Matrix Science Mascot Parser toolkit: Matrix Science Mascot Parser toolkit

Matrix Science Mascot Parser toolkit

Modules

  • Mascot results file module - To extract data from Mascot results files into other applications or to a relational database
  • Mascot configuration files module - To access the Mascot configuration files from a server or client application.
  • Mascot security and authentication module - For Mascot 2.1 and later server side applications only.
  • Mascot utilities and tools module - Miscellaneous tools for creating CDB files, zipping files, other file utilities and clustering.
  • Error handling and logging - for details on error handling and logging.
  • Quantitation analysis for Mascot Server and Distiller - for client and server applications.
  • Classes for calculating masses of peptides and fragments. - Classes for calculating masses of peptides and fragments.
  • Accessing a Mascot Server using HTTP - login, search submission and results retrieval are supported.

Installation

  • C++ toolkit installation
  • Java toolkit installation
  • Perl toolkit installation
  • Python toolkit installation
  • C# toolkit installation

Getting Started

  • License information for Mascot Parser
  • Getting started with Mascot Parser

Upgrading from previous versions

  • Release notes and version history
  • Updating from earlier versions of Mascot Parser

The following files are distributed with Mascot Parser.

The C++ files are categorised under directories named after each supported C++ compiler. The Perl module is supplied and installed with Mascot Server from version 2.0 onwards.

Directory | Files | Description
compiler/include | msparser.hpp and a number of other include files. | C++ headers; see C++ toolkit installation
compiler/lib | *.lib or *.a *.dll or *.so.1 | C++ library files; see C++ toolkit installation
compiler/example_cxx | *.cpp | C++ examples
doc | index.html Other html and javascript files | Help for use from a web browser
 | MascotParserUML.pdf | The UML diagram as a PDF (same as in the HTML help)
 | Developer Licence Agreement.pdf | Developer Licence Agreement as a PDF
example_csharp | *.cs | C# examples
example_java | *.java | Java examples
example_perl | *.pl | Perl examples
example_python | *.py | Python examples
java | msparser.dll or libmsparserj.so msparser.jar | Java library; see Java toolkit installation
perl516 (Linux only) perl518 (Linux only) perl520 (Linux only) perl522 (Linux only) perl524 perl526 perl528 perl530 perl532 perl534 (Linux only) perl536 (Linux only) | msparser.dll or msparser*.so msparser.pm | Perl module; see Perl toolkit installation
python36_and_later | _msparser.so or _msparser.pyd msparser.py | Python module; see Python toolkit installation
csharp | msparsercs.dll matrix_science.msparser.dll | C# module; see C# toolkit installation
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: License information for Mascot Parser

License information for Mascot Parser

The license agreement for Mascot Parser is located in a pdf file in the doc directory.

Mascot Parser uses a number of 3rd party libraries. The code for all of these libraries except the stdc++ libray for Linux is compiled into each .so, .dll, .a and .lib file, so there is no requirement for an application to link these separately. Any application that uses Mascot Parser must abide by the license for Mascot Parser and these components:

Library | Platforms
Xerces C++ XML Parser | All
libcurl - multiprotocol file transfer library | All Unix platforms - not Windows
Portable Hardware Locality (hwloc) | Linux only
libstdc++ | 64 bit Linux only
zlib | All
Regex Library | Windows only
Simplified Wrapper and Interface Generator (SWIG) | Perl, Java, Python and C# modules on all platforms
C Clustering library | All
OpenSSL | Linux only
SQLite | All
sqlpp11 | All
Date library (C++) | All
{fmt} | All

Xerces C++ XML Parser

The following text can be found at http://www.apache.org/licenses/LICENSE-1.1

/* ====================================================================
   The Apache Software License, Version 1.1

   Copyright (c) 2000 The Apache Software Foundation.  All rights
   reserved.

   Redistribution and use in source and binary forms, with or without
   modification, are permitted provided that the following conditions
   are met:

   1. Redistributions of source code must retain the above copyright
      notice, this list of conditions and the following disclaimer.

   2. Redistributions in binary form must reproduce the above copyright
      notice, this list of conditions and the following disclaimer in
      the documentation and/or other materials provided with the
      distribution.

   3. The end-user documentation included with the redistribution,
      if any, must include the following acknowledgment:
         "This product includes software developed by the
          Apache Software Foundation (http://www.apache.org/)."
      Alternately, this acknowledgment may appear in the software itself,
      if and wherever such third-party acknowledgments normally appear.

   4. The names "Apache" and "Apache Software Foundation" must
      not be used to endorse or promote products derived from this
      software without prior written permission. For written
      permission, please contact apach.nosp@m.e@ap.nosp@m.ache..nosp@m.org.

   5. Products derived from this software may not be called "Apache",
      nor may "Apache" appear in their name, without prior written
      permission of the Apache Software Foundation.

   THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
   WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
   OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
   DISCLAIMED.  IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR
   ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
   SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
   LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
   USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
   ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
   OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
   OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
   SUCH DAMAGE.
   ====================================================================

   This software consists of voluntary contributions made by many
   individuals on behalf of the Apache Software Foundation.  For more
   information on the Apache Software Foundation, please see
   http://www.apache.org/.

   Portions of this software are based upon public domain software
   originally written at the National Center for Supercomputing Applications,
   University of Illinois, Urbana-Champaign.
 */

libcurl - multiprotocol file transfer library

The following text can be found at http://curl.haxx.se/docs/copyright.html

OPYRIGHT AND PERMISSION NOTICE

Copyright (c) 1996 - 2007, Daniel Stenberg, danie.nosp@m.l@ha.nosp@m.xx.se.

All rights reserved.

Permission to use, copy, modify, and distribute this software for any purpose
with or without fee is hereby granted, provided that the above copyright
notice and this permission notice appear in all copies.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN
NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not
be used in advertising or otherwise to promote the sale, use or other dealings
in this Software without prior written authorization of the copyright holder.

Portable Hardware Locality (hwloc)

https://www.open-mpi.org/projects/hwloc/license.php

Copyright &#169; 2004-2006 The Trustees of Indiana University and Indiana University Research and Technology Corporation.  All rights reserved.
Copyright &#169; 2004-2005 The University of Tennessee and The University of Tennessee Research Foundation.  All rights reserved.
Copyright &#169; 2004-2005 High Performance Computing Center Stuttgart, University of Stuttgart.  All rights reserved.
Copyright &#169; 2004-2005 The Regents of the University of California. All rights reserved.
Copyright &#169; 2009      CNRS
Copyright &#169; 2009-2016 Inria.  All rights reserved.
Copyright &#169; 2009-2015 Université Bordeaux
Copyright &#169; 2009-2015 Cisco Systems, Inc.  All rights reserved.
Copyright &#169; 2009-2012 Oracle and/or its affiliates.  All rights reserved.
Copyright &#169; 2010      IBM
Copyright &#169; 2010      Jirka Hladky
Copyright &#169; 2012      Aleksej Saushev, The NetBSD Foundation
Copyright &#169; 2012      Blue Brain Project, EPFL. All rights reserved.
Copyright &#169; 2013-2014 University of Wisconsin-La Crosse. All rights reserved.
Copyright &#169; 2015      Research Organization for Information Science and Technology (RIST). All rights reserved.
Copyright &#169; 2015-2016 Intel, Inc.  All rights reserved.
See COPYING in top-level directory.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:
1. Redistributions of source code must retain the above copyright
   notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright
   notice, this list of conditions and the following disclaimer in the
   documentation and/or other materials provided with the distribution.
3. The name of the author may not be used to endorse or promote products
   derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

libstdc++

The following text can be found at http://gcc.gnu.org/onlinedocs/libstdc++/17_intro/license.html

Licenses for the Library

There are two licenses affecting GNU libstdc++: one for the code, and one for the documentation. Here we will describe both of them, and try to answer some of the widespread questions. If you have more questions, ask the FSF or the gcc mailing list; the person writing this page is a programmer, not a lawyer.

The Code: Runtime GPL

The source code of libstdc++ is distributed under version 2 of the GNU General Public License, with the so-called "runtime exception," as follows (or see any header or implementation file):

   As a special exception, you may use this file as part of a free software
   library without restriction.  Specifically, if other files instantiate
   templates or use macros or inline functions from this file, or you compile
   this file and link it with other files to produce an executable, this
   file does not by itself cause the resulting executable to be covered by
   the GNU General Public License.  This exception does not however
   invalidate any other reasons why the executable file might be covered by
   the GNU General Public License.

Hopefully that text is self-explanatory. If it isn't, you need to speak to your lawyer, or the Free Software Foundation.

Q: So any program which uses libstdc++ falls under the GPL? A: No. The special exception permits use of the library in proprietary applications.

Q: How is that different from the GNU {Lesser,Library} GPL? A: The LGPL requires that users be able to replace the LGPL code with a modified version; this is trivial if the library in question is a C shared library. But there's no way to make that work with C++, where much of the library consists of inline functions and templates, which are expanded inside the code that uses the library. So to allow people to replace the library code, someone using the library would have to distribute their own source, rendering the LGPL equivalent to the GPL.

Q: I see. So, what restrictions are there on programs that use the library? A: None. We encourage such programs to be released as open source, but we won't punish you or sue you if you choose otherwise. The Docs: GPL, FDL

The documentation shipped with the library and made available over the web, excluding the pages generated from source comments, are copyrighted by the Free Software Foundation, and placed under the GNU Free Documentation License version 1.1. There are no Front-Cover Texts, no Back-Cover Texts, and no Invariant Sections.

For documentation generated by doxygen or other automated tools via processing source code comments and markup, the original source code license applies to the generated files. Thus, the doxygen documents are licensed GPL.

If you plan on making copies of the documentation, please let us know. We can probably offer suggestions.

Comments and suggestions about this page are welcome, and may be sent to the libstdc++ mailing list. Comments or questions about the licenses themselves are also welcome, and should be directed to the GCC list as descibed above.

zlib

The following text can be found at http://www.zlib.net/zlib_license.html

 zlib License

/* zlib.h -- interface of the 'zlib' general purpose compression library
  version 1.2.3, July 18th, 2005

  Copyright (C) 1995-2005 Jean-loup Gailly and Mark Adler

  This software is provided 'as-is', without any express or implied
  warranty.  In no event will the authors be held liable for any damages
  arising from the use of this software.

  Permission is granted to anyone to use this software for any purpose,
  including commercial applications, and to alter it and redistribute it
  freely, subject to the following restrictions:

  1. The origin of this software must not be misrepresented; you must not
     claim that you wrote the original software. If you use this software
     in a product, an acknowledgment in the product documentation would be
     appreciated but is not required.
  2. Altered source versions must be plainly marked as such, and must not be
     misrepresented as being the original software.
  3. This notice may not be removed or altered from any source distribution.

  Jean-loup Gailly jloup.nosp@m.@gzi.nosp@m.p.org
  Mark Adler madle.nosp@m.r@al.nosp@m.umni..nosp@m.calt.nosp@m.ech.e.nosp@m.du

*/

Regex Library

Copyright 1992, 1993, 1994 Henry Spencer.  All rights reserved.
This software is not subject to any license of the American Telephone
and Telegraph Company or of the Regents of the University of California.

Permission is granted to anyone to use this software for any purpose on
any computer system, and to alter it and redistribute it, subject
to the following restrictions:

1. The author is not responsible for the consequences of use of this
   software, no matter how awful, even if they arise from flaws in it.

2. The origin of this software must not be misrepresented, either by
   explicit claim or by omission.  Since few users ever read sources,
   credits must appear in the documentation.

3. Altered versions must be plainly marked as such, and must not be
   misrepresented as being the original software.  Since few users
   ever read sources, credits must appear in the documentation.

4. This notice may not be removed or altered.

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
/*-
   Copyright (c) 1994
      The Regents of the University of California.  All rights reserved.

   Redistribution and use in source and binary forms, with or without
   modification, are permitted provided that the following conditions
   are met:
   1. Redistributions of source code must retain the above copyright
      notice, this list of conditions and the following disclaimer.
   2. Redistributions in binary form must reproduce the above copyright
      notice, this list of conditions and the following disclaimer in the
      documentation and/or other materials provided with the distribution.
   3. All advertising materials mentioning features or use of this software
      must display the following acknowledgement:
      This product includes software developed by the University of
      California, Berkeley and its contributors.
   4. Neither the name of the University nor the names of its contributors
      may be used to endorse or promote products derived from this software
      without specific prior written permission.

   THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
   ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
   IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
   ARE DISCLAIMED.  IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
   FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
   DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
   OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
   HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
   LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
   OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
   SUCH DAMAGE.

      @(#)COPYRIGHT	8.1 (Berkeley) 3/16/94
 */

Simplified Wrapper and Interface Generator (SWIG)

The following text can be found at http://swig.sourceforge.net/copyright.html

 Simplified Wrapper and Interface Generator  (SWIG)

 SWIG is distributed under the following terms:
 =================================================

 I.

 This software includes contributions that are Copyright (c) 1998-2002
 University of Chicago.
 All rights reserved.

 Redistribution and use in source and binary forms, with or without
 modification, are permitted provided that the following conditions are
 met:

 Redistributions of source code must retain the above copyright notice,
 this list of conditions and the following disclaimer.  Redistributions
 in binary form must reproduce the above copyright notice, this list of
 conditions and the following disclaimer in the documentation and/or
 other materials provided with the distribution.  Neither the name of
 the University of Chicago nor the names of its contributors may be
 used to endorse or promote products derived from this software without
 specific prior written permission.

 THIS SOFTWARE IS PROVIDED BY THE UNIVERSITY OF CHICAGO AND CONTRIBUTORS
 "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
 LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
 PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE UNIVERSITY OF
 CHICAGO OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
 SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
 TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

 II.

 Copyright (c) 1995-1998
 The University of Utah and the Regents of the University of California
 All Rights Reserved

 Permission is hereby granted, without written agreement and without
 license or royalty fees, to use, copy, modify, and distribute this
 software and its documentation for any purpose, provided that
 (1) The above copyright notice and the following two paragraphs
 appear in all copies of the source code and (2) redistributions
 including binaries reproduces these notices in the supporting
 documentation.   Substantial modifications to this software may be
 copyrighted by their authors and need not follow the licensing terms
 described here, provided that the new terms are clearly indicated in
 all files where they apply.

 IN NO EVENT SHALL THE AUTHOR, THE UNIVERSITY OF CALIFORNIA, THE
 UNIVERSITY OF UTAH OR DISTRIBUTORS OF THIS SOFTWARE BE LIABLE TO ANY
 PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL
 DAMAGES ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS DOCUMENTATION,
 EVEN IF THE AUTHORS OR ANY OF THE ABOVE PARTIES HAVE BEEN ADVISED OF
 THE POSSIBILITY OF SUCH DAMAGE.

 THE AUTHOR, THE UNIVERSITY OF CALIFORNIA, AND THE UNIVERSITY OF UTAH
 SPECIFICALLY DISCLAIM ANY WARRANTIES,INCLUDING, BUT NOT LIMITED TO,
 THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 PURPOSE. THE SOFTWARE PROVIDED HEREUNDER IS ON AN "AS IS" BASIS, AND
 THE AUTHORS AND DISTRIBUTORS HAVE NO OBLIGATION TO PROVIDE MAINTENANCE,
 SUPPORT, UPDATES, ENHANCEMENTS, OR MODIFICATIONS.

C Clustering library

Version 1.45 of the library was downloaded from here: http://bonsai.hgc.jp/~mdehoon/software/cluster/

where the manual is also available.

The following text appears at the top of the single 'c' source file that is used in Mascot Parser:

/* The C clustering library.
   Copyright (C) 2002 Michiel Jan Laurens de Hoon.

   This library was written at the Laboratory of DNA Information Analysis,
   Human Genome Center, Institute of Medical Science, University of Tokyo,
   4-6-1 Shirokanedai, Minato-ku, Tokyo 108-8639, Japan.
   Contact: mdehoon 'AT' gsc.riken.jp

   Permission to use, copy, modify, and distribute this software and its
   documentation with or without modifications and for any purpose and
   without fee is hereby granted, provided that any copyright notices
   appear in all copies and that both those copyright notices and this
   permission notice appear in supporting documentation, and that the
   names of the contributors or copyright holders not be used in
   advertising or publicity pertaining to distribution of the software
   without specific prior permission.

   THE CONTRIBUTORS AND COPYRIGHT HOLDERS OF THIS SOFTWARE DISCLAIM ALL
   WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED
   WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL THE
   CONTRIBUTORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY SPECIAL, INDIRECT
   OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
   OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE
   OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE
   OR PERFORMANCE OF THIS SOFTWARE.

 */

OpenSSL

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit.

  OpenSSL License
  ---------------
/* ====================================================================
   Copyright (c) 1998-2007 The OpenSSL Project.  All rights reserved.

   Redistribution and use in source and binary forms, with or without
   modification, are permitted provided that the following conditions
   are met:

   1. Redistributions of source code must retain the above copyright
      notice, this list of conditions and the following disclaimer.

   2. Redistributions in binary form must reproduce the above copyright
      notice, this list of conditions and the following disclaimer in
      the documentation and/or other materials provided with the
      distribution.

   3. All advertising materials mentioning features or use of this
      software must display the following acknowledgment:
      "This product includes software developed by the OpenSSL Project
      for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

   4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to
      endorse or promote products derived from this software without
      prior written permission. For written permission, please contact
      opens.nosp@m.sl-c.nosp@m.ore@o.nosp@m.pens.nosp@m.sl.or.nosp@m.g.

   5. Products derived from this software may not be called "OpenSSL"
      nor may "OpenSSL" appear in their names without prior written
      permission of the OpenSSL Project.

   6. Redistributions of any form whatsoever must retain the following
      acknowledgment:
      "This product includes software developed by the OpenSSL Project
      for use in the OpenSSL Toolkit (http://www.openssl.org/)"

   THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY
   EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
   IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
   PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE OpenSSL PROJECT OR
   ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
   SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
   NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
   LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
   HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
   STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
   ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
   OF THE POSSIBILITY OF SUCH DAMAGE.
   ====================================================================

   This product includes cryptographic software written by Eric Young
   (eay@c.nosp@m.rypt.nosp@m.soft..nosp@m.com).  This product includes software written by Tim
   Hudson (tjh@c.nosp@m.rypt.nosp@m.soft..nosp@m.com).

 */
 Original SSLeay License
 -----------------------
/* Copyright (C) 1995-1998 Eric Young (eay@c.nosp@m.rypt.nosp@m.soft..nosp@m.com)
   All rights reserved.

   This package is an SSL implementation written
   by Eric Young (eay@c.nosp@m.rypt.nosp@m.soft..nosp@m.com).
   The implementation was written so as to conform with Netscapes SSL.

   This library is free for commercial and non-commercial use as long as
   the following conditions are aheared to.  The following conditions
   apply to all code found in this distribution, be it the RC4, RSA,
   lhash, DES, etc., code; not just the SSL code.  The SSL documentation
   included with this distribution is covered by the same copyright terms
   except that the holder is Tim Hudson (tjh@c.nosp@m.rypt.nosp@m.soft..nosp@m.com).

   Copyright remains Eric Young's, and as such any Copyright notices in
   the code are not to be removed.
   If this package is used in a product, Eric Young should be given attribution
   as the author of the parts of the library used.
   This can be in the form of a textual message at program startup or
   in documentation (online or textual) provided with the package.

   Redistribution and use in source and binary forms, with or without
   modification, are permitted provided that the following conditions
   are met:
   1. Redistributions of source code must retain the copyright
      notice, this list of conditions and the following disclaimer.
   2. Redistributions in binary form must reproduce the above copyright
      notice, this list of conditions and the following disclaimer in the
      documentation and/or other materials provided with the distribution.
   3. All advertising materials mentioning features or use of this software
      must display the following acknowledgement:
      "This product includes cryptographic software written by
       Eric Young (eay@cryptsoft.com)"
      The word 'cryptographic' can be left out if the rouines from the library
      being used are not cryptographic related :-).
   4. If you include any Windows specific code (or a derivative thereof) from
      the apps directory (application code) you must include an acknowledgement:
      "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

   THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND
   ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
   IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
   ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
   FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
   DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
   OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
   HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
   LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
   OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
   SUCH DAMAGE.

   The licence and distribution terms for any publically available version or
   derivative of this code cannot be changed.  i.e. this code cannot simply be
   copied and put under another distribution licence
   [including the GNU Public Licence.]
 */

SQLite

The SQLite 3 amalgamation is included in Mascot Parser. SQLite is in the public domain: https://sqlite.org/copyright.html

Briefly, the relevant items from SQLite copyright page are:

  All of the code and documentation in SQLite has been dedicated to
  the public domain by the authors. All code authors, and
  representatives of the companies they work for, have signed
  affidavits dedicating their contributions to the public domain and
  originals of those signed affidavits are stored in a firesafe at the
  main offices of Hwaci. All contributors are citizens of countries
  that allow creative works to be dedicated into the public domain.
  Anyone is free to copy, modify, publish, use, compile, sell, or
  distribute the original SQLite code, either in source code form or
  as a compiled binary, for any purpose, commercial or non-commercial,
  and by any means.

  SQLite is in the public domain and does not require a license.

sqlpp11

sqlpp11 is a type safe C++ wrapper around SQLite, downloaded from: https://github.com/rbock/sqlpp11

Copyright (c) 2013-2016, Roland Bock
All rights reserved.

Redistribution and use in source and binary forms, with or without modification,
are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this
   list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this
   list of conditions and the following disclaimer in the documentation and/or
   other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Date library (C++)

A date and time library based on the C++11/14/17 chrono header, downloaded from: https://github.com/HowardHinnant/date

The source code in this project is released using the MIT License. There is no
global license for the project because each file is licensed individually with
different author names and/or dates.

If you contribute to this project, please add your name to the license of each
file you modify.  If you have already contributed to this project and forgot to
add your name to the license, please feel free to submit a new P/R to add your
name to the license in each file you modified.

For convenience, here is a copy of the MIT license found in each file except
without author names or dates:

The MIT License (MIT)

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.

{fmt}

{fmt} is an open-source formatting library providing a fast and safe alternative to C stdio and C++ iostreams.

https://github.com/fmtlib/fmt

Copyright (c) 2012 - present, Victor Zverovich and {fmt} contributors

Permission is hereby granted, free of charge, to any person obtaining
a copy of this software and associated documentation files (the
"Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to
the following conditions:

The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

--- Optional exception to the license ---

As an exception, if, as a result of your compiling your source code, portions
of this Software are embedded into a machine-executable object form of such
source code, you may redistribute such embedded portions in such object form
without including the above copyright and permission notices.
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Release notes and version history

Release notes and version history

Version 3.0.0 - released with Mascot Server 3.0.0

ID | Title
11568 | Remove references to Integra and Insight in Mascot Security. Mascot Insight is no longer available.
12892 | Zero value for Observed in unassigned list for query whose only match is a chimeric duplicate
13106 | Add new method ms_inputquery::getQueryNumber().
13447 | Add ms_inputquery::getPeakCharge() method
13480 | get_ms_mascotresults_params() defaults to old protein grouping for sequence tag searches
13531 | Reduce the time spent in caching search results
13678 | Support new .msr file format
14068 | Remove directory gnu/7.2.0 from Linux shipper image. The directory duplicated the contents of the gnu/lib directory.
14109 | MascotFileProcessingThreads set to -1 should automatically use all possible threads. The default value is 4.
14111 | Rename ms_mascotresfile to ms_mascotresfile_dat. Only the class name changes. The rest of the methods and class members are identical to Parser 2.8. Please see the migration instructions in Upgrading to Mascot Parser 3.0.x from 2.8.x.
14121 | New API for .msr results files, and implement parsing and interpretation of MSR v0.9 files. Mascot Search Results (MSR) is a new format in Mascot Server 3.0. MSR v0.9 was an intermediate format leading up to MSR v1.0.
14127 | Support for Visual Studio 2012 and 2013 has now been dropped. This change only affects the statically linked msparser.lib. If you are still using these compilers, please link dynamically against msparser.dll.
14157 | Undefined behaviour in ms_fdr_query_processor::getThresholdForFDR() when comparing pointer address to integer zero. Fixed due to a compiler warning. The fault made no observable difference to the algorithm.
14179 | MinGW instructions have been reviewed and tested using MinGW GCC 12.1.
14192 | C++ shippers on Linux are now compiled width GCC 5.5.0, and MinGW on Windows with GCC 7.1.0. If you are using the Parser static C++ library, please upgrade your compiler to GCC 5.5 or newer (Linux) or GCC 7.1 or newer (MinGW). If you are using the shared library, earlier compiler versions may be compatible.
14208 | ms_searchparams::getVarModsNeutralLosses() doesn't return satellite NLs.
14217 | Failing to read query-level mods NL string, fault introduced in Parser 2.7.0.
14240 | New mascot.dat option SearchSubmitOutputFormat. The setting is used by the Mascot Server web-based search form (search_form.pl). The setting defaults to 'msr', which is the new file format in Mascot Server 3.0.
14247 | New mascot.dat option to diagnose MSR generation.
14257 | Move Quantlib/Distiller time alignment code to Parser and save/load in cdb/xml
14262 | TMTpro 16-plex and 18-plex mod groups should be required=false
14274 | Methods and classes not wrapped properly by SWIG for Perl, Python, Java and C#
14285 | Implement New Imputation Methods in Parser. ms_imputation is experimental in Parser 3.0 and may be changed in a future release.
14293 | Further thread safety issues : matrix_science::ms_mascotresults::getPeptideThreshold. This method is now safe to call from multiple threads.
14315 | Add getStage method to ms_http_client_search
14320 | Update Doxygen to version 1.9.6.
14323 | ms_ms1quantitation should allow a search without a quantitation method to load replicate or average results.
14337 | Roll-up of changes to API doc and release notes for 3.0
14361 | ms_inputquery::getPeakMass(): Ions2 and Ions3 lines are missing the first peak. Ions2 and Ions3 lines in .dat format contain data entered with the rarely used ions(b-...) and ions(y-...) qualifiers. ms_inputquery::getPeakMass() and getPeakIntensity() accidentally skipped the first mass in the list.
14377 | getQmatch() returns INT_MAX if called with non-existent query number, should return 0.
14389 | Implement schema changes for MSR v0.99; implement MSR parsing/processing for v0.99; fix bugs in MSR parsing/processing; implement schema changes for SDB v0.99; implement SDB writing/processing for v0.99; fix bugs in SDB parsing/processing; rename headers
14392 | Add MSR files to the Parser test harness
14422 | Support MSR file download in new method ms_http_client_search::downloadResultsFileMSR()
14432 | Add streaming decompression to ms_zip
14433 | Parser should give a warning if reading a file from future version of Mascot
14441 | New Parser class for retrieving MSR file in .dat format
14445 | New option AlwaysCreateDat28ResultsFile. The setting is used by the Mascot Server search engine (nph-mascot.exe). The setting defaults to 0 (false) – Mascot Server 3.0 and later default to writing search results in MSR format.
14481 | All methods of ms_inputquery should be const.
14483 | Documentation for ms_inputquery::getNumUsed() was incorrect. This method always returns 0.
14544 | Change ms_modfile private member std::auto_ptr<ms_masses> to std::unique_ptr
14549 | Display emPAI in integrated error tolerant searches
14551 | ms_searchparams::getLIBRARY_SEARCH() returns -1 when LIBRARY_SEARCH=1 in search params
14553 | Remove ms_mascotoptions::getSeparateLockMem()
14554 | Compile SWIG modules with GCC11 and VS2019 (Perl, Python, C#, Java)
14558 | Update SWIG to 4.2.1
14571 | Unstable order of sameset accessions in integrated SL searches
14577 | Add wrapper for Perl 5.36 on Linux
14578 | Add new method ms_mascotresfilebase::getSLExecCommand()
14588 | Add accessor method ms_ms2quantitation::getPeptideSummary()
14590 | Update ms_ms1quantitation::mergeQuantitationResults() to support MSR
14636 | ms_fileutilities::getLastModificationTime() fails on Windows if the file has been opened without shared read access
14637 | Drop version-specific Python libraries and ship a single 'universal' library
14647

New argument to ms_mascotresfilebase::setPercolatorFeatures(): a vector of ML adapter parameters. The argument is optional and defaults to empty vector.

A new argument is also introduced for ms_mascotresfilebase::staticGetPercolatorFileNames(). The new argument is not optional, so if you use staticGetPercolatorFileNames(), this is a breaking change. Please pass an empty vector as argument.

14649 | ms_mascotresfilebase constructor, if XMLschemaDirectory is empty string, treat it the same as null pointer
14665 | Add a ms_modification::getClassification() method
14673 | ms_linker_site_vector fails to initialise alpha and beta peptide lengths to zero
14674 | Add quantitation option to choose type of time alignment
14692 | Internal shipper for Perl 5.38 built with VS2019 and GCC 11
14707 | ms_datfile::updateForInstaller(), replace ResultsCache with a default
14748 | New methods ms_searchparams::getPERCOLATE() and ms_searchparams::getML_ADAPTER_PARAM()
14749 | When setting Percolator flag in ms_mascotresfilebase::get_ms_mascotresults_params(), check the new search param PERCOLATE, then mascot.dat options
14750 | ms_mascotresfilebase::get_ms_mascotresults_params() treats DECOY=-1 as DECOY=1 when deciding whether to set MSPEPSUM_PERCOLATOR
14752 | ms_mascotresfilebase::get_ms_mascotresults_params() should not set MSPEPSUM_PERCOLATOR for error tolerant search
14766 | Update unimod.xml and unimod_xl.xml to the latest versions for 3.0
14775 | Python msparser library cannot be used with xgboost or tensorflow libraries
14776 | ms_datfile::updateForInstaller(), change SplitNumberOfQueries from 1000 to 2000
14777 | New option CreateLegacyModAndSubstitutionFiles
14778 | New option AlwaysEnableAutoDecoySearch
14785 | ms_datfile::updateForInstaller(), set PercolatorUseRT to 0
14789 | New mascot.dat option SearchSubmitAcceptedFileTypes
14795 | ms_ms1quant_time_align::getRToffset() looks in wrong part of array in some cases
14797 | LabelAll option is obsolete
14811 | Quantitation method for TMT 32/35-plex
14820 | Default to sequence FDR in ms_mascotresfilebase::get_ms_mascotresults_params()
14821 | ms_ms1quant_time_align::getRToffset() code is not treating the "to" consensus and "from" consensus properly
14833 | Change behavior of ms_mascotresfilebase::get_ms_mascotresults_params() to set the target FDR
14844 | Add new method ms_masses::saveToString()

Version 2.8.1 - released with Mascot Server 2.8.1

ID | Title
13751 | Add shippers for Python 3.7, 3.8, 3.9
13766 | 502.2 - Bad Gateway on opening search results, caused by segfault while reading empty protein description
13864 | Sorting unassigned list fails if filtering is active, caused by findPeptides() always returning results in query order
13927 | Start and end of quantitation match range can be reversed causing out of memory
13961 | Error message 539 lacks information - relevant taxonomy node files now added to error message
13962 | Dodgy protein inference when two interlinked proteins have the same very short beta peptide
13963 | Add TMTpro 18plex quant method
13989 | Xml configuration files should not be written in place
14000 | Increase limit of taxonomy choice include/exclude line length - new limit is 32kB

Version 2.8.0 - released with Mascot Server 2.8

ID | Title
12447 | Calculate an expect value for error tolerant matches. See Error tolerant searches.
13357 | End of 32-bit Parser on Windows. Parser 2.8 and later are now 64-bit only on all platforms.
13378 | Section title "Using STL classes" should mention vectord, vectori, VectorString
13406 | getThresholdForFDRAboveIdentity() doesn't always work when Percolator is enabled
13514 | Parser 2.7.0 C# is built with VS2015, not VS2012
13604 | New setting for number of input file parsing threads
13633 | updateForInstaller: replace PercolatorFeatures with new feature set
13634 | New options PercolatorTargetRankScoreThreshold and PercolatorTargetRankRelativeThreshold
13639 | Add static and shared libraries for VS2017. Parser 2.8 ships with libraries compiled for VS2012, VS2013, VS2015 and VS2017.
13663 | ms_aahelper never returns internal ions over 700 Da
13673 | ms_proteinsummary needs to check inference flags
13696 | New parameter for ms-createpip.exe multithreading
13715 | Only return false from getThresholdForFDRAboveHomology() if closest FDR is not within a factor of 2 of target FDR
13716 | Make ms_searchparams thread safe and more efficient
13726 | Logging and error handling documentation is mostly missing
13730 | Allow zero child elements in mxm:accessions, mxm:filters, mxm:scope, mxm:settings
13746 | Remove ICC2016 shippers. The GCC 4.8.5 static and shared libraries now shipped with Parser can be used with both GCC 4.8.5 and later, and Intel® Compiler 2016 and later. See C++ toolkit installation on Unix.
13759 | New ms_peptidesummary parameters: target FDR and FDR type. See Target-decoy searches and false discovery rate.
13763 | Add willCreateCache methods which take a ms_mascotresults_params argument
13769 | Update unimod.xml and unimod_xl.xml for 2.8.0
13806 | Target FDR algorithm: maximise the number of target matches if FDR is 0%
13808 | Update element descriptions in crosslinking schema for the crosslinking configuration editor
13818 | If alpha and beta are in different proteins, one of them is not assigned to any protein
13848 | Add Parser targets for Perl 5.32 and 5.34 (Linux) and Perl 5.32 (Windows).

Version 2.7.1 - released with Mascot Distiller 2.8

ID | Title
11666 | Add MS1 quantitation result reading to msparser
12409 | ms_ms1quantitation needs to handle normalisation
13548 | ms_http_client_session::submitSearch should be able to use -batch option
13556 | Schema changes required for Mascot Distiller 2.8
13607 | Multiple issues with ms_quant_helper::isPeptideQuantifiable for MS1 based quantitation
13614 | MS1 quantitation, XML output, Hit ratio set to invalid when it should be valid
13667 | ms_quant_helper VarModStringToVector doesn't handle letters correctly
13686 | ms_xic is not thread safe
13702 | Memory leak in mshandle
13725 | HTTP authentication fails if POST request redirects to GET (e.g. search with -batch mode)
13743 | More problems with ms_quant_helper
13760 | Missing and additional protein ratios for Precursor quantitation when mass-time-match is enabled

Version 2.7.0 - released with Mascot Server 2.7

ID | Title
10427 | ms_aahelper needs argument to generate mass values for all neutral losses
10714 | Parser error handling is not thread safe
10752 | Satellite ions should not be restricted to fragments containing R
10793 | findPeptides() with FT_PEPTIDE_EXP_MZ and FC_SEARCH_ALL_RANKS returns all ranks with no match
11802 | Python example script emits "query out of range" errors and crashes
12100 | single underscore character identifier is #defined in des.h
12326 | Add switch to mascot.dat to over-ride asynchronous search submission (batch mode)
12493 | Add an internal interface for fast conversions between strings and numbers
12496 | Disallow creating a database whose name differs from an existing one only by case
12624 | Use cache files from 2.4 and 2.5 in test harness to ensure backwards compatibility won't break
12672 | ms_mascotoptions setters should check the limits or be removed
12753 | ms_tinycdb openIndexFile uses string comparison on gmt timestamps to check file dates
12808 | ms_umod_configfile::findModification should be optimised with a lookup table
12820 | Add a clear() method to ms_progress_info
12832 | Expand parser test harness with files combining, mod search and ambiguity groups
12857 | Potential crash when sorting peptides
12860 | willCreateCache adds errors to the ms_mascotresfile object, resulting in duplicates
12863 | Search modification by name with findPeptides returns only one value on Windows
12888 | Add a documentation page for the FDR procedure
12891 | Test harness scripts should be converted to python
12895 | Add a utility function to compare XML files
12902 | Modification statistics for error tolerant search can be highly misleading
12913 | Revert to just saving rank 1 in percolator pip file
12921 | Add PSM and sequences used for ID to proteinHit element of quant XML export
12924 | Peptide summary cache file name is different between master_results and ms-searchcontrol
12932 | Support for Visual Studio 2005, 2008 and 2010 has now been dropped.
12959

Added XML export to ms_ms2quantitation and cdb file export and import to record user protein-peptide ratio selections. The following methods have been renamed and moved to ms_quantitation from ms_ms1quantitation: addHeaderInfo renamed to addHeaderField, addRawFileInfo renamed to addRawFileField, clearHeaderInfo renamed to clearHeaderFields and clearRawFileInfo renamed to clearRawFileFields.

For examples, see: ms_ms2quantitation::saveXmlFile, ms_ms2quantitation::saveCdbFile, ms_ms2quantitation::loadCdbFile, ms_ms2quantitation::loadCdbFiles, ms_quantitation::addHeaderField, ms_quantitation::clearHeaderFields, ms_quantitation::addRawFileField and ms_quantitation::clearRawFileFields

12936 | Report of Error tolerant search does not display all matches when None is selected
12937 | Update from SWIG 2.0.12 to SWIG 3.0.12 for ALL languages supported by Parser
12950 | Compile Parser with GCC 4.8.5
12951 | Support for GCC 4.1 and Intel Parallel Studio XE 2013 has now been dropped. Static libraries on Linux are compiled with GCC 4.8.5 and Intel Parallel Studio XE 2016. Support for 32-bit Linux has been dropped.
12977 Support for Perl 5.8 to Perl 5.14 has been dropped on Linux. Support for Perl 5.28 and 5.30 has been added on Linux.
Support for Perl 5.8 to Perl 5.16 has been dropped on Windows. Support for Perl 5.24, 5.26, 5.28 and 5.30 has been added on Windows.
12990 | Logging: Improvements for ms_loggingmonitor required including better documentation
13020 | I don't believe PSM and PepSeq counts for Percolated results
13029 | Add ActivePerl 5.24, 5.26, 5.28, 5.30 build targets on Linux
13033 | .MSP File Format Issues (Was Error message text for ERR_MSP_NIST_MSP_NO_SPECTRA is misleading)
13047 | Crosslinking changes for protein inference and Parser results file API
13048 | Why are a third of the tests slower on Windows compared to Linux?
13101 | Add support for Python 3.6
13108 | .MSP File Format Issues #2
13122 | Mascot Server reporters error with ms-ms data when variable reporter ion modifications are selected
13124 | Segfault when caching an iTRAQ 4-plex file with variable mod group
13200 | New ms_peptidesummary constructor parameter: minimum number of significant unique sequences
13203 | Make ms_mascotresfile more const
13230 | ms_mascotresfile::appendResfile() generates lots of XML errors unless used on Mascot Server
13234 | Crosslinking method definition API and class structure
13241 | Description of getMaxPepModArrangements method in the documentation is confusing
13243 | Update unimod.xml to the latest one
13268 | ms_peptidesummary::isDataCached() returns false for BUGFIX_12740
13276 | ms_mascotresfile::getMasses() sets electron mass to 0.0 for results files from 1.9 and earlier
13278 | ms_aahelper must support ET and library mods
13284 | DEFAULT_MINPEPLENINPEPSUMMARY should be 7
13288 | ms_fragment needs a constructor for precursor NL peaks
13294 | Replace Numerical Recipes code with ALGLIB
13301 | Add flanking residues to the distiller xml MS1 quantitation results export
13310 | Peptide without required fixed mod for Reporter quant incorrectly has quant ratios
13312 | Add new option in ms_mascotoptions for suppressing PIP file creation during the search
13315 | Review default crosslinking methods in crosslinking.xml
13324 | New method ms_mascotresults::getDiscoveredLocalModDeltas(), and output order of getDiscoveredErrTolModDeltas() is ambiguous
13409 | ms_peptide::getIonsScore() and ms_mascoresults::getIonsScore() return different values with same args.
13437

Add Options: DechargeFragmentPeaks

Version 2.6.2 - released with Mascot Server 2.6.2

ID | Title
10731 | ms_processors produces bogus results for more than 64 logical CPUs
12944 | Last pretty rank 2 peptide incorrectly assigned to a protein in ms_peptidesummary cache file, caused by dangerous map deletion during iteration. Occasional exception thrown in debug mode.
13064 | New option UseHTTPProxyForHTTPS available from ms_mascotoptions::isUseHTTPProxyForHTTPS and ms_connection_settings::isUseHTTPProxyForHTTPS

Version 2.6.1 - released with Mascot Server 2.6.1

ID | Title
12276 | Documentation changes for schema paths with spaces. See, for example: ms_distiller_data::loadXmlFile .
12538 | Performance improvements when expanding proteins etc. in a 3GB results file. Used to take several minutes with some files.
12606 | The rank argument of ms_mascotresults::getHomologyThreshold has been changed from an int to an enum.
12642 | Add functionality to allow a specified range of spectra in an MSP file to be exported/saved. Additional parameters for ms_spectral_lib_file::saveAs.
12643

Add Parameter in the options section of mascot.dat to specify max number of spectra in a block. See ms_mascotoptions::getSpectraPerLibraryBlock.

12656 | Segmentation fault if you pass null as filename to ms_mascotresfile has been fixed.
12657 | New parameter in options section: number of peaks per 100 Da to choose from observed spectrum when creating library spectrum. See ms_mascotoptions::getCrawlerNumPeaksPer100Da.
12683 | User entered sensitivity count or significance threshold not working as expected for low scores in library-only search.
12689 | Fixed small memory leaks in ms_datfile, ms_mascotoptions and ms_processors.
12695 Supply additional schema files to support reading of Distiller xml files:
  • distiller_data_1.xsd
  • distiller_preferences_1.xsd
  • distiller_massdelta_1.xsd
  • distiller_master_project_1.xsd
  • distiller_quantitation_1.xsd
  • distiller_quantitation_2.xsd
12704 | New functions, ms_mascotresfile::getSLFragmentTolerance and ms_mascotresfile::getSLFragmentToleranceUnit for reading spectral library fragment tolerance.
12717 | Minor peptide sorting changes for duplicate peptides from spectral libraries.
12721 | Calling the function willCreateCache used to create the directory if it didn't exist.
12724 | Change default value for ms_mascotoptions::getPepSearchTool
12729 | When searching two or more spectral libraries mapped to the same reference, all the proteins reported are to the same SL in master_results_2
12731 | Added a new methods for annotating an MSP spectrum : ms_spectral_lib_entry::annotatePeaks and ms_spectral_lib_peak_list::annotatePeaks.
12737 | Fixed a segmentation fault if you call setReferenceFasta() before setToleranceInDa() or setToleranceInPPM()
12740 | With Percolator enabled get "Protein: KLH40_HUMAN has 1 cached, but 0 from the re-load"
12749 | Added support for std::wstring in C#

Version 2.6.0 - released with Mascot Server 2.6

ID | Title
11481 | Improvements to ms_peptidesummary::getThresholdForFDRAboveHomology and ms_peptidesummary::getThresholdForFDRAboveIdentity
12026 | More progress reports when building cache files for ms_peptidesummary with hundreds of thousands of protein hits.
12036 | Changes to ms_peptidesummary::findPeptides to support finding error tolerant modifications
12037 | Added ms_mascotoptions::getSpectrumViewerColourSchemeString
12053 | Improved examples for using ms_peptidesummary
12101 | Support for C# under Windows. See C# toolkit installation and Using the toolkit from Perl, Java, Python and C#
12121 | Mascot security doesn't allow multiple Fasta files to be specified in multiple groups. The ms_security_tasks::addTask function was just adding the first item in the array.
12172 | Implement protein inference for both database and library matches. See Spectral libraries
12173 | New mascot.dat configuration values for spectral libraries. Primarily adding a new DATABASE_TYPE
12174 | New mascot.dat Options for library search and compression tool configuration. See ms_mascotoptions::getCompressToolSL
12212 | Fixed index error in ms_mascotoptions::isDefaultTargetFDRPercentage
12222 | The module for HTTP Communication to a Mascot Server could not be used from Perl and the documentation needed improving.
12244 | Occasional failure to write session files in cases where the authentication type was IP address or computer name
12331 | Support for Perl 5.20 and 5.22 on Linux
12232 | Chimeric duplicate peptide matches missing from some queries in merged results
12244 | Occasional failure to write session files for IP address and computer name
12265 | matrix_science::ms_http_helper class needs to support https
12291 | Added a new matrix_science::ms_loggingmonitor class
12349 | Extend Percolator calculations to all ranks
12364 | Some Error tolerant search reports junk matches and average threshold score of 0
12391 | Added ms_mascotresults_params
12405 | mzIdentML export of fragment matches fails if ITOL is ppm
12408 | Add XML_SCHEMA_DIRECTORY option to ms_mascotresfile::getXMLschemaFilePath
12414 | Support Python 3
12428 | Create Python scripts for the Parser Documentation
12430 | Score distribution does not include ET matches and the values look wrong
12431 | Support Visual Studio 2015
12433 | matrix_science::ms_http_client now works properly on Linux
12438 | Supply Perl, Python and Java modules built using VS2012 rather VS2005/VS2008. See Installation on Windows, Python toolkit installation, Installation on Windows for details of Visual Studio Runtime Library requirements.
12448 | Cache file with missing quantitation if errors due to missing xsd file causes missing quantitation information
12456 | Added an additional bool parameter (addMissingResidueMasses)to the matrix_science::ms_masses constructor that takes a ms_umod_configfile parameter.
12458 | Inconsistent handling of whitespace in user parameters between cache and non-cache mode
12468 | Add ms_umod_modification::isSameAs comparison method and ms_umod_modification::getSpecificityBySiteAndPosition
12497 | New overloaded method ms_inputquery::getRetentionTimes for reading all rtinseconds values
12508 | New mascot.dat setting for ions score cutoff checkbox / edit box ms_mascotoptions::getDisplayNonSignificantMatches
12578 | Changes to updateForInstaller for Mascot Server 2.6
12604 | ms_inputquery fails to parse a peak list if it contains no colons

Version 2.5.2 - released with Mascot Server 2.5.1 and Mascot Insight 2.5.2

ID | Title
11333 | The default value returned by ms_mascotoptions::getPercolatorMinQueries is 100 and this is too low for when there are 15 features. Increased the value to 750.
11806 | Make getProteinRatio() return negative standard deviation, standard error and p-values when protein ratio type is weighted, and add a new interface to ms_protein_quant_ratio for querying the reason why the values are unavailable.
11825 | Performance improvements for ms_inputquery.
11856 | The function getNumDiscoveredErrTolMods filters peptides based on Ions score below a significance threshold. This was also being applied to the Error Tolerant peptides as well and so erroneously filtered out some error tolerant peptides and their modifications.
11858 | The Mascot Server Windows installer should now always set ForkForUnixApache to 0. If the IFLG_UPDATEAPACHEFORKOPT flag is set when calling updateForInstaller then the value passed in wst is ignored and setForkForUnixApache is always called with 'false'. This change is for Windows only.
11862 | Support filtering of peptides using decimal mass values as doubles rather than strings. See ms_mascotresults::findPeptides.
11863 | Use correct Xerces encoding transcoder when loading and saving xml files. Supports UTF-8 correctly now so that some latin characters are parsed correctly.
11883 | Add support to ms_ms2quantitation::normaliseIntensities to allow for normalisation to selected peptides or proteins when using summed intensities.
11884 | ms_ms2quantitation::getCombinedReportRatioNames now returns unique ratio names in file order rather than alphabetical order.
11885 | Warning message : Attempting to call function matrix_science::ms_peptidesummary::getPeptide before createSummary() has completed with some files where _ignoreiosscorebelow is non-zero and it is an error tolerant search.
11888 | Support for Visual Studio 2013, Update 3.
11892 | Specificity visibility class was not allowing for multiple sites of the same name that differ by position.
11899 | ms_umod_modification::findSpecGroup sorts modification sites incorrectly. For example, it does not find the correct spec group for Phospho (ST) if the input string is "Phospho (ST)" and the T specificity preceeds S in in the list of specificities. This is because the method doesn't sort the sites, so its internal string ends up as "Phospho (TS)", which is of course different from "Phospho (ST)".
11907 | ms_peptidesummary::getQuantitationComponentForPeptide, should exclude a peptide if it matches more than one component. Added code to identify ambiguous components.
11937 | Implementation of willCreateCache function that doesn't require a ms_mascotresfile object and checks both cache files.
11959 | Performance improvements for ms_mascotresfile::getRepeatSearchString.
11960 | Open cache files for writing as soon as possible to reduce potential problems with multiple processes trying to create at the same time

Version 2.5.1 - Released with Mascot Server 2.5

ID | Title
6930 | Error tolerant match with exactly the 'same' score as a standard match is not discarded.
10671 | New function: ms_mascotresults::getQuantitationComponentForPeptide
11467 | Add a new MSPEPSUM flag to specify using homology threshold for ignore ions score below. See: matrix_science::ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH
11486 | Support Perl 5.16 under Windows and Linux, and Perl 5.18 under Linux.
11545 | Cron and ExecAfterSearch in mascot.dat cannot cope with spaces in paths.
11547 | matrix_science::ms_peptidesummary::getProtein() fails to return null when dbIdx is incorrect
11622 | A residue mass of zero is not permitted in mod_file. It is allowed in a unimod file.
11634 | Report standard error as well as standard deviation. Added function: matrix_science::ms_protein_quant_ratio::getStandardError
11686 | Added support for global and per-group modification visibility for matrix_science::ms_umod_configfile
11705 | Improved behaviour for chimeric spectra. New flag: matrix_science::ms_peptidesummary::MSPEPSUM_REMOVE_CHIMERIC_DUPES
11708 | ms_peptide::getAnyMatch was broken and always returned true in version 2.4.4 and version 2.5.0
11718 | Added new functions: getNumDistinctPeptideRepeats and getDistinctPeptide
11797 | ms_datfile::updateForInstaller shouldn't update parse rules if Database Manager is being used.

Version 2.5.0.1, 27th February 2014, released with Mascot Insight 2.5.1

ID | Title
11679 | ms_ms2quantitation is not taking uniquePepseq value from the passed quantitation method
11717 | If peptide ratios are manually excluded from a protein ratio then values from duplicate same query are used

Version 2.5.0, 26th November 2013, released with Mascot Distiller 2.5 and Mascot Insight 2.5

ID | Title
10290 | Added support for HTTP Communication to a Mascot Server
11234 | Move quantitation support from the perl cgi scripts to Mascot Parser. See Peptide and protein quantitation
11235 | Added a new function: ms_mascotresults::getProteinEmPAI
11358 | When combining results files, need to check that quantitation methods match rather than just comparing names. Added a new function isMethodCompatible
11392 | Need to be able to return std::string & parameters in Java. SWIG supports returning references to native types in Java by passing a single element array of, for example an int. However, it doesn't support this for std::string. Where a parameter is a std::string & it is now necessary to supply a StringBuffer object which will be modified by Parser. Note that const std::string & parameters are unaffected, and still expect a Java String
11399 | Simplify the requirements for specifying the location of the unimod and quantitation schema files when using ms_mascotresfile. See Specifying xml schema file locations
11409 | Temporary cdb file created even when MSPEPSUM_DISCARD_RELOADABLE not specified. Minor performance issue, but no other side effects.
11411 | Save qmatch and qploghole in the cdb file to improve performance.
11415 | ms_mascotresfile now inherits from the ms_errors class. See ms_mascotresfile now inherits from ms_errors
11422 | Under Windows, file sizes stored in cdb files are limited to 32 bits. Larger files had 'wrapped around' values and cdb files will be rebuilt automatically for these files.
11425 | New function ms_mascotresults::getIonsScore to return an ions score more rapidly than calling ms_mascotresults::getPeptide and then ms_peptide::getIonsScore
11438 | The functions ms_mascotresfile::getObservedCharge and ms_mascotresfile::getObservedMrValue need an optional parameter for specifying the summary or decoy summary section
11513 | Save the values returned by ms_protein::getCoverage in the cache
11568 | Remove support for Mascot Integra
11631 | Sign the msparser.jar file using a CA trusted certificate

Version 2.4.4, 4th November 2013. Released with Mascot Server 2.4.2

ID | Title
10873 | Support Python 2.7
11559 | Add MISECTASK_ flags for Mascot Insight to the security_tasks.xml file
11560 | MSPEPSUM_DISCARD_RELOADABLE and MSRES_INTEGRATED_ERR_TOL are incompatible.

Version 2.4.3, 1st October 2012. Released with Mascot Server 2.4.1

ID | Title
11115 | Provide interface to the tree/hierarchical cluster method of the C Clustering library: ms_treecluster.
11266 | New function: ms_mascotresfile::getNumEtSeqsSearched().
11190 | The function getProteinTaxonomyIDs() now also returns taxonomy IDs for PMF results where they are available for Mascot 2.4.1 and later. In version 2.4.0, it only returned values from the proteins section (for ms-ms searches).
11269 | Incorrect return value for getObservedCharge() when the charge state is greater than 8+.
11275 | Additional return values for getThresholdForFDRAboveIdentity() and getThresholdForFDRAboveHomology()
11305 | Get error: "Requested query 1, hit -64 in function ms_proteinsummary::getPeptide" with some PMF mixture results when creating a ms_proteinsummary

Version 2.4.2, 26th July 2012. Released with Mascot Distiller 2.4.3

ID | Title
11182 | Support streaming of compression date using ms_zip
11185 | Support for multiple modifications on one site in ms_aahelper. See: Multiple modifications for the same site for details.
11201 | ms_aahelper constructor using a results file needs path(s) to unimod schema and needs to report errors when the schema cannot be found.

Version 2.4.1, 23rd April 2012. Released with Mascot Server 2.4.0

ID | Title
10471 | Load and save mascot.dat using matrix_science::ms_datfile can move comments around. Also added functions: matrix_science::ms_datfile::getHeaderComments matrix_science::ms_datfile::setHeaderComments matrix_science::ms_customproperty::getPreceedingComments matrix_science::ms_customproperty::setPreceedingComments
10797 | Added functions to save and load custom parameters for ms_group and ms_user. See: matrix_science::ms_group::saveStringParam and matrix_science::ms_user::saveStringParam
10798 | New functions matrix_science::ms_mascotoptions::getReportBuilderColumnArrangement and matrix_science::ms_mascotoptions::setReportBuilderColumnArrangement
10823 | New function matrix_science::ms_peptide::getSummedModsStr for improved support in Mascot 2.4 for modifications on labelled residues. See also Multiple modifications for the same site
10874 | New function matrix_science::ms_taxonomyrules::getSpeciesFormatRegex() for additional regular expression in the Taxonomy_n section to read speclist.txt
10906 | New function matrix_science::ms_mascotresults::getThresholdForFDRAboveIdentity returns false and fails to find reasonable values for some Percolator files
10943 | Cron emulator improvements including new ms_cronoptions functions: getLoggingLevel(), setLoggingLevel(), getLogFileName() , setLogFileName() , deleteCronJob() and setCronJob() and new ms_cronjob functions: isEnabled() and setEnabled()
10979 | Add support for RAWFILE and LOCUS to matrix_science::ms_inputquery
10991 | ms_mascotresfile::versionGreaterOrEqual returns incorrect value.
10995 | Internal change to allowed values for identity threshold.
11002 | Change minPepLenInPepSummary functionality. Don't show proteins in which the only significant peptides have length < MinPepLenInPepSummary.
11018 | matrix_science::ms_mascotresults::getThresholdForFDRAboveIdentity and matrix_science::ms_mascotresults::getThresholdForFDRAboveHomology can fail to get the best values.
11042 | ms_mascotresfile doesn't fail safely if a cache file cannot be created due to incorrect permissions. Issue was introduced when Bug 10745 was fixed in version 2.4.0.
11041 | On 64 bit Linux only, the function matrix_science::int ms_mascotresults::getQmatch() can return a 'wrapped' negative number in the extremely rare case of the qmatch_x= value being > INT_MAX. In such cases, it now returns INT_MAX on all platforms.
11094 | Using matrix_science::ms_peptidesummary::MSPEPSUM_NO_PROTEIN_GROUPING can cause a crash when creating a ms_peptidesummary object.

Version 2.4.0, 9th August 2011. Released with Mascot Distiller 2.4

ID | Title
10536 | IgnoreIonsScoreBelow is converted to a score and rounded to an integer internally. First fixed as bug #567 in version 2.3, but this minor issue was re-introduced in version 2.3.1
10610 | "Possible duplicate accession string" errors caused by two accessions that only differ in upper/lower case.
10611 | Memory efficient mode for large search results. See matrix_science::ms_peptidesummary::freeHit and matrix_science::ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE
10621 | Added new class: matrix_science::ms_taxonomytree and function: matrix_science::ms_mascotresults::getProteinTaxonomyIDs to support additional taxonomy information available in Mascot 2.4 and later.
10622 | Added functions matrix_science::ms_mascotresults::createSummary, matrix_science::ms_mascotresults::getCreateSummaryProgress and matrix_science::ms_mascotresults::cancelCreateSummary to enable an application to cancel creating an ms_peptidesummary object.
10623 | Confusing error messages if ExecAfterSearch logging level set incorrectly.
10624 | Increase 2Gb CDB file size limit to 4Gb for 32 bit applications.
10626 | Font size in chm (help) file is too large.
10627 | On Windows, NTFS, cache files get re-created when going to/from daylight savings. Cache directory names also change.
10628 | New function: ms_mascotresfile::resetKeepAlive and added a %f tag for displaying the filename, which is useful with Combining multiple results files
10629 | Small memory leak in protein family grouping.
10630 | New function: matrix_science::ms_connection_settings::setUserAgent() and matrix_science::ms_connection_settings::getUserAgent()
10631 | Rare crash when using results cache with family summary and minPepLenInSearch < minPepLenInPepSummary.
10632 | ms_protein copy constructor is not reliable when using the results cache
10634 | ms_protein copy constructor is not reliable when using the results cache
10652 | Cannot load protein description line from ms_mascotresfile when protein accessions contain an = sign.
10657 | matrix_science::ms_peptide::getProteins() can return incomplete list when lead protein in a family is not the highest scoring.
10668 | Added function ms_mascotresfile::getMultiFileQueryNumber useful with Combining multiple results files
10673 | Added function matrix_science::ms_mascotresults::findProteins and added flags for searching for modifications.
10682 | Added functions: matrix_science::ms_mascotoptions::setIgnoreDupeAccession() and matrix_science::ms_mascotoptions::setReportNumberChoice()
10704 | Add support for a taxonomy rule where TaxID explicitly given.
10711 | Make matrix_science::ms_tinycdb thread safe.
10712 | Add a method to matrix_science::ms_session to return the timeout value.
10716 | New functions matrix_science::ms_mascotresults::getThresholdForFDRAboveIdentity and matrix_science::ms_mascotresults::getThresholdForFDRAboveHomology.
10734 | Use only the filename part of result files when constructing the cache filename for a multi-file peptide summary.
10745 | Creating an ms_mascotresfile object with a 'junk' file when specifying RESFILE_USE_CACHE creates a (tiny) cache file. The second time the ms_mascotresfile object is created with the same parameters, it reads the tiny cache file but fails to set the INVALID_RESFILE error.
10749 | ms_mascotresfile::getNumQueries() incorrectly returned -1 for the last file in a multi-file result set.
10780 | Change definition of matrix_science::ms_mascotresults::isPeptideUnique to be unique per family member rather than per family.
10804 | Change matrix_science::ms_mascotresults::getPeptideThreshold() to allow return of either homology or identity threshold as double.

Version 2.3.3, 11th October 2010. Released with Mascot 2.3.02

ID | Title
461 | matrix_science::ms_umod_configfile::getElementByName() hangs if called with null argument. Now just returns NULL.
596 | Documentation improvements and restructuring of some of the help.
614 | matrix_science::ms_aahelper::createPeptide now supports more than 9 variable modifications.
629 | Added matrix_science::ms_peptidesummary::FC_SEARCH_ALL_RANKS for use with matrix_science::ms_peptidesummary::findPeptides
630 | Accession strings with spaces in are truncated when loading proteins from cache.
632 | Added new function matrix_science::ms_peptidesummary::getFlags2()
633 | MinPepLenInPepSummary not used for family gouping. Also added function matrix_science::ms_peptide::getPeptideLength.
634 | matrix_science::ms_datfile error message says that 'mascot.dat. file does not exist even when opening file with different name, for example 'not.mascot.dat'. Change message to output the name of the file.
635 | Added support for Combining multiple results files
638 | ms_mascotresfile::getRepeatSearchString does not include scans, rawscans, rtinseconds and index
639 | Added ms_mascotresfile::enumerateQuerySectionKeys
641 | Unigene reports too slow. A cache file is now created and used automatically. See matrix_science::ms_unigene
644 | Added tags to pass through session_id and task_id in matrix_science::ms_mascotoptions::getExecAfterSearch
645 | Can't load family report for an ET search with ignoreIonsScoreBelow >0 and < 1
647 | Add Support for Python under Linux. See Python toolkit installation
649 | Performance improvements for matrix_science::ms_mascotresults::getProteinDescription and matrix_science::ms_mascotresults::getProteinMass
653 | Very slow to create cache files when > 100k potential proteins in the results file.
654 | Concurrency issue on Windows when using matrix_science::ms_session
655 | matrix_science::ms_fragment::getLabel returns an string with a truncated rather than a rounded neutral loss. For MetOx, this reports -63 rather than -64.
656 | Concurrency issue: if two processes try to create a directory using matrix_science::ms_fileutilities::createDirectory at the same time, one process may fail.

Version 2.3.2, 11th May 2010. Released with Mascot 2.3.01

ID | Title
624 | Family grouping no longer requires that the top scoring protein for a group appears as a lead protein. There are cases where more compact grouping can be obtained by making the highest scoring protein a subset/intersection.
626 | In rare cases, a protein could be marked as a subset when it should have been another family member. This is because the algorithm defined a protein as a subset when all of the peptides were found in any other protein, rather than any other family member protein.
627 | Change to matrix_science::ms_aahelper::ms_aahelper constructor when creating from a ms_mascotresfile. Added an additional optional parameter to pass a quantitation schema that will be used before calling ms_mascotresfile::getQuantitation
628 | Functions matrix_science::ms_protein::getNumDisplayPeptides and matrix_science::ms_protein::getNumDistinctPeptides return incorrect values for an error tolerant search when the flag for aboveThreshold is set to true. Error tolerant matches are now ignored in this case.

Version 2.3.1, 29th March 2010. Released with Mascot 2.3

See Upgrading to Mascot Parser 2.3.x from 2.2.x For a summary of changes required to scripts using Mascot Parser 2.2,

ID | Title
17 | Would like to collapse peptides that only differ with Isoleucine <-> Leucine. For the new protein grouping, peptides with the same same score and same query are considered to be the same, so, for example, Q <-> K will also collapse if the tolerances are wide enough.
117 | matrix_science::ms_mascotresults::getNextSubsetProtein is now significantly faster.
511 | Increase maximum number of enzyme cutters from 5 to 20 and improve error message and documentation.
523 | Mascot security doesn't work when specifying user_type=computer_name on Apache. This was because the session file names are case sensitive under unix.
531 | Allowed p value for significance threshold has been changed from 0 < p < 0.1 to 1E-18 < p < 1.
569 | Change homology threshold reporting. Can now report a homology threshold value where the qmatch value is less than 100 and the version is Mascot 2.3 or later.
575 | Session timeout fails to give an error if the session file has been deleted and guest is enabled.
582 | Support 64 bit Java for Windows.
583 | Better support for AMD processors.
584 | Added a flag to matrix_science::ms_umod_configfile::save_buffer() for whether to validate.
585 | Added matrix_science::ms_tinycdb for giving access to tinycdb files.
586 | Cache the ms_peptidesummary results. See Caching Mascot Results
587 | matrix_science::ms_mascotresults::isNA() should look in peptide matches and not protein matches. It used to return incorrect results in cases where there were no significant protein matches.
588 | Add a function to return a 'histogram' for all ions scores. Added: matrix_science::ms_mascotresults::getIonsScoreHistogram()
589 | matrix_science::ms_aahelper::calcFragmentsEx() used to not take fixed modifications into account for searches where a quantitation method was specified.
590 Added functions:
  • matrix_science::ms_inputquery::getRawScans
  • matrix_science::ms_inputquery::getIndex
Added additional parameter to:
  • ms_mascotresfile::getNumSeqs()
  • ms_mascotresfile::getNumSeqsAfterTax()
  • ms_mascotresfile::getNumResidues()
  • matrix_science::ms_inputquery::getScanNumbers
  • matrix_science::ms_inputquery::getRetentionTimes
593 | Add a function: matrix_science::ms_protein::getNumUniquePeptides()
594 | Add a function: matrix_science::ms_umod_modification::getRecordID()
595 Add functions to find accessions, descriptions, masses, sequences:
  • matrix_science::ms_peptidesummary::findProteinsByAccession()
  • matrix_science::ms_peptidesummary::findProteinsByDescription()
  • matrix_science::ms_peptidesummary::findPeptides()
598 | Add Using Percolator scores
600 | Add function to retrieve flags and other parameters required for creating an ms_peptidesummary or ms_proteinsummary.
601 Quantitation: Support Multiplex with multiple ions series (e.g. for IPTL)
Deprecated functions:
  • haveIonSeries()
  • dropIonSeries()
  • setIonSeries()
New funtions:
  • getNumberOfIonSeries()
  • clearIonSeries()
  • appendIonSeries()
  • getIonSeries() (New optional index parameter)
  • updateIonSeries()
  • deleteIonSeries()
Updated schema from 2.0 to 2.1
606 | matrix_science::ms_protein::isShowSubsets() does not read the value from mascot.dat because it is looking for ShowSubsets rather than ShowSubSets
607 Call to delete should be delete [] in ms_mascotresfile destructor. Will show up in valgrind as
          Mismatched free() / delete / delete []
            at 0x4C20A6E: operator delete(void*) (vg_replace_malloc.c:346)
            by 0x5B89ACB: matrix_science::ms_mascotresfile::~ms_mascotresfile()
613 | The only way to be able to get an ms_peptide object is to have an ms_mascotresults object which can be slow, so add a new flag to create an ms_peptidesummary object with no proteins. New flag added: matrix_science::ms_peptidesummary::MSPEPSUM_NO_PROTEIN_GROUPING
615 | Support for EMBL EST Taxonomy and Unigene. New enumeration: matrix_science::TAX_SPECIES_ACC2TAXID

Version 2.3, 17th June 2009. Used with Mascot Distiller 2.3

ID | Title
198 | Added matrix_science::ms_protein::getPepNumber() function, for when you're working bottom to top
456 | Added ms_mascotresfile::getMasses() function to create an ms_masses object from ms_mascotresfile.
465 | Additional function for PMF iteration: matrix_science::ms_protein::getMasses
471 | Added the function matrix_science::ms_peptidesummary::getQueryList(QL_FLAG flag) for an easier repeat search. Requires Mascot 2.3
474 | In security, add parameter to restrict spoofing. Additional security task: matrix_science::ms_security_tasks::SECTASK_SPOOFNAMEDGROUPSONLY and function matrix_science::ms_session::getSpoofableUsers() that is used in Mascot 2.3 ms-status.exe for the Show=MS_USERS command.
497 | matrix_science::ms_umod_element::setMonoMass and setAvgMass now check input parameters correctly
514 | Added a new matrix_science::ms_aahelper::ms_aahelper constructor to create an object based on the masses and modifications in a results file. Makes it easier to produce the tables found, for example in the peptide view table.
530 Initial implementation of new protein grouping for Mascot 2.3.
Warning: This code is experimental and there may be further changes before Mascot 2.3 is released
Additional flag: matrix_science::ms_peptidesummary::MSRES_CLUSTER_PROTEINS and additional function: matrix_science::ms_peptidesummary::getNextFamilyProtein
Added matrix_science::ms_mascotresults::getTreeClusterNodes which is used to provide values for producing the dendrograms in the Mascot 2.3 reports. Note that new license C Clustering library needs to be included in applications that use Mascot Parser
536 | Added a function: matrix_science::ms_peptidesummary::getAllProteinsWithThisPepMatch
538 | Added ms_mascotresfile::getFastaPath to retrieve the path to the fasta file(s) used in a search
540 | Support Perl 5.10. See Perl toolkit installation for details of which versions of Perl are supported on which platforms
542 | h1_q1_et_mods_pep and reqpep were not retrieved properly. This only affected protein summary, where they are are not used in the standard Mascot protein summary reports which don't show error tolerant matches
545 Added support for searches against multiple databases (introduced in Mascot 2.3). Existing functions just have an added optional parameter.
  • matrix_science::ms_searchparams::getNumberOfDatabases - [new function]
  • matrix_science::ms_searchparams::getDB - [function updated]
  • ms_mascotresfile::getFastaPath - [function updated]
  • ms_mascotresfile::getFastaVer - [function updated]
  • matrix_science::ms_mascotresults::getProtein - [function updated]
  • matrix_science::ms_protein::getDB - [new function]
551 | Added functions matrix_science::ms_umod_configfile::getMajorVersion() and matrix_science::ms_umod_configfile::getMinorVersion().
552 | Added matrix_science::ms_mascotoptions::getMinEtagMassDelta and matrix_science::ms_mascotoptions::getMaxEtagMassDelta .
556 | Memoryleak in ms_modfile fixed
557 | Added matrix_science::ms_mascotoptions::getMaxDatabases function.
558 Support for Quantitation version 2 schema. A number of functions have been added and some deprecated:
  • Added: matrix_science::ms_quant_average::getNumPeptides, matrix_science::ms_quant_average::getSelection, matrix_science::ms_quant_average::getReferenceAccession
  • Added: matrix_science::ms_quant_component::getSatellite
  • Added: matrix_science::ms_quant_configfile::getMajorVersion matrix_science::ms_quant_configfile::getMinorVersion
  • matrix_science::ms_quant_integration - a number of functions have been deprecated
  • Added: matrix_science::ms_quant_integration::getMatchedRho matrix_science::ms_quant_integration::getXicThreshold matrix_science::ms_quant_integration::getXicMaxWidth matrix_science::ms_quant_integration::getXicSmoothing matrix_science::ms_quant_integration::isAllChargeStates matrix_science::ms_quant_integration::getAllChargeStatesThreshold
  • Added: matrix_science::ms_quant_normalisation::getPeptides matrix_science::ms_quant_normalisation::getProteins
  • matrix_science::ms_quant_precursor - a number of functions have been deprecated.
  • Added: matrix_science::ms_quant_quality::isUniquePepseq matrix_science::ms_quant_quality::getIsolatedPrecursorThreshold
  • Added: matrix_science::ms_quant_reporter::getReporterTol
559 | Added Caching Mascot Results
560 | Add basic support for ontology files in the .obo format. See matrix_science::ms_obofile .
561 | Added a function matrix_science::ms_mascotresults::getQmatch to retrieve the the qmatch value from the results file.
564 | The default value for matrix_science::ms_mascotoptions::getInterFileBasePath was C:/InetPub/Mascot/data for Linux and Unix platforms.
565 | For Java, throw an exception if out of memory
566 | Added a security task matrix_science::ms_security_tasks::SECTASK_MAXNOENZQUERIES that enforces a separate query limit for no enzyme searches
567 | IgnoreIonsScoreBelow was converted to a score and rounded to an integer internally. No internal rounding performed now.
568 | Add simple_ratio to integration in quantitation_2
573 Quantitation reporter protocol: need to be able to specify a mod as required. Added functions:
  • matrix_science::ms_quant_modgroup::haveRequired
  • matrix_science::ms_quant_modgroup::isRequired
  • matrix_science::ms_quant_modgroup::setRequired
  • matrix_science::ms_quant_modgroup::dropRequired
  • matrix_science::ms_quant_modgroup::getRequiredSchemaType
574 | Added matrix_science::ms_peptidesummary::isPeptideUnique for quantitation support
577 | Finer control over progress reports. See ms_mascotresfile::outputKeepAlive
578 | Experimentatl support for Python. Windows only for now. See Python toolkit installation
579 | More security tasks: matrix_science::ms_security_tasks::SECTASK_MAXFASTAFILES and matrix_science::ms_security_tasks::SECTASK_DENYQUANT

Version 2.2.8, 25th June 2009 - Used by Mascot Server 2.2.06

ID | Title
581 | Patch for Dunnington, i7 and Nehalem processors for Linux. (Bug #562 only supported Windows)

Version 2.2.7, 8th January 2009 - Patch for Dunnington, i7 and Power5+ processors. Used by Mascot 2.2.05

ID | Title
562 | Support for Dunnington and Intel i7 processors.
563 | Support for Power5+ processors.
458 | matrix_science::ms_processors class may give incorrect information about number of cores per cpu in 64 bit Windows. (Linux and 32 bit Windows unaffected).

Version 2.2.6, 5th September 2008 - Used by Mascot Distiller 2.2.0

ID | Title
546 | The function matrix_science::ms_masses.copyFrom leaves a dangling pointer.
550 | Added statistical algroithm for use by Distiller to the Mascot utilities and tools module.

Version 2.2.5, 26th June 2008

ID | Title
509 | matrix_science::ms_mascotresults::createUnassignedList did not free some memory when the ms_mascot_results object was deleted.
539 | Add support for UltraSPARC T1 and T2, and IV+ processors
543 | Corrupt text could be caused by unicode characters in reference fields in unimod.xml. Error returns from Windows functions are now handled properly.

Version 2.2.4, 5th March 2008

ID | Title
532 | Support mingw and a more recent version of gcc. See Using the MinGW compiler
526 | Performance improvements in calls to getHomologyThreshold()
522 | The example code, create_mgf.pl misses last peak
520 | Add matrix_science::ms_peptide::getNum13C function
519 | Support Java 6. Previous releases would occasionally crash with Java 6 on Windows
518 | Need to escape spaces in schema file paths that are passed to Xerces.
493 | ms_proteinsummary is wrong for NA searches where there are hits from different frames. Instead of reporting a separate protein hit for each frame, the results are merged into one hit.

Version 2.2.3, 22nd June 2007

The following items were fixed in this release which was shipped with Mascot Server 2.2.02

ID | Title
512 | Calls to matrix_science::ms_fileutilities::setAccessRights can result in security tokens being repeated multiple times. (Only visible using command line cacls)
508 | matrix_science::ms_modification::setNeutralLoss could not be called from java or perl
507 | Trailing tabs in database definition line caused problems for some 3rd party software

Version 2.2.2, 18th April 2007

The following items were fixed in this release which was shipped with Mascot Distiller 2.1.1

ID | Title
504 | Failed to retrieve a remote configuration file when using an https Mascot server
502 | Failed to retrieve a remote configuration file when a proxy server requires a username and password to be specified

Version 2.2.1, 26th March 2007

The following items were fixed in this release which was shipped with Mascot 2.2.1

ID | Title
482 489 | Changes to matrix_science::ms_datfile::updateForInstaller for Windows installer

Version 2.2.0, 15th March 2007

The following items were fixed in this release which was shipped with Mascot 2.2

ID | Title
485 | Change matrix_science::ms_databases::findDatabase to allow searching of inactive databases
473 | The limit of 64 databases should only count active databases
481 | Added a function for Mascot installers to perform all required changes to mascot.dat. See matrix_science::ms_datfile::updateForInstaller()
480 | ms_license fails to report an error message in some cases
476 | Add support for a feature string in the mascot license file (required for BigMascot)
470 | standalone="no" is now omitted in xml-documents
466 | Add new function: matrix_science::ms_processors::getNumCores()
462 | Bugs in plpa library for 64 bit Linux fixed.
460 | Increase limit on number of parse rules from 64 to 256
449 | Homology threshold now uses the significance threshold value
447 | Mudpit score now decreases when the significance threshold is decreased
453 | Added matrix_science::ms_mascotoptions::getMaxVarMods() and matrix_science::ms_mascotoptions::getMaxEtVarMods()
451 | Errors now detected while saving config files
448 | Issue with leading space in comments when modifying mascot.dat fixed
446 | There are no longer and unicode versions of the Parser library for Windows. Applications that are compiled with unicode support should still be able to link against the non-unicode versions of Parser
444 | If modification is missing from ms_modvector, ms_aahelper crashes and burns
370 | Download of unimod.xml (0.5Mb) will be too slow over the internet. Parser now downloads the compressed unimod.xml, using the matrix_science::ms_zip class
442 | Curl support has never worked on 64 bit AIX and possibly other platforms
441 | Unigene support has never worked properly on 64 bit AIX release, (and possibly SGI/Sun/Tru64). The 64 bit Linux versions were not affected by this issue
440 | Add a new option to mascot.dat - access through matrix_science::ms_mascotoptions::getMaxPepNumVarMods
439 | ShowSubSets is now a double rather than a boolean. Add matrix_science::ms_mascotoptions::getShowSubsets and allow matrix_science::ms_mascotoptions::setShowSubsets to take a double as well as a boolean value
414 | 64 Bit Windows in now supported using Visual Studio 2005, service pack 1. This is available as a separate package
320 | Support for files > 2Gb introduced a file handle leak bug when accessing parameters in the query sections.
438 | Add matrix_science::ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB. See matrix_science::ms_peptidesummary::ms_peptidesummary for details.
437 | Add security task matrix_science::ms_security_tasks::SECTASK_SEESEARCHINANYGROUP for the right to view searches for all users in all groups belonged to. Shouldn't require any changes to any third party applications that call matrix_science::ms_session::canResultsFileBeViewed
436 | File Handle Leak in ms_mascotresfile with a zero byte file
435 | Spaces at the start of all configuration files are now stripped.
434 | A database name that starts with End is treated as the end of the database section.
433 | Preliminary support for UniGene section in mascot.dat: See matrix_science::ms_unigeneoptions. The main aim purpose of this change is to get the mascot.dat file to save correctly for the installation program.
427 | matrix_science::ms_enzyme::verifyEnzyme doesn't complain about numbers in restrict and and also allows lower case letters.
423 | Integrated error tolerant - numerous further changes, but may be complete now?
424 | ms_fragmentationrules::verifyRule - further additions to rules
427 | verifyEnzyme doesn't complain about numbers in restrict and and also allows lower case letters.
430 | Added z+2 series
154 | Sort order for peptide summary with single etag - now sorted by delta.
253 | Integra session files now get deleted properly. They now use the default timeout period.
293 | When logging in using the 'guest' username, guest session files, such as guest_12312312313 session no longer get created.
295 | Show Sub-sets is now a fraction, not boolean. See Grouping proteins together
298 | matrix_science::ms_aahelper::createPeptide documentation improved.
320 | File larger than 2Gb can now be read on 32bit parser.
335 | Calling matrix_science::ms_mascotresults::createUnassignedList for a protein summary when there is no protein summary no longer gives errors, but just creates an empty list.
337 | Mascot Integra users can no longer log in through Mascot - they must login through Integra.
343 | Taxonomy strings can now contains commas.
391 | Add method to ms_umod_modification to generate ms_modification objects.
393 | Threshold cut-offs have changed. Old behaviour was to suppress the homology threshold if there were less than 1000 sequences in the search. New behaviour is to supress the threshold if qmatch is less than 100. There is also now a minimum for identity threshold of 13.
409 | Verify enzyme used to return false if Restrict was empty
420 | matrix_science::ms_mascotresults::getIonsScoreCorrected was incorrect if ITOL units were mmu rather than Da
421 | Added matrix_science::ms_mascotoptions::getMudpitSwitch() and matrix_science::ms_mascotoptions::getSelectSwitch()
415 | Support for minInternalMass and maxInternalMass. See matrix_science::ms_fragmentationrules::getMinInternalMass() matrix_science::ms_searchparams::getMinInternalMass() and matrix_science::ms_inputquery::getMinInternalMass()
413 | New security params - varmods, varmods ET, num accessions. See matrix_science::ms_security_tasks::SECTASK_MAXVARMODS matrix_science::ms_security_tasks::SECTASK_MAXETVARMODS matrix_science::ms_security_tasks::SECTASK_MAXETACCESSIONS
410 | Add PSI_MS_Name ( ex_code_name) and maybe Approved. See matrix_science::ms_umod_modification::getExCodeName() and matrix_science::ms_umod_modification::isApproved
408 | Remove limit of 1024 mods - make it unlimited
407 | msparser class ms_umod_xref needs to have url-property
397 | Speed up ms_inputquery
396 | Output keep alives in matrix_science::ms_peptidesummary::createUnassignedList()
394 | Example C++ projects have the wrong compiler options for debug DLL versions
385 | Added matrix_science::ms_inputquery::getScanNumbers() and matrix_science::ms_inputquery::getRetentionTimes()
384 | mascot.dat Options functions missing: SortUnassigned etc.
358 | getTagStart, getTagEnd, getTagSeries stuck in infinite loop
313 | Unigene file parsing not quite right. File format change in unigene files now processed properly
402 | add validation precedures to fragrules and enzymes
395 | Keep alives need to be flushed. On Linux, the keep alive html comments are kept in a buffer and not flushed. This means, assuming that the standard text and default time of 5 seconds is used, that it takes 20 minutes for something to appear.
386 Support for mulitple neutral losses. The function matrix_science::ms_searchparams::getVarModsNeutralLosses which returns an array of neutral losses has been added.
matrix_science::ms_searchparams::getVarModsPepNeutralLoss and matrix_science::ms_searchparams::getVarModsReqPepNeutralLoss have also been added.
387 | The functions: matrix_science::ms_searchparams::getFixedModsName matrix_science::ms_searchparams::getFixedModsDelta matrix_science::ms_searchparams::getFixedModsNeutralLoss matrix_science::ms_searchparams::getFixedModsResidues have been added.
329 | Return the new parts of the results file required for quantitation
332 | Support decoy search results
338 | New option ResultsFileFormatVersion in mascot.dat
339 | ICAT mods mapping accepts only modnames without spaces
355 | Need to escape text in ms_inputquery::getINSTRUMENT() and ms_inputquery::getIT_MODS()
356 | Need to read enzyme and taxonomy sections of resfile
373 | getSeriesName returns empty string for ion series 19,20
376 | setDelta() for unimod modification disables mod delta
326 | If an old ICAT search is repeated with Mascot 2.2 or later, then the ICAT=ON should be translated to QUANTITATION=ICAT. The name 'ICAT' is retrieved from the options section of mascot.dat using getICATQuantitationMethod()
327 | If the require bold red flag is set, then the wrong protein number used to appear in the yellow popup. The protein accession string was correct.
328 | Further changes to quantitation.xml design. [Remove from 2.2 changes list]
330 | Support MODS and INSTRUMENT at the query level. See getINSTRUMENT(), getRULES() and getIT_MODS(). Needed for instruments that, for example, can switch between ETD and CID.
329 | Support more than 9 variable mods. See Increase in the number of variable modifications for details on the impact of this to existing clients using Mascot Parser.
333 | Add 3 new search parameters: getQUANTITATION() , getPEP_ISOTOPE_ERROR() and getDECOY()
248 Support for new PMF iterations introduced in Mascot 2.2
See: ms_proteinsummary::isPmfQueryUsed()
297 | A Java or Perl application calling matrix_science::ms_aahelper::calcFragments can now access the fragments array.

Version 2.1.03, 9th March 2006

The following items were fixed in this release which was shipped with Mascot 2.1.04

ID | Title
300 | Support high charge state fragments in aa_helper. Mascot only matches singly and doubly charged fragments, and there are no plans to change this. However, if someone wants to label peaks with higher charge states in Mascot Distiller or any other product that uses Mascot Parser, they can now do this.
301 | aa_helper used to give a negative peptide mz value for negative charge.
302 | calcPeptideMz() now gives correct mz values for higher charges.
307 | A dual core Xeon system with HT disabled in the bios was not detected correctly. The work-around was to enable HT in the bios.
310 | Process Affinity was not working on some 2.6 kernels (Linux). This has been fixed by using the PLPA library from Open-MPI.

Version 2.1.02, 18th October 2005

The following items were fixed in this release which was shipped with Mascot 2.1.02

ID | Title
263 | If a search was run using 'MONOISOTOPIC' rather than 'Monoisotopic', then a repeat search using search_form.pl would submit the second search using average masses because it doesn't recognise MONOISOTOPIC. This has been fixed in this parser release.
270 | The Tru64 release of parser 1.x sometimes gives a different sort order for the concise protein summary due to a bug in the Tru64 compiler. This problem has been fixed in this release by using a patched Tru64 compiler.
276 | Advanced topic! MSRES_DUPE_REMOVE_A will always be set which causes incorrect filtering when modifying these advanced flags. This does not affect any standard reports.
280 | getNextSubsetProtein() now always returns false unless MSRES_SHOW_SUBSETS is set. This makes coding for the client a little easier and more transparent.
281 | In cases where the highest scoring protein has no bold red peptides, selecting REQUIRE_BOLD_RED used to return no hits. Obviously, it is very rare for the highest scoring protein to not have any rank 1 peptide hits.
282 | Add SECTASK_BIOTOOLSBATCH in preparation for next Bruker Biotools release. Added this task to the PowerUsers group.
283 | Some customers still have systems with the electron mass being incorrect from the Mascot 1.9 installation. 'Fudge' the code by returning the correct value (0.000549) if the value in the file is 0.00549. If, so some bizarre reason, you really want the electron mass to be 0.00549, then specify it as 0.005490 in the masses file.
285 | The matrix_science::ms_processors class now supports dual core AMD Opteron and reports that process affinity is available on Linux 2.6 kernels. Additional functions are now available to determine the name of the processor manufacturer and a description of the hyperthreading/multi-core/SMT functionality on the processor.
286 | matrix_science::ms_protein::getFrame used to return -1 for protein database if the search was PMF. It now returns 0 as specified in the documentation.
287 and 290 | Using the require bold red flag, it was possible to get occasional matches to proteins without any bold red peptides.

Version 2.1.01, 24th June 2005

The following items were fixed in this release which was shipped with Mascot 2.1.01

ID | Title
261 | Java version of ms_aahelper fails. C++ and Perl worked OK.
262 | Passing a directory name rather than a file name caused a crash.
266 | ms_searchparams::getUSERID returns -1 for old searches - meaning that it is impossible to see old searches unless the view all searches token is set.
267 | In rare circumstances, a single peptide match generates multiple protein hits. Only happens at the random matching level and if minPepLenInPepSummary is non-zero.
267 | getErrTolModMasterNeutralLoss() returned an incorrect value.
272 | Java Parser on Linux fails to run.
273 | Performance improvement for results files with matches to a large number of ambiguous residues

Version 2.1.0, 30th April 2005

The following items were fixed in this release which was shipped with Mascot 2.1

ID | Title
2 | Read and parse the Mascot configuration files. See Mascot configuration files module
122 | Ambiguous residues coped with transparently. matrix_science::ms_peptide::getPeptideStr now takes an optional argument to specify whether ambiguous residues are reported with the substituted value
126 | Documentation - ms_searchparams class reference had multiple references to MASS=
142 | ms_protein::getFrame() is now a const function
143 | Documentation - now specifies that oneInXProb has lower limit of 10
144 | Documentation - now specifies that 0 is returned for auto in matrix_science::ms_searchparams::getREPORT()
145 | Documentation - matrix_science::ms_peptide::getIonsIntensity() is now clearer
146 | Documentation - matrix_science::ms_peptide::getNumIonsMatched() is now clearer
151 | Provide functions to calculate peptide and fragment masses. See Mascot utilities and tools module
162 | Example perl script for protein summary and peptide summary have incorrect tag calls.
164 | C++ test harness: peptide_list.cpp only builds on Windows.
173 | Performing a search in the Windows msparser help no longer gives the same 'Title' for all pages.
175 | Documentation - Ions series are now correct in matrix_science::ms_searchparams::getRULES()
183 | Peptides with and without ambigious residues are now split into two entries. When decides whether to check if one protein is a sub-set of another it now compares the substituted peptide strings instead of original.
186 | Mascot User authentication and login. See Mascot security and authentication module
187 | Re-organise the help into separate modules, and provide example code in the examples directory as well as the online help.
199 | Huge results files loaded and parsed using less memory.
200 | AutoSelectCharge is a new parameter in the options section of mascot.dat See: matrix_science::ms_mascotoptions::getAutoSelectCharge()
206 | Before loading whole results file, check it really is a Mascot result file.
218 | Support for negative charge state.
221 | In the help, remove the class and class hierachy menu in the tree. These are now grouped together under the separate modules.

Version 1.2.2, 19th January 2004

The following items were fixed in this release which was shipped with Mascot 2.0:

ID | Title
134 | Support non-threaded build of Perl on Linux. Perl supplied with RedHat Linux is normally built with threads support. The default build of Perl (and therefore the one supplied with most other Linux distributions) has thread support disabled. See Installation on Linux platforms for details of which version of msparser.so is required for your system
135 | If a query contains a tag or an etag, then the homology threshold is now suppressed.
137 | New protein scoring for MudPIT type searches. See matrix_science::ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE
139 | Version string format in msparser.pm changed from, for example: $VERSION = "1.2.1" to $VERSION = 1.002001; for more reliable version checking with different versions of perl.
140 | Add matrix_science::ms_mascotresults::getProteinExpectationValue() and matrix_science::ms_mascotresults::getPeptideExpectationValue()

Version 1.2.1, 15th December 2003

The following items were fixed in this release:

ID | Title
121 | Support for tag and etag additions in Mascot 2.0 result files has been added. See for example, matrix_science::ms_peptidesummary::getTagString() , matrix_science::ms_peptidesummary::getTagDeltaRangeStart() and matrix_science::ms_peptidesummary::getTagDeltaRangeEnd()
125 | The C++ documentation referred to msparser.h where it should have been 'msparser.hpp'
127 | DLLMain is no longer defined in the Windows static C++ libraries.
128 | Added ms_mascotresfile::getUniqueTaskID() to support taskid's used by Mascot Daemon in Mascot 2.0
129 | Fixed a crash for a faulty results file with the incorrect number of queries.
130 | Sort order for proteins with identical scores used to be incorrect with .NET 2003 compiler, and Linux Intel compiler. Code generated by all other compilers was working properly.
132 | getAvePeptideIdentityThreshold used to be incorrect for a search that has queries with no matches. Also, added matrix_science::ms_mascotresults::getMaxPeptideIdentityThreshold() as a safer option to display above the histogram on the Mascot 2.0 reports.

Version 1.2.0, 20th October 2003

Support for Java has now been added. See Java toolkit installation for details.

Windows Visual C++ .NET 2003 is now supported along with Visual C++ 6.0. Separate directories are provided for each compiler. The DLLs no longer require Perl to be installed on the computer.

Important Windows Perl users please note that the msparser.dll file is now located in a perl56 or perl58 directory. Do not use the one in the lib directory as this no longer provides any perl support.

The following items were fixed in this release:

ID | Title
5 | Proteins with identical scores are now sorted by accesion number. If the accessions contain numbers (e.g. gi numbers), then the sorting is by the actual number. Otherwise, it sorts lexicographically. See also issue #48 below.
15 | A warning message is now provided for duplicate accessions. Duplicate accessions are normally an indication of a faulty database, or incorrect parse rules, and should be investigated by the Mascot Administrator.
16 | A new function matrix_science::ms_mascotresults::isNA can be called to determine if the search was against a protein database or a nucleic acid database.
36 | Peptide mass fingerprint mixture mode is now supported. See Peptide mass fingerprint mixtures
40 and 102 | Version information can now be found using the standard perl and java interfaces. Further information can be found at: ms_mascotresfile::getMSParserVersion()
42 | Added a function to find number of proteins in the results. see matrix_science::ms_mascotresults::getNumberOfHits()
43 | Added two new functions: ms_mascotresfile::enumerateSectionKeys matrix_science::ms_searchparams::getAllUSERParams to get 'user' parameters.
48 | For a full protein summary report, the sort order now has a one to one correspondence with the entries in the results file. See also issue #5 above, which affects concise summary and peptide summaries.
49 | Added a new function matrix_science::ms_mascotresults::getProteinScoreForHistogram to return the top 50 scores.
50 | Issue with symbol log10: referenced symbol not found on some Solaris systems has been resolved.
54 | A number of minor problems with the unassigned list have been resolved
56 | Added two new functions: matrix_science::ms_inputquery::getPepTol() matrix_science::ms_inputquery::getPepTolUnits()
57 | Changed matrix_science::ms_peptidesummary::getProteinsWithThisPepMatch to have an extra default parameter that returns quotes around the accession strings. This is required to allow accessions with spaces.
58 | Add matrix_science::ms_protein::getUnmatchedMasses to get the list of observed mass values that failed to get a match to a protein hit in a PMF (listed at end of each hit in a protein summary report).
59 | For a peptide summary, the probability cutoff calculation was not the same as in the Mascot 1.9 results reports, which use the average peptide probability. This is always a very minor difference.
60 | Calculation for protein score in peptide summary is now exactly the same as in the Mascot 1.9 results reports. This resulted in very rare minor differences.
61 | Error handler changes. IsValid() no longer returns false if there are only warning messages. Messages are now classified by severity. The test harness shows new code to print out warnings if the file is valid. Messages no longer have the file name at the beginning.
62 | Added new function: matrix_science::ms_searchparams::getElectronMass().
71 | Changes to the output of matrix_science::ms_mascotresults::getReadableVarMods for error tolerant search results.
72 | Calling getProteinMass used to fail for hit number 50.
74 | Option to 'leak bytes' to keep browser connection alive when a report is taking a long time to produce. See: ms_mascotresfile::ms_mascotresfile and ms_mascotresfile::outputKeepAlive()
76 | Added a method for getting a protein or peptide summary for single hit very quickly. A parameter 'singleHit' has been added to both matrix_science::ms_peptidesummary::ms_peptidesummary and matrix_science::ms_proteinsummary::ms_proteinsummary.
77 | Any SQ always used to return false - even for a sequence query.
78 | Added matrix_science::ms_protein::getRMSDeltas to return RMS error for a protein.
79 | Proteins in a protein summary are now collapsed by query number rather than peptide string. See Grouping proteins together for further information. This should give compatible results with Mascot 1.9 reports.
81 | Key names in the results files are now always matched case insensitively.
82 | Sample code for repeating a search is now provided in Perl, Java and C++ in the relevant 'test_' directory. See also Automated repeating of searches
83 | Trying to read a result files from Mascot versions earlier than 1.02.00 will now produce an error. These files are not supported.
84 and 85 | ms_mascotresfile::getRepeatSearchString used to fail to return the peptol() parameter in cases where an override peptide tolerance had been specified. It also returned seq() instead of comp() for a composition query.
86 | Minor differences in the output for an error tolerant search have been fixed.
91 | Changed matrix_science::ms_peptidesummary::getProteinsWithThisPepMatch() is now considerably faster
92 | Added matrix_science::ms_inputquery::getPepTolString()
93 | The parameter minPepLenInPepSummary now behaves in the same way as the Mascot 1.9 reports. In the previous version, peptides shorter than this were totally ignored. Now, they are just ignored for Grouping proteins together purposes.
103 | OneInXprobRnd is now a a double rather than an int - it was previously possible to overflow this value.
104 | Added a new function: matrix_science::ms_mascotresults::getSequenceMass to calculate the relative mass of a sequence.
110 | The function: matrix_science::ms_peptide::getPrettyRank has changed. The ordering of the numbers is now slightly different and is consistent with the original Mascot reports.
113 and 116 | A bug in: matrix_science::ms_protein::getCoverage that caused to large a value to be reported (particularly with error tolerant searches) has been fixed. The getCoverage function is not supported for Mixture mode and Unigene - and will return 0 for these results.

Known bugs in Version 1.2.0
39 - Installer required for installing the perl package

Version 1.01, 5th March 2003

The following items were fixed in this release

ID | Title
1 | Unigene indexes are now fully supported. Simply pass the name of the Unigene index file when creating a results object.
28 | ms_mascotresfile::anyMSMS() always used to return false if there was just one query. It now functions properly.
29 | ms_mascotresfile::getRepeatSearchString used to have a line feed at the end of the string, making it inconvenient to use.
30 | matrix_science::ms_peptide::getMrExperimental() can return 0. This is "by design", since it is calculated from getMrCalc() + getDelta(). It is generally recommended that ms_mascotresfile::getObservedMrValue() is used, since this will always return the relative mass, even for no match. Documentation has been updated.
31 | matrix_science::ms_mascotresults::MSRES_REQUIRE_BOLD_RED now functions properly. In version 1.0, supplying the flag had no effect.
32 | The C++ test harness now (optionally) loads parameters from a configuration file. This functionality is solely designed to help in-house testing of the library.
35 | Error messages: ERR_UNASSIGNED_??? were all reported incorrectly. (Message numbers were all out by one).
37 | The documentation is no longer supplied as a pdf file. This help is only available in html format now. The image for the UML diagram was poor quality in the PDF document - a separate PDF file is now supplied.
38 | "Corrupt" title strings could sometimes be returned by matrix_science::ms_inputquery::getStringTitle(true). Spaces were treated correctly, but other characters such as a parenthesis were not handled correctly. The unescaped string was always returned correctly.
– | Solaris and Linux versions now available.

Known bugs in Version 1.01
39 - Installer required for installing the perl package

Version 1.0, 28th November 2002

The following items were fixed in this release

ID Title
22

Duplicate accession strings in database or repeated peptides in a protein cause confusion. Added matrix_science::ms_protein::getNumDisplayPeptides()

23

Add function to get the string for a repeat search. See: ms_mascotresfile::getRepeatSearchString()

24

Documentation addition. Added requirement for

      #define _MATRIX_USE_STATIC_LIB

when compiling under Windows using static library. See Compiler Options

25

Add "summary" example C++ test file. This outputs a list of of the top matching proteins. C++ example only.

26

Failure to get protein mass from proteins section. If a protein was in the proteins section, but not in the summary section, then the protein mass was not returned when calling matrix_science::ms_mascotresults::getProteinMass()

27

Added ms_mascotresfile::getMSParserVersion() to return the Mascot Parser version.

Known bugs in Version 1.0
Bug 1 - Unigene support. Interfaces available, but not yet implemented.

Beta 7, 10th November 2002

The following items were fixed in this release

ID | Title
14 | Supply all (or nearly all!) combinations of C++ static and DLL libraries for Microsoft Windows.
21 | Update the C++ example code documentation.
18 | Infinite loop in perl test harness.

Beta 6, 24th September 2002

The following items were fixed in this release

ID | Title
4

Backward compatibility - need to know if there is a peptides block. Two new functions should enable this:

  • ms_mascotresfile::doesSectionExist()
  • ms_mascotresfile::anyPeptideSummaryMatches()

6

Need MinPepLenInPepSummary. There is a new parameter to matrix_science::ms_peptidesummary::ms_peptidesummary.

7

How to do AUTO. Improved documentation. See the examples.

9

Null accessions now create an error. See ms_mascotresfile::ERR_NULL_ACC_PEP_SUM and ms_mascotresfile::ERR_NULL_ACC_PROT_SUM.

10

Error reporting - instead of just keeping one error, have a list of errors. See Error Handling for details.

11

There is now a way of getting the list of unassigned peptides. See Unassigned peptides list for details.

12

Need an IsBold function.
See matrix_science::ms_protein::getPeptideIsBold()

13 | Need a IsDisplayCheckBox function See matrix_science::ms_protein::getPeptideIsBold()

Beta 5, 13th September 2002

First release with these help pages.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Updating from earlier versions of Mascot Parser

Updating from earlier versions of Mascot Parser

Upgrading to Mascot Parser 3.0.x from 2.8.x

Renaming of ms_mascotresfile to ms_mascotresfile_dat

The class ms_mascotresfile has been renamed to ms_mascotresfile_dat. The class now inherits from ms_mascotresfilebase, as part of implementing support for parsing Mascot Search Results (MSR) files. The methods and members of ms_mascotresfile_dat are otherwise identical to ms_mascotresfile in Parser 2.8.

Because the API remains the same, client-side code is straightforward to update.

Renaming in C++ sources

  1. Update Parser to version 3.0 (msparser.dll, msparser.so, msparser.a, msparser.lib).
  2. Search for calls to ms_mascotresfile::willCreateCache(). Rename these to ms_mascotresfilebase::willCreateCache().
  3. Search for the string "ms_mascotresfile::" in your source code and replace these with "ms_mascotresfile_dat::".
  4. Search for the regex "ms_mascotresfile\W" or "ms_mascotresfile[^a-z_]", which should match cases like "ms_mascotresfile " and "ms_mascotresfile*", and replace these with "ms_mascotresfile_dat".
  5. Compile. The compiler should point out remaining instances where "ms_mascotresfile" is still used.

Renaming in Perl sources

  1. Update Parser to version 3.0 (msparser.dll, msparser.so, msparser.pm).
  2. Search for calls to ms_mascotresfile::willCreateCache(). Rename these to ms_mascotresfilebase::willCreateCache().
  3. Search for the string "ms_mascotresfile::" in your source code and replace these with "ms_mascotresfile_dat::".
  4. Search for the regex "ms_mascotresfile\W" or "ms_mascotresfile[^a-z_]", which should match cases like "ms_mascotresfile " and "ms_mascotresfile->", and replace these with "ms_mascotresfile_dat".
  5. Compile your program with perl -c -w your_script.pl. Perl should point out remaining instances where "ms_mascotresfile" is still used.

Note: The Perl compiler will warn you about cases where ms_mascotresfile is used as a bare identifier, but it will not warn you about cases where you are using class variables like enums from ms_mascotresfile, such as $ms_mascotresfile::RESFILE_NOFLAG.

Renaming in Python sources

  1. Update Parser to version 3.0 (_msparser.pyd, _msparser.so, msparser.py).
  2. Search for calls to msparser.ms_mascotresfile.willCreateCache(). Rename these to msparser.ms_mascotresfilebase.willCreateCache().
  3. Search for the string "ms_mascotresfile::" in your source code and replace these with "ms_mascotresfile_dat::".
  4. Search for the regex "ms_mascotresfile\W" or "ms_mascotresfile[^a-z_]", which should match cases like "ms_mascotresfile " and "ms_mascotresfile(", and replace these with "ms_mascotresfile_dat".
  5. Run your program. If you reach code that tries to instantiate ms_mascotresfile, the Python interpreter will throw an exception.

Note: Although most Python code is compiled to intermediate bytecode, the compiler does not provide full static analysis or type checking. We recommend exercising every code path in your program if you don't already have unit tests in place.

Renaming in C# and Java sources

  1. Update Parser to version 3.0 (msparsercs.dll, matrix_science.msparser.dll; msparserj.dll, msparser.jar).
  2. Search for calls to msparser.ms_mascotresfile.willCreateCache(). Rename these to msparser.ms_mascotresfilebase.willCreateCache().
  3. Search for the regex "ms_mascotresfile\W" or "ms_mascotresfile[^a-z_]", which should match cases like "ms_mascotresfile " and "ms_mascotresfile.", and replace these with "ms_mascotresfile_dat".
  4. Compile. The compiler should point out remaining instances where "ms_mascotresfile" is still used.

New resfile class for Mascot Search Results (MSR)

Mascot Server 3.0 defaults to writing search results in Mascot Search Results (MSR) format, which is an SQLite file. The new class ms_mascotresfile_msr provides full support for reading MSR files. ms_mascotresfile_dat and ms_mascotresfile_msr inherit from the new base class ms_mascotresfilebase.

All Parser results file classes, such as ms_peptidesummary and ms_inputquery, have been updated to support reading from ms_mascotresfile_msr. The relevant constructors and methods now take an ms_mascotresfilebase reference as input, instead of ms_mascotresfile_dat. All the API remains otherwise the same, which means supporting both .dat and MSR formats can be done with a few small changes.

  1. Use the new function matrix_science::ms_mascotresfilebase::createResfile to open a results file. The function returns either ms_mascotresfile_msr or ms_mascotresfile_dat based on the file contents.
  2. If you have a function or method that takes an ms_mascotresfile_dat pointer/reference, simply change it to ms_mascotresfilebase pointer/reference.
  3. Check all places where you use low-level (legacy) methods such as ms_mascotresfile_dat::getSectionValueStr(). Change these calls to higher-level methods. A full table of recommend replacements is below.
Old method call | Intent | Replacement
ms_mascotresfile::willCreateCache(filepath, ms_mascotresfile::RESFILE_USE_CACHE, cacheDirectory) | Will a cache file be created? | ms_mascotresfilebase::willCreateCache(filepath, ms_mascotresfilebase::RESFILE_USE_CACHE, cacheDirectory)
ms_mascotresfile::doesSectionExist(SEC_DECOYSUMMARY)
ms_mascotresfile::doesSectionExist(SEC_ERRTOLDECOYSUMMARY) 		Is this a target-decoy search? ms_searchparams::getDECOY() > 0
ms_mascotresfile::doesSectionExist(SEC_ERRTOLPEPTIDES) | Sometimes used to test whether this is an ET search | ms_mascotresfilebase::isErrorTolerant()
not ms_mascotresfile::doesSectionExist(SEC_ERRTOLSUMMARY) | Often used in conjunction with ms_mascotresfile::isErrorTolerant() to detect a manual ET search (aka old-style ET search) | ms_mascotresfilebase::isErrorTolerant() && not(ms_searchparams::getErrTolParentFilename() == "") (not enough to test ms_searchparams::getERRORTOLERANT())
ms_mascotresfile::doesSectionExist(SEC_SPECTRAL_LIBRARY)
or ms_mascotresfile::doesSectionExist(SEC_LIBRARYSUMMARY)
or ms_mascotresfile::doesSectionExist(SEC_LIBRARYPEPTIDES) 		Often used to detect a spectral library search ms_mascotresfilebase::anySpectraLibraryMatches()
ms_mascotresfile::doesSectionExist(SEC_CROSSLINK_SUMMARY)
or ms_mascotresfile::doesSectionExist(SEC_CROSSLINK_PEPTIDES) 		Often used to detect a crosslink search ms_mascotresfilebase::anyCrosslinkedMatches()
ms_mascotresfile::getSectionValueStr(SEC_HEADER)
ms_mascotresfile::enumerateSectionKeys(SEC_HEADER) 		Read values from the results file header Either use ms_searchparams methods (preferred) or the lower level ms_mascotresfilebase::getHeaderKeyValues()
ms_mascotresfile::getSectionValueStr(SEC_PARAMETERS)
ms_mascotresfile::enumerateSectionKeys(SEC_PARAMETERS) 		Read search parameters directly Either use ms_searchparams methods (preferred) or the lower level ms_mascotresfilebase::getSearchParametersKeyValues()
ms_mascotresfile::getSectionValueStr(SEC_MASSES)
ms_mascotresfile::enumerateSectionKeys(SEC_MASSES) 		Read fixed mod and variable mod masses directly Either use ms_searchparams methods (preferred) or the lower level ms_mascotresfilebase::getMassesKeyValues()
ms_mascotresfile::getSectionValueStr(SEC_PEPTIDES)
or other peptides section 		Often used in places where new type of data has been added to the results file, but before new Parser API had been introduced. Replace with a suitable higher-level API method, usually ms_peptide or ms_peptidesummary.
ms_mascotresfile::getSectionValueStr(SEC_PEPTIDES, "q1_p1_na_diff") | Concrete example of the above | New methods introduced in 3.0, ms_mascotresults::getErrTolOriginalNaSeq(), ms_mascotresults::getErrTolModifiedNaSeq()
ms_mascotresfile::getQuerySectionValueStr()
ms_mascotresfile::enumerateQuerySectionKeys() 		Read query-level attributes directly Create ms_inputquery and use its methods
ms_mascotresfile::anyPeptideSummaryMatches(SEC_*) | Are there any peptide matches of the specified type? | Use one of: ms_mascotresfilebase::anyFastaMatches(), ms_mascotresfilebase::anySpectraLibraryMatches(), ms_mascotresfilebase::anyErrorTolerantMatches(), ms_mascotresfilebase::anyCrosslinkedMatches()

Windows compiler support

Support for Visual Studio 2012 and 2013 has now been dropped. The Parser libraries have been compiled with VS2015 and support the VS2015-VS2022 runtime.

The MinGW static and shared libraries are now compiled with GCC 7.1.0. If you use the static Parser library with MinGW, please use GCC 7.1.0 or later.

Linux compiler support

Parser on Linux is now compiled with GCC 5.5.0. If you use the static Parser library, please use GCC 5.5 or later. The shared library may work with earlier compiler versions.

Upgrading to Mascot Parser 2.8.x from 2.7.x

Windows compiler support

Support for 32-bit Windows has been dropped.

Linux compiler support

Static libraries for Intel Parallel Studio XE 2016 and later are no longer shipped with Parser. Please use the GCC 4.8.5 compiled libraries, which are binary compatible with the Intel compiler.

Error tolerant search changes

Mascot Server 2.8 added target-decoy support for error tolerant searches. The results file has new sections et_decoy_summary and et_decoy_peptides, which are analogous to et_summary/decoy_summary and et_peptides/decoy_peptides, respectively. Parser classes automatically read the new sections if they are present.

If the error tolerant search is from Server 2.8 or later, error tolerant matches now have expect values denoting statistical significance. See Error tolerant searches for more information.

If the error tolerant search is from Server 2.7 or earlier, expect values are not available. Previous Parser versions reported a non-zero, numerically incorrect value. It's best to check the return value of ms_mascotresults::getPeptideExpectationValue(): if it's -1, expect value is not available.

MinProbability and IgnoreIonsScoreBelow

If the search is error tolerant and from Server 2.8 or later, Parser applies separate significance thresholds (minProbability) to first pass and second pass (ET) matches. These are available through ms_mascotresults::getProbabilityThreshold() and ms_mascotresults::getErrTolProbabilityThreshold(). The active thresholds may differ from the minProbability parameter passed to the constructor if the TargetFDR parameter is specified.

Because there are two thresholds, IgnoreIonsScoreBelow is restricted to only two values, making it into a binary choice.

  • IgnoreIonsScoreBelow=0: all matches are shown.
  • IgnoreIonsScoreBelow=-1: only statistically significant matches are shown.

In the latter case, Parser uses either the first or the second pass threshold to suppress non-significant matches.

If the search is not error tolerant, IgnoreIonsScoreBelow operates as an expect value or score filter like in previous versions. The value -1 ("automatic") is available in both ET and non-ET searches.

MS1 quantitation

Parser now has complete support for MS1 quantitation using Mascot Distiller project files. See Quantitation analysis for Mascot Server and Distiller.

Upgrading to Mascot Parser 2.7.x from 2.6.x

Windows Compiler support

Support for Visual Studio 2005, 2008 and 2010 has been dropped.

Linux compiler support

Support for GCC 4.1 and Intel Parallel Studio XE 2013 has been dropped. Static libraries are now compiled with GCC 4.8.5 and Intel Parallel Studio XE 2016. The shared libraries remain compatible with GCC versions older than 4.8.

Support for 32-bit Linux has been dropped.

Reading crosslinked search results

Mascot 2.7 introduced support for intact crosslinking and cleavable crosslinking. The results file contains a new section for intact crosslinked matches.

The default mode in Parser 2.7 and later is to mimic 2.6. That is, if you use the default flags, for example from get_ms_mascotresults_params(), then the file is opened in "linear-only" mode. If you want to see the intact crosslinked peptide matches, specify MSPEPSUM_CROSSLINK_INTEGRATED as the special mode flag to the ms_peptidesummary constructor.

Opening the files in Parser 2.6 and earlier is possible. Older versions will simply ignore intact crosslinked matches. If there are any matches with monolinks, however, client code will report the intact linker mass as the modification delta.

See Crosslinked search results for more information.

Upgrading to Mascot Parser 2.6.1 from 2.6.0

The matrix_science::ms_spectral_lib_file::FILE_FORMAT enum has been replaced by the matrix_science::ms_spectral_lib::FILE_FORMAT enum.

Upgrading to Mascot Parser 2.6.x from 2.5.x

Reading spectral library search results

Mascot 2.6 introduced integrated spectral library searches, where the peak lists are searched simultaneously against FASTA database(s) and NIST-format spectral libraries. The results file contains additional sections for spectral library metadata and matches to library entries. There are no changes to the non-library sections of the file.

Opening the files in Parser 2.5 and earlier requires no changes to your code; the file works as if it contained no spectral library data.

The default mode in Parser 2.6 and later is to mimic 2.5. That is, if you use the default flags, for example from get_ms_mascotresults_params(), then the file is opened in "Mascot-only" mode. If you want to see the library matches, specify either MSPEPSUM_SL_INTEGRATED or MSPEPSUM_SL_ONLY as the special mode flag to the ms_peptidesummary constructor.

See Spectral libraries for more information.

Modification Statistics

In Mascot 2.6, Modification Statistics are based on modifications observed in rank 1 significant matches assigned to a protein hit, whereas they used to be based on matches which could be in the unassigned list.

This change applies to methods matrix_science::ms_mascotresults::getNumDiscoveredFixedMods(), matrix_science::ms_mascotresults::getNumDiscoveredVariableMods(), matrix_science::ms_mascotresults::getNumDiscoveredLocalMods(), matrix_science::ms_mascotresults::getDiscoveredLocalModNames(), matrix_science::ms_mascotresults::getNumDiscoveredErrTolMods(), matrix_science::ms_mascotresults::getDiscoveredErrTolModNames(), matrix_science::ms_mascotresults::getDiscoveredErrTolModDeltas(), matrix_science::ms_mascotresults::getNumDiscoveredLibraryMods(), matrix_science::ms_mascotresults::getNumDiscoveredNonSpecCleavage() .

Upgrading to Mascot Parser 2.5.x from 2.4.x

Specifying xml schema file locations

In Mascot Parser, functions and classes that access Unimod or Quantitation XML configuration files require the schema files in order to validate the XML content. The required schema files are supplied with Mascot Parser in the config directory. The Mascot result files, (accessed using the ms_mascotresfile class), also contain a copy of the relevant part(s) of the XML configuration files that were used during the search. In Mascot 2.4 and earlier, some ms_mascotresfile member functions, or functions that pass a ms_mascotresfile object also require the relevant schema file. To avoid having to specify the schema file in multiple places, a directory can now be passed to the constructor to specify the location of the schema files. Additionally, a new function: setXMLschemaFilePath() may be called for finer grained access.

To ensure backward compatibility, it was necessary to add an additional parameter (with a default value) to ms_mascotresfile::getUnimod. If you are using this function, then this version of Mascot Parser is backward compatible with your existing code. However to simplify your code, if you have passed the relevant directory to the ms_mascotresfile constructor, then you may wish to remove the call to ms_umod_configfile::setSchemaFileName and then pass 'true' as useSchemaFromResfile when calling ms_mascotresfile::getUnimod.

It is strongly recommended that applications using Mascot Parser now:

  • Ship all the *.xsd files in the Mascot Parser config directory.
  • Specify the directory that contains these files in the ms_mascotresfile constructor.
  • Replace any calls to ms_mascotresfile::getQuantitation with ms_mascotresfile::getQuantitationMethod
  • Pass 'NULL' or 0 for the quantSchemaFilePath and unimodSchemaFilePath parameters to the ms_aahelper constructor

ms_mascotresfile now inherits from ms_errors

For consistency and simplicity, ms_mascotresfile now inherits from ms_errors.

The enumerated definitions for errors declared in error numbers are now deprecated. The error numbers defined at ms_errs::err should be used instead for new applications. The numbers for the two lists are the same and have not been changed in any version of Parser, thus ensuring backward compatibility.

The following functions

  • ms_mascotresfile::getNumberOfErrors
  • ms_mascotresfile::getErrorNumber
  • ms_mascotresfile::getErrorString
  • ms_mascotresfile::appendErrors

just call the relevant ms_errs functions.

ms_connection_settings additions

In Mascot Parser 2.1 and later, it is possible to download and parse configuration files from a remote Mascot Server using http. When accessing these files remotely, for example, using ms_enzymefile it is necessary to supply an ms_connection_settings object. In versions prior to 2.5, when the Mascot Server has authentication enabled, an http username and password needed to be supplied in the url for the ms_enzymefileobject. In Parser 2.5 and later, it is more convenient to supply these values using: ms_connection_settings::setHttpUsername and ms_connection_settings::setHttpPassword

User group based modification privacy. ms_umod_configfile and ms_modfile behaviour changes

Mascot Server 2.5 now allows locally defined modifications to have restricted access based on user groups. If security is enabled then Mascot Parser 2.5 will check these restrictions and remove modifications from the ms_modfile and ms_modfile object instances. During construction, passing a valid ms_connection_settings object with a session_id into these instances will apply the restrictions for that user. If no ms_connection_settings object is used then the default session will be employed. This behaviour will work for both fat and thin client applications.

Windows Compiler support

Support for Visual Studio 6 and VS2003 has been dropped.

Support for VS2010 and VS2012 has been added.

Windows SDK 2003 SP1 required for Visual Studio 2005

Upgrading to Mascot Parser 2.4.x from 2.3.x

Multiple modifications for the same site

For all versions of Mascot, it has been possible to search using multiple variable modifications for the same residue. In this case, Mascot searches for one modification or the other on each particular site. It never searches for both modifications being applied to the same site.

In Mascot Server 2.4 and later, it is possible to search for two modifications being applied to the same site. This is most useful with chemical labels used for quantitation, so it is currently only implemented when using a Quantitation method with exclusive modifications. For example, with a SILAC method, where the label is Label:13C(6)15N(2), it is also possible to specify Acetyl (K) as a variable modification. When Mascot is searching for the 'heavy' SILAC component it will look for:

  • a labelled K (delta 8 Da) or
  • a labelled K plus the Acetyl - a total delta of 8 + 42 = 50

The function matrix_science::ms_peptide::getVarModsStr() returns a single string from the q1_p1= line in the results file as before. A new function matrix_science::ms_peptide::getSummedModsStr() returns a new string of the same format.

For example, consider the case where the SILAC label is specified as an exclusive modification, and Methyl (KR) and Acetyl (K) are both specified as variable modifications.

In the case where K1 has the SILAC label + Methylation and K6 has the SILAC label + Acetyl, the results file would contain:

delta1=42.010565,Acetyl (K)
NeutralLoss1=0.000000
. . .
delta3=14.015650,Methyl (KR)
NeutralLoss3=0.000000
. . .
delta6=8.014199,Label:13C(6)15N(2) (K)
NeutralLoss6=0.000000

q3_p1=2,1057.657852,0.000561,8,KQLATKAAR,17,06000060000, . .
q3_p1_summed_mods=03000010000

matrix_science::ms_peptide::getVarModsStr() would return "06000060000" and matrix_science::ms_peptide::getSummedModsStr() would return "03000010000"

This new functionality is only available when MULTI_SITE_MODS is defined in the search input and this is not enabled by default. See matrix_science::ms_searchparams::getMULTI_SITE_MODS

When using matrix_science::ms_aahelper, use the new overloaded version of createPeptide with the summedMods and summedModsNL parameters. The varModVector passed to matrix_science::ms_aahelper::setAvailableModifications should obviously include the summed mods and the variable mods.

Upgrading to Mascot Parser 2.3.x from 2.2.x

Percolator

In Mascot 2.3 and later, ms-ms searches can also be run through Percolator, and the Percolator scores can then be shown in the Mascot reports. See Using Percolator scores for details.

Support for searching multiple fasta files

There is now support for searching multiple fasta files. A search against a single fasta file will create a results file similar to that in Mascot 2.2. However, when searching multiple fasta files, remember that the same accession may exist in different fasta databases. The following are additional/changed functions that may be useful:

  • matrix_science::ms_searchparams::getNumberOfDatabases - [new function]
  • matrix_science::ms_searchparams::getDB - [function updated]
  • matrix_science::ms_mascotresfile_dat::getFastaPath - [function updated]
  • matrix_science::ms_mascotresfile_dat::getFastaVer - [function updated]
  • matrix_science::ms_mascotresfile_dat::getNumResidues - [function updated]
  • matrix_science::ms_mascotresfile_dat::getNumSeqs - [function updated]
  • matrix_science::ms_mascotresults::getProtein - [function updated]
  • matrix_science::ms_mascotresults::getProteinMass - [function updated]
  • matrix_science::ms_mascotresults::getProteinDescription - [function updated]
  • matrix_science::ms_protein::getDB - [new function]
  • matrix_science::ms_peptidesummary::ms_peptidesummary - [function updated for single hit]

New protein inferencing

New protein grouping. See Using MSRES_CLUSTER_PROTEINS. Software needs to specify the new flag and call matrix_science::ms_mascotresults::getNextFamilyProtein as described in Using MSRES_CLUSTER_PROTEINS

Caching results

It is now possible (but not required) to cache results. This is fully described in Caching Mascot Results

Support for Quantitation 2

An updated schema, version 2.1 (quantitation_2.xsd) is supplied with Mascot Parser 2.3. Version 1.0 was supplied with Mascot Parser 2.x and version 2.0 was supplied with Mascot Distiller 2.3. To support files (for example results files) with quantation_1 and quantation_2 formats, both schema must be made made available.

The following calls worked with Mascot Parser 2.1 and 2.2, but will fail with Mascot Parser 2.3 and Quantiation 2:

  $objResFile = new msparser::ms_mascotresfile("F001234.dat");
  $objQuantFile = new msparser::ms_quant_configfile();
  if ($objResFile->getQuantitation($objQuantFile)) {
    # abort on fatal error. Note that isValid() remains true if there are only warnings
    unless ($objQuantFile->isValid) {
    . . .
  }

The schema filenames now need to be set before the getQuantitation() call as described in ms_mascotresfile::getQuantitation

Upgrading to Mascot Parser 2.2.x from 2.1.x

Please contact Matrix Science support if you experience any issues upgrading from Parser 2.1 or earlier.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Deprecated List

Deprecated List
Member ms_fragmentationrules::getFirstSerie ()
Use getFirstSeries().
Member ms_fragmentationrules::getLastSerie ()
Use getLastSeries().
Member ms_group::GROUPID_INTEGRA_SYSTEM
The Mascot Integra system group, only member is normally USERID_INTEGRA_SYSTEM. Users will never be able to log in as this user - it is only used from the Integra server.
Member ms_http_client_search::sessionId () const
Use getSessionID()
Member ms_license::ms_license ()
Warning: This class just reads licenses for Mascot version 2.4.x and earlier
Member ms_license::ms_license (const char *filename)
Warning: This class just reads licenses for Mascot version 2.4.x and earlier
Member ms_license::read_file ()
Warning: This class just reads licenses for Mascot version 2.4.x and earlier
Member ms_license::setFileName (const char *filename)
Warning: This class just reads licenses for Mascot version 2.4.x and earlier
Member ms_mascotoptions::getMudpit () const
For Mascot 2.2 and later, use getMudpitSwitch() and getSelectSwitch().
Member ms_mascotoptions::isShowSubsets () const
See getShowSubsets().
Member ms_mascotoptions::setShowSubsets (const bool value)
See setShowSubsets(const double).
Member ms_mascotresfile_dat::err
- use ms_errs::err instead
Member ms_mascotresfilebase::get_ms_mascotresults_params (const ms_mascotoptions &opts, unsigned int *gpFlags, double *gpMinProbability, int *gpMaxHitsToReport, double *gpIgnoreIonsScoreBelow, unsigned int *gpMinPepLenInPepSummary, bool *gpUsePeptideSummary, unsigned int *gpFlags2) const
This function is deprecated. All new code should use ms_mascotresfilebase::get_ms_mascotresults_params(const ms_mascotoptions &, ms_mascotresults_params &) instead, as all the parameters are encapsulated in the ms_mascotresults_params class.
Member ms_mascotresfilebase::getQuantitation (ms_quant_configfile *qfile) const =0
See getQuantitationMethod() which is generally easier to use.
Member ms_mascotresfilebase::setPercolatorFeatures (const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes)
This function is deprecated and has been replaced with matrix_science::ms_mascotresfilebase::setPercolatorFeatures(const ms_mascotoptions&, const char*, const std::vector<std::string>&).
Member ms_mascotresfilebase::staticGetPercolatorFileNames (const char *szFileName, const char *cacheDirectory, const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes, std::vector< std::string > &filenames, std::vector< bool > &exists)
This function is deprecated and has been replaced with matrix_science::ms_mascotresfilebase::staticGetPercolatorFileNames(const char*, const char*, const ms_mascotoptions&, const char *, const std::vector<std::string>&, std::vector<std::string>&, std::vector<bool>&).
Member ms_mascotresults::FC_ALL_PEPTITDES
Unfortunate spelling error, please use FC_ALL_PEPTIDES which has an identical value.
Member ms_mascotresults::findProteinsByAccession (const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
See findProteins() with the ms_mascotresults::FT_PROTEIN_ACCESSION flag.
Member ms_mascotresults::findProteinsByDescription (const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
See findProteins() with the ms_mascotresults::FT_PROTEIN_DESCRIPTION flag.
Member ms_mascotresults::getProbOfPepBeingRandomMatch (const double score, const int query) const
Use getPeptideExpectationValue().
Member ms_mascotresults::getProbOfProteinBeingRandomMatch (const double score) const
Use getProteinExpectationValue().
Member ms_mascotresults::getQmatch (const int query, const ms_mascotresfile_dat::section sec) const
This method is deprecated in favour of ms_mascotresfilebase::getQmatch
Member ms_mascotresults::getQmatch (const int query) const
This method is deprecated in favour of ms_mascotresfilebase::getQmatch
Member ms_modification::copyMassFile (const ms_masses *massFile)
Do not use.
Member ms_ms1quant_charge_state::getBucket (int index, unsigned &scanId, double &area) const
see getBucket(const int, int, unsigned &, double &)
Member ms_ms1quant_time_align::getFinalResults ()
This function is deprecated and now calls the more accurately named getShiftsToConsensus()
Member ms_ms1quant_time_align::getFinalResults () const
This function is deprecated and now calls the more accurately named getShiftsToConsensus()
Member ms_ms1quantitation::getSummary () const
Use getPeptideSummary() instead.
Member ms_peptidesummary::getSrcRank (int q, int p) const
This method is only useful with files in dat28 format.
Member ms_peptidesummary::getSrcSection (int q, int p) const
This method is only useful with files in dat28 format.
Member ms_processors::getHyperThreadedCPUsMask () const
Use isPrimaryLogicalProcessor(), getCoreFromLogical() and getPhysicalFromLogical() instead.
Member ms_processors::getWhichAvailableForMascot () const

Use isLogicalCPUAvailableForMascot() instead.

Use getWhichAvailableForMascot2

Member ms_protein::getSimilarProteinDB () const
Use ms_protein::getSimilarProteins(), ms_mascotresults::getNextSimilarProtein() or ms_mascotresults::getNextSimilarProteinOf() instead.
Member ms_protein::getSimilarProteinName () const
Use ms_protein::getSimilarProteins(), ms_mascotresults::getNextSimilarProtein() or ms_mascotresults::getNextSimilarProteinOf() instead.
Member ms_quant_component::dropFileIndex ()
After version 2.7.2, multiple file indexes are supported per component
Member ms_quant_component::getFileIndex () const
After version 2.7.2, multiple file indexes are supported per component and this just returns the first one.
Member ms_quant_component::haveFileIndex () const
After version 2.7.2, multiple file indexes are supported per component
Member ms_quant_component::setFileIndex (const int file_index)
After version 2.7.2, multiple file indexes are supported per component and this just sets the first one.
Member ms_quant_integration::dropMassDelta ()
Not in use.
Member ms_quant_integration::dropMassDeltaUnit ()
Not in use.
Member ms_quant_integration::dropPrecursorRange ()
Do not use.
Member ms_quant_integration::dropProcessingOptions ()
Do not use.
Member ms_quant_integration::getMassDelta () const
Not in use.
Member ms_quant_integration::getMassDeltaSchemaType () const
Not in use.
Member ms_quant_integration::getMassDeltaUnit () const
Not in use.
Member ms_quant_integration::getMassDeltaUnitSchemaType () const
Not in use.
Member ms_quant_integration::getPrecursorRange () const
Do not use.
Member ms_quant_integration::getPrecursorRangeSchemaType () const
Do not use.
Member ms_quant_integration::getProcessingOptions () const
Do not use.
Member ms_quant_integration::getProcessingOptionsSchemaType () const
Do not use.
Member ms_quant_integration::haveMassDelta () const
Not in use.
Member ms_quant_integration::haveMassDeltaUnit () const
Not in use.
Member ms_quant_integration::havePrecursorRange () const
Do not use.
Member ms_quant_integration::haveProcessingOptions () const
Do not use.
Member ms_quant_integration::setMassDelta (const char *value)
Not in use.
Member ms_quant_integration::setMassDeltaUnit (const char *value)
Not in use.
Member ms_quant_integration::setPrecursorRange (const char *value)
Do not use.
Member ms_quant_integration::setProcessingOptions (const std::string value)
Do not use.
Member ms_quant_multiplex::dropIonSeries ()
Replaced with clearIonSeries().
Member ms_quant_multiplex::setIonSeries (const std::string ionSeries)
Replaced with appendIonSeries().
Member ms_quant_precursor::dropAllChargeStates ()

Moved to ms_quant_integration.

Moved to ms_quant_integration.

Member ms_quant_precursor::dropAllowElutionShift ()

Moved to ms_quant_integration.

Moved to ms_quant_integration.

Member ms_quant_precursor::getAllChargeStatesSchemaType () const
Moved to ms_quant_integration.
Member ms_quant_precursor::getAllowElutionShiftSchemaType () const
Moved to ms_quant_integration.
Member ms_quant_precursor::haveAllChargeStates () const
Moved to ms_quant_integration.
Member ms_quant_precursor::haveAllowElutionShift () const
Moved to ms_quant_integration.
Member ms_quant_precursor::isAllChargeStates () const
Moved to ms_quant_integration.
Member ms_quant_precursor::isAllowElutionShift () const
Moved to ms_quant_integration.
Member ms_security::getIntegraUsers () const
Mascot Integra is not supported in Mascot Parser 2.5 and later.
Member ms_security_options::getIntegraAppServerURL () const
Mascot Integra is not supported in Mascot Parser 2.5 and later.
Member ms_security_options::getIntegraDatabaseName () const
Mascot Integra is not supported in Mascot Parser 2.5 and later.
Member ms_security_options::getIntegraOracleServerName () const
Mascot Integra is not supported in Mascot Parser 2.5 and later.
Member ms_security_options::setIntegraAppServerURL (std::string newVal)
Mascot Integra is not supported in Mascot Parser 2.5 and later.
Member ms_security_options::setIntegraDatabaseName (std::string newVal)
Mascot Integra is not supported in Mascot Parser 2.5 and later.
Member ms_security_options::setIntegraOracleServerName (std::string newVal)
Mascot Integra is not supported in Mascot Parser 2.5 and later.
Member ms_security_tasks::MISECTASK_ACCESS
INSIGHT: Access to Mascot Insight.
Member ms_security_tasks::MISECTASK_ADDCUSTOMREPORT
INSIGHT: Add custom report to Mascot Insight.
Member ms_security_tasks::MISECTASK_ADDEXCLUSIONFILE
INSIGHT: Add BlastCluster exclusion file.
Member ms_security_tasks::MISECTASK_ADDIMPORTFILTER
INSIGHT: Add import assignment filter.
Member ms_security_tasks::MISECTASK_ADMIN
INSIGHT: Mascot Insight administration functions.
Member ms_security_tasks::MISECTASK_DELETECUSTOMREPORT
INSIGHT: Delete custom report Mascot Insight.
Member ms_security_tasks::MISECTASK_DELETEEXCLUSIONFILE
INSIGHT: Delete BlastCluster exclusion file.
Member ms_security_tasks::MISECTASK_PROTEINAPPROVAL
INSIGHT: Protein approval in Mascot Insight.
Member ms_security_tasks::MISECTASK_SENDNOTIFICATION
INSIGHT: Send notification.
Member ms_security_tasks::SECTASK_INTEGRASYSTEMACCOUNT
CLIENT: Integra system account.
Member ms_session::ms_session (const std::string userName, const std::string connectionID, const std::string database)
Mascot Integra is not supported in Mascot Parser 2.5 and later.
Member ms_user::USER_INTEGRA
Mascot Integra is not supported in Mascot Parser 2.5 and later. Login etc. is done through Mascot Insight.
Member ms_user::USERID_INTEGRA_SYSTEM
Mascot Integra is not supported in Mascot Parser 2.5 and later.
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Modules

Modules
Here is a list of all modules:
[detail level 123]
▼ Installing Mascot Parser
Perl toolkit installation
▼ C++ toolkit installation
C++ toolkit installation on Windows
C++ toolkit installation on Unix
Java toolkit installation
Python toolkit installation
C# toolkit installation
▼ Getting started with Mascot Parser
Quickstart: how to open a results file
Using the toolkit from C++
Using the toolkit from Perl, Java, Python and C#
Garbage collection problems (advanced reading)
Multithreading (advanced reading)
▼ Mascot results file module
Examples for the results file module
UML Class Diagram
Issues with backward compatibility for results files
Error Handling
Peptide mass fingerprint mixtures
Grouping proteins together
Unassigned peptides list
Treatment of duplicate peptides
Detecting ambiguous peptide matches
Error tolerant searches
Crosslinked search results
Using the singleHit parameter to return a single protein
Automated repeating of searches
Target-decoy searches and false discovery rate
Using Percolator scores
Caching Mascot Results
Combining multiple results files
Query-level modifications
Spectral libraries
Spectral library score threshold (advanced reading)
▼ Mascot configuration files module
Configuration files
Examples for the configuration files module
Fixed values for quantitation.xml
Fixed values for crosslinking.xml
▼ Mascot security and authentication module
Using the Mascot security module
Examples for the Mascot security module
▼ Mascot utilities and tools module
Examples for the Mascot tools module
Spectral library Classes
▼ Error handling and logging
Error Handling
Logging using ms_loggingmonitor
Examples for error handling in Mascot Parser modules
▼ Quantitation analysis for Mascot Server and Distiller
Peptide and protein quantitation
Accessing Distiller Quantitation Results
Accessing Distiller Multi-file Quantitation Results
Extracting quantitation results with the Distiller toolkit
Source code for the Shapiro-Wilk W test algorithm
Examples for the Mascot Parser quantitation module
▼ Classes for calculating masses of peptides and fragments.
Examples for the mass calculation module
▼ Accessing a Mascot Server using HTTP
HTTP Communication to a Mascot Server
Examples for the Mascot http client module
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Installing Mascot Parser

Modules
Installing Mascot Parser

Modules

Perl toolkit installation
C++ toolkit installation
Java toolkit installation
Python toolkit installation
C# toolkit installation

Detailed Description

This section provides information on installing Mascot Parser on your chosen platform. It also gives general instructions on how to write (and compile) programs that use Mascot Parser. For more detailed information about using Mascot Parser in a particular programming language, see Getting started with Mascot Parser.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Perl toolkit installation

Perl toolkit installation
Installing Mascot Parser

To use the toolkit, an appropriate version of Perl must be installed.

Installation on Windows

Supported versions (Windows)

The supported versions of Perl on Windows are 64-bit versions 5.24, 5.26, 5.28, 5.30 and 5.32 of ActiveState ActivePerl and Strawberry Perl. ActivePerl is available for download from https://www.activestate.com/. Strawberry Perl can be downloaded from https://strawberryperl.com/.

Determine which version of Perl you are using (Windows)
To find out which version of perl you have, type the following at a command prompt:
    perl -v
This will report the Perl version and copyright. The first line gives the version number. For example:
This is perl 5, version 26, subversion 2 (v5.26.2) built for MSWin32-x64-multi-thread

If it reports built for MSWin32-x64... then the 64 bit version of Mascot Parser is required. If it reports built for MSWin32-x86... then the 32 bit version of Mascot Parser is required. In this case, please use Parser 2.7 or earlier.

Find the correct version of the Mascot Parser Files (Windows)
The correct Mascot Parser files will be in the following directories:
Perl version | Directory
ActivePerl/Strawberry Perl 5.24.x | perl524
ActivePerl/Strawberry Perl 5.26.x | perl526
ActivePerl/Strawberry Perl 5.28.x | perl528
ActivePerl/Strawberry Perl 5.30.x | perl530
ActivePerl/Strawberry Perl 5.32.x | perl532
Copy the two files to a suitable location (Windows)
To use Mascot Parser in your program, the files msparser.pm must either be in the same directory as your program, or in a directory searched by the Perl interpreter.
In either case, msparser.dll must be copied into a subdirectory auto\msparser that is relative to msparser.pm. For example:
C:\msparser\perl526>dir

Directory of C:\msparser\perl526

19/07/2019  08:56    <DIR>          .
19/07/2019  08:56    <DIR>          ..
19/07/2019  08:56    <DIR>          auto
18/07/2019  15:59           582,464 msparser.pm
               1 File(s)        582,464 bytes
               3 Dir(s)  862,835,568,640 bytes free

C:\msparser\perl526>dir auto\msparser

Directory of C:\msparser\perl526\auto\msparser

19/07/2019  15:05    <DIR>          .
19/07/2019  15:05    <DIR>          ..
18/07/2019  16:34        25,823,927 msparser.dll
               1 File(s)     25,823,927 bytes
               2 Dir(s)  862,835,568,640 bytes free
Define the module path (Windows)
If the msparser.pm file is not in the current directory, there are four alternative ways to define the module search path:

  1. Define or modify PERL5LIB:
    You can define the PERL5LIB environment variable to point to the directory where Mascot Parser Perl files are located.

  2. Add use lib into your program:
    You can use the lib module to add the directory where Mascot Parser Perl files are located to the module search path:

    use lib 'c:\path\to\msparser\perl_files';

  3. Use the -I command-line flag:
    You can use the -I command-line flag when running Perl to add a directory to the module search path.

  4. Global installation:
    You can copy the Mascot Parser Perl files to C:\Perl\site\lib directory as follows:
    • Copy msparser.pm into C:\Perl64\site\lib
    • Make a directory C:\Perl64\site\lib\auto\msparser
    • Copy msparser.dll into C:\Perl64\site\lib\auto\msparser
    (The directories above assume that ActivePerl is installed in C:\Perl64).
Install Microsoft Runtime Libraries (Windows)
You may also need to install the Microsoft Visual C++ 2015 Update 1 (or later) Redistributable Package
To check if you need this:
  1. Download and run depends.exe from https://www.dependencywalker.com/ or Dependencies program from https://github.com/lucasg/Dependencies
  2. Open msparser.dll in the program.
  3. If it reports that the dependent MSVCR140.dll and MSVCP140.dll are missing, download the Visual C++ 2015 Update 1 (or later) redistributable package from the Microsoft Download Center: https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0
  4. Choose vc_redist.x64.exe for 64-bit
Test the installation (Windows)
Type the following at a command prompt:
    perl -e "use msparser;"
This should give no output and just return to the command prompt.

Installation on Linux platforms

Supported versions (Linux)

Different releases and builds of Perl are supported on 64-bit Linux. Support for 32-bit Linux has been discontinued. This version of Mascot Parser provides the following builds of the Perl module:

.so filename | Linux - 64bit
msparser516-thread-multi_64.so | X
msparser518-thread-multi_64.so | X
msparser520-thread-multi_64.so | X
msparser522-thread-multi_64.so | X
msparser524-thread-multi_64.so | X
msparser526-thread-multi_64.so | X
msparser528-thread-multi_64.so | X
msparser530-thread-multi_64.so | X
msparser532-thread-multi_64.so | X
msparser534-thread-multi_64.so | X
msparser536-thread-multi_64.so | X

You need to determine which .so file matches your version of Perl, and then make a soft link or rename it to msparser.so.

Determine which version of Perl you are using (Linux)
To find out which version of perl you have, type the following at a shell prompt:
perl -v
This will report the Perl version and copyright. The first line gives the version number. For example:
This is perl 5, version 26, subversion 1 (v5.26.1) built for x86_64-linux-thread-multi
Find the correct version of the Mascot Parser Files (Linux)
The correct Mascot Parser files will be in the following directories:
Perl version | Directory
5.16.x | perl516
5.18.x | perl518
5.20.x | perl520
5.22.x | perl522
5.24.x | perl524
5.26.x | perl526
5.28.x | perl528
5.30.x | perl530
5.32.x | perl532
5.34.x | perl534
5.36.x | perl536
Determine Perl build options (Linux)

In earlier versions of Parser, the naming convention of the shared library was:

msparser[ver][-thread][-multi][-64int][_64].so

This version of Parser only ships with:

msparser[ver]-thread-multi_64.so

For reference, the build options [-thread], [-multi] and [-64int] refer to the following:

[-thread]

Type perl -V (note the uppercase V) and look for the line starting usethreads or useithreads. For example:

   usethreads=define useithreads=define ...

If usethreads is define, then you will need an .so file with -thread in the name. (This option is no longer supported in Mascot Parser)

[-multi]

Type perl -V (as above) and look for the line containing usemultiplicity. If it is define, then you will need an .so file with -multi in the name. (This option is no longer supported in Mascot Parser)

[-64int]

Type perl -V (as above) and look for the line containing use64bitint. If it is define, then you will need an .so file with -64int in the name. (This option is no longer supported in Mascot Parser)

[_64]

Type perl -V (as above) and look for the line containing ptrsize. For example:

  intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678

If ptrsize is 8, then you will need an .so file with _64 in the name.

If any of the required build options are missing, we recommend compiling Perl from source or installing a supported version of ActiveState ActivePerl from https://activestate.com.

Copy the two files to a suitable location (Linux)
To use Mascot Parser in your program, the file msparser.pm must either be in the same directory as your program, or in a directory searched by the Perl interpreter.
  • In both cases, msparser.so must be in the directory auto/msparser relative to msparser.pm.
  • In that directory, make a soft link msparser.so to the msparser[ver]-thread-multi_64.so file
Define the module path (Linux)
If the msparser.pm file is not in the current directory, there are four alternative ways to define the module search path:

  1. Define or modify PERL5LIB:
    You can define the PERL5LIB environment variable to point to the directory where Mascot Parser Perl files are located.

  2. Add use lib into your program: You can use the lib module to add the directory where Mascot Parser Perl files are located to the module search path:

    use lib '/path/to/msparser/perl_files';

  3. Use the -I command-line flag: You can use the -I command-line flag when running Perl to add a directory to the module search path.

  4. Global installation: You can copy the Mascot Parser Perl files to the site_perl directory as follows. Note that the exact path will depend on your distribution and how Perl has been configured; the following example is from CentOS 7 64-bit:
    • Copy msparser.pm into /usr/local/lib64/perl5/site_perl/5.16.3/x86_64-linux-thread-multi/
    • Make a directory /usr/local/lib64/perl5/site_perl/5.16.3/x86_64-linux-thread-multi/auto/msparser
    • Copy msparser516-thread-multi.so into /usr/local/lib/perl5/site_perl/5.16.3/x86_64-linux-thread-multi/auto/msparser
    • Make a soft link msparser.so in /usr/local/lib/perl5/site_perl/5.16.1/x86_64-linux-thread-multi/auto/msparser

Using the Perl toolkit

Reasonable proficiency in Perl programming will be required. Please see Quickstart: how to open a results file and Examples for the results file module.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: C++ toolkit installation

Modules
C++ toolkit installation
Installing Mascot Parser

Modules

C++ toolkit installation on Windows
C++ toolkit installation on Unix

Detailed Description

To use the toolkit, reasonable proficiency in C++ programming is required. Internally, the library makes extensive use of different STL containers, but this is 'hidden' from the user of the toolkit. A working C++ compiler is required on any platform.

The following compilers are supported. Directory refers to a subdirectory in the unpacked Mascot Parser directory tree. Note that not all compiler directories are present in every Mascot Parser package.

Platform | Directory | Compiler
Windows (x86-win64) | vs2015 – compatible with VS2015-VS2022 | Microsoft Visual Studio 2015 (Update 1)
Windows (x86-win64) | mingw | Minimal GNU for Windows (MinGW) 5.0.2 using GNU g++ 7.1.0
Linux (x86_64) | gcc | GNU g++ 5.5.0 or later

Other compilers have not been tested with Mascot Parser, and are unlikely to work.

The Visual Studio 2015 (toolset v140) static and shared libraries are binary compatible with VS2015-VS2022, as explained in https://docs.microsoft.com/en-us/cpp/porting/binary-compat-2015-2017

See C++ toolkit installation on Windows for details on installing the development kit under Microsoft Windows, and C++ toolkit installation on Unix for installing under supported Unix platforms.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: C++ toolkit installation on Windows

C++ toolkit installation on Windows
Installing Mascot Parser » C++ toolkit installation

Directory structure

Directory | Files | Description
compiler/include | msparser.hpp and a number of other include files. | You only need to #include "msparser.hpp" – this includes the other files. Make sure that this directory is on your include path.
compiler/lib | msparser.lib msparserD.lib msparserDS.lib msparserS.lib msparser.dll msparserD.dll | Mascot Parser library file; see Choosing the correct DLL file and Using the MinGW compiler.
compiler/example_cxx | *.cpp build_all.cmd | Source code for C++ examples. These can all be built from the command line using the build_all.cmd command. Make sure that the C++ compiler is on the system path when running build_all.cmd.

Using Visual C++

Choosing the correct DLL file

For Microsoft Visual C++, there are three choices:

Debug or release builds.

It is normally necessary to use the debug build of Mascot Parser with a debug build of your application, and the release build for release builds of your application.

If the wrong build of msparser.dll is used, then, for example, Mascot Parser will be using the non-debug version of the Microsoft run time library, while application code will be using the debug version. Since pointers to memory are being passed between msparser and application code, they need to use the same RTL. Note however, that the debug version can be very slow with very large files.

Static or dynamically linked.

A statically linked library has the advantage that you won't need to ship any extra modules with your application. The disadvantage is increased executable size.

With a dynamically linked library, the advantage is that if there is a bug fix or an enhancement in Mascot Parser, then you would only need to ship a patched version of the msparser.dll file. The disadvantage is, of course, having to ship the file with the application.

Unicode or MBCS.
Use whichever version your application uses. However, note that Mascot only saves single byte characters in the results files, so separate unicode builds of the library are not required and will not be supplied in version 2.2 and later.

The filenames for the .lib and .dll files and the directories for the test harness are shown below:

Debug | Static | .lib name | .dll name | Directory
 |  | msparser.lib | msparser.dll | Win32_Release
 | X | msparserS.lib | n/a | Win32_ReleaseS
X |  | msparserD.lib | msparserD.dll | Win32_Debug
X | X | msparserDS.lib | n/a | Win32_DebugS

Compiler Options

When compiling against the static libraries, you need to add the following definition in your source code, or add it to the project file:

#define _MATRIX_USE_STATIC_LIB

If in doubt, check the options in the appropriate test harness.

Note the following:

  • When using the DLL versions, you must compile your application using the multithreaded DLL runtime library. You cannot use the statically linked runtime.

  • When using the statically linked library versions, you must compile your application using multithreaded or multithreaded debug runtime library. You cannot use the DLL runtime libraries.

  • When using the MFC library with Visual C++ compiler, you must specify the /FORCE:MULTIPLE linker option to avoid an error message about a duplicate operator new() symbol in debug configurations.

Where to install msparser.dll

Mascot Parser is being used by some mass spectrometer vendors. This means that there is the possibility that another version of the DLL may be installed on the computer. To avoid any possible conflict, it is strongly recommended that you do not install this DLL in the system32 directory, but just put it in your application directory.

Compiling examples from the command line

It is possible to compile the Windows C++ examples from the command line rather than creating a project. For example, to build using the static library:

  C:\>cl -D _MATRIX_USE_STATIC_LIB /MT /EHsc -I ..\include resfile_error.cpp
    /link ../lib/msparserS.lib ws2_32.lib advapi32.lib wininet.lib /OPT:NOREF

There is a cmd file, build_all.cmd, in the C++ examples directory that builds all the examples.

Using the MinGW compiler

The mingw/lib directory contains three files:

File | Description
libmsparser.a | Static library without debugging information.
msparser.dll | DLL for use with applications compiled using MinGW
libmsparser_import.a | Import library for use when compiling an application to be dynamically linked with msparser.dll

To compile and link one of the example programs statically:

  $ g++ -D _MATRIX_USE_STATIC_LIB  -I ../include -L ../lib  resfile_summary.cpp -lmsparser -lwininet -lwinhttp -lws2_32 -lgdi32 -lole32

To compile and link one of the example programs dynamically:

  $ g++ -I ../include  -L ../lib  resfile_summary.cpp -lmsparser_import

In this case, you will need to make sure that msparser.dll is in the same directory as the .exe file or is located on the system path.

If you are using MSYS2, and if you are getting mysterious compiler errors or undefined types, make sure you are using the MinGW64 toolchain shell, not the MSYS2 shell.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: C++ toolkit installation on Unix

C++ toolkit installation on Unix
Installing Mascot Parser » C++ toolkit installation

Directory structure

Directory | Files | Description
gnu/include | msparser.hpp and a number of other include files. | You only need to #include "msparser.hpp" – this includes the other files. Make sure that this directory is on your include path.
gnu/lib | libmsparser.a | Static library for C++ development, and can be linked against as long as one of the supported compilers is used.
 | libmsparser.so.1 | Shared library for C++ development, and can potentially be used by compilers other than mentioned here.
gnu/example_cxx | *.cpp | Source code for C++ examples.

Installation and compilation under Linux

One version of the libraries is supplied. The libraries in the gnu directory are compiled using GNU g++ 5.5.0. These are compatible with both GNU g++ 5.5.0 or later and the Intel® C++ Compiler if you use GCC 5.5.0 or later as the underlying toolchain.

There are four ways to link Mascot Parser in your program:

  1. Static library using GNU g++
  2. Static library using Intel® C++ Compiler
  3. Shared library using GNU g++
  4. Shared library using Intel® C++ Compiler

The static library file is gnu/lib/libmsparser.a, while the shared library file is gnu/lib/libmsparser.so.1. To use libmsparser.so.1 in its existing directory, simply add the directory to LD_LIBRARY_PATH. Under bash and sh, for example, you can do:

    export LD_LIBRARY_PATH=/path/to/msparser/gnu/lib:$LD_LIBRARY_PATH

You also need to make a soft link to the .so file:

    cd /path/to/msparser/gnu/lib
    ln -s libmsparser.so.1 libmsparser.so

Remove the soft link if you want to revert to using the static library.

Optionally, you can install the shared library in /usr/local/lib:

  1. cp libmsparser.so.1 /usr/local/lib
  2. cd /usr/local/lib
  3. ln -s libmsparser.so.1 libmsparser.so
  4. ldconfig -v

Static library using GNU g++

To compile the example code in the example_cxx directory and statically link to Mascot Parser, use the following command:

    g++ -m64 -D__LINUX64__ -D_GLIBCXX_USE_CXX11_ABI=0 -I../include -pthread -static resfile_summary.cpp -L../lib -lmsparser

This will produce a binary that has no dependencies on any shared libraries.

Static library using Intel® C++ Compiler

The library gnu/lib/libmsparser.a has been built without -Kpic. It has been compiled using the GNU stdc++ library.

It may be possible to build a binary that links to all C and C++ libraries statically using the Intel® C++ Compiler (Parallel Studio or OneAPI). The Intel® C++ compiler is binary compatible with libraries compiled with GCC 5.5.0 or later. Please consult the Intel® compiler documentation for suitable command-line arguments and switches.

Shared library using GNU g++

To compile the example code in the example_cxx directory, use the following command:

    g++ -m64 -D__LINUX64__ -D_GLIBCXX_USE_CXX11_ABI=0 -I../include -pthread resfile_summary.cpp -L../lib -lmsparser

This will produce a binary that has dependencies on libmsparser.so and on the GNU stdc++ and C libraries (use ldd a.out to list the dependencies). In some versions of GCC, you may also need to use the flag -static-libstdc++ to link statically to the GNU stdc++ library.

Shared library using Intel® C++ Compiler

To compile the example code in the example_cxx directory and dynamically link to Mascot Parser, use the following command:

    icpc -D__LINUX64__ -I../include resfile_summary.cpp -pthread  -L../lib -lmsparser

This will produce a binary that has dependencies on libmsparser.so, the Intel® compiler libraries, libstdc++ and glibc (use ldd a.out to list the dependencies). In some versions of the compiler, the dependency on the Intel® compiler libraries can again be removed by using the -i-static flag.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Java toolkit installation

Java toolkit installation
Installing Mascot Parser

To use the toolkit, an appropriate version of Java Development Kit must be installed.

Installation on Windows

Mascot Parser Java toolkit has been tested with Oracle/Sun JDK versions 1.6.0_31 (Java SE 6) and 1.7.0_3 (Java SE 7). The Java Development Kit for Windows is available for download from http://www.oracle.com/technetwork/java/javase/downloads/.

You may also need to install the Microsoft Visual C++ 2012 Update 3 (or later) Redistributable Package
To check if you need this:

  1. Download and run depends.exe from http://www.dependencywalker.com/ or Dependencies program from https://github.com/lucasg/Dependencies
  2. Open msparserj.dll in the program.
  3. If it reports that the dependent MSVCR140.dll and MSVCP140.dll are missing, download the Visual C++ 2015 (or later) redistributable package from the Microsoft Download Center: https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0
  4. Choose vc_redist.x64.exe for 64-bit

To use Mascot Parser, both msparserj.dll and msparser.jar must be accessible by your program.

msparserj.dll must be visible on the PATH

Either put msparserj.dll in your program directory or modify the PATH environment variable to include the directory where msparserj.dll is located.

Alternatively, the location of msparserj.dll can be specified explicitly in your program. To do this, instead of using the System.loadLibrary() method used in the examples, call the System.load() method. For example,

    static {
        try {
            System.load("C:/temp/parser/msparserj.dll");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. " + e);
            e.printStackTrace();
            System.exit(1);
        }
    }

msparser.jar must be present on your Java Classpath

You can either define the classpath when running java.exe or javac.exe by specifying the -classpath option, or modify the CLASSPATH environment variable. We recommend that you place the msparser.jar archive in a readily accessible location and define the classpath on the command line to include msparser.jar as required.

Installation on Unix platforms

Mascot Parser Java toolkit has been tested with Oracle/Sun JDK version 1.6.0_45 (Java SE 6). The Java Development Kit is available for download from http://www.oracle.com/technetwork/java/javase/downloads/. The Mascot Parser Java toolkit should also be compatible with OpenJDK, which can be installed from the package repository of most recent Linux distributions. The Mascot Parser Java toolkit requires glibc-2.5 or later and libstdc++-6.0.8 or later.

To use Mascot Parser, both libmsparserj.so and msparser.jar must be accessible by your program.

libmsparserj.so must be visible on LD_LIBRARY_PATH

You have two choices: either put libmsparserj.so in your program directory or put it in some other readily accessible location. In the first case, you need to add the working directory (.) to LD_LIBRARY_PATH; in the second, the full path to the directory where libmsparserj.so resides.

Modifying LD_LIBRARY_PATH can be done under bash and sh as follows:

    LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/some/path"; export LD_LIBRARY_PATH

Note that this change is temporary. Consult your operating system manual how to make the change permanent.

Alternatively, the location of libmsparserj.so can be specified explicitly in your program. To do this, instead of using the System.loadLibrary() method used in the examples, call the System.load() method. For example:

    static {
        try {
            System.load("/tmp/parser/libmsparserj.so");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. " + e);
            e.printStackTrace();
            System.exit(1);
        }
    }

msparser.jar must be present on your Java Classpath

You can either define the classpath when running java or javac by specifying the -classpath option, or modify the CLASSPATH environment variable We recommend that you place the msparser.jar archive in a readily accessible location and define the classpath on the command line to include msparser.jar as required.

Building and running the Java examples in Windows

Open a command prompt, and change to the example_java directory.

To compile (for example) resfile_params.java:

    javac -classpath .;../java/msparser.jar resfile_params.java

To run the example:

    java -classpath .;../java/msparser.jar resfile_params F981123.dat

Building and running the Java examples in Unix

Open a terminal window, and change to the example_java directory.

To compile (for example) resfile_params.java:

    LD_LIBRARY_PATH="$LD_LIBRARY_PATH:../java" javac -classpath .:../java/msparser.jar resfile_params.java
Note
This command temporarily sets LD_LIBRARY_PATH to include the java directory, where libmsparserj.so resides.

To run the example:

    LD_LIBRARY_PATH="$LD_LIBRARY_PATH:../java" java -classpath .:../java/msparser.jar resfile_params F981123.dat

Using the Java toolkit

Reasonable proficiency in Java programming will be required. Please see Quickstart: how to open a results file and Examples for the results file module.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Python toolkit installation

Python toolkit installation
Installing Mascot Parser

To use the toolkit, a Python interpreter must be installed.

On Windows, all versions of 64-bit Python 3, version 3.6 or later, are supported. We recommend the official Python (CPython) from https://python.org, but the module should also work with:

  • ActiveState ActivePython (CPython compatible) from https://www.activestate.com/
  • Gregory Szorc's standalone build (CPython compatible) from https://gregoryszorc.com/docs/python-build-standalone/main/

Other Python builds may work but have not been officially tested.

On Linux, all versions of 64-bit Python 3, version 3.6 or later, are supported. Python can be installed from the package repository of most Linux distributions, and it can also be downloaded and compiled from source from from https://python.org/.

The Parser module has been compiled using Python's stable API and should be binary compatible with all Python versions from 3.6 and up. Please contact us if you require Mascot Parser for a different version of Python.

Note
Mascot Parser Python modules are not Unicode-aware. Make sure that any string objects you pass as parameters to Mascot Parser functions are non-Unicode string objects.

To use Mascot Parser in your program, the files msparser.py and _msparser.pyd (_msparser.so on Linux) must either be in the same directory as your program, or in a directory searched by the Python interpreter. In the latter case, there are three alternatives.

Define or modify PYTHONPATH:

You can define the PYTHONPATH environment variable to point to the directory where Mascot Parser Python files are located.

  • Setting PYTHONPATH

Use sys.path.append():

You can use sys.path.append() in your program to add the directory where Mascot Parser files are located to the module search path. This is equivalent to modifying PYTHONPATH, except that the path is hardcoded in your program.

Global installation:

You can copy the Mascot Parser Python files to the site-packages directory of your Python installation.

  • In Windows, assuming CPython 3.11 or ActivePython 3.11, this could be C:\Python311\Lib\site-packages. The exact path depends on where Python was installed. Please refer to the official Python documentation: https://docs.python.org/3/using/windows.html#windows-finding-modules
  • In Linux, this is similar to /usr/local/lib/python3.11/site-packages, assuming Python 3.11. The exact path depends on where Python was installed.

Visual C++ Redistributable Package (Windows)

You may also need to install the Microsoft Visual C++ 2015 (or later) Redistributable Package
To check if you need this:

  1. Download and run depends.exe from http://www.dependencywalker.com/ or Dependencies program from https://github.com/lucasg/Dependencies
  2. Open msparser.dll in the program.
  3. If it reports that the dependent MSVCR140.dll and MSVCP140.dll are missing, download the Visual C++ 2015 (or later) redistributable package from the Microsoft Download Center: https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0
  4. Choose vc_redist.x64.exe for 64-bit

Running a Python example on Windows

Open a command prompt, and change to the example_python directory. To run, say, resfile_error.py:

    python.exe resfile_error.py C:\Inetpub\mascot\data\F981119.dat

If python.exe is not in PATH%, prefix the command with the absolute path to python.exe.

Running a Python example on Linux

Open a terminal window, and change to the example_python directory. To run, say, resfile_error.py:

    ./resfile_error.py /usr/local/mascot/data/F981119.dat

This only works if resfile_error.py has the executable bit set, and if the script has the correct "shebang" line. The "shebang" line is the first line of the script, and gives the location of the Python interpreter:

    #!/usr/bin/python

You can use the Python interpreter directly:

    python resfile_error.py /usr/local/mascot/data/F981119.dat

Using the Python toolkit

Reasonable proficiency in Python programming will be required. Please see Quickstart: how to open a results file and Examples for the results file module.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: C# toolkit installation

C# toolkit installation
Installing Mascot Parser

To use the toolkit, an appropriate version of the Microsoft .NET Framework must be installed.

Installation on Windows

Mascot Parser C# toolkit has been built using the Microsoft .NET Framework 4.0 and tested with the .NET Framework 4.5. If not already installed, the .NET 4.5 Framework can be downloaded from http://www.microsoft.com/en-us/download/details.aspx?id=30653.

You may also need to install the Microsoft Visual C++ 2015 Redistributable Package. To check if you need this:

  1. Download and run depends.exe from http://www.dependencywalker.com/ or Dependencies program from https://github.com/lucasg/Dependencies
  2. Open msparsercs.dll in the program.
  3. If it reports that the dependent MSVCR140.dll and MSVCP140.dll are missing, download and install the Visual C++ 2015-2019 redistributable package.

You can download the correct files from Microsoft Download Center:

Missing file | Packages for 32-bit and 64-bit Windows
MSCVR140.dll, MSCVP140.dll | Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 Choose vc_redist.x64.exe for 64-bit

Using Visual Studio

In order to access the Mascot Parser C# toolkit in a C# project in Visual Studio 2015 or later, you must add a reference to matrix_science.msparser.dll to your project. To do this, right click over your project and click on Add Reference... in the context menu. In the window that opens, select the Browse option and then browse to, and select, the matrix_science.msparser.dll file.

Using Mascot Parser in compiled programs

To use Mascot Parser, both matrix_science.msparser.dll and msparsercs.dll must be accessible by your program.

To avoid any possible conflict, it is strongly recommended that you do not install these DLLs in the system32 directory, but just put them in your application directory.

Using the C# toolkit

Reasonable proficiency in C# programming will be required. Please see Quickstart: how to open a results file and Examples for the results file module.

Compiling examples from the command line

It is possible to compile the Windows C# examples from the command line rather than creating a project. The C# compiler is called csc.exe, which you must ensure is on your system path before trying to build the example files. You can do this by opening a Developer command prompt, either from the Visual Studio->Visual Studio Tools folder of your Start menu, or you may had an entry on your Start menu for the installed .NET Framework.

For example, the following would compile config_mascotdat.cs to config_mascotdat.exe

c:\>csc.exe /r:matrix_science.msparser.dll config_mascotdat.cs

All of the examples in the example_csharp directory can all be built from the command line using the build_all.cmd command. Make sure that the C# compiler is on the system path when running build_all.cmd.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Getting started with Mascot Parser

Modules
Getting started with Mascot Parser

Modules

Quickstart: how to open a results file
Using the toolkit from C++
Using the toolkit from Perl, Java, Python and C#
Garbage collection problems (advanced reading)
Multithreading (advanced reading)

Detailed Description

This section gives details on how to use Mascot Parser in the supported programming languages, which in this version are C++, Perl, Java and Python.

  • Quickstart: how to open a results file describes how to write a minimal Mascot Parser program.
  • Using the toolkit from C++ describes C++ memory management conventions.
  • Using the toolkit from Perl, Java, Python and C# describes syntax and idioms when using Mascot Parser from Perl, Java and Python.

Source code examples for each programming language are available in

  • Examples for error handling in Mascot Parser modules
  • Examples for the results file module
  • Examples for the configuration files module
  • Examples for the Mascot security module
  • Examples for the Mascot tools module
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Quickstart: how to open a results file

Quickstart: how to open a results file
Getting started with Mascot Parser

Prelude: linking or importing Mascot Parser

Before Mascot Parser can be used in your program, it must be linked in or imported. Details depend on the programming language.

C++

Details how to link Mascot Parser statically or dynamically to your program depend on the operating system, compiler and linker. Please refer to C++ toolkit installation on Windows and C++ toolkit installation on Unix.

You must include msparser.hpp before using Mascot Parser classes:

    #include "msparser.hpp"

All classes live in the matrix_science namespace. You will either need to import the namespace or explicitly state the namespace before each class name:

    {
        // Import the namespace into the current scope.
        using namespace matrix_science;
        std::unique_ptr<ms_mascotresfilebase> resfile = ms_mascotresfilebase::createResfile(filename);
    }

    // Or explicitly:
    std::unique_ptr<matrix_science::ms_mascotresfilebase> resfile = matrix_science::ms_mascotresfilebase::createResfile(filename);

Perl

Before you can call Parser functions, you need to import the msparser package with use.

    use msparser;

It is also a good idea to enable strict error checking with use strict;. Additionally, if you add use warnings; or use the -w command-line flag, the Perl interpreter will warn you if you try to use constants that are not defined anywhere. This is very useful in checking for typos in names of global constants and enumerated values.

If Mascot Parser Perl libraries are not in the current directory and are not installed in a system-wide path, you must also add the directory of msparser.pm and msparser.dll or msparser.so to the module search path with use lib. For example:

    # On Windows:
    use lib 'c:\path\to\msparser\perl_files';
    use msparser;

    # On Unix:
    use lib '/path/to/msparser/perl_files';
    use msparser;

The use lib statement must precede the use msparser statement.

For more details, see Perl toolkit installation.

All Mascot Parser classes are defined in the msparser package, which you must always prefix to the actual class name. For example, to create a new ms_mascotresfilebase_msr object:

    my $resfile = msparser::ms_mascotresfile_msr->new($filename);

    # However, it is better to use the general method that supports both file types:
    my $resfile = msparser::ms_mascotresfilebase::createResfile($filename);

Java

You need to use the -classpath command-line parameter with javac and java when you compile and run your program. See Building and running the Java examples in Windows and Building and running the Java examples in Unix.

Before you can use Mascot Parser classes, you need to import them from the matrix_science.msparser namespace.

    // Import everything:
    import matrix_science.msparser.*;

    // Import selectively:
    import matrix_science.msparser.ms_mascotresfilebase;
    import matrix_science.msparser.ms_peptidesummary;

In addition to this, the msparserj library must be loaded into your Java class. The following should be added at the top of your Java code before any class method definitions:

    public class MyClass {
        static {
            try {
                System.loadLibrary("msparserj");
            } catch (UnsatisfiedLinkError e) {
                System.err.println("Native code library failed to load. "
                                   + "Is msparserj.dll on the path?\n" + e);
                System.exit(0);
            }
        }

For more details, see Installation on Windows.

Python

Before you can use Parser classes, you need to import them from the msparser package:

    import msparser

Alternatively, you can selectively import a subset of classes:

    from msparser import msparser.ms_mascotresfilebase, msparser.ms_peptidesummary

If Mascot Parser Python libraries are not in the current directory and are not installed in a system-wide path, you must also add the directory of msparser.py and _msparser.dll or _msparser.so to the module search path by appending the directory to sys.path:

    # On Windows:
    import sys
    sys.path.append('C:\path\to\msparser\python_files')
    import msparser

    # On Unix:
    import sys
    sys.path.append('/path/to/msparser/python_files')
    import msparser

sys.path.append must precede the import msparser statement.

For more details, see Python toolkit installation.

All Mascot Parser classes are defined in the msparser package. For example, to create a new ms_mascotresfilebase object:

    resfile = msparser.ms_mascotresfilebase.createResfile(filename)

C#

You need to use the /r:matrix_science.msparser.dll command-line option with csc.exe when you compile your program. You also need to put msparsercs.dll and matrix_science.msparser.dll in the directory containing your executable when you run your program. See Compiling examples from the command line

All Mascot Parser classes live in the matrix_science.msparser namespace. You will either need to import the namespace or explicitly state the namespace before each class name:

    {
        // Import the namespace into the current scope.
        using namespace matrix_science.msparser;
        ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile(filename);
    }

    // Or explicitly:
    matrix_science.msparser.ms_mascotresfilebase resfile = matrix_science.msparser.ms_mascotresfilebase.createResfile(filename);

For more details, see Installation on Windows.

Getting basic information from the results file

Opening a results file is very easy. Simply create an ms_mascotresfilebase object, passing the file name as the only parameter:

C++
    ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile("F001234.msr");
Perl
    my $resfile = msparser::ms_mascotresfile::createResfile("F001234.msr");
Java and C#
    ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile("F001234.msr");
Python
    resfile = msparser.ms_mascotresfilebase.createResfile("F001234.msr")

All data in the results file is accessible using Mascot Parser classes and methods. For example, the search parameters can be found by using the params() method of the resfile object, which returns an ms_searchparams object. The following code be used to find the MODS entry:

C++
    std::string mods = resfile.params().getMODS();
Perl
    my $mods = $resfile->params->getMODS;
Java
    String mods = resfile.params().getMODS();
Python
    mods = resfile.params().getMODS()
C#
    string mods = resfile._params().getMODS();

ms_mascotresfilebase is a base class for ms_mascotresfile_msr (MSR format) and ms_mascotresfile_dat (dat28 format). The concrete classes have methods for reading 'raw' information from the results file. In general, it is easier, faster, and less error-prone to use objects instead of directly reading the character strings from the file. Using objects will also guard your application from changes in the underlying data format.

Getting protein information

ms_mascotresfilebase provides only a low-level view of the results file. You need to create an ms_proteinsummary or ms_peptidesummary object to access protein hits and peptide matches. Which one is needed depends on the type of the search results: a Protein Summary should be used with a peptide mass fingerprint search, while Peptide Summary is more convenient for MS-MS searches.

The easiest and recommended way to choose is to use get_ms_mascotresults_params(). This is a helper function of the resfile object that returns default flags and parameters to use in order to re-create the same report shown by Mascot Server. The function is called with a single argument: an ms_mascotoptions object. If you are running the program on the Mascot Server, this should be fetched from the ms_datfile object; otherwise you can simply pass an empty ms_mascotoptions object.

The following example demonstrates how to fetch the default parameters, and how to select which type of report to open. The scriptName parameter can generally be ignored outside Mascot Server.

C++
    // If running on Mascot Server:

    ms_datfile datfile("../config/mascot.dat");

    ms_mascotresults_params resParams;
    std::string scriptName = resfile.get_ms_mascotresults_params(
        datfile.getMascotOptions(), resParams
    );

    if (resParams.isUsePeptideSummary()) {
        ms_peptidesummary pepsum(
            resfile, resParams
        );

        /* Call pepsum methods... */
    } else {
        ms_proteinsummary proteinsum(
            resfile, resParams
        );

        /* Call proteinsum methods... */
    }

    // If running outside Mascot Server:

    ms_mascotresults_params resParams;
    std::string scriptName = resfile.get_ms_mascotresults_params(
        ms_mascotoptions(), resParams
    );

Perl
    # If running on Mascot Server:

    my $datfile = msparser::ms_datfile->new('../config/mascot.dat');
    my $resParams = msparser::ms_mascotresults_params->new();
    my $scriptName = $resfile->get_ms_mascotresults_params($datfile->getMascotOptions, $resParams);

    if ($resParams->isUsePeptideSummary()) {
        my $pepsum = msparser::ms_peptidesummary->new(
            $resfile, $resParams
        );

        # Call $pepsum methods...
    } else {
        my $proteinsum = msparser::ms_proteinsummary->new(
            $resfile, $resParams
        );

        # Call $proteinsum methods...
    }

    # If running outside Mascot Server:

    my $resParams = msparser::ms_mascotresults_params->new();
    my $scriptName = $resfile->get_ms_mascotresults_params(msparser::ms_mascotoptions->new(), $resParams);

Java
    // If running on Mascot Server:

    ms_datfile datfile = new ms_datfile("../config/mascot.dat");

    ms_mascotresults_params resParams = new ms_mascotresults_params();
    String scriptName = resfile.get_ms_mascotresults_params(
        datfile.getMascotOptions(), resParams
    );

    if (resParams.isUsePeptideSummary()) {
        ms_peptidesummary pepsum = new ms_peptidesummary(
            resfile, resParams
        );

        /* Call pepsum methods... */
    } else {
        ms_proteinsummary proteinsum = new ms_proteinsummary(
            resfile, resParams
        );

        /* Call proteinsum methods... */
    }

    // If running outside Mascot Server:

    ms_mascotresults_params resParams = new ms_mascotresults_params();
    String scriptName = resfile.get_ms_mascotresults_params(
        new ms_mascotoptions(), resParams
    );
Python
    # If running on Mascot Server:

    datfile = msparser.ms_datfile('../config/mascot.dat')
    resParams = msparser.ms_mascotresults_params()
    scriptName = resfile.get_ms_mascotresults_params(datfile.getMascotOptions(), resParams)

    if resParams.isUsePeptideSummary():
        pepsum = msparser.ms_peptidesummary(
            resfile, resParams
            )

        # Call pepsum methods...
    else:
        proteinsum = msparser.ms_proteinsummary(
            resfile, resParams
            )

        # Call proteinsum methods...

    # If running outside Mascot Server:

    resParams = msparser.ms_mascotresults_params()
    scriptName = resfile.get_ms_mascotresults_params(msparser.ms_mascotoptions(), resParams)
C#
    // if running on Mascot server
    ms_mascotresults_params resParams = new ms_mascotresults_params();
    string scriptName = resfile.get_ms_mascotresults_params(
        datfile.getMascotOptions(), resParams
    );

    if (resParams.isUsePeptideSummary())
    {
        ms_peptidesummary pepsum = new ms_peptidesummary(
            resfile, resParams
        );

        /* Call pepsum methods... */
    }
    else
    {
        ms_proteinsummary proteinsum = new ms_proteinsummary(
            resfile, resParams
        );

        /* Call proteinsum methods... */
    }

    // if running outside Mascot server
    ms_mascotresults_params resParams = new ms_mascotresults_params();
    string scriptName = resfile.get_ms_mascotresults_params(
        new ms_mascotoptions(), resParams
    );

Once you have created the summary object, you can access protein hits by calling getHit(). Here is an example how to get the accession string of the top-scoring protein hit.

C++
    ms_protein *top_hit = pepsum.getHit(1);
    std::string acc = top_hit->getAccession();

    std::cout << acc << std::endl;

Perl
    my $top_hit = $pepsum->getHit(1);
    my $acc = $top_hit->getAccession();

    print $acc, "\n";

Java
    ms_protein top_hit = pepsum.getHit(1);
    String acc = top_hit.getAccession();

    System.out.println(acc);

Python
    top_hit = pepsum.getHit(1)
    acc = top_hit.getAccession()

    print(acc)

C#
    ms_protein top_hit = pepsum.getHit(1);
    string acc = top_hit.getAccession();

    Console.WriteLine(acc);

Next steps

  • Using the toolkit from C++
  • Using the toolkit from Perl, Java, Python and C#
  • Examples for error handling in Mascot Parser modules
  • Examples for the results file module
  • Examples for the configuration files module
  • Examples for the Mascot security module
  • Examples for the Mascot tools module
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Using the toolkit from C++

Using the toolkit from C++
Getting started with Mascot Parser

Memory management conventions

Variables are passed by value in C++. When dealing with ms_mascotresfilebase objects that can be as large as the data file on disk (even gigabytes in size), it is obviously good practice to pass a reference or a pointer to such an object instead of calling its copy constructor.

Similarly, if one has a ms_mascotresfilebase object, and one wants to view a portion of it, say a protein hit entry with ms_mascotresults::getHit(), it would be possible to return a copy of the subset of the data file to the caller. But for performance reasons, it is often more desirable to simply return a reference or a pointer to an object internal to the ms_mascotresfilebase object.

This creates a subtle problem with hidden parent-child relationships between objects that is not obvious from the API. If object P returns a reference or a pointer to object C, and P is deallocated, is it still safe to use C? Usually, in Mascot Parser, the answer is no. The reason is that C often has an internal reference to the parent object P, and deallocating P means the reference points to some arbitrary chunk of memory. Calling methods in C, if they happen to reference P, will then cause a segmentation fault.

Two rules of thumb

The rules of thumb elaborated here serve as general guidelines: follow them and you will not introduce subtle bugs that may lead to crashes. In some cases it is possible to break the rule and survive, but this usually requires knowledge of Parser internals. (In other words, don't do it.)

There are two rules of thumb. In both of them, it is assumed both A and B are in the matrix_science namespace, i.e. classes defined in Mascot Parser.

  1. Methods returning a reference or a pointer:

        A* B::func();
    A& B::func();

    You must keep both the returned object and b in memory as long as you use either. Parser owns the returned object, which means you must not deallocate it.

  2. Methods or constructors taking a reference or a pointer:

        B::B(A *a);
    B::B(A &a);

    B::func(A *a);
    B::func(A &a);

    Ownership does not change: if you owned a previously, you still do. However, you must keep both objects in memory as long as you use either.

Beware of implicit deallocation when you allocate things on the stack. The following code will segfault when function print_db_name() is called:

    using namespace matrix_science;

    ms_searchparams& get_parameters(string filename) {
        std::unique_ptr<ms_mascotresfilebase> resfile = ms_mascotresfilebase::createResfile(filename);

        if (!resfile->isValid())
            throw new std::runtime_error(resfile->getLastErrorString());

        return resfile->params(); // PROBLEM HERE
    }

    void print_db_name(string filename) {
        ms_searchparams& params = get_parameters(filename);
        std::cout << params->getDB() << std::endl; // CRASH HERE
    }

The resfile object gets deallocated at the end of get_parameters(), as it is allocated on the stack. This means the object referenced by params in print_db_name() will also be deallocated (because Parser owns the ms_searchparams object) and havoc ensues.

Examples of the rules of thumb

    ms_mascotresfilebase resfile = ms_mascotresfilebase::createResfile(filename);
    ms_searchparams& params = resfile.params();
    ms_inputquery q1(resfile, 1);

Rule of thumb 1: resfile must be kept in memory for as long as you use params.

Rule of thumb 2: resfile must be kept in memory for as long as you use q1.

    ms_mascotresfilebase resfile = ms_mascotresfilebase::createResfile(filename);
    ms_peptidesummary pepsum(resfile);
    ms_protein* hit = pepsum.getHit(1);

Rule of thumb 1: pepsum must be kept in memory for as long as you use hit. Do not deallocate hit; it belongs to Parser.

Rule of thumb 2: resfile must be kept in memory for as long as you use pepsum.

    ms_datfile datfile();
    const ms_databases* dbs = datfile.getDatabases();

Rule of thumb 1: datfile must be kept in memory for as long as you use dbs. Do not deallocate dbs; it is owned by Parser.

    ms_quant_configfile qf();
    bool success = resfile.getQuantitation(&qf);

Rule of thumb 2: resfile must be kept in memory for as long as you use qf.

Using Apache Xerces and Parser in the same application

Parser uses the XML parser library Apache Xerces internally to read and write XML configuration files. Xerces symbols are in the xercesc namespace, which is an alias of the version-specific namespace. For example, Xerces 3.1 namespace is xerces_3_1.

If your application also links against Xerces, special care may need to be taken depending on the platform (Windows or Linux) and whether you're linking against the dynamic or static version of Parser. If your application does not use Xerces, you can ignore the rest of this section.

Origin of the problem

Xerces mandates that the global constructor xercesc::XMLPlatformUtils::Initialize() is called before any other Xerces method calls, and the global destructor xercesc::XMLPlatformUtils::Terminate() called after the last Xerces method call. Normally these calls are done at the start and end of main() or in a global application constructor and destructor class.

Parser calls both Initialize() and Terminate() internally. The Initialize() function takes as parameters pointers to an error handler and a memory manager, which are assigned to variables shared by Xerces methods inside the library.

If your application links against both Parser and Xerces, it is possible (see below) that the application ends up with only one copy of Xerces. The linker may silently choose one or the other copy of Xerces depending on linking order and how the static or shared Parser was constructed. This means that if you also call xercesc::XMLPlatformUtils::Initialize() (with or without your own error handler), it can corrupt the internal Xerces pointers. You will either receive no error messages or the application will crash while using Xerces or Parser methods.

Xerces and statically linked Parser

The statically linked Parser calls Initialize() and Terminate() as needed. The calls are balanced exactly, so that when a Parser class or method uses Xerces, Initialize() is called right before and Terminate() right after the Xerces calls.

When you link statically against both Parser and Xerces, the linker on both Windows and Linux will include only one copy of Xerces in the final application. This is fine as long as you are very careful about when and how you use Xerces. Only use Xerces strictly before or strictly after any calls to Parser functions, and never interleave the two.

Consider the following singlethreaded example:

  1. Program starts.
  2. Call xercesc::XMLPlatformUtils::Initialize() within your application.
  3. Do some XML processing with Xerces.
  4. Call xercesc::XMLPlatformUtils::Terminate() within your application.
  5. Create ms_datfile and read options from mascot.dat.
  6. Create ms_mascotresfilebase.
  7. Create ms_peptidesummary and iterate over hits.
  8. Delete or free the Parser objects.
  9. Call xercesc::XMLPlatformUtils::Initialize() within your application.
  10. Do some XML processing with Xerces.
  11. Call xercesc::XMLPlatformUtils::Terminate() within your application.
  12. Program ends.

This sequence is safe, because Xerces is deinitialised before steps 5-7 and there are no explicit calls to Xerces between steps 5-7. Parser may call xercesc::XMLPlatformUtils::Initialize() and xercesc::XMLPlatformUtils::Terminate() some number of times in steps 5-7. After step 8, Parser will have deinitialised Xerces; the calls are balanced exactly. This means step 9 is safe, and as long as there are no Parser calls in steps 2-4 and 9-11, the program will work as expected.

Note that there are additional restrictions concerning Xerces in multithreaded applications; see Multithreading (advanced reading).

Xerces and dynamically linked Parser on Windows

The Windows DLL version of Parser does not suffer from the problem. The shared library contains its own, separate copy of Xerces, which is initialised and deinitialised in DllMain(), right before and after your application starts. You can link against Xerces and the two libraries will not conflict.

Xerces and dynamically linked Parser on Linux

The Linux shared library version of Parser may export Xerces symbols depending on the compiler and linker. The library initialises Xerces in a library constructor function before main() is run, and deinitialises in a library destructor function after main(). Although Parser does not export the internal Xerces variables, the implementation within Parser refers to them internally. It is possible that the final application contains only the Parser implementation or only the other implementation of Xerces. In this case, using Xerces methods either explicitly in your application or implicitly through Parser will almost certainly cause a crash, whether you call xercesc::XMLPlatformUtils::Initialize() or not.

The only way to avoid the problem is to move your copy of Xerces in a different namespace (e.g. my_xercesc). To do this, you need to either change the default namespace of Xerces and recompile it, or create a statically linked wrapper library. This may not be an option of you are linking against Xerces installed as a system library.

Another way to avoid the problem is to use a different version of Xerces. Parser 2.5 uses Xerces 3.1. Xerces namespaces are versioned, so you could use Xerces 3.0 or 3.2 or any other version and the linker should keep the two implementations separate. Future versions of Parser may use a different version of Xerces, though.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Using the toolkit from Perl, Java, Python and C#

Using the toolkit from Perl, Java, Python and C#
Getting started with Mascot Parser

On this page:

  • The matrix_science namespace in Perl, Java, Python and C#
  • Using enumerated values and static const ints in Perl, Java, Python and C#
  • Type equivalence between C++ and Perl, Java, Python and C#
  • Passing objects to functions in Perl, Java, Python and C#
  • Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#
  • Catching C++ exceptions in Perl, Java, Python and C#
  • Default parameters in Perl, Java, Python and C#
  • Static functions in Perl, Java, Python and C#
  • Object initialising functions in Perl, Java, Python and C#
  • Multiple return values in Perl, Java, Python and C#
  • Maintaining object references: two rules of thumb

The matrix_science namespace in Perl, Java, Python and C#

All Mascot Parser classes are defined in the matrix_science namespace. When you use Mascot Parser from Perl, Java or Python, these objects are available in a package or class.

Perl

All classes are available in the msparser package. For example, the class matrix_science::ms_mascotresfilebase is accessible as msparser::ms_mascotresfilebase.

Java

All classes are available in the matrix_science.msparser package. For example, the class matrix_science::ms_mascotresfilebase is accessible as matrix_science.ms_parser.ms_mascotresfilebase.

Python

All classes are available in the msparser class. For example, the class matrix_science::ms_mascotresfilebase is accessible as msparser.ms_mascotresfilebase.

C#
All classes are available in the matrix_science.msparser namespace. For example, the class matrix_science::ms_mascotresfilebase is accessible as matrix_science.msparser.ms_mascotresfilebase.

Using enumerated values and static const ints in Perl, Java, Python and C#

Using enumerated values and static const ints in Perl, Java and Python

In the documentation for ms_mascotresfilebase, the following 'enum' definition is used:

    enum FLAGS {
      RESFILE_NOFLAG,
      RESFILE_USE_CACHE,

These values are available in the following way in the class they are defined in:

Perl
    $msparser::ms_mascotresfilebase::RESFILE_NOFLAG

Java
    ms_mascotresfilebase.RESFILE_NOFLAG

Python
    msparser.ms_mascotresfilebase.RESFILE_NOFLAG

Using enumerated values in C#

In C#, enum values are wrapped as proper C# enums. The enum values are the available in the following way in the class and enumeration they are defined in:

C#
    ms_mascotresfilebase.FLAGS.RESFILE_NOFLAG

To use enumeration values as function parameters in C#, you will need to cast the enum value to the required parameter type, usually an int or uint. For example, to use the ms_mascotresfilebase.willCreateCache method, the flags parameter needs to be cast to a uint :

    string cachefile;
    bool will_create_cache = ms_mascotresfilebase.willCreateCache(
        "F981123.dat",
        (uint) matrix_science.msparser.ms_mascotresfilebase.FLAGS.RESFILE_USE_CACHE,
        new matrix_science.msparser.ms_mascotoptions().getCacheDirectory(),
        out cachefile
    );

Type equivalence between C++ and Perl, Java, Python and C#

Some values are converted automatically between C++ and the calling code. If a function returns, say, std::string, this is equivalent to a native string object.

In short:

C++ | Perl | Java | Python | C#
std::string const std::string & char * const char * | ordinary Perl string | String | non-Unicode string object | string
int long float double | ordinary number | int long float double | ordinary number object | int long float double
bool | ordinary number (0 means false, any other number means true) | boolean | Bool | bool
std::string & | usually a return value; see Multiple return values in Perl, Java, Python and C# | StringBuffer | usually a return value; see Multiple return values in Perl, Java, Python and C# | out string
int & |  | int[] |  | out int
unsigned int & |  | long[] |  | out uint

Some keywords have a different interpretation:

C++ | Perl | Java | Python | C#
const | can be ignored | roughly equivalent to final but see special case const std::string & | can be ignored | roughly equivalent to C# const but see special case const std::string &
inline virtual | can be ignored

Passing objects to functions in Perl, Java, Python and C#

In Perl, Java, Python and C# all objects are references. The same is not true in C++, where a variable can point to the object in three different ways. All three ways are collated transparently into references, which means you do not need to worry about it. Objects can be passed to C++ functions as they are.

You can recognise the three different ways easily. The three following lines all declare a function that takes an object as a parameter:

    void func1(ms_mascotresfile_msr resfile);
    void func2(ms_mascotresfile_msr &resfile);
    void func3(ms_mascotresfile_msr *resfile);

These three functions would all take an object reference in Perl, Java and Python:

Perl
    my $resfile = msparser::ms_mascotresfile_msr->new(...);
    func1($resfile);
    func2($resfile);
    func3($resfile);

Java
    ms_mascotresfile_msr resfile = new ms_mascotresfile_msr(...);
    func1(resfile);
    func2(resfile);
    func3(resfile);

Python
    resfile = msparser.ms_mascotresfile_msr(...)
    func1(resfile)
    func2(resfile)
    func3(resfile)

C#
    ms_mascotresfile_msr resfile = new ms_mascotresfile_msr(...);
    func1(resfile);
    func2(resfile);
    func3(resfile);

For example, take a function such as ms_fileutilities::getLastModificationTime():

    static time_t getLastModificationTime(const char *filename, ms_errs *err=NULL);

The function expects an ms_errs object as a parameter. You can simply pass an object reference:

Perl
    my $errs = msparser::ms_errs->new();
    my $time = msparser::ms_fileutilities::getLastModificationTime($filename, $errs);

    if (!$errs->isValid()) {
        ...
    }

Java
    ms_errs errs = new ms_errs();
    int time = ms_fileutilities.getLastModificationTime(filename, errs);

    if (!errs.isValid()) {
        ...
    }

Python
    errs = msparser.ms_errs()
    time = msparser.ms_fileutilities.getLastModificationTime(filename, errs)

    if not errs.isValid() :
        ...

C#
    ms_errs errs = new ms_errs();
    long time = ms_fileutilities.getLastModificationTime(filename, errs);

    if (!errs.isValid()) {
        ...
    }

Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#

Some functions take or return arrays of values. In C++, these are called vectors, and each vector can only store values of one particular type. std::vector is the "Standard Template Library" (STL) class for vectors. std::vector<int> can only store integer values, while std::vector<std::string> can only store string values. An example function that both returns a vector and takes vectors as arguments is getAllProteinsWithThisPepMatch(). When calling such functions, you must create a vector object of the correct type:

Perl
    my $vectorOfInts    = new msparser::vectori;       # For std::vector<int>
    my $vectorOfLongs   = new msparser::vectorl;       # For std::vector<long>
    my $vectorOfDoubles = new msparser::vectord;       # For std::vector<double>
    my $vectorOfBools   = new msparser::vectorb;       # For std::vector<bool>
    my $vectorOfStrings = new msparser::VectorString;  # For std::vector<std::string>

Java and C#
    vectori vectorOfInts    = new vectori();           # For std::vector<int>
    vectorl vectorOfLongs   = new vectorl();           # For std::vector<long>
    vectord vectorOfDoubles = new vectord();           # For std::vector<double>
    vectorb vectorOfBools   = new vectorb();           # For std::vector<bool>
    VectorString vectorOfStrings = new VectorString(); # For std::vector<std::string>

Python
    vectorOfInts    = msparser.vectori()      # For std::vector<int>
    vectorOfLongs   = msparser.vectorl()      # For std::vector<long>
    vectorOfDoubles = msparser.vectord()      # For std::vector<double>
    vectorOfBools   = msparser.vectorb()      # For std::vector<bool>
    vectorOfStrings = msparser.VectorString() # For std::vector<std::string>

The different vector classes share a common interface, as shown next.

Perl

Vectors are similar to Perl arrays, but with two differences: appending and modifying items is more restricted, and vectors are strictly typed. Strict typing means that if you try to append an integer to VectorString, for example, you will get a runtime exception. See Catching C++ exceptions in Perl, Java, Python and C#.

    # Create a vector of size 0. (In this example, we'll use integer vectors.)
    my $vector = new msparser::vectori;
    # Create a vector of any size, say 20. Items will be initialised to undef.
    my $vector2 = new msparser::vectori(20);

    # Append a value at the end of the vector.
    $vector->push(100);
    $vector->push(200);

    # Get the number of items in the vector. Vector indices run from 0
    # to $size - 1.
    my $size = $vector->size();

    # Get item at any index. If the index is out of range (negative or
    # greater than $size - 1), an exception will be thrown.
    my $val = $vector->get(1);

    # Set the value of item at a given index. After this call, $vector
    # is [200, 200].
    $vector->set(0, 200);

    # Remove the last item of the vector and return its value. If
    # $vector->size() is zero, this will throw an exception.
    $val = $vector->pop();

    # Predicate testing whether the vector is empty (equivalent to
    # testing $vector->size == 0).
    if ($vector->empty) { ... }

    # Iterate over all items in the vector.
    for my $i (0 .. $vector->size-1) {
        print $vector->get($i), "\n";
    }

    # Clear the vector, i.e. remove all of its elements.
    $vector->clear();

Java

STL vectors are similar to Java Vectors; std::vector<int> is analogous to Vector<int>. However, there is no compile-time type checking, which means that if you try to append values to the vector that are not of the correct type, a runtime exception will be thrown. See Catching C++ exceptions in Perl, Java, Python and C#.

    // Create a vector of size 0. (In this example, we'll use integer vectors.)
    vectori vector = new vectori();
    // Create a vector of any size, say 20. Items will be initialised to null.
    vectori vector2 = new vectori(20);

    // Append a value at the end of the vector.
    vector.push(100);
    vector.push(200);

    // Get the number of items in the vector. Vector indices run from 0
    // to size - 1.
    int size = vector.size();

    // Get item at any index. If the index is out of range (negative or
    // greater than size - 1), an exception will be thrown.
    int val = vector.get(1);

    // Set the value of item at a given index. After this call, 'vector'
    // contains values [200, 200].
    vector.set(0, 200);

    // Remove the last item of the vector and return its value. If
    // vector.size() is zero, this will throw an exception.
    int val = vector.pop();

    // Predicate testing whether the vector is empty (equivalent to
    // testing vector.size() == 0).
    if (vector.empty()) { ... }

    // Iterate over all items in the vector.
    for (int i = 0; i != vector.size(); i++)
        System.out.println(vector.get(i));

    // Clear the vector, i.e. remove all of its elements.
    vector.clear();

Python

Vectors are similar to Python arrays, but with two differences: appending and modifying items is more restricted, and vectors are strictly typed. Strict typing means that if you try to append an integer to VectorString, you will get a runtime exception. See Catching C++ exceptions in Perl, Java, Python and C#.

    # Create a vector of size 0. (In this example, we'll use integer vectors.)
    vector = msparser.vectori()
    # Create a vector of any size, say 20. Items will be initialised to None.
    vector2 = msparser.vectori(20)

    # Append a value at the end of the vector. If the value is not of
    # the correct type (integer for vectori, string for VectorString, etc.),
    # an exception will be thrown. See below how to catch it.
    vector.append(100)
    vector.append(200)

    # Get the number of items in the vector. Vector indices run from 0
    # to size - 1.
    size = len(vector)

    # Get item at any index. If the index is out of range (negative or
    # greater than size - 1), an exception will be thrown.
    val = vector[1]

    # Set the value of item at a given index. After this call, vector
    # is [200, 200]. If the index is out of range, an exception will be
    # thrown.
    vector[0] = 200

    # Remove the last item of the vector and return its value. If
    # vector.size() is zero, this will throw an exception.
    val = vector.pop_back()

    # Predicate testing whether the vector is empty (equivalent to
    # testing len(vector) == 0).
    if vector.empty()
        ...

    # Iterate over all items in the vector.
    for item in vector:
        print(item)

    # Clear the vector, i.e. remove all of its elements.
    vector.clear()

C#

STL vectors are similar to C# Lists; std::vector<int> is analogous to List<int>. However, there is no compile-time type checking, which means that if you try to append values to the vector that are not of the correct type, a runtime exception will be thrown. See Catching C++ exceptions in Perl, Java, Python and C#.

    // Create a vector of size 0. (In this example, we'll use integer vectors.)
    vectori vector = new vectori();
    // Create a vector of any size, say 20. Items will be initialised to null.
    vectori vector2 = new vectori(20);

    // Append a value at the end of the vector.
    vector.Add(100);
    vector.Add(200);

    // Get the number of items in the vector. Vector indices run from 0
    // to size - 1.
    int size = vector.Count;

    // Get item at any index. If the index is out of range (negative or
    // greater than size - 1), an exception will be thrown.
    int val = vector[1];

    // Set the value of item at a given index. After this call, 'vector'
    // contains values [200, 200].
    vector[0] = 200;

    // Remove the last item of the vector and return its value. If
    // vector.size() is zero, this will throw an exception.
    val = vector[size-1];
    vector.RemoveAt(size-1);

    // Predicate testing whether the vector is empty (equivalent to
    // testing vector.size() == 0).
    if (vector.Count == 0) {  }

    // Iterate over all items in the vector.
    for (int i = 0; i != vector.Count; i++)
        Console.WriteLine(vector[i]);

    // Clear the vector, i.e. remove all of its elements.
    vector.Clear();

Here is an example how to call a method that takes vectors of multiple types as arguments.

Perl
    my $start = new msparser::vectori;
    my $end   = new msparser::vectori;
    my $pre   = new msparser::VectorString;
    my $post  = new msparser::VectorString;
    my $frame = new msparser::vectori;
    my $multiplicity = new msparser::vectori;
    my $db    = new msparser::vectori;
    my $accessions = $pepsum->getAllProteinsWithThisPepMatch(
        1, 1, $start, $end, $pre, $post, $frame, $multiplicity, $db
    );

In the API documentation, the method getAllProteinsWithThisPepMatch() returns a VectorString. However, any vector returned from a function is automatically converted into an array reference in Perl.

You can access the elements of each vector by using the get() method, and calling size() returns the number of elements in the vector. For instance:

    for my $i (0 .. $multiplicity->size()-1) {
        print $multiplicity->get($i), "\n";
    }

    # This assumes $db->size() == scalar(@$accessions).
    for my $i (0 .. $#$accessions) {
        print $db->get($i), '::', $$accessions[$i], "\n";
    }

It is easy to convert STL vectors into Perl arrays:

    sub stl_to_array { [ map { $_[0]->get($_) } 0 .. $_[0]->size-1 ] }

    # Usage (assuming $db is a vectori object as above):
    my $db_arr = stl_to_array($db);

    # And now the loop is more symmetrical:
    for my $i (0 .. $#$accessions) {
        print $$db_arr[$i], '::', $$accessions[$i], "\n";
    }

Java
    vectori      start = new vectori();
    vectori      end   = new vectori();
    VectorString pre   = new VectorString();
    VectorString post  = new VectorString();
    vectori      frame = new vectori();
    vectori      multiplicity = new vectori();
    vectori      db    = new vectori();
    VectorString accessions = pepsum.getAllProteinsWithThisPepMatch(
        1, 1, start, end, pre, post, frame, multiplicity, db
    );

You can access the elements of each vector by using the get() method, and calling size() returns the number of elements in the vector. For instance:

    for (int i = 0; i != multiplicity.size(); i++)
        System.out.println(multiplicity.get(i));

    // This assumes db.size() == accessions.size().
    for (int i = 0; i != accessions.size(); i++)
        System.out.println(new String(db.get(i)) + "::" + accessions.get(i));

Python
    start = msparser.vectori()
    end   = msparser.vectori()
    pre   = msparser.VectorString()
    post  = msparser.VectorString()
    frame = msparser.vectori()
    multiplicity = msparser.vectori()
    db    = msparser.vectori()
    accessions = pepsum.getAllProteinsWithThisPepMatch(
        1, 1, start, end, pre, post, frame, multiplicity, db
    )

You can then iterate over the items in each vector:

    for m in multiplicity:
        print(m)

    # This assumes db.size() == accessions.size().
    for i in range(accessions.size()):
        print("%d :: %s" % (db[i], accessions[i]))

C#
    vectori      start = new vectori();
    vectori      end   = new vectori();
    VectorString pre   = new VectorString();
    VectorString post  = new VectorString();
    vectori      frame = new vectori();
    vectori      multiplicity = new vectori();
    vectori      db    = new vectori();
    VectorString accessions = pepsum.getAllProteinsWithThisPepMatch(
        1, 1, start, end, pre, post, frame, multiplicity, db
    );

You can then iterate over the items in each vector, and accessing the Count parameter returns the number of elements in the vector. For instance:

    for (int i = 0; i != multiplicity.Count; i++) {
        Console.WriteLine(multiplicity[i]);
    }
    // This assumes db.Count == accessions.Count.
    for (int i = 0; i != accessions.Count; i++) {
        Console.WriteLine("{0}::{1}", db[i], accessions[i]);
    }

Catching C++ exceptions in Perl, Java, Python and C#

Exceptions from within Parser can be caught using exception handling mechanisms in the native language, as shown below. Exceptions will only be thrown by STL classes; Mascot Parser handles errors internally (see Error Handling).

Perl
    my $vectori = new msparser::vectori;

    # This will always throw an exception for an empty vector.
    eval { $vectori->pop() };

    if ($@) {
        print $@;
    }

Java
    vectori vector = new msparser.vectori();

    // This will always throw an exception for an empty vector.
    try {
        vector.pop();
    } catch (Exception e) {
        System.out.println(e);
    }

Python
    vector = msparser.vectori()

    # This will always throw an exception for an empty vector.
    try:
        vector.pop_back()
    except Exception as e:
        print(e)

C#
    vectori vector = new vectori();
    try {
        // this will always throw an exception for an empty vector.
        vector.RemoveAt(0);
    } catch (Exception e) {
        Console.Error.WriteLine(e);
    }

Default parameters in Perl, Java, Python and C#

In C++, functions take a fixed number of arguments. However, some of these arguments can have default values. For example, the getDB() function has the following declaration:

    std::string getDB(int idx = 1)

Whenever you see an equals sign (=) in the function documentation, the parameter next to the sign has a default value. This means that you can leave out the parameter when calling the constructor or method:

Perl

Assume $params is of type ms_searchparams.

    my $db = $params->getDB();   # Equivalent to $params->getDB(1)
    my $db2 = $params->getDB(2); # Override default parameter

    # This will always print 'yes'.
    if ($params->getDB eq $params->getDB(1)) {
        print "yes\n";
    }

Java

Assume params is of class ms_searchparams.

    int db = params.getDB();   // Equivalent to params.getDB(1)
    int db2 = params.getDB(2); // Override default parameter

    // This will always print 'yes'.
    if (params.getDB().equals(params.getDB(1))) {
        System.out.println("yes");
    }

Python

Assume params is of type ms_searchparams.

    db = params.getDB()   # Equivalent to params.getDB(1)
    db2 = params.getDB(2) # Override default parameter

    # This will always print 'yes'.
    if params.getDB() == params.getDB(1):
        print("yes")

C#

Assume _params is of class ms_searchparams.

    int db = _params.getDB();   // Equivalent to _params.getDB(1)
    int db2 = _params.getDB(2); // Override default parameter

    // This will always print 'yes'.
    if (_params.getDB().equals(_params.getDB(1))) {
        Console.WriteLine("yes");
    }

Static functions in Perl, Java, Python and C#

Some functions in Mascot Parser are defined at class level rather than object level. In C++, C# and Java, these are called static functions, while in Perl and Python they are called class methods. Static functions can be used directly without creating an object of the class, as the following example shows:

Perl
    my ($will_create_cache, $cachefile) = msparser::ms_mascotresfilebase::willCreateCache(
        "F981123.dat",
        $msparser::ms_mascotresfilebase::RESFILE_USE_CACHE,
        msparser::ms_mascotoptions->new->getCacheDirectory(),
    );

    if ($will_create_cache) {
        print "ms_mascotresfilebase will use $cachefile as the cache file.\n";
    } else {
        print "ms_mascotresfilebase will not use the cache.\n";
    }

Java
    String[] cachefile;
    boolean will_create_cache = ms_mascotresfilebase.willCreateCache(
        "F981123.dat",
        msparser.ms_mascotresfilebase.RESFILE_USE_CACHE,
        new msparser.ms_mascotoptions().getCacheDirectory(),
        cachefile
    );

    if (will_create_cache) {
        System.out.println(
            "ms_mascotresfilebase will use " + cachefile[0] + " as the cache file."
        );
    } else {
        System.out.println(
            "ms_mascotresfilebase will not use the cache."
        );
    }

Python
    will_create_cache, cachefile = msparser.ms_mascotresfilebase.willCreateCache(
        "F981123.dat",
        msparser.ms_mascotresfilebase.RESFILE_USE_CACHE,
        msparser.ms_mascotoptions().getCacheDirectory(),
        )

    if will_create_cache :
        print("ms_mascotresfilebase will use %s as the cache file." % cachefile)
    else :
        print("ms_mascotresfilebase will not use the cache.")

C#
    string cachefile;
    bool will_create_cache = ms_mascotresfilebase.willCreateCache(
        "F981123.dat",
        (uint) matrix_science.msparser.ms_mascotresfilebase.FLAGS.RESFILE_USE_CACHE,
        new matrix_science.msparser.ms_mascotoptions().getCacheDirectory(),
        out cachefile
    );

    if (will_create_cache) {
        Console.WriteLine(
            "ms_mascotresfilebase will use {0} as the cache file.",
        cachefile);
    } else {
        Console.WriteLine(
            "ms_mascotresfilebase will not use the cache."
        );
    }

Object initialising functions in Perl, Java, Python and C#

Some functions in Mascot Parser are used to initialise an object. These are not constructors, but rather take an object reference as an argument, whose member fields are then filled in.

In C++, these "object initialising functions" take a pointer or reference argument. In Perl, Java, C# and Python, you can simply pass an object reference. For example, ms_mascotresfilebase::getQuantitation() (which is used in the example below) takes an ms_quant_configfile object, while staticGetPercolatorFileNames() takes two vectors as arguments and fills them in.

Perl
    my $resfile = msparser::ms_mascotresfilebase::createResfile($filename);
    my $qf = msparser::ms_quant_configfile->new();
    $qf->setSchemaFileName(
        "http://www.matrixscience.com/xmlns/schema/quantitation_2"
        . " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd"
        . " http://www.matrixscience.com/xmlns/schema/quantitation_1"
        . " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd"
    );

    if ($resfile->getQuantitation($qf)) {
        print "Quantitation name: ", $qf->getMethodByNumber(0)->getName(), "\n";
    } else {
        print "No quantitation section\n";
    }

Java
    ms_mascotresfilebase resfile = ms_mascotresfilebase::createResfile(filename);
    ms_quant_configfile qf = new ms_quant_configfile();
    qf.setSchemaFileName(
        "http://www.matrixscience.com/xmlns/schema/quantitation_2"
        + " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd"
        + " http://www.matrixscience.com/xmlns/schema/quantitation_1"
        + " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd"
    );

    if (resfile.getQuantitation(qf))
        System.out.println("Quantitation name: " + qf.getMethodByNumber(0).getName());
    else
        System.out.println("No quantitation section");

Python
    resfile = msparser.ms_mascotresfilebase::createResfile($filename)
    qf = msparser.ms_quant_configfile()

    qf.setSchemaFileName(
        "http://www.matrixscience.com/xmlns/schema/quantitation_2"
        + " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd"
        + " http://www.matrixscience.com/xmlns/schema/quantitation_1"
        + " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd"
        )

    if resfile.getQuantitation(qf) :
        print("Quantitation name: %s" % qf.getMethodByNumber(0).getName())
    else :
        print("No quantitation section")

C#
    ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile(filename);
    ms_quant_configfile qf = new ms_quant_configfile();
    qf.setSchemaFileName(
        "http://www.matrixscience.com/xmlns/schema/quantitation_2"
        + " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd"
        + " http://www.matrixscience.com/xmlns/schema/quantitation_1"
        + " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd"
    );

    if (resfile.getQuantitation(qf))
        Console.WriteLine("Quantitation name: " + qf.getMethodByNumber(0).getName());
    else
        Console.WriteLine("No quantitation section");

Multiple return values in Perl, Java, Python and C#

Some functions in Mascot Parser return multiple values. In C++, this is usually handled by returning values in pointer arguments. In the API documentation, parameters to these kinds of functions are marked either as "in" or "out": "in" means the parameter is read by the function, and "out" means the function returns a value in the parameter. If the function parameter has no "in" or "out", it is assumed to be "in" by default.

In Perl, "out" values are returned as a list, while in Python the values are return as a tuple. In C# you mark the "out" parameters with the out keyword. In Java, however, you must use arrays of length 1 as the following example shows:

Perl

In Perl, a function can return a list of values. This means that a Mascot Parser function may also return multiple values. There are only a few functions in Mascot Parser that do so; these are documented in the API. An example is ms_mascotresfilebase::getKeepAlive().

    my ($kaTask,
        $kaPercentage,
        $kaAccession,
        $kaHit,
        $kaQuery,
        $kaText
    ) = $resfile->getKeepAlive();

The returning in a list only applies to native types, for example integers, doubles and strings. Objects passed to the function documented by [in,out] should be passed as normal to the function.

Java

Note that std::string & parameters require a StringBuffer and the value in the StringBuffer is modified by the Mascot Parser function. There is no need to follow the instructions below for StringBuffer parameters.

In Java, methods can only have one return value. If a Mascot Parser method returns multiple native values via pointers, you must use arrays of length 1 as parameters to that function. The return values will then be at the zeroth index of the arrays. For example, ms_mascotresfilebase::getKeepAlive() returns multiple values:

    int[]     kaTask = {0};
    int[]     kaPercentage = {0};
    StringBuffer kaAccession = new StringBuffer();
    int[]     kaHit = {0};
    int[]     kaQuery = {0};
    StringBuffer kaText = new StringBuffer();

    resfile.getKeepAlive(
        kaTask,
        kaPercentage,
        kaAccession,
        kaHit,
        kaQuery,
        kaText
    );

    // Results in kaTask[0], kaPercentage[0], ...

Python

In Python, functions can return multiple values in tuples. The same applies to Mascot Parser functions that return multiple values; an example is ms_mascotresfilebase::getKeepAlive().

    (kaTask,
     kaPercentage,
     kaAccession,
     kaHit,
     kaQuery,
     kaText) = resfile.getKeepAlive()

C#

In C#, methods can have multiple return parameters, specified using the out keyword. Therefore, any parameter documented as an "out" parameter in the Mascot Parser API must be preceded by the out keyword when calling the method from C#. For example, ms_mascotresfilebase::getKeepAlive() returns multiple values:

    ms_mascotresfilebase.KA_TASK kaTask;
    int kaPercentage, kaHit, kaQuery;
    string kaAccession, kaText;

    string scriptname = resfile.getKeepAlive(
        out kaTask,
        out kaPercentage,
        out kaAccession,
        out kaHit,
        out kaQuery,
        out kaText
    );

    // results in kaTask, kaPercentage, ...

With C#, every out parameter must be supplied, even if the documentation states that there is a default value.

Maintaining object references: two rules of thumb

Innocent-looking programs that crash

Consider the following three programs in Perl, Java, and Python, respectively. (Error handling is omitted for clarity, but adding it would not fix the problem.)

Perl
    #!/usr/local/bin/perl
    use strict;
    use msparser;

    sub get_params {
        my $resfile = msparser::ms_mascotresfilebase::createResfile($_[0]);
        return $resfile->params;                 # PROBLEM HERE
    }

    my $params = get_params($ARGV[0]);
    print $params->getNumberOfDatabases, "\n";   # CRASH HERE

Java
    import matrix_science.msparser.*;

    public class example {
        static {
            try {
                System.loadLibrary("msparserj");
            } catch (UnsatisfiedLinkError e) {
                System.exit(0);
            }
        }

        private static get_params(String filename) {
            ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile(filename);
            return resfile.params();    // PROBLEM HERE
        }

        public static void main(String argv[]) {
            ms_searchparams params = get_params(argv[0]);
            System.gc();                // See below why these are needed
            System.runFinalization();   // to trigger the crash.
            System.out.println(params.getNumberOfDatabases()); // CRASH HERE
        }
    }

Python
    #!/usr/bin/python
    import msparser
    import sys

    def get_params(filename):
        resfile = msparser.ms_mascotresfilebase.createResfile(filename)
        return resfile.params()           # PROBLEM HERE

    params = get_params(sys.argv[1])
    print(params.getNumberOfDatabases())   # CRASH HERE

All of the programs crash at the end of the main program while trying to print the number of databases. (Go ahead and try!) In this case, the params() method of the resfile object returns an object that contains an internal reference to the parent resfile object. At the end of get_params(), resfile goes out of scope. The program will then crash when methods of the params object are accessed, because resfile is no longer in scope.

The same problem can be demonstrated in C#:

C#
    using System;
    using matrix_science.msparser;
    class GarbageCollectionExample
    {
        private static ms_peptidesummary loadPeptideSummary(string filename)
        {
            ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile(filename);
            ms_datfile datfile = new ms_datfile("../config/mascot.dat");

            ms_mascotoptions opts = new ms_mascotoptions();

            ms_mascotresults_params resParams = new ms_mascotresults_params();
            resfile.get_ms_mascotresults_params(opts, resParams);

            return new ms_peptidesummary(resfile, resParams); // PROBLEM HERE
        }

        public static void Main(string[] argv)
        {
            ms_peptidesummary pepsum = loadPeptideSummary(argv[0]);
            for (int i = 1; i <= pepsum.getNumberOfHits(); i++)
            {
                ms_protein hit = pepsum.getHit(i);
                for (int e = 1; e <= hit.getNumPeptides(); e++)
                {
                    int q = hit.getPeptideQuery(e), p = hit.getPeptideP(e);
                    ms_peptide peptide = pepsum.getPeptide(q, p);
                    Console.WriteLine(peptide.getPeptideStr());   // CRASH HERE
                }
            }
        }

    }

This program will crash within a few iterations when calling peptide.getPeptideStr() . Again, the problem is that the ms_peptidesummary object contains an internal reference to an ms_mascotresfilebase object which goes out of scope at the end of loadPeptideSummary.

If you are interested in gritty details, see Garbage collection problems (advanced reading).

Note
The Java and C# examples have an explicit call to the system garbage collector. Without those statements, the example program may work just fine most of the time, and then once in a blue moon crash unexpectedly. This is because the Java and C# garbage collector are run at unpredictable times, not necessarily at the end of scope.
Note
Do also note that the following is safe in Python, because if, for and while do not create a new lexical scope, but just inherit either the global or function (local) scope:
    #!/usr/bin/python
    import msparser
    import sys

    if sys.argv[1]:
        resfile = msparser.ms_mascotresfilebase.createResfile(sys.argv[1])
        params = resfile.params()

    if params:
        print(params.getNumberOfDatabases())  # No crash here.

Two rules of thumb

There are two easy rules of thumb to avoid crashes such as above. In the following, suppose that $b contains an object of class B, and $a contains an object of class A.

  1. When the C++ function of class B takes a pointer or a reference as an argument, and you pass it $a, you must keep a reference to $a for as long as you use $b.
  2. When the C++ function of class B returns a pointer or a reference as an argument, and you store it in $a, you must keep a reference to $b for as long as you use $a.

There is one exception:

  • If a method of class B takes or returns only objects not in the matrix_science namespace, no coupling will be introduced, and no precautions are needed for $b and $a.

How do you recognise a C++ pointer or reference in the API documentation?

  ms_protein* ms_mascotresults::getHit(const int hit);
  ms_inputquery::ms_inputquery(const ms_mascotresfilebase &resfile, const int q);

The first line defines a function getHit that returns a pointer. The second line defines a function (actually a constructor) ms_inputquery that takes a references as a parameter. So, be on a lookout for ampersands (&) and asterisks (*) when reading the API documentation.

In practice, the rules of thumb are easily followed by keeping the objects together in a hash, dictionary or array until they are no longer needed, or by creating a wrapper class that holds references to all affected objects. In short programs and scripts, you may wish to just make ms_mascotresfilebase, ms_proteinsummary and ms_peptidesummary objects global instead of lexically scoped, or wrap them in singleton classes.

Examples of the rules of thumb

The following examples are written in Python, as Python code is syntactically close to natural language, and can serve as an effective pseudocode. Statements are terminated with semicolons to make the code more familiar for Perl, Java and C# programmers.

    resfile = msparser.ms_mascotresfilebase::createResfile(filename);
    params = resfile.params();
    q1 = msparser.ms_inputquery(resfile, 1);

Rule of thumb 1: keep a reference to resfile for as long as you use params.

Rule of thumb 2: keep a reference to resfile for as long as you use q1.

    resfile = msparser.ms_mascotresfilebase::createResfile(filename);
    pepsum = msparser.ms_peptidesummary(resfile);
    hit = pepsum.getHit(1);

Rule of thumb 1: keep a reference to pepsum for as long as you use hit.

Rule of thumb 2: keep a reference to resfile for as long as you use pepsum.

    datfile = msparser.ms_datfile();
    dbs = datfile.getDatabases();

Rule of thumb 1: keep a reference to datfile for as long as you use dbs.

    qf = msparser.ms_quant_configfile();
    success = resfile.getQuantitation(qf);

Rule of thumb 2: keep a reference to resfile for as long as you use qf.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Garbage collection problems (advanced reading)

Garbage collection problems (advanced reading)
Getting started with Mascot Parser
Perl
    #!/usr/local/bin/perl
    use strict;
    use msparser;

    sub get_params {
        my $resfile = msparser::ms_mascotresfilebase::createResfile($_[0]);
        return $resfile->params;                 # PROBLEM HERE
    }

    my $params = get_params($ARGV[0]);
    print $params->getNumberOfDatabases, "\n";   # CRASH HERE

Java
    import matrix_science.msparser.*;

    public class example {
        static {
            try {
                System.loadLibrary("msparserj");
            } catch (UnsatisfiedLinkError e) {
                System.exit(0);
            }
        }

        private static get_params(String filename) {
            ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile(filename);
            return resfile.params();    // PROBLEM HERE
        }

        public static void main(String argv[]) {
            ms_searchparams params = get_params(argv[0]);
            System.gc();                // See below why these are needed
            System.runFinalization();   // to trigger the crash.
            System.out.println(params.getNumberOfDatabases()); // CRASH HERE
        }
    }

Python
    #!/usr/bin/python
    import msparser
    import sys

    def get_params(filename):
        resfile = msparser.ms_mascotresfilebase.createResfile(filename)
        return resfile.params()           # PROBLEM HERE

    params = get_params(sys.argv[1])
    print(params.getNumberOfDatabases())   # CRASH HERE

C#
    using System;
    using matrix_science.msparser;
    class GarbageCollectionExample
    {
        private static ms_peptidesummary loadPeptideSummary(string filename)
        {
            ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile(filename);
            ms_datfile datfile = new ms_datfile("../config/mascot.dat");

            ms_mascotoptions opts = new ms_mascotoptions();

            ms_mascotresults_params resParams = new ms_mascotresults_params();
            resfile.get_ms_mascotresults_params(opts, resParams);

            return new ms_peptidesummary(resfile, resParams); // PROBLEM HERE
        }

        public static void Main(string[] argv)
        {
            ms_peptidesummary pepsum = loadPeptideSummary(argv[0]);
            for (int i = 1; i <= pepsum.getNumberOfHits(); i++)
            {
                ms_protein hit = pepsum.getHit(i);
                for (int e = 1; e <= hit.getNumPeptides(); e++)
                {
                    int q = hit.getPeptideQuery(e), p = hit.getPeptideP(e);
                    ms_peptide peptide = pepsum.getPeptide(q, p);
                    Console.WriteLine(peptide.getPeptideStr());   // CRASH HERE
                }
            }
        }

    }

Why do the example programs crash?

The programs crash because the resfile object is deallocated from memory too early.

The resfile object is lexically scoped only to the get_params() function (or the loadPeptideSummary function in the C# example). When get_params() or loadPeptideSummary ends, resfile becomes unreachable and is ready for garbage collection. In Perl and Python, this happens at the end of the function; in Java and C#, this happens at an arbitrary point during execution, but you can force it at any time by calling System.gc(); System.runFinalization(); in Java (as we do in the example program to illustrate the problem).

By itself, this is not a problem at all. The problem becomes clear when you look at the declaration of matrix_science::ms_mascotresfilebase::params(). Mascot Parser uses SWIG (Simplified Wrapper and Interface Generator, http://swig.org/) to generate the mappings between C++ and the target language. The params() method returns a C++ reference to an ms_searchparams object, not a copy, which the SWIG layer helpfully wraps into a native class object, thus masking the real nature of the return value.

So the resfile object is freed from memory at the end of scope, and all its internal data deallocated, which also means the ms_searchparams object. But we still have an object pointing to the internal ms_searchparams object! It now points to some arbitrary chunk of memory, which most certainly is not executable code. If you then try to call its methods, you will crash the program with a segmentation fault.

Why is this not handled in SWIG? Because the SWIG layer cannot detect that the ms_searchparams object has an internal reference to the parent ms_mascotresfilebase object. This is hidden inside the C++ implementation. A general solution to this problem would need to track all pointer and reference assignments in the C++ code, and then increase and decrease the reference count of each wrapped object in the runtime environment of whichever programming language you are using. It is very difficult to implement correctly.

Note that the problem in Java and C# is even more subtle than in Perl and Python. If you remove the System.gc() and System.runFinalization() lines from the example program, the program may run just fine for hundreds of times, and then one time, if the system is running out of memory for some reason, or any other similar issue, the JVM or .NET CLR garbage collector might be run just before params.getNumberOfDatabases() – and bang! Your program, which has worked hundreds of times before, crashes for no reason. This is obviously even harder to detect and debug in a large program.

Luckily there is a safe fix: follow Two rules of thumb when writing programs using Mascot Parser.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Multithreading (advanced reading)

Multithreading (advanced reading)
Getting started with Mascot Parser

Using Parser in multithreaded applications

If your application is singlethreaded, you can safely skip this section.

Most Parser classes and methods are not guaranteed to be reentrant or thread-safe. However, with some care, it is possible to use Parser in a multithreaded application.

Option 1: Access Parser from a single thread

The easiest and safest solution is to only use Parser from a single thread in your application. For example, if your application has four threads, only use Parser classes and methods in thread 3 and never from threads 1, 2 or 4. If you can guarantee that no thread other than thread 3 uses Parser or has access to thread 3's variables or memory space, then Parser methods will work just fine. Note that if thread 3 should transfer data to or from the other threads, the data cannot be encapsulated in Parser objects; that is, don't pass ms_protein or ms_peptide objects between threads, or any other Parser objects.

Option 2: Only call methods that are marked thread safe

A small subset of methods and classes are thread safe. These are used by Mascot Distiller, so they are tested extensively with each release of Parser. If your application uses a single thread for most Parser classes and restricts multithreading only to the below classes and methods, the application should be safe.

  • matrix_science::ms_inputquery (all methods)
  • matrix_science::ms_mascotresfilebase::getNumQueries
  • matrix_science::ms_mascotresfilebase::getNumberOfResfiles
  • matrix_science::ms_mascotresfilebase::getSrcQueryAndFileIdForMultiFile
  • matrix_science::ms_ms1quantitation (all methods)
  • matrix_science::ms_peptide::getCharge
  • matrix_science::ms_peptide::getMrCalc
  • matrix_science::ms_peptide::getQuery
  • matrix_science::ms_peptidesummary::createUnassignedList
  • matrix_science::ms_peptidesummary::getIonsScore
  • matrix_science::ms_peptidesummary::getNumberOfHits
  • matrix_science::ms_peptidesummary::getPeptide
  • matrix_science::ms_peptidesummary::getPeptideString
  • matrix_science::ms_peptidesummary::getProtein
  • matrix_science::ms_peptidesummary::getUnassigned
  • matrix_science::ms_protein::getHitNumber
  • matrix_science::ms_quant_helper::ms_quant_helper
  • matrix_science::ms_quant_helper::isPeptideQualityOK

Option 3: Global synchronisation or thread-local copy of Parser

If you need to use arbitrary Parser classes from multiple threads, you have two choices: either create a synchronised data abstraction class (shared global data), or use thread-local storage for completely independent instances of Parser objects in each thread.

In the synchronised class scenario, you need to write a data abstraction class that uses Parser internally (storing copies of the ms_mascotresfile_msr etc. objects), whose methods are guarded by a single mutual exclusion lock (mutex). The mutex must guard access to the entire data abstraction object, and each method must start by acquiring the mutex. If thread 3, for example, makes a method call and acquires the mutex, then any other thread making the same or different method call on the object will block until thread 3's method call has finished and released the mutex. This strict mutual exclusion prevents race conditions and ensures the Parser data shared between threads is only ever accessed by one thread at a time.

However, there are two caveats: 1) the data abstraction class must not return Parser objects or otherwise expose them, as this would nullify the protection of the mutex; and 2) the data abstraction class must be instantiated in a global memory space shared between all threads, so that it is not specific to a thread. The data abstraction class need not implement the Singleton pattern; you could have multiple instances of the class, each with its own internal, independent copies of Parser classes. If you do make it a Singleton, ensure you follow a thread-safe Singleton pattern.

In the other scenario, each thread could have its own copies of Parser classes that are independent of each other. For example, if thread 1 creates an ms_mascotresfile_msr object resfile1, and thread 2 creates resfile2, then thread 1 can call methods of resfile1 concurrently with thread 2 calling methods of resfile2. This is in effect the same situation as the singlethreaded mode, with the same restrictions: thread 2 must not call methods of resfile1, or vice versa, and the threads must not pass Parser objects between themselves. If you do, the application is almost certain to crash sooner or later.

Further restrictions in C++

The above design restrictions apply to all programming languages, including C++. However, the C++ version of Parser has an additional restriction related to Apache Xerces; please refer to section Using Apache Xerces and Parser in the same application.

Multithreading does not change these issues in the dynamically linked case on either platform, but you must take extra care if you are linking statically against Parser and Xerces. Section Xerces and statically linked Parser shows an example sequence of Xerces and Parser calls that is safe in a singlethreaded application. The same sequence will only be safe in a multithreaded application if you can guarantee that no two threads call Parser and Xerces functions concurrently. Otherwise you are almost certain to corrupt the internal Xerces state.

The only easy fix is to do all Parser and Xerces processing in a single thread strictly following each other (not interleaved in any way). It may be best to use a different XML library in statically linked multithreaded applications to avoid the problem entirely.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Mascot results file module

Modules | Classes
Mascot results file module

Modules

Examples for the results file module
UML Class Diagram
Issues with backward compatibility for results files
Error Handling
Peptide mass fingerprint mixtures
Grouping proteins together
Unassigned peptides list
Treatment of duplicate peptides
Detecting ambiguous peptide matches
Error tolerant searches
Crosslinked search results
Using the singleHit parameter to return a single protein
Automated repeating of searches
Target-decoy searches and false discovery rate
Using Percolator scores
Caching Mascot Results
Combining multiple results files
Query-level modifications
Spectral libraries
Spectral library score threshold (advanced reading)

Classes

class | ms_inputquery
This class encapsulates the input queries (peak lists) in the Mascot results file. More...
class | ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink. More...
class | ms_linker_site_vector
A vector of linker sites. More...
class | ms_mascotresfile_dat
Class for parsing and reading files in dat28 format. More...
class | ms_mascotresfile_msr
Class for parsing and reading files in MSR format. More...
class | ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr. More...
class | ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary. More...
class | ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary. More...
class | ms_msr2dat28
This class converts a Mascot Search Results (MSR) file to legacy .dat format. More...
class | ms_peptide
This class encapsulates a peptide from the mascot results file. More...
class | ms_peptidesummary
Use this class to get peptide summary results. More...
class | ms_protein
This class encapsulates a protein in the mascot results file. More...
class | ms_proteinsummary
class | ms_searchparams
This class encapsulates the search parameters in the Mascot results file. More...
class | ms_unigene
This class encapsulates a complete unigene file. More...
class | ms_unigene_entry
This class encapsulates a single entry from a unigene file. More...

Detailed Description

The Mascot results files module is used for parsing information from the results files. This data is typically used to populate a database with search results, or to provide custom reports. The standard Mascot reports uses this module.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Examples for the results file module

Examples for the results file module
Mascot results file module

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation

The quick guide Quickstart: how to open a results file shows how to get very basic information from the search result files with just a few lines of code. The following examples are more comprehensive.

Description | Perl | C++ | Java | Python | C#
Error handling | resfile_error.pl | resfile_error.cpp | resfile_error.java | resfile_error.py | resfile_error.cs
Retrieving information about the search | resfile_info.pl | resfile_info.cpp | resfile_info.java | resfile_info.py | resfile_info.cs
Retrieving the input spectrum for the search results | resfile_input.pl | resfile_input.cpp | resfile_input.java | resfile_input.py | resfile_input.cs
Retrieving the search parameters from the search results | resfile_params.pl | resfile_params.cpp | resfile_params.java | resfile_params.py | resfile_params.cs
Retrieving peptide or protein summary information from the search results | resfile_summary.pl | resfile_summary.cpp | resfile_summary.java | resfile_summary.py | resfile_summary.cs
To repeat a search | repeat_search.pl | repeat_search.cpp | repeat_search.java | repeat_search.py | repeat_search.cs
To create a Mascot Generic File (mgf) from search results | create_mgf.pl | - | - | create_mgf.py | create_mgf.cs
To display peptide level information (cgi) | - | peptide_list.cpp | - | - | -
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: UML Class Diagram

UML Class Diagram
Mascot results file module
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Issues with backward compatibility for results files

Issues with backward compatibility for results files
Mascot results file module

Matrix Science endeavours not to make changes to the Mascot search results files that would 'break' 3rd party applications. In general, any application that uses Mascot Parser will be safe when a new version of Mascot Server is released – even if that software is not re-built (or re-linked) with the latest version of Mascot Parser. There are some exceptions to this, and these are listed below.

Increase in the number of variable modifications

From Mascot version 1.5 to 2.1, the limit on the number of variable modifications is 9. The variable modification string returned by ms_peptide::getVarModsStr() is of the form 0110030. One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates delta1, 2 indicates delta2, etc., in the masses section of the results file. An 'X' is used to indicate an error tolerant modification that can be retrieved using ms_peptidesummary::getErrTolModName.

Mascot Server 2.2 and later still limit the number of variable modifications specified in the search form to 9 per search. However, 'exclusive' modifications are supported in quantitation methods, and these are reported using the same variable modifications string. It is possible that the number of modifications could then exceed 9. To support numbers greater than 9, the letters A..W are permitted, with A being 10 and W being 32. In Mascot Parser 2.2 and later, the method ms_mascotresults::getReadableVarMods() will return the correct modifications for values A to W. Earlier versions of Parser ignore any non numeric value apart from X. Any third party client software that parses the string returned from ms_peptide::getVarModsStr() will need to be modified to support A to W, and convert these to the numbers 10 to 32.

Separation between form-level and query-level modifications

Mascot 2.2 introduced query-level modifications, which are modifications speficied locally in an MS/MS peak list in a Mascot Generic Format (MGF) input file, using the IT_MODS parameter. Mascot 2.2, 2.3 and 2.4 combine search form-level modifications, exclusive modifications and all query-level modifications into a master list before the search starts. The master modification list is saved in the search parameters section, as above, available via ms_searchparams. The modifications string of a peptide match, getVarModsStr(), always refers to the indices of the master list.

Mascot 2.5 and later treat form-level and query-level modifications separately. The master list contains only form-level modifications and no query-level modifications. If query X has a local IT_MODS parameter and its rank Y match uses at least one local modification, Mascot writes a new parameter to the results file, called qX_pY_local_mods. The variable modifications string getVarModsStr() continues to refer to the master modification list, while the new query-level modifications string is available as getLocalModsStr(). The latter is a string of 1-based indices to the IT_MODS parameter of the corresponding input query. The Unimod section lists the equivalent of the master list of modifications, including all query-level modifications used in the search.

Most Parser functionality remains unaffected by the changes. For example, getReadableVarMods() takes the local modifications string automatically into account, and the duplicatedness status of peptide matches within a protein hit takes both form-level and query-level modifications into account when comparing peptide modifications. This means that for most common tasks, or if you do not use query-level modifications, you do not need to change anything in your program. In particular, Parser 2.5 and later fully support Mascot 2.4 and earlier results files.

If you do use query-level modifications, note that Parser 2.4 and earlier are not aware of the new qX_pY_local_mods strings in Mascot 2.5 and later results files. You can extract the raw values using getSectionValueStr(), but Parser 2.4 and earlier will not parse the values or include the query-level mods internally in getReadableVarMods() or elsewhere.

See Accessing query-level modification information for more details on query-level modifications in Mascot 2.5 and later results files.

Monolink deltas in crosslinked searches

Mascot 2.7 introduced intact crosslinks and cleavable crosslinks. Both types can produce monolinks, which are variable modifications. However, the monolinks of a linker usually have deltas different from the intact linker mass. Monolinks share the same variable mod number in the variable mods string and are differentiated by the monolink number in ms_peptide::getMonoLinkStr().

Parser 2.6 and earlier are not aware of the monolink string and will report incorrect deltas for monolinks.

Parser 2.7 and later automatically inspect the monolink string where relevant, for example in getReadableVarMods(). If you're processing the variable mods string manually, you must use the new API described in Crosslinked search results.

Legacy results file format (.dat) and Mascot Search Results (MSR) format

Mascot Server 3.0 defaults to saving search results in a new file format, Mascot Search Results (MSR). This is an SQLite database that Parser 2.8 and earlier are unable to read.

The legacy .dat format is referred to as the dat28 format. It's the plain text MIME-format file of sections of key-value lines produced by Mascot Server 2.8 and earlier. The dat28 format is now frozen and will never change. The MSR format will eventually diverge from dat28 as new features are implemented in future versions of Mascot.

Parser 3.0 continues to support dat28 files with the ms_mascotresfile_dat class. If your client application is unable to update to Parser 3.0, it is possible to export results in dat28 format from Mascot Server 3.0. However, we recommend updating Parser as soon as feasible to future-proof your application.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Error Handling

Error Handling
Mascot results file module

Error handling in ms_mascotresfile

All errors from all classes in the Mascot results file module are accumulated into a list in the ms_mascotresfile object, even if the error occurs in a related object. The errors are accumulated in the ms_mascotresfile object that was given as the parameter to the other object constructor. For example, when you create a new ms_peptidesummary object, errors are accessed through the ms_mascotresfile object, not the ms_peptidesummary object:

C++
    std::unique_ptr<ms_mascotresfilebase> resfile = ms_mascotresfilebase::createResfile(filename);

    if (!resfile->isValid()) {
        /* Handle errors... */
    }

    resfile->clearAllErrors();

    ms_peptidesummary *pepsum = new ms_peptidesummary(resfile);

    if (!resfile->isValid()) { // resfile now contains errors from ms_peptidesummary
        /* Handle errors... */
    }

Perl
    my $resfile = msparser::ms_mascotresfilebase::createResfile($filename);

    if (not $resfile->isValid()) {
        # Handle errors...
    }

    $resfile->clearAllErrors();

    my $pepsum = new msparser::ms_peptidesummary($resfile);

    if (not $resfile->isValid()) { # resfile now contains errors from ms_peptidesummary
        /* Handle errors... */
    }

Java and C#
    ms_mascotresfilebase resfile = ms_mascotresfilebase::createResfile(filename);

    if (!resfile.isValid()) {
        /* Handle errors... */
    }

    resfile.clearAllErrors();

    ms_peptidesummary pepsum = new ms_peptidesummary(resfile);

    if (!resfile.isValid()) { // resfile now contains errors from ms_peptidesummary
        /* Handle errors... */
    }

Python
    resfile = msparser.ms_mascotresfilebase.createResfile(filename)

    if not resfile.isValid():
        # Handle errors...

    resfile.clearAllErrors()

    pepsum = ms_peptidesummary(resfile)

    if not resfile.isValid(): # resfile now contains errors from ms_peptidesummary
        # Handle errors...

The list of errors is only ever cleared by calling clearAllErrors().

To determine the number of errors, call getNumberOfErrors(). To access a particular error by its number, call getErrorNumber(i), where i is a number between 1 and getNumberOfErrors(), inclusive. To get the error string for the same error, use getErrorString(i).

Multiple similar errors are grouped together. For, example, suppose that creating a peptide summary gave 3000 errors for null accession strings (and no other errors). getNumberOfErrors() then would return 2, but the second error would have the following error message:

Null accession number found for query x, rank y in peptides section. (Error repeated 2999 times)

Errors are classified as 'fatal' or 'warning'. The function isValid() will return true if there are just warnings, and false if there are any fatal errors.

Example code:

C++ | resfile_error.cpp
Perl | resfile_error.pl
Java | resfile_error.java
Python | resfile_error.py
C# | resfile_error.cs

For a list of error return values, see ms_errs.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Peptide mass fingerprint mixtures

Peptide mass fingerprint mixtures
Mascot results file module

With Mascot Server 1.9 and later, all peptide mass fingerprint searches test for the possibility that the sample is a mixture of proteins. Mascot will automatically detect and report statistically significant protein mixtures of up to six components. The results are saved in a 'mixtures' section of the results file. The 'summary' section of the results file is unchanged.

To ignore PMF mixtures, set the flag ms_mascotresults::MSRES_IGNORE_PMF_MIXTURE when creating the ms_proteinsummary object.

ms_proteinsummary::getHit() can return a protein that is a 'mixture'. However, this is not a 'real' protein but just a container for a number of component proteins. To determine if the protein is a 'mixture', use the method ms_protein::isPMFMixture().

This 'mixture protein' has a list of peptides and in general can be treated as a normal protein object, with the difference that its accession will be "Mixture k", where k is an integer. Also, the description line returned from ms_mascotresults::getProteinDescription() will be of the form:

  Mixture from proteins:"gi|1234","gi|5432","gi|9999"

ms_mascotresults::getProteinMass() will always be zero for 'mixtures'.

To find out how many component proteins a 'mixture' originates from, use ms_protein::getNumComponents(). You can then access each component protein with ms_protein::getComponent().

To find the number of peptides that matched, use ms_protein::getNumDisplayPeptides(). Only peptides that matched in two or more component proteins are counted in the number. To display a 'colour coded' report, the component ID for the getComponent() call is also available for each peptide that matched with ms_protein::getProteinComponentID().

For the concise protein summary report, a single protein is never collapsed into a mixture and a mixture is never collapsed into a single protein.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Grouping proteins together

Grouping proteins together
Mascot results file module

Why group proteins together?

It is generally not useful to have a results page with a list of many (possibly hundreds) of highly homologous proteins. In most cases, it is far better to group these proteins together. The goal of grouping is to answer the following question: "which minimal set of proteins completely accounts for the peptides found in the experimental data?".

There are two separate algorithms for grouping proteins in Mascot Parser. The first option MSRES_GROUP_PROTEINS uses Occam's Razor and was introduced in the first version of Mascot Parser. The second option MSRES_CLUSTER_PROTEINS is more inclusive and is the algorithm used for the MS-MS search results in Mascot Server 2.3.

Using MSRES_GROUP_PROTEINS

The flag MSRES_GROUP_PROTEINS can be used with both ms_peptidesummary and ms_proteinsummary objects.

In this grouping mode, Occam's Razor is ruthlessly applied to the results, so that proteins which span the same set or a subset of peptides can be collapsed into a single entry in the hit list.

There is a subtle difference between the test used to group proteins for a peptide mass fingerprint search and for other searches. If there are any MS-MS data, then proteins are grouped together if the peptide sequences for each match are the same. If there is no MS-MS data, proteins are grouped together when the input masses of peptide matches are the same.

Using MSRES_CLUSTER_PROTEINS

The flag MSRES_CLUSTER_PROTEINS is only supported with ms_peptidesummary.

One of the disadvantages of the MSRES_GROUP_PROTEINS algorithm is that a protein may be excluded from being a subset or sameset protein because it has just one 'new' peptide that prevents it from being grouped. The MSRES_CLUSTER_PROTEINS mode groups proteins by considering shared peptide matches above homology threshold. Each protein hit consists of a 'family' of proteins, where each protein in the family shares at least one peptide match above homology threshold with another family member.

Proteins in the hit can be accessed in the following way:

 | Protein | Description | getGrouping returns | getSimilarProteins returns
1.1 | A | This is the 'lead' or 'master' protein for hit 1 [returned by getHit(1)] | GROUP_NO | nothing
 | B | A protein with the same peptide matches as Protein A [returned by getNextSimilarProteinOf("A", 1, 1)] | GROUP_COMPLETE | Protein A
 | C | A protein that contains a subset of the peptides in Protein A and Protein I [returned by getNextSubsetProteinOf("A", 1, 1)] | GROUP_SUBSET | Protein A Protein I
 | D | A protein that contains the same set of the peptides in Protein C [returned by getNextSimilarProteinOf("C", 1, 1)] | GROUP_COMPLETE | Protein C
1.2 | E | This is another family member of the first hit [returned by getNextFamilyProtein(1,1)] | GROUP_FAMILY | nothing
 | F | A protein with the same peptide matches as Protein E [returned by getNextSimilarProteinOf("E", 1, 1)] | GROUP_COMPLETE | Protein E
 | G | A protein that contains a subset of the peptides in Protein E [returned by getNextSubsetProteinOf("E", 1, 1)] | GROUP_SUBSET | Protein E
 | H | A protein that contains the same set of the peptides in Protein G [returned by getNextSimilarProteinOf("G", 1, 1)] | GROUP_COMPLETE | Protein G
1.3 | I | This is another family member of the first hit [returned by getNextFamilyProtein(1,2)] | GROUP_FAMILY | nothing
 | J | A protein with the same peptide matches as Protein I [returned by getNextSimilarProteinOf("I", 1, 1)] | GROUP_COMPLETE | Protein I
 | K | A protein that contains a subset of the peptides in Protein I [returned by getNextSubsetProteinOf("I", 1, 1)] | GROUP_SUBSET | Protein I
 | C | A protein that contains a subset of the peptides in Protein A and protein I [returned by getNextSubsetProteinOf("I", 1, 2)] | GROUP_SUBSET | Protein A Protein I
 | L | A protein that contains the same set of the peptides in Protein K [returned by getNextSimilarProteinOf("K", 1, 1)] | GROUP_COMPLETE | Protein I
2.1 | X | This is the 'lead' or 'master' protein for hit 2 [returned by getHit(2)] | GROUP_NO | nothing

Note that Protein C is a subset of Protein A and Protein I. An alternative way of showing subsets is to have a single list at the end of the family. For this case, it is probably easier to call getNextSubsetProtein(hit, id, searchWholeFamily) with searchWholeFamily == true, which returns each subset protein in the family, one at a time. See also getSimilarProteins(), which returns the list of proteins that a subset protein belongs to (in some sense the 'superset' proteins of the subset protein).

For family grouping, it is important to call getNextSimilarProteinOf() and getNextSubsetProteinOf() rather than getNextSimilarProtein() and getNextSubsetProtein(). Otherwise the list of similar proteins will always be for the 'lead' protein.

minPepLenInPepSummary

In peptide summary only (using either method of grouping), any peptides shorter than minPepLenInPepSummary will be ignored when grouping proteins together. You need to specify this value when creating an ms_peptidesummary object. The default value may be obtained from ms_mascotoptions::getMinPepLenInPepSummary().

Handling 'subset' proteins

Assume that

  • protein 'A' has three peptide matches (to queries 1, 2 and 3); and
  • protein 'B' has only two peptide matches (to queries 1 and 3).

We say that protein 'B' matches a subset of peptides. Mascot Parser allows you to treat these subset matches in three separate ways:

  1. Display the proteins that matched a subset of the peptides 'under' the main protein. For the standard Mascot Server reports, this is implemented by specifying "ShowSubSets 1" in the Options section of mascot.dat. In Mascot Parser, specify MSRES_SHOW_SUBSETS when creating the ms_peptidesummary or ms_proteinsummary object.

  2. Discard the proteins that matched a subset of the peptides 'under' the main protein. For the standard Mascot Server reports, this is implemented by specifying "ShowSubSets 0" in the Options section of mascot.dat. In Mascot Parser, do not specify MSRES_SHOW_SUBSETS when creating the ms_peptidesummary or ms_proteinsummary object.

  3. Treat proteins that matched a subset of the peptides as separate, unique proteins with no relation to the main protein. In Mascot Parser, specify MSRES_SUBSETS_DIFF_PROT when creating the ms_peptidesummary or ms_proteinsummary object.

If you have a primary hit with (say) 100 peptide matches, you may be very interested in subset proteins with 99 matches, but not in ones that have 1 or 2 matches; these just clutter up the report if you use MSRES_SHOW_SUBSETS. On the other hand, if you have a primary hit with (say) 2 peptide matches, you are more likely to be interested in sub-set proteins with just 1 match. The function ms_mascotresults::setSubsetsThreshold() was introduced in Mascot 2.2 to facilitate including or removing these less interesting subset proteins.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Unassigned peptides list

Unassigned peptides list
Mascot results file module

Unassigned list in peptide summary reports

In standard Mascot Server peptide summary reports, there is an "unassigned list" at the bottom of the page - for example:

Unassigned queries: (no details means no match)
 Query  Observed Mr(expt) Mr(calc)   Delta  Miss Score  Rank   Peptide
  113   893.28   1784.54   1784.92   -0.37    0    65     1    VGAVAGNDWLIWDITR
  107   882.21   1762.40   1762.79   -0.38    0    62     1    LISWYDNEFGYSNR
  67    691.20   1380.39   1380.64   -0.24    0    61     1    ALEESNYELEGK
  70    695.73   1389.45   1389.67   -0.21    0    60     1    QSLEASLAETEGR

This is a list of MS-MS spectra that have had matches to peptides, but are not included in the main report because the proteins which they are found in have too low a score. If the list of proteins in the main report was not cut off, i.e. if all proteins were displayed, then there would be no unassigned list.

For example, if a query had the following matches, then it would not be in the unassigned list.

Rank | Pretty Rank | Score | Peptide | Protein
1 | 1 | 78 | ABCDEFG |
2 | 1 | 78 | ABCDEGF | gi|123456
3 | 1 | 78 | BACDEFG |
4 | 4 | 65 | ASDADSD |
5 | 4 | 65 | SDFSGSD |
6 | 6 | 12 | DFGHDFG |
7 | 7 | 8 | SSDFDFD |
8 | 8 | 7 | RTYRYRY |
9 | 9 | 4 | RTYRYRY |
10 | 10 | 2 | TYUTUTU |

Although there was no protein match the rank 1 peptide, the rank 2 peptide had the same score, so this is in effect treated as the top match for the query. The query will then be included under gi|123456.

Unassigned list in protein summary reports

An unassigned list can be created for a protein summary. This list is just the list of peptides that didn't get a match anywhere in the top 50 hits.

Creating the unassigned list

After creating an ms_peptidesummary object, the method createUnassignedList() needs to be called. The parameter is one of:

ms_mascotresults::QUERY

Sort the unassigned list by ascending query number. This is the same as ascending relative mass order.

ms_mascotresults::SCORE

Sort the unassigned list by descending score.

ms_mascotresults::INTENSITY

Sort the unassigned list by descending intensity. Intensity values are taken from the qintensity value in the results file if they are available (pkl files, some MGF files). If these values are not available, then the intensity is calculated from the sum of all the ions values.

Note that for a very large MS-MS file, this option can take some time to process unless there are qintensity values in the results file.

Getting the entries for the unassigned list

Once the unassigned list has been created, use getNumberOfUnassigned() to determine the number of items in the list. You can then retrieve peptide at index i with getUnassigned(i).

See also getUnassignedIsBold() and getUnassignedShowCheckbox().

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Treatment of duplicate peptides

Treatment of duplicate peptides
Mascot results file module

Peptide match duplicates

Warning – this is a complex issue that only applies to peptide summary reports, and only needs to be understood by advanced users. The default flag MSRES_DUPE_DEFAULT is suitable for most use cases.

Duplicate peptides arise from data

In a typical results file derived from an LC-MS-MS data set, the same peptide will appear multiple times. In a perfect system, identical peptides would rarely be seen. Ideally, peptides would be separated perfectly by chromatography, and even if that failed, peak detection software would combine similar peptides before the data were submitted to Mascot Server.

Back to reality... The standard Mascot Server reports display most 'duplicate' peptides, but the scores are shown with brackets (parentheses) to indicate that these peptides don't affect the total protein score. Mascot Parser has full flexibility to customise the treatment of such 'duplicate' peptides.

How Mascot Parser detects duplicate peptides

In peptide summary reports, each candidate protein contains one or more peptides. Some of these peptides will be duplicates of others, and these generally do not add to the confidence of the protein match, and therefore can optionally be ignored.

There are four possible situations that will cause Mascot Parser to mark a peptide as a duplicate:

  1. Same query number. For example, if a protein contains the two peptides ABCDIK and BACIDK, and query 3 matches both of these (possibly with different scores), then the two peptides are duplicates of each other. Alternatively, the same query could match the same peptide twice but with different modifications.

  2. Same peptide sequence. The peptide matches may or may not be from the same query. Also, they may or may not have the same start and end position in case there are repeated peptides in the protein.

    If the match is a crosslinked match, it can only be marked as a duplicate of another crosslinked match whose alpha and beta sequences are the same and alpha and beta peptides are in the same protein (an intralinked match).

  3. Same modifications. If the peptide sequences are different, then (to reduce permutations) the modifications are defined as being different.

  4. Same start and end positions in the protein sequence. Normally caused by repeats in the sequence. If the peptide sequences are different, then the start and end positions are defined as being different. (This is necessary because for a Unigene entry, the start and end positions could be the same for different peptides. Each Unigene entry is made up from different EST fragments.)

    If the match is a crosslinked match, and alpha and beta are in different proteins (an interlinked match), then their positions are always treated as different.

There are 4 rules to cover the cases above, which generates 16 possibilities. However, because of the definitions described above, only 9 are possible combinations:

Query | Sequence | Modifications | Position | Rule_ID
same | same | same | different | A
same | same | different | same | B
same | same | different | different | C
same | different | different | different | D
different | same | same | same | E
different | same | same | different | F
different | same | different | same | G
different | same | different | different | H
different | different | different | different | I

Use of the 'Rule ID' column is described below.

When the rules are applied

There are two flags that control how these rules are applied to the ms_mascotresults object:

MSRES_DUPE_REMOVE_[RULE_ID]

Each protein initially contains all possible matching peptides. If this flag is given to the constructor, duplicate peptides are then removed according to the specified rules.

A removed peptide will never be considered to be part of that protein – so, for example, it won't be included in the score. In rare cases, this will also affect how proteins are grouped together. (See Grouping proteins together). If no duplicates are ever to be removed, specify MSRES_DUPE_REMOVE_NONE.

Crosslinked matches are subject to duplicate detection. Intralinked matches (alpha and beta in same protein) are removed according to the specified MSRES_DUPE_REMOVE_[RULE_ID]. Interlinked matches (alpha and beta in different proteins) may be flagged as duplicates but cannot be removed using any of the existing rule IDs. If you can think of a use case for suppressing or removing duplicate interlinked matches, please contact us at support@matrixscience.com!

MSRES_DUPE_INCL_IN_SCORE_[RULE_ID]

When calculating the protein score, it may be desireable to include some duplicates in the score. If this flag is given to the constructor, duplicates matching the rule will be included in protein scoring. These flags apply to standard Mascot protein scoring and not to MudPIT scoring.

For the standard Mascot Server reports, no duplicates are included when calculating the protein score. (And duplicates are shown in brackets.) Any peptides removed by MSRES_DUPE_REMOVE_[RULE_ID] have already been removed before protein scoring is performed, so it is pointless to try and override, for example, MSRES_DUPE_REMOVE_D by using MSRES_DUPE_INCL_IN_SCORE_D.

When displaying or storing a list of peptides, it may be desirable to inhibit the display of some duplicate peptides. ms_protein::getPeptideDuplicate() can be used to that end. Note that peptides that have been removed due the MSRES_DUPE_REMOVE_[RULE_ID] setting need never be specifically inhibited by client code, since they will not be present anyway.

ms_peptidesummary::getProteinsWithThisPepMatch() will return a list of all proteins that contained this peptide. The list only includes peptides that were not discarded due to the MSRES_DUPE_REMOVE_[RULE_ID] setting. There is currently no other override for this function.

Rules for standard Mascot reports

For Mascot 1.9 and Mascot 2.0, the default for MSRES_DUPE_REMOVE_[RULE_ID] is MSRES_DUPE_REMOVE_A | MSRES_DUPE_REMOVE_D. This means that peptides with

  • same query, same sequence, same mods, different position

or

  • same query, different sequence, different mods, different position

are not included in any proteins.

No duplicates are ever added into the score, so MSRES_DUPE_INCL_IN_SCORE_NONE needs to be specified. MSRES_DUPE_DEFAULT is defined as MSRES_DUPE_REMOVE_A | MSRES_DUPE_REMOVE_D | MSRES_DUPE_INCL_IN_SCORE_NONE.

Compatibility with previous versions

This functionality was introduced in Mascot Parser 1.2. No changes are required to client code that was used before Mascot Parser 1.02:

  • If no MSRES_DUPE_REMOVE_[RULE_ID] flags are supplied, then the default MSRES_DUPE_REMOVE_A | MSRES_DUPE_REMOVE_D is assumed. (In the unlikely event that it is required that no duplicates are ever to be removed, then MSRES_DUPE_REMOVE_NONE must be specified.)

  • The default is to never add duplicates to the protein score, so MSRES_DUPE_INCL_IN_SCORE_NONE needs to be specified. However, since this is defined as '0', it does not need to be passed to the ms_peptidesummary constructor.

Earlier client code would typically check the following before displaying peptides or adding them to a database:

    prot->getPeptideDuplicate(i) != ms_protein::DUPE_DuplicateSameQuery

This test is still required since generally peptides with the same query, same sequence and different modifications are not shown in the report, but would be seen in the yellow popup.

Chimeric duplicates

Warning – this is a complex issue that only applies to peptide summary reports, and only needs to be understood by advanced users. It is best to always specify MSPEPSUM_REMOVE_CHIMERIC_DUPES or always use ms_mascotresfilebase::get_ms_mascotresults_params().

Mascot 2.5 added support for chimeric spectra. A chimeric spectrum contains MS/MS data from multiple precursors. Mascot divides each input spectrum with multiple precursor masses into a set of subsidiary queries, linked by the source index of the original spectrum. Each subsidiary query is matched separately, so that the number of output queries is the total number of precursor masses in the input file.

The subsidiary queries in each set can have duplicate matches, called chimeric duplicates. This is easiest to explain by example. Suppose we have a chimeric spectrum with two precursors, forming queries 1 and 2:

Query 1
Rank | Sequence | Delta |
1 | TVAGQDAVIVLLGTR | 0.002411 |
2 | ISMPDIDLNLTGPK | -0.916199 | (dupe)
3 | LLSENADLKKQVR | -0.992782 | (dupe)
4 | FLTGPLNLNDPDAK | -1.908081 | (dupe)
5 | AEAGLQDGISGPATAR | -0.883652 | (dupe)

Query 2
Rank | Sequence | Delta |
1 | TVAGQDAVIVLLGTR | 0.921411 | (dupe)
2 | ISMPDIDLNLTGPK | 0.002801 |
3 | LLSENADLKKQVR | -0.073782 |
4 | FLTGPLNLNDPDAK | -0.989081 |
5 | AEAGLQDGISGPATAR | 0.035348 |

The two queries originate from the same chimeric spectrum and have nearly the same precursor masses. (The precursor mass tolerance is quite wide in this example.) As a result, both queries match the same peptide sequences. However, all but the rank 1 match in the first query have a much larger mass delta than in query 2. This means the rank 2-5 matches in query 1 are all chimeric duplicates. Conversely, the rank 1 match in query 2 is a duplicate.

Parser removes chimeric duplicates from consideration if you open the results file as a peptide summary (ms_peptidesummary) and use the flag MSPEPSUM_REMOVE_CHIMERIC_DUPES. In the above case, you would only see one match in query 1 and four in query 2. Ranks are renumbered accordingly (e.g. query 2 rank 2 becomes query 2 rank 1 when the chimeric duplicate is removed). Chimeric duplicate removal is done at query level before protein grouping and before considering peptide match duplicates within protein hits.

Chimeric duplicates are removed by default if you use ms_mascotresfilebase::get_ms_mascotresults_params() to construct the default flags to ms_peptidesummary. Otherwise you need to specify the flag yourself when creating the peptide summary object.

Note that the flag has no effect if the results file was created by Mascot 2.4 or earlier, or if the results file has no chimeric spectra.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Detecting ambiguous peptide matches

Detecting ambiguous peptide matches
Mascot results file module

Matches with same score are ambiguous

Mascot may give the same score to two or more matches in the same query. A typical case is an I/L difference in peptide sequences, say CIPALDSLTPANEDQK and CIPALDSITPANEDQK. Because leucine (L) and isoleucine (I) have exactly the same molecular weight, the calculated fragments for these two peptides are also exactly the same. The two matches get the same score when matched against the same spectrum.

Parser signals this ambiguity by pretty rank, accessible with ms_peptide::getPrettyRank(). Two peptides with the same score have the same pretty rank. For example, if CIPALDSLTPANEDQK and CIPALDSITPANEDQK are the rank 1 and rank 2 matches, both have pretty rank 1.

Note that score-level ambiguity has little to do with ms_peptide::getAmbiguityString(), which encodes residue substitutions based on ambiguous residues in protein sequences.

Ambiguity group IDs in integrated spectral library searches

Mascot 2.6 and later support Spectral libraries. Integrated spectral library searches may have ambiguity of a different kind. Within a query, two peptide matches are ambiguous if they have the same pretty rank (as above) or they have the same sequence but come from a different search engine. Ambiguous sequences are automatically taken into account during protein inference.

Consider the following matches to a query:

Rank | Sequence | Score | Source | Pretty rank | Ambiguity group
1 | CIPALDSLTPANEDQK | 524 | SL | 1 | 1
2 | CIPALDSLTPANEDQK | 399 | SL | 2 | 2
3 | CIPALDSLTPANEDQK | 51 | AA | 3 | 1
4 | CIPALDSITPANEDQK | 51 | AA | 3 | 1
5 | CIPALDSLTPANEDQK | 310 | SL | 4 | 3
6 | SLNNQIETLLTPEGSR | 250 | SL | 5 | 4

The rank 1 match starts ambiguity group numbering, exactly the same as in the pretty rank case.

The rank 2 match is in a different ambiguity group than rank 1. Although the sequences are the same, the matches have the same search engine (both from spectral library) but different score (they probably had different library spectra).

Rank 3 and 4 matches have the same pretty rank; they are the typical I/L case. Because the rank 3 match has the same sequence and different search engine than the rank 1 match, ranks 1, 3 and 4 belong to the same ambiguity group.

The rank 5 match is again in an ambiguity group of its own for the same reason as the rank 2 match.

Finally, the rank 6 match has a different sequence and different score from the rest, so it also is in its own ambiguity group.

Ambiguity grouping for a query is available with ms_peptidesummary::getAmbiguityRanks().

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Error tolerant searches

Error tolerant searches
Mascot results file module

There are two types of error tolerant search and these are described at the Matrix Science website. In Mascot Parser documentation, these are referred to as the Error tolerant search and the Integrated error tolerant search. This section assumes familiarity with both types.

Original error tolerant search

In Mascot Server 1.8 and later, an error tolerant search may be run as a repeat search. In this case, one or more ACCESSIONs will have been specified, and the results file will just contain the error tolerant search results. The accessions in the search may be retrieved using ms_searchparams::getACCESSION().

In the peptide summary report, peptide matches are ignored if

  • the ions score is lower than the top match for this query in the original search; OR
  • the ions score is below the significance level.

Significance level is taken from the parameter ignoreIonsScoreBelow given to the ms_peptidesummary constructor. If this value is zero, then a default threshold of 1 in 20 is used.

The filename for the 'parent' non-error-tolerant search is saved in the parameters section as _errortolerantsearchparent, and can be accessed with ms_searchparams::getErrTolParentFilename(). It is not possible to use getINTERMEDIATE() because an error tolerant search can be performed as a repeat search from another error tolerant search. If MSRES_SHOW_ALL_FROM_ERR_TOL is not specified, and the file specified by _errortolerantsearchparent cannot be found, then the error ERR_NO_ERR_TOL_PARENT will be set, and the results will be shown as if MSRES_SHOW_ALL_FROM_ERR_TOL had been specified.

Always use standard protein grouping (MSRES_GROUP_PROTEINS) with manual error tolerant searches. If you enable protein clustering, the parent file is ignored and the results reported may be incorrect.

Integrated error tolerant search

In Mascot Server 2.2 and later, a single search can be performed which contains both the standard search results and the error tolerant search results. This is known as the integrated error tolerant search.

For an integrated error tolerant search, if MSRES_ERR_TOL is specified, then the results will just be taken from the error tolerant sections of the results file, and these results are handled in exactly the same way as for the Original error tolerant search. If MSRES_INTEGRATED_ERR_TOL is specifed, then the results will contain matches from both the standard and error tolerant sections. If neither of these flags are specified, then the results will just be derived from the standard peptides section.

When MSRES_INTEGRATED_ERR_TOL is specified, the results are first combined at the query level, so there will be up to 20 matches for each query. The methods ms_peptide::getRank() and ms_protein::getPeptideP() will therefore return a number in the range 1 to 20. This rank value can be used for any ms_peptidesummary method that requires a 'p' (rank) value. Use the method ms_peptide::getIsFromErrorTolerant() to find out if the results are from the standard results section or the error tolerant section.

Score thresholds and score filtering (Mascot Server 2.8 and later)

Error tolerant searches from Mascot Server 2.8 and later are subject to two kinds of filtering. If a query has a significant first pass match (score exceeds threshold), then ET matches in the query are suppressed. This is equivalent to only searching unassigned/unmatched queries in the error tolerant pass.

Secondly, ET matches are suppressed if they score lower than the rank 1 first pass match. The flag MSRES_SHOW_ALL_FROM_ERR_TOL can be used to override this behaviour.

First and second pass results may have different significance thresholds. If the search is a target-decoy search, and the constructor parameter TargetFDR is defined, Parser chooses independent first and second pass significance thresholds that yield the target FDR. If TargetFDR is not defined, or the search is not a target-decoy search, Parser uses the same significance threshold for both passes (by default, 0.05).

The score threshold for queries searched in the error tolerant pass is derived from the combined first and second pass identity threshold (number of trials, or qmatch). The expect value of an ET match is calculated in the same way as first pass matches. See ms_mascotresults::getPeptideExpectationValue().

Protein score is derived from the highest scoring non-error-tolerant match for each query, and this value can be found by calling ms_protein::getPeptideIonsScore().

Score thresholds and score filtering (Mascot Server 2.7 and earlier)

If the error tolerant search is from Mascot Server 2.7 or earlier, different rules apply.

An error tolerant match will be discarded if it has a score below the average identity threshold (getAvePeptideIdentityThreshold()) or below the maximum standard result for the query. This means that, in practice, it will be rare to get 20 matches for a particular query – the requirement would be for all 10 error tolerant matches to be the top 10 scores, and all would need to be above the average peptide identity threshold. To show all matches, including those that would be discarded by default, the flag MSRES_SHOW_ALL_FROM_ERR_TOL needs to be used when constructing the ms_peptidesummary object.

The average identity threshold is calculated using the minProbability value passed to the ms_peptidesummary constructor. If a value of <= 0 or >= 0.1 is passed to the constructor, then a default of 1 in 20 is assumed for calculating the threshold. The flag MSRES_MAXHITS_OVERRIDES_MINPROB should normally be used so that the maxHitsToReport value is not overridden by the minProbability value.

Statistical significance of error tolerant matches is not defined, so ms_mascotresults::getPeptideExpectationValue() returns -1.

Useful functions for both type of search

To determine if a search is an error tolerant search, use ms_mascotresfilebase::isErrorTolerant().

The following functions can be used from both peptide and protein summary to get information about error tolerant modifications or residue substitutions.

  • ms_mascotresults::getErrTolModName()
  • ms_mascotresults::getErrTolModDelta()
  • ms_mascotresults::getErrTolModNeutralLoss()

See also ms_mascotresfilebase::getNumEtSeqsSearched().

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Crosslinked search results

Crosslinked search results
Mascot results file module

Crosslinked search results

Mascot 2.7 and later can search for intact crosslinked peptides as well as peptides with cleavable crosslinks. A typical example of intact crosslinking is disuccinimidyl suberate (DSS), which chemically bonds lysines in two different peptides. An MS-cleavable linker like disuccinimidyl sulfoxide (DSSO) also links lysines but mostly cleaves during CID.

Intact crosslinked peptide matches consist of the alpha peptide sequence, the beta peptide sequence and the linker. The intact link can occasionally cleave during MS/MS, which leaves behind a linker fragment called the monolink. Monolinks are modelled as ordinary variable modifications.

Conversely, cleavable crosslinks are always modelled as monolinks. The alpha and beta peptides hold different ends of the linker fragment, and there is one peptide-spectrum match for alpha and another for beta. However, if cleaving efficiency is less than 100%, some of the links may survive MS or MS/MS intact, so the search results may still contain intact crosslinked peptide matches. The rules are defined in the crosslinking method.

A linker is often chemically quenched during sample processing when one end reacts with a non-peptide molecule. The distinction between quenched linkers and linker fragments is made in the neutral loss elements of the linker definition. Mascot treats both types simply as monolinks.

By default, Parser opens crosslinked search results in a backwards-compatible mode, where intact crosslinked matches are invisible. Adding support in client code is more involved than just setting a constructor flag. Many of the methods either take a new argument in Parser 2.7, or they interpret existing arguments differently.

Glossary of terminology and concepts

Term | Synonyms | Definition
linear peptide |  | a single peptide sequence without branches or cycles
(intact) crosslink | chemical crosslink; non-cleavable link | a link between two peptides that survives MS/MS (e.g. DSS/BS3, DST, ...)
cleavable crosslink |  | a link between two peptides that cleaves during CID or is cleaved by other means before MS/MS
monolink | type 0 modification; deadend link | a linear peptide with a linker fragment whose other end is unattached
looplinked peptide | type 1 modification; intrapeptide link; intramolecular link | a single peptide where two sites are linked, forming a loop
crosslinked peptide | type 2 modification; interpeptide link; intermolecular link | two linear peptides joined by the intact crosslink
alpha peptide, beta peptide | alpha chain, beta chain | the two linear peptides part of a crosslinked unit; alpha is the heavier or longer one
homo-crosslinked peptide |  | type 2 link where alpha and beta peptides have the same sequence
hetero-crosslinked peptide |  | type 2 link where alpha and beta peptides have different sequences
protein intralink |  | a protein where two non-overlapping peptides have an intact crosslink
protein interlink |  | two proteins with an intact crosslink (either homo-crosslinked or hetero-crosslinked proteins)
crosslinking method |  | a set of parameters and settings that define which types of links to search

Note that a looplinked peptide (type 1) is different from a homo-crosslinked peptide (type 2).

Note also that either or both of the alpha or beta peptide in a crosslinked pair may contain looplinks. For simplicity of terminology, a linear peptide denotes both a single peptide sequence (with or without looplinks) and the alpha or beta peptide in a crosslinked pair (with or without looplinks).

Detecting and opening crosslinked search results

To determine whether a results file might contain matches with intact crosslinks, looplinks or monolinks, use ms_mascotresfilebase::getCrosslinkingMethod(). If the search has a crosslinking method, some of the linear peptide matches in the 'peptides' section may contain monolinks or looplinks. There is currently no easy check to determine whether there are any matches with monolinks or looplinks, other than iterating through all peptide matches. No special constructor flags are needed for accessing linear peptide data.

To determine whether there actually are crosslinked matches, use ms_mascotresfile_dat::anyCrosslinkedMatches(). If the test returns true, then the results file contains crosslinked matches and the file should be opened in integrated crosslink mode.

Three modes are available:

  1. Linear-only mode (no flag): The backwards-compatible default is to hide crosslinked matches.
    If the search contains only crosslinked matches, then opening the file in this mode means there are no matches available at all.
  2. Integrated crosslink mode (MSPEPSUM_CROSSLINK_INTEGRATED): Show matches from all sections of the results file.
  3. Crosslink-only mode (MSPEPSUM_CROSSLINK_ONLY): Hide linear matches (not recommended).

The helper function ms_mascotresfilebase::get_ms_mascotresults_params() does not set MSPEPSUM_CROSSLINK_INTEGRATED automatically. This means code written for Parser 2.6 and earlier always opens crosslinked search results in linear-only mode.

The following search types are not supported in combination with crosslinking:

  • nucleic acid databases
  • decoy searching
  • error tolerant searching
  • Percolator
  • quantitation methods
  • spectral library searching

These restrictions may be lifted in a future release.

Opening the file in integrated mode

To open the file in integrated mode, pass the flag MSPEPSUM_CROSSLINK_INTEGRATED to the matrix_science::ms_peptidesummary constructor.

The integrated crosslink mode is similar to the integrated error tolerant mode (see Integrated error tolerant search) and the integrated spectral library mode (see Opening the file in integrated mode). A query can contain a mixture of up to 20 linear and intact crosslinked peptide matches (see ms_mascotresults::getMaxRankValue()).

The identity and homology thresholds are determined by pooling match data from both linear and crosslinked peptides. For example, the total number of trials (qmatch) is the sum of qmatch from the linear summary section and qmatch from the crosslinked summary section.

Integrated mode is the preferred mode for opening crosslinked search results.

Opening the file in crosslink-only mode

To open the file in crosslink-only mode, pass the flag MSPEPSUM_CROSSLINK_ONLY to the matrix_science::ms_peptidesummary constructor.

If the search contains only linear matches, then opening the file in this mode means there are no matches available at all. Using this mode is not recommended, because you will get misleading significance thresholds.

The crosslinking method

The crosslinking method defines the linkers used in the search as well as parameters like whether to search for protein intralinks or protein interlinks. See the Mascot help page for more detail.

Use ms_mascotresfilebase::getCrosslinkingMethod() or ms_peptidesummary::getCrosslinkingMethod() to access the crosslinking method object.

How crosslinked and looplinked match data are encoded (MSR format)

Mascot Server 3.0 introduces a new file format, Mascot Search Results (MSR). The MSR format is fully documented in the Mascot Server Installation & Setup manual, chapter 8. Match data for crosslinks and looplinks is stored in the table psm__linked_sites, and monolinks are stored in psm__monolinks.

How crosslinked and looplinked match data are encoded (dat28 format)

Mascot Server 2.8 and earlier saved results in a MIME-format file with .dat extension, now called the dat28 format. The format is documented in chapter 8 of the Mascot Server Installation & Setup manual. The information below gives more detail about how crosslinked matches are stored in this format.

When Mascot parses the crosslinking method at the beginning of the search, it assigns a variable mod number to each linker specificity. For example, if the method defines linker specificities Xlink:DSS (Protein N-term) and Xlink:DSS (K), the first one could be varmod number 1 and the second varmod number 2. The linked sites are encoded in the variable mods string, and additionally in the linked_sites attribute.

Here is an example of a match with one intact link between alpha K4 (1:4:2) and beta K5 (2:5:2) and no variable modifications.

q9913_p1=-0.000397,11,66,16.87,1010001000200001201,0,0
q9913_p1_sequence_1=1,801.470831,NLGKVGSK,0000200000;"ALBU_HUMAN":0:453:460:1
q9913_p1_sequence_2=1,746.403463,ASSAKQR,000002000;"ALBU_HUMAN":0:215:221:1
q9913_p1_linked_sites=1:4:2,2:5:2

If a match has a monolink, the variable mod number of the linker is output in the variable mods string. The monolink string records the index of the corresponding neutral loss element in the linker definition. In the next example, the alpha peptide has a monolink at K8, and the intact link is between alpha K2 (1:2:2) and beta K5 (2:5:2). The monolink has neutral loss index 1, which (in this case) corresponds to monolink code [A]. NL index 0 (in this case) corresponds to the intact link [I]. The monolink string is only present if the peptide match has monolinks or looplinks.

q17957_p1=-0.000976,10,65,29.12,0010001011200001001,0,0
q17957_p1_sequence_1=2,1590.855163,LKCASLQKFGER,00200000200000;"ALBU_HUMAN":0:222:233:1
q17957_p1_sequence_2=1,746.403463,ASSAKQR,000002000;"ALBU_HUMAN":0:215:221:1
q17957_p1_linked_sites=1:2:2,2:5:2
q17957_p1_monolink_1=00000000100000
q17957_p1_monolink_2=000000000

If the match has a looplink, one end of the looplink is encoded exactly like a monolink. The other end can be inferred from the looplinked_sites attribute. Linear peptides may have monolinks and looplinks, as in the example below. The peptide has a looplink between K2 and K4. One end, K2, is encoded like a monolink, except its NL index corresponds to the intact link [I]. The peptide also has a normal monolink at K7.

q9022_p1=3,1599.934799,0.000313,8,HKPKATKEQLK,39,0020000200000,17.70,1000011012000002000,0,0;"ALBU_HUMAN":0:559:569:1
q9022_p1_monolink=0000000100000
q9022_p1_looplinked_sites=2:4

Finally, the most complicated case is a crosslinked peptide where the alpha and beta peptides have variable mods (like Oxidation (M)), monolinks and looplinks, and the variable mods additionally have fragment neutral losses. Matches this complicated are not commonly seen.

Parser API for accessing intact link, monolink and looplink data

ms_peptide methods for intact crosslinked peptide match

The ms_peptide class represents the peptide-spectrum match. The original API design assumes a linear peptide. Some interface changes have been made to allow fetching data specific to alpha and beta peptides without introducing a new class or a new set of methods.

Most ms_peptide methods take a new argument psmComponent of type ms_peptide::PSM. This is one of PSM_COMPLETE, PSM_CROSSLINK_ALPHA or PSM_CROSSLINK_BETA.

The rules for whether the parameter needs to be specified are:

  • If ms_peptide::getNumberOfLinkedPeptides() returns 0, the peptide match is linear. Leave psmComponent at its default value (PSM_COMPLETE) or omit the parameter.
  • Otherwise, set psmComponent to PSM_CROSSLINK_ALPHA or PSM_CROSSLINK_BETA to access the alpha or beta data, and PSM_COMPLETE to access match-level data.

In either case, the match may contain monolinks encoded as variable modifications, as well as looplinks.

In an intact crosslinked match, PSM_COMPLETE represents only the match-level data, such as match score. Where reasonable, methods may return data concatenated or summed from the alpha and beta peptides. For example, ms_peptide::getPeptideStr(true, ms_peptide::PSM_COMPLETE) returns a string where the alpha sequence is concatenated with the beta sequence. The two sequences are separated by "][", where the characters mark the alpha C-terminus and beta N-terminus, respectively. This ensures the concatenated variable mods string, primary NL string and related strings align correctly with the concatenated sequence string.

The table below summarises the return values when the match is an intact crosslinked peptide and the method depends on psmComponent. Methods that always return match-level data, like ms_peptide::getDelta() do not take a new parameter.

Method | Return value with PSM_COMPLETE | Return value with PSM_CROSSLINK_ALPHA | Return value with PSM_CROSSLINK_BETA
ms_peptide::getAmbiguityString() | "" | alpha string | beta string
ms_peptide::getAnyProteinTermination() | false, false | alpha values for isNterminus, isCterminus | beta value isNterminus, isCterminus
ms_peptide::getComponentStr() | alpha component if alpha component == beta component, otherwise "" | alpha component | beta component
ms_peptide::getLocalModsNlStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getLocalModsStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getLoopLinks() | alpha looplinks followed by beta looplinks | alpha looplinks | beta looplinks
ms_peptide::getMissedCleavages() | -1 if alpha/beta value is -1, otherwise alpha value + beta value | alpha value | beta value
ms_peptide::getMonoLinkStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getMrCalc() | alpha value + beta value + linker mass | alpha value | beta value
ms_peptide::getPeptideLength() | alpha length + length("][") + beta length | alpha length | beta length
ms_peptide::getPeptideStr() | alpha string + "][" + beta string | alpha string | beta string
ms_peptide::getPrimaryNlStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getSummedModsNlStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getSummedModsStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getVarModsStr() | alpha string + beta string | alpha string | beta string

ms_peptide methods for linear peptide match

The table below summarises the return values when the match is a linear peptide and the method depends on psmComponent. The argument is ignored in all cases.

Method | Return value with PSM_COMPLETE, PSM_CROSSLINK_ALPHA, PSM_CROSSLINK_BETA
ms_peptide::getAmbiguityString() | ambiguity string
ms_peptide::getAnyProteinTermination() | isNterminus, isCterminus
ms_peptide::getComponentStr() | peptide component
ms_peptide::getLocalModsNlStr() | local mods NL string
ms_peptide::getLocalModsStr() | local mods string
ms_peptide::getLoopLinks() | looplinks
ms_peptide::getMissedCleavages() | missed cleavages
ms_peptide::getMonoLinkStr() | monolink string
ms_peptide::getMrCalc() | MrCalc
ms_peptide::getPeptideLength() | peptide sequence length
ms_peptide::getPeptideStr() | peptide sequence
ms_peptide::getPrimaryNlStr() | primary NL string
ms_peptide::getSummedModsNlStr() | summed mods NL string
ms_peptide::getSummedModsStr() | summed mods string
ms_peptide::getVarModsStr() | variable mods string

Procedure for differentiating between intact links, looplinks and monolinks

For backwards compatibility, the delta returned by ms_searchparams::getVarModsDelta() is the mass of the intact link. If you open crosslinked search results in Parser 2.6 or earlier, which are unaware of the new attributes, it will appear as if monolinks and looplinks all have the same delta. This is correct for looplinks but not for monolinks.

Determining the type of the variable mod number is a sequential procedure.

  1. Get the list of intact link positions from ms_peptide::getIntactLinks().
  2. Get the list of looplink positions from ms_peptide::getLoopLinks().
  3. When looping over the variable mods string, if the mod number is 0, there's no mod or linker at this position.
  4. Otherwise:
    1. Call intactLinks.getVarModIdxOfLinkedSite() to determine whether there is an intact link at this position.
    2. If not an intact link, call loopLinks.getVarModIdxOfLinkedSite() to determine whether there is looplink at this position.
    3. If not a looplink, extract the the monolink number from the monolink string, ms_peptide::getMonoLinkStr(), at the same position. Use the variable mod number and the monolink number as arguments to ms_mascotresfilebase::getMonoLinkModification(). If it returns a valid object, this position encodes a monolink.
    4. Otherwise, this position is an ordinary variable modification.

Processing intact link and looplink data is easiest in a separate loop. For intact links:

  1. Get the list of intact link positions from ms_peptide::getIntactLinks().
    This class encapsulates the linked_sites line.
  2. Loop over the contents of the ms_linker_site_vector:
    1. Access the linker start and end positions and the variable mod numbers using the ms_linker_site methods.
    2. Note that the PSM component is different at either end of the link.

Processing looplink data is the same, except it is typically easiest to do it separately for alpha and beta peptides:

  1. Get the list of intact link positions from ms_peptide::getLoopLinks(PSM_CROSSLINK_ALPHA).
    This class encapsulates the looplinked_sites line.
  2. Loop over the contents of the ms_linker_site_vector:
    1. Access the looplink start and end positions and the variable mod numbers using the ms_linker_site methods.
    2. Note that the PSM component is PSM_CROSSLINK_ALPHA at both ends of the link.
  3. Repeat for PSM_CROSSLINK_BETA.

Note that the monolink index zero could mean either lack of modification (if the variable mods string also has a zero) or the first monolink in the linker definition. It's important to check both the variable mods string and the monolink string.

The following C++ code illustrates processing the variable mods, intact links, looplinks and monolinks of a linear peptide match.

C++
std::string varModsStr = peptide.getVarModsStr();
std::string monoLinkStr = peptide.getMonoLinkStr();
ms_linker_site_vector intactLinks = peptide.getIntactLinks();
ms_linker_site_vector loopLinks = peptide.getLoopLinks(ms_peptide::PSM_COMPLETE);

for (int i = 0; i < varModsStr.length(); ++i) {
  int modNum = convertToInt(varModsStr[i]);
  int monoLinkNum = 0;

  // Monolink string could be empty -- check first.
  if (monoLinkStr.size() > 0)
    monoLinkNum = convertToInt(monoLinkStr[i]);

  if (modNum == 0)
    continue;

  // Is it an intact link?
  if (0 < intactLinks.getVarModIdxOfLinkedSite(ms_peptide::PSM_COMPLETE, i)) {
    // Yes, it's an intact link. Process in a separate loop as described above.
    continue;
  }

  // Is it a looplink in either PSM component?
  if (0 < loopLinks.getVarModIdxOfLinkedSite(ms_peptide::PSM_COMPLETE, i)) {
    // Yes, it's a looplink. Process in a separate loop as described above.
    continue;
  }

  // Is it a monolink?
  const ms_modification *monoLinkMod = resfile.getMonoLinkModification(modNum, monoLinkNum);
  if (monoLinkMod) {
    delta = monoLinkMod->getDelta(MASS_TYPE_MONO);
    continue;
  }

  // Not intact link, monolink or looplink, so it's a regular variable mod.
  delta = resfile.params().getVarModsDelta(modNum);
}

Processing the alpha or beta peptide in a crosslinked match is very similar; simply replace ms_peptide::PSM_COMPLETE with ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA where relevant.

Protein inference

Protein inference and the ms_protein API are not affected by the presence of monolinks or looplinks, since these are just variable modifications.

However, there are a few details to consider with intact crosslinked peptides. A peptide match is assigned to a protein hit when the alpha sequence, the beta sequence or both appear in the protein. Methods that return sequence-level data, such as ms_protein::getPeptideStart() now take a new parameter psmComponent. The change is analogous to ms_peptide methods for intact crosslinked peptide match. In fact, the easiest way to check whether psmComponent is assigned to the protein is by looking at the return value of getPeptideStart(): if it's -1, the psmComponent is not assigned to the protein hit.

The definition of duplicate peptide has been extended:

  • A crosslinked peptide and a linear peptide can never be duplicates of each other.
  • A crosslinked peptide can be a duplicate of another crosslinked peptide if their alpha sequences are the same, beta sequences are the same, alpha variable modifications, monolinks and looplinks are the same, beta variable modifications, monolinks and looplinks are the same and the linker positions and sites are the same.

No client code changes are needed; duplicate checking is done internally, as before. (For more details, see Peptide match duplicates.)

Protein inference is not affected by intact crosslinks. That is, the intact crosslink between two proteins is not enough to cluster them in the same protein family. Clustering requires sharing the same significant alpha or beta sequence.

If a protein has any crosslinked peptides, these are ignored when emPAI is calculated.

ms_protein methods for intact crosslinked peptide match

The table summarises the return values when at least one psmComponent is assigned to the protein hit.

Method | Return value with PSM_COMPLETE | Return value with PSM_CROSSLINK_ALPHA | Return value with PSM_CROSSLINK_BETA
ms_protein::getPeptideStart() | -1 | alpha value (if alpha is in this protein) or -1 | beta value (if beta is in this protein) or -1
ms_protein::getPeptideEnd() | -1 | alpha value (if alpha is in this protein) or -1 | beta value (if beta is in this protein) or -1
ms_protein::getPeptideMultiplicity() | -1 | alpha value (if alpha is in this protein) or -1 | beta value (if beta is in this protein) or -1
ms_protein::getPeptideFrame() | -1 | alpha value (if alpha is in this protein) or -1 | beta value (if beta is in this protein) or -1
ms_protein::getPeptideResidueBefore() | '?' | alpha value (if alpha is in this protein) or '?' | beta value (if beta is in this protein) or '?'
ms_protein::getPeptideResidueAfter() | '?' | alpha value (if alpha is in this protein) or '?' | beta value (if beta is in this protein) or '?'

ms_protein methods for linear peptide match

When the peptide match assigned to the protein hit is a linear peptide, the psmComponent argument is ignored.

Method | Return value with PSM_COMPLETE, PSM_CROSSLINK_ALPHA, PSM_CROSSLINK_BETA
ms_protein::getPeptideStart() | start position
ms_protein::getPeptideEnd() | end position
ms_protein::getPeptideMultiplicity() | multiplicity
ms_protein::getPeptideFrame() | frame or -1
ms_protein::getPeptideResidueBefore() | residue before
ms_protein::getPeptideResidueAfter() | residue after

Fragmenting crosslinked and looplinked peptides

ms_aahelper::calcFragmentsEx() and related methods can fragment a crosslinked peptide. Fragmentation produces single-cleavage product ions. First, the beta sequence is treated as a modification attached to the alpha peptide, and the alpha sequence is fragmented as usual. Then the roles are reversed. The final list of fragments contains single-cleavage ions from alpha and single-cleavage ions from beta. There are no double-cleavage ions where the alpha and beta fragment simultaneously.

The ms_fragment class has two new methods: isFromAlpha() and isFromBeta(). Fragmenting a linear peptide produces ms_fragment objects where both methods return false. Fragmenting a crosslinked peptide produces fragments where one or the other flag is true. Because there are no double-cleavage ions, isFromAlpha() and isFromBeta() cannot both be true at the same time.

There is a helper method for linking two peptide objects: ms_aahelper::createCrosslinkedPeptide().

Fragmenting a peptide with looplinks the exactly the same as fragmenting a peptide without looplinks, apart from one exception. The looplink is assumed to be stronger than the peptide backbone. Thus, there are no fragments that start or end in the region spanned by a looplink. This includes regular series as well as internals.

Crosslinking changes in ms_peptidesummary

There is a new method that returns the number of discovered intact crosslinks and looplinks: ms_peptidesummary::getNumDiscoveredIntactLinks()

Because monolinks share the same variable mod number, ms_peptidesummary::getNumDiscoveredVariableMods() has been extended. The method returns the modification names and deltas as well as counts, positions and sites.

ms_peptidesummary::getAllProteinsWithThisPepMatch() has been extended to return the psmComponent assigned to the protein hit.

There are no changes to the parameters of ms_peptidesummary::findPeptides(). If you search for a peptide sequence with findPeptides(), it will compare the input string to both the alpha sequence and beta sequence. If either one is a match, findPeptides() adds it to the return vector.

Calling ms_peptidesummary::getReadableVarMods() without psmComponent produces a human-readable string of variable modifications, monolinks, looplinks and intact links contained in the peptide match.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Using the singleHit parameter to return a single protein

Using the singleHit parameter to return a single protein
Mascot results file module

The singleHit parameter for ms_proteinsummary and ms_peptidesummary should only be used for retrieving the results for a single protein. The purpose of the parameter is to do the retrieval more quickly than by generating a full results file object. This is used, for example, in the Mascot Server protein view report.

Note that the value passed as the singleHit parameter will be different in these two cases. However, in both cases the single protein hit can be obtained using ms_mascotresults::getHit(1).

Getting a single hit from the protein summary

The parameters when creating an ms_proteinsummary object should be as follows:

  • resfile should be the ms_mascotresfile object.

  • flags should generally be set to MSRES_IGNORE_PMF_MIXTURE, because the return value from getProteinSummaryHit() is the hit number that corresponds to the protein summary with mixtures and grouping ignored.

    Obviously, if the protein is from the decoy section, then MSRES_DECOY also needs to be specified.

  • minProbability should be set to zero. If this is set to a higher value than the score for the requested protein, then no results will be returned.

  • maxHitsToReport should be set to 1 for clarity. Any value above one would still return only one protein. A value of zero would return no proteins.

  • unigeneIndexFile can be used as normal for a UniGene entry.

  • singleHit is the hit number as a string from the protein summary. This is the hit number in the results file, and hence is the same number as when the protein summary is used without grouping. The hit number can be obtained by creating an ms_proteinsummary object without the singleHit parameter and using getProteinSummaryHit().

Getting a single hit from the peptide summary

Mascot Server 2.3 introduced caching of results files for peptide summary reports. See Using the pepsum cache for protein_view.pl for details. If caching is enabled, opening the results file in the usual way is as fast as using the singleHit parameter.

For backwards compatibility, and when caching is disabled, you can still use the singleHit parameter. In that case, the parameters when creating an ms_peptidesummary object should be as follows:

  • resfile should be the ms_mascotresfile object.

  • flags can be set to 0. All of the flags are still processed and used as for a normal results object. However, since a single protein is being returned, flags relating to grouping are essentially ignored.

    MSRES_REQUIRE_BOLD_RED will have a limited meaning: every peptide will be 'bold' because it s the first time it has been reported.

    The MSRES_DUPE_INCL_ and MSRES_DUPE_REMOVE_ flags are treated as normal.

  • minProbability should be set to zero. If this is set to a higher value than the score for the requested protein, then no results will be returned.

  • maxHitsToReport should be set to 1 for clarity. Any value above one would still return only one protein. A value of zero would return no proteins.

  • unigeneIndexFile can be used as normal for a UniGene entry.

  • ignoreIonsScoreBelow should be set to the same value that you would normally use.

  • minPepLenInPepSummary should be set to the same value that you would normally use.

  • singleHit is the accession string for the protein that is to be retrieved. For new applications, the database ID should be specified in the string, followed by a colon. Example: "3:CH60_SHEON".

  • flags2 should be MSPEPSUM_SINGLE_HIT_DBIDX if the singleHit accession string starts with the database ID followed by a colon.
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Automated repeating of searches

Automated repeating of searches
Mascot results file module

A common requirement is to repeat all searches with, for example, a different or updated database. The standard Mascot Server reports provide a button "Search Selected" or "Re-search all" to repeat a search, but it is tedious to do this manually for more than a few searches. Mascot Daemon also allows searches to be repeated as a follow on from a search using the original peak lists.

Repeating searches in a batch can easily be achieved using Mascot Parser. It is assumed you have access to a Mascot Server installation.

Overview

To repeat a search, nph-mascot.exe has to be run with command parameter 4 and the search data needs to be taken from a MIME format input file. The format of the input file is described in the Mascot Installation and Setup manual, chapter 8.

MIME Format File

In its simplest form, the MIME format file has the following structure:

    ----12345
    Content-Disposition: form-data; name="QUE"

    MASS=Monoisotopic
    CLE=Trypsin
    ...

    1234.012
    1567.086
    ----12345--

where MASS, CLE, etc. are the search parameters, and the two numbers are simply two masses for a peptide mass fingerprint search. Note the standard MIME format header and terminating line.

You can access the search parameters easily in Mascot Parser by using the params() method of the ms_mascotresfilebase object. Another way is to iterate through the keys using ms_mascotresfilebase::getSearchParametersKeyValues(), which avoids having to type all parameter names directly.

The following example prints all search parameters except DB, which is changed to another database. INTERMEDIATE and RULES are also skipped for reasons explained below.

C++
    ms_mascotresfilebase resfile = ms_mascotresfilebase::createResfile(filename);

    if (!resfile.isValid()) {
        /* Error handling... */
    }

    std::vector<std::string> keys, values;
    resfile.getSearchParametersKeyValues(keys, values);

    for (size_t i = 0; i != keys.size(); ++i) {
        std::string key = keys[i];
        std::string val = values[i];

        if (!val.empty() && key != "INTERMEDIATE" && key != "RULES" && key != "DB")
            std::cout << key << "=" << val << std::endl;
    }

    std::cout << "DB=My_database" << std::endl;

Perl
    my $resfile = msparser::ms_mascotresfilebase::createResfile($filename);

    if (not $resfile->isValid()) {
        # Error handling...
    }

    my $keys = msparser::VectorString->new;
    my $values = msparser::VectorString->new;
    $resfile->getSearchParametersKeyValues($keys, $values);

    for my $i (0 .. $keys->size()-1) {
        my $key = $keys->get($i);
        my $val = $values->get($i);

        if ($val ne '' and $key ne "INTERMEDIATE" and $key ne "RULES" and $key ne "DB") {
            print $key, "=", $val, "\n";
        }
    }

    print "DB=My_database\n";

Java
    ms_mascotresfilebase resfile = ms_mascotresfilebase::createResfile(filename);

    if (!resfile.isValid()) {
        /* Error handling... */
    }

    VectorString keys = new VectorString();
    VectorString values = new VectorString();
    resfile.getSearchParametersKeyValues(keys, values);

    for (int i = 0; i != keys.size(); ++i) {
        String key = keys.get(i);
        String val = values.get(i);

        if (val != "" && key != "INTERMEDIATE" && key != "RULES" && key != "DB")
            System.out.println(key + "=" + val);
    }

    System.out.println("DB=My_database");

Python
    resfile = msparser.ms_mascotresfilebase::createResfile(filename)

    if not resfile.isValid() :
        # Error handling...

    keys = msparser.VectorString()
    values = msparser.VectorString()
    resfile.getSearchParametersKeyValues(keys, values);

    for i in range(keys.size()):
        key = keys.get(i)
        val = values.get(i)

        if len(val) > 0 and key != "INTERMEDIATE" and key != "RULES" and key != "DB" :
            print("%s=%s" % (key, val))

    print("DB=My_database")

C#
    ms_mascotresfilebase resfile = ms_mascotresfilebase::createResfile(filename);

    if (!resfile.isValid()) {
        /* Error handling... */
    }

    VectorString keys = new VectorString;
    VectorString values = new VectorString;
    resfile.getSearchParametersKeyValues(keys, values);

    for (int i = 0; i != keys.Count; ++i) {
        String key = keys[i];
        String val = values[i];

        if (val != "" && key != "INTERMEDIATE" && key != "RULES" && key != "DB")
            Console.WriteLine("{0} = {1}",key,val);
    }
    Console.WriteLine("DB=My_database");

For MS-MS data, the complete set of ions peaks could be megabytes or even gigabytes of data, and it may make no sense to copy the data into the repeat search file. nph-mascot.exe supports a "query" statement for this purpose, which is returned by getRepeatSearchString():

C++
    for (int q=1; q != resfile.getNumQueries(); q++)
        std::cout << resfile.getRepeatSearchString(q) << std::endl;

Perl
    for my $q (1 .. $resfile->getNumQueries()) {
        print $resfile->getRepeatSearchString($q), "\n";
    }

Java
    for (int q = 1; q != resfile.getNumQueries(); q++)
        System.out.println(resfile.getRepeatSearchString(q));

Python
    for q in range(1, 1 + resfile.getNumQueries()) :
        print(resfile.getRepeatSearchString(q))

C#
    for (int q = 1; q != resfile.getNumQueries(); q++)
        Console.WriteLine(resfile.getRepeatSearchString(q));

When nph-mascot.exe reads in a query statement, it loads the original input data from the Mascot results (.dat) file. To this end, you also need to add the INTERMEDIATE parameter that points to the original results file:

C++
    std::cout << "INTERMEDIATE=" << filename << std::endl;

Perl
    print "INTERMEDIATE=", $filename, "\n";

Java
    System.out.println("INTERMEDIATE=" + filename);

Python
    print("INTERMEDIATE=%s" % filename)

C#
    Console.WriteLine("INTERMEDIATE={0}", filename);

Running the repeat search

In the example code, the search is run by calling nph-mascot.exe with two parameters, and the repeat search data is piped into the process' standard input:

    nph-mascot.exe 4 -commandline > tmp.txt

The 4 indicates that this is a repeat search. The -commandline parameter is used to prevent progress reports and HTML being written to standard out.

For a successful search, the output (e.g. tmp.txt) will be of the form:

    SUCCESS
    ../data/20031007/F001547.dat

where the data file name is output following the text "SUCCESS".

If an error occurs, the output will be of the form:

    FATAL_ERROR: M00027
    Sorry, the database (SwissProt) is not currently available for searching [M00027]

Comparing the results

The example code uses a simple approach to compare the old and new results. For searches with PMF data, the top protein hit from both searches are compared and if their scores differ by more than 10, then the difference is reported.

For searches with MS-MS data, peptide matches are compared, and a score difference of more than 10 will be reported.

It is more than likely that these comparison rules will need to be changed for optimum results.

Remember that if the searches were performed with a much older version of Mascot Server, then the scores may have changed a little because minor changes have been made to Mascot to optimize the scoring. However, a score difference of greater than 10 is likely to indicate a new protein sequence in the database.

Example Code

Example code is provided in various programming languages:

  • repeat_search.cpp
  • repeat_search.pl
  • repeat_search.java
  • repeat_search.py
  • repeat_search.cs

The sample program takes a single input file, repeats the search and compares results as above. To run the program on a whole directory of files, use 'find' under Unix, or a FOR loop in a batch/cmd file under Windows. For example, to repeat all searches from the year 2002 under Unix:

    # find ../data/2002???? -name \*.dat | xargs -n 1 repeat_search.pl

Remember that new results will go in 'todays' directory, so be sure not to include that directory with 'find' or the repeated searches will be repeated again and again and again...

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Target-decoy searches and false discovery rate

Target-decoy searches and false discovery rate
Mascot results file module

Decoy search results

In Mascot Server 2.2 and later, any search can be run against a decoy database generated on the fly. Each sequence in the database is randomised or reversed and then searched along with the original sequence. Results for matches against the original sequence are stored as normal, while results against the randomised sequence are saved in the decoy_summary, decoy_mixture and decoy_peptides sections. The decoy algorithm type is saved in the header section and can be retrieved with ms_mascotresfilebase::getDecoyTypeForDB.

It is easy to switch between the decoy results and the standard results. To view the decoy results, specify MSRES_DECOY when creating the ms_peptidesummary or ms_proteinsummary object.

The functions ms_mascotresfilebase::anyFastaMatches(), ms_mascotresfilebase::anySpectralLibrary(), ms_mascotresfilebase::anyErrorTolerantMatches() ms_mascotresfilebase::anyCrosslinkedMatches() and ms_mascotresfile_dat::getNumHits() have an optional section name parameter so that these can be used with decoy or error tolerant results.

Calculating the false discovery rate (FDR)

The false discovery rate is an estimate of the proportion of false discoveries (false positives) among all significant matches. The number of hits in the decoy database provides the estimated number of false positives. The FDR is then (number of decoy hits) / (number of target hits).

The following methods return the number of hits at different thresholds:

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

For a peptide summary, the number of hits is the number of peptide matches, while for a protein summary, the number of hits is the number of protein matches.

You can use ms_searchparams::getDECOY() to decide whether to display false discovery rates.

Automatically adjusting the significance threshold

You can use ms_mascotresults_params::setTargetFDR() to set a target FDR. Parser will choose a significance threshold that yields an FDR as close as possible to the target. The chosen significance threshold is available through ms_mascotresults::getProbabilityThreshold().

If the search is an error tolerant target-decoy search, the target FDR applies to both first and second pass matches; see Score thresholds and score filtering (Mascot Server 2.8 and later).

Another procedure available in Parser 2.7 and earlier was to use ms_mascotresults::getThresholdForFDRAboveIdentity or ms_mascotresults::getThresholdForFDRAboveHomology to automatically determine a significance threshold that yields the desired target FDR. This procedure is no longer recommended, because it requires creating an auxiliary ms_peptidesummary object.

  1. Create ms_mascotresfilebase as usual; call it resfile.
  2. Create ms_peptidesummary as usual; call it pepsum. The minProbability parameter can be the default (0.05).
  3. Decide on a target FDR, say 0.01, and get new minProbability with ms_mascotresults::getThresholdForFDRAboveHomology. You may want to check the return value and closestFDR, since it's not always possible to find a suitable FDR, especially in small searches.
  4. Create a new ms_peptidesummary object using the same resfile but new minProbability. The rest of the parameters can be the same as before. You don't need to keep the original pepsum object in memory. It's only needed for finding the desired significance threshold.

Note that the FDR is a global FDR and it applies to the whole search.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Using Percolator scores

Using Percolator scores
Mascot results file module

Mascot Server ships with Percolator, which is an algorithm that uses semi-supervised machine learning to improve the discrimination between correct and incorrect spectrum identifications.

Percolator was developed by Lukas Käll, Jesse D Canterbury, Jason Weston, William Stafford Noble and Michael J MacCoss at the University of Washington, Department of Genome Sciences.

  • https://www.matrixscience.com/help/percolator_help.html
  • https://github.com/percolator/percolator
  • http://percolator.ms/

Percolator scores can be shown in Mascot Server reports instead of Mascot ions scores.

Workflow

Percolated results are available both for old and new searches. However, they are only available when a decoy search has been performed. The Mascot results file is not changed by Percolator, but additional files for each results file are created by running ms-createpip.exe and percolator.exe.

ms-createpip.exe calculates core features from the peptide match data. Mascot Server 3.0 and later can also fetch predicted features from other machine learning tools like MS2Rescore using an adapter interface. There are two sets of pip (Percolator input) and pop (Percolator output) files, whose names depend on Mascot options and ML adapter parameters. These are enumerated below.

Name | Meaning | Dependencies
Core pip file Percolator input (pip) file created by ms-createpip.exe, containing features calculated from target and decoy peptide matches. The core pip file name and contents depend on mascot.dat options:
  • PercolatorFeatures (string)
  • PercolatorUseRT (true/false)
  • PercolatorUseProteins (true/false)
  • PercolatorExeFlags (string)
  • PercolatorTargetRankScoreThreshold (int)
  • PercolatorTargetRankRelativeThreshold (double)
Final pip file | Pip file created by insert_predicted_data.pl from the core pip file, containing features predicted by machine learning tools (e.g. MS2Rescore). | The final pip file name and contents depend on the core pip file, the above mascot.dat options, plus any ML adapter parameters (e.g. with MS2Rescore, the MS2PIP model name).
Pop file | Percolator output (pop) file created by percolator.exe from a pip file. Percolator creates one pop file for target matches and one for decoy matches. | The target and decoy pop file names depend on the above mascot.dat options plus any ML adapter parameters. The contents depend only on the pip file given as argument.

Workflow on the client side

When you use Parser in a client application, you need the results file and the target/decoy pop files. Normally these are downloaded from Mascot Server, and the easiest way is using ms_http_client_search.

  • Download the search results, e.g. using ms_http_client_search::downloadResultsFileMSR.
  • Download pop files, e.g. using ms_http_client_search::downloadPercolatorFile.
  • Also download the mascot.dat configuration file, e.g. using ms_datfile.

Parser reads pop files from a fixed location:

  • The directory is set using cacheDirectory argument to the ms_mascotresfilebase constructor. Pop files must be placed there even if other caching is disabled.

  • The pop file name is generated from Percolator settings in the mascot.dat Options section, by calling ms_mascotresfilebase::setPercolatorFeatures().

    Parser will only find the downloaded pop file if you use exactly the same Percolator options as were used on server side.

The detailed workflow is:

  1. Mascot Server 3.0 and later: Set PERCOLATE=1 search parameter.
    Mascot Server 2.8 and earlier: Set Percolator option to 1 in mascot.dat on server side, so that Mascot runs ms-createpip.exe and percolator.exe at the end of the search (ExecAfterSearch).
  2. Run a Mascot search, making sure that the DECOY option is on. Download the results file.
  3. Download config/mascot.dat.
  4. Download the pop files.
  5. Check that there are sufficient queries in the search by comparing ms_mascotresfilebase::getNumQueries() with ms_mascotoptions::getPercolatorMinQueries().
  6. Check that there are sufficient sequences in the search by comparing ms_mascotresfilebase::getNumSeqsAfterTax() with ms_mascotoptions::getPercolatorMinSequences().
  7. Generate the pip and pop file names: call ms_mascotresfilebase::setPercolatorFeatures(). Use the same ms_mascotoptions object.
  8. Specify MSPEPSUM_PERCOLATOR as part of the flags2 parameter when creating an ms_peptidesummary object.
  9. Optionally, specify target FDR with ms_mascotresults_params::setTargetFDR().

If the downloaded pop file name doesn't match the one generated by setPercolatorFeatures(), it may be because the Mascot options have a difference, or it could be because you are using a different version of Parser compared to the Mascot Server version. An easy workaround is to rename the downloaded pop files to match the file names returned by ms_mascotresfilebase::getPercolatorFileNames().

Workflow on the server side

For completeness, the workflow in Mascot Server is as follows. The workflow is implemented in the server-side script mascot/bin/refine_results_with_ml.pl. The detailed steps are:

  1. Run a Mascot search, making sure that the DECOY option is on.
  2. Check that there are sufficient queries in the search by comparing ms_mascotresfilebase::getNumQueries() with ms_mascotoptions::getPercolatorMinQueries().
  3. Check that there are sufficient sequences in the search by comparing ms_mascotresfilebase::getNumSeqsAfterTax() with ms_mascotoptions::getPercolatorMinSequences().
  4. Run refine_results_with_ml.pl.

refine_results_with_ml.pl performs the steps:

  5. Generate the core pip file name.
    • If ML adapters are not active, the core pip file is the same as the final pip file.
    • Generate the core pip file name: call ms_mascotresfilebase::setPercolatorFeatures() with empty vector as the adapterParameters argument.
  6. Retrieve the pip file name with ms_mascotresfilebase::getPercolatorFileNames().
  7. Run ms-createpip.exe, specifying the output filename as the core pip file.
  8. Generate the final pip and pop file names: call ms_mascotresfilebase::setPercolatorFeatures(). If any ML adapters should be enabled, pass the ML adapter parameters as the vector argument.
  9. If the core and final pip files are different, run insert_predicted_data.pl with core pip file as –pipfile_in and final pip file as –pipfile_out, and giving the ML adapter parameters as arguments.
  10. Run percolator.exe with command-line parameters from getPercolatorExeFlags() , giving the final pip and pop file names as argument.

Finally:

  11. If the final pip and pop files were generated successfully, specify MSPEPSUM_PERCOLATOR as part of the flags2 parameter when creating an ms_peptidesummary object.
  12. Optionally, specify target FDR with ms_mascotresults_params::setTargetFDR().

Steps 5 to 10 can be performed automatically after a search by specifying the appropriate options in getExecAfterSearch() .

There is also a static function, staticGetPercolatorFileNames() that can be called to get filenames without creating an ms_mascotresfile_msr or ms_mascotresfile_dat object.

Percolator Scores

A 'Percolator score' is calculated from the posterior error probability (PEP) by

    percolatorScore = -10 * log10(PEP)

This is analogous to the Mascot ions score, which is -10*log10(p-value). The posterior error probability is similar to but not the same as a p-value.

Percolator processes the rank 1 matches found by Mascot, plus any other ranks as defined by ms_mascotoptions::getPercolatorTargetRankScoreThreshold and ms_mascotoptions::getPercolatorTargetRankRelativeThreshold.

Peptide matches that were not processed by Percolator get a score based on the rank 1 match, scaled by the Mascot ions score:

    rank2PercolatorScore = (rank2MascotIonsScore/rank1MascotIonsScore) * rank1Percolatorscore

If the PEP value for rank 1 is exactly 1, it is reset to 0.9999. This is to ensure that there is a tiny amount of spread in scores for lower ranking peptides.

The function ms_peptide::getPercolatorScores() returns the posterior error probability which is used by Mascot Parser. A different score (calculated by Percolator itself) and the qValue can also be obtained, but these are unused by Mascot Parser.

When the MSPEPSUM_PERCOLATOR flag is specified, all Mascot scores are replaced with percolator derived scores. The original Mascot ions score for a peptide is still available by calling getPercolatorScores(). The following table describes how each of the existing Mascot functions have been changed to return Percolator values.

Mascot Parser Function | How value is calculated
ms_peptide::getIonsScore() | -10 * log10( posterior error probability )
ms_protein::getPeptideIonsScore() | Same value as getIonsScore() above, except a minor correction for large proteins is applied in the same way as for the Mascot Score.
ms_protein::getScore() | Calculated using the percolator scores rather than Mascot scores. Same rules for MudPIT and standard scoring apply.
ms_protein::getNonMudpitScore() | Calculated using the percolator scores rather than Mascot scores. Same rules for MudPIT scoring apply.
ms_mascotresults::getPeptideIdentityThreshold() | Calculated by taking -10log10(sigthreshold), so a value of sigthreshold=0.05 gives a threshold score of ~13
ms_mascotresults::getAvePeptideIdentityThreshold() | With Percolator, the threshold is the same for every query, so this is exactly the same as getPeptideIdentityThreshold() above.
ms_mascotresults::getMaxPeptideIdentityThreshold() | With Percolator, the threshold is the same for every query, so this is exactly the same as getPeptideIdentityThreshold() above.
ms_mascotresults::getHomologyThreshold() | With Percolator, there is no homology threshold, so this always returns 0.
ms_mascotresults::getHomologyThresholdForHistogram() | With Percolator, there is no homology threshold, so this always returns 0.
ms_mascotresults::getPeptideExpectationValue() | Return the posterior error probability by calculating it back from the score using 10 ^ score/-10. The same value can also be obtained by calling ms_peptide::getPercolatorScores() and retrieving the posterior error probability value.
ms_mascotresults::getProbFromScore() | Calls getPeptideExpectationValue() as above.
ms_mascotresults::getIonsScoreHistogram() | Returns a vector of Percolator scores rather than Mascot scores.
ms_mascotresults::getProteinScoreForHistogram() | Returns the Percolator protein score rather than Mascot protein score
ms_mascotresults::getNumHitsAboveIdentity() | Any peptide with a posterior error probability less than the significance value specified will be counted.
ms_mascotresults::getNumDecoyHitsAboveIdentity() | Any peptide with a posterior error probability less than the significance value specified will be counted.
ms_mascotresults::getNumHitsAboveHomology() | No homology thresholds, so always returns the same number as getNumHitsAboveIdentity().
ms_mascotresults::getNumDecoyHitsAboveHomology() | No homology thresholds, so always returns the same number as getNumDecoyHitsAboveIdentity().

You currently cannot specify MSPEPSUM_PERCOLATOR with an Integrated error tolerant search.

The following configuration functions are relevant:

  • ms_mascotresfilebase::setPercolatorFeatures()
  • ms_mascotoptions::isPercolator()
  • ms_mascotoptions::getPercolatorFeatures()
  • ms_mascotoptions::getPercolatorTargetRankScoreThreshold
  • ms_mascotoptions::getPercolatorTargetRankRelativeThreshold
  • ms_mascotoptions::getPercolatorMinQueries()
  • ms_mascotoptions::getPercolatorMinSequences()
  • ms_mascotoptions::isPercolatorUseProteins()
  • ms_mascotoptions::isPercolatorUseRT()
  • ms_mascotoptions::getPercolatorExeFlags()
  • ms_mascotoptions::getExecAfterSearch()
  • ms_mascotresfilebase::staticGetPercolatorFileNames()
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Caching Mascot Results

Caching Mascot Results
Mascot results file module

Mascot Parser supports two types of cache file, which speed up access to very large results files.

  • resfile cache: A cache for the results file itself (ms_mascotresfile_dat), i.e. the .dat file.
  • pepsum cache: A cache for the protein and peptide data after protein inference (ms_mascotresults/ms_peptidesummary).

Resfile cache (MSR format)

Mascot Server 3.0 introduces a new file format, Mascot Search Results (MSR). The MSR file is an SQLite database, which provides fast random access to the 'raw' search results. Unlike dat28 files (described below), no resfile cache is required for MSR.

Parser supports saving protein inference results from an MSR file in a pepsum cache.

Resfile cache (dat28 format)

Mascot Server 2.8 and earlier saved results in a MIME-format file with .dat extension, now called the dat28 format. For new applications, we recommend using MSR files, as they are much more efficient for random access.

For dat28 files, Mascot Parser 2.3 and later support the use of cache files to speed up access. The resfile cache is an index to different sections and raw lines of the results file itself, and only needs to be rebuilt if the file changes.

Parser supports saving protein inference results from a dat28 file in a pepsum cache.

Pepsum cache (both formats)

The pepsum cache contains processed and grouped protein hits and peptide data. It is created and used by ms_peptidesummary. Without a pepsum cache, protein grouping needs to be done anew every time an ms_peptidesummary object is created. With caching, the grouped data can be stored in the cache file, and subsequent file access can skip protein grouping entirely.

For MSR files, the pepsum cache has file extension .sdb, which is an SQLite database.

For dat28 files, the pepsum cache has file extension .cdb, which is a read-only key-value database.

Specifying cache file directory

In a standard Mascot Server setup, cache files are located in a directory specified by the CacheDirectory value in the options section of mascot.dat. If CacheDirectory specifies a relative directory, then it is relative to the current working directory of the calling program. The function ms_mascotoptions::getCacheDirectory() can be used to retrieve the cache directory from mascot.dat. In all Mascot Server scripts, the return value from this function is passed to the ms_mascotresfilebase::createResfile.

Cache files for a specific results file are put into their own directory under the directory specified by CacheDirectory. The name of the directory is constructed by calling getMD5Sum() and passing a string comprising the filename (or filenames if combining multiple results files; see Combining multiple results files), file size and last modified date. The function ms_mascotresfile::getCacheDirectory() can be used to retrieve the directory used for cache files for a specific results file.

A number of special 'tokens' can be used to split the potentially large number of files/directories into more convenient subdirectories. The 'tokens' are generated using the strftime function using the last modified date of .dat file. Whilst the strftime function has a large number of options, the ones most likely to be useful are:

  • %d - The day of the month as a decimal number (range 01 to 31)
  • %m - The month as a decimal number (range 01 to 12)
  • %y - The year as a decimal number without a century (range 00 to 99)
  • %Y - The year as a decimal number including the century

Other tokens accepted by strftime are documented here: http://www.cplusplus.com/reference/clibrary/ctime/strftime/

The default value is "../data/cache/%Y/%m" which specifies a new directory for each month. For example, for a file dated the 3rd February 2020, the files would be in a directory ../data/cache/2020/02.

Mascot Parser will try to create a cache directory if it doesn't exist. If necessary, it will create the whole directory tree.

Filenames for the pepsum cache files

The base name for pepsum cache for dat28 format is

    F01234.dat.[a-z0-9]*.cdb

The base name for pepsum cache for MSR format is

    F01234.msr.[a-z0-9]*.sdb

The segment [a-z0-9] will be replaced by exactly 26 numbers or lower-case letters created by calling getMD5Sum() on a string created using all parameters passed to the ms_peptidesummary constructor, including the UniGene index file path.

If, for example, two reports are created for the same results file, one with a probability threshold of 0.05 and another with a threshold of 0.001, then separate cache files with unique filenames will be created, making it fast to switch between the two reports. Separate cache files are necessary, because changing any of the constructor parameters may change protein and peptide scoring, grouping, cut-off thresholds, etc.

The following flags do not affect the contents of the cache file and therefore are not included in the MD5Sum for the name:

  • matrix_science::ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE
  • matrix_science::ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE

The function ms_peptidesummary::getCacheFileName() can be called to retrieve the full or relative path to the cache file.

Using the resfile cache (dat28 format only)

The default constructor for ms_mascotresfile_dat has the flag RESFILE_NOFLAG, which means that when a results file is opened, no cache will be used. Simply specify RESFILE_USE_CACHE to use a cache. This flag is a "no-op" for MSR files.

Most errors relating to the cache files are 'soft'. For example, if two applications both try and create a cache file at the same time, then the first will succeed in creating the cache file, and the second one will carry on without using a cache. If an application crashes in the middle of creating a file, then the next application to try and use the cache will re-create it. If an application fails to create the cache for any reason, it will carry on without the cache.

A resfile cache may be recreated under some conditions, even when it already exists:

  • If the size or last modified date of a results file has changed since the cache was created, then the cache will be rebuilt.
  • An internal version number for the cache is saved within the file. If Matrix Science need to change the format of the cache file, then this will cause the cache to be rebuilt.

The resfile cache has a maximum size of 4GB. In general, the ms_mascotresfile_dat cache file is about 10% of the size of the results file.

The static function ms_mascotresfile_dat::willCreateCache() can be called before creating an ms_mascotresfile_dat object to determine if a cache file will be created. This is useful in checking whether creating the object will take a long time.

The function ms_mascotresfile::getCacheFileName() can be called to retrieve the full or relative path to the cache file.

Using the pepsum cache (MSR and dat28)

Specify MSPEPSUM_USE_CACHE when creating the ms_peptidesummary object to enable caching.

If the cache file doesn't exist, then it will be created. If it exists, then the ms_peptidesummary constructor will return without extra delay. Calling getHit() and getPeptide() will load data from the cache file on demand. This means that after the cache file has been created once, you will need much less memory to access data in the file, as the whole file does not need to be read into memory.

What is cached?

Different versions of Parser cache more or less data in the pepsum cache. The following list is an example of what is stored:

  • Protein grouping and family links, most common fields (except description)
  • ms_mascotresults::isNA()
  • ms_mascotresults::getProteinScoreForHistogram()
  • ms_mascotresults::getAvePeptideIdentityThreshold()
  • ms_mascotresults::getIonsScoreHistogram()
  • For results using a UniGene index, the date, time and size of the UniGene file are cached.
  • For a decoy search, calls to the following methods when using the default minProbability value:
    • getNumHitsAboveIdentity()
    • getNumHitsAboveHomology()
    • getNumDecoyHitsAboveIdentity()
    • getNumDecoyHitsAboveHomology()
  • The unassigned list. It may still be slow to sort the unassigned list by intensity, as the intensity values are not cached.

Assuming MSRES_DECOY is not specified, no actual decoy matches will be saved. The same is true in reverse: when using MSRES_DECOY, protein hits from the standard search are not cached.

If a UniGene index is in use and the UniGene file changes, the cache will be rebuilt.

Performance issues when creating the pepsum cache (dat28 format only)

If you use the cache for an ms_mascotresfile_dat object, and then create a new ms_peptidesummary object, caching will typically take 1.5 to 3 times longer than without an ms_mascotresfile_dat cache.

The static function matrix_science::ms_peptidesummary::willCreateCache() can be called before creating an ms_peptidesummary object to determine if there will be a delay while a cache file is created.

Performance issues with ms_protein objects

Once a cache file has been created, it should take less than a second to create a new ms_peptidesummary object. Calling matrix_science::ms_mascotresults::getHit() should also be very fast as this just loads data from the cache file. However, only basic information for each matrix_science::ms_protein object is loaded at this time. The first call for any particular ms_protein object to a function that takes a pepNumber argument (for example: matrix_science::ms_protein::getPeptideIonsScore() ) will be slow because this will cause a reload of data from multiple parts of the results file. Subsequent calls to any function for that ms_protein object will be fast, until matrix_science::ms_mascotresults::freeHit() is called.

Some applications just need a list of query/rank values for each protein so these values are cached separately for each top level protein and family member protein. Therefore, the first call to matrix_science::ms_protein::getPeptideQuery() or matrix_science::ms_protein::getPeptideP() will be reasonbly fast compared will calls to the other functions that take a pepNumber.

Performance issues when using non-default arguments

Calls to any function that takes a OneInXprobRnd argument will be slow if 1) caching is in use and 2) the argument is not the same as when the cache file was created. Typically, this argument is 1 / results.getProbabilityThreshold(). The value is compared to what is saved in the cache file (within a certain precision), and if the argument differs, this may trigger an expensive loop over all queries.

The affected functions are:

  • getHomologyThresholdForHistogram
  • getAvePeptideIdentityThreshold
  • getNumHitsAboveIdentity
  • getNumHitsAboveHomology
  • getNumDecoyHitsAboveIdentity
  • getNumDecoyHitsAboveHomology
  • getPeptideIdentityThreshold
  • getHomologyThreshold
  • getProteinThreshold

Other potentially slow function calls in cache mode

Parser is backwards compatible with cache files from a number of previous versions. New functionality often necessitates adding more data to new cache files to improve performance. If this data is not present in the current cache file (e.g. the cache file is from one or two versions before the current version), it is read directly from the results file or calculated on the fly.

The enum ms_peptidesummary::BUGFIX_NUM maintains a list of new functionality and performance improvements where this may be the case. If you use cache files created by a previous version of Parser, it is good practice to call ms_peptidesummary::isDataCached() with the relevant bug number to discover whether the data needed by the method you use is indeed present in the cache file. If it isn't, you can avoid the function call, prepare a progress feedback screen or recreate the cache files.

How a script should decide whether to use a cache

There are two lines in the options section of mascot.dat which specify what each script should do:

    ResfileCache master_results.pl,master_results_2.pl,peptide_view.pl...
    ResultsCache master_results.pl,master_results_2.pl,peptide_view.pl...

Each script should see if it is listed in ResfileCache, and if so, it should specify RESFILE_USE_CACHE when creating the ms_mascotresfilebase object. The value can be retrieved from the Options section of mascot.dat by calling ms_mascotoptions::getResfileCache(). The procedure is correct for both MSR and dat28 files; ms_mascotresfile_msr simply ignores RESFILE_USE_CACHE if it's set.

Each script should see if it is listed in ResultsCache, and if so, it should specify MSPEPSUM_USE_CACHE when creating the ms_mascotresults object. The value can be retrieved from the Options section of mascot.dat by calling ms_mascotoptions::getResultsCache().

Using the pepsum cache for protein_view.pl

To quickly load details for a single protein (e.g. for protein_view.pl), applications prior to Mascot Parser 2.3 would generally use the singleHit parameter. However, it is faster to use a cache file if it exists.

For ms_proteinsummary, no peptide summary cache is available, so continue to follow the instructions as in Getting a single hit from the protein summary.

For ms_peptidesummary, the fastest method of loading details for a single protein is to use the cache if it already exists. For protein_view.pl, it is likely that a cache has already been created by master_results.pl or master_results_2.pl. So, as long as the exact same flags and parameters for the ms_peptidesummary constructor are used, access will be fast.

Protocol:

  • Check to see if protein_view.pl (or whatever application/script) is to use a cache file as described above.
  • Create the new ms_peptidesummary without the singleHit parameter and using the same flags and parameters as in master_results.pl or master_results_2.pl to make sure an existing cache file is used. Make sure that MSPEPSUM_USE_CACHE is specified.
  • Use getProtein() to get the single protein hit.
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Combining multiple results files

Combining multiple results files
Mascot results file module

Overview

Mascot Parser 2.3.03 and later support combining multiple results files. This is useful, for example when two searches have been performed one with ETD data and another with CID, but you want to combine the results to give a new single ms_peptidesummary.

To combine multiple files, simply create an ms_mascoresfilebase object for the first file, and then call appendResfile() to add each of the subsequent files to the first file. Then create a new ms_peptidesummary object just for the first file object.

For example (but excluding any error handling!):

C++
   std::unique_ptr<ms_mascotresfilebase> resfile1 = ms_mascotresfilebase::createResfile("F0001.msr");
   resfile1->appendResfile("F0002.msr");
   resfile1->appendResfile("F0003.msr");
   ms_peptidesummary pepsum = ms_peptidesummary(*resfile1,...

Perl
   my $resfile1 = new msparser::ms_mascotresfilebase::createResfile("F0001.msr");
   $resfile1->appendResfile("F0002.msr");
   $resfile1->appendResfile("F0003.msr");
   my $pepsum = new msparser::ms_peptidesummary($resfile1,...

Java and C#
   ms_mascotresfilebase resfile1 = ms_mascotresfilebase::createResfile("F0001.msr");
   resfile1.appendResfile("F0002.msr");
   resfile1.appendResfile("F0003.msr");
   ms_peptidesummary pepsum = new ms_peptidesummary(resfile1,...

Python
   resfile1 = msparser.ms_mascotresfilebase.createResfile("F0001.msr")
   resfile1.appendResfile("F0002.msr")
   resfile1.appendResfile("F0003.msr")
   pepsum = msparser.ms_peptidesummary(resfile1,...

Query numbers for the second file are 'renumbered' to start at one greater than the number of queries in the first file. This is all dealt with internally in Mascot Parser at the lowest level.

If you need access to the appended results files, use getResfile(). You may also need to use getSrcQueryAndFileIdForMultiFile() to return a query number in the original resfile.

The appended objects are deleted when the parent ms_mascotresfile object is deleted.

Limitations

Trying to combine results where any of the following differ will result in an error:

  • ITOL
  • ITOLU
  • ENZYME
  • PFA
  • MASS
  • Residue and terminus masses
  • Incompatible methods as returned by isMethodCompatible
  • MODS (fixed)
  • IT_MODS (variable)
  • DECOY
  • TAXONOMY
  • PEP_ISOTOPE_ERROR
  • ERRORTOLERANT
  • databases

Currently, all variable modifications must be the same, and in the same order in each file. This restriction may be changed in a future release.

Combining integrated error tolerant searches (see Integrated error tolerant search) is fully supported. Combining old-style error tolerant searches is not supported.

A combined protein summary is not supported. After calling appendResfile(), the function getNumHits() will return -1. A side effect of this is that getProteinMass() and getProteinDescription() will only work if there is an entry in a protein section in one of this files – it won't look in the summary sections.

Percolator is not currently supported for combined results files.

Changed and additional API

Additional functions:

  • matrix_science::ms_mascotresfilebase::appendResfile
  • matrix_science::ms_mascotresfilebase::getResfile
  • matrix_science::ms_mascotresfilebase::getNumberOfResfiles
  • matrix_science::ms_mascotresfilebase::getSrcQueryAndFileIdForMultiFile
  • matrix_science::ms_mascotresfilebase::getMultiFileQueryNumber

Changed functions:

  • matrix_science::ms_mascotresfilebase::getNumQueries() – now takes an optional ID.
  • matrix_science::ms_mascotresfilebase::getJobNumber() – now takes an optional ID.
  • matrix_science::ms_mascotresfilebase::getFileName() – now takes an optional ID.
  • matrix_science::ms_mascotresfilebase::anyPeptideSummaryMatches() – looks through all files.

Cache Files

Using the resfile cache (dat28 format only) gives details of how to use the 'resfile cache'. When a call is made to the primary ms_mascotresfilebase object that requires it to look in another results file, it will use the cache if that was specified for the second results file when calling appendResfile().

The ms_peptidesummary cache is slightly more complex, but still works. See Filenames for the pepsum cache files. The base part of the cache filename will be the primary results file, but the 26 character hash uses the names of all the subsequent files added using ms_mascotresfilebase::appendResfile. This ensures that different cache files will be used for opening a results file and a results file with appended files. The name of the cache file is dependent on the order that the additional results files are added.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Query-level modifications

Query-level modifications
Mascot results file module

Accessing query-level modification information

This section describes accessing and handling of query-level modifications in Mascot 2.5 and later results files. Query-level modifications were handled as part of the master variable modification list in Mascot 2.4 and earlier, so this information is only useful if you use query-level modifications in Mascot 2.5 or later. See also the section on backwards compatibility.

For simplicity, we will refer to variable modifications specified at search form level or in the quantitation method as form-level modifications, and variable modifications specified in an individual query as query-level or local modifications.

1. Extracting variable modifications of a match

Suppose the search has form-level modifications IT_MODS=Oxidation (M),Acetyl (N-term), and that there is a peptide match to query 1, which has the query-level modifications IT_MODS=Phospho (ST). The form-level modification numbers are 1=Oxidation (M) and 2=Acetyl (N-term), while the query-level modifications of query 1 have 1=Phospho (ST).

To find the modifications of the peptide match, fetch the peptide's variable mods string getVarModsStr() and the query-level mods string getLocalModsStr(). In this case, the variable mods string could be 20100000 and the query-level mods string 00001000. We can decode the strings in two steps:

  1. Using each non-zero digit in the variable mods string 2010000, look up the modification name using ms_searchparams::getVarModsName(). We find the peptide is acetylated at the N-terminus and oxidised at the second residue.
  2. Using each non-zero digit in the query-level mods string 00001000, look up the modification name using ms_inputquery::getLocalVarModName(). We find the peptide is phosphorylated at the fourth residue.

Points to note:

  • Query-level modification numbering is independent of both form-level modifications and other queries. That is, query-level modification numbers are 1-based, starting at 1, no matter how many form-level modifications there are.
  • Form-level modification names are stored in the masses section of the results file, accessible via ms_searchparams, as in Mascot 2.4 and earlier.
  • All versions of Mascot since 2.2 save query-level modification names as the IT_MODS parameter in the query section, which can be accessed with ms_inputquery::getIT_MODS(). Parser 2.5 and later parse the value of IT_MODS and make it available via ms_inputquery::getLocalVarModName(). In Parser 2.4 and earlier, you would need to split the unescaped IT_MODS manually to find the query-level modification names.
  • The local mods string getLocalModsStr() can be empty in Mascot 2.4 and earlier results files, and it can consist of only zeroes. If you need to test whether a peptide match uses query-level modifications, test that the string is non-empty and contains at least one non-zero digit.

In general, modification number for a residue can be non-zero only in one mods string at a time; that is, a residue cannot have a modification in both the variable mods string and the local mods string. The only exception is when support for multiple modifications on the same site is explicitly enabled, as described in section 3 below.

2. Extracting neutral losses

The neutral loss information of form-level and query-level modifications is encoded in two strings: ms_peptide::getPrimaryNlStr() and ms_peptide::getLocalModsNlStr(). The data format and numbering is analogous to variable modifications.

For form-level mods, use ms_searchparams::getVarModsNeutralLosses() to load the neutral loss vector of the variable modification. If a digit in getPrimaryNlStr() is non-zero, it refers to an element in the neutral loss vector. The vector is 0-based, so digit 2, for example, is the second element, at index 1.

For query-level mods, you need to locate the modification object first; see getLocalModsStr() for an example workflow. The correct neutral loss vector can then be loaded with ms_modification::getNeutralLoss(). As above, the non-zero digits in getLocalModsNlStr() refer to elements in the neutral loss vector.

3. More than one modification on the same site when MULTI_SITE_MODS=1

Mascot 2.4 added support for Multiple modifications for the same site in certain quantitation configurations, which is triggered when the search is run with the MULTI_SITE_MODS=1 parameter. In this mode, getVarModsStr() describes the exclusive modifications defined in the quantitation method, and getSummedModsStr() describes variable modifications occuring at the same sites as the exclusive modifications.

For example, suppose you have a results file using the SILAC quantitation method, which specifies Label:13C(6)15N(2) (K) as an exclusive modification. Suppose you also specify variable modification Acetyl (K) in the search form, so that the form-level modifications are 1=Acetyl (K) and 2=Label:13C(6)15N(2) (K). When MULTI_SITE_MODS=1, a peptide match could have getVarModsStr() == 00020000 and getSummedModsStr() == 00010000 That is, the former contains the (exclusive) SILAC label on K and the latter the variable modification (acetylation) on the same residue.

Now suppose the input query has also the query-level modifications IT_MODS=Methyl (KR), so that 1=Methyl (KR). Peptide matches to the query could have the following combinations of mods strings:

 | Rank 1 | Rank 2 | Rank 3 |
getVarModsStr() | 00020000 | 00020000 | 00020000 | exclusive mods
getSummedModsStr() | 00010000 | 00000000 | 00010000 | variable mods
getLocalModsStr() | 00000000 | 00010000 | 00000010 | variable mods
 | 123456 | 123456 | 123456 | (residue number)

In this case, the rank 1 match has acetylation and SILAC label on K (residue 3), while the rank 2 match has methylation and SILAC label on K (residue 3). The rank 3 match has acetylation and SILAC label on K (residue 3), and methylation on K or R at the C terminus (residue 6). Observe that in the rank 2 match, the summed mods string is empty and both the variable mods string and the local mods string contain a non-zero value for the third residue. This is the only case where getVarModsStr() and getLocalModsStr() can report a non-zero digit at the same site.

As a mnemonic, the summed and local modifications are always in addition to ("summed with") the exclusive modifications, which are recorded in getVarModsStr().

4. Using ms_aahelper to fragment peptide matches with query-level modifications

ms_aahelper::calcFragments() and ms_aahelper::calcFragmentsEx() are used for generating the fragment masses of a peptide match. The functions take an ms_peptide object as the first argument.

The peptide match object can have query-level modifications (a non-empty getLocalModsStr()). In this case, the query-level modifications are only included in fragment mass calculation if the peptide object is directly related to the results file with which the ms_aahelper object was initialised. That is, to calculate the right fragments for peptide matches with query-level modifications:

  1. Open the results file using ms_mascotresfile_msr or ms_mascotresfile_dat.
  2. Create an ms_aahelper object using the ms_mascotresfile object.
  3. Create an ms_peptidesummary object using the same ms_mascotresfilebase object.
  4. Find the peptide you want to fragment using e.g. ms_peptidesummary::getPeptide().
  5. Pass the peptide object to ms_aahelper::calcFragmentsEx().

If the peptide object comes from a different file or if you initialise ms_aahelper without a results file, fragmentation will not take query-level modifications into account and some of the fragment masses will be incorrect.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Spectral libraries

Spectral libraries
Mascot results file module

Spectral library search results

Mascot 2.6 and later can search spectral libraries in parallel with a FASTA database. This page deals with opening spectral library search results using the standard Parser interface. If you need to read spectral library files (in MSP format), see Classes for reading and writing spectral libraries.

By default, Parser opens spectral library results in backwards-compatible mode, where spectral library matches are invisible. Enabling spectral library support in code using Parser is more involved than just setting a constructor flag. Please study the list of methods under Spectral library API summary. Many of the methods listed either take a new argument in Parser 2.6 to differentiate between FASTA and library matches, or they interpret existing arguments differently depending on mode.

For example, ms_peptidesummary::getPeptideThreshold() takes an optional rank parameter. You should always specify it, because Mascot and library matches have different score thresholds. If you don't give a rank to the method, it will choose the score threshold based on the rank 1 match.

Detecting and opening spectral library results

To detect whether a results file contains spectral library matches, the easiest test is ms_mascotresfilebase::anySpectralLibraryMatches(). If the test returns true, the results file contains spectral library matches and the file can be opened as a spectral library search.

Three modes are available:

  1. FASTA-only mode (no flag): The backwards-compatible default is to hide spectral library matches.
    If the search contains only spectral library matches, then opening the file in this mode means there are no matches available at all.
  2. SL-only mode (MSPEPSUM_SL_ONLY): Show only spectral library matches.
    If the search contains only FASTA matches, then opening the file in this mode means there are no matches available at all.
  3. Integrated mode (MSPEPSUM_SL_INTEGRATED): The integrated library mode is similar to the integrated error tolerant mode (see Integrated error tolerant search). A query can contain a mixture of up to 20 FASTA and library matches, and protein accessions can come from both the FASTA file and the spectral library (or its reference database – see Protein inference in spectral library searches).
    If the search contains only FASTA matches or only spectral library matches, the integrated mode is equivalent to the FASTA-only or SL-only mode, respectively.

The helper function ms_mascotresfilebase::get_ms_mascotresults_params() does not set MSPEPSUM_SL_ONLY or MSPEPSUM_SL_INTEGRATED automatically. This means code written for Parser 2.5 and earlier always opens spectral library search results in FASTA-only mode.

Parser 2.6 and Mascot 2.6 do not support the following search types in combination with spectral libraries:

  • decoy searching
  • error tolerant searching
  • Percolator
  • quantitation methods(*)

(*) Reporter quantitation may work; it depends on spectral library matches having the correct set of modifications (see How modifications are encoded). Other types of quantitation will not work with library matches.

Opening the file in SL-only mode

To open the file in SL-only mode, pass the flag MSPEPSUM_SL_ONLY to the matrix_science::ms_peptidesummary constructor.

The default value for minProbability, 0.05, corresponds to a score threshold of 300 (see Library scores and thresholds). To convert a raw score to a value suitable as minProbability, see ms_peptidesummary::getMinProbabilityForSLScore().

Opening the file in integrated mode

To open the file in integrated mode, pass the flag MSPEPSUM_SL_INTEGRATED to the matrix_science::ms_peptidesummary constructor. Observe the following points:

  • As in integrated error tolerant mode, each query can have up to ms_mascotresults::getMaxRankValue() matches. Matches within a query are sorted by expect value.
  • Library score threshold is determined from matching the mean and standard deviation of FASTA and library scores in queries where there is a significant top rank FASTA match and top rank library match to the same sequence (see below).
  • Protein inference prefers FASTA accessions over library accessions (see Protein inference in spectral library searches).

Library scores and thresholds

In Mascot 2.6, the spectral library search tool is the NIST MSPepSearch. Library scores range from 0 to 1000, with 0 meaning the observed spectrum and the library match are entirely dissimilar, and 1000 meaning they are identical. Library scores are obviously on a very different scale from Mascot scores, which have no particular upper limit (although a score of a couple hundred is extremely unusual). FASTA matches and library matches must have different score thresholds.

If a query contains both FASTA and library matches, and you open the file in integrated mode, there are three thresholds of interest:

  • the Mascot identity threshold
  • the Mascot homology threshold
  • the library score threshold

The library score threshold is global – it applies to all queries in the search – whereas Mascot thresholds are specific to a query. However, in order to retain a compatible API, functions that return the identity threshold may return either the Mascot identity or the library score threshold, depending on function arguments. Functions that return the homology threshold will always return zero for spectral library matches.

For example, the following functions take a new argument that determines which threshold is of interest:

  • matrix_science::ms_mascotresults::getAvePeptideIdentityThreshold
  • matrix_science::ms_mascotresults::getHomologyThresholdForHistogram
  • matrix_science::ms_mascotresults::getIonsScoreHistogram
  • matrix_science::ms_mascotresults::getMaxPeptideIdentityThreshold
  • matrix_science::ms_mascotresults::getPeptideIdentityThreshold

The type of the score returned by ms_peptide::getIonsScore() depends on the type of the match. Use ms_peptide::getIsFromLibrary() to find out.

The expect value of a spectral library match is a function of its score and threshold, as usual.

For details on how the library score threshold is derived, see Advanced reading: calculating the spectral library score threshold.

Protein inference in spectral library searches

Protein inference in SL-only or integrated mode uses the same rules as in FASTA-only mode and previous versions of Parser. The main differences are the source of protein data for spectral library matches, and the treatment of "ties" between otherwise equivalent accessions, e.g., when choosing a representative family member or sameset protein.

During a library search, a library match can be mapped to a FASTA accession, library accession or both. FASTA accession in this context means an accession from a FASTA database that is part of the same search. Library accession means an accession from the reference database of the spectral library, or an accession from the MSP file if the sequence was not found in the reference database; see the Mascot help for more information on reference databases.

The search can be opened in integrated or SL-only mode. In SL-only mode, spectral library matches appear only under library accessions. It is as if the FASTA database was not searched at all, so protein inference is the same as in a single database search.

In integrated mode, a spectral library match can be mapped to a FASTA accession or a library accession or both. There are therefore potentially many more sameset and subset proteins. The situation is more even complicated if the spectral library has a reference database that is not part of the search.

Database number and type

Here are some of the possible database, library and reference database combinations:

A. One library (getNumberOfDatabases() == 1)
  1. NIST_S.cerevesiae_IonTrap (SL)
  2. SwissProt (SLREF of 1)
B. One library, one FASTA; FASTA is not reference db (getNumberOfDatabases() == 2)
  1. NIST_S.cerevisiae_IonTrap (SL)
  2. UniProt_Yeast (AA)
  3. SwissProt (SLREF of 1)
C. Two libraries with same reference db (getNumberOfDatabases() == 2)
  1. NIST_S.cerevisiae_IonTrap (SL)
  2. PRIDE_Contaminants (SL)
  3. SwissProt (SLREF of 1 and 2)
D. Two libraries, one FASTA that is a reference db (getNumberOfDatabases() == 3)
  1. NIST_S.cerevisiae_IonTrap (SL)
  2. PRIDE_S.cerevisiae (SL)
  3. SwissProt (AA, also ref of 1)
  4. UniProt_Yeast (SLREF of 2)

The string in parentheses (AA, SL, SLREF) is the database type. The numbers refer to the database number. This is normally in the interval 1..ms_searchparams::getNumberOfDatabases(), except that reference databases have index numbers after this range. It is possible for a FASTA database to be both part of the search and a spectral library's reference database.

Parser assigns reference accessions the database number of the relevant spectral library, so most of the time you do not need to worry about the difference. For example, in case C of two libraries with the same reference database, an accession from SwissProt (e.g., KPYK1_YEAST) can appear under either database number, "1::KPYK1_YEAST" and "2::KPYK2_YEAST". Matches from the first library searched appear under "1::KPYK1_YEAST", and matches from the second under "2::KPYK2_YEAST". (Protein inference may of course make one a subset of the other.) Database numbers above ms_searchparams::getNumberOfDatabases() do not appear in ms_protein::getDB().

You can access the database type and the mapping between spectral library index and reference database index with ms_mascotresfilebase::getDatabaseType(), ms_mascotresfilebase::getReferenceDatabaseNumberOfSL() and ms_mascotresfilebase::getSLDatabaseNumbersOfReference().

FASTA accessions are preferred over reference and library accessions

Parser prioritises FASTA accessions over reference accessions and reference accessions over MSP accessions in protein inference. For example, if a FASTA accession and a reference accession have the same set of significant sequences, Parser will choose the FASTA accession as the representative protein and relegate the reference accession to sameset status. If a FASTA accession is the superset protein of a library accession (of either kind), the library accession is removed entirely. This prioritisation is necessary to simplify the output of protein inference and remove redundancies.

Reference database name matters in external lookups

The mass and description of reference accessions are not saved in the results file. This means ms_mascotresults::getProteinDescription() returns the empty string for reference accessions. The description of an MSP accession may or may not be available, depending on what the MSP file contained at the time of the search.

When you need to look up a protein attribute like mass, description, pI or taxonomy information from an external source, you need to know what the correct source database is. If the protein comes from a FASTA file (database type AA or NA), the source database is the FASTA file. But if the protein comes from a spectral library (database type SL), you need to target the query at the reference database. You can find the reference database number with ms_mascotresfilebase::getReferenceDatabaseNumberOfSL() and the reference database name with ms_searchparams::getDB().

How modifications are encoded

Modifications are encoded differently between FASTA matches and spectral library matches. In a FASTA-only search, you can specify both fixed and variable modifications, as well as have query-level modifications and modifications as part of a quantitation method. In an SL-only or integrated library search, none of these modifications are used for spectral library matches.

Spectral library matches can contain their own modifications, which you can access with ms_mascotresults::getLibraryModString(). The modifications originate from the spectral library entry. The results file contains a list of all possible library modifications in the spectral libraries searched; see ms_searchparams::getLibraryModName(). It is possible for fixed and variable modifications to have the same name as a library modification, and vice versa. Whether they are the same modification depends entirely on how the spectral library was created.

Other attributes specific to spectral libraries

The results file contains a back reference for each spectral library match that allows you to look up the corresponding library entry from the spectral library file. See ms_peptidesummary::getLibraryEntryId() for more details.

Spectral library API summary

For more details on spectral library specific behaviour, see the following classes and functions:

ms_searchparams
  • matrix_science::ms_searchparams::getDB
  • matrix_science::ms_searchparams::getLibraryModName
  • matrix_science::ms_searchparams::getLibraryModDelta
  • matrix_science::ms_searchparams::getNumberOfLibraryMods
  • matrix_science::ms_searchparams::getLIBRARY_SEARCH

ms_mascotresfilebase
  • ms_mascotresfilebase::anySpectralLibraryMatches
  • ms_mascotresfilebase::getDatabaseType
  • ms_mascotresfilebase::getFastaPath
  • ms_mascotresfilebase::getFastaVer
  • ms_mascotresfilebase::getNumLibraryEntries
  • ms_mascotresfilebase::getReferenceDatabaseNumberOfSL
  • ms_mascotresfilebase::getSLDatabaseNumbersOfReference
  • ms_mascotresfilebase::isDatabaseTypeAvailable
  • ms_mascotresfilebase::getSLFragmentTolerance
  • ms_mascotresfilebase::getSLFragmentToleranceUnit

ms_mascotresfile_dat (dat28 format)
  • ms_mascotresfile_dat::SEC_LIBRARYPEPTIDES
  • ms_mascotresfile_dat::SEC_SPECTRAL_LIBRARY
  • ms_mascotresfile_dat::SEC_LIBRARYSUMMARY

ms_mascotresults
  • matrix_science::ms_mascotresults::getAvePeptideIdentityThreshold
  • matrix_science::ms_mascotresults::getHomologyThresholdForHistogram
  • matrix_science::ms_mascotresults::getIonsScoreHistogram
  • matrix_science::ms_mascotresults::getLibraryModString
  • matrix_science::ms_mascotresults::getMaxPeptideIdentityThreshold
  • matrix_science::ms_mascotresults::getMaxRankValue
  • matrix_science::ms_mascotresults::getNumDecoyHitsAboveHomology
  • matrix_science::ms_mascotresults::getNumDecoyHitsAboveIdentity
  • matrix_science::ms_mascotresults::getNumDiscoveredLibraryMods
  • matrix_science::ms_mascotresults::getNumHitsAboveHomology
  • matrix_science::ms_mascotresults::getNumHitsAboveIdentity
  • matrix_science::ms_mascotresults::getPeptideIdentityThreshold
  • matrix_science::ms_mascotresults::getPeptideExpectationValue
  • matrix_science::ms_mascotresults::getProteinDescription
  • matrix_science::ms_mascotresults::getQmatch
  • matrix_science::ms_mascotresults::getThresholdForFDRAboveHomology
  • matrix_science::ms_mascotresults::getThresholdForFDRAboveIdentity

ms_peptidesummary
  • matrix_science::ms_peptidesummary::getLibraryEntryId
  • matrix_science::ms_peptidesummary::getMinProbabilityForSLScore
  • matrix_science::ms_peptidesummary::getPeptideThreshold
  • matrix_science::ms_peptidesummary::getSLThresholdFromMinProbability
  • matrix_science::ms_peptidesummary::MSPEPSUM_SL_INTEGRATED
  • matrix_science::ms_peptidesummary::MSPEPSUM_SL_ONLY

ms_peptide
  • matrix_science::ms_peptide::getExpectationValue
  • matrix_science::ms_peptide::getIonsScore
  • matrix_science::ms_peptide::getIsFromLibrary

ms_libraryoptions
  • matrix_science::ms_libraryoptions

ms_spectral_lib_file
  • matrix_science::ms_spectral_lib_file

ms_spectral_lib_entry
  • matrix_science::ms_spectral_lib_entry

ms_spectral_lib_peak
  • matrix_science::ms_spectral_lib_peak

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Spectral library score threshold (advanced reading)

Spectral library score threshold (advanced reading)
Mascot results file module

Advanced reading: calculating the spectral library score threshold

Warning: The details of how the spectral library score threshold is calculated is not required reading. The API is described in section Spectral library search results. The sections below are intended for reference only.

Score excess over threshold

The expect value, library match "significance" and library score contribution to protein score all use the basic concept of score excess over threshold. This is simply score - thr: the higher the excess, the lower the expect value and vice versa. A match score exactly at the threshold has excess zero. Similarly, only library matches with excess above zero contribute to the protein score.

Score excess is used in a similar way with Mascot scores and FASTA matches. The main difference is that Mascot score threshold is specific to a query.

The library score excess is calculated differently depending on which mode is active, integrated mode or SL-only mode. However, since the model in both cases is not a true statistical model, the phrase "library score is significant" should be interpreted very loosely. It simply means the score is above threshold (score excess is positive).

Score excess, threshold and expect value in integrated mode

In integrated mode, the library score excess is derived from matching the mean and standard deviation of library scores to the mean and standard deviation of Mascot score excess. This yields a formula for converting raw library scores to values equivalent to the Mascot score excess:

    excess(s) = mascot.mean + mascot.stdev * (s - library.mean) / library.stdev

The formula simply standardises library scores, then rescales them. Here s is the raw library score. The values for mascot.mean, mascot.stdev, library.mean and library.stdev are calculated from queries where the FASTA and library matches have the same sequence and the Mascot match is significant:

  1. Iterate over all queries. If a query contains a significant rank 1 FASTA match and a library match at rank 2 with the same sequence, add the paired score (mascot.excess, library.score) to the list. mascot.excess = mascot.score - mascot.thr is the score excess over threshold for the rank 1 match.
  2. Calculate the mean and standard deviation of mascot.excess in this list; store in mascot.mean and mascot.stdev.
  3. Calculate the mean and standard deviation of library.score in this list; store in library.mean and library.stdev.

The procedure can be justified if you look at the paired score distribution in large integrated library searches. Queries that match the same peptide sequence in both the protein sequence database and the spectral library show high correlation between Mascot score and library score. The shapes of the Mascot score distribution and the library score distribution are also quite similar, although the similarity breaks down in small searches or searches with few matches from one or the other search engine.

The formula is valid for all library scores in the search, not just those used in the above calculation. This is because MSPepSearch scores are on an absolute scale with a finite range, and scores between different spectra seem to be very well calibrated.

Now that we can compute the equivalent score excess for library matches, the expect value can be calculated using the same formula as for Mascot scores, namely

    E(s) = minProbability * 10 ** (-excess(s)/10)

Here minProbability is the significance threshold argument given to the ms_peptidesummary constructor. An excess of zero gives E(s) = minProbability, while high excess gives low expect value.

The library score threshold is now easy to calculate: it is the score s for which score excess is zero. Equivalently, it is the score s for which E(s) = minProbability. Note that unlike with Mascot scores, the library score threshold is calculated after expect values are already known.

The score excess is also used in calculating protein scores; see Protein scores below.

As a small numerical example, suppose the search contains ten queries with the following matches:

Query | Rank | Match | Source
1 | (no matches)
2 | 1 | CIPALDSLTPANEDQK, score = 51, thr = 13 | AA
 | 2 | CIPALDSLTPANEDQK, score = 524 | SL
3 | 1 | SLNNQIETLLTPEGSR, score = 21, thr = 33 | AA
4 | (no matches)
5 | 1 | ENNEQLR, score = 22, thr = 20 | AA
 | 2 | ENNEQLR, score = 300 | SL
6 | 1 | NIHMWCAMR, score = 101 | SL
7 | 1 | TLNDELEIIEGMOK, score = 40, thr = 25 | AA
7 | 2 | TLNDELELIEGMOK, score = 255 | SL
8 | 1 | NSGGNNNTTDLK, score = 39, thr = 16 | AA
 | 2 | NSGGNNNTTDLK, score = 428 | SL
9 | (no matches)
10 | 1 | LYGTDDNTQEVEAVTNK, score = 61, thr = 36 | AA
 | 2 | LYGTDDNTQEVEAVTNK, score = 384 | SL

Queries 1, 4 and 9 contribute nothing, since they have no matches.

Queries 3 and 6 don't contribute, since either the FASTA or the library match is missing. In query 3, another problem is that the FASTA match is below threshold, so not significant.

Query 7 doesn't contribute, since there is no library match to the same sequence (the match is to a slightly different sequence).

From the remaining queries, the data set is the pairs of scores from query 2 (38, 524), query 5 (2, 300), query 8 (23, 428) and query 10 (25, 384). The statistics will not be meaningful with such a small sample, but for the sake of completeness, we get mascot.mean = 22, mascot.stdev = 14.9, library.mean = 409 and library.stdev = 93.3. The transformed library score excess for the matches in queries 2, 5, 6, 7, 8 and 10 are excess(524) = 40.4, excess(300) = 4.6, excess(101) = -27.2, excess(255) = -2.6, excess(428) = 25.0 and excess(384) = 18.0. The score excess is similar to the Mascot score excess, which is a feature of many real-life data sets as well.

Score excess, threshold and expect value in SL-only mode

In SL-only mode, there are no Mascot scores, so there is no reference point based on an existing model. We discovered during the development of Mascot 2.6 that library score 300 is a rough but consistent estimate of a "universal" score threshold in MS/MS searches at approximately 5% level of significance. This observation might not be valid for small spectral libraries or small searches.

Unlike in integrated mode, score excess and the effective threshold are calculated from the following expect value formula:

  E(s) = 0.05 * 10 ** (-(s - 300)/100)

Here s is the raw library score. Note especially that minProbability does not appear in the formula.

The library score threshold is the value of s for which E(s) = minProbability; this is the same criterion as in the integrated case. If minProbability is the default 0.05, then library score threshold is 300. Note that again the expect value is known before the library score threshold, which is the same as in the integrated case but different from FASTA-only searches.

The library score excess is simple: find the library score threshold thr, and let excess = score - thr. The excess is on the library score scale rather than a scale equivalent to Mascot score excess.

The score excess is used in calculating protein scores; see Protein scores below.

Protein scores

It's recommended to use MudPIT scoring with spectral library searches. The calculation is explained in ms_protein::getScore(). In SL-only mode, the contribution of a match is the raw library score excess. In integrated mode, the contribution is the Mascot-equivalent score excess (see excess(s) in Score excess, threshold and expect value in integrated mode).

Note that even if you select standard scoring, the protein score calculation always uses the uncorrected match score; there is no multiplicity correction.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_inputquery Class Reference

  • matrix_science
  • ms_inputquery
Public Member Functions | List of all members
ms_inputquery Class Reference
Mascot results file module

This class encapsulates the input queries (peak lists) in the Mascot results file. More...

#include <ms_inputquery.hpp>

Public Member Functions

ms_inputquery (const ms_mascotresfilebase &resfile, const int q)
Use this contructor to create an object to get the input data.
bool | getAverageCharge (int *averageCharge, double *averageChargeDbl=0) const
For Waters MS^E data, return the average charge.
std::string | getCharge () const
Returns a string that represents the supplied charge for the query.
std::string | getComp (int comp_no) const
Returns a string that represents one of the sequence queries.
int | getIndex () const
Returns the zero based index of the peak list in an MGF, PKL or DTA file.
std::string | getINSTRUMENT (const bool unescaped=true) const
Returns an INSTRUMENT string if this has been specified at the query level.
double | getIntMax () const
Returns the maximum intensity of any ion.
double | getIntMin () const
Returns the minimum intensity of any ion.
double | getIonMobility () const
Returns the ion mobility specified using the ION_MOBILITY= line.
std::string | getIT_MODS (const bool unescaped=true) const
Returns the names of variable modifications if such have been specified at the query level.
std::string | getLocalVarModName (const int num) const
Returns the query-level modification name by 1-based index.
std::string | getLocus () const
Returns the locus specified in the MGF file using the LOCUS= line.
double | getMassMax () const
Returns the maximum mass of any ion.
double | getMassMin () const
Returns the minimum mass of any ion.
double | getMaxInternalMass () const
Returns the maximum mass to be considered for internal fragments if an INSTRUMENT has been specified at the query level.
double | getMinInternalMass () const
Returns the minimum mass to be considered for internal fragemnts if an INSTRUMENT has been specified at the query level.
int | getNumberOfLocalVarMods () const
Returns the number of query-level variable modifications.
int | getNumberOfPeaks (const int ions) const
Returns the number of ions peaks in an ms-ms spectrum.
int | getNumUsed () const
Returns the number of ions used for matching - value no longer available.
int | getNumVals () const
Returns the number of ions.
int | getPeakCharge (const int ions, const int peakNo) const
Returns the charge of a particular ions peak.
double | getPeakIntensity (const int ions, const int peakNo) const
Returns the intensity of a particular ions peak.
std::vector< std::pair< double, double > > | getPeakList (const int ions) const
Returns a list of ions peaks for a query.
double | getPeakMass (const int ions, const int peakNo) const
Returns the mass of a particular ions peak.
double | getPepTol () const
Returns the peptide tolerance for this query.
std::string | getPepTolString () const
Returns the peptol string .
std::string | getPepTolUnits () const
Returns the peptide tolerance units for this query.
int | getQueryNumber () const
Returns the Mascot query number.
std::string | getRawfile () const
Returns the rawfile specified in the MGF file using the RAWFILE= line.
std::string | getRawScans (const int rawFileIdx=-1) const
Returns the rawscan number(s) that were used to generate this peak list.
void | getRawScans (std::vector< int > &index, std::vector< std::string > &rawscans) const
Returns all rawscan numbers that were used to generate this peak list.
std::string | getRetentionTimes (const int rawFileIdx=-1) const
Returns the retention time(s) in seconds of the scans that were used to generate this peak list.
void | getRetentionTimes (std::vector< int > &index, std::vector< std::string > &times) const
Returns all retention times in seconds of the scans that were used to generate this peak list.
std::string | getRULES () const
Returns the instrument rules if this has been specified at the query level.
std::string | getScanNumbers (const int rawFileIdx=-1) const
Returns the scan number(s) that were used to generate this peak list.
void | getScanNumbers (std::vector< int > &index, std::vector< std::string > &scans) const
Returns all scan numbers that were used to generate this peak list.
std::string | getSeq (int seq_no) const
Returns a string that represents one of the sequence queries.
std::string | getStringIons1 (bool includeCharges=false) const
Returns the peak list for the ions as a string.
std::string | getStringIons2 (bool includeCharges=false) const
Returns the peak list for the ions as a string.
std::string | getStringIons3 (bool includeCharges=false) const
Returns the peak list for the ions as a string.
std::string | getStringTitle (bool unescaped) const
Returns the title for the ms-ms data (if any).
std::string | getTag (int tag_no) const
Returns a string that represents one of the sequence tag queries.
double | getTotalIonsIntensity () const
Returns the sum of all the ions intensities.
bool | hasINTERNALS () const
Returns true if this spectrum has specific internal masses.

Detailed Description

This class encapsulates the input queries (peak lists) in the Mascot results file.

Thread safe
This class is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Examples
resfile_input.cpp.

Constructor & Destructor Documentation

◆ ms_inputquery()

ms_inputquery | ( | const ms_mascotresfilebase & | resfile,
 |  | const int | q
 | ) |  |

Use this contructor to create an object to get the input data.

Constructor for ms_inputquery.

See Maintaining object references: two rules of thumb.

Parameters
resfile | Must be a valid ms_mascotresfilebase object.
q | is the query number and must be in the range 1 to ms_mascotresfilebase::getNumQueries().

Member Function Documentation

◆ getAverageCharge()

bool getAverageCharge | ( | int * | averageCharge,
 |  | double * | averageChargeDbl = 0
 | ) |  | const

For Waters MS^E data, return the average charge.

Peak lists form Waters MS^E DIA scan data will most likely have a charge state of 1+ by default. Peptide matches will have been matched based on this charge state. If the datasource is MS^E then it should have valid average charge values. If the average charge value is valid (ie non-zero) then substitute this one instead. MDRO puts the average charge into the query title, so we can check for that and parse it if available.

The only time this is really needed is when searching the survey (MS1) scans for the m/z for the peptide. The values recorded in the search results file for the m/z and mr values are 'decharged' to 1+. To find the true m/z, recalulate it using the mr value and the average charge.

The average charge will normally be a floating point value. Suppose the data is made from one 2+ ion and three 3+ ions. The average might then be 2.75. This value will be returned in averageChargeDbl but it is generally more useful to use the rounded integer value which would be 3 in this case.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | averageCharge | will be set to this if found. If not, the value will be set to 0. This is the rounded integer value
[out] | averageChargeDbl | is the floating point value. Passing a null value is acceptable.
Returns
True if an average charge value was found, false if not

◆ getCharge()

std::string getCharge ( ) const

Returns a string that represents the supplied charge for the query.

This value will only be present if a charge was specified at the query level in the input (MGF, PKL, mzData, DTA) file. It will normally be one of the following strings:

  • '8-'
  • '7-'
  • '6-'
  • '5-'
  • '4-'
  • '3-'
  • '2- and 3-'
  • '2-'
  • '1-, 2- and 3-'
  • '1-'
  • 'Mr'
  • '1+'
  • '1+, 2+ and 3+'
  • '2+'
  • '2+ and 3+'
  • '3+'
  • '4+'
  • '5+'
  • '6+'
  • '7+'
  • '8+'

The charge can also be any comma separated list of charge states.

See also
https://www.matrixscience.com/help/search_field_help.html#TWO for further information.

The default charge states are available from ms_searchparams::getCHARGE. Use ms_peptide::getCharge to return the actual charge state that was used for a peptide match.

Returns
The charge(s) as a string.

◆ getComp()

std::string getComp ( int comp_no ) const

Returns a string that represents one of the sequence queries.

Up to 20 sets of composition data can be entered for each peptide mass.

See also
https://www.matrixscience.com/help/search_field_help.html#QUE for further information.
Parameters
comp_no is an index for the comp() command. The input data is available as COMP1, COMP2 COMP3 etc. To get all composition data, call this function with numbers from 1 to 20.
Returns
the comp() command as a string

◆ getIndex()

int getIndex ( ) const

Returns the zero based index of the peak list in an MGF, PKL or DTA file.

In Mascot 2.3 and later, the index of each spectrum is saved as an index= value in each query section or query__data table. This can be useful, because the query numbers are not the same as the index into the text file, and if there are non-unique titles, then it is hard to get back from the query to the original spectrum in the MGF, PKL or DTA file

The index is stored in mzIdentML files using the CV term:

[Term]
id: MS:1000774
name: multiple peak list nativeID format
def: "index=xsd:nonNegativeInteger" [PSI:MS]
comment: Used for conversion of peak list files with multiple spectra, i.e. MGF, PKL, merged DTA files. Index is the spectrum number in the file, starting from 0.
is_a: MS:1000767 ! native spectrum identifier format
Returns
A zero based index, or -1 if the value is not available.

◆ getINSTRUMENT()

std::string getINSTRUMENT ( const bool unescaped = true ) const

Returns an INSTRUMENT string if this has been specified at the query level.

This string will always be empty for versions of Mascot prior to 2.2.

A value is only returned when INSTRUMENT is specified in the MGF file. For example:

     BEGIN IONS
     PEPMASS=1234
     INSTRUMENT=ETD_TRAP
     50 1
     100 3
     400 5
     END IONS

The value is obtained from the INSTRUMENT= line in the relevant query section or query__data table of the results file. If there is no instrument specified at the query level, then the INSTRUMENT specified in the search form is used. This can be retrieved using ms_searchparams::getINSTRUMENT().

See also ms_inputquery::getRULES(). It is preferable to use the rules rather than this name to determine which ions series were searched since the user can change the definition of the instrument name.

See also
https://www.matrixscience.com/help/search_field_help.html#INSTRUMENT for further information.
Parameters
unescaped has to be TRUE for human-readable instrument name and FALSE for generating input for a mascot search.
Returns
The INSTRUMENT string, or an empty string if no instrument was specified at the query level.

◆ getIntMax()

double getIntMax ( ) const

Returns the maximum intensity of any ion.

Returns
The maximum intensity. Even if ions are entered as ions(b- ...), ions(y-...) and ions(...), this function returns the maximum intensity of any ion.

◆ getIntMin()

double getIntMin ( ) const

Returns the minimum intensity of any ion.

Returns
The minimum intensity. Even if ions are entered as ions(b- ...), ions(y-...) and ions(...), this function returns the minimum intensity of any ion.

◆ getIonMobility()

double getIonMobility ( ) const

Returns the ion mobility specified using the ION_MOBILITY= line.

The value is only available if client software specified it in the MGF file. Ion mobility could be 1/k_0 or some other value. The unit and dimension depends on what the client software provided.

Returns
The ion mobility.

◆ getIT_MODS()

std::string getIT_MODS ( const bool unescaped = true ) const

Returns the names of variable modifications if such have been specified at the query level.

This string will always be empty for versions of Mascot prior to 2.2.

A value is only returned when variable modifications are specified in the MGF file. For example:

     BEGIN IONS
     PEPMASS=1234
     IT_MODS=Phospho (STY)
     50 1
     100 3
     400 5
     END IONS

The value is obtained from the IT_MODS= line in the relevant query section or query__data table of the results file. If there are no modifications specified at the query level, then the IT_MODS specified in the search parameters are used. These can be retrieved using ms_searchparams::getIT_MODS().

See also
https://www.matrixscience.com/help/search_field_help.html#MODS
Parameters
unescaped has to be TRUE for human readable modification names and FALSE for generating input for a mascot search.
Returns
The IT_MODS string, or an empty string if no local modifications were specified.

◆ getLocalVarModName()

std::string getLocalVarModName ( const int num ) const

Returns the query-level modification name by 1-based index.

This method returns unescaped modification names as returned by getIT_MODS(), but accessible with a 1-based numerical index. You can produce the same vector of modification titles by splitting the return value of getIT_MODS(true) on comma ",".

Parameters
num Index of the query-level modification between 1 and getNumberOfLocalVarMods().
Returns
The modification name, or the empty string if num is outside the index range.

◆ getLocus()

std::string getLocus ( ) const

Returns the locus specified in the MGF file using the LOCUS= line.

LOCUS is an optional attribute for an MS-MS peak list in an MGF file.

LOCUS was introduced in Mascot 2.4

See also
https://www.matrixscience.com/help/data_file_help.html#PARAMS
Returns
The locus= value in the query section or query__data table.

◆ getMassMax()

double getMassMax ( ) const

Returns the maximum mass of any ion.

Returns
The maximum mass. Even if ions are entered as ions(b- ...), ions(y-...) and ions(...), this function returns the maximum mass of any ion.

◆ getMassMin()

double getMassMin ( ) const

Returns the minimum mass of any ion.

Returns
The minimum mass. Even if ions are entered as ions(b- ...), ions(y-...) and ions(...), this function returns the minimum mass of any ion.

◆ getMaxInternalMass()

double getMaxInternalMass ( ) const

Returns the maximum mass to be considered for internal fragments if an INSTRUMENT has been specified at the query level.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

The value specified for the instrument is saved in the parameters section or search__parameters table of the results file. If there is no INTERNALS= line, the default value of 700.0 is returned. A different instrument can be specified for each MS-MS spectrum, in which case the values are returned using this function and ms_inputquery::getMinInternalMass

See also
getMinInternalMass(), getRULES() and getINSTRUMENT()
Returns
The maximum internal mass considered for this spectrum in this search If no instrument was specified at the query level, then this function will return -1.

◆ getMinInternalMass()

double getMinInternalMass ( ) const

Returns the minimum mass to be considered for internal fragemnts if an INSTRUMENT has been specified at the query level.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

The value specified for the instrument is saved in the parameters section or search__parameters table of the results file. A different instrument can be specified for each MS-MS spectrum, in which case the values are returned using this function and ms_inputquery::getMaxInternalMass.

See also
ms_searchparams::getMinInternalMass(), ms_searchparams::getMaxInternalMass()
Returns
The minimum internal mass considered for this spectrum in this search. If no instrument was specified at the query level, then this function will return -1.

◆ getNumberOfLocalVarMods()

int getNumberOfLocalVarMods ( ) const

Returns the number of query-level variable modifications.

Returns
The number of unescaped modification names from getIT_MODS().

◆ getNumberOfPeaks()

int getNumberOfPeaks ( const int ions ) const

Returns the number of ions peaks in an ms-ms spectrum.

See also
getPeakList(), getPeakMass() and getPeakIntensity()

The 'ions' value will normally be '1'. For MS-MS data entered via the sequence query, it is possible to specify that values are part of a b-series, y-series or either series – see https://www.matrixscience.com/help/sq_help.html#IONS.

If all three types of ions are entered, then the separate values will be saved as Ions1, Ions2 and Ions3 in the results file. For data uploaded from a file, only ions1 values will be found.

The Ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters
ions will be a value of 1..3.
Returns
The number of peaks in the peak list.

◆ getNumUsed()

int getNumUsed ( ) const

Returns the number of ions used for matching - value no longer available.

Parser 2.8 and earlier incorrectly stated that this method returns -1. This method always returns 0.

To find the number of ions peaks used for scoring, see ms_peptide::getPeaksUsedFromIons1, ms_peptide::getPeaksUsedFromIons2 and ms_peptide::getPeaksUsedFromIons3.

Returns
0

◆ getNumVals()

int getNumVals ( ) const

Returns the number of ions.

This is retrieved from the num_vals= line of the query section or query__data table.

Even if ions are entered as ions(b- ...), ions(y-...) and ions(...), this function returns the number of all ions.

Returns
The number of ions.

◆ getPeakCharge()

int getPeakCharge | ( | const int | ions,
 |  | const int | peakNo
 | ) |  | const

Returns the charge of a particular ions peak.

See also
getPeakList(), getNumberOfPeaks() and getPeakMass()

Fragment charge is an optional "third column" in MGF format peak lists. Support was added in Mascot Server 2.7. If fragment charge is unspecified, this method returns 0.

The 'ions' value will normally be '1'. For MS-MS data entered via the sequence query, it is possible to specify that values are part of a b-series, y-series or either series – see https://www.matrixscience.com/help/sq_help.html#IONS.

If all three types of ions are entered, then the separate values will be saved as Ions1, Ions2 and Ions3 in the results file. For data uploaded from a file, only Ions1 values will be found.

The Ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters
ions | will be a value of 1..3.
peakNo | should be in the range 1.. getNumberOfPeaks().
Returns
If there is no peak information, then the return value will be 0.

◆ getPeakIntensity()

double getPeakIntensity | ( | const int | ions,
 |  | const int | peakNo
 | ) |  | const

Returns the intensity of a particular ions peak.

See also
getPeakList(), getNumberOfPeaks() and getPeakMass()

The 'ions' value will normally be '1'. For MS-MS data entered via the sequence query, it is possible to specify that values are part of a b-series, y-series or either series – see https://www.matrixscience.com/help/sq_help.html#IONS.

If all three types of ions are entered, then the separate values will be saved as Ions1, Ions2 and Ions3 in the results file. For data uploaded from a file, only Ions1 values will be found.

The Ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters
ions | will be a value of 1..3.
peakNo | should be in the range 1.. getNumberOfPeaks().
Returns
If there is no peak information, then the return value will be 0.

◆ getPeakList()

std::vector< std::pair< double, double > > getPeakList ( const int ions ) const

Returns a list of ions peaks for a query.

This function only works from C++.

For other languages, Use getNumberOfPeaks(), getPeakMass() and getPeakIntensity() instead.

The 'ions' value will normally be '1'. For MS-MS data entered via the sequence query, it is possible to specify that values are part of a b-series, y-series or either series – see https://www.matrixscience.com/help/sq_help.html#IONS.

If all three types of ions are entered, then the separate values will be saved as Ions1, Ions2 and Ions3 in the results file. For data uploaded from a file, only Ions1 values will be found.

The Ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters
ions ions value, can be 1, 2 or 3
Returns
The peak list.

◆ getPeakMass()

double getPeakMass | ( | const int | ions,
 |  | const int | peakNo
 | ) |  | const

Returns the mass of a particular ions peak.

See also
getPeakList(), getNumberOfPeaks() and getPeakIntensity()

The 'ions' value will normally be '1'. For MS-MS data entered via the sequence query, it is possible to specify that values are part of b-series, y-series or either series – see https://www.matrixscience.com/help/sq_help.html#IONS.

If all three types of ions are entered, then the separate values will be saved as Ions1, Ions2 and Ions3 in the results file. For data uploaded from a file, only Ions1 values will be found.

The Ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters
ions | will be a value of 1..3.
peakNo | should be in the range 1.. getNumberOfPeaks().
Returns
If there is no peak information, then the return value will be 0.

◆ getPepTol()

double getPepTol ( ) const

Returns the peptide tolerance for this query.

peptol(tolerance,unit) may be used to specify a mass tolerance for an individual query, over-riding the search form default. For example, peptol(10,%) or peptol(2,Da).

Returns
Will return 0 if there is no peptide tolerance override for this query.

◆ getPepTolString()

std::string getPepTolString ( ) const

Returns the peptol string .

Returns, for example, peptol(2.01,Da). The number is always returned in 'fixed' notation. Trailing zeros apart from the one (if any) after the decimal are removed.

This function is intended to be used to create a sequence query string rather than for use to display in a report.

See also
getPepTolUnits(), getPepTol()
Returns
Will return an empty string if there is no peptide tolerance override for this query.

◆ getPepTolUnits()

std::string getPepTolUnits ( ) const

Returns the peptide tolerance units for this query.

In the search form, the command peptol(tolerance,unit) may be used override the default mass tolerance for an individual query. For example, peptol(10,%) or peptol(2,Da).

The units will be one of:

%
fraction expressed as a percentage
mmu
absolute milli-mass units, i.e. units of .001 Da
Da
absolute units of Da
ppm
fraction expressed as parts per million
Da
absolute units of Da
Returns
Will return an empty string if there is no peptide tolerance override for this query.

◆ getQueryNumber()

int getQueryNumber ( ) const

Returns the Mascot query number.

Returns
A 1-based Mascot query number, which was passed as the constructor argument.

◆ getRawfile()

std::string getRawfile ( ) const

Returns the rawfile specified in the MGF file using the RAWFILE= line.

RAWFILE is an optional attribute for an MS-MS peak list in an MGF file.

RAWFILE was introduced in Mascot 2.4.

See also
https://www.matrixscience.com/help/data_file_help.html#PARAMS
Returns
The rawfile= value in the query section or query__data table.

◆ getRawScans() [1/2]

std::string getRawScans ( const int rawFileIdx = -1 ) const

Returns the rawscan number(s) that were used to generate this peak list.

RAWSCANS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "rawscans" with no brackets or zero or more "rawscans[i]" lines.

If rawFileIdx is -1, this method returns the unbracketed value. Otherwise, an individual bracketed line is retrieved.

To retrieve all unbracketed and bracketed values, use ms_inputquery::getRawScans(std::vector<int>&, std::vector<std::string>&).

See also
https://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters
rawFileIdx is the raw file index for MGF files that were created from multiple raw files.
Returns
The scan number(s) in the form a[[-b][,c[-d]]]

◆ getRawScans() [2/2]

void getRawScans | ( | std::vector< int > & | index,
 |  | std::vector< std::string > & | rawscans
 | ) |  | const

Returns all rawscan numbers that were used to generate this peak list.

RAWSCANS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "rawscans" with no brackets or zero or more "rawscans[i]" lines.

This method returns all rawscans lines, bracketed or not. The elements returned in index are the indices, and the corresponding elements in scans are the values. For example, if the query has

rawscans=sn13

then both index and times will have one element. index[0] will be -1 (unbracketed) and rawscans[0] will be sn13. If the query instead has

rawscans[3]=sn13
rawscans[5]=sn24

then index[0] == 3, index[1] == 5 and rawscans[0] == "sn13", rawscans[1] == "sn24".

If you already know which lines are present in the query, you can use ms_inputquery::getRawScans(const int) to access the individual lines.

See also
https://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters
[out] | index | Vector of index numbers for corresponding "rawscans" lines. Unbracketed line has index -1, and the other indices start from 0.
[out] | rawscans | Vector of values from the "rawscans" lines in the same order as the index vector.

◆ getRetentionTimes() [1/2]

std::string getRetentionTimes ( const int rawFileIdx = -1 ) const

Returns the retention time(s) in seconds of the scans that were used to generate this peak list.

RTINSECONDS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "rtinseconds" with no brackets or zero or more "rtinseconds[i]" lines.

If rawFileIdx is -1, this method returns the unbracketed value. Otherwise, an individual bracketed line is retrieved.

To retrieve all unbracketed and bracketed values, use ms_inputquery::getRetentionTimes(std::vector<int>&, std::vector<std::string>&).

See also
https://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters
rawFileIdx is the raw file index for MGF files that were created from multiple raw files.
Returns
The retention time(s) in the form v[[-w][,x[-y]]].

◆ getRetentionTimes() [2/2]

void getRetentionTimes | ( | std::vector< int > & | index,
 |  | std::vector< std::string > & | times
 | ) |  | const

Returns all retention times in seconds of the scans that were used to generate this peak list.

RTINSECONDS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "rtinseconds" with no brackets or zero or more "rtinseconds[i]" lines.

This method returns all rtinseconds lines, bracketed or not. The elements returned in index are the indices, and the corresponding elements in scans are the values. For example, if the query has

rtinseconds=1234.0

then both index and times will have one element. index[0] will be -1 (unbracketed) and times[0] will be 1234.0. If the query instead has

rtinseconds[3]=1234.0
rtinseconds[5]=1244.0

then index[0] == 3, index[1] == 5 and times[0] == 1234.0, times[1] == 1244.0.

If you already know which lines are present in the query, you can use ms_inputquery::getRetentionTimes(const int) to access the individual lines.

See also
https://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters
[out] | index | Vector of index numbers for corresponding "rtinseconds" lines. Unbracketed line has index -1, and the other indices start from 0.
[out] | times | Vector of values from the "rtinseconds" lines in the same order as the index vector.

◆ getRULES()

std::string getRULES ( ) const

Returns the instrument rules if this has been specified at the query level.

This string will always be empty for versions of Mascot prior to 2.2.

A value is only returned when INSTRUMENT is specified in the MGF file. For example:

     BEGIN IONS
     PEPMASS=1234
     INSTRUMENT=ETD_TRAP
     50 1
     100 3
     400 5
     END IONS

The value is obtained from the RULES= line in the relevant query section or query__data table of the results file. If there is no instrument specified at the query level, then RULES specified in the search form, and the rules for this query are the global rules which can be retrieved using ms_searchparams::getRULES().

It is preferable to use the rules rather than the instrument name to determine which ions series were searched since the user can change the definition of the instrument name.

See also
getINSTRUMENT()
Returns
The RULES string, or an empty string if no instrument was specified. See ms_searchparams::getRULES() for a full definition of the rules.

◆ getScanNumbers() [1/2]

std::string getScanNumbers ( const int rawFileIdx = -1 ) const

Returns the scan number(s) that were used to generate this peak list.

SCANS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "scans" with no brackets or zero or more "scans[i]" lines.

If rawFileIdx is -1, this method returns the unbracketed value. Otherwise, an individual bracketed line is retrieved.

To retrieve all unbracketed and bracketed values, use ms_inputquery::getScanNumbers(std::vector<int>&, std::vector<std::string>&).

See also
https://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters
rawFileIdx is the raw file index for MGF files that were created from multiple raw files.
Returns
The scan number(s) in the form a[[-b][,c[-d]]].

◆ getScanNumbers() [2/2]

void getScanNumbers | ( | std::vector< int > & | index,
 |  | std::vector< std::string > & | scans
 | ) |  | const

Returns all scan numbers that were used to generate this peak list.

SCANS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "scans" with no brackets or zero or more "scans[i]" lines.

This method returns all scans lines, bracketed or not. The elements returned in index are the indices, and the corresponding elements in scans are the values. For example, if the query has

scans=1

then both index and scans will have one element. index[0] will be -1 (unbracketed) and scans[0] will be 1. If the query instead has

scans[3]=13
scans[5]=26

then index[0] == 3, index[1] == 5 and scans[0] == 13, scans[1] == 26.

If you already know which lines are present in the query, you can use ms_inputquery::getScanNumbers(const int) to access the individual lines.

See also
https://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters
[out] | index | Vector of index numbers for corresponding "scans" lines. Unbracketed line has index -1, and the other indices start from 0.
[out] | scans | Vector of values from the "scans" lines in the same order as the index vector.

◆ getSeq()

std::string getSeq ( int seq_no ) const

Returns a string that represents one of the sequence queries.

Up to 20 sets of sequence information can be entered for each peptide mass.

See also
https://www.matrixscience.com/help/search_field_help.html#QUE for further information.
Parameters
seq_no is an index for the seq() command. The input data is available as SEQ1, SEQ2 SEQ3 etc. To get all sequence data, call this function with numbers from 1 to 20.
Returns
the seq() command as a string.

◆ getStringIons1()

std::string getStringIons1 ( bool includeCharges = false ) const

Returns the peak list for the ions as a string.

The Ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters
includeCharges will add any supplied charges to the returned string, so the format will be: m/z[:intensity[:charge]], m/z[:intensity[:charge]]... if no intensities were applied initially, then the string returned will be the same as if this parameter was false
Returns
The Ions1= value in the form: 136.070000:42.95,175.110000:133.1,299.060000:710.1,415.030000:144.6 . . .

◆ getStringIons2()

std::string getStringIons2 ( bool includeCharges = false ) const

Returns the peak list for the ions as a string.

The ions2= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters
includeCharges will add any supplied charges to the returned string, so the format will be: m/z[:intensity[:charge]], m/z[:intensity[:charge]]... if no intensities were applied initially, then the string returned will be the same as if this parameter was false
Returns
The ions2= value in the form: 136.070000:42.95,175.110000:133.1,299.060000:710.1,415.030000:144.6 . . .

◆ getStringIons3()

std::string getStringIons3 ( bool includeCharges = false ) const

Returns the peak list for the ions as a string.

The ions3= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters
includeCharges will add any supplied charges to the returned string, so the format will be: m/z[:intensity[:charge]], m/z[:intensity[:charge]]... if no intensities were applied initially, then the string returned will be the same as if this parameter was false
Returns
The ions3= value in the form: 136.070000:42.95,175.110000:133.1,299.060000:710.1,415.030000:144.6 . . .

◆ getStringTitle()

std::string getStringTitle ( bool unescaped ) const

Returns the title for the ms-ms data (if any).

The string will have a maximum length of 30k characters. It might for example be:

1: Scan 2443 (rt=1651.36) [P:\\service\\on_campus\\Nunari\\Laura\\ft20061020.RAW]
Parameters
unescaped - If this is false, then any non alpha-numeric characters in the string will be converted to %xx where the xx are the hex representation of the character.
Returns
The title string.

◆ getTag()

std::string getTag ( int tag_no ) const

Returns a string that represents one of the sequence tag queries.

Up to 20 tag/etag commands can be entered for each peptide mass.

See also
https://www.matrixscience.com/help/search_field_help.html#QUE for further information.
Parameters
tag_no is an index for the tag() command. The input data is available as TAG1, TAG2 TAG3 etc. To get all tags, call this function with numbers from 1 to 20.
Returns
the tag() command as a string in the format e,977.4,[Q|K][Q|K][Q|K]EE,1619.7 where the first character will be 'e' for etag and 't' for tag.

◆ getTotalIonsIntensity()

double getTotalIonsIntensity ( ) const

Returns the sum of all the ions intensities.

See also ms_mascotresfilebase::getObservedIntensity. If the precursor intensity wasn't supplied in the input file, this function can be called instead. Processing this function for a large number of spectra may take some time since it will need to load the Ions1= values from disk and sum all the intensities.

See also ms_peptide::getIonsIntensity which just calls this function.

The Ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Returns
Will return 0 if there is no MS-MS data.

◆ hasINTERNALS()

bool hasINTERNALS ( ) const

Returns true if this spectrum has specific internal masses.

Different values of maximum and minimum internal masses to those in the parameters section or search__parameters table can be specified for each spectrum.

See also
getMinInternalMass() and getMaxIntenalMass()
Returns
true if the minimum and maximum masses are specified for this spectrum
The documentation for this class was generated from the following files:
  • ms_inputquery.hpp
  • ms_inputquery.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_linker_site Class Reference

  • matrix_science
  • ms_linker_site
Public Member Functions | List of all members
ms_linker_site Class Reference
Mascot results file module

Position of an intact link between alpha and beta peptide or a looplink. More...

#include <ms_linker_site.hpp>

Public Member Functions

ms_linker_site ()
Create a nil linker site.
ms_linker_site (const ms_linker_site &src)
Copying constructor.
ms_linker_site (ms_peptide::PSM linkFrom, ms_peptide::PSM linkTo, int siteFrom, int siteTo, int varModIdxFrom, int varModIdxTo, double linkerMass)
Create a linker site.
~ms_linker_site ()
Destructor.
void | copyFrom (const ms_linker_site *right)
Copies all content from another instance of this class.
double | getLinkerMass () const
Linker mass (Mr).
ms_peptide::PSM | getLinkFrom () const
Source peptide type.
ms_peptide::PSM | getLinkTo () const
Target peptide type.
int | getSiteFrom () const
Linker site index in source peptide.
int | getSiteTo () const
Linker site index in target peptide.
int | getVarModIdxFrom () const
Varmod index at the source site.
int | getVarModIdxTo () const
Varmod index at the target site.
ms_linker_site & | operator= (const ms_linker_site &right)
C++ assignment operator.

Detailed Description

Position of an intact link between alpha and beta peptide or a looplink.

The ms_linker_site class encapsulates the position of an intact link between the alpha and beta peptides, and looplinks in general. The link end points ("from" and "to") may have different variable mod numbers if the sites require different specificities. For example, one end could be a lysine with Xlink:DSS (K) and the other could be N-term with Xlink:DSS (Protein N-term).

Member Function Documentation

◆ getLinkerMass()

double getLinkerMass ( ) const

Linker mass (Mr).

Returns
Mass of the linker molecule. There is only one mass even if getVarModIdxFrom() and getVarModIdxTo() differ.

◆ getLinkFrom()

ms_peptide::PSM getLinkFrom ( ) const

Source peptide type.

Returns
ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA

◆ getLinkTo()

ms_peptide::PSM getLinkTo ( ) const

Target peptide type.

Returns
ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA

◆ getSiteFrom()

int getSiteFrom ( ) const

Linker site index in source peptide.

Returns
Integer index between 0 and n+1, where n is the source peptide sequence length.

◆ getSiteTo()

int getSiteTo ( ) const

Linker site index in target peptide.

Returns
Integer index between 0 and m+1, where m is the target peptide sequence length.

◆ getVarModIdxFrom()

int getVarModIdxFrom ( ) const

Varmod index at the source site.

The variable mods index could be different between the from and to ends of the link if they have different specificities. For example, getVarModIdxFrom() could be index 1 (Xlink:DSS (K)) and getVarModIdxTo() could be index 3 (Xlink:DSS (Protein N-term)).

Returns
Varmod index of the linker at the source site.

◆ getVarModIdxTo()

int getVarModIdxTo ( ) const

Varmod index at the target site.

The variable mods index could be different between the from and to ends of the link if they have different specificities. For example, getVarModIdxFrom() could be index 1 (Xlink:DSS (K)) and getVarModIdxTo() could be index 3 (Xlink:DSS (Protein N-term)).

Returns
Varmod index of the linker at the target site.
The documentation for this class was generated from the following files:
  • ms_linker_site.hpp
  • ms_linker_site.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_linker_site_vector Class Reference

  • matrix_science
  • ms_linker_site_vector
Public Member Functions | List of all members
ms_linker_site_vector Class Reference
Mascot results file module

A vector of linker sites. More...

#include <ms_linker_site_vector.hpp>

Public Member Functions

ms_linker_site_vector ()
Create an empty linker site vector.
ms_linker_site_vector (const ms_linker_site_vector &src)
Copying constructor.
ms_linker_site_vector (const std::list< ms_linker_site > &v, const int alphaVarModsLen, const int betaVarModsLen)
Create a linker site vector from an STL list.
ms_linker_site_vector (const std::vector< ms_linker_site > &v, const int alphaVarModsLen, const int betaVarModsLen)
Create a linker site vector from an STL vector.
~ms_linker_site_vector ()
Destructor.
void | append (const ms_linker_site_vector &src)
Appends all content from another instance of the class.
void | clear ()
Clear the vector.
bool | containsVarModIdx (int idx) const
Return true if the vector contains a link with the given variable mod index.
void | copyFrom (const ms_linker_site_vector *src)
Copies all content from another instance of the class.
bool | empty () const
Boolean test: is the vector empty?
ms_linker_site | get (int idx) const
Return the linker site at the given index.
int | getAlphaVarModsStrLength () const
Return the alpha peptide sequence length.
int | getBetaVarModsStrLength () const
Return the beta peptide sequence length.
int | getVarModIdxOfLinkedSite (const ms_peptide::PSM psmComponent, const int i) const
Return the variable mod index if the PSM component has a link at position i.
ms_linker_site_vector & | operator= (const ms_linker_site_vector &right)
C++ assignment operator.
ms_linker_site pop ()
Pop a value from the end of the vector.
void | push (const ms_linker_site &linkerSite)
Push a new linker site at the end of the vector.
void | set (int idx, const ms_linker_site &linkerSite)
Set the value at the given index.
int | size () const
Return the size of the container.
void | swap (ms_linker_site_vector &right)
Swap the contents with another linker site vector.
const std::vector< ms_linker_site > & | toVector () const
C++ conversion to std::vector.

Detailed Description

A vector of linker sites.

ms_linker_site_vector is a wrapper around the C++ vector class std::vector, specialised to contain ms_linker_site objects. The ms_peptide class returns such vectors.

The interface to this class follows that of vectori and vectorString, as described in Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Constructor & Destructor Documentation

◆ ms_linker_site_vector() [1/2]

ms_linker_site_vector | ( | const std::vector< ms_linker_site > & | v,
 |  | const int | alphaVarModsLen,
 |  | const int | betaVarModsLen
 | ) |  |

Create a linker site vector from an STL vector.

Note
This constructor can only be used from C++.

The alpha and beta variable mods string lengths are not optional, but one or both can be set to zero. See getVarModIdxOfLinkedSite().

Parameters
v | STL vector to initialise with.
alphaVarModsLen | length of the alpha peptide variable mods string.
betaVarModsLen | length of the beta peptide variable mods string.

◆ ms_linker_site_vector() [2/2]

ms_linker_site_vector | ( | const std::list< ms_linker_site > & | v,
 |  | const int | alphaVarModsLen,
 |  | const int | betaVarModsLen
 | ) |  |

Create a linker site vector from an STL list.

Note
This constructor can only be used from C++.

The alpha and beta variable mods string lengths are not optional, but one or both can be set to zero. See getVarModIdxOfLinkedSite().

Parameters
v | STL list to initialise with.
alphaVarModsLen | length of the alpha peptide variable mods string.
betaVarModsLen | length of the beta peptide variable mods string.

Member Function Documentation

◆ append()

void append ( const ms_linker_site_vector & src )

Appends all content from another instance of the class.

This method does not change getAlphaVarModsStrLength() or getBetaVarModsStrLength().

Parameters
src is another ms_linker_site_vector to append the sites from.

◆ clear()

void clear ( )

Clear the vector.

After clear, the vector will be empty. Alpha and beta variable mods string lengths are set to zero.

◆ containsVarModIdx()

bool containsVarModIdx ( int idx ) const

Return true if the vector contains a link with the given variable mod index.

Parameters
idx Variable mod index.
Returns
True if any linker object uses idx at either end of the link.

◆ empty()

bool empty ( ) const

Boolean test: is the vector empty?

Returns
True if the vector is empty (has size 0); false otherwise.

◆ get()

ms_linker_site get ( int idx ) const

Return the linker site at the given index.

Note that idx must be within the 0-indexed range. Otherwise the method will throw an exception.

Parameters
idx The element index, 0..size()-1.
Returns
The element at the corresponding index.

◆ getAlphaVarModsStrLength()

int getAlphaVarModsStrLength ( ) const

Return the alpha peptide sequence length.

Returns
Length of the alpha variable mods string, or 0 if not set.

◆ getBetaVarModsStrLength()

int getBetaVarModsStrLength ( ) const

Return the beta peptide sequence length.

Returns
Length of the beta variablem mods string, or 0 if not set.

◆ getVarModIdxOfLinkedSite()

int getVarModIdxOfLinkedSite | ( | const ms_peptide::PSM | psmComponent,
 |  | const int | i
 | ) |  | const

Return the variable mod index if the PSM component has a link at position i.

There are two use cases.

If psmComponent is ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA, the position i indexes the alpha or the beta variable mods string returned by ms_peptide::getVarModsStr(psmComponent). This method returns a non-zero variable mod number if there is a link in the given psmComponent at position i.

If psmComponent is ms_peptide::PSM_COMPLETE, the position i indexes the concatenated variable mods string returned by ms_peptide::getVarModsStr(PSM_COMPLETE). A simple calculation is done to determine whether i is a position in the alpha or the beta peptide:

  • If (0 <= i and i < alphaVarModsLen), then set pos = i and psmComponent = ms_peptide::PSM_CROSSLINK_ALPHA.
  • If (alphaLen <= i and i < alphaVarModsLen + betaVarModsLen), then set pos = (i - alphaVarModsLen) and psmComponent = ms_peptide::PSM_CROSSLINK_BETA.

One or both of alpha or beta variable mods string lengths can be zero.

Parameters
psmComponent | One of ms_peptide::PSM.
i | Position within the variable mods string.
Returns
Variable mod index if the there is a link at position i. If there is no link, returns 0.

◆ pop()

ms_linker_site pop ( )

Pop a value from the end of the vector.

Note that the vector must be nonempty (it must contain at least one element). If it doesn't, the method throws an exception.

Returns
The value popped from the end of the vector.

◆ push()

void push ( const ms_linker_site & linkerSite )

Push a new linker site at the end of the vector.

Parameters
linkerSite Linker site to append to the vector.

◆ set()

void set | ( | int | idx,
 |  | const ms_linker_site & | linkerSite
 | ) |  |

Set the value at the given index.

Note that idx must be within the 0-indexed range. Otherwise the method will throw an exception. If you need to extend the vector, use push().

Parameters
idx | The element index, 0..size()-1.
linkerSite | The new value to be set at that index.

◆ size()

int size ( ) const

Return the size of the container.

Returns
The number of elements in the vector, or 0 if the vector is empty.

◆ swap()

void swap ( ms_linker_site_vector & src )

Swap the contents with another linker site vector.

After this method returns, the data of src is stored inside this object, and src stores the old contents of this object.

This method swaps getAlphaVarModsStrLength() and getBetaVarModsStrLength() with src.

Parameters
src Linker site vector to swap contents with.

◆ toVector()

const std::vector< ms_linker_site > & toVector ( ) const

C++ conversion to std::vector.

Note
This method can only be used from C++.
Returns
A copy of the linker site vector as an STL vector.
The documentation for this class was generated from the following files:
  • ms_linker_site_vector.hpp
  • ms_linker_site.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresfile_dat Class Reference

  • matrix_science
  • ms_mascotresfile_dat
Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
ms_mascotresfile_dat Class Reference
Mascot results file module

Class for parsing and reading files in dat28 format. More...

#include <ms_mascotresfile_dat.hpp>

Inheritance diagram for ms_mascotresfile_dat:
[legend]
Collaboration diagram for ms_mascotresfile_dat:
[legend]

Public Types

enum err {
ERR_NO_ERROR = 0x0000 ,
ERR_NOMEM = 0x0001 ,
ERR_NOSUCHFILE = 0x0002 ,
ERR_READINGFILE = 0x0003 ,
ERR_QUERYOUTOFRANGE = 0x0004 ,
ERR_MISSINGENTRY = 0x0005 ,
ERR_PEPSUMMPEPGET = 0x0006 ,
ERR_PEPTIDESTR = 0x0007 ,
ERR_ACCINPEPTIDESTR = 0x0008 ,
ERR_PROTSUMM = 0x0009 ,
ERR_PROTSUMMPEP = 0x000A ,
ERR_ADDPEPTIDES = 0x000B ,
ERR_MISSINGHIT = 0x000C ,
ERR_MISSINGSECTION = 0x000D ,
ERR_MISSINGSECTIONEND = 0x000E ,
ERR_MALFORMED_ERR_TOL = 0x000F ,
ERR_NO_ERR_TOL_PARENT = 0x0010 ,
ERR_NULL_ACC_PEP_SUM = 0x0011 ,
ERR_NULL_ACC_PROT_SUM = 0x0012 ,
ERR_DUPE_ACCESSION = 0x0013 ,
ERR_UNASSIGNED_PROG = 0x0014 ,
ERR_UNASSIGNED_RANGE = 0x0015 ,
ERR_UNASSIGNED_UNK = 0x0016 ,
ERR_NO_UNIGENE_FILE = 0x0017 ,
ERR_DUPLICATE_KEY = 0x0018 ,
ERR_OLDRESULTSFILE = 0x0019 ,
ERR_MALFORMED_TAG = 0x001A ,
ERR_MALFORMED_DRANGE = 0x001B ,
ERR_INVALID_NUMQUERIES = 0x001C ,
ERR_MALFORMED_TERMS = 0x001D ,
ERR_INVALID_RESFILE = 0x001E ,
ERR_INVALID_PROTDB = 0x001F ,
ERR_UNIGENE_MULTIDB = 0x0020 ,
ERR_INVALID_CACHE_DIR = 0x0021 ,
ERR_FAIL_OPEN_DAT_FILE = 0x0022 ,
ERR_MISSING_CDB_FILE = 0x0023 ,
ERR_FAIL_MK_CACHE_DIR = 0x0024 ,
ERR_FAIL_MK_CDB_FILE = 0x0025 ,
ERR_FAIL_CLOSE_FILE = 0x0026 ,
ERR_FAIL_CDB_INIT = 0x0027 ,
ERR_INVALID_CDB_FILE = 0x0028 ,
ERR_WRITE_CDB_FILE = 0x0029 ,
ERR_CDB_TOO_LARGE = 0x002A ,
ERR_NEED_64_BIT = 0x002B ,
ERR_CDB_64_BIT_REMAKE = 0x002C ,
ERR_CDB_OLD_VER_RETRY = 0x002D ,
ERR_CDB_OLD_VER_NO_RETRY = 0x002E ,
ERR_CDB_INCOMPLETE_RETRY = 0x002F ,
ERR_CDB_INCOMPLETE_NO_RETRY = 0x0030 ,
ERR_CDB_BEING_CREATED = 0x0031 ,
ERR_CDB_FAIL_REMOVE = 0x0032 ,
ERR_CDB_FAIL_LOCK = 0x0033 ,
ERR_CDB_FAIL_UNLOCK = 0x0034 ,
ERR_CDB_SOURCE_CHANGE_RETRY = 0x0035 ,
ERR_CDB_SOURCE_CHANGE_NO_RETRY = 0x0036 ,
ERR_MISSING_PERCOLATOR_FILE = 0x0037 ,
ERR_CANNOT_APPEND_RESFILE = 0x0038 ,
ERR_CANNOT_APPEND_RESFILE_NO_FNAMES = 0x0039 ,
ERR_RESULTS_NOT_CREATED = 0x003A ,
ERR_LASTONE = 0x003B
}
Definitions for error numbers. More...
enum FLAGS {
RESFILE_NOFLAG = 0x00000000 ,
RESFILE_USE_CACHE = 0x00000001 ,
RESFILE_CACHE_IGNORE_ACC_DUPES = 0x00000002 ,
RESFILE_USE_PARENT_PARAMS = 0x00000004 ,
RESFILE_CACHE_IGNORE_DATE_CHANGE = 0x00000008
}
Flags for opening the results file. More...
enum KA_TASK {
KA_CREATEINDEX_CI = 0 ,
KA_READFILE_RF = 1 ,
KA_ASSIGNPROTEINS_AP = 2 ,
KA_GROUPPROTEINS_GP = 3 ,
KA_UNASSIGNEDLIST_UL = 4 ,
KA_QUANTITATION = 5 ,
KA_CREATECACHE_CC = 6 ,
KA_THRESHFORFDR_FDR = 7 ,
KA_LAST = 8
}
Processing some results files is computationally intensive. These are the tasks that can be performed. More...
enum PERCOLATOR_FILE_NAMES {
PERCOLATOR_INPUT_FILE = 0 ,
PERCOLATOR_OUTPUT_TARGET = 1 ,
PERCOLATOR_OUTPUT_DECOY = 2
}
Offsets into a vector of Percolator filenames. More...
enum RESFILE_TYPE {
RESFILE_DAT28 = 0 ,
RESFILE_MSR = 1 ,
RESFILE_UNKNOWN = 2
}
Supported results file formats. More...
enum section {
SEC_PARAMETERS ,
SEC_HEADER ,
SEC_MASSES ,
SEC_SUMMARY ,
SEC_MIXTURE ,
SEC_PEPTIDES ,
SEC_PROTEINS ,
SEC_QUERY1 ,
SEC_QUANTITATION ,
SEC_UNIMOD ,
SEC_ENZYME ,
SEC_TAXONOMY ,
SEC_DECOYSUMMARY ,
SEC_DECOYMIXTURE ,
SEC_DECOYPEPTIDES ,
SEC_DECOYPROTEINS ,
SEC_ERRTOLSUMMARY ,
SEC_ERRTOLPEPTIDES ,
SEC_SPECTRAL_LIBRARY ,
SEC_LIBRARYPEPTIDES ,
SEC_LIBRARYSUMMARY ,
SEC_CROSSLINK_SUMMARY ,
SEC_CROSSLINK_PEPTIDES ,
SEC_CROSSLINKING ,
SEC_UNIMOD_XL ,
SEC_ERRTOLDECOYSUMMARY ,
SEC_ERRTOLDECOYPEPTIDES ,
SEC_INDEX ,
SEC_NUMSECTIONS
}
Section names in the standard mascot results files. More...
enum XML_SCHEMA {
XML_SCHEMA_QUANTITATION = 0 ,
XML_SCHEMA_UNIMOD = 1 ,
XML_SCHEMA_DIRECTORY = 2 ,
XML_SCHEMA_CROSSLINKING = 3 ,
XML_SCHEMA_LAST = 4
}
The results file contains embedded files in XML format and these need to be validated against a schema. More...

Public Member Functions

ms_mascotresfile_dat (const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0)
Constructor to open a Mascot results file in dat28 format.
bool | anyCrosslinkedMatches (const bool isDecoy=false) const override
Returns true if there are any Crosslinked matches.
bool | anyErrorTolerantMatches (const bool isDecoy=false) const override
Returns true if there are any Error Tolerant matches.
bool | anyFastaMatches (const bool isDecoy=false) const override
Returns true if there are any FASTA matches.
bool | anyMSMS () const override
Returns true if any of the queries in the search contain ions data.
bool | anyPeptideSummaryMatches (const section sec=SEC_PEPTIDES) const
Returns true if there is a peptides section, and if there are any results in it.
bool | anyPMF () const override
Returns true if any of the queries in the search just contain a single peptide mass.
bool | anySpectralLibraryMatches (const bool isDecoy=false) const override
Returns true if there are any Spectral Library matches.
bool | anySQ () const override
Returns true if any of the queries in the search contain seq or comp commands.
bool | anyTag () const override
Returns true if any of the queries in the search contain tag or etag commands.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
int | appendResfile (const char *filename, int flags=RESFILE_USE_PARENT_PARAMS, const char *cacheDirectory=0) override
Multiple results files can be summed together and treated as 'one'.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
bool | doesSectionExist (const section sec) const
Returns true if there is an entry for the passed section.
std::string | enumerateQuerySectionKeys (const int query, const int num, int *pPreviousNum=0, OFFSET64_T *pPreviousOffset=0) const
Get the key name for each item in a query section.
std::string | enumerateSectionKeys (const section sec, const int num, int *pPreviousNum=0, OFFSET64_T *pPreviousOffset=0) const
Get the key name for each item in a section.
std::string | get_ms_mascotresults_params (const ms_mascotoptions &opts, ms_mascotresults_params &params) const
Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.
std::string | get_ms_mascotresults_params (const ms_mascotoptions &opts, unsigned int *gpFlags, double *gpMinProbability, int *gpMaxHitsToReport, double *gpIgnoreIonsScoreBelow, unsigned int *gpMinPepLenInPepSummary, bool *gpUsePeptideSummary, unsigned int *gpFlags2) const
[Deprecated] Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.
std::string | getCacheDirectory (bool processed=true) const override
Returns the directory being used for cache files (if any).
std::string | getCacheFileName () const override
Returns the filename of the cache file.
bool | getCrosslinkingMethod (ms_crosslinking_method *method) const
Return the crosslinking method object from the embedded crosslinking file.
DATABASE_TYPE | getDatabaseType (const int idx) const override
Return database type if available.
int | getDate () const override
Returns the date and time of the search in seconds since midnight January 1st 1970.
ms_mascotoptions::DECOY_ALGORITHM | getDecoyTypeForDB (const int idx=1) const override
Returns the decoy algorithm type for a given database.
bool | getEnzyme (ms_enzymefile *efile, const char *enzymeFileName=0) const override
Returns an object that represents the embedded enzyme file as a reduced enzymes file.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getErrorNumber (const int num=-1) const
Return a specific error number - or ms_errs::ERR_NO_ERROR.
std::string | getErrorString (const int num) const
Return a specific error as a string.
int | getExecTime () const override
Returns the time taken for the search.
std::string | getFastaPath (int idx=1) const override
Returns the path to the FASTA file used.
std::string | getFastaVer (int idx=1) const override
Returns the FASTA file version.
std::string | getFileName (const int id=1) const override
Returns the name of the results file passed into the constructor.
double | getFirstPassThreshold () const override
Return the threshold value for the first pass of an automated error tolerant search.
void | getHeaderKeyValues (std::vector< std::string > &keys, std::vector< std::string > &values) const override
Return all the header key-value pairs.
virtual std::string | getHeaderValue (const std::string &key) const override
Return the header value for the given key.
ms_inputquery | getInputQuery (const int queryNum) const override
Return the ms_inputquery object for the query given as argument.
int | getJobNumber (const int resfileID=1) const override
Return the job number for this file - obtained from the file name.
void | getKeepAlive (KA_TASK &kaTask, int &kaPercentage, std::string &kaAccession, int &kaHit, int &kaQuery, std::string &kaText) const
Return the progress indicators used by the keepAlive functions.
int | getLastError () const
Return the last error number - or ms_erros::ERR_NO_ERROR.
std::string | getLastErrorString () const
Return the last error number - or an empty string.
int | getLibraryMods (std::vector< std::string > &modNames, std::vector< double > &modDeltas) const override
Return all the library mod names and deltas.
std::string | getMascotVer () const override
Returns the version of Mascot used to perform the search.
bool | getMasses (ms_masses *masses) const
Returns an ms_masses object from the mass values in the results file.
void | getMassesKeyValues (std::vector< std::string > &keys, std::vector< double > &values) const override
Return all the residue and modification masses as key-value pairs.
virtual double | getMassValue (const std::string &key) const override
Return the residue or modification mass for the given key.
const ms_modification * | getMonoLinkModification (const int modNum, const int monoLink) const
Returns an ms_modification object that represents a monolink variable modification.
std::string | getMSParserVersion () const
Returns the version number of the Mascot Parser library.
int | getMultiFileQueryNumber (const int localQuery, const int fileId) const override
Return the multi-file query number from the local query number in an appended file.
int | getNumberOfErrors () const
Return the number of errors since the last call to clearAllErrors.
int | getNumberOfResfiles () const override
Multiple results files can be summed together and treated as 'one'.
int | getNumEtSeqsSearched (const int idx=0) const override
Returns the number of sequences searched in the second pass of an integrated error tolerant search.
int | getNumHits (const section sec=SEC_SUMMARY) const
Returns the maximum number of hits possible for a protein summary.
int | getNumLibraryEntries (const int idx=0) const override
Returns the number of entries in the spectral library searched.
int | getNumQueries (const int resfileID=0) const override
Returns the number of queries (peptide masses or ms-ms spectra).
double | getNumResidues (const int idx=0) const override
Returns the number of residues in the FASTA file(s) searched.
int | getNumSeqs (const int idx=0) const override
Returns the number of sequences in the FASTA file(s) searched.
int | getNumSeqsAfterTax (const int idx=0) const override
Returns the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.
int | getObservedCharge (const int query, const bool decoy=false) const override
The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.
double | getObservedIntensity (const int query) const override
Returns the experimental intensity for the peptide.
double | getObservedMass (const int query) const override
Returns the experimental mass value as entered by the user.
double | getObservedMrValue (const int query, const bool decoy=false) const override
Returns the experimental mass value (as a relative mass) as entered by the user.
std::vector< std::string > | getPercolatorFileNames () const
Retrieve the filenames use for percolator input and output.
ms_progress_info * | getProgressInfo (bool forPeptideSummary=false) const
If a matrix_science::ms_progress_info object is passed to the constructor, this is returned here.
int64_t | getQmatch (const int query, const ms_peptide::PSM_TYPE pepType) const override
Return the number of peptide masses within precursor tolerance of this query.
double | getQplughole (const int query, const ms_peptide::PSM_TYPE pepType) const override
Return the threshold score for homologous peptide match (MIS only).
bool | getQuantitation (ms_quant_configfile *qfile) const override
Returns an object that represents the embedded quantitation file as a reduced quantitation.xml file.
bool | getQuantitationMethod (ms_quant_method *qmethod) const
Return the quantitation method object from the embedded quantitation file.
int | getQuerySectionValue (const int query, const char *key, char *str, int maxLen) const
Return the string value from a query in the results file.
double | getQuerySectionValueDouble (const int query, const char *key) const
Return the floating point value from a query in the results file.
int | getQuerySectionValueInt (const int query, const char *key) const
Return the integer value from a query in the results file.
std::string | getQuerySectionValueStr (const int query, const char *key) const
Return the string value from a query in the results file.
int | getReferenceDatabaseNumberOfSL (const int idx) const override
Return the database number of the reference database of a spectral library.
std::string | getRepeatSearchString (const int query, const bool fullQuery=false) const override
To perform a repeat search need to build up appropriate string.
const ms_mascotresfile_dat * | getResfile (int id) const override
Returns a pointer to the underlying ms_mascotresfile_dat object created by calling appendResfile.
virtual std::string | getSearchParameter (const std::string &key) const override
Return the search parameter the given key.
void | getSearchParametersKeyValues (std::vector< std::string > &keys, std::vector< std::string > &values) const override
Return all the search parameters as key-value pairs.
int | getSectionValue (const section sec, const char *key, char *str, int maxLen) const
Return the string value from any line in the results file.
double | getSectionValueDouble (const section sec, const char *key) const
Return the floating point value from any line in the results file.
int | getSectionValueInt (const section sec, const char *key) const
Return the integer value from any line in the results file.
std::string | getSectionValueStr (const section sec, const char *key) const
Return the string value from any line in the results file.
std::vector< int > | getSLDatabaseNumbersOfReference (const int idx) const override
Return the database numbers of the spectral libraries whose reference database is at the given index.
virtual std::string | getSLExecCommand (int idx=1) const override
Returns the library search command line and parameters (sl_exec_command).
double | getSLFragmentTolerance (int idx=1) const override
Returns the effective spectral library fragment tolerance.
std::string | getSLFragmentToleranceUnit (int idx=1) const override
Returns the unit of the effective spectral library fragment tolerance.
bool | getSrcQueryAndFileIdForMultiFile (const int q, int &gsqNewQuery, int &gsqFileId) const override
Return the query number and file ID in the source .dat file.
bool | getTaxonomy (ms_taxonomyfile *tfile) const override
Returns an object that represents the embedded taxonomy file as a reduced taxonomy file.
bool | getUnimod (ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const override
Returns an object that represents the embedded unimod file as a reduced unimod_2.xml file.
bool | getUnimodXL (ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const override
Returns an object that represents the embedded unimod_xl file as a reduced unimod_xl.xml file.
std::string | getUniqueTaskID () const override
Returns the unique task ID used by Mascot Daemon.
std::string | getXMLschemaFilePath (XML_SCHEMA XMLschema) const
Gets the XML schema to be used by functions using quantitation or unimod.
bool | hasEnzyme () const override
Return true if the results file contains information about the enzyme used.
bool | hasQuantitation () const override
Return true if the results file contains quantitation data.
bool | hasRT () const override
Return true if the results file contains retention time data.
bool | isDatabaseTypeAvailable () const override
Check whether database types are available.
bool | isErrorTolerant () const override
Returns true if the search was an error tolerant search.
bool | isMSMS () const override
Returns true if the search was an MSMS search (SEARCH=MIS).
bool | isPMF () const override
Returns true if the search was a PMF search (SEARCH=PMF).
bool | isSQ () const override
Returns true if the search was a sequence query search (SEARCH=SQ).
bool | isValid () const
Call this function to determine if there have been any errors.
bool | outputKeepAlive () const
Outputs the "keep-alive" string during time-consuming operations.
ms_searchparams & | params () const
Returns a reference to the search parameters class.
void | resetKeepAlive (const int keepAliveInterval, const char *keepAliveText, const bool propagateToAppended=true, const bool resetStartTime=false)
Replace the existing keepAlive values with new values.
void | setPercolatorFeatures (const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes)
Set Percolator features before creating an ms_peptidesummary with Percolator scoring (deprecated).
void | setPercolatorFeatures (const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters=std::vector< std::string >())
Set Percolator features before creating an ms_peptidesummary with Percolator scoring.
bool | setXMLschemaFilePath (XML_SCHEMA XMLschema, const char *path)
Sets the XML schema to be used by functions using quantitation or unimod.
bool | versionGreaterOrEqual (int major, int minor, int revision) const
Compare the value returned by getMascotVer() with the passed version number.

Static Public Member Functions

static std::unique_ptr< ms_mascotresfilebase > | createResfile (const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, matrix_science::ms_progress_info *progressMonitor=0)
Return a new ms_mascotresfile_msr or ms_mascotresfile_dat based on the file contents.
static section | getPeptideSection (const ms_peptide::PSM_TYPE pepType)
Return peptide section in the .dat file that contains matches of type pepType.
static const char * | getSectionName (const section sec)
Return the section name as a string given the enum value.
static section | getSummarySection (const ms_peptide::PSM_TYPE pepType)
Return the summary section in the .dat file that contains matches of type pepType.
static RESFILE_TYPE | resfileType (const std::string &fileName)
Return the results format of the file provided as an argument.
static bool | staticGetPercolatorFileNames (const char *szFileName, const char *cacheDirectory, const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes, std::vector< std::string > &filenames, std::vector< bool > &exists)
Returns a list of the Percolator input and output files for the specified data file (deprecated).
static bool | staticGetPercolatorFileNames (const char *szFileName, const char *cacheDirectory, const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters, std::vector< std::string > &filenames, std::vector< bool > &exists)
Returns a list of the Percolator input and output files for the specified data file.
static bool | willCreateCache (const char *szFileName, const ms_mascotoptions &opts, const char *applicationName, std::string &resfileCacheFileName, unsigned int &cacheStatus)
Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.
static bool | willCreateCache (const char *szFileName, const unsigned int flags, const char *cacheDirectory, std::string *cacheFileName)
Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.

Protected Member Functions

bool | getCrosslinking (ms_crosslinking_configfile *crosslinkingFile) const override
std::string | getErrorInfoAsString (const int num) const
bool | setErrorInfoFromString (const std::string &e)

Detailed Description

Class for parsing and reading files in dat28 format.

Until Mascot Server 2.8, there was only one Mascot results file format: plain text MIME format file with .dat extension. Mascot Server 3.0 introduced a new file format, Mascot Search Results (MSR), which is an SQLite database. The old .dat format is frozen and now referred to as dat28.

This class reads files in the dat28 format.

Member Enumeration Documentation

◆ err

enum err

Definitions for error numbers.

See Using enumerated values and static const ints in Perl, Java, Python and C#. Messages are classified as fatal errors [F] or warnings [W]. A warning will not cause ms_mascotresfile_dat::isValid() to return false.

Deprecated:
  • use ms_errs::err instead
Enumerator
ERR_NO_ERROR | [W] Success
ERR_NOMEM | [F] Failed to allocate memory to load the file
ERR_NOSUCHFILE | [F] The file passed in the constructor does not exist
ERR_READINGFILE | [F] Opened the file successfully, but failed to read from it
ERR_QUERYOUTOFRANGE | [F] Set if query < 1 or query > getNumQueries
ERR_MISSINGENTRY | [F] Set if there is no qexp value in the file
ERR_PEPSUMMPEPGET | [F] Value of q, p or h out of range, so cannot get peptide info
ERR_PEPTIDESTR | [F] The string in the peptides block is not valid
ERR_ACCINPEPTIDESTR | [F] Could not parse an item for a given accession in the peptide section
ERR_PROTSUMM | [F] Error parsing a line in the protein summary
ERR_PROTSUMMPEP | [F] Couldn't parse peptide information from the protein summary section
ERR_ADDPEPTIDES | [F] Failed to add peptides when creating the peptide summary
ERR_MISSINGHIT | [F] Missing hit in the summary section
ERR_MISSINGSECTION | [F] Complete missing section in the file
ERR_MISSINGSECTIONEND | [F] Missing end of section in the file
ERR_MALFORMED_ERR_TOL | [W] Expecting a line of format: q1_p2_et_mods=0.984020,0.000000,Citrullination
ERR_NO_ERR_TOL_PARENT | [F] No parent search file. See Error tolerant searches
ERR_NULL_ACC_PEP_SUM | [W] An empty accession string has been found. Possible problem in database
ERR_NULL_ACC_PROT_SUM | [W] An empty accession string has been found. Possible problem in database
ERR_DUPE_ACCESSION | [W] A possible duplicate accession string has been found. Possible problem in database.
ERR_UNASSIGNED_PROG | [F] Programming error! Calling getNumberOfUnassigned() or getUnassigned() before createUnassignedList()
ERR_UNASSIGNED_RANGE | [F] Calling ms_mascotresults::getUnassigned() with out of range number
ERR_UNASSIGNED_UNK | [F] Calling ms_mascotresults::getUnassigned() - unable to retrieve value
ERR_NO_UNIGENE_FILE | [F] Failed to open the UniGene file specified
ERR_DUPLICATE_KEY | [W] Duplicate entries with the same key in the named section.
ERR_OLDRESULTSFILE | [F] Very old results file (last century!). Parser requires 1.02 or later
ERR_MALFORMED_TAG | [W] Expecting a line in format: q1_p2_tag=1:3:5:6,2:4:12:6,...
ERR_MALFORMED_DRANGE | [W] Expecting a line in format: q1_p2_drange=0,256
ERR_INVALID_NUMQUERIES | [W] Invalid number of queries in results file has been corrected.
ERR_MALFORMED_TERMS | [W] Expecting a line in format: q1_p2_terms=A,B:-,I:...
ERR_INVALID_RESFILE | [F] Invalid results file format - missing or corrupt headers
ERR_INVALID_PROTDB | [W] Invalid h1_db-string format. Expecting an integer number.
ERR_UNIGENE_MULTIDB | [W] UniGene index is not supported in multi-database search
ERR_INVALID_CACHE_DIR | [F] Must specify a cache directory if using CDB cache files
ERR_FAIL_OPEN_DAT_FILE | [F] Failed to open the results file for reading
ERR_MISSING_CDB_FILE | [W] Cache file is missing or cannot be opened
ERR_FAIL_MK_CACHE_DIR | [F] Failed to create cache directory for cache files
ERR_FAIL_MK_CDB_FILE | [W] Failed to create an cache file
ERR_FAIL_CLOSE_FILE | [W] Failed to close file
ERR_FAIL_CDB_INIT | [W] Failed to initialise cache file (%s). Error code %d.
ERR_INVALID_CDB_FILE | [W] Value in cdb cache file (%s) is corrupt: %s
ERR_WRITE_CDB_FILE | [W] Failed to write to the cache file (%s). Error %d (%s)
ERR_CDB_TOO_LARGE | [W] Cannot use cache file (s) which exceeded max size of s. Try deleting the cache file and retrying
ERR_NEED_64_BIT | [F] This results file (%s) is too large for 32 bit Mascot Parser. Please upgrade to 64 bit.
ERR_CDB_64_BIT_REMAKE | [W] Re-creating %s. Was too large for 32 bit, but may succeed with 64 bit
ERR_CDB_OLD_VER_RETRY | [W] Cache file %s is an old version. Creating new cache file
ERR_CDB_OLD_VER_NO_RETRY | [W] Cache file %s is an old version. Continuing without cache
ERR_CDB_INCOMPLETE_RETRY | [W] Cache file %s was not complete. Re-creating the cache file
ERR_CDB_INCOMPLETE_NO_RETRY | [W] Cache file %s was not complete. Continuing without cache
ERR_CDB_BEING_CREATED | [W] Cache file %s being created by another task. Continuing without cache
ERR_CDB_FAIL_REMOVE | [W] Failed to remove old cache file %s - error %s. Continuing without cache
ERR_CDB_FAIL_LOCK | [W] Failed to lock cache file %s. Error code: %d
ERR_CDB_FAIL_UNLOCK | [W] Failed to unlock cache file %s. Error code: %d
ERR_CDB_SOURCE_CHANGE_RETRY | [W] %s changed. %s (was %s), %s bytes (was %s). Re-creating the cache file
ERR_CDB_SOURCE_CHANGE_NO_RETRY | [W] %s changed. %s (was %s), %s bytes (was %s). Continuing without cache
ERR_MISSING_PERCOLATOR_FILE | [F] Percolator file %s is missing. Cannot continue
ERR_CANNOT_APPEND_RESFILE | [F] The file %s cannot be appended to %s because %s values are different
ERR_CANNOT_APPEND_RESFILE_NO_FNAMES | [F] The file cannot be appended because %s values are different
ERR_RESULTS_NOT_CREATED | [W] Attempting to call function %s before createSummary() has completed.

◆ FLAGS

enum FLAGS
inherited

Flags for opening the results file.

See Using enumerated values and static const ints in Perl, Java, Python and C# and Caching Mascot Results.

Enumerator
RESFILE_NOFLAG | Dat28 format: Read the whole file into memory. MSR format: Use standard SQLite methods to read the file with low memory overhead.
RESFILE_USE_CACHE | Dat28 format: Create the resfile cache if it doesn't already exist. Use the cache rather than reading the whole .dat file into memory. MSR format: this flag is ignored.
RESFILE_CACHE_IGNORE_ACC_DUPES | When creating a cache file, don't check for duplicate accessions in the SEC_PROTEINS and SEC_DECOYPROTEINS sections which can save some time. Strongly recommend that this flag is never used unless performance becomes a real issue and it is known that ms_mascotoptions::getIgnoreDupeAccession was not defined for the relevant database(s) when they were compressed.
RESFILE_USE_PARENT_PARAMS | For use when Combining multiple results files. The flags and parameters are then inherited from the parent search.
RESFILE_CACHE_IGNORE_DATE_CHANGE | Dat28 format: Opening the resfile cache CDB file should ignore the last modified timestamp on the .dat file. MSR format: this flag is ignored.

◆ KA_TASK

enum KA_TASK
inherited

Processing some results files is computationally intensive. These are the tasks that can be performed.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Used with getKeepAlive(), but also see outputKeepAlive()

Enumerator
KA_CREATEINDEX_CI | Creating a cache file when Using the resfile cache (dat28 format only) in dat28 format.
KA_READFILE_RF | Reading the results file into memory when not using a cache.
KA_ASSIGNPROTEINS_AP | Assigning peptides to proteins to get a list of all possible proteins.
KA_GROUPPROTEINS_GP | Grouping proteins using ms_mascotresults::MSRES_GROUP_PROTEINS or ms_mascotresults::MSRES_CLUSTER_PROTEINS.
KA_UNASSIGNEDLIST_UL | Creating the unassigned list - see ms_mascotresults::createUnassignedList.
KA_QUANTITATION | Calculating quantitation values for reporter and multiplex protocols.
KA_CREATECACHE_CC | Creating a cache file when Using the pepsum cache (MSR and dat28).
KA_THRESHFORFDR_FDR | Calls to ms_mascotresults::getThresholdForFDRAboveHomology can be slow.
KA_LAST | Placeholder that is equal to the number of possible tasks.

◆ PERCOLATOR_FILE_NAMES

enum PERCOLATOR_FILE_NAMES
inherited

Offsets into a vector of Percolator filenames.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Used with getPercolatorFileNames().

Enumerator
PERCOLATOR_INPUT_FILE | This file is created by ms-createpip.exe and read by Percolator.
PERCOLATOR_OUTPUT_TARGET | From std::out of percolator.exe.
PERCOLATOR_OUTPUT_DECOY | Specified using the -B flag when calling Percolator.

◆ RESFILE_TYPE

enum RESFILE_TYPE
inherited

Supported results file formats.

Enumerator
RESFILE_DAT28 | Plain text MIME-format results file produced by Mascot Server 2.0 to 2.8.
RESFILE_MSR | Mascot Search Results (MSR) file introduced in Mascot Server 3.0.
RESFILE_UNKNOWN | Unknown file format.

◆ section

enum section

Section names in the standard mascot results files.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
SEC_PARAMETERS | parameters section
SEC_HEADER | header section
SEC_MASSES | masses section
SEC_SUMMARY | summary section
SEC_MIXTURE | mixture section (pmf mixture)
SEC_PEPTIDES | peptides section
SEC_PROTEINS | proteins section
SEC_QUERY1 | query1 section. Don't use, see getQuerySectionValueStr() etc.
SEC_QUANTITATION | quantitation section
SEC_UNIMOD | unimod section
SEC_ENZYME | enzyme section
SEC_TAXONOMY | taxonomy section
SEC_DECOYSUMMARY | decoy_summary section. See also Target-decoy searches and false discovery rate.
SEC_DECOYMIXTURE | decoy_mixture section. See also Target-decoy searches and false discovery rate.
SEC_DECOYPEPTIDES | decoy_peptides section. See also Target-decoy searches and false discovery rate.
SEC_DECOYPROTEINS | decoy_proteins section. See also Target-decoy searches and false discovery rate.
SEC_ERRTOLSUMMARY | error tolerant summary section. See also Error tolerant searches.
SEC_ERRTOLPEPTIDES | error tolerant peptides section. See also Error tolerant searches.
SEC_SPECTRAL_LIBRARY | spectral library section. See also Spectral libraries.
SEC_LIBRARYPEPTIDES | spectral library peptides section. See also Spectral libraries.
SEC_LIBRARYSUMMARY | spectral library summary section. See also Spectral libraries.
SEC_CROSSLINK_SUMMARY | crosslink_summary section. See also Crosslinked search results.
SEC_CROSSLINK_PEPTIDES | crosslink_peptides section. See also Crosslinked search results.
SEC_CROSSLINKING | crosslinking section
SEC_UNIMOD_XL | unimod_xl section
SEC_ERRTOLDECOYSUMMARY | error tolerant decoy summary section. See also Error tolerant searches.
SEC_ERRTOLDECOYPEPTIDES | error tolerant decoy peptides section. See also Error tolerant searches.
SEC_INDEX | index section
SEC_NUMSECTIONS | !!don't use - place holder

◆ XML_SCHEMA

enum XML_SCHEMA
inherited

The results file contains embedded files in XML format and these need to be validated against a schema.

This is the list of schema that can be set using setXMLschemaFilePath() and getXMLschemaFilePath()

Enumerator
XML_SCHEMA_QUANTITATION | From the embedded quantation file. Valid aliases are: "http://www.matrixscience.com/xmlns/schema/quantitation_1" and "http://www.matrixscience.com/xmlns/schema/quantitation_2".
XML_SCHEMA_UNIMOD | From the embedded unimod file. Valid alias is: http://www.unimod.org/xmlns/schema/unimod_2.
XML_SCHEMA_DIRECTORY | From the value of XMLschemaDirectory passed into the ms_mascotresfilebase constructor.
XML_SCHEMA_CROSSLINKING | From the embedded crosslinking file. Valid alias is: http://www.matrixscience.com/xmlns/schema/crosslinking_1.
XML_SCHEMA_LAST | Placeholder that is equal to the number of possible schema.

Constructor & Destructor Documentation

◆ ms_mascotresfile_dat()

ms_mascotresfile_dat | ( | const char * | szFileName,
 |  | const int | keepAliveInterval = 0,
 |  | const char * | keepAliveText = "<!-- %d seconds -->\n",
 |  | const unsigned int | flags = RESFILE_NOFLAG,
 |  | const char * | cacheDirectory = "../data/cache/%Y/%m",
 |  | const char * | XMLschemaDirectory = 0,
 |  | ms_progress_info * | progressMonitor = 0
 | ) |  |

Constructor to open a Mascot results file in dat28 format.

If the ms_mascotresfilebase::RESFILE_NOFLAG flag is specified, then the constructor reads the whole file into memory, and makes an in memory index of all the keys for fast lookup later. This was the default (and only) behaviour for Mascot Parser versions 2.2 and earlier.

If the ms_mascotresfilebase::RESFILE_USE_CACHE flag is specified, then the file is not read into memory, but a separate cache file containing offsets is used to read each line in the results file when requested. This is considerably faster if just a few lines of the results file need to be accessed and also takes less memory. The filenames for the cache file will be created by extracting the filename part from the path supplied in szFileName and appending '.cdb'. So, typically the cache filenames will be of the form Fxxxxx.dat.cdb. See Caching Mascot Results.

For HTML reports with large result files it is sometimes necessary to output HTML fragments to keep the connection alive. This can be done by specifying the interval at which the text is output (keepAliveInterval) and the text that should be output (keepAliveText). See ms_mascotresfilebase::outputKeepAlive() for more details.

The functions isValid() or getLastError() should be called after creating the object to determine if the file was valid and loaded properly.

Possible error values:

  • ms_mascotresfile_dat::ERR_NOMEM
  • ms_mascotresfile_dat::ERR_NOSUCHFILE
  • ms_mascotresfile_dat::ERR_MISSINGSECTION
  • ms_mascotresfile_dat::ERR_MISSINGSECTIONEND
  • ms_mascotresfile_dat::ERR_READINGFILE
  • ms_mascotresfile_dat::ERR_INVALID_CACHE_DIR
  • ms_mascotresfile_dat::ERR_FAIL_OPEN_DAT_FILE
  • ms_mascotresfile_dat::ERR_FAIL_MK_CACHE_DIR
  • ms_mascotresfile_dat::ERR_FAIL_CDB_INIT
  • ms_mascotresfile_dat::ERR_MISSING_CDB_FILE
  • ms_mascotresfile_dat::ERR_INVALID_NUMQUERIES
  • ms_mascotresfile_dat::ERR_INVALID_RESFILE
  • ms_mascotresfile_dat::ERR_FAIL_MK_CDB_FILE
  • ms_mascotresfile_dat::ERR_FAIL_CLOSE_FILE
Parameters
szFileName | is the path to a valid Mascot results file
keepAliveInterval | is the interval in seconds between each time the keepAliveText is output to stdout. If a value of zero is specified, then no keep alive text will be output.
keepAliveText | is output every keepAliveInterval seconds while the file is being loaded. See outputKeepAlive() for further details.
flags | are created by bitwise ORing the ms_mascotresfile_dat::FLAGS
cacheDirectory | is the location where any cache files are stored. See Specifying cache file directory. If cacheDirectory is null or empty and RESFILE_USE_CACHE is specified, then ERR_INVALID_CACHE_DIR will be set and the object will be invalid. Most applications should get this value from ms_mascotoptions::getCacheDirectory().
XMLschemaDirectory | is the location where the xml schema files are located. Some sections of the results file are encoded in XML, and Mascot Parser needs to verify that these are in the correct format using 'xsd' schema files. The required files are supplied with Mascot Parser in the config directory. Either supply the path to that directory, or copy the .xsd files from it to another directory and supply the path to that (only the xsd files from that directory are required). If this parameter is 0 (the default) or empty string (""), then it is assumed that the software is running on the Mascot Server and that the files are located in separate directories under ../html/xmlns/schema as defined in setXMLschemaFilePath(). The constructor does not check that the schema files exist, but subsequent calls to functions such as getUnimod() and getQuantitationMethod() will fail if the schema is not available. The function setXMLschemaFilePath() may be called to override this value passed in the constructor for individual schema files.
progressMonitor | is an optional parameter that can be used to track progress of the creation of this object. It can also be used (from another thread) to cancel the creation of the object by calling ms_progress_info::setBreak. If the passed progressMonitor has a subTask, created by calling ms_progress_info::addSubtask("Creating peptide summary", 100), then that subtask will be used when creating the ms_peptidesummary object. If the subtask doesn't exist, then one is created. Both pointers can be obtained by calling ms_mascotresfile_dat::getProgressInfo(). Make sure that the calling function does not delete the object pointed to by this paramater until after the ms_mascotresfile_dat object has been deleted. See: Maintaining object references: two rules of thumb

Member Function Documentation

◆ anyMSMS()

bool anyMSMS ( ) const
overridevirtual

Returns true if any of the queries in the search contain ions data.

See also the isMSMS() member, although this function is the preferred one.

Returns
true if any queries contain MS-MS fragment masses

Implements ms_mascotresfilebase.

◆ anyPeptideSummaryMatches()

bool anyPeptideSummaryMatches ( const section sec = SEC_PEPTIDES ) const

Returns true if there is a peptides section, and if there are any results in it.

If no parameter is passed to this function, information is returned about the standard peptides section.

This function is useful if, for example, you want to know if there is a peptides, decoy_peptides or et_peptides section in the results file. Very early versions of Mascot didn't have a peptides section for MS-MS searches, and the decoy and error tolerant peptides sections were added in Mascot 2.2, so it is safest to check that this function returns true before creating an ms_peptidesummary report. If this function returns false, consider creating an ms_proteinsummary instead.

This function will also return false if there is a peptides section that doesn't contain any results.

Even if this function returns true, it is possible that an ms_peptidesummary object created from the file will be empty if, for example, all the matches have ions scores below the specified minimum ions score.

Parameters
sec Can be one of ms_mascotresfile_dat::SEC_PEPTIDES, ms_mascotresfile_dat::SEC_DECOYPEPTIDES, ms_mascotresfile_dat::SEC_ERRTOLPEPTIDES, ms_mascotresfile_dat::SEC_ERRTOLDECOYPEPTIDES, ms_mascotresfile_dat::SEC_LIBRARYPEPTIDES, ms_mascotresfile_dat::SEC_CROSSLINK_PEPTIDES
Returns
True if the section exists and contains any results in the specified section

◆ anyPMF()

bool anyPMF ( ) const
overridevirtual

Returns true if any of the queries in the search just contain a single peptide mass.

See also the isPMF() member, although this function is the preferred one.

Returns
true if any queries contain no MS-MS values

Implements ms_mascotresfilebase.

◆ anySQ()

bool anySQ ( ) const
overridevirtual

Returns true if any of the queries in the search contain seq or comp commands.

See also the isSQ() member, although this function is the preferred one.

Returns
true if any queries contain seq or comp commands

Implements ms_mascotresfilebase.

◆ anyTag()

bool anyTag ( ) const
overridevirtual

Returns true if any of the queries in the search contain tag or etag commands.

See also anySQ(), anyPMF() and anyMSMS()

Returns
true if any queries contain tag or etag commands
true if it has any tag

Implements ms_mascotresfilebase.

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ appendResfile()

int appendResfile | ( | const char * | filename,
 |  | int | flags = RESFILE_USE_PARENT_PARAMS,
 |  | const char * | cacheDirectory = 0
 | ) |  |
overridevirtual

Multiple results files can be summed together and treated as 'one'.

See Combining multiple results files.

Attempts to load the specifed results file and append to the existing file.

Any warning or error messages in the file are also appended to the existing object. If isValid() for the new file returns false, it is not appended and this function returns 0.

A merged report requires the results to be in the same file format. That is, a dat28 (.dat) can be appended to another dat28 file, and an MSR file (.msr) can be appended to another MSR file, but you cannot append an MSR file to a dat28 file or vice versa.

ms_errs::ERR_INVALID_RESFILE, ms_errs::ERR_READINGFILE or ms_errs::ERR_MSP_MSR_READING_FILE may be set if the file formats are not compatible.

ms_errs::ERR_CANNOT_APPEND_RESFILE_NO_FNAMES and ms_errs::ERR_CANNOT_APPEND_RESFILE will be set if the file cannot be appended because of different parameters, such as a different enzyme.

Parameters
filename | is the path to the results file to append.
flags | are one of the ms_mascotresfilebase::FLAGS. If RESFILE_USE_PARENT_PARAMS is specified, then the flags, keepAlive and cache directory are copied from the parent object.
cacheDirectory | is the directory for the cache files if RESFILE_USE_CACHE has been specified. If RESFILE_USE_PARENT_PARAMS is specified and cacheDirectory is null or an empty string, then the cache directory for the parent object is used.
Returns
0 on error, or the id number of the new file. The id can be used with getNumQueries(), getJobNumber(), getFileName() or getResfile(). The return value from the first successful call to this function will be 2.

Implements ms_mascotresfilebase.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ createResfile()

std::unique_ptr< ms_mascotresfilebase > createResfile | ( | const char * | szFileName,
 |  | const int | keepAliveInterval = 0,
 |  | const char * | keepAliveText = "<!-- %d seconds -->\n",
 |  | const unsigned int | flags = matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG,
 |  | const char * | cacheDirectory = "../data/cache/%Y/%m",
 |  | const char * | XMLschemaDirectory = 0,
 |  | matrix_science::ms_progress_info * | progressMonitor = 0
 | ) |  |
staticinherited

Return a new ms_mascotresfile_msr or ms_mascotresfile_dat based on the file contents.

The function 'sniffs' and detects the file contents using ms_mascotresfilebase::resfileType. If it looks like an MSR file, the function returns a new ms_mascotresfile_msr. If it looks like a dat28 (.dat) file, the function returns ms_mascotresfile_dat. Otherwise, a 'nil' object is returned which contains no data and is invalid.

The arguments are the same between the classes, but the details differ a bit. For example, ms_mascotresfile_msr doesn't need caching for fast random access, so it ignores the flags parameter. However, it's always safe to use the same flags regardless of class.

Please see the detailed class documentation:

  • ms_mascotresfile_msr::ms_mascotresfile_msr
  • ms_mascotresfile_dat::ms_mascotresfile_dat
Parameters
szFileName | is the path to a valid Mascot results file
keepAliveInterval | is the interval in seconds between each time the keepAliveText is output to stdout.
keepAliveText | is output every keepAliveInterval seconds while the file is being loaded. See outputKeepAlive() for further details.
flags | are created by bitwise ORing the ms_mascotresfile_dat::FLAGS.
cacheDirectory | is the location where any cache files are stored.
XMLschemaDirectory | is the location where the xml schema files are located.
progressMonitor | is an optional parameter that can be used to track progress of the creation of this object.
Returns
ms_mascotresfile_msr or ms_mascotresfile_dat object, or a 'nil' object if the file type isn't supported.

◆ doesSectionExist()

bool doesSectionExist ( const section sec ) const

Returns true if there is an entry for the passed section.

This function is useful if, for example, you want to know if there is a peptides section in the results file. Very early versions of Mascot didn't have a peptides section for MS-MS searches.

Parameters
sec is the section number
Returns
True if the section exists

◆ enumerateQuerySectionKeys()

std::string enumerateQuerySectionKeys | ( | const int | query,
 |  | const int | num,
 |  | int * | pPreviousNum = 0,
 |  | OFFSET64_T * | pPreviousOffset = 0
 | ) |  | const

Get the key name for each item in a query section.

Enumerate through all the entries in a section. It returns the key name (not value) for a single item.

In version of Mascot Parser prior to version 2.3, the items are returned in alphabetical order. In Mascot Parser version 2.3 and later, the items are returned in the order in the results file.

See ms_searchparams::getAllUSERParams for an example of using this method.

Note
When using this method in a programming language other than C++, you can not use the optional parameters pPreviousNum and pPreviousOffset.
Parameters
query | should be in the range 1..getNumQueries().
num | is the line number (1..n) of the line in the required section.
pPreviousNum | is an optional parameter to speed up iterating through a large section when using cached files. If this value is not null, then the pPreviousOffset should also be passed.
pPreviousOffset | is an optional parameter to speed up iterating through a large section when using cached files. If this value is not null, then the pPreviousNum should also be passed.
Returns
The key name. An empty string is returned when num is greater than the number of items in the section or is less than 1.

◆ enumerateSectionKeys()

std::string enumerateSectionKeys | ( | const section | sec,
 |  | const int | num,
 |  | int * | pPreviousNum = 0,
 |  | OFFSET64_T * | pPreviousOffset = 0
 | ) |  | const

Get the key name for each item in a section.

Enumerate through all the entries in a section. It returns the key name (not value) for a single item.

In version of Mascot Parser prior to version 2.3, the items are returned in alphabetical order. In Mascot Parser version 2.3 and later, the items are returned in the order in the results file.

See ms_searchparams::getAllUSERParams for an example of using this method.

Note
When using this method in a programming language other than C++, you can not use the optional parameters pPreviousNum and pPreviousOffset.
Parameters
sec | can be any section number that contains value= lines This function will not work for sections that contain embedded XML such as the unimod section.
num | is the line number (1..n) of the line in the required section.
pPreviousNum | is an optional parameter to speed up iterating through a large section when using cached files. If this value is not null, then the pPreviousOffset should also be passed.
pPreviousOffset | is an optional parameter to speed up iterating through a large section when using cached files. If this value is not null, then the pPreviousNum should also be passed.
Returns
The key name. An empty string is returned when num is greater than the number of items in the section or is less than 1.

◆ get_ms_mascotresults_params() [1/2]

std::string get_ms_mascotresults_params | ( | const ms_mascotoptions & | opts,
 |  | ms_mascotresults_params & | resParams
 | ) |  | const
 inherited

Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.

A number of optional flags and parameters can be passed to the ms_proteinsummary or ms_peptide summary constructors. For an application or script running on the Mascot server, the default values for some of these parameters should normally be taken from the mascot.dat file. This function sets the values and flags required to pass to the constructor in the passed ms_mascotresults_params object.

Parameters
[in] | opts | contains the options stored in mascot.dat. Call the ms_datfile construction and then ms_datfile::getMascotOptions() to obtain this value.
[out] | resParams | the values and flags required to pass to the peptide or protein summary object are set to this ms_mascotresults_params object, overwriting any values which were already set.
Returns
If the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch, then the returned script name will be ms_mascotoptions::getResultsPerlScript_2, otherwise it will be ms_mascotoptions::getResultsPerlScript.
Examples
resfile_summary.cpp.

◆ get_ms_mascotresults_params() [2/2]

std::string get_ms_mascotresults_params | ( | const ms_mascotoptions & | opts,
 |  | unsigned int * | gpFlags,
 |  | double * | gpMinProbability,
 |  | int * | gpMaxHitsToReport,
 |  | double * | gpIgnoreIonsScoreBelow,
 |  | unsigned int * | gpMinPepLenInPepSummary,
 |  | bool * | gpUsePeptideSummary,
 |  | unsigned int * | gpFlags2
 | ) |  | const
 inherited

[Deprecated] Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.

Deprecated:
This function is deprecated. All new code should use ms_mascotresfilebase::get_ms_mascotresults_params(const ms_mascotoptions &, ms_mascotresults_params &) instead, as all the parameters are encapsulated in the ms_mascotresults_params class.

A number of optional flags and parameters can be passed to the ms_proteinsummary or ms_peptide summary constructors. For an application or script running on the Mascot server, the default values for some of these parameters should normally be taken from the mascot.dat file. This function returns the values and flags required to pass to the constructor.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | opts | contains the options stored in mascot.dat. Call the ms_datfile construction and then ms_datfile::getMascotOptions() to obtain this value.
[out] | gpFlags | will return the flags that are to be passed as the second parameter to the ms_proteinsummary or ms_peptidesummary object.
[out] | gpMinProbability | is the third parameter to be passed to the ms_proteinsummary or ms_peptidesummary objects. This return value will nomally be equal to the value returned from ms_mascotoptions::getSigThreshold().
[out] | gpMaxHitsToReport | this return value will normally be the one returned by ms_searchparams::getREPORT().
[out] | gpIgnoreIonsScoreBelow | this return value will be the one returned by ms_mascotoptions::getIgnoreIonsScoreBelow().
[out] | gpMinPepLenInPepSummary | this return value will be the one returned by ms_mascotoptions::getMinPepLenInPepSummary.
[out] | gpUsePeptideSummary | will be false is the file doesn't contain any anyMSMS (as returned by the anyMSMS() function) or any sequence tags (anyTag()). In this case, you should create an ms_proteinsummary. If gpUsePeptideSummary is true, you should create an ms_peptidesummary object.
[out] gpFlags2 is only required for an ms_peptidesummary. If gpUsePeptideSummary is true, gpFlags2 will have the following bits set.
  • ms_peptidesummary::MSPEPSUM_PERCOLATOR if all of the following apply:
    • the number of queries is >= ms_mascotoptions::getPercolatorMinQueries;
    • the number of sequences searched >= ms_mascotoptions::getPercolatorMinSequences;
    • this is a decoy search;
    • ms_mascotoptions::isPercolator() returns true;
  • ms_peptidesummary::MSPEPSUM_USE_CACHE if the script name that the function will return is in the string specified by ms_mascotoptions::getResultsCache().
  • ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH if the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch.
  • ms_peptidesummary::MSPEPSUM_REMOVE_CHIMERIC_DUPES if the results file comes from Mascot 2.5 or later.
Returns
If the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch, then the returned script name will be ms_mascotoptions::getResultsPerlScript_2, otherwise it will be ms_mascotoptions::getResultsPerlScript.

◆ getCacheDirectory()

std::string getCacheDirectory ( bool processed = true ) const
overridevirtual

Returns the directory being used for cache files (if any).

The cacheDirectory supplied to the constructor ms_mascotresfilebase::ms_mascotresfilebase may contain a number of '%' flags which get substituted by Mascot Parser.

This function returns either an absolute directory or a directory relative to the current working directory, depending on what was supplied and the parameter processed.

See Caching Mascot Results and ms_mascotoptions::getCacheDirectory

Parameters
processed if true (the default), then the returned directory is relative to the current directory and will have any '%' flags replaced with the relevant directory. If processed is false, then the directory returned will be identical to the one passed to the constructor.
Returns
The cache directory.

Implements ms_mascotresfilebase.

◆ getCacheFileName()

std::string getCacheFileName ( ) const
overridevirtual

Returns the filename of the cache file.

If the cacheDirectory supplied to the ms_mascotresfile_dat::ms_mascotresfile_dat constructor is not empty, then a filename will be returned. This does not guarantee that the file exists, or is being used.

See Caching Mascot Results.

Returns
The filename for the cache file.

Implements ms_mascotresfilebase.

◆ getCrosslinking()

bool getCrosslinking ( ms_crosslinking_configfile * crosslinkingFile ) const
overrideprotectedvirtual

The return value indicates that the embedded crosslinking method file exists in the results file. Call ms_crosslinking_configfile::isValid to determine whether the XML part has been parsed successfully.

The contents of the file are validated against a schema by default.

See Object initialising functions in Perl, Java, Python and C#.

See also
getCrosslinkingMethod() which is generally easier to use.
Parameters
crosslinkingFile a pointer to crosslinking file object. This must be a valid pointer to a valid object, which should normally be created using the default constructor: ms_crosslinking_configfile::ms_crosslinking_configfile
Returns
true if embedded file exists and false if it doesn't

Implements ms_mascotresfilebase.

◆ getCrosslinkingMethod()

bool getCrosslinkingMethod ( ms_crosslinking_method * method ) const
inherited

Return the crosslinking method object from the embedded crosslinking file.

This method returns true if all of the following apply:

  • the embedded crosslinking file exists;
  • a valid schema file location has been set using the XMLschemaDirectory parameter in the constructor or the file exists in the default location;
  • the embedded crosslinking file validates against the schema;
  • the crosslinking method named in the CROSSLINKING parameter exists;
  • the crosslinking method can be loaded.

Otherwise the method returns false.

If the CROSSLINKING parameter is empty or equals "none", then the method simply returns false. Otherwise, on failure, the method sets the warning ms_errors::ERR_MSP_CROSSLINKING_FAILEDLOAD.

Parameters
method A pointer to crosslinking method object. This must be a valid pointer to a valid object, which should normally be created using the default constructor ms_quant_method::ms_quant_method.
Returns
True if the method was loaded; false otherwise.

◆ getDatabaseType()

DATABASE_TYPE getDatabaseType ( const int idx ) const
overridevirtual

Return database type if available.

In dat28 format, Mascot 2.6 and later save the type of the searched database(s) in the results file, as db_typeX= lines in the header section. These types are AA (amino acid), NA (nucleic acid) or SL (spectral library).

In MSR format, introduced in Mascot Server 3.0, the 'db_type' column is always present in the search__databases table.

The number of databases is ms_searchparams::getNumberOfDatabases(), so idx should be between 1 and getNumberOfDatabases().

Spectral libraries must have a reference database. If the reference database is not part of the actual search, protein accessions mapped to it have a database number above ms_searchparams::getNumberOfDatabases(). For example, if the search contains one AA database and one spectral library, getNumberOfDatabases() is 2 and the types returned by getDatabaseType() are AA (idx = 1) and SL (idx = 2). The reference database is at index 3 with type SLREF.

To find the number of the reference database of a spectral library, see ms_mascotresfilebase::geReferenceDatabaseNumberOfSL().

Parameters
idx index of the database; must normally be between 1 and ms_searchparams::getNumberOfDatabases(), or a valid database number returned by ms_mascotresfilebase::getReferenceDatabaseNumberOfSL()
Returns
database type if available. If idx is out of range or isDatabaseTypeAvailable() is false, returns AA.

Implements ms_mascotresfilebase.

◆ getDate()

int getDate ( ) const
inlineoverridevirtual

Returns the date and time of the search in seconds since midnight January 1st 1970.

In dat28 format, obtained from the date= line in the header section of the file.

In MSR format, obtained from the 'date' row in the search__header table.

Can be converted to day, month, year etc. using gmtime or similar functions.

Returns
the date and time of the search in seconds since midnight January 1st 1970.

Implements ms_mascotresfilebase.

◆ getDecoyTypeForDB()

ms_mascotoptions::DECOY_ALGORITHM getDecoyTypeForDB ( const int idx = 1 ) const
overridevirtual

Returns the decoy algorithm type for a given database.

In dat28 format, the decoy algorithm type is saved as decoy_type= or decoy_typeX= in the header section, depending on Mascot version.

In MSR format, the algorithm type is saved as the 'decoy_type' column in the search__databases table.

If idx = 1, the method returns the value of decoy_type=. If idx > 1, the method returns the corresponding decoy_typeX= line, or if one doesn't exist, falls back on decoy_type=.

If there is no suitable value in the file or idx is outside its range, the method returns ms_mascotoptions::DECOY_ALGORITHM_NONE.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the decoy algorithm type, or ms_mascotoptions::DECOY_ALGORITHM_NONE.

Implements ms_mascotresfilebase.

◆ getEnzyme()

bool getEnzyme | ( | ms_enzymefile * | efile,
 |  | const char * | enzymeFileName = 0
 | ) |  | const
 overridevirtual

Returns an object that represents the embedded enzyme file as a reduced enzymes file.

In dat28 format, for data files created with Mascot 2.2 and later, the full definition of the enzyme used is included in the Mascot results file. For earlier versions of Mascot, just the name is recorded. This function attempts to read the definition from the results file. If the definition is not present in the results file and a path to the enzymes file has been passed, then this function reads the enzymes file and removes all entries from the list in memory apart from the one with the name specified in the results file.

In MSR format, the full definition of the enzyme used in the search is included in the Mascot results file.

To determine whether the content has been parsed successfully call ms_enzymefile::isValid.

See Object initialising functions in Perl, Java, Python and C#.

Parameters
efile | a pointer to enzymes-file object that will accept the content from the embedded file or the extenal enzymes file if necessary. If successful, the enzyme itself can be retrieved by passing an index of zero to ms_enzymefile::getEnzymeByNumber()
enzymeFileName | is only used for results files prior to Mascot 2.2
Returns
True if the embedded file exists in the results file or if the enzyme specified in the results file can be loaded from the external enzymes file.

Implements ms_mascotresfilebase.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getErrorInfoAsString()

std::string getErrorInfoAsString ( const int num ) const
protectedinherited

For saving any errors in the .cdb file

Parameters
num 1..getNumberOfErrors()
Returns
"[Error Number]:[Number of times]:[Error string]"

◆ getErrorNumber()

int getErrorNumber ( const int num = -1 ) const
inherited

Return a specific error number - or ms_errs::ERR_NO_ERROR.

All errors are accumulated into a list in this object, until clearAllErrors() is called.

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

See Error Handling.

See also
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()

In Mascot Parser 2.5 and later, this is implemented by calling: ms_errs::getErrorNumber()

Parameters
num is the error number in the range 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or ERR_NO_ERROR. If an invalid number is passed, ERR_NO_ERROR will be returned (and no error will be added to the list of errors!).
Returns
the error number
Examples
resfile_error.cpp, and resfile_summary.cpp.

◆ getErrorString()

std::string getErrorString ( const int num ) const
inherited

Return a specific error as a string.

All errors are accumulated into a list in this object, until clearAllErrors() is called. To return a particular error, call this function with a number 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or an empty string. If an invalid number is passed an empty string will be returned (and no error will be added to the list of errors!).

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

In Mascot Parser 2.5 and later, this is implemented by calling ms_errs::getErrorString but functionality is identical to previous versions.

See Error Handling.

See also
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()
Parameters
num 1 to number of errors, or -1
Returns
error string for the given number, or the last error for -1, empty string if none
Examples
resfile_error.cpp, and resfile_summary.cpp.

◆ getExecTime()

int getExecTime ( ) const
inlineoverridevirtual

Returns the time taken for the search.

In dat28 format, obtained from the exec_time= line in the header section.

In MSR format, obtained from the 'exec_time' row in the search__header table.

This is the 'wall clock' time, not the CPU time.

Returns
execution time in seconds

Implements ms_mascotresfilebase.

◆ getFastaPath()

std::string getFastaPath ( int idx = 1 ) const
overridevirtual

Returns the path to the FASTA file used.

Available in Mascot 2.2 and later.

Mascot 2.6 and later support spectral libraries. Each spectral library must have a reference database into which found peptide sequences are mapped at the end of the search. The "effective" reference database could be one of the protein sequence databases searched, or it could be a separate database used only for lookup purposes. You can find the database number of the reference database with ms_mascotresfilebase::getReferenceDatabaseNumberOfSL(). If this is larger than getNumberOfDatabases(), the FASTA file path is obtained from the library_reference_fastafile line in the results file header.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases() for databases or libraries searched, or an index returned by ms_mascotresfilebase::getReferenceDatabaseNumberOfSL().
Returns
The full path to the database or library file used in the search.

Implements ms_mascotresfilebase.

◆ getFastaVer()

std::string getFastaVer ( int idx = 1 ) const
overridevirtual

Returns the FASTA file version.

Mascot 2.6 and later support spectral libraries. Each spectral library must have a reference database into which found peptide sequences are mapped at the end of the search. The "effective" reference database could be one of the protein sequence databases searched, or it could be a separate database used only for lookup purposes. You can find the database number of the reference database with ms_mascotresfilebase::getReferenceDatabaseNumberOfSL(). If this is larger than getNumberOfDatabases(), the FASTA file version is obtained from the library_reference_release line in the results file header.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases() for databases or libraries searched, or an index returned by ms_mascotresfilebase::getReferenceDatabaseNumberOfSL().
Returns
File name of the database or library searched.

Implements ms_mascotresfilebase.

◆ getFileName()

std::string getFileName ( const int id = 1 ) const
overridevirtual

Returns the name of the results file passed into the constructor.

Parameters
id a 1 based index. Unless appendResfile() has been called, this value must be '1'.
Returns
the file name (or file path) of the results file.

Implements ms_mascotresfilebase.

◆ getFirstPassThreshold()

double getFirstPassThreshold ( ) const
overridevirtual

Return the threshold value for the first pass of an automated error tolerant search.

Return the first pass threshold of an automated error tolerant search. This is the significance threshold used at the end of the first pass to select proteins for the second pass.

In Mascot Server 2.7 and earlier, the first pass threshold was always 0.05.

In Mascot Server 2.8 and later, you can specify a target FDR in the search form. If the search is an error tolerant target-decoy search with target FDR, the first pass threshold can differ from 0.05.

See Score thresholds and score filtering (Mascot Server 2.8 and later).

Returns
First pass threshold, or 0.0 if this is not an integrated error tolerant search.

Implements ms_mascotresfilebase.

◆ getHeaderKeyValues()

void getHeaderKeyValues | ( | std::vector< std::string > & | keys,
 |  | std::vector< std::string > & | values
 | ) |  | const
 overridevirtual

Return all the header key-value pairs.

Get all the key-value pairs of the results header. The header contains data such as: number of queries, exec_time (search duration), database types (AA, NA, SL) and task ID.

To get the value of an individual header key, use ms_mascotresfilebase::getHeaderValue().

Parameters
[out] | keys | A vector of non-empty keys.
[out] | values | A vector of strings (some may be empty) in the same order as keys.

Implements ms_mascotresfilebase.

◆ getHeaderValue()

std::string getHeaderValue ( const std::string & key ) const
overridevirtual

Return the header value for the given key.

Get the value associated with the input key in the results header. To get all the values, use ms_mascotresfilebase::getHeaderKeyValues().

Parameters
[in] key A non-empty string.
Returns
the value associated to the key, or empty if the key does not exist.

Implements ms_mascotresfilebase.

◆ getInputQuery()

ms_inputquery getInputQuery ( const int queryNum ) const
overridevirtual

Return the ms_inputquery object for the query given as argument.

This method call is equivalent to creating an ms_inputquery object with the current results file and queryNum as parameter.

Parameters
queryNum is the query number
Returns
ms_inputquery object

Implements ms_mascotresfilebase.

◆ getJobNumber()

int getJobNumber ( const int resfileID = 1 ) const
overridevirtual

Return the job number for this file - obtained from the file name.

The library can only 'guess' at this since the value is not in the results file. To perform this function, it retrieves the job number from the file name, so be warned about changing file names. The function returns 0 if it cannot determine the job number.

Parameters
resfileID is the the 1 based id of the results file. If multiple files have been merged together with appendResfile(), use the file ID returned by appendResfile() or getSrcFileIdForMultiFile() to access the job number of the appended files.
Returns
the derived job number.

Implements ms_mascotresfilebase.

◆ getKeepAlive()

void getKeepAlive | ( | KA_TASK & | kaTask,
 |  | int & | kaPercentage,
 |  | std::string & | kaAccession,
 |  | int & | kaHit,
 |  | int & | kaQuery,
 |  | std::string & | kaText
 | ) |  | const
 inherited

Return the progress indicators used by the keepAlive functions.

See Multiple return values in Perl, Java, Python and C# although there may be issues with some languages and the kaTask parameter.

It is normally easier for client applications to call ms_mascotresults::getCreateSummaryProgress() or outputKeepAlive() than to call this function.

Parameters
kaTask | is the task currently being performed by Mascot Parser. If Parser is doing nothing, then this will be the last task that was completed and kaPercentage will be 100
kaPercentage | is the percentage (0..100) complete for the current kaTask.
kaAccession | is the current 'accession' being processed. See outputKeepAlive() for details of which tasks set this value
kaHit | is the current hit being processed. See outputKeepAlive() for details of which tasks set this value
kaQuery | is the current 'query' being processed. See outputKeepAlive() for details of which tasks set this value
kaText | is the text that would be output by outputKeepAlive()

◆ getLastError()

int getLastError ( ) const
inherited

Return the last error number - or ms_erros::ERR_NO_ERROR.

Same as calling getErrorNumber() with -1 as a parameter.

Returns
error number
Examples
peptide_list.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the last error number - or an empty string.

Same as calling getErrorString() with -1 as a parameter.

Returns
last error string
Examples
peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, and resfile_params.cpp.

◆ getLibraryMods()

int getLibraryMods | ( | std::vector< std::string > & | modNames,
 |  | std::vector< double > & | modDeltas
 | ) |  | const
 overridevirtual

Return all the library mod names and deltas.

Get a list of all library modifications. If multiple spectral libraries were searched, this is the combined list of modifications.

Parameters
[out] | modNames | Library modification names.
[out] | modDeltas | Library modification deltas.
Returns
the number of modifications, or 0 if there are none.

Implements ms_mascotresfilebase.

◆ getMascotVer()

std::string getMascotVer ( ) const
inlineoverridevirtual

Returns the version of Mascot used to perform the search.

In dat28 format, obtained from the version= entry in the header section of the file.

In MSR format, obtained from the 'version' row in the search__header table.

See also
versionGreaterOrEqual
Returns
the version of Mascot used to perform the search.

Implements ms_mascotresfilebase.

◆ getMasses()

bool getMasses ( ms_masses * masses ) const
inherited

Returns an ms_masses object from the mass values in the results file.

For results files from Mascot 2.2 and later, this function simply calls

    if (getUnimod(&umodConfigFile) && umodConfigFile.isValid())
    {
        masses->copyFrom(&umodConfigFile);
    }

For earlier results files in dat28 format, it reads the residue mass values from the masses section of the file. Since this section either contains average or monoisotopic masses (but not both), the resulting ms_masses object will only have one set of masses.

See Object initialising functions in Perl, Java, Python and C#.

Parameters
masses a pointer to a valid masses object that will accept the content from the section.
Returns
true always.

◆ getMassesKeyValues()

void getMassesKeyValues | ( | std::vector< std::string > & | keys,
 |  | std::vector< double > & | values
 | ) |  | const
 overridevirtual

Return all the residue and modification masses as key-value pairs.

Get all the modification and residue masses as key-value pairs. This includes:

  • Residue masses (A, B, C, D, etc.)
  • Terminus masses (N-term, C-term)
  • Element and atomic masses (H, O, electron, etc.)
  • Variable modification deltas (delta1, delta2, etc.)
  • Fixed modification deltas (FixedMod1, FixedMod2, etc.)
  • Fragment neutral loss (NeutralLoss1, NeutralLoss2, etc.)
  • Peptide neutral loss (PepNeutralLoss1, PepNeutralLoss2, etc.)
  • Required peptide neutral loss (ReqPepNeutralLoss1, ReqPepNeutralLoss2, etc.)
  • Ignore masses (Ignore1, Ignore2, etc.)

To get the value of an individual key, use ms_mascotresfilebase::getMassValue().

In general, it is easier to access these values through ms_searchparams.

Parameters
[out] | keys | A vector of non-empty keys.
[out] | values | A vector of doubles in the same order as keys.

Implements ms_mascotresfilebase.

◆ getMassValue()

double getMassValue ( const std::string & key ) const
overridevirtual

Return the residue or modification mass for the given key.

Get the value associated with the input key in the list of masses. To get all the values, use ms_mascotresfilebase::getMassKeyValues().

Parameters
[in] key A non-empty string.
Returns
the value associated to the key, or 0.0 if the key does not exist.

Implements ms_mascotresfilebase.

◆ getMonoLinkModification()

const ms_modification * getMonoLinkModification | ( | const int | modNum,
 |  | const int | monoLink
 | ) |  | const
 inherited

Returns an ms_modification object that represents a monolink variable modification.

The method performs the following steps:

  • Fetch the the embedded unimod_xl file (ms_mascotresfilebase::getUnimodXL()).
  • Fetch the linker name (ms_searchparams::getVarModName()) of modNum.
  • Find the corresponding ms_umod_modification entry in the embedded unimod_xl file.
  • Wrap the correct neutral loss element as an ms_modification.

The ms_modification object contains the following fields:

  • ms_modification::getTitle() returns the modfile-style name, like "Xlink:DSS (K)".
  • ms_modification::getCode() returns the monolink code.
  • ms_modification::getMonoLinkTitle() returns a modfile-style title containing the monolink code in square brackets, like "Xlink:DSS[W] (K)".
  • ms_modification::getDelta() returns the monolink delta corresponding to the monolink code (linker delta - monolink NL).
  • ms_modification::getPairsWith() returns the code or codes this monolink pairs with, or empty string if not defined.
  • ms_modification::isGeneratedMonoLinker() returns true.
  • ms_modification::isLoopLinker() returns true if the monolink NL is zero; otherwise false.
  • The neutral loss list is empty.
Parameters
modNum | Variable mod index in range 1..32. Usually this comes from the peptide's variable mods string.
monoLink | Index of the neutral loss element. Usually this comes from the peptide's monolink string.
Returns
a pointer, or null if this isn't a linker or the monolink index is invalid.

◆ getMSParserVersion()

std::string getMSParserVersion ( ) const
inherited

Returns the version number of the Mascot Parser library.

This version information is also available:

  • In Windows from the Mascot Parser DLL in the version 'tab'
  • From Perl using perl -Mmsparser -e "print msparser->VERSION()"
  • From Java using:
        JarFile jar = new JarFile(new File(jarName));
    Manifest jarManifest = jar.getManifest();
    Attributes mainAttributes = jarManifest.getMainAttributes();
    String version = (String) mainAttributes.get(Attributes.Name.IMPLEMENTATION_VERSION);
Returns
the version number as a string.

◆ getMultiFileQueryNumber()

int getMultiFileQueryNumber | ( | const int | localQuery,
 |  | const int | fileId
 | ) |  | const
 overridevirtual

Return the multi-file query number from the local query number in an appended file.

See Multiple return values in Perl, Java, Python and C#.

Needs to be called on the 'primary' file object rather than on a ms_mascotresfile_dat or ms_mascotresfile_msr object returned by the getResfile() function.

See Combining multiple results files.

Example: Assume that the primary results file has 10 queries, file 2 has 20 queries and file 3 has 30 queries. This function will return the following:

localQuery | fileId | returned query
6 | 1 | 6
11 | 2 | 21
1 | 3 | 31
See also
getSrcQueryAndFileIdForMultiFile() for the 'inverse' function
Parameters
localQuery | is the query number which should be a value between 1 and getNumQueries() for the file specified by fileId.
fileId | is a 1 based index to the source file.
Returns
the query number that should be used for the primary file, or -1 if an invalid localQuery / fileId parameter combination is passed.

Implements ms_mascotresfilebase.

◆ getNumberOfErrors()

int getNumberOfErrors ( ) const
inherited

Return the number of errors since the last call to clearAllErrors.

This will be zero if there has been no error.

All errors are accumulated into a list in this object, until clearAllErrors() is called.

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

From version 2.5, implemented by calling getErrorHandler()->getNumberOfErrors()

See Error Handling.

See also
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()
Returns
number of errors
Examples
resfile_error.cpp, and resfile_summary.cpp.

◆ getNumberOfResfiles()

int getNumberOfResfiles ( ) const
overridevirtual

Multiple results files can be summed together and treated as 'one'.

See Combining multiple results files.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
the number of results files that have been combined together. If appendResfile() has not been called then this function will return a value of 1.

Implements ms_mascotresfilebase.

◆ getNumEtSeqsSearched()

int getNumEtSeqsSearched ( const int idx = 0 ) const
overridevirtual

Returns the number of sequences searched in the second pass of an integrated error tolerant search.

In dat28 format, the value is obtained from the et_sequences= or et_sequencesX= line in the header section of the file.

In MSR format, the value is obtained from the 'et_sequences' column in the search__databases table.

See also
getNumSeqs(), getNumSeqsAfterTax() getNumResidues()

See Integrated error tolerant search . This function will return -1 for the Original error tolerant search and for searches prior to Mascot 2.4.1

Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is -1.
Returns
the number of sequences that were searched in the second pass of an Integrated error tolerant search

Implements ms_mascotresfilebase.

◆ getNumHits()

int getNumHits ( const section sec = SEC_SUMMARY ) const

Returns the maximum number of hits possible for a protein summary.

If no parameter is passed to this function, information is returned about the standard 'summary' section.

This function returns the number of hits contained in the summary, decoy_summary, et_summary or et_decoy_summary section of the results file. The value returned by ms_proteinsummary::getNumberOfHits will generally be more useful. The number of hits recorded in the summary section sec could be zero even if there are peptide matches in the corresponding peptides section.

If appendResfile() has been called (see Combining multiple results files) then this value will return -1 because the protein summary is not supported for multiple dat files.

Parameters
sec Can be one of ms_mascotresfile_dat::SEC_SUMMARY, ms_mascotresfile_dat::SEC_DECOYSUMMARY, ms_mascotresfile_dat::SEC_ERRTOLSUMMARY, ms_mascotresfile_dat::SEC_ERRTOLDECOYSUMMARY.
Returns
The value of num_hits= in the specified section or -1 if an invalid section is passed of if the object is a multifile results file.

◆ getNumLibraryEntries()

int getNumLibraryEntries ( const int idx = 0 ) const
overridevirtual

Returns the number of entries in the spectral library searched.

In dat28 format, the value is obtained from the library_entriesX= line in the header section of the file. Spectral library support was added in Mascot 2.6.

In MSR format, the value is obtained by summing up the values of the 'entries' column in the search__spectral_libraries table.

Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all library entries searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is not a spectral library, the value returned is -1.
Returns
the number of entries in the spectral library.

Implements ms_mascotresfilebase.

◆ getNumQueries()

int getNumQueries ( const int resfileID = 0 ) const
overridevirtual

Returns the number of queries (peptide masses or ms-ms spectra).

Obtained from the queries= line in the header section of the file (dat28 format) or by getting the maximum value of the 'query_id' column in the query__data table (MSR format).

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
resfileID is the the 1 based id of the results file. When the default value of 0 is used for a single results file, this is number of queries in the file. For Combining multiple results files supplying a value of zero returns the total number of queries in all the results files that have been combined. Use a value of 1 to get the number of queries just in the first results file.
Returns
the number of queries or -1 if resfileID is invalid

Implements ms_mascotresfilebase.

◆ getNumResidues()

double getNumResidues ( const int idx = 0 ) const
overridevirtual

Returns the number of residues in the FASTA file(s) searched.

In dat28 format, the value is obtained from the residues= or residuesX= line in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

In MSR format, the value is obtained from the 'residues' column of the search__databases table.

See also
getNumSeqs(), getNumSeqsAfterTax()
Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns
the number of residues in the FASTA file searched. The value is returned as a double, because this method was introduced with 32-bit versions of Parser. These were unable to return an integer larger than 32 bits.

Implements ms_mascotresfilebase.

◆ getNumSeqs()

int getNumSeqs ( const int idx = 0 ) const
overridevirtual

Returns the number of sequences in the FASTA file(s) searched.

In dat28 format, the value is obtained from the sequences= or sequencesX= in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

In MSR format, the value is obainted from the 'sequences' column in the search__databases table.

See also
getNumSeqsAfterTax(), getNumResidues(), getNumLibraryEntries()
Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns
the number of sequences in the FASTA file(s).

Implements ms_mascotresfilebase.

◆ getNumSeqsAfterTax()

int getNumSeqsAfterTax ( const int idx = 0 ) const
overridevirtual

Returns the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.

In dat28 format, the value is obtained from the sequences_after_tax= or sequences_after_taxX= line in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

In MSR format, the value is obtained from the 'sequences_after_tax' column of the search__databases table.

See also
getNumSeqs(), getNumResidues(), getNumLibraryEntries()
Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns
the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.

Implements ms_mascotresfilebase.

◆ getObservedCharge()

int getObservedCharge | ( | const int | query,
 |  | const bool | decoy = false
 | ) |  | const
 overridevirtual

The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.

In dat28 format, this is obtained from the qexp[query] value. It will come from the SEC_SUMMARY section. If decoy is set to true, it is obtained from the SEC_DECOYSUMMARY section.

In MSR format, the observed charge is obtained from the query__summary table. If decoy is false, the value comes from the standard, target pass of the search; decoy is true, from the standard, decoy pass.

The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.

Possible error values:

  • ms_errs::ERR_MISSINGENTRY
  • ms_errs::ERR_QUERYOUTOFRANGE

If an 'ambiguous' charge state is specified for the whole search or for a specific query, then Mascot just records matches for the highest scoring charge state, and it is this charge state that is returned from this function. For example, the search may have been performed with "2+, 3+ or 4+" and ms_inputquery::getCharge() will return "2+, 3+ or 4+". If the highest scoring peptide match for a particular query was to charge state 4+, then all top 10 matches for that query will be for 4+ and this function will return '4'.

It is therefore not impossible to get different charge values for standard peptide matches from the decoy and target passes of the results files.

In dat28 format, this method can only read charge from the 'summary' and 'decoy_summary' sections. In MSR format, this method can only read charge for standard target or decoy peptide matches. If the peptide match type is error tolerant or crosslink, it's best to use ms_peptide::getCharge(), as these can have different charge state from the standard peptide matches in this query.

The functions getObservedIntensity() and getObservedMass() do not require the decoy parameter as the values will be identical from target and decoy passes.

See also
getObservedMrValue
Parameters
query | is a number in the range 1..getNumQueries()
decoy | should be false for target and true for decoy matches.
Returns
the observed charge for the peptide.

Implements ms_mascotresfilebase.

◆ getObservedIntensity()

double getObservedIntensity ( const int query ) const
overridevirtual

Returns the experimental intensity for the peptide.

In dat28 format, this is obtained from SEC_SUMMARY - qintensity[query]. In MSR format, from the query__summary table.

The observed intensity is not always available and does not need to be supplied by the end user.

Returns 0 if the query cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

Parameters
query is a number in the range 1..getNumQueries()
Returns
0 if the intensity value is not available.

Implements ms_mascotresfilebase.

◆ getObservedMass()

double getObservedMass ( const int query ) const
overridevirtual

Returns the experimental mass value as entered by the user.

In dat28 format, this is obtained from SEC_SUMMARY - qexp[query].

In MSR format, this is obtained from the query__summary table.

Returns 0 if the value cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

Parameters
query query number
Returns
the observed peptide mass.

Implements ms_mascotresfilebase.

◆ getObservedMrValue()

double getObservedMrValue | ( | const int | query,
 |  | const bool | decoy = false
 | ) |  | const
 overridevirtual

Returns the experimental mass value (as a relative mass) as entered by the user.

In dat28 format, this is obtained from the qmass[query] value. It will come from the SEC_SUMMARY section unless decoy is set to true in which case it is obtained from the SEC_DECOYSUMMARY section.

In MSR format, the value is obtained from the query__summary table. If decoy is false, the value comes from the standard, target pass of the search; decoy is true, from the standard, decoy pass.

See also
getObservedCharge

Returns 0 if the value cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

Parameters
query | is a number in the range 1..getNumQueries()
decoy | should only be set to true if ms_searchparams::getDECOY returns true.
Returns
the relative mass of the observed peptide.

Implements ms_mascotresfilebase.

◆ getPeptideSection()

ms_mascotresfile_dat::section getPeptideSection ( const ms_peptide::PSM_TYPE pepType )
static

Return peptide section in the .dat file that contains matches of type pepType.

Parameters
pepType the ms_peptide::PSM_TYPE
Returns
the peptides section in the .dat results file that contains matches whose origin and search pass is specified by pepType.

◆ getPercolatorFileNames()

std::vector< std::string > getPercolatorFileNames ( ) const
inherited

Retrieve the filenames use for percolator input and output.

This function will return an empty vector unless setPercolatorFeatures() has been called beforehand.

The offsets into the return array are defined by ms_mascotresfilebase::PERCOLATOR_FILE_NAMES.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

You can get the list of Percolator file names without creating an object by using matrix_science::ms_mascotresfilebase::staticGetPercolatorFileNames(const char*, const char*, const ms_mascotoptions&, const char *, const std::vector<std::string>&, std::vector<std::string>&, std::vector<bool>&).

Returns
the list of files.

◆ getProgressInfo()

ms_progress_info * getProgressInfo ( bool forPeptideSummary = false ) const
inherited

If a matrix_science::ms_progress_info object is passed to the constructor, this is returned here.

Parameters
forPeptideSummary should be set to true to get the progress object used when creating the ms_peptidesummary, or false to return the object used when creating the ms_mascotresfilebase object.
Returns
a pointer to the progress information. This will be null if no progressMonitor is passed in the constructor

◆ getQmatch()

int64_t getQmatch | ( | const int | query,
 |  | const ms_peptide::PSM_TYPE | pepType
 | ) |  | const
 overridevirtual

Return the number of peptide masses within precursor tolerance of this query.

Return the 'qmatch' value of the query. This is the count of trials for the query, where a trial is a candidate peptide sequence + modifications whose mass is within precursor tolerance.

The count of trials could be different depending on the peptide type. For example, error tolerant peptide matches normally have much higher count of trials than peptides from the first pass of the search.

Note
This method used to be defined in ms_peptidesummary::getQmatch(). It was moved to ms_mascotresfilebase in Parser 3.0.
Parameters
query | Query number, 1..getNumQueries().
pepType | Peptide match type.
Returns
qmatch value for the query and peptide match type.

Implements ms_mascotresfilebase.

◆ getQplughole()

double getQplughole | ( | const int | query,
 |  | const ms_peptide::PSM_TYPE | pepType
 | ) |  | const
 overridevirtual

Return the threshold score for homologous peptide match (MIS only).

Return the 'qplughole' value of the query. This is the critical value for calculating the homology threshold. The value could be different depending on peptide type, as the emprical score distribution within a query can be different between (for example) the first and second pass of an error tolerant search.

Parameters
query | Query number, 1..getNumQueries().
pepType | Peptide match type.
Returns
qplughole value for the query and peptide match type.

Implements ms_mascotresfilebase.

◆ getQuantitation()

bool getQuantitation ( ms_quant_configfile * qfile ) const
overridevirtual

Returns an object that represents the embedded quantitation file as a reduced quantitation.xml file.

The return value indicates that the embedded quantitation file exists in the results file. Call ms_quant_configfile::isValid to determine whether the XML part has been parsed successfully.

For quantitation_2 and later, the contents of the file are validated against a schema by default. For quantitation_1, to explicitly validate against a schema, use ms_quant_configfile::setSchemaFileName() to choose a schema, and then use ms_quant_configfile::validateDocument() to validate.

See Object initialising functions in Perl, Java, Python and C#.

Deprecated:
See getQuantitationMethod() which is generally easier to use.
Parameters
qfile a pointer to quantitation file object. This must be a valid pointer to a valid object, which should normally be created using the default constructor: ms_quant_configfile::ms_quant_configfile
Returns
true if embedded file exists and false if it doesn't

Implements ms_mascotresfilebase.

◆ getQuantitationMethod()

bool getQuantitationMethod ( ms_quant_method * qm ) const
inherited

Return the quantitation method object from the embedded quantitation file.

This method returns true if all of the following apply:

  • the embedded quantitation file exists;
  • a valid schema file location has been set using the XMLschemaDirectory parameter in the constructor or the file exists in the default location;
  • the embedded quantitation file validates against the schema;
  • the quantitation method named in the QUANTITATION parameter exists;
  • the quantitation method can be loaded.

Otherwise the method returns false.

If the QUANTITATION parameter is empty or equals "none", then the method simply returns false. Otherwise, on failure, the method sets the warning ms_errors::ERR_MSP_QUANT_FAILEDLOAD.

Parameters
qm A pointer to quantitation method object. This must be a valid pointer to a valid object, which should normally be created using the default constructor ms_quant_method::ms_quant_method.
Returns
True if the method was loaded; false otherwise.

◆ getQuerySectionValue()

int getQuerySectionValue | ( | const int | query,
 |  | const char * | key,
 |  | char * | str,
 |  | int | maxLen
 | ) |  | const

Return the string value from a query in the results file.

Returns a string from the query section. It is generally easier to use the ms_inputquery class rather than use this lower level function.

Note
You cannot use this method in programming languages other than C++. Use ms_inputquery instead.
Parameters
query | is a number in the range 1..getNumQueries()
key | is case insensitive.
str | is a pointer to a buffer to receive the string.
maxLen | is the length of the buffer (including a null terminator).
Returns
The number of bytes in the returned, null terminated string.

◆ getQuerySectionValueDouble()

double getQuerySectionValueDouble | ( | const int | query,
 |  | const char * | key
 | ) |  | const

Return the floating point value from a query in the results file.

Gets the number from the query section of the results file if it exists.

Parameters
query | is a number in the range 1..getNumQueries()
key | is case insensitive.
Returns
0.0 if the value is not found. It is generally easier to use the ms_inputquery class rather than use this lower level function.

◆ getQuerySectionValueInt()

int getQuerySectionValueInt | ( | const int | query,
 |  | const char * | key
 | ) |  | const

Return the integer value from a query in the results file.

Gets the number from the query section of the results file if it exists.

Parameters
query | is a number in the range 1..getNumQueries()
key | is case insensitive.
Returns
0 if the value is not found. It is generally easier to use the ms_inputquery class rather than use this lower level function.

◆ getQuerySectionValueStr()

std::string getQuerySectionValueStr | ( | const int | query,
 |  | const char * | key
 | ) |  | const

Return the string value from a query in the results file.

Gets the string from the query section of the results file if it exists. It is generally easier to use the ms_inputquery class rather than use this lower level function.

Parameters
query | is a number in the range 1..getNumQueries()
key | is case insensitive.
Returns
an empty string if the value is not present in the file

◆ getReferenceDatabaseNumberOfSL()

int getReferenceDatabaseNumberOfSL ( const int idx ) const
overridevirtual

Return the database number of the reference database of a spectral library.

The reference database of a spectral library is either one of the databases searched – if the reference database was part of the actual search – or a virtual database whose number is above ms_searchparams::getNumberOfDatabases(). In the first case, getReferenceDatabaseNumberOfSL() returns a database number between 1 and ms_searchparams::getNumberOfDatabases(). In the second case, the number is above getNumberOfDatabases().

If idx does not refer to a spectral library, the method returns -1.

Parameters
idx Database number of the spectral library of interest, between 1 and ms_searchparams::getNumberOfDatabases() and whose type is SL (see getDatabaseType())
Returns
Database number of the reference database of the spectral library, or -1 if idx is not a spectral library.

Implements ms_mascotresfilebase.

◆ getRepeatSearchString()

std::string getRepeatSearchString | ( | const int | query,
 |  | const bool | fullQuery = false
 | ) |  | const
 overridevirtual

To perform a repeat search need to build up appropriate string.

If the 'fullQuery' parameter is false (the default) then the format will be:

mr from(observed, charge) query(querynum) etc.

If the 'fullQuery' parameter is true then the format will be:

mr from(observer, charge1, charge2...) ions() etc.

where 'etc' will be one or more of the following (split onto several lines here for readability):

 intensity(value) peptol(value, units) seq() comp()  tag() etag()
 title() instrument() it_mods() index() rtinseconds() rtinseconds[x]()
 scans scans[x]() rawscans rawscans[x]()
  • from contains the observed mass, and the charge found in the original search. If the fullQuery parameter is true, then the charge parameter may be a list of charge states to consider, in which case the mr value is for the first charge.
  • intensity will be returned if an intensity for the peptide was entered.
  • peptol will be returned if there is a specific tolerance override for this query. In dat28 format, it is taken from the PepTol= line in the queryx section of the results file. In MSR format, from the 'pep_tol' column in the query__data table.
  • seq() will be returned if there was a sequence query. It is the exact text that was entered by the user. In dat28 format, it comes from seq1= line in the queryx section of the results file. If there were multiple seq() commands in the original search, then these will be in the results file as seq1=, seq2= etc., and will be returned as seq(...) seq(...). In MSR format, the values are selected from the query__seq table.
  • comp() will be returned if there was a composition query. It is the exact text that was entered by the user. In dat28 format, it comes from comp1= line in the queryx section of the results file. If there were multiple comp() commands in the original search, then these will be in the results file as comp1=, comp2= etc., and will be returned as comp(...) comp(...). In MSR format, the values are selected from the query__comp table.
  • tag() will be returned if there was a tag query. It is the exact text that was entered by the user. In dat28 format, it comes from tag1=t line in the queryx section of the results file. If there were multiple tag() commands in the original search, then these will be in the results file as tag1=, tag2= etc., and will be returned as tag(...) tag(...). In MSR format, the values are selected from the query__seq_tag table.
  • etag() will be returned if there was a etag query. It is the exact text that was entered by the user. In dat28 format, it comes from tag1=e line in the queryx section of the results file. If there were multiple etag() commands in the original search, then these will be in the results file as tag1=, tag2= etc., and will be returned as etag(...) etag(...). In MSR format, the values are selected from the query__seq_tag table.
  • title will be returned if there was a title for the particular MS-MS spectrum. The title is returned as an escaped string.
  • instrument will be returned if there was an instrument defined at the query level in the original search. It is returned as an escaped string.
  • it_mods will be returned if modifications were defined at the query level in the original search. If there was more than modification, these will be returned as a comma separated list.
  • index will be returned if there was an index defined at the query level in the original search which will be the case for all searches in Mascot 2.3 and later. See ms_inputquery::getIndex.
  • scans or scans[x] will be returned if these were defined at the query level in the original search. They will have the format scans(29-34, 43) or scans[0](29-34) scans[1](43).
  • rtinseconds or rtinseconds[x] will be returned if these were defined at the query level in the original search. They will have the format rtinseconds(10-20, 25) or rtinseconds[0](10-20) rtinseconds[1](25).
  • rawscans or rawscans[x] will be returned if these were defined at the query level in the original search. They will have the format, for example, of: rawscans[0](pd0cy1ex1:pd0cy1ex3) rawscans[1](fn2ix1).
  • rawfile will be returned if these were defined at the query level in the original search. They will have the format, for example, of: rawfile(c:/data/rawfile.raw).
  • locus will be returned if these were defined at the query level in the original search. They will have the format, for example, of: locus(2.1.1.24.1).
  • query is only used for MS-MS spectra. To save data transfer with a repeat search, this command is used instead of resubmitting all the MS-MS ions values. When nph-mascot.exe comes to the query(x) command it gets the ions vales from the original .dat file
  • ions will be used to give a list of peaks.

Returns 0 if the value cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

See Automated repeating of searches.

Parameters
query | is a number in the range 1..getNumQueries()
fullQuery | If true, then a complete and self contained sequence query will be returned. See above for details
Returns
repeat search string

Implements ms_mascotresfilebase.

◆ getResfile()

const ms_mascotresfile_dat * getResfile ( int id ) const
overridevirtual

Returns a pointer to the underlying ms_mascotresfile_dat object created by calling appendResfile.

See Combining multiple results files and Maintaining object references: two rules of thumb.

Parameters
id is the the 1 based id of the results file and must be in the range 1..getNumberOfResfiles(). A value of 1 will (not particularly usefully!) return a pointer to the ms_mascotresfilebase that was originally created. A value of 2 will return ms_mascotresfilebase created in the first successful call to appendResfile(), and so on.
Returns
a pointer to the ms_mascotresfilebase object, or 0 if the parameter is invalid.

Implements ms_mascotresfilebase.

◆ getSearchParameter()

std::string getSearchParameter ( const std::string & key ) const
overridevirtual

Return the search parameter the given key.

Get the value associated with the input key in the search parameters. To get all the values, use ms_mascotresfilebase::getSearchParameterKeyValues().

Parameters
[in] key A non-empty string.
Returns
the value associated to the key, or empty if the key does not exist.

Implements ms_mascotresfilebase.

◆ getSearchParametersKeyValues()

void getSearchParametersKeyValues | ( | std::vector< std::string > & | keys,
 |  | std::vector< std::string > & | values
 | ) |  | const
 overridevirtual

Return all the search parameters as key-value pairs.

Get all the search parameters as key-value pairs. Search parameters are more easily accessible through ms_searchparams. This low-level method is useful for creating repeat searches, where the search parameters should just be copied as is.

To get the value of an individual header key, use ms_mascotresfilebase::getSearchParameter().

Parameters
[out] | keys | A vector of non-empty keys.
[out] | values | A vector of strings (some may be empty) in the same order as keys.

Implements ms_mascotresfilebase.

◆ getSectionName()

const char * getSectionName ( const section sec )
static

Return the section name as a string given the enum value.

The section name is intended for printing in error or log messages.

Parameters
sec One of the values in ms_mascotresfile_dat::section.
Returns
Section name as string, or "(unknown)" if the enum cannot be stringified.

◆ getSectionValue()

int getSectionValue | ( | const section | sec,
 |  | const char * | key,
 |  | char * | str,
 |  | int | maxLen
 | ) |  | const

Return the string value from any line in the results file.

Note
You cannot use this method in programming languages other than C++. Use getSectionValueStr() instead.

Function to return a string (into the passed str value) from the results file without using STL. It is generally easier to use getSectionValueStr() which returns a std::string.

Gets the requested string from the results file if it exists. Use the enumeration to choose which section. Returns the number of characters copied into 'str' which will not be greater than maxLen. E.g.

   char s[1024];
   f.getSectionValue(ms_mascotresfile_dat::SEC_PARAMETERS,"MODS",s,1024);
Parameters
sec | can be any section number
key | is case insensitive.
str | is a pointer to a buffer to receive the string
maxLen | is the length of the buffer (including a null terminator)
Returns
The number of bytes in the returned, null terminated string.

◆ getSectionValueDouble()

double getSectionValueDouble | ( | const section | sec,
 |  | const char * | key
 | ) |  | const

Return the floating point value from any line in the results file.

Parameters
sec | can be any section number
key | is case insensitive.
Returns
0.0 if the value is not found or is not a number.

◆ getSectionValueInt()

int getSectionValueInt | ( | const section | sec,
 |  | const char * | key
 | ) |  | const

Return the integer value from any line in the results file.

A value of -1 will be returned if there is no corresponding entry in the results file.

A value of zero will be returned if the entry contains a value that isn't a number.

If the correct value is out of the range of representable values, INT_MAX or INT_MIN is returned.

Parameters
sec | can be any section number
key | is case insensitive.
Returns
the value is not found.

◆ getSectionValueStr()

std::string getSectionValueStr | ( | const section | sec,
 |  | const char * | key
 | ) |  | const

Return the string value from any line in the results file.

Gets the requested string from the results file if it exists. Use the enumeration to choose which section. E.g.

    std::string s;
    s = file.getSectionValue(ms_mascotresfile_dat::SEC_PARAMETERS, "MODS");
Parameters
sec | can be any section number
key | is case insensitive.
Returns
an empty string if the value is not present in the file.

◆ getSLDatabaseNumbersOfReference()

std::vector< int > getSLDatabaseNumbersOfReference ( const int idx ) const
overridevirtual

Return the database numbers of the spectral libraries whose reference database is at the given index.

The reference database of a spectral library is either one of the databases searched – if the reference database was part of the actual search – or a virtual database whose number is above ms_searchparams::getNumberOfDatabases(). The same database can be the reference database of multiple spectral libraries.

If idx does not refer to a reference database, the method returns the empty vector.

Parameters
idx Database number of the reference database of interest.
Returns
A vector of database numbers of spectral libraries whose reference database idx is. This vector can be empty.

Implements ms_mascotresfilebase.

◆ getSLExecCommand()

std::string getSLExecCommand ( int idx = 1 ) const
overridevirtual

Returns the library search command line and parameters (sl_exec_command).

The command line for the library search is typically like:

    ../bin/NIST/mspepsearch/MSPepSearch.exe m a P /Z 0.1 /M 0.602993 /LIB [PATH_TO_MSP_FILE] /INP [PATH_TO_MSP_FILE] /OUTTAB [PATH_TO_TSV_FILE] /HITS 10 /MinMF 0 /NumCompared /OutPrecursorMz /OutDeltaPrecursorMz /OutSpecNum

The exact contents depend on the file paths, fragment tolerance and library search options specified in mascot.dat.

In dat28 format, the command string is saved as sl_exec_commandX= line in the header section.

In MSR format, the command string is saved in the search__spectral_libraries table as 'sl_exec_command'.

If idx is outside its range, the method returns the empty string.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the command line for the spectral library search of the given library.

Implements ms_mascotresfilebase.

◆ getSLFragmentTolerance()

double getSLFragmentTolerance ( int idx = 1 ) const
overridevirtual

Returns the effective spectral library fragment tolerance.

When a search is run against a spectral library, the effective fragment tolerance is calculated from the user-configured library fragment tolerance and the tolerance specified in the search parameters. This may be different from ms_searchparams::getITOL() and ms_searchparams::getITOLU().

The tolerance unit can be retrieved with getSLFragmentToleranceUnit().

In dat28 format, in Mascot 2.6.01 and later, the effective tolerance value and unit are saved in the header section of the results file as sl_itolX=. For files created by Mascot 2.6.00, the value is parsed from the sl_exec_commandX= line if present.

In MSR format, the effective tolerance value and unit are saved in the search__spectral_libraries table as 'itol'.

If idx is outside its range, the method returns 0.0.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the effective fragment tolerance.

Implements ms_mascotresfilebase.

◆ getSLFragmentToleranceUnit()

std::string getSLFragmentToleranceUnit ( int idx = 1 ) const
overridevirtual

Returns the unit of the effective spectral library fragment tolerance.

When a search is run against a spectral library, the effective fragment tolerance is calculated from the user-configured library fragment tolerance and the tolerance specified in the search parameters. This may be different from ms_searchparams::getITOL() and ms_searchparams::getITOLU().

The tolerance can be retrieved with getSLFragmentTolerance().

In dat28 format, in Mascot 2.6.01 and later, the effective tolerance value and unit are saved in the header section of the results file as sl_itolX=. For files created by Mascot 2.6.00, the value is parsed from the sl_exec_commandX= line if present.

In MSR format, the effective tolerance value and unit are saved in the search__spectral_libraries table as 'itol_units'.

If idx is outside its range, the method returns 0.0.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the tolerance unit.

Implements ms_mascotresfilebase.

◆ getSrcQueryAndFileIdForMultiFile()

bool getSrcQueryAndFileIdForMultiFile | ( | const int | q,
 |  | int & | gsqNewQuery,
 |  | int & | gsqFileId
 | ) |  | const
 overridevirtual

Return the query number and file ID in the source .dat file.

See Multiple return values in Perl, Java, Python and C#.

Useful for combining multiple results files (see Combining multiple results files) but also returns valid values for a single file.

Example: Assume that the primary results file has 10 queries, file 2 has 20 queries and file 3 has 30 queries. This function will return the following:

q | newQuery | fileId
6 | 6 | 1
21 | 11 | 2
31 | 1 | 3
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
See also
getMultiFileQueryNumber() for the 'inverse' function
Parameters
q | is the query number which should be a value between 1 and getNumQueries().
gsqNewQuery | is used to return the query number in the specified source file.
gsqFileId | is a 1 based index to the source file.
Returns
true if the query is in the range 1..getNumQueries().

Implements ms_mascotresfilebase.

◆ getSummarySection()

ms_mascotresfile_dat::section getSummarySection ( const ms_peptide::PSM_TYPE pepType )
static

Return the summary section in the .dat file that contains matches of type pepType.

Parameters
pepType the ms_peptide::PSM_TYPE
Returns
the summary section in the .dat results file that contains matches whose origin and search pass is specified by pepType.

◆ getTaxonomy()

bool getTaxonomy ( ms_taxonomyfile * tfile ) const
overridevirtual

Returns an object that represents the embedded taxonomy file as a reduced taxonomy file.

The return value only indicates that the embedded file exists. If you want to find out whether the content has been parsed successfully, call the methods of matrix_science::ms_taxonomyfile.

See Object initialising functions in Perl, Java, Python and C#.

Parameters
tfile a pointer to taxonomy file object that will accept the content from the embedded taxonomy file.
Returns
true if the embedded taxonomy file was read and parsed.

Implements ms_mascotresfilebase.

◆ getUnimod()

bool getUnimod | ( | ms_umod_configfile * | ufile,
 |  | bool | useSchemaFromResfile = false
 | ) |  | const
 overridevirtual

Returns an object that represents the embedded unimod file as a reduced unimod_2.xml file.

The return value only indicates that the embedded Unimod XML exists in the results file. If you want to find out whether the XML part has been parsed successfully, call ms_umod_configfile::isValid

See Object initialising functions in Perl, Java, Python and C#.

Parameters
ufile | a pointer to unimod file object that will accept the XML content.
useSchemaFromResfile | determines where the location of the XML schema is defined. If 'true', then the schema location should have been defined by specifying XMLschemaDirectory in the constructor. If 'false', then ms_umod_configfile::setSchemaFileName must have been called on ufile before calling this function. This parameter was added in Parser 2.5, and the default value is false to ensure that it is backward compatible with previous versions.
Returns
true if embedded file exists and false if it doesn't.

Implements ms_mascotresfilebase.

◆ getUnimodXL()

bool getUnimodXL | ( | ms_umod_configfile * | ufile,
 |  | bool | useSchemaFromResfile = false
 | ) |  | const
 overridevirtual

Returns an object that represents the embedded unimod_xl file as a reduced unimod_xl.xml file.

The return value only indicates that the embedded Unimod crosslinking file exists in the results file. If you want to find out whether the XML part has been parsed successfully, call ms_umod_configfile::isValid

See Object initialising functions in Perl, Java, Python and C#.

Parameters
ufile | a pointer to unimod file object that will accept the XML content.
useSchemaFromResfile | determines where the location of the XML schema is defined. If 'true', then the schema location should have been defined by specifying XMLschemaDirectory in the constructor. If 'false', then ms_umod_configfile::setSchemaFileName must have been called on ufile before calling this function. getUnimodXL uses the same schema as ms_mascotresfilebase::getUnimod.
Returns
true if embedded file exists and false if it doesn't.

Implements ms_mascotresfilebase.

◆ getUniqueTaskID()

std::string getUniqueTaskID ( ) const
overridevirtual

Returns the unique task ID used by Mascot Daemon.

Although this value is a number, it is a 64 bit integer. Some languages on some platforms cannot deal with 64 bit integers properly, so the value is returned as a string. For searches with no taskid, an empty string is returned.

Returns
unique task id as a string

Implements ms_mascotresfilebase.

◆ getXMLschemaFilePath()

std::string getXMLschemaFilePath ( XML_SCHEMA XMLschema ) const
inherited

Gets the XML schema to be used by functions using quantitation or unimod.

See also
setXMLschemaFilePath
Parameters
XMLschema The XML_SCHEMA enumeration value of the required xml schema file.
Returns
The requested xml schema value or an empty string if it has not been set.

◆ hasEnzyme()

bool hasEnzyme ( ) const
overridevirtual

Return true if the results file contains information about the enzyme used.

Check whether the results file contains enzyme information as an embedded 'enzymes' file.

Returns
true if the file contains enzyme information. Always true for results from Mascot Server 2.2 and later.

Implements ms_mascotresfilebase.

◆ hasQuantitation()

bool hasQuantitation ( ) const
overridevirtual

Return true if the results file contains quantitation data.

Check whether the results file contains an embedded quantitation method.

Returns
true if the file has an embedded quantitation method.

Implements ms_mascotresfilebase.

◆ hasRT()

bool hasRT ( ) const
overridevirtual

Return true if the results file contains retention time data.

Check whether the first query has retention time stored in the RTINSECONDS field. If it does, return true. The implicit assumption is that all the other queries also have (or don't have) RTINSECONDS if the first query has (or doesn't have).

Returns
true if the file contains retention time data.

Implements ms_mascotresfilebase.

◆ isDatabaseTypeAvailable()

bool isDatabaseTypeAvailable ( ) const
overridevirtual

Check whether database types are available.

In dat28 format, Mascot 2.6 and later save the type of the database(s) in the results file, as db_typeX= lines in the header section. If the types are not available, the database or databases searched could be AA or NA.

In MSR format, introduced in Mascot Server 3.0, the 'db_type' column is always present in the search__databases table.

Returns
Whether the db_typeX= lines exist or not in the dat28 results file. Always true in MSR format. false.

Implements ms_mascotresfilebase.

◆ isErrorTolerant()

bool isErrorTolerant ( ) const
overridevirtual

Returns true if the search was an error tolerant search.

In dat28 format, obtained from the ERRORTOLERANT value in the parameters section. In MSR format, obtained from the ERRORTOLERANT value in the search__parameters table.

In Mascot versions 1.8 and later, an error tolerant search can be run as a repeat search. In this case, one or more ACCESSIONs (which may be retrieved using ms_searchparams::getACCESSION ) must have been specified, and the results file will just contain the error tolerant search results. In Mascot 2.2 and later, a single search can be performed which contains both the standard search results and the error tolerant search results of automatically selected proteins. In this case, ms_searchparams::getACCESSION will return an empty string.

See Error tolerant searches.

See also
https://www.matrixscience.com/help/error_tolerant_help.html
Returns
true is the result file is from an error tolerant search, false otherwise

Implements ms_mascotresfilebase.

◆ isMSMS()

bool isMSMS ( ) const
overridevirtual

Returns true if the search was an MSMS search (SEARCH=MIS).

Since all types of search may be entered as a sequence query, it may be more useful to use the anyMSMS() member.

Returns
true if SEARCH=MIS in the parameters section or search__parameters table of the file.

Implements ms_mascotresfilebase.

◆ isPMF()

bool isPMF ( ) const
overridevirtual

Returns true if the search was a PMF search (SEARCH=PMF).

Since all types of search may be entered as a sequence query, it may be more useful to use the anyPMF() member.

Returns
true if SEARCH=PMF in the parameters section or search__parameters table of the file.

Implements ms_mascotresfilebase.

◆ isSQ()

bool isSQ ( ) const
overridevirtual

Returns true if the search was a sequence query search (SEARCH=SQ).

Since all types of search may be entered as a sequence query, it may be more useful to use the anySQ() member.

Returns
true if SEARCH=SQ in the parameters section or search__parameters table of the file.

Implements ms_mascotresfilebase.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ outputKeepAlive()

bool outputKeepAlive ( ) const
inherited

Outputs the "keep-alive" string during time-consuming operations.

For HTML reports with large result files it is sometimes necessary to output HTML comments to keep the connection alive. This can be done by specifying the interval at which the text is output (keepAliveInterval) and the text that should be output (keepAliveText) as parameters to the ms_mascotresfilebase::ms_mascotresfilebase() constructor.

If the value of keepAliveInterval passed to ms_mascotresfilebase::ms_mascotresfilebase is not 0, then the text specfied by keepAliveText will be output approximately every keepAliveInterval seconds. A 'd' in the keepAliveText will be replaced by the number of seconds since the process started.

This functionality is implemented by calling this function 'often', rather than by using a separate thread. This means that the times between calls will not be accurate. A computationally intensive application that uses Mascot Parser can also call this function as required.

From version 2.3 onwards, the keepAliveText can contain tags that allow different text to be output for different lengthy tasks. The tags are:

  • ci= - output when creating a cache file.
  • rf= - output when reading the .dat file.
  • ap= - output when assigning peptides to proteins.
  • gp= - output when grouping proteins.
  • ul= - output when calling ms_peptidesummary::createUnassignedList()
  • qu= - output when calculating quantitation intensities for reporter or multiplex protocols.
  • cc= - output when creating a cache file as part of calling ms_peptidesummary::ms_peptidesummary
  • fd= - output when calling ms_mascotresults::getThresholdForFDRAboveIdentity or ms_mascotresults::getThresholdForFDRAboveHomology.

The text can also include the following tags which are substituted by values:

  • %d - The time elapsed since the initial call to ms-mascotresfile.
  • %p - The percentage complete for the current task.
  • %h - The hit number.
  • %q - The query number.
  • %a - The accession string for the current protein being processed.
  • %f - The filename of the .dat file being processed. May be useful for the ci= value with Combining multiple results files

The following table indicates which values are available for which tasks:

 | ci= | rf= | ap= | gp= | ul= | cc= | fd=
%d | X | X | X | X | X | X | X
%p | X | X | X | X | X | X | X
%h |  |  | X | X |  | X |
%q |  |  | X | X | X | X |
%a |  |  | X | X |  | X |
%f | X | X | X | X | X | X |

The %a and %h values for cc= are not output for the second half of caching.

A 'complete' example string might be: ' ul=Creating unassigned list (%p% complete)\n qu=Calculating quantitation component intensities (%p% complete)\ ci=Creating cache file (%p% complete)\n rf=Reading results file (%p% complete)\n ap=Assigning peptides to proteins (%p% complete) hit=%h, time=%d\n gp=Found protein group: %a, hit=%h, %p% complete, %d seconds\n cc=Caching results (%p% complete)\n fd=Calculating false discovery rate (%p% complete)\n '

Any text before the first tag will be used as a default for cases where text isn't supplied for a particular task. For example:

Processing: %p% complete gp=Grouping %a

would output the text:

Processing 23% complete

for all tasks except the protein grouping which would output:

Grouping gi|12345

Returns
true if the work is complete, false otherwise

◆ params()

ms_searchparams & params ( ) const
inlineinherited

Returns a reference to the search parameters class.

For C# only, params is a keyword, so this function is renamed to _params.

Returns
reference to the ms_searchparams object

◆ resetKeepAlive()

void resetKeepAlive | ( | const int | keepAliveInterval,
 |  | const char * | keepAliveText,
 |  | const bool | propagateToAppended = true,
 |  | const bool | resetStartTime = false
 | ) |  |
inherited

Replace the existing keepAlive values with new values.

KeepAlive values are passed when creating the ms_mascotresfilebase object, but it can be useful to change these at a later time.

See outputKeepAlive() for further details.

Parameters
keepAliveInterval | is the new interval in seconds. Specify a value of -1 to keep the old value, or 0 to stop outputting keepAliveText.
keepAliveText | is the text to output every keepAliveInterval seconds while the file is being loaded, or while other tasks are in progress.
propagateToAppended | only has meaning if additional files have been appended by calling appendResfile().
resetStartTime | can be set to true to reset the "%d" value to zero. See outputKeepAlive() for details.

◆ resfileType()

ms_mascotresfilebase::RESFILE_TYPE resfileType ( const std::string & fileName )
staticinherited

Return the results format of the file provided as an argument.

This method tries to open the file and 'sniff' the first few bytes. If those bytes are the SQLite database header, then this is a Mascot Search Results (MSR) file and the method returns RESFILE_MSR. If the bytes look like a MIME format header, then this is a dat28 (.dat) file and the method returns RESFILE_DAT28. In any other case, the method returns RESFILE_UNKNOWN.

Parameters
fileName relative or absolute path to the file to 'sniff'.
Returns
the file type.

◆ setErrorInfoFromString()

bool setErrorInfoFromString ( const std::string & e )
protectedinherited

For restoring any errors in the .cdb file

Parameters
e is the stored string obtained from calling getErrorInfoAsString
Returns
true if the input string is parsed successfully

◆ setPercolatorFeatures() [1/2]

void setPercolatorFeatures | ( | const char * | percolatorFeatures,
 |  | const char * | additionalFeatures,
 |  | const bool | useRetentionTimes
 | ) |  |
inherited

Set Percolator features before creating an ms_peptidesummary with Percolator scoring (deprecated).

Deprecated:
This function is deprecated and has been replaced with matrix_science::ms_mascotresfilebase::setPercolatorFeatures(const ms_mascotoptions&, const char*, const std::vector<std::string>&).

The names (and contents!) of the Percolator files depend on the features that have been enabled. When running from a report script on Mascot Server, turning on an additional feature in percolatorFeatures will cause Mascot to create a new file, but the old file will still be available if the feature is removed again from percolatorFeatures.

When running outside Mascot Server, the parameters passed to this method must match the parameters used by the report scripts, in order to get the same Percolator file names. If the pip/pop files are from Mascot Server 2.8 or later, please use matrix_science::ms_mascotresfilebase::setPercolatorFeatures(const ms_mascotoptions&, const char*, const std::vector<std::string>&) and the same mascot.dat options as were used on the server.

Parameters
percolatorFeatures | is normally retrieved by calling ms_mascotoptions::getPercolatorFeatures().
additionalFeatures | is normally a string passed to ms-createpip.exe. For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. An empty string means nothing is added or removed from ms_mascotoptions::getPercolatorFeatures().
useRetentionTimes | is a flag to indicate whether retention time information is used by percolator.exe. This value is normally retrieved by calling ms_mascotoptions::isPercolatorUseRT().

◆ setPercolatorFeatures() [2/2]

void setPercolatorFeatures | ( | const ms_mascotoptions & | options,
 |  | const char * | additionalFeatures,
 |  | const std::vector< std::string > & | adapterParameters = std::vector<std::string>()
 | ) |  |
inherited

Set Percolator features before creating an ms_peptidesummary with Percolator scoring.

The names (and contents!) of the Percolator files depend on the features that have been enabled. When running from a report script on Mascot Server, turning on an additional feature in PercolatorFeatures will cause Mascot to create a new file, but the old file will still be available if the feature is removed again from PercolatorFeatures.

The method uses the following fields from options:

  • PercolatorFeatures (string)
  • PercolatorUseRT (true/false)
  • PercolatorUseProteins (true/false)
  • PercolatorExeFlags (string)
  • PercolatorTargetRankScoreThreshold (int)
  • PercolatorTargetRankRelativeThreshold (double)

When running outside Mascot Server, the parameters passed to this method must match the parameters used by the report scripts, in order to get the same Percolator file names. If the pip/pop files are from Mascot Server 2.8 or later, please use the same mascot.dat options as were used on the server. Make sure you also use the same adapterParameters.

Parameters
options | contains the options stored in mascot.dat.
additionalFeatures | is normally a string passed to ms-createpip.exe For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default
adapterParameters | is a vector of parameters to ML adapters introduced in Mascot Server 3.0. If the vector is not empty, then the parameters are sorted and hashed into an additional MD5 checksum component of the pip/pop file names.

◆ setXMLschemaFilePath()

bool setXMLschemaFilePath | ( | XML_SCHEMA | XMLschema,
 |  | const char * | path
 | ) |  |
inherited

Sets the XML schema to be used by functions using quantitation or unimod.

It is generally easier to pass a directory as the XMLschemaDirectory parameter to the constructor rather than calling this function for each of the required schema.

Warning
if a relative path for the xsd is specified, then this will be relative to the document and not relative to the current working directory.

Example:

  std::string qs;
  qs  = "http://www.matrixscience.com/xmlns/schema/quantitation_1 ";
  qs += "C:/myfiles/quant_schema_1.xsd ";
  qs += "http://www.matrixscience.com/xmlns/schema/quantitation_2 ";
  qs += "../schema%20files/quantitation_2.xsd";
  setXMLschemaFilePath(XML_SCHEMA_QUANTITATION, qs.c_str());
*

The default values used in cases where this function has not been called and no parameter is passed to the constructor are the values suitable for scripts and programs running on the Mascot Server. These values are:

XML_SCHEMA_QUANTITATION :
    http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd
    http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd

XML_SCHEMA_UNIMOD :
    http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd

XML_SCHEMA_CROSSLINKING :
    http://www.matrixscience.com/xmlns/schema/crosslinking_1 ../html/xmlns/schema/crosslinking_1/crosslinking_1.xsd
Parameters
XMLschema | must be one of the valid XML_SCHEMA values
path | should be a list of pairs "_schema_alias_ SPACE _file_path_", where SPACE is the space character. See XML_SCHEMA for the supported _scheama_alias_ values for each type of schema
Returns
true if the XMLschema value is valid

◆ staticGetPercolatorFileNames() [1/2]

bool staticGetPercolatorFileNames | ( | const char * | szFileName,
 |  | const char * | cacheDirectory,
 |  | const char * | percolatorFeatures,
 |  | const char * | additionalFeatures,
 |  | const bool | useRetentionTimes,
 |  | std::vector< std::string > & | filenames,
 |  | std::vector< bool > & | exists
 | ) |  |
staticinherited

Returns a list of the Percolator input and output files for the specified data file (deprecated).

Deprecated:
This function is deprecated and has been replaced with matrix_science::ms_mascotresfilebase::staticGetPercolatorFileNames(const char*, const char*, const ms_mascotoptions&, const char *, const std::vector<std::string>&, std::vector<std::string>&, std::vector<bool>&).

This static function can be called without creating an ms_mascotresfilebase object, and can be used in advance of creating an object to see if the percolator files will need to be created. If an object has already been created, it is normally easier to call setPercolatorFeatures() and then getPercolatorFileNames().

See Using Percolator scores and Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
szFileName | is the absolute or relative path to the results file.
cacheDirectory | will normally be the value returned from ms_mascotoptions::getCacheDirectory. If it's empty, then the default pattern is used (../data/cache/%Y/%d).
percolatorFeatures | is normally retrieved by calling ms_mascotoptions::getPercolatorFeatures(). The filenames encode the features so that there is no conflict.
additionalFeatures | is normally a string passed to ms-createpip.exe. For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. Any other parameters except -a and -r are ignored. An empty string means nothing is added or removed from percolatorFeatures.
useRetentionTimes | is a flag to indicate whether retention time information is used by percolator.exe.
filenames | returns the list of files. The offsets are defined by ms_mascotresfilebase::PERCOLATOR_FILE_NAMES.
exists | is a boolean vector which will return flags indicating if the Percolator files exists. The values correspond to the values in filenames vector.
Returns
true if all files exist

◆ staticGetPercolatorFileNames() [2/2]

bool staticGetPercolatorFileNames | ( | const char * | szFileName,
 |  | const char * | cacheDirectory,
 |  | const ms_mascotoptions & | options,
 |  | const char * | additionalFeatures,
 |  | const std::vector< std::string > & | adapterParameters,
 |  | std::vector< std::string > & | filenames,
 |  | std::vector< bool > & | exists
 | ) |  |
staticinherited

Returns a list of the Percolator input and output files for the specified data file.

This static function can be called without creating an ms_mascotresfilebase object, and can be used in advance of creating an object to see if the percolator files will need to be created. If an object has already been created, it is normally easier to call setPercolatorFeatures() and then getPercolatorFileNames().

The function uses the following fields from options:

  • PercolatorFeatures (string)
  • PercolatorUseRT (true/false)
  • PercolatorUseProteins (true/false)
  • PercolatorExeFlags (string)
  • PercolatorTargetRankScoreThreshold (int)
  • PercolatorTargetRankRelativeThreshold (double)

Make sure you set PercolatorExeFlags in options based on whether the results file has any queries with a retention time. Otherwise, this method may generate a filename different from setPercolatorFeatures().

    bool anyRT = (whether any query has RTINSECONDS);
    std::string percolatorFlags = options.getPercolatorRtFlags(anyRT, options.isPercolatorUseRT());
    options.setPercolatorExeFlags(percolatorFlags.c_str());

See Using Percolator scores and Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
szFileName | is the absolute or relative path to the results file.
cacheDirectory | will normally be the value returned from ms_mascotoptions::getCacheDirectory. If it's empty, then the default pattern is used (../data/cache/%Y/%d).
options | contains the options stored in mascot.dat It is used to access the relevant options to generate the file names.
additionalFeatures | is normally a string passed to ms-createpip.exe. For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. Any other parameters except -a and -r are ignored. An empty string means nothing is added or removed from ms_mascotoptions::getPercolatorFeatures().
adapterParameters | is a vector of parameters to ML adapters introduced in Mascot Server 3.0. If the vector is not empty, then the parameters are sorted and hashed into an additional MD5 checksum component of the pip/pop file names.
filenames | returns the list of files. The offsets are defined by ms_mascotresfilebase::PERCOLATOR_FILE_NAMES.
exists | is a boolean vector which will return flags indicating if the Percolator files exists. The values correspond to the values in filenames vector.
Returns
true if all files exist

◆ versionGreaterOrEqual()

bool versionGreaterOrEqual | ( | int | major,
 |  | int | minor,
 |  | int | revision
 | ) |  | const
 inherited

Compare the value returned by getMascotVer() with the passed version number.

Utility function to perform easy comparison. For example, to test if a results file could have taxonomy information, use:

if (versionGreaterOrEqual(2, 4, 0)) then ...

Note
Versions 2.3.1 to 2.4.0 of Mascot Parser returned the incorrect value. This was fixed in 2.4.1
Parameters
major | is the major version to be compared with
minor | is the minor version to be compared with
revision | is the minor revision to be compared with
Returns
Will return true if the version of the file is greater than or equal to the passed value

◆ willCreateCache() [1/2]

bool willCreateCache | ( | const char * | szFileName,
 |  | const ms_mascotoptions & | opts,
 |  | const char * | applicationName,
 |  | std::string & | resfileCacheFileName,
 |  | unsigned int & | cacheStatus
 | ) |  |
staticinherited

Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.

This static function can be called without creating an ms_mascotresfile_msr or ms_mascotresfile_dat object. It can be used in advance of creating the object to see if there will be a delay while (re)creating the cache file(s).

The purpose of this method is to get the status of the cache in addition of whether the cache will be created or not.

See Multiple return values in Perl, Java, Python and C#

See Static functions in Perl, Java, Python and C#

Parameters
[in] | szFileName | is the absolute or relative path to the Fxxxxx.dat file
[in] | opts | normally loaded from the mascot.dat file using ms_datfile::getMascotOptions()
[in] | applicationName | is the name of the application or script that is calling this function. The applicationName is searched for in the return value from ms_mascotoptions::getResultsCache and ms_mascotoptions::getResfileCache to determine if the application should be using cache files. If it is not found then the function returns false and sets the cacheStatus to ms_peptidesummary::RESFILE_CACHE_DISABLED_IN_OPTIONS. If null, or an empty string is passed, no check is made.
[out] | resfileCacheFileName | returns the name of the ms_mascotresfilebase cache file if one exists or would be created
[out] | cacheStatus | is the ms_peptidesummary::CACHE_STATUS enumeration which gives more details about why the cache file may or may not be created. Multiple values may be bitwise OR'd toegether.
Returns
true if either of the cache files will be (re-)created because they does not exist or are not complete or not up to date. It will return false if the options specify that the applicationName shouldn't create or use cache files.

◆ willCreateCache() [2/2]

bool willCreateCache | ( | const char * | szFileName,
 |  | const unsigned int | flags,
 |  | const char * | cacheDirectory,
 |  | std::string * | cacheFileName
 | ) |  |
staticinherited

Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.

This static function can be called without creating an ms_mascotresfile_dat or ms_mascotresfile_msr object, and can be used in advance of creating an object to see if there will be a delay while (re)creating a cache file. The function has the same parameters as the ms_mascotresfilebase constructor.

The behaviour depends on the file type (ms_mascotresfilebase::resfileType()). If it is MSR, this method always returns false, because MSR files do not need a resfile cache. If it is dat28 format (.dat), a resfile cache may be needed.

See Static functions in Perl, Java, Python and C#

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | szFileName | - see ms_mascotresfilebase::ms_mascotresfilebase
[in] | flags | - see ms_mascotresfilebase::ms_mascotresfilebase
[in] | cacheDirectory | - see ms_mascotresfilebase::ms_mascotresfilebase
[out] | cacheFileName | - the full path name of the cache file. For languages other than C++, this will be a reference rather than a pointer to a std::string.
Returns
true if the cache file will be (re-)created because it does not exist or is not complete or not up to date. If the RESFILE_USE_CACHE flag has not been specified, it will always return false
The documentation for this class was generated from the following files:
  • ms_mascotresfile_dat.hpp
  • ms_mascotresfile_dat.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresfile_msr Class Reference

  • matrix_science
  • ms_mascotresfile_msr
Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
ms_mascotresfile_msr Class Reference
Mascot results file module

Class for parsing and reading files in MSR format. More...

#include <ms_mascotresfile_msr.hpp>

Inheritance diagram for ms_mascotresfile_msr:
[legend]
Collaboration diagram for ms_mascotresfile_msr:
[legend]

Public Types

enum FLAGS {
RESFILE_NOFLAG = 0x00000000 ,
RESFILE_USE_CACHE = 0x00000001 ,
RESFILE_CACHE_IGNORE_ACC_DUPES = 0x00000002 ,
RESFILE_USE_PARENT_PARAMS = 0x00000004 ,
RESFILE_CACHE_IGNORE_DATE_CHANGE = 0x00000008
}
Flags for opening the results file. More...
enum KA_TASK {
KA_CREATEINDEX_CI = 0 ,
KA_READFILE_RF = 1 ,
KA_ASSIGNPROTEINS_AP = 2 ,
KA_GROUPPROTEINS_GP = 3 ,
KA_UNASSIGNEDLIST_UL = 4 ,
KA_QUANTITATION = 5 ,
KA_CREATECACHE_CC = 6 ,
KA_THRESHFORFDR_FDR = 7 ,
KA_LAST = 8
}
Processing some results files is computationally intensive. These are the tasks that can be performed. More...
enum PERCOLATOR_FILE_NAMES {
PERCOLATOR_INPUT_FILE = 0 ,
PERCOLATOR_OUTPUT_TARGET = 1 ,
PERCOLATOR_OUTPUT_DECOY = 2
}
Offsets into a vector of Percolator filenames. More...
enum RESFILE_TYPE {
RESFILE_DAT28 = 0 ,
RESFILE_MSR = 1 ,
RESFILE_UNKNOWN = 2
}
Supported results file formats. More...
enum XML_SCHEMA {
XML_SCHEMA_QUANTITATION = 0 ,
XML_SCHEMA_UNIMOD = 1 ,
XML_SCHEMA_DIRECTORY = 2 ,
XML_SCHEMA_CROSSLINKING = 3 ,
XML_SCHEMA_LAST = 4
}
The results file contains embedded files in XML format and these need to be validated against a schema. More...

Public Member Functions

ms_mascotresfile_msr (const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0)
Constructor to open a Mascot results file in MSR format.
bool | anyCrosslinkedMatches (const bool isDecoy=false) const override
Returns true if there are any Crosslinked matches.
bool | anyErrorTolerantMatches (const bool isDecoy=false) const override
Returns true if there are any Error Tolerant matches.
bool | anyFastaMatches (const bool isDecoy=false) const override
Returns true if there are any FASTA matches.
bool | anyMSMS () const override
Returns true if any of the queries in the search contain ions data.
bool | anyPMF () const override
Returns true if any of the queries in the search just contain a single peptide mass.
bool | anySpectralLibraryMatches (const bool isDecoy=false) const override
Returns true if there are any Spectral library matches.
bool | anySQ () const override
Returns true if any of the queries in the search contain seq or comp commands.
bool | anyTag () const override
Returns true if any of the queries in the search contain tag or etag commands.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
int | appendResfile (const char *filename, int flags=RESFILE_USE_PARENT_PARAMS, const char *cacheDirectory=0) override
Multiple results files can be summed together and treated as 'one'.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::string | get_ms_mascotresults_params (const ms_mascotoptions &opts, ms_mascotresults_params &params) const
Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.
std::string | get_ms_mascotresults_params (const ms_mascotoptions &opts, unsigned int *gpFlags, double *gpMinProbability, int *gpMaxHitsToReport, double *gpIgnoreIonsScoreBelow, unsigned int *gpMinPepLenInPepSummary, bool *gpUsePeptideSummary, unsigned int *gpFlags2) const
[Deprecated] Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.
std::string | getCacheDirectory (bool processed=true) const override
Returns the directory being used for cache files (if any).
std::string | getCacheFileName () const override
Returns the filename of the cache file.
bool | getCrosslinkingMethod (ms_crosslinking_method *method) const
Return the crosslinking method object from the embedded crosslinking file.
DATABASE_TYPE | getDatabaseType (const int idx) const override
Return database type if available.
int | getDate () const override
Returns the date and time of the search in seconds since midnight January 1st 1970.
ms_mascotoptions::DECOY_ALGORITHM | getDecoyTypeForDB (const int idx=1) const override
Returns the decoy algorithm type for a given database.
bool | getEnzyme (ms_enzymefile *efile, const char *enzymeFileName=0) const override
Returns an object that represents the embedded enzyme file as a reduced enzymes file.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getErrorNumber (const int num=-1) const
Return a specific error number - or ms_errs::ERR_NO_ERROR.
std::string | getErrorString (const int num) const
Return a specific error as a string.
int | getExecTime () const override
Returns the time taken for the search.
std::string | getFastaPath (int idx=1) const override
Returns the path to the FASTA file used.
std::string | getFastaVer (int idx=1) const override
Returns the FASTA file version.
std::string | getFileName (const int id=1) const override
Returns the name of the results file passed into the constructor.
double | getFirstPassThreshold () const override
Return the threshold value for the first pass of an automated error tolerant search.
void | getHeaderKeyValues (std::vector< std::string > &keys, std::vector< std::string > &values) const override
Return all the header key-value pairs.
virtual std::string | getHeaderValue (const std::string &key) const override
Return the header value for the given key.
ms_inputquery | getInputQuery (const int queryNum) const override
Return the ms_inputquery object for the query given as argument.
int | getJobNumber (const int resfileID=1) const override
Return the job number for this file - obtained from the file name.
void | getKeepAlive (KA_TASK &kaTask, int &kaPercentage, std::string &kaAccession, int &kaHit, int &kaQuery, std::string &kaText) const
Return the progress indicators used by the keepAlive functions.
int | getLastError () const
Return the last error number - or ms_erros::ERR_NO_ERROR.
std::string | getLastErrorString () const
Return the last error number - or an empty string.
int | getLibraryMods (std::vector< std::string > &modNames, std::vector< double > &modDeltas) const override
Return all the library mod names and deltas.
std::string | getMascotVer () const override
Returns the version of Mascot used to perform the search.
bool | getMasses (ms_masses *masses) const
Returns an ms_masses object from the mass values in the results file.
void | getMassesKeyValues (std::vector< std::string > &keys, std::vector< double > &values) const override
Return all the residue and modification masses as key-value pairs.
virtual double | getMassValue (const std::string &key) const override
Return the residue or modification mass for the given key.
const ms_modification * | getMonoLinkModification (const int modNum, const int monoLink) const
Returns an ms_modification object that represents a monolink variable modification.
std::string | getMSParserVersion () const
Returns the version number of the Mascot Parser library.
int | getMultiFileQueryNumber (const int localQuery, const int fileId) const override
Return the multi-file query number from the local query number in an appended file.
int | getNumberOfErrors () const
Return the number of errors since the last call to clearAllErrors.
int | getNumberOfResfiles () const override
Multiple results files can be summed together and treated as 'one'.
int | getNumEtSeqsSearched (const int idx=0) const override
Returns the number of sequences searched in the second pass of an integrated error tolerant search.
int | getNumLibraryEntries (const int idx=0) const override
Returns the number of entries in the spectral library searched.
int | getNumQueries (const int resfileID=0) const override
Returns the number of queries (peptide masses or ms-ms spectra).
double | getNumResidues (const int idx=0) const override
Returns the number of residues in the FASTA file(s) searched.
int | getNumSeqs (const int idx=0) const override
Returns the number of sequences in the FASTA file(s) searched.
int | getNumSeqsAfterTax (const int idx=0) const override
Returns the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.
int | getObservedCharge (const int query, const bool decoy=false) const override
The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.
double | getObservedIntensity (const int query) const override
Returns the experimental intensity for the peptide.
double | getObservedMass (const int query) const override
Returns the experimental mass value as entered by the user.
double | getObservedMrValue (const int query, const bool decoy=false) const override
Returns the experimental mass value (as a relative mass) as entered by the user.
std::vector< std::string > | getPercolatorFileNames () const
Retrieve the filenames use for percolator input and output.
ms_progress_info * | getProgressInfo (bool forPeptideSummary=false) const
If a matrix_science::ms_progress_info object is passed to the constructor, this is returned here.
int64_t | getQmatch (const int query, const ms_peptide::PSM_TYPE pepType) const override
Return the number of peptide masses within precursor tolerance of this query.
double | getQplughole (const int query, const ms_peptide::PSM_TYPE pepType) const override
Return the threshold score for homologous peptide match (MIS only).
bool | getQuantitation (ms_quant_configfile *qfile) const override
Returns an object that represents the embedded quantitation file as a reduced quantitation.xml file.
bool | getQuantitationMethod (ms_quant_method *qmethod) const
Return the quantitation method object from the embedded quantitation file.
int | getReferenceDatabaseNumberOfSL (const int idx) const override
Return the database number of the reference database of a spectral library.
std::string | getRepeatSearchString (const int query, const bool fullQuery=false) const override
To perform a repeat search need to build up appropriate string.
const ms_mascotresfile_msr * | getResfile (int id) const override
Returns a pointer to the ms_mascotresfile_msr object created by calling appendResfile.
virtual std::string | getSearchParameter (const std::string &key) const override
Return the search parameter the given key.
void | getSearchParametersKeyValues (std::vector< std::string > &keys, std::vector< std::string > &values) const override
Return all the search parameters as key-value pairs.
std::vector< int > | getSLDatabaseNumbersOfReference (const int idx) const override
Return the database numbers of the spectral libraries whose reference database is at the given index.
virtual std::string | getSLExecCommand (int idx=1) const override
Returns the library search command line and parameters (sl_exec_command).
double | getSLFragmentTolerance (int idx=1) const override
Returns the effective spectral library fragment tolerance.
std::string | getSLFragmentToleranceUnit (int idx=1) const override
Returns the unit of the effective spectral library fragment tolerance.
bool | getSrcQueryAndFileIdForMultiFile (const int q, int &gsqNewQuery, int &gsqFileId) const override
Return the query number and file ID in the source results file.
bool | getTaxonomy (ms_taxonomyfile *tfile) const override
Returns an object that represents the embedded taxonomy file as a reduced taxonomy file.
bool | getUnimod (ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const override
Returns an object that represents the embedded unimod file as a reduced unimod_2.xml file.
bool | getUnimodXL (ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const override
Returns an object that represents the embedded unimod_xl file as a reduced unimod_xl.xml file.
std::string | getUniqueTaskID () const override
Returns the unique task ID used by Mascot Daemon.
std::string | getXMLschemaFilePath (XML_SCHEMA XMLschema) const
Gets the XML schema to be used by functions using quantitation or unimod.
bool | hasEnzyme () const override
Return true if the results file contains information about the enzyme used.
bool | hasQuantitation () const override
Return true if the results file contains quantitation data.
bool | hasRT () const override
Return true if the results file contains retention time data.
bool | isDatabaseTypeAvailable () const override
Check whether database types are available.
bool | isErrorTolerant () const override
Returns true if the search was an error tolerant search.
bool | isMSMS () const override
Returns true if the search was an MSMS search (SEARCH=MIS).
bool | isPMF () const override
Returns true if the search was a PMF search (SEARCH=PMF).
bool | isSQ () const override
Returns true if the search was a sequence query search (SEARCH=SQ).
bool | isValid () const
Call this function to determine if there have been any errors.
bool | outputKeepAlive () const
Outputs the "keep-alive" string during time-consuming operations.
ms_searchparams & | params () const
Returns a reference to the search parameters class.
void | resetKeepAlive (const int keepAliveInterval, const char *keepAliveText, const bool propagateToAppended=true, const bool resetStartTime=false)
Replace the existing keepAlive values with new values.
void | setPercolatorFeatures (const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes)
Set Percolator features before creating an ms_peptidesummary with Percolator scoring (deprecated).
void | setPercolatorFeatures (const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters=std::vector< std::string >())
Set Percolator features before creating an ms_peptidesummary with Percolator scoring.
bool | setXMLschemaFilePath (XML_SCHEMA XMLschema, const char *path)
Sets the XML schema to be used by functions using quantitation or unimod.
bool | versionGreaterOrEqual (int major, int minor, int revision) const
Compare the value returned by getMascotVer() with the passed version number.

Static Public Member Functions

static std::unique_ptr< ms_mascotresfilebase > | createResfile (const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, matrix_science::ms_progress_info *progressMonitor=0)
Return a new ms_mascotresfile_msr or ms_mascotresfile_dat based on the file contents.
static RESFILE_TYPE | resfileType (const std::string &fileName)
Return the results format of the file provided as an argument.
static bool | staticGetPercolatorFileNames (const char *szFileName, const char *cacheDirectory, const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes, std::vector< std::string > &filenames, std::vector< bool > &exists)
Returns a list of the Percolator input and output files for the specified data file (deprecated).
static bool | staticGetPercolatorFileNames (const char *szFileName, const char *cacheDirectory, const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters, std::vector< std::string > &filenames, std::vector< bool > &exists)
Returns a list of the Percolator input and output files for the specified data file.
static bool | willCreateCache (const char *szFileName, const ms_mascotoptions &opts, const char *applicationName, std::string &resfileCacheFileName, unsigned int &cacheStatus)
Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.
static bool | willCreateCache (const char *szFileName, const unsigned int flags, const char *cacheDirectory, std::string *cacheFileName)
Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.

Protected Member Functions

bool | getCrosslinking (ms_crosslinking_configfile *crosslinkingFile) const override
std::string | getErrorInfoAsString (const int num) const
bool | setErrorInfoFromString (const std::string &e)

Detailed Description

Class for parsing and reading files in MSR format.

Until Mascot Server 2.8, there was only one Mascot results file format: plain text MIME format file with .dat extension. Mascot Server 3.0 introduced a new file format, Mascot Search Results (MSR), which is an SQLite database. The old .dat format is frozen and now referred to as dat28.

This class reads files in the MSR format.

Member Enumeration Documentation

◆ FLAGS

enum FLAGS
inherited

Flags for opening the results file.

See Using enumerated values and static const ints in Perl, Java, Python and C# and Caching Mascot Results.

Enumerator
RESFILE_NOFLAG | Dat28 format: Read the whole file into memory. MSR format: Use standard SQLite methods to read the file with low memory overhead.
RESFILE_USE_CACHE | Dat28 format: Create the resfile cache if it doesn't already exist. Use the cache rather than reading the whole .dat file into memory. MSR format: this flag is ignored.
RESFILE_CACHE_IGNORE_ACC_DUPES | When creating a cache file, don't check for duplicate accessions in the SEC_PROTEINS and SEC_DECOYPROTEINS sections which can save some time. Strongly recommend that this flag is never used unless performance becomes a real issue and it is known that ms_mascotoptions::getIgnoreDupeAccession was not defined for the relevant database(s) when they were compressed.
RESFILE_USE_PARENT_PARAMS | For use when Combining multiple results files. The flags and parameters are then inherited from the parent search.
RESFILE_CACHE_IGNORE_DATE_CHANGE | Dat28 format: Opening the resfile cache CDB file should ignore the last modified timestamp on the .dat file. MSR format: this flag is ignored.

◆ KA_TASK

enum KA_TASK
inherited

Processing some results files is computationally intensive. These are the tasks that can be performed.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Used with getKeepAlive(), but also see outputKeepAlive()

Enumerator
KA_CREATEINDEX_CI | Creating a cache file when Using the resfile cache (dat28 format only) in dat28 format.
KA_READFILE_RF | Reading the results file into memory when not using a cache.
KA_ASSIGNPROTEINS_AP | Assigning peptides to proteins to get a list of all possible proteins.
KA_GROUPPROTEINS_GP | Grouping proteins using ms_mascotresults::MSRES_GROUP_PROTEINS or ms_mascotresults::MSRES_CLUSTER_PROTEINS.
KA_UNASSIGNEDLIST_UL | Creating the unassigned list - see ms_mascotresults::createUnassignedList.
KA_QUANTITATION | Calculating quantitation values for reporter and multiplex protocols.
KA_CREATECACHE_CC | Creating a cache file when Using the pepsum cache (MSR and dat28).
KA_THRESHFORFDR_FDR | Calls to ms_mascotresults::getThresholdForFDRAboveHomology can be slow.
KA_LAST | Placeholder that is equal to the number of possible tasks.

◆ PERCOLATOR_FILE_NAMES

enum PERCOLATOR_FILE_NAMES
inherited

Offsets into a vector of Percolator filenames.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Used with getPercolatorFileNames().

Enumerator
PERCOLATOR_INPUT_FILE | This file is created by ms-createpip.exe and read by Percolator.
PERCOLATOR_OUTPUT_TARGET | From std::out of percolator.exe.
PERCOLATOR_OUTPUT_DECOY | Specified using the -B flag when calling Percolator.

◆ RESFILE_TYPE

enum RESFILE_TYPE
inherited

Supported results file formats.

Enumerator
RESFILE_DAT28 | Plain text MIME-format results file produced by Mascot Server 2.0 to 2.8.
RESFILE_MSR | Mascot Search Results (MSR) file introduced in Mascot Server 3.0.
RESFILE_UNKNOWN | Unknown file format.

◆ XML_SCHEMA

enum XML_SCHEMA
inherited

The results file contains embedded files in XML format and these need to be validated against a schema.

This is the list of schema that can be set using setXMLschemaFilePath() and getXMLschemaFilePath()

Enumerator
XML_SCHEMA_QUANTITATION | From the embedded quantation file. Valid aliases are: "http://www.matrixscience.com/xmlns/schema/quantitation_1" and "http://www.matrixscience.com/xmlns/schema/quantitation_2".
XML_SCHEMA_UNIMOD | From the embedded unimod file. Valid alias is: http://www.unimod.org/xmlns/schema/unimod_2.
XML_SCHEMA_DIRECTORY | From the value of XMLschemaDirectory passed into the ms_mascotresfilebase constructor.
XML_SCHEMA_CROSSLINKING | From the embedded crosslinking file. Valid alias is: http://www.matrixscience.com/xmlns/schema/crosslinking_1.
XML_SCHEMA_LAST | Placeholder that is equal to the number of possible schema.

Constructor & Destructor Documentation

◆ ms_mascotresfile_msr()

ms_mascotresfile_msr | ( | const char * | szFileName,
 |  | const int | keepAliveInterval = 0,
 |  | const char * | keepAliveText = "<!-- %d seconds -->\n",
 |  | const unsigned int | flags = RESFILE_NOFLAG,
 |  | const char * | cacheDirectory = "../data/cache/%Y/%m",
 |  | const char * | XMLschemaDirectory = 0,
 |  | ms_progress_info * | progressMonitor = 0
 | ) |  |

Constructor to open a Mascot results file in MSR format.

It is always safe to specify just the ms_mascotresfilebase::RESFILE_NOFLAG flag. The Mascot Search Results (MSR) file is an SQLite database, and reading the file has no memory overhead. The ms_mascotresfilebase::RESFILE_USE_CACHE and ms_mascotresfilebase::RESFILE_CACHE_IGNORE_DATE_CHANGE flags are ignored. These are only useful with ms_mascotresfile_dat.

For HTML reports with large result files it is sometimes necessary to output HTML fragments to keep the connection alive. This can be done by specifying the interval at which the text is output (keepAliveInterval) and the text that should be output (keepAliveText). Although ms_mascotresfile_msr does not create a cache file, the outputKeepAlive mechanism is also used by ms_peptidesummary. See ms_mascotresfilebase::outputKeepAlive() for more details.

The functions isValid() or getLastError() should be called after creating the object to determine if the file was valid and loaded properly.

Possible error values:

  • ms_errs::ERR_MSP_MSR_READING_FILE
  • ms_errs::ERR_RESFILE_FUTURE_VERSION
Parameters
szFileName | is the path to a valid Mascot results file in MSR format
keepAliveInterval | is the interval in seconds between each time the keepAliveText is output to stdout. If a value of zero is specified, then no keep alive text will be output.
keepAliveText | is output every keepAliveInterval seconds while the file is being loaded. See outputKeepAlive() for further details.
flags | are created by bitwise ORing the ms_mascotresfilebase::FLAGS
cacheDirectory | is the location where any cache files are stored. See Specifying cache file directory. If cacheDirectory is null or empty, then ms_peptidesummary will not be able to use caching. Most applications should get this value from ms_mascotoptions::getCacheDirectory().
XMLschemaDirectory | is the location where the xml schema files are located. Some sections of the results file are encoded in XML, and Mascot Parser needs to verify that these are in the correct format using 'xsd' schema files. The required files are supplied with Mascot Parser in the config directory. Either supply the path to that directory, or copy the .xsd files from it to another directory and supply the path to that (only the xsd files from that directory are required). If this parameter is 0 (the default) or empty string (""), then it is assumed that the software is running on the Mascot Server and that the files are located in separate directories under ../html/xmlns/schema as defined in setXMLschemaFilePath(). The constructor does not check that the schema files exist, but subsequent calls to functions such as getUnimod() and getQuantitationMethod() will fail if the schema is not available. The function setXMLschemaFilePath() may be called to override this value passed in the constructor for individual schema files.
progressMonitor | is an optional parameter that can be used to track progress of the creation of this object. It can also be used (from another thread) to cancel the creation of the object by calling ms_progress_info::setBreak. If the passed progressMonitor has a subTask, created by calling ms_progress_info::addSubtask("Creating peptide summary", 100), then that subtask will be used when creating the ms_peptidesummary object. If the subtask doesn't exist, then one is created. Both pointers can be obtained by calling ms_mascotresfilebase::getProgressInfo(). Make sure that the calling function does not delete the object pointed to by this paramater until after the ms_mascotresfile_msr object has been deleted. See: Maintaining object references: two rules of thumb

Member Function Documentation

◆ anyCrosslinkedMatches()

bool anyCrosslinkedMatches ( const bool isDecoy = false ) const
overridevirtual

Returns true if there are any Crosslinked matches.

Returns
true if it has any Crosslinked matches

Implements ms_mascotresfilebase.

◆ anyErrorTolerantMatches()

bool anyErrorTolerantMatches ( const bool isDecoy = false ) const
overridevirtual

Returns true if there are any Error Tolerant matches.

Returns
true if it has any Error Tolerant matches

Implements ms_mascotresfilebase.

◆ anyFastaMatches()

bool anyFastaMatches ( const bool isDecoy = false ) const
overridevirtual

Returns true if there are any FASTA matches.

Returns
true if it has any FASTA matches

Implements ms_mascotresfilebase.

◆ anyMSMS()

bool anyMSMS ( ) const
overridevirtual

Returns true if any of the queries in the search contain ions data.

See also the isMSMS() member, although this function is the preferred one.

Returns
true if any queries contain MS-MS fragment masses

Implements ms_mascotresfilebase.

◆ anyPMF()

bool anyPMF ( ) const
overridevirtual

Returns true if any of the queries in the search just contain a single peptide mass.

See also the isPMF() member, although this function is the preferred one.

Returns
true if any queries contain no MS-MS values

Implements ms_mascotresfilebase.

◆ anySpectralLibraryMatches()

bool anySpectralLibraryMatches ( const bool isDecoy = false ) const
overridevirtual

Returns true if there are any Spectral library matches.

Returns
true if it has any Spectral Library matches

Implements ms_mascotresfilebase.

◆ anySQ()

bool anySQ ( ) const
overridevirtual

Returns true if any of the queries in the search contain seq or comp commands.

See also the isSQ() member, although this function is the preferred one.

Returns
true if any queries contain seq or comp commands

Implements ms_mascotresfilebase.

◆ anyTag()

bool anyTag ( ) const
overridevirtual

Returns true if any of the queries in the search contain tag or etag commands.

See also anySQ(), anyPMF() and anyMSMS()

Returns
true if any queries contain tag or etag commands
true if it has any tag

Implements ms_mascotresfilebase.

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ appendResfile()

int appendResfile | ( | const char * | filename,
 |  | int | flags = RESFILE_USE_PARENT_PARAMS,
 |  | const char * | cacheDirectory = 0
 | ) |  |
overridevirtual

Multiple results files can be summed together and treated as 'one'.

See Combining multiple results files.

Attempts to load the specifed results file and append to the existing file.

Any warning or error messages in the file are also appended to the existing object. If isValid() for the new file returns false, it is not appended and this function returns 0.

A merged report requires the results to be in the same file format. That is, a dat28 (.dat) can be appended to another dat28 file, and an MSR file (.msr) can be appended to another MSR file, but you cannot append an MSR file to a dat28 file or vice versa.

ms_errs::ERR_INVALID_RESFILE, ms_errs::ERR_READINGFILE or ms_errs::ERR_MSP_MSR_READING_FILE may be set if the file formats are not compatible.

ms_errs::ERR_CANNOT_APPEND_RESFILE_NO_FNAMES and ms_errs::ERR_CANNOT_APPEND_RESFILE will be set if the file cannot be appended because of different parameters, such as a different enzyme.

Parameters
filename | is the path to the results file to append.
flags | are one of the ms_mascotresfilebase::FLAGS. If RESFILE_USE_PARENT_PARAMS is specified, then the flags, keepAlive and cache directory are copied from the parent object.
cacheDirectory | is the directory for the cache files if RESFILE_USE_CACHE has been specified. If RESFILE_USE_PARENT_PARAMS is specified and cacheDirectory is null or an empty string, then the cache directory for the parent object is used.
Returns
0 on error, or the id number of the new file. The id can be used with getNumQueries(), getJobNumber(), getFileName() or getResfile(). The return value from the first successful call to this function will be 2.

Implements ms_mascotresfilebase.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ createResfile()

std::unique_ptr< ms_mascotresfilebase > createResfile | ( | const char * | szFileName,
 |  | const int | keepAliveInterval = 0,
 |  | const char * | keepAliveText = "<!-- %d seconds -->\n",
 |  | const unsigned int | flags = matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG,
 |  | const char * | cacheDirectory = "../data/cache/%Y/%m",
 |  | const char * | XMLschemaDirectory = 0,
 |  | matrix_science::ms_progress_info * | progressMonitor = 0
 | ) |  |
staticinherited

Return a new ms_mascotresfile_msr or ms_mascotresfile_dat based on the file contents.

The function 'sniffs' and detects the file contents using ms_mascotresfilebase::resfileType. If it looks like an MSR file, the function returns a new ms_mascotresfile_msr. If it looks like a dat28 (.dat) file, the function returns ms_mascotresfile_dat. Otherwise, a 'nil' object is returned which contains no data and is invalid.

The arguments are the same between the classes, but the details differ a bit. For example, ms_mascotresfile_msr doesn't need caching for fast random access, so it ignores the flags parameter. However, it's always safe to use the same flags regardless of class.

Please see the detailed class documentation:

  • ms_mascotresfile_msr::ms_mascotresfile_msr
  • ms_mascotresfile_dat::ms_mascotresfile_dat
Parameters
szFileName | is the path to a valid Mascot results file
keepAliveInterval | is the interval in seconds between each time the keepAliveText is output to stdout.
keepAliveText | is output every keepAliveInterval seconds while the file is being loaded. See outputKeepAlive() for further details.
flags | are created by bitwise ORing the ms_mascotresfile_dat::FLAGS.
cacheDirectory | is the location where any cache files are stored.
XMLschemaDirectory | is the location where the xml schema files are located.
progressMonitor | is an optional parameter that can be used to track progress of the creation of this object.
Returns
ms_mascotresfile_msr or ms_mascotresfile_dat object, or a 'nil' object if the file type isn't supported.

◆ get_ms_mascotresults_params() [1/2]

std::string get_ms_mascotresults_params | ( | const ms_mascotoptions & | opts,
 |  | ms_mascotresults_params & | resParams
 | ) |  | const
 inherited

Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.

A number of optional flags and parameters can be passed to the ms_proteinsummary or ms_peptide summary constructors. For an application or script running on the Mascot server, the default values for some of these parameters should normally be taken from the mascot.dat file. This function sets the values and flags required to pass to the constructor in the passed ms_mascotresults_params object.

Parameters
[in] | opts | contains the options stored in mascot.dat. Call the ms_datfile construction and then ms_datfile::getMascotOptions() to obtain this value.
[out] | resParams | the values and flags required to pass to the peptide or protein summary object are set to this ms_mascotresults_params object, overwriting any values which were already set.
Returns
If the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch, then the returned script name will be ms_mascotoptions::getResultsPerlScript_2, otherwise it will be ms_mascotoptions::getResultsPerlScript.
Examples
resfile_summary.cpp.

◆ get_ms_mascotresults_params() [2/2]

std::string get_ms_mascotresults_params | ( | const ms_mascotoptions & | opts,
 |  | unsigned int * | gpFlags,
 |  | double * | gpMinProbability,
 |  | int * | gpMaxHitsToReport,
 |  | double * | gpIgnoreIonsScoreBelow,
 |  | unsigned int * | gpMinPepLenInPepSummary,
 |  | bool * | gpUsePeptideSummary,
 |  | unsigned int * | gpFlags2
 | ) |  | const
 inherited

[Deprecated] Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.

Deprecated:
This function is deprecated. All new code should use ms_mascotresfilebase::get_ms_mascotresults_params(const ms_mascotoptions &, ms_mascotresults_params &) instead, as all the parameters are encapsulated in the ms_mascotresults_params class.

A number of optional flags and parameters can be passed to the ms_proteinsummary or ms_peptide summary constructors. For an application or script running on the Mascot server, the default values for some of these parameters should normally be taken from the mascot.dat file. This function returns the values and flags required to pass to the constructor.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | opts | contains the options stored in mascot.dat. Call the ms_datfile construction and then ms_datfile::getMascotOptions() to obtain this value.
[out] | gpFlags | will return the flags that are to be passed as the second parameter to the ms_proteinsummary or ms_peptidesummary object.
[out] | gpMinProbability | is the third parameter to be passed to the ms_proteinsummary or ms_peptidesummary objects. This return value will nomally be equal to the value returned from ms_mascotoptions::getSigThreshold().
[out] | gpMaxHitsToReport | this return value will normally be the one returned by ms_searchparams::getREPORT().
[out] | gpIgnoreIonsScoreBelow | this return value will be the one returned by ms_mascotoptions::getIgnoreIonsScoreBelow().
[out] | gpMinPepLenInPepSummary | this return value will be the one returned by ms_mascotoptions::getMinPepLenInPepSummary.
[out] | gpUsePeptideSummary | will be false is the file doesn't contain any anyMSMS (as returned by the anyMSMS() function) or any sequence tags (anyTag()). In this case, you should create an ms_proteinsummary. If gpUsePeptideSummary is true, you should create an ms_peptidesummary object.
[out] gpFlags2 is only required for an ms_peptidesummary. If gpUsePeptideSummary is true, gpFlags2 will have the following bits set.
  • ms_peptidesummary::MSPEPSUM_PERCOLATOR if all of the following apply:
    • the number of queries is >= ms_mascotoptions::getPercolatorMinQueries;
    • the number of sequences searched >= ms_mascotoptions::getPercolatorMinSequences;
    • this is a decoy search;
    • ms_mascotoptions::isPercolator() returns true;
  • ms_peptidesummary::MSPEPSUM_USE_CACHE if the script name that the function will return is in the string specified by ms_mascotoptions::getResultsCache().
  • ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH if the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch.
  • ms_peptidesummary::MSPEPSUM_REMOVE_CHIMERIC_DUPES if the results file comes from Mascot 2.5 or later.
Returns
If the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch, then the returned script name will be ms_mascotoptions::getResultsPerlScript_2, otherwise it will be ms_mascotoptions::getResultsPerlScript.

◆ getCacheDirectory()

std::string getCacheDirectory ( bool processed = true ) const
overridevirtual

Returns the directory being used for cache files (if any).

The cacheDirectory supplied to the constructor ms_mascotresfilebase::ms_mascotresfilebase may contain a number of '%' flags which get substituted by Mascot Parser.

This function returns either an absolute directory or a directory relative to the current working directory, depending on what was supplied and the parameter processed.

See Caching Mascot Results and ms_mascotoptions::getCacheDirectory

Parameters
processed if true (the default), then the returned directory is relative to the current directory and will have any '%' flags replaced with the relevant directory. If processed is false, then the directory returned will be identical to the one passed to the constructor.
Returns
The cache directory.

Implements ms_mascotresfilebase.

◆ getCacheFileName()

std::string getCacheFileName ( ) const
overridevirtual

Returns the filename of the cache file.

Files in .dat (dat28) format need a cache file to avoid issues with random access. MSR files accessed with ms_mascotresfile_msr do not need a cache file, so this method always returns the empty string.

Returns
The empty string.

Implements ms_mascotresfilebase.

◆ getCrosslinking()

bool getCrosslinking ( ms_crosslinking_configfile * crosslinkingFile ) const
overrideprotectedvirtual

The return value indicates that the embedded crosslinking method file exists in the results file. Call ms_crosslinking_configfile::isValid to determine whether the XML part has been parsed successfully.

The contents of the file are validated against a schema by default.

See Object initialising functions in Perl, Java, Python and C#.

See also
getCrosslinkingMethod() which is generally easier to use.
Parameters
crosslinkingFile a pointer to crosslinking file object. This must be a valid pointer to a valid object, which should normally be created using the default constructor: ms_crosslinking_configfile::ms_crosslinking_configfile
Returns
true if embedded file exists and false if it doesn't

Implements ms_mascotresfilebase.

◆ getCrosslinkingMethod()

bool getCrosslinkingMethod ( ms_crosslinking_method * method ) const
inherited

Return the crosslinking method object from the embedded crosslinking file.

This method returns true if all of the following apply:

  • the embedded crosslinking file exists;
  • a valid schema file location has been set using the XMLschemaDirectory parameter in the constructor or the file exists in the default location;
  • the embedded crosslinking file validates against the schema;
  • the crosslinking method named in the CROSSLINKING parameter exists;
  • the crosslinking method can be loaded.

Otherwise the method returns false.

If the CROSSLINKING parameter is empty or equals "none", then the method simply returns false. Otherwise, on failure, the method sets the warning ms_errors::ERR_MSP_CROSSLINKING_FAILEDLOAD.

Parameters
method A pointer to crosslinking method object. This must be a valid pointer to a valid object, which should normally be created using the default constructor ms_quant_method::ms_quant_method.
Returns
True if the method was loaded; false otherwise.

◆ getDatabaseType()

DATABASE_TYPE getDatabaseType ( const int idx ) const
overridevirtual

Return database type if available.

In dat28 format, Mascot 2.6 and later save the type of the searched database(s) in the results file, as db_typeX= lines in the header section. These types are AA (amino acid), NA (nucleic acid) or SL (spectral library).

In MSR format, introduced in Mascot Server 3.0, the 'db_type' column is always present in the search__databases table.

The number of databases is ms_searchparams::getNumberOfDatabases(), so idx should be between 1 and getNumberOfDatabases().

Spectral libraries must have a reference database. If the reference database is not part of the actual search, protein accessions mapped to it have a database number above ms_searchparams::getNumberOfDatabases(). For example, if the search contains one AA database and one spectral library, getNumberOfDatabases() is 2 and the types returned by getDatabaseType() are AA (idx = 1) and SL (idx = 2). The reference database is at index 3 with type SLREF.

To find the number of the reference database of a spectral library, see ms_mascotresfilebase::geReferenceDatabaseNumberOfSL().

Parameters
idx index of the database; must normally be between 1 and ms_searchparams::getNumberOfDatabases(), or a valid database number returned by ms_mascotresfilebase::getReferenceDatabaseNumberOfSL()
Returns
database type if available. If idx is out of range or isDatabaseTypeAvailable() is false, returns AA.

Implements ms_mascotresfilebase.

◆ getDate()

int getDate ( ) const
overridevirtual

Returns the date and time of the search in seconds since midnight January 1st 1970.

In dat28 format, obtained from the date= line in the header section of the file.

In MSR format, obtained from the 'date' row in the search__header table.

Can be converted to day, month, year etc. using gmtime or similar functions.

Returns
the date and time of the search in seconds since midnight January 1st 1970.

Implements ms_mascotresfilebase.

◆ getDecoyTypeForDB()

ms_mascotoptions::DECOY_ALGORITHM getDecoyTypeForDB ( const int idx = 1 ) const
overridevirtual

Returns the decoy algorithm type for a given database.

In dat28 format, the decoy algorithm type is saved as decoy_type= or decoy_typeX= in the header section, depending on Mascot version.

In MSR format, the algorithm type is saved as the 'decoy_type' column in the search__databases table.

If idx = 1, the method returns the value of decoy_type=. If idx > 1, the method returns the corresponding decoy_typeX= line, or if one doesn't exist, falls back on decoy_type=.

If there is no suitable value in the file or idx is outside its range, the method returns ms_mascotoptions::DECOY_ALGORITHM_NONE.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the decoy algorithm type, or ms_mascotoptions::DECOY_ALGORITHM_NONE.

Implements ms_mascotresfilebase.

◆ getEnzyme()

bool getEnzyme | ( | ms_enzymefile * | efile,
 |  | const char * | enzymeFileName = 0
 | ) |  | const
 overridevirtual

Returns an object that represents the embedded enzyme file as a reduced enzymes file.

In dat28 format, for data files created with Mascot 2.2 and later, the full definition of the enzyme used is included in the Mascot results file. For earlier versions of Mascot, just the name is recorded. This function attempts to read the definition from the results file. If the definition is not present in the results file and a path to the enzymes file has been passed, then this function reads the enzymes file and removes all entries from the list in memory apart from the one with the name specified in the results file.

In MSR format, the full definition of the enzyme used in the search is included in the Mascot results file.

To determine whether the content has been parsed successfully call ms_enzymefile::isValid.

See Object initialising functions in Perl, Java, Python and C#.

Parameters
efile | a pointer to enzymes-file object that will accept the content from the embedded file or the extenal enzymes file if necessary. If successful, the enzyme itself can be retrieved by passing an index of zero to ms_enzymefile::getEnzymeByNumber()
enzymeFileName | is only used for results files prior to Mascot 2.2
Returns
True if the embedded file exists in the results file or if the enzyme specified in the results file can be loaded from the external enzymes file.

Implements ms_mascotresfilebase.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getErrorInfoAsString()

std::string getErrorInfoAsString ( const int num ) const
protectedinherited

For saving any errors in the .cdb file

Parameters
num 1..getNumberOfErrors()
Returns
"[Error Number]:[Number of times]:[Error string]"

◆ getErrorNumber()

int getErrorNumber ( const int num = -1 ) const
inherited

Return a specific error number - or ms_errs::ERR_NO_ERROR.

All errors are accumulated into a list in this object, until clearAllErrors() is called.

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

See Error Handling.

See also
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()

In Mascot Parser 2.5 and later, this is implemented by calling: ms_errs::getErrorNumber()

Parameters
num is the error number in the range 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or ERR_NO_ERROR. If an invalid number is passed, ERR_NO_ERROR will be returned (and no error will be added to the list of errors!).
Returns
the error number
Examples
resfile_error.cpp, and resfile_summary.cpp.

◆ getErrorString()

std::string getErrorString ( const int num ) const
inherited

Return a specific error as a string.

All errors are accumulated into a list in this object, until clearAllErrors() is called. To return a particular error, call this function with a number 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or an empty string. If an invalid number is passed an empty string will be returned (and no error will be added to the list of errors!).

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

In Mascot Parser 2.5 and later, this is implemented by calling ms_errs::getErrorString but functionality is identical to previous versions.

See Error Handling.

See also
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()
Parameters
num 1 to number of errors, or -1
Returns
error string for the given number, or the last error for -1, empty string if none
Examples
resfile_error.cpp, and resfile_summary.cpp.

◆ getExecTime()

int getExecTime ( ) const
overridevirtual

Returns the time taken for the search.

In dat28 format, obtained from the exec_time= line in the header section.

In MSR format, obtained from the 'exec_time' row in the search__header table.

This is the 'wall clock' time, not the CPU time.

Returns
execution time in seconds

Implements ms_mascotresfilebase.

◆ getFastaPath()

std::string getFastaPath ( int idx = 1 ) const
overridevirtual

Returns the path to the FASTA file used.

Available in Mascot 2.2 and later.

Mascot 2.6 and later support spectral libraries. Each spectral library must have a reference database into which found peptide sequences are mapped at the end of the search. The "effective" reference database could be one of the protein sequence databases searched, or it could be a separate database used only for lookup purposes. You can find the database number of the reference database with ms_mascotresfilebase::getReferenceDatabaseNumberOfSL(). If this is larger than getNumberOfDatabases(), the FASTA file path is obtained from the library_reference_fastafile line in the results file header.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases() for databases or libraries searched, or an index returned by ms_mascotresfilebase::getReferenceDatabaseNumberOfSL().
Returns
The full path to the database or library file used in the search.

Implements ms_mascotresfilebase.

◆ getFastaVer()

std::string getFastaVer ( int idx = 1 ) const
overridevirtual

Returns the FASTA file version.

Mascot 2.6 and later support spectral libraries. Each spectral library must have a reference database into which found peptide sequences are mapped at the end of the search. The "effective" reference database could be one of the protein sequence databases searched, or it could be a separate database used only for lookup purposes. You can find the database number of the reference database with ms_mascotresfilebase::getReferenceDatabaseNumberOfSL(). If this is larger than getNumberOfDatabases(), the FASTA file version is obtained from the library_reference_release line in the results file header.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases() for databases or libraries searched, or an index returned by ms_mascotresfilebase::getReferenceDatabaseNumberOfSL().
Returns
File name of the database or library searched.

Implements ms_mascotresfilebase.

◆ getFileName()

std::string getFileName ( const int id = 1 ) const
overridevirtual

Returns the name of the results file passed into the constructor.

Parameters
id a 1 based index. Unless appendResfile() has been called, this value must be '1'.
Returns
the file name (or file path) of the results file.

Implements ms_mascotresfilebase.

◆ getFirstPassThreshold()

double getFirstPassThreshold ( ) const
overridevirtual

Return the threshold value for the first pass of an automated error tolerant search.

Return the first pass threshold of an automated error tolerant search. This is the significance threshold used at the end of the first pass to select proteins for the second pass.

In Mascot Server 2.7 and earlier, the first pass threshold was always 0.05.

In Mascot Server 2.8 and later, you can specify a target FDR in the search form. If the search is an error tolerant target-decoy search with target FDR, the first pass threshold can differ from 0.05.

See Score thresholds and score filtering (Mascot Server 2.8 and later).

Returns
First pass threshold, or 0.0 if this is not an integrated error tolerant search.

Implements ms_mascotresfilebase.

◆ getHeaderKeyValues()

void getHeaderKeyValues | ( | std::vector< std::string > & | keys,
 |  | std::vector< std::string > & | values
 | ) |  | const
 overridevirtual

Return all the header key-value pairs.

Get all the key-value pairs of the results header. The header contains data such as: number of queries, exec_time (search duration), database types (AA, NA, SL) and task ID.

To get the value of an individual header key, use ms_mascotresfilebase::getHeaderValue().

Parameters
[out] | keys | A vector of non-empty keys.
[out] | values | A vector of strings (some may be empty) in the same order as keys.

Implements ms_mascotresfilebase.

◆ getHeaderValue()

std::string getHeaderValue ( const std::string & key ) const
overridevirtual

Return the header value for the given key.

Get the value associated with the input key in the results header. To get all the values, use ms_mascotresfilebase::getHeaderKeyValues().

Parameters
[in] key A non-empty string.
Returns
the value associated to the key, or empty if the key does not exist.

Implements ms_mascotresfilebase.

◆ getInputQuery()

ms_inputquery getInputQuery ( const int queryNum ) const
overridevirtual

Return the ms_inputquery object for the query given as argument.

This method call is equivalent to creating an ms_inputquery object with the current results file and queryNum as parameter.

Parameters
queryNum is the query number
Returns
ms_inputquery object

Implements ms_mascotresfilebase.

◆ getJobNumber()

int getJobNumber ( const int resfileID = 1 ) const
overridevirtual

Return the job number for this file - obtained from the file name.

The library can only 'guess' at this since the value is not in the results file. To perform this function, it retrieves the job number from the file name, so be warned about changing file names. The function returns 0 if it cannot determine the job number.

Parameters
resfileID is the the 1 based id of the results file. If multiple files have been merged together with appendResfile(), use the file ID returned by appendResfile() or getSrcFileIdForMultiFile() to access the job number of the appended files.
Returns
the derived job number.

Implements ms_mascotresfilebase.

◆ getKeepAlive()

void getKeepAlive | ( | KA_TASK & | kaTask,
 |  | int & | kaPercentage,
 |  | std::string & | kaAccession,
 |  | int & | kaHit,
 |  | int & | kaQuery,
 |  | std::string & | kaText
 | ) |  | const
 inherited

Return the progress indicators used by the keepAlive functions.

See Multiple return values in Perl, Java, Python and C# although there may be issues with some languages and the kaTask parameter.

It is normally easier for client applications to call ms_mascotresults::getCreateSummaryProgress() or outputKeepAlive() than to call this function.

Parameters
kaTask | is the task currently being performed by Mascot Parser. If Parser is doing nothing, then this will be the last task that was completed and kaPercentage will be 100
kaPercentage | is the percentage (0..100) complete for the current kaTask.
kaAccession | is the current 'accession' being processed. See outputKeepAlive() for details of which tasks set this value
kaHit | is the current hit being processed. See outputKeepAlive() for details of which tasks set this value
kaQuery | is the current 'query' being processed. See outputKeepAlive() for details of which tasks set this value
kaText | is the text that would be output by outputKeepAlive()

◆ getLastError()

int getLastError ( ) const
inherited

Return the last error number - or ms_erros::ERR_NO_ERROR.

Same as calling getErrorNumber() with -1 as a parameter.

Returns
error number
Examples
peptide_list.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the last error number - or an empty string.

Same as calling getErrorString() with -1 as a parameter.

Returns
last error string
Examples
peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, and resfile_params.cpp.

◆ getLibraryMods()

int getLibraryMods | ( | std::vector< std::string > & | modNames,
 |  | std::vector< double > & | modDeltas
 | ) |  | const
 overridevirtual

Return all the library mod names and deltas.

Get a list of all library modifications. If multiple spectral libraries were searched, this is the combined list of modifications.

Parameters
[out] | modNames | Library modification names.
[out] | modDeltas | Library modification deltas.
Returns
the number of modifications, or 0 if there are none.

Implements ms_mascotresfilebase.

◆ getMascotVer()

std::string getMascotVer ( ) const
overridevirtual

Returns the version of Mascot used to perform the search.

In dat28 format, obtained from the version= entry in the header section of the file.

In MSR format, obtained from the 'version' row in the search__header table.

See also
versionGreaterOrEqual
Returns
the version of Mascot used to perform the search.

Implements ms_mascotresfilebase.

◆ getMasses()

bool getMasses ( ms_masses * masses ) const
inherited

Returns an ms_masses object from the mass values in the results file.

For results files from Mascot 2.2 and later, this function simply calls

    if (getUnimod(&umodConfigFile) && umodConfigFile.isValid())
    {
        masses->copyFrom(&umodConfigFile);
    }

For earlier results files in dat28 format, it reads the residue mass values from the masses section of the file. Since this section either contains average or monoisotopic masses (but not both), the resulting ms_masses object will only have one set of masses.

See Object initialising functions in Perl, Java, Python and C#.

Parameters
masses a pointer to a valid masses object that will accept the content from the section.
Returns
true always.

◆ getMassesKeyValues()

void getMassesKeyValues | ( | std::vector< std::string > & | keys,
 |  | std::vector< double > & | values
 | ) |  | const
 overridevirtual

Return all the residue and modification masses as key-value pairs.

Get all the modification and residue masses as key-value pairs. This includes:

  • Residue masses (A, B, C, D, etc.)
  • Terminus masses (N-term, C-term)
  • Element and atomic masses (H, O, electron, etc.)
  • Variable modification deltas (delta1, delta2, etc.)
  • Fixed modification deltas (FixedMod1, FixedMod2, etc.)
  • Fragment neutral loss (NeutralLoss1, NeutralLoss2, etc.)
  • Peptide neutral loss (PepNeutralLoss1, PepNeutralLoss2, etc.)
  • Required peptide neutral loss (ReqPepNeutralLoss1, ReqPepNeutralLoss2, etc.)
  • Ignore masses (Ignore1, Ignore2, etc.)

To get the value of an individual key, use ms_mascotresfilebase::getMassValue().

In general, it is easier to access these values through ms_searchparams.

Parameters
[out] | keys | A vector of non-empty keys.
[out] | values | A vector of doubles in the same order as keys.

Implements ms_mascotresfilebase.

◆ getMassValue()

double getMassValue ( const std::string & key ) const
overridevirtual

Return the residue or modification mass for the given key.

Get the value associated with the input key in the list of masses. To get all the values, use ms_mascotresfilebase::getMassKeyValues().

Parameters
[in] key A non-empty string.
Returns
the value associated to the key, or 0.0 if the key does not exist.

Implements ms_mascotresfilebase.

◆ getMonoLinkModification()

const ms_modification * getMonoLinkModification | ( | const int | modNum,
 |  | const int | monoLink
 | ) |  | const
 inherited

Returns an ms_modification object that represents a monolink variable modification.

The method performs the following steps:

  • Fetch the the embedded unimod_xl file (ms_mascotresfilebase::getUnimodXL()).
  • Fetch the linker name (ms_searchparams::getVarModName()) of modNum.
  • Find the corresponding ms_umod_modification entry in the embedded unimod_xl file.
  • Wrap the correct neutral loss element as an ms_modification.

The ms_modification object contains the following fields:

  • ms_modification::getTitle() returns the modfile-style name, like "Xlink:DSS (K)".
  • ms_modification::getCode() returns the monolink code.
  • ms_modification::getMonoLinkTitle() returns a modfile-style title containing the monolink code in square brackets, like "Xlink:DSS[W] (K)".
  • ms_modification::getDelta() returns the monolink delta corresponding to the monolink code (linker delta - monolink NL).
  • ms_modification::getPairsWith() returns the code or codes this monolink pairs with, or empty string if not defined.
  • ms_modification::isGeneratedMonoLinker() returns true.
  • ms_modification::isLoopLinker() returns true if the monolink NL is zero; otherwise false.
  • The neutral loss list is empty.
Parameters
modNum | Variable mod index in range 1..32. Usually this comes from the peptide's variable mods string.
monoLink | Index of the neutral loss element. Usually this comes from the peptide's monolink string.
Returns
a pointer, or null if this isn't a linker or the monolink index is invalid.

◆ getMSParserVersion()

std::string getMSParserVersion ( ) const
inherited

Returns the version number of the Mascot Parser library.

This version information is also available:

  • In Windows from the Mascot Parser DLL in the version 'tab'
  • From Perl using perl -Mmsparser -e "print msparser->VERSION()"
  • From Java using:
        JarFile jar = new JarFile(new File(jarName));
    Manifest jarManifest = jar.getManifest();
    Attributes mainAttributes = jarManifest.getMainAttributes();
    String version = (String) mainAttributes.get(Attributes.Name.IMPLEMENTATION_VERSION);
Returns
the version number as a string.

◆ getMultiFileQueryNumber()

int getMultiFileQueryNumber | ( | const int | localQuery,
 |  | const int | fileId
 | ) |  | const
 overridevirtual

Return the multi-file query number from the local query number in an appended file.

See Multiple return values in Perl, Java, Python and C#.

Needs to be called on the 'primary' file object rather than on a ms_mascotresfile_dat or ms_mascotresfile_msr object returned by the getResfile() function.

See Combining multiple results files.

Example: Assume that the primary results file has 10 queries, file 2 has 20 queries and file 3 has 30 queries. This function will return the following:

localQuery | fileId | returned query
6 | 1 | 6
11 | 2 | 21
1 | 3 | 31
See also
getSrcQueryAndFileIdForMultiFile() for the 'inverse' function
Parameters
localQuery | is the query number which should be a value between 1 and getNumQueries() for the file specified by fileId.
fileId | is a 1 based index to the source file.
Returns
the query number that should be used for the primary file, or -1 if an invalid localQuery / fileId parameter combination is passed.

Implements ms_mascotresfilebase.

◆ getNumberOfErrors()

int getNumberOfErrors ( ) const
inherited

Return the number of errors since the last call to clearAllErrors.

This will be zero if there has been no error.

All errors are accumulated into a list in this object, until clearAllErrors() is called.

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

From version 2.5, implemented by calling getErrorHandler()->getNumberOfErrors()

See Error Handling.

See also
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()
Returns
number of errors
Examples
resfile_error.cpp, and resfile_summary.cpp.

◆ getNumberOfResfiles()

int getNumberOfResfiles ( ) const
overridevirtual

Multiple results files can be summed together and treated as 'one'.

See Combining multiple results files.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
the number of results files that have been combined together. If appendResfile() has not been called then this function will return a value of 1.

Implements ms_mascotresfilebase.

◆ getNumEtSeqsSearched()

int getNumEtSeqsSearched ( const int idx = 0 ) const
overridevirtual

Returns the number of sequences searched in the second pass of an integrated error tolerant search.

In dat28 format, the value is obtained from the et_sequences= or et_sequencesX= line in the header section of the file.

In MSR format, the value is obtained from the 'et_sequences' column in the search__databases table.

See also
getNumSeqs(), getNumSeqsAfterTax() getNumResidues()

See Integrated error tolerant search . This function will return -1 for the Original error tolerant search and for searches prior to Mascot 2.4.1

Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is -1.
Returns
the number of sequences that were searched in the second pass of an Integrated error tolerant search

Implements ms_mascotresfilebase.

◆ getNumLibraryEntries()

int getNumLibraryEntries ( const int idx = 0 ) const
overridevirtual

Returns the number of entries in the spectral library searched.

In dat28 format, the value is obtained from the library_entriesX= line in the header section of the file. Spectral library support was added in Mascot 2.6.

In MSR format, the value is obtained by summing up the values of the 'entries' column in the search__spectral_libraries table.

Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all library entries searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is not a spectral library, the value returned is -1.
Returns
the number of entries in the spectral library.

Implements ms_mascotresfilebase.

◆ getNumQueries()

int getNumQueries ( const int resfileID = 0 ) const
overridevirtual

Returns the number of queries (peptide masses or ms-ms spectra).

Obtained from the queries= line in the header section of the file (dat28 format) or by getting the maximum value of the 'query_id' column in the query__data table (MSR format).

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
resfileID is the the 1 based id of the results file. When the default value of 0 is used for a single results file, this is number of queries in the file. For Combining multiple results files supplying a value of zero returns the total number of queries in all the results files that have been combined. Use a value of 1 to get the number of queries just in the first results file.
Returns
the number of queries or -1 if resfileID is invalid

Implements ms_mascotresfilebase.

◆ getNumResidues()

double getNumResidues ( const int idx = 0 ) const
overridevirtual

Returns the number of residues in the FASTA file(s) searched.

In dat28 format, the value is obtained from the residues= or residuesX= line in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

In MSR format, the value is obtained from the 'residues' column of the search__databases table.

See also
getNumSeqs(), getNumSeqsAfterTax()
Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns
the number of residues in the FASTA file searched. The value is returned as a double, because this method was introduced with 32-bit versions of Parser. These were unable to return an integer larger than 32 bits.

Implements ms_mascotresfilebase.

◆ getNumSeqs()

int getNumSeqs ( const int idx = 0 ) const
overridevirtual

Returns the number of sequences in the FASTA file(s) searched.

In dat28 format, the value is obtained from the sequences= or sequencesX= in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

In MSR format, the value is obainted from the 'sequences' column in the search__databases table.

See also
getNumSeqsAfterTax(), getNumResidues(), getNumLibraryEntries()
Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns
the number of sequences in the FASTA file(s).

Implements ms_mascotresfilebase.

◆ getNumSeqsAfterTax()

int getNumSeqsAfterTax ( const int idx = 0 ) const
overridevirtual

Returns the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.

In dat28 format, the value is obtained from the sequences_after_tax= or sequences_after_taxX= line in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

In MSR format, the value is obtained from the 'sequences_after_tax' column of the search__databases table.

See also
getNumSeqs(), getNumResidues(), getNumLibraryEntries()
Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns
the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.

Implements ms_mascotresfilebase.

◆ getObservedCharge()

int getObservedCharge | ( | const int | query,
 |  | const bool | decoy = false
 | ) |  | const
 overridevirtual

The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.

In dat28 format, this is obtained from the qexp[query] value. It will come from the SEC_SUMMARY section. If decoy is set to true, it is obtained from the SEC_DECOYSUMMARY section.

In MSR format, the observed charge is obtained from the query__summary table. If decoy is false, the value comes from the standard, target pass of the search; decoy is true, from the standard, decoy pass.

The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.

Possible error values:

  • ms_errs::ERR_MISSINGENTRY
  • ms_errs::ERR_QUERYOUTOFRANGE

If an 'ambiguous' charge state is specified for the whole search or for a specific query, then Mascot just records matches for the highest scoring charge state, and it is this charge state that is returned from this function. For example, the search may have been performed with "2+, 3+ or 4+" and ms_inputquery::getCharge() will return "2+, 3+ or 4+". If the highest scoring peptide match for a particular query was to charge state 4+, then all top 10 matches for that query will be for 4+ and this function will return '4'.

It is therefore not impossible to get different charge values for standard peptide matches from the decoy and target passes of the results files.

In dat28 format, this method can only read charge from the 'summary' and 'decoy_summary' sections. In MSR format, this method can only read charge for standard target or decoy peptide matches. If the peptide match type is error tolerant or crosslink, it's best to use ms_peptide::getCharge(), as these can have different charge state from the standard peptide matches in this query.

The functions getObservedIntensity() and getObservedMass() do not require the decoy parameter as the values will be identical from target and decoy passes.

See also
getObservedMrValue
Parameters
query | is a number in the range 1..getNumQueries()
decoy | should be false for target and true for decoy matches.
Returns
the observed charge for the peptide.

Implements ms_mascotresfilebase.

◆ getObservedIntensity()

double getObservedIntensity ( const int query ) const
overridevirtual

Returns the experimental intensity for the peptide.

In dat28 format, this is obtained from SEC_SUMMARY - qintensity[query]. In MSR format, from the query__summary table.

The observed intensity is not always available and does not need to be supplied by the end user.

Returns 0 if the query cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

Parameters
query is a number in the range 1..getNumQueries()
Returns
0 if the intensity value is not available.

Implements ms_mascotresfilebase.

◆ getObservedMass()

double getObservedMass ( const int query ) const
overridevirtual

Returns the experimental mass value as entered by the user.

In dat28 format, this is obtained from SEC_SUMMARY - qexp[query].

In MSR format, this is obtained from the query__summary table.

Returns 0 if the value cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

Parameters
query query number
Returns
the observed peptide mass.

Implements ms_mascotresfilebase.

◆ getObservedMrValue()

double getObservedMrValue | ( | const int | query,
 |  | const bool | decoy = false
 | ) |  | const
 overridevirtual

Returns the experimental mass value (as a relative mass) as entered by the user.

In dat28 format, this is obtained from the qmass[query] value. It will come from the SEC_SUMMARY section unless decoy is set to true in which case it is obtained from the SEC_DECOYSUMMARY section.

In MSR format, the value is obtained from the query__summary table. If decoy is false, the value comes from the standard, target pass of the search; decoy is true, from the standard, decoy pass.

See also
getObservedCharge

Returns 0 if the value cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

Parameters
query | is a number in the range 1..getNumQueries()
decoy | should only be set to true if ms_searchparams::getDECOY returns true.
Returns
the relative mass of the observed peptide.

Implements ms_mascotresfilebase.

◆ getPercolatorFileNames()

std::vector< std::string > getPercolatorFileNames ( ) const
inherited

Retrieve the filenames use for percolator input and output.

This function will return an empty vector unless setPercolatorFeatures() has been called beforehand.

The offsets into the return array are defined by ms_mascotresfilebase::PERCOLATOR_FILE_NAMES.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

You can get the list of Percolator file names without creating an object by using matrix_science::ms_mascotresfilebase::staticGetPercolatorFileNames(const char*, const char*, const ms_mascotoptions&, const char *, const std::vector<std::string>&, std::vector<std::string>&, std::vector<bool>&).

Returns
the list of files.

◆ getProgressInfo()

ms_progress_info * getProgressInfo ( bool forPeptideSummary = false ) const
inherited

If a matrix_science::ms_progress_info object is passed to the constructor, this is returned here.

Parameters
forPeptideSummary should be set to true to get the progress object used when creating the ms_peptidesummary, or false to return the object used when creating the ms_mascotresfilebase object.
Returns
a pointer to the progress information. This will be null if no progressMonitor is passed in the constructor

◆ getQmatch()

int64_t getQmatch | ( | const int | query,
 |  | const ms_peptide::PSM_TYPE | pepType
 | ) |  | const
 overridevirtual

Return the number of peptide masses within precursor tolerance of this query.

Return the 'qmatch' value of the query. This is the count of trials for the query, where a trial is a candidate peptide sequence + modifications whose mass is within precursor tolerance.

The count of trials could be different depending on the peptide type. For example, error tolerant peptide matches normally have much higher count of trials than peptides from the first pass of the search.

Note
This method used to be defined in ms_peptidesummary::getQmatch(). It was moved to ms_mascotresfilebase in Parser 3.0.
Parameters
query | Query number, 1..getNumQueries().
pepType | Peptide match type.
Returns
qmatch value for the query and peptide match type.

Implements ms_mascotresfilebase.

◆ getQplughole()

double getQplughole | ( | const int | query,
 |  | const ms_peptide::PSM_TYPE | pepType
 | ) |  | const
 overridevirtual

Return the threshold score for homologous peptide match (MIS only).

Return the 'qplughole' value of the query. This is the critical value for calculating the homology threshold. The value could be different depending on peptide type, as the emprical score distribution within a query can be different between (for example) the first and second pass of an error tolerant search.

Parameters
query | Query number, 1..getNumQueries().
pepType | Peptide match type.
Returns
qplughole value for the query and peptide match type.

Implements ms_mascotresfilebase.

◆ getQuantitation()

bool getQuantitation ( ms_quant_configfile * qfile ) const
overridevirtual

Returns an object that represents the embedded quantitation file as a reduced quantitation.xml file.

The return value indicates that the embedded quantitation file exists in the results file. Call ms_quant_configfile::isValid to determine whether the XML part has been parsed successfully.

For quantitation_2 and later, the contents of the file are validated against a schema by default. For quantitation_1, to explicitly validate against a schema, use ms_quant_configfile::setSchemaFileName() to choose a schema, and then use ms_quant_configfile::validateDocument() to validate.

See Object initialising functions in Perl, Java, Python and C#.

Deprecated:
See getQuantitationMethod() which is generally easier to use.
Parameters
qfile a pointer to quantitation file object. This must be a valid pointer to a valid object, which should normally be created using the default constructor: ms_quant_configfile::ms_quant_configfile
Returns
true if embedded file exists and false if it doesn't

Implements ms_mascotresfilebase.

◆ getQuantitationMethod()

bool getQuantitationMethod ( ms_quant_method * qm ) const
inherited

Return the quantitation method object from the embedded quantitation file.

This method returns true if all of the following apply:

  • the embedded quantitation file exists;
  • a valid schema file location has been set using the XMLschemaDirectory parameter in the constructor or the file exists in the default location;
  • the embedded quantitation file validates against the schema;
  • the quantitation method named in the QUANTITATION parameter exists;
  • the quantitation method can be loaded.

Otherwise the method returns false.

If the QUANTITATION parameter is empty or equals "none", then the method simply returns false. Otherwise, on failure, the method sets the warning ms_errors::ERR_MSP_QUANT_FAILEDLOAD.

Parameters
qm A pointer to quantitation method object. This must be a valid pointer to a valid object, which should normally be created using the default constructor ms_quant_method::ms_quant_method.
Returns
True if the method was loaded; false otherwise.

◆ getReferenceDatabaseNumberOfSL()

int getReferenceDatabaseNumberOfSL ( const int idx ) const
overridevirtual

Return the database number of the reference database of a spectral library.

The reference database of a spectral library is either one of the databases searched – if the reference database was part of the actual search – or a virtual database whose number is above ms_searchparams::getNumberOfDatabases(). In the first case, getReferenceDatabaseNumberOfSL() returns a database number between 1 and ms_searchparams::getNumberOfDatabases(). In the second case, the number is above getNumberOfDatabases().

If idx does not refer to a spectral library, the method returns -1.

Parameters
idx Database number of the spectral library of interest, between 1 and ms_searchparams::getNumberOfDatabases() and whose type is SL (see getDatabaseType())
Returns
Database number of the reference database of the spectral library, or -1 if idx is not a spectral library.

Implements ms_mascotresfilebase.

◆ getRepeatSearchString()

std::string getRepeatSearchString | ( | const int | query,
 |  | const bool | fullQuery = false
 | ) |  | const
 overridevirtual

To perform a repeat search need to build up appropriate string.

If the 'fullQuery' parameter is false (the default) then the format will be:

mr from(observed, charge) query(querynum) etc.

If the 'fullQuery' parameter is true then the format will be:

mr from(observer, charge1, charge2...) ions() etc.

where 'etc' will be one or more of the following (split onto several lines here for readability):

 intensity(value) peptol(value, units) seq() comp()  tag() etag()
 title() instrument() it_mods() index() rtinseconds() rtinseconds[x]()
 scans scans[x]() rawscans rawscans[x]()
  • from contains the observed mass, and the charge found in the original search. If the fullQuery parameter is true, then the charge parameter may be a list of charge states to consider, in which case the mr value is for the first charge.
  • intensity will be returned if an intensity for the peptide was entered.
  • peptol will be returned if there is a specific tolerance override for this query. In dat28 format, it is taken from the PepTol= line in the queryx section of the results file. In MSR format, from the 'pep_tol' column in the query__data table.
  • seq() will be returned if there was a sequence query. It is the exact text that was entered by the user. In dat28 format, it comes from seq1= line in the queryx section of the results file. If there were multiple seq() commands in the original search, then these will be in the results file as seq1=, seq2= etc., and will be returned as seq(...) seq(...). In MSR format, the values are selected from the query__seq table.
  • comp() will be returned if there was a composition query. It is the exact text that was entered by the user. In dat28 format, it comes from comp1= line in the queryx section of the results file. If there were multiple comp() commands in the original search, then these will be in the results file as comp1=, comp2= etc., and will be returned as comp(...) comp(...). In MSR format, the values are selected from the query__comp table.
  • tag() will be returned if there was a tag query. It is the exact text that was entered by the user. In dat28 format, it comes from tag1=t line in the queryx section of the results file. If there were multiple tag() commands in the original search, then these will be in the results file as tag1=, tag2= etc., and will be returned as tag(...) tag(...). In MSR format, the values are selected from the query__seq_tag table.
  • etag() will be returned if there was a etag query. It is the exact text that was entered by the user. In dat28 format, it comes from tag1=e line in the queryx section of the results file. If there were multiple etag() commands in the original search, then these will be in the results file as tag1=, tag2= etc., and will be returned as etag(...) etag(...). In MSR format, the values are selected from the query__seq_tag table.
  • title will be returned if there was a title for the particular MS-MS spectrum. The title is returned as an escaped string.
  • instrument will be returned if there was an instrument defined at the query level in the original search. It is returned as an escaped string.
  • it_mods will be returned if modifications were defined at the query level in the original search. If there was more than modification, these will be returned as a comma separated list.
  • index will be returned if there was an index defined at the query level in the original search which will be the case for all searches in Mascot 2.3 and later. See ms_inputquery::getIndex.
  • scans or scans[x] will be returned if these were defined at the query level in the original search. They will have the format scans(29-34, 43) or scans[0](29-34) scans[1](43).
  • rtinseconds or rtinseconds[x] will be returned if these were defined at the query level in the original search. They will have the format rtinseconds(10-20, 25) or rtinseconds[0](10-20) rtinseconds[1](25).
  • rawscans or rawscans[x] will be returned if these were defined at the query level in the original search. They will have the format, for example, of: rawscans[0](pd0cy1ex1:pd0cy1ex3) rawscans[1](fn2ix1).
  • rawfile will be returned if these were defined at the query level in the original search. They will have the format, for example, of: rawfile(c:/data/rawfile.raw).
  • locus will be returned if these were defined at the query level in the original search. They will have the format, for example, of: locus(2.1.1.24.1).
  • query is only used for MS-MS spectra. To save data transfer with a repeat search, this command is used instead of resubmitting all the MS-MS ions values. When nph-mascot.exe comes to the query(x) command it gets the ions vales from the original .dat file
  • ions will be used to give a list of peaks.

Returns 0 if the value cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

See Automated repeating of searches.

Parameters
query | is a number in the range 1..getNumQueries()
fullQuery | If true, then a complete and self contained sequence query will be returned. See above for details
Returns
repeat search string

Implements ms_mascotresfilebase.

◆ getSearchParameter()

std::string getSearchParameter ( const std::string & key ) const
overridevirtual

Return the search parameter the given key.

Get the value associated with the input key in the search parameters. To get all the values, use ms_mascotresfilebase::getSearchParameterKeyValues().

Parameters
[in] key A non-empty string.
Returns
the value associated to the key, or empty if the key does not exist.

Implements ms_mascotresfilebase.

◆ getSearchParametersKeyValues()

void getSearchParametersKeyValues | ( | std::vector< std::string > & | keys,
 |  | std::vector< std::string > & | values
 | ) |  | const
 overridevirtual

Return all the search parameters as key-value pairs.

Get all the search parameters as key-value pairs. Search parameters are more easily accessible through ms_searchparams. This low-level method is useful for creating repeat searches, where the search parameters should just be copied as is.

To get the value of an individual header key, use ms_mascotresfilebase::getSearchParameter().

Parameters
[out] | keys | A vector of non-empty keys.
[out] | values | A vector of strings (some may be empty) in the same order as keys.

Implements ms_mascotresfilebase.

◆ getSLDatabaseNumbersOfReference()

std::vector< int > getSLDatabaseNumbersOfReference ( const int idx ) const
overridevirtual

Return the database numbers of the spectral libraries whose reference database is at the given index.

The reference database of a spectral library is either one of the databases searched – if the reference database was part of the actual search – or a virtual database whose number is above ms_searchparams::getNumberOfDatabases(). The same database can be the reference database of multiple spectral libraries.

If idx does not refer to a reference database, the method returns the empty vector.

Parameters
idx Database number of the reference database of interest.
Returns
A vector of database numbers of spectral libraries whose reference database idx is. This vector can be empty.

Implements ms_mascotresfilebase.

◆ getSLExecCommand()

std::string getSLExecCommand ( int idx = 1 ) const
overridevirtual

Returns the library search command line and parameters (sl_exec_command).

The command line for the library search is typically like:

    ../bin/NIST/mspepsearch/MSPepSearch.exe m a P /Z 0.1 /M 0.602993 /LIB [PATH_TO_MSP_FILE] /INP [PATH_TO_MSP_FILE] /OUTTAB [PATH_TO_TSV_FILE] /HITS 10 /MinMF 0 /NumCompared /OutPrecursorMz /OutDeltaPrecursorMz /OutSpecNum

The exact contents depend on the file paths, fragment tolerance and library search options specified in mascot.dat.

In dat28 format, the command string is saved as sl_exec_commandX= line in the header section.

In MSR format, the command string is saved in the search__spectral_libraries table as 'sl_exec_command'.

If idx is outside its range, the method returns the empty string.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the command line for the spectral library search of the given library.

Implements ms_mascotresfilebase.

◆ getSLFragmentTolerance()

double getSLFragmentTolerance ( int idx = 1 ) const
overridevirtual

Returns the effective spectral library fragment tolerance.

When a search is run against a spectral library, the effective fragment tolerance is calculated from the user-configured library fragment tolerance and the tolerance specified in the search parameters. This may be different from ms_searchparams::getITOL() and ms_searchparams::getITOLU().

The tolerance unit can be retrieved with getSLFragmentToleranceUnit().

In dat28 format, in Mascot 2.6.01 and later, the effective tolerance value and unit are saved in the header section of the results file as sl_itolX=. For files created by Mascot 2.6.00, the value is parsed from the sl_exec_commandX= line if present.

In MSR format, the effective tolerance value and unit are saved in the search__spectral_libraries table as 'itol'.

If idx is outside its range, the method returns 0.0.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the effective fragment tolerance.

Implements ms_mascotresfilebase.

◆ getSLFragmentToleranceUnit()

std::string getSLFragmentToleranceUnit ( int idx = 1 ) const
overridevirtual

Returns the unit of the effective spectral library fragment tolerance.

When a search is run against a spectral library, the effective fragment tolerance is calculated from the user-configured library fragment tolerance and the tolerance specified in the search parameters. This may be different from ms_searchparams::getITOL() and ms_searchparams::getITOLU().

The tolerance can be retrieved with getSLFragmentTolerance().

In dat28 format, in Mascot 2.6.01 and later, the effective tolerance value and unit are saved in the header section of the results file as sl_itolX=. For files created by Mascot 2.6.00, the value is parsed from the sl_exec_commandX= line if present.

In MSR format, the effective tolerance value and unit are saved in the search__spectral_libraries table as 'itol_units'.

If idx is outside its range, the method returns 0.0.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the tolerance unit.

Implements ms_mascotresfilebase.

◆ getSrcQueryAndFileIdForMultiFile()

bool getSrcQueryAndFileIdForMultiFile | ( | const int | q,
 |  | int & | gsqNewQuery,
 |  | int & | gsqFileId
 | ) |  | const
 overridevirtual

Return the query number and file ID in the source results file.

See Multiple return values in Perl, Java, Python and C#.

Useful for combining multiple results files (see Combining multiple results files) but also returns valid values for a single file.

Example: Assume that the primary results file has 10 queries, file 2 has 20 queries and file 3 has 30 queries. This function will return the following:

q | newQuery | fileId
6 | 6 | 1
21 | 11 | 2
31 | 1 | 3
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
See also
getMultiFileQueryNumber() for the 'inverse' function
Parameters
q | is the query number which should be a value between 1 and getNumQueries().
gsqNewQuery | is used to return the query number in the specified source file.
gsqFileId | is a 1 based index to the source file.
Returns
true if the query is in the range 1..getNumQueries().

Implements ms_mascotresfilebase.

◆ getTaxonomy()

bool getTaxonomy ( ms_taxonomyfile * tfile ) const
overridevirtual

Returns an object that represents the embedded taxonomy file as a reduced taxonomy file.

The return value only indicates that the embedded file exists. If you want to find out whether the content has been parsed successfully, call the methods of matrix_science::ms_taxonomyfile.

See Object initialising functions in Perl, Java, Python and C#.

Parameters
tfile a pointer to taxonomy file object that will accept the content from the embedded taxonomy file.
Returns
true if the embedded taxonomy file was read and parsed.

Implements ms_mascotresfilebase.

◆ getUnimod()

bool getUnimod | ( | ms_umod_configfile * | ufile,
 |  | bool | useSchemaFromResfile = false
 | ) |  | const
 overridevirtual

Returns an object that represents the embedded unimod file as a reduced unimod_2.xml file.

The return value only indicates that the embedded Unimod XML exists in the results file. If you want to find out whether the XML part has been parsed successfully, call ms_umod_configfile::isValid

See Object initialising functions in Perl, Java, Python and C#.

Parameters
ufile | a pointer to unimod file object that will accept the XML content.
useSchemaFromResfile | determines where the location of the XML schema is defined. If 'true', then the schema location should have been defined by specifying XMLschemaDirectory in the constructor. If 'false', then ms_umod_configfile::setSchemaFileName must have been called on ufile before calling this function. This parameter was added in Parser 2.5, and the default value is false to ensure that it is backward compatible with previous versions.
Returns
true if embedded file exists and false if it doesn't.

Implements ms_mascotresfilebase.

◆ getUnimodXL()

bool getUnimodXL | ( | ms_umod_configfile * | ufile,
 |  | bool | useSchemaFromResfile = false
 | ) |  | const
 overridevirtual

Returns an object that represents the embedded unimod_xl file as a reduced unimod_xl.xml file.

The return value only indicates that the embedded Unimod crosslinking file exists in the results file. If you want to find out whether the XML part has been parsed successfully, call ms_umod_configfile::isValid

See Object initialising functions in Perl, Java, Python and C#.

Parameters
ufile | a pointer to unimod file object that will accept the XML content.
useSchemaFromResfile | determines where the location of the XML schema is defined. If 'true', then the schema location should have been defined by specifying XMLschemaDirectory in the constructor. If 'false', then ms_umod_configfile::setSchemaFileName must have been called on ufile before calling this function. getUnimodXL uses the same schema as ms_mascotresfilebase::getUnimod.
Returns
true if embedded file exists and false if it doesn't.

Implements ms_mascotresfilebase.

◆ getUniqueTaskID()

std::string getUniqueTaskID ( ) const
overridevirtual

Returns the unique task ID used by Mascot Daemon.

Although this value is a number, it is a 64 bit integer. Some languages on some platforms cannot deal with 64 bit integers properly, so the value is returned as a string. For searches with no taskid, an empty string is returned.

Returns
unique task id as a string

Implements ms_mascotresfilebase.

◆ getXMLschemaFilePath()

std::string getXMLschemaFilePath ( XML_SCHEMA XMLschema ) const
inherited

Gets the XML schema to be used by functions using quantitation or unimod.

See also
setXMLschemaFilePath
Parameters
XMLschema The XML_SCHEMA enumeration value of the required xml schema file.
Returns
The requested xml schema value or an empty string if it has not been set.

◆ hasEnzyme()

bool hasEnzyme ( ) const
overridevirtual

Return true if the results file contains information about the enzyme used.

Check whether the results file contains enzyme information as an embedded 'enzymes' file.

Returns
true if the file contains enzyme information. Always true for results from Mascot Server 2.2 and later.

Implements ms_mascotresfilebase.

◆ hasQuantitation()

bool hasQuantitation ( ) const
overridevirtual

Return true if the results file contains quantitation data.

Check whether the results file contains an embedded quantitation method.

Returns
true if the file has an embedded quantitation method.

Implements ms_mascotresfilebase.

◆ hasRT()

bool hasRT ( ) const
overridevirtual

Return true if the results file contains retention time data.

Check whether the first query has retention time stored in the RTINSECONDS field. If it does, return true. The implicit assumption is that all the other queries also have (or don't have) RTINSECONDS if the first query has (or doesn't have).

Returns
true if the file contains retention time data.

Implements ms_mascotresfilebase.

◆ isDatabaseTypeAvailable()

bool isDatabaseTypeAvailable ( ) const
overridevirtual

Check whether database types are available.

In dat28 format, Mascot 2.6 and later save the type of the database(s) in the results file, as db_typeX= lines in the header section. If the types are not available, the database or databases searched could be AA or NA.

In MSR format, introduced in Mascot Server 3.0, the 'db_type' column is always present in the search__databases table.

Returns
Whether the db_typeX= lines exist or not in the dat28 results file. Always true in MSR format. false.

Implements ms_mascotresfilebase.

◆ isErrorTolerant()

bool isErrorTolerant ( ) const
overridevirtual

Returns true if the search was an error tolerant search.

In dat28 format, obtained from the ERRORTOLERANT value in the parameters section. In MSR format, obtained from the ERRORTOLERANT value in the search__parameters table.

In Mascot versions 1.8 and later, an error tolerant search can be run as a repeat search. In this case, one or more ACCESSIONs (which may be retrieved using ms_searchparams::getACCESSION ) must have been specified, and the results file will just contain the error tolerant search results. In Mascot 2.2 and later, a single search can be performed which contains both the standard search results and the error tolerant search results of automatically selected proteins. In this case, ms_searchparams::getACCESSION will return an empty string.

See Error tolerant searches.

See also
https://www.matrixscience.com/help/error_tolerant_help.html
Returns
true is the result file is from an error tolerant search, false otherwise

Implements ms_mascotresfilebase.

◆ isMSMS()

bool isMSMS ( ) const
overridevirtual

Returns true if the search was an MSMS search (SEARCH=MIS).

Since all types of search may be entered as a sequence query, it may be more useful to use the anyMSMS() member.

Returns
true if SEARCH=MIS in the parameters section or search__parameters table of the file.

Implements ms_mascotresfilebase.

◆ isPMF()

bool isPMF ( ) const
overridevirtual

Returns true if the search was a PMF search (SEARCH=PMF).

Since all types of search may be entered as a sequence query, it may be more useful to use the anyPMF() member.

Returns
true if SEARCH=PMF in the parameters section or search__parameters table of the file.

Implements ms_mascotresfilebase.

◆ isSQ()

bool isSQ ( ) const
overridevirtual

Returns true if the search was a sequence query search (SEARCH=SQ).

Since all types of search may be entered as a sequence query, it may be more useful to use the anySQ() member.

Returns
true if SEARCH=SQ in the parameters section or search__parameters table of the file.

Implements ms_mascotresfilebase.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ outputKeepAlive()

bool outputKeepAlive ( ) const
inherited

Outputs the "keep-alive" string during time-consuming operations.

For HTML reports with large result files it is sometimes necessary to output HTML comments to keep the connection alive. This can be done by specifying the interval at which the text is output (keepAliveInterval) and the text that should be output (keepAliveText) as parameters to the ms_mascotresfilebase::ms_mascotresfilebase() constructor.

If the value of keepAliveInterval passed to ms_mascotresfilebase::ms_mascotresfilebase is not 0, then the text specfied by keepAliveText will be output approximately every keepAliveInterval seconds. A 'd' in the keepAliveText will be replaced by the number of seconds since the process started.

This functionality is implemented by calling this function 'often', rather than by using a separate thread. This means that the times between calls will not be accurate. A computationally intensive application that uses Mascot Parser can also call this function as required.

From version 2.3 onwards, the keepAliveText can contain tags that allow different text to be output for different lengthy tasks. The tags are:

  • ci= - output when creating a cache file.
  • rf= - output when reading the .dat file.
  • ap= - output when assigning peptides to proteins.
  • gp= - output when grouping proteins.
  • ul= - output when calling ms_peptidesummary::createUnassignedList()
  • qu= - output when calculating quantitation intensities for reporter or multiplex protocols.
  • cc= - output when creating a cache file as part of calling ms_peptidesummary::ms_peptidesummary
  • fd= - output when calling ms_mascotresults::getThresholdForFDRAboveIdentity or ms_mascotresults::getThresholdForFDRAboveHomology.

The text can also include the following tags which are substituted by values:

  • %d - The time elapsed since the initial call to ms-mascotresfile.
  • %p - The percentage complete for the current task.
  • %h - The hit number.
  • %q - The query number.
  • %a - The accession string for the current protein being processed.
  • %f - The filename of the .dat file being processed. May be useful for the ci= value with Combining multiple results files

The following table indicates which values are available for which tasks:

 | ci= | rf= | ap= | gp= | ul= | cc= | fd=
%d | X | X | X | X | X | X | X
%p | X | X | X | X | X | X | X
%h |  |  | X | X |  | X |
%q |  |  | X | X | X | X |
%a |  |  | X | X |  | X |
%f | X | X | X | X | X | X |

The %a and %h values for cc= are not output for the second half of caching.

A 'complete' example string might be: ' ul=Creating unassigned list (%p% complete)\n qu=Calculating quantitation component intensities (%p% complete)\ ci=Creating cache file (%p% complete)\n rf=Reading results file (%p% complete)\n ap=Assigning peptides to proteins (%p% complete) hit=%h, time=%d\n gp=Found protein group: %a, hit=%h, %p% complete, %d seconds\n cc=Caching results (%p% complete)\n fd=Calculating false discovery rate (%p% complete)\n '

Any text before the first tag will be used as a default for cases where text isn't supplied for a particular task. For example:

Processing: %p% complete gp=Grouping %a

would output the text:

Processing 23% complete

for all tasks except the protein grouping which would output:

Grouping gi|12345

Returns
true if the work is complete, false otherwise

◆ params()

ms_searchparams & params ( ) const
inlineinherited

Returns a reference to the search parameters class.

For C# only, params is a keyword, so this function is renamed to _params.

Returns
reference to the ms_searchparams object

◆ resetKeepAlive()

void resetKeepAlive | ( | const int | keepAliveInterval,
 |  | const char * | keepAliveText,
 |  | const bool | propagateToAppended = true,
 |  | const bool | resetStartTime = false
 | ) |  |
inherited

Replace the existing keepAlive values with new values.

KeepAlive values are passed when creating the ms_mascotresfilebase object, but it can be useful to change these at a later time.

See outputKeepAlive() for further details.

Parameters
keepAliveInterval | is the new interval in seconds. Specify a value of -1 to keep the old value, or 0 to stop outputting keepAliveText.
keepAliveText | is the text to output every keepAliveInterval seconds while the file is being loaded, or while other tasks are in progress.
propagateToAppended | only has meaning if additional files have been appended by calling appendResfile().
resetStartTime | can be set to true to reset the "%d" value to zero. See outputKeepAlive() for details.

◆ resfileType()

ms_mascotresfilebase::RESFILE_TYPE resfileType ( const std::string & fileName )
staticinherited

Return the results format of the file provided as an argument.

This method tries to open the file and 'sniff' the first few bytes. If those bytes are the SQLite database header, then this is a Mascot Search Results (MSR) file and the method returns RESFILE_MSR. If the bytes look like a MIME format header, then this is a dat28 (.dat) file and the method returns RESFILE_DAT28. In any other case, the method returns RESFILE_UNKNOWN.

Parameters
fileName relative or absolute path to the file to 'sniff'.
Returns
the file type.

◆ setErrorInfoFromString()

bool setErrorInfoFromString ( const std::string & e )
protectedinherited

For restoring any errors in the .cdb file

Parameters
e is the stored string obtained from calling getErrorInfoAsString
Returns
true if the input string is parsed successfully

◆ setPercolatorFeatures() [1/2]

void setPercolatorFeatures | ( | const char * | percolatorFeatures,
 |  | const char * | additionalFeatures,
 |  | const bool | useRetentionTimes
 | ) |  |
inherited

Set Percolator features before creating an ms_peptidesummary with Percolator scoring (deprecated).

Deprecated:
This function is deprecated and has been replaced with matrix_science::ms_mascotresfilebase::setPercolatorFeatures(const ms_mascotoptions&, const char*, const std::vector<std::string>&).

The names (and contents!) of the Percolator files depend on the features that have been enabled. When running from a report script on Mascot Server, turning on an additional feature in percolatorFeatures will cause Mascot to create a new file, but the old file will still be available if the feature is removed again from percolatorFeatures.

When running outside Mascot Server, the parameters passed to this method must match the parameters used by the report scripts, in order to get the same Percolator file names. If the pip/pop files are from Mascot Server 2.8 or later, please use matrix_science::ms_mascotresfilebase::setPercolatorFeatures(const ms_mascotoptions&, const char*, const std::vector<std::string>&) and the same mascot.dat options as were used on the server.

Parameters
percolatorFeatures | is normally retrieved by calling ms_mascotoptions::getPercolatorFeatures().
additionalFeatures | is normally a string passed to ms-createpip.exe. For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. An empty string means nothing is added or removed from ms_mascotoptions::getPercolatorFeatures().
useRetentionTimes | is a flag to indicate whether retention time information is used by percolator.exe. This value is normally retrieved by calling ms_mascotoptions::isPercolatorUseRT().

◆ setPercolatorFeatures() [2/2]

void setPercolatorFeatures | ( | const ms_mascotoptions & | options,
 |  | const char * | additionalFeatures,
 |  | const std::vector< std::string > & | adapterParameters = std::vector<std::string>()
 | ) |  |
inherited

Set Percolator features before creating an ms_peptidesummary with Percolator scoring.

The names (and contents!) of the Percolator files depend on the features that have been enabled. When running from a report script on Mascot Server, turning on an additional feature in PercolatorFeatures will cause Mascot to create a new file, but the old file will still be available if the feature is removed again from PercolatorFeatures.

The method uses the following fields from options:

  • PercolatorFeatures (string)
  • PercolatorUseRT (true/false)
  • PercolatorUseProteins (true/false)
  • PercolatorExeFlags (string)
  • PercolatorTargetRankScoreThreshold (int)
  • PercolatorTargetRankRelativeThreshold (double)

When running outside Mascot Server, the parameters passed to this method must match the parameters used by the report scripts, in order to get the same Percolator file names. If the pip/pop files are from Mascot Server 2.8 or later, please use the same mascot.dat options as were used on the server. Make sure you also use the same adapterParameters.

Parameters
options | contains the options stored in mascot.dat.
additionalFeatures | is normally a string passed to ms-createpip.exe For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default
adapterParameters | is a vector of parameters to ML adapters introduced in Mascot Server 3.0. If the vector is not empty, then the parameters are sorted and hashed into an additional MD5 checksum component of the pip/pop file names.

◆ setXMLschemaFilePath()

bool setXMLschemaFilePath | ( | XML_SCHEMA | XMLschema,
 |  | const char * | path
 | ) |  |
inherited

Sets the XML schema to be used by functions using quantitation or unimod.

It is generally easier to pass a directory as the XMLschemaDirectory parameter to the constructor rather than calling this function for each of the required schema.

Warning
if a relative path for the xsd is specified, then this will be relative to the document and not relative to the current working directory.

Example:

  std::string qs;
  qs  = "http://www.matrixscience.com/xmlns/schema/quantitation_1 ";
  qs += "C:/myfiles/quant_schema_1.xsd ";
  qs += "http://www.matrixscience.com/xmlns/schema/quantitation_2 ";
  qs += "../schema%20files/quantitation_2.xsd";
  setXMLschemaFilePath(XML_SCHEMA_QUANTITATION, qs.c_str());
*

The default values used in cases where this function has not been called and no parameter is passed to the constructor are the values suitable for scripts and programs running on the Mascot Server. These values are:

XML_SCHEMA_QUANTITATION :
    http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd
    http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd

XML_SCHEMA_UNIMOD :
    http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd

XML_SCHEMA_CROSSLINKING :
    http://www.matrixscience.com/xmlns/schema/crosslinking_1 ../html/xmlns/schema/crosslinking_1/crosslinking_1.xsd
Parameters
XMLschema | must be one of the valid XML_SCHEMA values
path | should be a list of pairs "_schema_alias_ SPACE _file_path_", where SPACE is the space character. See XML_SCHEMA for the supported _scheama_alias_ values for each type of schema
Returns
true if the XMLschema value is valid

◆ staticGetPercolatorFileNames() [1/2]

bool staticGetPercolatorFileNames | ( | const char * | szFileName,
 |  | const char * | cacheDirectory,
 |  | const char * | percolatorFeatures,
 |  | const char * | additionalFeatures,
 |  | const bool | useRetentionTimes,
 |  | std::vector< std::string > & | filenames,
 |  | std::vector< bool > & | exists
 | ) |  |
staticinherited

Returns a list of the Percolator input and output files for the specified data file (deprecated).

Deprecated:
This function is deprecated and has been replaced with matrix_science::ms_mascotresfilebase::staticGetPercolatorFileNames(const char*, const char*, const ms_mascotoptions&, const char *, const std::vector<std::string>&, std::vector<std::string>&, std::vector<bool>&).

This static function can be called without creating an ms_mascotresfilebase object, and can be used in advance of creating an object to see if the percolator files will need to be created. If an object has already been created, it is normally easier to call setPercolatorFeatures() and then getPercolatorFileNames().

See Using Percolator scores and Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
szFileName | is the absolute or relative path to the results file.
cacheDirectory | will normally be the value returned from ms_mascotoptions::getCacheDirectory. If it's empty, then the default pattern is used (../data/cache/%Y/%d).
percolatorFeatures | is normally retrieved by calling ms_mascotoptions::getPercolatorFeatures(). The filenames encode the features so that there is no conflict.
additionalFeatures | is normally a string passed to ms-createpip.exe. For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. Any other parameters except -a and -r are ignored. An empty string means nothing is added or removed from percolatorFeatures.
useRetentionTimes | is a flag to indicate whether retention time information is used by percolator.exe.
filenames | returns the list of files. The offsets are defined by ms_mascotresfilebase::PERCOLATOR_FILE_NAMES.
exists | is a boolean vector which will return flags indicating if the Percolator files exists. The values correspond to the values in filenames vector.
Returns
true if all files exist

◆ staticGetPercolatorFileNames() [2/2]

bool staticGetPercolatorFileNames | ( | const char * | szFileName,
 |  | const char * | cacheDirectory,
 |  | const ms_mascotoptions & | options,
 |  | const char * | additionalFeatures,
 |  | const std::vector< std::string > & | adapterParameters,
 |  | std::vector< std::string > & | filenames,
 |  | std::vector< bool > & | exists
 | ) |  |
staticinherited

Returns a list of the Percolator input and output files for the specified data file.

This static function can be called without creating an ms_mascotresfilebase object, and can be used in advance of creating an object to see if the percolator files will need to be created. If an object has already been created, it is normally easier to call setPercolatorFeatures() and then getPercolatorFileNames().

The function uses the following fields from options:

  • PercolatorFeatures (string)
  • PercolatorUseRT (true/false)
  • PercolatorUseProteins (true/false)
  • PercolatorExeFlags (string)
  • PercolatorTargetRankScoreThreshold (int)
  • PercolatorTargetRankRelativeThreshold (double)

Make sure you set PercolatorExeFlags in options based on whether the results file has any queries with a retention time. Otherwise, this method may generate a filename different from setPercolatorFeatures().

    bool anyRT = (whether any query has RTINSECONDS);
    std::string percolatorFlags = options.getPercolatorRtFlags(anyRT, options.isPercolatorUseRT());
    options.setPercolatorExeFlags(percolatorFlags.c_str());

See Using Percolator scores and Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
szFileName | is the absolute or relative path to the results file.
cacheDirectory | will normally be the value returned from ms_mascotoptions::getCacheDirectory. If it's empty, then the default pattern is used (../data/cache/%Y/%d).
options | contains the options stored in mascot.dat It is used to access the relevant options to generate the file names.
additionalFeatures | is normally a string passed to ms-createpip.exe. For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. Any other parameters except -a and -r are ignored. An empty string means nothing is added or removed from ms_mascotoptions::getPercolatorFeatures().
adapterParameters | is a vector of parameters to ML adapters introduced in Mascot Server 3.0. If the vector is not empty, then the parameters are sorted and hashed into an additional MD5 checksum component of the pip/pop file names.
filenames | returns the list of files. The offsets are defined by ms_mascotresfilebase::PERCOLATOR_FILE_NAMES.
exists | is a boolean vector which will return flags indicating if the Percolator files exists. The values correspond to the values in filenames vector.
Returns
true if all files exist

◆ versionGreaterOrEqual()

bool versionGreaterOrEqual | ( | int | major,
 |  | int | minor,
 |  | int | revision
 | ) |  | const
 inherited

Compare the value returned by getMascotVer() with the passed version number.

Utility function to perform easy comparison. For example, to test if a results file could have taxonomy information, use:

if (versionGreaterOrEqual(2, 4, 0)) then ...

Note
Versions 2.3.1 to 2.4.0 of Mascot Parser returned the incorrect value. This was fixed in 2.4.1
Parameters
major | is the major version to be compared with
minor | is the minor version to be compared with
revision | is the minor revision to be compared with
Returns
Will return true if the version of the file is greater than or equal to the passed value

◆ willCreateCache() [1/2]

bool willCreateCache | ( | const char * | szFileName,
 |  | const ms_mascotoptions & | opts,
 |  | const char * | applicationName,
 |  | std::string & | resfileCacheFileName,
 |  | unsigned int & | cacheStatus
 | ) |  |
staticinherited

Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.

This static function can be called without creating an ms_mascotresfile_msr or ms_mascotresfile_dat object. It can be used in advance of creating the object to see if there will be a delay while (re)creating the cache file(s).

The purpose of this method is to get the status of the cache in addition of whether the cache will be created or not.

See Multiple return values in Perl, Java, Python and C#

See Static functions in Perl, Java, Python and C#

Parameters
[in] | szFileName | is the absolute or relative path to the Fxxxxx.dat file
[in] | opts | normally loaded from the mascot.dat file using ms_datfile::getMascotOptions()
[in] | applicationName | is the name of the application or script that is calling this function. The applicationName is searched for in the return value from ms_mascotoptions::getResultsCache and ms_mascotoptions::getResfileCache to determine if the application should be using cache files. If it is not found then the function returns false and sets the cacheStatus to ms_peptidesummary::RESFILE_CACHE_DISABLED_IN_OPTIONS. If null, or an empty string is passed, no check is made.
[out] | resfileCacheFileName | returns the name of the ms_mascotresfilebase cache file if one exists or would be created
[out] | cacheStatus | is the ms_peptidesummary::CACHE_STATUS enumeration which gives more details about why the cache file may or may not be created. Multiple values may be bitwise OR'd toegether.
Returns
true if either of the cache files will be (re-)created because they does not exist or are not complete or not up to date. It will return false if the options specify that the applicationName shouldn't create or use cache files.

◆ willCreateCache() [2/2]

bool willCreateCache | ( | const char * | szFileName,
 |  | const unsigned int | flags,
 |  | const char * | cacheDirectory,
 |  | std::string * | cacheFileName
 | ) |  |
staticinherited

Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.

This static function can be called without creating an ms_mascotresfile_dat or ms_mascotresfile_msr object, and can be used in advance of creating an object to see if there will be a delay while (re)creating a cache file. The function has the same parameters as the ms_mascotresfilebase constructor.

The behaviour depends on the file type (ms_mascotresfilebase::resfileType()). If it is MSR, this method always returns false, because MSR files do not need a resfile cache. If it is dat28 format (.dat), a resfile cache may be needed.

See Static functions in Perl, Java, Python and C#

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | szFileName | - see ms_mascotresfilebase::ms_mascotresfilebase
[in] | flags | - see ms_mascotresfilebase::ms_mascotresfilebase
[in] | cacheDirectory | - see ms_mascotresfilebase::ms_mascotresfilebase
[out] | cacheFileName | - the full path name of the cache file. For languages other than C++, this will be a reference rather than a pointer to a std::string.
Returns
true if the cache file will be (re-)created because it does not exist or is not complete or not up to date. If the RESFILE_USE_CACHE flag has not been specified, it will always return false
The documentation for this class was generated from the following files:
  • ms_mascotresfile_msr.hpp
  • ms_mascotresfile_msr.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresfilebase Class Reference

  • matrix_science
  • ms_mascotresfilebase
Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
ms_mascotresfilebase Class Referenceabstract
Mascot results file module

Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr. More...

#include <ms_mascotresfilebase.hpp>

Inheritance diagram for ms_mascotresfilebase:
[legend]
Collaboration diagram for ms_mascotresfilebase:
[legend]

Public Types

enum FLAGS {
RESFILE_NOFLAG = 0x00000000 ,
RESFILE_USE_CACHE = 0x00000001 ,
RESFILE_CACHE_IGNORE_ACC_DUPES = 0x00000002 ,
RESFILE_USE_PARENT_PARAMS = 0x00000004 ,
RESFILE_CACHE_IGNORE_DATE_CHANGE = 0x00000008
}
Flags for opening the results file. More...
enum KA_TASK {
KA_CREATEINDEX_CI = 0 ,
KA_READFILE_RF = 1 ,
KA_ASSIGNPROTEINS_AP = 2 ,
KA_GROUPPROTEINS_GP = 3 ,
KA_UNASSIGNEDLIST_UL = 4 ,
KA_QUANTITATION = 5 ,
KA_CREATECACHE_CC = 6 ,
KA_THRESHFORFDR_FDR = 7 ,
KA_LAST = 8
}
Processing some results files is computationally intensive. These are the tasks that can be performed. More...
enum PERCOLATOR_FILE_NAMES {
PERCOLATOR_INPUT_FILE = 0 ,
PERCOLATOR_OUTPUT_TARGET = 1 ,
PERCOLATOR_OUTPUT_DECOY = 2
}
Offsets into a vector of Percolator filenames. More...
enum RESFILE_TYPE {
RESFILE_DAT28 = 0 ,
RESFILE_MSR = 1 ,
RESFILE_UNKNOWN = 2
}
Supported results file formats. More...
enum XML_SCHEMA {
XML_SCHEMA_QUANTITATION = 0 ,
XML_SCHEMA_UNIMOD = 1 ,
XML_SCHEMA_DIRECTORY = 2 ,
XML_SCHEMA_CROSSLINKING = 3 ,
XML_SCHEMA_LAST = 4
}
The results file contains embedded files in XML format and these need to be validated against a schema. More...

Public Member Functions

ms_mascotresfilebase (const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory=0, const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0)
ms_mascotresfilebase is an abstract class; use createResfile().
virtual bool | anyCrosslinkedMatches (const bool isDecoy=false) const =0
Returns true if there are any Crosslinked matches.
virtual bool | anyErrorTolerantMatches (const bool isDecoy=false) const =0
Returns true if there are any Error Tolerant matches.
virtual bool | anyFastaMatches (const bool isDecoy=false) const =0
Returns true if there are any FASTA matches.
virtual bool | anyMSMS () const =0
Returns true if any of the queries in the search contain ions data.
virtual bool | anyPMF () const =0
Returns true if any of the queries in the search just contain a single peptide mass.
virtual bool | anySpectralLibraryMatches (const bool isDecoy=false) const =0
Returns true if there are any Spectral Library matches.
virtual bool | anySQ () const =0
Returns true if any of the queries in the search contain seq or comp commands.
virtual bool | anyTag () const =0
Returns true if any of the queries in the search contain tag or etag commands.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
virtual int | appendResfile (const char *filename, int flags=RESFILE_USE_PARENT_PARAMS, const char *cacheDirectory=0)=0
Multiple results files can be summed together and treated as 'one'.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::string | get_ms_mascotresults_params (const ms_mascotoptions &opts, ms_mascotresults_params &params) const
Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.
std::string | get_ms_mascotresults_params (const ms_mascotoptions &opts, unsigned int *gpFlags, double *gpMinProbability, int *gpMaxHitsToReport, double *gpIgnoreIonsScoreBelow, unsigned int *gpMinPepLenInPepSummary, bool *gpUsePeptideSummary, unsigned int *gpFlags2) const
[Deprecated] Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.
virtual std::string | getCacheDirectory (bool processed=true) const =0
Returns the directory being used for cache files (if any).
virtual std::string | getCacheFileName () const =0
Returns the filename of the cache file; see ms_mascotresfile_msr::getCacheFileName() and ms_mascotresfile_dat::getCacheFileName().
bool | getCrosslinkingMethod (ms_crosslinking_method *method) const
Return the crosslinking method object from the embedded crosslinking file.
virtual DATABASE_TYPE | getDatabaseType (const int idx) const =0
Return database type if available.
virtual int | getDate () const =0
Returns the date and time of the search in seconds since midnight January 1st 1970.
virtual ms_mascotoptions::DECOY_ALGORITHM | getDecoyTypeForDB (const int idx=1) const =0
Returns the decoy algorithm type for a given database.
virtual bool | getEnzyme (ms_enzymefile *efile, const char *enzymeFileName=0) const =0
Returns an object that represents the embedded enzyme file as a reduced enzymes file.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getErrorNumber (const int num=-1) const
Return a specific error number - or ms_errs::ERR_NO_ERROR.
std::string | getErrorString (const int num) const
Return a specific error as a string.
virtual int | getExecTime () const =0
Returns the time taken for the search.
virtual std::string | getFastaPath (int idx=1) const =0
Returns the path to the FASTA file used.
virtual std::string | getFastaVer (int idx=1) const =0
Returns the FASTA file version.
virtual std::string | getFileName (const int id=1) const =0
Returns the name of the results file passed into the constructor.
virtual double | getFirstPassThreshold () const =0
Return the threshold value for the first pass of an automated error tolerant search.
virtual void | getHeaderKeyValues (std::vector< std::string > &keys, std::vector< std::string > &values) const =0
Return all the header key-value pairs.
virtual std::string | getHeaderValue (const std::string &key) const =0
Return the header value for the given key.
virtual ms_inputquery | getInputQuery (const int queryNum) const =0
Return the ms_inputquery object for the query given as argument.
virtual int | getJobNumber (const int resfileID=1) const =0
Return the job number for this file - obtained from the file name.
void | getKeepAlive (KA_TASK &kaTask, int &kaPercentage, std::string &kaAccession, int &kaHit, int &kaQuery, std::string &kaText) const
Return the progress indicators used by the keepAlive functions.
int | getLastError () const
Return the last error number - or ms_erros::ERR_NO_ERROR.
std::string | getLastErrorString () const
Return the last error number - or an empty string.
virtual int | getLibraryMods (std::vector< std::string > &modNames, std::vector< double > &modDeltas) const =0
Return all the library mod names and deltas.
virtual std::string | getMascotVer () const =0
Returns the version of Mascot used to perform the search.
bool | getMasses (ms_masses *masses) const
Returns an ms_masses object from the mass values in the results file.
virtual void | getMassesKeyValues (std::vector< std::string > &keys, std::vector< double > &values) const =0
Return all the residue and modification masses as key-value pairs.
virtual double | getMassValue (const std::string &key) const =0
Return the residue or modification mass for the given key.
const ms_modification * | getMonoLinkModification (const int modNum, const int monoLink) const
Returns an ms_modification object that represents a monolink variable modification.
std::string | getMSParserVersion () const
Returns the version number of the Mascot Parser library.
virtual int | getMultiFileQueryNumber (const int localQuery, const int fileId) const =0
Return the multi-file query number from the local query number in an appended file.
int | getNumberOfErrors () const
Return the number of errors since the last call to clearAllErrors.
virtual int | getNumberOfResfiles () const =0
Multiple results files can be summed together and treated as 'one'.
virtual int | getNumEtSeqsSearched (const int idx=0) const =0
Returns the number of sequences searched in the second pass of an integrated error tolerant search.
virtual int | getNumLibraryEntries (const int idx=0) const =0
Returns the number of entries in the spectral library searched.
virtual int | getNumQueries (const int resfileID=0) const =0
Returns the number of queries (peptide masses or ms-ms spectra).
virtual double | getNumResidues (const int idx=0) const =0
Returns the number of residues in the FASTA file(s) searched.
virtual int | getNumSeqs (const int idx=0) const =0
Returns the number of sequences in the FASTA file(s) searched.
virtual int | getNumSeqsAfterTax (const int idx=0) const =0
Returns the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.
virtual int | getObservedCharge (const int query, const bool decoy=false) const =0
The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.
virtual double | getObservedIntensity (const int query) const =0
Returns the experimental intensity for the peptide.
virtual double | getObservedMass (const int query) const =0
Returns the experimental mass value as entered by the user.
virtual double | getObservedMrValue (const int query, const bool decoy=false) const =0
Returns the experimental mass value (as a relative mass) as entered by the user.
std::vector< std::string > | getPercolatorFileNames () const
Retrieve the filenames use for percolator input and output.
ms_progress_info * | getProgressInfo (bool forPeptideSummary=false) const
If a matrix_science::ms_progress_info object is passed to the constructor, this is returned here.
virtual int64_t | getQmatch (const int query, const ms_peptide::PSM_TYPE pepType) const =0
Return the number of peptide masses within precursor tolerance of this query.
virtual double | getQplughole (const int query, const ms_peptide::PSM_TYPE pepType) const =0
Return the threshold score for homologous peptide match (MIS only).
virtual bool | getQuantitation (ms_quant_configfile *qfile) const =0
Returns an object that represents the embedded quantitation file as a reduced quantitation.xml file.
bool | getQuantitationMethod (ms_quant_method *qmethod) const
Return the quantitation method object from the embedded quantitation file.
virtual int | getReferenceDatabaseNumberOfSL (const int idx) const =0
Return the database number of the reference database of a spectral library.
virtual std::string | getRepeatSearchString (const int query, const bool fullQuery=false) const =0
To perform a repeat search need to build up appropriate string.
virtual const ms_mascotresfilebase * | getResfile (int id) const =0
virtual std::string | getSearchParameter (const std::string &key) const =0
Return the search parameter the given key.
virtual void | getSearchParametersKeyValues (std::vector< std::string > &keys, std::vector< std::string > &values) const =0
Return all the search parameters as key-value pairs.
virtual std::vector< int > | getSLDatabaseNumbersOfReference (const int idx) const =0
Return the database numbers of the spectral libraries whose reference database is at the given index.
virtual std::string | getSLExecCommand (int idx=1) const =0
Returns the library search command line and parameters (sl_exec_command).
virtual double | getSLFragmentTolerance (int idx=1) const =0
Returns the effective spectral library fragment tolerance.
virtual std::string | getSLFragmentToleranceUnit (int idx=1) const =0
Returns the unit of the effective spectral library fragment tolerance.
virtual bool | getSrcQueryAndFileIdForMultiFile (const int q, int &gsqNewQuery, int &gsqFileId) const =0
Return the query number and file ID in the source results file.
virtual bool | getTaxonomy (ms_taxonomyfile *tfile) const =0
Returns an object that represents the embedded taxonomy file as a reduced taxonomy file.
virtual bool | getUnimod (ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const =0
Returns an object that represents the embedded unimod file as a reduced unimod_2.xml file.
virtual bool | getUnimodXL (ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const =0
Returns an object that represents the embedded unimod_xl file as a reduced unimod_xl.xml file.
virtual std::string | getUniqueTaskID () const =0
Returns the unique task ID used by Mascot Daemon.
std::string | getXMLschemaFilePath (XML_SCHEMA XMLschema) const
Gets the XML schema to be used by functions using quantitation or unimod.
virtual bool | hasEnzyme () const =0
Return true if the results file contains information about the enzyme used.
virtual bool | hasQuantitation () const =0
Return true if the results file contains quantitation data.
virtual bool | hasRT () const =0
Return true if the results file contains retention time data.
virtual bool | isDatabaseTypeAvailable () const =0
Check whether database types are available.
virtual bool | isErrorTolerant () const =0
Returns true if the search was an error tolerant search.
virtual bool | isMSMS () const =0
Returns true if the search was an MSMS search (SEARCH=MIS).
virtual bool | isPMF () const =0
Returns true if the search was a PMF search (SEARCH=PMF).
virtual bool | isSQ () const =0
Returns true if the search was a sequence query search (SEARCH=SQ).
bool | isValid () const
Call this function to determine if there have been any errors.
bool | outputKeepAlive () const
Outputs the "keep-alive" string during time-consuming operations.
ms_searchparams & | params () const
Returns a reference to the search parameters class.
void | resetKeepAlive (const int keepAliveInterval, const char *keepAliveText, const bool propagateToAppended=true, const bool resetStartTime=false)
Replace the existing keepAlive values with new values.
void | setPercolatorFeatures (const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes)
Set Percolator features before creating an ms_peptidesummary with Percolator scoring (deprecated).
void | setPercolatorFeatures (const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters=std::vector< std::string >())
Set Percolator features before creating an ms_peptidesummary with Percolator scoring.
bool | setXMLschemaFilePath (XML_SCHEMA XMLschema, const char *path)
Sets the XML schema to be used by functions using quantitation or unimod.
bool | versionGreaterOrEqual (int major, int minor, int revision) const
Compare the value returned by getMascotVer() with the passed version number.

Static Public Member Functions

static std::unique_ptr< ms_mascotresfilebase > | createResfile (const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, matrix_science::ms_progress_info *progressMonitor=0)
Return a new ms_mascotresfile_msr or ms_mascotresfile_dat based on the file contents.
static RESFILE_TYPE | resfileType (const std::string &fileName)
Return the results format of the file provided as an argument.
static bool | staticGetPercolatorFileNames (const char *szFileName, const char *cacheDirectory, const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes, std::vector< std::string > &filenames, std::vector< bool > &exists)
Returns a list of the Percolator input and output files for the specified data file (deprecated).
static bool | staticGetPercolatorFileNames (const char *szFileName, const char *cacheDirectory, const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters, std::vector< std::string > &filenames, std::vector< bool > &exists)
Returns a list of the Percolator input and output files for the specified data file.
static bool | willCreateCache (const char *szFileName, const ms_mascotoptions &opts, const char *applicationName, std::string &resfileCacheFileName, unsigned int &cacheStatus)
Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.
static bool | willCreateCache (const char *szFileName, const unsigned int flags, const char *cacheDirectory, std::string *cacheFileName)
Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.

Protected Member Functions

virtual bool | getCrosslinking (ms_crosslinking_configfile *crosslinkingFile) const =0
std::string | getErrorInfoAsString (const int num) const
bool | setErrorInfoFromString (const std::string &e)

Detailed Description

Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.

Until Mascot Server 2.8, there was only one Mascot results file format: plain text MIME format file with .dat extension. Mascot Server 3.0 introduced a new file format, Mascot Search Results (MSR), which is an SQLite database. The old .dat format is frozen and now referred to as dat28.

ms_mascotresfilebase has two concrete implementations.

  • ms_mascotresfile_dat parses a file in dat28 format.
  • ms_mascotresfile_msr parser a file in MSR format.

Use ms_mascotresfilebase::createResfile() to create an object using the right constructor. Almost all of the API is the same between the two classes, except for very low-level methods specific to the dat28 format.

Examples
peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

◆ FLAGS

enum FLAGS

Flags for opening the results file.

See Using enumerated values and static const ints in Perl, Java, Python and C# and Caching Mascot Results.

Enumerator
RESFILE_NOFLAG | Dat28 format: Read the whole file into memory. MSR format: Use standard SQLite methods to read the file with low memory overhead.
RESFILE_USE_CACHE | Dat28 format: Create the resfile cache if it doesn't already exist. Use the cache rather than reading the whole .dat file into memory. MSR format: this flag is ignored.
RESFILE_CACHE_IGNORE_ACC_DUPES | When creating a cache file, don't check for duplicate accessions in the SEC_PROTEINS and SEC_DECOYPROTEINS sections which can save some time. Strongly recommend that this flag is never used unless performance becomes a real issue and it is known that ms_mascotoptions::getIgnoreDupeAccession was not defined for the relevant database(s) when they were compressed.
RESFILE_USE_PARENT_PARAMS | For use when Combining multiple results files. The flags and parameters are then inherited from the parent search.
RESFILE_CACHE_IGNORE_DATE_CHANGE | Dat28 format: Opening the resfile cache CDB file should ignore the last modified timestamp on the .dat file. MSR format: this flag is ignored.

◆ KA_TASK

enum KA_TASK

Processing some results files is computationally intensive. These are the tasks that can be performed.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Used with getKeepAlive(), but also see outputKeepAlive()

Enumerator
KA_CREATEINDEX_CI | Creating a cache file when Using the resfile cache (dat28 format only) in dat28 format.
KA_READFILE_RF | Reading the results file into memory when not using a cache.
KA_ASSIGNPROTEINS_AP | Assigning peptides to proteins to get a list of all possible proteins.
KA_GROUPPROTEINS_GP | Grouping proteins using ms_mascotresults::MSRES_GROUP_PROTEINS or ms_mascotresults::MSRES_CLUSTER_PROTEINS.
KA_UNASSIGNEDLIST_UL | Creating the unassigned list - see ms_mascotresults::createUnassignedList.
KA_QUANTITATION | Calculating quantitation values for reporter and multiplex protocols.
KA_CREATECACHE_CC | Creating a cache file when Using the pepsum cache (MSR and dat28).
KA_THRESHFORFDR_FDR | Calls to ms_mascotresults::getThresholdForFDRAboveHomology can be slow.
KA_LAST | Placeholder that is equal to the number of possible tasks.

◆ PERCOLATOR_FILE_NAMES

enum PERCOLATOR_FILE_NAMES

Offsets into a vector of Percolator filenames.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Used with getPercolatorFileNames().

Enumerator
PERCOLATOR_INPUT_FILE | This file is created by ms-createpip.exe and read by Percolator.
PERCOLATOR_OUTPUT_TARGET | From std::out of percolator.exe.
PERCOLATOR_OUTPUT_DECOY | Specified using the -B flag when calling Percolator.

◆ RESFILE_TYPE

enum RESFILE_TYPE

Supported results file formats.

Enumerator
RESFILE_DAT28 | Plain text MIME-format results file produced by Mascot Server 2.0 to 2.8.
RESFILE_MSR | Mascot Search Results (MSR) file introduced in Mascot Server 3.0.
RESFILE_UNKNOWN | Unknown file format.

◆ XML_SCHEMA

enum XML_SCHEMA

The results file contains embedded files in XML format and these need to be validated against a schema.

This is the list of schema that can be set using setXMLschemaFilePath() and getXMLschemaFilePath()

Enumerator
XML_SCHEMA_QUANTITATION | From the embedded quantation file. Valid aliases are: "http://www.matrixscience.com/xmlns/schema/quantitation_1" and "http://www.matrixscience.com/xmlns/schema/quantitation_2".
XML_SCHEMA_UNIMOD | From the embedded unimod file. Valid alias is: http://www.unimod.org/xmlns/schema/unimod_2.
XML_SCHEMA_DIRECTORY | From the value of XMLschemaDirectory passed into the ms_mascotresfilebase constructor.
XML_SCHEMA_CROSSLINKING | From the embedded crosslinking file. Valid alias is: http://www.matrixscience.com/xmlns/schema/crosslinking_1.
XML_SCHEMA_LAST | Placeholder that is equal to the number of possible schema.

Constructor & Destructor Documentation

◆ ms_mascotresfilebase()

ms_mascotresfilebase | ( | const char * | szFileName,
 |  | const int | keepAliveInterval = 0,
 |  | const char * | keepAliveText = "<!-- %d seconds -->\n",
 |  | const unsigned int | flags = RESFILE_NOFLAG,
 |  | const char * | cacheDirectory = 0,
 |  | const char * | XMLschemaDirectory = 0,
 |  | ms_progress_info * | progressMonitor = 0
 | ) |  |

ms_mascotresfilebase is an abstract class; use createResfile().

See ms_mascotresfilebase::createResfile.

Parameters
szFileName | is the path to a valid Mascot results file
keepAliveInterval | is the interval in seconds between each time the keepAliveText is output to stdout.
keepAliveText | is output every keepAliveInterval seconds while the file is being loaded. See outputKeepAlive() for further details.
flags | are created by bitwise ORing the ms_mascotresfile_dat::FLAGS.
cacheDirectory | is the location where any cache files are stored.
XMLschemaDirectory | is the location where the xml schema files are located.
progressMonitor | is an optional parameter that can be used to track progress of the creation of this object.

Member Function Documentation

◆ anyMSMS()

bool anyMSMS ( ) const
pure virtual

Returns true if any of the queries in the search contain ions data.

See also the isMSMS() member, although this function is the preferred one.

Returns
true if any queries contain MS-MS fragment masses

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ anyPMF()

bool anyPMF ( ) const
pure virtual

Returns true if any of the queries in the search just contain a single peptide mass.

See also the isPMF() member, although this function is the preferred one.

Returns
true if any queries contain no MS-MS values

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
repeat_search.cpp, and resfile_info.cpp.

◆ anySQ()

bool anySQ ( ) const
pure virtual

Returns true if any of the queries in the search contain seq or comp commands.

See also the isSQ() member, although this function is the preferred one.

Returns
true if any queries contain seq or comp commands

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ anyTag()

bool anyTag ( ) const
pure virtual

Returns true if any of the queries in the search contain tag or etag commands.

See also anySQ(), anyPMF() and anyMSMS()

Returns
true if any queries contain tag or etag commands

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ appendResfile()

int appendResfile | ( | const char * | filename,
 |  | int | flags = RESFILE_USE_PARENT_PARAMS,
 |  | const char * | cacheDirectory = 0
 | ) |  |
pure virtual

Multiple results files can be summed together and treated as 'one'.

See Combining multiple results files.

Attempts to load the specifed results file and append to the existing file.

Any warning or error messages in the file are also appended to the existing object. If isValid() for the new file returns false, it is not appended and this function returns 0.

A merged report requires the results to be in the same file format. That is, a dat28 (.dat) can be appended to another dat28 file, and an MSR file (.msr) can be appended to another MSR file, but you cannot append an MSR file to a dat28 file or vice versa.

ms_errs::ERR_INVALID_RESFILE, ms_errs::ERR_READINGFILE or ms_errs::ERR_MSP_MSR_READING_FILE may be set if the file formats are not compatible.

ms_errs::ERR_CANNOT_APPEND_RESFILE_NO_FNAMES and ms_errs::ERR_CANNOT_APPEND_RESFILE will be set if the file cannot be appended because of different parameters, such as a different enzyme.

Parameters
filename | is the path to the results file to append.
flags | are one of the ms_mascotresfilebase::FLAGS. If RESFILE_USE_PARENT_PARAMS is specified, then the flags, keepAlive and cache directory are copied from the parent object.
cacheDirectory | is the directory for the cache files if RESFILE_USE_CACHE has been specified. If RESFILE_USE_PARENT_PARAMS is specified and cacheDirectory is null or an empty string, then the cache directory for the parent object is used.
Returns
0 on error, or the id number of the new file. The id can be used with getNumQueries(), getJobNumber(), getFileName() or getResfile(). The return value from the first successful call to this function will be 2.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ createResfile()

std::unique_ptr< ms_mascotresfilebase > createResfile | ( | const char * | szFileName,
 |  | const int | keepAliveInterval = 0,
 |  | const char * | keepAliveText = "<!-- %d seconds -->\n",
 |  | const unsigned int | flags = matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG,
 |  | const char * | cacheDirectory = "../data/cache/%Y/%m",
 |  | const char * | XMLschemaDirectory = 0,
 |  | matrix_science::ms_progress_info * | progressMonitor = 0
 | ) |  |
static

Return a new ms_mascotresfile_msr or ms_mascotresfile_dat based on the file contents.

The function 'sniffs' and detects the file contents using ms_mascotresfilebase::resfileType. If it looks like an MSR file, the function returns a new ms_mascotresfile_msr. If it looks like a dat28 (.dat) file, the function returns ms_mascotresfile_dat. Otherwise, a 'nil' object is returned which contains no data and is invalid.

The arguments are the same between the classes, but the details differ a bit. For example, ms_mascotresfile_msr doesn't need caching for fast random access, so it ignores the flags parameter. However, it's always safe to use the same flags regardless of class.

Please see the detailed class documentation:

  • ms_mascotresfile_msr::ms_mascotresfile_msr
  • ms_mascotresfile_dat::ms_mascotresfile_dat
Parameters
szFileName | is the path to a valid Mascot results file
keepAliveInterval | is the interval in seconds between each time the keepAliveText is output to stdout.
keepAliveText | is output every keepAliveInterval seconds while the file is being loaded. See outputKeepAlive() for further details.
flags | are created by bitwise ORing the ms_mascotresfile_dat::FLAGS.
cacheDirectory | is the location where any cache files are stored.
XMLschemaDirectory | is the location where the xml schema files are located.
progressMonitor | is an optional parameter that can be used to track progress of the creation of this object.
Returns
ms_mascotresfile_msr or ms_mascotresfile_dat object, or a 'nil' object if the file type isn't supported.

◆ get_ms_mascotresults_params() [1/2]

std::string get_ms_mascotresults_params | ( | const ms_mascotoptions & | opts,
 |  | ms_mascotresults_params & | resParams
 | ) |  | const

Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.

A number of optional flags and parameters can be passed to the ms_proteinsummary or ms_peptide summary constructors. For an application or script running on the Mascot server, the default values for some of these parameters should normally be taken from the mascot.dat file. This function sets the values and flags required to pass to the constructor in the passed ms_mascotresults_params object.

Parameters
[in] | opts | contains the options stored in mascot.dat. Call the ms_datfile construction and then ms_datfile::getMascotOptions() to obtain this value.
[out] | resParams | the values and flags required to pass to the peptide or protein summary object are set to this ms_mascotresults_params object, overwriting any values which were already set.
Returns
If the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch, then the returned script name will be ms_mascotoptions::getResultsPerlScript_2, otherwise it will be ms_mascotoptions::getResultsPerlScript.
Examples
resfile_summary.cpp.

◆ get_ms_mascotresults_params() [2/2]

std::string get_ms_mascotresults_params | ( | const ms_mascotoptions & | opts,
 |  | unsigned int * | gpFlags,
 |  | double * | gpMinProbability,
 |  | int * | gpMaxHitsToReport,
 |  | double * | gpIgnoreIonsScoreBelow,
 |  | unsigned int * | gpMinPepLenInPepSummary,
 |  | bool * | gpUsePeptideSummary,
 |  | unsigned int * | gpFlags2
 | ) |  | const

[Deprecated] Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.

Deprecated:
This function is deprecated. All new code should use ms_mascotresfilebase::get_ms_mascotresults_params(const ms_mascotoptions &, ms_mascotresults_params &) instead, as all the parameters are encapsulated in the ms_mascotresults_params class.

A number of optional flags and parameters can be passed to the ms_proteinsummary or ms_peptide summary constructors. For an application or script running on the Mascot server, the default values for some of these parameters should normally be taken from the mascot.dat file. This function returns the values and flags required to pass to the constructor.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | opts | contains the options stored in mascot.dat. Call the ms_datfile construction and then ms_datfile::getMascotOptions() to obtain this value.
[out] | gpFlags | will return the flags that are to be passed as the second parameter to the ms_proteinsummary or ms_peptidesummary object.
[out] | gpMinProbability | is the third parameter to be passed to the ms_proteinsummary or ms_peptidesummary objects. This return value will nomally be equal to the value returned from ms_mascotoptions::getSigThreshold().
[out] | gpMaxHitsToReport | this return value will normally be the one returned by ms_searchparams::getREPORT().
[out] | gpIgnoreIonsScoreBelow | this return value will be the one returned by ms_mascotoptions::getIgnoreIonsScoreBelow().
[out] | gpMinPepLenInPepSummary | this return value will be the one returned by ms_mascotoptions::getMinPepLenInPepSummary.
[out] | gpUsePeptideSummary | will be false is the file doesn't contain any anyMSMS (as returned by the anyMSMS() function) or any sequence tags (anyTag()). In this case, you should create an ms_proteinsummary. If gpUsePeptideSummary is true, you should create an ms_peptidesummary object.
[out] gpFlags2 is only required for an ms_peptidesummary. If gpUsePeptideSummary is true, gpFlags2 will have the following bits set.
  • ms_peptidesummary::MSPEPSUM_PERCOLATOR if all of the following apply:
    • the number of queries is >= ms_mascotoptions::getPercolatorMinQueries;
    • the number of sequences searched >= ms_mascotoptions::getPercolatorMinSequences;
    • this is a decoy search;
    • ms_mascotoptions::isPercolator() returns true;
  • ms_peptidesummary::MSPEPSUM_USE_CACHE if the script name that the function will return is in the string specified by ms_mascotoptions::getResultsCache().
  • ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH if the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch.
  • ms_peptidesummary::MSPEPSUM_REMOVE_CHIMERIC_DUPES if the results file comes from Mascot 2.5 or later.
Returns
If the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch, then the returned script name will be ms_mascotoptions::getResultsPerlScript_2, otherwise it will be ms_mascotoptions::getResultsPerlScript.

◆ getCacheDirectory()

std::string getCacheDirectory ( bool processed = true ) const
pure virtual

Returns the directory being used for cache files (if any).

The cacheDirectory supplied to the constructor ms_mascotresfilebase::ms_mascotresfilebase may contain a number of '%' flags which get substituted by Mascot Parser.

This function returns either an absolute directory or a directory relative to the current working directory, depending on what was supplied and the parameter processed.

See Caching Mascot Results and ms_mascotoptions::getCacheDirectory

Parameters
processed if true (the default), then the returned directory is relative to the current directory and will have any '%' flags replaced with the relevant directory. If processed is false, then the directory returned will be identical to the one passed to the constructor.
Returns
The cache directory.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getCrosslinking()

bool getCrosslinking ( ms_crosslinking_configfile * crosslinkingFile ) const
protectedpure virtual

The return value indicates that the embedded crosslinking method file exists in the results file. Call ms_crosslinking_configfile::isValid to determine whether the XML part has been parsed successfully.

The contents of the file are validated against a schema by default.

See Object initialising functions in Perl, Java, Python and C#.

See also
getCrosslinkingMethod() which is generally easier to use.
Parameters
crosslinkingFile a pointer to crosslinking file object. This must be a valid pointer to a valid object, which should normally be created using the default constructor: ms_crosslinking_configfile::ms_crosslinking_configfile
Returns
true if embedded file exists and false if it doesn't

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getCrosslinkingMethod()

bool getCrosslinkingMethod ( ms_crosslinking_method * method ) const

Return the crosslinking method object from the embedded crosslinking file.

This method returns true if all of the following apply:

  • the embedded crosslinking file exists;
  • a valid schema file location has been set using the XMLschemaDirectory parameter in the constructor or the file exists in the default location;
  • the embedded crosslinking file validates against the schema;
  • the crosslinking method named in the CROSSLINKING parameter exists;
  • the crosslinking method can be loaded.

Otherwise the method returns false.

If the CROSSLINKING parameter is empty or equals "none", then the method simply returns false. Otherwise, on failure, the method sets the warning ms_errors::ERR_MSP_CROSSLINKING_FAILEDLOAD.

Parameters
method A pointer to crosslinking method object. This must be a valid pointer to a valid object, which should normally be created using the default constructor ms_quant_method::ms_quant_method.
Returns
True if the method was loaded; false otherwise.

◆ getDatabaseType()

DATABASE_TYPE getDatabaseType ( const int idx ) const
pure virtual

Return database type if available.

In dat28 format, Mascot 2.6 and later save the type of the searched database(s) in the results file, as db_typeX= lines in the header section. These types are AA (amino acid), NA (nucleic acid) or SL (spectral library).

In MSR format, introduced in Mascot Server 3.0, the 'db_type' column is always present in the search__databases table.

The number of databases is ms_searchparams::getNumberOfDatabases(), so idx should be between 1 and getNumberOfDatabases().

Spectral libraries must have a reference database. If the reference database is not part of the actual search, protein accessions mapped to it have a database number above ms_searchparams::getNumberOfDatabases(). For example, if the search contains one AA database and one spectral library, getNumberOfDatabases() is 2 and the types returned by getDatabaseType() are AA (idx = 1) and SL (idx = 2). The reference database is at index 3 with type SLREF.

To find the number of the reference database of a spectral library, see ms_mascotresfilebase::geReferenceDatabaseNumberOfSL().

Parameters
idx index of the database; must normally be between 1 and ms_searchparams::getNumberOfDatabases(), or a valid database number returned by ms_mascotresfilebase::getReferenceDatabaseNumberOfSL()
Returns
database type if available. If idx is out of range or isDatabaseTypeAvailable() is false, returns AA.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getDate()

virtual int getDate ( ) const
pure virtual

Returns the date and time of the search in seconds since midnight January 1st 1970.

In dat28 format, obtained from the date= line in the header section of the file.

In MSR format, obtained from the 'date' row in the search__header table.

Can be converted to day, month, year etc. using gmtime or similar functions.

Returns
the date and time of the search in seconds since midnight January 1st 1970.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ getDecoyTypeForDB()

ms_mascotoptions::DECOY_ALGORITHM getDecoyTypeForDB ( const int idx = 1 ) const
pure virtual

Returns the decoy algorithm type for a given database.

In dat28 format, the decoy algorithm type is saved as decoy_type= or decoy_typeX= in the header section, depending on Mascot version.

In MSR format, the algorithm type is saved as the 'decoy_type' column in the search__databases table.

If idx = 1, the method returns the value of decoy_type=. If idx > 1, the method returns the corresponding decoy_typeX= line, or if one doesn't exist, falls back on decoy_type=.

If there is no suitable value in the file or idx is outside its range, the method returns ms_mascotoptions::DECOY_ALGORITHM_NONE.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the decoy algorithm type, or ms_mascotoptions::DECOY_ALGORITHM_NONE.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getEnzyme()

bool getEnzyme | ( | ms_enzymefile * | efile,
 |  | const char * | enzymeFileName = 0
 | ) |  | const
 pure virtual

Returns an object that represents the embedded enzyme file as a reduced enzymes file.

In dat28 format, for data files created with Mascot 2.2 and later, the full definition of the enzyme used is included in the Mascot results file. For earlier versions of Mascot, just the name is recorded. This function attempts to read the definition from the results file. If the definition is not present in the results file and a path to the enzymes file has been passed, then this function reads the enzymes file and removes all entries from the list in memory apart from the one with the name specified in the results file.

In MSR format, the full definition of the enzyme used in the search is included in the Mascot results file.

To determine whether the content has been parsed successfully call ms_enzymefile::isValid.

See Object initialising functions in Perl, Java, Python and C#.

Parameters
efile | a pointer to enzymes-file object that will accept the content from the embedded file or the extenal enzymes file if necessary. If successful, the enzyme itself can be retrieved by passing an index of zero to ms_enzymefile::getEnzymeByNumber()
enzymeFileName | is only used for results files prior to Mascot 2.2
Returns
True if the embedded file exists in the results file or if the enzyme specified in the results file can be loaded from the external enzymes file.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getErrorInfoAsString()

std::string getErrorInfoAsString ( const int num ) const
protected

For saving any errors in the .cdb file

Parameters
num 1..getNumberOfErrors()
Returns
"[Error Number]:[Number of times]:[Error string]"

◆ getErrorNumber()

int getErrorNumber ( const int num = -1 ) const

Return a specific error number - or ms_errs::ERR_NO_ERROR.

All errors are accumulated into a list in this object, until clearAllErrors() is called.

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

See Error Handling.

See also
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()

In Mascot Parser 2.5 and later, this is implemented by calling: ms_errs::getErrorNumber()

Parameters
num is the error number in the range 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or ERR_NO_ERROR. If an invalid number is passed, ERR_NO_ERROR will be returned (and no error will be added to the list of errors!).
Returns
the error number
Examples
resfile_error.cpp, and resfile_summary.cpp.

◆ getErrorString()

std::string getErrorString ( const int num ) const

Return a specific error as a string.

All errors are accumulated into a list in this object, until clearAllErrors() is called. To return a particular error, call this function with a number 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or an empty string. If an invalid number is passed an empty string will be returned (and no error will be added to the list of errors!).

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

In Mascot Parser 2.5 and later, this is implemented by calling ms_errs::getErrorString but functionality is identical to previous versions.

See Error Handling.

See also
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()
Parameters
num 1 to number of errors, or -1
Returns
error string for the given number, or the last error for -1, empty string if none
Examples
resfile_error.cpp, and resfile_summary.cpp.

◆ getExecTime()

virtual int getExecTime ( ) const
pure virtual

Returns the time taken for the search.

In dat28 format, obtained from the exec_time= line in the header section.

In MSR format, obtained from the 'exec_time' row in the search__header table.

This is the 'wall clock' time, not the CPU time.

Returns
execution time in seconds

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ getFastaPath()

std::string getFastaPath ( int idx = 1 ) const
pure virtual

Returns the path to the FASTA file used.

Available in Mascot 2.2 and later.

Mascot 2.6 and later support spectral libraries. Each spectral library must have a reference database into which found peptide sequences are mapped at the end of the search. The "effective" reference database could be one of the protein sequence databases searched, or it could be a separate database used only for lookup purposes. You can find the database number of the reference database with ms_mascotresfilebase::getReferenceDatabaseNumberOfSL(). If this is larger than getNumberOfDatabases(), the FASTA file path is obtained from the library_reference_fastafile line in the results file header.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases() for databases or libraries searched, or an index returned by ms_mascotresfilebase::getReferenceDatabaseNumberOfSL().
Returns
The full path to the database or library file used in the search.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getFastaVer()

std::string getFastaVer ( int idx = 1 ) const
pure virtual

Returns the FASTA file version.

Mascot 2.6 and later support spectral libraries. Each spectral library must have a reference database into which found peptide sequences are mapped at the end of the search. The "effective" reference database could be one of the protein sequence databases searched, or it could be a separate database used only for lookup purposes. You can find the database number of the reference database with ms_mascotresfilebase::getReferenceDatabaseNumberOfSL(). If this is larger than getNumberOfDatabases(), the FASTA file version is obtained from the library_reference_release line in the results file header.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases() for databases or libraries searched, or an index returned by ms_mascotresfilebase::getReferenceDatabaseNumberOfSL().
Returns
File name of the database or library searched.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ getFileName()

std::string getFileName ( const int id = 1 ) const
pure virtual

Returns the name of the results file passed into the constructor.

Parameters
id a 1 based index. Unless appendResfile() has been called, this value must be '1'.
Returns
the file name (or file path) of the results file.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
repeat_search.cpp.

◆ getFirstPassThreshold()

double getFirstPassThreshold ( ) const
pure virtual

Return the threshold value for the first pass of an automated error tolerant search.

Return the first pass threshold of an automated error tolerant search. This is the significance threshold used at the end of the first pass to select proteins for the second pass.

In Mascot Server 2.7 and earlier, the first pass threshold was always 0.05.

In Mascot Server 2.8 and later, you can specify a target FDR in the search form. If the search is an error tolerant target-decoy search with target FDR, the first pass threshold can differ from 0.05.

See Score thresholds and score filtering (Mascot Server 2.8 and later).

Returns
First pass threshold, or 0.0 if this is not an integrated error tolerant search.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getHeaderKeyValues()

void getHeaderKeyValues | ( | std::vector< std::string > & | keys,
 |  | std::vector< std::string > & | values
 | ) |  | const
 pure virtual

Return all the header key-value pairs.

Get all the key-value pairs of the results header. The header contains data such as: number of queries, exec_time (search duration), database types (AA, NA, SL) and task ID.

To get the value of an individual header key, use ms_mascotresfilebase::getHeaderValue().

Parameters
[out] | keys | A vector of non-empty keys.
[out] | values | A vector of strings (some may be empty) in the same order as keys.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getHeaderValue()

std::string getHeaderValue ( const std::string & key ) const
pure virtual

Return the header value for the given key.

Get the value associated with the input key in the results header. To get all the values, use ms_mascotresfilebase::getHeaderKeyValues().

Parameters
[in] key A non-empty string.
Returns
the value associated to the key, or empty if the key does not exist.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getInputQuery()

ms_inputquery getInputQuery ( const int queryNum ) const
pure virtual

Return the ms_inputquery object for the query given as argument.

This method call is equivalent to creating an ms_inputquery object with the current results file and queryNum as parameter.

Parameters
queryNum is the query number
Returns
ms_inputquery object

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getJobNumber()

int getJobNumber ( const int resfileID = 1 ) const
pure virtual

Return the job number for this file - obtained from the file name.

The library can only 'guess' at this since the value is not in the results file. To perform this function, it retrieves the job number from the file name, so be warned about changing file names. The function returns 0 if it cannot determine the job number.

Parameters
resfileID is the the 1 based id of the results file. If multiple files have been merged together with appendResfile(), use the file ID returned by appendResfile() or getSrcFileIdForMultiFile() to access the job number of the appended files.
Returns
the derived job number.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getKeepAlive()

void getKeepAlive | ( | KA_TASK & | kaTask,
 |  | int & | kaPercentage,
 |  | std::string & | kaAccession,
 |  | int & | kaHit,
 |  | int & | kaQuery,
 |  | std::string & | kaText
 | ) |  | const

Return the progress indicators used by the keepAlive functions.

See Multiple return values in Perl, Java, Python and C# although there may be issues with some languages and the kaTask parameter.

It is normally easier for client applications to call ms_mascotresults::getCreateSummaryProgress() or outputKeepAlive() than to call this function.

Parameters
kaTask | is the task currently being performed by Mascot Parser. If Parser is doing nothing, then this will be the last task that was completed and kaPercentage will be 100
kaPercentage | is the percentage (0..100) complete for the current kaTask.
kaAccession | is the current 'accession' being processed. See outputKeepAlive() for details of which tasks set this value
kaHit | is the current hit being processed. See outputKeepAlive() for details of which tasks set this value
kaQuery | is the current 'query' being processed. See outputKeepAlive() for details of which tasks set this value
kaText | is the text that would be output by outputKeepAlive()

◆ getLastError()

int getLastError ( ) const

Return the last error number - or ms_erros::ERR_NO_ERROR.

Same as calling getErrorNumber() with -1 as a parameter.

Returns
error number
Examples
peptide_list.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ getLastErrorString()

std::string getLastErrorString ( ) const

Return the last error number - or an empty string.

Same as calling getErrorString() with -1 as a parameter.

Returns
last error string
Examples
peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, and resfile_params.cpp.

◆ getLibraryMods()

int getLibraryMods | ( | std::vector< std::string > & | modNames,
 |  | std::vector< double > & | modDeltas
 | ) |  | const
 pure virtual

Return all the library mod names and deltas.

Get a list of all library modifications. If multiple spectral libraries were searched, this is the combined list of modifications.

Parameters
[out] | modNames | Library modification names.
[out] | modDeltas | Library modification deltas.
Returns
the number of modifications, or 0 if there are none.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getMascotVer()

virtual std::string getMascotVer ( ) const
pure virtual

Returns the version of Mascot used to perform the search.

In dat28 format, obtained from the version= entry in the header section of the file.

In MSR format, obtained from the 'version' row in the search__header table.

See also
versionGreaterOrEqual
Returns
the version of Mascot used to perform the search.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ getMasses()

bool getMasses ( ms_masses * masses ) const

Returns an ms_masses object from the mass values in the results file.

For results files from Mascot 2.2 and later, this function simply calls

    if (getUnimod(&umodConfigFile) && umodConfigFile.isValid())
    {
        masses->copyFrom(&umodConfigFile);
    }

For earlier results files in dat28 format, it reads the residue mass values from the masses section of the file. Since this section either contains average or monoisotopic masses (but not both), the resulting ms_masses object will only have one set of masses.

See Object initialising functions in Perl, Java, Python and C#.

Parameters
masses a pointer to a valid masses object that will accept the content from the section.
Returns
true always.

◆ getMassesKeyValues()

void getMassesKeyValues | ( | std::vector< std::string > & | keys,
 |  | std::vector< double > & | values
 | ) |  | const
 pure virtual

Return all the residue and modification masses as key-value pairs.

Get all the modification and residue masses as key-value pairs. This includes:

  • Residue masses (A, B, C, D, etc.)
  • Terminus masses (N-term, C-term)
  • Element and atomic masses (H, O, electron, etc.)
  • Variable modification deltas (delta1, delta2, etc.)
  • Fixed modification deltas (FixedMod1, FixedMod2, etc.)
  • Fragment neutral loss (NeutralLoss1, NeutralLoss2, etc.)
  • Peptide neutral loss (PepNeutralLoss1, PepNeutralLoss2, etc.)
  • Required peptide neutral loss (ReqPepNeutralLoss1, ReqPepNeutralLoss2, etc.)
  • Ignore masses (Ignore1, Ignore2, etc.)

To get the value of an individual key, use ms_mascotresfilebase::getMassValue().

In general, it is easier to access these values through ms_searchparams.

Parameters
[out] | keys | A vector of non-empty keys.
[out] | values | A vector of doubles in the same order as keys.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getMassValue()

std::string getMassValue ( const std::string & key ) const
pure virtual

Return the residue or modification mass for the given key.

Get the value associated with the input key in the list of masses. To get all the values, use ms_mascotresfilebase::getMassKeyValues().

Parameters
[in] key A non-empty string.
Returns
the value associated to the key, or 0.0 if the key does not exist.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getMonoLinkModification()

const ms_modification * getMonoLinkModification | ( | const int | modNum,
 |  | const int | monoLink
 | ) |  | const

Returns an ms_modification object that represents a monolink variable modification.

The method performs the following steps:

  • Fetch the the embedded unimod_xl file (ms_mascotresfilebase::getUnimodXL()).
  • Fetch the linker name (ms_searchparams::getVarModName()) of modNum.
  • Find the corresponding ms_umod_modification entry in the embedded unimod_xl file.
  • Wrap the correct neutral loss element as an ms_modification.

The ms_modification object contains the following fields:

  • ms_modification::getTitle() returns the modfile-style name, like "Xlink:DSS (K)".
  • ms_modification::getCode() returns the monolink code.
  • ms_modification::getMonoLinkTitle() returns a modfile-style title containing the monolink code in square brackets, like "Xlink:DSS[W] (K)".
  • ms_modification::getDelta() returns the monolink delta corresponding to the monolink code (linker delta - monolink NL).
  • ms_modification::getPairsWith() returns the code or codes this monolink pairs with, or empty string if not defined.
  • ms_modification::isGeneratedMonoLinker() returns true.
  • ms_modification::isLoopLinker() returns true if the monolink NL is zero; otherwise false.
  • The neutral loss list is empty.
Parameters
modNum | Variable mod index in range 1..32. Usually this comes from the peptide's variable mods string.
monoLink | Index of the neutral loss element. Usually this comes from the peptide's monolink string.
Returns
a pointer, or null if this isn't a linker or the monolink index is invalid.

◆ getMSParserVersion()

std::string getMSParserVersion ( ) const

Returns the version number of the Mascot Parser library.

This version information is also available:

  • In Windows from the Mascot Parser DLL in the version 'tab'
  • From Perl using perl -Mmsparser -e "print msparser->VERSION()"
  • From Java using:
        JarFile jar = new JarFile(new File(jarName));
    Manifest jarManifest = jar.getManifest();
    Attributes mainAttributes = jarManifest.getMainAttributes();
    String version = (String) mainAttributes.get(Attributes.Name.IMPLEMENTATION_VERSION);
Returns
the version number as a string.

◆ getMultiFileQueryNumber()

int getMultiFileQueryNumber | ( | const int | localQuery,
 |  | const int | fileId
 | ) |  | const
 pure virtual

Return the multi-file query number from the local query number in an appended file.

See Multiple return values in Perl, Java, Python and C#.

Needs to be called on the 'primary' file object rather than on a ms_mascotresfile_dat or ms_mascotresfile_msr object returned by the getResfile() function.

See Combining multiple results files.

Example: Assume that the primary results file has 10 queries, file 2 has 20 queries and file 3 has 30 queries. This function will return the following:

localQuery | fileId | returned query
6 | 1 | 6
11 | 2 | 21
1 | 3 | 31
See also
getSrcQueryAndFileIdForMultiFile() for the 'inverse' function
Parameters
localQuery | is the query number which should be a value between 1 and getNumQueries() for the file specified by fileId.
fileId | is a 1 based index to the source file.
Returns
the query number that should be used for the primary file, or -1 if an invalid localQuery / fileId parameter combination is passed.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getNumberOfErrors()

int getNumberOfErrors ( ) const

Return the number of errors since the last call to clearAllErrors.

This will be zero if there has been no error.

All errors are accumulated into a list in this object, until clearAllErrors() is called.

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

From version 2.5, implemented by calling getErrorHandler()->getNumberOfErrors()

See Error Handling.

See also
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()
Returns
number of errors
Examples
resfile_error.cpp, and resfile_summary.cpp.

◆ getNumberOfResfiles()

int getNumberOfResfiles ( ) const
pure virtual

Multiple results files can be summed together and treated as 'one'.

See Combining multiple results files.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
the number of results files that have been combined together. If appendResfile() has not been called then this function will return a value of 1.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getNumEtSeqsSearched()

int getNumEtSeqsSearched ( const int idx = 0 ) const
pure virtual

Returns the number of sequences searched in the second pass of an integrated error tolerant search.

In dat28 format, the value is obtained from the et_sequences= or et_sequencesX= line in the header section of the file.

In MSR format, the value is obtained from the 'et_sequences' column in the search__databases table.

See also
getNumSeqs(), getNumSeqsAfterTax() getNumResidues()

See Integrated error tolerant search . This function will return -1 for the Original error tolerant search and for searches prior to Mascot 2.4.1

Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is -1.
Returns
the number of sequences that were searched in the second pass of an Integrated error tolerant search

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getNumLibraryEntries()

int getNumLibraryEntries ( const int idx = 0 ) const
pure virtual

Returns the number of entries in the spectral library searched.

In dat28 format, the value is obtained from the library_entriesX= line in the header section of the file. Spectral library support was added in Mascot 2.6.

In MSR format, the value is obtained by summing up the values of the 'entries' column in the search__spectral_libraries table.

Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all library entries searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is not a spectral library, the value returned is -1.
Returns
the number of entries in the spectral library.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getNumQueries()

int getNumQueries ( const int resfileID = 0 ) const
pure virtual

Returns the number of queries (peptide masses or ms-ms spectra).

Obtained from the queries= line in the header section of the file (dat28 format) or by getting the maximum value of the 'query_id' column in the query__data table (MSR format).

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
resfileID is the the 1 based id of the results file. When the default value of 0 is used for a single results file, this is number of queries in the file. For Combining multiple results files supplying a value of zero returns the total number of queries in all the results files that have been combined. Use a value of 1 to get the number of queries just in the first results file.
Returns
the number of queries or -1 if resfileID is invalid

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, and resfile_info.cpp.

◆ getNumResidues()

double getNumResidues ( const int idx = 0 ) const
pure virtual

Returns the number of residues in the FASTA file(s) searched.

In dat28 format, the value is obtained from the residues= or residuesX= line in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

In MSR format, the value is obtained from the 'residues' column of the search__databases table.

See also
getNumSeqs(), getNumSeqsAfterTax()
Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns
the number of residues in the FASTA file searched. The value is returned as a double, because this method was introduced with 32-bit versions of Parser. These were unable to return an integer larger than 32 bits.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ getNumSeqs()

int getNumSeqs ( const int idx = 0 ) const
pure virtual

Returns the number of sequences in the FASTA file(s) searched.

In dat28 format, the value is obtained from the sequences= or sequencesX= in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

In MSR format, the value is obainted from the 'sequences' column in the search__databases table.

See also
getNumSeqsAfterTax(), getNumResidues(), getNumLibraryEntries()
Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns
the number of sequences in the FASTA file(s).

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ getNumSeqsAfterTax()

int getNumSeqsAfterTax ( const int idx = 0 ) const
pure virtual

Returns the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.

In dat28 format, the value is obtained from the sequences_after_tax= or sequences_after_taxX= line in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

In MSR format, the value is obtained from the 'sequences_after_tax' column of the search__databases table.

See also
getNumSeqs(), getNumResidues(), getNumLibraryEntries()
Parameters
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns
the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ getObservedCharge()

int getObservedCharge | ( | const int | query,
 |  | const bool | decoy = false
 | ) |  | const
 pure virtual

The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.

In dat28 format, this is obtained from the qexp[query] value. It will come from the SEC_SUMMARY section. If decoy is set to true, it is obtained from the SEC_DECOYSUMMARY section.

In MSR format, the observed charge is obtained from the query__summary table. If decoy is false, the value comes from the standard, target pass of the search; decoy is true, from the standard, decoy pass.

The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.

Possible error values:

  • ms_errs::ERR_MISSINGENTRY
  • ms_errs::ERR_QUERYOUTOFRANGE

If an 'ambiguous' charge state is specified for the whole search or for a specific query, then Mascot just records matches for the highest scoring charge state, and it is this charge state that is returned from this function. For example, the search may have been performed with "2+, 3+ or 4+" and ms_inputquery::getCharge() will return "2+, 3+ or 4+". If the highest scoring peptide match for a particular query was to charge state 4+, then all top 10 matches for that query will be for 4+ and this function will return '4'.

It is therefore not impossible to get different charge values for standard peptide matches from the decoy and target passes of the results files.

In dat28 format, this method can only read charge from the 'summary' and 'decoy_summary' sections. In MSR format, this method can only read charge for standard target or decoy peptide matches. If the peptide match type is error tolerant or crosslink, it's best to use ms_peptide::getCharge(), as these can have different charge state from the standard peptide matches in this query.

The functions getObservedIntensity() and getObservedMass() do not require the decoy parameter as the values will be identical from target and decoy passes.

See also
getObservedMrValue
Parameters
query | is a number in the range 1..getNumQueries()
decoy | should be false for target and true for decoy matches.
Returns
the observed charge for the peptide.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_error.cpp.

◆ getObservedIntensity()

double getObservedIntensity ( const int query ) const
pure virtual

Returns the experimental intensity for the peptide.

In dat28 format, this is obtained from SEC_SUMMARY - qintensity[query]. In MSR format, from the query__summary table.

The observed intensity is not always available and does not need to be supplied by the end user.

Returns 0 if the query cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

Parameters
query is a number in the range 1..getNumQueries()
Returns
0 if the intensity value is not available.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getObservedMass()

double getObservedMass ( const int query ) const
pure virtual

Returns the experimental mass value as entered by the user.

In dat28 format, this is obtained from SEC_SUMMARY - qexp[query].

In MSR format, this is obtained from the query__summary table.

Returns 0 if the value cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

Parameters
query query number
Returns
the observed peptide mass.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getObservedMrValue()

double getObservedMrValue | ( | const int | query,
 |  | const bool | decoy = false
 | ) |  | const
 pure virtual

Returns the experimental mass value (as a relative mass) as entered by the user.

In dat28 format, this is obtained from the qmass[query] value. It will come from the SEC_SUMMARY section unless decoy is set to true in which case it is obtained from the SEC_DECOYSUMMARY section.

In MSR format, the value is obtained from the query__summary table. If decoy is false, the value comes from the standard, target pass of the search; decoy is true, from the standard, decoy pass.

See also
getObservedCharge

Returns 0 if the value cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

Parameters
query | is a number in the range 1..getNumQueries()
decoy | should only be set to true if ms_searchparams::getDECOY returns true.
Returns
the relative mass of the observed peptide.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getPercolatorFileNames()

std::vector< std::string > getPercolatorFileNames ( ) const

Retrieve the filenames use for percolator input and output.

This function will return an empty vector unless setPercolatorFeatures() has been called beforehand.

The offsets into the return array are defined by ms_mascotresfilebase::PERCOLATOR_FILE_NAMES.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

You can get the list of Percolator file names without creating an object by using matrix_science::ms_mascotresfilebase::staticGetPercolatorFileNames(const char*, const char*, const ms_mascotoptions&, const char *, const std::vector<std::string>&, std::vector<std::string>&, std::vector<bool>&).

Returns
the list of files.

◆ getProgressInfo()

ms_progress_info * getProgressInfo ( bool forPeptideSummary = false ) const

If a matrix_science::ms_progress_info object is passed to the constructor, this is returned here.

Parameters
forPeptideSummary should be set to true to get the progress object used when creating the ms_peptidesummary, or false to return the object used when creating the ms_mascotresfilebase object.
Returns
a pointer to the progress information. This will be null if no progressMonitor is passed in the constructor

◆ getQmatch()

int64_t getQmatch | ( | const int | query,
 |  | const ms_peptide::PSM_TYPE | pepType
 | ) |  | const
 pure virtual

Return the number of peptide masses within precursor tolerance of this query.

Return the 'qmatch' value of the query. This is the count of trials for the query, where a trial is a candidate peptide sequence + modifications whose mass is within precursor tolerance.

The count of trials could be different depending on the peptide type. For example, error tolerant peptide matches normally have much higher count of trials than peptides from the first pass of the search.

Note
This method used to be defined in ms_peptidesummary::getQmatch(). It was moved to ms_mascotresfilebase in Parser 3.0.
Parameters
query | Query number, 1..getNumQueries().
pepType | Peptide match type.
Returns
qmatch value for the query and peptide match type.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getQplughole()

double getQplughole | ( | const int | query,
 |  | const ms_peptide::PSM_TYPE | pepType
 | ) |  | const
 pure virtual

Return the threshold score for homologous peptide match (MIS only).

Return the 'qplughole' value of the query. This is the critical value for calculating the homology threshold. The value could be different depending on peptide type, as the emprical score distribution within a query can be different between (for example) the first and second pass of an error tolerant search.

Parameters
query | Query number, 1..getNumQueries().
pepType | Peptide match type.
Returns
qplughole value for the query and peptide match type.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getQuantitation()

bool getQuantitation ( ms_quant_configfile * qfile ) const
pure virtual

Returns an object that represents the embedded quantitation file as a reduced quantitation.xml file.

The return value indicates that the embedded quantitation file exists in the results file. Call ms_quant_configfile::isValid to determine whether the XML part has been parsed successfully.

For quantitation_2 and later, the contents of the file are validated against a schema by default. For quantitation_1, to explicitly validate against a schema, use ms_quant_configfile::setSchemaFileName() to choose a schema, and then use ms_quant_configfile::validateDocument() to validate.

See Object initialising functions in Perl, Java, Python and C#.

Deprecated:
See getQuantitationMethod() which is generally easier to use.
Parameters
qfile a pointer to quantitation file object. This must be a valid pointer to a valid object, which should normally be created using the default constructor: ms_quant_configfile::ms_quant_configfile
Returns
true if embedded file exists and false if it doesn't

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getQuantitationMethod()

bool getQuantitationMethod ( ms_quant_method * qm ) const

Return the quantitation method object from the embedded quantitation file.

This method returns true if all of the following apply:

  • the embedded quantitation file exists;
  • a valid schema file location has been set using the XMLschemaDirectory parameter in the constructor or the file exists in the default location;
  • the embedded quantitation file validates against the schema;
  • the quantitation method named in the QUANTITATION parameter exists;
  • the quantitation method can be loaded.

Otherwise the method returns false.

If the QUANTITATION parameter is empty or equals "none", then the method simply returns false. Otherwise, on failure, the method sets the warning ms_errors::ERR_MSP_QUANT_FAILEDLOAD.

Parameters
qm A pointer to quantitation method object. This must be a valid pointer to a valid object, which should normally be created using the default constructor ms_quant_method::ms_quant_method.
Returns
True if the method was loaded; false otherwise.

◆ getReferenceDatabaseNumberOfSL()

int getReferenceDatabaseNumberOfSL ( const int idx ) const
pure virtual

Return the database number of the reference database of a spectral library.

The reference database of a spectral library is either one of the databases searched – if the reference database was part of the actual search – or a virtual database whose number is above ms_searchparams::getNumberOfDatabases(). In the first case, getReferenceDatabaseNumberOfSL() returns a database number between 1 and ms_searchparams::getNumberOfDatabases(). In the second case, the number is above getNumberOfDatabases().

If idx does not refer to a spectral library, the method returns -1.

Parameters
idx Database number of the spectral library of interest, between 1 and ms_searchparams::getNumberOfDatabases() and whose type is SL (see getDatabaseType())
Returns
Database number of the reference database of the spectral library, or -1 if idx is not a spectral library.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getRepeatSearchString()

std::string getRepeatSearchString | ( | const int | query,
 |  | const bool | fullQuery = false
 | ) |  | const
 pure virtual

To perform a repeat search need to build up appropriate string.

If the 'fullQuery' parameter is false (the default) then the format will be:

mr from(observed, charge) query(querynum) etc.

If the 'fullQuery' parameter is true then the format will be:

mr from(observer, charge1, charge2...) ions() etc.

where 'etc' will be one or more of the following (split onto several lines here for readability):

 intensity(value) peptol(value, units) seq() comp()  tag() etag()
 title() instrument() it_mods() index() rtinseconds() rtinseconds[x]()
 scans scans[x]() rawscans rawscans[x]()
  • from contains the observed mass, and the charge found in the original search. If the fullQuery parameter is true, then the charge parameter may be a list of charge states to consider, in which case the mr value is for the first charge.
  • intensity will be returned if an intensity for the peptide was entered.
  • peptol will be returned if there is a specific tolerance override for this query. In dat28 format, it is taken from the PepTol= line in the queryx section of the results file. In MSR format, from the 'pep_tol' column in the query__data table.
  • seq() will be returned if there was a sequence query. It is the exact text that was entered by the user. In dat28 format, it comes from seq1= line in the queryx section of the results file. If there were multiple seq() commands in the original search, then these will be in the results file as seq1=, seq2= etc., and will be returned as seq(...) seq(...). In MSR format, the values are selected from the query__seq table.
  • comp() will be returned if there was a composition query. It is the exact text that was entered by the user. In dat28 format, it comes from comp1= line in the queryx section of the results file. If there were multiple comp() commands in the original search, then these will be in the results file as comp1=, comp2= etc., and will be returned as comp(...) comp(...). In MSR format, the values are selected from the query__comp table.
  • tag() will be returned if there was a tag query. It is the exact text that was entered by the user. In dat28 format, it comes from tag1=t line in the queryx section of the results file. If there were multiple tag() commands in the original search, then these will be in the results file as tag1=, tag2= etc., and will be returned as tag(...) tag(...). In MSR format, the values are selected from the query__seq_tag table.
  • etag() will be returned if there was a etag query. It is the exact text that was entered by the user. In dat28 format, it comes from tag1=e line in the queryx section of the results file. If there were multiple etag() commands in the original search, then these will be in the results file as tag1=, tag2= etc., and will be returned as etag(...) etag(...). In MSR format, the values are selected from the query__seq_tag table.
  • title will be returned if there was a title for the particular MS-MS spectrum. The title is returned as an escaped string.
  • instrument will be returned if there was an instrument defined at the query level in the original search. It is returned as an escaped string.
  • it_mods will be returned if modifications were defined at the query level in the original search. If there was more than modification, these will be returned as a comma separated list.
  • index will be returned if there was an index defined at the query level in the original search which will be the case for all searches in Mascot 2.3 and later. See ms_inputquery::getIndex.
  • scans or scans[x] will be returned if these were defined at the query level in the original search. They will have the format scans(29-34, 43) or scans[0](29-34) scans[1](43).
  • rtinseconds or rtinseconds[x] will be returned if these were defined at the query level in the original search. They will have the format rtinseconds(10-20, 25) or rtinseconds[0](10-20) rtinseconds[1](25).
  • rawscans or rawscans[x] will be returned if these were defined at the query level in the original search. They will have the format, for example, of: rawscans[0](pd0cy1ex1:pd0cy1ex3) rawscans[1](fn2ix1).
  • rawfile will be returned if these were defined at the query level in the original search. They will have the format, for example, of: rawfile(c:/data/rawfile.raw).
  • locus will be returned if these were defined at the query level in the original search. They will have the format, for example, of: locus(2.1.1.24.1).
  • query is only used for MS-MS spectra. To save data transfer with a repeat search, this command is used instead of resubmitting all the MS-MS ions values. When nph-mascot.exe comes to the query(x) command it gets the ions vales from the original .dat file
  • ions will be used to give a list of peaks.

Returns 0 if the value cannot be found and sets the error ms_errs::ERR_QUERYOUTOFRANGE.

See Automated repeating of searches.

Parameters
query | is a number in the range 1..getNumQueries()
fullQuery | If true, then a complete and self contained sequence query will be returned. See above for details
Returns
repeat search string

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
repeat_search.cpp, and resfile_input.cpp.

◆ getResfile()

const ms_mascotresfilebase * getResfile ( int id ) const
pure virtual

See Combining multiple results files and Maintaining object references: two rules of thumb.

Parameters
id is the the 1 based id of the results file and must be in the range 1..getNumberOfResfiles(). A value of 1 will (not particularly usefully!) return a pointer to the ms_mascotresfilebase that was originally created. A value of 2 will return ms_mascotresfilebase created in the first successful call to appendResfile(), and so on.
Returns
a pointer to the ms_mascotresfilebase object, or 0 if the parameter is invalid.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getSearchParameter()

std::string getSearchParameter ( const std::string & key ) const
pure virtual

Return the search parameter the given key.

Get the value associated with the input key in the search parameters. To get all the values, use ms_mascotresfilebase::getSearchParameterKeyValues().

Parameters
[in] key A non-empty string.
Returns
the value associated to the key, or empty if the key does not exist.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getSearchParametersKeyValues()

void getSearchParametersKeyValues | ( | std::vector< std::string > & | keys,
 |  | std::vector< std::string > & | values
 | ) |  | const
 pure virtual

Return all the search parameters as key-value pairs.

Get all the search parameters as key-value pairs. Search parameters are more easily accessible through ms_searchparams. This low-level method is useful for creating repeat searches, where the search parameters should just be copied as is.

To get the value of an individual header key, use ms_mascotresfilebase::getSearchParameter().

Parameters
[out] | keys | A vector of non-empty keys.
[out] | values | A vector of strings (some may be empty) in the same order as keys.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getSLDatabaseNumbersOfReference()

std::vector< int > getSLDatabaseNumbersOfReference ( const int idx ) const
pure virtual

Return the database numbers of the spectral libraries whose reference database is at the given index.

The reference database of a spectral library is either one of the databases searched – if the reference database was part of the actual search – or a virtual database whose number is above ms_searchparams::getNumberOfDatabases(). The same database can be the reference database of multiple spectral libraries.

If idx does not refer to a reference database, the method returns the empty vector.

Parameters
idx Database number of the reference database of interest.
Returns
A vector of database numbers of spectral libraries whose reference database idx is. This vector can be empty.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getSLExecCommand()

std::string getSLExecCommand ( int idx = 1 ) const
pure virtual

Returns the library search command line and parameters (sl_exec_command).

The command line for the library search is typically like:

    ../bin/NIST/mspepsearch/MSPepSearch.exe m a P /Z 0.1 /M 0.602993 /LIB [PATH_TO_MSP_FILE] /INP [PATH_TO_MSP_FILE] /OUTTAB [PATH_TO_TSV_FILE] /HITS 10 /MinMF 0 /NumCompared /OutPrecursorMz /OutDeltaPrecursorMz /OutSpecNum

The exact contents depend on the file paths, fragment tolerance and library search options specified in mascot.dat.

In dat28 format, the command string is saved as sl_exec_commandX= line in the header section.

In MSR format, the command string is saved in the search__spectral_libraries table as 'sl_exec_command'.

If idx is outside its range, the method returns the empty string.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the command line for the spectral library search of the given library.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getSLFragmentTolerance()

double getSLFragmentTolerance ( int idx = 1 ) const
pure virtual

Returns the effective spectral library fragment tolerance.

When a search is run against a spectral library, the effective fragment tolerance is calculated from the user-configured library fragment tolerance and the tolerance specified in the search parameters. This may be different from ms_searchparams::getITOL() and ms_searchparams::getITOLU().

The tolerance unit can be retrieved with getSLFragmentToleranceUnit().

In dat28 format, in Mascot 2.6.01 and later, the effective tolerance value and unit are saved in the header section of the results file as sl_itolX=. For files created by Mascot 2.6.00, the value is parsed from the sl_exec_commandX= line if present.

In MSR format, the effective tolerance value and unit are saved in the search__spectral_libraries table as 'itol'.

If idx is outside its range, the method returns 0.0.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the effective fragment tolerance.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getSLFragmentToleranceUnit()

std::string getSLFragmentToleranceUnit ( int idx = 1 ) const
pure virtual

Returns the unit of the effective spectral library fragment tolerance.

When a search is run against a spectral library, the effective fragment tolerance is calculated from the user-configured library fragment tolerance and the tolerance specified in the search parameters. This may be different from ms_searchparams::getITOL() and ms_searchparams::getITOLU().

The tolerance can be retrieved with getSLFragmentTolerance().

In dat28 format, in Mascot 2.6.01 and later, the effective tolerance value and unit are saved in the header section of the results file as sl_itolX=. For files created by Mascot 2.6.00, the value is parsed from the sl_exec_commandX= line if present.

In MSR format, the effective tolerance value and unit are saved in the search__spectral_libraries table as 'itol_units'.

If idx is outside its range, the method returns 0.0.

Parameters
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns
the tolerance unit.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getSrcQueryAndFileIdForMultiFile()

bool getSrcQueryAndFileIdForMultiFile | ( | const int | q,
 |  | int & | gsqNewQuery,
 |  | int & | gsqFileId
 | ) |  | const
 pure virtual

Return the query number and file ID in the source results file.

See Multiple return values in Perl, Java, Python and C#.

Useful for combining multiple results files (see Combining multiple results files) but also returns valid values for a single file.

Example: Assume that the primary results file has 10 queries, file 2 has 20 queries and file 3 has 30 queries. This function will return the following:

q | newQuery | fileId
6 | 6 | 1
21 | 11 | 2
31 | 1 | 3
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
See also
getMultiFileQueryNumber() for the 'inverse' function
Parameters
q | is the query number which should be a value between 1 and getNumQueries().
gsqNewQuery | is used to return the query number in the specified source file.
gsqFileId | is a 1 based index to the source file.
Returns
true if the query is in the range 1..getNumQueries().

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getTaxonomy()

bool getTaxonomy ( ms_taxonomyfile * tfile ) const
pure virtual

Returns an object that represents the embedded taxonomy file as a reduced taxonomy file.

The return value only indicates that the embedded file exists. If you want to find out whether the content has been parsed successfully, call the methods of matrix_science::ms_taxonomyfile.

See Object initialising functions in Perl, Java, Python and C#.

Parameters
tfile a pointer to taxonomy file object that will accept the content from the embedded taxonomy file.
Returns
true if the embedded taxonomy file was read and parsed.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getUnimod()

bool getUnimod | ( | ms_umod_configfile * | ufile,
 |  | bool | useSchemaFromResfile = false
 | ) |  | const
 pure virtual

Returns an object that represents the embedded unimod file as a reduced unimod_2.xml file.

The return value only indicates that the embedded Unimod XML exists in the results file. If you want to find out whether the XML part has been parsed successfully, call ms_umod_configfile::isValid

See Object initialising functions in Perl, Java, Python and C#.

Parameters
ufile | a pointer to unimod file object that will accept the XML content.
useSchemaFromResfile | determines where the location of the XML schema is defined. If 'true', then the schema location should have been defined by specifying XMLschemaDirectory in the constructor. If 'false', then ms_umod_configfile::setSchemaFileName must have been called on ufile before calling this function. This parameter was added in Parser 2.5, and the default value is false to ensure that it is backward compatible with previous versions.
Returns
true if embedded file exists and false if it doesn't.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getUnimodXL()

bool getUnimodXL | ( | ms_umod_configfile * | ufile,
 |  | bool | useSchemaFromResfile = false
 | ) |  | const
 pure virtual

Returns an object that represents the embedded unimod_xl file as a reduced unimod_xl.xml file.

The return value only indicates that the embedded Unimod crosslinking file exists in the results file. If you want to find out whether the XML part has been parsed successfully, call ms_umod_configfile::isValid

See Object initialising functions in Perl, Java, Python and C#.

Parameters
ufile | a pointer to unimod file object that will accept the XML content.
useSchemaFromResfile | determines where the location of the XML schema is defined. If 'true', then the schema location should have been defined by specifying XMLschemaDirectory in the constructor. If 'false', then ms_umod_configfile::setSchemaFileName must have been called on ufile before calling this function. getUnimodXL uses the same schema as ms_mascotresfilebase::getUnimod.
Returns
true if embedded file exists and false if it doesn't.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getUniqueTaskID()

std::string getUniqueTaskID ( ) const
pure virtual

Returns the unique task ID used by Mascot Daemon.

Although this value is a number, it is a 64 bit integer. Some languages on some platforms cannot deal with 64 bit integers properly, so the value is returned as a string. For searches with no taskid, an empty string is returned.

Returns
unique task id as a string

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ getXMLschemaFilePath()

std::string getXMLschemaFilePath ( XML_SCHEMA XMLschema ) const

Gets the XML schema to be used by functions using quantitation or unimod.

See also
setXMLschemaFilePath
Parameters
XMLschema The XML_SCHEMA enumeration value of the required xml schema file.
Returns
The requested xml schema value or an empty string if it has not been set.

◆ hasEnzyme()

bool hasEnzyme ( ) const
pure virtual

Return true if the results file contains information about the enzyme used.

Check whether the results file contains enzyme information as an embedded 'enzymes' file.

Returns
true if the file contains enzyme information. Always true for results from Mascot Server 2.2 and later.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ hasQuantitation()

bool hasQuantitation ( ) const
pure virtual

Return true if the results file contains quantitation data.

Check whether the results file contains an embedded quantitation method.

Returns
true if the file has an embedded quantitation method.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ hasRT()

bool hasRT ( ) const
pure virtual

Return true if the results file contains retention time data.

Check whether the first query has retention time stored in the RTINSECONDS field. If it does, return true. The implicit assumption is that all the other queries also have (or don't have) RTINSECONDS if the first query has (or doesn't have).

Returns
true if the file contains retention time data.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ isDatabaseTypeAvailable()

bool isDatabaseTypeAvailable ( ) const
pure virtual

Check whether database types are available.

In dat28 format, Mascot 2.6 and later save the type of the database(s) in the results file, as db_typeX= lines in the header section. If the types are not available, the database or databases searched could be AA or NA.

In MSR format, introduced in Mascot Server 3.0, the 'db_type' column is always present in the search__databases table.

Returns
Whether the db_typeX= lines exist or not in the dat28 results file. Always true in MSR format. false.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

◆ isErrorTolerant()

bool isErrorTolerant ( ) const
pure virtual

Returns true if the search was an error tolerant search.

In dat28 format, obtained from the ERRORTOLERANT value in the parameters section. In MSR format, obtained from the ERRORTOLERANT value in the search__parameters table.

In Mascot versions 1.8 and later, an error tolerant search can be run as a repeat search. In this case, one or more ACCESSIONs (which may be retrieved using ms_searchparams::getACCESSION ) must have been specified, and the results file will just contain the error tolerant search results. In Mascot 2.2 and later, a single search can be performed which contains both the standard search results and the error tolerant search results of automatically selected proteins. In this case, ms_searchparams::getACCESSION will return an empty string.

See Error tolerant searches.

See also
https://www.matrixscience.com/help/error_tolerant_help.html
Returns
true is the result file is from an error tolerant search, false otherwise

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ isMSMS()

bool isMSMS ( ) const
pure virtual

Returns true if the search was an MSMS search (SEARCH=MIS).

Since all types of search may be entered as a sequence query, it may be more useful to use the anyMSMS() member.

Returns
true if SEARCH=MIS in the parameters section or search__parameters table of the file.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
peptide_list.cpp, and resfile_info.cpp.

◆ isPMF()

bool isPMF ( ) const
pure virtual

Returns true if the search was a PMF search (SEARCH=PMF).

Since all types of search may be entered as a sequence query, it may be more useful to use the anyPMF() member.

Returns
true if SEARCH=PMF in the parameters section or search__parameters table of the file.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ isSQ()

bool isSQ ( ) const
pure virtual

Returns true if the search was a sequence query search (SEARCH=SQ).

Since all types of search may be entered as a sequence query, it may be more useful to use the anySQ() member.

Returns
true if SEARCH=SQ in the parameters section or search__parameters table of the file.

Implemented in ms_mascotresfile_dat, and ms_mascotresfile_msr.

Examples
resfile_info.cpp.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ outputKeepAlive()

bool outputKeepAlive ( ) const

Outputs the "keep-alive" string during time-consuming operations.

For HTML reports with large result files it is sometimes necessary to output HTML comments to keep the connection alive. This can be done by specifying the interval at which the text is output (keepAliveInterval) and the text that should be output (keepAliveText) as parameters to the ms_mascotresfilebase::ms_mascotresfilebase() constructor.

If the value of keepAliveInterval passed to ms_mascotresfilebase::ms_mascotresfilebase is not 0, then the text specfied by keepAliveText will be output approximately every keepAliveInterval seconds. A 'd' in the keepAliveText will be replaced by the number of seconds since the process started.

This functionality is implemented by calling this function 'often', rather than by using a separate thread. This means that the times between calls will not be accurate. A computationally intensive application that uses Mascot Parser can also call this function as required.

From version 2.3 onwards, the keepAliveText can contain tags that allow different text to be output for different lengthy tasks. The tags are:

  • ci= - output when creating a cache file.
  • rf= - output when reading the .dat file.
  • ap= - output when assigning peptides to proteins.
  • gp= - output when grouping proteins.
  • ul= - output when calling ms_peptidesummary::createUnassignedList()
  • qu= - output when calculating quantitation intensities for reporter or multiplex protocols.
  • cc= - output when creating a cache file as part of calling ms_peptidesummary::ms_peptidesummary
  • fd= - output when calling ms_mascotresults::getThresholdForFDRAboveIdentity or ms_mascotresults::getThresholdForFDRAboveHomology.

The text can also include the following tags which are substituted by values:

  • %d - The time elapsed since the initial call to ms-mascotresfile.
  • %p - The percentage complete for the current task.
  • %h - The hit number.
  • %q - The query number.
  • %a - The accession string for the current protein being processed.
  • %f - The filename of the .dat file being processed. May be useful for the ci= value with Combining multiple results files

The following table indicates which values are available for which tasks:

 | ci= | rf= | ap= | gp= | ul= | cc= | fd=
%d | X | X | X | X | X | X | X
%p | X | X | X | X | X | X | X
%h |  |  | X | X |  | X |
%q |  |  | X | X | X | X |
%a |  |  | X | X |  | X |
%f | X | X | X | X | X | X |

The %a and %h values for cc= are not output for the second half of caching.

A 'complete' example string might be: ' ul=Creating unassigned list (%p% complete)\n qu=Calculating quantitation component intensities (%p% complete)\ ci=Creating cache file (%p% complete)\n rf=Reading results file (%p% complete)\n ap=Assigning peptides to proteins (%p% complete) hit=%h, time=%d\n gp=Found protein group: %a, hit=%h, %p% complete, %d seconds\n cc=Caching results (%p% complete)\n fd=Calculating false discovery rate (%p% complete)\n '

Any text before the first tag will be used as a default for cases where text isn't supplied for a particular task. For example:

Processing: %p% complete gp=Grouping %a

would output the text:

Processing 23% complete

for all tasks except the protein grouping which would output:

Grouping gi|12345

Returns
true if the work is complete, false otherwise

◆ params()

ms_searchparams & params ( ) const
inline

Returns a reference to the search parameters class.

For C# only, params is a keyword, so this function is renamed to _params.

Returns
reference to the ms_searchparams object

◆ resetKeepAlive()

void resetKeepAlive | ( | const int | keepAliveInterval,
 |  | const char * | keepAliveText,
 |  | const bool | propagateToAppended = true,
 |  | const bool | resetStartTime = false
 | ) |  |

Replace the existing keepAlive values with new values.

KeepAlive values are passed when creating the ms_mascotresfilebase object, but it can be useful to change these at a later time.

See outputKeepAlive() for further details.

Parameters
keepAliveInterval | is the new interval in seconds. Specify a value of -1 to keep the old value, or 0 to stop outputting keepAliveText.
keepAliveText | is the text to output every keepAliveInterval seconds while the file is being loaded, or while other tasks are in progress.
propagateToAppended | only has meaning if additional files have been appended by calling appendResfile().
resetStartTime | can be set to true to reset the "%d" value to zero. See outputKeepAlive() for details.

◆ resfileType()

ms_mascotresfilebase::RESFILE_TYPE resfileType ( const std::string & fileName )
static

Return the results format of the file provided as an argument.

This method tries to open the file and 'sniff' the first few bytes. If those bytes are the SQLite database header, then this is a Mascot Search Results (MSR) file and the method returns RESFILE_MSR. If the bytes look like a MIME format header, then this is a dat28 (.dat) file and the method returns RESFILE_DAT28. In any other case, the method returns RESFILE_UNKNOWN.

Parameters
fileName relative or absolute path to the file to 'sniff'.
Returns
the file type.

◆ setErrorInfoFromString()

bool setErrorInfoFromString ( const std::string & e )
protected

For restoring any errors in the .cdb file

Parameters
e is the stored string obtained from calling getErrorInfoAsString
Returns
true if the input string is parsed successfully

◆ setPercolatorFeatures() [1/2]

void setPercolatorFeatures | ( | const char * | percolatorFeatures,
 |  | const char * | additionalFeatures,
 |  | const bool | useRetentionTimes
 | ) |  |

Set Percolator features before creating an ms_peptidesummary with Percolator scoring (deprecated).

Deprecated:
This function is deprecated and has been replaced with matrix_science::ms_mascotresfilebase::setPercolatorFeatures(const ms_mascotoptions&, const char*, const std::vector<std::string>&).

The names (and contents!) of the Percolator files depend on the features that have been enabled. When running from a report script on Mascot Server, turning on an additional feature in percolatorFeatures will cause Mascot to create a new file, but the old file will still be available if the feature is removed again from percolatorFeatures.

When running outside Mascot Server, the parameters passed to this method must match the parameters used by the report scripts, in order to get the same Percolator file names. If the pip/pop files are from Mascot Server 2.8 or later, please use matrix_science::ms_mascotresfilebase::setPercolatorFeatures(const ms_mascotoptions&, const char*, const std::vector<std::string>&) and the same mascot.dat options as were used on the server.

Parameters
percolatorFeatures | is normally retrieved by calling ms_mascotoptions::getPercolatorFeatures().
additionalFeatures | is normally a string passed to ms-createpip.exe. For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. An empty string means nothing is added or removed from ms_mascotoptions::getPercolatorFeatures().
useRetentionTimes | is a flag to indicate whether retention time information is used by percolator.exe. This value is normally retrieved by calling ms_mascotoptions::isPercolatorUseRT().

◆ setPercolatorFeatures() [2/2]

void setPercolatorFeatures | ( | const ms_mascotoptions & | options,
 |  | const char * | additionalFeatures,
 |  | const std::vector< std::string > & | adapterParameters = std::vector<std::string>()
 | ) |  |

Set Percolator features before creating an ms_peptidesummary with Percolator scoring.

The names (and contents!) of the Percolator files depend on the features that have been enabled. When running from a report script on Mascot Server, turning on an additional feature in PercolatorFeatures will cause Mascot to create a new file, but the old file will still be available if the feature is removed again from PercolatorFeatures.

The method uses the following fields from options:

  • PercolatorFeatures (string)
  • PercolatorUseRT (true/false)
  • PercolatorUseProteins (true/false)
  • PercolatorExeFlags (string)
  • PercolatorTargetRankScoreThreshold (int)
  • PercolatorTargetRankRelativeThreshold (double)

When running outside Mascot Server, the parameters passed to this method must match the parameters used by the report scripts, in order to get the same Percolator file names. If the pip/pop files are from Mascot Server 2.8 or later, please use the same mascot.dat options as were used on the server. Make sure you also use the same adapterParameters.

Parameters
options | contains the options stored in mascot.dat.
additionalFeatures | is normally a string passed to ms-createpip.exe For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default
adapterParameters | is a vector of parameters to ML adapters introduced in Mascot Server 3.0. If the vector is not empty, then the parameters are sorted and hashed into an additional MD5 checksum component of the pip/pop file names.

◆ setXMLschemaFilePath()

bool setXMLschemaFilePath | ( | XML_SCHEMA | XMLschema,
 |  | const char * | path
 | ) |  |

Sets the XML schema to be used by functions using quantitation or unimod.

It is generally easier to pass a directory as the XMLschemaDirectory parameter to the constructor rather than calling this function for each of the required schema.

Warning
if a relative path for the xsd is specified, then this will be relative to the document and not relative to the current working directory.

Example:

  std::string qs;
  qs  = "http://www.matrixscience.com/xmlns/schema/quantitation_1 ";
  qs += "C:/myfiles/quant_schema_1.xsd ";
  qs += "http://www.matrixscience.com/xmlns/schema/quantitation_2 ";
  qs += "../schema%20files/quantitation_2.xsd";
  setXMLschemaFilePath(XML_SCHEMA_QUANTITATION, qs.c_str());
*

The default values used in cases where this function has not been called and no parameter is passed to the constructor are the values suitable for scripts and programs running on the Mascot Server. These values are:

XML_SCHEMA_QUANTITATION :
    http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd
    http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd

XML_SCHEMA_UNIMOD :
    http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd

XML_SCHEMA_CROSSLINKING :
    http://www.matrixscience.com/xmlns/schema/crosslinking_1 ../html/xmlns/schema/crosslinking_1/crosslinking_1.xsd
Parameters
XMLschema | must be one of the valid XML_SCHEMA values
path | should be a list of pairs "_schema_alias_ SPACE _file_path_", where SPACE is the space character. See XML_SCHEMA for the supported _scheama_alias_ values for each type of schema
Returns
true if the XMLschema value is valid

◆ staticGetPercolatorFileNames() [1/2]

bool staticGetPercolatorFileNames | ( | const char * | szFileName,
 |  | const char * | cacheDirectory,
 |  | const char * | percolatorFeatures,
 |  | const char * | additionalFeatures,
 |  | const bool | useRetentionTimes,
 |  | std::vector< std::string > & | filenames,
 |  | std::vector< bool > & | exists
 | ) |  |
static

Returns a list of the Percolator input and output files for the specified data file (deprecated).

Deprecated:
This function is deprecated and has been replaced with matrix_science::ms_mascotresfilebase::staticGetPercolatorFileNames(const char*, const char*, const ms_mascotoptions&, const char *, const std::vector<std::string>&, std::vector<std::string>&, std::vector<bool>&).

This static function can be called without creating an ms_mascotresfilebase object, and can be used in advance of creating an object to see if the percolator files will need to be created. If an object has already been created, it is normally easier to call setPercolatorFeatures() and then getPercolatorFileNames().

See Using Percolator scores and Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
szFileName | is the absolute or relative path to the results file.
cacheDirectory | will normally be the value returned from ms_mascotoptions::getCacheDirectory. If it's empty, then the default pattern is used (../data/cache/%Y/%d).
percolatorFeatures | is normally retrieved by calling ms_mascotoptions::getPercolatorFeatures(). The filenames encode the features so that there is no conflict.
additionalFeatures | is normally a string passed to ms-createpip.exe. For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. Any other parameters except -a and -r are ignored. An empty string means nothing is added or removed from percolatorFeatures.
useRetentionTimes | is a flag to indicate whether retention time information is used by percolator.exe.
filenames | returns the list of files. The offsets are defined by ms_mascotresfilebase::PERCOLATOR_FILE_NAMES.
exists | is a boolean vector which will return flags indicating if the Percolator files exists. The values correspond to the values in filenames vector.
Returns
true if all files exist

◆ staticGetPercolatorFileNames() [2/2]

bool staticGetPercolatorFileNames | ( | const char * | szFileName,
 |  | const char * | cacheDirectory,
 |  | const ms_mascotoptions & | options,
 |  | const char * | additionalFeatures,
 |  | const std::vector< std::string > & | adapterParameters,
 |  | std::vector< std::string > & | filenames,
 |  | std::vector< bool > & | exists
 | ) |  |
static

Returns a list of the Percolator input and output files for the specified data file.

This static function can be called without creating an ms_mascotresfilebase object, and can be used in advance of creating an object to see if the percolator files will need to be created. If an object has already been created, it is normally easier to call setPercolatorFeatures() and then getPercolatorFileNames().

The function uses the following fields from options:

  • PercolatorFeatures (string)
  • PercolatorUseRT (true/false)
  • PercolatorUseProteins (true/false)
  • PercolatorExeFlags (string)
  • PercolatorTargetRankScoreThreshold (int)
  • PercolatorTargetRankRelativeThreshold (double)

Make sure you set PercolatorExeFlags in options based on whether the results file has any queries with a retention time. Otherwise, this method may generate a filename different from setPercolatorFeatures().

    bool anyRT = (whether any query has RTINSECONDS);
    std::string percolatorFlags = options.getPercolatorRtFlags(anyRT, options.isPercolatorUseRT());
    options.setPercolatorExeFlags(percolatorFlags.c_str());

See Using Percolator scores and Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
szFileName | is the absolute or relative path to the results file.
cacheDirectory | will normally be the value returned from ms_mascotoptions::getCacheDirectory. If it's empty, then the default pattern is used (../data/cache/%Y/%d).
options | contains the options stored in mascot.dat It is used to access the relevant options to generate the file names.
additionalFeatures | is normally a string passed to ms-createpip.exe. For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. Any other parameters except -a and -r are ignored. An empty string means nothing is added or removed from ms_mascotoptions::getPercolatorFeatures().
adapterParameters | is a vector of parameters to ML adapters introduced in Mascot Server 3.0. If the vector is not empty, then the parameters are sorted and hashed into an additional MD5 checksum component of the pip/pop file names.
filenames | returns the list of files. The offsets are defined by ms_mascotresfilebase::PERCOLATOR_FILE_NAMES.
exists | is a boolean vector which will return flags indicating if the Percolator files exists. The values correspond to the values in filenames vector.
Returns
true if all files exist

◆ versionGreaterOrEqual()

bool versionGreaterOrEqual | ( | int | major,
 |  | int | minor,
 |  | int | revision
 | ) |  | const

Compare the value returned by getMascotVer() with the passed version number.

Utility function to perform easy comparison. For example, to test if a results file could have taxonomy information, use:

if (versionGreaterOrEqual(2, 4, 0)) then ...

Note
Versions 2.3.1 to 2.4.0 of Mascot Parser returned the incorrect value. This was fixed in 2.4.1
Parameters
major | is the major version to be compared with
minor | is the minor version to be compared with
revision | is the minor revision to be compared with
Returns
Will return true if the version of the file is greater than or equal to the passed value

◆ willCreateCache() [1/2]

bool willCreateCache | ( | const char * | szFileName,
 |  | const ms_mascotoptions & | opts,
 |  | const char * | applicationName,
 |  | std::string & | resfileCacheFileName,
 |  | unsigned int & | cacheStatus
 | ) |  |
static

Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.

This static function can be called without creating an ms_mascotresfile_msr or ms_mascotresfile_dat object. It can be used in advance of creating the object to see if there will be a delay while (re)creating the cache file(s).

The purpose of this method is to get the status of the cache in addition of whether the cache will be created or not.

See Multiple return values in Perl, Java, Python and C#

See Static functions in Perl, Java, Python and C#

Parameters
[in] | szFileName | is the absolute or relative path to the Fxxxxx.dat file
[in] | opts | normally loaded from the mascot.dat file using ms_datfile::getMascotOptions()
[in] | applicationName | is the name of the application or script that is calling this function. The applicationName is searched for in the return value from ms_mascotoptions::getResultsCache and ms_mascotoptions::getResfileCache to determine if the application should be using cache files. If it is not found then the function returns false and sets the cacheStatus to ms_peptidesummary::RESFILE_CACHE_DISABLED_IN_OPTIONS. If null, or an empty string is passed, no check is made.
[out] | resfileCacheFileName | returns the name of the ms_mascotresfilebase cache file if one exists or would be created
[out] | cacheStatus | is the ms_peptidesummary::CACHE_STATUS enumeration which gives more details about why the cache file may or may not be created. Multiple values may be bitwise OR'd toegether.
Returns
true if either of the cache files will be (re-)created because they does not exist or are not complete or not up to date. It will return false if the options specify that the applicationName shouldn't create or use cache files.

◆ willCreateCache() [2/2]

bool willCreateCache | ( | const char * | szFileName,
 |  | const unsigned int | flags,
 |  | const char * | cacheDirectory,
 |  | std::string * | cacheFileName
 | ) |  |
static

Returns true if a cache file will be created when the ms_mascotresfile_dat constructor is called.

This static function can be called without creating an ms_mascotresfile_dat or ms_mascotresfile_msr object, and can be used in advance of creating an object to see if there will be a delay while (re)creating a cache file. The function has the same parameters as the ms_mascotresfilebase constructor.

The behaviour depends on the file type (ms_mascotresfilebase::resfileType()). If it is MSR, this method always returns false, because MSR files do not need a resfile cache. If it is dat28 format (.dat), a resfile cache may be needed.

See Static functions in Perl, Java, Python and C#

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | szFileName | - see ms_mascotresfilebase::ms_mascotresfilebase
[in] | flags | - see ms_mascotresfilebase::ms_mascotresfilebase
[in] | cacheDirectory | - see ms_mascotresfilebase::ms_mascotresfilebase
[out] | cacheFileName | - the full path name of the cache file. For languages other than C++, this will be a reference rather than a pointer to a std::string.
Returns
true if the cache file will be (re-)created because it does not exist or is not complete or not up to date. If the RESFILE_USE_CACHE flag has not been specified, it will always return false
The documentation for this class was generated from the following files:
  • ms_mascotresfilebase.hpp
  • ms_mascotresfilebase.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresults Class Reference

  • matrix_science
  • ms_mascotresults
Public Types | Public Member Functions | Protected Member Functions | List of all members
ms_mascotresults Class Referenceabstract
Mascot results file module

Abstract class for either ms_peptidesummary or ms_proteinsummary. More...

#include <ms_mascotresults.hpp>

Inheritance diagram for ms_mascotresults:
[legend]

Public Types

enum DB_MATCH_TYPE {
DM_FASTA = 0 ,
DM_SPECTRAL_LIBRARY = 1 ,
DM_BOTH = 2 ,
DM_FASTA_FIRST_PASS = 3 ,
DM_FASTA_SECOND_PASS = 4
}
Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram(). More...
enum DECOY_STATS_COUNT_TYPE {
DS_COUNT_PSM = 0 ,
DS_COUNT_SEQUENCE = 1
}
Type of object counted by getNumHitsAboveIdentity() and friends. More...
enum FIND_COMPARE_FLAGS {
FC_COMPLETESTR = 0x00000001 ,
FC_SUBSTR = 0x00000002 ,
FC_STARTSTR = 0x00000003 ,
FC_STRTOK = 0x00000004 ,
FC_MASK_STR_PART = 0x0000000F ,
FC_CASE_INSENSITIVE = 0x00000000 ,
FC_CASE_SENSITIVE = 0x00000010 ,
FC_MASK_CASE = 0x000000F0 ,
FC_FORWARD = 0x00000000 ,
FC_REVERSE = 0x00000100 ,
FC_MASK_DIRECTION = 0x00000F00 ,
FC_RESTRICT_TO_HIT = 0x00001000 ,
FC_LOOP_INTO_UNASSIGNED = 0x00002000 ,
FC_LOOP_FROM_UNASSIGNED = 0x00004000 ,
FC_UNASSIGNED_MASK = 0x00006000 ,
FC_SEARCH_ALL_RANKS = 0x00008000 ,
FC_ALL_PEPTIDES = 0x00000000 ,
FC_ALL_PEPTITDES = 0x00000000 ,
FC_SIGNIFICANT_PEPTIDES = 0x00010000 ,
FC_SEARCH_IGNORED_RANKS = 0x00020000 ,
FC_SCORING_MASK = 0x000F0000 ,
FC_PROTEIN_IGN_SAMESETS = 0x00100000 ,
FC_PROTEIN_IGN_SUBSETS = 0x00200000 ,
FC_PROTEIN_IGN_FAMILY = 0x00400000 ,
FC_PROTEIN_IGN_MASK = 0x00F00000 ,
FC_PROTEIN_INC_ALT_ACC = 0x01000000
}
Flags to specify how comparisons are performed in the find functions. More...
enum FIND_FLAGS {
FT_PEPTIDE_EXP_MZ = 0x00000001 ,
FT_PEPTIDE_EXP_MR = 0x00000002 ,
FT_PEPTIDE_CALC_MZ = 0x00000004 ,
FT_PEPTIDE_CALC_MR = 0x00000008 ,
FT_PEPTIDE_STRING = 0x00000010 ,
FT_PEPTIDE_QUERY = 0x00000020 ,
FT_PEPTIDE_VARMOD = 0x00000040 ,
FT_PEPTIDE_FIXMOD = 0x00000080 ,
FT_PEPTIDE_ETMOD = 0x00000100 ,
FT_PEPTIDE_SLMOD = 0x00000200 ,
FT_PEPTIDE_VARMOD_BYNAME = 0x00000400 ,
FT_PEPTIDE_FIND_MASK = 0x00000FFF ,
FT_PROTEIN_ACCESSION = 0x00001000 ,
FT_PROTEIN_DESCRIPTION = 0x00002000
}
Flags for findPeptides() and findProteins(). More...
enum FLAGS {
MSRES_NOFLAG = 0x00000000 ,
MSRES_GROUP_PROTEINS = 0x00000001 ,
MSRES_SHOW_SUBSETS = 0x00000002 ,
MSRES_SUBSETS_DIFF_PROT = 0x00000004 ,
MSRES_REQUIRE_BOLD_RED = 0x00000008 ,
MSRES_SHOW_ALL_FROM_ERR_TOL = 0x00000010 ,
MSRES_IGNORE_PMF_MIXTURE = 0x00000020 ,
MSRES_MUDPIT_PROTEIN_SCORE = 0x00000040 ,
MSRES_DECOY = 0x00000080 ,
MSRES_INTEGRATED_ERR_TOL = 0x00000100 ,
MSRES_ERR_TOL = 0x00000200 ,
MSRES_MAXHITS_OVERRIDES_MINPROB = 0x00000400 ,
MSRES_CLUSTER_PROTEINS = 0x00000800 ,
MSRES_DUPE_INCL_IN_SCORE_NONE = 0x00000000 ,
MSRES_DUPE_INCL_IN_SCORE_A = 0x00002000 ,
MSRES_DUPE_INCL_IN_SCORE_B = 0x00004000 ,
MSRES_DUPE_INCL_IN_SCORE_C = 0x00008000 ,
MSRES_DUPE_INCL_IN_SCORE_D = 0x00010000 ,
MSRES_DUPE_INCL_IN_SCORE_E = 0x00020000 ,
MSRES_DUPE_INCL_IN_SCORE_F = 0x00040000 ,
MSRES_DUPE_INCL_IN_SCORE_G = 0x00080000 ,
MSRES_DUPE_INCL_IN_SCORE_H = 0x00100000 ,
MSRES_DUPE_INCL_IN_SCORE_I = 0x00200000 ,
MSRES_DUPE_REMOVE_NONE = 0x00400000 ,
MSRES_DUPE_REMOVE_A = 0x00800000 ,
MSRES_DUPE_REMOVE_B = 0x01000000 ,
MSRES_DUPE_REMOVE_C = 0x02000000 ,
MSRES_DUPE_REMOVE_D = 0x04000000 ,
MSRES_DUPE_REMOVE_E = 0x08000000 ,
MSRES_DUPE_REMOVE_F = 0x10000000 ,
MSRES_DUPE_REMOVE_G = 0x20000000 ,
MSRES_DUPE_REMOVE_H = 0x40000000 ,
MSRES_DUPE_REMOVE_I = 0x80000000 ,
MSRES_DUPE_REMOVE_I = 0x80000000 ,
MSRES_DUPE_DEFAULT = 0x04800000
}
Flags for the type of results. More...
enum HOMOLOGY_THRESHOLD_SOURCE {
}
Flags for getHomologyThreshold() More...
enum IONS_HISTOGRAM {
IH_INCLUDE_TOP_MATCHES = 0x0000 ,
IH_INCLUDE_TOP_10_MATCHES = 0x0001
}
Flags for getIonsScoreHistogram(). More...
enum QUANT_COMPONENT_STATUS {
QCS_OK ,
QCS_OK_NO_MATCH ,
QCS_ERROR_NO_METHOD ,
QCS_ERROR_NO_COMPONENTS ,
QCS_ERROR_BAD_COMPONENT_NAME ,
QCS_OK_MULTIPLE_MATCHES
}
Return codes for getQuantitationComponentForPeptide(). More...
enum sortBy {
QUERY ,
SCORE ,
INTENSITY
}
Flags for createUnassignedList(). More...
enum THRESHOLD_TYPE {
TT_HOMOLOGY = 0x0000 ,
TT_IDENTITY = 0x0001 ,
TT_PEPSUM_DEFAULT = 0x0002
}
Flags for getPeptideThreshold() More...
enum TREE_CLUSTER_METHOD {
}
Flags for getTreeClusterNodes(). More...
enum UNIQUE_PEP_RULES {
UPR_WITHIN_FAMILY = 0x0001 ,
UPR_WITHIN_FAMILY_MEMBER = 0x0002 ,
UPR_IGNORE_SUBSET_PROTEINS = 0x0004 ,
UPR_DEFAULT = (UPR_WITHIN_FAMILY_MEMBER + UPR_IGNORE_SUBSET_PROTEINS)
}
Flags for isPeptideUnique(). More...

Public Member Functions

ms_mascotresults ()
ms_mascotresults is an abstract class; use ms_peptidesummary::ms_peptidesummary or ms_proteinsummary::ms_proteinsummary.
virtual bool | anyEmPAI () const
Return true if any emPAI values are available.
virtual bool | anyNumDiscoveredMods () const
Return true if modification discovery statistics are available.
void | cancelCreateSummary (bool newValue=true)
Cancel the call to createSummary()
virtual bool | createSummary ()
Create the summary after the ms_mascotresults object has been created.
bool | createUnassignedList (sortBy s=QUERY)
To have a list of unassigned peptides, need to call this first.
virtual int | findPeptides (const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const =0
Find the next hit that contains peptides with the specified attribute.
virtual int | findProteins (const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
Find the next hit that contains proteins with the specified attributes.
virtual int | findProteinsByAccession (const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
Find the next hit that contains proteins with the specified accession.
virtual int | findProteinsByDescription (const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
Find the next hit that contains proteins with the specified description.
virtual void | freeHit (const int hit)
Frees any memory associated with the passed hit number.
virtual int | getAllFamilyMembersWithThisPepMatch (const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const =0
Return a list of (top level) family proteins that have a match to the specified q and p.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const =0
Return a complete list of proteins that contain this same peptide match.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const =0
Return a complete list of proteins that contain this same peptide match.
virtual int | getAvePeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the average threshold value for all MS-MS data sets.
virtual bool | getComponentIntensity (const int q, const int p, const std::string &componentName, double &value, double &rawValue) const =0
Returns the component intensity for reporter or multiplex methods.
virtual const ms_protein * | getComponentProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
virtual std::string | getComponentString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const =0
Return q1_p2_comp string value; for h1_q2 this string is always empty.
bool | getCreateSummaryProgress (int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const
Return progress for the createSummary() call.
virtual std::vector< double > | getDiscoveredErrTolModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all error tolerant modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredErrTolModNames () const
Return the names of all error tolerant modifications discovered in this search.
virtual std::vector< double > | getDiscoveredLocalModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all query-level modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredLocalModNames () const
Return the names of all query-level modifications discovered in this search.
virtual double | getErrTolModDelta (const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const
Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.
virtual std::string | getErrTolModifiedNaSeq (const int q, const int p) const
Return the modified sequence of nucleic acids after a single base modification in an error tolerant search.
virtual std::vector< double > | getErrTolModMasterNeutralLoss (const int q, const int p) const
Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.
virtual std::string | getErrTolModMasterString (const int q, const int p) const =0
Return the error tolerant mod primary neutral loss string from h1_q2_et_mods_master or q1_p1_et_mods_master.
virtual std::string | getErrTolModName (const int q, const int p, std::string *modString=NULL) const
Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.
virtual double | getErrTolModNeutralLoss (const int q, const int p) const
Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.
virtual std::vector< double > | getErrTolModPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.
virtual std::string | getErrTolModPepString (const int q, const int p) const =0
Return the error tolerant mod peptide neutral loss string from h1_q2_et_mods_pep or q1_p1_et_mods_pep.
virtual std::vector< double > | getErrTolModReqPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.
virtual std::string | getErrTolModReqPepString (const int q, const int p) const =0
Return the error tolerant mod required peptide neutral loss string from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.
virtual std::vector< double > | getErrTolModSlaveNeutralLoss (const int q, const int p) const
Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.
virtual std::string | getErrTolModSlaveString (const int q, const int p) const =0
Return the error tolerant mod slave neutral loss string from h1_q2_et_mods_slave or q1_p1_et_mods_slave.
virtual std::string | getErrTolModString (const int q, const int p) const =0
Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.
virtual std::string | getErrTolOriginalNaSeq (const int q, const int p) const
Return the original sequence of nucleic acids before a single base modification in an error tolerant search.
virtual double | getErrTolProbabilityThreshold () const
unsigned int | getFlags () const
Returns the flags value passed to the constructor.
unsigned int | getFlags2 () const
Return the flags2 value passed to the ms_peptidesummary constructor.
virtual ms_protein * | getHit (const int hit, const int memberNumber=0) const
Return the ms_protein hit - returns null if hit > number of hits.
virtual int | getHomologyThreshold (const int query, double OneInXprobRnd, const int rank=1) const
Returns the 'homology' threshold.
virtual int | getHomologyThresholdForHistogram (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns the value for the 'yellow section' in the histogram.
virtual double | getIonsScore (const int q, const int p, const bool decoy) const =0
Returns an ions score quickly without having to load an ms_peptide object.
virtual std::vector< int > | getIonsScoreHistogram (IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns a list of counts for binned ions scores.
virtual std::string | getLibraryModString (const int q, const int p) const =0
Return the modification string of the spectral library match from q1_p1_SLmod.
virtual int | getMaxPeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the max threshold value for all MS-MS data sets.
virtual int | getMaxRankValue () const
Returns the maximum 'rank' or 'hit' or 'p' value.
int | getMinPepLenInPepSummary () const
Peptides shorter than this are ignored when putting proteins into groups.
virtual ms_protein * | getNextFamilyProtein (const int masterHit, const int id) const
Find the next protein in the family masterHit.
virtual ms_protein * | getNextSimilarProtein (const int masterHit, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSimilarProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProtein (const int masterHit, const int id, const bool searchWholeFamily=true) const
Return the next protein that contains some of the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains some of the peptides in the 'master' protein.
virtual int | getNumberOfFamilyMembers () const
Return the total number of family members.
virtual int | getNumberOfHits () const
Returns the number of hits in the results.
int | getNumberOfUnassigned () const
Return the number of peptides in the unassigned list.
virtual long | getNumDecoyHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the homology threshold.
virtual long | getNumDecoyHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the identity threshold.
virtual std::vector< int > | getNumDiscoveredErrTolMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of error tolerant modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredFixedMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of fixed modifications discovered in this search.
std::vector< int > | getNumDiscoveredIntactLinks (std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const
Return the count of intact crosslinks in this search.
std::vector< int > | getNumDiscoveredLibraryMods (const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of library modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredLocalMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of query-level modifications discovered in this search.
virtual int | getNumDiscoveredNonSpecCleavage () const
Return the count of non-specific cleavages in an error tolerant search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of variable modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const
Return the count of variable modifications discovered in this search.
virtual long | getNumHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the homology threshold.
virtual long | getNumHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the identity threshold.
virtual std::vector< int > | getPepsWithSameScore (const int q, const int p) const =0
Returns a list of 'p' values for peptides with the same score.
virtual ms_peptide | getPeptide (const int q, const int p) const =0
Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_proteinsummary).
virtual bool | getPeptide (const int q, const int p, ms_peptide *&pep) const =0
Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_proteinsummary).
virtual double | getPeptideExpectationValue (const double score, const int query, const int rank=0) const
Returns the expectation value for the given peptide score and query.
virtual int | getPeptideIdentityThreshold (const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the threshold value for this ms-ms data being a random match.
double | getPeptideThreshold (const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const
Return either the identity or the homology threshold.
virtual double | getProbabilityThreshold () const
Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.
virtual int | getProbFromScore (const double score) const
Returns a probability value given a score.
virtual double | getProbOfPepBeingRandomMatch (const double score, const int query) const
virtual double | getProbOfProteinBeingRandomMatch (const double score) const
virtual const ms_protein * | getProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
std::string | getProteinDescription (const char *accession, const int dbIdx=1) const
Return protein description if available.
virtual double | getProteinEmPAI (const char *accession, const int dbIdx=1, const int length=-1) const
Return protein emPAI if available.
virtual double | getProteinExpectationValue (const double score) const
Returns the expectation value for the given protein score.
double | getProteinMass (const char *accession, const int dbIdx=1) const
Return protein mass if available.
virtual int | getProteinScoreCutoff (double OneInXprobRnd) const =0
Return the 'protein' score value for cutting off results (different for peptide and protein summary).
virtual double | getProteinScoreForHistogram (const int num) const
Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.
virtual std::string | getProteinsWithThisPepMatch (const int q, const int p, const bool quotes=false)=0
Return a partial list of proteins that matched the same peptide.
void | getProteinTaxonomyIDs (const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const
Return the taxonomy ID(s), if any, from the results file.
virtual int | getProteinThreshold (double OneInXprobRnd) const
Return a threshold value for the protein summary report.
virtual int | getQmatch (const int query) const
[Deprecated] Return the number of peptides with masses that matched this query.
virtual int | getQmatch (const int query, const ms_mascotresfile_dat::section sec) const
[Deprecated] Use ms_mascotresfilebase::getQmatch().
virtual QUANT_COMPONENT_STATUS | getQuantitationComponentForPeptide (const matrix_science::ms_peptide &peptide, matrix_science::ms_quant_component &component, const matrix_science::ms_quant_method *method=NULL) const =0
Get the component in the quantitation method that matches the peptide.
virtual std::string | getReadableVarMods (const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return a 'human readable' string with the variable, summed and error tolerant mods.
const ms_mascotresfilebase & | getResfile () const
Return a reference to the resfile.
ms_mascotresults_params | getResultsParameters () const
Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.
double | getSequenceMass (const char *seq) const
Return the mass of a sequence (protein or peptide).
virtual int | getTagDeltaRangeEnd (const int q, const int p) const =0
Return the second number from h1_q2_drange=0,256.
virtual int | getTagDeltaRangeStart (const int q, const int p) const =0
Return the first number from h1_q2_drange=0,256.
virtual int | getTagEnd (const int q, const int p, const int tagNumber) const
Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagSeries (const int q, const int p, const int tagNumber) const
Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagStart (const int q, const int p, const int tagNumber) const
Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual std::string | getTagString (const int q, const int p) const =0
Return the complete tag string from h1_q2_tag or q1_p1_tag.
virtual std::string | getTerminalResiduesString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const =0
Return the complete terminal residue string from h1_q1_terms or q1_p1_terms.
bool | getThresholdForFDRAboveHomology (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveHomology (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.
double | getToleranceInDalton (bool &needMass, const double *const pMass=NULL) const
Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.
virtual bool | getTreeClusterNodes (const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, TREE_CLUSTER_METHOD tcm=TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const
Return distances and structure suitable for a dendrogram plot.
ms_peptide | getUnassigned (const int num) const
Need to call createUnassignedList() before calling this.
bool | getUnassignedIsBold (const int num) const
Returns true if the item indexed by num in the assigned list should be bold.
bool | getUnassignedShowCheckbox (const int num) const
Returns true if the item indexed by num in the assigned list should have a check box next to it.
bool | isEmPAIallowed () const
Return true if emPAI could be calculated using data in this results file.
bool | isNA () const
Returns TRUE for a search against a nucelic acid database.
virtual bool | isPeptideUnique (const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const =0
Returns true if this peptide match is unique to one protein or one protein family.
virtual void | setSubsetsThreshold (const double scoreFraction)
Specifies which subset proteins should be reported.

Protected Member Functions

double getIonsScoreCorrected (const double ionsScore, const long multiplicity) const

Detailed Description

Abstract class for either ms_peptidesummary or ms_proteinsummary.

The following functions provide threshold values:

  • getPeptideIdentityThreshold()
  • getAvePeptideIdentityThreshold()
  • getMaxPeptideIdentityThreshold()
  • getPeptideThreshold()
  • getProteinThreshold()
  • getHomologyThreshold()
  • getHomologyThresholdForHistogram()
  • getProbFromScore()
  • getProbOfPepBeingRandomMatch()
  • double getProbOfProteinBeingRandomMatch()
Examples
peptide_list.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

◆ DB_MATCH_TYPE

enum DB_MATCH_TYPE

Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram().

Enumerator
DM_FASTA | Mascot matches to FASTA sequences. This is the default.
DM_SPECTRAL_LIBRARY | Matches to spectral library entries. This was introduced in Parser 2.6.
DM_BOTH | Only valid for count of matches (getNumHitsAboveIdentity() and friends): the combined count for FASTA and spectral library entries.
DM_FASTA_FIRST_PASS | Mascot matches to FASTA sequences, first pass only.
DM_FASTA_SECOND_PASS | Mascot matches to FASTA sequences, second pass only (e.g. error tolerant).

◆ DECOY_STATS_COUNT_TYPE

enum DECOY_STATS_COUNT_TYPE

Type of object counted by getNumHitsAboveIdentity() and friends.

Enumerator
DS_COUNT_PSM | Count peptide-spectrum matches (PSMs). This is the default.
DS_COUNT_SEQUENCE | Count distinct peptide sequences. This was introduced in Parser 2.6.

◆ FIND_COMPARE_FLAGS

enum FIND_COMPARE_FLAGS

Flags to specify how comparisons are performed in the find functions.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

These flags are used in findProteins(), findPeptides() and the deprecated functions: findProteinsByAccession() and findProteinsByDescription(). The flags are used to specify how the comparison is performed and whether it should be a forward or reverse seach. Typically, three values will be combined together, using an OR operator; however, any default values do not need to be specifically specified.

  • Choose 1 of: FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK
  • Choose 1 of: FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE
  • Choose 1 of: FC_FORWARD, FC_REVERSE
  • Optionally choose FC_RESTRICT_TO_HIT or (FC_LOOP_INTO_UNASSIGNED and/or FC_LOOP_FROM_UNASSIGNED)
  • Optionally choose FC_SEARCH_ALL_RANKS
  • Optionally choose FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES
  • Optionally choose one or more of the FC_PROTEIN_IGN_ flags when calling findProteins()
Enumerator
FC_COMPLETESTR

Search for the complete string. If search item is a decimal number then match the number exactly.

FC_SUBSTR

Search for any substring. Not valid if search item is a decimal number.

FC_STARTSTR

String must match to start of target string. If search item is a decimal number then match to the same decimal precision of the filter value but rounded. For example a filter value of 1234.56 will return items with values in the range (1234.555 >= value < 1234.565).

FC_STRTOK

Supplied string is a set of tokens, for example "STY" could be used to search for S or T or Y in a peptide sequence.

FC_MASK_STR_PART

Bit mask to extract which one of FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK has been specified.

FC_CASE_INSENSITIVE

Case insensitive search (default).

FC_CASE_SENSITIVE

Case sensitive search.

FC_MASK_CASE

Bit mask to extract which one of FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE has been specified.

FC_FORWARD

Forward search. The returned hit number will be the same as or higher than the start hit number. (default).

FC_REVERSE

Reverse search. The returned hit number will be the same as or lower than the start hit number.

FC_MASK_DIRECTION

Bit mask to extract which one of FC_FORWARD, FC_REVERSE has been specified.

FC_RESTRICT_TO_HIT

Don't search beyond the specified hit number. Cannot be used with FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_LOOP_INTO_UNASSIGNED

If no matches are found in the passed hit, or any subsequent hit, then search the unassigned list.

FC_LOOP_FROM_UNASSIGNED

If the passed hit number is 0, and no match is found in the unassigned list, then start searching at 1 if FC_FORWARD is specified or start searching at 'numHits' if FC_REVERSE is specified.

FC_UNASSIGNED_MASK

Bit mask to extract FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_SEARCH_ALL_RANKS

For use with findPeptides() only. Ordinarily only those queries and ranks are searched that are assigned to a protein hit. Use this flag to search all ranks in such queries instead.

FC_ALL_PEPTIDES

Search all peptides regardless of score (default).

FC_ALL_PEPTITDES
Deprecated:
Unfortunate spelling error, please use FC_ALL_PEPTIDES which has an identical value.
FC_SIGNIFICANT_PEPTIDES

Only search peptides above identitity or homology threshold.

FC_SEARCH_IGNORED_RANKS

In integrated library mode, also search peptides that are part of a family member's list of ignored peptides.

FC_SCORING_MASK

Bit mask to extract FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES.

FC_PROTEIN_IGN_SAMESETS

Ignore sameset proteins - only used for findProteins()

FC_PROTEIN_IGN_SUBSETS

Ignore subset proteins - only used for findProteins()

FC_PROTEIN_IGN_FAMILY

Ignore family member proteins - only used for findProteins()

FC_PROTEIN_IGN_MASK

Ignore proteins flags.

FC_PROTEIN_INC_ALT_ACC

For use with findProteins() only. If protein entries in the database are representative (i.e. contain multiple accessions) and those accessions are saved in the results file (Mascot 2.4 or later), setting this flag will search all accessions of each protein entry, not just the first accession.

◆ FIND_FLAGS

enum FIND_FLAGS

Flags for findPeptides() and findProteins().

Details what needs to be searched for. Any of the FT_PEPTIDE_ flags may be used for either findPeptides() or findProteins(), but the FT_PROTEIN flags may only be used for findProteins()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
FT_PEPTIDE_EXP_MZ | Find an experimental m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_EXP_MR | Find an experimental relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_CALC_MZ | Find a calculated m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_CALC_MR | Find a calculated relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_STRING | Find a peptide string.
FT_PEPTIDE_QUERY | Find a query number.
FT_PEPTIDE_VARMOD | Find a variable modification. Specifiy the modification 'number' as the string.
FT_PEPTIDE_FIXMOD | Find a fixed modification. Specifiy the modification 'number' as the string.
FT_PEPTIDE_ETMOD | Find an error tolerant modification. Specifiy a delta mass as the string.
FT_PEPTIDE_SLMOD | Find a spectral library modification. Specifiy any substring of the mod name as the string.
FT_PEPTIDE_VARMOD_BYNAME | Find a variable or query level modification. Specify any substring of the mod name as the string.
FT_PEPTIDE_FIND_MASK | Bit mask for any of the peptide values to be found.
FT_PROTEIN_ACCESSION | Find an accession - findProteins() only.
FT_PROTEIN_DESCRIPTION | Find a description - findProteins() only.

◆ FLAGS

enum FLAGS

Flags for the type of results.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Not all of the flags applicable for protein summary (e.g. MSRES_REQUIRE_BOLD_RED); see ms_proteinsummary.

Enumerator
MSRES_NOFLAG | Does nothing.
MSRES_GROUP_PROTEINS | Group proteins with same peptide matches. See Grouping proteins together.
MSRES_SHOW_SUBSETS | Show proteins that only match a subset of peptides. See Grouping proteins together.
MSRES_SUBSETS_DIFF_PROT | Proteins that contain a subset of peptides are treated as a unique protein. See Grouping proteins together.
MSRES_REQUIRE_BOLD_RED | Only proteins that have a top scoring peptide not seen before will be returned.
MSRES_SHOW_ALL_FROM_ERR_TOL | If this flag is set, then all hits from error tolerant search are shown. See Error tolerant searches.
MSRES_IGNORE_PMF_MIXTURE | If this flag is set, then PMF mixtures are ignored. See Peptide mass fingerprint mixtures.
MSRES_MUDPIT_PROTEIN_SCORE | Protein scoring for the peptide summary was changed at Mascot 2.0 for large (MudPIT) searches. See ms_protein::getScore().
MSRES_DECOY | If this flag is set, then use the results from searching against the decoy database. See Target-decoy searches and false discovery rate.
MSRES_INTEGRATED_ERR_TOL | If this flag is set, then create a ms_peptidesummary object that contains results from the summary and et_summary section. See Error tolerant searches.
MSRES_ERR_TOL | If this flag is set, then create a ms_peptidesummary object that contains results from the et_summary section. See Error tolerant searches.
MSRES_MAXHITS_OVERRIDES_MINPROB | If minProbability and maxHitsToReport are both non zero, then minProbability is ignored when determining the number of proteins to be displayed. See ms_mascotresults::ms_mascotresults.
MSRES_CLUSTER_PROTEINS | Protein clustering introduced in Mascot 2.3. See Using MSRES_CLUSTER_PROTEINS.
MSRES_DUPE_INCL_IN_SCORE_NONE | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_A | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_B | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_C | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_D | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_E | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_F | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_G | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_H | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_I | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_NONE | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_A | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_B | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_C | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_D | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_E | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_F | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_G | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_H | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_I | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_I | See Treatment of duplicate peptides.
MSRES_DUPE_DEFAULT | Default parameter for treatment of duplicates. See Treatment of duplicate peptides.

◆ HOMOLOGY_THRESHOLD_SOURCE

enum HOMOLOGY_THRESHOLD_SOURCE

Flags for getHomologyThreshold()

The method getHomologyThreshold() accepts either a rank argument or one of the special enumerated values listed here. For backwards compatibility, the integers 1-20 have their own enumerated values.

Enumerator
HOMTHR_FASTA | Retrieve the homology threshold for FASTA matches.
HOMTHR_SL | Retrieve the homology threshold for spectral library matches.

◆ IONS_HISTOGRAM

enum IONS_HISTOGRAM

Flags for getIonsScoreHistogram().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
IH_INCLUDE_TOP_MATCHES | The default. Just include the top match to each spectrum.
IH_INCLUDE_TOP_10_MATCHES | Instead of just the top match, use the top 10 matches to each spectrum.

◆ QUANT_COMPONENT_STATUS

enum QUANT_COMPONENT_STATUS

Return codes for getQuantitationComponentForPeptide().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
QCS_OK | The component was retrieved successfully.
QCS_OK_NO_MATCH | The quantitation method's components were searched successfully, no matching component was found.
QCS_ERROR_NO_METHOD | There is no quantitation method available (e.g. for protein summary).
QCS_ERROR_NO_COMPONENTS | There are no components specified in the quantitation method (e.g. for non-precursor method).
QCS_ERROR_BAD_COMPONENT_NAME | The peptide's component name in the Mascot results does not match any component in the quantitation method.
QCS_OK_MULTIPLE_MATCHES | The quantitation method's components were searched successfully, multiple matching components were found.

◆ sortBy

enum sortBy

Flags for createUnassignedList().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
QUERY | Sort the unassigned list by ascending query number - this is the same as ascending relative mass order.
SCORE | Sort the unassigned list by descending score.
INTENSITY | Sort the unassigned list by descending intensity. Intensity values are taken from the qintensity value in the results file if they are available (from PKL files, or some MGF files). If these values are not available, then the intensity is calculated from the sum of all the ions values. For a very large MS-MS file, this option can take some time to process unless there are qintensity value in the results file.

◆ THRESHOLD_TYPE

enum THRESHOLD_TYPE

Flags for getPeptideThreshold()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TT_HOMOLOGY | Homology threshold.
TT_IDENTITY | Identity threshold.
TT_PEPSUM_DEFAULT | If ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH is specified in the constructor, then this will resolve to TT_HOMOLOGY, otherwise it will resolve to TT_IDENTITY.

◆ TREE_CLUSTER_METHOD

enum TREE_CLUSTER_METHOD

Flags for getTreeClusterNodes().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TCM_PAIRWISE_SINGLE | 's': pairwise single-linkage clustering.
TCM_PAIRWISE_MAXIMUM | 'm': pairwise maximum- (or complete-) linkage clustering.
TCM_PAIRWISE_AVERAGE | 'a': pairwise average-linkage clustering.

◆ UNIQUE_PEP_RULES

enum UNIQUE_PEP_RULES

Flags for isPeptideUnique().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Choose UPR_WITHIN_FAMILY or UPR_WITHIN_FAMILY_MEMBER and then optionally 'or' UPR_IGNORE_SUBSET_PROTEINS

Enumerator
UPR_WITHIN_FAMILY | The peptide is unique if it occurs in proteins that are part of a single family.
UPR_WITHIN_FAMILY_MEMBER | The peptide is unique if it occurs in proteins that just belong to a single family member.
UPR_IGNORE_SUBSET_PROTEINS | Ignore any susbset proteins that contain the match when deciding if a peptide is unique. However, if the peptide just belongs to subset proteins for the same hit, then it is still considered to be unique.
UPR_DEFAULT | Set to UPR_WITHIN_FAMILY_MEMBER | UPR_IGNORE_SUBSET_PROTEINS.

Member Function Documentation

◆ anyEmPAI()

bool anyEmPAI ( ) const
virtual

Return true if any emPAI values are available.

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns
true if above conditions are true and at least one protein has a non-zero emPAI value.

Reimplemented in ms_peptidesummary.

◆ anyNumDiscoveredMods()

bool anyNumDiscoveredMods ( ) const
virtual

Return true if modification discovery statistics are available.

Modification discovery counts for fixed and variable modifications (and error tolerant modifications in an error tolerant search) are only available if the results file contains a Unimod section. Since only significant rank 1 peptide matches assigned to a protein hit are inspected for modification counting purposes, it is possible for the counts to be zero even when a Unimod section exists.

Returns
True if number of modifications could be counted and there is at least one modification with a non-zero count; false otherwise.

◆ cancelCreateSummary()

void cancelCreateSummary ( bool newValue = true )

Cancel the call to createSummary()

It is normally recommended that an application should delete the ms_peptidesummary object after calling this function because some objects will still be in memory (no cleanup is performed).

Cancelling may not occur immediately, and the calling application needs to wait for the createSummary() call to return.

See also getCreateSummaryProgress() and ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE

Parameters
newValue should be set to true to cancel the createSummary call

◆ createSummary()

bool createSummary ( )
virtual

Create the summary after the ms_mascotresults object has been created.

Creating an ms_peptidesummary object for a large results file can take a considerable amount of time. The standard Mascot reports do not have an option to 'cancel' the creation of the report and rely on the ms_mascotresfilebase::outputKeepAlive() function to provide progress reports and keep the connection alive. This is not so desireable for a client application that doesn't want to redirect stdout, and wants to allow the user to cancel a long operation. Specify the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag when creating the ms_peptidesummary object, and then use one thread to call this function and a separate thread to call getCreateSummaryProgress() and report progress to the end user.

This function is called directly by the ms_mascotresults constructor unless the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag is specified. If that flag is specified, then the constructor returns 'immediately' and this function must be called by the client code. Until this function returns, the client code in the separate thread can only reliably call the getCreateSummaryProgress(), ms_mascotresfilebase::outputKeepAlive() or cancelCreateSummary() functions. Calling any other function for the ms_mascotresults object may result in undefined behaviour and cause the ms_mascotresfilebase::ERR_RESULTS_NOT_CREATED error to be set.

This function should not be called for a ms_proteinsummary.

Returns
true if successful

Reimplemented in ms_peptidesummary.

◆ createUnassignedList()

bool createUnassignedList ( sortBy s = QUERY )

To have a list of unassigned peptides, need to call this first.

See Unassigned peptides list for details of creating an unassigned list.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
s order to sort the unassigned list
Returns
Currently always returns true unless createSummary() has not completed
Examples
resfile_summary.cpp.

◆ findPeptides()

int findPeptides | ( | const int | startHit,
 |  | const std::string & | str,
 |  | FIND_FLAGS | item,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< int > & | q,
 |  | std::vector< int > & | p
 | ) |  | const
 pure virtual

Find the next hit that contains peptides with the specified attribute.

Note
For a protein summary, this function always returns -1.

Can be used to find peptide-spectrum matches with a specified query number, sequence, mass, or fixed or variable modification. Returns the protein hit number and a list of q,p values that contains one or more string matches to the input string.

In crosslinked searches, both alpha and beta peptides are compared to the search criteria. Only one needs to match the input string.

All subset, sameset and family member proteins are searched, and it is possible that the returned q and p values only correspond to peptides in a single subset protein. The FC_PROTEIN_IGN_SAMESETS, FC_PROTEIN_IGN_SUBSETS and FC_PROTEIN_IGN_FAMILY flags cannot be used with this function. To find proteins which contain particular peptide matches, or to control which proteins to search, see findProteins().

For FT_PEPTIDE_VARMOD , str should contain the modification 'number' as passed to ms_searchparams::getVarModsName(). Modification numbers between 1 and 9 correspond to strings "1" through "9", and numbers between 10 and 32 correspond to "A" through "W". To find all error tolerant modifications, specify "X" and then use ms_peptidesummary::getErrTolModName() to retrieve the name of the modification.

For FT_PEPTIDE_FIXMOD, str should contain the modification 'number' as passed to ms_searchparams::getFixedModsName(). This will be in the range 1-20.

For both types of modification searches, str should only contain a single character. The value for compareFlags should include FC_SUBSTR, because this function is implemented by searching the return value from ms_peptide::getVarModsStr(). Specifying incorrect flags does not generate an error and results in undefined behaviour.

There is an alternative way to search for fixed mods: specify FT_PEPTIDE_STRING and FC_STRTOK as item and compareFlags, respectively, and pass the return value of ms_searchparams::getFixedModsResidues() as the string to search for, str. Although this may seem equivalent to the combination FT_PEPTIDE_FIXMOD and FC_SUBSTR, there are two corner cases where the latter works while the former doesn't:

  • ms_searchparams::getFixedModsResidues() can return "N_term" or "C_term", which are clearly not strings of amino acids.
  • The case where a fixed mod is 'replaced' with a variable mod. For example, if Carbamidomethyl (C) is specified as a fixed mod and Propionamide (C) as variable mod, then it is not sufficient to just check if a peptide contains a cysteine.
Parameters
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1. To search the unassigned list, pass a value of 0.
str | is the string to be matched.
item | is the peptide item to be found (for example, the peptide sequence or mass). Any of the FT_PEPTIDE_ values may be used.
compareFlags | specifies whether the str value is required to match all or just part of the target string. It can also be used to specify a reverse search.
q | is a vector of query values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
p | is a vector of corresponding rank values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains all the returned matched items, or 0 if the match is in the unassigned list, or -1 if there is no match found.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ findProteins()

int findProteins | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | FIND_FLAGS | item,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const
 pure virtual

Find the next hit that contains proteins with the specified attributes.

Note
For a protein summary, this function always returns -1.

Used to find accessions, protein descriptions or proteins that have peptide matches with a specified query number, sequence, mass, or fixed or variable modification. Any of the FIND_FLAGS may be used.

The findPeptides() function does not return any information about which subset/sameset/family proteins in a hit contain the found matches. findProteins(), however, returns a list of the protein accessions that contained a peptide match that fits the search criteria, and also allows the searched proteins to exclude samesets (FC_PROTEIN_IGN_SAMESETS), subsets (FC_PROTEIN_IGN_SUBSETS or family members (FC_PROTEIN_IGN_FAMILY).

If protein entries in the database are representative (i.e. contain multiple accessions), by default only the first accession will be considered when FT_PROTEIN_ACCESSION is specified as a search item. If alternative accessions are saved in the results file (Mascot 2.4 or later), setting FC_PROTEIN_INC_ALT_ACC will search all accessions of each protein entry. Note that this will make the search slower.

Parameters
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the string to be matched and depends on the value of item. If item is FT_PROTEIN_ACCESSION, then str will be the accession (or part of one) to be matched. If item is one of the FT_PEPTIDE_ values, then see FIND_FLAGS and findPeptides() for operational details.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
item | is the accession, description or peptide item to be found. For example, return all proteins with a given peptide sequence or mass.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains the matches, or -1 if there is no match found.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ findProteinsByAccession()

int findProteinsByAccession | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const
 pure virtual

Find the next hit that contains proteins with the specified accession.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_ACCESSION flag.
Note
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with accessions that match to the the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Parameters
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ findProteinsByDescription()

int findProteinsByDescription | ( | const int | startHit,
 |  | const std::string & | str,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const
 pure virtual

Find the next hit that contains proteins with the specified description.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_DESCRIPTION flag.
Note
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with descriptions that match the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Descriptions are just those included in the results file. See getProteinDescription() for details of what is loaded into the results.

Parameters
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
compareFlags | specifies whether the str value is required to match all or just part of the description. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ freeHit()

void freeHit ( const int hit )
virtual

Frees any memory associated with the passed hit number.

Has no effect except when Using the pepsum cache (MSR and dat28). This function frees the ms_protein objects for the specified hit. The return values from getHit(), getNextFamilyProtein(), getNextSimilarProtein(), getNextSimilarProteinOf(), getNextSubsetProtein() etc. for this hit will then point to deleted objects and hence should not be used.

In addition, any ms_peptide objects loaded into memory using the getPeptide(const int, const int, ms_peptide *&)const function will 'unloaded' if the ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE has been specified. This function has no effect on the ms_peptide objects returned from the alternative getPeptide(const int, const int)const function.

Parameters
hit should be in the range 1.. getNumberOfHits().

Reimplemented in ms_peptidesummary.

◆ getAllFamilyMembersWithThisPepMatch()

int getAllFamilyMembersWithThisPepMatch | ( | const int | hit,
 |  | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | db,
 |  | std::vector< std::string > & | acc,
 |  | std::vector< int > & | dupe_status
 | ) |  | const
 pure virtual

Return a list of (top level) family proteins that have a match to the specified q and p.

Only the top level proteins are returned by this function, that is, the proteins that would be returned by getHit() and getNextFamilyProtein(). It will be considerably faster than calling ms_protein::getPeptideQuery() and related functions, because that involves loading more information from the cache and from the .dat file.

This function will return the values rapidly when caching is enabled; see Using the pepsum cache (MSR and dat28). It also functions correctly when not using the cache.

The returned vectors are all guaranteed to have the same number of elements. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use them from programming languages other than C++.

See also
getAllProteinsWithThisPepMatch() and getProteinsWithThisPepMatch()
Parameters
hit | Should be in the range 1.. getNumberOfHits().
q | is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
db | is a vector of database IDs.
acc | is the corresponding vector of accessions.
dupe_status | is the corresponding vector of ms_protein::DUPLICATE values for the returned proteins. Note that ms_protein::DUPE_Ignored will only appear in integrated library searches where the peptide match was removed due to IgnoreIonsScoreBelow.
Returns
The number of proteins in the db/acc/dupe_status vectors.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getAllProteinsWithThisPepMatch() [1/2]

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db
 | ) |  | const
 pure virtual

Return a complete list of proteins that contain this same peptide match.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

Crosslink searches only: If you need to know whether the accessions come from the alpha or beta peptide, use the 10-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also
getProteinsWithThisPepMatch()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues – one for each accession
end | Returns a vector of the end residues – one for each accession
pre | Returns a vector of the residue before the peptide – one for each accession
post | Returns a vector of the residue after the peptide – one for each accession
frame | Returns a vector of the frames – one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities – one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
Returns
A list of all the accessions that contained the peptide matched by this result.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getAllProteinsWithThisPepMatch() [2/2]

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db,
 |  | std::vector< int > & | psmComponent
 | ) |  | const
 pure virtual

Return a complete list of proteins that contain this same peptide match.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

This method was added in Parser 2.7 for crosslinking support. If you don't need to know whether the accessions come from the alpha or beta peptide, you can use the 9-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also
getProteinsWithThisPepMatch()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues – one for each accession
end | Returns a vector of the end residues – one for each accession
pre | Returns a vector of the residue before the peptide – one for each accession
post | Returns a vector of the residue after the peptide – one for each accession
frame | Returns a vector of the frames – one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities – one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
psmComponent | Returns a vector of psmComponent markers (ms_peptide::PSM) – one for each accession. For a crosslinked match, this will be one of ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA. In all other types of match, it will always be ms_peptide::PSM_COMPLETE.
Returns
A list of all the accessions that contained the peptide matched by this result.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getAvePeptideIdentityThreshold()

int getAvePeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtual

Return the average threshold value for all MS-MS data sets.

The average value is calculated by taking the mean value from calling getPeptideIdentityThreshold() for each query. This is the value that is used to be shown at the top of the standard Mascot reports in versions before Mascot 2.0. For example, threshold in the following string could be calculated by calling getAvePeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot score threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
The average score threshold. If there was no MS-MS data then -1 will be returned.

◆ getComponentIntensity()

bool getComponentIntensity | ( | const int | q,
 |  | const int | p,
 |  | const std::string & | componentName,
 |  | double & | value,
 |  | double & | rawValue
 | ) |  | const
 pure virtual

Returns the component intensity for reporter or multiplex methods.

This function will only succeed for MS2 based quantitation methods such as "reporter" and "multiplex" where the required data is in the .dat file. It is up to the calling application to check that this is the case using ms_mascotresfilebase::getQuantitationMethod and ms_quant_method::getProtocol

This function was added in Mascot Parser 2.5. If the calling application is Using the pepsum cache (MSR and dat28) and the cache files were created with Mascot Parser 2.4 or earlier, then this function will calculate the intensities on demand. The first call to this function causes values for the whole file to be calculated, which may be slow. With new cache files, all the values are saved in the cache file.

This function will only calculate values for cases where ms_quant_helper::isPeptideQuantifiable returns ms_quant_helper::PEPTIDE_IS_QUANTIFIABLE

For a particular q,p pair there will always be values for all components or for no components. There can never be a case where there is just a value available for a subset of the components.

Parameters
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue(). For "reporter" protocols, this must be 1.
componentName | is the name of the component as defined in the method. For example, for iTRAQ this might be "114", and for one of the SILAC methods this might be "Heavy".
[out] | value | is the corrected intensity value. Corrections are applied as specified in the method included in the results file.
[out] | rawValue | is the uncorrected intensity value.
Returns
false if the method is unable to calculate or determine an intensity value for the specified q and p values

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getComponentProtein()

const ms_protein * getComponentProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const
 virtual

Return a pointer to the protein entry given an accession.

Only use this function for the "components" of a UniGene search. It will generally be more convenient for client applications to call ms_protein::getComponent() to get an ms_protein object, both in UniGene searches and PMF mixture searches.

Parameters
accession | is the accession string.
dbIdx | a database index (1..ms_searchparams::getNumberOfDatabases()).
Returns
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

◆ getComponentString()

std::string getComponentString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const
 pure virtual

Return q1_p2_comp string value; for h1_q2 this string is always empty.

Note
This function will always return the empty string for a protein summary.

The entry in the results file might be, for example:

   q1_p2_comp=light

For a crosslinked match, the results file line is q1_p1_comp_1= or q1_p1_comp_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

See also ms_peptide::getComponentStr().

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'rank' number, which should be in the range 1..10.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns
the full component string for a peptide summary, and the empty string for a protein summary.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getCreateSummaryProgress()

bool getCreateSummaryProgress | ( | int * | cspTotalPercentComplete,
 |  | unsigned int * | cspCurrTask,
 |  | int * | cspCurrTaskPercentageComplete,
 |  | std::string * | cspAccession,
 |  | int * | cspHit,
 |  | int * | cspQuery,
 |  | std::string * | cspKeepAliveText
 | ) |  | const

Return progress for the createSummary() call.

See Multiple return values in Perl, Java, Python and C#.

This function is most useful when using the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag and calling createSummary() from a separate thread. The ms_mascotresfilebase::outputKeepAlive() outputs progress text to stdout, and this may not be convenient for some applications.

Any of the passed parameters may be null.

Parameters
[out] | cspTotalPercentComplete | is simply calculated from: 100 * cspCurrTask / ms_mascotresfilebase::KA_LAST + cspCurrTask / ms_mascotresfilebase::KA_LAST
[out] | cspCurrTask | is the ms_mascotresfilebase::KA_TASK currently being performed by Mascot Parser. If Parser is doing nothing, then this will be the last task that was completed and cspCurrTaskPercentageComplete will be 100
[out] | cspCurrTaskPercentageComplete | is the percentage (0..100) complete for the current cspCurrTask.
[out] | cspAccession | is the current 'accession' being processed. See ms_mascotresfilebase::outputKeepAlive() for details of which tasks set this value. For languages other than C++, this will be a reference rather than a pointer to a std::string.
[out] | cspHit | is the current hit being processed. See ms_mascotresfilebase::outputKeepAlive() for details of which tasks set this value
[out] | cspQuery | is the current 'query' being processed. See ms_mascotresfilebase::outputKeepAlive() for details of which tasks set this value
[out] | cspKeepAliveText | is the text that would be output by ms_mascotresfilebase::outputKeepAlive(). To use this, specify a suitable keepAliveText to the ms_mascotresfilebase constructor but set keepAliveInterval to zero to prevent any output to stdout. For languages other than C++, this will be a reference rather than a pointer to a std::string.
Returns
true if the createSummary() call has completed.

◆ getDiscoveredErrTolModDeltas()

std::vector< double > getDiscoveredErrTolModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const
virtual

Return the deltas of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification deltas. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

The list of error tolerant modification deltas is most useful when used in combination with getNumDiscoveredErrTolMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredErrTolModNames()

Nucleic acid insertion, deletion and substitution whose special names are NA_INSERTION, NA_DELETION and NA_SUBSTITUTION have a delta of 0.0.

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns
A vector of error tolerant modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getDiscoveredErrTolModNames()

std::vector< std::string > getDiscoveredErrTolModNames ( ) const
virtual

Return the names of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification names. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted. Nucleic acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

The list of error tolerant modification names is most useful when used in combination with getNumDiscoveredErrTolMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns
A vector of error tolerant modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getDiscoveredLocalModDeltas()

std::vector< double > getDiscoveredLocalModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const
virtual

Return the deltas of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredLocalModNames()

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns
A vector of query-level modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getDiscoveredLocalModNames()

std::vector< std::string > getDiscoveredLocalModNames ( ) const
virtual

Return the names of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns
A vector of query-level modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getErrTolModDelta()

double getErrTolModDelta | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL,
 |  | std::string * | deltaAsString = NULL
 | ) |  | const
 virtual

Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification delta will be 0.984020. In general, modification delta could be any valid floating point number, including 0.0.

See also
getErrTolModName(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the delta directly
deltaAsString
Returns
The modification delta.

◆ getErrTolModifiedNaSeq()

std::string getErrTolModifiedNaSeq | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the modified sequence of nucleic acids after a single base modification in an error tolerant search.

If an error tolerant search was made against a nucleic acid database, and if the NA sequence had an unsuspected insertion, deletion or substitution, then this method returns the modified NA sequence before translation.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'hit' or 'rank' number.
Returns
the modified sequence of nucleic acids before a single base modification in an error tolerant search

◆ getErrTolModMasterNeutralLoss()

std::vector< double > getErrTolModMasterNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p1_et_mods_master might be

   q1_p1_et_mods_master=1.0,2.0

The returned list will not contain the dominant neutral loss – that can be retrieved using getErrTolModNeutralLoss().

See also
getErrTolModSlaveNeutralLoss() and getErrTolModNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification additional primary neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModMasterString()

std::string getErrTolModMasterString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Return the error tolerant mod primary neutral loss string from h1_q2_et_mods_master or q1_p1_et_mods_master.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_master might be
       q1_p2_et_mods_master=1.0,2.0
  • The entry in h1_q2_et_mods_master might be
       h1_q2_et_mods_master=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModMasterNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant master neutral loss string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getErrTolModName()

std::string getErrTolModName | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL
 | ) |  | const
 virtual

Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification name will be Citrullination.

See also
getErrTolModDelta(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the name directly
Returns
The modification name, or empty string if this match has no ET modification.

◆ getErrTolModNeutralLoss()

double getErrTolModNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than 10 of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods might be

   q1_p1_et_mods=79.966330,97.976898,Phospho (STY)

where the highest scoring modification neutral loss, returned by this function is 97.976898.

See also
getErrTolModName(), getErrTolModDelta(), getReadableVarMods(), getErrTolModMasterNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification neutral loss value.

◆ getErrTolModPepNeutralLoss()

std::vector< double > getErrTolModPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.

Some modifications specify one or more peptide neutral losses. PepNeutralLoss allows a neutral loss from the precursor to be specified so that this peak is not treated as a noise peak when being scored by Mascot. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_pep might be

   q1_p1_et_mods_pep=97.976896, 79.966330
See also
getErrTolModReqPepNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification peptide neutral loss values as a vector of doubles See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModPepString()

std::string getErrTolModPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Return the error tolerant mod peptide neutral loss string from h1_q2_et_mods_pep or q1_p1_et_mods_pep.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_pep might be
       q1_p2_et_mods_pep=1.0,2.0
  • The entry in h1_q2_et_mods_pep might be
       h1_q2_et_mods_pep=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModPepNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant peptide neutral loss string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getErrTolModReqPepNeutralLoss()

std::vector< double > getErrTolModReqPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.

Some modifications specify one or more required peptide neutral losses. ReqPepNeutralLoss performs the same function as PepNeutralLoss but with the additional condition that the peak must be present in the spectrum. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_reqpep might be

   q1_p1_et_mods_reqpep=97.976896, 79.966330
See also
getErrTolModPepNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification required peptide neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModReqPepString()

std::string getErrTolModReqPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Return the error tolerant mod required peptide neutral loss string from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_reqpep might be
       q1_p2_et_mods_reqpep=1.0,2.0
  • The entry in h1_q2_et_mods_reqpep might be
       h1_q2_et_mods_reqpep=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModReqPepNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant required peptide neutral loss string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getErrTolModSlaveNeutralLoss()

std::vector< double > getErrTolModSlaveNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_slave might be

   q1_p2_et_mods_slave=1.0,2.0
See also
getErrTolModMasterNeutralLoss(), getErrTolModNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification slave neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModSlaveString()

std::string getErrTolModSlaveString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Return the error tolerant mod slave neutral loss string from h1_q2_et_mods_slave or q1_p1_et_mods_slave.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_slave might be
       q1_p2_et_mods_slave=1.0,2.0
  • The entry in h1_q2_et_mods_slave might be
       h1_q2_et_mods_slave=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModSlaveNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant slave neutral loss string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getErrTolModString()

std::string getErrTolModString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods might be
       q1_p2_et_mods=0.984020,0.000000,Citrullination
  • The entry in h1_q2_et_mods might be
       h1_q2_et_mods=0.984020,0.000000,Citrullination

This function returns the complete string value. More useful functions are

  • ms_mascotresults::getErrTolModName(),
  • ms_mascotresults::getErrTolModDelta(),
  • ms_mascotresults::getErrTolModNeutralLoss() and
  • ms_mascotresults::getReadableVarMods(),

all of which will work for both the protein summary and the peptide summary.

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant modification string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getErrTolOriginalNaSeq()

std::string getErrTolOriginalNaSeq | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the original sequence of nucleic acids before a single base modification in an error tolerant search.

If an error tolerant search was made against a nucleic acid database, and if the NA sequence had an unsuspected insertion, deletion or substitution, then this method returns the original NA sequence before translation.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'hit' or 'rank' number.
Returns
the original sequence of nucleic acids before a single base modification in an error tolerant search

◆ getErrTolProbabilityThreshold()

double getErrTolProbabilityThreshold ( ) const
virtual

For a protein summary, this method always returns the same value as getProbabilityThreshold().

Error tolerant matches in an integrated error tolerant search can have a different probability threshold (significance threshold) from first pass peptide matches. The first pass matches always use getProbabilityThreshold() as the significance threshold, and second pass matches always use getErrTolProbabilityThreshold().

The error tolerant significance threshold is determined using ms_mascotresults_params::getTargetFDR(). If a target FDR is specified and the search is an error tolerant target-decoy search, the probability threshold is chosen such that error tolerant matches have false discovery rate (FDR) equal to the target or as close as feasible. If the search is not a target-decoy search or target FDR is not specified, the error tolerant significance threshold is the same as the first pass significance threshold.

See also
getProbabilityThreshold(), Error tolerant searches
Returns
probability threshold for error tolerant matches.

◆ getFlags()

unsigned int getFlags ( ) const

Returns the flags value passed to the constructor.

Returns
the ms_mascotresults::FLAGS value.

◆ getFlags2()

unsigned int getFlags2 ( ) const

Return the flags2 value passed to the ms_peptidesummary constructor.

For an ms_proteinsummary, will always return 0 as there is no option to set the flags2 value.

Returns
the ms_peptidesummary::MSPEPSUM value.

◆ getHit()

ms_protein * getHit | ( | const int | hit,
 |  | const int | memberNumber = 0
 | ) |  | const
 virtual

Return the ms_protein hit - returns null if hit > number of hits.

Parameters
hit | should be in the range 1.. getNumberOfHits().
memberNumber | Should be 1 or less for a main protein or one not in a family, or 2 or more for later sibling proteins in the hit family. If this number is greater than the number of proteins in the hit family then the function returns a null value.
Returns
If the hit number is outside the range above, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

Examples
peptide_list.cpp, and resfile_summary.cpp.

◆ getHomologyThreshold()

int getHomologyThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1
 | ) |  | const
 virtual

Returns the 'homology' threshold.

For MS-MS data only, this returns a threshold value for significant homology rather than identity. This value appears in the yellow popup box for an MS-MS result: Score greater than XX indicates homology.

The return value will be zero if the threshold is not available. The value cannot be determined if the query contains error tolerant matches, or if the query contains a tag or etag, or if the value of qmatch is less than or equal to 100.

The value returned will not be higher than the identity threshold.

In versions prior to 2.2, the homology threshold was not affected by OneInXprobRnd – this was corrected in version 2.2.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. You can either pass ms_peptide::getRank() as the rank parameter, or use one of the enumerated values for HOMOLOGY_THRESHOLD_SOURCE. The rank determines the data source.

In an integrated spectral library search:

  • If rank = HOMTHR_FASTA, the method returns the FASTA homology threshold.
  • If the peptide at the given rank is from a FASTA database and is not a library match, the method returns the FASTA homology threshold.
  • If rank = HOMTHR_SL, the method returns zero (since library searches don't have a homology threshold).
  • If the peptide at the given rank is from a spectral library, the method returns zero.

In an integrated error tolerant search, behaviour depends on Mascot version. If the results file is from Mascot 2.8 or later:

  • If the query was selected for the second pass search, the method returns zero regardless of the rank argument.
  • If the query was only searched in the first pass, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().

If the integrated error tolerant search is from Mascot 2.7 or earlier:

  • If rank = HOMTHR_FASTA, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().
  • If the peptide at the given rank is a first pass match, the method returns the first pass homology threshold.
  • If the peptide at the given rank is an ET match, the method returns 0.
Parameters
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
Returns
The homology threshold. If there was no MS-MS data for this query then 0 will be returned.
Examples
resfile_summary.cpp.

◆ getHomologyThresholdForHistogram()

int getHomologyThresholdForHistogram | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtual

Returns the value for the 'yellow section' in the histogram.

For MS-MS data only, this returns a homology (rather than identity) threshold value that is shown at the top of the report: Individual ions scores > 19 indicate peptides with significant homology (p<0.05).

The yellow area on the histogram also corresponds to this value.

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot homology threshold. If dbType is DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
The homology threshold. Note that this value is only available for an MS-MS search with just one MS-MS data set, otherwise the return value will be zero.

◆ getIonsScore()

double getIonsScore | ( | const int | q,
 |  | const int | p,
 |  | const bool | decoy
 | ) |  | const
 pure virtual

Returns an ions score quickly without having to load an ms_peptide object.

If other values are required from the ms_peptide object, then it is normally faster to call getPeptide() and then ms_peptide::getIonsScore

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
decoy is a flag to indicate if the score should be taken from the decoy section. This should only be set to true for searches with decoy matches.
Returns
the score, or 0 if there was no score for these q / p values.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getIonsScoreCorrected()

double getIonsScoreCorrected | ( | const double | ionsScore,
 |  | const long | multiplicity
 | ) |  | const
 protected
Note
It shouldn't be necessary to call this function from outside the library.

This function is required here rather than as part of the ms_peptide object because one ms_peptide object can be used from many different proteins – each with a different multiplicity factor.

This function subtracts the factor:

  • -10 * log(multiplicity) * $tolFact / log(10); where
  • tolFact = sqrt(ITOL * ITOL + 0.0625);
Parameters
ionsScore | Is the uncorrected ions score.
multiplicity | can be obtained from ms_protein::getPeptideMultiplicity.
Returns
The corrected value..

◆ getIonsScoreHistogram()

std::vector< int > getIonsScoreHistogram | ( | IONS_HISTOGRAM | flags = IH_INCLUDE_TOP_MATCHES,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtual

Returns a list of counts for binned ions scores.

  • The first element of the array returns the count of matches with a score between 0 and 1.
  • The second element of the array returns the count of matches with a score between 1 and 2.
  • The third element of the array returns the count of matches with a score between 2 and 3. etc. etc.
Parameters
flags | Currently only IH_INCLUDE_TOP_MATCHES and IH_INCLUDE_TOP_10_MATCHES are supported.
dbType | If given, should be DM_FASTA for Mascot scores and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, empty vector is returned.)
Returns
a vector of integers. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getLibraryModString()

std::string getLibraryModString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Return the modification string of the spectral library match from q1_p1_SLmod.

The modification string has the format

 q1_p1_SLmod=position:mod,position:mod,...

where position is a 1-based index into the peptide sequence and mod is a numeric index into the spectral_library section of the results file. The modification name and delta can be found with ms_searchparams::getLibraryModName() and ms_searchparams::getLibraryModDelta().

Note that position 1 is the first residue of the peptide sequence, which is the same convention as with ms_peptide::getVarModsStr(). However, MSPepSearch reports terminal modifications as modifications on the first and last residue. Positions 0 and N+1 (if sequence length is N) are reserved for future use.

For Mascot matches, the library modification string is empty.

In protein summary, this method always returns the empty string.

See also
Spectral libraries.
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the rank number.
Returns
modification string of the match if it is a spectral library match and has modifications, and empty string otherwise.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getMaxPeptideIdentityThreshold()

int getMaxPeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtual

Return the max threshold value for all MS-MS data sets.

The maximum value is calculated by taking the maximum value returned by calling getPeptideIdentityThreshold() for each query. This is the value that is shown at the top of the standard Mascot peptide summary report (version 2.0 and later). For example, threshold in the following string could be calculated by calling getMaxPeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Versions of Mascot prior to 2.0 displayed the equivalent of getAvePeptideIdentityThreshold().

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
The maximum score threshold. If there was no MS-MS data then -1 will be returned.

◆ getMaxRankValue()

int getMaxRankValue ( ) const
virtual

Returns the maximum 'rank' or 'hit' or 'p' value.

For functions such as getPeptide(), a 'rank' or 'hit' value is required. The allowable range for this values depends on whether it is a protein summary or peptide summary.

For a peptide summary the value returned will normally be 10, but for an integrated error tolerant search, integrated spectral library search and integrated crosslinked search, this can be in the range 1..20.

For a protein summary the return value will be ms_mascotresfilebase::getNumHits() – with the appropriate parameter passed for the case of a decoy or error tolerant search.

Returns
max rank value

◆ getMinPepLenInPepSummary()

int getMinPepLenInPepSummary ( ) const

Peptides shorter than this are ignored when putting proteins into groups.

minPepLenInPepSummary is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins together.

Specify this value when creating an ms_peptidesummary::ms_peptidesummary object. This value will always be zero for ms_proteinsummary.

Returns
The minimum peptide length considered when creating the peptide summary.

◆ getNextFamilyProtein()

ms_protein * getNextFamilyProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const
 virtual

Find the next protein in the family masterHit.

Call this function multiple times for each masterHit, incrementing id each time. When there are no more protein families this function will return a null value.

The main protein for the hit should be obtained by calling ms_mascotresults::getHit()

See Using MSRES_CLUSTER_PROTEINS for further information.

See also
ms_protein::GROUP
Parameters
masterHit | is the id for the main hit (1..n).
id | is a 'one based' number.
Returns
The next protein family or a null value if there is no such group. See Maintaining object references: two rules of thumb.
Examples
resfile_summary.cpp.

◆ getNextSimilarProtein()

ms_protein * getNextSimilarProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const
 virtual

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP
Parameters
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
Returns
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.

◆ getNextSimilarProteinOf()

ms_protein * getNextSimilarProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const
 virtual

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP
Parameters
masterAccession | is the accession for the main hit.
masterDB | is the database (FASTA) ID for the main hit.
id | is a 'one based' number.
Returns
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.
Examples
resfile_summary.cpp.

◆ getNextSubsetProtein()

ms_protein * getNextSubsetProtein | ( | const int | masterHit,
 |  | const int | id,
 |  | const bool | searchWholeFamily = true
 | ) |  | const
 virtual

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP, getNextSubsetProteinOf()
Parameters
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
searchWholeFamily | only has meaning when MSRES_CLUSTER_PROTEINS is specified. See Using MSRES_CLUSTER_PROTEINS.
Returns
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.

◆ getNextSubsetProteinOf()

ms_protein * getNextSubsetProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const
 virtual

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information.

Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP, getNextSubsetProtein()
Parameters
masterAccession | is the accession for the master hit or a family hit.
masterDB | is the database (fasta) ID for the main hit.
id | is a 'one based' number.
Returns
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.
Examples
resfile_summary.cpp.

◆ getNumberOfFamilyMembers()

int getNumberOfFamilyMembers ( ) const
virtual

Return the total number of family members.

Returns
This function returns the number of 'top level' hits and family members, not taking into account any proteins that are identical or subsets of these hits. The value will be identical to that returned by getNumberOfHits() unless the ms_mascotresults::MSRES_CLUSTER_PROTEINS flag has been specified. In that case the number of values returned by getNextFamilyProtein() will be included.

◆ getNumberOfHits()

int getNumberOfHits ( ) const
virtual

Returns the number of hits in the results.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
This function returns the number of 'top level' hits – not taking into account any proteins that are identical or subsets of the 'top level' hits. ms_mascotresults::getHit() can be called with any number from 1 to the value returned by this function.

◆ getNumberOfUnassigned()

int getNumberOfUnassigned ( ) const

Return the number of peptides in the unassigned list.

See Unassigned peptides list for details of creating and using an unassigned list.

If there is no cache file for the results, then createUnassignedList() must be called before calling this function or the ms_errs::ERR_UNASSIGNED_PROG error will be set, and this function will return 0.

If a cache file has been created, then there is no requirement to call createUnassignedList() before calling this function.

Returns
the number of peptides in the unassigned list, or 0 in the case of an error.
Examples
resfile_summary.cpp.

◆ getNumDecoyHitsAboveHomology()

long getNumDecoyHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtual

Return the number of hits from the decoy search with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold(). These values may be slightly different from the threshold for the non-decoy matches.

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

y* The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of decoy hits with a score at or above the homology threshold.

◆ getNumDecoyHitsAboveIdentity()

long getNumDecoyHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtual

Return the number of hits from the decoy search with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold(). This value may be slightly different from the threshold for the non-decoy matches.

For a protein summary, the number of hits is the number of protein matches. This number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of decoy hits with a score at or above the identity threshold.

◆ getNumDiscoveredErrTolMods()

std::vector< int > getNumDiscoveredErrTolMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtual

Return the count of error tolerant modifications discovered in this search.

The number of times an error tolerant modification has been discovered in the search is the number of times it appears in rank 1 matches in the search results. Since the number and kind of error tolerant modifications is (practically) unlimited, you should call getDiscoveredErrTolModNames() first to find out which error tolerant modifications appear in the search. (The count of error tolerant modifications that do not appear in the search is, of course, zero.) Amino acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

Only significant rank 1 matches assigned to a protein hit are counted. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the error tolerant modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
modName | Error tolerant modification name (as returned by getDiscoveredErrTolModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the error tolerant modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredFixedMods()

std::vector< int > getNumDiscoveredFixedMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtual

Return the count of fixed modifications discovered in this search.

The number of times a fixed modification has been discovered in the search is the number of times the terminus or residue matching its specificity appears in significant rank 1 matches assigned to a protein hit in the search results. For example, if Carbamidomethyl (C) is specified as a fixed modification, then the number of times it has been discovered in the search is the number of C residues in peptide sequences in significant rank 1 matches assigned to a protein hit.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the fixed modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a fixed modification with two different specificities in the search, discovery counts will be returned separately. For example, if fixed modification 1 is Carbamidomethyl (C) and 2 is Carbamidomethyl (N-term), then calling getNumDiscoveredFixedMods() with num = 1 returns the Carbamidomethyl count for specificity "Anywhere" and "C", while num = 2 returns the count for specificity "Any N-term" and "N-term". In both cases each vector contains a single item.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
num | Fixed modification number (same value as passed to ms_searchparams::getFixedModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the fixed modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredIntactLinks()

std::vector< int > getNumDiscoveredIntactLinks | ( | std::vector< int > & | varModNum1,
 |  | std::vector< std::string > & | position1,
 |  | std::vector< std::string > & | site1,
 |  | std::vector< int > & | varModNum2,
 |  | std::vector< std::string > & | position2,
 |  | std::vector< std::string > & | site2,
 |  | std::vector< int > & | numLinkedPeptides
 | ) |  | const

Return the count of intact crosslinks in this search.

The number of times an intact crosslink has been discovered in the search is the number of times it appears as the intact link in significant rank 1 matches assigned to a protein hit.

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the link occurred, while varModNum1, position1 and site1 have the variable mod number, position and site of the first end of the link and varModNum2, position2 and site2 have the second end.

For example, if the ith specificity is N-terminal K, the ith element of alphaPositions would be "Any N-term" and the ith element of alphaSites would be "K".

In the simplest case, there is one linker with one specificity, say Xlink:DSS (K). All the vectors have just one element. If the linker has two specificities, like Xlink:DSS (K) and Xlink:DSS (Protein N-term), there will be three site pairs: (K, K), (K, Protein N-term) and (Protein N-term, Protein N-term). The pair (Protein N-term, K) is collated with (K, Protein N-term).

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
varModNum1 | Variable modification number for the first end of link.
position1 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site1 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
varModNum2 | Variable modification number for the second end of link.
position2 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site2 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
numLinkedPeptides | A vector containing the number of linked peptides corresponding to each count. Looplinked counts have 1 peptide, while crosslinked counts have 2 peptides.
Returns
The number of times the intact link was observed in significant rank 1 matches assigned to a protein hit.

◆ getNumDiscoveredLibraryMods()

std::vector< int > getNumDiscoveredLibraryMods | ( | const int | modId,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const

Return the count of library modifications discovered in this search.

The number of times a library modification has been discovered in the search is the number of times it appears in the library mods string in significant rank 1 spectral library matches assigned to a protein hit in the search results.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the library modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that modifications are part of the metadata of spectral library entries. Unlike in database searches, they are not specified as part of the search parameters. Some caveats apply:

  • A library modification may have the same name as a variable or fixed modification in the database search, and they may well be the same modification – but you need to know how the library was constructed to conclude either way.
  • Library modification name is usually a free-text string, which may or may not be a Unimod modification name.
  • The MSP format for spectral libraries does not support specifities in the same way as Mascot. The "position" of the modification is not encoded in the library and is thus unknown; it will always be Anywhere.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
modId | modification ID, same as passed to ms_searchparams::getLibraryModName(). Must be in range 1..ms_searchparams::getNumberOfLibraryMods().
positions | A vector of positions, always "Anywhere".
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the library modification was observed in significant rank 1 spectral library matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredLocalMods()

std::vector< int > getNumDiscoveredLocalMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtual

Return the count of query-level modifications discovered in this search.

The number of times a query-level modification has been discovered in the search is the number of times it appears in significant rank 1 matches assigned to a protein hit in the search results.

Query-level modifications are counted separately from variable modifications (specified at search form level), because each individual query may contain up to 32 query-level variable modifications. This means the search as a whole may contain more than 32 different query-level modifications. You should call getDiscoveredLocalModNames() first to find out which query-level modifications appear in the search.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the query-level modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that only significant rank 1 matches assigned to a protein hit are counted.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
modName | Query-level modification name (as returned by getDiscoveredLocalModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the query-level modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredNonSpecCleavage()

int getNumDiscoveredNonSpecCleavage ( ) const
virtual

Return the count of non-specific cleavages in an error tolerant search.

An error tolerant match is the product of non-specific cleavage when the residue before or after the peptide terminal residue does not match the cleavage specificity of the enzyme. For example, trypsin cleaves at C-term K or R (unless followed by P), so all tryptic peptide sequences have K or R as the (N-term) residue before the sequence. An error tolerant match with non-specific cleavage would have a residue other than K or R at N-terminus.

Only significant rank 1 matches assigned to a protein hit contribute towards the count of non-specific cleavages. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the match is not counted.

Returns
The number of times non-specific cleavage occurred in significant rank 1 matches assigned to a protein hit, or -1 for non-error tolerant search.

◆ getNumDiscoveredVariableMods() [1/2]

std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtual

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

See also
getNumDiscoveredVariableMods(const int, std::vector<std::string>&, std::vector<std::string>&, std::vector<delta>&, std::vector<std::string>&) const
Parameters
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredVariableMods() [2/2]

std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites,
 |  | std::vector< double > & | deltas,
 |  | std::vector< std::string > & | names
 | ) |  | const
 virtual

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

The ith element in the deltas and names vectors defines the delta and name of the modification, respectively. If the search has no crosslinking method, these two parameters can be ignored. When the modification number num refers to a crosslinker, the the deltas and names vectors contain values for all monolinks represented by the entry.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
deltas | A vector of deltas.
names | A vector of names.
Returns
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumHitsAboveHomology()

long getNumHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtual

Return the number of hits with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold().

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of hits with a score at or above the homology threshold.

◆ getNumHitsAboveIdentity()

long getNumHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtual

Return the number of hits with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold().

For a protein summary, the number of hits is the number of protein matches. The number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions make take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of hits with a score at or above the identity threshold.

◆ getPepsWithSameScore()

std::vector< int > getPepsWithSameScore | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Returns a list of 'p' values for peptides with the same score.

Peptides with the same score will have the same pretty rank. See ms_peptide::getPrettyRank() for details.

It is preferable to call this function rather than to loop through all the ranks calling getPeptide() for each one because the cached index stores the pretty ranks and this should therefore be faster.

For a protein summary, the returned list always contains a single value that is the same as the passed p value.

Parameters
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue().
Returns
a list of the ranks that have the same pretty value. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getPeptide() [1/2]

ms_peptide getPeptide | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_proteinsummary).

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfilebase::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
an ms_peptide object.

Implemented in ms_peptidesummary, and ms_proteinsummary.

Examples
peptide_list.cpp, and resfile_summary.cpp.

◆ getPeptide() [2/2]

bool getPeptide | ( | const int | q,
 |  | const int | p,
 |  | ms_peptide *& | pep
 | ) |  | const
 pure virtual

Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_proteinsummary).

Note
This function can not be used in programming languages other than C++.

To get the q and p values for a peptide in an ms_protein, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfilebase::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries()
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.

  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
pep is reference to a pointer to an ms_peptide object that will be returned.
Returns
true if the peptide exists.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getPeptideExpectationValue()

double getPeptideExpectationValue | ( | const double | score,
 |  | const int | query,
 |  | const int | rank = 0
 | ) |  | const
 virtual

Returns the expectation value for the given peptide score and query.

Returns the number of peptides that you would expect to get this score or higher from this database. This value is displayed as the expectation value in Mascot 2.0 and later reports. When the value is below 1, it approximates the p-value corrected for multiple testing.

For Mascot matches, the expectation value is calculated from

    E = Pthreshold * (10 ** ((Sthreshold - score) / 10))

For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

The Sthreshold value is the value returned by getHomologyThreshold() if ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specifed in the ms_peptidesummary constructor, otherwise the value used is the one returned from getPeptideIdentityThreshold().

Parser 2.8 and later can calculate expectation values for Mascot error tolerant matches. The value is based on the combined first and second pass identity threshold. If rank is zero, getPeptideExpectationValue() assumes the score is a first pass match score and calculates the value from the first pass identity or homology threshold. If rank is non-zero, the correct threshold is chosen based on the match at rank rank in this query.

ET expectation value is only available if the results file is from Mascot 2.8 and later. When you open results from Mascot 2.7 and earlier, expectation value for ET matches is -1. Note that Parser 2.7 and earlier returned a non-negative but incorrect number for ET matches.

For spectral library matches, the expectation value formula depends on report mode.

  • In integrated mode (ms_peptidesummary::MSPEPSUM_SL_INTEGRATED), library scores are scaled internally so that their mean and standard deviation match the mean and standard deviation of significant rank 1 Mascot matches with the same sequence in the same query. See Library scores and thresholds.
  • In SL-only mode (ms_peptidesummary::MSPEPSUM_SL_ONLY), the expect value formula is
     E = 0.05 * 10 ** (-(s - 300)/100).
    For example, E = 0.05 for score 300.

Spectral library support was added in Mascot Parser 2.6. If rank is zero, which is the default in Parser 2.5 and earlier, the score is assumed to be a Mascot ions score. If rank is non-zero, the correct formula is chosen based on the type of the match at rank rank in this query.

See also
getProteinExpectationValue()
Parameters
score | is the Mascot score to be converted.
query | specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
rank | is the rank of the match of interest in this query.
Returns
The number of peptides that you would expect to get this score or higher from this database, or -1 if it cannot be calculated.

◆ getPeptideIdentityThreshold()

int getPeptideIdentityThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtual

Return the threshold value for this ms-ms data being a random match.

See also
getAvePeptideIdentityThreshold()
Parameters
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType | If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
A score threshold. If query is < 1 or > ms_mascotresfilebase::getNumQueries() then -1 will be returned. If there was no MS-MS data or no match for this query, then -1 will be returned.
Examples
peptide_list.cpp, and resfile_summary.cpp.

◆ getPeptideThreshold()

double getPeptideThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1,
 |  | const THRESHOLD_TYPE | thresholdType = TT_PEPSUM_DEFAULT
 | ) |  | const

Return either the identity or the homology threshold.

The default is to use identity thresholds for the original Peptide Summary and Select Summary reports. For the Family Summary grouping, homology thresholds are used, and this needs to be specified by using the ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH flag. (This flag is automatically set when using the ms_mascotresfilebase::get_ms_mascotresults_params helper function).

This function calls getPeptideIdentityThreshold() or getHomologyThreshold() as appropriate. If it calls getHomologyThreshold() and this returns 0, then the identity threshold is returned.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. See getHomologyThreshold().

If the peptide match at rank rank is an ET match, and the results file is from Mascot Server 2.7 or earlier, then getPeptideIdentityThreshold() returns -1 and getPeptideThreshold() returns -1.

Parameters
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries()
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
thresholdType | can be any one of the ms_mascotresults::THRESHOLD_TYPE values
Returns
the threshold.

◆ getProbabilityThreshold()

double getProbabilityThreshold ( ) const
virtual

Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.

In a protein summary, the probability threshold specifies a cutoff point for protein scores, a cutoff for an Integrated error tolerant search and a threshold for calculating MudPIT scores.

In a peptide summary, the identity and homology thresholds of a peptide match are calculated from the probability threshold (significance threshold). This is the value of "Significance threshold p&lt;" shown in Mascot search reports.

getProbabilityThreshold() returns the currently active first pass significance threshold. The value may differ from the minProbability constructor argument if a target FDR has been specified. See ms_mascotresults_params::getTargetFDR().

If target FDR has not been specified, and if a value of <= 1e-18 or >= 1 is passed to the constructor, then a value of 1/20 (0.05) will be returned by this function. Otherwise it will just return the value passed to the ms_mascotresults::ms_mascotresults constructor.

In an error tolerant search, getProbabilityThreshold() may differ from the significance threshold used during the search, which was the basis for protein selection for the second pass. This is recorded as the first_pass_threshold= line in the results file header.

Error tolerant matches use an independent significance threshold, getErrTolProbabilityThreshold().

Returns
probability threshold for peptide matches.

◆ getProbFromScore()

int getProbFromScore ( const double score ) const
virtual

Returns a probability value given a score.

Warning
Do not use this without fully understanding what the function returns. It is more likely that you will want to use getPeptideExpectationValue() or getProteinExpectationValue().
Parameters
score is the Mascot score.
Returns
probability calculated from p = pow(10.0, (score/10.0)).

◆ getProbOfPepBeingRandomMatch()

double getProbOfPepBeingRandomMatch | ( | const double | score,
 |  | const int | query
 | ) |  | const
 virtual
Deprecated:
Use getPeptideExpectationValue().

Returns the inverse of getPeptideExpectationValue(). If, for example, the identity threshold (p<0.05) for a particular query is 30, and a value of 30 is passed to this function, then the return value will be 1/0.05. If, for the same search, a peptide of interest gets a score of 50, then this function will return a value of 1 / 0.00067 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also
getProbOfProteinBeingRandomMatch()
Parameters
score | is the Mascot score
query | specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
Returns
The probability.
Examples
resfile_summary.cpp.

◆ getProbOfProteinBeingRandomMatch()

double getProbOfProteinBeingRandomMatch ( const double score ) const
virtual
Deprecated:
Use getProteinExpectationValue().

Returns the inverse of getProteinExpectationValue(). If, for example, the identity threshold (p<0.05) for a PMF search is 56, and a value of 56 is passed to this function, then the return value will be 1/0.05. If, for the same search, a protein of interest gets a score of 90, then this function will return a value of 1 / 0.000025 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also
getProbOfPepBeingRandomMatch()
Parameters
score is the Mascot score to be converted.
Returns
The inverse of getProteinExpectationValue().

◆ getProtein()

const ms_protein * getProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const
 virtual

Return a pointer to the protein entry given an accession.

Parameters
accession is the accession string.
dbIdx is the database index (1..ms_searchparams::getNumberOfDatabases()).
  • For a PMF mixture in protein summary (see Peptide mass fingerprint mixtures), use the default value of 1 even if the component proteins are all from other databases.
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

◆ getProteinDescription()

std::string getProteinDescription | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const

Return protein description if available.

This method attempts to return the 'description line' for the given accession. The description line originated from the FASTA file that was searched. An empty string will be returned if the protein is not listed in the proteins section or the summary section of the results file.

Format in the proteins section is, for example:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search all, protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

The alternative way to get the description line is to call

     ms-getseq.exe [db] [accession] title

when nothing is returned by getProteinDescription(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

If the 'protein' is actually a UniGene entry, then the description line is taken by concatenating the Gene and the Title line for the relevant entry.

If the protein is a PMF mixture, then the description line will be of the format:

 * Mixture from proteins:"gi|1234","gi|5432","gi|9999"

If the protein comes from the reference database of a spectral library, then its description is not saved in the results file and this method returns the empty string. If the protein comes from the spectral library, it may or may not have a description, depending on how the library was created.

For a search against a decoy database, if the result is from the decoy section, then the description is prefixed with "Random sequence, was ", or if there is no description in the file, "Random sequence.". Depending on the configuration of the search, Random may also be Reversed or Shuffled.

Parameters
accession | is the accession string.
dbIdx | database index used for the search.
Returns
The description line or an empty string.
Examples
resfile_summary.cpp.

◆ getProteinEmPAI()

double getProteinEmPAI | ( | const char * | accession,
 |  | const int | dbIdx = 1,
 |  | const int | length = -1
 | ) |  | const
 virtual

Return protein emPAI if available.

The Exponentially Modified Protein Abundance Index (emPAI) offers approximate, label-free, relative quantitation of the proteins in a mixture based on protein coverage by the peptide matches in a database search result. The key publication is

Ishihama, Y., et al.: Exponentially modified protein abundance index (emPAI) for estimation of absolute protein amount in proteomics by the number of sequenced peptides per protein (2005). Molecular & Cellular Proteomics 4:1265-1272.

The number of observed peptides is determined using the function ms_protein::getNumObservedForEmPAI().

Protein sequence length is needed for emPAI calculation. You have two options:

  1. Give the sequence length as an argument to this method. You will need to fetch it with e.g. ms-getseq.exe on the Mascot Server machine.
  2. Give no argument to the method. If the protein has a mass in the results file, the mass will be used to calculate an approximate sequence length.

If no sequence length is given and the protein has no mass in the results file, the method returns -1. If you know the mass of the protein but not its sequence length, you can use the following approximate formula:

length = floor(0.5 + mass / 111)

Here 111 Da is the average mass of an amino acid residue.

If ms_mascotresults::isEmPAIallowed() is false, this method returns -1.

Parameters
accession | Protein accession.
dbIdx | Protein database index number.
length | Protein sequence length (optional). If the length is not given, protein mass from the results file will be used to approximate it. If protein mass is not available, the method returns -1.
Returns
emPAI or -1, as described above.

Reimplemented in ms_peptidesummary.

◆ getProteinExpectationValue()

double getProteinExpectationValue ( const double score ) const
virtual

Returns the expectation value for the given protein score.

Returns the number of proteins that you would expect to get this score or higher from random matches for this search. For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also
getPeptideExpectationValue()
Parameters
score is the Mascot protein score to be converted.
Returns
The expectation value.

◆ getProteinMass()

double getProteinMass | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const

Return protein mass if available.

This method attempts to return the mass for the given accession. The protein mass is calculated during the Mascot search, and some, but not all, of these masses are saved in the results file. A value of zero will be returned if the protein is not listed in the proteins section or the summary section of the results file.

The format in the proteins section is, for example, for a protein of mass 79480.13 daltons:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search, all protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines and masses in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines and masses are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

If a mass of zero is returned by this function, then the alternative way to get the mass is to call

     ms-getseq.exe [db] [accession] seq

to get the sequence, and then call getSequenceMass(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

Parameters
accession | is the accession string.
dbIdx | database number (1..ms_searchparams::getNumberOfDatabases()).
Returns
The protein mass or 0.0.
Examples
resfile_summary.cpp.

◆ getProteinScoreCutoff()

int getProteinScoreCutoff ( double OneInXprobRnd ) const
pure virtual

Return the 'protein' score value for cutting off results (different for peptide and protein summary).

The protein probability cutoff is calculated differently for a protein summary and a peptide summary.

  • For a peptide summary, we want to display any proteins that contain even one significant peptide, which means the threshold is the same as getAvePeptideIdentityThreshold().

    For MudPIT scoring, any protein with a score greater than zero must have one or more peptides above the homology threshold, so this function returns a value of 1.

  • For a protein summary, we simply use the protein score that corresponds to the threshold.
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns
The protein score cutoff threshold.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getProteinScoreForHistogram()

double getProteinScoreForHistogram ( const int num ) const
virtual

Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.

The 'well known' green and red histogram at the top of the Mascot reports is created from the top 50 protein scores in the results. However, if the number of hits requested for a peptide or protein summary is 'AUTO' or is less than 50, then there won't be 50 hits in the ms_mascotresults object so it won't be possible to create the histogram.

This simple method can reliably be used to return the score for a hit number between 1 and 50, regardless of the number of entries in the protein or peptide summary. To create the histogram, it will be necessary to call this method 50 times - with num being 1..50.

In the rare case of there being less than 50 proteins in the results file, a value of -1 will be returned for values of num that have no protein hit. If a protein is rejected because it only has peptides shorter than minPepLenInPepSummary or because the MSRES_REQUIRE_BOLD_RED is set, then this protein will not be included in the list.

Parameters
num Is a value in the range 1..50.
Returns
The score.

◆ getProteinsWithThisPepMatch()

std::string getProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | const bool | quotes = false
 | ) |  |
pure virtual

Return a partial list of proteins that matched the same peptide.

The returned string is of the following form:

    1:Q9XZJ2  2:100K_RAT  3:AAF55150

The list is the hit number / accession of all proteins that matched the same peptide. There is no indication of which database the hit is from, but this can of course be determined by calling getHit().

In ms_peptidesummary, this is taken from the list of accessions on the q1_p1= line. The returned string only includes proteins that are in the current peptide summary. This means for example that if you choose to only see the top 5 hits, and this query/rank is for a peptide that occurs in protein 6, then protein number 6 will not appear in the resulting string.

In ms_proteinsummary, the string is also constructed from the list of accessions on the q1_h1= line. There's an additional check that the query number is the same, and that the peptide is the same string.

If you want a list of accession strings rather than a single concatenated string, use the function getAllProteinsWithThisPepMatch().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' number (in ms_proteinsummary) or 'rank' number (in ms_proteinsummary).
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence h must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
quotes specifies whether the accessions will be quoted, which should allow accesions with spaces and colons. If true, the string returned would then be
1:"Q9XZJ2" 2:"100K_RAT" 3:"AAF55150"
Returns
list of proteins matching the peptide, as a string

Implemented in ms_peptidesummary, and ms_proteinsummary.

Examples
peptide_list.cpp, and resfile_summary.cpp.

◆ getProteinTaxonomyIDs()

void getProteinTaxonomyIDs | ( | const char * | accession,
 |  | const int | dbIdx,
 |  | std::vector< int > & | gpt_ids,
 |  | std::vector< std::string > & | gpt_accessions
 | ) |  | const

Return the taxonomy ID(s), if any, from the results file.

In Mascot 2.4.0 and later, taxonomy IDs are saved in the proteins section of the results files in the form:

   [DB::]"accession"_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

In Mascot 2.4.1 and later, taxonomy IDs are also saved in the summary section of the results files in the form:

   hN_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

For example, for a single database, with a single accession/taxonomy:

   "gi|209490801"_tax=87229

   h1=gi|209490801, ...
   h1_tax=87229

and for a multi-database search, with a single accession/taxonomy:

   02::"gi|209490801"_tax=87229

   h1_db=2
   h1=gi|209490801, ...
   h1_tax=87229

and for a single database, with multiple accession/taxonomy:

   "gi|182438931"_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

   h1=gi|182438931, ...
   h1_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

If none of the databases used for the search contain taxonomy information, then no _tax lines will be output.

If any of the databases used for the search contain taxonomy information, then a _tax line will be output for all relevant proteins. This is governed by the same rules that determine for which proteins to output the mass and description lines. If a protein has no taxonomy information (for example, the database has no taxonomy), -1 will be used as the taxonomy ID.

Therefore, to determine if taxonomy information is available in the results file, simply take any protein in the proteins section, and see if there is a corresponding _tax entry.

For most FASTA files, there is a single accession and taxonomy for each sequence entry. For the NCBInr database, identical sequences are only stored once, but there are multiple accession/description lines separated by a "Control-A" character. Each accession may have a different taxonomy. This function returns the list of taxonomy IDs and corresponding accessions. For the last example shown above, this function will return the arrays of IDs

  [455632, 649189, 455632, 649189]

and accessions

  ["gi|182438931", "gi|282872348", "gi|178467447", "gi|282574201"]

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
accession | is the primary accession
dbIdx | is the 1 based database ID
gpt_ids | the taxonomy IDs
gpt_accessions | the list of accessions

◆ getProteinThreshold()

int getProteinThreshold ( double OneInXprobRnd ) const
virtual

Return a threshold value for the protein summary report.

This is simply calculated by using:

   10.0 * log10(seqsAfterTax * OneInXprobRnd)

where seqsAfterTax is obtained from ms_mascotresfilebase::getNumSeqsAfterTax().

The threshold value is displayed at the top of the protein summary report: Protein scores greater than 72 are significant (p<0.05).

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns
The protein threshold.

◆ getQmatch() [1/2]

int getQmatch ( const int query ) const
virtual

[Deprecated] Return the number of peptides with masses that matched this query.

Deprecated:
This method is deprecated in favour of ms_mascotresfilebase::getQmatch
See also
getPeptideIdentityThreshold()
Note
This method only works with dat28 (.dat) results files. The value returned with MSR files is undefined.

If the value is greater than INT_MAX, then INT_MAX will be returned.

This function calls the getQmatch(query, section) function with the 'relevant' section which will normally be SEC_SUMMARY.

If the MSRES_DECOY flag was specified in the constructor, then the 'relevant' section will be SEC_DECOYSUMMARY. If the search is an error tolerant search, then the 'relevant' section will be SEC_ERRTOLPEPTIDES, and analogously for crosslinked searches (SEC_CROSSLINK_PEPTIDES).

However, to get the spectral library qmatch values, it is necessary to explicitly call: getQmatch(query, ms_mascotresfile_dat::SEC_LIBRARYSUMMARY)

Parameters
query Specifies the query number. This should be in the range 1 .. ms_mascotresfile_dat::getNumQueries().
Returns
the number of peptides with masses that matched this query

◆ getQmatch() [2/2]

int getQmatch | ( | const int | query,
 |  | const ms_mascotresfile_dat::section | sec
 | ) |  | const
 virtual

[Deprecated] Use ms_mascotresfilebase::getQmatch().

Deprecated:
This method is deprecated in favour of ms_mascotresfilebase::getQmatch

If the value is greater than INT_MAX, then INT_MAX will be returned.

Note
This method only works with dat28 (.dat) results files. The value returned with MSR files is undefined.
Parameters
query Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
sec is the section number and can be one of:
  • ms_mascotresfile_dat::SEC_SUMMARY
  • ms_mascotresfile_dat::SEC_DECOYSUMMARY
  • ms_mascotresfile_dat::SEC_ERRTOLSUMMARY
  • ms_mascotresfile_dat::SEC_ERRTOLDECOYSUMMARY
  • ms_mascotresfile_dat::SEC_LIBRARYSUMMARY
  • ms_mascotresfile_dat::SEC_CROSSLINK_SUMMARY
Returns
the number of peptides with masses that matched this query. If the specified sec doesn't exist, then 0 will be returned.

◆ getQuantitationComponentForPeptide()

int getQuantitationComponentForPeptide | ( | const matrix_science::ms_peptide & | peptide,
 |  | matrix_science::ms_quant_component & | component,
 |  | const matrix_science::ms_quant_method * | method = NULL
 | ) |  | const
 pure virtual

Get the component in the quantitation method that matches the peptide.

If the component name has already been determined (see ms_peptide::getComponentStr()) then that component is retrieved from the method.

If the component name has not yet been determined for the peptide, each component in the method is checked in turn to determine if it is the correct component for the peptide (see ms_peptidesummary::isPeptideComponentMatch()). A component only matches the peptide if every modification group of the component matches the peptide.

This is only applicable if there is a quantitation method, the method uses the Precursor protocol and the method has components defined. If an error occurs then an error message is appended to the matrix_science::ms_mascotresfilebase and a matching status code is returned.

Parameters
peptide | The peptide to find the component for.
component | This is set to the first matching component found, if any.
method | An optional parameter that overrides the quantitation method used to look for matching components. If no method is specified here then the method from the ms_mascotresfilebase is used.
Returns
One of the return status codes in ms_mascotresults::QUANT_COMPONENT_STATUS.

Implemented in ms_proteinsummary, and ms_peptidesummary.

◆ getReadableVarMods()

std::string getReadableVarMods | ( | const int | q,
 |  | const int | p,
 |  | const int | numDecimalPlaces = 2,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const
 virtual

Return a 'human readable' string with the variable, summed and error tolerant mods.

This function creates a string of the form

2 Oxidation (M); Phosphorylation (ST)

It works by getting the variable mods string, e.g. 0110030, using ms_peptide::getVarModsStr(). It then converts the string to a human readable form. Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W.

This function will work whether or not there are variable and/or error tolerant mods, and can be called for either the peptide or the protein summary. Variable modification names are obtained using ms_searchparams::getVarModsName() and error tolerant modification names are found using ms_mascotresults::getErrTolModName(). Library modification names, in peptide summary, are found using ms_searchparams::getLibraryModName(). See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Error tolerant mods are shown with the delta in square brackets after the modification or substitution. For example:

   R->G [-99.08]

The delta is shown to numDecimalPlaces.

If the match is an intact crosslinked match, the returned string contains a short description of the linked sites and what they are linked with. For example:

   Xlink:DSS (K) in alpha crosslinked with Xlink:DSS (K) in beta

Use ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA as the psmComponent argument to inspect the alpha and beta mods separately. In this case, the intact linker is described like "intact Xlink:DSS (K)".

Summed mods, from ms_peptide::getSummedModsStr(), and query-level mods, from ms_peptide::getLocalModsStr(), are also included in the returned string.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10.
numDecimalPlaces | (optional) Used for the display of modification deltas.
psmComponent | (optional) Either ms_peptide::PSM_COMPLETE for the match as a whole, or ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA to get components of a crosslinked match.
Returns
The formatted string.
Examples
resfile_summary.cpp.

◆ getResultsParameters()

ms_mascotresults_params getResultsParameters ( ) const

Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.

Returns
An ms_mascotresults_params object containing the parameter and flag values used to generate the report.

◆ getSequenceMass()

double getSequenceMass ( const char * seq ) const

Return the mass of a sequence (protein or peptide).

The sequence mass is calculated by summing the mass of each residue, using ms_searchparams::getResidueMass, and adding terminus masses using ms_searchparams::getCTermMass and ms_searchparams::getNTermMass.

The mass is therefore the 'Mr' (uncharged) mass, and is calculated using any static modifications.

Parameters
seq is the protein sequence.
Returns
The relative mass of the sequence.

◆ getTagDeltaRangeEnd()

int getTagDeltaRangeEnd | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Return the second number from h1_q2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
the second number from the string or -1 if there is no tag match.

Implemented in ms_peptidesummary, and ms_proteinsummary.

Examples
resfile_summary.cpp.

◆ getTagDeltaRangeStart()

int getTagDeltaRangeStart | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Return the first number from h1_q2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
the first number from the string or -1 if there is no tag match.

Implemented in ms_peptidesummary, and ms_proteinsummary.

Examples
resfile_summary.cpp.

◆ getTagEnd()

int getTagEnd | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const
 virtual

Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also
getTagStart(), getTagSeries()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns
The residue end position of the tag.
Examples
resfile_summary.cpp.

◆ getTagSeries()

int getTagSeries | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const
 virtual

Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also
getTagStart(), getTagEnd()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns
The series that contained a match to the tag. Possible ion series numbers are
  • -1 means no matches for the tag
  • 0 "a" series (single charge)
  • 1 "a-NH3" series (single charge)
  • 2 "a" series (double charge)
  • 3 "b" series (single charge)
  • 4 "b-NH3" series (single charge)
  • 5 "b" series (double charge)
  • 6 "y" series (single charge)
  • 7 "y-NH3" series (single charge)
  • 8 "y" series (double charge)
  • 9 "c" series (single charge)
  • 10 "c" series (double charge)
  • 11 "x" series (single charge)
  • 12 "x" series (double charge)
  • 13 "z" series (single charge)
  • 14 "z" series (double charge)
  • 15 "a-H2O" series (single charge)
  • 16 "a-H2O" series (double charge)
  • 17 "b-H2O" series (single charge)
  • 18 "b-H2O" series (double charge)
  • 19 "y-H2O" series (single charge)
  • 20 "y-H2O" series (double charge)
  • 21 "a-NH3" series (double charge)
  • 22 "b-NH3" series (double charge)
  • 23 "y-NH3" series (double charge)
  • 25 "internal yb" series (single charge)
  • 26 "internal ya" series (single charge)
  • 27 "z+1" series (single charge)
  • 28 "z+1" series (double charge)
  • 29 high-enrgy "d" and "d'" series (single charge)
  • 31 high-enrgy "v" series (single charge)
  • 32 high-enrgy "w" and "w'" series (single charge)
  • 33 "z+2" series (single charge)
  • 34 "z+2" series (double charge)
Examples
resfile_summary.cpp.

◆ getTagStart()

int getTagStart | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const
 virtual

Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also
getTagEnd(), getTagSeries()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns
The residue start position of the tag.
Examples
resfile_summary.cpp.

◆ getTagString()

std::string getTagString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 pure virtual

Return the complete tag string from h1_q2_tag or q1_p1_tag.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_tag might be
       q1_p2_tag=1:10:12:6,3:1:12:1,...
  • The entry in h1_q2_tag might be
       h1_q2_tag=1:10:12:6,3:1:12:1,...

This function returns the complete string value. Every group of four numbers between commas is tagNumber:startPos:endPos:series.

More useful functions are

  • ms_mascotresults::getTagStart(),
  • ms_mascotresults::getTagEnd() and
  • ms_mascotresults::getTagSeries(),

all of which will work for both the protein summary and the peptide summary.

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete tag string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

Examples
resfile_summary.cpp.

◆ getTerminalResiduesString()

std::string getTerminalResiduesString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const
 pure virtual

Return the complete terminal residue string from h1_q1_terms or q1_p1_terms.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in the results file might be
       q1_p2_terms=-,A:K,I:-,-:Q,-:@,R:...
  • The entry in the results file might be
       h1_q2_terms=A,Q

This function returns the complete string value. More useful functions are ms_protein::getPeptideResidueBefore() and ms_protein::getPeptideResidueAfter(), which will work for both the protein summary and the peptide summary.

ms_peptidesummary only: For a crosslinked match, the results file line is q1_p1_terms_1= or q1_p1_terms_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns
the full terminal residues string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

◆ getThresholdForFDRAboveHomology() [1/2]

bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFDRAboveHomology(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getThresholdForFDRAboveHomology() [2/2]

bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |

Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.

For example, to find out which probability threshold gives 1% FDR above identity or homology threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the * minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveHomology() and getNumDecoyHitsAboveHomology().

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

Otherwise functionality is the same as getThresholdForFDRAboveIdentity(double, double*, double*, int*, int*).

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getThresholdForFDRAboveIdentity() [1/2]

bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFDRAboveIdentity(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getThresholdForFDRAboveIdentity() [2/2]

bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |

Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.

For example, to find out which probability threshold gives 1% FDR above identity threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveIdentity() and getNumDecoyHitsAboveIdentity().

The function returns a value that maximises the number of peptide-spectrum matches while giving an FDR below the targetFDR value. In some cases, it would be possible to get an FDR closer to the supplied targetFDR, but with fewer target matches.

For a large file, this function can take some time to return. Feedback can be obtained by using ms_mascotresfilebase::outputKeepAlive with the fd= tag.

This function was first introduced in version 2.4.0 and the method for calculating the value was changed between version 2.4.0 and 2.4.1.

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If this function returns false, there are several possibilities:

  • The function is being called for a ms_proteinsummary object
  • The supplied targetFDR is 0, or negative
  • It is not possible to get an FDR less than the targetFDR. In this case, the lowest possible FDR is given
  • The function is being called for an error tolerant search

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getToleranceInDalton()

double getToleranceInDalton | ( | bool & | needMass,
 |  | const double *const | pMass = NULL
 | ) |  | const

Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.

Returns the tolerance of the result file in dalton.

Parameters
needMass | Reference to a boolean to determine if the mass is needed to calculate the delta, namely when the tolerance unit is in % or ppm
pMass | Optional parameter to calculate the tolerance from the mass for % and ppm
Returns
The tolerance in dalton

◆ getTreeClusterNodes()

bool getTreeClusterNodes | ( | const int | hit,
 |  | std::vector< int > & | left,
 |  | std::vector< int > & | right,
 |  | std::vector< double > & | distance,
 |  | TREE_CLUSTER_METHOD | tcm = TCM_PAIRWISE_MAXIMUM,
 |  | double *** | reserved1 = 0,
 |  | unsigned int * | reserved2 = 0
 | ) |  | const
 virtual

Return distances and structure suitable for a dendrogram plot.

The 'distances' between each protein in the family are calculated using a tree clustering routine which, by default, implements pairwise maximum (or complete) linkage clustering. It is used for the dendrogram display in the reports introduced in Mascot 2.3.

The vectors returned by this function only contain values when MSRES_CLUSTER_PROTEINS has been specified and where there are at least two family members.

The code uses the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/

The License agreement for using this excellent Open Source code is included with Mascot Parser; see C Clustering library.

A value of 0 returned in the left or right vector corresponds to the lead protein as returned by getHit(). To find the protein associated with a positive node value returned in the left or right vector, call getNextFamilyProtein() with the id value set to the value in the vector.

The distances passed to the cluster algorithm are calculated by determining which peptides need to be excluded to make one protein a subset of another. Each unique peptide sequence is considered in turn, and the distance is calculated by taking the maximum difference between the score and the value returned by getPeptideThreshold(). Additionally, where a query has matches to different peptides above threshold in each protein, the delta of the scores is added to the distance.

For details of how to use the left, right and distance parameters, see Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
hit | is the hit number for the lead protein.
left | returns a vector of 'left' values.
right | returns a vector of 'right' values.
distance | returns a vector of 'distance' values.
tcm | is the method to be used. See documentation referenced above
reserved1 | is for Matrix Science use only
reserved2 | is for Matrix Science use only
Returns
true unless the code causes an out of memory error.

Reimplemented in ms_peptidesummary.

◆ getUnassigned()

ms_peptide getUnassigned ( const int num ) const

Need to call createUnassignedList() before calling this.

See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_errs::ERR_UNASSIGNED_PROG will be set, and this function will return an empty ms_peptide.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
num Must be in the range 1..getNumberOfUnassigned().
Returns
If num is outside the range ..getNumberOfUnassigned(), then an error ms_errs::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.
Examples
resfile_summary.cpp.

◆ getUnassignedIsBold()

bool getUnassignedIsBold ( const int num ) const

Returns true if the item indexed by num in the assigned list should be bold.

This function returns true if this peptide should be displayed in bold in a Mascot report. Bold is used for the first time a query is shown in a report. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_errs::ERR_UNASSIGNED_PROG will be set, and this function will return true.

Parameters
num Must be in the range 1..getNumberOfUnassigned().
Returns
If num is outside the range ..getNumberOfUnassigned(), then an error ms_errs::ERR_UNASSIGNED_RANGE will be set, and this function will return true.

◆ getUnassignedShowCheckbox()

bool getUnassignedShowCheckbox ( const int num ) const

Returns true if the item indexed by num in the assigned list should have a check box next to it.

A check box is displayed if this is the first rank 1 match that has been displayed for this query. See also ms_peptide::getRank() and ms_peptide::getPrettyRank().

By definition, all unassigned queries will need a check box. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_errs::ERR_UNASSIGNED_PROG will be set, and this function will return false.

Parameters
num Must be in the range 1..getNumberOfUnassigned().
Returns
If num is outside the range ..getNumberOfUnassigned(), then an error ms_errs::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.

◆ isEmPAIallowed()

bool isEmPAIallowed ( ) const

Return true if emPAI could be calculated using data in this results file.

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns
true if emPAI is allowed.

◆ isNA()

bool isNA ( ) const

Returns TRUE for a search against a nucelic acid database.

There is no specific information in the results file for this. It is implemented by looking to see if there is a frame number that is non-zero in any result. If there are no matches to any query, then this method will return false and therefore may be wrong. (However, if there are no matches then it is unlikely that the outcome of this function is important!)

In versions prior to 2.3.01, this was determined by looking in protein matches. In version 2.3.01 and later, this is determined by looking in all peptide matches, regardless of score.

Returns
True if the search was against a nucleic acid database.

◆ isPeptideUnique()

bool isPeptideUnique | ( | const int | q,
 |  | const int | p,
 |  | const UNIQUE_PEP_RULES | rules = UPR_DEFAULT
 | ) |  | const
 pure virtual

Returns true if this peptide match is unique to one protein or one protein family.

Note
This function currently returns false for ms_proteinsummary. This function is only likely to be useful for a peptide summary.

This function is used, for example, in quantitation to only report ratios for peptide sequences that are unique to one protein hit. This can be specified as part of a Mascot quantitation method; see ms_quant_quality::isUniquePepseq().

No attempt is made to collapse peptides that just differ by, for example, I or L.

The specified q and p values must be for a peptide that has a protein match in the current report, i.e. not in the unassigned list. The function searches all proteins and not just those in the current report. For example, if peptide 'ABCDEFK' appears in protein hit one and protein hit 100, then it will return false even if only the top 10 hits have been requested.

If grouping is not selected when creating the ms_peptidesummary, (i.e. neither ms_mascotresults::MSRES_GROUP_PROTEINS nor ms_mascotresults::MSRES_CLUSTER_PROTEINS), then it is likely that this function will return false for most peptides.

At version 2.3, this function did not have the optional third parameter and the default value was the same as using ms_mascotresults::UPR_WITHIN_FAMILY, which is not the default value in version 2.4 and later. At version 2.3, the function would therefore return true for all peptides with a score above the homology threshold when ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified.

Parameters
q | is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the * range 1 to 50.
rules | should passed appropriate ms_mascotresults::UNIQUE_PEP_RULES flags to specify what rules are to be used for considerering when a peptide is unique.
Returns
true if the peptide match is unique. Always false in ms_proteinsummary.

Implemented in ms_proteinsummary, and ms_peptidesummary.

◆ setSubsetsThreshold()

void setSubsetsThreshold ( const double scoreFraction )
virtual

Specifies which subset proteins should be reported.

If you have a primary hit with (say) 100 peptide matches, you are very interested in sub-set proteins with 99 matches but not if they only have 1 or 2 matches. These are the sub-set hits that clutter up the report if Show Sub-sets is checked in Mascot 2.1 and earlier. If you have a primary hit with (say) 2 peptide matches, you are more likely to be interested in sub-set proteins with just 1 match.

A scoreFraction of 1 indicates that all proteins with a subset of matches should be reported. A value of 0 indicates that no subsets will be reported. The flag MSRES_SHOW_SUBSETS must have been specified if a value > 0 is used, or no subsets will be shown.

See also
getNextSubsetProtein(), getNextSubsetProteinOf()
Parameters
scoreFraction is the fractional score required for a protein to be counted as a subset. Its score must be greater than or equal to main_protein_score * (1-scoreFraction). The default value is 1.0.
The documentation for this class was generated from the following files:
  • ms_mascotresults.hpp
  • ms_mascotresults.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresults_params Class Reference

  • matrix_science
  • ms_mascotresults_params
Public Member Functions | List of all members
ms_mascotresults_params Class Reference
Mascot results file module

Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary. More...

#include <ms_mascotresults_params.hpp>

Public Member Functions

ms_mascotresults_params (const ms_mascotresults_params &src)
Copying constructor.
ms_mascotresults_params (const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS, double minProbability=0.05, int maxHitsToReport=0, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=ms_peptidesummary::MSPEPSUM_NONE)
Call this method once to create the ms_mascotresults_params.
void | copyFrom (const ms_mascotresults_params *right)
Copies all data from another instance of the class.
unsigned int | getFlags () const
Returns the value of the flags parameter if available.
unsigned int | getFlags2 () const
Returns the value of the flags2 parameter if available.
double | getIgnoreIonsScoreBelow () const
Returns the value of the ignoreIonsScoreBelow parameter if available.
int | getMaxHitsToReport () const
Returns the maximum number of protein hits to report.
int | getMinNumSigUniqueSequences () const
Returns the value of the MinNumSigUniqueSequences parameter.
int | getMinPepLenInPeptideSummary () const
Returns the minimum length of peptide match to use when generating a peptide summary report.
double | getMinProbability () const
Returns the significance threshold.
std::string | getSingleHit () const
Returns the optional single hit parameter used to get the results for a single hit quickly.
double | getTargetFDR () const
Returns the target FDR, if any.
ms_mascotresults::DECOY_STATS_COUNT_TYPE | getTargetFDRType () const
Returns the target FDR type.
std::string | getUnigeneIndexFile () const
Optional file path to a UniGene Index file.
bool | isUsePeptideSummary () const
Returns a hint as to whether a peptide or protein summary should be created.
ms_mascotresults_params & | operator= (const ms_mascotresults_params &right)
Assignment operator.
void | setFlag (const ms_mascotresults::FLAGS flag, bool enabled)
Toggles the value of an individual flag for use in the ms_mascotresults constructor.
void | setFlag2 (const ms_peptidesummary::MSPEPSUM flag, bool enabled)
Toggles the value of an individual flag used in the ms_peptidesummary constructor.
void | setFlags (const unsigned int flags)
Sets the value of the flags parameter for use in the ms_mascotresults constructor.
void | setFlags2 (const unsigned int flags2)
Sets the value of the flags2 parameter used in the ms_peptidesummary constructor.
void | setIgnoreIonsScoreBelow (const double ignoreIonsScoreBelow)
Sets the value of the ignoreIonsScoreBelow parameter.
void | setMaxHitsToReport (const int maxHitsToReport)
Sets the maximum number of protein hits to report.
void | setMinNumSigUniqueSequences (const int n)
Sets the value of the MinNumSigUniqueSequences parameter.
void | setMinPepLenInPeptideSummary (const int minPepLenInPeptideSummary)
Sets the minimum length of peptide match to use when generating a peptide summary report.
void | setMinProbability (const double minProbability)
Sets the significance threshold.
void | setSingleHit (const char *singleHit)
Sets the optional single hit parameter.
void | setTargetFDR (double fdr)
Sets the target FDR.
void | setTargetFDRType (ms_mascotresults::DECOY_STATS_COUNT_TYPE fdrType)
Sets the target FDR type.
void | setUnigeneIndexFile (const char *unigeneIndexFile)
Sets the optional file path to a UniGene Index file.
void | setUsePeptideSummary (const bool usePeptideSummary)
Set the hint as to whether a peptide or protein summary should be created.

Detailed Description

Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.

Constructor & Destructor Documentation

◆ ms_mascotresults_params() [1/2]

ms_mascotresults_params | ( | const unsigned int | flags = ms_mascotresults::MSRES_GROUP_PROTEINS,
 |  | double | minProbability = 0.05,
 |  | int | maxHitsToReport = 0,
 |  | const char * | unigeneIndexFile = 0,
 |  | double | ignoreIonsScoreBelow = 0.0,
 |  | int | minPepLenInPepSummary = 0,
 |  | const char * | singleHit = 0,
 |  | const unsigned int | flags2 = ms_peptidesummary::MSPEPSUM_NONE
 | ) |  |

Call this method once to create the ms_mascotresults_params.

This object has fields for all of the flags and parameters required to create peptide and protein summary result objects. Both ms_peptidesummary and ms_proteinsummary have constructors which will accept an ms_mascotresults_params object.

You do not need to supply any of the parameter values when creating an ms_mascotresults_params object as all of the parameters have setter methods, allowing you to update their values. You can also set all of the required parameters for a result by calling the get_ms_mascotresults_params method of ms_mascotresfilebase.

Parameters
flags | can be one or more of the ms_mascotresults::FLAGS values OR'ed together
minProbability | specifies the significance threshold. See getMinProbability(). See also getTargetFDR().
maxHitsToReport | is a maximum value of protein hits to report. See getMaxHitsToReport().
unigeneIndexFile is an optional file path to a UniGene Index file. This only makes sense if ms_mascotresults::MSRES_GROUP_PROTEINS is set.
  • From programming languages other than C++, pass an empty string object to specify no UniGene index file.
ignoreIonsScoreBelow | is an optional flag for the peptide summary only. See getIgnoreIonsScoreBelow().
minPepLenInPepSummary | is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins (see Grouping proteins together).
singleHit | should only be used for getting the results for a single protein quickly. See setSingleHit().
flags2 | should be one or more of the ms_peptidesummary::MSPEPSUM flags OR'd together

◆ ms_mascotresults_params() [2/2]

ms_mascotresults_params ( const ms_mascotresults_params & src )

Copying constructor.

Parameters
src is the source to initialise from

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_mascotresults_params * right )

Copies all data from another instance of the class.

Parameters
right is the source to initialise from

◆ getFlags()

unsigned int getFlags ( ) const

Returns the value of the flags parameter if available.

The value of the flags parameter should be one or more of the ms_mascotresults::FLAGS values OR'ed together.

Returns
The value of the flags parameter used by the ms_peptidesummary and ms_proteinsummary constructors

◆ getFlags2()

unsigned int getFlags2 ( ) const

Returns the value of the flags2 parameter if available.

Flags2 is an optional parameter for the peptide summary only. It's value should be one or more of the ms_peptidesummary::MSPEPSUM flags OR'ed together.

Returns
The value of the flags2 parameter used by the ms_peptidesummary constructor.

◆ getIgnoreIonsScoreBelow()

double getIgnoreIonsScoreBelow ( ) const

Returns the value of the ignoreIonsScoreBelow parameter if available.

ignoreIonsScoreBelow is an optional flag for the peptide summary only. Any peptides with a score less than this will be ignored. If the value is greater than 0 and less than 1 then this is assumed to to be a probability rather than an absolute score; the reciprocal of this value is passed to ms_peptidesummary::getPeptideThreshold() to determine the score cutoff.

A value of -1 is treated as equivalent to minProbability. This is the most convenient setting if you want to filter out non-significant matches.

If the search is an error tolerant search, any non-zero value is treated as equal to -1. That is, specifying IgnoreIonsScoreBelow = 0.0 will display all matches, and specifying any other value will display only significant matches.

Returns
The value of ignoreIonsScoreBelow to use in the ms_peptidesummary constructor

◆ getMaxHitsToReport()

int getMaxHitsToReport ( ) const

Returns the maximum number of protein hits to report.

This is a maximum value. There may be fewer than this number if minProbability is low (or > 1 and high), or if there are insufficient results.

  • If the ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB flag is set, then the minProbability value is ignored when determining the number of hits to display.
  • With versions of parser before Mascot 2.2, this flag was not available so a value of 0 was passed as minProbability in the standard Mascot results reports. Also, if this flag is specified, a value of zero can be used for maxHitsToReport and the cutoff is then specified by minProbability.
  • If the flag ms_mascotresults::MSRES_GROUP_PROTEINS is set, then this value applies to the top level proteins – the similar and subset proteins are not included in the count.
Returns
The maximum number of protein hits to report.

◆ getMinNumSigUniqueSequences()

int getMinNumSigUniqueSequences ( ) const

Returns the value of the MinNumSigUniqueSequences parameter.

MinNumSigUniqueSequences is an optional flag for the peptide summary only. A protein hit must have at least as many significant unique sequences to be reported as a hit. A peptide sequence is significant if it has at least one peptide match above significance threshold, and it is unique if it appears in no other protein hit.

The default is 1. The value range is between 1 and 5, inclusive.

Returns
The value of MinNumSigUniqueSequences to use in the ms_peptidesummary constructor

◆ getMinPepLenInPeptideSummary()

int getMinPepLenInPeptideSummary ( ) const

Returns the minimum length of peptide match to use when generating a peptide summary report.

This is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins (see Grouping proteins together).

Returns
the minimum peptide length used to differentiate different proteins.

◆ getMinProbability()

double getMinProbability ( ) const

Returns the significance threshold.

minProbability is applied to both peptide matches and protein hits.

Peptide matches:

  • A peptide match (PSM) is significant if its expect value is below minProbability.
  • minProbability can be overriden by getTargetFDR().

Protein hits if ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB is active:

  • If ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB is set, minProbability is ignored. Instead, up to getMaxHitsToReport() proteins are reported.

Protein hits if MSRES_MAXHITS_OVERRIDES_MINPROB is not active:

  • A value of 0 indicates no cutoff - report getMaxHitsToReport() proteins, whatever the protein scores.
  • A value between 0 and 1 is used to calculate a protein score cut-off based on peptide match expect values. With standard protein scoring, 0.05 would discard all proteins with a score less the average score of a peptide with an expect value of 0.05. With MudPIT protein scoring, 0.05 would be the peptide expect value threshold used for calculating the protein scores, and only proteins with non-zero scores are reported.
  • A value greater than 1 indicates an absolute score cutoff for proteins, but this is not valid for an Integrated error tolerant search and is not permitted in the standard Mascot Search reports, so is not recommended.
  • If the flag ms_mascotresults::MSRES_GROUP_PROTEINS is set, then this value applies to the top level proteins - the similar and subset proteins are not 'cutoff' by this value.
  • The cutoff point is the lower of maxHitsToReport and this value. With versions of parser before Mascot 2.2, MSRES_MAXHITS_OVERRIDES_MINPROB was not available so AUTO in the standard Mascot results reports was implemented by setting this probability to a (user) defined value and setting getMaxHitsToReport() to a very large number.

Other points to note:

  • A value of less than 0 is not permitted and will be replaced with the default of 0.05.
  • In Mascot Parser 2.2 and earlier, a value between 0.1 and 1.0 was replaced with the default value of 0.05. In Mascot Parser 2.3, any value between 1e-18 and 1.0 is acceptable.
Returns
The value of the minProbability parameter used in the ms_peptidesummary and ms_proteinsummary constructors

◆ getSingleHit()

std::string getSingleHit ( ) const

Returns the optional single hit parameter used to get the results for a single hit quickly.

Should only be used for getting the results for a single protein quickly. See setSingleHit().

Returns
The single hit parameter value if available.

◆ getTargetFDR()

double getTargetFDR ( ) const

Returns the target FDR, if any.

Target FDR is only valid with ms_peptidesummary. Target FDR type is sequence (DS_COUNT_SEQUENCE) by default, which can be overriden using setTargetFDRType().

If target FDR is 0 (default), it is interpreted as "not set". ms_peptidesummary uses getMinProbability() as the significance threshold.

Target FDR is a value between 0 and 1. If the search is a target-decoy search, ms_peptidesummary tries to calibrate minProbability to a value that yields the target FDR (either PSM FDR or sequence FDR). If the search is not a target-decoy search, or ms_peptidesummary fails to reach the target, then getMinProbability() is used as the fallback value.

If the search is a target-decoy, integrated error tolerant, ms_peptidesummary has two independent significance thresholds, one for first pass matches and one for second pass matches. If target FDR is non-zero, ms_peptidesummary tries to calibrate both sets of matches to the same target FDR.

Mascot Server 2.8 and later may output a first_pass_threshold= value in the header section of the results file. This is the minProbability used at the end of the first pass of an integrated error tolerant search.

Mascot Server 2.8 and later accept a TARGET_FDR_PERCENT= search parameter, which is stored in the parameters section of the results file.

ms_mascotresfilebase::get_ms_mascotresults_params() follows this protocol:

  • Use ms_mascotresfilebase::getSectionValueDouble() to get first_pass_threshold=.
  • If it's non-zero, pass it to setMinProbability().
  • Use ms_searchparams::getTARGET_FDR_PERCENT(). Divide by 100 and pass to setTargetFDR().
  • Set FDR type to the default (ms_mascotresults::DS_COUNT_SEQUENCE).
Returns
target FDR, or 0 if not set.

◆ getTargetFDRType()

ms_mascotresults::DECOY_STATS_COUNT_TYPE getTargetFDRType ( ) const

Returns the target FDR type.

Target FDR type can be either PSM or sequence (default).

PSM FDR is calculated from the number of decoy PSMs and target PSMs.

Sequence FDR is calculated from the number of distinct decoy peptide sequences and distinct target peptide sequences, where each distinct peptide sequence has at least one PSM.

See getTargetFDR() for more details.

Returns
target FDR type.

◆ getUnigeneIndexFile()

std::string getUnigeneIndexFile ( ) const

Optional file path to a UniGene Index file.

This only makes sense if ms_mascotresults::MSRES_GROUP_PROTEINS is set.

Returns
The unigene index file parameter if available.

◆ isUsePeptideSummary()

bool isUsePeptideSummary ( ) const

Returns a hint as to whether a peptide or protein summary should be created.

The parameter is set when you call get_ms_mascotresults_params to populate the ms_mascotresults_params object. The value returned by this function is not used by any of the ms_peptidesummary or ms_proteinsummary constructors.

Returns
True if the ms_mascotresfilebase contains any MS/MS data, false if not.

◆ operator=()

ms_mascotresults_params & operator= ( const ms_mascotresults_params & right )

Assignment operator.

Parameters
right is the source to initialise from
Returns
reference to the current object

◆ setFlag()

void setFlag | ( | const ms_mascotresults::FLAGS | flag,
 |  | bool | enabled
 | ) |  |

Toggles the value of an individual flag for use in the ms_mascotresults constructor.

Parameters
flag | Should be one of the ms_mascotresults::FLAGS values.
enabled | Choose true to set the flag and false to unset.

◆ setFlag2()

void setFlag2 | ( | const ms_peptidesummary::MSPEPSUM | flag,
 |  | bool | enabled
 | ) |  |

Toggles the value of an individual flag used in the ms_peptidesummary constructor.

Parameters
flag | Should be one of the ms_peptidesummary::MSPEPSUM values.
enabled | Choose true to set the flag and false to unset.

◆ setFlags()

void setFlags ( const unsigned int flags )

Sets the value of the flags parameter for use in the ms_mascotresults constructor.

Parameters
flags Should be one or more of the ms_mascotresults::FLAGS values OR'ed together.

◆ setFlags2()

void setFlags2 ( const unsigned int flags2 )

Sets the value of the flags2 parameter used in the ms_peptidesummary constructor.

Flags2 is an optional parameter for the peptide summary only.

Parameters
flags2 Should be one or more of the ms_peptidesummary::MSPEPSUM flags OR'ed together.

◆ setIgnoreIonsScoreBelow()

void setIgnoreIonsScoreBelow ( const double ignoreIonsScoreBelow )

Sets the value of the ignoreIonsScoreBelow parameter.

Parameters
ignoreIonsScoreBelow is an optional flag for the peptide summary only. Any peptides with a score less than this will be ignored. If the value is greater than 0 and less than 1 then this is assumed to to be a probability rather than an absolute score; the reciprocal of this value is passed to ms_peptidesummary::getPeptideThreshold() to determine the score cutoff. If the value is -1, it is treated as equivalent to minProbability.

◆ setMaxHitsToReport()

void setMaxHitsToReport ( const int maxHitsToReport )

Sets the maximum number of protein hits to report.

For details, see getMaxHitsToReport().

Parameters
maxHitsToReport is the new maximum value.

◆ setMinNumSigUniqueSequences()

void setMinNumSigUniqueSequences ( const int n )

Sets the value of the MinNumSigUniqueSequences parameter.

For details, see getMinNumSigUniqueSequences().

Parameters
n New value between 1 and 5, inclusive. If n is outside this range, it's set to 1.

◆ setMinPepLenInPeptideSummary()

void setMinPepLenInPeptideSummary ( const int minPepLenInPeptideSummary )

Sets the minimum length of peptide match to use when generating a peptide summary report.

Parameters
minPepLenInPeptideSummary is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins (see Grouping proteins together).

◆ setMinProbability()

void setMinProbability ( const double minProbability )

Sets the significance threshold.

For details, see getMinProbability() and getTargetFDR().

Parameters
minProbability specifies the significance threshold.

◆ setSingleHit()

void setSingleHit ( const char * singleHit )

Sets the optional single hit parameter.

Parameters
singleHit should only be used for getting the results for a single protein quickly. This is used for example by the the protein view report in Mascot, which just shows the matches for a single protein. See Using the singleHit parameter to return a single protein.
  • From programming languages other than C++, pass an empty string object to specify that all proteins should be used.
  • For Mascot 2.3 and later, a database index needs to be specified because the search may have been against multiple fasta files. If the database index is to be specified, the string must be of the form: "3:CH60_SHEON" and the ms_peptidesummary::MSPEPSUM_SINGLE_HIT_DBIDX must be specified in flags2. Othersise, at database index of 1 is assumed.

◆ setTargetFDR()

void setTargetFDR ( double fdr )

Sets the target FDR.

Target FDR is a value between 0 and 1. Zero means "not set" and is the default. Target FDR type is set with setTargetFDRType().

See getTargetFDR() for details.

Parameters
fdr target FDR. If outside the valid range, target FDR is set to 0.

◆ setTargetFDRType()

void setTargetFDRType ( ms_mascotresults::DECOY_STATS_COUNT_TYPE fdrType )

Sets the target FDR type.

Target FDR type can be either PSM or sequence (default).

See getTargetFDRType() for details.

Parameters
fdrType new type.

◆ setUnigeneIndexFile()

void setUnigeneIndexFile ( const char * unigeneIndexFile )

Sets the optional file path to a UniGene Index file.

Parameters
unigeneIndexFile is an optional file path to a UniGene Index file. This only makes sense if ms_mascotresults::MSRES_GROUP_PROTEINS is set.
  • From programming languages other than C++, pass an empty string object to specify no UniGene index file.

◆ setUsePeptideSummary()

void setUsePeptideSummary ( const bool usePeptideSummary )

Set the hint as to whether a peptide or protein summary should be created.

The parameter is set when you call get_ms_mascotresults_params to populate the ms_mascotresults_params object. The value returned by this function is not used by any of the ms_peptidesummary or ms_proteinsummary constructors.

Parameters
usePeptideSummary Pass in true if the result file contains MS/MS data, false if not
The documentation for this class was generated from the following files:
  • ms_mascotresults_params.hpp
  • ms_mascotresults_params.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_msr2dat28 Class Reference

  • matrix_science
  • ms_msr2dat28
Public Member Functions | List of all members
ms_msr2dat28 Class Reference
Mascot results file module

This class converts a Mascot Search Results (MSR) file to legacy .dat format. More...

#include <ms_msr2dat28.hpp>

Inheritance diagram for ms_msr2dat28:
[legend]
Collaboration diagram for ms_msr2dat28:
[legend]

Public Member Functions

ms_msr2dat28 (const ms_mascotresfile_msr &resfile)
Create a converter.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
int | getCurrentLineNumber () const
Get the current line number.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getNextLine ()
Generate the next line of text.
void | includeIndexSection (bool maybe)
Enable or disable the index section.
void | includeQuerySectionIonsLines (bool maybe)
Enable or disable inclusion of peak lists in query sections.
bool | isConversionSupported () const
Check whether this file can be converted.
bool | isIndexSectionIncluded () const
Check whether the index section is enabled.
bool | isQuerySectionIonsLinesIncluded () const
Check whether the peak lists will be included in query sections.
bool | isValid () const
Call this function to determine if there have been any errors.
void | rewind ()
Rewind to the beginning of the file.

Detailed Description

This class converts a Mascot Search Results (MSR) file to legacy .dat format.

Mascot Server 3.0 introduced a new file format, Mascot Search Results (MSR). MSR files are SQLite databases with a formal table structure. Previous Mascot versions saved search results in a plain text file with file extension .dat. The legacy .dat format is frozen and matches the output of Mascot Server 2.8.

ms_msr2dat28 can be used for converting an MSR file into legacy .dat format. This is mainly useful for third-party tools that have a custom .dat parser or tools that use Mascot Parser 2.8 or earlier for reading results. In all other cases, you are better off using the latest version of Mascot Parser to read the MSR file directly, or exporting Mascot results as mzIdentML, mzTab, XML or CSV instead of .dat format.

Overview of conversion:

  • Open the MSR file using ms_mascotresfile_msr.
  • Pass it as argument to the ms_msr2dat28 constructor.
  • Check that conversion is supported (isConversionSupported()) and the object is valid (isValid()).
  • Call ms_msr2dat28::getNextLine() repeatedly and save the result strings. End loop once getNextLine() returns false.
  • Check that the object is valid (isValid()) at end of conversion. If it is not, discard the result strings – they may be corrupt or incomplete.

Some of the data lines can be filtered out. For example, to create a "slim" .dat file without peak lists, call ms_msr2dat28::includeQuerySectionIonsLines(false) before ms_msr2dat28::getNextLine().

Constructor & Destructor Documentation

◆ ms_msr2dat28()

ms_msr2dat28 ( const ms_mascotresfile_msr & resfile )
explicit

Create a converter.

The converter defaults to generating all .dat file sections, including peak lists in query sections and the index section.

Parameters
resfile A results file from which data is read.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getCurrentLineNumber()

int getCurrentLineNumber ( ) const

Get the current line number.

Returns
Current line number, starting from 0.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getNextLine()

std::string getNextLine ( )

Generate the next line of text.

The legacy .dat format is a plain text file with UTF-8 encoding. Data is generated line by line. A line is a non-empty string terminated by LF (Linux) or CRLF (Windows), depending on the platform where the MSR file was created.

If the next line is blank, then the result string contains just the line terminator, which is one or two characters (LF or CRLF).

At end of file, the method returns the empty string (not a blank line!).

If there is a fatal error, the method immediately returns the empty string. Use isValid() and getLastErrorString() to check for errors.

Returns
a line of text if one could be generated, and empty string when you reach end of file or a fatal error.

◆ includeIndexSection()

void includeIndexSection ( bool maybe )

Enable or disable the index section.

The .dat file ends with an "index" section, which lists the line numbers of all preceding sections. The line numbers are not used by Mascot Parser, but they may be used by third-party programs. If the .dat file will be consumed by Mascot Parser, the index section can be omitted to make the file smaller.

The index section is enabled by default. If set to false, no index section is generated.

The setting takes effect from the next getNextLine() call. If you set it to false and a part of the index section has already been generated, the index section will be truncated.

Parameters
maybe True to include the index section lines, false otherwise.

◆ includeQuerySectionIonsLines()

void includeQuerySectionIonsLines ( bool maybe )

Enable or disable inclusion of peak lists in query sections.

The .dat file query sections store metadata like query title, scan number and peak lists. The peak lists are often the bulk of the .dat file, when measured in number of bytes. Some client programs like Mascot Distiller do not need the peak lists, because they have access to the raw data.

The peak lists (Ions1= lines) are enabled by default. If set to false, an empty "Ions1=" line is generated.

The setting takes effect from the next getNextLine() call.

Parameters
maybe True to include peak lists in Ions1= lines, false otherwise.

◆ isConversionSupported()

bool isConversionSupported ( ) const

Check whether this file can be converted.

This version of Parser requires certain legacy data sections to be stored as a binary blob in the MSR file. These blobs are saved by Mascot Server when the file is created.

A future version of Mascot might omit some of the blobs. If the binary blobs are missing or have an unsupported encoding, ms_msr2dat28 cannot convert the file. Please download a later version of Parser to do the conversion.

Returns
true if conversion is supported for this file, false otherwise.

◆ isIndexSectionIncluded()

bool isIndexSectionIncluded ( ) const

Check whether the index section is enabled.

Returns
true if the index section will be included, false otherwise.

◆ isQuerySectionIonsLinesIncluded()

bool isQuerySectionIonsLinesIncluded ( ) const

Check whether the peak lists will be included in query sections.

Returns
true if peak lists will be included in Ions1= lines in query sections, false otherwise.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ rewind()

void rewind ( )

Rewind to the beginning of the file.

Go back to the beginning of the .dat contents. The next getNextLine() call will start from the first line.

Inclusion filters are not affected by this call.

The documentation for this class was generated from the following files:
  • ms_msr2dat28.hpp
  • ms_msr2dat28.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide Class Reference

  • matrix_science
  • ms_peptide
Public Types | Public Member Functions | List of all members
ms_peptide Class Reference
Mascot results file module

This class encapsulates a peptide from the mascot results file. More...

#include <ms_peptide.hpp>

Public Types

enum PSM {
PSM_COMPLETE = 0 ,
PSM_CROSSLINK_ALPHA = 1 ,
PSM_CROSSLINK_BETA = 2
}
Type of data to return from accessor methods. More...
enum PSM_TYPE {
PSM_STANDARD = 0 ,
PSM_DECOY = 1 ,
PSM_ERRTOL = 2 ,
PSM_ERRTOLDECOY = 3 ,
PSM_LIBRARY = 4 ,
PSM_CROSSLINK = 5 ,
N_PSM_TYPES = 6
}
Specifies the search pass and origin of the peptide match. More...

Public Member Functions

ms_peptide ()
Default constructor.
ms_peptide (const int query, const int rank, const SEARCH_PHASE searchPhase, const double delta, const double observed, const int charge, const int numIonsMatched, const int peaksUsedFromIons1, const double ionsScore, const std::string &seriesUsedStr, const int peaksUsedFromIons2, const int peaksUsedFromIons3, const ms_peptide &pepAlpha, const ms_peptide &pepBeta, const ms_linker_site &linkerSite, const ms_mascotresults *pResults=0, const bool storeReloadableInfo=true)
Constructor to initialise a crosslinked peptide.
ms_peptide (const int query, const int rank, const SEARCH_PHASE searchPhase, const int missedCleavages, const double mrCalc, const double delta, const double observed, const int charge, const int numIonsMatched, const std::string &peptideStr, const int peaksUsedFromIons1, const std::string &varModsStr, const std::string &summedModsStr, const std::string &localModsStr, const std::string &monoLinkStr, const ms_linker_site_vector &loopLinks, const double ionsScore, const std::string &seriesUsedStr, const int peaksUsedFromIons2, const int peaksUsedFromIons3, const std::string &primaryNlStr, const std::string &summedModsNlStr, const std::string &localModsNlStr, const std::string &substStr, const std::string &componentStr, const ms_mascotresults *pResults=0, const bool storeReloadableInfo=true)
Constructor to initialise all values.
ms_peptide (const ms_peptide &src)
Copying constructor.
ms_peptide (int query, int rank, int missedCleavages, double mrCalc, double delta, double observed, int charge, int numIonsMatched, std::string peptideStr, int peaksUsedFromIons1, std::string varModsStr, double ionsScore, std::string seriesUsedStr, int peaksUsedFromIons2, int peaksUsedFromIons3, const ms_mascotresults *pResults=0, bool storeReloadableInfo=true)
Constructor to initialise most commonly used values.
~ms_peptide ()
Destructor.
bool | anyPercolatorResults () const
Return true if there are percolator results for this peptide.
bool | clearReloadableInfo ()
To save on memory, may need to call this function.
void | copyFrom (const ms_peptide *src)
Copies all content from another instance of the class.
std::string | getAmbiguityString (const PSM psmComponent=PSM_COMPLETE) const
Used for X, B and Z residues in source databases where Mascot then substitutes for a residue.
bool | getAnyMatch () const
Returns true if there was a peptide match to this spectrum.
void | getAnyProteinTermination (bool &isNterminus, bool &isCterminus, const PSM psmComponent=PSM_COMPLETE) const
Determines if the Mascot search matched the peptide as a C or N terminus.
int | getCharge () const
Returns the charge state for the parent mass.
std::string | getComponentStr (const PSM psmComponent=PSM_COMPLETE) const
Returns the quantitation method component name used for the peptide match.
double | getDelta () const
Returns the difference between the calculated and experimental relative masses.
double | getExpectationValue () const
Returns the expectation value.
int | getFirstProtAppearedIn () const
Returns the hit numberof the first protein that contains this peptide.
ms_linker_site_vector | getIntactLinks () const
Returns a vector of links between crosslinked peptides.
void | getIntactLinks (ms_linker_site_vector &vec) const
Returns a vector of links between crosslinked peptides.
double | getIonsIntensity () const
Returns the total intensity of all of the ions in the spectrum.
double | getIonsScore () const
Returns the ions score.
bool | getIsFromErrorTolerant () const
Returns true if this peptide came from the error tolerant search.
bool | getIsFromLibrary () const
Returns true if this peptide came from the library search.
bool | getLessThanMinPepLen () const
Returns true if the length of the peptide sequence is less than the minimum used for grouping.
std::string | getLocalModsNlStr (const PSM psmComponent=PSM_COMPLETE) const
Returns neutral loss information associated with any query-level modification for the peptide.
std::string | getLocalModsStr (const PSM psmComponent=PSM_COMPLETE) const
Query-level variable modifications as a string of digits.
ms_linker_site_vector | getLoopLinks (const PSM psmComponent=PSM_COMPLETE) const
Returns a vector of looplinks.
void | getLoopLinks (ms_linker_site_vector &vec, const PSM psmComponent=PSM_COMPLETE) const
Returns a vector of looplinks.
int | getMissedCleavages (const PSM psmComponent=PSM_COMPLETE) const
Returns the number of missed cleavages.
std::string | getMonoLinkStr (const PSM psmComponent=PSM_COMPLETE) const
Returns monolink information associated with a linker used as a variable modification.
double | getMrCalc (const PSM psmComponent=PSM_COMPLETE) const
Returns the calculated relative mass for this peptide .
double | getMrExperimental () const
Returns the observed mz value as a relative mass.
int | getNum13C (const double tol, const std::string tolu, const std::string mass_type) const
Returns the number of 13C peaks offset required to get a match with the supplied tolerance.
int | getNumberOfLinkedPeptides () const
Returns the number of peptides in this peptide-spectrum match.
int | getNumIonsMatched () const
Returns the number of ions matched.
int | getNumProteins () const
Returns the number of proteins that contains this peptide.
double | getObserved () const
Returns the observed mass / charge value.
int | getPeaksUsedFromIons1 () const
Returns number of peaks used from ions1.
int | getPeaksUsedFromIons2 () const
Returns number of peaks used from ions2.
int | getPeaksUsedFromIons3 () const
Returns number of peaks used from ions3.
int | getPeptideLength (const PSM psmComponent=PSM_COMPLETE) const
Returns the length in residues of the sequence found for the peptide.
std::string | getPeptideStr (bool substituteAmbiguous=true, const PSM psmComponent=PSM_COMPLETE) const
Returns the sequence found for the peptide.
void | getPercolatorScores (double *posteriorErrorProbability, double *qValue, double *internalPercolatorScore, double *mascotIonsScore) const
Returns the percolator scores and original Mascot ions score.
int | getPrettyRank () const
Similar to getRank() except that equivalent scores get the same rank.
std::string | getPrimaryNlStr (const PSM psmComponent=PSM_COMPLETE) const
Returns neutral loss information associated with any modification for the peptide.
const ms_protein * | getProtein (int num) const
Returns a pointer to a protein that contains this peptide.
const std::vector< int > | getProteins () const
Return a list of hit numbers for the proteins that contain this peptide.
int | getQuery () const
Each peptide is associate with a query.
int | getRank () const
Return the 'rank' of the peptide match.
std::string | getSeriesUsedStr () const
Returns the series used as a string.
std::string | getSummedModsNlStr (const PSM psmComponent=PSM_COMPLETE) const
Returns neutral loss information associated with any summed modification for the peptide.
std::string | getSummedModsStr (const PSM psmComponent=PSM_COMPLETE) const
Summed variable modifications as a string of digits.
std::string | getVarModsStr (const PSM psmComponent=PSM_COMPLETE) const
Variable modifications as a string of digits.
bool | isSamePeptideStr (ms_peptide *peptide, bool substituteAmbiguous=true) const
Returns true if the two peptides are identical.
bool | isSameSummedModsStr (ms_peptide *peptide) const
Returns true if the two summed variable modifications are identical.
bool | isSameVarModsStr (ms_peptide *peptide) const
Returns true if the two variable modifications are identical.
ms_peptide & | operator= (const ms_peptide &right)
C++ assignment operator.
void | setLocalModsStr (const std::string str, const PSM psmComponent=PSM_COMPLETE)
Query-level variable modifications as a string of digits.
void | setSummedModsStr (const std::string str, const PSM psmComponent=PSM_COMPLETE)
Summed variable modifications as a string of digits.
void | setVarModsStr (const std::string str, const PSM psmComponent=PSM_COMPLETE)
Variable modifications as a string of digits.

Detailed Description

This class encapsulates a peptide from the mascot results file.

This class is used for protein summary and peptide summary results. There is generally no need to create an object of this class. Simply open the results file as ms_proteinsummary or ms_peptidesummary and call ms_proteinsummary::getPeptide() or ms_peptidesummary::getPeptide().

To create an ms_peptide object that is not in a Mascot results file, use ms_aahelper::createPeptide().

Examples
peptide_list.cpp, repeat_search.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

Member Enumeration Documentation

◆ PSM

enum PSM

Type of data to return from accessor methods.

Mascot 2.7 and later can identify intact crosslinked peptides. The ms_peptide object contains data for both the peptide sequence(s) and the spectrum match.

The PSM flag specifies the type of data returned from accessor methods. It is used as an optional argument with, for example, getPeptideStr().

See Using enumerated values and static const ints in Perl, Java, Python and C# and Crosslinked search results.

Enumerator
PSM_COMPLETE | Peptide-spectrum match, also linear peptide in a non-crosslinked match.
PSM_CROSSLINK_ALPHA | Alpha peptide in a crosslinked match.
PSM_CROSSLINK_BETA | Beta peptide in a crosslinked match.

◆ PSM_TYPE

enum PSM_TYPE

Specifies the search pass and origin of the peptide match.

Mascot 3.0 and later stores the value of this enum in the psm_type columns of the MSR files for each peptide match.

Enumerator
PSM_STANDARD | Standard (FASTA search of target database)
PSM_DECOY | Decoy (FASTA search of decoy database)
PSM_ERRTOL | Error tolerant (second pass search, target database)
PSM_ERRTOLDECOY | Error tolerant decoy (second pass search, decoy database)
PSM_LIBRARY | Spectral library (SL search of target library)
PSM_CROSSLINK | Crosslink (FASTA search of intact crosslinks of proteins specified in the crosslinking method)

Constructor & Destructor Documentation

◆ ms_peptide() [1/2]

ms_peptide ( )

Default constructor.

The constructor should generally only be used from within the library.

◆ ms_peptide() [2/2]

ms_peptide | ( | int | query,
 |  | int | rank,
 |  | int | missedCleavages,
 |  | double | mrCalc,
 |  | double | delta,
 |  | double | observed,
 |  | int | charge,
 |  | int | numIonsMatched,
 |  | std::string | peptideStr,
 |  | int | peaksUsedFromIons1,
 |  | std::string | varModsStr,
 |  | double | ionsScore,
 |  | std::string | seriesUsedStr,
 |  | int | peaksUsedFromIons2,
 |  | int | peaksUsedFromIons3,
 |  | const ms_mascotresults * | pResults = 0,
 |  | bool | storeNonPersistantInfo = true
 | ) |  |

Constructor to initialise most commonly used values.

This constructor should generally only used from within the library.

Not all values can be initialised from this constructor, but this constructor will remain available in future versions of the library.

Consider using ms_aahelper::createPeptide or ms_mascotresults::getPeptide(const int, const int) const instead of this constructor.

Parameters
query | is the query number in the range 1..ms_mascotresfilebase::getNumQueries()
rank | is the rank number. See getRank() for details
missedCleavages | is the number of missed cleavages, or -1 if there was no match
mrCalc | is the relative mass of the peptide. See getMrCalc()
delta | is the difference between the calculated and experimental relative masses
observed | is the observed mass / charge value. See getObserved()
charge | is the charge state for the parent mass
numIonsMatched | is the number of ions matched. See getNumIonsMatched()
peptideStr | is the peptide sequence
peaksUsedFromIons1 | is the number of peaks used from ions1. See getPeaksUsedFromIons1()
varModsStr | is the variable modifications as a string of digits. See getVarModsStr()
ionsScore | is the ions score. See getIonsScore()
seriesUsedStr | is the ions series used as a string. See getSeriesUsedStr()
peaksUsedFromIons2 | is the number of peaks used from ions2. See getPeaksUsedFromIons2()
peaksUsedFromIons3 | is the number of peaks used from ions2. See getPeaksUsedFromIons3()
pResults | is a pointer to the results object and should be supplied where possible
storeNonPersistantInfo | should be set to true

Member Function Documentation

◆ anyPercolatorResults()

bool anyPercolatorResults ( ) const

Return true if there are percolator results for this peptide.

See Using Percolator scores for further information.

Returns
Should always return true if ms_peptidesummary::MSPEPSUM_PERCOLATOR has been specified.

◆ getAmbiguityString()

std::string getAmbiguityString ( const PSM psmComponent = PSM_COMPLETE ) const

Used for X, B and Z residues in source databases where Mascot then substitutes for a residue.

Mascot 2.0 and later will try and substitute ambiguous 'residues' with a residue to get a match. Specifically:

  • 'X' can be substituted with any residue
  • 'B' can be substituted with an Asparagine (N) or Aspartic acid (D)
  • 'Z' can be substituted with a Glutamic acid (E) or a Glutamine(Q)

This string is read from the h1_q1_subst= line of the results file for the protein summary, and from the q1_p1_subst line of the results file for the peptide summary.

Calling getPeptideStr(true) will return the substituted string.

Calling this function will return a string with the format:

   pos1,ambig1,matched1...,posn,ambigm,matchedn

For example:

  • getAmbiguityString() returns 3,B,N,4,X,A
  • getPeptideStr(false) returns AFBXK
  • getPeptideStr(true) returns AFNAK

If the peptide match is a crosslinked peptide, you must specify psmComponent. PSM_CROSSLINK_ALPHA returns the alpha peptide ambiguity string, and PSM_CROSSLINK_BETA returns the beta peptide ambiguity string. If you pass PSM_COMPLETE, the method returns the empty string.

Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
ambiguity string for this peptide

◆ getAnyMatch()

bool getAnyMatch ( ) const

Returns true if there was a peptide match to this spectrum.

Internally (and in the results file) this is signified by the first value on the line, which is the number of missed cleavages. See also getMissedCleavages().

Returns
true if there was a peptide match to this spectrum.
Examples
resfile_summary.cpp.

◆ getAnyProteinTermination()

void getAnyProteinTermination | ( | bool & | isNterminus,
 |  | bool & | isCterminus,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  | const

Determines if the Mascot search matched the peptide as a C or N terminus.

This is determined from the residues string . The residues string is a series of residues sepearated by colons (':'). If an individual residue starts with a hyphen ('-') then the peptide is an N-terminus for a protein. If an individual residue ends with a one ('1') then the peptide is a C-terminus for a protein.

If the peptide match is a crosslinked peptide, you must specify psmComponent. PSM_CROSSLINK_ALPHA returns the values for the alpha peptide, and PSM_CROSSLINK_BETA for the beta peptide. If you pass PSM_COMPLETE, the returned values are false.

Parameters
isNterminus | Set to true if the peptide was matched as an N-terminus, otherwise false.
isCterminus | Set to true if the peptide was matched as a C-terminus, otherwise false.
psmComponent | Type of data to return: complete molecule, alpha peptide or beta peptide.

◆ getCharge()

int getCharge ( ) const

Returns the charge state for the parent mass.

This will be 0 for an Mr value, or 1,2,3,4 etc. If an error has occurred, then the charge will be -100.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
The charge state for the parent mass.
Examples
resfile_summary.cpp.

◆ getComponentStr()

std::string getComponentStr ( const PSM psmComponent = PSM_COMPLETE ) const

Returns the quantitation method component name used for the peptide match.

If a search was performed using a 'precursor' quantitation method, then peptide hits may have a quantitation method component name associated with them.

The entry in the results file might be, for example:

   q1_p2_comp=light

Component strings are only saved in the results file for methods with 'Isotopes' defined. For example, with the 15N Metabolic [MD] method. In other cases, for example with the SILAC methods, the component needs to be determined from the modifications assigned to the peptide.

To determine if a method has isotopes, use the following code (error handling omitted to make it more readable):

 my $resfile = msparser::ms_mascotresfile_msr->new($filename);
 my $qfile = new msparser::ms_quant_configfile;
 $qfile->setSchemaFileName(
        "http://www.matrixscience.com/xmlns/schema/quantitation_2"
        . " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd"
        . " http://www.matrixscience.com/xmlns/schema/quantitation_1"
        . " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd"
 );

 my $numIsotopes = 0;
 if ($resfile->getQuantitation($qfile)) {
   my $method = $qfile->getMethodByNumber(0);
   for (my $idx= 0; $idx < $method->getNumberOfComponents(); $idx++) {
     my $comp = $method->getComponentByNumber($idx);
     $numIsotopes += $comp->getNumberOfIsotopes();
   }
 }
 if ($numIsotopes > 0) {
   ... expect getComponentStr to return values...
 }

See also ms_mascotresults::getComponentString

If the match is an intact crosslinked peptide, you must specify psmComponent. PSM_CROSSLINK_ALPHA returns the alpha component and PSM_CROSSLINK_BETA the beta component. If you pass PSM_COMPLETE, the method returns either the alpha component (if alpha component == beta component) or the empty string.

Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
a component name or an empty string.

◆ getDelta()

double getDelta ( ) const

Returns the difference between the calculated and experimental relative masses.

Returns
The delta in daltons.
Examples
resfile_summary.cpp.

◆ getExpectationValue()

double getExpectationValue ( ) const

Returns the expectation value.

Returns
The expectation value.

◆ getFirstProtAppearedIn()

int getFirstProtAppearedIn ( ) const

Returns the hit numberof the first protein that contains this peptide.

Returns
The hit number (1..n) or 0 if the peptide is not in any of the proteins in the ms_peptidesummary list.

◆ getIntactLinks() [1/2]

ms_linker_site_vector getIntactLinks ( ) const

Returns a vector of links between crosslinked peptides.

In Mascot 2.7, the number of links between crosslinked peptides is limited to 1.

Returns
A vector of links, or the empty vector if getNumberOfLinkedPeptides() == 0.

◆ getIntactLinks() [2/2]

void getIntactLinks ( ms_linker_site_vector & vec ) const

Returns a vector of links between crosslinked peptides.

In Mascot 2.7, the number of links between crosslinked peptides is limited to 1.

Parameters
vec is vector of links, or the empty vector if getNumberOfLinkedPeptides() == 0.

◆ getIonsIntensity()

double getIonsIntensity ( ) const

Returns the total intensity of all of the ions in the spectrum.

This value is only guaranteed to be valid for ms_peptidesummary when sorting unassigned by intensity and using the ms_peptide object returned by the ms_mascotresults::getUnassigned() function.

The same value is returned by ms_inputquery::getTotalIonsIntensity()

Returns
The total intensity of all of the ions in the spectrum.

◆ getIonsScore()

double getIonsScore ( ) const

Returns the ions score.

Note that ms_protein::getPeptideIonsScore() returns the ions score in the context of the protein match and will generally be slightly lower than the return value from this function. The Mascot results pages display the score returned from this function because results from similar proteins are displayed together.

Returns
The ions score.
Examples
peptide_list.cpp, repeat_search.cpp, and resfile_summary.cpp.

◆ getIsFromErrorTolerant()

bool getIsFromErrorTolerant ( ) const

Returns true if this peptide came from the error tolerant search.

This peptide may have been found as a result of a standard error tolerant or an integrated error tolerant search. See Error tolerant searches.

Returns
true if this peptide is from an error tolerant search

◆ getIsFromLibrary()

bool getIsFromLibrary ( ) const

Returns true if this peptide came from the library search.

This peptide may have been found as a result of a library or an integrated library search. See Spectral libraries.

Returns
true if this peptide is from a spectral library search

◆ getLessThanMinPepLen()

bool getLessThanMinPepLen ( ) const

Returns true if the length of the peptide sequence is less than the minimum used for grouping.

If the function returns true, this peptide has not been considered when grouping proteins.

In a crosslinked search, if the match is crosslinked, either alpha or beta sequence must be longer than MinPepLenInPepSummary for the match to be considered in protein grouping. The test for a standard (linear) match is to compare its sequence length, as before.

See also
ms_mascotresults::getMinPepLenInPepSummary()
Returns
true if the peptide length is less than the minimum specified in MinPepLenInPepSummary in the options section of mascot.dat.

◆ getLocalModsNlStr()

std::string getLocalModsNlStr ( const PSM psmComponent = PSM_COMPLETE ) const

Returns neutral loss information associated with any query-level modification for the peptide.

Neutral loss information is encoded in the same way as variable modification neutral losses (getPrimaryNlStr()). The neutral loss string is a string of digits, one digit for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, while numbers from 1 onwards are indices to the neutral loss vector of the modification, ms_modification::getNeutralLoss().

For example, suppose the peptide match has a query-level modification at residue 6, so that the query-level mods string is 000000100 and the neutral loss string is 000000200. To find the value of neutral loss 2, load the query-level modification object 1 (see getLocalModsStr()) and get the neutral loss vector with ms_modification::getNeutralLoss(). The neutral loss vector is 0-based, so neutral loss 2 is the second element of the vector, at index 1.

See also
getLocalModsStr()
Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
A string with neutral loss information, or an empty string.

◆ getLocalModsStr()

std::string getLocalModsStr ( const PSM psmComponent = PSM_COMPLETE ) const

Query-level variable modifications as a string of digits.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, while digits and letters 1..9 and A..W indicate the corresponding modification in the IT_MODS array of the input query. The digits can be used to look up the modification name using ms_inputquery::getLocalVarModName().

For example, suppose the query-level mods string of a peptide match is 000000100 (residue 6 modified). To load the modification object:

  1. Look up the name with ms_inputquery::getLocalVarModName(1).
  2. Load the Unimod section of the results file with ms_mascotresfilebase::getUnimod()
  3. Populate the ms_modification object from the Unimod section with ms_modification::getFromUnimod().

Note that query-level modifications can never include error tolerant modifications, so the string never contains an 'X'.

See also
ms_mascotresults::getReadableVarMods()
Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
Query-level variable modifications as a string of digits.

◆ getLoopLinks() [1/2]

ms_linker_site_vector getLoopLinks ( const PSM psmComponent = PSM_COMPLETE ) const

Returns a vector of looplinks.

If this is a linear peptide match, psmComponent is ignored.

If this is a crosslinked peptide match, psmComponent chooses between the alpha or the beta peptide. If psmComponent is PSM_COMPLETE, looplinks for both peptides are returned.

Parameters
psmComponent One of ms_peptide::PSM.
Returns
A vector of looplinks, which could be empty.

◆ getLoopLinks() [2/2]

void getLoopLinks | ( | ms_linker_site_vector & | vec,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  | const

Returns a vector of looplinks.

If this is a linear peptide match, psmComponent is ignored.

If this is a crosslinked peptide match, psmComponent chooses between the alpha or the beta peptide. If psmComponent is PSM_COMPLETE, looplinks for both peptides are returned.

Parameters
vec | is vector of looplinks, which could remain empty.
psmComponent | One of ms_peptide::PSM.

◆ getMissedCleavages()

int getMissedCleavages ( const PSM psmComponent = PSM_COMPLETE ) const

Returns the number of missed cleavages.

See also getAnyMatch().

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta).

The psmComponent argument is optional in a non-crosslinked search. For a crosslinked match, it chooses the type of data to return. With PSM_COMPLETE, the method returns -1 if alpha or beta value is -1, and otherwise returns alpha missed cleavages + beta missed cleavages. With PSM_CROSSLINK_ALPHA or PSM_CROSSLINK_BETA, the method returns the alpha or beta value, respectively.

See Crosslinked search results.

Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
Will be -1 if there was no match. Will always be 0 for a no enzyme search.
Examples
resfile_summary.cpp.

◆ getMonoLinkStr()

std::string getMonoLinkStr ( const PSM psmComponent = PSM_COMPLETE ) const

Returns monolink information associated with a linker used as a variable modification.

Monolink information is encoded in a similar way to variable modifications. If the variable modification at position i is a linker (e.g. Xlink:DSS), the value at position i of the monolink string records the index of the monolink (e.g. "neutral loss" element 1 of Xlink:DSS (K)).

Use the relevant number from this function as an argument to ms_mascotresfilebase::getMonoLinkModification() to determine the monolink delta used for scoring.

Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
A string with monolink index information, or an empty string if no monolinks were searched.

◆ getMrCalc()

double getMrCalc ( const PSM psmComponent = PSM_COMPLETE ) const

Returns the calculated relative mass for this peptide .

Takes into account any modifications.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta).

The psmComponent argument is optional in a non-crosslinked search. For a crosslinked match, it chooses the type of data to return. With PSM_COMPLETE, the method returns the mass of the intact molecule: alpha Mr + beta Mr + linker mass. With PSM_CROSSLINK_ALPHA or PSM_CROSSLINK_BETA, the method returns the alpha or beta value, respectively, without the linker.

See Crosslinked search results.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
The relative mass.
Examples
resfile_summary.cpp.

◆ getMrExperimental()

double getMrExperimental ( ) const

Returns the observed mz value as a relative mass.

This is equal to getMrCalc() + getDelta(), so note that this will be zero if there was no match because there is no calculated value and no delta. It is generally recommended that you call ms_mascotresfilebase::getObservedMrValue() since it will always return the relative mass, even for no match.

Returns
The observed mz value as a relative mass.
Examples
resfile_summary.cpp.

◆ getNum13C()

int getNum13C | ( | const double | tol,
 |  | const std::string | tolu,
 |  | const std::string | mass_type
 | ) |  | const

Returns the number of 13C peaks offset required to get a match with the supplied tolerance.

Sometimes, peak detection chooses the 13C peak rather than the 12C. In extreme cases, it may pick the 13C2 peak. The normal test for a precursor match is

tol > absolute(exp - calc)

Assuming the mass values and tolerance are in Da, and the PEP_ISOTOPE_ERROR field is set to 1, the test will also succeed for

tol > absolute(exp - calc - 1)

If the PEP_ISOTOPE_ERROR field is set to 2, the test will succeed for the above two conditions, plus

tol > absolute(exp - calc - 2)

This means that you can use a tight mass tolerance and still get a match to a 13C peak. If you are using a very high accuracy instrument, note that the precise shifts are the carbon isotope spacings of 1.0033548 and 2.0067096, rather than 1 and 2. However, if average rather than isotopic masses are specified in the search, the values will be 0.9926548 and 1.9853096

Parameters
tol | Is the tolerance for the search. The return value from matrix_science::ms_searchparams::getTOL() may be used.
tolu | Is the units of the tolerance supplied when performing the search. The return value from matrix_science::ms_searchparams::getTOLU() may be used.
mass_type | will either be Monoisotopic or Average. The return value from matrix_science::ms_searchparams::getMASS() may be used.
Returns
  • 0 if the delta is within the applied tolerance;
  • 1 if the delta minus 1.0033548is within the tolerance;
  • 2 if the delta minus 2.0067096 is within the tolerance;
  • -1 if there was no match (i.e. getAnyMatch() returns 0) or if invalid tolerance units are supplied or if the delta is outside any of the above ranges.

◆ getNumberOfLinkedPeptides()

int getNumberOfLinkedPeptides ( ) const

Returns the number of peptides in this peptide-spectrum match.

In Mascot 2.7, there are two possible return values:

  • 0 (no crosslinking)
  • 2 (crosslinked alpha and beta peptide)
Returns
The number of peptides in this peptide-spectrum match.

◆ getNumIonsMatched()

int getNumIonsMatched ( ) const

Returns the number of ions matched.

Mascot begins by selecting a small number of experimental peaks on the basis of normalised intensity. It calculates a probability based score according to the number of matches. It then increases the number of selected peaks and recalculates the score. It continues to iterate until it is clear that the score can only get worse. It then reports the best score it found, which should correspond to an optimum selection, taking mostly real peaks and leaving behind mostly noise.

Mascot is not trying to find all possible matches in the spectrum. Many spectra have "peak at every mass" noise, and can match any ion series from any sequence if there is no intensity discrimination. So, you may look at a peptide view report and see obvious matches that are unlabelled. However, if the peak selection was to be extended to include these additional matches, it would also have to include a number of additional noise peaks, and the score would decrease.

Returns
The number of ions matched in order to get the highest score.
Examples
resfile_summary.cpp.

◆ getNumProteins()

int getNumProteins ( ) const

Returns the number of proteins that contains this peptide.

See also
getProtein(), ms_mascotresults::getAllProteinsWithThisPepMatch()
Returns
The number of proteins in the current results set that contained this peptide.

◆ getObserved()

double getObserved ( ) const

Returns the observed mass / charge value.

Returns
The observed mass / charge value.
Examples
resfile_summary.cpp.

◆ getPeaksUsedFromIons1()

int getPeaksUsedFromIons1 ( ) const

Returns number of peaks used from ions1.

It is possible, but unusual, to specify which ions series particular ions come from: https://www.matrixscience.com/help/sq_help.html#IONS

If a search specifies that some ions are from the b series, some are from the y series and that some are from any series then these will be stored separately in Ions1, Ions2 and Ions3. The number of matches to each set of ions is avaible using getPeaksUsedFromIons1(), getPeaksUsedFromIons2() and getPeaksUsedFromIons3().

For most searches, getPeaksUsedFromIons1() is the only function that needs to be used.

See also
getNumIonsMatched()
Returns
The number of peaks used from ions1.
Examples
resfile_summary.cpp.

◆ getPeaksUsedFromIons2()

int getPeaksUsedFromIons2 ( ) const

Returns number of peaks used from ions2.

It is possible, but unusual, to specify which ions series particular ions come from: https://www.matrixscience.com/help/sq_help.html#IONS

If a search specifies that some ions are from the b series, some are from the y series and that some are from any series then these will be stored separately in Ions1, Ions2 and Ions3. The number of matches to each set of ions is avaible using getPeaksUsedFromIons1(), getPeaksUsedFromIons2() and getPeaksUsedFromIons3().

For most searches, getPeaksUsedFromIons1() is the only function that needs to be used.

See also
getNumIonsMatched()
Returns
The number of peaks used from ions2.
Examples
resfile_summary.cpp.

◆ getPeaksUsedFromIons3()

int getPeaksUsedFromIons3 ( ) const

Returns number of peaks used from ions3.

It is possible, but unusual, to specify which ions series particular ions come from: https://www.matrixscience.com/help/sq_help.html#IONS

If a search specifies that some ions are from the b series, some are from the y series and that some are from any series then these will be stored separately in Ions1, Ions2 and Ions3. The number of matches to each set of ions is avaible using getPeaksUsedFromIons1(), getPeaksUsedFromIons2() and getPeaksUsedFromIons3().

For most searches, getPeaksUsedFromIons1() is the only function that needs to be used.

See also
getNumIonsMatched()
Returns
The number of peaks used from ions3.
Examples
resfile_summary.cpp.

◆ getPeptideLength()

int getPeptideLength ( const PSM psmComponent = PSM_COMPLETE ) const

Returns the length in residues of the sequence found for the peptide.

This should be faster than calling getPeptideStr() and determining the length of the returned string.

Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
Returns the length in residues of the sequence found for the peptide.

◆ getPeptideStr()

std::string getPeptideStr | ( | bool | substituteAmbiguous = true,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  | const

Returns the sequence found for the peptide.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to return. If you pass PSM_COMPLETE, the method returns a concatenated sequence: alpha sequence + "][" + beta sequence. The characters "][" represent the alpha C-terminus and beta N-terminus.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters
substituteAmbiguous | If true, and if there were any ambiguous residues, then the returned result will have the substituted residues rather than an 'X', 'B' or 'Z'.
psmComponent | Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
The peptide sequence – will be the empty string if there was no match.
Examples
peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ getPercolatorScores()

void getPercolatorScores | ( | double * | posteriorErrorProbability,
 |  | double * | qValue,
 |  | double * | internalPercolatorScore,
 |  | double * | mascotIonsScore
 | ) |  | const

Returns the percolator scores and original Mascot ions score.

See Using Percolator scores for further information and Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | posteriorErrorProbability | is the probability that individual match with this Percolator score is random match.
[out] | qValue | is equivalent to the FDR if all matches with this Percolator score or higher were accepted
[out] | internalPercolatorScore | is not used in Mascot Parser. See Percolator documentation.
[out] | mascotIonsScore | is the ions score that Mascot originally assigned.

◆ getPrettyRank()

int getPrettyRank ( ) const

Similar to getRank() except that equivalent scores get the same rank.

For a peptide summary, the top 10 peptide matches for each query are saved. These are scored with rank 1 to 10, and the rank can be obtained using the getRank() function. However, if say, the top three matches are the same, it is generally better to say (in a report) that these are all rank 1. The following table shows an example:

Rank | Pretty Rank | Score | Peptide | Protein
1 | 1 | 78 | ABCDEFG |
2 | 1 | 78 | ABCDEGF | gi|123456
3 | 1 | 78 | BACDEFG |
4 | 4 | 65 | ASDADSD |
5 | 4 | 65 | SDFSGSD |
6 | 6 | 12 | DFGHDFG |
7 | 7 | 8 | SSDFDFD |
8 | 8 | 7 | RTYRYRY |
9 | 9 | 4 | RTYRYRY |
10 | 10 | 2 | TYUTUTU |

For a protein summary, getPrettyRank() will always return the same as getRank().

Returns
The 'pretty rank'.
Examples
resfile_summary.cpp.

◆ getPrimaryNlStr()

std::string getPrimaryNlStr ( const PSM psmComponent = PSM_COMPLETE ) const

Returns neutral loss information associated with any modification for the peptide.

Neutral loss information is encoded in a similar way to variable modifications. Use the relevant number from this function as an offset into the array returned from ms_searchparams::getVarModsNeutralLosses() to determine the neutral loss used for scoring.

The neutral loss string is a string of digits, one digit for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates NeutralLoss1, 2 indicates NeutralLoss2 etc., in the masses section.

Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
A string with neutral loss information, or an empty string.

◆ getProtein()

const ms_protein * getProtein ( int num ) const

Returns a pointer to a protein that contains this peptide.

It is normally better to use ms_mascotresults::getAllProteinsWithThisPepMatch() than this function.

This function returns all the proteins that are seen in the top level report that contain this peptide. If grouping is enabled, it will only return proteins that are returned from ms_mascotresults::getHit – it will not return proteins that would be returned from ms_mascotresults::getNextSimilarProtein().

The function will only return proteins up to the number of hits that were requested when creating the ms_mascotresults object.

See Maintaining object references: two rules of thumb.

Parameters
num should be in the range 1.. getNumProteins() or this function will return a null value.
Returns
A pointer to protein if found, or a null value if not found.

◆ getProteins()

const std::vector< int > getProteins ( ) const

Return a list of hit numbers for the proteins that contain this peptide.

See also
getProtein()
Returns
a vector of protein hit numbers. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getQuery()

int getQuery ( ) const

Each peptide is associate with a query.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
The query number in the range 1..ms_mascotresfilebase::getNumQueries().
Examples
resfile_summary.cpp.

◆ getRank()

int getRank ( ) const

Return the 'rank' of the peptide match.

Each spectrum will match to a number of different peptides. The best (highest scoring) match will have a rank value of 1.

In a peptide summary, this will be in the range 1..10.

In a protein summary, this will be the hit number (1..50).

See also
ms_mascotresults::getMaxRankValue()
Returns
The rank.
Examples
resfile_summary.cpp.

◆ getSeriesUsedStr()

std::string getSeriesUsedStr ( ) const

Returns the series used as a string.

The string is a set of 0s and 1s and 2s.

  • 0 - no significant match
  • 1 - significant match, but not used in score
  • 2 - significant match, used for scoring

The 'position' in the string is used to indicate which series:

  • 01 - A series
  • 02 - placeholder (was A - NH3 series in older versions of Mascot)
  • 03 - A++ series
  • 04 - B series
  • 05 - placeholder (was B - NH3 series in older versions of Mascot)
  • 06 - B++ series
  • 07 - Y series
  • 08 - placeholder (was Y - NH3 series in older versions of Mascot)
  • 09 - Y++ series
  • 10 - C series
  • 11 - C++ series
  • 12 - X series
  • 13 - X++ series
  • 14 - Z series
  • 15 - Z++ series
  • 16 - Z+H series
  • 17 - Z+H++ series
  • 18 - Z+2H series
  • 19 - Z+2H++ series

For example, 00020010000000000 would indicate b series used for scoring, and y series significant, but not used for scoring. Note that earlier versions of Mascot did not look for all these ions series, so the string will not necessarily be 17 characters long.

Returns
series used
Examples
resfile_summary.cpp.

◆ getSummedModsNlStr()

std::string getSummedModsNlStr ( const PSM psmComponent = PSM_COMPLETE ) const

Returns neutral loss information associated with any summed modification for the peptide.

Neutral loss information is encoded in a similar way to summed modifications. Use the relevant number from this function as an offset into the array returned from ms_searchparams::getVarModsNeutralLosses() to determine the neutral loss used for scoring.

The neutral loss string is a string of digits, one digit for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates NeutralLoss1, 2 indicates NeutralLoss2 etc., in the masses section.

See also
getSummedModsStr()
Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
A string with neutral loss information, or an empty string.

◆ getSummedModsStr()

std::string getSummedModsStr ( const PSM psmComponent = PSM_COMPLETE ) const

Summed variable modifications as a string of digits.

When two modifications occur at the same site, the extra modification is stored in the q1_p1_summed_mods= string in the results file. Summed mods are only supported when using quantitation methods with exclusive modifications. The exclusive modification will always be returned by getVarModsStr(), while getSummedModsStr() is used for post translational modifications to the same site.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates delta1, 2 indicates delta2 etc., in the masses section. An 'X' is used to indicate an error tolerant modification that can be retrieved using matrix_science::ms_peptidesummary::getErrTolModName().

To support numbers greater than 9, the letters A..W are permitted, with A being 10 and W being 32.

See also
Multiple modifications for the same site
ms_peptide::getVarModsStr()
ms_mascotresults::getReadableVarMods()
ms_searchparams::getMULTI_SITE_MODS
Increase in the number of variable modifications.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to return.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
Summed variable modifications as a string of digits.

◆ getVarModsStr()

std::string getVarModsStr ( const PSM psmComponent = PSM_COMPLETE ) const

Variable modifications as a string of digits.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates delta1, 2 indicates delta2 etc., in the masses section. An 'X' is used to indicate an error tolerant modification that can be retrieved using matrix_science::ms_peptidesummary::getErrTolModName().

To support numbers greater than 9, the letters A..W are permitted, with A being 10 and W being 32.

See also Increase in the number of variable modifications.

See also
ms_mascotresults::getReadableVarMods()

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to return.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
Variable modifications as a string of digits.
Examples
resfile_summary.cpp.

◆ isSamePeptideStr()

bool isSamePeptideStr | ( | ms_peptide * | peptide,
 |  | bool | substituteAmbiguous = true
 | ) |  | const

Returns true if the two peptides are identical.

Calling this function may be faster than calling getPeptideStr() twice and doing the compare on the returned peptide.

Parameters
peptide | is a pointer to the peptide object with the sequence to compare.
substituteAmbiguous | should be set to true to compare sequences after substituting any X for the residue used to get a match.
Returns
true if the peptides are the same.

◆ isSameSummedModsStr()

bool isSameSummedModsStr ( ms_peptide * peptide ) const

Returns true if the two summed variable modifications are identical.

Calling this function may be faster than calling getSummedModsStr() twice and doing the compare on the returned peptide.

Parameters
peptide is a pointer to the peptide object with the summed mods string to compare.
Returns
True if the summed variable modifications for the two peptides are the same.

◆ isSameVarModsStr()

bool isSameVarModsStr ( ms_peptide * peptide ) const

Returns true if the two variable modifications are identical.

Calling this function may be faster than calling getVarModsStr() twice and doing the compare on the returned peptide.

Parameters
peptide is a pointer to the peptide object with the mods string to compare.
Returns
True if the variable modifications for the two peptides are the same.

◆ setLocalModsStr()

void setLocalModsStr | ( | const std::string | str,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  |

Query-level variable modifications as a string of digits.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, while digits and letters 1..9 and A..W indicate the corresponding modification in the IT_MODS array of the input query.

Note that query-level modifications can never include error tolerant modifications, so the string never contains an 'X'.

See also
ms_mascotresults::getReadableVarMods()

Setting the string does not cause a re-calculation of the peptide mass – this needs to be done manually.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to set. The caller is responsible for data consistency between PSM_COMPLETE, PSM_CROSSLINK_ALPHA and PSM_CROSSLINK_BETA.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters
str | is the new query-level variable modifications as a string of digits.
psmComponent | Type of data to set: complete molecule, alpha peptide or beta peptide.

◆ setSummedModsStr()

void setSummedModsStr | ( | const std::string | str,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  |

Summed variable modifications as a string of digits.

When two modifications occur at the same site, the extra modification is stored in the q1_p1_summed_mods= string in the results file. Summed mods are only supported when using quantitation methods with exclusive modifications. The exclusive modification will always be returned by getVarModsStr(), while getSummedModsStr() is used for post translational modifications to the same site.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates delta1, 2 indicates delta2 etc., in the masses section. An 'X' is used to indicate an error tolerant modification that can be retrieved using matrix_science::ms_peptidesummary::getErrTolModName().

To support numbers greater than 9, the letters A..W are permitted, with A being 10 and W being 32.

See also Increase in the number of variable modifications.

See also
ms_mascotresults::getReadableVarMods()

Setting the string does not cause a re-calculation of the peptide mass – this needs to be done manually.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to set. The caller is responsible for data consistency between PSM_COMPLETE, PSM_CROSSLINK_ALPHA and PSM_CROSSLINK_BETA.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters
str | is the new variable modifications as a string of digits.
psmComponent | Type of data to set: complete molecule, alpha peptide or beta peptide.

◆ setVarModsStr()

void setVarModsStr | ( | const std::string | str,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  |

Variable modifications as a string of digits.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates delta1, 2 indicates delta2 etc., in the masses section. An 'X' is used to indicate an error tolerant modification that can be retrieved using matrix_science::ms_peptidesummary::getErrTolModName().

To support numbers greater than 9, the letters A..W are permitted, with A being 10 and W being 32.

See also Increase in the number of variable modifications.

See also
ms_mascotresults::getReadableVarMods()

Setting the string does not cause a re-calculation of the peptide mass – this needs to be done manually.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to set. The caller is responsible for data consistency between PSM_COMPLETE, PSM_CROSSLINK_ALPHA and PSM_CROSSLINK_BETA.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters
str | is the new variable modifications as a string of digits.
psmComponent | Type of data to set: complete molecule, alpha peptide or beta peptide.
The documentation for this class was generated from the following files:
  • ms_peptide.hpp
  • ms_peptide.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptidesummary Class Reference

  • matrix_science
  • ms_peptidesummary
Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
ms_peptidesummary Class Reference
Mascot results file module

Use this class to get peptide summary results. More...

#include <ms_peptidesummary.hpp>

Inheritance diagram for ms_peptidesummary:
[legend]
Collaboration diagram for ms_peptidesummary:
[legend]

Public Types

enum BUGFIX_NUM {
BUGFIX_10780 = 10780 ,
BUGFIX_10995 = 10995 ,
BUGFIX_11002 = 11002 ,
BUGFIX_11018 = 11018 ,
BUGFIX_11235 = 11235 ,
BUGFIX_11254 = 11254 ,
BUGFIX_11344 = 11344 ,
BUGFIX_11411 = 11411 ,
BUGFIX_11425 = 11425 ,
BUGFIX_11438 = 11438 ,
BUGFIX_11483 = 11483 ,
BUGFIX_11499 = 11499 ,
BUGFIX_11856 = 11856 ,
BUGFIX_12123 = 12123 ,
BUGFIX_12317 = 12317 ,
BUGFIX_11481 = 11481 ,
BUGFIX_12538 = 12538 ,
BUGFIX_12729 = 12729 ,
BUGFIX_12740 = 12740 ,
BUGFIX_13324 = 13324 ,
BUGFIX_12447 = 12447 ,
BUGFIX_13759 = 13759
}
bugNum values for isDataCached(). More...
enum CACHE_STATUS {
CACHE_MISSING_RESFILE = 0x10000 ,
RESFILE_CACHE_FILE_NOT_PRESENT = 0x00001 ,
RESFILE_CACHE_BEING_CREATED = 0x00002 ,
RESFILE_CACHE_DISABLED_IN_OPTIONS = 0x00004 ,
RESFILE_CACHE_VALID = 0x00008 ,
RESFILE_CACHE_CAN_CREATE = 0x00010 ,
PEPSUMMARY_CACHE_FILE_NOT_PRESENT = 0x00100 ,
PEPSUMMARY_CACHE_BEING_CREATED = 0x00200 ,
PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS = 0x00400 ,
PEPSUMMARY_CACHE_VALID = 0x00800 ,
PEPSUMMARY_CACHE_CAN_CREATE = 0x01000 ,
PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE = 0x02000 ,
PEPSUMMARY_CACHE_NOT_FOR_PMF = 0x04000
}
Returned by the willCreateCache function. More...
enum DB_MATCH_TYPE {
DM_FASTA = 0 ,
DM_SPECTRAL_LIBRARY = 1 ,
DM_BOTH = 2 ,
DM_FASTA_FIRST_PASS = 3 ,
DM_FASTA_SECOND_PASS = 4
}
Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram(). More...
enum DECOY_STATS_COUNT_TYPE {
DS_COUNT_PSM = 0 ,
DS_COUNT_SEQUENCE = 1
}
Type of object counted by getNumHitsAboveIdentity() and friends. More...
enum FIND_COMPARE_FLAGS {
FC_COMPLETESTR = 0x00000001 ,
FC_SUBSTR = 0x00000002 ,
FC_STARTSTR = 0x00000003 ,
FC_STRTOK = 0x00000004 ,
FC_MASK_STR_PART = 0x0000000F ,
FC_CASE_INSENSITIVE = 0x00000000 ,
FC_CASE_SENSITIVE = 0x00000010 ,
FC_MASK_CASE = 0x000000F0 ,
FC_FORWARD = 0x00000000 ,
FC_REVERSE = 0x00000100 ,
FC_MASK_DIRECTION = 0x00000F00 ,
FC_RESTRICT_TO_HIT = 0x00001000 ,
FC_LOOP_INTO_UNASSIGNED = 0x00002000 ,
FC_LOOP_FROM_UNASSIGNED = 0x00004000 ,
FC_UNASSIGNED_MASK = 0x00006000 ,
FC_SEARCH_ALL_RANKS = 0x00008000 ,
FC_ALL_PEPTIDES = 0x00000000 ,
FC_ALL_PEPTITDES = 0x00000000 ,
FC_SIGNIFICANT_PEPTIDES = 0x00010000 ,
FC_SEARCH_IGNORED_RANKS = 0x00020000 ,
FC_SCORING_MASK = 0x000F0000 ,
FC_PROTEIN_IGN_SAMESETS = 0x00100000 ,
FC_PROTEIN_IGN_SUBSETS = 0x00200000 ,
FC_PROTEIN_IGN_FAMILY = 0x00400000 ,
FC_PROTEIN_IGN_MASK = 0x00F00000 ,
FC_PROTEIN_INC_ALT_ACC = 0x01000000
}
Flags to specify how comparisons are performed in the find functions. More...
enum FIND_FLAGS {
FT_PEPTIDE_EXP_MZ = 0x00000001 ,
FT_PEPTIDE_EXP_MR = 0x00000002 ,
FT_PEPTIDE_CALC_MZ = 0x00000004 ,
FT_PEPTIDE_CALC_MR = 0x00000008 ,
FT_PEPTIDE_STRING = 0x00000010 ,
FT_PEPTIDE_QUERY = 0x00000020 ,
FT_PEPTIDE_VARMOD = 0x00000040 ,
FT_PEPTIDE_FIXMOD = 0x00000080 ,
FT_PEPTIDE_ETMOD = 0x00000100 ,
FT_PEPTIDE_SLMOD = 0x00000200 ,
FT_PEPTIDE_VARMOD_BYNAME = 0x00000400 ,
FT_PEPTIDE_FIND_MASK = 0x00000FFF ,
FT_PROTEIN_ACCESSION = 0x00001000 ,
FT_PROTEIN_DESCRIPTION = 0x00002000
}
Flags for findPeptides() and findProteins(). More...
enum FLAGS {
MSRES_NOFLAG = 0x00000000 ,
MSRES_GROUP_PROTEINS = 0x00000001 ,
MSRES_SHOW_SUBSETS = 0x00000002 ,
MSRES_SUBSETS_DIFF_PROT = 0x00000004 ,
MSRES_REQUIRE_BOLD_RED = 0x00000008 ,
MSRES_SHOW_ALL_FROM_ERR_TOL = 0x00000010 ,
MSRES_IGNORE_PMF_MIXTURE = 0x00000020 ,
MSRES_MUDPIT_PROTEIN_SCORE = 0x00000040 ,
MSRES_DECOY = 0x00000080 ,
MSRES_INTEGRATED_ERR_TOL = 0x00000100 ,
MSRES_ERR_TOL = 0x00000200 ,
MSRES_MAXHITS_OVERRIDES_MINPROB = 0x00000400 ,
MSRES_CLUSTER_PROTEINS = 0x00000800 ,
MSRES_DUPE_INCL_IN_SCORE_NONE = 0x00000000 ,
MSRES_DUPE_INCL_IN_SCORE_A = 0x00002000 ,
MSRES_DUPE_INCL_IN_SCORE_B = 0x00004000 ,
MSRES_DUPE_INCL_IN_SCORE_C = 0x00008000 ,
MSRES_DUPE_INCL_IN_SCORE_D = 0x00010000 ,
MSRES_DUPE_INCL_IN_SCORE_E = 0x00020000 ,
MSRES_DUPE_INCL_IN_SCORE_F = 0x00040000 ,
MSRES_DUPE_INCL_IN_SCORE_G = 0x00080000 ,
MSRES_DUPE_INCL_IN_SCORE_H = 0x00100000 ,
MSRES_DUPE_INCL_IN_SCORE_I = 0x00200000 ,
MSRES_DUPE_REMOVE_NONE = 0x00400000 ,
MSRES_DUPE_REMOVE_A = 0x00800000 ,
MSRES_DUPE_REMOVE_B = 0x01000000 ,
MSRES_DUPE_REMOVE_C = 0x02000000 ,
MSRES_DUPE_REMOVE_D = 0x04000000 ,
MSRES_DUPE_REMOVE_E = 0x08000000 ,
MSRES_DUPE_REMOVE_F = 0x10000000 ,
MSRES_DUPE_REMOVE_G = 0x20000000 ,
MSRES_DUPE_REMOVE_H = 0x40000000 ,
MSRES_DUPE_REMOVE_I = 0x80000000 ,
MSRES_DUPE_REMOVE_I = 0x80000000 ,
MSRES_DUPE_DEFAULT = 0x04800000
}
Flags for the type of results. More...
enum HOMOLOGY_THRESHOLD_SOURCE {
}
Flags for getHomologyThreshold() More...
enum IONS_HISTOGRAM {
IH_INCLUDE_TOP_MATCHES = 0x0000 ,
IH_INCLUDE_TOP_10_MATCHES = 0x0001
}
Flags for getIonsScoreHistogram(). More...
enum MSPEPSUM {
MSPEPSUM_NONE = 0x0000 ,
MSPEPSUM_PERCOLATOR = 0x0001 ,
MSPEPSUM_USE_CACHE = 0x0002 ,
MSPEPSUM_SINGLE_HIT_DBIDX = 0x0004 ,
MSPEPSUM_USE_HOMOLOGY_THRESH = 0x0008 ,
MSPEPSUM_NO_PROTEIN_GROUPING = 0x0010 ,
MSPEPSUM_DISCARD_RELOADABLE = 0x0020 ,
MSPEPSUM_DEFERRED_CREATE = 0x0040 ,
MSPEPSUM_CACHE_IGNORE_DATE_CHANGE = 0x0080 ,
MSPEPSUM_REMOVE_CHIMERIC_DUPES = 0x0100 ,
MSPEPSUM_SL_INTEGRATED = 0x0200 ,
MSPEPSUM_SL_ONLY = 0x0400 ,
MSPEPSUM_CROSSLINK_INTEGRATED = 0x0800 ,
MSPEPSUM_CROSSLINK_ONLY = 0x1000
}
flags2 for ms_peptidesummary introduced in Mascot Parser 2.3. More...
enum QL_FLAG {
}
Flags for getQueryList(). More...
enum QUANT_COMPONENT_STATUS {
QCS_OK ,
QCS_OK_NO_MATCH ,
QCS_ERROR_NO_METHOD ,
QCS_ERROR_NO_COMPONENTS ,
QCS_ERROR_BAD_COMPONENT_NAME ,
QCS_OK_MULTIPLE_MATCHES
}
Return codes for getQuantitationComponentForPeptide(). More...
enum sortBy {
QUERY ,
SCORE ,
INTENSITY
}
Flags for createUnassignedList(). More...
enum THRESHOLD_TYPE {
TT_HOMOLOGY = 0x0000 ,
TT_IDENTITY = 0x0001 ,
TT_PEPSUM_DEFAULT = 0x0002
}
Flags for getPeptideThreshold() More...
enum TREE_CLUSTER_METHOD {
}
Flags for getTreeClusterNodes(). More...
enum UNIQUE_PEP_RULES {
UPR_WITHIN_FAMILY = 0x0001 ,
UPR_WITHIN_FAMILY_MEMBER = 0x0002 ,
UPR_IGNORE_SUBSET_PROTEINS = 0x0004 ,
UPR_DEFAULT = (UPR_WITHIN_FAMILY_MEMBER + UPR_IGNORE_SUBSET_PROTEINS)
}
Flags for isPeptideUnique(). More...

Public Member Functions

ms_peptidesummary (const ms_mascotresfilebase &resfile, const ms_mascotresults_params &parameters)
Call this constructor once to create peptide summary results.
ms_peptidesummary (const ms_mascotresfilebase &resfile, const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS, double minProbability=0.0, int maxHits=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE)
[Deprecated] Call this constructor once to create peptide summary results.
virtual bool | anyEmPAI () const
virtual bool | anyNumDiscoveredMods () const
Return true if modification discovery statistics are available.
void | cancelCreateSummary (bool newValue=true)
Cancel the call to createSummary()
virtual bool | createSummary ()
Create the summary using a separate call after the ms_peptidesummary_dat object has been created.
bool | createUnassignedList (sortBy s=QUERY)
To have a list of unassigned peptides, need to call this first.
bool | dumpCDB (const std::string dumpFileName)
virtual int | findPeptides (const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const
Find the next hit that contains peptides with the specified attribute.
virtual int | findProteins (const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified attributes.
virtual int | findProteinsByAccession (const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified accession.
virtual int | findProteinsByDescription (const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified description.
virtual void | freeHit (const int hit)
Frees any memory associated with the passed hit number.
virtual int | getAllFamilyMembersWithThisPepMatch (const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const
Return a list of (top level) family proteins that have a match to the specified q and p.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const
Returns a complete list of all the accessions that contained the peptide matched by this result.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const
Returns a complete list of all the accessions that contained the peptide matched by this result.
virtual int | getAvePeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the average threshold value for all MS-MS data sets.
std::string | getCacheFileName () const
Returns the filename of the cache file.
virtual bool | getComponentIntensity (const int q, const int p, const std::string &componentName, double &value, double &rawValue) const
Returns the component intensity for reporter or multiplex methods.
virtual const ms_protein * | getComponentProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
virtual std::string | getComponentString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return q1_p2_comp string value.
bool | getCreateSummaryProgress (int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const
Return progress for the createSummary() call.
const ms_crosslinking_method * | getCrosslinkingMethod () const
Returns the crosslinking method from the results file.
virtual std::vector< double > | getDiscoveredErrTolModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all error tolerant modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredErrTolModNames () const
Return the names of all error tolerant modifications discovered in this search.
virtual std::vector< double > | getDiscoveredLocalModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all query-level modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredLocalModNames () const
Return the names of all query-level modifications discovered in this search.
virtual double | getErrTolModDelta (const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const
Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.
virtual std::string | getErrTolModifiedNaSeq (const int q, const int p) const
Return the modified sequence of nucleic acids after a single base modification in an error tolerant search.
virtual std::vector< double > | getErrTolModMasterNeutralLoss (const int q, const int p) const
Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.
virtual std::string | getErrTolModMasterString (const int q, const int p) const
Return the complete error tolerant mod master neutral loss string from q1_p1_et_mods_master.
virtual std::string | getErrTolModName (const int q, const int p, std::string *modString=NULL) const
Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.
virtual double | getErrTolModNeutralLoss (const int q, const int p) const
Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.
virtual std::vector< double > | getErrTolModPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.
virtual std::string | getErrTolModPepString (const int q, const int p) const
Return the complete error tolerant mod peptide neutral loss string from q1_p1_et_mods_pep.
virtual std::vector< double > | getErrTolModReqPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.
virtual std::string | getErrTolModReqPepString (const int q, const int p) const
Return the complete error tolerant mod required peptide neutral loss string from q1_p1_et_mods_reqpep.
virtual std::vector< double > | getErrTolModSlaveNeutralLoss (const int q, const int p) const
Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.
virtual std::string | getErrTolModSlaveString (const int q, const int p) const
Return the complete error tolerant mod slave neutral loss string from q1_p1_et_mods_slave.
virtual std::string | getErrTolModString (const int q, const int p) const
Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.
virtual std::string | getErrTolOriginalNaSeq (const int q, const int p) const
Return the original sequence of nucleic acids before a single base modification in an error tolerant search.
virtual double | getErrTolProbabilityThreshold () const
unsigned int | getFlags () const
Returns the flags value passed to the constructor.
unsigned int | getFlags2 () const
Return the flags2 value passed to the ms_peptidesummary constructor.
virtual ms_protein * | getHit (const int hit, const int memberNumber=0) const
Return the ms_protein hit - returns null if hit > number of hits.
virtual int | getHomologyThreshold (const int query, double OneInXprobRnd, const int rank=1) const
Returns the 'homology' threshold.
virtual int | getHomologyThresholdForHistogram (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns the value for the 'yellow section' in the histogram.
virtual double | getIonsScore (const int q, const int p, const bool decoy) const
Returns an ions score quickly without having to load an ms_peptide object.
virtual std::vector< int > | getIonsScoreHistogram (IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns a list of counts for binned ions scores.
void | getLibraryEntryId (const int q, const int p, std::vector< int > &dbIdx, std::vector< int > &offset, std::vector< std::string > &checksum, std::vector< std::string > &mods) const
Return the database number, MSP file offset, checksum and modifications of the matched spectral library entry.
virtual std::string | getLibraryModString (const int q, const int p) const
Return the modification string of the spectral library match from q1_p1_SLmod.
virtual int | getMaxPeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the max threshold value for all MS-MS data sets.
virtual int | getMaxRankValue () const
Returns the maximum 'rank' or 'hit' or 'p' value.
int | getMinPepLenInPepSummary () const
Peptides shorter than this are ignored when putting proteins into groups.
virtual ms_protein * | getNextFamilyProtein (const int masterHit, const int id) const
Find the next protein in the family masterHit.
virtual ms_protein * | getNextSimilarProtein (const int masterHit, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSimilarProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProtein (const int masterHit, const int id, const bool searchWholeFamily=true) const
Return the next protein that contains some of the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains some of the peptides in the 'master' protein.
std::vector< int > | getNumberOfAccessionDBTypes (int q, int p) const
Return a count of protein accessions by database type of all the accessions that contained the peptide match.
std::vector< int > | getNumberOfFamilyAccessionDBTypes (int hit, int q, int p, bool includeSamesets=true) const
Return a count of protein accessions by database type of all the family members that contained the peptide match.
virtual int | getNumberOfFamilyMembers () const
Return the total number of family members.
virtual int | getNumberOfHits () const
Returns the number of hits in the results.
int | getNumberOfUnassigned () const
Return the number of peptides in the unassigned list.
virtual long | getNumDecoyHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the homology threshold.
virtual long | getNumDecoyHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the identity threshold.
virtual std::vector< int > | getNumDiscoveredErrTolMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of error tolerant modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredFixedMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of fixed modifications discovered in this search.
std::vector< int > | getNumDiscoveredIntactLinks (std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const
Return the count of intact crosslinks in this search.
std::vector< int > | getNumDiscoveredLibraryMods (const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of library modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredLocalMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of query-level modifications discovered in this search.
virtual int | getNumDiscoveredNonSpecCleavage () const
Return the count of non-specific cleavages in an error tolerant search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of variable modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const
Return the count of variable modifications discovered in this search.
virtual long | getNumHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the homology threshold.
virtual long | getNumHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the identity threshold.
virtual std::vector< int > | getPepsWithSameScore (const int q, const int p) const
Returns a list of 'p' values for peptides with the same score.
virtual ms_peptide | getPeptide (const int q, const int p) const
Return a peptide object for the specified query / rank.
virtual bool | getPeptide (const int q, const int p, ms_peptide *&pep) const
Return a peptide object for the specified query / rank.
std::vector< int > | getPeptideAmbiguityRanks (const int q, const int p)
Return a vector of ranks that have the same ambiguity group.
virtual double | getPeptideExpectationValue (const double score, const int query, const int rank=0) const
Returns the expectation value for the given peptide score and query.
virtual int | getPeptideIdentityThreshold (const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the threshold value for this ms-ms data being a random match.
double | getPeptideThreshold (const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const
Return either the identity or the homology threshold.
virtual double | getProbabilityThreshold () const
Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.
virtual int | getProbFromScore (const double score) const
Returns a probability value given a score.
virtual double | getProbOfPepBeingRandomMatch (const double score, const int query) const
virtual double | getProbOfProteinBeingRandomMatch (const double score) const
virtual const ms_protein * | getProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
std::string | getProteinDescription (const char *accession, const int dbIdx=1) const
Return protein description if available.
virtual double | getProteinEmPAI (const char *accession, const int dbIdx=1, const int length=-1) const
Return protein emPAI if available.
virtual double | getProteinExpectationValue (const double score) const
Returns the expectation value for the given protein score.
double | getProteinMass (const char *accession, const int dbIdx=1) const
Return protein mass if available.
virtual int | getProteinScoreCutoff (double OneInXprobRnd) const
Return the 'protein' score value for cutting off results. Different for peptide and protein summary.
virtual double | getProteinScoreForHistogram (const int num) const
Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.
virtual std::string | getProteinsWithThisPepMatch (const int q, const int p, const bool quotes=false)
Return a partial list of proteins that matched the same peptide.
void | getProteinTaxonomyIDs (const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const
Return the taxonomy ID(s), if any, from the results file.
virtual int | getProteinThreshold (double OneInXprobRnd) const
Return a threshold value for the protein summary report.
virtual int | getQmatch (const int query) const
[Deprecated] Return the number of peptides with masses that matched this query.
virtual int | getQmatch (const int query, const ms_mascotresfile_dat::section sec) const
[Deprecated] Use ms_mascotresfilebase::getQmatch().
virtual QUANT_COMPONENT_STATUS | getQuantitationComponentForPeptide (const ms_peptide &peptide, ms_quant_component &component, const ms_quant_method *method=NULL) const
Get the component in the quantitation method that matches the peptide.
const ms_quant_method * | getQuantMethod () const
Returns the quantitation method from the results file.
std::string | getQueryList (QL_FLAG flag, bool outputListOfQueries=true)
Returns a list of query numbers that can be used for a repeat search.
virtual std::string | getReadableVarMods (const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return a 'human readable' string with the variable, summed and error tolerant mods.
const ms_mascotresfilebase & | getResfile () const
Return a reference to the resfile.
ms_mascotresults_params | getResultsParameters () const
Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.
double | getSequenceMass (const char *seq) const
Return the mass of a sequence (protein or peptide).
int | getSrcRank (int q, int p) const
Returns the 'source' rank for a given peptide match.
ms_mascotresfile_dat::section | getSrcSection (int q, int p) const
Returns the 'source' section for a given peptide match.
virtual int | getTagDeltaRangeEnd (const int q, const int p) const
Return the second number from q1_p2_drange=0,256.
virtual int | getTagDeltaRangeStart (const int q, const int p) const
Return the first number from q1_p2_drange=0,256.
virtual int | getTagEnd (const int q, const int p, const int tagNumber) const
Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagSeries (const int q, const int p, const int tagNumber) const
Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagStart (const int q, const int p, const int tagNumber) const
Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual std::string | getTagString (const int q, const int p) const
Return the complete tag string from q1_p1_tag.
virtual std::string | getTerminalResiduesString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the complete terminal residue string from q1_p1_terms.
bool | getThresholdForFDRAboveHomology (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveHomology (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.
double | getToleranceInDalton (bool &needMass, const double *const pMass=NULL) const
Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.
virtual bool | getTreeClusterNodes (const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, ms_mascotresults::TREE_CLUSTER_METHOD tcm=ms_mascotresults::TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const
Return distances and structure suitable for a dendrogram plot.
ms_peptide | getUnassigned (const int num) const
Need to call createUnassignedList() before calling this.
bool | getUnassignedIsBold (const int num) const
Returns true if the item indexed by num in the assigned list should be bold.
bool | getUnassignedShowCheckbox (const int num) const
Returns true if the item indexed by num in the assigned list should have a check box next to it.
bool | hasCrosslinkingMethod () const
Returns true if the results file has a crosslinking method.
bool | hasQuantMethod () const
Returns true if the results file has a quantitation method.
bool | isDataCached (ms_peptidesummary::BUGFIX_NUM bugNum) const
bool | isEmPAIallowed () const
Return true if emPAI could be calculated using data in this results file.
bool | isNA () const
Returns TRUE for a search against a nucelic acid database.
bool | isPeptideComponentMatch (const ms_quant_component &component, const ms_peptide &peptide) const
Tests whether the peptide is a match for all the modifications of the quantitation component.
bool | isPeptideModificationMatch (const ms_quant_modgroup &group, const ms_peptide &peptide) const
Tests whether the peptide is a match for the quantitation modification group.
virtual bool | isPeptideUnique (const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const
Returns true if this peptide match is unique to one protein or one protein family.
const ms_mascotresfilebase & | mascotresfile () const
Return the attached results file.
virtual void | setSubsetsThreshold (const double scoreFraction)
Specifies which subset proteins should be reported.

Static Public Member Functions

static std::string | getCacheFilename (const ms_mascotresfilebase &resfile, const ms_mascotresults_params &parameters)
Call this to retrieve the name of the file that the peptide summary will use for its cache.
static std::string | getCacheFilename (const ms_mascotresfilebase &resfile, const unsigned int flags, double minProbability=0.0, int maxHitsToReport=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE)
[Deprecated] Call this to retrieve the name of the file that the peptide summary will use for its cache.
static double | getMinProbabilityForSLScore (double score)
Return the minProbability value that sets library score threshold to the given value in SL-only mode.
static double | getSLThresholdFromMinProbability (double minProbability)
Return the library score threshold in SL-only mode corresponding to the given value of minProbability.
static bool | willCreateCache (const char *resultsFileName, const ms_mascotoptions &opts, const char *unigeneIndexFile, const char *singleHit, const char *applicationName, std::string &resfileCacheFileName, std::string &peptideSummaryCacheFileName, unsigned int &cacheStatus)
[Deprecated] Returns true if either cache file will be created when the ms_mascotresfilebase and ms_peptidesummary_dat objects are created
static bool | willCreateCache (const ms_mascotresfilebase &resfile, const ms_mascotresults_params &parameters)
Returns true if a cache file will be created when the ms_peptidesummary_dat constructor is called.
static bool | willCreateCache (const ms_mascotresfilebase &resfile, const ms_mascotresults_params &parameters, const ms_mascotoptions &opts, std::string &peptideSummaryCacheFileName, unsigned int &cacheStatus)
Returns true if either cache file will be created when the ms_mascotresfilebase and ms_peptidesummary_dat objects are created.
static bool | willCreateCache (const ms_mascotresfilebase &resfile, const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS, double minProbability=0.0, int maxHits=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE)
[Deprecated] Returns true if a cache file will be created when the ms_peptidesummary_dat constructor is called.

Protected Member Functions

double getIonsScoreCorrected (const double ionsScore, const long multiplicity) const

Detailed Description

Use this class to get peptide summary results.

The following functions provide threshold values:

  • getPeptideIdentityThreshold()
  • getAvePeptideIdentityThreshold()
  • getMaxPeptideIdentityThreshold()
  • getPeptideThreshold()
  • getProteinThreshold()
  • getHomologyThreshold()
  • getHomologyThresholdForHistogram()
  • getProbFromScore()
  • getProbOfPepBeingRandomMatch()
  • double getProbOfProteinBeingRandomMatch()

This class inherits from ms_mascotresults_dat, and all the class functions except for getPeptide() are documented in ms_mascotresults_dat.

Examples
peptide_list.cpp, repeat_search.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

◆ BUGFIX_NUM

enum BUGFIX_NUM

bugNum values for isDataCached().

If caching is in use and the cache file has been created with a previous version of Parser, then the cache file may not contain data for later improvements. While this does not affect functionality, it may impact performance. For example, the addition of getProteinEmPAI() (bug 11235) causes the number of observed peptides to be saved in new cache files. If the numbers are missing from the cache file, they are computed on the fly, which may be slow with very large cache files.

See Using enumerated values and static const ints in Perl, Java, Python and C# and ms_peptidesummary::isDataCached(), and also Caching Mascot Results.

Enumerator
BUGFIX_10780 | The definition of peptide uniqueness changed in Parser 2.4.0. If isDataCached() returns false, isPeptideUnique() may be slower than expected when using the default setting UPR_DEFAULT.
BUGFIX_10995 | Since Parser 2.4.1, score thresholds never drop below 13. If isDataCached() returns false, score thresholds below 13 may be observed.
BUGFIX_11002 | Parser 2.4.1 filters out proteins whose longest significant peptide match is less than MinPepLenInPepSummary. If isDataCached() returns false, families may contain proteins with significant peptide matches shorter than MinPepLenInPepSummary.
BUGFIX_11018 | The scores of rank 1 matches have been saved in the cache file since Parser 2.4.01. If isDataCached() returns false, ms_mascotresults::getThresholdForFDRAboveIdentity() and ms_mascotresults::getThresholdForFDRAboveHomology() may be slower than expected.
BUGFIX_11235 | emPAI calculation was moved to Parser in version 2.5.0, which includes saving the number of observed peptides for each protein in the cache file. If isDataCached() returns false, ms_mascotresults::getProteinEmPAI() may be slower than expected.
BUGFIX_11254 | Parser 2.5.0 introduced modification discovery statistics (getNumDiscoveredVariableMods() et al.). If isDataCached() returns false, these statistics are computed by iterating over all queries in the file, which may be slow with large files.
BUGFIX_11344 | Reporter and Multiplex quantitation were moved to Parser in version 2.5.0. If isDataCached() returns false, component intensities will be extracted from queries on the fly, which may make ms_ms2quantitation and ms_mascotresults::getComponentIntensity() slower than expected.
BUGFIX_11411 | Parser 2.5.0 saves the qmatch and qplughole values of each match in new cache files. If isDataCached() returns false, peptide threshold calculation may be slower than expected.
BUGFIX_11425 | Parser 2.5.0 introduced ms_mascotresults::getIonsScore() for fetching match scores without a peptide object. If isDataCached() returns false, the cache file does not contain the saved scores and getIonsScore() and ms_ms2quantitation may be slower than expected.
BUGFIX_11438 | Parser 2.5.0 saves the charge of each query in new cache files. If isDataCached() returns false, ms_mascotresfile_dat::getObservedCharge() and ms_ms2quantitation may be slower than expected.
BUGFIX_11483 | The number of unique sequences per protein are saved in new cache files since Parser 2.5.0. If isDataCached() returns false, ms_protein::getNumDistinctPeptides() may be slower than expected when using the DPF_UNIQUE flag.
BUGFIX_11499 | Parser 2.5.0 started saving the number of hits above identity and homology for all searches, not just decoy searches. If the numbers are not available, getNumHitsAboveIdentity() and getNumHitsAboveHomology() can be slow, especially in large files.
BUGFIX_11856 | Parser 2.5.0 getNumDiscoveredErrTolMods() excluded some error tolerant modifications when the queries were below requested probability threshold. If using isDataCached() then use BUGFIX_11254 enumeration. Refer to bug 11254 above for more information.
BUGFIX_12123 | Parser 2.6 added two new types of decoy statistics: counting peptide sequences, and counting library matches. If isDataCached() returns false, only counts for PSMs in FASTA sequences are saved in the cache file. Otherwise, all counts are cached. See getNumHitsAboveIdentity() for information about the different count types.
BUGFIX_12317 | Parser 2.6 also bug 12430, average identity threshold must be calculated with a number of qmatches of at least 20.
BUGFIX_11481 | Parser 2.6 decoy peptide strings added to cache so that they can be accessed in a non-decoy summary environment.
BUGFIX_12538 | Parser 2.6.1 ambiguity group id for peptides added to cache to speed up report loading.
BUGFIX_12729 | Improved protein inference for multi-library searches with only one reference database; fixed in Parser 2.6.1.
BUGFIX_12740 | Parser 2.6.0 supports reranking matches when Percolator is enabled, based on the new Percolated scores. Some attributes required for reranking were not being written correctly in the cache file. This is fixed in Parser 2.6.1.
BUGFIX_13324 | In Parser 2.6, ms_peptidesummary::getDiscoveredErrTolModDeltas() returned ET mod deltas in sorted order. Parser 2.7 and later return deltas in the same order as the names in getDiscoveredErrTolModNames(). If caching is enabled, deltas are only available when reading a 2.7 or later cache file.
BUGFIX_12447 | Mascot Server 2.8 reports expect values for ET matches and supports fusion ET decoy searching. If caching is in use and the cache file was created by Parser 2.7 or earlier, ET expect values and false discovery rate are not available. It's best to recreate the cache file.
BUGFIX_13759 | Target FDR can be specified as ms_peptidesummary constructor argument in Parser 2.8. If caching is in use and the cache file was created by Parser 2.7 or earlier, the target FDR argument is ignored.

◆ CACHE_STATUS

enum CACHE_STATUS

Returned by the willCreateCache function.

See Using enumerated values and static const ints in Perl, Java, Python and C# and Caching Mascot Results

The function may bitwise OR multiple values together

Enumerator
CACHE_MISSING_RESFILE | Either the results file is missing or an empty string is passed to the function.
RESFILE_CACHE_FILE_NOT_PRESENT | The ms_mascotresfile_dat cache file is not present and is not being created.
RESFILE_CACHE_BEING_CREATED | The ms_mascotresfile_dat cache file is being created.
RESFILE_CACHE_DISABLED_IN_OPTIONS | Use of the ms_mascotresfile_dat cache file is disabled in the options section of mascot.dat.
RESFILE_CACHE_VALID | The ms_mascotresfile_dat cache file has already been created and is valid.
RESFILE_CACHE_CAN_CREATE | The ms_mascotresfile_dat cache file can be (re-)created. It either doesn't exist or is out of date or invalid for some reason.
PEPSUMMARY_CACHE_FILE_NOT_PRESENT | The ms_peptidesummary cache file is not present and is not being created.
PEPSUMMARY_CACHE_BEING_CREATED | The ms_peptidesummary cache file is being created.
PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS | Use of the ms_peptidesummary cache file is disabled in the options section of mascot.dat.
PEPSUMMARY_CACHE_VALID | The ms_peptidesummary cache file has already been created and is valid.
PEPSUMMARY_CACHE_CAN_CREATE | The ms_peptidesummary cache file can be (re-)created. It either doesn't exist or is out of date or invalid for some reason.
PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE | If the ms_mascotresfile_dat cache file is not present, then no attempt is made to find out about the ms_peptidesummary cache file.
PEPSUMMARY_CACHE_NOT_FOR_PMF | A ms_peptidesummary cache file is not created if the results file just contains PMF matches.

◆ DB_MATCH_TYPE

enum DB_MATCH_TYPE
inherited

Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram().

Enumerator
DM_FASTA | Mascot matches to FASTA sequences. This is the default.
DM_SPECTRAL_LIBRARY | Matches to spectral library entries. This was introduced in Parser 2.6.
DM_BOTH | Only valid for count of matches (getNumHitsAboveIdentity() and friends): the combined count for FASTA and spectral library entries.
DM_FASTA_FIRST_PASS | Mascot matches to FASTA sequences, first pass only.
DM_FASTA_SECOND_PASS | Mascot matches to FASTA sequences, second pass only (e.g. error tolerant).

◆ DECOY_STATS_COUNT_TYPE

enum DECOY_STATS_COUNT_TYPE
inherited

Type of object counted by getNumHitsAboveIdentity() and friends.

Enumerator
DS_COUNT_PSM | Count peptide-spectrum matches (PSMs). This is the default.
DS_COUNT_SEQUENCE | Count distinct peptide sequences. This was introduced in Parser 2.6.

◆ FIND_COMPARE_FLAGS

enum FIND_COMPARE_FLAGS
inherited

Flags to specify how comparisons are performed in the find functions.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

These flags are used in findProteins(), findPeptides() and the deprecated functions: findProteinsByAccession() and findProteinsByDescription(). The flags are used to specify how the comparison is performed and whether it should be a forward or reverse seach. Typically, three values will be combined together, using an OR operator; however, any default values do not need to be specifically specified.

  • Choose 1 of: FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK
  • Choose 1 of: FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE
  • Choose 1 of: FC_FORWARD, FC_REVERSE
  • Optionally choose FC_RESTRICT_TO_HIT or (FC_LOOP_INTO_UNASSIGNED and/or FC_LOOP_FROM_UNASSIGNED)
  • Optionally choose FC_SEARCH_ALL_RANKS
  • Optionally choose FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES
  • Optionally choose one or more of the FC_PROTEIN_IGN_ flags when calling findProteins()
Enumerator
FC_COMPLETESTR

Search for the complete string. If search item is a decimal number then match the number exactly.

FC_SUBSTR

Search for any substring. Not valid if search item is a decimal number.

FC_STARTSTR

String must match to start of target string. If search item is a decimal number then match to the same decimal precision of the filter value but rounded. For example a filter value of 1234.56 will return items with values in the range (1234.555 >= value < 1234.565).

FC_STRTOK

Supplied string is a set of tokens, for example "STY" could be used to search for S or T or Y in a peptide sequence.

FC_MASK_STR_PART

Bit mask to extract which one of FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK has been specified.

FC_CASE_INSENSITIVE

Case insensitive search (default).

FC_CASE_SENSITIVE

Case sensitive search.

FC_MASK_CASE

Bit mask to extract which one of FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE has been specified.

FC_FORWARD

Forward search. The returned hit number will be the same as or higher than the start hit number. (default).

FC_REVERSE

Reverse search. The returned hit number will be the same as or lower than the start hit number.

FC_MASK_DIRECTION

Bit mask to extract which one of FC_FORWARD, FC_REVERSE has been specified.

FC_RESTRICT_TO_HIT

Don't search beyond the specified hit number. Cannot be used with FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_LOOP_INTO_UNASSIGNED

If no matches are found in the passed hit, or any subsequent hit, then search the unassigned list.

FC_LOOP_FROM_UNASSIGNED

If the passed hit number is 0, and no match is found in the unassigned list, then start searching at 1 if FC_FORWARD is specified or start searching at 'numHits' if FC_REVERSE is specified.

FC_UNASSIGNED_MASK

Bit mask to extract FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_SEARCH_ALL_RANKS

For use with findPeptides() only. Ordinarily only those queries and ranks are searched that are assigned to a protein hit. Use this flag to search all ranks in such queries instead.

FC_ALL_PEPTIDES

Search all peptides regardless of score (default).

FC_ALL_PEPTITDES
Deprecated:
Unfortunate spelling error, please use FC_ALL_PEPTIDES which has an identical value.
FC_SIGNIFICANT_PEPTIDES

Only search peptides above identitity or homology threshold.

FC_SEARCH_IGNORED_RANKS

In integrated library mode, also search peptides that are part of a family member's list of ignored peptides.

FC_SCORING_MASK

Bit mask to extract FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES.

FC_PROTEIN_IGN_SAMESETS

Ignore sameset proteins - only used for findProteins()

FC_PROTEIN_IGN_SUBSETS

Ignore subset proteins - only used for findProteins()

FC_PROTEIN_IGN_FAMILY

Ignore family member proteins - only used for findProteins()

FC_PROTEIN_IGN_MASK

Ignore proteins flags.

FC_PROTEIN_INC_ALT_ACC

For use with findProteins() only. If protein entries in the database are representative (i.e. contain multiple accessions) and those accessions are saved in the results file (Mascot 2.4 or later), setting this flag will search all accessions of each protein entry, not just the first accession.

◆ FIND_FLAGS

enum FIND_FLAGS
inherited

Flags for findPeptides() and findProteins().

Details what needs to be searched for. Any of the FT_PEPTIDE_ flags may be used for either findPeptides() or findProteins(), but the FT_PROTEIN flags may only be used for findProteins()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
FT_PEPTIDE_EXP_MZ | Find an experimental m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_EXP_MR | Find an experimental relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_CALC_MZ | Find a calculated m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_CALC_MR | Find a calculated relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_STRING | Find a peptide string.
FT_PEPTIDE_QUERY | Find a query number.
FT_PEPTIDE_VARMOD | Find a variable modification. Specifiy the modification 'number' as the string.
FT_PEPTIDE_FIXMOD | Find a fixed modification. Specifiy the modification 'number' as the string.
FT_PEPTIDE_ETMOD | Find an error tolerant modification. Specifiy a delta mass as the string.
FT_PEPTIDE_SLMOD | Find a spectral library modification. Specifiy any substring of the mod name as the string.
FT_PEPTIDE_VARMOD_BYNAME | Find a variable or query level modification. Specify any substring of the mod name as the string.
FT_PEPTIDE_FIND_MASK | Bit mask for any of the peptide values to be found.
FT_PROTEIN_ACCESSION | Find an accession - findProteins() only.
FT_PROTEIN_DESCRIPTION | Find a description - findProteins() only.

◆ FLAGS

enum FLAGS
inherited

Flags for the type of results.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Not all of the flags applicable for protein summary (e.g. MSRES_REQUIRE_BOLD_RED); see ms_proteinsummary.

Enumerator
MSRES_NOFLAG | Does nothing.
MSRES_GROUP_PROTEINS | Group proteins with same peptide matches. See Grouping proteins together.
MSRES_SHOW_SUBSETS | Show proteins that only match a subset of peptides. See Grouping proteins together.
MSRES_SUBSETS_DIFF_PROT | Proteins that contain a subset of peptides are treated as a unique protein. See Grouping proteins together.
MSRES_REQUIRE_BOLD_RED | Only proteins that have a top scoring peptide not seen before will be returned.
MSRES_SHOW_ALL_FROM_ERR_TOL | If this flag is set, then all hits from error tolerant search are shown. See Error tolerant searches.
MSRES_IGNORE_PMF_MIXTURE | If this flag is set, then PMF mixtures are ignored. See Peptide mass fingerprint mixtures.
MSRES_MUDPIT_PROTEIN_SCORE | Protein scoring for the peptide summary was changed at Mascot 2.0 for large (MudPIT) searches. See ms_protein::getScore().
MSRES_DECOY | If this flag is set, then use the results from searching against the decoy database. See Target-decoy searches and false discovery rate.
MSRES_INTEGRATED_ERR_TOL | If this flag is set, then create a ms_peptidesummary object that contains results from the summary and et_summary section. See Error tolerant searches.
MSRES_ERR_TOL | If this flag is set, then create a ms_peptidesummary object that contains results from the et_summary section. See Error tolerant searches.
MSRES_MAXHITS_OVERRIDES_MINPROB | If minProbability and maxHitsToReport are both non zero, then minProbability is ignored when determining the number of proteins to be displayed. See ms_mascotresults::ms_mascotresults.
MSRES_CLUSTER_PROTEINS | Protein clustering introduced in Mascot 2.3. See Using MSRES_CLUSTER_PROTEINS.
MSRES_DUPE_INCL_IN_SCORE_NONE | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_A | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_B | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_C | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_D | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_E | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_F | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_G | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_H | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_I | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_NONE | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_A | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_B | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_C | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_D | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_E | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_F | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_G | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_H | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_I | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_I | See Treatment of duplicate peptides.
MSRES_DUPE_DEFAULT | Default parameter for treatment of duplicates. See Treatment of duplicate peptides.

◆ HOMOLOGY_THRESHOLD_SOURCE

enum HOMOLOGY_THRESHOLD_SOURCE
inherited

Flags for getHomologyThreshold()

The method getHomologyThreshold() accepts either a rank argument or one of the special enumerated values listed here. For backwards compatibility, the integers 1-20 have their own enumerated values.

Enumerator
HOMTHR_FASTA | Retrieve the homology threshold for FASTA matches.
HOMTHR_SL | Retrieve the homology threshold for spectral library matches.

◆ IONS_HISTOGRAM

enum IONS_HISTOGRAM
inherited

Flags for getIonsScoreHistogram().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
IH_INCLUDE_TOP_MATCHES | The default. Just include the top match to each spectrum.
IH_INCLUDE_TOP_10_MATCHES | Instead of just the top match, use the top 10 matches to each spectrum.

◆ MSPEPSUM

enum MSPEPSUM

flags2 for ms_peptidesummary introduced in Mascot Parser 2.3.

See Using enumerated values and static const ints in Perl, Java, Python and C# and ms_peptidesummary::ms_peptidesummary.

Enumerator
MSPEPSUM_NONE | Default.
MSPEPSUM_PERCOLATOR | See Using Percolator scores for details.
MSPEPSUM_USE_CACHE | See Using the pepsum cache (MSR and dat28).
MSPEPSUM_SINGLE_HIT_DBIDX | The singleHit parameter string must start with a database index and a colon, e.g. 3:CH60_SHEON. See Using the singleHit parameter to return a single protein.
MSPEPSUM_USE_HOMOLOGY_THRESH | Expect values and cutoffs will use homology thresholds rather than identity thresholds.
MSPEPSUM_NO_PROTEIN_GROUPING | Used for when a ms_peptidesummary object it required, but no protein grouping is needed. ms_peptidesummary::getNumberOfHits() will return zero. The only functions that are guaranteed to work are ms_peptidesummary::getPeptide(), ms_peptidesummary::getAllProteinsWithThisPepMatch(), ms_peptidesummary::getQmatch(). Will not work with error tolerant searches.
MSPEPSUM_DISCARD_RELOADABLE | Specify this flag to use less memory. However, calls to getPeptide() will be slower because the data wll always be loaded again from the results file.
MSPEPSUM_DEFERRED_CREATE | Useful if it is necessary to be able to cancel creation of a ms_peptidesummary() object (which can take a long time). Call createSummary() manually after creating the ms_peptidesummary object.
MSPEPSUM_CACHE_IGNORE_DATE_CHANGE | Opening the peptide summary cache CDB file should ignore the last modified timestamp on the .dat file.
MSPEPSUM_REMOVE_CHIMERIC_DUPES | Specify this flag to remove duplicate matches from chimeric spectra (spectra with more than one precursor mass). See Chimeric duplicates.
MSPEPSUM_SL_INTEGRATED | Merge spectral library matches with Mascot matches, if any exist in the results file. If the flag is not specified, only Mascot matches are available.
MSPEPSUM_SL_ONLY | Use only the spectral library match sections and ignore Mascot matches.
MSPEPSUM_CROSSLINK_INTEGRATED | Merge crosslinked matches with standard, linear matches, if any exist in the results file. If the flag is not specified, only standard, linear matches are available.
MSPEPSUM_CROSSLINK_ONLY | Use only the crosslinked match sections.

◆ QL_FLAG

enum QL_FLAG

Flags for getQueryList().

See Using enumerated values and static const ints in Perl, Java, Python and C# and getQueryList().

Enumerator
QL_ALL | Returns "All" .
QL_UNASSIGNED | Returns a comma separated list of the query numbers in the unassigned list. If createUnassignedList() has not been called, getQueryList() function will call it, possibly causing some delay.
QL_BELOW_IDENTITY | Returns a comma separated list of the query numbers which have scores below the identity threshold calculated using the minProbability threshold specified in the ms_peptidesummary constructor. If minProbability <= 0 or >= 1, then an empty string is returned.
QL_BELOW_HOMOLOGY | Returns a comma separated list of the query numbers which have scores below the homology threshold calculated using the minProbability threshold specified in the ms_peptidesummary constructor. If minProbability <= 0 or >= 1, then an empty string is returned.
QL_IGNORE_IONS_SCORE_BELOW | Uses the threshold specified by the ignoreIonsScoreBelow parameter. If ignoreIonsScoreBelow is zero, then an empty string is returned.
QL_LAST | For looping through all possible values.

◆ QUANT_COMPONENT_STATUS

enum QUANT_COMPONENT_STATUS
inherited

Return codes for getQuantitationComponentForPeptide().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
QCS_OK | The component was retrieved successfully.
QCS_OK_NO_MATCH | The quantitation method's components were searched successfully, no matching component was found.
QCS_ERROR_NO_METHOD | There is no quantitation method available (e.g. for protein summary).
QCS_ERROR_NO_COMPONENTS | There are no components specified in the quantitation method (e.g. for non-precursor method).
QCS_ERROR_BAD_COMPONENT_NAME | The peptide's component name in the Mascot results does not match any component in the quantitation method.
QCS_OK_MULTIPLE_MATCHES | The quantitation method's components were searched successfully, multiple matching components were found.

◆ sortBy

enum sortBy
inherited

Flags for createUnassignedList().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
QUERY | Sort the unassigned list by ascending query number - this is the same as ascending relative mass order.
SCORE | Sort the unassigned list by descending score.
INTENSITY | Sort the unassigned list by descending intensity. Intensity values are taken from the qintensity value in the results file if they are available (from PKL files, or some MGF files). If these values are not available, then the intensity is calculated from the sum of all the ions values. For a very large MS-MS file, this option can take some time to process unless there are qintensity value in the results file.

◆ THRESHOLD_TYPE

enum THRESHOLD_TYPE
inherited

Flags for getPeptideThreshold()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TT_HOMOLOGY | Homology threshold.
TT_IDENTITY | Identity threshold.
TT_PEPSUM_DEFAULT | If ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH is specified in the constructor, then this will resolve to TT_HOMOLOGY, otherwise it will resolve to TT_IDENTITY.

◆ TREE_CLUSTER_METHOD

enum TREE_CLUSTER_METHOD
inherited

Flags for getTreeClusterNodes().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TCM_PAIRWISE_SINGLE | 's': pairwise single-linkage clustering.
TCM_PAIRWISE_MAXIMUM | 'm': pairwise maximum- (or complete-) linkage clustering.
TCM_PAIRWISE_AVERAGE | 'a': pairwise average-linkage clustering.

◆ UNIQUE_PEP_RULES

enum UNIQUE_PEP_RULES
inherited

Flags for isPeptideUnique().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Choose UPR_WITHIN_FAMILY or UPR_WITHIN_FAMILY_MEMBER and then optionally 'or' UPR_IGNORE_SUBSET_PROTEINS

Enumerator
UPR_WITHIN_FAMILY | The peptide is unique if it occurs in proteins that are part of a single family.
UPR_WITHIN_FAMILY_MEMBER | The peptide is unique if it occurs in proteins that just belong to a single family member.
UPR_IGNORE_SUBSET_PROTEINS | Ignore any susbset proteins that contain the match when deciding if a peptide is unique. However, if the peptide just belongs to subset proteins for the same hit, then it is still considered to be unique.
UPR_DEFAULT | Set to UPR_WITHIN_FAMILY_MEMBER | UPR_IGNORE_SUBSET_PROTEINS.

Constructor & Destructor Documentation

◆ ms_peptidesummary() [1/2]

ms_peptidesummary | ( | const ms_mascotresfilebase & | resfile,
 |  | const unsigned int | flags = ms_mascotresults::MSRES_GROUP_PROTEINS,
 |  | double | minProbability = 0.0,
 |  | int | maxHitsToReport = 50,
 |  | const char * | unigeneIndexFile = 0,
 |  | double | ignoreIonsScoreBelow = 0.0,
 |  | int | minPepLenInPepSummary = 0,
 |  | const char * | singleHit = 0,
 |  | const unsigned int | flags2 = MSPEPSUM_NONE
 | ) |  |

[Deprecated] Call this constructor once to create peptide summary results.

Note
This constructor is deprecated in favour of ms_peptidesummary(const ms_mascotresfilebase&, const ms_mascotresults_params&). All new code should use the new constructor.

Creating an ms_peptidesummary object may take some time for a very large file with a large number of protein hits.

Parameters
resfile | An ms_mascotresfilebase object. See Maintaining object references: two rules of thumb.
flags | can be one or more of the ms_mascotresults::FLAGS values OR'ed together
minProbability | specifies the significance threshold. See ms_mascotresults_params::getMinProbability(). See also ms_mascotresults_params::getTargetFDR().
maxHitsToReport | is a maximum value of protein hits to report. See ms_mascotresults_params::getMaxHitsToReport().
unigeneIndexFile is an optional file path to a UniGene Index file. This only makes sense if ms_mascotresults::MSRES_GROUP_PROTEINS is set.
  • From programming languages other than C++, pass an empty string object to specify no UniGene index file.
ignoreIonsScoreBelow | is an optional flag for the peptide summary only. See ms_mascotresults_params::getIgnoreIonsScoreBelow().
minPepLenInPepSummary | is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins (see Grouping proteins together).
singleHit | should only be used for getting the results for a single protein quickly. See ms_mascotresults_params::setSingleHit().
flags2 | should be one or more of the ms_peptidesummary::MSPEPSUM flags OR'd together

◆ ms_peptidesummary() [2/2]

ms_peptidesummary | ( | const ms_mascotresfilebase & | resfile,
 |  | const ms_mascotresults_params & | parameters
 | ) |  |

Call this constructor once to create peptide summary results.

Creating an ms_peptidesummary object may take some time for a very large file with a large number of protein hits.

Parameters
resfile | An ms_mascotresfilebase object. See Maintaining object references: two rules of thumb.
parameters | An ms_mascotresults_params object which should contain all of the required values and flags to generate the peptide summary.

Member Function Documentation

◆ anyEmPAI()

bool anyEmPAI ( ) const
virtual

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns
true if above conditions are true and at least one protein has a non-zero emPAI value.

Reimplemented from ms_mascotresults.

◆ anyNumDiscoveredMods()

bool anyNumDiscoveredMods ( ) const
virtualinherited

Return true if modification discovery statistics are available.

Modification discovery counts for fixed and variable modifications (and error tolerant modifications in an error tolerant search) are only available if the results file contains a Unimod section. Since only significant rank 1 peptide matches assigned to a protein hit are inspected for modification counting purposes, it is possible for the counts to be zero even when a Unimod section exists.

Returns
True if number of modifications could be counted and there is at least one modification with a non-zero count; false otherwise.

◆ cancelCreateSummary()

void cancelCreateSummary ( bool newValue = true )
inherited

Cancel the call to createSummary()

It is normally recommended that an application should delete the ms_peptidesummary object after calling this function because some objects will still be in memory (no cleanup is performed).

Cancelling may not occur immediately, and the calling application needs to wait for the createSummary() call to return.

See also getCreateSummaryProgress() and ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE

Parameters
newValue should be set to true to cancel the createSummary call

◆ createSummary()

bool createSummary ( )
virtual

Create the summary using a separate call after the ms_peptidesummary_dat object has been created.

Creating an ms_peptidesummary object for a large results file can take a considerable amount of time. The standard Mascot reports do not have an option to 'cancel' the creation of the report and rely on the ms_mascotresfilebase::outputKeepAlive() function to provide progress reports and keep the connection alive. This is not so desireable for a client application that doesn't want to redirect stdout, and wants to allow the user to cancel a long operation. Specify the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag when creating the ms_peptidesummary object, and then use one thread to call this function and a separate thread to call getCreateSummaryProgress() and report progress to the end user.

This function is called directly by the ms_mascotresults constructor unless the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag is specified. If that flag is specified, then the constructor returns 'immediately' and this function must be called by the client code. Until this function returns, the client code in the separate thread can only reliably call the getCreateSummaryProgress(), ms_mascotresfilebase::outputKeepAlive() or cancelCreateSummary() functions. Calling any other function for the ms_mascotresults object may result in undefined behaviour and cause the ms_mascotresfilebase::ERR_RESULTS_NOT_CREATED error to be set.

This function should not be called for a ms_proteinsummary.

Returns
true if successful

Reimplemented from ms_mascotresults.

◆ createUnassignedList()

bool createUnassignedList ( sortBy s = QUERY )
inherited

To have a list of unassigned peptides, need to call this first.

See Unassigned peptides list for details of creating an unassigned list.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
s order to sort the unassigned list
Returns
Currently always returns true unless createSummary() has not completed
Examples
resfile_summary.cpp.

◆ dumpCDB()

bool dumpCDB ( const std::string dumpFileName )

Debugging aid. Exports the cdb file as text.

Parameters
dumpFileName is the path of the text file to dump information to .
Returns
true if the file can be created and written to.

◆ findPeptides()

int findPeptides | ( | const int | startHit,
 |  | const std::string & | str,
 |  | FIND_FLAGS | item,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< int > & | q,
 |  | std::vector< int > & | p
 | ) |  | const
 virtual

Find the next hit that contains peptides with the specified attribute.

Note
For a protein summary, this function always returns -1.

Can be used to find peptide-spectrum matches with a specified query number, sequence, mass, or fixed or variable modification. Returns the protein hit number and a list of q,p values that contains one or more string matches to the input string.

In crosslinked searches, both alpha and beta peptides are compared to the search criteria. Only one needs to match the input string.

All subset, sameset and family member proteins are searched, and it is possible that the returned q and p values only correspond to peptides in a single subset protein. The FC_PROTEIN_IGN_SAMESETS, FC_PROTEIN_IGN_SUBSETS and FC_PROTEIN_IGN_FAMILY flags cannot be used with this function. To find proteins which contain particular peptide matches, or to control which proteins to search, see findProteins().

For FT_PEPTIDE_VARMOD , str should contain the modification 'number' as passed to ms_searchparams::getVarModsName(). Modification numbers between 1 and 9 correspond to strings "1" through "9", and numbers between 10 and 32 correspond to "A" through "W". To find all error tolerant modifications, specify "X" and then use ms_peptidesummary::getErrTolModName() to retrieve the name of the modification.

For FT_PEPTIDE_FIXMOD, str should contain the modification 'number' as passed to ms_searchparams::getFixedModsName(). This will be in the range 1-20.

For both types of modification searches, str should only contain a single character. The value for compareFlags should include FC_SUBSTR, because this function is implemented by searching the return value from ms_peptide::getVarModsStr(). Specifying incorrect flags does not generate an error and results in undefined behaviour.

There is an alternative way to search for fixed mods: specify FT_PEPTIDE_STRING and FC_STRTOK as item and compareFlags, respectively, and pass the return value of ms_searchparams::getFixedModsResidues() as the string to search for, str. Although this may seem equivalent to the combination FT_PEPTIDE_FIXMOD and FC_SUBSTR, there are two corner cases where the latter works while the former doesn't:

  • ms_searchparams::getFixedModsResidues() can return "N_term" or "C_term", which are clearly not strings of amino acids.
  • The case where a fixed mod is 'replaced' with a variable mod. For example, if Carbamidomethyl (C) is specified as a fixed mod and Propionamide (C) as variable mod, then it is not sufficient to just check if a peptide contains a cysteine.
Parameters
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1. To search the unassigned list, pass a value of 0.
str | is the string to be matched.
item | is the peptide item to be found (for example, the peptide sequence or mass). Any of the FT_PEPTIDE_ values may be used.
compareFlags | specifies whether the str value is required to match all or just part of the target string. It can also be used to specify a reverse search.
q | is a vector of query values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
p | is a vector of corresponding rank values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains all the returned matched items, or 0 if the match is in the unassigned list, or -1 if there is no match found.

Implements ms_mascotresults.

◆ findProteins()

int findProteins | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | FIND_FLAGS | item,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const
 virtual

Find the next hit that contains proteins with the specified attributes.

Note
For a protein summary, this function always returns -1.

Used to find accessions, protein descriptions or proteins that have peptide matches with a specified query number, sequence, mass, or fixed or variable modification. Any of the FIND_FLAGS may be used.

The findPeptides() function does not return any information about which subset/sameset/family proteins in a hit contain the found matches. findProteins(), however, returns a list of the protein accessions that contained a peptide match that fits the search criteria, and also allows the searched proteins to exclude samesets (FC_PROTEIN_IGN_SAMESETS), subsets (FC_PROTEIN_IGN_SUBSETS or family members (FC_PROTEIN_IGN_FAMILY).

If protein entries in the database are representative (i.e. contain multiple accessions), by default only the first accession will be considered when FT_PROTEIN_ACCESSION is specified as a search item. If alternative accessions are saved in the results file (Mascot 2.4 or later), setting FC_PROTEIN_INC_ALT_ACC will search all accessions of each protein entry. Note that this will make the search slower.

Parameters
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the string to be matched and depends on the value of item. If item is FT_PROTEIN_ACCESSION, then str will be the accession (or part of one) to be matched. If item is one of the FT_PEPTIDE_ values, then see FIND_FLAGS and findPeptides() for operational details.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
item | is the accession, description or peptide item to be found. For example, return all proteins with a given peptide sequence or mass.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains the matches, or -1 if there is no match found.

Implements ms_mascotresults.

◆ findProteinsByAccession()

int findProteinsByAccession | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const
 virtual

Find the next hit that contains proteins with the specified accession.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_ACCESSION flag.
Note
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with accessions that match to the the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Parameters
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implements ms_mascotresults.

◆ findProteinsByDescription()

int findProteinsByDescription | ( | const int | startHit,
 |  | const std::string & | str,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const
 virtual

Find the next hit that contains proteins with the specified description.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_DESCRIPTION flag.
Note
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with descriptions that match the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Descriptions are just those included in the results file. See getProteinDescription() for details of what is loaded into the results.

Parameters
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
compareFlags | specifies whether the str value is required to match all or just part of the description. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implements ms_mascotresults.

◆ freeHit()

void freeHit ( const int hit )
virtual

Frees any memory associated with the passed hit number.

Has no effect except when Using the pepsum cache (MSR and dat28). This function frees the ms_protein objects for the specified hit. The return values from getHit(), getNextFamilyProtein(), getNextSimilarProtein(), getNextSimilarProteinOf(), getNextSubsetProtein() etc. for this hit will then point to deleted objects and hence should not be used.

In addition, any ms_peptide objects loaded into memory using the getPeptide(const int, const int, ms_peptide *&)const function will 'unloaded' if the ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE has been specified. This function has no effect on the ms_peptide objects returned from the alternative getPeptide(const int, const int)const function.

Parameters
hit should be in the range 1.. getNumberOfHits().

Reimplemented from ms_mascotresults.

◆ getAllFamilyMembersWithThisPepMatch()

int getAllFamilyMembersWithThisPepMatch | ( | const int | hit,
 |  | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | db,
 |  | std::vector< std::string > & | acc,
 |  | std::vector< int > & | dupe_status
 | ) |  | const
 virtual

Return a list of (top level) family proteins that have a match to the specified q and p.

Only the top level proteins are returned by this function, that is, the proteins that would be returned by getHit() and getNextFamilyProtein(). It will be considerably faster than calling ms_protein::getPeptideQuery() and related functions, because that involves loading more information from the cache and from the .dat file.

This function will return the values rapidly when caching is enabled; see Using the pepsum cache (MSR and dat28). It also functions correctly when not using the cache.

The returned vectors are all guaranteed to have the same number of elements. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use them from programming languages other than C++.

See also
getAllProteinsWithThisPepMatch() and getProteinsWithThisPepMatch()
Parameters
hit | Should be in the range 1.. getNumberOfHits().
q | is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
db | is a vector of database IDs.
acc | is the corresponding vector of accessions.
dupe_status | is the corresponding vector of ms_protein::DUPLICATE values for the returned proteins. Note that ms_protein::DUPE_Ignored will only appear in integrated library searches where the peptide match was removed due to IgnoreIonsScoreBelow.
Returns
The number of proteins in the db/acc/dupe_status vectors.

Implements ms_mascotresults.

◆ getAllProteinsWithThisPepMatch() [1/2]

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db
 | ) |  | const
 virtual

Returns a complete list of all the accessions that contained the peptide matched by this result.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

Crosslink searches only: If you need to know whether the accessions come from the alpha or beta peptide, use the 10-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also
getProteinsWithThisPepMatch()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues – one for each accession
end | Returns a vector of the end residues – one for each accession
pre | Returns a vector of the residue before the peptide – one for each accession
post | Returns a vector of the residue after the peptide – one for each accession
frame | Returns a vector of the frames – one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities – one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
Returns
A list of all the accessions that contained the peptide matched by this result.

Implements ms_mascotresults.

◆ getAllProteinsWithThisPepMatch() [2/2]

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db,
 |  | std::vector< int > & | psmComponent
 | ) |  | const
 virtual

Returns a complete list of all the accessions that contained the peptide matched by this result.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

This method was added in Parser 2.7 for crosslinking support. If you don't need to know whether the accessions come from the alpha or beta peptide, you can use the 9-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also
getProteinsWithThisPepMatch()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues – one for each accession
end | Returns a vector of the end residues – one for each accession
pre | Returns a vector of the residue before the peptide – one for each accession
post | Returns a vector of the residue after the peptide – one for each accession
frame | Returns a vector of the frames – one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities – one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
psmComponent | Returns a vector of psmComponent markers (ms_peptide::PSM) – one for each accession. For a crosslinked match, this will be one of ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA. In all other types of match, it will always be ms_peptide::PSM_COMPLETE.
Returns
A list of all the accessions that contained the peptide matched by this result.

Implements ms_mascotresults.

◆ getAvePeptideIdentityThreshold()

int getAvePeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtualinherited

Return the average threshold value for all MS-MS data sets.

The average value is calculated by taking the mean value from calling getPeptideIdentityThreshold() for each query. This is the value that is used to be shown at the top of the standard Mascot reports in versions before Mascot 2.0. For example, threshold in the following string could be calculated by calling getAvePeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot score threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
The average score threshold. If there was no MS-MS data then -1 will be returned.

◆ getCacheFileName()

std::string getCacheFileName ( ) const

Returns the filename of the cache file.

If the cacheDirectory supplied to the ms_mascotresfilebase::ms_mascotresfilebase constructor is not empty, then a filename will be returned. This does not guarantee that the file exists, or is being used.

See also Caching Mascot Results.

Returns
The filename for the cache file.

◆ getCacheFilename() [1/2]

std::string getCacheFilename | ( | const ms_mascotresfilebase & | resfile,
 |  | const ms_mascotresults_params & | parameters
 | ) |  |
static

Call this to retrieve the name of the file that the peptide summary will use for its cache.

Parameters
resfile | The ms_mascotresfilebase for the project
parameters | The processing parameters passed to the constructor.
Returns
cache file name

◆ getCacheFilename() [2/2]

std::string getCacheFilename | ( | const ms_mascotresfilebase & | resfile,
 |  | const unsigned int | flags,
 |  | double | minProbability = 0.0,
 |  | int | maxHitsToReport = 50,
 |  | const char * | unigeneIndexFile = 0,
 |  | double | ignoreIonsScoreBelow = 0.0,
 |  | int | minPepLenInPepSummary = 0,
 |  | const char * | singleHit = 0,
 |  | const unsigned int | flags2 = MSPEPSUM_NONE
 | ) |  |
static

[Deprecated] Call this to retrieve the name of the file that the peptide summary will use for its cache.

Note
This method is deprecated in favour of getCacheFileName(const ms_mascotresfilebase&, const ms_mascotresults_params&). All new code should use the new method.
Parameters
resfile | The ms_mascotresfilebase for the project
flags | collection of values, bitwise or-ed together, from the FLAGS enumeration of ms_mascotresults.
minProbability | The minimum significance probability threshold
maxHitsToReport | The number of protein hits to include in the results
unigeneIndexFile | path to the Unigene index file
ignoreIonsScoreBelow | The score cutoff threshold value
minPepLenInPepSummary | The minimum peptide length used to differentiate different proteins
singleHit | The accession string to retrieve a single protein
flags2 | collection of values, bitwise or-ed together, from the MSPEPSUM enumeration of ms_peptidesummary.
Returns
cache file name

◆ getComponentIntensity()

bool getComponentIntensity | ( | const int | q,
 |  | const int | p,
 |  | const std::string & | componentName,
 |  | double & | value,
 |  | double & | rawValue
 | ) |  | const
 virtual

Returns the component intensity for reporter or multiplex methods.

This function will only succeed for MS2 based quantitation methods such as "reporter" and "multiplex" where the required data is in the .dat file. It is up to the calling application to check that this is the case using ms_mascotresfilebase::getQuantitationMethod and ms_quant_method::getProtocol

This function was added in Mascot Parser 2.5. If the calling application is Using the pepsum cache (MSR and dat28) and the cache files were created with Mascot Parser 2.4 or earlier, then this function will calculate the intensities on demand. The first call to this function causes values for the whole file to be calculated, which may be slow. With new cache files, all the values are saved in the cache file.

This function will only calculate values for cases where ms_quant_helper::isPeptideQuantifiable returns ms_quant_helper::PEPTIDE_IS_QUANTIFIABLE

For a particular q,p pair there will always be values for all components or for no components. There can never be a case where there is just a value available for a subset of the components.

Parameters
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue(). For "reporter" protocols, this must be 1.
componentName | is the name of the component as defined in the method. For example, for iTRAQ this might be "114", and for one of the SILAC methods this might be "Heavy".
[out] | value | is the corrected intensity value. Corrections are applied as specified in the method included in the results file.
[out] | rawValue | is the uncorrected intensity value.
Returns
false if the method is unable to calculate or determine an intensity value for the specified q and p values

Implements ms_mascotresults.

◆ getComponentProtein()

const ms_protein * getComponentProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const
 virtual

Return a pointer to the protein entry given an accession.

Only use this function for the "components" of a UniGene search. It will generally be more convenient for client applications to call ms_protein::getComponent() to get an ms_protein object, both in UniGene searches and PMF mixture searches.

Parameters
accession | is the accession string.
dbIdx | a database index (1..ms_searchparams::getNumberOfDatabases()).
Returns
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented from ms_mascotresults.

◆ getComponentString()

std::string getComponentString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const
 virtual

Return q1_p2_comp string value.

Note
This function will always return the empty string for a protein summary.

The entry in the results file might be, for example:

   q1_p2_comp=light

For a crosslinked match, the results file line is q1_p1_comp_1= or q1_p1_comp_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

See also ms_peptide::getComponentStr().

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'rank' number, which should be in the range 1..10.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns
the full component string for a peptide summary, and the empty string for a protein summary.

Implements ms_mascotresults.

◆ getCreateSummaryProgress()

bool getCreateSummaryProgress | ( | int * | cspTotalPercentComplete,
 |  | unsigned int * | cspCurrTask,
 |  | int * | cspCurrTaskPercentageComplete,
 |  | std::string * | cspAccession,
 |  | int * | cspHit,
 |  | int * | cspQuery,
 |  | std::string * | cspKeepAliveText
 | ) |  | const
 inherited

Return progress for the createSummary() call.

See Multiple return values in Perl, Java, Python and C#.

This function is most useful when using the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag and calling createSummary() from a separate thread. The ms_mascotresfilebase::outputKeepAlive() outputs progress text to stdout, and this may not be convenient for some applications.

Any of the passed parameters may be null.

Parameters
[out] | cspTotalPercentComplete | is simply calculated from: 100 * cspCurrTask / ms_mascotresfilebase::KA_LAST + cspCurrTask / ms_mascotresfilebase::KA_LAST
[out] | cspCurrTask | is the ms_mascotresfilebase::KA_TASK currently being performed by Mascot Parser. If Parser is doing nothing, then this will be the last task that was completed and cspCurrTaskPercentageComplete will be 100
[out] | cspCurrTaskPercentageComplete | is the percentage (0..100) complete for the current cspCurrTask.
[out] | cspAccession | is the current 'accession' being processed. See ms_mascotresfilebase::outputKeepAlive() for details of which tasks set this value. For languages other than C++, this will be a reference rather than a pointer to a std::string.
[out] | cspHit | is the current hit being processed. See ms_mascotresfilebase::outputKeepAlive() for details of which tasks set this value
[out] | cspQuery | is the current 'query' being processed. See ms_mascotresfilebase::outputKeepAlive() for details of which tasks set this value
[out] | cspKeepAliveText | is the text that would be output by ms_mascotresfilebase::outputKeepAlive(). To use this, specify a suitable keepAliveText to the ms_mascotresfilebase constructor but set keepAliveInterval to zero to prevent any output to stdout. For languages other than C++, this will be a reference rather than a pointer to a std::string.
Returns
true if the createSummary() call has completed.

◆ getCrosslinkingMethod()

const matrix_science::ms_crosslinking_method * getCrosslinkingMethod ( ) const

Returns the crosslinking method from the results file.

Returns
The crosslinking method from the ms_mascotresfilebase object if any, otherwise 0.

◆ getDiscoveredErrTolModDeltas()

std::vector< double > getDiscoveredErrTolModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const
virtualinherited

Return the deltas of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification deltas. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

The list of error tolerant modification deltas is most useful when used in combination with getNumDiscoveredErrTolMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredErrTolModNames()

Nucleic acid insertion, deletion and substitution whose special names are NA_INSERTION, NA_DELETION and NA_SUBSTITUTION have a delta of 0.0.

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns
A vector of error tolerant modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getDiscoveredErrTolModNames()

std::vector< std::string > getDiscoveredErrTolModNames ( ) const
virtualinherited

Return the names of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification names. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted. Nucleic acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

The list of error tolerant modification names is most useful when used in combination with getNumDiscoveredErrTolMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns
A vector of error tolerant modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getDiscoveredLocalModDeltas()

std::vector< double > getDiscoveredLocalModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const
virtualinherited

Return the deltas of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredLocalModNames()

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns
A vector of query-level modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getDiscoveredLocalModNames()

std::vector< std::string > getDiscoveredLocalModNames ( ) const
virtualinherited

Return the names of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns
A vector of query-level modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getErrTolModDelta()

double getErrTolModDelta | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL,
 |  | std::string * | deltaAsString = NULL
 | ) |  | const
 virtualinherited

Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification delta will be 0.984020. In general, modification delta could be any valid floating point number, including 0.0.

See also
getErrTolModName(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the delta directly
deltaAsString
Returns
The modification delta.

◆ getErrTolModifiedNaSeq()

std::string getErrTolModifiedNaSeq | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the modified sequence of nucleic acids after a single base modification in an error tolerant search.

If an error tolerant search was made against a nucleic acid database, and if the NA sequence had an unsuspected insertion, deletion or substitution, then this method returns the modified NA sequence before translation.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'hit' or 'rank' number.
Returns
the modified sequence of nucleic acids before a single base modification in an error tolerant search

◆ getErrTolModMasterNeutralLoss()

std::vector< double > getErrTolModMasterNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p1_et_mods_master might be

   q1_p1_et_mods_master=1.0,2.0

The returned list will not contain the dominant neutral loss – that can be retrieved using getErrTolModNeutralLoss().

See also
getErrTolModSlaveNeutralLoss() and getErrTolModNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification additional primary neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModMasterString()

std::string getErrTolModMasterString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete error tolerant mod master neutral loss string from q1_p1_et_mods_master.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_master might be
       q1_p2_et_mods_master=1.0,2.0
  • The entry in h1_q2_et_mods_master might be
       h1_q2_et_mods_master=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModMasterNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant master neutral loss string.

Implements ms_mascotresults.

◆ getErrTolModName()

std::string getErrTolModName | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL
 | ) |  | const
 virtualinherited

Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification name will be Citrullination.

See also
getErrTolModDelta(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the name directly
Returns
The modification name, or empty string if this match has no ET modification.

◆ getErrTolModNeutralLoss()

double getErrTolModNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than 10 of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods might be

   q1_p1_et_mods=79.966330,97.976898,Phospho (STY)

where the highest scoring modification neutral loss, returned by this function is 97.976898.

See also
getErrTolModName(), getErrTolModDelta(), getReadableVarMods(), getErrTolModMasterNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification neutral loss value.

◆ getErrTolModPepNeutralLoss()

std::vector< double > getErrTolModPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.

Some modifications specify one or more peptide neutral losses. PepNeutralLoss allows a neutral loss from the precursor to be specified so that this peak is not treated as a noise peak when being scored by Mascot. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_pep might be

   q1_p1_et_mods_pep=97.976896, 79.966330
See also
getErrTolModReqPepNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification peptide neutral loss values as a vector of doubles See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModPepString()

std::string getErrTolModPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete error tolerant mod peptide neutral loss string from q1_p1_et_mods_pep.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_pep might be
       q1_p2_et_mods_pep=1.0,2.0
  • The entry in h1_q2_et_mods_pep might be
       h1_q2_et_mods_pep=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModPepNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant peptide neutral loss string.

Implements ms_mascotresults.

◆ getErrTolModReqPepNeutralLoss()

std::vector< double > getErrTolModReqPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.

Some modifications specify one or more required peptide neutral losses. ReqPepNeutralLoss performs the same function as PepNeutralLoss but with the additional condition that the peak must be present in the spectrum. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_reqpep might be

   q1_p1_et_mods_reqpep=97.976896, 79.966330
See also
getErrTolModPepNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification required peptide neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModReqPepString()

std::string getErrTolModReqPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete error tolerant mod required peptide neutral loss string from q1_p1_et_mods_reqpep.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_reqpep might be
       q1_p2_et_mods_reqpep=1.0,2.0
  • The entry in h1_q2_et_mods_reqpep might be
       h1_q2_et_mods_reqpep=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModReqPepNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant required peptide neutral loss string.

Implements ms_mascotresults.

◆ getErrTolModSlaveNeutralLoss()

std::vector< double > getErrTolModSlaveNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_slave might be

   q1_p2_et_mods_slave=1.0,2.0
See also
getErrTolModMasterNeutralLoss(), getErrTolModNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification slave neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModSlaveString()

std::string getErrTolModSlaveString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete error tolerant mod slave neutral loss string from q1_p1_et_mods_slave.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_slave might be
       q1_p2_et_mods_slave=1.0,2.0
  • The entry in h1_q2_et_mods_slave might be
       h1_q2_et_mods_slave=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModSlaveNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant slave neutral loss string.

Implements ms_mascotresults.

◆ getErrTolModString()

std::string getErrTolModString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods might be
       q1_p2_et_mods=0.984020,0.000000,Citrullination
  • The entry in h1_q2_et_mods might be
       h1_q2_et_mods=0.984020,0.000000,Citrullination

This function returns the complete string value. More useful functions are

  • ms_mascotresults::getErrTolModName(),
  • ms_mascotresults::getErrTolModDelta(),
  • ms_mascotresults::getErrTolModNeutralLoss() and
  • ms_mascotresults::getReadableVarMods(),

all of which will work for both the protein summary and the peptide summary.

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant modification string.

Implements ms_mascotresults.

◆ getErrTolOriginalNaSeq()

std::string getErrTolOriginalNaSeq | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the original sequence of nucleic acids before a single base modification in an error tolerant search.

If an error tolerant search was made against a nucleic acid database, and if the NA sequence had an unsuspected insertion, deletion or substitution, then this method returns the original NA sequence before translation.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'hit' or 'rank' number.
Returns
the original sequence of nucleic acids before a single base modification in an error tolerant search

◆ getErrTolProbabilityThreshold()

double getErrTolProbabilityThreshold ( ) const
virtualinherited

For a protein summary, this method always returns the same value as getProbabilityThreshold().

Error tolerant matches in an integrated error tolerant search can have a different probability threshold (significance threshold) from first pass peptide matches. The first pass matches always use getProbabilityThreshold() as the significance threshold, and second pass matches always use getErrTolProbabilityThreshold().

The error tolerant significance threshold is determined using ms_mascotresults_params::getTargetFDR(). If a target FDR is specified and the search is an error tolerant target-decoy search, the probability threshold is chosen such that error tolerant matches have false discovery rate (FDR) equal to the target or as close as feasible. If the search is not a target-decoy search or target FDR is not specified, the error tolerant significance threshold is the same as the first pass significance threshold.

See also
getProbabilityThreshold(), Error tolerant searches
Returns
probability threshold for error tolerant matches.

◆ getFlags()

unsigned int getFlags ( ) const
inherited

Returns the flags value passed to the constructor.

Returns
the ms_mascotresults::FLAGS value.

◆ getFlags2()

unsigned int getFlags2 ( ) const
inherited

Return the flags2 value passed to the ms_peptidesummary constructor.

For an ms_proteinsummary, will always return 0 as there is no option to set the flags2 value.

Returns
the ms_peptidesummary::MSPEPSUM value.

◆ getHit()

ms_protein * getHit | ( | const int | hit,
 |  | const int | memberNumber = 0
 | ) |  | const
 virtual

Return the ms_protein hit - returns null if hit > number of hits.

If MSPEPSUM_USE_CACHE is set, this function will load the hit results 'on demand'.

If MSRES_GROUP_PROTEINS is specifed when creating the ms_peptidesummary, then memberNumber should be set to 1 (or 0) and the 'main' hit is returned.

If MSRES_CLUSTER_PROTEINS is specifed when creating the ms_peptidesummary, then there may be multiple members for each family. See Using MSRES_CLUSTER_PROTEINS for more details.

Parameters
hit | Must be in the range 1.. getNumberOfHits().
memberNumber | Should be 1 (or 0) for a protein not in a family or for the main protein in a hit family. It should be 2 or more for subsequent proteins in the family. If this number is greater than the number of proteins in the family then the function returns a null value.
Returns
If the hit number is outside the range above, then this function will return a null value. See Maintaining object references: two rules of thumb.

Reimplemented from ms_mascotresults.

◆ getHomologyThreshold()

int getHomologyThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1
 | ) |  | const
 virtualinherited

Returns the 'homology' threshold.

For MS-MS data only, this returns a threshold value for significant homology rather than identity. This value appears in the yellow popup box for an MS-MS result: Score greater than XX indicates homology.

The return value will be zero if the threshold is not available. The value cannot be determined if the query contains error tolerant matches, or if the query contains a tag or etag, or if the value of qmatch is less than or equal to 100.

The value returned will not be higher than the identity threshold.

In versions prior to 2.2, the homology threshold was not affected by OneInXprobRnd – this was corrected in version 2.2.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. You can either pass ms_peptide::getRank() as the rank parameter, or use one of the enumerated values for HOMOLOGY_THRESHOLD_SOURCE. The rank determines the data source.

In an integrated spectral library search:

  • If rank = HOMTHR_FASTA, the method returns the FASTA homology threshold.
  • If the peptide at the given rank is from a FASTA database and is not a library match, the method returns the FASTA homology threshold.
  • If rank = HOMTHR_SL, the method returns zero (since library searches don't have a homology threshold).
  • If the peptide at the given rank is from a spectral library, the method returns zero.

In an integrated error tolerant search, behaviour depends on Mascot version. If the results file is from Mascot 2.8 or later:

  • If the query was selected for the second pass search, the method returns zero regardless of the rank argument.
  • If the query was only searched in the first pass, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().

If the integrated error tolerant search is from Mascot 2.7 or earlier:

  • If rank = HOMTHR_FASTA, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().
  • If the peptide at the given rank is a first pass match, the method returns the first pass homology threshold.
  • If the peptide at the given rank is an ET match, the method returns 0.
Parameters
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
Returns
The homology threshold. If there was no MS-MS data for this query then 0 will be returned.
Examples
resfile_summary.cpp.

◆ getHomologyThresholdForHistogram()

int getHomologyThresholdForHistogram | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtualinherited

Returns the value for the 'yellow section' in the histogram.

For MS-MS data only, this returns a homology (rather than identity) threshold value that is shown at the top of the report: Individual ions scores > 19 indicate peptides with significant homology (p<0.05).

The yellow area on the histogram also corresponds to this value.

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot homology threshold. If dbType is DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
The homology threshold. Note that this value is only available for an MS-MS search with just one MS-MS data set, otherwise the return value will be zero.

◆ getIonsScore()

double getIonsScore | ( | const int | q,
 |  | const int | p,
 |  | const bool | decoy
 | ) |  | const
 virtual

Returns an ions score quickly without having to load an ms_peptide object.

If other values are required from the ms_peptide object, then it is normally faster to call getPeptide() and then ms_peptide::getIonsScore

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
decoy is a flag to indicate if the score should be taken from the decoy section. This should only be set to true for searches with decoy matches.
Returns
the score, or 0 if there was no score for these q / p values.

Implements ms_mascotresults.

◆ getIonsScoreCorrected()

double getIonsScoreCorrected | ( | const double | ionsScore,
 |  | const long | multiplicity
 | ) |  | const
 protectedinherited
Note
It shouldn't be necessary to call this function from outside the library.

This function is required here rather than as part of the ms_peptide object because one ms_peptide object can be used from many different proteins – each with a different multiplicity factor.

This function subtracts the factor:

  • -10 * log(multiplicity) * $tolFact / log(10); where
  • tolFact = sqrt(ITOL * ITOL + 0.0625);
Parameters
ionsScore | Is the uncorrected ions score.
multiplicity | can be obtained from ms_protein::getPeptideMultiplicity.
Returns
The corrected value..

◆ getIonsScoreHistogram()

std::vector< int > getIonsScoreHistogram | ( | IONS_HISTOGRAM | flags = IH_INCLUDE_TOP_MATCHES,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtualinherited

Returns a list of counts for binned ions scores.

  • The first element of the array returns the count of matches with a score between 0 and 1.
  • The second element of the array returns the count of matches with a score between 1 and 2.
  • The third element of the array returns the count of matches with a score between 2 and 3. etc. etc.
Parameters
flags | Currently only IH_INCLUDE_TOP_MATCHES and IH_INCLUDE_TOP_10_MATCHES are supported.
dbType | If given, should be DM_FASTA for Mascot scores and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, empty vector is returned.)
Returns
a vector of integers. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getLibraryEntryId()

void getLibraryEntryId | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | dbIdx,
 |  | std::vector< int > & | offset,
 |  | std::vector< std::string > & | checksum,
 |  | std::vector< std::string > & | mods
 | ) |  | const

Return the database number, MSP file offset, checksum and modifications of the matched spectral library entry.

If the peptide match q,p is a spectral library match, this method returns the source database index, an offset into the MSP file that was searched, a checksum of the peak list of the library entry and the modifications in the library entry. Typically each of the dbIdx, offset and checksum vectors contains only one element – the library entry that matched the query. However, under some circumstances Mascot may merge matches from different library entries or libraries in the same peptide match (for example, if it has same sequence, same mods and same score). In that case, the vectors may contain multiple elements, but each vector is guaranteed to have the same number of elements. Mascot 2.6 does not merge library matches.

The datatabase index, offset, checksum and mods can be used for looking up the correct library entry; see example code in ms_spectral_lib_file::findEntries(). Once the correct entry is found, you can access its attributes, peak list, etc. with the corresponding methods in ms_spectral_lib_entry.

Note that the library ID returned by MSPepSearch is not stored in the Mascot results file, as the NIST library compression tool can renumber library entries arbitrarily if the MSP file changes.

If q,p is not a spectral library match, the returned vectors are empty.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
q | query number of the spectral library match, in range 1..ms_mascotresfilebase::getNumQueries().
p | rank of the spectral library match, in range 1..getMaxRankValue().
dbIdx | returns a list of database indices.
offset | returns a list of integer offsets.
checksum | returns a list of peak list checksums.
mods | returns a list of the modifications for each entry. The format of the mods is as described in ms_spectral_lib_entry::getMods() and can be passed verbatim to ms_spectral_lib_file::findEntries().

◆ getLibraryModString()

std::string getLibraryModString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the modification string of the spectral library match from q1_p1_SLmod.

The modification string has the format

 q1_p1_SLmod=position:mod,position:mod,...

where position is a 1-based index into the peptide sequence and mod is a numeric index into the spectral_library section of the results file. The modification name and delta can be found with ms_searchparams::getLibraryModName() and ms_searchparams::getLibraryModDelta().

Note that position 1 is the first residue of the peptide sequence, which is the same convention as with ms_peptide::getVarModsStr(). However, MSPepSearch reports terminal modifications as modifications on the first and last residue. Positions 0 and N+1 (if sequence length is N) are reserved for future use.

For Mascot matches, the library modification string is empty.

In protein summary, this method always returns the empty string.

See also
Spectral libraries.
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the rank number.
Returns
modification string of the match if it is a spectral library match and has modifications, and empty string otherwise.

Implements ms_mascotresults.

◆ getMaxPeptideIdentityThreshold()

int getMaxPeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtualinherited

Return the max threshold value for all MS-MS data sets.

The maximum value is calculated by taking the maximum value returned by calling getPeptideIdentityThreshold() for each query. This is the value that is shown at the top of the standard Mascot peptide summary report (version 2.0 and later). For example, threshold in the following string could be calculated by calling getMaxPeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Versions of Mascot prior to 2.0 displayed the equivalent of getAvePeptideIdentityThreshold().

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
The maximum score threshold. If there was no MS-MS data then -1 will be returned.

◆ getMaxRankValue()

int getMaxRankValue ( ) const
virtualinherited

Returns the maximum 'rank' or 'hit' or 'p' value.

For functions such as getPeptide(), a 'rank' or 'hit' value is required. The allowable range for this values depends on whether it is a protein summary or peptide summary.

For a peptide summary the value returned will normally be 10, but for an integrated error tolerant search, integrated spectral library search and integrated crosslinked search, this can be in the range 1..20.

For a protein summary the return value will be ms_mascotresfilebase::getNumHits() – with the appropriate parameter passed for the case of a decoy or error tolerant search.

Returns
max rank value

◆ getMinPepLenInPepSummary()

int getMinPepLenInPepSummary ( ) const
inherited

Peptides shorter than this are ignored when putting proteins into groups.

minPepLenInPepSummary is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins together.

Specify this value when creating an ms_peptidesummary::ms_peptidesummary object. This value will always be zero for ms_proteinsummary.

Returns
The minimum peptide length considered when creating the peptide summary.

◆ getMinProbabilityForSLScore()

double getMinProbabilityForSLScore ( double score )
static

Return the minProbability value that sets library score threshold to the given value in SL-only mode.

The significance threshold (minProbability parameter) that corresponds to the library score threshold score is calculated from the expect value formula:

E(s) = 0.05 * 10 ** (-(s - 300)/100)

This method should only be used in SL-only mode (MSPEPSUM_SL_ONLY). In integrated mode (MSPEPSUM_SL_INTEGRATED), library score significance is calculated based on Mascot matches; see getPeptideExpectationValue().

Note that due to how library scores are converted to expect values, the maximum minProbability (1.0) corresponds to score 170. If you give a score less than 170 as argument, the function returns just a bit less than 1.0.

Parameters
score Desired library score threshold. If it is not within the range (0, 1000), the function returns 0.05.
Returns
Value for the minProbability parameter that sets library score threshold to score in SL-only mode.

◆ getNextFamilyProtein()

ms_protein * getNextFamilyProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const
 virtualinherited

Find the next protein in the family masterHit.

Call this function multiple times for each masterHit, incrementing id each time. When there are no more protein families this function will return a null value.

The main protein for the hit should be obtained by calling ms_mascotresults::getHit()

See Using MSRES_CLUSTER_PROTEINS for further information.

See also
ms_protein::GROUP
Parameters
masterHit | is the id for the main hit (1..n).
id | is a 'one based' number.
Returns
The next protein family or a null value if there is no such group. See Maintaining object references: two rules of thumb.
Examples
resfile_summary.cpp.

◆ getNextSimilarProtein()

ms_protein * getNextSimilarProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const
 virtualinherited

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP
Parameters
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
Returns
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.

◆ getNextSimilarProteinOf()

ms_protein * getNextSimilarProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const
 virtualinherited

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP
Parameters
masterAccession | is the accession for the main hit.
masterDB | is the database (FASTA) ID for the main hit.
id | is a 'one based' number.
Returns
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.
Examples
resfile_summary.cpp.

◆ getNextSubsetProtein()

ms_protein * getNextSubsetProtein | ( | const int | masterHit,
 |  | const int | id,
 |  | const bool | searchWholeFamily = true
 | ) |  | const
 virtualinherited

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP, getNextSubsetProteinOf()
Parameters
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
searchWholeFamily | only has meaning when MSRES_CLUSTER_PROTEINS is specified. See Using MSRES_CLUSTER_PROTEINS.
Returns
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.

◆ getNextSubsetProteinOf()

ms_protein * getNextSubsetProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const
 virtualinherited

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information.

Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP, getNextSubsetProtein()
Parameters
masterAccession | is the accession for the master hit or a family hit.
masterDB | is the database (fasta) ID for the main hit.
id | is a 'one based' number.
Returns
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.
Examples
resfile_summary.cpp.

◆ getNumberOfAccessionDBTypes()

std::vector< int > getNumberOfAccessionDBTypes | ( | int | q,
 |  | int | p
 | ) |  | const

Return a count of protein accessions by database type of all the accessions that contained the peptide match.

For the full list of data about protein accessions, see getAllProteinsWithThisPepMatch(). This method only counts the number of times each type of database (AA, NA, SL, SLREF) appears in the list of protein accessions.

Crosslinked searches only: in a crosslinked match, if alpha and beta are assigned to the same protein hit, the protein's database is counted twice.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'hit' or 'rank' number. For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) or an integrated spectral library search, this can be in the range 1 to 20.
Returns
A vector of counts by database type. The vector has four elements, where the indices are AA (0), NA (1), SL (2) and SLREF (3).

◆ getNumberOfFamilyAccessionDBTypes()

std::vector< int > getNumberOfFamilyAccessionDBTypes | ( | int | hit,
 |  | int | q,
 |  | int | p,
 |  | bool | includeSamesets = true
 | ) |  | const

Return a count of protein accessions by database type of all the family members that contained the peptide match.

For the full list of data about family members, see getAllFamilyMembersWithThisPepMatch(). This method only counts the number of times each type of database (AA, NA, SL, SLREF) appears in the list of protein accessions.

What is counted: family members and optionally their samesets.

What is not counted: subset and intersection proteins and their samesets.

Parameters
hit | Should be in the range 1.. getNumberOfHits().
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'hit' or 'rank' number. For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) or an integrated spectral library search, this can be in the range 1 to 20.
includeSamesets | If true (default), include samesets of family members in the counts. Otherwise count only lead proteins of family members.
Returns
A vector of counts by database type. The vector has four elements, where the indices are AA (0), NA (1), SL (2) and SLREF (3).

◆ getNumberOfFamilyMembers()

int getNumberOfFamilyMembers ( ) const
virtualinherited

Return the total number of family members.

Returns
This function returns the number of 'top level' hits and family members, not taking into account any proteins that are identical or subsets of these hits. The value will be identical to that returned by getNumberOfHits() unless the ms_mascotresults::MSRES_CLUSTER_PROTEINS flag has been specified. In that case the number of values returned by getNextFamilyProtein() will be included.

◆ getNumberOfHits()

int getNumberOfHits ( ) const
virtualinherited

Returns the number of hits in the results.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
This function returns the number of 'top level' hits – not taking into account any proteins that are identical or subsets of the 'top level' hits. ms_mascotresults::getHit() can be called with any number from 1 to the value returned by this function.

◆ getNumberOfUnassigned()

int getNumberOfUnassigned ( ) const
inherited

Return the number of peptides in the unassigned list.

See Unassigned peptides list for details of creating and using an unassigned list.

If there is no cache file for the results, then createUnassignedList() must be called before calling this function or the ms_errs::ERR_UNASSIGNED_PROG error will be set, and this function will return 0.

If a cache file has been created, then there is no requirement to call createUnassignedList() before calling this function.

Returns
the number of peptides in the unassigned list, or 0 in the case of an error.
Examples
resfile_summary.cpp.

◆ getNumDecoyHitsAboveHomology()

long getNumDecoyHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtualinherited

Return the number of hits from the decoy search with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold(). These values may be slightly different from the threshold for the non-decoy matches.

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

y* The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of decoy hits with a score at or above the homology threshold.

◆ getNumDecoyHitsAboveIdentity()

long getNumDecoyHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtualinherited

Return the number of hits from the decoy search with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold(). This value may be slightly different from the threshold for the non-decoy matches.

For a protein summary, the number of hits is the number of protein matches. This number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of decoy hits with a score at or above the identity threshold.

◆ getNumDiscoveredErrTolMods()

std::vector< int > getNumDiscoveredErrTolMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtualinherited

Return the count of error tolerant modifications discovered in this search.

The number of times an error tolerant modification has been discovered in the search is the number of times it appears in rank 1 matches in the search results. Since the number and kind of error tolerant modifications is (practically) unlimited, you should call getDiscoveredErrTolModNames() first to find out which error tolerant modifications appear in the search. (The count of error tolerant modifications that do not appear in the search is, of course, zero.) Amino acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

Only significant rank 1 matches assigned to a protein hit are counted. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the error tolerant modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
modName | Error tolerant modification name (as returned by getDiscoveredErrTolModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the error tolerant modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredFixedMods()

std::vector< int > getNumDiscoveredFixedMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtualinherited

Return the count of fixed modifications discovered in this search.

The number of times a fixed modification has been discovered in the search is the number of times the terminus or residue matching its specificity appears in significant rank 1 matches assigned to a protein hit in the search results. For example, if Carbamidomethyl (C) is specified as a fixed modification, then the number of times it has been discovered in the search is the number of C residues in peptide sequences in significant rank 1 matches assigned to a protein hit.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the fixed modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a fixed modification with two different specificities in the search, discovery counts will be returned separately. For example, if fixed modification 1 is Carbamidomethyl (C) and 2 is Carbamidomethyl (N-term), then calling getNumDiscoveredFixedMods() with num = 1 returns the Carbamidomethyl count for specificity "Anywhere" and "C", while num = 2 returns the count for specificity "Any N-term" and "N-term". In both cases each vector contains a single item.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
num | Fixed modification number (same value as passed to ms_searchparams::getFixedModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the fixed modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredIntactLinks()

std::vector< int > getNumDiscoveredIntactLinks | ( | std::vector< int > & | varModNum1,
 |  | std::vector< std::string > & | position1,
 |  | std::vector< std::string > & | site1,
 |  | std::vector< int > & | varModNum2,
 |  | std::vector< std::string > & | position2,
 |  | std::vector< std::string > & | site2,
 |  | std::vector< int > & | numLinkedPeptides
 | ) |  | const
 inherited

Return the count of intact crosslinks in this search.

The number of times an intact crosslink has been discovered in the search is the number of times it appears as the intact link in significant rank 1 matches assigned to a protein hit.

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the link occurred, while varModNum1, position1 and site1 have the variable mod number, position and site of the first end of the link and varModNum2, position2 and site2 have the second end.

For example, if the ith specificity is N-terminal K, the ith element of alphaPositions would be "Any N-term" and the ith element of alphaSites would be "K".

In the simplest case, there is one linker with one specificity, say Xlink:DSS (K). All the vectors have just one element. If the linker has two specificities, like Xlink:DSS (K) and Xlink:DSS (Protein N-term), there will be three site pairs: (K, K), (K, Protein N-term) and (Protein N-term, Protein N-term). The pair (Protein N-term, K) is collated with (K, Protein N-term).

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
varModNum1 | Variable modification number for the first end of link.
position1 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site1 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
varModNum2 | Variable modification number for the second end of link.
position2 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site2 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
numLinkedPeptides | A vector containing the number of linked peptides corresponding to each count. Looplinked counts have 1 peptide, while crosslinked counts have 2 peptides.
Returns
The number of times the intact link was observed in significant rank 1 matches assigned to a protein hit.

◆ getNumDiscoveredLibraryMods()

std::vector< int > getNumDiscoveredLibraryMods | ( | const int | modId,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 inherited

Return the count of library modifications discovered in this search.

The number of times a library modification has been discovered in the search is the number of times it appears in the library mods string in significant rank 1 spectral library matches assigned to a protein hit in the search results.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the library modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that modifications are part of the metadata of spectral library entries. Unlike in database searches, they are not specified as part of the search parameters. Some caveats apply:

  • A library modification may have the same name as a variable or fixed modification in the database search, and they may well be the same modification – but you need to know how the library was constructed to conclude either way.
  • Library modification name is usually a free-text string, which may or may not be a Unimod modification name.
  • The MSP format for spectral libraries does not support specifities in the same way as Mascot. The "position" of the modification is not encoded in the library and is thus unknown; it will always be Anywhere.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
modId | modification ID, same as passed to ms_searchparams::getLibraryModName(). Must be in range 1..ms_searchparams::getNumberOfLibraryMods().
positions | A vector of positions, always "Anywhere".
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the library modification was observed in significant rank 1 spectral library matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredLocalMods()

std::vector< int > getNumDiscoveredLocalMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtualinherited

Return the count of query-level modifications discovered in this search.

The number of times a query-level modification has been discovered in the search is the number of times it appears in significant rank 1 matches assigned to a protein hit in the search results.

Query-level modifications are counted separately from variable modifications (specified at search form level), because each individual query may contain up to 32 query-level variable modifications. This means the search as a whole may contain more than 32 different query-level modifications. You should call getDiscoveredLocalModNames() first to find out which query-level modifications appear in the search.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the query-level modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that only significant rank 1 matches assigned to a protein hit are counted.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
modName | Query-level modification name (as returned by getDiscoveredLocalModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the query-level modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredNonSpecCleavage()

int getNumDiscoveredNonSpecCleavage ( ) const
virtualinherited

Return the count of non-specific cleavages in an error tolerant search.

An error tolerant match is the product of non-specific cleavage when the residue before or after the peptide terminal residue does not match the cleavage specificity of the enzyme. For example, trypsin cleaves at C-term K or R (unless followed by P), so all tryptic peptide sequences have K or R as the (N-term) residue before the sequence. An error tolerant match with non-specific cleavage would have a residue other than K or R at N-terminus.

Only significant rank 1 matches assigned to a protein hit contribute towards the count of non-specific cleavages. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the match is not counted.

Returns
The number of times non-specific cleavage occurred in significant rank 1 matches assigned to a protein hit, or -1 for non-error tolerant search.

◆ getNumDiscoveredVariableMods() [1/2]

std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtualinherited

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

See also
getNumDiscoveredVariableMods(const int, std::vector<std::string>&, std::vector<std::string>&, std::vector<delta>&, std::vector<std::string>&) const
Parameters
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredVariableMods() [2/2]

std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites,
 |  | std::vector< double > & | deltas,
 |  | std::vector< std::string > & | names
 | ) |  | const
 virtualinherited

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

The ith element in the deltas and names vectors defines the delta and name of the modification, respectively. If the search has no crosslinking method, these two parameters can be ignored. When the modification number num refers to a crosslinker, the the deltas and names vectors contain values for all monolinks represented by the entry.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
deltas | A vector of deltas.
names | A vector of names.
Returns
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumHitsAboveHomology()

long getNumHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtualinherited

Return the number of hits with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold().

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of hits with a score at or above the homology threshold.

◆ getNumHitsAboveIdentity()

long getNumHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtualinherited

Return the number of hits with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold().

For a protein summary, the number of hits is the number of protein matches. The number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions make take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of hits with a score at or above the identity threshold.

◆ getPepsWithSameScore()

std::vector< int > getPepsWithSameScore | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Returns a list of 'p' values for peptides with the same score.

Peptides with the same score will have the same pretty rank. See ms_peptide::getPrettyRank() for details.

It is preferable to call this function rather than to loop through all the ranks calling getPeptide() for each one because the cached index stores the pretty ranks and this should therefore be faster.

For a protein summary, the returned list always contains a single value that is the same as the passed p value.

Parameters
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue().
Returns
a list of the ranks that have the same pretty value. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Implements ms_mascotresults.

◆ getPeptide() [1/2]

ms_peptide getPeptide | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return a peptide object for the specified query / rank.

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfilebase::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
an ms_peptide object.

Implements ms_mascotresults.

◆ getPeptide() [2/2]

bool getPeptide | ( | const int | q,
 |  | const int | p,
 |  | ms_peptide *& | pep
 | ) |  | const
 virtual

Return a peptide object for the specified query / rank.

Note
This function can not be used in programming languages other than C++.

To get the q and p values for a peptide in an ms_protein, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfilebase::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries()
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.

  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
pep is reference to a pointer to an ms_peptide object that will be returned.
Returns
true if the peptide exists.

Implements ms_mascotresults.

◆ getPeptideAmbiguityRanks()

std::vector< int > getPeptideAmbiguityRanks | ( | const int | q,
 |  | const int | p
 | ) |  |

Return a vector of ranks that have the same ambiguity group.

Ambiguity group ids start at 1 Two peptides are in the same ambiguity group when either 1) they have the same query and same pretty rank 2) or they have the same query, same sequence and different search engine

Note: q and p have to be within limits, otherwise an empty vector is returned Additional note: these values are in the cache file only from ms_peptidesummary::BUGFIX_12538 Calling this method with an older cache may be considerably slower

Parameters
q | query number
p | rank number
Returns
A vector of ranks that have the same ambiguity group id.

◆ getPeptideExpectationValue()

double getPeptideExpectationValue | ( | const double | score,
 |  | const int | query,
 |  | const int | rank = 0
 | ) |  | const
 virtualinherited

Returns the expectation value for the given peptide score and query.

Returns the number of peptides that you would expect to get this score or higher from this database. This value is displayed as the expectation value in Mascot 2.0 and later reports. When the value is below 1, it approximates the p-value corrected for multiple testing.

For Mascot matches, the expectation value is calculated from

    E = Pthreshold * (10 ** ((Sthreshold - score) / 10))

For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

The Sthreshold value is the value returned by getHomologyThreshold() if ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specifed in the ms_peptidesummary constructor, otherwise the value used is the one returned from getPeptideIdentityThreshold().

Parser 2.8 and later can calculate expectation values for Mascot error tolerant matches. The value is based on the combined first and second pass identity threshold. If rank is zero, getPeptideExpectationValue() assumes the score is a first pass match score and calculates the value from the first pass identity or homology threshold. If rank is non-zero, the correct threshold is chosen based on the match at rank rank in this query.

ET expectation value is only available if the results file is from Mascot 2.8 and later. When you open results from Mascot 2.7 and earlier, expectation value for ET matches is -1. Note that Parser 2.7 and earlier returned a non-negative but incorrect number for ET matches.

For spectral library matches, the expectation value formula depends on report mode.

  • In integrated mode (ms_peptidesummary::MSPEPSUM_SL_INTEGRATED), library scores are scaled internally so that their mean and standard deviation match the mean and standard deviation of significant rank 1 Mascot matches with the same sequence in the same query. See Library scores and thresholds.
  • In SL-only mode (ms_peptidesummary::MSPEPSUM_SL_ONLY), the expect value formula is
     E = 0.05 * 10 ** (-(s - 300)/100).
    For example, E = 0.05 for score 300.

Spectral library support was added in Mascot Parser 2.6. If rank is zero, which is the default in Parser 2.5 and earlier, the score is assumed to be a Mascot ions score. If rank is non-zero, the correct formula is chosen based on the type of the match at rank rank in this query.

See also
getProteinExpectationValue()
Parameters
score | is the Mascot score to be converted.
query | specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
rank | is the rank of the match of interest in this query.
Returns
The number of peptides that you would expect to get this score or higher from this database, or -1 if it cannot be calculated.

◆ getPeptideIdentityThreshold()

int getPeptideIdentityThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtualinherited

Return the threshold value for this ms-ms data being a random match.

See also
getAvePeptideIdentityThreshold()
Parameters
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType | If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
A score threshold. If query is < 1 or > ms_mascotresfilebase::getNumQueries() then -1 will be returned. If there was no MS-MS data or no match for this query, then -1 will be returned.
Examples
peptide_list.cpp, and resfile_summary.cpp.

◆ getPeptideThreshold()

double getPeptideThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1,
 |  | const THRESHOLD_TYPE | thresholdType = TT_PEPSUM_DEFAULT
 | ) |  | const
 inherited

Return either the identity or the homology threshold.

The default is to use identity thresholds for the original Peptide Summary and Select Summary reports. For the Family Summary grouping, homology thresholds are used, and this needs to be specified by using the ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH flag. (This flag is automatically set when using the ms_mascotresfilebase::get_ms_mascotresults_params helper function).

This function calls getPeptideIdentityThreshold() or getHomologyThreshold() as appropriate. If it calls getHomologyThreshold() and this returns 0, then the identity threshold is returned.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. See getHomologyThreshold().

If the peptide match at rank rank is an ET match, and the results file is from Mascot Server 2.7 or earlier, then getPeptideIdentityThreshold() returns -1 and getPeptideThreshold() returns -1.

Parameters
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries()
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
thresholdType | can be any one of the ms_mascotresults::THRESHOLD_TYPE values
Returns
the threshold.

◆ getProbabilityThreshold()

double getProbabilityThreshold ( ) const
virtualinherited

Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.

In a protein summary, the probability threshold specifies a cutoff point for protein scores, a cutoff for an Integrated error tolerant search and a threshold for calculating MudPIT scores.

In a peptide summary, the identity and homology thresholds of a peptide match are calculated from the probability threshold (significance threshold). This is the value of "Significance threshold p&lt;" shown in Mascot search reports.

getProbabilityThreshold() returns the currently active first pass significance threshold. The value may differ from the minProbability constructor argument if a target FDR has been specified. See ms_mascotresults_params::getTargetFDR().

If target FDR has not been specified, and if a value of <= 1e-18 or >= 1 is passed to the constructor, then a value of 1/20 (0.05) will be returned by this function. Otherwise it will just return the value passed to the ms_mascotresults::ms_mascotresults constructor.

In an error tolerant search, getProbabilityThreshold() may differ from the significance threshold used during the search, which was the basis for protein selection for the second pass. This is recorded as the first_pass_threshold= line in the results file header.

Error tolerant matches use an independent significance threshold, getErrTolProbabilityThreshold().

Returns
probability threshold for peptide matches.

◆ getProbFromScore()

int getProbFromScore ( const double score ) const
virtualinherited

Returns a probability value given a score.

Warning
Do not use this without fully understanding what the function returns. It is more likely that you will want to use getPeptideExpectationValue() or getProteinExpectationValue().
Parameters
score is the Mascot score.
Returns
probability calculated from p = pow(10.0, (score/10.0)).

◆ getProbOfPepBeingRandomMatch()

double getProbOfPepBeingRandomMatch | ( | const double | score,
 |  | const int | query
 | ) |  | const
 virtualinherited
Deprecated:
Use getPeptideExpectationValue().

Returns the inverse of getPeptideExpectationValue(). If, for example, the identity threshold (p<0.05) for a particular query is 30, and a value of 30 is passed to this function, then the return value will be 1/0.05. If, for the same search, a peptide of interest gets a score of 50, then this function will return a value of 1 / 0.00067 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also
getProbOfProteinBeingRandomMatch()
Parameters
score | is the Mascot score
query | specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
Returns
The probability.
Examples
resfile_summary.cpp.

◆ getProbOfProteinBeingRandomMatch()

double getProbOfProteinBeingRandomMatch ( const double score ) const
virtualinherited
Deprecated:
Use getProteinExpectationValue().

Returns the inverse of getProteinExpectationValue(). If, for example, the identity threshold (p<0.05) for a PMF search is 56, and a value of 56 is passed to this function, then the return value will be 1/0.05. If, for the same search, a protein of interest gets a score of 90, then this function will return a value of 1 / 0.000025 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also
getProbOfPepBeingRandomMatch()
Parameters
score is the Mascot score to be converted.
Returns
The inverse of getProteinExpectationValue().

◆ getProtein()

const ms_protein * getProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const
 virtual

Return a pointer to the protein entry given an accession.

Parameters
accession is the accession string.
dbIdx is the database index (1..ms_searchparams::getNumberOfDatabases()).
  • For a PMF mixture in protein summary (see Peptide mass fingerprint mixtures), use the default value of 1 even if the component proteins are all from other databases.
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented from ms_mascotresults.

◆ getProteinDescription()

std::string getProteinDescription | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const
 inherited

Return protein description if available.

This method attempts to return the 'description line' for the given accession. The description line originated from the FASTA file that was searched. An empty string will be returned if the protein is not listed in the proteins section or the summary section of the results file.

Format in the proteins section is, for example:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search all, protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

The alternative way to get the description line is to call

     ms-getseq.exe [db] [accession] title

when nothing is returned by getProteinDescription(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

If the 'protein' is actually a UniGene entry, then the description line is taken by concatenating the Gene and the Title line for the relevant entry.

If the protein is a PMF mixture, then the description line will be of the format:

 * Mixture from proteins:"gi|1234","gi|5432","gi|9999"

If the protein comes from the reference database of a spectral library, then its description is not saved in the results file and this method returns the empty string. If the protein comes from the spectral library, it may or may not have a description, depending on how the library was created.

For a search against a decoy database, if the result is from the decoy section, then the description is prefixed with "Random sequence, was ", or if there is no description in the file, "Random sequence.". Depending on the configuration of the search, Random may also be Reversed or Shuffled.

Parameters
accession | is the accession string.
dbIdx | database index used for the search.
Returns
The description line or an empty string.
Examples
resfile_summary.cpp.

◆ getProteinEmPAI()

double getProteinEmPAI | ( | const char * | accession,
 |  | const int | dbIdx = 1,
 |  | const int | length = -1
 | ) |  | const
 virtual

Return protein emPAI if available.

The Exponentially Modified Protein Abundance Index (emPAI) offers approximate, label-free, relative quantitation of the proteins in a mixture based on protein coverage by the peptide matches in a database search result. The key publication is

Ishihama, Y., et al.: Exponentially modified protein abundance index (emPAI) for estimation of absolute protein amount in proteomics by the number of sequenced peptides per protein (2005). Molecular & Cellular Proteomics 4:1265-1272.

The number of observed peptides is determined using the function ms_protein::getNumObservedForEmPAI().

Protein sequence length is needed for emPAI calculation. You have two options:

  1. Give the sequence length as an argument to this method. You will need to fetch it with e.g. ms-getseq.exe on the Mascot Server machine.
  2. Give no argument to the method. If the protein has a mass in the results file, the mass will be used to calculate an approximate sequence length.

If no sequence length is given and the protein has no mass in the results file, the method returns -1. If you know the mass of the protein but not its sequence length, you can use the following approximate formula:

length = floor(0.5 + mass / 111)

Here 111 Da is the average mass of an amino acid residue.

If ms_mascotresults::isEmPAIallowed() is false, this method returns -1.

Parameters
accession | Protein accession.
dbIdx | Protein database index number.
length | Protein sequence length (optional). If the length is not given, protein mass from the results file will be used to approximate it. If protein mass is not available, the method returns -1.
Returns
emPAI or -1, as described above.

Reimplemented from ms_mascotresults.

◆ getProteinExpectationValue()

double getProteinExpectationValue ( const double score ) const
virtualinherited

Returns the expectation value for the given protein score.

Returns the number of proteins that you would expect to get this score or higher from random matches for this search. For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also
getPeptideExpectationValue()
Parameters
score is the Mascot protein score to be converted.
Returns
The expectation value.

◆ getProteinMass()

double getProteinMass | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const
 inherited

Return protein mass if available.

This method attempts to return the mass for the given accession. The protein mass is calculated during the Mascot search, and some, but not all, of these masses are saved in the results file. A value of zero will be returned if the protein is not listed in the proteins section or the summary section of the results file.

The format in the proteins section is, for example, for a protein of mass 79480.13 daltons:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search, all protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines and masses in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines and masses are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

If a mass of zero is returned by this function, then the alternative way to get the mass is to call

     ms-getseq.exe [db] [accession] seq

to get the sequence, and then call getSequenceMass(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

Parameters
accession | is the accession string.
dbIdx | database number (1..ms_searchparams::getNumberOfDatabases()).
Returns
The protein mass or 0.0.
Examples
resfile_summary.cpp.

◆ getProteinScoreCutoff()

int getProteinScoreCutoff ( double OneInXprobRnd ) const
virtual

Return the 'protein' score value for cutting off results. Different for peptide and protein summary.

The protein probability cutoff is calculated differently for a protein summary and a peptide summary.

  • For a peptide summary, we want to display any proteins that contain even one significant peptide, which means the threshold is the same as getAvePeptideIdentityThreshold().

    For MudPIT scoring, any protein with a score greater than zero must have one or more peptides above the homology threshold, so this function returns a value of 1.

  • For a protein summary, we simply use the protein score that corresponds to the threshold.
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns
The protein score cutoff threshold.

Implements ms_mascotresults.

◆ getProteinScoreForHistogram()

double getProteinScoreForHistogram ( const int num ) const
virtualinherited

Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.

The 'well known' green and red histogram at the top of the Mascot reports is created from the top 50 protein scores in the results. However, if the number of hits requested for a peptide or protein summary is 'AUTO' or is less than 50, then there won't be 50 hits in the ms_mascotresults object so it won't be possible to create the histogram.

This simple method can reliably be used to return the score for a hit number between 1 and 50, regardless of the number of entries in the protein or peptide summary. To create the histogram, it will be necessary to call this method 50 times - with num being 1..50.

In the rare case of there being less than 50 proteins in the results file, a value of -1 will be returned for values of num that have no protein hit. If a protein is rejected because it only has peptides shorter than minPepLenInPepSummary or because the MSRES_REQUIRE_BOLD_RED is set, then this protein will not be included in the list.

Parameters
num Is a value in the range 1..50.
Returns
The score.

◆ getProteinsWithThisPepMatch()

std::string getProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | const bool | quotes = false
 | ) |  |
virtual

Return a partial list of proteins that matched the same peptide.

The returned string is of the following form:

    1:Q9XZJ2  2:100K_RAT  3:AAF55150

The list is the hit number / accession of all proteins that matched the same peptide. There is no indication of which database the hit is from, but this can of course be determined by calling getHit().

In ms_peptidesummary, this is taken from the list of accessions on the q1_p1= line. The returned string only includes proteins that are in the current peptide summary. This means for example that if you choose to only see the top 5 hits, and this query/rank is for a peptide that occurs in protein 6, then protein number 6 will not appear in the resulting string.

In ms_proteinsummary, the string is also constructed from the list of accessions on the q1_h1= line. There's an additional check that the query number is the same, and that the peptide is the same string.

If you want a list of accession strings rather than a single concatenated string, use the function getAllProteinsWithThisPepMatch().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' number (in ms_proteinsummary) or 'rank' number (in ms_proteinsummary).
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence h must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
quotes specifies whether the accessions will be quoted, which should allow accesions with spaces and colons. If true, the string returned would then be
1:"Q9XZJ2" 2:"100K_RAT" 3:"AAF55150"
Returns
list of proteins matching the peptide, as a string

Implements ms_mascotresults.

◆ getProteinTaxonomyIDs()

void getProteinTaxonomyIDs | ( | const char * | accession,
 |  | const int | dbIdx,
 |  | std::vector< int > & | gpt_ids,
 |  | std::vector< std::string > & | gpt_accessions
 | ) |  | const
 inherited

Return the taxonomy ID(s), if any, from the results file.

In Mascot 2.4.0 and later, taxonomy IDs are saved in the proteins section of the results files in the form:

   [DB::]"accession"_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

In Mascot 2.4.1 and later, taxonomy IDs are also saved in the summary section of the results files in the form:

   hN_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

For example, for a single database, with a single accession/taxonomy:

   "gi|209490801"_tax=87229

   h1=gi|209490801, ...
   h1_tax=87229

and for a multi-database search, with a single accession/taxonomy:

   02::"gi|209490801"_tax=87229

   h1_db=2
   h1=gi|209490801, ...
   h1_tax=87229

and for a single database, with multiple accession/taxonomy:

   "gi|182438931"_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

   h1=gi|182438931, ...
   h1_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

If none of the databases used for the search contain taxonomy information, then no _tax lines will be output.

If any of the databases used for the search contain taxonomy information, then a _tax line will be output for all relevant proteins. This is governed by the same rules that determine for which proteins to output the mass and description lines. If a protein has no taxonomy information (for example, the database has no taxonomy), -1 will be used as the taxonomy ID.

Therefore, to determine if taxonomy information is available in the results file, simply take any protein in the proteins section, and see if there is a corresponding _tax entry.

For most FASTA files, there is a single accession and taxonomy for each sequence entry. For the NCBInr database, identical sequences are only stored once, but there are multiple accession/description lines separated by a "Control-A" character. Each accession may have a different taxonomy. This function returns the list of taxonomy IDs and corresponding accessions. For the last example shown above, this function will return the arrays of IDs

  [455632, 649189, 455632, 649189]

and accessions

  ["gi|182438931", "gi|282872348", "gi|178467447", "gi|282574201"]

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
accession | is the primary accession
dbIdx | is the 1 based database ID
gpt_ids | the taxonomy IDs
gpt_accessions | the list of accessions

◆ getProteinThreshold()

int getProteinThreshold ( double OneInXprobRnd ) const
virtualinherited

Return a threshold value for the protein summary report.

This is simply calculated by using:

   10.0 * log10(seqsAfterTax * OneInXprobRnd)

where seqsAfterTax is obtained from ms_mascotresfilebase::getNumSeqsAfterTax().

The threshold value is displayed at the top of the protein summary report: Protein scores greater than 72 are significant (p<0.05).

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns
The protein threshold.

◆ getQmatch() [1/2]

int getQmatch ( const int query ) const
virtualinherited

[Deprecated] Return the number of peptides with masses that matched this query.

Deprecated:
This method is deprecated in favour of ms_mascotresfilebase::getQmatch
See also
getPeptideIdentityThreshold()
Note
This method only works with dat28 (.dat) results files. The value returned with MSR files is undefined.

If the value is greater than INT_MAX, then INT_MAX will be returned.

This function calls the getQmatch(query, section) function with the 'relevant' section which will normally be SEC_SUMMARY.

If the MSRES_DECOY flag was specified in the constructor, then the 'relevant' section will be SEC_DECOYSUMMARY. If the search is an error tolerant search, then the 'relevant' section will be SEC_ERRTOLPEPTIDES, and analogously for crosslinked searches (SEC_CROSSLINK_PEPTIDES).

However, to get the spectral library qmatch values, it is necessary to explicitly call: getQmatch(query, ms_mascotresfile_dat::SEC_LIBRARYSUMMARY)

Parameters
query Specifies the query number. This should be in the range 1 .. ms_mascotresfile_dat::getNumQueries().
Returns
the number of peptides with masses that matched this query

◆ getQmatch() [2/2]

int getQmatch | ( | const int | query,
 |  | const ms_mascotresfile_dat::section | sec
 | ) |  | const
 virtualinherited

[Deprecated] Use ms_mascotresfilebase::getQmatch().

Deprecated:
This method is deprecated in favour of ms_mascotresfilebase::getQmatch

If the value is greater than INT_MAX, then INT_MAX will be returned.

Note
This method only works with dat28 (.dat) results files. The value returned with MSR files is undefined.
Parameters
query Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
sec is the section number and can be one of:
  • ms_mascotresfile_dat::SEC_SUMMARY
  • ms_mascotresfile_dat::SEC_DECOYSUMMARY
  • ms_mascotresfile_dat::SEC_ERRTOLSUMMARY
  • ms_mascotresfile_dat::SEC_ERRTOLDECOYSUMMARY
  • ms_mascotresfile_dat::SEC_LIBRARYSUMMARY
  • ms_mascotresfile_dat::SEC_CROSSLINK_SUMMARY
Returns
the number of peptides with masses that matched this query. If the specified sec doesn't exist, then 0 will be returned.

◆ getQuantitationComponentForPeptide()

ms_mascotresults::QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide | ( | const ms_peptide & | peptide,
 |  | matrix_science::ms_quant_component & | component,
 |  | const ms_quant_method * | method = NULL
 | ) |  | const
 virtual

Get the component in the quantitation method that matches the peptide.

If the component name has already been determined (see ms_peptide::getComponentStr()) then that component is retrieved from the method.

If the component name has not yet been determined for the peptide, each component in the method is checked in turn to determine if it is the correct component for the peptide (see ms_peptidesummary::isPeptideComponentMatch()). A component only matches the peptide if every modification group of the component matches the peptide.

This is only applicable if there is a quantitation method, the method uses the Precursor protocol and the method has components defined. If an error occurs then an error message is appended to the matrix_science::ms_mascotresfilebase and a matching status code is returned.

Parameters
peptide | The peptide to find the component for.
component | This is set to the first matching component found, if any.
method | An optional parameter that overrides the quantitation method used to look for matching components. If no method is specified here then the method from the ms_mascotresfilebase is used.
Returns
One of the return status codes in ms_mascotresults::QUANT_COMPONENT_STATUS.

Implements ms_mascotresults.

◆ getQuantMethod()

const matrix_science::ms_quant_method * getQuantMethod ( ) const

Returns the quantitation method from the results file.

Returns
The quantitation method from the ms_mascotresfilebase object if any, otherwise 0.

◆ getQueryList()

std::string getQueryList | ( | QL_FLAG | flag,
 |  | bool | outputListOfQueries = true
 | ) |  |

Returns a list of query numbers that can be used for a repeat search.

The list returned by this function should be used as the querylist parameter in a repeat search in Mascot 2.3 or later.

Parameters
flag | See the ms_peptidesummary::QL_FLAG definition for a description of the different values.
outputListOfQueries | is used to specify whether a comma separated list of values is returned, or an encoded short string that will be interpreted by nph-mascot. Setting this value to false is not supported in Mascot 2.3.
Returns
A string that can be used for the querylist value when repeating a search.

◆ getReadableVarMods()

std::string getReadableVarMods | ( | const int | q,
 |  | const int | p,
 |  | const int | numDecimalPlaces = 2,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const
 virtualinherited

Return a 'human readable' string with the variable, summed and error tolerant mods.

This function creates a string of the form

2 Oxidation (M); Phosphorylation (ST)

It works by getting the variable mods string, e.g. 0110030, using ms_peptide::getVarModsStr(). It then converts the string to a human readable form. Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W.

This function will work whether or not there are variable and/or error tolerant mods, and can be called for either the peptide or the protein summary. Variable modification names are obtained using ms_searchparams::getVarModsName() and error tolerant modification names are found using ms_mascotresults::getErrTolModName(). Library modification names, in peptide summary, are found using ms_searchparams::getLibraryModName(). See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Error tolerant mods are shown with the delta in square brackets after the modification or substitution. For example:

   R->G [-99.08]

The delta is shown to numDecimalPlaces.

If the match is an intact crosslinked match, the returned string contains a short description of the linked sites and what they are linked with. For example:

   Xlink:DSS (K) in alpha crosslinked with Xlink:DSS (K) in beta

Use ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA as the psmComponent argument to inspect the alpha and beta mods separately. In this case, the intact linker is described like "intact Xlink:DSS (K)".

Summed mods, from ms_peptide::getSummedModsStr(), and query-level mods, from ms_peptide::getLocalModsStr(), are also included in the returned string.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10.
numDecimalPlaces | (optional) Used for the display of modification deltas.
psmComponent | (optional) Either ms_peptide::PSM_COMPLETE for the match as a whole, or ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA to get components of a crosslinked match.
Returns
The formatted string.
Examples
resfile_summary.cpp.

◆ getResultsParameters()

ms_mascotresults_params getResultsParameters ( ) const
inherited

Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.

Returns
An ms_mascotresults_params object containing the parameter and flag values used to generate the report.

◆ getSequenceMass()

double getSequenceMass ( const char * seq ) const
inherited

Return the mass of a sequence (protein or peptide).

The sequence mass is calculated by summing the mass of each residue, using ms_searchparams::getResidueMass, and adding terminus masses using ms_searchparams::getCTermMass and ms_searchparams::getNTermMass.

The mass is therefore the 'Mr' (uncharged) mass, and is calculated using any static modifications.

Parameters
seq is the protein sequence.
Returns
The relative mass of the sequence.

◆ getSLThresholdFromMinProbability()

double getSLThresholdFromMinProbability ( double minProbability )
static

Return the library score threshold in SL-only mode corresponding to the given value of minProbability.

This is the inverse of getMinProbabilityForSLScore(). Note that due to how library scores are converted to expect values, the minimum value returned by this function is 170, for minProbability >= 1.0.

Parameters
minProbability between 0 (exclusive) and 1 (exclusive).
Returns
score The library score threshold.

◆ getSrcRank()

int getSrcRank | ( | int | q,
 |  | int | p
 | ) |  | const

Returns the 'source' rank for a given peptide match.

Deprecated:
This method is only useful with files in dat28 format.

Mascot normally saves up to 10 peptide matches per query. These are the top 10 ranks. In integrated reports of more complex searches, matches are merged at query level. There may be up to 20 matches per query.

There are several kinds of integrated report:

  • ms_mascotresults::MSRES_INTEGRATED_ERR_TOL - integrated error tolerant search.
  • ms_peptidesummary::MSPEPSUM_SL_INTEGRATED - integrated spectral library search.
  • ms_peptidesummary::MSPEPSUM_CROSSLINK_INTEGRATED - integrated report of a crosslink search.

For example, when ms_mascotresults::MSRES_INTEGRATED_ERR_TOL is specified for an integrated error tolerant search (see Integrated error tolerant search), the peptide matches from the first and second passes are combined in each query. ms_peptide::getRank() or ms_protein::getPeptideP() will return a number in the range 1 to 20. This rank value can be used for any ms_peptidesummary function that requires a 'p' (rank) value.

In dat28 format, if you want to access data directly from the results file using functions like me_mascotresfile_dat::getQuerySectionValueStr(), then you need to call this function and getSrcSection() to determine which entry to retrieve.

If integrated reporting is not active, then this function simply returns the argument p.

Parameters
q | is the query number.
p | is the rank number.
Returns
the source rank number in the results file.

◆ getSrcSection()

ms_mascotresfile_dat::section getSrcSection | ( | int | q,
 |  | int | p
 | ) |  | const

Returns the 'source' section for a given peptide match.

Deprecated:
This method is only useful with files in dat28 format.

Mascot normally saves up to 10 peptide matches per query. These are the top 10 ranks. In integrated reports of more complex searches, matches are merged at query level. There may be up to 20 matches per query.

There are several kinds of integrated report:

  • ms_mascotresults::MSRES_INTEGRATED_ERR_TOL - integrated error tolerant search.
  • ms_peptidesummary::MSPEPSUM_SL_INTEGRATED - integrated spectral library search.
  • ms_peptidesummary::MSPEPSUM_CROSSLINK_INTEGRATED - integrated report of a crosslink search.

This function returns the peptide section that the peptide, specified by q and p, is obtained from. It will be one of:

  • ms_mascotresfile_dat::SEC_PEPTIDES
  • ms_mascotresfile_dat::SEC_DECOYPEPTIDES
  • ms_mascotresfile_dat::SEC_ERRTOLPEPTIDES
  • ms_mascotresfile_dat::SEC_ERRTOLDECOYPEPTIDES
  • ms_mascotresfile_dat::SEC_LIBRARYPEPTIDES
  • ms_mascotresfile_dat::SEC_CROSSLINK_PEPTIDES

For example, when ms_mascotresults::MSRES_INTEGRATED_ERR_TOL is specified for an integrated error tolerant search (see Integrated error tolerant search), the results from the ms_mascotresfile_dat::SEC_PEPTIDES and ms_mascotresfile_dat::SEC_ERRTOLPEPTIDES sections are combined at the query level, so there will be up to 20 matches for each query. ms_peptide::getRank() or ms_protein::getPeptideP() will therefore return a number in the range 1 to 20. This rank value can be used for any ms_peptidesummary function that requires a 'p' (rank) value. If you want to access data directly from the results file using functions like me_mascotresfile_dat::getQuerySectionValueStr(), then you need to call this function and getSrcRank() to determine which entry to retrieve.

Parameters
q | is the query number.
p | is the rank number.
Returns
the section in the results file.

◆ getTagDeltaRangeEnd()

int getTagDeltaRangeEnd | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the second number from q1_p2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
the second number from the string or -1 if there is no tag match.

Implements ms_mascotresults.

◆ getTagDeltaRangeStart()

int getTagDeltaRangeStart | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the first number from q1_p2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
the first number from the string or -1 if there is no tag match.

Implements ms_mascotresults.

◆ getTagEnd()

int getTagEnd | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const
 virtualinherited

Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also
getTagStart(), getTagSeries()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns
The residue end position of the tag.
Examples
resfile_summary.cpp.

◆ getTagSeries()

int getTagSeries | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const
 virtualinherited

Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also
getTagStart(), getTagEnd()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns
The series that contained a match to the tag. Possible ion series numbers are
  • -1 means no matches for the tag
  • 0 "a" series (single charge)
  • 1 "a-NH3" series (single charge)
  • 2 "a" series (double charge)
  • 3 "b" series (single charge)
  • 4 "b-NH3" series (single charge)
  • 5 "b" series (double charge)
  • 6 "y" series (single charge)
  • 7 "y-NH3" series (single charge)
  • 8 "y" series (double charge)
  • 9 "c" series (single charge)
  • 10 "c" series (double charge)
  • 11 "x" series (single charge)
  • 12 "x" series (double charge)
  • 13 "z" series (single charge)
  • 14 "z" series (double charge)
  • 15 "a-H2O" series (single charge)
  • 16 "a-H2O" series (double charge)
  • 17 "b-H2O" series (single charge)
  • 18 "b-H2O" series (double charge)
  • 19 "y-H2O" series (single charge)
  • 20 "y-H2O" series (double charge)
  • 21 "a-NH3" series (double charge)
  • 22 "b-NH3" series (double charge)
  • 23 "y-NH3" series (double charge)
  • 25 "internal yb" series (single charge)
  • 26 "internal ya" series (single charge)
  • 27 "z+1" series (single charge)
  • 28 "z+1" series (double charge)
  • 29 high-enrgy "d" and "d'" series (single charge)
  • 31 high-enrgy "v" series (single charge)
  • 32 high-enrgy "w" and "w'" series (single charge)
  • 33 "z+2" series (single charge)
  • 34 "z+2" series (double charge)
Examples
resfile_summary.cpp.

◆ getTagStart()

int getTagStart | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const
 virtualinherited

Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also
getTagEnd(), getTagSeries()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns
The residue start position of the tag.
Examples
resfile_summary.cpp.

◆ getTagString()

std::string getTagString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete tag string from q1_p1_tag.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_tag might be
       q1_p2_tag=1:10:12:6,3:1:12:1,...
  • The entry in h1_q2_tag might be
       h1_q2_tag=1:10:12:6,3:1:12:1,...

This function returns the complete string value. Every group of four numbers between commas is tagNumber:startPos:endPos:series.

More useful functions are

  • ms_mascotresults::getTagStart(),
  • ms_mascotresults::getTagEnd() and
  • ms_mascotresults::getTagSeries(),

all of which will work for both the protein summary and the peptide summary.

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete tag string.

Implements ms_mascotresults.

◆ getTerminalResiduesString()

std::string getTerminalResiduesString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const
 virtual

Return the complete terminal residue string from q1_p1_terms.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in the results file might be
       q1_p2_terms=-,A:K,I:-,-:Q,-:@,R:...
  • The entry in the results file might be
       h1_q2_terms=A,Q

This function returns the complete string value. More useful functions are ms_protein::getPeptideResidueBefore() and ms_protein::getPeptideResidueAfter(), which will work for both the protein summary and the peptide summary.

ms_peptidesummary only: For a crosslinked match, the results file line is q1_p1_terms_1= or q1_p1_terms_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns
the full terminal residues string.

Implements ms_mascotresults.

◆ getThresholdForFDRAboveHomology() [1/2]

bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |
inherited

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFDRAboveHomology(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getThresholdForFDRAboveHomology() [2/2]

bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |
inherited

Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.

For example, to find out which probability threshold gives 1% FDR above identity or homology threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the * minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveHomology() and getNumDecoyHitsAboveHomology().

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

Otherwise functionality is the same as getThresholdForFDRAboveIdentity(double, double*, double*, int*, int*).

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getThresholdForFDRAboveIdentity() [1/2]

bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |
inherited

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFDRAboveIdentity(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getThresholdForFDRAboveIdentity() [2/2]

bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |
inherited

Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.

For example, to find out which probability threshold gives 1% FDR above identity threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveIdentity() and getNumDecoyHitsAboveIdentity().

The function returns a value that maximises the number of peptide-spectrum matches while giving an FDR below the targetFDR value. In some cases, it would be possible to get an FDR closer to the supplied targetFDR, but with fewer target matches.

For a large file, this function can take some time to return. Feedback can be obtained by using ms_mascotresfilebase::outputKeepAlive with the fd= tag.

This function was first introduced in version 2.4.0 and the method for calculating the value was changed between version 2.4.0 and 2.4.1.

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If this function returns false, there are several possibilities:

  • The function is being called for a ms_proteinsummary object
  • The supplied targetFDR is 0, or negative
  • It is not possible to get an FDR less than the targetFDR. In this case, the lowest possible FDR is given
  • The function is being called for an error tolerant search

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getToleranceInDalton()

double getToleranceInDalton | ( | bool & | needMass,
 |  | const double *const | pMass = NULL
 | ) |  | const
 inherited

Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.

Returns the tolerance of the result file in dalton.

Parameters
needMass | Reference to a boolean to determine if the mass is needed to calculate the delta, namely when the tolerance unit is in % or ppm
pMass | Optional parameter to calculate the tolerance from the mass for % and ppm
Returns
The tolerance in dalton

◆ getTreeClusterNodes()

bool getTreeClusterNodes | ( | const int | hit,
 |  | std::vector< int > & | left,
 |  | std::vector< int > & | right,
 |  | std::vector< double > & | distance,
 |  | ms_mascotresults::TREE_CLUSTER_METHOD | tcm = ms_mascotresults::TCM_PAIRWISE_MAXIMUM,
 |  | double *** | reserved1 = 0,
 |  | unsigned int * | reserved2 = 0
 | ) |  | const
 virtual

Return distances and structure suitable for a dendrogram plot.

The 'distances' between each protein in the family are calculated using a tree clustering routine which, by default, implements pairwise maximum (or complete) linkage clustering. It is used for the dendrogram display in the reports introduced in Mascot 2.3.

The vectors returned by this function only contain values when MSRES_CLUSTER_PROTEINS has been specified and where there are at least two family members.

The code uses the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/

The License agreement for using this excellent Open Source code is included with Mascot Parser; see C Clustering library.

A value of 0 returned in the left or right vector corresponds to the lead protein as returned by getHit(). To find the protein associated with a positive node value returned in the left or right vector, call getNextFamilyProtein() with the id value set to the value in the vector.

The distances passed to the cluster algorithm are calculated by determining which peptides need to be excluded to make one protein a subset of another. Each unique peptide sequence is considered in turn, and the distance is calculated by taking the maximum difference between the score and the value returned by getPeptideThreshold(). Additionally, where a query has matches to different peptides above threshold in each protein, the delta of the scores is added to the distance.

For details of how to use the left, right and distance parameters, see Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
hit | is the hit number for the lead protein.
left | returns a vector of 'left' values.
right | returns a vector of 'right' values.
distance | returns a vector of 'distance' values.
tcm | is the method to be used. See documentation referenced above
reserved1 | is for Matrix Science use only
reserved2 | is for Matrix Science use only
Returns
true unless the code causes an out of memory error.

Reimplemented from ms_mascotresults.

◆ getUnassigned()

ms_peptide getUnassigned ( const int num ) const
inherited

Need to call createUnassignedList() before calling this.

See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_errs::ERR_UNASSIGNED_PROG will be set, and this function will return an empty ms_peptide.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
num Must be in the range 1..getNumberOfUnassigned().
Returns
If num is outside the range ..getNumberOfUnassigned(), then an error ms_errs::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.
Examples
resfile_summary.cpp.

◆ getUnassignedIsBold()

bool getUnassignedIsBold ( const int num ) const
inherited

Returns true if the item indexed by num in the assigned list should be bold.

This function returns true if this peptide should be displayed in bold in a Mascot report. Bold is used for the first time a query is shown in a report. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_errs::ERR_UNASSIGNED_PROG will be set, and this function will return true.

Parameters
num Must be in the range 1..getNumberOfUnassigned().
Returns
If num is outside the range ..getNumberOfUnassigned(), then an error ms_errs::ERR_UNASSIGNED_RANGE will be set, and this function will return true.

◆ getUnassignedShowCheckbox()

bool getUnassignedShowCheckbox ( const int num ) const
inherited

Returns true if the item indexed by num in the assigned list should have a check box next to it.

A check box is displayed if this is the first rank 1 match that has been displayed for this query. See also ms_peptide::getRank() and ms_peptide::getPrettyRank().

By definition, all unassigned queries will need a check box. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_errs::ERR_UNASSIGNED_PROG will be set, and this function will return false.

Parameters
num Must be in the range 1..getNumberOfUnassigned().
Returns
If num is outside the range ..getNumberOfUnassigned(), then an error ms_errs::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.

◆ hasCrosslinkingMethod()

bool hasCrosslinkingMethod ( ) const

Returns true if the results file has a crosslinking method.

Returns
True if there is crosslinking method, otherwise false.

◆ hasQuantMethod()

bool hasQuantMethod ( ) const

Returns true if the results file has a quantitation method.

Returns
True if there is quantitation method, otherwise false.

◆ isDataCached()

bool isDataCached ( ms_peptidesummary::BUGFIX_NUM bugNum ) const

If caching is in use and the cache file exists, it may have been created with a previous version of Parser. Parser does not always recreate the cache file when new features are added, which means that if newer versions would save more data in the cache file, some of this data may need to be computed on the fly when using an old cache file.

If caching is in use and the cache file contains data relevant to bugNum, the method returns true. Otherwise it returns false. If caching is not in use, the method always returns true, as the data related to the given bug number will always be computed on the fly.

See also Caching Mascot Results.

Parameters
bugNum Bug number of the relevant feature or bugfix.
Returns
True if data related to the bug number is available in the cache file or if caching is not in use. False otherwise.

◆ isEmPAIallowed()

bool isEmPAIallowed ( ) const
inherited

Return true if emPAI could be calculated using data in this results file.

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns
true if emPAI is allowed.

◆ isNA()

bool isNA ( ) const
inherited

Returns TRUE for a search against a nucelic acid database.

There is no specific information in the results file for this. It is implemented by looking to see if there is a frame number that is non-zero in any result. If there are no matches to any query, then this method will return false and therefore may be wrong. (However, if there are no matches then it is unlikely that the outcome of this function is important!)

In versions prior to 2.3.01, this was determined by looking in protein matches. In version 2.3.01 and later, this is determined by looking in all peptide matches, regardless of score.

Returns
True if the search was against a nucleic acid database.

◆ isPeptideUnique()

bool isPeptideUnique | ( | const int | q,
 |  | const int | p,
 |  | const UNIQUE_PEP_RULES | rules = UPR_DEFAULT
 | ) |  | const
 virtual

Returns true if this peptide match is unique to one protein or one protein family.

Note
This function currently returns false for ms_proteinsummary. This function is only likely to be useful for a peptide summary.

This function is used, for example, in quantitation to only report ratios for peptide sequences that are unique to one protein hit. This can be specified as part of a Mascot quantitation method; see ms_quant_quality::isUniquePepseq().

No attempt is made to collapse peptides that just differ by, for example, I or L.

The specified q and p values must be for a peptide that has a protein match in the current report, i.e. not in the unassigned list. The function searches all proteins and not just those in the current report. For example, if peptide 'ABCDEFK' appears in protein hit one and protein hit 100, then it will return false even if only the top 10 hits have been requested.

If grouping is not selected when creating the ms_peptidesummary, (i.e. neither ms_mascotresults::MSRES_GROUP_PROTEINS nor ms_mascotresults::MSRES_CLUSTER_PROTEINS), then it is likely that this function will return false for most peptides.

At version 2.3, this function did not have the optional third parameter and the default value was the same as using ms_mascotresults::UPR_WITHIN_FAMILY, which is not the default value in version 2.4 and later. At version 2.3, the function would therefore return true for all peptides with a score above the homology threshold when ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified.

Parameters
q | is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the * range 1 to 50.
rules | should passed appropriate ms_mascotresults::UNIQUE_PEP_RULES flags to specify what rules are to be used for considerering when a peptide is unique.
Returns
true if the peptide match is unique. Always false in ms_proteinsummary.

Implements ms_mascotresults.

◆ mascotresfile()

const ms_mascotresfilebase & mascotresfile ( ) const

Return the attached results file.

Returns
The ms_mascotresfilebase object passed in the constructor.

◆ setSubsetsThreshold()

void setSubsetsThreshold ( const double scoreFraction )
virtualinherited

Specifies which subset proteins should be reported.

If you have a primary hit with (say) 100 peptide matches, you are very interested in sub-set proteins with 99 matches but not if they only have 1 or 2 matches. These are the sub-set hits that clutter up the report if Show Sub-sets is checked in Mascot 2.1 and earlier. If you have a primary hit with (say) 2 peptide matches, you are more likely to be interested in sub-set proteins with just 1 match.

A scoreFraction of 1 indicates that all proteins with a subset of matches should be reported. A value of 0 indicates that no subsets will be reported. The flag MSRES_SHOW_SUBSETS must have been specified if a value > 0 is used, or no subsets will be shown.

See also
getNextSubsetProtein(), getNextSubsetProteinOf()
Parameters
scoreFraction is the fractional score required for a protein to be counted as a subset. Its score must be greater than or equal to main_protein_score * (1-scoreFraction). The default value is 1.0.

◆ willCreateCache() [1/4]

bool willCreateCache | ( | const char * | resultsFileName,
 |  | const ms_mascotoptions & | opts,
 |  | const char * | unigeneIndexFile,
 |  | const char * | singleHit,
 |  | const char * | applicationName,
 |  | std::string & | resfileCacheFileName,
 |  | std::string & | peptideSummaryCacheFileName,
 |  | unsigned int & | cacheStatus
 | ) |  |
static

[Deprecated] Returns true if either cache file will be created when the ms_mascotresfilebase and ms_peptidesummary_dat objects are created

Note
This method is deprecated in favour of calling ms_mascotresfilebase::willCreateCache(const char*, const ms_mascotoptions&, const char *, std::string &, unsigned int&) then populating a ms_mascotoptions object, a ms_mascotresults_params object, and calling willCreateCache(const ms_mascotresfilebase&, const ms_mascotresults_params&, const ms_mascotoptions&, std::string&, unsigned int&) All new code should use the new methods.

This static function can be called without creating an ms_mascotresfilebase or an ms_peptidesummary object. It can be used in advance of creating the object to see if there will be a delay while (re)creating the cache file(s). The function has the some of the same parameters as the ms_peptidesummary constructor, but takes a pointer to the options section of the mascot.dat file which will have the default parameters for reports.

The function may be more convenient than calling ms_mascotresfilebase::willCreateCache and then creating an ms_mascotresfilebase object and then calling the other willCreateCache

See Multiple return values in Perl, Java, Python and C#

See Static functions in Perl, Java, Python and C#

Parameters
[in] | resultsFileName | is the absolute or relative path to the Fxxxxx.dat file
[in] | opts | normally loaded from the mascot.dat file using ms_datfile::getMascotOptions()
[in] | unigeneIndexFile | See ms_peptidesummary::ms_peptidesummary
[in] | singleHit | See ms_peptidesummary::ms_peptidesummary
[in] | applicationName | is the name of the application or script that is calling this function. The applicationName is searched for in the return value from ms_mascotoptions::getResultsCache and ms_mascotoptions::getResfileCache to determine if the application should be using cache files. If it is not found then the function returns false and sets the cacheStatus to ms_peptidesummary::RESFILE_CACHE_DISABLED_IN_OPTIONS and/or ms_peptidesummary::PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS. If null, or an empty string is passed, no check is made.
[out] | resfileCacheFileName | returns the name of the ms_mascotresfilebase cache file if one exists or would be created
[out] | peptideSummaryCacheFileName | returns the name of the ms_peptidesummary cache file if one exists or would be created
[out] | cacheStatus | is the ms_peptidesummary::CACHE_STATUS enumeration which gives more details about why the cache file may or may not be created. Multiple values may be bitwise OR'd toegether.
Returns
true if either of the cache files will be (re-)created because they does not exist or are not complete or not up to date. It will return false if the options specify that the applicationName shouldn't create or use cache files.

◆ willCreateCache() [2/4]

bool willCreateCache | ( | const ms_mascotresfilebase & | resfile,
 |  | const ms_mascotresults_params & | parameters
 | ) |  |
static

Returns true if a cache file will be created when the ms_peptidesummary_dat constructor is called.

This static function can be called without creating an ms_peptidesummary object, and can be used in advance of creating an object to see if there will be a delay while (re)creating a cache file. The function has the exact same parameters as the ms_peptidesummary constructor – see the documentation for ms_peptidesummary::ms_peptidesummary for details.

Parameters
resfile | – see ms_peptidesummary::ms_peptidesummary
parameters | – see ms_peptidesummary::ms_peptidesummary
Returns
true if the cache file will be (re-)created because it does not exist or is not complete or not up to date. If the MSPEPSUM_USE_CACHE flag has not been specified, it will always return false.

◆ willCreateCache() [3/4]

bool willCreateCache | ( | const ms_mascotresfilebase & | resfile,
 |  | const ms_mascotresults_params & | parameters,
 |  | const ms_mascotoptions & | opts,
 |  | std::string & | peptideSummaryCacheFileName,
 |  | unsigned int & | cacheStatus
 | ) |  |
static

Returns true if either cache file will be created when the ms_mascotresfilebase and ms_peptidesummary_dat objects are created.

This static function can be called without creating an ms_peptidesummary object. It can be used in advance of creating the object to see if there will be a delay while (re)creating the cache file(s).

The purpose of this method is to be able to provide a ms_mascotresults_params object as well as to get the status of the cache.

See Multiple return values in Perl, Java, Python and C#

See Static functions in Perl, Java, Python and C#

Parameters
[in] | resfile | – see ms_peptidesummary::ms_peptidesummary
[in] | parameters | – see ms_peptidesummary::ms_peptidesummary
[in] | opts | normally loaded from the mascot.dat file using ms_datfile::getMascotOptions()
[out] | peptideSummaryCacheFileName | returns the name of the ms_peptidesummary cache file if one exists or would be created
[out] | cacheStatus | is the ms_peptidesummary::CACHE_STATUS enumeration which gives more details about why the cache file may or may not be created. Multiple values may be bitwise OR'd toegether.
Returns
true if the ms_peptidesummary cache file will be (re-)created because it does not exist or is not complete or not up to date.

◆ willCreateCache() [4/4]

bool willCreateCache | ( | const ms_mascotresfilebase & | resfile,
 |  | const unsigned int | flags = ms_mascotresults::MSRES_GROUP_PROTEINS,
 |  | double | minProbability = 0.0,
 |  | int | maxHitsToReport = 50,
 |  | const char * | unigeneIndexFile = 0,
 |  | double | ignoreIonsScoreBelow = 0.0,
 |  | int | minPepLenInPepSummary = 0,
 |  | const char * | singleHit = 0,
 |  | const unsigned int | flags2 = MSPEPSUM_NONE
 | ) |  |
static

[Deprecated] Returns true if a cache file will be created when the ms_peptidesummary_dat constructor is called.

Note
This method is deprecated in favour of willCreateCache(const ms_mascotresfilebase&, const ms_mascotresults_params&). All new code should use the new method.

This static function can be called without creating an ms_peptidesummary object, and can be used in advance of creating an object to see if there will be a delay while (re)creating a cache file. The function has the exact same parameters as the ms_peptidesummary constructor – see the documentation for ms_peptidesummary::ms_peptidesummary for details.

Parameters
resfile | – see ms_peptidesummary::ms_peptidesummary
flags | – see ms_peptidesummary::ms_peptidesummary
minProbability | – see ms_peptidesummary::ms_peptidesummary
maxHitsToReport | – see ms_peptidesummary::ms_peptidesummary
unigeneIndexFile | – see ms_peptidesummary::ms_peptidesummary
ignoreIonsScoreBelow | – see ms_peptidesummary::ms_peptidesummary
minPepLenInPepSummary | – see ms_peptidesummary::ms_peptidesummary
singleHit | – see ms_peptidesummary::ms_peptidesummary
flags2 | – see ms_peptidesummary::ms_peptidesummary
Returns
true if the cache file will be (re-)created because it does not exist or is not complete or not up to date. If the MSPEPSUM_USE_CACHE flag has not been specified, it will always return false.
The documentation for this class was generated from the following files:
  • ms_peptidesummary.hpp
  • ms_peptidesummary.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_protein Class Reference

  • matrix_science
  • ms_protein
Public Types | Public Member Functions | Friends | List of all members
ms_protein Class Reference
Mascot results file module

This class encapsulates a protein in the mascot results file. More...

#include <ms_protein.hpp>

Public Types

enum DISTINCT_PEPTIDE_FLAGS {
DPF_SEQUENCE = 0x0001 ,
DPF_CHARGE = 0x0002 ,
DPF_MODS = 0x0004 ,
DPF_UNIQUE = 0x0008 ,
DPF_NODUPSAMEQUERY = 0x0010
}
Enum for getNumDistinctPeptides(). More...
enum DUPLICATE {
DUPE_NotDuplicate ,
DUPE_Duplicate ,
DUPE_DuplicateSameQuery ,
DUPE_HighestScoringDuplicate ,
DUPE_Ignored
}
Enum for the each peptide in the protein to indicate if it is a duplicate. More...
enum GROUP {
GROUP_UNKNOWN ,
GROUP_NO ,
GROUP_SUBSET ,
GROUP_COMPLETE ,
GROUP_FAMILY
}
Enum to say if a protein is similar to another higher scoring protein. More...
enum MASS_FLAGS {
MASS_NON_SELECT_NON_MATCH = 0x0001 ,
MASS_SELECT_NON_MATCH = 0x0010 ,
MASS_NON_SELECT_MATCH = 0x0100 ,
MASS_SELECT_MATCH = 0x1000
}
enum for each protein to specify what masses to select. More...

Public Member Functions

ms_protein (const double score, const std::string accession, const bool updateScoreFromPepScores, const int proteinSummaryHit=0)
Constructors - used from ms_proteinsummary and ms_peptidesummary.
ms_protein (const ms_protein &src)
Copying constructor.
~ms_protein ()
Destructor - called automatically - don't call explicitly from Perl or Java.
bool | anyBoldRedPeptides (const ms_mascotresults &results) const
Returns true if any of the peptides in the match were top scoring and not seen before.
bool | anyMatchToQuery (const int query) const
See if any match to this query.
bool | anyMatchToQueryAndP (const int query, const int P) const
See if any match to this query and 'P' (rank / hit).
void | copyFrom (const ms_protein *src)
Copies all content from another instance of the class.
std::string | getAccession () const
Return the accession string for a protein.
const ms_protein * | getComponent (const int componentNumber) const
For UniGene and PMF mixture return the 'component' protein.
long | getCoverage () const
Return the number of residues covered.
int | getDB () const
Return the index of the database where the sequence is found.
ms_peptide | getDistinctPeptide (int distinctIndex, int repeatIndex=1, bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const
Return the peptide repeat of the distinct peptide in the protein's peptide matches.
int | getFrame () const
Returns the frame number for the protein.
GROUP | getGrouping () const
Returns a flag which shows if this protein only contain the same peptides as those in another protein.
int | getHitNumber () const
Returns the hit number in the results list.
void | getIgnoredQPs (std::vector< int > &q, std::vector< int > &p) const
Return a list of queries and ranks that would have been part of this protein hit had they not been removed by IgnoreIonsScoreBelow.
int | getLongestPeptideLen () const
Return the length (in residues) of the longest peptide in the protein.
int | getLongestSigPeptideLen () const
Return the length (in residues) of the longest significant peptide in the protein.
std::string | getMasses (ms_mascotresfilebase &resfile, const ms_proteinsummary &summary, const unsigned int flags=MASS_SELECT_MATCH, const int numDecimalPlaces=2) const
Return a list of comma separated experimental masses according to a specified filter.
int | getMemberNumber () const
Returns the member number within a family in the results list.
double | getNonMudpitScore () const
Will only return a different score from getScore() if the MSRES_MUDPIT_PROTEIN_SCORE flag has been specified.
int | getNumComponents () const
For UniGene and PMF mixture, return number of 'component' proteins.
int | getNumDisplayPeptides (bool aboveThreshold=false) const
Return the number of peptides excluding those that with duplicate matches to same query.
int | getNumDistinctPeptideRepeats (int distinctIndex, bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const
Return the number of repeats of the distinct peptide in the protein's peptide matches.
int | getNumDistinctPeptides (bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const
Return the number of distinct peptides in the protein sequence.
int | getNumObservedForEmPAI () const
Return the number of peptides 'observed' for emPAI quantitation calculation.
int | getNumPeptides () const
Return the number of peptides that had a match in this protein.
int | getPepNumber (const int q, const int p) const
Return the pepNumber given query and rank.
int | getPeptideComponentID (const int pepNumber) const
Returns 0 except for a UniGene entry or a PMF mixture entry.
DUPLICATE | getPeptideDuplicate (const int pepNumber, const bool allowErrTolDuplicate=true) const
Return the DUPLICATE status given the peptide 'number'.
long | getPeptideEnd (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the peptide end residue given the peptide 'number'.
int | getPeptideFrame (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the frame number given the peptide 'number'.
double | getPeptideIonsScore (const int pepNumber) const
Return the ions score within this protein context given the peptide 'number'.
bool | getPeptideIsBold (const int pepNumber) const
Returns true if this peptide should be displayed in bold in a Mascot report.
long | getPeptideMultiplicity (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the number of precursor matches in this protein for the specified peptide 'number'.
int | getPeptideP (const int pepNumber) const
Return the 'rank' number given the peptide 'number'.
int | getPeptideQuery (const int pepNumber) const
Return the query number given the peptide 'number'.
char | getPeptideResidueAfter (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Returns the residue immediately after the peptide.
char | getPeptideResidueBefore (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Returns the residue immediately before the peptide.
bool | getPeptideShowCheckbox (const int pepNumber) const
Returns true if a check box for repeat searches should be shown in a Mascot report.
long | getPeptideStart (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the peptide start residue given the peptide 'number'.
int64_t | getProteinId () const
Return the protein id.
int | getProteinSummaryHit () const
For a protein from the protein summary only.
double | getRMSDeltas (const ms_mascotresults &results) const
Return the RMS value of the deltas between the calculated and experimental value.
double | getScore () const
Return the protein score for this protein.
double | getScoreWithET () const
Return the protein score including ET matches for this protein.
int | getSimilarProteinDB () const
Return the database index of a protein that contains the same set (or a superset of) of the peptides in this protein.
std::string | getSimilarProteinName () const
Return the accession of a protein that contains the same set (or a superset of) of the peptides in this protein.
int | getSimilarProteins (std::vector< std::string > &accessions, std::vector< int > &dbIdxs) const
Return a list of proteins that that contains the same set (or a superset of) of the peptides in this protein.
std::string | getUnmatchedMasses (ms_mascotresfilebase &resfile, const int numDecimalPlaces=2) const
Return a list of comma separated experimental masses that don't match.
bool | isASimilarProtein (const ms_protein *prot, const ms_mascotresults *results, const bool groupByQueryNumber=false)
Find a protein in the results.
bool | isPMFMixture () const
Returns true if the 'protein' is actually a PMF mixture.
bool | isSimilarProtein (const std::string &acc, const int dbIdx) const
Returns true if the specified protein has the sameset or a superset of peptides that this protein has.
bool | isUnigene () const
Returns true if the 'protein' is actually a UniGene entry.
bool | isUpdateScoreFromPepScores () const
\ Returns true if protein score is updated from peptides
ms_protein & | operator= (const ms_protein &right)
C++ assignment operator.
void | setDB (int dbIdx)
Set database index.
void | setPeptideIsBold (const int pepNumber)
void | setPeptideShowCheckbox (const int pepNumber)
void | setProteinId (int64_t proteinId)
Set Protein id.
void | sortPeptides (const ms_mascotresults &results, bool keepAlive=false, int keepAlivePercent=0, const char *keepAliveAccession="", int keepAliveCount=0)
Sorts the peptides into ascending query number.

Friends

bool operator< (const ms_protein &lhs, const ms_protein &rhs)
Protein objects perform a simple sort of themselves by database ID and then accession.

Detailed Description

This class encapsulates a protein in the mascot results file.

Pointers to ms_protein objects are returned from ms_peptidesummary::getHit() or ms_proteinsummary::getHit(), so there should be no need to create one of these from outside the library.

Examples
peptide_list.cpp, repeat_search.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

◆ DISTINCT_PEPTIDE_FLAGS

enum DISTINCT_PEPTIDE_FLAGS

Enum for getNumDistinctPeptides().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

There are several possible defintions for 'distinct'!

One of more of these flags can be combined using a bitwise 'OR' operator to determine which peptide matches are treated as distinct matches when counting up matches. Imagine a protein that has the following matches

  • AGCMK - Charge state 2
  • AGCMK - Charge state 3
  • AGCMK - Charge state 2, Oxidised methionine
  • HSMTMR - Charge state 2
  • HSMTMR - Charge state 2
  • HSMTMR - Charge state 2, Oxidised methionine

In this case:

  • If DPF_SEQUENCE is specified, getNumDistinctPeptides() will return 2.
  • If DPF_SEQUENCE .OR. DPF_CHARGE is specified, getNumDistinctPeptides() will return 3.
  • If DPF_SEQUENCE .OR. DPF_MODS is specified, getNumDistinctPeptides() will return 4.
  • If DPF_SEQUENCE .OR. DPF_CHARGE .OR. DPF_MODS is specified, getNumDistinctPeptides() will return 5.

For completeness, getNumDisplayPeptides() will return a count of 6 and getNumPeptides() could return a count of 6 or could return 7 if HSM*TMR and HSMTM*R (where the asterisk indicates the oxidised methioine) both appear in the top 10 matches to the final query. (Some of these functions apply a threshold to the match scores, so this example assumes either no threshold is used or all matches are above threshold.)

A further complication is uniqueness within the whole database search. A peptide sequence that is distinct in one protein hit may also appear in another protein hit in the search. If you specify the flag DPF_UNIQUE, then only peptide matches that are unique within the whole search are counted, subject to the other flags. For example, if DPF_SEQUENCE .OR. DPF_UNIQUE is specified in the example above, then getNumDistinctPeptides() may return 0, 1 or 2, depending on which other protein hits contain the distinct peptide sequences assigned to the current protein hit.

The MCP guidelines require a count of "the total number of peptides assigned to the protein. To compute this number, multiple matches to peptides with the same primary sequence count as one, even if they represent different charge states or modification states". Specify DPF_SEQUENCE by itself to obtain this value.

A flags value that does not include DPF_SEQUENCE is unlikely to give a useful return value from getNumDistinctPeptides().

Enumerator
DPF_SEQUENCE | Peptide matches must have different primary sequences to be counted as distinct matches.
DPF_CHARGE | Peptide matches must have different charge states to be counted as distinct matches.
DPF_MODS | Peptide matches must have different modification states to be counted as distinct matches.
DPF_UNIQUE | Peptide matches must be unique in the whole search to be counted as distinct matches.
DPF_NODUPSAMEQUERY | Duplicate peptide matches from the same query should be excluded (see DUPE_DuplicateSameQuery ).

◆ DUPLICATE

enum DUPLICATE

Enum for the each peptide in the protein to indicate if it is a duplicate.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

A protein match is made up of one or more peptides. Duplicate peptides don't increase the coverage of the protein. They also do not increase the score except for MudPIT scoring.

Enumerator
DUPE_NotDuplicate | There are no other peptides with the same sequence in this protein - from this query or other queries.
DUPE_Duplicate | Another peptide from a different query with the same sequence as this got a higher score.
DUPE_DuplicateSameQuery | Another match for the same query with the same peptide string got a higher score (different mods).
DUPE_HighestScoringDuplicate | There is at least one other peptide the same as this with a lower score.
DUPE_Ignored | The peptide match was ignored due to IgnoreIonsScoreBelow.

◆ GROUP

enum GROUP

Enum to say if a protein is similar to another higher scoring protein.

See Grouping proteins together and Using enumerated values and static const ints in Perl, Java, Python and C#.

Note that if there are say 3 proteins with the same 4 peptide matches, then the highest scoring protein will have GROUP_NO, and the other two will have GROUP_COMPLETE. Calling getSimilarProteinName() on the highest scoring protein will return an empty string. Calling it for the other two proteins will return the accession for the highest scoring protein.

See also
ms_mascotresults::getNextSimilarProtein(), ms_mascotresults::getNextSubsetProteinOf()
Enumerator
GROUP_UNKNOWN | No information about grouping.
GROUP_NO | Does not contain same set (or subset) of peptides as another proteins. A 'lead' protein.
GROUP_SUBSET | Contains a subset of peptides in one ore more other proteins.
GROUP_COMPLETE | Contains an identical set of peptides to one or more other proteins.
GROUP_FAMILY | Second or subsequent family member when using new family grouping introduced in Mascot 2.3.

◆ MASS_FLAGS

enum MASS_FLAGS

enum for each protein to specify what masses to select.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Only a subset of all masses is used for scoring proteins. However, all matching masses are usually reported for each protein. Using these flags one can specify more precisely what sub-set of masses one is interested in. The flags can be combined with binary OR ("|"-operator in C++).

Enumerator
MASS_NON_SELECT_NON_MATCH | Only masses that are not selected and couldn't match.
MASS_SELECT_NON_MATCH | Only masses that are selected but do not match.
MASS_NON_SELECT_MATCH | Only masses that are not selected but otherwise would match.
MASS_SELECT_MATCH | Only masses that are selected and do match.

Constructor & Destructor Documentation

◆ ms_protein()

ms_protein ( const ms_protein & src )

Copying constructor.

Calling this function ensures that all the data is loaded into memory in the case where ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE is specified.

Parameters
src is the ms_protein object that will be copied.

Member Function Documentation

◆ anyMatchToQuery()

bool anyMatchToQuery ( const int query ) const

See if any match to this query.

This could be useful if you need to give a list of unmatched queries for a given protein.

Parameters
query Query number
Returns
true if any match was found, false otherwise

◆ anyMatchToQueryAndP()

bool anyMatchToQueryAndP | ( | const int | query,
 |  | const int | P
 | ) |  | const

See if any match to this query and 'P' (rank / hit).

This is useful for finding if this protein matched an identical peptide to another protein.

Parameters
query | query number
P | rank number
Returns
true if any match was found, false otherwise

◆ copyFrom()

void copyFrom ( const ms_protein * src )

Copies all content from another instance of the class.

Calling this function ensures that all the data is loaded into memory in the case where ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE is specified.

Parameters
src is a pointer to the source object

◆ getAccession()

std::string getAccession ( ) const

Return the accession string for a protein.

This will always be available, for every protein.

Returns
accession string of the protein
Examples
resfile_summary.cpp.

◆ getComponent()

const ms_protein * getComponent ( const int componentNumber ) const

For UniGene and PMF mixture return the 'component' protein.

For Unigene and PMF mixture, each 'protein' is made up of a number of components. Call this method to get the protein 'components' that were used to make up this 'pseudo' protein.

See Peptide mass fingerprint mixtures and Maintaining object references: two rules of thumb.

Parameters
componentNumber must be in the range 1..getNumComponents(), or a null value will be returned. No error message is generated for an out of range call.
Returns
A protein object if the componentNumber is valid, or a null value if there is an error.

◆ getCoverage()

long getCoverage ( ) const

Return the number of residues covered.

If two peptides overlap, then the overlapped ones are only counted once. Getting the coverage as a percentage is not possible from the results file because the length of the protein is not stored in the file. An approximate value could be calculated using ms_mascotresults::getProteinMass() and dividing by 110.

This function currently returns '0' for a PMF mixture and for a UniGene entry.

Returns
coverage of the protein
Examples
resfile_summary.cpp.

◆ getDB()

int getDB ( ) const

Return the index of the database where the sequence is found.

Use ms_searchparams::getDB() to retrieve the database name using the index returned by this function.

Returns
A number in the range 1..ms_searchparams::getNumberOfDatabases(), except for a UniGene or protein mixture where the returned number will be zero.
Examples
resfile_summary.cpp.

◆ getDistinctPeptide()

ms_peptide getDistinctPeptide | ( | int | distinctIndex,
 |  | int | repeatIndex = 1,
 |  | bool | aboveThreshold = false,
 |  | DISTINCT_PEPTIDE_FLAGS | flags = DPF_SEQUENCE
 | ) |  | const

Return the peptide repeat of the distinct peptide in the protein's peptide matches.

getNumDistinctPeptides() and getNumDistinctPeptideRepeats() indicate how many distinct peptides the protein has and how often they recur.

The individual ocurrences of the peptide are sorted by their ions scores in decreasing order. The first one (repeatIndex = 1) is the occurrence with the highest score.

When determining the valid ranges for the indexes, the same values should be passed for the aboveThreshold and flags parameters.

This can be used to retrieve the peptides to construct a tree as seen on the Mascot Search Results report or the Mascot Distiller protein tab.

To create a tree that matches the Mascot Search Results report, set aboveThreshold to false and use flags DPF_SEQUENCE, DPF_CHARGE, DPF_MODS and DPF_NODUPSAMEQUERY.

To create a tree that matches the Mascot Distiller protein tab, set aboveThreshold to false and use flags DPF_SEQUENCE, DPF_MODS and DPF_NODUPSAMEQUERY.

The distinct peptides are ordered into increasing molecular weight (see ms_peptide::getMrCalc()). The lowest Mr(calc) is the first peptide (distinctIndex = 1).

The repeats are ordered into decreasing score (see ms_peptide::getIonsScore()). The highest score is always the first repeat (repeatIndex = 1).

Parameters
distinctIndex | Index into a list of distinct peptides, 1..getNumDistinctPeptides().
repeatIndex | Index into a list of repeats of the distinct peptide, 1..getNumDistinctPeptideRepeats(). Set this to 1 to get the primary (highest score) instance of the distinct peptide.
aboveThreshold | If true, the function will only count the number of peptides above the threshold. The threshold used will be ms_mascotresults::getPeptideIdentityThreshold() unless ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specified in the ms_peptidesummary constructor in which case the threshold is returned by ms_peptidesummary::getHomologyThreshold().
flags | - see ms_protein::DISTINCT_PEPTIDE_FLAGS for details.
Returns
The chosen repeat of the chosen distinct peptide.

◆ getFrame()

int getFrame ( ) const

Returns the frame number for the protein.

A value of -1 will be returned if the peptides come from different frames. For a protein database, a value of zero will be returned. Frames 1 to 3 are the 'forward' strand, and 4 to 6 are the 'reverse' strand.

Returns
frame of the protein
Examples
resfile_summary.cpp.

◆ getGrouping()

ms_protein::GROUP getGrouping ( ) const

Returns a flag which shows if this protein only contain the same peptides as those in another protein.

See Grouping proteins together.

Returns
The group flag.

◆ getHitNumber()

int getHitNumber ( ) const

Returns the hit number in the results list.

For a protein that is a subset, the value returned is the hit number of the 'main' protein.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
hit number of the protein

◆ getIgnoredQPs()

void getIgnoredQPs | ( | std::vector< int > & | q,
 |  | std::vector< int > & | p
 | ) |  | const

Return a list of queries and ranks that would have been part of this protein hit had they not been removed by IgnoreIonsScoreBelow.

Note that this method is only useful when the search is an integrated spectral library search, the results file has been opened in integrated library mode (ms_peptidesummary::MSPEPSUM_SL_INTEGRATED) and IgnoreIonsScoreBelow is set to a non-zero value.

When all the requirements are met, this method returns the queries and ranks (q,p) of the peptide matches removed due to IgnoreIonsScoreBelow but which would have been part of this protein hit otherwise. The q,p values are needed when iterating over all peptide matches assigned to this protein hit, because evidence for a peptide sequence can come from either search engine.

For example, suppose query 4339 has two matches to the same sequence: significant rank 1 match from the FASTA file and non-significant rank 2 match from the spectral library. Let the rank 1 match be in FASTA accession FAS1 and the rank 2 match in library accession LIB1. Since the matches have the same sequence, the rank 1 match provides evidence for it (it is significant) and the sequence is used in protein grouping. FAS1 and LIB1 end up in the same family, since they match the same significant sequence.

Suppose the rank 2 match is now hidden due to IgnoreIonsScoreBelow. Suppose further that FAS1 ends up as a subset of LIB1. If you iterate over the visible peptide matches of LIB1, query 4339 is nowhere to be seen, because it's hidden. But FAS1 might not appear anywhere either, since it's a subset protein. Query 4339 won't be in the unassigned list, because its rank 1 match was used as peptide evidence in protein grouping.

The only way to discover query 4339 is by iterating over the ignored matches in LIB1. There, query 4339 has the rank 2 match, and you can inspect the other ranks in the query to discover the rank 1 match.

See also
Spectral libraries.
Parameters
[out] | q | Vector in which the list of queries is returned.
[out] | p | Vector in which the list of ranks is returned.

◆ getLongestPeptideLen()

int getLongestPeptideLen ( ) const

Return the length (in residues) of the longest peptide in the protein.

Returns
The length of the longest peptide in the protein

◆ getLongestSigPeptideLen()

int getLongestSigPeptideLen ( ) const

Return the length (in residues) of the longest significant peptide in the protein.

The threshold can be the identity or the homology threshold and is determined using ms_mascotresults::getPeptideThreshold()

Returns
the length of the longest peptide with a score greater than the relevant threshold.

◆ getMasses()

std::string getMasses | ( | ms_mascotresfilebase & | resfile,
 |  | const ms_proteinsummary & | summary,
 |  | const unsigned int | flags = MASS_SELECT_MATCH,
 |  | const int | numDecimalPlaces = 2
 | ) |  | const

Return a list of comma separated experimental masses according to a specified filter.

This is useful for selecting and displaying the list of observed mass values that satisfy the selection criteria. A number of different flag combinations can produce various sets of masses. An incomplete list of possible combinations follows:

  • peaks selected for scoring that match: MASS_SELECT_MATCH
  • peaks selected for scoring that don't match: MASS_SELECT_NON_MATCH
  • peaks not used for scoring that could match: MASS_NON_SELECT_MATCH
  • peaks not used for scoring that wouldn't match: NON_SEL_NON_MATCH
  • all peaks that could match: MASS_SELECT_MATCH | MASS_NON_SELECT_MATCH
  • all peaks that wouldn't match: MASS_NON_SELECT_NON_MATCH | MASS_SELECT_NON_MATCH

See Maintaining object references: two rules of thumb.

Parameters
resfile | file object to extract information from.
summary | summary-object to extract information from.
flags | controls what masses should be returned (see ms_protein::MASS_FLAGS for the complete list of possible values).
numDecimalPlaces | number of decimal places for a formatted mass.
Returns
string of concatenated observer masses separated by commas

◆ getMemberNumber()

int getMemberNumber ( ) const

Returns the member number within a family in the results list.

For a protein that is not in a family, the value returned is 0. For a 'main' protein in a family, the value returned is 1. For other members of a family, the value returned is 2 or more.

Returns
member number of the protain

◆ getNonMudpitScore()

double getNonMudpitScore ( ) const

Will only return a different score from getScore() if the MSRES_MUDPIT_PROTEIN_SCORE flag has been specified.

For a protein summary, this will be the same as returned by getScore().

For a peptide summary, if the ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE has been specified as a flag when creating the ms_peptidesummary object, then the protein score will be calculated differently to offset some artifacts created when the number of spectra approaches the number of sequences in the database (e.g. for MudPIT data sets). See getScore() for details.

If the MUDPIT flag was specified, then the old score can be obtained using this function.

For a peptide summary where ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE was not specified, this function will return the same value as getScore().

Returns
non mudpit score of the protein

◆ getNumComponents()

int getNumComponents ( ) const

For UniGene and PMF mixture, return number of 'component' proteins.

For UniGene and PMF mixture, each 'protein' is made up of a number of components. Call this method to see how many 'components' were used to make up this 'pseudo' protein. Then call getComponent() to get each of the proteins in turn.

For a 'real' protein (i.e not a mixture or UniGene entry), this method will return zero.

See Peptide mass fingerprint mixtures.

Returns
The number of components.

◆ getNumDisplayPeptides()

int getNumDisplayPeptides ( bool aboveThreshold = false ) const

Return the number of peptides excluding those that with duplicate matches to same query.

There can be multiple matches to a peptide from the same query; this will occur when there are matches with different mods or mods in different locations. In this case, it is normal to display them using the following loop:

 for (int i=1; i <= prot->getNumPeptides(); i++)
 {
   int query = prot->getPeptideQuery(i);
   int p     = prot->getPeptideP(i);

   if (p != -1
   && query != -1
   && prot->getPeptideDuplicate(i) != ms_protein::DUPE_DuplicateSameQuery)
   {
       // Display peptide match
   }
 }

For an error tolerant search, if the top match to a query is an error tolerant match, then the query does not contribute to the number of matches above the threshold even if the rank 2 match for the query is above the threshold.

Parameters
aboveThreshold If true, the function will only count the number of peptides above the threshold. The threshold used will be ms_mascotresults::getPeptideIdentityThreshold() unless ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specified in the ms_peptidesummary constructor in which case the threshold is returned by ms_peptidesummary::getHomologyThreshold().
Returns
the number of peptides that would be displayed.
Examples
resfile_summary.cpp.

◆ getNumDistinctPeptideRepeats()

int getNumDistinctPeptideRepeats | ( | int | distinctIndex,
 |  | bool | aboveThreshold = false,
 |  | DISTINCT_PEPTIDE_FLAGS | flags = DPF_SEQUENCE
 | ) |  | const

Return the number of repeats of the distinct peptide in the protein's peptide matches.

getNumDistinctPeptides() returns the number of distinct peptides (distinct as defined by the calling parameters). Each distinct peptide may occur more than once in the complete set of peptide matches for the protein.

This returns the number of times the distinct peptide occurs. The individual occurrences can then be accessed with getDistinctPeptide().

When determining the valid ranges for the index, the same values should be passed for the aboveThreshold and flags parameters.

Parameters
distinctIndex | Index into a list of distinct peptides, 1..getNumDistinctPeptides()
aboveThreshold | If true, the function will only count the number of peptides above the threshold. The threshold used will be ms_mascotresults::getPeptideIdentityThreshold() unless ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specified in the ms_peptidesummary constructor in which case the threshold is returned by ms_peptidesummary::getHomologyThreshold().
flags | - see ms_protein::DISTINCT_PEPTIDE_FLAGS for details.
Returns
the count of the number of repeats of the chosen distinct peptide.

◆ getNumDistinctPeptides()

int getNumDistinctPeptides | ( | bool | aboveThreshold = false,
 |  | DISTINCT_PEPTIDE_FLAGS | flags = DPF_SEQUENCE
 | ) |  | const

Return the number of distinct peptides in the protein sequence.

Useful, for example, for MCP reports.

Parameters
aboveThreshold | If true, the function will only count the number of peptides above the threshold. The threshold used will be ms_mascotresults::getPeptideIdentityThreshold() unless ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specified in the ms_peptidesummary constructor in which case the threshold is returned by ms_peptidesummary::getHomologyThreshold().
flags | - see ms_protein::DISTINCT_PEPTIDE_FLAGS for details.
Returns
the count of the number of distinct peptides.

◆ getNumObservedForEmPAI()

int getNumObservedForEmPAI ( ) const

Return the number of peptides 'observed' for emPAI quantitation calculation.

This function should not normally be called directly but is called by ms_mascotresults::getProteinEmPAI

The count of observed peptides only includes peptide matches with scores at or above the homology threshold, or the identity threshold, if there is no homology threshold. Ishihama et. al. obtained best proportionality for a standard protein mixture by counting unique parent ions, including different charge states from the same peptide sequence. This function counts the number of unique parent ions ignoring charge state, which produces better results when the number of charge states is large (e.g. 2+, 3+, 4+, 5+, 6+ and 7+). The differences are negligible when the data are only singly or doubly charged.

This function will still return a value even if ms_mascotresults::isEmPAIallowed() returns false.

If the protein contains any intact crosslinks, the emPAI assumptions are no longer valid, so the count of peptides returned is 0.

The value returned is stored in the cache file when Using the pepsum cache (MSR and dat28)

Returns
the count of peptides used for the emPAI value. Will be 0 if no peptides are above the specified threshold

◆ getNumPeptides()

int getNumPeptides ( ) const

Return the number of peptides that had a match in this protein.

This includes peptides that are duplicates. See also getNumDisplayPeptides().

Returns
number of peptides in the protein
Examples
resfile_summary.cpp.

◆ getPepNumber()

int getPepNumber | ( | const int | q,
 |  | const int | p
 | ) |  | const

Return the pepNumber given query and rank.

A matched protein contains a number of peptides. Further information about the peptide in the context of the protein can be obtained by calling getPeptideFrame(), getPeptideStart(), getPeptideEnd() etc. These functions all require a pepNumber, and this may be found using this function in cases where only q and p are readily available.

Parameters
q | is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p | is the 'rank' number. For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. See ms_peptidesummary::getMaxRankValue() and ms_proteinsummary::getMaxRankValue().
Returns
pepNumber will be -1 if there is no matching peptide with these q and p values. Otherwise it will be in the range 1 to getNumPeptides().

◆ getPeptideComponentID()

int getPeptideComponentID ( const int pepNumber ) const

Returns 0 except for a UniGene entry or a PMF mixture entry.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

If this protein is really just a UniGene entry, or a PMF mixture entry then it is not a 'real' protein but just a container for a number of component proteins. In this case, each peptide originates from one of the components. The 'real' protein that corresponds to each component can be found using getComponent().

In the case of the same peptide being found in multiple components, the ID returned will be any one of these components.

Parameters
pepNumber must be in the range 1 to getNumPeptides().
Returns
component id for the peptide whose index is passed

◆ getPeptideDuplicate()

ms_protein::DUPLICATE getPeptideDuplicate | ( | const int | pepNumber,
 |  | const bool | allowErrTolDuplicate = true
 | ) |  | const

Return the DUPLICATE status given the peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

However, duplicate peptides could possibly be different for different proteins, so this value is not available in the ms_peptide object, but can be found in here in the protein object.

The allowErrTolDuplicate parameter controls duplicate checking behaviour in error tolerant searches. When true (default), the peptide pepNum is compared to all first pass and second pass (ET) matches. If the peptide is flagged as a duplicate, it may be a duplicate of a first or a second pass match.

When allowErrTolDuplicate is false, the peptide pepNum is only compared to first pass matches. This special case is used during protein inference.

Parameters
pepNumber | must be in the range 1 to getNumPeptides().
allowErrTolDuplicate | is true by default. See above for behaviour when set to false.
Returns
duplicate status for peptide whose index is passed in parameter
Examples
resfile_summary.cpp.

◆ getPeptideEnd()

long getPeptideEnd | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Return the peptide end residue given the peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

However, the same peptide sequence may occur in different places in different proteins, so the start and end residue information is not available in the ms_peptide object, but can be found in here using this function and getPeptideStart(). The returned number is 1 based.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide end or beta peptide end. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is -1.

If the peptide match is not crosslinked, psmComponent is ignored.

Parameters
pepNumber | must be in the range 1 to getNumPeptides().
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
end of the peptide whose index is passed in parameter

◆ getPeptideFrame()

int getPeptideFrame | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Return the frame number given the peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

However, the same peptide sequence may occur in different frames in different proteins, so the frame information is not available in the ms_peptide object, but can be found in here in the protein object.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide frame or beta peptide frame. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is -1.

If the peptide match is not crosslinked, psmComponent is ignored.

Parameters
pepNumber | must be in the range 1 to getNumPeptides().
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
frame of the peptide whose index is passed in parameter

◆ getPeptideIonsScore()

double getPeptideIonsScore ( const int pepNumber ) const

Return the ions score within this protein context given the peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

However, there are minor corrections to the score for each peptide depending on the protein that it is found in.

The Mascot results pages display the score returned from ms_peptide::getIonsScore() because results from similar proteins are displayed together. For ms_proteinsummary results, the return values from ms_peptide::getIonsScore() and ms_protein::getPeptideIonsScore() will be identical.

For an integrated error tolerant search where ms_mascotresults::MSRES_INTEGRATED_ERR_TOL is specified, the protein score is derived from the highest scoring non error tolerant match for each query, and this is the value returned by this function.

In an integrated spectral library search, if the peptide at pepNumber is a library match, the return values from ms_peptide::getIonsScore() and ms_protein::getPeptideIonsScore() will be identical. Library scores are not affected by multiplicity correction.

Parameters
pepNumber must be in the range 1 to getNumPeptides().
Returns
the peptide ions score as used in the protein score.

◆ getPeptideIsBold()

bool getPeptideIsBold ( const int pepNumber ) const

Returns true if this peptide should be displayed in bold in a Mascot report.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

This function returns true if this peptide should be displayed in bold in a Mascot report. Bold is used for the first time a query is shown in a report. See also ms_peptide::getFirstProtAppearedIn().

Parameters
pepNumber must be in the range 1 to getNumPeptides().
Returns
whether the peptide whose index is passed in parameter is bold
Examples
resfile_summary.cpp.

◆ getPeptideMultiplicity()

long getPeptideMultiplicity | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Return the number of precursor matches in this protein for the specified peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

The multiplicity value is the number of times that the precursor mass for the specified peptide got a match in this protein. With a tight tolerance and no variable modifications, this will normally be a small number. For a large protein, with no enzyme specificity and a large number of modifications (or an error tolerant search), this can be a large number.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide multiplicity or beta peptide multiplicity. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is -1.

If the peptide match is not crosslinked, psmComponent is ignored.

This value is used internally for standard protein scoring and is not normally required outside Mascot Parser.

See also
ms_mascotresults::getIonsScoreCorrected() and getScore() for details of how this value is used for protein scoring.
Parameters
pepNumber | must be in the range 1 to getNumPeptides().
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
The number of matches to the precursor in this protein.

◆ getPeptideP()

int getPeptideP ( const int pepNumber ) const

Return the 'rank' number given the peptide 'number'.

A matched protein contains a number of peptides. These peptides all originate from a 'query'. For peptide summary information, the top 10 scoring results are kept. This is the 'rank' number.

For protein summary information, 'P' refers to the protein hit number.

To get an ms_peptide object, call ms_mascotresults::getPeptide() using the return value from this function and the 'query' from ms_protein::getPeptideQuery().

Parameters
pepNumber must be in the range 1 to getNumPeptides().
Returns
rank number for the peptide whose index is passed in parameter
Examples
resfile_summary.cpp.

◆ getPeptideQuery()

int getPeptideQuery ( const int pepNumber ) const

Return the query number given the peptide 'number'.

A matched protein contains a number of peptides. These peptides all originate from a 'query'. The query number is returned by this function.

To get an ms_peptide object, call ms_mascotresults::getPeptide() using the return value from this function and the 'p' value from ms_protein::getPeptideP().

Parameters
pepNumber must be in the range 1 to getNumPeptides().
Returns
query number for the peptide whose index is passed in parameter
Examples
resfile_summary.cpp.

◆ getPeptideResidueAfter()

char getPeptideResidueAfter | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Returns the residue immediately after the peptide.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

The residue before and after are only saved in the results files for Mascot 2.1 and later. For files created with earlier versions of Mascot, a '?' will be returned.

If the peptide is an C terminal peptide, then this function will return '-'.

If the search was against nucleic acid data and the peptide is just before a stop codon, then this function will return '@'.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide residue or beta peptide residue. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is '?'.

If the peptide match is not crosslinked, psmComponent is ignored.

Parameters
pepNumber | must be in the range 1 to getNumPeptides().
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
residue after the peptide whose index is passed in parameter

◆ getPeptideResidueBefore()

char getPeptideResidueBefore | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Returns the residue immediately before the peptide.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

The residue before and after are only saved in the results files for Mascot 2.1 and later. For files created with earlier versions of Mascot, a '?' will be returned.

If the peptide is an N terminal peptide, then this function will return '-'.

If the search was against nucleic acid data and the peptide is just after a stop codon, then this function will return '@'.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide residue or beta peptide residue. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is '?'.

If the peptide match is not crosslinked, psmComponent is ignored.

Parameters
pepNumber must be in the range 1 to getNumPeptides()
psmComponent is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
residue before the peptide whose index is passed in parameter

◆ getPeptideShowCheckbox()

bool getPeptideShowCheckbox ( const int pepNumber ) const

Returns true if a check box for repeat searches should be shown in a Mascot report.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

A check box is displayed if this is the first rank 1 match that has been displayed for this query. See also ms_peptide::getRank() and ms_peptide::getPrettyRank().

By definition, all unassigned queries will need a check box.

Parameters
pepNumber must be in the range 1 to getNumPeptides().
Returns
whether a check box is displayed the peptide whose index is passed in parameter
Examples
resfile_summary.cpp.

◆ getPeptideStart()

long getPeptideStart | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Return the peptide start residue given the peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

However, the same peptide sequence may occur in different places in different proteins, so the start and end residue information is not available in the ms_peptide object, but can be found in here using this function and getPeptideEnd(). The returned number is 1 based.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide start or beta peptide start. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is -1.

If the peptide match is not crosslinked, psmComponent is ignored.

A value of -1 is returned if there is an error.

Parameters
pepNumber | must be in the range 1 to getNumPeptides().
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns
start of the peptide whose index is passed in parameter

◆ getProteinId()

int64_t getProteinId ( ) const

Return the protein id.

Unique identifier for proteins used in msr format

Returns
protein id. If unavailable, return -1

◆ getProteinSummaryHit()

int getProteinSummaryHit ( ) const

For a protein from the protein summary only.

There should be no real reason to use this method outside the library, apart from when determining a value to pass as the singleHit parameter when calling ms_proteinsummary::ms_proteinsummary().

If the protein came from the summary section (or mixture section) then this will return the hit number. For a protein that came from a ms_peptidesummary, this will return zero.

Used within the library for getting the sort order for a PMF the same as in the results file (only an issue for proteins with a similar score).

Returns
hit number of the protein in the protein summary

◆ getRMSDeltas()

double getRMSDeltas ( const ms_mascotresults & results ) const

Return the RMS value of the deltas between the calculated and experimental value.

The value is returned in ppm.

Parameters
results reference to an ms_mascotresults object
Returns
RMS value of all deltas in the protein

◆ getScore()

double getScore ( ) const

Return the protein score for this protein.

Two protein scoring algorithms are available: MudPIT scoring (recommended) and standard scoring. For a protein summary, only standard scoring is supported.

MudPIT Scoring (recommended)

If the flag ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE is specified, protein score is calculated by:

  Protein score = 0
  For each peptide match {
    If there is a homology threshold and ions score > homology threshold
    {
      Protein score += ions score - homology threshold
    } else if ions score > identity threshold {
      Protein score += ions score - identity threshold
    }
  }
  Protein score += 1 * average of all the subtracted thresholds

In spectral library searches (Parser 2.6 and later), the algorithm is the same but the score excess over threshold has a different form depending on library mode:

  • In SL-only mode, proteins contain only spectral library matches, so MudPIT score is calculated as above using the raw library scores and library score threshold.
  • In integrated library mode, proteins can contain a mixture of FASTA and library matches. Library scores are first converted to a score excess on the same scale as Mascot scores. (For a detailed discussion, see Advanced reading: calculating the spectral library score threshold.)

In versions prior to 2.2, the thresholds were not affected by the minProbability parameter of the ms_peptidesummary constructor; a default value of 1 in 20 was always used.

Standard Scoring

The standard protein score is the sum of ions scores for each match. For duplicate peptides, just the highest score is taken.

The standard score can be lower than the sum of the ions scores, particularly when the protein is large. This is because a correction is applied to compensate for the accumulation of random ions scores from random matches. The difference is more substantial when doing a no-enzyme search, because there are orders of magnitude more random matches. See the function ms_mascotresults::getIonsScoreCorrected() for details of how the correction is calculated. If the correction causes the ions score to become negative, then this ions score is ignored when calculating the protein score.

Note that the match score correction is only used with standard scoring. MudPIT scoring always uses the uncorrected score.

See also
getNonMudpitScore(), ms_mascotoptions::getMudpitSwitch()
Returns
score of the protein
Examples
repeat_search.cpp, and resfile_summary.cpp.

◆ getScoreWithET()

double getScoreWithET ( ) const

Return the protein score including ET matches for this protein.

Returns the score of the protein including ET matches This is used mainly for Family grouping, to differentiate between between two otherwise identical proteins

Returns
score of the protein including error tolerant matches

◆ getSimilarProteinDB()

int getSimilarProteinDB ( ) const

Return the database index of a protein that contains the same set (or a superset of) of the peptides in this protein.

Deprecated:
Use ms_protein::getSimilarProteins(), ms_mascotresults::getNextSimilarProtein() or ms_mascotresults::getNextSimilarProteinOf() instead.

This function returns a single protein database ID. When using the ms_mascotresults::MSRES_CLUSTER_PROTEINS flag, a subset protein may be a subset of more than one parent protein. To find the complete list of proteins that it is a subset of, call getSimilarProteins(). This function just returns the 'first' protein in the list of superset proteins. There will only be a multiple 'similar' proteins in cases where ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified and where this protein is a GROUP_SUBSET. There will only be a single 'similar' protein where this protein is GROUP_COMPLETE.

See Grouping proteins together, getGrouping() and getSimilarProteinName().

Returns
the database ID for the sameset or superset protein.

◆ getSimilarProteinName()

std::string getSimilarProteinName ( ) const

Return the accession of a protein that contains the same set (or a superset of) of the peptides in this protein.

Deprecated:
Use ms_protein::getSimilarProteins(), ms_mascotresults::getNextSimilarProtein() or ms_mascotresults::getNextSimilarProteinOf() instead.

This function returns a single protein accession string. When using the ms_mascotresults::MSRES_CLUSTER_PROTEINS flag, a subset protein may be a subset of more than one parent protein. To find the complete list of proteins that it is a subset of, call getSimilarProteins(). This function just returns the 'first' protein in the list of superset proteins. There will only be a multiple 'similar' proteins in cases where ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified and where this protein is a GROUP_SUBSET. There will only be a single 'similar' protein where this protein is GROUP_COMPLETE.

See Grouping proteins together, getGrouping() and getSimilarProteinDB().

Returns
the accession for the sameset or superset protein.

◆ getSimilarProteins()

int getSimilarProteins | ( | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIdxs
 | ) |  | const

Return a list of proteins that that contains the same set (or a superset of) of the peptides in this protein.

See Using MSRES_CLUSTER_PROTEINS.

Parameters
accessions | Is the list of accessions for which this protein is a sameset or a subset. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIdxs | Is the corresponding list of databases for the accessions. This array will be the same size as the accessions array. For a search against a single database, all the IDs will be 1. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
The number of accessions and database IDs returned in the vectors.

◆ getUnmatchedMasses()

std::string getUnmatchedMasses | ( | ms_mascotresfilebase & | resfile,
 |  | const int | numDecimalPlaces = 2
 | ) |  | const

Return a list of comma separated experimental masses that don't match.

This is useful for displaying the list of observed mass values that failed to get a match to a protein hit in a PMF (listed at end of each hit in a protein summary report).

Parameters
resfile | reference to a ms_mascotresfilebase object
numDecimalPlaces | decimal precision
Returns
string of concatenate observed masses separated by commas

◆ isASimilarProtein()

bool isASimilarProtein | ( | const ms_protein * | prot,
 |  | const ms_mascotresults * | results,
 |  | const bool | groupByQueryNumber = false
 | ) |  |

Find a protein in the results.

Note
This function should not need to be called from outside Mascot Parser.

The function looks to see if 'self' contains the same set or a subset of matching peptides as the passed 'prot'. If it does, then it sets its group to be GROUP_COMPLETE or GROUP_SUBSET and also sets the similar protein accession.

Parameters
prot | Is the protein to compare.
results | Need to be passed for access to the peptide information.
groupByQueryNumber | Is used to determine whether peptide similarity is just by query number (for PMF) or by peptide string for MS-MS.
Returns
TRUE if the proteins are similar.

◆ isPMFMixture()

bool isPMFMixture ( ) const

Returns true if the 'protein' is actually a PMF mixture.

To find out what 'component' proteins were used to get this entry, see getComponent() and Peptide mass fingerprint mixtures.

Returns
true if the protein originates from a PMF mixture, false otherwise

◆ isUpdateScoreFromPepScores()

bool isUpdateScoreFromPepScores ( ) const

\ Returns true if protein score is updated from peptides

TODO

Returns
true if the

◆ setDB()

void setDB ( int idx )

Set database index.

Parameters
idx database index from 1 to ms_searchparams::getNumberOfDatabases().

◆ setPeptideIsBold()

void setPeptideIsBold ( const int pepNumber )
Note
This function should normally only be used internally.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

Parameters
pepNumber must be in the range 1 to getNumPeptides().

◆ setPeptideShowCheckbox()

void setPeptideShowCheckbox ( const int pepNumber )

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

A check box is displayed if this is the first rank 1 match that has been displayed for this query. See also ms_peptide::getRank() and ms_peptide::getPrettyRank().

By definition, all unassigned queries will need a check box.

Parameters
pepNumber must be in the range 1 to getNumPeptides().

◆ setProteinId()

void setProteinId ( int64_t proteinId )

Set Protein id.

Set the unique identifier for proteins used in msr format

Parameters
proteinId Unique id retrieved from the msr file.

Friends And Related Function Documentation

◆ operator<

bool operator< | ( | const ms_protein & | lhs,
 |  | const ms_protein & | rhs
 | ) |  |
friend

Protein objects perform a simple sort of themselves by database ID and then accession.

Note
This method can only be used by C++ programs.

Final sorting for proteins by score and then accession is more complex.

Parameters
lhs | left element to compare
rhs | right element to compare
The documentation for this class was generated from the following files:
  • ms_protein.hpp
  • ms_protein.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_proteinsummary Class Reference

  • matrix_science
  • ms_proteinsummary
Public Types | Public Member Functions | Protected Member Functions | List of all members
ms_proteinsummary Class Reference
Mascot results file module

#include <ms_proteinsummary.hpp>

Inheritance diagram for ms_proteinsummary:
[legend]
Collaboration diagram for ms_proteinsummary:
[legend]

Public Types

enum DB_MATCH_TYPE {
DM_FASTA = 0 ,
DM_SPECTRAL_LIBRARY = 1 ,
DM_BOTH = 2 ,
DM_FASTA_FIRST_PASS = 3 ,
DM_FASTA_SECOND_PASS = 4
}
Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram(). More...
enum DECOY_STATS_COUNT_TYPE {
DS_COUNT_PSM = 0 ,
DS_COUNT_SEQUENCE = 1
}
Type of object counted by getNumHitsAboveIdentity() and friends. More...
enum FIND_COMPARE_FLAGS {
FC_COMPLETESTR = 0x00000001 ,
FC_SUBSTR = 0x00000002 ,
FC_STARTSTR = 0x00000003 ,
FC_STRTOK = 0x00000004 ,
FC_MASK_STR_PART = 0x0000000F ,
FC_CASE_INSENSITIVE = 0x00000000 ,
FC_CASE_SENSITIVE = 0x00000010 ,
FC_MASK_CASE = 0x000000F0 ,
FC_FORWARD = 0x00000000 ,
FC_REVERSE = 0x00000100 ,
FC_MASK_DIRECTION = 0x00000F00 ,
FC_RESTRICT_TO_HIT = 0x00001000 ,
FC_LOOP_INTO_UNASSIGNED = 0x00002000 ,
FC_LOOP_FROM_UNASSIGNED = 0x00004000 ,
FC_UNASSIGNED_MASK = 0x00006000 ,
FC_SEARCH_ALL_RANKS = 0x00008000 ,
FC_ALL_PEPTIDES = 0x00000000 ,
FC_ALL_PEPTITDES = 0x00000000 ,
FC_SIGNIFICANT_PEPTIDES = 0x00010000 ,
FC_SEARCH_IGNORED_RANKS = 0x00020000 ,
FC_SCORING_MASK = 0x000F0000 ,
FC_PROTEIN_IGN_SAMESETS = 0x00100000 ,
FC_PROTEIN_IGN_SUBSETS = 0x00200000 ,
FC_PROTEIN_IGN_FAMILY = 0x00400000 ,
FC_PROTEIN_IGN_MASK = 0x00F00000 ,
FC_PROTEIN_INC_ALT_ACC = 0x01000000
}
Flags to specify how comparisons are performed in the find functions. More...
enum FIND_FLAGS {
FT_PEPTIDE_EXP_MZ = 0x00000001 ,
FT_PEPTIDE_EXP_MR = 0x00000002 ,
FT_PEPTIDE_CALC_MZ = 0x00000004 ,
FT_PEPTIDE_CALC_MR = 0x00000008 ,
FT_PEPTIDE_STRING = 0x00000010 ,
FT_PEPTIDE_QUERY = 0x00000020 ,
FT_PEPTIDE_VARMOD = 0x00000040 ,
FT_PEPTIDE_FIXMOD = 0x00000080 ,
FT_PEPTIDE_ETMOD = 0x00000100 ,
FT_PEPTIDE_SLMOD = 0x00000200 ,
FT_PEPTIDE_VARMOD_BYNAME = 0x00000400 ,
FT_PEPTIDE_FIND_MASK = 0x00000FFF ,
FT_PROTEIN_ACCESSION = 0x00001000 ,
FT_PROTEIN_DESCRIPTION = 0x00002000
}
Flags for findPeptides() and findProteins(). More...
enum FLAGS {
MSRES_NOFLAG = 0x00000000 ,
MSRES_GROUP_PROTEINS = 0x00000001 ,
MSRES_SHOW_SUBSETS = 0x00000002 ,
MSRES_SUBSETS_DIFF_PROT = 0x00000004 ,
MSRES_REQUIRE_BOLD_RED = 0x00000008 ,
MSRES_SHOW_ALL_FROM_ERR_TOL = 0x00000010 ,
MSRES_IGNORE_PMF_MIXTURE = 0x00000020 ,
MSRES_MUDPIT_PROTEIN_SCORE = 0x00000040 ,
MSRES_DECOY = 0x00000080 ,
MSRES_INTEGRATED_ERR_TOL = 0x00000100 ,
MSRES_ERR_TOL = 0x00000200 ,
MSRES_MAXHITS_OVERRIDES_MINPROB = 0x00000400 ,
MSRES_CLUSTER_PROTEINS = 0x00000800 ,
MSRES_DUPE_INCL_IN_SCORE_NONE = 0x00000000 ,
MSRES_DUPE_INCL_IN_SCORE_A = 0x00002000 ,
MSRES_DUPE_INCL_IN_SCORE_B = 0x00004000 ,
MSRES_DUPE_INCL_IN_SCORE_C = 0x00008000 ,
MSRES_DUPE_INCL_IN_SCORE_D = 0x00010000 ,
MSRES_DUPE_INCL_IN_SCORE_E = 0x00020000 ,
MSRES_DUPE_INCL_IN_SCORE_F = 0x00040000 ,
MSRES_DUPE_INCL_IN_SCORE_G = 0x00080000 ,
MSRES_DUPE_INCL_IN_SCORE_H = 0x00100000 ,
MSRES_DUPE_INCL_IN_SCORE_I = 0x00200000 ,
MSRES_DUPE_REMOVE_NONE = 0x00400000 ,
MSRES_DUPE_REMOVE_A = 0x00800000 ,
MSRES_DUPE_REMOVE_B = 0x01000000 ,
MSRES_DUPE_REMOVE_C = 0x02000000 ,
MSRES_DUPE_REMOVE_D = 0x04000000 ,
MSRES_DUPE_REMOVE_E = 0x08000000 ,
MSRES_DUPE_REMOVE_F = 0x10000000 ,
MSRES_DUPE_REMOVE_G = 0x20000000 ,
MSRES_DUPE_REMOVE_H = 0x40000000 ,
MSRES_DUPE_REMOVE_I = 0x80000000 ,
MSRES_DUPE_REMOVE_I = 0x80000000 ,
MSRES_DUPE_DEFAULT = 0x04800000
}
Flags for the type of results. More...
enum HOMOLOGY_THRESHOLD_SOURCE {
}
Flags for getHomologyThreshold() More...
enum IONS_HISTOGRAM {
IH_INCLUDE_TOP_MATCHES = 0x0000 ,
IH_INCLUDE_TOP_10_MATCHES = 0x0001
}
Flags for getIonsScoreHistogram(). More...
enum QUANT_COMPONENT_STATUS {
QCS_OK ,
QCS_OK_NO_MATCH ,
QCS_ERROR_NO_METHOD ,
QCS_ERROR_NO_COMPONENTS ,
QCS_ERROR_BAD_COMPONENT_NAME ,
QCS_OK_MULTIPLE_MATCHES
}
Return codes for getQuantitationComponentForPeptide(). More...
enum sortBy {
QUERY ,
SCORE ,
INTENSITY
}
Flags for createUnassignedList(). More...
enum THRESHOLD_TYPE {
TT_HOMOLOGY = 0x0000 ,
TT_IDENTITY = 0x0001 ,
TT_PEPSUM_DEFAULT = 0x0002
}
Flags for getPeptideThreshold() More...
enum TREE_CLUSTER_METHOD {
}
Flags for getTreeClusterNodes(). More...
enum UNIQUE_PEP_RULES {
UPR_WITHIN_FAMILY = 0x0001 ,
UPR_WITHIN_FAMILY_MEMBER = 0x0002 ,
UPR_IGNORE_SUBSET_PROTEINS = 0x0004 ,
UPR_DEFAULT = (UPR_WITHIN_FAMILY_MEMBER + UPR_IGNORE_SUBSET_PROTEINS)
}
Flags for isPeptideUnique(). More...

Public Member Functions

ms_proteinsummary (const ms_mascotresfilebase &resfile, const ms_mascotresults_params &parameters)
Call this constructor once to create protein summary results.
ms_proteinsummary (const ms_mascotresfilebase &resfile, const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS|ms_mascotresults::MSRES_SHOW_SUBSETS, double minProbability=0.0, int maxHitsToReport=50, const char *unigeneIndexFile=0, const char *singleHit=0)
Call this constructor once to create protein summary results.
virtual bool | anyEmPAI () const
Return true if any emPAI values are available.
virtual bool | anyNumDiscoveredMods () const
Return true if modification discovery statistics are available.
void | cancelCreateSummary (bool newValue=true)
Cancel the call to createSummary()
virtual bool | createSummary ()
Create the summary after the ms_mascotresults object has been created.
bool | createUnassignedList (sortBy s=QUERY)
To have a list of unassigned peptides, need to call this first.
virtual void | freeHit (const int hit)
Frees any memory associated with the passed hit number.
virtual int | getAllFamilyMembersWithThisPepMatch (const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const
Return a list of (top level) family proteins that have a match to the specified q and p.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const
Return a complete list of proteins that contain this same peptide match.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const
Return a complete list of proteins that contain this same peptide match.
virtual int | getAvePeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the average threshold value for all MS-MS data sets.
virtual bool | getComponentIntensity (const int q, const int p, const std::string &componentName, double &value, double &rawValue) const
Returns the component intensity for reporter or multiplex methods.
virtual const ms_protein * | getComponentProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
virtual std::string | getComponentString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return an empty string.
bool | getCreateSummaryProgress (int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const
Return progress for the createSummary() call.
virtual std::vector< double > | getDiscoveredErrTolModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all error tolerant modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredErrTolModNames () const
Return the names of all error tolerant modifications discovered in this search.
virtual std::vector< double > | getDiscoveredLocalModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all query-level modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredLocalModNames () const
Return the names of all query-level modifications discovered in this search.
virtual double | getErrTolModDelta (const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const
Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.
virtual std::string | getErrTolModifiedNaSeq (const int q, const int p) const
Return the modified sequence of nucleic acids after a single base modification in an error tolerant search.
virtual std::vector< double > | getErrTolModMasterNeutralLoss (const int q, const int p) const
Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.
virtual std::string | getErrTolModMasterString (const int q, const int p) const
Return the complete error tolerant mod primary neutral loss string from h1_q1_et_mods_primary.
virtual std::string | getErrTolModName (const int q, const int p, std::string *modString=NULL) const
Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.
virtual double | getErrTolModNeutralLoss (const int q, const int p) const
Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.
virtual std::vector< double > | getErrTolModPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.
virtual std::string | getErrTolModPepString (const int q, const int p) const
Return the complete error tolerant mod peptide neutral loss string from h1_q1_et_mods_pep.
virtual std::vector< double > | getErrTolModReqPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.
virtual std::string | getErrTolModReqPepString (const int q, const int p) const
Return the complete error tolerant mod required peptide neutral loss string from h1_q1_et_mods_reqpep.
virtual std::vector< double > | getErrTolModSlaveNeutralLoss (const int q, const int p) const
Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.
virtual std::string | getErrTolModSlaveString (const int q, const int p) const
Return the complete error tolerant mod slave neutral loss string from h1_q1_et_mods_slave.
virtual std::string | getErrTolModString (const int q, const int p) const
Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.
virtual std::string | getErrTolOriginalNaSeq (const int q, const int p) const
Return the original sequence of nucleic acids before a single base modification in an error tolerant search.
virtual double | getErrTolProbabilityThreshold () const
unsigned int | getFlags () const
Returns the flags value passed to the constructor.
unsigned int | getFlags2 () const
Return the flags2 value passed to the ms_peptidesummary constructor.
virtual ms_protein * | getHit (const int hit, const int memberNumber=0) const
Return the ms_protein hit - returns null if hit > number of hits.
virtual int | getHomologyThreshold (const int query, double OneInXprobRnd, const int rank=1) const
Returns the 'homology' threshold.
virtual int | getHomologyThresholdForHistogram (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns the value for the 'yellow section' in the histogram.
virtual double | getIonsScore (const int q, const int p, const bool decoy) const
Returns an ions score quickly without having to load an ms_peptide object.
virtual std::vector< int > | getIonsScoreHistogram (IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns a list of counts for binned ions scores.
virtual std::string | getLibraryModString (const int q, const int p) const
Return the modification string of the spectral library match from q1_p1_SLmod.
virtual int | getMaxPeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the max threshold value for all MS-MS data sets.
virtual int | getMaxRankValue () const
Returns the maximum 'rank' or 'hit' or 'p' value.
int | getMinPepLenInPepSummary () const
Peptides shorter than this are ignored when putting proteins into groups.
virtual ms_protein * | getNextFamilyProtein (const int masterHit, const int id) const
Find the next protein in the family masterHit.
virtual ms_protein * | getNextSimilarProtein (const int masterHit, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSimilarProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProtein (const int masterHit, const int id, const bool searchWholeFamily=true) const
Return the next protein that contains some of the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains some of the peptides in the 'master' protein.
virtual int | getNumberOfFamilyMembers () const
Return the total number of family members.
virtual int | getNumberOfHits () const
Returns the number of hits in the results.
int | getNumberOfUnassigned () const
Return the number of peptides in the unassigned list.
virtual long | getNumDecoyHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the homology threshold.
virtual long | getNumDecoyHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the identity threshold.
virtual std::vector< int > | getNumDiscoveredErrTolMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of error tolerant modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredFixedMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of fixed modifications discovered in this search.
std::vector< int > | getNumDiscoveredIntactLinks (std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const
Return the count of intact crosslinks in this search.
std::vector< int > | getNumDiscoveredLibraryMods (const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of library modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredLocalMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of query-level modifications discovered in this search.
virtual int | getNumDiscoveredNonSpecCleavage () const
Return the count of non-specific cleavages in an error tolerant search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of variable modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const
Return the count of variable modifications discovered in this search.
virtual long | getNumHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the homology threshold.
virtual long | getNumHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the identity threshold.
int | getNumPmfQueriesUsed () const
Returns number of queries (masses) used when calculating PMF protein scores.
virtual std::vector< int > | getPepsWithSameScore (const int q, const int p) const
Returns a list of 'p' values for peptides with the same score.
virtual ms_peptide | getPeptide (const int q, const int p) const
Return a peptide object for the specified query / hit.
virtual bool | getPeptide (const int q, const int p, ms_peptide *&pep) const
Return a peptide object for the specified query / hit.
virtual double | getPeptideExpectationValue (const double score, const int query, const int rank=0) const
Returns the expectation value for the given peptide score and query.
virtual int | getPeptideIdentityThreshold (const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the threshold value for this ms-ms data being a random match.
double | getPeptideThreshold (const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const
Return either the identity or the homology threshold.
virtual double | getProbabilityThreshold () const
Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.
virtual int | getProbFromScore (const double score) const
Returns a probability value given a score.
virtual double | getProbOfPepBeingRandomMatch (const double score, const int query) const
virtual double | getProbOfProteinBeingRandomMatch (const double score) const
virtual const ms_protein * | getProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
std::string | getProteinDescription (const char *accession, const int dbIdx=1) const
Return protein description if available.
virtual double | getProteinEmPAI (const char *accession, const int dbIdx=1, const int length=-1) const
Return protein emPAI if available.
virtual double | getProteinExpectationValue (const double score) const
Returns the expectation value for the given protein score.
double | getProteinMass (const char *accession, const int dbIdx=1) const
Return protein mass if available.
virtual int | getProteinScoreCutoff (double OneInXprobRnd) const
Return the 'protein' score value for cutting off results. Different for peptide and protein summary.
virtual double | getProteinScoreForHistogram (const int num) const
Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.
virtual std::string | getProteinsWithThisPepMatch (const int q, const int p, const bool quotes=false)
Return a partial list of proteins that matched the same peptide.
void | getProteinTaxonomyIDs (const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const
Return the taxonomy ID(s), if any, from the results file.
virtual int | getProteinThreshold (double OneInXprobRnd) const
Return a threshold value for the protein summary report.
virtual int | getQmatch (const int query) const
[Deprecated] Return the number of peptides with masses that matched this query.
virtual int | getQmatch (const int query, const ms_mascotresfile_dat::section sec) const
[Deprecated] Use ms_mascotresfilebase::getQmatch().
virtual ms_mascotresults::QUANT_COMPONENT_STATUS | getQuantitationComponentForPeptide (const matrix_science::ms_peptide &peptide, matrix_science::ms_quant_component &component, const matrix_science::ms_quant_method *method=NULL) const
Get the component in the quantitation method that matches the peptide.
virtual std::string | getReadableVarMods (const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return a 'human readable' string with the variable, summed and error tolerant mods.
const ms_mascotresfilebase & | getResfile () const
Return a reference to the resfile.
ms_mascotresults_params | getResultsParameters () const
Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.
double | getSequenceMass (const char *seq) const
Return the mass of a sequence (protein or peptide).
virtual int | getTagDeltaRangeEnd (const int q, const int p) const
Return the second number from h1_q2_drange=0,256.
virtual int | getTagDeltaRangeStart (const int q, const int p) const
Return the first number from h1_q2_drange=0,256.
virtual int | getTagEnd (const int q, const int p, const int tagNumber) const
Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagSeries (const int q, const int p, const int tagNumber) const
Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagStart (const int q, const int p, const int tagNumber) const
Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual std::string | getTagString (const int q, const int p) const
Return the complete tag string from h1_q2_tag or q1_p1_tag.
virtual std::string | getTerminalResiduesString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the complete terminal residue string from h1_q1_terms.
bool | getThresholdForFDRAboveHomology (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveHomology (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.
double | getToleranceInDalton (bool &needMass, const double *const pMass=NULL) const
Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.
virtual bool | getTreeClusterNodes (const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, TREE_CLUSTER_METHOD tcm=TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const
Return distances and structure suitable for a dendrogram plot.
ms_peptide | getUnassigned (const int num) const
Need to call createUnassignedList() before calling this.
bool | getUnassignedIsBold (const int num) const
Returns true if the item indexed by num in the assigned list should be bold.
bool | getUnassignedShowCheckbox (const int num) const
Returns true if the item indexed by num in the assigned list should have a check box next to it.
bool | isEmPAIallowed () const
Return true if emPAI could be calculated using data in this results file.
bool | isNA () const
Returns TRUE for a search against a nucelic acid database.
virtual bool | isPeptideUnique (const int q, const int p, const ms_mascotresults::UNIQUE_PEP_RULES rules=ms_mascotresults::UPR_DEFAULT) const
Returns true if this peptide match is unique to one protein or one protein family.
bool | isPmfQueryUsed (const int queryIdx) const
Indicates whether a mass value was used when calculating PMF protein scores.
virtual void | setSubsetsThreshold (const double scoreFraction)
Specifies which subset proteins should be reported.

Protected Member Functions

virtual int | findPeptides (const int startHit, const std::string &str, ms_mascotresults::FIND_FLAGS item, ms_mascotresults::FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const
Find the next hit that contains peptides with the specified attribute.
virtual int | findProteins (const int startHit, const std::string &str, const int dbIdx, ms_mascotresults::FIND_FLAGS item, ms_mascotresults::FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified attributes.
virtual int | findProteinsByAccession (const int startHit, const std::string &str, const int dbIdx, ms_mascotresults::FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified accession.
virtual int | findProteinsByDescription (const int startHit, const std::string &str, ms_mascotresults::FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified description.
double | getIonsScoreCorrected (const double ionsScore, const long multiplicity) const

Detailed Description

Use this class to get protein summary results.

The following functions provide threshold values:

  • getPeptideIdentityThreshold()
  • getAvePeptideIdentityThreshold()
  • getMaxPeptideIdentityThreshold()
  • getPeptideThreshold()
  • getProteinThreshold()
  • getHomologyThreshold()
  • getHomologyThresholdForHistogram()
  • getProbFromScore()
  • getProbOfPepBeingRandomMatch()
  • double getProbOfProteinBeingRandomMatch()

This class inherits from ms_mascotresults, and all the class functions except for getPeptide() are documented in ms_mascotresults.

Examples
repeat_search.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

◆ DB_MATCH_TYPE

enum DB_MATCH_TYPE
inherited

Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram().

Enumerator
DM_FASTA | Mascot matches to FASTA sequences. This is the default.
DM_SPECTRAL_LIBRARY | Matches to spectral library entries. This was introduced in Parser 2.6.
DM_BOTH | Only valid for count of matches (getNumHitsAboveIdentity() and friends): the combined count for FASTA and spectral library entries.
DM_FASTA_FIRST_PASS | Mascot matches to FASTA sequences, first pass only.
DM_FASTA_SECOND_PASS | Mascot matches to FASTA sequences, second pass only (e.g. error tolerant).

◆ DECOY_STATS_COUNT_TYPE

enum DECOY_STATS_COUNT_TYPE
inherited

Type of object counted by getNumHitsAboveIdentity() and friends.

Enumerator
DS_COUNT_PSM | Count peptide-spectrum matches (PSMs). This is the default.
DS_COUNT_SEQUENCE | Count distinct peptide sequences. This was introduced in Parser 2.6.

◆ FIND_COMPARE_FLAGS

enum FIND_COMPARE_FLAGS
inherited

Flags to specify how comparisons are performed in the find functions.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

These flags are used in findProteins(), findPeptides() and the deprecated functions: findProteinsByAccession() and findProteinsByDescription(). The flags are used to specify how the comparison is performed and whether it should be a forward or reverse seach. Typically, three values will be combined together, using an OR operator; however, any default values do not need to be specifically specified.

  • Choose 1 of: FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK
  • Choose 1 of: FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE
  • Choose 1 of: FC_FORWARD, FC_REVERSE
  • Optionally choose FC_RESTRICT_TO_HIT or (FC_LOOP_INTO_UNASSIGNED and/or FC_LOOP_FROM_UNASSIGNED)
  • Optionally choose FC_SEARCH_ALL_RANKS
  • Optionally choose FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES
  • Optionally choose one or more of the FC_PROTEIN_IGN_ flags when calling findProteins()
Enumerator
FC_COMPLETESTR

Search for the complete string. If search item is a decimal number then match the number exactly.

FC_SUBSTR

Search for any substring. Not valid if search item is a decimal number.

FC_STARTSTR

String must match to start of target string. If search item is a decimal number then match to the same decimal precision of the filter value but rounded. For example a filter value of 1234.56 will return items with values in the range (1234.555 >= value < 1234.565).

FC_STRTOK

Supplied string is a set of tokens, for example "STY" could be used to search for S or T or Y in a peptide sequence.

FC_MASK_STR_PART

Bit mask to extract which one of FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK has been specified.

FC_CASE_INSENSITIVE

Case insensitive search (default).

FC_CASE_SENSITIVE

Case sensitive search.

FC_MASK_CASE

Bit mask to extract which one of FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE has been specified.

FC_FORWARD

Forward search. The returned hit number will be the same as or higher than the start hit number. (default).

FC_REVERSE

Reverse search. The returned hit number will be the same as or lower than the start hit number.

FC_MASK_DIRECTION

Bit mask to extract which one of FC_FORWARD, FC_REVERSE has been specified.

FC_RESTRICT_TO_HIT

Don't search beyond the specified hit number. Cannot be used with FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_LOOP_INTO_UNASSIGNED

If no matches are found in the passed hit, or any subsequent hit, then search the unassigned list.

FC_LOOP_FROM_UNASSIGNED

If the passed hit number is 0, and no match is found in the unassigned list, then start searching at 1 if FC_FORWARD is specified or start searching at 'numHits' if FC_REVERSE is specified.

FC_UNASSIGNED_MASK

Bit mask to extract FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_SEARCH_ALL_RANKS

For use with findPeptides() only. Ordinarily only those queries and ranks are searched that are assigned to a protein hit. Use this flag to search all ranks in such queries instead.

FC_ALL_PEPTIDES

Search all peptides regardless of score (default).

FC_ALL_PEPTITDES
Deprecated:
Unfortunate spelling error, please use FC_ALL_PEPTIDES which has an identical value.
FC_SIGNIFICANT_PEPTIDES

Only search peptides above identitity or homology threshold.

FC_SEARCH_IGNORED_RANKS

In integrated library mode, also search peptides that are part of a family member's list of ignored peptides.

FC_SCORING_MASK

Bit mask to extract FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES.

FC_PROTEIN_IGN_SAMESETS

Ignore sameset proteins - only used for findProteins()

FC_PROTEIN_IGN_SUBSETS

Ignore subset proteins - only used for findProteins()

FC_PROTEIN_IGN_FAMILY

Ignore family member proteins - only used for findProteins()

FC_PROTEIN_IGN_MASK

Ignore proteins flags.

FC_PROTEIN_INC_ALT_ACC

For use with findProteins() only. If protein entries in the database are representative (i.e. contain multiple accessions) and those accessions are saved in the results file (Mascot 2.4 or later), setting this flag will search all accessions of each protein entry, not just the first accession.

◆ FIND_FLAGS

enum FIND_FLAGS
inherited

Flags for findPeptides() and findProteins().

Details what needs to be searched for. Any of the FT_PEPTIDE_ flags may be used for either findPeptides() or findProteins(), but the FT_PROTEIN flags may only be used for findProteins()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
FT_PEPTIDE_EXP_MZ | Find an experimental m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_EXP_MR | Find an experimental relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_CALC_MZ | Find a calculated m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_CALC_MR | Find a calculated relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.
FT_PEPTIDE_STRING | Find a peptide string.
FT_PEPTIDE_QUERY | Find a query number.
FT_PEPTIDE_VARMOD | Find a variable modification. Specifiy the modification 'number' as the string.
FT_PEPTIDE_FIXMOD | Find a fixed modification. Specifiy the modification 'number' as the string.
FT_PEPTIDE_ETMOD | Find an error tolerant modification. Specifiy a delta mass as the string.
FT_PEPTIDE_SLMOD | Find a spectral library modification. Specifiy any substring of the mod name as the string.
FT_PEPTIDE_VARMOD_BYNAME | Find a variable or query level modification. Specify any substring of the mod name as the string.
FT_PEPTIDE_FIND_MASK | Bit mask for any of the peptide values to be found.
FT_PROTEIN_ACCESSION | Find an accession - findProteins() only.
FT_PROTEIN_DESCRIPTION | Find a description - findProteins() only.

◆ FLAGS

enum FLAGS
inherited

Flags for the type of results.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Not all of the flags applicable for protein summary (e.g. MSRES_REQUIRE_BOLD_RED); see ms_proteinsummary.

Enumerator
MSRES_NOFLAG | Does nothing.
MSRES_GROUP_PROTEINS | Group proteins with same peptide matches. See Grouping proteins together.
MSRES_SHOW_SUBSETS | Show proteins that only match a subset of peptides. See Grouping proteins together.
MSRES_SUBSETS_DIFF_PROT | Proteins that contain a subset of peptides are treated as a unique protein. See Grouping proteins together.
MSRES_REQUIRE_BOLD_RED | Only proteins that have a top scoring peptide not seen before will be returned.
MSRES_SHOW_ALL_FROM_ERR_TOL | If this flag is set, then all hits from error tolerant search are shown. See Error tolerant searches.
MSRES_IGNORE_PMF_MIXTURE | If this flag is set, then PMF mixtures are ignored. See Peptide mass fingerprint mixtures.
MSRES_MUDPIT_PROTEIN_SCORE | Protein scoring for the peptide summary was changed at Mascot 2.0 for large (MudPIT) searches. See ms_protein::getScore().
MSRES_DECOY | If this flag is set, then use the results from searching against the decoy database. See Target-decoy searches and false discovery rate.
MSRES_INTEGRATED_ERR_TOL | If this flag is set, then create a ms_peptidesummary object that contains results from the summary and et_summary section. See Error tolerant searches.
MSRES_ERR_TOL | If this flag is set, then create a ms_peptidesummary object that contains results from the et_summary section. See Error tolerant searches.
MSRES_MAXHITS_OVERRIDES_MINPROB | If minProbability and maxHitsToReport are both non zero, then minProbability is ignored when determining the number of proteins to be displayed. See ms_mascotresults::ms_mascotresults.
MSRES_CLUSTER_PROTEINS | Protein clustering introduced in Mascot 2.3. See Using MSRES_CLUSTER_PROTEINS.
MSRES_DUPE_INCL_IN_SCORE_NONE | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_A | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_B | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_C | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_D | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_E | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_F | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_G | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_H | See Treatment of duplicate peptides.
MSRES_DUPE_INCL_IN_SCORE_I | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_NONE | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_A | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_B | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_C | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_D | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_E | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_F | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_G | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_H | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_I | See Treatment of duplicate peptides.
MSRES_DUPE_REMOVE_I | See Treatment of duplicate peptides.
MSRES_DUPE_DEFAULT | Default parameter for treatment of duplicates. See Treatment of duplicate peptides.

◆ HOMOLOGY_THRESHOLD_SOURCE

enum HOMOLOGY_THRESHOLD_SOURCE
inherited

Flags for getHomologyThreshold()

The method getHomologyThreshold() accepts either a rank argument or one of the special enumerated values listed here. For backwards compatibility, the integers 1-20 have their own enumerated values.

Enumerator
HOMTHR_FASTA | Retrieve the homology threshold for FASTA matches.
HOMTHR_SL | Retrieve the homology threshold for spectral library matches.

◆ IONS_HISTOGRAM

enum IONS_HISTOGRAM
inherited

Flags for getIonsScoreHistogram().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
IH_INCLUDE_TOP_MATCHES | The default. Just include the top match to each spectrum.
IH_INCLUDE_TOP_10_MATCHES | Instead of just the top match, use the top 10 matches to each spectrum.

◆ QUANT_COMPONENT_STATUS

enum QUANT_COMPONENT_STATUS
inherited

Return codes for getQuantitationComponentForPeptide().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
QCS_OK | The component was retrieved successfully.
QCS_OK_NO_MATCH | The quantitation method's components were searched successfully, no matching component was found.
QCS_ERROR_NO_METHOD | There is no quantitation method available (e.g. for protein summary).
QCS_ERROR_NO_COMPONENTS | There are no components specified in the quantitation method (e.g. for non-precursor method).
QCS_ERROR_BAD_COMPONENT_NAME | The peptide's component name in the Mascot results does not match any component in the quantitation method.
QCS_OK_MULTIPLE_MATCHES | The quantitation method's components were searched successfully, multiple matching components were found.

◆ sortBy

enum sortBy
inherited

Flags for createUnassignedList().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
QUERY | Sort the unassigned list by ascending query number - this is the same as ascending relative mass order.
SCORE | Sort the unassigned list by descending score.
INTENSITY | Sort the unassigned list by descending intensity. Intensity values are taken from the qintensity value in the results file if they are available (from PKL files, or some MGF files). If these values are not available, then the intensity is calculated from the sum of all the ions values. For a very large MS-MS file, this option can take some time to process unless there are qintensity value in the results file.

◆ THRESHOLD_TYPE

enum THRESHOLD_TYPE
inherited

Flags for getPeptideThreshold()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TT_HOMOLOGY | Homology threshold.
TT_IDENTITY | Identity threshold.
TT_PEPSUM_DEFAULT | If ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH is specified in the constructor, then this will resolve to TT_HOMOLOGY, otherwise it will resolve to TT_IDENTITY.

◆ TREE_CLUSTER_METHOD

enum TREE_CLUSTER_METHOD
inherited

Flags for getTreeClusterNodes().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TCM_PAIRWISE_SINGLE | 's': pairwise single-linkage clustering.
TCM_PAIRWISE_MAXIMUM | 'm': pairwise maximum- (or complete-) linkage clustering.
TCM_PAIRWISE_AVERAGE | 'a': pairwise average-linkage clustering.

◆ UNIQUE_PEP_RULES

enum UNIQUE_PEP_RULES
inherited

Flags for isPeptideUnique().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Choose UPR_WITHIN_FAMILY or UPR_WITHIN_FAMILY_MEMBER and then optionally 'or' UPR_IGNORE_SUBSET_PROTEINS

Enumerator
UPR_WITHIN_FAMILY | The peptide is unique if it occurs in proteins that are part of a single family.
UPR_WITHIN_FAMILY_MEMBER | The peptide is unique if it occurs in proteins that just belong to a single family member.
UPR_IGNORE_SUBSET_PROTEINS | Ignore any susbset proteins that contain the match when deciding if a peptide is unique. However, if the peptide just belongs to subset proteins for the same hit, then it is still considered to be unique.
UPR_DEFAULT | Set to UPR_WITHIN_FAMILY_MEMBER | UPR_IGNORE_SUBSET_PROTEINS.

Constructor & Destructor Documentation

◆ ms_proteinsummary() [1/2]

ms_proteinsummary | ( | const ms_mascotresfilebase & | resfile,
 |  | const unsigned int | flags = ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS,
 |  | double | minProbability = 0.0,
 |  | int | maxHitsToReport = 50,
 |  | const char * | unigeneIndexFile = 0,
 |  | const char * | singleHit = 0
 | ) |  |

Call this constructor once to create protein summary results.

Creating an ms_proteinsummary object may take some time for a very large file with a large number of protein hits.

Parameters
resfile | An ms_mascotresfilebase object. See Maintaining object references: two rules of thumb.
flags | can be one or more of the ms_mascotresults::FLAGS values OR'ed together
minProbability specifies a cutoff point for protein scores, a cutoff for an Integrated error tolerant search and a threshold for calculating MudPIT scores.
  • A value of 0 indicates no cutoff - report maxHitsToReport proteins, whatever the protein scores.
  • A value between 0 and 1 is used to calculate a protein score cut-off based on peptide match expect values. With standard protein scoring, 0.05 would discard all proteins with a score less the average score of a peptide with an expect value of 0.05. With MudPIT protein scoring, 0.05 would be the peptide expect value threshold used for calculating the protein scores, and only proteins with non-zero scores are reported. This value is also used to select proteins for an Integrated error tolerant search.
  • A value of less than 0 is not permitted and will be replaced with the default of 0.05.
  • In Mascot Parser 2.2 and earlier, a value between 0.1 and 1.0 was replaced with the default value of 0.05. In Mascot Parser 2.3, any value between 1e-18 and 1.0 is acceptable.
  • A value greater than 1 indicates an absolute score cutoff for proteins, but this is not valid for an Integrated error tolerant search and is not permitted in the standard Mascot Search reports, so is not recommended.
Other points to note:
  • If the flag ms_mascotresults::MSRES_GROUP_PROTEINS is set, then this value applies to the top level proteins - the similar and subset proteins are not 'cutoff' by this value.
  • The cutoff point is the lower of maxHitsToReport and this value, unless the ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB flag is set. With versions of parser before Mascot 2.2, this flag was not available so AUTO in the standard Mascot results reports was implemented by setting this probablility to a (user) defined value and setting maxHitsToReport to a very large number.
maxHitsToReport is a maximum value. There may be fewer hits than this number if minProbability is high, or if there are insufficient results.
  • If the ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB flag is set, then the minProbability value is ignored when determining the number of hits to display. With versions of parser before Mascot 2.2, this flag was not available so a value of 0 was passed as minProbability in the standard Mascot results reports.
  • If the flag ms_mascotresults::MSRES_GROUP_PROTEINS is set, then this value applies to the top level proteins - the similar and subset proteins are not included in the count.
unigeneIndexFile | is an optional file path to a UniGene Index file. This only makes sense if ms_mascotresults::MSRES_GROUP_PROTEINS is set.
singleHit should only be used for getting the results for a single protein quickly. This is used for example by the the protein view report in Mascot, which just shows the matches for a single protein. For the protein summary, pass, for example "3" to get hit 3. See Using the singleHit parameter to return a single protein.
  • From programming languages other than C++, pass an empty string object to specify that all proteins should be used.

◆ ms_proteinsummary() [2/2]

ms_proteinsummary | ( | const ms_mascotresfilebase & | resfile,
 |  | const ms_mascotresults_params & | parameters
 | ) |  |

Call this constructor once to create protein summary results.

Creating an ms_proteinsummary object may take some time for a very large file with a large number of protein hits.

Parameters
resfile | An ms_mascotresfilebase object. See Maintaining object references: two rules of thumb.
parameters | An ms_mascotresults_params object which should contain all of the required values and flags to generate the protein summary.

Member Function Documentation

◆ anyEmPAI()

bool anyEmPAI ( ) const
virtualinherited

Return true if any emPAI values are available.

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns
true if above conditions are true and at least one protein has a non-zero emPAI value.

Reimplemented in ms_peptidesummary.

◆ anyNumDiscoveredMods()

bool anyNumDiscoveredMods ( ) const
virtualinherited

Return true if modification discovery statistics are available.

Modification discovery counts for fixed and variable modifications (and error tolerant modifications in an error tolerant search) are only available if the results file contains a Unimod section. Since only significant rank 1 peptide matches assigned to a protein hit are inspected for modification counting purposes, it is possible for the counts to be zero even when a Unimod section exists.

Returns
True if number of modifications could be counted and there is at least one modification with a non-zero count; false otherwise.

◆ cancelCreateSummary()

void cancelCreateSummary ( bool newValue = true )
inherited

Cancel the call to createSummary()

It is normally recommended that an application should delete the ms_peptidesummary object after calling this function because some objects will still be in memory (no cleanup is performed).

Cancelling may not occur immediately, and the calling application needs to wait for the createSummary() call to return.

See also getCreateSummaryProgress() and ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE

Parameters
newValue should be set to true to cancel the createSummary call

◆ createSummary()

bool createSummary ( )
virtualinherited

Create the summary after the ms_mascotresults object has been created.

Creating an ms_peptidesummary object for a large results file can take a considerable amount of time. The standard Mascot reports do not have an option to 'cancel' the creation of the report and rely on the ms_mascotresfilebase::outputKeepAlive() function to provide progress reports and keep the connection alive. This is not so desireable for a client application that doesn't want to redirect stdout, and wants to allow the user to cancel a long operation. Specify the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag when creating the ms_peptidesummary object, and then use one thread to call this function and a separate thread to call getCreateSummaryProgress() and report progress to the end user.

This function is called directly by the ms_mascotresults constructor unless the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag is specified. If that flag is specified, then the constructor returns 'immediately' and this function must be called by the client code. Until this function returns, the client code in the separate thread can only reliably call the getCreateSummaryProgress(), ms_mascotresfilebase::outputKeepAlive() or cancelCreateSummary() functions. Calling any other function for the ms_mascotresults object may result in undefined behaviour and cause the ms_mascotresfilebase::ERR_RESULTS_NOT_CREATED error to be set.

This function should not be called for a ms_proteinsummary.

Returns
true if successful

Reimplemented in ms_peptidesummary.

◆ createUnassignedList()

bool createUnassignedList ( sortBy s = QUERY )
inherited

To have a list of unassigned peptides, need to call this first.

See Unassigned peptides list for details of creating an unassigned list.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
s order to sort the unassigned list
Returns
Currently always returns true unless createSummary() has not completed
Examples
resfile_summary.cpp.

◆ findPeptides()

int findPeptides | ( | const int | startHit,
 |  | const std::string & | str,
 |  | ms_mascotresults::FIND_FLAGS | item,
 |  | ms_mascotresults::FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< int > & | q,
 |  | std::vector< int > & | p
 | ) |  | const
 protectedvirtual

Find the next hit that contains peptides with the specified attribute.

Note
For a protein summary, this function always returns -1.

Can be used to find peptide-spectrum matches with a specified query number, sequence, mass, or fixed or variable modification. Returns the protein hit number and a list of q,p values that contains one or more string matches to the input string.

In crosslinked searches, both alpha and beta peptides are compared to the search criteria. Only one needs to match the input string.

All subset, sameset and family member proteins are searched, and it is possible that the returned q and p values only correspond to peptides in a single subset protein. The FC_PROTEIN_IGN_SAMESETS, FC_PROTEIN_IGN_SUBSETS and FC_PROTEIN_IGN_FAMILY flags cannot be used with this function. To find proteins which contain particular peptide matches, or to control which proteins to search, see findProteins().

For FT_PEPTIDE_VARMOD , str should contain the modification 'number' as passed to ms_searchparams::getVarModsName(). Modification numbers between 1 and 9 correspond to strings "1" through "9", and numbers between 10 and 32 correspond to "A" through "W". To find all error tolerant modifications, specify "X" and then use ms_peptidesummary::getErrTolModName() to retrieve the name of the modification.

For FT_PEPTIDE_FIXMOD, str should contain the modification 'number' as passed to ms_searchparams::getFixedModsName(). This will be in the range 1-20.

For both types of modification searches, str should only contain a single character. The value for compareFlags should include FC_SUBSTR, because this function is implemented by searching the return value from ms_peptide::getVarModsStr(). Specifying incorrect flags does not generate an error and results in undefined behaviour.

There is an alternative way to search for fixed mods: specify FT_PEPTIDE_STRING and FC_STRTOK as item and compareFlags, respectively, and pass the return value of ms_searchparams::getFixedModsResidues() as the string to search for, str. Although this may seem equivalent to the combination FT_PEPTIDE_FIXMOD and FC_SUBSTR, there are two corner cases where the latter works while the former doesn't:

  • ms_searchparams::getFixedModsResidues() can return "N_term" or "C_term", which are clearly not strings of amino acids.
  • The case where a fixed mod is 'replaced' with a variable mod. For example, if Carbamidomethyl (C) is specified as a fixed mod and Propionamide (C) as variable mod, then it is not sufficient to just check if a peptide contains a cysteine.
Parameters
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1. To search the unassigned list, pass a value of 0.
str | is the string to be matched.
item | is the peptide item to be found (for example, the peptide sequence or mass). Any of the FT_PEPTIDE_ values may be used.
compareFlags | specifies whether the str value is required to match all or just part of the target string. It can also be used to specify a reverse search.
q | is a vector of query values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
p | is a vector of corresponding rank values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains all the returned matched items, or 0 if the match is in the unassigned list, or -1 if there is no match found.

Implements ms_mascotresults.

◆ findProteins()

int findProteins | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | ms_mascotresults::FIND_FLAGS | item,
 |  | ms_mascotresults::FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const
 protectedvirtual

Find the next hit that contains proteins with the specified attributes.

Note
For a protein summary, this function always returns -1.

Used to find accessions, protein descriptions or proteins that have peptide matches with a specified query number, sequence, mass, or fixed or variable modification. Any of the FIND_FLAGS may be used.

The findPeptides() function does not return any information about which subset/sameset/family proteins in a hit contain the found matches. findProteins(), however, returns a list of the protein accessions that contained a peptide match that fits the search criteria, and also allows the searched proteins to exclude samesets (FC_PROTEIN_IGN_SAMESETS), subsets (FC_PROTEIN_IGN_SUBSETS or family members (FC_PROTEIN_IGN_FAMILY).

If protein entries in the database are representative (i.e. contain multiple accessions), by default only the first accession will be considered when FT_PROTEIN_ACCESSION is specified as a search item. If alternative accessions are saved in the results file (Mascot 2.4 or later), setting FC_PROTEIN_INC_ALT_ACC will search all accessions of each protein entry. Note that this will make the search slower.

Parameters
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the string to be matched and depends on the value of item. If item is FT_PROTEIN_ACCESSION, then str will be the accession (or part of one) to be matched. If item is one of the FT_PEPTIDE_ values, then see FIND_FLAGS and findPeptides() for operational details.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
item | is the accession, description or peptide item to be found. For example, return all proteins with a given peptide sequence or mass.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains the matches, or -1 if there is no match found.

Implements ms_mascotresults.

◆ findProteinsByAccession()

int findProteinsByAccession | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | ms_mascotresults::FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const
 protectedvirtual

Find the next hit that contains proteins with the specified accession.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_ACCESSION flag.
Note
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with accessions that match to the the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Parameters
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implements ms_mascotresults.

◆ findProteinsByDescription()

int findProteinsByDescription | ( | const int | startHit,
 |  | const std::string & | str,
 |  | ms_mascotresults::FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const
 protectedvirtual

Find the next hit that contains proteins with the specified description.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_DESCRIPTION flag.
Note
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with descriptions that match the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Descriptions are just those included in the results file. See getProteinDescription() for details of what is loaded into the results.

Parameters
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
compareFlags | specifies whether the str value is required to match all or just part of the description. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implements ms_mascotresults.

◆ freeHit()

void freeHit ( const int hit )
virtualinherited

Frees any memory associated with the passed hit number.

Has no effect except when Using the pepsum cache (MSR and dat28). This function frees the ms_protein objects for the specified hit. The return values from getHit(), getNextFamilyProtein(), getNextSimilarProtein(), getNextSimilarProteinOf(), getNextSubsetProtein() etc. for this hit will then point to deleted objects and hence should not be used.

In addition, any ms_peptide objects loaded into memory using the getPeptide(const int, const int, ms_peptide *&)const function will 'unloaded' if the ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE has been specified. This function has no effect on the ms_peptide objects returned from the alternative getPeptide(const int, const int)const function.

Parameters
hit should be in the range 1.. getNumberOfHits().

Reimplemented in ms_peptidesummary.

◆ getAllFamilyMembersWithThisPepMatch()

int getAllFamilyMembersWithThisPepMatch | ( | const int | hit,
 |  | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | db,
 |  | std::vector< std::string > & | acc,
 |  | std::vector< int > & | dupe_status
 | ) |  | const
 virtual

Return a list of (top level) family proteins that have a match to the specified q and p.

Only the top level proteins are returned by this function, that is, the proteins that would be returned by getHit() and getNextFamilyProtein(). It will be considerably faster than calling ms_protein::getPeptideQuery() and related functions, because that involves loading more information from the cache and from the .dat file.

This function will return the values rapidly when caching is enabled; see Using the pepsum cache (MSR and dat28). It also functions correctly when not using the cache.

The returned vectors are all guaranteed to have the same number of elements. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use them from programming languages other than C++.

See also
getAllProteinsWithThisPepMatch() and getProteinsWithThisPepMatch()
Parameters
hit | Should be in the range 1.. getNumberOfHits().
q | is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
db | is a vector of database IDs.
acc | is the corresponding vector of accessions.
dupe_status | is the corresponding vector of ms_protein::DUPLICATE values for the returned proteins. Note that ms_protein::DUPE_Ignored will only appear in integrated library searches where the peptide match was removed due to IgnoreIonsScoreBelow.
Returns
The number of proteins in the db/acc/dupe_status vectors.

Implements ms_mascotresults.

◆ getAllProteinsWithThisPepMatch() [1/2]

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db
 | ) |  | const
 virtual

Return a complete list of proteins that contain this same peptide match.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

Crosslink searches only: If you need to know whether the accessions come from the alpha or beta peptide, use the 10-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also
getProteinsWithThisPepMatch()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues – one for each accession
end | Returns a vector of the end residues – one for each accession
pre | Returns a vector of the residue before the peptide – one for each accession
post | Returns a vector of the residue after the peptide – one for each accession
frame | Returns a vector of the frames – one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities – one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
Returns
A list of all the accessions that contained the peptide matched by this result.

Implements ms_mascotresults.

◆ getAllProteinsWithThisPepMatch() [2/2]

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db,
 |  | std::vector< int > & | psmComponent
 | ) |  | const
 virtual

Return a complete list of proteins that contain this same peptide match.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

This method was added in Parser 2.7 for crosslinking support. If you don't need to know whether the accessions come from the alpha or beta peptide, you can use the 9-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also
getProteinsWithThisPepMatch()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues – one for each accession
end | Returns a vector of the end residues – one for each accession
pre | Returns a vector of the residue before the peptide – one for each accession
post | Returns a vector of the residue after the peptide – one for each accession
frame | Returns a vector of the frames – one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities – one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
psmComponent | Returns a vector of psmComponent markers (ms_peptide::PSM) – one for each accession. For a crosslinked match, this will be one of ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA. In all other types of match, it will always be ms_peptide::PSM_COMPLETE.
Returns
A list of all the accessions that contained the peptide matched by this result.

Implements ms_mascotresults.

◆ getAvePeptideIdentityThreshold()

int getAvePeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtualinherited

Return the average threshold value for all MS-MS data sets.

The average value is calculated by taking the mean value from calling getPeptideIdentityThreshold() for each query. This is the value that is used to be shown at the top of the standard Mascot reports in versions before Mascot 2.0. For example, threshold in the following string could be calculated by calling getAvePeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot score threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
The average score threshold. If there was no MS-MS data then -1 will be returned.

◆ getComponentIntensity()

bool getComponentIntensity | ( | const int | q,
 |  | const int | p,
 |  | const std::string & | componentName,
 |  | double & | value,
 |  | double & | rawValue
 | ) |  | const
 virtual

Returns the component intensity for reporter or multiplex methods.

This function will only succeed for MS2 based quantitation methods such as "reporter" and "multiplex" where the required data is in the .dat file. It is up to the calling application to check that this is the case using ms_mascotresfilebase::getQuantitationMethod and ms_quant_method::getProtocol

This function was added in Mascot Parser 2.5. If the calling application is Using the pepsum cache (MSR and dat28) and the cache files were created with Mascot Parser 2.4 or earlier, then this function will calculate the intensities on demand. The first call to this function causes values for the whole file to be calculated, which may be slow. With new cache files, all the values are saved in the cache file.

This function will only calculate values for cases where ms_quant_helper::isPeptideQuantifiable returns ms_quant_helper::PEPTIDE_IS_QUANTIFIABLE

For a particular q,p pair there will always be values for all components or for no components. There can never be a case where there is just a value available for a subset of the components.

Parameters
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue(). For "reporter" protocols, this must be 1.
componentName | is the name of the component as defined in the method. For example, for iTRAQ this might be "114", and for one of the SILAC methods this might be "Heavy".
[out] | value | is the corrected intensity value. Corrections are applied as specified in the method included in the results file.
[out] | rawValue | is the uncorrected intensity value.
Returns
false if the method is unable to calculate or determine an intensity value for the specified q and p values

Implements ms_mascotresults.

◆ getComponentProtein()

const ms_protein * getComponentProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const
 virtualinherited

Return a pointer to the protein entry given an accession.

Only use this function for the "components" of a UniGene search. It will generally be more convenient for client applications to call ms_protein::getComponent() to get an ms_protein object, both in UniGene searches and PMF mixture searches.

Parameters
accession | is the accession string.
dbIdx | a database index (1..ms_searchparams::getNumberOfDatabases()).
Returns
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

◆ getComponentString()

std::string getComponentString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const
 virtual

Return an empty string.

Note
This function will always return the empty string for a protein summary.

The entry in the results file might be, for example:

   q1_p2_comp=light

For a crosslinked match, the results file line is q1_p1_comp_1= or q1_p1_comp_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

See also ms_peptide::getComponentStr().

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'rank' number, which should be in the range 1..10.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns
the full component string for a peptide summary, and the empty string for a protein summary.

Implements ms_mascotresults.

◆ getCreateSummaryProgress()

bool getCreateSummaryProgress | ( | int * | cspTotalPercentComplete,
 |  | unsigned int * | cspCurrTask,
 |  | int * | cspCurrTaskPercentageComplete,
 |  | std::string * | cspAccession,
 |  | int * | cspHit,
 |  | int * | cspQuery,
 |  | std::string * | cspKeepAliveText
 | ) |  | const
 inherited

Return progress for the createSummary() call.

See Multiple return values in Perl, Java, Python and C#.

This function is most useful when using the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag and calling createSummary() from a separate thread. The ms_mascotresfilebase::outputKeepAlive() outputs progress text to stdout, and this may not be convenient for some applications.

Any of the passed parameters may be null.

Parameters
[out] | cspTotalPercentComplete | is simply calculated from: 100 * cspCurrTask / ms_mascotresfilebase::KA_LAST + cspCurrTask / ms_mascotresfilebase::KA_LAST
[out] | cspCurrTask | is the ms_mascotresfilebase::KA_TASK currently being performed by Mascot Parser. If Parser is doing nothing, then this will be the last task that was completed and cspCurrTaskPercentageComplete will be 100
[out] | cspCurrTaskPercentageComplete | is the percentage (0..100) complete for the current cspCurrTask.
[out] | cspAccession | is the current 'accession' being processed. See ms_mascotresfilebase::outputKeepAlive() for details of which tasks set this value. For languages other than C++, this will be a reference rather than a pointer to a std::string.
[out] | cspHit | is the current hit being processed. See ms_mascotresfilebase::outputKeepAlive() for details of which tasks set this value
[out] | cspQuery | is the current 'query' being processed. See ms_mascotresfilebase::outputKeepAlive() for details of which tasks set this value
[out] | cspKeepAliveText | is the text that would be output by ms_mascotresfilebase::outputKeepAlive(). To use this, specify a suitable keepAliveText to the ms_mascotresfilebase constructor but set keepAliveInterval to zero to prevent any output to stdout. For languages other than C++, this will be a reference rather than a pointer to a std::string.
Returns
true if the createSummary() call has completed.

◆ getDiscoveredErrTolModDeltas()

std::vector< double > getDiscoveredErrTolModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const
virtualinherited

Return the deltas of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification deltas. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

The list of error tolerant modification deltas is most useful when used in combination with getNumDiscoveredErrTolMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredErrTolModNames()

Nucleic acid insertion, deletion and substitution whose special names are NA_INSERTION, NA_DELETION and NA_SUBSTITUTION have a delta of 0.0.

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns
A vector of error tolerant modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getDiscoveredErrTolModNames()

std::vector< std::string > getDiscoveredErrTolModNames ( ) const
virtualinherited

Return the names of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification names. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted. Nucleic acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

The list of error tolerant modification names is most useful when used in combination with getNumDiscoveredErrTolMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns
A vector of error tolerant modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getDiscoveredLocalModDeltas()

std::vector< double > getDiscoveredLocalModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const
virtualinherited

Return the deltas of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredLocalModNames()

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns
A vector of query-level modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getDiscoveredLocalModNames()

std::vector< std::string > getDiscoveredLocalModNames ( ) const
virtualinherited

Return the names of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns
A vector of query-level modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.

◆ getErrTolModDelta()

double getErrTolModDelta | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL,
 |  | std::string * | deltaAsString = NULL
 | ) |  | const
 virtualinherited

Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification delta will be 0.984020. In general, modification delta could be any valid floating point number, including 0.0.

See also
getErrTolModName(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the delta directly
deltaAsString
Returns
The modification delta.

◆ getErrTolModifiedNaSeq()

std::string getErrTolModifiedNaSeq | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the modified sequence of nucleic acids after a single base modification in an error tolerant search.

If an error tolerant search was made against a nucleic acid database, and if the NA sequence had an unsuspected insertion, deletion or substitution, then this method returns the modified NA sequence before translation.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'hit' or 'rank' number.
Returns
the modified sequence of nucleic acids before a single base modification in an error tolerant search

◆ getErrTolModMasterNeutralLoss()

std::vector< double > getErrTolModMasterNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p1_et_mods_master might be

   q1_p1_et_mods_master=1.0,2.0

The returned list will not contain the dominant neutral loss – that can be retrieved using getErrTolModNeutralLoss().

See also
getErrTolModSlaveNeutralLoss() and getErrTolModNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification additional primary neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModMasterString()

std::string getErrTolModMasterString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete error tolerant mod primary neutral loss string from h1_q1_et_mods_primary.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_master might be
       q1_p2_et_mods_master=1.0,2.0
  • The entry in h1_q2_et_mods_master might be
       h1_q2_et_mods_master=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModMasterNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant master neutral loss string.

Implements ms_mascotresults.

◆ getErrTolModName()

std::string getErrTolModName | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL
 | ) |  | const
 virtualinherited

Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification name will be Citrullination.

See also
getErrTolModDelta(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the name directly
Returns
The modification name, or empty string if this match has no ET modification.

◆ getErrTolModNeutralLoss()

double getErrTolModNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than 10 of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods might be

   q1_p1_et_mods=79.966330,97.976898,Phospho (STY)

where the highest scoring modification neutral loss, returned by this function is 97.976898.

See also
getErrTolModName(), getErrTolModDelta(), getReadableVarMods(), getErrTolModMasterNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification neutral loss value.

◆ getErrTolModPepNeutralLoss()

std::vector< double > getErrTolModPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.

Some modifications specify one or more peptide neutral losses. PepNeutralLoss allows a neutral loss from the precursor to be specified so that this peak is not treated as a noise peak when being scored by Mascot. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_pep might be

   q1_p1_et_mods_pep=97.976896, 79.966330
See also
getErrTolModReqPepNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification peptide neutral loss values as a vector of doubles See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModPepString()

std::string getErrTolModPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete error tolerant mod peptide neutral loss string from h1_q1_et_mods_pep.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_pep might be
       q1_p2_et_mods_pep=1.0,2.0
  • The entry in h1_q2_et_mods_pep might be
       h1_q2_et_mods_pep=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModPepNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant peptide neutral loss string.

Implements ms_mascotresults.

◆ getErrTolModReqPepNeutralLoss()

std::vector< double > getErrTolModReqPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.

Some modifications specify one or more required peptide neutral losses. ReqPepNeutralLoss performs the same function as PepNeutralLoss but with the additional condition that the peak must be present in the spectrum. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_reqpep might be

   q1_p1_et_mods_reqpep=97.976896, 79.966330
See also
getErrTolModPepNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification required peptide neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModReqPepString()

std::string getErrTolModReqPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete error tolerant mod required peptide neutral loss string from h1_q1_et_mods_reqpep.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_reqpep might be
       q1_p2_et_mods_reqpep=1.0,2.0
  • The entry in h1_q2_et_mods_reqpep might be
       h1_q2_et_mods_reqpep=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModReqPepNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant required peptide neutral loss string.

Implements ms_mascotresults.

◆ getErrTolModSlaveNeutralLoss()

std::vector< double > getErrTolModSlaveNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_slave might be

   q1_p2_et_mods_slave=1.0,2.0
See also
getErrTolModMasterNeutralLoss(), getErrTolModNeutralLoss()
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
The modification slave neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrTolModSlaveString()

std::string getErrTolModSlaveString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete error tolerant mod slave neutral loss string from h1_q1_et_mods_slave.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_slave might be
       q1_p2_et_mods_slave=1.0,2.0
  • The entry in h1_q2_et_mods_slave might be
       h1_q2_et_mods_slave=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModSlaveNeutralLoss().

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant slave neutral loss string.

Implements ms_mascotresults.

◆ getErrTolModString()

std::string getErrTolModString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods might be
       q1_p2_et_mods=0.984020,0.000000,Citrullination
  • The entry in h1_q2_et_mods might be
       h1_q2_et_mods=0.984020,0.000000,Citrullination

This function returns the complete string value. More useful functions are

  • ms_mascotresults::getErrTolModName(),
  • ms_mascotresults::getErrTolModDelta(),
  • ms_mascotresults::getErrTolModNeutralLoss() and
  • ms_mascotresults::getReadableVarMods(),

all of which will work for both the protein summary and the peptide summary.

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete error tolerant modification string.

Implements ms_mascotresults.

◆ getErrTolOriginalNaSeq()

std::string getErrTolOriginalNaSeq | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtualinherited

Return the original sequence of nucleic acids before a single base modification in an error tolerant search.

If an error tolerant search was made against a nucleic acid database, and if the NA sequence had an unsuspected insertion, deletion or substitution, then this method returns the original NA sequence before translation.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the 'hit' or 'rank' number.
Returns
the original sequence of nucleic acids before a single base modification in an error tolerant search

◆ getErrTolProbabilityThreshold()

double getErrTolProbabilityThreshold ( ) const
virtualinherited

For a protein summary, this method always returns the same value as getProbabilityThreshold().

Error tolerant matches in an integrated error tolerant search can have a different probability threshold (significance threshold) from first pass peptide matches. The first pass matches always use getProbabilityThreshold() as the significance threshold, and second pass matches always use getErrTolProbabilityThreshold().

The error tolerant significance threshold is determined using ms_mascotresults_params::getTargetFDR(). If a target FDR is specified and the search is an error tolerant target-decoy search, the probability threshold is chosen such that error tolerant matches have false discovery rate (FDR) equal to the target or as close as feasible. If the search is not a target-decoy search or target FDR is not specified, the error tolerant significance threshold is the same as the first pass significance threshold.

See also
getProbabilityThreshold(), Error tolerant searches
Returns
probability threshold for error tolerant matches.

◆ getFlags()

unsigned int getFlags ( ) const
inherited

Returns the flags value passed to the constructor.

Returns
the ms_mascotresults::FLAGS value.

◆ getFlags2()

unsigned int getFlags2 ( ) const
inherited

Return the flags2 value passed to the ms_peptidesummary constructor.

For an ms_proteinsummary, will always return 0 as there is no option to set the flags2 value.

Returns
the ms_peptidesummary::MSPEPSUM value.

◆ getHit()

ms_protein * getHit | ( | const int | hit,
 |  | const int | memberNumber = 0
 | ) |  | const
 virtualinherited

Return the ms_protein hit - returns null if hit > number of hits.

Parameters
hit | should be in the range 1.. getNumberOfHits().
memberNumber | Should be 1 or less for a main protein or one not in a family, or 2 or more for later sibling proteins in the hit family. If this number is greater than the number of proteins in the hit family then the function returns a null value.
Returns
If the hit number is outside the range above, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

Examples
peptide_list.cpp, and resfile_summary.cpp.

◆ getHomologyThreshold()

int getHomologyThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1
 | ) |  | const
 virtualinherited

Returns the 'homology' threshold.

For MS-MS data only, this returns a threshold value for significant homology rather than identity. This value appears in the yellow popup box for an MS-MS result: Score greater than XX indicates homology.

The return value will be zero if the threshold is not available. The value cannot be determined if the query contains error tolerant matches, or if the query contains a tag or etag, or if the value of qmatch is less than or equal to 100.

The value returned will not be higher than the identity threshold.

In versions prior to 2.2, the homology threshold was not affected by OneInXprobRnd – this was corrected in version 2.2.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. You can either pass ms_peptide::getRank() as the rank parameter, or use one of the enumerated values for HOMOLOGY_THRESHOLD_SOURCE. The rank determines the data source.

In an integrated spectral library search:

  • If rank = HOMTHR_FASTA, the method returns the FASTA homology threshold.
  • If the peptide at the given rank is from a FASTA database and is not a library match, the method returns the FASTA homology threshold.
  • If rank = HOMTHR_SL, the method returns zero (since library searches don't have a homology threshold).
  • If the peptide at the given rank is from a spectral library, the method returns zero.

In an integrated error tolerant search, behaviour depends on Mascot version. If the results file is from Mascot 2.8 or later:

  • If the query was selected for the second pass search, the method returns zero regardless of the rank argument.
  • If the query was only searched in the first pass, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().

If the integrated error tolerant search is from Mascot 2.7 or earlier:

  • If rank = HOMTHR_FASTA, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().
  • If the peptide at the given rank is a first pass match, the method returns the first pass homology threshold.
  • If the peptide at the given rank is an ET match, the method returns 0.
Parameters
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
Returns
The homology threshold. If there was no MS-MS data for this query then 0 will be returned.
Examples
resfile_summary.cpp.

◆ getHomologyThresholdForHistogram()

int getHomologyThresholdForHistogram | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtualinherited

Returns the value for the 'yellow section' in the histogram.

For MS-MS data only, this returns a homology (rather than identity) threshold value that is shown at the top of the report: Individual ions scores > 19 indicate peptides with significant homology (p<0.05).

The yellow area on the histogram also corresponds to this value.

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot homology threshold. If dbType is DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
The homology threshold. Note that this value is only available for an MS-MS search with just one MS-MS data set, otherwise the return value will be zero.

◆ getIonsScore()

double getIonsScore | ( | const int | q,
 |  | const int | p,
 |  | const bool | decoy
 | ) |  | const
 virtual

Returns an ions score quickly without having to load an ms_peptide object.

If other values are required from the ms_peptide object, then it is normally faster to call getPeptide() and then ms_peptide::getIonsScore

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
decoy is a flag to indicate if the score should be taken from the decoy section. This should only be set to true for searches with decoy matches.
Returns
the score, or 0 if there was no score for these q / p values.

Implements ms_mascotresults.

◆ getIonsScoreCorrected()

double getIonsScoreCorrected | ( | const double | ionsScore,
 |  | const long | multiplicity
 | ) |  | const
 protectedinherited
Note
It shouldn't be necessary to call this function from outside the library.

This function is required here rather than as part of the ms_peptide object because one ms_peptide object can be used from many different proteins – each with a different multiplicity factor.

This function subtracts the factor:

  • -10 * log(multiplicity) * $tolFact / log(10); where
  • tolFact = sqrt(ITOL * ITOL + 0.0625);
Parameters
ionsScore | Is the uncorrected ions score.
multiplicity | can be obtained from ms_protein::getPeptideMultiplicity.
Returns
The corrected value..

◆ getIonsScoreHistogram()

std::vector< int > getIonsScoreHistogram | ( | IONS_HISTOGRAM | flags = IH_INCLUDE_TOP_MATCHES,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtualinherited

Returns a list of counts for binned ions scores.

  • The first element of the array returns the count of matches with a score between 0 and 1.
  • The second element of the array returns the count of matches with a score between 1 and 2.
  • The third element of the array returns the count of matches with a score between 2 and 3. etc. etc.
Parameters
flags | Currently only IH_INCLUDE_TOP_MATCHES and IH_INCLUDE_TOP_10_MATCHES are supported.
dbType | If given, should be DM_FASTA for Mascot scores and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, empty vector is returned.)
Returns
a vector of integers. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getLibraryModString()

std::string getLibraryModString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the modification string of the spectral library match from q1_p1_SLmod.

The modification string has the format

 q1_p1_SLmod=position:mod,position:mod,...

where position is a 1-based index into the peptide sequence and mod is a numeric index into the spectral_library section of the results file. The modification name and delta can be found with ms_searchparams::getLibraryModName() and ms_searchparams::getLibraryModDelta().

Note that position 1 is the first residue of the peptide sequence, which is the same convention as with ms_peptide::getVarModsStr(). However, MSPepSearch reports terminal modifications as modifications on the first and last residue. Positions 0 and N+1 (if sequence length is N) are reserved for future use.

For Mascot matches, the library modification string is empty.

In protein summary, this method always returns the empty string.

See also
Spectral libraries.
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | is the rank number.
Returns
modification string of the match if it is a spectral library match and has modifications, and empty string otherwise.

Implements ms_mascotresults.

◆ getMaxPeptideIdentityThreshold()

int getMaxPeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtualinherited

Return the max threshold value for all MS-MS data sets.

The maximum value is calculated by taking the maximum value returned by calling getPeptideIdentityThreshold() for each query. This is the value that is shown at the top of the standard Mascot peptide summary report (version 2.0 and later). For example, threshold in the following string could be calculated by calling getMaxPeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Versions of Mascot prior to 2.0 displayed the equivalent of getAvePeptideIdentityThreshold().

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
The maximum score threshold. If there was no MS-MS data then -1 will be returned.

◆ getMaxRankValue()

int getMaxRankValue ( ) const
virtualinherited

Returns the maximum 'rank' or 'hit' or 'p' value.

For functions such as getPeptide(), a 'rank' or 'hit' value is required. The allowable range for this values depends on whether it is a protein summary or peptide summary.

For a peptide summary the value returned will normally be 10, but for an integrated error tolerant search, integrated spectral library search and integrated crosslinked search, this can be in the range 1..20.

For a protein summary the return value will be ms_mascotresfilebase::getNumHits() – with the appropriate parameter passed for the case of a decoy or error tolerant search.

Returns
max rank value

◆ getMinPepLenInPepSummary()

int getMinPepLenInPepSummary ( ) const
inherited

Peptides shorter than this are ignored when putting proteins into groups.

minPepLenInPepSummary is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins together.

Specify this value when creating an ms_peptidesummary::ms_peptidesummary object. This value will always be zero for ms_proteinsummary.

Returns
The minimum peptide length considered when creating the peptide summary.

◆ getNextFamilyProtein()

ms_protein * getNextFamilyProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const
 virtualinherited

Find the next protein in the family masterHit.

Call this function multiple times for each masterHit, incrementing id each time. When there are no more protein families this function will return a null value.

The main protein for the hit should be obtained by calling ms_mascotresults::getHit()

See Using MSRES_CLUSTER_PROTEINS for further information.

See also
ms_protein::GROUP
Parameters
masterHit | is the id for the main hit (1..n).
id | is a 'one based' number.
Returns
The next protein family or a null value if there is no such group. See Maintaining object references: two rules of thumb.
Examples
resfile_summary.cpp.

◆ getNextSimilarProtein()

ms_protein * getNextSimilarProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const
 virtualinherited

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP
Parameters
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
Returns
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.

◆ getNextSimilarProteinOf()

ms_protein * getNextSimilarProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const
 virtualinherited

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP
Parameters
masterAccession | is the accession for the main hit.
masterDB | is the database (FASTA) ID for the main hit.
id | is a 'one based' number.
Returns
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.
Examples
resfile_summary.cpp.

◆ getNextSubsetProtein()

ms_protein * getNextSubsetProtein | ( | const int | masterHit,
 |  | const int | id,
 |  | const bool | searchWholeFamily = true
 | ) |  | const
 virtualinherited

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP, getNextSubsetProteinOf()
Parameters
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
searchWholeFamily | only has meaning when MSRES_CLUSTER_PROTEINS is specified. See Using MSRES_CLUSTER_PROTEINS.
Returns
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.

◆ getNextSubsetProteinOf()

ms_protein * getNextSubsetProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const
 virtualinherited

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information.

Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also
ms_protein::GROUP, getNextSubsetProtein()
Parameters
masterAccession | is the accession for the master hit or a family hit.
masterDB | is the database (fasta) ID for the main hit.
id | is a 'one based' number.
Returns
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.
Examples
resfile_summary.cpp.

◆ getNumberOfFamilyMembers()

int getNumberOfFamilyMembers ( ) const
virtualinherited

Return the total number of family members.

Returns
This function returns the number of 'top level' hits and family members, not taking into account any proteins that are identical or subsets of these hits. The value will be identical to that returned by getNumberOfHits() unless the ms_mascotresults::MSRES_CLUSTER_PROTEINS flag has been specified. In that case the number of values returned by getNextFamilyProtein() will be included.

◆ getNumberOfHits()

int getNumberOfHits ( ) const
virtualinherited

Returns the number of hits in the results.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
This function returns the number of 'top level' hits – not taking into account any proteins that are identical or subsets of the 'top level' hits. ms_mascotresults::getHit() can be called with any number from 1 to the value returned by this function.

◆ getNumberOfUnassigned()

int getNumberOfUnassigned ( ) const
inherited

Return the number of peptides in the unassigned list.

See Unassigned peptides list for details of creating and using an unassigned list.

If there is no cache file for the results, then createUnassignedList() must be called before calling this function or the ms_errs::ERR_UNASSIGNED_PROG error will be set, and this function will return 0.

If a cache file has been created, then there is no requirement to call createUnassignedList() before calling this function.

Returns
the number of peptides in the unassigned list, or 0 in the case of an error.
Examples
resfile_summary.cpp.

◆ getNumDecoyHitsAboveHomology()

long getNumDecoyHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtualinherited

Return the number of hits from the decoy search with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold(). These values may be slightly different from the threshold for the non-decoy matches.

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

y* The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of decoy hits with a score at or above the homology threshold.

◆ getNumDecoyHitsAboveIdentity()

long getNumDecoyHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtualinherited

Return the number of hits from the decoy search with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold(). This value may be slightly different from the threshold for the non-decoy matches.

For a protein summary, the number of hits is the number of protein matches. This number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of decoy hits with a score at or above the identity threshold.

◆ getNumDiscoveredErrTolMods()

std::vector< int > getNumDiscoveredErrTolMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtualinherited

Return the count of error tolerant modifications discovered in this search.

The number of times an error tolerant modification has been discovered in the search is the number of times it appears in rank 1 matches in the search results. Since the number and kind of error tolerant modifications is (practically) unlimited, you should call getDiscoveredErrTolModNames() first to find out which error tolerant modifications appear in the search. (The count of error tolerant modifications that do not appear in the search is, of course, zero.) Amino acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

Only significant rank 1 matches assigned to a protein hit are counted. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the error tolerant modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
modName | Error tolerant modification name (as returned by getDiscoveredErrTolModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the error tolerant modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredFixedMods()

std::vector< int > getNumDiscoveredFixedMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtualinherited

Return the count of fixed modifications discovered in this search.

The number of times a fixed modification has been discovered in the search is the number of times the terminus or residue matching its specificity appears in significant rank 1 matches assigned to a protein hit in the search results. For example, if Carbamidomethyl (C) is specified as a fixed modification, then the number of times it has been discovered in the search is the number of C residues in peptide sequences in significant rank 1 matches assigned to a protein hit.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the fixed modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a fixed modification with two different specificities in the search, discovery counts will be returned separately. For example, if fixed modification 1 is Carbamidomethyl (C) and 2 is Carbamidomethyl (N-term), then calling getNumDiscoveredFixedMods() with num = 1 returns the Carbamidomethyl count for specificity "Anywhere" and "C", while num = 2 returns the count for specificity "Any N-term" and "N-term". In both cases each vector contains a single item.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
num | Fixed modification number (same value as passed to ms_searchparams::getFixedModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the fixed modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredIntactLinks()

std::vector< int > getNumDiscoveredIntactLinks | ( | std::vector< int > & | varModNum1,
 |  | std::vector< std::string > & | position1,
 |  | std::vector< std::string > & | site1,
 |  | std::vector< int > & | varModNum2,
 |  | std::vector< std::string > & | position2,
 |  | std::vector< std::string > & | site2,
 |  | std::vector< int > & | numLinkedPeptides
 | ) |  | const
 inherited

Return the count of intact crosslinks in this search.

The number of times an intact crosslink has been discovered in the search is the number of times it appears as the intact link in significant rank 1 matches assigned to a protein hit.

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the link occurred, while varModNum1, position1 and site1 have the variable mod number, position and site of the first end of the link and varModNum2, position2 and site2 have the second end.

For example, if the ith specificity is N-terminal K, the ith element of alphaPositions would be "Any N-term" and the ith element of alphaSites would be "K".

In the simplest case, there is one linker with one specificity, say Xlink:DSS (K). All the vectors have just one element. If the linker has two specificities, like Xlink:DSS (K) and Xlink:DSS (Protein N-term), there will be three site pairs: (K, K), (K, Protein N-term) and (Protein N-term, Protein N-term). The pair (Protein N-term, K) is collated with (K, Protein N-term).

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
varModNum1 | Variable modification number for the first end of link.
position1 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site1 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
varModNum2 | Variable modification number for the second end of link.
position2 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site2 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
numLinkedPeptides | A vector containing the number of linked peptides corresponding to each count. Looplinked counts have 1 peptide, while crosslinked counts have 2 peptides.
Returns
The number of times the intact link was observed in significant rank 1 matches assigned to a protein hit.

◆ getNumDiscoveredLibraryMods()

std::vector< int > getNumDiscoveredLibraryMods | ( | const int | modId,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 inherited

Return the count of library modifications discovered in this search.

The number of times a library modification has been discovered in the search is the number of times it appears in the library mods string in significant rank 1 spectral library matches assigned to a protein hit in the search results.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the library modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that modifications are part of the metadata of spectral library entries. Unlike in database searches, they are not specified as part of the search parameters. Some caveats apply:

  • A library modification may have the same name as a variable or fixed modification in the database search, and they may well be the same modification – but you need to know how the library was constructed to conclude either way.
  • Library modification name is usually a free-text string, which may or may not be a Unimod modification name.
  • The MSP format for spectral libraries does not support specifities in the same way as Mascot. The "position" of the modification is not encoded in the library and is thus unknown; it will always be Anywhere.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
modId | modification ID, same as passed to ms_searchparams::getLibraryModName(). Must be in range 1..ms_searchparams::getNumberOfLibraryMods().
positions | A vector of positions, always "Anywhere".
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the library modification was observed in significant rank 1 spectral library matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredLocalMods()

std::vector< int > getNumDiscoveredLocalMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtualinherited

Return the count of query-level modifications discovered in this search.

The number of times a query-level modification has been discovered in the search is the number of times it appears in significant rank 1 matches assigned to a protein hit in the search results.

Query-level modifications are counted separately from variable modifications (specified at search form level), because each individual query may contain up to 32 query-level variable modifications. This means the search as a whole may contain more than 32 different query-level modifications. You should call getDiscoveredLocalModNames() first to find out which query-level modifications appear in the search.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the query-level modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that only significant rank 1 matches assigned to a protein hit are counted.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
modName | Query-level modification name (as returned by getDiscoveredLocalModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the query-level modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredNonSpecCleavage()

int getNumDiscoveredNonSpecCleavage ( ) const
virtualinherited

Return the count of non-specific cleavages in an error tolerant search.

An error tolerant match is the product of non-specific cleavage when the residue before or after the peptide terminal residue does not match the cleavage specificity of the enzyme. For example, trypsin cleaves at C-term K or R (unless followed by P), so all tryptic peptide sequences have K or R as the (N-term) residue before the sequence. An error tolerant match with non-specific cleavage would have a residue other than K or R at N-terminus.

Only significant rank 1 matches assigned to a protein hit contribute towards the count of non-specific cleavages. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the match is not counted.

Returns
The number of times non-specific cleavage occurred in significant rank 1 matches assigned to a protein hit, or -1 for non-error tolerant search.

◆ getNumDiscoveredVariableMods() [1/2]

std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const
 virtualinherited

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

See also
getNumDiscoveredVariableMods(const int, std::vector<std::string>&, std::vector<std::string>&, std::vector<delta>&, std::vector<std::string>&) const
Parameters
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumDiscoveredVariableMods() [2/2]

std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites,
 |  | std::vector< double > & | deltas,
 |  | std::vector< std::string > & | names
 | ) |  | const
 virtualinherited

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

The ith element in the deltas and names vectors defines the delta and name of the modification, respectively. If the search has no crosslinking method, these two parameters can be ignored. When the modification number num refers to a crosslinker, the the deltas and names vectors contain values for all monolinks represented by the entry.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
deltas | A vector of deltas.
names | A vector of names.
Returns
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.

◆ getNumHitsAboveHomology()

long getNumHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtualinherited

Return the number of hits with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold().

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of hits with a score at or above the homology threshold.

◆ getNumHitsAboveIdentity()

long getNumHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  |
virtualinherited

Return the number of hits with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold().

For a protein summary, the number of hits is the number of protein matches. The number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions make take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns
The number of hits with a score at or above the identity threshold.

◆ getNumPmfQueriesUsed()

int getNumPmfQueriesUsed ( ) const

Returns number of queries (masses) used when calculating PMF protein scores.

See isPmfQueryUsed() for a detailed explanation.

Returns
The number queries (masses) used for calculating protein scores.

◆ getPepsWithSameScore()

std::vector< int > getPepsWithSameScore | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Returns a list of 'p' values for peptides with the same score.

Peptides with the same score will have the same pretty rank. See ms_peptide::getPrettyRank() for details.

It is preferable to call this function rather than to loop through all the ranks calling getPeptide() for each one because the cached index stores the pretty ranks and this should therefore be faster.

For a protein summary, the returned list always contains a single value that is the same as the passed p value.

Parameters
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue().
Returns
a list of the ranks that have the same pretty value. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Implements ms_mascotresults.

◆ getPeptide() [1/2]

ms_peptide getPeptide | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return a peptide object for the specified query / hit.

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfilebase::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
an ms_peptide object.

Implements ms_mascotresults.

◆ getPeptide() [2/2]

bool getPeptide | ( | const int | q,
 |  | const int | p,
 |  | ms_peptide *& | pep
 | ) |  | const
 virtual

Return a peptide object for the specified query / hit.

Note
This function can not be used in programming languages other than C++.

To get the q and p values for a peptide in an ms_protein, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfilebase::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries()
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.

  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
pep is reference to a pointer to an ms_peptide object that will be returned.
Returns
true if the peptide exists.

Implements ms_mascotresults.

◆ getPeptideExpectationValue()

double getPeptideExpectationValue | ( | const double | score,
 |  | const int | query,
 |  | const int | rank = 0
 | ) |  | const
 virtualinherited

Returns the expectation value for the given peptide score and query.

Returns the number of peptides that you would expect to get this score or higher from this database. This value is displayed as the expectation value in Mascot 2.0 and later reports. When the value is below 1, it approximates the p-value corrected for multiple testing.

For Mascot matches, the expectation value is calculated from

    E = Pthreshold * (10 ** ((Sthreshold - score) / 10))

For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

The Sthreshold value is the value returned by getHomologyThreshold() if ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specifed in the ms_peptidesummary constructor, otherwise the value used is the one returned from getPeptideIdentityThreshold().

Parser 2.8 and later can calculate expectation values for Mascot error tolerant matches. The value is based on the combined first and second pass identity threshold. If rank is zero, getPeptideExpectationValue() assumes the score is a first pass match score and calculates the value from the first pass identity or homology threshold. If rank is non-zero, the correct threshold is chosen based on the match at rank rank in this query.

ET expectation value is only available if the results file is from Mascot 2.8 and later. When you open results from Mascot 2.7 and earlier, expectation value for ET matches is -1. Note that Parser 2.7 and earlier returned a non-negative but incorrect number for ET matches.

For spectral library matches, the expectation value formula depends on report mode.

  • In integrated mode (ms_peptidesummary::MSPEPSUM_SL_INTEGRATED), library scores are scaled internally so that their mean and standard deviation match the mean and standard deviation of significant rank 1 Mascot matches with the same sequence in the same query. See Library scores and thresholds.
  • In SL-only mode (ms_peptidesummary::MSPEPSUM_SL_ONLY), the expect value formula is
     E = 0.05 * 10 ** (-(s - 300)/100).
    For example, E = 0.05 for score 300.

Spectral library support was added in Mascot Parser 2.6. If rank is zero, which is the default in Parser 2.5 and earlier, the score is assumed to be a Mascot ions score. If rank is non-zero, the correct formula is chosen based on the type of the match at rank rank in this query.

See also
getProteinExpectationValue()
Parameters
score | is the Mascot score to be converted.
query | specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
rank | is the rank of the match of interest in this query.
Returns
The number of peptides that you would expect to get this score or higher from this database, or -1 if it cannot be calculated.

◆ getPeptideIdentityThreshold()

int getPeptideIdentityThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const
 virtualinherited

Return the threshold value for this ms-ms data being a random match.

See also
getAvePeptideIdentityThreshold()
Parameters
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType | If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns
A score threshold. If query is < 1 or > ms_mascotresfilebase::getNumQueries() then -1 will be returned. If there was no MS-MS data or no match for this query, then -1 will be returned.
Examples
peptide_list.cpp, and resfile_summary.cpp.

◆ getPeptideThreshold()

double getPeptideThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1,
 |  | const THRESHOLD_TYPE | thresholdType = TT_PEPSUM_DEFAULT
 | ) |  | const
 inherited

Return either the identity or the homology threshold.

The default is to use identity thresholds for the original Peptide Summary and Select Summary reports. For the Family Summary grouping, homology thresholds are used, and this needs to be specified by using the ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH flag. (This flag is automatically set when using the ms_mascotresfilebase::get_ms_mascotresults_params helper function).

This function calls getPeptideIdentityThreshold() or getHomologyThreshold() as appropriate. If it calls getHomologyThreshold() and this returns 0, then the identity threshold is returned.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. See getHomologyThreshold().

If the peptide match at rank rank is an ET match, and the results file is from Mascot Server 2.7 or earlier, then getPeptideIdentityThreshold() returns -1 and getPeptideThreshold() returns -1.

Parameters
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries()
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.
  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
thresholdType | can be any one of the ms_mascotresults::THRESHOLD_TYPE values
Returns
the threshold.

◆ getProbabilityThreshold()

double getProbabilityThreshold ( ) const
virtualinherited

Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.

In a protein summary, the probability threshold specifies a cutoff point for protein scores, a cutoff for an Integrated error tolerant search and a threshold for calculating MudPIT scores.

In a peptide summary, the identity and homology thresholds of a peptide match are calculated from the probability threshold (significance threshold). This is the value of "Significance threshold p&lt;" shown in Mascot search reports.

getProbabilityThreshold() returns the currently active first pass significance threshold. The value may differ from the minProbability constructor argument if a target FDR has been specified. See ms_mascotresults_params::getTargetFDR().

If target FDR has not been specified, and if a value of <= 1e-18 or >= 1 is passed to the constructor, then a value of 1/20 (0.05) will be returned by this function. Otherwise it will just return the value passed to the ms_mascotresults::ms_mascotresults constructor.

In an error tolerant search, getProbabilityThreshold() may differ from the significance threshold used during the search, which was the basis for protein selection for the second pass. This is recorded as the first_pass_threshold= line in the results file header.

Error tolerant matches use an independent significance threshold, getErrTolProbabilityThreshold().

Returns
probability threshold for peptide matches.

◆ getProbFromScore()

int getProbFromScore ( const double score ) const
virtualinherited

Returns a probability value given a score.

Warning
Do not use this without fully understanding what the function returns. It is more likely that you will want to use getPeptideExpectationValue() or getProteinExpectationValue().
Parameters
score is the Mascot score.
Returns
probability calculated from p = pow(10.0, (score/10.0)).

◆ getProbOfPepBeingRandomMatch()

double getProbOfPepBeingRandomMatch | ( | const double | score,
 |  | const int | query
 | ) |  | const
 virtualinherited
Deprecated:
Use getPeptideExpectationValue().

Returns the inverse of getPeptideExpectationValue(). If, for example, the identity threshold (p<0.05) for a particular query is 30, and a value of 30 is passed to this function, then the return value will be 1/0.05. If, for the same search, a peptide of interest gets a score of 50, then this function will return a value of 1 / 0.00067 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also
getProbOfProteinBeingRandomMatch()
Parameters
score | is the Mascot score
query | specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
Returns
The probability.
Examples
resfile_summary.cpp.

◆ getProbOfProteinBeingRandomMatch()

double getProbOfProteinBeingRandomMatch ( const double score ) const
virtualinherited
Deprecated:
Use getProteinExpectationValue().

Returns the inverse of getProteinExpectationValue(). If, for example, the identity threshold (p<0.05) for a PMF search is 56, and a value of 56 is passed to this function, then the return value will be 1/0.05. If, for the same search, a protein of interest gets a score of 90, then this function will return a value of 1 / 0.000025 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also
getProbOfPepBeingRandomMatch()
Parameters
score is the Mascot score to be converted.
Returns
The inverse of getProteinExpectationValue().

◆ getProtein()

const ms_protein * getProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const
 virtualinherited

Return a pointer to the protein entry given an accession.

Parameters
accession is the accession string.
dbIdx is the database index (1..ms_searchparams::getNumberOfDatabases()).
  • For a PMF mixture in protein summary (see Peptide mass fingerprint mixtures), use the default value of 1 even if the component proteins are all from other databases.
Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Returns
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

◆ getProteinDescription()

std::string getProteinDescription | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const
 inherited

Return protein description if available.

This method attempts to return the 'description line' for the given accession. The description line originated from the FASTA file that was searched. An empty string will be returned if the protein is not listed in the proteins section or the summary section of the results file.

Format in the proteins section is, for example:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search all, protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

The alternative way to get the description line is to call

     ms-getseq.exe [db] [accession] title

when nothing is returned by getProteinDescription(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

If the 'protein' is actually a UniGene entry, then the description line is taken by concatenating the Gene and the Title line for the relevant entry.

If the protein is a PMF mixture, then the description line will be of the format:

 * Mixture from proteins:"gi|1234","gi|5432","gi|9999"

If the protein comes from the reference database of a spectral library, then its description is not saved in the results file and this method returns the empty string. If the protein comes from the spectral library, it may or may not have a description, depending on how the library was created.

For a search against a decoy database, if the result is from the decoy section, then the description is prefixed with "Random sequence, was ", or if there is no description in the file, "Random sequence.". Depending on the configuration of the search, Random may also be Reversed or Shuffled.

Parameters
accession | is the accession string.
dbIdx | database index used for the search.
Returns
The description line or an empty string.
Examples
resfile_summary.cpp.

◆ getProteinEmPAI()

double getProteinEmPAI | ( | const char * | accession,
 |  | const int | dbIdx = 1,
 |  | const int | length = -1
 | ) |  | const
 virtualinherited

Return protein emPAI if available.

The Exponentially Modified Protein Abundance Index (emPAI) offers approximate, label-free, relative quantitation of the proteins in a mixture based on protein coverage by the peptide matches in a database search result. The key publication is

Ishihama, Y., et al.: Exponentially modified protein abundance index (emPAI) for estimation of absolute protein amount in proteomics by the number of sequenced peptides per protein (2005). Molecular & Cellular Proteomics 4:1265-1272.

The number of observed peptides is determined using the function ms_protein::getNumObservedForEmPAI().

Protein sequence length is needed for emPAI calculation. You have two options:

  1. Give the sequence length as an argument to this method. You will need to fetch it with e.g. ms-getseq.exe on the Mascot Server machine.
  2. Give no argument to the method. If the protein has a mass in the results file, the mass will be used to calculate an approximate sequence length.

If no sequence length is given and the protein has no mass in the results file, the method returns -1. If you know the mass of the protein but not its sequence length, you can use the following approximate formula:

length = floor(0.5 + mass / 111)

Here 111 Da is the average mass of an amino acid residue.

If ms_mascotresults::isEmPAIallowed() is false, this method returns -1.

Parameters
accession | Protein accession.
dbIdx | Protein database index number.
length | Protein sequence length (optional). If the length is not given, protein mass from the results file will be used to approximate it. If protein mass is not available, the method returns -1.
Returns
emPAI or -1, as described above.

Reimplemented in ms_peptidesummary.

◆ getProteinExpectationValue()

double getProteinExpectationValue ( const double score ) const
virtualinherited

Returns the expectation value for the given protein score.

Returns the number of proteins that you would expect to get this score or higher from random matches for this search. For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also
getPeptideExpectationValue()
Parameters
score is the Mascot protein score to be converted.
Returns
The expectation value.

◆ getProteinMass()

double getProteinMass | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const
 inherited

Return protein mass if available.

This method attempts to return the mass for the given accession. The protein mass is calculated during the Mascot search, and some, but not all, of these masses are saved in the results file. A value of zero will be returned if the protein is not listed in the proteins section or the summary section of the results file.

The format in the proteins section is, for example, for a protein of mass 79480.13 daltons:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search, all protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines and masses in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines and masses are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

If a mass of zero is returned by this function, then the alternative way to get the mass is to call

     ms-getseq.exe [db] [accession] seq

to get the sequence, and then call getSequenceMass(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

Parameters
accession | is the accession string.
dbIdx | database number (1..ms_searchparams::getNumberOfDatabases()).
Returns
The protein mass or 0.0.
Examples
resfile_summary.cpp.

◆ getProteinScoreCutoff()

int getProteinScoreCutoff ( double OneInXprobRnd ) const
virtual

Return the 'protein' score value for cutting off results. Different for peptide and protein summary.

The protein probability cutoff is calculated differently for a protein summary and a peptide summary.

  • For a peptide summary, we want to display any proteins that contain even one significant peptide, which means the threshold is the same as getAvePeptideIdentityThreshold().

    For MudPIT scoring, any protein with a score greater than zero must have one or more peptides above the homology threshold, so this function returns a value of 1.

  • For a protein summary, we simply use the protein score that corresponds to the threshold.
Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns
The protein score cutoff threshold.

Implements ms_mascotresults.

◆ getProteinScoreForHistogram()

double getProteinScoreForHistogram ( const int num ) const
virtualinherited

Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.

The 'well known' green and red histogram at the top of the Mascot reports is created from the top 50 protein scores in the results. However, if the number of hits requested for a peptide or protein summary is 'AUTO' or is less than 50, then there won't be 50 hits in the ms_mascotresults object so it won't be possible to create the histogram.

This simple method can reliably be used to return the score for a hit number between 1 and 50, regardless of the number of entries in the protein or peptide summary. To create the histogram, it will be necessary to call this method 50 times - with num being 1..50.

In the rare case of there being less than 50 proteins in the results file, a value of -1 will be returned for values of num that have no protein hit. If a protein is rejected because it only has peptides shorter than minPepLenInPepSummary or because the MSRES_REQUIRE_BOLD_RED is set, then this protein will not be included in the list.

Parameters
num Is a value in the range 1..50.
Returns
The score.

◆ getProteinsWithThisPepMatch()

std::string getProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | const bool | quotes = false
 | ) |  |
virtual

Return a partial list of proteins that matched the same peptide.

The returned string is of the following form:

    1:Q9XZJ2  2:100K_RAT  3:AAF55150

The list is the hit number / accession of all proteins that matched the same peptide. There is no indication of which database the hit is from, but this can of course be determined by calling getHit().

In ms_peptidesummary, this is taken from the list of accessions on the q1_p1= line. The returned string only includes proteins that are in the current peptide summary. This means for example that if you choose to only see the top 5 hits, and this query/rank is for a peptide that occurs in protein 6, then protein number 6 will not appear in the resulting string.

In ms_proteinsummary, the string is also constructed from the list of accessions on the q1_h1= line. There's an additional check that the query number is the same, and that the peptide is the same string.

If you want a list of accession strings rather than a single concatenated string, use the function getAllProteinsWithThisPepMatch().

Parameters
q is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' number (in ms_proteinsummary) or 'rank' number (in ms_proteinsummary).
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence h must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
quotes specifies whether the accessions will be quoted, which should allow accesions with spaces and colons. If true, the string returned would then be
1:"Q9XZJ2" 2:"100K_RAT" 3:"AAF55150"
Returns
list of proteins matching the peptide, as a string

Implements ms_mascotresults.

◆ getProteinTaxonomyIDs()

void getProteinTaxonomyIDs | ( | const char * | accession,
 |  | const int | dbIdx,
 |  | std::vector< int > & | gpt_ids,
 |  | std::vector< std::string > & | gpt_accessions
 | ) |  | const
 inherited

Return the taxonomy ID(s), if any, from the results file.

In Mascot 2.4.0 and later, taxonomy IDs are saved in the proteins section of the results files in the form:

   [DB::]"accession"_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

In Mascot 2.4.1 and later, taxonomy IDs are also saved in the summary section of the results files in the form:

   hN_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

For example, for a single database, with a single accession/taxonomy:

   "gi|209490801"_tax=87229

   h1=gi|209490801, ...
   h1_tax=87229

and for a multi-database search, with a single accession/taxonomy:

   02::"gi|209490801"_tax=87229

   h1_db=2
   h1=gi|209490801, ...
   h1_tax=87229

and for a single database, with multiple accession/taxonomy:

   "gi|182438931"_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

   h1=gi|182438931, ...
   h1_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

If none of the databases used for the search contain taxonomy information, then no _tax lines will be output.

If any of the databases used for the search contain taxonomy information, then a _tax line will be output for all relevant proteins. This is governed by the same rules that determine for which proteins to output the mass and description lines. If a protein has no taxonomy information (for example, the database has no taxonomy), -1 will be used as the taxonomy ID.

Therefore, to determine if taxonomy information is available in the results file, simply take any protein in the proteins section, and see if there is a corresponding _tax entry.

For most FASTA files, there is a single accession and taxonomy for each sequence entry. For the NCBInr database, identical sequences are only stored once, but there are multiple accession/description lines separated by a "Control-A" character. Each accession may have a different taxonomy. This function returns the list of taxonomy IDs and corresponding accessions. For the last example shown above, this function will return the arrays of IDs

  [455632, 649189, 455632, 649189]

and accessions

  ["gi|182438931", "gi|282872348", "gi|178467447", "gi|282574201"]

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
accession | is the primary accession
dbIdx | is the 1 based database ID
gpt_ids | the taxonomy IDs
gpt_accessions | the list of accessions

◆ getProteinThreshold()

int getProteinThreshold ( double OneInXprobRnd ) const
virtualinherited

Return a threshold value for the protein summary report.

This is simply calculated by using:

   10.0 * log10(seqsAfterTax * OneInXprobRnd)

where seqsAfterTax is obtained from ms_mascotresfilebase::getNumSeqsAfterTax().

The threshold value is displayed at the top of the protein summary report: Protein scores greater than 72 are significant (p<0.05).

Parameters
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns
The protein threshold.

◆ getQmatch() [1/2]

int getQmatch ( const int query ) const
virtualinherited

[Deprecated] Return the number of peptides with masses that matched this query.

Deprecated:
This method is deprecated in favour of ms_mascotresfilebase::getQmatch
See also
getPeptideIdentityThreshold()
Note
This method only works with dat28 (.dat) results files. The value returned with MSR files is undefined.

If the value is greater than INT_MAX, then INT_MAX will be returned.

This function calls the getQmatch(query, section) function with the 'relevant' section which will normally be SEC_SUMMARY.

If the MSRES_DECOY flag was specified in the constructor, then the 'relevant' section will be SEC_DECOYSUMMARY. If the search is an error tolerant search, then the 'relevant' section will be SEC_ERRTOLPEPTIDES, and analogously for crosslinked searches (SEC_CROSSLINK_PEPTIDES).

However, to get the spectral library qmatch values, it is necessary to explicitly call: getQmatch(query, ms_mascotresfile_dat::SEC_LIBRARYSUMMARY)

Parameters
query Specifies the query number. This should be in the range 1 .. ms_mascotresfile_dat::getNumQueries().
Returns
the number of peptides with masses that matched this query

◆ getQmatch() [2/2]

int getQmatch | ( | const int | query,
 |  | const ms_mascotresfile_dat::section | sec
 | ) |  | const
 virtualinherited

[Deprecated] Use ms_mascotresfilebase::getQmatch().

Deprecated:
This method is deprecated in favour of ms_mascotresfilebase::getQmatch

If the value is greater than INT_MAX, then INT_MAX will be returned.

Note
This method only works with dat28 (.dat) results files. The value returned with MSR files is undefined.
Parameters
query Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
sec is the section number and can be one of:
  • ms_mascotresfile_dat::SEC_SUMMARY
  • ms_mascotresfile_dat::SEC_DECOYSUMMARY
  • ms_mascotresfile_dat::SEC_ERRTOLSUMMARY
  • ms_mascotresfile_dat::SEC_ERRTOLDECOYSUMMARY
  • ms_mascotresfile_dat::SEC_LIBRARYSUMMARY
  • ms_mascotresfile_dat::SEC_CROSSLINK_SUMMARY
Returns
the number of peptides with masses that matched this query. If the specified sec doesn't exist, then 0 will be returned.

◆ getQuantitationComponentForPeptide()

ms_mascotresults::QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide | ( | const matrix_science::ms_peptide & | peptide,
 |  | matrix_science::ms_quant_component & | component,
 |  | const matrix_science::ms_quant_method * | method = NULL
 | ) |  | const
 virtual

Get the component in the quantitation method that matches the peptide.

If the component name has already been determined (see ms_peptide::getComponentStr()) then that component is retrieved from the method.

If the component name has not yet been determined for the peptide, each component in the method is checked in turn to determine if it is the correct component for the peptide (see ms_peptidesummary::isPeptideComponentMatch()). A component only matches the peptide if every modification group of the component matches the peptide.

This is only applicable if there is a quantitation method, the method uses the Precursor protocol and the method has components defined. If an error occurs then an error message is appended to the matrix_science::ms_mascotresfilebase and a matching status code is returned.

Parameters
peptide | The peptide to find the component for.
component | This is set to the first matching component found, if any.
method | An optional parameter that overrides the quantitation method used to look for matching components. If no method is specified here then the method from the ms_mascotresfilebase is used.
Returns
One of the return status codes in ms_mascotresults::QUANT_COMPONENT_STATUS.

Implements ms_mascotresults.

◆ getReadableVarMods()

std::string getReadableVarMods | ( | const int | q,
 |  | const int | p,
 |  | const int | numDecimalPlaces = 2,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const
 virtualinherited

Return a 'human readable' string with the variable, summed and error tolerant mods.

This function creates a string of the form

2 Oxidation (M); Phosphorylation (ST)

It works by getting the variable mods string, e.g. 0110030, using ms_peptide::getVarModsStr(). It then converts the string to a human readable form. Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W.

This function will work whether or not there are variable and/or error tolerant mods, and can be called for either the peptide or the protein summary. Variable modification names are obtained using ms_searchparams::getVarModsName() and error tolerant modification names are found using ms_mascotresults::getErrTolModName(). Library modification names, in peptide summary, are found using ms_searchparams::getLibraryModName(). See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Error tolerant mods are shown with the delta in square brackets after the modification or substitution. For example:

   R->G [-99.08]

The delta is shown to numDecimalPlaces.

If the match is an intact crosslinked match, the returned string contains a short description of the linked sites and what they are linked with. For example:

   Xlink:DSS (K) in alpha crosslinked with Xlink:DSS (K) in beta

Use ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA as the psmComponent argument to inspect the alpha and beta mods separately. In this case, the intact linker is described like "intact Xlink:DSS (K)".

Summed mods, from ms_peptide::getSummedModsStr(), and query-level mods, from ms_peptide::getLocalModsStr(), are also included in the returned string.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10.
numDecimalPlaces | (optional) Used for the display of modification deltas.
psmComponent | (optional) Either ms_peptide::PSM_COMPLETE for the match as a whole, or ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA to get components of a crosslinked match.
Returns
The formatted string.
Examples
resfile_summary.cpp.

◆ getResultsParameters()

ms_mascotresults_params getResultsParameters ( ) const
inherited

Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.

Returns
An ms_mascotresults_params object containing the parameter and flag values used to generate the report.

◆ getSequenceMass()

double getSequenceMass ( const char * seq ) const
inherited

Return the mass of a sequence (protein or peptide).

The sequence mass is calculated by summing the mass of each residue, using ms_searchparams::getResidueMass, and adding terminus masses using ms_searchparams::getCTermMass and ms_searchparams::getNTermMass.

The mass is therefore the 'Mr' (uncharged) mass, and is calculated using any static modifications.

Parameters
seq is the protein sequence.
Returns
The relative mass of the sequence.

◆ getTagDeltaRangeEnd()

int getTagDeltaRangeEnd | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the second number from h1_q2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
the second number from the string or -1 if there is no tag match.

Implements ms_mascotresults.

◆ getTagDeltaRangeStart()

int getTagDeltaRangeStart | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the first number from h1_q2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
the first number from the string or -1 if there is no tag match.

Implements ms_mascotresults.

◆ getTagEnd()

int getTagEnd | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const
 virtualinherited

Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also
getTagStart(), getTagSeries()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns
The residue end position of the tag.
Examples
resfile_summary.cpp.

◆ getTagSeries()

int getTagSeries | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const
 virtualinherited

Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also
getTagStart(), getTagEnd()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns
The series that contained a match to the tag. Possible ion series numbers are
  • -1 means no matches for the tag
  • 0 "a" series (single charge)
  • 1 "a-NH3" series (single charge)
  • 2 "a" series (double charge)
  • 3 "b" series (single charge)
  • 4 "b-NH3" series (single charge)
  • 5 "b" series (double charge)
  • 6 "y" series (single charge)
  • 7 "y-NH3" series (single charge)
  • 8 "y" series (double charge)
  • 9 "c" series (single charge)
  • 10 "c" series (double charge)
  • 11 "x" series (single charge)
  • 12 "x" series (double charge)
  • 13 "z" series (single charge)
  • 14 "z" series (double charge)
  • 15 "a-H2O" series (single charge)
  • 16 "a-H2O" series (double charge)
  • 17 "b-H2O" series (single charge)
  • 18 "b-H2O" series (double charge)
  • 19 "y-H2O" series (single charge)
  • 20 "y-H2O" series (double charge)
  • 21 "a-NH3" series (double charge)
  • 22 "b-NH3" series (double charge)
  • 23 "y-NH3" series (double charge)
  • 25 "internal yb" series (single charge)
  • 26 "internal ya" series (single charge)
  • 27 "z+1" series (single charge)
  • 28 "z+1" series (double charge)
  • 29 high-enrgy "d" and "d'" series (single charge)
  • 31 high-enrgy "v" series (single charge)
  • 32 high-enrgy "w" and "w'" series (single charge)
  • 33 "z+2" series (single charge)
  • 34 "z+2" series (double charge)
Examples
resfile_summary.cpp.

◆ getTagStart()

int getTagStart | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const
 virtualinherited

Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also
getTagEnd(), getTagSeries()
Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns
The residue start position of the tag.
Examples
resfile_summary.cpp.

◆ getTagString()

std::string getTagString | ( | const int | q,
 |  | const int | p
 | ) |  | const
 virtual

Return the complete tag string from h1_q2_tag or q1_p1_tag.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_tag might be
       q1_p2_tag=1:10:12:6,3:1:12:1,...
  • The entry in h1_q2_tag might be
       h1_q2_tag=1:10:12:6,3:1:12:1,...

This function returns the complete string value. Every group of four numbers between commas is tagNumber:startPos:endPos:series.

More useful functions are

  • ms_mascotresults::getTagStart(),
  • ms_mascotresults::getTagEnd() and
  • ms_mascotresults::getTagSeries(),

all of which will work for both the protein summary and the peptide summary.

Parameters
q Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns
complete tag string.

Implements ms_mascotresults.

◆ getTerminalResiduesString()

std::string getTerminalResiduesString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const
 virtual

Return the complete terminal residue string from h1_q1_terms.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in the results file might be
       q1_p2_terms=-,A:K,I:-,-:Q,-:@,R:...
  • The entry in the results file might be
       h1_q2_terms=A,Q

This function returns the complete string value. More useful functions are ms_protein::getPeptideResidueBefore() and ms_protein::getPeptideResidueAfter(), which will work for both the protein summary and the peptide summary.

ms_peptidesummary only: For a crosslinked match, the results file line is q1_p1_terms_1= or q1_p1_terms_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

Parameters
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns
the full terminal residues string.

Implements ms_mascotresults.

◆ getThresholdForFDRAboveHomology() [1/2]

bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |
inherited

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFDRAboveHomology(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getThresholdForFDRAboveHomology() [2/2]

bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |
inherited

Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.

For example, to find out which probability threshold gives 1% FDR above identity or homology threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the * minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveHomology() and getNumDecoyHitsAboveHomology().

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

Otherwise functionality is the same as getThresholdForFDRAboveIdentity(double, double*, double*, int*, int*).

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getThresholdForFDRAboveIdentity() [1/2]

bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |
inherited

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFDRAboveIdentity(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getThresholdForFDRAboveIdentity() [2/2]

bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |
inherited

Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.

For example, to find out which probability threshold gives 1% FDR above identity threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveIdentity() and getNumDecoyHitsAboveIdentity().

The function returns a value that maximises the number of peptide-spectrum matches while giving an FDR below the targetFDR value. In some cases, it would be possible to get an FDR closer to the supplied targetFDR, but with fewer target matches.

For a large file, this function can take some time to return. Feedback can be obtained by using ms_mascotresfilebase::outputKeepAlive with the fd= tag.

This function was first introduced in version 2.4.0 and the method for calculating the value was changed between version 2.4.0 and 2.4.1.

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If this function returns false, there are several possibilities:

  • The function is being called for a ms_proteinsummary object
  • The supplied targetFDR is 0, or negative
  • It is not possible to get an FDR less than the targetFDR. In this case, the lowest possible FDR is given
  • The function is being called for an error tolerant search

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns
true if the FDR was reached, false otherwise.

◆ getToleranceInDalton()

double getToleranceInDalton | ( | bool & | needMass,
 |  | const double *const | pMass = NULL
 | ) |  | const
 inherited

Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.

Returns the tolerance of the result file in dalton.

Parameters
needMass | Reference to a boolean to determine if the mass is needed to calculate the delta, namely when the tolerance unit is in % or ppm
pMass | Optional parameter to calculate the tolerance from the mass for % and ppm
Returns
The tolerance in dalton

◆ getTreeClusterNodes()

bool getTreeClusterNodes | ( | const int | hit,
 |  | std::vector< int > & | left,
 |  | std::vector< int > & | right,
 |  | std::vector< double > & | distance,
 |  | TREE_CLUSTER_METHOD | tcm = TCM_PAIRWISE_MAXIMUM,
 |  | double *** | reserved1 = 0,
 |  | unsigned int * | reserved2 = 0
 | ) |  | const
 virtualinherited

Return distances and structure suitable for a dendrogram plot.

The 'distances' between each protein in the family are calculated using a tree clustering routine which, by default, implements pairwise maximum (or complete) linkage clustering. It is used for the dendrogram display in the reports introduced in Mascot 2.3.

The vectors returned by this function only contain values when MSRES_CLUSTER_PROTEINS has been specified and where there are at least two family members.

The code uses the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/

The License agreement for using this excellent Open Source code is included with Mascot Parser; see C Clustering library.

A value of 0 returned in the left or right vector corresponds to the lead protein as returned by getHit(). To find the protein associated with a positive node value returned in the left or right vector, call getNextFamilyProtein() with the id value set to the value in the vector.

The distances passed to the cluster algorithm are calculated by determining which peptides need to be excluded to make one protein a subset of another. Each unique peptide sequence is considered in turn, and the distance is calculated by taking the maximum difference between the score and the value returned by getPeptideThreshold(). Additionally, where a query has matches to different peptides above threshold in each protein, the delta of the scores is added to the distance.

For details of how to use the left, right and distance parameters, see Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
hit | is the hit number for the lead protein.
left | returns a vector of 'left' values.
right | returns a vector of 'right' values.
distance | returns a vector of 'distance' values.
tcm | is the method to be used. See documentation referenced above
reserved1 | is for Matrix Science use only
reserved2 | is for Matrix Science use only
Returns
true unless the code causes an out of memory error.

Reimplemented in ms_peptidesummary.

◆ getUnassigned()

ms_peptide getUnassigned ( const int num ) const
inherited

Need to call createUnassignedList() before calling this.

See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_errs::ERR_UNASSIGNED_PROG will be set, and this function will return an empty ms_peptide.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
num Must be in the range 1..getNumberOfUnassigned().
Returns
If num is outside the range ..getNumberOfUnassigned(), then an error ms_errs::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.
Examples
resfile_summary.cpp.

◆ getUnassignedIsBold()

bool getUnassignedIsBold ( const int num ) const
inherited

Returns true if the item indexed by num in the assigned list should be bold.

This function returns true if this peptide should be displayed in bold in a Mascot report. Bold is used for the first time a query is shown in a report. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_errs::ERR_UNASSIGNED_PROG will be set, and this function will return true.

Parameters
num Must be in the range 1..getNumberOfUnassigned().
Returns
If num is outside the range ..getNumberOfUnassigned(), then an error ms_errs::ERR_UNASSIGNED_RANGE will be set, and this function will return true.

◆ getUnassignedShowCheckbox()

bool getUnassignedShowCheckbox ( const int num ) const
inherited

Returns true if the item indexed by num in the assigned list should have a check box next to it.

A check box is displayed if this is the first rank 1 match that has been displayed for this query. See also ms_peptide::getRank() and ms_peptide::getPrettyRank().

By definition, all unassigned queries will need a check box. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_errs::ERR_UNASSIGNED_PROG will be set, and this function will return false.

Parameters
num Must be in the range 1..getNumberOfUnassigned().
Returns
If num is outside the range ..getNumberOfUnassigned(), then an error ms_errs::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.

◆ isEmPAIallowed()

bool isEmPAIallowed ( ) const
inherited

Return true if emPAI could be calculated using data in this results file.

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns
true if emPAI is allowed.

◆ isNA()

bool isNA ( ) const
inherited

Returns TRUE for a search against a nucelic acid database.

There is no specific information in the results file for this. It is implemented by looking to see if there is a frame number that is non-zero in any result. If there are no matches to any query, then this method will return false and therefore may be wrong. (However, if there are no matches then it is unlikely that the outcome of this function is important!)

In versions prior to 2.3.01, this was determined by looking in protein matches. In version 2.3.01 and later, this is determined by looking in all peptide matches, regardless of score.

Returns
True if the search was against a nucleic acid database.

◆ isPeptideUnique()

bool isPeptideUnique | ( | const int | q,
 |  | const int | p,
 |  | const ms_mascotresults::UNIQUE_PEP_RULES | rules = ms_mascotresults::UPR_DEFAULT
 | ) |  | const
 virtual

Returns true if this peptide match is unique to one protein or one protein family.

Note
This function currently returns false for ms_proteinsummary. This function is only likely to be useful for a peptide summary.

This function is used, for example, in quantitation to only report ratios for peptide sequences that are unique to one protein hit. This can be specified as part of a Mascot quantitation method; see ms_quant_quality::isUniquePepseq().

No attempt is made to collapse peptides that just differ by, for example, I or L.

The specified q and p values must be for a peptide that has a protein match in the current report, i.e. not in the unassigned list. The function searches all proteins and not just those in the current report. For example, if peptide 'ABCDEFK' appears in protein hit one and protein hit 100, then it will return false even if only the top 10 hits have been requested.

If grouping is not selected when creating the ms_peptidesummary, (i.e. neither ms_mascotresults::MSRES_GROUP_PROTEINS nor ms_mascotresults::MSRES_CLUSTER_PROTEINS), then it is likely that this function will return false for most peptides.

At version 2.3, this function did not have the optional third parameter and the default value was the same as using ms_mascotresults::UPR_WITHIN_FAMILY, which is not the default value in version 2.4 and later. At version 2.3, the function would therefore return true for all peptides with a score above the homology threshold when ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified.

Parameters
q | is the query number in the range 1 to ms_mascotresfilebase::getNumQueries().
p is the 'hit' or 'rank' number.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the * range 1 to 50.
rules | should passed appropriate ms_mascotresults::UNIQUE_PEP_RULES flags to specify what rules are to be used for considerering when a peptide is unique.
Returns
true if the peptide match is unique. Always false in ms_proteinsummary.

Implements ms_mascotresults.

◆ isPmfQueryUsed()

bool isPmfQueryUsed ( const int queryIdx ) const

Indicates whether a mass value was used when calculating PMF protein scores.

When submitting a PMF search with intensity values, some masses with low intensities (often noise peaks) may be ignored when calculating scores. Mascot iterates through the intensity values to determine the best score. The total number of masses (queries) used for the best match, and hence used to calculate the score of every protein, can be obtained by calling getNumPmfQueriesUsed().

Use this function to test if a particular query was in the set of masses that obtained the best score.

If no query intensities are supplied, or if all queries have the same intensity, then every query will be used for the search.

Parameters
queryIdx a query number from 1 to ms_mascotresfilebase::getNumQueries().
Returns
true if the query was used when calculating scores.

◆ setSubsetsThreshold()

void setSubsetsThreshold ( const double scoreFraction )
virtualinherited

Specifies which subset proteins should be reported.

If you have a primary hit with (say) 100 peptide matches, you are very interested in sub-set proteins with 99 matches but not if they only have 1 or 2 matches. These are the sub-set hits that clutter up the report if Show Sub-sets is checked in Mascot 2.1 and earlier. If you have a primary hit with (say) 2 peptide matches, you are more likely to be interested in sub-set proteins with just 1 match.

A scoreFraction of 1 indicates that all proteins with a subset of matches should be reported. A value of 0 indicates that no subsets will be reported. The flag MSRES_SHOW_SUBSETS must have been specified if a value > 0 is used, or no subsets will be shown.

See also
getNextSubsetProtein(), getNextSubsetProteinOf()
Parameters
scoreFraction is the fractional score required for a protein to be counted as a subset. Its score must be greater than or equal to main_protein_score * (1-scoreFraction). The default value is 1.0.
The documentation for this class was generated from the following files:
  • ms_proteinsummary.hpp
  • ms_proteinsummary.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_searchparams Class Reference

  • matrix_science
  • ms_searchparams
Public Types | Public Member Functions | List of all members
ms_searchparams Class Reference
Mascot results file module

This class encapsulates the search parameters in the Mascot results file. More...

#include <ms_searchparams.hpp>

Public Types

enum MULTI_SITE_MODS {
MSM_NOT_PERMITTED = 0x0000 ,
MSM_EXCLUSIVE_PLUS_VARIABLE = 0x0001
}
Possible values for MULTI_SITE_MODS. More...

Public Member Functions

ms_searchparams (const ms_mascotresfilebase &resfile)
Either explicitily create an object using this constructor or call ms_mascotresfilebase::params().
~ms_searchparams ()
Should never need to call this destructor directly.
std::string | getACCESSION ()
Returns a comma separated list of accession strings to which the search was limited.
std::string | getAllUSERParams () const
Returns all the 'user defined' parameters.
double | getCarbonMass () const
Returns the mass of carbon as specified in the Unimod file.
std::string | getCHARGE ()
Returns the charge state of the peptide masses entered.
std::string | getCLE ()
Returns the name of the enzyme used for the search.
std::string | getCOM ()
This is the comment or "Search title" entered by the user in the search form.
std::string | getCROSSLINKING () const
Returns the name of the crosslinking method used.
double | getCTermMass ()
Returns the C terminus mass.
std::string | getDATAURL ()
Returns the URL of the uploaded file (if any).
std::string | getDB (int idx=1)
Returns one of the database names used for the search.
int | getDECOY () const
Returns a value showing if a decoy database has been searched.
double | getElectronMass () const
Returns the mass of an electron as specified in the Unimod file.
bool | getERRORTOLERANT ()
Returns true for an error tolerant search.
std::string | getErrTolParentFilename ()
Returns the filename of the 'parent' search for an old-style (manual) error tolerant search.
std::string | getFILENAME ()
Returns the name of the uploaded file (if any).
double | getFixedModsDelta (int num)
Returns the delta mass of a fixed modification.
std::string | getFixedModsName (int num) const
double | getFixedModsNeutralLoss (int num)
Returns the neutral loss value of the specified fixed modification.
std::string | getFixedModsResidues (int num) const
Returns the residues modified by the specified fixed modification.
std::string | getFORMAT ()
Returns the file format type selected by the user.
std::string | getFORMVER ()
Returns the version of the form used to submit the search.
double | getHydrogenMass () const
Returns the mass of nitrogen as specified in the Unimod file.
bool | getICAT ()
Returns true if the user selected the ICAT button on the search form.
std::string | getINSTRUMENT ()
Returns the instrument name that the user selected.
std::string | getINTERMEDIATE ()
For a repeat search, it may be necessary to know the "parent" search.
std::string | getIT_MODS ()
Returns a comma separated list of the variable modifications used in a search.
double | getITOL ()
Returns the tolerance for msms ions.
std::string | getITOLU ()
Returns the units that the ions tolerance is specified in.
int | getLIBRARY_SEARCH () const
Returns a value showing whether a spectral library is allowed as a search parameter.
double | getLibraryModDelta (int num) const
Returns the delta mass of the specified spectral library modification.
std::string | getLibraryModName (int num) const
Returns the name of the specified spectral library modification.
std::string | getLICENSE ()
Returns the Mascot license string.
std::string | getMASS ()
Returns whether monoisotopic or average masses have been specified.
MASS_TYPE getMassType ()
Returns either MASS_TYPE_MONO or MASS_TYPE_AVE.
double | getMaxInternalMass ()
Returns the maximum mass to be considered for internal fragments.
double | getMinInternalMass ()
Returns the minimum mass to be considered for internal fragments.
std::vector< std::string > | getML_ADAPTER_PARAM () const
Returns a list of strings defined as default ML adapter parameters.
std::string | getMODS ()
Returns a comma separated list of the fixed modifications used in a search.
unsigned int | getMULTI_SITE_MODS () const
Returns a flag showing what MULTI_SITE_MODS options were selected.
double | getNitrogenMass () const
Returns the mass of nitrogen as specified in the Unimod file.
double | getNTermMass ()
Returns the N terminus mass.
int | getNumberOfDatabases ()
Returns total number of databases used for the search.
int | getNumberOfLibraryMods () const
Return the number of modifications in the spectral libraries searched.
bool | getOVERVIEW ()
Returns true if the user selected the option to show the overview table.
double | getOxygenMass () const
Returns the mass of oxygen as specified in the Unimod file.
int | getPEP_ISOTOPE_ERROR () const
Returns a value showing how a peak detection error is handled.
int | getPERCOLATE () const
Returns a value showing if Percolator is selected as a search parameter.
int | getPFA ()
Returns the number of missed cleavage points allowed for in a search.
double | getPRECURSOR ()
Returns the precursor mass for an MS/MS query.
std::string | getQUANTITATION () const
Returns the name of the quantitation method used.
std::string | getQUE ()
Currently returns an empty string.
int | getREPORT ()
Returns the number of results to show in the report.
std::string | getREPTYPE ()
Returns the type of report requested by the user.
double | getResidueMass (char residue)
Returns the mass of the specified residue (must be uppercase letter A-Z).
std::string | getRULES ()
Returns as a comma separated list, the rules / ions series used for a search.
std::string | getSEARCH ()
Returns the type of search – this will be PMF, SQ, MIS.
int | getSEG ()
Returns the segment or protein mass.
int | getSUBCLUSTER ()
Returns the sub cluster number.
double | getTARGET_FDR_PERCENT () const
Returns the target FDR specified as a search parameter.
std::string | getTAXONOMY ()
Returns the name of the taxonomy selection.
double | getTOL ()
Returns the peptide tolerance for the search.
std::string | getTOLU ()
Returns the peptide tolerance units for the search.
std::string | getUSEREMAIL ()
Returns the user's email address (if any) as entered in the search form.
std::string | getUSERField (int num)
Returns the user fields USER00, USER01, USER02 ... USER12.
int | getUSERID ()
Returns the user's USERID.
std::string | getUSERNAME ()
Returns the user name (if any) as entered in the search form.
double | getVarModsDelta (int num)
Returns the delta mass for a variable modification.
std::string | getVarModsName (int num) const
double | getVarModsNeutralLoss (int num)
Returns the first neutral loss value of the specified variable modification.
std::vector< double > | getVarModsNeutralLosses (int num) const
Returns all the neutral loss values of the specified variable modification.
std::vector< double > | getVarModsPepNeutralLoss (int num)
Returns the peptide neutral loss value(s) of the specified variable modification.
std::vector< double > | getVarModsReqPepNeutralLoss (int num)
Returns the required peptide neutral loss value(s) of the specified variable modification.
bool | hasINTERNALS () const
Returns true if minimum or maximum internal fragment mass was specified.

Detailed Description

This class encapsulates the search parameters in the Mascot results file.

Although all these parameters could be obtained using the lower level functions in the ms_mascotresfilebase class, it is generally more convenient to use this object.

Examples
resfile_params.cpp.

Member Enumeration Documentation

◆ MULTI_SITE_MODS

enum MULTI_SITE_MODS

Possible values for MULTI_SITE_MODS.

See Using enumerated values and static const ints in Perl, Java, Python and C#. The return value from getMULTI_SITE_MODS() is one or more of these values OR'd together.

Currently only has one permitted value, but could be extended in future.

Enumerator
MSM_NOT_PERMITTED | The default value. Only one variable or exclusive mod per residue.
MSM_EXCLUSIVE_PLUS_VARIABLE | An exclusive mod and one or more variable mod may be specified for the same residue.

Constructor & Destructor Documentation

◆ ms_searchparams()

ms_searchparams ( const ms_mascotresfilebase & resfile )

Either explicitily create an object using this constructor or call ms_mascotresfilebase::params().

Search parameters can be obtained either by creating a search params object or by using the object created when the results file is created:

C++
   ms_mascotresfile_msr resfile(filename);

   // Option 1:
   ms_searchparams *params = new ms_searchparams(resfile);
   // Option 2:
   ms_searchparams params = resfile.params();
Perl
   my $resfile = msparser::ms_mascotresfile_msr->new($filename);

   # Option 1:
   my $params = msparser::ms_searchparams->new($resfile);
   # Option 2:
   my $params = $resfile->params();
Java
   ms_mascotresfile_msr resfile = new ms_mascotresfile_msr(filename);

   // Option 1:
   ms_searchparams params = new ms_searchparams(resfile);
   // Option 2:
   ms_searchparams params = resfile.params();
Python
   resfile = msparser.ms_mascotresfile_msr(filename)

   # Option 1:
   params = msparser.ms_searchparams(resfile)
   # Option 2:
   params = resfile.params()

See Maintaining object references: two rules of thumb.

Parameters
resfile result file object

Member Function Documentation

◆ getACCESSION()

std::string getACCESSION ( )

Returns a comma separated list of accession strings to which the search was limited.

The search space may be limited to the named accessions by specifying ACCESSION= as a search parameter.

For an old-style (manual) error tolerant search, the user typically specifies a list of accession "numbers" to be searched. This function returns a comma separated list of accession strings – each will have double quotes around it. The string is obtained from the ACCESSION= line in the parameters section of the results file.

Returns
comma separated list of accession strings

◆ getAllUSERParams()

std::string getAllUSERParams ( ) const

Returns all the 'user defined' parameters.

Returns a string of all the entries in the 'parameters' section or search__parameters table that have a leading underscore. Each item is separated by a newline character. Note that if there are two user parameters with the same key (differing only by case), then the second one of these will be discarded.

Returns
all the user defined parameters

◆ getCarbonMass()

double getCarbonMass ( ) const

Returns the mass of carbon as specified in the Unimod file.

This is obtained from the carbon= line in the masses section or search__symbol_masses table of the results file.

The mass will also depend on whether monoisotopic or average masses were selected by the user. See getMASS().

These values originate from the Unimod file.

Returns
mass of carbon.

◆ getCHARGE()

std::string getCHARGE ( )

Returns the charge state of the peptide masses entered.

This is obtained from the CHARGE= line in the parameters section or search__parameters table of the results file. Use ms_peptide::getCharge to return the actual charge state that was used for a peptide match.

This is the default charge state that was used when running the search. It can be overridden by charge states in an uploaded file; see ms_inputquery::getCharge().

If the search was submitted from the standard Mascot search form, then it will be one of the following strings:

  • '8-'
  • '7-'
  • '6-'
  • '5-'
  • '4-'
  • '3-'
  • '2- and 3-'
  • '2-'
  • '1-, 2- and 3-'
  • '1-'
  • 'Mr'
  • '1+'
  • '1+, 2+ and 3+'
  • '2+'
  • '2+ and 3+'
  • '3+'
  • '4+'
  • '5+'
  • '6+'
  • '7+'
  • '8+'

The charge can also be any comma separated list of charge states.

See also
https://www.matrixscience.com/help/search_field_help.html#TWO
Returns
The default charge(s) as a string.

◆ getCLE()

std::string getCLE ( )

Returns the name of the enzyme used for the search.

This is obtained from the CLE= line in the parameters section or search__parameters table of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#CLE
Returns
name of the enzyme used for the search

◆ getCOM()

std::string getCOM ( )

This is the comment or "Search title" entered by the user in the search form.

This is obtained from the COM= line in the parameters section or search__parameters table of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#COM
Returns
comment or "Search title" entered by the user in the search form

◆ getCROSSLINKING()

std::string getCROSSLINKING ( ) const

Returns the name of the crosslinking method used.

Available in Mascot 2.7 and later.

See also
https://www.matrixscience.com/help/search_field_help.html#CROSSLINKING
Returns
If no crosslinking is specified, an empty string or "None". Otherwise return the name of the crosslinking method from the CROSSLINKING= value in the parameters section or search__parameters table of the results file.

◆ getCTermMass()

double getCTermMass ( )

Returns the C terminus mass.

This is obtained from the C_term= line in the masses section or search__symbol_masses table of the results file.

The mass value will depend on whether monoisotopic or average masses were selected by the user (see getMASS()). Additionally, any fixed (but not variable) modifications are included in this mass. If no C terminus mods are specified, this value should be the same as getOxygenMass() + getHydrogenMass().

These values originate from the Unimod file.

Returns
C terminus mass

◆ getDATAURL()

std::string getDATAURL ( )

Returns the URL of the uploaded file (if any).

This is obtained from the DATAURL= line in the parameters section or search__parameters table of the results file.

Returns
URL of the uploaded file

◆ getDB()

std::string getDB ( int idx = 1 )

Returns one of the database names used for the search.

This is normally obtained from the DB= line in the parameters section or search__parameters table of the results file.

It is not possible to find the database file name and path directly from its name. The get the path to the database file used in the search, use ms_mascotresfilebase::getFastaPath(), or you will need to manually parse the Databases section of mascot.dat and search for the line starting with the name returned by getDB(). Replace the last part of the path with the return value from the ms_mascotresfilebase::getFastaVer() function to complete the file name.

Mascot 2.6 and later support spectral libraries. Each spectral library must have a reference database into which found peptide sequences are mapped at the end of the search. The "effective" reference database could be one of the protein sequence databases searched, or it could be a separate database used only for lookup purposes. You can find the database number of the reference database with ms_mascotresfilebase::getReferenceDatabaseNumberOfSL(). If this is larger than getNumberOfDatabases(), the database name is obtained from the library_reference_DB line in the header section of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#DB
Parameters
idx index of the database from 1 to getNumberOfDatabases() for databases or libraries searched, or an index returned by ms_mascotresfilebase::getReferenceDatabaseNumberOfSL().
Returns
one of the database names used for the search

◆ getDECOY()

int getDECOY ( ) const

Returns a value showing if a decoy database has been searched.

Available in Mascot 2.2 and later.

See also
https://www.matrixscience.com/help/decoy_help.html#AUTO

The value is obtained from the DECOY= line in the parameters section or search__parameters table of the results file. If there is no such line, this method returns -1. Otherwise, the method returns 0 if DECOY is off and 1 if DECOY is on.

Returns
-1, 0 or 1.

◆ getElectronMass()

double getElectronMass ( ) const

Returns the mass of an electron as specified in the Unimod file.

This is obtained from the Electron= line in the masses section or search__symbol_masses table of the results file.

Results files produced by Mascot versions prior to 1.9 do not have this entry. For those files, the returned value will be zero.

These values originate from the Unimod file.

Returns
mass of an electron.

◆ getERRORTOLERANT()

bool getERRORTOLERANT ( )

Returns true for an error tolerant search.

This is obtained from the ERRORTOLERANT= line in the parameters section or search__parameters table of the results file.

If getErrTolParentFilename() is empty and getERRORTOLERANT() is true, then this is an integrated error tolerant search. This is the preferred mode in Mascot Server 2.2 and later.

If getErrTolParentFilename() is not empty and getERRORTOLERANT() is true, then is this an old-style (manual) error tolerant search. Use getACCESSION() to get the list of accession numbers that were used in the error tolerant pass.

See also
https://www.matrixscience.com/help/error_tolerant_help.html
Returns
true if the search is error tolerant, false otherwise

◆ getErrTolParentFilename()

std::string getErrTolParentFilename ( )

Returns the filename of the 'parent' search for an old-style (manual) error tolerant search.

If getErrTolParentFilename() is empty and getERRORTOLERANT() is true, then this is an integrated error tolerant search. This is the preferred mode in Mascot Server 2.2 and later.

If getErrTolParentFilename() is not empty and getERRORTOLERANT() is true, then is this an old-style (manual) error tolerant search. Use getACCESSION() to get the list of accession numbers that were used in the error tolerant pass.

A manual error tolerant search is normally performed as a repeat search. The filename for the 'parent' non error tolerant search is saved in the parameters section as _errortolerantsearchparent, and can be accessed using this function.

It is not possible to use getINTERMEDIATE(), because a manual error tolerant search can be performed as a repeat search from another manual error tolerant search.

See Error tolerant searches for further details.

Returns
relative path to the parent error tolerant file

◆ getFILENAME()

std::string getFILENAME ( )

Returns the name of the uploaded file (if any).

This is obtained from the FILE= line in the parameters section or search__parameters table of the results file.

Returns
name of the uploaded file

◆ getFixedModsDelta()

double getFixedModsDelta ( int num )

Returns the delta mass of a fixed modification.

In dat28 format, this value is obtained from the FixedMod[num]= line in the masses section of the results file.

In MSR format, the values are fetched from the search__fixed_mods table.

Any number of fixed modifications can be applied during a search as long as multiple modifications don't affect the same residue/terminus. Information about fixed modifications can be found using these functions:

  • getFixedModsName(int num)
  • getFixedModsDelta(int num)
  • getFixedModsNeutralLoss(int num)
  • getFixedModsResidues(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about fixed modifications.

Parameters
num is the modification number. This number is not referenced elsewhere in the results file.
Returns
The delta, or a value of zero if no delta is found.

◆ getFixedModsName()

std::string getFixedModsName ( int num ) const

In dat28 format, this value is obtained from the FixedMod[num]= line in the masses section of the results file.

In MSR format, the values are fetched from the search__fixed_mods table.

Any number of fixed modifications can be applied during a search as long as multiple modifications don't affect the same residue/terminus. Information about fixed modifications can be found using these functions:

  • getFixedModsName(int num)
  • getFixedModsDelta(int num)
  • getFixedModsNeutralLoss(int num)
  • getFixedModsResidues(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about fixed modifications.

Parameters
num is the modification number. This number is not referenced elsewhere in the results file.
Returns
The modification name, or an empty string if no name is found.

◆ getFixedModsNeutralLoss()

double getFixedModsNeutralLoss ( int num )

Returns the neutral loss value of the specified fixed modification.

In dat28 format, this value is obtained from the FixedModNeutralLoss[num]= line in the masses section of the results file.

In MSR format, the values are fetched from the search__fixed_mods table.

Any number of fixed modifications can be applied during a search as long as multiple modifications don't affect the same residue/terminus. Information about fixed modifications can be found using these functions:

  • getFixedModsName(int num)
  • getFixedModsDelta(int num)
  • getFixedModsNeutralLoss(int num)
  • getFixedModsResidues(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about fixed modifications.

Parameters
num is the modification number. This number is not referenced elsewhere in the results file.
Returns
The neutral loss delta, or zero if no neutral loss is found. Only a single neutral loss is permitted for a fixed modifcation.

◆ getFixedModsResidues()

std::string getFixedModsResidues ( int num ) const

Returns the residues modified by the specified fixed modification.

In dat28 format, this value is obtained from the FixedModResidues[num]= line in the masses section of the results file.

In MSR format, the values are fetched from the search__fixed_mods table.

Any number of fixed modifications can be applied during a search as long as multiple modifications don't affect the same residue/terminus. Information about fixed modifications can be found using these functions:

  • getFixedModsName(int num)
  • getFixedModsDelta(int num)
  • getFixedModsNeutralLoss(int num)
  • getFixedModsResidues(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about fixed modifications.

Parameters
num is the modification number. This number is not referenced elsewhere in the results file.
Returns
The string representing which residues/terminus are modified. It will be of the form [A-Z]|C_term|N_term. Multiple residues will be listed as, for example, STY.

◆ getFORMAT()

std::string getFORMAT ( )

Returns the file format type selected by the user.

This is obtained from the FORMAT= line in the parameters section or search__parameters table of the results file.

Currently supported formats:
  • Mascot generic
  • Sequest (.DTA)
  • Finnigan (.ASC)
  • Micromass (.PKL)
  • PerSeptive (.PKS)
  • Sciex API III
  • Bruker (.XML)
  • mzData (.XML)
  • mzML (.mzML)
See also
https://www.matrixscience.com/help/data_file_help.html
Returns
file format type selected by the user

◆ getFORMVER()

std::string getFORMVER ( )

Returns the version of the form used to submit the search.

This is obtained from the FORMVER= line in the parameters section or search__parameters table of the results file.

This is currently 1.01.

Returns
version of the form used to submit the search

◆ getHydrogenMass()

double getHydrogenMass ( ) const

Returns the mass of nitrogen as specified in the Unimod file.

This is obtained from the hydrogen= line in the masses section or search__symbol_masses table of the results file.

The mass will also depend on whether monoisotopic or average masses were selected by the user. See getMASS().

These values originate from the Unimod file.

Returns
mass of nitrogen.

◆ getICAT()

bool getICAT ( )

Returns true if the user selected the ICAT button on the search form.

This is obtained from the ICAT= line in the parameters section or search__parameters table of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#ICAT
Returns
If the value in the results file is (case insensitive) ON or 1, this will return true.

◆ getINSTRUMENT()

std::string getINSTRUMENT ( )

Returns the instrument name that the user selected.

This is obtained from the INSTRUMENT= line in the parameters section or search__parameters table of the results file.

This string will be NULL for versions of Mascot prior to 1.8.

See also getRULES(). It is preferable to use the rules rather than this name to determine which ions series were searched since the user can change the definition of the name.

See also
https://www.matrixscience.com/help/search_field_help.html#INSTRUMENT
Returns
instrument name that the user selected

◆ getINTERMEDIATE()

std::string getINTERMEDIATE ( )

For a repeat search, it may be necessary to know the "parent" search.

This is obtained from the INTERMEDIATE= line in the parameters section or search__parameters table of the results file.

This function returns the file name for the results file of the 'parent' search.

Returns
file name of the parent search result file

◆ getIT_MODS()

std::string getIT_MODS ( )

Returns a comma separated list of the variable modifications used in a search.

This is obtained from the IT_MODS= line in the parameters section or search__parameters table of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#MODS
Returns
comma separated list of the variable modifications used in a search

◆ getITOL()

double getITOL ( )

Returns the tolerance for msms ions.

This is obtained from the ITOL= line in the parameters section or search__parameters table of the results file.

See also
getITOLU()
https://www.matrixscience.com/help/search_field_help.html#ITOL
Returns
tolerance for MS/MS ions

◆ getITOLU()

std::string getITOLU ( )

Returns the units that the ions tolerance is specified in.

This is obtained from the ITOLU= line in the parameters section or search__parameters table of the results file.

The units will be one of:

mmu
absolute milli-mass units, i.e. units of .001 Da
Da
absolute units of Da
ppm
fraction expressed as parts per million
See also
getITOL()
https://www.matrixscience.com/help/search_field_help.html#ITOL
Returns
unit that the ions tolerance is specified in

◆ getLIBRARY_SEARCH()

int getLIBRARY_SEARCH ( ) const

Returns a value showing whether a spectral library is allowed as a search parameter.

Available in Mascot 2.6 and later.

See also
https://www.matrixscience.com/help/spectral_library.html

The value is obtained from the LIBRARY_SEARCH= line in the parameters section or search__parameters table of the results file. If there is no such line, this method returns -1. Otherwise, the method returns 0 if LIBRARY_SEARCH is off and 1 if LIBRARY_SEARCH is on.

If LIBRARY_SEARCH is on, it means one or more DB parameter is allowed to be a spectral library. To check whether any spectral libraries were actually searched, either inspect the database types (ms_mascotresfilebase::getDatabaseType()) or check ms_mascotresfilebase::anySpectralLibraryMatches().

Returns
-1, 0 or 1.

◆ getLibraryModDelta()

double getLibraryModDelta ( int num ) const

Returns the delta mass of the specified spectral library modification.

In dat28 format, library modifications are stored in the spectral_library section of the results file. In MSR format, in search__spectral_library_mods table.

These are all the modifications contained in the spectral libraries selected for searching. Individual spectral library matches, if they have modifications, refer to modification index numbers in this list.

The modification only has a delta mass if its name was in the Unimod configuration file at the time of the search. Otherwise only its name is recorded in the spectral_library section. It is better to look up the modification by name from the Unimod configuration file than rely on the delta mass being present.

Note that the list of modifications in actual matches in the search is different. See ms_peptidesummary::getNumDiscoveredLibraryMods().

Parameters
num is library modification index. See ms_peptidesummary::getLibraryModString(). The index should be between 1 and getNumberOfLibraryMods().
Returns
modification delta mass, or 0.0 if not available.

◆ getLibraryModName()

std::string getLibraryModName ( int num ) const

Returns the name of the specified spectral library modification.

In dat28 format, library modifications are stored in the spectral_library section of the results file. In MSR format, in search__spectral_library_mods table.

These are all the modifications contained in the spectral libraries selected for searching. Individual spectral library matches, if they have modifications, refer to modification index numbers in this list.

Note that the list of modifications in actual matches in the search is different. See ms_peptidesummary::getNumDiscoveredLibraryMods().

Parameters
num is library modification index. See ms_peptidesummary::getLibraryModString(). The index should be between 1 and getNumberOfLibraryMods().
Returns
modification name. The name may be a Unimod name, or it may be a free-text string; this depends on how the library was constructed.

◆ getLICENSE()

std::string getLICENSE ( )

Returns the Mascot license string.

This string is the one in the license file, and is printed out during a Mascot search. This is obtained from the LICENSE= line in the parameters section or search__parameters table of the results file.

Returns
Mascot license string

◆ getMASS()

std::string getMASS ( )

Returns whether monoisotopic or average masses have been specified.

This is obtained from the MASS= line in the parameters section or search__parameters table of the results file. The returned text will be "Monoisotopic" or "Average" – even if the text in the results file is, for example, all upper case.

See also
getMassType() which may be a more useful function.
https://www.matrixscience.com/help/search_field_help.html#MASS
Returns
"Monoisotopic" or "Average"

◆ getMassType()

MASS_TYPE getMassType ( )

Returns either MASS_TYPE_MONO or MASS_TYPE_AVE.

The value is obtained from the MASS= line in the parameters section or search__parameters table of the results file.

See also
getMASS()
Returns
MASS_TYPE_MONO or MASS_TYPE_AVE

◆ getMaxInternalMass()

double getMaxInternalMass ( )

Returns the maximum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

The value specified for the instrument is saved in the parameters section or search__parameters table of the results file as INTERNALS=min,max. If there is no INTERNALS= line, the default value of 700.0 is returned.

A different instrument can be specified for each spectrum, in which case the values can be found using ms_inputquery::getMinInternalMass and ms_inputquery::getMaxInternalMass

See also
getRULES(), getINSTRUMENT()
Returns
The maximum internal mass considered in this search.

◆ getMinInternalMass()

double getMinInternalMass ( )

Returns the minimum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

The value specified for the instrument is saved in the parameters section or search__parameters table of the results file as INTERNALS=min,max. If there is no INTERNALS= line, the default value of 0 is returned.

A different instrument can be specified for each spectrum, in which case the values can be found using ms_inputquery::getMinInternalMass and ms_inputquery::getMaxInternalMass.

See also
getRULES() getINSTRUMENT()
Returns
The minimum internal mass considered in this search.

◆ getML_ADAPTER_PARAM()

std::vector< std::string > getML_ADAPTER_PARAM ( ) const

Returns a list of strings defined as default ML adapter parameters.

Available in Mascot 3.0 and later.

See also
https://www.matrixscience.com/help/search_field_help.html#PERCOLATE

A user can submit default ML adapter parameters as ML_ADAPTER_PARAM. This is a list of key-value parameters joined by equals sign and separated by commas. Examples of valid values:

Nothing defined:

ML_ADAPTER_PARAM=

One parameter:

ML_ADAPTER_PARAM="MS2Rescore.ms2pip_model=HCD2021"

Two parameters:

ML_ADAPTER_PARAM="MS2Rescore.ms2pip_model=HCD2021","MS2Rescore.deeplc_model=full_hc_hela_hf_psms_aligned"

This method splits the values on comma, then returns the key-value pairs as strings. The vector is suitable as input to ms_mascotresfilebase::setPercolatorFeatures().

The values available at search submission time depend on the adapters defined in mascot/config/ML_adapters.toml.

Returns
a vector of strings, or empty vector if no parameter is defined.

◆ getMODS()

std::string getMODS ( )

Returns a comma separated list of the fixed modifications used in a search.

This is obtained from the MODS= line in the parameters section or search__parameters table of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#MODS
Returns
comma separated list of the fixed modifications used in a search

◆ getMULTI_SITE_MODS()

unsigned int getMULTI_SITE_MODS ( ) const

Returns a flag showing what MULTI_SITE_MODS options were selected.

Available in Mascot 2.4 and later.

See also
ms_peptide::getSummedModsStr
Multiple modifications for the same site
Returns
the value of MULTI_SITE_MODS in the paramters section or search__parameters table of the results file. This will be one or more ms_searchparams::MULTI_SITE_MODS values OR'ed together. If there is no MULTI_SITE_MODS in the results file, then ms_searchparams::MSM_NOT_PERMITTED will be returned.

◆ getNitrogenMass()

double getNitrogenMass ( ) const

Returns the mass of nitrogen as specified in the Unimod file.

This is obtained from the nitrogen= line in the masses section or search__symbol_masses table of the results file.

The mass will also depend on whether monoisotopic or average masses were selected by the user. See getMASS().

These values originate from the Unimod file.

Returns
mass of nitrogen.

◆ getNTermMass()

double getNTermMass ( )

Returns the N terminus mass.

This is obtained from the N_term= line in the masses section or search__symbol_masses table of the results file.

The mass value will depend on whether monoisotopic or average masses were selected by the user (see getMASS()). Additionally, any fixed (but not variable) modifications are included in this mass. If no N terminus mods are specified, this value should be the same as getHydrogenMass().

These values originate from the Unimod file.

Returns
N terminus mass

◆ getNumberOfDatabases()

int getNumberOfDatabases ( )

Returns total number of databases used for the search.

This method is used in conjunction with getDB() to find out the total number of databases used in the search.

Mascot 2.6 and later support spectral libraries. The total number of databases searched includes the protein sequence and nucleic acid databases and spectral libraries, but does not include any reference databases of spectral libraries.

Returns
The number of databases and libraries used in the search.

◆ getNumberOfLibraryMods()

int getNumberOfLibraryMods ( ) const

Return the number of modifications in the spectral libraries searched.

In dat28 format, library modifications are stored in the spectral_library section of the results file. In MSR format, in search__spectral_library_mods table.

These are all the modifications contained in the spectral libraries selected for searching. Individual spectral library matches, if they have modifications, refer to modification index numbers in this list.

Note that the list of modifications in actual matches in the search is different. See ms_peptidesummary::getNumDiscoveredLibraryMods().

Returns
the number of entries in the spectral_library section, which equals the last non-empty index X in the ModX= lines.

◆ getOVERVIEW()

bool getOVERVIEW ( )

Returns true if the user selected the option to show the overview table.

This is obtained from the OVERVIEW= line in the parameters section or search__parameters table of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#OVERVIEW
Returns
True if the value is (case insensitive) ON or 1.

◆ getOxygenMass()

double getOxygenMass ( ) const

Returns the mass of oxygen as specified in the Unimod file.

This is obtained from the oxygen= line in the masses section or search__symbol_masses table of the results file.

The mass will also depend on whether monoisotopic or average masses were selected by the user. See getMASS().

These values originate from the Unimod file.

Returns
mass of oxygen.

◆ getPEP_ISOTOPE_ERROR()

int getPEP_ISOTOPE_ERROR ( ) const

Returns a value showing how a peak detection error is handled.

Available in Mascot 2.2 and later.

See also
https://www.matrixscience.com/help/search_field_help.html#PEP_ISOTOPE_ERROR

Normal test for a peptide match is

exp > calc-tol  && exp < calc+tol

If PEP_ISOTOPE_ERROR >= 1, also test for

exp > calc+1.003+tol && exp < calc+1.003-tol

If PEP_ISOTOPE_ERROR >= 2, also test for

exp > calc+2.007+tol && exp < calc+2.007-tol
Returns
The value of PEP_ISOTOPE_ERROR in the parameters section or search__parameters table of the results file. If there is no PEP_ISOTOPE_ERROR value in the results file, then -1 is returned.

◆ getPERCOLATE()

int getPERCOLATE ( ) const

Returns a value showing if Percolator is selected as a search parameter.

Available in Mascot 3.0 and later.

See also
https://www.matrixscience.com/help/search_field_help.html#PERCOLATE

The value is obtained from the PERCOLATE= line in the parameters section or search__parameters table of the results file. If there is no such line, this method returns -1. Otherwise, the method returns 0 if PERCOLATE is off and 1 if PERCOLATE is on.

Returns
-1, 0 or 1.

◆ getPFA()

int getPFA ( )

Returns the number of missed cleavage points allowed for in a search.

This is obtained from the PFA= line in the parameters section or search__parameters table of the results file

See also
https://www.matrixscience.com/help/search_field_help.html#PFA
Returns
number of missed cleavage points allowed for in a search

◆ getPRECURSOR()

double getPRECURSOR ( )

Returns the precursor mass for an MS/MS query.

This is obtained from the PRECURSOR= line in the parameters section or search__parameters table of the results file.

Three data file formats, SCIEX API III and PerSeptive (.PKS) and Bruker (.XML), do not include m/z information for the precursor peptide. For these formats only, the Precursor field is used to specify the m/z value of the parent peptide.

See also
https://www.matrixscience.com/help/search_field_help.html#PRECURSOR
Returns
precursor mass for an MS-MS query

◆ getQUANTITATION()

std::string getQUANTITATION ( ) const

Returns the name of the quantitation method used.

Available in Mascot 2.2 and later.

See also
https://www.matrixscience.com/help/search_field_help.html#QUANTITATION
Returns
If no quantitation is specified, an empty string or "None". Otherwise return the name of the quantitation method from the QUANTITATION= value in the parameters section or search__parameters table of the results file.

◆ getQUE()

std::string getQUE ( )

Currently returns an empty string.

This is obtained from the QUE= line in the parameters section or search__parameters table of the results file.

Returns
QUE

◆ getREPORT()

int getREPORT ( )

Returns the number of results to show in the report.

This is obtained from the REPORT= line in the parameters section or search__parameters table of the results file. For 'AUTO' a value of 0 is returned.

See also
https://www.matrixscience.com/help/search_field_help.html#REPORT
Returns
number of results to show in the report

◆ getREPTYPE()

std::string getREPTYPE ( )

Returns the type of report requested by the user.

This is obtained from the REPTYPE= line in the parameters section or search__parameters table of the results file

This will be one of:

  • concise
  • peptide
  • protein
See also
https://www.matrixscience.com/help/results_help.html
Returns
type of report requested by the user

◆ getResidueMass()

double getResidueMass ( char residue )

Returns the mass of the specified residue (must be uppercase letter A-Z).

This is obtained from the A=,B= etc. line in the masses section or search__symbol_masses table of the results file.

The mass value will depend on whether monoisotopic or average masses were selected by the user (see getMASS()). Additionally, any fixed (but not variable) modifications are included in this mass.

Parameters
residue uppercase letter A-Z
Returns
mass of the specified residue

◆ getRULES()

std::string getRULES ( )

Returns as a comma separated list, the rules / ions series used for a search.

This is obtained from the RULES= line in the parameters section or search__parameters table of the results file.

The numbers in the comma separated list have the following meanings:

   1 = singly charged
   2 = doubly charged if precursor 2+ or higher (not internal or immonium)
   3 = doubly charged if precursor 3+ or higher (not internal or immonium)
   4 = immonium
   5 = a series
   6 = a - NH3 if a significant and fragment includes RKNQ
   7 = a - H2O if a significant and fragment includes STED
   8 = b series
   9 = b - NH3 if b significant and fragment includes RKNQ
   10= b - H2O if b significant and fragment includes STED
   11= c series
   12= x series
   13= y series
   14= y - NH3 if y significant and fragment includes RKNQ
   15= y - H2O if y significant and fragment includes STED
   16= z series
   17= internal yb < 700 Da
   18= internal ya < 700 Da
   19= y or y++ must be significant
   20= y or y++ must be highest scoring series
   21= z+1 series
   22= d and d' series
   23= v series
   24= w and w' series
   25= z+2 series
See also
getINSTRUMENT() to find the descriptive name of the selected instrument.
https://www.matrixscience.com/help/search_field_help.html#INSTRUMENT
Returns
comma separated list, the rules / ions series used for a search

◆ getSEARCH()

std::string getSEARCH ( )

Returns the type of search – this will be PMF, SQ, MIS.

This is obtained from the SEARCH= line in the parameters section or search__parameters table of the results file.

Rather than using this value directly, it is generally easier to use the functions ms_mascotresfilebase::isMSMS(), ms_mascotresfilebase::isPMF() or ms_mascotresfilebase::isSQ(), and it is normally safer to use ms_mascotresfilebase::anyMSMS(), ms_mascotresfilebase::anyPMF() and ms_mascotresfilebase::anySQ().

Returns
type of the search

◆ getSEG()

int getSEG ( )

Returns the segment or protein mass.

This is obtained from the SEG= line in the parameters section or search__parameters table of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#SEG
Returns
segment or protein mass

◆ getSUBCLUSTER()

int getSUBCLUSTER ( )

Returns the sub cluster number.

This is obtained from the SUBCLUSTER= line in the parameters section or search__parameters table of the results file.

For a large cluster, split up into multiple sub clusters, this returns the sub cluster number.

Returns
The subcluster number.

◆ getTARGET_FDR_PERCENT()

double getTARGET_FDR_PERCENT ( ) const

Returns the target FDR specified as a search parameter.

Available in Mascot 2.8 and later.

See also
https://www.matrixscience.com/help/decoy_help.html#AUTO

The value is obtained from the TARGET_FDR_PERCENT= line in the parameters section or search__parameters table of the results file. If there is no such line, or the value is not a floating point number, this method returns 0.0.

Returns
0.0, or target FDR specified as a percentage.

◆ getTAXONOMY()

std::string getTAXONOMY ( )

Returns the name of the taxonomy selection.

This is obtained from the TAXONOMY= line in the parameters section or search__parameters table of the results file.

To find out exactly which taxa were included and excluded from the search, inspect ms_mascotresfilebase::getTaxonomy().

See also
https://www.matrixscience.com/help/search_field_help.html#TAXONOMY
Returns
name of the taxonomy selection

◆ getTOL()

double getTOL ( )

Returns the peptide tolerance for the search.

This is obtained from the TOL= line in the parameters section or search__parameters table of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#TOL
Returns
peptide tolerance for the search

◆ getTOLU()

std::string getTOLU ( )

Returns the peptide tolerance units for the search.

This is obtained from the TOLU= line in the parameters section or search__parameters table of the results file.

The units will be one of:

%%
fraction expressed as a percentage
mmu
absolute milli-mass units, i.e. units of .001 Da
Da
absolute units of Da
ppm
fraction expressed as parts per million
See also
https://www.matrixscience.com/help/search_field_help.html#TOL
Returns
peptide tolerance units for the search

◆ getUSEREMAIL()

std::string getUSEREMAIL ( )

Returns the user's email address (if any) as entered in the search form.

This is obtained from the USERMAIL= line in the parameters section or search__parameters table of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#NAME
Returns
user email

◆ getUSERField()

std::string getUSERField ( int num )

Returns the user fields USER00, USER01, USER02 ... USER12.

Parameters
num must be in the range 0..12.
Returns
user fields

◆ getUSERID()

int getUSERID ( )

Returns the user's USERID.

This is obtained from the USERID= line in the parameters section or search__parameters table of the results file. This value is the user's ID if Mascot security is enabled.

Searches prior to version 2.1 will not have this parameter, in which case it will return 0. For searches with Mascot 2.1 or later, where security is not enabled, this function will also return 0.

See Mascot security and authentication module

Returns
user id

◆ getUSERNAME()

std::string getUSERNAME ( )

Returns the user name (if any) as entered in the search form.

This is obtained from the USERNAME= line in the parameters section or search__parameters table of the results file.

See also
https://www.matrixscience.com/help/search_field_help.html#NAME
Returns
user name as entered in the search form

◆ getVarModsDelta()

double getVarModsDelta ( int num )

Returns the delta mass for a variable modification.

In dat28 format, this value is obtained from the delta[num]= line in the masses section of the results file. In MSR format, from the search__variable_mods table.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns
delta mass for a variable modification

◆ getVarModsName()

std::string getVarModsName ( int num ) const

In dat28 format, this value is obtained from the delta[num]= line in the masses section of the results file. In MSR format, from the search__variable_mods table.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns
name of the specified variable modification selected by the user

◆ getVarModsNeutralLoss()

double getVarModsNeutralLoss ( int num )

Returns the first neutral loss value of the specified variable modification.

Note
This function is deprecated, since it only returns a single neutral loss value. This function has been replaced with getVarModsNeutralLosses() which returns multiple neutral losses

In dat28 format, the value is obtained from the NeutralLoss[num]= line in the masses section of the results file. In MSR format, from the search__variable_mod_nl table.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns
first neutral loss value for the specified variable modification.

◆ getVarModsNeutralLosses()

std::vector< double > getVarModsNeutralLosses ( int num ) const

Returns all the neutral loss values of the specified variable modification.

In dat28 format, The first neutral loss is obtained from the NeutralLoss[num]= line in the masses section of the results file. Subsequent neutral losses considered (if any) are obtained from the NeutralLoss[num]_master= line; the first value on the comma separated line would be for neutralLossNum=2, the second for neutralLossNum=3 etc.

In MSR format, the values are fetched from the search__variable_mod_nl table.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns
neutral loss values for the specified variable modification

◆ getVarModsPepNeutralLoss()

std::vector< double > getVarModsPepNeutralLoss ( int num )

Returns the peptide neutral loss value(s) of the specified variable modification.

In dat28 format, this value is obtained from the PepNeutralLoss[num]= line in the masses section of the results file.

In MSR format, the values are fetched from the search__variable_mod_nl table.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns
peptide neutral loss value(s) for the specified variable modification

◆ getVarModsReqPepNeutralLoss()

std::vector< double > getVarModsReqPepNeutralLoss ( int num )

Returns the required peptide neutral loss value(s) of the specified variable modification.

In dat28 format, these value is obtained from the ReqPepNeutralLoss[num]= line in the masses section of the results file.

In MSR format, the values are fetched from the search__variable_mod_nl table.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns
required peptide neutral loss value(s) for the specified variable modification

◆ hasINTERNALS()

bool hasINTERNALS ( ) const

Returns true if minimum or maximum internal fragment mass was specified.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

The value specified for the instrument is saved in the parameters section or search__parameters table of the results file as INTERNALS=min,max. If there is no INTERNALS= line, this method returns false.

Use getMinInternalMass() and getMaxInternalMass() to access the values.

Returns
true if INTERNALS= was specified.
The documentation for this class was generated from the following files:
  • ms_searchparams.hpp
  • ms_searchparams.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_unigene Class Reference

  • matrix_science
  • ms_unigene
Public Member Functions | Protected Member Functions | List of all members
ms_unigene Class Referenceabstract
Mascot results file module

This class encapsulates a complete unigene file. More...

#include <ms_unigene.hpp>

Inherited by ms_unigene_dat.

Collaboration diagram for ms_unigene:
[legend]

Public Member Functions

ms_unigene (const ms_mascotresfilebase &resfile, const char *filename)
The constructor for a unigene object.
virtual const ms_unigene_entry * | findEntry (const char *id)=0
Given an accession, return a pointer to the relevant unigene entry.
virtual std::string | getUnigeneForAccession (const std::string accession, const int index)=0
Return the Unigene 'accession' (ID) for a given EST accession.

Protected Member Functions

void addAccessionUnigenePair (const ms_unigene_entry *unigene, const std::string &accession)
Used internally to create a lookup of gi numbers to a list of accessions.

Detailed Description

This class encapsulates a complete unigene file.

Creating one of these objects reads in the unigene file, creating a number of ms_unigene_entry objects. The gi and EMBL accessions are all indexed.

The documentation for this class was generated from the following files:
  • ms_unigene.hpp
  • ms_unigene.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_unigene_entry Class Reference

  • matrix_science
  • ms_unigene_entry
Public Member Functions | List of all members
ms_unigene_entry Class Reference
Mascot results file module

This class encapsulates a single entry from a unigene file. More...

#include <ms_unigene.hpp>

Public Member Functions

ms_unigene_entry (const std::string &id, const std::string &title, const std::string &gene, const std::string &cytoBand, const std::string &locusLink, const std::string &express, const long chromosome, const int numAccessions, const OFFSET64_T fileOffset)
This constructor should only be called from within the library.
ms_unigene_entry (FILE *f, ms_unigene &unigene)
This constructor should only be called from within the library.
~ms_unigene_entry ()
Destructor.
long | getChromosome () const
Return the chromosome that contains the unignene entry.
std::string | getCytoBand () const
Return the CYTOBAND - e.g. 4q21-q23.
std::string | getExpress () const
Return the EXPRESS entry. Can be very long - 5000 bytes.
OFFSET64_T | getFileOffset () const
Return the offset into the unigene data file for this entry.
std::string | getGene () const
Return the gene name for this entry - e.g. "ADH1B".
std::string | getID () const
Return the 'ID' of this entry - e.g. Hs.4.
std::string | getLocusLink () const
Return the LocusLink - e.g. 125.
int | getNumAccessions () const
Return the number of accessions (gi numbers or EMBL accessions) that comprise this entry.
std::string | getTitle () const
Return the 'title' of this entry - e.g. "alcohol dehydrogenase...".

Detailed Description

This class encapsulates a single entry from a unigene file.

A number of objects of this class will be created when a ms_unigene object is created.

Constructor & Destructor Documentation

◆ ms_unigene_entry() [1/2]

ms_unigene_entry | ( | FILE * | f,
 |  | ms_unigene & | unigene
 | ) |  |

This constructor should only be called from within the library.

Reads lines in the file up to the next // and fills the object.

If the id_ value is empty, (use getID()) or the number of accessions (use getNumAccessions()) then the object has not been initialised correcty

Parameters
f | is a file pointer returned by the 'C' fopen() function
unigene | is the object that stores all the accession -> id mappings.

◆ ms_unigene_entry() [2/2]

ms_unigene_entry | ( | const std::string & | id,
 |  | const std::string & | title,
 |  | const std::string & | gene,
 |  | const std::string & | cytoBand,
 |  | const std::string & | locusLink,
 |  | const std::string & | express,
 |  | const long | chromosome,
 |  | const int | numAccessions,
 |  | const OFFSET64_T | fileOffset
 | ) |  |

This constructor should only be called from within the library.

Parameters
id | is the unigene id as returned by the getID() function.
title | is the unigene title as returned by the getTitle() function.
gene | is the gene name as returned by the getGene() function.
cytoBand | is the CYTOBAND as returned by the getCytoBand() function.
locusLink | is the LocusLink as returned by the getLocusLink() function.
express | is EXPRESS entry as returned by the getExpress() function.
chromosome | is the chromosome that contains the unignene entry as returned by the getChromosome() function.
numAccessions | is the number of accessions that comprise this unigene entry.
fileOffset | is the byte offset into the .data file for this unigene entry.

Member Function Documentation

◆ getChromosome()

long getChromosome ( ) const
inline

Return the chromosome that contains the unignene entry.

Returns
the chromosome number

◆ getCytoBand()

std::string getCytoBand ( ) const
inline

Return the CYTOBAND - e.g. 4q21-q23.

Returns
the CYTOBAND

◆ getExpress()

std::string getExpress ( ) const
inline

Return the EXPRESS entry. Can be very long - 5000 bytes.

For example, can be of the form:

adipose tissue| blood| bone marrow| brain| connective tissue| dorsal
Returns
the express entry string.

◆ getFileOffset()

OFFSET64_T getFileOffset ( ) const
inline

Return the offset into the unigene data file for this entry.

This function returns quickly if an index file has been created.

Returns
the number of bytes into the file where this entry starts

◆ getGene()

std::string getGene ( ) const
inline

Return the gene name for this entry - e.g. "ADH1B".

Returns
the gene name

◆ getID()

std::string getID ( ) const
inline

Return the 'ID' of this entry - e.g. Hs.4.

Returns
the ID (also called accession) for the entry

◆ getLocusLink()

std::string getLocusLink ( ) const
inline

Return the LocusLink - e.g. 125.

Seems to be identical to the gene number in most cases?

Returns

◆ getNumAccessions()

int getNumAccessions ( ) const
inline

Return the number of accessions (gi numbers or EMBL accessions) that comprise this entry.

The accessions themselves cannot be returned from this object. See ms_unigene::findEntry

Returns
The number of accessions

◆ getTitle()

std::string getTitle ( ) const
inline

Return the 'title' of this entry - e.g. "alcohol dehydrogenase...".

Returns
a readable name for the entry.
The documentation for this class was generated from the following files:
  • ms_unigene.hpp
  • ms_unigene.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Mascot configuration files module

Modules | Classes | Enumerations
Mascot configuration files module

Modules

Configuration files
Examples for the configuration files module
Fixed values for quantitation.xml
Fixed values for crosslinking.xml

Classes

class | ms_clusterparams
An instance of this class represents all the parameters specified in the Cluster section of mascot.dat. More...
class | ms_computeraddress
The class serves as a container for computer address parameters for cluster mode. More...
class | ms_cronjob
Represents a single entry from the cron section of mascot.dat. More...
class | ms_cronoptions
Contains parameters from the cron section of mascot.dat. More...
class | ms_crosslinking_accession
Accession element in crosslinking.xml More...
class | ms_crosslinking_accessions
Accessions element in crosslinking.xml More...
class | ms_crosslinking_configfile
This class represents the file crosslinking.xml. More...
class | ms_crosslinking_does_not_pair_with
mxm:does_not_pair_with element in crosslinking.xml More...
class | ms_crosslinking_filters
Filters element in crosslinking.xml More...
class | ms_crosslinking_linker
Linker element in crosslinking.xml More...
class | ms_crosslinking_linkers
Linkers element in crosslinking.xml More...
class | ms_crosslinking_method
Represents a method object in crosslinking.xml More...
class | ms_crosslinking_monolink
Monolink element in crosslinking.xml More...
class | ms_crosslinking_parameter
Parameter name and value pair. More...
class | ms_crosslinking_parameters
A class that represents base parametersType in crosslinking_1.xsd. More...
class | ms_crosslinking_scope
Scope element in crosslinking.xml More...
class | ms_crosslinking_settings
Settings element in crosslinking.xml More...
class | ms_databaseoptions
An instance of this class represents a single database definition from the Databases section of mascot.dat. More...
class | ms_databases
An instance of this class represents the Databases section of mascot.dat. More...
class | ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters. More...
class | ms_dbprocessors
Represent a single dabatase entry in the Processors section. More...
class | ms_enzyme
Represent a single entry in the enzymes file. More...
class | ms_enzymefile
Reads and parses the enzymes file that contains multiple enzyme definitions. More...
class | ms_fragmentationrules
This class encapsulates a single entry (an instrument) from a fragmentation_rules file. More...
class | ms_fragrulesfile
This class encapsulates a complete fragmentation_rules file. More...
class | ms_libraryoptions
Represents the LibraryOptions section of mascot.dat. More...
class | ms_license
The class provides access license details in read-only mode. More...
class | ms_mascotfiles
An instance of this class contains configuration files paths (except for mascot.dat). More...
class | ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot.dat. More...
class | ms_masses
Reads and parses the masses file with residue and atom masses. More...
class | ms_modfile
Use this class in order to read in the amino acid modification file. More...
class | ms_modification
The class represents a single modification-entry in mod_file. More...
class | ms_modvector
General usage class for creating lists of modifications to be passed as parameters. More...
class | ms_obofile
The class provides simplified access to ontology files in the .obo format. More...
class | ms_parseoptions
Represents the PARSE section of mascot.dat. More...
class | ms_parserule
Represents a single regular expression parsing rule. More...
class | ms_parserule_plus
Represents regular expression parse rule plus some additional parameters. More...
class | ms_processoroptions
An instance of this class represents all the parameters specified in the Processors section of mascot.dat. More...
class | ms_processors
This class is designed to retrieve current CPU configuration on the computer and set affinity. More...
class | ms_quant_average
An object of this class represent a single "average" element in quantitation.xml. More...
class | ms_quant_component
An object of this class represent a single component element in quantitation.xml. More...
class | ms_quant_composition
Describes the compositionType type in quantitation.xml. More...
class | ms_quant_configfile
Use this class in order to read/write quantitation.xml. More...
class | ms_quant_correction
Represents a correction element. More...
class | ms_quant_element
The element sub-element of compositionType in quantitation.xml. More...
class | ms_quant_file_index
Represents a file_index element. More...
class | ms_quant_integration
An object of this class represent a single integration element in quantitation.xml. More...
class | ms_quant_isotope
Represents an isotope element. More...
class | ms_quant_localdef
Represents a local_definition element. More...
class | ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml. More...
class | ms_quant_modgroup
An object of this class represent a single modification group element in quantitation.xml. More...
class | ms_quant_moverz
Parameter name and value pair. More...
class | ms_quant_multiplex
An object of this class represent a multiplex element in quantitation.xml. More...
class | ms_quant_neutralloss
A neutral loss for the sequence ions, e.g. loss of phosphate. More...
class | ms_quant_normalisation
An object of this class represent a single normalisation element in quantitation.xml. More...
class | ms_quant_normalisation_peptide
An object of this class represent a single peptide element in quantitation.xml. More...
class | ms_quant_normalisation_peptides
An object of this class represent a collection of peptide elements in quantitation.xml. More...
class | ms_quant_normalisation_protein
An object of this class represent a single protein element in quantitation.xml. More...
class | ms_quant_normalisation_proteins
An object of this class represent a collection of peptide elements in quantitation.xml. More...
class | ms_quant_numerator
Represent numerator_component and denominator_component elements. More...
class | ms_quant_outliers
An object of this class represent a single OUTLIERS element in quantitation.xml. More...
class | ms_quant_parameter
Parameter name and value pair. More...
class | ms_quant_parameters
A class that represents base parametersType in quantitation.xml. More...
class | ms_quant_pepneutralloss
A neutral loss from the precursor. More...
class | ms_quant_precursor
An object of this class represent a single precursor element in quantitation.xml. More...
class | ms_quant_protocol
An object of this class represent a protocol element in quantitation.xml. More...
class | ms_quant_quality
An object of this class represent a single quality element in quantitation.xml. More...
class | ms_quant_ratio
Represents the ratioType type for the report_ratio element in quantitation.xml. More...
class | ms_quant_replicate
An object of this class represent a single replicate element in quantitation.xml. More...
class | ms_quant_reporter
An object of this class represents a single reporter element in quantitation.xml. More...
class | ms_quant_satellite
An object of this class represent a single satellite element in quantitation.xml. More...
class | ms_quant_specificity
Describes a specificity element in quantitation.xml (Unimod style specificity). More...
class | ms_quant_unmodified
Describes an unmodified element in quantitation.xml. More...
class | ms_taxnodesfiles
Filenames and formats for taxonomy nodes or genetic codes files. More...
class | ms_taxonomychoice
The class represents a single taxonomy choice entry in the taxonomy file. More...
class | ms_taxonomyfile
Use this class in order to read in a taxonomy file. More...
class | ms_taxonomyrules
This class represents a single Taxonomy_XXX section in mascot.dat. More...
class | ms_taxonomytree
The complete taxonomy tree as built from one or more files such as nodes.dmp. More...
class | ms_taxspeciesfiles
An instance of this class describes one entry of taxonomy species files. More...
class | ms_umod_aminoacid
Represents an "amino acid" object in unimod.xml. More...
class | ms_umod_composition
Represents the composition type in unimod.xml. More...
class | ms_umod_configfile
This class represents the file unimod.xml. More...
class | ms_umod_element
Represents an element object in unimod.xml. More...
class | ms_umod_elemref
Represents the elemref_t type in unimod.xml. More...
class | ms_umod_modbrick
Represents a modification brick object in unimod.xml. More...
class | ms_umod_modification
Represents a modif object in unimod.xml. More...
class | ms_umod_neutralloss
Represents NeutralLoss and PepNeutralLoss objects in unimod.xml. More...
class | ms_umod_specificity
Represents modification specificity objects in unimod.xml. More...
class | ms_umod_xref
Represents the cross references objects in unimod.xml. More...
class | ms_unigeneoptions
An instance of this class represents all the parameters specified in UniGene section of mascot.dat. More...
class | ms_wwwentry
Represent a single entry in the WWW section of mascot.dat. More...
class | ms_wwwoptions
Represents the whole WWW section. More...
class | ms_xml_parameter
Parameter name and value pair. More...
class | ms_xml_parameters
A class that represents a base parametersType. More...

Enumerations

enum { MAX_VAR_MODS = 'W' -'A' + 10 }
Maximum number of variable mods. More...
enum DATABASE_TYPE {
AA =0 ,
NA =1 ,
SL =2 ,
SLREF =3
}
enum MASS_TYPE {
MASS_TYPE_MONO = 0x0000 ,
MASS_TYPE_AVE = 0x0001
}
All possible mass types. More...
enum MOD_TYPES {
MOD_TYPE_RESIDUE = 0 ,
MOD_TYPE_N_TERM = 1 ,
MOD_TYPE_C_TERM = 2 ,
MOD_TYPE_N_PROTEIN = 3 ,
MOD_TYPE_C_PROTEIN = 4 ,
MOD_TYPE_N_TERM_RESIDUE = 5 ,
MOD_TYPE_C_TERM_RESIDUE = 6 ,
MOD_TYPE_N_PROTEIN_RESIDUE = 7 ,
MOD_TYPE_C_PROTEIN_RESIDUE = 8 ,
MOD_TYPE_______LAST = 9
}
enum OPERATING_SYS {
_OS_UNKNOWN = 0 ,
_OS_WINDOWS_NT = 1 ,
_OS_LINUX = 2 ,
_OS_NUM_OPERATING_SYS = 3
}
enum TAX_NODE_FORMAT {
TAX_NODE_NCBI ,
TAX_NODE_GENCODE
}
enum TAX_SPECIES_FORMAT {
TAX_SPECIES_NCBI ,
TAX_SPECIES_SWISSPROT ,
TAX_SPECIES_PDB ,
TAX_SPECIES_GI2TAXID ,
TAX_SPECIES_ACC2TAXID ,
TAX_SPECIES_EXPLICIT ,
TAX_SPECIES_FORMAT_COUNT
}
enum WWW_TYPE {
WWW_SEQ = 0 ,
WWW_REP = 1
}

Detailed Description

The Mascot configuration files module is used to simplify retrieving and saving information to the configuration files.

Enumeration Type Documentation

◆ anonymous enum

anonymous enum

Maximum number of variable mods.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
MAX_VAR_MODS

The results file uses 1..9 and A..W (1..32).

◆ DATABASE_TYPE

enum DATABASE_TYPE

Definition of all supported database types.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
AA | Protein sequence database (FASTA file, amino acid)
NA | NA sequence database (FASTA file, nucleic acid)
SL | Spectral Library (MSP file)
SLREF | FASTA reference database of a Spectral Library.

◆ MASS_TYPE

enum MASS_TYPE

All possible mass types.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
MASS_TYPE_MONO | monoisotopic mass index
MASS_TYPE_AVE | average mass index

◆ MOD_TYPES

enum MOD_TYPES

Definitions for possible modification types.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
MOD_TYPE_RESIDUE | Applies to specific residues, independent of position within the peptide.
MOD_TYPE_N_TERM | Applies to the peptide N-terminus, independent of residue identity.
MOD_TYPE_C_TERM | Applies to the peptide C-terminus, independent of residue identity.
MOD_TYPE_N_PROTEIN | Applies to the protein N-terminus, independent of residue identity.
MOD_TYPE_C_PROTEIN | Applies to the protein C-terminus, independent of residue identity.
MOD_TYPE_N_TERM_RESIDUE | Applies to a specific residue only when that residue is at N-terminus.
MOD_TYPE_C_TERM_RESIDUE | Applies to a specific residue only when that residue is at C-terminus.
MOD_TYPE_N_PROTEIN_RESIDUE | Applies to a specific residue only when that residue is at N-terminus of a protein.
MOD_TYPE_C_PROTEIN_RESIDUE | Applies to a specific residue only when that residue is at C-terminus of a protein.

◆ OPERATING_SYS

enum OPERATING_SYS

List of all supported operating systems (past and present)

Mascot runs on a number of different operating systems. The following are currently supported.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
_OS_UNKNOWN | Unknown OS.
_OS_WINDOWS_NT | WindowsXXX.
_OS_LINUX | Linux.
_OS_NUM_OPERATING_SYS | Placeholder.

◆ TAX_NODE_FORMAT

enum TAX_NODE_FORMAT

Possible formats for the nodes.dmp and gencode.dmp files.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TAX_NODE_NCBI | NCBI nodes.dmp format.
TAX_NODE_GENCODE | NCBI gencode.dmp format.

◆ TAX_SPECIES_FORMAT

enum TAX_SPECIES_FORMAT

All possible taxonomy species file formats.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TAX_SPECIES_NCBI | NCBI names.dmp taxonomy species files.
TAX_SPECIES_SWISSPROT | SwissProt.
TAX_SPECIES_PDB | PDB.
TAX_SPECIES_GI2TAXID | GI2TAXID.
TAX_SPECIES_ACC2TAXID | Simple 'accession taxID' (any whitespace).
TAX_SPECIES_EXPLICIT | No lookup required, because the ID is given in the description line. For example: >IPI:IPI00000001.2 Tax_Id=9606 Double-stranded RNA ...

◆ WWW_TYPE

enum WWW_TYPE

All supported types of entries in the WWW section.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
WWW_SEQ | Sequence string source.
WWW_REP | Full text report source.
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Configuration files

Configuration files
Mascot configuration files module

Mascot configuration files are represented by library classes and can be dealt with programmatically from programs written in the supported languages.

Configuration file classes

The following configuration files are supported:

mascot.dat

Main configuration file represented by the ms_datfile class and divided into several sections. Each section is, in turn, represented by a corresponding class.

enzymes

List of available enzymes. The corresponding class is ms_enzymefile.

fragmentation_rules

Information about available instruments for MS/MS searches; represented by ms_fragrulesfile.

mascot.license

Software license file that can only be local read-only file. The corresponding class ms_license allows checking the validity of the license and to obtain some additional information. Please note the ms_license class will only work with license files from Mascot release 2.3 or earlier.

masses

Chemical elements and amino acid masses. Can be read/written with ms_masses.

mod_file and substitutions

Modifications for regular and error-tolerant searches, respectively. The single class ms_modfile can process both of them.

unimod.xml

Protein modifications; can be accessed in read-only mode on http://www.unimod.org using either ms_modfile or ms_umod_configfile.

quantitation.xml
Configuration parameters for quantitation experiments; represented by ms_quant_configfile.

One additional class, ms_processors, doesn't correspond to any file but can be used to obtain information about available CPUs in the system.

All files except for mascot.license and unimod.xml can be read and written locally in text format. ms_modfile can import the unimod.xml file and then store all configuration information in a local text file, but not vice versa. ms_umod_configfile allows changing the content and saving unimod.xml in XML-format locally.

Each configuration file class provides a range of get/set methods for accessing individual properties. Instances of the classes can be used even without accessing a physical or remote file; default values are provided where appropriate. However, classes that represent configuration files with many entries (enzymes, instruments, modifications, etc.) will by default contain empty lists of entries.

In general, all files except for mascot.license can be accessed remotely via Internet, altered and then stored locally (if needed). These operations are described in more detail below.

Reading from and writing to configuration files

Reading from a configuration file can be done in two ways. The easiest way is to use an immediate-action constructor that accepts a string file name as a parameter:

C++
    matrix_science::ms_datfile datFile("../config/mascot.dat");

    if ( datFile.isValid() )
    {
        // extract some properties here
        // ...
    }

Perl
    my $datFile = msparser::ms_datfile->new("../config/mascot.dat");

    if ($datFile->isValid()) {
        # extract some properties here
        # ...
    }

Java and C#
    ms_datfile datFile = new ms_datfile("../config/mascot.dat");

    if (datFile.isValid())
    {
        // extract some properties here
        // ...
    }

Python
    ms_datfile = msparser.ms_datfile("../config/mascot.dat")

    if datFile.isValid() :
        # extract some properties here
        # ...

As shown in the last example, an object has to be tested for the presence of any fatal errors before continuing any work with it. Possible errors include a missing or inaccessible file as well as wrong file format or inconsistent values. Every class representing a configuration file is derived from ms_errors; please refer to Error Handling for details.

Another way to read from a file is to create an instance of representing class, set a file name and call the read_file() method:

C++
    ms_enzymefile enzFile();
    enzFile.setFileName("../config/enzymes");
    enzFile.read_file();

    if (enzFile.isValid())
    {
        // obtain information here
        // ...
    }

Perl
    my $enzFile = new msparser::ms_enzymefile();
    $enzFile->setFileName("../config/enzymes");
    $enzFile->read_file();

    if ($enzFile->isValid()) {
        # obtain information here
        # ...
    }

Java and C#
    ms_enzymefile enzFile = new ms_enzymefile();
    enzFile.setFileName("../config/enzymes");
    enzFile.read_file();

    if (enzFile.isValid())
    {
        // obtain information here
        // ...
    }

Python
    enzFile = msparser.ms_enzymefile()
    enzFile.setFileName("../config/enzymes")
    enzFile.read_file()

    if enzFile.isValid() :
        # obtain information here
        # ...

One exception to these examples is ms_quant_configfile, which requires a local path to an XML schema file in addition to the quantitation.xml file name and path. You can submit the schema path to either the constructor or by using the setSchemaFileName() method:

C++
    // Here we access the file remotely (see below for more information), but
    // a local file name can also be used. However, the schema file should be
    // stored locally.
    ms_quant_configfile quantFile("http://localhost/mascot/cgi", "C:\quantitation_1.xsd");

    if (quantFile.isValid()) {
        // obtain information here
        // ...
    }

Perl
    # Here we access the file remotely (see below for more information), but
    # a local file name can also be used. However, the schema file should be
    # stored locally.
    my $quantFile = new msparser::ms_quant_configfile(
        "http://localhost/mascot/cgi", "C:\quantitation_1.xsd"
    );

    if ($quantFile->isValid()) {
        # obtain information here
        # ...
    }

Java and C#
    // Here we access the file remotely (see below for more information), but
    // a local file name can also be used. However, the schema file should be
    // stored locally.
    ms_quant_configfile quantFile = new ms_quant_configfile(
        "http://localhost/mascot/cgi", "C:\quantitation_1.xsd"
    );

    if (quantFile.isValid()) {
        // obtain information here
        // ...
    }

Python
    # Here we access the file remotely (see below for more information), but
    # a local file name can also be used. However, the schema file should be
    # stored locally.
    quantFile = msparser.ms_quant_configfile(
        "http://localhost/mascot/cgi", "C:\quantitation_1.xsd"
        )

    if quantFile.isValid() :
        # obtain information here
        # ...

The quantitation schema file is distributed as part of Mascot Parser and should not be changed to avoid parsing problems.

Writing to files is only allowed on local files (on a hard disc or in a local network). Writing can be done via using the save_file() method. You can use setFileName() to change the file name and path if you need to save the file in a new location.

XML-format configuration files

unimod.xml can be opened with ms_modfile; supply it with the full file name (absolute or relative) that has a proper extension '.xml'. Files with any other extension will be treated as being in a text format.

ms_modfile cannot be used to save data in unimod.xml. If the content is initially imported from it, then it can only be stored as a new text file with a different name. One of the reasons for this restriction lies in inevitable loss of information while importing Unimod files. ms_umod_configfile was designed to overcome this limitation.

Remote file location

All configuration files except for mascot.license can be accessed remotely in the same way as they are read from local files. The mandatory prefix "http://" has to be used to indicate the remote location. Configuration files are accessed though the get_params.pl script on Mascot Server, which is in the mascot/cgi directory. Example URL:

   http://your-server/mascot/cgi

The configuration file class adds /get_params.pl?Show=xxxx to the end of the URL.

The Unimod file can only be accessed at an explicit location (usually http://www.unimod.org/xml/unimod.xml).

A proxy server may have to be defined before downloading files from the Intranet/Internet. This can be done in one of two possible ways:

C++
    // Setting the proxy server explicitly:
    ms_datfile::setProxyServer("proxy_server_name");
    ms_datfile::setProxyUsername("user_name");
    ms_datfile::setProxyPassword("user_password");
    // Now we can download safely.
    ms_fragrulesfile fragRules("http://host_name/mascot/cgi");

    // Retrieving proxy settings from mascot.dat:
    ms_datfile datFile("../config/mascot.dat");
    // Now we can download safely.
    ms_umod_configfile unimodFile("http://www.unimod.org/xml/unimod.xml");

Perl
    # Setting the proxy server explicitly:
    msparser::ms_datfile::setProxyServer("proxy_server_name");
    msparser::ms_datfile::setProxyUsername("user_name");
    msparser::ms_datfile::setProxyPassword("user_password");
    # Now we can download safely.
    my $fragRules = msparser::ms_fragrulesfile->new("http://host_name/mascot/cgi");

    # Retrieving proxy settings from mascot.dat:
    my $datFile = msparser::ms_datfile->new("../config/mascot.dat");
    # Now we can download safely.
    my $unimodFile = msparser::ms_umod_configfile->new("http://www.unimod.org/xml/unimod.xml");

Java and C#
    // Setting the proxy server explicitly:
    ms_datfile.setProxyServer("proxy_server_name");
    ms_datfile.setProxyUsername("user_name");
    ms_datfile.setProxyPassword("user_password");
    // Now we can download safely.
    ms_fragrulesfile fragRules = new ms_fragrulesfile("http://host_name/mascot/cgi");

    // Retrieving proxy settings from mascot.dat:
    ms_datfile datFile = new ms_datfile("../config/mascot.dat");
    // Now we can download safely.
    ms_umod_configfile unimodFile = new ms_umod_configfile("http://www.unimod.org/xml/unimod.xml");

Python
    # Setting the proxy server explicitly:
    msparser.ms_datfile.setProxyServer("proxy_server_name")
    msparser.ms_datfile.setProxyUsername("user_name")
    msparser.ms_datfile.setProxyPassword("user_password")
    # Now we can download safely.
    fragRules = msparser.ms_fragrulesfile("http://host_name/mascot/cgi")

    # Retrieving proxy settings from mascot.dat:
    datFile = msparser.ms_datfile("../config/mascot.dat")
    # Now we can download safely.
    unimodFile = msparser.ms_umod_configfile("http://www.unimod.org/xml/unimod.xml")
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Examples for the configuration files module

Examples for the configuration files module
Mascot configuration files module

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
Reading the mascot.dat file | config_mascotdat.pl | config_mascotdat.cpp | config_mascotdat.java | config_mascotdat.py | config_mascotdat.cs
Reading the enzymes file | config_enzymes.pl | config_enzymes.cpp | config_enzymes.java | config_enzymes.py | config_enzymes.cs
Reading the fragmentation rules file | config_fragrules.pl | config_fragrules.cpp | config_fragrules.java | config_fragrules.py | config_fragrules.cs
Reading the mascot.license file | config_license.pl | config_license.cpp | config_license.java | config_license.py | -
Reading the masses file | config_masses.pl | config_masses.cpp | config_masses.java | config_masses.py | config_masses.cs
Reading the modifications from mod_file | config_modfile.pl | config_modfile.cpp | config_modfile.java | config_modfile.py | config_modfile.cs
Determining the computer CPU configuration | config_procs.pl | config_procs.cpp | config_procs.java | config_procs.py | config_procs.cs
Reading the taxonomy file | config_taxonomy.pl | config_taxonomy.cpp | config_taxonomy.java | config_taxonomy.py | config_taxonomy.cs
Reading the quantitation.xml file | config_quantitation.pl | config_quantitation.cpp | config_quantitation.java | config_quantitation.py | config_quantitation.cs
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Fixed values for quantitation.xml

Fixed values for quantitation.xml
Mascot configuration files module

Some attributes and element values in quantitation.xml are restrictions of the string-type and can accept one of the fixed values defined in a special enumeration-list.

Type mqm:calcType

How to calculate a ratio for a protein
List of values

Value | Description
median | Protein ratio is the median of the peptide ratios
average | Protein ratio is the unweighted average of the peptide ratios
weighted | For each component, the intensity values are summed over the set of peptides and the protein ratio is calculated from the summed values

Type mqm:correctionTypeType

Isotope correction factor
List of values

Value | Description
AB certificate | Percentage isotopic impurities for each reagent as tabulated on a Certificate of Analysis.
averagine | Mass dependent isotope overlap. Isotope purity specified using element attribute of correction
impurity | Isotope under-enrichment

Type mqm:integrationMethodType

Integration method
List of values

Value | Description
none | No integration
simpsons | Numerical integration using Simpsons rule
trapezium | Numerical integration using the trapezium rule

Type mqm:ionSeriesType

Symbols for sequence ion series
List of values

Value | Description
a | a series fragment ions
b | b series fragment ions
c | c series fragment ions
x | x series fragment ions
y | y series fragment ions
z | z series fragment ions
z+1 | -
z+2 | -

Type mqm:modeType

Specificity for a group of modifications
List of values

Value | Description
fixed | Quantitative modification
variable | Non-quantitative modification
exclusive | A given peptide may carry one or the other set of modifications, but never a mixture of both

Type mqm:normaliseType

normalisation method
List of values

Value | Description
none | No normalisation
sum | (Reporter protocol only) The total intensity of each reporter ion, summed across all MS/MS spectra, is made equal
average | For each ratio, the geometric mean of all reported values for peptide matches is made unity
median | For each ratio, the median of all reported values for peptide matches is made unity

Type mqm:outlierType

method of detecting outliers
List of values

Value | Description
none | No outlier removal
dixons | Detect and remove outliers using Dixon's method
auto | Detect and remove outliers using Dixon's method or Rosner's method according to the number of values
grubbs | Detect and remove outliers using Grubb's method
rosners | Detect and remove outliers using Rosner's method

Type mqm:positionType

Unimod position
List of values

Value | Description
Anywhere | Unrestricted
Any N-term | Modification only if residue or terminus is at peptide N-term
Any C-term | Modification only if residue or terminus is at peptide C-term
Protein N-term | Modification only if residue or terminus is at N-term of intact protein
Protein C-term | Modification only if residue or terminus is at C-term of intact protein

Type mqm:proteinScoreType

Mascot protein score method
List of values

Value | Description
standard | Use Mascot standard protein scoring
mudpit | Use Mascot mudpit protein scoring

Type mqm:scanType

Data source for integration
List of values

Value | Description
survey | Precursor peak area from survey scan
zoom | Precursor peak area from zoom scan
header | XIC value taken from file header
fragments | Sum of fragment peak areas from MS/MS scan
mrm | Multiple reaction monitoring

Type mqm:siteType

Unimod site
List of values

Value | Description
A | Alanine
C | Cysteine
D | Aspartic acid
E | Glutamic acid
F | Phenylalanine
G | Glycine
H | Histidine
I | Isoleucine
J | Unassigned
K | Lysine
L | Leucine
M | Methionine
N | Asparagine
O | Unassigned
P | Proline
Q | Glutamine
R | Arginine
S | Serine
T | Threonine
U | Selenocysteine
V | Valine
W | Tryptophan
Y | Tyrosine
N-term | Amino terminus
C-term | Carboxy terminus

Type mqm:thresholdType

Significance threshold for peptide matches
List of values

Value | Description
minimum score | Significance threshold for peptide matches is a minimum score
maximum expect | Significance threshold for peptide matches is a maximum expectation value
at least identity | Significance threshold for peptide matches is score at or above identity threshold
at least homology | Significance threshold for peptide matches is score at or above homology threshold

Type mqm:timeUnitType

time units
List of values

Value | Description
seconds | seconds
minutes | minutes
% | Fraction expressed as parts per 100
ppm | Fraction expressed as parts per million

Type mqm:averageSelectionType

List of allowed values for selection-attribute
List of values

Value | Description
unique_sequence | Peptides to be used for quantitation are required to be unique sequences
unique_mr | Accept different modification states of same sequence
unique_mz | Accept peptides with same sequence and modifications in different charge states

Type mqm:timeAlignmentAlgorithmType

List of allowed values for timeAlignmentAlgorithm attribute
List of values

Value | Description
Auto | The quantitation software should choose the most appropriate time alignment algorithm for the supplied raw data files
Unsupervised | Just use the MS1 data to attempt to align the raw data files
Supervised | Use the Mascot search results to align the raw data files

Type mqm:reporterTolUnitType

Units for reporter_tol
List of values

Value | Description
Da | Daltons
ppm | ppm
mmu | mmu
% | %
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Fixed values for crosslinking.xml

Fixed values for crosslinking.xml
Mascot configuration files module

Some attributes and element values in crosslinking.xml are restrictions of the string-type and can accept one of the fixed values defined in a special enumeration-list.

Type mxm:strategyNameType

Strategy used when identifying peptides or pairs of peptides with crosslinks
List of values

Value | Description
None | No crosslinking
Brute-force | Find intact crosslinks among all pairs of peptides
CID-ETD-MS2 | Attempt to match CID and ETD scans using pairs of candidate peptides
CID-MS2-MS3-hybrid | Attempt to match MS2 scans using pairs of candidate peptides and MS3 scans using individual candidate peptides
CID-MS3 | Attempt to match MS3 scans using individual candidate peptides
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_clusterparams Class Reference

  • matrix_science
  • ms_clusterparams
Public Types | Public Member Functions | List of all members
ms_clusterparams Class Reference
Mascot configuration files module

An instance of this class represents all the parameters specified in the Cluster section of mascot.dat. More...

#include <ms_clusterparams.hpp>

Inheritance diagram for ms_clusterparams:
[legend]
Collaboration diagram for ms_clusterparams:
[legend]

Public Types

enum { NUM_PROCESSORS_AUTO_DETECT = -1 }
Value used to indicate that the number of processors in the first SubClusterSet should be automatically determined at runtime. More...

Public Member Functions

ms_clusterparams ()
Default constructor.
ms_clusterparams (const ms_clusterparams &src)
Copying constructor.
~ms_clusterparams ()
Destructor.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendSubCluster (const int id, const int maxCPUs)
Add a new SubClusterSet entry.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearSubClusters ()
Erases information about all sub clusters.
void | copyFrom (const ms_clusterparams *right)
Can be used to create a copy of another object.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | defaultValues ()
Initialises the instance with default values.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
int | getCheckNodesAliveFreq () const
Returns the value of CheckNodesAliveFreq.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDefaultNodeHomeDir () const
Returns the value of DefaultNodeHomeDir.
std::string | getDefaultNodeHomeDirFromMaster () const
Returns the value of DefaultNodeHomeDirFromMaster.
OPERATING_SYS | getDefaultNodeOS () const
Returns value of DefaultNodeOS as one of the enumeration members.
int | getDefaultPort () const
Returns the value of DefaultPort.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
std::string | getIPCLogfile () const
Returns the value of IPCLogfile.
int | getIPCLogging () const
Returns value of IPCLogging.
int | getIPCTimeout () const
Returns the value of IPCTimeout.
std::string | getMascotNodeRebootScript () const
Returns the value of MascotNodeRebootScript.
std::string | getMascotNodeScript () const
Returns the value of MascotNodeScript.
const ms_computeraddress * | getMasterComputer () const
Returns an instance of ms_computeraddress created for MasterComputerName.
std::string | getNodeSequenceDatabaseDir () const
Returns the value of NodeSequenceDatabaseDir.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
int | getNumberOfSubClusters () const
Returns the number of SubClusterSet parameter entries, which is a total number of sub-clusters.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
int | getSecsToWaitForNodeAtStartup () const
Returns the value of SecsToWaitForNodeAtStartup.
int | getSubClusterID (const int index) const
Returns sub-cluster ID by its index.
int | getSubClusterMaxCPU (const int index) const
Returns the Y part of SubClusterSet.
bool | isEnabled () const
Returns TRUE if Enabled parameter is set to 1 and FALSE otherwise.
bool | isSectionAvailable () const
Check whether the section has been actually read from the file.
ms_clusterparams & | operator= (const ms_clusterparams &right)
Assignment operator for C++ client applications.
void | setCheckNodesAliveFreq (const int value)
Change CheckNodesAliveFreq.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setDefaultNodeHomeDir (const char *str)
Change DefaultNodeHomeDir.
void | setDefaultNodeHomeDirFromMaster (const char *str)
Change DefaultNodeHomeDirFromMaster.
void | setDefaultNodeOS (const OPERATING_SYS value)
Change DefaultNodeOS.
void | setDefaultPort (const int value)
Change DefaultPort.
void | setEnabled (const bool flag)
Change Enabled.
void | setIPCLogfile (const char *str)
Change IPCLogfile.
void | setIPCLogging (const int value)
Change IPCLogging.
void | setIPCTimeout (const int value)
Change IPCTimeout.
void | setMascotNodeRebootScript (const char *str)
Change MascotNodeRebootScript.
void | setMascotNodeScript (const char *str)
Change MascotNodeScript.
void | setMasterComputer (const ms_computeraddress *value)
Change MasterComputerName.
void | setNodeSequenceDatabaseDir (const char *str)
Change NodeSequenceDatabaseDir.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setSecsToWaitForNodeAtStartup (const int value)
Change SecsToWaitForNodeAtStartup.
void | setSectionAvailable (const bool value)
Change availability of the section, i.e. if it should be saved in a file.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

An instance of this class represents all the parameters specified in the Cluster section of mascot.dat.

An instance of this class is created and polulated in ms_datfile. It can also be created separately and initialized with default values. One can create an instance of the class or copy from another instance in order to pass it then as an parameters-containing object. For detailed information on any of the options please consult Mascot manual.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples
config_mascotdat.cpp.

Member Enumeration Documentation

◆ anonymous enum

anonymous enum

Value used to indicate that the number of processors in the first SubClusterSet should be automatically determined at runtime.

The value assigned will be identical to the number of 'processors' licensed.

See also
getSubClusterMaxCPU().

(Defined as an enum rather than static const int to support VC6)

Enumerator
NUM_PROCESSORS_AUTO_DETECT

Value used to indicate that the number of processors in the first SubClusterSet should be automatically determined at runtime.

Member Function Documentation

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendSubCluster()

void appendSubCluster | ( | const int | id,
 |  | const int | maxCPUs
 | ) |  |

Add a new SubClusterSet entry.

See getNumberOfSubClusters() for more information.

Parameters
id | unique ID identifying a sub-cluster (from 0 to 49) to set number of CPUs for.
maxCPUs | maximum number of CPUs for the specified sub-cluster (from 0 to 1024*64).

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ clearSubClusters()

void clearSubClusters ( )

Erases information about all sub clusters.

One entry (0,0) for "this subcluster" stays in the list forever.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getCheckNodesAliveFreq()

int getCheckNodesAliveFreq ( ) const

Returns the value of CheckNodesAliveFreq.

The CheckNodesAliveFreq parameter specifies the interval in seconds between 'health checks' on the nodes. Default value is 30 sec.

Returns
Frequency to check if nodes are alive

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDefaultNodeHomeDir()

std::string getDefaultNodeHomeDir ( ) const

Returns the value of DefaultNodeHomeDir.

If no specific home directory is specified for a particular node in nodelist.txt, then the value of the DefaultNodeHomeDir parameter is used. To override this setting for a particular node, enter the directory on the node line in nodelist.txt.

Default is the /MascotNode folder.

See also
getDefaultPort()
Returns
Default node home directory

◆ getDefaultNodeHomeDirFromMaster()

std::string getDefaultNodeHomeDirFromMaster ( ) const

Returns the value of DefaultNodeHomeDirFromMaster.

This is the directory on the node as seen from the master. For a Windows cluster, this must be present and specified as a UNC name. For a Unix cluster, this parameter must be commented out.

Default is

\\<host_name>\c$\mascotnode
Returns
Default node home directory from master

◆ getDefaultNodeOS()

OPERATING_SYS getDefaultNodeOS ( ) const

Returns value of DefaultNodeOS as one of the enumeration members.

If no OS is defined for a particular node, then this parameter value is assumed as the OS. See OPERATING_SYS for a list of possible values.

Default is _OS_WINDOWS_NT (2).

Returns
Default node OS

◆ getDefaultPort()

int getDefaultPort ( ) const

Returns the value of DefaultPort.

If no port number is specified for a node in nodelist.txt, then this port number will be used.

Default is 5001.

See also
getDefaultNodeHomeDir()
Returns
Default port

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getIPCLogfile()

std::string getIPCLogfile ( ) const

Returns the value of IPCLogfile.

The IPCLogfile parameter specifies a relative path to the inter-process communication log file.

Default is ../logs/IPC.log.

See also
getIPCTimeout()
Returns
IPC log file name

◆ getIPCLogging()

int getIPCLogging ( ) const

Returns value of IPCLogging.

IPCLogging specifies logging level for inter-process communications. It has the followings possible values:

  • 0 for no logging of inter-process communication
  • 1 for for minimal logging
  • 2 for for verbose logging

Default is 0.

See also
getIPCTimeout()
Returns
IPC logging level

◆ getIPCTimeout()

int getIPCTimeout ( ) const

Returns the value of IPCTimeout.

The IPCTimeout parameter is the timeout in seconds for inter-process communication.

Default is 10 seconds.

See also
getIPCLogging(), getIPCLogfile()
Returns
IPC timeout value

◆ getMascotNodeRebootScript()

std::string getMascotNodeRebootScript ( ) const

Returns the value of MascotNodeRebootScript.

MascotNodeRebootScript is the name of an optional script to re-boot a cluster node. If this parameter is defined, then there will be a link at the bottom of each Mascot Cluster Node status page. When this link is clicked, ms-monitor will run the defined script on the master. The host name of the specified node will be passed to the script as a parameter.

By default this is empty.

Returns
Mascot node reboot script

◆ getMascotNodeScript()

std::string getMascotNodeScript ( ) const

Returns the value of MascotNodeScript.

The MascotNodeScript parameter specifies a script name which is run for each node with different parameters described in Mascot manual.

By default this is empty.

Returns
Mascot node script

◆ getMasterComputer()

const ms_computeraddress * getMasterComputer ( ) const

Returns an instance of ms_computeraddress created for MasterComputerName.

The MasterComputerName parameter contains a host name for the master computer and, optionally, the IP address separated by a comma. See ms_computeraddress for information about its parameters and default values.

Returns
Pointer to the master computer object

◆ getNodeSequenceDatabaseDir()

std::string getNodeSequenceDatabaseDir ( ) const

Returns the value of NodeSequenceDatabaseDir.

Specify the sequence database directory to be used by to all cluster nodes. This can be a relative path to the node bin directory or an absolute path. Default is the ../sequence sub folder.

Returns
Node sequence database directory

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getNumberOfSubClusters()

int getNumberOfSubClusters ( ) const

Returns the number of SubClusterSet parameter entries, which is a total number of sub-clusters.

Large clusters can be divided into sub-clusters. There might be several SubClusterSet parameter entries on separate lines in the configuration file. Each parameter line has the following format:

SubClusterSet X Y

X is a unique integer value (0-based) used to identify the sub-cluster (from 0 to 49 inclusively).

Y is the maximum number of processors in the sub-cluster.

A single cluster must have a single entry with X set to 0. If no such entries are present in the file, one subcluster is assumed - default entry (0,0). Therefore, default value returned by this function is 1.

Use getSubClusterID() and getSubClusterMaxCPU() to retrieve the entries.

Returns
Number of sub clusters

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ getSecsToWaitForNodeAtStartup()

int getSecsToWaitForNodeAtStartup ( ) const

Returns the value of SecsToWaitForNodeAtStartup.

The SecsToWaitForNodeAtStartup parameter specifies a timeout. At startup, if a node is not available within this time, the system will continue to startup without that node. If the value is set to 0, then the system will wait indefinitely.

This timeout is also used if a node fails while the system is running. The system will wait for this number of seconds before re-initialising ms-monitor.exe. This means that a short-lived interruption in network communication doesn't create a major service interruption.

Default is 60 sec.

Returns
Seconds to wait for node at startup

◆ getSubClusterID()

int getSubClusterID ( const int index ) const

Returns sub-cluster ID by its index.

Parameters
index a number between 0 and (getNumberOfSubClusters()-1).
Returns
integer number which serves as a sub-cluster ID.

◆ getSubClusterMaxCPU()

int getSubClusterMaxCPU ( const int index ) const

Returns the Y part of SubClusterSet.

See getNumberOfSubClusters() for more detailed explanations.

Parameters
index a number in the list (from 0 to (getNumberOfSubClusters()-1)).
Returns
maximum number of CPUs for the specified sub-cluster (0 by default).

◆ isSectionAvailable()

bool isSectionAvailable ( ) const

Check whether the section has been actually read from the file.

By default the Options section is unavailable until it has been set to a different state.

Returns
true is the section is available
Examples
config_mascotdat.cpp.

◆ setCheckNodesAliveFreq()

void setCheckNodesAliveFreq ( const int value )

Change CheckNodesAliveFreq.

See getCheckNodesAliveFreq() for more information.

Parameters
value Frequency to check if nodes are alive

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setDefaultNodeHomeDir()

void setDefaultNodeHomeDir ( const char * str )

Change DefaultNodeHomeDir.

See getDefaultNodeHomeDir() for more information.

Parameters
str default node home directory

◆ setDefaultNodeHomeDirFromMaster()

void setDefaultNodeHomeDirFromMaster ( const char * str )

Change DefaultNodeHomeDirFromMaster.

See getDefaultNodeHomeDirFromMaster() for more information.

Parameters
str default mode home directory from master

◆ setDefaultNodeOS()

void setDefaultNodeOS ( const OPERATING_SYS value )

Change DefaultNodeOS.

See getDefaultNodeOS() for more information.

Parameters
value default node OS

◆ setDefaultPort()

void setDefaultPort ( const int value )

Change DefaultPort.

See getDefaultPort() for more information.

Parameters
value Default port

◆ setEnabled()

void setEnabled ( const bool flag )

Change Enabled.

See isEnabled() for more information.

Parameters
flag Enabled

◆ setIPCLogfile()

void setIPCLogfile ( const char * str )

Change IPCLogfile.

See getIPCLogfile() for more information.

Parameters
str IPC log file

◆ setIPCLogging()

void setIPCLogging ( const int value )

Change IPCLogging.

See getIPCLogging() for more information.

Parameters
value IPC logging level

◆ setIPCTimeout()

void setIPCTimeout ( const int value )

Change IPCTimeout.

See getIPCTimeout() for more information.

Parameters
value IPC timeout

◆ setMascotNodeRebootScript()

void setMascotNodeRebootScript ( const char * str )

Change MascotNodeRebootScript.

See getMascotNodeRebootScript() for more information.

Parameters
str mascot mode reboot script

◆ setMascotNodeScript()

void setMascotNodeScript ( const char * str )

Change MascotNodeScript.

See getMascotNodeScript() for more information.

Parameters
str Mascot node script

◆ setMasterComputer()

void setMasterComputer ( const ms_computeraddress * value )

Change MasterComputerName.

See getMasterComputer() for more information.

Parameters
value Pointer to a valid ms_computeraddress object

◆ setNodeSequenceDatabaseDir()

void setNodeSequenceDatabaseDir ( const char * str )

Change NodeSequenceDatabaseDir.

See getNodeSequenceDatabaseDir() for more information.

Parameters
str node sequence database directory

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ setSecsToWaitForNodeAtStartup()

void setSecsToWaitForNodeAtStartup ( const int value )

Change SecsToWaitForNodeAtStartup.

See getSecsToWaitForNodeAtStartup() for more information.

Parameters
value seconds to wait for node at startup

◆ setSectionAvailable()

void setSectionAvailable ( const bool value )

Change availability of the section, i.e. if it should be saved in a file.

Value of 1 is to enable cluster mode, whereas 0 is to enable single server mode.

Default is 0.

Parameters
value Boolean whether the section is available

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_clusterparams.hpp
  • ms_clusterparams.cpp
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_computeraddress Class Reference

  • matrix_science
  • ms_computeraddress
Public Member Functions | List of all members
ms_computeraddress Class Reference
Mascot configuration files module

The class serves as a container for computer address parameters for cluster mode. More...

#include <ms_computeraddress.hpp>

Public Member Functions

ms_computeraddress ()
Default constructor.
ms_computeraddress (const ms_computeraddress &src)
Copying constructor.
~ms_computeraddress ()
Destructor.
void | copyFrom (const ms_computeraddress *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
std::string | getHostName () const
Returns the host name.
std::string | getInetAddress () const
Returns IP address of the host.
unsigned int | getPort () const
Returns the port number for the host.
ms_computeraddress & | operator= (const ms_computeraddress &right)
Assignment operator for C++ client applications.
void | setHostName (const char *name)
Change the host name.
void | setInetAddress (const char *address)
Change the IP address of the host.
void | setPort (const unsigned int value)
Change the port number for the host.

Detailed Description

The class serves as a container for computer address parameters for cluster mode.

Member Function Documentation

◆ getHostName()

std::string getHostName ( ) const

Returns the host name.

Default is localhost.

Returns
Host name

◆ getInetAddress()

std::string getInetAddress ( ) const

Returns IP address of the host.

Default is "127.0.0.1".

Returns
IP address

◆ getPort()

unsigned int getPort ( ) const

Returns the port number for the host.

Default is 0.

Returns
Port number

◆ setHostName()

void setHostName ( const char * name )

Change the host name.

Parameters
name New host name to set

◆ setInetAddress()

void setInetAddress ( const char * address )

Change the IP address of the host.

Parameters
address New address to set

◆ setPort()

void setPort ( const unsigned int value )

Change the port number for the host.

Parameters
value New port number to set
The documentation for this class was generated from the following files:
  • ms_computeraddress.hpp
  • ms_computeraddress.cpp
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_cronjob Class Reference

  • matrix_science
  • ms_cronjob
Public Member Functions | List of all members
ms_cronjob Class Reference
Mascot configuration files module

Represents a single entry from the cron section of mascot.dat. More...

#include <ms_cronoptions.hpp>

Public Member Functions

ms_cronjob ()
Default constructor.
ms_cronjob (const ms_cronjob &src)
Copying constructor.
~ms_cronjob ()
Default destructor.
void | copyFrom (const ms_cronjob *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
std::string | getCommandStr () const
Returns a string that is executed by the shell (command prompt) at the specified times.
bool | isDayOfMonth (const int day) const
Returns TRUE for a valid day number, FALSE otherwise.
bool | isDayOfWeek (const int day) const
Returns TRUE for a valid day of week number, FALSE otherwise.
bool | isEnabled () const
Returns true if the cron job is enabled.
bool | isHour (const int hour) const
Returns TRUE for a valid hour number, FALSE otherwise.
bool | isMinute (const int min) const
Returns TRUE for a valid minute number, FALSE otherwise.
bool | isMonthOfYear (const int month) const
Returns TRUE for a valid month number, FALSE otherwise.
ms_cronjob & | operator= (const ms_cronjob &right)
Assignment operator for C++ client applications.
void | setCommandStr (const char *str)
Set the command that is executed by the shell (command prompt) at the specified times.
void | setDayOfMonth (const int day, const bool value)
Set valid/illegal days.
void | setDayOfWeek (const int day, const bool value)
Set valid/illegal days.
void | setEnabled (const bool enabled)
Set the flag for determining if the cron job is enabled or disabled.
void | setHour (const int hour, const bool value)
Set valid/illegal hours.
void | setMinute (const int min, const bool value)
Set valid/illegal minutes.
void | setMonthOfYear (const int month, const bool value)
Set valid/illegal months.

Detailed Description

Represents a single entry from the cron section of mascot.dat.

Instances of this class can be stored in ms_cronoptions.

Member Function Documentation

◆ getCommandStr()

std::string getCommandStr ( ) const

Returns a string that is executed by the shell (command prompt) at the specified times.

By default this is empty.

Returns
the command to be run.
Examples
config_mascotdat.cpp.

◆ isDayOfMonth()

bool isDayOfMonth ( const int day ) const

Returns TRUE for a valid day number, FALSE otherwise.

A cron job entry in the configuration file specifies time to run a command. Use this function to retrieve the 'day' part of this specification.

Parameters
day a day number (1..31).
Returns
By default FALSE is returned for all days.

◆ isDayOfWeek()

bool isDayOfWeek ( const int day ) const

Returns TRUE for a valid day of week number, FALSE otherwise.

A cron job entry in the configuration file specifies time to run a command. Use this function to retrieve the 'day of week' part of this specification.

Parameters
day a day of week number (0..6, 0=Sunday).
Returns
By default FALSE is returned for all days.

◆ isEnabled()

bool isEnabled ( ) const

Returns true if the cron job is enabled.

A cron job entry in the configuration file specifies time to run a command. The entry can be disabled by putting a comments symbol # at the start of the line

Returns
true if the cron job is enabled.

◆ isHour()

bool isHour ( const int hour ) const

Returns TRUE for a valid hour number, FALSE otherwise.

A cron job entry in the configuration file specifies time to run a command. Use this function to retrieve the 'hour' part of this specification.

Parameters
hour an hour number (0..23).
Returns
By default FALSE is returned for all hours.

◆ isMinute()

bool isMinute ( const int min ) const

Returns TRUE for a valid minute number, FALSE otherwise.

A cron job entry in the configuration file specifies time to run a command. Use this function to retrieve the 'minute' part of this specification.

Parameters
min a minute number (0..59).
Returns
By default FALSE is returned for all minutes.

◆ isMonthOfYear()

bool isMonthOfYear ( const int month ) const

Returns TRUE for a valid month number, FALSE otherwise.

A cron job entry in the configuration file specifies time to run a command. Use this function to retrieve the 'month' part of this specification.

Parameters
month a month number (1..12).
Returns
By default FALSE is returned for all months.

◆ setCommandStr()

void setCommandStr ( const char * str )

Set the command that is executed by the shell (command prompt) at the specified times.

Parameters
str is the new command to be run.

◆ setDayOfMonth()

void setDayOfMonth | ( | const int | day,
 |  | const bool | value
 | ) |  |

Set valid/illegal days.

See also
isDayOfMonth()
Parameters
day | an hour number (1..31).
value | a new boolean flag for the given day.

◆ setDayOfWeek()

void setDayOfWeek | ( | const int | day,
 |  | const bool | value
 | ) |  |

Set valid/illegal days.

See also
isDayOfWeek()
Parameters
day | a day of week number (0..6, 0=Sunday).
value | a new boolean flag for the given day.

◆ setEnabled()

void setEnabled ( const bool enabled )

Set the flag for determining if the cron job is enabled or disabled.

A cron job entry in the configuration file specifies time to run a command. The entry can be disabled by putting a comments symbol # at the start of the line

Parameters
enabled true if the cron job is enabled.

◆ setHour()

void setHour | ( | const int | hour,
 |  | const bool | value
 | ) |  |

Set valid/illegal hours.

See also
isHour()
Parameters
hour | an hour number (0..23).
value | a new boolean flag for the given hour.

◆ setMinute()

void setMinute | ( | const int | min,
 |  | const bool | value
 | ) |  |

Set valid/illegal minutes.

See also
isMinute()
Parameters
min | a minute number (0..59)
value | a new boolean flag for the given minute

◆ setMonthOfYear()

void setMonthOfYear | ( | const int | month,
 |  | const bool | value
 | ) |  |

Set valid/illegal months.

See also
isMonthOfYear()
Parameters
month | a month number (1..12).
value | a new boolean flag for the given month.
The documentation for this class was generated from the following files:
  • ms_cronoptions.hpp
  • ms_cronoptions.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_cronoptions Class Reference

  • matrix_science
  • ms_cronoptions
Public Member Functions | List of all members
ms_cronoptions Class Reference
Mascot configuration files module

Contains parameters from the cron section of mascot.dat. More...

#include <ms_cronoptions.hpp>

Inheritance diagram for ms_cronoptions:
[legend]
Collaboration diagram for ms_cronoptions:
[legend]

Public Member Functions

ms_cronoptions ()
Default constructor.
ms_cronoptions (const ms_cronoptions &src)
Copying constructor.
~ms_cronoptions ()
Destructor.
void | appendCronJob (const ms_cronjob *job)
Add a new job entry at the end of the list.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearCronJobs ()
Delete all cron-job entries.
void | copyFrom (const ms_cronoptions *right)
Can be used to create a copy of another object.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | defaultValues ()
Initialises the instance with default values.
bool | deleteCronJob (const int idx)
Delete a single cron job.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
const ms_cronjob | getCronJob (const int idx) const
Returns an object describing a single cron job by its number.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
std::string | getLogFileName () const
Returns the path to the log file.
int | getLoggingLevel () const
Returns the current logging level.
int | getNumberOfCronJobs () const
Returns the total number of cron-jobs configured.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
bool | isCronEnabled () const
Returns true if parameter CronEnabled is set to 1 and false otherwise.
bool | isSectionAvailable () const
Returns TRUE if the section was actually read from a file.
ms_cronoptions & | operator= (const ms_cronoptions &right)
Assignment operator for C++ client applications.
void | setCronEnabled (const bool value)
Change CronEnabled.
bool | setCronJob (const int idx, const ms_cronjob job)
Replace the current definition of a cron job.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
bool | setLogFileName (const std::string &fileName)
Sets the path to the log file.
bool | setLoggingLevel (const int level)
Sets a new logging level.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setSectionAvailable (const bool value)
Changes availability of the section, meaning whether it should be stored in a file.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

Contains parameters from the cron section of mascot.dat.

On Unix systems, cron can be used to automate routine procedures such as the overnight updating of sequence database files. Windows 2000 and later include an equivalent utility called Scheduled Tasks. The Mascot ms-monitor.exe service/daemon runs the cron jobs listed in mascot.dat

In Mascot 2.4 and later, the Database Manager uses the cron job to download and update fasta database files.

For detailed information on any of the cron parameters please consult the Mascot manual.

See ms_datfile::getCronOptions() and ms_datfile::setCronOptions()

The base class ms_customproperty can be used to facilitate the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples
config_mascotdat.cpp.

Constructor & Destructor Documentation

◆ ms_cronoptions() [1/2]

ms_cronoptions ( )

Default constructor.

The ms_cronoptions object will normally be created using ms_datfile::getCronOptions().

◆ ms_cronoptions() [2/2]

ms_cronoptions ( const ms_cronoptions & src )

Copying constructor.

Parameters
src is a reference to the object to copy from.

◆ ~ms_cronoptions()

~ms_cronoptions ( )

Destructor.

Frees all memory. Pointers returned by getCronJob() are no longer valid.

Member Function Documentation

◆ appendCronJob()

void appendCronJob ( const ms_cronjob * job )

Add a new job entry at the end of the list.

Parameters
job is a pointer to the new job

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ clearCronJobs()

void clearCronJobs ( )

Delete all cron-job entries.

This does not change the log file settings or the 'enabled' value.

◆ defaultValues()

void defaultValues ( )

Initialises the instance with default values.

Clears the list of cron jobs, sets the 'enabled' flag to false.

◆ deleteCronJob()

bool deleteCronJob ( const int idx )

Delete a single cron job.

Parameters
idx a number from 0 to (getNumberOfCronJobs()-1).
Returns
true if idx is a valid index.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getCronJob()

const ms_cronjob getCronJob ( const int idx ) const

Returns an object describing a single cron job by its number.

All cron jobs are assigned consecutive ID numbers (0 based).

To make changes to the returned ms_cronjob permanent, call setCronJob() followed by ms_datfile::setCronOptions

Note
In versions of Mascot Parser prior to 2.4.1, this function returned a const pointer to the ms_conjob object rather than a copy of the object.
Parameters
idx a number from 0 to (getNumberOfCronJobs()-1)
Returns
instance of ms_cronjob class describing the corresponding entry.
Examples
config_mascotdat.cpp.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getLogFileName()

std::string getLogFileName ( ) const

Returns the path to the log file.

The filename can be a relative or absolute path.

Parameter | Logfile
Permitted values | A non empty string
Default (if no parameter in mascot.dat) | "../logs/cron.log"
Value in mascot.dat | "../logs/cron.log"
Returns
the logging file name.

◆ getLoggingLevel()

int getLoggingLevel ( ) const

Returns the current logging level.

The value specifies the level of logging. Messages are put into the file specified by getLogFileName()

Parameter | Logging
Permitted values 0..3 where:
  • 0 - No logging
  • 1 - Log successful commands (return code 0)
  • 2 - Log unsuccessful commands (return code not 0)
  • 3 - Log successful and unsuccessful commands
Default
(if no parameter in mascot.dat) 		3
Value in mascot.dat | 3
Returns
the logging level

◆ getNumberOfCronJobs()

int getNumberOfCronJobs ( ) const

Returns the total number of cron-jobs configured.

Every line (except the first one) in the cron section represents a cron-job. This function returns a number of such lines (except commented out).

Returns
the number of cron jobs.
Examples
config_mascotdat.cpp.

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ isCronEnabled()

bool isCronEnabled ( ) const

Returns true if parameter CronEnabled is set to 1 and false otherwise.

The first parameter in the cron section of mascot.dat is always CronEnabled parameter. The rest is a list of cron-jobs. See getNumberOfCronJobs() for more information about them.

CronEnable should be set to 1 to enable cron functionality, 0 to disable. By default it is disabled.

Returns
true if the cron functionality is enabled
Examples
config_mascotdat.cpp.

◆ setCronEnabled()

void setCronEnabled ( const bool value )

Change CronEnabled.

See isCronEnabled() for more information.

Parameters
value should be true or false

◆ setCronJob()

bool setCronJob | ( | const int | idx,
 |  | const ms_cronjob | job
 | ) |  |

Replace the current definition of a cron job.

Parameters
idx | a number from 0 to (getNumberOfCronJobs()-1).
job | is the new definition for the job.
Returns
true if job is not a null pointer and idx is a valid index.

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setLogFileName()

bool setLogFileName ( const std::string & fileName )

Sets the path to the log file.

The filename can be a relative or absolute path.

Parameter | Logfile
Permitted values | A non empty string
Default (if no parameter in mascot.dat) | "../logs/cron.log"
Value in mascot.dat | "../logs/cron.log"
Parameters
fileName is the logging file name.
Returns
true if fileName is not an empty string.

◆ setLoggingLevel()

bool setLoggingLevel ( const int level )

Sets a new logging level.

The value specifies the level of logging. Messages are put into the file specified by getLogFileName()

Parameter | Logging
Permitted values 0..3 where:
  • 0 - No logging
  • 1 - Log successful commands (return code 0)
  • 2 - Log unsuccessful commands (return code not 0)
  • 3 - Log successful and unsuccessful commands
Default
(if no parameter in mascot.dat) 		3
Value in mascot.dat | 3
Parameters
level is the new logging level, a value 0..3.
Returns
true if a valid logging level is supplied.

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_cronoptions.hpp
  • ms_cronoptions.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_accession Class Reference

  • matrix_science
  • ms_crosslinking_accession
Public Member Functions | List of all members
ms_crosslinking_accession Class Reference
Mascot configuration files module

Accession element in crosslinking.xml More...

#include <ms_crosslinking_accession.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_crosslinking_accession ()
Default constructor.
ms_crosslinking_accession (const ms_crosslinking_accession &src)
Copying constructor.
virtual | ~ms_crosslinking_accession ()
Destructor.
void | copyFrom (const ms_crosslinking_accession *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropDatabaseName ()
Delete the DatabaseName attribute.
void | dropValue ()
Delete the custom text.
std::string | getDatabaseName () const
Returns the value of the DatabaseName attribute.
std::string | getDatabaseNameSchemaType () const
Obtain a symbolic name for the DatabaseName attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getValue () const
Returns the text of the node.
std::string | getValueSchemaType () const
Obtain a symbolic name for the text node schema type.
bool | haveDatabaseName () const
Indicates presence of the DatabaseName attribute.
bool | haveValue () const
Returns the text of the node.
ms_crosslinking_accession & | operator= (const ms_crosslinking_accession &right)
C++ style assignment operator.
void | setDatabaseName (const char *value)
Set a custom value for the DatabaseName attribute.
void | setValue (const char *value)
Set a custom text.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Accession element in crosslinking.xml

Accessions may come from different databases. If an accession has no DatabaseName attribute, the accession is looked up in all databases selected for the search.

Constructor & Destructor Documentation

◆ ms_crosslinking_accession() [1/2]

ms_crosslinking_accession ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_accession() [2/2]

ms_crosslinking_accession ( const ms_crosslinking_accession & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_crosslinking_accession * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropDatabaseName()

void dropDatabaseName ( )

Delete the DatabaseName attribute.

Deletes the attribute until is re-set.

◆ getDatabaseName()

std::string getDatabaseName ( ) const

Returns the value of the DatabaseName attribute.

Returns
current value of the attribute.

◆ getDatabaseNameSchemaType()

std::string getDatabaseNameSchemaType ( ) const

Obtain a symbolic name for the DatabaseName attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mxm:nameType").

◆ getValue()

std::string getValue ( ) const

Returns the text of the node.

Returns
current value text.

◆ getValueSchemaType()

std::string getValueSchemaType ( ) const

Obtain a symbolic name for the text node schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveDatabaseName()

bool haveDatabaseName ( ) const

Indicates presence of the DatabaseName attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_crosslinking_accession & operator= ( const ms_crosslinking_accession & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setDatabaseName()

void setDatabaseName ( const char * value )

Set a custom value for the DatabaseName attribute.

Parameters
value a new value for the attribute.

◆ setValue()

void setValue ( const char * value )

Set a custom text.

Parameters
value a new value text.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_accession.hpp
  • ms_crosslinking_accession.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_accessions Class Reference

  • matrix_science
  • ms_crosslinking_accessions
Public Member Functions | List of all members
ms_crosslinking_accessions Class Reference
Mascot configuration files module

Accessions element in crosslinking.xml More...

#include <ms_crosslinking_accessions.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_crosslinking_accessions ()
Default constructor.
ms_crosslinking_accessions (const ms_crosslinking_accessions &src)
Copying constructor.
virtual | ~ms_crosslinking_accessions ()
Destructor.
void | appendAccession (const ms_crosslinking_accession *item)
Adds a new accession code at the end of the list.
void | clearAccessions ()
Deletes all accession codes from the list.
void | copyFrom (const ms_crosslinking_accessions *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteAccessionByNumber (const int idx)
Remove a accession code from the list in memory by its index.
const ms_crosslinking_accession * | getAccessionByNumber (const int idx) const
Returns a accession code object by its number.
std::string | getAccessionSchemaType () const
Obtain a symbolic name for the accession element schema type.
int | getNumberOfAccessions () const
Returns the number of accession.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_accessions & | operator= (const ms_crosslinking_accessions &right)
C++ style assignment operator.
bool | updateAccessionByNumber (const int idx, const ms_crosslinking_accession *accession)
Update the information for a specific accession code refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Accessions element in crosslinking.xml

The list of accessions limits the search space of crosslinked peptides to just the named ones. If no accessions are defined, search space is unrestricted.

Constructor & Destructor Documentation

◆ ms_crosslinking_accessions() [1/2]

ms_crosslinking_accessions ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_accessions() [2/2]

ms_crosslinking_accessions ( const ms_crosslinking_accessions & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendAccession()

void appendAccession ( const ms_crosslinking_accession * item )

Adds a new accession code at the end of the list.

Creates a new accession code object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters
item an instance of a accession object to copy content from.

◆ copyFrom()

void copyFrom ( const ms_crosslinking_accessions * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteAccessionByNumber()

bool deleteAccessionByNumber ( const int idx )

Remove a accession code from the list in memory by its index.

Parameters
idx number of the accession code for deletion from 0 to (getNumberOfAccessions() - 1).
Returns
TRUE if the accession code has been found and successfully deleted and FALSE otherwise.

◆ getAccessionByNumber()

const ms_crosslinking_accession * getAccessionByNumber ( const int idx ) const

Returns a accession code object by its number.

Parameters
idx number of the accession code from 0 to (getNumberOfAccessions() - 1).
Returns
a read-only pointer to a accession object. See Maintaining object references: two rules of thumb.

◆ getAccessionSchemaType()

std::string getAccessionSchemaType ( ) const

Obtain a symbolic name for the accession element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfAccessions()

int getNumberOfAccessions ( ) const

Returns the number of accession.

Returns
total number of monolink codes.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ operator=()

ms_crosslinking_accessions & operator= ( const ms_crosslinking_accessions & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ updateAccessionByNumber()

bool updateAccessionByNumber | ( | const int | idx,
 |  | const ms_crosslinking_accession * | accession
 | ) |  |

Update the information for a specific accession code refering to it by its index.

Parameters
idx | number of the accession code for updating from 0 to (getNumberOfAccessions() - 1).
accession | an object to copy the content from.
Returns
TRUE if the accession code has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_accessions.hpp
  • ms_crosslinking_accessions.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_configfile Class Reference

  • matrix_science
  • ms_crosslinking_configfile
Public Member Functions | Static Public Member Functions | List of all members
ms_crosslinking_configfile Class Reference
Mascot configuration files module

This class represents the file crosslinking.xml. More...

#include <ms_crosslinking_configfile.hpp>

Inheritance diagram for ms_crosslinking_configfile:
[legend]
Collaboration diagram for ms_crosslinking_configfile:
[legend]

Public Member Functions

ms_crosslinking_configfile ()
Default constructor.
ms_crosslinking_configfile (const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0, bool useSchema=true)
Immediate action constructor that reads the XML file with the given name.
ms_crosslinking_configfile (const ms_crosslinking_configfile &right)
Copying constructor.
virtual | ~ms_crosslinking_configfile ()
Desctructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | appendMethod (const ms_crosslinking_method *elem)
Adds a new method at the end of the list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearMethods ()
Deletes all methods from the list.
void | copyFrom (const ms_crosslinking_configfile *right)
Copies all the information from another instance.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual void | defaultValues ()
Re-initialises the instance.
bool | deleteMethodByName (const char *name)
Remove an method from the list in memory.
bool | deleteMethodByNumber (const int idx)
Remove an method from the list in memory.
ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns the current file name.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getMajorVersion () const
Returns major document schema version as read from the file, otherwise the latest.
const ms_crosslinking_method * | getMethodByName (const char *name) const
Returns an method object by its name or NULL in case of not found.
const ms_crosslinking_method * | getMethodByNumber (const int idx) const
Returns an method object by its number.
std::string | getMinorVersion () const
Returns minor document schema version as read from the file, otherwise the latest.
int | getNumberOfMethods () const
Returns a number of methods currently held in memory.
std::string | getSchemaFileName () const
Returns the current schema file name that is used to validate the XML file.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_crosslinking_configfile & | operator= (const ms_crosslinking_configfile &right)
Assignment operator for C++ applications.
void | read_buffer (const char *buffer)
Reads configuration information from a string buffer.
void | read_file ()
Reads configuration information from the XML file.
std::string | save_buffer (bool validateAgainstSchema=true)
Creates a string representation of the XML document with all the content of the object.
void | save_file ()
Saves configuration information in the XML file (not mod_file).
void | setConnectionSettings (const ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *filename)
Changes the file name for subsequent read/write operations.
void | setSchemaFileName (const char *name)
Call this member to specify a custom schema file name for validating the XML file.
bool | updateMethodByName (const char *name, const ms_crosslinking_method *method)
Update the information for a specific method.
bool | updateMethodByNumber (const int idx, const ms_crosslinking_method *method)
Update the information for a specific method.
std::string | validateDocument () const
Validates the whole document against schema and returns errors as a string.

Static Public Member Functions

static std::string getDefaultSchemaFileName ()
Returns the default schema filename (no path)

Detailed Description

This class represents the file crosslinking.xml.

The crosslinking configuration file contains definitions for crosslinking methods. The method comprises settings such as intact vs cleavable linker, which protein accessions to intralink or interlink and various method-specific filters and settings. The file can be created from scratch, read from a disk file or retrieved from a remote location (HTTP).

After reading a file and before using the object check validity by calling isValid() and retrieve error descriptions with getLastErrorString() if not valid. Similarly, after writing out the file, isValid() can be used to check if the file has been created correctly and is valid for further use.

Constructor & Destructor Documentation

◆ ms_crosslinking_configfile() [1/2]

ms_crosslinking_configfile | ( | const char * | fileName,
 |  | const char * | schemaFileName,
 |  | const ms_connection_settings * | cs = 0,
 |  | bool | useSchema = true
 | ) |  |

Immediate action constructor that reads the XML file with the given name.

An instance of this class is normally created using this form of the constructor.

Parameters
fileName | represents either local file name (for example, "C:/crosslinking.xml") or a fully formed URL such as http://www.matrixscience.com/cgi . The filename may use backslashes or forward slashes on Windows and spaces in file or directory names are allowed.
schemaFileName | is a local file name for the schema (for example, "C:/crosslinking_2.xsd"). The schema must be a local file – it cannot be accessed using HTTP. The schema filename may use backslashes or forward slashes on Windows and spaces in file or directory names are allowed.
cs | a connection settings object for downloading the file from a Mascot server. This should contain a sessionID and optionally the proxy server settings. For a local file cs is not required and will be ignored.
useSchema | specify whether it should use a xsd schema validator, true by default

◆ ms_crosslinking_configfile() [2/2]

ms_crosslinking_configfile ( const ms_crosslinking_configfile & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ appendMethod()

void appendMethod ( const ms_crosslinking_method * elem )

Adds a new method at the end of the list.

Creates a new method object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters
elem an instance of the method object to copy content from.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_crosslinking_configfile * right )

Copies all the information from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ defaultValues()

void defaultValues ( )
virtual

Re-initialises the instance.

After calling this method, all internal values will be reset to their defaults, as if the object had been freshly created with the default constructor.

This method, however, doesn't change file name, schema location and connection settings. If a complete cleanup is required, you need to do three additional calls:

   crosslinking_configfile.setFileName("");
   crosslinking_configfile.setSchemaFileName("");
   crosslinking_configfile.setConnectionSetting(ms_connection_settings());

◆ deleteMethodByName()

bool deleteMethodByName ( const char * name )

Remove an method from the list in memory.

Parameters
name name of the method for deletion.
Returns
TRUE if the method has been found and successfully deleted and FALSE otherwise.

◆ deleteMethodByNumber()

bool deleteMethodByNumber ( const int idx )

Remove an method from the list in memory.

Parameters
idx number of the method for deletion from 0 to (getNumberOfMethods() - 1).
Returns
TRUE if the method has been found and successfully deleted and FALSE otherwise.

◆ getDefaultSchemaFileName()

std::string getDefaultSchemaFileName ( )
static

Returns the default schema filename (no path)

Static method to return the filename of the currently used schema

Returns
Returns "crosslinking_2.xsd" (at version 2.6.1)

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFileName()

std::string getFileName ( ) const

Returns the current file name.

Returns
currently set file location (not necessarily the location from which the current content has been read).

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMethodByName()

const ms_crosslinking_method * getMethodByName ( const char * name ) const

Returns an method object by its name or NULL in case of not found.

Parameters
name a unique name of the method.
Returns
a read-only pointer to an method object. See Maintaining object references: two rules of thumb.

◆ getMethodByNumber()

const ms_crosslinking_method * getMethodByNumber ( const int idx ) const

Returns an method object by its number.

Parameters
idx number of the method from 0 to (getNumberOfMethods() - 1).
Returns
a read-only pointer to an method object. See Maintaining object references: two rules of thumb.

◆ getNumberOfMethods()

int getNumberOfMethods ( ) const

Returns a number of methods currently held in memory.

Returns
total number of methods in the configuration file.

◆ getSchemaFileName()

std::string getSchemaFileName ( ) const

Returns the current schema file name that is used to validate the XML file.

Returns
currently set file location (not necessarily the location from which the current content has been read).

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_crosslinking_configfile & operator= ( const ms_crosslinking_configfile & right )

Assignment operator for C++ applications.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ read_buffer()

void read_buffer ( const char * buffer )

Reads configuration information from a string buffer.

This method is useful when reading configuration information from a mascor result file. Old content of the object will be removed and substituted with the information read from the buffer.

Parameters
buffer string buffer that contains a valid xml-document. It can be a document with just one modification in it, or only with amino acid masses.

◆ read_file()

void read_file ( )

Reads configuration information from the XML file.

Downloads the file if necessary from the Crosslinking web site and parses it. Check for errors before using any other methods for retrieving content.

◆ save_buffer()

std::string save_buffer ( bool validateAgainstSchema = true )

Creates a string representation of the XML document with all the content of the object.

Creates a valid XML document and returns it as a string which can be used, for example, for writing out configuration information to mascot result file.

To produce a 'file' that validates against the schema, it is not sufficient to add, for example, just a modification because this will be missing keyrefs to elements and termini building 'bricks'.

If you choose not to validate against the schema, then it is sufficient to just output, say, a single modification.

Parameters
validateAgainstSchema specifies whether to validate against the schema. If true and the schema file exists and the resulting XML fails to validate, then an empty string will be returned and the errors will indicate why it failed to validate.
Returns
XML document with the object content.

◆ save_file()

void save_file ( )

Saves configuration information in the XML file (not mod_file).

Check for errors after calling this method to see if the operation has been successful or to get any schema validation errors. If the document is not valid it is going to be saved anyway unless there are other problems.

If you want to validate document without actually saving it use validateDocument().

◆ setConnectionSettings()

void setConnectionSettings ( const ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters
cs is the new connection settings.

◆ setFileName()

void setFileName ( const char * name )

Changes the file name for subsequent read/write operations.

Calling this method does not mean an immediate update on disk. Use either read_file() or save_file() for that.

Parameters
name a new file location.

◆ setSchemaFileName()

void setSchemaFileName ( const char * name )

Call this member to specify a custom schema file name for validating the XML file.

Parameters
name a new file location (if empty default value will be assigned).

◆ updateMethodByName()

bool updateMethodByName | ( | const char * | name,
 |  | const ms_crosslinking_method * | method
 | ) |  |

Update the information for a specific method.

Parameters
name | name of the method for updating.
method | an object to copy the content from.
Returns
TRUE if the method has been found and successfully updated and FALSE otherwise.

◆ updateMethodByNumber()

bool updateMethodByNumber | ( | const int | idx,
 |  | const ms_crosslinking_method * | method
 | ) |  |

Update the information for a specific method.

Parameters
idx | number of the method for updating from 0 to (getNumberOfMethods() - 1).
method | an object to copy the content from.
Returns
TRUE if the method has been found and successfully updated and FALSE otherwise.

◆ validateDocument()

std::string validateDocument ( ) const

Validates the whole document against schema and returns errors as a string.

This method doesn't attempt to store the document anywhere and doesn't make the object invalid. Also, no errors are stored. Therefore, this method can be called as many times as necessary without any consequences.

All validation errors will be returned back as a string. However, the XML parser will describe errors in terms of row and column numbers as if the document was actually saved in a file.

Returns
validation errors as a string or an empty string if there are no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_configfile.hpp
  • ms_crosslinking_configfile.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_does_not_pair_with Class Reference

  • matrix_science
  • ms_crosslinking_does_not_pair_with
Public Member Functions | List of all members
ms_crosslinking_does_not_pair_with Class Reference
Mascot configuration files module

mxm:does_not_pair_with element in crosslinking.xml More...

#include <ms_crosslinking_does_not_pair_with.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_crosslinking_does_not_pair_with ()
Default constructor.
ms_crosslinking_does_not_pair_with (const ms_crosslinking_does_not_pair_with &src)
Copying constructor.
virtual | ~ms_crosslinking_does_not_pair_with ()
Destructor.
void | copyFrom (const ms_crosslinking_does_not_pair_with *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropModFileName ()
Delete the ModFileName attribute.
std::string | getModFileName () const
Returns the value of the ModFileName attribute.
std::string | getModFileNameSchemaType () const
Obtain a symbolic name for the ModFileName attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveModFileName () const
Indicates presence of the ModFileName attribute.
ms_crosslinking_does_not_pair_with & | operator= (const ms_crosslinking_does_not_pair_with &right)
C++ style assignment operator.
void | setModFileName (const char *value)
Set a custom value for the ModFileName attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

mxm:does_not_pair_with element in crosslinking.xml

Constructor & Destructor Documentation

◆ ms_crosslinking_does_not_pair_with() [1/2]

ms_crosslinking_does_not_pair_with ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_does_not_pair_with() [2/2]

ms_crosslinking_does_not_pair_with ( const ms_crosslinking_does_not_pair_with & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_crosslinking_does_not_pair_with * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropModFileName()

void dropModFileName ( )

Delete the ModFileName attribute.

Deletes the attribute until it is re-set.

◆ getModFileName()

std::string getModFileName ( ) const

Returns the value of the ModFileName attribute.

Returns
a descriptive name that will appear in drop down lists, etc.

◆ getModFileNameSchemaType()

std::string getModFileNameSchemaType ( ) const

Obtain a symbolic name for the ModFileName attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mxm:nameType").

◆ haveModFileName()

bool haveModFileName ( ) const

Indicates presence of the ModFileName attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_crosslinking_does_not_pair_with & operator= ( const ms_crosslinking_does_not_pair_with & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setModFileName()

void setModFileName ( const char * value )

Set a custom value for the ModFileName attribute.

Parameters
value a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_does_not_pair_with.hpp
  • ms_crosslinking_does_not_pair_with.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_filters Class Reference

  • matrix_science
  • ms_crosslinking_filters
Public Member Functions | List of all members
ms_crosslinking_filters Class Reference
Mascot configuration files module

Filters element in crosslinking.xml More...

#include <ms_crosslinking_filters.hpp>

Inheritance diagram for ms_crosslinking_filters:
[legend]
Collaboration diagram for ms_crosslinking_filters:
[legend]

Public Member Functions

ms_crosslinking_filters ()
Default constructor.
ms_crosslinking_filters (const ms_crosslinking_filters &src)
Copying constructor.
virtual | ~ms_crosslinking_filters ()
Destructor.
void | appendParameter (const ms_crosslinking_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_crosslinking_filters *right)
Copies all content from another instance.
void | copyFrom (const ms_crosslinking_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_crosslinking_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_crosslinking_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_filters & | operator= (const ms_crosslinking_filters &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its index.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Filters element in crosslinking.xml

The filters section contains a list of parameters. These specify which spectra are excluded from crosslinked matching.

In Mascot 2.7, available filters are:

  • MinPrecursorMr: minimum relative precursor mass (Da)
  • MinLen: minimum length of the shortest peptide in the pair
  • MinCharge: minimum precursor charge (absolute value). For example, specify "4" to exclude charge states -3, -2, -1, +1, +2 and +3.

Constructor & Destructor Documentation

◆ ms_crosslinking_filters() [1/2]

ms_crosslinking_filters ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_filters() [2/2]

ms_crosslinking_filters ( const ms_crosslinking_filters & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom() [1/2]

void copyFrom ( const ms_crosslinking_filters * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_crosslinking_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_crosslinking_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_crosslinking_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtual

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Reimplemented from ms_crosslinking_parameters.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mxm:nameType").

Reimplemented from ms_crosslinking_parameters.

◆ operator=()

ms_crosslinking_filters & operator= ( const ms_crosslinking_filters & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_crosslinking_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_crosslinking_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_filters.hpp
  • ms_crosslinking_filters.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_linker Class Reference

  • matrix_science
  • ms_crosslinking_linker
Public Member Functions | List of all members
ms_crosslinking_linker Class Reference
Mascot configuration files module

Linker element in crosslinking.xml More...

#include <ms_crosslinking_linker.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_crosslinking_linker ()
Default constructor.
ms_crosslinking_linker (const ms_crosslinking_linker &src)
Copying constructor.
virtual | ~ms_crosslinking_linker ()
Destructor.
void | appendDoesNotPairWith (const ms_crosslinking_does_not_pair_with *item)
Adds a new does_not_pair_with restriction at the end of the list.
void | appendMonoLink (const ms_crosslinking_monolink *item)
Adds a new monolink code at the end of the list.
void | clearDoesNotPairWiths ()
Deletes all does_not_pair_with restrictions from the list.
void | clearMonoLinks ()
Deletes all monolink codes from the list.
void | copyFrom (const ms_crosslinking_linker *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteDoesNotPairWithByNumber (const int idx)
Remove a does_not_pair_with restriction from the list in memory by its index.
bool | deleteMonoLinkByNumber (const int idx)
Remove a monolink code from the list in memory by its index.
void | dropModFileName ()
Delete the ModFileName attribute.
const ms_crosslinking_does_not_pair_with * | getDoesNotPairWithByNumber (const int idx) const
Returns a does_not_pair_with restriction object by its number.
std::string | getDoesNotPairWithSchemaType () const
Obtain a symbolic name for the does_not_pair_with element schema type.
std::string | getModFileName () const
Returns the value of the ModFileName attribute.
std::string | getModFileNameSchemaType () const
Obtain a symbolic name for the ModFileName attribute schema type.
const ms_crosslinking_monolink * | getMonoLinkByNumber (const int idx) const
Returns a monolink code object by its number.
std::string | getMonoLinkSchemaType () const
Obtain a symbolic name for the monolink element schema type.
int | getNumberOfDoesNotPairWiths () const
Returns the number of does_not_pair_with restrictions.
int | getNumberOfMonoLinks () const
Returns the number of monolink codes.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveModFileName () const
Indicates presence of the ModFileName attribute.
ms_crosslinking_linker & | operator= (const ms_crosslinking_linker &right)
C++ style assignment operator.
void | setModFileName (const char *value)
Set a custom value for the ModFileName attribute.
bool | updateDoesNotPairWithByNumber (const int idx, const ms_crosslinking_does_not_pair_with *does_not_pair_with)
Update the information for a specific does_not_pair_with restriction refering to it by its index.
bool | updateMonoLinkByNumber (const int idx, const ms_crosslinking_monolink *monolink)
Update the information for a specific monolink code refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Linker element in crosslinking.xml

The linker element specifies the modfile-style name of the linker molecule. A modfile-style name consists of the Unimod title of the linker (like "Xlink:DSS") followed by a specificity (like "Protein N-term"), e.g. "Xlink:DSS (Protein N-term)".

The linker element may list monolink definitions that should be tried as variable modifications during the search. Each monolink node is a one-letter code that identifies a "neutral loss" element in its definition.

The linker element may list does_not_pair_with restrictions. If there are no restrictions, the linker may pair with any other linker in the method. Otherwise, does_not_pair_with can be used to restrict the pairings.

Constructor & Destructor Documentation

◆ ms_crosslinking_linker() [1/2]

ms_crosslinking_linker ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_linker() [2/2]

ms_crosslinking_linker ( const ms_crosslinking_linker & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendDoesNotPairWith()

void appendDoesNotPairWith ( const ms_crosslinking_does_not_pair_with * item )

Adds a new does_not_pair_with restriction at the end of the list.

Creates a new does_not_pair_with restriction object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters
item an instance of a does_not_pair_with object to copy content from.

◆ appendMonoLink()

void appendMonoLink ( const ms_crosslinking_monolink * item )

Adds a new monolink code at the end of the list.

Creates a new monolink code object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters
item an instance of a monolink object to copy content from.

◆ copyFrom()

void copyFrom ( const ms_crosslinking_linker * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteDoesNotPairWithByNumber()

bool deleteDoesNotPairWithByNumber ( const int idx )

Remove a does_not_pair_with restriction from the list in memory by its index.

Parameters
idx number of the does_not_pair_with restriction for deletion from 0 to (getNumberOfDoesNotPairWiths() - 1).
Returns
TRUE if the does_not_pair_with restriction has been found and successfully deleted and FALSE otherwise.

◆ deleteMonoLinkByNumber()

bool deleteMonoLinkByNumber ( const int idx )

Remove a monolink code from the list in memory by its index.

Parameters
idx number of the monolink code for deletion from 0 to (getNumberOfMonoLinks() - 1).
Returns
TRUE if the monolink code has been found and successfully deleted and FALSE otherwise.

◆ dropModFileName()

void dropModFileName ( )

Delete the ModFileName attribute.

Deletes the attribute until it is re-set.

◆ getDoesNotPairWithByNumber()

const ms_crosslinking_does_not_pair_with * getDoesNotPairWithByNumber ( const int idx ) const

Returns a does_not_pair_with restriction object by its number.

Parameters
idx number of the does_not_pair_with restriction from 0 to (getNumberOfDoesNotPairWiths() - 1).
Returns
a read-only pointer to a does_not_pair_with object. See Maintaining object references: two rules of thumb.

◆ getDoesNotPairWithSchemaType()

std::string getDoesNotPairWithSchemaType ( ) const

Obtain a symbolic name for the does_not_pair_with element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getModFileName()

std::string getModFileName ( ) const

Returns the value of the ModFileName attribute.

Returns
a descriptive name that will appear in drop down lists, etc.

◆ getModFileNameSchemaType()

std::string getModFileNameSchemaType ( ) const

Obtain a symbolic name for the ModFileName attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMonoLinkByNumber()

const ms_crosslinking_monolink * getMonoLinkByNumber ( const int idx ) const

Returns a monolink code object by its number.

Parameters
idx number of the monolink code from 0 to (getNumberOfMonoLinks() - 1).
Returns
a read-only pointer to a monolink object. See Maintaining object references: two rules of thumb.

◆ getMonoLinkSchemaType()

std::string getMonoLinkSchemaType ( ) const

Obtain a symbolic name for the monolink element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfDoesNotPairWiths()

int getNumberOfDoesNotPairWiths ( ) const

Returns the number of does_not_pair_with restrictions.

Returns
total number of does_not_pair_with restrictions.

◆ getNumberOfMonoLinks()

int getNumberOfMonoLinks ( ) const

Returns the number of monolink codes.

Returns
total number of monolink codes.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ haveModFileName()

bool haveModFileName ( ) const

Indicates presence of the ModFileName attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_crosslinking_linker & operator= ( const ms_crosslinking_linker & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setModFileName()

void setModFileName ( const char * value )

Set a custom value for the ModFileName attribute.

Parameters
value a new value for the attribute.

◆ updateDoesNotPairWithByNumber()

bool updateDoesNotPairWithByNumber | ( | const int | idx,
 |  | const ms_crosslinking_does_not_pair_with * | does_not_pair_with
 | ) |  |

Update the information for a specific does_not_pair_with restriction refering to it by its index.

Parameters
idx | number of the does_not_pair_with restriction for updating from 0 to (getNumberOfDoesNotPairWiths() - 1).
does_not_pair_with | an object to copy the content from.
Returns
TRUE if the does_not_pair_with restriction has been found and successfully updated and FALSE otherwise.

◆ updateMonoLinkByNumber()

bool updateMonoLinkByNumber | ( | const int | idx,
 |  | const ms_crosslinking_monolink * | monolink
 | ) |  |

Update the information for a specific monolink code refering to it by its index.

Parameters
idx | number of the monolink code for updating from 0 to (getNumberOfMonoLinks() - 1).
monolink | an object to copy the content from.
Returns
TRUE if the monolink code has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_linker.hpp
  • ms_crosslinking_linker.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_linkers Class Reference

  • matrix_science
  • ms_crosslinking_linkers
Public Member Functions | List of all members
ms_crosslinking_linkers Class Reference
Mascot configuration files module

Linkers element in crosslinking.xml More...

#include <ms_crosslinking_linkers.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_crosslinking_linkers ()
Default constructor.
ms_crosslinking_linkers (const ms_crosslinking_linkers &src)
Copying constructor.
virtual | ~ms_crosslinking_linkers ()
Destructor.
void | appendLinker (const ms_crosslinking_linker *item)
Adds a new linker code at the end of the list.
void | clearLinkers ()
Deletes all linker codes from the list.
void | copyFrom (const ms_crosslinking_linkers *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteLinkerByNumber (const int idx)
Remove a linker code from the list in memory by its index.
const ms_crosslinking_linker * | getLinkerByNumber (const int idx) const
Returns a linker code object by its number.
std::string | getLinkerSchemaType () const
Obtain a symbolic name for the linker element schema type.
int | getNumberOfLinkers () const
Returns the number of linker.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_linkers & | operator= (const ms_crosslinking_linkers &right)
C++ style assignment operator.
bool | updateLinkerByNumber (const int idx, const ms_crosslinking_linker *linker)
Update the information for a specific linker code refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Linkers element in crosslinking.xml

The linkers element groups together specificities of a single linker.

In Mascot 2.7, the restrictions are:

  • At most one linkers element
  • The linkers group can contain multiple specificities of a single linker

For example, it is possible to specify Xlink:DSS (K) and Xlink:DSS (Protein N-term) for searching, as it is a single linker with two specificities. It is not possible to select two different linkers, like Xlink:DSS and Xlink:DSSO.

Constructor & Destructor Documentation

◆ ms_crosslinking_linkers() [1/2]

ms_crosslinking_linkers ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_linkers() [2/2]

ms_crosslinking_linkers ( const ms_crosslinking_linkers & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendLinker()

void appendLinker ( const ms_crosslinking_linker * item )

Adds a new linker code at the end of the list.

Creates a new linker code object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters
item an instance of a linker object to copy content from.

◆ copyFrom()

void copyFrom ( const ms_crosslinking_linkers * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteLinkerByNumber()

bool deleteLinkerByNumber ( const int idx )

Remove a linker code from the list in memory by its index.

Parameters
idx number of the linker code for deletion from 0 to (getNumberOfLinkers() - 1).
Returns
TRUE if the linker code has been found and successfully deleted and FALSE otherwise.

◆ getLinkerByNumber()

const ms_crosslinking_linker * getLinkerByNumber ( const int idx ) const

Returns a linker code object by its number.

Parameters
idx number of the linker code from 0 to (getNumberOfLinkers() - 1).
Returns
a read-only pointer to a linker object. See Maintaining object references: two rules of thumb.

◆ getLinkerSchemaType()

std::string getLinkerSchemaType ( ) const

Obtain a symbolic name for the linker element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfLinkers()

int getNumberOfLinkers ( ) const

Returns the number of linker.

Returns
total number of monolink codes.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ operator=()

ms_crosslinking_linkers & operator= ( const ms_crosslinking_linkers & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ updateLinkerByNumber()

bool updateLinkerByNumber | ( | const int | idx,
 |  | const ms_crosslinking_linker * | linker
 | ) |  |

Update the information for a specific linker code refering to it by its index.

Parameters
idx | number of the linker code for updating from 0 to (getNumberOfLinkers() - 1).
linker | an object to copy the content from.
Returns
TRUE if the linker code has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_linkers.hpp
  • ms_crosslinking_linkers.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_method Class Reference

  • matrix_science
  • ms_crosslinking_method
Public Member Functions | List of all members
ms_crosslinking_method Class Reference
Mascot configuration files module

Represents a method object in crosslinking.xml More...

#include <ms_crosslinking_method.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_crosslinking_method ()
Default constructor.
ms_crosslinking_method (const ms_crosslinking_method &src)
Copying constructor.
virtual | ~ms_crosslinking_method ()
Destructor.
void | copyFrom (const ms_crosslinking_method *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropAccessions ()
Delete the accessions element.
void | dropDescription ()
Delete the description attribute.
void | dropFilters ()
Delete the filters element.
void | dropLinkers ()
Delete the linkers element.
void | dropName ()
Delete the name attribute.
void | dropScope ()
Delete the scope element.
void | dropSettings ()
Delete the settings element.
void | dropStrategy ()
Delete the strategy attribute.
const ms_crosslinking_accessions * | getAccessions () const
Returns a pointer to the accessions element.
std::string | getAccessionsSchemaType () const
Obtain a symbolic name for the accessions element schema type.
std::string | getDescription () const
Returns the value of the description attribute.
std::string | getDescriptionSchemaType () const
Obtain a symbolic name for the description attribute schema type.
const ms_crosslinking_filters * | getFilters () const
Returns a pointer to the filters element.
std::string | getFiltersSchemaType () const
Obtain a symbolic name for the filters element schema type.
const ms_crosslinking_linkers * | getLinkers () const
Returns a pointer to the linkers element.
std::string | getLinkersSchemaType () const
Obtain a symbolic name for the linkers element schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the "name attribute" schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
const ms_crosslinking_scope * | getScope () const
Returns a pointer to the scope element.
std::string | getScopeSchemaType () const
Obtain a symbolic name for the scope element schema type.
const ms_crosslinking_settings * | getSettings () const
Returns a pointer to the settings element.
std::string | getSettingsSchemaType () const
Obtain a symbolic name for the settings element schema type.
std::string | getStrategy () const
Returns the value of the strategy attribute.
std::string | getStrategySchemaType () const
Obtain a symbolic name for the strategy attribute schema type.
bool | haveAccessions () const
Returns TRUE if a accessions element exists.
bool | haveDescription () const
Indicates whether the description attribute is present.
bool | haveFilters () const
Returns TRUE if a filters element exists.
bool | haveLinkers () const
Returns TRUE if a linkers element exists.
bool | haveName () const
Indicates whether the name attribute is present.
bool | haveScope () const
Returns TRUE if a scope element exists.
bool | haveSettings () const
Returns TRUE if a settings element exists.
bool | haveStrategy () const
Indicates whether the strategy attribute is present.
ms_crosslinking_method & | operator= (const ms_crosslinking_method &right)
C++ style assignment operator.
void | setAccessions (const ms_crosslinking_accessions *accessions)
Supply custom content for the accessions element.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setFilters (const ms_crosslinking_filters *filters)
Supply custom content for the filters element.
void | setLinkers (const ms_crosslinking_linkers *linkers)
Supply custom content for the linkers element.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setScope (const ms_crosslinking_scope *scope)
Supply custom content for the scope element.
void | setSettings (const ms_crosslinking_settings *settings)
Supply custom content for the settings element.
void | setStrategy (const char *value)
Set a custom value for the strategy attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents a method object in crosslinking.xml

A crosslinking method is a set of parameters that define and constrain the search space. See Crosslinked search results for a full description.

Constructor & Destructor Documentation

◆ ms_crosslinking_method() [1/2]

ms_crosslinking_method ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_method() [2/2]

ms_crosslinking_method ( const ms_crosslinking_method & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_crosslinking_method * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropAccessions()

void dropAccessions ( )

Delete the accessions element.

Deletes the element until it is re-set.

◆ dropDescription()

void dropDescription ( )

Delete the description attribute.

Deletes the attribute until it is re-set.

◆ dropFilters()

void dropFilters ( )

Delete the filters element.

Deletes the element until it is re-set.

◆ dropLinkers()

void dropLinkers ( )

Delete the linkers element.

Deletes the element until it is re-set.

◆ dropName()

void dropName ( )

Delete the name attribute.

Deletes the attribute until it is re-set.

◆ dropScope()

void dropScope ( )

Delete the scope element.

Deletes the element until it is re-set.

◆ dropSettings()

void dropSettings ( )

Delete the settings element.

Deletes the element until it is re-set.

◆ dropStrategy()

void dropStrategy ( )

Delete the strategy attribute.

Deletes the attribute until it is re-set.

◆ getAccessions()

const ms_crosslinking_accessions * getAccessions ( ) const

Returns a pointer to the accessions element.

Returns
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.

◆ getAccessionsSchemaType()

std::string getAccessionsSchemaType ( ) const

Obtain a symbolic name for the accessions element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getDescription()

std::string getDescription ( ) const

Returns the value of the description attribute.

Returns
a descriptive description that will appear in drop down lists, etc.

◆ getDescriptionSchemaType()

std::string getDescriptionSchemaType ( ) const

Obtain a symbolic name for the description attribute schema type.

The obtained type description can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type description for the element.

◆ getFilters()

const ms_crosslinking_filters * getFilters ( ) const

Returns a pointer to the filters element.

Returns
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.

◆ getFiltersSchemaType()

std::string getFiltersSchemaType ( ) const

Obtain a symbolic name for the filters element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getLinkers()

const ms_crosslinking_linkers * getLinkers ( ) const

Returns a pointer to the linkers element.

Returns
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.

◆ getLinkersSchemaType()

std::string getLinkersSchemaType ( ) const

Obtain a symbolic name for the linkers element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getName()

std::string getName ( ) const

Returns the value of the name attribute.

Returns
a descriptive name that will appear in drop down lists, etc.

◆ getNameSchemaType()

std::string getNameSchemaType ( ) const

Obtain a symbolic name for the "name attribute" schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ getScope()

const ms_crosslinking_scope * getScope ( ) const

Returns a pointer to the scope element.

Returns
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.

◆ getScopeSchemaType()

std::string getScopeSchemaType ( ) const

Obtain a symbolic name for the scope element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSettings()

const ms_crosslinking_settings * getSettings ( ) const

Returns a pointer to the settings element.

Returns
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.

◆ getSettingsSchemaType()

std::string getSettingsSchemaType ( ) const

Obtain a symbolic name for the settings element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getStrategy()

std::string getStrategy ( ) const

Returns the value of the strategy attribute.

Returns
a descriptive strategy that will appear in drop down lists, etc.

◆ getStrategySchemaType()

std::string getStrategySchemaType ( ) const

Obtain a symbolic name for the strategy attribute schema type.

The obtained type strategy can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type strategy for the element.

◆ haveAccessions()

bool haveAccessions ( ) const

Returns TRUE if a accessions element exists.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveDescription()

bool haveDescription ( ) const

Indicates whether the description attribute is present.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveFilters()

bool haveFilters ( ) const

Returns TRUE if a filters element exists.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveLinkers()

bool haveLinkers ( ) const

Returns TRUE if a linkers element exists.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveName()

bool haveName ( ) const

Indicates whether the name attribute is present.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveScope()

bool haveScope ( ) const

Returns TRUE if a scope element exists.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveSettings()

bool haveSettings ( ) const

Returns TRUE if a settings element exists.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveStrategy()

bool haveStrategy ( ) const

Indicates whether the strategy attribute is present.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_crosslinking_method & operator= ( const ms_crosslinking_method & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAccessions()

void setAccessions ( const ms_crosslinking_accessions * accessions )

Supply custom content for the accessions element.

Parameters
accessions a new content for the element.

◆ setDescription()

void setDescription ( const char * value )

Set a custom value for the description attribute.

Parameters
value a new value for the attribute.

◆ setFilters()

void setFilters ( const ms_crosslinking_filters * filters )

Supply custom content for the filters element.

Parameters
filters a new content for the element.

◆ setLinkers()

void setLinkers ( const ms_crosslinking_linkers * linkers )

Supply custom content for the linkers element.

Parameters
linkers a new content for the element.

◆ setName()

void setName ( const char * value )

Set a custom value for the name attribute.

Parameters
value a new value for the attribute.

◆ setScope()

void setScope ( const ms_crosslinking_scope * scope )

Supply custom content for the scope element.

Parameters
scope a new content for the element.

◆ setSettings()

void setSettings ( const ms_crosslinking_settings * settings )

Supply custom content for the settings element.

Parameters
settings a new content for the element.

◆ setStrategy()

void setStrategy ( const char * value )

Set a custom value for the strategy attribute.

Parameters
value a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_method.hpp
  • ms_crosslinking_method.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_monolink Class Reference

  • matrix_science
  • ms_crosslinking_monolink
Public Member Functions | List of all members
ms_crosslinking_monolink Class Reference
Mascot configuration files module

Monolink element in crosslinking.xml More...

#include <ms_crosslinking_monolink.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_crosslinking_monolink ()
Default constructor.
ms_crosslinking_monolink (const ms_crosslinking_monolink &src)
Copying constructor.
virtual | ~ms_crosslinking_monolink ()
Destructor.
void | copyFrom (const ms_crosslinking_monolink *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getValue () const
Returns the text of the node.
std::string | getValueSchemaType () const
Obtain a symbolic name for the text node schema type.
ms_crosslinking_monolink & | operator= (const ms_crosslinking_monolink &right)
C++ style assignment operator.
void | setValue (const char *value)
Set a custom text.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Monolink element in crosslinking.xml

Constructor & Destructor Documentation

◆ ms_crosslinking_monolink() [1/2]

ms_crosslinking_monolink ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_monolink() [2/2]

ms_crosslinking_monolink ( const ms_crosslinking_monolink & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_crosslinking_monolink * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mxm:nameType").

◆ getValue()

std::string getValue ( ) const

Returns the text of the node.

Returns
current value text.

◆ getValueSchemaType()

std::string getValueSchemaType ( ) const

Obtain a symbolic name for the text node schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ operator=()

ms_crosslinking_monolink & operator= ( const ms_crosslinking_monolink & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setValue()

void setValue ( const char * value )

Set a custom text.

Parameters
value a new value text.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_monolink.hpp
  • ms_crosslinking_monolink.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_parameter Class Reference

  • matrix_science
  • ms_crosslinking_parameter
Public Member Functions | List of all members
ms_crosslinking_parameter Class Reference
Mascot configuration files module

Parameter name and value pair. More...

#include <ms_crosslinking_parameters.hpp>

Inheritance diagram for ms_crosslinking_parameter:
[legend]
Collaboration diagram for ms_crosslinking_parameter:
[legend]

Public Member Functions

ms_crosslinking_parameter ()
Default constructor.
ms_crosslinking_parameter (const ms_crosslinking_parameter &src)
Copying constructor.
virtual | ~ms_crosslinking_parameter ()
Destructor.
void | copyFrom (const ms_crosslinking_parameter *right)
Copies all content from another instance.
void | copyFrom (const ms_xml_parameter *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropDescription ()
Delete the description attribute.
void | dropName ()
Delete the name attribute.
std::string | getDescription () const
Returns the value of the description attribute.
virtual std::string | getDescriptionSchemaType () const
Obtain a symbolic name for the description attribute schema type.
std::string | getName () const
Returns the value of the name attribute.
virtual std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getValue () const
Returns the value of the value attribute.
virtual std::string | getValueSchemaType () const
Obtain a symbolic name for the value attribute schema type.
bool | haveDescription () const
Indicates presence of the description attribute.
bool | haveName () const
Indicates presence of the name attribute.
ms_crosslinking_parameter & | operator= (const ms_crosslinking_parameter &right)
C++ style assignment operator.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setValue (const char *value)
Set a custom value for the value attribute.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Parameter name and value pair.

Constructor & Destructor Documentation

◆ ms_crosslinking_parameter() [1/2]

ms_crosslinking_parameter ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_parameter() [2/2]

ms_crosslinking_parameter ( const ms_crosslinking_parameter & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom() [1/2]

void copyFrom ( const ms_crosslinking_parameter * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_xml_parameter * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ dropDescription()

void dropDescription ( )
inherited

Delete the description attribute.

Deletes the attribute until is re-set.

◆ dropName()

void dropName ( )
inherited

Delete the name attribute.

Deletes the attribute until is re-set.

◆ getDescription()

std::string getDescription ( ) const
inherited

Returns the value of the description attribute.

Returns
a free text description of this parameter.

◆ getDescriptionSchemaType()

std::string getDescriptionSchemaType ( ) const
virtual

Obtain a symbolic name for the description attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameter.

◆ getName()

std::string getName ( ) const
inherited

Returns the value of the name attribute.

Returns
a descriptive name that will appear in drop down lists, etc.

◆ getNameSchemaType()

std::string getNameSchemaType ( ) const
virtual

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameter.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Implements ms_xml_parameter.

◆ getValue()

std::string getValue ( ) const
inherited

Returns the value of the value attribute.

Returns
a string value of this parameter.

◆ getValueSchemaType()

std::string getValueSchemaType ( ) const
virtual

Obtain a symbolic name for the value attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameter.

◆ haveDescription()

bool haveDescription ( ) const
inherited

Indicates presence of the description attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveName()

bool haveName ( ) const
inherited

Indicates presence of the name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_crosslinking_parameter & operator= ( const ms_crosslinking_parameter & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setDescription()

void setDescription ( const char * value )
inherited

Set a custom value for the description attribute.

Parameters
value a new value for the attribute.

◆ setName()

void setName ( const char * value )
inherited

Set a custom value for the name attribute.

Parameters
value a new value for the attribute.

◆ setValue()

void setValue ( const char * value )
inherited

Set a custom value for the value attribute.

Parameters
value a new string value for the parameter.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_parameters.hpp
  • ms_crosslinking_parameters.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_parameters Class Reference

  • matrix_science
  • ms_crosslinking_parameters
Public Member Functions | List of all members
ms_crosslinking_parameters Class Reference
Mascot configuration files module

A class that represents base parametersType in crosslinking_1.xsd. More...

#include <ms_crosslinking_parameters.hpp>

Inheritance diagram for ms_crosslinking_parameters:
[legend]
Collaboration diagram for ms_crosslinking_parameters:
[legend]

Public Member Functions

ms_crosslinking_parameters ()
Default constructor.
ms_crosslinking_parameters (const ms_crosslinking_parameters &src)
Copying constructor.
virtual | ~ms_crosslinking_parameters ()
Destructor.
void | appendParameter (const ms_crosslinking_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_crosslinking_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_crosslinking_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_crosslinking_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_parameters & | operator= (const ms_crosslinking_parameters &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its index.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

A class that represents base parametersType in crosslinking_1.xsd.

Holds a list of arbitrary parameters.

Constructor & Destructor Documentation

◆ ms_crosslinking_parameters() [1/2]

ms_crosslinking_parameters ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_parameters() [2/2]

ms_crosslinking_parameters ( const ms_crosslinking_parameters & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_crosslinking_parameters * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtual

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtual

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtual

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_crosslinking_parameter * getParameterByName ( const char * name ) const

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_crosslinking_parameter * getParameterByNumber ( const int idx ) const

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtual

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

Reimplemented in ms_crosslinking_filters, ms_crosslinking_scope, and ms_crosslinking_settings.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mxm:nameType").

Implements ms_xml_parameters.

Reimplemented in ms_crosslinking_filters, ms_crosslinking_scope, and ms_crosslinking_settings.

◆ operator=()

ms_crosslinking_parameters & operator= ( const ms_crosslinking_parameters & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_crosslinking_parameter * | param
 | ) |  |

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_crosslinking_parameter * | param
 | ) |  |

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_parameters.hpp
  • ms_crosslinking_parameters.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_scope Class Reference

  • matrix_science
  • ms_crosslinking_scope
Public Member Functions | List of all members
ms_crosslinking_scope Class Reference
Mascot configuration files module

Scope element in crosslinking.xml More...

#include <ms_crosslinking_scope.hpp>

Inheritance diagram for ms_crosslinking_scope:
[legend]
Collaboration diagram for ms_crosslinking_scope:
[legend]

Public Member Functions

ms_crosslinking_scope ()
Default constructor.
ms_crosslinking_scope (const ms_crosslinking_scope &src)
Copying constructor.
virtual | ~ms_crosslinking_scope ()
Destructor.
void | appendParameter (const ms_crosslinking_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_crosslinking_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_crosslinking_scope *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_crosslinking_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_crosslinking_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_scope & | operator= (const ms_crosslinking_scope &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its index.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Scope element in crosslinking.xml

The scope section contains a list of parameters. These define the type of links to look for.

In Mascot 2.7, scope parameters are:

  • MaxProteins: maximum number of proteins to consider for interlinking
  • InterLink: look for links between proteins ("True" or "False")
  • IntraLink: look for links within proteins ("True" or "False")
  • LoopLink: look for links within peptides ("True" or "False")

Constructor & Destructor Documentation

◆ ms_crosslinking_scope() [1/2]

ms_crosslinking_scope ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_scope() [2/2]

ms_crosslinking_scope ( const ms_crosslinking_scope & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom() [1/2]

void copyFrom ( const ms_crosslinking_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_crosslinking_scope * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_crosslinking_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_crosslinking_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtual

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Reimplemented from ms_crosslinking_parameters.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mxm:nameType").

Reimplemented from ms_crosslinking_parameters.

◆ operator=()

ms_crosslinking_scope & operator= ( const ms_crosslinking_scope & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_crosslinking_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_crosslinking_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_scope.hpp
  • ms_crosslinking_scope.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_settings Class Reference

  • matrix_science
  • ms_crosslinking_settings
Public Member Functions | List of all members
ms_crosslinking_settings Class Reference
Mascot configuration files module

Settings element in crosslinking.xml More...

#include <ms_crosslinking_settings.hpp>

Inheritance diagram for ms_crosslinking_settings:
[legend]
Collaboration diagram for ms_crosslinking_settings:
[legend]

Public Member Functions

ms_crosslinking_settings ()
Default constructor.
ms_crosslinking_settings (const ms_crosslinking_settings &src)
Copying constructor.
virtual | ~ms_crosslinking_settings ()
Destructor.
void | appendParameter (const ms_crosslinking_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_crosslinking_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_crosslinking_settings *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_crosslinking_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_crosslinking_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_settings & | operator= (const ms_crosslinking_settings &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its index.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Settings element in crosslinking.xml

The settings section contains a list of parameters. These define the "business logic" for the crosslinking strategy.

These settings are intended for upstream (downstream) processing before (after) the spectrum has been matched:

  • AssumeLinear: fragments with this charge or less are assumed not to include linked peptide (absolute value)
  • AssumeLinked: fragments with this charge or more are assumed to include linked peptide (absolute value)
  • SignatureScan: identifier(s) for scans to be inspected for signature peaks (see below)
  • SignatureType: one of "reporter", "doublet", "triplet", "quadruplet"
  • SignatureComp: depends on SignatureType, and specified as an elemental composition. The signature could be a single delta, multiple deltas or one or more reporter peaks.
  • SignatureSN: minimum S/N for signature peak(s)
  • SignatureStringency: one of "low", "medium", "high"
  • SignatureTop: number of the most intense peaks that are candidates to be signature peaks
  • MatchPair: identifier(s) for scans that may include fragments from both peptides in a pair (see below)
  • MatchSingle: identifier(s) for scans that may include fragments from one peptide only (see below)

Scan identifier format for SignatureScan, MatchPair and MatchSingle is a comma-separated list of tokens from:

  • CID
  • ETD
  • MS1
  • MS2
  • MS3

Constructor & Destructor Documentation

◆ ms_crosslinking_settings() [1/2]

ms_crosslinking_settings ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_crosslinking_settings() [2/2]

ms_crosslinking_settings ( const ms_crosslinking_settings & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom() [1/2]

void copyFrom ( const ms_crosslinking_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_crosslinking_settings * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_crosslinking_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_crosslinking_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtual

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Reimplemented from ms_crosslinking_parameters.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mxm:nameType").

Reimplemented from ms_crosslinking_parameters.

◆ operator=()

ms_crosslinking_settings & operator= ( const ms_crosslinking_settings & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_crosslinking_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_crosslinking_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_settings.hpp
  • ms_crosslinking_settings.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_databaseoptions Class Reference

  • matrix_science
  • ms_databaseoptions
Public Types | Public Member Functions | List of all members
ms_databaseoptions Class Reference
Mascot configuration files module

An instance of this class represents a single database definition from the Databases section of mascot.dat. More...

#include <ms_databaseoptions.hpp>

Public Types

enum { NUM_THREADS_AUTO_DETECT = -1 }
Value used to indicate that the number of threads to be used should be automatically determined at runtime. More...

Public Member Functions

ms_databaseoptions ()
Default constructor.
ms_databaseoptions (const ms_databaseoptions &src)
Copying constructor.
~ms_databaseoptions ()
Destructor.
void | copyFrom (const ms_databaseoptions *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
int | getAccessionParseRuleIndex () const
Returns the value of AccessionParseRuleIndex.
int | getAccessionRefParseRuleIndex () const
Returns the value of AccessionRefParseRuleIndex.
int | getDBType () const
Return the database type.
int | getDescriptionParseRuleIndex () const
Returns the value of DescriptionParseRuleIndex.
std::string | getName () const
Returns the value of Name.
int | getNumberOfThreads () const
Returns the value of Threads.
std::string | getPath () const
Return the value of Path.
const std::string & | getPreceedingComments () const
Get the comment preceding this database entry.
int | getTaxonomyParseRuleIndex () const
Returns the value of TaxonomyParseRuleIndex.
bool | isActive () const
Returns true if the database definition is active and false otherwise.
bool | isLocalRefFile () const
Returns TRUE if LocalRefFile flag is set to 1 and FALSE otherwise.
bool | isLockMemory () const
Returns TRUE if MemLock flag is set to 1 and FALSE otherwise.
bool | isMemoryMapFiles () const
Returns the value of MemMap.
ms_databaseoptions & | operator= (const ms_databaseoptions &right)
Assignment operator for C++ client applications.
void | setAccessionParseRuleIndex (const int index)
Change AccessionParseRuleIndex.
void | setAccessionRefParseRuleIndex (const int index)
Change AccessionRefParseRuleIndex.
void | setActive (const bool value)
Set the definition as active or inactive.
void | setDBType (const int type)
Change the database type.
void | setDescriptionParseRuleIndex (const int index)
Change DescriptionParseRuleIndex.
void | setLocalRefFile (const bool flag)
Change LocalRefFile.
void | setLockMemory (const bool flag)
Change MemLock.
void | setMemoryMapFiles (const bool flag)
Change MemMap.
void | setName (const char *name)
Change Name.
void | setNumberOfThreads (const int number)
Change Threads.
void | setPath (const char *path)
Change Path.
void | setPreceedingComments (const std::string &str)
Set the comments preceding this database entry.
void | setTaxonomyParseRuleIndex (const int index)
Change TaxonomyParseRuleIndex.

Detailed Description

An instance of this class represents a single database definition from the Databases section of mascot.dat.

An instance of this class can be normally created within ms_datfile. Before using a definition you must check whether it is active or not (with isActive()). An inactive database definition is allowed to have invalid properties and, therefore, must be ignored for database searches/maintenance. An inactive definition can be made active with setActive(). Before doing so, make sure all the properties are valid.

Instances of the class can be stored in ms_databases.

Member Enumeration Documentation

◆ anonymous enum

anonymous enum

Value used to indicate that the number of threads to be used should be automatically determined at runtime.

See ms_processors::getAutoDetectNumThreads() and getNumberOfThreads().

(Defined as an enum rather than static const int to support VC6)

Enumerator
NUM_THREADS_AUTO_DETECT

Value used to indicate that the number of threads to be used should be automatically determined at runtime.

Member Function Documentation

◆ getAccessionParseRuleIndex()

int getAccessionParseRuleIndex ( ) const

Returns the value of AccessionParseRuleIndex.

Index of the regular expression in the PARSE section that can be used to parse an accession string from a FASTA file title line.

Default is 0.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns
the index for the parse rule.

◆ getAccessionRefParseRuleIndex()

int getAccessionRefParseRuleIndex ( ) const

Returns the value of AccessionRefParseRuleIndex.

Index of the regular expression in the PARSE section that can be used to parse an accession string from a local full text reference file. If there is no local reference file, this value is ignored.

Default is 0.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns
the index for the parse rule.

◆ getDBType()

int getDBType ( ) const

Return the database type.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns
One of the DATABASE_TYPE enumeration values. Note that the returned type is never SLREF.

◆ getDescriptionParseRuleIndex()

int getDescriptionParseRuleIndex ( ) const

Returns the value of DescriptionParseRuleIndex.

Index of the regular expression in the PARSE section that can be used to parse a description string from a FASTA file title line.

Default is 0.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns
the index for the parse rule.

◆ getName()

std::string getName ( ) const

Returns the value of Name.

Each database must have a unique case-sensitive name that is displayed in the search form

The name does not need to be the same as or even similar to the filename of the actual FASTA file.

Do not use spaces, punctuation, or control characters in names.

By default this is empty.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns
the name of the database
Examples
config_mascotdat.cpp.

◆ getNumberOfThreads()

int getNumberOfThreads ( ) const

Returns the value of Threads.

A Mascot search can use multiple threads. If you are running in cluster mode, Threads should be set to 1. Otherwise, specify the same number of threads as processors in your system.

A value of -1 is 'AUTO' which means that the number of threads is set to the maximum possible depending on the number of cores avaiable and the size of the license.

This value has no meaning for spectral libraries

Default, from version 2.6 onwards is -1.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | N
Returns
the number of threads

◆ getPath()

std::string getPath ( ) const

Return the value of Path.

FASTA database files must be on a local disk. Mascot creates its compressed files in the same directory as the original FASTA file. The location of the FASTA file is defined in the Path field. This must be the fully qualified path to the FASTA file, with a wild card in the filename. The delimiters between directories must always be forward slashes, even if Mascot is running on a Windows system.

By default this is empty.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns
the path with wild card

◆ getTaxonomyParseRuleIndex()

int getTaxonomyParseRuleIndex ( ) const

Returns the value of TaxonomyParseRuleIndex.

Index of the taxonomy rule block to be used to parse taxonomy information. If taxonomy information is not available, or is not to be used, this value should be set to 0.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | N

Default is 0.

Returns
Index of the taxonony rule

◆ isActive()

bool isActive ( ) const

Returns true if the database definition is active and false otherwise.

Inactive definitions represent the entries that can be made active by the database manager utility. In the mascot.dat file, they are simply commented out entries.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns
true if the database definition is active
Examples
config_mascotdat.cpp.

◆ isLocalRefFile()

bool isLocalRefFile ( ) const

Returns TRUE if LocalRefFile flag is set to 1 and FALSE otherwise.

Flag to indicate whether a local reference file is available (1) or not (0). For certain databases (MSDB, OWL, and SwissProt), it is possible to have a local reference file, from which full text information can be taken for a Protein View report.

Default is 0.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | N
Returns
true if the database has a local reference file

◆ isLockMemory()

bool isLockMemory ( ) const

Returns TRUE if MemLock flag is set to 1 and FALSE otherwise.

Flag to indicate whether a memory mapped database file should be locked in memory (1) or not (0).

Default is 0.

See also
isMemoryMapFiles()

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | N
Returns
true if the database should be locked in memory

◆ isMemoryMapFiles()

bool isMemoryMapFiles ( ) const

Returns the value of MemMap.

This flag is to indicate whether the database file should be memory mapped (1) or not (0). Database files should always be memory mapped. Unlike memory locking, this does not consume physical RAM.

Default is 1.

See also
isLockMemory()

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | N
Returns
true if the database is to be memory mapped

◆ setAccessionParseRuleIndex()

void setAccessionParseRuleIndex ( const int index )

Change AccessionParseRuleIndex.

See getAccessionParseRuleIndex() for more information.

Parameters
index is the new value

◆ setAccessionRefParseRuleIndex()

void setAccessionRefParseRuleIndex ( const int index )

Change AccessionRefParseRuleIndex.

See getAccessionRefParseRuleIndex() for more information.

Parameters
index is the new value

◆ setActive()

void setActive ( const bool value )

Set the definition as active or inactive.

See isActive() for more information.

Parameters
value is the new value

◆ setDBType()

void setDBType ( const int type )

Change the database type.

See getDBType() for more information.

Parameters
type should be one of the DATABASE_TYPE enumeration values. Note that SLREF is not a supported database type for this purpose.

◆ setDescriptionParseRuleIndex()

void setDescriptionParseRuleIndex ( const int index )

Change DescriptionParseRuleIndex.

See getDescriptionParseRuleIndex() for more information.

Parameters
index is the new value

◆ setLocalRefFile()

void setLocalRefFile ( const bool flag )

Change LocalRefFile.

See isLocalRefFile() for more information.

Parameters
flag is the new value

◆ setLockMemory()

void setLockMemory ( const bool flag )

Change MemLock.

See isLockMemory() for more information.

Parameters
flag is the new value

◆ setMemoryMapFiles()

void setMemoryMapFiles ( const bool flag )

Change MemMap.

See isMemoryMapFiles() for more information.

Parameters
flag is the new value

◆ setName()

void setName ( const char * name )

Change Name.

See getName() for more information.

Parameters
name is the new value

◆ setNumberOfThreads()

void setNumberOfThreads ( const int number )

Change Threads.

See getNumberOfThreads() for more information.

Parameters
number is the new value

◆ setPath()

void setPath ( const char * path )

Change Path.

See getPath() for more information.

Parameters
path is the new value

◆ setTaxonomyParseRuleIndex()

void setTaxonomyParseRuleIndex ( const int index )

Change TaxonomyParseRuleIndex.

See getTaxonomyParseRuleIndex() for more information.

Parameters
index is the new value
The documentation for this class was generated from the following files:
  • ms_databaseoptions.hpp
  • ms_databaseoptions.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_databases Class Reference

  • matrix_science
  • ms_databases
Public Member Functions | List of all members
ms_databases Class Reference
Mascot configuration files module

An instance of this class represents the Databases section of mascot.dat. More...

#include <ms_databaseoptions.hpp>

Inheritance diagram for ms_databases:
[legend]
Collaboration diagram for ms_databases:
[legend]

Public Member Functions

ms_databases ()
Default constructor.
ms_databases (const ms_databases &src)
Copying constructor.
~ms_databases ()
Destructor.
void | appendDatabase (const ms_databaseoptions *item)
Add one more database definition at the end of the list.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearDatabases ()
Deletes all database definitions.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_databases *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
bool | deleteDatabaseByName (const char *name)
Remove a database from the list in memory.
bool | deleteDatabaseByNumber (const int num)
Remove a database from the list in memory.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findDatabase (const char *dbName, const bool searchInactive=false) const
Finds a database with the specified name and returns its number to access.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
const ms_databaseoptions * | getDatabase (const int index) const
Returns a database definition by its number.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
int | getNumberOfDatabases () const
Returns the total number of database definitions including inactive (commented out) databases.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
bool | isSectionAvailable () const
Check if the section has been actually read form the file or have to be saved.
ms_databases & | operator= (const ms_databases &right)
Assignment operator for C++ client applications.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in the file.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.
bool | updateDatabaseByName (const char *name, const ms_databaseoptions db)
Update the information for a specific database.
bool | updateDatabaseByNumber (const int num, const ms_databaseoptions db)
Update the information for a specific database.

Detailed Description

An instance of this class represents the Databases section of mascot.dat.

An instance is created and populated with database entries within ms_datfile class. It contains active database definitions as well as inactive ones. When traversing the list of database with getNumberOfDatabases() and getDatabase() members, don't forget to check each entry for being active. Otherwise one or all database parameters might be invalid and, therefore, must be ignored. In a text-based configuration file a database definition can be made inactive by commenting it out.

For detailed information on any of the options please consult Mascot manual.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • retrieving an unsupported property
  • retrieving raw/text/xml property representation
  • checking for existence of a certain property rather than dealing with its default value
  • accessing commented lines in a section

More functionality is described in details in the documentation for the class.

Examples
config_mascotdat.cpp.

Member Function Documentation

◆ appendDatabase()

void appendDatabase ( const ms_databaseoptions * item )

Add one more database definition at the end of the list.

Parameters
item valid pointer to a ms_databaseoptions object

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ deleteDatabaseByName()

bool deleteDatabaseByName ( const char * name )

Remove a database from the list in memory.

If the database name is specified incorrectly FALSE value is returned and no action is performed.

Parameters
name the database name.
Returns
TRUE if the database has been found and deleted and FALSE otherwise.

◆ deleteDatabaseByNumber()

bool deleteDatabaseByNumber ( const int num )

Remove a database from the list in memory.

If the database index is specified incorrectly FALSE value is returned and no action is performed.

Parameters
num zero-based database index.
Returns
TRUE if the database has been deleted and FALSE otherwise.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findDatabase()

int findDatabase | ( | const char * | dbName,
 |  | const bool | searchInactive = false
 | ) |  | const

Finds a database with the specified name and returns its number to access.

Note that only active database will be returned (unless searchInactive is set to TRUE). If no database have been found the returning value will be -1.

Parameters
dbName | a database name to find.
searchInactive | set this parameter to TRUE if you want to search both active and inactive databases.
Returns
the database index if found and -1 if not.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getDatabase()

const ms_databaseoptions * getDatabase ( const int index ) const

Returns a database definition by its number.

Use this member to retrieve a database definition with index from 0 to (getNumberOfDatabases()-1).

Parameters
index number of database to look for
Returns
pointer to a ms_databaseoptions object
Examples
config_mascotdat.cpp.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getNumberOfDatabases()

int getNumberOfDatabases ( ) const

Returns the total number of database definitions including inactive (commented out) databases.

By default the list of database is empty unless explicitly populated.

Returns
Number of databases
Examples
config_mascotdat.cpp.

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise

◆ updateDatabaseByName()

bool updateDatabaseByName | ( | const char * | name,
 |  | const ms_databaseoptions | db
 | ) |  |

Update the information for a specific database.

If a database with the supplied name cannot be found no database will be updated and the returning value will be FALSE.

Parameters
name | a database name to find.
db | a database object to copy the content from.
Returns
TRUE if the database has been successfully found and updated and FALSE otherwise.

◆ updateDatabaseByNumber()

bool updateDatabaseByNumber | ( | const int | num,
 |  | const ms_databaseoptions | db
 | ) |  |

Update the information for a specific database.

If the index is out of bounds no database will be updated and the returning value will be FALSE.

Parameters
num | a zero-based index of the database to update.
db | a database object to copy the content from.
Returns
TRUE if the database index indicates a valid database in the internal list and FALSE otherwise.
The documentation for this class was generated from the following files:
  • ms_databaseoptions.hpp
  • ms_databaseoptions.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_datfile Class Reference

  • matrix_science
  • ms_datfile
Public Types | Public Member Functions | List of all members
ms_datfile Class Reference
Mascot configuration files module

Encapsulates the mascot.dat file that contains the most important parameters. More...

#include <ms_datfile.hpp>

Inheritance diagram for ms_datfile:
[legend]
Collaboration diagram for ms_datfile:
[legend]

Public Types

enum INST_FLAGS {
IFLG_UPDATETAXONOMY = 0x00000001 ,
IFLG_UPDATEPARSERULES = 0x00000002 ,
IFLG_UPDATESWISSPROT = 0x00000004 ,
IFLG_UPDATECLUSTER = 0x00000008 ,
IFLG_UPDATEESTTAX = 0x00000010 ,
IFLG_ADDMISSINGOPTIONS = 0x00000020 ,
IFLG_ADDREPORTAUTO = 0x00000040 ,
IFLG_UPDATEAPACHEFORKOPT = 0x00000080 ,
IFLG_ADDPERCOLATOROPT = 0x00000100 ,
IFLG_UPDATENCBIHTTPS = 0x00000200 ,
IFLG_UPDATEPRIDECONTAMINANTS = 0x00000400 ,
IFLG_UPDATEDBMANAGERPERLPATH = 0x00000800 ,
IFLG_UPDATEMSPEPSEARCHOPTS = 0x00001000 ,
IFLG_UPDATEEXECAFTERSEARCH = 0x00002000 ,
IFLG_UPDATEPERCOLATORFEATS = 0x00004000 ,
IFLG_UPDATEPROTFAMILYSWITCH = 0x00008000 ,
IFLG_UPDATEPERCOLATORUSERT = 0x00010000 ,
IFLG_UPDATESPLITNUMOFQUERIES = 0x00020000 ,
IFLG_UPDATESPLITDATAFILESIZE = 0x00040000 ,
IFLG_UPDATERESULTSCACHE = 0x00080000 ,
IFLG_DEFAULTNEWINSTALL ,
IFLG_DEFAULTUPGRADE
}
Flags for the updateForInstaller() function. More...
enum SEQDB_INSTALL {
SEQDB_INSTALL_SHOULD_QUERY_USER = 0x0000FFFF ,
SEQDB_INSTALL_CUSTOMISED = 0x00000001 ,
SEQDB_INSTALL_INACTIVE = 0x00000002 ,
SEQDB_INSTALL_INVALID_CONFIG = 0x00000004 ,
SEQDB_INSTALL_EXISTING_LARGER = 0x00000010 ,
SEQDB_INSTALL_INVALID_DBNAME = 0x00000000 ,
SEQDB_INSTALL_MUST_UPDATE_CFG = 0x000F000F ,
SEQDB_INSTALL_MISSING_CONFIG = 0x00010000 ,
SEQDB_INSTALL_OLD_RULES = 0x00020000 ,
SEQDB_INSTALL_WRONG_WILDCARD = 0x00040000 ,
SEQDB_INSTALL_CURRENT_RULES = 0x01000000
}
Flags for checkSeqDBInstallRequest(). More...
enum WST {
WST_APACHE =0 ,
WST_IIS =1
}
Web server type for the updateForInstaller() function. More...

Public Member Functions

ms_datfile ()
Default constructor.
ms_datfile (const char *filename, const int timeoutSec=0, const matrix_science::ms_connection_settings *cs=0)
Immediate action constructor.
ms_datfile (const ms_datfile &src)
Copying constructor.
~ms_datfile ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
unsigned int | checkSeqDBInstallRequest (const std::string &dbName, const double newFastaSize) const
Utility function for the installation program.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_datfile *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | defaultValues ()
Can be used for initialising an instance with default values.
bool | editedByDatabaseManager () const
This function returns true if Database Manager has edited the mascot.dat file.
const ms_clusterparams * | getClusterParams () const
Returns an instance of the class representing the Cluster section.
matrix_science::ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_cronoptions * | getCronOptions () const
Returns an instance of the class representing the Cron section.
const ms_databases * | getDatabases () const
Returns an instance of the class representing the Databases section.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a path to the file that was set explicitly or the default file name.
int | getFindFileTimeout () const
Returns current time out value in seconds for open file operation.
std::string | getHeaderComments () const
Returns comment lines at the start of mascot.dat.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
const ms_libraryoptions * | getLibraryOptions () const
Returns an instance of the class representing the LibraryOptions section.
const ms_mascotfiles * | getMascotFiles () const
Returns an instance of the class containing location of other configuration files.
const ms_mascotoptions * | getMascotOptions () const
Returns an instance of the class representing the Options section.
int | getMaxTaxonomyRules () const
Returns a maximum possible Taxonomy section number that can be used to retrieve/set the section content.
const ms_parseoptions * | getParseOptions () const
Returns an instance of the class representing the PARSE section.
const ms_processoroptions * | getProcessors () const
Returns an instance of the class representing the Processors section.
const ms_taxonomyrules * | getTaxonomyRules (const int idx) const
Returns an instance of the class representing one of the Taxonomy_XXX sections.
const ms_unigeneoptions * | getUniGeneOptions () const
Returns an instance of the class representing the UniGene section.
const ms_wwwoptions * | getWWWOptions () const
Returns an instance of the class representing the WWW section.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_datfile & | operator= (const ms_datfile &right)
C++ style assignment operator.
void | read_file ()
Call this method in order to read the configuration information from the file.
void | save_file ()
Saves the content in the file.
void | setClusterParams (const ms_clusterparams *params)
Update the content of the Cluster section.
void | setConnectionSettings (const matrix_science::ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setCronOptions (const ms_cronoptions *options)
Update the content of the Cron section.
void | setDatabases (const ms_databases *dbs)
Update the content of the Databases section.
void | setFileName (const char *name)
Set the file name explicitly, before saving or loading.
void | setFindFileTimeout (const int seconds)
Sets the time out for local file search.
void | setHeaderComments (const std::string headerComments)
Sets comment lines at the start of mascot.dat.
void | setLibraryOptions (const ms_libraryoptions *spectralLibraryOptions)
Update the content of the LibraryOptions section.
void | setMascotFiles (const ms_mascotfiles *src)
Update the location of other configuration files.
void | setMascotOptions (const ms_mascotoptions *opt)
Update the content of the Options section.
void | setParseOptions (const ms_parseoptions *rules)
Update the content of the PARSE section.
void | setProcessors (const ms_processoroptions *info)
Update the content of the Processors section.
void | setTaxonomyRules (const int idx, const ms_taxonomyrules *rules)
Update or create an existing the Taxonomy_XXX section.
void | setUniGeneOptions (const ms_unigeneoptions *uoptions)
Update the content of the UniGene section.
void | setWWWOptions (const ms_wwwoptions *www)
Update the content of the WWW section.
bool | updateForInstaller (ms_errs &log, const char *not_mascot_dat_path, const char *mascot_dat_path, const char *licenseFilePath, const char *pathToMascot, const char *mascotURL, const char *sequenceDatabases, const bool clusterEnable, const WST wst, const char *NTGuestName, const char *NTAdminName, const unsigned int flags)
Creates and updates mascot.dat for the Mascot Installation programs.

Detailed Description

Encapsulates the mascot.dat file that contains the most important parameters.

The file is divided into several sections. Each section has corresponding accessor methods (getXXX/setXXX).

The path to mascot.dat can be specified explicitly. However, several default locations will be tried if the object is used without setting a file name. Before obtaining any section content check the object for any errors that might occur using isValid() method.

Examples
common_error.cpp, config_mascotdat.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

◆ INST_FLAGS

enum INST_FLAGS

Flags for the updateForInstaller() function.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
IFLG_UPDATETAXONOMY | Inserts missing taxonomy sections.
IFLG_UPDATEPARSERULES | Inserts missing parse rules.
IFLG_UPDATESWISSPROT | Add an entry for SwissProt if it doesn't exist, or update it if parse rules are wrong.
IFLG_UPDATECLUSTER | Update the cluster section.
IFLG_UPDATEESTTAX | Update EST_human, EST_mouse if very old taxonomy.
IFLG_ADDMISSINGOPTIONS | Add entries missing options from the default values in not.mascot.dat.
IFLG_ADDREPORTAUTO | Add AUTO to the list in ReportNumberChoices if it isn't already present.
IFLG_UPDATEAPACHEFORKOPT | Update ForkForUnixApache using the value specified by the wst parameter. From Parser 2.5.2 onwards, under Windows, the value in wst is ignored and it is assumed to be WST_IIS.
IFLG_ADDPERCOLATOROPT | Add -U to the flags in PercolatorExeFlags if it doesn't already exist.
IFLG_UPDATENCBIHTTPS | Change TaxBrowserUrl http://www.ncbi... to TaxBrowserUrl https://www.ncbi...
IFLG_UPDATEPRIDECONTAMINANTS | Add an entry for PRIDE_Contaminants if it doesn't exist, or update it if parse rules are wrong.
IFLG_UPDATEDBMANAGERPERLPATH | If the path to perl for the dbman_process_tasks.pl script in the cron section is missing, or wrong, then insert ot replace.
IFLG_UPDATEMSPEPSEARCHOPTS | If the LibrarySearch line in the Options section of mascot.dat contains ' m G ' then change this to ' m a P '. Also, if it contains " /HITS 100 " change this to " /HITS 10 ".
IFLG_UPDATEEXECAFTERSEARCH | Update ExecAfterSearch_* lines and remove ms-createpip.exe from it.
IFLG_UPDATEPERCOLATORFEATS | Update Percolator features set.
IFLG_UPDATEPROTFAMILYSWITCH | Update ProteinFamilySwitch.
IFLG_UPDATEPERCOLATORUSERT | Update PercolatorUseRT.
IFLG_UPDATESPLITNUMOFQUERIES | Update SplitNumberOfQueries.
IFLG_UPDATESPLITDATAFILESIZE | Update SplitDataFileSize.
IFLG_DEFAULTNEWINSTALL | Default flags for a new installation. Just the IFLG_UPDATECLUSTER and IFLG_UPDATEAPACHEFORKOPT flag.
IFLG_DEFAULTUPGRADE | Default flags for an upgrade. All flags except IFLG_UPDATECLUSTER, IFLG_UPDATESWISSPROT and IFLG_UPDATEPRIDECONTAMINANTS.

◆ SEQDB_INSTALL

enum SEQDB_INSTALL

Flags for checkSeqDBInstallRequest().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

These values may be bitwise 'ORd' together.

Enumerator
SEQDB_INSTALL_SHOULD_QUERY_USER | Bitwise 'and' the return value from checkSeqDBInstallRequest() with this value to determine if an update of the fasta files may be unwise.
SEQDB_INSTALL_CUSTOMISED | User has an unrecognised configuration, possibly with a customised SwissProt, so installing an update may be unwise.
SEQDB_INSTALL_INACTIVE | User has an existing configuration, but it is disabled.
SEQDB_INSTALL_INVALID_CONFIG | User has an invalid configuration. For example, missing parse rules or specifying to use accession from the fasta and ID from the .dat.
SEQDB_INSTALL_EXISTING_LARGER | User has an existing fasta file larger (and presumably later) than the one on the installer CD.
SEQDB_INSTALL_INVALID_DBNAME | An unsupported dbName was passed to the function.
SEQDB_INSTALL_MUST_UPDATE_CFG | The configuration must be updated if the newer fasta files are to be installed.
SEQDB_INSTALL_MISSING_CONFIG | There is no configuration for the database. Installing should not give any conflict.
SEQDB_INSTALL_OLD_RULES | For example, the rules for SwissProt are for version 51 to version 55.
SEQDB_INSTALL_WRONG_WILDCARD | For example, could be Sprot_*.fasta rather than SwissProt_*.fasta.
SEQDB_INSTALL_CURRENT_RULES | Currently set if the rules for SwissProt are for version 56 to version ...

◆ WST

enum WST

Web server type for the updateForInstaller() function.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
WST_APACHE | Apache. From Parser 2.5.2 onwards, under Windows, this value is ignored when setting ForkForUnixApache and it is assumed to be WST_IIS.
WST_IIS | Microsoft IIS (Internet Information Services)

Constructor & Destructor Documentation

◆ ms_datfile() [1/3]

ms_datfile ( )

Default constructor.

The default constructor can be used to create a new ms_datfile programmatically.

◆ ms_datfile() [2/3]

ms_datfile ( const ms_datfile & src )

Copying constructor.

Note
Do not use this constructor in programming languages other than C++.

Create a new copy of the object from an existing one.

Parameters
src is the datfile to copy from.

◆ ms_datfile() [3/3]

ms_datfile | ( | const char * | filename,
 |  | const int | timeoutSec = 0,
 |  | const matrix_science::ms_connection_settings * | cs = 0
 | ) |  |

Immediate action constructor.

Parameters
filename | The file name parameter can be either a local file path or a Mascot server URL. It cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi.
timeoutSec | timeout for open operation. For more information, see setFindFileTimeout().
cs | is a pointer to the connection settings. This should contain a sessionID and optionally the proxy server settings.

◆ ~ms_datfile()

~ms_datfile ( )

Destructor.

Releases all memory. Called automatically from all supported languages.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ checkSeqDBInstallRequest()

unsigned int checkSeqDBInstallRequest | ( | const std::string & | dbName,
 |  | const double | newFastaSize
 | ) |  | const

Utility function for the installation program.

This function is called by an installer to determine whether it is 'safe' to update a particular database. The return value is an integer that comprises one or more flags, bitwise ANDed together.

After calling this function, any errors can be found by calling isValid() and getLastErrorString().

The return value should be OR'd with ms_datfile::SEQDB_INSTALL_SHOULD_QUERY_USER to determine whether to ask the end user to confirm that they wish to continue with the installation/update of the specified database.

Parameters
dbName | Currently only "SwissProt" and "PRIDE_Contaminants" are supported. Passing any other string will result in ms_datfile::SEQDB_INSTALL_INVALID_DBNAME being returned.
newFastaSize | is the size in bytes of the new fasta file. This is passed as a double because there is no guarantee of 64 bit integer support in Perl.
Returns
One or more ms_datfile::SEQDB_INSTALL values, ORd together.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_datfile * right )

Use this member to make a copy of another instance.

C++: use the copy constructor instead.

Parameters
right is the object to copy from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ defaultValues()

void defaultValues ( )

Can be used for initialising an instance with default values.

All existing settings, apart from the filename, are lost.

◆ editedByDatabaseManager()

bool editedByDatabaseManager ( ) const

This function returns true if Database Manager has edited the mascot.dat file.

If Database Manager is being used, then most sections of the file should not be edited in a text editor or by using this Mascot Parser class. See comments at the top of the mascot.dat file for further information.

Returns
true if the line
#  WARNING: Do not edit this file to make changes to        #
is found near the top of the file

◆ getClusterParams()

const ms_clusterparams * getClusterParams ( ) const

Returns an instance of the class representing the Cluster section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setClusterParams().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns
a const pointer to the ms_clusterparams object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples
config_mascotdat.cpp.

◆ getCronOptions()

const ms_cronoptions * getCronOptions ( ) const

Returns an instance of the class representing the Cron section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setCronOptions().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns
a const pointer to the ms_cronoptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples
config_mascotdat.cpp.

◆ getDatabases()

const ms_databases * getDatabases ( ) const

Returns an instance of the class representing the Databases section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setDatabases().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns
a const pointer to the ms_databases object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples
config_mascotdat.cpp.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFileName()

std::string getFileName ( ) const

Returns a path to the file that was set explicitly or the default file name.

The filename should include the complete or relative path, or it can be a URL to a Mascot server.

Returns
the current filename for mascot.dat.

◆ getFindFileTimeout()

int getFindFileTimeout ( ) const

Returns current time out value in seconds for open file operation.

This may be useful for the file that is being periodically updated or downloaded by another application. During file-copying operations the file might be inacessible. The library will still try to open it during the specified period of time.

By default, the timeout is set to zero meaning no further attempts are made to find and open the file.

Returns
Time in seconds.

◆ getHeaderComments()

std::string getHeaderComments ( ) const

Returns comment lines at the start of mascot.dat.

Multiple lines are separated by \n

The first section in the mascot.dat file is the Databases section and this must exist.

Comments before sections other than the databases section can be returned using ms_customproperty::getPreceedingComments(). The ms_databases class inherits from ms_customproperty, but due to historical reasons the comments preceding it are stored separately.

Returns
the comment lines at the start of mascot.dat

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getLibraryOptions()

const ms_libraryoptions * getLibraryOptions ( ) const

Returns an instance of the class representing the LibraryOptions section.

Returns
an instance of the class representing the LibraryOptions section.

◆ getMascotFiles()

const ms_mascotfiles * getMascotFiles ( ) const

Returns an instance of the class containing location of other configuration files.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setMascotFiles().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns
a const pointer to the ms_mascotfiles object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.

◆ getMascotOptions()

const ms_mascotoptions * getMascotOptions ( ) const

Returns an instance of the class representing the Options section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setMascotOptions().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns
a const pointer to the ms_mascotoptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples
config_mascotdat.cpp.

◆ getMaxTaxonomyRules()

int getMaxTaxonomyRules ( ) const

Returns a maximum possible Taxonomy section number that can be used to retrieve/set the section content.

There are multiple taxonomy rules sections in mascot.dat: Taxonomy_1, Taxonomy_2, etc. This value is the maximum number that can be used for a taxonomy section.

See also
getTaxonomyRules(), setTaxonomyRules()
Returns
The maximum value for a taxonomy section in mascot.dat.
Examples
config_mascotdat.cpp.

◆ getParseOptions()

const ms_parseoptions * getParseOptions ( ) const

Returns an instance of the class representing the PARSE section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setParseOptions().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns
a const pointer to the ms_parseoptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples
config_mascotdat.cpp.

◆ getProcessors()

const ms_processoroptions * getProcessors ( ) const

Returns an instance of the class representing the Processors section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setProcessors().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns
a const pointer to the ms_processoroptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples
config_mascotdat.cpp.

◆ getTaxonomyRules()

const ms_taxonomyrules * getTaxonomyRules ( const int idx ) const

Returns an instance of the class representing one of the Taxonomy_XXX sections.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setTaxonomyRules().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Taxonomy rules sections can be listed in mascot.dat in a random order and with gaps between numbers. Therefore, it is essential that the return value is checked to be not null before accessing its properties. A NULL value indicates 'no such taxonomy section'.

Parameters
idx is the ID of the taxonomy rules section. There are multiple taxonomy rules sections mascot.dat: Taxonomy_1, Taxonomy_2 etc. The value should be in the range 1 to getMaxTaxonomyRules().
Returns
a const pointer to the ms_taxonomyrules object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples
config_mascotdat.cpp.

◆ getUniGeneOptions()

const ms_unigeneoptions * getUniGeneOptions ( ) const

Returns an instance of the class representing the UniGene section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setUniGeneOptions().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns
a const pointer to the ms_unigeneoptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.

◆ getWWWOptions()

const ms_wwwoptions * getWWWOptions ( ) const

Returns an instance of the class representing the WWW section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setWWWOptions().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns
a const pointer to the ms_wwwoptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples
config_mascotdat.cpp.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_datfile & operator= ( const ms_datfile & right )

C++ style assignment operator.

Note
This operator can only be used in C++.
Parameters
right is the object to copy from.
Returns
a reference to 'this'.

◆ read_file()

void read_file ( )

Call this method in order to read the configuration information from the file.

It shouldn't normally be necessary to call this function as it will be called automatically from the constructor. See ms_datfile::ms_datfile for further information.

Examples
common_error.cpp.

◆ save_file()

void save_file ( )

Saves the content in the file.

Saves the file using the current filename. Can only be saved as a local file.

◆ setClusterParams()

void setClusterParams ( const ms_clusterparams * params )

Update the content of the Cluster section.

The ms_datfile object is updated with a copy of the data passed.

See also
getClusterParams()
Parameters
params is a pointer to the new ms_clusterparams.

◆ setConnectionSettings()

void setConnectionSettings ( const matrix_science::ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters
cs is the new connection settings.

◆ setCronOptions()

void setCronOptions ( const ms_cronoptions * options )

Update the content of the Cron section.

The ms_datfile object is updated with a copy of the data passed.

See also
getCronOptions()
Parameters
options is a pointer to the new ms_cronoptions.

◆ setDatabases()

void setDatabases ( const ms_databases * dbs )

Update the content of the Databases section.

The ms_datfile object is updated with a copy of the data passed.

See also
getDatabases()
Parameters
dbs is a pointer to the new ms_databases.

◆ setFileName()

void setFileName ( const char * name )

Set the file name explicitly, before saving or loading.

The filename should include the complete or relative path, or it can be a URL to a Mascot server.

Parameters
name is the new filename for mascot.dat.
Examples
common_error.cpp.

◆ setFindFileTimeout()

void setFindFileTimeout ( const int seconds )

Sets the time out for local file search.

This may be useful for the file that is being periodically updated or downloaded by another application. During file-copying operations the file might be inacessible. The library will still try to open it during the specified period of time.

By default, the timeout is set to zero meaning no further attempts are made to find and open the file.

Parameters
seconds is the time in seconds.

◆ setHeaderComments()

void setHeaderComments ( const std::string headerComments )

Sets comment lines at the start of mascot.dat.

Multiple lines are separated by \n

The first section in the mascot.dat file is the Databases section and this must exist.

Comments before sections other than the databases section can be set using ms_customproperty::setPreceedingComments(). The ms_databases class inherits from ms_customproperty, but due to historical reasons the comments preceding it are stored separately.

Parameters
headerComments are new comments to replace the old ones.

◆ setLibraryOptions()

void setLibraryOptions ( const ms_libraryoptions * spectralLibraryOptions )

Update the content of the LibraryOptions section.

call ms_datfile::save_file() after calling this function.

Parameters
spectralLibraryOptions is the new LibraryOptions section.

◆ setMascotFiles()

void setMascotFiles ( const ms_mascotfiles * src )

Update the location of other configuration files.

The ms_datfile object is updated with a copy of the data passed.

See also
getMascotFiles()
Parameters
src is a pointer to the new ms_mascotfiles.

◆ setMascotOptions()

void setMascotOptions ( const ms_mascotoptions * opt )

Update the content of the Options section.

The ms_datfile object is updated with a copy of the data passed.

See also
getMascotOptions()
Parameters
opt is a pointer to the new ms_mascotoptions.

◆ setParseOptions()

void setParseOptions ( const ms_parseoptions * rules )

Update the content of the PARSE section.

The ms_datfile object is updated with a copy of the data passed.

See also
getParseOptions()
Parameters
rules is a pointer to the new ms_parseoptions.

◆ setProcessors()

void setProcessors ( const ms_processoroptions * info )

Update the content of the Processors section.

The ms_datfile object is updated with a copy of the data passed.

See also
getProcessors()
Parameters
info is a pointer to the new ms_processoroptions.

◆ setTaxonomyRules()

void setTaxonomyRules | ( | const int | idx,
 |  | const ms_taxonomyrules * | rules
 | ) |  |

Update or create an existing the Taxonomy_XXX section.

The ms_datfile object is updated with a copy of the data passed.

See also
getTaxonomyRules()
Parameters
idx | is the ID of the taxonomy rules section. There are multiple taxonomy rules sections in mascot.dat: Taxonomy_1, Taxonomy_2 etc. The value should be in the range 1 to getMaxTaxonomyRules().
rules | is a pointer to the new ms_taxonomyrules. In order to erase an existing section submit NULL as this parameter.

◆ setUniGeneOptions()

void setUniGeneOptions ( const ms_unigeneoptions * uoptions )

Update the content of the UniGene section.

The ms_datfile object is updated with a copy of the data passed.

See also
getUniGeneOptions()
Parameters
uoptions is a pointer to the new ms_unigeneoptions.

◆ setWWWOptions()

void setWWWOptions ( const ms_wwwoptions * www )

Update the content of the WWW section.

The ms_datfile object is updated with a copy of the data passed.

See also
getWWWOptions()
Parameters
www is a pointer to the new ms_wwwoptions.

◆ updateForInstaller()

bool updateForInstaller | ( | ms_errs & | log,
 |  | const char * | not_mascot_dat_path,
 |  | const char * | mascot_dat_path,
 |  | const char * | licenseFilePath,
 |  | const char * | pathToMascot,
 |  | const char * | mascotURL,
 |  | const char * | sequenceDatabasePath,
 |  | const bool | clusterEnable,
 |  | const WST | wst,
 |  | const char * | NTGuestName,
 |  | const char * | NTAdminName,
 |  | const unsigned int | flags
 | ) |  |

Creates and updates mascot.dat for the Mascot Installation programs.

To use, first create a new ms_datfile using the default constructor. Then, create an ms_errs object and call ms_errs::setLoggingLevel() to set the severity level to ms_errs::sev_info. After calling updateForInstaller(), call isValid() on the passed ms_errs object, to check for any errors. If there are no errors, then call setFileName() followed by save_file(). Finally, call the isValid() function (on this object) to check that the file has been saved without error.

For a new installation, the passed mascot_dat_path must be null/empty.

The following actions are performed for both installation and upgrades:

  • The not.mascot.dat file is read.
  • In the options section, NTIUserGroup is changed to the passed value. If null or an empty string is passed, then the setting is not changed.
  • In the options section, NTIMonitorGroup is changed to the passed value. If null or an empty string is passed, then the setting is not changed.
  • In the databases section, ###ROOT###/sequence is replaced with the value passed in sequenceDatabasePath.
  • Other occurrences of ###ROOT### are replaced with pathToMascot.
  • ###HOSTNAME### is replaced with the computer hostname.
  • ###URL### is replaced with mascotURL.

The following actions are performed for a new install:

  • The contents of not.mascot.dat are copied to this instance of ms_datfile.
  • The number of threads for each database is replaced with the value: ms_databaseoptions::NUM_THREADS_AUTO_DETECT.

The following actions are performed for an upgrade:

  • The contents of mascot.dat are loaded into this instance of ms_datfile.

The following actions are performed depending on the passed flags:

  • ms_datfile::IFLG_UPDATETAXONOMY: Any missing taxonomy sections are added.
  • ms_datfile::IFLG_UPDATEPARSERULES: Any missing parse rules are added. For example, if there is no RULE_32 in mascot.dat, but there is a RULE_32 in not.mascot.dat, then RULE_32 is added. From version 2.5.1 onwards, this flag is ignored if the file has been editedByDatabaseManager() because database manager will add extra parse rules when required and it gets upset if the parse rules in the mascot.dat file aren't the same as those in its 'source' xml file.
  • ms_datfile::IFLG_UPDATECLUSTER: The clusterEnable flag is used to enable or disable cluster mode.
    • If there are no SubClusterSet lines, then a single SubClusterSet 0 line is added with the number of processors set to: ms_clusterparams::NUM_PROCESSORS_AUTO_DETECT.
    • If the DefaultNodeOS value is not correct, then this is set correctly and the DefaultNodeHomeDir is set to either "C:/MascotNode" or "/usr/local/mascotnode"
    • For Windows, if DefaultNodeHomeDirFromMaster is commented, then it is uncommented.
    • For Windows, if MascotNodeScript is uncommented, then it is commented.
    • For Linux, if DefaultNodeHomeDirFromMaster is uncommented, then it is commented.
    • For Linux, if MascotNodeScript is commented, then it is uncommented.
  • ms_datfile::IFLG_UPDATESWISSPROT: The following actions are only performed if the return value of checkSeqDBInstallRequest() has the ms_datfile::SEQDB_INSTALL_MUST_UPDATE_CFG bits set.
    • The three parse rules required for SwissProt are added if necessary. This may require that new rules are added with different numbers.
    • If there is no entry for the SwissProt database, then add the relevant lines from not.mascot.dat, changing ###ROOT###/sequence with the value passed in sequenceDatabasePath, and possibly changing the rule numbers as appropriate.
    • The wildcard part of the path is set to SwissProt_*.fasta.
  • ms_datfile::IFLG_UPDATEPRIDECONTAMINANTS: The following actions are only performed if the return value of checkSeqDBInstallRequest() has the ms_datfile::SEQDB_INSTALL_MUST_UPDATE_CFG bits set.
    • The three parse rules required for PRIDE_Contaminants are added if necessary. This may require that new rules are added with different numbers.
    • If there is no entry for the PRIDE_Contaminants database, then add the relevant lines from not.mascot.dat, changing ###ROOT###/sequence with the value passed in sequenceDatabasePath, and possibly changing the rule numbers as appropriate.
    • The wildcard part of the path is set to PRIDE_Contaminants_*.msp.
  • ms_datfile::IFLG_UPDATEESTTAX: If the EST_human database has taxonomy rule 0, and a Taxonomy_10 section was added, then change the rule to Taxonomy_10.
  • ms_datfile::IFLG_UPDATEESTTAX: If the EST_mouse database has taxonomy rule 0, and a Taxonomy_11 section was added, then change the rule to Taxonomy_11.
  • ms_datfile::IFLG_ADDMISSINGOPTIONS: Add entries missing in the options section from the default values in not.mascot.dat.
  • ms_datfile::IFLG_ADDMISSINGOPTIONS: If an upgrade, the config/db_manager/global.conf file is read if it exists, and proxy settings copied over. If mascot.dat already contains proxy settings, the global.conf file is ignored.
  • ms_datfile::IFLG_ADDREPORTAUTO: If there is no AUTO in ReportNumberChoices, then this is added.
  • ms_datfile::IFLG_ADDPERCOLATOROPT: If there is no -U in PercolatorExeFlags, then this is added.
  • ms_datfile::IFLG_UPDATENCBIHTTPS:
    • If the TaxBrowserUrl setting in Options starts with http://www.ncbi.nlm.nih.gov/ then change this to https://...
    • In the www section, look for any cases where ms_wwwentry::getHostName() contains "eutils.ncbi.nlm". If ms_wwwentry::getPortNumber() returns 80 then call ms_wwwentry::setPortNumber(443). However, this will only be done if the file has not been editedByDatabaseManager()
  • ms_datfile::IFLG_UPDATEMSPEPSEARCHOPTS:
    • If LibrarySearch contains " m G " (the 2.6 option) then replace this with " m a P ". See ms_mascotoptions::getPepSearchTool for further details.
    • If LibrarySearch contains " /HITS 100 " (the 2.6 option) then replace this with " /HITS 10 ".

Possible error messages:

  • Any read/parse errors for mascot.dat or not.mascot.dat will be reported.
  • ms_errs::ERR_MSP_INST_FAILADDPARSERULE will be reported if all 255 available parse rules have been used, and the rules required for SwissProt cannot be added.

All other issues are treated as warnings.

Parameters
log | is used to collect errors and information messages.
not_mascot_dat_path | The file must exist or an error will be reported.
mascot_dat_path | may be null (or an empty string) for a clean installation where there is no existing mascot.dat If specified, the file must exist.
licenseFilePath | not used in Parser version 2.4.1 and later. The number of threads to use for each database is set to an 'auto' value in Mascot 2.4 and later.
pathToMascot | is used for when mascot_dat_path is null, and is used to replace ###ROOT###. Any backslashes will be replaced with forward slashes. The caller is responsible for ensuring that the string doesn't contain any spaces.
mascotURL | is used to replace ###URL###. It doesn't matter if the URL ends with a '/' or not. This parameter is also used to explicitly update ResultsFullURL to mascotURL/cgi/master_results.pl unless a null pointer or an empty string is passed. It is not used to update ResultsFullURL_2 because this may have been manually set to master_results.pl because a user does not like the family reports.
sequenceDatabasePath | is used to replace ###ROOT###/sequence. Any backslashes will be replaced with forward slashes. The caller is responsible for ensuring that the string doesn't contain any spaces.
clusterEnable | should be set to true to enable cluster mode. If IFLG_UPDATECLUSTER is not set, this flag is ignored.
wst | Should be set to WST_APACHE or WST_IIS.
NTGuestName | Should be set to the guest group name (Windows only). Should only be passed for a new installation.
NTAdminName | Should be set to Administrators group name (Windows only). Should only be passed for a new installation.
flags | Specifies which actions to take. See ms_datfile::INST_FLAGS for further information. Most common values to use are ms_datfile::IFLG_DEFAULTNEWINSTALL or ms_datfile::IFLG_DEFAULTUPGRADE.
Returns
false if the hostname is missing, or if not.mascot.dat or the result file is not valid, true otherwise
The documentation for this class was generated from the following files:
  • ms_datfile.hpp
  • ms_datfile.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_dbprocessors Class Reference

  • matrix_science
  • ms_dbprocessors
Public Member Functions | List of all members
ms_dbprocessors Class Reference
Mascot configuration files module

Represent a single dabatase entry in the Processors section. More...

#include <ms_processoroptions.hpp>

Public Member Functions

ms_dbprocessors ()
Default constructor.
ms_dbprocessors (const ms_dbprocessors &src)
Copying constructor.
~ms_dbprocessors ()
Destructor.
void | appendThreadProcessorID (const int proccessorID)
Adds a new thread with a processor ID to the list.
void | clearThreads ()
Deletes all threads (processor IDs) from the entry.
void | copyFrom (const ms_dbprocessors *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
std::string | getName () const
Return database name for the entry.
int | getNumberOfThreads () const
Returns a number of values (threads/processor IDs) specified for the database.
int | getThreadProcessorID (const int threadIndex) const
Returns a single processor ID by its index from 0 to (getNumberOfThreads()-1).
ms_dbprocessors & | operator= (const ms_dbprocessors &right)
Assinment operator for C++ client applications.
void | setName (const char *str)
Change the database name of the entry.

Detailed Description

Represent a single dabatase entry in the Processors section.

The documentation for this class was generated from the following files:
  • ms_processoroptions.hpp
  • ms_processoroptions.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_enzyme Class Reference

  • matrix_science
  • ms_enzyme
Public Types | Public Member Functions | List of all members
ms_enzyme Class Reference
Mascot configuration files module

Represent a single entry in the enzymes file. More...

#include <ms_enzyme.hpp>

Inheritance diagram for ms_enzyme:
[legend]
Collaboration diagram for ms_enzyme:
[legend]

Public Types

enum cuttertype {
UNDEFINED_CUTTER = 0x0000 ,
NTERM_CUTTER = 0x0001 ,
CTERM_CUTTER = 0x0002
}
Definitions for types of cutter. More...

Public Member Functions

ms_enzyme ()
Default constructor.
ms_enzyme (const ms_enzyme &src)
Copying constructor.
~ms_enzyme ()
Destructor.
void | addCutter (const cuttertype type, const char *cleaveAtStr, const char *restrictStr)
Adds an cutter to the enzyme.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
bool | canCleave (const int cutterNum, const char leftResidue, const char rightResidue) const
Returns TRUE if the cutter can cut between the two residues.
void | clearAllCutters ()
Deletes all cutters from the list.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_enzyme *right)
Can be used to create a clone.
void | defaultValues ()
Use this member to re-initialise an instance to default values.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getCleave (const int cutterNum) const
Returns the list of cleavage points for a cutter.
ms_enzyme::cuttertype | getCutterType (const int cutterNum) const
Return the number of cutters that make up the enzyme definition.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
int | getNumberOfCutters () const
Returns the number of cutters.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
std::string | getRestrict (const int cutterNum) const
Returns the list of restriction points for a cutter.
std::string | getTitle () const
Returns a name of the enzyme as appears in the file.
bool | isIndependent () const
Check whether multiple enzymes have been applied independently.
bool | isSemiSpecific () const
Returns TRUE if the enzyme is semi-specific.
bool | isValid () const
Use this method to do basic check on a newly created object.
ms_enzyme & | operator= (const ms_enzyme &right)
C++ style operator= for copying.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setIndependent (const bool bit)
Sets the flag that specifies whether multiple enzymes have been applied independently.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setSemiSpecific (const bool value)
Sets a new value for the semi specific flag.
void | setTitle (const char *str)
Sets a new title for the enzyme.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.
bool | verifyEnzyme (ms_errs *errObj) const
Tries to detect any inconsistencies in the enzyme definition.

Detailed Description

Represent a single entry in the enzymes file.

An instance of this class is normally be created by calling matrix_science::ms_enzymefile::getEnzymeByNumber() or matrix_science::ms_enzymefile::getEnzymeByName() and should then only be used in 'read-only' mode.

As well as 'simple' enzymes, the following cases are supported:

  • semi-specific enzymes (isSemiSpecific())
  • mixed cutters (C-term and N-term)
  • independent cutters (isIndependent())

In case of independent enzymes an instance contains several enzyme definitions that can be iterated through. Otherwise several enzymes with mixed-term cutting are combined together.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples
config_enzymes.cpp, and tools_aahelper.cpp.

Member Enumeration Documentation

◆ cuttertype

enum cuttertype

Definitions for types of cutter.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
UNDEFINED_CUTTER | Undefined - normally due to an invalid parameter when calling a function.
NTERM_CUTTER | N Terminus cutter - cuts before the specified residue(s).
CTERM_CUTTER | C Terminus cutter - cuts after the specified residue(s).

Constructor & Destructor Documentation

◆ ms_enzyme() [1/2]

ms_enzyme ( )

Default constructor.

An enzyme object should normally be created using matrix_science::ms_enzymefile::getEnzymeByNumber() or matrix_science::ms_enzymefile::getEnzymeByName().

◆ ms_enzyme() [2/2]

ms_enzyme ( const ms_enzyme & src )

Copying constructor.

Note
You cannot use this constructor in programming languages other than C++.
Parameters
src is the enzyme to make a copy of.

◆ ~ms_enzyme()

~ms_enzyme ( )

Destructor.

Called automatically from C++ and other languages.

Member Function Documentation

◆ addCutter()

void addCutter | ( | const cuttertype | type,
 |  | const char * | cleaveAtStr,
 |  | const char * | restrictStr
 | ) |  |

Adds an cutter to the enzyme.

This function doesn't perform any checks for valid residues etc, so the verifyEnzyme() function should be called after adding a cutter.

Parameters
type | is either ms_enzyme::NTERM_CUTTER or ms_enzyme::CTERM_CUTTER.
cleaveAtStr | One or more residue letters which are the potential cleavage points.
restrictStr | Zero or more residue letters that are restriction points.

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ canCleave()

bool canCleave | ( | const int | cutterNum,
 |  | const char | leftResidue,
 |  | const char | rightResidue
 | ) |  | const

Returns TRUE if the cutter can cut between the two residues.

Gives an answer for the question: Will the enzyme cut at the this position or not?

This function doesn't take into account the semi specific flag.

Parameters
cutterNum | must be in the range 0..getNumberOfCutters()-1.
leftResidue | amino acid letter representing a residue before the cutting point.
rightResidue | amino acid letter representing a residue after the cutting point.
Returns
True if the enzyme can cleave at this point.

◆ clearAllCutters()

void clearAllCutters ( )

Deletes all cutters from the list.

Only useful when defining enzymes 'on the fly'.

◆ copyFrom()

void copyFrom ( const ms_enzyme * right )

Can be used to create a clone.

Simply create an instance of the class using the default constructor and call this method.

Parameters
right pointer to another instance to copy from.

◆ defaultValues()

void defaultValues ( )

Use this member to re-initialise an instance to default values.

The default values are no cutters, no title, independent = false and semiSpecific = false.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getCleave()

std::string getCleave ( const int cutterNum ) const

Returns the list of cleavage points for a cutter.

Returns the residues after which an enzyme may cut (for a CTERM_CUTTER) or before which an enzyme may cut (for an NTERM_CUTTER).

See also
getRestrict()
Parameters
cutterNum must be in the range 0..getNumberOfCutters()-1.
Returns
A string of possible cleaveage points.
Examples
config_enzymes.cpp.

◆ getCutterType()

ms_enzyme::cuttertype getCutterType ( const int cutterNum ) const

Return the number of cutters that make up the enzyme definition.

Parameters
cutterNum must be in the range 0..getNumberOfCutters()-1.
Returns
ms_enzyme::NTERM_CUTTER, or ms_enzyme::CTERM_CUTTER or ms_enzyme::UNDEFINED_CUTTER if cutterNum is an invalid value.
Examples
config_enzymes.cpp.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getNumberOfCutters()

int getNumberOfCutters ( ) const

Returns the number of cutters.

For most enzymes, there will be just one cutter. See isIndependent() for details of multiple cutters in an enzyme.

The limit of 5 cutters per enzyme was raised to a limit of 20 cutters per enzyme in Parser 2.3.01.

Returns
The number of cutters.
Examples
config_enzymes.cpp.

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ getRestrict()

std::string getRestrict ( const int cutterNum ) const

Returns the list of restriction points for a cutter.

Returns the residues after which an enzyme may cut (for a CTERM_CUTTER) or before which an enzyme may cut (for an NTERM_CUTTER).

See also
getCleave()
Parameters
cutterNum must be in the range 0..getNumberOfCutters()-1.
Returns
A string of possible cleaveage points.
Examples
config_enzymes.cpp.

◆ isIndependent()

bool isIndependent ( ) const

Check whether multiple enzymes have been applied independently.

In cases where a single enzyme has been used, the 'independent' flag has no meaning and would normally be set to false. Where multiple enzymes are used on a single sample, these can have been applied in two different ways:

  • Independent = true indicates that the specificities should be treated as if independent digests had been performed on separate sample aliquots and the resulting peptide mixtures combined. Thus, any given peptide will conform to the specificity of one cleavage type only. In the case of CNBr+Trypsin, if Independent was true, you would not find any peptides resulting from cleavage after K or R at one end, and cleavage after M at the other.
  • Independent = false indicates that the specificities are combined, as if the reagents had been applied simultaneously or serially to a single sample aliquot.
See also
getNumberOfCutters()
Returns
True if the cutters are applied independently.

◆ isSemiSpecific()

bool isSemiSpecific ( ) const

Returns TRUE if the enzyme is semi-specific.

Enzymes don't function perfectly all the time. In most cases where they fail to cut at the specified cleavage point, this only affects one terminus. In Mascot, when a semi specific enzyme is defined, peptides only need to conform to the cleavage specificity at one end.

All enzymes represented by the entry have to be either semi-specific or not.

Returns
True if the enzyme is semi specific.

◆ isValid()

bool isValid ( ) const

Use this method to do basic check on a newly created object.

This function calls verifyEnzyme() and is merely provided to give a consistently available function interface to the object. To determine the cause of any inconsistencies or errors, call verifyEnzyme() with an error object.

Returns
False if there are any errors in the enzyme definition.

◆ operator=()

ms_enzyme & operator= ( const ms_enzyme & right )

C++ style operator= for copying.

Note
This operator is only available in C++.

Acts identically to copyFrom().

Parameters
right is the enzyme definition to copy from.
Returns
reference to the current object

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setIndependent()

void setIndependent ( const bool bit )

Sets the flag that specifies whether multiple enzymes have been applied independently.

In cases where a single enzyme has been used, the 'independent' flag has no meaning and would normally be set to false. Where multiple enzymes are used on a single sample, these can have been applied in two different ways:

  • Independent = true indicates that the specificities should be treated as if independent digests had been performed on separate sample aliquots and the resulting peptide mixtures combined. Thus, any given peptide will conform to the specificity of one cleavage type only. In the case of CNBr+Trypsin, if Independent was true, you would not find any peptides resulting from cleavage after K or R at one end, and cleavage after M at the other.
  • Independent = false indicates that the specificities are combined, as if the reagents had been applied simultaneously or serially to a single sample aliquot.
See also
getNumberOfCutters()
Parameters
bit is the new value.

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ setSemiSpecific()

void setSemiSpecific ( const bool value )

Sets a new value for the semi specific flag.

C++ If you load an enzyme using matrix_science::ms_enzymefile::getEnzymeByNumber() or matrix_science::ms_enzymefile::getEnzymeByName(), you will not be able to call this member because those functions return a const pointer.

Calling this function will not affect the enzymes file. See ms_enzymefile::updateByNumber() and ms_enzymefile::updateByName().

Enzymes don't function perfectly all the time. In most cases where they fail to cut at the specified cleavage point, this only affects one terminus. In Mascot, when a semi specific enzyme is defined, peptides only need to conform to the cleavage specificity at one end.

All enzymes represented by the entry have to be either semi-specific or not.

Parameters
value is the new flag to specify if the enzyme is semi specific.
Examples
config_enzymes.cpp.

◆ setTitle()

void setTitle ( const char * str )

Sets a new title for the enzyme.

C++: If you load an enzyme using matrix_science::ms_enzymefile::getEnzymeByNumber() or matrix_science::ms_enzymefile::getEnzymeByName(), you will not be able to call this member because those functions return a const pointer.

Calling this will not affect the enzymes file. See ms_enzymefile::updateByNumber() and ms_enzymefile::updateByName().

Parameters
str is the new name for the enzyme.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise

◆ verifyEnzyme()

bool verifyEnzyme ( ms_errs * errObj ) const

Tries to detect any inconsistencies in the enzyme definition.

If errors are found in the enzyme definition, the ms_errs::ERR_MSP_ENZYME_DEFINITION_PROBLEM error will be set, once for each error. Each error message will also include one of following additional text strings.

The reason or method required to 'fix' the error are the following:

  • "empty title" - Need to call setTitle().
  • "no cutting rules" - Need to call addCutter() at least once.
  • "more restrict than cleave rules for C-term" - probably an internal parser error.
  • "more restrict than cleave rules for N-term" - probably an internal parser error.
  • "no cleavage residues for a cutter" - addCutter() has been called with an empty or invalid cleaveAtStr().
  • "too many cleavage residues specified" - all residues have been specified for cleaving at.
  • "too many restricting residues specified" - all residues have been specified as restriction, meaning that the enzyme won't cut anywhere.
  • "cleavage residues must be uppercase A-Z" - a lower case letter or a non alphabetic character has been specified.
  • "restrict residues must be uppercase A-Z" - a lower case letter or a non alphabetic character has been specified.
Parameters
errObj passed error-object to store error messages.
Returns
true if the enzyme definition is valid.
The documentation for this class was generated from the following files:
  • ms_enzyme.hpp
  • ms_enzyme.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_enzymefile Class Reference

  • matrix_science
  • ms_enzymefile
Public Member Functions | List of all members
ms_enzymefile Class Reference
Mascot configuration files module

Reads and parses the enzymes file that contains multiple enzyme definitions. More...

#include <ms_enzyme.hpp>

Inheritance diagram for ms_enzymefile:
[legend]
Collaboration diagram for ms_enzymefile:
[legend]

Public Member Functions

ms_enzymefile ()
Default constructor.
ms_enzymefile (const char *filename, const matrix_science::ms_connection_settings *cs=0)
This constructor may be used in order to read the given file immediately on construction.
ms_enzymefile (const ms_enzymefile &src)
Copying constructor.
~ms_enzymefile ()
Destructor.
void | appendEnzyme (const ms_enzyme *item)
Adds a copy of given enzyme at the end of the list.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearEnzymes ()
Deletes all enzymes from the list.
void | copyFrom (const ms_enzymefile *right)
Call this member to copy all the information from another instance.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | defaultValues ()
Use this member to re-initialise the instance.
bool | deleteEnzymeByName (const char *name)
Remove an enzyme from the list in memory.
bool | deleteEnzymeByNumber (const int num)
Remove an enzyme from the list in memory.
matrix_science::ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_enzyme * | getEnzymeByName (const char *name) const
Finds an enzyme with the specified name (case insensitive).
const ms_enzyme * | getEnzymeByNumber (const int num) const
Returns a pointer to an internally stored enzyme.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a file name previously set or a default one used to read the file.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumberOfEnzymes () const
Returns a number of enzymes successfully read from the file.
bool | isNoneFound () const
Returns TRUE if an entry with name "NONE" has been found in the file.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_enzymefile & | operator= (const ms_enzymefile &right)
C++ style assignment operator.
void | read_buffer (const char *buffer)
Reads and parses an in-memory null-terminated buffer instead of a disk file.
void | read_file ()
Reads and parses the file.
void | save_file ()
Stores enzyme definitions in a file.
void | setConnectionSettings (const matrix_science::ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *filename)
Call this member before reading the file if you want to specify a non-default name.
bool | updateEnzymeByName (const char *name, const ms_enzyme enzyme)
Update the information for a specific enzyme.
bool | updateEnzymeByNumber (const int num, const ms_enzyme enzyme)
Update the information for a specific enzyme.

Detailed Description

Reads and parses the enzymes file that contains multiple enzyme definitions.

Proteolytic enzymes and specific chemical cleavage agents are defined in ../config/enzymes .

Usage is simple:

  • Create an instance of this class.
  • Set a file name if needed, otherwise a default name will be used.
  • Call read_file().
  • Check for errors with isValid().
  • Iterate thourgh enzyme list using getNumberOfEnzymes() and getEnzymeByNumber().
  • Alternatively, one can find an enzyme by name (if known) with getEnzymeByName().
Examples
config_enzymes.cpp, and tools_aahelper.cpp.

Constructor & Destructor Documentation

◆ ms_enzymefile() [1/3]

ms_enzymefile ( )

Default constructor.

Creates an empty list of enzymes in memory. A file is not created.

◆ ms_enzymefile() [2/3]

ms_enzymefile ( const ms_enzymefile & src )

Copying constructor.

Note
This constructor can only be used from C++.
Parameters
src is the ms_enzymefile to make a copy of.

◆ ms_enzymefile() [3/3]

ms_enzymefile | ( | const char * | filename,
 |  | const matrix_science::ms_connection_settings * | cs = 0
 | ) |  |

This constructor may be used in order to read the given file immediately on construction.

Equivalent to the following call sequence:

  • default contructor ms_enzymefile();
  • setFileName();
  • setConnectionSettings();
  • read_file().
Parameters
filename | The file name parameter can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
cs | is a an optional pointer to the connection settings. This should contain a sessionID and optionally the proxy server settings.

◆ ~ms_enzymefile()

~ms_enzymefile ( )

Destructor.

Called automatically from C++ and other languages.

Member Function Documentation

◆ appendEnzyme()

void appendEnzyme ( const ms_enzyme * item )

Adds a copy of given enzyme at the end of the list.

Parameters
item is the new item to add to the end of the list of enzymes.

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ clearEnzymes()

void clearEnzymes ( )

Deletes all enzymes from the list.

Similar to calling defaultValues() except that this function doesn't clear all the comments from the file.

◆ copyFrom() [1/2]

void copyFrom ( const ms_enzymefile * right )

Call this member to copy all the information from another instance.

Simply create an instance of the class using the default constructor and call this method.

Parameters
right Pointer to another instance to copy from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ defaultValues()

void defaultValues ( )

Use this member to re-initialise the instance.

Note that this member doesn't clear the file name; that has to be re-set explicitly if needed.

◆ deleteEnzymeByName()

bool deleteEnzymeByName ( const char * name )

Remove an enzyme from the list in memory.

Parameters
name must be a valid enzyme name.
Returns
True if the enyzme name is valid.
Examples
config_enzymes.cpp.

◆ deleteEnzymeByNumber()

bool deleteEnzymeByNumber ( const int num )

Remove an enzyme from the list in memory.

Parameters
num must be in the range 0..getNumberOfEnzymes()-1.
Returns
True if the enyzme number is valid.

◆ getConnectionSettings()

matrix_science::ms_connection_settings getConnectionSettings ( ) const

Returns the sessionID and proxy server for use with an HTTP transfer.

See also the constructor documentation and setConnectionSettings().

Returns
The current connection settings.

◆ getEnzymeByName()

const ms_enzyme * getEnzymeByName ( const char * name ) const

Finds an enzyme with the specified name (case insensitive).

The special entry "NONE" being found also generates NULL as an outcome. For more information on this see isNoneFound().

Parameters
name name of the enzyme to look for
Returns
a pointer to the found one or NULL otherwise. See Maintaining object references: two rules of thumb.

◆ getEnzymeByNumber()

const ms_enzyme * getEnzymeByNumber ( const int num ) const

Returns a pointer to an internally stored enzyme.

Parameters
num Must be in the range 0..getNumberOfEnzymes()-1.
Returns
A pointer to an ms_enzyme object. If num is out of range, then the return value is a null object.
Examples
config_enzymes.cpp.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFileName()

std::string getFileName ( ) const

Returns a file name previously set or a default one used to read the file.

Returns
The filename (if any) as set in a previous call to setFileName() or as specified in the constructor.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getNumberOfEnzymes()

int getNumberOfEnzymes ( ) const

Returns a number of enzymes successfully read from the file.

Returns
The current number of enzymes in the list.
Examples
config_enzymes.cpp.

◆ isNoneFound()

bool isNoneFound ( ) const

Returns TRUE if an entry with name "NONE" has been found in the file.

The standard enzymes files has an entry "None" which is used to specify a no enzyme search. This special entry never represents a real enzyme and therefore all properties of the entry are meaningless. Therefore, calling getEnzymeByName() with "None" as a parameter will always return NULL.

Returns
True if there is an entry for "None" in the file.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_enzymefile & operator= ( const ms_enzymefile & right )

C++ style assignment operator.

Note
This operator can only be used in C++.

Acts identically to copyFrom() member.

Parameters
right is the enzymefile definition to copy from.
Returns
reference to the current object

◆ read_buffer()

void read_buffer ( const char * buffer )

Reads and parses an in-memory null-terminated buffer instead of a disk file.

Check for possible errors after calling this functions with isValid(). In case of any errors it keeps all of the already read entries that can still be accessed in a usual way.

Parameters
buffer a null-terminated string with enzymes definitions.

◆ read_file()

void read_file ( )

Reads and parses the file.

Check for possible errors after calling this functions with isValid(). In case of any errors it keeps all of the already read entries that can still be accessed in a usual way.

◆ save_file()

void save_file ( )

Stores enzyme definitions in a file.

Don't forget to check for errors after this function call. The filename used to save the file is specified by setFileName().

Examples
config_enzymes.cpp.

◆ setConnectionSettings()

void setConnectionSettings ( const matrix_science::ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters
cs is the new connection settings.

◆ setFileName()

void setFileName ( const char * filename )

Call this member before reading the file if you want to specify a non-default name.

Parameters
filename is the name of the file to be saved using save_file() or read using read_file().
Examples
config_enzymes.cpp.

◆ updateEnzymeByName()

bool updateEnzymeByName | ( | const char * | name,
 |  | const ms_enzyme | enzyme
 | ) |  |

Update the information for a specific enzyme.

Parameters
name | title of the enzyme to retrieve.
enzyme | is a pointer to the new definition of the enzyme.
Returns
true if the name can be found, false otherwise

◆ updateEnzymeByNumber()

bool updateEnzymeByNumber | ( | const int | num,
 |  | const ms_enzyme | enzyme
 | ) |  |

Update the information for a specific enzyme.

Parameters
num | must be in the range 0..getNumberOfEnzymes()-1.
enzyme | Is a pointer to the new definition of the enzyme.
Returns
true if num param is in range, false otherwise
Examples
config_enzymes.cpp.
The documentation for this class was generated from the following files:
  • ms_enzyme.hpp
  • ms_enzyme.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fragmentationrules Class Reference

  • matrix_science
  • ms_fragmentationrules
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_fragmentationrules Class Reference
Mascot configuration files module

This class encapsulates a single entry (an instrument) from a fragmentation_rules file. More...

#include <ms_fragmentationrules.hpp>

Inheritance diagram for ms_fragmentationrules:
[legend]
Collaboration diagram for ms_fragmentationrules:
[legend]

Public Types

enum FRAG_SERIES_TYPE {
FRAG_IMMONIUM = 4 ,
FRAG_A_SERIES = 5 ,
FRAG_A_MINUS_NH3 = 6 ,
FRAG_A_MINUS_H2O = 7 ,
FRAG_B_SERIES = 8 ,
FRAG_B_MINUS_NH3 = 9 ,
FRAG_B_MINUS_H2O = 10 ,
FRAG_C_SERIES = 11 ,
FRAG_X_SERIES = 12 ,
FRAG_Y_SERIES = 13 ,
FRAG_Y_MINUS_NH3 = 14 ,
FRAG_Y_MINUS_H2O = 15 ,
FRAG_Z_SERIES = 16 ,
FRAG_INTERNAL_YB = 17 ,
FRAG_INTERNAL_YA = 18 ,
FRAG_Z_PLUS_1 = 21 ,
FRAG_D_SERIES = 22 ,
FRAG_V_SERIES = 23 ,
FRAG_W_SERIES = 24 ,
FRAG_Z_PLUS_2 = 25
}
Definitions for ID-constants for series used. More...

Public Member Functions

ms_fragmentationrules ()
Default constructor is used to create an empty object.
ms_fragmentationrules (const ms_fragmentationrules &src)
Copying constructor.
~ms_fragmentationrules ()
Destructor.
bool | anyNLseriesUsed (const int series) const
Will return true if any 'neutral loss' series is specified for this series.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearSeries ()
Deletes all series usage information.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_fragmentationrules *right)
Copies all information from another instance of the class.
void | defaultValues ()
Initialises the instance with default values.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
double | getMaxInternalMass () const
Returns the maximum mass to be considered for internal fragments.
double | getMinInternalMass () const
Returns the minimum mass to be considered for internal fragments.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
std::string | getTitle () const
Returns the title of the instrument.
bool | isCharged2Plus () const
Returns true if the 'doubly charged 2+' fragmentation rule is specified.
bool | isCharged3Plus () const
Returns true if the 'doubly charged 3+' fragmentation rule is specified.
bool | isSeriesUsed (const int series) const
Returns true if a given series is specified for the instrument.
bool | isSinglyCharged () const
Returns true if the 'singly charged' fragmentation rule is specified.
bool | isValid () const
Use this method to do a basic check on a newly created object.
ms_fragmentationrules & | operator= (const ms_fragmentationrules &right)
Assignment operator.
void | setCharged2Plus (const bool value)
Change the availability the of 'doubly charged 2+' fragmentation rule.
void | setCharged3Plus (const bool value)
Change the availability the of 'doubly charged 3+' fragmentation rule.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setMaxInternalMass (const double mass)
Sets the maximum mass to be considered for internal fragments.
void | setMinInternalMass (const double mass)
Set the minimum mass to be considered for internal fragments.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setSeriesUsed (const int series, const bool val)
Sets availability on a given series.
void | setSinglyCharged (const bool value)
Change the availability of the 'singly charged' fragmentation rule.
void | setTitle (const char *title)
Assigns a new title to the rule.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.
bool | verifyRule (ms_errs *err_, const bool tryToFix)
Tries to detect any inconsistencies in the instrument definition.

Static Public Member Functions

static int | getFirstSerie ()
The lowest series number that can be used.
static int | getFirstSeries ()
The lowest series number that can be used.
static int | getLastSerie ()
The highest series number that can be used.
static int | getLastSeries ()
The highest series number that can be used.
static std::string | getSeriesDescription (const int series)
Returns a description string for a given series.
static std::string | getSeriesName (const int series)
Returns a short series name.
static int | getTotalSeriesOutput ()
Returns the length of the series string output in a Mascot results file.
static bool | isBackboneSeries (const int series)
Returns true if the series is a 'backbone' fragment.
static bool | isNeutralLossSeries (const int series)
Returns true if the series is a 'neutral loss' series.

Detailed Description

This class encapsulates a single entry (an instrument) from a fragmentation_rules file.

Objects of this class are normally created by loading a file using the ms_fragrulesfile class.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples
config_fragrules.cpp.

Member Enumeration Documentation

◆ FRAG_SERIES_TYPE

enum FRAG_SERIES_TYPE

Definitions for ID-constants for series used.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

See http://www.matrixscience.com/help/fragmentation_help.html for details of ions types.

Enumerator
FRAG_IMMONIUM | Immonium ions.
FRAG_A_SERIES | A series ions.
FRAG_A_MINUS_NH3 | Referred to as a* in Mascot reports.
FRAG_A_MINUS_H2O | Referred to as ao in Mascot reports.
FRAG_B_SERIES | B series ions.
FRAG_B_MINUS_NH3 | Referred to as b* in Mascot reports.
FRAG_B_MINUS_H2O | Referred to as bo in Mascot reports.
FRAG_C_SERIES | C series ions.
FRAG_X_SERIES | X series ions.
FRAG_Y_SERIES | Y series ions.
FRAG_Y_MINUS_NH3 | Referred to as y* in Mascot reports.
FRAG_Y_MINUS_H2O | Referred to as yo in Mascot reports.
FRAG_Z_SERIES | Z series ions.
FRAG_INTERNAL_YB | Internal series, caused by double backbone cleavage. Combination of b type and y type cleavage.
FRAG_INTERNAL_YA | Internal series, caused by double backbone cleavage. Combination of a type and y type cleavage.
FRAG_Z_PLUS_1 | Z+1 series.
FRAG_D_SERIES | D Satellite Ions. A series partial side chain. Collision induced dissociation of ions at keV energies.
FRAG_V_SERIES | V Satellite Ions. Y series partial side chain. Collision induced dissociation of ions at keV energies.
FRAG_W_SERIES | W Satellite Ions. Z series partial side chain. Collision induced dissociation of ions at keV energies.
FRAG_Z_PLUS_2 | Z+2 series.

Constructor & Destructor Documentation

◆ ms_fragmentationrules()

ms_fragmentationrules ( )

Default constructor is used to create an empty object.

Use member functions to fill up the list of allowed series.

◆ ~ms_fragmentationrules()

~ms_fragmentationrules ( )

Destructor.

Frees all memory allocated for the object.

Member Function Documentation

◆ anyNLseriesUsed()

bool anyNLseriesUsed ( const int series ) const

Will return true if any 'neutral loss' series is specified for this series.

Parameters
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns
true if the passed series
  • is A and A with loss of water or NH3 is also specified, or
  • is B and B with loss of water or NH3 is also specified, or
  • is Y and Y with loss of water or NH3 is also specified.
Otherwise returns false.

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ clearSeries()

void clearSeries ( )

Deletes all series usage information.

All series are set to be unused, but the instrument title is retained.

◆ copyFrom()

void copyFrom ( const ms_fragmentationrules * right )

Copies all information from another instance of the class.

Parameters
right is the fragmentation rules to copy from.

◆ defaultValues()

void defaultValues ( )

Initialises the instance with default values.

Sets all series to be unused.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getFirstSerie()

int getFirstSerie ( )
static

The lowest series number that can be used.

Deprecated:
Use getFirstSeries().
Returns
The first usable series number. Series numbers '1', '2' and '3' relate to allowed charge states rather than real series.

◆ getFirstSeries()

int getFirstSeries ( )
static

The lowest series number that can be used.

See also
ms_fragmentationrules::getLastSeries()
Returns
The first usable series number. Series numbers '1', '2' and '3' relate to allowed charge states rather than real series.

◆ getLastSerie()

int getLastSerie ( )
static

The highest series number that can be used.

Deprecated:
Use getLastSeries().
Returns
The last usable series number. More series may be added in later versions of Mascot, and using this function may allow code to be made 'future proof'.

◆ getLastSeries()

int getLastSeries ( )
static

The highest series number that can be used.

See also
ms_fragmentationrules::getFirstSeries()
Returns
The last usable series number. More series may be added in later versions of Mascot, and using this function may allow code to be made 'future proof'.

◆ getMaxInternalMass()

double getMaxInternalMass ( ) const

Returns the maximum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

These are the masses used for the FRAG_INTERNAL_YB and FRAG_INTERNAL_YA series.

Returns
The maximum internal mass to be considered for this instrument.

◆ getMinInternalMass()

double getMinInternalMass ( ) const

Returns the minimum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

These are the masses used for the FRAG_INTERNAL_YB and FRAG_INTERNAL_YA series.

Returns
The minimum internal mass to be considered for this instrument.

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ getSeriesDescription()

std::string getSeriesDescription ( const int series )
static

Returns a description string for a given series.

Parameters
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns
series description

◆ getSeriesName()

std::string getSeriesName ( const int series )
static

Returns a short series name.

Parameters
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns
series name

◆ getTitle()

std::string getTitle ( ) const

Returns the title of the instrument.

This is obtained from the

title:

line in the fragmentation_rules file.

Returns
The title.

◆ getTotalSeriesOutput()

int getTotalSeriesOutput ( )
static

Returns the length of the series string output in a Mascot results file.

See also
ms_peptide::getVarModsStr()
Returns
the number of series that output for each peptide in the Mascot results file.

◆ isBackboneSeries()

bool isBackboneSeries ( const int series )
static

Returns true if the series is a 'backbone' fragment.

Parameters
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns
true if the series is A, B, Y, C, X, Z, Z+1, Z+2 or loss of water or NH3 from A,B or Y.

◆ isCharged2Plus()

bool isCharged2Plus ( ) const

Returns true if the 'doubly charged 2+' fragmentation rule is specified.

Returns
true if rule 2, doubly charged if precursor 2+ or higher is specified and therefore 2+ ions, for the specified series (not internal or immonium) are to be considered.

◆ isCharged3Plus()

bool isCharged3Plus ( ) const

Returns true if the 'doubly charged 3+' fragmentation rule is specified.

Returns
true if rule 3, doubly charged if precursor 3+ or higher is specified and therefore 2+ ions, for the specified series (not internal or immonium) are to be considered.

◆ isNeutralLossSeries()

bool isNeutralLossSeries ( const int series )
static

Returns true if the series is a 'neutral loss' series.

Parameters
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns
true if the series is loss of water or NH3 from A,B or Y.

◆ isSeriesUsed()

bool isSeriesUsed ( const int series ) const

Returns true if a given series is specified for the instrument.

Currently supported series are (FRAG_SERIES_TYPE):

  • 4 - immonium ions
  • 5 - 'a' ions
  • 6 - 'a-NH3' or 'a*' ions
  • 7 - 'a-H2O' or 'a0' ions
  • 8 - 'b' ions
  • 9 - 'b-NH3' or 'b*' ions
  • 10 - 'b-H2O' or 'b0' ions
  • 11 - 'c' ions
  • 12 - 'x' ions
  • 13 - 'y' ions
  • 14 - 'y-NH3' or 'y*' ions
  • 15 - 'y-H2O' or 'y0' ions
  • 16 - 'z' ions
  • 17 - internal fragments 'yb'
  • 18 - internal fragments 'ya'
  • 21 - 'z+1' ions
  • 22 - high-energy 'd' ions
  • 23 - high-energy 'v' ions
  • 24 - high-energy 'w' ions
  • 25 - 'z+2' ions

In addition, two more rules may be specified:

  • 19 - 'y' or 'y++' series presense must be significant
  • 20 - 'y' or 'y++' must be highest scoring series
Parameters
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns
true if the series if used, false otherwise

◆ isSinglyCharged()

bool isSinglyCharged ( ) const

Returns true if the 'singly charged' fragmentation rule is specified.

Returns
true if rule 1 singly charged ions is specified and therefore 1+ ions, for the specified series are to be considered.

◆ isValid()

bool isValid ( ) const

Use this method to do a basic check on a newly created object.

The verifyRule() function will generally be more useful.

Returns
true if the series and masses are consistent, false otherwise

◆ operator=()

ms_fragmentationrules & operator= ( const ms_fragmentationrules & right )

Assignment operator.

Parameters
right is the fragmentation rules to copy from.
Returns
reference to the current object

◆ setCharged2Plus()

void setCharged2Plus ( const bool value )

Change the availability the of 'doubly charged 2+' fragmentation rule.

Parameters
value should be set to true if rule 2, doubly charged if precursor 2+ or higher is to be specified and therefore 2+ ions, for the specified series (not internal or immonium) are to be considered.

◆ setCharged3Plus()

void setCharged3Plus ( const bool value )

Change the availability the of 'doubly charged 3+' fragmentation rule.

Parameters
value should be set to true if rule 3, doubly charged if precursor 3+ or higher is to be specified and therefore 2+ ions, for the specified series (not internal or immonium) are to be considered.

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setMaxInternalMass()

void setMaxInternalMass ( const double mass )

Sets the maximum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

These are the masses used for the FRAG_INTERNAL_YB and FRAG_INTERNAL_YA series.

Parameters
mass The new maximum internal mass to be considered for this instrument.

◆ setMinInternalMass()

void setMinInternalMass ( const double mass )

Set the minimum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

These are the masses used for the FRAG_INTERNAL_YB and FRAG_INTERNAL_YA series.

Parameters
mass The new minimum internal mass to be considered for this instrument.

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ setSeriesUsed()

void setSeriesUsed | ( | const int | series,
 |  | const bool | val
 | ) |  |

Sets availability on a given series.

See isSeriesUsed() for a list of available series.

Parameters
series | must be a number between getFirstSeries() and getLastSeries() inclusive.
val | is a boolean value to specify whether the series should be considered.
Examples
config_fragrules.cpp.

◆ setSinglyCharged()

void setSinglyCharged ( const bool value )

Change the availability of the 'singly charged' fragmentation rule.

Parameters
value should be set to true if rule 1 (singly charged ions) are to be considered.

◆ setTitle()

void setTitle ( const char * title )

Assigns a new title to the rule.

Parameters
title is the new title.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise

◆ verifyRule()

bool verifyRule | ( | ms_errs * | errObj,
 |  | const bool | tryToFix
 | ) |  |

Tries to detect any inconsistencies in the instrument definition.

This method tries to detect any inconsistencies and to fix some of them.

When tryToFix is set to true will force the method to try and fix the instrument definition and return a success code. In this case, error descriptions for the problems detected (and fixed) will be accumulated in errObj.

For example, if the FRAG_A_MINUS_NH3 series is specified, and FRAG_A_SERIES isn't specified, then, if tryToFix is specified, FRAG_A_SERIES will be added, and the ms_errs::ERR_MSP_FRAGMENTATION_RULES error will be added to the errObj list.

Parameters
errObj | error-object to store error messages.
tryToFix | if true, try to fix any problems encountered.
Returns
always true, errors are set if something is wrong
The documentation for this class was generated from the following files:
  • ms_fragmentationrules.hpp
  • ms_fragmentationrules.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fragrulesfile Class Reference

  • matrix_science
  • ms_fragrulesfile
Public Member Functions | List of all members
ms_fragrulesfile Class Reference
Mascot configuration files module

This class encapsulates a complete fragmentation_rules file. More...

#include <ms_fragmentationrules.hpp>

Inheritance diagram for ms_fragrulesfile:
[legend]
Collaboration diagram for ms_fragrulesfile:
[legend]

Public Member Functions

ms_fragrulesfile ()
Default constructor.
ms_fragrulesfile (const char *filename, const matrix_science::ms_connection_settings *cs=0)
Immediate-action constructor that reads the given file.
ms_fragrulesfile (const ms_fragrulesfile &src)
Copying constructor.
~ms_fragrulesfile ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | appendInstrument (const ms_fragmentationrules *item)
Adds a new instrument definition at the end of the list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearInstruments ()
Deletes all instruments definitions.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_fragrulesfile *right)
Can be used to make a copy of another instance.
void | defaultValues ()
Re-initialises the list of fragmentation rules, so the instance can be re-used.
bool | deleteInstrumentByName (const char *name)
Remove an instrument from the list in memory.
bool | deleteInstrumentByNumber (const int num)
Remove an instrument from the list in memory.
matrix_science::ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Get the currently used file name.
const ms_fragmentationrules * | getInstrumentByName (const char *name) const
Returns a configuration for an instrument by name.
const ms_fragmentationrules * | getInstrumentByNumber (const int instrumentNum) const
Returns a configuration for an instrument by its number from 0 to (getNumberOfInstruments()-1).
std::string | getInstrumentName (const int instrumentNum) const
Returns an instrument name by its number from 0 to (getNumberOfInstruments()-1).
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumberOfInstruments () const
Returns a number of instruments configured.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_fragrulesfile & | operator= (const ms_fragrulesfile &right)
C++ style assignment operator.
void | read_buffer (const char *buffer)
Reads and parses the string, populates the list of instruments.
void | read_file ()
Reads and parses the file, populates the list of instruments.
void | save_file ()
Stores instrument definitions in a file.
void | setConnectionSettings (const matrix_science::ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *filename)
Use this member to set a non-default file name.
bool | updateInstrumentByName (const char *name, const ms_fragmentationrules item)
Update the information for a specific instrument.
bool | updateInstrumentByNumber (const int num, const ms_fragmentationrules item)
Update the information for a specific instrument.

Detailed Description

This class encapsulates a complete fragmentation_rules file.

Usage of this class is simple. Just create an instance, set an explicit file name if necessary, call read_file()-member, check for errors (isValid()) and retrieve an instrument by its name or number.

Examples
config_fragrules.cpp.

Constructor & Destructor Documentation

◆ ms_fragrulesfile() [1/2]

ms_fragrulesfile ( )

Default constructor.

Not generally useful. The filename is set to ../config/fragmentation_rules, but the file is not read.

◆ ms_fragrulesfile() [2/2]

ms_fragrulesfile | ( | const char * | filename,
 |  | const matrix_science::ms_connection_settings * | cs = 0
 | ) |  |

Immediate-action constructor that reads the given file.

Parameters
filename | The file name parameter can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
cs | is a pointer to the connection settings. This should contain a sessionID and optionally the proxy server settings.

◆ ~ms_fragrulesfile()

~ms_fragrulesfile ( )

Destructor.

Frees all memory allocated for the object.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ appendInstrument()

void appendInstrument ( const ms_fragmentationrules * item )

Adds a new instrument definition at the end of the list.

Typically, the file would be saved after doing this.

Parameters
item is the the new instrument definition to be added.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ clearInstruments()

void clearInstruments ( )

Deletes all instruments definitions.

All instruments are removed.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_fragrulesfile * right )

Can be used to make a copy of another instance.

Parameters
right is the fragmentation rules file to copy values from.

◆ defaultValues()

void defaultValues ( )

Re-initialises the list of fragmentation rules, so the instance can be re-used.

Clears the list of instruments and comments. Clears all errors.

◆ deleteInstrumentByName()

bool deleteInstrumentByName ( const char * name )

Remove an instrument from the list in memory.

Parameters
name must be a valid instrument name.
Returns
True if the instrument name is valid and the instrument is removed.
Examples
config_fragrules.cpp.

◆ deleteInstrumentByNumber()

bool deleteInstrumentByNumber ( const int num )

Remove an instrument from the list in memory.

Parameters
num must be in the range 0..getNumberOfInstruments()-1.
Returns
True if the instrument number is valid.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFileName()

std::string getFileName ( ) const

Get the currently used file name.

Returns
The new file name or URL.

◆ getInstrumentByName()

const ms_fragmentationrules * getInstrumentByName ( const char * name ) const

Returns a configuration for an instrument by name.

Parameters
name is the name of the instrument as specified in the title line in the fragmentation_rules file.
Returns
The rules specified for the given instrument.
Examples
config_fragrules.cpp.

◆ getInstrumentByNumber()

const ms_fragmentationrules * getInstrumentByNumber ( const int instrumentNum ) const

Returns a configuration for an instrument by its number from 0 to (getNumberOfInstruments()-1).

Parameters
instrumentNum is the number of the instrument and should be between zero and getNumberOfInstruments()-1.
Returns
The rules specified for the given instrument.

◆ getInstrumentName()

std::string getInstrumentName ( const int instrumentNum ) const

Returns an instrument name by its number from 0 to (getNumberOfInstruments()-1).

Parameters
instrumentNum is the number of the instrument and should be between zero and getNumberOfInstruments()-1.
Returns
The name of the instrument from the title: line in the fragmentation_rules file.
Examples
config_fragrules.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getNumberOfInstruments()

int getNumberOfInstruments ( ) const

Returns a number of instruments configured.

Returns
the number of instrument types with assigned settings.
Examples
config_fragrules.cpp.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_fragrulesfile & operator= ( const ms_fragrulesfile & right )

C++ style assignment operator.

Parameters
right is the fragmentation rules file to copy values from.
Returns
reference to the current object

◆ read_buffer()

void read_buffer ( const char * buffer )

Reads and parses the string, populates the list of instruments.

Check for possible errors with isValid()-function and retrieve errors descriptions (if any) after calling this function. If an error occurs during reading the buffer it will still contain some of the instruments that have been successfully read from the file.

Parameters
buffer buffer to read

◆ read_file()

void read_file ( )

Reads and parses the file, populates the list of instruments.

Check for possible errors with isValid()-function and retrieve errors descriptions (if any) after calling this function. If an error occurs during reading the file it will still contain some of the instruments that have been successfully read from the file.

◆ save_file()

void save_file ( )

Stores instrument definitions in a file.

Don't forget to check for errors after this function call.

Examples
config_fragrules.cpp.

◆ setConnectionSettings()

void setConnectionSettings ( const matrix_science::ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters
cs is the new connection settings.

◆ setFileName()

void setFileName ( const char * filename )

Use this member to set a non-default file name.

Parameters
filename is the new file name or URL.
Examples
config_fragrules.cpp.

◆ updateInstrumentByName()

bool updateInstrumentByName | ( | const char * | name,
 |  | const ms_fragmentationrules | item
 | ) |  |

Update the information for a specific instrument.

Parameters
name | must be a valid Instrument name.
item | is a pointer to the new definition of the instrument.
Returns
true if the instrument was found and was updated.
Examples
config_fragrules.cpp.

◆ updateInstrumentByNumber()

bool updateInstrumentByNumber | ( | const int | num,
 |  | const ms_fragmentationrules | item
 | ) |  |

Update the information for a specific instrument.

Parameters
num | must be in the range 0..getNumberOfInstruments()-1.
item | is a pointer to the new definition of the instrument definition.
Returns
true if the instrument was found and was updated.
The documentation for this class was generated from the following files:
  • ms_fragmentationrules.hpp
  • ms_fragmentationrules.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_libraryoptions Class Reference

  • matrix_science
  • ms_libraryoptions
Public Member Functions | List of all members
ms_libraryoptions Class Reference
Mascot configuration files module

Represents the LibraryOptions section of mascot.dat. More...

#include <ms_libraryoptions.hpp>

Inheritance diagram for ms_libraryoptions:
[legend]
Collaboration diagram for ms_libraryoptions:
[legend]

Public Member Functions

ms_libraryoptions ()
Default constructor.
ms_libraryoptions (const ms_libraryoptions &src)
Copying constructor.
~ms_libraryoptions ()
Destructor.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_libraryoptions *right)
Can be used to copy content from another instance.
void | defaultValues ()
Initializes the instance.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
void | dropSpectralLibrary (const char *spectralLibraryName)
Remove all references to the specified spectral library.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
std::string | getLibraryName (const int num) const
Return the name of the library.
int | getNumberOfLibraries () const
Return the number of libraries.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
std::string | getReferenceFasta (const char *spectralLibraryName) const
Returns the name of the Fasta database used as a reference for accessions for the spectral library.
std::string | getReferenceFastaTaxonomyTitle (const char *spectralLibraryName) const
Returns the title of the taxonomy to use for the reference database.
double | getToleranceInDa (const char *spectralLibraryName) const
Returns the tolerance of the data in spectral library.
double | getToleranceInPPM (const char *spectralLibraryName) const
Returns the tolerance of the data in spectral library.
bool | isSectionAvailable () const
Check whether the section has been actually read from the file.
ms_libraryoptions & | operator= (const ms_libraryoptions &right)
Assignment operator for C++ client applications.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setReferenceFasta (const char *spectralLibraryName, const char *fastaDatabaseName, const char *taxonomyTitle)
Sets the name of the Fasta database used as a reference for accessions for the spectral library.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.
void | setToleranceInDa (const char *spectralLibraryName, double tolerance)
Sets the tolerance of the data in spectral library.
void | setToleranceInPPM (const char *spectralLibraryName, double tolerance)
Sets the tolerance of the data in spectral library.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

Represents the LibraryOptions section of mascot.dat.

See : ms_datfile::getLibraryOptions and ms_datfile::setLibraryOptions

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Constructor & Destructor Documentation

◆ ms_libraryoptions() [1/2]

ms_libraryoptions ( )

Default constructor.

Create an object with no options

◆ ms_libraryoptions() [2/2]

ms_libraryoptions ( const ms_libraryoptions & src )

Copying constructor.

C++ only. Use copyFrom from other languages.

Parameters
src is the source options to copy into the new object

◆ ~ms_libraryoptions()

~ms_libraryoptions ( )

Destructor.

Frees any memory

Member Function Documentation

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ copyFrom()

void copyFrom ( const ms_libraryoptions * right )

Can be used to copy content from another instance.

Copy all the parameter for the libraries from right into the object

Parameters
right is the source library options

◆ defaultValues()

void defaultValues ( )

Initializes the instance.

Remove details for all the libraries

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ dropSpectralLibrary()

void dropSpectralLibrary ( const char * spectralLibraryName )

Remove all references to the specified spectral library.

Parameters
spectralLibraryName is the (short) name of the library

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getLibraryName()

std::string getLibraryName ( const int num ) const

Return the name of the library.

Parameters
num must be in the range 0 to getNumberOfLibraries() -1
Returns
the name of the library which can be used in other functions such as getReferenceFasta()

◆ getNumberOfLibraries()

int getNumberOfLibraries ( ) const

Return the number of libraries.

Returns
The number of libraries with parameters in the section

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ getReferenceFasta()

std::string getReferenceFasta ( const char * spectralLibraryName ) const

Returns the name of the Fasta database used as a reference for accessions for the spectral library.

A Spectral library is essentially a peptide library and will often not contain meaningful accessions. To get useful protein grouping in Mascot reports, it is recommended that users specify a 'reference' database. When a reference database is used, Mascot tries to find the peptide sequence from the library in the reference fasta, and if it is found then it adds the accession for that protein sequence to the search results.

See also
getReferenceFastaTaxonomyTitle()
Parameters
spectralLibraryName is the (short) name of the library
Returns
the (short) name of the reference fasta

◆ getReferenceFastaTaxonomyTitle()

std::string getReferenceFastaTaxonomyTitle ( const char * spectralLibraryName ) const

Returns the title of the taxonomy to use for the reference database.

The reference database may contain protein accessions from multiple taxa. If a suitable taxonomy index is configured, you can define the taxon to use for reference accessions. The returned value is the title string of an entry in the taxonomy configuration file (typically mascot/config/taxonomy).

See also
getReferenceFasta()
Parameters
spectralLibraryName is the (short) name of the library
Returns
the title of the taxon, or the empty string if not set.

◆ getToleranceInDa()

double getToleranceInDa ( const char * spectralLibraryName ) const

Returns the tolerance of the data in spectral library.

A spectral library is created using an instrument with a known tolerance and this tolerance is specified by the user when they enable the use of the library in Mascot. When the library is searched, the tolerance used is the square root of the sum of the squares of the data being searched and this value.

The tolerance of the library is specified in Da and ppm since the user may choose either units when they submit a search.

See also, getToleranceInPPM(), setToleranceInPPM() and setToleranceInDa()

If spectralLibraryName does not exist, returns the default (0.6 Da)

Parameters
spectralLibraryName is the (short) name of the library
Returns
the tolerance of the data in the library

◆ getToleranceInPPM()

double getToleranceInPPM ( const char * spectralLibraryName ) const

Returns the tolerance of the data in spectral library.

A spectral library is created using an instrument with a known tolerance and this tolerance is specified by the user when they enable the use of the library in Mascot. When the library is searched, the tolerance used is the square root of the sum of the squares of the data being searched and this value.

The tolerance of the library is specified in Da and ppm since the user may choose either units when they submit a search.

See also, setToleranceInPPM(), getToleranceInDa() and setToleranceInDa()

If spectralLibraryName does not exist, returns the default (500ppm)

Parameters
spectralLibraryName is the (short) name of the library
Returns
the tolerance of the data in the library

◆ isSectionAvailable()

bool isSectionAvailable ( ) const

Check whether the section has been actually read from the file.

By default the LibraryOptions section is unavailable until it has been set to a different state.

The section does not have to exist in the mascot.dat file

Returns
true if the section exists

◆ operator=()

ms_libraryoptions & operator= ( const ms_libraryoptions & right )

Assignment operator for C++ client applications.

C++ only

Parameters
right is the source library options
Returns
a reference to 'this'

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ setReferenceFasta()

void setReferenceFasta | ( | const char * | spectralLibraryName,
 |  | const char * | fastaDatabaseName,
 |  | const char * | taxonomyTitle
 | ) |  |

Sets the name of the Fasta database used as a reference for accessions for the spectral library.

A Spectral library is essentially a peptide library and will often not contain meaningful accessions. To get useful protein grouping in Mascot reports, it is recommended that users specify a 'reference' database. When a reference database is used, Mascot tries to find the peptide sequence from the library in the reference fasta. If it is found, Mascot adds the accession for that protein sequence to the search results.

The reference database may contain protein accessions from multiple taxa. To restrict accesions to a particular taxon, give its title as the third argument. Titles typically come from the taxonomy configuration file (mascot/config/taxonomy). If left empty, there is no restriction.

Parameters
spectralLibraryName | is the (short) name of the library
fastaDatabaseName | is the (short) name of the reference database
taxonomyTitle | is the title of the taxon to use, or the empty string.

◆ setSectionAvailable()

void setSectionAvailable ( const bool value )

Changes availability of the section, i.e. whether it should be saved in a file.

The section does not have to exist in the mascot.dat file

Parameters
value set to true if the section exists

◆ setToleranceInDa()

void setToleranceInDa | ( | const char * | spectralLibraryName,
 |  | double | tolerance
 | ) |  |

Sets the tolerance of the data in spectral library.

A spectral library is created using an instrument with a known tolerance and this tolerance is specified by the user when they enable the use of the library in Mascot. When the library is searched, the tolerance used is the square root of the sum of the squares of the data being searched and this value.

The tolerance of the library is specified in Da and ppm since the user may choose either units when they submit a search.

See also, getToleranceInPPM(), setToleranceInPPM() and getToleranceInDa()

If spectralLibraryName does not exist, returns the default (500ppm)

Parameters
spectralLibraryName | is the (short) name of the library
tolerance | is the new tolerance for spectralLibraryName

◆ setToleranceInPPM()

void setToleranceInPPM | ( | const char * | spectralLibraryName,
 |  | double | tolerance
 | ) |  |

Sets the tolerance of the data in spectral library.

A spectral library is created using an instrument with a known tolerance and this tolerance is specified by the user when they enable the use of the library in Mascot. When the library is searched, the tolerance used is the square root of the sum of the squares of the data being searched and this value.

The tolerance of the library is specified in Da and ppm since the user may choose either units when they submit a search.

See also, getToleranceInPPM(), getToleranceInDa() and setToleranceInDa()

If spectralLibraryName does not exist, this adds a new entry for the library and sets a default value for other parameters for the library

Parameters
spectralLibraryName | is the (short) name of the library
tolerance | is the new tolerance for spectralLibraryName

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_libraryoptions.hpp
  • ms_libraryoptions.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_license Class Reference

  • matrix_science
  • ms_license
Public Member Functions | List of all members
ms_license Class Reference
Mascot configuration files module

The class provides access license details in read-only mode. More...

#include <ms_license.hpp>

Inheritance diagram for ms_license:
[legend]
Collaboration diagram for ms_license:
[legend]

Public Member Functions

ms_license ()
Default constructor.
ms_license (const char *filename)
Immediate action constructor.
ms_license (const ms_license &src)
Copying constructor.
~ms_license ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_license *right)
Copies all information from another instance.
void | defaultValues ()
Can be called before re-using the instance in order to erase the previous license details.
std::string | getDistributor () const
Returns Mascot distributor information.
std::string | getEndDate () const
Returns a date the license is valid until as a string.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFeatures () const
Returns a string which encodes feature information.
std::string | getFileName () const
Returns a file name being used as a license.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getLicensee () const
Returns a name of the licensee.
std::string | getLicenseString () const
Returns a compound license string that can be used for displaying license information.
std::string | getLicenseVersion () const
Returns a license version as a string.
int | getNumProcessorsLicensed () const
Returns a number of processors licensed.
std::string | getStartDate () const
Returns a date the license is valid from as a string.
bool | isLicenseValid () const
Returns TRUE if the license has been sucessfully read, parsed and checked.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_license & | operator= (const ms_license &right)
Assignment operator for C++ client applications.
void | read_file ()
Main method that reads in the license file.
void | setFileName (const char *filename)
Set the license file name explicitly rather than use a default location.

Detailed Description

The class provides access license details in read-only mode.

This class doesn't contain functions to create a new license or read details of why a license may be invalid.

Please note the ms_license class will only work with license files from Mascot release 2.3 or earlier.

To use this class:

  • Create an instance of this class.
  • Set an explicit file name if needed.
  • Call read_file().
  • Check for possible file reading errors with isValid().
  • Check license validity with isLicenseValid().
  • If the license is valid, then access individual license properties.
  • Re-use the instance (if you need to read multiple licenses) after calling defaultValues().
Examples
config_license.cpp.

Constructor & Destructor Documentation

◆ ms_license() [1/2]

ms_license ( )

Default constructor.

Deprecated:
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

This doesn't read a license file.

◆ ms_license() [2/2]

ms_license ( const char * filename )

Immediate action constructor.

Deprecated:
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

Loads the license file into memory. Call isValid() and isLicenseValid() to checks that it is a valid license file.

Parameters
filename is a full or relative path to mascot.license

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getDistributor()

std::string getDistributor ( ) const

Returns Mascot distributor information.

The distributor will be one of:

  • Unknown
  • Direct
  • Bruker
  • Infocom
  • Kratos
  • Applied Biosystems
  • Mass Solutions Ltd Taiwan
Returns
the distributor as a string.

◆ getEndDate()

std::string getEndDate ( ) const

Returns a date the license is valid until as a string.

Returns
the license end date as a string in the format YYYYMMDD.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFeatures()

std::string getFeatures ( ) const

Returns a string which encodes feature information.

Returns
a numerically encoded string.

◆ getFileName()

std::string getFileName ( ) const

Returns a file name being used as a license.

Returns
The license filename – full or relative path.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getLicensee()

std::string getLicensee ( ) const

Returns a name of the licensee.

The licensee name will be up to 80 characters long.

Returns
the licensee as a string.

◆ getLicenseString()

std::string getLicenseString ( ) const

Returns a compound license string that can be used for displaying license information.

This will be of the following format:

   Licensed to: xxx, (yy processors).

For a temporary license:

    Licensed to: xxx, (yy processors). Demo version expires: zzzz
Returns
the license string.
Examples
config_license.cpp.

◆ getLicenseVersion()

std::string getLicenseVersion ( ) const

Returns a license version as a string.

The license version number is not directly related to the Mascot version number. It is incremented each time new functionality (and hence extra lines) are added to the license file.

Returns
The license version number as a string.

◆ getNumProcessorsLicensed()

int getNumProcessorsLicensed ( ) const

Returns a number of processors licensed.

Returns
the number of processors licensed.

◆ getStartDate()

std::string getStartDate ( ) const

Returns a date the license is valid from as a string.

Returns
the license start date as a string in the format YYYYMMDD.

◆ isLicenseValid()

bool isLicenseValid ( ) const

Returns TRUE if the license has been sucessfully read, parsed and checked.

If the license is not valid, some information may be available by calling getLastErrorString() or getLastError().

Returns
true if the license is valid.
Examples
config_license.cpp.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ read_file()

void read_file ( )

Main method that reads in the license file.

Deprecated:
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

Called by the constructor if a filename is passed.

◆ setFileName()

void setFileName ( const char * filename )

Set the license file name explicitly rather than use a default location.

Deprecated:
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

A default location for the license file is ../config/mascot.license. Call this member to change this file name before calling read_file().

Parameters
filename The license filename – full or relative path.
The documentation for this class was generated from the following files:
  • ms_license.hpp
  • ms_license.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotfiles Class Reference

  • matrix_science
  • ms_mascotfiles
Public Member Functions | List of all members
ms_mascotfiles Class Reference
Mascot configuration files module

An instance of this class contains configuration files paths (except for mascot.dat). More...

#include <ms_mascotfiles.hpp>

Inheritance diagram for ms_mascotfiles:
[legend]
Collaboration diagram for ms_mascotfiles:
[legend]

Public Member Functions

ms_mascotfiles ()
Default constructor.
ms_mascotfiles (const ms_mascotfiles &src)
Copying constructor.
~ms_mascotfiles ()
Destructor.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_mascotfiles *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
std::string | getEnzymes () const
Returns enzymes path.
std::string | getFrequencies () const
Returns freqs.dat path.
std::string | getModifications () const
Returns mod_file path.
std::string | getNodeListFile () const
Returns nodelist.txt path.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
ms_mascotfiles & | operator= (const ms_mascotfiles &right)
Assignment operator for C++ client application.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setEnzymes (const char *filename)
Change enzymes path.
void | setFrequencies (const char *filename)
Change freqs.dat path.
void | setModifications (const char *filename)
Change mod_file path.
void | setNodeListFile (const char *filename)
Change nodelist.txt path.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

An instance of this class contains configuration files paths (except for mascot.dat).

An instance of this class is normally created and populated within ms_datfile. It contains filepaths for mod_file, enzymes, frequencies and nodelist.txt.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Member Function Documentation

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_mascotfiles.hpp
  • ms_mascotfiles.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotoptions Class Reference

  • matrix_science
  • ms_mascotoptions
Public Types | Public Member Functions | List of all members
ms_mascotoptions Class Reference
Mascot configuration files module

An instance of this class represents all the parameters specified in the Options section of mascot.dat. More...

#include <ms_mascotoptions.hpp>

Inheritance diagram for ms_mascotoptions:
[legend]
Collaboration diagram for ms_mascotoptions:
[legend]

Public Types

enum DECOY_ALGORITHM {
DECOY_ALGORITHM_NONE = 0 ,
DECOY_PROTEIN_REVERSE = 1 ,
DECOY_PEPTIDE_REVERSE = 2 ,
DECOY_PROTEIN_RANDOM = 3 ,
DECOY_PEPTIDE_RANDOM = 4 ,
DECOY_PROTEIN_RANDOM_DIPEP = 5 ,
DECOY_PEPTIDE_RANDOM_DIPEP = 6 ,
DECOY_PROTEIN_SHUFFLE = 7 ,
DECOY_PEPTIDE_SHUFFLE = 8 ,
DECOY_PROTEIN_BASED_MASK = 0x0001
}
Definitions for how the decoy sequences are generated. More...
enum | EXEC_AFTER_SEARCH { MAX_EXEC_AFTER_SEARCH = 10 }
Definitions for the ExecAfterSearch_XXX lines in the Options section of mascot.dat. More...
enum MS_REVIEW_COL {
MS_REVIEW_COL_JOB = 0x0000 ,
MS_REVIEW_COL_PID = 0x0001 ,
MS_REVIEW_COL_DATABASE = 0x0002 ,
MS_REVIEW_COL_USERNAME = 0x0003 ,
MS_REVIEW_COL_USEREMAIL = 0x0004 ,
MS_REVIEW_COL_TITLE = 0x0005 ,
MS_REVIEW_COL_RESULTS_FILE = 0x0006 ,
MS_REVIEW_COL_START_TIME = 0x0007 ,
MS_REVIEW_COL_DURATION = 0x0008 ,
MS_REVIEW_COL_STATUS = 0x0009 ,
MS_REVIEW_COL_PRIORITY = 0x000A ,
MS_REVIEW_COL_SEARCHTYPE = 0x000B ,
MS_REVIEW_COL_ENZYMEUSED = 0x000C ,
MS_REVIEW_COL_IPADDRESS = 0x000D ,
MS_REVIEW_COL_USERID = 0x000E ,
MS_REVIEW_COL_PEAKLISTDATAFILE = 0x000F ,
MS_REVIEW_COL____LAST___ = 0x0010
}
Definitions for columns in ms-review.exe for use with getReviewColWidth() and getReviewColDisplay(). More...
enum | NUMERICAL_VALUE_STORAGE { MASS_DECIMAL_PLACES = 6 }
Definitions for storage of numerical values in files. More...
enum PERC_EXE_RT {
PERC_EXE_RT_USE_DEFAULT = 1 ,
PERC_EXE_RT_FORCE_ON = 2 ,
PERC_EXE_RT_FORCE_OFF = 3
}
Definitions for retention time override when calling getPercolatorExeFlags(). More...

Public Member Functions

ms_mascotoptions ()
Default constructor.
ms_mascotoptions (const ms_mascotoptions &src)
Copying constructor.
~ms_mascotoptions ()
Destructor.
void | appendIgnoreDupeAccession (const std::string value)
Appends a database to the list databases that shouldn't be checked for duplicate accessions.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendReportNumberChoice (const int value)
Append a value to the ReportNumberChoices list.
void | appendTargetFDRPercentage (const double value, const bool makeDefault=false)
Append a value to the TargetFDRPercentages list.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearIgnoreDupeAccessions ()
Clears the list of databases that shouldn't be checked for duplicate accessions.
void | clearReportNumberChoices ()
Deletes all ReportNumberChoices values from the list.
void | clearTargetFDRPercentages ()
Deletes all TargetFDRPercentages values from the list.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_mascotoptions *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getCacheDirectory () const
Returns the value of CacheDirectory.
double | getCentroidWidth () const
Returns the value of CentroidWidth.
int | getCentroidWidthCount () const
Returns the value of CentroidWidthCount.
std::string | getCompressToolAA () const
Returns the value of CompressTool_AA.
std::string | getCompressToolCommandLineFasta (DATABASE_TYPE dbType, const std::string &dbname, const std::string &dbpath) const
Get command line to compress fasta, eg ms-compress.exe.
std::string | getCompressToolCommandLineLibrary (const std::string &logfilepath, const std::string &inputfile, const std::string &outputdirectory) const
Get command line to compress library, eg lib2nistcl.exe.
std::string | getCompressToolNA () const
Returns the value of CompressTool_NA.
std::string | getCompressToolSL () const
Returns the value of CompressTool_NA.
int | getCrawlerNumPeaksPer100Da () const
Returns the number of peaks to output in each 100 Da window for the library crawler.
int | getCreatePipThreadBlockSize () const
Returns the value of CreatePipThreadBlockSize.
int | getCreatePipThreads () const
Returns the value of CreatePipThreads.
int | getDechargeFragmentPeaks () const
Return the maximum fragment ion charge state to be decharged.
int | getDecoyTypeNoEnzyme () const
Returns the value of DecoyTypeNoEnzyme.
int | getDecoyTypeSpecific () const
Returns the value of DecoyTypeSpecific.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
int | getDisplayNonSignificantMatches () const
Returns the value of DisplayNonSignificantMatches.
std::string | getEmailFromTextName () const
Returns the value of EmailFromTextName.
std::string | getEmailFromUser () const
Returns the value of EmailFromUser.
std::string | getEmailPassword () const
Returns the value of EmailPassword.
std::string | getEmailProfile () const
Returns the value of EmailProfile.
std::string | getEmailService () const
Returns the value of EmailService.
int | getEmailTimeOutPeriod () const
Returns the value of EmailTimeOutPeriod.
std::string | getErrMessageEmailTo () const
Returns the value of ErrMessageEmailTo.
std::string | getErrorLogFile () const
Returns the value of ErrorLogFile.
int | getErrTolMaxAccessions () const
Returns the value of ErrTolMaxAccessions.
int | getExecAfterSearch (const char *szResultsFilePath, std::vector< std::string > &commands, std::vector< std::string > &titles, std::vector< int > &waitfor, std::vector< int > &logging, std::vector< std::string > &additionalFlags, const char *sessionID=0, const char *taskID=0) const
Returns the values of the ExecAfterSearch_XXX parameters.
int | getFeatureTableLength () const
Returns the value of FeatureTableLength.
double | getFeatureTableMinScore () const
Returns the value of FeatureTableMinScore.
std::string | getFormVersion () const
Returns the value of FormVersion.
const ms_blastaccession * | getGetSeqBlastAccession () const
Returns GetSeqBlastAccession.
std::string | getGetSeqJobIdFile () const
Returns the value of GetSeqJobIdFile.
std::string | getICATFilter () const
Returns the value of ICATFilter.
std::string | getICATHeavy () const
Returns the value of ICATHeavy.
std::string | getICATLight () const
Returns the value of ICATLight.
std::string | getICATQuantitationMethod () const
Returns the value of name of the ICATQuantitationMethod.
std::string | getIgnoreDupeAccession (const unsigned int index) const
Returns one of the list databases that shouldn't be checked for duplicate accessions.
double | getIgnoreIonsScoreBelow () const
Returns the value of IgnoreIonsScoreBelow.
int | getIntensitySigFigs () const
Returns the value of IntensitySigFigs.
std::string | getInterFileBasePath () const
Returns the value of InterFileBasePath.
std::string | getInterFileRelPath () const
Returns the value of InterFileRelPath.
int | getIonsDecimalPlaces () const
Returns the value of IonsDecimalPlaces.
std::string | getLastQueryAscFile () const
Returns the value of LastQueryAscFile.
std::string | getLogoImageFile () const
Returns the value of LogoImageFile.
std::string | getMailTempFile () const
Returns the value of MailTempFile.
int | getMailTransport () const
Returns the value of MailTransport.
std::string | getMascNodeCtrlFile () const
Returns the value of MascotNodeControlFile.
std::string | getMascotCmdLine () const
Returns the value of MascotCmdLine.
std::string | getMascotControlFile () const
Returns the value of MascotControlFile.
int | getMascotFileProcessingThreads () const
Returns the value of MascotFileProcessingThreads.
std::string | getMascotJobIdFile () const
Returns the value of MascotJobIdFile.
std::string | getMascotMessage () const
Returns the value of MascotMessage.
int | getMassDecimalPlaces () const
Returns the value of MassDecimalPlaces.
int | getMaxConcurrentSearches () const
Returns the value of MaxConcurrentSearches.
int | getMaxDatabases () const
Returns the value of MaxDatabases.
int | getMaxDescriptionLen () const
Returns the value of MaxDescriptionLen.
double | getMaxEtagMassDelta () const
Returns the value of MaxEtagMassDelta.
int | getMaxEtVarMods () const
Returns the value of MaxEtVarMods.
int | getMaxIntactCrosslinkPeptides () const
Returns the value of MaxIntactCrosslinkPeptides.
int | getMaxNumOfReportBuilderColumnArrangements () const
Returns the maximum number of column arrangements allowed.
int | getMaxNumPeptides () const
Returns the value of MaxNumPeptides.
int | getMaxPepModArrangements () const
Returns the value of MaxPepModArrangements.
int | getMaxPepNumModifiedSites () const
Returns value of the MaxPepNumModifiedSites.
int | getMaxPepNumVarMods () const
Returns value of the MaxPepNumVarMods.
int | getMaxQueries () const
Returns the value of MaxQueries.
int | getMaxSearchesPerUser () const
Returns the value of MaxSearchesPerUser.
int | getMaxSequenceLen () const
Returns the value of MaxSequenceLen.
int | getMaxVarMods () const
Returns the value of MaxVarMods.
double | getMinEtagMassDelta () const
Returns the value of MinEtagMassDelta.
int | getMinPepLenInPepSummary () const
Returns the value of MinPepLenInPepSummary.
int | getMinPepLenInSearch () const
Returns value of the MinPepLenInSearch.
int | getMonitorEmailCheckFreq () const
Returns the value of MonitorEmailCheckFreq.
std::string | getMonitorLogFile () const
Returns the value of MonitorLogFile.
std::string | getMonitorPidFile () const
Returns the value of MonitorPidFile.
int | getMonitorTestTimeout () const
Returns the value of MonitorTestTimeout.
int | getMudpit () const
Returns the value of Mudpit.
double | getMudpitSwitch () const
Returns the value of MudpitSwitch.
std::string | getNoResultsScript () const
Returns the value of NoResultsScript.
std::string | getNTIUserGroup () const
Returns the value of NTIUserGroup.
std::string | getNTMonitorGroup () const
Returns the value of NTMonitorGroup.
unsigned int | getNumberOfIgnoreDupeAccessions () const
Returns the number of databases that shouldn't be checked for duplicate accessions.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
int | getNumberOfReportNumberChoices () const
Returns the values of ReportNumberChoices.
int | getNumberOfTargetFDRPercentages () const
Returns the values of TargetFDRPercentages.
std::string | getPepSearchTool () const
Returns the value of LibrarySearch.
std::string | getPepSearchToolCommandLine (const std::string &peptideToleranceUnit, const double &peptideTolerance, const std::string &ionToleranceUnit, const double &ionTolerance, const std::string &libraryDirectoryPath, const std::string &inputFileRelativePath, const std::string &outputFileRelativePath) const
Get command line to search a library, eg MSPepSearch.exe.
std::string | getPercolatorExeFlags (bool anyRetentionTimes, const std::vector< std::string > percolatorFiles, const PERC_EXE_RT rt=PERC_EXE_RT_USE_DEFAULT) const
Returns the value of PercolatorExeFlags.
std::string | getPercolatorFeatures () const
Returns the value of PercolatorFeatures.
int | getPercolatorMinQueries () const
Returns the value of PercolatorMinQueries.
int | getPercolatorMinSequences () const
Returns the value of PercolatorMinSequences.
std::string | getPercolatorRtFlags (const bool anyRetentionTimes, const bool useRT) const
Returns PercolatorExeFlags with the -D flag optionally removed if there are no retention times.
double | getPercolatorTargetRankRelativeThreshold () const
Returns the value of PercolatorTargetRankRelativeThreshold.
int | getPercolatorTargetRankScoreThreshold () const
Returns the value of PercolatorTargetRankScoreThreshold.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
double | getPrecursorCutOutLowerLimit () const
Gets the first PrecursorCutOut.
double | getPrecursorCutOutUpperLimit () const
Gets the second PrecursorCutOut.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
int | getProteinFamilySwitch () const
Returns the value of ProteinFamilySwitch.
int | getProteinsInResultsFile () const
Returns the value of ProteinsInResultsFile.
std::string | getProxyPassword () const
Returns the value of proxy_password.
std::string | getProxyServer () const
Returns the value of proxy_server.
std::string | getProxyType () const
Returns the value of ProxyType.
std::string | getProxyUsername () const
Returns the value of proxy_username.
std::string | getReportBuilderColumnArrangement (const int index) const
Returns ReportBuilderColumnArrangement by number.
int | getReportNumberChoice (const int index) const
Returns an element of the ReportNumberChoices list by its number.
std::string | getResfileCache () const
Returns the value of ResfileCache.
std::string | getResultsCache () const
Returns the value of ResultsCache.
std::string | getResultsFileFormatVersion () const
Returns the value of ResultsFileFormatVersion.
std::string | getResultsFullURL () const
Returns the value of ResultsFullURL.
std::string | getResultsFullURL_2 () const
Returns the value of ResultsFullURL_2.
std::string | getResultsPerlScript () const
Returns the value of ResultsPerlScript.
std::string | getResultsPerlScript_2 () const
Returns the value of ResultsPerlScript_2.
bool | getReviewColDisplay (const MS_REVIEW_COL index) const
Returns ReviewColDisplay by number.
int | getReviewColWidth (const MS_REVIEW_COL index) const
Returns ReviewColWidths by number.
std::string | getSearchLogFile () const
Returns the value of SearchLogFile.
std::string | getSearchSubmitAcceptedFileTypes () const
Returns a list of accepted input file types in the Mascot search form.
std::string | getSearchSubmitDefaultPeptideCharge () const
Returns the value in the CHARGE parameter when the peptide charge control is hidden in the search form.
std::string | getSearchSubmitMode () const
Returns the Mascot search submission mode.
std::string | getSearchSubmitOutputFormat () const
Returns the Mascot search submission output format.
int | getSelectSwitch () const
Returns the value of SelectSwitch.
std::string | getSendmailPath () const
Returns the value of sendmailPath.
double | getShowSubsets () const
Returns the value of ShowSubSets.
double | getSigThreshold () const
Returns the value of SigThreshold.
double | getSiteAnalysisMD10Prob () const
Returns the value of SiteAnalysisMD10Prob.
std::string | getSortUnassigned () const
Returns the value of SortUnassigned.
int | getSpectraPerLibraryBlock () const
Returns the number of spectra in a spectral library block.
std::vector< std::string > | getSpectrumViewerColourSchemeNames () const
Returns the names of all colour schemes (SpectrumViewerColourScheme).
std::string | getSpectrumViewerColourSchemeString (const std::string &name) const
Returns SpectrumViewerColourScheme by name.
std::string | getSpectrumViewerDefaultColourSchemeName () const
Return the name of the default colour scheme (SpectrumViewerDefaultColourScheme).
int | getSplitDataFileSize () const
Returns the value of SplitDataFileSize.
int | getSplitNumberOfQueries () const
Returns the value of SplitNumberOfQueries.
int | getSVGSpectrumSwitch () const
Returns the value of SVGSpectrumSwitch.
double | getTargetFDRPercentage (const int index) const
Returns an element of the TargetFDRPercentages list by its number.
std::string | getTaxBrowserUrl () const
Returns value of the TaxBrowserUrl.
std::string | getTestDirectory () const
Returns the value of TestDirectory.
int | getUniqueJobStartNumber () const
Returns the value of UniqueJobStartNumber.
int | getUnixDirPerm () const
Returns the value of UnixDirPerm.
int | getUnixWebUserGroup () const
Returns the value of UnixWebUserGroup.
INT64 | getVmemory () const
Returns the value of Vmemory.
bool | isAlwaysCreateDat28ResultsFile () const
Returns the value of AlwaysCreateDat28ResultsFile.
bool | isAlwaysEnableAutoDecoySearch () const
Returns true if Mascot always runs an automatic target-decoy search.
bool | isAutoSelectCharge () const
Returns the value of AutoSelectCharge.
bool | isCreateLegacyModAndSubstitutionFiles () const
Returns true if Mascot Monitor creates legacy files containing modification definitions.
bool | isDefaultTargetFDRPercentage (const int index) const
Returns true if the element of TargetFDRPercentages is a default value.
bool | isEmailErrorsEnabled () const
Returns the value of EmailErrorsEnabled.
bool | isEmailUsersEnabled () const
Returns the value of EmailUsersEnabled.
bool | isForkForUnixApache () const
Returns the value of ForkForUnixApache.
bool | isInIgnoreDupeAccessionList (const std::string value) const
Checks to see if the passed database name is in the list databases that shouldn't be checked for duplicate accessions.
bool | isIteratePMFIntensities () const
Returns value of the IteratePMFIntensities.
bool | isLabelAll () const
Returns the value of LabelAll.
bool | isMatchOppositeCrosslinkPairs () const
Returns the value of MatchOppositeCrosslinkPairs.
bool | isMoveOldDbToOldDir () const
Returns the value of MoveOldDbToOldDir.
bool | isPercolator () const
Returns the value of Percolator.
bool | isPercolatorUseProteins () const
Returns the value of PercolatorUseProteins.
bool | isPercolatorUseRT () const
Returns the value of PercolatorUseRT.
bool | isRemoveOldIndexFiles () const
Returns the value of RemoveOldIndexFiles.
bool | isRequireBoldRed () const
Returns the value of RequireBoldRed.
bool | isSaveEveryLastQueryAsc () const
Returns the value of SaveEveryLastQueryAsc.
bool | isSaveLastQueryAsc () const
Returns the value of SaveLastQueryAsc.
bool | isSectionAvailable () const
Indicates whether the section has been actually read from the file.
bool | isShowAllFromErrorTolerant () const
Returns the value of ShowAllFromErrorTolerant.
bool | isShowSubsets () const
Returns the value of ShowSubSets.
bool | isStoreModPermutations () const
Returns the value of StoreModPermutations.
bool | isUnixDirPermDefined () const
Returns true if the UnixDirPerm value is defined.
bool | isUseHTTPProxyForFTP () const
Returns the value of UseHTTPProxyForFTP.
bool | isUseHTTPProxyForHTTPS () const
Returns the value of UseHTTPProxyForHTTPS.
ms_mascotoptions & | operator= (const ms_mascotoptions &right)
C++ style assignment operator.
void | setAlwaysCreateDat28ResultsFile (const bool value)
Sets the value of AlwaysCreateDat28ResultsFile.
void | setAlwaysEnableAutoDecoySearch (const bool value)
Sets AlwaysEnableAutoDecoySearch.
void | setAutoSelectCharge (const bool value)
Sets AutoSelectCharge.
void | setCacheDirectory (const char *value)
Sets CacheDirectory.
void | setCentroidWidth (const double value)
Sets CentroidWidth.
void | setCentroidWidthCount (const int value)
Sets CentroidWidthCount.
void | setCompressToolAA (const std::string value)
Sets CompressTool_AA.
void | setCompressToolNA (const std::string value)
Sets CompressTool_NA.
void | setCompressToolSL (const std::string value)
Sets CompressTool_NA.
void | setCrawlerNumPeaksPer100Da (const int value)
Sets the number of peaks to output in each 100 Da window for the library crawler.
void | setCreateLegacyModAndSubstitutionFiles (const bool value)
Sets an option for backwards compatibility with very old software.
void | setCreatePipThreadBlockSize (const int blockSize)
Sets CreatePipThreadBlockSize.
void | setCreatePipThreads (const int nThreads)
Sets CreatePipThreads.
void | setDechargeFragmentPeaks (const int maxCharge)
Sets the maximum fragment ion charge state to be decharged.
void | setDecoyTypeNoEnzyme (const int value)
Sets DecoyTypeNoEnzyme.
void | setDecoyTypeSpecific (const int value)
Sets DecoyTypeSpecific.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setDefaultTargetFDRPercentage (const int index)
Makes an element of TargetFDRPercentages at the given index the default value.
void | setDisplayNonSignificantMatches (const int value)
Sets DisplayNonSignificantMatches.
void | setEmailErrorsEnabled (const bool value)
Sets EmailErrorsEnabled.
void | setEmailFromTextName (const char *str)
Sets EmailFromTextName.
void | setEmailFromUser (const char *str)
Sets EmailFromUser.
void | setEmailPassword (const char *str)
Sets EmailPassword.
void | setEmailProfile (const char *str)
Sets EmailPassword.
void | setEmailService (const char *str)
Sets EmailService.
void | setEmailTimeOutPeriod (const int value)
Sets EmailTimeOutPeriod.
void | setEmailUsersEnabled (const bool value)
Sets EmailUsersEnabled.
void | setErrMessageEmailTo (const char *str)
Sets ErrMessageEmailTo.
void | setErrorLogFile (const char *str)
Sets ErrorLogFile path.
void | setErrTolMaxAccessions (const int value)
Sets ErrTolMaxAccessions.
void | setExecAfterSearch (const int num, std::string value)
Sets ExecAfterSearch_XXX.
void | setFeatureTableLength (const int value)
Sets FeatureTableLength.
void | setFeatureTableMinScore (const double value)
Sets FeatureTableMinScore.
void | setForkForUnixApache (const bool value)
Sets ForkForUnixApache.
void | setFormVersion (const char *str)
Sets FormVersion.
void | setGetSeqBlastAccession (const ms_blastaccession *value)
Sets GetSeqBlastAccession.
void | setGetSeqJobIdFile (const char *str)
Sets GetSeqJobIdFile.
void | setICATFilter (const char *filterString)
Sets ICATFilter.
void | setICATHeavy (const char *modName)
Sets ICATHeavy.
void | setICATLight (const char *modName)
Sets ICATLight.
void | setICATQuantitationMethod (const char *methodName)
Sets ICATQuantitationMethod.
void | setIgnoreDupeAccession (const unsigned int index, const std::string value)
Sets an item in the IgnoreDupeAccessions list by its index.
void | setIgnoreIonsScoreBelow (const double value)
Sets IgnoreIonsScoreBelow.
void | setIntensitySigFigs (const int value)
Sets IntensitySigFigs.
void | setInterFileBasePath (const char *str)
Sets InterFileBasePath.
void | setInterFileRelPath (const char *str)
Sets InterFileRelPath.
void | setIonsDecimalPlaces (const int value)
Sets IonsDecimalPlaces.
void | setIteratePMFIntensities (const bool value)
Sets IteratePMFIntensities.
void | setLabelAll (const bool value)
Sets LabelAll.
void | setLastQueryAscFile (const char *str)
Sets LastQueryAscFile to the passed value.
void | setLogoImageFile (const char *str)
Sets LogoImageFile.
void | setMailTempFile (const char *str)
Sets MailTempFile.
void | setMailTransport (const int value)
Sets MailTransport.
void | setMascNodeCtrlFile (const char *str)
Sets MascNodeCtrlFile.
void | setMascotCmdLine (const char *str)
Sets MascotCmdLine.
void | setMascotControlFile (const char *str)
Sets MascotControlFile.
void | setMascotFileProcessingThreads (const int value)
Sets MascotFileProcessingThreads.
void | setMascotJobIdFile (const char *str)
Sets MascotJobIdFile.
void | setMascotMessage (const char *str)
Sets MascotMessage.
void | setMassDecimalPlaces (const int value)
Sets MassDecimalPlaces.
void | setMatchOppositeCrosslinkPairs (const bool value)
Sets MatchOppositeCrosslinkPairs.
void | setMaxConcurrentSearches (const int value)
Sets MaxConcurrentSearches.
void | setMaxDatabases (const int value)
Sets MaxDatabases.
void | setMaxDescriptionLen (const int value)
Sets MaxDescriptionLen.
void | setMaxEtagMassDelta (const double value)
Sets MaxEtagMassDelta.
void | setMaxEtVarMods (const int value)
Sets MaxEtVarMods.
void | setMaxIntactCrosslinkPeptides (const int value)
Sets MaxIntactCrosslinkPeptides.
void | setMaxNumPeptides (const int value)
Sets MaxNumPeptides.
void | setMaxPepModArrangements (const int value)
Sets MaxPepModArrangements.
void | setMaxPepNumModifiedSites (const int value)
Sets MaxPepNumModifiedSites.
void | setMaxPepNumVarMods (const int value)
Sets MaxPepNumVarMods.
void | setMaxQueries (const int value)
Sets MaxQueries.
void | setMaxSearchesPerUser (const int value)
Sets MaxSearchesPerUser.
void | setMaxSequenceLen (const int value)
Sets MaxSequenceLen.
void | setMaxVarMods (const int value)
Sets MaxVarMods.
void | setMinEtagMassDelta (const double value)
Sets MinEtagMassDelta.
void | setMinPepLenInPepSummary (const int value)
Sets MinPepLenInPepSummary.
void | setMinPepLenInSearch (const int value)
Sets MinPepLenInSearch.
void | setMonitorEmailCheckFreq (const int value)
Sets MonitorEmailCheckFreq.
void | setMonitorLogFile (const char *str)
Sets MonitorLogFile.
void | setMonitorPidFile (const char *str)
Sets MonitorPidFile.
void | setMonitorTestTimeout (const int value)
Sets MonitorTestTimeout.
void | setMoveOldDbToOldDir (const bool value)
Sets MoveOldDbToOldDir.
void | setMudpit (const int value)
Sets Mudpit.
void | setMudpitSwitch (const double value)
Sets MudpitSwitch.
void | setNoResultsScript (const char *str)
Sets NoResultsScript.
void | setNTIUserGroup (const char *str)
Sets NTIUserGroup.
void | setNTMonitorGroup (const char *str)
Sets NTMonitorGroup.
void | setPepSearchTool (const std::string value)
Sets LibrarySearch.
void | setPercolator (const bool value)
Sets Percolator.
void | setPercolatorExeFlags (const char *value)
Sets PercolatorExeFlags.
void | setPercolatorFeatures (std::string value)
Sets PercolatorFeatures.
void | setPercolatorMinQueries (const int value)
Sets PercolatorMinQueries.
void | setPercolatorMinSequences (const int value)
Sets PercolatorMinSequences.
void | setPercolatorTargetRankRelativeThreshold (const double threshold)
Sets PercolatorTargetRankRelativeThreshold.
void | setPercolatorTargetRankScoreThreshold (const int threshold)
Sets PercolatorTargetRankScoreThreshold.
void | setPercolatorUseProteins (const bool value)
Sets PercolatorUseProteins.
void | setPercolatorUseRT (const bool value)
Sets PercolatorUseRT.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPrecursorCutOutLowerLimit (const double value)
Sets the first PrecursorCutOut.
void | setPrecursorCutOutUpperLimit (const double value)
Sets the second PrecursorCutOut.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setProteinFamilySwitch (const int value)
Sets ProteinFamilySwitch.
void | setProteinsInResultsFile (const int value)
Sets ProteinsInResultsFile.
void | setProxyPassword (const char *str)
Sets proxy_password.
void | setProxyServer (const char *str)
Sets proxy_server.
void | setProxyType (const std::string &value)
Sets ProxyType.
void | setProxyUsername (const char *str)
Sets proxy_username.
void | setRemoveOldIndexFiles (const bool value)
Sets RemoveOldIndexFiles.
void | setReportBuilderColumnArrangement (const int index, const std::string str)
Sets ReportBuilderColumnArrangement.
void | setReportNumberChoice (const int index, const int value)
Sets an element of the ReportNumberChoices list by its index.
void | setRequireBoldRed (const bool value)
Sets RequireBoldRed.
void | setResfileCache (const char *value)
Sets ResfileCache.
void | setResultsCache (const char *value)
Sets ResultsCache.
void | setResultsFileFormatVersion (const char *value)
Sets ResultsFileFormatVersion.
void | setResultsFullURL (const char *str)
Sets ResultsFullURL.
void | setResultsFullURL_2 (std::string value)
Sets ResultsFullURL_2.
void | setResultsPerlScript (const char *str)
Sets ResultsPerlScript.
void | setResultsPerlScript_2 (std::string value)
Sets ResultsPerlScript_2.
void | setReviewColDisplay (const MS_REVIEW_COL index, const bool value)
Sets ReviewColDisplay.
void | setReviewColWidth (const MS_REVIEW_COL index, const int value)
Sets ReviewColWidths.
void | setSaveEveryLastQueryAsc (const bool flag)
Sets SaveEveryLastQueryAsc to 1 or 0.
void | setSaveLastQueryAsc (const bool flag)
Sets SaveLastQueryAsc to 1 or 0.
void | setSearchLogFile (const char *str)
Sets SearchLogFile.
void | setSearchSubmitAcceptedFileTypes (const std::string value)
Sets the accepted input file types in the Mascot search form.
void | setSearchSubmitDefaultPeptideCharge (const std::string value)
Sets the default peptide charge when not specified in the input file.
void | setSearchSubmitMode (const std::string value)
Sets the Mascot search submission mode.
void | setSearchSubmitOutputFormat (const std::string value)
Sets the Mascot search submission output format.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.
void | setSelectSwitch (const int value)
Sets SelectSwitch.
void | setSendmailPath (const char *str)
Sets sendmailPath.
void | setShowAllFromErrorTolerant (const bool value)
Sets ShowAllFromErrorTolerant.
void | setShowSubsets (const bool value)
Sets ShowSubSets.
void | setShowSubsets (const double value)
Sets ShowSubSets.
void | setSigThreshold (const double value)
Set the SigThreshold.
void | setSiteAnalysisMD10Prob (const double value)
Set the SiteAnalysisMD10Prob.
void | setSortUnassigned (const std::string newValue)
Sets SortUnassigned.
void | setSpectraPerLibraryBlock (const int value)
Sets the number of spectra in a spectral library block.
void | setSpectrumViewerColourSchemeString (const std::string &name, const std::string &str, bool doCheck=true)
Sets SpectrumViewerColourScheme.
void | setSpectrumViewerDefaultColourSchemeName (const std::string &name)
Sets the default colour scheme name (SpectrumViewerDefaultColourScheme).
void | setSplitDataFileSize (const int value)
Sets SplitDataFileSize.
void | setSplitNumberOfQueries (const int value)
Sets SplitNumberOfQueries.
void | setStoreModPermutations (const bool value)
Sets StoreModPermutations.
void | setSVGSpectrumSwitch (const int value)
Sets SVGSpectrumSwitch.
void | setTargetFDRPercentage (const int index, const double value, const bool makeDefault=false)
Sets an element of the TargetFDRPercentages list by its index.
void | setTaxBrowserUrl (const std::string value)
Sets TaxBrowserURL.
void | setTestDirectory (const char *str)
Sets TestDirectory.
void | setUniqueJobStartNumber (const int value)
Sets UniqueJobStartNumber.
void | setUnixDirPerm (const int value)
Sets UnixDirPerm.
void | setUnixWebUserGroup (const int value)
Sets UnixWebUserGroup.
void | setUseHTTPProxyForFTP (const bool value)
Sets UseHTTPProxyForFTP.
void | setUseHTTPProxyForHTTPS (const bool value)
Sets UseHTTPProxyForHTTPS.
void | setVmemory (const INT64 value)
Sets Vmemory.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

An instance of this class represents all the parameters specified in the Options section of mascot.dat.

An instance of this class is created and populated in ms_datfile.

It can also be created separately and initialized with default values. One can create an instance of the class or copy from another instance in order to pass it then as an options containing object.

For detailed information on any of the options please consult Mascot manual.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples
config_mascotdat.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

◆ DECOY_ALGORITHM

enum DECOY_ALGORITHM

Definitions for how the decoy sequences are generated.

In Mascot 2.4 and later, DecoyTypeSpecific and DecoyTypeNoEnzyme control how the decoy database is generated. The strategies are based on the classification by G. Wang, et al. (2009), "Decoy Methods for Assessing False Positives and False Discovery Rates in Shotgun Proteomics", Anal Chem. 81(1):146-159 (doi: 10.1021/ac801664q).

There are four protein based strategies and four peptide based strategies.

The peptide based strategies are not supported for getDecoyTypeNoEnzyme() and if specified in mascot.dat, the corresponding protein based strategy will be returned.

For the peptide based strategies, with a semi-specific search, the protein sequences are generated in the same way as if the search was fully specific, rather than preserving the terminii of the non-specific terminus. A similar rule is applied for missed cleavages: i.e. the two residues either side of the missed cleavage site will be the same as in the target sequence.

This value is returned by getDecoyTypeSpecific() and getDecoyTypeNoEnzyme() See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
DECOY_ALGORITHM_NONE | (0) No algorithm defined. An invalid value.
DECOY_PROTEIN_REVERSE | (1) Reverse the sequence of each protein entry. For a nucleic acid database, the bases are reversed before translation.
DECOY_PEPTIDE_REVERSE | (2) Digest each protein sequence into peptides, then reverse the resulting peptide sequences, but keep the same terminal residues.
DECOY_PROTEIN_RANDOM | (3) For each protein entry, generate a random sequence of the same length, with the composition based on the average composition of the whole database. This is the default in Mascot 2.3 and earlier. For nucleic acid databases, the randomised sequence is generated before translation.
DECOY_PEPTIDE_RANDOM | (4) Digest each protein sequence into peptides, then generate a random sequence for each peptide, as for DECOY_PROTEIN_RANDOM, but keep the same terminal residues and don't introduce new cutting sites. If this option is specified and a nucleic acid database is searched, DECOY_PROTEIN_RANDOM is used.
DECOY_PROTEIN_RANDOM_DIPEP | (5) Protein sequence randomization based on dipeptide frequency (randomDipep): for each protein, an amino acid is randomly chosen according to their frequency distribution as the N-terminal. Each amino acid generated thereafter is based on the occurrence frequency of each dipeptide that starts with its preceding neighboring amino acid. Decoy sequences created this way are expected to have similar amino acid composition and nearest-neighbor frequencies of the target database. (Not implemented in Mascot 2.4).
DECOY_PEPTIDE_RANDOM_DIPEP | (6) Digest each protein sequence into peptides, but generate random dipeptide sequences for each peptide as in DECOY_PROTEIN_RANDOM_DIPEP, keeping the same terminal residues. (Not implemented in Mascot 2.4).
DECOY_PROTEIN_SHUFFLE | (7) Randomise the order of amino acids in each protein sequence using the STL random_shuffle algorithm: http://www.cplusplus.com/reference/algorithm/random_shuffle/ .
DECOY_PEPTIDE_SHUFFLE | (8) Digest each protein sequence into peptides, but shuffle their sequence as in DECOY_PROTEIN_SHUFFLE, excluding the terminus residue.
DECOY_PROTEIN_BASED_MASK | If the value AND'ed with this is '1', then the algorithm is protein based. (Protein based strategies have value 1,3,5,7)

◆ EXEC_AFTER_SEARCH

enum EXEC_AFTER_SEARCH

Definitions for the ExecAfterSearch_XXX lines in the Options section of mascot.dat.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
MAX_EXEC_AFTER_SEARCH

The maximum value for setExecAfterSearch () abd getExecAfterSearch()

◆ MS_REVIEW_COL

enum MS_REVIEW_COL

Definitions for columns in ms-review.exe for use with getReviewColWidth() and getReviewColDisplay().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
MS_REVIEW_COL_JOB | The job number column.
MS_REVIEW_COL_PID | The process ID column.
MS_REVIEW_COL_DATABASE | The database name column.
MS_REVIEW_COL_USERNAME | The USERNAME column.
MS_REVIEW_COL_USEREMAIL | The USEREMAIL column.
MS_REVIEW_COL_TITLE | The search title (COM) column.
MS_REVIEW_COL_RESULTS_FILE | The results file name column.
MS_REVIEW_COL_START_TIME | The job start time and date column.
MS_REVIEW_COL_DURATION | The job duration column (seconds).
MS_REVIEW_COL_STATUS | The job status column - normally 'User read res'.
MS_REVIEW_COL_PRIORITY | The job priority column (0 = normal priority).
MS_REVIEW_COL_SEARCHTYPE | The job search type column (PMF, MIS or SQ).
MS_REVIEW_COL_ENZYMEUSED | The job enzyme used column (Yes or No).
MS_REVIEW_COL_IPADDRESS | The IP address from where the search was submitted.
MS_REVIEW_COL_USERID | The USERID of the user who submitted the search.
MS_REVIEW_COL_PEAKLISTDATAFILE | The name of the data file.
MS_REVIEW_COL____LAST___ | Placeholder.

◆ NUMERICAL_VALUE_STORAGE

enum NUMERICAL_VALUE_STORAGE

Definitions for storage of numerical values in files.

Enumerator
MASS_DECIMAL_PLACES

Decimal places used when storing mass values as strings in files.

◆ PERC_EXE_RT

enum PERC_EXE_RT

Definitions for retention time override when calling getPercolatorExeFlags().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
PERC_EXE_RT_USE_DEFAULT | Use the default value in mascot.dat.
PERC_EXE_RT_FORCE_ON | Override the value in mascot.dat, forcing the use of retention times.
PERC_EXE_RT_FORCE_OFF | Override the value in mascot.dat, turning off the use of retention times.

Constructor & Destructor Documentation

◆ ms_mascotoptions() [1/2]

ms_mascotoptions ( )

Default constructor.

See ms_datfile::getMascotOptions() for the most common way to create an ms_mascotoptions object.

◆ ms_mascotoptions() [2/2]

ms_mascotoptions ( const ms_mascotoptions & src )

Copying constructor.

See ms_datfile::getMascotOptions() for the most common way to create an ms_mascotoptions object.

Parameters
src reference to a valid ms_mascotoptions object

Member Function Documentation

◆ appendIgnoreDupeAccession()

void appendIgnoreDupeAccession ( const std::string value )

Appends a database to the list databases that shouldn't be checked for duplicate accessions.

When FASTA files are compressed, they are checked to ensure that there are no duplicate accession strings. For a large EST database with many millions of entries, this can take up a lot of memory. Adding a database to the list of values for the IgnoreDupeAccessions entry in mascot.dat prevents this database from being tested.

Add a database to the list.

Parameters
value is the name of the database to add to the list.

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendReportNumberChoice()

void appendReportNumberChoice ( const int value )

Append a value to the ReportNumberChoices list.

See getReportNumberChoice() for more information. If the provided value is not valid, the existing value will be kept.

Parameters
value is the value to be appended to the list.

◆ appendTargetFDRPercentage()

void appendTargetFDRPercentage | ( | const double | value,
 |  | const bool | makeDefault = false
 | ) |  |

Append a value to the TargetFDRPercentages list.

See getTargetFDRPercentage() for more information. If the provided value is not valid, the list will be unchanged.

Parameters
value | is the value to be appended to the list.
makeDefault | controls whether the new element should be made the default item in the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ clearIgnoreDupeAccessions()

void clearIgnoreDupeAccessions ( )

Clears the list of databases that shouldn't be checked for duplicate accessions.

When FASTA files are compressed, they are checked to ensure that there are no duplicate accession strings. For a large EST database with many millions of entries, this can take up a lot of memory. Adding a database to the list of values for the IgnoreDupeAccessions entry in mascot.dat prevents this database from being tested.

See also
getNumberOfIgnoreDupeAccessions(), getIgnoreDupeAccession()

◆ clearReportNumberChoices()

void clearReportNumberChoices ( )

Deletes all ReportNumberChoices values from the list.

See getNumberOfReportNumberChoices().

◆ clearTargetFDRPercentages()

void clearTargetFDRPercentages ( )

Deletes all TargetFDRPercentages values from the list.

See getNumberOfTargetFDRPercentages().

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getCacheDirectory()

std::string getCacheDirectory ( ) const

Returns the value of CacheDirectory.

See Caching Mascot Results.

The value returned by this function may have an 'encoded' string which requires interpretation by the calling application. For this reason, it is normally easier to call ms_mascotresfilebase::getCacheDirectory().

Parameter | CacheDirectory
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data/cache/%Y/%m
Value in mascot.dat | ../data/cache/%Y/%m
Returns
the directory.

◆ getCentroidWidth()

double getCentroidWidth ( ) const

Returns the value of CentroidWidth.

The width in Daltons of the sliding window used for re-centroiding profile data.

Parameter | CentroidWidth
Permitted values | Floating point > 0 and less than 10.0
Default (if no parameter in mascot.dat) | 0.25
Value in mascot.dat | 0.25
Returns
the width in Da.

◆ getCentroidWidthCount()

int getCentroidWidthCount ( ) const

Returns the value of CentroidWidthCount.

Centroiding is applied to a scan when the number of peaks in the scan exceeds CentroidWidthCount.

Parameter | CentroidWidthCount
Permitted values | Positive integer > 0
Default (if no parameter in mascot.dat) | 1000
Value in mascot.dat | 1000
Returns
the peak count threshold.

◆ getCompressToolAA()

std::string getCompressToolAA ( ) const

Returns the value of CompressTool_AA.

Not implemented (at version 2.6)

See also
getCompressToolSL(), getCompressToolNA() and getCompressToolCommandLineFasta()
Parameter | CompressTool_AA
Permitted values | Any non empty text string. Should contain $dbname and $dbpath
Default
(if no parameter in mascot.dat) 		"../bin/ms-compress.exe $dbname $dbpath"
Value in mascot.dat | "../bin/ms-compress.exe $dbname $dbpath"
Returns
raw compress tool command line from mascot.dat

◆ getCompressToolCommandLineFasta()

std::string getCompressToolCommandLineFasta | ( | DATABASE_TYPE | dbType,
 |  | const std::string & | dbname,
 |  | const std::string & | dbpath
 | ) |  | const

Get command line to compress fasta, eg ms-compress.exe.

CURRENTLY NOT IN USE

Parameters
dbType | Database type, AA or NA
dbname | Name of the database
dbpath | Full path to the database file
Returns
complete compress tool command line for a fasta

◆ getCompressToolCommandLineLibrary()

std::string getCompressToolCommandLineLibrary | ( | const std::string & | logfilepath,
 |  | const std::string & | inputfile,
 |  | const std::string & | outputdirectory
 | ) |  | const

Get command line to compress library, eg lib2nistcl.exe.

This function is called by ms-monitor.exe to get the command line required to compress (or otherwise prepare) a spectral library. It calls getCompressToolSL which contains a number of 'tags' which need to be replaced with search specific parameters. In theory, any tool could be used instead of lib2nistcl.exe . This function replaces the following tags with the corresponding variable passed to this function:

  • $logfile is replaced with logfilepath
  • $inputfile is replaced with inputfile
  • $outputdirectory is replaced with outputdirectory
See also
getCompressToolSL()
Parameters
logfilepath | full path to the log file that the tool will create. The contents of this file are inserted into the .stats file.
inputfile | full path to the input file. Typically an msp file, but could be any format supported by the tool.
outputdirectory | path to the output directory. For lib2nistcl, this is a directory, but it could be a filename.
Returns
complete compress tool command line for a spectral library

◆ getCompressToolNA()

std::string getCompressToolNA ( ) const

Returns the value of CompressTool_NA.

Not implemented (at version 2.6)

See also
getCompressToolSL() and getCompressToolAA() and getCompressToolCommandLineFasta()
Parameter | CompressTool_NA
Permitted values | Any non empty text string. Should contain $dbname and $dbpath
Default
(if no parameter in mascot.dat) 		"../bin/ms-compress.exe $dbname $dbpath"
Value in mascot.dat | "../bin/ms-compress.exe $dbname $dbpath"
Returns
raw compress tool command line from mascot.dat

◆ getCompressToolSL()

std::string getCompressToolSL ( ) const

Returns the value of CompressTool_NA.

See also
getCompressToolAA(), getCompressToolNA() and getCompressToolCommandLineLibrary
Parameter | CompressTool_SL
Permitted values | Any non empty text string. Should contain $logfile, $inputfile and $outputdirectory
Default
(if no parameter in mascot.dat) 		"../bin/NIST/lib2nistcl/lib2nistcl.exe -log9 $logfile -msp2peplib $inputfile $outputdirectory"
Value in mascot.dat | "../bin/NIST/lib2nistcl/lib2nistcl.exe -log9 $logfile -msp2peplib $inputfile $outputdirectory"
Returns
raw compress tool command line from mascot.dat

◆ getCrawlerNumPeaksPer100Da()

int getCrawlerNumPeaksPer100Da ( ) const

Returns the number of peaks to output in each 100 Da window for the library crawler.

The number of highest-intensity peaks to choose from each 100 Da window of the observed spectrum when creating the library spectrum.

Parameter | CrawlerNumPeaksPer100Da
Permitted values | Any integer > 0.
Default (if no parameter in mascot.dat) | 100
Value in mascot.dat | 100
Returns
the number of peaks to choose from each 100 Da window

◆ getCreatePipThreadBlockSize()

int getCreatePipThreadBlockSize ( ) const

Returns the value of CreatePipThreadBlockSize.

Mascot 2.8 and later parallelises the calculation of the Percolator features. Each thread calculates the features in blocks of queries whose size is specified by this option. This option is not implemented in Mascot 2.7 and earlier.

See Using Percolator scores for further information.

Permitted values | An integer greater than 0
Default (if no parameter in mascot.dat) | 2000
Value in mascot.dat | 2000
Returns
Number of queries processed by each thread.

◆ getCreatePipThreads()

int getCreatePipThreads ( ) const

Returns the value of CreatePipThreads.

Mascot 2.8 and later parallelises the calculation of the Percolator features. If the value of this option is set to -1, all available threads will be used. This option is not implemented in Mascot 2.7 and earlier.

See Using Percolator scores for further information.

Permitted values | Any iteger greater or equal to -1
Default (if no parameter in mascot.dat) | 4
Value in mascot.dat | 4
Returns
Number of threads used in ms-createpip.exe.

◆ getDechargeFragmentPeaks()

int getDechargeFragmentPeaks ( ) const

Return the maximum fragment ion charge state to be decharged.

Fragment ion peak charges can be specified in Mascot Generic Format. Mascot Server only looks for 1+ and 2+ fragment ions, so higher charge states will not be matched unless they are de-charged.

If the charge specified for a particular fragment in the MGF file is less than or equal to the value returned by this function, then the m/z value will be decharged to the singly charged MH+ value before searching.

Some instruments will never produce very high charge states, but the peak detection software may incorrectly report a very high charge state. Setting this value to a sensible maximum charge state will prevent decharging of these fragment peaks. A value of zero will prevent any decharging.

Parameter | DechargeFragmentPeaks
Permitted values | Zero or a positive integer
Default (if no parameter in mascot.dat) | 10
Value in mascot.dat | 10
Returns
currently defined value.

◆ getDecoyTypeNoEnzyme()

int getDecoyTypeNoEnzyme ( ) const

Returns the value of DecoyTypeNoEnzyme.

Mascot 2.2 introduced automatic decoy searches. Any search can be run simultaneously against a randomised decoy database, which is generated on the fly.

See ms_mascotoptions::DECOY_ALGORITHM for a description of the possible values. However, only PROTEIN based strategies are supported for no-enzyme searches.

Only the following values are implemented for no-enzyme searches:

  • ms_mascotoptions::DECOY_PROTEIN_REVERSE
  • ms_mascotoptions::DECOY_PROTEIN_RANDOM (default)
  • ms_mascotoptions::DECOY_PROTEIN_SHUFFLE

The other values may be implemented in future versions of Mascot and are thus reserved values. Setting DecoyTypeNoEnzyme to any of them will select the default strategy (3).

For a search with an enzyme specified, see getDecoyTypeSpecific().

Parameter | DecoyTypeNoEnzyme
Permitted values | 1, 2, 3, 4, 5, 6, 7, 8
Default (if no parameter in mascot.dat) | 3
Value in mascot.dat | 3
Returns
the decoy search type for a no-enzyme search.

◆ getDecoyTypeSpecific()

int getDecoyTypeSpecific ( ) const

Returns the value of DecoyTypeSpecific.

Mascot 2.2 introduced automatic decoy searches. Any search can be run simultaneously against a randomised decoy database, which is generated on the fly.

See ms_mascotoptions::DECOY_ALGORITHM for a description of the possible values.

Only the following values are implemented:

  • ms_mascotoptions::DECOY_PROTEIN_REVERSE (default)
  • ms_mascotoptions::DECOY_PEPTIDE_REVERSE
  • ms_mascotoptions::DECOY_PROTEIN_RANDOM
  • ms_mascotoptions::DECOY_PEPTIDE_RANDOM
  • ms_mascotoptions::DECOY_PROTEIN_SHUFFLE
  • ms_mascotoptions::DECOY_PEPTIDE_SHUFFLE

The other values may be implemented in future versions of Mascot and are thus reserved values. Setting DecoyTypeSpecific to any of them will select the default strategy (1).

For a search with no enzyme specified, see getDecoyTypeNoEnzyme().

Parameter | DecoyTypeSpecific
Permitted values | 1, 2, 3, 4, 5, 6, 7, 8
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 2
Returns
the decoy search type for an ordinary search.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getDisplayNonSignificantMatches()

int getDisplayNonSignificantMatches ( ) const

Returns the value of DisplayNonSignificantMatches.

In Mascot 2.5 and earlier, the search reports show an input field for "Ignore ions score below". The control allows filtering out non-significant or uninteresting peptide matches by score or expect value.

In Mascot 2.6 and later, the search reports show either a checkbox for "Display non-significant matches" or the edit field from previous versions, depending on the value of DisplayNonSignificantMatches: if 0 or 1, display the checkbox, and if 2, display the edit field. Additionally, 0 means the checkbox is unchecked by default and 1 means checked.

Parameter | DisplayNonSignificantMatches
Permitted values | 0, 1, 2
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 0
Returns
form control type for filtering out non-significant matches.

◆ getEmailFromTextName()

std::string getEmailFromTextName ( ) const

Returns the value of EmailFromTextName.

The EmailFromTextName value is the text name of the sender of all messages For example, if the email is from "Mascot Server <sender@somewhere.com>", then "Mascot Server" is the EmailFromTextName value. The default value of 'your_domain' in earlier versions of mascot.dat was somewhat confusing.

Used by all e-mail configurations.

See also
getEmailFromUser(), getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | EmailFromTextName
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | Mascot
Returns
the name from which messages are sent.

◆ getEmailFromUser()

std::string getEmailFromUser ( ) const

Returns the value of EmailFromUser.

EmailFromUser is the email address which will appear in the From field of the email message. Used by all e-mail configurations.

See also
getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | EmailFromUser
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | your_id
Returns
the email address from which messages are sent.

◆ getEmailPassword()

std::string getEmailPassword ( ) const

Returns the value of EmailPassword.

EmailPassword is the password (if any) required to log onto MAPI or CMC.

See also
getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | EmailPassword
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | your_password
Returns
the password for the email service.

◆ getEmailProfile()

std::string getEmailProfile ( ) const

Returns the value of EmailProfile.

EmailProfile is the MAPI profile name.

See also
getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | EmailProfile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | your_profile
Returns
the name for the MAPI email profile.

◆ getEmailService()

std::string getEmailService ( ) const

Returns the value of EmailService.

EmailService is the service name (CMC only).

See also
getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | EmailService
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | your_service
Returns
the name of the CMC email service.

◆ getEmailTimeOutPeriod()

int getEmailTimeOutPeriod ( ) const

Returns the value of EmailTimeOutPeriod.

See isEmailUsersEnabled() for information on this parameter.

Parameter | EmailTimeOutPeriod
Permitted values | Any positive integer
Default (if no parameter in mascot.dat) | 120
Value in mascot.dat | 120
Returns
The timeout period in seconds.

◆ getErrMessageEmailTo()

std::string getErrMessageEmailTo ( ) const

Returns the value of ErrMessageEmailTo.

If EmailErrorsEnabled is set to 1, serious error messages will be emailed to ErrMessageEmailTo.

See also
isEmailErrorsEnabled().
Parameter | ErrMessageEmailTo
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | admin.nosp@m.istr.nosp@m.ator@.nosp@m.your.nosp@m..doma.nosp@m.in
Returns
the email address to which messages are sent.

◆ getErrorLogFile()

std::string getErrorLogFile ( ) const

Returns the value of ErrorLogFile.

This defines where error messages should be stored.

Parameter | ErrorLogFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../logs/errorlog.txt
Value in mascot.dat | [not defined]
Returns
the full (or relative) path to the errorlog file.

◆ getErrTolMaxAccessions()

int getErrTolMaxAccessions ( ) const

Returns the value of ErrTolMaxAccessions.

The maximum number of accessions allowed for an 'old style' error-tolerant search.

A value of zero indicates no limit

Parameter | ErrTolMaxAccessions
Permitted values | Any integer >= 0
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns
the maximum number of accessions.

◆ getExecAfterSearch()

int getExecAfterSearch | ( | const char * | szResultsFilePath,
 |  | std::vector< std::string > & | commands,
 |  | std::vector< std::string > & | titles,
 |  | std::vector< int > & | waitfor,
 |  | std::vector< int > & | logging,
 |  | std::vector< std::string > & | additionalFlags,
 |  | const char * | sessionID = 0,
 |  | const char * | taskID = 0
 | ) |  | const

Returns the values of the ExecAfterSearch_XXX parameters.

After each search, a number of 'user' programs can be run. For example, Percolator may be run after each search.

Parameter | ExecAfterSearch_XXX
Permitted values Text string of the format:
flag:num[;flag:num], title string, command
where
  • flag:num can be one or more of flag:value pairs from the table below
  • title string is the (optional) text output by nph-mascot while the process is running. For example "Percolating...". The title must not contain a comma!
  • command should be a unix/windows command string. It may contain one or more of tags as described below
Default
(if no parameter in mascot.dat) 		[empty]
Value in mascot.dat | ExecAfterSearch_2 waitfor:0;logging:0;percolator:1, Percolating, ../bin/percolator.exe $PercolatorExeFlags

The following flags may be specified:

flag | Acceptable 'num' | Description
waitfor | 0 or 1..10 | This command should not be run until the command specified by the waitfor has finished. A value of 0 indicates 'don't wait'.
logging 0..3 The values indicate the level of logging. Messages are put into errorlog.txt:
  • 0 - No logging
  • 1 - Log successful commands (return code 0)
  • 2 - Log unsuccessful commands (return code not 0)
  • 3 - Log successful and unsuccessful commands
percolator | 0 or 1 | This command will only be run if Percolator is set to 1 in mascot.dat and if the search meets the criteria to percolate results. See Using Percolator scores
cgienv | 0 or 1 | Default is 1. When nph-mascot.exe runs the command specified, it uses spawn/exec so all the same environment variables available to nph-mascot.exe are set. When this includes cgi environment variables, it can cause confusion and problems for some perl scripts such as export_dat.pl, where the script behaves differently when running as cgi process. Setting this flag to 0 ensures that all the cgi environment variables, such as =CONTENT_LENGTH= and =SCRIPT_NAME= are cleared before the process is run.

For consistency with ms_mascotresfilebase::staticGetPercolatorFileNames() and ms_mascotresfilebase::setPercolatorFeatures(), it is important to set PercolatorExeFlags correctly before calling this method. Otherwise, this method may generate a pip or pop filename different from setPercolatorFeatures().

    bool anyRT = (whether any query has RTINSECONDS);
    std::string percolatorFlags = options.getPercolatorRtFlags(anyRT, options.isPercolatorUseRT());
    options.setPercolatorExeFlags(percolatorFlags.c_str());

The following tags will be replaced. (Note that it would potentially be unsafe to add a tag for a value that can be entered by the user in a search form, e.g. a user could enter cat /etc/passwd as their username).

Tag | Replaced with
%resultfilepath | The passed szResultsFilePath
%resultfilename | The filename part of the passed szResultsFilePath
%percolator_pip | The input file from ms_mascotresfilebase::staticGetPercolatorFileNames()
%percolator_decoy_pop | The decoy output file from ms_mascotresfilebase::staticGetPercolatorFileNames()
%percolator_target_pop | The target output file from ms_mascotresfilebase::staticGetPercolatorFileNames()
%session_id | Is replaced by the passed sessionID parameter
%task_id | Is replaced by the passed taskID parameter
$PercolatorExeFlags | This flag is not replaced by this function! nph-mascot calls getPercolatorExeFlags() to replace it.

A set of vectors is returned from this function. Currently, each vector will have 10 entries, corresponding to ExecAfterSearch_1 ... ExecAfterSearch_10, but this value may be increased in future. The calling application should use the size of the vectors rather than hardcode the number 10. Note that many (or all) of the commands may be empty.

Parameters
szResultsFilePath | is the path to the results file.
commands | is a vector, containing the list of commands to be run. the flags and titles will have been stripped from the command, and any tags in the commands will have been replaced by values as described above. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
titles | is a vector containing the text to be output will the process is running. For example: "Creating XML output....". See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
waitfor | is a vector of integers containing the dependency for each commands to be run. A value of 0 indicates that the command should be run immediately without waiting for another one to finish. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
logging | is a vector of integers containing the logging level for each commands to be run. A value of 0 indicates that no entries should be added to the errorlog.txt file. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
additionalFlags | is a vector of strings containing any flags apart from the waitfor or logging flag. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
sessionID | is the session identifier for the search. See ms_session::ms_session. This value is passed to the search engine using the –sessionID parameter.
taskID | is the task identifier for the search and is normally obtained by calling ms-searchcontrol.exe or client.pl. It is passed to nph-mascot.exe using the –taskID parameter.
Returns
the total number of commands to be run. This is not the same as the size of the vectors as the vectors may contain empty values.

◆ getFeatureTableLength()

int getFeatureTableLength ( ) const

Returns the value of FeatureTableLength.

If a nucleic acid sequence is longer than FeatureTableLength parameter value, the protein view report will automatically switch to feature table mode and output the matches as a GenBank feature table.

Parameter | FeatureTableLength
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 30,000
Value in mascot.dat | [not defined]
Returns
the length at which to switch to a feature table.

◆ getFeatureTableMinScore()

double getFeatureTableMinScore ( ) const

Returns the value of FeatureTableMinScore.

By default, only matches with significant scores (p < 0.05) are output. A different score threshold can be specified using the parameter FeatureTableMinScore.

Parameter | FeatureTableMinScore
Permitted values | Floating point > 0
Default (if no parameter in mascot.dat) | 13.0
Value in mascot.dat | [not defined]
Returns
the minimum score to be shown in a feature table.

◆ getFormVersion()

std::string getFormVersion ( ) const

Returns the value of FormVersion.

Mascot users may save search forms off-line, or submit searches using scripts or private forms. When the search engine is upgraded, there is the possibility that old scripts or forms may contain invalid or obsolete parameters. If a search is submitted to Mascot without a version number, or if the version number is lower than that specified by FormVersion, a warning will be included in the results file and in the master results report.

Parameter | FormVersion
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | 1.01
Value in mascot.dat | 1.01
Returns
the form version.

◆ getGetSeqJobIdFile()

std::string getGetSeqJobIdFile ( ) const

Returns the value of GetSeqJobIdFile.

GetSeqJobIdFile contains the next available job number for the ms-getseq.exe utility. These numbers wrap around at 999 and do not appear in the search logs. If this file is deleted, the next job number will be reset to 1 and a new jobId-file created automatically.

Parameter | GetSeqJobIdFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data/getseq.job
Value in mascot.dat | ../data/getseq.job
Returns
the path to the getseq.job file.

◆ getICATFilter()

std::string getICATFilter ( ) const

Returns the value of ICATFilter.

Parameter ICATFilter gives a residue that ICAT modifications apply to.

Parameter | ICATFilter
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | "C"
Value in mascot.dat | [not defined]
Returns
the filter string used as a comp command.

◆ getICATHeavy()

std::string getICATHeavy ( ) const

Returns the value of ICATHeavy.

The ICATHeavy parameter is the name of ICAT heavy modification. The full modification definition can be found in mod_file.

Parameter | ICATHeavy
Permitted values | Any text string
Default (if no parameter in mascot.dat) | ICAT_heavy
Value in mascot.dat | [not defined]
Returns
the name of the heavy ICAT modification.

◆ getICATLight()

std::string getICATLight ( ) const

Returns the value of ICATLight.

The ICATLight parameter is the name of ICAT light modification. The full modification definition can be found in mod_file.

Parameter | ICATLight
Permitted values | Any text string
Default (if no parameter in mascot.dat) | ICAT_light
Value in mascot.dat | [not defined]
Returns
the name of the light ICAT modification.

◆ getICATQuantitationMethod()

std::string getICATQuantitationMethod ( ) const

Returns the value of name of the ICATQuantitationMethod.

The ICATQuantitationMethod parameter is the name of the quantitation method to use if the old 'ICAT' checkbox is clicked for Mascot 2.2 and later. Just for backward compatibility.

Parameter | ICATQuantitationMethod
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ICAT
Value in mascot.dat | ICAT ABI Cleavable [MD]
Returns
the name of quantitation method to use.

◆ getIgnoreDupeAccession()

std::string getIgnoreDupeAccession ( const unsigned int index ) const

Returns one of the list databases that shouldn't be checked for duplicate accessions.

When FASTA files are compressed, they are checked to ensure that there are no duplicate accession strings. For a large EST database with many millions of entries, this can take up a lot of memory. Adding a database to the list of values for the IgnoreDupeAccessions entry in mascot.dat prevents this database from being tested.

Parameter | IgnoreDupeAccessions
Permitted values | text strings delimted by tab, space and comma
Default (if no parameter in mascot.dat) | EST_others
Value in mascot.dat | EST_others
Parameters
index is a 0 based index into the list of databases.
Returns
the database name.

◆ getIgnoreIonsScoreBelow()

double getIgnoreIonsScoreBelow ( ) const

Returns the value of IgnoreIonsScoreBelow.

Any ions score lower than this value will be set to zero and ignored. The parameter is a floating point number.

Parameter | IgnoreIonsScoreBelow
Permitted values | Any floating point >= 0.0
Default (if no parameter in mascot.dat) | 0.0
Value in mascot.dat | 0.0
Returns
the minimum ions score to be considered when generating search reports.

◆ getIntensitySigFigs()

int getIntensitySigFigs ( ) const

Returns the value of IntensitySigFigs.

The precision of intensity values written to the result file is determined by IntensitySigFigs.

The default in the mascot.dat suppplied with version 2.2 and later is 4.

Parameter | IntensitySigFigs
Permitted values | 1 to 20
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | 4
Returns
the number of significant figures to be used when saving values.

◆ getInterFileBasePath()

std::string getInterFileBasePath ( ) const

Returns the value of InterFileBasePath.

Mascot output files are written to a path given by:

   InterFileBasePath/InterFileRelPath/yyyymmdd/Fnnnnnn.dat

Here yyyymmdd is the current ISO date, and nnnnnn is a sequential job number. The path is split into a base path and a relative path as seen by the CGI scripts so that the search engine can pass a file path to (say) master_results.pl as:

   InterFileRelPath/yyyymmdd/Fnnnnnn.dat

Parameter | InterFileBasePath
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | C:/InetPub/Mascot/data for Windows and /usr/local/mascot/data for all other platforms
Value in mascot.dat | ###ROOT###/data
Returns
the path to the Mascot output files.

◆ getInterFileRelPath()

std::string getInterFileRelPath ( ) const

Returns the value of InterFileRelPath.

One of the critical values that determine a location for storing intermediate files.

See getInterFileBasePath() for further information.

Parameter | InterFileRelPath
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data
Value in mascot.dat | ../data
Returns
the relative path to Mascot results files.

◆ getIonsDecimalPlaces()

int getIonsDecimalPlaces ( ) const

Returns the value of IonsDecimalPlaces.

Mascot calculates all masses to an accuracy of 1/65535 Daltons. By default, values are displayed to two decimal places, which is probably too few for most modern instruments. The default in the mascot.dat suppplied with version 2.2 and later is 4.

The displayed precision of fragment ion masses in reports can be altered by changing the values of IonsDecimalPlaces.

Parameter | IonsDecimalPlaces
Permitted values | 1 to 20
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | 4
Returns
the number of decimal places to be displayed.

◆ getLastQueryAscFile()

std::string getLastQueryAscFile ( ) const

Returns the value of LastQueryAscFile.

See isSaveLastQueryAsc() for a detailed explanation.

Parameter | LastQueryAscFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../logs/lastquery.asc
Value in mascot.dat | ../logs/lastquery.asc
Returns
the full pathname of the file.

◆ getLogoImageFile()

std::string getLogoImageFile ( ) const

Returns the value of LogoImageFile.

This is the URL of the Matrix Science logo, used at the top of a search progress report. You can customise this by substituting the URL of your own logo. For optimum appearance, the image should be 88 pixels wide and 31 pixels high.

Parameter | LogoImageFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../images/88x31_logo_white.gif
Value in mascot.dat | ../images/88x31_logo_white.gif
Returns
the path to an image file.

◆ getMailTempFile()

std::string getMailTempFile ( ) const

Returns the value of MailTempFile.

See isEmailUsersEnabled() for information on this parameter.

Parameter | MailTempFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | C:/TEMP/MXXXXXX
Value in mascot.dat | /var/tmp/MXXXXXX
Returns
the location of temp files created for sending emails.

◆ getMailTransport()

int getMailTransport ( ) const

Returns the value of MailTransport.

MailTransport should be set to one of the following values:

  • 0 for CMC. See getEmailService(), getEmailPassword()
  • 1 for MAPI. See getEmailProfile(), getEmailPassword()
  • 2 for sendmail (Unix only). See getSendmailPath()
  • 3 for Blat. See getSendmailPath().

E-mail functionality has to be enabled by one of the following parameters: isEmailUsersEnabled(), isEmailErrorsEnabled().

Other parameters are common for all e-mail transports.

See also
getEmailFromUser(), getEmailFromTextName(), getErrMessageEmailTo(), getMailTempFile().
Parameter | MailTransport
Permitted values | 0 to 3 inclusive
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | 0
Returns
a code defining the mail transport to be used.

◆ getMascNodeCtrlFile()

std::string getMascNodeCtrlFile ( ) const

Returns the value of MascotNodeControlFile.

Parameter | MascotNodeControlFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data/mascotnode.control
Value in mascot.dat | ../data/mascotnode.control
Returns
the path to the mascotnode.control file.

◆ getMascotCmdLine()

std::string getMascotCmdLine ( ) const

Returns the value of MascotCmdLine.

Filepath to the mascot executable. This is used by ms-monitor.exe when running the test search.

Parameter | MascotCmdLine
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../cgi/nph-mascot.exe
Value in mascot.dat | ../cgi/nph-mascot.exe
Returns
the absolute or relative patch to nph-mascot.exe.
Examples
config_mascotdat.cpp.

◆ getMascotControlFile()

std::string getMascotControlFile ( ) const

Returns the value of MascotControlFile.

MascotControlFile contains critical internal parameters. This file must be memory mapped and locked to provide interprocess communication between different Mascot components.

Parameter | MascotControlFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data/mascot.control
Value in mascot.dat | ../data/mascot.control
Returns
the path to the mascot.control file.

◆ getMascotFileProcessingThreads()

int getMascotFileProcessingThreads ( ) const

Returns the value of MascotFileProcessingThreads.

MascotFileProcessingThreads specifies the number of threads used for pre-processing the input data at the beginning of the search, and for file processing at the beginning and end of each chunk. This setting does not affect the number of threads used for the search proper, which is determined by the number of licensed CPUs. If the value is -1 (automatic), the search will use the maximum number of threads authorised by the license, while respecting the configuration from Database Manager.

Parameter | MascotFileProcessingThreads
Permitted values | Any integer > 0, or -1 for automatic.
Default (if no parameter in mascot.dat) | 4
Value in mascot.dat | [not defined]
Returns
the number of threads to use to process files

◆ getMascotJobIdFile()

std::string getMascotJobIdFile ( ) const

Returns the value of MascotJobIdFile.

MascotJobIdFile contains the next available job number. If this file is deleted, the next job number will be initialised to the value given by UniqueJobStartNumber, and a new jobId file created automatically.

Parameter | MascotJobIdFile
Permitted values | Any non empty text stringg
Default (if no parameter in mascot.dat) | ../data/mascot.job
Value in mascot.dat | ../data/mascot.job
Returns
the path to the mascot.job file.

◆ getMascotMessage()

std::string getMascotMessage ( ) const

Returns the value of MascotMessage.

Displays the specified message while a search is running.

Parameter | MascotMessage
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | [not defined]
Returns
the message to be displayed for all searches.

◆ getMassDecimalPlaces()

int getMassDecimalPlaces ( ) const

Returns the value of MassDecimalPlaces.

Mascot calculates all masses to an accuracy of 1/65535 Daltons. By default, values are displayed to two decimal places, which is probably too few for most modern instruments. The default in the mascot.dat suppplied with version 2.2 and later is 4.

The displayed precision of peptide masses in reports can be altered by changing the values of MassDecimalPlaces.

Parameter | MassDecimalPlaces
Permitted values | 1 to 20
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | 4
Returns
the number of decimal places to be displayed.

◆ getMaxConcurrentSearches()

int getMaxConcurrentSearches ( ) const

Returns the value of MaxConcurrentSearches.

This parameter limits the maximum number of concurrent searches so as to avoid overloading the Mascot server.

See also ms_security_tasks::SECTASK_MAXCONCURRENTSEARCHES.

Parameter | MaxConcurrentSearches
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 10
Value in mascot.dat | 10
Returns
the maximum number of concurrent searches.

◆ getMaxDatabases()

int getMaxDatabases ( ) const

Returns the value of MaxDatabases.

Maximum number of databases that can be configured without re-starting monitor. Older versions of Mascot had a fixed limit of 64, which is a default value. Avoid specifying very large number as this will consume more physical memory and disk space unnecessarily.

Parameter | MaxDatabases
Permitted values | Any integer > 64
Default (if no parameter in mascot.dat) | 64
Value in mascot.dat | 256
Returns
an integer value specifying the limit.

◆ getMaxDescriptionLen()

int getMaxDescriptionLen ( ) const

Returns the value of MaxDescriptionLen.

Long FASTA title (description) lines will be truncated at this number of characters.

Parameter | MaxDescriptionLen
Permitted values | Any positive integer
Default (if no parameter in mascot.dat) | 100
Value in mascot.dat | 250
Returns
the maximum length.

◆ getMaxEtagMassDelta()

double getMaxEtagMassDelta ( ) const

Returns the value of MaxEtagMassDelta.

See also
getMinEtagMassDelta()
Parameter | MaxEtagMassDelta
Permitted values | Any floating point number
Default (if no parameter in mascot.dat) | 1770.0
Value in mascot.dat | 1770.0
Returns
The maximum delta to be considered for an error tolerant match.

◆ getMaxEtVarMods()

int getMaxEtVarMods ( ) const

Returns the value of MaxEtVarMods.

The maximum number of variable modifications allowed in an error-tolerant search.

Parameter | MaxEtVarMods
Permitted values | Any integer in the range 0 to 31
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | [not defined]
Returns
the maximum number of variable modifications for the first pass search.

◆ getMaxIntactCrosslinkPeptides()

int getMaxIntactCrosslinkPeptides ( ) const

Returns the value of MaxIntactCrosslinkPeptides.

The maximum number of intact crosslink peptides to consider for a crosslink search. All regular peptides are still considered in the search and are not affected by this parameter.

Parameter | MaxIntactCrosslinkPeptides
Permitted values | Any integer > 0.
Default (if no parameter in mascot.dat) | 1000000
Value in mascot.dat | 1000000
Returns
the maximum number of crosslink peptides to consider for matching

◆ getMaxNumOfReportBuilderColumnArrangements()

int getMaxNumOfReportBuilderColumnArrangements ( ) const

Returns the maximum number of column arrangements allowed.

The maximum number of column arrangements defined in mascot.dat is limited. If security is enabled, each user can save additional column arrangements in user preferences.

Returns
Maximum number of column arrangements.

◆ getMaxNumPeptides()

int getMaxNumPeptides ( ) const

Returns the value of MaxNumPeptides.

The maximum number of peptides which can be expected from the enzymatic digest of a single entry.

If this value is not defined in mascot.dat than the value is calculated from getMaxSequenceLen() / 4

In general, this should not be defined in mascot.dat.

Parameter | MaxNumPeptides
Permitted values | Any positive integer
Default (if no parameter in mascot.dat) | [not defined]
Value in mascot.dat | [not defined]
Returns
the maximum number of peptides to be considered in a search.

◆ getMaxPepModArrangements()

int getMaxPepModArrangements ( ) const

Returns the value of MaxPepModArrangements.

Mascot iterates over the variable modifications of a peptide in the following way:

  • Choose a (sub)set of variable modifications, up to a limit of MaxPepNumVarMods.
  • Choose the number of instances for each modification that fits the precursor mass within precursor tolerance. Total number of instances is limited by MaxPepNumModifiedSites.
  • Assign the selected modification instances on modifiable sites. Each assignment is an arrangement of the modification instances. Repeat until the arrangements are exhausted or MaxPepModArrangements is reached.

The number of arrangements for some peptides can be very large.

A value of zero indicates maximum.

This parameter is new in Mascot 2.7. Previous versions had no specific upper limit, although in many cases iteration ended before about 16-20 arrangements had been sampled.

Parameter | MaxModArrangements
Permitted values | Any integer >= 0 and <= 1000000
Default (if no parameter in mascot.dat) | 64
Value in mascot.dat | 64
Returns
the maximum number of variable modification arrangements allowed for a single peptide.

◆ getMaxPepNumModifiedSites()

int getMaxPepNumModifiedSites ( ) const

Returns value of the MaxPepNumModifiedSites.

Mascot iterates over the variable modifications of a peptide in the following way:

  • Choose a (sub)set of variable modifications, up to a limit of MaxPepNumVarMods.
  • Choose the number of instances for each modification that fits the precursor mass within precursor tolerance. Total number of instances is limited by MaxPepNumModifiedSites.
  • Assign the selected modification instances on modifiable sites. Each assignment is an arrangement of the modification instances. Repeat until the arrangements are exhausted or MaxPepModArrangements is reached.

A value of zero indicates maximum.

This parameter is new in Mascot 2.7. Previous versions had no configurable upper limit.

Parameter | MaxPepNumModifiedSites
Permitted values | Any integer >= 0 and <= 10000
Default (if no parameter in mascot.dat) | 5
Value in mascot.dat | 5
Returns
the maximum number of modified sites in a peptide

◆ getMaxPepNumVarMods()

int getMaxPepNumVarMods ( ) const

Returns value of the MaxPepNumVarMods.

Mascot iterates over the variable modifications of a peptide in the following way:

  • Choose a (sub)set of variable modifications, up to a limit of MaxPepNumVarMods.
  • Choose the number of instances for each modification that fits the precursor mass within precursor tolerance. Total number of instances is limited by MaxPepNumModifiedSites.
  • Assign the selected modification instances on modifiable sites. Each assignment is an arrangement of the modification instances. Repeat until the arrangements are exhausted or MaxPepModArrangements is reached.

A value of zero indicates maximum.

Parameter | MaxPepNumVarMods
Permitted values | Any integer >= 0 and <= 10000
Default (if no parameter in mascot.dat) | 3
Value in mascot.dat | 3
Returns
the maximum number of modifications in one peptide.

◆ getMaxQueries()

int getMaxQueries ( ) const

Returns the value of MaxQueries.

The maximum number of mass values (PMF) or MS/MS spectra (MIS) allowed in a single search.

Parameter | MaxQueries
Permitted values | Integer >= 10
Default (if no parameter in mascot.dat) | 10000
Value in mascot.dat | 1000000
Returns
the maximum number of queries per search.

◆ getMaxSearchesPerUser()

int getMaxSearchesPerUser ( ) const

Returns the value of MaxSearchesPerUser.

Sets the maximum number of concurrent searches from a single IP-address.

A value of 0 means no limit.

Parameter | MaxSearchesPerUser
Permitted values | Any integer >= 0
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns
the maximum number of concurrent searches per user.

◆ getMaxSequenceLen()

int getMaxSequenceLen ( ) const

Returns the value of MaxSequenceLen.

This parameters defines the maximum length of a database entry in characters, (bases for nucleic acids or residues for amino acids databases respectively).

Parameter | MaxSequenceLen
Permitted values | Any integer >= 100
Default (if no parameter in mascot.dat) | 80,000
Value in mascot.dat | 80,000
Returns
the maximum sequence length.

◆ getMaxVarMods()

int getMaxVarMods ( ) const

Returns the value of MaxVarMods.

The maximum number of variable modifications allowed in a standard search.

Parameter | MaxVarMods
Permitted values | Any integer in the range 0 to 32
Default (if no parameter in mascot.dat) | 9
Value in mascot.dat | [not defined]
Returns
the maximum number of variable modifications.

◆ getMinEtagMassDelta()

double getMinEtagMassDelta ( ) const

Returns the value of MinEtagMassDelta.

See also
getMaxEtagMassDelta()
Parameter | MinEtagMassDelta
Permitted values | Any floating point number
Default (if no parameter in mascot.dat) | -130.0
Value in mascot.dat | -130.0
Returns
The minimum delta to be considered for an error tolerant match.

◆ getMinPepLenInPepSummary()

int getMinPepLenInPepSummary ( ) const

Returns the value of MinPepLenInPepSummary.

In a Peptide Summary report, two proteins are reported as distinct matches if the peptide matches to one protein are not identical to or a sub-set of the peptide matches to the other protein. Since matches to very short peptides are usually random, peptides shorter than MinPepLenInPepSummary are not considered in this comparison.

Parameter | MinPepLenInPepSummary
Permitted values | Any integer greater than zero
Default (if no parameter in mascot.dat) | 7
Value in mascot.dat | 7 (Was 5 in Mascot 2.3.02 and earlier)
Returns
the minimum peptide length used to differentiate different proteins.

◆ getMinPepLenInSearch()

int getMinPepLenInSearch ( ) const

Returns value of the MinPepLenInSearch.

This parameter specifies the minimal length of a peptide to be accepted as a match to any query in all searches. Use this parameter if you see too many short peptides in a result file that constitute mostly meaningless matches.

Parameter | MinPepLenInSearch
Permitted values | Any non-negative integer
Default (if no parameter in mascot.dat) | 3
Value in mascot.dat | 5
Returns
the minimum peptide length.

◆ getMonitorEmailCheckFreq()

int getMonitorEmailCheckFreq ( ) const

Returns the value of MonitorEmailCheckFreq.

See isEmailUsersEnabled() for information on this parameter..

Parameter | MonitorEmailCheckFreq
Permitted values | Any positive integer
Default (if no parameter in mascot.dat) | 300
Value in mascot.dat | 300
Returns
the frequency to check for sending emails in seconds.

◆ getMonitorLogFile()

std::string getMonitorLogFile ( ) const

Returns the value of MonitorLogFile.

This path defines where monitor log file should be placed. The ms-monitor.exe service/daemon writes to this file.

Parameter | MonitorLogFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../logs/monitor.log
Value in mascot.dat | [not defined]
Returns
the relative or absolute path to the monitor log.

◆ getMonitorPidFile()

std::string getMonitorPidFile ( ) const

Returns the value of MonitorPidFile.

The name for the file which holds the process ID number for ms-monitor.exe. Unix only.

Parameter | MonitorPidFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../bin/monitor.pid
Value in mascot.dat | [not defined]
Returns
monitor pid file name

◆ getMonitorTestTimeout()

int getMonitorTestTimeout ( ) const

Returns the value of MonitorTestTimeout.

A time-out is applied to the test searches used to validate a new database. If the test search on a new database does not produce a valid result within the number of seconds specified by MonitorTestTimeout, the problem is assumed to be with the new database, and the exchange process is halted.

Parameter | MonitorTestTimeout
Permitted values | Any positive integer
Default (if no parameter in mascot.dat) | 1200
Value in mascot.dat | 1200
Returns
the timeout period in seconds.

◆ getMudpit()

int getMudpit ( ) const

Returns the value of Mudpit.

Deprecated:
For Mascot 2.2 and later, use getMudpitSwitch() and getSelectSwitch().

Gets the number of queries at which the protein scoring switches to MudPIT mode.

See also
ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE
Parameter | Mudpit
Permitted values | Any integer>0
Default (if no parameter in mascot.dat) | 1000
Value in mascot.dat | [not defined]
Returns
number of queries at which scoring switches to MudPIT mode

◆ getMudpitSwitch()

double getMudpitSwitch ( ) const

Returns the value of MudpitSwitch.

A ratio of the number of queries divided by the number of entries in the database is used to determine when to switch between the two methods of protein scoring. The default value for SelectSwitch is 0.001. If q/e < 0.001, then standard protein scoring is used. If it is higher than 0.001, then MudPIT protein scoring is used.

If the user never wants to see MudPIT scoring, then this should be set to a large value, e.g. 1000

In the standard reports, the _server_mudpit_switch flag can be passed as a url parameter to override this setting.

This parameter, and getSelectSwitch() replaced the single value returned by getMudpit() in Mascot 2.1 and earlier.

See also ms_protein::getScore() for a description of standard and MudPIT protein scoring.

Parameter | MudpitSwitch
Permitted values | Any floating point value > 0
Default (if no parameter in mascot.dat) | 0.001
Value in mascot.dat | 0.001
Returns
The q/e value used to determine which protein scoring method to use.

◆ getNoResultsScript()

std::string getNoResultsScript ( ) const

Returns the value of NoResultsScript.

See getResultsPerlScript() for more information.

Parameter | NoResultsScript
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../cgi/master_results.pl
Value in mascot.dat | ../cgi/master_results.pl
Returns
the url for the no results script.

◆ getNTIUserGroup()

std::string getNTIUserGroup ( ) const

Returns the value of NTIUserGroup.

See getNTMonitorGroup() for information on this parameter.

The default in mascot.dat since mascot 2.3.0 is "Users". Earlier versions had the default as "Guests"

Parameter | NTIUserGroup
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | Guests
Value in mascot.dat | Users
Returns
NTI user group

◆ getNTMonitorGroup()

std::string getNTMonitorGroup ( ) const

Returns the value of NTMonitorGroup.

Under Windows NT, the Mascot service is generally run using the Local System account. It has to create, write and read the memory mapped files. The CGI scripts (such as nph-mascot.exe) are run by the Web server, and will be run using a different user name with different permissions from the service. These programs also need to be able to read and write to these files.

For example, with the Microsoft Web server (IIS), a new user with the name IUSR_<name_of_pc> is created when the server is installed, and the scripts are run using this user name. The installation program sets these values appropriately. Other Web servers may use different user names, with different permissions.

NTMonitorGroup is used to define one of the groups that the administrator belongs to. In most cases, this can be left at the default of Administrators.

NTIUserGroup is the name of one of the groups that the user name used to run the CGI scripts belongs to.

Parameter | NTMonitorGroup
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | Administrators
Value in mascot.dat | Administrators
Returns
the name of the Administrators group.

◆ getNumberOfIgnoreDupeAccessions()

unsigned int getNumberOfIgnoreDupeAccessions ( ) const

Returns the number of databases that shouldn't be checked for duplicate accessions.

When fasta files are compressed, they are checked to ensure that there are no duplicate accession strings. For a large EST database with many millions of entries, this can take up a lot of memory. Adding a database to the list of values for the IgnoreDupeAccessions entry in mascot.dat prevents this database from being tested.

Parameter | IgnoreDupeAccessions
Permitted values | text strings delimted by tab, space and comma
Default (if no parameter in mascot.dat) | EST_others
Value in mascot.dat | EST_others
Returns
the number of items in the IgnoreDupeAccessions parameter.

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getNumberOfReportNumberChoices()

int getNumberOfReportNumberChoices ( ) const

Returns the values of ReportNumberChoices.

If present, ReportNumberChoices list will define the choices provided in the search form Report top drop down list box. If not, this member will return zero.

getReportNumberChoice() member is used to retrieve individual elements of the list.

The default value in mascot.dat is AUTO,5,10,20,30,50,100,200, so this function would return 8 for that case.

Parameter | ReportNumberChoices
Permitted values | Any integer > 0, or -1.
Default (if no parameter in mascot.dat) | 5,10,20,30,40,50
Value in mascot.dat | AUTO,5,10,20,30,50,100,200
Returns
the number of integers in the list.

◆ getNumberOfTargetFDRPercentages()

int getNumberOfTargetFDRPercentages ( ) const

Returns the values of TargetFDRPercentages.

If present, the TargetFDRPercentages list will define the choices available in a Protein Family Summary report of a decoy search. Each item in the list is a percentage (e.g. 2.5 means 2.5% or 0.025). If the option is not present, this function will return 0.

An element in the list can be marked as the default value. Use getTargetFDRPercentage() to retrieve individual elements of the list, and isDefaultTargetFDRPercentage() to find out if an element is marked as the default element.

The default value in mascot.dat is 0.1, 0.2, 0.5, 1+, 2, 5, so this function would return 6 in the default case. The postfix "+" means that, in this case, 1 is the default value.

Parameter | TargetFDRPercentages
Permitted values | Any number >0
Default (if no parameter in mascot.dat) | 0.1, 0.2, 0.5, 1+, 2, 5
Value in mascot.dat | 0.1, 0.2, 0.5, 1+, 2, 5
Returns
the number of integers in the list.

◆ getPepSearchTool()

std::string getPepSearchTool ( ) const

Returns the value of LibrarySearch.

See also
setPepSearchTool() and getPepSearchToolCommandLine()

Introduced in version 2.6.0.

In version 2.6.1, "m G" was replaced with "m a P" where:

MSPepSearch parameter | Meaning
m | precursor ion m/z within precursor ion m/z uncertainty
G | generic (no peak annotations or peptide peak weighting used)
a | alternative peak matching in computing match factors
P | peptide (use peak annotations and peak weighting)

And, in 2.6.1, we made sure that every library spectrum has properly annotated peaks, and not just a "?"

Also, in 2.6.1, "/HITS 100" was changed to "/HITS 10"

Parameter | LibrarySearch
Permitted values | Any non empty text string.
Default (if no parameter in mascot.dat) | ../bin/NIST/mspepsearch/MSPepSearch.exe m a P $peptidetoleranceunit $peptidetolerance $iontoleranceunit $iontolerance /LIB $libname /INP $inputfile /OUTTAB $outputfile /HITS 10 /MinMF 0 /NumCompared /OutPrecursorMz /OutDeltaPrecursorMz /OutSpecNum
Value in mascot.dat | ../bin/NIST/mspepsearch/MSPepSearch.exe m a P $peptidetoleranceunit $peptidetolerance $iontoleranceunit $iontolerance /LIB $libname /INP $inputfile /OUTTAB $outputfile /HITS 10 /MinMF 0 /NumCompared /OutPrecursorMz /OutDeltaPrecursorMz /OutSpecNum
Returns
the value of LibrarySearch.

◆ getPepSearchToolCommandLine()

std::string getPepSearchToolCommandLine | ( | const std::string & | peptideToleranceUnit,
 |  | const double & | peptideTolerance,
 |  | const std::string & | ionToleranceUnit,
 |  | const double & | ionTolerance,
 |  | const std::string & | libraryDirectoryPath,
 |  | const std::string & | inputFileRelativePath,
 |  | const std::string & | outputFileRelativePath
 | ) |  | const

Get command line to search a library, eg MSPepSearch.exe.

This function is called by nph-mascot.exe to get the command line required to invoke the spectral library search tool. It calls getPepSearchTool which contains a number of 'tags' which need to be replaced with search specific parameters. In theory, any search tool that accepts an MGF file and outputs a CSV file could be used instead of MSPepSearch. This function replaces the following tags with the corresponding variable passed to this function:

  • $peptidetoleranceunit is replaced with peptideToleranceUnit
  • $peptidetolerance is replaced with peptideTolerance
  • $iontoleranceunit is replaced with ionToleranceUnit
  • $iontolerance is replaced with ionTolerance
  • $libname is replaced with libraryDirectoryPath
  • $inputfile is replaced with inputFileRelativePath
  • $outputfile is replaced with outputFileRelativePath
See also
getPepSearchTool() and setPepSearchTool()
Parameters
peptideToleranceUnit | will be Z or ZPPM, where 'Z' specifies Daltons.
peptideTolerance | tolerance in the unit above.
ionToleranceUnit | will be M or MPPM, where 'M' specifies Daltons.
ionTolerance | tolerance in the unit above.
libraryDirectoryPath | full path to the directory containing the spectral library 'database'.
inputFileRelativePath | path to the mgf file created by nph-mascot.exe.
outputFileRelativePath | is the path to the results file produced by the library search tool that will be read by nph-mascot.exe.
Returns
complete pep search tool command line for the specified spectral library.

◆ getPercolatorExeFlags()

std::string getPercolatorExeFlags | ( | bool | anyRetentionTimes,
 |  | const std::vector< std::string > | percolatorFiles,
 |  | const PERC_EXE_RT | rt = PERC_EXE_RT_USE_DEFAULT
 | ) |  | const

Returns the value of PercolatorExeFlags.

See Using Percolator scores for further information.

Parameter | PercolatorExeFlags
Permitted values | any string
Default (if no parameter in mascot.dat) | -i 10 -D 14 -v 0
Value in mascot.dat | -i 10 -D 14 -v 0

This function will create a string of the form

  -i 10 -D 14 -v 0 -j [percolator_input_file] -B [percolator_decoy_file] -r [percolator_target_file]

If anyRetentionTimes is true and either forceUseRT or the return from isPercolatorUseRT() is true, then the -D [num] option will be retained, otherwise the -D [num] option will be removed from the PercolatorExeFlags parameters.

Parameters
anyRetentionTimes | should be set to true if there are any retention times in the results file. It is normally safe to just check the first query and if ms_inputquery::getRetentionTimes() returns an empty string, then set this parameter to false.
percolatorFiles | is the parameter returned by ms_mascotresfilebase::getPercolatorFileNames().
rt | one of the ms_mascotoptions::PERC_EXE_RT enumerations may be specified to override the value in mascot.dat that is returned by calling isPercolatorUseRT().
Returns
the flags and options to be used when calling percolator.exe.

◆ getPercolatorFeatures()

std::string getPercolatorFeatures ( ) const

Returns the value of PercolatorFeatures.

Returns a list of features that should be considered when running percolator.

To see the list of available features, run ms-createpip.exe –help. See Using Percolator scores for further information.

Parameter | PercolatorFeatures
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | mScore,lgDScore, mrCalc, charge, dM, dMppm, absDM, absDMppm, isoDM, isoDMppm, mc, varmods, totInt, intMatchedTot,relIntMatchedTot
Value in mascot.dat | mScore,lgDScore, mrCalc, charge, dM, dMppm, absDM, absDMppm, isoDM, isoDMppm, mc, varmods, totInt, intMatchedTot,relIntMatchedTot
Returns
the comma separated list of features.

◆ getPercolatorMinQueries()

int getPercolatorMinQueries ( ) const

Returns the value of PercolatorMinQueries.

Percolator requires a 'reasonable' number of ms-ms spectra to perform well, and this parameter specifies that minimum. If the number of queries is below this value, percolator results will not be made available.

See Using Percolator scores for further information.

Parameter | PercolatorMinQueries
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 750
Value in mascot.dat | 750 (was 100 for Mascot Server versions 2.3 to 2.5.0)
Returns
the minimum number of queries required to display percolator results.

◆ getPercolatorMinSequences()

int getPercolatorMinSequences ( ) const

Returns the value of PercolatorMinSequences.

Percolator requires a 'reasonable' number of sequences to perform well, and this parameter specifies that minimum. If the number of sequences searched is below this value, percolator results will not be made available.

See Using Percolator scores for further information.

Parameter | PercolatorMinSequences
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 100
Value in mascot.dat | 100
Returns
the minimum number of sequences.

◆ getPercolatorRtFlags()

std::string getPercolatorRtFlags | ( | const bool | anyRetentionTimes,
 |  | const bool | useRT
 | ) |  | const

Returns PercolatorExeFlags with the -D flag optionally removed if there are no retention times.

Note
This method is only needed when using getExecAfterSearch() or ms_mascotresfilebase::staticGetPercolatorFileNames(). In all other cases, please use getPercolatorExeFlags().
Returns
the raw value of the PercolatorExeFlags_XXX parameter in the mascot.dat file. If anyRetentionTimes is true and useRT is true, then the -D [num] option will be retained, otherwise the -D [num] option will be removed from the PercolatorExeFlags parameters.

◆ getPercolatorTargetRankRelativeThreshold()

double getPercolatorTargetRankRelativeThreshold ( ) const

Returns the value of PercolatorTargetRankRelativeThreshold.

For a description of this function, see getPercolatorTargetRankScoreThreshold().

See Using Percolator scores for further information.

Permitted values | A real number in [0, 1]
Default (if no parameter in mascot.dat) | 0.2
Value in mascot.dat | 0.2
Returns
Minimum relative score difference with rank 1 match.

◆ getPercolatorTargetRankScoreThreshold()

int getPercolatorTargetRankScoreThreshold ( ) const

Returns the value of PercolatorTargetRankScoreThreshold.

Mascot 2.8 and later exports rank 1 matches plus further ranks from target if score > PercolatorTargetRankScoreThreshold and the relative difference from rank 1 score < PercolatorTargetRankRelativeThreshold. This option is not implemented in Mascot 2.7 and earlier.

See Using Percolator scores for further information.

Parameter | PercolatorTargetRankScoreThreshold
Permitted values | Positive integers
Default (if no parameter in mascot.dat) | 20
Value in mascot.dat | 20
Returns
Minimum score for matches whose rank is greater than 1.

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPrecursorCutOutLowerLimit()

double getPrecursorCutOutLowerLimit ( ) const

Gets the first PrecursorCutOut.

This parameter defines boundaries for cut-out window for precursor m/z value. It consists of two numbers - the lower limit and the upper limit for precursor m/z window. If both numbers are the same (i.e. if the window is of zero-length) Mascot uses a "smart" mechanism for filtering out peptide m/z from MS-spectra.

Parameter | PrecursorCutOut
Permitted values | Any 2 comma separated floating point numbers
Default (if no parameter in mascot.dat) | "-1, -1"
Value in mascot.dat | "-1, -1"
Returns
the first of the two values.

◆ getPrecursorCutOutUpperLimit()

double getPrecursorCutOutUpperLimit ( ) const

Gets the second PrecursorCutOut.

This parameter defines boundaries for cut-out window for precursor m/z value. It consists of two numbers - the lower limit and the upper limit for precursor m/z window. If both numbers are the same (i.e. if the window is of zero-length) Mascot uses a "smart" mechanism for filtering out peptide m/z from MS-spectra.

Parameter | PrecursorCutOut
Permitted values | Any 2 comma separated floating point numbers
Default (if no parameter in mascot.dat) | "-1, -1"
Value in mascot.dat | "-1, -1"
Returns
the second of the two values.

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ getProteinFamilySwitch()

int getProteinFamilySwitch ( ) const

Returns the value of ProteinFamilySwitch.

For Mascot 2.3 and later, if a search has greater than or equal the number of MS-MS spectra defined by getProteinFamilySwitch(), then the script defined by getResultsPerlScript_2() is run.

Parameter | ProteinFamilySwitch
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 300
Value in mascot.dat | 300
Returns
the number of MS-MS spectra required for displaying the Protein Family Summary report.

◆ getProteinsInResultsFile()

int getProteinsInResultsFile ( ) const

Returns the value of ProteinsInResultsFile.

Determines the number of protein title lines saved to each results file. Possible values are:

  • 1 - as in Mascot 1.7 and earlier, only proteins that appear in the Summary section will appear in the Proteins section.
  • 2 - include proteins with at least one top ranking peptide match to a peptide of length greater than or equal to MinPepLengthInPepSummary (see getMinPepLenInPepSummary()).
  • 3 - include all proteins.
Parameter | ProteinsInResultsFile
Permitted values | 1, 2 or 3
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | [not defined]
Returns
a value defining which protein descriptions should be stored in the results file.

◆ getProxyPassword()

std::string getProxyPassword ( ) const

Returns the value of proxy_password.

See getProxyServer().

Parameter | proxy_password
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | [commented out]# proxy_password mypassword
Returns
the password for the proxy server user.

◆ getProxyServer()

std::string getProxyServer ( ) const

Returns the value of proxy_server.

This parameter allows a proxy server to be defined.

Other parameters defining proxy server are proxy_username (getProxyUsername()) and proxy_password (getProxyPassword()).

Parameter | proxy_server
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | [commented out]# proxy_server myserver
Returns
the proxy server name.

◆ getProxyType()

std::string getProxyType ( ) const

Returns the value of ProxyType.

Proxy server settings can be specified in a number of ways depending on the operating system and local network policies. See ms_connection_settings::PROXY_TYPE for a description. The proxy type value in mascot.dat is case-insensitive; for example, all of none, None and NONE mean ms_connection_settings::PROXY_TYPE_NO_PROXY.

This parameter was introduced in Mascot Server 2.5. The default in Mascot Server 2.4 and earlier is equivalent to Specify. If proxy_server is not given in mascot.dat, the default in 2.4 is None.

Parameter | ProxyType
Permitted values | None, Registry, Specify, WPAD, Environment, Auto
Default (if no parameter in mascot.dat) | Auto
Value in mascot.dat | Auto
Returns
A string matching one of the ms_connection_settings::PROXY_TYPE values.

◆ getProxyUsername()

std::string getProxyUsername ( ) const

Returns the value of proxy_username.

See getProxyServer().

Parameter | proxy_username
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | [commented out]# proxy_username myusername
Returns
the username for proxy server.

◆ getReportBuilderColumnArrangement()

std::string getReportBuilderColumnArrangement ( const int index ) const

Returns ReportBuilderColumnArrangement by number.

Set the column arrangement at the given index. Column arrangements are used by Report Builder (introduced in Mascot 2.4) to provide a default list of columns to show. These can be selected from a dropdown list in the report.

Each column arrangement is of the form

  Name:[columns]

where Name is the column arrangement name (e.g. Standard) and [columns] is a comma-separated list of column names, as used by Report Builder. The following is the standard list of column names, available in every report:

  family
  member
  db
  acc
  score
  mass
  matches
  matches-sig
  sequences
  sequences-sig
  empai
  frame
  desc

(frame will not be shown in the report if the search is against an amino acid database.) Quantitation methods add additional column names, but these are generated from the quantitation ratio names. The easiest way to create a column arrangement string is to arrange the columns in Report Builder, then "export" the column arrangement as a string and copy it into mascot.dat.

See also
setReportBuilderColumnArrangement().
Parameter | ReportBuilderColumnArrangement_XXX
Permitted values | A name followed by colon followed by column arrangement string (see above)
Default (if no parameter in mascot.dat) | ReportBuilderColumnArrangement_1 Standard:family,member,db,acc,score,mass,matches,matches-sig,sequences,sequences-sig,empai,frame,desc
Value in mascot.dat | ReportBuilderColumnArrangement_1 Standard:family,member,db,acc,score,mass,matches,matches-sig,sequences,sequences-sig,empai,frame,desc
Parameters
index A value between 1 and getMaxNumOfReportBuilderColumnArrangements(), inclusive.
Returns
The column arrangement definition at that index, or the empty string if the arrangement does not exist.

◆ getReportNumberChoice()

int getReportNumberChoice ( const int index ) const

Returns an element of the ReportNumberChoices list by its number.

The function returns -1 in case of AUTO string. For more information on the ReportNumberChoices parameter see getNumberOfReportNumberChoices().

The default value in mascot.dat is AUTO,5,10,20,30,50,100,200, so this function would return 5 for an index value of 1

Parameter | ReportNumberChoices
Permitted values | Any integer > 0, or -1.
Default (if no parameter in mascot.dat) | 5,10,20,30,40,50
Value in mascot.dat | AUTO,5,10,20,30,50,100,200
Parameters
index element number from 0 to (getNumberOfReportNumberChoices()-1).
Returns
an element of the list that corresponds to the given index. Returns 0 if the provided index is not valid.

◆ getResfileCache()

std::string getResfileCache ( ) const

Returns the value of ResfileCache.

See Caching Mascot Results.

This parameter is rather counter-intuitive! A script or application running on the Mascot server has a choice of whether or not to specify ms_mascotresfilebase::RESFILE_USE_CACHE. Each Mascot script calls this function which returns a comma separated list of scripts and executable programs. The script then searches for its own name, and if it finds it, then it will specify the ms_mascotresfilebase::RESFILE_USE_CACHE flag. Mascot parser does not use this parameter internally – it is up to each script to use it.

A user can disable/enable the use of the cache for one or more scripts by adding them to the list in mascot.dat.

See also
getResultsCache()
Parameter | ResfileCache
Permitted values | Comma, space or tab delimeted string. May be empty
Default (if no parameter in mascot.dat) | master_results.pl,master_results_2.pl,peptide_view.pl,protein_view.pl,export_dat.pl,export_dat_2.pl,ms-createpip.exe,MSAnatomiser.class,mi_getpeaklist.pl,msms_gif.pl,nph-mascot.exe,ms-searchcontrol.exe,client.pl
Value in mascot.dat | master_results.pl,master_results_2.pl,peptide_view.pl,protein_view.pl,export_dat.pl,export_dat_2.pl,ms-createpip.exe,MSAnatomiser.class,mi_getpeaklist.pl,msms_gif.pl,nph-mascot.exe,ms-searchcontrol.exe,client.pl
Returns
a comma separated list of scripts that should specify ms_mascotresfilebase::RESFILE_USE_CACHE when creating a ms_mascotresfilebase object.

◆ getResultsCache()

std::string getResultsCache ( ) const

Returns the value of ResultsCache.

See Caching Mascot Results.

This parameter is rather counter intuitive! A script or application running on the Mascot server has a choice of whether or not to specify ms_peptidesummary::MSPEPSUM_USE_CACHE. Each Mascot script calls this function which returns a comma separated list of scripts and executable programs. The script then searches for its own name, and if it finds it, then it will specify the ms_peptidesummary::MSPEPSUM_USE_CACHE flag. Mascot parser does not use this parameter internally – it is up to each script to use it.

A user can disable/enable the use of the cache for one or more scripts by adding them to the list in mascot.dat.

See also
getResfileCache()
Parameter | ResultsCache
Permitted values | Comma, space or tab delimeted string. May be empty
Default (if no parameter in mascot.dat) | master_results.pl,master_results_2.pl,peptide_view.pl,protein_view.pl,export_dat.pl,export_dat_2.pl,MSAnatomiser.class,mi_getpeaklist.pl,nph-mascot.exe,ms-searchcontrol.exe
Value in mascot.dat | master_results.pl,master_results_2.pl,peptide_view.pl,protein_view.pl,export_dat.pl,export_dat_2.pl,MSAnatomiser.class,mi_getpeaklist.pl,nph-mascot.exe,ms-searchcontrol.exe
Returns
a comma separated list of scripts that should specify ms_peptidesummary::MSPEPSUM_USE_CACHE when creating a ms_peptidesummary object.

◆ getResultsFileFormatVersion()

std::string getResultsFileFormatVersion ( ) const

Returns the value of ResultsFileFormatVersion.

Currently only one value choice is supported: "2.1". Specifiying this value will force Mascot to produce result file compatible with ver. 2.1. An empty or any other value means current version result file format.

Be careful, however, when submitting to Mascot a search which explicitly requires new functionality. In this case Mascot will decide whether to output results in the requested or the current format.

Parameter | ResultsFileFormatVersion
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | [commented out] #ResultsFileFormatVersion 2.1
Returns
the version string.

◆ getResultsFullURL()

std::string getResultsFullURL ( ) const

Returns the value of ResultsFullURL.

The ResultsFullURL entry is used when results are emailed to a user. Since the email will probably be received on another system, the URL used needs to have the full name including the Web server.

Parameter | ResultsFullURL
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ###URL###/cgi/master_results.pl
Value in mascot.dat | http://www.matrixscience.com/cgi/master_results.pl
Returns
the url.

◆ getResultsFullURL_2()

std::string getResultsFullURL_2 ( ) const

Returns the value of ResultsFullURL_2.

For Mascot 2.3 and later, if a search has greater than or equal the number of MS-MS spectra defined by getProteinFamilySwitch(), then this URL is used to send results by email.

Parameter | ResultsFullURL_2
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | http://www.matrixscience.com/cgi/master_results_2.pl
Value in mascot.dat | http://www.matrixscience.com/cgi/master_results_2.pl
Returns
the URL to use.

◆ getResultsPerlScript()

std::string getResultsPerlScript ( ) const

Returns the value of ResultsPerlScript.

There are URLs (not disk paths) of the scripts to be called by the search engine at the completion of a search. A successful search calls ResultsPerlScript, while a search that didn't find any hits calls NoResultsScript. In the scripts supplied with Mascot, for Mascot 2.2 and earlier, both eventualities are handled by a single script: master_results.pl.

Parameter | ResultsPerlScript
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../cgi/master_results.pl
Value in mascot.dat | ../cgi/master_results.pl
Returns
the url for the results script.

◆ getResultsPerlScript_2()

std::string getResultsPerlScript_2 ( ) const

Returns the value of ResultsPerlScript_2.

For Mascot 2.3 and later, if a search has greater than or equal the number of MS-MS spectra defined by getProteinFamilySwitch(), this script is run.

Parameter | ResultsPerlScript_2
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../cgi/master_results_2.pl
Value in mascot.dat | ../cgi/master_results_2.pl
Returns
the script to run.

◆ getReviewColDisplay()

bool getReviewColDisplay ( const MS_REVIEW_COL index ) const

Returns ReviewColDisplay by number.

End users can specify the display states in mascot.dat to suit their requirements, for example if they want to hide by default some columns.

See also
setReviewColDisplay().
Parameter | ReviewColDisplay
Permitted values | 1 (true) for display, 0 (false) for hide
Default (if no parameter in mascot.dat) | 1, 1, 1, 1, 0, 0, 1, 1, 1, 1, 1, 1, 1, 0, 1, 1
Value in mascot.dat | 1, 1, 1, 1, 0, 0, 1, 1, 1, 1, 1, 1, 1, 0, 1, 1
Parameters
index A value from the MS_REVIEW_COL enumeration.
Returns
column display state for the given number

◆ getReviewColWidth()

int getReviewColWidth ( const MS_REVIEW_COL index ) const

Returns ReviewColWidths by number.

End users can specify the widths in mascot.dat to suit their requirements, for example if they use long titles.

See also
setReviewColWidth().
Parameter | ReviewColWidths
Permitted values | Positive integer >0
Default (if no parameter in mascot.dat) | 7, 8, 8, 27, 30, 100, 32, 25, 6, 13, 4, 4, 6, 16, 7, 32
Value in mascot.dat | 7, 8, 8, 27, 30, 100, 32, 25, 6, 13, 4, 4, 6, 16, 7, 32
Parameters
index A value from the MS_REVIEW_COL enumeration.
Returns
column width for the given number.

◆ getSearchLogFile()

std::string getSearchLogFile ( ) const

Returns the value of SearchLogFile.

This path defines where search log file should be stored.

Parameter | SearchLogFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../logs/searches.log
Value in mascot.dat | [not defined]
Returns
the relative or absolute path to the searches log.

◆ getSearchSubmitAcceptedFileTypes()

std::string getSearchSubmitAcceptedFileTypes ( ) const

Returns a list of accepted input file types in the Mascot search form.

Returns accepted input the file formats of searches submitted through the search form.

The setting SearchSubmitAcceptedFileTypes is a list of input file formats selectable in the browser-based search form (search_form.pl). The default is MGF (Mascot generic) and mzML. Mascot supports other file formats, most of which are no longer in use.

The full list of file types is:

Mascot generic
Sequest (.DTA)
Finnigan (.ASC)
Micromass (.PKL)
PerSeptive (.PKS)
PerSeptive (.PKM)
Sciex API III
Bruker reportfile
Bruker (.XML)
mzData (.XML)
mzML (.mzML)

Parameter | SearchSubmitOutputFormat
Permitted values | A comma-separated list of the supported file formats
Default (if no parameter in mascot.dat) | Mascot generic,mzML (.mzML)
Value in mascot.dat | Mascot generic,mzML (.mzML)
Returns
currently defined value.

◆ getSearchSubmitDefaultPeptideCharge()

std::string getSearchSubmitDefaultPeptideCharge ( ) const

Returns the value in the CHARGE parameter when the peptide charge control is hidden in the search form.

Parameter | SearchSubmitDefaultPeptideCharge
Permitted values One of the following:
  • 8-
  • 7-
  • 6-
  • 5-
  • 4-
  • 3-
  • 2-
  • 2-, 3- and 4-
  • 2- and 3-
  • 2-
  • 1-, 2- and 3-
  • 1-
  • Mr
  • 1+
  • 1+, 2+ and 3+
  • 2+
  • 2+ and 3+
  • 2+, 3+ and 4+
  • 3+
  • 4+
  • 5+
  • 6+
  • 7+
  • 8+
Default
(if no parameter in mascot.dat) 		2+, 3+ and 4+
Value in mascot.dat | 2+, 3+ and 4+
Returns
currently defined value.

◆ getSearchSubmitMode()

std::string getSearchSubmitMode ( ) const

Returns the Mascot search submission mode.

In Mascot 2.5 and later, searches submitted through the search form report progress feedback asynchronously. Once the input file is uploaded, Mascot redirects from the search form to a separate search progress page.

If SearchSubmitMode is async, Mascot behaves as described above. If the value is direct, progress is reported directly by the nph-mascot.exe executable as in Mascot 2.4 and earlier. The downside of "direct" mode is that closing the web browser may kill the search.

Parameter | SearchSubmitMode
Permitted values | async or direct
Default (if no parameter in mascot.dat) | asynchronous
Value in mascot.dat | [not defined]
Returns
currently defined value.

◆ getSearchSubmitOutputFormat()

std::string getSearchSubmitOutputFormat ( ) const

Returns the Mascot search submission output format.

Returns the file format of searches submitted through the search form.

In Mascot 3.0 and later, searches submitted through the search form default to the new Mascot Search Results (MSR) file format. This is a relational database saved as an SQLite file and fully supported from Parser 3.0 onward.

If SearchSubmitOutputFormat is msr, Mascot behaves as described above. If the value is dat28, Mascot will write results in the old text-based .dat format compatible with Mascot Server 2.8. Choosing dat28 is only relevant if your application submits searches through the web based search form, and then reads the file directly from the 'daily' directory on the Mascot server. If you download search results using the client.pl or export_dat_2.pl API, set SearchSubmitOutputFormat to msr – the scripts automatically convert from MSR to .dat as needed.

If SearchSubmitOutputFormat is dat28,msr, then Mascot writes the results in two files, one in .dat format and one in MSR format. This combination doubles the amount of disk space used by new searches and is only recommended for testing purposes.

Parameter | SearchSubmitOutputFormat
Permitted values | dat28 or msr or dat28,msr
Default (if no parameter in mascot.dat) | msr
Value in mascot.dat | msr
Returns
currently defined value.

◆ getSelectSwitch()

int getSelectSwitch ( ) const

Returns the value of SelectSwitch.

This function and getMudpitSwitch() replaced the single function getMudpit() in Mascot 2.1 and earlier.

Parameter | SelectSwitch
Permitted values | Any integer >= 0
Default (if no parameter in mascot.dat) | 1000
Value in mascot.dat | 1000
Returns
The minimum number of queries for a select summary.

◆ getSendmailPath()

std::string getSendmailPath ( ) const

Returns the value of sendmailPath.

sendmailPath is the path to sendmail or BLAT programs.

See also
getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | sendmailPath
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | /usr/lib/sendmail
Value in mascot.dat | /usr/lib/sendmail
Returns
the full or relative path to sendmail or BLAT.

◆ getShowSubsets()

double getShowSubsets ( ) const

Returns the value of ShowSubSets.

If you have a primary hit with (say) 100 peptide matches, you are very interested in sub-set proteins with 99 matches but not if they only have 1 or 2 matches. These are the sub-set hits that clutter up the report if Show Sub-sets is checked in Mascot 2.1 and earlier. If you have a primary hit with (say) 2 peptide matches, you are more likely to be interested in sub-set proteins with just 1 match.

A value of 1 indicates that all proteins with a subset of matches should be reported. A value of 0 indicates that no subsets will be reported.

See also
ms_mascotresults::setSubsetsThreshold()
Parameter | ShowSubSets
Permitted values | Floating point in range 0 to 1 inclusive
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns
The fractional score required for a protein to be counted as a subset. Its score must be greater than or equal to main_protein_score * (1 - getShowSubsets()).

◆ getSigThreshold()

double getSigThreshold ( ) const

Returns the value of SigThreshold.

Significance threshold used in results reports.

This global default can be overridden on an individual report URL be appending &_sigthreshold=X, where X is the significance threshold.

Parameter | SigThreshold
Permitted values | Floating point 1e-18 to 1.0
Default (if no parameter in mascot.dat) | 0.05
Value in mascot.dat | 0.05
Returns
the significance threshold.

◆ getSiteAnalysisMD10Prob()

double getSiteAnalysisMD10Prob ( ) const

Returns the value of SiteAnalysisMD10Prob.

SiteAnalysisMD10Prob is used in calculating relative probabilities of modification assignments in Peptide View. It defines the factor in probability that a peptide score difference of 10 corresponds to. The default is 0.1, which means a score difference of 10 corresponds to a factor of 10 in probability. Similarly, 0.05 corresponds to a factor of 20.

Parameter | SiteAnalysisMD10Prob
Permitted values | Floating point 1e-18 to 1.0
Default (if no parameter in mascot.dat) | 0.1
Value in mascot.dat | 0.1
Returns
the MD10Score value.

◆ getSortUnassigned()

std::string getSortUnassigned ( ) const

Returns the value of SortUnassigned.

Parameter | SortUnassigned
Permitted values | "scoredown", "queryup" or "intdown"
Default (if no parameter in mascot.dat) | scoredown
Value in mascot.dat | [not defined]
Returns
The returned value will be one of:
  • scoredown - descending score
  • queryup - query order
  • intdown - intensity order

◆ getSpectraPerLibraryBlock()

int getSpectraPerLibraryBlock ( ) const

Returns the number of spectra in a spectral library block.

The NIST spectral library tools have a limit of about 600k spectra. Mascot deals with larger files by splitting them up into chunks each with the maximum number of spectra specified by this value.

Parameter | SpectraPerLibraryBlock
Permitted values | Any integer > 0.
Default (if no parameter in mascot.dat) | 500000
Value in mascot.dat | 500000
Returns
the maximum number of spectra before splitting into separate blocks

◆ getSpectrumViewerColourSchemeNames()

std::vector< std::string > getSpectrumViewerColourSchemeNames ( ) const

Returns the names of all colour schemes (SpectrumViewerColourScheme).

See also
getSpectrumViewerColourSchemeString()
Returns
A vector of colour scheme names defined in mascot.dat.

◆ getSpectrumViewerColourSchemeString()

std::string getSpectrumViewerColourSchemeString ( const std::string & name ) const

Returns SpectrumViewerColourScheme by name.

Spectrum Viewer colour schemes were added in Mascot 2.6, and they allow you to choose different peak colours in Peptide View.

Colour scheme name must contain ASCII letters and numbers only; no special characters are allowed.

Each colour scheme is a comma-separated list of key=value pairs, where the key is a peak class and value is either a colour name or an RGB value. The permitted peak classes are:

  • unmatched
  • internal_ion
  • immonium_ion
  • terminal_series_ion
  • terminal_series_ion_nl
  • library_peak

The colour is either one of the 16 HTML 4.01 colour names:

  • white
  • silver
  • gray
  • black
  • red
  • maroon
  • yellow
  • olive
  • lime
  • green
  • aqua
  • teal
  • blue
  • navy
  • fuchsia
  • purple
  • orange

Or an RGB value in standard CSS format, #rrggbb. For example, pure red is #ff0000. Letter case does not matter in colour names or hexadecimal digits.

Note that "orange" is not an HTML 4.01 colour name. It is accepted as a special exception, since it is a valid colour name in CSS 2.1.

Parameter | SpectrumViewerColourScheme_XXX
Permitted values | A comma-separated list of key=value pairs (see above)
Default (if no parameter in mascot.dat) | SpectrumViewerColourScheme_screen unmatched=black,internal_ion=orange,immonium_ion=orange,terminal_series_ion=red,terminal_series_ion_nl=orange,library_peak=blue
Value in mascot.dat | SpectrumViewerColourScheme_screen unmatched=black,internal_ion=orange,immonium_ion=orange,terminal_series_ion=red,terminal_series_ion_nl=orange,library_peak=blue
Parameters
name Colour scheme name; the defined names are returned by getSpectrumViewerColourSchemeNames().
Returns
The colour scheme string, or the empty string if the colour scheme does not exist.

◆ getSpectrumViewerDefaultColourSchemeName()

std::string getSpectrumViewerDefaultColourSchemeName ( ) const

Return the name of the default colour scheme (SpectrumViewerDefaultColourScheme).

The colour scheme used in Peptide View by default is the scheme named here.

See also
getSpectrumViewerColourSchemeString()
Parameter | SpectrumViewerDefaultColourScheme
Permitted values | colour scheme name
Default (if no parameter in mascot.dat) | screen
Value in mascot.dat | screen
Returns
The name of the default colour scheme.

◆ getSplitDataFileSize()

int getSplitDataFileSize ( ) const

Returns the value of SplitDataFileSize.

See getSplitNumberOfQueries() for a description.

Parameter | SplitDataFileSize
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 20000000
Value in mascot.dat | 20000000
Returns
the maximum size (bytes) of each chunk.

◆ getSplitNumberOfQueries()

int getSplitNumberOfQueries ( ) const

Returns the value of SplitNumberOfQueries.

Used in conjunction with SplitDataFileSize parameter. When large amount of spectra is submitted the input file is split into several chunks. Each chunk contains no more than SplitNumberOfQueries queries and no more than SplitDataFileSize bytes long.

Parameter | SplitNumberOfQueries
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 2000
Value in mascot.dat | 2000
Returns
the maximum number of queries in each chunk.

◆ getSVGSpectrumSwitch()

int getSVGSpectrumSwitch ( ) const

Returns the value of SVGSpectrumSwitch.

Mascot 2.5 introduced SVG-based graphics in Peptide View. Since the graphics is rendered in the browser, spectra with a large number of peaks may cause Peptide View to load much slower than in Mascot 2.4 and ealier.

SVGSpectrumSwitch is the cut-off point where Peptide View reverts to the static spectrum graphic used in Mascot 2.4 and earlier. If the spectrum has more peaks than SVGSpectrumSwitch, the old graphic is used; otherwise the new SVG-based graphic is shown. In particular, if you set SVGSpectrumSwitch to 0, the new SVG-based graphic is never shown. If you set it to the maximum value (100000), the SVG-based graphic is always shown.

Parameter | SVGSpectrumSwitch
Permitted values | 0-100000
Default (if no parameter in mascot.dat) | 2000
Value in mascot.dat | 2000
Returns
cut-off point where Peptide View reverts to the static spectrum graphic

◆ getTargetFDRPercentage()

double getTargetFDRPercentage ( const int index ) const

Returns an element of the TargetFDRPercentages list by its number.

For more information on the TargetFDRPercentages parameter see getNumberOfTargetFDRPercentages().

Parameters
index element number from 0 to (getNumberOfTargetFDRPercentages()-1).
Returns
an element of the list that corresponds to the given index. Returns 0 if the index is not valid.

◆ getTaxBrowserUrl()

std::string getTaxBrowserUrl ( ) const

Returns value of the TaxBrowserUrl.

The URL used in reports to retrieve taxonomy information for a Protein View report.

Parameter | TaxBrowserUrl
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | http://www.ncbi.nlm.nih.gov/Taxonomy/Browser/wwwtax.cgi?lvl=0&id=#TAXID#
Returns
the URL.

◆ getTestDirectory()

std::string getTestDirectory ( ) const

Returns the value of TestDirectory.

TestDirectory contains the input files used by Monitor to test new sequence databases.

Parameter | TestDirectory
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data/test
Value in mascot.dat | ../data/test
Returns
the test directory.

◆ getUniqueJobStartNumber()

int getUniqueJobStartNumber ( ) const

Returns the value of UniqueJobStartNumber.

See getMascotJobIdFile() for explanations on usage of this parameter.

Parameter | UniqueJobStartNumber
Permitted values | Integer >= 0
Default (if no parameter in mascot.dat) | 1234
Value in mascot.dat | 1234
Returns
the start job number to be used if the job id file does not exist.

◆ getUnixDirPerm()

int getUnixDirPerm ( ) const

Returns the value of UnixDirPerm.

Specify the Unix permissions for the 'daily' result file directories and the logs directory. For example, 775 makes each directory world readable but not writeable.

See also
getUnixWebUserGroup()
Parameter | UnixDirPerm
Permitted values | Any integer in octal format
Default (if no parameter in mascot.dat) | 777 (octal)
Value in mascot.dat | [not defined]
Returns
the permissions flag.

◆ getUnixWebUserGroup()

int getUnixWebUserGroup ( ) const

Returns the value of UnixWebUserGroup.

The paramater UnixWebUserGroup, if present, will restrict access to the files created by ms-monitor.exe, and hence improve system security. UnixWebUserGroup parameter value is the id of the group used by the web server to run CGI programs.

With Apache, the group name will generally be nobody or apache and you will need to ascertain the group number from the group file. For other Web servers, check the documentation that comes with the server to find out which user name is used for running CGI programs.

A value of -2 can be used if the same user name is used to run Web server scripts as runs ms-monitor.exe. In this case, the files created by ms-monitor.exe will not be world accessible, and chown is not used on the files to change ownership.

Parameter | UnixWebUserGroup
Permitted values | Any text string
Default (if no parameter in mascot.dat) | -1
Value in mascot.dat | [not defined]
Returns
the id of the group.

◆ getVmemory()

INT64 getVmemory ( ) const

Returns the value of Vmemory.

Alpha Tru64 only. When setting resource limits for address space, this is the maximum number of bytes requested. If a value of -1 is specified, then the maximum system value is requested.

Parameter | Vmemory
Permitted values | 64 bit integer >= -1
Default (if no parameter in mascot.dat) | -1
Value in mascot.dat | [not defined]
Returns
the vmemory limit.

◆ isAlwaysCreateDat28ResultsFile()

bool isAlwaysCreateDat28ResultsFile ( ) const

Returns the value of AlwaysCreateDat28ResultsFile.

This option is only intended for backwards compatibility with third-party software.

If AlwaysCreateDat28ResultsFile is set to 0, the file format for search results defaults to Mascot Search Results (MSR). The task ID is associated with the filename F001234.msr. If set to 1, then nph-mascot.exe writes search results in two files, F001234.msr (MSR) and F001234.dat (dat28). The task ID is associated with the filename F001234.dat.

The behaviour can be overriden by the client program by using the -format argument when submitting the search to nph-mascot.exe. The behaviour can also be overriden in the Mascot search form with getSearchSubmitOutputFormat(). The setting AlwaysCreateDat28ResultsFile should only be used if these alternatives are infeasible.

Parameter | AlwaysCreateDat28ResultsFile
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns
true if Mascot searches should always create a result file in dat28 format

◆ isAlwaysEnableAutoDecoySearch()

bool isAlwaysEnableAutoDecoySearch ( ) const

Returns true if Mascot always runs an automatic target-decoy search.

Controls whether to run an automatic decoy search. Before Mascot Server 3.0, an automatic target-decoy search was only run if the search parameter DECOY=1 is set. From Mascot Server 3.0, if AlwaysEnableAutoDecoySearch is 1 (default), nph-mascot.exe defaults to DECOY=1 unless overridden by the DECOY search parameter. The Decoy checkbox is not shown in the browser-based search form. A decoy search is only omitted for unsupported search types (currently spectral library searches and intact crosslink searches).

If set to 0, the Decoy checkbox is shown in the browser-based search form and defaults to unchecked, and nph-mascot.exe defaults to DECOY=0 unless overridden by the DECOY search parameter.

Parameter | AlwaysEnableAutoDecoySearch
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 1
Returns
true if nph-mascot.exe should always write a dat28 (.dat) file

◆ isAutoSelectCharge()

bool isAutoSelectCharge ( ) const

Returns the value of AutoSelectCharge.

When this parameter is set to 1 only the charge state that gives the best ion score is reported for each query. Otherwise, each query will be transformed and split into several queries (one for each possible charge state).

Parameter | AutoSelectCharge
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 1
Returns
true if the auto selection of charge is enabled.

◆ isCreateLegacyModAndSubstitutionFiles()

bool isCreateLegacyModAndSubstitutionFiles ( ) const

Returns true if Mascot Monitor creates legacy files containing modification definitions.

This option is meant for backwards compatibility with very old third-party software. Mascot Server 2.1 and earlier saved modification definitions in three files, ../config/mod_file, ../config_masses and ../config/substitutions. Since Unimod support was added in Mascot Server 2.2, these files have been automatically generated from unimod.xml.

Set the option to true (1) and Mascot Monitor will create the legacy files. Note that this option may be removed in a future Mascot release.

Parameter | CreateLegacyModAndSubstitutionFiles
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns
true if Mascot Monitor should create obsolete mod_file, substitutions and masses files

◆ isDefaultTargetFDRPercentage()

bool isDefaultTargetFDRPercentage ( const int index ) const

Returns true if the element of TargetFDRPercentages is a default value.

For more information on the TargetFDRPercentages parameter see getNumberOfTargetFDRPercentages().

Parameters
index element number from 0 to (getNumberOfTargetFDRPercentages()-1).
Returns
true if the element is marked as a default value.

◆ isEmailErrorsEnabled()

bool isEmailErrorsEnabled ( ) const

Returns the value of EmailErrorsEnabled.

Serious error messages can be emailed to an administrator. This facility can be enabled by setting EmailErrorsEnabled to 1 or disabled by setting it to 0.

Error messages that are considered serious are identified in the file errors.html. This file can be found in the root directory of the installation CD-ROM.

A number of other parameters are required to send e-mail messages. See isEmailUsersEnabled(), getErrMessageEmailTo(), and getMailTransport() for more information.

Parameter | EmailErrorsEnabled
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
true if error messages should be emailed to the Mascot server administrator.

◆ isEmailUsersEnabled()

bool isEmailUsersEnabled ( ) const

Returns the value of EmailUsersEnabled.

When the search engine executes as a CGI application, email can be used to send the results of a search to a user who accidentally or deliberately disconnected before the search was complete. This facility can be enabled by setting EmailUsersEnabled to 1 or disabled by setting it to 0.

If EmailUsersEnabled is set to 1, search results will be emailed to a user if their web browser does not respond within the number of seconds specified in EmailTimeOutPeriod following the completion of a search. See getEmailTimeOutPeriod().

Email messages can be sent in batches at intervals specified by MonitorEmailCheckFreq (in seconds). See getMonitorEmailCheckFreq().

MailTempFile is the name of the temporary file used to store email messages until they can be sent. See getMailTempFile().

A number of other parameters are used to define how email should be sent. You can find some more information about other parameters in the the Mascot installation and setup manual.

See also
getMailTransport()
Parameter | EmailUsersEnabled
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
the flag indicating if emails with a link to results should be sent.

◆ isForkForUnixApache()

bool isForkForUnixApache ( ) const

Returns the value of ForkForUnixApache.

If a user presses Stop or goes to another page in their browser when a search is running, then the intended behaviour is that the search should continue, and the user be emailed with their results.

However, when running some versions of Apache under Unix, the search is terminated by Apache when the connection to the browser is lost. To stop this from happening, set this value to 1.

Windows versions of Mascot prior to 2.5.1 also used this parameter and attempted to emulate a 'fork' after the search started. However, with Windows 7 and later versions, this was very unreliable and the functionality was removed from the Windows version of nph-mascot.exe in Mascot Server version 2.5.1. However, this Mascot Parser function still returns the value in mascot.dat for both Windows and Linux.

Parameter | ForkForUnixApache
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
true if the nph-mascot.exe process should be forked at startup

◆ isInIgnoreDupeAccessionList()

bool isInIgnoreDupeAccessionList ( const std::string value ) const

Checks to see if the passed database name is in the list databases that shouldn't be checked for duplicate accessions.

When FASTA files are compressed, they are checked to ensure that there are no duplicate accession strings. For a large EST database with many millions of entries, this can take up a lot of memory. Adding a database to the list of values for the IgnoreDupeAccessions entry in mascot.dat prevents this database from being tested.

Parameter | IgnoreDupeAccessions
Permitted values | text strings delimted by tab, space and comma
Default (if no parameter in mascot.dat) | EST_others
Value in mascot.dat | EST_others
Parameters
value is the name of the databases to check.
Returns
true if the database is in the list.

◆ isIteratePMFIntensities()

bool isIteratePMFIntensities ( ) const

Returns value of the IteratePMFIntensities.

The IteratePMFIntensities parameter is used in order to switch off iterative PMF scoring. If the parameter is set to 1 mascot will try to use only as many queries for scoring as necessary to achieve the best PMF score.

Parameter | IteratePMFIntensities
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 1
Returns
TRUE if the parameter is set to 1 and FALSE otherwise.

◆ isLabelAll()

bool isLabelAll ( ) const
obsolete

Returns the value of LabelAll.

LabelAll is obsolete. Peptide View in Mascot 3.0 and later always shows all annotated peaks.

If LabelAll is set to 1, the initial display in Peptide View is the one in which all peaks that match a calculated mass value are labelled.

Parameter | LabelAll
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
true if if all peaks that match a calculated mass value should be labelled in Peptide View.

◆ isMatchOppositeCrosslinkPairs()

bool isMatchOppositeCrosslinkPairs ( ) const

Returns the value of MatchOppositeCrosslinkPairs.

Mascot 2.7 and later support intact crosslinking. Normally Mascot only stores a match to the alpha-beta pair, where the alpha has the higher Mr, longer sequence or is alphabetically first (in this order).

If this setting is 1, both alpha-beta and beta-alpha matches are stored in the results file. Enabling the setting is only useful for debugging purposes.

Parameter | MatchOppositeCrosslinkPairs
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns
true if for each crosslink pair, the opposite combination should also be considered for matching

◆ isMoveOldDbToOldDir()

bool isMoveOldDbToOldDir ( ) const

Returns the value of MoveOldDbToOldDir.

After a successful database swap, the old fasta file and old reference file are moved to the ../old directory unless this is set to 0 in which case the files are simply deleted.

Parameter | MoveOldDbToOldDir
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | [not defined]
Returns
true if old fasta and reference files are moved to the old directory

◆ isPercolator()

bool isPercolator ( ) const

Returns the value of Percolator.

Returns true if percolated results should be opened by default.

See Using Percolator scores for further information.

Parameter | Percolator
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 1
Returns
true if percolated results should be opened by default.

◆ isPercolatorUseProteins()

bool isPercolatorUseProteins ( ) const

Returns the value of PercolatorUseProteins.

Percolator can use the assignment of proteins to peptides to improve specificity. However, this is risky in some situations so can be switched off.

Currently not supported

See Using Percolator scores for further information.

Parameter | PercolatorUseProteins
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
true if percolator should use protein features.

◆ isPercolatorUseRT()

bool isPercolatorUseRT ( ) const

Returns the value of PercolatorUseRT.

Percolator can use retention times of peptides to improve specificity. However, this is risky in some situations so can be switched off.

See Using Percolator scores for further information.

Parameter | PercolatorUseRT
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
true if percolator should use retention times.

◆ isRemoveOldIndexFiles()

bool isRemoveOldIndexFiles ( ) const

Returns the value of RemoveOldIndexFiles.

After a successful database swap, the compressed files in the current directory are deleted unless this is set to 0.

Parameter | RemoveOldIndexFiles
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | [not defined]
Returns
true if compressed files in the current directory are deleted after a swap

◆ isRequireBoldRed()

bool isRequireBoldRed ( ) const

Returns the value of RequireBoldRed.

If RequireBoldRed is set to 1 in a Peptide Summary report, only protein matches which have one or more 'bold red' peptide matches will be listed. That is, proteins that include at least one top ranking peptide match that has not already appeared in the report.

Not used for the Protein Family Summary report and when ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified.

Parameter | RequireBoldRed
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
true if all proteins must contain a bold red peptide.

◆ isSaveEveryLastQueryAsc()

bool isSaveEveryLastQueryAsc ( ) const

Returns the value of SaveEveryLastQueryAsc.

If set to 1, the Mascot input file will be saved for any search that fails to complete because it generates a fatal error. The name of the output file follows the same naming convention as a normal Mascot output file, except for the additional suffix .inp. If a search goes to completion, this file is deleted as soon as the normal output file has been written to disk.

See also
isSaveLastQueryAsc(), getLastQueryAscFile().
Parameter | SaveEveryLastQueryAsc
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 0
Returns
true if the value in the file is '1'.

◆ isSaveLastQueryAsc()

bool isSaveLastQueryAsc ( ) const

Returns the value of SaveLastQueryAsc.

SaveLastQueryAsc is a flag which controls whether the most recent input file to Mascot (i.e. the MIME format file containing MS data and search parameters) should be saved to disk (1) or not (0). This can be a useful debugging tool when writing scripts or forms to submit searches to Mascot.

If SaveLastQueryAsc is set to 1, the name of the file is determined by LastQueryAscFile.

Each new search overwrites this file.

See also
isSaveEveryLastQueryAsc(), getLastQueryAscFile().
Parameter | SaveLastQueryAsc
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
true if the value in the file is '1'.

◆ isSectionAvailable()

bool isSectionAvailable ( ) const

Indicates whether the section has been actually read from the file.

The Options section is unavailable until it has been read from the file. This function doesn't normally need to be used by client applications.

Returns
true if the seciton is available.
Examples
config_mascotdat.cpp.

◆ isShowAllFromErrorTolerant()

bool isShowAllFromErrorTolerant ( ) const

Returns the value of ShowAllFromErrorTolerant.

If ShowAllFromErrorTolerant is set to 0, result resports of manual error tolerant searches show only those matches that satisfy two criteria: (i) the score must be at least as high as the match for the same query in the original "parent" search, (ii) the score equals or exceeds the identity threshold for the same query in the original "parent" search. Setting ShowAllFromErrorTolerant to 1 causes all matches to be displayed.

Parameter | ShowAllFromErrorTolerant
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
true if all matches should be displayed in manual error tolerant searches.

◆ isShowSubsets()

bool isShowSubsets ( ) const

Returns the value of ShowSubSets.

Deprecated:
See getShowSubsets().
Parameter | ShowSubSets
Permitted values | Floating point in range 0 to 1 inclusive
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns
true if the return from getShowSubsets is greater than 0.

◆ isStoreModPermutations()

bool isStoreModPermutations ( ) const

Returns the value of StoreModPermutations.

If set to 0, only the highest scoring permutation of variable modifications for each unique peptide sequence is retained in the list of the top 10 ions scores. If set to 1, then different permutations of variable modifications are treated as independent matches, creating the possibility that all 10 top ions scores correspond to the same primary sequence.

Parameter | StoreModPermutations
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | [not defined]
Returns
true if peptides with different modification permuatation should be stored.

◆ isUnixDirPermDefined()

bool isUnixDirPermDefined ( ) const

Returns true if the UnixDirPerm value is defined.

See getUnixDirPerm().

Parameter | UnixDirPerm
Permitted values | Any integer in octal format
Default (if no parameter in mascot.dat) | 777 (octal)
Value in mascot.dat | [not defined]
Returns
true if there is a value in mascot.dat.

◆ isUseHTTPProxyForFTP()

bool isUseHTTPProxyForFTP ( ) const

Returns the value of UseHTTPProxyForFTP.

This parameter allows making FTP requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

The default is false. You should only alter the setting if FTP requests fail.

Parameter | UseHTTPProxyForFTP
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
true if FTP requests should use the HTTP proxy server.

This option is ignored on Windows if auto proxy configuration is enabled.

◆ isUseHTTPProxyForHTTPS()

bool isUseHTTPProxyForHTTPS ( ) const

Returns the value of UseHTTPProxyForHTTPS.

This parameter allows making HTTPS requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

The default is false. You should only alter the setting if HTTPS requests fail.

Parameter | UseHTTPProxyForHTTPS
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns
true if HTTPS requests should use the HTTP proxy server.

This option is ignored on Windows if auto proxy configuration is enabled.

◆ setAlwaysCreateDat28ResultsFile()

void setAlwaysCreateDat28ResultsFile ( const bool value )

Sets the value of AlwaysCreateDat28ResultsFile.

For a description of this function, see isAlwaysCreateDat28ResultsFile().

Parameters
value is the new setting.

◆ setAlwaysEnableAutoDecoySearch()

void setAlwaysEnableAutoDecoySearch ( const bool value )

Sets AlwaysEnableAutoDecoySearch.

For a description of this function, see isAlwaysEnableAutoDecoySearch().

Parameters
value is the new setting.

◆ setAutoSelectCharge()

void setAutoSelectCharge ( const bool value )

Sets AutoSelectCharge.

For a description of this function, see isAutoSelectCharge().

Parameters
value is the new setting.

◆ setCacheDirectory()

void setCacheDirectory ( const char * value )

Sets CacheDirectory.

For a description of this function, see getCacheDirectory(). If the provided value is null, the existing value will be kept.

Parameters
value is the new cache directory.

◆ setCentroidWidth()

void setCentroidWidth ( const double value )

Sets CentroidWidth.

For a description of this function, see getCentroidWidth(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new centroid width.

◆ setCentroidWidthCount()

void setCentroidWidthCount ( const int value )

Sets CentroidWidthCount.

For a description of this function, see getCentroidWidthCount(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new peak count threshold.

◆ setCompressToolAA()

void setCompressToolAA ( const std::string value )

Sets CompressTool_AA.

For a description of this function, see getCompressToolAA() If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting

◆ setCompressToolNA()

void setCompressToolNA ( const std::string value )

Sets CompressTool_NA.

For a description of this function, see getCompressToolNA() If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting

◆ setCompressToolSL()

void setCompressToolSL ( const std::string value )

Sets CompressTool_NA.

For a description of this function, see getCompressToolSL() If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting

◆ setCrawlerNumPeaksPer100Da()

void setCrawlerNumPeaksPer100Da ( const int value )

Sets the number of peaks to output in each 100 Da window for the library crawler.

Sets the number of peaks to output in each 100 Da window for the library crawler If the provided value is not valid, the existing value will be kept.

Parameters
value must be a number greater than zero

◆ setCreateLegacyModAndSubstitutionFiles()

void setCreateLegacyModAndSubstitutionFiles ( const bool value )

Sets an option for backwards compatibility with very old software.

For a description of this function, see isCreateLegacyModAndSubstitutionFiles().

Parameters
value is the new setting.

◆ setCreatePipThreadBlockSize()

void setCreatePipThreadBlockSize ( const int blockSize )

Sets CreatePipThreadBlockSize.

For a description of this function, see getCreatePipThreadBlockSize(). If the provided value is not valid, the existing value will be kept.

Parameters
blockSize is .

◆ setCreatePipThreads()

void setCreatePipThreads ( const int nThreads )

Sets CreatePipThreads.

For a description of this function, see getCreatePipThreads(). If the provided value is not valid, the existing value will be kept.

Parameters
nThreads is the number of threads used to generate the Percolator input file.

◆ setDechargeFragmentPeaks()

void setDechargeFragmentPeaks ( const int maxCharge )

Sets the maximum fragment ion charge state to be decharged.

For a description of this function, see getDechargeFragmentPeaks(). If the provided value is not valid, the existing value will be kept.

Parameters
maxCharge must be zero or a positive integer

◆ setDecoyTypeNoEnzyme()

void setDecoyTypeNoEnzyme ( const int value )

Sets DecoyTypeNoEnzyme.

For a description of this function, see getDecoyTypeNoEnzyme(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting.

◆ setDecoyTypeSpecific()

void setDecoyTypeSpecific ( const int value )

Sets DecoyTypeSpecific.

For a description of this function, see getDecoyTypeSpecific(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting.

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setDefaultTargetFDRPercentage()

void setDefaultTargetFDRPercentage ( const int index )

Makes an element of TargetFDRPercentages at the given index the default value.

See getTargetFDRPercentage() for more information. If the provided index is not valid, the existing value will be kept.

Parameters
index is the index of the item to set. index must be between 0 and getNumberOfTargetFDRPercentages()-1.

◆ setDisplayNonSignificantMatches()

void setDisplayNonSignificantMatches ( const int value )

Sets DisplayNonSignificantMatches.

For a description of this function, see getDisplayNonSignificantMatches().

Parameters
value is the new setting. If it is not one of the permitted values, the setting remains unchanged.

◆ setEmailErrorsEnabled()

void setEmailErrorsEnabled ( const bool value )

Sets EmailErrorsEnabled.

For a description of this function, see isEmailErrorsEnabled().

Parameters
value specified whether errors should be emailed.

◆ setEmailFromTextName()

void setEmailFromTextName ( const char * str )

Sets EmailFromTextName.

For a description of this function, see getEmailFromTextName(). If the provided value is null, the existing value will be kept.

Parameters
str is the new name of the user from which email appears to come.

◆ setEmailFromUser()

void setEmailFromUser ( const char * str )

Sets EmailFromUser.

For a description of this function, see getEmailFromUser(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new email address of the user from which email appears to come.

◆ setEmailPassword()

void setEmailPassword ( const char * str )

Sets EmailPassword.

For a description of this function, see getEmailPassword(). If the provided value is null, the existing value will be kept.

Parameters
str is the new email password.

◆ setEmailProfile()

void setEmailProfile ( const char * str )

Sets EmailPassword.

For a description of this function, see getEmailProfile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the email profile.

◆ setEmailService()

void setEmailService ( const char * str )

Sets EmailService.

For a description of this function, see getEmailService(). If the provided value is null, the existing value will be kept.

Parameters
str is the new email service name.

◆ setEmailTimeOutPeriod()

void setEmailTimeOutPeriod ( const int value )

Sets EmailTimeOutPeriod.

For a description of this function, see getEmailTimeOutPeriod(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new timeout period.

◆ setEmailUsersEnabled()

void setEmailUsersEnabled ( const bool value )

Sets EmailUsersEnabled.

For a description of this function, see isEmailUsersEnabled().

Parameters
value specifies whether users should be emailed.

◆ setErrMessageEmailTo()

void setErrMessageEmailTo ( const char * str )

Sets ErrMessageEmailTo.

For a description of this function, see getErrMessageEmailTo(). If the provided value is null, the existing value will be kept.

Parameters
str is the new name of the person to send errors to.

◆ setErrorLogFile()

void setErrorLogFile ( const char * str )

Sets ErrorLogFile path.

For a description of this function, see getErrorLogFile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the errorlog file.

◆ setErrTolMaxAccessions()

void setErrTolMaxAccessions ( const int value )

Sets ErrTolMaxAccessions.

For a description of this function, see getErrTolMaxAccessions(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new maximum.

◆ setExecAfterSearch()

void setExecAfterSearch | ( | const int | num,
 |  | std::string | value
 | ) |  |

Sets ExecAfterSearch_XXX.

For a description of this function, see getExecAfterSearch(). If the provided value is not valid, the existing value will be kept.

Parameters
num | is the 1 based number for the ExecAfterSearch_[num] parameter.
value | is the command to be run.

◆ setFeatureTableLength()

void setFeatureTableLength ( const int value )

Sets FeatureTableLength.

For a description of this function, see getFeatureTableLength(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new length.

◆ setFeatureTableMinScore()

void setFeatureTableMinScore ( const double value )

Sets FeatureTableMinScore.

For a description of this function, see getFeatureTableMinScore(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new minimum score.

◆ setForkForUnixApache()

void setForkForUnixApache ( const bool value )

Sets ForkForUnixApache.

For a description of this function, see isForkForUnixApache().

Parameters
value specifies whether the fork command should be used.

◆ setFormVersion()

void setFormVersion ( const char * str )

Sets FormVersion.

For a description of this function, see getFormVersion(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new version string.

◆ setGetSeqBlastAccession()

void setGetSeqBlastAccession ( const ms_blastaccession * value )

Sets GetSeqBlastAccession.

For a description of this function, see getGetSeqBlastAccession(). If the provided value is null, the existing value will be kept.

Parameters
value is the new setting.

◆ setGetSeqJobIdFile()

void setGetSeqJobIdFile ( const char * str )

Sets GetSeqJobIdFile.

For a description of this function, see getGetSeqJobIdFile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the job id file.

◆ setICATFilter()

void setICATFilter ( const char * filterString )

Sets ICATFilter.

For a description of this function, see getICATFilter(). If the provided value is not valid, the existing value will be kept.

Parameters
filterString is the new name of the ICAT filter.

◆ setICATHeavy()

void setICATHeavy ( const char * modName )

Sets ICATHeavy.

For a description of this function, see getICATHeavy(). If the provided value is null, the existing value will be kept.

Parameters
modName is the new name of the heavy ICAT mod.

◆ setICATLight()

void setICATLight ( const char * modName )

Sets ICATLight.

For a description of this function, see getICATLight(). If the provided value is null, the existing value will be kept.

Parameters
modName is the new name of the light ICAT mod.

◆ setICATQuantitationMethod()

void setICATQuantitationMethod ( const char * methodName )

Sets ICATQuantitationMethod.

For a description of this function, see getICATQuantitationMethod(). If the provided value is not valid, the existing value will be kept.

Parameters
methodName is the new name of the quantitation method.

◆ setIgnoreDupeAccession()

void setIgnoreDupeAccession | ( | const unsigned int | index,
 |  | const std::string | value
 | ) |  |

Sets an item in the IgnoreDupeAccessions list by its index.

See getIgnoreDupeAccession() and isInIgnoreDupeAccessionList() for details.

This method sets the value at the given index.

Parameters
index | is the index of the value to set. index must be between 0 and getNumberOfIgnoreDupeAccessions()-1.
value | is the value to set (the name of the database).

◆ setIgnoreIonsScoreBelow()

void setIgnoreIonsScoreBelow ( const double value )

Sets IgnoreIonsScoreBelow.

For a description of this function, see getIgnoreIonsScoreBelow(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new maximum.

◆ setIntensitySigFigs()

void setIntensitySigFigs ( const int value )

Sets IntensitySigFigs.

For a description of this function, see getIntensitySigFigs(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new number of significant figures.

◆ setInterFileBasePath()

void setInterFileBasePath ( const char * str )

Sets InterFileBasePath.

For a description of this function, see getInterFileBasePath(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new path.

◆ setInterFileRelPath()

void setInterFileRelPath ( const char * str )

Sets InterFileRelPath.

For a description of this function, see getInterFileRelPath(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new path.

◆ setIonsDecimalPlaces()

void setIonsDecimalPlaces ( const int value )

Sets IonsDecimalPlaces.

For a description of this function, see getIonsDecimalPlaces(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new number of decimal places.

◆ setIteratePMFIntensities()

void setIteratePMFIntensities ( const bool value )

Sets IteratePMFIntensities.

For a description of this function, see isIteratePMFIntensities().

Parameters
value is the new setting.

◆ setLabelAll()

void setLabelAll ( const bool value )
obsolete

Sets LabelAll.

For a description of this function, see isLabelAll().

Parameters
value specifies if all peaks that match a calculated mass value should be labelled in Peptide View.

◆ setLastQueryAscFile()

void setLastQueryAscFile ( const char * filename )

Sets LastQueryAscFile to the passed value.

For a description of this function, see isSaveLastQueryAsc(). If the provided value is not valid, the existing value will be kept.

Parameters
filename is the new name of the lastqueryasc file.

◆ setLogoImageFile()

void setLogoImageFile ( const char * str )

Sets LogoImageFile.

For a description of this function, see getLogoImageFile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new logo image file.

◆ setMailTempFile()

void setMailTempFile ( const char * str )

Sets MailTempFile.

For a description of this function, see getMailTempFile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the temp file.

◆ setMailTransport()

void setMailTransport ( const int value )

Sets MailTransport.

For a description of this function, see getMailTransport(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new mail transport option.

◆ setMascNodeCtrlFile()

void setMascNodeCtrlFile ( const char * str )

Sets MascNodeCtrlFile.

For a description of this function, see getMascNodeCtrlFile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the node control file.

◆ setMascotCmdLine()

void setMascotCmdLine ( const char * str )

Sets MascotCmdLine.

For a description of this function, see getMascotCmdLine(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new path.

◆ setMascotControlFile()

void setMascotControlFile ( const char * str )

Sets MascotControlFile.

For a description of this function, see getMascotControlFile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the control file.

◆ setMascotFileProcessingThreads()

void setMascotFileProcessingThreads ( const int value )

Sets MascotFileProcessingThreads.

For a description of this function, see getMascotFileProcessingThreads() If the provided value is not valid, the existing value will be kept.

Parameters
value must be a number greater than zero or -1

◆ setMascotJobIdFile()

void setMascotJobIdFile ( const char * str )

Sets MascotJobIdFile.

For a description of this function, see getMascotJobIdFile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the job id file.

◆ setMascotMessage()

void setMascotMessage ( const char * str )

Sets MascotMessage.

For a description of this function, see getMascotMessage(). If the provided value is null, the existing value will be kept.

Parameters
str is the new message.

◆ setMassDecimalPlaces()

void setMassDecimalPlaces ( const int value )

Sets MassDecimalPlaces.

For a description of this function, see getMassDecimalPlaces(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new number of decimal places.

◆ setMatchOppositeCrosslinkPairs()

void setMatchOppositeCrosslinkPairs ( const bool value )

Sets MatchOppositeCrosslinkPairs.

For a description of this function, see isMatchOppositeCrosslinkPairs().

Parameters
value is the new setting.

◆ setMaxConcurrentSearches()

void setMaxConcurrentSearches ( const int value )

Sets MaxConcurrentSearches.

For a description of this function, see getMaxConcurrentSearches(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new maximum value.

◆ setMaxDatabases()

void setMaxDatabases ( const int value )

Sets MaxDatabases.

For a description of this function, see getMaxDatabases(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new maximum number of databases.

◆ setMaxDescriptionLen()

void setMaxDescriptionLen ( const int value )

Sets MaxDescriptionLen.

For a description of this function, see getMaxDescriptionLen(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new maximum length.

◆ setMaxEtagMassDelta()

void setMaxEtagMassDelta ( const double value )

Sets MaxEtagMassDelta.

For a description of this function, see getMaxEtagMassDelta().

Parameters
value is the new maximum delta.

◆ setMaxEtVarMods()

void setMaxEtVarMods ( const int value )

Sets MaxEtVarMods.

For a description of this function, see getMaxEtVarMods()

Parameters
value is the new maximum in the range 0 to 31.

◆ setMaxIntactCrosslinkPeptides()

void setMaxIntactCrosslinkPeptides ( const int value )

Sets MaxIntactCrosslinkPeptides.

For a description of this function, see getMaxIntactCrosslinkPeptides() If the provided value is not valid, the existing value will be kept.

Parameters
value must be a number greater than zero

◆ setMaxNumPeptides()

void setMaxNumPeptides ( const int value )

Sets MaxNumPeptides.

For a description of this function, see getMaxNumPeptides().

Parameters
value is the new maximum value.

◆ setMaxPepModArrangements()

void setMaxPepModArrangements ( const int value )

Sets MaxPepModArrangements.

For a description of this function, see getMaxPepModArrangements() If the provided value is not valid, the existing value will be kept.

Parameters
value is the new maximum.

◆ setMaxPepNumModifiedSites()

void setMaxPepNumModifiedSites ( const int value )

Sets MaxPepNumModifiedSites.

For a description of this function, see getMaxPepNumModifiedSites(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new maximum number of modified sites.

◆ setMaxPepNumVarMods()

void setMaxPepNumVarMods ( const int value )

Sets MaxPepNumVarMods.

For a description of this function, see getMaxPepNumVarMods(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new maximum number of modifications.

◆ setMaxQueries()

void setMaxQueries ( const int value )

Sets MaxQueries.

For a description of this function, see getMaxQueries(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new maximum number of queries.

◆ setMaxSearchesPerUser()

void setMaxSearchesPerUser ( const int value )

Sets MaxSearchesPerUser.

For a description of this function, see getMaxSearchesPerUser(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the maximum value.

◆ setMaxSequenceLen()

void setMaxSequenceLen ( const int value )

Sets MaxSequenceLen.

For a description of this function, see getMaxSequenceLen(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new maximum length.

◆ setMaxVarMods()

void setMaxVarMods ( const int value )

Sets MaxVarMods.

For a description of this function, see getMaxVarMods().

Parameters
value is the new maximum in the range 0 to 32.

◆ setMinEtagMassDelta()

void setMinEtagMassDelta ( const double value )

Sets MinEtagMassDelta.

For a description of this function, see getMinEtagMassDelta().

Parameters
value is the new minimum delta.

◆ setMinPepLenInPepSummary()

void setMinPepLenInPepSummary ( const int value )

Sets MinPepLenInPepSummary.

For a description of this function, see getMinPepLenInPepSummary(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new minimum length.

◆ setMinPepLenInSearch()

void setMinPepLenInSearch ( const int value )

Sets MinPepLenInSearch.

For a description of this function, see getMinPepLenInSearch(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new minimum setting.

◆ setMonitorEmailCheckFreq()

void setMonitorEmailCheckFreq ( const int value )

Sets MonitorEmailCheckFreq.

For a description of this function, see getMonitorEmailCheckFreq(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new time period.

◆ setMonitorLogFile()

void setMonitorLogFile ( const char * str )

Sets MonitorLogFile.

For a description of this function, see getMonitorLogFile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the monitor log.

◆ setMonitorPidFile()

void setMonitorPidFile ( const char * str )

Sets MonitorPidFile.

For a description of this function, see getMonitorPidFile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the pid file.

◆ setMonitorTestTimeout()

void setMonitorTestTimeout ( const int value )

Sets MonitorTestTimeout.

For a description of this function, see getMonitorTestTimeout(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new timeout period.

◆ setMoveOldDbToOldDir()

void setMoveOldDbToOldDir ( const bool value )

Sets MoveOldDbToOldDir.

For a description of this function, see isMoveOldDbToOldDir().

Parameters
value is the new setting.

◆ setMudpit()

void setMudpit ( const int value )

Sets Mudpit.

For a description of this function, see getMudpit(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting.

◆ setMudpitSwitch()

void setMudpitSwitch ( const double value )

Sets MudpitSwitch.

For a description of this function, see getMudpitSwitch(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new q/e value used to determine which protein scoring method to use.

◆ setNoResultsScript()

void setNoResultsScript ( const char * str )

Sets NoResultsScript.

For a description of this function, see getNoResultsScript(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the script.

◆ setNTIUserGroup()

void setNTIUserGroup ( const char * str )

Sets NTIUserGroup.

For a description of this function, see getNTIUserGroup(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the web user group.

◆ setNTMonitorGroup()

void setNTMonitorGroup ( const char * str )

Sets NTMonitorGroup.

For a description of this function, see getNTMonitorGroup(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the group used by ms-monitor.exe.

◆ setPepSearchTool()

void setPepSearchTool ( const std::string value )

Sets LibrarySearch.

For a description of this function, see getPepSearchTool() If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting

◆ setPercolator()

void setPercolator ( const bool value )

Sets Percolator.

For a description of this function, see isPercolator().

Parameters
value True if percolated results should be opened by default.

◆ setPercolatorExeFlags()

void setPercolatorExeFlags ( const char * value )

Sets PercolatorExeFlags.

For a description of this function, see getPercolatorExeFlags(). If the provided value is null, the existing value will be kept.

Parameters
value is the new flags.

◆ setPercolatorFeatures()

void setPercolatorFeatures ( std::string value )

Sets PercolatorFeatures.

For a description of this function, see getPercolatorFeatures(). If the provided value is empty, the existing value will be kept.

Parameters
value is the new list of features.

◆ setPercolatorMinQueries()

void setPercolatorMinQueries ( const int value )

Sets PercolatorMinQueries.

For a description of this function, see getPercolatorMinQueries(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new minimum number of queries.

◆ setPercolatorMinSequences()

void setPercolatorMinSequences ( const int value )

Sets PercolatorMinSequences.

For a description of this function, see getPercolatorMinSequences(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new minimum number of sequences.

◆ setPercolatorTargetRankRelativeThreshold()

void setPercolatorTargetRankRelativeThreshold ( const double threshold )

Sets PercolatorTargetRankRelativeThreshold.

For a description of this function, see getPercolatorTargetRankScoreThreshold(). If the provided value is not valid, the existing value will be kept.

Parameters
threshold is the minimum relative score difference with rank 1 match.

◆ setPercolatorTargetRankScoreThreshold()

void setPercolatorTargetRankScoreThreshold ( const int threshold )

Sets PercolatorTargetRankScoreThreshold.

For a description of this function, see getPercolatorTargetRankScoreThreshold(). If the provided value is not valid, the existing value will be kept.

Parameters
threshold is the minimum score to include a match in the pip file.

◆ setPercolatorUseProteins()

void setPercolatorUseProteins ( const bool value )

Sets PercolatorUseProteins.

For a description of this function, see isPercolatorUseProteins().

Parameters
value is the new flag.

◆ setPercolatorUseRT()

void setPercolatorUseRT ( const bool value )

Sets PercolatorUseRT.

For a description of this function, see isPercolatorUseRT().

Parameters
value is the new flag.

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPrecursorCutOutLowerLimit()

void setPrecursorCutOutLowerLimit ( const double value )

Sets the first PrecursorCutOut.

For a description of this function, see getPrecursorCutOutLowerLimit().

Parameters
value is the new lower limit.

◆ setPrecursorCutOutUpperLimit()

void setPrecursorCutOutUpperLimit ( const double value )

Sets the second PrecursorCutOut.

For a description of this function, see getPrecursorCutOutUpperLimit().

Parameters
value is the new upper limit.

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ setProteinFamilySwitch()

void setProteinFamilySwitch ( const int value )

Sets ProteinFamilySwitch.

For a description of this function, see getProteinFamilySwitch(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new minimum number of spectra.

◆ setProteinsInResultsFile()

void setProteinsInResultsFile ( const int value )

Sets ProteinsInResultsFile.

For a description of this function, see getProteinsInResultsFile(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting.

◆ setProxyPassword()

void setProxyPassword ( const char * str )

Sets proxy_password.

For a description of this function, see getProxyPassword(). If the provided value is null, the existing value will be kept.

Parameters
str is the new password.

◆ setProxyServer()

void setProxyServer ( const char * str )

Sets proxy_server.

For a description of this function, see getProxyServer. If the provided value is null, the existing value will be kept.

Parameters
str is the new proxy server address/name.

◆ setProxyType()

void setProxyType ( const std::string & value )

Sets ProxyType.

For a description of this function, see getProxyServer.

Parameters
value A case-insensitive string matching one of the ms_connection_settings::PROXY_TYPE values. If value matches none of them, proxy type is set to Auto.

◆ setProxyUsername()

void setProxyUsername ( const char * str )

Sets proxy_username.

For a description of this function, see getProxyUsername(). If the provided value is null, the existing value will be kept.

Parameters
str is the new proxy user name.

◆ setRemoveOldIndexFiles()

void setRemoveOldIndexFiles ( const bool value )

Sets RemoveOldIndexFiles.

For a description of this function, see isRemoveOldIndexFiles().

Parameters
value is the new setting.

◆ setReportBuilderColumnArrangement()

void setReportBuilderColumnArrangement | ( | const int | index,
 |  | const std::string | str
 | ) |  |

Sets ReportBuilderColumnArrangement.

Set the column arrangement string at index to the given value. If str is the empty string, the column arrangement at that index will be deleted.

For details, see getReportBuilderColumnArrangement(). If the provided index or value is not valid, the list will be unchanged.

Parameters
index | A value between 1 and getMaxNumOfReportBuilderColumnArrangements, inclusive.
str | Name, followed by colon, followed by comma-separated column arrangement string, e.g. "Mini:family,member,db,acc,score,mass,desc"

◆ setReportNumberChoice()

void setReportNumberChoice | ( | const int | index,
 |  | const int | value
 | ) |  |

Sets an element of the ReportNumberChoices list by its index.

See getReportNumberChoice() for more information. If the provided index or value is not valid, the existing value will be kept.

Parameters
index | is the index of the item to set. index must be between 0 and getNumberOfReportNumberChoices()-1.
value | is the value it should be set to.

◆ setRequireBoldRed()

void setRequireBoldRed ( const bool value )

Sets RequireBoldRed.

For a description of this function, see isRequireBoldRed().

Parameters
value specifies if proteins need a bold red peptide.

◆ setResfileCache()

void setResfileCache ( const char * value )

Sets ResfileCache.

For a description of this function, see getResfileCache(). If the provided value is null, the existing value will be kept.

Parameters
value a comma separated list of scripts that should specify ms_mascotresfilebase::RESFILE_USE_CACHE when creating a ms_mascotresfilebase object.

◆ setResultsCache()

void setResultsCache ( const char * value )

Sets ResultsCache.

For a description of this function, see getResultsCache(). If the provided value is null, the existing value will be kept.

Parameters
value a comma separated list of scripts that should specify ms_peptidesummary::MSPEPSUM_USE_CACHE when creating a ms_peptidesummary object.

◆ setResultsFileFormatVersion()

void setResultsFileFormatVersion ( const char * value )

Sets ResultsFileFormatVersion.

For a description of this function, see getResultsFileFormatVersion(). If the provided value is null, the existing value will be kept.

Parameters
value is the new version string.

◆ setResultsFullURL()

void setResultsFullURL ( const char * str )

Sets ResultsFullURL.

For a description of this function, see getResultsFullURL(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new URL.

◆ setResultsFullURL_2()

void setResultsFullURL_2 ( std::string value )

Sets ResultsFullURL_2.

For a description of this function, see getResultsFullURL_2(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new perl script.

◆ setResultsPerlScript()

void setResultsPerlScript ( const char * str )

Sets ResultsPerlScript.

For a description of this function, see getResultsPerlScript(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the script.

◆ setResultsPerlScript_2()

void setResultsPerlScript_2 ( std::string value )

Sets ResultsPerlScript_2.

For a description of this function, see getResultsPerlScript_2(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new perl script.

◆ setReviewColDisplay()

void setReviewColDisplay | ( | const MS_REVIEW_COL | index,
 |  | const bool | value
 | ) |  |

Sets ReviewColDisplay.

End users can specify the display states in mascot.dat to suit their requirements, for example if they want to hide some columns by default.

See also
getReviewColDisplay(). If the provided index is not valid, the list will be unchanged.
Parameters
index | is a value from the MS_REVIEW_COL enumeration.
value | is the new display state to set.

◆ setReviewColWidth()

void setReviewColWidth | ( | const MS_REVIEW_COL | index,
 |  | const int | value
 | ) |  |

Sets ReviewColWidths.

End users can specify the widths in mascot.dat to suit their requirements, for example if they use long titles.

See also
getReviewColWidth(). If the provided index or value is not valid, the list will be unchanged.
Parameters
index | is a value from the MS_REVIEW_COL enumeration.
value | is the new width to set.

◆ setSaveEveryLastQueryAsc()

void setSaveEveryLastQueryAsc ( const bool flag )

Sets SaveEveryLastQueryAsc to 1 or 0.

For a description of this function, see isSaveEveryLastQueryAsc().

Parameters
flag is a boolean flag that corresponds to 1 (true) or 0 (false).

◆ setSaveLastQueryAsc()

void setSaveLastQueryAsc ( const bool flag )

Sets SaveLastQueryAsc to 1 or 0.

For a description of this function, see isSaveLastQueryAsc().

Parameters
flag is a boolean flag that corresponds to 1 (true) or 0 (false).

◆ setSearchLogFile()

void setSearchLogFile ( const char * str )

Sets SearchLogFile.

For a description of this function, see getSearchLogFile(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the search log.

◆ setSearchSubmitAcceptedFileTypes()

void setSearchSubmitAcceptedFileTypes ( const std::string value )

Sets the accepted input file types in the Mascot search form.

For a description of this function, see getSearchSubmitAcceptedFileTypes(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting

◆ setSearchSubmitDefaultPeptideCharge()

void setSearchSubmitDefaultPeptideCharge ( const std::string value )

Sets the default peptide charge when not specified in the input file.

For a description of this function, see getSearchSubmitDefaultPeptideCharge(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting

◆ setSearchSubmitMode()

void setSearchSubmitMode ( const std::string value )

Sets the Mascot search submission mode.

For a description of this function, see getSearchSubmitMode(). If the provided value is not valid, the existing value will be kept.

Parameters
value must be either "asynchronous" or "direct".

◆ setSearchSubmitOutputFormat()

void setSearchSubmitOutputFormat ( const std::string value )

Sets the Mascot search submission output format.

For a description of this function, see getSearchSubmitOutputFormat(). If the provided value is not valid, the existing value will be kept.

Parameters
value must be either "dat28" or "msr" or "dat28,msr".

◆ setSelectSwitch()

void setSelectSwitch ( const int value )

Sets SelectSwitch.

For a description of this function, see getSelectSwitch(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new minimum number of queries for a select summary.

◆ setSendmailPath()

void setSendmailPath ( const char * str )

Sets sendmailPath.

For a description of this function, see getSendmailPath(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new name of the sendmail program.

◆ setShowAllFromErrorTolerant()

void setShowAllFromErrorTolerant ( const bool value )

Sets ShowAllFromErrorTolerant.

For a description of this function, see isShowAllFromErrorTolerant().

Parameters
value specifies if all matches should be displayed in manual error tolerant searches.

◆ setShowSubsets() [1/2]

void setShowSubsets ( const bool value )

Sets ShowSubSets.

Deprecated:
See setShowSubsets(const double).

Simply calls setShowSubsets(const double) with a value of 0.0 or 1.0.

Parameters
value if set to true, 1.0 is used, otherwise 0.0 is used

◆ setShowSubsets() [2/2]

void setShowSubsets ( const double value )

Sets ShowSubSets.

See getShowSubsets().

Parameters
value is the fractional score required for a protein to be counted as a subset. Its score must be greater than or equal to main_protein_score * (1-getShowSubsets()). A value between 0 and 1 (inclusive) is required and the default value is 0.

◆ setSigThreshold()

void setSigThreshold ( const double value )

Set the SigThreshold.

For a description of this function, see getSigThreshold(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new default threshold value.

◆ setSiteAnalysisMD10Prob()

void setSiteAnalysisMD10Prob ( const double value )

Set the SiteAnalysisMD10Prob.

For a description of this function, see getSiteAnalysisMD10Prob(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new default MD10Prob value.

◆ setSortUnassigned()

void setSortUnassigned ( const std::string value )

Sets SortUnassigned.

For a description of this function, see getSortUnassigned(). If the provided value is not valid, the existing value will be kept.

Parameters
value should be one of:
  • scoredown - descending score
  • queryup - query order
  • intdown - intensity order

◆ setSpectraPerLibraryBlock()

void setSpectraPerLibraryBlock ( const int value )

Sets the number of spectra in a spectral library block.

For a description of this function, see getSpectraPerLibraryBlock() If the provided value is not valid, the existing value will be kept.

Parameters
value must be a number greater than zero

◆ setSpectrumViewerColourSchemeString()

void setSpectrumViewerColourSchemeString | ( | const std::string & | name,
 |  | const std::string & | str,
 |  | bool | doCheck = true
 | ) |  |

Sets SpectrumViewerColourScheme.

If str is the empty string, the named colour scheme will be deleted.

For details, see getSpectrumViewerColourSchemeString(). If the provided name or value is not valid, the list will be unchanged.

Parameters
name | Colour scheme name; the defined names are returned by getSpectrumViewerColourSchemeNames().
str | Colour scheme specification as defined in getSpectrumViewerColourSchemeString(), or the empty string.
doCheck | Whether the method should check if the colour scheme is of the correct format, default to true.

◆ setSpectrumViewerDefaultColourSchemeName()

void setSpectrumViewerDefaultColourSchemeName ( const std::string & name )

Sets the default colour scheme name (SpectrumViewerDefaultColourScheme).

For a description of this function, see getSpectrumViewerDefaultColourSchemeName(). If the provided default name is not in the list of current names, the value will not be changed.

Parameters
name Colour scheme name, typically one of getSpectrumViewerColourSchemeNames().

◆ setSplitDataFileSize()

void setSplitDataFileSize ( const int value )

Sets SplitDataFileSize.

For a description of this function, see getSplitDataFileSize(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new file size to split at.

◆ setSplitNumberOfQueries()

void setSplitNumberOfQueries ( const int value )

Sets SplitNumberOfQueries.

For a description of this function, see getSplitNumberOfQueries(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new number of queries.

◆ setStoreModPermutations()

void setStoreModPermutations ( const bool value )

Sets StoreModPermutations.

For a description of this function, see isStoreModPermutations().

Parameters
value is the new setting.

◆ setSVGSpectrumSwitch()

void setSVGSpectrumSwitch ( const int value )

Sets SVGSpectrumSwitch.

For a description of this function, see getSVGSpectrumSwitch(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new setting.

◆ setTargetFDRPercentage()

void setTargetFDRPercentage | ( | const int | index,
 |  | const double | value,
 |  | const bool | makeDefault = false
 | ) |  |

Sets an element of the TargetFDRPercentages list by its index.

See getTargetFDRPercentage() for more information. If the provided index or value is not valid, the list will be unchanged.

Parameters
index | is the index of the item to set. index must be between 0 and getNumberOfTargetFDRPercentages()-1.
value | is the value it should be set to.
makeDefault | controls whether the new element should be made the default item in the list.

◆ setTaxBrowserUrl()

void setTaxBrowserUrl ( const std::string value )

Sets TaxBrowserURL.

For a description of this function, see getTaxBrowserUrl().

Parameters
value is the URL.

◆ setTestDirectory()

void setTestDirectory ( const char * str )

Sets TestDirectory.

For a description of this function, see getTestDirectory(). If the provided value is not valid, the existing value will be kept.

Parameters
str is the new path.

◆ setUniqueJobStartNumber()

void setUniqueJobStartNumber ( const int value )

Sets UniqueJobStartNumber.

For a description of this function, see getUniqueJobStartNumber(). If the provided value is negative, the existing value will be kept.

Parameters
value is the new job start number.

◆ setUnixDirPerm()

void setUnixDirPerm ( const int value )

Sets UnixDirPerm.

For a description of this function, see getUnixDirPerm(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new permissions.

◆ setUnixWebUserGroup()

void setUnixWebUserGroup ( const int value )

Sets UnixWebUserGroup.

For a description of this function, see getUnixWebUserGroup().

Parameters
value is the new setting for the web user group.

◆ setUseHTTPProxyForFTP()

void setUseHTTPProxyForFTP ( const bool value )

Sets UseHTTPProxyForFTP.

For a description of this function, see isUseHTTPProxyForFTP.

Parameters
value True if FTP requests should use HTTP proxy settings; false otherwise.

◆ setUseHTTPProxyForHTTPS()

void setUseHTTPProxyForHTTPS ( const bool value )

Sets UseHTTPProxyForHTTPS.

For a description of this function, see isUseHTTPProxyForHTTPS.

Parameters
value True if HTTPS requests should use HTTP proxy settings; false otherwise.

◆ setVmemory()

void setVmemory ( const INT64 value )

Sets Vmemory.

For a description of this function, see getVmemory(). If the provided value is not valid, the existing value will be kept.

Parameters
value is the new value.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_mascotoptions.hpp
  • ms_mascotoptions.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_masses Class Reference

  • matrix_science
  • ms_masses
Public Member Functions | List of all members
ms_masses Class Reference
Mascot configuration files module

Reads and parses the masses file with residue and atom masses. More...

#include <ms_masses.hpp>

Inheritance diagram for ms_masses:
[legend]
Collaboration diagram for ms_masses:
[legend]

Public Member Functions

ms_masses ()
Default constructor.
ms_masses (const char *filename, const matrix_science::ms_connection_settings *cs=0)
Reads the file immediately after the construction.
ms_masses (const ms_masses &src)
Copying constructor.
ms_masses (const ms_umod_configfile &src, bool addMissingResidueMasses=true)
Copying constructor.
ms_masses (const ms_umod_configfile &src, const ms_quant_component &quantComp)
Constructor for prepared isotope-substituted version of masses.
~ms_masses ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
ms_modvector | applyFixedMods (const ms_modvector *mods, ms_errs *err)
Change residue masses according to the list of fixed modifications.
void | applyIsotopes (const ms_umod_configfile *umodFile, const ms_quant_component *quantComp)
Update masses of amino-acids with isotope substitution.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_masses *right)
Copies masses from another instance.
void | copyFrom (const ms_umod_configfile *right, bool addMissingResidueMasses=true)
Copies masses from a Unimod file.
void | defaultValues (bool useDefaultResidueMasses=true)
Use this member to re-initialise internal members.
double | getCarbonMass (const matrix_science::MASS_TYPE massType) const
Returns a carbon(C) atom mass for a given mass type (MONO or AVE).
matrix_science::ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
double | getCtermDelta (const matrix_science::MASS_TYPE massType) const
Returns C-term modification delta if there is a correspondent fixed modification applied.
double | getCterminalMass (const matrix_science::MASS_TYPE massType) const
Returns C-terminal group mass (i.e. fixed modification delta or OH-mass).
double | getCtermNeutralLoss (const matrix_science::MASS_TYPE massType) const
Returns C-term neutral loss value if there is a correspondent fixed modification applied.
double | getElectronMass () const
Returns an electron mass.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a file name set before or by default.
double | getFragResidueMass (const matrix_science::MASS_TYPE massType, const char residue) const
Returns a residue mass with neutral loss after applying fixed modifications.
double | getHydrogenMass (const matrix_science::MASS_TYPE massType) const
Returns a hydrogen (H) atom mass for a given mass type (MONO or AVE).
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
double | getNitrogenMass (const matrix_science::MASS_TYPE massType) const
Returns a nitrogen (N) atom mass for a given mass type (MONO or AVE).
double | getNtermDelta (const matrix_science::MASS_TYPE massType) const
Returns N-term modification delta if there is a correspondent fixed modification applied.
double | getNterminalMass (const matrix_science::MASS_TYPE massType) const
Returns N-terminal group mass (i.e. fixed modification delta or H-mass).
double | getNtermNeutralLoss (const matrix_science::MASS_TYPE massType) const
Returns N-term neutral loss value if there is a correspondent fixed modification applied.
double | getOxygenMass (const matrix_science::MASS_TYPE massType) const
Returns a oxygen (O) atom mass for a given mass type (MONO or AVE).
double | getResidueMass (const matrix_science::MASS_TYPE massType, const char residue) const
Returns a mass for a given amino acid.
bool | isResidueModified (const char residue) const
Returns true for residues modified by fixed modifications.
bool | isSame (const ms_masses &other, const MASS_TYPE massType) const
Return true if other ms_masses is the same as this one.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_masses & | operator= (const ms_masses &right)
C++ style assignment operator.
void | read_file ()
Reads the configuration file, parses it and fill the mass arrays.
void | save_file ()
Saves the information back to the file.
void | saveToString (std::string &modfileAsStr)
Stores masses information in the string supplied.
void | setCarbonMass (const double massMono, const double massAve)
Changes carbon mass values.
void | setConnectionSettings (const matrix_science::ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setCtermModification (const double monoDelta, const double aveDelta, const double monoNeutralLoss=0.0, const double aveNeutralLoss=0.0)
Set C-term modification.
void | setElectronMass (const double mass)
Changes oxygen mass values.
void | setFileName (const char *name)
Set a custom file name instead of ../config/masses.
void | setHydrogenMass (const double massMono, const double massAve)
Changes hydrogen mass values.
void | setNitrogenMass (const double massMono, const double massAve)
Changes nitrogen mass values.
void | setNtermModification (const double monoDelta, const double aveDelta, const double monoNeutralLoss=0.0, const double aveNeutralLoss=0.0)
Set N-term modification.
void | setOxygenMass (const double massMono, const double massAve)
Changes oxygen mass values.
void | setResidueMasses (const char residue, const double massMono, const double massAve)
Changes mass values for a single residue.
void | setResidueModification (const double monoDelta, const double aveDelta, const double monoNeutralLoss, const double aveNeutralLoss, const char *residues)
Applies a single residue modification.

Detailed Description

Reads and parses the masses file with residue and atom masses.

After reading a file and before using the object, check its validity by calling isValid() and retrieve error descriptions with getLastErrorString() if not valid.

A class instance can be used even if the configuration file has been read with problems or not read at all. Default values will be given to all members in that case.

Examples
config_masses.cpp, config_modfile.cpp, and tools_aahelper.cpp.

Constructor & Destructor Documentation

◆ ms_masses() [1/5]

ms_masses ( )

Default constructor.

Sets default mass values for all residues

◆ ms_masses() [2/5]

ms_masses ( const ms_masses & src )

Copying constructor.

Parameters
src is the source object to copy masses from

◆ ms_masses() [3/5]

ms_masses | ( | const ms_umod_configfile & | src,
 |  | bool | addMissingResidueMasses = true
 | ) |  |

Copying constructor.

Implemented by calling copyFrom(const ms_umod_configfile *, bool)

Parameters
src | has the residue and elemental masses that are used to initialise the masses
addMissingResidueMasses | is used to specify whether residue masses missing from the src should be set to zero or set to the default masses. If true, then default masses are used and if false, then any missing masses are just set to zero.

◆ ms_masses() [4/5]

ms_masses | ( | const ms_umod_configfile & | src,
 |  | const ms_quant_component & | quantComp
 | ) |  |

Constructor for prepared isotope-substituted version of masses.

Masses of amino-acids are re-calculated with a different isotope applied (for example, 13C instead of C).

Parameters
src | a Unimod file object containing the composition of amino acids and original masses.
quantComp | a quantitation component containing isotope substitutions used in the quantitation experiment. This object can be created from scratch without reading its content from a file, but normally it should be taken from the quantitation method selected by a user. An alternative way to apply isotope substition is to use applyIsotopes() method.

◆ ms_masses() [5/5]

ms_masses | ( | const char * | filename,
 |  | const matrix_science::ms_connection_settings * | cs = 0
 | ) |  |

Reads the file immediately after the construction.

Parameters
filename | can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
cs | is a pointer to the connection settings. This should contain a sessionID and optionally the proxy server settings.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ applyFixedMods()

ms_modvector applyFixedMods | ( | const ms_modvector * | mods,
 |  | ms_errs * | err
 | ) |  |

Change residue masses according to the list of fixed modifications.

If you want to get the original (unmodified) masses of amino acids, load them from a file or obtain from another instance of the class.

Fixed modifications can also be applied separately using setNtermModification(), setCtermModification() and setResidueModification().

Parameters
mods | is the vector of modifications to apply
err | is used to collect the errors. To add any errors to the ms_masses object, pass this->getErrorHandler()
Returns
the new list of modifications

◆ applyIsotopes()

void applyIsotopes | ( | const ms_umod_configfile * | umodFile,
 |  | const ms_quant_component * | quantComp
 | ) |  |

Update masses of amino-acids with isotope substitution.

Call this method explictly in order to re-calculate all amino acid masses according to a selected quantitation method. However, the quantitation component object can also be created on the fly with any custom isotope substitution. All applied fixed modifications are cancelled and should be re-applied if necessary with applyFixedMods() method.

Parameters
umodFile | a Unimod file object containing chemical composition of amino acids and element masses.
quantComp | a quantitation component object with isotope substitution information. If the object doesn't have any isotope elements in it no action will be taken.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/3]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/3]

void copyFrom ( const ms_masses * right )

Copies masses from another instance.

Parameters
right is the source masses object

◆ copyFrom() [3/3]

void copyFrom | ( | const ms_umod_configfile * | right,
 |  | bool | addMissingResidueMasses = true
 | ) |  |

Copies masses from a Unimod file.

Parameters
right | a pointer to unimod file object to copy the masses from.
addMissingResidueMasses | is used to specify whether residue masses missing from right should be set to zero or set to the default masses. If true, then default masses are used and if false, then any missing masses are just set to zero.

◆ defaultValues()

void defaultValues ( bool useDefaultResidueMasses = true )

Use this member to re-initialise internal members.

Called internally, but may also be used by other applications

Parameters
useDefaultResidueMasses should be set to true if the residue masses are to be initialised with default values. Otherwise they will all be set to mass zero.

◆ getCarbonMass()

double getCarbonMass ( const matrix_science::MASS_TYPE massType ) const

Returns a carbon(C) atom mass for a given mass type (MONO or AVE).

Parameters
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns
the mass of carbon

◆ getConnectionSettings()

matrix_science::ms_connection_settings getConnectionSettings ( ) const

Returns the sessionID and proxy server for use with an HTTP transfer.

See also the constructor documentation and setConnectionSettings().

Returns
The current connection settings.

◆ getCtermDelta()

double getCtermDelta ( const matrix_science::MASS_TYPE massType ) const

Returns C-term modification delta if there is a correspondent fixed modification applied.

See also
getCterminalMass()
Parameters
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns
the delta compared to an unmodified C terminus mass

◆ getCterminalMass()

double getCterminalMass ( const matrix_science::MASS_TYPE massType ) const

Returns C-terminal group mass (i.e. fixed modification delta or OH-mass).

See also
getCtermDelta()
Parameters
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns
the C terminus mass, including any applied modification

◆ getCtermNeutralLoss()

double getCtermNeutralLoss ( const matrix_science::MASS_TYPE massType ) const

Returns C-term neutral loss value if there is a correspondent fixed modification applied.

See also
getCterminalMass()
Parameters
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns
the delta compared to an unmodified C terminus mass

◆ getElectronMass()

double getElectronMass ( ) const

Returns an electron mass.

Returns
the mass of an electron

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFileName()

std::string getFileName ( ) const

Returns a file name set before or by default.

See also
setFileName()
Returns
the name of the masses file

◆ getFragResidueMass()

double getFragResidueMass | ( | const matrix_science::MASS_TYPE | massType,
 |  | const char | residue
 | ) |  | const

Returns a residue mass with neutral loss after applying fixed modifications.

Parameters
massType | one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
residue | a single letter encoding an amino acid in the range a..z or A..Z.
Returns
an absolute fragment for the amino acid.

◆ getHydrogenMass()

double getHydrogenMass ( const matrix_science::MASS_TYPE massType ) const

Returns a hydrogen (H) atom mass for a given mass type (MONO or AVE).

Parameters
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns
the mass of hydrogen

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getNitrogenMass()

double getNitrogenMass ( const matrix_science::MASS_TYPE massType ) const

Returns a nitrogen (N) atom mass for a given mass type (MONO or AVE).

Parameters
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns
the mass of nitrogen

◆ getNtermDelta()

double getNtermDelta ( const matrix_science::MASS_TYPE massType ) const

Returns N-term modification delta if there is a correspondent fixed modification applied.

See also
getNterminalMass()
Parameters
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns
the delta compared to an unmodified N terminus mass

◆ getNterminalMass()

double getNterminalMass ( const matrix_science::MASS_TYPE massType ) const

Returns N-terminal group mass (i.e. fixed modification delta or H-mass).

See also
getNtermDelta()
Parameters
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns
the N terminus mass, including any applied modification

◆ getNtermNeutralLoss()

double getNtermNeutralLoss ( const matrix_science::MASS_TYPE massType ) const

Returns N-term neutral loss value if there is a correspondent fixed modification applied.

Parameters
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns
any neutral loss on the N terminus

◆ getOxygenMass()

double getOxygenMass ( const matrix_science::MASS_TYPE massType ) const

Returns a oxygen (O) atom mass for a given mass type (MONO or AVE).

Parameters
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns
the mass of oxygen

◆ getResidueMass()

double getResidueMass | ( | const matrix_science::MASS_TYPE | massType,
 |  | const char | residue
 | ) |  | const

Returns a mass for a given amino acid.

Parameters
massType | one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
residue | a single letter encoding an amino acid in the range a..z or A..Z.
Returns
an absolute mass for the amino acid.
Examples
config_masses.cpp.

◆ isResidueModified()

bool isResidueModified ( const char residue ) const

Returns true for residues modified by fixed modifications.

Parameters
residue a single letter encoding an amino acid in the range a..z or A..Z.
Returns
true for residues modified by fixed modifications.

◆ isSame()

bool isSame | ( | const ms_masses & | right,
 |  | const MASS_TYPE | massType
 | ) |  | const

Return true if other ms_masses is the same as this one.

Parameters
right | is the object to test against
massType | specifies whether to compare monoisotopic or average masses.
Returns
true if all the masses are the same

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_masses & operator= ( const ms_masses & right )

C++ style assignment operator.

Only available for C++

Parameters
right is the source object
Returns
a reference to 'this'

◆ read_file()

void read_file ( )

Reads the configuration file, parses it and fill the mass arrays.

Called from the constructor: ms_masses(const char*, const ms_connection_settings*)

◆ save_file()

void save_file ( )

Saves the information back to the file.

See also
setFileName() If the file cannot be opened for writing, an ms_errs::ERR_MSP_FAILED_TO_OPEN_FILE error is added.

Other errors in saving the file use ms_errs::ERR_MSP_FAILED_TO_WRITE_FILE

◆ saveToString()

void saveToString ( std::string & asStr )

Stores masses information in the string supplied.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] asStr is the complete file as a string

◆ setCarbonMass()

void setCarbonMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes carbon mass values.

Parameters
massMono | is the new monoisotopic mass of carbon
massAve | is the new average mass of carbon

◆ setConnectionSettings()

void setConnectionSettings ( const matrix_science::ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters
cs is the new connection settings.

◆ setCtermModification()

void setCtermModification | ( | const double | monoDelta,
 |  | const double | aveDelta,
 |  | const double | monoNeutralLoss = 0.0,
 |  | const double | aveNeutralLoss = 0.0
 | ) |  |

Set C-term modification.

Warning
The name of this function and the name of the first two parameters are potentially misleading.
Parameters
monoDelta | is the mass of the CTerminus. If there is no fixed modification, the value passed should be the monoisotopic mass of hydrogen plus the monoisotopic mass of oxygen.
aveDelta | is the mass of the CTerminus. If there is no fixed modification, the value passed should be the average mass of hydrogen plus the average mass of oxygen.
monoNeutralLoss | is the neutral loss of any fixed C terminus modification.
aveNeutralLoss | is the neutral loss of any fixed C terminusmodification.

◆ setElectronMass()

void setElectronMass ( const double mass )

Changes oxygen mass values.

Parameters
mass is the new monoisotopic mass of an electron

◆ setFileName()

void setFileName ( const char * name )

Set a custom file name instead of ../config/masses.

Does not re-read the file, just saves the new name

See also
getFileName()
read_file()
Parameters
name is the new file name

◆ setHydrogenMass()

void setHydrogenMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes hydrogen mass values.

Parameters
massMono | is the new monoisotopic mass of hydrogen
massAve | is the new average mass of hydrogen

◆ setNitrogenMass()

void setNitrogenMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes nitrogen mass values.

Parameters
massMono | is the new monoisotopic mass of nitrogen
massAve | is the new average mass of nitrogen

◆ setNtermModification()

void setNtermModification | ( | const double | monoDelta,
 |  | const double | aveDelta,
 |  | const double | monoNeutralLoss = 0.0,
 |  | const double | aveNeutralLoss = 0.0
 | ) |  |

Set N-term modification.

Warning
The name of this function and the name of the first two parameters are potentially misleading.
Parameters
monoDelta | is the mass of the NTerminus. If there is no fixed modification, the value passed should be the monoisotopic mass of hydrogen.
aveDelta | is the mass of the NTerminus. If there is no fixed modification, the value passed should be the average mass of hydrogen.
monoNeutralLoss | is the neutral loss of any fixed N terminus modification.
aveNeutralLoss | is the neutral loss of any fixed N terminus modification.

◆ setOxygenMass()

void setOxygenMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes oxygen mass values.

Parameters
massMono | is the new monoisotopic mass of oxygen
massAve | is the new average mass of oxygen

◆ setResidueMasses()

void setResidueMasses | ( | const char | residue,
 |  | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes mass values for a single residue.

Parameters
residue | a single letter encoding an amino acid in the range a..z or A..Z.
massMono | is the new monoisotopic mass for the residue
massAve | is the new average mass for the residue

◆ setResidueModification()

void setResidueModification | ( | const double | monoDelta,
 |  | const double | aveDelta,
 |  | const double | monoNeutralLoss,
 |  | const double | aveNeutralLoss,
 |  | const char * | residues
 | ) |  |

Applies a single residue modification.

Parameters
monoDelta | is the delta in daltons for monoisotopic masses
aveDelta | is the delta in daltons for average masses
monoNeutralLoss | is the neutral loss for monoisotopic masses (typically zero)
aveNeutralLoss | is the neutral loss for average masses (typically zero)
residues | is a null terminated string with one or more letters which encoding amino acids in the range a..z or A..Z.
The documentation for this class was generated from the following files:
  • ms_masses.hpp
  • ms_masses.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_modfile Class Reference

  • matrix_science
  • ms_modfile
Public Member Functions | List of all members
ms_modfile Class Reference
Mascot configuration files module

Use this class in order to read in the amino acid modification file. More...

#include <ms_modfile.hpp>

Inheritance diagram for ms_modfile:
[legend]
Collaboration diagram for ms_modfile:
[legend]

Public Member Functions

ms_modfile ()
Default constructor.
ms_modfile (const char *filename, const ms_masses *massFile, const bool fromSubstitutions=false, const ms_connection_settings *cs=0)
Immediate-action constructor that reads the given file on construction.
ms_modfile (const ms_modfile &src)
Copying constructor.
ms_modfile (const ms_umod_configfile &src, const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL)
Copying constructor that accepts unimod-file object.
~ms_modfile ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | appendModification (const ms_modification *item)
Adds a new modification at the end of the list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearModifications ()
Deletes all modifications from the list.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_modfile *right)
Copies all content from another instance.
void | copyFrom (const ms_umod_configfile *right, const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL)
Copies all content from unimod-file object.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteModificationByName (const char *name)
Remove a modification from the list in memory.
bool | deleteModificationByNumber (const int num)
Remove a modification from the list in memory.
ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a file name that is used to read configuration information.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
const ms_masses * | getMassFile () const
Returns previously set ms_masses class instance.
const ms_modification * | getModificationByName (const char *nameMod) const
Returns a modification object by its name or NULL in case of not found.
const ms_modification * | getModificationByNumber (const int numMod) const
Returns a modification object by its number.
int | getNumberOfModifications () const
Returns a number of modifications currently held in memory.
bool | isFromSubstitutions () const
Returns TRUE if reading is done from the substitutions file.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_modfile & | operator= (const ms_modfile &right)
C++ style assignment operator.
void | read_file ()
Reads configuration information from the file.
void | save_file ()
Stores modification information in the file.
void | saveToString (std::string &modfileAsStr)
Stores modification information in the string supplied.
void | setConnectionSettings (const ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *name)
Call this member to set a custom file name to read from a different location.
void | setFromSubstitutions (const bool value)
Sets internal flag telling which file should be used for extracting modifications.
void | setMassFile (const ms_masses *massFile)
Set the atom masses to use when generating fragmentation mass deltas.
void | sortModifications ()
Re-orders mods by their names.
bool | updateModificationByName (const char *name, const ms_modification mod)
Update the information for a specific modification.
bool | updateModificationByNumber (const int num, const ms_modification mod)
Update the information for a specific modification.

Detailed Description

Use this class in order to read in the amino acid modification file.

Amino acid modifications are defined in two files: mod_file and substitutions. An instance of this class can be used to read a file with any other name. Otherwise, the default name ../config/mod_file is used. Just create an instance of the class and call read_file()-member.

Alternatively, you can call setFileName() to supply a custom file name. It is also recommended to read in the atom masses configuration file with ms_masses and call setMassFile() before calling read_file().

After reading a file and before using the object, check its by calling isValid() and retrieve error descriptions with getLastErrorString() if not valid.

Examples
config_modfile.cpp, and tools_aahelper.cpp.

Constructor & Destructor Documentation

◆ ms_modfile() [1/2]

ms_modfile | ( | const ms_umod_configfile & | src,
 |  | const unsigned int | flags = ms_umod_configfile::MODFILE_FLAGS_ALL
 | ) |  |

Copying constructor that accepts unimod-file object.

Parameters
src | a Unimod file object to extract modifications from.
flags | can be one or more of the ms_umod_configfile::MODFILE_FLAGS values OR'ed together.

◆ ms_modfile() [2/2]

ms_modfile | ( | const char * | filename,
 |  | const ms_masses * | massFile,
 |  | const bool | fromSubstitutions = false,
 |  | const ms_connection_settings * | cs = 0
 | ) |  |

Immediate-action constructor that reads the given file on construction.

Parameters
filename | The file name parameter can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
massFile | In order to use default masses, use a null value.
fromSubstitutions | is an optional parameter is only used when the first parameter is a Mascot Server URL. Use FALSE or (leave the parameter out) to open the mod_file, and use TRUE to open the substitutions file.
cs | connection settings to use when accessing remote files. This should contain a sessionID and optionally the proxy server settings. If security is enabled on the session and visibility control files are present in a unimod subdirectory then private modifications will not be loaded.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom | ( | const ms_umod_configfile * | right,
 |  | const unsigned int | flags = ms_umod_configfile::MODFILE_FLAGS_ALL
 | ) |  |

Copies all content from unimod-file object.

Parameters
right | unimod file object to extract modifications from.
flags | can be one or more of the ms_umod_configfile::MODFILE_FLAGS values OR'ed together.

◆ deleteModificationByName()

bool deleteModificationByName ( const char * name )

Remove a modification from the list in memory.

Parameters
name must be a valid modification name.
Returns
True if the modification name is valid and the modification was removed.
Examples
config_modfile.cpp.

◆ deleteModificationByNumber()

bool deleteModificationByNumber ( const int num )

Remove a modification from the list in memory.

Parameters
num must be in the range 0..getNumberOfModifications()-1.
Returns
True if the modification number is valid.

◆ getConnectionSettings()

matrix_science::ms_connection_settings getConnectionSettings ( ) const

Returns the sessionID and proxy server for use with an HTTP transfer.

See also the constructor documentation and setConnectionSettings().

Returns
The current connection settings.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getModificationByNumber()

const ms_modification * getModificationByNumber ( const int numMod ) const

Returns a modification object by its number.

Parameters
numMod is the modification number greater than or equal to zero and less than getNumberOfModifications().
Returns
The modification object, or a null value if an invalid numMod value is passed. See Maintaining object references: two rules of thumb.
Examples
config_modfile.cpp.

◆ isFromSubstitutions()

bool isFromSubstitutions ( ) const

Returns TRUE if reading is done from the substitutions file.

This flag is important only when downloading the file from a remote host since the URL doesn't contain the file name – only the location. See setFromSubstitutions() and read_file().

Returns
true if the subtitutions file is used to extract modifications, false if the mod file is used

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ read_file()

void read_file ( )

Reads configuration information from the file.

The function uses the file name supplied in setFileName() for reading.

◆ saveToString()

void saveToString ( std::string & modfileAsStr )

Stores modification information in the string supplied.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] modfileAsStr is the complete file as a string

◆ setConnectionSettings()

void setConnectionSettings ( const ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters
cs is the new connection settings.

◆ setFileName()

void setFileName ( const char * name )

Call this member to set a custom file name to read from a different location.

The file name passed as the parameter can be either full/relative path to a local file or URL of the web-site to download it from. In case of URL, the parameter should specify only web-site address. The file name will be chosen depending on whether the file is substitutions or a regular one. Call setFromSubstitutions() before calling read_file() if you want to obtain substitutions configurations rather than regular modifications.

Parameters
name The file name parameter can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
Examples
config_modfile.cpp.

◆ setFromSubstitutions()

void setFromSubstitutions ( const bool value )

Sets internal flag telling which file should be used for extracting modifications.

In case of remote URL it is necessary to tell which file (mod_file or substitutions) should be used for extracting modifications. By default all modifications are read from mod_file either locally or remotely.

See read_file() for more information.

Parameters
value set whether the mod file or the substutitions file is used to extract modifications

◆ updateModificationByName()

bool updateModificationByName | ( | const char * | name,
 |  | const ms_modification | mod
 | ) |  |

Update the information for a specific modification.

Parameters
name | must be a valid modification name.
mod | is the new definition of the modification.
Returns
true if the modification was found and updated.
Examples
config_modfile.cpp.

◆ updateModificationByNumber()

bool updateModificationByNumber | ( | const int | num,
 |  | const ms_modification | mod
 | ) |  |

Update the information for a specific modification.

Parameters
num | must be in the range 0..(getNumberOfModifications() - 1).
mod | is the new definition of the modification.
Returns
true if the modification was found and updated.
The documentation for this class was generated from the following files:
  • ms_modfile.hpp
  • ms_modfile.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_modification Class Reference

  • matrix_science
  • ms_modification
Public Member Functions | List of all members
ms_modification Class Reference
Mascot configuration files module

The class represents a single modification-entry in mod_file. More...

#include <ms_modfile.hpp>

Inheritance diagram for ms_modification:
[legend]
Collaboration diagram for ms_modification:
[legend]

Public Member Functions

ms_modification (const ms_masses *massFile=NULL)
Default constructor.
ms_modification (const ms_modification &src)
Copying constructor.
~ms_modification ()
Destructor.
void | appendIgnoreMass (const double massMono, const double massAve)
Appends a new ignore mass pair.
void | appendModifiedResidue (const char residue, const double massMono, const double massAve)
Adds one more residue that can be modified together with its new mass.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearIgnoreMasses ()
Deletes all ignore-masses.
void | clearModifiedResidues ()
Deletes all residues modified together with their masses and deltas.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_modification *src)
Copies modification configuration from another instance.
void | copyMassFile (const ms_masses *massFile)
void | defaultValues ()
Re-initialises the object.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getClassification () const
Returns the value of the classification attribute.
std::string | getCode () const
Return the monolink code.
double | getCTerminusMass (const MASS_TYPE massType) const
Returns the mass of modified C-terminus.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
double | getDelta (const MASS_TYPE massType) const
Returns delta (in Da) value for the given mass type.
bool | getFromUnimod (const char *modName, const ms_umod_configfile *umod_file)
Retrieves modification from the Unimod file object by its mod_file-style name.
double | getIgnoreMass (const MASS_TYPE massType, const int idx) const
Returns the value of the ith ignore mass. See getNumberOfIgnoreMasses() for more explanations.
const ms_masses * | getMassFile () const
Returns a pointer to ms_masses instance held internally.
int | getModificationType () const
Returns the type (or class) of modification.
char | getModifiedResidue (const int n) const
Traverse the modified residues list.
std::string | getMonoLinkTitle () const
Return the modification title with monolink code appended.
ms_vectorDouble | getNeutralLoss (const MASS_TYPE massType) const
Return neutral loss delta.
ms_vectorBool | getNeutralLossRequired () const
Returns a vector of boolean values (required/not required) for each neutral loss value.
double | getNTerminusMass (const MASS_TYPE massType) const
Returns the mass of modified N-terminus.
int | getNumberOfIgnoreMasses () const
Returns the number of masses to be ignored.
int | getNumberOfModifiedResidues () const
Returns a total number of modified residue for a residue-specific modification.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPairsWith () const
Return the monolink codes this monolink pairs with.
ms_vectorDouble | getPepNeutralLoss (const MASS_TYPE massType) const
Returns a vector of PepNeutralLoss-values.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
ms_vectorDouble | getReqPepNeutralLoss (const MASS_TYPE massType) const
Returns a vector of RepPepNeutralLoss-values.
double | getResidueMass (const MASS_TYPE massType, const char residue) const
Returns a mass of modified residue.
std::string | getTitle () const
Returns the modification title.
bool | inErrorTolerant () const
Returns whether this modification should be used in error tolerant searches.
bool | inLongList () const
Returns whether this modification is flagged to appear in the search form long list.
bool | inShortList () const
Returns whether this modification is flagged to appear in the search form short list.
bool | isGeneratedMonoLinker () const
Return true if this is a monolink modification.
bool | isHidden () const
Returns value of the Hidden parameter.
bool | isLoopLinker () const
Return true if this is a monolink modification whose delta corresponds to the intact link mass.
bool | isResidueModified (const char residue) const
Check a single residue.
bool | isSubstitution () const
Returns TRUE if the modification is derived from the substitutions file.
ms_modification & | operator= (const ms_modification &right)
C++ style assignment operator.
void | setCTerminusMass (const double massMono, const double massAve)
Sets the mass of modified C-terminus.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setDelta (const double massMono, const double massAve)
Changes delta value for the given mass type.
void | setHidden (const bool value)
Sets the value of Hidden parameter.
void | setInErrorTolerant (const bool value)
Sets whether this modification should be used in error tolerant searches.
void | setInLongList (const bool value)
Sets whether this modification is flagged to appear in the search form long list.
void | setInShortList (const bool value)
Sets whether this modification is flagged to appear in the search form short list.
void | setMassFile (const ms_masses *massFile)
Stores pointer to the external ms_masses object to refer later.
void | setModificationType (const int type)
Sets the modification type parameter into the supplied value.
void | setNeutralLoss (const ms_vectorDouble massMono, const ms_vectorDouble massAve, const ms_vectorBool required)
Returns a vector of corresponding frequencies for each neutral loss value.
void | setNTerminusMass (const double massMono, const double massAve)
Sets the mass of modified N-terminus.
void | setPepNeutralLoss (const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve)
Set the vector of PepNeutralLoss-values.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setReqPepNeutralLoss (const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve)
Set the vector of RepPepNeutralLoss-values.
void | setTitle (const char *value)
Change the title for the modification.
void | setTitleSource (const char *unimodName, const char *specString)
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

The class represents a single modification-entry in mod_file.

Instances of this class are created in ms_modfile when parsing mod_file. It should be used in read-only mode. But if you really want to create a custom modification from scratch then specify modification type and supply the mass file object first and set residue masses or deltas second.

Modifications that only apply to a specific residue at a specific terminus need to be handled with care. An example is the conversion of Methionine to Homoserine lactone. This is defined in mod_file as follows:

   Title:Hse_lact (C-term M)
   ResiduesCterm:M -31.000631 -31.1002

These mods are always processed as variable mods, even if they were originally specified as fixed mods. Mascot Parser implicitly treats them as terminal group mods, so that the return values from Mascot Parser for this modification are as follows:

     ms_modification::getResidueMass(matrix_science::MASS_TYPE_MONO, "M") returns 0
     ms_modification::getDelta(matrix_science::MASS_TYPE_MONO) returns -48.003370665
     ms_modification::isResidueModified("M") returns TRUE
     ms_modification::getCTerminusMass(matrix_science::MASS_TYPE_MONO) returns -31.000631
     ms_masses::getResidueMass(matrix_science::MASS_TYPE_MONO, "M") returns 131.04048
     ms_masses::isResidueModified("M") returns FALSE
     ms_masses::getCtermDelta(matrix_science::MASS_TYPE_MONO) returns 0
     ms_masses::getCterminalMass(matrix_science::MASS_TYPE_MONO) returns 17.002739665

When writing code, you may wish to categorise such cases as residue mods. If so, in the case of Hse_lact, the mass of the modified residue would be the sum of the return values from ms_modification::getDelta() and ms_masses::getResidueMass().

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples
config_modfile.cpp, and tools_aahelper.cpp.

Constructor & Destructor Documentation

◆ ms_modification() [1/2]

ms_modification ( const ms_masses * massFile = NULL )

Default constructor.

Not normally called from client applications.

Parameters
massFile Optional parameter to specify the source file for this modification.

◆ ms_modification() [2/2]

ms_modification ( const ms_modification & src )

Copying constructor.

Not normally called from client applications.

Parameters
src reference to an ms_modification object

Member Function Documentation

◆ appendIgnoreMass()

void appendIgnoreMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Appends a new ignore mass pair.

See also
getNumberOfIgnoreMasses(), getIgnoreMass(), clearIgnoreMasses()
Parameters
massMono | is the mono-isotopic mass of the fragment to be ignored.
massAve | is the average mass of the fragment to be ignored.

◆ appendModifiedResidue()

void appendModifiedResidue | ( | const char | residue,
 |  | const double | massMono,
 |  | const double | massAve
 | ) |  |

Adds one more residue that can be modified together with its new mass.

If you call this method for terminal residue modifications, the supplied masses are ignored, only the modified flag for the residue will be set and the total number of residues will be increased. However, if you need to set modified terminal masses for terminal modifications (residue-specific or not) use setNTerminusMass() and setCTerminusMass().

Parameters
residue | needs to be a residue A-Z (or a-z).
massMono | is the mono-isotopic mass of the modified residue.
massAve | is the average mass of the modified residue.

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ clearIgnoreMasses()

void clearIgnoreMasses ( )

Deletes all ignore-masses.

See also
getNumberOfIgnoreMasses(), getIgnoreMass(), appendIgnoreMass()

◆ clearModifiedResidues()

void clearModifiedResidues ( )

Deletes all residues modified together with their masses and deltas.

Values returned by getDelta() and getNeutralLoss() are not cleared.

◆ copyFrom()

void copyFrom ( const ms_modification * src )

Copies modification configuration from another instance.

Parameters
src is the source modification to be copied.

◆ copyMassFile()

void copyMassFile ( const ms_masses * massFile )
Deprecated:
Do not use.
Parameters
massFile pointer to a ms_masses object

◆ defaultValues()

void defaultValues ( )

Re-initialises the object.

Call this member if you want to re-use the instance by resetting all values to defaults.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getClassification()

std::string getClassification ( ) const

Returns the value of the classification attribute.

Returns
the value of the classification attribute

◆ getCode()

std::string getCode ( ) const

Return the monolink code.

The monolink code is a single letter identifier, like A or W.

See also
ms_mascotresfilebase::getMonoLinkModification
Returns
Empty string if no code is defined, or a string containing one letter.

◆ getCTerminusMass()

double getCTerminusMass ( const MASS_TYPE massType ) const

Returns the mass of modified C-terminus.

Call this method only for terminal modifications (irrespective of whether it is residue-specific or not). Residue modifications will always return zero.

Parameters
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns
mass of C-Terminus

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getDelta()

double getDelta ( const MASS_TYPE massType ) const

Returns delta (in Da) value for the given mass type.

By default all values are equal to zero.

Parameters
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns
difference between unmodified and modified mass.

◆ getFromUnimod()

bool getFromUnimod | ( | const char * | modName,
 |  | const ms_umod_configfile * | umod_file
 | ) |  |

Retrieves modification from the Unimod file object by its mod_file-style name.

Parameters
modName | modification name in a mod_file style, such as "Acetyl (C)".
umod_file | a pointer to a Unimod file object where the modification is retrieved from.
Returns
TRUE if the modification is successfully retrieved and FALSE if it is not found in the the Unimod file.

◆ getIgnoreMass()

double getIgnoreMass | ( | const MASS_TYPE | massType,
 |  | const int | idx
 | ) |  | const

Returns the value of the ith ignore mass. See getNumberOfIgnoreMasses() for more explanations.

See also
getNumberOfIgnoreMasses(), clearIgnoreMasses(), appendIgnoreMass()
Parameters
massType | should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
idx | index of the mass to be ignored and can be one of 0..(getNumberOfIgnoreMasses()-1).
Returns
The mass in Daltons.

◆ getMassFile()

const ms_masses * getMassFile ( ) const

Returns a pointer to ms_masses instance held internally.

See also
setMassFile()
Returns
A pointer to the ms_masses object used. See Maintaining object references: two rules of thumb.

◆ getModificationType()

int getModificationType ( ) const

Returns the type (or class) of modification.

By default this is a residue modification.

Returns
One of the enumeration MOD_TYPES values.

◆ getModifiedResidue()

char getModifiedResidue ( const int n ) const

Traverse the modified residues list.

Parameters
n residue number that can be one of 0..(getNumberOfModifiedResidues()-1).
Returns
a letter encoding an amino acid.

◆ getMonoLinkTitle()

std::string getMonoLinkTitle ( ) const

Return the modification title with monolink code appended.

The monolink title consists of the Unimod name followed by the monolink code in square brackets. For example, the W monolink of Xlink:DSS (K) has monolink title "Xlink:DSS[W] (K)".

If this object is not a monolink (isGeneratedMonoLink() returns false), or if the modification was not generated from a Unimod entry, the monolink title is the same as ms_modification::getTitle().

Returns
modification title containing the monolink code, in modfile-style format.

◆ getNeutralLoss()

ms_vectorDouble getNeutralLoss ( const MASS_TYPE massType ) const

Return neutral loss delta.

By default there is no neutral loss for the modification (zero).

Parameters
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns
A vector of neutral loss values. For example, for phosphorylation three different netutral loss values may be specified.

◆ getNeutralLossRequired()

ms_vectorBool getNeutralLossRequired ( ) const

Returns a vector of boolean values (required/not required) for each neutral loss value.

Returns
The values in the vector have a one to one correspondence with the values returned by in getNeutralLoss().

◆ getNTerminusMass()

double getNTerminusMass ( const MASS_TYPE massType ) const

Returns the mass of modified N-terminus.

Call this method only for terminal modifications (irrespective of whether it is residue-specific or not). Residue modifications will always return zero.

Parameters
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns
mass of N-Terminus

◆ getNumberOfIgnoreMasses()

int getNumberOfIgnoreMasses ( ) const

Returns the number of masses to be ignored.

If a modification gives rise to intense, predictable non-sequence ion peaks, Mascot can be instructed to ignore these artefacts by means of "ignore masses". Initially, there is no ignore-masses in the list.

Returns
The number of masses in the 'ignore' list.

◆ getNumberOfModifiedResidues()

int getNumberOfModifiedResidues ( ) const

Returns a total number of modified residue for a residue-specific modification.

By default the internal list of residues is empty.

Returns
The number of modified residues.

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPairsWith()

std::string getPairsWith ( ) const

Return the monolink codes this monolink pairs with.

The pairsWith attribute is a string of single letter identifiers. These are typically used when pairing up peptide matches with MS-cleavable linkers.

See also
ms_mascotresfilebase::getMonoLinkModification
Returns
Empty string if no codes are defined, or a string containing one or more letters.

◆ getPepNeutralLoss()

ms_vectorDouble getPepNeutralLoss ( const MASS_TYPE massType ) const

Returns a vector of PepNeutralLoss-values.

Parameters
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns
vector of PepNeutralLoss values

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ getReqPepNeutralLoss()

ms_vectorDouble getReqPepNeutralLoss ( const MASS_TYPE massType ) const

Returns a vector of RepPepNeutralLoss-values.

Parameters
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns
vector of RepPepNeutralLoss values

◆ getResidueMass()

double getResidueMass | ( | const MASS_TYPE | massType,
 |  | const char | residue
 | ) |  | const

Returns a mass of modified residue.

Only modified residues will have non-zero mass. So, the default value returned by this function is zero.

Parameters
massType | should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
residue | a letter encoding an amino acid.
Returns
modification delta + absolute mass of the residue, in Daltons, or 0 if the residue is not modified.

◆ getTitle()

std::string getTitle ( ) const

Returns the modification title.

A text string that is used to identify the modification in forms and reports. By default this is empty.

Returns
The title.
Examples
config_modfile.cpp, and tools_aahelper.cpp.

◆ inErrorTolerant()

bool inErrorTolerant ( ) const

Returns whether this modification should be used in error tolerant searches.

Returns whether this modification should be used in error tolerant searches.

◆ inLongList()

bool inLongList ( ) const

Returns whether this modification is flagged to appear in the search form long list.

Returns whether this modification is flagged to appear in the search form long list.

◆ inShortList()

bool inShortList ( ) const

Returns whether this modification is flagged to appear in the search form short list.

Returns whether this modification is flagged to appear in the search form short list.

◆ isGeneratedMonoLinker()

bool isGeneratedMonoLinker ( ) const

Return true if this is a monolink modification.

A Unimod linker definition encodes monolinks as neutral losses. A monolink modification has the same title as the linker, but the delta is (linker mass - monolink NL).

See also
ms_mascotresfilebase::getMonoLinkModification
Returns
whether this modification is a monolink generated from a linker definition.

◆ isHidden()

bool isHidden ( ) const

Returns value of the Hidden parameter.

If you wish to include modifications in mod_file without having them appear in a search form, the property Hidden should be set to TRUE.

By default this is not hidden.

Returns
TRUE is the modification is hidden.

◆ isLoopLinker()

bool isLoopLinker ( ) const

Return true if this is a monolink modification whose delta corresponds to the intact link mass.

A Unimod linker definition encodes monolinks as neutral losses. A looplink modification is like a monolink modification, except its delta is the same as the intact linker mass.

See also
ms_mascotresfilebase::getMonoLinkModification
Returns
whether this modification is a looplink generated from a linker definition.

◆ isResidueModified()

bool isResidueModified ( const char residue ) const

Check a single residue.

By default FALSE is returned for each residue, meaning "residue not modified".

Parameters
residue a letter encoding an amino acid.
Returns
TRUE if the residue is modified.

◆ isSubstitution()

bool isSubstitution ( ) const

Returns TRUE if the modification is derived from the substitutions file.

If the modification is AA-substitution then this method will return TRUE.

Returns
true if the modification is from substitution

◆ operator=()

ms_modification & operator= ( const ms_modification & right )

C++ style assignment operator.

Parameters
right is the source modification to be copied.
Returns
reference to the current object

◆ setCTerminusMass()

void setCTerminusMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Sets the mass of modified C-terminus.

The method only has an effect for c-terminus modifications. This method will also override the delta value depending on the terminus mass supplied with the mass file object. However, if the mass file object has some fixed modifications applied, the delta will reflect this fact (not the terminus mass itself).

Parameters
massMono | mass mono-isotopic
massAve | average mass

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setDelta()

void setDelta | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes delta value for the given mass type.

By default all values are equal to zero.

Parameters
massMono | is the delta using 12C monoisotopic masses.
massAve | is the delta using average masses.

◆ setHidden()

void setHidden ( const bool value )

Sets the value of Hidden parameter.

If you wish to include modifications in mod_file without having them appear in a search form, the property Hidden should be set to TRUE.

By default this is not hidden.

Parameters
value should be set to TRUE if the modification is to be hidden.
Examples
config_modfile.cpp.

◆ setInErrorTolerant()

void setInErrorTolerant ( const bool value )

Sets whether this modification should be used in error tolerant searches.

Sets whether this modification should be used in error tolerant searches.

◆ setInLongList()

void setInLongList ( const bool value )

Sets whether this modification is flagged to appear in the search form long list.

Sets whether this modification is flagged to appear in the search form long list.

◆ setInShortList()

void setInShortList ( const bool value )

Sets whether this modification is flagged to appear in the search form short list.

Sets whether this modification is flagged to appear in the search form short list.

◆ setMassFile()

void setMassFile ( const ms_masses * massFile )

Stores pointer to the external ms_masses object to refer later.

If no external ms_masses instance is supplied, then the modification object will create an internal ms_masses instance filled with default values. Create an instance of ms_masses class, call its ms_masses::read_file() member and then call this function to supply the instance as a parameter. Alternatively, you can use copyMassFile() for content copying instead of pointer-copying.

Remember to keep massFile in memory for as long as you use this class object. See Memory management conventions.

Parameters
massFile must be a valid pointer to an ms_masses object. See Maintaining object references: two rules of thumb.

◆ setModificationType()

void setModificationType ( const int type )

Sets the modification type parameter into the supplied value.

Parameters
type should be one of the MOD_TYPES values.

◆ setNeutralLoss()

void setNeutralLoss | ( | const ms_vectorDouble | massMono,
 |  | const ms_vectorDouble | massAve,
 |  | const ms_vectorBool | required
 | ) |  |

Returns a vector of corresponding frequencies for each neutral loss value.

Change neutral loss delta.

All three arrays must be the same length or the function will fail.

Parameters
massMono | is an array of mono-isotopic mass neutral losses.
massAve | is an array of average mass neutral losses.
required | is an array of booleans to specify if fragments with the loss must be seen for the series to be scored.

◆ setNTerminusMass()

void setNTerminusMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Sets the mass of modified N-terminus.

The method only has an effect for n-terminus modifications. This method will also override the delta value depending on the terminus mass supplied with the mass file object. However, if the mass file object has some fixed modifications applied, the delta will reflect this fact (not the terminus mass itself).

Parameters
massMono | mass mono-isotopic
massAve | average mass

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ setTitle()

void setTitle ( const char * value )

Change the title for the modification.

See getTitle() for more information.

Parameters
value is a string value for the new title.

◆ setTitleSource()

void setTitleSource | ( | const char * | unimodName,
 |  | const char * | specString
 | ) |  |
Parameters
unimodName | is the Unimod name of the source definition.
specString | is the specification string with a leading space, e.g. " (K)".

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_modfile.hpp
  • ms_modfile.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_modvector Class Reference

  • matrix_science
  • ms_modvector
Public Member Functions | List of all members
ms_modvector Class Reference
Mascot configuration files module

General usage class for creating lists of modifications to be passed as parameters. More...

#include <ms_modfile.hpp>

Public Member Functions

ms_modvector ()
Default constructor.
ms_modvector (const ms_modvector &src)
Copying constructor.
ms_modvector (const ms_umod_modification &src, const ms_umod_configfile &umod_file)
Copying constructor that takes a Unimod file object as a source.
~ms_modvector ()
Destructor.
void | appendModification (const ms_modification *item)
Adds a new modification at the end of the vector.
void | appendModifications (ms_modvector &right)
Adds copies of modifications at the end of the vector.
void | clearModifications ()
Deletes all modifications from the vector.
void | copyFrom (const ms_modvector *right)
Copies all content from another instance.
void | copyFrom (const ms_umod_modification *right, const ms_umod_configfile *umod_file)
Copies all content from a Unimod modification object.
const ms_modification * | getModificationByName (const std::string &name) const
Returns a modification object by its name.
const ms_modification * | getModificationByNumber (const int numMod) const
Returns a modification object by its number.
int | getNumberOfModifications () const
Returns the number of modifications currently held in the vector.
ms_modvector & | operator= (const ms_modvector &right)
C++ style assignment operator.

Detailed Description

General usage class for creating lists of modifications to be passed as parameters.

Examples
tools_aahelper.cpp.

Constructor & Destructor Documentation

◆ ms_modvector()

ms_modvector | ( | const ms_umod_modification & | src,
 |  | const ms_umod_configfile & | umod_file
 | ) |  |

Copying constructor that takes a Unimod file object as a source.

Each modificationbelement in Unimod consists of one or more specificities that can be grouped by their specGroup value. Therefore, each modification element can be converted to one or more mod_file style modifications.

Parameters
src | a Unimod object to copy the content from.
umod_file | an instance of a Unimod file object from which to extract element masses.

Member Function Documentation

◆ copyFrom()

void copyFrom | ( | const ms_umod_modification * | right,
 |  | const ms_umod_configfile * | umod_file
 | ) |  |

Copies all content from a Unimod modification object.

Every modification object in a Unimod file consits of one or more specificities. Specificities can be grouped or merged by their specificity group ID. Therefore, we can potentially obtain a vector of specificity groups out of any modification in a Unimod file. Such specificity groups can be converted into mod_file style modifications directly.

Parameters
right | a Unimod style modification object to copy the content from.
umod_file | Unimod file object from which to get masses of elements and amino-acids.

◆ getModificationByName()

const ms_modification * getModificationByName ( const std::string & nameMod ) const

Returns a modification object by its name.

Parameters
nameMod is the modification name to match.
Returns
The modification object, or a null value if a non-existent nameMod value is passed.

◆ getModificationByNumber()

const ms_modification * getModificationByNumber ( const int numMod ) const

Returns a modification object by its number.

Parameters
numMod is the modification number greater than or equal to zero and less than getNumberOfModifications().
Returns
The modification object, or a null value if an invalid numMod value is passed. See Maintaining object references: two rules of thumb.
Examples
tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_modfile.hpp
  • ms_modfile.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_obofile Class Reference

  • matrix_science
  • ms_obofile
Public Member Functions | List of all members
ms_obofile Class Reference
Mascot configuration files module

The class provides simplified access to ontology files in the .obo format. More...

#include <ms_obofile.hpp>

Inheritance diagram for ms_obofile:
[legend]
Collaboration diagram for ms_obofile:
[legend]

Public Member Functions

ms_obofile ()
Default constructor - not generally useful.
ms_obofile (const char *oboFileName)
Constructor which loads the obo file from a local file.
ms_obofile (const ms_obofile &right)
Copying constructor.
~ms_obofile ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_obofile *right)
Copies all data from another instance of the class.
void | defaultValues ()
Initialises the object.
std::string | findIDFromTagValue (const char *tag, const char *value) const
Find the ontology term with an exact match to the passed tag/value pair.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::vector< std::string > | getItemFromId (const char *id) const
Returns the vector of tag, value, comment strings for the specified ontology item.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumberOfEntries () const
Returns the number of entries .
bool | isValid () const
Call this function to determine if there have been any errors.
ms_obofile & | operator= (const ms_obofile &right)
Assignment operator.
void | parseLine (const std::string str, std::string &tag, std::string &value, std::string &comment) const
Retrieves the tag, value and any comments from a line in the obo file.

Detailed Description

The class provides simplified access to ontology files in the .obo format.

The file format for the ontology files is described in http://www.geneontology.org/GO.format.obo-1_2.shtml .

This class provides limited read only access to OBO files. The aim of the class is to allow scripts using Mascot Parser to easily look up an ID for a given term in a local .obo file.

Constructor & Destructor Documentation

◆ ms_obofile() [1/3]

ms_obofile ( )

Default constructor - not generally useful.

Create a default empty ontology.

◆ ms_obofile() [2/3]

ms_obofile ( const char * oboFileName )

Constructor which loads the obo file from a local file.

Loads ontology from a local file. The file format will be:

[Term]
id: PI:00000
name: protein informatics cv
def: "Collection of terms for PSI Proteome Informatics standards." [PSI:PI]

[Term]
. . .

The ID of each term is indexed for fast access.

After loading, use the isValid() function to determine if there were any errors.

Parameters
oboFileName is the file name of the local file.

◆ ms_obofile() [3/3]

ms_obofile ( const ms_obofile & src )

Copying constructor.

Note
This constructor can only be used in C++.
Parameters
src is the original OBO file.

◆ ~ms_obofile()

~ms_obofile ( )

Destructor.

No need to call this directly. Frees the complete ontology.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_obofile * right )

Copies all data from another instance of the class.

Parameters
right is the original object to copy to the new one.

◆ defaultValues()

void defaultValues ( )

Initialises the object.

Reset all values to their defaults.

◆ findIDFromTagValue()

std::string findIDFromTagValue | ( | const char * | tag,
 |  | const char * | value
 | ) |  | const

Find the ontology term with an exact match to the passed tag/value pair.

This function is only useful for retrieving items where you expect the tag value to be unique – for example the "name" field.

Parameters
tag | is the name of the tag. For example, "name", "is_a", "property_value".
value | is the value to be found.
Returns
An empty string if there is no match, or the term ID if successful.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getItemFromId()

std::vector< std::string > getItemFromId ( const char * id ) const

Returns the vector of tag, value, comment strings for the specified ontology item.

Returns all the lines in the [Term] for the specified ID.

Parameters
id is the ID of the term. For example, "PI:00171".
Returns
vector of lines

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getNumberOfEntries()

int getNumberOfEntries ( ) const

Returns the number of entries .

Each [Term] section is considered to be a single entry.

Returns
The number of terms in the ontology.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_obofile & operator= ( const ms_obofile & right )

Assignment operator.

Parameters
right is the original object to copy to the new one.
Returns
reference to the current object

◆ parseLine()

void parseLine | ( | const std::string | str,
 |  | std::string & | tag,
 |  | std::string & | value,
 |  | std::string & | comment
 | ) |  | const

Retrieves the tag, value and any comments from a line in the obo file.

Note
This function can only be used from C++.

For example, for the following line, the tag would be "is_a", the value returned would be "PI:00153" and the comment would be "search engine specific score":

   is_a: PI:00153 ! search engine specific score
Parameters
str | is the input string.
tag | is the name of the tag in the input line.
value | is the value of the tag in the input line.
comment | is any comment (after the ! in the input line).
The documentation for this class was generated from the following files:
  • ms_obofile.hpp
  • ms_obofile.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_parseoptions Class Reference

  • matrix_science
  • ms_parseoptions
Public Member Functions | List of all members
ms_parseoptions Class Reference
Mascot configuration files module

Represents the PARSE section of mascot.dat. More...

#include <ms_parserule.hpp>

Inheritance diagram for ms_parseoptions:
[legend]
Collaboration diagram for ms_parseoptions:
[legend]

Public Member Functions

ms_parseoptions ()
Default constructor.
ms_parseoptions (const ms_parseoptions &src)
Copying constructor.
~ms_parseoptions ()
Destructor.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearParseRules ()
Makes all rules unavailable.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_parseoptions *right)
Can be used to copy content from another instance.
void | defaultValues ()
Initializes the instance.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
void | dropParseRule (const int index)
Makes a parse rule with the specified index unavailable.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
int | getNumberOfParseRules () const
Can be used to get upper limit for a parse rule number.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
const ms_parserule * | getParseRule (const int index) const
Returns a parse rule by number.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
bool | isSectionAvailable () const
Check whether the section has been actually read from the file.
ms_parseoptions & | operator= (const ms_parseoptions &right)
Assignment operator for C++ client applications.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setParseRule (const int index, const ms_parserule *rule)
Set a new parse rule for a given number.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

Represents the PARSE section of mascot.dat.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples
config_mascotdat.cpp.

Member Function Documentation

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ dropParseRule()

void dropParseRule ( const int index )

Makes a parse rule with the specified index unavailable.

Unavailable rules are not shown in the file any more and are not valid entries. In order to make it available again, create a new rule and put it in using setParseRule() member.

Parameters
index of rule to drop

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getNumberOfParseRules()

int getNumberOfParseRules ( ) const

Can be used to get upper limit for a parse rule number.

The limit is currently hard-coded. Use this function to retrieve its value.

Returns
max number of parse rules
Examples
config_mascotdat.cpp.

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getParseRule()

const ms_parserule * getParseRule ( const int index ) const

Returns a parse rule by number.

Parse rules are not not stored consecutively. They are stored according to their numbers explicitly specified in the file. So, not every number will yield an available rule. See ms_parserule::isAvailable().

Parameters
index a number from 0 to (getNumberOfParseRules()-1).
Returns
an instance of ms_parserule class representing a rule. See Maintaining object references: two rules of thumb.
Examples
config_mascotdat.cpp.

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ isSectionAvailable()

bool isSectionAvailable ( ) const

Check whether the section has been actually read from the file.

By default the PARSE section is unavailable until it has been set to a different state.

Returns
true if the section is available, false otherwise
Examples
config_mascotdat.cpp.

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_parserule.hpp
  • ms_parserule.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_parserule Class Reference

  • matrix_science
  • ms_parserule
Public Member Functions | List of all members
ms_parserule Class Reference
Mascot configuration files module

Represents a single regular expression parsing rule. More...

#include <ms_parserule.hpp>

Public Member Functions

ms_parserule ()
Default constructor.
ms_parserule (const ms_parserule &src)
Copying constructor.
~ms_parserule ()
Destructor.
void | copyFrom (const ms_parserule *right)
Copies all contents from another instance.
void | defaultValues ()
Initialises the instance.
std::string | getRuleStr () const
Returns a string representing the rule.
bool | isAvailable () const
Call this member to check if this rule has been specified in the file or just a placeholder.
ms_parserule & | operator= (const ms_parserule &right)
Assignment operator for C++ client applications.
void | setAvailable (const bool value)
Change the availability of the rule.
void | setRuleStr (const char *str)
Change the rule string.

Detailed Description

Represents a single regular expression parsing rule.

Instances of this class can be stored in ms_parseoptions as a list of parse rules specified in PARSE section of mascot.dat.

Member Function Documentation

◆ isAvailable()

bool isAvailable ( ) const

Call this member to check if this rule has been specified in the file or just a placeholder.

Parse rules in the PARSE section are specified in arbitrary order with their unique numbers. There might be gaps and unspecified rules. Therefore, it is recommended to check if the rule is actually available in the file before retrieving its properties.

By default this returns FALSE.

Returns
true is the rule is available, false otherwise
Examples
config_mascotdat.cpp.

◆ setAvailable()

void setAvailable ( const bool value )

Change the availability of the rule.

See isAvailable() for more information.

Parameters
value boolean whether the rule is available or not
The documentation for this class was generated from the following files:
  • ms_parserule.hpp
  • ms_parserule.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_parserule_plus Class Reference

  • matrix_science
  • ms_parserule_plus
Public Types | Public Member Functions | List of all members
ms_parserule_plus Class Reference
Mascot configuration files module

Represents regular expression parse rule plus some additional parameters. More...

#include <ms_taxonomyrules.hpp>

Public Types

typedef unsigned int TAX_CHOP_SRC
Data type used for the parameter specifying how to chop a source line. This will be zero or more of the ms_parserule_plus::TAX_CHOP_TYPES values OR'ed together.
enum TAX_CHOP_TYPES {
TAX_CHOP_PREFIX = 0x0001 ,
TAX_CHOP_SUFFIX = 0x0002 ,
TAX_CHOP_WORDS = 0x0004
}
Constants used for combining TAX_CHOP_SRC values. More...

Public Member Functions

ms_parserule_plus ()
Default constructor.
ms_parserule_plus (const ms_parserule_plus &src)
Copying constructor.
~ms_parserule_plus ()
Destructor.
void | copyFrom (const ms_parserule_plus *right)
Can be used to create a copy of another instance.
void | defaultValues ()
Initialises the instance.
TAX_CHOP_SRC | getChopSource () const
Returns additional parameter specifying how to chop a source line.
TAX_SPECIES_FORMAT | getFileTypeToSearch () const
Returns the file format.
std::string | getNameOfDB () const
Returns the database name.
const ms_parserule * | getRule () const
Returns the regular expression-based parse rule.
ms_parserule_plus & | operator= (const ms_parserule_plus &right)
Assignment operator for C++ client applications.
void | setChopSource (const TAX_CHOP_SRC value)
Change the parameter specifying how to a chop source line.
void | setFileTypeToSearch (const TAX_SPECIES_FORMAT value)
Change the file format.
void | setNameOfDB (const char *name)
Change the database name.
void | setRule (const ms_parserule *src)
Set a new parse rule.

Detailed Description

Represents regular expression parse rule plus some additional parameters.

Member Enumeration Documentation

◆ TAX_CHOP_TYPES

enum TAX_CHOP_TYPES

Constants used for combining TAX_CHOP_SRC values.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TAX_CHOP_PREFIX | Remove all words at the start of the text specified in the PrefixRemoves section. See ms_taxonomyrules::getPrefixRemove().
TAX_CHOP_SUFFIX | Remove all words at the end of the text specified in the SuffixRemoves section. See ms_taxonomyrules::getSuffixRemove().
TAX_CHOP_WORDS | Remove one word at a time from the end of the text and try to get a taxonomy match again.

Member Function Documentation

◆ getChopSource()

ms_parserule_plus::TAX_CHOP_SRC getChopSource ( ) const

Returns additional parameter specifying how to chop a source line.

Parsing taxonomy information from a reference file or fasta file can not always be performed reliably using simple regular expressions. The 'CHOP' rules allow prefixes and suffixes to be removed and for 'words' to be extracted. For example:

  DefaultRule         NCBI, CHOP:WP   "\‍(.*\‍)"    # Everything!
  PrefixRemoves       C;Species: and mitochondrion chloroplast plastid endogenous

species that any of the listed prefixes are removed, and if that fails, it should remove one word at a time from the end of the text and try to get a match.

Returns
Will be zero or more of the ms_parserule_plus::TAX_CHOP_TYPES OR'ed together.

◆ setChopSource()

void setChopSource ( const TAX_CHOP_SRC value )

Change the parameter specifying how to a chop source line.

Parsing taxonomy information from a reference file or fasta file can not always be performed reliably using simple regular expressions. The 'CHOP' rules allow prefixes and suffixes to be removed and for 'words' to be extracted. For example:

  DefaultRule         NCBI, CHOP:WP   "\‍(.*\‍)"    # Everything!
  PrefixRemoves       C;Species: and mitochondrion chloroplast plastid endogenous

species that any of the listed prefixes are removed, and if that fails, it should remove one word at a time from the end of the text and try to get a match.

Parameters
value Should be zero or more of the ms_parserule_plus::TAX_CHOP_TYPES values OR'ed together.
The documentation for this class was generated from the following files:
  • ms_taxonomyrules.hpp
  • ms_taxonomyrules.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_processoroptions Class Reference

  • matrix_science
  • ms_processoroptions
Public Member Functions | List of all members
ms_processoroptions Class Reference
Mascot configuration files module

An instance of this class represents all the parameters specified in the Processors section of mascot.dat. More...

#include <ms_processoroptions.hpp>

Inheritance diagram for ms_processoroptions:
[legend]
Collaboration diagram for ms_processoroptions:
[legend]

Public Member Functions

ms_processoroptions ()
Default constructor.
ms_processoroptions (const ms_processoroptions &src)
Copying constructor.
~ms_processoroptions ()
Destructor.
void | appendDatabase (const ms_dbprocessors *db)
Adds a new database to the list.
void | appendProcessor (const int processorID)
Adds a new processor to the list for the ProcessorSet parameter.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearDatabases ()
Deletes all database entries.
void | clearProcessors ()
Deletes all processors from the ProcessorSet list.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_processoroptions *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
const ms_dbprocessors * | getDatabase (const int index) const
Returns an individual database entry.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
int | getNumberOfDatabases () const
Returns number of individual database entries in the section.
int | getNumberOfProcessors () const
Returns a number of processors specified in the ProcessorSet parameter.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
int | getProcessor (const int index) const
Returns a single processor ID by its index.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
bool | isSectionAvailable () const
Check whether the section has been actually read from the file.
ms_processoroptions & | operator= (const ms_processoroptions &right)
Assignment operator for C++ client applications.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

An instance of this class represents all the parameters specified in the Processors section of mascot.dat.

An instance of this class is created and populated in ms_datfile. It can also be created separately and initialized with default values. You can create an instance of the class or copy from another instance in order to pass it then as an parameters-containing object. For detailed information on any of the options please consult Mascot manual.

Most of the parameters here can be accessed using a dabatase number, which corresponds to database indices in ms_databases.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples
config_mascotdat.cpp.

Member Function Documentation

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getNumberOfDatabases()

int getNumberOfDatabases ( ) const

Returns number of individual database entries in the section.

Each of the lines corresponds to a certain database. All CPU numbers are listed in the same database entry and correspond to threads. A number of CPUs listed for the database must be the same as number of threads specified for the database in Databases section of mascot.dat. Also, all CPUs listed here must belong to the set of CPUs specified by ProcessorSet parameter.

By default the list of databases is empty.

Returns
number of databases

◆ getNumberOfProcessors()

int getNumberOfProcessors ( ) const

Returns a number of processors specified in the ProcessorSet parameter.

The ProcessorSet line specifies the complete set of processors to be used. The number in this list must be less than or equal to the number processors licensed, or the system will not run.

There can be up to 64 CPUs specified in the bit mask. Each bit can be set either to 1 or 0 for a listed CPU or not listed one respectively. Following this parameter, the processors to be used for each database are specified in mascot.dat. These numbers must be a subset of the numbers in the ProcessorSet, and there must be the same number of values as the number of threads specified earlier in the database section.

See also
ms_processors::getWhichForDB(), ms_processors::getDBValSetInMascotDat()

By default the list is empty.

Returns
number of processors
Examples
config_mascotdat.cpp.

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ isSectionAvailable()

bool isSectionAvailable ( ) const

Check whether the section has been actually read from the file.

By default the Processors section is unavailable until it has been set to a different state.

Returns
true if the section is available, false otherwise
Examples
config_mascotdat.cpp.

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_processoroptions.hpp
  • ms_processoroptions.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_processors Class Reference

  • matrix_science
  • ms_processors
Public Types | Public Member Functions | List of all members
ms_processors Class Reference
Mascot configuration files module

This class is designed to retrieve current CPU configuration on the computer and set affinity. More...

#include <ms_processors.hpp>

Inheritance diagram for ms_processors:
[legend]
Collaboration diagram for ms_processors:
[legend]

Public Types

enum { DEPRECATED_MAX_CORES_PER_LICENSE = 4 }
The maximum number of cores that may be used for a single 'cpu' license. More...
enum HYPERTHREADING {
HT_NOT_CAPABLE = 0 ,
HT_ENABLED = 1 ,
HT_DISABLED = 2 ,
HT_SUPPORTED_NOT_ENABLED = 3 ,
HT_CANNOT_DETECT = 4
}
Hyper-threading status for the CPUs. More...

Public Member Functions

ms_processors (bool checkLinuxHT, int unused)
Retrieves all CPU information immediately.
ms_processors (const ms_processors &src)
Copying constructor.
~ms_processors ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_processors *right)
Allows to make a copy of another instance.
int | getAutoDetectNumThreads (const int numLicensed, const int numCoresPerCpuLicense) const
Return the 'optimal' number of threads for the license.
int | getCoreFromLogical (const int cpu) const
For multi-core processors, returns the core number for the give logical CPU.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getHT_IDFromLogical (const int cpu) const
For Intel processors, return an ID corresponding to the logical processors hyper-threading state.
UINT64 | getHyperThreadedCPUsMask () const
HYPERTHREADING | getHyperThreadingState () const
Returns the hyper-threading state as best as can be detected .
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getMultithreadedName () const
Returns a string that describes multithreading or multi-core capabilities.
int | getNumAvailableToProcess () const
Returns the number of logical CPUs that a process can use.
int | getNumCores (const int packageID=-1) const
Returns the number of cores on the processor specified by the physical CPU number.
int | getNumLogicalPerPhysical (const int packageID=0) const
Returns the number of 'logical' CPUs per physical processor.
int | getNumOnSystem () const
Returns the number of logical CPUs installed in the system.
int | getNumPhysicalOnSystem () const
Return the number of physical CPUs on a system.
int | getNumProcessorGroups () const
Return the number of processor groups.
int | getPhysicalFromLogical (const int cpu) const
Returns the physical CPU number for a given logical CPU number.
std::string | getProcessorName () const
Returns a string that describes the processor.
UINT64 | getWhichAvailableForMascot () const
std::vector< int > | getWhichAvailableForMascot2 () const
Returns a vector of logical CPU numbers available for Mascot (or any other process).
bool | isLogicalCPUAvailableForMascot (const int cpu) const
Returns true if the numbered logical CPU is available to Mascot (or any other process).
bool | isPrimaryLogicalProcessor (const int cpu) const
Supersedes getHyperThreadedCPUsMask.
bool | isProcessAffinitySupported () const
Returns true if process affinity is supported by the OS and false if only thread affinity is supported.
bool | isThreadedLogicalProcessor (const int cpu) const
Supersedes getHyperThreadedCPUsMask.
bool | isUseProcessesNotThreads () const
Returns a flag which indicates if the platform supports pinning threads to a processor.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_processors & | operator= (const ms_processors &right)
Assignment operator for C++ client applications.

Detailed Description

This class is designed to retrieve current CPU configuration on the computer and set affinity.

Just create an instance and then read necessary values using other members. Check for validity (if necessary) and report any errors (if any) after reading the configuration.

In this class, a logical processsor number is a zero based contiguous index. Under Windows 7/Server 2008 R2 and later, more than 64 'cores' are supported, and in this case, they are split into processor groups, and there may be gaps in the numbering. For example, on a system with 2 x 48core processors, group 0 will have 0-47, and group 1 will have numbers 64-111.

Examples
config_procs.cpp.

Member Enumeration Documentation

◆ anonymous enum

anonymous enum

The maximum number of cores that may be used for a single 'cpu' license.

Warning
This value should no longer be used as the number of cores per cpu is now specified in the license.

Note that the cores may be spread over multiple physical processors and that 'threaded' (e.g. hyperthreaded) units are not included

(Defined as an enum rather than static const int to support VC6)

Enumerator
DEPRECATED_MAX_CORES_PER_LICENSE

The maximum number of cores that may be used for a single 'cpu' license.

◆ HYPERTHREADING

enum HYPERTHREADING

Hyper-threading status for the CPUs.

This is currently only relevant for Intel Pentium processors and Power 5 processors under AIX. It will be HT_NOT_CAPABLE for AMD dual processor systems.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
HT_NOT_CAPABLE | For older Intel chips, and all other processors.
HT_ENABLED | Intel processor that supports hyper-threading and has it enabled in the BIOS.
HT_DISABLED | Pentium P4 (non Xeon) that has hyper-threading 'cobbled' so it cannot be used.
HT_SUPPORTED_NOT_ENABLED | Pentium P4 (Xeon) and later that has hyper-threading turned off in the BIOS.
HT_CANNOT_DETECT | Pentium P4, but OS limitation prevents detection of HT.

Constructor & Destructor Documentation

◆ ms_processors()

ms_processors | ( | bool | checkLinuxHT,
 |  | int | unused
 | ) |  |

Retrieves all CPU information immediately.

Parameters
checkLinuxHT | is now ignored and always assumed to be 'true'. (It was required for 2.4 kernels where detection was slow)
unused | was only used for Intel Linux when checkLinuxHT is set to false so is also now ignored.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_processors * right )

Allows to make a copy of another instance.

Called by the copy constructor in C++.

Parameters
right pointer to a valid ms_processors object

◆ getAutoDetectNumThreads()

int getAutoDetectNumThreads | ( | const int | numLicensed,
 |  | const int | numCoresPerCpuLicense
 | ) |  | const

Return the 'optimal' number of threads for the license.

For Mascot 2.3 up to Mascot 2.6 (inclusive), each license can be used for up to 4 cores. If the processor supports hyperthreading, then these are added 'for free'.

For Mascot 2.7 and later, the number of cores per cpu is defined in the license file, and that value will be passed to this function

The code to calculate this value is:

    int threadedFactor  = getNumLogicalPerPhysical() / getNumCores();
    int maxLicensable   = numLicensed * \a numCoresPerCpuLicense * threadedFactor;

    if (maxLicensable <= getNumAvailableToProcess()) {
        return maxLicensable;
    } else {
        return getNumAvailableToProcess();
    }

For example, consider a 6 core processor with Intel hyperthreading. The processor will have 12 'virtual cpus'. If numLicensed is 1, then this function will return 8.

If the number of threads in mascot.dat is specified as ms_databaseoptions::NUM_THREADS_AUTO_DETECT, then this function is called by nph-mascot.exe to determine the number of threads to use.

Parameters
numLicensed | is the value of the "CPU units" licence feature.
numCoresPerCpuLicense | is the value of the "Cores per CPU units" licence feature.
Returns
The number of threads that should be created.

◆ getCoreFromLogical()

int getCoreFromLogical ( const int cpu ) const

For multi-core processors, returns the core number for the give logical CPU.

If getNumCores() is 1, then this will return -1 for each CPU. Note that the core ID returned has no real significance – it is just a number. To use it, for example to see which logical IDs correspong to hyper-threading / cool threads on the same core, you need to see if one or more logical ID's have the same core ID and same physical ID, and then 'group' these together.

See also
getPhysicalFromLogical()
Parameters
cpu is the number of the logical CPU. To test if this is a valid logical CPU number, check that the return value from isLogicalCPUAvailableForMascot() is true.
Returns
The ID of the core that corresponds to the logical CPU.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getHT_IDFromLogical()

int getHT_IDFromLogical ( const int cpu ) const

For Intel processors, return an ID corresponding to the logical processors hyper-threading state.

Only currently supported for Intel .

Note that the ID returned has no real significance – it is just a number, and will currently be either 0 or 1. To use it, for example to see which logical IDs share the same core on a CPU, you need to see if one or more logical ID's have the same core ID and same physical ID, and then 'group' these together.

See also
getPhysicalFromLogical(), getCoreFromLogical()
Parameters
cpu is the number of the logical CPU. To test if this is a valid logical CPU number, check that the return value from isLogicalCPUAvailableForMascot() is true.
Returns
The hyper-threading ID that corresponds to the logical CPU.

◆ getHyperThreadedCPUsMask()

UINT64 getHyperThreadedCPUsMask ( ) const
Deprecated:
Use isPrimaryLogicalProcessor(), getCoreFromLogical() and getPhysicalFromLogical() instead.

Returns a 'mask' with the bit set for each logical CPU number that is hyper-threaded. The return value is a 64 bit integer, so the maximum number of logical cpus per system that is supported by this function will be 64.

This function is now poorly named - for HyperThreaded read HyperThreadedOrMultiCored, because it doesn't differentiate between a hyper-threaded CPU and a multi-cored CPU.

The 'primary' logical CPU for each physical CPU will not have this bit set. For example, on a dual CPU (single core) Intel system with hyper-threading enabled, the low 8 bits of this flag would be 00001100, indicating that CPU numbers 2 and 3 were the hyper-threaded ones.

The assignment of primary and secondary is totally artificial as both are generally equal.

Returns
A mask indicating which logical CPU numbers refer to 'threads' or second/subsequent cores on each physical processor.

◆ getHyperThreadingState()

ms_processors::HYPERTHREADING getHyperThreadingState ( ) const

Returns the hyper-threading state as best as can be detected .

See also
getMultithreadedName(), getNumPhysicalOnSystem(), getNumOnSystem(), getNumLogicalPerPhysical()
Returns
Whether the system supports some type of multi-threading.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMultithreadedName()

std::string getMultithreadedName ( ) const

Returns a string that describes multithreading or multi-core capabilities.

  • For AMD processors, this will either be "single core", "dual core", "quad core" or "xx core".

  • For Intel processors, this will potentially be made up of two parts, separated by a comma. The first part specifies the hyper-threading state and will be

    • "No hyper-threading in cpu"
    • "hyper-threading enabled"
    • "hyper-threading disabled in cpu"
    • "hyper-threading disabled in bios"
    • "Cannot detect hyper-threading"

    The second part will either be "single core", "dual core", "quad core" or "xx core".

Returns
The name of the multithreading supported on the processor.

◆ getNumAvailableToProcess()

int getNumAvailableToProcess ( ) const

Returns the number of logical CPUs that a process can use.

On some systems with processor sets or other resource management, it is possible to prevent a user or process from having access to all of the CPUs on the system. In this case, this function will return a smaller value than getNumOnSystem. Currently, this function always returns the same value as getNumOnSystem()

See also
getNumPhysicalOnSystem(), getWhichAvailableForMascot().
Returns
The number of logical CPUs that a process can use.

◆ getNumCores()

int getNumCores ( const int packageID = -1 ) const

Returns the number of cores on the processor specified by the physical CPU number.

The returned number does not include hyper-threaded CPUs. For example, for a dual core Xeon processor with hyper-threading, this function will return 2, but getNumLogicalPerPhysical() will return 4.

Parameters
packageID is the number of the physical CPU as returned by getPhysicalFromLogical(). Prior to December 2017, all supported systems except Solaris were required to have the same number of cores on each processor, so this parameter was ignored. The default value of -1 is used to specify the physical processor ID for the first logical processor. The safe way to get this parameter is to initially find a logical cpu number using getWhichAvailableForMascot2() and then to call getPhysicalFromLogical() with this logical CPU number.
Returns
the number of cores on the specfied physical CPU.

◆ getNumLogicalPerPhysical()

int getNumLogicalPerPhysical ( const int packageID = 0 ) const

Returns the number of 'logical' CPUs per physical processor.

Most processors now have multiple cores and some also provide multiple threading (known as hyper-threading).

For example, a dual core Intel processor with hyper-threading, this function will return 4.

Parameters
packageID is the zero based number of the physical processor
Returns
The number of logical processors running on each physical processor.

◆ getNumOnSystem()

int getNumOnSystem ( ) const

Returns the number of logical CPUs installed in the system.

The number of logical CPUs may be different from the number of physical CPUs, for example with Intel Hyper-threading or AMD multi-core.

See also
getNumPhysicalOnSystem(), getNumAvailableToProcess(), getWhichAvailableForMascot().
Returns
The number of logical CPUs installed in the system.
Examples
config_procs.cpp.

◆ getNumPhysicalOnSystem()

int getNumPhysicalOnSystem ( ) const

Return the number of physical CPUs on a system.

The number of logical CPUs may be different from the number of physical CPUs, for example with Intel hyper-threading or multi-core processors.

See also
getNumOnSystem(), getNumAvailableToProcess(), getWhichAvailableForMascot().
Returns
The number of physical CPUs on a system.

◆ getNumProcessorGroups()

int getNumProcessorGroups ( ) const

Return the number of processor groups.

Returns
1 for Linux, and >= 1 for Windows

◆ getPhysicalFromLogical()

int getPhysicalFromLogical ( const int cpu ) const

Returns the physical CPU number for a given logical CPU number.

If getNumLogicalPerPhysical() is 1, this will return -1 for each CPU. Note that the physical ID returned has no real significance – it is just a number. To use it, need to see if one or more logical ID's have the same physical ID, and then 'group' these together.

Parameters
cpu is the number of the logical CPU. To test if this is a valid logical CPU number, check that the return value from isLogicalCPUAvailableForMascot() is true.
Returns
The physical ID of the CPU.

◆ getProcessorName()

std::string getProcessorName ( ) const

Returns a string that describes the processor.

Will return an empty string or one of the following:

  • Intel

  • AMD

Returns
processor name

◆ getWhichAvailableForMascot()

UINT64 getWhichAvailableForMascot ( ) const
Deprecated:
Use isLogicalCPUAvailableForMascot() instead.
Deprecated:
Use getWhichAvailableForMascot2

Returns a 64 bit mask of the logical CPUs available to Mascot (or any other process). The return value is a 64 bit integer, so the maximum number of logical CPUs per system that is supported will be 64.

This function returns a mask of the CPUs available to Mascot. So, if the least significant bit is set, the processor 0 is available to Mascot etc. These bits indicate logical CPUs and not physical CPUs.

On some systems with processor sets or other resource management, it is possible to prevent a user or process from having access to all of the CPUs on the system. In this case, the returned mask will have 'holes'.

Returns
A 64 bit mask indicating which CPUs are online.

◆ getWhichAvailableForMascot2()

std::vector< int > getWhichAvailableForMascot2 ( ) const

Returns a vector of logical CPU numbers available for Mascot (or any other process).

This function supersedes getWhichAvailableForMascot() which is limited to a maximum of 64 processors per system.

On some systems with processor sets or other resource management, it is possible to prevent a user or process from having access to all of the CPUs on the system, so a system with 6 cpus may not have numbers 0..5.

See also
isLogicalCPUAvailableForMascot() which may be more convenient.
Returns
A vector of the processors available for Mascot. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ isLogicalCPUAvailableForMascot()

bool isLogicalCPUAvailableForMascot ( const int cpu ) const

Returns true if the numbered logical CPU is available to Mascot (or any other process).

See also getWhichAvailableForMascot2().

On some systems with processor sets or other resource management, it is possible to prevent a user or process from having access to all of the CPUs on the system, so a system with 6 CPUs may not have numbers 0..5.

Parameters
cpu is the logical CPU number
Returns
True if the numbered logical CPU is available to Mascot (or any other process).

◆ isPrimaryLogicalProcessor()

bool isPrimaryLogicalProcessor ( const int cpu ) const

Supersedes getHyperThreadedCPUsMask.

The 'primary' logical CPU for each physical CPU is the first logical CPU for each physical CPU. Subsequent cores/threading logical CPUs on the same physical processor will return false from this function.

The Mascot Database status screen lists non 'primary' processors in italics.

Parameters
cpu is the number of the logical CPU. To test if this is a valid logical CPU number, check that the return value from isLogicalCPUAvailableForMascot() is true.
Returns
False for each logical CPU numbers which is a second of subsequent core or 'thread'.

◆ isProcessAffinitySupported()

bool isProcessAffinitySupported ( ) const

Returns true if process affinity is supported by the OS and false if only thread affinity is supported.

Mascot Server uses process affinity where possible.

For Linux, this always returns true.

For Microsoft Windows, this returns true if there is only one processor set, otherwise it returns false.

Returns
True if process affinity is supported by the OS and false if only thread affinity is supported.

◆ isThreadedLogicalProcessor()

bool isThreadedLogicalProcessor ( const int cpu ) const

Supersedes getHyperThreadedCPUsMask.

The 'primary' logical cpu for each physical CPU is the first logical cpu for each physical CPU. Subsequent logical CPUs that are on the same core on the same physical processors as a previous logical CPU are described by Mascot Parser as 'threaded', and will return true from this function.

Parameters
cpu is the number of the logical CPU. To test if this is a valid logical CPU number, check that the return value from isLogicalCPUAvailableForMascot() is true.
Returns
the opposite of isPrimaryLogicalProcessor().

◆ isUseProcessesNotThreads()

bool isUseProcessesNotThreads ( ) const

Returns a flag which indicates if the platform supports pinning threads to a processor.

Now returns false for all platforms because all platforms support POSIX threads.

Returns
Will always return false.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_processors.hpp
  • ms_processors.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_average Class Reference

  • matrix_science
  • ms_quant_average
Public Member Functions | List of all members
ms_quant_average Class Reference
Mascot configuration files module

An object of this class represent a single "average" element in quantitation.xml. More...

#include <ms_quant_average.hpp>

Inheritance diagram for ms_quant_average:
[legend]
Collaboration diagram for ms_quant_average:
[legend]

Public Member Functions

ms_quant_average ()
Default constructor.
ms_quant_average (const ms_quant_average &src)
Copying constructor.
virtual | ~ms_quant_average ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_average *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropNumPeptides ()
Delete the num_peptides attribute.
void | dropReferenceAccession ()
Delete the reference_accession attribute.
void | dropReferenceAmount ()
Delete the reference_amount attribute.
void | dropReferenceDatabase ()
Delete the reference_database attribute.
void | dropSelection ()
Delete the selection attribute.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
int | getNumPeptides () const
Returns the value of the num_peptides attribute.
std::string | getNumPeptidesSchemaType () const
Obtain a symbolic name for the num_peptides attribute schema type.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
std::string | getReferenceAccession () const
Returns the value of the reference_accession attribute.
std::string | getReferenceAccessionSchemaType () const
Obtain a symbolic name for the reference_accession attribute schema type.
std::string | getReferenceAmount () const
Returns the value of the reference_amount attribute.
std::string | getReferenceAmountSchemaType () const
Obtain a symbolic name for the reference_amount attribute schema type.
std::string | getReferenceDatabase () const
Returns the value of the reference_database attribute.
std::string | getReferenceDatabaseSchemaType () const
Obtain a symbolic name for the reference_database attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSelection () const
Returns the value of the selection attribute.
std::string | getSelectionSchemaType () const
Obtain a symbolic name for the selection attribute schema type.
bool | haveNumPeptides () const
Indicates presence of the num_peptides attribute.
bool | haveReferenceAccession () const
Indicates presence of the reference_accession attribute.
bool | haveReferenceAmount () const
Indicates presence of the reference_amount attribute.
bool | haveReferenceDatabase () const
Indicates presence of the reference_database attribute.
bool | haveSelection () const
Indicates presence of the selection attribute.
ms_quant_average & | operator= (const ms_quant_average &right)
C++ style assignment operator.
void | setNumPeptides (int value)
Set a custom value for the num_peptides attribute.
void | setReferenceAccession (const char *value)
Set a custom value for the reference_accession attribute.
void | setReferenceAmount (const char *value)
Set a custom value for the reference_amount attribute.
void | setReferenceDatabase (const char *value)
Set a custom value for the reference_database attribute.
void | setSelection (const char *value)
Set a custom value for the selection attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single "average" element in quantitation.xml.

Serves as a possible sub-element of the "protocol" element.

Constructor & Destructor Documentation

◆ ms_quant_average() [1/2]

ms_quant_average ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_average() [2/2]

ms_quant_average ( const ms_quant_average & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendParameter()

void appendParameter ( const ms_quant_parameter * item )
inherited

Adds a new parameter at the end of the list.

Parameters
item an instance of parameter object to copy content from.

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_average * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ dropNumPeptides()

void dropNumPeptides ( )

Delete the num_peptides attribute.

Disables the attribute until it is re-set.

◆ dropReferenceAccession()

void dropReferenceAccession ( )

Delete the reference_accession attribute.

Disables the attribute until it is re-set.

◆ dropReferenceAmount()

void dropReferenceAmount ( )

Delete the reference_amount attribute.

Disables the attribute until it is re-set.

◆ dropReferenceDatabase()

void dropReferenceDatabase ( )

Delete the reference_database attribute.

Disables the attribute until it is re-set.

◆ dropSelection()

void dropSelection ( )

Delete the selection attribute.

Disables the attribute until it is re-set.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getNumPeptides()

int getNumPeptides ( ) const

Returns the value of the num_peptides attribute.

Number of peptides per protein to be used for quantitation.

Returns
current value of "num_peptides" attribute.

◆ getNumPeptidesSchemaType()

std::string getNumPeptidesSchemaType ( ) const

Obtain a symbolic name for the num_peptides attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getParameterByName()

const ms_quant_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_quant_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtualinherited

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

◆ getReferenceAccession()

std::string getReferenceAccession ( ) const

Returns the value of the reference_accession attribute.

Database accession for reference protein.

Returns
current value of the "reference_accession" attribute.

◆ getReferenceAccessionSchemaType()

std::string getReferenceAccessionSchemaType ( ) const

Obtain a symbolic name for the reference_accession attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getReferenceAmount()

std::string getReferenceAmount ( ) const

Returns the value of the reference_amount attribute.

Amount of reference protein.

Returns
current value of the "reference_amount" attribute.

◆ getReferenceAmountSchemaType()

std::string getReferenceAmountSchemaType ( ) const

Obtain a symbolic name for the reference_amount attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getReferenceDatabase()

std::string getReferenceDatabase ( ) const

Returns the value of the reference_database attribute.

Database database for reference protein.

Returns
current value of the "reference_database" attribute.

◆ getReferenceDatabaseSchemaType()

std::string getReferenceDatabaseSchemaType ( ) const

Obtain a symbolic name for the reference_database attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

◆ getSelection()

std::string getSelection ( ) const

Returns the value of the selection attribute.

Whether to require the peptides to be used for quantitation to be unique sequences, or to accept different modification states of same sequence (unique_mr), or even accept peptides with same sequence and modifications in different charge states (unique_mz).

Returns
current value of the "selection" attribute.

◆ getSelectionSchemaType()

std::string getSelectionSchemaType ( ) const

Obtain a symbolic name for the selection attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveNumPeptides()

bool haveNumPeptides ( ) const

Indicates presence of the num_peptides attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveReferenceAccession()

bool haveReferenceAccession ( ) const

Indicates presence of the reference_accession attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveReferenceAmount()

bool haveReferenceAmount ( ) const

Indicates presence of the reference_amount attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveReferenceDatabase()

bool haveReferenceDatabase ( ) const

Indicates presence of the reference_database attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveSelection()

bool haveSelection ( ) const

Indicates presence of the selection attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ operator=()

ms_quant_average & operator= ( const ms_quant_average & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setNumPeptides()

void setNumPeptides ( int value )

Set a custom value for the num_peptides attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropNumPeptides().

Parameters
value a new value for the attribute.

◆ setReferenceAccession()

void setReferenceAccession ( const char * value )

Set a custom value for the reference_accession attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropReferenceAccession().

Parameters
value a new value for the attribute.

◆ setReferenceAmount()

void setReferenceAmount ( const char * value )

Set a custom value for the reference_amount attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropReferenceAmount().

Parameters
value a new value for the attribute.

◆ setReferenceDatabase()

void setReferenceDatabase ( const char * value )

Set a custom value for the reference_database attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropReferenceDatabase().

Parameters
value a new value for the attribute.

◆ setSelection()

void setSelection ( const char * value )

Set a custom value for the selection attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropSelection().

Parameters
value a new value for the attribute.

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_average.hpp
  • ms_quant_average.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_component Class Reference

  • matrix_science
  • ms_quant_component
Public Member Functions | List of all members
ms_quant_component Class Reference
Mascot configuration files module

An object of this class represent a single component element in quantitation.xml. More...

#include <ms_quant_component.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_component ()
Default constructor.
ms_quant_component (const ms_quant_component &src)
Copying constructor.
virtual | ~ms_quant_component ()
Destructor.
void | appendCorrection (const ms_quant_correction *correction)
Adds a new correction element at the end of the list.
void | appendFileIndex (const ms_quant_file_index *file_index)
Adds a new correction element at the end of the list.
void | appendIsotope (const ms_quant_isotope *isotope)
Adds a new isotope element at the end of the list.
void | appendModificationGroup (const ms_quant_modgroup *item)
Adds a new modification group at the end of the list.
void | clearCorrections ()
Deletes all correction elements from the list.
void | clearFileIndexes ()
Deletes all file_index elements from the list.
void | clearIsotopes ()
Deletes all isotope elements from the list.
void | clearModificationGroups ()
Deletes all modification groups from the list.
void | copyFrom (const ms_quant_component *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteCorrection (const int idx)
Remove a correction element from the list.
bool | deleteFileIndex (const int idx)
Remove a single file_index element from the list.
bool | deleteIsotope (const int idx)
Remove a isotope element from the list.
bool | deleteModificationGroupByName (const char *name)
Remove a modification group from the list in memory by its unique name.
bool | deleteModificationGroupByNumber (const int idx)
Remove a modification group from the list in memory by its index.
void | dropFileIndex ()
Delete the file_index element.
void | dropMoverz ()
Delete the moverz element.
void | dropName ()
Delete the name attribute.
void | dropSatellite ()
Delete the satellite element.
const ms_quant_correction * | getCorrection (const int idx) const
Returns a correction element object by its number.
std::string | getCorrectionSchemaType () const
Obtain a symbolic name for the correction element schema type.
int | getFileIndex () const
Returns the value of the first file_index element.
const ms_quant_file_index * | getFileIndex (const int idx) const
Returns a file_index element object by its number.
std::string | getFileIndexSchemaType () const
Obtain a symbolic name for the file_index element schema type.
const ms_quant_isotope * | getIsotope (const int idx) const
Returns a isotope element object by its number.
std::string | getIsotopeSchemaType () const
Obtain a symbolic name for the isotope element schema type.
const ms_quant_modgroup * | getModificationGroupByName (const char *name) const
Returns a modification group object by its name or a null value in case it is not found.
const ms_quant_modgroup * | getModificationGroupByNumber (const int idx) const
Returns a modification group object by its number.
std::string | getModificationGroupSchemaType () const
Obtain a symbolic name for the modification_group element schema type.
const ms_quant_moverz * | getMoverz () const
Returns the value of the moverz element.
std::string | getMoverzSchemaType () const
Obtain a symbolic name for the moverz element schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
int | getNumberOfCorrections () const
Returns the number of correction elements held.
int | getNumberOfFileIndexes () const
Returns the number of file_index elements held.
int | getNumberOfIsotopes () const
Returns the number of isotope elements held.
int | getNumberOfModificationGroups () const
Returns the number of nested modification groups.
const ms_quant_satellite * | getSatellite () const
Returns the value of the satellite element.
std::string | getSatelliteSchemaType () const
Obtain a symbolic name for the satellite element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveFileIndex () const
Check for presence of one or more file_index element.
bool | haveMoverz () const
Check for presence of the moverz element.
bool | haveName () const
Check for presence of the name attribute.
bool | haveSatellite () const
Check for presence of the satellite element.
ms_quant_component & | operator= (const ms_quant_component &right)
C++ style assignment operator.
void | setFileIndex (const int file_index)
Supply a custom content for the first file_index element.
void | setMoverz (const ms_quant_moverz *moverz)
Supply a custom content for the moverz element.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setSatellite (const ms_quant_satellite *satellite)
Supply a custom content for the satellite element.
bool | updateCorrection (const int idx, const ms_quant_correction *isotope)
Update the information for a specific correction element.
bool | updateFileIndex (const int idx, const ms_quant_file_index *file_index)
Adds a new correction element at the end of the list.
bool | updateIsotope (const int idx, const ms_quant_isotope *isotope)
Update the information for a specific isotope element.
bool | updateModificationGroupByName (const char *name, const ms_quant_modgroup *modgroup)
Update the information for a specific modification group refering to it by its unique name.
bool | updateModificationGroupByNumber (const int idx, const ms_quant_modgroup *modgroup)
Update the information for a specific modification group refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single component element in quantitation.xml.

Identifies a component used to calculate a ratio.

Constructor & Destructor Documentation

◆ ms_quant_component() [1/2]

ms_quant_component ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_component() [2/2]

ms_quant_component ( const ms_quant_component & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendCorrection()

void appendCorrection ( const ms_quant_correction * correction )

Adds a new correction element at the end of the list.

Parameters
correction an instance to copy the content into the newly added element from.

◆ appendFileIndex()

void appendFileIndex ( const ms_quant_file_index * file_index )

Adds a new correction element at the end of the list.

Parameters
file_index a new content for the element.

◆ appendIsotope()

void appendIsotope ( const ms_quant_isotope * isotope )

Adds a new isotope element at the end of the list.

Parameters
isotope an instance to copy the content into the newly added element from.

◆ appendModificationGroup()

void appendModificationGroup ( const ms_quant_modgroup * item )

Adds a new modification group at the end of the list.

Creates a new modification group object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters
item an instance of modification group object to copy content from.

◆ clearCorrections()

void clearCorrections ( )

Deletes all correction elements from the list.

Deletes all nested correction elements.

◆ clearFileIndexes()

void clearFileIndexes ( )

Deletes all file_index elements from the list.

Deletes all file_index elements from the list.

◆ copyFrom()

void copyFrom ( const ms_quant_component * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteCorrection()

bool deleteCorrection ( const int idx )

Remove a correction element from the list.

Parameters
idx a zero-based index of the element to delete.
Returns
TRUE if the element has been successfully deleted and FALSE otherwise.

◆ deleteFileIndex()

bool deleteFileIndex ( const int idx )

Remove a single file_index element from the list.

Parameters
idx is the zero based index for the element and should be >=0 and < getNumberOfFileIndexes()
Returns
true if idx >=0 and < getNumberOfFileIndexes()

◆ deleteIsotope()

bool deleteIsotope ( const int idx )

Remove a isotope element from the list.

Parameters
idx a zero-based index of the element to delete.
Returns
TRUE if the element has been successfully deleted and FALSE otherwise.

◆ deleteModificationGroupByName()

bool deleteModificationGroupByName ( const char * name )

Remove a modification group from the list in memory by its unique name.

Parameters
name name of the modification group for deletion.
Returns
TRUE if the modification group has been found and successfully deleted and FALSE otherwise.

◆ deleteModificationGroupByNumber()

bool deleteModificationGroupByNumber ( const int idx )

Remove a modification group from the list in memory by its index.

Parameters
idx number of the modification group for deletion from 0 to (getNumberOfModificationGroups() - 1).
Returns
TRUE if the modification group has been found and successfully deleted and FALSE otherwise.

◆ dropFileIndex()

void dropFileIndex ( )

Delete the file_index element.

Deprecated:
After version 2.7.2, multiple file indexes are supported per component

Just calls clearFileIndexes()

◆ dropMoverz()

void dropMoverz ( )

Delete the moverz element.

Deletes the element until it is re-set.

◆ dropName()

void dropName ( )

Delete the name attribute.

Deletes the attribute until it is re-set.

◆ dropSatellite()

void dropSatellite ( )

Delete the satellite element.

Deletes the element until it is re-set.

◆ getCorrection()

const ms_quant_correction * getCorrection ( const int idx ) const

Returns a correction element object by its number.

Parameters
idx a zero-based index of the element to retrieve.
Returns
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.

◆ getCorrectionSchemaType()

std::string getCorrectionSchemaType ( ) const

Obtain a symbolic name for the correction element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getFileIndex() [1/2]

int getFileIndex ( ) const

Returns the value of the first file_index element.

The file_index element is a data file identifier (replicate).

Deprecated:
After version 2.7.2, multiple file indexes are supported per component and this just returns the first one.

Call getNumberOfFileIndexes() and for each one call getFileIndex(const int idx) to return a matrix_science::ms_quant_file_index * and then call ms_quant_file_index::getContent() to retrieve the the file index

Returns
current element content.

◆ getFileIndex() [2/2]

const ms_quant_file_index * getFileIndex ( const int idx ) const

Returns a file_index element object by its number.

Parameters
idx a zero-based index of the element to retrieve.
Returns
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.

◆ getFileIndexSchemaType()

std::string getFileIndexSchemaType ( ) const

Obtain a symbolic name for the file_index element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getIsotope()

const ms_quant_isotope * getIsotope ( const int idx ) const

Returns a isotope element object by its number.

Element for non-SILAC metabolic labelling. Applies to residues only.

Parameters
idx a zero-based index of the element to retrieve.
Returns
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.

◆ getIsotopeSchemaType()

std::string getIsotopeSchemaType ( ) const

Obtain a symbolic name for the isotope element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getModificationGroupByName()

const ms_quant_modgroup * getModificationGroupByName ( const char * name ) const

Returns a modification group object by its name or a null value in case it is not found.

Parameters
name name of the modification group to find.
Returns
a read-only pointer to a modification group object. See Maintaining object references: two rules of thumb.

◆ getModificationGroupByNumber()

const ms_quant_modgroup * getModificationGroupByNumber ( const int idx ) const

Returns a modification group object by its number.

Parameters
idx number of the modification group from 0 to (getNumberOfModificationGroups() - 1).
Returns
a read-only pointer to a modification group object. See Maintaining object references: two rules of thumb.

◆ getModificationGroupSchemaType()

std::string getModificationGroupSchemaType ( ) const

Obtain a symbolic name for the modification_group element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMoverz()

const ms_quant_moverz * getMoverz ( ) const

Returns the value of the moverz element.

Returns
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.

◆ getMoverzSchemaType()

std::string getMoverzSchemaType ( ) const

Obtain a symbolic name for the moverz element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getName()

std::string getName ( ) const

Returns the value of the name attribute.

Returns
a descriptive name that will appear in drop down lists, etc.

◆ getNameSchemaType()

std::string getNameSchemaType ( ) const

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfCorrections()

int getNumberOfCorrections ( ) const

Returns the number of correction elements held.

Returns
total number of correction elements held.

◆ getNumberOfFileIndexes()

int getNumberOfFileIndexes ( ) const

Returns the number of file_index elements held.

Returns
the number of file index / fraction pairs found

◆ getNumberOfIsotopes()

int getNumberOfIsotopes ( ) const

Returns the number of isotope elements held.

Returns
total number of isotope elements held.

◆ getNumberOfModificationGroups()

int getNumberOfModificationGroups ( ) const

Returns the number of nested modification groups.

Returns
total number of nested modification groups.

◆ getSatellite()

const ms_quant_satellite * getSatellite ( ) const

Returns the value of the satellite element.

Returns
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.

◆ getSatelliteSchemaType()

std::string getSatelliteSchemaType ( ) const

Obtain a symbolic name for the satellite element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ haveFileIndex()

bool haveFileIndex ( ) const

Check for presence of one or more file_index element.

Deprecated:
After version 2.7.2, multiple file indexes are supported per component

Use getNumberOfFileIndexes()

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveMoverz()

bool haveMoverz ( ) const

Check for presence of the moverz element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveName()

bool haveName ( ) const

Check for presence of the name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveSatellite()

bool haveSatellite ( ) const

Check for presence of the satellite element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ operator=()

ms_quant_component & operator= ( const ms_quant_component & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setFileIndex()

void setFileIndex ( const int file_index )

Supply a custom content for the first file_index element.

Deprecated:
After version 2.7.2, multiple file indexes are supported per component and this just sets the first one.

Call appendFileIndex() or updateFileIndex() to set a file_index

Parameters
file_index a new content for the element.

◆ setMoverz()

void setMoverz ( const ms_quant_moverz * moverz )

Supply a custom content for the moverz element.

Parameters
moverz a new content for the element.

◆ setName()

void setName ( const char * value )

Set a custom value for the name attribute.

Parameters
value a new value for the attribute.

◆ setSatellite()

void setSatellite ( const ms_quant_satellite * satellite )

Supply a custom content for the satellite element.

Parameters
satellite a new content for the element.

◆ updateCorrection()

bool updateCorrection | ( | const int | idx,
 |  | const ms_quant_correction * | correction
 | ) |  |

Update the information for a specific correction element.

Parameters
idx | a zero-based index of the element to update.
correction | an instance to copy the content from.
Returns
TRUE if the element has been successfully updated and FALSE otherwise.

◆ updateFileIndex()

bool updateFileIndex | ( | const int | idx,
 |  | const ms_quant_file_index * | file_index
 | ) |  |

Adds a new correction element at the end of the list.

Parameters
idx | is the zero based index for the element and should be >= 0 and < getNumberOfFileIndexes()
file_index | a new content for the element.
Returns
true if idx >= 0 and < getNumberOfFileIndexes()

◆ updateIsotope()

bool updateIsotope | ( | const int | idx,
 |  | const ms_quant_isotope * | isotope
 | ) |  |

Update the information for a specific isotope element.

Parameters
idx | a zero-based index of the element to update.
isotope | an instance to copy the content from.
Returns
TRUE if the element has been successfully updated and FALSE otherwise.

◆ updateModificationGroupByName()

bool updateModificationGroupByName | ( | const char * | name,
 |  | const ms_quant_modgroup * | modgroup
 | ) |  |

Update the information for a specific modification group refering to it by its unique name.

Parameters
name | name of the modification group for updating.
modgroup | an object to copy the content from.
Returns
TRUE if the modification group has been found and successfully updated and FALSE otherwise.

◆ updateModificationGroupByNumber()

bool updateModificationGroupByNumber | ( | const int | idx,
 |  | const ms_quant_modgroup * | modgroup
 | ) |  |

Update the information for a specific modification group refering to it by its index.

Parameters
idx | number of the modification group for updating from 0 to (getNumberOfModificationGroups() - 1).
modgroup | an object to copy the content from.
Returns
TRUE if the modification group has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_component.hpp
  • ms_quant_component.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_composition Class Reference

  • matrix_science
  • ms_quant_composition
Public Member Functions | List of all members
ms_quant_composition Class Reference
Mascot configuration files module

Describes the compositionType type in quantitation.xml. More...

#include <ms_quant_composition.hpp>

Inheritance diagram for ms_quant_composition:
[legend]

Public Member Functions

ms_quant_composition ()
Default constructor.
ms_quant_composition (const ms_quant_composition &src)
Copying constructor.
virtual | ~ms_quant_composition ()
Destructor.
void | appendElement (const ms_quant_element *element)
Adds a new element at the end of the list.
void | clearElements ()
Deletes all elements from the list.
void | copyFrom (const ms_quant_composition *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElement (const int idx)
Remove an element from the list.
const ms_quant_element * | getElement (const int idx) const
Returns an element object by its number.
std::string | getElementSchemaType () const
Obtain a symbolic name for the element's schema type.
int | getNumberOfElements () const
Returns a number of elements held.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_quant_composition & | operator= (const ms_quant_composition &right)
C++ style assignment operator.
bool | updateElement (const int idx, const ms_quant_element *element)
Update the information for a specific element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Describes the compositionType type in quantitation.xml.

Objects of this type host a list of nested element elements.

Constructor & Destructor Documentation

◆ ms_quant_composition() [1/2]

ms_quant_composition ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_composition() [2/2]

ms_quant_composition ( const ms_quant_composition & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendElement()

void appendElement ( const ms_quant_element * element )

Adds a new element at the end of the list.

Parameters
element an instance of element object to copy content from.

◆ copyFrom()

void copyFrom ( const ms_quant_composition * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteElement()

bool deleteElement ( const int idx )

Remove an element from the list.

Parameters
idx number of the element for deletion from 0 to (getNumberOfElements() - 1).
Returns
TRUE if the element has been found and successfully deleted and FALSE otherwise.

◆ getElement()

const ms_quant_element * getElement ( const int idx ) const

Returns an element object by its number.

Parameters
idx number of the element from 0 to (getNumberOfElements() - 1).
Returns
a read-only pointer to an element object. See Maintaining object references: two rules of thumb.

◆ getElementSchemaType()

std::string getElementSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfElements()

int getNumberOfElements ( ) const

Returns a number of elements held.

Returns
total number of elements in the list.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented in ms_quant_neutralloss, and ms_quant_pepneutralloss.

◆ operator=()

ms_quant_composition & operator= ( const ms_quant_composition & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ updateElement()

bool updateElement | ( | const int | idx,
 |  | const ms_quant_element * | element
 | ) |  |

Update the information for a specific element.

Parameters
idx | number of the element for updating from 0 to (getNumberOfElements() - 1).
element | an object to copy the content from.
Returns
TRUE if the element has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_neutralloss, and ms_quant_pepneutralloss.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_neutralloss, and ms_quant_pepneutralloss.

The documentation for this class was generated from the following files:
  • ms_quant_composition.hpp
  • ms_quant_composition.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_configfile Class Reference

  • matrix_science
  • ms_quant_configfile
Public Member Functions | List of all members
ms_quant_configfile Class Reference
Mascot configuration files module

Use this class in order to read/write quantitation.xml. More...

#include <ms_quant_configfile.hpp>

Inheritance diagram for ms_quant_configfile:
[legend]
Collaboration diagram for ms_quant_configfile:
[legend]

Public Member Functions

ms_quant_configfile ()
Default constructor.
ms_quant_configfile (const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0)
Cconstructor that reads the given file on construction.
ms_quant_configfile (const ms_quant_configfile &src)
Copying constructor.
~ms_quant_configfile ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | appendMethod (const ms_quant_method *item)
Adds a new quantitation method at the end of the list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearMethods ()
Deletes all quantitation methods from the list.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_quant_configfile *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteMethodByName (const char *name)
Remove a quantitation method from the list in memory.
bool | deleteMethodByNumber (const int idx)
Remove a quantitation method from the list in memory.
ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a file name that is used to read configuration information.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getMajorVersion () const
Returns major document schema version as read from the file, otherwise the latest.
const ms_quant_method * | getMethodByName (const char *name) const
Returns a quantitation method object by its name or a null value in case it is not found.
const ms_quant_method * | getMethodByNumber (const int idx) const
Returns a quantitation method object by its number.
std::string | getMinorVersion () const
Returns minor document schema version as read from the file, otherwise the latest.
int | getNumberOfMethods () const
Returns a number of quantitation methods currently held in memory.
std::string | getSchemaDirectory () const
Returns the schema directory name.
std::string | getSchemaFileName () const
Returns the current schema file name that is used to validate XML file.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_quant_configfile & | operator= (const ms_quant_configfile &right)
C++ style assignment operator.
void | read_buffer (const char *buffer)
Reads configuration information from a buffer.
void | read_file ()
Reads configuration information from the file.
std::string | save_buffer ()
Creates a string representation of the XML document with all the content of the object.
void | save_file ()
Stores modification information in the file.
void | setConnectionSettings (const ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *name)
Call this member to set a custom file name to read from a different location.
void | setSchemaDirectory (const char *dir)
Sets common location for all versions of schema files.
void | setSchemaFileName (const char *name)
Call this member to specify a custom schema file name for validating XML file.
bool | updateMethodByName (const char *name, const ms_quant_method *mod)
Update the information for a specific quantitation method.
bool | updateMethodByNumber (const int idx, const ms_quant_method *mod)
Update the information for a specific quantitation method.
std::string | validateDocument () const
Validates the whole document against the schema and return errors as a string.

Detailed Description

Use this class in order to read/write quantitation.xml.

This file defines all necessary configuration information for performing quantitation experiments with Mascot.

After reading a file and before using the object check validity by calling isValid() and retrieve error descriptions with getLastErrorString() if not valid. Similarly, after writing out the file, isValid() can be used to check if the file has been created correctly and is valid for further use.

Examples
config_quantitation.cpp.

Constructor & Destructor Documentation

◆ ms_quant_configfile() [1/3]

ms_quant_configfile ( )

Default constructor.

The default constructor just sets the current filename and schema name to be the defaults. Use this function to create an empty object before calling ms_mascotresfilebase::getQuantitation().

◆ ms_quant_configfile() [2/3]

ms_quant_configfile ( const ms_quant_configfile & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

◆ ms_quant_configfile() [3/3]

ms_quant_configfile | ( | const char * | fileName,
 |  | const char * | schemaFileName,
 |  | const ms_connection_settings * | cs = 0
 | ) |  |

Cconstructor that reads the given file on construction.

An instance of this class is normally be created using this form of the constructor.

Parameters
fileName | string that represents either local file name (for example, "C:/quantitation.xml") or a fully formed URL such as http://www.matrixscience.com/cgi . The filename may use backslashes or forward slashes on Windows and spaces in file or directory names are allowed.
schemaFileName | is a "schema location" string. See setSchemaFileName() for information on this parameter. To accept default schema location leave this parameter empty.
cs | a connection settings object for downloading the file from a Mascot server. This should contain a sessionID and optionally the proxy server settings. When reading a local file cs is not required and will be ignored.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ appendMethod()

void appendMethod ( const ms_quant_method * item )

Adds a new quantitation method at the end of the list.

Creates a new quantitation method object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters
item an instance of method object to copy content from.
Examples
config_quantitation.cpp.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_configfile * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor. However, the file name, schema location or connection settings are not reset. You need three additional calls:

    quant_configfile.setFileName("");
    quant_configfile.setSchemaFileName("");
    quant_configfile.setConnectionSettings(ms_connection_settings());

◆ deleteMethodByName()

bool deleteMethodByName ( const char * name )

Remove a quantitation method from the list in memory.

Parameters
name name of the quantitation method for deletion.
Returns
TRUE if the quantitation method has been found and successfully deleted and FALSE otherwise.

◆ deleteMethodByNumber()

bool deleteMethodByNumber ( const int idx )

Remove a quantitation method from the list in memory.

Parameters
idx number of the method for deletion from 0 to (getNumberOfMethods() - 1).
Returns
TRUE if the quantitation method has been found and successfully deleted and FALSE otherwise.

◆ getConnectionSettings()

ms_connection_settings getConnectionSettings ( ) const

Returns the sessionID and proxy server for use with an HTTP transfer.

See also the constructor documentation and setConnectionSettings().

Returns
The current connection settings.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFileName()

std::string getFileName ( ) const

Returns a file name that is used to read configuration information.

Returns
currently set file location, which may not be the location from which the current content has been read if setFileName() has been called after reading the file.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMethodByName()

const ms_quant_method * getMethodByName ( const char * name ) const

Returns a quantitation method object by its name or a null value in case it is not found.

Parameters
name a unique name of the quantitation method.
Returns
a read-only pointer to a method object. See Maintaining object references: two rules of thumb.

◆ getMethodByNumber()

const ms_quant_method * getMethodByNumber ( const int idx ) const

Returns a quantitation method object by its number.

Parameters
idx number of the method from 0 to (getNumberOfMethods() - 1).
Returns
a read-only pointer to a method-object. See Maintaining object references: two rules of thumb.
Examples
config_quantitation.cpp.

◆ getNumberOfMethods()

int getNumberOfMethods ( ) const

Returns a number of quantitation methods currently held in memory.

Returns
total number of method elements in the configuration file.
Examples
config_quantitation.cpp.

◆ getSchemaDirectory()

std::string getSchemaDirectory ( ) const

Returns the schema directory name.

Returns
current schema directory value.

◆ getSchemaFileName()

std::string getSchemaFileName ( ) const

Returns the current schema file name that is used to validate XML file.

Returns
currently set schema file location.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_quant_configfile & operator= ( const ms_quant_configfile & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ read_buffer()

void read_buffer ( const char * buffer )

Reads configuration information from a buffer.

This method is used when reading configuration information from a Mascot result file. Any old content in the object will be removed and substituted with the information read from the buffer.

Parameters
buffer string buffer that contains a valid quantitation XML document. Schema validation of the document is not performed.

◆ read_file()

void read_file ( )

Reads configuration information from the file.

Reads the file from the local disk, or downloads the file from a Mascot web site. Check for errors using isValid() before using any other methods for retrieving content.

◆ save_buffer()

std::string save_buffer ( )

Creates a string representation of the XML document with all the content of the object.

Creates a valid XML document and returns it as a string which can be used when writing out configuration information to a Mascot result file.

Returns
XML document with the object content.

◆ save_file()

void save_file ( )

Stores modification information in the file.

Check for errors after calling this method using isValid() to see if the operation has been successful or to get any schema validation errors. If the document is not valid it will still be saved.

Examples
config_quantitation.cpp.

◆ setConnectionSettings()

void setConnectionSettings ( const ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters
cs is the new connection settings.

◆ setFileName()

void setFileName ( const char * name )

Call this member to set a custom file name to read from a different location.

Calling this method does not cause an write to or read from disk. Use either read_file() or save_file() methods to read or write with the new file name.

Parameters
name a new file location (if empty a default file name will be assigned).
Examples
config_quantitation.cpp.

◆ setSchemaDirectory()

void setSchemaDirectory ( const char * dir )

Sets common location for all versions of schema files.

This method allows setting a universal location for all schema versions. Client applications needn't be modified each time a new major version is introduced. However, it requires that all schemas (current and future) be placed in the same folder.

Calling this method will clear the list of pairs (alias/path) that could have possibly be submitted using setSchemaFileName().

Parameters
dir directory path for schema files.

◆ setSchemaFileName()

void setSchemaFileName ( const char * name )

Call this member to specify a custom schema file name for validating XML file.

You should either supply the schema location explicitly for each version of schema or set the schema directory with setSchemaDirectory(). These two choices are mutualy exclusive and setting one of them will make another value empty.

Use this method to supply schema location as a list of pairs (alias/path) if all schemas you are using are potentially located in different folders. Essentially, it would require explicit path for each schema version and the list of pairs will have to be updated for each new major schema version.

An alternative would be to supply one common folder to retrieve any schemas that might potentially be introduced in future.

Deprecated usage: Old clients can supply a relative or an absolute file path (for example, "C:/quantitation_1.xsd") for schema version 1.

Newer clients have to submit a list of pairs "_schema_alias_ SPACE _file_path_", where SPACE is the space character. Currently supported aliases are "http://www.matrixscience.com/xmlns/schema/quantitation_1" and "http://www.matrixscience.com/xmlns/schema/quantitation_2".

Parameters
name schema location string. It can be left empty to accept the default location; otherwise it specifies the disk file locations for schema files. In this case, all file paths have to be URL-escaped ("C:/My%20Documents/quantitation_1.xsd"). The default location for schema files is the appropriate folder in Mascot installation or in Mascot Parser installation. Calling this method with an empty string will reset the schema location to standard default paths. Examples of valid values:
  • "http://www.matrixscience.com/xmlns/schema/quantitation_2 ../schema%20files/quantitation_2.xsd" – schema for version 1 will be taken from default location (if needed).
  • "http://www.matrixscience.com/xmlns/schema/quantitation_1 C:/myfiles/quant_schema_1.xsd http://www.matrixscience.com/xmlns/schema/quantitation_2 ../schema%20files/quantitation_2.xsd"

◆ updateMethodByName()

bool updateMethodByName | ( | const char * | name,
 |  | const ms_quant_method * | mod
 | ) |  |

Update the information for a specific quantitation method.

Parameters
name | name of the quantitation method for updating.
mod | an object to copy the content from.
Returns
TRUE if the quantitation method has been found and successfully updated and FALSE otherwise.

◆ updateMethodByNumber()

bool updateMethodByNumber | ( | const int | idx,
 |  | const ms_quant_method * | mod
 | ) |  |

Update the information for a specific quantitation method.

Parameters
idx | number of the method for updating from 0 to (getNumberOfMethods() - 1).
mod | an object to copy the content from.
Returns
TRUE if the quantitation method has been found and successfully updated and FALSE otherwise.

◆ validateDocument()

std::string validateDocument ( ) const

Validates the whole document against the schema and return errors as a string.

This method doesn't store the document and doesn't make the object invalid. Also, no errors are stored within the object. Therefore, this method can be called as many times as necessary without any consequences.

All validation errors will be returned back as a string. The XML parser will describe errors in terms of row and column numbers as if the document were actually saved in a file.

Returns
validation errors as a string or an empty string if no errors are detected.
Examples
config_quantitation.cpp.
The documentation for this class was generated from the following files:
  • ms_quant_configfile.hpp
  • ms_quant_configfile.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_correction Class Reference

  • matrix_science
  • ms_quant_correction
Public Member Functions | List of all members
ms_quant_correction Class Reference
Mascot configuration files module

Represents a correction element. More...

#include <ms_quant_correction.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_correction ()
Default constructor.
ms_quant_correction (const ms_quant_correction &src)
Copying constructor.
virtual | ~ms_quant_correction ()
Destructor.
void | copyFrom (const ms_quant_correction *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropElement ()
Delete the element attribute.
void | dropShift ()
Delete the shift attribute.
void | dropType ()
Delete the type attribute.
std::string | getContent () const
Returns string value of the element.
std::string | getContentSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getElement () const
Returns the value of the element attribute.
std::string | getElementSchemaType () const
Obtain a symbolic name for the the element attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
int | getShift () const
Returns the value of the shift attribute.
std::string | getShiftSchemaType () const
Obtain a symbolic name for the shift attribute schema type.
std::string | getType () const
Returns the value of the type attribute.
std::string | getTypeSchemaType () const
Obtain a symbolic name for the type attribute schema type.
bool | haveElement () const
Indicates presence of the element attribute.
bool | haveShift () const
Indicates presence of the shift attribute.
bool | haveType () const
Indicates presence of the type attribute.
ms_quant_correction & | operator= (const ms_quant_correction &right)
C++ style assignment operator.
void | setContent (const char *value)
Set a custom floating point number value as a string for the element content.
void | setElement (const char *value)
Set a custom value for the element attribute.
void | setShift (const int value)
Set a custom value for the shift attribute.
void | setType (const char *value)
Set a custom value for the type attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents a correction element.

Constructor & Destructor Documentation

◆ ms_quant_correction() [1/2]

ms_quant_correction ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_correction() [2/2]

ms_quant_correction ( const ms_quant_correction & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_correction * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropElement()

void dropElement ( )

Delete the element attribute.

Deletes the attribute until is re-set.

◆ dropShift()

void dropShift ( )

Delete the shift attribute.

Deletes the attribute until is re-set.

◆ dropType()

void dropType ( )

Delete the type attribute.

Deletes the attribute until is re-set.

◆ getContent()

std::string getContent ( ) const

Returns string value of the element.

Returns
string value of the element content.

◆ getContentSchemaType()

std::string getContentSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getElement()

std::string getElement ( ) const

Returns the value of the element attribute.

Returns
current value of the attribute.

◆ getElementSchemaType()

std::string getElementSchemaType ( ) const

Obtain a symbolic name for the the element attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ getShift()

int getShift ( ) const

Returns the value of the shift attribute.

Returns
for example, -1.

◆ getShiftSchemaType()

std::string getShiftSchemaType ( ) const

Obtain a symbolic name for the shift attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getType()

std::string getType ( ) const

Returns the value of the type attribute.

Returns
AB factor or linear combination coefficient.

◆ getTypeSchemaType()

std::string getTypeSchemaType ( ) const

Obtain a symbolic name for the type attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveElement()

bool haveElement ( ) const

Indicates presence of the element attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveShift()

bool haveShift ( ) const

Indicates presence of the shift attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveType()

bool haveType ( ) const

Indicates presence of the type attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_quant_correction & operator= ( const ms_quant_correction & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setContent()

void setContent ( const char * value )

Set a custom floating point number value as a string for the element content.

Parameters
value a new value for the content.

◆ setElement()

void setElement ( const char * value )

Set a custom value for the element attribute.

Parameters
value a new value for the attribute.

◆ setShift()

void setShift ( const int value )

Set a custom value for the shift attribute.

Parameters
value a new value for the attribute.

◆ setType()

void setType ( const char * value )

Set a custom value for the type attribute.

Parameters
value a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_correction.hpp
  • ms_quant_correction.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_element Class Reference

  • matrix_science
  • ms_quant_element
Public Member Functions | List of all members
ms_quant_element Class Reference
Mascot configuration files module

The element sub-element of compositionType in quantitation.xml. More...

#include <ms_quant_composition.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_element ()
Default constructor.
ms_quant_element (const ms_quant_element &src)
Copying constructor.
virtual | ~ms_quant_element ()
Destructor.
void | copyFrom (const ms_quant_element *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropNumber ()
Deletes the number attribute.
void | dropSymbol ()
Deletes the symbol attribute.
int | getNumber () const
Returns the value of the number attribute.
std::string | getNumberSchemaType () const
Obtain a symbolic name for the number attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSymbol () const
Returns the value of the symbol attribute.
std::string | getSymbolSchemaType () const
Obtain a symbolic name for the symbol attribute schema type.
bool | haveNumber () const
Indicates presence of the number attribute.
bool | haveSymbol () const
Indicates presence of the symbol attribute.
ms_quant_element & | operator= (const ms_quant_element &right)
C++ style assignment operator.
void | setNumber (const int number)
Set a custom value for the number attribute.
void | setSymbol (const char *symbol)
Set a custom value for the symbol attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

The element sub-element of compositionType in quantitation.xml.

Constructor & Destructor Documentation

◆ ms_quant_element() [1/2]

ms_quant_element ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_element() [2/2]

ms_quant_element ( const ms_quant_element & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_element * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropNumber()

void dropNumber ( )

Deletes the number attribute.

Deletes the attribute until is re-set.

◆ dropSymbol()

void dropSymbol ( )

Deletes the symbol attribute.

Deletes the attribute until is re-set.

◆ getNumber()

int getNumber ( ) const

Returns the value of the number attribute.

Count for the element or isotope. Can be negative.

Returns
current value of the attribute.

◆ getNumberSchemaType()

std::string getNumberSchemaType ( ) const

Obtain a symbolic name for the number attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ getSymbol()

std::string getSymbol ( ) const

Returns the value of the symbol attribute.

Chemical element or isotope.

Returns
current value of the attribute.

◆ getSymbolSchemaType()

std::string getSymbolSchemaType ( ) const

Obtain a symbolic name for the symbol attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveNumber()

bool haveNumber ( ) const

Indicates presence of the number attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveSymbol()

bool haveSymbol ( ) const

Indicates presence of the symbol attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_quant_element & operator= ( const ms_quant_element & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setNumber()

void setNumber ( const int number )

Set a custom value for the number attribute.

Parameters
number a new value for the attribute.

◆ setSymbol()

void setSymbol ( const char * symbol )

Set a custom value for the symbol attribute.

Parameters
symbol a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_composition.hpp
  • ms_quant_composition.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_file_index Class Reference

  • matrix_science
  • ms_quant_file_index
Public Member Functions | Static Public Attributes | List of all members
ms_quant_file_index Class Reference
Mascot configuration files module

Represents a file_index element. More...

#include <ms_quant_file_index.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_file_index ()
Default constructor.
ms_quant_file_index (const ms_quant_file_index &src)
Copying constructor.
virtual | ~ms_quant_file_index ()
Destructor.
void | copyFrom (const ms_quant_file_index *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropFraction ()
Delete the fraction attribute.
int | getContent () const
Returns integer value of the element (the actual index).
std::string | getContentSchemaType () const
Obtain a symbolic name for the element's schema type.
int | getFraction () const
Returns the value of the fraction attribute.
std::string | getFractionSchemaType () const
Obtain a symbolic name for the fraction attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveFraction () const
Indicates presence of the fraction attribute.
ms_quant_file_index & | operator= (const ms_quant_file_index &right)
C++ style assignment operator.
void | setContent (const int fileIndex)
Set a custom file index as element content.
void | setFraction (const int value)
Set a custom value for the fraction attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Static Public Attributes

static const int file_index_value_not_set = -1
A file_index value is a 1 based number. In cases where file_index values are not used (e.g. precursor), this is the 'default' value.

Detailed Description

Represents a file_index element.

Currently just used for the replicate protocol (label free)

Typically, there is one file for each file sample, so each component is just one raw file. A list of files is submitted for quantitation, and each one is mapped to the component using the file_index

However, if the samples have been prefractionated, either at the protein level or after digestion at the peptide level, then, there will be one file for each fraction, for each component. This class enables the mapping of an individual file to its fraction.

Constructor & Destructor Documentation

◆ ms_quant_file_index() [1/2]

ms_quant_file_index ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_file_index() [2/2]

ms_quant_file_index ( const ms_quant_file_index & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_file_index * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropFraction()

void dropFraction ( )

Delete the fraction attribute.

Deletes the attribute until is re-set.

◆ getContent()

int getContent ( ) const

Returns integer value of the element (the actual index).

The default value is ms_quant_file_index::file_index_value_not_set

Returns
the file_index value, which is the element content.

◆ getContentSchemaType()

std::string getContentSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getFraction()

int getFraction ( ) const

Returns the value of the fraction attribute.

There is no requirement for fraction numbers to be sequential. Files with the same fraction number will be 'time aligned' by Distiller to enable prediction of retention times for peptides.

The default value if not set, is -1

Returns
for example, -1.

◆ getFractionSchemaType()

std::string getFractionSchemaType ( ) const

Obtain a symbolic name for the fraction attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ haveFraction()

bool haveFraction ( ) const

Indicates presence of the fraction attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_quant_file_index & operator= ( const ms_quant_file_index & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setContent()

void setContent ( const int value )

Set a custom file index as element content.

Parameters
value a new value for the content.

◆ setFraction()

void setFraction ( const int value )

Set a custom value for the fraction attribute.

There is no requirement for fraction numbers to be sequential. Files with the same fraction number will be 'time aligned' by Distiller to enable prediction of retention times for peptides.

The default value if not set, is -1

Parameters
value a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_file_index.hpp
  • ms_quant_file_index.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_integration Class Reference

  • matrix_science
  • ms_quant_integration
Public Member Functions | List of all members
ms_quant_integration Class Reference
Mascot configuration files module

An object of this class represent a single integration element in quantitation.xml. More...

#include <ms_quant_integration.hpp>

Inheritance diagram for ms_quant_integration:
[legend]
Collaboration diagram for ms_quant_integration:
[legend]

Public Member Functions

ms_quant_integration ()
Default constructor.
ms_quant_integration (const ms_quant_integration &src)
Copying constructor.
virtual | ~ms_quant_integration ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_integration *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropAllChargeStates ()
Delete the all_charge_states attribute.
void | dropAllChargeStatesThreshold ()
Delete the all_charge_states_threshold attribute.
void | dropAllowElutionShift ()
Delete the allow_elution_shift attribute.
void | dropElutionProfileCorrelationThreshold ()
Delete the elution_profile_correlation_threshold attribute.
void | dropElutionTimeDelta ()
Delete the elution_time_delta attribute.
void | dropElutionTimeDeltaUnit ()
Delete the elution_time_delta_unit attribute.
void | dropMassDelta ()
void | dropMassDeltaUnit ()
void | dropMatchedRho ()
Delete the matched_rho attribute.
void | dropMethod ()
Delete the method attribute.
void | dropPrecursorRange ()
void | dropProcessingOptions ()
void | dropSimpleRatio ()
Delete the simple_ratio attribute.
void | dropSource ()
Delete the source attribute.
void | dropXicMaxWidth ()
Delete the xic_max_width attribute.
void | dropXicSmoothing ()
Delete the xic_smoothing attribute.
void | dropXicThreshold ()
Delete the xic_threshold attribute.
std::string | getAllChargeStatesSchemaType () const
Obtain a symbolic name for the all_charge_states attribute schema type.
std::string | getAllChargeStatesThreshold () const
Returns the value of the all_charge_states_threshold attribute.
std::string | getAllChargeStatesThresholdSchemaType () const
Obtain a symbolic name for the all_charge_states_threshold attribute schema type.
std::string | getAllowElutionShiftSchemaType () const
Obtain a symbolic name for the allow_elution_shift attribute schema type.
std::string | getElutionProfileCorrelationThreshold () const
Returns the value of the elution_profile_correlation_threshold attribute.
std::string | getElutionProfileCorrelationThresholdSchemaType () const
Obtain a symbolic name for the elution_profile_correlation_threshold attribute schema type.
std::string | getElutionTimeDelta () const
Returns the value of the elution_time_delta attribute.
std::string | getElutionTimeDeltaSchemaType () const
Obtain a symbolic name for the elution_time_delta attribute schema type.
std::string | getElutionTimeDeltaUnit () const
Returns the value of the elution_time_delta_unit attribute.
std::string | getElutionTimeDeltaUnitSchemaType () const
Obtain a symbolic name for the elution_time_delta_unit attribute schema type.
std::string | getMassDelta () const
std::string | getMassDeltaSchemaType () const
std::string | getMassDeltaUnit () const
std::string | getMassDeltaUnitSchemaType () const
std::string | getMatchedRho () const
Returns the value of the matched_rho attribute.
std::string | getMatchedRhoSchemaType () const
Obtain a symbolic name for the matched_rho attribute schema type.
std::string | getMethod () const
Returns the value of the method attribute.
std::string | getMethodSchemaType () const
Obtain a symbolic name for the method attribute schema type.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
std::string | getPrecursorRange () const
std::string | getPrecursorRangeSchemaType () const
std::string | getProcessingOptions () const
std::string | getProcessingOptionsSchemaType () const
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSimpleRatioSchemaType () const
Obtain a symbolic name for the simple_ratio attribute schema type.
std::string | getSource () const
Returns the value of the source attribute.
std::string | getSourceSchemaType () const
Obtain a symbolic name for the source attribute schema type.
int | getXicMaxWidth () const
Returns the value of the xic_max_width attribute.
std::string | getXicMaxWidthSchemaType () const
Obtain a symbolic name for the "xic_max_width" schema type.
int | getXicSmoothing () const
Returns the value of the xic_smoothing attribute.
std::string | getXicSmoothingSchemaType () const
Obtain a symbolic name for the xic_smoothing attribute schema type.
std::string | getXicThreshold () const
Returns the value of the xic_threshold attribute.
std::string | getXicThresholdSchemaType () const
Obtain a symbolic name for the xic_threshold attribute schema type.
bool | haveAllChargeStates () const
Indicates presence of the all_charge_states attribute.
bool | haveAllChargeStatesThreshold () const
Indicates presence of the all_charge_states_threshold attribute.
bool | haveAllowElutionShift () const
Indicates presence of the allow_elution_shift attribute.
bool | haveElutionProfileCorrelationThreshold () const
Indicates presence of the elution_profile_correlation_threshold attribute.
bool | haveElutionTimeDelta () const
Indicates presence of the elution_time_delta attribute.
bool | haveElutionTimeDeltaUnit () const
Indicates presence of the elution_time_delta_unit attribute.
bool | haveMassDelta () const
bool | haveMassDeltaUnit () const
bool | haveMatchedRho () const
Indicates presence of the matched_rho attribute.
bool | haveMethod () const
Indicates presence of the method attribute.
bool | havePrecursorRange () const
bool | haveProcessingOptions () const
bool | haveSimpleRatio () const
Indicates presence of the simple_ratio attribute.
bool | haveSource () const
Indicates presence of the source attribute.
bool | haveXicMaxWidth () const
Indicates presence of the xic_max_width attribute.
bool | haveXicSmoothing () const
Indicates presence of the xic_smoothing attribute.
bool | haveXicThreshold () const
Indicates presence of the xic_threshold attribute.
bool | isAllChargeStates () const
Returns the value of the all_charge_states attribute.
bool | isAllowElutionShift () const
Returns the value of the allow_elution_shift attribute.
bool | isSimpleRatio () const
Returns the value of the simple_ratio attribute.
ms_quant_integration & | operator= (const ms_quant_integration &right)
C++ style assignment operator.
void | setAllChargeStates (const bool value)
Set a custom value for the all_charge_states attribute.
void | setAllChargeStatesThreshold (const char *value)
Set a custom value for the all_charge_states_threshold attribute.
void | setAllowElutionShift (const bool value)
Set a custom value for the allow_elution_shift attribute.
void | setElutionProfileCorrelationThreshold (const char *value)
Set a custom value for the elution_profile_correlation_threshold attribute.
void | setElutionTimeDelta (const char *value)
Set a custom value for the elution_time_delta attribute.
void | setElutionTimeDeltaUnit (const char *value)
Set a custom value for the elution_time_delta_unit attribute.
void | setMassDelta (const char *value)
void | setMassDeltaUnit (const char *value)
void | setMatchedRho (const char *value)
Set a custom value for the matched_rho attribute.
void | setMethod (const char *value)
Set a custom value for the method attribute.
void | setPrecursorRange (const char *value)
void | setProcessingOptions (const std::string value)
void | setSimpleRatio (const bool value)
Set a custom value for the simple_ratio attribute.
void | setSource (const char *value)
Set a custom value for the source attribute.
void | setXicMaxWidth (int value)
Set a custom value for the xic_max_width attribute.
void | setXicSmoothing (int value)
Set a custom value for the xic_smoothing attribute.
void | setXicThreshold (const char *value)
Set a custom value for the xic_threshold attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single integration element in quantitation.xml.

Specifies the method and parameters to be used to integrate precursor over time.

Constructor & Destructor Documentation

◆ ms_quant_integration() [1/2]

ms_quant_integration ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_integration() [2/2]

ms_quant_integration ( const ms_quant_integration & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendParameter()

void appendParameter ( const ms_quant_parameter * item )
inherited

Adds a new parameter at the end of the list.

Parameters
item an instance of parameter object to copy content from.

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_integration * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ dropAllChargeStates()

void dropAllChargeStates ( )

Delete the all_charge_states attribute.

Disables the attribute until it is re-set.

◆ dropAllChargeStatesThreshold()

void dropAllChargeStatesThreshold ( )

Delete the all_charge_states_threshold attribute.

Disables the attribute until it is re-set.

◆ dropAllowElutionShift()

void dropAllowElutionShift ( )

Delete the allow_elution_shift attribute.

Disables the attribute until it is re-set.

◆ dropElutionProfileCorrelationThreshold()

void dropElutionProfileCorrelationThreshold ( )

Delete the elution_profile_correlation_threshold attribute.

Disables the attribute until it is re-set.

◆ dropElutionTimeDelta()

void dropElutionTimeDelta ( )

Delete the elution_time_delta attribute.

Disables the attribute until it is re-set.

◆ dropElutionTimeDeltaUnit()

void dropElutionTimeDeltaUnit ( )

Delete the elution_time_delta_unit attribute.

Disables the attribute until it is re-set.

◆ dropMassDelta()

void dropMassDelta ( )
Deprecated:
Not in use.

◆ dropMassDeltaUnit()

void dropMassDeltaUnit ( )
Deprecated:
Not in use.

◆ dropMatchedRho()

void dropMatchedRho ( )

Delete the matched_rho attribute.

Disables the attribute until it is re-set.

◆ dropMethod()

void dropMethod ( )

Delete the method attribute.

Disables the attribute until it is re-set.

◆ dropPrecursorRange()

void dropPrecursorRange ( )
Deprecated:
Do not use.

◆ dropProcessingOptions()

void dropProcessingOptions ( )
Deprecated:
Do not use.

◆ dropSimpleRatio()

void dropSimpleRatio ( )

Delete the simple_ratio attribute.

Disables the attribute until it is re-set.

◆ dropSource()

void dropSource ( )

Delete the source attribute.

Disables the attribute until it is re-set.

◆ dropXicMaxWidth()

void dropXicMaxWidth ( )

Delete the xic_max_width attribute.

Disables the attribute until it is re-set.

◆ dropXicSmoothing()

void dropXicSmoothing ( )

Delete the xic_smoothing attribute.

Disables the attribute until it is re-set.

◆ dropXicThreshold()

void dropXicThreshold ( )

Delete the xic_threshold attribute.

Disables the attribute until it is re-set.

◆ getAllChargeStatesSchemaType()

std::string getAllChargeStatesSchemaType ( ) const

Obtain a symbolic name for the all_charge_states attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getAllChargeStatesThreshold()

std::string getAllChargeStatesThreshold ( ) const

Returns the value of the all_charge_states_threshold attribute.

When all_charge_states is true, additional contiguous charge states are included in quantitation if their intensity exceeds this fraction of the the most intense charge state for which there is a database match.

Returns
current value of the all_charge_states_threshold attribute.

◆ getAllChargeStatesThresholdSchemaType()

std::string getAllChargeStatesThresholdSchemaType ( ) const

Obtain a symbolic name for the all_charge_states_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getAllowElutionShiftSchemaType()

std::string getAllowElutionShiftSchemaType ( ) const

Obtain a symbolic name for the allow_elution_shift attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getElutionProfileCorrelationThreshold()

std::string getElutionProfileCorrelationThreshold ( ) const

Returns the value of the elution_profile_correlation_threshold attribute.

Threshold on the standard error for a straight line fit of the component intensities from each of the scans in the XIC peak.

Returns
current value of the elution_profile_correlation_threshold attribute.

◆ getElutionProfileCorrelationThresholdSchemaType()

std::string getElutionProfileCorrelationThresholdSchemaType ( ) const

Obtain a symbolic name for the elution_profile_correlation_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getElutionTimeDelta()

std::string getElutionTimeDelta ( ) const

Returns the value of the elution_time_delta attribute.

Elution time difference allowed when trying to pair up components.

Returns
current value of the elution_time_delta attribute.

◆ getElutionTimeDeltaSchemaType()

std::string getElutionTimeDeltaSchemaType ( ) const

Obtain a symbolic name for the elution_time_delta attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getElutionTimeDeltaUnit()

std::string getElutionTimeDeltaUnit ( ) const

Returns the value of the elution_time_delta_unit attribute.

Units for the elution_time_delta attribute.

Returns
current value of the elution_time_delta_unit attribute.

◆ getElutionTimeDeltaUnitSchemaType()

std::string getElutionTimeDeltaUnitSchemaType ( ) const

Obtain a symbolic name for the elution_time_delta_unit attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMassDelta()

std::string getMassDelta ( ) const
Deprecated:
Not in use.
Returns
mass delta

◆ getMassDeltaSchemaType()

std::string getMassDeltaSchemaType ( ) const
Deprecated:
Not in use.
Returns
mass delta schema type

◆ getMassDeltaUnit()

std::string getMassDeltaUnit ( ) const
Deprecated:
Not in use.
Returns
mass delta unit

◆ getMassDeltaUnitSchemaType()

std::string getMassDeltaUnitSchemaType ( ) const
Deprecated:
Not in use.
Returns
mass delta unit schema type

◆ getMatchedRho()

std::string getMatchedRho ( ) const

Returns the value of the matched_rho attribute.

Threshold on the correlation coefficient between the predicted and observed precursor isotope distributions.

Returns
current value of the matched_rho attribute.

◆ getMatchedRhoSchemaType()

std::string getMatchedRhoSchemaType ( ) const

Obtain a symbolic name for the matched_rho attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMethod()

std::string getMethod ( ) const

Returns the value of the method attribute.

The method attribute specifies an integration algorithm.

Returns
current value of the method attribute.

◆ getMethodSchemaType()

std::string getMethodSchemaType ( ) const

Obtain a symbolic name for the method attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_quant_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_quant_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtualinherited

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

◆ getPrecursorRange()

std::string getPrecursorRange ( ) const
Deprecated:
Do not use.
Returns
precursor range

◆ getPrecursorRangeSchemaType()

std::string getPrecursorRangeSchemaType ( ) const
Deprecated:
Do not use.
Returns
precursor range schema type

◆ getProcessingOptions()

std::string getProcessingOptions ( ) const
Deprecated:
Do not use.
Returns
processing options

◆ getProcessingOptionsSchemaType()

std::string getProcessingOptionsSchemaType ( ) const
Deprecated:
Do not use.
Returns
processing options schema type

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

◆ getSimpleRatioSchemaType()

std::string getSimpleRatioSchemaType ( ) const

Obtain a symbolic name for the simple_ratio attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSource()

std::string getSource ( ) const

Returns the value of the source attribute.

Scan type containing data to be integrated.

Returns
current value of the source attribute.

◆ getSourceSchemaType()

std::string getSourceSchemaType ( ) const

Obtain a symbolic name for the source attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getXicMaxWidth()

int getXicMaxWidth ( ) const

Returns the value of the xic_max_width attribute.

Upper limit on the number of survey scans in an XIC peak.

Returns
current value of the xic_max_width attribute.

◆ getXicMaxWidthSchemaType()

std::string getXicMaxWidthSchemaType ( ) const

Obtain a symbolic name for the "xic_max_width" schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getXicSmoothing()

int getXicSmoothing ( ) const

Returns the value of the xic_smoothing attribute.

XIC peak is smoothed by a set of 2n+1 Savitzky-Golay convolution integers, where n is this value (0 corresponds to no smoothing).

Returns
current value of the xic_smoothing attribute.

◆ getXicSmoothingSchemaType()

std::string getXicSmoothingSchemaType ( ) const

Obtain a symbolic name for the xic_smoothing attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getXicThreshold()

std::string getXicThreshold ( ) const

Returns the value of the xic_threshold attribute.

The start and end of an XIC peak are where the intensity drops to this fraction of the intensity of the XIC peak maximum.

Returns
current value of the xic_threshold attribute.

◆ getXicThresholdSchemaType()

std::string getXicThresholdSchemaType ( ) const

Obtain a symbolic name for the xic_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveAllChargeStates()

bool haveAllChargeStates ( ) const

Indicates presence of the all_charge_states attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveAllChargeStatesThreshold()

bool haveAllChargeStatesThreshold ( ) const

Indicates presence of the all_charge_states_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveAllowElutionShift()

bool haveAllowElutionShift ( ) const

Indicates presence of the allow_elution_shift attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveElutionProfileCorrelationThreshold()

bool haveElutionProfileCorrelationThreshold ( ) const

Indicates presence of the elution_profile_correlation_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveElutionTimeDelta()

bool haveElutionTimeDelta ( ) const

Indicates presence of the elution_time_delta attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveElutionTimeDeltaUnit()

bool haveElutionTimeDeltaUnit ( ) const

Indicates presence of the elution_time_delta_unit attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveMassDelta()

bool haveMassDelta ( ) const
Deprecated:
Not in use.
Returns
true if mass delta is set, false otherwise

◆ haveMassDeltaUnit()

bool haveMassDeltaUnit ( ) const
Deprecated:
Not in use.
Returns
true if mass delta unit is set, false otherwise

◆ haveMatchedRho()

bool haveMatchedRho ( ) const

Indicates presence of the matched_rho attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveMethod()

bool haveMethod ( ) const

Indicates presence of the method attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ havePrecursorRange()

bool havePrecursorRange ( ) const
Deprecated:
Do not use.
Returns
true if precusor range is set, false otherwise

◆ haveProcessingOptions()

bool haveProcessingOptions ( ) const
Deprecated:
Do not use.
Returns
true if processing options is set, false otherwise

◆ haveSimpleRatio()

bool haveSimpleRatio ( ) const

Indicates presence of the simple_ratio attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveSource()

bool haveSource ( ) const

Indicates presence of the source attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveXicMaxWidth()

bool haveXicMaxWidth ( ) const

Indicates presence of the xic_max_width attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveXicSmoothing()

bool haveXicSmoothing ( ) const

Indicates presence of the xic_smoothing attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveXicThreshold()

bool haveXicThreshold ( ) const

Indicates presence of the xic_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ isAllChargeStates()

bool isAllChargeStates ( ) const

Returns the value of the all_charge_states attribute.

All charge states extends the mass and time matching to cover contiguous charge states. In other words, if there is a positive match on 2+, the software will look for 1+ and 3+. It will not look for 4+ unless 3+ is found, etc.

Returns
current attribute value.

◆ isAllowElutionShift()

bool isAllowElutionShift ( ) const

Returns the value of the allow_elution_shift attribute.

Returns
current attribute value.

◆ isSimpleRatio()

bool isSimpleRatio ( ) const

Returns the value of the simple_ratio attribute.

Returns
current attribute value.

◆ operator=()

ms_quant_integration & operator= ( const ms_quant_integration & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAllChargeStates()

void setAllChargeStates ( const bool value )

Set a custom value for the all_charge_states attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropAllChargeStates().

Parameters
value a new value for the attribute.

◆ setAllChargeStatesThreshold()

void setAllChargeStatesThreshold ( const char * value )

Set a custom value for the all_charge_states_threshold attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropAllChargeStatesThreshold().

Parameters
value a new value for the attribute.

◆ setAllowElutionShift()

void setAllowElutionShift ( const bool value )

Set a custom value for the allow_elution_shift attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropAllowElutionShift().

Parameters
value a new value for the attribute.

◆ setElutionProfileCorrelationThreshold()

void setElutionProfileCorrelationThreshold ( const char * value )

Set a custom value for the elution_profile_correlation_threshold attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropElutionProfileCorrelationThreshold().

Parameters
value a new value for the attribute.

◆ setElutionTimeDelta()

void setElutionTimeDelta ( const char * value )

Set a custom value for the elution_time_delta attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropElutionTimeDelta().

Parameters
value a new value for the attribute.

◆ setElutionTimeDeltaUnit()

void setElutionTimeDeltaUnit ( const char * value )

Set a custom value for the elution_time_delta_unit attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropElutionTimeDeltaUnit().

Parameters
value a new value for the attribute.

◆ setMassDelta()

void setMassDelta ( const char * value )
Deprecated:
Not in use.
Parameters
value mass delta

◆ setMassDeltaUnit()

void setMassDeltaUnit ( const char * value )
Deprecated:
Not in use.
Parameters
value mass delta unit

◆ setMatchedRho()

void setMatchedRho ( const char * value )

Set a custom value for the matched_rho attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMatchedRho().

Parameters
value a new value for the attribute.

◆ setMethod()

void setMethod ( const char * value )

Set a custom value for the method attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMethod().

Parameters
value a new value for the attribute.

◆ setPrecursorRange()

void setPrecursorRange ( const char * value )
Deprecated:
Do not use.
Parameters
value precursor range

◆ setProcessingOptions()

void setProcessingOptions ( const std::string value )
Deprecated:
Do not use.
Parameters
value processing options

◆ setSimpleRatio()

void setSimpleRatio ( const bool value )

Set a custom value for the simple_ratio attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropSimpleRatio().

Parameters
value a new value for the attribute.

◆ setSource()

void setSource ( const char * value )

Set a custom value for the source attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropSource().

Parameters
value a new value for the attribute.

◆ setXicMaxWidth()

void setXicMaxWidth ( int value )

Set a custom value for the xic_max_width attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropXicMaxWidth().

Parameters
value a new value for the attribute.

◆ setXicSmoothing()

void setXicSmoothing ( int value )

Set a custom value for the xic_smoothing attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropXicSmoothing().

Parameters
value a new value for the attribute.

◆ setXicThreshold()

void setXicThreshold ( const char * value )

Set a custom value for the xic_threshold attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropXicThreshold().

Parameters
value a new value for the attribute.

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_integration.hpp
  • ms_quant_integration.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_isotope Class Reference

  • matrix_science
  • ms_quant_isotope
Public Member Functions | List of all members
ms_quant_isotope Class Reference
Mascot configuration files module

Represents an isotope element. More...

#include <ms_quant_isotope.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_isotope ()
Default constructor.
ms_quant_isotope (const ms_quant_isotope &src)
Copying constructor.
virtual | ~ms_quant_isotope ()
Destructor.
void | copyFrom (const ms_quant_isotope *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropNew ()
Delete the new element.
void | dropOld ()
Delete the old element.
std::string | getNew () const
Returns the value of the new element.
std::string | getNewSchemaType () const
Obtain a symbolic name for the new element schema type.
std::string | getOld () const
Returns the value of the old element.
std::string | getOldSchemaType () const
Obtain a symbolic name for the old element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveNew () const
Indicates presence of the new element.
bool | haveOld () const
Indicates presence of the old element.
ms_quant_isotope & | operator= (const ms_quant_isotope &right)
C++ style assignment operator.
void | setNew (const char *value)
Set a custom value for the new element.
void | setOld (const char *value)
Set a custom value for the old element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents an isotope element.

Constructor & Destructor Documentation

◆ ms_quant_isotope() [1/2]

ms_quant_isotope ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_isotope() [2/2]

ms_quant_isotope ( const ms_quant_isotope & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_isotope * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropNew()

void dropNew ( )

Delete the new element.

Deletes the element until is re-set.

◆ dropOld()

void dropOld ( )

Delete the old element.

Deletes the element until is re-set.

◆ getNew()

std::string getNew ( ) const

Returns the value of the new element.

The new element represents isotope label.

Returns
a particular isotope to use instead of a standard element.

◆ getNewSchemaType()

std::string getNewSchemaType ( ) const

Obtain a symbolic name for the new element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getOld()

std::string getOld ( ) const

Returns the value of the old element.

The old element specifies isotope to be replaced, usually the most abundant natural isotope of the element.

Returns
for example, "N".

◆ getOldSchemaType()

std::string getOldSchemaType ( ) const

Obtain a symbolic name for the old element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ haveNew()

bool haveNew ( ) const

Indicates presence of the new element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveOld()

bool haveOld ( ) const

Indicates presence of the old element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ operator=()

ms_quant_isotope & operator= ( const ms_quant_isotope & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setNew()

void setNew ( const char * value )

Set a custom value for the new element.

Parameters
value a new value for the element.

◆ setOld()

void setOld ( const char * value )

Set a custom value for the old element.

Parameters
value a new value for the element.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_isotope.hpp
  • ms_quant_isotope.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_localdef Class Reference

  • matrix_science
  • ms_quant_localdef
Public Member Functions | List of all members
ms_quant_localdef Class Reference
Mascot configuration files module

Represents a local_definition element. More...

#include <ms_quant_localdef.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_localdef ()
Default constructor.
ms_quant_localdef (const ms_quant_localdef &src)
Copying constructor.
virtual | ~ms_quant_localdef ()
Destructor.
void | appendIgnore (const ms_quant_composition *ignore)
Adds a new Ignore element at the end of the list.
void | appendSpecificity (const ms_quant_specificity *specificity)
Adds a new specificity element at the end of the list.
void | clearIgnores ()
Deletes all Ignore elements from the list.
void | clearSpecificities ()
Deletes all specificity elements from the list.
void | copyFrom (const ms_quant_localdef *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteIgnore (const int idx)
Remove an Ignore element from the list.
bool | deleteSpecificity (const int idx)
Remove a specificity element from the list.
void | dropDelta ()
Deletes the delta element.
void | dropTitle ()
Deletes the title attribute.
const ms_quant_composition * | getDelta () const
Returns a pointer to the delta element.
std::string | getDeltaSchemaType () const
Obtain a symbolic name for the delta element schema type.
const ms_quant_composition * | getIgnore (const int idx) const
Returns an Ignore element object by its number.
std::string | getIgnoreSchemaType () const
Obtain a symbolic name for the Ignore element schema type.
int | getNumberOfIgnores () const
Returns the number of Ignore elements held.
int | getNumberOfSpecificities () const
Returns the number of specificity elements held.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
const ms_quant_specificity * | getSpecificity (const int idx) const
Returns a specificity element object by its number.
std::string | getSpecificitySchemaType () const
Obtain a symbolic name for the specificity element schema type.
std::string | getTitle () const
Returns the value of the title attribute.
std::string | getTitleSchemaType () const
Obtain a symbolic name for the title attribute schema type.
bool | haveDelta () const
Check presence of the delta element.
bool | haveTitle () const
Check presence of the title attribute.
ms_quant_localdef & | operator= (const ms_quant_localdef &right)
C++ style assignment operator.
void | setDelta (const ms_quant_composition *delta)
Supply custom content for the delta element.
void | setTitle (const char *value)
Set a custom value for the title attribute.
bool | updateIgnore (const int idx, const ms_quant_composition *ignore)
Update the information for a specific Ignore element.
bool | updateSpecificity (const int idx, const ms_quant_specificity *specificity)
Update the information for a specific specificity element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents a local_definition element.

Constructor & Destructor Documentation

◆ ms_quant_localdef() [1/2]

ms_quant_localdef ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_localdef() [2/2]

ms_quant_localdef ( const ms_quant_localdef & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendIgnore()

void appendIgnore ( const ms_quant_composition * ignore )

Adds a new Ignore element at the end of the list.

Parameters
ignore an instance to copy the content into the newly added element from.

◆ appendSpecificity()

void appendSpecificity ( const ms_quant_specificity * specificity )

Adds a new specificity element at the end of the list.

Parameters
specificity an instance to copy the content into the newly added element from.

◆ copyFrom()

void copyFrom ( const ms_quant_localdef * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteIgnore()

bool deleteIgnore ( const int idx )

Remove an Ignore element from the list.

Parameters
idx a zero-based index of the element to delete.
Returns
TRUE if the element has been successfully deleted and FALSE otherwise.

◆ deleteSpecificity()

bool deleteSpecificity ( const int idx )

Remove a specificity element from the list.

Parameters
idx a zero-based index of the element to delete.
Returns
TRUE if the element has been successfully deleted and FALSE otherwise.

◆ dropDelta()

void dropDelta ( )

Deletes the delta element.

Disables the element until it is re-set.

◆ dropTitle()

void dropTitle ( )

Deletes the title attribute.

Disables the attribute until it is re-set.

◆ getDelta()

const ms_quant_composition * getDelta ( ) const

Returns a pointer to the delta element.

Returns
a read-only pointer to the current content. See Maintaining object references: two rules of thumb.

◆ getDeltaSchemaType()

std::string getDeltaSchemaType ( ) const

Obtain a symbolic name for the delta element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getIgnore()

const ms_quant_composition * getIgnore ( const int idx ) const

Returns an Ignore element object by its number.

Parameters
idx a zero-based index of the element to retrieve.
Returns
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.

◆ getIgnoreSchemaType()

std::string getIgnoreSchemaType ( ) const

Obtain a symbolic name for the Ignore element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfIgnores()

int getNumberOfIgnores ( ) const

Returns the number of Ignore elements held.

Returns
total number of Ignore elements held.

◆ getNumberOfSpecificities()

int getNumberOfSpecificities ( ) const

Returns the number of specificity elements held.

Returns
total number of specificity elements held.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ getSpecificity()

const ms_quant_specificity * getSpecificity ( const int idx ) const

Returns a specificity element object by its number.

Parameters
idx a zero-based index of the element to retrieve.
Returns
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.

◆ getSpecificitySchemaType()

std::string getSpecificitySchemaType ( ) const

Obtain a symbolic name for the specificity element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getTitle()

std::string getTitle ( ) const

Returns the value of the title attribute.

Returns
current value of the attribute.

◆ getTitleSchemaType()

std::string getTitleSchemaType ( ) const

Obtain a symbolic name for the title attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveDelta()

bool haveDelta ( ) const

Check presence of the delta element.

Returns
TRUE if the element is available.

◆ haveTitle()

bool haveTitle ( ) const

Check presence of the title attribute.

Returns
TRUE if the attribute is available.

◆ operator=()

ms_quant_localdef & operator= ( const ms_quant_localdef & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setDelta()

void setDelta ( const ms_quant_composition * delta )

Supply custom content for the delta element.

Calling this method makes the sub-element automatically available in the current element.

Parameters
delta a new content for the element.

◆ setTitle()

void setTitle ( const char * title )

Set a custom value for the title attribute.

Calling this method makes the attribute automatically available in the current element.

Parameters
title a new value for the attribute.

◆ updateIgnore()

bool updateIgnore | ( | const int | idx,
 |  | const ms_quant_composition * | ignore
 | ) |  |

Update the information for a specific Ignore element.

Parameters
idx | a zero-based index of the element to update.
ignore | an instance to copy the content from.
Returns
TRUE if the element has been successfully updated and FALSE otherwise.

◆ updateSpecificity()

bool updateSpecificity | ( | const int | idx,
 |  | const ms_quant_specificity * | specificity
 | ) |  |

Update the information for a specific specificity element.

Parameters
idx | a zero-based index of the element to update.
specificity | an instance to copy the content from.
Returns
TRUE if the element has been successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_localdef.hpp
  • ms_quant_localdef.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_method Class Reference

  • matrix_science
  • ms_quant_method
Public Types | Public Member Functions | List of all members
ms_quant_method Class Reference
Mascot configuration files module

An object of this class represent a single quantitation method from quantitation.xml. More...

#include <ms_quant_method.hpp>

Inherits ms_xml_IValidatable.

Public Types

enum METHOD_COMPATIBLE {
COMPATIBLE ,
COMPATIBLE_DIFF_PROTOCOL ,
COMPATIBLE_DIFF_NUM_COMPONENTS ,
COMPATIBLE_MISSING_COMPONENT ,
COMPATIBLE_DIFF_NUM_MOD_GROUPS ,
COMPATIBLE_MISSING_MOD_GROUP ,
COMPATIBLE_DIFF_NUM_LOCAL_MODS ,
COMPATIBLE_DIFF_LOCAL_MOD ,
COMPATIBLE_DIFF_NUM_MODS ,
COMPATIBLE_MISSING_MOD ,
COMPATIBLE_MISSING_INTEGRATION ,
COMPATIBLE_MISSING_INTEGRATION_PARAM ,
COMPATIBLE_DIFF_INTEGRATION_PARAM ,
COMPATIBLE_DIFF_NUM_ISOTOPES
}
Enum used by isMethodCompatible() More...

Public Member Functions

ms_quant_method ()
Default constructor.
ms_quant_method (const ms_quant_method &src)
Copying constructor.
virtual | ~ms_quant_method ()
Destructor.
void | appendComponent (const ms_quant_component *item)
Adds a new component at the end of the list.
void | appendExclusion (const char *exclusion)
Adds a new exclusion element at the end of the list.
void | appendModificationGroup (const ms_quant_modgroup *item)
Adds a new modification group at the end of the list.
void | appendReportRatio (const ms_quant_ratio *ratio)
Adds a new report_ratio element at the end of the list.
void | appendSeq (const char *seq)
Adds a new seq element at the end of the list.
void | clearComponents ()
Deletes all components from the list.
void | clearExclusions ()
Deletes all exclusion elements from the list.
void | clearModificationGroups ()
Deletes all modification groups from the list.
void | clearReportRatios ()
Deletes all report_ratio elements from the list.
void | clearSeqs ()
Deletes all seq elements from the list.
void | copyFrom (const ms_quant_method *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteComponentByName (const char *name)
Remove a component from the list in memory by its unique name.
bool | deleteComponentByNumber (const int idx)
Remove a component from the list in memory by its index.
bool | deleteExclusion (const int idx)
Remove a exclusion element from the list in memory by its index.
bool | deleteModificationGroupByName (const char *name)
Remove a modification group from the list in memory by its unique name.
bool | deleteModificationGroupByNumber (const int idx)
Remove a modification group from the list in memory by its index.
bool | deleteReportRatioByName (const char *name)
Remove a report_ratio element from the list in memory by its unique name.
bool | deleteReportRatioByNumber (const int idx)
Remove a report_ratio element from the list in memory by its index.
bool | deleteSeq (const int idx)
Remove a seq element from the list in memory by its index.
void | dropComp ()
Delete the comp element.
void | dropConstrainSearch ()
Delete the constrain_search attribute.
void | dropDescription ()
Delete the description attribute.
void | dropIntegration ()
Delete the integration element.
void | dropMinNumPeptides ()
Delete the min_num_peptides attribute.
void | dropName ()
Delete the name attribute.
void | dropNormalisation ()
Delete the normalisation element.
void | dropOutliers ()
Delete the outliers element.
void | dropProteinRatioType ()
Delete the protein_ratio_type attribute.
void | dropProtocol ()
Delete the protocol element.
void | dropProtScoreType ()
Delete the prot_score_type attribute.
void | dropQuality ()
Delete the quality element.
void | dropReportDetail ()
Delete the report_detail attribute.
void | dropRequireBoldRed ()
Delete the require_bold_red attribute.
void | dropShowSubSets ()
Delete the show_sub_sets attribute.
void | dropSigThresholdValue ()
Delete the sig_threshold_value attribute.
std::string | getComp () const
Returns the value of the comp element.
const ms_quant_component * | getComponentByName (const char *name) const
Returns a component object by its name or a null value in case of not found.
const ms_quant_component * | getComponentByNumber (const int idx) const
Returns a component object by its number (0..n-1).
std::string | getComponentSchemaType () const
Obtain a symbolic name for the component element schema type.
std::string | getCompSchemaType () const
Obtain a symbolic name for the comp element schema type.
std::string | getConstrainSearchSchemaType () const
Obtain a symbolic name for the constrain_search attribute schema type.
std::string | getDescription () const
Returns the value of the description attribute.
std::string | getDescriptionSchemaType () const
Obtain a symbolic name for the description attribute schema type.
std::string | getExclusion (const int idx) const
Returns a exclusion element object by its number.
std::string | getExclusionSchemaType () const
Obtain a symbolic name for the exclusion element schema type.
const ms_quant_integration * | getIntegration () const
Returns a pointer to the integration element.
std::string | getIntegrationSchemaType () const
Obtain a symbolic name for the integration element schema type.
void | getLocalModifications (std::vector< const ms_quant_localdef * > &localDefVector)
Returns all local modification definitions within method and components.
int | getMinNumPeptides () const
Returns the value of the min_num_peptides attribute.
std::string | getMinNumPeptidesSchemaType () const
Obtain a symbolic name for the min_num_peptides attribute schema type.
const ms_quant_modgroup * | getModificationGroupByName (const char *name) const
Returns a modification group object by its name or a null value in case of not found.
const ms_quant_modgroup * | getModificationGroupByNumber (const int idx) const
Returns a modification group object by its number.
std::string | getModificationGroupSchemaType () const
Obtain a symbolic name for the modification group element schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the "name attribute" schema type.
const ms_quant_normalisation * | getNormalisation () const
Returns a pointer to the normalisation element.
std::string | getNormalisationSchemaType () const
Obtain a symbolic name for the normalisation element schema type.
int | getNumberOfComponents () const
Returns the number of nested components.
int | getNumberOfExclusions () const
Returns the number of nested exclusion elements.
int | getNumberOfModificationGroups () const
Returns the number of nested modification groups.
int | getNumberOfReportRatios () const
Returns the number of nested report_ratio elements.
int | getNumberOfSeqs () const
Returns the number of nested seq elements.
const ms_quant_outliers * | getOutliers () const
Returns a pointer to the outliers element.
std::string | getOutliersSchemaType () const
Obtain a symbolic name for the outliers element schema type.
std::string | getProteinRatioType () const
Returns the value of the protein_ratio_type attribute.
std::string | getProteinRatioTypeSchemaType () const
Obtain a symbolic name for the protein_ratio_type attribute schema type.
const ms_quant_protocol * | getProtocol () const
Returns a pointer to the protocol element.
std::string | getProtocolSchemaType () const
Obtain a symbolic name for the protocol element schema type.
std::string | getProtScoreType () const
Returns the value of the prot_score_type attribute.
std::string | getProtScoreTypeSchemaType () const
Obtain a symbolic name for the prot_score_type attribute schema type.
const ms_quant_quality * | getQuality () const
Returns a pointer to the quality element.
std::string | getQualitySchemaType () const
Obtain a symbolic name for the quality element schema type.
std::string | getReportDetailSchemaType () const
Obtain a symbolic name for the report_detail attribute schema type.
const ms_quant_ratio * | getReportRatioByName (const char *name) const
Returns a report_ratio element object by its name or a null value in case of not found.
const ms_quant_ratio * | getReportRatioByNumber (const int idx) const
Returns a report_ratio element object by its number.
std::string | getReportRatioSchemaType () const
Obtain a symbolic name for the report_ratio element schema type.
std::string | getRequireBoldRedSchemaType () const
Obtain a symbolic name for the require_bold_red attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSeq (const int idx) const
Returns a seq element object by its number.
std::string | getSeqSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getShowSubSets () const
Returns the value of the show_sub_sets attribute.
std::string | getShowSubSetsSchemaType () const
Obtain a symbolic name for the show_sub_sets attribute schema type.
std::string | getSigThresholdValue () const
Returns the value of the sig_threshold_value attribute.
std::string | getSigThresholdValueSchemaType () const
Obtain a symbolic name for the sig_threshold_value attribute schema type.
bool | haveComp () const
Indicates whether the comp element is present.
bool | haveConstrainSearch () const
Indicates whether the constrain_search attribute is present.
bool | haveDescription () const
Indicates whether the description attribute is present.
bool | haveIntegration () const
Indicates whether the integration element is present.
bool | haveMinNumPeptides () const
Indicates whether the min_num_peptides attribute is present.
bool | haveName () const
Indicates whether the name attribute is present.
bool | haveNormalisation () const
Indicates whether the normalisation element is present.
bool | haveOutliers () const
Indicates whether the outliers element is present.
bool | haveProteinRatioType () const
Indicates whether the protein_ratio_type attribute is present.
bool | haveProtocol () const
Indicates whether the protocol element is present.
bool | haveProtScoreType () const
Indicates whether the prot_score_type attribute is present.
bool | haveQuality () const
Indicates whether the quality element is present.
bool | haveReportDetail () const
Indicates whether the report_detail attribute is present.
bool | haveRequireBoldRed () const
Indicates whether the require_bold_red attribute is present.
bool | haveShowSubSets () const
Indicates whether the show_sub_sets attribute is present.
bool | haveSigThresholdValue () const
Indicates whether the sig_threshold_value attribute is present.
bool | isConstrainSearch () const
Returns the value of the constrain_search attribute.
int | isMethodCompatible (const ms_quant_method &other, std::string &reasonStrRef) const
Methods are compatible if the protocol and selected other values are identical.
bool | isReportDetail () const
Returns the value of the report_detail attribute.
bool | isRequireBoldRed () const
Returns the value of the require_bold_red attribute.
ms_quant_method & | operator= (const ms_quant_method &right)
C++ style assignment operator.
void | setComp (const char *value)
Set a custom value for the comp element.
void | setConstrainSearch (const bool value)
Set a custom value for the constrain_search attribute.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setIntegration (const ms_quant_integration *integration)
Supply custom content for the integration element.
void | setMinNumPeptides (const int value)
Set a custom value for the min_num_peptides attribute.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setNormalisation (const ms_quant_normalisation *normalisation)
Supply custom content for the normalisation element.
void | setOutliers (const ms_quant_outliers *outliers)
Supply custom content for the outliers element.
void | setProteinRatioType (const char *value)
Set a custom value for the protein_ratio_type attribute.
void | setProtocol (const ms_quant_protocol *protocol)
Supply custom content for the protocol element.
void | setProtScoreType (const char *value)
Set a custom value for the prot_score_type attribute.
void | setQuality (const ms_quant_quality *quality)
Supply custom content for the quality element.
void | setReportDetail (const bool value)
Set a custom value for the report_detail attribute.
void | setRequireBoldRed (const bool value)
Set a custom value for the require_bold_red attribute.
void | setShowSubSets (const char *value)
Set a custom value for the show_sub_sets attribute.
void | setSigThresholdValue (const char *value)
Set a custom value for the sig_threshold_value attribute.
bool | updateComponentByName (const char *name, const ms_quant_component *comp)
Update the information for a specific component refering to it by its unique name.
bool | updateComponentByNumber (const int idx, const ms_quant_component *comp)
Update the information for a specific component refering to it by its index.
bool | updateExclusion (const int idx, const char *exclusion)
Update the information for a specific exclusion element refering to it by its index.
bool | updateModificationGroupByName (const char *name, const ms_quant_modgroup *modgroup)
Update the information for a specific modification group refering to it by its unique name.
bool | updateModificationGroupByNumber (const int idx, const ms_quant_modgroup *modgroup)
Update the information for a specific modification group refering to it by its index.
bool | updateReportRatioByName (const char *name, const ms_quant_ratio *ratio)
Update the information for a specific report_ratio element refering to it by its unique name.
bool | updateReportRatioByNumber (const int idx, const ms_quant_ratio *ratio)
Update the information for a specific report_ratio element refering to it by its index.
bool | updateSeq (const int idx, const char *seq)
Update the information for a specific seq element refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single quantitation method from quantitation.xml.

Examples
config_quantitation.cpp.

Member Enumeration Documentation

◆ METHOD_COMPATIBLE

enum METHOD_COMPATIBLE

Enum used by isMethodCompatible()

See Using enumerated values and static const ints in Perl, Java, Python and C#. The description for each of the enums is the human readable text for each of the 'error' codes

Enumerator
COMPATIBLE | Methods are compatible.
COMPATIBLE_DIFF_PROTOCOL | Methods 'x' and 'y' are incompatible: Different protocols ('p1' and 'p2') for the methods.
COMPATIBLE_DIFF_NUM_COMPONENTS | Methods 'x' and 'y' are incompatible: Different number of components ('c1' and 'c2').
COMPATIBLE_MISSING_COMPONENT | Methods 'x' and 'y' are incompatible: Component 'c1' is missing from method 'y'.
COMPATIBLE_DIFF_NUM_MOD_GROUPS | Methods 'x' and 'y' are incompatible: Different number of modification groups ('mg1' and 'mg2') for component/method 'Z'.
COMPATIBLE_MISSING_MOD_GROUP | Methods 'x' and 'y' are incompatible: Modification group mg is missing from component 'c'.
COMPATIBLE_DIFF_NUM_LOCAL_MODS | Methods 'x' and 'y' are incompatible: Different number of local modification definitions ('mg1' and 'mg2') for modification group 'mg'.
COMPATIBLE_DIFF_LOCAL_MOD | Methods 'x' and 'y' are incompatible: Local modification 'lm' definition differs.
COMPATIBLE_DIFF_NUM_MODS | Methods 'x' and 'y' are incompatible: Different number of modifications ('mg1' and 'mg2') for modification group 'mg'.
COMPATIBLE_MISSING_MOD | Methods 'x' and 'y' are incompatible: Modification 'mod' is missing from modification group 'mg'.
COMPATIBLE_MISSING_INTEGRATION | Methods 'x' and 'y' are incompatible: One method has integration parameters and the other has none.
COMPATIBLE_MISSING_INTEGRATION_PARAM | Methods 'x' and 'y' are incompatible: "Method 'x' has integration parameter 'p' but method 'y' does not.
COMPATIBLE_DIFF_INTEGRATION_PARAM | Methods 'x' and 'y' are incompatible: Method 'x' has integration parameter 'p1'='v1' but method 'y' has 'p2'='v2'.
COMPATIBLE_DIFF_NUM_ISOTOPES | Methods 'x' and 'y' are incompatible: Different number of isotopes ('mg1' and 'mg2') for component 'c1'.

Constructor & Destructor Documentation

◆ ms_quant_method() [1/2]

ms_quant_method ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_method() [2/2]

ms_quant_method ( const ms_quant_method & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendComponent()

void appendComponent ( const ms_quant_component * item )

Adds a new component at the end of the list.

Creates a new component object, copies all content from the object supplied as a parameter and adds it at the end of the components list.

Parameters
item an instance of component object to copy content from.

◆ appendExclusion()

void appendExclusion ( const char * exclusion )

Adds a new exclusion element at the end of the list.

Creates a new exclusion element object and adds it at the end of the exclusion elements list.

Parameters
exclusion an string value for the element.

◆ appendModificationGroup()

void appendModificationGroup ( const ms_quant_modgroup * item )

Adds a new modification group at the end of the list.

Creates a new modification group object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters
item an instance of modification group object to copy content from.

◆ appendReportRatio()

void appendReportRatio ( const ms_quant_ratio * item )

Adds a new report_ratio element at the end of the list.

Creates a new report_ratio element object, copies all content from the object supplied as a parameter and adds it at the end of the "report_ratio" elements list.

Parameters
item an instance of report_ratio element object to copy content from.

◆ appendSeq()

void appendSeq ( const char * seq )

Adds a new seq element at the end of the list.

Creates a new seq element object and adds it at the end of the "seq" elements list.

Parameters
seq an string value for the element.

◆ copyFrom()

void copyFrom ( const ms_quant_method * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteComponentByName()

bool deleteComponentByName ( const char * name )

Remove a component from the list in memory by its unique name.

Parameters
name name of the component for deletion.
Returns
TRUE if the component has been found and successfully deleted and FALSE otherwise.

◆ deleteComponentByNumber()

bool deleteComponentByNumber ( const int idx )

Remove a component from the list in memory by its index.

Parameters
idx number of the component for deletion from 0 to (getNumberOfComponents() - 1).
Returns
TRUE if the component has been found and successfully deleted and FALSE otherwise.

◆ deleteExclusion()

bool deleteExclusion ( const int idx )

Remove a exclusion element from the list in memory by its index.

Parameters
idx number of the exclusion element for deletion from 0 to (getNumberOfExclusions() - 1).
Returns
TRUE if the exclusion element has been found and successfully deleted and FALSE otherwise.

◆ deleteModificationGroupByName()

bool deleteModificationGroupByName ( const char * name )

Remove a modification group from the list in memory by its unique name.

Parameters
name name of the modification group for deletion.
Returns
TRUE if the modification group has been found and successfully deleted and FALSE otherwise.

◆ deleteModificationGroupByNumber()

bool deleteModificationGroupByNumber ( const int idx )

Remove a modification group from the list in memory by its index.

Parameters
idx number of the modification group for deletion from 0 to (getNumberOfModificationGroups() - 1).
Returns
TRUE if the modification group has been found and successfully deleted and FALSE otherwise.

◆ deleteReportRatioByName()

bool deleteReportRatioByName ( const char * name )

Remove a report_ratio element from the list in memory by its unique name.

Parameters
name name of the report_ratio element for deletion.
Returns
TRUE if the report_ratio element has been found and successfully deleted and FALSE otherwise.

◆ deleteReportRatioByNumber()

bool deleteReportRatioByNumber ( const int idx )

Remove a report_ratio element from the list in memory by its index.

Parameters
idx number of the report_ratio element for deletion from 0 to (getNumberOfReportRatios() - 1).
Returns
TRUE if the report_ratio element has been found and successfully deleted and FALSE otherwise.

◆ deleteSeq()

bool deleteSeq ( const int idx )

Remove a seq element from the list in memory by its index.

Parameters
idx number of the seq element for deletion from 0 to (getNumberOfSeqs() - 1).
Returns
TRUE if the seq element has been found and successfully deleted and FALSE otherwise.

◆ dropComp()

void dropComp ( )

Delete the comp element.

Disables the element until it is re-set.

◆ dropConstrainSearch()

void dropConstrainSearch ( )

Delete the constrain_search attribute.

Disables the attribute until it is re-set.

◆ dropDescription()

void dropDescription ( )

Delete the description attribute.

Disables the attribute until it is re-set.

◆ dropIntegration()

void dropIntegration ( )

Delete the integration element.

Deletes the element until it is re-set.

◆ dropMinNumPeptides()

void dropMinNumPeptides ( )

Delete the min_num_peptides attribute.

Disables the attribute until it is re-set.

◆ dropName()

void dropName ( )

Delete the name attribute.

Disables the attribute until it is re-set.

◆ dropNormalisation()

void dropNormalisation ( )

Delete the normalisation element.

Deletes the element until it is re-set.

◆ dropOutliers()

void dropOutliers ( )

Delete the outliers element.

Deletes the element until it is re-set.

◆ dropProteinRatioType()

void dropProteinRatioType ( )

Delete the protein_ratio_type attribute.

Disables the attribute until it is re-set.

◆ dropProtocol()

void dropProtocol ( )

Delete the protocol element.

Deletes the element until it is re-set.

◆ dropProtScoreType()

void dropProtScoreType ( )

Delete the prot_score_type attribute.

Disables the attribute until it is re-set.

◆ dropQuality()

void dropQuality ( )

Delete the quality element.

Deletes the element until it is re-set.

◆ dropReportDetail()

void dropReportDetail ( )

Delete the report_detail attribute.

Disables the attribute until it is re-set.

◆ dropRequireBoldRed()

void dropRequireBoldRed ( )

Delete the require_bold_red attribute.

Disables the attribute until it is re-set.

◆ dropShowSubSets()

void dropShowSubSets ( )

Delete the show_sub_sets attribute.

Disables the attribute until it is re-set.

◆ dropSigThresholdValue()

void dropSigThresholdValue ( )

Delete the sig_threshold_value attribute.

Disables the attribute until it is re-set.

◆ getComp()

std::string getComp ( ) const

Returns the value of the comp element.

See haveComp() method for more information on how to use this.

Returns
a composition qualifier in Mascot notation, e.g. *[C].

◆ getComponentByName()

const ms_quant_component * getComponentByName ( const char * name ) const

Returns a component object by its name or a null value in case of not found.

Parameters
name name of the component to find.
Returns
a read-only pointer to a component object. See Maintaining object references: two rules of thumb.

◆ getComponentByNumber()

const ms_quant_component * getComponentByNumber ( const int idx ) const

Returns a component object by its number (0..n-1).

Parameters
idx number of the component from 0 to (getNumberOfComponents() - 1).
Returns
a read-only pointer to a component object. See Maintaining object references: two rules of thumb.

◆ getComponentSchemaType()

std::string getComponentSchemaType ( ) const

Obtain a symbolic name for the component element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getCompSchemaType()

std::string getCompSchemaType ( ) const

Obtain a symbolic name for the comp element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getConstrainSearchSchemaType()

std::string getConstrainSearchSchemaType ( ) const

Obtain a symbolic name for the constrain_search attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getDescription()

std::string getDescription ( ) const

Returns the value of the description attribute.

Returns
free text string for description.

◆ getDescriptionSchemaType()

std::string getDescriptionSchemaType ( ) const

Obtain a symbolic name for the description attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getExclusion()

std::string getExclusion ( const int idx ) const

Returns a exclusion element object by its number.

Parameters
idx number of the exclusion element from 0 to (getNumberOfExclusions() - 1).
Returns
a string copy of the exclusion element.

◆ getExclusionSchemaType()

std::string getExclusionSchemaType ( ) const

Obtain a symbolic name for the exclusion element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getIntegration()

const ms_quant_integration * getIntegration ( ) const

Returns a pointer to the integration element.

See haveIntegration() for more information.

Returns
a pointer to the object that represents theintegration" element (or a null value if not present). See Maintaining object references: two rules of thumb.

◆ getIntegrationSchemaType()

std::string getIntegrationSchemaType ( ) const

Obtain a symbolic name for the integration element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getLocalModifications()

void getLocalModifications ( std::vector< const ms_quant_localdef * > & localDefVector )

Returns all local modification definitions within method and components.

Method currently only valid for C++ due to vector of object pointers.

Parameters
localDefVector vector to fill with ms_quant_localdef* object pointers.

◆ getMinNumPeptides()

int getMinNumPeptides ( ) const

Returns the value of the min_num_peptides attribute.

Minimum number of peptide matches for reporting quantitation at protein level.

Returns
minimum number of peptide matches

◆ getMinNumPeptidesSchemaType()

std::string getMinNumPeptidesSchemaType ( ) const

Obtain a symbolic name for the min_num_peptides attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getModificationGroupByName()

const ms_quant_modgroup * getModificationGroupByName ( const char * name ) const

Returns a modification group object by its name or a null value in case of not found.

Parameters
name name of the modification group to find.
Returns
a read-only pointer to a modification group object. See Maintaining object references: two rules of thumb.

◆ getModificationGroupByNumber()

const ms_quant_modgroup * getModificationGroupByNumber ( const int idx ) const

Returns a modification group object by its number.

Parameters
idx number of the modification group from 0 to (getNumberOfModificationGroups() - 1).
Returns
a read-only pointer to a modification group object. See Maintaining object references: two rules of thumb.

◆ getModificationGroupSchemaType()

std::string getModificationGroupSchemaType ( ) const

Obtain a symbolic name for the modification group element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getName()

std::string getName ( ) const

Returns the value of the name attribute.

Returns
a descriptive name that will appear in drop down lists, etc.
Examples
config_quantitation.cpp.

◆ getNameSchemaType()

std::string getNameSchemaType ( ) const

Obtain a symbolic name for the "name attribute" schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.
Examples
config_quantitation.cpp.

◆ getNormalisation()

const ms_quant_normalisation * getNormalisation ( ) const

Returns a pointer to the normalisation element.

See haveNormalisation() for more information.

Returns
a pointer to the object that represents the normalisation element (or a null value if not present). See Maintaining object references: two rules of thumb.

◆ getNormalisationSchemaType()

std::string getNormalisationSchemaType ( ) const

Obtain a symbolic name for the normalisation element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfComponents()

int getNumberOfComponents ( ) const

Returns the number of nested components.

Returns
total number of nested components.

◆ getNumberOfExclusions()

int getNumberOfExclusions ( ) const

Returns the number of nested exclusion elements.

Exclude peptides from quantitation if they contain modifications from this group.

Returns
total number of nested exclusion elements.

◆ getNumberOfModificationGroups()

int getNumberOfModificationGroups ( ) const

Returns the number of nested modification groups.

Returns
total number of nested modification groups.

◆ getNumberOfReportRatios()

int getNumberOfReportRatios ( ) const

Returns the number of nested report_ratio elements.

Returns
total number of nested report_ratio elements.

◆ getNumberOfSeqs()

int getNumberOfSeqs ( ) const

Returns the number of nested seq elements.

Sequence qualifier in Mascot notation, e.g. *-TSL.

Returns
total number of nested seq elements.

◆ getOutliers()

const ms_quant_outliers * getOutliers ( ) const

Returns a pointer to the outliers element.

See haveOutliers() for more information.

Returns
a pointer to the object that represents theoutliers" element (or a null value if not present). See Maintaining object references: two rules of thumb.

◆ getOutliersSchemaType()

std::string getOutliersSchemaType ( ) const

Obtain a symbolic name for the outliers element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getProteinRatioType()

std::string getProteinRatioType ( ) const

Returns the value of the protein_ratio_type attribute.

Method of calculating the ratio for the protein from the individual peptide ratios.

Returns
protein ratio type

◆ getProteinRatioTypeSchemaType()

std::string getProteinRatioTypeSchemaType ( ) const

Obtain a symbolic name for the protein_ratio_type attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getProtocol()

const ms_quant_protocol * getProtocol ( ) const

Returns a pointer to the protocol element.

See haveProtocol() for more information.

Returns
a pointer to the object that represents the protocol element (or a null value if not present). See Maintaining object references: two rules of thumb.

◆ getProtocolSchemaType()

std::string getProtocolSchemaType ( ) const

Obtain a symbolic name for the protocol element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getProtScoreType()

std::string getProtScoreType ( ) const

Returns the value of the prot_score_type attribute.

Returns
either "standard" or "mudpit" type.

◆ getProtScoreTypeSchemaType()

std::string getProtScoreTypeSchemaType ( ) const

Obtain a symbolic name for the prot_score_type attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getQuality()

const ms_quant_quality * getQuality ( ) const

Returns a pointer to the quality element.

See haveQuality() for more information.

Returns
a pointer to the object that represents thequality" element (or a null value if not present). See Maintaining object references: two rules of thumb.

◆ getQualitySchemaType()

std::string getQualitySchemaType ( ) const

Obtain a symbolic name for the quality element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getReportDetailSchemaType()

std::string getReportDetailSchemaType ( ) const

Obtain a symbolic name for the report_detail attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getReportRatioByName()

const ms_quant_ratio * getReportRatioByName ( const char * name ) const

Returns a report_ratio element object by its name or a null value in case of not found.

Parameters
name name of the report_ratio element to find.
Returns
a read-only pointer to a report_ratio element object. See Maintaining object references: two rules of thumb.

◆ getReportRatioByNumber()

const ms_quant_ratio * getReportRatioByNumber ( const int idx ) const

Returns a report_ratio element object by its number.

Parameters
idx number of the report_ratio element from 0 to (getNumberOfReportRatios() - 1).
Returns
a read-only pointer to a report_ratio element object. See Maintaining object references: two rules of thumb.

◆ getReportRatioSchemaType()

std::string getReportRatioSchemaType ( ) const

Obtain a symbolic name for the report_ratio element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getRequireBoldRedSchemaType()

std::string getRequireBoldRedSchemaType ( ) const

Obtain a symbolic name for the require_bold_red attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ getSeq()

std::string getSeq ( const int idx ) const

Returns a seq element object by its number.

Parameters
idx number of the seq element from 0 to (getNumberOfSeqs() - 1).
Returns
a string copy of the seq element.

◆ getSeqSchemaType()

std::string getSeqSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getShowSubSets()

std::string getShowSubSets ( ) const

Returns the value of the show_sub_sets attribute.

Returns
A floating point number (represented as a string) between 0 and 1 showing how many subset proteins to display. See also ms_mascotresults::setSubsetsThreshold().

◆ getShowSubSetsSchemaType()

std::string getShowSubSetsSchemaType ( ) const

Obtain a symbolic name for the show_sub_sets attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSigThresholdValue()

std::string getSigThresholdValue ( ) const

Returns the value of the sig_threshold_value attribute.

Mascot score significance threshold as a probabliltiy, default 0.05.

Returns
significant threshold

◆ getSigThresholdValueSchemaType()

std::string getSigThresholdValueSchemaType ( ) const

Obtain a symbolic name for the sig_threshold_value attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveComp()

bool haveComp ( ) const

Indicates whether the comp element is present.

The comp element can be missing for the current method object. In order to be qualified as valid composition qualifier it must be at least 4 characters long. Therefore, an empty string returned by getComp() is not a valid value for the element. Always check whether the comp element is present in the document before retrieving its value.

Returns
TRUE if present and FALSE otherwise.

◆ haveConstrainSearch()

bool haveConstrainSearch ( ) const

Indicates whether the constrain_search attribute is present.

Returns
TRUE if present and FALSE otherwise.

◆ haveDescription()

bool haveDescription ( ) const

Indicates whether the description attribute is present.

Returns
TRUE if present and FALSE otherwise.

◆ haveIntegration()

bool haveIntegration ( ) const

Indicates whether the integration element is present.

The integration element describes method and parameters to be used to integrate precursor over time. If missing, no integration is performed.

Returns
TRUE if present and FALSE if missing.

◆ haveMinNumPeptides()

bool haveMinNumPeptides ( ) const

Indicates whether the min_num_peptides attribute is present.

Returns
TRUE if present and FALSE otherwise.

◆ haveName()

bool haveName ( ) const

Indicates whether the name attribute is present.

Returns
TRUE if present and FALSE otherwise.

◆ haveNormalisation()

bool haveNormalisation ( ) const

Indicates whether the normalisation element is present.

Method of normailising ratios for a complete data set. If missing, no normalisation is performed.

Returns
TRUE if present and FALSE otherwise.

◆ haveOutliers()

bool haveOutliers ( ) const

Indicates whether the outliers element is present.

Method and parameters to be used to remove outliers. If missing, no outlier removal is performed.

Returns
TRUE if present and FALSE otherwise.

◆ haveProteinRatioType()

bool haveProteinRatioType ( ) const

Indicates whether the protein_ratio_type attribute is present.

Returns
TRUE if present and FALSE otherwise.

◆ haveProtocol()

bool haveProtocol ( ) const

Indicates whether the protocol element is present.

The protocol element describes how the quantitative information is obtained.

Returns
TRUE if present and FALSE otherwise.

◆ haveProtScoreType()

bool haveProtScoreType ( ) const

Indicates whether the prot_score_type attribute is present.

Returns
TRUE if present and FALSE otherwise.

◆ haveQuality()

bool haveQuality ( ) const

Indicates whether the quality element is present.

This element specifies quality thresholds for selecting individual spectra or matches.

Returns
TRUE if present and FALSE otherwise.

◆ haveReportDetail()

bool haveReportDetail ( ) const

Indicates whether the report_detail attribute is present.

Returns
TRUE if present and FALSE otherwise.

◆ haveRequireBoldRed()

bool haveRequireBoldRed ( ) const

Indicates whether the require_bold_red attribute is present.

Returns
TRUE if present and FALSE otherwise.

◆ haveShowSubSets()

bool haveShowSubSets ( ) const

Indicates whether the show_sub_sets attribute is present.

Returns
TRUE if present and FALSE otherwise.

◆ haveSigThresholdValue()

bool haveSigThresholdValue ( ) const

Indicates whether the sig_threshold_value attribute is present.

Returns
TRUE if present and FALSE otherwise.

◆ isConstrainSearch()

bool isConstrainSearch ( ) const

Returns the value of the constrain_search attribute.

If any modification group specifies exclusive mode, then apply this constraint during the search so that only matches that can be used for quantitation will be returned.

Returns
true if constraint applies to the search, false otherwise

◆ isMethodCompatible()

int isMethodCompatible | ( | const ms_quant_method & | other,
 |  | std::string & | reasonStrRef
 | ) |  | const

Methods are compatible if the protocol and selected other values are identical.

Result files with 'compatible' quantitation methods can be combined. It is also possible to apply a modified method to an existing results file when creating an ms_ms2quantitation object as long as the methods are 'compatible'.

See ms_quant_method::METHOD_COMPATIBLE for a list of reasons why the methods may not be compatible.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | other | is the other method to compare with this one.
[out] | reasonStrRef | is set to a human readable string if the methods are not compatible.
Returns
ms_quant_method::COMPATIBLE if the quantitation methods are compatible otherwise returns one of the error codes.

◆ isReportDetail()

bool isReportDetail ( ) const

Returns the value of the report_detail attribute.

This attribute defines whether to display quantitation results at the peptide match level.

Returns
true if quantitation results are displayed, false otherwise

◆ isRequireBoldRed()

bool isRequireBoldRed ( ) const

Returns the value of the require_bold_red attribute.

Returns
TRUE if only show proteins that contain a least one "bold red" peptide match.

◆ operator=()

ms_quant_method & operator= ( const ms_quant_method & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setComp()

void setComp ( const char * value )

Set a custom value for the comp element.

Parameters
value a new value for the element.

◆ setConstrainSearch()

void setConstrainSearch ( const bool value )

Set a custom value for the constrain_search attribute.

Parameters
value a new value for the attribute.

◆ setDescription()

void setDescription ( const char * value )

Set a custom value for the description attribute.

Parameters
value a new value for the attribute.

◆ setIntegration()

void setIntegration ( const ms_quant_integration * integration )

Supply custom content for the integration element.

Parameters
integration an object to copy the content from.

◆ setMinNumPeptides()

void setMinNumPeptides ( const int value )

Set a custom value for the min_num_peptides attribute.

Parameters
value a new value for the attribute.

◆ setName()

void setName ( const char * value )

Set a custom value for the name attribute.

Parameters
value a new value for the attribute.
Examples
config_quantitation.cpp.

◆ setNormalisation()

void setNormalisation ( const ms_quant_normalisation * normalisation )

Supply custom content for the normalisation element.

Parameters
normalisation an object to copy the content from.

◆ setOutliers()

void setOutliers ( const ms_quant_outliers * outliers )

Supply custom content for the outliers element.

Parameters
outliers an object to copy the content from.

◆ setProteinRatioType()

void setProteinRatioType ( const char * value )

Set a custom value for the protein_ratio_type attribute.

Parameters
value a new value for the attribute.

◆ setProtocol()

void setProtocol ( const ms_quant_protocol * protocol )

Supply custom content for the protocol element.

Parameters
protocol an object to copy the content from.

◆ setProtScoreType()

void setProtScoreType ( const char * value )

Set a custom value for the prot_score_type attribute.

Parameters
value a new value for the attribute.

◆ setQuality()

void setQuality ( const ms_quant_quality * quality )

Supply custom content for the quality element.

Parameters
quality an object to copy the content from.

◆ setReportDetail()

void setReportDetail ( const bool value )

Set a custom value for the report_detail attribute.

Parameters
value a new value for the attribute.

◆ setRequireBoldRed()

void setRequireBoldRed ( const bool value )

Set a custom value for the require_bold_red attribute.

Parameters
value a new value for the attribute.

◆ setShowSubSets()

void setShowSubSets ( const char * value )

Set a custom value for the show_sub_sets attribute.

Parameters
value a new value for the attribute.

◆ setSigThresholdValue()

void setSigThresholdValue ( const char * value )

Set a custom value for the sig_threshold_value attribute.

Parameters
value a new value for the attribute.

◆ updateComponentByName()

bool updateComponentByName | ( | const char * | name,
 |  | const ms_quant_component * | comp
 | ) |  |

Update the information for a specific component refering to it by its unique name.

Parameters
name | name of the component for updating.
comp | an object to copy the content from.
Returns
TRUE if the component has been found and successfully updated and FALSE otherwise.

◆ updateComponentByNumber()

bool updateComponentByNumber | ( | const int | idx,
 |  | const ms_quant_component * | comp
 | ) |  |

Update the information for a specific component refering to it by its index.

Parameters
idx | number of the component for updating from 0 to (getNumberOfComponents() - 1).
comp | an object to copy the content from.
Returns
TRUE if the component has been found and successfully updated and FALSE otherwise.

◆ updateExclusion()

bool updateExclusion | ( | const int | idx,
 |  | const char * | exclusion
 | ) |  |

Update the information for a specific exclusion element refering to it by its index.

Parameters
idx | number of the exclusion element for updating from 0 to (getNumberOfExclusions() - 1).
exclusion | new string value for the element.
Returns
TRUE if the exclusion element has been successfully updated and FALSE otherwise.

◆ updateModificationGroupByName()

bool updateModificationGroupByName | ( | const char * | name,
 |  | const ms_quant_modgroup * | modgroup
 | ) |  |

Update the information for a specific modification group refering to it by its unique name.

Parameters
name | name of the modification group for updating.
modgroup | an object to copy the content from.
Returns
TRUE if the modification group has been found and successfully updated and FALSE otherwise.

◆ updateModificationGroupByNumber()

bool updateModificationGroupByNumber | ( | const int | idx,
 |  | const ms_quant_modgroup * | modgroup
 | ) |  |

Update the information for a specific modification group refering to it by its index.

Parameters
idx | number of the modification group for updating from 0 to (getNumberOfModificationGroups() - 1).
modgroup | an object to copy the content from.
Returns
TRUE if the modification group has been found and successfully updated and FALSE otherwise.

◆ updateReportRatioByName()

bool updateReportRatioByName | ( | const char * | name,
 |  | const ms_quant_ratio * | ratio
 | ) |  |

Update the information for a specific report_ratio element refering to it by its unique name.

Parameters
name | name of the report_ratio element for updating.
ratio | an object to copy the content from.
Returns
TRUE if the report_ratio element has been found and successfully updated and FALSE otherwise.

◆ updateReportRatioByNumber()

bool updateReportRatioByNumber | ( | const int | idx,
 |  | const ms_quant_ratio * | ratio
 | ) |  |

Update the information for a specific report_ratio element refering to it by its index.

Parameters
idx | number of the report_ratio element for updating from 0 to (getNumberOfReportRatios() - 1).
ratio | an object to copy the content from.
Returns
TRUE if the report_ratio element has been found and successfully updated and FALSE otherwise.

◆ updateSeq()

bool updateSeq | ( | const int | idx,
 |  | const char * | seq
 | ) |  |

Update the information for a specific seq element refering to it by its index.

Parameters
idx | number of the seq element for updating from 0 to (getNumberOfSeqs() - 1).
seq | a new string value for the element.
Returns
TRUE if the seq element has been successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
Examples
config_quantitation.cpp.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
Examples
config_quantitation.cpp.
The documentation for this class was generated from the following files:
  • ms_quant_method.hpp
  • ms_quant_method.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_modgroup Class Reference

  • matrix_science
  • ms_quant_modgroup
Public Member Functions | List of all members
ms_quant_modgroup Class Reference
Mascot configuration files module

An object of this class represent a single modification group element in quantitation.xml. More...

#include <ms_quant_modgroup.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_modgroup ()
Default constructor.
ms_quant_modgroup (const ms_quant_modgroup &src)
Copying constructor.
virtual | ~ms_quant_modgroup ()
Destructor.
void | appendLocalDefinition (const ms_quant_localdef *localdef)
Adds a new local_definition element at the end of the list.
void | appendModFile (const char *mod)
Adds a new mod_file at the end of the list.
void | appendUnmodified (const ms_quant_unmodified *unmodified)
Adds a new unmodified element at the end of the list.
void | clearLocalDefinitions ()
Deletes all local_definition elements from the list.
void | clearModFiles ()
Deletes all mod_file elements from the list.
void | clearUnmodified ()
Deletes all unmodified elements from the list.
void | copyFrom (const ms_quant_modgroup *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteLocalDefinition (const int idx)
Removes a local_definition element from the list.
bool | deleteModFile (const int idx)
Removes mod_file element from the list.
bool | deleteUnmodified (const int idx)
Removes an unmodified element from the list.
void | dropMode ()
Delete the mode attribute.
void | dropName ()
Delete the name attribute.
void | dropRequired ()
Delete the required attribute.
int | findModFile (const char *mod) const
Return zero-based index of a mod_file if it is found in the list, -1 otherwise.
const ms_quant_localdef * | getLocalDefinition (const int idx) const
Returns a local_definition element object by its number.
std::string | getLocalDefinitionSchemaType () const
Obtain a symbolic name for the local_definition element schema type.
std::string | getMode () const
Returns the value of the mode attribute.
std::string | getModeSchemaType () const
Obtain a symbolic name for the mode attribute schema type.
std::string | getModFile (const int idx) const
Returns mod_file element content by its number.
std::string | getModFileSchemaType () const
Obtain a symbolic name for the mod_file element schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
int | getNumberOfLocalDefinitions () const
Returns the number of nested local_definition elements.
int | getNumberOfModFiles () const
Returns the number of nested mod_file elements.
int | getNumberOfUnmodified () const
Returns the number of nested unmodified elements.
std::string | getRequiredSchemaType () const
Obtain a symbolic name for the required attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
const ms_quant_unmodified * | getUnmodified (const int idx) const
Returns an unmodified element object by its number.
std::string | getUnmodifiedSchemaType () const
Obtain a symbolic name for the unmodified element schema type.
bool | haveMode () const
Indicates presence of the mode attribute.
bool | haveName () const
Check for presence of the name attribute.
bool | haveRequired () const
Indicates presence of the required attribute.
bool | isRequired () const
Returns the value of the required attribute.
ms_quant_modgroup & | operator= (const ms_quant_modgroup &right)
C++ style assignment operator.
void | setMode (const char *value)
Set a custom value for the mode attribute.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setRequired (bool value)
Set a custom value for the required attribute.
bool | updateLocalDefinition (const int idx, const ms_quant_localdef *localdef)
Supply new content for one of the local_definition elements in the list.
bool | updateUnmodified (const int idx, const ms_quant_unmodified *unmodified)
Supply new content for one of the unmodified elements in the list.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single modification group element in quantitation.xml.

Grouping to enable mode constraint (e.g. exclusive) to apply to a set of modifications.

Constructor & Destructor Documentation

◆ ms_quant_modgroup() [1/2]

ms_quant_modgroup ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_modgroup() [2/2]

ms_quant_modgroup ( const ms_quant_modgroup & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendLocalDefinition()

void appendLocalDefinition ( const ms_quant_localdef * localdef )

Adds a new local_definition element at the end of the list.

Parameters
localdef a new element to be added to the list.

◆ appendModFile()

void appendModFile ( const char * mod )

Adds a new mod_file at the end of the list.

Parameters
mod a title from the Mascot mod_file.

◆ appendUnmodified()

void appendUnmodified ( const ms_quant_unmodified * unmodified )

Adds a new unmodified element at the end of the list.

Parameters
unmodified a new element to be added to the list.

◆ copyFrom()

void copyFrom ( const ms_quant_modgroup * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteLocalDefinition()

bool deleteLocalDefinition ( const int idx )

Removes a local_definition element from the list.

Parameters
idx a zero based index of the local_definition element to delete from the list.
Returns
true if the index is in rage, false otherwise

◆ deleteModFile()

bool deleteModFile ( const int idx )

Removes mod_file element from the list.

Parameters
idx zero based index of the element to remove.
Returns
TRUE if the element has been successfully removed and FALSE otherwise.

◆ deleteUnmodified()

bool deleteUnmodified ( const int idx )

Removes an unmodified element from the list.

Parameters
idx a zero based index of the unmodified element to delete from the list.
Returns
true if the index is in range, false otherwise

◆ dropMode()

void dropMode ( )

Delete the mode attribute.

Disables the attribute until it is re-set.

◆ dropName()

void dropName ( )

Delete the name attribute.

Deletes the attribute until it is re-set.

◆ dropRequired()

void dropRequired ( )

Delete the required attribute.

Disables the attribute until it is re-set.

◆ findModFile()

int findModFile ( const char * mod ) const

Return zero-based index of a mod_file if it is found in the list, -1 otherwise.

Parameters
mod a title from the Mascot mod_file.
Returns
zero-based index of a mod_file if it is found in the list, otherwise -1.

◆ getLocalDefinition()

const ms_quant_localdef * getLocalDefinition ( const int idx ) const

Returns a local_definition element object by its number.

Parameters
idx a zero based index of the element to retrieve.
Returns
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.

◆ getLocalDefinitionSchemaType()

std::string getLocalDefinitionSchemaType ( ) const

Obtain a symbolic name for the local_definition element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMode()

std::string getMode ( ) const

Returns the value of the mode attribute.

"Mode" is one of fixed, variable or exclusive. Applies to all the modifications in the group.

Returns
current value of the mode attribute.

◆ getModeSchemaType()

std::string getModeSchemaType ( ) const

Obtain a symbolic name for the mode attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getModFile()

std::string getModFile ( const int idx ) const

Returns mod_file element content by its number.

Parameters
idx zero based index of the mod_file element.
Returns
mod_file element content.

◆ getModFileSchemaType()

std::string getModFileSchemaType ( ) const

Obtain a symbolic name for the mod_file element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getName()

std::string getName ( ) const

Returns the value of the name attribute.

Returns
a descriptive name that will appear in drop down lists, etc.

◆ getNameSchemaType()

std::string getNameSchemaType ( ) const

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfLocalDefinitions()

int getNumberOfLocalDefinitions ( ) const

Returns the number of nested local_definition elements.

Returns
total number of nested local_definition elements.

◆ getNumberOfModFiles()

int getNumberOfModFiles ( ) const

Returns the number of nested mod_file elements.

Returns
total number of nested mod_file elements.

◆ getNumberOfUnmodified()

int getNumberOfUnmodified ( ) const

Returns the number of nested unmodified elements.

Returns
total number of nested unmodified elements.

◆ getRequiredSchemaType()

std::string getRequiredSchemaType ( ) const

Obtain a symbolic name for the required attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ getUnmodified()

const ms_quant_unmodified * getUnmodified ( const int idx ) const

Returns an unmodified element object by its number.

Parameters
idx a zero based index of the element to retrieve.
Returns
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.

◆ getUnmodifiedSchemaType()

std::string getUnmodifiedSchemaType ( ) const

Obtain a symbolic name for the unmodified element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveMode()

bool haveMode ( ) const

Indicates presence of the mode attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveName()

bool haveName ( ) const

Check for presence of the name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveRequired()

bool haveRequired ( ) const

Indicates presence of the required attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ isRequired()

bool isRequired ( ) const

Returns the value of the required attribute.

Modification required for a peptide to be part of a component. Does not affect the Mascot search.

Returns
current value of the required attribute.

◆ operator=()

ms_quant_modgroup & operator= ( const ms_quant_modgroup & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setMode()

void setMode ( const char * value )

Set a custom value for the mode attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMode().

Parameters
value a new value for the attribute.

◆ setName()

void setName ( const char * value )

Set a custom value for the name attribute.

Parameters
value a new value for the attribute.

◆ setRequired()

void setRequired ( bool value )

Set a custom value for the required attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropRequired().

Parameters
value a new value for the attribute.

◆ updateLocalDefinition()

bool updateLocalDefinition | ( | const int | idx,
 |  | const ms_quant_localdef * | localdef
 | ) |  |

Supply new content for one of the local_definition elements in the list.

Parameters
idx | a zero based index of the element to update.
localdef | a source to copy the content from.
Returns
TRUE if the element has been successfully updated.

◆ updateUnmodified()

bool updateUnmodified | ( | const int | idx,
 |  | const ms_quant_unmodified * | unmodified
 | ) |  |

Supply new content for one of the unmodified elements in the list.

Parameters
idx | a zero based index of the element to update.
unmodified | a source to copy the content from.
Returns
TRUE if the element has been successfully updated.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_modgroup.hpp
  • ms_quant_modgroup.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_moverz Class Reference

  • matrix_science
  • ms_quant_moverz
Public Member Functions | List of all members
ms_quant_moverz Class Reference
Mascot configuration files module

Parameter name and value pair. More...

#include <ms_quant_moverz.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_moverz ()
Default constructor.
ms_quant_moverz (const ms_quant_moverz &src)
Copying constructor.
virtual | ~ms_quant_moverz ()
Destructor.
void | copyFrom (const ms_quant_moverz *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropAverage ()
Delete the average attribute.
void | dropMonoisotopic ()
Delete the monoisotopic attribute.
std::string | getAverage () const
Returns the value of the average attribute.
std::string | getAverageSchemaType () const
Obtain a symbolic name for the average attribute schema type.
std::string | getMonoisotopic () const
Returns the value of the monoisotopic attribute.
std::string | getMonoisotopicSchemaType () const
Obtain a symbolic name for the monoisotopic attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveAverage () const
Indicates presence of the average attribute.
bool | haveMonoisotopic () const
Indicates presence of the monoisotopic attribute.
ms_quant_moverz & | operator= (const ms_quant_moverz &right)
C++ style assignment operator.
void | setAverage (const char *value)
Set a custom value for the average attribute.
void | setMonoisotopic (const char *value)
Set a custom value for the monoisotopic attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Parameter name and value pair.

Constructor & Destructor Documentation

◆ ms_quant_moverz() [1/2]

ms_quant_moverz ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_moverz() [2/2]

ms_quant_moverz ( const ms_quant_moverz & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_moverz * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropAverage()

void dropAverage ( )

Delete the average attribute.

Deletes the attribute until is re-set.

◆ dropMonoisotopic()

void dropMonoisotopic ( )

Delete the monoisotopic attribute.

Deletes the attribute until is re-set.

◆ getAverage()

std::string getAverage ( ) const

Returns the value of the average attribute.

Returns
current value of the attribute.

◆ getAverageSchemaType()

std::string getAverageSchemaType ( ) const

Obtain a symbolic name for the average attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMonoisotopic()

std::string getMonoisotopic ( ) const

Returns the value of the monoisotopic attribute.

Returns
current attribute value.

◆ getMonoisotopicSchemaType()

std::string getMonoisotopicSchemaType ( ) const

Obtain a symbolic name for the monoisotopic attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ haveAverage()

bool haveAverage ( ) const

Indicates presence of the average attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveMonoisotopic()

bool haveMonoisotopic ( ) const

Indicates presence of the monoisotopic attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_quant_moverz & operator= ( const ms_quant_moverz & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAverage()

void setAverage ( const char * value )

Set a custom value for the average attribute.

Parameters
value a new value for the attribute.

◆ setMonoisotopic()

void setMonoisotopic ( const char * value )

Set a custom value for the monoisotopic attribute.

Parameters
value a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_moverz.hpp
  • ms_quant_moverz.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_multiplex Class Reference

  • matrix_science
  • ms_quant_multiplex
Public Member Functions | List of all members
ms_quant_multiplex Class Reference
Mascot configuration files module

An object of this class represent a multiplex element in quantitation.xml. More...

#include <ms_quant_multiplex.hpp>

Inheritance diagram for ms_quant_multiplex:
[legend]
Collaboration diagram for ms_quant_multiplex:
[legend]

Public Member Functions

ms_quant_multiplex ()
Default constructor.
ms_quant_multiplex (const ms_quant_multiplex &src)
Copying constructor.
virtual | ~ms_quant_multiplex ()
Destructor.
void | appendIonSeries (const std::string ionSeries)
Adds a new ion_series element at the end of the list.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
void | clearIonSeries ()
Deletes all ions_series elements from the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_multiplex *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteIonSeries (const int idx)
Remove an ion_series element from the list in memory by its index.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropExcludeInternalLabel ()
Delete the exclude_internal_label attribute.
void | dropExcludeIsobaricFragments ()
Delete the exclude_isobaric_fragments attribute.
void | dropIonIntensityThreshold ()
Delete the ion_intensity_threshold attribute.
void | dropIonSeries ()
Delete the ion_series element.
void | dropMinIonPairs ()
Delete the min_ion_pairs attribute.
std::string | getExcludeInternalLabelSchemaType () const
Obtain a symbolic name for the exclude_internal_label element schema type.
std::string | getExcludeIsobaricFragmentsSchemaType () const
Obtain a symbolic name for the exclude_isobaric_fragments attribute schema type.
std::string | getIonIntensityThreshold () const
Returns the value of the ion_intensity_threshold attribute.
std::string | getIonIntensityThresholdSchemaType () const
Obtain a symbolic name for the ion_intensity_threshold attribute schema type.
const std::string | getIonSeries (const int idx=0) const
Returns a ion_series element object by its number.
std::string | getIonSeriesSchemaType () const
Obtain a symbolic name for the ion_series element schema type.
int | getMinIonPairs () const
Returns the value of the min_ion_pairs attribute.
std::string | getMinIonPairsSchemaType () const
Obtain a symbolic name for the min_ion_pairs attribute schema type.
int | getNumberOfIonSeries () const
Returns the number of ions series.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveExcludeInternalLabel () const
Indicates presence of the exclude_internal_label attribute.
bool | haveExcludeIsobaricFragments () const
Indicates presence of the exclude_isobaric_fragments attribute.
bool | haveIonIntensityThreshold () const
Indicates presence of the ion_intensity_threshold attribute.
bool | haveIonSeries () const
Check for presence of the ion_series element.
bool | haveMinIonPairs () const
Indicates presence of the min_ion_pairs attribute.
bool | isExcludeInternalLabel () const
Returns the value of the exclude_internal_label attribute value.
bool | isExcludeIsobaricFragments () const
Returns the value of the exclude_isobaric_fragments attribute.
ms_quant_multiplex & | operator= (const ms_quant_multiplex &right)
C++ style assignment operator.
void | setExcludeInternalLabel (const bool value)
Set a custom value for the exclude_internal_label attribute.
void | setExcludeIsobaricFragments (const bool value)
Set a custom value for the exclude_isobaric_fragments attribute.
void | setIonIntensityThreshold (const char *value)
Set a custom value for the ion_intensity_threshold attribute.
void | setIonSeries (const std::string ionSeries)
Supply custom content for the ion_series element.
void | setMinIonPairs (const int value)
Set a custom value for the min_ion_pairs attribute.
bool | updateIonSeries (const int idx, const std::string ionSeries)
Update the information for a specific ion_series element refering to it by its index.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a multiplex element in quantitation.xml.

Use intensities of sequence ion fragment peaks within an MS/MS spectrum.

Constructor & Destructor Documentation

◆ ms_quant_multiplex() [1/2]

ms_quant_multiplex ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_multiplex() [2/2]

ms_quant_multiplex ( const ms_quant_multiplex & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendIonSeries()

void appendIonSeries ( const std::string ionSeries )

Adds a new ion_series element at the end of the list.

In quantitation_1, only a single ions series was allowed for multiplex. This function supersedes setIonSeries().

Parameters
ionSeries is the value to append.

◆ appendParameter()

void appendParameter ( const ms_quant_parameter * item )
inherited

Adds a new parameter at the end of the list.

Parameters
item an instance of parameter object to copy content from.

◆ clearIonSeries()

void clearIonSeries ( )

Deletes all ions_series elements from the list.

In quantitation_1, only a single ions series was allowed for multiplex. This function supersedes dropIonSeries().

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_multiplex * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteIonSeries()

bool deleteIonSeries ( const int idx )

Remove an ion_series element from the list in memory by its index.

Parameters
idx should be in the range 0..getNumberOfIonSeries()-1.
Returns
true if idx is in the correct range.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ dropExcludeInternalLabel()

void dropExcludeInternalLabel ( )

Delete the exclude_internal_label attribute.

Disables the attribute until it is re-set.

◆ dropExcludeIsobaricFragments()

void dropExcludeIsobaricFragments ( )

Delete the exclude_isobaric_fragments attribute.

Disables the attribute until it is re-set.

◆ dropIonIntensityThreshold()

void dropIonIntensityThreshold ( )

Delete the ion_intensity_threshold attribute.

Disables the attribute until it is re-set.

◆ dropIonSeries()

void dropIonSeries ( )

Delete the ion_series element.

Deprecated:
Replaced with clearIonSeries().

In quantitation_1, only a single ions series was allowed for multiplex. This function has the same effect as calling clearIonSeries().

◆ dropMinIonPairs()

void dropMinIonPairs ( )

Delete the min_ion_pairs attribute.

Disables the attribute until it is re-set.

◆ getExcludeInternalLabelSchemaType()

std::string getExcludeInternalLabelSchemaType ( ) const

Obtain a symbolic name for the exclude_internal_label element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getExcludeIsobaricFragmentsSchemaType()

std::string getExcludeIsobaricFragmentsSchemaType ( ) const

Obtain a symbolic name for the exclude_isobaric_fragments attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getIonIntensityThreshold()

std::string getIonIntensityThreshold ( ) const

Returns the value of the ion_intensity_threshold attribute.

Specifies fragment ion intensity threshold as fraction of base peak.

Returns
current value of the ion_intensity_threshold attribute.

◆ getIonIntensityThresholdSchemaType()

std::string getIonIntensityThresholdSchemaType ( ) const

Obtain a symbolic name for the ion_intensity_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getIonSeries()

const std::string getIonSeries ( const int idx = 0 ) const

Returns a ion_series element object by its number.

In quantitation_1, only a single ions series was permitted. This function returns the first ions series if no index is specified.

Parameters
idx should be in the range 0..getNumberOfIonSeries()-1.
Returns
current element content.

◆ getIonSeriesSchemaType()

std::string getIonSeriesSchemaType ( ) const

Obtain a symbolic name for the ion_series element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMinIonPairs()

int getMinIonPairs ( ) const

Returns the value of the min_ion_pairs attribute.

Specifies whether to exclude fragment ions which have a potential isobaric interferences.

Returns
current value of the min_ion_pairs attribute.

◆ getMinIonPairsSchemaType()

std::string getMinIonPairsSchemaType ( ) const

Obtain a symbolic name for the min_ion_pairs attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfIonSeries()

int getNumberOfIonSeries ( ) const

Returns the number of ions series.

In quantitation_1, only a single ions series was allowed for multiplex.

Returns
the number of ions series specified.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_quant_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_quant_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtualinherited

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

◆ haveExcludeInternalLabel()

bool haveExcludeInternalLabel ( ) const

Indicates presence of the exclude_internal_label attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveExcludeIsobaricFragments()

bool haveExcludeIsobaricFragments ( ) const

Indicates presence of the exclude_isobaric_fragments attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveIonIntensityThreshold()

bool haveIonIntensityThreshold ( ) const

Indicates presence of the ion_intensity_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveIonSeries()

bool haveIonSeries ( ) const

Check for presence of the ion_series element.

In quantitation_1, only a single ions series was allowed for multiplex.

Returns
TRUE if one or more ion series are specified.

◆ haveMinIonPairs()

bool haveMinIonPairs ( ) const

Indicates presence of the min_ion_pairs attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ isExcludeInternalLabel()

bool isExcludeInternalLabel ( ) const

Returns the value of the exclude_internal_label attribute value.

TRUE value means label is allowed at terminus only.

Returns
current value of the exclude_internal_label attribute.

◆ isExcludeIsobaricFragments()

bool isExcludeIsobaricFragments ( ) const

Returns the value of the exclude_isobaric_fragments attribute.

Specifies whether to exclude fragment ions which have a potential isobaric interferences.

Returns
current value of the exclude_isobaric_fragments attribute.

◆ operator=()

ms_quant_multiplex & operator= ( const ms_quant_multiplex & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setExcludeInternalLabel()

void setExcludeInternalLabel ( const bool value )

Set a custom value for the exclude_internal_label attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropExcludeInternalLabel().

Parameters
value a new value for the attribute.

◆ setExcludeIsobaricFragments()

void setExcludeIsobaricFragments ( const bool value )

Set a custom value for the exclude_isobaric_fragments attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropExcludeIsobaricFragments().

Parameters
value a new value for the attribute.

◆ setIonIntensityThreshold()

void setIonIntensityThreshold ( const char * value )

Set a custom value for the ion_intensity_threshold attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropIonIntensityThreshold().

Parameters
value a new value for the attribute.

◆ setIonSeries()

void setIonSeries ( const std::string ionSeries )

Supply custom content for the ion_series element.

Deprecated:
Replaced with appendIonSeries().

In quantitation_1, only a single ions series was allowed for multiplex. This function now clears the list of ions series and replaces the list with a single new value.

Parameters
ionSeries a new content for the element.

◆ setMinIonPairs()

void setMinIonPairs ( const int value )

Set a custom value for the min_ion_pairs attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMinIonPairs().

Parameters
value a new value for the attribute.

◆ updateIonSeries()

bool updateIonSeries | ( | const int | idx,
 |  | const std::string | ionSeries
 | ) |  |

Update the information for a specific ion_series element refering to it by its index.

Parameters
idx | should be in the range 0..getNumberOfIonSeries()-1.
ionSeries | is the new ions series value.
Returns
true if idx is in the correct range.

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_multiplex.hpp
  • ms_quant_multiplex.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_neutralloss Class Reference

  • matrix_science
  • ms_quant_neutralloss
Public Member Functions | List of all members
ms_quant_neutralloss Class Reference
Mascot configuration files module

A neutral loss for the sequence ions, e.g. loss of phosphate. More...

#include <ms_quant_neutralloss.hpp>

Inheritance diagram for ms_quant_neutralloss:
[legend]
Collaboration diagram for ms_quant_neutralloss:
[legend]

Public Member Functions

ms_quant_neutralloss ()
Default constructor.
ms_quant_neutralloss (const ms_quant_neutralloss &src)
Copying constructor.
virtual | ~ms_quant_neutralloss ()
Destructor.
void | appendElement (const ms_quant_element *element)
Adds a new element at the end of the list.
void | clearElements ()
Deletes all elements from the list.
void | copyFrom (const ms_quant_composition *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_neutralloss *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElement (const int idx)
Remove an element from the list.
void | dropFlag ()
Deletes the flag attribute.
const ms_quant_element * | getElement (const int idx) const
Returns an element object by its number.
std::string | getElementSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getFlagSchemaType () const
Obtain a symbolic name for the flag attribute schema type.
int | getNumberOfElements () const
Returns a number of elements held.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveFlag () const
Indicates presence of the flag attribute.
bool | isFlag () const
Returns the value of the flag attribute.
ms_quant_neutralloss & | operator= (const ms_quant_neutralloss &right)
C++ style assignment operator.
void | setFlag (const bool flag)
Set a custom value for the flag attribute.
bool | updateElement (const int idx, const ms_quant_element *element)
Update the information for a specific element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

A neutral loss for the sequence ions, e.g. loss of phosphate.

Constructor & Destructor Documentation

◆ ms_quant_neutralloss() [1/2]

ms_quant_neutralloss ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_neutralloss() [2/2]

ms_quant_neutralloss ( const ms_quant_neutralloss & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendElement()

void appendElement ( const ms_quant_element * element )
inherited

Adds a new element at the end of the list.

Parameters
element an instance of element object to copy content from.

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_composition * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_neutralloss * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteElement()

bool deleteElement ( const int idx )
inherited

Remove an element from the list.

Parameters
idx number of the element for deletion from 0 to (getNumberOfElements() - 1).
Returns
TRUE if the element has been found and successfully deleted and FALSE otherwise.

◆ dropFlag()

void dropFlag ( )

Deletes the flag attribute.

Deletes the attribute until is re-set.

◆ getElement()

const ms_quant_element * getElement ( const int idx ) const
inherited

Returns an element object by its number.

Parameters
idx number of the element from 0 to (getNumberOfElements() - 1).
Returns
a read-only pointer to an element object. See Maintaining object references: two rules of thumb.

◆ getElementSchemaType()

std::string getElementSchemaType ( ) const
inherited

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getFlagSchemaType()

std::string getFlagSchemaType ( ) const

Obtain a symbolic name for the flag attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfElements()

int getNumberOfElements ( ) const
inherited

Returns a number of elements held.

Returns
total number of elements in the list.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_composition.

◆ haveFlag()

bool haveFlag ( ) const

Indicates presence of the flag attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ isFlag()

bool isFlag ( ) const

Returns the value of the flag attribute.

Neutral losses can be potentially a scoring series (FALSE) or non-scoring satellite peaks (TRUE).

Returns
current value of the attribute.

◆ operator=()

ms_quant_neutralloss & operator= ( const ms_quant_neutralloss & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setFlag()

void setFlag ( const bool flag )

Set a custom value for the flag attribute.

Parameters
flag a new value for the attribute.

◆ updateElement()

bool updateElement | ( | const int | idx,
 |  | const ms_quant_element * | element
 | ) |  |
inherited

Update the information for a specific element.

Parameters
idx | number of the element for updating from 0 to (getNumberOfElements() - 1).
element | an object to copy the content from.
Returns
TRUE if the element has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_quant_composition.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_quant_composition.

The documentation for this class was generated from the following files:
  • ms_quant_neutralloss.hpp
  • ms_quant_neutralloss.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_normalisation Class Reference

  • matrix_science
  • ms_quant_normalisation
Public Member Functions | List of all members
ms_quant_normalisation Class Reference
Mascot configuration files module

An object of this class represent a single normalisation element in quantitation.xml. More...

#include <ms_quant_normalisation.hpp>

Inheritance diagram for ms_quant_normalisation:
[legend]
Collaboration diagram for ms_quant_normalisation:
[legend]

Public Member Functions

ms_quant_normalisation ()
Default constructor.
ms_quant_normalisation (const ms_quant_normalisation &src)
Copying constructor.
virtual | ~ms_quant_normalisation ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_normalisation *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropMethod ()
Delete the method attribute.
void | dropPeptides ()
Delete the peptides element.
void | dropProteins ()
Delete the proteins element.
std::string | getMethod () const
Returns the value of the method attribute.
std::string | getMethodSchemaType () const
Obtain a symbolic name for the method attribute schema type.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
const ms_quant_normalisation_peptides * | getPeptides () const
Returns a pointer to the peptides element.
std::string | getPeptidesSchemaType () const
Obtain a symbolic name for the peptides element schema type.
const ms_quant_normalisation_proteins * | getProteins () const
Returns a pointer to the proteins element.
std::string | getProteinsSchemaType () const
Obtain a symbolic name for the proteins element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveMethod () const
Indicates presence of the method attribute.
bool | havePeptides () const
Indicates presence of the peptides element.
bool | haveProteins () const
Indicates presence of the proteins element.
ms_quant_normalisation & | operator= (const ms_quant_normalisation &right)
C++ style assignment operator.
void | setMethod (const char *value)
Set a custom value for the method attribute.
void | setPeptides (const ms_quant_normalisation_peptides *peptides)
Supply custom content for peptides element.
void | setProteins (const ms_quant_normalisation_proteins *proteins)
Supply custom content for the proteins element.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single normalisation element in quantitation.xml.

Method of normalising ratios for a complete data set.

Constructor & Destructor Documentation

◆ ms_quant_normalisation() [1/2]

ms_quant_normalisation ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_normalisation() [2/2]

ms_quant_normalisation ( const ms_quant_normalisation & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendParameter()

void appendParameter ( const ms_quant_parameter * item )
inherited

Adds a new parameter at the end of the list.

Parameters
item an instance of parameter object to copy content from.

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_normalisation * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ dropMethod()

void dropMethod ( )

Delete the method attribute.

Disables the attribute until it is re-set.

◆ dropPeptides()

void dropPeptides ( )

Delete the peptides element.

Deletes the element until it is re-set.

◆ dropProteins()

void dropProteins ( )

Delete the proteins element.

Deletes the element until it is re-set.

◆ getMethod()

std::string getMethod ( ) const

Returns the value of the method attribute.

  • Average: For each ratio, the geometric mean of all reported values for peptide matches is made unity.
  • Median: For each ratio, the median of all reported values for peptide matches is made unity.
  • Sum: (Reporter protocol only) The total intensity of each reporter ion, summed across all MS/MS spectra, is made equal.

Sum is only available for reporter protocol; average and median are only available when all protein hits are processed (i.e. REPORT=AUTO).

Returns
current value of the method attribute.

◆ getMethodSchemaType()

std::string getMethodSchemaType ( ) const

Obtain a symbolic name for the method attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_quant_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_quant_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtualinherited

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

◆ getPeptides()

const ms_quant_normalisation_peptides * getPeptides ( ) const

Returns a pointer to the peptides element.

List of peptide sequences to be used for normalisation.

Returns
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.

◆ getPeptidesSchemaType()

std::string getPeptidesSchemaType ( ) const

Obtain a symbolic name for the peptides element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getProteins()

const ms_quant_normalisation_proteins * getProteins ( ) const

Returns a pointer to the proteins element.

List of protein accessions to be used for normalisation.

Returns
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.

◆ getProteinsSchemaType()

std::string getProteinsSchemaType ( ) const

Obtain a symbolic name for the proteins element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

◆ haveMethod()

bool haveMethod ( ) const

Indicates presence of the method attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ havePeptides()

bool havePeptides ( ) const

Indicates presence of the peptides element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveProteins()

bool haveProteins ( ) const

Indicates presence of the proteins element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ operator=()

ms_quant_normalisation & operator= ( const ms_quant_normalisation & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setMethod()

void setMethod ( const char * value )

Set a custom value for the method attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMethod().

Parameters
value a new value for the attribute.

◆ setPeptides()

void setPeptides ( const ms_quant_normalisation_peptides * peptides )

Supply custom content for peptides element.

Parameters
peptides a new content for the element.

◆ setProteins()

void setProteins ( const ms_quant_normalisation_proteins * proteins )

Supply custom content for the proteins element.

Parameters
proteins a new content for the element.

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_normalisation.hpp
  • ms_quant_normalisation.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_normalisation_peptide Class Reference

  • matrix_science
  • ms_quant_normalisation_peptide
Public Member Functions | List of all members
ms_quant_normalisation_peptide Class Reference
Mascot configuration files module

An object of this class represent a single peptide element in quantitation.xml. More...

#include <ms_quant_normalisation_peptide.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_normalisation_peptide ()
Default constructor.
ms_quant_normalisation_peptide (const ms_quant_normalisation_peptide &src)
Copying constructor.
virtual | ~ms_quant_normalisation_peptide ()
Destructor.
void | copyFrom (const ms_quant_normalisation_peptide *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropSequence ()
Delete the sequence attribute.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSequence () const
Returns the value of the sequence attribute.
std::string | getSequenceSchemaType () const
Obtain a symbolic name for the sequence attribute schema type.
bool | haveSequence () const
Check for presence of the sequence attribute.
ms_quant_normalisation_peptide & | operator= (const ms_quant_normalisation_peptide &right)
C++ style assignment operator.
void | setSequence (const char *value)
Supply custom content for sequence attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single peptide element in quantitation.xml.

Identifies a peptide sequence to be used for normalisation.

Constructor & Destructor Documentation

◆ ms_quant_normalisation_peptide() [1/2]

ms_quant_normalisation_peptide ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_normalisation_peptide() [2/2]

ms_quant_normalisation_peptide ( const ms_quant_normalisation_peptide & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_normalisation_peptide * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropSequence()

void dropSequence ( )

Delete the sequence attribute.

Deletes the attribute until it is re-set.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ getSequence()

std::string getSequence ( ) const

Returns the value of the sequence attribute.

Returns
peptide sequence string.

◆ getSequenceSchemaType()

std::string getSequenceSchemaType ( ) const

Obtain a symbolic name for the sequence attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveSequence()

bool haveSequence ( ) const

Check for presence of the sequence attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_quant_normalisation_peptide & operator= ( const ms_quant_normalisation_peptide & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setSequence()

void setSequence ( const char * value )

Supply custom content for sequence attribute.

Parameters
value a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_normalisation_peptide.hpp
  • ms_quant_normalisation_peptide.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_normalisation_peptides Class Reference

  • matrix_science
  • ms_quant_normalisation_peptides
Public Member Functions | List of all members
ms_quant_normalisation_peptides Class Reference
Mascot configuration files module

An object of this class represent a collection of peptide elements in quantitation.xml. More...

#include <ms_quant_normalisation_peptide.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_normalisation_peptides ()
Default constructor.
ms_quant_normalisation_peptides (const ms_quant_normalisation_peptides &src)
Copying constructor.
virtual | ~ms_quant_normalisation_peptides ()
Destructor.
void | appendPeptide (const ms_quant_normalisation_peptide *pep)
Adds a new peptide element at the end of the list.
void | clearPeptides ()
Deletes all peptide elements from the list.
void | copyFrom (const ms_quant_normalisation_peptides *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deletePeptide (const int idx)
Removes peptide element from the list.
int | getNumberOfPeptides () const
Returns the number of nested peptide elements.
const ms_quant_normalisation_peptide * | getPeptide (const int idx) const
Returns the value of the peptide element object by its number.
std::string | getPeptideSchemaType () const
Obtain a symbolic name for the peptide element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_quant_normalisation_peptides & | operator= (const ms_quant_normalisation_peptides &right)
C++ style assignment operator.
bool | updatePeptide (const int idx, const ms_quant_normalisation_peptide *pep)
Supply new content for one of the peptide elements in the list.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a collection of peptide elements in quantitation.xml.

Constructor & Destructor Documentation

◆ ms_quant_normalisation_peptides() [1/2]

ms_quant_normalisation_peptides ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_normalisation_peptides() [2/2]

ms_quant_normalisation_peptides ( const ms_quant_normalisation_peptides & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendPeptide()

void appendPeptide ( const ms_quant_normalisation_peptide * pep )

Adds a new peptide element at the end of the list.

Parameters
pep a new element to be added to the list.

◆ copyFrom()

void copyFrom ( const ms_quant_normalisation_peptides * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deletePeptide()

bool deletePeptide ( const int idx )

Removes peptide element from the list.

Parameters
idx a zero based index of the peptide element to delete from the list.
Returns
true if the index is in range, false otherwise

◆ getNumberOfPeptides()

int getNumberOfPeptides ( ) const

Returns the number of nested peptide elements.

Returns
total number of nested peptide elements.

◆ getPeptide()

const ms_quant_normalisation_peptide * getPeptide ( const int idx ) const

Returns the value of the peptide element object by its number.

Parameters
idx a zero based index of the element to retrieve.
Returns
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.

◆ getPeptideSchemaType()

std::string getPeptideSchemaType ( ) const

Obtain a symbolic name for the peptide element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ operator=()

ms_quant_normalisation_peptides & operator= ( const ms_quant_normalisation_peptides & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ updatePeptide()

bool updatePeptide | ( | const int | idx,
 |  | const ms_quant_normalisation_peptide * | pep
 | ) |  |

Supply new content for one of the peptide elements in the list.

Parameters
idx | a zero based index of the element to update.
pep | a source to copy the content from.
Returns
TRUE if the element has been successfully updated.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_normalisation_peptide.hpp
  • ms_quant_normalisation_peptide.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_normalisation_protein Class Reference

  • matrix_science
  • ms_quant_normalisation_protein
Public Member Functions | List of all members
ms_quant_normalisation_protein Class Reference
Mascot configuration files module

An object of this class represent a single protein element in quantitation.xml. More...

#include <ms_quant_normalisation_protein.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_normalisation_protein ()
Default constructor.
ms_quant_normalisation_protein (const ms_quant_normalisation_protein &src)
Copying constructor.
virtual | ~ms_quant_normalisation_protein ()
Destructor.
void | copyFrom (const ms_quant_normalisation_protein *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropAccession ()
Delete the accession attribute.
std::string | getAccession () const
Returns the value of the accession attribute.
std::string | getAccessionSchemaType () const
Obtain a symbolic name for the accession attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveAccession () const
Check for presence of the accession attribute.
ms_quant_normalisation_protein & | operator= (const ms_quant_normalisation_protein &right)
C++ style assignment operator.
void | setAccession (const char *value)
Supply a custom content for accession attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single protein element in quantitation.xml.

Identifies a protein to be used for normalisation.

Constructor & Destructor Documentation

◆ ms_quant_normalisation_protein() [1/2]

ms_quant_normalisation_protein ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_normalisation_protein() [2/2]

ms_quant_normalisation_protein ( const ms_quant_normalisation_protein & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_normalisation_protein * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropAccession()

void dropAccession ( )

Delete the accession attribute.

Deletes the attribute until it is re-set.

◆ getAccession()

std::string getAccession ( ) const

Returns the value of the accession attribute.

Returns
protein accession string.

◆ getAccessionSchemaType()

std::string getAccessionSchemaType ( ) const

Obtain a symbolic name for the accession attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ haveAccession()

bool haveAccession ( ) const

Check for presence of the accession attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_quant_normalisation_protein & operator= ( const ms_quant_normalisation_protein & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAccession()

void setAccession ( const char * value )

Supply a custom content for accession attribute.

Parameters
value a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_normalisation_protein.hpp
  • ms_quant_normalisation_protein.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_normalisation_proteins Class Reference

  • matrix_science
  • ms_quant_normalisation_proteins
Public Member Functions | List of all members
ms_quant_normalisation_proteins Class Reference
Mascot configuration files module

An object of this class represent a collection of peptide elements in quantitation.xml. More...

#include <ms_quant_normalisation_protein.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_normalisation_proteins ()
Default constructor.
ms_quant_normalisation_proteins (const ms_quant_normalisation_proteins &src)
Copying constructor.
virtual | ~ms_quant_normalisation_proteins ()
Destructor.
void | appendProtein (const ms_quant_normalisation_protein *protein)
Adds a new protein element at the end of the list.
void | clearProteins ()
Deletes all protein elements from the list.
void | copyFrom (const ms_quant_normalisation_proteins *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteProtein (const int idx)
Removes a protein element from the list.
int | getNumberOfProteins () const
Returns a number of nested protein elements.
const ms_quant_normalisation_protein * | getProtein (const int idx) const
Returns the value of the protein element object by its number.
std::string | getProteinSchemaType () const
Obtain a symbolic name for the protein element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_quant_normalisation_proteins & | operator= (const ms_quant_normalisation_proteins &right)
C++ style assignment operator.
bool | updateProtein (const int idx, const ms_quant_normalisation_protein *protein)
Supply new content for one of the protein elements in the list.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a collection of peptide elements in quantitation.xml.

Constructor & Destructor Documentation

◆ ms_quant_normalisation_proteins() [1/2]

ms_quant_normalisation_proteins ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_normalisation_proteins() [2/2]

ms_quant_normalisation_proteins ( const ms_quant_normalisation_proteins & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendProtein()

void appendProtein ( const ms_quant_normalisation_protein * protein )

Adds a new protein element at the end of the list.

Parameters
protein a new element to be added to the list.

◆ copyFrom()

void copyFrom ( const ms_quant_normalisation_proteins * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteProtein()

bool deleteProtein ( const int idx )

Removes a protein element from the list.

Parameters
idx a zero based index of the protein element to delete from the list.
Returns
true if the index is in range, false otherwise

◆ getNumberOfProteins()

int getNumberOfProteins ( ) const

Returns a number of nested protein elements.

Returns
total number of nested protein elements.

◆ getProtein()

const ms_quant_normalisation_protein * getProtein ( const int idx ) const

Returns the value of the protein element object by its number.

Parameters
idx a zero based index of the element to retrieve.
Returns
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.

◆ getProteinSchemaType()

std::string getProteinSchemaType ( ) const

Obtain a symbolic name for the protein element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ operator=()

ms_quant_normalisation_proteins & operator= ( const ms_quant_normalisation_proteins & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ updateProtein()

bool updateProtein | ( | const int | idx,
 |  | const ms_quant_normalisation_protein * | protein
 | ) |  |

Supply new content for one of the protein elements in the list.

Parameters
idx | a zero based index of the element to update.
protein | a source to copy the content from.
Returns
TRUE if the element has been successfully updated.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_normalisation_protein.hpp
  • ms_quant_normalisation_protein.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_numerator Class Reference

  • matrix_science
  • ms_quant_numerator
Public Member Functions | List of all members
ms_quant_numerator Class Reference
Mascot configuration files module

Represent numerator_component and denominator_component elements. More...

#include <ms_quant_numerator.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_numerator ()
Default constructor.
ms_quant_numerator (const ms_quant_numerator &src)
Copying constructor.
virtual | ~ms_quant_numerator ()
Destructor.
void | copyFrom (const ms_quant_numerator *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropCoefficient ()
Delete the coefficient attribute.
void | dropName ()
Delete the name attribute.
std::string | getCoefficient () const
Returns the value of the coefficient attribute.
std::string | getCoefficientSchemaType () const
Obtain a symbolic name for the coefficient attribute schema type.
std::string | getContent () const
Returns string value of the element.
std::string | getContentSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveCoefficient () const
Indicates presence of the coefficient attribute.
bool | haveName () const
Indicates presence of the name attribute.
ms_quant_numerator & | operator= (const ms_quant_numerator &right)
C++ style assignment operator.
void | setCoefficient (const char *value)
Set a custom value for the coefficient attribute.
void | setContent (const char *value)
Set a custom value for the the element.
void | setName (const char *value)
Set a custom value for the name attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represent numerator_component and denominator_component elements.

Constructor & Destructor Documentation

◆ ms_quant_numerator() [1/2]

ms_quant_numerator ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_numerator() [2/2]

ms_quant_numerator ( const ms_quant_numerator & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_numerator * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropCoefficient()

void dropCoefficient ( )

Delete the coefficient attribute.

Deletes the attribute until is re-set.

◆ dropName()

void dropName ( )

Delete the name attribute.

Deletes the attribute until is re-set.

◆ getCoefficient()

std::string getCoefficient ( ) const

Returns the value of the coefficient attribute.

Returns
coefficient used to form linear combination of values.

◆ getCoefficientSchemaType()

std::string getCoefficientSchemaType ( ) const

Obtain a symbolic name for the coefficient attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getContent()

std::string getContent ( ) const

Returns string value of the element.

Returns
string value of the element content.

◆ getContentSchemaType()

std::string getContentSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNameSchemaType()

std::string getNameSchemaType ( ) const

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ haveCoefficient()

bool haveCoefficient ( ) const

Indicates presence of the coefficient attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveName()

bool haveName ( ) const

Indicates presence of the name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_quant_numerator & operator= ( const ms_quant_numerator & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setCoefficient()

void setCoefficient ( const char * value )

Set a custom value for the coefficient attribute.

Parameters
value a new value for the attribute.

◆ setContent()

void setContent ( const char * value )

Set a custom value for the the element.

Parameters
value a new string value for the content.

◆ setName()

void setName ( const char * value )

Set a custom value for the name attribute.

Parameters
value a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_numerator.hpp
  • ms_quant_numerator.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_outliers Class Reference

  • matrix_science
  • ms_quant_outliers
Public Member Functions | List of all members
ms_quant_outliers Class Reference
Mascot configuration files module

An object of this class represent a single OUTLIERS element in quantitation.xml. More...

#include <ms_quant_outliers.hpp>

Inheritance diagram for ms_quant_outliers:
[legend]
Collaboration diagram for ms_quant_outliers:
[legend]

Public Member Functions

ms_quant_outliers ()
Default constructor.
ms_quant_outliers (const ms_quant_outliers &src)
Copying constructor.
virtual | ~ms_quant_outliers ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_outliers *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropMethod ()
Delete the method attribute.
std::string | getMethod () const
Returns the value of the method attribute.
std::string | getMethodSchemaType () const
Obtain a symbolic name for the method attribute schema type.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveMethod () const
Indicates presence of the method attribute.
ms_quant_outliers & | operator= (const ms_quant_outliers &right)
C++ style assignment operator.
void | setMethod (const char *value)
Set a custom value for the method attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single OUTLIERS element in quantitation.xml.

Method and parameters to be used to remove outliers. If missing, no outlier removal is performed.

Constructor & Destructor Documentation

◆ ms_quant_outliers() [1/2]

ms_quant_outliers ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_outliers() [2/2]

ms_quant_outliers ( const ms_quant_outliers & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendParameter()

void appendParameter ( const ms_quant_parameter * item )
inherited

Adds a new parameter at the end of the list.

Parameters
item an instance of parameter object to copy content from.

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_outliers * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ dropMethod()

void dropMethod ( )

Delete the method attribute.

Disables the attribute until it is re-set.

◆ getMethod()

std::string getMethod ( ) const

Returns the value of the method attribute.

The method attribute specifies the outlier detection algorithm.

Returns
current value of the method attribute.

◆ getMethodSchemaType()

std::string getMethodSchemaType ( ) const

Obtain a symbolic name for the method attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_quant_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_quant_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtualinherited

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

◆ haveMethod()

bool haveMethod ( ) const

Indicates presence of the method attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ operator=()

ms_quant_outliers & operator= ( const ms_quant_outliers & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setMethod()

void setMethod ( const char * value )

Set a custom value for the method attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMethod().

Parameters
value a new value for the attribute.

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_outliers.hpp
  • ms_quant_outliers.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_parameter Class Reference

  • matrix_science
  • ms_quant_parameter
Public Member Functions | List of all members
ms_quant_parameter Class Reference
Mascot configuration files module

Parameter name and value pair. More...

#include <ms_quant_parameters.hpp>

Inheritance diagram for ms_quant_parameter:
[legend]
Collaboration diagram for ms_quant_parameter:
[legend]

Public Member Functions

ms_quant_parameter ()
Default constructor.
ms_quant_parameter (const ms_quant_parameter &src)
Copying constructor.
virtual | ~ms_quant_parameter ()
Destructor.
void | copyFrom (const ms_quant_parameter *right)
Copies all content from another instance.
void | copyFrom (const ms_xml_parameter *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropDescription ()
Delete the description attribute.
void | dropName ()
Delete the name attribute.
std::string | getDescription () const
Returns the value of the description attribute.
virtual std::string | getDescriptionSchemaType () const
Obtain a symbolic name for the description attribute schema type.
std::string | getName () const
Returns the value of the name attribute.
virtual std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getValue () const
Returns the value of the value attribute.
virtual std::string | getValueSchemaType () const
Obtain a symbolic name for the value attribute schema type.
bool | haveDescription () const
Indicates presence of the description attribute.
bool | haveName () const
Indicates presence of the name attribute.
ms_quant_parameter & | operator= (const ms_quant_parameter &right)
C++ style assignment operator.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setValue (const char *value)
Set a custom value for the value attribute.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Parameter name and value pair.

Constructor & Destructor Documentation

◆ ms_quant_parameter() [1/2]

ms_quant_parameter ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_parameter() [2/2]

ms_quant_parameter ( const ms_quant_parameter & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_parameter * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_xml_parameter * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )
inherited

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropDescription()

void dropDescription ( )
inherited

Delete the description attribute.

Deletes the attribute until is re-set.

◆ dropName()

void dropName ( )
inherited

Delete the name attribute.

Deletes the attribute until is re-set.

◆ getDescription()

std::string getDescription ( ) const
inherited

Returns the value of the description attribute.

Returns
a free text description of this parameter.

◆ getDescriptionSchemaType()

std::string getDescriptionSchemaType ( ) const
virtual

Obtain a symbolic name for the description attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameter.

◆ getName()

std::string getName ( ) const
inherited

Returns the value of the name attribute.

Returns
a descriptive name that will appear in drop down lists, etc.

◆ getNameSchemaType()

std::string getNameSchemaType ( ) const
virtual

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameter.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Implements ms_xml_parameter.

◆ getValue()

std::string getValue ( ) const
inherited

Returns the value of the value attribute.

Returns
a string value of this parameter.

◆ getValueSchemaType()

std::string getValueSchemaType ( ) const
virtual

Obtain a symbolic name for the value attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameter.

◆ haveDescription()

bool haveDescription ( ) const
inherited

Indicates presence of the description attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveName()

bool haveName ( ) const
inherited

Indicates presence of the name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_quant_parameter & operator= ( const ms_quant_parameter & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setDescription()

void setDescription ( const char * value )
inherited

Set a custom value for the description attribute.

Parameters
value a new value for the attribute.

◆ setName()

void setName ( const char * value )
inherited

Set a custom value for the name attribute.

Parameters
value a new value for the attribute.

◆ setValue()

void setValue ( const char * value )
inherited

Set a custom value for the value attribute.

Parameters
value a new string value for the parameter.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_parameters.hpp
  • ms_quant_parameters.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_parameters Class Reference

  • matrix_science
  • ms_quant_parameters
Public Member Functions | List of all members
ms_quant_parameters Class Reference
Mascot configuration files module

A class that represents base parametersType in quantitation.xml. More...

#include <ms_quant_parameters.hpp>

Inheritance diagram for ms_quant_parameters:
[legend]
Collaboration diagram for ms_quant_parameters:
[legend]

Public Member Functions

ms_quant_parameters ()
Default constructor.
ms_quant_parameters (const ms_quant_parameters &src)
Copying constructor.
virtual | ~ms_quant_parameters ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_quant_parameters & | operator= (const ms_quant_parameters &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

A class that represents base parametersType in quantitation.xml.

Holds a list of parameters.

Constructor & Destructor Documentation

◆ ms_quant_parameters() [1/2]

ms_quant_parameters ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_parameters() [2/2]

ms_quant_parameters ( const ms_quant_parameters & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendParameter()

void appendParameter ( const ms_quant_parameter * item )

Adds a new parameter at the end of the list.

Parameters
item an instance of parameter object to copy content from.

◆ copyFrom()

void copyFrom ( const ms_quant_parameters * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtual

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtual

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtual

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_quant_parameter * getParameterByName ( const char * name ) const

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_quant_parameter * getParameterByNumber ( const int idx ) const

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtual

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Implements ms_xml_parameters.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

◆ operator=()

ms_quant_parameters & operator= ( const ms_quant_parameters & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
inherited

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_parameters.hpp
  • ms_quant_parameters.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_pepneutralloss Class Reference

  • matrix_science
  • ms_quant_pepneutralloss
Public Member Functions | List of all members
ms_quant_pepneutralloss Class Reference
Mascot configuration files module

A neutral loss from the precursor. More...

#include <ms_quant_pepneutralloss.hpp>

Inheritance diagram for ms_quant_pepneutralloss:
[legend]
Collaboration diagram for ms_quant_pepneutralloss:
[legend]

Public Member Functions

ms_quant_pepneutralloss ()
Default constructor.
ms_quant_pepneutralloss (const ms_quant_pepneutralloss &src)
Copying constructor.
virtual | ~ms_quant_pepneutralloss ()
Destructor.
void | appendElement (const ms_quant_element *element)
Adds a new element at the end of the list.
void | clearElements ()
Deletes all elements from the list.
void | copyFrom (const ms_quant_composition *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_pepneutralloss *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElement (const int idx)
Remove an element from the list.
void | dropRequired ()
Deletes the required attribute.
const ms_quant_element * | getElement (const int idx) const
Returns an element object by its number.
std::string | getElementSchemaType () const
Obtain a symbolic name for the element's schema type.
int | getNumberOfElements () const
Returns a number of elements held.
std::string | getRequiredSchemaType () const
Obtain a symbolic name for the required attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveRequired () const
Indicates presence of the required attribute.
bool | isRequired () const
Returns the value of the required attribute.
ms_quant_pepneutralloss & | operator= (const ms_quant_pepneutralloss &right)
C++ style assignment operator.
void | setRequired (const bool required)
Set a custom value for the required attribute.
bool | updateElement (const int idx, const ms_quant_element *element)
Update the information for a specific element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

A neutral loss from the precursor.

Constructor & Destructor Documentation

◆ ms_quant_pepneutralloss() [1/2]

ms_quant_pepneutralloss ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_pepneutralloss() [2/2]

ms_quant_pepneutralloss ( const ms_quant_pepneutralloss & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendElement()

void appendElement ( const ms_quant_element * element )
inherited

Adds a new element at the end of the list.

Parameters
element an instance of element object to copy content from.

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_composition * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_pepneutralloss * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteElement()

bool deleteElement ( const int idx )
inherited

Remove an element from the list.

Parameters
idx number of the element for deletion from 0 to (getNumberOfElements() - 1).
Returns
TRUE if the element has been found and successfully deleted and FALSE otherwise.

◆ dropRequired()

void dropRequired ( )

Deletes the required attribute.

Deletes the attribute until is re-set.

◆ getElement()

const ms_quant_element * getElement ( const int idx ) const
inherited

Returns an element object by its number.

Parameters
idx number of the element from 0 to (getNumberOfElements() - 1).
Returns
a read-only pointer to an element object. See Maintaining object references: two rules of thumb.

◆ getElementSchemaType()

std::string getElementSchemaType ( ) const
inherited

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfElements()

int getNumberOfElements ( ) const
inherited

Returns a number of elements held.

Returns
total number of elements in the list.

◆ getRequiredSchemaType()

std::string getRequiredSchemaType ( ) const

Obtain a symbolic name for the required attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_composition.

◆ haveRequired()

bool haveRequired ( ) const

Indicates presence of the required attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ isRequired()

bool isRequired ( ) const

Returns the value of the required attribute.

TRUE if this is a required neutral loss.

Returns
current value of the attribute.

◆ operator=()

ms_quant_pepneutralloss & operator= ( const ms_quant_pepneutralloss & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setRequired()

void setRequired ( const bool required )

Set a custom value for the required attribute.

Parameters
required a new value for the attribute.

◆ updateElement()

bool updateElement | ( | const int | idx,
 |  | const ms_quant_element * | element
 | ) |  |
inherited

Update the information for a specific element.

Parameters
idx | number of the element for updating from 0 to (getNumberOfElements() - 1).
element | an object to copy the content from.
Returns
TRUE if the element has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_quant_composition.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_quant_composition.

The documentation for this class was generated from the following files:
  • ms_quant_pepneutralloss.hpp
  • ms_quant_pepneutralloss.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_precursor Class Reference

  • matrix_science
  • ms_quant_precursor
Public Member Functions | List of all members
ms_quant_precursor Class Reference
Mascot configuration files module

An object of this class represent a single precursor element in quantitation.xml. More...

#include <ms_quant_precursor.hpp>

Inheritance diagram for ms_quant_precursor:
[legend]
Collaboration diagram for ms_quant_precursor:
[legend]

Public Member Functions

ms_quant_precursor ()
Default constructor.
ms_quant_precursor (const ms_quant_precursor &src)
Copying constructor.
virtual | ~ms_quant_precursor ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_precursor *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropAllChargeStates ()
void | dropAllowElutionShift ()
void | dropAllowMassTimeMatch ()
Delete the allow_mass_time_match attribute.
std::string | getAllChargeStatesSchemaType () const
std::string | getAllowElutionShiftSchemaType () const
std::string | getAllowMassTimeMatchSchemaType () const
Obtain a symbolic name for the allow_mass_time_match attribute schema type.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveAllChargeStates () const
bool | haveAllowElutionShift () const
bool | haveAllowMassTimeMatch () const
Indicates presence of the allow_mass_time_match attribute.
bool | isAllChargeStates () const
bool | isAllowElutionShift () const
bool | isAllowMassTimeMatch () const
Returns the value of the allow_mass_time_match attribute.
ms_quant_precursor & | operator= (const ms_quant_precursor &right)
C++ style assignment operator.
void | setAllowMassTimeMatch (const bool value)
Set a custom value for the allow_mass_time_match attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single precursor element in quantitation.xml.

Serves as a possible sub-element of "protocol" element

Constructor & Destructor Documentation

◆ ms_quant_precursor() [1/2]

ms_quant_precursor ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_precursor() [2/2]

ms_quant_precursor ( const ms_quant_precursor & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendParameter()

void appendParameter ( const ms_quant_parameter * item )
inherited

Adds a new parameter at the end of the list.

Parameters
item an instance of parameter object to copy content from.

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_precursor * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ dropAllChargeStates()

void dropAllChargeStates ( )
Deprecated:
Moved to ms_quant_integration.

This function is no longer available in Parser 2.3 See ms_quant_integration::setAllChargeStates(). param value new value

Deprecated:
Moved to ms_quant_integration.

◆ dropAllowElutionShift()

void dropAllowElutionShift ( )
Deprecated:
Moved to ms_quant_integration.

This function is no longer available in Parser 2.3 See ms_quant_integration::setAllowElutionShift(). param value new value

Deprecated:
Moved to ms_quant_integration.

◆ dropAllowMassTimeMatch()

void dropAllowMassTimeMatch ( )

Delete the allow_mass_time_match attribute.

Disables the attribute until it is re-set.

◆ getAllChargeStatesSchemaType()

std::string getAllChargeStatesSchemaType ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns
all charge states schema type

◆ getAllowElutionShiftSchemaType()

std::string getAllowElutionShiftSchemaType ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns
allow elution shift schema type

◆ getAllowMassTimeMatchSchemaType()

std::string getAllowMassTimeMatchSchemaType ( ) const

Obtain a symbolic name for the allow_mass_time_match attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_quant_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_quant_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtualinherited

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

◆ haveAllChargeStates()

bool haveAllChargeStates ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns
true if all charge states is set, false otherwise

◆ haveAllowElutionShift()

bool haveAllowElutionShift ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns
true if allow elution shift is set, false otherwise

◆ haveAllowMassTimeMatch()

bool haveAllowMassTimeMatch ( ) const

Indicates presence of the allow_mass_time_match attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ isAllChargeStates()

bool isAllChargeStates ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns
true if all charge states is set, false otherwise

◆ isAllowElutionShift()

bool isAllowElutionShift ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns
true if allow elution shift is set, false otherwise

◆ isAllowMassTimeMatch()

bool isAllowMassTimeMatch ( ) const

Returns the value of the allow_mass_time_match attribute.

If false, we only report a ratio if we have peptide matches to both components. Also, if false, then all_charge_states treated as false, even if true in method. Almost always set true in practice.

Returns
TRUE/FALSE.

◆ operator=()

ms_quant_precursor & operator= ( const ms_quant_precursor & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAllowMassTimeMatch()

void setAllowMassTimeMatch ( const bool value )

Set a custom value for the allow_mass_time_match attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropAllowMassTimeMatch().

Parameters
value a new value for the attribute.

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_precursor.hpp
  • ms_quant_precursor.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_protocol Class Reference

  • matrix_science
  • ms_quant_protocol
Public Member Functions | List of all members
ms_quant_protocol Class Reference
Mascot configuration files module

An object of this class represent a protocol element in quantitation.xml. More...

#include <ms_quant_protocol.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_protocol ()
Default constructor.
ms_quant_protocol (const ms_quant_protocol &src)
Copying constructor.
virtual | ~ms_quant_protocol ()
Destructor.
void | copyFrom (const ms_quant_protocol *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
const ms_quant_average * | getAverage () const
Returns the average element or a null value if not available.
std::string | getAverageSchemaType () const
Obtain a symbolic name for the average element schema type.
const ms_quant_multiplex * | getMultiplex () const
Returns the multiplex element or a null value if not available.
std::string | getMultiplexSchemaType () const
Obtain a symbolic name for the multiplex element schema type.
const ms_quant_precursor * | getPrecursor () const
Returns the precursor element or a null value if not available.
std::string | getPrecursorSchemaType () const
Obtain a symbolic name for the precursor element schema type.
const ms_quant_replicate * | getReplicate () const
Returns the replicate element or a null value if not available.
std::string | getReplicateSchemaType () const
Obtain a symbolic name for the replicate element schema type.
const ms_quant_reporter * | getReporter () const
Returns the reporter element or a null value if not available.
std::string | getReporterSchemaType () const
Obtain a symbolic name for the reporter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getType () const
Call this method first to determine which sub element to retrieve.
ms_quant_protocol & | operator= (const ms_quant_protocol &right)
C++ style assignment operator.
void | setAverage (const ms_quant_average *average)
Override content with another average element.
void | setMultiplex (const ms_quant_multiplex *multiplex)
Override content with another multiplex element.
void | setNull ()
Sets content of the protocol element to a null value and deletes all previously held information.
void | setPrecursor (const ms_quant_precursor *precursor)
Override content with another precursor element.
void | setReplicate (const ms_quant_replicate *replicate)
Override content with another replicate element.
void | setReporter (const ms_quant_reporter *reporter)
Override content with another reporter element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a protocol element in quantitation.xml.

6 different protocols are currently supported, and an object of this class is a container for exactly one of those protocols. The getType() function returns a string which contains the protocol for the current quantitation method. Use the return value from it to determine which of the functions to call to get further protocol details.

Constructor & Destructor Documentation

◆ ms_quant_protocol()

ms_quant_protocol ( const ms_quant_protocol & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_protocol * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ getAverage()

const ms_quant_average * getAverage ( ) const

Returns the average element or a null value if not available.

Call this method only if getType() returns average.

Returns
an average element object. See Maintaining object references: two rules of thumb.

◆ getAverageSchemaType()

std::string getAverageSchemaType ( ) const

Obtain a symbolic name for the average element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMultiplex()

const ms_quant_multiplex * getMultiplex ( ) const

Returns the multiplex element or a null value if not available.

Call this method only if getType() returns "multiplex".

Returns
a multiplex element object. See Maintaining object references: two rules of thumb.

◆ getMultiplexSchemaType()

std::string getMultiplexSchemaType ( ) const

Obtain a symbolic name for the multiplex element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getPrecursor()

const ms_quant_precursor * getPrecursor ( ) const

Returns the precursor element or a null value if not available.

Call this method only if getType() returns "precursor".

Returns
a precursor element object. See Maintaining object references: two rules of thumb.

◆ getPrecursorSchemaType()

std::string getPrecursorSchemaType ( ) const

Obtain a symbolic name for the precursor element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getReplicate()

const ms_quant_replicate * getReplicate ( ) const

Returns the replicate element or a null value if not available.

Call this method only if getType() returns "replicate".

Returns
a replicate element object. See Maintaining object references: two rules of thumb.

◆ getReplicateSchemaType()

std::string getReplicateSchemaType ( ) const

Obtain a symbolic name for the replicate element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getReporter()

const ms_quant_reporter * getReporter ( ) const

Returns the reporter element or a null value if not available.

Call this method only if getType() returns "reporter".

Returns
a reporter element object. See Maintaining object references: two rules of thumb.

◆ getReporterSchemaType()

std::string getReporterSchemaType ( ) const

Obtain a symbolic name for the reporter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ getType()

std::string getType ( ) const

Call this method first to determine which sub element to retrieve.

This table describes possible return values and which function to then call.

String returned | Function to call required
reporter | getReporter()
average | getAverage()
precursor | getPrecursor()
multiplex | getMultiplex()
replicate | getReplicate()
null | Indicates that the object is not initialised

If, for example, getReporter() is called when the return value from this function is "average", then a null value will be returned.

Calling one of the setXXX()-methods will change the protocol type returned by this method.

Returns
type of the protocol.

◆ operator=()

ms_quant_protocol & operator= ( const ms_quant_protocol & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAverage()

void setAverage ( const ms_quant_average * average )

Override content with another average element.

Calling this method with a null value as a parameter will set the protocol type to "null".

Parameters
average a new value for the average element.

◆ setMultiplex()

void setMultiplex ( const ms_quant_multiplex * multiplex )

Override content with another multiplex element.

Calling this method with a null value as a parameter will set the protocol type to "null".

Parameters
multiplex a new value for the multiplex element.

◆ setNull()

void setNull ( )

Sets content of the protocol element to a null value and deletes all previously held information.

Call this to clear the content and set sub-element as "null".

◆ setPrecursor()

void setPrecursor ( const ms_quant_precursor * precursor )

Override content with another precursor element.

Calling this method with a null value as a parameter will set the protocol type to "null".

Parameters
precursor a new value for the precursor element.

◆ setReplicate()

void setReplicate ( const ms_quant_replicate * replicate )

Override content with another replicate element.

Calling this method with a null value as a parameter will set the protocol type to "null".

Parameters
replicate a new value for the replicate element.

◆ setReporter()

void setReporter ( const ms_quant_reporter * reporter )

Override content with another reporter element.

Calling this method with a null value as a parameter will set the protocol type to "null"

Parameters
reporter a new value for the reporter element.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_protocol.hpp
  • ms_quant_protocol.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_quality Class Reference

  • matrix_science
  • ms_quant_quality
Public Member Functions | List of all members
ms_quant_quality Class Reference
Mascot configuration files module

An object of this class represent a single quality element in quantitation.xml. More...

#include <ms_quant_quality.hpp>

Inheritance diagram for ms_quant_quality:
[legend]
Collaboration diagram for ms_quant_quality:
[legend]

Public Member Functions

ms_quant_quality ()
Default constructor.
ms_quant_quality (const ms_quant_quality &src)
Copying constructor.
virtual | ~ms_quant_quality ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_quality *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropIsolatedPrecursor ()
Delete the isolated_precursor attribute.
void | dropIsolatedPrecursorThreshold ()
Delete the isolated_precursor_threshold attribute.
void | dropMinimumA1 ()
Delete the minimum_a1 attribute.
void | dropMinPrecursorCharge ()
Delete the min_precursor_charge attribute.
void | dropPepThresholdType ()
Delete the pep_threshold_type attribute.
void | dropPepThresholdValue ()
Delete the pep_threshold_value attribute.
void | dropTotalIntensity ()
Delete the total_intensity attribute.
void | dropTotalIntensityThreshold ()
Delete the total_intensity_threshold attribute.
void | dropUniquePepseq ()
Delete the unique_pepseq attribute.
std::string | getIsolatedPrecursorSchemaType () const
Obtain a symbolic name for the isolated_precursor attribute schema type.
std::string | getIsolatedPrecursorThreshold () const
Returns the value of the isolated_precursor_threshold attribute.
std::string | getIsolatedPrecursorThresholdSchemaType () const
Obtain a symbolic name for the isolated_precursor_threshold attribute schema type.
std::string | getMinimumA1 () const
Returns the value of the minimum_a1 attribute.
std::string | getMinimumA1SchemaType () const
Obtain a symbolic name for the minimum_a1 attribute schema type.
int | getMinPrecursorCharge () const
Returns the value of the min_precursor_charge attribute.
std::string | getMinPrecursorChargeSchemaType () const
Obtain a symbolic name for the min_precursor_charge attribute schema type.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
std::string | getPepThresholdType () const
Returns the value of the pep_threshold_type attribute.
std::string | getPepThresholdTypeSchemaType () const
Obtain a symbolic name for the pep_threshold_type attribute schema type.
std::string | getPepThresholdValue () const
Returns the value of the pep_threshold_value attribute.
std::string | getPepThresholdValueSchemaType () const
Obtain a symbolic name for the "pep_threshold_value" schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getTotalIntensitySchemaType () const
Obtain a symbolic name for the total_intensity attribute schema type.
std::string | getTotalIntensityThreshold () const
Returns the value of the total_intensity_threshold attribute.
std::string | getTotalIntensityThresholdSchemaType () const
Obtain a symbolic name for the total_intensity_threshold attribute schema type.
std::string | getUniquePepseqSchemaType () const
Obtain a symbolic name for the unique_pepseq attribute schema type.
bool | haveIsolatedPrecursor () const
Indicates presence of the isolated_precursor attribute.
bool | haveIsolatedPrecursorThreshold () const
Indicates presence of the isolated_precursor_threshold attribute.
bool | haveMinimumA1 () const
Indicates presence of the minimum_a1 attribute.
bool | haveMinPrecursorCharge () const
Indicates presence of the min_precursor_charge attribute.
bool | havePepThresholdType () const
Indicates presence of the pep_threshold_type attribute.
bool | havePepThresholdValue () const
Indicates presence of the pep_threshold_value attribute.
bool | haveTotalIntensity () const
Indicates presence of the total_intensity attribute.
bool | haveTotalIntensityThreshold () const
Indicates presence of the total_intensity_threshold attribute.
bool | haveUniquePepseq () const
Indicates presence of the unique_pepseq attribute.
bool | isIsolatedPrecursor () const
Returns the value of the isolated_precursor attribute.
bool | isTotalIntensity () const
Returns the value of the total_intensity attribute.
bool | isUniquePepseq () const
Returns the value of the unique_pepseq attribute.
ms_quant_quality & | operator= (const ms_quant_quality &right)
C++ style assignment operator.
void | setIsolatedPrecursor (const bool value)
Set a custom value for the isolated_precursor attribute.
void | setIsolatedPrecursorThreshold (const char *value)
Set a custom value for the isolated_precursor_threshold attribute.
void | setMinimumA1 (const char *value)
Set a custom value for the minimum_a1 attribute.
void | setMinPrecursorCharge (const int value)
Set a custom value for the min_precursor_charge attribute.
void | setPepThresholdType (const char *value)
Set a custom value for the pep_threshold_type attribute.
void | setPepThresholdValue (const char *value)
Set a custom value for the pep_threshold_value attribute.
void | setTotalIntensity (bool value)
Set a custom value for the total_intensity attribute.
void | setTotalIntensityThreshold (std::string value)
Set a custom value for the total_intensity_threshold attribute.
void | setUniquePepseq (bool value)
Set a custom value for the unique_pepseq attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single quality element in quantitation.xml.

Constructor & Destructor Documentation

◆ ms_quant_quality() [1/2]

ms_quant_quality ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_quality() [2/2]

ms_quant_quality ( const ms_quant_quality & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendParameter()

void appendParameter ( const ms_quant_parameter * item )
inherited

Adds a new parameter at the end of the list.

Parameters
item an instance of parameter object to copy content from.

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_quality * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ dropIsolatedPrecursor()

void dropIsolatedPrecursor ( )

Delete the isolated_precursor attribute.

Disables the attribute until it is re-set.

◆ dropIsolatedPrecursorThreshold()

void dropIsolatedPrecursorThreshold ( )

Delete the isolated_precursor_threshold attribute.

Disables the attribute until it is re-set.

◆ dropMinimumA1()

void dropMinimumA1 ( )

Delete the minimum_a1 attribute.

Disables the attribute until it is re-set.

◆ dropMinPrecursorCharge()

void dropMinPrecursorCharge ( )

Delete the min_precursor_charge attribute.

Disables the attribute until it is re-set.

◆ dropPepThresholdType()

void dropPepThresholdType ( )

Delete the pep_threshold_type attribute.

Disables the attribute until it is re-set.

◆ dropPepThresholdValue()

void dropPepThresholdValue ( )

Delete the pep_threshold_value attribute.

Disables the attribute until it is re-set.

◆ dropTotalIntensity()

void dropTotalIntensity ( )

Delete the total_intensity attribute.

Disables the attribute until it is re-set.

◆ dropTotalIntensityThreshold()

void dropTotalIntensityThreshold ( )

Delete the total_intensity_threshold attribute.

Disables the attribute until it is re-set.

◆ dropUniquePepseq()

void dropUniquePepseq ( )

Delete the unique_pepseq attribute.

Disables the attribute until it is re-set.

◆ getIsolatedPrecursorSchemaType()

std::string getIsolatedPrecursorSchemaType ( ) const

Obtain a symbolic name for the isolated_precursor attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getIsolatedPrecursorThreshold()

std::string getIsolatedPrecursorThreshold ( ) const

Returns the value of the isolated_precursor_threshold attribute.

Threshold on the fraction of the peak area in the precursor region accounted for by the components.

Returns
current value of the isolated_precursor_threshold attribute.

◆ getIsolatedPrecursorThresholdSchemaType()

std::string getIsolatedPrecursorThresholdSchemaType ( ) const

Obtain a symbolic name for the isolated_precursor_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMinimumA1()

std::string getMinimumA1 ( ) const

Returns the value of the minimum_a1 attribute.

See Hsu, J. L., et al.: "Beyond quantitative proteomics: Signal enhancement of the a(1) ion as a mass tag for peptide sequencing using dimethyl labeling". Journal of Proteome Research 4 101-108 (2005).

Returns
current value of the minimum_a1 attribute.

◆ getMinimumA1SchemaType()

std::string getMinimumA1SchemaType ( ) const

Obtain a symbolic name for the minimum_a1 attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMinPrecursorCharge()

int getMinPrecursorCharge ( ) const

Returns the value of the min_precursor_charge attribute.

Unsigned integer, corresponding to abs(charge), in case anyone is using negative ions.

Returns
current value of the min_precursor_charge attribute.

◆ getMinPrecursorChargeSchemaType()

std::string getMinPrecursorChargeSchemaType ( ) const

Obtain a symbolic name for the min_precursor_charge attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_quant_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_quant_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtualinherited

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

◆ getPepThresholdType()

std::string getPepThresholdType ( ) const

Returns the value of the pep_threshold_type attribute.

Type of significance threshold for peptide matches.

Returns
current value of the pep_threshold_type attribute.

◆ getPepThresholdTypeSchemaType()

std::string getPepThresholdTypeSchemaType ( ) const

Obtain a symbolic name for the pep_threshold_type attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getPepThresholdValue()

std::string getPepThresholdValue ( ) const

Returns the value of the pep_threshold_value attribute.

Value of significance threshold for peptide matches (only used by certain threshold types).

Returns
current value of the pep_threshold_value attribute.

◆ getPepThresholdValueSchemaType()

std::string getPepThresholdValueSchemaType ( ) const

Obtain a symbolic name for the "pep_threshold_value" schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

◆ getTotalIntensitySchemaType()

std::string getTotalIntensitySchemaType ( ) const

Obtain a symbolic name for the total_intensity attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getTotalIntensityThreshold()

std::string getTotalIntensityThreshold ( ) const

Returns the value of the total_intensity_threshold attribute.

If TRUE, only report ratios for peptide sequences where the the totalIntensity of fitted peaks across the XIC peak exceeds the value of the total_intensity_threshold attribute.

Returns
current value of the total_intensity_threshold attribute.

◆ getTotalIntensityThresholdSchemaType()

std::string getTotalIntensityThresholdSchemaType ( ) const

Obtain a symbolic name for the total_intensity_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getUniquePepseqSchemaType()

std::string getUniquePepseqSchemaType ( ) const

Obtain a symbolic name for the unique_pepseq attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveIsolatedPrecursor()

bool haveIsolatedPrecursor ( ) const

Indicates presence of the isolated_precursor attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveIsolatedPrecursorThreshold()

bool haveIsolatedPrecursorThreshold ( ) const

Indicates presence of the isolated_precursor_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveMinimumA1()

bool haveMinimumA1 ( ) const

Indicates presence of the minimum_a1 attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveMinPrecursorCharge()

bool haveMinPrecursorCharge ( ) const

Indicates presence of the min_precursor_charge attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ havePepThresholdType()

bool havePepThresholdType ( ) const

Indicates presence of the pep_threshold_type attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ havePepThresholdValue()

bool havePepThresholdValue ( ) const

Indicates presence of the pep_threshold_value attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveTotalIntensity()

bool haveTotalIntensity ( ) const

Indicates presence of the total_intensity attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveTotalIntensityThreshold()

bool haveTotalIntensityThreshold ( ) const

Indicates presence of the total_intensity_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveUniquePepseq()

bool haveUniquePepseq ( ) const

Indicates presence of the unique_pepseq attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ isIsolatedPrecursor()

bool isIsolatedPrecursor ( ) const

Returns the value of the isolated_precursor attribute.

Determines whether to perform test for matched_fraction.

Returns
current value of the isolated_precursor attribute.

◆ isTotalIntensity()

bool isTotalIntensity ( ) const

Returns the value of the total_intensity attribute.

Determines whether to apply the test for totalIntensity

Returns
current value of the total_intensity attribute.

◆ isUniquePepseq()

bool isUniquePepseq ( ) const

Returns the value of the unique_pepseq attribute.

If TRUE, only report ratios for peptide sequences that are unique to one protein hit (which may be a family containing multiple proteins).

Returns
current value of the unique_pepseq attribute.

◆ operator=()

ms_quant_quality & operator= ( const ms_quant_quality & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setIsolatedPrecursor()

void setIsolatedPrecursor ( const bool value )

Set a custom value for the isolated_precursor attribute.

Parameters
value a new value for the attribute.

◆ setIsolatedPrecursorThreshold()

void setIsolatedPrecursorThreshold ( const char * value )

Set a custom value for the isolated_precursor_threshold attribute.

Parameters
value a new value for the attribute.

◆ setMinimumA1()

void setMinimumA1 ( const char * value )

Set a custom value for the minimum_a1 attribute.

Parameters
value a new value for the attribute.

◆ setMinPrecursorCharge()

void setMinPrecursorCharge ( const int value )

Set a custom value for the min_precursor_charge attribute.

Parameters
value a new value for the attribute.

◆ setPepThresholdType()

void setPepThresholdType ( const char * value )

Set a custom value for the pep_threshold_type attribute.

Parameters
value a new value for the attribute.

◆ setPepThresholdValue()

void setPepThresholdValue ( const char * value )

Set a custom value for the pep_threshold_value attribute.

Parameters
value a new value for the attribute.

◆ setTotalIntensity()

void setTotalIntensity ( bool value )

Set a custom value for the total_intensity attribute.

Parameters
value a new value for the attribute.

◆ setTotalIntensityThreshold()

void setTotalIntensityThreshold ( std::string value )

Set a custom value for the total_intensity_threshold attribute.

Parameters
value a new value for the attribute.

◆ setUniquePepseq()

void setUniquePepseq ( bool value )

Set a custom value for the unique_pepseq attribute.

Parameters
value a new value for the attribute.

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_quality.hpp
  • ms_quant_quality.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_ratio Class Reference

  • matrix_science
  • ms_quant_ratio
Public Member Functions | List of all members
ms_quant_ratio Class Reference
Mascot configuration files module

Represents the ratioType type for the report_ratio element in quantitation.xml. More...

#include <ms_quant_ratio.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_ratio ()
Default constructor.
ms_quant_ratio (const ms_quant_ratio &src)
Copying constructor.
virtual | ~ms_quant_ratio ()
Destructor.
void | appendDenominator (const ms_quant_numerator *denominator)
Adds a new denominator at the end of the list.
void | appendNumerator (const ms_quant_numerator *numerator)
Adds a new numerator at the end of the list.
void | clearDenominators ()
Deletes all denominators from the list.
void | clearNumerators ()
Deletes all numerators from the list.
void | copyFrom (const ms_quant_ratio *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteDenominatorByName (const char *name)
Remove a denominator from the list in memory by its unique name.
bool | deleteDenominatorByNumber (const int idx)
Remove a denominator from the list in memory by its index.
bool | deleteNumeratorByName (const char *name)
Remove a numerator from the list in memory by its unique name.
bool | deleteNumeratorByNumber (const int idx)
Remove a numerator from the list in memory by its index.
void | dropName ()
Delete the name attribute.
const ms_quant_numerator * | getDenominatorByName (const char *name) const
Returns a denominator object by its name or a null value in case of not found.
const ms_quant_numerator * | getDenominatorByNumber (const int idx) const
Returns a denominator object by its number or a null value in case of not found.
std::string | getDenominatorSchemaType () const
Obtain a symbolic name for the denominator element schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
int | getNumberOfDenominators () const
Returns a number of nested denominators.
int | getNumberOfNumerators () const
Returns the number of nested numerators.
const ms_quant_numerator * | getNumeratorByName (const char *name) const
Returns a numerator object by its name or a null value in case of not found.
const ms_quant_numerator * | getNumeratorByNumber (const int idx) const
Returns a numerator object by its number or a null value in case of not found.
std::string | getNumeratorSchemaType () const
Obtain a symbolic name for the numerator element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveName () const
Indicates presence of the name attribute.
ms_quant_ratio & | operator= (const ms_quant_ratio &right)
C++ style assignment operator.
void | setName (const char *value)
Set a custom value for the name attribute.
bool | updateDenominatorByName (const char *name, const ms_quant_numerator *denominator)
Update the information for a specific denominator refering to it by its unique name.
bool | updateDenominatorByNumber (const int idx, const ms_quant_numerator *denominator)
Update the information for a specific denominator refering to it by its index.
bool | updateNumeratorByName (const char *name, const ms_quant_numerator *numerator)
Update the information for a specific numerator refering to it by its unique name.
bool | updateNumeratorByNumber (const int idx, const ms_quant_numerator *numerator)
Update the information for a specific numerator refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents the ratioType type for the report_ratio element in quantitation.xml.

Constructor & Destructor Documentation

◆ ms_quant_ratio() [1/2]

ms_quant_ratio ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_ratio() [2/2]

ms_quant_ratio ( const ms_quant_ratio & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendDenominator()

void appendDenominator ( const ms_quant_numerator * denominator )

Adds a new denominator at the end of the list.

Creates a new denominator object, copies all content from the object supplied as a parameter and adds it at the end of the denominators list.

Parameters
denominator an instance of denominator object to copy content from.

◆ appendNumerator()

void appendNumerator ( const ms_quant_numerator * numerator )

Adds a new numerator at the end of the list.

Creates a new numerator object, copies all content from the object supplied as a parameter and adds it at the end of the numerators list.

Parameters
numerator an instance of numerator object to copy content from.

◆ copyFrom()

void copyFrom ( const ms_quant_ratio * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteDenominatorByName()

bool deleteDenominatorByName ( const char * name )

Remove a denominator from the list in memory by its unique name.

Parameters
name name of the denominator for deletion.
Returns
TRUE if the denominator has been found and successfully deleted and FALSE otherwise.

◆ deleteDenominatorByNumber()

bool deleteDenominatorByNumber ( const int idx )

Remove a denominator from the list in memory by its index.

Parameters
idx number of the denominator for deletion from 0 to (getNumberOfDenominators() - 1).
Returns
TRUE if the denominator has been found and successfully deleted and FALSE otherwise.

◆ deleteNumeratorByName()

bool deleteNumeratorByName ( const char * name )

Remove a numerator from the list in memory by its unique name.

Parameters
name name of the numerator for deletion.
Returns
TRUE if the numerator has been found and successfully deleted and FALSE otherwise.

◆ deleteNumeratorByNumber()

bool deleteNumeratorByNumber ( const int idx )

Remove a numerator from the list in memory by its index.

Parameters
idx number of the numerator for deletion from 0 to (getNumberOfNumerators() - 1).
Returns
TRUE if the numerator has been found and successfully deleted and FALSE otherwise.

◆ dropName()

void dropName ( )

Delete the name attribute.

Deletes the attribute until it is re-set.

◆ getDenominatorByName()

const ms_quant_numerator * getDenominatorByName ( const char * name ) const

Returns a denominator object by its name or a null value in case of not found.

Parameters
name name of the denominator to find.
Returns
a read-only pointer to a denominator object. See Maintaining object references: two rules of thumb.

◆ getDenominatorByNumber()

const ms_quant_numerator * getDenominatorByNumber ( const int idx ) const

Returns a denominator object by its number or a null value in case of not found.

Parameters
idx number of the denominator from 0 to (getNumberOfDenominators() - 1).
Returns
a read-only pointer to a denominator object. See Maintaining object references: two rules of thumb.

◆ getDenominatorSchemaType()

std::string getDenominatorSchemaType ( ) const

Obtain a symbolic name for the denominator element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getName()

std::string getName ( ) const

Returns the value of the name attribute.

Returns
a descriptive name that will appear in drop down lists, etc.

◆ getNameSchemaType()

std::string getNameSchemaType ( ) const

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumeratorByName()

const ms_quant_numerator * getNumeratorByName ( const char * name ) const

Returns a numerator object by its name or a null value in case of not found.

Parameters
name name of the numerator to find.
Returns
a read-only pointer to a numerator object. See Maintaining object references: two rules of thumb.

◆ getNumeratorByNumber()

const ms_quant_numerator * getNumeratorByNumber ( const int idx ) const

Returns a numerator object by its number or a null value in case of not found.

Parameters
idx number of the numerator from 0 to (getNumberOfNumerators() - 1).
Returns
a read-only pointer to a numerator object. See Maintaining object references: two rules of thumb.

◆ getNumeratorSchemaType()

std::string getNumeratorSchemaType ( ) const

Obtain a symbolic name for the numerator element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ haveName()

bool haveName ( ) const

Indicates presence of the name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_quant_ratio & operator= ( const ms_quant_ratio & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setName()

void setName ( const char * value )

Set a custom value for the name attribute.

Parameters
value a new value for the attribute.

◆ updateDenominatorByName()

bool updateDenominatorByName | ( | const char * | name,
 |  | const ms_quant_numerator * | denominator
 | ) |  |

Update the information for a specific denominator refering to it by its unique name.

Parameters
name | name of the denominator for updating.
denominator | an object to copy the content from.
Returns
TRUE if the denominator has been found and successfully updated and FALSE otherwise.

◆ updateDenominatorByNumber()

bool updateDenominatorByNumber | ( | const int | idx,
 |  | const ms_quant_numerator * | denominator
 | ) |  |

Update the information for a specific denominator refering to it by its index.

Parameters
idx | number of the denominator for updating from 0 to (getNumberOfDenominators() - 1).
denominator | an object to copy the content from.
Returns
TRUE if the denominator has been found and successfully updated and FALSE otherwise.

◆ updateNumeratorByName()

bool updateNumeratorByName | ( | const char * | name,
 |  | const ms_quant_numerator * | numerator
 | ) |  |

Update the information for a specific numerator refering to it by its unique name.

Parameters
name | name of the numerator for updating.
numerator | an object to copy the content from.
Returns
TRUE if the numerator has been found and successfully updated and FALSE otherwise.

◆ updateNumeratorByNumber()

bool updateNumeratorByNumber | ( | const int | idx,
 |  | const ms_quant_numerator * | numerator
 | ) |  |

Update the information for a specific numerator refering to it by its index.

Parameters
idx | number of the numerator for updating from 0 to (getNumberOfNumerators() - 1).
numerator | an object to copy the content from.
Returns
TRUE if the numerator has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_ratio.hpp
  • ms_quant_ratio.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_replicate Class Reference

  • matrix_science
  • ms_quant_replicate
Public Member Functions | List of all members
ms_quant_replicate Class Reference
Mascot configuration files module

An object of this class represent a single replicate element in quantitation.xml. More...

#include <ms_quant_replicate.hpp>

Inheritance diagram for ms_quant_replicate:
[legend]
Collaboration diagram for ms_quant_replicate:
[legend]

Public Member Functions

ms_quant_replicate ()
Default constructor.
ms_quant_replicate (const ms_quant_replicate &src)
Copying constructor.
virtual | ~ms_quant_replicate ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_replicate *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropTimeAlignmentAlgorithm ()
Delete the time_alignment_algorithm attribute.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getTimeAlignmentAlgorithm () const
Returns the value of the time_alignment_algorithm attribute.
std::string | getTimeAlignmentAlgorithmSchemaType () const
Obtain a symbolic name for the time_alignment_algorithm attribute schema type.
bool | haveTimeAlignmentAlgorithm () const
Indicates presence of the time_alignment_algorithm attribute.
ms_quant_replicate & | operator= (const ms_quant_replicate &right)
C++ style assignment operator.
void | setTimeAlignmentAlgorithm (const char *value)
Set a custom value for the time_alignment_algorithm attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single replicate element in quantitation.xml.

Serves as a possible sub-element of the protocol element.

Constructor & Destructor Documentation

◆ ms_quant_replicate() [1/2]

ms_quant_replicate ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_replicate() [2/2]

ms_quant_replicate ( const ms_quant_replicate & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendParameter()

void appendParameter ( const ms_quant_parameter * item )
inherited

Adds a new parameter at the end of the list.

Parameters
item an instance of parameter object to copy content from.

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_replicate * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ dropTimeAlignmentAlgorithm()

void dropTimeAlignmentAlgorithm ( )

Delete the time_alignment_algorithm attribute.

Disables the attribute until it is re-set.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_quant_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_quant_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtualinherited

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

◆ getTimeAlignmentAlgorithm()

std::string getTimeAlignmentAlgorithm ( ) const

Returns the value of the time_alignment_algorithm attribute.

Algorithm to be used when performing time alignment for label free (replicate) quantitation.

Returns
current value of the time_alignment_algorithm attribute.

◆ getTimeAlignmentAlgorithmSchemaType()

std::string getTimeAlignmentAlgorithmSchemaType ( ) const

Obtain a symbolic name for the time_alignment_algorithm attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveTimeAlignmentAlgorithm()

bool haveTimeAlignmentAlgorithm ( ) const

Indicates presence of the time_alignment_algorithm attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current elementand FALSE otherwise.

◆ operator=()

ms_quant_replicate & operator= ( const ms_quant_replicate & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setTimeAlignmentAlgorithm()

void setTimeAlignmentAlgorithm ( const char * value )

Set a custom value for the time_alignment_algorithm attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropTimeAlignmentAlgorithm().

Parameters
value a new value for the attribute.

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_replicate.hpp
  • ms_quant_replicate.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_reporter Class Reference

  • matrix_science
  • ms_quant_reporter
Public Member Functions | List of all members
ms_quant_reporter Class Reference
Mascot configuration files module

An object of this class represents a single reporter element in quantitation.xml. More...

#include <ms_quant_reporter.hpp>

Inheritance diagram for ms_quant_reporter:
[legend]
Collaboration diagram for ms_quant_reporter:
[legend]

Public Member Functions

ms_quant_reporter ()
Default constructor.
ms_quant_reporter (const ms_quant_reporter &src)
Copying constructor.
virtual | ~ms_quant_reporter ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_reporter *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropReporterTol ()
Delete the reporter_tol attribute.
void | dropReporterTolUnit ()
Delete the reporter_tol_unit attribute.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
std::string | getReporterTol () const
Returns the value of the reporter_tol attribute.
std::string | getReporterTolSchemaType () const
Obtain a symbolic name for the reporter_tol attribute schema type.
std::string | getReporterTolUnit () const
Returns the value of the reporter_tol_unit attribute.
std::string | getReporterTolUnitSchemaType () const
Obtain a symbolic name for the reporter_tol_unit attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveReporterTol () const
Indicates presence of the reporter_tol attribute.
bool | haveReporterTolUnit () const
Indicates presence of the reporter_tol_unit attribute.
ms_quant_reporter & | operator= (const ms_quant_reporter &right)
C++ style assignment operator.
void | setReporterTol (const char *value)
Set a custom value for the reporter_tol attribute.
void | setReporterTolUnit (const char *value)
Set a custom value for the reporter_tol_unit attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represents a single reporter element in quantitation.xml.

Serves as a possible sub-element of the protocol element.

Constructor & Destructor Documentation

◆ ms_quant_reporter() [1/2]

ms_quant_reporter ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_reporter() [2/2]

ms_quant_reporter ( const ms_quant_reporter & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendParameter()

void appendParameter ( const ms_quant_parameter * item )
inherited

Adds a new parameter at the end of the list.

Parameters
item an instance of parameter object to copy content from.

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_parameters * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_quant_reporter * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
virtualinherited

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
virtualinherited

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

◆ dropReporterTol()

void dropReporterTol ( )

Delete the reporter_tol attribute.

Disables the attribute until it is re-set.

◆ dropReporterTolUnit()

void dropReporterTolUnit ( )

Delete the reporter_tol_unit attribute.

Disables the attribute until it is re-set.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
virtualinherited

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implements ms_xml_parameters.

◆ getParameterByName()

const ms_quant_parameter * getParameterByName ( const char * name ) const
inherited

Returns a parameter object by its name or a null value in case of not found.

Parameters
name name of the parameter to find.
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterByNumber()

const ms_quant_parameter * getParameterByNumber ( const int idx ) const
inherited

Returns a parameter object by its number.

Parameters
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
virtualinherited

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implements ms_xml_parameters.

◆ getReporterTol()

std::string getReporterTol ( ) const

Returns the value of the reporter_tol attribute.

Mass tolerance to be used for matching reporter ion peaks.

Returns
current value of the reporter_tol attribute.

◆ getReporterTolSchemaType()

std::string getReporterTolSchemaType ( ) const

Obtain a symbolic name for the reporter_tol attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getReporterTolUnit()

std::string getReporterTolUnit ( ) const

Returns the value of the reporter_tol_unit attribute.

Units for reporter_tol (Da ppm mmu %).

Returns
current value of the reporter_tol_unit attribute.

◆ getReporterTolUnitSchemaType()

std::string getReporterTolUnitSchemaType ( ) const

Obtain a symbolic name for the reporter_tol_unit attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

◆ haveReporterTol()

bool haveReporterTol ( ) const

Indicates presence of the reporter_tol attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ haveReporterTolUnit()

bool haveReporterTolUnit ( ) const

Indicates presence of the reporter_tol_unit attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns
TRUE if the attribute is present in current element and FALSE otherwise.

◆ operator=()

ms_quant_reporter & operator= ( const ms_quant_reporter & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setReporterTol()

void setReporterTol ( const char * value )

Set a custom value for the reporter_tol attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropReporterTol().

Parameters
value a new value for the attribute.

◆ setReporterTolUnit()

void setReporterTolUnit ( const char * value )

Set a custom value for the reporter_tol_unit attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropReporterTolUnit().

Parameters
value a new value for the attribute.

◆ updateParameterByName()

bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its unique name.

Parameters
name | name of the parameter for updating.
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ updateParameterByNumber()

bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |
inherited

Update the information for a specific parameter refering to it by its index.

Parameters
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns
TRUE if the parameter has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_reporter.hpp
  • ms_quant_reporter.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_satellite Class Reference

  • matrix_science
  • ms_quant_satellite
Public Member Functions | List of all members
ms_quant_satellite Class Reference
Mascot configuration files module

An object of this class represent a single satellite element in quantitation.xml. More...

#include <ms_quant_satellite.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_satellite ()
Default constructor.
ms_quant_satellite (const ms_quant_satellite &src)
Copying constructor.
virtual | ~ms_quant_satellite ()
Destructor.
void | copyFrom (const ms_quant_satellite *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropModifications ()
Delete the modifications element.
const ms_quant_modgroup * | getModifications () const
Returns the value of the modifications element.
std::string | getModificationsSchemaType () const
Obtain a symbolic name for the modifications element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveModifications () const
Check for presence of the modifications element.
ms_quant_satellite & | operator= (const ms_quant_satellite &right)
C++ style assignment operator.
void | setModifications (const ms_quant_modgroup *moverz)
Supply a custom content for modifications element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single satellite element in quantitation.xml.

Modification group that defines satellite peaks to be summed into the heaviest component to correct for Arg-Pro conversion of SILAC label.

Constructor & Destructor Documentation

◆ ms_quant_satellite() [1/2]

ms_quant_satellite ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_satellite() [2/2]

ms_quant_satellite ( const ms_quant_satellite & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_satellite * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropModifications()

void dropModifications ( )

Delete the modifications element.

Deletes the element until it is re-set.

◆ getModifications()

const ms_quant_modgroup * getModifications ( ) const

Returns the value of the modifications element.

Returns
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.

◆ getModificationsSchemaType()

std::string getModificationsSchemaType ( ) const

Obtain a symbolic name for the modifications element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType").

◆ haveModifications()

bool haveModifications ( ) const

Check for presence of the modifications element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ operator=()

ms_quant_satellite & operator= ( const ms_quant_satellite & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setModifications()

void setModifications ( const ms_quant_modgroup * mods )

Supply a custom content for modifications element.

Modification group that defines satellite peaks to be summed into the heaviest component to correct for Arg-Pro conversion of SILAC label.

Parameters
mods a new content for the element.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_satellite.hpp
  • ms_quant_satellite.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_specificity Class Reference

  • matrix_science
  • ms_quant_specificity
Public Member Functions | List of all members
ms_quant_specificity Class Reference
Mascot configuration files module

Describes a specificity element in quantitation.xml (Unimod style specificity). More...

#include <ms_quant_specificity.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_specificity ()
Default constructor.
ms_quant_specificity (const ms_quant_specificity &src)
Copying constructor.
virtual | ~ms_quant_specificity ()
Destructor.
void | appendNeutralLoss (const ms_quant_neutralloss *neutralloss)
Adds a new NeutralLoss element at the end of the list.
void | appendPepNeutralLoss (const ms_quant_pepneutralloss *neutralloss)
Adds a new PepNeutralLoss element at the end of the list.
void | clearNeutralLosses ()
Deletes all elements from the list.
void | clearPepNeutralLosses ()
Deletes all elements from the list.
void | copyFrom (const ms_quant_specificity *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteNeutralLoss (const int idx)
Remove a NeutralLoss element from the list.
bool | deletePepNeutralLoss (const int idx)
Remove a PepNeutralLoss element from the list.
void | dropPosition ()
Deletes the position attribute.
void | dropSite ()
Deletes the site attribute.
const ms_quant_neutralloss * | getNeutralLoss (const int idx) const
Returns a NeutralLoss element object by its number.
std::string | getNeutralLossSchemaType () const
Obtain a symbolic name for the NeutralLoss element schema type.
int | getNumberOfNeutralLosses () const
Returns the number of NeutralLoss elements held.
int | getNumberOfPepNeutralLosses () const
Returns the number of PepNeutralLoss elements held.
const ms_quant_pepneutralloss * | getPepNeutralLoss (const int idx) const
Returns a pointer to the PepNeutralLoss element by its number.
std::string | getPepNeutralLossSchemaType () const
Obtain a symbolic name for the PepNeutralLoss element schema type.
std::string | getPosition () const
Returns the value of the position attribute.
std::string | getPositionSchemaType () const
Obtain a symbolic name for the position attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSite () const
Returns the value of the site attribute.
std::string | getSiteSchemaType () const
Obtain a symbolic name for the site attribute schema type.
bool | havePosition () const
Indicates whether the position attribute is present or not.
bool | haveSite () const
Indicates whether the site attribute is present or not.
ms_quant_specificity & | operator= (const ms_quant_specificity &right)
C++ style assignment operator.
void | setPosition (const char *position)
Set a custom value for the position attribute.
void | setSite (const char *site)
Set a custom value for the site attribute.
bool | updateNeutralLoss (const int idx, const ms_quant_neutralloss *neutralloss)
Update the information for a specific neutral loss.
bool | updatePepNeutralLoss (const int idx, const ms_quant_pepneutralloss *neutralloss)
Update the information for a specific peptide neutral loss.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Describes a specificity element in quantitation.xml (Unimod style specificity).

Objects of this type host a list of nested NeutralLoss elements.

Constructor & Destructor Documentation

◆ ms_quant_specificity() [1/2]

ms_quant_specificity ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_specificity() [2/2]

ms_quant_specificity ( const ms_quant_specificity & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendNeutralLoss()

void appendNeutralLoss ( const ms_quant_neutralloss * neutralloss )

Adds a new NeutralLoss element at the end of the list.

Parameters
neutralloss an instance to copy the content into the newly added element from.

◆ appendPepNeutralLoss()

void appendPepNeutralLoss ( const ms_quant_pepneutralloss * pepneutralloss )

Adds a new PepNeutralLoss element at the end of the list.

Parameters
pepneutralloss an instance to copy the content into the newly added element from.

◆ copyFrom()

void copyFrom ( const ms_quant_specificity * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteNeutralLoss()

bool deleteNeutralLoss ( const int idx )

Remove a NeutralLoss element from the list.

Parameters
idx a zero-based index of the element to delete.
Returns
TRUE if the element has been successfully deleted and FALSE otherwise.

◆ deletePepNeutralLoss()

bool deletePepNeutralLoss ( const int idx )

Remove a PepNeutralLoss element from the list.

Parameters
idx a zero-based index of the element to delete.
Returns
TRUE if the element has been successfully deleted and FALSE otherwise.

◆ dropPosition()

void dropPosition ( )

Deletes the position attribute.

Disables the attribute until it is re-set.

◆ dropSite()

void dropSite ( )

Deletes the site attribute.

Disables the attribute until it is re-set.

◆ getNeutralLoss()

const ms_quant_neutralloss * getNeutralLoss ( const int idx ) const

Returns a NeutralLoss element object by its number.

Parameters
idx a zero-based index of the element to retrieve.
Returns
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.

◆ getNeutralLossSchemaType()

std::string getNeutralLossSchemaType ( ) const

Obtain a symbolic name for the NeutralLoss element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getPepNeutralLoss()

const ms_quant_pepneutralloss * getPepNeutralLoss ( const int idx ) const

Returns a pointer to the PepNeutralLoss element by its number.

Parameters
idx a zero-based index of the element to obtain.
Returns
a read-only pointer to the current content. See Maintaining object references: two rules of thumb.

◆ getPepNeutralLossSchemaType()

std::string getPepNeutralLossSchemaType ( ) const

Obtain a symbolic name for the PepNeutralLoss element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getPosition()

std::string getPosition ( ) const

Returns the value of the position attribute.

Returns
current value of the position attribute.

◆ getPositionSchemaType()

std::string getPositionSchemaType ( ) const

Obtain a symbolic name for the position attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ getSite()

std::string getSite ( ) const

Returns the value of the site attribute.

Returns
current value of the site attribute.

◆ getSiteSchemaType()

std::string getSiteSchemaType ( ) const

Obtain a symbolic name for the site attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ havePosition()

bool havePosition ( ) const

Indicates whether the position attribute is present or not.

Returns
TRUE if the attribute is available.

◆ haveSite()

bool haveSite ( ) const

Indicates whether the site attribute is present or not.

Returns
TRUE if the attribute is available.

◆ operator=()

ms_quant_specificity & operator= ( const ms_quant_specificity & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setPosition()

void setPosition ( const char * position )

Set a custom value for the position attribute.

Calling this method makes the attribute automatically available in the current element.

Parameters
position a new value for the position attribute.

◆ setSite()

void setSite ( const char * site )

Set a custom value for the site attribute.

Calling this method makes the attribute automatically available in the current element.

Parameters
site a new value for the site attribute.

◆ updateNeutralLoss()

bool updateNeutralLoss | ( | const int | idx,
 |  | const ms_quant_neutralloss * | neutralloss
 | ) |  |

Update the information for a specific neutral loss.

Parameters
idx | a zero-based index of the element to update.
neutralloss | an instance to copy the content from.
Returns
TRUE if the element has been successfully updated and FALSE otherwise.

◆ updatePepNeutralLoss()

bool updatePepNeutralLoss | ( | const int | idx,
 |  | const ms_quant_pepneutralloss * | pepneutralloss
 | ) |  |

Update the information for a specific peptide neutral loss.

Parameters
idx | a zero-based index of the element to update.
pepneutralloss | an instance to copy the content from.
Returns
TRUE if the element has been successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_specificity.hpp
  • ms_quant_specificity.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_unmodified Class Reference

  • matrix_science
  • ms_quant_unmodified
Public Member Functions | List of all members
ms_quant_unmodified Class Reference
Mascot configuration files module

Describes an unmodified element in quantitation.xml. More...

#include <ms_quant_unmodified.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_quant_unmodified ()
Default constructor.
ms_quant_unmodified (const ms_quant_unmodified &src)
Copying constructor.
virtual | ~ms_quant_unmodified ()
Destructor.
void | copyFrom (const ms_quant_unmodified *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropPosition ()
Deletes the position attribute.
void | dropSite ()
Deletes the site attribute.
std::string | getContent () const
Returns string value of the element.
std::string | getContentSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getPosition () const
Returns the value of the position attribute.
std::string | getPositionSchemaType () const
Obtain a symbolic name for the position attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSite () const
Returns the value of the site attribute.
std::string | getSiteSchemaType () const
Obtain a symbolic name for the site attribute schema type.
bool | havePosition () const
Indicates whether the position attribute is present or not.
bool | haveSite () const
Indicates whether the site attribute is present or not.
ms_quant_unmodified & | operator= (const ms_quant_unmodified &right)
C++ style assignment operator.
void | setContent (const char *value)
Set a custom value for the the element.
void | setPosition (const char *position)
Set a custom value for the position attribute.
void | setSite (const char *site)
Set a custom value for the site attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Describes an unmodified element in quantitation.xml.

Constructor & Destructor Documentation

◆ ms_quant_unmodified() [1/2]

ms_quant_unmodified ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_quant_unmodified() [2/2]

ms_quant_unmodified ( const ms_quant_unmodified & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_quant_unmodified * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropPosition()

void dropPosition ( )

Deletes the position attribute.

Disables the attribute until it is re-set.

◆ dropSite()

void dropSite ( )

Deletes the site attribute.

Disables the attribute until it is re-set.

◆ getContent()

std::string getContent ( ) const

Returns string value of the element.

Returns
string content of the element.

◆ getContentSchemaType()

std::string getContentSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getPosition()

std::string getPosition ( ) const

Returns the value of the position attribute.

Returns
current value of the position attribute.

◆ getPositionSchemaType()

std::string getPositionSchemaType ( ) const

Obtain a symbolic name for the position attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

◆ getSite()

std::string getSite ( ) const

Returns the value of the site attribute.

Returns
current value of the site attribute.

◆ getSiteSchemaType()

std::string getSiteSchemaType ( ) const

Obtain a symbolic name for the site attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ havePosition()

bool havePosition ( ) const

Indicates whether the position attribute is present or not.

Returns
TRUE if the attribute is available.

◆ haveSite()

bool haveSite ( ) const

Indicates whether the site attribute is present or not.

Returns
TRUE if the attribute is available.

◆ operator=()

ms_quant_unmodified & operator= ( const ms_quant_unmodified & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setContent()

void setContent ( const char * value )

Set a custom value for the the element.

Parameters
value new content for the element.

◆ setPosition()

void setPosition ( const char * position )

Set a custom value for the position attribute.

Calling this method makes the attribute automatically available in the current element.

Parameters
position a new value for the position attribute.

◆ setSite()

void setSite ( const char * site )

Set a custom value for the site attribute.

Calling this method makes the attribute automatically available in the current element.

Parameters
site a new value for the site attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_unmodified.hpp
  • ms_quant_unmodified.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_taxnodesfiles Class Reference

  • matrix_science
  • ms_taxnodesfiles
Public Member Functions | List of all members
ms_taxnodesfiles Class Reference
Mascot configuration files module

Filenames and formats for taxonomy nodes or genetic codes files. More...

#include <ms_taxonomyrules.hpp>

Public Member Functions

ms_taxnodesfiles ()
Default constructor.
ms_taxnodesfiles (const ms_taxnodesfiles &src)
Copying constructor.
~ms_taxnodesfiles ()
Destructor.
void | copyFrom (const ms_taxnodesfiles *right)
Can be used to create a copy of another instance.
void | defaultValues ()
Initialises the instance.
std::string | getFileName () const
Returns the file name.
TAX_NODE_FORMAT | getFormat () const
Returns format identifier of the file.
ms_taxnodesfiles & | operator= (const ms_taxnodesfiles &right)
Assignment operator for C++ client applications.
void | setFileName (const char *name)
Change the file name.
void | setFormat (const TAX_NODE_FORMAT value)
Change the format property.

Detailed Description

Filenames and formats for taxonomy nodes or genetic codes files.

See also ms_taxonomytree which provides functionality for the taxonomy nodes files.

The documentation for this class was generated from the following files:
  • ms_taxonomyrules.hpp
  • ms_taxonomyrules.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_taxonomychoice Class Reference

  • matrix_science
  • ms_taxonomychoice
Public Member Functions | List of all members
ms_taxonomychoice Class Reference
Mascot configuration files module

The class represents a single taxonomy choice entry in the taxonomy file. More...

#include <ms_taxonomyfile.hpp>

Inheritance diagram for ms_taxonomychoice:
[legend]
Collaboration diagram for ms_taxonomychoice:
[legend]

Public Member Functions

ms_taxonomychoice ()
Default constructor.
ms_taxonomychoice (const ms_taxonomychoice &src)
Copying constructor.
~ms_taxonomychoice ()
Destructor.
void | appendExcludeTaxonomy (const int id)
Adds one more taxonomy ID to the exclude list.
void | appendIncludeTaxonomy (const int id)
Adds one more taxonomy ID to the include list.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearExcludeTaxonomies ()
Deletes all taxonomy IDs from the exclude list.
void | clearIncludeTaxonomies ()
Deletes all taxonomy IDs from the include list.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_taxonomychoice *src)
Copies modification configuration from another instance.
void | defaultValues ()
Re-initialises the object.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
int | getExcludeTaxonomy (const int n) const
Traverse the excluded taxonomy IDs.
int | getIncludeTaxonomy (const int n) const
Traverse the included taxonomy IDs.
int | getNumberOfExcludeTaxonomies () const
Returns a total number of excluded taxonomy IDs.
int | getNumberOfIncludeTaxonomies () const
Returns a total number of included taxonomy IDs.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
std::string | getTitle () const
Returns the taxonomy choice title.
ms_taxonomychoice & | operator= (const ms_taxonomychoice &right)
C++ style assignment operator.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setTitle (const char *value)
Change the title for taxonomy choice.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

The class represents a single taxonomy choice entry in the taxonomy file.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Member Function Documentation

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_taxonomyfile.hpp
  • ms_taxonomyfile.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_taxonomyfile Class Reference

  • matrix_science
  • ms_taxonomyfile
Public Member Functions | List of all members
ms_taxonomyfile Class Reference
Mascot configuration files module

Use this class in order to read in a taxonomy file. More...

#include <ms_taxonomyfile.hpp>

Inheritance diagram for ms_taxonomyfile:
[legend]
Collaboration diagram for ms_taxonomyfile:
[legend]

Public Member Functions

ms_taxonomyfile ()
Default constructor.
ms_taxonomyfile (const char *filename, const matrix_science::ms_connection_settings *cs=0)
Immediate-action constructor that reads the given file on construction.
ms_taxonomyfile (const ms_taxonomyfile &src)
Copying constructor.
~ms_taxonomyfile ()
Destructor.
void | appendEntry (const ms_taxonomychoice *item)
Adds a new taxonomy choice at the end of the list.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearEntries ()
Deletes all taxonomy choices from the list.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_taxonomyfile *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
matrix_science::ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
ms_taxonomychoice * | getEntryByName (const char *name)
Returns a taxonomy choice entry by its name or NULL in case of not found.
const ms_taxonomychoice * | getEntryByNumber (const int index) const
Returns a taxonomy choice entry by its number.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a file name that is used to read the file.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumberOfEntries () const
Returns a number of taxonomy choices currently held in memory.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_taxonomyfile & | operator= (const ms_taxonomyfile &right)
C++ style assignment operator.
void | read_buffer (const char *buffer)
Reads and parses an in-memory null-terminated buffer instead of a disk file.
void | read_file ()
Reads configuration information from the file.
void | save_file ()
Stores modification information in the file.
void | setConnectionSettings (const matrix_science::ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an http transfer.
void | setFileName (const char *name)
Call this member to set a custom file name to read from a different location.

Detailed Description

Use this class in order to read in a taxonomy file.

The list of taxonomy choices in the search form is taken from the taxonomy file. The file consists of several entries. The first line of each entry must start with the Title: keyword, followed by a text string that is used to identify the species in forms and reports. The definition should be short and self-explanatory.

To show the tree structure, indentation can be used. Unfortunately, it is not possible to use tabs or multiple spaces for indentation in an HTML form, so a full stop (period) and a space are used to indent the list. Internal spaces are significant, and there should never be two or more spaces together.

This should be followed with a definition line starting with the Include: keyword, followed by one or more numbers separated with commas. With the supplied MSDB database, and supplied taxonomy files, these numbers should be the NCBI taxonomy ID.

This should be followed with a definition line starting with the Exclude: keyword, followed by one or more numbers separated with commas. Any sequence with a taxonomy ID that passes the 'include' test may then be rejected by any entry in the exclude list.

Finally, each entry must end with a *.

Examples
config_taxonomy.cpp.

Constructor & Destructor Documentation

◆ ms_taxonomyfile()

ms_taxonomyfile | ( | const char * | filename,
 |  | const matrix_science::ms_connection_settings * | cs = 0
 | ) |  |

Immediate-action constructor that reads the given file on construction.

Parameters
filename | The file name parameter can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
cs | is a pointer to the connection settings. This should contain a sessionID and optionally the proxy server settings.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getConnectionSettings()

matrix_science::ms_connection_settings getConnectionSettings ( ) const

Returns the sessionID and proxy server for use with an HTTP transfer.

See also the constructor documentation and setConnectionSettings().

Returns
The current connection settings.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ read_buffer()

void read_buffer ( const char * buffer )

Reads and parses an in-memory null-terminated buffer instead of a disk file.

Check for possible errors after calling this functions with isValid().

Parameters
buffer a null-terminated string with taxonomies definitions.

◆ read_file()

void read_file ( )

Reads configuration information from the file.

Check for possible errors after calling this functions with isValid().

◆ setConnectionSettings()

void setConnectionSettings ( const matrix_science::ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an http transfer.

This value would normally be passed in the constructor.

Parameters
cs Is the new connection settings.
The documentation for this class was generated from the following files:
  • ms_taxonomyfile.hpp
  • ms_taxonomyfile.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_taxonomyrules Class Reference

  • matrix_science
  • ms_taxonomyrules
Public Member Functions | List of all members
ms_taxonomyrules Class Reference
Mascot configuration files module

This class represents a single Taxonomy_XXX section in mascot.dat. More...

#include <ms_taxonomyrules.hpp>

Inheritance diagram for ms_taxonomyrules:
[legend]
Collaboration diagram for ms_taxonomyrules:
[legend]

Public Member Functions

ms_taxonomyrules ()
Default constructor.
ms_taxonomyrules (const ms_taxonomyrules &src)
Copying constructor.
~ms_taxonomyrules ()
Destructor.
void | appendGencodeFile (const ms_taxnodesfiles *item)
Adds an entry into the GencodeFiles list.
void | appendNoBreakDescLineIf (const char *str)
Adds an entry into the NoBreakDescLineIf list.
void | appendNodesFile (const ms_taxnodesfiles *item)
Adds an entry into the NodesFiles list.
void | appendPerDbSrcRule (const ms_parserule_plus *item)
Adds a new database source string into the list.
void | appendPrefixRemove (const char *item)
Adds an entry into the PrefixRemoves list.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendSpeciesFile (const ms_taxspeciesfiles *item)
Adds an entry into the SpeciesFiles list.
void | appendStrFile (const ms_taxspeciesfiles *item)
void | appendSuffixRemove (const char *item)
Adds an entry into the SuffixRemoves list.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearDBLevelTaxId ()
Deletes DBLevelTaxId; it will not be saved in the file.
void | clearGencodeFiles ()
Deletes all GencodeFiles entries.
void | clearNoBreakDescLineIf ()
Deletes all NoBreakDescLineIf entries.
void | clearNodesFiles ()
Deletes all NodesFiles entries.
void | clearPerDbSrcRules ()
Deletes all database source strings.
void | clearPrefixRemoves ()
Deletes all PrefixRemoves entries.
void | clearSpeciesFiles ()
Deletes all entries for SpeciesFiles.
void | clearSuffixRemoves ()
Deletes all SuffixRemoves entries.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_taxonomyrules *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
const ms_parserule * | getAccFromSpeciesLine () const
Returns the value of AccFromSpeciesLine.
int | getDBLevelTaxId () const
Returns the value of DBLevelTaxId.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
const ms_parserule_plus * | getDefaultRule () const
Returns the value of DefaultRule.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
char | getDescriptionLineSep () const
Returns the value of DescriptionLineSep.
const ms_parserule * | getDoThisRuleFirst () const
Returns the value of DoThisRuleFirst.
int | getErrorLevel () const
Returns the value of ErrorLevel.
const ms_taxnodesfiles * | getGencodeFile (const int index) const
Returns an instance of ms_taxnodesfiles describing an entry in GencodeFiles.
std::string | getIdentifier () const
Returns the value of Identifier.
std::string | getNoBreakDescLineIf (const int index) const
Returns a NoBreakDescLineIf entry by its number.
const ms_taxnodesfiles * | getNodesFile (const int index) const
Returns an instance of ms_taxnodesfiles describing an entry in NodesFiles.
int | getNumberOfGencodeFiles () const
Returns the number of file names specified in GencodeFiles.
int | getNumberOfNoBreakDescLineIf () const
Returns the number of NoBreakDescLineIf entries.
int | getNumberOfNodesFiles () const
Returns the number of file names specified in NodesFiles.
int | getNumberOfPerDbSrcRules () const
Returns the number of database source strings.
int | getNumberOfPrefixRemoves () const
Returns the number of PrefixRemoves entries.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
int | getNumberOfSpeciesFiles () const
Returns the number of file names specified in SpeciesFiles.
int | getNumberOfStrFiles () const
int | getNumberOfSuffixRemoves () const
Returns the number of SuffixRemoves entries.
const ms_parserule_plus * | getPerDbSrcRule (const int index) const
Returns a database source string by its number.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPrefixRemove (const int index) const
Returns the PrefixRemoves string by number.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
std::string | getQuickRefSearch () const
Returns the value of QuickRefSearch.
const ms_taxspeciesfiles * | getSpeciesFile (const int index) const
Returns an instance of ms_taxspeciesfiles describing an entry in SpeciesFiles.
std::string | getSpeciesFormatRegex (const TAX_SPECIES_FORMAT format) const
Returns a regular expression, if any for the species format.
const ms_parserule * | getSrcDatabaseRule () const
Returns the value of SrcDatabaseRule.
const ms_taxspeciesfiles * | getStrFile (const int index) const
const ms_parserule_plus * | getStrRule () const
std::string | getSuffixRemove (const int index) const
Returns a SuffixRemoves string by number.
bool | isConcatRefFileLines () const
Returns TRUE if ConcatRefFileLines parameter is set to 1 and FALSE otherwise.
bool | isDBLevelTaxId () const
Returns TRUE if there is a database level taxonomy ID in the file.
bool | isEnabled () const
Returns TRUE if Enabled parameter is set to 1 and FALSE otherwise.
bool | isFromRefFile () const
Returns TRUE if FromRefFile parameter is set to 1 and FALSE otherwise.
bool | isMitochondrialTranslation () const
Returns TRUE if MitochondrialTranslation parameter is set to 1 and FALSE otherwise.
bool | isSectionAvailable () const
Checks whether the section has been actually read from the file.
ms_taxonomyrules & | operator= (const ms_taxonomyrules &right)
Assignment operator for C++ client applications.
void | setAccFromSpeciesLine (const ms_parserule *src)
Change the value of AccFromSpeciesLine.
void | setConcatRefFileLines (const bool flag)
Change the value of ConcatRefFileLines.
void | setDBLevelTaxId (const int value)
Change the value of DBLevelTaxId.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setDefaultRule (const ms_parserule_plus *src)
Change the value of DefaultRule.
void | setDescriptionLineSep (const char value)
Change the value of DescriptionLineSep.
void | setDoThisRuleFirst (const ms_parserule *src)
Change the value of DoThisRuleFirst.
void | setEnabled (const bool flag)
Change the value of Enabled.
void | setErrorLevel (const int value)
Change the value of ErrorLevel.
void | setFromRefFile (const bool flag)
Change the value of FromRefFile.
void | setIdentifier (const char *str)
Change the value of Identifier.
void | setMitochondrialTranslation (const bool flag)
Set the value of MitochondrialTranslation.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setQuickRefSearch (const char *str)
Change the value of QuickRefSearch.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.
void | setSpeciesFormatRegex (const TAX_SPECIES_FORMAT format, const std::string regex)
Set the regular expression, if any, for the species format.
void | setSrcDatabaseRule (const ms_parserule *src)
Change the value of SrcDatabaseRule.
void | setStrRule (const ms_parserule_plus *src)
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

This class represents a single Taxonomy_XXX section in mascot.dat.

The Taxonomy section defines a set of taxonomy rules that can be selected for a database. Usage of taxonomy rules can be turned off by setting Enabled property to 0. See isEnabled() for more information.

Instances of this class are created in ms_datfile.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Member Function Documentation

◆ appendGencodeFile()

void appendGencodeFile ( const ms_taxnodesfiles * item )

Adds an entry into the GencodeFiles list.

See getGencodeFile() for more information.

Parameters
item an item to add a copy of into the list.

◆ appendNoBreakDescLineIf()

void appendNoBreakDescLineIf ( const char * str )

Adds an entry into the NoBreakDescLineIf list.

See getNoBreakDescLineIf() for more information.

Parameters
str an item to add a copy of into the list.

◆ appendNodesFile()

void appendNodesFile ( const ms_taxnodesfiles * item )

Adds an entry into the NodesFiles list.

See getNodesFile() for more information.

Parameters
item an item to add a copy of into the list.

◆ appendPerDbSrcRule()

void appendPerDbSrcRule ( const ms_parserule_plus * item )

Adds a new database source string into the list.

See getPerDbSrcRule() for more information.

Parameters
item an item to add a copy of into the list

◆ appendPrefixRemove()

void appendPrefixRemove ( const char * item )

Adds an entry into the PrefixRemoves list.

See getPrefixRemove() for more information.

Parameters
item an item to add a copy of into the list.

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendSpeciesFile()

void appendSpeciesFile ( const ms_taxspeciesfiles * item )

Adds an entry into the SpeciesFiles list.

See getSpeciesFile() for more information.

Parameters
item an item to add a copy of into the list.

◆ appendStrFile()

void appendStrFile ( const ms_taxspeciesfiles * item )
Parameters
item pointer to a taxonomy species file

◆ appendSuffixRemove()

void appendSuffixRemove ( const char * item )

Adds an entry into the SuffixRemoves list.

See getSuffixRemove() for more information.

Parameters
item an item to add a copy of into the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ clearGencodeFiles()

void clearGencodeFiles ( )

Deletes all GencodeFiles entries.

See getGencodeFile() for more information.

◆ clearNoBreakDescLineIf()

void clearNoBreakDescLineIf ( )

Deletes all NoBreakDescLineIf entries.

See getNoBreakDescLineIf() for more information.

◆ clearNodesFiles()

void clearNodesFiles ( )

Deletes all NodesFiles entries.

See getNodesFile() for more information.

◆ clearPerDbSrcRules()

void clearPerDbSrcRules ( )

Deletes all database source strings.

See getPerDbSrcRule() for more information.

◆ clearPrefixRemoves()

void clearPrefixRemoves ( )

Deletes all PrefixRemoves entries.

See getPrefixRemove() for more information.

◆ clearSpeciesFiles()

void clearSpeciesFiles ( )

Deletes all entries for SpeciesFiles.

See getSpeciesFile() for more information.

◆ clearSuffixRemoves()

void clearSuffixRemoves ( )

Deletes all SuffixRemoves entries.

See getSuffixRemove() for more information.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getAccFromSpeciesLine()

const ms_parserule * getAccFromSpeciesLine ( ) const

Returns the value of AccFromSpeciesLine.

MSDB database explicitly associates each species line with the accession string of the primary database entry. A further rule, AccFromSpeciesLine, is used to extract this accession string.

Returns
pointer to a parser rule

◆ getDBLevelTaxId()

int getDBLevelTaxId ( ) const

Returns the value of DBLevelTaxId.

Database level taxonomy ID can be specified in order to find proper NA translation table without names.dmp and nodes.dmp files usage.

Default is -1, which is not a valid taxonomy ID.

Returns
database level taxonomy id

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDefaultRule()

const ms_parserule_plus * getDefaultRule ( ) const

Returns the value of DefaultRule.

The DefaultRule describes how to find the species name in the line of text in the reference file. The string in quotes is a regular expression. All words in the PrefixRemoves and SuffixRemoves keywords should be removed before trying to do a match. For more detailed information on how to specify this parameter consult Mascot manual.

If specified, DoThisRuleFirst is applied first, and the default rule would only be used if this failed.

See also
getQuickRefSearch(), getDoThisRuleFirst(), getAccFromSpeciesLine()
Returns
pointer to a parser rule

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getDescriptionLineSep()

char getDescriptionLineSep ( ) const

Returns the value of DescriptionLineSep.

The line that contains the species IDs has multiple IDs, separated by a character, whose ASCII code is specified by DescriptionLineSep.

There is no default value for this parameter.

Returns
description line separator for this taxonomy

◆ getDoThisRuleFirst()

const ms_parserule * getDoThisRuleFirst ( ) const

Returns the value of DoThisRuleFirst.

See getDefaultRule().

Returns
a pointer to the parser rule for which to do this rule first

◆ getErrorLevel()

int getErrorLevel ( ) const

Returns the value of ErrorLevel.

ErrorLevel indicates the type of warnings or errors that are found when creating the taxonomy information. Possible values and their meanings:

  • 0 - an entry is put into the NoTaxonomyMatch.txt file for every sequence where no taxonomy information is found.
  • 1+ (severe) - an entry is put into the NoTaxonomyMatch.txt file for every sequence that had any accession string without a match. Since some sequences in NCBI will have up to 200 gi numbers (sources), there is a reasonable chance that some of these entries will not have species information, and this would cause the errors files to become very large.

Default is 1.

Returns
error level

◆ getGencodeFile()

const ms_taxnodesfiles * getGencodeFile ( const int index ) const

Returns an instance of ms_taxnodesfiles describing an entry in GencodeFiles.

The GencodeFiles file is used to find a proper NA translation table for a given taxonomy. For more detailed information on how to configure this parameter consult Mascot manual and documentation for ms_taxnodesfiles.

By default the list of files is empty.

Parameters
index file number from 0 to (getNumberOfGencodeFiles()-1).
Returns
instance of ms_taxnodesfiles class describing one of the files specified in GencodeFiles parameter of the Taxonomy section.

◆ getIdentifier()

std::string getIdentifier ( ) const

Returns the value of Identifier.

This parameter contains a symbolic name for the taxonomy specification as seen, for instance, in the database GUI utility.

By default this is empty.

Returns
identifier of the taxonomy
Examples
config_mascotdat.cpp.

◆ getNoBreakDescLineIf()

std::string getNoBreakDescLineIf ( const int index ) const

Returns a NoBreakDescLineIf entry by its number.

NoBreakDescLineIf specifies keywords that prevent description line from being broken into separate words.

By default this is an empty list.

Parameters
index number of entry from 0 to (getNumberOfNoBreakDescLineIf()-1).
Returns
a string value.

◆ getNodesFile()

const ms_taxnodesfiles * getNodesFile ( const int index ) const

Returns an instance of ms_taxnodesfiles describing an entry in NodesFiles.

The NodesFiles file is used to traverse taxonomy hierarchy. It contains taxonomy ID nodes together with their parents IDs. For more detailed information on how to configure this parameter consult Mascot manual and documentation for ms_taxnodesfiles.

By default the list of files is empty.

Parameters
index file number from 0 to (getNumberOfNodesFiles()-1).
Returns
instance of ms_taxnodesfiles class describing one of the files specified in NodesFiles parameter of the Taxonomy section.

◆ getNumberOfGencodeFiles()

int getNumberOfGencodeFiles ( ) const

Returns the number of file names specified in GencodeFiles.

See getGencodeFile() and documentation for ms_taxnodesfiles.

Returns
number of gencode files

◆ getNumberOfNoBreakDescLineIf()

int getNumberOfNoBreakDescLineIf ( ) const

Returns the number of NoBreakDescLineIf entries.

See getNoBreakDescLineIf() for explanations.

Returns
number of keywords which prevent breaking description lines

◆ getNumberOfNodesFiles()

int getNumberOfNodesFiles ( ) const

Returns the number of file names specified in NodesFiles.

See getNodesFile() and documentation for ms_taxnodesfiles.

Returns
number of nodes files

◆ getNumberOfPerDbSrcRules()

int getNumberOfPerDbSrcRules ( ) const

Returns the number of database source strings.

See getPerDbSrcRule() and documentation for ms_parserule_plus.

Returns
number of database source strings

◆ getNumberOfPrefixRemoves()

int getNumberOfPrefixRemoves ( ) const

Returns the number of PrefixRemoves entries.

See getPrefixRemove().

Returns
number of prefix removes

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getNumberOfSpeciesFiles()

int getNumberOfSpeciesFiles ( ) const

Returns the number of file names specified in SpeciesFiles.

See getSpeciesFile() and documentation for ms_taxspeciesfiles.

Returns
number of species files

◆ getNumberOfStrFiles()

int getNumberOfStrFiles ( ) const
Returns
number of taxonomy species files

◆ getNumberOfSuffixRemoves()

int getNumberOfSuffixRemoves ( ) const

Returns the number of SuffixRemoves entries.

See getSuffixRemove().

Returns
number of suffix removes

◆ getPerDbSrcRule()

const ms_parserule_plus * getPerDbSrcRule ( const int index ) const

Returns a database source string by its number.

Database source strings contained in taxonomy section all look like RULE_XXX or OTHERRULE.

By default the list of rules is empty.

Parameters
index database source string number from 0 to (getNumberOfPerDbSrcRules()-1).
Returns
pointer to a parser rule

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPrefixRemove()

std::string getPrefixRemove ( const int index ) const

Returns the PrefixRemoves string by number.

See getDefaultRule() for information on this parameter.

By default the list of prefixes is empty.

Parameters
index number of a string specified in the parameter from 0 to (getNumberOfPrefixRemoves()-1).
Returns
one of the string specifed in the parameter.

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ getQuickRefSearch()

std::string getQuickRefSearch ( ) const

Returns the value of QuickRefSearch.

The QuickRefSearch string is used to speed up the compressing of the database. Rather than use the regular expression for each line in the .ref file, this text is used for a fast compare to the string C;Species. Other lines are ignored.

By default this is empty.

Returns
quick ref search for the taxonomy rule

◆ getSpeciesFile()

const ms_taxspeciesfiles * getSpeciesFile ( const int index ) const

Returns an instance of ms_taxspeciesfiles describing an entry in SpeciesFiles.

The SpeciesFiles file is used to convert a species name to a taxonomy ID. For more detailed information on how to configure this parameter consult Mascot manual and documentation for ms_taxspeciesfiles.

By default the list is empty.

Parameters
index file number from 0 to (getNumberOfSpeciesFiles()-1).
Returns
instance of ms_taxspeciesfiles class describing one of the files specified in SpeciesFiles parameter of the Taxonomy section.

◆ getSpeciesFormatRegex()

std::string getSpeciesFormatRegex ( const TAX_SPECIES_FORMAT format ) const

Returns a regular expression, if any for the species format.

Introduced in Mascot 2.4, allows the use of a regular expression for a species file. The regular expression needs to return two values: the 'accession' or 'id' and the taxonomy_id

For example, in the Taxonomy_X section of mascot.dat, there is, for example an entry:

* SWISSPROTRegex "^\\‍([A-Z0-9]*\\‍) *[ABEV] *\\‍([0-9]*\\‍):"

which has two bracketed expressions intended to extract AADNV and 648330 from

AADNV V 648330: N=Aedes albopictus densovirus (isolate Boublik/1994)

If there is no value for SWISSPROTRegex in the mascot.dat file, then the value returned is the default as shown above.

Parameters
format can be any TAX_SPECIES_FORMAT value, although only TAX_SPECIES_SWISSPROT is currently supported in Mascot Server.
Returns
the regular expression or an empty string.

◆ getSrcDatabaseRule()

const ms_parserule * getSrcDatabaseRule ( ) const

Returns the value of SrcDatabaseRule.

The parameter is used for finding database source string with regular expression.

See also
getPerDbSrcRule()
Returns
pointer to a parser rule

◆ getStrFile()

const ms_taxspeciesfiles * getStrFile ( const int index ) const
Parameters
index file index to look for
Returns
taxonomy species file

◆ getStrRule()

const ms_parserule_plus * getStrRule ( ) const
Returns
pointer to a parser rule

◆ getSuffixRemove()

std::string getSuffixRemove ( const int index ) const

Returns a SuffixRemoves string by number.

See getDefaultRule() for information on this parameter.

By default the list of suffixes is empty.

Parameters
index number of a string specified in the parameter from 0 to (getNumberOfSuffixRemoves()-1).
Returns
one of the string specifed in the parameter.

◆ isConcatRefFileLines()

bool isConcatRefFileLines ( ) const

Returns TRUE if ConcatRefFileLines parameter is set to 1 and FALSE otherwise.

A value of 1 (default) means that there might be multiple lines in reference file describing the same entry of the database.

See also
isFromRefFile(), getDescriptionLineSep().
Returns
true is ConcatRefFileLines equals 1, false otherwise

◆ isEnabled()

bool isEnabled ( ) const

Returns TRUE if Enabled parameter is set to 1 and FALSE otherwise.

Set Enabled parameter to 0 to disable the taxonomy. Most of the other parameters will be ignored although the taxonomy will be available for a database to select in database maintenance utility.

Default is 0.

Returns
true if taxonomy rules are enabled, false otherwise

◆ isFromRefFile()

bool isFromRefFile ( ) const

Returns TRUE if FromRefFile parameter is set to 1 and FALSE otherwise.

FromRefFile is set to 0 to indicate that the taxonomy should be found in the .fasta file rather than in a reference file.

Default is 0.

See also
isConcatRefFileLines(), getDescriptionLineSep().
Returns
true if the taxonomy should be found in the fasta file, false otherwise

◆ isMitochondrialTranslation()

bool isMitochondrialTranslation ( ) const

Returns TRUE if MitochondrialTranslation parameter is set to 1 and FALSE otherwise.

Two types of NA translation tables can be used: nuclear and mitochondrial. Setting this parameter to 0 indicates the first type whereas 1 indicates the second one.

Default is 0.

Returns
true if NA translation tables used are mitochondrial, false if they are nuclear

◆ isSectionAvailable()

bool isSectionAvailable ( ) const

Checks whether the section has been actually read from the file.

By default a Taxonomy section is unavailable until it has been set to a different state.

Returns
true if the section has been set to available

◆ setAccFromSpeciesLine()

void setAccFromSpeciesLine ( const ms_parserule * src )

Change the value of AccFromSpeciesLine.

See getAccFromSpeciesLine() for more information.

Parameters
src pointer to a parser rule

◆ setConcatRefFileLines()

void setConcatRefFileLines ( const bool flag )

Change the value of ConcatRefFileLines.

See isConcatRefFileLines() for more information.

Parameters
flag boolean value to set whether there might be multiple lines for the same entry

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setDefaultRule()

void setDefaultRule ( const ms_parserule_plus * src )

Change the value of DefaultRule.

See getDefaultRule().

Parameters
src pointer to a parser rule

◆ setDescriptionLineSep()

void setDescriptionLineSep ( const char value )

Change the value of DescriptionLineSep.

See getDescriptionLineSep() for more information.

Parameters
value description line separator

◆ setDoThisRuleFirst()

void setDoThisRuleFirst ( const ms_parserule * src )

Change the value of DoThisRuleFirst.

See getDoThisRuleFirst().

Parameters
src pointer to a parser rule for which it should do this rule first

◆ setEnabled()

void setEnabled ( const bool flag )

Change the value of Enabled.

See isEnabled() for more information.

Parameters
flag whether the taxonomy rules are enabled or not

◆ setErrorLevel()

void setErrorLevel ( const int value )

Change the value of ErrorLevel.

See getErrorLevel() for more information.

Parameters
value error level

◆ setFromRefFile()

void setFromRefFile ( const bool flag )

Change the value of FromRefFile.

See isFromRefFile() for more information.

Parameters
flag boolean value to define if the taxonomy should be found in the fasta file

◆ setIdentifier()

void setIdentifier ( const char * str )

Change the value of Identifier.

For more information see getIdentifier().

Parameters
str identifier for the taxonomy

◆ setMitochondrialTranslation()

void setMitochondrialTranslation ( const bool flag )

Set the value of MitochondrialTranslation.

See isMitochondrialTranslation().

Parameters
flag true if NA translation tables used are mitochondrial, false if they are nuclear

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ setQuickRefSearch()

void setQuickRefSearch ( const char * str )

Change the value of QuickRefSearch.

See getQuickRefSearch().

Parameters
str string used to speed up database compression

◆ setSpeciesFormatRegex()

void setSpeciesFormatRegex | ( | const TAX_SPECIES_FORMAT | format,
 |  | const std::string | regex
 | ) |  |

Set the regular expression, if any, for the species format.

Instroduced in Mascot 2.4, allows the use of a regular expression for a species file. The regular expression needs to return two values: the 'accession' or 'id' and the taxonomy_id

For example, in the Taxonomy_X section of mascot.dat, there is, for example an entry:

* SWISSPROTRegex "^\\‍([A-Z0-9]*\\‍) *[ABEV] *\\‍([0-9]*\\‍):"

which has two bracketed expressions intended to extract AADNV and 648330 from

AADNV V 648330: N=Aedes albopictus densovirus (isolate Boublik/1994)
Parameters
format | can be any TAX_SPECIES_FORMAT value, although only TAX_SPECIES_SWISSPROT is currently supported in Mascot Server.
regex | is the new regular expression or an empty string.

◆ setSrcDatabaseRule()

void setSrcDatabaseRule ( const ms_parserule * src )

Change the value of SrcDatabaseRule.

See getSrcDatabaseRule().

Parameters
src pointer to a parser rule

◆ setStrRule()

void setStrRule ( const ms_parserule_plus * src )
Parameters
src pointer to a parser str rule

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_taxonomyrules.hpp
  • ms_taxonomyrules.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_taxonomytree Class Reference

  • matrix_science
  • ms_taxonomytree
Public Member Functions | List of all members
ms_taxonomytree Class Reference
Mascot configuration files module

The complete taxonomy tree as built from one or more files such as nodes.dmp. More...

#include <ms_taxonomyrules.hpp>

Inheritance diagram for ms_taxonomytree:
[legend]
Collaboration diagram for ms_taxonomytree:
[legend]

Public Member Functions

ms_taxonomytree (const ms_taxonomyrules *taxonomyRules, const char *taxonomyDirectory="../taxonomy", const bool useIndex=true, const bool createList=false, const char *preparingDirectory="../taxonomy/preparing", const char *oldDirectory="../taxonomy/old")
Create a taxonomy tree based on the rules specified in mascot.dat.
ms_taxonomytree (const ms_taxonomytree &src)
Copying constructor.
~ms_taxonomytree ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_taxonomytree *right)
Can be used to create a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getParent (const int id, int &ttParent, int &ttGenTable) const
Return the parent id and translation table id for a species.
TAX_TREE_NODES * | getTaxIDArray ()
Return a raw array of TAX_TREE_NODE values, with the array index being the id.
bool | isIncludedIn (const int id, const ms_taxonomychoice *choice) const
Return true if the taxonomy id is included in the choice.
bool | isSpeciesDescendantOf (const int parentID, const int id) const
Determine if a particular id is a child of the parentID.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_taxonomytree & | operator= (const ms_taxonomytree &right)
Assignment operator for C++ client applications.

Detailed Description

The complete taxonomy tree as built from one or more files such as nodes.dmp.

Used for determining the taxonomy lineage. This class is used to load all of the files specified in a specified taxonomy section in mascot.dat, for example:

NodesFiles          NCBI:nodes.dmp, NCBI:merged.dmp

Index files are created using ms_tinycdb to improve performance in cases where a moderate number of parent id's are required. Index files are created in the same directory as the text files, with an additional 'extension' of ".cdb". Error or warning messages in ms_tinycdb are concatenated into the ms_taxonomytree object. If, for example, the process does not have write access to the directory with the taxonomy files , then an error ms_errs:: is generated, but the object is still valid and will continue with just the text files.

Other possible errors include: ms_errs::ERR_MSP_TAXONOMY_CONFLICT_PARENTS ms_errs::ERR_MSP_TAXONOMY_INVALID_NODE_FILE ms_errs::ERR_MSP_TAXONOMY_MISSING_NODE_FILE

The nodes.dmp file also contains the genetic code translation table id to be used when translating from nucleic acid to protein.

Example code to see if Homo Sapiens (9606) are mammals (40674):

my $datfile = new msparser::ms_datfile("../config/mascot.dat");
my $taxonomy_rules = $datfile->getTaxonomyRules(3);
my $tree = new msparser::ms_taxonomytree($taxonomy_rules);
if ($tree->isValid()) {
  my $human = 9606;
  my $mammalia = 40674;
  if ($tree->isSpeciesDescendantOf($mammalia, $human)) {
    print "Indeed, we are mammals\n";
  }
}

Constructor & Destructor Documentation

◆ ms_taxonomytree()

ms_taxonomytree | ( | const ms_taxonomyrules * | taxonomyRules,
 |  | const char * | taxonomyDirectory = "../taxonomy",
 |  | const bool | useIndex = true,
 |  | const bool | createList = false,
 |  | const char * | preparingDirectory = "../taxonomy/preparing",
 |  | const char * | oldDirectory = "../taxonomy/old"
 | ) |  |

Create a taxonomy tree based on the rules specified in mascot.dat.

The complete taxonomy tree as built from one or more files such as nodes.dmp

Parameters
taxonomyRules | contains the list of NodesFiles specified in the taxonomy section of mascot.dat. These files are all loaded by this constructor. The names are retrieved using ms_taxonomyrules::getNodesFile
taxonomyDirectory | specifies the directory to look in for the files. The names in mascot.dat do not normally include path information since the files are generally in the ../taxonomy directory
useIndex | will normally be set to true. If just a handful of 'parent ids' are required, then it is most efficient to use the index files. See getTaxIDArray() for a situation where this should be set to false.
createList | will normally be set to false. It is used to create the list of nodes in memory even if the cache file is used.
preparingDirectory | optional parameter to specify a directory to look for new files and create temporary index files. Once the index files have been created, the new file and the created index files are moved to taxonomyDirectory. If this parameter is an empty string, or if there are no taxonomy files in this directory, new files will be looked for in taxonomyDirectory instead, and the index files will be created directly in taxonomyDirectory.
oldDirectory | optional parameter to archive existing files once index files have been created for a new file. If this parameter is an empty string, no archiving will be done.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_taxonomytree * right )

Can be used to create a copy of another instance.

Useful from Perl or scripting languages

Parameters
right is the object to copy from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getParent()

bool getParent | ( | const int | id,
 |  | int & | ttParent,
 |  | int & | ttGenTable
 | ) |  | const

Return the parent id and translation table id for a species.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | id | is the NCBI taxonomy id for which to find the parent and translation table.
[out] | ttParent | is the parent id. This will be set to 0 if an entry is not found for id.
[out] | ttGenTable | is the genetic code translation table to be used for converting nucleic acid sequences to protein sequences.
Returns
false if the id is < 1 or greater than the number of entries or if the id is not found in any of the tables.

◆ getTaxIDArray()

ms_taxonomytree::TAX_TREE_NODES * getTaxIDArray ( )

Return a raw array of TAX_TREE_NODE values, with the array index being the id.

This function will only return a non zero value if the useIndex value passed to the constructor is set to false.

The calling function should not call delete on the pointer. The vector is deleted when the ms_taxonomytree object is deleted.

Returns
a pointer to the taxonomy tree nodes or NULL

◆ isIncludedIn()

bool isIncludedIn | ( | const int | id,
 |  | const ms_taxonomychoice * | choice
 | ) |  | const

Return true if the taxonomy id is included in the choice.

For example, take the definition of "Other Mammalia":

  Title:. . . . . . . . . . . . . . Other mammalia
  Include: 40674
  Exclude: 9443, 9989

If you pass 9606 (Human) and a choice of "Other Mammalia", this function would return false, because in this case, 9606 is part of 9443 (Primates).

Parameters
id | is the taxonomy id
choice | is the return from calling ms_taxonomyfile::getEntryByName
Returns
true if taxonomy id is included in taxonomy choice, false otherwise

◆ isSpeciesDescendantOf()

bool isSpeciesDescendantOf | ( | const int | parentID,
 |  | const int | id
 | ) |  | const

Determine if a particular id is a child of the parentID.

Parameters
parentID | is the taxonomy id of the parent
id | is the taxonomy id to be tested
Returns
true if the taxonomy is a descendent of the parentID

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_taxonomytree & operator= ( const ms_taxonomytree & right )

Assignment operator for C++ client applications.

Cannot be used from scripting languages

Parameters
right is the object to copy from
Returns
a reference to 'this'
The documentation for this class was generated from the following files:
  • ms_taxonomyrules.hpp
  • ms_taxonomyrules.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_taxspeciesfiles Class Reference

  • matrix_science
  • ms_taxspeciesfiles
Public Member Functions | List of all members
ms_taxspeciesfiles Class Reference
Mascot configuration files module

An instance of this class describes one entry of taxonomy species files. More...

#include <ms_taxonomyrules.hpp>

Public Member Functions

ms_taxspeciesfiles ()
Default constructor.
ms_taxspeciesfiles (const ms_taxspeciesfiles &src)
Copying constructor.
~ms_taxspeciesfiles ()
Destructor.
void | copyFrom (const ms_taxspeciesfiles *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance.
std::string | getFileName () const
Returns the file name.
TAX_SPECIES_FORMAT | getFormat () const
Returns a format identifier for the entry.
ms_taxspeciesfiles & | operator= (const ms_taxspeciesfiles &right)
Assignment operator for C++ client applications.
void | setFileName (const char *name)
Change the file name.
void | setFormat (const TAX_SPECIES_FORMAT value)
Change the format of the entry.

Detailed Description

An instance of this class describes one entry of taxonomy species files.

The documentation for this class was generated from the following files:
  • ms_taxonomyrules.hpp
  • ms_taxonomyrules.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_aminoacid Class Reference

  • matrix_science
  • ms_umod_aminoacid
Public Member Functions | List of all members
ms_umod_aminoacid Class Reference
Mascot configuration files module

Represents an "amino acid" object in unimod.xml. More...

#include <ms_umod_aminoacid.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_umod_aminoacid ()
Default constructor.
ms_umod_aminoacid (const ms_umod_aminoacid &src)
Copying constructor.
virtual | ~ms_umod_aminoacid ()
Destructor.
void | appendElemRef (const ms_umod_elemref *elemref)
Adds a new element reference object at the end of the list.
void | clearElemRefs ()
Deletes all element reference objects from the list.
void | copyFrom (const ms_umod_aminoacid *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElemRef (const int idx)
Remove an element reference object from the list in memory.
void | dropAvgeMass ()
Delete the avge_mass attribute.
void | dropFullName ()
Delete the full_name attribute.
void | dropMonoMass ()
Delete the mono_mass attribute.
void | dropThreeLetter ()
Delete the three_letter attribute.
void | dropTitle ()
Delete the title attribute.
double | getAvgeMass () const
Returns the value of the avge_mass attribute.
std::string | getAvgeMassSchemaType () const
Obtain a symbolic name for the avge_mass attribute schema type.
const ms_umod_elemref * | getElemRef (const int idx) const
Returns a read-only pointer to an element reference object by its number.
std::string | getElemRefSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getFullName () const
Returns the value of the full_name attribute.
std::string | getFullNameSchemaType () const
Obtain a symbolic name for the full_name attribute schema type.
double | getMonoMass () const
Returns the value of the mono_mass attribute.
std::string | getMonoMassSchemaType () const
Obtain a symbolic name for the mono_mass attribute schema type.
int | getNumberOfElemRefs () const
Returns a number of element reference objects currently held in memory.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getThreeLetter () const
Returns the value of the three_letter attribute.
std::string | getThreeLetterSchemaType () const
Obtain a symbolic name for the three_letter attribute schema type.
std::string | getTitle () const
Returns the value of the title attribute.
std::string | getTitleSchemaType () const
Obtain a symbolic name for the title attribute schema type.
bool | haveAvgeMass () const
Indicates presence of the avge_mass attribute.
bool | haveFullName () const
Indicates presence of the full_name attribute.
bool | haveMonoMass () const
Indicates presence of the mono_mass attribute.
bool | haveThreeLetter () const
Indicates presence of the three_letter attribute.
bool | haveTitle () const
Indicates presence of the title attribute.
ms_umod_aminoacid & | operator= (const ms_umod_aminoacid &right)
C++ style assignment operator.
void | setAvgeMass (const double value)
Set a custom value for the avge_mass attribute.
void | setFullName (const char *value)
Set a custom value for the full_name attribute.
void | setMonoMass (const double value)
Set a custom value for the mono_mass attribute.
void | setThreeLetter (const char *value)
Set a custom value for the three_letter attribute.
void | setTitle (const char *value)
Set a custom value for the title attribute.
bool | updateElemRef (const int idx, const ms_umod_elemref *elemref)
Update the information for a particular element reference object.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents an "amino acid" object in unimod.xml.

Constructor & Destructor Documentation

◆ ms_umod_aminoacid() [1/2]

ms_umod_aminoacid ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_umod_aminoacid() [2/2]

ms_umod_aminoacid ( const ms_umod_aminoacid & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendElemRef()

void appendElemRef ( const ms_umod_elemref * elemref )

Adds a new element reference object at the end of the list.

Creates a new element reference object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters
elemref an instance of element reference object to copy the content from.

◆ clearElemRefs()

void clearElemRefs ( )

Deletes all element reference objects from the list.

Deletes all element references from the list

◆ copyFrom()

void copyFrom ( const ms_umod_aminoacid * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteElemRef()

bool deleteElemRef ( const int idx )

Remove an element reference object from the list in memory.

Parameters
idx number of the element reference for deletion from 0 to (getNumberOfElemRefs() - 1).
Returns
TRUE if the object has been found and successfully deleted and FALSE otherwise.

◆ dropAvgeMass()

void dropAvgeMass ( )

Delete the avge_mass attribute.

Deletes the attribute until is re-set.

◆ dropFullName()

void dropFullName ( )

Delete the full_name attribute.

Deletes the attribute until it is re-set.

◆ dropMonoMass()

void dropMonoMass ( )

Delete the mono_mass attribute.

Deletes the attribute until is re-set.

◆ dropThreeLetter()

void dropThreeLetter ( )

Delete the three_letter attribute.

Deletes the attribute until it is re-set.

◆ dropTitle()

void dropTitle ( )

Delete the title attribute.

Deletes the attribute until it is re-set.

◆ getAvgeMass()

double getAvgeMass ( ) const

Returns the value of the avge_mass attribute.

Average mass for the amino acid.

Returns
current value of the attribute.

◆ getAvgeMassSchemaType()

std::string getAvgeMassSchemaType ( ) const

Obtain a symbolic name for the avge_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getElemRef()

const ms_umod_elemref * getElemRef ( const int idx ) const

Returns a read-only pointer to an element reference object by its number.

Retrieves an element reference object from the list by its number.

Parameters
idx number of the reference from 0 to (getNumberOfElemRefs() - 1).
Returns
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.

◆ getElemRefSchemaType()

std::string getElemRefSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getFullName()

std::string getFullName ( ) const

Returns the value of the full_name attribute.

A full name for the amino acid.

Returns
current value of the attribute.

◆ getFullNameSchemaType()

std::string getFullNameSchemaType ( ) const

Obtain a symbolic name for the full_name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMonoMass()

double getMonoMass ( ) const

Returns the value of the mono_mass attribute.

Monoisotopic mass for the amino acid.

Returns
current value of the attribute.

◆ getMonoMassSchemaType()

std::string getMonoMassSchemaType ( ) const

Obtain a symbolic name for the mono_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfElemRefs()

int getNumberOfElemRefs ( ) const

Returns a number of element reference objects currently held in memory.

Returns
total number of chemical element references in the modification object

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType").

◆ getThreeLetter()

std::string getThreeLetter ( ) const

Returns the value of the three_letter attribute.

A three-letter name for the amino acid.

Returns
current value of the attribute.

◆ getThreeLetterSchemaType()

std::string getThreeLetterSchemaType ( ) const

Obtain a symbolic name for the three_letter attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getTitle()

std::string getTitle ( ) const

Returns the value of the title attribute.

A unique name for the amino acid.

Returns
current value of the attribute.

◆ getTitleSchemaType()

std::string getTitleSchemaType ( ) const

Obtain a symbolic name for the title attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveAvgeMass()

bool haveAvgeMass ( ) const

Indicates presence of the avge_mass attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveFullName()

bool haveFullName ( ) const

Indicates presence of the full_name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveMonoMass()

bool haveMonoMass ( ) const

Indicates presence of the mono_mass attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveThreeLetter()

bool haveThreeLetter ( ) const

Indicates presence of the three_letter attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveTitle()

bool haveTitle ( ) const

Indicates presence of the title attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_umod_aminoacid & operator= ( const ms_umod_aminoacid & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAvgeMass()

void setAvgeMass ( const double value )

Set a custom value for the avge_mass attribute.

Parameters
value a new value for the attribute.

◆ setFullName()

void setFullName ( const char * value )

Set a custom value for the full_name attribute.

Parameters
value a new value for the attribute.

◆ setMonoMass()

void setMonoMass ( const double value )

Set a custom value for the mono_mass attribute.

Parameters
value a new value for the attribute.

◆ setThreeLetter()

void setThreeLetter ( const char * value )

Set a custom value for the three_letter attribute.

Parameters
value a new value for the attribute.

◆ setTitle()

void setTitle ( const char * value )

Set a custom value for the title attribute.

Parameters
value a new value for the attribute.

◆ updateElemRef()

bool updateElemRef | ( | const int | idx,
 |  | const ms_umod_elemref * | elemref
 | ) |  |

Update the information for a particular element reference object.

Parameters
idx | number of the element reference for updating from 0 to (getNumberOfElemRefs() - 1).
elemref | an object to copy the content from.
Returns
TRUE if the element reference has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_aminoacid.hpp
  • ms_umod_aminoacid.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_composition Class Reference

  • matrix_science
  • ms_umod_composition
Public Member Functions | List of all members
ms_umod_composition Class Reference
Mascot configuration files module

Represents the composition type in unimod.xml. More...

#include <ms_umod_composition.hpp>

Inheritance diagram for ms_umod_composition:
[legend]

Public Member Functions

ms_umod_composition ()
Default constructor.
ms_umod_composition (const ms_quant_composition &src, const ms_umod_configfile &umodFile)
Copying constructor.
ms_umod_composition (const ms_umod_composition &src)
Copying constructor.
virtual | ~ms_umod_composition ()
Destructor.
void | appendElemRef (const ms_umod_elemref *elemref)
Adds a new element reference object at the end of the list.
void | clearElemRefs ()
Deletes all element reference objects from the list.
void | copyFrom (const ms_quant_composition *right, const ms_umod_configfile &umodFile)
Copies all content from another object.
void | copyFrom (const ms_umod_composition *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElemRef (const int idx)
Remove an element reference object from the list in memory.
void | dropAvgeMass ()
Delete the avge_mass attribute.
void | dropCompositionString ()
Delete the composition attribute.
void | dropMonoMass ()
Delete the mono_mass attribute.
double | getAvgeMass () const
Returns the value of the avge_mass attribute.
std::string | getAvgeMassSchemaType () const
Obtain a symbolic name for the avge_mass attribute schema type.
std::string | getCompositionString () const
Returns the value of the composition attribute.
std::string | getCompositionStringSchemaType () const
Obtain a symbolic name for the composition attribute schema type.
const ms_umod_elemref * | getElemRef (const int idx) const
Returns a read-only pointer to an element reference object by its number.
std::string | getElemRefSchemaType () const
Obtain a symbolic name for the element's schema type.
double | getMonoMass () const
Returns the value of the mono_mass attribute.
std::string | getMonoMassSchemaType () const
Obtain a symbolic name for the mono_mass attribute schema type.
int | getNumberOfElemRefs () const
Returns the number of element reference objects currently held in memory.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveAvgeMass () const
Indicates presence of the avge_mass attribute.
bool | haveCompositionString () const
Indicates presence of the composition attribute.
bool | haveMonoMass () const
Indicates presence of the mono_mass attribute.
bool | isSameAs (const ms_umod_composition &right) const
Returns true if instances contain the same information.
ms_umod_composition & | operator= (const ms_umod_composition &right)
C++ style assignment operator.
void | setAvgeMass (const double value)
Set a custom value for the avge_mass attribute.
void | setCompositionString (const char *value)
Set a custom value for the composition attribute.
void | setMonoMass (const double value)
Set a custom value for the mono_mass attribute.
bool | updateElemRef (const int idx, const ms_umod_elemref *elemref)
Update the information for a particular element reference object.
void | updateMasses (const ms_umod_configfile &umodFile, const ms_quant_component &quantComp)
Recalculates all deltas with isotope substitution according to selected component in quantification.xml.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents the composition type in unimod.xml.

This type is used for modification delta and ignore elements in unimod.xml.

Constructor & Destructor Documentation

◆ ms_umod_composition() [1/3]

ms_umod_composition ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_umod_composition() [2/3]

ms_umod_composition ( const ms_umod_composition & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

◆ ms_umod_composition() [3/3]

ms_umod_composition | ( | const ms_quant_composition & | src,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copying constructor.

Parameters
src | another object to copy the content from.
umodFile | an instance of a Unimod file object to extract element masses.

Member Function Documentation

◆ appendElemRef()

void appendElemRef ( const ms_umod_elemref * elemref )

Adds a new element reference object at the end of the list.

Creates a new element reference object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters
elemref an instance of element reference object to copy the content from.

◆ copyFrom() [1/2]

void copyFrom | ( | const ms_quant_composition * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copies all content from another object.

Parameters
right | another object to copy the content from.
umodFile | a Unimod file object to obtain element masses from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_umod_composition * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

This will reset all internal values to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteElemRef()

bool deleteElemRef ( const int idx )

Remove an element reference object from the list in memory.

Parameters
idx number of the element reference for deletion from 0 to (getNumberOfElemRefs() - 1).
Returns
TRUE if the object has been found and successfully deleted and FALSE otherwise.

◆ dropAvgeMass()

void dropAvgeMass ( )

Delete the avge_mass attribute.

Deletes the attribute until is re-set.

◆ dropCompositionString()

void dropCompositionString ( )

Delete the composition attribute.

Deletes the attribute until it is re-set.

◆ dropMonoMass()

void dropMonoMass ( )

Delete the mono_mass attribute.

Deletes the attribute until is re-set.

◆ getAvgeMass()

double getAvgeMass ( ) const

Returns the value of the avge_mass attribute.

Average mass for the object.

Returns
current value of the attribute.

◆ getAvgeMassSchemaType()

std::string getAvgeMassSchemaType ( ) const

Obtain a symbolic name for the avge_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getCompositionString()

std::string getCompositionString ( ) const

Returns the value of the composition attribute.

A composition string for the object.

Returns
current value of the attribute.

◆ getCompositionStringSchemaType()

std::string getCompositionStringSchemaType ( ) const

Obtain a symbolic name for the composition attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getElemRef()

const ms_umod_elemref * getElemRef ( const int idx ) const

Returns a read-only pointer to an element reference object by its number.

Retrieves an element reference object from the list by its number.

Parameters
idx number of the reference from 0 to (getNumberOfElemRefs() - 1).
Returns
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.

◆ getElemRefSchemaType()

std::string getElemRefSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMonoMass()

double getMonoMass ( ) const

Returns the value of the mono_mass attribute.

Monoisotopic mass for the object.

Returns
current value of the attribute.

◆ getMonoMassSchemaType()

std::string getMonoMassSchemaType ( ) const

Obtain a symbolic name for the mono_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfElemRefs()

int getNumberOfElemRefs ( ) const

Returns the number of element reference objects currently held in memory.

Returns
total number of chemical element references in the composition object.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType").

Reimplemented in ms_umod_neutralloss.

◆ haveAvgeMass()

bool haveAvgeMass ( ) const

Indicates presence of the avge_mass attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveCompositionString()

bool haveCompositionString ( ) const

Indicates presence of the composition attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveMonoMass()

bool haveMonoMass ( ) const

Indicates presence of the mono_mass attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ isSameAs()

bool isSameAs ( const ms_umod_composition & right ) const

Returns true if instances contain the same information.

Compares the element symbols and number of symbols that make up the composition regardless of storage order. Element symbols may be specified in the composition but have a count of zero and so do not affect the total mass values.

Parameters
right another instance of this class to compare.
Returns
true if the two compositions are equivalent.

◆ operator=()

ms_umod_composition & operator= ( const ms_umod_composition & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAvgeMass()

void setAvgeMass ( const double value )

Set a custom value for the avge_mass attribute.

Parameters
value a new value for the attribute.

◆ setCompositionString()

void setCompositionString ( const char * value )

Set a custom value for the composition attribute.

Parameters
value a new value for the attribute.

◆ setMonoMass()

void setMonoMass ( const double value )

Set a custom value for the mono_mass attribute.

Parameters
value a new value for the attribute.

◆ updateElemRef()

bool updateElemRef | ( | const int | idx,
 |  | const ms_umod_elemref * | elemref
 | ) |  |

Update the information for a particular element reference object.

Parameters
idx | number of the element reference for updating from 0 to (getNumberOfElemRefs() - 1).
elemref | an object to copy the content from.
Returns
TRUE if the element reference has been found and successfully updated and FALSE otherwise.

◆ updateMasses()

void updateMasses | ( | const ms_umod_configfile & | umodFile,
 |  | const ms_quant_component & | quantComp
 | ) |  |

Recalculates all deltas with isotope substitution according to selected component in quantification.xml.

The method updates masses according to the selected isotope substitution. Masses are recalculated only in the current modification object, not in the whole Unimod file object umodFile. The Unimod file object is used only to retrieve masses of elements and their isotopes.

Parameters
umodFile | Unimod file object.
quantComp | component object from quantitation.xml.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_umod_neutralloss.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_umod_neutralloss.

The documentation for this class was generated from the following files:
  • ms_umod_composition.hpp
  • ms_umod_composition.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_configfile Class Reference

  • matrix_science
  • ms_umod_configfile
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_umod_configfile Class Reference
Mascot configuration files module

This class represents the file unimod.xml. More...

#include <ms_umod_configfile.hpp>

Inheritance diagram for ms_umod_configfile:
[legend]
Collaboration diagram for ms_umod_configfile:
[legend]

Public Types

enum MODFILE_FLAGS {
MODFILE_FLAGS_EMPTY = 0x00000000 ,
MODFILE_FLAGS_REGULAR = 0x00000001 ,
MODFILE_FLAGS_HIDDEN = 0x00000002 ,
MODFILE_FLAGS_AASUBST = 0x00000004 ,
MODFILE_FLAGS_ALL = 0x7FFFFFFF
}
Flags for the type of modifications to retrieve. More...

Public Member Functions

ms_umod_configfile ()
Default constructor.
ms_umod_configfile (const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0, bool useSchema=true)
Immediate action constructor that reads the XML file with the given name.
ms_umod_configfile (const ms_umod_configfile &right)
Copying constructor.
virtual | ~ms_umod_configfile ()
Desctructor.
void | appendAminoAcid (const ms_umod_aminoacid *aa)
Adds a new amino acid at the end of the list.
void | appendElement (const ms_umod_element *elem)
Adds a new element at the end of the list.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | appendModBrick (const ms_umod_modbrick *brick)
Adds a new modification brick at the end of the list.
void | appendModification (const ms_umod_modification *mod)
Adds a new modification at the end of the list.
void | applyVisibility (const ms_session *session)
If visibility settings are present for this file and session then apply to the currently loaded list of modifications.
void | applyVisibility (const std::vector< int > &groupIds)
If visibility settings are present for this file and these group ids, then apply to the currently loaded list of modifications.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearAminoAcids ()
Deletes all amino acids from the list.
void | clearElements ()
Deletes all elements from the list.
void | clearModBricks ()
Deletes all modification bricks from the list.
void | clearModifications ()
Deletes all modifications from the list.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_umod_configfile *right)
Copies all the information from another instance.
virtual void | defaultValues ()
Re-initialises the instance.
bool | deleteAminoAcidByName (const char *name)
Remove an amino acid from the list in memory.
bool | deleteAminoAcidByNumber (const int idx)
Remove an amino acid from the list in memory.
bool | deleteElementByName (const char *name)
Remove an element from the list in memory.
bool | deleteElementByNumber (const int idx)
Remove an element from the list in memory.
bool | deleteModBrickByName (const char *name)
Remove a modification brick from the list in memory.
bool | deleteModBrickByNumber (const int idx)
Remove a modification brick from the list in memory.
bool | deleteModificationByName (const char *name)
Remove a modification from the list in memory.
bool | deleteModificationByNumber (const int idx)
Remove a modification from the list in memory.
int | findModFileName (const char *modFileName) const
Returns modification index by its mod_file-style name (like "Acetyl (K)").
int | findModification (const char *modName) const
Retrieves modification index by its plain name.
const ms_umod_aminoacid * | getAminoAcidByName (const char *name) const
Returns an amino acid object by its name or NULL in case of not found.
const ms_umod_aminoacid * | getAminoAcidByNumber (const int idx) const
Returns an amino acid object by its number.
ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_umod_element * | getElementByName (const char *name) const
Returns an element object by its name or NULL in case of not found.
const ms_umod_element * | getElementByNumber (const int idx) const
Returns an element object by its number.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns the current file name.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getMajorVersion () const
Returns major document schema version as read from the file, otherwise the latest.
std::string | getMinorVersion () const
Returns minor document schema version as read from the file, otherwise the latest.
const ms_umod_modbrick * | getModBrickByName (const char *name) const
Returns a modification brick object by its name or NULL in case of not found.
const ms_umod_modbrick * | getModBrickByNumber (const int idx) const
Returns an modification brick object by its number.
std::vector< std::string > | getModFileList (const unsigned int flags=MODFILE_FLAGS_ALL) const
Returns an ordered list of modification names in mod_file-style, i.e. "Acetyl (K)" instead of "Acetyl".
const ms_umod_modification * | getModificationByName (const char *name) const
Returns a modification object by its name or NULL in case of not found.
const ms_umod_modification * | getModificationByNumber (const int idx) const
Returns a modification object by its number.
int | getNumberOfAminoAcids () const
Returns a number of amino acids currently held in memory.
int | getNumberOfElements () const
Returns a number of elements currently held in memory.
int | getNumberOfModBricks () const
Returns a number of modification bricks currently held in memory.
int | getNumberOfModifications () const
Returns a number of modifications currently held in memory.
std::string | getSchemaFileName () const
Returns the current schema file name that is used to validate the XML file.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_umod_configfile & | operator= (const ms_umod_configfile &right)
Assignment operator for C++ applications.
void | read_buffer (const char *buffer)
Reads configuration information from a string buffer.
void | read_file ()
Reads configuration information from the XML file.
std::string | save_buffer (bool validateAgainstSchema=true)
Creates a string representation of the XML document with all the content of the object.
void | save_file ()
Saves configuration information in the XML file (not mod_file).
void | setConnectionSettings (const ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *filename)
Changes the file name for subsequent read/write operations (do not use it for saving in a mod_file!).
void | setMajorVersion (const std::string &version)
Update the major document schema version.
void | setMinorVersion (const std::string &version)
Update the minor document schema version.
void | setSchemaFileName (const char *name)
Call this member to specify a custom schema file name for validating the XML file.
bool | updateAminoAcidByName (const char *name, const ms_umod_aminoacid *aa)
Update the information for a specific amino acid.
bool | updateAminoAcidByNumber (const int idx, const ms_umod_aminoacid *aa)
Update the information for a specific amino acid.
bool | updateElementByName (const char *name, const ms_umod_element *element)
Update the information for a specific element.
bool | updateElementByNumber (const int idx, const ms_umod_element *element)
Update the information for a specific element.
void | updateMasses ()
Recalculates all masses derived from elements (brick masses, modification deltas etc.).
bool | updateModBrickByName (const char *name, const ms_umod_modbrick *brick)
Update the information for a specific modification brick.
bool | updateModBrickByNumber (const int idx, const ms_umod_modbrick *brick)
Update the information for a specific modification brick.
bool | updateModificationByName (const char *name, const ms_umod_modification *mod)
Update the information for a specific modification.
bool | updateModificationByNumber (const int idx, const ms_umod_modification *mod)
Update the information for a specific modification.
std::string | validateDocument () const
Validates the whole document against schema and returns errors as a string.

Static Public Member Functions

static std::string getDefaultSchemaFileName ()
Returns the default schema filename (no path)

Detailed Description

This class represents the file unimod.xml.

The Unimod file comprises chemical elements, amino-acids and modifications. The file can be created from scratch, read from a disk file or retrieved from a remote location (HTTP) and then saved as a mod_file or another unimod.xml.

After reading a file and before using the object check validity by calling isValid() and retrieve error descriptions with getLastErrorString() if not valid. Similarly, after writing out the file, isValid() can be used to check if the file has been created correctly and is valid for further use.

Member Enumeration Documentation

◆ MODFILE_FLAGS

enum MODFILE_FLAGS

Flags for the type of modifications to retrieve.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

The result of combining these flags is a union of modifications sets.

Enumerator
MODFILE_FLAGS_EMPTY | Default behaviour (regular modifications only).
MODFILE_FLAGS_REGULAR | Non-hidden modifications which are not AA-substitutions.
MODFILE_FLAGS_HIDDEN | Hidden modifications which are not AA-substitutions.
MODFILE_FLAGS_AASUBST | AA substitutions.
MODFILE_FLAGS_ALL | Get all modifications.

Constructor & Destructor Documentation

◆ ms_umod_configfile() [1/2]

ms_umod_configfile | ( | const char * | fileName,
 |  | const char * | schemaFileName,
 |  | const ms_connection_settings * | cs = 0,
 |  | bool | useSchema = true
 | ) |  |

Immediate action constructor that reads the XML file with the given name.

An instance of this class is normally created using this form of the constructor.

Parameters
fileName | represents either local file name (for example, "C:/unimod.xml") or a fully formed URL such as http://www.matrixscience.com/cgi . The filename may use backslashes or forward slashes on Windows and spaces in file or directory names are allowed.
schemaFileName | is a local file name for the schema (for example, "C:/unimod_2.xsd"). The schema must be a local file – it cannot be accessed using HTTP. The schema filename may use backslashes or forward slashes on Windows and spaces in file or directory names are allowed.
cs | a connection settings object for downloading the file from a Mascot server. This should contain a sessionID and optionally the proxy server settings. For a local file cs is not required and will be ignored.
useSchema | specify whether it should use a xsd schema validator, true by default

◆ ms_umod_configfile() [2/2]

ms_umod_configfile ( const ms_umod_configfile & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendAminoAcid()

void appendAminoAcid ( const ms_umod_aminoacid * aa )

Adds a new amino acid at the end of the list.

Creates a new amino acid object, copies all content from the object supplied as a parameter and adds it at the end of the amino acids list.

Parameters
aa an instance of the amino acid object to copy content from.

◆ appendElement()

void appendElement ( const ms_umod_element * elem )

Adds a new element at the end of the list.

Creates a new element object, copies all content from the object supplied as a parameter and adds it at the end of the elements list.

Parameters
elem an instance of the element object to copy content from.

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ appendModBrick()

void appendModBrick ( const ms_umod_modbrick * brick )

Adds a new modification brick at the end of the list.

Creates a new modification brick object, copies all content from the object supplied as a parameter and adds it at the end of the modification bricks list.

Parameters
brick an instance of the modification brick object to copy content from.

◆ appendModification()

void appendModification ( const ms_umod_modification * mod )

Adds a new modification at the end of the list.

Creates a new modification object, copies all content from the object supplied as a parameter and adds it at the end of the modifications list.

Parameters
mod an instance of the modification object to copy content from.

◆ applyVisibility() [1/2]

void applyVisibility ( const ms_session * session )

If visibility settings are present for this file and session then apply to the currently loaded list of modifications.

If visibility settings are present for this file and session then apply to the currently loaded list of modifications.

Parameters
session Optional session object used to apply user security restrictions. Can be NULL or not supplied.

◆ applyVisibility() [2/2]

void applyVisibility ( const std::vector< int > & groupIds )

If visibility settings are present for this file and these group ids, then apply to the currently loaded list of modifications.

If visibility settings are present for this file and group ids then apply to the currently loaded list of modifications.

Parameters
groupIds vector of group ids to apply visibility for

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_umod_configfile * right )

Copies all the information from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )
virtual

Re-initialises the instance.

After calling this method, all internal values will be reset to their defaults, as if the object had been freshly created with the default constructor.

This method, however, doesn't change file name, schema location and connection settings. If a complete cleanup is required, you need to do three additional calls:

   umod_configfile.setFileName("");
   umod_configfile.setSchemaFileName("");
   umod_configfile.setConnectionSetting(ms_connection_settings());

◆ deleteAminoAcidByName()

bool deleteAminoAcidByName ( const char * name )

Remove an amino acid from the list in memory.

Parameters
name name of the amino acid for deletion.
Returns
TRUE if the amino acid has been found and successfully deleted and FALSE otherwise.

◆ deleteAminoAcidByNumber()

bool deleteAminoAcidByNumber ( const int idx )

Remove an amino acid from the list in memory.

Parameters
idx number of the amino acid for deletion from 0 to (getNumberOfAminoAcids() - 1).
Returns
TRUE if the amino acid has been found and successfully deleted and FALSE otherwise.

◆ deleteElementByName()

bool deleteElementByName ( const char * name )

Remove an element from the list in memory.

Parameters
name name of the element for deletion.
Returns
TRUE if the element has been found and successfully deleted and FALSE otherwise.

◆ deleteElementByNumber()

bool deleteElementByNumber ( const int idx )

Remove an element from the list in memory.

Parameters
idx number of the element for deletion from 0 to (getNumberOfElements() - 1).
Returns
TRUE if the element has been found and successfully deleted and FALSE otherwise.

◆ deleteModBrickByName()

bool deleteModBrickByName ( const char * name )

Remove a modification brick from the list in memory.

Parameters
name name of the modification brick for deletion.
Returns
TRUE if the modification brick has been found and successfully deleted and FALSE otherwise.

◆ deleteModBrickByNumber()

bool deleteModBrickByNumber ( const int idx )

Remove a modification brick from the list in memory.

Parameters
idx number of the modification brick for deletion from 0 to (getNumberOfModBricks() - 1).
Returns
TRUE if the modification brick has been found and successfully deleted and FALSE otherwise.

◆ deleteModificationByName()

bool deleteModificationByName ( const char * name )

Remove a modification from the list in memory.

Parameters
name name of the modification for deletion.
Returns
TRUE if the modification has been found and successfully deleted and FALSE otherwise.

◆ deleteModificationByNumber()

bool deleteModificationByNumber ( const int idx )

Remove a modification from the list in memory.

Parameters
idx number of the modification for deletion from 0 to (getNumberOfModifications() - 1).
Returns
TRUE if the modification has been found and successfully deleted and FALSE otherwise.

◆ findModFileName()

int findModFileName ( const char * modFileName ) const

Returns modification index by its mod_file-style name (like "Acetyl (K)").

Parameters
modFileName modification string name.
Returns
modification zero-based index or -1 (if not found).

◆ findModification()

int findModification ( const char * modName ) const

Retrieves modification index by its plain name.

Tries to find modification by its name (not mod_file-style name).

Parameters
modName modification string name.
Returns
modification zero-based index if the modification is found and -1 otherwise.

◆ getAminoAcidByName()

const ms_umod_aminoacid * getAminoAcidByName ( const char * name ) const

Returns an amino acid object by its name or NULL in case of not found.

Parameters
name a unique name of the amino acid.
Returns
a read-only pointer to an amino acid object. See Maintaining object references: two rules of thumb.

◆ getAminoAcidByNumber()

const ms_umod_aminoacid * getAminoAcidByNumber ( const int idx ) const

Returns an amino acid object by its number.

Parameters
idx number of the amino acid from 0 to (getNumberOfAminoAcids() - 1).
Returns
a read-only pointer to an amino acid object.

◆ getDefaultSchemaFileName()

std::string getDefaultSchemaFileName ( )
static

Returns the default schema filename (no path)

Static method to return the filename of the currently used schema

Returns
Returns "unimod_2.xsd" (at version 2.6.1)

◆ getElementByName()

const ms_umod_element * getElementByName ( const char * name ) const

Returns an element object by its name or NULL in case of not found.

Parameters
name a unique name of the element.
Returns
a read-only pointer to an element object. See Maintaining object references: two rules of thumb.

◆ getElementByNumber()

const ms_umod_element * getElementByNumber ( const int idx ) const

Returns an element object by its number.

Parameters
idx number of the element from 0 to (getNumberOfElements() - 1).
Returns
a read-only pointer to an element object. See Maintaining object references: two rules of thumb.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFileName()

std::string getFileName ( ) const

Returns the current file name.

Returns
currently set file location (not necessarily the location from which the current content has been read).

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getModBrickByName()

const ms_umod_modbrick * getModBrickByName ( const char * name ) const

Returns a modification brick object by its name or NULL in case of not found.

Parameters
name a unique name of the modification brick.
Returns
a read-only pointer to a modification brick object. See Maintaining object references: two rules of thumb.

◆ getModBrickByNumber()

const ms_umod_modbrick * getModBrickByNumber ( const int idx ) const

Returns an modification brick object by its number.

Parameters
idx number of the modification brick from 0 to (getNumberOfModBricks() - 1).
Returns
a read-only pointer to a modification brick object.

◆ getModFileList()

std::vector< std::string > getModFileList ( const unsigned int flags = MODFILE_FLAGS_ALL ) const

Returns an ordered list of modification names in mod_file-style, i.e. "Acetyl (K)" instead of "Acetyl".

Parameters
flags can be one or more of the ms_umod_configfile::MODFILE_FLAGS values OR'ed together.
Returns
an ordered modification names list.

◆ getModificationByName()

const ms_umod_modification * getModificationByName ( const char * name ) const

Returns a modification object by its name or NULL in case of not found.

Parameters
name a unique name of the modification.
Returns
a read-only pointer to a modification object. See Maintaining object references: two rules of thumb.

◆ getModificationByNumber()

const ms_umod_modification * getModificationByNumber ( const int idx ) const

Returns a modification object by its number.

Parameters
idx number of the modification from 0 to (getNumberOfModifications() - 1).
Returns
a read-only pointer to a modification-object. See Maintaining object references: two rules of thumb.

◆ getNumberOfAminoAcids()

int getNumberOfAminoAcids ( ) const

Returns a number of amino acids currently held in memory.

Returns
total number of amino acids in the configuration file.

◆ getNumberOfElements()

int getNumberOfElements ( ) const

Returns a number of elements currently held in memory.

Returns
total number of elements in the configuration file.

◆ getNumberOfModBricks()

int getNumberOfModBricks ( ) const

Returns a number of modification bricks currently held in memory.

Returns
total number of modification bricks in the configuration file.

◆ getNumberOfModifications()

int getNumberOfModifications ( ) const

Returns a number of modifications currently held in memory.

Returns
total number of modifications in the configuration file.

◆ getSchemaFileName()

std::string getSchemaFileName ( ) const

Returns the current schema file name that is used to validate the XML file.

Returns
currently set file location (not necessarily the location from which the current content has been read).

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_umod_configfile & operator= ( const ms_umod_configfile & right )

Assignment operator for C++ applications.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ read_buffer()

void read_buffer ( const char * buffer )

Reads configuration information from a string buffer.

This method is useful when reading configuration information from a mascor result file. Old content of the object will be removed and substituted with the information read from the buffer.

Parameters
buffer string buffer that contains a valid xml-document. It can be a document with just one modification in it, or only with amino acid masses.

◆ read_file()

void read_file ( )

Reads configuration information from the XML file.

Downloads the file if necessary from the Unimod web site and parses it. Check for errors before using any other methods for retrieving content.

◆ save_buffer()

std::string save_buffer ( bool validateAgainstSchema = true )

Creates a string representation of the XML document with all the content of the object.

Creates a valid XML document and returns it as a string which can be used, for example, for writing out configuration information to mascot result file.

To produce a 'file' that validates against the schema, it is not sufficient to add, for example, just a modification because this will be missing keyrefs to elements and termini building 'bricks'.

If you choose not to validate against the schema, then it is sufficient to just output, say, a single modification.

Parameters
validateAgainstSchema specifies whether to validate against the schema. If true and the schema file exists and the resulting XML fails to validate, then an empty string will be returned and the errors will indicate why it failed to validate.
Returns
XML document with the object content.

◆ save_file()

void save_file ( )

Saves configuration information in the XML file (not mod_file).

Check for errors after calling this method to see if the operation has been successful or to get any schema validation errors. If the document is not valid it is going to be saved anyway unless there are other problems.

If you want to validate document without actually saving it use validateDocument().

◆ setConnectionSettings()

void setConnectionSettings ( const ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters
cs is the new connection settings.

◆ setFileName()

void setFileName ( const char * name )

Changes the file name for subsequent read/write operations (do not use it for saving in a mod_file!).

Calling this method does not mean an immediate update on disk. Use either read_file() or save_file() for that.

Parameters
name a new file location.

◆ setSchemaFileName()

void setSchemaFileName ( const char * name )

Call this member to specify a custom schema file name for validating the XML file.

Parameters
name a new file location (if empty default value will be assigned).

◆ updateAminoAcidByName()

bool updateAminoAcidByName | ( | const char * | name,
 |  | const ms_umod_aminoacid * | aa
 | ) |  |

Update the information for a specific amino acid.

Parameters
name | name of the amino acid for updating.
aa | an object to copy the content from.
Returns
TRUE if the amino acid has been found and successfully updated and FALSE otherwise.

◆ updateAminoAcidByNumber()

bool updateAminoAcidByNumber | ( | const int | idx,
 |  | const ms_umod_aminoacid * | aa
 | ) |  |

Update the information for a specific amino acid.

Parameters
idx | number of the amino acid for updating from 0 to (getNumberOfAminoAcids() - 1).
aa | an object to copy the content from.
Returns
TRUE if the amino acid has been found and successfully updated and FALSE otherwise.

◆ updateElementByName()

bool updateElementByName | ( | const char * | name,
 |  | const ms_umod_element * | element
 | ) |  |

Update the information for a specific element.

Parameters
name | name of the element for updating.
element | an object to copy the content from.
Returns
TRUE if the element has been found and successfully updated and FALSE otherwise.

◆ updateElementByNumber()

bool updateElementByNumber | ( | const int | idx,
 |  | const ms_umod_element * | element
 | ) |  |

Update the information for a specific element.

Parameters
idx | number of the element for updating from 0 to (getNumberOfElements() - 1).
element | an object to copy the content from.
Returns
TRUE if the element has been found and successfully updated and FALSE otherwise.

◆ updateModBrickByName()

bool updateModBrickByName | ( | const char * | name,
 |  | const ms_umod_modbrick * | brick
 | ) |  |

Update the information for a specific modification brick.

Parameters
name | name of the modification brick for updating.
brick | an object to copy the content from.
Returns
TRUE if the modification brick has been found and successfully updated and FALSE otherwise.

◆ updateModBrickByNumber()

bool updateModBrickByNumber | ( | const int | idx,
 |  | const ms_umod_modbrick * | brick
 | ) |  |

Update the information for a specific modification brick.

Parameters
idx | number of the modification brick for updating from 0 to (getNumberOfModBricks() - 1).
brick | an object to copy the content from.
Returns
TRUE if the modification brick has been found and successfully updated and FALSE otherwise.

◆ updateModificationByName()

bool updateModificationByName | ( | const char * | name,
 |  | const ms_umod_modification * | mod
 | ) |  |

Update the information for a specific modification.

Parameters
name | name of the modification for updating.
mod | an object to copy the content from.
Returns
TRUE if the modification has been found and successfully updated and FALSE otherwise.

◆ updateModificationByNumber()

bool updateModificationByNumber | ( | const int | idx,
 |  | const ms_umod_modification * | mod
 | ) |  |

Update the information for a specific modification.

Parameters
idx | number of the modification for updating from 0 to (getNumberOfModifications() - 1).
mod | an object to copy the content from.
Returns
TRUE if the modification has been found and successfully updated and FALSE otherwise.

◆ validateDocument()

std::string validateDocument ( ) const

Validates the whole document against schema and returns errors as a string.

This method doesn't attempt to store the document anywhere and doesn't make the object invalid. Also, no errors are stored. Therefore, this method can be called as many times as necessary without any consequences.

All validation errors will be returned back as a string. However, the XML parser will describe errors in terms of row and column numbers as if the document was actually saved in a file.

Returns
validation errors as a string or an empty string if there are no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_configfile.hpp
  • ms_umod_configfile.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_element Class Reference

  • matrix_science
  • ms_umod_element
Public Member Functions | List of all members
ms_umod_element Class Reference
Mascot configuration files module

Represents an element object in unimod.xml. More...

#include <ms_umod_element.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_umod_element ()
Default constructor.
ms_umod_element (const ms_umod_element &src)
Copying constructor.
virtual | ~ms_umod_element ()
Destructor.
void | copyFrom (const ms_umod_element *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropAvgeMass ()
Delete the avge_mass attribute.
void | dropFullName ()
Delete the full_name attribute.
void | dropMonoMass ()
Delete the mono_mass attribute.
void | dropTitle ()
Delete the title attribute.
std::string | getAvgeMass () const
Returns the value of the avge_mass attribute as a string.
double | getAvgeMassAsNumber () const
Returns the value of the avge_mass attribute as a floating point number.
std::string | getAvgeMassSchemaType () const
Obtain a symbolic name for the avge_mass attribute schema type.
std::string | getFullName () const
Returns the value of the full_name attribute.
std::string | getFullNameSchemaType () const
Obtain a symbolic name for the full_name attribute schema type.
std::string | getMonoMass () const
Returns the value of the mono_mass attribute as a string.
double | getMonoMassAsNumber () const
Returns the value of the mono_mass attribute as a floating point number.
std::string | getMonoMassSchemaType () const
Obtain a symbolic name for the mono_mass attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getTitle () const
Returns the value of the title attribute.
std::string | getTitleSchemaType () const
Obtain a symbolic name for the title attribute schema type.
bool | haveAvgeMass () const
Indicates presence of the avge_mass attribute.
bool | haveFullName () const
Indicates presence of the full_name attribute.
bool | haveMonoMass () const
Indicates presence of the mono_mass attribute.
bool | haveTitle () const
Indicates presence of the title attribute.
ms_umod_element & | operator= (const ms_umod_element &right)
C++ style assignment operator.
bool | setAvgeMass (const char *value, ms_errs *err=NULL)
Set a custom string value for the avge_mass attribute.
void | setFullName (const char *value)
Set a custom value for the full_name attribute.
bool | setMonoMass (const char *value, ms_errs *err=NULL)
Set a custom string value for the mono_mass attribute.
void | setTitle (const char *value)
Set a custom value for the title attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents an element object in unimod.xml.

Constructor & Destructor Documentation

◆ ms_umod_element() [1/2]

ms_umod_element ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_umod_element() [2/2]

ms_umod_element ( const ms_umod_element & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_umod_element * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

After calling this method, internal values are reset to defaults, as if the object had been freshly created with the default constructor.

◆ dropAvgeMass()

void dropAvgeMass ( )

Delete the avge_mass attribute.

Deletes the attribute until is re-set.

◆ dropFullName()

void dropFullName ( )

Delete the full_name attribute.

Deletes the attribute until is re-set.

◆ dropMonoMass()

void dropMonoMass ( )

Delete the mono_mass attribute.

Deletes the attribute until is re-set.

◆ dropTitle()

void dropTitle ( )

Delete the title attribute.

Deletes the attribute until is re-set.

◆ getAvgeMass()

std::string getAvgeMass ( ) const

Returns the value of the avge_mass attribute as a string.

Average mass for the chemical element or an isotope.

Returns
current string value of the attribute.

◆ getAvgeMassAsNumber()

double getAvgeMassAsNumber ( ) const

Returns the value of the avge_mass attribute as a floating point number.

Average mass for the chemical element or an isotope.

Returns
current floating point number value of the attribute.

◆ getAvgeMassSchemaType()

std::string getAvgeMassSchemaType ( ) const

Obtain a symbolic name for the avge_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getFullName()

std::string getFullName ( ) const

Returns the value of the full_name attribute.

A full name for the chemical element or an isotope (for example, 'Hydrogen').

Returns
current value of the attribute.

◆ getFullNameSchemaType()

std::string getFullNameSchemaType ( ) const

Obtain a symbolic name for the full_name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMonoMass()

std::string getMonoMass ( ) const

Returns the value of the mono_mass attribute as a string.

Monoisotopic mass for the chemical element or an isotope.

Returns
current string value of the attribute.

◆ getMonoMassAsNumber()

double getMonoMassAsNumber ( ) const

Returns the value of the mono_mass attribute as a floating point number.

Monoisotopic mass for the chemical element or an isotope.

Returns
current floating point number value of the attribute.

◆ getMonoMassSchemaType()

std::string getMonoMassSchemaType ( ) const

Obtain a symbolic name for the mono_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType").

◆ getTitle()

std::string getTitle ( ) const

Returns the value of the title attribute.

A unique name for the chemical element or an isotope (for example, 'N15').

Returns
current value of the attribute.

◆ getTitleSchemaType()

std::string getTitleSchemaType ( ) const

Obtain a symbolic name for the title attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveAvgeMass()

bool haveAvgeMass ( ) const

Indicates presence of the avge_mass attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveFullName()

bool haveFullName ( ) const

Indicates presence of the full_name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveMonoMass()

bool haveMonoMass ( ) const

Indicates presence of the mono_mass attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveTitle()

bool haveTitle ( ) const

Indicates presence of the title attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_umod_element & operator= ( const ms_umod_element & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAvgeMass()

bool setAvgeMass | ( | const char * | value,
 |  | ms_errs * | err = NULL
 | ) |  |

Set a custom string value for the avge_mass attribute.

The method is trying to parse the string value as a floating point number first. It it fails it reports an error and returns FALSE leaving the old value unchanged.

Parameters
value | a new string value for the attribute.
err | an error object to return possible error messages.
Returns
TRUE if the value has been parsed successfully and FALSE otherwise.

◆ setFullName()

void setFullName ( const char * value )

Set a custom value for the full_name attribute.

Parameters
value a new value for the attribute.

◆ setMonoMass()

bool setMonoMass | ( | const char * | value,
 |  | ms_errs * | err = NULL
 | ) |  |

Set a custom string value for the mono_mass attribute.

The method is trying to parse the string value as a floating point number first. It it fails it reports an error and returns FALSE leaving the old value unchanged.

Parameters
value | a new string value for the attribute.
err | an error object to return possible error messages.
Returns
TRUE if the value has been parsed successfully and FALSE otherwise.

◆ setTitle()

void setTitle ( const char * value )

Set a custom value for the title attribute.

Parameters
value a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_element.hpp
  • ms_umod_element.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_elemref Class Reference

  • matrix_science
  • ms_umod_elemref
Public Member Functions | List of all members
ms_umod_elemref Class Reference
Mascot configuration files module

Represents the elemref_t type in unimod.xml. More...

#include <ms_umod_elemref.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_umod_elemref ()
Default constructor.
ms_umod_elemref (const ms_quant_element &src)
Copying constructor.
ms_umod_elemref (const ms_umod_elemref &src)
Copying constructor.
virtual | ~ms_umod_elemref ()
Destructor.
void | copyFrom (const ms_quant_element *right)
Copies all content from another object.
void | copyFrom (const ms_umod_elemref *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropNumber ()
Delete the number attribute.
void | dropSymbol ()
Delete the symbol attribute.
int | getNumber () const
Returns the value of the number attribute.
std::string | getNumberSchemaType () const
Obtain a symbolic name for the number attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSymbol () const
Returns the value of the symbol attribute.
std::string | getSymbolSchemaType () const
Obtain a symbolic name for the symbol attribute schema type.
bool | haveNumber () const
Indicates presence of the number attribute.
bool | haveSymbol () const
Indicates presence of the symbol attribute.
ms_umod_elemref & | operator= (const ms_umod_elemref &right)
C++ style assignment operator.
void | setNumber (const int value)
Set a custom value for the number attribute.
void | setSymbol (const char *value)
Set a custom value for the symbol attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents the elemref_t type in unimod.xml.

This type is used for compositions in order to specify number of each chemical element used in a composition.

Constructor & Destructor Documentation

◆ ms_umod_elemref() [1/3]

ms_umod_elemref ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_umod_elemref() [2/3]

ms_umod_elemref ( const ms_umod_elemref & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

◆ ms_umod_elemref() [3/3]

ms_umod_elemref ( const ms_quant_element & src )

Copying constructor.

Parameters
src another object to copy the content from.

Member Function Documentation

◆ copyFrom() [1/2]

void copyFrom ( const ms_quant_element * right )

Copies all content from another object.

Parameters
right another object to copy the content from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_umod_elemref * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropNumber()

void dropNumber ( )

Delete the number attribute.

Deletes the attribute until it is re-set.

◆ dropSymbol()

void dropSymbol ( )

Delete the symbol attribute.

Deletes the attribute until it is re-set.

◆ getNumber()

int getNumber ( ) const

Returns the value of the number attribute.

Returns
current value of the attribute.

◆ getNumberSchemaType()

std::string getNumberSchemaType ( ) const

Obtain a symbolic name for the number attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ getSymbol()

std::string getSymbol ( ) const

Returns the value of the symbol attribute.

Returns
current value of the attribute.

◆ getSymbolSchemaType()

std::string getSymbolSchemaType ( ) const

Obtain a symbolic name for the symbol attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveNumber()

bool haveNumber ( ) const

Indicates presence of the number attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveSymbol()

bool haveSymbol ( ) const

Indicates presence of the symbol attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_umod_elemref & operator= ( const ms_umod_elemref & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setNumber()

void setNumber ( const int value )

Set a custom value for the number attribute.

Parameters
value a new value for the attribute.

◆ setSymbol()

void setSymbol ( const char * value )

Set a custom value for the symbol attribute.

Parameters
value a new value for the attribute.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_elemref.hpp
  • ms_umod_elemref.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_modbrick Class Reference

  • matrix_science
  • ms_umod_modbrick
Public Member Functions | List of all members
ms_umod_modbrick Class Reference
Mascot configuration files module

Represents a modification brick object in unimod.xml. More...

#include <ms_umod_modbrick.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_umod_modbrick ()
Default constructor.
ms_umod_modbrick (const ms_umod_modbrick &src)
Copying constructor.
virtual | ~ms_umod_modbrick ()
Destructor.
void | appendElemRef (const ms_umod_elemref *elemref)
Adds a new element reference object at the end of the list.
void | clearElemRefs ()
Deletes all element reference objects from the list.
void | copyFrom (const ms_umod_modbrick *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElemRef (const int idx)
Remove an element reference object from the list in memory.
void | dropAvgeMass ()
Delete the avge_mass attribute.
void | dropFullName ()
Delete the full_name attribute.
void | dropMonoMass ()
Delete the mono_mass attribute.
void | dropTitle ()
Delete the title attribute.
double | getAvgeMass () const
Returns the value of the avge_mass attribute.
std::string | getAvgeMassSchemaType () const
Obtain a symbolic name for the avge_mass attribute schema type.
const ms_umod_elemref * | getElemRef (const int idx) const
Returns a read-only pointer to an element reference object by its number.
std::string | getElemRefSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getFullName () const
Returns the full_name attribute.
std::string | getFullNameSchemaType () const
Obtain a symbolic name for the full_name attribute schema type.
double | getMonoMass () const
Returns the value of the mono_mass attribute.
std::string | getMonoMassSchemaType () const
Obtain a symbolic name for the mono_mass attribute schema type.
int | getNumberOfElemRefs () const
Returns the number of element reference objects currently held in memory.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getTitle () const
Returns the value of the title attribute.
std::string | getTitleSchemaType () const
Obtain a symbolic name for the title attribute schema type.
bool | haveAvgeMass () const
Indicates presence of the avge_mass attribute.
bool | haveFullName () const
Indicates presence of the full_name attribute.
bool | haveMonoMass () const
Indicates presence of the mono_mass attribute.
bool | haveTitle () const
Indicates presence of the title attribute.
ms_umod_modbrick & | operator= (const ms_umod_modbrick &right)
C++ style assignment operator.
void | setAvgeMass (const double value)
Set a custom value for the avge_mass attribute.
void | setFullName (const char *value)
Set a custom value for the full_name attribute.
void | setMonoMass (const double value)
Set a custom value for the mono_mass attribute.
void | setTitle (const char *value)
Set a custom value for the title attribute.
bool | updateElemRef (const int idx, const ms_umod_elemref *elemref)
Update the information for a particular element reference object.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents a modification brick object in unimod.xml.

Constructor & Destructor Documentation

◆ ms_umod_modbrick() [1/2]

ms_umod_modbrick ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_umod_modbrick() [2/2]

ms_umod_modbrick ( const ms_umod_modbrick & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ appendElemRef()

void appendElemRef ( const ms_umod_elemref * elemref )

Adds a new element reference object at the end of the list.

Creates a new element reference object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters
elemref an instance of element reference object to copy the content from.

◆ copyFrom()

void copyFrom ( const ms_umod_modbrick * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteElemRef()

bool deleteElemRef ( const int idx )

Remove an element reference object from the list in memory.

Parameters
idx number of the element reference for deletion from 0 to (getNumberOfElemRefs() - 1).
Returns
TRUE if the object has been found and successfully deleted and FALSE otherwise.

◆ dropAvgeMass()

void dropAvgeMass ( )

Delete the avge_mass attribute.

Deletes the attribute until is re-set.

◆ dropFullName()

void dropFullName ( )

Delete the full_name attribute.

Deletes the attribute until it is re-set.

◆ dropMonoMass()

void dropMonoMass ( )

Delete the mono_mass attribute.

Deletes the attribute until is re-set.

◆ dropTitle()

void dropTitle ( )

Delete the title attribute.

Deletes the attribute until it is re-set.

◆ getAvgeMass()

double getAvgeMass ( ) const

Returns the value of the avge_mass attribute.

Average mass for the modification brick.

Returns
current value of the attribute.

◆ getAvgeMassSchemaType()

std::string getAvgeMassSchemaType ( ) const

Obtain a symbolic name for the avge_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getElemRef()

const ms_umod_elemref * getElemRef ( const int idx ) const

Returns a read-only pointer to an element reference object by its number.

Parameters
idx number of the reference from 0 to (getNumberOfElemRefs() - 1).
Returns
a read-only pointer to the retrieved object.

◆ getElemRefSchemaType()

std::string getElemRefSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getFullName()

std::string getFullName ( ) const

Returns the full_name attribute.

A full name for the modification brick.

Returns
current value of the attribute.

◆ getFullNameSchemaType()

std::string getFullNameSchemaType ( ) const

Obtain a symbolic name for the full_name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMonoMass()

double getMonoMass ( ) const

Returns the value of the mono_mass attribute.

Monoisotopic mass for the modification brick.

Returns
current value of the attribute.

◆ getMonoMassSchemaType()

std::string getMonoMassSchemaType ( ) const

Obtain a symbolic name for the mono_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfElemRefs()

int getNumberOfElemRefs ( ) const

Returns the number of element reference objects currently held in memory.

Returns
total number of chemical element references in the modification brick object.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ getTitle()

std::string getTitle ( ) const

Returns the value of the title attribute.

A unique name for the modification brick.

Returns
current value of the attribute.

◆ getTitleSchemaType()

std::string getTitleSchemaType ( ) const

Obtain a symbolic name for the title attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveAvgeMass()

bool haveAvgeMass ( ) const

Indicates presence of the avge_mass attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveFullName()

bool haveFullName ( ) const

Indicates presence of the full_name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveMonoMass()

bool haveMonoMass ( ) const

Indicates presence of the mono_mass attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveTitle()

bool haveTitle ( ) const

Indicates presence of the title attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_umod_modbrick & operator= ( const ms_umod_modbrick & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAvgeMass()

void setAvgeMass ( const double value )

Set a custom value for the avge_mass attribute.

Parameters
value a new value for the attribute.

◆ setFullName()

void setFullName ( const char * value )

Set a custom value for the full_name attribute.

Parameters
value a new value for the attribute.

◆ setMonoMass()

void setMonoMass ( const double value )

Set a custom value for the mono_mass attribute.

Parameters
value a new value for the attribute.

◆ setTitle()

void setTitle ( const char * value )

Set a custom value for the title attribute.

Parameters
value a new value for the attribute.

◆ updateElemRef()

bool updateElemRef | ( | const int | idx,
 |  | const ms_umod_elemref * | elemref
 | ) |  |

Update the information for a particular element reference object.

Parameters
idx | number of the element reference for updating from 0 to (getNumberOfElemRefs() - 1).
elemref | an object to copy the content from.
Returns
TRUE if the element reference has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_modbrick.hpp
  • ms_umod_modbrick.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_modification Class Reference

  • matrix_science
  • ms_umod_modification
Public Member Functions | List of all members
ms_umod_modification Class Reference
Mascot configuration files module

Represents a modif object in unimod.xml. More...

#include <ms_umod_modification.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_umod_modification ()
Default constructor.
ms_umod_modification (const ms_quant_localdef &src, const ms_umod_configfile &umodFile)
Copying constructor that copies the content from a quantitation.xml object.
ms_umod_modification (const ms_quant_unmodified &src)
Copying constructor that copies the content from a quantitation.xml object.
ms_umod_modification (const ms_umod_modification &src)
Copying constructor.
virtual | ~ms_umod_modification ()
Destructor.
void | appendAltName (const char *alt_name)
Adds a new alt_name element at the end of the list.
void | appendIgnore (const ms_umod_composition *ignore)
Adds a new Ignore object at the end of the list.
void | appendSpecificity (const ms_umod_specificity *specificity)
Adds a new specificity at the end of the list.
void | appendXref (const ms_umod_xref *xref)
Adds a new 'xref' object at the end of the list.
void | clearAltNames ()
Deletes all alt_name elements from the list.
void | clearIgnores ()
Deletes all Ignore elements from the list.
void | clearSpecificities ()
Deletes all specificities from the list.
void | clearXrefs ()
Deletes all xref elements from the list.
void | copyFrom (const ms_quant_localdef *right, const ms_umod_configfile &umodFile)
Copies all content from a quantitation.xml object.
void | copyFrom (const ms_quant_unmodified *right)
Copies all content from a quantitation.xml object.
void | copyFrom (const ms_umod_modification *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteAltName (const int idx)
Remove an alt_name element from the list in memory.
bool | deleteIgnore (const int idx)
Remove an Ignore element from the list in memory.
bool | deleteSpecificity (const int idx)
Remove a specificity from the list in memory.
bool | deleteXref (const int idx)
Remove an xref element from the list in memory.
void | dropApproved ()
Delete the approved attribute.
void | dropDateTimeModified ()
Delete the date_time_modified attribute.
void | dropDateTimePosted ()
Delete the date_time_posted attribute.
void | dropDelta ()
Delete all information about the currently held delta element.
void | dropFullName ()
Delete the full_name attribute.
void | dropGroupOfPoster ()
Delete the group_of_poster attribute.
void | dropMiscNotes ()
Delete the misc_notes element.
void | dropRecordID ()
Delete the record_id attribute.
void | dropTitle ()
Delete the title attribute.
void | dropUsernameOfPoster ()
Delete the username_of_poster attribute.
int | findSpecGroup (const char *modFileName) const
Retrieves specificity group ID for mod_file-style modification name.
std::string | getAltName (const int idx) const
Returns an alt_name element by its number.
std::string | getAltNameSchemaType () const
Obtain a symbolic name for the alt_name element schema type.
std::string | getApprovedSchemaType () const
Obtain a symbolic name for the approved attribute schema type.
std::string | getDateTimeModified () const
Returns the value of the date_time_modified attribute.
std::string | getDateTimeModifiedSchemaType () const
Obtain a symbolic name for the date_time_modified attribute schema type.
std::string | getDateTimePosted () const
Returns the value of the date_time_posted attribute.
std::string | getDateTimePostedSchemaType () const
Obtain a symbolic name for the date_time_posted attribute schema type.
const ms_umod_composition * | getDelta () const
Returns a read-only pointer to the object representing delta element.
std::string | getDeltaSchemaType () const
Obtain a symbolic name for the delta element schema type.
std::string | getFullName () const
Returns the value of the full_name attribute.
std::string | getFullNameSchemaType () const
Obtain a symbolic name for the full_name attribute schema type.
std::string | getGroupOfPoster () const
Returns the value of the group_of_poster attribute.
std::string | getGroupOfPosterSchemaType () const
Obtain a symbolic name for the group_of_poster attribute schema type.
const ms_umod_composition * | getIgnore (const int idx) const
Returns an Ignore object by its number.
std::string | getIgnoreSchemaType () const
Obtain a symbolic name for the Ignore element schema type.
std::string | getMiscNotes () const
Returns the misc_notes element or an empty string if not set.
std::string | getMiscNotesSchemaType () const
Obtain a symbolic name for the misc_notes element schema type.
std::vector< std::string > | getModFileList (const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL) const
Returns an ordered list of modification names in mod_file-style, i.e. "Acetyl (K)" instead of "Acetyl".
int | getNumberOfAltNames () const
Returns the number of alt_name elements currently held in memory.
int | getNumberOfIgnores () const
Returns the number of Ignore objects currently held in memory.
int | getNumberOfSpecificities () const
Returns the number of specificities currently held in memory.
int | getNumberOfXrefs () const
Returns the number of xref elements currently held in memory.
std::string | getRecordID () const
Returns the value of the record_id attribute.
std::string | getRecordIDSchemaType () const
Obtain a symbolic name for the record_id attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
const ms_umod_specificity * | getSpecificity (const int idx) const
Returns a specificity object by its number.
const ms_umod_specificity * | getSpecificityBySite (const char *site) const
Returns a specificity object by its site name.
const ms_umod_specificity * | getSpecificityBySiteAndPosition (const char *site, const char *position) const
Returns a specificity object by its site name and position.
std::string | getSpecificitySchemaType () const
Obtain a symbolic name for the specificity element schema type.
std::string | getTitle () const
Returns the value of the title attribute.
std::string | getTitleSchemaType () const
Obtain a symbolic name for the title attribute schema type.
std::string | getUsernameOfPoster () const
Returns the value of the username_of_poster attribute.
std::string | getUsernameOfPosterSchemaType () const
Obtain a symbolic name for the username_of_poster attribute schema type.
const ms_umod_xref * | getXref (const int idx) const
Returns a read-only pointer to xref element by its number.
std::string | getXrefSchemaType () const
Obtain a symbolic name for the xref element schema type.
bool | haveApproved () const
Indicates presence of the approved attribute.
bool | haveDateTimeModified () const
Indicates presence of the date_time_modified attribute.
bool | haveDateTimePosted () const
Indicates presence of the date_time_posted attribute.
bool | haveDelta () const
Indicates presence of the delta element.
bool | haveFullName () const
Indicates presence of the full_name attribute.
bool | haveGroupOfPoster () const
Indicates presence of the group_of_poster attribute.
bool | haveMiscNotes () const
Indicates presence of the misc_notes element.
bool | haveRecordID () const
Indicates presence of the record_id attribute.
bool | haveTitle () const
Indicates presence of the title attribute.
bool | haveUsernameOfPoster () const
Indicates presence of the username_of_poster attribute.
bool | isApproved () const
Returns the value of the approved attribute.
bool | isPrivacyEnabled () const
Indicates whether privacy settings are enabled for this modification.
bool | isPrivate () const
Indicates whether this modification is private and so cannot be viewed or used. Only valid if privacy is enabled.
bool | isSameAs (const ms_umod_modification &right_mod) const
Returns true if instances contain the same information.
ms_umod_modification & | operator= (const ms_umod_modification &right)
C++ style assignment operator.
void | setApproved (const bool value)
Set a custom value for the approved attribute.
void | setDateTimeModified (const char *value)
Set a custom value for the date_time_modified attribute.
void | setDateTimePosted (const char *value)
Set a custom value for the date_time_posted attribute.
void | setDelta (const ms_umod_composition *delta)
Supply new content for the delta element.
void | setFullName (const char *value)
Set a custom value for the full_name attribute.
void | setGroupOfPoster (const char *value)
Set a custom value for the group_of_poster attribute.
void | setMiscNotes (const char *value)
Set a custom value for the misc_notes element.
void | setPrivacyEnabled (bool b)
Sets whether privacy settings are enabled for this modification.
void | setPrivate (bool b)
Sets whether this modification is private.
void | setRecordID (const char *value)
Set a custom value for the record_id attribute.
void | setTitle (const char *value)
Set a custom value for the title attribute.
void | setUsernameOfPoster (const char *value)
Set a custom value for the username_of_poster attribute.
bool | updateAltName (const int idx, const char *alt_name)
Update the string for a particular alt_name element.
bool | updateIgnore (const int idx, const ms_umod_composition *ignore)
Update the information for a particular Ignore element.
void | updateMasses (const ms_umod_configfile &umodFile, const ms_quant_component &quantComp)
Recalculates all deltas with isotope-substitution according to selected component in quantification.xml.
bool | updateSpecificity (const int idx, const ms_umod_specificity *specificity)
Update the information for a particular specificity.
bool | updateXref (const int idx, const ms_umod_xref *xref)
Update the information for a particular xref element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents a modif object in unimod.xml.

Constructor & Destructor Documentation

◆ ms_umod_modification() [1/4]

ms_umod_modification ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_umod_modification() [2/4]

ms_umod_modification ( const ms_umod_modification & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

◆ ms_umod_modification() [3/4]

ms_umod_modification | ( | const ms_quant_localdef & | src,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copying constructor that copies the content from a quantitation.xml object.

Parameters
src | a quantitation.xml object to copy the content from.
umodFile | an instance of a Unimod file object to extract element masses.

◆ ms_umod_modification() [4/4]

ms_umod_modification ( const ms_quant_unmodified & src )

Copying constructor that copies the content from a quantitation.xml object.

Parameters
src a quantitation.xml object to copy the content from.

Member Function Documentation

◆ appendAltName()

void appendAltName ( const char * alt_name )

Adds a new alt_name element at the end of the list.

Creates a new alt_name element, sets it to the supplied string value and adds it at the end of the alt_name elements list.

Parameters
alt_name a string value for the new element.

◆ appendIgnore()

void appendIgnore ( const ms_umod_composition * ignore )

Adds a new Ignore object at the end of the list.

Creates a new Ignore element, copies all content from the object supplied as a parameter and adds it at the end of the ignores list.

Parameters
ignore an Ignore object to copy the content from.

◆ appendSpecificity()

void appendSpecificity ( const ms_umod_specificity * specificity )

Adds a new specificity at the end of the list.

Creates a new specificity object, copies all content from the object supplied as a parameter and adds it at the end of the specificities list.

Parameters
specificity an instance of specificity object to copy the content from.

◆ appendXref()

void appendXref ( const ms_umod_xref * xref )

Adds a new 'xref' object at the end of the list.

Creates a new xref element, copies all content from the object supplied as a parameter and adds it at the end of the xref elements list.

Parameters
xref an xref object to copy the content from.

◆ copyFrom() [1/3]

void copyFrom | ( | const ms_quant_localdef * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copies all content from a quantitation.xml object.

Parameters
right | a quantitation object to copy the content from.
umodFile | a Unimod file object to extract element masses from.

◆ copyFrom() [2/3]

void copyFrom ( const ms_quant_unmodified * right )

Copies all content from a quantitation.xml object.

Parameters
right a quantitation object to copy the content from.

◆ copyFrom() [3/3]

void copyFrom ( const ms_umod_modification * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteAltName()

bool deleteAltName ( const int idx )

Remove an alt_name element from the list in memory.

Parameters
idx number of the alt_name element for deletion from 0 to (getNumberOfAltNames() - 1).
Returns
TRUE if the element has been found and successfully deleted and FALSE otherwise.

◆ deleteIgnore()

bool deleteIgnore ( const int idx )

Remove an Ignore element from the list in memory.

Parameters
idx number of the Ignore element for deletion from 0 to (getNumberOfIgnores() - 1).
Returns
TRUE if the element has been found and successfully deleted and FALSE otherwise.

◆ deleteSpecificity()

bool deleteSpecificity ( const int idx )

Remove a specificity from the list in memory.

Parameters
idx number of the specificity for deletion from 0 to (getNumberOfSpecificities() - 1).
Returns
TRUE if the specificity has been found and successfully deleted and FALSE otherwise.

◆ deleteXref()

bool deleteXref ( const int idx )

Remove an xref element from the list in memory.

Parameters
idx number of the xref element for deletion from 0 to (getNumberOfXrefs() - 1).
Returns
TRUE if the element has been found and successfully deleted and FALSE otherwise.

◆ dropApproved()

void dropApproved ( )

Delete the approved attribute.

Deletes the attribute until it is re-set.

◆ dropDateTimeModified()

void dropDateTimeModified ( )

Delete the date_time_modified attribute.

Deletes the attribute until it is re-set.

◆ dropDateTimePosted()

void dropDateTimePosted ( )

Delete the date_time_posted attribute.

Deletes the attribute until it is re-set.

◆ dropDelta()

void dropDelta ( )

Delete all information about the currently held delta element.

Deletes the element until it is re-set.

◆ dropFullName()

void dropFullName ( )

Delete the full_name attribute.

Deletes the attribute until it is re-set.

◆ dropGroupOfPoster()

void dropGroupOfPoster ( )

Delete the group_of_poster attribute.

Deletes the attribute until it is re-set.

◆ dropMiscNotes()

void dropMiscNotes ( )

Delete the misc_notes element.

Deletes the element until it is re-set.

◆ dropRecordID()

void dropRecordID ( )

Delete the record_id attribute.

Deletes the attribute until it is re-set.

◆ dropTitle()

void dropTitle ( )

Delete the title attribute.

Deletes the attribute until it is re-set.

◆ dropUsernameOfPoster()

void dropUsernameOfPoster ( )

Delete the username_of_poster attribute.

Deletes the attribute until it is re-set.

◆ findSpecGroup()

int findSpecGroup ( const char * modFileName ) const

Retrieves specificity group ID for mod_file-style modification name.

As each modification from unimod.xml can be converted into several mod_file-style modifications, we have to be able to find the right specificity group for a given mod_file-style name.

Parameters
modFileName mod_file-style modification name (like 'Acetyl (K)').
Returns
specificity group ID which can be used to extract just a single mod_file-style modification from a Unimod-style modification. If the specificity not found -1 will be returned.

◆ getAltName()

std::string getAltName ( const int idx ) const

Returns an alt_name element by its number.

Retrieves an alt_name element from the list by its number.

Parameters
idx number of the alt_name element from 0 to (getNumberOfAltNames() - 1).
Returns
the retrieved string value.

◆ getAltNameSchemaType()

std::string getAltNameSchemaType ( ) const

Obtain a symbolic name for the alt_name element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getApprovedSchemaType()

std::string getApprovedSchemaType ( ) const

Obtain a symbolic name for the approved attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getDateTimeModified()

std::string getDateTimeModified ( ) const

Returns the value of the date_time_modified attribute.

Returns
current value of the attribute.

◆ getDateTimeModifiedSchemaType()

std::string getDateTimeModifiedSchemaType ( ) const

Obtain a symbolic name for the date_time_modified attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getDateTimePosted()

std::string getDateTimePosted ( ) const

Returns the value of the date_time_posted attribute.

Returns
current value of the attribute.

◆ getDateTimePostedSchemaType()

std::string getDateTimePostedSchemaType ( ) const

Obtain a symbolic name for the date_time_posted attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getDelta()

const ms_umod_composition * getDelta ( ) const

Returns a read-only pointer to the object representing delta element.

Modification delta which is represented as a composition of chemical elements.

Returns
read-only pointer to the 'delta' object. See Maintaining object references: two rules of thumb.

◆ getDeltaSchemaType()

std::string getDeltaSchemaType ( ) const

Obtain a symbolic name for the delta element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getFullName()

std::string getFullName ( ) const

Returns the value of the full_name attribute.

A full name for the modification.

Returns
current value of the attribute.

◆ getFullNameSchemaType()

std::string getFullNameSchemaType ( ) const

Obtain a symbolic name for the full_name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getGroupOfPoster()

std::string getGroupOfPoster ( ) const

Returns the value of the group_of_poster attribute.

Returns
current value of the attribute.

◆ getGroupOfPosterSchemaType()

std::string getGroupOfPosterSchemaType ( ) const

Obtain a symbolic name for the group_of_poster attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getIgnore()

const ms_umod_composition * getIgnore ( const int idx ) const

Returns an Ignore object by its number.

Parameters
idx number of the Ignore element from 0 to (getNumberOfIgnores() - 1).
Returns
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.

◆ getIgnoreSchemaType()

std::string getIgnoreSchemaType ( ) const

Obtain a symbolic name for the Ignore element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMiscNotes()

std::string getMiscNotes ( ) const

Returns the misc_notes element or an empty string if not set.

Returns
current string value of the element.

◆ getMiscNotesSchemaType()

std::string getMiscNotesSchemaType ( ) const

Obtain a symbolic name for the misc_notes element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfSpecificities()

int getNumberOfSpecificities ( ) const

Returns the number of specificities currently held in memory.

Returns
total number of specificities in the modification object.

◆ getRecordID()

std::string getRecordID ( ) const

Returns the value of the record_id attribute.

The unique and stable record ID for the unimod record. Added in Mascot Parser version 2.3.01.

Note that in previous versions of parser, this attribute was not loaded or saved from files. This means that files created by the Mascot Server 2.2 configuration editor strip out the record ID. It also means that the Unimod fragments contained in the Mascot results files from version 2.2 do not contain the record ID.

Returns
current value of the attribute.

◆ getRecordIDSchemaType()

std::string getRecordIDSchemaType ( ) const

Obtain a symbolic name for the record_id attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ getSpecificity()

const ms_umod_specificity * getSpecificity ( const int idx ) const

Returns a specificity object by its number.

Parameters
idx number of the specificity from 0 to (getNumberOfSpecificities() - 1).
Returns
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.

◆ getSpecificityBySite()

const ms_umod_specificity * getSpecificityBySite ( const char * site ) const

Returns a specificity object by its site name.

Multiple specificities may exist for a given site with differing position definitions. This method returns the first specificity found with the same site definition. Use ms_umod_modification::getSpecificityBySiteAndPosition to obtain a specificity by bot site and position.

Parameters
site Name of the specificity to return. String that should be one of the Type mqm:siteType values.
Returns
a read-only pointer to the retrieved object, can be NULL if specificity for the site is not yet defined. See Maintaining object references: two rules of thumb.

◆ getSpecificityBySiteAndPosition()

const ms_umod_specificity * getSpecificityBySiteAndPosition | ( | const char * | site,
 |  | const char * | position
 | ) |  | const

Returns a specificity object by its site name and position.

Multiple specificities may exist for a given site with differing position definitions.

Parameters
site | Name of the specificity to return. String that should be one of the Type mqm:siteType values.
position | Position of the specificity to return. String that should be one of the Type mqm:positionType values.
Returns
a read-only pointer to the retrieved object, can be NULL if specificity for the site is not yet defined. See Maintaining object references: two rules of thumb.

◆ getSpecificitySchemaType()

std::string getSpecificitySchemaType ( ) const

Obtain a symbolic name for the specificity element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getTitle()

std::string getTitle ( ) const

Returns the value of the title attribute.

A unique name for the modification object.

Returns
current value of the attribute.

◆ getTitleSchemaType()

std::string getTitleSchemaType ( ) const

Obtain a symbolic name for the title attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getUsernameOfPoster()

std::string getUsernameOfPoster ( ) const

Returns the value of the username_of_poster attribute.

Returns
current value of the attribute.

◆ getUsernameOfPosterSchemaType()

std::string getUsernameOfPosterSchemaType ( ) const

Obtain a symbolic name for the username_of_poster attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getXref()

const ms_umod_xref * getXref ( const int idx ) const

Returns a read-only pointer to xref element by its number.

Parameters
idx number of the 'xref' element from 0 to (getNumberOfXrefs() - 1).
Returns
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.

◆ getXrefSchemaType()

std::string getXrefSchemaType ( ) const

Obtain a symbolic name for the xref element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveApproved()

bool haveApproved ( ) const

Indicates presence of the approved attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveDateTimeModified()

bool haveDateTimeModified ( ) const

Indicates presence of the date_time_modified attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveDateTimePosted()

bool haveDateTimePosted ( ) const

Indicates presence of the date_time_posted attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveDelta()

bool haveDelta ( ) const

Indicates presence of the delta element.

Returns
TRUE if the element 'delta' is present and FALSE otherwise.

◆ haveFullName()

bool haveFullName ( ) const

Indicates presence of the full_name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveGroupOfPoster()

bool haveGroupOfPoster ( ) const

Indicates presence of the group_of_poster attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveMiscNotes()

bool haveMiscNotes ( ) const

Indicates presence of the misc_notes element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveRecordID()

bool haveRecordID ( ) const

Indicates presence of the record_id attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveTitle()

bool haveTitle ( ) const

Indicates presence of the title attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveUsernameOfPoster()

bool haveUsernameOfPoster ( ) const

Indicates presence of the username_of_poster attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ isApproved()

bool isApproved ( ) const

Returns the value of the approved attribute.

Returns
current value of the attribute.

◆ isPrivacyEnabled()

bool isPrivacyEnabled ( ) const

Indicates whether privacy settings are enabled for this modification.

Returns
true if this modification has privacy enabled. Note: Not part of the Unimod schema file.

◆ isPrivate()

bool isPrivate ( ) const

Indicates whether this modification is private and so cannot be viewed or used. Only valid if privacy is enabled.

Returns
true if this modification is private and so cannot be viewed or used. Only valid if privacy is enabled. Note: Not part of the Unimod schema file.

◆ isSameAs()

bool isSameAs ( const ms_umod_modification & right_mod ) const

Returns true if instances contain the same information.

Compares all data members except modified date, posted date and user.

Parameters
right_mod another instance of this class to compare.
Returns
true if objects contain same information.

◆ operator=()

ms_umod_modification & operator= ( const ms_umod_modification & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setApproved()

void setApproved ( const bool value )

Set a custom value for the approved attribute.

Parameters
value a new value for the attribute.

◆ setDateTimeModified()

void setDateTimeModified ( const char * value )

Set a custom value for the date_time_modified attribute.

Parameters
value a new value for the attribute.

◆ setDateTimePosted()

void setDateTimePosted ( const char * value )

Set a custom value for the date_time_posted attribute.

Parameters
value a new value for the attribute.

◆ setDelta()

void setDelta ( const ms_umod_composition * delta )

Supply new content for the delta element.

Parameters
delta new content for the 'delta' object. If a NULL pointer is supplied instead of an object, the current content will be deleted and the 'delta' element will be dropped.

◆ setFullName()

void setFullName ( const char * value )

Set a custom value for the full_name attribute.

Parameters
value a new value for the attribute.

◆ setGroupOfPoster()

void setGroupOfPoster ( const char * value )

Set a custom value for the group_of_poster attribute.

Parameters
value a new value for the attribute.

◆ setMiscNotes()

void setMiscNotes ( const char * value )

Set a custom value for the misc_notes element.

Parameters
value a new value for the element.

◆ setPrivacyEnabled()

void setPrivacyEnabled ( bool b )

Sets whether privacy settings are enabled for this modification.

Parameters
b sets if this modification has privacy enabled.

◆ setPrivate()

void setPrivate ( bool b )

Sets whether this modification is private.

Parameters
b sets if this modification is private.

◆ setRecordID()

void setRecordID ( const char * value )

Set a custom value for the record_id attribute.

Parameters
value a new value for the attribute.

◆ setTitle()

void setTitle ( const char * value )

Set a custom value for the title attribute.

Parameters
value a new value for the attribute.

◆ setUsernameOfPoster()

void setUsernameOfPoster ( const char * value )

Set a custom value for the username_of_poster attribute.

Parameters
value a new value for the attribute.

◆ updateAltName()

bool updateAltName | ( | const int | idx,
 |  | const char * | alt_name
 | ) |  |

Update the string for a particular alt_name element.

Parameters
idx | number of the alt_name element for updating from 0 to (getNumberOfAltNames() - 1).
alt_name | an object to copy the content from.
Returns
TRUE if the element has been found and successfully updated and FALSE otherwise.

◆ updateIgnore()

bool updateIgnore | ( | const int | idx,
 |  | const ms_umod_composition * | ignore
 | ) |  |

Update the information for a particular Ignore element.

Parameters
idx | number of the Ignore element for updating from 0 to (getNumberOfIgnores() - 1).
ignore | an object to copy the content from.
Returns
TRUE if the object has been found and successfully updated and FALSE otherwise.

◆ updateMasses()

void updateMasses | ( | const ms_umod_configfile & | umodFile,
 |  | const ms_quant_component & | quantComp
 | ) |  |

Recalculates all deltas with isotope-substitution according to selected component in quantification.xml.

The method updates all deltas, neutral losses and ignore masses according to the selected isotope substitution. Masses are recalculated only in the current modification object, not in the whole Unimod file object umodFile. The Unimod file object is used only to retrieve masses of elements and their isotopes.

Parameters
umodFile | a Unimod file object.
quantComp | a component object from the quantitation.xml file.

◆ updateSpecificity()

bool updateSpecificity | ( | const int | idx,
 |  | const ms_umod_specificity * | specificity
 | ) |  |

Update the information for a particular specificity.

Parameters
idx | number of the specificity for updating from 0 to (getNumberOfSpecificities() - 1).
specificity | an object to copy the content from.
Returns
TRUE if the specificity has been found and successfully updated and FALSE otherwise.

◆ updateXref()

bool updateXref | ( | const int | idx,
 |  | const ms_umod_xref * | xref
 | ) |  |

Update the information for a particular xref element.

Parameters
idx | number of the xref element for updating from 0 to (getNumberOfXrefs() - 1)
xref | an object to copy the content from.
Returns
TRUE if the object has been found and successfully updated and FALSE otherwise.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_modification.hpp
  • ms_umod_modification.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_neutralloss Class Reference

  • matrix_science
  • ms_umod_neutralloss
Public Member Functions | List of all members
ms_umod_neutralloss Class Reference
Mascot configuration files module

Represents NeutralLoss and PepNeutralLoss objects in unimod.xml. More...

#include <ms_umod_neutralloss.hpp>

Inheritance diagram for ms_umod_neutralloss:
[legend]
Collaboration diagram for ms_umod_neutralloss:
[legend]

Public Member Functions

ms_umod_neutralloss ()
Default constructor.
ms_umod_neutralloss (const ms_quant_neutralloss &src, const ms_umod_configfile &umodFile)
Copying constructor.
ms_umod_neutralloss (const ms_quant_pepneutralloss &src, const ms_umod_configfile &umodFile)
Copying constructor.
ms_umod_neutralloss (const ms_umod_neutralloss &src)
Copying constructor.
virtual | ~ms_umod_neutralloss ()
Destructor.
void | appendElemRef (const ms_umod_elemref *elemref)
Adds a new element reference object at the end of the list.
void | clearElemRefs ()
Deletes all element reference objects from the list.
void | copyFrom (const ms_quant_composition *right, const ms_umod_configfile &umodFile)
Copies all content from another object.
void | copyFrom (const ms_quant_neutralloss *right, const ms_umod_configfile &umodFile)
Copies all content from another object.
void | copyFrom (const ms_quant_pepneutralloss *right, const ms_umod_configfile &umodFile)
Copies all content from another object.
void | copyFrom (const ms_umod_composition *right)
Copies all content from another instance.
void | copyFrom (const ms_umod_neutralloss *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElemRef (const int idx)
Remove an element reference object from the list in memory.
void | dropAvgeMass ()
Delete the avge_mass attribute.
void | dropCode ()
Delete the code attribute.
void | dropCompositionString ()
Delete the composition attribute.
void | dropDescription ()
Delete the description attribute.
void | dropFlag ()
Delete the flag attribute.
void | dropMonoMass ()
Delete the mono_mass attribute.
void | dropPairsWith ()
Delete the pairs_with attribute.
double | getAvgeMass () const
Returns the value of the avge_mass attribute.
std::string | getAvgeMassSchemaType () const
Obtain a symbolic name for the avge_mass attribute schema type.
std::string | getCode () const
Returns the value of the code attribute.
std::string | getCodeSchemaType () const
Obtain a symbolic name for the code attribute schema type.
std::string | getCompositionString () const
Returns the value of the composition attribute.
std::string | getCompositionStringSchemaType () const
Obtain a symbolic name for the composition attribute schema type.
std::string | getDescription () const
Returns the value of the description attribute.
std::string | getDescriptionSchemaType () const
Obtain a symbolic name for the description attribute schema type.
const ms_umod_elemref * | getElemRef (const int idx) const
Returns a read-only pointer to an element reference object by its number.
std::string | getElemRefSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getFlagSchemaType () const
Obtain a symbolic name for the flag attribute schema type.
double | getMonoMass () const
Returns the value of the mono_mass attribute.
std::string | getMonoMassSchemaType () const
Obtain a symbolic name for the mono_mass attribute schema type.
int | getNumberOfElemRefs () const
Returns the number of element reference objects currently held in memory.
std::string | getPairsWith () const
Returns the value of the pairs_with attribute.
std::string | getPairsWithSchemaType () const
Obtain a symbolic name for the pairs_with attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveAvgeMass () const
Indicates presence of the avge_mass attribute.
bool | haveCode () const
Indicates presence of the code attribute.
bool | haveCompositionString () const
Indicates presence of the composition attribute.
bool | haveDescription () const
Indicates presence of the description attribute.
bool | haveFlag () const
Indicates presence of the flag attribute.
bool | haveMonoMass () const
Indicates presence of the mono_mass attribute.
bool | havePairsWith () const
Indicates presence of the pairs_with attribute.
bool | isFlag () const
Returns the value of the flag attribute.
bool | isSameAs (const ms_umod_composition &right) const
Returns true if instances contain the same information.
ms_umod_neutralloss & | operator= (const ms_umod_neutralloss &right)
C++ style assignment operator.
void | setAvgeMass (const double value)
Set a custom value for the avge_mass attribute.
void | setCode (const char *value)
Set a custom value for the code attribute.
void | setCompositionString (const char *value)
Set a custom value for the composition attribute.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setFlag (const bool value)
Set a custom value for the flag attribute.
void | setMonoMass (const double value)
Set a custom value for the mono_mass attribute.
void | setPairsWith (const char *value)
Set a custom value for the pairs_with attribute.
bool | updateElemRef (const int idx, const ms_umod_elemref *elemref)
Update the information for a particular element reference object.
void | updateMasses (const ms_umod_configfile &umodFile, const ms_quant_component &quantComp)
Recalculates all deltas with isotope substitution according to selected component in quantification.xml.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents NeutralLoss and PepNeutralLoss objects in unimod.xml.

The only difference between a composition object and this object is the attribute 'flag' (which can be the required attribute for the PepNeutralLoss element).

Constructor & Destructor Documentation

◆ ms_umod_neutralloss() [1/4]

ms_umod_neutralloss ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_umod_neutralloss() [2/4]

ms_umod_neutralloss ( const ms_umod_neutralloss & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

◆ ms_umod_neutralloss() [3/4]

ms_umod_neutralloss | ( | const ms_quant_neutralloss & | src,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copying constructor.

Parameters
src | another object to copy the content from.
umodFile | a Unimod file object to extract element masses from.

◆ ms_umod_neutralloss() [4/4]

ms_umod_neutralloss | ( | const ms_quant_pepneutralloss & | src,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copying constructor.

Parameters
src | another object to copy the content from.
umodFile | a Unimod file object to extract element masses from.

Member Function Documentation

◆ appendElemRef()

void appendElemRef ( const ms_umod_elemref * elemref )
inherited

Adds a new element reference object at the end of the list.

Creates a new element reference object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters
elemref an instance of element reference object to copy the content from.

◆ copyFrom() [1/5]

void copyFrom | ( | const ms_quant_composition * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |
inherited

Copies all content from another object.

Parameters
right | another object to copy the content from.
umodFile | a Unimod file object to obtain element masses from.

◆ copyFrom() [2/5]

void copyFrom | ( | const ms_quant_neutralloss * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copies all content from another object.

Parameters
right | another object to copy the content from.
umodFile | a Unimod file object to obtain chemical element masses from.

◆ copyFrom() [3/5]

void copyFrom | ( | const ms_quant_pepneutralloss * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copies all content from another object.

Parameters
right | another object to copy the content from.
umodFile | a Unimod file object to obtain chemical element masses from.

◆ copyFrom() [4/5]

void copyFrom ( const ms_umod_composition * right )
inherited

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ copyFrom() [5/5]

void copyFrom ( const ms_umod_neutralloss * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteElemRef()

bool deleteElemRef ( const int idx )
inherited

Remove an element reference object from the list in memory.

Parameters
idx number of the element reference for deletion from 0 to (getNumberOfElemRefs() - 1).
Returns
TRUE if the object has been found and successfully deleted and FALSE otherwise.

◆ dropAvgeMass()

void dropAvgeMass ( )
inherited

Delete the avge_mass attribute.

Deletes the attribute until is re-set.

◆ dropCode()

void dropCode ( )

Delete the code attribute.

Deletes the attribute until it is re-set.

◆ dropCompositionString()

void dropCompositionString ( )
inherited

Delete the composition attribute.

Deletes the attribute until it is re-set.

◆ dropDescription()

void dropDescription ( )

Delete the description attribute.

Deletes the attribute until it is re-set.

◆ dropFlag()

void dropFlag ( )

Delete the flag attribute.

Deletes the attribute until it is re-set.

◆ dropMonoMass()

void dropMonoMass ( )
inherited

Delete the mono_mass attribute.

Deletes the attribute until is re-set.

◆ dropPairsWith()

void dropPairsWith ( )

Delete the pairs_with attribute.

Deletes the attribute until it is re-set.

◆ getAvgeMass()

double getAvgeMass ( ) const
inherited

Returns the value of the avge_mass attribute.

Average mass for the object.

Returns
current value of the attribute.

◆ getAvgeMassSchemaType()

std::string getAvgeMassSchemaType ( ) const
inherited

Obtain a symbolic name for the avge_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getCode()

std::string getCode ( ) const

Returns the value of the code attribute.

The single-letter code for the fragment of the monolink.

Returns
current value of the attribute.

◆ getCodeSchemaType()

std::string getCodeSchemaType ( ) const

Obtain a symbolic name for the code attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getCompositionString()

std::string getCompositionString ( ) const
inherited

Returns the value of the composition attribute.

A composition string for the object.

Returns
current value of the attribute.

◆ getCompositionStringSchemaType()

std::string getCompositionStringSchemaType ( ) const
inherited

Obtain a symbolic name for the composition attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getDescription()

std::string getDescription ( ) const

Returns the value of the description attribute.

The partner codes for the monolink.

Returns
current value of the attribute.

◆ getDescriptionSchemaType()

std::string getDescriptionSchemaType ( ) const

Obtain a symbolic name for the description attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getElemRef()

const ms_umod_elemref * getElemRef ( const int idx ) const
inherited

Returns a read-only pointer to an element reference object by its number.

Retrieves an element reference object from the list by its number.

Parameters
idx number of the reference from 0 to (getNumberOfElemRefs() - 1).
Returns
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.

◆ getElemRefSchemaType()

std::string getElemRefSchemaType ( ) const
inherited

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getFlagSchemaType()

std::string getFlagSchemaType ( ) const

Obtain a symbolic name for the flag attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMonoMass()

double getMonoMass ( ) const
inherited

Returns the value of the mono_mass attribute.

Monoisotopic mass for the object.

Returns
current value of the attribute.

◆ getMonoMassSchemaType()

std::string getMonoMassSchemaType ( ) const
inherited

Obtain a symbolic name for the mono_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfElemRefs()

int getNumberOfElemRefs ( ) const
inherited

Returns the number of element reference objects currently held in memory.

Returns
total number of chemical element references in the composition object.

◆ getPairsWith()

std::string getPairsWith ( ) const

Returns the value of the pairs_with attribute.

The partner codes for the monolink.

Returns
current value of the attribute.

◆ getPairsWithSchemaType()

std::string getPairsWithSchemaType ( ) const

Obtain a symbolic name for the pairs_with attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

Reimplemented from ms_umod_composition.

◆ haveAvgeMass()

bool haveAvgeMass ( ) const
inherited

Indicates presence of the avge_mass attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveCode()

bool haveCode ( ) const

Indicates presence of the code attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveCompositionString()

bool haveCompositionString ( ) const
inherited

Indicates presence of the composition attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveDescription()

bool haveDescription ( ) const

Indicates presence of the description attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveFlag()

bool haveFlag ( ) const

Indicates presence of the flag attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveMonoMass()

bool haveMonoMass ( ) const
inherited

Indicates presence of the mono_mass attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ havePairsWith()

bool havePairsWith ( ) const

Indicates presence of the pairs_with attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ isFlag()

bool isFlag ( ) const

Returns the value of the flag attribute.

Returns
current value of the attribute.

◆ isSameAs()

bool isSameAs ( const ms_umod_composition & right ) const
inherited

Returns true if instances contain the same information.

Compares the element symbols and number of symbols that make up the composition regardless of storage order. Element symbols may be specified in the composition but have a count of zero and so do not affect the total mass values.

Parameters
right another instance of this class to compare.
Returns
true if the two compositions are equivalent.

◆ operator=()

ms_umod_neutralloss & operator= ( const ms_umod_neutralloss & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setAvgeMass()

void setAvgeMass ( const double value )
inherited

Set a custom value for the avge_mass attribute.

Parameters
value a new value for the attribute.

◆ setCode()

void setCode ( const char * value )

Set a custom value for the code attribute.

Parameters
value a new value for the attribute.

◆ setCompositionString()

void setCompositionString ( const char * value )
inherited

Set a custom value for the composition attribute.

Parameters
value a new value for the attribute.

◆ setDescription()

void setDescription ( const char * value )

Set a custom value for the description attribute.

Parameters
value a new value for the attribute.

◆ setFlag()

void setFlag ( const bool value )

Set a custom value for the flag attribute.

Parameters
value a new value for the attribute.

◆ setMonoMass()

void setMonoMass ( const double value )
inherited

Set a custom value for the mono_mass attribute.

Parameters
value a new value for the attribute.

◆ setPairsWith()

void setPairsWith ( const char * value )

Set a custom value for the pairs_with attribute.

Parameters
value a new value for the attribute.

◆ updateElemRef()

bool updateElemRef | ( | const int | idx,
 |  | const ms_umod_elemref * | elemref
 | ) |  |
inherited

Update the information for a particular element reference object.

Parameters
idx | number of the element reference for updating from 0 to (getNumberOfElemRefs() - 1).
elemref | an object to copy the content from.
Returns
TRUE if the element reference has been found and successfully updated and FALSE otherwise.

◆ updateMasses()

void updateMasses | ( | const ms_umod_configfile & | umodFile,
 |  | const ms_quant_component & | quantComp
 | ) |  |
inherited

Recalculates all deltas with isotope substitution according to selected component in quantification.xml.

The method updates masses according to the selected isotope substitution. Masses are recalculated only in the current modification object, not in the whole Unimod file object umodFile. The Unimod file object is used only to retrieve masses of elements and their isotopes.

Parameters
umodFile | Unimod file object.
quantComp | component object from quantitation.xml.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_umod_composition.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_umod_composition.

The documentation for this class was generated from the following files:
  • ms_umod_neutralloss.hpp
  • ms_umod_neutralloss.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_specificity Class Reference

  • matrix_science
  • ms_umod_specificity
Public Member Functions | List of all members
ms_umod_specificity Class Reference
Mascot configuration files module

Represents modification specificity objects in unimod.xml. More...

#include <ms_umod_specificity.hpp>

Public Member Functions

ms_umod_specificity ()
Default constructor.
ms_umod_specificity (const ms_quant_specificity &src, const ms_umod_configfile &umodFile)
Copying constructor that takes an object from quantitation.xml.
ms_umod_specificity (const ms_umod_specificity &src)
Copying constructor.
virtual | ~ms_umod_specificity ()
Destructor.
void | appendNeutralLoss (const ms_umod_neutralloss *nl)
Adds a new 'NeutralLoss' element at the end of the list.
void | appendPepNeutralLoss (const ms_umod_neutralloss *pnl)
Adds a new 'PepNeutralLoss' element at the end of the list.
void | clearNeutralLosses ()
Deletes all 'NeutralLoss' elements from the list.
void | clearPepNeutralLosses ()
Deletes all 'PepNeutralLoss' elements from the list.
void | copyFrom (const ms_quant_specificity *right, const ms_umod_configfile &umodFile)
Copies all content from an object of quantitation.xml.
void | copyFrom (const ms_umod_specificity *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteNeutralLoss (const int idx)
Remove a 'NeutralLoss' element from the list in memory.
bool | deletePepNeutralLoss (const int idx)
Remove a 'PepNeutralLoss' element object from the list in memory.
void | dropClassification ()
Delete the classification attribute.
void | dropHidden ()
Delete the hidden attribute.
void | dropMiscNotes ()
Delete the misc_notes element.
void | dropPosition ()
Delete the position attribute.
void | dropSite ()
Delete the site attribute.
void | dropSpecGroup ()
Delete the spec_group attribute.
std::string | getClassification () const
Returns the value of the classification attribute.
std::string | getClassificationSchemaType () const
Obtain a symbolic name for the classification attribute schema type.
std::string | getHiddenSchemaType () const
Obtain a symbolic name for the hidden attribute schema type.
std::string | getMiscNotes () const
Returns the value of the misc_notes element.
std::string | getMiscNotesSchemaType () const
Obtain a symbolic name for the misc_notes element schema type.
const ms_umod_neutralloss * | getNeutralLoss (const int idx) const
Returns a read-only pointer to a 'NeutralLoss' element by its number.
std::string | getNeutralLossSchemaType () const
Obtain a symbolic name for the 'NeutralLoss' element schema type.
int | getNumberOfNeutralLosses () const
Returns the number of 'NeutralLoss' elements currently held in memory.
int | getNumberOfPepNeutralLosses () const
Returns the number of 'PepNeutralLoss' elements currently held in memory.
const ms_umod_neutralloss * | getPepNeutralLoss (const int idx) const
Returns a read-only pointer to a 'PepNeutralLoss' element object by its number.
std::string | getPepNeutralLossSchemaType () const
Obtain a symbolic name for the 'NeutralLoss' element schema type.
std::string | getPosition () const
Returns the value of the position attribute.
std::string | getPositionSchemaType () const
Obtain a symbolic name for the position attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSite () const
Returns the value of the site attribute.
std::string | getSiteSchemaType () const
Obtain a symbolic name for the site attribute schema type.
int | getSpecGroup () const
Returns the value of the spec_group attribute.
std::string | getSpecGroupSchemaType () const
Obtain a symbolic name for the spec_group attribute schema type.
bool | haveClassification () const
Indicates presence of the classification attribute.
bool | haveHidden () const
Indicates presence of the hidden attribute.
bool | haveMiscNotes () const
Indicates presence of the misc_notes element.
bool | havePosition () const
Indicates presence of the position attribute.
bool | haveSite () const
Indicates presence of the site attribute.
bool | haveSpecGroup () const
Indicates presence of the spec_group attribute.
bool | inErrorTolerant () const
bool | inLongList () const
Indicates whether this specificity is in the full list on the Mascot search form.
bool | inShortList () const
Indicates whether this specificity is in the short list on the Mascot search form.
bool | isHidden () const
Returns the value of the hidden attribute.
bool | isSameAs (const ms_umod_specificity &right) const
Returns true if instances contain the same information.
ms_umod_specificity & | operator= (const ms_umod_specificity &right)
C++ style assignment operator.
void | setClassification (const char *value)
Set a custom value for the classification attribute.
void | setHidden (const bool value)
Set a custom value for the hidden attribute.
void | setMiscNotes (const char *value)
Set a custom value for the misc_notes element.
void | setPosition (const char *value)
Set a custom value for the position attribute.
void | setSite (const char *value)
Set a custom value for the site attribute.
void | setSpecGroup (const int value)
Set a custom value for the spec_group attribute.
void | showInLongList (bool b)
void | showInShortList (bool b)
bool | updateNeutralLoss (const int idx, const ms_umod_neutralloss *nl)
Update the information for a particular 'NeutralLoss' element.
bool | updatePepNeutralLoss (const int idx, const ms_umod_neutralloss *pnl)
Update the information for a particular 'PepNeutralLoss' element.
void | useInErrorTolerant (bool b)
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents modification specificity objects in unimod.xml.

Constructor & Destructor Documentation

◆ ms_umod_specificity() [1/3]

ms_umod_specificity ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_umod_specificity() [2/3]

ms_umod_specificity ( const ms_umod_specificity & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

◆ ms_umod_specificity() [3/3]

ms_umod_specificity | ( | const ms_quant_specificity & | src,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copying constructor that takes an object from quantitation.xml.

Parameters
src | an instance of quantitation.xml class to copy the content from.
umodFile | a Unimod file object to extract element masses from.

Member Function Documentation

◆ appendNeutralLoss()

void appendNeutralLoss ( const ms_umod_neutralloss * nl )

Adds a new 'NeutralLoss' element at the end of the list.

Creates a new neutral loss object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters
nl an instance of neutral loss object to copy the content from.

◆ appendPepNeutralLoss()

void appendPepNeutralLoss ( const ms_umod_neutralloss * pnl )

Adds a new 'PepNeutralLoss' element at the end of the list.

Creates a new peptide neutral loss object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters
pnl an instance of peptide neutral loss object to copy the content from.

◆ copyFrom() [1/2]

void copyFrom | ( | const ms_quant_specificity * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copies all content from an object of quantitation.xml.

Parameters
right | an instance of a quantitation.xml class.
umodFile | a Unimod file object to extract element masses from.

◆ copyFrom() [2/2]

void copyFrom ( const ms_umod_specificity * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteNeutralLoss()

bool deleteNeutralLoss ( const int idx )

Remove a 'NeutralLoss' element from the list in memory.

Parameters
idx number of the neutral loss for deletion from 0 to (getNumberOfNeutralLosses() - 1).
Returns
TRUE if the object has been found and successfully deleted and FALSE otherwise.

◆ deletePepNeutralLoss()

bool deletePepNeutralLoss ( const int idx )

Remove a 'PepNeutralLoss' element object from the list in memory.

Parameters
idx number of the peptide neutral loss for deletion from 0 to (getNumberOfPepNeutralLosses() - 1).
Returns
TRUE if the object has been found and successfully deleted and FALSE otherwise.

◆ dropClassification()

void dropClassification ( )

Delete the classification attribute.

Deletes the attribute until is re-set.

◆ dropHidden()

void dropHidden ( )

Delete the hidden attribute.

Deletes the attribute until is re-set.

◆ dropMiscNotes()

void dropMiscNotes ( )

Delete the misc_notes element.

Deletes the element until it is re-set.

◆ dropPosition()

void dropPosition ( )

Delete the position attribute.

Deletes the attribute until is re-set.

◆ dropSite()

void dropSite ( )

Delete the site attribute.

Deletes the attribute until is re-set.

◆ dropSpecGroup()

void dropSpecGroup ( )

Delete the spec_group attribute.

Deletes the attribute until is re-set.

◆ getClassification()

std::string getClassification ( ) const

Returns the value of the classification attribute.

Returns
current value of the attribute.

◆ getClassificationSchemaType()

std::string getClassificationSchemaType ( ) const

Obtain a symbolic name for the classification attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getHiddenSchemaType()

std::string getHiddenSchemaType ( ) const

Obtain a symbolic name for the hidden attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getMiscNotes()

std::string getMiscNotes ( ) const

Returns the value of the misc_notes element.

Returns
current value of the element.

◆ getMiscNotesSchemaType()

std::string getMiscNotesSchemaType ( ) const

Obtain a symbolic name for the misc_notes element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNeutralLoss()

const ms_umod_neutralloss * getNeutralLoss ( const int idx ) const

Returns a read-only pointer to a 'NeutralLoss' element by its number.

Parameters
idx number of the neutral loss from 0 to (getNumberOfNeutralLosses() - 1).
Returns
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.

◆ getNeutralLossSchemaType()

std::string getNeutralLossSchemaType ( ) const

Obtain a symbolic name for the 'NeutralLoss' element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getNumberOfNeutralLosses()

int getNumberOfNeutralLosses ( ) const

Returns the number of 'NeutralLoss' elements currently held in memory.

Returns
total number of neutral losses in the specificity.

◆ getNumberOfPepNeutralLosses()

int getNumberOfPepNeutralLosses ( ) const

Returns the number of 'PepNeutralLoss' elements currently held in memory.

Returns
total number of peptide neutral losses in the specificity.

◆ getPepNeutralLoss()

const ms_umod_neutralloss * getPepNeutralLoss ( const int idx ) const

Returns a read-only pointer to a 'PepNeutralLoss' element object by its number.

Parameters
idx number of the peptide neutral loss from 0 to (getNumberOfPepNeutralLosses() - 1).
Returns
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.

◆ getPepNeutralLossSchemaType()

std::string getPepNeutralLossSchemaType ( ) const

Obtain a symbolic name for the 'NeutralLoss' element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getPosition()

std::string getPosition ( ) const

Returns the value of the position attribute.

Returns
Position of the specificity that should be one of the Type mqm:positionType values.

◆ getPositionSchemaType()

std::string getPositionSchemaType ( ) const

Obtain a symbolic name for the position attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ getSite()

std::string getSite ( ) const

Returns the value of the site attribute.

Returns
Site string that should be one of the Type mqm:siteType values.

◆ getSiteSchemaType()

std::string getSiteSchemaType ( ) const

Obtain a symbolic name for the site attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getSpecGroup()

int getSpecGroup ( ) const

Returns the value of the spec_group attribute.

Returns
current value of the attribute.

◆ getSpecGroupSchemaType()

std::string getSpecGroupSchemaType ( ) const

Obtain a symbolic name for the spec_group attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveClassification()

bool haveClassification ( ) const

Indicates presence of the classification attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveHidden()

bool haveHidden ( ) const

Indicates presence of the hidden attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveMiscNotes()

bool haveMiscNotes ( ) const

Indicates presence of the misc_notes element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ havePosition()

bool havePosition ( ) const

Indicates presence of the position attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveSite()

bool haveSite ( ) const

Indicates presence of the site attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveSpecGroup()

bool haveSpecGroup ( ) const

Indicates presence of the spec_group attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ inErrorTolerant()

bool inErrorTolerant ( ) const
Returns
true if this specificity is included in error tolerant searches in mascot.

◆ inLongList()

bool inLongList ( ) const

Indicates whether this specificity is in the full list on the Mascot search form.

Returns
true if this specificity is required in the mascot search form full list.

◆ inShortList()

bool inShortList ( ) const

Indicates whether this specificity is in the short list on the Mascot search form.

Returns
true if this specificity is required in the mascot search form short list.

◆ isHidden()

bool isHidden ( ) const

Returns the value of the hidden attribute.

Returns
current value of the attribute.

◆ isSameAs()

bool isSameAs ( const ms_umod_specificity & right ) const

Returns true if instances contain the same information.

Parameters
right another instance of this class to compare.
Returns
true if the specificities are equivalent.

◆ operator=()

ms_umod_specificity & operator= ( const ms_umod_specificity & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setClassification()

void setClassification ( const char * value )

Set a custom value for the classification attribute.

Parameters
value a new value for the attribute.

◆ setHidden()

void setHidden ( const bool value )

Set a custom value for the hidden attribute.

Parameters
value a new value for the attribute.

◆ setMiscNotes()

void setMiscNotes ( const char * value )

Set a custom value for the misc_notes element.

Parameters
value a new value for the element.

◆ setPosition()

void setPosition ( const char * value )

Set a custom value for the position attribute.

Parameters
value Position of the specificity that should be one of the Type mqm:positionType values.

◆ setSite()

void setSite ( const char * value )

Set a custom value for the site attribute.

Parameters
value that should be one of the Type mqm:siteType values.

◆ setSpecGroup()

void setSpecGroup ( const int value )

Set a custom value for the spec_group attribute.

Parameters
value a new value for the attribute.

◆ showInLongList()

void showInLongList ( bool b )
Parameters
b sets if this specificity is required in the mascot search form full list.

◆ showInShortList()

void showInShortList ( bool b )
Parameters
b sets if this specificity is required in the mascot search form short list.

◆ updateNeutralLoss()

bool updateNeutralLoss | ( | const int | idx,
 |  | const ms_umod_neutralloss * | nl
 | ) |  |

Update the information for a particular 'NeutralLoss' element.

Parameters
idx | number of the neutral loss object for updating from 0 to (getNumberOfNeutralLosses() - 1).
nl | an object to copy the content from.
Returns
TRUE if the neutral loss has been found and successfully updated and FALSE otherwise.

◆ updatePepNeutralLoss()

bool updatePepNeutralLoss | ( | const int | idx,
 |  | const ms_umod_neutralloss * | pnl
 | ) |  |

Update the information for a particular 'PepNeutralLoss' element.

Parameters
idx | number of the peptide neutral loss object for updating from 0 to (getNumberOfPepNeutralLosses() - 1).
pnl | an object to copy the content from.
Returns
TRUE if the peptide neutral loss has been found and successfully updated and FALSE otherwise.

◆ useInErrorTolerant()

void useInErrorTolerant ( bool b )
Parameters
b sets if this specificity is required in error tolerant searches.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_specificity.hpp
  • ms_umod_specificity.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_xref Class Reference

  • matrix_science
  • ms_umod_xref
Public Member Functions | List of all members
ms_umod_xref Class Reference
Mascot configuration files module

Represents the cross references objects in unimod.xml. More...

#include <ms_umod_xref.hpp>

Inherits ms_xml_IValidatable.

Public Member Functions

ms_umod_xref ()
Default constructor.
ms_umod_xref (const ms_umod_xref &src)
Copying constructor.
virtual | ~ms_umod_xref ()
Destructor.
void | copyFrom (const ms_umod_xref *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropSource ()
Delete the source element.
void | dropText ()
Delete the text element.
void | dropUrl ()
Delete the url element.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSource () const
Returns the value of the source element.
std::string | getSourceSchemaType () const
Obtain a symbolic name for the source element schema type.
std::string | getText () const
Returns the value of the text element.
std::string | getTextSchemaType () const
Obtain a symbolic name for the text element schema type.
std::string | getUrl () const
Returns the value of the url element.
std::string | getUrlSchemaType () const
Obtain a symbolic name for the url element schema type.
bool | haveSource () const
Indicates presence of the source element.
bool | haveText () const
Indicates presence of the text element.
bool | haveUrl () const
Indicates presence of the url element.
bool | isSameAs (const ms_umod_xref &right) const
Returns true if instances contain the same information.
ms_umod_xref & | operator= (const ms_umod_xref &right)
C++ style assignment operator.
void | setSource (const char *value)
Set a custom value for the source element.
void | setText (const char *value)
Set a custom value for the text element.
void | setUrl (const char *value)
Set a custom value for the url element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents the cross references objects in unimod.xml.

Constructor & Destructor Documentation

◆ ms_umod_xref() [1/2]

ms_umod_xref ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_umod_xref() [2/2]

ms_umod_xref ( const ms_umod_xref & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_umod_xref * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropSource()

void dropSource ( )

Delete the source element.

Deletes the element until it is re-set.

◆ dropText()

void dropText ( )

Delete the text element.

Deletes the element until it is re-set.

◆ dropUrl()

void dropUrl ( )

Delete the url element.

Deletes the element until it is re-set.

◆ getSchemaType()

std::string getSchemaType ( ) const
virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "umod:nameType")

◆ getSource()

std::string getSource ( ) const

Returns the value of the source element.

Returns
current value of the element.

◆ getSourceSchemaType()

std::string getSourceSchemaType ( ) const

Obtain a symbolic name for the source element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getText()

std::string getText ( ) const

Returns the value of the text element.

Returns
current value of the element.

◆ getTextSchemaType()

std::string getTextSchemaType ( ) const

Obtain a symbolic name for the text element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ getUrl()

std::string getUrl ( ) const

Returns the value of the url element.

Returns
current value of the element.

◆ getUrlSchemaType()

std::string getUrlSchemaType ( ) const

Obtain a symbolic name for the url element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

◆ haveSource()

bool haveSource ( ) const

Indicates presence of the source element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveText()

bool haveText ( ) const

Indicates presence of the text element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ haveUrl()

bool haveUrl ( ) const

Indicates presence of the url element.

Returns
TRUE if the element is present and FALSE otherwise.

◆ isSameAs()

bool isSameAs ( const ms_umod_xref & right ) const

Returns true if instances contain the same information.

Ignores carriage return characters when comparing the text.

Parameters
right another instance of this class to compare.
Returns
true if the two instances are equivalent.

◆ operator=()

ms_umod_xref & operator= ( const ms_umod_xref & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setSource()

void setSource ( const char * value )

Set a custom value for the source element.

Parameters
value a new value for the element.

◆ setText()

void setText ( const char * value )

Set a custom value for the text element.

Parameters
value a new value for the element.

◆ setUrl()

void setUrl ( const char * value )

Set a custom value for the url element.

Parameters
value a new value for the element.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const
virtual

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_xref.hpp
  • ms_umod_xref.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_unigeneoptions Class Reference

  • matrix_science
  • ms_unigeneoptions
Public Member Functions | List of all members
ms_unigeneoptions Class Reference
Mascot configuration files module

An instance of this class represents all the parameters specified in UniGene section of mascot.dat. More...

#include <ms_unigeneoptions.hpp>

Inheritance diagram for ms_unigeneoptions:
[legend]
Collaboration diagram for ms_unigeneoptions:
[legend]

Public Member Functions

ms_unigeneoptions ()
Default constructor.
ms_unigeneoptions (const ms_unigeneoptions &src)
Copying constructor.
virtual | ~ms_unigeneoptions ()
Destructor.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_unigeneoptions *right)
Can be used to create a copy of another object.
virtual void | defaultValues ()
Initialises the instance with default values.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
bool | isSectionAvailable () const
Indicates whether the section has been actually read from the file.
ms_unigeneoptions & | operator= (const ms_unigeneoptions &right)
C++ style assignment operator.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. should it be saved in a file.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

An instance of this class represents all the parameters specified in UniGene section of mascot.dat.

An instance of this class is created and populated in ms_datfile and is available by calling ms_datfile::getUniGeneOptions(). It can also be created separately and initialised with default values. You can create an instance of the class or copy from another instance in order to pass it then as an options-containing object.

For detailed information on any of the options please consult Mascot manual.

Currently, access to the values is only provided through the ms_customproperty class, from which this class is derived. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Constructor & Destructor Documentation

◆ ms_unigeneoptions() [1/2]

ms_unigeneoptions ( )

Default constructor.

Note
Not normally called from outside Mascot Parser.

◆ ms_unigeneoptions() [2/2]

ms_unigeneoptions ( const ms_unigeneoptions & src )

Copying constructor.

Note
Not normally called from outside Mascot Parser.
Parameters
src unigene options object

◆ ~ms_unigeneoptions()

~ms_unigeneoptions ( )
virtual

Destructor.

Note
Not normally called from outside Mascot Parser.

Member Function Documentation

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ copyFrom()

void copyFrom ( const ms_unigeneoptions * right )

Can be used to create a copy of another object.

Note
Not normally called from outside Mascot Parser.
Parameters
right is the source to be copied.

◆ defaultValues()

void defaultValues ( )
virtual

Initialises the instance with default values.

Note
Not normally called from outside Mascot Parser.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ isSectionAvailable()

bool isSectionAvailable ( ) const

Indicates whether the section has been actually read from the file.

By default the UniGene section is unavailable until it has been set to a different state.

Returns
true if the section is available.

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ setSectionAvailable()

void setSectionAvailable ( const bool value )

Changes availability of the section, i.e. should it be saved in a file.

Parameters
value should be true to make the section available.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_unigeneoptions.hpp
  • ms_unigeneoptions.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_wwwentry Class Reference

  • matrix_science
  • ms_wwwentry
Public Member Functions | List of all members
ms_wwwentry Class Reference
Mascot configuration files module

Represent a single entry in the WWW section of mascot.dat. More...

#include <ms_wwwoptions.hpp>

Public Member Functions

ms_wwwentry ()
Default constructor.
ms_wwwentry (const ms_wwwentry &src)
Copying constructor.
~ms_wwwentry ()
Destructor.
void | copyFrom (const ms_wwwentry *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
std::string | getHostName () const
Returns a host name used to retrieve reports from.
std::string | getName () const
Returns the name of the database the entry refers to.
int | getParseRule () const
Returns a parse rule number for the entry that corresponds to one of the parse rules specified in the PARSE section of mascot.dat.
std::string | getPath () const
Returns a path to the executable and parameters.
int | getPortNumber () const
Returns a port number for the host used as the information source.
WWW_TYPE | getType () const
Returns the name of the database the entry refers to.
ms_wwwentry & | operator= (const ms_wwwentry &right)
Assignment operator for C++ client applications.
void | setHostName (const char *value)
Change the host name parameter.
void | setName (const char *value)
Set the database name for the entry.
void | setParseRule (const int value)
Change the parse rule number for the entry.
void | setPath (const char *value)
Change the path.
void | setPortNumber (const int value)
Change the port number.
void | setType (const WWW_TYPE value)
Change the entry type.

Detailed Description

Represent a single entry in the WWW section of mascot.dat.

Instances of this class can be stored in in ms_wwwoptions to represent the whole section. Consult the Mascot manual if you are unsure how to configure an entry. It defines an information source where CGI scripts look for the information needed to compile a results report.

Member Function Documentation

◆ getHostName()

std::string getHostName ( ) const

Returns a host name used to retrieve reports from.

For ms-getseq.exe or a similar local executable, this attribute should contain localhost. The word localhost is used to determine whether the application is a command line executable or a CGI application. If you want to specify a CGI application on the local server, just specify the hostname in some other way, for example 127.0.0.1).

For a remote source, or a local source that will be queried as a CGI application, this should be the hostname.

Default is localhost.

See also
getPortNumber()
Returns
host name

◆ getName()

std::string getName ( ) const

Returns the name of the database the entry refers to.

Note that database name is case sensitive.

The name should be one of those specified in the Databases section. Every name can be associated with more than one entry in the WWW section as different entry types are supported. In order to retrieve the entry type use getType().

By default this is an empty string.

Returns
name
Examples
config_mascotdat.cpp.

◆ getParseRule()

int getParseRule ( ) const

Returns a parse rule number for the entry that corresponds to one of the parse rules specified in the PARSE section of mascot.dat.

The index of a rule in the PARSE section that can be used to extract the information required.

Default is -1, which is an invalid rule number.

Returns
parse rule number

◆ getPath()

std::string getPath ( ) const

Returns a path to the executable and parameters.

A string containing the path to the executable and parameters, some of which are variables.

By default this is empty.

Returns
path

◆ getPortNumber()

int getPortNumber ( ) const

Returns a port number for the host used as the information source.

In most cases it should be left as 80, which is the default value.

See also
getHostName()
Returns
port number

◆ getType()

WWW_TYPE getType ( ) const

Returns the name of the database the entry refers to.

Several entry types are supported. For the complete list of types, see the enumeration values in WWW_TYPE.

There is no default value for this parameter.

Returns
type
Examples
config_mascotdat.cpp.

◆ setHostName()

void setHostName ( const char * value )

Change the host name parameter.

See getHostName() for more information.

Parameters
value new host name

◆ setName()

void setName ( const char * value )

Set the database name for the entry.

See getName() for more information.

Parameters
value new name

◆ setParseRule()

void setParseRule ( const int value )

Change the parse rule number for the entry.

See getParseRule() for more information.

Parameters
value new parse rule number

◆ setPath()

void setPath ( const char * value )

Change the path.

See getPath() for more information.

Parameters
value path

◆ setPortNumber()

void setPortNumber ( const int value )

Change the port number.

See getPortNumber() for more information.

Parameters
value new port number

◆ setType()

void setType ( const WWW_TYPE value )

Change the entry type.

See getType() for more information.

Parameters
value new type
The documentation for this class was generated from the following files:
  • ms_wwwoptions.hpp
  • ms_wwwoptions.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_wwwoptions Class Reference

  • matrix_science
  • ms_wwwoptions
Public Member Functions | List of all members
ms_wwwoptions Class Reference
Mascot configuration files module

Represents the whole WWW section. More...

#include <ms_wwwoptions.hpp>

Inheritance diagram for ms_wwwoptions:
[legend]
Collaboration diagram for ms_wwwoptions:
[legend]

Public Member Functions

ms_wwwoptions ()
Default constructor.
ms_wwwoptions (const ms_wwwoptions &src)
Copying constructor.
~ms_wwwoptions ()
Destructor.
void | appendEntry (const ms_wwwentry *item)
Append a new entry which is a copy of the only parameter.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | clearEntries ()
Deletes all entries from the list.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | copyFrom (const ms_wwwoptions *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
void | dropEntry (const int index)
Make the entry at the given index unavailable.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
const ms_wwwentry * | getEntry (const int index) const
Returns an entry by its index.
int | getNumberOfEntries () const
Returns the total number of entries in the section.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
const ms_wwwentry * | getRepEntryByName (const char *dbName) const
Searches the entries list for the given name and type of REP.
const ms_wwwentry * | getSeqEntryByName (const char *dbName) const
Searches the entries list for the given name and type of SEQ.
bool | isSectionAvailable () const
Check whether the section has been actually read from the file.
ms_wwwoptions & | operator= (const ms_wwwoptions &right)
Assignment operator for C++ client applications.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setEntry (const int index, const ms_wwwentry *item)
Update the entry at the given index.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

Represents the whole WWW section.

The WWW section defines where CGI scripts look for the information needed to compile a results report. At least one entry is required for each database, to define the source from which the sequence string of a database entry can be obtained. A second line can optionally define the source from which the full text report of an entry can be obtained. The syntax is very similar in both cases, independent of whether the information originates locally or on a remote system.

An instance of this class holds a list of entries (see ms_wwwentry) that can be obtained and dealt with individually. By default the list is empty.

For detailed information on any of the options please consult the Mascot manual.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples
config_mascotdat.cpp.

Member Function Documentation

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ delProp()

void delProp ( const char * str )
inherited

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )
inherited

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ dropEntry()

void dropEntry ( const int index )

Make the entry at the given index unavailable.

This is achieved by deleting the corresponding line from the mascot.dat file. This does not affect the indices of other entries in this instance of the object. In other words, dropping an entry will reset the value at that index to a default, and the gap is plugged the next time the file is loaded.

Parameters
index The index of the entry to delete, between 0 and getNumberOfEntries()-1.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const
 inherited

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const
inherited

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const
inherited

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getEntry()

const ms_wwwentry * getEntry ( const int index ) const

Returns an entry by its index.

See getNumberOfEntries() for more information.

Parameters
index The entry to return, between 0 and getNumberOfEntries()-1.
Returns
pointer to an entry
Examples
config_mascotdat.cpp.

◆ getNumberOfEntries()

int getNumberOfEntries ( ) const

Returns the total number of entries in the section.

Note that there might be several entries associated with each database. Therefore, total number of entries differs with the number of databases in Databases section.

The entries are not ordered and are represented as is. Use specific functions such as getSeqEntryByName() and getRepEntryByName() to retrieve the entry by name, or getEntry() by the entry index.

Returns
number of entries
Examples
config_mascotdat.cpp.

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const
inherited

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const
inherited

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const
inherited

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const
inherited

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const
inherited

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ getRepEntryByName()

const ms_wwwentry * getRepEntryByName ( const char * dbName ) const

Searches the entries list for the given name and type of REP.

If an entry is not found, a null value is returned. Note that database names are case sensitive.

Parameters
dbName name to get entry from
Returns
pointer to an entry whose name is in parameter

◆ getSeqEntryByName()

const ms_wwwentry * getSeqEntryByName ( const char * dbName ) const

Searches the entries list for the given name and type of SEQ.

If an entry is not found, a null value is returned. Note that database names are case sensitive.

Parameters
dbName name to get entry from
Returns
pointer to an entry whose name is in parameter

◆ isSectionAvailable()

bool isSectionAvailable ( ) const

Check whether the section has been actually read from the file.

By default the WWW section is unavailable until it has been set to a different state.

Returns
true if the section has been set to available, false otherwise
Examples
config_mascotdat.cpp.

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )
inherited

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setEntry()

void setEntry | ( | const int | index,
 |  | const ms_wwwentry * | item
 | ) |  |

Update the entry at the given index.

Parameters
index | The index of the entry to update, between 0 and getNumberOfEntries()-1.
item | The data to update with. Member fields of item will copied to the underlying object.

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )
inherited

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |
inherited

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |
inherited

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |
inherited

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |
inherited

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_wwwoptions.hpp
  • ms_wwwoptions.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_xml_parameter Class Reference

  • matrix_science
  • ms_xml_parameter
Public Member Functions | List of all members
ms_xml_parameter Class Referenceabstract
Mascot configuration files module

Parameter name and value pair. More...

#include <ms_xml_parameters.hpp>

Inheritance diagram for ms_xml_parameter:
[legend]

Public Member Functions

ms_xml_parameter ()
Default constructor.
ms_xml_parameter (const ms_xml_parameter &src)
Copying constructor.
virtual | ~ms_xml_parameter ()
Destructor.
void | copyFrom (const ms_xml_parameter *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropDescription ()
Delete the description attribute.
void | dropName ()
Delete the name attribute.
std::string | getDescription () const
Returns the value of the description attribute.
virtual std::string | getDescriptionSchemaType () const =0
Obtain a symbolic name for the description attribute schema type.
std::string | getName () const
Returns the value of the name attribute.
virtual std::string | getNameSchemaType () const =0
Obtain a symbolic name for the name attribute schema type.
virtual std::string | getSchemaType () const =0
Returns name of the schema type that can be used to validate this element.
std::string | getValue () const
Returns the value of the value attribute.
virtual std::string | getValueSchemaType () const =0
Obtain a symbolic name for the value attribute schema type.
bool | haveDescription () const
Indicates presence of the description attribute.
bool | haveName () const
Indicates presence of the name attribute.
ms_xml_parameter & | operator= (const ms_xml_parameter &right)
C++ style assignment operator.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setValue (const char *value)
Set a custom value for the value attribute.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Parameter name and value pair.

The Mascot configuration files quantitation.xml and crosslinking.xml use a common node structure for a set of key-value pairs. ms_xml_parameter is a base class for a single parameter element.

Constructor & Destructor Documentation

◆ ms_xml_parameter() [1/2]

ms_xml_parameter ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_xml_parameter() [2/2]

ms_xml_parameter ( const ms_xml_parameter & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_xml_parameter * right )

Copies all content from another instance.

Parameters
right another instance of this class to copy the content from.

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ dropDescription()

void dropDescription ( )

Delete the description attribute.

Deletes the attribute until is re-set.

◆ dropName()

void dropName ( )

Delete the name attribute.

Deletes the attribute until is re-set.

◆ getDescription()

std::string getDescription ( ) const

Returns the value of the description attribute.

Returns
a free text description of this parameter.

◆ getDescriptionSchemaType()

std::string getDescriptionSchemaType ( ) const
pure virtual

Obtain a symbolic name for the description attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implemented in ms_crosslinking_parameter, and ms_quant_parameter.

◆ getName()

std::string getName ( ) const

Returns the value of the name attribute.

Returns
a descriptive name that will appear in drop down lists, etc.

◆ getNameSchemaType()

std::string getNameSchemaType ( ) const
pure virtual

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implemented in ms_crosslinking_parameter, and ms_quant_parameter.

◆ getSchemaType()

std::string getSchemaType ( ) const
pure virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Implemented in ms_crosslinking_parameter, and ms_quant_parameter.

◆ getValue()

std::string getValue ( ) const

Returns the value of the value attribute.

Returns
a string value of this parameter.

◆ getValueSchemaType()

std::string getValueSchemaType ( ) const
pure virtual

Obtain a symbolic name for the value attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implemented in ms_crosslinking_parameter, and ms_quant_parameter.

◆ haveDescription()

bool haveDescription ( ) const

Indicates presence of the description attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ haveName()

bool haveName ( ) const

Indicates presence of the name attribute.

Returns
TRUE if the attribute is present and FALSE otherwise.

◆ operator=()

ms_xml_parameter & operator= ( const ms_xml_parameter & right )

C++ style assignment operator.

Parameters
right another instance of this class to copy the content from.
Returns
reference to the current object

◆ setDescription()

void setDescription ( const char * value )

Set a custom value for the description attribute.

Parameters
value a new value for the attribute.

◆ setName()

void setName ( const char * value )

Set a custom value for the name attribute.

Parameters
value a new value for the attribute.

◆ setValue()

void setValue ( const char * value )

Set a custom value for the value attribute.

Parameters
value a new string value for the parameter.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_xml_parameters.hpp
  • ms_xml_parameters.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_xml_parameters Class Reference

  • matrix_science
  • ms_xml_parameters
Public Member Functions | List of all members
ms_xml_parameters Class Referenceabstract
Mascot configuration files module

A class that represents a base parametersType. More...

#include <ms_xml_parameters.hpp>

Inheritance diagram for ms_xml_parameters:
[legend]

Public Member Functions

ms_xml_parameters ()
Default constructor.
ms_xml_parameters (const ms_xml_parameters &src)
Copying constructor.
virtual | ~ms_xml_parameters ()
Destructor.
virtual void | clearParameters ()=0
Deletes all parameters from the list.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)=0
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)=0
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const =0
Returns the number of parameters held.
virtual std::string | getParameterSchemaType () const =0
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const =0
Returns name of the schema type that can be used to validate this element.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

A class that represents a base parametersType.

The Mascot configuration files quantitation.xml and crosslinking.xml use a common node structure for a set of key-value pairs. ms_xml_parameters is a base class for ms_quant_parameters and ms_crosslinking_parameters, because the parameter sets share the same API.

Constructor & Destructor Documentation

◆ ms_xml_parameters() [1/2]

ms_xml_parameters ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_xml_parameters() [2/2]

ms_xml_parameters ( const ms_xml_parameters & src )

Copying constructor.

Parameters
src another instance of this class to copy the content from.

Member Function Documentation

◆ defaultValues()

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

◆ deleteParameterByName()

bool deleteParameterByName ( const char * name )
pure virtual

Remove a parameter from the list in memory by its unique name.

Parameters
name name of the parameter for deletion.
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implemented in ms_crosslinking_parameters, and ms_quant_parameters.

◆ deleteParameterByNumber()

bool deleteParameterByNumber ( const int idx )
pure virtual

Remove a parameter from the list in memory by its index.

Parameters
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implemented in ms_crosslinking_parameters, and ms_quant_parameters.

◆ getNumberOfParameters()

int getNumberOfParameters ( ) const
pure virtual

Returns the number of parameters held.

Returns
total number of parameters in the list.

Implemented in ms_crosslinking_parameters, and ms_quant_parameters.

◆ getParameterSchemaType()

std::string getParameterSchemaType ( ) const
pure virtual

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns
symbolic type name for the element.

Implemented in ms_crosslinking_filters, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, and ms_quant_parameters.

◆ getSchemaType()

std::string getSchemaType ( ) const
pure virtual

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also
validateShallow(), validateDeep()
Returns
a symbolic fully qualified type name (for example, "mqm:nameType").

Implemented in ms_crosslinking_filters, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_parameters, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

◆ validateDeep()

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also
validateShallow(), getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.

◆ validateShallow()

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also
getSchemaType()
Parameters
pSchemaFileObj a valid schema object instance to validate against.
Returns
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_xml_parameters.hpp
  • ms_xml_parameters.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Mascot security and authentication module

Modules | Classes
Mascot security and authentication module

Modules

Using the Mascot security module
Examples for the Mascot security module

Classes

class | ms_group
This class will normally only be used by Mascot Security Administration applications. More...
class | ms_security
The main security class to be used by the administration application. More...
class | ms_security_options
Options for the Mascot security system. More...
class | ms_security_task
Each group has permission to do one or more tasks. This class defines an individual task. More...
class | ms_security_tasks
Each group has permission to do one or more tasks. This class defines a collection of tasks. More...
class | ms_session
Use this class to determine if a user is logged in and if they have 'permission' to perform tasks. More...
class | ms_user
This class will normally only be used by Mascot Security Administration applications. More...

Detailed Description

The security module is used to determine who is logged in and what access rights they have

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Using the Mascot security module

Using the Mascot security module
Mascot security and authentication module

Introduction

The design goals of the Mascot security module include the following:

  • Restrict access to results files and sequence databases based on group and user definitions.
  • Allow authorised users to change Mascot server configuration files in a secure and traceable manner using thin client web based GUI tools that are supplied with Mascot Server.
  • Prevent un-authorised changes of Mascot server configuration files.
  • Standard 'session' support (with time-outs) so users do not need to re-enter passwords.
  • Restrict access to Mascot server based utilities that allow deletion of searches and other job control functions.

Mascot security from a fat client application

A client application can perform most tasks using the login.pl script that is installed in the mascot/cgi directory. A copy is supplied with Mascot Parser and the available commands can be seen at the start of the file.

Calls to most applications on Mascot server require a sessionID parameter. To see if security is disabled, use the login.pl script:

    http://mascot_server/mascot/cgi/login.pl?action=issecuritydisabled&display=nothing

If this returns a valid sessionID, then the sessionID can (but doesn't need to be) passed to any of the applications that accepts a sessionID.

If this call returns an error (and hence doesn't return a sessionID), then try:

    http://mascot_server/mascot/cgi/login.pl?action=webauthentication&display=nothing

If this succeeds, then either the Mascot web server is set up to use IIS integrated authentication, or a user name and password have to be specified in the URL. You can use the returned sessionID as above. If the call returns an error (and hence doesn't return a sessionID), then try

    http://mascot_server/mascot/cgi/login.pl?action=guestlogin&display=nothing

If this succeeds, then an interface should be provided to allow the user to log into the system as a different user with more rights. By default, the guest account is disabled on Mascot servers.

If this also fails (or if you choose not to call it), then the user must be prompted for a user name and password. Pass the username and password to the login.pl script:

    http://mascot_server/mascot/cgi/login.pl?action=login&username=xxx&password=yyy&display=nothing

If this returns an error, you should display the errorstring= value to the end user and prompt once again for the user name and password. Possible errors are listed in the documentation for ms_session().

A special case of ERR_MSP_SECURITY_PASSWORDEXPIRED can be handled by asking for the old and new passwords, and then calling login.pl with the appropriate parameters. Alternatively, a poor solution is to suggest that the user logs into Mascot using a browser and updates their password there.

The sessionID should be passed to daemon.pl and nph-mascot.exe. See documentation for those applications for further details.

Using the ms_session class from a CGI application

For most CGI applications, the only requirement is to create an ms_session object, check that it is valid (isValid()), and then use the methods isPermitted(), isPermitted_long(), etc.

If isValid() returns false, then the error should be treated as described in the ms_session constructor.

Using custom parameters

ms_session, ms_user and ms_group objects can store and retrieve custom string parameters using the methods saveStringParam() and getStringParam(), and the corresponding methods for integers, doubles and booleans. In each case, the key/value pairs are saved in a <mss:custom_parameters> section of the relevant XML files; for example, ms_user custom parameters are saved in user.xml. Custom parameters for ms_user and ms_group were added in Mascot Parser 2.4.1.

Custom parameters are typically used with a temporary session object, which is independent of users and Mascot security and is created with the ms_session(const int, const std::string) constructor. However, it is also possible to use custom parameters with a user session, which is created when a user logs in to Mascot. The rest of this section deals with user sessions.

User sessions can contain three types of custom parameters: parameters saved in the session (ms_session), parameters saved in group.xml (ms_group) and parameters saved in user.xml (ms_user). ms_session custom parameters in user session files are lost when the session file is rewritten. A rewrite may occur, for example, after editing user settings in Mascot Configuration Editor. Both ms_user and ms_group custom parameters survive a rewrite.

Custom ms_user and ms_group parameters are copied to the relevant user session files when ms_security::updateUser or ms_security::updateGroup are called. It is of course possible for ms_user and ms_group objects to contain custom parameters with the same name. Only one value will be saved in the user session file, and parameters from ms_user override parameters from ms_group.

Advanced

The administration utility uses the ms_security class to add users (addNewUser()) and groups (addNewGroup()). Refer to the class documentation for further details.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Examples for the Mascot security module

Examples for the Mascot security module
Mascot security and authentication module

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation

The most comprehensive example for the security module is the administration tool supplied with Mascot 2.1

Description | Perl | C++ | Java | Python | C#
Checking the 'current' session | security_session.pl | - | security_session.java | - | -
Login to the security system | login.pl | - | - | - | -
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_group Class Reference

  • matrix_science
  • ms_group
Public Types | Public Member Functions | List of all members
ms_group Class Reference
Mascot security and authentication module

This class will normally only be used by Mascot Security Administration applications. More...

#include <ms_security_group.hpp>

Public Types

enum systemids {
GROUPID_GUESTS = 0x0001 ,
GROUPID_ADMINISTRATORS = 0x0002 ,
GROUPID_POWERUSERS = 0x0003 ,
GROUPID_DAEMONS = 0x0004 ,
GROUPID_INTEGRA_SYSTEM = 0x0005 ,
GROUPID_LAST = 0x0006
}
Definitions for predefined groups. More...

Public Member Functions

ms_group ()
Create a new ms_group.
ms_group (const int groupID, const std::string groupName)
Create a new ms_group.
void | addPermittedTask (const matrix_science::ms_security_task &task)
Each group has one or more permitted tasks. Use this function to add to the list.
bool | addUser (const int userID)
Each group has one or more users. Use this function to add a user.
bool | clearParam (const std::string name)
Remove an additional user parameter associated with the group.
bool | deleteUser (const int userID)
Each group has one or more users. Use this function to delete a user.
std::vector< int > | getAllUserIDs (const void *const security=NULL, const int voidSortby=1) const
Return a list of user ids in the group.
int | getID () const
Return the unique group ID.
std::string | getName () const
Return the name of the group.
matrix_science::ms_security_tasks | getPermittedTasks () const
Return the list of permitted tasks.
std::string | getStringParam (const std::string name) const
Return a custom parameter for the group.
bool | getStringParam (const std::string name, std::string &param) const
Return a custom parameter for the group.
bool | isUserInGroup (const int userID) const
Returns true if the user is a member of the group.
bool | removePermittedTask (const int taskID)
Each group has one or more permitted tasks. Use this function to remove one from the list.
bool | saveStringParam (const std::string name, const std::string param)
Save an additional 'string' parameter for the group.
void | setID (int newVal)
Set the unique group ID.
void | setName (const std::string newVal)
Set the name of the group.
void | setPermittedTasks (matrix_science::ms_security_tasks &tasks)
Sets the list of permitted tasks.

Detailed Description

This class will normally only be used by Mascot Security Administration applications.

Member Enumeration Documentation

◆ systemids

enum systemids

Definitions for predefined groups.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
GROUPID_GUESTS

The guests group. By default, the matrix_science::ms_user::USERID_GUEST user belongs to this group.

GROUPID_ADMINISTRATORS

The Administrators group. By default, the matrix_science::ms_user::USERID_ADMINISTRATOR user belongs to this group.

GROUPID_POWERUSERS

An example group for users who need access to almost everything.

GROUPID_DAEMONS

Mascot Daemon needs to be set up with a user to run searches. By default, the matrix_science::ms_user::USERID_DAEMON user belongs to this group.

GROUPID_INTEGRA_SYSTEM
Deprecated:
The Mascot Integra system group, only member is normally USERID_INTEGRA_SYSTEM. Users will never be able to log in as this user - it is only used from the Integra server.
GROUPID_LAST

Placeholder.

Member Function Documentation

◆ addPermittedTask()

void addPermittedTask ( const matrix_science::ms_security_task & task )

Each group has one or more permitted tasks. Use this function to add to the list.

The function ms_security::updateGroup() should be called after this function to save the change permanently.

Parameters
task The new task, which should be obtained by calling ms_security::getTasks(), to get a list of all possible tasks, and then calling ms_security::tasks::getTask() or ms_security::tasks::getTaskFromID() to get the particular task. If additional parameters are required for the task, (e.g. for maximum number of MS-MS spectra), then this data should be added using one of the addXXXParam functions (e.g. ms_security_task::addLongParam()) before calling this function.

◆ addUser()

bool addUser ( const int userID )

Each group has one or more users. Use this function to add a user.

Add the user to this group. Since a user ID remains constant, but the user name can be altered, it is the userID that is associated with the group rather than the name. After adding a user to a group call ms_security::updateGroup().

Parameters
userID The unique ID of the user to be added to the group.
Returns
true if the userID is at least zero and if insertion succeeds, false otherwise

◆ clearParam()

bool clearParam ( const std::string name )

Remove an additional user parameter associated with the group.

Additional custom data for a group are saved in a <mss:custom_parameters> section in the group.xml file.

Use this function when you no longer want a value associated with a key name for a group.

To make the changes permanent, use ms_security::updateGroup().

See also Using custom parameters

Parameters
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns
boolean value to indicate if the value was successfully removed.

◆ deleteUser()

bool deleteUser ( const int userID )

Each group has one or more users. Use this function to delete a user.

The function ms_security::updateGroup() should be called after this function to save the change permanently.

Parameters
userID Must be a valid userID for a user that belongs to the group.
Returns
True if the user is found, and can be deleted.

◆ getAllUserIDs()

std::vector< int > getAllUserIDs | ( | const void *const | security = NULL,
 |  | const int | voidSortby = 1
 | ) |  | const

Return a list of user ids in the group.

To get information about each of the userIDs returned, call ms_security::getUserFromID() to return a matrix_science::ms_user object.

Parameters
security | Should be a valid pointer to an ms_security object, by default it is NULL
voidSortby | Should be a valid ms_security::USERID_SORTBY, by default it is 1
Returns
A vector of userIDs. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getName()

std::string getName ( ) const

Return the name of the group.

Each group will have a unique name, and a unique ID.

Returns
The name of this group.

◆ getStringParam() [1/2]

std::string getStringParam ( const std::string name ) const

Return a custom parameter for the group.

Additional custom data for a group are saved in a <mss:custom_parameters> section in the group.xml file.

If an empty string is returned, it is not possible to determine if this is because there is no key value or if an empty string was set for the key.

See also
saveStringParam()

See also Using custom parameters

Parameters
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns
Is the value of the parameter associated with the key name or an empty string if there is no key.

◆ getStringParam() [2/2]

bool getStringParam | ( | const std::string | name,
 |  | std::string & | param
 | ) |  | const

Return a custom parameter for the group.

Additional custom data for a group are saved in a <mss:custom_parameters> section in the group.xml file.

Note
This function should not be used from programming languages other than C++. Use getStringParam(const std::string) const instead.
See also
saveStringParam()

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns
boolean value to indicate if the value was successfully retrieved.

◆ isUserInGroup()

bool isUserInGroup ( const int userID ) const

Returns true if the user is a member of the group.

Parameters
userID Should be a valid userID.
Returns
True if the user is found.

◆ removePermittedTask()

bool removePermittedTask ( const int taskID )

Each group has one or more permitted tasks. Use this function to remove one from the list.

Parameters
taskID Must be a task ID for a task currently assigned to the group.
Returns
True if the task was removed.

◆ saveStringParam()

bool saveStringParam | ( | const std::string | name,
 |  | const std::string | param
 | ) |  |

Save an additional 'string' parameter for the group.

Additional custom data for a group are saved in a <mss:custom_parameters> section in the group.xml file.

The value can be retrieved using getStringParam().

To make the changes permanent, use ms_security::updateGroup().

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns
true if the value is successfully saved.

◆ setID()

void setID ( int newVal )

Set the unique group ID.

The function ms_security::updateGroup() should be called after this function to save the change permanently.

Parameters
newVal Is the new ID for the group. This function does not normally need to be called by an application. New groups should be added by calling ms_security::addNewGroup().

◆ setName()

void setName ( const std::string newVal )

Set the name of the group.

Each group will have a unique name, and a unique ID.

The function ms_security::updateGroup() should be called after this function to save the change permanently.

Parameters
newVal The new name of this group.

◆ setPermittedTasks()

void setPermittedTasks ( matrix_science::ms_security_tasks & tasks )

Sets the list of permitted tasks.

The function ms_security::updateGroup() should be called after this function to save the change permanently.

Parameters
tasks a list of tasks to copy from.
The documentation for this class was generated from the following files:
  • ms_security_group.hpp
  • ms_security_group.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security Class Reference

  • matrix_science
  • ms_security
Public Types | Public Member Functions | List of all members
ms_security Class Reference
Mascot security and authentication module

The main security class to be used by the administration application. More...

#include <ms_security.hpp>

Inheritance diagram for ms_security:
[legend]
Collaboration diagram for ms_security:
[legend]

Public Types

enum USERID_SORTBY {
USERID_SORTBY_ID = 1 ,
USERID_SORTBY_LOGINNAME = 2 ,
USERID_SORTBY_FULLNAME = 3
}
Sorting criterion to retrieve all users. More...

Public Member Functions

ms_security ()
The constructor loads all the groups and users information from the ../config directory.
bool | addNewGroup (const std::string sessionID, const int groupID, const std::string groupName)
Add a new group to the current list of groups.
bool | addNewUser (const std::string sessionID, const int userID, const std::string userName, const std::string password, const time_t passwordExpiry, const std::string fullName, const std::string emailAddress, const ms_user::usertype userType, const bool enabled)
Add a new user to the current list of users.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
bool | createDefaults (const std::string sessionID="")
Create default users, groups and sessions.
bool | deleteGroup (const std::string sessionID, const std::string groupName)
Delete a group from the system.
bool | deleteUser (const std::string sessionID, const std::string userName)
Delete a user from the system.
ms_user::customParams_t | getAllCustomParamsForUser (const ms_user &user) const
Return a 'map' of all the custom parameters for a user.
std::vector< int > | getAllGroupIDs () const
Return a list of all group IDs.
std::vector< int > | getAllUserIDs (const USERID_SORTBY sortby=USERID_SORTBY_ID) const
Return a list of all user IDs.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
ms_group | getGroup (const std::string groupName) const
Return a group given the name .
ms_group | getGroupFromID (const int groupID) const
Return a group given the ID.
std::vector< std::string > | getIntegraUsers () const
Returns a list of Integra users.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
ms_security_options | getMascotSecurityOptions () const
Return the security options.
ms_security_tasks | getPermittedTasksForUser (const std::string name) const
Return a list of the tasks permitted for the user.
ms_security_tasks | getTasks () const
Return the complete list of possible tasks available.
ms_user | getUser (const std::string userName) const
Return a user given the name.
ms_user | getUserFromID (const int userID) const
Return a user given the ID.
bool | isTaskExists (const int taskID) const
Return true if a security task with the given ID exists.
bool | isUserExists (const int userID) const
Return true if a user with this ID exists.
bool | isValid () const
Call this function to determine if there have been any errors.
std::vector< int > | sortUsers (std::vector< ms_user * > &vecUsers, const USERID_SORTBY sortby) const
Sort a list of users and return a list of user IDs.
bool | updateAllSessionFiles (bool deleteOnly=false)
Update all the session files after making a change to parameters.
bool | updateGroup (const std::string sessionID, const ms_group &group)
Call this after updating any details for a group.
bool | updatePassword (const std::string sessionID, const std::string userName, const std::string oldPassword, const std::string newPassword)
Update the password for an existing user.
bool | updateUser (const std::string sessionID, const ms_user user)
Update an existing user int the system.

Detailed Description

The main security class to be used by the administration application.

Other applications should just need to use ms_session.

When an object of this class is created, it loads all the users, groups tasks and options into memory.

Member Enumeration Documentation

◆ USERID_SORTBY

enum USERID_SORTBY

Sorting criterion to retrieve all users.

Enumerator
USERID_SORTBY_ID | Sort the list of users id by id.
USERID_SORTBY_LOGINNAME | Sort the list of users id by login name (its displayed name)
USERID_SORTBY_FULLNAME | Sort the list of users id by full name.

Constructor & Destructor Documentation

◆ ms_security()

ms_security ( )

The constructor loads all the groups and users information from the ../config directory.

The administration program should use this constructor to load all users, groups and tasks. New users and groups should be added through this interface.

Member Function Documentation

◆ addNewGroup()

bool addNewGroup | ( | const std::string | sessionID,
 |  | const int | groupID,
 |  | const std::string | groupName
 | ) |  |

Add a new group to the current list of groups.

To add a new group, call this function first. If the function returns true, then get the group using getGroup(), add users and tasks to the group and then call updateGroup().

Parameters
sessionID | This is the session id for the administrator who is adding the user. A valid session ID with administrator rights is required, and all additions of users and groups are logged using the details in the session ID.
groupID | Can be set to -1 in which case the system provides a new unique ID. If a value is provided, and there is already a group with this ID, then the function will return false and the error ms_errs::ERR_MSP_SECURITY_DUPE_GROUP_ID.
groupName Is the name of the new group to be added. This must not contain spaces or any of the following characters:
><\\/`;,+*"
If there is already a group with this name, then the function will return false and set the error ms_errs::ERR_MSP_SECURITY_DUPE_GROUP_NAME.
Returns
True if the function succeeds. The function will fail if the session is invalid, or doesn't have administrator rights. The function will also fail if there is a group with a the same name or the same ID.

◆ addNewUser()

bool addNewUser | ( | const std::string | sessionID,
 |  | const int | userID,
 |  | const std::string | userName,
 |  | const std::string | password,
 |  | const time_t | passwordExpiry,
 |  | const std::string | fullName,
 |  | const std::string | emailAddress,
 |  | const ms_user::usertype | userType,
 |  | const bool | enabled
 | ) |  |

Add a new user to the current list of users.

Use this function, rather than ms_user::ms_user to add a new user to the system.

Possible errors are:

  • ms_errs::ERR_MSP_SECURITY_INVALID_SESSION_ID
  • ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION
  • ms_errs::ERR_MSP_SECURITY_USERID_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_DISABLE_ADMIN
  • ms_errs::ERR_MSP_SECURITY_DUPE_USER_NAME_U
  • ms_errs::ERR_MSP_SECURITY_PASSWORD_TOO_SHORT
  • ms_errs::ERR_MSP_SECURITY_BAD_USER_NAME
Parameters
sessionID | This is the session id for the administrator who is adding the user. A valid session ID with administrator rights is required, and all additions of users and groups are logged using the details in the session ID.
userID | Can be set to -1 in which case the system provides a new unique ID. If a value is provided, and there is already a user with this ID, then the function will return false and set the error ms_errs::ERR_MSP_SECURITY_DUPE_USER_ID.
userName The user name must not contain spaces or any of the following characters:
><\\/`;,+*"
If there is already a user with this name, then the function will return false and set the error ms_errs::ERR_MSP_SECURITY_DUPE_USER_NAME.
password | The password length must be greater than or equal to ms_security_options::getMinimumPasswordLength() unless the passwordExpiry parameter is set to 1, in which case the user will be prompted for a new password when they log in.
passwordExpiry | is the time in seconds since Jan 1, 1970 when the password will expire. See ms_security_options::getDefaultPasswordExpiryTime() for details. A value of '0'is used to indicate that the password should never expire. A value of 'now' or 1 can be used to force the user to change their password next time they log in.
fullName | Can be any number of characters, but ideally should not be left blank.
emailAddress | Can be any number of characters, but ideally should not be left blank. No error checking is performed in this function.
userType must be ascertained correctly by the calling application, since there is no error checking in this function. Normally, this function should only be called with one of
  • ms_user::USER_NORMAL
  • ms_user::USER_COMPUTER_NAME
  • ms_user::USER_IP_ADDRESS
  • ms_user::USER_AGENT_STRING or
  • ms_user::USER_WEBAUTH
The type should never be ms_user::USER_SECURITY_DISABLED
enabled | Should normally be set to true to allow the user to login.
Returns
True if successful.

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ createDefaults()

bool createDefaults ( const std::string sessionID = "" )

Create default users, groups and sessions.

This function should be called by the installation program to create all the default users, default groups, default sessions etc. if they don't already exist.

This function creates:

  • An 'admin' user with ID: ms_user::USERID_ADMINISTRATOR.
  • A 'guest' user with ID: ms_user::USERID_GUEST. This user account is however disabled.
  • An 'Administrators' group with ID: ms_group::GROUPID_ADMINISTRATORS. The admin user is added to this group, which also has ms_security_tasks::SECTASK_ADMINPAGES, ms_security_tasks::SECTASK_KILLALLTASK, ms_security_tasks::SECTASK_ACCESSDBSETUP, and ms_security_tasks::SECTASK_VIEWCONFIGUSINGMSSTATUS rights assigned.
  • A 'Guests' group with the ID: ms_group::GROUPID_GUESTS. The guest user is added, along with a few minimal access rights.
Parameters
sessionID Will generally be the built in command line session that is automatically created for any programs not being run from the web server.
Returns
True if the function succeeds. Possible errors are: ms_errs::ERR_MSP_SECURITY_INVALID_SESSION_ID, ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION and all errors that can be set from calling addNewUser() and addNewGroup().

◆ deleteGroup()

bool deleteGroup | ( | const std::string | sessionID,
 |  | const std::string | groupName
 | ) |  |

Delete a group from the system.

Possible error values are:

  • ms_errs::ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION
  • ms_errs::ERR_MSP_SECURITY_DEL_SPECIAL_GROUP
Parameters
sessionID | This is the session id for the administrator who is deleting the group. A valid session ID with administrator rights is required, and all deletions of users and groups are logged using the details in the session ID.
groupName | Needs to be a valid user name.
Returns
Will return true if the function succeeds in deleting the group. Otherwise, it will return false and set just one of the above errors.

◆ deleteUser()

bool deleteUser | ( | const std::string | sessionID,
 |  | const std::string | userName
 | ) |  |

Delete a user from the system.

Possible error values are:

  • ms_errs::ERR_MSP_SECURITY_USERNAME_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION
  • ms_errs::ERR_MSP_SECURITY_DEL_SPECIAL_USER
Parameters
sessionID | This is the session id for the administrator who is deleting the user. A valid session ID with administrator rights is required, and all deletions of users and groups are logged using the details in the session ID.
userName | Needs to be a valid user name.
Returns
Will return true if the function succeeds in deleting the user Otherwise, it will return false and set just one of the above errors.

◆ getAllCustomParamsForUser()

ms_user::customParams_t getAllCustomParamsForUser ( const ms_user & user ) const

Return a 'map' of all the custom parameters for a user.

If an invalid user object is passed, then the returned object will be empty

Customer parameters for a user can originate from the user or group settings. Values at the user level overwrite values at the group level. See Using custom parameters

Parameters
user Needs to be a valid user object.
Returns
a 'map' of custom parameters and values.

◆ getAllGroupIDs()

std::vector< int > getAllGroupIDs ( ) const

Return a list of all group IDs.

To find details of each group, call getGroupFromID().

Returns
An array of user IDs. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getAllUserIDs()

std::vector< int > getAllUserIDs ( const USERID_SORTBY sortby = USERID_SORTBY_ID ) const

Return a list of all user IDs.

To find details of each user, call getUserFromID().

Parameters
sortby The field on which to sort the users whose IDs are returned, by default they are sorted by id
Returns
An array of user IDs. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getGroup()

ms_group getGroup ( const std::string groupName ) const

Return a group given the name .

If an invalid group name is passed, then for the returned object, ms_group::getID() will return -1.

Parameters
groupName Needs to be a valid group name.
Returns
an ms_group object.

◆ getGroupFromID()

ms_group getGroupFromID ( const int groupID ) const

Return a group given the ID.

If an invalid group ID is passed, then for the returned object, ms_group::getUserID() will return -1.

Parameters
groupID Needs to be a valid group ID.
Returns
an ms_group object.

◆ getIntegraUsers()

std::vector< std::string > getIntegraUsers ( ) const

Returns a list of Integra users.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Will return an empty list if there is no local Mascot Integra system or the definitions in the option file are not correct. These users have not neccessarily been added to the list of Mascot users.

Returns
An array of Integra user names. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMascotSecurityOptions()

ms_security_options getMascotSecurityOptions ( ) const

Return the security options.

If an ms_security object is available, it is faster to call this than creating a new matrix_science::ms_security_options object because there will be no need to load the options file from disk.

Note that this function returns a copy of the security options, so changing the options will have no effect on the ms_security object. To have the changes take effect, a new ms_security object will have to be created.

Returns
The security options. If the configuration file is not present, defaults will be used.

◆ getPermittedTasksForUser()

ms_security_tasks getPermittedTasksForUser ( const std::string name ) const

Return a list of the tasks permitted for the user.

If an invalid user name is passed, then for the returned object, ms_security_tasks::getNumberOfTasks() will return 0.

Parameters
name Needs to be a valid user name.
Returns
A ms_security_tasks object.

◆ getTasks()

ms_security_tasks getTasks ( ) const

Return the complete list of possible tasks available.

The administration module will use this function to display a list of possible tasks to the end user.

Returns
The complete list of tasks.

◆ getUser()

ms_user getUser ( const std::string userName ) const

Return a user given the name.

If an invalid user name is passed, then for the returned object, ms_user::getID() will return -1.

Parameters
userName Needs to be a valid user name.
Returns
an ms_user object.

◆ getUserFromID()

ms_user getUserFromID ( const int userID ) const

Return a user given the ID.

If an invalid user ID is passed, then for the returned object, ms_user::getUserID() will return -1.

Parameters
userID Needs to be a valid user ID.
Returns
an ms_user object.

◆ isTaskExists()

bool isTaskExists ( const int taskID ) const

Return true if a security task with the given ID exists.

Parameters
taskID Task ID to check.
Returns
true if a task with this ID exists; false otherwise.

◆ isUserExists()

bool isUserExists ( const int userID ) const

Return true if a user with this ID exists.

Parameters
userID User ID to check.
Returns
true if a user with this ID exists; false otherwise.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ sortUsers()

std::vector< int > sortUsers | ( | std::vector< ms_user * > & | vecUsers,
 |  | const USERID_SORTBY | sortby
 | ) |  | const

Sort a list of users and return a list of user IDs.

Sorts a list of users by the given field

Parameters
vecUsers | A vector of users to sort
sortby | The field on which to sort the users whose IDs are returned
Returns
An array of user IDs sorted by id, login name or full name

◆ updateAllSessionFiles()

bool updateAllSessionFiles ( bool deleteOnly = false )

Update all the session files after making a change to parameters.

This function is called by addNewUser(), deleteUser(), updateUser(), addNewGroup(), deleteGroup() and updateGroup().

Parameters
deleteOnly is set to true when this function is called from ms-monitor.exe. This prevents session files from being created with the incorrect file permissions.
Returns
always returns true

◆ updateGroup()

bool updateGroup | ( | const std::string | sessionID,
 |  | const ms_group & | group
 | ) |  |

Call this after updating any details for a group.

Groups can be changed by adding/deleting users, changing the name or adding/deleting tasks. To make any of these changes, call getGroup() or getGroupFromID() to get the group and then make changes using the ms_group member functions. Finally, call this function to make the changes permanent. Do not change the groupID, or this function will fail.

Possible errors are:

  • ms_errs::ERR_MSP_SECURITY_INVALID_SESSION_ID
  • ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION
  • ms_errs::ERR_MSP_SECURITY_GROUPID_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_DUPE_GROUP_NAME_U
  • ms_errs::ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP
  • ms_errs::ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS
Parameters
sessionID | This is the session id for the administrator who is updating the group. A valid session ID with administrator rights is required, and all updates of users and groups are logged using the details in the session ID.
group | The group returned from getGroup() or getGroupFromID().
Returns
True if the group already exists and has been successfully updated.

◆ updatePassword()

bool updatePassword | ( | const std::string | sessionID,
 |  | const std::string | userName,
 |  | const std::string | oldPassword,
 |  | const std::string | newPassword
 | ) |  |

Update the password for an existing user.

If the old password is empty, or is supplied, then anyone can call this function. If the sessionID is for a valid session with Administrator privileges, then the old password is not required.

Possible errors are:

  • ms_errs::ERR_MSP_SECURITY_INVALID_SESSION_ID
  • ms_errs::ERR_MSP_SECURITY_OLD_PW_INVALID
  • ms_errs::ERR_MSP_SECURITY_USERNAME_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_NO_GUEST_PWD
  • ms_errs::ERR_MSP_SECURITY_PASSWORD_TOO_SHORT
  • ms_errs::ERR_MSP_SECURITY_SAMEPASSWORD
Parameters
sessionID | Is the session ID for a session with Administrator permissions or a session for the named user.
userName | Needs to be an existing user name.
oldPassword | The old password must be correct.
newPassword | The password will be updated with the new value.
Returns
Will return true if the password has been updated successfully.

◆ updateUser()

bool updateUser | ( | const std::string | sessionID,
 |  | const ms_user | user
 | ) |  |

Update an existing user int the system.

Most properties of a user account can be changed – for example the login name, or the full name or email address. The ID cannot be changed. The password must be changed using updatePassword(). To change which groups a user belongs to, see updateGroup().

To call this function, the session must either have ms_security_tasks::SECTASK_ADMINPAGES or ms_security_tasks::SECTASK_MODIFYOWNPROFILE rights. In the latter case, the user to be updated must be the same as the session user, and the only things that can be changed are the full name and the email address.

Possible errors are:

  • ms_errs::ERR_MSP_SECURITY_INVALID_SESSION_ID
  • ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION
  • ms_errs::ERR_MSP_SECURITY_USERID_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_DISABLE_ADMIN
  • ms_errs::ERR_MSP_SECURITY_DUPE_USER_NAME_U
  • ms_errs::ERR_MSP_SECURITY_PASSWORD_TOO_SHORT
  • ms_errs::ERR_MSP_SECURITY_BAD_USER_NAME
Parameters
sessionID | Is the session ID for a session with Administrator permissions.
user | Needs to be an existing user. All details will be reset with the passed information, including the password.
Returns
Will return false and set ms_errs::ERR_MSP_SECURITY_USERNAME_NOT_FOUND if the named user cannot be found.
The documentation for this class was generated from the following files:
  • ms_security.hpp
  • ms_security.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security_options Class Reference

  • matrix_science
  • ms_security_options
Public Member Functions | List of all members
ms_security_options Class Reference
Mascot security and authentication module

Options for the Mascot security system. More...

#include <ms_security_options.hpp>

Inheritance diagram for ms_security_options:
[legend]
Collaboration diagram for ms_security_options:
[legend]

Public Member Functions

ms_security_options ()
Loads the options file into memory.
ms_security_options (const ms_security_options &src)
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_security_options *right)
time_t | getDefaultPasswordExpiryTime () const
Returns the time in days before a password expires.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getIntegraAppServerURL () const
Returns the URL to the Integra Application server host.
std::string | getIntegraDatabaseName () const
Returns the name of the Integra database.
std::string | getIntegraOracleServerName () const
Returns the name of the oracle server for Mascot Integra.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getLogFileName ()
Returns the log file name.
matrix_science::ms_errs::msg_sev | getLoggingLevel () const
Returns the logging level.
unsigned int | getMinimumPasswordLength () const
Returns the minimum password length.
time_t | getSessionTimeout () const
Returns the time in seconds before a user is logged out.
bool | getUseSessionCookies () const
Returns true if session (rather than file) cookies are to be used.
bool | getVerifySessionIPAddress () const
Returns true if a session will be invalid if used from a different IP address from the original session request.
bool | isSecurityEnabled () const
Will return true if the Mascot security system is enabled.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_security_options & | operator= (const ms_security_options &right)
void | setDefaultPasswordExpiryTime (time_t newVal)
Sets the time in days before a password expires.
void | setIntegraAppServerURL (std::string newVal)
Sets the URL to the Integra Application server host.
void | setIntegraDatabaseName (std::string newVal)
Sets the name of the Integra database.
void | setIntegraOracleServerName (std::string newVal)
Sets the name of the oracle server for Mascot Integra.
void | setLogFileName (std::string newVal)
Sets the log file name.
void | setLoggingLevel (ms_errs::msg_sev newVal)
Sets the logging level.
void | setMinimumPasswordLength (unsigned int newVal)
Sets the minimum password length.
void | setSecurityEnabled (bool newVal)
Enables the Mascot security system.
void | setSessionTimeout (time_t newVal)
Sets the time in seconds before a user is logged out.
void | setUseSessionCookies (bool newVal)
Set whether session or file cookies should be used.
void | setVerifySessionIPAddress (bool newVal)
Set if a session will be invalid if used from a different IP address from the original session request.

Detailed Description

Options for the Mascot security system.

This class will generally only be used by the security administration utility. It is used by the ms_security and ms_session classes.

Constructor & Destructor Documentation

◆ ms_security_options() [1/2]

ms_security_options ( )

Loads the options file into memory.

If the file cannot be found, the following defaults are set:

Security enabled
false
Session timeout
21,600 seconds (6 hours)
Default password expiry time
365 (days)
Minimum password length
5 characters
Use session cookies
false
Verify IP address for sessions
false
Mascot Integra application server URL
"http://integra:8080/topaz"
Mascot Integra database name
"integra"
Mascot Integra Oracle server name
Integra

It will often be faster to call ms_security::getMascotSecurityOptions() if a ms_security object is already available.

◆ ms_security_options() [2/2]

ms_security_options ( const ms_security_options & src )
Parameters
src is the source to initialise from

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_security_options * right )
Parameters
right is the source to initialise from

◆ getDefaultPasswordExpiryTime()

time_t getDefaultPasswordExpiryTime ( ) const

Returns the time in days before a password expires.

When a new user is created using ms_security::addNewUser(), the password expiry is explicity set using that function. A value of 1 will typically be passed to that function to force the user to choose a new password when they first log in. However, the administration utility could take the current time, and add this default value to set the new expiry time.

This default value is used to set the expiry time for the password when ms_security::updatePassword() is called. If the default expiry time is zero, then the user's password will be set to never expire.

See also
ms_user::getPasswordExpiry(), setDefaultPasswordExpiryTime()
Returns
The expiry time in days.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getIntegraAppServerURL()

std::string getIntegraAppServerURL ( ) const

Returns the URL to the Integra Application server host.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the URL to the Mascot Integra system. Should be blank where there is no local Mascot Integra installation. It will typically be of the form http://integra:8080/topaz.

See also
setIntegraAppServerURL()
Returns
The URL for Mascot Integra server.

◆ getIntegraDatabaseName()

std::string getIntegraDatabaseName ( ) const

Returns the name of the Integra database.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the database name on the Mascot Integra system. Should be blank where there is no local Mascot Integra installation. It will typically be 'integra'.

See also
setIntegraDatabaseName()
Returns
The Mascot Integra database name.

◆ getIntegraOracleServerName()

std::string getIntegraOracleServerName ( ) const

Returns the name of the oracle server for Mascot Integra.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the location of the Oracle server used by Mascot Integra, which may not be on the same system as Mascot Integra. Should be blank where there is no local Mascot Integra installation. It will typically be 'integra'.

See also
setIntegraOracleServerName().
Returns
The Mascot Integra Oracle database server name.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getLogFileName()

std::string getLogFileName ( )

Returns the log file name.

Any changes to security settings are logged in the log file.

Returns
The log file name.

◆ getLoggingLevel()

ms_errs::msg_sev getLoggingLevel ( ) const

Returns the logging level.

Any changes to security settings are logged in the log file. The number of messages depends on the logging level.

Returns
The logging level.

◆ getMinimumPasswordLength()

unsigned int getMinimumPasswordLength ( ) const

Returns the minimum password length.

A value of zero can be used to indicate that passwords are not required. This value is checked when ms_security::addNewUser() or ms_security::updatePassword() are called. If the entered password is less than this length, then the error ms_errs::ERR_MSP_SECURITY_PASSWORD_TOO_SHORT will be generated.

See also
setMinimumPasswordLength()
Returns
The minimum password length.

◆ getSessionTimeout()

time_t getSessionTimeout ( ) const

Returns the time in seconds before a user is logged out.

Accessing a session using ms_session (normally done viewing any page that uses the session) will start the clock ticking again for that session. Session timeouts are not used for guest sessions, or if the user type is one of

  • ms_user::USER_INTEGRA,
  • ms_user::USER_COMPUTER_NAME,
  • ms_user::USER_IP_ADDRESS,
  • ms_user::USER_AGENT_STRING or
  • ms_user::USER_WEBAUTH.
See also
setSessionTimeout()
Returns
The session timeout value in seconds which will be in the range 60 to 31,449,600 (one year).

◆ getUseSessionCookies()

bool getUseSessionCookies ( ) const

Returns true if session (rather than file) cookies are to be used.

A session, or non persistent cookie is not saved on the end users disk, and just lasts for the time that the browser is open. A file or persistent cookie is saved on the end users disk so that it will be available when the browser is opened again.

The name of the cookie that saves the session ID should be MascotSessionID – see ms_session::ms_session() for details of how the cookie is used.

The only time that a cookie should be set is when the user logs in. If this option to use session cookies is set, then the 'expires' value must not be set. See also setUseSessionCookies().

Returns
True if session rather than persistent cookies should be used.

◆ getVerifySessionIPAddress()

bool getVerifySessionIPAddress ( ) const

Returns true if a session will be invalid if used from a different IP address from the original session request.

When a session is created, the IP address of the originator and the value of this flag is saved in the session file. If this flag is set to true, and there is a request to open the session from a different IP address, then that request will be denied with the error ms_errs::ERR_MSP_SECURITY_DIFFERENTIPADDR. Guest users, or any user with the type ms_user::USER_WEBAUTH will never generate that error.

See also
setVerifySessionIPAddress(), ms_session::getIPAddress()
Returns
True if IP addresses should be checked.

◆ isSecurityEnabled()

bool isSecurityEnabled ( ) const

Will return true if the Mascot security system is enabled.

Most applications will not need to call this function, since they will need to create a ms_session object anyway, and can then use the ms_session::isSecurityEnabled() function.

Returns
True if security is enabled.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_security_options & operator= ( const ms_security_options & right )
Parameters
right is the source to initialise from
Returns
reference to the current object

◆ setDefaultPasswordExpiryTime()

void setDefaultPasswordExpiryTime ( time_t newVal )

Sets the time in days before a password expires.

When a new user is created using ms_security::addNewUser(), the password expiry is explicity set using that function. A value of 1 will typically be passed to that function to force the user to choose a new password when they first log in. However, the administration utility could take the current time, and add this default value to set the new expiry time.

This default value is used to set the expiry time for the password when ms_security::updatePassword is called. If the default expiry time is zero, then the user's password will be set to never expire.

See also
ms_user::getPasswordExpiry(), getDefaultPasswordExpiryTime()
Parameters
newVal is the new expiry time in days.

◆ setIntegraAppServerURL()

void setIntegraAppServerURL ( std::string newVal )

Sets the URL to the Integra Application server host.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the URL to the Mascot Integra system. Should be blank where there is no local Mascot Integra installation. It will typically be of the form http://integra:8080/topaz.

See also
getIntegraAppServerURL()
Parameters
newVal The URL for Mascot Integra server.

◆ setIntegraDatabaseName()

void setIntegraDatabaseName ( std::string newVal )

Sets the name of the Integra database.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the database name on the Mascot Integra system. Should be blank where there is no local Mascot Integra installation. It will typically be 'integra'.

See also
setIntegraDatabaseName()
Parameters
newVal The Mascot Integra database name.

◆ setIntegraOracleServerName()

void setIntegraOracleServerName ( std::string newVal )

Sets the name of the oracle server for Mascot Integra.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the location of the Oracle server used by Mascot Integra, which may not be on the same system as Mascot Integra. Should be blank where there is no local Mascot Integra installation. It will typically be 'integra'.

See also
getIntegraOracleServerName()
Parameters
newVal The Mascot Integra Oracle database server name.

◆ setLogFileName()

void setLogFileName ( std::string newVal )

Sets the log file name.

Any changes to security settings are logged in the log file.

Parameters
newVal The new log file name.

◆ setLoggingLevel()

void setLoggingLevel ( ms_errs::msg_sev newVal )

Sets the logging level.

Any changes to security settings are logged in the log file. (../logs/security.log). The number of messages depends on the logging level:

  • 1 - Errors
  • 2 - Warnings
  • 3 - Information (Default)
  • 4 - Debug level 1
  • 5 - Debug level 2
  • 6 - Debug level 3
Parameters
newVal The new logging level.

◆ setMinimumPasswordLength()

void setMinimumPasswordLength ( unsigned int newVal )

Sets the minimum password length.

A value of zero can be used to indicate that passwords are not required. This value is checked when ms_security::addNewUser() or ms_security::updatePassword() are called. If the entered password is less than this length, then the error ms_errs::ERR_MSP_SECURITY_PASSWORD_TOO_SHORT will be generated.

See also
getMinimumPasswordLength()
Parameters
newVal is the new minimum password length.

◆ setSecurityEnabled()

void setSecurityEnabled ( bool newVal )

Enables the Mascot security system.

Used by the security administration utility. See also isSecurityEnabled().

Parameters
newVal Should be set to true to enable security or false to disable it.

◆ setSessionTimeout()

void setSessionTimeout ( time_t newVal )

Sets the time in seconds before a user is logged out.

Viewing any page that uses the session timeout will start the clock ticking again. Session timeouts are not used for guest sessions, or if the user type is one of

  • ms_user::USER_INTEGRA,
  • ms_user::USER_COMPUTER_NAME,
  • ms_user::USER_IP_ADDRESS,
  • ms_user::USER_AGENT_STRING or
  • ms_user::USER_WEBAUTH.
See also
getSessionTimeout()
Parameters
newVal is the new session timeout in seconds. It must be in the range 60 to 31,449,600 (one year).

◆ setUseSessionCookies()

void setUseSessionCookies ( bool newVal )

Set whether session or file cookies should be used.

A session, or non persistent cookie is not saved on the end users disk, and just lasts for the time that the browser is open. A file or persistent cookie is saved on the end users disk so that it will be available when the browser is opened again.

The name of the cookie that saves the session ID should be MascotSessionID – see ms_session::ms_session() for details of how the cookie is used.

The only time that a cookie should be set is when the user logs in. If this option to use session cookies is set, then the 'expires' value must not be set. See also getUseSessionCookies().

Parameters
newVal Should be set to true to specify that session rather than persistent cookies should be used.

◆ setVerifySessionIPAddress()

void setVerifySessionIPAddress ( bool newVal )

Set if a session will be invalid if used from a different IP address from the original session request.

When a session is created, the IP address of the originator and the value of this flag is saved in the session file. If this flag is set to true, and there is a request to open the session from a different IP address, then that request will be denied with the error ms_errs::ERR_MSP_SECURITY_DIFFERENTIPADDR. Guest users, or any user with the type ms_user::USER_WEBAUTH will never generate that error.

See also
setVerifySessionIPAddress(), ms_session::getIPAddress()
Parameters
newVal Should be set to true if IP addresses should be checked.
The documentation for this class was generated from the following files:
  • ms_security_options.hpp
  • ms_security_options.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security_task Class Reference

  • matrix_science
  • ms_security_task
Public Types | Public Member Functions | List of all members
ms_security_task Class Reference
Mascot security and authentication module

Each group has permission to do one or more tasks. This class defines an individual task. More...

#include <ms_security_task.hpp>

Public Types

enum paramType {
TYPE_BOOL = 0x0000 ,
TYPE_EQ_LONG = 0x0001 ,
TYPE_LTE_LONG = 0x0002 ,
TYPE_GTE_LONG = 0x0003 ,
TYPE_LONG_ARRAY = 0x0004 ,
TYPE_EQ_DOUBLE = 0x0005 ,
TYPE_LTE_DOUBLE = 0x0006 ,
TYPE_GTE_DOUBLE = 0x0007 ,
TYPE_DOUBLE_ARRAY = 0x0008 ,
TYPE_EQ_STRING = 0x0009 ,
TYPE_STRING_ARRAY = 0x000A ,
TYPE_USERS_ARRAY = 0x000B ,
TYPE_ALL_USERS_ARRAY = 0x000C
}
Definitions for parameter type. More...

Public Member Functions

ms_security_task ()
Create a new empty object - not particularly useful.
~ms_security_task ()
Destructor of the class.
bool | addDoubleParam (const double value)
Add a floating point parameter to the task.
bool | addLongParam (const long value)
Add a long parameter to the task.
bool | addStringParam (const std::string value)
Add a string parameter to the task.
void | clearParams ()
Clears all parameters.
std::string | getAllParamsAsString () const
Return all the parameters as a comma separated string.
std::string | getConstantName () const
Returns the 'constant definition name' for the task.
std::string | getDescription () const
Returns a single line description for the task.
std::vector< double > | getDoubleParams () const
Get the list of long parameters for the task.
int | getID () const
Returns the unique ID for the task.
std::vector< long > | getLongParams () const
Get the list of long parameters for the task.
std::string | getNotes () const
Returns any notes applied to the task.
std::vector< std::string > | getStringParams () const
Get the list of string parameters for the task.
paramType | getType () const
Returns the 'type' of the parameter for a task.
bool | isPermitted () const
See if the task is permitted.
bool | isPermitted_double (const double value) const
See if the value is in the floating point parameter list.
bool | isPermitted_long (const long value) const
See if the value is in the long integer parameter list.
bool | isPermitted_string (const std::string value) const
See if the value is in the string parameter list.
void | setParams (const std::string value)
Set all parameters, regardless of type.

Detailed Description

Each group has permission to do one or more tasks. This class defines an individual task.

There is currently no programmatic interface for saving task information, since this should normally only be done by developers.

Tasks are loaded from the file config/security_tasks.xml.

Parameters, for example, the maximum number of queries for a group, or the databases that can be used by a group are not saved in config/security_tasks.xml, but are saved as part of the group information. However, the type of the parameter is saved in config/security_tasks.xml.

Member Enumeration Documentation

◆ paramType

enum paramType

Definitions for parameter type.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Each task has one or more parameters associated with it. For example, "Access to administration pages" would have a boolean value. Other tasks such as "Maximum execution time" need a single number to determine the limit.

Enumerator
TYPE_BOOL | The default - A single boolean parameter that is always 'true'.
TYPE_EQ_LONG | Single extra long integer parameter. The 'test' value must equal the stored value for this task to be permitted.
TYPE_LTE_LONG | Single extra long integer parameter. The 'test' value must be less than or equal to the stored value for this task to be permitted.
TYPE_GTE_LONG | Single extra long integer parameter. The 'test' value must be greater than or equal to the stored value for this task to be permitted.
TYPE_LONG_ARRAY | Array of extra long integer parameters. The test value must equal one of these values for the task to be permitted.
TYPE_EQ_DOUBLE | Single extra floating point parameter. The 'test' value must equal the stored value for this task to be permitted.
TYPE_LTE_DOUBLE | Single extra floating point parameter. The 'test' value must be less than or equal to the stored value for this task to be permitted.
TYPE_GTE_DOUBLE | Single extra floating point parameter. The 'test' value must be greater than or equal to the stored value for this task to be permitted.
TYPE_DOUBLE_ARRAY | Array of extra floating point parameters. The test value must equal one of these values for the task to be permitted.
TYPE_EQ_STRING | Single extra string parameter. The 'test' value must equal the stored value for this task to be permitted.
TYPE_STRING_ARRAY | Array of extra string parameters. The test value must equal one of these values for the task to be permitted.
TYPE_USERS_ARRAY | Array of user IDs, similar to TYPE_LONG_ARRAY. When this type of task is assigned to a group, it is automatically filled with all user IDs in the group.
TYPE_ALL_USERS_ARRAY | Array of user IDs, similar to TYPE_LONG_ARRAY. When this type of task is assigned to a group, it is automatically filled with the user IDs of all users that are in any group that the user belongs to.

Constructor & Destructor Documentation

◆ ms_security_task()

ms_security_task ( )

Create a new empty object - not particularly useful.

Default constructor does nothing. Need to call loadFromFile() or addTask() to assign tasks to the list.

◆ ~ms_security_task()

~ms_security_task ( )

Destructor of the class.

The destructor is never called directly.

Member Function Documentation

◆ addDoubleParam()

bool addDoubleParam ( const double value )

Add a floating point parameter to the task.

This function will generally only be called by Administration utilities.

See also addLongParam() for an example.

Parameters
value
  • If the param type is ms_security_task::TYPE_EQ_DOUBLE then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_LTE_DOUBLE then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_GTE_DOUBLE then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_DOUBLE_ARRAY then value will be added to the list of values.
Returns
true for any of the valid types above, otherwise return false because the expected parameter type is not correct.

◆ addLongParam()

bool addLongParam ( const long value )

Add a long parameter to the task.

This function will generally only be called by Administration utilities. For example, this could be the maximum number of spectra permitted for a search.

See also isPermitted_long() which might be called by other applications to determine if a user has rights to run, for example, a search with 1000 spectra.

Parameters
value
  • If the param type is ms_security_task::TYPE_EQ_LONG then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_LTE_LONG then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_GTE_LONG then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_LONG_ARRAY then value will be added to the list of values.
  • If the param type is ms_security_task::TYPE_USERS_ARRAY then value will be added to the list of values.
  • If the param type is ms_security_task::TYPE_ALL_USERS_ARRAY then value will be added to the list of values.
Returns
true for any of the valid types above, otherwise return false because the expected parameter type is not correct.

◆ addStringParam()

bool addStringParam ( const std::string value )

Add a string parameter to the task.

This function will generally only be called by Administration utilities. For example, this could be a list of databases that may be searched.

See also isPermitted_string() which might be called by other applications to determine if a user has rights to run, for example, a search agains EST_others.

Parameters
value
  • If the param type is ms_security_task::TYPE_EQ_STRING then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_STRING_ARRAY then value will be added to the list of values.
Returns
true for any of the valid types above, otherwise return false because the expected parameter type is not correct.

◆ clearParams()

void clearParams ( )

Clears all parameters.

These parameters are not saved in the tasks file, but in the individual groups files.

◆ getAllParamsAsString()

std::string getAllParamsAsString ( ) const

Return all the parameters as a comma separated string.

This function is mostly useful for debugging, or possibly for an administration application.

Returns
A comma separated string of values.

◆ getConstantName()

std::string getConstantName ( ) const

Returns the 'constant definition name' for the task.

Each task that has been predefined by Matrix Science will have a definition that can be used by applications calling Mascot Parser instead of just using the number (available from getID()). Any additional tasks added by end users will have a constant name, but this cannot be used in the calling code because it will not be embedded into the library.

Returns
constant name of the task

◆ getDescription()

std::string getDescription ( ) const

Returns a single line description for the task.

This should describe the task sufficiently well for an administrator.

Returns
description of the task

◆ getDoubleParams()

std::vector< double > getDoubleParams ( ) const

Get the list of long parameters for the task.

If the task type is one of the following, then the function will return a single long value in the array:

  • ms_security_task::TYPE_EQ_DOUBLE
  • ms_security_task::TYPE_LTE_DOUBLE
  • ms_security_task::TYPE_GTE_DOUBLE

If the task type is ms_security_task::TYPE_DOUBLE_ARRAY then the function will return an array of long values.

For all other task types, the return value will be an empty array.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns
vector of double param values, can be empty

◆ getID()

int getID ( ) const

Returns the unique ID for the task.

IDs up to 1000 are reserved for use by Matrix Science. Values above 1000 may be used by other applications.

Returns
id of the task

◆ getLongParams()

std::vector< long > getLongParams ( ) const

Get the list of long parameters for the task.

If the task type is one of the following, then the function will return a single long value in the array:

  • ms_security_task::TYPE_EQ_LONG
  • ms_security_task::TYPE_LTE_LONG
  • ms_security_task::TYPE_GTE_LONG

If the task type is ms_security_task::TYPE_LONG_ARRAY or TYPE_USERS_ARRAY or TYPE_ALL_USERS_ARRAY then the function will return an array of long values.

For all other task types, the return value will be an empty array.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns
vector of long param values, can be empty

◆ getNotes()

std::string getNotes ( ) const

Returns any notes applied to the task.

Optional notes to describe the values. Could be displayed by an administration utility for providing further help.

Returns
notes of the task

◆ getStringParams()

std::vector< std::string > getStringParams ( ) const

Get the list of string parameters for the task.

If the task type is one of the following, then the function will return a single long value in the array:

  • ms_security_task::TYPE_EQ_STRING
  • ms_security_task::TYPE_LTE_STRING
  • ms_security_task::TYPE_GTE_STRING

If the task type is ms_security_task::TYPE_STRING_ARRAY then the function will return an array of long values.

For all other task types, the return value will be an empty array.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns
vector of string param values, can be empty

◆ isPermitted()

bool isPermitted ( ) const

See if the task is permitted.

For example, this could called by an application to determine if a user has rights to access administration screens.

This function should only be called if the parameter type is ms_security_task::TYPE_BOOL in which case it will return true.

Returns
true if the parameter type is ms_security_task::TYPE_BOOL, otherwise it will return false.

◆ isPermitted_double()

bool isPermitted_double ( const double value ) const

See if the value is in the floating point parameter list.

For example, this could called by an application to determine if a user has rights to run a search with 1000 spectra (except this would use LONG rather than DOUBLE).

Parameters
value
  • If the param type is ms_security_task::TYPE_EQ_DOUBLE and value is equal to the saved value, then this function will return true.
  • If the param type is ms_security_task::TYPE_LTE_DOUBLE and value is less than or equal to the stored value, then this function will return true.
  • If the param type is ms_security_task::TYPE_GTE_DOUBLE and value is greater than or equal to the stored value, then this function will return true.
  • If the param type is ms_security_task::TYPE_DOUBLE_ARRAY and value matches one of the values in the list of stored values, then function will return true.
Returns
true if one of the conditions above is met, otherwise it will return false.

◆ isPermitted_long()

bool isPermitted_long ( const long value ) const

See if the value is in the long integer parameter list.

For example, this could called by an application to determine if a user has rights to run a search with 1000 spectra.

Parameters
value
  • If the param type is ms_security_task::TYPE_EQ_LONG and value is equal to the saved value, then this function will return true.
  • If the param type is ms_security_task::TYPE_LTE_LONG and value is less than or equal to the stored value, then this function will return true.
  • If the param type is ms_security_task::TYPE_GTE_LONG and value is greater than or equal to the stored value, then this function will return true.
  • If the param type is ms_security_task::TYPE_LONG_ARRAY and value matches one of the values in the list of stored values, then function will return true.
  • If the param type is ms_security_task::TYPE_USERS_ARRAY and value matches one of the values in the list of stored values, then function will return true.
  • If the param type is ms_security_task::TYPE_ALL_USERS_ARRAY and value matches one of the values in the list of stored values, then function will return true.
Returns
true if one of the conditions above is met, otherwise it will return false.

◆ isPermitted_string()

bool isPermitted_string ( const std::string value ) const

See if the value is in the string parameter list.

For example, this function could be called by an application to determine if a user has rights to run, for example, a search against EST_others.

Parameters
value
  • If the param type is ms_security_task::TYPE_EQ_STRING and value matches the stored value, then this function will return true.
  • If the param type is ms_security_task::TYPE_STRING_ARRAY and value matches one of the stored values, then this function will return true.
Returns
true if one of the conditions above is met, otherwise it will return false.

◆ setParams()

void setParams ( const std::string value )

Set all parameters, regardless of type.

This function will generally only be called by Administration utilities. It is useful when setting parameters from a general edit box. The text is parsed and if a list is expected, this will be split at commas or spaces.

Parameters
value parameter value to set, can be a comma or space separated list
The documentation for this class was generated from the following files:
  • ms_security_task.hpp
  • ms_security_task.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security_tasks Class Reference

  • matrix_science
  • ms_security_tasks
Public Types | Public Member Functions | List of all members
ms_security_tasks Class Reference
Mascot security and authentication module

Each group has permission to do one or more tasks. This class defines a collection of tasks. More...

#include <ms_security_tasks.hpp>

Inheritance diagram for ms_security_tasks:
[legend]
Collaboration diagram for ms_security_tasks:
[legend]

Public Types

enum TASKID {
SECTASK_ALLOWPMF = 1 ,
SECTASK_ALLOWMSMS = 2 ,
SECTASK_ALLOWMSMSNOENZYME = 3 ,
SECTASK_ALLOWPMFNOENZYME = 4 ,
SECTASK_MAXCONCURRENTSEARCHES = 5 ,
SECTASK_MAXJOBPRIORITY = 6 ,
SECTASK_MAXQUERIES = 7 ,
SECTASK_MAXEXECUTIONTIME = 8 ,
SECTASK_ALLFASTA = 9 ,
SECTASK_NAMEDFASTA = 10 ,
SECTASK_MAXVARMODS = 11 ,
SECTASK_MAXETVARMODS = 12 ,
SECTASK_SEESEARCHINGROUP = 13 ,
SECTASK_SEEALLSEARCHESWITHUSERID = 14 ,
SECTASK_SEEOLDSEARCHES = 15 ,
SECTASK_USEMSREVIEWEXE = 16 ,
SECTASK_VIEWCONFIGUSINGMSSTATUS = 17 ,
SECTASK_MODIFYOWNPROFILE = 18 ,
SECTASK_DAEMONCLIENT = 19 ,
SECTASK_DISTILLERCLIENT = 20 ,
SECTASK_ALLOWSPOOFOTHERUSER = 22 ,
SECTASK_INTEGRASYSTEMACCOUNT = 23 ,
SECTASK_BIOTOOLSBATCH = 24 ,
SECTASK_SPOOFNAMEDGROUPSONLY = 25 ,
SECTASK_DOWNLOAD_DISTILLER_XML = 26 ,
SECTASK_UPLOAD_DISTILLER_XML = 27 ,
SECTASK_ADMINPAGES = 30 ,
SECTASK_ACCESSDBSETUP = 31 ,
SECTASK_USEMSSTATUSEXE = 32 ,
SECTASK_MSSTATUSEXECLUSTER = 33 ,
SECTASK_MSSTATUSEXERETRYDB = 34 ,
SECTASK_KILLTASKINGROUP = 35 ,
SECTASK_KILLALLTASK = 36 ,
SECTASK_VIEWCONFIG = 37 ,
SECTASK_EDITCONFIG = 38 ,
SECTASK_MAXETACCESSIONS = 50 ,
SECTASK_MAXNOENZQUERIES = 51 ,
SECTASK_MAXFASTAFILES = 52 ,
SECTASK_DENYQUANT = 53 ,
SECTASK_DATAURLPROTOCOLS = 54 ,
SECTASK_DATAURLMAXSIZE = 55 ,
SECTASK_SEESEARCHINANYGROUP = 60 ,
MISECTASK_ACCESS =100 ,
MISECTASK_PROTEINAPPROVAL =101 ,
MISECTASK_ADDIMPORTFILTER =102 ,
MISECTASK_ADMIN =103 ,
MISECTASK_ADDCUSTOMREPORT =104 ,
MISECTASK_DELETECUSTOMREPORT =105 ,
MISECTASK_ADDEXCLUSIONFILE =106 ,
MISECTASK_DELETEEXCLUSIONFILE =107 ,
MISECTASK_SENDNOTIFICATION =108
}
Definitions for TASKID. More...

Public Member Functions

ms_security_tasks ()
Create an empty list of tasks.
ms_security_tasks (const char *filename)
Load the list of tasks from file.
~ms_security_tasks ()
Destructor of the class.
bool | addTask (const ms_security_task &task)
Add a task to the list.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::string | getDiffsAsText (const ms_security_tasks &old)
Returns differences between the two task lists as text.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumberOfTasks () const
Returns the number of tasks in the collection.
ms_security_task | getTask (const int num) const
Returns a particular task.
ms_security_task | getTaskFromID (const int taskID) const
Returns a particular task.
bool | isFastaPermitted (const std::string database) const
See if a particular fasta file can be accessed.
bool | isPermitted (const int taskID) const
See if the task is permitted.
bool | isPermitted_double (const int taskID, const double value) const
See if the value is in the floating point parameter list.
bool | isPermitted_long (const int taskID, const long value) const
See if the value is in the long integer parameter list.
bool | isPermitted_string (const int taskID, const std::string value) const
See if the value is in the string parameter list.
bool | isTaskExists (const int taskID) const
Returns true if a task with this ID exists.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | loadFromFile (const char *filename)
Load definitions either from security_tasks.xml or from a group file.
void | removeAllTasks ()
Remove all tasks from the list.
bool | removeTask (const int taskID)
Remove a task from the list.
bool | saveToFile (const char *filename)
Save definitions either to the security_tasks.xml file or to a group file.
bool | updateTask (const ms_security_task &task)
Updates a task in the list with new parameters.

Detailed Description

Each group has permission to do one or more tasks. This class defines a collection of tasks.

There is currently no programmatic interface for saving task information, since this should normally only be done by developers.

Tasks are loaded from the file security_tasks.xml.

Parameters, for example, the maximum number of queries for a group, or the databases that can be used by a group are not saved in security_tasks.xml, but are saved as part of the group file. However, the type of the parameter is saved in security_tasks.xml.

Member Enumeration Documentation

◆ TASKID

enum TASKID

Definitions for TASKID.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Each task has one or more parameters associated with it. For example, "Access to administration pages" would have a boolean value. Other tasks such as "Maximum execution time" need a single number to determine the limit. security_tasks.xml has further information about each task.

Enumerator
SECTASK_ALLOWPMF

SEARCH: Allow PMF searches.

SECTASK_ALLOWMSMS

SEARCH: Allow MS-MS (and SQ) searches.

SECTASK_ALLOWMSMSNOENZYME

SEARCH: Allow no-enzyme MSMS searche.

SECTASK_ALLOWPMFNOENZYME

SEARCH: Allow no-enzyme PMF searches.

SECTASK_MAXCONCURRENTSEARCHES

SEARCH: Maximum number of concurrent searches per user.

SECTASK_MAXJOBPRIORITY

SEARCH: Maximum mascot search job priority.

SECTASK_MAXQUERIES

SEARCH: Maximum number of queries per search.

SECTASK_MAXEXECUTIONTIME

SEARCH: Maximum execution time.

SECTASK_ALLFASTA

SEARCH: Allow all fasta databases to be searched.

SECTASK_NAMEDFASTA

SEARCH: Special fasta databases that override the default setting.

SECTASK_MAXVARMODS

SEARCH: Maximum number of variable modifications allowed for a standard search.

SECTASK_MAXETVARMODS

SEARCH: Maximum number of variable modifications allowed in an error tolerant search.

SECTASK_SEESEARCHINGROUP

VIEW: See search results from other people in your own group.

SECTASK_SEEALLSEARCHESWITHUSERID

VIEW: See all search results with a USERID.

SECTASK_SEEOLDSEARCHES

VIEW: See search results without USERID field.

SECTASK_USEMSREVIEWEXE

VIEW: Allow user to view the search log.

SECTASK_VIEWCONFIGUSINGMSSTATUS

GENERAL: View config files using ms-status.

SECTASK_MODIFYOWNPROFILE

GENERAL: Allow user to modify their own profile.

SECTASK_DAEMONCLIENT

CLIENT: Mascot Daemon is allowed to submit searches.

SECTASK_DISTILLERCLIENT

CLIENT: Mascot Distiller is allowed to submit searches.

SECTASK_ALLOWSPOOFOTHERUSER

CLIENT: For Mascot Daemon, allow spoofing of another user.

SECTASK_INTEGRASYSTEMACCOUNT
Deprecated:
CLIENT: Integra system account.
SECTASK_BIOTOOLSBATCH

CLIENT: Bruker BioTools batch searches.

SECTASK_SPOOFNAMEDGROUPSONLY

CLIENT: For Mascot Daemon, restrict spoofing to the named group(s).

SECTASK_DOWNLOAD_DISTILLER_XML

CLIENT: Client is allowed to download Distiller XML files.

SECTASK_UPLOAD_DISTILLER_XML

CLIENT: Client is allowed to upload Distiller XML files.

SECTASK_ADMINPAGES

ADMIN: Use the security administration utility.

SECTASK_ACCESSDBSETUP

ADMIN: Access to the Database Maintenance application.

SECTASK_USEMSSTATUSEXE

ADMIN: Allow use of Database Status application.

SECTASK_MSSTATUSEXECLUSTER

ADMIN: Allow user to see cluster pages in ms-status.exe.

SECTASK_MSSTATUSEXERETRYDB

ADMIN: Allow user to retry a failed database or recompress files using ms-status.exe.

SECTASK_KILLTASKINGROUP

ADMIN: Kill / pause / change priority of searches from own group.

SECTASK_KILLALLTASK

ADMIN: Kill / pause / change priority of searches from other groups.

SECTASK_VIEWCONFIG

ADMIN: Access to the configuration editor to view configuration files.

SECTASK_EDITCONFIG

ADMIN: Access to the configuration editor to edit configuration files.

SECTASK_MAXETACCESSIONS

SEARCH: Maximum number of accessions allowed in an old style error tolerant search.

SECTASK_MAXNOENZQUERIES

SEARCH: Maximum number of queries for a no enzyme search. If not specified, SECTASK_MAXQUERIES will be used.

SECTASK_MAXFASTAFILES

SEARCH: Maximum number of fasta files in a single search.

SECTASK_DENYQUANT

SEARCH: Prevent the use of quantitation methods in a search.

SECTASK_DATAURLPROTOCOLS

SEARCH: Allow submitting searches with DATAURL parameter.

SECTASK_DATAURLMAXSIZE

SEARCH: Maximum number of bytes to download for DATAURL.

SECTASK_SEESEARCHINANYGROUP

VIEW: See search results from any user in any group you belong to.

MISECTASK_ACCESS
Deprecated:
INSIGHT: Access to Mascot Insight.
MISECTASK_PROTEINAPPROVAL
Deprecated:
INSIGHT: Protein approval in Mascot Insight.
MISECTASK_ADDIMPORTFILTER
Deprecated:
INSIGHT: Add import assignment filter.
MISECTASK_ADMIN
Deprecated:
INSIGHT: Mascot Insight administration functions.
MISECTASK_ADDCUSTOMREPORT
Deprecated:
INSIGHT: Add custom report to Mascot Insight.
MISECTASK_DELETECUSTOMREPORT
Deprecated:
INSIGHT: Delete custom report Mascot Insight.
MISECTASK_ADDEXCLUSIONFILE
Deprecated:
INSIGHT: Add BlastCluster exclusion file.
MISECTASK_DELETEEXCLUSIONFILE
Deprecated:
INSIGHT: Delete BlastCluster exclusion file.
MISECTASK_SENDNOTIFICATION
Deprecated:
INSIGHT: Send notification.

Constructor & Destructor Documentation

◆ ms_security_tasks()

ms_security_tasks ( )

Create an empty list of tasks.

Default constructor does nothing. Need to call loadFromFile() or addTask() to assign tasks to the list.

◆ ~ms_security_tasks()

~ms_security_tasks ( )

Destructor of the class.

The destructor is never called directly.

Member Function Documentation

◆ addTask()

bool addTask ( const ms_security_task & task )

Add a task to the list.

If there is already a task with this ID, then the two will be 'combined'. For example, assume that the task SECTASK_ALLOWNAMEDFASTA is already in the list with NCBInr as a parameter. If this function is called with the same task, but MSDB as a parameter, then the resulting task will have MSDB and NCBInr as parameters.

Similarly, if the task SECTASK_MAXQUERIES is already in the list with a value of 300, and a new task is added with a value of 1000, then the value 1000 will be used. For the types ms_security_task::TYPE_EQ_LONG, ms_security_task::TYPE_EQ_DOUBLE and ms_security_task::TYPE_EQ_STRING, the parameter for the new task being added will replace the existing task parameter.

Parameters
task is the new task to be added to the list.
Returns
True if the function succeeds. The function should not normally fail.

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getDiffsAsText()

std::string getDiffsAsText ( const ms_security_tasks & old )

Returns differences between the two task lists as text.

Primarily used for logging.

Parameters
old ms_security_tasks object to diff
Returns
all differences as a string

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getNumberOfTasks()

int getNumberOfTasks ( ) const

Returns the number of tasks in the collection.

Use this value when trying to retrieve all tasks using getTask().

Returns
number of tasks

◆ getTask()

ms_security_task getTask ( const int num ) const

Returns a particular task.

Parameters
num should be in the range 0.. getNumberOfTasks() -1
Returns
an ms_security_task object. If there was an error, the id for this security object will be -1.

◆ getTaskFromID()

ms_security_task getTaskFromID ( const int taskID ) const

Returns a particular task.

Find a task in the collection given its ID.

Parameters
taskID should be a valid taskID.
Returns
an ms_security_task object. If there was an error, the id for this security object will be -1.

◆ isFastaPermitted()

bool isFastaPermitted ( const std::string database ) const

See if a particular fasta file can be accessed.

Check if a user has rights to search against a particular database This is a special case because SECTASK_NAMEDFASTA is the only 'negative' task (and only if SECTASK_ALLFASTA is set), so this specific call makes end user programs simpler.

Parameters
database is the database name – for example MSDB.
Returns
True if the user has rights to search this database.

◆ isPermitted()

bool isPermitted ( const int taskID ) const

See if the task is permitted.

For example, this could called by an application to determine if a user has rights to access administration screens.

This function should only be called if the parameter type of taskID is ms_security_task::TYPE_BOOL.

Parameters
taskID The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration – for example, matrix_science::ms_security_tasks::SECTASK_ADMINPAGES.
Returns
true if the parameter type is ms_security_task::TYPE_BOOL, and the specified task in the list of tasks otherwise it will return false.

◆ isPermitted_double()

bool isPermitted_double | ( | const int | taskID,
 |  | const double | value
 | ) |  | const

See if the value is in the floating point parameter list.

See also
ms_security_task::isPermitted_double()
Parameters
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration – for example, matrix_science::ms_security_tasks::SECTASK_MAXQUERIES.
value | is the value for comparison.
Returns
True if the tasks is permitted.

◆ isPermitted_long()

bool isPermitted_long | ( | const int | taskID,
 |  | const long | value
 | ) |  | const

See if the value is in the long integer parameter list.

For example, this could called by an application to determine if a user has rights to run a search with 1000 spectra.

See also
ms_security_task::isPermitted_long()
Parameters
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration – for example, matrix_science::ms_security_tasks::SECTASK_MAXQUERIES.
value | is the value for comparison.
Returns
True if the tasks is permitted.

◆ isPermitted_string()

bool isPermitted_string | ( | const int | taskID,
 |  | const std::string | value
 | ) |  | const

See if the value is in the string parameter list.

For example, this could called by an application to determine if a user has rights to run a search against the MSDB database.

See also
isFastaPermitted(), ms_security_task::isPermitted_string()
Parameters
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration – for example, matrix_science::ms_security_tasks::SECTASK_NAMEDFASTA.
value | Is the value for comparison.
Returns
True if the tasks is permitted.

◆ isTaskExists()

bool isTaskExists ( const int taskID ) const

Returns true if a task with this ID exists.

Parameters
taskID Task ID to check.
Returns
true if a task with this ID exists; false otherwise.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ removeAllTasks()

void removeAllTasks ( )

Remove all tasks from the list.

The result will then be an empty list.

◆ removeTask()

bool removeTask ( const int taskID )

Remove a task from the list.

Parameters
taskID Should be a valid task ID.
Returns
True if the task was in the list and was deleted.

◆ updateTask()

bool updateTask ( const ms_security_task & task )

Updates a task in the list with new parameters.

Parameters
task Replace the definition for a task in the list with this.
Returns
True if the task was already in the list.
The documentation for this class was generated from the following files:
  • ms_security_tasks.hpp
  • ms_security_tasks.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_session Class Reference

  • matrix_science
  • ms_session
Public Member Functions | List of all members
ms_session Class Reference
Mascot security and authentication module

Use this class to determine if a user is logged in and if they have 'permission' to perform tasks. More...

#include <ms_security_session.hpp>

Inheritance diagram for ms_session:
[legend]
Collaboration diagram for ms_session:
[legend]

Public Member Functions

ms_session (const int timeout, const std::string prefix)
Use this constructor to start a new session independent of users and Mascot security.
ms_session (const std::string session_id="")
Use this constructor to open the current session.
ms_session (const std::string userName, const std::string connectionID, const std::string database)
This constructor is used by Mascot integra to login to Mascot.
ms_session (const std::string userName, const std::string userPassword)
Use this constructor to start a new secure session.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
bool | canResultsFileBeViewed (const int userID) const
Check if a results file with the passed user ID can be viewed.
void | clearAllErrors ()
Remove all errors from the current list of errors.
bool | clearParam (const std::string name)
Remove a custom parameter from the session file.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
bool | destroy ()
Destroy the current session. Should be called when a user logs out.
bool | getBoolParam (const std::string name, bool &param) const
Return a custom 'bool' parameter from the session file.
double | getDoubleParam (const std::string name) const
Return a custom 'double' parameter from the session file.
bool | getDoubleParam (const std::string name, double &param) const
Return a custom 'double' parameter from the session file.
std::string | getEmailAddress () const
Return the email address for the currently logged in user.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFullUserName () const
Return the full name for the currently logged in user.
std::string | getID () const
Return the sessionID for this session file.
int | getIntParam (const std::string name) const
Return a custom 'integer' parameter from the session file.
bool | getIntParam (const std::string name, int &param) const
Return a custom 'integer' parameter from the session file.
std::string | getIPAddress () const
Return ip address of the currently logged in user.
time_t | getLastAccessed () const
Returns the time that the session was last updated.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
long | getLongParam (const std::string name) const
Return a custom 'long' parameter from the session file.
bool | getLongParam (const std::string name, long &param) const
Return a custom 'long' parameter from the session file.
std::map< std::string, std::string > | getParams () const
Returns a list of all the parameters saved in the session file.
matrix_science::ms_security_tasks | getPermittedTasks () const
Returns the permitted tasks for the currently logged in user.
std::vector< int > | getSpoofableUsers () const
Returns a list of user IDs that can be spoofed.
std::string | getStringParam (const std::string name) const
Return a custom 'string' parameter from the session file.
bool | getStringParam (const std::string name, std::string &param) const
Return a custom 'string' parameter from the session file.
time_t | getTimeout () const
Returns the time when the session times out.
time_t | getTimeParam (const std::string name) const
Return a custom 'time' parameter from the session file.
bool | getTimeParam (const std::string name, time_t &param) const
Return a custom 'time' parameter from the session file.
int | getUserID () const
Return the unique userid for the currently logged in user.
std::string | getUserName () const
Return the user 'login' name for the currently logged in user.
matrix_science::ms_user::usertype | getUserType () const
Returns the type of user.
bool | isFastaPermitted (const std::string database) const
Check if a particular fasta file can be accessed.
bool | isPermitted (const int taskID) const
Check if the task is permitted.
bool | isPermitted_double (const int taskID, const double value) const
Check if the value is in the floating point parameter list.
bool | isPermitted_long (const int taskID, const long value) const
Check if the value is in the long integer parameter list.
bool | isPermitted_string (const int taskID, const std::string value) const
Check if the value is in the string parameter list.
bool | isSecurityEnabled () const
Return true if the security system is enabled.
bool | isTimedOut () const
Returns true if the current session has timed out.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | saveBoolParam (const std::string name, bool param)
Save a custom 'bool' parameter in the session file.
bool | saveDoubleParam (const std::string name, double param)
Save a custom 'double' parameter in the session file.
bool | saveIntParam (const std::string name, int param)
Save a custom 'integer' parameter in the session file.
bool | saveLongParam (const std::string name, long param)
Save a custom 'long integer' parameter in the session file.
bool | saveStringParam (const std::string name, const std::string param)
Save a custom 'string' parameter in the session file.
bool | saveTimeParam (const std::string name, time_t param)
Save a custom 'time' parameter in the session file.
bool | setPermittedTasks (const matrix_science::ms_security_tasks &val)
Sets the permitted tasks for the currently logged in user.
bool | update (const ms_security &sec)
Only needs to be called by administration applications after user rights have changed.

Detailed Description

Use this class to determine if a user is logged in and if they have 'permission' to perform tasks.

This is the only security class that most applications will need to use. This class should be used even if security is disabled because the underlying structure deals with this. If security is disabled, then isValid() and isPermitted() will both return true.

Session information is saved in files in the ../sessions directory. The session files have the same name as the session id which will be of the general form 'username_uniquenumber'. The unique number is assigned by the system and the username is the login name.

Special cases are as follows:

Session Name | Description
[username]_[random_number] | Session name for a normal user.
[username]_webserverauth | Session name for a user logged in using web authentication. This session file is created/modified when the user is modified. It is not possible to use this session id unless the user is 'logged into' the web server using the name 'username'
all_secdisabledsession | The Mascot security system is not enabled. This session file will only exist if security is disabled. Attempts to use it when security is enabled will fail.
cmd_cmdlinesession | Any applications run directly from a shell or command prompt will use this session id. Any script run directly as a cgi application (or chained from a cgi script) will not be able to use this session id.
guest_guestsession | Any user who is logged in as 'guest'. If the guest account is not enabled, this session will not be available
[name]_computername | for 3rd party applications that have not implemented Mascot security, it is possible to specify a computer name rather than a login name and password.
[ipaddr]_computeripaddress | For 3rd party applications that have not implemented Mascot security, it is possible to specify an ip address rather than a login name and password.
[string]_agentstring | Agent string such as 'Mozilla'. Will only be used a last resort by third party applications.
integradb@name_session | Mascot integra user. The integradb is the value returned by: ms_security_options::getIntegraDatabaseName(). Internally, this session id will be translated into a Mascot Integra session string by replacing the @ with a pipe symbol, and removing the underscore between the name and the session. The Mascot cookie will be this session id, and not the Integra connection string. There is a special case of the user being (system).

Constructor & Destructor Documentation

◆ ms_session() [1/4]

ms_session ( const std::string session_id = "" )

Use this constructor to open the current session.

Call isValid() to check that a session was opened. If isValid() returns false, then getLastError() should be called to determine an appropriate action, such as asking a user to login.

A successful call to this constructor will cause the last accessed time to be updated (for ms_user::USER_NORMAL only).

If the session_id parameter is empty, then this constructor will try the following in turn:

  • Try to find the session_id from a cookie (MASCOT_SESSION=).
  • If the program is being run from the command line (no REMOTE_USER environment variable set) use cmd_cmdlinesession, with all access rights.
  • If security is disabled, then a disabled security session will be created.
  • If integrated web server authentication is enabled, check REMOTE_USER – if that fails, try guest.
  • If a computer name/IP address has been specified as a work-around for 3rd party applications, try that.
  • If a guest account has been enabled use that.

isPermitted() should be then be called as required to determine if the user can perform certain actions.

Possible errors, and suitable actions for an interactive application, are:

  • ms_errs::ERR_MSP_SECURITY_NOTLOGGEDIN - ask the user to login.
  • ms_errs::ERR_MSP_SECURITY_DIFFERENTIPADDR - display an error message and ask user to login again.
  • ms_errs::ERR_MSP_SECURITY_TIMEDOUT - ask the user to login again.
  • ms_errs::ERR_MSP_SECURITY_MISSINGSESSIONFILE - similar to timeout, so ask the user to login again.
  • ms_errs::ERR_MSP_SECURITY_SPOOFATTEMPT1 - ask the user to try again, and if this fails contact their Administrator.
  • ms_errs::ERR_MSP_SECURITY_SPOOFATTEMPT2 - ask the user to try again, and if this fails contact their Administrator.
  • ms_errs::ERR_MSP_SECURITY_SPOOFATTEMPT3 - ask the user to try again, and if this fails contact their Administrator.
  • ms_errs::ERR_MSP_SECURITY_SPOOFATTEMPT4 - ask the user to try again, and if this fails contact their Administrator.
Parameters
session_id If session_id is empty, then this constructor will try to find session_id from a cookie (MASCOT_SESSION=).

◆ ms_session() [2/4]

ms_session | ( | const std::string | userName,
 |  | const std::string | userPassword
 | ) |  |

Use this constructor to start a new secure session.

The value from getID() should the be saved in a cookie.

Possible errors, and suitable actions for an interactive application, are:

  • ms_errs::ERR_MSP_SECURITY_NOT_ENABLED - no action.
  • ms_errs::ERR_MSP_SECURITY_INVALIDUSER - ask the user to try again.
  • ms_errs::ERR_MSP_SECURITY_INVALIDPASSWORD - ask the user to try again.
  • ms_errs::ERR_MSP_SECURITY_PASSWORDEXPIRED - put up a screen with old password, new password and then call ms_security::updatePassword().
  • ms_errs::ERR_MSP_SECURITY_ACCOUNT_DISABLED - ask the user to contact the administrator.
  • ms_errs::ERR_MSP_SECURITY_NOTNORMALUSER - ask the user to contact the administrator.
  • ms_errs::ERR_MSP_SECURITY_SAVESESSIONFILE - ask the user to contact the administrator.
  • (deprecated) ms_errs::ERR_MSP_SECURITY_FAILGETINTEGRAURL - ask the user to check the Mascot Integra server.
  • (deprecated) ms_errs::ERR_MSP_SECURITY_NO_INTEGRA_LOGIN - ask the user to login from Mascot Integra.
Parameters
userName | is the user name entered by the user.
userPassword | is the unencrypted password.

◆ ms_session() [3/4]

ms_session | ( | const std::string | userName,
 |  | const std::string | connectionID,
 |  | const std::string | database
 | ) |  |

This constructor is used by Mascot integra to login to Mascot.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

This constructor should only be used from Mascot Integra, or an application running in the Integra environment. The Integra application will have access to the currently logged in user name, and also to the Integra connectionID.

Possible errors, and suitable actions for an interactive application, are:

  • ms_errs::ERR_MSP_SECURITY_INVALIDUSER - add this user to the Mascot security.
  • ms_errs::ERR_MSP_SECURITY_ACCOUNT_DISABLED - ask the user to contact the administrator.
  • ms_errs::ERR_MSP_SECURITY_SAVESESSIONFILE - ask the user to contact the administrator.
  • ms_errs::ERR_MSP_SECURITY_FAILGETINTEGRAURL - ask the user to check the Mascot Integra server.
  • ms_errs::ERR_MSP_SECURITY_NOT_INTEGRA_USER - The 'type' of user needs to be changed to a Mascot Integra user using the Mascot security administration application.

If this function succeeds, it will set session_id to a session variable of the form database@userName_connectionID.

Parameters
userName | is the Integra user name.
connectionID | is the Integra connection string.
database | is the name of the Mascot integra database.

◆ ms_session() [4/4]

ms_session | ( | const int | timeout,
 |  | const std::string | prefix
 | ) |  |

Use this constructor to start a new session independent of users and Mascot security.

Parameters
timeout | is the inactivity time in seconds before the session becomes timed out. A value of zero indicates it will never time out.
prefix | is a prefix to be used as the session id: will be of the form prefix_randomnumber.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ canResultsFileBeViewed()

bool canResultsFileBeViewed ( const int userID ) const

Check if a results file with the passed user ID can be viewed.

This is a helper function to make end user programs simpler.

Parameters
userID is the USERID value from the results file. Old results files don't have this value, in which case ms_searchparams::getUSERID() will return 0.
Returns
True if the user has rights to view this results file.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ clearParam()

bool clearParam ( const std::string name )

Remove a custom parameter from the session file.

Use this function when you no longer want a value associated with a key name.

See also Using custom parameters

Parameters
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns
boolean value to indicate if the value was successfully removed.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ destroy()

bool destroy ( )

Destroy the current session. Should be called when a user logs out.

The session file is deleted and all user parameters are removed. Don't attempt to use the object after calling destroy().

Returns
True if the session was deleted. An attempt to delete the session file for a guest user, command line session, or authentication disabled will fail and return false.

◆ getBoolParam()

bool getBoolParam | ( | const std::string | name,
 |  | bool & | param
 | ) |  | const

Return a custom 'bool' parameter from the session file.

Note
This function should not be used from programming languages other than C++. Use getBoolParam(const std::string) const instead.
See also
saveBoolParam()

See also Using custom parameters

Parameters
name | name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns
boolean value to indicate if the value was successfully retrieved.

◆ getDoubleParam() [1/2]

double getDoubleParam ( const std::string name ) const

Return a custom 'double' parameter from the session file.

If a value of 0 is returned, it is not possible to determine if this is because there is no key value or if a value of zero was set for the key.

See also
saveDoubleParam()

See also Using custom parameters

Parameters
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns
The value of the parameter associated with the key name.

◆ getDoubleParam() [2/2]

bool getDoubleParam | ( | const std::string | name,
 |  | double & | param
 | ) |  | const

Return a custom 'double' parameter from the session file.

Note
This function should not be used from programming languages other than C++. Use getDoubleParam(const std::string) const instead.
See also
saveDoubleParam()

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns
The value of the parameter associated with the key name.

◆ getEmailAddress()

std::string getEmailAddress ( ) const

Return the email address for the currently logged in user.

Note that there is no guarantee that this is a valid email address.

Returns
email address for this session

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFullUserName()

std::string getFullUserName ( ) const

Return the full name for the currently logged in user.

See also
getUserName()
Returns
full user name for this session

◆ getID()

std::string getID ( ) const

Return the sessionID for this session file.

This the same as the session filename. If isValid() returns false, this will return an empty string. System session ids are described in ms_session::ms_session.

Returns
id of the session

◆ getIntParam() [1/2]

int getIntParam ( const std::string name ) const

Return a custom 'integer' parameter from the session file.

If a value of 0 is returned, it is not possible to determine if this is because there is no key value or if a value of zero was set for the key.

See also
saveIntParam()

See also Using custom parameters

Parameters
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns
The value of the parameter associated with the key name.

◆ getIntParam() [2/2]

bool getIntParam | ( | const std::string | name,
 |  | int & | param
 | ) |  | const

Return a custom 'integer' parameter from the session file.

Note
This function should not be used from programming languages other than C++. Use getIntParam(const std::string) const instead.
See also
saveIntParam()

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns
boolean value to indicate if the value was successfully retrieved.

◆ getIPAddress()

std::string getIPAddress ( ) const

Return ip address of the currently logged in user.

Will be 'UNKNOWN' if authentication is turned off and for the guest account.

Returns
IP address

◆ getLastAccessed()

time_t getLastAccessed ( ) const

Returns the time that the session was last updated.

Note that this time is not valid if authentication is turned off or the guest account is in use.

Returns
last access time

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getLongParam() [1/2]

long getLongParam ( const std::string name ) const

Return a custom 'long' parameter from the session file.

If a value of 0 is returned, it is not possible to determine if this is because there is no key value or if a value of zero was set for the key.

See also
saveLongParam()

See also Using custom parameters

Parameters
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns
The value of the parameter associated with the key name.

◆ getLongParam() [2/2]

bool getLongParam | ( | const std::string | name,
 |  | long & | param
 | ) |  | const

Return a custom 'long' parameter from the session file.

Note
This function should not be used from programming languages other than C++. Use getLongParam(const std::string) const instead.
See also
saveLongParam()

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns
boolean value to indicate if the value was successfully retrieved.

◆ getParams()

std::map< std::string, std::string > getParams ( ) const

Returns a list of all the parameters saved in the session file.

Note
Do not use this function from programming languages other than C++.
Returns
array of key, value pairs.

◆ getPermittedTasks()

ms_security_tasks getPermittedTasks ( ) const

Returns the permitted tasks for the currently logged in user.

Returns
A 'list' of the tasks that can be performed by the user.

◆ getSpoofableUsers()

std::vector< int > getSpoofableUsers ( ) const

Returns a list of user IDs that can be spoofed.

This will return an empty list if ms_security_tasks::SECTASK_ALLOWSPOOFOTHERUSER has not been specified.

If ms_security_tasks::SECTASK_SPOOFNAMEDGROUPSONLY is not specified, then this function returns all users by calling ms_security::getAllUserIDs().

If ms_security_tasks::SECTASK_SPOOFNAMEDGROUPSONLY is specified, then only users belonging to the names groups will be returned. This could be an empty list if the named groups don't contain any users or if there is no list of groups.

When ms-status.exe (or get_params.pl) is called with the parameter Show=MS_USERS, this function is called to create a list of users. The output format from these programs is:

"username","user id","user type","full name","email address"

For example:

 C:\Inetpub\mascot\x-cgi>ms-status.exe Show=MS_USERS
 Content-type: text/plain

 "guest","1","1","Guest user","guest@localhost"
 "admin","2","1","Administrator","admin@localhost"
 "daemon","4","1","Mascot Daemon","daemon@localhost"
 "(system)","6","2","Mascot Integra system account","integra@localhost"
Returns
a vector of IDs that can be spoofed, sorted by login names. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getStringParam() [1/2]

std::string getStringParam ( const std::string name ) const

Return a custom 'string' parameter from the session file.

If an empty string is returned, it is not possible to determine if this is because there is no key value or if an empty string was set for the key.

See also
saveStringParam()

See also Using custom parameters

Parameters
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns
Is the value of the parameter associated with the key name or an empty string if there is no key.

◆ getStringParam() [2/2]

bool getStringParam | ( | const std::string | name,
 |  | std::string & | param
 | ) |  | const

Return a custom 'string' parameter from the session file.

Note
This function should not be used from programming languages other than C++. Use getStringParam(const std::string) const instead.
See also
saveStringParam()

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns
boolean value to indicate if the value was successfully retrieved.

◆ getTimeout()

time_t getTimeout ( ) const

Returns the time when the session times out.

Note that the timeout is not valid if authentication is turned off or the guest account is in use.

A value of zero indicates it will never time out.

Note also that the timeout is set globally in the security settings, so the return value of this function is the same as calling ms_security_options::getSessionTimeout() . The only case where the two can differ is if 1) the user logs in and 2) the session timeout is changed globally after that.

Returns
timeout

◆ getTimeParam() [1/2]

time_t getTimeParam ( const std::string name ) const

Return a custom 'time' parameter from the session file.

If a value of 0 is returned, it is not possible to determine if this is because there is no key value or if a value of zero was set for the key.

See also
saveTimeParam()

See also Using custom parameters

Parameters
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns
The value of the parameter associated with the key name.

◆ getTimeParam() [2/2]

bool getTimeParam | ( | const std::string | name,
 |  | time_t & | param
 | ) |  | const

Return a custom 'time' parameter from the session file.

Note
This function should not be used from programming languages other than C++. Use getTimeParam(const std::string) const instead.
See also
saveTimeParam()

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns
boolean value to indicate if the value was successfully retrieved.

◆ getUserID()

int getUserID ( ) const

Return the unique userid for the currently logged in user.

Returns
The unique user id of the person logged in. There are several predefined IDs - see ms_user::systemids. Returns -1 if there is an error.

◆ getUserName()

std::string getUserName ( ) const

Return the user 'login' name for the currently logged in user.

Note that this will not include spaces. The full user name is available by calling: getFullUserName().

Returns
user name for this session

◆ getUserType()

ms_user::usertype getUserType ( ) const

Returns the type of user.

Returns
The user type as defined by the administrator using the administration utility.

◆ isFastaPermitted()

bool isFastaPermitted ( const std::string database ) const

Check if a particular fasta file can be accessed.

Check if a user has rights to search against a particular database This is a special case because SECTASK_NAMEDFASTA is the only 'negative' task (and only if SECTASK_ALLFASTA is set), so this specific call makes end user programs simpler.

See also
ms_security_tasks::isFastaPermitted()
Parameters
database is the database name – for example MSDB.
Returns
True if the user has rights to search this database.

◆ isPermitted()

bool isPermitted ( const int taskID ) const

Check if the task is permitted.

Returns true if the user is allowed to perform the task. If security is disabled, then this always returns true.

Parameters
taskID Task IDs are stored in security_tasks.xml file.
Returns
true if the user can accomplish the given task

◆ isPermitted_double()

bool isPermitted_double | ( | const int | taskID,
 |  | const double | value
 | ) |  | const

Check if the value is in the floating point parameter list.

See also
ms_security_task::isPermitted_double()
Parameters
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration – for example, matrix_science::ms_security_tasks::SECTASK_MAXQUERIES.
value | is the value for comparison.
Returns
True if the tasks is permitted.

◆ isPermitted_long()

bool isPermitted_long | ( | const int | taskID,
 |  | const long | value
 | ) |  | const

Check if the value is in the long integer parameter list.

For example, this could called by an application to determine if a user has rights to run a search with 1000 spectra.

See also
ms_security_task::isPermitted_long()
Parameters
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration – for example, matrix_science::ms_security_tasks::SECTASK_MAXQUERIES.
value | is the value for comparison.
Returns
True if the tasks is permitted.

◆ isPermitted_string()

bool isPermitted_string | ( | const int | taskID,
 |  | const std::string | value
 | ) |  | const

Check if the value is in the string parameter list.

For example, this could called by an application to determine if a user has rights to run a search against the MSDB database.

See also
ms_security_task::isPermitted_string()
Parameters
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration – for example, matrix_science::ms_security_tasks::SECTASK_NAMEDFASTA.
value | is the value for comparison.
Returns
True if the tasks is permitted.

◆ isSecurityEnabled()

bool isSecurityEnabled ( ) const

Return true if the security system is enabled.

If this returns false, then isPermitted() will also always return true.

Returns
true if security is enabled, false otherwise

◆ isTimedOut()

bool isTimedOut ( ) const

Returns true if the current session has timed out.

Some sessions such as the commandline session will never time out.

Returns
boolean value to indicate if the session has timed out.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ saveBoolParam()

bool saveBoolParam | ( | const std::string | name,
 |  | bool | param
 | ) |  |

Save a custom 'bool' parameter in the session file.

This can be useful for saving additional information that will be available to a cgi program later on in the same session. The value can be retrieved using getBoolParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns
true if the value is successfully saved.

◆ saveDoubleParam()

bool saveDoubleParam | ( | const std::string | name,
 |  | double | param
 | ) |  |

Save a custom 'double' parameter in the session file.

This can be useful for saving additional information that will be available to a cgi program later on in the same session. The value can be retrieved using getDoubleParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns
true if the value is successfully saved.

◆ saveIntParam()

bool saveIntParam | ( | const std::string | name,
 |  | int | param
 | ) |  |

Save a custom 'integer' parameter in the session file.

This can be useful for saving additional information that will be available to a CGI program later on in the same session. The value can be retrieved using getIntParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns
true if the value is successfully saved.

◆ saveLongParam()

bool saveLongParam | ( | const std::string | name,
 |  | long | param
 | ) |  |

Save a custom 'long integer' parameter in the session file.

This can be useful for saving additional information that will be available to a cgi program later on in the same session. The value can be retrieved using getLongParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns
true if the value is successfully saved.

◆ saveStringParam()

bool saveStringParam | ( | const std::string | name,
 |  | const std::string | param
 | ) |  |

Save a custom 'string' parameter in the session file.

This can be useful for saving additional information that will be available to a CGI program later on in the same session. The value can be retrieved using getStringParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns
true if the value is successfully saved.

◆ saveTimeParam()

bool saveTimeParam | ( | const std::string | name,
 |  | time_t | param
 | ) |  |

Save a custom 'time' parameter in the session file.

This can be useful for saving additional information that will be available to a cgi program later on in the same session. The value can be retrieved using getTimeParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns
true if the value is successfully saved.

◆ setPermittedTasks()

bool setPermittedTasks ( const matrix_science::ms_security_tasks & val )

Sets the permitted tasks for the currently logged in user.

This function is called by the administration utility so that it can save a list of tasks in a temporary session. It shouldn't normally be called by other applications.

Parameters
val is the 'list' of the tasks that can be performed by the user.
Returns
true if everything is valid and no error occurred, false otherwise
The documentation for this class was generated from the following files:
  • ms_security_session.hpp
  • ms_security_session.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_user Class Reference

  • matrix_science
  • ms_user
Public Types | Public Member Functions | List of all members
ms_user Class Reference
Mascot security and authentication module

This class will normally only be used by Mascot Security Administration applications. More...

#include <ms_security_user.hpp>

Public Types

enum systemids {
USERID_SECURITY_DISABLED = 0x0000 ,
USERID_GUEST = 0x0001 ,
USERID_ADMINISTRATOR = 0x0002 ,
USERID_CMDLINE = 0x0003 ,
USERID_DAEMON = 0x0004 ,
USERID_PUBLIC_SEARCHES = 0x0005 ,
USERID_INTEGRA_SYSTEM = 0x0006 ,
USERID_LAST = 0x0007
}
Definitions for predefined users. More...
enum usertype {
USER_SECURITY_DISABLED = 0x0000 ,
USER_NORMAL = 0x0001 ,
USER_INTEGRA = 0x0002 ,
USER_COMPUTER_NAME = 0x0003 ,
USER_IP_ADDRESS = 0x0004 ,
USER_AGENT_STRING = 0x0005 ,
USER_WEBAUTH = 0x0006
}
Definitions for types of user. More...

Public Member Functions

ms_user ()
Create a new 'empty' user with no name, password, ID.
ms_user (const int userID, const std::string userName, const std::string password, const long passwordExpiry, const std::string fullName, const std::string emailAddress, const usertype userType, const bool enabled)
Create a new user.
bool | clearParam (const std::string name)
Remove an additional user parameter associated with the user.
std::string | getEmailAddress () const
Returns the email address of the user.
std::string | getEncryptedPassword () const
Returns the encrypted password.
std::string | getFullName () const
Return the full user name.
int | getID () const
Return the unique user ID.
std::string | getName () const
Return the user login name.
time_t | getPasswordExpiry () const
Returns the time that the password will expire.
std::string | getStringParam (const std::string name) const
Return a custom parameter for the user.
bool | getStringParam (const std::string name, std::string &param) const
Return a custom parameter for the user.
usertype | getUserType () const
Return the 'type' of user.
bool | hasPasswordExpired () const
Returns true if the password has expired.
bool | isAccountEnabled () const
Return true if the account is enabled.
bool | saveStringParam (const std::string name, const std::string param)
Save an additional 'string' parameter for the user.
void | setAccountEnabled (bool newVal)
Pass true to enable the account.
void | setEmailAddress (std::string newVal)
Sets the email address of the user.
void | setEncryptedPassword (std::string newVal)
Update the encrypted password - details are saved immediately.
void | setFullName (std::string newVal)
Update the full user name – details are saved immediately.
void | setID (int newVal)
Set the unique user ID.
void | setName (std::string newVal)
Set the user login name.
void | setPassword (std::string barePassword)
Encrypt and save the passed password.
void | setPasswordExpiry (time_t newVal)
Set the password expiry time.
void | setUserType (usertype newVal)
Update the user type – details are saved immediately.
bool | validatePassword (const std::string pwd, int &errorFlag) const
Checks to see if the password is correct for the user.

Detailed Description

This class will normally only be used by Mascot Security Administration applications.

Call ms_security::addNewUser() to create a new user or ms_security::getUser() or ms_security::getUserFromID() to get an existing user, and then use the ms_user member functions to query or modify the ms_user object.

To make the changes permanent, use ms_security::updateUser().

Member Enumeration Documentation

◆ systemids

enum systemids

Definitions for predefined users.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
USERID_SECURITY_DISABLED

Only valid if security is disabled.

USERID_GUEST

The built in guest user. Note that this accound is disabled by default.

USERID_ADMINISTRATOR

The built in administrator account. Cannot be deleted or disabled.

USERID_CMDLINE

Applications run from the command line rather than as a cgi application use this by default.

USERID_DAEMON

Mascot Daemon will use this user to run searches.

USERID_PUBLIC_SEARCHES

Example files use this user id. matrix_science::ms_session::canResultsFileBeViewed always returns true for this ID.

USERID_INTEGRA_SYSTEM
Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.
USERID_LAST

Placeholder.

◆ usertype

enum usertype

Definitions for types of user.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
USER_SECURITY_DISABLED

Not a real user, but the USERID if security is disabled.

USER_NORMAL

A 'normal' Mascot user, that doesn't fit into any of the other categories below.

USER_INTEGRA
Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later. Login etc. is done through Mascot Insight.
USER_COMPUTER_NAME

This type of user is defined by a computer name. Should only be used for 3rd party applications.

USER_IP_ADDRESS

This type of user is defined by an IP address. Should only be used for 3rd party applications.

USER_AGENT_STRING

This type of user is defined by a client agent string. Should only be used for 3rd party applications as a last resort.

USER_WEBAUTH

The configuration is to use web server authentication, so this user has no password.

Member Function Documentation

◆ clearParam()

bool clearParam ( const std::string name )

Remove an additional user parameter associated with the user.

Additional custom data for a user are saved in a <mss:custom_parameters> section in the user.xml file.

Use this function when you no longer want a value associated with a key name for a user.

To make the changes permanent, use ms_security::updateUser().

See also Using custom parameters

Parameters
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns
boolean value to indicate if the value was successfully removed.

◆ getEmailAddress()

std::string getEmailAddress ( ) const

Returns the email address of the user.

This is not a required field, which means the return value may be the empty string.

Returns
email address

◆ getEncryptedPassword()

std::string getEncryptedPassword ( ) const

Returns the encrypted password.

Unlikely to be useful for most applications. It is not possible to retrieve the unencrypted password from the system, and the value returned from this function will not be the same as the value passed to ms_user::setPassword().

Returns
The encrypted password.

◆ getFullName()

std::string getFullName ( ) const

Return the full user name.

Useful for displaying the full name in reports etc.

Returns
The current full (long) user name.

◆ getID()

int getID ( ) const

Return the unique user ID.

The unique user ID for the user. This should never be changed, since all searches are saved with the USERID equal to this value. Special user IDs are the same as the values in ms_user::systemids.

Returns
The current user ID.

◆ getPasswordExpiry()

time_t getPasswordExpiry ( ) const

Returns the time that the password will expire.

The time in seconds since January 1st 1970. A value of '0'is used to indicate that the password should never expire.

Returns
The current password expiry date.

◆ getStringParam() [1/2]

std::string getStringParam ( const std::string name ) const

Return a custom parameter for the user.

Additional custom data for a user are saved in a <mss:custom_parameters> section in the user.xml file.

If an empty string is returned, it is not possible to determine if this is because there is no key value or if an empty string was set for the key.

See also
saveStringParam()

See also Using custom parameters

Parameters
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns
Is the value of the parameter associated with the key name or an empty string if there is no key.

◆ getStringParam() [2/2]

bool getStringParam | ( | const std::string | name,
 |  | std::string & | param
 | ) |  | const

Return a custom parameter for the user.

Additional custom data for a user are saved in a <mss:custom_parameters> section in the user.xml file.

Note
This function should not be used from programming languages other than C++. Use getStringParam(const std::string) const instead.
See also
saveStringParam()

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns
boolean value to indicate if the value was successfully retrieved.

◆ getUserType()

ms_user::usertype getUserType ( ) const

Return the 'type' of user.

See also
ms_user::setUserType().
Returns
user type

◆ hasPasswordExpired()

bool hasPasswordExpired ( ) const

Returns true if the password has expired.

If the password expiry value is zero, the password will never expire. An expiry value of 1 may be used to indicate that the user should change their password when they first log in.

Returns
True if the password has expired.

◆ saveStringParam()

bool saveStringParam | ( | const std::string | name,
 |  | const std::string | param
 | ) |  |

Save an additional 'string' parameter for the user.

Additional custom data for a user are saved in a <mss:custom_parameters> section in the user.xml file.

The value can be retrieved using getStringParam().

To make the changes permanent, use ms_security::updateUser().

See also Using custom parameters

Parameters
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns
true if the value is successfully saved.

◆ setAccountEnabled()

void setAccountEnabled ( bool newVal )

Pass true to enable the account.

To make the changes permanent, use ms_security::updateUser().

Parameters
newVal Set to true to enable the account, and false to disable the account.

◆ setEmailAddress()

void setEmailAddress ( std::string newVal )

Sets the email address of the user.

To make the changes permanent, use ms_security::updateUser().

Parameters
newVal is the new email address of the user.

◆ setFullName()

void setFullName ( std::string newVal )

Update the full user name – details are saved immediately.

Useful for displaying the full name in reports etc.

To make the changes permanent, use ms_security::updateUser().

Parameters
newVal is the new full (long) name for the user.

◆ setID()

void setID ( int newVal )

Set the unique user ID.

The unique user ID for the user. This should never be changed, since all searches are saved with the USERID equal to this value. Special user IDs are the same as the values in ms_user::systemids.

To make the changes permanent, use ms_security::updateUser().

Parameters
newVal is the new user ID.

◆ setName()

void setName ( std::string newVal )

Set the user login name.

The login name for a user. It is safe to change this for an existing user (as long as the user ID is not changed).

To make the changes permanent, use ms_security::updateUser().

Parameters
newVal is the new login name for the user.

◆ setPasswordExpiry()

void setPasswordExpiry ( time_t newVal )

Set the password expiry time.

The time in seconds since January 1st 1970. A value of '0' is used to indicate that the password should never expire.

To make the changes permanent, use ms_security::updateUser().

Parameters
newVal Is the new date for the password expiry.

◆ setUserType()

void setUserType ( ms_user::usertype newVal )

Update the user type – details are saved immediately.

See ms_user::ms_user for restrictions on setting the user type. To make the changes permanent, use ms_security::updateUser().

See also
ms_user::setUserType()
Parameters
newVal is the new user type.

◆ validatePassword()

bool validatePassword | ( | const std::string | pwd,
 |  | int & | errorFlag
 | ) |  | const

Checks to see if the password is correct for the user.

Parameters
pwd | is the the unencrypted password to be checked against the encrypted password saved in the user's file.
errorFlag | will contain 0 if the function returns true. If the function returns false, then a value of 1 indicates an incorrect password and a value of 2 indicates an internal problem with the seed value.
Returns
Will return true if the password is correct, or if there is no saved password.
The documentation for this class was generated from the following files:
  • ms_security_user.hpp
  • ms_security_user.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Mascot utilities and tools module

Modules | Namespaces | Classes
Mascot utilities and tools module

Modules

Examples for the Mascot tools module
Spectral library Classes

Namespaces

namespace matrix_science::ms_spectral_lib

Classes

class | ms_fileutilities
This utility class mainly contains static members. More...
class | ms_imputation
class | ms_imputation_average_value
class | ms_imputation_fixed_value
class | ms_imputation_knn
class | ms_imputation_method
class | ms_imputation_missforest
class | ms_imputation_peptide_data
class | ms_matrix
A two-dimensional matrix of numbers. More...
class | ms_spectral_lib_entry
This class is used to encapsulate a single entry, i.e. single spectrum from a NIST .msp file or SpectraST .sptxt file. More...
class | ms_spectral_lib_file
This class is used to encapsulate a complete NIST .msp, SpectraST .sptxt or X!Hunter ASL MGF file. More...
class | ms_spectral_lib_peak
This class is used to encapsulate a single fragment ion in a NIST .msp or a SpectraST .sptxt file. More...
class | ms_spectral_lib_peak_list
This class is used to encapsulate a peak list from a single spectrum in a NIST .msp or a SpectraST .sptxt file. More...
class | ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokarev. More...
class | ms_treecluster
This class is an interface to the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/. More...
class | ms_zip
Utility class for compressing and decompressing data in compress format, and compressing in gzip format. More...

Detailed Description

Tools for creating CDB files, zipping files, file manipulation and clustering

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Examples for the Mascot tools module

Examples for the Mascot tools module
Mascot utilities and tools module

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
For using ms_zip streaming compression | tools_ms_zip.pl |  |  |  |
For using the tinycdb index files | tools_tinycdb.pl |  |  | tools_tinycdb.py | tools_tinycdb.cs
For using the ms_treecluster class | tools_treecluster.pl |  |  | tools_treecluster.py | tools_treecluster.cs
For using the ms_imputation class |  |  |  |  | tools_imputation.cs
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Spectral library Classes

Spectral library Classes
Mascot utilities and tools module

Classes for reading and writing spectral libraries

Mascot 2.6 and later support searching spectral libraries in parallel with a FASTA database.

See: Spectral library search on the Matrix Science public web site for an overview.

For help on reading spectral library results from Mascot Results files, see Spectral libraries

The classes described in this section are used for reading, parsing and writing spectral library files. These classes are not used for performing the library search, which is done by third party tools.

ms_spectral_lib_file is used to open and read a spectral library. The third parameter is used to specify whether to use and create an index file which will improve performance with searching for particular spectra within the library. See ms_spectral_lib_file::findEntries for details of how to lookup entries in the library.

When a spectral library is added to Mascot Server for searching, it converts the library to the NIST format using: ms_spectral_lib_file::saveAs function. It also sets the replaceProteinName parameter to 'true'. Mascot Server saves the spectrum peaklist checksum in results files so that the findEntries function can be used to lookup the spectrum reliably.

ms_spectral_lib_file::getEntryFromNumber can be used to return one ms_spectral_lib_entry object

Supported Spectral Library Formats

Mascot Parser Supports the following formats:

The NIST MSP format

The National Institute of Standards and Technology, NIST in the United States provides a number of libraries to be used with their search tool, MSPepSearch. They provide libraries in a binary format, and also in a text 'MSP' format. Mascot Parser can read and write libraries in MSP format. The format is documented here.

PRIDE files are essentially .msp files, but without any peak annotation. When the file is saved in NIST format, a "?" is added as peak annotation otherwise MSPepSearch can fail to find matches.

The ISB SpectraST format

These files typically have a .sptxt extension. The format is slightly different from the NIST MSP format. There are some details here.

  • The Name field can include a modification delta, for example: Name: K.AADQADESSPLLS[167]PS[167]NSNHPSEHPQQDLNNK.S/4
  • The PeakList entries are a slightly different format.
  • The line specifying the number of peaks is Num peaks: in an MSP file, but NumPeaks: in a SpectraST file.
  • There are normally comment lines at the top of the file.

X! Hunter Annotated Spectrum Library (ASL)

The format is described here

These files are converted to NIST MSP format before being submitted to MSPepSearch.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: matrix_science::ms_spectral_lib Namespace Reference

  • matrix_science
  • ms_spectral_lib
Enumerations
matrix_science::ms_spectral_lib Namespace Reference
Mascot utilities and tools module

Enumerations

enum FILE_FORMAT {
FORMAT_UNKNOWN ,
FORMAT_NIST_MSP ,
FORMAT_SPECTRAST ,
FORMAT_MGF ,
FORMAT_XHUNTER
}

Detailed Description

The ms_spectral_lib namespace currently just contains one enum used for the ms_spectral_lib_xxx classes

Enumeration Type Documentation

◆ FILE_FORMAT

enum FILE_FORMAT

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Spectral libraries are available in a number of formats. All the formats obviously have m/z and intensity and intensity pairs, but there are different annotation formats, and different header formats.

Enumerator
FORMAT_UNKNOWN | Unknown format.
FORMAT_NIST_MSP | NIST MSP formt.
FORMAT_SPECTRAST | Institute for Systems Biology (ISB) SpectraST format.
FORMAT_MGF | Mascot Generic Format. Only suitable for output.
FORMAT_XHUNTER | X!HUNTER ASL MGF file format (2007.06.01)
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fileutilities Class Reference

  • matrix_science
  • ms_fileutilities
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_fileutilities Class Reference
Mascot utilities and tools module

This utility class mainly contains static members. More...

#include <ms_fileutilities.hpp>

Public Types

enum CMD_ARGUMENT_PARSE_RESULT {
CMD_ARGUMENT_PARSE_OK = 0 ,
CMD_ARGUMENT_PARSE_UNBALANCED = -1 ,
CMD_ARGUMENT_PARSE_COLLISION = -2 ,
CMD_ARGUMENT_PARSE_INVALIDCHAR = -3
}
Return status from parseCommandLineArgumentString(). More...
enum compareXMLFiles_flags {
CMPXML_NO_FLAG = 0x0000 ,
CMPXML_IGN_DBL_IDENTICAL = 0x0001 ,
CMPXML_IGN_DBL_DIFF_100_PPM = 0x0002 ,
CMPXML_IGN_DBL_DIFF_10_PPM = 0x0004 ,
CMPXML_IGN_DBL_DIFF_1_PPM = 0x0008 ,
CMPXML_IGN_DBL_MASK = (CMPXML_IGN_DBL_IDENTICAL | CMPXML_IGN_DBL_DIFF_100_PPM | CMPXML_IGN_DBL_DIFF_10_PPM | CMPXML_IGN_DBL_DIFF_1_PPM) ,
CMPXML_STRIP_TRAILING_ZEROS = 0x0010 ,
CMPXML_IGN_COL_SIZE_EQ_ONE = 0x0020 ,
CMPXML_IGN_TODAY_DATE = 0x0040 ,
CMPXML_IGN_INF_999999 = 0x0080 ,
CMPXML_IGN_FILE_URL = 0x0100 ,
CMPXML_IGN_RAWFILE_NAME = 0x0200
}
Flags for the compareXmlFiles() function. More...
enum err_sar {
SAR_SUCCESS ,
SAR_FAIL_CHMOD ,
SAR_FAIL_GET_NAMED_SECURITY_INFO ,
SAR_FAIL_SET_ENTRIES_IN_ACL ,
SAR_FAIL_SET_NAMED_SECURITY_INFO ,
SAR_FAIL_CHOWN
}
setAccessRights() return value. More...

Public Member Functions

ms_fileutilities ()
Default constructor.
void | findClose ()
Functions to search for all files that match a wildcard.
bool | findNext (std::string &fileName)
Functions to search for all files that match a wildcard.
bool | findOpen (const std::string directory, const std::string wildcard)
Functions to search for all files that match a wildcard.
unsigned long | getSARExtendedErrorCode () const
err_sar | setAccessRights (const char *filename, const bool bWrite, const bool bExecute, const bool isFile, const ms_mascotoptions &Options, const bool avoid_reapply=false)
Sets access rights for a file according to settings in mascot.dat.

Static Public Member Functions

static bool | compareXmlFiles (const std::string &filePath1, const std::string &filePath2, const std::string &schemaPath, const int flags, const std::vector< std::string > &ignoreElements, const std::vector< std::string > &ignoreAttributes, ms_errs &errs, std::string &differences, std::string &lhsOnly, std::string &rhsOnly)
Compare 2 XML files.
static int | createDirectory (const std::string &directory, std::string &errorDirectory)
Create a directory or directory tree.
static int | deleteDirectory (const std::string &directory, const bool bDeleteSubdirectories=true)
Delete a directory or directory tree.
static bool | doesFileExist (const char *filename)
Returns true if the specified file exists, false otherwise.
static std::string | findMascotDat (const char *szMascotDatFilename, ms_errs *err=NULL, const int timeoutSec=0)
Returns a correct path to mascot.dat if it can be found in one of the default places.
static UINT64 | getFileSize (const char *filename, ms_errs *err=NULL)
Returns the size of the file.
static time_t | getLastModificationTime (const char *filename, ms_errs *err=NULL)
Returns the last file modification time.
static std::string | getMD5Sum (const std::string &str, const bool b32bitEncoding=true)
Return an MD5 sum of a string.
static bool | isDirectory (const char *path)
Determine if the passed path is a directory or a file.
static bool | isFileWritable (const char *filePath)
static int | parseCommandLineArgumentString (const std::string &command, std::vector< std::string > &components)
Split a command-line argument string into components.
static void | setLastModificationTime (const char *filename, time_t modificationTime, ms_errs *err=NULL)
Sets the last file modification time.
static std::string | stripLastFolder (const std::string pathname)
Returns a pathname without last token, i.e. makes "C:\myfolder" from "C:\myfolder\XXX".

Detailed Description

This utility class mainly contains static members.

For static members, creating an instance of this class is not required.

See Static functions in Perl, Java, Python and C#

Member Enumeration Documentation

◆ CMD_ARGUMENT_PARSE_RESULT

enum CMD_ARGUMENT_PARSE_RESULT

Return status from parseCommandLineArgumentString().

Enumerator
CMD_ARGUMENT_PARSE_OK | Command line parsed successfully.
CMD_ARGUMENT_PARSE_UNBALANCED | Command line contains an unbalanced quote.
CMD_ARGUMENT_PARSE_COLLISION | Command line contains a starting (ending) quote preceded (followed) by a non-whitespace character.
CMD_ARGUMENT_PARSE_INVALIDCHAR | Command line contains invalid characters, such as linebreaks.

◆ compareXMLFiles_flags

enum compareXMLFiles_flags

Flags for the compareXmlFiles() function.

Enumerator
CMPXML_NO_FLAG | No specific options.
CMPXML_IGN_DBL_IDENTICAL | For example 0.2000 and 0.2 would be considered identical if the schema type for the value is double.
CMPXML_IGN_DBL_DIFF_100_PPM | Ignore differences of 100 ppm (1/10,000) between floating point values if the schema type for the value is double.
CMPXML_IGN_DBL_DIFF_10_PPM | Ignore differences of 10 ppm (1/100,000) between floating point values if the schema type for the value is double.
CMPXML_IGN_DBL_DIFF_1_PPM | Ignore differences of 1 ppm (1/1,000,000) between floating point values if the schema type for the value is double.
CMPXML_STRIP_TRAILING_ZEROS | For example 0.2000 and 0.2 would be considered identical even if the schema type is not double
CMPXML_IGN_COL_SIZE_EQ_ONE | For distiller_quantitation_2 where Distiller 2.7 has zero rows (and hence zero columns) but records: <calcMoverZ col_size="1" row_size="0"/>
CMPXML_IGN_TODAY_DATE | If the XML has todays date, it's likely that it won't compare with when the baseline was written. Date is of the form val="Wed Apr 18 16:06:24 2018".
CMPXML_IGN_INF_999999 | Double values of "INF" and "999999999999999970000000000000000000000000000000000000000000000000000000000000000000000000000000000.000000" will compare.
CMPXML_IGN_FILE_URL | Text strings starting with "file:///" will ignore directory differences and only compare the filename part. For example: "file:///c:/tmp/filename.txt" will compare OK with "file:///server/mytestdir/tmp/filename.txt" but not with "file:///c:/tmp/AnotherFile.txt".
CMPXML_IGN_RAWFILE_NAME | Text strings for an attribute named "val" in element "info" which has parent element "rawfile" will ignore directory differences and only compare the filename part. For example: val="e:%5cbuildserver%5cfilename.wiff" will compare OK with val="C:%5cbackedup%5cgit%5cfilename.wiff".

◆ err_sar

enum err_sar

setAccessRights() return value.

Enumerator
SAR_SUCCESS | Success!
SAR_FAIL_CHMOD | Error returned by call to chmod().
SAR_FAIL_GET_NAMED_SECURITY_INFO | Error returned by call to GetNamedSecurityInfo().
SAR_FAIL_SET_ENTRIES_IN_ACL | Error returned by call to SetEntriesInAcl().
SAR_FAIL_SET_NAMED_SECURITY_INFO | Error returned by call to SetNamedSecurityInfo().
SAR_FAIL_CHOWN | Error returned by call to chown().

Constructor & Destructor Documentation

◆ ms_fileutilities()

ms_fileutilities ( )

Default constructor.

Creating an instance of this class is not required.

Member Function Documentation

◆ compareXmlFiles()

bool compareXmlFiles | ( | const std::string & | filePath1,
 |  | const std::string & | filePath2,
 |  | const std::string & | schemaPath,
 |  | const int | flags,
 |  | const std::vector< std::string > & | ignoreElements,
 |  | const std::vector< std::string > & | ignoreAttributes,
 |  | ms_errs & | errs,
 |  | std::string & | differences,
 |  | std::string & | lhsOnly,
 |  | std::string & | rhsOnly
 | ) |  |
static

Compare 2 XML files.

See Multiple return values in Perl, Java, Python and C#.

Warning
if a relative path for the xsd is specified, then this will be relative to the documents and not relative to the current working directory. This means that if the files to be compared are in different directories, then absolute path(s) will be required in the schemaPath
Parameters
[in] | filePath1 | is the path for the first (or left) file.
[in] | filePath2 | is the path for the first (or right) file.
[in] | schemaPath | must be valid and must have space separated pairs of "namespace" "path_to_xsd". See the example in ms_mascotresfilebase::setXMLschemaFilePath.
[in] | flags | is one or more ms_fileutilities::compareXMLFiles_flags bitwise OR'd together.
[in] | ignoreElements | is a vector of element names for which the element values will be ignored. Any attributes and child elements for the specified elements will still be compared. The full path to the element should be specified, e.g. "<quantitationResults><peptideMatch><partner><xic><intensity>" See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#
[in] | ignoreAttributes | is a vector of string of attribute names to be ignored in the comparison. If a value contains an '=', then it will only be ignored if the attribute (in either file) is equal to the specified value. For example, 'minorVersion' would ignore all 'minorVersion' attributes, but 'minorVersion="2"' will only ignore if either side has a value of "2" See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#
[out] | errs | is used to return a list of any XML parsing errors
[out] | differences | is used to return a list of attribute and value differences for elements that appear in both input files.
[out] | lhsOnly | is used to return a list of elements that only appear in file1
[out] | rhsOnly | is used to return a list of elements that only appear in file2
Returns
true if the files could be read and validated against the schema file

◆ createDirectory()

int createDirectory | ( | const std::string & | directory,
 |  | std::string & | errorDirectory
 | ) |  |
static

Create a directory or directory tree.

See Static functions in Perl, Java, Python and C#

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | directory | is the path of the directory to be created.
[out] | errorDirectory | is the path of the first directory that it fails to create if the function fails.
Returns
0 for success, or errno if there is an error.

◆ deleteDirectory()

int deleteDirectory | ( | const std::string & | directory,
 |  | const bool | bDeleteSubdirectories = true
 | ) |  |
static

Delete a directory or directory tree.

See Static functions in Perl, Java, Python and C#

Deletes the contents and subdirectories of a tree.

Parameters
[in] | directory | is the path of the directory to be deleted.
[in] | bDeleteSubdirectories | is a flag to specify if subdirectories should be deleted
Returns
0 for success, or errno/Windows Error code if there is an error.

◆ doesFileExist()

bool doesFileExist ( const char * filename )
static

Returns true if the specified file exists, false otherwise.

See Static functions in Perl, Java, Python and C#

Parameters
filename is the file to check
Returns
true if file exists

◆ findClose()

void findClose ( )

Functions to search for all files that match a wildcard.

To use findOpen(), findNext() and findClose() :

  • Create an ms_fileutilities object.
  • Call findOpen() and check return value.
  • Call findNext() repeatedly until it returns false.
  • Call findClose()

These functions cannot currently be called from any language apart from C++

Do not call findOpen() for a second directory on any ms_fileutilities object until findClose() has been called for the first directory.

◆ findMascotDat()

std::string findMascotDat | ( | const char * | szMascotDatFilename,
 |  | ms_errs * | err = NULL,
 |  | const int | timeout = 0
 | ) |  |
static

Returns a correct path to mascot.dat if it can be found in one of the default places.

See Static functions in Perl, Java, Python and C#

Parameters
szMascotDatFilename | is an optional filename. If an empty string or a null pointer is passed, default values are used depending on the platform.
err | is a pointer to an error object which can be used to return detailed errors. See Passing objects to functions in Perl, Java, Python and C#
timeout | is the time in seconds to look for the file. If the file is being edited, it may not exist for a short period, so rather than erroring, this function will wait.
Returns
path to file mascot.dat

◆ findNext()

bool findNext ( std::string & fileName )

Functions to search for all files that match a wildcard.

To use findOpen(), findNext() and findClose() :

  • Create an ms_fileutilities object.
  • Call findOpen() and check return value.
  • Call findNext() repeatedly until it returns false.
  • Call findClose()

These functions cannot currently be called from any language apart from C++

Do not call findOpen() for a second directory on any ms_fileutilities object until findClose() has been called for the first directory.

Parameters
fileName is the name of the found file.
Returns
true if a file was found.

◆ findOpen()

bool findOpen | ( | const std::string | directory,
 |  | const std::string | wildcard
 | ) |  |

Functions to search for all files that match a wildcard.

To use findOpen(), findNext() and findClose() :

  • Create an ms_fileutilities object.
  • Call findOpen() and check return value.
  • Call findNext() repeatedly until it returns false.
  • Call findClose()

These functions cannot currently be called from any language apart from C++

Do not call findOpen() for a second directory on any ms_fileutilities object until findClose() has been called for the first directory.

Parameters
directory | is the directory to find files.
wildcard | is a wildcard pattern. For example "*.dat".
Returns
true if the function succeeds

◆ getFileSize()

UINT64 getFileSize | ( | const char * | filename,
 |  | ms_errs * | err = NULL
 | ) |  |
static

Returns the size of the file.

See Static functions in Perl, Java, Python and C#

Parameters
filename | is the relative or absolute path to the file
err | is a pointer to an optional error object which can be used to return detailed errors. See Passing objects to functions in Perl, Java, Python and C#
Returns
0 if the function fails

◆ getLastModificationTime()

time_t getLastModificationTime | ( | const char * | filename,
 |  | ms_errs * | err = NULL
 | ) |  |
static

Returns the last file modification time.

See Static functions in Perl, Java, Python and C#

Parameters
filename | is the relative or absolute path to the file
err | is a pointer to an optional error object which can be used to return detailed errors. See Passing objects to functions in Perl, Java, Python and C#
Returns
0 if the function fails

◆ getMD5Sum()

std::string getMD5Sum | ( | const std::string & | str,
 |  | const bool | b32bitEncoding = true
 | ) |  |
static

Return an MD5 sum of a string.

See Static functions in Perl, Java, Python and C#

Useful for creating a unique filename from, for example, a long pathname or a set of options.

For 64 bit encoding the returned text is base 64 Encoded with a URL and Filename Safe Alphabet; see http://tools.ietf.org/html/rfc3548#section-4.

For 32 bit encoding, the returned text is base 32 bit encoded (except that lower case rather than upper case letters are used); see http://tools.ietf.org/html/rfc3548#section-5.

Parameters
str | is the string (of any length) than needs to be converted. If a zero length string is passed, a zero length string will be returned.
b32bitEncoding | should be set to true to give 32 bit encoded string (essential for file systems where an upper case filename and a lower case filename are considered to be the same. If this value is false, then 64 bit encoding is used.
Returns
the MD5 sum of the string.

◆ getSARExtendedErrorCode()

unsigned long getSARExtendedErrorCode ( ) const

This can be called if setAccessRights() returns one of the following:

  • SAR_FAIL_GET_NAMED_SECURITY_INFO
  • SAR_FAIL_SET_ENTRIES_IN_ACL
  • SAR_FAIL_SET_NAMED_SECURITY_INFO

The value will be zero for any other errors and is used to return an error code for Windows only.

Returns
An optional extra errorCode if setAccessRights failed.

◆ isDirectory()

bool isDirectory ( const char * path )
static

Determine if the passed path is a directory or a file.

See Static functions in Perl, Java, Python and C#

Parameters
path Path to a directory or file
Returns
True if the path specifies a directory, otherwise returns false. If the path doesn't exist, the function will also return false.

◆ isFileWritable()

bool isFileWritable ( const char * filePath )
static

See Static functions in Perl, Java, Python and C#

Parameters
filePath is the file to check
Returns
true if the file is writable

◆ parseCommandLineArgumentString()

int parseCommandLineArgumentString | ( | const std::string & | command,
 |  | std::vector< std::string > & | components
 | ) |  |
static

Split a command-line argument string into components.

A command-line argument string consists of an executable name or filepath followed by a list of zero or more arguments. The executable and arguments are separated by one or more whitespace character. Here are some examples at increasing levels of complexity:

  dir
  cd "C:/Program Files"
  "C:/Program Files/Perl64/bin/perl.exe" C:/inetpub/mascot/bin/dbman_download.pl SwissProt

Any of the components can include spaces, including the executable name; in this case, the component with spaces must be delimited by quotes ("). If the command string does include quotes, the quotes must be balanced, in the sense that an opening quote must follow a closing quote. Further, an opening quote must be preceded by whitespace and a closing quote followed by whitespace. Otherwise the method indicates a syntax error (as such strings are ambiguous). This means the following are all syntax errors and cause the method to return a non-OK status:

   "dir
   cd"C:/Program Files"
   "C:/Program Files/Perl64/bin/perl.exe"C:/inetpub/mascot/bin/dbman_download.pl SwissProt

Note that any of the components, including the executable name, can be the empty string, e.g.

   dir ""
   "" SwissProt

You need to check each item in components before processing further, even if the command string is parsed without error.

If you pass in the empty string in command, you will get an OK status and an empty vector out.

This method does not interpret the components in any way. In particular, it does not check that the first component is an executable filepath or that it exists on disk.

Parameters
command | The command-line style string.
components | Components parsed from command, with quotes stripped out.
Returns
Status indicating success or failure, one of ms_fileutilities::CMD_ARGUMENT_PARSE_RESULT.

◆ setAccessRights()

ms_fileutilities::err_sar setAccessRights | ( | const char * | filename,
 |  | const bool | bWrite,
 |  | const bool | bExecute,
 |  | const bool | bIsFile,
 |  | const ms_mascotoptions & | Options,
 |  | const bool | avoid_reapply = false
 | ) |  |

Sets access rights for a file according to settings in mascot.dat.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Windows:

The bWrite flag is ignored.

The bExecute flag is ignored.

  • Always does a chmod(filename, _S_IREAD | _S_IWRITE)
  • If the filename is a directory, and this is running on NT4, nothing further is done
  • A security descriptor is constructed using the name specified by ms_mascotoptions::getNTIUserGroup() With NT4, Service Pack 4, it isn't possible to add a group to existing groups Q242510, so in this case only, the existing security is replaced with the NTIUserGroup name and the name specified by ms_mascotoptions::getNTMonitorGroup()
  • For a memory mapped object (where bIsFile is false), STANDARD_RIGHTS_ALL | SPECIFIC_RIGHTS_ALL are added to the current rights for the group specified above.
  • For a file or directory (where bIsFile is true), FILE_ALL_ACCESS rights are added to the current rights for the group specified above.

Unix:

The bIsFile parameter is ignored.

If the filename passed is for a file rather than a directory, then chmod is called with the following flags:

  • S_IRUSR (Read access for user)
  • S_IWUSR (Write access for user)
  • S_IXUSR (Execute access for user) - but only if the bExecute flag is set
  • S_IRGRP (Read access for group)
  • S_IWGRP (Write access for group) - but only if the bWrite flag is set
  • S_IXGRP (Execute access for group) - but only if the bExecute flag is set
  • S_IROTH (Read access for others) - but only if ms_mascotoptions::getUnixWebUserGroup() is -1
  • S_IWOTH (Write access for others) - but only if ms_mascotoptions::getUnixWebUserGroup() is -1 and if the bWrite flag is set
  • S_IXOTH (Execute access for others) - but only if ms_mascotoptions::getUnixWebUserGroup() is -1 and if the bExecute flag is set

If the filename passed is for a directory, then chmod is called with the flags above unless ms_mascotoptions::getUnixDirPerm() is defined, in which case the permission used are defined by that entry in mascot.dat.

If ms_mascotoptions::getUnixWebUserGroup() is not -1 and is not -2, then a chown will be performed using the group id specified by ms_mascotoptions::getUnixWebUserGroup().

Parameters
filename | is the name of the file, or memory mapped object that will be changed by this function.
bWrite | should be set to true if the file should be set to be writeable by the group and others.
bExecute | should be set to true for executable files or directories.
bIsFile | should be set to true for files and directories, and false for for memory mapped file objects.
Options | is the options section of mascot.dat.
avoid_reapply | should be set to true if it should avoid applying the rights if the files already have the desired access configuration. Windows only, false by default.
Returns
Will return SAR_SUCCESS if it succeeds. See also getSARExtendedErrorCode().

◆ setLastModificationTime()

void setLastModificationTime | ( | const char * | filename,
 |  | time_t | modificationTime,
 |  | ms_errs * | err = NULL
 | ) |  |
static

Sets the last file modification time.

See Static functions in Perl, Java, Python and C#

Parameters
filename | is the relative or absolute path to the file
modificationTime | is the time to be applied as the file's last write time
err | is a pointer to an optional error object which can be used to return detailed errors. See Passing objects to functions in Perl, Java, Python and C#

◆ stripLastFolder()

std::string stripLastFolder ( const std::string pathname )
static

Returns a pathname without last token, i.e. makes "C:\myfolder" from "C:\myfolder\XXX".

See Static functions in Perl, Java, Python and C#

Parameters
pathname of the filepath to strip.
Returns
stripped folder name
The documentation for this class was generated from the following files:
  • ms_fileutilities.hpp
  • ms_fileutilities.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_imputation Class Reference

  • matrix_science
  • ms_imputation
Public Types | Public Member Functions | List of all members
ms_imputation Class Reference
Mascot utilities and tools module

#include <ms_imputation.hpp>

Inheritance diagram for ms_imputation:
[legend]
Collaboration diagram for ms_imputation:
[legend]

Public Types

enum IMPUTATION_VARIABLE {
IMPUTE_PROTEIN_RATIO ,
IMPUTE_PEPTIDE_RATIO ,
IMPUTE_RETENTION_TIME
}
What type of data is being imputed. More...

Public Member Functions

ms_imputation (const ms_ms1quantitation *ms1quantitation, ms_imputation_method &m, IMPUTATION_VARIABLE imputationVariableChoice)
Use this contructor to create an object to impute missing ms1 ratio values.
ms_imputation (const ms_ms2quantitation *ms2quantitation, ms_imputation_method &m, IMPUTATION_VARIABLE imputationVariableChoice)
Use this contructor to create an object to impute missing ms2 ratio values.
~ms_imputation ()
Imputation Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
const IMPUTATION_VARIABLE | getImputationVariableChoice () const
Get what the imputation object is currently imputing. I.e. protein/peptide ratios from ms1 or ms2 quantitation, or retention times for label free quantitation.
bool | getImputeExcludedMs2PeptideRatios ()
Get how the imputation object is currently treating ms2 excluded ratios. I.e. are excluded ratios treated as missing. Not used when imputing ms1 quantitation results.
bool | getImputeMs1PeptideExcludedByCorrelationThr ()
Get how the imputation object is currently treating ms1 peptide ratios excluded because of the fraction threshold. Not used when imputing ms2 quantitation results.
bool | getImputeMs1PeptideExcludedByFractionThr ()
Get how the imputation object is currently treating ms1 peptide ratios excluded because of the fraction threshold. Not used when imputing ms2 quantitation results.
bool | getImputeMs1PeptideExcludedByStdErrThr ()
Get how the imputation object is currently treating ms1 peptide ratios excluded because of the std err threshold. Not used when imputing ms2 quantitation results.
bool | getImputeMs1PeptideNegativeRatio ()
Get how the imputation object is currently treating negative ms1 peptide ratios. Not used when imputing ms2 quantitation results.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::vector< std::vector< double > > | impute ()
Returns a 2D (m,n) array of doubles. m is the number of variables, implemented so far is quantitation ratios or subprojects n is the number of observations, implemented so far is the number of protein or peptides.
bool | isValid () const
Call this function to determine if there have been any errors.
void | setImputationVariableChoice (const IMPUTATION_VARIABLE imputationVariableChoiceIn)
Set the imputation object to impute protein/peptide ratios from ms1 or ms2 quantitation, or retention times for label free quantitation.
void | setImputeExcludedMs2PeptideRatios (bool imputationMs2PeptideChoiceIn)
Set the imputation object to treat excluded ms2 ratios as missing Not used when imputing ms1 quantitation results.
void | setImputeMs1PeptideExcludedByCorrelationThr (bool imputeMs1PeptideExcludedByCorrelationThr)
Set the imputation object behaviour of ms1 peptide ratios excluded because of the fraction threshold. Not used when imputing ms2 quantitation results.
void | setImputeMs1PeptideExcludedByFractionThr (bool imputeMs1PeptideExcludedByFractionThr)
Set the imputation object behaviour of ms1 peptide ratios excluded because of the fraction threshold. Not used when imputing ms2 quantitation results.
void | setImputeMs1PeptideExcludedByStdErrThr (bool imputeMs1PeptideExcludedByStdErrThr)
Set the imputation object behaviour of ms1 peptide ratios excluded because of the std err threshold. Not used when imputing ms2 quantitation results.
void | setImputeMs1PeptideNegativeRatio (bool imputeMs1PeptideNegativeRatio)
Set the imputation object behaviour of negative ms1 peptide ratios. Not used when imputing ms2 quantitation results.

Detailed Description

This class is the main conduit to execute numerical methods used to predict or impute missing values within incomplete arrays of data.

EXPERIMENTAL
This class is EXPERIMENTAL. Both the API and the implementation may change in a future version of Parser.

Data is set using the supplied quantitation objects on ratio or retention time values.

Member Enumeration Documentation

◆ IMPUTATION_VARIABLE

enum IMPUTATION_VARIABLE

What type of data is being imputed.

Use in the ms1 and ms2 ms_imputation constructors to declare the choice of ratios being imputed.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
IMPUTE_PROTEIN_RATIO | Missing protein ratios are imputed.
IMPUTE_PEPTIDE_RATIO | Missing peptide ratios are imputed. How to treat excluded peptide ratios is set via setImputeMs1PeptideExcludedByFractionThr and similarly named get/setters or by setImputeExcludedMs2PeptideRatios.
IMPUTE_RETENTION_TIME | Missing peptide retention times are being imputed.

Constructor & Destructor Documentation

◆ ms_imputation() [1/2]

ms_imputation | ( | const ms_ms1quantitation * | ms1quantitation,
 |  | ms_imputation_method & | m,
 |  | IMPUTATION_VARIABLE | imputationVariableChoice
 | ) |  |

Use this contructor to create an object to impute missing ms1 ratio values.

Use this constructor for when imputing missing ratio values from ms1 quantitation.

Parameters
ms1quantitation | is a pointer to the ms1 quantitation object.
m | is a reference to the chosen imputation method object.
imputationVariableChoice | is an enum of which values to impute. Only protein or peptide.

◆ ms_imputation() [2/2]

ms_imputation | ( | const ms_ms2quantitation * | ms2quantitation,
 |  | ms_imputation_method & | m,
 |  | IMPUTATION_VARIABLE | imputationVariableChoice
 | ) |  |

Use this contructor to create an object to impute missing ms2 ratio values.

Use this constructor for when imputing missing ratio values from ms2 quantitation.

Parameters
ms2quantitation | is a pointer to the ms2 quantitation object.
m | is a reference to the chosen imputation method object.
imputationVariableChoice | is an enum of which values to impute. Only protein or peptide.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ impute()

std::vector< std::vector< double > > impute ( )

Returns a 2D (m,n) array of doubles. m is the number of variables, implemented so far is quantitation ratios or subprojects n is the number of observations, implemented so far is the number of protein or peptides.

The 2D array will contain a mixture of real double values and imputed double values where previously there was missing values. The imputation method executed will be the type chosen in the ms_imputation constructor.

Returns
The 2D array of double values.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ setImputeMs1PeptideExcludedByCorrelationThr()

void setImputeMs1PeptideExcludedByCorrelationThr ( bool imputeMs1PeptideExcludedByCorrelationThr )

Set the imputation object behaviour of ms1 peptide ratios excluded because of the fraction threshold. Not used when imputing ms2 quantitation results.

Set how the imputation object is currently treating ms1 peptide ratios excluded because of the std err threshold.

Parameters
imputeMs1PeptideExcludedByCorrelationThr is a bool to set if ms1 peptide ratio values excluded by fraction threshold are treated as missing values or not.

◆ setImputeMs1PeptideExcludedByFractionThr()

void setImputeMs1PeptideExcludedByFractionThr ( bool imputeMs1PeptideExcludedByFractionThr )

Set the imputation object behaviour of ms1 peptide ratios excluded because of the fraction threshold. Not used when imputing ms2 quantitation results.

Set how the imputation object is currently treating ms1 peptide ratios excluded because of the fraction threshold.

Parameters
imputeMs1PeptideExcludedByFractionThr is a bool to set if ms1 peptide ratio values excluded by fraction threshold are treated as missing values or not.

◆ setImputeMs1PeptideExcludedByStdErrThr()

void setImputeMs1PeptideExcludedByStdErrThr ( bool imputeMs1PeptideExcludedByStdErrThr )

Set the imputation object behaviour of ms1 peptide ratios excluded because of the std err threshold. Not used when imputing ms2 quantitation results.

Set how the imputation object is currently treating ms1 peptide ratios excluded because of the std err threshold.

Parameters
imputeMs1PeptideExcludedByStdErrThr is a bool to set if ms1 peptide ratio values excluded by std err threshold are treated as missing values or not.

◆ setImputeMs1PeptideNegativeRatio()

void setImputeMs1PeptideNegativeRatio ( bool imputeMs1PeptideNegativeRatio )

Set the imputation object behaviour of negative ms1 peptide ratios. Not used when imputing ms2 quantitation results.

Set how the imputation object is currently treating ms1 peptide ratios excluded because of the std err threshold.

Parameters
imputeMs1PeptideNegativeRatio is a bool to set if negative ms1 peptide ratio values are treated as missing values or not.
The documentation for this class was generated from the following files:
  • ms_imputation.hpp
  • ms_imputation.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_imputation_average_value Class Reference

  • matrix_science
  • ms_imputation_average_value
Public Member Functions | Protected Member Functions | List of all members
ms_imputation_average_value Class Reference
Mascot utilities and tools module

#include <ms_imputation.hpp>

Inheritance diagram for ms_imputation_average_value:
[legend]
Collaboration diagram for ms_imputation_average_value:
[legend]

Public Member Functions

void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::vector< double > | getAverageValues ()
Get the vector of average values, one average per variable, that will be written in place of all missing values.
std::vector< std::vector< ms_imputation_missing_val > > & | getDataWithMissing ()
Get the data array that the imputation method will impute.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::vector< std::vector< double > > | impute () override
Returns a 2D array of doubles with the calculated average value in place of missing values.
bool | isValid () const
Call this function to determine if there have been any errors.
void | setAverageValues (std::vector< double > averageValuesIn)
Set the vector of average values, one average per variable, that will be written in place of all missing values.

Protected Member Functions

void | averageFindAverage ()
Find average of each column.
std::vector< std::vector< double > > | changems_imputation_missing_valArrayToDoubleArray (std::vector< std::vector< ms_imputation_missing_val > > dataProcess)
Extracts only the values from a 2d array of missing value objects.
std::vector< double > | changems_imputation_missing_valVecToDoubleVec (std::vector< ms_imputation_missing_val > missingObservation)
Extracts only the values from a vector of missing value objects.
std::vector< double > | getKnownValues (std::vector< ms_imputation_missing_val >)
Loop over one observation and get not missing values.
std::vector< int > | getMissingIndexes (std::vector< ms_imputation_missing_val >)
Loop over one observation and get missing indexes.
std::vector< std::vector< int > > | removeDuplicateIndexes (std::vector< std::vector< int > > duplicateIndexes)
The same combination of missing indexes can appear multiple times within a dataset. Duplicate indexes are removed from the missing indexes list to avoid making repeated alglib models.
void | setDataWithMissing (const std::vector< std::vector< ms_imputation_missing_val > > &dataWithMissingIn)

Detailed Description

Average value imputation class inherits general imputation method class with average value specific properties and methods

EXPERIMENTAL
This class is EXPERIMENTAL. Both the API and the implementation may change in a future version of Parser.

A slightly more complex method of imputation than fixed value. The arithmetic mean of each variable is calculated then written in place missing observations for all observations of each variables.

For example the array of five observations of five variables with some missing observations marked with a "x":

0 1 2 3 4
0.3 1.3 2.3 3.3 4.3
0 x 2 x 4
x 1 x 3 x
0 x 2 x 4

Is imputed to:

0 1 2 3 4
0 1 2 3 4
0 1 2 3 4
0.1 1 2.1 3 4.1
0 1.1 2 3.1 4

Average value imputation class inherits general imputation method class with average value specific properties and methods To use average value impution, create an instance of the ms_imputation_average_value class, then create an instance of ms_imputation using ms_imputation_average_value in the constructor, finally call ms_imputation.impute(). For example, with a valid ms_ms1quantitation object, in C#: ms_imputation_average_value averageValueImputation = new ms_imputation_average_value(); ms_imputation Imputation = new ms_imputation(ms1Quant, ms_imputation_average_value, IMPUTATION_VARIABLE.IMPUTE_PEPTIDE_RATIO); VecVecdouble imputationRes = Imputation.impute()

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ impute()

std::vector< std::vector< double > > impute ( )
overridevirtual

Returns a 2D array of doubles with the calculated average value in place of missing values.

A slightly more complex method of imputation than fixed value. The arithmetic mean of each variable is calculated then written in place missing observations for all observations of each variables.

For example the array of five observations of five variables with some missing observations marked with a "x":

0 1 2 3 4
0.3 1.3 2.3 3.3 4.3
0 x 2 x 4
x 1 x 3 x
0 x 2 x 4

Is imputed to:

0 1 2 3 4
0 1 2 3 4
0 1 2 3 4
0.1 1 2.1 3 4.1
0 1.1 2 3.1 4
Returns
A 2D array with the arithmetic mean values of each variable in place of missing observations

Implements ms_imputation_method.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ setDataWithMissing()

void setDataWithMissing ( const std::vector< std::vector< ms_imputation_missing_val > > & dataWithMissingIn )
protectedinherited

Set the missing value array

Parameters
dataWithMissingIn The array of missing values to be imputed
The documentation for this class was generated from the following files:
  • ms_imputation.hpp
  • ms_imputation.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_imputation_fixed_value Class Reference

  • matrix_science
  • ms_imputation_fixed_value
Public Member Functions | Protected Member Functions | List of all members
ms_imputation_fixed_value Class Reference
Mascot utilities and tools module

#include <ms_imputation.hpp>

Inheritance diagram for ms_imputation_fixed_value:
[legend]
Collaboration diagram for ms_imputation_fixed_value:
[legend]

Public Member Functions

void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::vector< std::vector< ms_imputation_missing_val > > & | getDataWithMissing ()
Get the data array that the imputation method will impute.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
double | getFixedValue ()
Get the single fixed value that will be written in place of all missing values.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::vector< std::vector< double > > | impute () override
Returns a 2D array of doubles with the fixed value in place of missing values.
bool | isValid () const
Call this function to determine if there have been any errors.
void | setFixedValue (double fixedValueIn)
Set the single fixed value that will be written in place of all missing values.

Protected Member Functions

void | averageFindAverage ()
Find average of each column.
std::vector< std::vector< double > > | changems_imputation_missing_valArrayToDoubleArray (std::vector< std::vector< ms_imputation_missing_val > > dataProcess)
Extracts only the values from a 2d array of missing value objects.
std::vector< double > | changems_imputation_missing_valVecToDoubleVec (std::vector< ms_imputation_missing_val > missingObservation)
Extracts only the values from a vector of missing value objects.
std::vector< double > | getKnownValues (std::vector< ms_imputation_missing_val >)
Loop over one observation and get not missing values.
std::vector< int > | getMissingIndexes (std::vector< ms_imputation_missing_val >)
Loop over one observation and get missing indexes.
std::vector< std::vector< int > > | removeDuplicateIndexes (std::vector< std::vector< int > > duplicateIndexes)
The same combination of missing indexes can appear multiple times within a dataset. Duplicate indexes are removed from the missing indexes list to avoid making repeated alglib models.
void | setDataWithMissing (const std::vector< std::vector< ms_imputation_missing_val > > &dataWithMissingIn)

Detailed Description

Fixed value imputation class inherits general imputation method class with fixed value specific properties and methods

EXPERIMENTAL
This class is EXPERIMENTAL. Both the API and the implementation may change in a future version of Parser.

The simplest method of imputation. A single constant fixed value is written in place missing observations for all observations and variables.

For example the array of five observations of five variables with some missing observations marked with a "x":

0 1 2 3 4
0 1 2 3 4
0 x 2 x 4
x 1 x 3 x
0 x 2 x 4

Is imputed to:

0 1 2 3 4
0 1 2 3 4
0 1 2 1 4
1 1 1 3 1
0 1 2 1 4

With a fixed value of 1.

Fixed value imputation class inherits general imputation method class with average value specific properties and methods To use fixed value impution, create an instance of the ms_imputation_fixed_value class, set the fixed value you desire, then create an instance of ms_imputation using ms_imputation_fixed_value in the constructor, finally call ms_imputation.impute(). For example, with a valid ms_ms1quantitation object, in C#: ms_imputation_fixed_value fixedValueImputation = new ms_imputation_fixed_value(); fixedValueImputation.setFixedValue(2.71828); ms_imputation Imputation = new ms_imputation(ms1Quant, ms_imputation_fixed_value, IMPUTATION_VARIABLE.IMPUTE_PEPTIDE_RATIO); VecVecdouble imputationRes = Imputation.impute()

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ impute()

std::vector< std::vector< double > > impute ( )
overridevirtual

Returns a 2D array of doubles with the fixed value in place of missing values.

The simplest method of imputation. A single constant fixed value is written in place missing observations for all observations and variables.

For example the array of five observations of five variables with some missing observations marked with a "x":

0 1 2 3 4
0 1 2 3 4
0 x 2 x 4
x 1 x 3 x
0 x 2 x 4

Is imputed to:

0 1 2 3 4
0 1 2 3 4
0 1 2 1 4
1 1 1 3 1
0 1 2 1 4

With a fixed value of 1.

Returns
A 2D array with the fixed value in place of missing observations

Implements ms_imputation_method.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ setDataWithMissing()

void setDataWithMissing ( const std::vector< std::vector< ms_imputation_missing_val > > & dataWithMissingIn )
protectedinherited

Set the missing value array

Parameters
dataWithMissingIn The array of missing values to be imputed
The documentation for this class was generated from the following files:
  • ms_imputation.hpp
  • ms_imputation.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_imputation_knn Class Reference

  • matrix_science
  • ms_imputation_knn
Public Member Functions | Protected Member Functions | List of all members
ms_imputation_knn Class Reference
Mascot utilities and tools module

#include <ms_imputation.hpp>

Inheritance diagram for ms_imputation_knn:
[legend]
Collaboration diagram for ms_imputation_knn:
[legend]

Public Member Functions

void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::vector< std::vector< ms_imputation_missing_val > > & | getDataWithMissing ()
Get the data array that the imputation method will impute.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getKnnNumNeighbours ()
Get the number of nearest neighbours used when calculating an imputed value. Default value = 5.
bool | getKnnUseWeightedAverage ()
Get the bool to signify if a weighted average of nearest neighbours is used when calculating an imputed value. Default case = true.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::vector< std::vector< double > > | impute () override
Returns a 2D array of doubles with the calculated nearest neighbour average value in place of missing values.
bool | isValid () const
Call this function to determine if there have been any errors.
void | setKnnNumNeighbours (int knnNumNeighboursIn)
Set the number of nearest neighbours used when calculating the imputed value. Default value = 5.
void | setKnnUseWeightedAverage (bool knnUseWeightedAverageIn)
Set the bool to signify if a weighted average of nearest neighbours is used when calculating an imputed value. Default case = true.

Protected Member Functions

void | averageFindAverage ()
Find average of each column.
std::vector< std::vector< double > > | changems_imputation_missing_valArrayToDoubleArray (std::vector< std::vector< ms_imputation_missing_val > > dataProcess)
Extracts only the values from a 2d array of missing value objects.
std::vector< double > | changems_imputation_missing_valVecToDoubleVec (std::vector< ms_imputation_missing_val > missingObservation)
Extracts only the values from a vector of missing value objects.
std::vector< double > | getKnownValues (std::vector< ms_imputation_missing_val >)
Loop over one observation and get not missing values.
std::vector< int > | getMissingIndexes (std::vector< ms_imputation_missing_val >)
Loop over one observation and get missing indexes.
std::vector< std::vector< int > > | removeDuplicateIndexes (std::vector< std::vector< int > > duplicateIndexes)
The same combination of missing indexes can appear multiple times within a dataset. Duplicate indexes are removed from the missing indexes list to avoid making repeated alglib models.
void | setDataWithMissing (const std::vector< std::vector< ms_imputation_missing_val > > &dataWithMissingIn)

Detailed Description

Knn imputation class inherits general imputation method class with average value specific properties and methods

EXPERIMENTAL
This class is EXPERIMENTAL. Both the API and the implementation may change in a future version of Parser.

A fast and reliable method of imputation that makes more accurate predictions than average value. KNN finds the most similar complete observations to each observation with missing then calculate the average of the closest k variables. KNN requires that a subset of observations contain no missing values. This subset becomes the neighbour group that all predictions are calculated from. KNN has two configurable settings that will effect the prediction value set via the get/set structure. knnNumNearest sets the number of neighbours that are included when the prediction is calculated. knnUseWeightedMean sets whether the calculated average of the neighbours is weighted by the cloesness of the neighbour

For example the array of five observations of five variables with some missing observations marked with a "x":

0.0 1.0 2.0 3.0 4.0
0.3 1.3 2.3 3.3 4.3
0.1 1.1 2.1 3.1 4.1
x 1.2 x 3.2 x
-0.1 x 1.9 x 3.9

Is imputed to :

0.0 1.0 2.0 3.0 4.0
0.3 1.3 2.3 3.3 4.3
0.1 1.1 2.1 3.1 4.1
0.2 1.2 2.2 3.2 4.2
-0.1 1.05 1.9 3.05 3.9

with the parameters knnNumNearest = 2 and knnUseWeightedMean = False.

K-Nearest Neighbours imputation class inherits general imputation method class with average value specific properties and methods To use knn impution, create an instance of the ms_imputation_knn class, set the knn properties you desire, then create an instance of ms_imputation using ms_imputation_knn in the constructor, finally call ms_imputation.impute(). For example, with a valid ms_ms1quantitation object, in C#: ms_imputation_knn knnImputation = new ms_imputation_knn(); knnImputation.setKnnNumNeighbours(5); knnImputation.setKnnUseWeightedAverage(true); ms_imputation Imputation = new ms_imputation(ms1Quant, ms_imputation_knn, IMPUTATION_VARIABLE.IMPUTE_PEPTIDE_RATIO); VecVecdouble imputationRes = Imputation.impute()

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ impute()

std::vector< std::vector< double > > impute ( )
overridevirtual

Returns a 2D array of doubles with the calculated nearest neighbour average value in place of missing values.

A fast and reliable method of imputation that makes more accurate predictions than average value. KNN finds the most similar complete observations to each observation with missing then calculate the average of the closest k variables. KNN requires that a subset of observations contain no missing values. This subset becomes the neighbour group that all predictions are calculated from. KNN has two configurable settings that will effect the prediction value set via the get/set structure. knnNumNearest sets the number of neighbours that are included when the prediction is calculated. knnUseWeightedMean sets whether the calculated average of the neighbours is weighted by the cloesness of the neighbour

For example the array of five observations of five variables with some missing observations marked with a "x":

0.0 1.0 2.0 3.0 4.0
0.3 1.3 2.3 3.3 4.3
0.1 1.1 2.1 3.1 4.1
x 1.2 x 3.2 x
-0.1 x 1.9 x 3.9

Is imputed to :

0.0 1.0 2.0 3.0 4.0
0.3 1.3 2.3 3.3 4.3
0.1 1.1 2.1 3.1 4.1
0.2 1.2 2.2 3.2 4.2
-0.1 1.05 1.9 3.05 3.9

with the parameters knnNumNearest = 2 and knnUseWeightedMean = False.

Returns
A 2D array with the nearest neighbour predictions in place of missing observations

Implements ms_imputation_method.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ setDataWithMissing()

void setDataWithMissing ( const std::vector< std::vector< ms_imputation_missing_val > > & dataWithMissingIn )
protectedinherited

Set the missing value array

Parameters
dataWithMissingIn The array of missing values to be imputed
The documentation for this class was generated from the following files:
  • ms_imputation.hpp
  • ms_imputation.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_imputation_method Class Reference

  • matrix_science
  • ms_imputation_method
Public Member Functions | Protected Member Functions | List of all members
ms_imputation_method Class Referenceabstract
Mascot utilities and tools module

#include <ms_imputation.hpp>

Inheritance diagram for ms_imputation_method:
[legend]
Collaboration diagram for ms_imputation_method:
[legend]

Public Member Functions

void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::vector< std::vector< ms_imputation_missing_val > > & | getDataWithMissing ()
Get the data array that the imputation method will impute.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | isValid () const
Call this function to determine if there have been any errors.

Protected Member Functions

ms_imputation_method ()=default
Default constructor.
void | averageFindAverage ()
Find average of each column.
std::vector< std::vector< double > > | changems_imputation_missing_valArrayToDoubleArray (std::vector< std::vector< ms_imputation_missing_val > > dataProcess)
Extracts only the values from a 2d array of missing value objects.
std::vector< double > | changems_imputation_missing_valVecToDoubleVec (std::vector< ms_imputation_missing_val > missingObservation)
Extracts only the values from a vector of missing value objects.
std::vector< double > | getKnownValues (std::vector< ms_imputation_missing_val >)
Loop over one observation and get not missing values.
std::vector< int > | getMissingIndexes (std::vector< ms_imputation_missing_val >)
Loop over one observation and get missing indexes.
std::vector< std::vector< int > > | removeDuplicateIndexes (std::vector< std::vector< int > > duplicateIndexes)
The same combination of missing indexes can appear multiple times within a dataset. Duplicate indexes are removed from the missing indexes list to avoid making repeated alglib models.
void | setDataWithMissing (const std::vector< std::vector< ms_imputation_missing_val > > &dataWithMissingIn)

Detailed Description

ms_imputation_method is an abstract class; use ms_imputation_fixed_value, ms_imputation_average_value, ms_imputation_knn or ms_imputation_missforest

EXPERIMENTAL
This class is EXPERIMENTAL. Both the API and the implementation may change in a future version of Parser.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ setDataWithMissing()

void setDataWithMissing ( const std::vector< std::vector< ms_imputation_missing_val > > & dataWithMissingIn )
protected

Set the missing value array

Parameters
dataWithMissingIn The array of missing values to be imputed
The documentation for this class was generated from the following files:
  • ms_imputation.hpp
  • ms_imputation.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_imputation_missforest Class Reference

  • matrix_science
  • ms_imputation_missforest
Public Member Functions | Protected Member Functions | List of all members
ms_imputation_missforest Class Reference
Mascot utilities and tools module

#include <ms_imputation.hpp>

Inheritance diagram for ms_imputation_missforest:
[legend]
Collaboration diagram for ms_imputation_missforest:
[legend]

Public Member Functions

void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::vector< std::vector< ms_imputation_missing_val > > & | getDataWithMissing ()
Get the data array that the imputation method will impute.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::vector< std::vector< double > > | impute () override
Returns a 2D array of double with the miss forest prediction results in place of missing values.
bool | isValid () const
Call this function to determine if there have been any errors.

Protected Member Functions

void | averageFindAverage ()
Find average of each column.
std::vector< std::vector< double > > | changems_imputation_missing_valArrayToDoubleArray (std::vector< std::vector< ms_imputation_missing_val > > dataProcess)
Extracts only the values from a 2d array of missing value objects.
std::vector< double > | changems_imputation_missing_valVecToDoubleVec (std::vector< ms_imputation_missing_val > missingObservation)
Extracts only the values from a vector of missing value objects.
std::vector< double > | getKnownValues (std::vector< ms_imputation_missing_val >)
Loop over one observation and get not missing values.
std::vector< int > | getMissingIndexes (std::vector< ms_imputation_missing_val >)
Loop over one observation and get missing indexes.
std::vector< std::vector< int > > | removeDuplicateIndexes (std::vector< std::vector< int > > duplicateIndexes)
The same combination of missing indexes can appear multiple times within a dataset. Duplicate indexes are removed from the missing indexes list to avoid making repeated alglib models.
void | setDataWithMissing (const std::vector< std::vector< ms_imputation_missing_val > > &dataWithMissingIn)

Detailed Description

An accurate prediction algorithm that uses an iterative random forest approach to create progressively improving predictions.

EXPERIMENTAL
This class is EXPERIMENTAL. Both the API and the implementation may change in a future version of Parser.

The original paper can be found here: https://academic.oup.com/bioinformatics/article/28/1/112/219101 While slower to complete than KNN, Miss Forest has proven to be more accurate than KNN during in house testing and within the paper. Unlike KNN, Miss Forest does not need any complete observations to function. Miss Forest uses average value imputation as a starting point and as a means of filling out all missing observations. Although to missing values are no longer missing, the positions of the original missing values is saved and used throughout. Then Miss Forest creates a random forest from the average imputed data for each variable with original missing values. Each original missing value is predicted and updated within the working dataset. This process is repeated and the two products are compared with the difference recorded. The forest creation, prediction, update and comparsion is repeated until the difference between consecutive products increases in size. The final prediction is the previous product before the increase in differences.

For example the array of five observations of five variables with some missing observations marked with a "x":

0.0 1.0 2.0 3.0 4.0
0.3 1.3 2.3 3.3 4.3
0.1 1.1 2.1 3.1 4.1
x 1.2 x 3.2 x
-0.1 x 1.9 x 3.9

Is imputed to :

0.0 1.0 2.0 3.0 4.0
0.3 1.3 2.3 3.3 4.3
0.1 1.1 2.1 3.1 4.1
0.16 1.2 2.16 3.2 4.15
-0.1 1.0 1.9 3.0 3.9

This example requires 6 iterations.

Miss Forest imputation class inherits general imputation method class with average value specific properties and methods To use missforest impution, create an instance of the ms_imputation_missforest class, then an instance of ms_imputation using ms_imputation_missforest in the constructor, finally call ms_imputation.impute(). For example, with a valid ms_ms1quantitation object, in C#: ms_imputation_missforest missForestImputation = new ms_imputation_missforest(); ms_imputation Imputation = new ms_imputation(ms1Quant, missForestImputation, IMPUTATION_VARIABLE.IMPUTE_PEPTIDE_RATIO); VecVecdouble imputationRes = Imputation.impute()

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ impute()

std::vector< std::vector< double > > impute ( )
overridevirtual

Returns a 2D array of double with the miss forest prediction results in place of missing values.

An accurate prediction algorithm that uses an iterative random forest approach to create progressively improving predictions. The oriinal paper can be found here: https://academic.oup.com/bioinformatics/article/28/1/112/219101 While slower to complete than KNN, Miss Forest has proven to be more accurate than KNN during in house testing and within the paper. Unlike KNN, Miss Forest does not need any complete observations to function. Miss Forest uses average value imputation as a starting point and as a means of filling out all missing observations. Although to missing values are no longer missing, the positions of the original missing values is saved and used throughout. Then Miss Forest creates a random forest from the average imputed data for each variable with original missing values. Each original missing value is predicted and updated within the working dataset. This process is repeated and the two products are compared with the difference recorded. The forest creation, prediction, update and comparsion is repeated until the difference between consecutive products increases in size. The final prediction is the previous product before the increase in differences.

For example the array of five observations of five variables with some missing observations marked with a "x":

0.0 1.0 2.0 3.0 4.0
0.3 1.3 2.3 3.3 4.3
0.1 1.1 2.1 3.1 4.1
x 1.2 x 3.2 x
-0.1 x 1.9 x 3.9

Is imputed to :

0.0 1.0 2.0 3.0 4.0
0.3 1.3 2.3 3.3 4.3
0.1 1.1 2.1 3.1 4.1
0.16 1.2 2.16 3.2 4.15
-0.1 1.0 1.9 3.0 3.9

This example requires 6 iterations.

Returns
A 2D array with the miss forest predictions in place of missing observations

Implements ms_imputation_method.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ setDataWithMissing()

void setDataWithMissing ( const std::vector< std::vector< ms_imputation_missing_val > > & dataWithMissingIn )
protectedinherited

Set the missing value array

Parameters
dataWithMissingIn The array of missing values to be imputed
The documentation for this class was generated from the following files:
  • ms_imputation.hpp
  • ms_imputation.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_imputation_peptide_data Class Reference

  • matrix_science
  • ms_imputation_peptide_data
Public Member Functions | List of all members
ms_imputation_peptide_data Class Reference
Mascot utilities and tools module

#include <ms_imputation.hpp>

Public Member Functions

ms_imputation_peptide_data (double retentionTime, int subproject)
Constructor to initialise the parameters required for imputation.
const double | retentionTime () const
Get retention time for this peptide.
const int | subproject () const
Get the 1-based subproject index.

Detailed Description

This class is a holder of peptide information within the Supervised time alignment of label free quantitation.

EXPERIMENTAL
This class is EXPERIMENTAL. Both the API and the implementation may change in a future version of Parser.

Data is set using the supplied quantitation objects on ratio or retention time values.

The documentation for this class was generated from the following file:
  • ms_imputation.hpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_matrix Class Reference

  • matrix_science
  • ms_matrix
Public Member Functions | Static Public Member Functions | List of all members
ms_matrix Class Reference
Mascot utilities and tools module

A two-dimensional matrix of numbers. More...

#include <ms_matrix.hpp>

Public Member Functions

ms_matrix ()
Construct empty matrix.
ms_matrix (const matrix_t &m)
Construct a copy of a matrix.
ms_matrix (size_t si, size_t sj, double v=0.0)
Construct a rectangular matrix.
const matrix_t & | data () const
Get the internal constant matrix data.
double | getCR (size_t i, size_t j) const
Get the value for the specified row and column.
double | getRC (size_t i, size_t j) const
Get the value for the specified row and column.
bool | isZero () const
Return true if all values are zero.
void | logContents (ms_errs &errs, const char *description) const
Dump the contents of the matrix to the log.
double | multiplyByRow (const std::vector< double > &column, size_t row) const
Multiply the column matrix by the selected row matrix and return the resulting value. The column must be the same size as a row (getNumColumns) in the matrix.
bool | operator!= (const ms_matrix &m) const
Compare two matrices; size and all values.
ms_matrix | operator* (const ms_matrix &m) const
Multiply two matrices to produce a product matrix.
bool | operator== (const ms_matrix &m) const
Compare two matrices.
column_vector_t & | operator[] (size_t i)
Get a single column as a vector.
const column_vector_t & | operator[] (size_t i) const
Get a single column as a constant vector.
void | resize (size_t si, size_t sj, double v=0.0)
Change the size of the matrix, growing or shrinking as required. If grown then the data will be retained.
void | setColumnDown (size_t row, size_t col, const std::vector< double > &vec)
Copies the values in the passed vector into the column specified, starting at the passed row.
void | setColumnUp (size_t row, size_t col, const std::vector< double > &vec)
Copies the values in the passed vector into the column specified, starting at the passed row.
void | setCR (size_t i, size_t j, double value)
Set the value for the specified row and column.
void | setRC (size_t i, size_t j, double value)
Set the value for the specified row and column.
size_t | sizei () const
Return the number of columns in the matrix.
size_t | sizej () const
Return the number of rows in the matrix.
void | transpose ()
Transpose the matrix in place.

Static Public Member Functions

static ms_matrix | columnMatrix (const std::vector< double > &v)
Returns a matrix with a single column.
static ms_matrix | diagonalMatrix (size_t s, double v)
Returns a square, diagonal matrix.
static ms_matrix | identityMatrix (size_t s)
Returns a square, identity matrix.
static ms_matrix | rowMatrix (const std::vector< double > &v)
Returns a matrix with a single row.

Detailed Description

A two-dimensional matrix of numbers.

The size of a matrix is defined by the number of rows and columns that it contains.

The entry in the j-th row and i-th column of a matrix A is accessed as A[i][j]. Note that this is the opposite of the conventional mathematical notation, where the j-th row of the i-th column of a matrix A is referred to as A[j,i].

The row and column indexes are zero-based (0 to n-1). Note that this differs from the conventional mathematical notation where indexes are one-based (1 to n).

Constructor & Destructor Documentation

◆ ms_matrix() [1/2]

ms_matrix ( )

Construct empty matrix.

No rows and no columns.

◆ ms_matrix() [2/2]

ms_matrix ( const matrix_t & m )

Construct a copy of a matrix.

Parameters
m The matrix to copy.

Member Function Documentation

◆ columnMatrix()

ms_matrix columnMatrix ( const std::vector< double > & v )
static

Returns a matrix with a single column.

The column size will be the number of values given.

Parameters
v The values placed in the column.
Returns
The column matrix.

◆ data()

const ms_matrix::matrix_t & data ( ) const

Get the internal constant matrix data.

Returns
The internal representation of the matrix values.

◆ diagonalMatrix()

ms_matrix diagonalMatrix | ( | size_t | s,
 |  | double | v
 | ) |  |
static

Returns a square, diagonal matrix.

All values are zero except for the diagonal values.

Parameters
s | The size of a row or column; the number of columns and rows.
v | The value placed in every diagonal entry in the matrix.
Returns
The diagonal matrix.

◆ getCR()

double getCR | ( | size_t | i,
 |  | size_t | j
 | ) |  | const

Get the value for the specified row and column.

Parameters
i | The number of the column to retrieve from (0 .. m-1).
j | The number of the row to retrieve from (0 .. n-1).
Returns
The value of the selected entry.

◆ identityMatrix()

ms_matrix identityMatrix ( size_t s )
static

Returns a square, identity matrix.

All values are zero except for 1.0 in all the diagonal values.

Parameters
s The size of a row or column; the number of columns and rows.
Returns
The identity matrix.

◆ isZero()

bool isZero ( ) const

Return true if all values are zero.

Returns
True if all entries are zero. False if any entry is non-zero.

◆ logContents()

void logContents | ( | ms_errs & | errs,
 |  | const char * | description
 | ) |  | const

Dump the contents of the matrix to the log.

Outputs to the log if the logging level is high enough for message: ms_log::LOGMSG_MATRIX_OUTPUT_VALS

Parameters
errs | is the error handler
description | should be used to describe the matrix

◆ operator!=()

bool operator!= ( const ms_matrix & m ) const

Compare two matrices; size and all values.

Parameters
m reference to a valid ms_matrix object
Returns
True if either size or any entry is not identical.

◆ operator*()

ms_matrix operator* ( const ms_matrix & m ) const

Multiply two matrices to produce a product matrix.

The number of columns in the left-hand matrix must equal the number of rows in the right hand matrix.

The product matrix has a number of rows equal to the number of rows in the left-hand matrix and a number of columns equal to the number of columns in the right-hand matrix.

For example, a 2x3 matrix A can be mutlipled by a 4x2 matrix B, C=A*B, to produce a 4x3 matrix.but not the other way around, C=B*A.) (e.g. a 2x3 matrix multiplied by a 4x2 matrix would have a size of 4x3.)

Parameters
m reference to a valid ms_matrix object
Returns
new object of type ms_matrix

◆ operator==()

bool operator== ( const ms_matrix & m ) const

Compare two matrices.

Parameters
m reference to a valid ms_matrix object
Returns
True if the size and all entries are identical.

◆ operator[]() [1/2]

ms_matrix::column_vector_t & operator[] ( size_t i )

Get a single column as a vector.

Parameters
i The number of the column to retrieve (0 .. m-1).
Returns
The selected column.

◆ operator[]() [2/2]

const ms_matrix::column_vector_t & operator[] ( size_t i ) const

Get a single column as a constant vector.

Parameters
i The number of the column to retrieve (0 .. m-1).
Returns
The selected column.

◆ resize()

void resize | ( | size_t | si,
 |  | size_t | sj,
 |  | double | v = 0.0
 | ) |  |

Change the size of the matrix, growing or shrinking as required. If grown then the data will be retained.

Parameters
si | The new number of columns.
sj | The new number of the rows.
v | The value to place in new entries.

◆ rowMatrix()

ms_matrix rowMatrix ( const std::vector< double > & v )
static

Returns a matrix with a single row.

The row size will be the number of values given.

Parameters
v The values placed in the row.
Returns
The row matrix.

◆ setColumnDown()

void setColumnDown | ( | size_t | row,
 |  | size_t | col,
 |  | const std::vector< double > & | vec
 | ) |  |

Copies the values in the passed vector into the column specified, starting at the passed row.

The first value in vec is copied into row, col
The second value in vec is copied into row+1, col
etc.

If vec is larger than the size of the matrix, then the copying stops at the final row in the matrix.

Parameters
row | is the zero based row to start copying
col | is the column to be filled with values
vec | contains the values to be copied

◆ setColumnUp()

void setColumnUp | ( | size_t | row,
 |  | size_t | col,
 |  | const std::vector< double > & | vec
 | ) |  |

Copies the values in the passed vector into the column specified, starting at the passed row.

The last value in vec is copied into row, col
The second last value in vec is copied into row-1, col
etc.

If vec is larger than the size of the matrix, then the copying stops at the first row in the matrix.

Parameters
row | is the zero based row to start copying
col | is the column to be filled with values
vec | contains the values to be copied

◆ setCR()

void setCR | ( | size_t | i,
 |  | size_t | j,
 |  | double | value
 | ) |  |

Set the value for the specified row and column.

Parameters
i | The number of the column to retrieve from (0 .. m-1).
j | The number of the row to retrieve from (0 .. n-1).
value | The number to be stored in the specified matrix element.

◆ sizei()

size_t sizei ( ) const

Return the number of columns in the matrix.

Returns
The size of a row.

◆ sizej()

size_t sizej ( ) const

Return the number of rows in the matrix.

Returns
The size of a column.

◆ transpose()

void transpose ( )

Transpose the matrix in place.

Reflects the matrix over its main diagonal (which runs from top-left to bottom-right) to obtain its inverse.

The documentation for this class was generated from the following files:
  • ms_matrix.hpp
  • ms_matrix.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_spectral_lib_entry Class Reference

  • matrix_science
  • ms_spectral_lib_entry
Public Types | Public Member Functions | List of all members
ms_spectral_lib_entry Class Reference
Mascot utilities and tools module

This class is used to encapsulate a single entry, i.e. single spectrum from a NIST .msp file or SpectraST .sptxt file. More...

#include <ms_spectral_lib_entry.hpp>

Inheritance diagram for ms_spectral_lib_entry:
[legend]
Collaboration diagram for ms_spectral_lib_entry:
[legend]

Public Types

enum WHAT_TO_ANNOTATE {
ANNOTATE_NONE ,
ANNOTATE_REPLACE_ALL ,
ANNOTATE_REPLACE_QUESTION_MARKS ,
ANNOTATE_REPLACE_IF_ALL_EMPTY
}
Used by annotatePeaks to specify if existing annotation should be overwritten. More...

Public Member Functions

ms_spectral_lib_entry ()
Default constructor.
ms_spectral_lib_entry (const ms_spectral_lib_entry &src)
Copying constructor.
ms_spectral_lib_entry (const std::string &entry, const std::string &fileName, const ms_spectral_lib::FILE_FORMAT format)
Constructor.
ms_spectral_lib_entry (const std::vector< std::string > &entry, const std::string &fileName, const ms_spectral_lib::FILE_FORMAT format)
Constructor.
virtual | ~ms_spectral_lib_entry ()
Destructor.
bool | annotatePeaks (const WHAT_TO_ANNOTATE whatToAnnotate, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, const ms_umod_configfile *unimod=0)
If there is no existing annotation for any of the peaks in the peak list, then try to annotate using sequence string and modifications.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearAnnotation ()
Removes all annotation from all peaks.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_spectral_lib_entry *right)
Use this member to make a copy of another instance.
const std::string | get () const
Returns the whole entry, in the original format.
int | getCharge () const
Returns the charge state.
std::string | getComment () const
Returns the whole comment line.
std::string | getCommentField (const char *fieldName) const
Returns a particular field entry from the comment line.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns the filename where the entry was loaded from.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getLine (const char *key) const
Returns the line for a given key.
int | getMods (std::vector< std::string > &names, std::vector< int > &positions) const
Returns the modifications.
double | getMW () const
Returns the molecular weight.
std::string | getName () const
Returns the Name which is normally the sequence followed by /[CHARGE].
int | getNumPeaks () const
Returns the number of peaks in the spectrum.
std::vector< std::string > | getPeakList (bool convertToNISTformat=false) const
Returns the peak list.
std::string | getPeakListChecksum () const
Returns an MD5 checksum for the peak list.
matrix_science::ms_spectral_lib_peak_list | getPeakListObject () const
Returns the peak list object.
double | getPrecursorMZ () const
Return the 'best available' precursor m/z value.
std::string | getSequence () const
Returns the sequence.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_spectral_lib_entry & | operator= (const ms_spectral_lib_entry &right)
C++ style assignment operator.

Detailed Description

This class is used to encapsulate a single entry, i.e. single spectrum from a NIST .msp file or SpectraST .sptxt file.

Support for spectral library searches was added in Mascot Server 2.6 and Mascot Parser 2.6. Although external NIST software is used for the spectral library search itself, there is a requirement to process the msp files which are plain text.

The ms_spectral_lib_file class is used to open an msp file, and an individual entry can be returned using ms_spectral_lib_file::getEntryFromNumber

The format of the msp file is multiple lines, each with a [param][colon][space][value]. For example,

Name: AAAAAAAAAAAAAAAGAGAGAK/3
MW: 1598.861
Comment: Spec=Consensus Pep=Tryp
Num peaks: 150

followed by, in this case, 150 lines of peak data, followed by a blank line.

The format is defined here.

The SpectraST files (.sptxt) have minor differences, for example additional lines and a different format for the peak list. See ms_spectral_lib_file::saveAs() for details.

The code in this class allows additional parameter value lines in case of future extension. However, the Name: Comment: and Num peaks: parameters above are required, or an error will be generated.

See Spectral libraries for related information.

Member Enumeration Documentation

◆ WHAT_TO_ANNOTATE

enum WHAT_TO_ANNOTATE

Used by annotatePeaks to specify if existing annotation should be overwritten.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

See also ms_spectral_lib_file::saveAs

Enumerator
ANNOTATE_NONE | Don't perform any annotation.
ANNOTATE_REPLACE_ALL | Replace all existing annotation.
ANNOTATE_REPLACE_QUESTION_MARKS | Only annotate if ms_spectral_lib_peak_list::getPeakAnnotationLevel returns ms_spectral_lib_peak_list::ANNOT_LVL_QUESTION_MARKS.
ANNOTATE_REPLACE_IF_ALL_EMPTY | Only annotate if ms_spectral_lib_peak_list::getPeakAnnotationLevel returns ms_spectral_lib_peak_list::ANNOT_LVL_NONE.

Constructor & Destructor Documentation

◆ ms_spectral_lib_entry() [1/4]

ms_spectral_lib_entry ( )

Default constructor.

An ms_spectral_lib_entry object is normally created using ms_spectral_lib_file::getEntryFromNumber

◆ ms_spectral_lib_entry() [2/4]

ms_spectral_lib_entry ( const ms_spectral_lib_entry & src )

Copying constructor.

Parameters
src is the source to initialise from

◆ ms_spectral_lib_entry() [3/4]

ms_spectral_lib_entry | ( | const std::string & | entry,
 |  | const std::string & | fileName,
 |  | const ms_spectral_lib::FILE_FORMAT | format
 | ) |  |

Constructor.

An ms_spectral_lib_entry object is normally created using ms_spectral_lib_file::getEntryFromNumber

Parameters
entry | is a string containing multiple lines from an msp file.
fileName | is the path of the file where the entry was read from. It is saved as a convenience, and also for error reporting.
format | is the format of the entry. Should be an enum, of the type ms_spectral_lib_file::FILE_FORMAT

◆ ms_spectral_lib_entry() [4/4]

ms_spectral_lib_entry | ( | const std::vector< std::string > & | entry,
 |  | const std::string & | fileName,
 |  | const ms_spectral_lib::FILE_FORMAT | format
 | ) |  |

Constructor.

An ms_spectral_lib_entry object is normally created using ms_spectral_lib_file::getEntryFromNumber

Parameters
entry | is a string containing multiple lines from an msp file.
fileName | is the path of the file where the entry was read from. It is saved as a convenience, and also for error reporting.
format | is the format of the entry. Should be an enum, of the type ms_spectral_lib_file::FILE_FORMAT

Member Function Documentation

◆ annotatePeaks()

bool annotatePeaks | ( | const WHAT_TO_ANNOTATE | whatToAnnotate,
 |  | const double | fragmentToleranceValue,
 |  | const std::string | fragmentToleranceUnit,
 |  | const ms_umod_configfile * | unimod = 0
 | ) |  |

If there is no existing annotation for any of the peaks in the peak list, then try to annotate using sequence string and modifications.

Annotate peaks for this one entry.

For Spectral libraries on Mascot Server, the user needs to specify a tolerance in ppm or Daltons. See ms_libraryoptions::getToleranceInDa and ms_libraryoptions::getToleranceInPPM

Parameters
whatToAnnotate | is used to specify whether existing annotation should be replaced.
fragmentToleranceValue | is the value in the units specified, for matching to the calculated data. Only peaks within this tolerance will be annotated. Other peaks will be annotated with a "?"
fragmentToleranceUnit | must be "Da", "mmu" or "ppm".
unimod | is required if the entry has any modifications that are just specified by name. Otherwise, there is no way to calculate the fragment ion masses.
Returns
true if annotation was performed.

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_spectral_lib_entry * right )

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getCharge()

int getCharge ( ) const

Returns the charge state.

Each spectrum begins with the line in the format:

Name: [peptide sequence]/[charge]

for example

Name: AAAAAAGAGPEM(O)VR/2

where each amino acid in the [peptide sequence] is represented by the usual (upper case) letter sequence and [charge] is the positive charge on the peptide. The only modification explicitly shown is oxidized methionine as M(O).

The charge is taken from the end of this line.

Returns
the charge

◆ getComment()

std::string getComment ( ) const

Returns the whole comment line.

The third line for each entry contains annotation information for the peptide, its origin and its spectrum It has the format:

Comments: field1=value [field2=value ]...

Comments are composed of a series of space delimited field=value pairs, where values may be embedded within double quotes. All field names are described in Table 3 of this document. There is one mandatory field, namely Parent=<m/z>, which is the precursor ion m/z required for searching

Returns
the whole comment line

◆ getCommentField()

std::string getCommentField ( const char * fieldName ) const

Returns a particular field entry from the comment line.

The third line for each entry contains annotation information for the peptide, its origin and its spectrum It has the format:

Comments: field1=value [field2=value ]...

Comments are composed of a series of space delimited field=value pairs, where values may be embedded within double quotes. All field names are described in Table 3 of this document. There is one mandatory field, namely Parent=<m/z>, which is the precursor ion m/z required for searching

Parameters
fieldName should not contain the =. For example, specify "Parent". The fieldName is case sensitive.
Returns
The value for the key. If the value is in quotes, then these are stripped. An empty string is returned if the parameter is not found.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFileName()

std::string getFileName ( ) const

Returns the filename where the entry was loaded from.

Each entry keeps a copy of the filename, which can be useful for error reporting

Returns
the library filename

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMods()

int getMods | ( | std::vector< std::string > & | names,
 |  | std::vector< int > & | positions
 | ) |  | const

Returns the modifications.

Peptide modifications are specified in the comment line (see getComment()) and are given in the following format:

Mods=#/n,aa,tag/n,aa,tag...

Where

  • # is the number of modifications, with modifications separated by a forward slash "/" . Hence, Mods=0 denotes no modifications. Modifications are arranged in order of amino acid position and, if multiple modifications occur at a single position, they are arranged alphabetically by tag.
  • n is the position of the substituted amino acid, starting from 0
  • aa is the modified amino acid symbol
  • tag is the name of the modification. Ideally, this is the name defined in Unimod, but some library files may use a different convention.

For example:

Mods=2/0,A,Acetyl/8,M,Oxidation

Or files from NIST after 2017 had a different format:

Mods=1(7,C,CAM)
Mods=2(19,C,CAM)(20,C,CAM)

Or files generated by certain versions of Mascot Server:

Mods="2/0,G,Succinyl/11,K,IMID_2H(4)_NL (C-term K)"
Mods="3/6,N,2-succinyl (C)/10,N,2-succinyl (C)/12,Q,2-succinyl (C)"

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#

Parameters
[out] | names | are the names of the modifications.
[out] | positions | is zero based positions of the modifications.
Returns
the number of modifications.

◆ getMW()

double getMW ( ) const

Returns the molecular weight.

Taken from

MW: [exact molar mass of the peptide ion]

This is used for compatibility with electron-ionization spectra and is not used in the peptide library search; this line may be omitted.

Returns
the molecular weight

◆ getName()

std::string getName ( ) const

Returns the Name which is normally the sequence followed by /[CHARGE].

Each spectrum begins with the line in the format:

Name: [peptide sequence]/[charge]

for example

Name: AAAAAAGAGPEM(O)VR/2

where each amino acid in the [peptide sequence] is represented by the usual (upper case) letter sequence and [charge] is the positive charge on the peptide. The only modification explicitly shown is oxidized methionine as M(O).

For SpectraST files, a modification delta can be shown, for example:

Name: AAADALS[167]DLEIKDSK/2
Name: K.AADQADESSPLLS[167]PS[167]NSNHPSEHPQQDLNNK.S/4
Returns
name of the spectrum

◆ getNumPeaks()

int getNumPeaks ( ) const

Returns the number of peaks in the spectrum.

To get the peak list itself, call getPeakList

Returns
the number of peaks in the spectrum

◆ getPeakList()

std::vector< std::string > getPeakList ( bool convertToNISTformat = false ) const

Returns the peak list.

The format of the peak list is described in detail in this document.

Each peak is represented as a line divided into three tab separated fields:

[m/z][tab][relative abundance][tab]"[peak annotation(s)]"

For example:

196.1 41 "b3-18/-0.01 60/90 0.2"

For a SpectraST file, the format is slightly different:

311.0524 341.7 b4-18/-0.08 83/60 0.0981|0.54
325.1383 302.1 ? 67/60 0.0788|0.56

See also getPeakListObject()

MSPepsearch.exe does not return any results if there is no annotation on any peaks. If the input file had no annotation, and convertToNISTformat is true, then each peak is annotated with a "?"

For finer control over the format of the peak list, call getPeakListObject and then ms_spectral_lib_peak_list::asText

Parameters
convertToNISTformat determines the format. If this flag is false, then the string returned will be the same format as the text in the .msp or .sptxt file. If 'true', then the format is converted to the NIST format as described above.
Returns
the peak list in text format. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#

◆ getPeakListChecksum()

std::string getPeakListChecksum ( ) const

Returns an MD5 checksum for the peak list.

All spaces, tabs, newlines, carriage returns and quotation marks are removed before calculating the checksum

This is the checksum of the original 'file' entry before any annotations have been added, or format changes made.

For example: aj5r7ovt6b6q4wr7btazzd4s6i

Returns
the checksum as a string

◆ getPeakListObject()

ms_spectral_lib_peak_list getPeakListObject ( ) const

Returns the peak list object.

Returns
the peak list as a ms_spectral_lib_peak_list

◆ getPrecursorMZ()

double getPrecursorMZ ( ) const

Return the 'best available' precursor m/z value.

Returns
the "Mz_exact" value in the comment field if that exist, otherwise return the "Parent" value in the comment field. If neither are present, return 0.0

◆ getSequence()

std::string getSequence ( ) const

Returns the sequence.

Each spectrum begins with the line in the format:

Name: [peptide sequence]/[charge]

for example

Name: AAAAAAGAGPEM(O)VR/2

where each amino acid in the [peptide sequence] is represented by the usual (upper case) letter sequence and [charge] is the positive charge on the peptide. The only modification explicitly shown is oxidized methionine as M(O).

For SpectraST files, a modification delta can be shown, for example:

Name: AAADALS[167]DLEIKDSK/2
Name: K.AADQADESSPLLS[167]PS[167]NSNHPSEHPQQDLNNK.S/4

The charge is stripped from the end of this line, and all (O) and other mods are removed.

Returns
the sequence

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_spectral_lib_entry & operator= ( const ms_spectral_lib_entry & right )

C++ style assignment operator.

Parameters
right is the source to initialise from
Returns
reference to the current object
The documentation for this class was generated from the following files:
  • ms_spectral_lib_entry.hpp
  • ms_spectral_lib_entry.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_spectral_lib_file Class Reference

  • matrix_science
  • ms_spectral_lib_file
Public Member Functions | List of all members
ms_spectral_lib_file Class Reference
Mascot utilities and tools module

This class is used to encapsulate a complete NIST .msp, SpectraST .sptxt or X!Hunter ASL MGF file. More...

#include <ms_spectral_lib_file.hpp>

Inheritance diagram for ms_spectral_lib_file:
[legend]
Collaboration diagram for ms_spectral_lib_file:
[legend]

Public Member Functions

ms_spectral_lib_file (const char *fileName, const char *regexForAccession, const char *cdbFileName, const std::map< std::string, std::string > &modificationAliases)
Constructor just for C++, accepting a list of modification aliases.
ms_spectral_lib_file (const char *fileName, const char *regexForAccession, const char *cdbFileName=0)
Constructor.
~ms_spectral_lib_file ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::vector< int > | findEntries (const char *sequence, const char *checksum=0, const char *accession=0, const char *mods=0) const
Returns a list of entries that match the parameters.
std::string | getAccessionFromNumber (const int number) const
Returns the accession given the offset into the file.
std::vector< std::string > | getAllMods () const
Returns the complete list of mods named in the file.
std::string | getChecksumFromNumber (const int number) const
Returns the spectrum checksum given the offset into the file.
ms_spectral_lib_entry | getEntryFromNumber (const int number) const
Returns the individual spectrum from the msp file.
std::vector< std::string > | getEntryFromNumberAsText (const int number) const
Returns the individual spectrum from the msp file as a vector of strings.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns the full file path passed to the constructor.
ms_spectral_lib::FILE_FORMAT | getFormat () const
Returns the format of the file specified in the constructor.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getModsFromNumber (const int number) const
Returns the mods given the offset into the file.
int | getNumEntries () const
Returns the number of spectra in the msp file.
int | getNumResidues () const
Returns the number of residues in the msp file.
int | getPrecursorChargeFromNumber (const int number) const
Returns the precursor charge given the offset into the file.
double | getPrecursorMZFromNumber (const int number) const
Returns the precursor m/z value given the offset into the file.
long | getQmatch (double minMz, double maxMz) const
Return the number of spectra in the library with a precursor mass within the passed m/z range.
std::string | getSequenceFromNumber (const int number) const
Returns the spectrum peptide sequence given the offset into the file.
std::string | getStatsInformation () const
Returns some unstructured text giving some statistics for the file.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | saveAs (const char *fileName, const bool replaceProteinName=true, ms_spectral_lib::FILE_FORMAT fileFormat=ms_spectral_lib::FORMAT_NIST_MSP, const int startNumber=1, const int endNumber=-1, const ms_spectral_lib_entry::WHAT_TO_ANNOTATE whatToAnnotate=ms_spectral_lib_entry::ANNOTATE_REPLACE_QUESTION_MARKS, const double annotateTol=0.6, const char *annotateTolu="Da", const ms_umod_configfile *unimod=0) const
Save a copy of the file in the specified format.
bool | verifyThatModsAreInUnimod (const ms_umod_configfile &unimod)
The modifications listed should all be in the passed unimod file.

Detailed Description

This class is used to encapsulate a complete NIST .msp, SpectraST .sptxt or X!Hunter ASL MGF file.

Support for spectral library searches was added in Mascot Server 2.6 and Mascot Parser 2.6. Although external NIST software is used for the spectral library search itself, there is a requirement to process the msp and SpectraST files which are plain text.

This class is used to open an msp file, and an individual entries can be obtained using ms_spectral_lib_file::getEntryFromNumber

The format of the msp file is multiple lines, each with a [param][colon][space][value]. For example,

Name: AAAAAAAAAAAAAAAGAGAGAK/3
MW: 1598.861
Comment: Spec=Consensus Pep=Tryp
Num peaks: 150

followed by, in this case, 150 lines of peak data, followed by a blank line.

The format is defined here.

The SpectraST files (.sptxt) have minor differences, for example additional lines and a different format for the peak list. See saveAs() for details.

The X!Hunter ASL MGF format is described here.

See Spectral libraries for related information.

Constructor & Destructor Documentation

◆ ms_spectral_lib_file() [1/2]

ms_spectral_lib_file | ( | const char * | fileName,
 |  | const char * | regexForAccession,
 |  | const char * | cdbFileName = 0
 | ) |  |

Constructor.

Commonly used constructor.

The use of a cdb index file is optional. If one is specified in the constructor, and the file doesn't exist, or is incompatible, then the whole spectral library will be read and the index (re-) created during this constructor call. If no cdbFileName is specified, then the spectral library file will be opened, but only read on demand. For example, calling getNumEntries() obviously requires the whole file to be read, but calling getEntryFromNumber(1) only requires the first entry to be read.

The cdb index contains a lookup for the accessions found in the spectral library, and so is dependent on the regexForAccession. This means that if you try and create a ms_spectral_lib_file with a different regular expression, then the cdb file will be automatically re-created.

Parameters
fileName | is the full path to the spectral library file
regexForAccession | is the regular expression used to extract the accession from the protein description. If a regular expression is not defined, then it is not possible to search for or return an accession. If the regexForAccession is of the incorrect format, then ms_errs::ERR_MSP_COMPILE_PARSE_RULE errors will be raised.
cdbFileName | is the full path to the cdb index file for the library file.

◆ ms_spectral_lib_file() [2/2]

ms_spectral_lib_file | ( | const char * | fileName,
 |  | const char * | regexForAccession,
 |  | const char * | cdbFileName,
 |  | const std::map< std::string, std::string > & | modificationAliases
 | ) |  |

Constructor just for C++, accepting a list of modification aliases.

Constructor for C++

The use of a cdb index file is optional. If one is specified in the constructor, and the file doesn't exist, or is incompatible, then the whole spectral library will be read and the index (re-) created during this constructor call. If no cdbFileName is specified, then the spectral library file will be opened, but only read on demand. For example, calling getNumEntries() obviously requires the whole file to be read, but calling getEntryFromNumber(1) only requires the first entry to be read.

The cdb index contains a lookup for the accessions found in the spectral library, and so is dependent on the regexForAccession. This means that if you try and create a ms_spectral_lib_file with a different regular expression, then the cdb file will be automatically re-created.

Parameters
fileName | is the full path to the spectral library file
regexForAccession | is the regular expression used to extract the accession from the protein description. If a regular expression is not defined, then it is not possible to search for or return an accession. If the regexForAccession is of the incorrect format, then ms_errs::ERR_MSP_COMPILE_PARSE_RULE errors will be raised.
cdbFileName | is the full path to the cdb index file for the library file.
modificationAliases | are a map of modification aliases, such as "CAM" => "Carbamidomethyl". In Mascot Server, these are read from the library_mod_aliases file. The modification aliases are used in the created CDB file and when saveAs() is called.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ findEntries()

std::vector< int > findEntries | ( | const char * | sequence,
 |  | const char * | checksum = 0,
 |  | const char * | accession = 0,
 |  | const char * | mods = 0
 | ) |  | const

Returns a list of entries that match the parameters.

The library may contain multiple spectra for the same sequence and/or multiple spectra with the same checksum.

The function 'ands' all the parameters, so if sequence, checksum, accession and mods are all supplied, it will only return spectra which match all four parameters.

If a cdb index file has been created, then the lookup will be fast because an index is saved in the cdb file.

Use getEntryFromNumber() with each value from the returned list to get the relevant ms_spectral_lib_entry objects.

See also
ms_peptidesummary::getLibraryEntryId

Example code:

matrix_science::ms_peptidesummary pepsum(...);
std::vector<int> dbIdx, offset;
std::vector<std::string> checksum, mods;
pepsum.getLibraryEntryId(query, p, dbIdx, offset, checksum, mods);
if (!dbIdx.empty()) {
matrix_science::ms_peptide *pep;
if (pepsum.getPeptide(query, 1, pep)) {
std::vector<int> found = SLFile.findEntries(pep->getPeptideStr().c_str(), checksum[0].c_str(), 0, mods[0].c_str());
// If the spectral library file has not changed since the search
// was run then the 'offset' value[s] obtained from the results
// file will be the same as those returned from the findEntries call.
// However, if the spectral library file has changed since the
// search was run, but the original spectrum is still present in the
// updated spectral library file, but at a different offset,
// then it will be successfully returned using this
// ms_spectral_lib_file::findEntries() call
// Now, get the entry for each one (normally only one)
SLFile.getEntryFromNumber(found[x]);
}
}
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::getPeptideStr
std::string getPeptideStr(bool substituteAmbiguous=true, const PSM psmComponent=PSM_COMPLETE) const
Returns the sequence found for the peptide.
Definition: ms_peptide.cpp:710
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
Parameters
sequence | is the peptide sequence to find. It should just contain upper case A-Z
checksum | is the string that would be returned by ms_spectral_lib_entry::getPeakListChecksum()
accession | is matched to the accession retrieved from the Protein= entry in the comment line. The accession is extracted from the protein using the regular expression passed to the constructor
mods | is in the form exactly as in the spectral library file and as described in ms_spectral_lib_entry::getMods
Returns
a vector of 'numbers'. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getAccessionFromNumber()

std::string getAccessionFromNumber ( const int number ) const

Returns the accession given the offset into the file.

The accession retrived from the Protein= entry in the comment line. The accession is extracted from the protein using the regular expression passed to the ructor The number supplied has no relation to spectrum id returned by mspepsearch.exe and is normally obtained using findEntries()

Parameters
number must be in the range of 1..getNumEntries()
Returns
accession for the spectrum number passed in parameter

◆ getAllMods()

std::vector< std::string > getAllMods ( ) const

Returns the complete list of mods named in the file.

The order of the names is just the order that they appear in the file and there will be no duplicate names.

See ms_spectral_lib_entry::getMods for a description of the format in the msp file

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#

Returns
the list of modification names

◆ getChecksumFromNumber()

std::string getChecksumFromNumber ( const int number ) const

Returns the spectrum checksum given the offset into the file.

The number supplied has no relation to spectrum id returned by mspepsearch.exe and is normally obtained using findEntries()

Parameters
number must be in the range of 1..getNumEntries()
Returns
checksum for the spectrum number passed in parameter

◆ getEntryFromNumber()

ms_spectral_lib_entry getEntryFromNumber ( const int number ) const

Returns the individual spectrum from the msp file.

The number supplied has no relation to spectrum id returned by mspepsearch.exe. Either iterate through the whole file, using number = 1..getNumEntries() or use findEntries() to get the number.

If the function fails to load the entry, then a fatal error: ms_errs::ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY or ms_errs::ERR_MSP_NIST_INDEX_OUT_OF_RANGE is set in the returned ms_spectral_lib_entry object. Call ms_spectral_lib_entry::isValid() on the returned object to determine if it is safe to use it.

See also getEntryFromNumberAsText()

Parameters
number must be in the range of 1..getNumEntries()
Returns
an ms_spectral_lib_entry object

◆ getEntryFromNumberAsText()

std::vector< std::string > getEntryFromNumberAsText ( const int number ) const

Returns the individual spectrum from the msp file as a vector of strings.

The number supplied has no relation to spectrum id returned by mspepsearch.exe. Either iterate through the whole file, using number = 1..getNumEntries() or use findEntries() to get the number.

If the function fails to load the entry, then a fatal error: ms_errs::ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY or ms_errs::ERR_MSP_NIST_INDEX_OUT_OF_RANGE is set in this object. Call isValid() to determine if it is safe to use the returned vector of strings.

See also getEntryFromNumber()

Parameters
number must be in the range of 1..getNumEntries()
Returns
a vector of strings

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFileName()

std::string getFileName ( ) const

Returns the full file path passed to the constructor.

Returns
the file path.

◆ getFormat()

ms_spectral_lib::FILE_FORMAT getFormat ( ) const

Returns the format of the file specified in the constructor.

The file format of the file specified in the constructor is auto detected

Returns
the auto detected file format

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getModsFromNumber()

std::string getModsFromNumber ( const int number ) const

Returns the mods given the offset into the file.

The number supplied has no relation to spectrum id returned by mspepsearch.exe and is normally obtained using findEntries()

See ms_spectral_lib_entry::getMods for a description of the format in the msp file

Parameters
number must be in the range of 1..getNumEntries()
Returns
mods for the spectrum number passed in parameter

◆ getNumEntries()

int getNumEntries ( ) const

Returns the number of spectra in the msp file.

This value is retrieved from the cdb file if possible, or if no cdb file is specified, then the whole msp file will have to be parsed.

Returns
the number of spectra in the file.

◆ getNumResidues()

int getNumResidues ( ) const

Returns the number of residues in the msp file.

This value is retrieved from the cdb file if possible, or if no cdb file is specified, then the whole msp file will have to be parsed.

This is a slightly confusing number! It is the count of all of the residues in each sequence in the library. Just used because at the end of each Mascot search, we report the number of sequences and residues searched.

Returns
the number of residues in the file.

◆ getPrecursorChargeFromNumber()

int getPrecursorChargeFromNumber ( const int number ) const

Returns the precursor charge given the offset into the file.

For MSP files, the charge is taken from the Name: line

Parameters
number must be in the range of 1..getNumEntries()
Returns
the precursor charge for the spectrum

◆ getPrecursorMZFromNumber()

double getPrecursorMZFromNumber ( const int number ) const

Returns the precursor m/z value given the offset into the file.

There are several possible values in the Comment line to use for the precursor mz: Parent=865.409, Mz_exact=865.4092, Mz_av=865.898

This function returns the Mz_exact value if it exists, otherwise it returns the Parent= value.

In .sptxt files, there is also a separate PrecursorMZ: line, but this is currently not used.

See also getQmatch()

Parameters
number must be in the range of 1..getNumEntries()
Returns
the precursor m/z value for the spectrum

◆ getQmatch()

long getQmatch | ( | double | minMz,
 |  | double | maxMz
 | ) |  | const

Return the number of spectra in the library with a precursor mass within the passed m/z range.

This function calls getPrecursorMZFromNumber() to find the number of matches within a precursor mass range.

Parameters
minMz | Is the lower limit to consider
maxMz | Is the upper limit to consider
Returns
the number of entries in the library with a precursor mass between minMz and maxMz

◆ getSequenceFromNumber()

std::string getSequenceFromNumber ( const int number ) const

Returns the spectrum peptide sequence given the offset into the file.

The number supplied has no relation to spectrum id returned by mspepsearch.exe and is normally obtained using findEntries()

Parameters
number must be in the range of 1..getNumEntries()
Returns
sequence for the spectrum number passed in parameter

◆ getStatsInformation()

std::string getStatsInformation ( ) const

Returns some unstructured text giving some statistics for the file.

Returns
a free form multi-line text string

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ saveAs()

bool saveAs | ( | const char * | fileName,
 |  | const bool | replaceProteinName = true,
 |  | ms_spectral_lib::FILE_FORMAT | fileFormat = ms_spectral_lib::FORMAT_NIST_MSP,
 |  | const int | startNumber = 1,
 |  | const int | endNumber = -1,
 |  | const ms_spectral_lib_entry::WHAT_TO_ANNOTATE | whatToAnnotate = ms_spectral_lib_entry::ANNOTATE_REPLACE_QUESTION_MARKS,
 |  | const double | annotateTol = 0.6,
 |  | const char * | annotateTolu = "Da",
 |  | const ms_umod_configfile * | unimod = 0
 | ) |  | const

Save a copy of the file in the specified format.

SpectraST format files can be converted to files that will be read by NIST tools using this function

SpectraST and NIST (MSP) files differ in the following ways:

  • SpectraST files commonly have comments at the top. These are never written if the format is FORMAT_NIST_MSP
  • MSP files have the line: "Num peaks:" while SpectraST files have the line "NumPeaks:"
  • The peak list, following the "Num peaks:" or "NumPeaks:" in each entry has a different format
    • MSP files have 3 columns. The first column for m/z, the second for intensity and the third, in double quotes, is used for quoted annotations.
    • SpectraST files have 4 columns. The first two are idenctical to MSP files, but there are then two further columns for peak annotations that are unquoted.
Parameters
fileName | is the file to write to
replaceProteinName specifies if the Protein="..." field in the comment section should be replaced with Protein="[1..n]:checksum" where
  • 1..n is just the spectrum number offset in the file, and can be used with the getEntryFromNumber() function
  • checksum is the checksum of the spectrum as returned by ms_spectral_lib_entry::getPeakListChecksum
fileFormat | specifies the format as described above
startNumber | is the (index) number of the first spectrum to be saved. and should be in the range 1..getNumEntries(). The default value is 1
endNumber | is the (index) number of the last spectrum to be saved. and should be greater that startNumber and in the range 1..getNumEntries(). A value of -1 (the default) is used to specify that it should go the end of the file.
whatToAnnotate | is used to specify whether existing annotation should be replaced.
annotateTol | is the value in the units specified, for matching to the calculated data. Only peaks within this tolerance will be annotated. Other peaks will be annotated with a "?"
annotateTolu | must be "Da", "mmu" or "ppm".
unimod | is required if any entry has any modifications that are just specified by name. Otherwise, there is no way to calculate the fragment ion masses.
Returns
true if the file can be saved, false otherwise.

◆ verifyThatModsAreInUnimod()

bool verifyThatModsAreInUnimod ( const ms_umod_configfile & unimod )

The modifications listed should all be in the passed unimod file.

If any mods are not found, then a warning ms_errs::ERR_MSP_NIST_MODIFICATION_NOT_FOUND is added

Parameters
unimod is a reference to the unimod file
Returns
true if all modifications are listed in the passed unimod list
The documentation for this class was generated from the following files:
  • ms_spectral_lib_file.hpp
  • ms_spectral_lib_file.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_spectral_lib_peak Class Reference

  • matrix_science
  • ms_spectral_lib_peak
Public Member Functions | Static Public Member Functions | List of all members
ms_spectral_lib_peak Class Reference
Mascot utilities and tools module

This class is used to encapsulate a single fragment ion in a NIST .msp or a SpectraST .sptxt file. More...

#include <ms_spectral_lib_peak.hpp>

Public Member Functions

ms_spectral_lib_peak (const double mz, const double intensity, const std::string &annotation, ms_spectral_lib::FILE_FORMAT format)
Constructor.
ms_spectral_lib_peak (const ms_spectral_lib_peak &src)
Copying constructor.
ms_spectral_lib_peak (const std::string &text, ms_spectral_lib::FILE_FORMAT format, matrix_science::ms_errs &errs)
Preferred constructor.
std::string | asText (ms_spectral_lib::FILE_FORMAT format) const
Returns a 'line' with the peak m/z, intensity and annotation as text.
void | clearAnnotation ()
Clear any annotation for the peak.
void | copyFrom (const ms_spectral_lib_peak *right)
Use this member to make a copy of another instance.
std::string | getAnnotation (ms_spectral_lib::FILE_FORMAT format=ms_spectral_lib::FORMAT_NIST_MSP) const
Return annotations for the peak.
bool | getConsensusData (int *numerator, int *denominator, double *medianDeviation) const
For experamental data taken from a number of spectra, some statistics are available.
double | getDelta () const
Return the difference between the calculated and experimental value for the peak.
double | getIntensity () const
Return the intensity for the peak.
double | getMz () const
Return the mass over charge value for the peak.
bool | isMatchedToCalculatedPeak () const
Some peaks appear in spectra, but are no matching expected fragment is found.
bool | isSuspectAssignment () const
Returns true if the assignment to a calculated peak is not uncertain.
bool | isValid () const
Return true if the peak contains valid data.
ms_spectral_lib_peak & | operator= (const ms_spectral_lib_peak &right)
C++ style assignment operator.
void | setAnnotation (const std::string &annotation, ms_spectral_lib::FILE_FORMAT format)
Set annotations for the peak.

Static Public Member Functions

static std::string getUnmatchedAnnotationStr (ms_spectral_lib::FILE_FORMAT format)
Static function to return the string used to indicate that a peak wasn't matched when the library entry was generated.

Detailed Description

This class is used to encapsulate a single fragment ion in a NIST .msp or a SpectraST .sptxt file.

Constructor & Destructor Documentation

◆ ms_spectral_lib_peak() [1/3]

ms_spectral_lib_peak | ( | const std::string & | text,
 |  | ms_spectral_lib::FILE_FORMAT | format,
 |  | matrix_science::ms_errs & | errs
 | ) |  |

Preferred constructor.

The advantage of using this constructor is that when asText() is called, the returned line will contain m/z and intensity with exactly the same number of decimal places.

Each peak is represented as a line divided into three tab separated fields:

[m/z][tab][relative abundance][tab]"[peak annotation(s)]"

Tabs or spaces are suitable separators.

If the m/z and intensity cannot be read, then isValid() will return false.

Parameters
text | is the input line in the above format
format | is one of the ms_spectral_lib::FILE_FORMAT values.
errs | is used to add any error found if the text is not of the correct format

◆ ms_spectral_lib_peak() [2/3]

ms_spectral_lib_peak | ( | const double | mz,
 |  | const double | intensity,
 |  | const std::string & | annotation,
 |  | ms_spectral_lib::FILE_FORMAT | format
 | ) |  |

Constructor.

An ms_spectral_lib_peak object is normally created by calling ms_spectral_lib_peak_list::getPeak()

Parameters
mz | is the fragment m/z value
intensity | is the fragment intensity
annotation | is the fragment annotation. See getAnnotation() for details.
format | is one of the ms_spectral_lib::FILE_FORMAT values. It format is ms_spectral_lib::FORMAT_NIST_MSP then annotation should be in quotes.

◆ ms_spectral_lib_peak() [3/3]

ms_spectral_lib_peak ( const ms_spectral_lib_peak & src )

Copying constructor.

Parameters
src is the source to initialise from

Member Function Documentation

◆ asText()

std::string asText ( ms_spectral_lib::FILE_FORMAT format ) const

Returns a 'line' with the peak m/z, intensity and annotation as text.

For ms_spectral_lib::FORMAT_MGF and ms_spectral_lib::FORMAT_XHUNTER there will be no annotation text.

See also
getAnnotation()
Parameters
format is one of the ms_spectral_lib::FILE_FORMAT formats
Returns
the line of text

◆ clearAnnotation()

void clearAnnotation ( )

Clear any annotation for the peak.

Does not change the file format associated with the peak

◆ copyFrom()

void copyFrom ( const ms_spectral_lib_peak * right )

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getAnnotation()

std::string getAnnotation ( ms_spectral_lib::FILE_FORMAT format = ms_spectral_lib::FORMAT_NIST_MSP ) const

Return annotations for the peak.

This function can, in theory, return the annotation data in any available format. However, there is a current limitation that it will only return in the format that it was saved in. Specifically, it cannot convert between ms_spectral_lib::FORMAT_NIST_MSP and ms_spectral_lib::FORMAT_SPECTRAST

The ms_spectral_lib::FORMAT_NIST_MSP format includes double quotes round the returned string

NIST MSP Format

Examples:

 "b2i/1.03 12/21 0.1"
 "b2/0.03,b4-44^2/0.03 21/21 1.3"
 "p-46/-0.12 60/100 4.0"
 "? 31/61 0.4"
 "Int/AC/0.1 11/12 0.2"

The first character(s) denote the type, and will be one of the following:

  • y or b or a are the ion types. These are followeded by a number denoting the position in the peptide.
  • p is used to denote the peak is a precursor peak.
  • ? is used to denote that the mass cannot be assigned to a known fragment type.
  • Int is used to denote internal ions. In this case, the sequence is denoted by /SEQ
  • I is used to denote immonium ions. This is followed by XY where 'X' is the parent amino acid and Y are letters A,B,C.. used to distinguish different immonium products of the amino acid X.

Following the first character, and before the '/' there are additional options:

  • A neutral loss is indicated by a '-' followed by the loss. For example: y6-18 specifies loss of water on y ion at residue 6.
  • 13C peaks are denoted with a following i
  • A * is appended if the peak assignment is suspect
  • ^c denotes a charge > 1, where c is the charge

There is then a / followed by the difference between measured m/z and theoretical (exact) m/z. For unknown fragments, there is obviously no delta.

If a second assignment is possible, a second, comma-separated full assignment is given as in an example above.

For consensus spectra, a space follows the assignment(s), after which is given the number of replicate spectra having that peak and the minimum number of spectra required for that peak to have been reported � these numbers are separated by a �/�. A space follows, after which the median deviation of m/z (in 1/100th of an m/z) of the peaks in the original spectra used to create that peak.

SpectraST format

Examples:

b5/-0.07
y9-17^2/-0.08,y9-18^2/0.41
[y26^3/-0.1236]

Described here as:

SpectraST's syntax to annotate a fragment follows the scheme proposed by Roepstorff and Fohlman.

An annotation tag starts with the assigned ion type (a,b,c,x,y or z) and is followed by the number of amino acid residues present in the fragment. This number is possibly followed by a signed integer value, indicating a modification. Please note that besides post-translational modifications also loss of water (-18) and loss of ammonia (-17), e.g., are taken into account. The caret symbol '^' followed by an integer value depicts the charge state of the fragment. Its absence indicates a singly charged fragment ion. An additional 'i' at the end of the annotation tag implies that the mass value does not correspond to the expected mass value of the monoisotopic peak, but can be assigned to a different isotopic peak of the fragment. Finally, the annotation pattern contains the average mass deviation (in Da) from the theoretically expected mass. A slash '/' preceds this number.

The list of possible annotations is ordered by ascending charge states, where ties are broken by ascending mass deviations.

Annotation tags can be enclosed by square brackets, indicating that several peaks could be assigned the same particular ion. Usually, SpectraST would resolve such a situation by annotating only one of the ions and leaving the other ones blank. If data is not (sufficiently) centroided, this strategy might lead to a buch of unresolved peaks, which might in turn cause quality filters to fail. To circumvent this problem, if there are additional intense peaks that look to be the same ion, a bracketed annotation will be given to them.

Besides annotations following the Roepstorff/Fohlman notation SpectraST also assigns immonium ions. The corresponding tag consists of 3 capital letters, always starting with an 'I' (for immonium), followed by the amino acid and an additional letter to designate different residue-specific ions from that amino acid.

ms_spectral_lib::FORMAT_MGF and ms_spectral_lib::FORMAT_XHUNTER

This will return an empty string.

Parameters
format is one of the ms_spectral_lib::FILE_FORMAT formats
Returns
annotation

◆ getDelta()

double getDelta ( ) const

Return the difference between the calculated and experimental value for the peak.

If isMatchedToCalculatedPeak() returns false, then the returned value will be -999.0 as there can be no calculated delta. In other cases, no delta is provided in the file, for example:

1022.3 [tab] 340 [tab] "Int-18/AFTECCQAAD/ 46/53 1.7"

and -999 is also returned in this case.

Returns
the delta in m/z

◆ getIntensity()

double getIntensity ( ) const

Return the intensity for the peak.

Returns
the intensity of the the peak

◆ getMz()

double getMz ( ) const

Return the mass over charge value for the peak.

Returns
the mass over charge value for the peak

◆ getUnmatchedAnnotationStr()

std::string getUnmatchedAnnotationStr ( ms_spectral_lib::FILE_FORMAT format )
static

Static function to return the string used to indicate that a peak wasn't matched when the library entry was generated.

For ms_spectral_lib::FORMAT_NIST_MSP this returns "?" (quotes are included)

Parameters
format is one of the ms_spectral_lib::FILE_FORMAT values.
Returns
"?" for ms_spectral_lib::FORMAT_NIST_MSP and ? for ms_spectral_lib::FORMAT_SPECTRAST

◆ isMatchedToCalculatedPeak()

bool isMatchedToCalculatedPeak ( ) const

Some peaks appear in spectra, but are no matching expected fragment is found.

If a peak was matched to a calculated fragment, then this will return true. If the string returned from getAnnotation() is empty or contains a '?' then no match was found, and this function will return false.

Returns
true if the peak matched to a calculated match.

◆ isSuspectAssignment()

bool isSuspectAssignment ( ) const

Returns true if the assignment to a calculated peak is not uncertain.

Returns true if the annotation contains a '*' or if there is no annotation. The NIST documentation is not entirely clear on the meaning of this flag, since a ? may or may not be followed by a '*'

Returns
true if annotation is not empty and contains *, false otherwise

◆ isValid()

bool isValid ( ) const

Return true if the peak contains valid data.

Returns
false if the constructor taking a text string contains a string that cannot be parsed. Otherwise, it will return true;

◆ operator=()

ms_spectral_lib_peak & operator= ( const ms_spectral_lib_peak & right )

C++ style assignment operator.

Parameters
right is the source to initialise from
Returns
reference to the current object

◆ setAnnotation()

void setAnnotation | ( | const std::string & | annotation,
 |  | ms_spectral_lib::FILE_FORMAT | format
 | ) |  |

Set annotations for the peak.

For ms_spectral_lib::FORMAT_NIST_MSP the annotation string should include the double quotes

Parameters
annotation | annotation to set
format | is the ms_spectral_lib::FILE_FORMAT
The documentation for this class was generated from the following files:
  • ms_spectral_lib_peak.hpp
  • ms_spectral_lib_peak.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_spectral_lib_peak_list Class Reference

  • matrix_science
  • ms_spectral_lib_peak_list
Public Types | Public Member Functions | List of all members
ms_spectral_lib_peak_list Class Reference
Mascot utilities and tools module

This class is used to encapsulate a peak list from a single spectrum in a NIST .msp or a SpectraST .sptxt file. More...

#include <ms_spectral_lib_peak_list.hpp>

Inheritance diagram for ms_spectral_lib_peak_list:
[legend]
Collaboration diagram for ms_spectral_lib_peak_list:
[legend]

Public Types

enum PEAK_ANNOTATION_LEVEL {
ANNOT_LVL_NONE ,
ANNOT_LVL_QUESTION_MARKS ,
ANNOT_LVL_SOME_PEAKS ,
ANNOT_LVL_CANNOT_ANNOTATE
}
Amount of annotation as returned by getAnnotationLevel() More...

Public Member Functions

ms_spectral_lib_peak_list ()
Constructor.
ms_spectral_lib_peak_list (const ms_spectral_lib_peak_list &src)
Copying constructor.
ms_spectral_lib_peak_list (std::vector< std::string > input, ms_spectral_lib::FILE_FORMAT format)
Constructor from a peak list in NIST format.
~ms_spectral_lib_peak_list ()
Destructor.
void | addPeaks (const std::vector< double > &vecMz, const std::vector< double > &vecIntensity)
add peaks from masses and intensities
void | annotatePeaks (const ms_fragmentvector *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz)
annotate peaks for the given tolerance.
void | annotatePeaks (const std::vector< ms_fragment > *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz)
annotate peaks for the given tolerance, from a C++ vector.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
std::vector< std::string > | asText (ms_spectral_lib::FILE_FORMAT format) const
Return the whole peak list as an array of strings.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearAnnotation ()
Removes all annotation from all peaks.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_spectral_lib_peak_list *right)
Use this member to make a copy of another instance.
std::string | getChecksum () const
Return the 'checksum' for the original peak list before any calls to annotatePeaks.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumPeaks () const
Returns the number of peaks in the peak list.
const ms_spectral_lib_peak * | getPeak (const int pkNum) const
Return a single peak.
PEAK_ANNOTATION_LEVEL | getPeakAnnotationLevel () const
Return information about the amount of peak annotation - i.e. what experimental peaks matched to calculated peaks.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_spectral_lib_peak_list & | operator= (const ms_spectral_lib_peak_list &right)
C++ style assignment operator.
void | setAnnotationLevel (PEAK_ANNOTATION_LEVEL level)

Detailed Description

This class is used to encapsulate a peak list from a single spectrum in a NIST .msp or a SpectraST .sptxt file.

Member Enumeration Documentation

◆ PEAK_ANNOTATION_LEVEL

enum PEAK_ANNOTATION_LEVEL

Amount of annotation as returned by getAnnotationLevel()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

See ms_spectral_lib_peak::getAnnotation for a description of the annotation format.

Most files supplied by NIST have annotation, but PRIDE files don't have any annotation.

Enumerator
ANNOT_LVL_NONE | None of the peaks have any annotation.
ANNOT_LVL_QUESTION_MARKS | In Parser 2.6.0, when calling ms_spectral_lib_file::saveAs(), the resulting file adds "?" to each peak without annotation. At least one peak has a question mark, and none have any 'matching' annotation.
ANNOT_LVL_SOME_PEAKS | One or more peaks have annotation that is not just a "?".
ANNOT_LVL_CANNOT_ANNOTATE | A call to ms_spectral_lib_entry::annotatePeaks() or ms_spectral_lib_peak_list::annotatePeaks() failed to annotate the peak list.

Constructor & Destructor Documentation

◆ ms_spectral_lib_peak_list() [1/2]

ms_spectral_lib_peak_list | ( | std::vector< std::string > | input,
 |  | ms_spectral_lib::FILE_FORMAT | format
 | ) |  |

Constructor from a peak list in NIST format.

An ms_spectral_lib_peak_list object is nomally created by calling ms_spectral_lib_entry::getPeakListObject rather than calling this constructor which simply creates the ms_spectral_lib_peak objects using this constructor.

Leading and trailing white space is removed from each line.

Any format errors will be set in this object and isValid() will then return false.

Parameters
input | is a vector or raw strings from the .msp file.
format | is one of the ms_spectral_lib::FILE_FORMAT values.

◆ ms_spectral_lib_peak_list() [2/2]

ms_spectral_lib_peak_list ( const ms_spectral_lib_peak_list & src )

Copying constructor.

Parameters
src is the source to initialise from

Member Function Documentation

◆ addPeaks()

void addPeaks | ( | const std::vector< double > & | vecMz,
 |  | const std::vector< double > & | vecIntensity
 | ) |  |

add peaks from masses and intensities

Note that both vectors MUST have the same size.

Existing peaks are not removed.

Parameters
vecMz | vector of m/z values
vecIntensity | vector of intensity values

◆ annotatePeaks() [1/2]

void annotatePeaks | ( | const ms_fragmentvector * | fragments,
 |  | const double | fragmentToleranceValue,
 |  | const std::string | fragmentToleranceUnit,
 |  | double | precursorMz
 | ) |  |

annotate peaks for the given tolerance.

See also
annotatePeaks(const std::vector<ms_fragment> *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz)
Parameters
fragments | to a vector of fragments to be used for annotation
fragmentToleranceValue | fragment tolerance as a double
fragmentToleranceUnit | fragment tolerance unit (ppm, %, mmu or Da)
precursorMz | m/z value of the precursor, used to annotate a peak with a p class (p for precursor)

◆ annotatePeaks() [2/2]

void annotatePeaks | ( | const std::vector< ms_fragment > * | fragments,
 |  | const double | fragmentToleranceValue,
 |  | const std::string | fragmentToleranceUnit,
 |  | double | precursorMz
 | ) |  |

annotate peaks for the given tolerance, from a C++ vector.

Annotate the peaks stored in the object according to the NIST format, if the provided format is different, the NIST format will still be used. The existing annotation on peaks is overriden. All annotations are between double quotes.

Note that default values are used for the mass of Nitrogen, Helium, Oxygen and Carbon, the mono-isotopic type of these values are used. If a peak cannot be encoded in MSP format (for example for w ion series), or if there is no matching fragment, the annotation of the peak will be "?". Ion series c, x and z are not accepted in the MSP format; ion series b, y and y are respectively used instead with a differential neutral loss.

Parameters
fragments | to a vector of fragments to be used for annotation, it doesn't have to be sorted
fragmentToleranceValue | fragment tolerance as a double
fragmentToleranceUnit | fragment tolerance unit (ppm, %, mmu or Da)
precursorMz | m/z value of the precursor, used to annotate a peak with a p class (p for precursor)

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ clearAnnotation()

void clearAnnotation ( )

Removes all annotation from all peaks.

Does not change the file format associated with each peak.

See also ms_spectral_lib_peak::clearAnnotation

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_spectral_lib_peak_list * right )

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getChecksum()

std::string getChecksum ( ) const

Return the 'checksum' for the original peak list before any calls to annotatePeaks.

All spaces, tabs, newlines, carriage returns and quotation marks are removed before calculating the checksum

This is the checksum of the original 'file' entry before any annotations have been added, or format changes made.

For example: aj5r7ovt6b6q4wr7btazzd4s6i

Returns
the checksum as a string

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getNumPeaks()

int getNumPeaks ( ) const

Returns the number of peaks in the peak list.

Returns
the number of peaks in the list

◆ getPeak()

const ms_spectral_lib_peak * getPeak ( const int pkNum ) const

Return a single peak.

Parameters
pkNum must be in the range 1..getNumPeaks()
Returns
a pointer to the peak object, or 0 if pkNum is out of range

◆ getPeakAnnotationLevel()

ms_spectral_lib_peak_list::PEAK_ANNOTATION_LEVEL getPeakAnnotationLevel ( ) const

Return information about the amount of peak annotation - i.e. what experimental peaks matched to calculated peaks.

Returns
one of the ms_spectral_lib_peak_list::PEAK_ANNOTATION_LEVEL values

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_spectral_lib_peak_list & operator= ( const ms_spectral_lib_peak_list & right )

C++ style assignment operator.

Parameters
right is the source to initialise from
Returns
reference to the current object

◆ setAnnotationLevel()

void setAnnotationLevel ( PEAK_ANNOTATION_LEVEL level )
Parameters
level is the new annotation level
The documentation for this class was generated from the following files:
  • ms_spectral_lib_peak_list.hpp
  • ms_spectral_lib_peak_list.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_tinycdb Class Reference

  • matrix_science
  • ms_tinycdb
Public Member Functions | List of all members
ms_tinycdb Class Reference
Mascot utilities and tools module

Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokarev. More...

#include <ms_tinycdb.hpp>

Inheritance diagram for ms_tinycdb:
[legend]
Collaboration diagram for ms_tinycdb:
[legend]

Public Member Functions

ms_tinycdb (const char *indexFileName, const char *versionNumber, const char *sourceFileName)
Constructor for creating or reading a CDB index file.
~ms_tinycdb ()
Destructor closes any files and frees memory.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | closeIndexFile ()
Close index file.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
bool | finishCreate ()
Finish creating the index file and open it for reading.
std::vector< std::string > | getAllValuesFromKey (const std::string &keyName)
Returns the text values for a key associated with the key name.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
OFFSET64_T | getFileOffsetFromKey (const std::string &keyName)
A useful function for returning file indexes.
std::string | getIndexFileName () const
Return the full path to index file.
int | getIntFromKey (const std::string &keyName)
Return an integer value associated with a key.
int | getIntFromKey (const std::string &keyName, bool &found)
Return an integer value associated with a key and flag to indicate if the value was found in the CDB file.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getValueFromKey (const std::string &keyName, const int count=0)
Returns the text value of a key associated with the key name.
bool | isCreating () const
Return true if the file is open for writing.
bool | isOpenForReading () const
Check to see that the file is valid and open for reading.
bool | isPossibleToCreate () const
Check to see if the index file can be created.
bool | isValid () const
Call this function to determine if there have been any errors.
int | makeExists (const char *key) const
See if a key exists while making the file.
bool | openIndexFile (const bool mayRetryBuilding)
Open, or try to open an index file.
bool | prepareToCreate ()
Start creating the index file.
bool | saveFileOffsetForKey (const std::string &keyName, OFFSET64_T offset)
A useful function for storing file indexes.
bool | saveIntForKey (const std::string &keyName, int value)
Store an integer value associated with a key.
bool | saveValueForKey (const char *keyName, const char *value, const unsigned int keyNameLen=0, const unsigned int valueLen=0)
Add a key/value pair to the file.
void | setIndexFileName (const char *filename)
Set the index file name.

Detailed Description

Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokarev.

ms_tinycdb is a utility for creating and using a 'static' or 'constant' (read-only) database of arbitrary key/value pairs.

After creating the ms_tinycdb object, call openIndexFile(). If this returns true, then the index file exists, is complete, and values can be retrieved by calling the getValueFromKey() function.

If openIndexFile() returns false, it is because the index file does not exist, is incomplete, out of date or corrupt. To determine the reason, call getLastError() or getLastErrorString(). If the file exists, but for example is incomplete, it is possible that it is worth trying to create it again. The function isPossibleToCreate() will return true if it is worth trying to (re-)create the file. See the documentation for openIndexFile() for a full list of errors.

To create an index file, call prepareToCreate() first, and then call saveValueForKey(), saveFileOffsetForKey() or saveIntForKey() to to save all the key/value pairs that are required. Finally, call finishCreate() to close the index file. Once finishCreate() has been called, the file is then automatically opened again for reading.

The keyName values can be any text, except values starting with =0. which are reserved for internal use:

  • =0.1 : For duplicate accessions with .cdb files created for Mascot results files.
  • =0.2 : The version string (if any) supplied to the constructor.
  • =0.3 : Used for cases where the CDB file is larger than the maximum allowed.
  • =0.4 : The 'source' file size.
  • =0.5 : The 'source' file date.

These values can be retrieved, for example by passing a value of "=0.2" to getValueFromKey().

Pseudo code for opening/creaing a file with just one value:

create new ms_tinycdb
if !tinycdb->openIndexFile() then
  if tinycdb->getLastError() ==  ERR_CDB_BEING_CREATED) then
    print "Another task is creating the index file, try again later"
  else if tinycdb->isPossibleToCreate() then
    print "(Re)-creating index file because : " . tinycdb->getLastErrorString()
    if tinycdb->prepareToCreate()
      tinycdb->saveValueForKey("MyKey", "MyValue");
      tinycdb->finishCreate()
    else
      print "Cannot create index file because : " . tinycdb->getLastErrorString()
  else
    print "Cannot create index file because : " . tinycdb->getLastErrorString()
end if

# We've either just created the index file or it was created some time ago
if tinycdb->isValid() then
  print "My value = " . tinycdb->getValueFromKey("MyKey");
end if

See also the Examples for the Mascot tools module.

Constructor & Destructor Documentation

◆ ms_tinycdb()

ms_tinycdb | ( | const char * | indexFileName,
 |  | const char * | versionNumber,
 |  | const char * | sourceFileName
 | ) |  |

Constructor for creating or reading a CDB index file.

The constructor does not attempt to open or create an index file. The constructor will only fail if it is run on a big endian system, so there is currently no need to call isValid() after creating the object.

Parameters
indexFileName | is the full path to the index file. If it isn't specified here, then call setIndexFileName() before calling openIndexFile() or prepareToCreate().
versionNumber | is a string that defines the version of the index file. This value should be changed whenever the calling application changes the indexes saved in the file in a way that is not backward compatible. If an empty string is passed, then the the version number will not be saved in the index file and there will be no check for consistency.
sourceFileName | is an optional path to the 'source' of the index. If an index is based on a particular file (e.g. a Mascot results file), it may be useful to check if the file has changed size or date, because the index probably then needs to be rebuilt. If the size and date of the files differ, then the ms_errs::ERR_CDB_SOURCE_CHANGE_RETRY or ms_errs::ERR_CDB_SOURCE_CHANGE_NO_RETRY error will be set. If this parameter is an empty string, then no checking will be performed.

◆ ~ms_tinycdb()

~ms_tinycdb ( )

Destructor closes any files and frees memory.

The index file is left open for reading until the destructor is called. In version 2.3.2 and earlier, the whole file is memory mapped, which can require a significant address space overhead for the calling application. In version 2.3.3 and later, the memory required is reduced to a few kB.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ closeIndexFile()

void closeIndexFile ( )

Close index file.

This function is called when the object is destroyed. You may wish to call it from an application if, for example, you load a file and then find the file is invalid when you test a user defined key. This means that it is only necessary to call isOpenForReading() in your client code.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ finishCreate()

bool finishCreate ( )

Finish creating the index file and open it for reading.

Returns
Currently always returns true

◆ getAllValuesFromKey()

std::vector< std::string > getAllValuesFromKey ( const std::string & keyName )

Returns the text values for a key associated with the key name.

See also
getValueFromKey()
Parameters
keyName is the name of the key. It should not start with =0. as this is used for the version number and other internal values.
Returns
values as a vector of strings for the given key. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFileOffsetFromKey()

OFFSET64_T getFileOffsetFromKey ( const std::string & keyName )

A useful function for returning file indexes.

This function is useful for accessing file indexes that have been stored in a CDB file. To provide a quick look up into a source file (for example a Mascot results file), keys are used to store a byte offset into the file. The advantage of using these functions is that the offset is saved as a binary value and is always more compact than saving it in text format. One disadvantage of these functions is that there is currently no conversion between little endian and big endian format, so index files could not be moved between little endian and big endian systems.

Perl: 64 bit integer support is not available in all versions of Perl, so the saveIntForKey() and getIntFromKey() functions take 32 bit offsets on 32 bit versions of Perl. If used for file offsets, the file size limit is then 2Gb when using those functions.

Parameters
keyName is the name of the key. In C++, this key value may contain binary information. In other languages, it must be standard text.
Returns
the offset, or 0 if it is not found.

◆ getIntFromKey() [1/2]

int getIntFromKey ( const std::string & keyName )

Return an integer value associated with a key.

This function is useful for retrieving an integer value from a CDB file. See also getFileOffsetFromKey() for using 64 bit integer values.

The advantage of using this function rather than getValueFromKey() is that the value is saved as a binary value and is always more compact than saving it in text format. One disadvantage of this function is that there is currently no conversion between little endian and big endian format, so index files could not be moved between little endian and big endian systems.

See also
saveIntForKey()
Parameters
keyName is the name of the key. In C++, this key value may contain binary information. In other languages, it must be standard text.
Returns
the offset, or 0 if it is not found.

◆ getIntFromKey() [2/2]

int getIntFromKey | ( | const std::string & | keyName,
 |  | bool & | found
 | ) |  |

Return an integer value associated with a key and flag to indicate if the value was found in the CDB file.

This function is useful for retrieving an integer value from a CDB file. See also getFileOffsetFromKey() for using 64 bit integer values.

The advantage of using this function rather than getValueFromKey() is that the value is saved as a binary value and is always more compact than saving it in text format. One disadvantage of this function is that there is currently no conversion between little endian and big endian format, so index files could not be moved between little endian and big endian systems.

See also
saveIntForKey()
Parameters
keyName | is the name of the key. In C++, this key value may contain binary information. In other languages, it must be standard text.
found | will be set to true if the value is found in the CDB file and false if it is not found.
Returns
the offset, or 0 if it is not found.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getValueFromKey()

std::string getValueFromKey | ( | const std::string & | keyName,
 |  | const int | count = 0
 | ) |  |

Returns the text value of a key associated with the key name.

Note, if you want to call this method with a high value for count, it is advised to use getAllValuesFromKey() instead, which is much more efficient.

See also
saveValueForKey()
getAllValuesFromKey()
Parameters
keyName | is the name of the key. It should not start with =0. as this is used for the version number and other internal values.
count | should be zero unless multiple occurrences of the key are expected in the file.
Returns
value as a string for the given key

◆ isCreating()

bool isCreating ( ) const

Return true if the file is open for writing.

If prepareToCreate() returns true, then the file is open for writing

Returns
true if the cdb file is open for writing.

◆ isOpenForReading()

bool isOpenForReading ( ) const

Check to see that the file is valid and open for reading.

Returns
true if the index is useable.

◆ isPossibleToCreate()

bool isPossibleToCreate ( ) const

Check to see if the index file can be created.

This function will return true unless one of the following errors have occurred:

  • ms_errs::ERR_CDB_BEING_CREATED
  • ms_errs::ERR_CDB_TOO_LARGE
  • ms_errs::ERR_CDB_FAIL_REMOVE
Returns
True if the calling application should try and (re)build the index file.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ makeExists()

int makeExists ( const char * keyName ) const

See if a key exists while making the file.

Should only be called while creating an index file.

Parameters
keyName is the name of the key for the key/value pair.
Returns
A value of 1 if the key already exists.

◆ openIndexFile()

bool openIndexFile ( const bool mayRetryBuilding )

Open, or try to open an index file.

After creating an ms_tinycdb object, call this function to try and open the file. If the file is opened successfully, the function will return true. If it returns false, one or more of the following errors will be set and can be retrieved using getLastError().

ms_errs::ERR_MISSING_CDB_FILE:

The file does not exist or cannot be opened.

ms_errs::ERR_CDB_FAIL_LOCK and ms_errs::ERR_CDB_BEING_CREATED:

The index file is locked, probably because another process is writing to it. The calling application can decide to wait before retrying or to continue without the index if that is possible.

ms_errs::ERR_FAIL_CDB_INIT:

Normally because the index file is incomplete.

ms_errs::ERR_CDB_INCOMPLETE_RETRY or ms_errs::ERR_CDB_INCOMPLETE_NO_RETRY:

If a versionNumber has been specified in the constructor, but there is no key/value pair for the version (using the reserved internal key "=0.2"), then one of these errors is set. Which of the two errors is reported, depends on the mayRetryBuilding parameter.

ms_errs::ERR_CDB_OLD_VER_RETRY or ms_errs::ERR_CDB_OLD_VER_NO_RETRY:

If a versionNumber has been specified in the constructor, and there is a key/value pair for the version (using the reserved internal key "=0.2"), and the version string is different, then one of these errors is set. Which of the two errors is reported, depends on the mayRetryBuilding parameter.

ms_errs::ERR_CDB_SOURCE_CHANGE_RETRY or ms_errs::ERR_CDB_SOURCE_CHANGE_NO_RETRY:

If a sourceFileName has been specified in the constructor then the size and last modified date are compared with the key/value pairs in the index file using the reserved keys "=0.4" and "=0.5". If the values differ, one of these errors is reported. Which of the two errors is reported, depends on the mayRetryBuilding parameter.

ms_errs::ERR_CDB_TOO_LARGE or ms_errs::ERR_CDB_64_BIT_REMAKE:
The maximum size of an index file in Mascot Parser 2.3.3 and earlier was 2GB for a 32 bit application and 4GB for a 64 bit application because the offsets stored in the file were 32 bit. If the index file approaches this size then a value is saved in the partially complete file using the reservered key "=0.3" and this error is set. The maximum file size for Mascot Parser 2.4.1 and later is 256TB. If the file was originally created using an earlier version of Mascot Parser then it is worth trying to re-create the file. If the mayRetryBuilding flag is set then the second error is reported.
Parameters
mayRetryBuilding should be set to true if an attempt may be made to rebuild the index file if it is incomplete or if it is the wrong version. This just effects the errors put into the ms_errs object. For example, it would use ms_errs::ERR_CDB_OLD_VER_RETRY rather than ms_errs::ERR_CDB_OLD_VER_NO_RETRY.
Returns
true if the file was opened successfully.

◆ prepareToCreate()

bool prepareToCreate ( )

Start creating the index file.

To create an index file, call this function first, and then call saveValueForKey(), saveFileOffsetForKey() or saveIntForKey() to to save all the key/value pairs that are required. Finally, call finishCreate() to close the index file and open it again for reading.

Returns
true if the file is created successfully.

◆ saveFileOffsetForKey()

bool saveFileOffsetForKey | ( | const std::string & | keyName,
 |  | OFFSET64_T | offset
 | ) |  |

A useful function for storing file indexes.

This function is useful for accessing file indexes that have been stored in a CDB file. To provide a quick look up into a source file (for example a Mascot results file), keys are used to store a byte offset into the file. The advantage of using these functions is that the offset is saved as a binary value and is always more compact than saving it in text format. One disadvantage of these functions is that there is currently no conversion between little endian and big endian format, so index files could not be moved between little endian and big endian systems.

Perl: 64 bit integer support is not available in all versions of Perl, so the saveIntForKey() and getIntFromKey() functions take 32 bit offsets on 32 bit versions of Perl. If used for file offsets, the file size limit is then 2Gb when using those functions.

Parameters
keyName | is the name of the key. In C++, this key value may contain binary information. In other languages, it must be standard text.
offset | is the file offset to be associated with keyName.
Returns
True if the function succeeds.

◆ saveIntForKey()

bool saveIntForKey | ( | const std::string & | keyName,
 |  | int | value
 | ) |  |

Store an integer value associated with a key.

This function is useful for storing an integer value in a CDB file. See also saveFileOffsetFromKey() for using 64 bit integer values.

The advantage of using this function rather than saveValueForKey is that the value is saved as a binary value and is always more compact than saving it in text format. One disadvantage of this function is that there is currently no conversion between little endian and big endian format,so index files could not be moved between little endian and big endian systems.

See also
saveIntForKey()
Parameters
keyName | is the name of the key. In C++, this key value may contain binary information. In other languages, it must be standard text.
value | is the integer value to be associated with keyName.
Returns
True if the function succeeds.

◆ saveValueForKey()

bool saveValueForKey | ( | const char * | keyName,
 |  | const char * | value,
 |  | const unsigned int | keyNameLen = 0,
 |  | const unsigned int | valueLen = 0
 | ) |  |

Add a key/value pair to the file.

The prepareToCreate() function must have been called prior to calling this function.

C++: The keyName and value parameters will normally point to null terminated text strings. To use a binary data (in either the key or the value or both), specify the length of the data in the keyNameLen and the valLen parameters.

Parameters
keyName | is the name of the key. It should not start with =0. as this is used for the version number and other internal values.
value | is the value of the key to be stored.
keyNameLen | is the length of the data pointed to by the keyName parameter. If keyNameLen is 0 (the default), then it is assumed that the keyName is a null terminated string.
valueLen | is the length of the data pointed to by the value parameter. If valueLen is 0 (the default), then it is assumed that the value is a null terminated string.
Returns
true if the key/value pair is saved. It will fail if this would make the file too large, in which case the ms_errs::ERR_CDB_TOO_LARGE error will be set. It will also fail with the error ms_errs::ERR_WRITE_CDB_FILE if the file cannot be written to. Finally, it will fail without an error if the prepareToCreate() function has not been called.

◆ setIndexFileName()

void setIndexFileName ( const char * filename )

Set the index file name.

Parameters
filename The full path to the index file.
The documentation for this class was generated from the following files:
  • ms_tinycdb.hpp
  • ms_tinycdb.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_treecluster Class Reference

  • matrix_science
  • ms_treecluster
Public Types | Public Member Functions | List of all members
ms_treecluster Class Reference
Mascot utilities and tools module

This class is an interface to the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/. More...

#include <ms_treecluster.hpp>

Inheritance diagram for ms_treecluster:
[legend]
Collaboration diagram for ms_treecluster:
[legend]

Public Types

enum TREE_CLUSTER_DISTANCE {
TCD_CORRELATION ,
TCD_ABS_CORRELATION ,
TCD_UNCENTERED_CORRELATION ,
TCD_ABS_UNCENTERED_CORRELATION ,
TCD_SPEARMANS_RANK_CORRELATION ,
TCD_KENDALLS_TAU_CORRELATION ,
TCD_EUCLIDEAN ,
TCD_CITY_BLOCK
}
Flags for cluster(). More...

Public Member Functions

ms_treecluster (const ms_treecluster &right)
Copying constructor.
ms_treecluster (int rows, int columns)
Constructor.
~ms_treecluster ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
bool | cluster (TREE_CLUSTER_DISTANCE tcd, ms_mascotresults::TREE_CLUSTER_METHOD tcm, const std::vector< double > &weight, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, bool transpose=false)
Perform the clustering and populate the left, right and distance vectors with the results.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_treecluster *right)
Copies all data from another instance of the class.
void | defaultValues ()
Initialises the instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_treecluster & | operator= (const ms_treecluster &right)
Assignment operator.
bool | setRow (int row, std::vector< double > datarow, std::vector< int > maskrow)
Sets the values for the specified row in the data and mask arrays.

Detailed Description

This class is an interface to the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/.

The License agreement for using this excellent Open Source code is included with Mascot Parser; see C Clustering library.

  • To use this function, create an ms_treecluster object with the required number of rows and columns.
  • Call ms_treecluster::setRow() for each row.
  • Call ms_treecluster::cluster()
  • Access the nodes and distances from the 'returned' left, right and distance parameters

Member Enumeration Documentation

◆ TREE_CLUSTER_DISTANCE

enum TREE_CLUSTER_DISTANCE

Flags for cluster().

In order to cluster data into groups we need to define what exactly we mean by similar. In the C Clustering Library, eight distance functions are available to measure similarity, or conversely, distance.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TCD_CORRELATION | 'c': Pearson correlation coefficient
TCD_ABS_CORRELATION | 'a': Absolute value of the Pearson correlation coefficient
TCD_UNCENTERED_CORRELATION | 'u': Uncentered Pearson correlation (equivalent to the cosine of the angle between two data vectors)
TCD_ABS_UNCENTERED_CORRELATION | 'x': Absolute uncentered Pearson correlation
TCD_SPEARMANS_RANK_CORRELATION | 's': Spearman�s rank correlation;
TCD_KENDALLS_TAU_CORRELATION | 'k': Kendall tau rank correlation coefficient
TCD_EUCLIDEAN | 'e': Euclidean distance
TCD_CITY_BLOCK | 'b': City-block distance

Constructor & Destructor Documentation

◆ ms_treecluster()

ms_treecluster | ( | int | rows,
 |  | int | columns
 | ) |  |

Constructor.

Parameters
rows | is the number of rows in the data
columns | is the number of columns in the data

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ cluster()

bool cluster | ( | TREE_CLUSTER_DISTANCE | tcd,
 |  | ms_mascotresults::TREE_CLUSTER_METHOD | tcm,
 |  | const std::vector< double > & | weight,
 |  | std::vector< int > & | left,
 |  | std::vector< int > & | right,
 |  | std::vector< double > & | distance,
 |  | bool | transpose = false
 | ) |  |

Perform the clustering and populate the left, right and distance vectors with the results.

Call this function after making rows calls to setRow()

For details of how to use the weight, left, right and distance parameters, see Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

The function returns a list of items, nodes and distances in the left, right and distance vectors.

The original elements are numbered {0, . . . , nelements-1} and the nodes are numbered {-1, . . . , -(nelements-1)}.

The left, right and distance vectors are guaranteed to have the same number of elements, and for example, left[2], right[2], distance[2] all correspond to the same 'node'.

Element 0 from each of the three vectors corresponds to node -1, element 1 to node -2, element 2 to node -3 etc.

See also ms_peptidesummary::getTreeClusterNodes

Parameters
[in] | tcd | is used to define which method should be used as a measure of the distance between data items. See ms_treecluster::TREE_CLUSTER_DISTANCE.
[in] | tcm | Specifies which type of hierarchical clustering is used. See ms_mascotresults::TREE_CLUSTER_METHOD
[in] | weight | Dimension: columns (as passed to the constructor) if transpose is false, or rows (as passed to the constructor) if transpose is true. A zero length array is also accepted, in which case this is replaced by an array of 1s - i.e. all the same weight
[out] | left | returns an array, size rows -1 (as passed to the constructor) of element and node numbers
[out] | right | returns an array, size rows -1 (as passed to the constructor) of element and node numbers.
[out] | distance | returns an array, size rows -1 (as passed to the constructor) of distances between the elements/nodes
[in] | transpose | indicates whether row-wise or column-wise clustering is being performed. If transpose is false, rows are being clustered. Otherwise, columns are being clustered.
Returns
false if the weight array is not of the correct size and false if there is insufficient memory for the arrays.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_treecluster * right )

Copies all data from another instance of the class.

Called by copy constructor, or may be called directly.

Parameters
right is the object to copy values from

◆ defaultValues()

void defaultValues ( )

Initialises the instance.

Allocates internal memory based on the number of rows and columns passed to the constructor

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_treecluster & operator= ( const ms_treecluster & right )

Assignment operator.

Used from C++

Parameters
right is the object to copy values from
Returns
reference to the current object

◆ setRow()

bool setRow | ( | int | row,
 |  | std::vector< double > | datarow,
 |  | std::vector< int > | maskrow
 | ) |  |

Sets the values for the specified row in the data and mask arrays.

For details of how to use the datarow and maskrow parameters, see Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
row | is the zero based row number. Must be in the range 0..rows-1 passed to the constructor
datarow | is an array of the data points for the specified row. The length of the datarow array must be the same as columns passed to the constructor.
maskrow | is an array which specifies which elements in the data array, (if any), are missing. If mask[i][j]==0, then data[i][j] is missing. An empty array may be passed to show that no elements in the data array are missing. However, if a non empty array is passed, then the length of the maskrow array must be the same as columns passed to the constructor.
Returns
The function will return false if any of the following are true:
  • the row value is less than 0 or greater than or equal the rows value passed to the constructor.
  • the number of values in the datarow parameter is not the same as the columns parameter passed to the constructor.
  • the number of values in the maskrow parameter is not the same as the rows parameter passed to the constructor or is zero.
  • there was an out of memory error.
The documentation for this class was generated from the following files:
  • ms_treecluster.hpp
  • ms_treecluster.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_zip Class Reference

  • matrix_science
  • ms_zip
Public Member Functions | List of all members
ms_zip Class Reference
Mascot utilities and tools module

Utility class for compressing and decompressing data in compress format, and compressing in gzip format. More...

#include <ms_zip.hpp>

Inheritance diagram for ms_zip:
[legend]
Collaboration diagram for ms_zip:
[legend]

Public Member Functions

ms_zip (const bool isZipped)
Streaming mode constructor.
ms_zip (const bool isZipped, const std::string &buffer)
Buffer mode constructor.
ms_zip (const bool isZipped, const unsigned char *buffer, const unsigned long len)
Buffer mode constructor (only for C++).
ms_zip (const ms_zip &src)
Copying constructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
std::string | compressMore (const std::string &dataIn)
Feed more data to the compressor and retrieve the next chunk of compressed data.
void | compressMore (const unsigned char *dataIn, const unsigned long inputLen, unsigned char *dataOut, unsigned long *outputLen)
Feed more data to the compressor and retrieve the next chunk of compressed data.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_zip *right)
Call this member to copy all the information from another instance.
std::string | decompressMore (const std::string &dataIn)
Retrieve the next chunk of decompressed data.
void | decompressMore (const unsigned char *dataIn, const unsigned long inputLen, unsigned char *dataOut, unsigned long *outputLen)
Retrieve the next chunk of decompressed data.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getUnZipped () const
Return the uncompressed buffer.
unsigned long | getUnZipped (unsigned char *buffer, const unsigned long len) const
Copy the uncompressed buffer into a buffer.
unsigned long | getUnZippedLen () const
Return the length of the uncompressed buffer.
std::string | getZipped () const
Return the compressed buffer.
unsigned long | getZipped (unsigned char *buffer, const unsigned long len) const
Copy the compressed buffer into a buffer.
unsigned long | getZippedLen () const
Return the length of the compressed buffer.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_zip & | operator= (const ms_zip &right)
C++ style assignment operator.

Detailed Description

Utility class for compressing and decompressing data in compress format, and compressing in gzip format.

ms_zip is used internally in Mascot Parser, for example for decompressing unimod.xml and other configuration files when they are downloaded from a remote web site.

There are two ways to use the library: buffer mode and streaming mode.

Usage in buffer mode:

  1. Create a new object using ms_zip::ms_zip(const bool, const unsigned char*, const unsigned long) or ms_zip::ms_zip(const bool, const std::string&). The parameter buffer is the data to process; the parameter isZipped determines whether the data should be compressed (false) or decompressed (true).
  2. Check for errors after creating the object using ms_zip::isValid().
  3. If there are no errors, the resulting data can be read from ms_zip::getZipped() (compress mode) and ms_zip::getUnZipped() (decompress mode).

In buffer mode, both the compressed and decompressed data are kept in an internal buffer. The uncompressed input must not exceed 10 MB. The format of the compressed data is identical to the Unix command-line utility compress, except that the first four bytes of the buffer contain the length of the compressed data. For this reason, ms_zip buffer mode should only be used to decompress data that has been compressed with ms_zip buffer mode.

Usage in streaming compression mode:

  1. Create a new object using ms_zip::ms_zip(const bool) with parameter false.
  2. Check for errors after creating the object using ms_zip::isValid().
  3. If there are no errors, feed in data using ms_zip::compressMore(const unsigned char *, const unsigned long, unsigned char *, unsigned long *) or ms_zip::compressMore(const std::string &).
  4. Check for errors using ms_zip::isValid(). If there are no errors, continue from step 3 until you've run out of input data.
  5. Flush the stream by giving the empty string as parameter to ms_zip::compressMore(const std::string &) (or let inputLen be 0 in ms_zip::compressMore(const unsigned char *, const unsigned long, unsigned char *, unsigned long *) ).
  6. Repeat step 5 as long as ms_zip::isValid() and ms_zip::compressMore() returns more data.

In streaming mode, only the most recent input and output chunk is stored in the internal buffer. The input to ms_zip::compressMore() must not exceed 10 MB. The compressed data stream follows the gzip format with a minimal file header. The data can be decompressed with any tool that supports gzipped files.

Usage in streaming decompression mode:

  1. Create a new object using ms_zip::ms_zip(const bool) with parameter true.
  2. Check for errors after creating the object using ms_zip::isValid().
  3. If there are no errors, feed in data using ms_zip::decompressMore(const unsigned char *, const unsigned long, unsigned char *, unsigned long *) or ms_zip::decompressMore(const std::string &).
  4. Check for errors using ms_zip::isValid(). If there are no errors, continue from step 3 until you've run out of input data.
  5. Flush the stream by giving the empty string as parameter to ms_zip::decompressMore(const std::string &) (or let inputLen be 0 in ms_zip::decompressMore(const unsigned char *, const unsigned long, unsigned char *, unsigned long *) ).
  6. Repeat step 5 as long as ms_zip::isValid() and ms_zip::decompressMore() returns more data.

The input to ms_zip::decompressMore() must not exceed 10 MB. The compressed data stream is expected to be in gzip format with a minimal file header, for example a gzipped file.

Constructor & Destructor Documentation

◆ ms_zip() [1/4]

ms_zip | ( | const bool | isZipped,
 |  | const unsigned char * | buffer,
 |  | const unsigned long | len
 | ) |  |

Buffer mode constructor (only for C++).

This constructor initialises ms_zip for buffer mode. ms_zip can be used to compress and uncompress a small amount of data (less than 10 MB) in a buffer. When decompressing in buffer mode, the only supported data format is data compressed by ms_zip in buffer mode.

The first four bytes of the compressed buffer are used to store the length of the uncompressed data as an unsigned 32 bit integer (little endian) format. No other headers are written. The object will hold a copy of both the compressed and uncompressed data, so it is not suitable for use with large amounts of data. Use the streaming mode in that case.

After creating the object, call isValid() to determine if there are any errors. The errors can be retrieved using getLastErrorString().

Possible errors are:

  • ms_errs::ERR_MSP_ZIP_ENDIAN
  • ms_errs::ERR_MSP_ZIP_OUTOFMEMORY
  • ms_errs::ERR_MSP_ZIP_BUFTOOSMALL
  • ms_errs::ERR_MSP_ZIP_INVALIDDATA
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
  • ms_errs::ERR_MSP_ZIP_LENGTHDIFFERS
  • ms_errs::ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG
  • ms_errs::ERR_MSP_ZIP_ZEROLENGTH
Parameters
isZipped | should be true if the passed buffer contains compressed data (decompression mode), and false if it contains uncompressed data (compression mode).
buffer | is a pointer to the compressed or uncompressed data. If it is uncompressed, there is no assumption that the data is a null terminated string.
len | is the length of the passed buffer.

◆ ms_zip() [2/4]

ms_zip | ( | const bool | isZipped,
 |  | const std::string & | buffer
 | ) |  |

Buffer mode constructor.

This constructor initialises ms_zip for buffer mode. ms_zip can be used to compress and uncompress a small amount of data (less than 10 MB) in a buffer. When decompressing in buffer mode, the only supported data format is data compressed by ms_zip in buffer mode.

The first four bytes of the compressed buffer are used to store the length of the uncompressed data as an unsigned 32 bit integer (little endian) format. No other headers are written. The object will hold a copy of both the compressed and uncompressed data, so it is not suitable for use with large amounts of data. Use the streaming mode in that case.

After creating the object, call isValid() to determine if there are any errors. The errors can be retrieved using getLastErrorString().

Possible errors are:

  • ms_errs::ERR_MSP_ZIP_ENDIAN
  • ms_errs::ERR_MSP_ZIP_OUTOFMEMORY
  • ms_errs::ERR_MSP_ZIP_BUFTOOSMALL
  • ms_errs::ERR_MSP_ZIP_INVALIDDATA
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
  • ms_errs::ERR_MSP_ZIP_LENGTHDIFFERS
  • ms_errs::ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG
  • ms_errs::ERR_MSP_ZIP_ZEROLENGTH
Parameters
isZipped | should be true if the passed buffer contains compressed data (decompression mode), and false if it contains uncompressed data (compression mode).
buffer | is a string that contains the compressed or uncompressed data. If it is uncompressed, there is no assumption that the data is a null terminated string. C++ programmers should be aware that a std::string constructor needs to be passed the length parameter when creating a std::string that contains binary data. Otherwise, a 'zero' in the data will be considered to be a null terminator for a string.

◆ ms_zip() [3/4]

ms_zip ( const bool isZipped )
explicit

Streaming mode constructor.

This constructor initialises ms_zip in streaming mode. ms_zip can be used for compressing arbitrarily large data streams into gzip format. When decompressing in streaming mode, the only supported data format is gzip format.

In streaming compression mode, the compressed data stream will start with a minimal gzip header, followed by the compressed data. The constructor does not take any input data as a parameter, unlike in buffer mode. Instead, input data is fed to the object using ms_zip::compressMore(), which returns sequential chunks of compressed data. End of input data is indicated by passing the empty string to ms_zip::compressMore().

In streaming decompression mode, the compressed data stream is expected to start with a minimal gzip header, followed by the compressed data. Input data is fed to the object using ms_zip::decompressMore(), which returns sequential chunks of decompressed data. End of input data is indicated by passing the empty string to ms_zip::decompressMore().

If the underlying zlib library cannot be initialised, the following errors are possible:

  • ms_errs::ERR_MSP_ZIP_OUTOFMEMORY
  • ms_errs::ERR_MSP_ZIP_VERSIONERROR
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
Parameters
isZipped must always be false for compression mode.

◆ ms_zip() [4/4]

ms_zip ( const ms_zip & src )

Copying constructor.

Generally only used from C++, but will be called indirectly from other languages.

Parameters
src is the ms_zip to make a copy of.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ compressMore() [1/2]

std::string compressMore ( const std::string & dataIn )

Feed more data to the compressor and retrieve the next chunk of compressed data.

You may need to call ms_zip::compressMore() a few times with more input data until the compressed stream starts. This is indicated by returning a non-empty string.

Both the input and output strings are bounded: the input string length must not exceed 10 MB and the output string length will never exceed 10 MB.

End of input data is indicated by calling ms_zip::compressMore() with the empty string (length 0). The compressor will flush the output and return the last compressed bytes. If there are more bytes to return than the internal buffer allows, you must call the method again with the empty string. When there is no more data to be flushed, the returned string will be empty (length 0).

If the compressor has more output than fits in the output buffer, ms_zip pushes it into an internal output queue. The next call to ms_zip::compressMore() returns the chunk from the head of the internal queue and may append more to the tail of the queue. The operation is not visible to the caller. However, it's best to keep the size of input smaller than the output buffer, as otherwise ms_zip may use an unexpected amount of memory for the output queue.

If this method is called in non-streaming mode, an empty string object will be returned and the error ms_errs::ERR_MSP_ZIP_NOTSTREAMING set.

Other possible error conditions:

  • ms_errs::ERR_MSP_ZIP_INVALID_STREAMING_MODE
  • ms_errs::ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG
  • ms_errs::ERR_MSP_ZIP_STREAMERROR
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
Parameters
dataIn Next chunk of raw binary data to compress. The data need not be null terminated. C++ programmers should be aware that a std::string constructor needs to be passed the length parameter when creating a std::string that contains binary data. Otherwise, a 'zero' in the data will be considered to be a null terminator for a string.
Returns
A string (possibly empty) of raw compressed binary data.

◆ compressMore() [2/2]

void compressMore | ( | const unsigned char * | dataIn,
 |  | const unsigned long | inputLen,
 |  | unsigned char * | dataOut,
 |  | unsigned long * | outputLen
 | ) |  |

Feed more data to the compressor and retrieve the next chunk of compressed data.

You may need to call ms_zip::compressMore() a few times with more input data until the compressed stream starts. This is indicated by returning a non-empty string.

Both the input and output strings are bounded: inputLen and outputLen must not exceed 10 MB, and outputLen must always exceed 0. If any of these conditions fail, a corresponding error will be set.

End of input data is indicated by calling ms_zip::compressMore() with inputLen equal to 0 (dataIn can be nullptr). The compressor will flush the output and return the last compressed bytes. If there are more bytes to return than outputLen, you must call the method again with inputLen equal to 0. When there is no more data to be flushed, outputLen is set to 0.

If the compressor has more output than fits in the output buffer, ms_zip pushes it into an internal output queue. The next call to ms_zip::compressMore() returns the chunk from the head of the internal queue and may append more to the tail of the queue. The operation is not visible to the caller. However, it's best to keep the size of input smaller than the output buffer, as otherwise ms_zip may use an unexpected amount of memory for the output queue.

If this method is called in non-streaming mode, outputLen will be set to 0 and the error ms_errs::ERR_MSP_ZIP_NOTSTREAMING set.

Other possible error conditions:

  • ms_errs::ERR_MSP_ZIP_INVALID_STREAMING_MODE
  • ms_errs::ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG
  • ms_errs::ERR_MSP_ZIP_BUFTOOSMALL
  • ms_errs::ERR_MSP_ZIP_STREAMERROR
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
Parameters
dataIn | Next chunk of raw binary data compress. The data is not assumed to be null terminated.
inputLen | Length of data in dataIn.
dataOut | Pointer to the memory location where compressed data should be written. The caller must ensure at least outputLen bytes have been allocated.
outputLen | Maximum length of data to output. outputLen will be set to the actual length of dataOut on successful return.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_zip * right )

Call this member to copy all the information from another instance.

Simply create an instance of the class using the default constructor and call this method.

Parameters
right is a pointer to another instance to copy from.

◆ decompressMore() [1/2]

std::string decompressMore ( const std::string & dataIn )

Retrieve the next chunk of decompressed data.

You may need to call ms_zip::decompressMore() a few times with more input data until the compressed stream starts. This is indicated by returning a non-empty string.

Both the input and output strings are bounded: the input string length must not exceed 10 MB and the output string length will never exceed 10 MB.

End of input data is indicated by calling ms_zip::decompressMore() with the empty string (length 0). The compressor will flush the output and return the last decompressed bytes. If there are more bytes to return than the internal buffer allows, you must call the method again with the empty string. When there is no more data to be flushed, the returned string will be empty (length 0).

If the compressor has more output than fits in the output buffer, ms_zip pushes it into an internal output queue. The next call to ms_zip::decompressMore() returns the chunk from the head of the internal queue and may append more to the tail of the queue. The operation is not visible to the caller. However, it's best to keep the size of input smaller than the output buffer, as otherwise ms_zip may use an unexpected amount of memory for the output queue.

If this method is called in non-streaming mode, an empty string object will be returned and the error ms_errs::ERR_MSP_ZIP_NOTSTREAMING set.

Other possible error conditions:

  • ms_errs::ERR_MSP_ZIP_INVALID_STREAMING_MODE
  • ms_errs::ERR_MSP_ZIP_COMPRESSEDDATATOOLONG
  • ms_errs::ERR_MSP_ZIP_STREAMERROR
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
Parameters
dataIn Next chunk of raw binary data to decompress. The data need not be a null terminated string. C++ programmers should be aware that a std::string constructor needs to be passed the length parameter when creating a std::string that contains binary data. Otherwise, a 'zero' in the data will be considered to be a null terminator for a string.
Returns
A string (possibly empty) of raw compressed binary data.

◆ decompressMore() [2/2]

void decompressMore | ( | const unsigned char * | dataIn,
 |  | const unsigned long | inputLen,
 |  | unsigned char * | dataOut,
 |  | unsigned long * | outputLen
 | ) |  |

Retrieve the next chunk of decompressed data.

You may need to call ms_zip::decompressMore() a few times with more input data until the decompressed stream starts. This is indicated by returning a non-empty string.

Both the input and output strings are bounded: inputLen and outputLen must not exceed 10 MB, and outputLen must always exceed 0. If any of these conditions fail, a corresponding error will be set.

End of input data is indicated by calling ms_zip::decompressMore() with inputLen equal to 0 (dataIn can be nullptr). The compressor will flush the output and return the last decompressed bytes. If there are more bytes to return than outputLen, you must call the method again with inputLen equal to 0. When there is no more data to be flushed, outputLen is set to 0.

If the compressor has more output than fits in the output buffer, ms_zip pushes it into an internal output queue. The next call to ms_zip::decompressMore() returns the chunk from the head of the internal queue and may append more to the tail of the queue. The operation is not visible to the caller. However, it's best to keep the size of input smaller than the output buffer, as otherwise ms_zip may use an unexpected amount of memory for the output queue.

If this method is called in non-streaming mode, outputLen will be set to 0 and the error ms_errs::ERR_MSP_ZIP_NOTSTREAMING set.

Other possible error conditions:

  • ms_errs::ERR_MSP_ZIP_INVALID_STREAMING_MODE
  • ms_errs::ERR_MSP_ZIP_COMPRESSEDDATATOOLONG
  • ms_errs::ERR_MSP_ZIP_BUFTOOSMALL
  • ms_errs::ERR_MSP_ZIP_STREAMERROR
  • ms_errs::ERR_MSP_ZIP_INVALIDDATA
  • ms_errs::ERR_MSP_ZIP_OUTOFMEMORY
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
Parameters
dataIn | Next chunk of raw binary data decompress. The data is not assumed to be a null terminated string.
inputLen | Length of data in dataIn.
dataOut | Pointer to the memory location where decompressed data should be written. The caller must ensure at least outputLen bytes have been allocated.
outputLen | Maximum length of data to output. outputLen will be set to the actual length of dataOut on successful return.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getUnZipped() [1/2]

std::string getUnZipped ( ) const

Return the uncompressed buffer.

In buffer mode, return the uncompressed data.

In streaming compression mode, return the most recent input value to ms_zip::compressMore().

In streaming decompression mode, return the most recent value from ms_zip::decompressMore().

Note
In C++, the string will not be null terminated, so you should use the std::string::length function to determing the length of the data.
In Perl, use the length() function on the returned string. The uncompressed data may be binary or text.
Returns
uncompressed data as a string

◆ getUnZipped() [2/2]

unsigned long getUnZipped | ( | unsigned char * | buffer,
 |  | const unsigned long | len
 | ) |  | const

Copy the uncompressed buffer into a buffer.

In buffer mode, return the uncompressed data.

In streaming compression mode, return the most recent input value to ms_zip::compressMore().

In streaming decompression mode, return the most recent value from ms_zip::decompressMore().

Parameters
buffer | is the location where the uncompressed data will be copied to. The calling application should make sure that the buffer is long enough. Use getUnZippedLen() to find the length of the uncompressed data.
len | is the length of the passed buffer.
Returns
The number of bytes copied to the buffer.

◆ getUnZippedLen()

unsigned long getUnZippedLen ( ) const

Return the length of the uncompressed buffer.

Returns
The length, in bytes, of the uncompressed data from getUnZipped(unsigned char*, const unsigned int).

◆ getZipped() [1/2]

std::string getZipped ( ) const

Return the compressed buffer.

In buffer mode, return the compressed data.

In streaming compression mode, return the most recent value from ms_zip::compressMore().

In streaming decompression mode, return the most recent value given to ms_zip::decompressMore().

Note
In C++, the string will not be null terminated, so you should use the std::string::length function to determing the length of the data.
In Perl, use the length() function on the returned string.
Returns
compressed data as a string

◆ getZipped() [2/2]

unsigned long getZipped | ( | unsigned char * | buffer,
 |  | const unsigned long | len
 | ) |  | const

Copy the compressed buffer into a buffer.

In buffer mode, return the compressed data.

In streaming compression mode, return the most recent value from ms_zip::compressMore().

In streaming decompression mode, return the most recent value given to ms_zip::decompressMore().

Parameters
buffer | is the location where the compressed data will be copied to. The calling application should make sure that the buffer is long enough. Use getZippedLen() to find the length of the compressed data.
len | is the length of the passed buffer.
Returns
The number of bytes copied to the buffer.

◆ getZippedLen()

unsigned long getZippedLen ( ) const

Return the length of the compressed buffer.

Returns
The length, in bytes, of the compressed data from getZipped(unsigned char*, const unsigned int).

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_zip.hpp
  • ms_zip.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Error handling and logging

Modules | Classes
Error handling and logging

Modules

Error Handling
Logging using ms_loggingmonitor
Examples for error handling in Mascot Parser modules

Classes

class | ms_buffer_logger
Concrete class which implements ms_logger and stores log text in memory. More...
class | ms_errors
This class is used as a base class for several Mascot Parser classes. More...
class | ms_errs
All errors are collected in an instance of this class. More...
class | ms_file_logger
Concrete class which implements ms_logger and outputs log text to the specified file. More...
class | ms_log
Definitions for logging messages. More...
class | ms_logger
Abstract class which provides the interface used by ms_logging monitor to delegate logging events. More...
class | ms_loggingmonitor
Monitor class to delegate logging events generated from multiple sources. More...
class | ms_stdout_logger
Concrete class which implements ms_logger and outputs log text to standard out. More...

Detailed Description

Error handling and logging classes used by Mascot Parser classes.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Error Handling

Error Handling
Error handling and logging

Error handling

Mascot Parser 2.0 introduced configuration files and authentication functionality along with a more generic approach to error handling. The following classes are now derived from ms_errors, and provide the same interface to error handling.

  • ms_aahelper
  • ms_crosslinking_configfile
  • ms_datfile
  • ms_distiller_data
  • ms_distiller_master_project
  • ms_distiller_search_status_list
  • ms_enzymefile
  • ms_fragrulesfile
  • ms_http_client
  • ms_http_client_search
  • ms_http_client_session
  • ms_http_helper_handles
  • ms_license
  • ms_masses
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Logging using ms_loggingmonitor

Logging using ms_loggingmonitor
Error handling and logging

Logging using ms_loggingmonitor

Using setLoggingFile in Parser 2.5 and earlier (deprecated)

Mascot Parser 2.5 and earlier provided a function: ms_errs::setLoggingFile which saved error and logging messages to the specified file. The problem with this approach is that it's necessary to call this for every Mascot Parser object that is created because there is no global handler. Also, any logging that occurs in the constructor would not go into the log file.

ms_loggingmonitor was introduced in Mascot Parser 2.6. This can be used when an application wants to log its own messages and Parser messages to a single file, rather then to multiple log files.

Class diagram for logging classes:

Simple logging with Parser 2.6 and later

The following is an example of how to redirect all logging from msparser to a specified file and how to specify the logging level.

  1. In the program's main function, create a file logger:
    ms_file_logger fileLogger("C:/tmp/log.txt", ms_logger::COL_LOGGER_DEFAULTS );
    specifying whatever columns you want from the list in ms_logger::LogOutputColumns_e
  2. Add the file logger handler to the default monitor:
    ms_loggingmonitor::getDefaultMonitor() . addLogEventsHandler (fileLogger)
  3. Set the logging level, either to be the same for all event sources or different for each one, by calling, for example:
    ms_loggingmonitor::Level_e logLevel = ms_loggingmonitor::LVL_ERROR | ms_loggingmonitor::LVL_WARNING;
    ms_loggingmonitor::getDefaultMonitor().setLogMask(logLevel, ms_loggingmonitor::SRC_ALL);
  4. msparser messages will now all be logged to the specified log file
  5. Call ms_loggingmonitor::logMessage to log messages from your own application

Custom logging

For more complex cases, a custom logger can also be created:

class MyLogger : public matrix_science::ms_logger
{
public:
MyLogger(const std::string & logFile, const unsigned int colsToOutput) : ms_logger(colsToOutput)
{
ofs.open(logFile.c_str());
}
void onLogMessage(matrix_science::ms_loggingmonitor::Level_e eSeverity,
matrix_science::ms_loggingmonitor::Source_e eSource,
long lMsgId, const std::string &text, long lContextId = 0) {
ofs << "0x" << std::hex << std::setw(4) << std::setfill('0') << lMsgId
<< " " << matrix_science::ms_loggingmonitor::severityAsText(eSeverity)
<< " " << matrix_science::ms_loggingmonitor::messageSourceAsText(eSource)
<< " " << text << std::endl;
// Or could call
matrix_science::ms_logger::formatMessage(eSeverity, eSource, lMsgId, text, lContextId);
}
private:
std::ofstream ofs;
};
int main()
{
matrix_science::ms_loggingmonitor & loggingMonitor = matrix_science::ms_loggingmonitor::getDefaultMonitor();
MyLogger logger("C:/tmp/log.txt",
matrix_science::ms_logger::COL_ASC_TIME | matrix_science::ms_logger::COL_MSG);
loggingMonitor.addLogEventsHandler(logger);
}
matrix_science::ms_logger
Abstract class which provides the interface used by ms_logging monitor to delegate logging events.
Definition: ms_logging.hpp:137
matrix_science::ms_logger::formatMessage
std::string formatMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const
Returns a string with formatting based on the columns requested to be output.
Definition: ms_logging.cpp:281
matrix_science::ms_logger::COL_ASC_TIME
@ COL_ASC_TIME
[ ] Output the time in the format: "Sat Jan 6 11:35:22 2018"
Definition: ms_logging.hpp:152
matrix_science::ms_logger::COL_MSG
@ COL_MSG
[*] Output the formatted message text.
Definition: ms_logging.hpp:163
matrix_science::ms_logger::onLogMessage
virtual void onLogMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)=0
Processes and handles the passed logging message.
matrix_science::ms_loggingmonitor
Monitor class to delegate logging events generated from multiple sources.
Definition: ms_logging.hpp:44
matrix_science::ms_loggingmonitor::severityAsText
static std::string severityAsText(Level_e eSeverity)
Returns a severity enum value as a text string.
Definition: ms_logging.cpp:212
matrix_science::ms_loggingmonitor::getDefaultMonitor
static matrix_science::ms_loggingmonitor & getDefaultMonitor()
Returns the global ms_loggingmonitor used by msparser.
Definition: ms_logging.cpp:156
matrix_science::ms_loggingmonitor::addLogEventsHandler
virtual int addLogEventsHandler(ms_logger &logger)
Registers the passed ms_logger with the ms_loggingmonitor.
Definition: ms_logging.cpp:56
matrix_science::ms_loggingmonitor::Level_e
Level_e
Logging severity levels.
Definition: ms_logging.hpp:51
matrix_science::ms_loggingmonitor::Source_e
Source_e
Logging event source.
Definition: ms_logging.hpp:65
matrix_science::ms_loggingmonitor::messageSourceAsText
static std::string messageSourceAsText(Source_e eSource)
Returns a Source_e enum value as a text string.
Definition: ms_logging.cpp:179
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Examples for error handling in Mascot Parser modules

Examples for error handling in Mascot Parser modules
Error handling and logging

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
For general error handling | common_error.pl | common_error.cpp | - | common_error.py | common_error.cs
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_buffer_logger Class Reference

  • matrix_science
  • ms_buffer_logger
Public Types | Public Member Functions | List of all members
ms_buffer_logger Class Reference
Error handling and logging

Concrete class which implements ms_logger and stores log text in memory. More...

#include <ms_logging.hpp>

Inheritance diagram for ms_buffer_logger:
[legend]
Collaboration diagram for ms_buffer_logger:
[legend]

Public Types

enum LogOutputColumns_e {
COL_ASC_TIME = 0x0001 ,
COL_ISO8601_TIME = 0x0002 ,
COL_IP_ADDRESS = 0x0004 ,
COL_MSG_NUM_DEC = 0x0008 ,
COL_MSG_NUM_HEX = 0x0010 ,
COL_SEVERITY_NUM = 0x0020 ,
COL_SEVERITY_TXT = 0x0040 ,
COL_MSG_SOURCE_TXT = 0x0080 ,
COL_SRC_FILE = 0x0100 ,
COL_SRC_LINENUM = 0x0200 ,
COL_THREAD_ID = 0x0400 ,
COL_MSG = 0x0800 ,
COL_TSV = 0x1000 ,
COL_QUOTES = 0x2000 ,
COL_HEADERS = 0x4000 ,
COL_LOGGER_DEFAULTS = COL_ISO8601_TIME | COL_MSG_NUM_HEX | COL_SEVERITY_TXT | COL_MSG_SOURCE_TXT | COL_SRC_FILE | COL_SRC_LINENUM | COL_MSG | COL_HEADERS
}
Logging output columns. More...

Public Member Functions

ms_buffer_logger (unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS)
Constructor, sets columns to report.
virtual | ~ms_buffer_logger ()
Destructor.
std::vector< std::string > | flush ()
Clear and return all messages from the buffer.
std::string | formatMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const
Returns a string with formatting based on the columns requested to be output.
virtual unsigned int | getColsToOutput () const
Return the value which specifies which columns should be output by the logger.
std::string | getHeaderLine () const
Returns the header line based on the specified column names.
virtual void | onLogMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)
Format and store the passed message in memory.
virtual void | setColsToOutput (const unsigned int colsToOutput)
Set the value to specify which columns should be output by the logger.

Detailed Description

Concrete class which implements ms_logger and stores log text in memory.

Member Enumeration Documentation

◆ LogOutputColumns_e

enum LogOutputColumns_e
inherited

Logging output columns.

These flags determine which columns are output by ms_stdout_logger and ms_file_logger.

The only way to change the order of the columns is to override the onLogMessage() function.

Enums with a [*] in the description are included in COL_LOGGER_DEFAULTS

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
COL_ASC_TIME | [ ] Output the time in the format: "Sat Jan 6 11:35:22 2018"
COL_ISO8601_TIME | [*] Output the time in the format: "2018-05-28T08:26:34-01:00". If the local time is the same as UTC, then the format would be: "2018-05-28T08:26:34Z " with 5 trailing spaces.
COL_IP_ADDRESS | [ ] Output the IP address of the calling getenv("REMOTE_ADDR"). If this is empty, "localhost" is output. Most useful for cgi applications.
COL_MSG_NUM_DEC | [ ] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.
COL_MSG_NUM_HEX | [*] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.
COL_SEVERITY_NUM | [ ] Output the ms_loggingmonitor::Level_e severity as a number.
COL_SEVERITY_TXT | [*] Output the ms_loggingmonitor::Level_e severity as text by calling ms_loggingmonitor::severityAsText .
COL_MSG_SOURCE_TXT | [*] Output the source of the message. See ms_loggingmonitor::messageSourceAsText
COL_SRC_FILE | [*] Output the source code file name.
COL_SRC_LINENUM | [*] Ouput the line number in the source file.
COL_THREAD_ID | [ ] Output the current thread ID as a hexadecimal number.
COL_MSG | [*] Output the formatted message text.
COL_TSV | [ ] By default, the output format is CSV - with each field in quotes. If this flag is used, then the column separator will be a tab
COL_QUOTES | [ ] Put quotes around every field
COL_HEADERS | [*] For ms_file_logger, this will ouput column headers if the file is empty and for ms_stdout_logger the constructor will output this
COL_LOGGER_DEFAULTS | [ ] Default columns used by Matrix Science Applications, includes values marked with [*] above.

Constructor & Destructor Documentation

◆ ms_buffer_logger()

ms_buffer_logger ( unsigned int colsToOutput = ms_logger::COL_LOGGER_DEFAULTS )

Constructor, sets columns to report.

ms_logger implementation which stores log messages in memory.

Parameters
colsToOutput is used to specify the cols to include in the log and also the format

Member Function Documentation

◆ flush()

std::vector< std::string > flush ( )

Clear and return all messages from the buffer.

Returns
A vector of formatted log message strings. The strings may contain newlines.

◆ formatMessage()

std::string formatMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId
 | ) |  | const
 inherited

Returns a string with formatting based on the columns requested to be output.

Called by ms_stdout_logger::onLogMessage and ms_file_logger::onLogMessage to return a formatted string based on the ms_logger::LogOutputColumns_e flags returned by getColsToOutput().

This function can obviously also be called by any custom ms_logger

Parameters
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message (from MDRO)
Returns
the formatted string.

◆ getColsToOutput()

unsigned int getColsToOutput ( ) const
virtualinherited

Return the value which specifies which columns should be output by the logger.

The value returned is one or more ms_logger::LogOutputColumns_e values bitwise ORed together. formatMessage uses this value to determine which columns to return.

Returns
the value set in the constructor or by calling ms_logger::setColsToOutput

◆ getHeaderLine()

std::string getHeaderLine ( ) const
inherited

Returns the header line based on the specified column names.

Returns
a string that contains the column names

◆ onLogMessage()

void onLogMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId = 0
 | ) |  |
virtual

Format and store the passed message in memory.

Parameters
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message

Implements ms_logger.

◆ setColsToOutput()

void setColsToOutput ( const unsigned int colsToOutput )
virtualinherited

Set the value to specify which columns should be output by the logger.

formatMessage uses this value to determine which columns to return.

Parameters
colsToOutput is formed by bitwise ORing one or more ms_logger::LogOutputColumns_e values
The documentation for this class was generated from the following files:
  • ms_logging.hpp
  • ms_logging.cpp
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_errors Class Reference

  • matrix_science
  • ms_errors
Public Member Functions | List of all members
ms_errors Class Reference
Error handling and logging

This class is used as a base class for several Mascot Parser classes. More...

#include <ms_errors.hpp>

Inheritance diagram for ms_errors:
[legend]
Collaboration diagram for ms_errors:
[legend]

Public Member Functions

ms_errors ()
Default constructor.
~ms_errors ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | isValid () const
Call this function to determine if there have been any errors.

Detailed Description

This class is used as a base class for several Mascot Parser classes.

Examples
common_error.cpp.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ isValid()

bool isValid ( ) const

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_errors.hpp
  • ms_errors.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_errs Class Reference

  • matrix_science
  • ms_errs
Public Types | Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
ms_errs Class Reference
Error handling and logging

All errors are collected in an instance of this class. More...

#include <ms_errors.hpp>

Inheritance diagram for ms_errs:
[legend]
Collaboration diagram for ms_errs:
[legend]

Public Types

typedef msg_num_t | err
Definitions for error numbers.
typedef int | msg_num_t
Typedef for log and error message numbers.
enum msg_sev {
sev_fatal = 1 ,
sev_warn = 2 ,
sev_info = 3 ,
sev_debug1 = 4 ,
sev_debug2 = 5 ,
sev_debug3 = 6
}
Message severity levels. More...

Public Member Functions

ms_errs (msg_sev loglevel=sev_warn, bool combineRepeats=true, ms_loggingmonitor::Source_e api=ms_loggingmonitor::SRC_MSPARSER)
Constructor.
virtual | ~ms_errs ()
Destructor.
void | addToCatalog (const msg_catalog_t catalog[], size_t numEntries, ms_loggingmonitor::Source_e src, errorOrLogMessages_e errorOrLogMessages)
Add messages to the fast lookup map.
void | appendErrors (const ms_errs &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | forwardToParentInstance (ms_errs *parent)
Enable all messages from one object to be forwarded to another.
bool | getCombineRepeats () const
Get the flag for whether to merge repeated error messages.
int | getErrorNumber (const int num=-1) const
Return a specific error number or ERR_NO_ERROR.
int | getErrorRepeats (const int num=-1) const
Returns a number of times the specified error has been repeated.
msg_sev | getErrorSeverity (const int num=-1) const
Returns the severity of the specified error, warning, information or debug message.
std::string | getErrorString (const int num) const
Returns a specific error as a string.
int | getLastError () const
Return the last error number or ERR_NO_ERROR if no errors.
std::string | getLastErrorString () const
Return the last error number or an empty string.
std::string | getLoggingFileName () const
Return the name of the logging file.
virtual msg_sev | getLoggingLevel () const
Get the logging level.
ms_loggingmonitor::Source_e | getMessageSource (const ms_log::msg_num_t msgNum) const
Return the component (library/application) that generated the specified log message.
int | getNumberOfErrors () const
Return the number of errors since the last call to clearAllErrors().
bool | isValid () const
Returns TRUE if no errors occurred, FALSE otherwise.
void | setAPI (ms_loggingmonitor::Source_e api)
Sets the source API for the messages.
void | setCombineRepeats (const bool flag)
Set the flag for whether to merge repeated error messages.
void | setLoggingFile (const std::string filename, const msg_sev level)
Set the logging file.
void | setLoggingLevel (const msg_sev level)
Set the logging level.
bool | willMessageBeLogged (const ms_errs::err errorNum) const
Check to see if the message will be logged to a file or recorded anywhere.

Static Public Member Functions

static ms_errs::msg_sev | convertFromLogLevel (ms_loggingmonitor::Level_e logLevel)
Convert the ms_loggingmonitor level to an ms_errs severity.
static ms_loggingmonitor::Level_e | convertToLogLevel (ms_errs::msg_sev severity)
Convert the ms_errs severity level to a ms_loggingmonitor level.

Static Public Attributes

static const err | ERR_ACCINPEPTIDESTR = 0x0008
[F] Could not parse an item for a given accession in the peptide section.
static const err | ERR_ADDPEPTIDES = 0x000B
[F] Failed to add peptides when creating the peptide summary.
static const err | ERR_CANNOT_APPEND_RESFILE = 0x0038
[F] The file %s cannot be appended to %s because %s values are different.
static const err | ERR_CANNOT_APPEND_RESFILE_NO_FNAMES = 0x0039
[F] The file cannot be appended because %s values are different.
static const err | ERR_CDB_64_BIT_REMAKE = 0x002C
[W] Re-creating %s. Was too large for 32 bit, but may succeed with 64 bit.
static const err | ERR_CDB_BEING_CREATED = 0x0031
[W] Cache file %% being created by another task. Continuing without cache.
static const err | ERR_CDB_FAIL_LOCK = 0x0033
[W] Failed to lock cache file %s. Error code: %d.
static const err | ERR_CDB_FAIL_REMOVE = 0x0032
[W] Failed to remove old cache file %s - error %s. Continuing without cache.
static const err | ERR_CDB_FAIL_UNLOCK = 0x0034
[W] Failed to unlock cache file %s. Error code: %d.
static const err | ERR_CDB_INCOMPLETE_NO_RETRY = 0x0030
[W] Cache file %s was not complete. Continuing without cache.
static const err | ERR_CDB_INCOMPLETE_RETRY = 0x002F
[W] Cache file %s was not complete. Re-creating the cache file.
static const err | ERR_CDB_OLD_VER_NO_RETRY = 0x002E
[W] Cache file %s is an old version. Continuing without cache.
static const err | ERR_CDB_OLD_VER_RETRY = 0x002D
[W] Cache file %s is an old version. Creating new cache file.
static const err | ERR_CDB_SOURCE_CHANGE_NO_RETRY = 0x0036
[W] %s changed. %s (was %s), %s bytes (was %s). Continuing without cache.
static const err | ERR_CDB_SOURCE_CHANGE_RETRY = 0x0035
[W] %s changed. %s (was %s), %s bytes (was %s). Re-creating the cache file.
static const err | ERR_CDB_TOO_LARGE = 0x002A
[W] Cannot use cache file (s) which exceeded max size of s. Try deleting the cache file and retrying.
static const err | ERR_DUPE_ACCESSION = 0x0013
[W] A possible duplicate accession string has been found. Possible problem in database.
static const err | ERR_DUPLICATE_KEY = 0x0018
[W] Duplicate entries with the same key in the named section.
static const err | ERR_FAIL_CDB_INIT = 0x0027
[W] Failed to initialise cache file (%s). Error code %d.
static const err | ERR_FAIL_CLOSE_FILE = 0x0026
[W] Failed to close file.
static const err | ERR_FAIL_MK_CACHE_DIR = 0x0024
[F] Failed to create cache directory for cache files.
static const err | ERR_FAIL_MK_CDB_FILE = 0x0025
[W] Failed to create an cache file.
static const err | ERR_FAIL_OPEN_DAT_FILE = 0x0022
[F] Failed to open the results file for reading.
static const err | ERR_INVALID_CACHE_DIR = 0x0021
[F] Must specify a cache directory if using CDB cache files.
static const err | ERR_INVALID_CDB_FILE = 0x0028
[W] Value in cdb cache file (%s) is corrupt: %s.
static const err | ERR_INVALID_NUMQUERIES = 0x001C
[W] Invalid number of queries in results file has been corrected.
static const err | ERR_INVALID_PROTDB = 0x001F
[W] Invalid h1_db-string format. Expecting an integer number.
static const err | ERR_INVALID_RESFILE = 0x001E
[F] Invalid results file format – missing or corrupt headers.
static const err | ERR_MALFORMED_DRANGE = 0x001B
[W] Expecting a line in format q1_p2_drange=0,256.
static const err | ERR_MALFORMED_ERR_TOL = 0x000F
[W] Expecting a line of format q1_p2_et_mods=0.984020,0.000000,Citrullination.
static const err | ERR_MALFORMED_TAG = 0x001A
[W] Expecting a line in format q1_p2_tag=1:3:5:6,2:4:12:6,....
static const err | ERR_MALFORMED_TERMS = 0x001D
[W] Expecting a line in format q1_p2_terms=A,B:-,I:....
static const err | ERR_MISSING_CDB_FILE = 0x0023
[W] Cache file is missing or cannot be opened.
static const err | ERR_MISSING_PERCOLATOR_FILE = 0x0037
[F] Percolator file %s is missing. Cannot continue.
static const err | ERR_MISSINGENTRY = 0x0005
[F] Set if there is no qexp value in the file.
static const err | ERR_MISSINGHIT = 0x000C
[F] Missing hit in the summary section.
static const err | ERR_MISSINGSECTION = 0x000D
[F] Complete missing section in the file.
static const err | ERR_MISSINGSECTIONEND = 0x000E
[F] Missing end of section in the file.
static const err | ERR_MSP_BIND_INVALID_CPU = 0x0152
[W] Warning: Failed to bind invalid processor number: d.
static const err | ERR_MSP_CACHE_DATAOFFSETINVALID = 0x1B05
[F] Cache file meta data offset is invalid. 'filename'.
static const err | ERR_MSP_CACHE_DUPLICATESTREAMID = 0x1B0A
[F] Duplicate stream id detected: 'filename'.
static const err | ERR_MSP_CACHE_FILESEEKFAILED = 0x1B06
[F] Failed to open cache file: [code] 'filename'.
static const err | ERR_MSP_CACHE_INVALIDFORMAT = 0x1B03
[F] File format no longer supported. 'filename'.
static const err | ERR_MSP_CACHE_INVALIDSTREAMID = 0x1B08
[F] Stream ID is invalid: [id] 'filename'.
static const err | ERR_MSP_CACHE_INVALIDSTREAMPOSITION = 0x1B09
[F] Stream position is invalid: [position] 'filename'.
static const err | ERR_MSP_CACHE_INVALIDVERSION = 0x1B07
[F] File version is invalid: [version] 'filename'.
static const err | ERR_MSP_CACHE_MODIFYCLOSED = 0x1B0F
[F] Attempted to modify cache file while closed: 'filename'.
static const err | ERR_MSP_CACHE_MODIFYREADONLYMODE = 0x1B0E
[F] Attempted to modify cache file opened for read-only mode: 'filename'.
static const err | ERR_MSP_CACHE_OPENFAILED = 0x1B01
[F] Failed to open cache file: [code] 'filename'.
static const err | ERR_MSP_CACHE_PROT_NUMPEPTIDES_RELOAD = 0x1B12
[W] Protein "[accession]" expected [num] peptides, but read [num] from the cache file
static const err | ERR_MSP_CACHE_READFAILED = 0x1B02
[F] Failed to read cache file: [code] 'filename'.
static const err | ERR_MSP_CACHE_SIGNATUREINVALID = 0x1B04
[F] Cache file signature is invalid. 'filename'.
static const err | ERR_MSP_CACHE_SLREF_UPDATE = 0x1B11
[W] Cache file for spectral library search was created by Parser 2.6.0, but the treatment of reference accessions changed in Parser 2.6.1. Re-creating the cache file.
static const err | ERR_MSP_CACHE_STREAMNOTFOUND = 0x1B0C
[F] Failed to find stream in cache file: [streamID] 'filename'.
static const err | ERR_MSP_CACHE_UNINITIALISEDSTREAM = 0x1B10
[F] Attempted to access uninitialised stream.
static const err | ERR_MSP_CACHE_WRITEFAILED = 0x1B0B
[F] Failed to write cache file: [code] 'filename'.
static const err | ERR_MSP_CACHE_WRITETRUNCATED = 0x1B0D
[F] Write to cache file was truncated: 'filename'.
static const err | ERR_MSP_CLOSEST_FDR_FOR_ET = 0x1F04
[W] Target FDR s g%% could not be reached for error tolerant matches. Using closest s FDR g%% with minProbability = g.
static const err | ERR_MSP_CLOSEST_FDR_FOR_FIRST_PASS = 0x1F07
[W] Target FDR s g%% could not be reached. Using closest s FDR g%% with minProbability = g.
static const err | ERR_MSP_COLOURSCHEME_INVALID = 0x0629
[W] Colour scheme must be a comma-separated list of key=value pairs where keys and values have a specified format: s
static const err | ERR_MSP_COMPILE_PARSE_RULE = 0x0603
[W] Error while compiling a parse rule with regex.
static const err | ERR_MSP_CONFLICT_BETWEEN_MODS = 0x0A01
[F] A conflict between two or more modifications detected.
static const err | ERR_MSP_CRON_INVALID_CHAR = 0x0614
[W] Invalid character in Cron section.
static const err | ERR_MSP_CRON_INVALID_NUMBER = 0x0615
[W] Invalid number in Cron section.
static const err | ERR_MSP_CRON_INVALID_STAR = 0x0616
[W] Invalid star-character in Cron section.
static const err | ERR_MSP_CRON_NO_NUM_BEFORE_COMMA = 0x0617
[W] Expecting number before comma (,) in Cron section.
static const err | ERR_MSP_CRON_NO_NUM_BEFORE_MINUS = 0x0618
[W] Expecting number before dash (-) in Cron section.
static const err | ERR_MSP_CRON_TOO_MANY_JOBS = 0x0609
[W] Too many cron jobs.
static const err | ERR_MSP_CROSSLINKING_FAILEDLOAD = 0x2100
[W] Failed to load crosslinking.xml file.
static const err | ERR_MSP_CROSSLINKING_FAILEDSAVE = 0x2101
[W] Failed to save crosslinking.xml file.
static const err | ERR_MSP_CROSSLINKING_INVALID_LINK = 0x0A11
[F] Invalid link between peptides (link from = d, link to = d, site from = d, site to = d).
static const err | ERR_MSP_CROSSLINKING_MULTI_LINKS = 0x0A10
[F] Fragmenting with d links between peptides is not implemented.
static const err | ERR_MSP_CROSSLINKING_MULTI_PEPTIDE = 0x0A09
[F] Fragmenting of d linked peptides is not implemented.
static const err | ERR_MSP_CROSSLINKING_VARMOD_CONFLICT = 0x0A12
[F] Linker site contains a variable modification (peptide = s, position = d).
static const err | ERR_MSP_CUSTQUANT_FAILEDINIT = 0x1450
[E] Failed to initialise ms_customquantitation: %s .
static const err | ERR_MSP_CUSTQUANT_PROTR_UNIM = 0x1451
[W] Protein ratio type %s is not implemented; resetting to median.
static const err | ERR_MSP_DB_USES_MISSING_RULE = 0x0602
[W] A database uses non-existent rule.
static const err | ERR_MSP_DIFFERENT_1ST_PASS_THR_ET = 0x1F05
[W] Significance threshold has been changed from the original target value used to select proteins for the second pass search. Original first pass threshold = g, current threshold = g.
static const err | ERR_MSP_DOUBLE_CHARGE_NOT_ALLOWED = 0x0A05
[F] Double charged ions are not allowed on this series.
static const err | ERR_MSP_DUP_TAXONOMYRULE = 0x061F
[W] A taxonomy rule with duplicate number has been encountered.
static const err | ERR_MSP_DUPLICATE_MOD = 0x0400
[F] Duplicate modification names in mod_file.
static const err | ERR_MSP_EMPTY_MOD = 0x0A07
[F] A modification is missing or incomplete (perhaps it was not found in the configuration files).
static const err | ERR_MSP_ENZYME_DEFINITION_PROBLEM = 0x0502
[F] Invalid enzyme definition.
static const err | ERR_MSP_ENZYME_FILE_FORMAT = 0x0500
[F] Error in enzymes file.
static const err | ERR_MSP_ENZYME_TOO_MANY_RULES = 0x0503
[F] Too many cleavage rules for enzyme.
static const err | ERR_MSP_EXEC_AFTER_SEARCH_DEPENDS = 0x0622
[W] ExecAfterSearch has waitfor %d, but no %d command.
static const err | ERR_MSP_EXEC_AFTER_SEARCH_INVALID = 0x0621
[W] ExecAfterSearch must start with waitforX, where 0 <= X <= 10.
static const err | ERR_MSP_EXEC_AFTER_SEARCH_LOGGING = 0x0623
[W] ExecAfterSearch has an invalid logging level (should be 0..3).
static const err | ERR_MSP_FAIL_GET_PROCESS_AFFINITY = 0x0105
[F] Failed to find information about number of processors available: s.
static const err | ERR_MSP_FAIL_GET_SYSINFO = 0x0107
[F] Failed to obtain system information.
static const err | ERR_MSP_FAIL_HWLOC_INIT = 0x0150
[F] Failed to determine details about processors. (Call to hwloc_topology_init failed).
static const err | ERR_MSP_FAIL_HWLOC_LOAD = 0x0151
[F] Failed to determine details about processors. (Call to hwloc_topology_load failed).
static const err | ERR_MSP_FAIL_PROCESSOR_BIND = 0x0153
[W] Warning: Failed to bind process to set of processors (s). Return d, errno d.
static const err | ERR_MSP_FAIL_STAT = 0x0102
[W] OS-specific API-function stat() failed.
static const err | ERR_MSP_FAIL_THREAD_BIND = 0x0154
[W] Warning: Failed to bind thread d to processor d. Return d, errno d.
static const err | ERR_MSP_FAIL_UTIME = 0x0109
[W] Failed calling function utime() on file '%s'.
static const err | ERR_MSP_FAILED_TO_CLOSE_FILE = 0x0101
[W] Can happen everywhere.
static const err | ERR_MSP_FAILED_TO_OPEN_FILE = 0x0100
[F] Error when opening file.
static const err | ERR_MSP_FAILED_TO_READ_FILE = 0x010A
[F] Failed to read from "%s": s
static const err | ERR_MSP_FAILED_TO_WRITE_FILE = 0x0108
[F] Failed to write to file '%s' (file not open or disk full).
static const err | ERR_MSP_FILE_DOESNT_EXIST = 0x0104
[F] Cannot open file because it doesn't exist.
static const err | ERR_MSP_FRAGMENTATION_RULES = 0x0200
[F] Error when parsing fragmentation_rules file.
static const err | ERR_MSP_GET_VOLUME_INFO = 0x0103
[W] Failed to get volume information.
static const err | ERR_MSP_HTTP_ABORTEDBYUSER = 0x1A0E
[F] HTTP request aborted by user.
static const err | ERR_MSP_HTTP_BADHTTPSTATUS = 0x1A16
[F] HTTP status is [httpCode] 'httpText'.
static const err | ERR_MSP_HTTP_CHANGEPASSWORDDISABLED = 0x190B
[F] Change password failed: security is disabled.
static const err | ERR_MSP_HTTP_CLOSECONNECTIONFAILED = 0x1A0C
[F] Failed to close HTTP connection [code] 'text'.
static const err | ERR_MSP_HTTP_CLOSEREQUESTFAILED = 0x1A0D
[F] Failed to close HTTP request [code] 'text'.
static const err | ERR_MSP_HTTP_CLOSESESSIONFAILED = 0x1A0B
[F] Failed to close HTTP session [code] 'text'.
static const err | ERR_MSP_HTTP_DOWNLOADFAILED = 0x1A1B
[W] Unable to complete download of [s] to the local file [s] due to the following error: [s]. Check network and proxy settings or the local file permissions and try again.";
static const err | ERR_MSP_HTTP_ERROR = 0x1A17
[F] 'httpText'.
static const err | ERR_MSP_HTTP_GETPROXYFAILED = 0x1A15
[F] Failed to get HTTP proxy
static const err | ERR_MSP_HTTP_GETRESULTSFILENAME = 0x1A1A
[W] The http call client.pl?result_file_name&task_id=[taskID] returned [text]
static const err | ERR_MSP_HTTP_GETSEARCHSTAGE = 0x1A1D
[W] The http call client.pl?status_current_stage&task_id=[taskID] returned [text]
static const err | ERR_MSP_HTTP_HEADERFAILED = 0x1A1C
[W] Unable to access [s] due to the following error: [s]. Check network and proxy settings and try again.
static const err | ERR_MSP_HTTP_INVALID_URL = 0x0902
[F] Invalid web-address.
static const err | ERR_MSP_HTTP_LOGINERROR = 0x1909
[F] Mascot server login.pl=[command] error: [code].
static const err | ERR_MSP_HTTP_LOGINERRORINT = 0x190A
[F] Mascot server login.pl=[command(param)] error: [code].
static const err | ERR_MSP_HTTP_LOGINPARSERERROR = 0x1905
[F] Mascot server login.pl=[command] parser error: [code].
static const err | ERR_MSP_HTTP_LOGINPARSERERRORINT = 0x1906
[F] Mascot server login.pl=[command(param)] parser error: [code].
static const err | ERR_MSP_HTTP_LOGINSERVERERROR = 0x1907
[F] Mascot server login.pl=[command] server error.
static const err | ERR_MSP_HTTP_LOGINSERVERERRORINT = 0x1908
[F] Mascot server login.pl=[command(param)] server error.
static const err | ERR_MSP_HTTP_MAXCONECTIONS10FAILED = 0x1A10
[W] Failed to set maximum connections per 1.0 server
static const err | ERR_MSP_HTTP_MAXCONECTIONSFAILED = 0x1A0F
[W] Failed to set maximum connections per server
static const err | ERR_MSP_HTTP_MISSINGLOGINERROR = 0x1903
[F] Mascot server login.pl is not present.
static const err | ERR_MSP_HTTP_MISSINGLOGININFO = 0x1904
[I] Mascot server login.pl is not present; security is disabled.
static const err | ERR_MSP_HTTP_NORESPONSE = 0x1A08
[F] Failed to receive HTTP response
static const err | ERR_MSP_HTTP_OPENCONNECTIONFAILED = 0x1A0C
[F] Failed to open HTTP connection
static const err | ERR_MSP_HTTP_OPENOUTPUTFILEFAILED = 0x190C
[F] Failed to open file for writing: [code] 'text'.
static const err | ERR_MSP_HTTP_OPENREQUESTFAILED = 0x1A0D
[F] Failed to open HTTP request
static const err | ERR_MSP_HTTP_OPENSESSIONFAILED = 0x1A0B
[F] Failed to open HTTP session
static const err | ERR_MSP_HTTP_QUERYDATAFAILED = 0x1A13
[F] Failed to query data status
static const err | ERR_MSP_HTTP_QUERYSTATUSFAILED = 0x1A0A
[F] Failed to query HTTP status
static const err | ERR_MSP_HTTP_READDATAFAILED = 0x1A14
[F] Failed to read data
static const err | ERR_MSP_HTTP_READRESPONSEFAILED = 0x1A11
[F] Failed to read HTTP response: [code] 'text'.
static const err | ERR_MSP_HTTP_RELOGINFAILED = 0x190E
[F] Failed to relogin to the Mascot server: [code] '[text]'.
static const err | ERR_MSP_HTTP_SENDREQUESTFAILED = 0x1A12
[F] Failed to send HTTP request
static const err | ERR_MSP_HTTP_SESSIONALREADYOPEN = 0x1A18
[F] A session is already open.
static const err | ERR_MSP_HTTP_SETHTTPPASSWORDFAILED = 0x1A05
[F] Failed to set HTTP password
static const err | ERR_MSP_HTTP_SETHTTPUSERNAMEFAILED = 0x1A04
[F] Failed to set HTTP username
static const err | ERR_MSP_HTTP_SETPROXYFAILED = 0x1A01
[F] Failed to set HTTP proxy
static const err | ERR_MSP_HTTP_SETPROXYPASSWORDFAILED = 0x1A03
[F] Failed to set HTTP proxy password
static const err | ERR_MSP_HTTP_SETPROXYUSERNAMEFAILED = 0x1A02
[F] Failed to set HTTP proxy username
static const err | ERR_MSP_HTTP_SETREDIRECTFAILED = 0x1A06
[F] Failed to set redirect policy
static const err | ERR_MSP_HTTP_TRANSMISSION_FAILED = 0x0901
[F] Http-transmission failed.
static const err | ERR_MSP_HTTP_VERSIONERROR = 0x1902
[F] Mascot version error: s.
static const err | ERR_MSP_HTTP_WEBAUTHERROR = 0x1901
[F] Mascot login error: could not determine if web authentication is enabled.
static const err | ERR_MSP_HTTP_WRITEOUTPUTFILEFAILED = 0x190D
[F] Failed to write to file: [code].
static const err | ERR_MSP_HTTP_XMLUPLOADFAILED = 0x1C01
[F] Failed to upload XML data: 'text'.
static const err | ERR_MSP_IMPUTATION_AVERAGE_PROGRESS = 0x220D
[I] Average algorithm progress and info
static const err | ERR_MSP_IMPUTATION_CONSTRUCTOR = 0x2205
[W] Warning for objects set in imputation constructor
static const err | ERR_MSP_IMPUTATION_DEBUG1 = 0x2202
[D1] Debug1 message.
static const err | ERR_MSP_IMPUTATION_DEBUG2 = 0x2203
[D2] Debug2 message.
static const err | ERR_MSP_IMPUTATION_DEBUG3 = 0x2204
[D3] Debug3 message.
static const err | ERR_MSP_IMPUTATION_EMPTY_DATA = 0x220A
[W] Data is empty or contains empty row
static const err | ERR_MSP_IMPUTATION_FAIL = 0x2200
[F] Fail message.
static const err | ERR_MSP_IMPUTATION_FIXED_PROGRESS = 0x220C
[I] Fixed algorithm progress and info
static const err | ERR_MSP_IMPUTATION_KNN_BLANK_ROW = 0x220B
[W] KNN encountered a row with no known values
static const err | ERR_MSP_IMPUTATION_KNN_PROGRESS = 0x220E
[I] KNN algorithm progress and info
static const err | ERR_MSP_IMPUTATION_MISSFOR_PROGRESS = 0x220F
[I] Miss Forest progress and info
static const err | ERR_MSP_IMPUTATION_NO_RATIOS_PEPTIDE = 0x2208
[W] No ratios present for a peptide
static const err | ERR_MSP_IMPUTATION_NO_RATIOS_PROTEIN = 0x2207
[W] No ratios present for this protein
static const err | ERR_MSP_IMPUTATION_NO_TIMES = 0x2209
[F] No retention times present for a ms_imputationPeptideData
static const err | ERR_MSP_IMPUTATION_VARIABLE = 0x2206
[F] IMPUTATION_VARIABLE not set
static const err | ERR_MSP_IMPUTATION_WARNING = 0x2201
[W] Warning message.
static const err | ERR_MSP_IN_CLUSTER_SECTION = 0x0607
[W] Error in CLUSTER section.
static const err | ERR_MSP_IN_MASCOT_DAT_DB_SECT = 0x0605
[W] Error in Databases section.
static const err | ERR_MSP_IN_MASSES_FILE = 0x0300
[F] Error when parsing "masses" file.
static const err | ERR_MSP_IN_MODS_FILE = 0x0404
[F] Error in mod file.
static const err | ERR_MSP_IN_OPTIONS_SECTION = 0x0606
[W] Error in OPTIONS section.
static const err | ERR_MSP_IN_TAXONOMY_SECTION = 0x060F
[W] Error in Taxonomy section.
static const err | ERR_MSP_INCOMPATIBLE_TAX_RULES = 0x0610
[W] Incompatible taxonomy rules.
static const err | ERR_MSP_INST_CANTGETHOSTNAME = 0x1803
[F] Failed to determine the hostname.
static const err | ERR_MSP_INST_FAILADDPARSERULE = 0x1802
[F] Failed to added parse rule required for SwissProt - too many rules already in mascot.dat?
static const err | ERR_MSP_INST_INVALIDCPUINFO = 0x1800
[W] Failed to get CPU information. Assuming single core and no hyper-threading.
static const err | ERR_MSP_INST_MISSINGDATABASE = 0x1801
[W] No entry for s found in not.mascot.dat.
static const err | ERR_MSP_INVALID_CPU_PACKAGE_NUM = 0x0156
[W] Warning: Request for information about invalid cpu package number: d at line: d.
static const err | ERR_MSP_INVALID_LOGICAL_CPU_NUM = 0x0155
[W] Warning: Request for information about invalid logical cpu number: d at line: d.
static const err | ERR_MSP_INVALID_MASS_IN_MASSES_FILE = 0x0301
[F] Invalid mass in "masses" file.
static const err | ERR_MSP_INVALID_NUM_LICENSED = 0x0157
[W] Warning: Request for number of CPUs to run on returns 0 because number licesed is d.
static const err | ERR_MSP_INVALID_PARSE_RULE = 0x060A
[W] Invalid parsing rule.
static const err | ERR_MSP_INVALID_PARSE_RULE_NO = 0x060B
[W] Parsing rule with invalid number.
static const err | ERR_MSP_INVALID_PROCESSOR_LINE = 0x0619
[W] Invalid line in mascot.dat.
static const err | ERR_MSP_LEGACY_DATA_NOT_AVAILABLE = 0x0C01
[F] The legacy data blob is missing from the MSR file. Is the file from a future version of Mascot?
static const err | ERR_MSP_LEGACY_DATA_READ_ERROR = 0x0C04
[F] Error while decompressing the legacy data blob from the MSR file: s
static const err | ERR_MSP_LEGACY_DATA_SQL_ERROR = 0x0C03
[F] Error while reading the MSR file: s.
static const err | ERR_MSP_LEGACY_DATA_WRONG_FORMAT = 0x0C02
[F] The legacy data blob is compressed with an unsupported algorithm "%s".
static const err | ERR_MSP_LICENSE_DES_CHECKSUM = 0x0701
[F] Check sum in the license file is invalid.
static const err | ERR_MSP_LICENSE_EXPIRED = 0x0704
[F] The license has already expired.
static const err | ERR_MSP_LICENSE_INTERNAL_CONFIG = 0x0705
[F] Internal configuration error when reading a license file.
static const err | ERR_MSP_LICENSE_LINE_CHECKSUM = 0x0702
[F] Check sum in the license file is invalid.
static const err | ERR_MSP_LICENSE_LINE_INVALID = 0x0706
[F] Line [line number] of the license file is corrupt or this is not a license file.
static const err | ERR_MSP_LICENSE_NOT_YET_AVAIL = 0x0703
[F] Start date has not come yet.
static const err | ERR_MSP_LOOPLINKING_NOT_IMPLEMENTED = 0x0A08
[F] Fragmenting of looplinked peptides is not implemented.
static const err | ERR_MSP_MALFORMED_PEPTIDE = 0x0A04
[F] Empty or inconsistent peptide: s
static const err | ERR_MSP_MASCOT_NOT_RUNNING = 0x0903
[F] The Mascot service is not running. Unable to retrieve configuration file.
static const err | ERR_MSP_MAX_PREFIX_REMOVES = 0x0611
[W] Maximum number of prefixes is exceeded in Taxonomy section.
static const err | ERR_MSP_MAX_SUFFIX_REMOVES = 0x0612
[W] Maximum number of suffices is exceeded in Taxonomy section.
static const err | ERR_MSP_MAX_TAX_NO_BREAKS = 0x0613
[W] Maximum number of breaks is exceeded in Taxonomy section.
static const err | ERR_MSP_MISSING_DEFINITION_END = 0x0405
[F] Missing end of modification definition.
static const err | ERR_MSP_MISSING_ENZYME_TITLE = 0x0501
[F] Non-comment line encountered while searching for a title.
static const err | ERR_MSP_MISSING_ET_MOD = 0x0A13
[F] Error tolerant modification lookup failed: s
static const err | ERR_MSP_MISSING_MASCOT_DAT = 0x0601
[F] Missing mascot.dat file.
static const err | ERR_MSP_MISSING_MONOLINK_MOD = 0x0A15
[F] Monolink modification lookup failed: s
static const err | ERR_MSP_MISSING_QUOTE_IN_PARSE_RULE = 0x060D
[W] Missing quote character in a parse rule.
static const err | ERR_MSP_MISSING_SECTION = 0x0626
[W] There is no \'s\' section in the file: s
static const err | ERR_MSP_MISSING_SL_MOD = 0x0A14
[F] Spectral library modification lookup failed: s
static const err | ERR_MSP_MOD_MUST_BE_VAR = 0x0A03
[F] This modification can only be variable.
static const err | ERR_MSP_MS1QUANT_CDB_BYTES = 0x147F
[W] In index file: s, incorrect number of bytes in stream: s. Num bytes left: d, overexhausted: d
static const err | ERR_MSP_MS1QUANT_CDB_MISSING_KEY = 0x1481
[W] In index file: s, missing key values: s
static const err | ERR_MSP_MS1QUANT_CDB_VERSION = 0x1480
[W] In index file: s, expecting version: d, found version: d for stream: s
static const err | ERR_MSP_MS1QUANT_GET_COMBINED_LIMITS = 0x1473
[W] Failed to get combined quantitation limits. Missing fraction: %d
static const err | ERR_MSP_MS1QUANT_INVALID_PROJECT_ID = 0x1476
[W] Trying to use an invalid subProject number: %d
static const err | ERR_MSP_MS1QUANT_NO_EST_WIDTH = 0x147E
[W] In getEstimatedFeatureWidth(), for subProject: d, m/z: f, rt: f, bin: d, but there are no features in this bin
static const err | ERR_MSP_MS1QUANT_RTOFFSET_DIFF_FRACT = 0x1474
[W] Trying to get time offset between subproject: %d in fraction: %d and subproject: %d in fraction: %d
static const err | ERR_MSP_MS1QUANT_TIME_ALIGIN_CALCFRM = 0x1482
[W] Unexpected call to calculateFromConsensuValues() : s
static const err | ERR_MSP_MS1QUANT_TIME_ALIGN_INDEX = 0x1475
[W] Invalid index when getting RT offset. This project id: %d, other project id: %d. Rt in other project: %f, m/z: %f. rtInOtherProjectAsInt: %d, Array size: %d
static const err | ERR_MSP_MS1QUANT_XML_INVALID_BIN1 = 0x1478
[W] Invalid bin number when loading xml time alignment. <rawfile=%d, bin=%d> but Minimum bin: %d, Maximum bin: %d
static const err | ERR_MSP_MS1QUANT_XML_INVALID_BIN2 = 0x1479
[W] Invalid bin number when loading xml time alignment. <rawfile=%d, bin=%d> but binOffset: %d, array size: %d
static const err | ERR_MSP_MS1QUANT_XML_INVALID_RT = 0x147A
[W] Invalid retention time when loading xml time alignment. <rawfile=%d, bin=%d> rt: %d, array size: %d
static const err | ERR_MSP_MS1QUANT_XML_LOAD_PROJECT_ID = 0x1477
[W] Trying to use an invalid subProject number: %d when loading xml time alignment. Value should be in the range 1 to %d
static const err | ERR_MSP_MS1QUANT_XML_PARSE = 0x147D
[W] Error parsing XML at line: %d of input file: %s. Error: %s
static const err | ERR_MSP_MS1QUANT_XML_SAX_ELEMENT = 0x147C
[W] Unexpected element: %s with parent element: %s
static const err | ERR_MSP_MS1QUANT_XML_SAX_STATE = 0x147B
[W] Expecting state: dd but at state: ss in function: ss with element name: ss
static const err | ERR_MSP_MS1QUANTITATION_FAILEDINIT = 0x1472
[E] Failed to initialise ms_ms1quantitation: %s
static const err | ERR_MSP_MS1QUANTITATION_HITREF_DROP = 0x1471
[W] Protein hit not found for protein [accession] at reference [oldhit.member]
static const err | ERR_MSP_MS1QUANTITATION_HITREF_NEW = 0x1470
[D2] Protein hit reference has changed for protein [accession] from [oldhit.member] to [newhit.member]
static const err | ERR_MSP_MS2QUANTITATION_COMPONENTS = 0x1435
[W] Different number of raw and corrected MS2 quantitation component intensities for q:d, p:%
static const err | ERR_MSP_MS2QUANTITATION_FAILEDINIT = 0x1430
[E] Failed to initialise ms_ms2quantitation: %s
static const err | ERR_MSP_MS2QUANTITATION_NORM_NO_SUM = 0x1431
[W] Sum normalisation is only implemented in Reporter (current protocol is %s); ignoring normalisation type
static const err | ERR_MSP_MS2QUANTITATION_NORM_UNIMP = 0x1432
[W] Unknown normalisation type %s; ignoring
static const err | ERR_MSP_MS2QUANTITATION_PROTR_UNIM = 0x1434
[W] Protein ratio type %s is not implemented; resetting to median
static const err | ERR_MSP_MS2QUANTITATION_PROTWEIGH = 0x1433
[W] Protein ratio type 'Summed intensities' is only implemented in Reporter (current protocol is %s); resetting to median
static const err | ERR_MSP_MS2QUANTITATION_QUERY_SECS = 0x1436
[W] Cannot provide quantitation information because there is no ms-ms data in this file
static const err | ERR_MSP_MSR_CREATING_FILE = 0x0E01
[E] Failed to open "%s" for writing: s
static const err | ERR_MSP_MSR_READING_FILE = 0x0D01
[W] Failed to read the MSR file: s
static const err | ERR_MSP_MSR_WRITING_FILE = 0x0E02
[E] Failed to execute SQL statement on "%s": s
static const err | ERR_MSP_NEED_1_EXP_IN_PARSE_RULE = 0x0604
[W] Only one subexpression is allowed per parse rule.
static const err | ERR_MSP_NIST_CANNOT_ANNOTATE_PEAK = 0x1D09
[W] Ion series '[text]' is not valid in NIST format and cannot be used to annotate peaks
static const err | ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY = 0x1D06
[F] Failed to load entry number [text] from [file]. Error [text]
static const err | ERR_MSP_NIST_INDEX_OUT_OF_RANGE = 0x1D0A
[F] Requesting an invalid spectrum number (d) in the msp file: 's' which has d entries
static const err | ERR_MSP_NIST_MODIFICATION_NOT_FOUND = 0x1D0C
[W] The spectral library file contains one or more references to modification: [name] which are not present in unimod. Consider adding to the library_mod_aliases file if appropriate.
static const err | ERR_MSP_NIST_MSP_INCONSISTENT_MODS = 0x1D05
[W] The msp file: 'filename' has an inconsistent mods entry: [text]
static const err | ERR_MSP_NIST_MSP_INVALID_LINE = 0x1D01
[W] The msp file: 'filename' has an unexpected line: 'line'
static const err | ERR_MSP_NIST_MSP_MISSING_PARAMETER = 0x1D02
[W] Missing 'key' in msp file: 'filename'.
static const err | ERR_MSP_NIST_MSP_NO_CREATE_CDB = 0x1D04
[W] Cannot create index file: for msp file: because . Will continue without index
static const err | ERR_MSP_NIST_MSP_NO_SPECTRA = 0x1D03
[F] 'filename' doesn't appear to be an msp file: no lines starting with Name: or no precursor m/z values specified
static const err | ERR_MSP_NIST_NO_PEAKS_IN_SPECTRUM = 0x1D08
[W] The msp file: '[file]' contains a spectrum with no peaks. First line is: '[text]'
static const err | ERR_MSP_NIST_NO_PRECURSOR_MZ_VALUE = 0x1D0B
[W] The spectral library file: '[file]' contains a spectrum with no precursor m/z value. First line for spectrum is: '[text]'
static const err | ERR_MSP_NIST_SAVE_ZERO_SPECTRA = 0x1D07
[W] Calling ms_spectral_lib_file::saveAs([file]), with start=[value] and end=[value], so file not saved
static const err | ERR_MSP_NO_COMMAS_IN_MOD_NAME = 0x0403
[F] Comma is not allowed in mod name.
static const err | ERR_MSP_NO_ENZYME_SET = 0x0A06
[F] Cannot iterate peptides without enzyme specificity.
static const err | ERR_MSP_NO_LICENSE_FILE = 0x0700
[F] License file cannot be found or invalid.
static const err | ERR_MSP_NO_REGEX_MATCH = 0x0627
[W] Could not find description / accession number in s using rule: s
static const err | ERR_MSP_NO_SUCH_MOD = 0x0406
[F] Cannot find a modification.
static const err | ERR_MSP_PARSE_LEN_EXCEED = 0x060E
[W] Parse rule length exceeds the limit.
static const err | ERR_MSP_PERCOLATOR_USE_RT_OBSOLETE = 0x0630
[W] PercolatorUseRT is enabled. Percolator's RT model is obsolete but is still supported for backward compatibility reasons. A DeepLC model should be used instead.
static const err | ERR_MSP_PROCESSOR_NOT_IN_SET = 0x061A
[W] Processor specified is not in the ProcessorSet.
static const err | ERR_MSP_QUANT_ACCESSION_NOT_FOUND = 0x2005
[W] Passed accession value [accession] is not present in the search results. The Average reference protein will not be updated
static const err | ERR_MSP_QUANT_CDB_MATCH_STREAM = 0x2000
[F] Failed to load the quantitation match stream, or failed on bytes available check. Cache file name: [text], cdb file name: [text], key: [text]"
static const err | ERR_MSP_QUANT_CDB_MISSING_KEY = 0x2001
[F] No data from cdb for key. Cdb file name: [text], key: [text]
static const err | ERR_MSP_QUANT_EMPTY_REF_ACCESSION = 0x2004
[W] Passed accession value is empty. The Average reference protein will not be updated
static const err | ERR_MSP_QUANT_FAIL_LOAD_MATCH = 0x2007
[W] Quantitation error: failed to load match [value]
static const err | ERR_MSP_QUANT_FAIL_LOAD_PEPTIDE = 0x2003
[F] Failed to load peptide at index [number]
static const err | ERR_MSP_QUANT_FAILEDLOAD = 0x1400
[W] Failed to load quantitation configuration file.
static const err | ERR_MSP_QUANT_FAILEDSAVE = 0x1401
[W] Failed to save quantitation configuration file.
static const err | ERR_MSP_QUANT_HELPER_FAILEDINIT = 0x1410
[E] Failed to initialise ms_quant_helper: %s
static const err | ERR_MSP_QUANT_INVALID_REF_AMOUNT = 0x2006
[W] The passed reference amount value '[value]' is invalid. The reference amount will be set to the default of 1
static const err | ERR_MSP_QUANT_MISSING_COMPONENT = 0x2002
[W] Component number [number] is missing from match [number]
static const err | ERR_MSP_QUANTITATION_BADCOMPONENT = 0x1423
[W] The component name 's' does not exist in the quantitation mehod
static const err | ERR_MSP_QUANTITATION_BADMETHOD = 0x1422
[W] The quantitation method protocol s is not supported for function s
static const err | ERR_MSP_QUANTITATION_FAILEDINIT = 0x1420
[E] Failed to initialise ms_quantitation: %s
static const err | ERR_MSP_QUANTITATION_NOMETHOD = 0x1421
[W] No quantitation method is specified in the results file
static const err | ERR_MSP_REGEX_ERROR = 0x0628
[W] Error s finding description / accession number using rule: s
static const err | ERR_MSP_REPORTBUILDERCOLARR_INVALID = 0x0624
[W] ReportBuilderColumnArrangement must be of the form Name:[columns] where [columns] is a comma-separated string of column names.
static const err | ERR_MSP_RESIDUE_AND_TERMINUS_MOD = 0x0401
[F] Bad mod combination.
static const err | ERR_MSP_RULE_NO_ALREADY_DEFINED = 0x060C
[W] Parsing rule has been defined twice.
static const err | ERR_MSP_SECURITY_ACCOUNT_DISABLED = 0x110E
[F] Cannot login, your account (%s) has been disabled.
static const err | ERR_MSP_SECURITY_ADDGROUP = 0x1204
[I] Add group: name=%s, id=%d.
static const err | ERR_MSP_SECURITY_ADDUSER = 0x1200
[I] Add user: name=%s, id=%d, type=%d, enabled=%d.
static const err | ERR_MSP_SECURITY_BAD_GROUP_NAME = 0x1009
[W] Invalid group name - names cannot contain the following characters:
static const err | ERR_MSP_SECURITY_BAD_USER_NAME = 0x1004
[W] Invalid user name - names cannot contain the following characters:
static const err | ERR_MSP_SECURITY_CMDLINE_CGI = 0x111F
[F] Cannot use command-line session while running in CGI environment.
static const err | ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP = 0x1013
[W] The administrator user cannot be removed from the administrator group.
static const err | ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS = 0x1012
[W] The administrator rights cannot be removed from the administrator group.
static const err | ERR_MSP_SECURITY_DEL_SPECIAL_GROUP = 0x100F
[W] The special system group 's' cannot be deleted.
static const err | ERR_MSP_SECURITY_DEL_SPECIAL_USER = 0x1010
[W] The The special system user 's' cannot be deleted.
static const err | ERR_MSP_SECURITY_DELETEGROUP = 0x1205
[I] Delete group: name=%s, id=%d.
static const err | ERR_MSP_SECURITY_DELUSER = 0x1201
[I] Delete user: name=%s, id=%d.
static const err | ERR_MSP_SECURITY_DIFFERENTIPADDR = 0x1106
[F] The option to check IP address is enabled and this is an attempt to open this session from a different ip address.
static const err | ERR_MSP_SECURITY_DISABLE_ADMIN = 0x1011
[W] The administrator user cannot be disabled.
static const err | ERR_MSP_SECURITY_DUPE_GROUP_ID = 0x1007
[W] Attempt to add a group with the same ID as an existing group.
static const err | ERR_MSP_SECURITY_DUPE_GROUP_NAME = 0x1008
[W] Attempt to add a group with the same name as an existing group.
static const err | ERR_MSP_SECURITY_DUPE_GROUP_NAME_U = 0x1014
[W] Failed to update group – the name has been changed, and there is already another group with this name.
static const err | ERR_MSP_SECURITY_DUPE_USER_ID = 0x1002
[W] Attempt to add a user with the same ID as an existing user.
static const err | ERR_MSP_SECURITY_DUPE_USER_NAME = 0x1003
[W] Attempt to add a user with the same name as an existing user.
static const err | ERR_MSP_SECURITY_DUPE_USER_NAME_U = 0x1015
[W] Failed to update user – the name has been changed, and there is already another user with this name.
static const err | ERR_MSP_SECURITY_FAIL_LOAD_GROUP = 0x100E
[W] Failed to load the group information for group.
static const err | ERR_MSP_SECURITY_FAIL_LOAD_SEC = 0x100C
[W] Failed to load the main security configuration files.
static const err | ERR_MSP_SECURITY_FAIL_LOAD_USER = 0x100D
[W] Failed to load the user information for user.
static const err | ERR_MSP_SECURITY_FAIL_SAVE_SEC = 0x1019
[W] Failed to save the main security configuration files.
static const err | ERR_MSP_SECURITY_FAILGETINTEGRA = 0x1116
[W] Failed to get any integra users - return from Integra server was: %s.
static const err | ERR_MSP_SECURITY_FAILGETINTEGRAURL = 0x1115
[W] Failed to contact Integra server. See previous error in log file.
static const err | ERR_MSP_SECURITY_GETALLGROUPIDS = 0x1300
[D3] Called getAllGroupIDs - list of %d ids returned.
static const err | ERR_MSP_SECURITY_GETALLUSERIDS = 0x1307
[D3] Called ms_security::getAllUserIDs - list of %d ids returned.
static const err | ERR_MSP_SECURITY_GETGROUPFAIL = 0x1302
[D3] Called ms_security::getGroup(%s) - group not found.
static const err | ERR_MSP_SECURITY_GETGROUPFROMIDFAIL = 0x1309
[D3] Called ms_security::getGroupFromID('%d') - group id not found.
static const err | ERR_MSP_SECURITY_GETGROUPFROMIDOK = 0x1308
[D3] Called ms_security::getGroupFromID('%d') - returned group (%s) successfully.
static const err | ERR_MSP_SECURITY_GETGROUPOK = 0x1301
[D3] Called ms_security::getGroup(%s) - returned successfully.
static const err | ERR_MSP_SECURITY_GETINTEGRAUSERS1 = 0x130D
[D3] Called ms_security::getIntegraUsers - url %s.
static const err | ERR_MSP_SECURITY_GETINTEGRAUSERS2 = 0x130E
[D3] Called ms_security::getIntegraUsers - return string from URL is: %s.
static const err | ERR_MSP_SECURITY_GETINTEGRAUSERS3 = 0x130F
[D3] Called ms_security::getIntegraUsers - list of %d ids returned.
static const err | ERR_MSP_SECURITY_GETPERMTASKSFAIL = 0x130B
[D3] Called ms_security::getPermittedTasksForUser('%s') - user name not found.
static const err | ERR_MSP_SECURITY_GETPERMTASKSOK = 0x130A
[D3] Called ms_security::getPermittedTasksForUser('%s') - user name found, %d tasks returned.
static const err | ERR_MSP_SECURITY_GETUSERFAIL = 0x1304
[D3] Called ms_security::getUser('%s') - user not found.
static const err | ERR_MSP_SECURITY_GETUSERFROMIDFAIL = 0x1306
[D3] Called ms_security::getUserFromID('%d') - user id not found..
static const err | ERR_MSP_SECURITY_GETUSERFROMIDOK = 0x1305
[D3] Called ms_security::getUserFromID('%d') - returned user (%s) successfully.
static const err | ERR_MSP_SECURITY_GETUSEROK = 0x1303
[D3] Called ms_security::getUser('%s') - returned successfully.
static const err | ERR_MSP_SECURITY_GROUPID_NOT_FOUND = 0x100B
[W] Group ID not found.
static const err | ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND = 0x100A
[W] Group name not found.
static const err | ERR_MSP_SECURITY_INTEGRACONNFORMAT = 0x1117
[F] Integra connection id (%s) is not of the format expected.
static const err | ERR_MSP_SECURITY_INTEGRAINVALIDCO = 0x1119
[F] Integra connection id has probably timed out. Error return is: %s
static const err | ERR_MSP_SECURITY_INTEGRAINVALIDPW = 0x1118
[F] Integra password is probably invalid. Error return is: %s
static const err | ERR_MSP_SECURITY_INVALID_SESSION_ID = 0x1000
[W] An invalid session ID was passed to a function.
static const err | ERR_MSP_SECURITY_INVALIDPASSWORD = 0x1102
[F] You have entered an invalid password, %s - please try again [ec=%d].
static const err | ERR_MSP_SECURITY_INVALIDSESSION = 0x1109
[F] The current session is invalid, but an attempt has been made to save parameters.
static const err | ERR_MSP_SECURITY_INVALIDUSER = 0x1101
[F] No such user.
static const err | ERR_MSP_SECURITY_LOADINGSESS = 0x1332
[D3] Loading session (%s).
static const err | ERR_MSP_SECURITY_LOADSESSIONFILE = 0x111A
[F] The session file exists but we can't load it.
static const err | ERR_MSP_SECURITY_MISSINGSESSIONFILE = 0x1103
[F] Can't find the session file requested.
static const err | ERR_MSP_SECURITY_MSSESSCOOKIE = 0x1331
[D3] Cookie from ms_session::ms_session() = %s.
static const err | ERR_MSP_SECURITY_MSSESSINTEGRA = 0x1334
[I] Called ms_session::ms_session(%s,[connectionID],%s).
static const err | ERR_MSP_SECURITY_MSSESSIONCTOR = 0x1330
[D3] Called ms_session::ms_session(%s).
static const err | ERR_MSP_SECURITY_MSSESSLOGIN = 0x1333
[I] Called ms_session::ms_session(%s,[password]).
static const err | ERR_MSP_SECURITY_MSSESSRESULTSPERM = 0x1335
[D3] Called ms_session::canResultsFileBeViewed(%d - return %d).
static const err | ERR_MSP_SECURITY_NO_GUEST_PWD = 0x1017
[W] You cannot set a password for the guest user.
static const err | ERR_MSP_SECURITY_NO_INTEGRA_LOGIN = 0x111D
[F] You cannot login from this screen. Please login to Mascot Integra first, and access the Mascot Home Page from there.
static const err | ERR_MSP_SECURITY_NO_RIGHTS_UPD_USR = 0x101A
[W] Insufficient acccess rights to update user profile for %s.
static const err | ERR_MSP_SECURITY_NOCREATEGUEST = 0x110C
[F] Unable to create a guest session.
static const err | ERR_MSP_SECURITY_NOSAVEPARAMS = 0x110A
[F] Cannot save parameters in this type of sessin (e.g. guest user, no authentication enabled).
static const err | ERR_MSP_SECURITY_NOT_ADMIN_SESSION = 0x1001
[W] Administrator rights are required to add, delete or change users or groups.
static const err | ERR_MSP_SECURITY_NOT_ENABLED = 0x111C
[F] There is no need to login to this server - Mascot security is not enabled.
static const err | ERR_MSP_SECURITY_NOT_INTEGRA_USER = 0x111B
[F] The 'type' of user (%s) needs to be changed to a Mascot Integra user using the Mascot security administration application.
static const err | ERR_MSP_SECURITY_NOTLOGGEDIN = 0x1108
[F] User is not logged in, so could not create a session.
static const err | ERR_MSP_SECURITY_NOTNORMALUSER = 0x110F
[F] Cannot login as this user (%s) because the user type is not a 'normal' or 'integra' user.
static const err | ERR_MSP_SECURITY_OLD_PW_INVALID = 0x1016
[W] The old password is not correct and you don't have administrator rights. Password not changed.
static const err | ERR_MSP_SECURITY_PASSWORD_TOO_SHORT = 0x1018
[W] The password entered is too short. Minimum length required is defined in the options.
static const err | ERR_MSP_SECURITY_PASSWORDEXPIRED = 0x1107
[F] Your password has expired, %s - please enter a new password.
static const err | ERR_MSP_SECURITY_SAMEPASSWORD = 0x1110
[F] Cannot change your password to the same as the previous password.
static const err | ERR_MSP_SECURITY_SAVESESSIONFILE = 0x1104
[F] Can't save a new session file.
static const err | ERR_MSP_SECURITY_SESSIONDESTROYED = 0x110B
[D1]The session has been terminated and is therefore no longer valid.
static const err | ERR_MSP_SECURITY_SPOOFATTEMPT1 = 0x1111
[F] Trying to use session %s from computer with ip address %s - please contact your administrator.
static const err | ERR_MSP_SECURITY_SPOOFATTEMPT2 = 0x1112
[F] Trying to use session %s when logged into the web server as %s - please contact your administrator.
static const err | ERR_MSP_SECURITY_SPOOFATTEMPT3 = 0x1113
[F] Trying to use session %s (USER_AGENT_STRING) when agent string is actually %s - please contact your administrator.
static const err | ERR_MSP_SECURITY_SPOOFATTEMPT4 = 0x1114
[F] Trying to use command line session %s from a cgi application at ip address %s - please contact your administrator.
static const err | ERR_MSP_SECURITY_TIMEDOUT = 0x1105
[F] Session has timed out.
static const err | ERR_MSP_SECURITY_UPDATEALLSESSFILES = 0x130C
[D3] Called ms_security::updateAllSessionFiles - %d files potentially updated.
static const err | ERR_MSP_SECURITY_UPDATEGROUP = 0x1206
[I] Updated group: id=%d, old name=%s, new name=%s, added users=%s, deleted users=%s. Changed tasks=%s.
static const err | ERR_MSP_SECURITY_UPDATEPW = 0x1203
[I] Update user password for user id %d, name %s. Old p/w expiry=%ld. New p/w expiry=%ld.
static const err | ERR_MSP_SECURITY_UPDATESESS = 0x110D
[F] Unable to update session %s. Error %s.
static const err | ERR_MSP_SECURITY_UPDATEUSER = 0x1202
[I] Update user %d: [old,new]. Name=[%s,%s], FullName=[%s,%s], pw_exp=[%ld,%ld], type=[%d,%d], email=[%s,%s], enabled=[%d,%d].
static const err | ERR_MSP_SECURITY_USERID_NOT_FOUND = 0x1006
[W] User ID not found.
static const err | ERR_MSP_SECURITY_USERNAME_NOT_FOUND = 0x1005
[W] User name not found.
static const err | ERR_MSP_SECURITY_VALIDATEINTEGRACO1 = 0x1313
[D3] Called ms_security_session::verifyIntegraConnection - url %s.
static const err | ERR_MSP_SECURITY_VALIDATEINTEGRACO2 = 0x1314
[D3] Called ms_security_session::verifyIntegraConnection - OK.
static const err | ERR_MSP_SECURITY_VALIDATEINTEGRAPW1 = 0x1310
[D3] Called ms_security_session::validateIntegraPassword - url %s.
static const err | ERR_MSP_SECURITY_VALIDATEINTEGRAPW2 = 0x1311
[D3] Called ms_security_session::validateIntegraPassword - return string from URL is: %s.
static const err | ERR_MSP_SECURITY_VALIDATEINTEGRAPW3 = 0x1312
[D3] Called ms_security_session::validateIntegraPassword - OK.
static const err | ERR_MSP_SESSION_UTIME_FAIL = 0x111E
[W] Failed to update last modified time for s. Error: s
static const err | ERR_MSP_SL_SCORING_MODEL_FAIL = 0x1F01
[W] Failed to fit spectral library scoring model, so using a default threshold. Reason: s
static const err | ERR_MSP_SL_SCORING_MODEL_WARN = 0x1F02
[W] Spectral library threshold may not be optimal: s
static const err | ERR_MSP_SPECIFY_UNAVAILABLE_PROCESSOR = 0x061B
[W] ProcessorSet specifies unavailable processor.
static const err | ERR_MSP_SYSMP_FAIL = 0x0106
[F] Failed call to sysmp() for multi-processor support.
static const err | ERR_MSP_TARGET_FDR_FAILED_FOR_ET = 0x1F03
[W] Target FDR s g%% could not be reached for error tolerant matches. Using first pass sigthreshold for error tolerant matches.
static const err | ERR_MSP_TARGET_FDR_FAILED_FOR_FIRST_PASS = 0x1F06
[W] Target FDR s g%% could not be reached. Using minProbability = g.
static const err | ERR_MSP_TAXONOMY_CONFLICT_PARENTS = 0x0B05
[W] The parent for taxonomy id d in s conflicts with parent specified in files: s
static const err | ERR_MSP_TAXONOMY_DEFINITION_END = 0x0B04
[F] Missing end of taxonomy choice definition.
static const err | ERR_MSP_TAXONOMY_INVALID_NODE_FILE = 0x0B06
[F] Invalid line [%s] in the node file [%s].
static const err | ERR_MSP_TAXONOMY_MISSING_NODE_FILE = 0x0B07
[F] The taxonomy node file [%s] is missing.
static const err | ERR_MSP_TAXONOMY_NO_COMMAS = 0x0B02
[F] Comma is not allowed in taxonomy choice title.
static const err | ERR_MSP_TAXONOMY_NO_TITLE = 0x0B01
[F] The first non-empty line is expected to be Title:....
static const err | ERR_MSP_TAXONOMY_WRONG_LINE = 0x0B03
[F] Line cannot be parsed.
static const err | ERR_MSP_TOO_MANY_MODS_IN_MOD_FILE = 0x0402
[W] Too many modification have been loaded from file(s).
static const err | ERR_MSP_TOO_MANY_PROCESSORS = 0x061C
[W] More processors specified than licensed.
static const err | ERR_MSP_TOO_MANY_TH_PROCESSORS = 0x061D
[W] Too many processors named for a smaller number of threads for a database.
static const err | ERR_MSP_UMOD_FAILEDLOAD = 0x1500
[W] Failed to load unimod.xml file.
static const err | ERR_MSP_UMOD_FAILEDSAVE = 0x1501
[W] Failed to save unimod.xml file.
static const err | ERR_MSP_UNEXPECTED_LINE_OUT_OF_SECT = 0x0625
[W] Expecting a comment or section name, but found "%s" in the file: s
static const err | ERR_MSP_WRONG_ICAT_FILTER = 0x0620
[W] Empty ICAT filter is not allowed.
static const err | ERR_MSP_WRONG_MOD_VECTOR = 0x0A02
[F] Variable mods vector cannot be applied to the peptide.
static const err | ERR_MSP_WWW_SECTION = 0x061E
[W] Error in WWW section.
static const err | ERR_MSP_XHUNTER_WRONG_FORMAT = 0x1D20
[W] Mods= line '[text]' is not in valid XHunter format.
static const err | ERR_MSP_XML_ELEMENT_NOT_FOUND = 0x0807
[F] Cannot find element with the supplied name.
static const err | ERR_MSP_XML_FAILEDLOAD = 0x0809
[F] Failed to load xml file 's'. Reason: 's'.
static const err | ERR_MSP_XML_FAILEDSAVE = 0x0810
[F] Failed to save xml file 's'.
static const err | ERR_MSP_XML_FIELD_NOTFOUND = 0x0804
[F] Records in a table doesn't have the required field.
static const err | ERR_MSP_XML_INVALID_FIELD_FORMAT = 0x0805
[F] Field of a record contains data in wrong format.
static const err | ERR_MSP_XML_LOCAL_SCHEMA_NOT_STORED = 0x0806
[F] Cannot store XML-schema file locally.
static const err | ERR_MSP_XML_MEMORY_ERROR = 0x0808
[F] Memory allocation failed when working with XML.
static const err | ERR_MSP_XML_NO_ROOT_ELEMENT = 0x0802
[F] XML document doesn't contain a root element.
static const err | ERR_MSP_XML_SYSTEM_FAILED = 0x0801
[F] XML-library failure.
static const err | ERR_MSP_XML_TABLE_NOTFOUND = 0x0803
[F] Table with a specific name is not found amongst children of the current node.
static const err | ERR_MSP_XMLSCHEMA_FAILEDLOAD = 0x1600
[W] Failed to load xml schema file.
static const err | ERR_MSP_XMLSCHEMA_FAILEDSAVE = 0x1601
[W] Failed to save xml schema file.
static const err | ERR_MSP_ZIP_BUFTOOSMALL = 0x1702
[F] Buffer too small - [value].
static const err | ERR_MSP_ZIP_COMPRESSEDDATATOOLONG = 0x1711
[F] Compressed data longer ([value]) than maximum permitted ([value]).
static const err | ERR_MSP_ZIP_ENDIAN = 0x1700
[W] Failed to determine endian - assuming little endian.
static const err | ERR_MSP_ZIP_INVALID_STREAMING_MODE = 0x1712
[F] Invalid streaming mode requested (initialised for [value], streaming for [value]).
static const err | ERR_MSP_ZIP_INVALIDDATA = 0x1703
[F] Compressed data is invalid.
static const err | ERR_MSP_ZIP_LENGTHDIFFERS = 0x1705
[F] Expected length of uncompressed data ([value]) differs from actual length [value].
static const err | ERR_MSP_ZIP_NOTSTREAMING = 0x1709
[F] Streaming mode not initalised
static const err | ERR_MSP_ZIP_OUTOFMEMORY = 0x1701
[F] Insufficient memory to compress/decompress the data.
static const err | ERR_MSP_ZIP_STREAMERROR = 0x1710
[F] Cannot compress: [reason]
static const err | ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG = 0x1706
[F] Uncompressed data longer ([value]) than maximum permitted ([value]).
static const err | ERR_MSP_ZIP_UNKNOWN = 0x1704
[F] Unknown zip error
static const err | ERR_MSP_ZIP_VERSIONERROR = 0x1708
[F] Invalid zlib version: [reason]
static const err | ERR_MSP_ZIP_ZEROLENGTH = 0x1707
[F] Cannot compress zero length data.
static const err | ERR_NEED_64_BIT = 0x002B
[F] This results file (%s) is too large for 32 bit Mascot Parser. Please upgrade to 64 bit.
static const err | ERR_NO_ERR_TOL_PARENT = 0x0010
[F] No parent search file. See Error tolerant searches.
static const err | ERR_NO_ERROR = 0x0000
[W] Success.
static const err | ERR_NO_UNIGENE_FILE = 0x0017
[F] Failed to open the UniGene file specified.
static const err | ERR_NOMEM = 0x0001
[F] Failed to allocate memory to load the file.
static const err | ERR_NOSUCHFILE = 0x0002
[F] The file passed in the constructor does not exist.
static const err | ERR_NULL_ACC_PEP_SUM = 0x0011
[W] An empty accession string has been found. Possible problem in database.
static const err | ERR_NULL_ACC_PROT_SUM = 0x0012
[W] An empty accession string has been found. Possible problem in database.
static const err | ERR_OLDRESULTSFILE = 0x0019
[F] Very old results file (last century!). Parser requires 1.02 or later.
static const err | ERR_PEPSUMMPEPGET = 0x0006
[F] Value of q, p or h out of range, so cannot get peptide info.
static const err | ERR_PEPTIDESTR = 0x0007
[F] The string in the peptides block is not valid.
static const err | ERR_PROTSUMM = 0x0009
[F] Error parsing a line in the protein summary.
static const err | ERR_PROTSUMMPEP = 0x000A
[F] Couldn't parse peptide information from the protein summary section..
static const err | ERR_QUERYOUTOFRANGE = 0x0004
[F] Set if query < 1 or query > getNumQueries.
static const err | ERR_READINGFILE = 0x0003
[F] Opened the file successfully, but failed to read from it.
static const err | ERR_RESFILE_FUTURE_VERSION = 0x1E05
[W] Results file version s is newer than current Parser version s
static const err | ERR_RESFILE_INVALID_DB_TYPE = 0x1E01
[W] Invalid database type 's'. Forcing to AA.
static const err | ERR_RESFILE_LINKED_SITES = 0x1E02
[W] Could not read s from qd_pd_linked_sites in section s
static const err | ERR_RESFILE_LOOPLINKED_SITES = 0x1E03
[W] Could not read s from qd_pd_looplinked_sites in section s
static const err | ERR_RESFILE_MISSING_QEXP = 0x1E04
[W] Could not read s from section s in s
static const err | ERR_RESULTS_NOT_CREATED = 0x003A
[W] Attempting to call Mascot Parser function %s before createSummary() has completed.
static const err | ERR_UNASSIGNED_PROG = 0x0014
[F] Programming error! Calling getNumberOfUnassigned() or getUnassigned() before createUnassignedList().
static const err | ERR_UNASSIGNED_RANGE = 0x0015
[F] Calling ms_mascotresults::getUnassigned() with out of range number.
static const err | ERR_UNASSIGNED_UNK = 0x0016
[F] Calling ms_mascotresults::getUnassigned() – unable to retrieve value.
static const err | ERR_UNIGENE_MULTIDB = 0x0020
[W] UniGene index is not supported in multi-database search.
static const err | ERR_WRITE_CDB_FILE = 0x0029
[W] Failed to write to the cache file (%s). Error %d (%s).
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED = 0x0001060F
[D2] Iteration for seriesID=[num] stops at index=[num] and mass=[mass]: limit is [mass]
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES = 0x00010610
[D2] Skipping d' residue because it doesn't match /[I]/ or /[T]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE = 0x00010611
[D2] Skipping d residue because it doesn't match /[ITV]/ or /[CDEKLMNPQRS]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE = 0x00010612
[D2] Skipping v residue because it doesn't match /[ARDNCQEHILKMFPSTWYV]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES = 0x00010613
[D2] Skipping w' residue because it doesn't match /[I]/ or /[T]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE = 0x00010614
[D2] Skipping w residue because it doesn't match /[ITV]/ or /[RDNCQELKMPS]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER = 0x0001061D
[D3] PSM component [num] position i=[num] has intact link, modnum=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK = 0x0001061E
[D3] PSM component [num] position i=[num] has monolink modnum=[num] monoLinkNum=[num] title=[name]
static const msg_num_t | LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK = 0x0001061F
[D1] PSM component [num] column i=[num] is ignored because there is a looplink at sites [num]-[num], modnum=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_MASSES_VALUE = 0x0001061B
[D2] Active ms_masses: [name]=[value]
static const msg_num_t | LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE = 0x0001061C
[D1] Modification at site i=[num] is [name] with delta=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS = 0x00010600
[D1] Calculated [num] fragments for psmComponent=[num], seriesID=[num], fragCharge=[num], fragNlType=[num], linkerColumn=[num], linkerMassOffset=[mass]
static const msg_num_t | LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT = 0x0001061A
[D1] cfr: Initialising isotopes and fixed mods from quant component [name]
static const msg_num_t | LOGMSG_AAHELPER_CFR_START_FRAGMENTS = 0x00010618
[D1] cfr(psmComponent=[num], seriesID=[num], fragCharge=[num], minMass=[mass], maxMass=[mass], massType=[num], fragNlType=[num], linkerColumn=[num], linkerMassOffset=[mass])
static const msg_num_t | LOGMSG_AAHELPER_CROSSLINKED_END = 0x00010619
[D1] calcCrosslinkedFragments: returning [num] alpha and [num] beta fragments
static const msg_num_t | LOGMSG_AAHELPER_CROSSLINKED_START = 0x00010609
[D1] calcCrosslinkedFragments(seriesID=[num], fragCharge=[num], minMass=[mass], maxMass=[mass], massType=[num], fragNlType=[num]); mass of linker + alpha = [mass]; linker + beta = [mass]
static const msg_num_t | LOGMSG_AAHELPER_CUMULATIVE_MASS_NL = 0x0001060D
[D2] Cumulative mass and NL at i=[num] residue=[char]: m[i]=[mass], nl[i]=[mass]
static const msg_num_t | LOGMSG_AAHELPER_ETMOD_LOOKUP = 0x00010615
[D1] lookupErrorTolerantModification(q=[num], p=[num], residue=[char]) –> raw name=[string], raw delta=[string], mod name=[name], mod delta=[mass], is mod?=[num], nl=[mass]
static const msg_num_t | LOGMSG_AAHELPER_IMMONIUM_ION_ADD = 0x00010606
[D2] Added immonium ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], residue=[char], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_IMMONIUM_ION_REJECT = 0x00010605
[D2] Rejected immonium ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], residue=[char], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_INTERNAL_ION_ADD = 0x00010608
[D2] Added internal ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], start=[num], end=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_INTERNAL_ION_REJECT = 0x00010607
[D2] Rejected internal ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], start=[num], end=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_MASTER_NL_VALS = 0x0001060B
[D2] Master neutral loss=[array]
static const msg_num_t | LOGMSG_AAHELPER_MULTINL_INDICES = 0x0001060A
[D1] Currently active multi NL indices=[array]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_ION_ADD = 0x00010602
[D2] Added regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_ION_REJECT = 0x00010601
[D2] Rejected regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD = 0x00010604
[D2] Added regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num] ([name]), column=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT = 0x00010603
[D2] Rejected regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num] ([name]), column=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_SERIES_PARAMS = 0x0001060E
[D1] Parameters for seriesID=[num]: delta=[mass], start=[num], end=[num], forward=[num]
static const msg_num_t | LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG = 0x00010617
[D1] setupFromPre2_2ResultsFile(peptide=[string], varmods=[string]) –> anyChange=[num], modNum=[num], oldStyleModName=[string], modType=[num]
static const msg_num_t | LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT = 0x00010616
[D1] setupFromPre2_2ResultsFile(peptide=[string], varmods=[string]) –> modNum=[num], idx=[num], modType=[num]
static const msg_num_t | LOGMSG_AAHELPER_TOTAL_NL_VALS = 0x0001060C
[D2] Currently active multi NL neutral loss=[array]
static const msg_num_t | LOGMSG_CUSTQUANT_ADD_QUANT_KEY = 0x00010400
[D2] Adding quantitation key id d to protein s .
static const msg_num_t | LOGMSG_CUSTQUANT_REMOVE_ALL_KEY = 0x00010401
[D2] Removing quantitation key d from any proteins.
static const msg_num_t | LOGMSG_CUSTQUANT_REMOVE_KEY = 0x00010402
[D2] Removed quantitation key d from protein s.
static const msg_num_t | LOGMSG_DBG1_NUM_PROCESSOR_GROUPS = 0x00010160
[D1] Debug: Number of processor groups : %d.
static const msg_num_t | LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS = 0x00010178
[D2] Debug: Number of cores per physical cpu : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_GETAUTODETECT = 0x00010179
[D2] Debug: getAutoDetectNumThreads(1,4) : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS = 0x00010177
[D2] Debug: Number of logical cpus / physical cpu: %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_MT_NAME = 0x0001017A
[D2] Debug: Multi-threaded name : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_MT_STATUS = 0x0001017B
[D2] Debug: Hyper/multi threading status : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NAME = 0x00010173
[D2] Debug: Processor name : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_AVAIL = 0x00010171
[D2] Debug: Logical number of cpus available : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_GROUPS = 0x00010172
[D2] Debug: Number of processor groups : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_ON_SYS = 0x00010170
[D2] Debug: Logical number of cpus on the system : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL = 0x00010176
[D2] Debug: Physical number of cpus on the system: %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_PROC_AFFINITY = 0x00010174
[D2] Debug: Process Affinity supported : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_TABLE_LINE = 0x0001017D
[D2] Debug: %3d : %2d / %5d / %5d / %s / %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_TABLE_TITLE = 0x0001017C
[D2] Debug: logical : physical id / core id / ht id / is primary / is threaded:
static const msg_num_t | LOGMSG_DBG2_CPU_INF_USE_PROCESSES = 0x00010175
[D2] Debug: Use processes instead of threads : %s
static const msg_num_t | LOGMSG_DBG2_NUM_CONFIG_MISMATCH = 0x00010168
[D2] Debug: Processor configuration detection mismatch: hwloc detects %d and system detects %d configured processors.
static const msg_num_t | LOGMSG_DBG2_NUM_ONLINE_MISMATCH = 0x00010169
[D2] Debug: Processor configuration detection mismatch: hwloc detects %d and system detects %d online processors.
static const msg_num_t | LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD = 0x00010163
[D3] Debug: getAutoDetectNumThreads. logicalPerPhysical: %d, numCores: %d, numLicensed: %d, numCoresPerCpuLicense: %d, maxLicensable: %d, numAvailableToProcess: %d.
static const msg_num_t | LOGMSG_DBG3_BINDING_PROCESSORS = 0x00010166
[D3] Debug: binding processors %s.
static const msg_num_t | LOGMSG_DBG3_BINDING_THREAD = 0x00010167
[D3] Debug: binding thread p to logical processor %d.
static const msg_num_t | LOGMSG_DBG3_CALL_GET_CHIP_MFCTR = 0x00010164
[D3] Debug: about to call getChipManufacturer()
static const msg_num_t | LOGMSG_DBG3_HWLOC_GROUPS = 0x00010162
[D2] Debug: hwloc reports %d processor groups.
static const msg_num_t | LOGMSG_DBG3_HWLOC_TREE = 0x00010161
[D3] Debug: iterateHwlocChildren: %%-8s, logical: %d, depth: %d, packageID: %d, coreID: %d.
static const msg_num_t | LOGMSG_DBG3_PROCESSOR_NAME = 0x00010165
[D2] Debug: processor name: %s, hyperthreading: %s.
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND = 0x00010A05
[D2] getThresholdForFDR: found a new minimum at i=d, fdr_min=g, target_min=d, decoy_min=d, expect_min=g
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_START = 0x00010A03
[D2] getThresholdForFDR: i=d, expect=g, target=d, decoy=d, target_count=d, decoy_count=d, fdr=g, too_few=d
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT = 0x00010A04
[D2] getThresholdForFDR: target or decoy count dropped to zero at i=d, target_count=d, decoy_count=d
static const msg_num_t | LOGMSG_GET_THR_REACH_COND = 0x00010A06
[D2] getThresholdForFDR: Result FDR reached; minimum seen at fdr_min=g, expect_min=g, target_min=d, decoy_min=d
static const msg_num_t | LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET = 0x00010A02
[D1] getThresholdForFDR(g, s, DM_FASTA_SECOND_PASS) returned success = d, closestFDR = g, minProbability = g, numTargetMatches = d, numDecoyMatches = d
static const msg_num_t | LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR = 0x00010A01
[D1] getThresholdForFDR(g, s, DM_FASTA_FIRST_PASS) returned success = d, closestFDR = g, minProbability = g, numTargetMatches = d, numDecoyMatches = d
static const msg_num_t | LOGMSG_HTTP_GETRETURNSTRING = 0x00010304
[I] The http GET returned '[text]'.
static const msg_num_t | LOGMSG_HTTP_MAXCONECTIONS10FAILED = 0x00010303
[I] Failed to set maximum connections per 1.0 server
static const msg_num_t | LOGMSG_HTTP_MAXCONECTIONSFAILED = 0x00010302
[I] Failed to set maximum connections per server
static const msg_num_t | LOGMSG_HTTP_QUERYSTATUSRESULT = 0x00010301
[I] HTTP status is [httpCode] 'httpText'.
static const msg_num_t | LOGMSG_HTTP_URLSTRING = 0x00010300
[I] Sending HTTP [httpMethod] to [url] for action [command].
static const msg_num_t | LOGMSG_INST_ADDINGDATABASE = 0x00010205
[I] Adding entry for s to mascot.dat.
static const msg_num_t | LOGMSG_INST_ADDOPTIONSSECTION = 0x00010208
[I] Added [value] to the options section of mascot.dat.
static const msg_num_t | LOGMSG_INST_APPENDPARSERULE = 0x00010207
[I] Added parse rule number [value].
static const msg_num_t | LOGMSG_INST_APPENDTAXONOMY = 0x00010204
[I] Appended taxonomy section [value].
static const msg_num_t | LOGMSG_INST_CHANGEDBTAXONOMY = 0x00010206
[I] Changed taxonomy entry for [database].
static const msg_num_t | LOGMSG_INST_CHANGEPARSERULE = 0x0001020C
[I] Changed [value] parse rule from rule [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGEPERCOLATORFEATS = 0x00010210
[I] Changed PercolatorFeatures section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGEPERCOLATORUSERT = 0x00010212
[I] Changed PercolatorUseRT section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGEPROTFAMILYSWITCH = 0x00010211
[I] Changed ProteinFamilySwitch section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGERESULTSCACHE = 0x00010215
[I] Changed ResultsCache section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGESPLITDATAFILESIZE = 0x00010214
[I] Changed SplitDataFileSize section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGESPLITNUMOFQUERIES = 0x00010213
[I] Changed SplitNumberOfQueries section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CLUSTERSECTION = 0x0001020A
[I] Set the value of [name] to [value] in the cluster section of mascot.dat.
static const msg_num_t | LOGMSG_INST_FAILSAVEPOSTINSTALLFILE = 0x0001020E
[I] Failed to save Post Install File [name]. Error [value]
static const msg_num_t | LOGMSG_INST_LOGICALPERPHYSICALCPU = 0x00010200
[I] Detected %d logical processors per physical CPU.
static const msg_num_t | LOGMSG_INST_MASCOTDATOK = 0x00010203
[I] Successfully loaded existing mascot.dat from [path].
static const msg_num_t | LOGMSG_INST_NOSUBCLUSTERSET = 0x0001020B
[I] No SubClusterSet entry in mascot.dat.
static const msg_num_t | LOGMSG_INST_NOTMASCOTDATOK = 0x00010202
[I] Successfully loaded not.mascot.dat from [path].
static const msg_num_t | LOGMSG_INST_NUMTHREADS = 0x00010201
[I] Setting number of threads to [value].
static const msg_num_t | LOGMSG_INST_REMOVEOPTIONSSECTION = 0x0001020F
[I] Removed [value] from the options section of mascot.dat.
static const msg_num_t | LOGMSG_INST_SAVEDPOSTINSTALLFILE = 0x0001020D
[I] Saved line ([text]) in Post Install File [name] for Database Manager
static const msg_num_t | LOGMSG_INST_SETOPTIONSSECTION = 0x00010209
[I] Set the value of [name] to [value] in the options section of mascot.dat.
static const msg_num_t | LOGMSG_MATRIX_OUTPUT_VALS = 0x00010500
[D3] s. d rows and d columns
s
static const msg_num_t | LOGMSG_MSR2DAT28_SQL_TRACING = 0x00010B00
[D3] ms_msr2dat28 SQL: [string] –> [string]
static const msg_num_t | LOGMSG_NON_DEFAULT_HOMOLOGY_THRESHOLD = 0x00010A07
[D2] getHomologyThreshProtected called with OneInXprobRnd = g, where minProbability_= g, and 1/minProbability_= g, query = d
static const msg_num_t | LOGMSG_PEPSUM_GETHIT = 0x00010729
[D3] [function]: [string], [string], [string]
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP = 0x00010713
[D2] choose_next_free_protein(): free count of "[accession]" is [num] => keep
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_START = 0x00010710
[D1] choose_next_free_protein(): lead_proteins are [list]
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY = 0x00010711
[D2] choose_next_free_protein(): free_count of "[accession]" is [num] but no superset found in lead_proteins; keeping for now
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST = 0x00010712
[D2] choose_next_free_protein(): free count of "[accession]" is [num] => move to subset_list with parents [list]
static const msg_num_t | LOGMSG_PROTINFER_CLUSTER_FROM_ACC = 0x00010726
[D1] sortByScore(): Starting point for cluster in hit [num] is [accession]
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO = 0x0001070D
[D2] eliminate_intersections() : ran out of unused_proteins (all free counts are zero)
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT = 0x0001070E
[D2] eliminate_intersections() : next unused protein to try to add is "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST = 0x0001070F
[D2] eliminate_intersections() : fix-up of supersetlist for "[accession]", [changed lists]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_END = 0x00010704
[D1] findFamily() end for accession "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_QUEUE = 0x00010701
[D1] findFamily(): "[accession]" (node idx = [num]) has [num] PSMs above threshold ([num] PSMs below), [num] homologous proteins, in_queue size=[num], queue size=[num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS = 0x00010702
[D1] findFamily(): "[accession]" has the following [num] representative sequences: [list]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_START = 0x00010700
[D1] findFamily() start for accession "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END = 0x00010725
[D2] findMatchesForThisProteinAndChildren(): Accession: [accession], size of qp = [num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START = 0x00010723
[D2] findMatchesForThisProteinAndChildren(): Accession: [accession], size of qp = [num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START = 0x00010724
[D2] findMatchesForThisProteinAndChildren(): Subset accession: [accession]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST = 0x00010708
[D2] groupFamily(): discardedSLProteins: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION = 0x00010709
[D1] groupFamily(): eliminate_intersections. lead_proteins size = [num], subset_proteins size = [num]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST = 0x0001070B
[D1] groupFamily(): leadProteins after elimination: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST = 0x0001070A
[D1] groupFamily(): family members after elimination: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST = 0x0001070C
[D1] groupFamily(): "[accession]" has parent "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN = 0x0001072B
[D1] homologous_proteins(): "[accession]" shares q[num]_p[num] with "[accession]" => pull it in to the family
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST = 0x00010707
[D2] groupFamily(): samesetLeadProteins: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST = 0x00010706
[D2] groupFamily(): samesetParents: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_START = 0x00010705
[D1] groupFamily() for "[accession]": samesetLeadProteins=[num], samesetParents=[num], discardedSLProteins=[num]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FROM_ACC = 0x00010727
[D1] sortByScore(): Starting point for group in hit [num] is [accession]
static const msg_num_t | LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY = 0x0001072A
[D2] findFamily(): Family [num] has [num] peptide matches with keepingThisOne=[boolean]
static const msg_num_t | LOGMSG_PROTINFER_PEPTIDE_MATRIX = 0x00010703
[D2] findFamily(): [type] peptide matrix (transposed)
[matrix]
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD = 0x00010716
[D2] remove_conflicting_proteins(): lead protein "[accession]" has free count n < minNumSigUniqueSeqs (n = [num], minNumSiqUniqueSeqs = [num]) => move to subset list with parents [accessions]
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP = 0x00010715
[D2] remove_conflicting_proteins(): lead protein "[accession]" does not overlap with any current lead protein => keep
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_START = 0x00010714
[D2] remove_conflicting_proteins([list])
static const msg_num_t | LOGMSG_PROTINFER_SINGLETON_FROM_ACC = 0x00010728
[D1] sortByScore(): No grouping; hit [num] is just "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE = 0x00010718
[D2] sortByScore(): About to create sorted_
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED = 0x00010719
[D2] sortByScore(): Finished creating sorted_
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_DONE = 0x00010722
[D1] sortByScore(): reached the end of sorted_, so it's all done
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN = 0x00010721
[D1] sortByScore(): next accession in sorted_ with significant rank 1 peptide is "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS = 0x0001071A
[D1] sortByScore(): proteins_ is empty, so it's all done
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD = 0x00010720
[D1] sortByScore(): Removing "[accession]" because setBoldAndCheckBoxItems() returned false
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN = 0x0001071D
[D1] sortByScore(): Removing "[accession]" because longestPeptideLen [num] < minPepLenInPepSummary [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN = 0x0001071E
[D1] sortByScore(): Removing "[accession]" because longestSigPeptideLen [num] < minPepLenInPepSummary [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS = 0x0001071C
[D1] sortByScore(): Removing "[accession]" because numProteins [num] >= maxHitsToReport [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE = 0x0001071B
[D1] sortByScore(): Removing "[accession]" because its score [num] is less than minProteinScore [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_START = 0x00010717
[D1] sortByScore(): Num proteins: [num], num peptides: [num], hitToAdd: [num]
static const msg_num_t | LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT = 0x0001071F
[D2] sortByScore(): Protein "[accession]" is a subset in hit [num]. Because MSRES_SUBSETS_DIFF_PROT is active, it will now start hit [num]
static const msg_num_t | LOGMSG_QUANT_ADDED_PROTEIN_HIT = 0x00010417
[D2] Added quantitation protein hit [accession] to match [value] with sequence [text]
static const msg_num_t | LOGMSG_QUANT_ADDING_PROTEIN_HIT = 0x00010416
[D2] Adding quantitation protein hit [accession]
static const msg_num_t | LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED = 0x0001040F
[D2] Calling calc_complete() on merged dataset
static const msg_num_t | LOGMSG_QUANT_CLOSING_CACHE_FILE = 0x00010419
[D2] Closing quantitation cache file [filename]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE = 0x00010411
[D2] Excluding peptide for query: [value], rank: [value] because [string]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN = 0x00010413
[D2] Excluding peptide for query: [value], rank: [value] because [string]. [value] > [value]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN = 0x00010412
[D2] Excluding peptide for query: [value], rank: [value] because [string]. [value] < [value]
static const msg_num_t | LOGMSG_QUANT_FINISH_CALC_COMPLETE = 0x00010406
[D2] Finished calc_complete() call
static const msg_num_t | LOGMSG_QUANT_FINISH_LOAD_CDB = 0x00010409
[D2] Finished loadCdbFile() call
static const msg_num_t | LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE = 0x0001041B
[D1] Finished reordering of peptide matches after merge
static const msg_num_t | LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES = 0x00010404
[D2] Finished updating protein matches
static const msg_num_t | LOGMSG_QUANT_HELPER_TEST_REQUIRED = 0x00010800
[D3] testRequiredMods(): sorted required mods="[string]", sequence="[string]", mods="[string]", iter=[char]
static const msg_num_t | LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES = 0x0001040A
[D2] Loading all peptide status values
static const msg_num_t | LOGMSG_QUANT_LOADING_MATCHES = 0x0001040B
[D2] Loading quantitation matches
static const msg_num_t | LOGMSG_QUANT_MERGE_COMPONENT_DUPE_FI = 0x0001041D
[D1] Duplicate file_index: d when trying to merge file_index for same component. Name: s, Mods: s, m/z: f
static const msg_num_t | LOGMSG_QUANT_MERGE_COMPONENT_INCONSIST = 0x0001041C
[D1] Incompatibility trying to merge file_index for same component. Name: s (s), Mods: s (s), m/z: f (f)
static const msg_num_t | LOGMSG_QUANT_MERGE_COMPONENT_SUCCESS = 0x0001041E
[D2] Successfully merging file_index: d into existing component. Name: s, Mods: s, m/z: f
static const msg_num_t | LOGMSG_QUANT_OPENING_CACHE_FILE = 0x00010418
[D2] Opening quantitation cache file [filename]
static const msg_num_t | LOGMSG_QUANT_REAPPLY_THRESHOLDS = 0x0001040D
[D2] Reapplying quantitation quality thresholds
static const msg_num_t | LOGMSG_QUANT_REMATCHING_INFERRED = 0x00010410
[D2] Rematching [value] inferred matches
static const msg_num_t | LOGMSG_QUANT_REMOVE_INFERRED_MATCH = 0x00010415
[D1] Removing inferred quantitation match [value] - [value] < [value]
static const msg_num_t | LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE = 0x00010414
[D1] Removing quantitation match [value] - no remaining evidence
static const msg_num_t | LOGMSG_QUANT_RT_OFFSET_LOOKUP = 0x00010420
[D2] Retention time: f, from project: d, gives an offset of: f for project: d. (m/z: f)
static const msg_num_t | LOGMSG_QUANT_START_CALC_COMPLETE = 0x00010405
[D2] Calling calc_complete()
static const msg_num_t | LOGMSG_QUANT_START_LOAD_CDB = 0x00010408
[D2] Start of loadCdbFile() call. Cdb file: [filename], cache file: [filename]
static const msg_num_t | LOGMSG_QUANT_START_REORDER_AFTER_MERGE = 0x0001041A
[D1] Starting reordering of peptide matches after merge
static const msg_num_t | LOGMSG_QUANT_START_UPDATE_PROT_MATCHES = 0x00010403
[D2] Starting to update protein matches
static const msg_num_t | LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE = 0x0001041F
[D1] Invalid index when getting RT offset - expected for some Waters MS^E peptides. This project id: d, other project id: d. Rt in other project: f, m/z: f. Combined min bin number: d. bin number: d, Array size: d
static const msg_num_t | LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE1 = 0x00010421
[D1] In getEstimatedFeatureWidth(), for subProject: [num], m/z: [value], rt: [value], binIndex: [num], but max bin for this sub project: [num], min bin: 0
static const msg_num_t | LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES = 0x0001040E
[D2] Updating excluded matches
static const msg_num_t | LOGMSG_QUANT_UPDATING_PEP_EVIDENCE = 0x0001040C
[D2] Updating Peptide Evidence
static const msg_num_t | LOGMSG_REPORT_FUNCTION_CALLED_BY = 0x00010900
[D3] [function], called by [string]
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY = 0x00010901
[D3] [function] entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 = 0x00010902
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 = 0x00010903
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 = 0x00010904
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 = 0x00010905
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_EXIT = 0x00010910
[D3] [function] exited
static const msg_num_t | LOGMSG_REPORT_FUNCTION_EXIT_WITH = 0x00010911
[D3] [function] exited with [string]
static const msg_num_t | LOGMSG_RESFILE_APPEND = 0x00010A00
[D2] [string] numQueries=[num] cachedExpValues=[num]

Detailed Description

All errors are collected in an instance of this class.

Examples
common_error.cpp, and tools_aahelper.cpp.

Member Typedef Documentation

◆ msg_num_t

typedef int msg_num_t
inherited

Typedef for log and error message numbers.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Logging messages are classified as:

  • [I] information
  • [D1] Debug level 1 message
  • [D2] Debug level 2 message
  • [D3] Debug level 3 message

Ranges:

Product | Classification | First | Last
Parser | sev_fatal, sev_warn | 0x00000000 | 0x0000FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00010000 | 0x0001FFFF
MSQuantlib | sev_fatal, sev_warn | 0x00020000 | 0x0002FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00030000 | 0x0003FFFF
Purifier API | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00040000 | 0x0004FFFF
Purifier | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00050000 | 0x0005FFFF
Mascot Server | sev_fatal, sev_warn | 0x00000000 | 0x0000FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00060000 | 0x0006FFFF
MDRO | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x4C020000 | 0x4C03FFFF

Member Enumeration Documentation

◆ msg_sev

enum msg_sev
inherited

Message severity levels.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

See also: ms_loggingmonitor::Level_e

Enumerator
sev_fatal | A fatal error that results in the object being 'invalid'.
sev_warn | A warning message.
sev_info | Information message.
sev_debug1 | Debug level 1 message.
sev_debug2 | Debug level 2 message.
sev_debug3 | Debug level 3 message.

Constructor & Destructor Documentation

◆ ms_errs()

ms_errs | ( | msg_sev | loglevel = sev_warn,
 |  | bool | combineRepeats = true,
 |  | ms_loggingmonitor::Source_e | api = ms_loggingmonitor::SRC_MSPARSER
 | ) |  |

Constructor.

This constructor is generally for Matrix Science use only.

Parameters
loglevel | should specify the maximum level of logging for this object. A different level can be specified for ms_loggingmonitor, so ms_log::sev_fatal or ms_log::sev_warn is normally sufficient here.
combineRepeats | should be set to true to avoid multiple occurences of the same message appearing in the list of messages.
api | needs to be specified when using this class inside an api or application other than Mascot Parser.

Member Function Documentation

◆ addToCatalog()

void addToCatalog | ( | const msg_catalog_t | catalog[],
 |  | size_t | numEntries,
 |  | ms_loggingmonitor::Source_e | src,
 |  | errorOrLogMessages_e | errorOrLogMessages
 | ) |  |
inherited

Add messages to the fast lookup map.

Parameters
catalog | is a pointer to an array of messages and severities
numEntries | is the number of entries in catalog
src | is used to check if the messages have already been added to the static catalog_ map.
errorOrLogMessages | is used, with src to check if the messages have already been added to the static catalog_ map.

◆ appendErrors()

void appendErrors ( const ms_errs & src )

Copies all errors from another instance and appends them at the end of own list.

Mostly used internally, but can be useful for appending errors from one object into another object

Parameters
src is the error list to copy from.

◆ clearAllErrors()

void clearAllErrors ( )

Remove all errors from the current list of errors.

All errors, warnings, information and debug messages are accumulated into a list in this object, until this function is called.

See also
getNumberOfErrors()
Examples
tools_aahelper.cpp.

◆ convertFromLogLevel()

ms_errs::msg_sev convertFromLogLevel ( ms_loggingmonitor::Level_e logLevel )
static

Convert the ms_loggingmonitor level to an ms_errs severity.

Note that this function will not work with a mask that is created by bitwise ORing these enums together.

See also
ms_errs::convertToLogLevel
Parameters
logLevel is the logging level
Returns
the original Parser severity message level

◆ convertToLogLevel()

ms_loggingmonitor::Level_e convertToLogLevel ( ms_errs::msg_sev severity )
static

Convert the ms_errs severity level to a ms_loggingmonitor level.

See also
ms_errs::convertFromLogLevel
Parameters
severity will be sev_fatal, sev_warn etc
Returns
the ms_loggingmonitor level that can be bitwise or'ed used with the return from ms_loggingmonitor::getLogMask()

◆ forwardToParentInstance()

void forwardToParentInstance ( ms_errs * parent )

Enable all messages from one object to be forwarded to another.

When a parser object that uses ms_errs creates another object that uses a different ms_errs instance, it either has to call appendErrors() after calling any methods in the created object or it can just call this function on the created object to get all errors just recorded in the 'parent' object.

The ms_errs destructor tidies up the links between the two (or more) objects.

As many objects as required can use the same instance.

Parameters
parent is the object that messages will be stored in. If a value of zero is passed, this just removes any existing references.

◆ getCombineRepeats()

bool getCombineRepeats ( ) const

Get the flag for whether to merge repeated error messages.

The default is to combine repeated error messages.

Returns
Will be true if identical error messages are combined into a single message.

◆ getErrorNumber()

int getErrorNumber ( const int num = -1 ) const

Return a specific error number or ERR_NO_ERROR.

To return a particular error, warnings, information or debug messages from the list of messages, call this function with a number 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or ERR_NO_ERROR.

Parameters
num should be a value in the range 1..getNumberOfErrors()
Returns
the error number for item num in the list. If an invalid number is passed, ERR_NO_ERROR will be returned.
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getErrorRepeats()

int getErrorRepeats ( const int num = -1 ) const

Returns a number of times the specified error has been repeated.

Parameters
num should be a value in the range 1..getNumberOfErrors()
Returns
The number of times the specified message was repeated or 0 if there are no messages in the list.
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getErrorSeverity()

ms_errs::msg_sev getErrorSeverity ( const int num = -1 ) const

Returns the severity of the specified error, warning, information or debug message.

Parameters
num should be a value in the range 1..getNumberOfErrors()
Returns
The severity level. If an invalid number is passed, or if there are no messages or errors in the list then ms_errs::sev_warn is returned.

◆ getErrorString()

std::string getErrorString ( const int num ) const

Returns a specific error as a string.

To return a particular error, warnings, information or debug messages from the list of messages, call this function with a number 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or an empty string.

Parameters
num should be a value in the range 1..getNumberOfErrors() If an invalid number is passed, an empty string will be returned.
Returns
The specified error, warning, information or debug message string
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const

Return the last error number or ERR_NO_ERROR if no errors.

This function returns the last error, warning, information or debug message from the list of messages in this object.

This function is implemented by calling: getErrorNumber(-1)

Returns
the Error number for the last message in the list of messages

◆ getLastErrorString()

std::string getLastErrorString ( ) const

Return the last error number or an empty string.

This function returns the last error, warning, information or debug message from the list of messages in this object

Same as calling getErrorString() with -1 as a parameter.

Returns
The most recent error, warning, information or debug message
Examples
tools_aahelper.cpp.

◆ getLoggingFileName()

std::string getLoggingFileName ( ) const

Return the name of the logging file.

Returns
the name of the file where fatal errors, warning, informational and debugging messages are accumulated. If there is no log file, this string will be empty

◆ getLoggingLevel()

ms_errs::msg_sev getLoggingLevel ( ) const
virtual

Get the logging level.

The default logging level is ms_errs::sev_warn, so any messages with ms_errs::sev_info, ms_errs::sev_debug1, ms_errs::sev_debug2 or ms_errs::sev_debug3 will not be logged.

The same level is applied to messages stored internally in the list and to to the messages being written to the file specified using setLoggingFile()..

Returns
level is the current logging level.

Implements ms_log.

◆ getMessageSource()

ms_loggingmonitor::Source_e getMessageSource ( const ms_log::msg_num_t msgNum ) const
inherited

Return the component (library/application) that generated the specified log message.

The return value is based on the message number and determined from the table shown for msg_num_t above. If the value isn't in one of the above ranges, then ms_loggingmonitor::SRC_ALL will be returned.

Parameters
msgNum Numeric code of the messaged to be logged
Returns
the ms_loggingmonitor::Source_e value.

◆ getNumberOfErrors()

int getNumberOfErrors ( ) const

Return the number of errors since the last call to clearAllErrors().

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

If the logging level has been set to, for example ms_errs::sev_debug3 using setLoggingLevel(), then this function may return a positive number greater than zero even if isValid() returns true.

All errors are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
clearAllErrors(), getErrorNumber() and getErrorString()
Returns
the number of errors, warnings, or other messages in the list.
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ isValid()

bool isValid ( ) const

Returns TRUE if no errors occurred, FALSE otherwise.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages. This function will return true unless there are messages which have the severity level of ms_errs::sev_fatal

Returns
true unless there have been and fatal error messages
Examples
tools_aahelper.cpp.

◆ setAPI()

void setAPI ( ms_loggingmonitor::Source_e api )

Sets the source API for the messages.

The ms_errs class is primarily used by Mascot Parser, but it may also be used by other Matrix Science APIs, such as MSQuantlib. Any other API should call this function, so that logging messages are recorded as coming from the correct API

Parameters
api is one of the ms_loggingmonitor::Source_e values

◆ setCombineRepeats()

void setCombineRepeats ( const bool flag )

Set the flag for whether to merge repeated error messages.

The default is to combine repeated error messages

Parameters
flag should be set to true to enable identical error message to be combined into a single message.

◆ setLoggingFile()

void setLoggingFile | ( | const std::string | filename,
 |  | const msg_sev | level
 | ) |  |

Set the logging file.

It is generally easier to use Logging using ms_loggingmonitor than to use this function.

Parameters
filename | should be set to a valid filename, or an empty string to disable also saving to a log file.
level | is the logging level. See also getLoggingLevel() and setLoggingLevel(). The same level is applied to messages stored internally in the list and to to the messages being written to the specified filename.

◆ setLoggingLevel()

void setLoggingLevel ( const msg_sev level )

Set the logging level.

The default logging level is ms_errs::sev_warn, so any messages with ms_errs::sev_info, ms_errs::sev_debug1, ms_errs::sev_debug2 or ms_errs::sev_debug3 will not be logged.

This logging level is quite separate from the one used by ms_loggingmonitor. Call ms_loggingmonitor::setLogMask to enable a different level of logging. For example, you would normally only want ms_errs::sev_fatal and possibly ms_errs::sev_warn messages in any parser object so that you can report errors back to the user. You wouldn't want to fill the object with logging and information messages.

See also getLoggingLevel()

Parameters
level is the logging level. The same level is applied to messages stored internally in the list and to to the messages being written to the file specified when calling setLoggingFile

◆ willMessageBeLogged()

bool willMessageBeLogged ( const ms_errs::err errorNum ) const

Check to see if the message will be logged to a file or recorded anywhere.

If the code to format a log message might take some time to run, it is worth calling this function first to see if the message will be logged or used anywhere.

Parameters
errorNum must be a valid error number
Returns
true if the message will be logged, or returned by getErrorString()

Member Data Documentation

◆ ERR_MSP_SECURITY_BAD_GROUP_NAME

const err ERR_MSP_SECURITY_BAD_GROUP_NAME = 0x1009
static

[W] Invalid group name - names cannot contain the following characters:

><\\/`;,+*"

◆ ERR_MSP_SECURITY_BAD_USER_NAME

const err ERR_MSP_SECURITY_BAD_USER_NAME = 0x1004
static

[W] Invalid user name - names cannot contain the following characters:

><\\/`;,+*"
The documentation for this class was generated from the following files:
  • ms_errors.hpp
  • ms_errors.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_file_logger Class Reference

  • matrix_science
  • ms_file_logger
Public Types | Public Member Functions | List of all members
ms_file_logger Class Reference
Error handling and logging

Concrete class which implements ms_logger and outputs log text to the specified file. More...

#include <ms_logging.hpp>

Inheritance diagram for ms_file_logger:
[legend]
Collaboration diagram for ms_file_logger:
[legend]

Public Types

enum LogOutputColumns_e {
COL_ASC_TIME = 0x0001 ,
COL_ISO8601_TIME = 0x0002 ,
COL_IP_ADDRESS = 0x0004 ,
COL_MSG_NUM_DEC = 0x0008 ,
COL_MSG_NUM_HEX = 0x0010 ,
COL_SEVERITY_NUM = 0x0020 ,
COL_SEVERITY_TXT = 0x0040 ,
COL_MSG_SOURCE_TXT = 0x0080 ,
COL_SRC_FILE = 0x0100 ,
COL_SRC_LINENUM = 0x0200 ,
COL_THREAD_ID = 0x0400 ,
COL_MSG = 0x0800 ,
COL_TSV = 0x1000 ,
COL_QUOTES = 0x2000 ,
COL_HEADERS = 0x4000 ,
COL_LOGGER_DEFAULTS = COL_ISO8601_TIME | COL_MSG_NUM_HEX | COL_SEVERITY_TXT | COL_MSG_SOURCE_TXT | COL_SRC_FILE | COL_SRC_LINENUM | COL_MSG | COL_HEADERS
}
Logging output columns. More...

Public Member Functions

ms_file_logger (const std::string logFileName, unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS)
Constructor, sets the logfilename and columns to report.
virtual | ~ms_file_logger ()
Destructor.
std::string | formatMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const
Returns a string with formatting based on the columns requested to be output.
virtual unsigned int | getColsToOutput () const
Return the value which specifies which columns should be output by the logger.
std::string | getHeaderLine () const
Returns the header line based on the specified column names.
std::string | getLogFilename ()
virtual void | onLogMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)
Logs the passed message to the logfile.
virtual void | setColsToOutput (const unsigned int colsToOutput)
Set the value to specify which columns should be output by the logger.

Detailed Description

Concrete class which implements ms_logger and outputs log text to the specified file.

Member Enumeration Documentation

◆ LogOutputColumns_e

enum LogOutputColumns_e
inherited

Logging output columns.

These flags determine which columns are output by ms_stdout_logger and ms_file_logger.

The only way to change the order of the columns is to override the onLogMessage() function.

Enums with a [*] in the description are included in COL_LOGGER_DEFAULTS

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
COL_ASC_TIME | [ ] Output the time in the format: "Sat Jan 6 11:35:22 2018"
COL_ISO8601_TIME | [*] Output the time in the format: "2018-05-28T08:26:34-01:00". If the local time is the same as UTC, then the format would be: "2018-05-28T08:26:34Z " with 5 trailing spaces.
COL_IP_ADDRESS | [ ] Output the IP address of the calling getenv("REMOTE_ADDR"). If this is empty, "localhost" is output. Most useful for cgi applications.
COL_MSG_NUM_DEC | [ ] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.
COL_MSG_NUM_HEX | [*] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.
COL_SEVERITY_NUM | [ ] Output the ms_loggingmonitor::Level_e severity as a number.
COL_SEVERITY_TXT | [*] Output the ms_loggingmonitor::Level_e severity as text by calling ms_loggingmonitor::severityAsText .
COL_MSG_SOURCE_TXT | [*] Output the source of the message. See ms_loggingmonitor::messageSourceAsText
COL_SRC_FILE | [*] Output the source code file name.
COL_SRC_LINENUM | [*] Ouput the line number in the source file.
COL_THREAD_ID | [ ] Output the current thread ID as a hexadecimal number.
COL_MSG | [*] Output the formatted message text.
COL_TSV | [ ] By default, the output format is CSV - with each field in quotes. If this flag is used, then the column separator will be a tab
COL_QUOTES | [ ] Put quotes around every field
COL_HEADERS | [*] For ms_file_logger, this will ouput column headers if the file is empty and for ms_stdout_logger the constructor will output this
COL_LOGGER_DEFAULTS | [ ] Default columns used by Matrix Science Applications, includes values marked with [*] above.

Constructor & Destructor Documentation

◆ ms_file_logger()

ms_file_logger | ( | const std::string | logFileName,
 |  | unsigned int | colsToOutput = ms_logger::COL_LOGGER_DEFAULTS
 | ) |  |

Constructor, sets the logfilename and columns to report.

ms_logger implementation which logs to a specified file. The file is appended to and is never overwritten.

Parameters
logFileName | the full path to the log file to use
colsToOutput | is used to specify the cols to include in the log and also the format

Member Function Documentation

◆ formatMessage()

std::string formatMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId
 | ) |  | const
 inherited

Returns a string with formatting based on the columns requested to be output.

Called by ms_stdout_logger::onLogMessage and ms_file_logger::onLogMessage to return a formatted string based on the ms_logger::LogOutputColumns_e flags returned by getColsToOutput().

This function can obviously also be called by any custom ms_logger

Parameters
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message (from MDRO)
Returns
the formatted string.

◆ getColsToOutput()

unsigned int getColsToOutput ( ) const
virtualinherited

Return the value which specifies which columns should be output by the logger.

The value returned is one or more ms_logger::LogOutputColumns_e values bitwise ORed together. formatMessage uses this value to determine which columns to return.

Returns
the value set in the constructor or by calling ms_logger::setColsToOutput

◆ getHeaderLine()

std::string getHeaderLine ( ) const
inherited

Returns the header line based on the specified column names.

Returns
a string that contains the column names

◆ getLogFilename()

std::string getLogFilename ( )
Returns
the specified path to the current log file

◆ onLogMessage()

void onLogMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId = 0
 | ) |  |
virtual

Logs the passed message to the logfile.

Parameters
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message

Implements ms_logger.

◆ setColsToOutput()

void setColsToOutput ( const unsigned int colsToOutput )
virtualinherited

Set the value to specify which columns should be output by the logger.

formatMessage uses this value to determine which columns to return.

Parameters
colsToOutput is formed by bitwise ORing one or more ms_logger::LogOutputColumns_e values
The documentation for this class was generated from the following files:
  • ms_logging.hpp
  • ms_logging.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_log Class Reference

  • matrix_science
  • ms_log
Public Types | Public Member Functions | Static Public Attributes | List of all members
ms_log Class Referenceabstract
Error handling and logging

Definitions for logging messages. More...

#include <ms_log.hpp>

Inheritance diagram for ms_log:
[legend]

Public Types

typedef int msg_num_t
Typedef for log and error message numbers.
enum msg_sev {
sev_fatal = 1 ,
sev_warn = 2 ,
sev_info = 3 ,
sev_debug1 = 4 ,
sev_debug2 = 5 ,
sev_debug3 = 6
}
Message severity levels. More...

Public Member Functions

ms_log ()
Constructor.
virtual | ~ms_log ()
Destructor.
void | addToCatalog (const msg_catalog_t catalog[], size_t numEntries, ms_loggingmonitor::Source_e src, errorOrLogMessages_e errorOrLogMessages)
Add messages to the fast lookup map.
virtual msg_sev | getLoggingLevel () const =0
Get the logging level.
ms_loggingmonitor::Source_e | getMessageSource (const ms_log::msg_num_t msgNum) const
Return the component (library/application) that generated the specified log message.
bool | willMessageBeLogged (const msg_num_t msgNum) const
Check to see if the message will be logged to a file or recorded anywhere.

Static Public Attributes

static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED = 0x0001060F
[D2] Iteration for seriesID=[num] stops at index=[num] and mass=[mass]: limit is [mass]
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES = 0x00010610
[D2] Skipping d' residue because it doesn't match /[I]/ or /[T]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE = 0x00010611
[D2] Skipping d residue because it doesn't match /[ITV]/ or /[CDEKLMNPQRS]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE = 0x00010612
[D2] Skipping v residue because it doesn't match /[ARDNCQEHILKMFPSTWYV]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES = 0x00010613
[D2] Skipping w' residue because it doesn't match /[I]/ or /[T]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE = 0x00010614
[D2] Skipping w residue because it doesn't match /[ITV]/ or /[RDNCQELKMPS]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER = 0x0001061D
[D3] PSM component [num] position i=[num] has intact link, modnum=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK = 0x0001061E
[D3] PSM component [num] position i=[num] has monolink modnum=[num] monoLinkNum=[num] title=[name]
static const msg_num_t | LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK = 0x0001061F
[D1] PSM component [num] column i=[num] is ignored because there is a looplink at sites [num]-[num], modnum=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_MASSES_VALUE = 0x0001061B
[D2] Active ms_masses: [name]=[value]
static const msg_num_t | LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE = 0x0001061C
[D1] Modification at site i=[num] is [name] with delta=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS = 0x00010600
[D1] Calculated [num] fragments for psmComponent=[num], seriesID=[num], fragCharge=[num], fragNlType=[num], linkerColumn=[num], linkerMassOffset=[mass]
static const msg_num_t | LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT = 0x0001061A
[D1] cfr: Initialising isotopes and fixed mods from quant component [name]
static const msg_num_t | LOGMSG_AAHELPER_CFR_START_FRAGMENTS = 0x00010618
[D1] cfr(psmComponent=[num], seriesID=[num], fragCharge=[num], minMass=[mass], maxMass=[mass], massType=[num], fragNlType=[num], linkerColumn=[num], linkerMassOffset=[mass])
static const msg_num_t | LOGMSG_AAHELPER_CROSSLINKED_END = 0x00010619
[D1] calcCrosslinkedFragments: returning [num] alpha and [num] beta fragments
static const msg_num_t | LOGMSG_AAHELPER_CROSSLINKED_START = 0x00010609
[D1] calcCrosslinkedFragments(seriesID=[num], fragCharge=[num], minMass=[mass], maxMass=[mass], massType=[num], fragNlType=[num]); mass of linker + alpha = [mass]; linker + beta = [mass]
static const msg_num_t | LOGMSG_AAHELPER_CUMULATIVE_MASS_NL = 0x0001060D
[D2] Cumulative mass and NL at i=[num] residue=[char]: m[i]=[mass], nl[i]=[mass]
static const msg_num_t | LOGMSG_AAHELPER_ETMOD_LOOKUP = 0x00010615
[D1] lookupErrorTolerantModification(q=[num], p=[num], residue=[char]) –> raw name=[string], raw delta=[string], mod name=[name], mod delta=[mass], is mod?=[num], nl=[mass]
static const msg_num_t | LOGMSG_AAHELPER_IMMONIUM_ION_ADD = 0x00010606
[D2] Added immonium ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], residue=[char], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_IMMONIUM_ION_REJECT = 0x00010605
[D2] Rejected immonium ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], residue=[char], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_INTERNAL_ION_ADD = 0x00010608
[D2] Added internal ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], start=[num], end=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_INTERNAL_ION_REJECT = 0x00010607
[D2] Rejected internal ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], start=[num], end=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_MASTER_NL_VALS = 0x0001060B
[D2] Master neutral loss=[array]
static const msg_num_t | LOGMSG_AAHELPER_MULTINL_INDICES = 0x0001060A
[D1] Currently active multi NL indices=[array]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_ION_ADD = 0x00010602
[D2] Added regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_ION_REJECT = 0x00010601
[D2] Rejected regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD = 0x00010604
[D2] Added regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num] ([name]), column=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT = 0x00010603
[D2] Rejected regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num] ([name]), column=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_SERIES_PARAMS = 0x0001060E
[D1] Parameters for seriesID=[num]: delta=[mass], start=[num], end=[num], forward=[num]
static const msg_num_t | LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG = 0x00010617
[D1] setupFromPre2_2ResultsFile(peptide=[string], varmods=[string]) –> anyChange=[num], modNum=[num], oldStyleModName=[string], modType=[num]
static const msg_num_t | LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT = 0x00010616
[D1] setupFromPre2_2ResultsFile(peptide=[string], varmods=[string]) –> modNum=[num], idx=[num], modType=[num]
static const msg_num_t | LOGMSG_AAHELPER_TOTAL_NL_VALS = 0x0001060C
[D2] Currently active multi NL neutral loss=[array]
static const msg_num_t | LOGMSG_CUSTQUANT_ADD_QUANT_KEY = 0x00010400
[D2] Adding quantitation key id d to protein s .
static const msg_num_t | LOGMSG_CUSTQUANT_REMOVE_ALL_KEY = 0x00010401
[D2] Removing quantitation key d from any proteins.
static const msg_num_t | LOGMSG_CUSTQUANT_REMOVE_KEY = 0x00010402
[D2] Removed quantitation key d from protein s.
static const msg_num_t | LOGMSG_DBG1_NUM_PROCESSOR_GROUPS = 0x00010160
[D1] Debug: Number of processor groups : %d.
static const msg_num_t | LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS = 0x00010178
[D2] Debug: Number of cores per physical cpu : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_GETAUTODETECT = 0x00010179
[D2] Debug: getAutoDetectNumThreads(1,4) : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS = 0x00010177
[D2] Debug: Number of logical cpus / physical cpu: %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_MT_NAME = 0x0001017A
[D2] Debug: Multi-threaded name : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_MT_STATUS = 0x0001017B
[D2] Debug: Hyper/multi threading status : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NAME = 0x00010173
[D2] Debug: Processor name : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_AVAIL = 0x00010171
[D2] Debug: Logical number of cpus available : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_GROUPS = 0x00010172
[D2] Debug: Number of processor groups : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_ON_SYS = 0x00010170
[D2] Debug: Logical number of cpus on the system : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL = 0x00010176
[D2] Debug: Physical number of cpus on the system: %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_PROC_AFFINITY = 0x00010174
[D2] Debug: Process Affinity supported : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_TABLE_LINE = 0x0001017D
[D2] Debug: %3d : %2d / %5d / %5d / %s / %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_TABLE_TITLE = 0x0001017C
[D2] Debug: logical : physical id / core id / ht id / is primary / is threaded:
static const msg_num_t | LOGMSG_DBG2_CPU_INF_USE_PROCESSES = 0x00010175
[D2] Debug: Use processes instead of threads : %s
static const msg_num_t | LOGMSG_DBG2_NUM_CONFIG_MISMATCH = 0x00010168
[D2] Debug: Processor configuration detection mismatch: hwloc detects %d and system detects %d configured processors.
static const msg_num_t | LOGMSG_DBG2_NUM_ONLINE_MISMATCH = 0x00010169
[D2] Debug: Processor configuration detection mismatch: hwloc detects %d and system detects %d online processors.
static const msg_num_t | LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD = 0x00010163
[D3] Debug: getAutoDetectNumThreads. logicalPerPhysical: %d, numCores: %d, numLicensed: %d, numCoresPerCpuLicense: %d, maxLicensable: %d, numAvailableToProcess: %d.
static const msg_num_t | LOGMSG_DBG3_BINDING_PROCESSORS = 0x00010166
[D3] Debug: binding processors %s.
static const msg_num_t | LOGMSG_DBG3_BINDING_THREAD = 0x00010167
[D3] Debug: binding thread p to logical processor %d.
static const msg_num_t | LOGMSG_DBG3_CALL_GET_CHIP_MFCTR = 0x00010164
[D3] Debug: about to call getChipManufacturer()
static const msg_num_t | LOGMSG_DBG3_HWLOC_GROUPS = 0x00010162
[D2] Debug: hwloc reports %d processor groups.
static const msg_num_t | LOGMSG_DBG3_HWLOC_TREE = 0x00010161
[D3] Debug: iterateHwlocChildren: %%-8s, logical: %d, depth: %d, packageID: %d, coreID: %d.
static const msg_num_t | LOGMSG_DBG3_PROCESSOR_NAME = 0x00010165
[D2] Debug: processor name: %s, hyperthreading: %s.
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND = 0x00010A05
[D2] getThresholdForFDR: found a new minimum at i=d, fdr_min=g, target_min=d, decoy_min=d, expect_min=g
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_START = 0x00010A03
[D2] getThresholdForFDR: i=d, expect=g, target=d, decoy=d, target_count=d, decoy_count=d, fdr=g, too_few=d
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT = 0x00010A04
[D2] getThresholdForFDR: target or decoy count dropped to zero at i=d, target_count=d, decoy_count=d
static const msg_num_t | LOGMSG_GET_THR_REACH_COND = 0x00010A06
[D2] getThresholdForFDR: Result FDR reached; minimum seen at fdr_min=g, expect_min=g, target_min=d, decoy_min=d
static const msg_num_t | LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET = 0x00010A02
[D1] getThresholdForFDR(g, s, DM_FASTA_SECOND_PASS) returned success = d, closestFDR = g, minProbability = g, numTargetMatches = d, numDecoyMatches = d
static const msg_num_t | LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR = 0x00010A01
[D1] getThresholdForFDR(g, s, DM_FASTA_FIRST_PASS) returned success = d, closestFDR = g, minProbability = g, numTargetMatches = d, numDecoyMatches = d
static const msg_num_t | LOGMSG_HTTP_GETRETURNSTRING = 0x00010304
[I] The http GET returned '[text]'.
static const msg_num_t | LOGMSG_HTTP_MAXCONECTIONS10FAILED = 0x00010303
[I] Failed to set maximum connections per 1.0 server
static const msg_num_t | LOGMSG_HTTP_MAXCONECTIONSFAILED = 0x00010302
[I] Failed to set maximum connections per server
static const msg_num_t | LOGMSG_HTTP_QUERYSTATUSRESULT = 0x00010301
[I] HTTP status is [httpCode] 'httpText'.
static const msg_num_t | LOGMSG_HTTP_URLSTRING = 0x00010300
[I] Sending HTTP [httpMethod] to [url] for action [command].
static const msg_num_t | LOGMSG_INST_ADDINGDATABASE = 0x00010205
[I] Adding entry for s to mascot.dat.
static const msg_num_t | LOGMSG_INST_ADDOPTIONSSECTION = 0x00010208
[I] Added [value] to the options section of mascot.dat.
static const msg_num_t | LOGMSG_INST_APPENDPARSERULE = 0x00010207
[I] Added parse rule number [value].
static const msg_num_t | LOGMSG_INST_APPENDTAXONOMY = 0x00010204
[I] Appended taxonomy section [value].
static const msg_num_t | LOGMSG_INST_CHANGEDBTAXONOMY = 0x00010206
[I] Changed taxonomy entry for [database].
static const msg_num_t | LOGMSG_INST_CHANGEPARSERULE = 0x0001020C
[I] Changed [value] parse rule from rule [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGEPERCOLATORFEATS = 0x00010210
[I] Changed PercolatorFeatures section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGEPERCOLATORUSERT = 0x00010212
[I] Changed PercolatorUseRT section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGEPROTFAMILYSWITCH = 0x00010211
[I] Changed ProteinFamilySwitch section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGERESULTSCACHE = 0x00010215
[I] Changed ResultsCache section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGESPLITDATAFILESIZE = 0x00010214
[I] Changed SplitDataFileSize section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGESPLITNUMOFQUERIES = 0x00010213
[I] Changed SplitNumberOfQueries section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CLUSTERSECTION = 0x0001020A
[I] Set the value of [name] to [value] in the cluster section of mascot.dat.
static const msg_num_t | LOGMSG_INST_FAILSAVEPOSTINSTALLFILE = 0x0001020E
[I] Failed to save Post Install File [name]. Error [value]
static const msg_num_t | LOGMSG_INST_LOGICALPERPHYSICALCPU = 0x00010200
[I] Detected %d logical processors per physical CPU.
static const msg_num_t | LOGMSG_INST_MASCOTDATOK = 0x00010203
[I] Successfully loaded existing mascot.dat from [path].
static const msg_num_t | LOGMSG_INST_NOSUBCLUSTERSET = 0x0001020B
[I] No SubClusterSet entry in mascot.dat.
static const msg_num_t | LOGMSG_INST_NOTMASCOTDATOK = 0x00010202
[I] Successfully loaded not.mascot.dat from [path].
static const msg_num_t | LOGMSG_INST_NUMTHREADS = 0x00010201
[I] Setting number of threads to [value].
static const msg_num_t | LOGMSG_INST_REMOVEOPTIONSSECTION = 0x0001020F
[I] Removed [value] from the options section of mascot.dat.
static const msg_num_t | LOGMSG_INST_SAVEDPOSTINSTALLFILE = 0x0001020D
[I] Saved line ([text]) in Post Install File [name] for Database Manager
static const msg_num_t | LOGMSG_INST_SETOPTIONSSECTION = 0x00010209
[I] Set the value of [name] to [value] in the options section of mascot.dat.
static const msg_num_t | LOGMSG_MATRIX_OUTPUT_VALS = 0x00010500
[D3] s. d rows and d columns
s
static const msg_num_t | LOGMSG_MSR2DAT28_SQL_TRACING = 0x00010B00
[D3] ms_msr2dat28 SQL: [string] –> [string]
static const msg_num_t | LOGMSG_NON_DEFAULT_HOMOLOGY_THRESHOLD = 0x00010A07
[D2] getHomologyThreshProtected called with OneInXprobRnd = g, where minProbability_= g, and 1/minProbability_= g, query = d
static const msg_num_t | LOGMSG_PEPSUM_GETHIT = 0x00010729
[D3] [function]: [string], [string], [string]
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP = 0x00010713
[D2] choose_next_free_protein(): free count of "[accession]" is [num] => keep
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_START = 0x00010710
[D1] choose_next_free_protein(): lead_proteins are [list]
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY = 0x00010711
[D2] choose_next_free_protein(): free_count of "[accession]" is [num] but no superset found in lead_proteins; keeping for now
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST = 0x00010712
[D2] choose_next_free_protein(): free count of "[accession]" is [num] => move to subset_list with parents [list]
static const msg_num_t | LOGMSG_PROTINFER_CLUSTER_FROM_ACC = 0x00010726
[D1] sortByScore(): Starting point for cluster in hit [num] is [accession]
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO = 0x0001070D
[D2] eliminate_intersections() : ran out of unused_proteins (all free counts are zero)
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT = 0x0001070E
[D2] eliminate_intersections() : next unused protein to try to add is "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST = 0x0001070F
[D2] eliminate_intersections() : fix-up of supersetlist for "[accession]", [changed lists]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_END = 0x00010704
[D1] findFamily() end for accession "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_QUEUE = 0x00010701
[D1] findFamily(): "[accession]" (node idx = [num]) has [num] PSMs above threshold ([num] PSMs below), [num] homologous proteins, in_queue size=[num], queue size=[num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS = 0x00010702
[D1] findFamily(): "[accession]" has the following [num] representative sequences: [list]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_START = 0x00010700
[D1] findFamily() start for accession "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END = 0x00010725
[D2] findMatchesForThisProteinAndChildren(): Accession: [accession], size of qp = [num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START = 0x00010723
[D2] findMatchesForThisProteinAndChildren(): Accession: [accession], size of qp = [num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START = 0x00010724
[D2] findMatchesForThisProteinAndChildren(): Subset accession: [accession]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST = 0x00010708
[D2] groupFamily(): discardedSLProteins: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION = 0x00010709
[D1] groupFamily(): eliminate_intersections. lead_proteins size = [num], subset_proteins size = [num]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST = 0x0001070B
[D1] groupFamily(): leadProteins after elimination: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST = 0x0001070A
[D1] groupFamily(): family members after elimination: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST = 0x0001070C
[D1] groupFamily(): "[accession]" has parent "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN = 0x0001072B
[D1] homologous_proteins(): "[accession]" shares q[num]_p[num] with "[accession]" => pull it in to the family
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST = 0x00010707
[D2] groupFamily(): samesetLeadProteins: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST = 0x00010706
[D2] groupFamily(): samesetParents: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_START = 0x00010705
[D1] groupFamily() for "[accession]": samesetLeadProteins=[num], samesetParents=[num], discardedSLProteins=[num]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FROM_ACC = 0x00010727
[D1] sortByScore(): Starting point for group in hit [num] is [accession]
static const msg_num_t | LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY = 0x0001072A
[D2] findFamily(): Family [num] has [num] peptide matches with keepingThisOne=[boolean]
static const msg_num_t | LOGMSG_PROTINFER_PEPTIDE_MATRIX = 0x00010703
[D2] findFamily(): [type] peptide matrix (transposed)
[matrix]
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD = 0x00010716
[D2] remove_conflicting_proteins(): lead protein "[accession]" has free count n < minNumSigUniqueSeqs (n = [num], minNumSiqUniqueSeqs = [num]) => move to subset list with parents [accessions]
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP = 0x00010715
[D2] remove_conflicting_proteins(): lead protein "[accession]" does not overlap with any current lead protein => keep
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_START = 0x00010714
[D2] remove_conflicting_proteins([list])
static const msg_num_t | LOGMSG_PROTINFER_SINGLETON_FROM_ACC = 0x00010728
[D1] sortByScore(): No grouping; hit [num] is just "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE = 0x00010718
[D2] sortByScore(): About to create sorted_
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED = 0x00010719
[D2] sortByScore(): Finished creating sorted_
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_DONE = 0x00010722
[D1] sortByScore(): reached the end of sorted_, so it's all done
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN = 0x00010721
[D1] sortByScore(): next accession in sorted_ with significant rank 1 peptide is "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS = 0x0001071A
[D1] sortByScore(): proteins_ is empty, so it's all done
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD = 0x00010720
[D1] sortByScore(): Removing "[accession]" because setBoldAndCheckBoxItems() returned false
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN = 0x0001071D
[D1] sortByScore(): Removing "[accession]" because longestPeptideLen [num] < minPepLenInPepSummary [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN = 0x0001071E
[D1] sortByScore(): Removing "[accession]" because longestSigPeptideLen [num] < minPepLenInPepSummary [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS = 0x0001071C
[D1] sortByScore(): Removing "[accession]" because numProteins [num] >= maxHitsToReport [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE = 0x0001071B
[D1] sortByScore(): Removing "[accession]" because its score [num] is less than minProteinScore [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_START = 0x00010717
[D1] sortByScore(): Num proteins: [num], num peptides: [num], hitToAdd: [num]
static const msg_num_t | LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT = 0x0001071F
[D2] sortByScore(): Protein "[accession]" is a subset in hit [num]. Because MSRES_SUBSETS_DIFF_PROT is active, it will now start hit [num]
static const msg_num_t | LOGMSG_QUANT_ADDED_PROTEIN_HIT = 0x00010417
[D2] Added quantitation protein hit [accession] to match [value] with sequence [text]
static const msg_num_t | LOGMSG_QUANT_ADDING_PROTEIN_HIT = 0x00010416
[D2] Adding quantitation protein hit [accession]
static const msg_num_t | LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED = 0x0001040F
[D2] Calling calc_complete() on merged dataset
static const msg_num_t | LOGMSG_QUANT_CLOSING_CACHE_FILE = 0x00010419
[D2] Closing quantitation cache file [filename]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE = 0x00010411
[D2] Excluding peptide for query: [value], rank: [value] because [string]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN = 0x00010413
[D2] Excluding peptide for query: [value], rank: [value] because [string]. [value] > [value]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN = 0x00010412
[D2] Excluding peptide for query: [value], rank: [value] because [string]. [value] < [value]
static const msg_num_t | LOGMSG_QUANT_FINISH_CALC_COMPLETE = 0x00010406
[D2] Finished calc_complete() call
static const msg_num_t | LOGMSG_QUANT_FINISH_LOAD_CDB = 0x00010409
[D2] Finished loadCdbFile() call
static const msg_num_t | LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE = 0x0001041B
[D1] Finished reordering of peptide matches after merge
static const msg_num_t | LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES = 0x00010404
[D2] Finished updating protein matches
static const msg_num_t | LOGMSG_QUANT_HELPER_TEST_REQUIRED = 0x00010800
[D3] testRequiredMods(): sorted required mods="[string]", sequence="[string]", mods="[string]", iter=[char]
static const msg_num_t | LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES = 0x0001040A
[D2] Loading all peptide status values
static const msg_num_t | LOGMSG_QUANT_LOADING_MATCHES = 0x0001040B
[D2] Loading quantitation matches
static const msg_num_t | LOGMSG_QUANT_MERGE_COMPONENT_DUPE_FI = 0x0001041D
[D1] Duplicate file_index: d when trying to merge file_index for same component. Name: s, Mods: s, m/z: f
static const msg_num_t | LOGMSG_QUANT_MERGE_COMPONENT_INCONSIST = 0x0001041C
[D1] Incompatibility trying to merge file_index for same component. Name: s (s), Mods: s (s), m/z: f (f)
static const msg_num_t | LOGMSG_QUANT_MERGE_COMPONENT_SUCCESS = 0x0001041E
[D2] Successfully merging file_index: d into existing component. Name: s, Mods: s, m/z: f
static const msg_num_t | LOGMSG_QUANT_OPENING_CACHE_FILE = 0x00010418
[D2] Opening quantitation cache file [filename]
static const msg_num_t | LOGMSG_QUANT_REAPPLY_THRESHOLDS = 0x0001040D
[D2] Reapplying quantitation quality thresholds
static const msg_num_t | LOGMSG_QUANT_REMATCHING_INFERRED = 0x00010410
[D2] Rematching [value] inferred matches
static const msg_num_t | LOGMSG_QUANT_REMOVE_INFERRED_MATCH = 0x00010415
[D1] Removing inferred quantitation match [value] - [value] < [value]
static const msg_num_t | LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE = 0x00010414
[D1] Removing quantitation match [value] - no remaining evidence
static const msg_num_t | LOGMSG_QUANT_RT_OFFSET_LOOKUP = 0x00010420
[D2] Retention time: f, from project: d, gives an offset of: f for project: d. (m/z: f)
static const msg_num_t | LOGMSG_QUANT_START_CALC_COMPLETE = 0x00010405
[D2] Calling calc_complete()
static const msg_num_t | LOGMSG_QUANT_START_LOAD_CDB = 0x00010408
[D2] Start of loadCdbFile() call. Cdb file: [filename], cache file: [filename]
static const msg_num_t | LOGMSG_QUANT_START_REORDER_AFTER_MERGE = 0x0001041A
[D1] Starting reordering of peptide matches after merge
static const msg_num_t | LOGMSG_QUANT_START_UPDATE_PROT_MATCHES = 0x00010403
[D2] Starting to update protein matches
static const msg_num_t | LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE = 0x0001041F
[D1] Invalid index when getting RT offset - expected for some Waters MS^E peptides. This project id: d, other project id: d. Rt in other project: f, m/z: f. Combined min bin number: d. bin number: d, Array size: d
static const msg_num_t | LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE1 = 0x00010421
[D1] In getEstimatedFeatureWidth(), for subProject: [num], m/z: [value], rt: [value], binIndex: [num], but max bin for this sub project: [num], min bin: 0
static const msg_num_t | LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES = 0x0001040E
[D2] Updating excluded matches
static const msg_num_t | LOGMSG_QUANT_UPDATING_PEP_EVIDENCE = 0x0001040C
[D2] Updating Peptide Evidence
static const msg_num_t | LOGMSG_REPORT_FUNCTION_CALLED_BY = 0x00010900
[D3] [function], called by [string]
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY = 0x00010901
[D3] [function] entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 = 0x00010902
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 = 0x00010903
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 = 0x00010904
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 = 0x00010905
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_EXIT = 0x00010910
[D3] [function] exited
static const msg_num_t | LOGMSG_REPORT_FUNCTION_EXIT_WITH = 0x00010911
[D3] [function] exited with [string]
static const msg_num_t | LOGMSG_RESFILE_APPEND = 0x00010A00
[D2] [string] numQueries=[num] cachedExpValues=[num]

Detailed Description

Definitions for logging messages.

Member Typedef Documentation

◆ msg_num_t

typedef int msg_num_t

Typedef for log and error message numbers.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Logging messages are classified as:

  • [I] information
  • [D1] Debug level 1 message
  • [D2] Debug level 2 message
  • [D3] Debug level 3 message

Ranges:

Product | Classification | First | Last
Parser | sev_fatal, sev_warn | 0x00000000 | 0x0000FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00010000 | 0x0001FFFF
MSQuantlib | sev_fatal, sev_warn | 0x00020000 | 0x0002FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00030000 | 0x0003FFFF
Purifier API | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00040000 | 0x0004FFFF
Purifier | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00050000 | 0x0005FFFF
Mascot Server | sev_fatal, sev_warn | 0x00000000 | 0x0000FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00060000 | 0x0006FFFF
MDRO | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x4C020000 | 0x4C03FFFF

Member Enumeration Documentation

◆ msg_sev

enum msg_sev

Message severity levels.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

See also: ms_loggingmonitor::Level_e

Enumerator
sev_fatal | A fatal error that results in the object being 'invalid'.
sev_warn | A warning message.
sev_info | Information message.
sev_debug1 | Debug level 1 message.
sev_debug2 | Debug level 2 message.
sev_debug3 | Debug level 3 message.

Constructor & Destructor Documentation

◆ ms_log()

ms_log ( )

Constructor.

Initialisation by adding the message text and severity to a lookup

◆ ~ms_log()

~ms_log ( )
virtual

Destructor.

Nothing to delete, but a virtual destructor needs to be defined as we have virtual methods

Member Function Documentation

◆ addToCatalog()

void addToCatalog | ( | const msg_catalog_t | catalog[],
 |  | size_t | numEntries,
 |  | ms_loggingmonitor::Source_e | src,
 |  | errorOrLogMessages_e | errorOrLogMessages
 | ) |  |

Add messages to the fast lookup map.

Parameters
catalog | is a pointer to an array of messages and severities
numEntries | is the number of entries in catalog
src | is used to check if the messages have already been added to the static catalog_ map.
errorOrLogMessages | is used, with src to check if the messages have already been added to the static catalog_ map.

◆ getMessageSource()

ms_loggingmonitor::Source_e getMessageSource ( const ms_log::msg_num_t msgNum ) const

Return the component (library/application) that generated the specified log message.

The return value is based on the message number and determined from the table shown for msg_num_t above. If the value isn't in one of the above ranges, then ms_loggingmonitor::SRC_ALL will be returned.

Parameters
msgNum Numeric code of the messaged to be logged
Returns
the ms_loggingmonitor::Source_e value.

◆ willMessageBeLogged()

bool willMessageBeLogged ( const msg_num_t msgNum ) const

Check to see if the message will be logged to a file or recorded anywhere.

If the code to format a log message might take some time to run, it is worth calling this function first to see if the message will be logged or used anywhere.

Parameters
msgNum must be a valid error number
Returns
true if the message will be logged, or returned by getErrorString()
The documentation for this class was generated from the following files:
  • ms_log.hpp
  • ms_log.cpp
  • ms_log_impl.hpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_logger Class Reference

  • matrix_science
  • ms_logger
Public Types | Public Member Functions | List of all members
ms_logger Class Referenceabstract
Error handling and logging

Abstract class which provides the interface used by ms_logging monitor to delegate logging events. More...

#include <ms_logging.hpp>

Inheritance diagram for ms_logger:
[legend]

Public Types

enum LogOutputColumns_e {
COL_ASC_TIME = 0x0001 ,
COL_ISO8601_TIME = 0x0002 ,
COL_IP_ADDRESS = 0x0004 ,
COL_MSG_NUM_DEC = 0x0008 ,
COL_MSG_NUM_HEX = 0x0010 ,
COL_SEVERITY_NUM = 0x0020 ,
COL_SEVERITY_TXT = 0x0040 ,
COL_MSG_SOURCE_TXT = 0x0080 ,
COL_SRC_FILE = 0x0100 ,
COL_SRC_LINENUM = 0x0200 ,
COL_THREAD_ID = 0x0400 ,
COL_MSG = 0x0800 ,
COL_TSV = 0x1000 ,
COL_QUOTES = 0x2000 ,
COL_HEADERS = 0x4000 ,
COL_LOGGER_DEFAULTS = COL_ISO8601_TIME | COL_MSG_NUM_HEX | COL_SEVERITY_TXT | COL_MSG_SOURCE_TXT | COL_SRC_FILE | COL_SRC_LINENUM | COL_MSG | COL_HEADERS
}
Logging output columns. More...

Public Member Functions

ms_logger (const unsigned int colsToOutput=COL_MSG)
Constructor.
virtual | ~ms_logger ()
Destructor.
std::string | formatMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const
Returns a string with formatting based on the columns requested to be output.
virtual unsigned int | getColsToOutput () const
Return the value which specifies which columns should be output by the logger.
std::string | getHeaderLine () const
Returns the header line based on the specified column names.
virtual void | onLogMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)=0
Processes and handles the passed logging message.
virtual void | setColsToOutput (const unsigned int colsToOutput)
Set the value to specify which columns should be output by the logger.

Detailed Description

Abstract class which provides the interface used by ms_logging monitor to delegate logging events.

See also ms_stdout_logger and ms_file_logger which inherit from this class.

See Logging using ms_loggingmonitor for examples on using this class

Member Enumeration Documentation

◆ LogOutputColumns_e

enum LogOutputColumns_e

Logging output columns.

These flags determine which columns are output by ms_stdout_logger and ms_file_logger.

The only way to change the order of the columns is to override the onLogMessage() function.

Enums with a [*] in the description are included in COL_LOGGER_DEFAULTS

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
COL_ASC_TIME | [ ] Output the time in the format: "Sat Jan 6 11:35:22 2018"
COL_ISO8601_TIME | [*] Output the time in the format: "2018-05-28T08:26:34-01:00". If the local time is the same as UTC, then the format would be: "2018-05-28T08:26:34Z " with 5 trailing spaces.
COL_IP_ADDRESS | [ ] Output the IP address of the calling getenv("REMOTE_ADDR"). If this is empty, "localhost" is output. Most useful for cgi applications.
COL_MSG_NUM_DEC | [ ] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.
COL_MSG_NUM_HEX | [*] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.
COL_SEVERITY_NUM | [ ] Output the ms_loggingmonitor::Level_e severity as a number.
COL_SEVERITY_TXT | [*] Output the ms_loggingmonitor::Level_e severity as text by calling ms_loggingmonitor::severityAsText .
COL_MSG_SOURCE_TXT | [*] Output the source of the message. See ms_loggingmonitor::messageSourceAsText
COL_SRC_FILE | [*] Output the source code file name.
COL_SRC_LINENUM | [*] Ouput the line number in the source file.
COL_THREAD_ID | [ ] Output the current thread ID as a hexadecimal number.
COL_MSG | [*] Output the formatted message text.
COL_TSV | [ ] By default, the output format is CSV - with each field in quotes. If this flag is used, then the column separator will be a tab
COL_QUOTES | [ ] Put quotes around every field
COL_HEADERS | [*] For ms_file_logger, this will ouput column headers if the file is empty and for ms_stdout_logger the constructor will output this
COL_LOGGER_DEFAULTS | [ ] Default columns used by Matrix Science Applications, includes values marked with [*] above.

Constructor & Destructor Documentation

◆ ms_logger()

ms_logger ( const unsigned int colsToOutput = COL_MSG )

Constructor.

ms_logger is an abstract class, so this is called from ms_stdout_logger, ms_file_logger and should be called from any other inherited classes.

See Logging using ms_loggingmonitor for examples on using this class

Parameters
colsToOutput is formed by bitwise ORing one or more ms_logger::LogOutputColumns_e values

Member Function Documentation

◆ formatMessage()

std::string formatMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId
 | ) |  | const

Returns a string with formatting based on the columns requested to be output.

Called by ms_stdout_logger::onLogMessage and ms_file_logger::onLogMessage to return a formatted string based on the ms_logger::LogOutputColumns_e flags returned by getColsToOutput().

This function can obviously also be called by any custom ms_logger

Parameters
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message (from MDRO)
Returns
the formatted string.

◆ getColsToOutput()

unsigned int getColsToOutput ( ) const
virtual

Return the value which specifies which columns should be output by the logger.

The value returned is one or more ms_logger::LogOutputColumns_e values bitwise ORed together. formatMessage uses this value to determine which columns to return.

Returns
the value set in the constructor or by calling ms_logger::setColsToOutput

◆ getHeaderLine()

std::string getHeaderLine ( ) const

Returns the header line based on the specified column names.

Returns
a string that contains the column names

◆ setColsToOutput()

void setColsToOutput ( const unsigned int colsToOutput )
virtual

Set the value to specify which columns should be output by the logger.

formatMessage uses this value to determine which columns to return.

Parameters
colsToOutput is formed by bitwise ORing one or more ms_logger::LogOutputColumns_e values
The documentation for this class was generated from the following files:
  • ms_logging.hpp
  • ms_logging.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_loggingmonitor Class Reference

  • matrix_science
  • ms_loggingmonitor
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_loggingmonitor Class Reference
Error handling and logging

Monitor class to delegate logging events generated from multiple sources. More...

#include <ms_logging.hpp>

Public Types

enum Level_e {
LVL_NONE = 0 ,
LVL_ERROR = 1 ,
LVL_WARNING = 2 ,
LVL_INFO = 4 ,
LVL_DEBUG1 = 8 ,
LVL_DEBUG2 = 16 ,
LVL_DEBUG3 = 32
}
Logging severity levels. More...
enum Source_e {
SRC_APPLICATION = 1 ,
SRC_MASCOTSERVER = 2 ,
SRC_MSPARSER = 3 ,
SRC_MDRO = 4 ,
SRC_MSQUANTLIB = 5 ,
SRC_PURIFIERAPI = 6 ,
SRC_PURIFIERAPP = 7 ,
SRC_DENOVOLIB = 8 ,
SRC_VENDORSTART = 100 ,
SRC_ALL = 0xFFFF
}
Logging event source. More...

Public Member Functions

ms_loggingmonitor ()
Constructor.
virtual | ~ms_loggingmonitor ()
Destructor.
virtual int | addLogEventsHandler (ms_logger &logger)
Registers the passed ms_logger with the ms_loggingmonitor.
virtual ms_logger * | getLogEventsHandler (const int uid)
Returns the ms_logger object associated with the passed uid, or null if the specified uid is invalid.
virtual long | getLogMask (unsigned source=SRC_ALL)
Returns the current logging events mask.
virtual int | getNumLogEventsHandlers () const
Returns the number of events handlers.
virtual void | logMessage (Level_e eSeverity, Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) const
Logs the passed message with all registered ms_logger objects.
virtual bool | removeLogEventsHandler (const int uid)
Deregisters the specified ms_logger from the ms_loggingmonitor.
virtual void | setLogMask (long newVal, unsigned source=SRC_ALL)
Sets the current logging events mask.

Static Public Member Functions

static matrix_science::ms_loggingmonitor & | getDefaultMonitor ()
Returns the global ms_loggingmonitor used by msparser.
static std::string | messageSourceAsText (Source_e eSource)
Returns a Source_e enum value as a text string.
static void | setDefaultMonitor (ms_loggingmonitor &loggingMonitor)
Sets the global ms_loggingmonitor to be used by msparser.
static std::string | severityAsText (Level_e eSeverity)
Returns a severity enum value as a text string.

Detailed Description

Monitor class to delegate logging events generated from multiple sources.

See Logging using ms_loggingmonitor for details.

Member Enumeration Documentation

◆ Level_e

enum Level_e

Logging severity levels.

These have the same meaning as ms_errs::msg_sev, but do not have the same values. See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
LVL_NONE | Logging disabled.
LVL_ERROR | A fatal error that results in the object being 'invalid'.
LVL_WARNING | A warning message.
LVL_INFO | Information message. Not available by default unless setLoggingMask() called.
LVL_DEBUG1 | Debug level 1 message. Not available by default unless setLoggingMask() called .
LVL_DEBUG2 | Debug level 2 message. Not available by default unless setLoggingMask() called.
LVL_DEBUG3 | Debug level 3 message. Not available by default unless setLoggingMask() called.

◆ Source_e

enum Source_e

Logging event source.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
SRC_APPLICATION | Logging event raised by the current application.
SRC_MASCOTSERVER | Logging event raised by Mascot server.
SRC_MSPARSER | Logging event raised by the msparser library.
SRC_MDRO | Logging event raised by the MDRO library.
SRC_MSQUANTLIB | Logging event raised by the msquantlib library.
SRC_PURIFIERAPI | Logging event raised by the purifierapi library.
SRC_PURIFIERAPP | Logging event raised by the Purifier application.
SRC_DENOVOLIB | Logging event raised by the Denovo library.
SRC_VENDORSTART | Use this value for third party applications.
SRC_ALL | Use this with setLogMask() and getLogMask()

Member Function Documentation

◆ addLogEventsHandler()

int addLogEventsHandler ( ms_logger & logger )
virtual

Registers the passed ms_logger with the ms_loggingmonitor.

See also
Maintaining object references: two rules of thumb
Parameters
logger is the ms_logger object to add
Returns
the uid of the logger object in the ms_loggingmonitor, or -1 if it is already registered

◆ getDefaultMonitor()

ms_loggingmonitor & getDefaultMonitor ( )
static

Returns the global ms_loggingmonitor used by msparser.

To add a custom ms_logger to the default ms_logging monitor, call getDefaultMonitor().addLogEventsHandler()

Returns
the global ms_loggingmonitor object used to handle all logging events from msparser

◆ getLogEventsHandler()

ms_logger * getLogEventsHandler ( const int uid )
virtual

Returns the ms_logger object associated with the passed uid, or null if the specified uid is invalid.

Parameters
uid the uid of the ms_logger to retrieve
Returns
the ms_logger associated with the passed uid or NULL if not found

◆ getLogMask()

long getLogMask ( unsigned source = SRC_ALL )
virtual

Returns the current logging events mask.

The default log mask value is Level_e::LVL_ERROR | Level_e::LVL_WARNING, so only messages with a severity level of Level_e::LVL_ERROR or Level_e::LVL_WARNING will be logged

Parameters
source should be one of the Source_e values. See setLogMask for details.
Returns
the current logging events mask.

◆ getNumLogEventsHandlers()

int getNumLogEventsHandlers ( ) const
virtual

Returns the number of events handlers.

Returns
will be zero if there are no handlers, so there is no point in sending any messages to the logging monitor

◆ messageSourceAsText()

std::string messageSourceAsText ( Source_e eSource )
static

Returns a Source_e enum value as a text string.

Useful for writing a human readable log file, this method returns the message source as text:

  • SRC_APPLICATION : "APPLICATION_"
  • SRC_MASCOTSERVER : "MASCOTSERVER"
  • SRC_MSPARSER : "MSPARSER_API"
  • SRC_MDRO : "MDRO_LIB_API"
  • SRC_MSQUANTLIB : "QUANTLIB_API"
  • SRC_PURIFIERAPI : "PURIFIER_API"
  • SRC_PURIFIERAPP : "PURIFIER_APP"
  • SRC_DENOVOLIB : "MSDENOVO_API"
  • SRC_VENDORSTART : "VENDOR_START"
  • SRC_ALL : "ALL_SOURCES_"
  • Any other number : "UNKNOWN_SRC_"
Parameters
eSource should be on of the ms_loggingmonitor::Source_e enum values
Returns
One of 12 character strings above.

◆ removeLogEventsHandler()

bool removeLogEventsHandler ( const int uid )
virtual

Deregisters the specified ms_logger from the ms_loggingmonitor.

Parameters
uid the uid of the ms_logger to removed
Returns
true if the specified ms_logger was removed, false if it was not found

◆ setDefaultMonitor()

void setDefaultMonitor ( ms_loggingmonitor & loggingMonitor )
static

Sets the global ms_loggingmonitor to be used by msparser.

It is normally sufficient to add ms_logger objects to the default ms_loggingmonitor using getDefaultMonitor()

Parameters
loggingMonitor the ms_loggingmonitor to use

◆ setLogMask()

void setLogMask | ( | long | newVal,
 |  | unsigned | source = SRC_ALL
 | ) |  |
virtual

Sets the current logging events mask.

Parameters
newVal | the new log mask value to set. Bitwise Or the relevant ms_loggingmonitor::Level_e values
source | should be one of the Source_e values. For most applications, the same mask (logging level) can be used for all the components, so the default of SRC_ALL can be used. If different levels are required, then call this function multiple times, firstly with SRC_ALL to set the default, and then with, for example SRC_MDRO to set a higher or lower level for MDRO logging. When called with SRC_ALL, all previous values for specific components are removed.

◆ severityAsText()

std::string severityAsText ( Level_e eSeverity )
static

Returns a severity enum value as a text string.

Useful for writing a human readable log file, this method returns the message severity as text:

  • LVL_ERROR : "LVL_ERROR "
  • LVL_WARNING : "LVL_WARNING"
  • LVL_INFO : "LVL_INFO "
  • LVL_DEBUG1 : "LVL_DEBUG1 "
  • LVL_DEBUG2 : "LVL_DEBUG2 "
  • LVL_DEBUG3 : "LVL_DEBUG3 "
  • Unrecognised : "LVL_UNKNOWN"
Parameters
eSeverity should be on of the ms_loggingmonitor::Level_e enum values
Returns
One of 11 character strings above.
The documentation for this class was generated from the following files:
  • ms_logging.hpp
  • ms_logging.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_stdout_logger Class Reference

  • matrix_science
  • ms_stdout_logger
Public Types | Public Member Functions | List of all members
ms_stdout_logger Class Reference
Error handling and logging

Concrete class which implements ms_logger and outputs log text to standard out. More...

#include <ms_logging.hpp>

Inheritance diagram for ms_stdout_logger:
[legend]
Collaboration diagram for ms_stdout_logger:
[legend]

Public Types

enum LogOutputColumns_e {
COL_ASC_TIME = 0x0001 ,
COL_ISO8601_TIME = 0x0002 ,
COL_IP_ADDRESS = 0x0004 ,
COL_MSG_NUM_DEC = 0x0008 ,
COL_MSG_NUM_HEX = 0x0010 ,
COL_SEVERITY_NUM = 0x0020 ,
COL_SEVERITY_TXT = 0x0040 ,
COL_MSG_SOURCE_TXT = 0x0080 ,
COL_SRC_FILE = 0x0100 ,
COL_SRC_LINENUM = 0x0200 ,
COL_THREAD_ID = 0x0400 ,
COL_MSG = 0x0800 ,
COL_TSV = 0x1000 ,
COL_QUOTES = 0x2000 ,
COL_HEADERS = 0x4000 ,
COL_LOGGER_DEFAULTS = COL_ISO8601_TIME | COL_MSG_NUM_HEX | COL_SEVERITY_TXT | COL_MSG_SOURCE_TXT | COL_SRC_FILE | COL_SRC_LINENUM | COL_MSG | COL_HEADERS
}
Logging output columns. More...

Public Member Functions

ms_stdout_logger (unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS)
Constructor.
virtual | ~ms_stdout_logger ()
Destructor.
std::string | formatMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const
Returns a string with formatting based on the columns requested to be output.
virtual unsigned int | getColsToOutput () const
Return the value which specifies which columns should be output by the logger.
std::string | getHeaderLine () const
Returns the header line based on the specified column names.
virtual void | onLogMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)
Logs the passed message directly to standard out.
virtual void | setColsToOutput (const unsigned int colsToOutput)
Set the value to specify which columns should be output by the logger.

Detailed Description

Concrete class which implements ms_logger and outputs log text to standard out.

Member Enumeration Documentation

◆ LogOutputColumns_e

enum LogOutputColumns_e
inherited

Logging output columns.

These flags determine which columns are output by ms_stdout_logger and ms_file_logger.

The only way to change the order of the columns is to override the onLogMessage() function.

Enums with a [*] in the description are included in COL_LOGGER_DEFAULTS

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
COL_ASC_TIME | [ ] Output the time in the format: "Sat Jan 6 11:35:22 2018"
COL_ISO8601_TIME | [*] Output the time in the format: "2018-05-28T08:26:34-01:00". If the local time is the same as UTC, then the format would be: "2018-05-28T08:26:34Z " with 5 trailing spaces.
COL_IP_ADDRESS | [ ] Output the IP address of the calling getenv("REMOTE_ADDR"). If this is empty, "localhost" is output. Most useful for cgi applications.
COL_MSG_NUM_DEC | [ ] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.
COL_MSG_NUM_HEX | [*] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.
COL_SEVERITY_NUM | [ ] Output the ms_loggingmonitor::Level_e severity as a number.
COL_SEVERITY_TXT | [*] Output the ms_loggingmonitor::Level_e severity as text by calling ms_loggingmonitor::severityAsText .
COL_MSG_SOURCE_TXT | [*] Output the source of the message. See ms_loggingmonitor::messageSourceAsText
COL_SRC_FILE | [*] Output the source code file name.
COL_SRC_LINENUM | [*] Ouput the line number in the source file.
COL_THREAD_ID | [ ] Output the current thread ID as a hexadecimal number.
COL_MSG | [*] Output the formatted message text.
COL_TSV | [ ] By default, the output format is CSV - with each field in quotes. If this flag is used, then the column separator will be a tab
COL_QUOTES | [ ] Put quotes around every field
COL_HEADERS | [*] For ms_file_logger, this will ouput column headers if the file is empty and for ms_stdout_logger the constructor will output this
COL_LOGGER_DEFAULTS | [ ] Default columns used by Matrix Science Applications, includes values marked with [*] above.

Constructor & Destructor Documentation

◆ ms_stdout_logger()

ms_stdout_logger ( unsigned int colsToOutput = ms_logger::COL_LOGGER_DEFAULTS )

Constructor.

Parameters
colsToOutput is used to specify the cols to include in the log and also the format

Member Function Documentation

◆ formatMessage()

std::string formatMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId
 | ) |  | const
 inherited

Returns a string with formatting based on the columns requested to be output.

Called by ms_stdout_logger::onLogMessage and ms_file_logger::onLogMessage to return a formatted string based on the ms_logger::LogOutputColumns_e flags returned by getColsToOutput().

This function can obviously also be called by any custom ms_logger

Parameters
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message (from MDRO)
Returns
the formatted string.

◆ getColsToOutput()

unsigned int getColsToOutput ( ) const
virtualinherited

Return the value which specifies which columns should be output by the logger.

The value returned is one or more ms_logger::LogOutputColumns_e values bitwise ORed together. formatMessage uses this value to determine which columns to return.

Returns
the value set in the constructor or by calling ms_logger::setColsToOutput

◆ getHeaderLine()

std::string getHeaderLine ( ) const
inherited

Returns the header line based on the specified column names.

Returns
a string that contains the column names

◆ onLogMessage()

void onLogMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId = 0
 | ) |  |
virtual

Logs the passed message directly to standard out.

Parameters
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message (from MDRO)

Implements ms_logger.

◆ setColsToOutput()

void setColsToOutput ( const unsigned int colsToOutput )
virtualinherited

Set the value to specify which columns should be output by the logger.

formatMessage uses this value to determine which columns to return.

Parameters
colsToOutput is formed by bitwise ORing one or more ms_logger::LogOutputColumns_e values
The documentation for this class was generated from the following files:
  • ms_logging.hpp
  • ms_logging.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Quantitation analysis for Mascot Server and Distiller

Modules | Classes
Quantitation analysis for Mascot Server and Distiller

Modules

Peptide and protein quantitation
Accessing Distiller Quantitation Results
Accessing Distiller Multi-file Quantitation Results
Extracting quantitation results with the Distiller toolkit
Source code for the Shapiro-Wilk W test algorithm
Examples for the Mascot Parser quantitation module

Classes

class | ms_customquantitation
Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings. More...
class | ms_distiller_data
Distiller project parameters. More...
class | ms_distiller_data_quant
The details of a Distiller search. More...
class | ms_distiller_data_search
The details of a Distiller search. More...
class | ms_distiller_master_project
Data for a Distiller master project, includes a list of the subprojects. More...
class | ms_distiller_master_search
The details of a Distiller multifile search. More...
class | ms_distiller_search_status
A Mascot search status from a Distiller project file. More...
class | ms_distiller_search_status_list
A list of Mascot search status values, typically stored in a Distiller project file. More...
class | ms_distiller_sub_project
The details of a Distiller multifile subproject. More...
class | ms_distiller_subsearch
The details of a Distiller multifile subsearch. More...
class | ms_fitexy_result
Parameters and results from least squares fit with errors in both co-ordinates. More...
class | ms_ms1quant_average_results
Results specific to an 'average' type quantitation method. More...
class | ms_ms1quant_charge_state
A result from a charge state calculation. More...
class | ms_ms1quant_match
A peptide that has been matched, in quantitation, to a protein hit. More...
class | ms_ms1quant_match_component
A component within a match. More...
class | ms_ms1quant_match_range
A range for a component of a peptide match. More...
class | ms_ms1quant_match_ratio
The status resulting ratio for a peptide found in a match. More...
class | ms_ms1quant_peptide_status
An individual peptide's quantitation status. More...
class | ms_ms1quant_time_align
Time alignment between multiple runs (raw files) is performed in Mascot Distiller for label free quantitation. More...
class | ms_ms1quant_time_align_limits
Limits for m/z and retention time. More...
class | ms_ms1quantitation
The result of quantitation calculations applied to peptide summary. More...
class | ms_ms2quantitation
Peptide and protein quantitation in a Reporter or Multiplex Mascot results file. More...
class | ms_peptide_quant_key
Feature key identifying a peptide ratio. More...
class | ms_peptide_quant_key_vector
A vector of peptide quant keys. More...
class | ms_peptide_quant_ratio
Peptide abundance in one component relative to another in a quantitation experiment. More...
class | ms_progress_info
Contains information of the current progress of a task being performed. More...
class | ms_protein_quant_ratio
Protein abundance in one component relative to another in a quantitation experiment, derived from a sample of peptide ratios. More...
class | ms_quant_helper
Helper routines for peptide quantitation. More...
class | ms_quant_stats
Mathematical and statistical routines for peptide and protein quantitation. More...
class | ms_quantitation
Base class for peptide and protein quantitation. More...
class | ms_shapiro_wilk
The Shapiro-Wilk W test. More...
class | ms_xic
An eXtracted Ion Chromatogram (XIC). More...
class | ms_xic_point
A single point from a matrix_science::ms_xic object. More...

Detailed Description

Classes for handling the quantitation configuration files are in Mascot configuration files module

The statistics modules are used for the quantitation functions in both Mascot server and Mascot Distiller.

Source code for the Shapiro-Wilk W test algorithm

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Peptide and protein quantitation

Peptide and protein quantitation
Quantitation analysis for Mascot Server and Distiller

Overview

Mascot Server (since version 2.2) supports five labelled and label-free quantitation protocols. The protocols are Reporter, Precursor, Multiplex, Replicate and Average, and they are described in full on the Matrix Science website. Reporter and Multiplex work off of reporter ions or fragment peaks in the MS/MS spectrum, which means peptide and protein ratios can be calculated directly from the results file. Precursor, Replicate and Average require additional information from the raw data file.

In Mascot 2.2, 2.3 and 2.4, quantitation ratios for Reporter and Multiplex were calculated by the Mascot report scripts. In Mascot 2.5, and Parser 2.5, the calculation has been integrated as part of the Parser results file interface. The interface has some support for Precursor, Replicate and Average quantitation data as well, although you will need to extract component intensities from the raw data first, for example using Mascot Distiller.

If the results file has been downloaded from the Mascot Server using the cgi/client.pl script with the result_file_mime2 parameter, then note that the results file will not contain the query sections that contain the ms-ms data, so it won't be possible to get quantitation ratios for reporter and multiplex data.

Mascot also supports the Exponentially Modified Protein Abundance Index (emPAI), which is an approximate, relative quantitation method based on protein sequence coverage. In Mascot 2.2, 2.3 and 2.4, emPAI calculation was part of the Mascot report scripts. In Mascot 2.5 and Parser 2.5, the calculation is implemented in ms_mascotresults::getProteinEmPAI(). Since emPAI uses only protein sequence coverage, not MS/MS or raw data, it is essentially "always on" when the search results contain enough input queries, and no special initialisation needs to be done. The rest of the document describes the five other quantitation protocols. Please refer to the documentation for ms_mascotresults::getProteinEmPAI() for more details on emPAI.

From Reporter or Multiplex results file to protein ratios: ms_ms2quantitation

Initialising quantitation data

If you have a Mascot results file with Reporter or Multiplex data, and you used the correct quantitation method when submitting the search, then it is straightforward to extract peptide and protein ratios from the file using ms_ms2quantitation. Open the results file using ms_mascotresfile and ms_peptidesummary as described in Getting protein information; let the objects be resfile and pepsum, respectively. The following example code extracts component intensities and calculate peptide ratios in a single step, using the default quantitation method parameters:

quant = msparser.ms_ms2quantitation(pepsum);

if not quant.isValid():
    # report quant.getLastErrorString()
    return

# Data is now available in quant

(Small examples such as the one above are given in Python. A more complete example is given in other programming languages at the end of the section.)

Data normalisation

ms_ms2quantitation supports three kinds of normalisation: the normalisation constants can be calculated from the set of all peptide ratios, a set of peptide sequences (peptide ratios associated with the sequences) or a set of protein accessions (peptide ratios associated with the accessions). The normalisation constant for each report ratio, say 115/114 in an iTRAQ file, is the median or geometric mean of the selected 115/114 peptide ratios.

Normalisation does not happen automatically, because it may require calculating peptide ratios for all peptide matches in the results file. If normalisation is configured, you can cause the normalisation constants to be computed using normalisePeptideRatios(). The individual normalisation constants can be read out with getPeptideRatioNormalisationBase(). Note that changing quantitation method parameters (especially normalisation settings) or editing report ratios will reset the normalisation constants, for consistency.

If normalisation is not configured, then normalisePeptideRatios() simply returns without doing anything. This means that normally you always want to call normalisePeptideRatios() after creating an ms_ms2quantitation object, just to ensure the values match the quantitation method configuration. This is what we do in the following code examples.

If you already know the normalisation constants, or if you want to use your own values, you can use setPeptideRatioNormalisationBase() and skip the potentially time-consuming computation.

ms_ms2quantitation has limited support for normalisation at component intensity level. If your data is Reporter, you can enable the "sum" normalisation in the quantitation method settings and call normaliseIntensities() to cause the intensity-level normalisation constants to be computed. The method is exactly analogous to normalisePeptideRatios(), so same caveats apply.

Data caching

ms_ms2quantitation supports caching, but does not create a cache file itself. If the results file is Reporter or Multiplex, and caching is enabled, then ms_mascotresults will automatically extract and cache component intensities in the results cache file. ms_ms2quantitation will then read component intensities directly from it.

If the results cache file was created by an older version of Parser without full quantitation support, or if caching isn't in use, then component intensities are extracted from spectra as they are needed. In this case, the larger the file, the longer the ms_ms2quantitation constructor will take to run; the class needs to load component intensities for all quantifiable peptide matches to enable ratio normalisation.

Component intensity values can be accessed directly using ms_mascotresults::getComponentIntensity() and ms_ms2quantitation::getComponentIntensities().

Accessing peptide and protein ratios

Once you have an ms_ms2quantitation object, you can access peptide and protein ratios using getPeptideRatio() and getProteinRatio(), respectively. The following example prints the ratios of hit 1:

qm = quant.getQuantitationMethod()
ratioNames = []

for i in range(qm.getNumberOfReportRatios()):
    r = qm.getReportRatioByNumber(i)
    ratioNames[i] = r.getName()

hit = pepsum.getHit(1)

print("%s :" % hit.getAccession())

for ratioName in ratioNames:
    r = quant.getProteinRatio(hit.getAccession(), hit.getDB(), ratioName)

    if r.isMissing():
        print("     %s = (undefined)" % r.getRatioName())
    else if r.isInfinite():
        print("     %s = infinite" % r.getRatioName())
    else:
        print("     %s = %s (n = %d stderr = %s)" % (r.getRatioName(), r.getValue(), r.getSampleSize(), r.getStandardError()))

You can access the component intensities of each peptide ratio with getComponentIntensities().

Changing quantitation method parameters

A number of parameters change how peptide and protein ratios are calculated. These are encapsulated in the quantitation method object, ms_quant_method.

In the default workflow above, quantitation method parameters are read directly from the results file using the default XML schema. Certain parameters can be changed after the ms_ms2quantitation object has been created. These are normalisation, outlier detection, protein ratio calculation and including or excluding particular peptide ratios from protein ratio calculation. For example, you can change outlier detection in the following way:

qo = msparser.ms_quant_outliers()
qo.setMethod("dixons")

quant.setQuantOutliers(qo)

Changes take effect immediately; for example, values from getProteinRatio() may change after changing outlier detection, as some peptides may be excluded from protein ratio calculation.

It is not possible to change peptide quality settings in this way. (Quality settings determine which input queries are read from the results file, and changing the settings after the fact would require re-reading the results file.) You can use the default quantitation method as base configuration, alter the peptide-level settings, and then give the new method as argument to the constructor as follows:

embeddedQm = resfile.getQuantitationMethod()

if not qm:
    # not a quant results file
    return

# Note that we must create a copy, as embeddedQm is supposed to be const:
qm = msparser.ms_quant_method(embeddedQm)

qm.getQuality().setMinPrecursorCharge(2)

quant = msparser.ms_ms2quantitation(pepsum, qm)

if not quant.isValid():
    # report quant.getLastErrorString()
    return

quant.normalisePeptideRatios()

You can alter nearly all quantitation method settings this way. There are only two exceptions:

  1. Protocol must be identical (you cannot open a Multiplex file with a Reporter method).
  2. Components must be identical (e.g. you cannot define a new reporter ion for iTRAQ results without re-searching the data).

Please refer to the quantitation configuration help for more details on quantitation method parameters and how they affect ratio calculation.

Nearly complete example of ms_ms2quantitation

The example below shows how you can create an ms_ms2quantitation object, then change the default parameters and print the report ratios of the first protein hit. The example is given in the four programming languages supported by Parser:

C++
    const ms_quant_method *embeddedQm = resfile.getQuantitationMethod();

    if (!embeddedQm) {
        // not a quant results file
        return;
    }

    ms_quant_method qm = *embeddedQm;

    // Change a peptide quality setting:
    qm.getQuality()->setMinPrecursorCharge(2);

    ms_ms2quantitation quant = ms_ms2quantitation(pepsum, qm);

    if (!quant.isValid()) {
        // report quant.getLastErrorString()
        return;
    }

    // Change a peptide ratio outlier setting (could be done before quant is
    // created):
    ms_quant_outliers qo = qm.getOutliers() ? qm.getOutliers() : ms_quant_outliers();
    qo.setMethod("dixons");

    quant.setQuantOutliers(qo);

    // Then normalise, if normalisation is enabled.
    quant.normalisePeptideRatios();

    const ms_quant_method *currentQm = quant.getQuantitationMethod();
    std::vector<std::string> ratioNames;

    for (int i = 0; i != currentQm->getNumberOfReportRatios(); i++) {
        const ms_quant_ratio *r = currentQm->getReportRatioByNumber(i);
        ratioNames.push_back(r->getName());
    }

    const ms_protein *hit = pepsum.getHit(1);

    std::cout << hit->getAccession() << ":" << std::endl;

    for (std::vector<std::string>::size_type i = 0; i != ratioNames.size(); i++) {
        ms_protein_quant_ratio r = quant.getProteinRatio(hit->getAccession(), hit->getDB(), ratioNames[i]);

        if (r.isMissing()) {
            std::cout << "    " << r.getRatioName() << " = (undefined)" << std::endl;
        } else if (r.isInfinite()) {
            std::cout << "    " << r.getRatioName() << " = infinite" << std::endl;
        } else {
            std::cout << "    " << r.getRatioName() << " = " << r.getValue()
                << " (n = " << r.getSampleSize() << " stderr = " << r.getStandardError() << ")"
                << std::endl;
        }
    }

Perl
    my $embeddedQm = $resfile->getQuantitationMethod();

    if (not $embeddedQm) {
        # not a quant results file
        return;
    }

    my $qm = new msparser::ms_quant_method($embeddedQm);

    # Change a peptide quality setting:
    $qm->getQuality()->setMinPrecursorCharge(2);

    my $quant = new ms_ms2quantitation($pepsum, $qm);

    if (not $quant->isValid()) {
        # report $quant->getLastErrorString()
        return;
    }

    # Change a peptide ratio outlier setting (could be done before quant is
    # created):
    my $qo = $qm->getOutliers() ? $qm->getOutliers() : new msparser::ms_quant_outliers();
    $qo->setMethod("dixons");

    $quant->setQuantOutliers($qo);

    # Then normalise, if normalisation is enabled.
    $quant->normalisePeptideRatios();

    my $currentQm = $quant->getQuantitationMethod();
    my @ratioNames = ();

    for my $i (0 .. $currentQm->getNumberOfReportRatios()-1) {
        my $r = $currentQm->getReportRatioByNumber($i);
        push @ratioNames, $r->getName();
    }

    my $hit = $pepsum->getHit(1);

    print $hit->getAccession(), ":\n";

    for my $ratioName (@ratioNames) {
        my $r = $quant->getProteinRatio($hit->getAccession(), $hit->getDB(), $ratioName);

        if ($r->isMissing()) {
            print "    ", $r->getRatioName(), " = (undefined)\n";
        } elsif ($r->isInfinite()) {
            print "    ", $r->getRatioName(), " = infinite\n";
        } else {
            print "    ", $r->getRatioName(), " = ", $r->getValue(),
                " (n = ", $r->getSampleSize(), " stderr = ", $r->getStandardError(), ")",
                "\n"
                ;
        }
    }

Java
    ms_quant_method embeddedQm = resfile.getQuantitationMethod();

    if (embeddedQm == null) {
        // not a quant results file
        return;
    }

    // Change a peptide quality setting:
    ms_quant_method qm = new ms_quant_method(embeddedQm);

    qm.getQuality().setMinPrecursorCharge(2);

    ms_ms2quantitation quant = new ms_ms2quantitation(pepsum, qm);

    if (!quant.isValid()) {
        // report quant.getLastErrorString()
        return;
    }

    // Change a peptide ratio outlier setting (could be done before quant is
    // created):
    ms_quant_outliers qo = qm.getOutliers() ? qm.getOutliers() : new ms_quant_outliers();
    qo.setMethod("dixons");

    quant.setQuantOutliers(qo);

    // Then normalise, if normalisation is enabled.
    quant.normalisePeptideRatios();

    ms_quant_method currentQm = quant.getQuantitationMethod();
    Vector<String> ratioNames;

    for (int i = 0; i != currentQm.getNumberOfReportRatios(); i++) {
        ms_quant_ratio r = currentQm.getReportRatioByNumber(i);
        ratioNames.add(r.getName());
    }

    ms_protein hit = pepsum.getHit(1);

    System.out.println(hit.getAccession() + ":");

    for (String ratioName: ratioNames) {
        ms_protein_quant_ratio r = quant.getProteinRatio(hit.getAccession(), hit.getDB(), ratioName);

        if (r.isMissing()) {
            System.out.println("    " + r.getRatioName() + " = (undefined)");
        } else if (r.isInfinite()) {
            System.out.println("    " + r.getRatioName() + " = infinite");
        } else {
            System.out.println("    " + r.getRatioName() + " = " + r.getValue()
                + " (n = " + r.getSampleSize() + " stderr = " + r.getStandardError() + ")"
            );
        }
    }
Python
    embeddedQm = resfile.getQuantitationMethod()

    if not embeddedQm:
        # not a quant results file
        return

    qm = msparser.ms_quant_method(embeddedQm)

    # Change a peptide quality setting:
    qm.getQuality().setMinPrecursorCharge(2)

    quant = msparser.ms_ms2quantitation(pepsum, qm)

    if not quant.isValid():
        # report quant.getLastErrorString()
        return

    # Change a peptide ratio outlier setting (could be done before quant is
    # created):
    qo = qm.getOutliers() ? qm.getOutliers() : msparser.ms_quant_outliers()
    qo.setMethod("dixons")

    quant.setQuantOutliers(qo)

    # Then normalise, if normalisation is enabled.
    quant.normalisePeptideRatios()

    currentQm = quant.getQuantitationMethod()
    ratioNames = []

    for i in range(currentQm.getNumberOfReportRatios()):
        r = currentQm.getReportRatioByNumber(i)
        ratioNames[i] = r.getName()

    hit = pepsum.getHit(1)

    print("%s:" % hit.getAccession())

    for ratioName in ratioNames:
        r = quant.getProteinRatio(hit.getAccession(), hit.getDB(), ratioName)

        if r.isMissing():
            print("     %s = (undefined)" % r.getRatioName())
        else if r.isInfinite():
            print("     %s = infinite" % r.getRatioName())
        else:
            print("     %s = %d (n= %d stderr = %s)" % (r.getRatioName(), r.getValue(), r.getSampleSize(), r.getStandardError()))
C#
    ms_quant_method embeddedQm = new ms_quant_method();
    bool bQuant = resfile.getQuantitationMethod(embeddedQm);

    if (!bQuant) {
        // not a quant results file
        return;
    }

    // Change a peptide quality setting:
    ms_quant_method qm = new ms_quant_method(embeddedQm);

    qm.getQuality().setMinPrecursorCharge(2);

    ms_ms2quantitation quant = new ms_ms2quantitation(pepsum, qm);

    if (!quant.isValid()) {
        // report quant.getLastErrorString()
        return;
    }

    // Change a peptide ratio outlier setting (could be done before quant is
    // created):
    ms_quant_outliers qo = qm.haveOutliers() ? qm.getOutliers() : new ms_quant_outliers();
    qo.setMethod("dixons");

    quant.setQuantOutliers(qo);

    // Then normalise, if normalisation is enabled.
    quant.normalisePeptideRatios();

    ms_quant_method currentQm = quant.getQuantitationMethod();
    List<string> ratioNames = new List<string>();

    for (int i = 0; i != currentQm.getNumberOfReportRatios(); i++) {
        ms_quant_ratio r = currentQm.getReportRatioByNumber(i);
        ratioNames.Add(r.getName());
    }

    ms_protein hit = pepsum.getHit(1);

    Console.WriteLine("{0}:", hit.getAccession());

    foreach (string ratioName in ratioNames) {
        ms_protein_quant_ratio r = quant.getProteinRatio(hit.getAccession(), hit.getDB(), ratioName);

        if (r.isMissing()) {
            Console.WriteLine("    {0} = (undefined)", r.getRatioName());
        } else {
            Console.WriteLine("    {0} = {1} (n = {0} stderr = {0})", r.getRatioName(), r.getValue(), r.getSampleSize(), r.getStandardError());
        }
    }

Combined results files and merging ratios

It is possible to use ms_ms2quantitation with combined results files, as long as all files have identical settings and search parameters. (They cannot be combined otherwise; see Combining multiple results files). After creating the ms_ms2quantitation object, you can change quantitation method settings and access peptide and protein ratios as above.

There is an additional problem, though: peptide ratio definitions may differ between files. For example, suppose you have combined two iTRAQ 4-plex results files. The first file contains ratios "115/114", "116/114" and "117/114", while the second one contains "114/115", "116/115" and "117/115" – that is, a different channel is used as the reference component.

What should happen now? The ms_ms2quantitation class merges together ratio definitions with the same name. Imagine peptide ratios arranged in a table such that a row contains the report ratios for a particular peptide (q,p), and the columns are the ratios themselves ("115/114", "116/114", "117/114"). Merging in this context simply means peptide ratios with the same name appear in the same column, regardless of which file it comes from. Since the ratio names differ between files, the combined table will have six columns. Peptides from the first file will have a null value for ratios defined in the second file, and vice versa.

A similar problem exists even when ratio names are identical. For example, "115/114" in the first file may be the control, while the control in the second file is actually "116/114".

The solution to the first problem is to redefine the report ratio formulas in the second file, while the second problem is solved by renaming the ratios (e.g. "Control" for "115/114" in the first file and "Control" for "116/114" in the second file). Both can be accomplished using ms_ms2quantitation::setCombinedReportRatio(). Report ratio definition changes take effect immediately; no recalculation needs to be done. After changing the ratios, getPeptideRatio() and getProteinRatio() will return values according to the new definitions. You can enumerate the combined list of ratio names using ms_ms2quantitation::getCombinedReportRatioNames().

Using other protocols: ms_customquantitation

From custom peptide ratios to protein ratios

If your results file uses the Precursor, Replicate or Average protocols, or if you have a custom protocol that doesn't fit neatly in any category, you can't use ms_ms2quantitation, because the class expects to extract Reporter or Multiplex component intensities from the MS/MS data. Precursor, Replicate and Average require data from the original raw file, and there is no mechanism to feed in the raw file in Parser.

If you need this level of functionality, you need to use e.g. Mascot Distiller. Mascot Distiller quantitation results from these protocols can be extracted using Mascot Parser, see Accessing Distiller Quantitation Results.

If you have calculated peptide ratios in some way (e.g. by extracting component intensities from XICs), then you can use ms_customquantitation, which is the sibling class to ms_ms2quantitation. The class shares much of the same interface. In particular, both classes implement the same protein ratio calculation and significance testing, while ms_customquantitation allows greater control over peptide ratios.

In Reporter and Multiplex protocols, each peptide ratio is associated with a single peptide match (MS/MS spectrum). This is not necessarily the case with other protocols, where the peptide ratio can be calculated from a combination of features. In custom quantitation, each peptide ratio is associated with a peptide quant key, which fully identifies the ratio. The peptide quant key can be, for example, the query and rank of an identified peptide (in Reporter and Multiplex) or it can be any unique string value.

You will need to define a mapping from protein accessions to peptide quant keys for protein ratio calculation purposes; that is, you need to define which peptide ratios should be used in calculating a protein ratio. When you call getProteinRatio(), the class will look up all unique peptide ratios associated with the peptide quant keys associated with the protein accession, and use that set of ratios to calculate the protein ratio (the algorithm is the same as in ms_ms2quantitation). For this to work, you also need to configure protein ratio calculation settings in the quantitation method, or define outlier, normalisation and other settings after creating the ms_customquantitation object.

Bird's eye view to ms_customquantitation

ms_customquantitation can be used in a number of ways, and the right way depends on problem context. An example is sketched out below, using Python-like pseudocode syntax:

qm = resfile.getQuantitationMethod(...);

if not qm:
    return;

qm.getNormalisation().setMethod("none");
qm.getOutliers().setMethod("none");
qm.setMinNumPeptides(2);
qm.setProteinRatioType("average");

quant = msparser.ms_customquantitation(qm);

if not quant.isValid():
    # report quant.getLastErrorString()
    return;

# Set normalisation constants here if needed:
#quant.setNormalisationBase(..., ...);

for (loop over some data):
    q = ...;
    p = ...;
    ratioName = ...;
    value = ...;
    key = msparser.ms_peptide_quant_key(q, p)
    r = msparser.ms_peptide_quant_ratio(key, ratioName, value);

    # Add peptide ratio:
    quant.addPeptideRatio(r);

    accession = ...;
    dbIdx = ...;

    # Push it to the protein-peptide mapping:
    quant.addPeptideQuantKey(accession, dbIdx, key);

If you have a Mascot results file and open it as ms_peptidesummary, you can give the object as a parameter to ms_customquantitation, which will initialise the peptide-protein mappings directly from the results file. This saves quite a bit of work, and you are still able to edit the mappings later. For example:

# This also pulls the quantitation method from the results file.
quant = msparser.ms_customquantitation(pepsum);

if not quant.isValid():
    # report quant.getLastErrorString()
    return;

# Alter default settings:

qo = msparser.ms_quant_outliers();
qo.setMethod("none");

quant.setQuantOutliers(qo);

quant.setMinNumPeptides(2);
quant.setProteinRatioType("average");

# Set normalisation constants here if needed:
#quant.setNormalisationBase(..., ...);

for (loop over some data):
    q = ...;
    p = ...;
    ratioName = ...;
    value = ...;
    key = msparser.ms_peptide_quant_key(q, p)
    r = msparser.ms_peptide_quant_ratio(q, p, ratioName, value);

    # No need to use addPeptideQuantKey() -- mapping is already there.

Peptide quality control

If you are using ms_customquantitation, you may need to determine whether a peptide match is worth quantitating (for example, it may not be a statistically significant match). The ms_quant_helper class provides two methods to this end. The process is as follows, assuming qm is a quantitation method object that defines both peptide quality settings and the components:

umodfile = msparser.ms_umod_configfile();

if (!resfile.getUnimod(umodfile, true)):
    # log reason
    return;

qhelp = msparser.ms_quant_helper(pepsum, qm, umodfile);

if (!qhelp.isValid()):
    # log reason
    return;

for (loop over queries q and ranks p to quantitate):
    (qres, reason) = qhelp.isPeptideQuantifiable(q, p)

    if qres != msparser.ms_quant_helper.PEPTIDE_IS_QUANTIFIABLE:
        # log reason and skip peptide
        continue;

    (qualres, reason) = qhelp.isPeptideQualityOK(q, p)

    if qualres != msparser.ms_quant_helper.PEPTIDE_QUALITY_IS_OK:
        # log reason and skip peptide
        continue;

    # Add additional tests here if needed; otherwise the peptide contains the
    # required modifications (if specified in this protocol) needed for
    # quantitation and passes the score thresholds (if defined in quality
    # settings), so it can be quantified.

Additional tests can be, for example, testing the peptide sequence for uniqueness with ms_mascotresults::isPeptideUnique().

Special case: Reporter and Multiplex - converting ms_ms2quantitation to ms_customquantitation

If you have an ms_ms2quantitation object, you can use it also as an argument to the constructor. The constructor will pull all quantitation method settings, peptide-protein mappings and peptide ratios from the object and store them internally. You can then edit the peptide ratios or peptide-protein mappings if needed. The constructor documentation gives more details.

Note that ms_customquantitation does not support caching of any kind, as it is very difficult to define what goes in the cache file and what does not. If you need to cache data, you can use ms_tinycdb to read and write cache files.

Special case: peptide and protein data in the Average protocol

The Average protocol differs from the other four. First of all, the concept of peptide ratio has no meaning in the protocol. Protein ratios are instead calculated directly from the top three (or top N) peptide intensities assigned to the protein hit.

Second, only one protein ratio type is supported: average. The average protein ratio type has special meaning when protocol is Average, in that the protein ratio is simply the sum of its top N peptide intensities, divided by the sum of the top N peptide intensities of a named reference protein. In other protocols, average means the geometric mean of peptide ratios.

Third, outlier testing has no meaning in the Average protocol. It is not possible to use any other setting for outlier removal than none.

We suggest the following workflow for using Average with ms_customquantitation:

  1. Create a fresh ms_customquantitation object with a quantitation method object configured for the Average protocol.
  2. Add all peptide intensities in ms_peptide_quant_ratio objects: let the single ratio name be "intensity" and its value simply the raw intensity.
  3. Add peptide-protein mappings, linking specific peptide quant keys with protein accessions.
  4. Use setAverageReferenceProtein() to select a protein accession as the reference protein, if one has not yet been set in the quantitation method.
  5. Read off protein ratios with getProteinRatio(), where the ratio name is "intensity". The values will be relative to the intensity of the reference protein, taking the configured reference amount into account.

Note that peptide and protein ratio normalisation is meaningless in the Average protocol.

Further protein ratio statistics

Statistical routines used by other quantitation classes are collected in ms_quant_stats. The class is used internally by ms_ms2quantitation and ms_customquantitation to determine peptide ratio outliers and calculate the protein ratio p-value and statistical significance. You can use the class to calculate protein ratios manually in the following way, assuming quant contains an ms_quantitation object or one of its child classes (ms_ms2quantitation, ms_customquantitation):

keys = quant.getPeptideQuantKeys(accession, dbIdx);
ratioName = ...; # the ratio we're interested in

rawRatios = [];

for i in range(0, keys.size()-1):
    if not quant.hasPeptideRatio(keys.get(i), ratioName):
        continue;

    r = quant.getPeptideRatio(keys.get(i), ratioName);

    if not r.isInfinite():
        rawRatios.append(r.getValue());

outlierIndices = msparser.ms_quant_stats.detectOutliers(rawRatios, "auto");

ratios = [];

for i in range(0, len(rawRatios)-1):
    is_outlier = false;

    for j in range(0, len(outlierIndices)-1):
        if i == outlierIndices[j]:
            is_outlier = true;
            break;

    if is_outlier:
        continue;

    ratios.append(rawRatios[i]);

median = msparser.ms_quant_stats.unsortedMedian(ratios);

logratios = msparser.ms_quant_stats.logTransform(ratios);
logmean = msparser.ms_quant_stats.arithmeticMean(logratios);
logstdev = msparser.ms_quant_stats.arithmeticStandardDeviation(logratios, logmean);
logstderr = msparser.ms_quant_stats.arithmeticStandardErrorOfMedian(logstdev, len(ratios));
stderr = exp(logstderr)

ms_quant_stats also contains functions for calculating the cumulative distribution function and critical values of a few commonly used distributions. Please consult the class documentation for more details.

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Accessing Distiller Quantitation Results

Accessing Distiller Quantitation Results
Quantitation analysis for Mascot Server and Distiller

Note: This describes the structure of a single-file project. Projects with multiple files have a different, more complex structure, see Accessing Distiller Multi-file Quantitation Results.

Single-file Quantitation Overview

Distiller stores its parameters and results in a Distiller project (.rov) file.

The project file has the same internal format as a .ZIP file. You can view the contents by opening it with a .ZIP file viewer (e.g. by renaming the file to have a .zip extension and opening as usual for a .ZIP file).

The data can also be extracted using the Mascot Distiller SDK (MDRO), see Distiller projects and the toolkit.

Project file streams

The project file contains a number of streams:

name | format | contents
mdro_search_status | XML | A search status list detailing all of the result sets in the project.
mdro_search_status+N | MIME | The Mascot results data to be used to construct a ms_mascotresfile. N is the id attribute from the search status.
rover_data | XML | The Distiller project parameters to be used to create a ms_distiller_data.
rover_data+(cac0+N) | MIME | The peptide summary cache to be used to construct a ms_peptidesummary. N is the id attribute from the search status.
rover_data+(1f40+M) | binary | The quantitation results file used to populate a ms_ms1quantitation. M is the projectStream attribute from the Distiller project.
rover_data+(bb8+M) | binary | The quantitation cache file used to populate a ms_ms1quantitation. M is the projectStream attribute from the Distiller project.

Distiller project parameters

The Distiller project parameters are held in the stream rover_data.

The stream name can be retrieved directly from ms_distiller_search_status.

std::string projectStreamName = matrix_science::ms_distiller_data::getDistillerProjectStreamName();

This data should be loaded into an ms_distiller_data.

matrix_science::ms_distiller_data distillerData;
std::string roverXmlFilename = zipExtractPath + projectStreamName;
bool optionsLoadedFomXmlOk = distillerData.loadXmlFile(mascotXmlSchemaFolder.c_str(), roverXmlFilename);

It contains a number of parameters required for the ms_peptidesummary and also a list of searches and a list of quantitation results. The schema for this is in distiller_data_1.xsd.

Search list

The search list is held in the stream mdro_search_status.

This list is in XML format. The schema for this XML is in the file mdro_search_status_1.xsd.

The search list is used to determine the id of the results file stream to be loaded (at XPath /mdroMascotSearchStatusStream/searchStatusList/searchStatus/@id ).

There are other attributes that may be of interest; for example the search task id and title.

ms_distiller_search_status_list can be used to parse the file.

std::string searchFilename = zipExtractPath + matrix_science::ms_distiller_search_status_list::getSearchStatusListStreamName();
matrix_science::ms_distiller_search_status_list searchList;
bool ok = searchList.loadXml(searchFilename);

The schema for this is in mdro_search_status_1.xsd.

Mascot results

The mascot results are held in the stream mdro_search_status+N, where N is the id of the search status; for example "mdro_search_status+1". If the id is greater than 9 then it is expressed in lower-case hexadecimal, e.g. an id of 13 would have a stream name of "mdro_search_status+d".

The results file stream name can be retrieved directly from the search status.

std::string resfileStreamName = searchList.getSearch(1).getResfileStreamName();

This file should be loaded by the ms_mascotresfile.

The cache files for the results and the peptide summary will be placed in a folder located in the temporary file folder specified to the ms_mascotresfile constructor. The name of this sub-folder varies with the last update time attribute of the results file and is determined at the time the ms_mascotresfile is constructed. These cache files are not deleted by Parser after creation. In order to discourage unnecessary disk usage by an ever expanding number of files, you should set the last-write-time of the results file. Distiller sets it to 00:00:00 1/1/2010.

time_t time = matrix_science::ms_distiller_data::distillerResfileTimestamp;
matrix_science::ms_fileutilities::setLastModificationTime(pathnameResfile.c_str(), time);

When creating the ms_mascotresfile, the cache should be enabled (to speed up access) and the timestamp within the cache file should be ignored (to avoid timezone issues, this does not affect generation of the folder used for cache files).

int resFileFlags = matrix_science::ms_mascotresfile::RESFILE_USE_CACHE
        | matrix_science::ms_mascotresfile::RESFILE_CACHE_IGNORE_DATE_CHANGE;
matrix_science::ms_mascotresfile * resfile = new matrix_science::ms_mascotresfile(
        pathnameResfile.c_str(),
        0, // keepAliveInterval
        "<!-- %d seconds -->\n", // keepAliveText
        resFileFlags,
        temporaryFileFolder.c_str(),
        mascotXmlSchemaFolder.c_str());

Peptide summary cache

The peptide summary loads a cache file in order to improve access times and ensure consistent results across different versions of Mascot Parser.

The same parameters, available from the Distiller project parameters, are used in the generation of the peptide summary cache filename as are used in the creation of the peptide summary itself, so the same values should be used when invoking each of the two functions.

This is stored in the project file, in the stream rover_data+cac0 + N where N is the id of the search from the search status list; for example "rover_data+cac1". The stream name can be retrieved from the search.

std::string summaryStreamName = searchList.getSearch(1).getPeptideSummaryCacheStreamName();

The peptide summary cache data should be copied to the correct file location for use.

std::string pathnameCachefile = matrix_science::ms_peptidesummary::getCacheFilename(
        *resfile,
        distillerData,
        1); // first search in the list

Once the peptide summary cache file has been copied into position, the peptide summary should be created using exactly the same parameters as were used to generate the filename.

matrix_science::ms_peptidesummary * peptideSummary = new matrix_science::ms_peptidesummary(
        *resfile,
        distillerData,
        1);

Quantitation results

The quantitation data is stored in two streams of the Distiller project file.

The stream number offset is obtained from the first ms_distiller_data_quant in the list in the ms_distiller_data. This offset is added to 3000 for the quantitation data stream number and to 8000 to get the cache stream number. These should then be converted to hexadecimal to give the actual names of the streams; for example, a streamNumber of 2 would give stream names of "rover_data+bba" and "rover_data+1f42".

The quantitation results stream names can be retrieved directly.

std::string cdbStreamName = distillerData.getQuant(1).getResultsStreamName();
std::string cacheStreamName = distillerData.getQuant(1).getCacheStreamName();

These files can then be used to create a ms_ms1quantitation. The quantitation method required for the constructor is available from the Distiller project parameters.

matrix_science::ms_quant_method quantMethod = distillerData.quantMethod;
matrix_science::ms_ms1quantitation quant(peptideSummary, quantMethod);
quant.loadCdbFile(zipExtractPath + cdbStreamName, zipExtractPath + cacheStreamName);
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Accessing Distiller Multi-file Quantitation Results

Accessing Distiller Multi-file Quantitation Results
Quantitation analysis for Mascot Server and Distiller

Note: This describes the structure of a multi-file project. Projects with a single file have a different, simpler structure, see Extracting quantitation results with the Distiller toolkit.

Multi-file Quantitation Overview

Distiller stores its results are stored in a Distiller project (.rov) file.

The project file is the same format as a .ZIP file. You can view the contents by opening it with a .ZIP file viewer.

The data can also be extracted using the Mascot Distiller SDK (MDRO), see Distiller projects and the toolkit.

Project and subproject files

The master file for the Distiller multi-file project contains references to the subprojects.

The subproject files are held in a sub-folder with a name formed by appending ".files" to the name of the master file (without the ".rov" extension). For example, the master project file "Triple2.rov" would have a subfolder called "Triple2.files", in the same folder as the master file, to hold the subproject files.

Master project file streams

The master project file contains a number of streams.

name | format | contents
rover_data+2 | XML | The master project containing lists of the subprojects, searches and sub-searches.
rover_data | XML | The Distiller project to be used to create a ms_distiller_data.
rover_data+(cac0+N) | MIME | The combined peptide summary cache to be used to construct a ms_peptidesummary. N is the id attribute from the search in the master project lists.
rover_data+(1f40+M) | binary | The combined quantitation results file used to poulate a ms_ms1quantitation. M is the projectStream attribute from the Distiller project.
rover_data+(bb8+M) | binary | The combined quantitation cache file used to poulate a ms_ms1quantitation. M is the projectStream attribute from the Distiller project.

subproject file streams

Each subproject file contains a number of streams.

name | format | contents
mdro_search_status | XML | A search status list of the search results in the subproject.
mdro_search_status+N | MIME | The Mascot search results to be used in the combined ms_mascotresfile. N is the id attribute from the search status.

Master project lists

The lists of subprojects and searches are held in XML format in the stream rover_data+2 of the master project file. The presence of this stream indicates that this is the master file for a multi-file project.

This stream holds the list of subprojects in the master project (at XPath /MasterProject/SubProject).

It also holds the id used to generate the name of the combined peptide summary cache stream (at XPath /MasterProject/Searches/Search/@id).

The name of the stream is available from ms_distiller_master_project.

std::string masterProjectStreamName = matrix_science::ms_distiller_master_project::getMasterProjectStreamName();

This data should be loaded into an ms_distiller_master_project.

matrix_science::ms_distiller_master_project masterProject;
masterProject.loadXmlFile(xmlSchemaDirectory, masterProjectPathname);

The schema for this is in distiller_master_project_1.xsd.

Distiller project parameters

The Distiller project parameters are held in the stream rover_data.

This data has the same format as that for single file Distiller project parameters.

Mascot results

The Mascot results are combined from the mdro_search_status+N stream from each of the subproject files, where N is the id from the search status in the subproject. Each subproject has its own Mascot results stream. See Search list and Mascot results for a single file Distiller project.

For a multi-file project, instead of creating a ms_mascotresfile for each subproject, the ms_mascotresfile is created from the Mascot results of each subproject in turn. The first subproject is used for the constructor and then the subsequent ones are each appended.

The last update time attribute of the first results file is used by Parser when determining the name of the subfolder used for the peptide summary cache file; see Mascot results.

std::vector<std::string> resfilePathnames;

... // extract subproject results files and poluate filenames

matrix_science::ms_mascotresfile * resfile = new matrix_science::ms_mascotresfile(
        resfilePathnames[0].c_str(),
        0, // keepAliveInterval
        "<!-- %d seconds -->\n", // keepAliveText
        matrix_science::ms_mascotresfile::RESFILE_NOFLAG,
        cacheDirectory.c_str(),
        xmlSchemaDirectory);
for (int iResult = 1; iResult < resfilePathnames.size(); ++iResult)
{
    resfile->appendResfile(resfilePathnames[iResult].c_str());
}

Combined peptide summary cache

The peptide summary cache for the combined results files is in the stream rover_data+cac0 + N of the master project file, where N is the id of the search from the master project; for example "rover_data+cac1".

The ms_distiller_master_project should be used to retrieve the name of the stream containing the combined peptide summary cache file.

std::string pepsumStreamName = masterProject.getSearch(1).getCombinedPeptideSummaryCacheStreamName();

The ms_distiller_data from the master project should be used for the settings when creating the peptide summary filename and again when creating the peptide summary.

std::string pepsumFilename = matrix_science::ms_peptidesummary::getCacheFilename(
        *resfile,
        distillerData,
        1); // first search in the list

The peptide summary cache data should be copied to the correct file location before constructing the peptide summary, see Peptide summary cache for a single file Distiller project.

matrix_science::ms_peptidesummary * peptideSummary = new matrix_science::ms_peptidesummary(
        *resfile,
        distillerData,
        1);

Quantitation results

The combined (from all subprojects) quantitation data is stored in two streams of the master project file.

The stream names are obtained from the ms_distiller_data of the master project file. This is the same as for a single file project, see the single file Quantitation results.

matrix_science::ms_quant_method quantMethod = distillerData.quantMethod;
matrix_science::ms_ms1quantitation quant(peptideSummary, quantMethod);
std::string cdbStreamName = distillerData.getQuant(1).getResultsStreamName();
std::string cacheStreamName = distillerData.getQuant(1).getCacheStreamName();

... // extract the streams

quant.loadCdbFile(zipExtractPath + cdbStreamName, zipExtractPath + cacheStreamName);
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Extracting quantitation results with the Distiller toolkit

Extracting quantitation results with the Distiller toolkit
Quantitation analysis for Mascot Server and Distiller

Distiller projects and the toolkit

The Distiller project file can be accessed using the Mascot Distiller SDK. This library includes files for opening and reading Distiller project files and raw spectrographic data files.

Note – This method of automatic extraction of data from a Distiller project (.rov) file requires the use of the Mascot Distiller SDK (MDRO). The Mascot Distiller SDK is a Windows-only product and is not included in the Mascot Parser Toolkit and is not free.

Project file and search status

All the Distiller data is stored in a project file. By default, this has a '.rov' file extention.

The project is accessed by first creating a project manager. The file is then opened to get a project interface.

mdroapi::IMDROProjectManagerPtr iProjectManager;
HRESULT hr = iProjectManager.CreateInstance( __uuidof(mdroapi::MDROProjectManager) );
mdroapi::IMDROProjectPtr iProject;
hr = iProjectManager->raw_Open(
        _bstr_t(rovfilePathname.c_str()),
        mdroapi::mdroProjectFlagReadOnly,
        vtMissing,
        &iProject );

This can then be used to access the collection of search statuses: The collection may contain multiple search statuses. The data streams for the Mascot results and the peptide summary are accessed using the search status.

mdroapi::IMascotSearchStatusCollectionPtr iSearchStatusCollection;
mdroapi::IMDROProjectIOStreamPtr ISearchStatusStm;
hr = iProject->raw_OpenStream(
        mdroapi::mdroProjectStmFlagRead,
        mdroapi::mdroProjectStmSearchStatus,
        vtMissing,
        &ISearchStatusStm );
hr = iSearchStatusCollection.CreateInstance( __uuidof(mdroapi::MascotSearchStatusCollection) );
hr = iSearchStatusCollection->LoadFromStream( ISearchStatusStm );
long sCount = iSearchStatusCollection->Count;
int searchIndex = 1; // select required search, usually only one
mdroapi::IMascotSearchStatusPtr iSearchStatus = iSearchStatusCollection->GetItem(searchIndex);

Mascot results

The search status summary stream is used to extract the mascot results. It should be saved to a file to be re-loaded by the ms_mascotresfile.

mdroapi::IMDROProjectIOStreamPtr iSummaryStm;
hr = iSearchStatus->raw_OpenSummaryStream(mdroapi::mdroProjectStmFlagRead, iProject, &iSummaryStm);
bool ok = SaveIoStreamToFile(iSummaryStm, pathnameResfile);
iSummaryStm->Close();

The cache files for the results and the peptide summary will be placed in a folder located in the temporary file folder specified to the ms_mascotresfile constructor. The name of this sub-folder varies with the last update time attribute of the results file. In order to discourage unnecessary disk usage by an ever expanding number of files, you should set the last-write-time of the results file. Distiller sets it to 00:00:00 1/1/2010.

time_t time = matrix_science::ms_distiller_data::distillerResfileTimestamp;
matrix_science::ms_fileutilities::setLastModificationTime(pathnameResfile.c_str(), time);

When creating the ms_mascotresfile, the cache should be enabled (to speed up access) and the timestamp within the cache file should be ignored (to avoid timezone issues, this does not affect generation of the folder used for cache files).

int resFileFlags = matrix_science::ms_mascotresfile::RESFILE_USE_CACHE
        | matrix_science::ms_mascotresfile::RESFILE_CACHE_IGNORE_DATE_CHANGE;
matrix_science::ms_mascotresfile * resfile = new matrix_science::ms_mascotresfile(
        pathnameResfile.c_str(),
        0, // keepAliveInterval
        "<!-- %d seconds -->\n", // keepAliveText
        resFileFlags,
        temporaryFileFolder.c_str(),
        mascotXmlSchemaFolder.c_str());

Distiller project

The project data shoud be loaded into an ms_distiller_data.

This contains the stream number offset used in the name of the quantitation results streams.

matrix_science::ms_distiller_data distillerData;
std::string roverXml = GetIoStreamString(iProject, mdroapi::mdroProjectStmRover, 0);
distillerData.loadXml(mascotXmlSchemaFolder.c_str(), roverXml);
int quantStreamNumber = distillerData.getQuant(1).getStreamNumber();

Peptide summary cache

The peptide summary loads a cache file in order to improve access times. The name of this cache file is dependent on the parameters passed to the constructor. A function is available from matrix_science::ms_peptidesummary to allow the name of the cache file to be determined in advance so that it can be created.

std::string pathnameCachefile = matrix_science::ms_peptidesummary::getCacheFilename(
        *resfile,
        distillerData,
        1); // first search in the list

mdroapi::IMDROProjectIOStreamPtr iCacheStm;
hr = iProject->raw_OpenStream(
        mdroapi::mdroProjectStmFlagRead,
        mdroapi::mdroProjectStmRover,
        _variant_t(0xCAC0 + iSearchStatus->StatusId),
        &iCacheStm );
SaveIoStreamToFile(iCacheStm, pathnameCachefile);
iCacheStm->Close();

matrix_science::ms_peptidesummary * peptideSummary = new matrix_science::ms_peptidesummary(
        *resfile,
        distillerData,
        1); // first search in the list

Quantitation results

The quantitation data is stored in two streams of the Distiller project file. These should be extracted and saved to temporary files. There is no special requirement on the naming of these files.

The stream number, within the project, is obtained from the dataset quantitation result information. There may be multiple quantitation results sets in the project, each with a different stream number. The stream number will not necessarily be the same as the index into the quantitation results sets.

const long QUANTRESULT_OFFSET = 3000;
const long QUANTRESULT_CACHE_OFFSET = 8000;
int quantStreamNumber = distillerData.getQuant(1).getStreamNumber();
mdroapi::IMDROProjectIOStreamPtr iStream;
hr = iProject->raw_OpenStream(
        mdroapi::mdroProjectStmFlagRead,
        mdroapi::mdroProjectStmRover,
        _variant_t(QUANTRESULT_OFFSET + quantStreamNumber),
        &iStream );
SaveIoStreamToFile(iStream, cdbFilename);
iStream->Close();
hr = iProject->raw_OpenStream(
        mdroapi::mdroProjectStmFlagRead,
        mdroapi::mdroProjectStmRover,
        _variant_t(QUANTRESULT_CACHE_OFFSET + quantStreamNumber),
        &iStream );
SaveIoStreamToFile(iStream, cacheFilename);
iStream->Close();

The quantitation method is available from the mascot results.

These files can then be used to create a ms_ms1quantitation.

matrix_science::ms_quant_method quantMethod;
resfile->getQuantitationMethod(&quantMethod);
matrix_science::ms_ms1quantitation quant(peptideSummary, quantMethod);
quant.loadCdbFile(cdbFilename, cacheFilename);

Reading a project stream

Reading the data of a Distiller stream is can be accomplished by repeatedly reading it in chunks into SAFEARRAY. The data can be concatentated in memory, if it is going to be small enough, or written to a file.

Saving to a string

std::string GetIoStreamString(mdroapi::IMDROProjectIOStreamPtr IDistillerStm)
{
    std::string data;
    stmobjapi::IByteStreamSignalPtr ISignal = IDistillerStm;
    ISignal->BeginStreamOp(stmobjapi::stmobjStreamOpFlagRead);
    SAFEARRAYBOUND safeArrayBounds[1] = { 1024 * 1024, 0 };
    SAFEARRAY * safeArray = SafeArrayCreate(VT_UI1, 1, safeArrayBounds);
    stmobjapi::IByteStreamIOPtr IInStream = IDistillerStm;
    while (true)
    {
        long readCount = IInStream->ReadBytes(&safeArray);
        if (readCount == 0)
        {
            break;
        }
        const void * readBytes = safeArray->pvData;
        data.append((const char *)readBytes, ((const char *)readBytes) + readCount);
    }
    ISignal->EndStreamOp(VARIANT_TRUE);
    SafeArrayDestroy(safeArray);
    return data;
}

Saving to a file

void SaveIoStreamToFile(mdroapi::IMDROProjectIOStreamPtr iDistillerStm, const std::string & filename)
{
    std::ofstream file;
    file.open(filename.c_str(), std::ios_base::out|std::ios_base::binary);
    stmobjapi::IByteStreamSignalPtr iSignal = iDistillerStream;
    iSignal->BeginStreamOp(stmobjapi::stmobjStreamOpFlagRead);
    SAFEARRAYBOUND safeArrayBounds[1] = { 1024 * 1024, 0 };
    SAFEARRAY * safeArray = SafeArrayCreate(VT_UI1, 1, safeArrayBounds);
    stmobjapi::IByteStreamIOPtr iInStream = iDistillerStream;
    while (true)
    {
        long readCount = iInStream->ReadBytes(&safeArray);
        if (readCount == 0)
        {
            break;
        }
        const char * readBytes = (const char *)safeArray->pvData;
        file.write(readBytes, readCount);
    }
    iSignal->EndStreamOp(VARIANT_TRUE);
    SafeArrayDestroy(safeArray);
    file.close();
}
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Source code for the Shapiro-Wilk W test algorithm

Source code for the Shapiro-Wilk W test algorithm
Quantitation analysis for Mascot Server and Distiller
/*
##############################################################################
# File: ms_shapiro_wilk.cpp #
# Mascot Parser toolkit #
# Source file for Shapiro-Wilk W test #
##############################################################################
# $Source$
# $Author$
# $Date$
# $Revision$
##############################################################################
*/
/*
##############################################################################
# Applied Statistics algorithms #
# #
# Translated and adapted from routines that originally appeared in the #
# Journal of the Royal Statistical Society Series C (Applied Statistics) #
# and made available through StatLib http://lib.stat.cmu.edu/ #
# #
# The implementation and source code for this algorithm is available as a #
# free download from http://www.matrixscience.com/msparser.html #
# to conform with the requirement that no fee is charged for their use #
##############################################################################
*/
// STDAFX.H includes windows.h, msparser.hpp and other commonly used headers
#include "stdafx.h"
#include <cmath>
#include <limits>
#include <algorithm>
using namespace matrix_science;
ms_shapiro_wilk::ms_shapiro_wilk()
:w_(0)
,pw_(0)
,ifault_(0)
{
}
ms_shapiro_wilk::ms_shapiro_wilk(std::deque<std::pair<size_t,double> > x,
long n,
long n1,
long n2)
:w_(0)
,pw_(0)
,ifault_(0)
{
swilk(false, x, n, n1, n2, a_, w_, pw_, ifault_);
}
ms_shapiro_wilk::~ms_shapiro_wilk()
{
}
double ms_shapiro_wilk::getResult() const
{
return w_;
}
double ms_shapiro_wilk::getPValue() const
{
return pw_;
}
double ms_shapiro_wilk::getErrorCode() const
{
return ifault_;
}
void ms_shapiro_wilk::appendSampleValue(double x) {
std::deque<std::pair<size_t,double> >::size_type idx = x_.size();
x_.push_back(std::make_pair(idx, x));
w_ = 0;
pw_ = 0;
ifault_ = 0;
}
void ms_shapiro_wilk::clearSampleValues() {
x_.clear();
w_ = 0;
pw_ = 0;
ifault_ = 0;
}
void ms_shapiro_wilk::calculate(long n, long n1, long n2) {
swilk(false, x_, n, n1, n2, a_, w_, pw_, ifault_);
}
void ms_shapiro_wilk::swilk(bool init,
std::deque<std::pair<size_t,double> > x,
long n,
long n1,
long n2,
std::deque<double> &a,
double &w,
double &pw,
int &ifault) {
/* Algorithm AS R94, Journal of the Royal Statistical Society Series C
* (Applied Statistics) vol. 44, no. 4, pp. 547-551 (1995).
*/
w = 0; // stop the behaviour change 'feature'
pw = 0;
ifault = 0;
/* Initialized data */
static const double zero = 0.0;
static const double one = 1.0;
static const double two = 2.0;
static const double three = 3.0;
static const double z90 = 1.2816;
static const double z95 = 1.6449;
static const double z99 = 2.3263;
static const double zm = 1.7509;
static const double zss = 0.56268;
static const double bf1 = 0.8378;
static const double xx90 = 0.556;
static const double xx95 = 0.622;
static const double sqrth = 0.70711;/* sqrt(1/2) = .7071068 */
static const double small_value = 1e-19;
static const double pi6 = 1.909859;
static const double stqr = 1.047198;
/* polynomial coefficients */
static const double g[2] = { -2.273,.459 };
static const double c1[6] = { 0.,.221157,-.147981,-2.07119, 4.434685, -2.706056 },
c2[6] = { 0.,.042981,-.293762,-1.752461,5.682633, -3.582633 };
static const double c3[4] = { .544,-.39978,.025054,-6.714e-4 };
static const double c4[4] = { 1.3822,-.77857,.062767,-.0020322 };
static const double c5[4] = { -1.5861,-.31082,-.083751,.0038915 };
static const double c6[3] = { -.4803,-.082676,.0030302 };
static const double c7[2] = { .164,.533 };
static const double c8[2] = { .1736,.315 };
static const double c9[2] = { .256,-.00635 };
/* System generated locals */
double r__1;
a.resize(n, 0.0);
/*
* Auxiliary routines : poly() {below}
*/
/* Local variables */
int i, j, ncens, i1, nn2;
double zbar, ssassx, summ2, ssumm2, gamma, delta, range;
double a1, a2, an, bf, ld, m, s, sa, xi, sx, xx, y, w1;
double fac, asa, an25, ssa, z90f, sax, zfm, z95f, zsd, z99f, rsn, ssx, xsx;
/* Parameter adjustments */
pw = 1.0;
ifault = 0;
if (w >= 0.0) {
w = 1.0;
}
an = (double) (n);
nn2 = n / 2;
if (n2 < nn2) {
ifault = 3;
return;
}
if (n < 3) {
ifault = 1;
return;
}
/* If INIT is false, calculate coefficients a[] for the test */
if (! (init)) {
if (n==3) {
a[0] = sqrth;
} else {
an25 = an + .25;
summ2 = zero;
for (i = 1; i <= n2; ++i) {
a[i-1] = (double) ppnd7((i - .375f) / an25, ifault);
if (ifault) {
ifault = 8;
return;
}
summ2 += (a[i-1] * a[i-1]);
}
summ2 *= two;
ssumm2 = std::sqrt(summ2);
rsn = one / std::sqrt(an);
a1 = poly(c1, 6, rsn) - a[0] / ssumm2;
/* Normalize a[] */
if (n > 5) {
i1 = 3;
a2 = -a[1] / ssumm2 + poly(c2, 6, rsn);
fac = std::sqrt((summ2 - two * a[0] * a[0] - two * a[1] * a[1])
/ (one - two * a1 * a1 - two * a2 * a2));
a[1] = a2;
} else {
i1 = 2;
fac = std::sqrt((summ2 - two * a[0] * a[0]) / ( one - two * a1 * a1));
}
a[0] = a1;
for (i = i1; i <= nn2; ++i) a[i-1] /= - fac;
}
init = true;
}
if (n1 < 3) {
ifault = 1;
return;
}
ncens = n - n1;
if (ncens < 0 || (ncens > 0 && n < 20)) {
ifault = 4;
return;
}
delta = (double) ncens / an;
if (delta > 0.8) {
ifault = 5;
return;
}
/* If W input as negative, calculate significance level of -W */
if (w < zero) {
w1 = 1. + w;
ifault = 0;
goto L70;
}
/* Check for zero range */
range = x[n1 - 1].second - x[0].second;
if (range < small_value) {
ifault = 6;
return;
}
/* Check for correct sort order on range - scaled X */
/* *ifault = 7; <-- a no-op, since it is set 0, below, in ANY CASE! */
ifault = 0;
xx = x[0].second / range;
sx = xx;
sa = -a[0];
j = n - 1;
for (i = 2; i <= n1; ++i) {
xi = x[i-1].second / range;
if (xx - xi > small_value) {
/* Fortran had: print *, "ANYTHING"
* but do NOT; it *does* happen with sorted x (on Intel GNU/linux):
* shapiro.test(c(-1.7, -1,-1,-.73,-.61,-.5,-.24, .45,.62,.81,1))
*/
ifault = 7;
return;
}
sx += xi;
if (i != j) sa += sign(1,i - j) * a[std::min(i,j)-1];
xx = xi;
--j;
}
if (n > 5000) {
ifault = 2;
}
/* Calculate W statistic as squared correlation
between data and coefficients */
sa /= n1;
sx /= n1;
ssa = ssx = sax = zero;
j = n;
for (i = 1; i <= n1; ++i, --j) {
if (i != j)
asa = sign(1,i - j) * a[std::min(i,j)-1] - sa;
else
asa = -sa;
xsx = x[i-1].second / range - sx;
ssa += asa * asa;
ssx += xsx * xsx;
sax += asa * xsx;
}
/* W1 equals (1-W) claculated to avoid excessive rounding error
for W very near 1 (a potential problem in very large samples) */
ssassx = std::sqrt(ssa * ssx);
w1 = (ssassx - sax) * (ssassx + sax) / (ssa * ssx);
L70:
w = 1. - w1;
/* Calculate significance level for W */
if (n == 3) {/* exact P value : */
pw = pi6 * (std::asin(std::sqrt(w)) - stqr);
return;
}
y = std::log(w1);
xx = std::log(an);
m = zero;
s = one;
if (n <= 11) {
gamma = poly(g, 2, an);
if (y >= gamma) {
pw = small_value;/* FIXME: rather use an even small_valueer value, or NA ? */
return;
}
y = -std::log(gamma - y);
m = poly(c3, 4, an);
s = std::exp(poly(c4, 4, an));
} else {/* n >= 12 */
m = poly(c5, 4, xx);
s = std::exp(poly(c6, 3, xx));
}
/*DBG printf("c(w1=%g, w=%g, y=%g, m=%g, s=%g)\n",w1,*w,y,m,s); */
if (ncens > 0) {/* <==> n > n1 */
/* Censoring by proportion NCENS/N.
Calculate mean and sd of normal equivalent deviate of W. */
ld = -std::log(delta);
bf = one + xx * bf1;
r__1 = pow(xx90, (double) xx);
z90f = z90 + bf * std::pow(poly(c7, 2, r__1), (double) ld);
r__1 = pow(xx95, (double) xx);
z95f = z95 + bf * std::pow(poly(c8, 2, r__1), (double) ld);
z99f = z99 + bf * std::pow(poly(c9, 2, xx), (double)ld);
/* Regress Z90F,...,Z99F on normal deviates Z90,...,Z99 to get
* pseudo-mean and pseudo-sd of z as the slope and intercept
*/
zfm = (z90f + z95f + z99f) / three;
zsd = (z90 * (z90f - zfm) +
z95 * (z95f - zfm) + z99 * (z99f - zfm)) / zss;
zbar = zfm - zsd * zm;
m += zbar * s;
s *= zsd;
}
pw = alnorm((y-m)/s, true);
/* = alnorm_(dble((Y - M)/S), 1); */
// Results are returned in w, pw and ifault
return;
} /* swilk */
double ms_shapiro_wilk::poly(const double *cc, int nord, double x)
{
/* Auxiliary procedure in algorithm AS 181, Journal of the Royal
* Statistical Society Series C (Applied Statistics) vol. 31, no. 2,
* pp. 176-180 (1982).
*/
/* Local variables */
int n2,j;
double ret_val = cc[0];
if (nord == 1) return ret_val;
double p = x * cc[nord-1];
if (nord != 2) {
n2 = nord - 2;
j = n2 + 1;
for (int i=1;i<=n2;i++) {
p = (p + cc[j-1])*x;
j--;
}
}
ret_val = ret_val + p;
return ret_val;
} /* poly */
double ms_shapiro_wilk::ppnd7(double p, int &ifault) {
/* Algorithm AS 241, Journal of the Royal Statistical Society Series C
* (Applied Statistics) vol. 26, no. 3, pp. 118-121 (1977).
*/
static const double zero = 0.0;
static const double one = 1.0;
static const double half = 0.5;
static const double split1 = 0.425;
static const double split2 = 5.0;
static const double const1 = 0.180625;
static const double const2 = 1.6;
static const double a0 = 3.3871327179E+00;
static const double a1 = 5.0434271938E+01;
static const double a2 = 1.5929113202E+02;
static const double a3 = 5.9109374720E+01;
static const double b1 = 1.7895169469E+01;
static const double b2 = 7.8757757664E+01;
static const double b3 = 6.7187563600E+01;
static const double c0 = 1.4234372777E+00;
static const double c1 = 2.7568153900E+00;
static const double c2 = 1.3067284816E+00;
static const double c3 = 1.7023821103E-01;
static const double d1 = 7.3700164250E-01;
static const double d2 = 1.2021132975E-01;
static const double e0 = 6.6579051150E+00;
static const double e1 = 3.0812263860E+00;
static const double e2 = 4.2868294337E-01;
static const double e3 = 1.7337203997E-02;
static const double f1 = 2.4197894225E-01;
static const double f2 = 1.2258202635E-02;
double normal_dev;
double q;
double r;
ifault = 0;
q = p - half;
if (std::abs(q) <= split1) {
r = const1 - q * q;
normal_dev = q * (((a3 * r + a2) * r + a1) * r + a0) /
(((b3 * r + b2) * r + b1) * r + one);
return normal_dev;
} else {
if (q < zero) {
r = p;
} else {
r = one - p;
}
if (r <= zero) {
ifault = 1;
normal_dev = zero;
return normal_dev;
}
r = std::sqrt(-std::log(r));
if (r <= split2) {
r = r - const2;
normal_dev = (((c3 * r + c2) * r + c1) * r + c0) / ((d2 * r + d1) * r + one);
} else {
r = r - split2;
normal_dev = (((e3 * r + e2) * r + e1) * r + e0) / ((f2 * r + f1) * r + one);
}
if (q < zero) { normal_dev = - normal_dev; }
return normal_dev;
}
}
double ms_shapiro_wilk::alnorm(double x,bool upper) {
/* Algorithm AS 66, Journal of the Royal Statistical Society Series C
* (Applied Statistics) vol. 22, pp. 424-427 (1973).
*/
static const double zero = 0;
static const double one = 1;
static const double half = 0.5;
static const double con = 1.28;
static const double ltone = 7.0;
static const double utzero = 18.66;
static const double p = 0.398942280444;
static const double q = 0.39990348504;
static const double r = 0.398942280385;
static const double a1 = 5.75885480458;
static const double a2 = 2.62433121679;
static const double a3 = 5.92885724438;
static const double b1 = -29.8213557807;
static const double b2 = 48.6959930692;
static const double c1 = -3.8052E-8;
static const double c2 = 3.98064794E-4;
static const double c3 = -0.151679116635;
static const double c4 = 4.8385912808;
static const double c5 = 0.742380924027;
static const double c6 = 3.99019417011;
static const double d1 = 1.00000615302;
static const double d2 = 1.98615381364;
static const double d3 = 5.29330324926;
static const double d4 = -15.1508972451;
static const double d5 = 30.789933034;
double alnorm;
double z;
double y;
bool up = upper;
z = x;
if (z < zero){
up = !up;
z = -z;
}
if (z <= ltone || (up && z <= utzero)) {
y = half * z * z;
if (z > con) {
alnorm = r * std::exp(-y) / (z + c1 + d1 / (z + c2 + d2 / (z + c3 + d3
/ (z + c4 + d4 / (z + c5 + d5 / (z + c6))))));
} else {
alnorm = half - z * (p - q * y/(y + a1 + b1 /(y + a2 + b2/(y + a3))));
}
} else {
alnorm = zero;
}
if(!up) { alnorm = one - alnorm; }
return alnorm;
}
long ms_shapiro_wilk::sign(long x,long y) {
if (y<0)
return -std::labs(x);
else
return std::labs(x);
}
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Examples for the Mascot Parser quantitation module

Examples for the Mascot Parser quantitation module
Quantitation analysis for Mascot Server and Distiller

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
Testing peptides for quantifiability | tools_quant_helper.pl |  |  | tools_quant_helper.py | tools_quant_helper.cs
For using statistical routines | tools_stats.pl |  |  | tools_stats.py | tools_stats.cs
For calculating the Shapiro-Wilk W test | tools_shapiro_wilk.pl |  |  | tools_shapiro_wilk.py | tools_shapiro_wilk.cs
Extracting peptide ratios from a Reporter or Multiplex file | resfile_ms2quantitation.pl | - | resfile_ms2quantitation.java | resfile_ms2quantitation.py | resfile_ms2quantitation.cs
Converting ms_ms2quantitation to ms_customquantitation | resfile_ms2quant_to_custom.pl | - | - | resfile_ms2quant_to_custom.py | resfile_ms2quant_to_custom.cs
Basic usage of ms_customquantitation | resfile_customquantitation.pl | - | resfile_customquantitation.java | resfile_customquantitation.py | resfile_customquantitation.cs
Usage of ms_ms1quant_time_align | - | - | - | display_quant_time_align.py | -
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_customquantitation Class Reference

  • matrix_science
  • ms_customquantitation
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ms_customquantitation Class Referenceabstract
Quantitation analysis for Mascot Server and Distiller

Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings. More...

#include <ms_customquantitation.hpp>

Inheritance diagram for ms_customquantitation:
[legend]
Collaboration diagram for ms_customquantitation:
[legend]

Public Member Functions

ms_customquantitation (const ms_ms2quantitation &copyFrom)
Given an ms_ms2quantitation object, copy the peptide-protein mappings, quantitation method and peptide ratios from it.
ms_customquantitation (const ms_peptidesummary &initFrom)
Given a results file, initialise peptide-protein mappings and the quantitation method from it.
ms_customquantitation (const ms_peptidesummary &initFrom, const ms_quant_method &qm)
Given a results file, initialise peptide-protein mappings from it, and prepare for data insertion using the given quantitation method.
ms_customquantitation (const ms_quant_method &qm)
Default constructor: given a quantitation method with protein ratio settings, prepare for data insertion.
virtual | ~ms_customquantitation ()
Destructor.
void | addHeaderField (const std::string &name, const std::string &value)
Adds an item of project or search header information.
void | addPeptideQuantKey (const std::string &accession, int dbIdx, const ms_peptide_quant_key &key)
Associate a protein accession with a peptide quant key.
void | addPeptideQuantKeys (const std::string &accession, int dbIdx, const ms_peptide_quant_key_vector &keys)
Associate a protein accession with particular peptide quant keys.
void | addPeptideQuantKeys (const std::string &accession, int dbIdx, const std::vector< ms_peptide_quant_key > &keys)
Associate a protein accession with particular peptide quant keys.
void | addPeptideRatio (const ms_peptide_quant_ratio &ratio)
Add a new peptide ratio.
void | addRawFileField (const unsigned int id, const std::string &name, const std::string &value)
Adds an item of raw file header information.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearHeaderFields ()
Clears any header information from the result.
void | clearPeptideQuantKeys (const std::string &accession, int dbIdx)
Clear all peptide quant key associations for a given protein.
void | clearPeptideRatios ()
Remove all peptide ratios.
void | clearRawFileFields ()
Clears any raw file header information from the result.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual int | countDistinctPeptides (const ms_peptide_quant_key_vector &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
virtual int | countDistinctPeptides (const std::vector< ms_peptide_quant_key > &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
ms_peptide_quant_key_vector | getPeptideQuantKeys (const std::string &accession, int dbIdx) const
Look up peptide quant keys associated with a given protein, if any.
virtual ms_peptide_quant_ratio | getPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Given peptide quant key and ratio name, return the corresponding peptide ratio data.
double | getPeptideRatioNormalisationBase (const std::string &ratioName) const
Get the peptide ratio normalisation base of the given ratio name.
const ms_progress_info & | getProgressInfo ()
Get information about the progress of a currently running long operation (e.g. loading from a file).
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName) const
Given the protein accession, database ID and ratio name, return the protein ratio data.
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const
Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.
const ms_quant_method & | getQuantitationMethod () const
Return the current quantitation method.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType) const
Calculate the unnormalised average peptide ratio.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType, const ms_peptide_quant_key_vector &keys) const
Calculate the unnormalised average of selected peptide quant keys.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType, const std::string &accession, int dbIdx) const
Calculate the unnormalised average of peptide quant keys of a protein accession.
virtual bool | hasPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.
virtual bool | isPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName) const
Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?
bool | isValid () const
Call this function to determine if there have been any errors.
void | removePeptideQuantKey (const std::string &accession, int dbIdx, const ms_peptide_quant_key &key)
Deassociate a peptide quant key from the given protein.
void | removePeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName)
Remove a particular peptide ratio.
void | removePeptideRatioNormalisationBase (const std::string &ratioName)
Reset the peptide ratio normalisation base of the given ratio name.
void | removePeptideRatioNormalisationBases ()
Reset all peptide ratio normalisation bases.
void | setMinNumPeptides (int value)
Set the minimum number of peptides needed for protein ratio calculation.
virtual void | setPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally exclude a particular peptide ratio from protein ratio calculation.
virtual void | setPeptideRatioIncluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally include a particular peptide ratio in protein ratio calculation.
void | setPeptideRatioNormalisationBase (const std::string &ratioName, double b)
Set the peptide ratio normalisation base of the given ratio name.
virtual void | setProteinRatioType (const char *value)
Set the protein ratio type.
virtual void | setQuantOutliers (const ms_quant_outliers *)
Set new peptide ratio outlier settings.

Protected Member Functions

ms_protein_quant_ratio | calculateGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the geometric mean and standard deviation.
ms_protein_quant_ratio | calculateMedianRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the median and standard deviation from the median.
ms_protein_quant_ratio | calculateWeightedGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.
int | getMinNumPeptides () const
Get the minimum number of peptides needed for protein ratio calculation.
void | getProteinRatioSample (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const
Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.
virtual void | getSortedFinitePeptideRatioValues (const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const
Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.
bool | initialiseBaseSettings (const ms_quant_method &qmBase, const ms_quant_method &qmConfig)
Initialise quantitation method settings from the two method objects.

Protected Attributes

protein_to_peptide_quant_key_t proteinKeys_
Protein-to-peptide mapping.

Detailed Description

Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings.

ms_customquantitation provides full read and write access to peptide ratios and protein-peptide mappings.

Protein ratios are calculated using the same algorithm as in ms_ms2quantitation. There are three types of ratio: median, average and weighted. Median is the median of all peptide ratios associated with the protein hit, and average is the geometric mean (equivalently, the arithmetic mean of log-transformed peptide ratios). Weighted is the weighted geometric mean. The weighting factor of each peptide ratio must be specified when the peptide ratio is added to the class, and it can not depend on which protein the peptide ratio is associated with.

Note that the weighted ratio type is not the same as in ms_ms2quantitation, where the weights are derived automatically from the input query. In ms_customquantitation, any peptide ratio can have any user-specified weighting factor.

Choosing the right constructor reduces the amount of work you need to do. There are three general use cases:

  1. You have a Mascot results file with Reporter or Multiplex data, and would like to have more control over peptide ratios: create an ms_ms2quantitation object and use ms_customquantitation(const ms_ms2quantitation&).
  2. You have a Mascot results file and need to use peptide ratios from an external source, or need to calculate ratios manually: use ms_customquantitation(const ms_peptidesummary&, const char*) or ms_customquantitation(const ms_peptidesummary&, const ms_quant_method&).
  3. You don't have a Mascot results file, or you want to start completely from scratch: use ms_customquantitation(const ms_quant_method&).

(In the third case, the quantitation method need not correspond to any method defined in a Mascot Server installation.)

The three use cases are listed in order of increasing amount of work you need to do before getProteinRatio() returns useful values. There are two main steps: adding peptide ratios (addPeptideRatio()) and creating protein-peptide mappings (addPeptideQuantKeys()). Both steps are done for you in use case 1, only the second step is done for you in use case 2, and neither is done in use case 3.

The protein-related methods take two arguments to identify the protein: accession and database index. If your protein accessions come from a Mascot results file, use the database index returned by ms_protein::getDB() as database index.

If your data comes from somewhere else (e.g. an mzIdentML file), you can use any suitable integer for database index, as long as you are consistent with your choice. For example, if you know that all of your accessions are unique, you can simply use 0 as the database index.

ms_customquantitation supports normalisation, but it is less automatic than in ms_ms2quantitation. Normalisation settings in the quantitation method are ignored. Instead, you can set the normalisation factor of each ratio name with setPeptideRatioNormalisationBase(), with which peptide ratios associated with that ratio name are divided before returned by getPeptideRatio() or used in protein ratio calculation. To this end, you can use getUnnormalisedAveragePeptideRatio() to compute the mean or median of a given set of peptide ratios, peptide ratios associated with a protein hit, or all peptide ratios currently stored in the object.

Constructor & Destructor Documentation

◆ ms_customquantitation() [1/4]

ms_customquantitation ( const ms_quant_method & qm )
explicit

Default constructor: given a quantitation method with protein ratio settings, prepare for data insertion.

The quantitation method does not need to contain protocol settings, component definitions or peptide quality settings. (This is different from ms_ms2quantitation.) Only the following settings will be used by this class:

  • Protein ratio type, minimum number of peptides.
  • Protein ratio normalisation settings.
  • Outlier settings.

If none of these settings are defined, sensible defaults are used: ratio type "median", minimum number of peptides 1, no normalisation or outlier detection.

Note that all normalisation settings are ignored, although the configuration is copied in the current quantitation method object. See setPeptideRatioNormalisationBase().

After the object has been created, you need to add peptide ratios and protein-peptide mappings before protein ratios can be calculated. See addPeptideRatio() and addPeptideQuantKey().

Using the Average protocol: If quantitation protocol is Average, neither outlier removal nor normalisation are supported. If either one is configured in the quantitation method object, the constructor will terminate with an error. Use isValid() after creating the object to check for an error condition.

Parameters
qm Full or partial quantitation method describing how protein ratios are to be calculated.

◆ ms_customquantitation() [2/4]

ms_customquantitation ( const ms_peptidesummary & initFrom )
explicit

Given a results file, initialise peptide-protein mappings and the quantitation method from it.

This is done in two steps. First, the following quantitation method settings are loaded from the results file, if available:

  • Protein ratio type, minimum number of peptides.
  • Protein ratio normalisation settings.
  • Outlier settings.

If none of these settings are available in the results file, sensible defaults are used: ratio type "median", minimum number of peptides 1, no normalisation or outlier detection.

Note that all normalisation settings are ignored, although the configuration is copied in the current quantitation method object. See setPeptideRatioNormalisationBase().

In the second step, the constructor iterates through all protein hits and creates a mapping from protein accessions to its peptide matches (peptide quant keys). After this, you need to add peptide ratios using addPeptideRatio(). Protein ratios can then be accessed with getProteinRatio().

Using the Average protocol: If quantitation protocol is Average, neither outlier removal nor normalisation are supported. If either one is configured in the embedded quantitation method object, the constructor will terminate with an error. Use isValid() after creating the object to check for an error condition.

Parameters
initFrom Mascot results to initialise from. Before creating the ms_peptidesummary object from the ms_mascotresfilebase object, call ms_mascotresfilebase::setXMLschemaFilePath() to set the locations of the XML schema to validate the embedded quantitation XML file against.

◆ ms_customquantitation() [3/4]

ms_customquantitation | ( | const ms_peptidesummary & | initFrom,
 |  | const ms_quant_method & | qm
 | ) |  |

Given a results file, initialise peptide-protein mappings from it, and prepare for data insertion using the given quantitation method.

The quantitation method does not need to contain protocol settings, component definitions or peptide quality settings. (This is different from ms_ms2quantitation.) Only the following settings will be used by this class:

  • Protein ratio type, minimum number of peptides.
  • Protein ratio normalisation settings.
  • Outlier settings.

If none of these settings are defined, sensible defaults are used: ratio type "median", minimum number of peptides 1, no normalisation or outlier detection.

Note that all normalisation settings are ignored. See setPeptideRatioNormalisationBase().

Note also that the protocol or component definitions of qm need not match those embedded in the results file, unlike in ms_ms2quantitation.

After initialising quantitation method settings, the constructor iterates through all protein hits and creates a mapping from protein accessions to its peptide matches (peptide quant keys). The peptide quant key for each peptide match is its q,p value; that is, the peptide quant keys are constructed with ms_peptide_quant_key(int q, int p).

You will need to add peptide ratios using addPeptideRatio(). Protein ratios can then be accessed with getProteinRatio().

Using the Average protocol: If quantitation protocol is Average, neither outlier removal nor normalisation are supported. If either one is configured in the quantitation method object, the constructor will terminate with an error. Use isValid() after creating the object to check for an error condition.

Parameters
initFrom | Mascot results file to initialise peptide-protein mappings from.
qm | Full or partial quantitation method describing how protein ratios are to be calculated.

◆ ms_customquantitation() [4/4]

ms_customquantitation ( const ms_ms2quantitation & copyFrom )
explicit

Given an ms_ms2quantitation object, copy the peptide-protein mappings, quantitation method and peptide ratios from it.

The full quantitation method will be copied, although only the following values will be used by this class:

  • Protein ratio type, minimum number of peptides.
  • Protein ratio normalisation settings.
  • Outlier settings.

If none of these settings are defined, sensible defaults are used: ratio type "median", minimum number of peptides 1, no normalisation or outlier detection.

Two things are copied over from copyFrom: protein-peptide mappings for all toplevel protein accessions, and peptide ratios for all peptide quant keys associated with a protein hit. This means peptide ratios in the unassigned list will not be copied over. Copying is followed by setting peptide ratio normalisation to the correct values. You can access and change the values with getPeptideRatioNormalisationBase() and setPeptideRatioNormalisationBase() afterwards.

The peptide ratio and protein-peptide mapping peptide quant keys are constructed using ms_peptide_quant_key(int q, int p), and protein ratios are identified by the same accessions and database indices as in the source object.

The protein ratio type has one difference. Both classes implement median and average in the same way, but the weighted ratio type differs. If copyFrom contains Reporter data and specifies a weighted protein ratio, then protein ratio type is reset to median and the weights are not copied over. You can alter peptide ratio weighting factors later by overwriting the existing one with addPeptideRatio().

If copyFrom is not valid (ms_ms2quantitation::isValid() returns false), then no data importing will take place, and it is as if you called the parameterless constructor ms_customquantitation().

Parameters
copyFrom Fully initialised ms_ms2quantitation object to copy data from.

Member Function Documentation

◆ addPeptideQuantKey()

void addPeptideQuantKey | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key & | key
 | ) |  |

Associate a protein accession with a peptide quant key.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

If key is already associated with this protein, no changes are made.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
key | Peptide quant key.

◆ addPeptideQuantKeys() [1/2]

void addPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key_vector & | keys
 | ) |  |

Associate a protein accession with particular peptide quant keys.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

Values in keys already associated with the protein are skipped.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
keys | Peptide quant keys.

◆ addPeptideQuantKeys() [2/2]

void addPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::vector< ms_peptide_quant_key > & | keys
 | ) |  |

Associate a protein accession with particular peptide quant keys.

Note
This method can only be used from C++. Use addPeptideQuantKeys(std::string, int, const ms_peptide_quant_key_vector) from other programming languages instead.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

Values in keys already associated with the protein are skipped.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
keys | Peptide quant keys.

◆ addPeptideRatio()

void addPeptideRatio ( const ms_peptide_quant_ratio & ratio )

Add a new peptide ratio.

If an existing peptide ratio exists with the same query, rank and ratio name as ratio.getQuery(), ratio.getRank() and ratio.getRatioName(), it will be replaced with the new data.

If ratio represents an undefined ("missing") value, the peptide ratio will be removed, as if you had called removePeptideRatio() instead.

Parameters
ratio Peptide ratio to add.

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ calculateGeometricMeanRatio()

ms_protein_quant_ratio calculateGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protectedinherited

Given a sample of peptide ratios, calculate the geometric mean and standard deviation.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.

◆ calculateMedianRatio()

ms_protein_quant_ratio calculateMedianRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protectedinherited

Given a sample of peptide ratios, calculate the median and standard deviation from the median.

See ms_quant_stats::sortedMedian for details of how this is calculated.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-values, if relevant.

◆ calculateWeightedGeometricMeanRatio()

ms_protein_quant_ratio calculateWeightedGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< double > & | weights,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protectedinherited

Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ clearPeptideQuantKeys()

void clearPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  |

Clear all peptide quant key associations for a given protein.

After this, getProteinRatio() will return a ratio with state isMissing() when given accession, dbIdx and any ratio name.

Parameters
accession | Protein accession.
dbIdx | Protein database index.

◆ clearPeptideRatios()

void clearPeptideRatios ( )

Remove all peptide ratios.

This method also removes all q,p aliases of peptide ratios. However, the peptide-protein mapping will not be changed.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ countDistinctPeptides() [1/2]

int countDistinctPeptides ( const ms_peptide_quant_key_vector & activeKeys ) const
virtualinherited

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

This function just calls countDistinctPeptides() relevant to the implementing class (ms_ms1quantitation or ms_ms2quantitation).

Parameters
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns
The number of distinct peptides.

Reimplemented in ms_ms1quantitation, and ms_ms2quantitation.

◆ countDistinctPeptides() [2/2]

int countDistinctPeptides ( const std::vector< ms_peptide_quant_key > & activeKeys ) const
virtualinherited

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

Parameters
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns
The number of distinct peptides.

Reimplemented in ms_ms1quantitation, ms_ms1quantitation, ms_ms2quantitation, and ms_ms2quantitation.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMinNumPeptides()

int getMinNumPeptides ( ) const
protectedinherited

Get the minimum number of peptides needed for protein ratio calculation.

Returns
The minimum number of peptides needed for protein ratio calculation.

◆ getPeptideQuantKeys()

ms_peptide_quant_key_vector getPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const
 inherited

Look up peptide quant keys associated with a given protein, if any.

In ms_ms2quantitation, the list of peptide quant keys associated with the given protein is immutable, as the keys are derived from q,p values in the Mascot results file. The list does not contain all q,p values, but only those that 1) have component intensities and 2) pass the quality thresholds. Unless the data quality is extremely good, this list will always have fewer elements than the actual peptide matches assigned to the protein hit.

In ms_customquantitation, the peptide-to-protein mapping can be altered with ms_customquantitation::addPeptideQuantKey() and ms_customquantitation::removePeptideQuantKey().

Parameters
accession | The protein accession.
dbIdx | The protein database index.
Returns
A vector of peptide quant keys associated with the protein.

◆ getPeptideRatio()

ms_peptide_quant_ratio getPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 virtual

Given peptide quant key and ratio name, return the corresponding peptide ratio data.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

If hasPeptideRatio(const ms_peptide_quant_key&, std::string) const returns false for the given peptide quant key and ratio name, then the peptide ratio object returned by this method represents an undefined ("missing") value.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
The peptide ratio. If hasPeptideRatio() returns false, the field values of the object returned by this method are undefined.

Implements ms_quantitation.

◆ getPeptideRatioNormalisationBase()

double getPeptideRatioNormalisationBase ( const std::string & ratioName ) const
inherited

Get the peptide ratio normalisation base of the given ratio name.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters
ratioName Peptide ratio name.
Returns
The current peptide ratio normalisation base, or 1 if it hasn't been set.

◆ getProgressInfo()

const matrix_science::ms_progress_info & getProgressInfo ( )
inherited

Get information about the progress of a currently running long operation (e.g. loading from a file).

Returns
Progress information about the most recent long operation.

◆ getProteinRatio() [1/2]

ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName
 | ) |  | const
 virtual

Given the protein accession, database ID and ratio name, return the protein ratio data.

Protein ratios are calculated on demand from the current protein-peptide mapping using the current quantitation method and taking peptide exclusion into account. You can exclude peptides from protein ratio calculation by using setPeptideRatioExcluded(). The current outlier detection method may also change which peptide ratios are used for any given protein.

For ms_ms2quantitation, the protein-peptide mapping is immutable. There are three types of protein ratio, which can be changed with setProteinRatioType(): median, average and weighted. Median is the median of all peptide ratios associated with the protein hit, and average is the geometric mean (equivalently, the arithmetic mean of log-transformed peptide ratios). Weighted is a weighted mean of peptide ratios, where the weights are channel intensities. The weighted ratio type is only available for Reporter data.

For ms_customquantitation, you can change the protein-peptide mapping by associating different peptide quant keys with the protein accession; see ms_customquantitation::addPeptideQuantKey() for details. There are three types of protein ratio: median, average and weighted. Median and average are the same as in ms_ms2quantitation, except in the Average protocol (see below). Weighted is the weighted geometric mean, where the weighting factor of each peptide ratio must be specified when the peptide ratio is added to the class. This is not the same weighting as in ms_ms2quantitation.

ms1, ms2 and custom protein ratios are calculated using:

  • median - See ms_quant_stats::sortedMedian
  • average - See ms_quant_stats::geometricMean
  • weighted - See ms_quant_stats::weightedArithmeticMean

It is possible for the protein ratio to be undefined ("missing") even when it has associated peptide ratios, if there are not enough peptide ratios (setMinNumPeptides()), if all of them are marked excluded, or if too many of them are infinite.

If quantitation protocol is Reporter, Multiplex, Replicate or Precursor, the returned protein ratio object contains two p-values: the normality test value and the null hypothesis value.

The log-transformed peptide ratios are assumed normally distributed, and this hypothesis is tested using the Shapiro-Wilk W test. The normality p-value is -1 when the test could not be run (e.g. too few peptide ratios) and otherwise a positive number between 0 and 1. In the latter case, a value of less than 0.05 (or similar threshold) is usually taken as evidence that the log-transformed peptide ratios are not normally distributed, or equivalently that the peptide ratios are not log-normally distributed.

If outlier removal is configured, then outliers will be removed before normality testing. If this makes the normality p-value fall below 0.05, then the outliers will be restored. In this case the original sample was likely not normal to start with, and the normality p-value is calculated based on the original sample. If outlier removal is successful, then the normality p-value is based on the sample from which outliers have been removed, and it always exceeds 0.05.

The second p-value is for the null hypothesis. The null hypothesis is that the protein ratio equals 1.0 (component intensities have equal values). The p-value is -1 if there is only one peptide ratio, and otherwise a positive number between 0 and 1. The test is conducted after outlier removal, if any.

Note that the hypothesis test is done regardless of the p-value of the normality test. This means that you need to decide first if you accept peptide ratio normality before deciding whether to reject or not reject the null hypothesis. If normality is violated, then the hypothesis p-value is meaningless.

You can inspect which peptide quant keys were used in protein ratio calculation and which were ignored, due to being excluded or being outliers, with ms_protein_quant_ratio::getActiveKeys(), ms_protein_quant_ratio::getExcludedKeys() and ms_protein_quant_ratio::getOutlierKeys(). You can "move" peptide quant keys between the last two categories and the first by using the method getProteinRatio(const std::string &, int, const std::string &, const ms_peptide_quant_key_vector &, const ms_peptide_quant_key_vector &) const.

Note about weighted protein ratios: Parser 2.5 and 2.6 do not calculate the standard deviation, standard error or p-values when protein ratio type is weighted in Reporter data. The values are set to -1 ("unavailable"); see ms_protein_quant_ratio::getStandardDeviation(). The values are available in ms_customquantitation, which uses a different weighting formula.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, the only supported protein ratio type is "average", which does not mean a geometric average. Rather, the protein ratio is the sum of the "top N" peptide intensities, divided by the sum of the top N peptide intensities of the reference protein (see ms_customquantitation::setAverageReferenceProtein()). Neither outlier removal nor normalisation have any meaning in this protocol, which means no significance tests are done and the returned protein ratio object will not contain any p-values.

For more details on configuring other aspects of protein ratio calculation, please consult the quantitation help pages.

Parameters
accession | The protein accession.
dbIdx | The protein database index.
ratioName | The name of the ratio.
Returns
The protein ratio as calculated from peptide ratios associated with this protein accession. If the ratio could not be calculated (e.g. there are no associated peptide ratios), then the returned object will represent an undefined ("missing") value.

Implements ms_quantitation.

Reimplemented in ms_ms1quantitation.

◆ getProteinRatio() [2/2]

ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | includeKeys,
 |  | const ms_peptide_quant_key_vector & | excludeKeys
 | ) |  | const
 virtual

Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.

The protein ratio is calculated as described in getProteinRatio(const std::string &, int, const std::string &) const, but the two peptide quant key vectors includeKeys and excludeKeys can be used to override default decisions about globally excluded and outlier peptide ratios. The rules are as follows:

  1. If a peptide quant key is globally excluded with setPeptideRatioExcluded(), then giving the peptide quant key in includeKeys causes the peptide quant key to be included regardless ("undo global exclusion").
  2. If a peptide quant key is given in excludeKeys, then the peptide quant key will be always excluded ("exclude locally").

If the peptide quant key is in both includeKeys and excludeKeys, the latter takes precedence and the peptide quant key is excluded.

Note that if outlier detection is enabled, then a peptide quant key determined to be an outlier cannot be included back using includeKeys, i.e. the inclusion mechanism does not undo outlier removal. You can disable outlier removal entirely before calling getProteinRatio() if you do not want peptide quant keys to be removed.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, then the effect of excludeKeys depends on whether the peptide quant key describes a "top N" peptide intensity. If the peptide intensity is one of the top N intensities assigned to this protein, then excluding it means the next highest outside the top N intensities will take its place. No peptide quant keys will ever be excluded automatically as outliers, since outlier removal has no meaning in this protocol.

Parameters
accession | The protein accession.
dbIdx | The protein database index.
ratioName | The name of the ratio.
includeKeys | Peptide quant keys to always include, even if they are globally excluded or would be marked as outliers.
excludeKeys | Peptide quant keys to always exclude, even if they are not outliers.
Returns
The protein ratio as calculated from peptide ratios associated with this protein accession. If the ratio could not be calculated (e.g. there are no associated peptide ratios), then the returned object will represent an undefined ("missing") value.

Implements ms_quantitation.

Reimplemented in ms_ms1quantitation.

◆ getProteinRatioSample()

void getProteinRatioSample | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< ms_peptide_quant_key > & | includeKeys,
 |  | const std::vector< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | sample,
 |  | std::vector< double > & | logSample,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double & | normalityPvalue
 | ) |  | const
 protectedinherited

Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.

This method uses getSortedFinitePeptideRatioValues() internally to collect the vector of peptide ratios. If there are no peptide quant keys associated with the protein, or if no peptide ratios are associated with with those peptide quant keys, then sample, logSample, activeKeys and inactiveKeys will be empty and normalityPvalue will have an undefined value.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
ratioName | Name of the ratio.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
sample | Peptide ratios associated with ratioName and the protein's peptide quant keys, in numerically increasing order.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
activeKeys | Peptide quant keys corresponding to the order of sample (and logSample).
inactiveKeys | Peptide quant keys marked as skipped, excluded or outlier.
normalityPvalue | The p-value that the sample appears to be normally distributed after outlier removal. If less than 0.05, no outliers will have been removed.

◆ getQuantitationMethod()

const ms_quant_method & getQuantitationMethod ( ) const
inherited

Return the current quantitation method.

The current (or effective) quantitation method is the original quantitation method given as argument to the constructor (or loaded from the Mascot results file), with possible later modifications, such as changing normalisation or outlier settings.

For ms_ms2quantitation, you cannot change the protocol settings, component definitions or peptide quality settings. You must create a new object with the new settings instead. You are free to change how protein ratios are calculated and set new normalisation parameters. These changes will be reflected in this method's output value.

For ms_customquantitation, same restrictions apply, although it makes little difference, as the class does not use any protocol settings, component definitions or peptide quality settings.

Returns
The current quantitation method.

◆ getSortedFinitePeptideRatioValues()

void getSortedFinitePeptideRatioValues | ( | const std::string & | ratioName,
 |  | const std::set< ms_peptide_quant_key > & | keys,
 |  | const std::set< ms_peptide_quant_key > & | includeKeys,
 |  | const std::set< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | values,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys
 | ) |  | const
 protectedvirtual

Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.

The method looks up all peptide ratios associated with keys (ignoring duplicates) and returns them in numerically increasing order in values. Infinite and missing ratios are ignored. The vector activeKeys contains active peptide quant keys in the same order as values, and the map inactiveKeys contains peptide quant keys associated with the protein ratio but for indicated reasons not included in ratio calculation.

Parameters
ratioName | The name of the peptide ratio.
keys | A list of (sorted or unsorted) peptide quant keys for which to look up the ratios.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
values | Peptide ratios associated with ratioName and the given peptide quant keys.
weights | Weighting factors of corresponding to the order of values.
activeKeys | Peptide quant keys corresponding to the order of values.
inactiveKeys | Peptide quant keys skipped or excluded.

Implements ms_quantitation.

◆ getUnnormalisedAveragePeptideRatio() [1/3]

double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType
 | ) |  | const

Calculate the unnormalised average peptide ratio.

All peptide ratios currently stored in the object are used in calculation. If there are no peptide ratios associated with the ratio name, the method returns 1.0. Negative and infinite values are ignored.

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
Returns
The average of all peptide ratios currently stored in the object, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.

◆ getUnnormalisedAveragePeptideRatio() [2/3]

double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType,
 |  | const ms_peptide_quant_key_vector & | keys
 | ) |  | const

Calculate the unnormalised average of selected peptide quant keys.

All peptide ratios matching ratioName and whose peptide quant key is in keys are chosen for calculation. If there are no such peptide ratios, the method returns 1.0. Negative and infinite values are ignored.

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
keys | Peptide quant keys of peptide ratios to use in calculation.
Returns
The average of all selected peptide ratios, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.

◆ getUnnormalisedAveragePeptideRatio() [3/3]

double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType,
 |  | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const

Calculate the unnormalised average of peptide quant keys of a protein accession.

All peptide ratios matching ratioName and associated with the protein accession and database index are chosen for calculation. If there are no such peptide ratios, the method returns 1.0. Negative and infinite values are ignored. You can alter the protein-peptide mapping with addPeptideQuantKey().

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
accession | Protein accession.
dbIdx | Protein database index.
Returns
The average of all selected peptide ratios, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.

◆ hasPeptideRatio()

bool hasPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 virtual

Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
True if the peptide ratio exists; false otherwise.

Implements ms_quantitation.

◆ initialiseBaseSettings()

bool initialiseBaseSettings | ( | const ms_quant_method & | qmBase,
 |  | const ms_quant_method & | qmConfig
 | ) |  |
protectedinherited

Initialise quantitation method settings from the two method objects.

For any method settings which are not consistent between the passed qmBase and qmConfig, the values from qmConfig will be used.

Parameters
qmBase | The base quantitation method as defined on the Mascot server.
qmConfig | The quantitation method to use to calculate quantitation results using.
Returns
True.

◆ isPeptideRatioExcluded()

bool isPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 virtual

Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?

(This method is redundant; you could also look up the peptide ratio and use ms_peptide_quant_ratio::isExcluded().)

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
True if the peptide ratio should be excluded from protein ratio calculation; false otherwise.

Implements ms_quantitation.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ removePeptideQuantKey()

void removePeptideQuantKey | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key & | key
 | ) |  |

Deassociate a peptide quant key from the given protein.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
key | Peptide quant key.

◆ removePeptideRatio()

void removePeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |

Remove a particular peptide ratio.

However, the protein-peptide mapping related to the peptide quant key will not be changed.

Parameters
key | Peptide quant key.
ratioName | Ratio name.

◆ removePeptideRatioNormalisationBase()

void removePeptideRatioNormalisationBase ( const std::string & ratioName )
inherited

Reset the peptide ratio normalisation base of the given ratio name.

Resetting means the report ratio normalisation constant is set to 1.0. This has the same effect as calling setPeptideRatioNormalisationBase() with b = 1.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

Parameters
ratioName Ratio name whose normalisation base is to be reset.

◆ removePeptideRatioNormalisationBases()

void removePeptideRatioNormalisationBases ( )
inherited

Reset all peptide ratio normalisation bases.

Resetting all report ratio normalisation bases means all peptide and protein ratios become unnormalised.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

◆ setMinNumPeptides()

void setMinNumPeptides ( int value )
inherited

Set the minimum number of peptides needed for protein ratio calculation.

Changing the minimum number of peptides changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: The Average protocol has two settings for minimum number of peptides. This setting defines how many peptide intensities are needed for a protein before its ratio can be calculated. It is usually meaningless to choose a value other than 1. Use ms_customquantitation::setAverageNumPeptides() to define how many intensities should be used in protein ratio calculation.

Parameters
value The minimum number of peptide ratios (the sample size) a protein must have for protein ratio calculation purposes. Values less than 1 are interpreted as 1.

◆ setPeptideRatioExcluded()

void setPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |
virtual

Globally exclude a particular peptide ratio from protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

◆ setPeptideRatioIncluded()

void setPeptideRatioIncluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |
virtual

Globally include a particular peptide ratio in protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

◆ setPeptideRatioNormalisationBase()

void setPeptideRatioNormalisationBase | ( | const std::string & | ratioName,
 |  | double | b
 | ) |  |
inherited

Set the peptide ratio normalisation base of the given ratio name.

Setting peptide ratio normalisation to a particular value means all peptide ratios with ratioName will be divided by b before they are returned by getPeptideRatio(). That is, the underlying peptide ratios remain unaffected, which means this method will always return immediately without computing anything.

In ms_ms2quantitation, normalisation constants can most easily be calculated with ms_ms2quantitation::normalisePeptideRatios(), if normalisation is enabled and configured in the quantitation method. You are free to override this, but keeping track of who calculated which constant is up to you.

It is not a good idea to define both peptide ratio normalisation and component intensity normalisation at the same time. In fact, you can only configure one or the other using setQuantNormalisation(), and neither normalisePeptideRatios() nor normaliseIntensities() will step on each other's toes.

It is possible, but not recommended, to manually set normalisation bases for both peptide ratios and component intensities. The resulting peptide ratios are most likely meaningless.

In ms_customquantitation, you can use ms_customquantitation::getUnnormalisedAveragePeptideRatio() to calculate the mean or median of peptide ratios currently stored in the class, for normalisation purposes.

You can always set b to 1 to disable peptide ratio ratioName normalisation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters
ratioName | Peptide ratio name to normalise.
b | New normalisation base. If it is zero, the old base will be kept. If this is the first time the base is set, a value of 0 means it is set to 1.0.

◆ setProteinRatioType()

void setProteinRatioType ( const char * value )
virtual

Set the protein ratio type.

Changing the protein ratio type changes the current quantitation method. It does not alter the original quantitation method object.

ms_ms2quantitation supports "median", "average" and "weighted", and ms_customquantitation supports "median" and "average. If the ratio type is not implemented, it is set to "median". <strong>Using the Average protocol in ms_customquantitation</strong>: If quantitation protocol is Average, the only supported protein ratio type is "average". Setting it to anything else will result in an error. You should inspect isValid() and use clearAllErrors() should you accidentally do so.

Parameters
value Protein ratio type (e.g. median, average, weighted). Accepted values are defined in the quantitation XML schema.

Implements ms_quantitation.

◆ setQuantOutliers()

void setQuantOutliers ( const ms_quant_outliers * qo )
virtual

Set new peptide ratio outlier settings.

Peptide ratio outlier detection can be configured in several ways. Please consult the quantitation configuration help page for details.

Changing outlier settings changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: It is an error to define outlier removal if quantitation protocol is Average. You will need to inspect isValid() and clear the error with clearAllErrors() should you accidentally do so.

Parameters
qo An outlier configuration object. If this is NULL, outlier detection will be disabled (equivalent to "none").

Implements ms_quantitation.

The documentation for this class was generated from the following files:
  • ms_customquantitation.hpp
  • ms_customquantitation.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_data Class Reference

  • matrix_science
  • ms_distiller_data
Public Member Functions | Static Public Member Functions | List of all members
ms_distiller_data Class Reference
Quantitation analysis for Mascot Server and Distiller

Distiller project parameters. More...

#include <ms_distiller_data.hpp>

Inheritance diagram for ms_distiller_data:
[legend]
Collaboration diagram for ms_distiller_data:
[legend]

Public Member Functions

ms_distiller_data (const ms_distiller_data &copy)
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_distiller_data *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual ms_mascotresults_params | get_ms_mascotresults_params (const int searchIndex) const
Return default flags and parameters for creating an ms_peptidesummary object.
virtual const ms_datfile & | getDatfile () const
Return the Mascot data file used for the project.
virtual int | getDistillerExperimentType () const
Return the experiment type of the project, only available from schema 1.6 onwards.
virtual std::string | getDistillerVersion () const
Return the version number of Distiller used to generate the distiller_data xml file.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
virtual const ms_fragrulesfile & | getFragRulesFile () const
Return the fragmentation rules file used for the project.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
virtual int | getLoadedSearchIndex () const
Return the index (index 1..getSearchCount) of the currently loaded search.
virtual const ms_distiller_data_quant & | getQuant (int index) const
Return the information the selected quantitation result (index 1..getQuantCount).
virtual int | getQuantCount () const
Return the number of quantitation results in the project.
virtual const ms_distiller_data_quant * | getQuantForSearch (const std::string &taskId) const
Return the information the quantitation result associated with the selected search.
virtual const ms_quant_method & | getQuantMethod () const
Return the quantitation method used for the project.
virtual const ms_distiller_data_search & | getSearch (int index) const
Return the information the selected search (index 1..getSearchCount).
virtual int | getSearchCount () const
Return the number of searches in the project.
bool | isValid () const
Call this function to determine if there have been any errors.
virtual bool | loadXml (const char *xmlSchemaPath, const std::string &xmlText)
Load Distiller data from the supplied XML text.
virtual bool | loadXmlFile (const char *xmlSchemaPath, const std::string &xmlFilename)
Load Distiller data from the XML in the named file.
virtual bool | loadXmlStream (const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream)
Load Distiller data from a stream.
const ms_distiller_data & | operator= (const ms_distiller_data &copy)

Static Public Member Functions

static std::string | getDistillerProjectStreamName ()
Return the name of the stream, within the project file, used for the Distiller project parameters.
static time_t | getDistillerResfileTimestamp ()
Return the 'standard' Distiller results file timestamp; 2010/1/1 00:00:00.
static std::vector< std::string > | getRequiredSchemaFileNames ()
Return a list of the filenames of the schema that will be required when loading ms_distiller_data.

Detailed Description

Distiller project parameters.

Stored in a Distiller project file (.rov) in the stream "rover_data".

Constructor & Destructor Documentation

◆ ms_distiller_data()

ms_distiller_data ( const ms_distiller_data & copy )
Parameters
copy is the source to initialise from

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_distiller_data * right )

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ get_ms_mascotresults_params()

matrix_science::ms_mascotresults_params get_ms_mascotresults_params ( const int searchIndex ) const
virtual

Return default flags and parameters for creating an ms_peptidesummary object.

Parameters
searchIndex The index number (1..n) of the search in the Distiller data.
Returns
the values and flags required to pass to the peptide summary object.

◆ getDatfile()

const matrix_science::ms_datfile & getDatfile ( ) const
virtual

Return the Mascot data file used for the project.

Returns
The server configuration's ms_datfile.

◆ getDistillerExperimentType()

int getDistillerExperimentType ( ) const
virtual

Return the experiment type of the project, only available from schema 1.6 onwards.

0 = unknown, 1 = DDA, 2 = DIA

Returns
The Distiller experiment type [default = 1]

◆ getDistillerProjectStreamName()

std::string getDistillerProjectStreamName ( )
static

Return the name of the stream, within the project file, used for the Distiller project parameters.

Returns
The name of the stream containing the Distiller project parameters.

◆ getDistillerResfileTimestamp()

time_t getDistillerResfileTimestamp ( )
static

Return the 'standard' Distiller results file timestamp; 2010/1/1 00:00:00.

The timestamp on the Distiller results file is used to determine the name of the subfolder that is used to hold the results file and peptide summary cache files. It is also stored in the results cache file to check if the results file and the cache can be used together.

Setting the last update timestamp on the results file to a fixed time means that the cache file location can be controlled and so the file re-used. This saves time when loading and can help prevent wasted disk space by duplicated files.

Returns
The 'standard' time Distiller time; 2010/1/1 00:00:00.

◆ getDistillerVersion()

std::string getDistillerVersion ( ) const
virtual

Return the version number of Distiller used to generate the distiller_data xml file.

Returns
The Distiller version number.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFragRulesFile()

const matrix_science::ms_fragrulesfile & getFragRulesFile ( ) const
virtual

Return the fragmentation rules file used for the project.

Returns
The server configuration's ms_fragrulesfile.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getLoadedSearchIndex()

int getLoadedSearchIndex ( ) const
virtual

Return the index (index 1..getSearchCount) of the currently loaded search.

Returns
The current search index, or zero if no search is currently selected.

◆ getQuant()

const matrix_science::ms_distiller_data_quant & getQuant ( int index ) const
virtual

Return the information the selected quantitation result (index 1..getQuantCount).

Parameters
index An index (1..getQuantCount()) into the quantitation results int the project.
Returns
The selected quantitation result.

◆ getQuantCount()

int getQuantCount ( ) const
virtual

Return the number of quantitation results in the project.

Returns
The number of quantitation results in the project file.

◆ getQuantForSearch()

const matrix_science::ms_distiller_data_quant * getQuantForSearch ( const std::string & taskId ) const
virtual

Return the information the quantitation result associated with the selected search.

Parameters
taskId The task identifier of the Mascot search.
Returns
The search's quantitation result.

◆ getQuantMethod()

const matrix_science::ms_quant_method & getQuantMethod ( ) const
virtual

Return the quantitation method used for the project.

Returns
The quantitation method used.

◆ getRequiredSchemaFileNames()

std::vector< std::string > getRequiredSchemaFileNames ( )
static

Return a list of the filenames of the schema that will be required when loading ms_distiller_data.

This function can be used for checking that the required schema files are present before an error is raised.

Returns
a list of the filenames of the schema that will be required when loading ms_distiller_data, ms_distiller_master_project and ms_distiller_search_status_list from xml / project files

◆ getSearch()

const matrix_science::ms_distiller_data_search & getSearch ( int index ) const
virtual

Return the information the selected search (index 1..getSearchCount).

Parameters
index An index (1..getSearchCount()) into the search results int the project.
Returns
The selected search.

◆ getSearchCount()

int getSearchCount ( ) const
virtual

Return the number of searches in the project.

Returns
The number of searches in the project file.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ loadXml()

bool loadXml | ( | const char * | xmlSchemaPath,
 |  | const std::string & | xmlText
 | ) |  |
virtual

Load Distiller data from the supplied XML text.

Parameters
xmlSchemaPath | The folder where the quantitation XML schema files (XSD) can be found.
xmlText | The XML data to load.
Returns
True if the XML file was parsed and loaded successfully.

◆ loadXmlFile()

bool loadXmlFile | ( | const char * | xmlSchemaPath,
 |  | const std::string & | xmlFilename
 | ) |  |
virtual

Load Distiller data from the XML in the named file.

If the schema path contains spaces, it should be prefixed with "file:///" and the spaces should be replaced with "%20"

Parameters
xmlSchemaPath | The folder where the quantitation XML schema files (XSD) can be found.
xmlFilename | The path and filename of the XML file to load.
Returns
True if the XML file was parsed and loaded successfully.

◆ loadXmlStream()

bool loadXmlStream | ( | const char * | xmlSchemaPath,
 |  | matrix_science::ms_input_string_stream * | xmlStream
 | ) |  |
virtual

Load Distiller data from a stream.

Parameters
xmlSchemaPath | The path to the location of the XML schema (XSD) files.
xmlStream | The stream interface offering the data.
Returns
True if the data was parsed and loaded successfully.

◆ operator=()

const ms_distiller_data & operator= ( const ms_distiller_data & copy )
Parameters
copy is the source to initialise from
Returns
reference to the current object
The documentation for this class was generated from the following files:
  • ms_distiller_data.hpp
  • ms_distiller_data.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_data_quant Class Reference

  • matrix_science
  • ms_distiller_data_quant
Public Member Functions | List of all members
ms_distiller_data_quant Class Reference
Quantitation analysis for Mascot Server and Distiller

The details of a Distiller search. More...

#include <ms_distiller_data_quant.hpp>

Public Member Functions

std::string | getCacheStreamName () const
Return the name of the stream, within the project file, used for the quantitation cache file.
std::string | getResultsStreamName () const
Return the name of the stream, within the project file, used for the quantitation results file.
int | getStreamNumber () const
Return the number of the stream, within the project file, used to generate both the quantitation results and cache filenames.
std::string | getTaskId () const
Return the task ID of the search used in the quantitation results.

Detailed Description

The details of a Distiller search.

A list of these is stored in XML in the Distiller project file.

Member Function Documentation

◆ getCacheStreamName()

std::string getCacheStreamName ( ) const

Return the name of the stream, within the project file, used for the quantitation cache file.

Returns
The name of the stream containing the quantitation cache data.

◆ getResultsStreamName()

std::string getResultsStreamName ( ) const

Return the name of the stream, within the project file, used for the quantitation results file.

Returns
The name of the stream containing the quantitation result data.

◆ getStreamNumber()

int getStreamNumber ( ) const

Return the number of the stream, within the project file, used to generate both the quantitation results and cache filenames.

Returns
The number used to generate the stream names for the quantitation results and chache data.

◆ getTaskId()

std::string getTaskId ( ) const

Return the task ID of the search used in the quantitation results.

If there are multiple search result sets used in the quantitation then the task ID returned is that of the first search.

Returns
The task ID of the search the quantitation resultswere created from.
The documentation for this class was generated from the following files:
  • ms_distiller_data_quant.hpp
  • ms_distiller_data_quant.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_data_search Class Reference

  • matrix_science
  • ms_distiller_data_search
Public Types | Public Member Functions | List of all members
ms_distiller_data_search Class Reference
Quantitation analysis for Mascot Server and Distiller

The details of a Distiller search. More...

#include <ms_distiller_data_search.hpp>

Public Types

enum eGrouping {
eGroupAuto = 0 ,
eGroupStandard = 1 ,
eGroupFamily = 2
}
Setting to control how proteins are grouped. More...
enum eScoring {
eAuto = 0 ,
eMudpit = 1 ,
eStandard = 99999999
}
Determine whether to use MudPIT or standard (pre-Mascot 2.2) scoring. More...
enum eSpectralLibrary {
eUnknown = -1 ,
eFASTA = 0 ,
eLibrary = 1 ,
eIntegrated = 2
}
For integrated FASTA and Spectral Library search, determines the default result display option. More...

Public Member Functions

ms_distiller_data_search ()
Default constructor.
ms_distiller_data_search (const std::string &taskId, bool isLoaded, const std::string &cacheFileName, const std::string &quantMethodXml, const std::string &mascotServerURL, const std::string &mascotServerVersion, unsigned int flags, unsigned int flags2, bool requireBoldRed, bool showSameset, double showSubset, bool loadUnassigned, double significanceThreshold, eScoring scoring, int reporttop, bool errTolPeptide, eGrouping proteinGrouping, bool percolator, double scoreExpectCutOff, bool showSamesetFamily, bool showSubsetFamily, eSpectralLibrary libraryDisplayOption, bool percolatorUseProteins, bool percolatorUseRT, int minPepLenInPepSummary, bool isTargetFDR=false, const std::string &targetFDRType="", const std::string &targetFDRStr="")
Constructor with all values.
std::string | getCacheFileName () const
Return the name of the cache file used by Parser.
bool | getErrTolPeptide () const
Return true if the peptide search used error tolerant matching.
ms_mascotresults::DECOY_STATS_COUNT_TYPE | getFDRCountType () const
Returns the value of getTargetFDRType() transposed to the ms_mascotresults::DECOY_STATS_COUNT_TYPE enum.
bool | getLoaded () const
Returns true if the search data was currently loaded when the Distiller data was saved.
bool | getLoadUnassigned () const
Return true if the unassigned list should be loaded when opening the result.
std::string | getMascotSearchURL (const std::string &resultsFilePath) const
Return the URL for the search on the Mascot Server.
std::string | getMascotServerURL () const
The URL for the Mascot Server.
int | getMinPepLenInPepSummary () const
Return the minimum length of a peptide to be shown in a peptide summary.
unsigned int | getPeptideSummaryFlags () const
Return the default flags values to pass to the peptide summary constructor (as used in Distiller).
unsigned | getPeptideSummaryFlags2 () const
Return the default flags2 values to pass to the peptide summary constructor (as used in Distiller).
bool | getPercolator () const
Return true if the percolator is in use.
bool | getPercolatorUseProteins () const
Return true if percolator is set to set proteins for 'scoring'.
bool | getPercolatorUseRT () const
Return true if percolator will calculate and use retention times.
eGrouping | getProteinGrouping () const
Return the method of protein grouping that was used.
std::string | getQuantMethodXml () const
The XML text for the quantitation method, if any.
int | getReporttop () const
Return the number of protein hits to include in the results.
bool | getRequireBoldRed () const
Return true if bold, red font should be used.
double | getScoreExpectCutOff () const
Return the score cutoff threshold value.
eScoring | getScoring () const
Return the method of scoring that was used.
bool | getShowSamesets () const
Return true if same set matches should be shown for peptide and protein summary reports.
bool | getShowSamesetsFamily () const
Return true if same set matches should be shown for protein family summary reports.
double | getShowSubset () const
Return the threshold used to determine if a subset should be shown.
bool | getShowSubsetFamily () const
Return true if family subsets should be shown.
double | getSignificanceThreshold () const
Return the minimum probabilty threshold in use.
eSpectralLibrary | getSpectralLibraryDisplayOption () const
Returns the spectral library display option for the report.
double | getTargetFDR () const
Returns the numeric target fdr.
std::string | getTargetFDRStr () const
Returns the encoded target fdr for the targetFDR attribute.
std::string | getTargetFDRType () const
Returns the fdrType option for the targetFDR attribute.
std::string | getTaskId () const
The task ID of the Mascot search.
bool | isTargetFDR () const
Returns the "use" option for the targetFDR attribute.
bool | serverVersionNewerOrSameAs (int major, int minor, int patch) const
Compare the version of the Mascot Server with the specified values.

Detailed Description

The details of a Distiller search.

A list of these is stored in XML in the rover_data file in the Distiller project file. The data comes from the relevant <MascotSearch> section inside the <mascotsearches> section. Call ms_distiller_data::getSearch to get an instance of this object

Member Enumeration Documentation

◆ eGrouping

enum eGrouping

Setting to control how proteins are grouped.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
eGroupAuto | Grouping automatically determined when grouping begins, this value never appears in results.
eGroupStandard | Standard grouped protein list using parsimony / Occam’s razor.
eGroupFamily | Protein family grouping using Hierarchical Clustering.

◆ eScoring

enum eScoring

Determine whether to use MudPIT or standard (pre-Mascot 2.2) scoring.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
eAuto | Use MudPIT when the ratio of the number of spectra to the number of entries in the database is greater than the threshold.
eMudpit | Always use MudPIT.
eStandard | Never use MudPIT.

◆ eSpectralLibrary

enum eSpectralLibrary

For integrated FASTA and Spectral Library search, determines the default result display option.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
eUnknown | Attribute was not set.
eFASTA | Display FASTA search results only.
eLibrary | Display spectral library results only.
eIntegrated | Display integrated results report.

Constructor & Destructor Documentation

◆ ms_distiller_data_search()

ms_distiller_data_search | ( | const std::string & | taskId,
 |  | bool | isLoaded,
 |  | const std::string & | cacheFileName,
 |  | const std::string & | quantMethodXml,
 |  | const std::string & | mascotServerURL,
 |  | const std::string & | mascotServerVersion,
 |  | unsigned int | flags,
 |  | unsigned int | flags2,
 |  | bool | requireBoldRed,
 |  | bool | showSameset,
 |  | double | showSubset,
 |  | bool | loadUnassigned,
 |  | double | significanceThreshold,
 |  | eScoring | scoring,
 |  | int | reporttop,
 |  | bool | errTolPeptide,
 |  | eGrouping | proteinGrouping,
 |  | bool | percolator,
 |  | double | scoreExpectCutOff,
 |  | bool | showSamesetFamily,
 |  | bool | showSubsetFamily,
 |  | eSpectralLibrary | libraryDisplayOption,
 |  | bool | percolatorUseProteins,
 |  | bool | percolatorUseRT,
 |  | int | minPepLenInPepSummary,
 |  | bool | isTargetFDR = false,
 |  | const std::string & | targetFDRType = "",
 |  | const std::string & | targetFDRStr = ""
 | ) |  |

Constructor with all values.

Parameters
taskId | comes from the TaskID attribute in the <MascotSearch> element
isLoaded | comes from the Loaded attribute in the <MascotSearch> element
cacheFileName | comes from the cacheFileName attribute in the <MascotSearch> element
quantMethodXml | comes from the quantMethod attribute in the <MascotImportOptions> element
mascotServerURL | comes from the URL attribute in the <Server> element for the 'Default' server in the <MascotServers> element
mascotServerVersion | comes from the Version attribute in the <Server> element for the 'Default' server in the <MascotServers> element
flags | are the ms_mascotresults::FLAGS that would be passed to a ms_peptidesummary constructor
flags2 | are the ms_peptidesummary::MSPEPSUM flags that would be passed to a ms_peptidesummary constructor
requireBoldRed | comes from the requireBoldRed attribute in the <blueOptions>
showSameset | comes from the showSameset attribute in the <blueOptions>
showSubset | comes from the showSubset attribute in the <blueOptions>
loadUnassigned | comes from the loadUnassignedList attribute in the <blueOptions>
significanceThreshold | comes from the significanceThresholdStr attribute in the <blueOptions>
scoring | comes from the scoringType attribute in the <blueOptions>
reporttop | comes from the reportTop attribute in the <blueOptions>
errTolPeptide | comes from the ErrTolPeptide attribute in the <blueOptions>
proteinGrouping | comes from the proteinGrouping attribute in the <blueOptions>
percolator | comes from the percolator attribute in the <blueOptions>
scoreExpectCutOff | comes from the ScoreExpectCutOff attribute in the <blueOptions>
showSamesetFamily | comes from the showSamesetFamily attribute in the <blueOptions>
showSubsetFamily | comes from the showSubsetFamily attribute in the <blueOptions>
libraryDisplayOption | comes from the spectralLibraryDisplayOption attribute in the <blueOptions>
percolatorUseProteins | comes from the percolatorUseProteins attribute in the <blueOptions>
percolatorUseRT | comes from the percolatorUseRT attribute in the <blueOptions>
minPepLenInPepSummary | comes from the minPepLenInPepSummary attribute in the <blueOptions>
isTargetFDR | comes from the "use" attribute in the <targetFDR> [default=false]
targetFDRType | comes from the "fdrType" attribute in the <targetFDR> [default=empty string]
targetFDRStr | comes from the "targetFDRStr" attribute in the <targetFDR> [default=empty string]

Member Function Documentation

◆ getCacheFileName()

std::string getCacheFileName ( ) const

Return the name of the cache file used by Parser.

Default value: empty string

Obtained from the cacheFileName attribute in the <MascotSearch> element.

Returns
The name of the cache file used by Parser.

◆ getErrTolPeptide()

bool getErrTolPeptide ( ) const

Return true if the peptide search used error tolerant matching.

Default value: false

Obtained from the ErrTolPeptide attribute in the <blueoptions> element.

Returns
True if the peptide result was generated by an error tolerant Mascot search.

◆ getFDRCountType()

ms_mascotresults::DECOY_STATS_COUNT_TYPE getFDRCountType ( ) const

Returns the value of getTargetFDRType() transposed to the ms_mascotresults::DECOY_STATS_COUNT_TYPE enum.

Default value ms_mascotresults::DECOY_STATS_COUNT_TYPE::DS_COUNT_PSM

Returns
The target FDR type expressed as ms_mascotresults::DECOY_STATS_COUNT_TYPE

◆ getLoaded()

bool getLoaded ( ) const

Returns true if the search data was currently loaded when the Distiller data was saved.

Default value: false

Obtained from the Loaded attribute in the <MascotSearch> element.

Returns
True if the search was loaded when the Distiller data was saved.

◆ getLoadUnassigned()

bool getLoadUnassigned ( ) const

Return true if the unassigned list should be loaded when opening the result.

Default value: false

Obtained from the loadUnassignedList attribute in the <blueoptions> element.

Returns
True if the unassigned list should be loaded, false if not.

◆ getMascotSearchURL()

std::string getMascotSearchURL ( const std::string & resultsFilePath ) const

Return the URL for the search on the Mascot Server.

Default value: empty string

Built up on the fly from all the settings.

The URL will always specify master_results_2.pl rather than master_results.pl, even for a PMF

Parameters
resultsFilePath is, for example: "../data/2018010/F0012345.dat"
Returns
the URL for the search on the Mascot Server

◆ getMinPepLenInPepSummary()

int getMinPepLenInPepSummary ( ) const

Return the minimum length of a peptide to be shown in a peptide summary.

Default value: 5

Obtained from the minPepLenInPepSummary attribute in the <blueoptions> element which was added in Parser 2.7

Returns
the minimum length of a peptide to be shown in a peptide summary

◆ getPeptideSummaryFlags()

unsigned int getPeptideSummaryFlags ( ) const

Return the default flags values to pass to the peptide summary constructor (as used in Distiller).

The flags settings are a collection of values, bitwise or-ed together, from the FLAGS enumeration of ms_mascotresults.

Ideally, this function would call ms_mascotresfilebase::get_ms_mascotresults_params but we don't have a ms_mascotresfilebase object available.

Returns
The peptide summary flags settings.

◆ getPeptideSummaryFlags2()

unsigned int getPeptideSummaryFlags2 ( ) const

Return the default flags2 values to pass to the peptide summary constructor (as used in Distiller).

The flags2 settings are a collection of values, bitwise or-ed together, from the MSPEPSUM enumeration of ms_peptidesummary.

Returns
The peptide summary flags2 settings.

◆ getPercolator()

bool getPercolator ( ) const

Return true if the percolator is in use.

Default value: false

Obtained from the percolator attribute in the <blueoptions> element.

Returns
True if percolator re-scoring was used.

◆ getPercolatorUseProteins()

bool getPercolatorUseProteins ( ) const

Return true if percolator is set to set proteins for 'scoring'.

Default value: false

Obtained from the percolatorUseProteins attribute in the <blueoptions> element which was added in Parser 2.7

Returns
true if percolator is set to set proteins for 'scoring'

◆ getPercolatorUseRT()

bool getPercolatorUseRT ( ) const

Return true if percolator will calculate and use retention times.

Default value: false

Obtained from the percolatorUseRT attribute in the <blueoptions> element which was added in Parser 2.7

Returns
true if percolator will calculate and use retention times.

◆ getProteinGrouping()

ms_distiller_data_search::eGrouping getProteinGrouping ( ) const

Return the method of protein grouping that was used.

Default value: ms_distiller_data_search::eGroupAuto

Obtained from the proteinGrouping attribute in the <blueoptions> element.

Returns
The method of protein grouping that was used.

◆ getQuantMethodXml()

std::string getQuantMethodXml ( ) const

The XML text for the quantitation method, if any.

Default value: empty string

Obtained from the quantMethod attribute in the <MascotImportOptions> element.

This text can be loaded into a ms_quant_configfile using ms_quant_configfile::read_buffer().

Returns
The XML text containing the quantitation method, if any.

◆ getReporttop()

int getReporttop ( ) const

Return the number of protein hits to include in the results.

Default value: 0

Obtained from the reportTop attribute in the <blueoptions> element.

Returns
The number of protein hits to include in the results.

◆ getRequireBoldRed()

bool getRequireBoldRed ( ) const

Return true if bold, red font should be used.

Default value: false

Obtained from the requireBoldRed attribute in the <blueoptions> element.

Returns
True if bold, red font should be used.

◆ getScoreExpectCutOff()

double getScoreExpectCutOff ( ) const

Return the score cutoff threshold value.

Default value: 0

Obtained from the ScoreExpectCutOff attribute in the <blueoptions> element.

Returns
The score cutoff threshold value.

◆ getScoring()

ms_distiller_data_search::eScoring getScoring ( ) const

Return the method of scoring that was used.

Default value: ms_distiller_data_search::eAuto

Obtained from the scoringType attribute in the <blueoptions> element.

Returns
The method of scoring that was used.

◆ getShowSamesets()

bool getShowSamesets ( ) const

Return true if same set matches should be shown for peptide and protein summary reports.

Default value: true

Obtained from the showSameset attribute in the <blueoptions> element.

Returns
True if same set protein matches should be displayed, false if not

◆ getShowSamesetsFamily()

bool getShowSamesetsFamily ( ) const

Return true if same set matches should be shown for protein family summary reports.

Default value: true

Obtained from the showSamesetFamily attribute in the <blueoptions> element.

Returns
True if same set protein matches should be displayed, false if not

◆ getShowSubset()

double getShowSubset ( ) const

Return the threshold used to determine if a subset should be shown.

Default value: 0

Obtained from the showSubset attribute in the <blueoptions> element. This value is base 64 eoncoded in the xml file.

Returns
The threshold used to determine if a subset should be shown.

◆ getShowSubsetFamily()

bool getShowSubsetFamily ( ) const

Return true if family subsets should be shown.

Default value: false

Obtained from the showSubsetFamily attribute in the <blueoptions> element.

Returns
True if family subsets should be shown.

◆ getSignificanceThreshold()

double getSignificanceThreshold ( ) const

Return the minimum probabilty threshold in use.

Default value:

Obtained from the significanceThreshold attribute in the <blueoptions> element which is a base 64 encoded value. If that isn't present, get the value from the significanceThresholdStr attribute.

Returns
The minimum probability threshold setting.

◆ getSpectralLibraryDisplayOption()

ms_distiller_data_search::eSpectralLibrary getSpectralLibraryDisplayOption ( ) const

Returns the spectral library display option for the report.

Default value: ms_distiller_data_search::eUnknown

Obtained from the spectralLibraryDisplayOption attribute in the <blueoptions> element which was added in Parser 2.7.

The value in the XML should be one of: "fasta", "library" or "integrated".

Returns
The spectral library results display option

◆ getTargetFDR()

double getTargetFDR ( ) const

Returns the numeric target fdr.

Default value 0: Obtained from the targetFDRStr attribute in <targetFDR> element

Returns
The targetFDR

◆ getTargetFDRStr()

std::string getTargetFDRStr ( ) const

Returns the encoded target fdr for the targetFDR attribute.

Default value: empty string Obtained from the targetFDRStr attribute in <targetFDR> element The Base64 encoded target FDR

Returns
The targetFDRStr results display option

◆ getTargetFDRType()

std::string getTargetFDRType ( ) const

Returns the fdrType option for the targetFDR attribute.

Default value: empty string Obtained from the fdrType attribute in <targetFDR> element Should be one of either "psm" or "sequence" if set

Returns
The fdrType results display option

◆ getTaskId()

std::string getTaskId ( ) const

The task ID of the Mascot search.

Default value: empty string

Obtained from the TaskID attribute in the <MascotSearch> element.

Returns
The task ID of the Mascot search.

◆ isTargetFDR()

bool isTargetFDR ( ) const

Returns the "use" option for the targetFDR attribute.

Default value: false Obtained from the use attribute in <targetFDR> element

Returns
True if TargetFDR has been set and enabled, false if not

◆ serverVersionNewerOrSameAs()

bool serverVersionNewerOrSameAs | ( | int | major,
 |  | int | minor,
 |  | int | patch
 | ) |  | const

Compare the version of the Mascot Server with the specified values.

Parameters
major | is, for example 2 for version 2.5.1
minor | is, for example 5 for version 2.5.1
patch | is, for example 1 for version 2.5.1
Returns
true if the version saved in this object is a newer version than the passed major and minor values passed
The documentation for this class was generated from the following files:
  • ms_distiller_data_search.hpp
  • ms_distiller_data_search.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_master_project Class Reference

  • matrix_science
  • ms_distiller_master_project
Public Member Functions | Static Public Member Functions | List of all members
ms_distiller_master_project Class Reference
Quantitation analysis for Mascot Server and Distiller

Data for a Distiller master project, includes a list of the subprojects. More...

#include <ms_distiller_master_project.hpp>

Inheritance diagram for ms_distiller_master_project:
[legend]
Collaboration diagram for ms_distiller_master_project:
[legend]

Public Member Functions

ms_distiller_master_project (const ms_distiller_master_project &src)
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_distiller_master_project *right)
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
virtual int | getNumSearches () const
Return the number of searches in the master project.
virtual int | getNumSubprojects () const
Return the number of subprojects in the master project.
virtual const ms_distiller_master_search & | getSearch (int index) const
Return the selected search (index 1..n).
virtual const ms_distiller_sub_project & | getSubproject (int index) const
Return the selected subproject (index 1..n).
bool | isValid () const
Call this function to determine if there have been any errors.
virtual bool | loadXml (const char *xmlSchemaPath, std::string xmlText)
Load master project data from the supplied XML text.
virtual bool | loadXmlFile (const char *xmlSchemaPath, std::string xmlFilename)
Load master project data from the XML in the named file.
virtual bool | loadXmlStream (const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream)
Load master project data from a stream.
ms_distiller_master_project & | operator= (const ms_distiller_master_project &right)

Static Public Member Functions

static std::string getMasterProjectStreamName ()
Return the name of the stream, within the project file, used for the master project list.

Detailed Description

Data for a Distiller master project, includes a list of the subprojects.

This is stored in XML in the 'rover_data+2' stream.

Constructor & Destructor Documentation

◆ ms_distiller_master_project()

ms_distiller_master_project ( const ms_distiller_master_project & src )
Parameters
src is the source to initialise from

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_distiller_master_project * right )
Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMasterProjectStreamName()

std::string getMasterProjectStreamName ( )
static

Return the name of the stream, within the project file, used for the master project list.

Returns
The name of the stream containing the master project data.

◆ getNumSearches()

int getNumSearches ( ) const
virtual

Return the number of searches in the master project.

Returns
The number of searches in the master project.

◆ getNumSubprojects()

int getNumSubprojects ( ) const
virtual

Return the number of subprojects in the master project.

Returns
The number of subprojects in the master project.

◆ getSearch()

const matrix_science::ms_distiller_master_search & getSearch ( int index ) const
virtual

Return the selected search (index 1..n).

Parameters
index The search's index (1..getNumSearches()).
Returns
The selected search.

◆ getSubproject()

const matrix_science::ms_distiller_sub_project & getSubproject ( int index ) const
virtual

Return the selected subproject (index 1..n).

Parameters
index The project's index (1..getNumSubprojects()).
Returns
The selected project.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ loadXml()

bool loadXml | ( | const char * | xmlSchemaPath,
 |  | std::string | xmlText
 | ) |  |
virtual

Load master project data from the supplied XML text.

Parameters
xmlSchemaPath | The folder where the XML schema files (XSD) can be found.
xmlText | The XML data to load.
Returns
True if the XML file was parsed and loaded successfully.

◆ loadXmlFile()

bool loadXmlFile | ( | const char * | xmlSchemaPath,
 |  | std::string | xmlFilename
 | ) |  |
virtual

Load master project data from the XML in the named file.

If the schema path contains spaces, it should be prefixed with "file:///" and the spaces should be replaced with "%20"

Parameters
xmlSchemaPath | The folder where the XML schema files (XSD) can be found.
xmlFilename | The path and filename of the XML file to load.
Returns
True if the XML file was parsed and loaded successfully.

◆ loadXmlStream()

bool loadXmlStream | ( | const char * | xmlSchemaPath,
 |  | matrix_science::ms_input_string_stream * | xmlStream
 | ) |  |
virtual

Load master project data from a stream.

Parameters
xmlSchemaPath | The path to the location of the XML schema (XSD) files.
xmlStream | The stream interface offering the data.
Returns
True if the data was parsed and loaded successfully.

◆ operator=()

ms_distiller_master_project & operator= ( const ms_distiller_master_project & right )
Parameters
right is the source to initialise from
Returns
reference to the current object
The documentation for this class was generated from the following files:
  • ms_distiller_master_project.hpp
  • ms_distiller_master_project.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_master_search Class Reference

  • matrix_science
  • ms_distiller_master_search
Public Member Functions | List of all members
ms_distiller_master_search Class Reference
Quantitation analysis for Mascot Server and Distiller

The details of a Distiller multifile search. More...

#include <ms_distiller_master_search.hpp>

Public Member Functions

virtual std::string | getCacheFilename () const
Return the name of the cache file Distiller used.
virtual std::string | getCombinedPeptideSummaryCacheStreamName () const
Return the path and name of the peptide summary cache stream.
virtual int | getId () const
Return the identifier for the peptide summary cache stream in the master project file.
virtual int | getNumSubsearches () const
Return the number of subsearches in the master search.
virtual const ms_distiller_subsearch & | getSubsearch (int index) const
Return the selected search (index 1..n).

Detailed Description

The details of a Distiller multifile search.

A list of these is stored in XML in the Distiller master project file.

Member Function Documentation

◆ getCacheFilename()

std::string getCacheFilename ( ) const
virtual

Return the name of the cache file Distiller used.

Returns
The path and name of the file Distiller used to contain the peptide summary cache data.

◆ getCombinedPeptideSummaryCacheStreamName()

std::string getCombinedPeptideSummaryCacheStreamName ( ) const
virtual

Return the path and name of the peptide summary cache stream.

Returns
The name of the stream containing the peptide summary cache data.

◆ getId()

int getId ( ) const
virtual

Return the identifier for the peptide summary cache stream in the master project file.

Returns
The identifier for the peptide summary cache stream in the master project file.

◆ getNumSubsearches()

int getNumSubsearches ( ) const
virtual

Return the number of subsearches in the master search.

Returns
The number of subsearches in the master search.

◆ getSubsearch()

const matrix_science::ms_distiller_subsearch & getSubsearch ( int index ) const
virtual

Return the selected search (index 1..n).

Parameters
index The subsearch's index (1..getNumSubsearches()).
Returns
The selected subsearch.
The documentation for this class was generated from the following files:
  • ms_distiller_master_search.hpp
  • ms_distiller_master_search.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_search_status Class Reference

  • matrix_science
  • ms_distiller_search_status
Public Member Functions | List of all members
ms_distiller_search_status Class Reference
Quantitation analysis for Mascot Server and Distiller

A Mascot search status from a Distiller project file. More...

#include <ms_distiller_search_status.hpp>

Public Member Functions

int | getError () const
Return the error message code, if any, received from the Mascot search.
int | getId () const
Return the id number used in the names of the results file stream and peptide summary cache stream.
std::string | getPeptideSummaryCacheStreamName () const
Return the name of the peptide summary cache stream.
std::string | getResfileStreamName () const
Return the name of the results file stream.
std::string | getResultsFile () const
Return the name on the Mascot server of the file containing the results.
std::string | getServer () const
Return the URL of the Mascot server.
std::string | getStatusMsg () const
Return the status message, if any, received from the Mascot search.
std::string | getSubmitTime () const
Return the time the search was submitted to the Mascot server.
std::string | getTaskId () const
Return the Mascot search task ID.
std::string | getTitle () const
Return the Mascot search title.

Detailed Description

A Mascot search status from a Distiller project file.

A list of these is stored in XML in the Distiller project file.

Member Function Documentation

◆ getError()

int getError ( ) const

Return the error message code, if any, received from the Mascot search.

Returns
The error code, if any, received from mascot server.

◆ getId()

int getId ( ) const

Return the id number used in the names of the results file stream and peptide summary cache stream.

Returns
The identifier for the search identifier within the Distiller project.

◆ getPeptideSummaryCacheStreamName()

std::string getPeptideSummaryCacheStreamName ( ) const

Return the name of the peptide summary cache stream.

Returns
The name of the stream containing the peptide summary data.

◆ getResfileStreamName()

std::string getResfileStreamName ( ) const

Return the name of the results file stream.

Returns
The name of the stream containing the results file data.

◆ getResultsFile()

std::string getResultsFile ( ) const

Return the name on the Mascot server of the file containing the results.

Returns
The name of the results file on the Mascot server.

◆ getServer()

std::string getServer ( ) const

Return the URL of the Mascot server.

Returns
The URL of the Mascot server.

◆ getStatusMsg()

std::string getStatusMsg ( ) const

Return the status message, if any, received from the Mascot search.

Returns
The text of the status message, if any, received from mascot server.

◆ getSubmitTime()

std::string getSubmitTime ( ) const

Return the time the search was submitted to the Mascot server.

Returns
The time the search was submitted to the Mascot server.

◆ getTaskId()

std::string getTaskId ( ) const

Return the Mascot search task ID.

Returns
The Mascot task identifier.

◆ getTitle()

std::string getTitle ( ) const

Return the Mascot search title.

Returns
The title of the Mascot search.
The documentation for this class was generated from the following files:
  • ms_distiller_search_status.hpp
  • ms_distiller_search_status.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_search_status_list Class Reference

  • matrix_science
  • ms_distiller_search_status_list
Public Member Functions | Static Public Member Functions | List of all members
ms_distiller_search_status_list Class Reference
Quantitation analysis for Mascot Server and Distiller

A list of Mascot search status values, typically stored in a Distiller project file. More...

#include <ms_distiller_search_status_list.hpp>

Inheritance diagram for ms_distiller_search_status_list:
[legend]
Collaboration diagram for ms_distiller_search_status_list:
[legend]

Public Member Functions

ms_distiller_search_status_list (const ms_distiller_search_status_list &src)
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_distiller_search_status_list *right)
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumSearches () const
Return the number of searches in the search status list.
const ms_distiller_search_status & | getSearch (int index) const
Return the selected search status from the search status list.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | loadXml (const char *xmlSchemaPath, const std::string &xmlText)
Load the search status list from the supplied XML text.
bool | loadXmlFile (const char *xmlSchemaPath, const std::string &xmlFilename)
Load the search status list from the XML in the named file.
bool | loadXmlStream (const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream)
Load the search status list from a stream.
ms_distiller_search_status_list & | operator= (const ms_distiller_search_status_list &right)

Static Public Member Functions

static std::string getSearchStatusListStreamName ()
Return the name of the stream, within the subproject file, used for the search list.

Detailed Description

A list of Mascot search status values, typically stored in a Distiller project file.

This is stored in XML in the 'mdro_search_status' stream.

Constructor & Destructor Documentation

◆ ms_distiller_search_status_list()

ms_distiller_search_status_list ( const ms_distiller_search_status_list & src )
Parameters
src is the source to initialise from

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_distiller_search_status_list * right )
Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getNumSearches()

int getNumSearches ( ) const

Return the number of searches in the search status list.

Returns
The number of search statuses in the list.

◆ getSearch()

const matrix_science::ms_distiller_search_status & getSearch ( int index ) const

Return the selected search status from the search status list.

Parameters
index The search status's index (1..getNumSearches()).
Returns
The selected search status.

◆ getSearchStatusListStreamName()

std::string getSearchStatusListStreamName ( )
static

Return the name of the stream, within the subproject file, used for the search list.

Returns
The name of the stream containing the results list data.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ loadXml()

bool loadXml | ( | const char * | xmlSchemaPath,
 |  | const std::string & | xmlText
 | ) |  |

Load the search status list from the supplied XML text.

Parameters
xmlSchemaPath | The path to the location of the XML schema (XSD) files.
xmlText | The XML data to load.
Returns
True if the XML file was parsed and loaded successfully.

◆ loadXmlFile()

bool loadXmlFile | ( | const char * | xmlSchemaPath,
 |  | const std::string & | xmlFilename
 | ) |  |

Load the search status list from the XML in the named file.

If the schema path contains spaces, it should be prefixed with "file:///" and the spaces should be replaced with "%20"

Parameters
xmlSchemaPath | The path to the location of the XML schema (XSD) files.
xmlFilename | The path and filename of the XML file to load.
Returns
True if the XML file was parsed and loaded successfully.

◆ loadXmlStream()

bool loadXmlStream | ( | const char * | xmlSchemaPath,
 |  | matrix_science::ms_input_string_stream * | xmlStream
 | ) |  |

Load the search status list from a stream.

Parameters
xmlSchemaPath | The path to the location of the XML schema (XSD) files.
xmlStream | The stream interface offering the data.
Returns
True if the data was parsed and loaded successfully.

◆ operator=()

ms_distiller_search_status_list & operator= ( const ms_distiller_search_status_list & right )
Parameters
right is the source to initialise from
Returns
reference to the current object
The documentation for this class was generated from the following files:
  • ms_distiller_search_status_list.hpp
  • ms_distiller_search_status_list.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_sub_project Class Reference

  • matrix_science
  • ms_distiller_sub_project
Public Member Functions | Static Public Member Functions | List of all members
ms_distiller_sub_project Class Reference
Quantitation analysis for Mascot Server and Distiller

The details of a Distiller multifile subproject. More...

#include <ms_distiller_sub_project.hpp>

Public Member Functions

virtual bool | getHavePeakList () const
Return true if the subproject has any peak lists.
virtual int | getId () const
Return the number, within the subproject file, used in the name of the search list stream.
virtual std::string | getName () const
Return the name of the subproject.
virtual std::string | getProjectRelativePath () const
Return the relative path and filename to the raw file in the subproject.
virtual std::string | getRawAbsolutePath () const
Return the absolute path and filename to the raw file in the subproject.
virtual int | getRawFormat () const
Return the format type of the raw files in the subproject.
virtual std::string | getRawRelativePath () const
Return the relative path and filename to the raw file in the subproject.
virtual int | getRawSampleNumber () const
Return the raw sample number of the subproject.
virtual std::string | getType () const
Return the type of data the subproject is created from.

Static Public Member Functions

static std::string getResultsListStreamName ()
Return the name of the stream, within the subproject file, used for the search list.

Detailed Description

The details of a Distiller multifile subproject.

A list of these is stored in XML in the Distiller master project file.

Member Function Documentation

◆ getHavePeakList()

bool getHavePeakList ( ) const
virtual

Return true if the subproject has any peak lists.

Returns
True if the subproject has any peak lists.

◆ getId()

int getId ( ) const
virtual

Return the number, within the subproject file, used in the name of the search list stream.

Returns
The number used in the name of the search list stream.

◆ getName()

std::string getName ( ) const
virtual

Return the name of the subproject.

Returns
The name of the subproject.

◆ getProjectRelativePath()

std::string getProjectRelativePath ( ) const
virtual

Return the relative path and filename to the raw file in the subproject.

Returns
The relative path and filename to the raw file in the subproject.

◆ getRawAbsolutePath()

std::string getRawAbsolutePath ( ) const
virtual

Return the absolute path and filename to the raw file in the subproject.

Returns
The absolute path and filename to the raw file in the subproject.

◆ getRawFormat()

int getRawFormat ( ) const
virtual

Return the format type of the raw files in the subproject.

Returns
The format type of the raw files in the subproject.

◆ getRawRelativePath()

std::string getRawRelativePath ( ) const
virtual

Return the relative path and filename to the raw file in the subproject.

Returns
The relative path and filename to the raw file in the subproject.

◆ getRawSampleNumber()

int getRawSampleNumber ( ) const
virtual

Return the raw sample number of the subproject.

Returns
The raw sample number of the subproject.

◆ getResultsListStreamName()

std::string getResultsListStreamName ( )
static

Return the name of the stream, within the subproject file, used for the search list.

Returns
The name of the stream containing the results list data.

◆ getType()

std::string getType ( ) const
virtual

Return the type of data the subproject is created from.

Returns
The type of data the subproject is created from, "project" or "raw".
The documentation for this class was generated from the following files:
  • ms_distiller_sub_project.hpp
  • ms_distiller_sub_project.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_subsearch Class Reference

  • matrix_science
  • ms_distiller_subsearch
Public Member Functions | List of all members
ms_distiller_subsearch Class Reference
Quantitation analysis for Mascot Server and Distiller

The details of a Distiller multifile subsearch. More...

#include <ms_distiller_subsearch.hpp>

Public Member Functions

virtual std::string | getResultsFile () const
Return the name on the Mascot server of the file containing the results.
virtual std::string | getTaskId () const
Return the Mascot search task ID.
virtual std::string | getTitle () const
Return the Mascot search title.

Detailed Description

The details of a Distiller multifile subsearch.

A list of these is stored in XML in each search in the Distiller master project file.

Member Function Documentation

◆ getResultsFile()

std::string getResultsFile ( ) const
virtual

Return the name on the Mascot server of the file containing the results.

Returns
The name of the results file on the Mascot server.

◆ getTaskId()

std::string getTaskId ( ) const
virtual

Return the Mascot search task ID.

Returns
The Mascot task identifier.

◆ getTitle()

std::string getTitle ( ) const
virtual

Return the Mascot search title.

Returns
The title of the Mascot search.
The documentation for this class was generated from the following files:
  • ms_distiller_subsearch.hpp
  • ms_distiller_subsearch.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fitexy_result Class Reference

  • matrix_science
  • ms_fitexy_result
Public Member Functions | List of all members
ms_fitexy_result Class Reference
Quantitation analysis for Mascot Server and Distiller

Parameters and results from least squares fit with errors in both co-ordinates. More...

#include <ms_fitexy_result.hpp>

Inherits ms_handle.

Public Member Functions

ms_fitexy_result ()
Default constructor.
double | getA () const
Get the a value.
double | getB () const
Get the b value.
double | getChi2 () const
Get the chi-squared value.
double | getQ () const
Get the chi squared probabilty. The larger the value, the better the fit.
double | getSigmaA () const
Get the a sigma.
double | getSigmaB () const
Get the b sigma.
double | getSigmaX () const
Get the x sigma.
double | getSigmaY () const
Get the y sigma.

Detailed Description

Parameters and results from least squares fit with errors in both co-ordinates.

Mascot Parser does not contain the code to calculate the fit. This class just returns the result of the fitting of a straight line: y = a + bx

The results are stored in XML in a "fitexy" entity.

Constructor & Destructor Documentation

◆ ms_fitexy_result()

ms_fitexy_result ( )

Default constructor.

Assigns reasonable default values to all internal members.

Member Function Documentation

◆ getA()

double getA ( ) const

Get the a value.

The fitted line is y = a + bx

Returns
The a value.

◆ getB()

double getB ( ) const

Get the b value.

The fitted line is y = a + bx

Returns
The b value.

◆ getChi2()

double getChi2 ( ) const

Get the chi-squared value.

Returns
The chi-squared value.

◆ getQ()

double getQ ( ) const

Get the chi squared probabilty. The larger the value, the better the fit.

The goodness of fit probability q that the fit would have getChi2() this large or larger

Returns
The Q value.

◆ getSigmaA()

double getSigmaA ( ) const

Get the a sigma.

The relative probable uncertanty of 'a'

Returns
The a sigma.

◆ getSigmaB()

double getSigmaB ( ) const

Get the b sigma.

The relative probable uncertanty of 'b'

Returns
The b sigma.

◆ getSigmaX()

double getSigmaX ( ) const

Get the x sigma.

The standard deviation of x data.

Returns
The x sigma.

◆ getSigmaY()

double getSigmaY ( ) const

Get the y sigma.

The standard deviation of y data.

Returns
The y sigma.
The documentation for this class was generated from the following files:
  • ms_fitexy_result.hpp
  • ms_fitexy_result.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_average_results Class Reference

  • matrix_science
  • ms_ms1quant_average_results
Public Member Functions | List of all members
ms_ms1quant_average_results Class Reference
Quantitation analysis for Mascot Server and Distiller

Results specific to an 'average' type quantitation method. More...

#include <ms_ms1quant_average_results.hpp>

Inherits ms_handle.

Public Member Functions

ms_ms1quant_average_results ()
Default constructor.
ms_ms1quant_average_results (const ms_ms1quant_average_results_body &body)
Populated constructor, linked to loaded data.
int | getReferenceHitId () const
The hit number of the selected reference protein.
int | getReferenceMemberNumber () const
The hit-family member number of the selected reference protein.
int | isReferenceUserSelected () const
The true if the user selected the reference.

Detailed Description

Results specific to an 'average' type quantitation method.

This is stored in a Distiller results XML in an "averageResult" entity.

This is stored in a Distiller results CDB file in an "AverageInfo" stream.

Constructor & Destructor Documentation

◆ ms_ms1quant_average_results() [1/2]

ms_ms1quant_average_results ( )

Default constructor.

The default hit identifier is -1.

◆ ms_ms1quant_average_results() [2/2]

ms_ms1quant_average_results ( const ms_ms1quant_average_results_body & body )

Populated constructor, linked to loaded data.

Parameters
body The data loaded from the result file.

Member Function Documentation

◆ getReferenceHitId()

int getReferenceHitId ( ) const

The hit number of the selected reference protein.

Returns
The hit identifier of the reference protein.

◆ getReferenceMemberNumber()

int getReferenceMemberNumber ( ) const

The hit-family member number of the selected reference protein.

Returns
The family member number of the reference protein.

◆ isReferenceUserSelected()

int isReferenceUserSelected ( ) const

The true if the user selected the reference.

Returns
True if the reference protein was selected by the user, false if it was selected automatically.
The documentation for this class was generated from the following files:
  • ms_ms1quant_average_results.hpp
  • ms_ms1quant_average_results.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_charge_state Class Reference

  • matrix_science
  • ms_ms1quant_charge_state
Public Member Functions | List of all members
ms_ms1quant_charge_state Class Reference
Quantitation analysis for Mascot Server and Distiller

A result from a charge state calculation. More...

#include <ms_ms1quant_charge_state.hpp>

Inherits ms_handle.

Public Member Functions

ms_ms1quant_charge_state ()
Default constructor.
ms_ms1quant_charge_state (const double correctSppWidthMin, const double correctSppWidthMax, const double correctSppWidth, const double bucketWidth, const double maxAlignment, const double matchedRho, const double matchedFraction, const double totalIntensity, const std::map< int, std::map< int, double > > &bucketAreas, const std::vector< double > &calcMzVar, const std::vector< int > &idx2Comp)
ms_ms1quant_charge_state (const ms_ms1quant_charge_state_body &body)
Populated constructor.
bool | getBucket (const int file_index, int index, unsigned &scanId, double &area) const
Get a bucket scan number and intensity by its index (1..n).
bool | getBucket (int index, unsigned &scanId, double &area) const
Get a bucket scan number and intensity by its index (1..n).
double | getBucketWidth () const
Get the width of buckets used to collect peak area.
double | getCorrectedMaxSPPwidth () const
Get the maximum peak width used for final stage of peak detection.
double | getCorrectedMinSPPwidth () const
Get the minimum peak width used for final stage of peak detection.
double | getCorrectedSPPwidth () const
Get the expected peak width used for final stage of peak detection.
double | getMatchedFraction () const
Get the fitted peak area as a fraction of total peak area in XIC region. Value of 1.0 is perfect.
double | getMatchedRho () const
Get the correlation coefficient between calculated and experimental spectrum in XIC region. A value of 1.0 indicates a perfect fit.
double | getMaxAlignment () const
Get the offset required for optimum alignment of buckets with spectrum.
int | getNumberOfBuckets (const int file_index=ms_quant_file_index::file_index_value_not_set) const
Get the number of bucket scan areas.
double | getTotalIntensity () const
Get the peak area falling in all buckets summed over all scans in XIC peak.

Detailed Description

A result from a charge state calculation.

This is stored in XML in a "chargeStateData" entity.

Constructor & Destructor Documentation

◆ ms_ms1quant_charge_state() [1/3]

ms_ms1quant_charge_state ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_ms1quant_charge_state() [2/3]

ms_ms1quant_charge_state ( const ms_ms1quant_charge_state_body & body )

Populated constructor.

Parameters
body The data loaded from the result file.

◆ ms_ms1quant_charge_state() [3/3]

ms_ms1quant_charge_state | ( | const double | correctSppWidthMin,
 |  | const double | correctSppWidthMax,
 |  | const double | correctSppWidth,
 |  | const double | bucketWidth,
 |  | const double | maxAlignment,
 |  | const double | matchedRho,
 |  | const double | matchedFraction,
 |  | const double | totalIntensity,
 |  | const std::map< int, std::map< int, double > > & | bucketAreas,
 |  | const std::vector< double > & | calcMzVar,
 |  | const std::vector< int > & | idx2Comp
 | ) |  |
Parameters
correctSppWidthMin | see getCorrectedMinSPPwidth()
correctSppWidthMax | see getCorrectedMaxSPPwidth()
correctSppWidth | see getCorrectedSPPwidth()
bucketWidth | see getBucketWidth()
maxAlignment | see getMaxAlignment()
matchedRho | see getMatchedRho()
matchedFraction | see getMatchedFraction()
totalIntensity | see getTotalIntensity()
bucketAreas | is a std::map of scanIDs to area
calcMzVar | is a vector of calculated m/z values for each scan??
idx2Comp | is a vector of index to component values

Member Function Documentation

◆ getBucket() [1/2]

bool getBucket | ( | const int | file_index,
 |  | int | index,
 |  | unsigned & | scanId,
 |  | double & | area
 | ) |  | const

Get a bucket scan number and intensity by its index (1..n).

See Multiple return values in Perl, Java, Python and C#.

Peak area falling in a bucket for each scan in XIC peak.

Parameters
[in] | file_index | is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file. Old files didn't store the file_index for the bucket areas, so these will be set to ms_quant_file_index::file_index_value_not_set . So, try and cope with this intelligently. If the request is for a specific file_index, but the only one here is for ms_quant_file_index::file_index_value_not_set then return that one.
[in] | index | The bucket scan identifier and area by its index (1..getNumberOfBuckets()).
[out] | scanId | Filled in with the scan identifier of the bucket.
[out] | area | Filled in with the area of the bucket.
Returns
True if the index is in range and refers to a bucket.

◆ getBucket() [2/2]

bool getBucket | ( | int | index,
 |  | unsigned & | scanId,
 |  | double & | area
 | ) |  | const

Get a bucket scan number and intensity by its index (1..n).

See Multiple return values in Perl, Java, Python and C#.

Peak area falling in a bucket for each scan in XIC peak.

Deprecated:
see getBucket(const int, int, unsigned &, double &)
Parameters
[in] | index | The bucket scan identifier and area by its index (1..getNumberOfBuckets()).
[out] | scanId | Filled in with the scan identifier of the bucket.
[out] | area | Filled in with the area of the bucket.
Returns
True if the index is in range and refers to a bucket.

◆ getBucketWidth()

double getBucketWidth ( ) const

Get the width of buckets used to collect peak area.

Returns
The bucket width.

◆ getCorrectedMaxSPPwidth()

double getCorrectedMaxSPPwidth ( ) const

Get the maximum peak width used for final stage of peak detection.

Returns
The corrected maximum SPP width.

◆ getCorrectedMinSPPwidth()

double getCorrectedMinSPPwidth ( ) const

Get the minimum peak width used for final stage of peak detection.

Returns
The corrected minimum SPP width.

◆ getCorrectedSPPwidth()

double getCorrectedSPPwidth ( ) const

Get the expected peak width used for final stage of peak detection.

Returns
The corrected SPP width.

◆ getMatchedFraction()

double getMatchedFraction ( ) const

Get the fitted peak area as a fraction of total peak area in XIC region. Value of 1.0 is perfect.

Returns
The matched fraction value.

◆ getMatchedRho()

double getMatchedRho ( ) const

Get the correlation coefficient between calculated and experimental spectrum in XIC region. A value of 1.0 indicates a perfect fit.

Returns
The matched rho value.

◆ getMaxAlignment()

double getMaxAlignment ( ) const

Get the offset required for optimum alignment of buckets with spectrum.

Returns
The maximum alignment value.

◆ getNumberOfBuckets()

int getNumberOfBuckets ( const int file_index = ms_quant_file_index::file_index_value_not_set ) const

Get the number of bucket scan areas.

Parameters
[in] file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file. Old files didn't store the file_index for the bucket areas, so these will be set to ms_quant_file_index::file_index_value_not_set . So, try and cope with this intelligently. If the request is for a specific file_index, but the only one here is for ms_quant_file_index::file_index_value_not_set then return that one.
Returns
The number of bucket scan areas.

◆ getTotalIntensity()

double getTotalIntensity ( ) const

Get the peak area falling in all buckets summed over all scans in XIC peak.

Returns
The total intensity.
The documentation for this class was generated from the following files:
  • ms_ms1quant_charge_state.hpp
  • ms_ms1quant_charge_state.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match Class Reference

  • matrix_science
  • ms_ms1quant_match
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_ms1quant_match Class Reference
Quantitation analysis for Mascot Server and Distiller

A peptide that has been matched, in quantitation, to a protein hit. More...

#include <ms_ms1quant_match.hpp>

Inherits ms_handle.

Public Types

enum chargeType {
CHARGETYPE_ORIGINAL ,
CHARGETYPE_ALL
}
Types of charge state used when matching. More...

Public Member Functions

ms_ms1quant_match ()
Default constructor; for standard library collections.
ms_ms1quant_match (const ms_ms1quant_match_body &body)
Populated constructor, linked to loaded data.
ms_ms1quant_match_component * | addComponent (const matrix_science::ms_ms1quant_match_component &component)
Add a new component to the list. Must already have a component to base this one on.
ms_ms1quant_match_component * | addCreatedComponent (const matrix_science::ms_ms1quant_match_component &component)
Add a new component to the list. Must already have a component to base this one on.
ms_ms1quant_match_component * | addCreatedComponent (const std::string &componentName)
bool | allComponentsIdentified () const
Check if all the match components were identified by Mascot.
void | clearHitRatioExcluded (const std::string &ratioName, int hitId, int memberNumber)
Clear the match ratio from being excluded from a hit.
void | clearHitRatioOutlier (const std::string &ratioName, int hitId, int memberNumber)
Clear the match ratio from being an outlier for a hit.
int | getChargeState () const
Get the ion charge state.
ms_ms1quant_charge_state | getChargeStateData () const
Get the charge state data.
chargeType | getChargeType () const
Get whether this charge state has been extrapolated from the charge state of a Mascot match.
ms_ms1quant_match_component | getComponent (int index) const
Get a component associated with this match by its index (1..getNumComponents).
ms_ms1quant_match_component | getComponent (std::string componentName) const
Get a component of the matched peptide.
std::string | getConciseLabelFreeVarMods () const
Get the concise (un-numbered) readable variable modifications.
const ms_matrix & | getCorrectionMatrix () const
Get the correction matrix A, product of J (averagine) and I (impurity).
int | getDataSourceId () const
Get the data source identifier if processed independantly.
double | getDisplayIntensity () const
Get the total intensity of fitted peaks across the XIC peak.
int | getFirstXicScanId () const
Get the first scan of all the scans processed in the search for an XIC peak. Can be a wide region.
const ms_protein * | getHit (int index1) const
Get a protein hit associated with this match by its index (1..getNumHits).
matrix_science::ms_peptide_quant_key | getKey () const
Get a ms_peptide_quant_key code identifying the individual match.
std::string | getLabelFreeVarMods () const
Get the variable modification identifiers, with the labels removed.
int | getLastXicScanId () const
Get the last scan of all the scans processed in the search for an XIC peak. Can be a wide region..
int | getNumComponents () const
Get the number of components associated with this match.
int | getNumHits () const
Get the number of protein hits associated with this match.
int | getNumPeptideRatios () const
Get the number of peptide ratios associated with this match.
ms_ms1quant_match_ratio | getPeptideRatio (const std::string &ratioName) const
Get a peptide ratio value for the ratio name.
ms_ms1quant_match_ratio | getPeptideRatio (int index) const
Get a peptide ratio associated with this match by its index (0..getNumPeptideRatios-1).
std::string | getPeptideString () const
Get the peptide sequence in 1-letter code.
const ms_matrix & | getPerfectObservedMatrix () const
Get the predicted stick spectrum for measured amounts of each component.
const ms_matrix & | getPredictionMatrix () const
Get the predicted stick spectrum for equal amounts of each component.
std::string | getReadableLabelFreeVarMods () const
Get the readable variable modifications.
std::string | getVarMods () const
Get the variable modifications encoded as string of integers.
bool | hasComponent (std::string componentName) const
Returns true if the matched peptide has the component.
bool | hasIdentifiedComponent () const
Check if the match has any component that was identified by Mascot.
bool | hasPeptideRatio (const std::string &ratioName) const
Returns true if the match has a peptide ratio value for the ratio name.
bool | isHitRatioExcluded (const std::string &ratioName, int hitId, int memberNumber) const
Returns true if the match ratio is excluded from a hit.
bool | isHitRatioOutlier (const std::string &ratioName, int hitId, int memberNumber) const
Returns true if the match ratio is an outlier for a hit.
bool | isHitRatioUsedForAverage (const std::string &ratioName, int hitId, int memberNumber) const
Returns true if the match ratio is used in the average quantitation protocol for a hit.
bool | removeComponent (const std::string &componentName)
Primarily for replicate where we want to remove components that are found in other files.
void | setHitRatioExcluded (const std::string &ratioName, int hitId, int memberNumber)
Set the match ratio to be excluded from a hit.
void | setHitRatioOutlier (const std::string &ratioName, int hitId, int memberNumber)
Set the match ratio to be an outlier for a hit.

Static Public Member Functions

static chargeType | getCodeFromXml (std::string text)
Get the charge type code for an XML attribute value.
static std::string | getXmlCode (chargeType code)
Get the XML attribute value for a charge type code.

Detailed Description

A peptide that has been matched, in quantitation, to a protein hit.

Each protein can be matched to a number of peptides. The quantitation ratios of these peptides are used to determine the quantitaion ratio of the protein.

A peptide match can have a number of labelled components (such as 'heavy' and 'light') that are determined by the modifications.

This is stored in XML in a "peptideMatch" entity.

Member Enumeration Documentation

◆ chargeType

enum chargeType

Types of charge state used when matching.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
CHARGETYPE_ORIGINAL | Charge state found in result file.
CHARGETYPE_ALL | Match created in all charge states.

Constructor & Destructor Documentation

◆ ms_ms1quant_match() [1/2]

ms_ms1quant_match ( )

Default constructor; for standard library collections.

Assigns reasonable default values to all internal members.

◆ ms_ms1quant_match() [2/2]

ms_ms1quant_match ( const ms_ms1quant_match_body & body )

Populated constructor, linked to loaded data.

Parameters
body The data loaded from the result file.

Member Function Documentation

◆ addComponent()

ms_ms1quant_match_component * addComponent ( const matrix_science::ms_ms1quant_match_component & component )

Add a new component to the list. Must already have a component to base this one on.

Primarily for replicate. Take the first component for this match, make a copy of it and add it to the match, leving the it's origin unaltered

Parameters
component is the new component to be added
Returns
a pointer to the newly created component

◆ addCreatedComponent() [1/2]

ms_ms1quant_match_component * addCreatedComponent ( const matrix_science::ms_ms1quant_match_component & component )

Add a new component to the list. Must already have a component to base this one on.

Primarily for replicate. Take the first component for this match, make a copy of it and add it to the match, and set it's origin to be 'created'

Parameters
component is the new component to be added
Returns
a pointer to the newly created component

◆ addCreatedComponent() [2/2]

ms_ms1quant_match_component * addCreatedComponent ( const std::string & componentName )

Primarily for replicate. Take the first component for this match, make a copy of it and add it to the match

Parameters
componentName is the name of the new component to be added
Returns
a pointer to the newly created component

◆ allComponentsIdentified()

bool allComponentsIdentified ( ) const

Check if all the match components were identified by Mascot.

Tests to see if all the components were identified by Mascot. This method can return false event if hasIdentifiedComponent() returns true, as that method only requires one of the components to have been identified

See also
hasIdentifiedComponent()
Returns
True if all the components were identified by Mascot matches, false if not

◆ clearHitRatioExcluded()

void clearHitRatioExcluded | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  |

Clear the match ratio from being excluded from a hit.

Clears any excluded status for the match in the specified protein ratio.

See also
setHitRatioExcluded()
Parameters
ratioName | The name of the ratio.
hitId | One based protein hit number.
memberNumber | One based family member number.

◆ clearHitRatioOutlier()

void clearHitRatioOutlier | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  |

Clear the match ratio from being an outlier for a hit.

Data for a protein hit to which the peptide match is assigned.

Parameters
ratioName | The name of the ratio.
hitId | Protein hit number.
memberNumber | Family member number.

◆ getChargeState()

int getChargeState ( ) const

Get the ion charge state.

Returns
The ion charge state.

◆ getChargeStateData()

matrix_science::ms_ms1quant_charge_state getChargeStateData ( ) const

Get the charge state data.

Returns
The charge state data.

◆ getChargeType()

ms_ms1quant_match::chargeType getChargeType ( ) const

Get whether this charge state has been extrapolated from the charge state of a Mascot match.

Returns
CHARGETYPE_ORIGINAL if this charge state was found in the result file, otherwise CHARGETYPE_ALL as it has been extrapolated from the charge state of a Mascot match.

◆ getCodeFromXml()

ms_ms1quant_match::chargeType getCodeFromXml ( std::string text )
static

Get the charge type code for an XML attribute value.

Parameters
text The string used to encode the charge type in the XML file.
Returns
The charge type corresponding to the XML encoded string.

◆ getComponent() [1/2]

ms_ms1quant_match_component getComponent ( int index ) const

Get a component associated with this match by its index (1..getNumComponents).

Parameters
index An index (1..getNumComponents()) into the components associated with the peptide match.
Returns
The component.

◆ getComponent() [2/2]

ms_ms1quant_match_component getComponent ( std::string componentName ) const

Get a component of the matched peptide.

Parameters
componentName The name of component to be retrieved, e.g. "Heavy".
Returns
The component.

◆ getConciseLabelFreeVarMods()

std::string getConciseLabelFreeVarMods ( ) const

Get the concise (un-numbered) readable variable modifications.

For example: "Dimethyl (KR); Acetyl (K); Methyl (KR)".

Returns
A semi-colon separated text string.

◆ getCorrectionMatrix()

const matrix_science::ms_matrix & getCorrectionMatrix ( ) const

Get the correction matrix A, product of J (averagine) and I (impurity).

Returns
The correction matrix

◆ getDataSourceId()

int getDataSourceId ( ) const

Get the data source identifier if processed independantly.

Returns
The data source identifier, if processed independantly.

◆ getDisplayIntensity()

double getDisplayIntensity ( ) const

Get the total intensity of fitted peaks across the XIC peak.

Returns
The total intensity of fitted peaks across the XIC peak.

◆ getFirstXicScanId()

int getFirstXicScanId ( ) const

Get the first scan of all the scans processed in the search for an XIC peak. Can be a wide region.

Returns
The identifier of the first scan of all the scans processed in the search for an XIC peak. Can be a wide region.

◆ getHit()

const matrix_science::ms_protein * getHit ( int index1 ) const

Get a protein hit associated with this match by its index (1..getNumHits).

Parameters
index1 An index (1..getNumHits()) into the protein hits associated with the peptide match.
Returns
A protein hit, or null if the index is out of range.

◆ getKey()

matrix_science::ms_peptide_quant_key getKey ( ) const

Get a ms_peptide_quant_key code identifying the individual match.

Returns
The identifier for the match within the quantitation results.

◆ getLabelFreeVarMods()

std::string getLabelFreeVarMods ( ) const

Get the variable modification identifiers, with the labels removed.

For example: "00000100000043000009a2000".

Returns
A string of letters representing the modifications.

◆ getLastXicScanId()

int getLastXicScanId ( ) const

Get the last scan of all the scans processed in the search for an XIC peak. Can be a wide region..

Returns
The identifier of the last scan of all the scans processed in the search for an XIC peak. Can be a wide region.

◆ getNumComponents()

int getNumComponents ( ) const

Get the number of components associated with this match.

Returns
The number of components associated with the match.

◆ getNumHits()

int getNumHits ( ) const

Get the number of protein hits associated with this match.

Not all peptide matches are associated with every protein. This returns the number of proteins that are matched to this particular peptide and is typically less than the number of proteins in the peptide summary.

Returns
The number of protein hits associated with the match.

◆ getNumPeptideRatios()

int getNumPeptideRatios ( ) const

Get the number of peptide ratios associated with this match.

Returns
The number of peptide ratios associated with the match.

◆ getPeptideRatio() [1/2]

matrix_science::ms_ms1quant_match_ratio getPeptideRatio ( const std::string & ratioName ) const

Get a peptide ratio value for the ratio name.

Peptide ratio data that is independent of the assigned protein hit. To find out whether a match has been accepted or rejected under a particular protein hit, need to look under isHitRatioExcluded().

Parameters
ratioName The name of ratio to be searched for, e.g. "H/L".
Returns
The peptide match.

◆ getPeptideRatio() [2/2]

matrix_science::ms_ms1quant_match_ratio getPeptideRatio ( int index ) const

Get a peptide ratio associated with this match by its index (0..getNumPeptideRatios-1).

Parameters
index An index (0..getNumPeptideRatios()-1) into the peptide ratios associated with the match.
Returns
The peptide ratio.

◆ getPeptideString()

std::string getPeptideString ( ) const

Get the peptide sequence in 1-letter code.

Returns
The peptide sequence as a series of 1-letter codes.

◆ getPerfectObservedMatrix()

const matrix_science::ms_matrix & getPerfectObservedMatrix ( ) const

Get the predicted stick spectrum for measured amounts of each component.

Returns
The perfect observed matrix.

◆ getPredictionMatrix()

const matrix_science::ms_matrix & getPredictionMatrix ( ) const

Get the predicted stick spectrum for equal amounts of each component.

Returns
The prediction matrix

◆ getReadableLabelFreeVarMods()

std::string getReadableLabelFreeVarMods ( ) const

Get the readable variable modifications.

For example: "(1) Dimethyl (KR); (6) Acetyl (K); (9) Methyl (KR)".

Returns
A semi-colon separated text string.

◆ getVarMods()

std::string getVarMods ( ) const

Get the variable modifications encoded as string of integers.

Returns
The variable modifications encoded as string of integers.

◆ getXmlCode()

std::string getXmlCode ( ms_ms1quant_match::chargeType code )
static

Get the XML attribute value for a charge type code.

Some of the returned values include a substitution string of "%s" or "%d". These are replaced with a specific value in the created XML.

Parameters
code The charge type to get the XML excoding string for.
Returns
The string used to encode the charge type in the XML file.

◆ hasComponent()

bool hasComponent ( std::string componentName ) const

Returns true if the matched peptide has the component.

Parameters
componentName The name of component to be searched for, e.g. "Heavy".
Returns
True if the match has the component.

◆ hasIdentifiedComponent()

bool hasIdentifiedComponent ( ) const

Check if the match has any component that was identified by Mascot.

Returns
True if any component of the match has been identified.

◆ hasPeptideRatio()

bool hasPeptideRatio ( const std::string & ratioName ) const

Returns true if the match has a peptide ratio value for the ratio name.

Parameters
ratioName The name of ratio to be searched for, e.g. "H/L".
Returns
True if the ratio exists for the peptide match.

◆ isHitRatioExcluded()

bool isHitRatioExcluded | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  | const

Returns true if the match ratio is excluded from a hit.

Data for a protein hit to which the peptide match is assigned.

Parameters
ratioName | The name of the ratio.
hitId | Protein hit number.
memberNumber | Family member number.
Returns
True if the match ratio is excluded from this hit.

◆ isHitRatioOutlier()

bool isHitRatioOutlier | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  | const

Returns true if the match ratio is an outlier for a hit.

Data for a protein hit to which the peptide match is assigned.

Parameters
ratioName | The name of the ratio.
hitId | Protein hit number.
memberNumber | Family member number.
Returns
True if the match ratio is an outlier for the hit.

◆ isHitRatioUsedForAverage()

bool isHitRatioUsedForAverage | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  | const

Returns true if the match ratio is used in the average quantitation protocol for a hit.

Data for a protein hit to which the peptide match is assigned.

Parameters
ratioName | The name of the ratio.
hitId | Protein hit number.
memberNumber | Family member number.
Returns
True if the match ratio is used in the average protocol for this hit.

◆ removeComponent()

bool removeComponent ( const std::string & componentName )

Primarily for replicate where we want to remove components that are found in other files.

Parameters
componentName is the name of the new component to be added
Returns
true if the component was removed

◆ setHitRatioExcluded()

void setHitRatioExcluded | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  |

Set the match ratio to be excluded from a hit.

Data for a protein hit to which the peptide match is assigned.

See also
clearHitRatioExcluded()
Parameters
ratioName | The name of the ratio.
hitId | One based protein hit number.
memberNumber | One based family member number.

◆ setHitRatioOutlier()

void setHitRatioOutlier | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  |

Set the match ratio to be an outlier for a hit.

Data for a protein hit to which the peptide match is assigned.

Parameters
ratioName | The name of the ratio.
hitId | Protein hit number.
memberNumber | Family member number.
The documentation for this class was generated from the following files:
  • ms_ms1quant_match.hpp
  • ms_ms1quant_match.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match_component Class Reference

  • matrix_science
  • ms_ms1quant_match_component
Public Member Functions | Protected Member Functions | List of all members
ms_ms1quant_match_component Class Reference
Quantitation analysis for Mascot Server and Distiller

A component within a match. More...

#include <ms_ms1quant_match_component.hpp>

Inherits ms_handle.

Public Member Functions

ms_ms1quant_match_component ()
Default constructor.
ms_ms1quant_match_component (const ms_ms1quant_match_component_body &body)
Populated constructor.
double | getAbsoluteValue (const int file_index=-1) const
Get the summed intensity values for this component across the XIC peak. Required for normalisation.
std::string | getComponent () const
Get the component.
int | getFileIndex (const int idx) const
Return the 1 based file_index.
double | getMatchedFraction (const int file_index=-1) const
Get the matched fraction for the specified raw file.
double | getMatchedRho (const int file_index=-1) const
Get the matched rho for the specified raw file.
double | getMoverz () const
Get the calculated m/z value.
int | getNumFileIndexesMatched () const
For replicate, using prefractionation, this can return a value greater than zero.
int | getNumPeptides (const int file_index=ms_quant_file_index::file_index_value_not_set) const
Get the number of related peptides.
int | getNumRanges (const int file_index=ms_quant_file_index::file_index_value_not_set) const
Get the number of ranges.
void | getPeptideKey (const int file_index, int index, int &q, int &p) const
Get a related peptide's feature key by its index (1..n).
void | getPeptideKey (int index, int &q, int &p) const
Get a related peptide's feature key by its index (1..n).
ms_ms1quant_match_range | getRange (const int file_index, int index) const
Get a range value by its index (1..n).
ms_ms1quant_match_range | getRange (int index) const
Get a range value by its index (1..n).
double | getRelativeMass () const
Get the relative mass value.
std::string | getSummedModsStr () const
Returns the string for any 'summed' modifications for this particular match.
std::string | getVarModsStr () const
Returns the string for any 'variable' modifications for this particular match.
ms_xic | getXic (const int file_index=ms_quant_file_index::file_index_value_not_set) const
Get the extracted ion chromatogram (XIC).
bool | hasAbsoluteValue (const int file_index=-1) const
Check if the absolute value is available.
bool | hasMatchedFraction (const int file_index=-1) const
Check if the matched fraction is available for the specified raw file.
bool | hasMatchedRho (const int file_index=-1) const
Check if the matched rho is available for the specified raw file.
bool | isComponentIdentified (const int file_index=-1) const
Check if the component has been identified.

Protected Member Functions

std::size_t getIdxFromFileIndex (const int file_index) const
Just used internally by inherited classes that need access to inherited XICs etc.

Detailed Description

A component within a match.

This is stored in XML in "partner" and "absoluteValue" entities.

Constructor & Destructor Documentation

◆ ms_ms1quant_match_component() [1/2]

ms_ms1quant_match_component ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_ms1quant_match_component() [2/2]

ms_ms1quant_match_component ( const ms_ms1quant_match_component_body & body )

Populated constructor.

Parameters
body The data loaded from the result file.

Member Function Documentation

◆ getAbsoluteValue()

double getAbsoluteValue ( const int file_index = -1 ) const

Get the summed intensity values for this component across the XIC peak. Required for normalisation.

If ratio values not are absolute use total intensity as absolute value

Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
The absolute ratio value.

◆ getComponent()

std::string getComponent ( ) const

Get the component.

Returns
The name of the component (e.g. "Heavy").

◆ getFileIndex()

int getFileIndex ( const int idx ) const

Return the 1 based file_index.

See getNumFileIndexesMatched()

Parameters
idx must be in the range 0.. getNumFileIndexesMatched()-1
Returns
the 1 based file index. This component could, for example, have file_index values of 1,5,9,13

◆ getIdxFromFileIndex()

std::size_t getIdxFromFileIndex ( const int file_index ) const
protected

Just used internally by inherited classes that need access to inherited XICs etc.

Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
a 0 based internal index into a member vector

◆ getMatchedFraction()

double getMatchedFraction ( const int file_index = -1 ) const

Get the matched fraction for the specified raw file.

This is only used for the replicate protocol where data sets have been merged. For the precursor protocol, use matrix_science::ms_ms1quant_charge_state::getMatchedFraction

Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
The matched fraction value.

◆ getMatchedRho()

double getMatchedRho ( const int file_index = -1 ) const

Get the matched rho for the specified raw file.

This is only used for the replicate protocol where data sets have been merged. For the precursor protocol, use matrix_science::ms_ms1quant_charge_state::getMatchedRho

Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
The matched rho value.

◆ getMoverz()

double getMoverz ( ) const

Get the calculated m/z value.

Returns
The m/z value.

◆ getNumFileIndexesMatched()

int getNumFileIndexesMatched ( ) const

For replicate, using prefractionation, this can return a value greater than zero.

For protocols other than replicate, this will always return 1.

For replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.

See also
getFileIndex()
Returns
the number of file_indexes

◆ getNumPeptides()

int getNumPeptides ( const int file_index = ms_quant_file_index::file_index_value_not_set ) const

Get the number of related peptides.

Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
The number of related peptides.

◆ getNumRanges()

int getNumRanges ( const int file_index = ms_quant_file_index::file_index_value_not_set ) const

Get the number of ranges.

Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
The number of ranges.

◆ getPeptideKey() [1/2]

void getPeptideKey | ( | const int | file_index,
 |  | int | index,
 |  | int & | q,
 |  | int & | p
 | ) |  | const

Get a related peptide's feature key by its index (1..n).

See Multiple return values in Perl, Java, Python and C#.

The returned keys can be used to get the ms_peptide using ms_mascotresults::getPeptide().

Parameters
file_index | is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
index | The index of the required peptide (1..getNumPeptides()).
q | The query number.
p | The rank.

◆ getPeptideKey() [2/2]

void getPeptideKey | ( | int | index,
 |  | int & | q,
 |  | int & | p
 | ) |  | const

Get a related peptide's feature key by its index (1..n).

See Multiple return values in Perl, Java, Python and C#.

The returned keys can be used to get the ms_peptide using ms_mascotresults::getPeptide().

Parameters
index | The index of the required peptide (1..getNumPeptides()).
q | The query number.
p | The rank.

◆ getRange() [1/2]

matrix_science::ms_ms1quant_match_range getRange | ( | const int | file_index,
 |  | int | index
 | ) |  | const

Get a range value by its index (1..n).

Parameters
file_index | is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
index | The index of the required range (1..getNumRanges()).
Returns
The ms_ms1quant_match_range.

◆ getRange() [2/2]

matrix_science::ms_ms1quant_match_range getRange ( int index ) const

Get a range value by its index (1..n).

Parameters
index The index of the required range (1..getNumRanges()).
Returns
The ms_ms1quant_match_range.

◆ getRelativeMass()

double getRelativeMass ( ) const

Get the relative mass value.

Returns
The relative mass value.

◆ getSummedModsStr()

std::string getSummedModsStr ( ) const

Returns the string for any 'summed' modifications for this particular match.

See ms_peptide::getSummedModsStr for details of the format

Returns
the encoded summed mods string

◆ getVarModsStr()

std::string getVarModsStr ( ) const

Returns the string for any 'variable' modifications for this particular match.

See ms_peptide::getVarModsStr for details of the format

Returns
the encoded variable mods string

◆ getXic()

matrix_science::ms_xic getXic ( const int file_index = ms_quant_file_index::file_index_value_not_set ) const

Get the extracted ion chromatogram (XIC).

Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
The ms_xic.

◆ hasAbsoluteValue()

bool hasAbsoluteValue ( const int file_index = -1 ) const

Check if the absolute value is available.

Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
True if the absolute value is available (some older datasets may not hold the value).

◆ hasMatchedFraction()

bool hasMatchedFraction ( const int file_index = -1 ) const

Check if the matched fraction is available for the specified raw file.

This is only used for the replicate protocol where data sets have been merged. For the precursor protocol, use matrix_science::ms_ms1quant_charge_state::getMatchedFraction

Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
True if the matched fraction value is available.

◆ hasMatchedRho()

bool hasMatchedRho ( const int file_index = -1 ) const

Check if the matched rho is available for the specified raw file.

This is only used for the replicate protocol where data sets have been merged. For the precursor protocol, use matrix_science::ms_ms1quant_charge_state::getMatchedRho

Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
True if the matchedRho value is available.

◆ isComponentIdentified()

bool isComponentIdentified ( const int file_index = -1 ) const

Check if the component has been identified.

Parameters
file_index is used for replicate where a component comprises multiple raw data files, for example using prefractionation. This value defaults to ms_quant_file_index::file_index_value_not_set where the component match just originates from one data file
Returns
True if the component has been identified.
The documentation for this class was generated from the following files:
  • ms_ms1quant_match_component.hpp
  • ms_ms1quant_match_component.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match_range Class Reference

  • matrix_science
  • ms_ms1quant_match_range
Public Member Functions | List of all members
ms_ms1quant_match_range Class Reference
Quantitation analysis for Mascot Server and Distiller

A range for a component of a peptide match. More...

#include <ms_ms1quant_match_range.hpp>

Inherits ms_handle.

Public Member Functions

ms_ms1quant_match_range ()
Default constructor.
ms_ms1quant_match_range (const ms_ms1quant_match_range_body &body)
Construct a populated ms_ms1quant_match_range.
ms_ms1quant_match_range (int scanId, double rt)
Construct a range including a single scan.
void | extend (int scanId, double rt)
Extend the range.
void | getRt (double &start, double &end) const
Get the retention times for the first and last scans.
void | getScan (int &start, int &end) const
Get the scan numbers for the first and last scans.

Detailed Description

A range for a component of a peptide match.

This is stored in XML in a "range" entity.

Constructor & Destructor Documentation

◆ ms_ms1quant_match_range() [1/2]

ms_ms1quant_match_range ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_ms1quant_match_range() [2/2]

ms_ms1quant_match_range ( const ms_ms1quant_match_range_body & body )

Construct a populated ms_ms1quant_match_range.

Parameters
body The data loaded from the result file.

Member Function Documentation

◆ getRt()

void getRt | ( | double & | start,
 |  | double & | end
 | ) |  | const

Get the retention times for the first and last scans.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | start | Filled in with the retention time of the start of the range.
[out] | end | Filled in with the retention time of the end of the range.

◆ getScan()

void getScan | ( | int & | start,
 |  | int & | end
 | ) |  | const

Get the scan numbers for the first and last scans.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | start | Filled in with the first scan identifier in the range.
[out] | end | Filled in with the last scan identifier in the range.
The documentation for this class was generated from the following files:
  • ms_ms1quant_match_range.hpp
  • ms_ms1quant_match_range.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match_ratio Class Reference

  • matrix_science
  • ms_ms1quant_match_ratio
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_ms1quant_match_ratio Class Reference
Quantitation analysis for Mascot Server and Distiller

The status resulting ratio for a peptide found in a match. More...

#include <ms_ms1quant_match_ratio.hpp>

Inherits ms_handle.

Public Types

enum ratioStatusCode {
RS_EMPTY = 0 ,
RS_OK = 1 ,
RS_ISOLATEDPRECURSORFAILED = 2 ,
RS_INTEFERENCEFAILED = 4 ,
RS_NODATA = 8 ,
RS_FITEXYSIGMA = 16 ,
RS_NEGATIVERATIO = 32 ,
RS_INFINITERATIO = 64 ,
RS_ZERORATIO = 128 ,
RS_DO_NOT_USE = 256 ,
RS_TOTALINTENSITYFAILED = 512 ,
RS_VALID_FLAGS = RS_OK | RS_ISOLATEDPRECURSORFAILED | RS_INTEFERENCEFAILED | RS_NODATA | RS_FITEXYSIGMA | RS_NEGATIVERATIO | RS_INFINITERATIO | RS_ZERORATIO | RS_TOTALINTENSITYFAILED
}
Status codes from fitting ratios. More...

Public Member Functions

ms_ms1quant_match_ratio ()
Default constructor.
ms_ms1quant_match_ratio (const ms_ms1quant_match_ratio_body &body)
Populated constructor, linked to loaded data.
bool | getFitexy (ms_fitexy_result &value) const
Get the fitexy value. Returns true if a fitexy value is set.
double | getQuality () const
Get the quality of the match.
std::string | getRatioName () const
Returns the ratio name.
int | getStatus () const
Get the status composite value.
std::vector< ratioStatusCode > | getStatusList () const
Get the status values. Each status in the list is a single bit.
double | getValue () const
Return the numerical value of the ratio.
bool | isIncluded () const
Returns true if the item should be included in calculations.
bool | isSet () const
Returns true if the item has a value set.
bool | isUsedForAverage () const
Returns true if the item is used in the average protocol for quantitation.
bool | isValid () const
Returns true if the item has a valid value.

Static Public Member Functions

static ratioStatusCode | getCodeFromXml (std::string text)
Get the status code for an XML attribute value.
static bool | getCodeInfo (ratioStatusCode code, const ms_quant_method &method, double &info)
Return true if the status is associated with further information.
static std::string | getXmlCode (ratioStatusCode code)
Get the XML attribute value for a status code.

Detailed Description

The status resulting ratio for a peptide found in a match.

This is stored in XML in a "originalRatio" entity.

Member Enumeration Documentation

◆ ratioStatusCode

enum ratioStatusCode

Status codes from fitting ratios.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Note that RS_FITEXYSIGMA maps to "StdErrAboveTreshold" which has always been misspelt.

The "XML text" is returned by matrix_science::ms_ms1quant_match_ratio::getXmlCode

The statuses get set by matrix_science::ms_ms1quant_match::applyThresholds()

Enumerator
RS_EMPTY | XML text: "". No status set.
RS_OK | XML text: "ok". OK.
RS_ISOLATEDPRECURSORFAILED | XML text: "AreaFractionBelowThreshold". Isolated precursor failed [extra information is option value 'isolated precursor threshold'].
RS_INTEFERENCEFAILED | XML text: "PeakCorrBelowThreshold". Inteference failed [extra information is option value 'matched rho'].
RS_NODATA | XML text: "RatioUndefined". No data.
RS_FITEXYSIGMA | XML text: "StdErrAboveTreshold". fitexy sigma [extra information is option value 'elution profile correlation threshold'].
RS_NEGATIVERATIO | XML text: "NegativeRatio". Negative ratio.
RS_INFINITERATIO | XML text: "InfiniteRatio". Infinite ratio.
RS_ZERORATIO | XML text: "ZeroRatio". Zero ratio.
RS_DO_NOT_USE | XML text: "". Do not use (outlier)
RS_TOTALINTENSITYFAILED | XML text: "TotalIntensityBelowThreshold" Total intensity failed [extra information is option value 'total intensity threshold'].

Constructor & Destructor Documentation

◆ ms_ms1quant_match_ratio() [1/2]

ms_ms1quant_match_ratio ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_ms1quant_match_ratio() [2/2]

ms_ms1quant_match_ratio ( const ms_ms1quant_match_ratio_body & body )

Populated constructor, linked to loaded data.

Parameters
body The data loaded from the result file.

Member Function Documentation

◆ getCodeFromXml()

matrix_science::ms_ms1quant_match_ratio::ratioStatusCode getCodeFromXml ( std::string text )
static

Get the status code for an XML attribute value.

Parameters
text The string used to encode the ratio status in the XML file.
Returns
The ratio status corresponding to the XML encoded string.

◆ getCodeInfo()

bool getCodeInfo | ( | ratioStatusCode | code,
 |  | const ms_quant_method & | method,
 |  | double & | info
 | ) |  |
static

Return true if the status is associated with further information.

Four status codes have further information associated with them:

  • RS_ISOLATEDPRECURSORFAILED: isolated precursor threshold.
  • RS_INTEFERENCEFAILED: matched rho.
  • RS_FITEXYSIGMA: elution profile correlation threshold.
  • RS_TOTALINTENSITYFAILED: total intensity threshold.
Parameters
code | The ratio status for which extra information is wanted.
method | The quantitation method.
info | Filled in with the value of the extra information.
Returns
True if there is extra information for this ratio status.

◆ getFitexy()

bool getFitexy ( matrix_science::ms_fitexy_result & value ) const

Get the fitexy value. Returns true if a fitexy value is set.

Parameters
value Filled in with the ms_fitexy_result, if any.
Returns
True if a fitexy value is set.

◆ getQuality()

double getQuality ( ) const

Get the quality of the match.

Std. Err. = sigb / abs(b) from fitexy. Perfect fit is 0.0.

Returns
The quality of the ratio.

◆ getRatioName()

std::string getRatioName ( ) const

Returns the ratio name.

Returns
The ratio name.

◆ getStatus()

int getStatus ( ) const

Get the status composite value.

Whether a peptide ratio is included or rejected when calculating a protein ratio.

These can be retrieved as a collection of separate values with getStatusList().

Returns
A bitwise OR of any number of ratioStatusCode values.

◆ getStatusList()

std::vector< ms_ms1quant_match_ratio::ratioStatusCode > getStatusList ( ) const

Get the status values. Each status in the list is a single bit.

These can be retrieved as a single composite value with getStatus().

Returns
A collection of the individual status values.

◆ getValue()

double getValue ( ) const

Return the numerical value of the ratio.

Returns
The value of the ratio.

◆ getXmlCode()

std::string getXmlCode ( ratioStatusCode code )
static

Get the XML attribute value for a status code.

Parameters
code The ratio status to get the XML excoding string for.
Returns
The string used to encode the ratio status in the XML file.

◆ isIncluded()

bool isIncluded ( ) const

Returns true if the item should be included in calculations.

Returns
True if the item should be included in calculations.

◆ isSet()

bool isSet ( ) const

Returns true if the item has a value set.

Returns
True if the item has a value set.

◆ isUsedForAverage()

bool isUsedForAverage ( ) const

Returns true if the item is used in the average protocol for quantitation.

The Average protocol only uses a number of the the most intense peptides.

Returns
True if the item has been used in the Average protocol calculations.

◆ isValid()

bool isValid ( ) const

Returns true if the item has a valid value.

Returns
True if the item has a valid value.
The documentation for this class was generated from the following files:
  • ms_ms1quant_match_ratio.hpp
  • ms_ms1quant_match_ratio.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_peptide_status Class Reference

  • matrix_science
  • ms_ms1quant_peptide_status
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_ms1quant_peptide_status Class Reference
Quantitation analysis for Mascot Server and Distiller

An individual peptide's quantitation status. More...

#include <ms_ms1quant_peptide_status.hpp>

Inherits ms_handle.

Public Types

enum peptideStatus {
PS_OK = 0 ,
PS_EXPECTGREATERTHAN = 1 ,
PS_LESSTHANIDENTITY = 2 ,
PS_MINCHARGE = 3 ,
PS_NOTUNIQUE = 4 ,
PS_SCORELESSHOMOLOGY = 5 ,
PS_SCORELESSIDENTITY_NOHOMO = 6 ,
PS_SCORELESSTHRESHOLD = 7 ,
PS_EXCLUDE_LOCALDEF = 8 ,
PS_EXCLUDE_MODFILE = 9 ,
PS_EXCLUDE_UNMODIFIED = 10 ,
PS_NOTPARTOFQUANTITATION = 11 ,
PS_DUPLICATESAMEQUERY = 12 ,
PS_NOMATCHINTHISFRACTION = 13 ,
PS_MAX = 14
}
Status codes from fitting peptides. More...

Public Member Functions

ms_ms1quant_peptide_status ()
Default constructor.
ms_ms1quant_peptide_status (const ms_ms1quant_peptide_status_body &body)
Populated constructor, linked to loaded data.
std::string | getComponent () const
Get the component for the peptide hit.
int | getQuery () const
Get the query for the peptide.
int | getRank () const
Get the rank for the peptide.
peptideStatus | getStatus () const
Get the status for the peptide hit.

Static Public Member Functions

static peptideStatus | getCodeFromXml (std::string str)
Get the status code for an XML attribute value.
static std::string | getXmlCode (peptideStatus code)
Get the XML attribute value for a status code.

Detailed Description

An individual peptide's quantitation status.

This is the status determined for the peptide during quantitation.

Member Enumeration Documentation

◆ peptideStatus

enum peptideStatus

Status codes from fitting peptides.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
PS_OK | No problem.
PS_EXPECTGREATERTHAN | The expectation is greater then 1.
PS_LESSTHANIDENTITY | The score is less than that required for identity.
PS_MINCHARGE | The charge state is less than the minimum required.
PS_NOTUNIQUE | The peptide is not unique.
PS_SCORELESSHOMOLOGY | The score is less than that required for homology.
PS_SCORELESSIDENTITY_NOHOMO | The score is less than that required for identity and there is no homology.
PS_SCORELESSTHRESHOLD | The score is less than the required threshold.
PS_EXCLUDE_LOCALDEF | The peptide is excluded due to a local definition.
PS_EXCLUDE_MODFILE | The peptide is excluded due to a modification file.
PS_EXCLUDE_UNMODIFIED | The peptide is excluded due to it being unmodified.
PS_NOTPARTOFQUANTITATION | The peptide is excluded because it is not part of quantitation.
PS_DUPLICATESAMEQUERY | The peptide is excluded because it is a duplicate in the same query.
PS_NOMATCHINTHISFRACTION | The peptide cannot be inferred because there is no match in this fraction.
PS_MAX | The number of values in this enumeration.

Constructor & Destructor Documentation

◆ ms_ms1quant_peptide_status() [1/2]

ms_ms1quant_peptide_status ( )

Default constructor.

Assigns reasonable default values to all internal members. The status is set to PS_NOTPARTOFQUANTITATION.

◆ ms_ms1quant_peptide_status() [2/2]

ms_ms1quant_peptide_status ( const ms_ms1quant_peptide_status_body & body )

Populated constructor, linked to loaded data.

Parameters
body The data loaded from the result file.

Member Function Documentation

◆ getCodeFromXml()

ms_ms1quant_peptide_status::peptideStatus getCodeFromXml ( std::string str )
static

Get the status code for an XML attribute value.

Some of the returned values include a substitution string of "%s" or "%d". The text is decoded based on the value up until the first substitution position.

Parameters
str The string used to encode the status value in the XML file.
Returns
The peptide status corresponding to the XML encoded string.

◆ getComponent()

std::string getComponent ( ) const

Get the component for the peptide hit.

Returns
The component (e.g. "Heavy") for the peptide component.

◆ getQuery()

int getQuery ( ) const

Get the query for the peptide.

Returns
The query number.

◆ getRank()

int getRank ( ) const

Get the rank for the peptide.

Returns
The rank within the query.

◆ getStatus()

matrix_science::ms_ms1quant_peptide_status::peptideStatus getStatus ( ) const

Get the status for the peptide hit.

Returns
The status for the peptide hit.

◆ getXmlCode()

std::string getXmlCode ( ms_ms1quant_peptide_status::peptideStatus code )
static

Get the XML attribute value for a status code.

Some of the returned values include a substitution string of "%s" or "%d". These are replaced with a specific value in the created XML.

Parameters
code The peptide status to get the XML excoding string for.
Returns
The string used to encode the status value in the XML file.
The documentation for this class was generated from the following files:
  • ms_ms1quant_peptide_status.hpp
  • ms_ms1quant_peptide_status.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_time_align Class Reference

  • matrix_science
  • ms_ms1quant_time_align
Public Types | Public Member Functions | Protected Member Functions | List of all members
ms_ms1quant_time_align Class Reference
Quantitation analysis for Mascot Server and Distiller

Time alignment between multiple runs (raw files) is performed in Mascot Distiller for label free quantitation. More...

#include <ms_ms1quant_time_align.hpp>

Inheritance diagram for ms_ms1quant_time_align:
[legend]
Collaboration diagram for ms_ms1quant_time_align:
[legend]

Public Types

typedef std::vector< std::vector< std::map< double, double > > > | featureWidths_t
[prj][m/z bin][rt->width]
typedef std::map< int, std::vector< int > > | fractionToSubProject_t
the vector for each fraction contains 0 based subProject numbers and fraction numbers don't need to be sequential, hence the map
enum status_t {
ST_TA_NO_DATA ,
ST_TA_LOADED_FROM_XML ,
ST_TA_LOADED_FROM_CDB ,
ST_TA_CALCULATED
}

Public Member Functions

ms_ms1quant_time_align (const int binSize=12)
Default constructor.
ms_ms1quant_time_align (const ms_ms1quant_time_align_body &body)
Populated constructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
bool | calculateFromConsensuValues (bool replaceExisting=false)
A retention time shift is calculated by the shift from project A to the consensus and then subtracting the shift from the consensus to project B. This.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::string | getAlgorithmName () const
Return the name of the algorithm used for calculating the time alignment.
int | getBinSize () const
Return the value supplied in the constructor, or loaded from an xml or cdb file.
ms_ms1quant_time_align_limits & | getCombinedLimits (const int fractionNum)
The m/z and retention time limits for each fraction are calculated from the limits for each rawfile and search results file for that fraction.
ms_ms1quant_time_align_limits | getCombinedLimits (const int fractionNum) const
The m/z and retention time limits for each fraction are calculated from the limits for each rawfile and search results file for that fraction.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
double | getEstimatedFeatureWidth (const int subProjectId, const double mOverZ, const double rt) const
For label free, return the estimated width of an XIC for a given mOverZ and retention time.
bool | getEvaluation (const int subProject, double &meanErrorsRaw, double &meanErrorsAligned, double &stdevErrorsRaw, double &stdevErrorsAligned, double &pearsonCoefficientRaw, double &pearsonCoefficientAligned)
const featureWidths_t & | getFeatureWidths () const
Returns the multidimentional vector that has the feature widths for each project.
std::vector< std::vector< std::vector< double > > > & | getFinalResults ()
const std::vector< std::vector< std::vector< double > > > & | getFinalResults () const
fractionToSubProject_t | getFractionToSubProjectMap () const
Return the map to enable looking up a list of sub projects for each fraction.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
double | getRToffset (const int myProjectId, const int otherProjectId, const double rtInOtherProject, const double mOverZ) const
Get the offset between two projects.
const std::vector< std::vector< std::vector< double > > > & | getShiftsFromConsensus () const
Returns the vector that has all the offsets from a consensus to a specified project.
const std::vector< std::vector< std::vector< double > > > & | getShiftsToConsensus () const
Returns the vector that has all the offsets from one project to a consensus.
status_t | getStatus (void) const
Get the status of the data.
std::string | getStatusAsText (void) const
Get the status of the data as text for a message.
const std::vector< int > | getSubProjectToFractionMap () const
Return a vector containing the fraction number that each subproject belongs to.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | loadXmlFile (const std::string &xmlFilename, const std::string &schemaDirectory)
Populate the object from an XML file.
bool | saveXmlFile (const std::string &xmlFilename, const std::string &schemaDirectory) const
Save just the time alignment data to an XML file.
void | setAlgorithmName (const char *algorithmName)
void | setAverageFeatureWidths (const std::vector< double > &featureWidths)
For supervised time alignment, a single feature width per subproject is used.

Protected Member Functions

void setEvaluation (int subProject, double meanErrorsRaw, double meanErrorsAligned, double stdevErrorsRaw, double stdevErrorsAligned, double pearsonCoefficientRaw, double pearsonCoefficientAligned)

Detailed Description

Time alignment between multiple runs (raw files) is performed in Mascot Distiller for label free quantitation.

The time alignment results are stored within a .rov file in Distiller 2.9 and later.

See: ms_ms1quantitation::getTimeAlignmentData() for how to obtain this object. Alternatively, create an empty object and then call ms_ms1quant_time_align::loadXmlFile()

For example code, see Examples for the Mascot Parser quantitation module

Member Enumeration Documentation

◆ status_t

enum status_t

Flags used to determine whether time alignment needs to be performed (again)

Enumerator
ST_TA_NO_DATA | No time alignment data. If the protocol is replicate, this indicates time alignment still needs to be performed. Time alignment is not performed for other protocols.
ST_TA_LOADED_FROM_XML | The time alignment data has been loaded from an xml so does not need to be recalculated.
ST_TA_LOADED_FROM_CDB | The time alignment data has been loaded from a cdb file so does not need to be recalculated.
ST_TA_CALCULATED | The time alignment data has been calculated and is in memory.

Constructor & Destructor Documentation

◆ ms_ms1quant_time_align()

ms_ms1quant_time_align ( const int binSize = 12 )

Default constructor.

The constructor will normally be called internally in Parser. See: ms_ms1quantitation::getTimeAlignmentData() for how to obtain this object. Alternatively, use this constructor and then call ms_ms1quant_time_align::loadXmlFile()

Parameters
binSize defaults to 12 daltons

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getAlgorithmName()

std::string getAlgorithmName ( ) const

Return the name of the algorithm used for calculating the time alignment.

Brief descriptive text that describes the algorithm used for the time alignment.

Currently restricted to "Unsupervised" or "Supervised"

Returns
the name of the type of algorithm used.

◆ getBinSize()

int getBinSize ( ) const

Return the value supplied in the constructor, or loaded from an xml or cdb file.

For time alignment, m/z values are binned together. This is the size of each bin. Spectra with precursors in the same 'bin' will have the same time alignment shift.

Returns
the bin size

◆ getCombinedLimits() [1/2]

ms_ms1quant_time_align_limits & getCombinedLimits ( const int fractionNum )

The m/z and retention time limits for each fraction are calculated from the limits for each rawfile and search results file for that fraction.

Parameters
fractionNum can be obtained by calling getSubProjectToFractionMap()
Returns
the limits for the specified fraction

◆ getCombinedLimits() [2/2]

ms_ms1quant_time_align_limits getCombinedLimits ( const int fractionNum ) const

The m/z and retention time limits for each fraction are calculated from the limits for each rawfile and search results file for that fraction.

Parameters
fractionNum can be obtained by calling getSubProjectToFractionMap()
Returns
the limits for the specified fraction

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getEstimatedFeatureWidth()

double getEstimatedFeatureWidth | ( | const int | subProjectId,
 |  | const double | mOverZ,
 |  | const double | rt
 | ) |  | const

For label free, return the estimated width of an XIC for a given mOverZ and retention time.

Used in label free quantitation (Replicate, not Average). Should only be used where a retention time is predicted based on time alignment. If a match has been found from a Mascot database search, we should be confident that we can start searching for the XIC from that retention time. If the the retention time has been predicted by the time alignment algorithm, then it isn't safe to assume that the predicted point will be in the XIC. Safer to use a range, but we need an estimate of that range, and that is what is returned by this function.

The retention time of the query in another subproject is transformed into the retention time passed to this function by calling getRToffset() , so rt is not going to be an exact value, and it's unlikely that there will be a 'feature' in this subproject at that retention time. So, this function looks for the closest retention time.

It can't be assumed that all subprojects will have the same number of bins. For example, another subproject may have a peptide with m/z 5000 but this subproject may have only found (in the crude feature finding) values up to a maximum m/z 4800. In this case, the highest bin is used.

If there are no bins for a specific subproject, or an invalid subProjectId is passed, then zero will be returned.

For Waters MS^E DIA projects, it's possible to get LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE1 debug messages for some lower mass pepetides. This is because an "average" charge will have been rounded up to the nearest integer, and matrix_science::ms_ms1quant_match_component_body::updateMoverZ() is called and therefore, the value returned by matrix_science::ms_ms1quant_match_component::getMoverz() may be lower than any of the precursor values in the 'survey' scans. If this happens, the debug message is generated, and the nearest bin is used. This should give a very close approximation to the proper value, and the debug message can safely be ignored by the client application.

Logging, warnings and errors:
ms_log::LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE1
ms_errs::ERR_MSP_MS1QUANT_NO_EST_WIDTH
ms_errs::ERR_MSP_MS1QUANT_INVALID_PROJECT_ID
Parameters
[in] | subProjectId | is a 1 based sub project number
[in] | mOverZ | is the precursor m/z value. m/z values are 'binned' so similar m/z values may return the same width
[in] | rt | is the predicted retention time of the ms/ms spectrum
Returns
the estimated feature width in seconds

◆ getEvaluation()

bool getEvaluation | ( | const int | subProject,
 |  | double & | meanErrorsRaw,
 |  | double & | meanErrorsAligned,
 |  | double & | stdevErrorsRaw,
 |  | double & | stdevErrorsAligned,
 |  | double & | pearsonCoefficientRaw,
 |  | double & | pearsonCoefficientAligned
 | ) |  |

See Multiple return values in Perl, Java, Python and C#.

Use these values to assess how good the alignment is before and after the optimised shift has been found using a measure of correlation between the two datasets. The Pearson coefficient is a number between -1 and 1 where -1 is a perfect negative correlation, zero indicates no correlation and 1 is a perfect positive correlation. The correlation is a suitable test for alignment because, in quantitation tests, the datasets are likely to have some biological difference between them due to the test parameters. The correlation will still return a positive correlation even if the peak intensity for one dataset is much smaller than the other.

If the pearsonCoefficientRaw is close to zero (say -0.1 to +0.1) then the two datasets are very dissimilar. It's possible to then flag to the user that they may have loaded two completely unrelated datasets into the analysis by mistake. Also if pearsonCoefficientAligned isn't very high (say less than 0.8) the user can be warned that the alignment process hasn't worked very well and they may want to use a different method.

The correlation coefficient value can be used to determine if the time alignment operation has improved the correlation (and therefore alignment). Some threshold values can be defined to warn the user if the alignment is poor before and/or after the alignment operation, or even if two completely unrelated datasets have been supplied to the algorithm.

For each 'fraction', a consensus time alignment is calculated. For each subproject, the shift from the consensus to the subproject is calculated. The values here are for the correlation between the consensus and the project.

The 'raw' values are the intensity values from each scan and subproject or fraction. The aligned values are the intensity values after all optimised time shifts have been applied.

Parameters
[in] | subProject | is the one based subproject number
[out] | meanErrorsRaw | is the mean average of the absolute difference between the consensus and raw values for each subproject and fraction
[out] | meanErrorsAligned | is the mean average of the absolute difference between the consensus and aligned values for each subproject and fraction
[out] | stdevErrorsRaw | is the standard deviation of the difference between the consensus and raw values for each subproject and fraction
[out] | stdevErrorsAligned | is the standard deviation of the difference between the consensus and aligned values for each subproject and fraction
[out] | pearsonCoefficientRaw | is the Pearson correlation coefficient between the consensus and raw values for each subproject and fraction
[out] | pearsonCoefficientAligned | is the Pearson correlation coefficient between the consensus and aligned values for each subproject and fraction
Returns
true if subProject >= 1 and <= numSubProjects and data has been loaded or calculated

◆ getFeatureWidths()

const ms_ms1quant_time_align::featureWidths_t & getFeatureWidths ( ) const

Returns the multidimentional vector that has the feature widths for each project.

To access the correct map/dictionary use the return value with indexes: [prj][bin] where

  • prj is the zero based subproject number
  • bin is the zero based m/z bin number. A value of 0 specifies that the bin number is ms_ms1quant_time_align_limits::getCombinedMinBinNum. The bin size can be found from getBinSize(), so to find the index to use for a specific mOverZ value, use: int(int(mOverZ) / getBinSize()) - getCombinedMinBinNum()

The returned map/dictionary will have a set of values mapping specific retention times to widths

Returns
a 2D vector accessed by: [prj][m/z bin] where the value will be a map (dictionary) of retention_time to width (in seconds)

◆ getFinalResults() [1/2]

std::vector< std::vector< std::vector< double > > > & getFinalResults ( )
Deprecated:
This function is deprecated and now calls the more accurately named getShiftsToConsensus()

◆ getFinalResults() [2/2]

const std::vector< std::vector< std::vector< double > > > & getFinalResults ( ) const
Deprecated:
This function is deprecated and now calls the more accurately named getShiftsToConsensus()

◆ getFractionToSubProjectMap()

ms_ms1quant_time_align::fractionToSubProject_t getFractionToSubProjectMap ( ) const

Return the map to enable looking up a list of sub projects for each fraction.

See also
getSubProjectToFractionMap() The vector for each fraction contains 0 based subProject numbers and fraction numbers don't need to be sequential, hence the use of a map (dictionary) rather than a vector
Returns
the map of fraction to subproject

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getRToffset()

double getRToffset | ( | const int | myProjectId,
 |  | const int | otherProjectId,
 |  | const double | rtInOtherProject,
 |  | const double | mOverZ
 | ) |  | const

Get the offset between two projects.

Returns the estimated retention time offset between two projects for a given m/z value. To find a predicted retention time in myProject, call this function and then add the returned offset to the rtInOtherProject

This is implemented by finding the value in the array returned by getShiftsToConsensus() for otherProjectId and adding the value in the array returned by getShiftsFromConsensus() for myProjectId.

Both projects must belong to the same fraction for this to be meaningful.

For Waters MS^E DIA projects, it's possible to get LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE debug messages for some lower mass pepetides. This is because an "average" charge will have been rounded up to the nearest integer, and matrix_science::ms_ms1quant_match_component_body::updateMoverZ() is called and therefore, the value returned by matrix_science::ms_ms1quant_match_component::getMoverz() may be lower than any of the precursor values in the 'survey' scans. If this happens, the debug message is generated, and the nearest bin is used. This should give a very close approximation to the proper value, and the debug message can safely be ignored by the client application.

Logging, warnings and errors:
ms_errs::ERR_MSP_MS1QUANT_RTOFFSET_DIFF_FRACT
ms_errs::ERR_MSP_MS1QUANT_TIME_ALIGN_INDEX
ms_log::LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE
ms_log::LOGMSG_QUANT_RT_OFFSET_LOOKUP
Parameters
myProjectId | is a zero based
otherProjectId | is a zero based
rtInOtherProject | is the retention time in the other project which is to be 'aligned' to a retention time in my project
mOverZ | is required because alignment is done in m/z bins
Returns
the offset

◆ getShiftsFromConsensus()

const std::vector< std::vector< std::vector< double > > > & getShiftsFromConsensus ( ) const

Returns the vector that has all the offsets from a consensus to a specified project.

Return a read-only 3D vector that should be accessed with [prj][bin][rt] where

  • prj is the zero based subproject number
  • bin is the zero based m/z bin number. A value of 0 specifies that the bin number is ms_ms1quant_time_align_limits::getCombinedMinBinNum. The bin size can be found from getBinSize(), so to find the index to use for a specific mOverZ value, use: int(int(mOverZ) / getBinSize()) - getCombinedMinBinNum()
  • rt is the retention time rounded to an integer.

The value in the array at those indexes is the predicted retention time shift from the 'consensus' to [prj].

To find the predicted retention time shift between project 'A' and project 'B', call getRToffset()

Returns
a 3D vector that should be accessed with [prj][bin][rt]

◆ getShiftsToConsensus()

const std::vector< std::vector< std::vector< double > > > & getShiftsToConsensus ( ) const

Returns the vector that has all the offsets from one project to a consensus.

Return a read-only 3D vector that should be accessed with [prj][bin][rt] where

  • prj is the zero based subproject number
  • bin is the zero based m/z bin number. A value of 0 specifies that the bin number is ms_ms1quant_time_align_limits::getCombinedMinBinNum. The bin size can be found from getBinSize(), so to find the index to use for a specific mOverZ value, use: int(int(mOverZ) / getBinSize()) - getCombinedMinBinNum()
  • rt is the retention time rounded to an integer.

The value in the array at those indexes is the predicted retention time shift from [prj] to the 'consensus'.

To find the predicted retention time shift between project 'A' and project 'B', call getRToffset()

Returns
a 3D vector that should be accessed with [prj][bin][rt]

◆ getStatus()

ms_ms1quant_time_align::status_t getStatus ( void ) const

Get the status of the data.

When the object is initially constructed, it sets the status to ms_ms1quant_time_align::ST_TA_NO_DATA

A successful calls to loadXmlFile() will cause the flag to be set to ms_ms1quant_time_align::ST_TA_LOADED_FROM_XML and if the object is initialised from a CDB file it will be set to ms_ms1quant_time_align::ST_TA_LOADED_FROM_CDB If the data is calculated in msquantlib, the value is set to ms_ms1quant_time_align::ST_TA_CALCULATED

Returns
the current status of the object

◆ getStatusAsText()

std::string getStatusAsText ( void ) const

Get the status of the data as text for a message.

When the object is initially constructed, it sets the status to ms_ms1quant_time_align::ST_TA_NO_DATA

A successful calls to loadXmlFile() will cause the flag to be set to ms_ms1quant_time_align::ST_TA_LOADED_FROM_XML and if the object is initialised from a CDB file it will be set to ms_ms1quant_time_align::ST_TA_LOADED_FROM_CDB If the data is calculated in msquantlib, the value is set to ms_ms1quant_time_align::ST_TA_CALCULATED

Returns
the current status of the object as text that can be used in a log message

◆ getSubProjectToFractionMap()

const std::vector< int > getSubProjectToFractionMap ( ) const

Return a vector containing the fraction number that each subproject belongs to.

See also
getFractionToSubProjectMap()
Returns
a vector of the size identical to the number of subprojects. The offset into the vector is therefore zero based, and the values are the fraction numbers for each subproject.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ loadXmlFile()

bool loadXmlFile | ( | const std::string & | xmlFilename,
 |  | const std::string & | schemaDirectory
 | ) |  |

Populate the object from an XML file.

This function is used to load the time alignment data as a discrete XML file.

If this function is successful, it will return true and the value returned by getStatus() will be ms_ms1quant_time_align::ST_TA_LOADED_FROM_XML

Parameters
xmlFilename | The path and filename of the file to load
schemaDirectory | is the directory which will contain the distiller_time_align_1.xsd file
Returns
true if the file is successfully loaded. If it fails, there will be an error message in the matrix_science::ms_errs object passed to the constructor.

◆ saveXmlFile()

bool saveXmlFile | ( | const std::string & | xmlFilename,
 |  | const std::string & | schemaDirectory
 | ) |  | const

Save just the time alignment data to an XML file.

This is function is used to load the time alignment data as a discrete XML file. The time alignment data can also be saved as part of the the ms1 based quantitation results by calling ms_ms1quantitation::saveXmlFile with the saveTimeAlignmentData parameter set to true.

Parameters
xmlFilename | The path and filename of the file to load
schemaDirectory | is the directory which will contain the distiller_time_align_1.xsd file
Returns
true if the file is successfully saved. If it fails, there will be an error message in the matrix_science::ms_errs object passed to the constructor.

◆ setAlgorithmName()

void setAlgorithmName ( const char * algorithmName )

Brief descriptive text that describes the algorithm used for the time alignment.

Currently restricted to "Unsupervised" or "Supervised"

Parameters
algorithmName describes the type of algorithm used.

◆ setAverageFeatureWidths()

void setAverageFeatureWidths ( const std::vector< double > & featureWidths )

For supervised time alignment, a single feature width per subproject is used.

For supervised time alignment, the feature width for a subproject is calculated by taking the average xic width for all identified peptides in the subproject. Hence, just one value per subproject.

Parameters
simpleFeatureWidths is a 1D vector with numSubproject values in seconds

◆ setEvaluation()

void setEvaluation | ( | int | subProject,
 |  | double | meanErrorsRaw,
 |  | double | meanErrorsAligned,
 |  | double | stdevErrorsRaw,
 |  | double | stdevErrorsAligned,
 |  | double | pearsonCoefficientRaw,
 |  | double | pearsonCoefficientAligned
 | ) |  |
protected
Parameters
[in] | subProject | is the one based subproject number
[out] | meanErrorsRaw | is the mean average of the absolute difference between the ? ? ?
[out] | meanErrorsAligned
[out] | stdevErrorsRaw
[out] | stdevErrorsAligned
[out] | pearsonCoefficientRaw
[out] | pearsonCoefficientAligned
The documentation for this class was generated from the following files:
  • ms_ms1quant_time_align.hpp
  • ms_ms1quant_time_align.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_time_align_limits Class Reference

  • matrix_science
  • ms_ms1quant_time_align_limits
Public Types | Public Member Functions | Static Public Attributes | List of all members
ms_ms1quant_time_align_limits Class Reference
Quantitation analysis for Mascot Server and Distiller

Limits for m/z and retention time. More...

#include <ms_ms1quant_time_align_limits.hpp>

Inherits ms_handle.

Public Types

typedef int combinedRT_t
At the moment, when creating a common grid, integer retention times are used.

Public Member Functions

ms_ms1quant_time_align_limits ()
Constructor.
int | getCombinedMaxBinNum () const
Get the maximum bin number.
combinedRT_t | getCombinedMaxRT () const
Get the maximum retention time to be used for the common grid.
int | getCombinedMinBinNum () const
Get the minimum bin number.
combinedRT_t | getCombinedMinRT () const
Get the minimum retention time to be used for the common grid.
double | getMaxMZ () const
Get the maximum m/z value found.
double | getMaxRT () const
Get the maximum retention time found.
double | getMinMZ () const
Get the minimum m/z value found.
double | getMinRT () const
Get the minimum retention time found.
int | getNumQueries () const
Get the number of queries found.
int | getNumQueriesAboveThreshold () const
Get the number of queries with scores above threshold found.
void | setMaxBinNum (const int value)
Set the maximum bin number.
void | setMaxMZ (const double value)
Set the maximum m/z value found.
void | setMaxRT (const double value)
Set the maximum retention time found.
void | setMinBinNum (const int value)
Set the minimum bin number.
void | setMinMZ (const double value)
Set the minimum m/z value found.
void | setMinRT (const double value)
Set the minimum retention time found.
void | setNumQueries (const int value)
Set the number of queries found.
void | setNumQueriesAboveThreshold (const int value)
Set the number of queries with scores above threshold found.

Static Public Attributes

static const combinedRT_t combinedRTinterval = 1
At the moment, when creating a common grid, integer retention times are used.

Detailed Description

Limits for m/z and retention time.

Contains the m/z and retention time limits used for time alignment.

See ms_ms1quant_time_align::getCombinedLimits() and ms_ms1quantitation::getTimeAlignmentData() for details of how to get this object from the ms1 quantitation data

Constructor & Destructor Documentation

◆ ms_ms1quant_time_align_limits()

ms_ms1quant_time_align_limits ( )

Constructor.

Constructor for the m/z and retention time limits used for time alignment.

See ms_ms1quant_time_align::getCombinedLimits() and ms_ms1quantitation::getTimeAlignmentData() for details of how to get this object from the ms1 quantitation data

Member Function Documentation

◆ getCombinedMaxBinNum()

int getCombinedMaxBinNum ( ) const

Get the maximum bin number.

Returns
the maximum bin number required for the common grid

◆ getCombinedMaxRT()

ms_ms1quant_time_align_limits::combinedRT_t getCombinedMaxRT ( ) const

Get the maximum retention time to be used for the common grid.

When the common grid is created for looking up the retention times, the start, end and step size need to be determined. These are currently integer values.

Currently calculated by calling round( getMaxRT() ) and casting to the return type

Returns
the maximum retention time used for the common grid

◆ getCombinedMinBinNum()

int getCombinedMinBinNum ( ) const

Get the minimum bin number.

Returns
the minimum bin number required for the common grid

◆ getCombinedMinRT()

ms_ms1quant_time_align_limits::combinedRT_t getCombinedMinRT ( ) const

Get the minimum retention time to be used for the common grid.

When the common grid is created for looking up the retention times, the start, end and step size need to be determined. These are currently integer values.

Currently calculated by calling round( getMinRT() ) and casting to the return type

Returns
the minimum retention time used for the common grid

◆ getMaxMZ()

double getMaxMZ ( ) const

Get the maximum m/z value found.

The constructor initialises this value to zero

See also
setMaxMZ()
Returns
the maximum m/z value.

◆ getMaxRT()

double getMaxRT ( ) const

Get the maximum retention time found.

The constructor initialises this value to zero

See also
setMaxRT()
getCombinedMaxRT()
Returns
the maximum retention time.

◆ getMinMZ()

double getMinMZ ( ) const

Get the minimum m/z value found.

The constructor initialises this value to the maximum possible double value

See also
setMinMZ()
Returns
the minimum m/z value.

◆ getMinRT()

double getMinRT ( ) const

Get the minimum retention time found.

The constructor initialises this value to the maximum possible double value

See also
setMinRT()
getCombinedMinRT()
Returns
the minimum retention time.

◆ getNumQueries()

int getNumQueries ( ) const

Get the number of queries found.

The constructor initialises this value to zero

Not strictly part of the limits, but this is the number of queries from the Mascot database search(es) that were used when determining the limits

See also
setNumQueries()
getNumQueriesAboveThreshold()
Returns
the number of queries

◆ getNumQueriesAboveThreshold()

int getNumQueriesAboveThreshold ( ) const

Get the number of queries with scores above threshold found.

The constructor initialises this value to zero

Not strictly part of the limits, but this is the number of queries above the specified threshold from the Mascot database search(es) that were used when determining the limits

See also
setNumQueriesAboveThreshold()
getNumQueries()
Returns
the number of queries above the threshold

◆ setMaxBinNum()

void setMaxBinNum ( const int value )

Set the maximum bin number.

The constructor initialises this value to zero

Not strictly part of the limits. It is calculated from int(round(getMaxMZ())) / binSize

See also
getCombinedMaxBinNum()
Parameters
value is the new maximum bin number

◆ setMaxMZ()

void setMaxMZ ( const double value )

Set the maximum m/z value found.

The constructor initialises this value to zero

See also
getMaxMZ()
Parameters
value is the new maximum m/z value.

◆ setMaxRT()

void setMaxRT ( const double value )

Set the maximum retention time found.

The constructor initialises this value to zero

See also
getMaxRT()
getCombinedMaxRT()
Parameters
value is the new maximum retention time.

◆ setMinBinNum()

void setMinBinNum ( const int value )

Set the minimum bin number.

The constructor initialises this value to zero

Not strictly part of the limits. It is calculated from int(round(getMinMZ())) / binSize

See also
getCombinedMinBinNum()
Parameters
value is the new minimum bin number

◆ setMinMZ()

void setMinMZ ( const double value )

Set the minimum m/z value found.

The constructor initialises this value to the maximum possible double value

See also
getMinMZ()
Parameters
value is the new minimum m/z value.

◆ setMinRT()

void setMinRT ( const double value )

Set the minimum retention time found.

The constructor initialises this value to the maximum possible double value

See also
getMinRT()
getCombinedMinRT()
Parameters
value is the new minimum retention time.

◆ setNumQueries()

void setNumQueries ( const int value )

Set the number of queries found.

The constructor initialises this value to zero

Not strictly part of the limits, but this is the number of queries from the Mascot database search(es) that were used when determining the limits

See also
getNumQueries()
Parameters
value is the new number of queries

◆ setNumQueriesAboveThreshold()

void setNumQueriesAboveThreshold ( const int value )

Set the number of queries with scores above threshold found.

The constructor initialises this value to zero

Not strictly part of the limits, but this is the number of queries above the specified threshold from the Mascot database search(es) that were used when determining the limits

See also
setNumQueriesAboveThreshold()
getNumQueries()
Parameters
value is the new number of queries above the threshold
The documentation for this class was generated from the following files:
  • ms_ms1quant_time_align_limits.hpp
  • ms_ms1quant_time_align_limits.cpp
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quantitation Class Reference

  • matrix_science
  • ms_ms1quantitation
Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ms_ms1quantitation Class Reference
Quantitation analysis for Mascot Server and Distiller

The result of quantitation calculations applied to peptide summary. More...

#include <ms_ms1quantitation.hpp>

Inheritance diagram for ms_ms1quantitation:
[legend]
Collaboration diagram for ms_ms1quantitation:
[legend]

Public Types

enum MERGE_QUANT_RESULTS_FLAGS {
MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS = 0x0001 ,
MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH = 0x0002 ,
MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC = 0x0004 ,
MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE = 0x0008 ,
MERGE_QUANT_DEFAULT_PRECURSOR_METHOD = MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE ,
MERGE_QUANT_DEFAULT_REPLICATE_METHOD = (MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS | MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH | MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC)
}
Enum for mergeQuantitationResults() More...
enum MS1QUANT_BUGFIX_NUM { BUGFIX_12409 = 12409 }
bugNum values for isDataCached(). More...

Public Member Functions

ms_ms1quantitation (const ms_peptidesummary &summary, const ms_quant_method &method)
Constructor: given a peptide summary and a quantitation method, prepare for data processing.
void | addHeaderField (const std::string &name, const std::string &value)
Adds an item of project or search header information.
matrix_science::ms_ms1quant_match | addMatchInferred (const ms_ms1quant_match &siblingMatch, int newCharge)
Add an inferred peptide match to the quantitation results.
void | addMatchPeptide (matrix_science::ms_protein *hit, matrix_science::ms_peptide *peptide, const matrix_science::ms_quant_component &component, const std::string &matchBelongsToComponent, const int thisSubProjectId=matrix_science::ms_quant_file_index::file_index_value_not_set)
Add a quantitation peptide match to a protein hit.
void | addMatchStatus (matrix_science::ms_peptide *peptide, matrix_science::ms_ms1quant_peptide_status::peptideStatus status, matrix_science::ms_protein *hit=0)
Add the quantitation status for the protein-peptide match to the quantitation results.
void | addPeptideQuantKey (const std::string &accession, int dbIdx, const ms_peptide_quant_key &key)
Associate a protein accession with a peptide quant key.
void | addPeptideQuantKeys (const std::string &accession, int dbIdx, const ms_peptide_quant_key_vector &keys)
Associate a protein accession with particular peptide quant keys.
void | addPeptideQuantKeys (const std::string &accession, int dbIdx, const std::vector< ms_peptide_quant_key > &keys)
Associate a protein accession with particular peptide quant keys.
void | addPeptideRatio (const ms_peptide_quant_ratio &ratio)
Add a new peptide ratio.
void | addRawFileField (const unsigned int id, const std::string &name, const std::string &value)
Adds an item of raw file header information.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearHeaderFields ()
Clears any header information from the result.
void | clearPeptideQuantKeys (const std::string &accession, int dbIdx)
Clear all peptide quant key associations for a given protein.
void | clearPeptideRatios ()
Remove all peptide ratios.
void | clearRawFileFields ()
Clears any raw file header information from the result.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual int | countDistinctPeptides (const ms_peptide_quant_key_vector &activeKeys) const
Bring across base class member that we don't overload, otherwise it will be hidden.
virtual int | countDistinctPeptides (const std::vector< ms_peptide_quant_key > &activeKeys) const
Bring across base class member that we don't overload, otherwise it will be hidden.
virtual int | countDistinctPeptides (const std::vector< ms_peptide_quant_key > &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
bool | findMatch (matrix_science::ms_peptide_quant_key matchKey, ms_ms1quant_match *match) const
Get a match by its key.
bool | findPeptideStatus (int query, int rank, ms_ms1quant_peptide_status *peptideStatus) const
Get a peptide status in the quantitation results by the peptide's query and rank.
bool | getAveragePeptideIntensity (const std::string &accession, int dbIdx, double *averageIntensity, int *sampleSize, ms_peptide_quant_key_vector *includeKeys, ms_peptide_quant_key_vector *excludeKeys) const
Average protocol only: get the intensity of the protein based on its component peptide intensities.
const ms_ms1quant_average_results * | getAverageResults () const
Return the results from an 'average' protocol.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
ms_protein * | getHit (int index1) const
Get a quantitated protein.
std::string | getLabelFree (std::string peptideStr, std::string varMods, std::string summedMods, const matrix_science::ms_quant_component &comp) const
Get the label-free modifications string, combined from the variable mods and the summed mods.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
ms_ms1quant_match | getMatch (const ms_peptide_quant_key &key) const
Get a match by its key.
ms_ms1quant_match | getMatch (int index) const
Get a match by its index (1..getNumMatches()).
ms_ms1quant_match | getMatchForHit (int index, int hitId, int memberNumber) const
Get a match for the specified hit protein (index is 1..numberOfMatchesForHit).
int | getNumGroups () const
Return the number of match groups
int | getNumHits () const
Get the number of quantitated proteins.
int | getNumMatches () const
Get the number of peptide matches for all quantitated proteins.
int | getNumMatchesForGroup (int groupIndex1) const
Return the number of matches for each group.
int | getNumMatchesForHit (int hitId, int memberNumber) const
Get the number of matches for the specified hit protein.
int | getNumPeptideStatuses () const
Get the number of peptide statuses.
int | getNumProteinFamilies () const
Get the number of protein families.
ms_peptide_quant_key_vector | getPeptideQuantKeys (const std::string &accession, int dbIdx) const
Look up peptide quant keys associated with a given protein, if any.
virtual ms_peptide_quant_ratio | getPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Given peptide quant key and ratio name, return the corresponding peptide ratio data.
double | getPeptideRatioNormalisationBase (const std::string &ratioName) const
Get the peptide ratio normalisation base of the given ratio name.
ms_ms1quant_peptide_status | getPeptideStatus (int index) const
Get a peptide status by its index.
const ms_peptidesummary & | getPeptideSummary () const
The summary is needed to recover the proteins and peptides.
const ms_progress_info & | getProgressInfo ()
Get information about the progress of a currently running long operation (e.g. loading from a file).
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName) const
Overridden from ms_quantitation (via ms_customquantitation) base class.
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const
Overridden from ms_quantitation (via ms_customquantitation) base class.
std::vector< int > | getQuantitationDatasources () const
Get the datasource identifiers of every data source in use for quantitation.
const ms_quant_method & | getQuantitationMethod () const
Return the current quantitation method.
std::string | getReadableVarMods (std::string varmods)
Get the human-readable format of the given variable modifications.
std::string | getReadableVarModsConcise (std::string varmods)
Get the concise version of the human-readable format of the given variable modifications.
const ms_peptidesummary & | getSummary () const
The summary is needed to recover the proteins and peptides.
matrix_science::ms_ms1quant_time_align & getTimeAlignmentData ()
Returns the time alignment data for label free quantitation.
const matrix_science::ms_ms1quant_time_align & | getTimeAlignmentData () const
Returns the time alignment data for label free quantitation.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType) const
Calculate the unnormalised average peptide ratio.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType, const ms_peptide_quant_key_vector &keys) const
Calculate the unnormalised average of selected peptide quant keys.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType, const std::string &accession, int dbIdx) const
Calculate the unnormalised average of peptide quant keys of a protein accession.
virtual bool | hasPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.
void | initGroupChargeStates (std::set< int > *calc_chargestates, int iGroup1, int minCharge, int maxCharge)
Add inferred charge states to the group if specified in the method.
bool | isAverageProtocol () const
Return true if the quantitation method uses the Average protocol.
bool | isDataCached (MS1QUANT_BUGFIX_NUM bugNum) const
Returns true if the cache file contains data relevant to the given bug number.
virtual bool | isPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName) const
Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?
bool | isValid () const
Call this function to determine if there have been any errors.
bool | loadCdbFile (const std::string &cdbFilename, const std::string &cacheFilename, bool revalidateQualityThresholds=true)
Load the results from a matched pair of files.
bool | loadXmlFile (const std::string &filename, const std::string &xmlSchemaPath)
Load quantitation results from an XML file. The schema is loaded from the location known to the.
bool | mergeQuantitationResults (const std::vector< std::string > &cdbFilenames, const std::vector< std::string > &cacheFilenames, const MERGE_QUANT_RESULTS_FLAGS flags, const matrix_science::ms_quant_method *originalMethod=0)
Merges the quantitation results from matched pairs of cdb files.
bool | mergeQuantitationResults (const std::vector< std::string > &xmlFilenames, const MERGE_QUANT_RESULTS_FLAGS flags, const std::string &xmlSchemaPath="", const matrix_science::ms_quant_method *originalMethod=0)
Merges the quantitation results loaded from xml result files.
void | removeMatch (matrix_science::ms_peptide_quant_key matchKey)
Remove the specified peptide match from the results.
void | removePeptideQuantKey (const std::string &accession, int dbIdx, const ms_peptide_quant_key &key)
Deassociate a peptide quant key from the given protein.
void | removePeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName)
Remove a particular peptide ratio.
void | removePeptideRatioNormalisationBase (const std::string &ratioName)
Reset the peptide ratio normalisation base of the given ratio name.
void | removePeptideRatioNormalisationBases ()
Reset all peptide ratio normalisation bases.
bool | saveCdbFile (const std::string &cdbFilename, const std::string &cacheFilename, bool createEmptyMissingComponents=false)
Save the results to a matched pair of files.
bool | saveXmlFile (const std::string &xmlFilename, bool completeReport, bool saveTimeAlignmentData=false)
Save the quantitation results to an XML file.
void | setAverageNumPeptides (unsigned int num=3)
Average protocol only: set the number of most intense peptide groups to use.
void | setAverageReferenceProtein (const char *accession, int dbIdx, bool isReferenceUserSelected)
Average protocol only: select a reference protein accession and database.
void | setAverageSelection (const char *value)
Average protocol only: set the method of grouping peptide ratios.
void | setMinNumPeptides (int value)
Set the minimum number of peptides needed for protein ratio calculation.
virtual void | setPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally exclude a particular peptide ratio from protein ratio calculation.
virtual void | setPeptideRatioIncluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally include a particular peptide ratio in protein ratio calculation.
void | setPeptideRatioNormalisationBase (const std::string &ratioName, double b)
Set the peptide ratio normalisation base of the given ratio name.
virtual void | setProteinRatioType (const char *value)
Set the protein ratio type.
virtual void | setQuantOutliers (const ms_quant_outliers *)
Set new peptide ratio outlier settings.
void | setTimeAlignmentData (matrix_science::ms_ms1quant_time_align &alignmentData)

Static Public Member Functions

static matrix_science::ms_ms1quantitation * | openQuantitationCdbResults (const matrix_science::ms_peptidesummary &summary, const matrix_science::ms_quant_method &method, const std::string &cdbFilename, const std::string &cacheFilename, const matrix_science::ms_quant_method *originalMethod=0)
Opens and loads quantitation results from a matched pair of cdb files.
static matrix_science::ms_ms1quantitation * | openQuantitationXmlResults (const matrix_science::ms_peptidesummary &summary, const matrix_science::ms_quant_method &method, const std::string &filename, const std::string &xmlSchemaPath="", const matrix_science::ms_quant_method *originalMethod=0)
Opens and loads quantitation results from an xml result file.
static bool | readResultCounters (const std::string &cdbFile, int &numMatches, int &numHits, int &numPepGrp, int &numPeptideComponents)
Reads and returns the Counters information from the cdb result file.

Protected Member Functions

ms_protein_quant_ratio | calculateGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the geometric mean and standard deviation.
ms_protein_quant_ratio | calculateMedianRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the median and standard deviation from the median.
ms_protein_quant_ratio | calculateWeightedGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.
int | getMinNumPeptides () const
Get the minimum number of peptides needed for protein ratio calculation.
void | getProteinRatioSample (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const
Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.
virtual void | getSortedFinitePeptideRatioValues (const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const
Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.
bool | initialiseBaseSettings (const ms_quant_method &qmBase, const ms_quant_method &qmConfig)
Initialise quantitation method settings from the two method objects.

Protected Attributes

protein_to_peptide_quant_key_t proteinKeys_
Protein-to-peptide mapping.

Detailed Description

The result of quantitation calculations applied to peptide summary.

Each ms_protein hit from the ms_peptidesummary can have any number of peptide matches (ms_ms1quant_match) that contribute to its protein ratios.

Peptide ratios are identified by the index key (0..getNumMatches()-1) identifying the ms_ms1quant_match (ms_peptide_quant_key(int ID)).

Protein ratios are identified by protein accession and database index.

As the quantitation results are loading (loadCdbFile() or loadXmlFile()), the protein hits references to the quantitation peptide ratio results validated with the current ms_peptidesummary. These will normally match but may not if, for instance, the peptide summary has been re-calculated since the quantitation results were generated. If a protein has changed its hit reference in the peptide summary (but can still be found by its accession, in any database) a warning message is added to the ms_errors to indicate that the protein reference has been updated. If a protein is no longer present in the peptide summary then a warning message is added to the ms_errors to indicate that the protein was not found.

Example code to load quantitation results and list protein ratios:

void listProteins(const ms_peptidesummary & pepsum, const ms_quant_method & method, const char * cdbFilename, const char * cacheFilename)
{
    ms_ms1quantitation quant(pepsum, method);
    quant.loadCdbFile(cdbFilename, cacheFilename);
    for (int iHit = 1; iHit <= pepsum.getNumberOfHits(); ++iHit)
    {
        ms_protein * hit = pepsum.getHit(iHit);
        cout << endl << pepsum.getProteinDescription(hit->getAccession().c_str(), hit->getDB()) << endl;
        const std::vector<const matrix_science::ms_quant_ratio*> & proteinRatios = quant.getProtocol()->getProteinRatios();
        for (unsigned iRatio = 0; iRatio < proteinRatios.size(); ++iRatio)
        {
            std::string ratioName = proteinRatios[iRatio]->getName();
            ms_protein_quant_ratio rat = quant.getProteinRatio(hit->getAccession(), hit->getDB(), ratioName);
            if (!rat.isMissing())
            {
                cout << "    " << ratioName << " = " << rat.getValue() << endl;
            }
        }
    }
}
Thread safe
This class is safe to use from multiple threads. See also Using Parser in multithreaded applications.

Member Enumeration Documentation

◆ MERGE_QUANT_RESULTS_FLAGS

enum MERGE_QUANT_RESULTS_FLAGS

Enum for mergeQuantitationResults()

Enumerator
MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS | For replicate, each subproject uses the merged results. (For precursor, each subproject uses its own search result)
MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH | For replicate, we create a component in one file, based on the match to the same query in another file. Merge these components into one ms_ms1quant_match.
MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC | For replicate, the XIC for a particular component is saved saved in the relevant file, available using ms_quant_component::getFileIndex(). For precursor, all components can be in one subproject file.
MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE | This shouldn't be done for replicate, because the ratios will all be incorrect until they are recalculated after calling mergeQuantitationResults()
MERGE_QUANT_DEFAULT_PRECURSOR_METHOD | Use this for any precursor method.
MERGE_QUANT_DEFAULT_REPLICATE_METHOD | Use this for any replicate method.

◆ MS1QUANT_BUGFIX_NUM

enum MS1QUANT_BUGFIX_NUM

bugNum values for isDataCached().

If loaded from a cdb file from Distiller 2.7 or earlier, then the cache file may not contain data for later improvements. While this does not affect functionality, it may impact performance. For example, bug#12409 means that unnormalised peptide ratios are saved in the cdb file, allowing for rapid disabling of normalisation without requiring requantitation

See Using enumerated values and static const ints in Perl, Java, Python and C# and ms_peptidesummary::isDataCached(),

Enumerator
BUGFIX_12409

Distiller 2.7 or earlier save normalised peptide ratios to the cdb file. If this method returns false, the enabling and disabling normalisation is not possible from within msparser and requires the data to be requantitated.

Constructor & Destructor Documentation

◆ ms_ms1quantitation()

ms_ms1quantitation | ( | const ms_peptidesummary & | summary,
 |  | const ms_quant_method & | method
 | ) |  |

Constructor: given a peptide summary and a quantitation method, prepare for data processing.

ms_ms1quantitation does not calculate the quantitation matches; it loads in previously calculated and stored matches but the peptide and protein ratios are re-calculated as required.

After contructing the ms_ms1quantitation, the quantitation results should be loaded using loadCdbFile() or loadXmlFile().

Parameters
summary | Mascot results file to quantitate. Note that you must first validate the embedded XML sections of the results file. Either pass the schema directory to the ms_mascotresfilebase constructor or use ms_mascotresfilebase::setXMLschemaFilePath().
method | Quantitation method to use. If the results are being taken from a Distiller project file, then the quantitation method from the ms_distiller_data should be used.

Member Function Documentation

◆ addMatchInferred()

matrix_science::ms_ms1quant_match addMatchInferred | ( | const ms_ms1quant_match & | siblingMatch,
 |  | int | newCharge
 | ) |  |

Add an inferred peptide match to the quantitation results.

Parameters
siblingMatch | The identified match the inferred match is derived from
newCharge | The charge state of the inferred match
Returns
the newly created and added ms_ms1quant_match object

◆ addMatchPeptide()

void addMatchPeptide | ( | matrix_science::ms_protein * | hit,
 |  | matrix_science::ms_peptide * | peptide,
 |  | const matrix_science::ms_quant_component & | component,
 |  | const std::string & | matchBelongsToComponent,
 |  | const int | thisSubProjectId = matrix_science::ms_quant_file_index::file_index_value_not_set
 | ) |  |

Add a quantitation peptide match to a protein hit.

For Replicate, this is only called from the subproject quantitation, so only add a 'file_index' for thisSubProjectId, and therefore only use perFileIndex_[0]

Parameters
hit | The protein hit the peptide quantitation match is associated with
peptide | The peptide
component | The quantitation component the match is associated with
matchBelongsToComponent | is used to determine whether to call ms_ms1quant_match::addIdentifiedComponent() or ms_ms1quant_match::addCreatedComponent() because for MS1 label free we need a created component if there's no match in our file. Pass an empty string for protocols other than label free
thisSubProjectId | defaults to matrix_science::ms_quant_file_index::file_index_value_not_set and is used to set the file_index in the ms_ms1quant_match_component

◆ addMatchStatus()

void addMatchStatus | ( | matrix_science::ms_peptide * | peptide,
 |  | matrix_science::ms_ms1quant_peptide_status::peptideStatus | status,
 |  | matrix_science::ms_protein * | hit = 0
 | ) |  |

Add the quantitation status for the protein-peptide match to the quantitation results.

Adds the status of a peptide match assigned to the specified protein to the quantitation results

Parameters
peptide | The peptide associated with the quantitation match
status | The peptide quantitation match status
hit | The protein hit the peptide match is associated with. Do not pass this parameter for unassigned peptide matches

◆ addPeptideQuantKey()

void addPeptideQuantKey | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key & | key
 | ) |  |
inherited

Associate a protein accession with a peptide quant key.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

If key is already associated with this protein, no changes are made.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
key | Peptide quant key.

◆ addPeptideQuantKeys() [1/2]

void addPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key_vector & | keys
 | ) |  |
inherited

Associate a protein accession with particular peptide quant keys.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

Values in keys already associated with the protein are skipped.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
keys | Peptide quant keys.

◆ addPeptideQuantKeys() [2/2]

void addPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::vector< ms_peptide_quant_key > & | keys
 | ) |  |
inherited

Associate a protein accession with particular peptide quant keys.

Note
This method can only be used from C++. Use addPeptideQuantKeys(std::string, int, const ms_peptide_quant_key_vector) from other programming languages instead.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

Values in keys already associated with the protein are skipped.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
keys | Peptide quant keys.

◆ addPeptideRatio()

void addPeptideRatio ( const ms_peptide_quant_ratio & ratio )
inherited

Add a new peptide ratio.

If an existing peptide ratio exists with the same query, rank and ratio name as ratio.getQuery(), ratio.getRank() and ratio.getRatioName(), it will be replaced with the new data.

If ratio represents an undefined ("missing") value, the peptide ratio will be removed, as if you had called removePeptideRatio() instead.

Parameters
ratio Peptide ratio to add.

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ calculateGeometricMeanRatio()

ms_protein_quant_ratio calculateGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protectedinherited

Given a sample of peptide ratios, calculate the geometric mean and standard deviation.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.

◆ calculateMedianRatio()

ms_protein_quant_ratio calculateMedianRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protectedinherited

Given a sample of peptide ratios, calculate the median and standard deviation from the median.

See ms_quant_stats::sortedMedian for details of how this is calculated.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-values, if relevant.

◆ calculateWeightedGeometricMeanRatio()

ms_protein_quant_ratio calculateWeightedGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< double > & | weights,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protectedinherited

Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ clearPeptideQuantKeys()

void clearPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  |
inherited

Clear all peptide quant key associations for a given protein.

After this, getProteinRatio() will return a ratio with state isMissing() when given accession, dbIdx and any ratio name.

Parameters
accession | Protein accession.
dbIdx | Protein database index.

◆ clearPeptideRatios()

void clearPeptideRatios ( )
inherited

Remove all peptide ratios.

This method also removes all q,p aliases of peptide ratios. However, the peptide-protein mapping will not be changed.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ countDistinctPeptides()

int countDistinctPeptides ( const std::vector< ms_peptide_quant_key > & activeKeys ) const
virtual

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

Parameters
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns
The number of distinct peptides.

Reimplemented from ms_quantitation.

◆ findMatch()

bool findMatch | ( | matrix_science::ms_peptide_quant_key | matchKey,
 |  | matrix_science::ms_ms1quant_match * | match
 | ) |  | const

Get a match by its key.

Parameters
matchKey | The ms_peptide_quant_key to search for in the results' matches.
match | An ms_ms1quant_match to receive the found match information.
Returns
True if a ms_ms1quant_match was found with a key matching matchKey.

◆ findPeptideStatus()

bool findPeptideStatus | ( | int | query,
 |  | int | rank,
 |  | matrix_science::ms_ms1quant_peptide_status * | peptideStatus
 | ) |  | const

Get a peptide status in the quantitation results by the peptide's query and rank.

Parameters
query | The query number of the peptide.
rank | The rank of the peptide within the query.
peptideStatus | An ms_ms1quant_peptide_status to receive the found peptide information.
Returns
True if a peptide matching the search criteria was found in the quantitation data.

◆ getAveragePeptideIntensity()

bool getAveragePeptideIntensity | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | double * | averageIntensity,
 |  | int * | sampleSize,
 |  | matrix_science::ms_peptide_quant_key_vector * | includeKeys,
 |  | matrix_science::ms_peptide_quant_key_vector * | excludeKeys
 | ) |  | const

Average protocol only: get the intensity of the protein based on its component peptide intensities.

The number of peptide intensities associated with a protein will typically not be the same as then number to be used for the Average protocol, see setAverageNumPeptides(). If there are insufficient peptide intensities then the sample size will still be set (less than the number required). If there are sufficient peptide intensities then the sample size is set to the total number and the average is set to the average of the peptide intensities used (typically not the entire sample).

The average returned is that of the grouped intensities. Each peptide ratio group is summed and then the average is taken of those sums.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | accession | The protein accession.
[in] | dbIdx | The protein database index.
[out] | averageIntensity | Returns the average of the peptide intenties that are selected.
[out] | sampleSize | Returns the number of different peptide groups available; after grouping by selection type.
[out] | includeKeys | The peptide quant ratio keys in the peptide groups that were selected; this may be greater than sampleSize.
[out] | excludeKeys | The peptide quant ratio keys in the peptide groups that were not selected.
Returns
True if enough peptides (after grouping) are associated with the sample to calculate the average.

◆ getAverageResults()

const matrix_science::ms_ms1quant_average_results * getAverageResults ( ) const

Return the results from an 'average' protocol.

Returns
The results that are only applicable to an 'average' protocol, or null if the quantitation method type is not 'average'.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getHit()

matrix_science::ms_protein * getHit ( int index1 ) const

Get a quantitated protein.

Parameters
index1 The quantitated protein's index (1..getNumHits()).
Returns
The selected quantitated protein.

◆ getLabelFree()

std::string getLabelFree | ( | std::string | peptideStr,
 |  | std::string | varMods,
 |  | std::string | summedMods,
 |  | const matrix_science::ms_quant_component & | comp
 | ) |  | const

Get the label-free modifications string, combined from the variable mods and the summed mods.

Mods are now encoded into two strings: varMods and summedMods. The use of two strings allows for the site of the label to also contain another mod. Having stripped the labels from the strings, there will only be one mod per site allowing the two strings to be merged into a single label-free mod string

Parameters
peptideStr | The peptide sequence string.
varMods | The encoded variable modifications.
summedMods | The encoded summed modifications.
comp | The component defining all the modifications that are part of the labelling protocol and so should not be included in the label-free list of modifications.
Returns
label-free string.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMatch() [1/2]

ms_ms1quant_match getMatch ( const ms_peptide_quant_key & key ) const

Get a match by its key.

Parameters
key The match's key
Returns
The selected match, or an empty match if not found.

◆ getMatch() [2/2]

ms_ms1quant_match getMatch ( int index ) const

Get a match by its index (1..getNumMatches()).

Parameters
index The match's index (1..getNumMatches()).
Returns
The selected match.

◆ getMatchForHit()

ms_ms1quant_match getMatchForHit | ( | int | index,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  | const

Get a match for the specified hit protein (index is 1..numberOfMatchesForHit).

Parameters
index | The index (1..getNumMatches()) of the required match.
hitId | The protein hit's identifier.
memberNumber | The number of the hits within its family, or zero if it is not in a family.
Returns
The match from the list of matches associated with the protein hit, or null if the index or match identifiers are invalid.

◆ getMinNumPeptides()

int getMinNumPeptides ( ) const
protectedinherited

Get the minimum number of peptides needed for protein ratio calculation.

Returns
The minimum number of peptides needed for protein ratio calculation.

◆ getNumGroups()

int getNumGroups ( ) const

Return the number of match groups

A single match group is all the matches with a unique datasourceId:peptideStr:labelFreeVarMods.

Returns
the number of match groups

◆ getNumHits()

int getNumHits ( ) const

Get the number of quantitated proteins.

Returns
The number of proteins included in the quantitation result.

◆ getNumMatches()

int getNumMatches ( ) const

Get the number of peptide matches for all quantitated proteins.

Returns
The number of matches in the quantitation result.

◆ getNumMatchesForGroup()

int getNumMatchesForGroup ( int groupIndex1 ) const

Return the number of matches for each group.

There will be one match group for each datasourceId:peptideStr:labelFreeVarMods that got a significant match. Each match group will contain one or more matches, one for each charge state that had a signficant PSM.

Parameters
groupIndex1 should be in the range 1..getNumGroups()
Returns
the number of matches for each group

◆ getNumMatchesForHit()

int getNumMatchesForHit | ( | int | hitId,
 |  | int | memberNumber
 | ) |  | const

Get the number of matches for the specified hit protein.

Parameters
hitId | The protein hit's identifier.
memberNumber | The number of the hits within its family, or zero if it is not in a family.
Returns
The number of matches associated with the protein hit.

◆ getNumPeptideStatuses()

int getNumPeptideStatuses ( ) const

Get the number of peptide statuses.

Returns
The number of peptides with a status in the quantitation result.

◆ getNumProteinFamilies()

int getNumProteinFamilies ( ) const

Get the number of protein families.

This function can be removed when bug 13150 is fixed

Returns
the number of protein fmailies that have been quantitated

◆ getPeptideQuantKeys()

ms_peptide_quant_key_vector getPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const
 inherited

Look up peptide quant keys associated with a given protein, if any.

In ms_ms2quantitation, the list of peptide quant keys associated with the given protein is immutable, as the keys are derived from q,p values in the Mascot results file. The list does not contain all q,p values, but only those that 1) have component intensities and 2) pass the quality thresholds. Unless the data quality is extremely good, this list will always have fewer elements than the actual peptide matches assigned to the protein hit.

In ms_customquantitation, the peptide-to-protein mapping can be altered with ms_customquantitation::addPeptideQuantKey() and ms_customquantitation::removePeptideQuantKey().

Parameters
accession | The protein accession.
dbIdx | The protein database index.
Returns
A vector of peptide quant keys associated with the protein.

◆ getPeptideRatio()

ms_peptide_quant_ratio getPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 virtualinherited

Given peptide quant key and ratio name, return the corresponding peptide ratio data.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

If hasPeptideRatio(const ms_peptide_quant_key&, std::string) const returns false for the given peptide quant key and ratio name, then the peptide ratio object returned by this method represents an undefined ("missing") value.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
The peptide ratio. If hasPeptideRatio() returns false, the field values of the object returned by this method are undefined.

Implements ms_quantitation.

◆ getPeptideRatioNormalisationBase()

double getPeptideRatioNormalisationBase ( const std::string & ratioName ) const
inherited

Get the peptide ratio normalisation base of the given ratio name.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters
ratioName Peptide ratio name.
Returns
The current peptide ratio normalisation base, or 1 if it hasn't been set.

◆ getPeptideStatus()

matrix_science::ms_ms1quant_peptide_status getPeptideStatus ( int index ) const

Get a peptide status by its index.

Parameters
index The peptide status's index (1..getNumPeptideStatuses()).
Returns
The selected peptide status.

◆ getPeptideSummary()

const matrix_science::ms_peptidesummary & getPeptideSummary ( ) const

The summary is needed to recover the proteins and peptides.

Returns
The summary that was passed to the constructor.

◆ getProgressInfo()

const matrix_science::ms_progress_info & getProgressInfo ( )
inherited

Get information about the progress of a currently running long operation (e.g. loading from a file).

Returns
Progress information about the most recent long operation.

◆ getProteinRatio() [1/2]

matrix_science::ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName
 | ) |  | const
 virtual

Overridden from ms_quantitation (via ms_customquantitation) base class.

See ms_quantitation::getProteinRatio for further details of how the ratio is calculated

The list of included and excluded keys are retrieved from the result before being passed to the base class for processing. These will override the lists of keys set by setPeptideRatioExcluded() and setPeptideRatioIncluded() so that the same result can be obtained as was set twhen the results were calculated. To override the lists of peptides from the stored result, call getProteinRatio() on the base class (ms_customquantitation).

Parameters
accession | The accession of the protein.
dbIdx | The database the protein is from.
ratioName | The name of the ratio to calculate.
Returns
The match from the list of matches associated with the protein hit, or null if the index or match identifiers are invalid.

Reimplemented from ms_customquantitation.

◆ getProteinRatio() [2/2]

matrix_science::ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | includeKeys,
 |  | const ms_peptide_quant_key_vector & | excludeKeys
 | ) |  | const
 virtual

Overridden from ms_quantitation (via ms_customquantitation) base class.

The list of included and excluded keys are retrieved from the result before being passed to the base class for processing. These will override the lists of keys set by setPeptideRatioExcluded() and setPeptideRatioIncluded() so that the same result can be obtained as was set twhen the results were calculated. To override the lists of peptides from the stored result, call getProteinRatio() on the base class (ms_customquantitation).

Parameters
accession | The accession of the protein.
dbIdx | The database the protein is from.
ratioName | The name of the ratio to calculate.
includeKeys | The keys of peptide matches that are to be included in the protein ratio.
excludeKeys | The keys of peptide matches that are to be excluded in the protein ratio
Returns
The match from the list of matches associated with the protein hit, or null if the index or match identifiers are invalid.

Reimplemented from ms_customquantitation.

◆ getProteinRatioSample()

void getProteinRatioSample | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< ms_peptide_quant_key > & | includeKeys,
 |  | const std::vector< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | sample,
 |  | std::vector< double > & | logSample,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double & | normalityPvalue
 | ) |  | const
 protectedinherited

Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.

This method uses getSortedFinitePeptideRatioValues() internally to collect the vector of peptide ratios. If there are no peptide quant keys associated with the protein, or if no peptide ratios are associated with with those peptide quant keys, then sample, logSample, activeKeys and inactiveKeys will be empty and normalityPvalue will have an undefined value.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
ratioName | Name of the ratio.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
sample | Peptide ratios associated with ratioName and the protein's peptide quant keys, in numerically increasing order.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
activeKeys | Peptide quant keys corresponding to the order of sample (and logSample).
inactiveKeys | Peptide quant keys marked as skipped, excluded or outlier.
normalityPvalue | The p-value that the sample appears to be normally distributed after outlier removal. If less than 0.05, no outliers will have been removed.

◆ getQuantitationDatasources()

std::vector< int > getQuantitationDatasources ( ) const

Get the datasource identifiers of every data source in use for quantitation.

Returns
A collection of all the datasource identifiers that are in use in all the quantitation matches.

◆ getQuantitationMethod()

const ms_quant_method & getQuantitationMethod ( ) const
inherited

Return the current quantitation method.

The current (or effective) quantitation method is the original quantitation method given as argument to the constructor (or loaded from the Mascot results file), with possible later modifications, such as changing normalisation or outlier settings.

For ms_ms2quantitation, you cannot change the protocol settings, component definitions or peptide quality settings. You must create a new object with the new settings instead. You are free to change how protein ratios are calculated and set new normalisation parameters. These changes will be reflected in this method's output value.

For ms_customquantitation, same restrictions apply, although it makes little difference, as the class does not use any protocol settings, component definitions or peptide quality settings.

Returns
The current quantitation method.

◆ getReadableVarMods()

std::string getReadableVarMods ( std::string varmods )

Get the human-readable format of the given variable modifications.

Parameters
varmods The encoded variable modifications.
Returns
The human-readable form of the variable modifications.

◆ getReadableVarModsConcise()

std::string getReadableVarModsConcise ( std::string varmods )

Get the concise version of the human-readable format of the given variable modifications.

Parameters
varmods The encoded variable modifications.
Returns
The concise version of the human-readable form of the variable modifications.

◆ getSortedFinitePeptideRatioValues()

void getSortedFinitePeptideRatioValues | ( | const std::string & | ratioName,
 |  | const std::set< ms_peptide_quant_key > & | keys,
 |  | const std::set< ms_peptide_quant_key > & | includeKeys,
 |  | const std::set< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | values,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys
 | ) |  | const
 protectedvirtualinherited

Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.

The method looks up all peptide ratios associated with keys (ignoring duplicates) and returns them in numerically increasing order in values. Infinite and missing ratios are ignored. The vector activeKeys contains active peptide quant keys in the same order as values, and the map inactiveKeys contains peptide quant keys associated with the protein ratio but for indicated reasons not included in ratio calculation.

Parameters
ratioName | The name of the peptide ratio.
keys | A list of (sorted or unsorted) peptide quant keys for which to look up the ratios.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
values | Peptide ratios associated with ratioName and the given peptide quant keys.
weights | Weighting factors of corresponding to the order of values.
activeKeys | Peptide quant keys corresponding to the order of values.
inactiveKeys | Peptide quant keys skipped or excluded.

Implements ms_quantitation.

◆ getSummary()

const matrix_science::ms_peptidesummary & getSummary ( ) const

The summary is needed to recover the proteins and peptides.

Deprecated:
Use getPeptideSummary() instead.
Returns
The summary that was passed to the constructor.

◆ getTimeAlignmentData() [1/2]

matrix_science::ms_ms1quant_time_align & getTimeAlignmentData ( )

Returns the time alignment data for label free quantitation.

Only available for label free quantitation using the Replicate protocol

For other protocols, calling getStatus() on the return value of this function will return ms_ms1quant_time_align::ST_TA_NO_DATA

Returns
the time alignment data if that has been saved in the project

◆ getTimeAlignmentData() [2/2]

const matrix_science::ms_ms1quant_time_align & getTimeAlignmentData ( ) const

Returns the time alignment data for label free quantitation.

Only available for label free quantitation using the Replicate protocol.

For other protocols, calling getStatus() on the return value of this function will return ms_ms1quant_time_align::ST_TA_NO_DATA

Returns
the time alignment data if that has been saved in the project

◆ getUnnormalisedAveragePeptideRatio() [1/3]

double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType
 | ) |  | const
 inherited

Calculate the unnormalised average peptide ratio.

All peptide ratios currently stored in the object are used in calculation. If there are no peptide ratios associated with the ratio name, the method returns 1.0. Negative and infinite values are ignored.

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
Returns
The average of all peptide ratios currently stored in the object, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.

◆ getUnnormalisedAveragePeptideRatio() [2/3]

double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType,
 |  | const ms_peptide_quant_key_vector & | keys
 | ) |  | const
 inherited

Calculate the unnormalised average of selected peptide quant keys.

All peptide ratios matching ratioName and whose peptide quant key is in keys are chosen for calculation. If there are no such peptide ratios, the method returns 1.0. Negative and infinite values are ignored.

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
keys | Peptide quant keys of peptide ratios to use in calculation.
Returns
The average of all selected peptide ratios, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.

◆ getUnnormalisedAveragePeptideRatio() [3/3]

double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType,
 |  | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const
 inherited

Calculate the unnormalised average of peptide quant keys of a protein accession.

All peptide ratios matching ratioName and associated with the protein accession and database index are chosen for calculation. If there are no such peptide ratios, the method returns 1.0. Negative and infinite values are ignored. You can alter the protein-peptide mapping with addPeptideQuantKey().

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
accession | Protein accession.
dbIdx | Protein database index.
Returns
The average of all selected peptide ratios, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.

◆ hasPeptideRatio()

bool hasPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 virtualinherited

Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
True if the peptide ratio exists; false otherwise.

Implements ms_quantitation.

◆ initGroupChargeStates()

void initGroupChargeStates | ( | std::set< int > * | calc_chargestates,
 |  | int | iGroup1,
 |  | int | minCharge,
 |  | int | maxCharge
 | ) |  |

Add inferred charge states to the group if specified in the method.

Only called if ms_quant_integration::isAllChargeStates() returns true

This extends the mass and time matching to cover contiguous charge states. In other words, if there is a positive match on 2+, the software will look for 1+ and 3+. It will not look for 4+ unless 3+ is found, etc.

Parameters
[out] | calc_chargestates | will contain the list of calculated charges added
[in] | iGroup1 | must be in the range 1..getNumGroups()
[in] | minCharge | will be the value in the quantitation method: ms_quant_quality::getMinPrecursorCharge
[in] | maxCharge | will normally be the MDRO processing option: MS->MaxPeakCharge

◆ initialiseBaseSettings()

bool initialiseBaseSettings | ( | const ms_quant_method & | qmBase,
 |  | const ms_quant_method & | qmConfig
 | ) |  |
protectedinherited

Initialise quantitation method settings from the two method objects.

For any method settings which are not consistent between the passed qmBase and qmConfig, the values from qmConfig will be used.

Parameters
qmBase | The base quantitation method as defined on the Mascot server.
qmConfig | The quantitation method to use to calculate quantitation results using.
Returns
True.

◆ isAverageProtocol()

bool isAverageProtocol ( ) const

Return true if the quantitation method uses the Average protocol.

Returns
True if the quantitation method uses the Average protocol.

◆ isPeptideRatioExcluded()

bool isPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 virtualinherited

Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?

(This method is redundant; you could also look up the peptide ratio and use ms_peptide_quant_ratio::isExcluded().)

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
True if the peptide ratio should be excluded from protein ratio calculation; false otherwise.

Implements ms_quantitation.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ loadCdbFile()

bool loadCdbFile | ( | const std::string & | cdbFilename,
 |  | const std::string & | cacheFilename,
 |  | bool | revalidateQualityThresholds = true
 | ) |  |

Load the results from a matched pair of files.

Distiller stores these in a project file (*.rov) in streams 3000+n and 8000+n where n is the value in the projectStream attribute of the QuantResult from the Quantitation folder.

If the function fails, any errors are reported in the (base class) ms_errors object.

Parameters
cdbFilename | The path and filename of the CDB file containing the quantitation results.
cacheFilename | The path and filename of the file containing the quantitation cache data.
revalidateQualityThresholds | If true, the MS/MS peptide match evidence will be retested against the method quality thresholds. If no settings have been changed, this parameter should be set to false as re-evaluating the thresholds can lose user selections. However, if this parameter is incorrectly set to false, then misleading quantitation results may be obtained. [default=true]
Returns
True if the files were loaded successfully.

◆ loadXmlFile()

bool loadXmlFile | ( | const std::string & | filename,
 |  | const std::string & | xmlSchemaPath
 | ) |  |

Load quantitation results from an XML file. The schema is loaded from the location known to the.

This uses the ms_mascotresfilebase attached to the ms_peptidesummary supplied in the constructor. If no schema location was specified to the ms_mascotresfilebase then loading the XML file will fail.

If the function fails, any errors are reported in the (base class) ms_errors object.

A warning message is added to ms_errors to indicate whenever a protein reference has been changed or removed because the peptide summar results do not match the quantitation results.

If the schema path contains spaces, it should be prefixed with "file:///" and the spaces should be replaced with "%20"

Parameters
filename | The path and filename of the file to load.
xmlSchemaPath | The folder where the quantitation XML schema files (XSD) can be found.
Returns
True if the file was loaded successfully.

◆ mergeQuantitationResults() [1/2]

bool mergeQuantitationResults | ( | const std::vector< std::string > & | cdbFilenames,
 |  | const std::vector< std::string > & | cacheFilenames,
 |  | const MERGE_QUANT_RESULTS_FLAGS | flags,
 |  | const matrix_science::ms_quant_method * | originalMethod = 0
 | ) |  |

Merges the quantitation results from matched pairs of cdb files.

This method merges the passed pairs of cdb files into the current object.

To use it, create a new ms_ms1quantitation::ms_ms1quantitation() object, passing in the ms_peptidesummary object for the merged search results and the quantitation method for the new merged results.

If you have changed the quantitation quality settings, you should pass in a pointer to the original quantitation settings. This method will then compare between the new and original settings. If the changed settings cause a change which cannot be handled within the ms_ms1quantitation class, then error details will be set and the method will return false. For example, if you enabled mass-time-matching when the original dataset has this setting disabled then additional matches would need quantification carrying out from within Mascot Distiller.

Parameters
cdbFilenames | Vector containing the paths and filenames of the Mascot Distiller quantitation results cdb files to merge.
cacheFilenames | Vector containing the paths and filenames of the Mascot Distiller quantitation cache cdb files to merge.
flags | is one or more ms_ms1quantitation::MERGE_QUANT_RESULTS_FLAGS bitwise ORed together
originalMethod | Optional pointer to the original quantitation method. Set this only if the passed method is different.
Returns
true if successful. If false is returned, call getLastError() to see the error that was encountered.

◆ mergeQuantitationResults() [2/2]

bool mergeQuantitationResults | ( | const std::vector< std::string > & | xmlFilenames,
 |  | const MERGE_QUANT_RESULTS_FLAGS | flags,
 |  | const std::string & | xmlSchemaPath = "",
 |  | const matrix_science::ms_quant_method * | originalMethod = 0
 | ) |  |

Merges the quantitation results loaded from xml result files.

This helper method merges the passed xml result files into the current object.

To use it, create a new ms_ms1quantitation::ms_ms1quantitation() object, passing in the ms_peptidesummary object for the merged search results and the quantitation method for the new merged results.

If you have changed the quantitation quality settings, you should pass in a pointer to the original quantitation settings. This method will then compare between the new and original settings. If the changed settings cause a change which cannot be handled within the ms_ms1quantitation class, then error details will be set and the method will return false. For example, if you enabled mass-time-matching when the original dataset has this setting disabled then additional matches would need quantification carrying out from within Mascot Distiller.

Parameters
xmlFilenames | Vector containing the paths and filenames of the Mascot Distiller quantitation result xml files to merge.
xmlSchemaPath | Path to the directory containing the Distiller quantitation results xml schema file.
flags | is one or more ms_ms1quantitation::MERGE_QUANT_RESULTS_FLAGS bitwise ORed together
originalMethod | Optional pointer to the original quantitation method. Set this only if the passed method is different.
Returns
true if successful. If false is returned, call getLastError() to see the error that was encountered.

◆ openQuantitationCdbResults()

matrix_science::ms_ms1quantitation * openQuantitationCdbResults | ( | const matrix_science::ms_peptidesummary & | summary,
 |  | const matrix_science::ms_quant_method & | method,
 |  | const std::string & | cdbFilename,
 |  | const std::string & | cacheFilename,
 |  | const matrix_science::ms_quant_method * | originalMethod = 0
 | ) |  |
static

Opens and loads quantitation results from a matched pair of cdb files.

This helper method creates, loads and returns an ms_ms1quantitation object for a pair of matched cdb files. If you have changed the quantitation quality settings, you should pass in a pointer to the original quantitation settings. This method will then compare between the new and original settings. If the changed settings cause a change which cannot be handled within the ms_ms1quantitation class, then the error details will be set on the returned ms_ms1quantitation object - For example, if you enabled mass-time-matching when the original dataset has this setting disabled then additional matches would need quantification carrying out from within Mascot Distiller. Use the isValid() method of ms_ms1quantitation to check if the returned quantitation results object is valid.

Note: In unmanaged languages such as C++, this method returns a pointer to a new ms_ms1quantitation method. It is the responsibility of the calling code to delete this when the ms_ms1quantitation object has been finished with.

Parameters
summary | The Mascot result peptide summary the quantitation results apply to.
method | The quantitation settings to generate the report using.
cdbFilename | The path and filename of the Mascot Distiller quantitation results cdb file to open.
cacheFilename | The path and filename of the Mascot Distiller quantitation cache file.
originalMethod | Optional pointer to the original quantitation method. Set this only if the passed method is different.
Returns
The calculated ms_ms1quantitation results. If errors were encountered, they will be set to the returned object. Check the value of isValid() and getLastError() to see if an error was encountered.

◆ openQuantitationXmlResults()

matrix_science::ms_ms1quantitation * openQuantitationXmlResults | ( | const matrix_science::ms_peptidesummary & | summary,
 |  | const matrix_science::ms_quant_method & | method,
 |  | const std::string & | filename,
 |  | const std::string & | xmlSchemaPath = "",
 |  | const matrix_science::ms_quant_method * | originalMethod = 0
 | ) |  |
static

Opens and loads quantitation results from an xml result file.

This helper method creates, loads and returns an ms_ms1quantitation object from an exported Mascot Distiller quantitation results xml file. If you have changed the quantitation quality settings, you should pass in a pointer to the original quantitation settings. This method will then compare between the new and original settings. If the changed settings cause a change which cannot be handled within the ms_ms1quantitation class, then the error details will be set on the returned ms_ms1quantitation object - For example, if you enabled mass-time-matching when the original dataset has this setting disabled then additional matches would need quantification carrying out from within Mascot Distiller. Use the isValid() method of ms_ms1quantitation to check if the returned quantitation results object is valid.

Note: In unmanaged languages such as C++, this method returns a pointer to a new ms_ms1quantitation method. It is the responsibility of the calling code to delete this when the ms_ms1quantitation object has been finished with.

Parameters
summary | The Mascot result peptide summary the quantitation results apply to.
method | The quantitation settings to generate the report using.
filename | The path and filename of the Mascot Distiller quantitation results xml file to open.
xmlSchemaPath | The path to the directory containing the Distiller quantitation results xml schema file.
originalMethod | Optional pointer to the original quantitation method. Set this only if the passed method is different.
Returns
The calculated ms_ms1quantitation results. If errors were encountered, they will be set to the returned object. Check the value of isValid() and getLastError() to see if an error was encountered.

◆ readResultCounters()

bool readResultCounters | ( | const std::string & | cdbFile,
 |  | int & | numMatches,
 |  | int & | numHits,
 |  | int & | numPepGrp,
 |  | int & | numPeptideComponents
 | ) |  |
static

Reads and returns the Counters information from the cdb result file.

This helper method loads the Counters values from the passed cdbfile and sets the return values. See Multiple return values in Perl, Java, Python and C#.

Parameters
cdbFile | The cdbfile to load the counters from
[out] | numMatches | The number of peptide quant matches is set to this parameter
[out] | numHits | The number of protein hits quantified
[out] | numPepGrp | The number of peptide groups
[out] | numPeptideComponents | The number of peptide components
Returns
True if the counters have been read and the return values set, false if not

◆ removeMatch()

void removeMatch ( matrix_science::ms_peptide_quant_key matchKey )

Remove the specified peptide match from the results.

Parameters
matchKey The identifier of the peptide quantitation match

◆ removePeptideQuantKey()

void removePeptideQuantKey | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key & | key
 | ) |  |
inherited

Deassociate a peptide quant key from the given protein.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
key | Peptide quant key.

◆ removePeptideRatio()

void removePeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |
inherited

Remove a particular peptide ratio.

However, the protein-peptide mapping related to the peptide quant key will not be changed.

Parameters
key | Peptide quant key.
ratioName | Ratio name.

◆ removePeptideRatioNormalisationBase()

void removePeptideRatioNormalisationBase ( const std::string & ratioName )
inherited

Reset the peptide ratio normalisation base of the given ratio name.

Resetting means the report ratio normalisation constant is set to 1.0. This has the same effect as calling setPeptideRatioNormalisationBase() with b = 1.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

Parameters
ratioName Ratio name whose normalisation base is to be reset.

◆ removePeptideRatioNormalisationBases()

void removePeptideRatioNormalisationBases ( )
inherited

Reset all peptide ratio normalisation bases.

Resetting all report ratio normalisation bases means all peptide and protein ratios become unnormalised.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

◆ saveCdbFile()

bool saveCdbFile | ( | const std::string & | cdbFilename,
 |  | const std::string & | cacheFilename,
 |  | bool | createEmptyMissingComponents = false
 | ) |  |

Save the results to a matched pair of files.

Distiller stores these in an MDRO project file (*.rov) in streams 3000+n and 8000+n where n is the value in the projectStream attribute of the QuantResult from the Quantitation folder.

If cdbFilename already exists and can be opened as a CDB file, then this function just returns true immediately.

Parameters
cdbFilename | The path and filename of the CDB file to receive the quantitation results.
cacheFilename | The path and filename of the CDB file to receive the quantitation cache data.
createEmptyMissingComponents | should be set to true for cases like the Replicate protocol where an individual raw file does not have the other components. The CDB file expects a component for each item component specified in the method.
Returns
True if the file was saved successfully.

◆ saveXmlFile()

bool saveXmlFile | ( | const std::string & | xmlFilename,
 |  | bool | completeReport,
 |  | bool | saveTimeAlignmentData = false
 | ) |  |

Save the quantitation results to an XML file.

The schema for the XML file is: distiller_quantitation_2.xsd

Some ratios calculations will results in an 'invalid' number, for example, because of no data (NaN) or division by zero. In these cases, the XML will have additional element(s), with ms_ms1quant_match_ratio::ratioStatusCode to describe them.

To simplify code for consumers of the xml, the 'value' saved in the xml is converted to a finite value accordingly:

IEEE 754-2008 Value | Standard XML representation | Value output to XML | ratioStatusCode(s)
qNaN or sNaN | "NaN" | "0" | "RatioUndefined"
+infinity | "INF" | "999999999999999967336168804116691273849533185806555472917961779471295845921727862608739868455469056.000000" (this value is the text representation of 1e99) | "InfiniteRatio"
-infinity; | "-INF" | "999999999999999967336168804116691273849533185806555472917961779471295845921727862608739868455469056.000000" (this value is the text representation of 1e99) | "InfiniteRatio" and "NegativeRatio"
Parameters
xmlFilename | The path and filename of the file to save.
completeReport | True if a complete report of all data is to be generated, or false to generate concise report data.
saveTimeAlignmentData | should be set to true to save the data from the matrix_science::ms_ms1quant_time_align object. The data saved in the xml will be identical to that as saved by ms_ms1quant_time_align::saveXmlFile but within a <timeAlignment> element and using a "ta" namespace
Returns
True if the file was saved successfully.

◆ setAverageNumPeptides()

void setAverageNumPeptides ( unsigned int num = 3 )

Average protocol only: set the number of most intense peptide groups to use.

This method only works when quantitation method protocol is Average. If protocol is not Average, calling the method has no effect.

In the Average protocol, protein intensities are calculated as the sum of the "top \a num" peptide intensities assigned to the protein hit. num is conventionally 3.

Parameters
num The number of most intense peptide intensities to use in calculating protein intensities in the Average protocol. If 0, the value is reset to 3.

◆ setAverageReferenceProtein()

void setAverageReferenceProtein | ( | const char * | accession,
 |  | int | dbIdx,
 |  | bool | isReferenceUserSelected
 | ) |  |

Average protocol only: select a reference protein accession and database.

This method only works when quantitation method protocol is Average. If protocol is not Average, calling the method has no effect.

In the Average protocol, protein ratios are relative to a specified reference protein, identified by its accession and dbIdx The reference protein should be one that has peptide ratios (intensities) associated with it. If it does not, getProteinRatio() will simply return raw intensity values.

If the quantitation method doesn't specify an accession, then the calling software should find the first protein hit, pass the accession and dbIdx of that hit and pass isReferenceUserSelected as false.

Calling this method does not modify the current quantitation method.

Parameters
accession | Accession of the reference protein. If null or an empty string, the warning matrix_science::ms_errs::ERR_MSP_QUANT_EMPTY_REF_ACCESSION will be set, and the function does nothing.
dbIdx | The database the protein is from. Must be correct! If the search results don't contain a protein matching the passed accession and dbIdx, then the warning matrix_science::ms_errs::ERR_MSP_QUANT_ACCESSION_NOT_FOUND is set
isReferenceUserSelected | should be set to true if the reference accession was specified in the method.

◆ setAverageSelection()

void setAverageSelection ( const char * mode )

Average protocol only: set the method of grouping peptide ratios.

This method only works when quantitation method protocol is Average. If protocol is not Average, calling the method has no effect.

In the Average protocol, protein intensities are calculated as the sum of the "top" peptide intensities assigned to the protein hit. If peptides are _identical_ then they all included but only count as one peptide for the purpose of determining the average. The selection mode determines how the peptides are compared to see if they should be treated as identical or not.

Whether to require the peptides to be used to be unique sequences (unique_sequence), or to accept different modification states of same sequence (unique_mr), or even accept peptides with same sequence and modifications in different charge states (unique_mz).

Parameters
mode The way in which peptides are matched when selecting peptide intensities for the protein.

◆ setMinNumPeptides()

void setMinNumPeptides ( int value )
inherited

Set the minimum number of peptides needed for protein ratio calculation.

Changing the minimum number of peptides changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: The Average protocol has two settings for minimum number of peptides. This setting defines how many peptide intensities are needed for a protein before its ratio can be calculated. It is usually meaningless to choose a value other than 1. Use ms_customquantitation::setAverageNumPeptides() to define how many intensities should be used in protein ratio calculation.

Parameters
value The minimum number of peptide ratios (the sample size) a protein must have for protein ratio calculation purposes. Values less than 1 are interpreted as 1.

◆ setPeptideRatioExcluded()

void setPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |
virtualinherited

Globally exclude a particular peptide ratio from protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

◆ setPeptideRatioIncluded()

void setPeptideRatioIncluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |
virtualinherited

Globally include a particular peptide ratio in protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

◆ setPeptideRatioNormalisationBase()

void setPeptideRatioNormalisationBase | ( | const std::string & | ratioName,
 |  | double | b
 | ) |  |
inherited

Set the peptide ratio normalisation base of the given ratio name.

Setting peptide ratio normalisation to a particular value means all peptide ratios with ratioName will be divided by b before they are returned by getPeptideRatio(). That is, the underlying peptide ratios remain unaffected, which means this method will always return immediately without computing anything.

In ms_ms2quantitation, normalisation constants can most easily be calculated with ms_ms2quantitation::normalisePeptideRatios(), if normalisation is enabled and configured in the quantitation method. You are free to override this, but keeping track of who calculated which constant is up to you.

It is not a good idea to define both peptide ratio normalisation and component intensity normalisation at the same time. In fact, you can only configure one or the other using setQuantNormalisation(), and neither normalisePeptideRatios() nor normaliseIntensities() will step on each other's toes.

It is possible, but not recommended, to manually set normalisation bases for both peptide ratios and component intensities. The resulting peptide ratios are most likely meaningless.

In ms_customquantitation, you can use ms_customquantitation::getUnnormalisedAveragePeptideRatio() to calculate the mean or median of peptide ratios currently stored in the class, for normalisation purposes.

You can always set b to 1 to disable peptide ratio ratioName normalisation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters
ratioName | Peptide ratio name to normalise.
b | New normalisation base. If it is zero, the old base will be kept. If this is the first time the base is set, a value of 0 means it is set to 1.0.

◆ setProteinRatioType()

void setProteinRatioType ( const char * value )
virtualinherited

Set the protein ratio type.

Changing the protein ratio type changes the current quantitation method. It does not alter the original quantitation method object.

ms_ms2quantitation supports "median", "average" and "weighted", and ms_customquantitation supports "median" and "average. If the ratio type is not implemented, it is set to "median". <strong>Using the Average protocol in ms_customquantitation</strong>: If quantitation protocol is Average, the only supported protein ratio type is "average". Setting it to anything else will result in an error. You should inspect isValid() and use clearAllErrors() should you accidentally do so.

Parameters
value Protein ratio type (e.g. median, average, weighted). Accepted values are defined in the quantitation XML schema.

Implements ms_quantitation.

◆ setQuantOutliers()

void setQuantOutliers ( const ms_quant_outliers * qo )
virtualinherited

Set new peptide ratio outlier settings.

Peptide ratio outlier detection can be configured in several ways. Please consult the quantitation configuration help page for details.

Changing outlier settings changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: It is an error to define outlier removal if quantitation protocol is Average. You will need to inspect isValid() and clear the error with clearAllErrors() should you accidentally do so.

Parameters
qo An outlier configuration object. If this is NULL, outlier detection will be disabled (equivalent to "none").

Implements ms_quantitation.

◆ setTimeAlignmentData()

void setTimeAlignmentData ( matrix_science::ms_ms1quant_time_align & alignmentData )

Only available for label free quantitation using the Replicate protocol

Parameters
alignmentData is the new time alignment data
The documentation for this class was generated from the following files:
  • ms_ms1quantitation.hpp
  • ms_ms1quantitation.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms2quantitation Class Reference

  • matrix_science
  • ms_ms2quantitation
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ms_ms2quantitation Class Reference
Quantitation analysis for Mascot Server and Distiller

Peptide and protein quantitation in a Reporter or Multiplex Mascot results file. More...

#include <ms_ms2quantitation.hpp>

Inheritance diagram for ms_ms2quantitation:
[legend]
Collaboration diagram for ms_ms2quantitation:
[legend]

Public Member Functions

ms_ms2quantitation (const ms_peptidesummary &pepsum)
Default constructor: load the quantitation method from the results file and quantitate all peptides that pass the quality thresholds.
ms_ms2quantitation (const ms_peptidesummary &pepsum, const ms_quant_method &qm)
Quantitate all peptides that pass the quality thresholds using the given quantitation method.
virtual | ~ms_ms2quantitation ()
Destructor.
void | addHeaderField (const std::string &name, const std::string &value)
Adds an item of project or search header information.
void | addRawFileField (const unsigned int id, const std::string &name, const std::string &value)
Adds an item of raw file header information.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearHeaderFields ()
Clears any header information from the result.
void | clearRawFileFields ()
Clears any raw file header information from the result.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual int | countDistinctPeptides (const ms_peptide_quant_key_vector &activeKeys) const
Bring across base class member that we don't overload, otherwise it will be hidden.
virtual int | countDistinctPeptides (const std::vector< ms_peptide_quant_key > &activeKeys) const
Bring across base class member that we don't overload, otherwise it will be hidden.
virtual int | countDistinctPeptides (const std::vector< ms_peptide_quant_key > &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
void | excludeProteinPeptideRatioKeys (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &excludeKeys)
Excludes the passed peptide ratio values from the protein ratio calculation.
const ms_quant_ratio * | getCombinedReportRatio (const std::string &ratioName) const
Return a combined quantitation ratio matching the given name.
std::vector< std::string > | getCombinedReportRatioNames () const
Return a list of current combined report ratio names.
std::vector< double > | getComponentIntensities (const ms_peptide_quant_key &key, bool raw=false) const
Return the component intensities for the given peptide-spectrum match, if available.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
double | getIntensityNormalisationBase (const std::string &componentName) const
Get the intensity normalisation base of the given component name.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
ms_peptide_quant_key_vector | getPeptideQuantKeys (const std::string &accession, int dbIdx) const
Look up peptide quant keys associated with a given protein, if any.
virtual ms_peptide_quant_ratio | getPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Given peptide quant key and ratio name, return the corresponding peptide ratio data.
double | getPeptideRatioNormalisationBase (const std::string &ratioName) const
Get the peptide ratio normalisation base of the given ratio name.
const ms_peptidesummary & | getPeptideSummary () const
The summary is needed to recover the proteins and peptides.
const ms_progress_info & | getProgressInfo ()
Get information about the progress of a currently running long operation (e.g. loading from a file).
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName) const
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const
Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.
const ms_quant_method & | getQuantitationMethod () const
Return the current quantitation method.
const ms_quant_ratio * | getReportRatioFromFile (unsigned int fileNum, const std::string &ratioName) const
Return a quantitation ratio matching the given name in the given file.
std::vector< std::string > | getReportRatioNamesInFile (unsigned int fileNum) const
Return a list of current report ratio names in the given file.
bool | hasIntensityNormalisation () const
Return true if intensity normalisation is enabled and configured.
virtual bool | hasPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.
bool | hasPeptideRatioNormalisation () const
Return true if peptide ratio normalisation is enabled and configured.
void | includeProteinPeptideRatioKeys (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys)
Includes the passed peptide ratio values in the protein ratio calculation.
virtual bool | isPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName) const
Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?
bool | isValid () const
Call this function to determine if there have been any errors.
bool | loadCdbFile (const char *path)
Load user adjusted protein-peptide quantitation ratio settings from a cdb file.
bool | loadCdbFiles (const std::vector< std::string > &cdbFiles)
Merges the settings from multiple protein-peptide user selection cdbfiles.
void | normaliseIntensities ()
Normalise component intensities, or do nothing if intensity normalisation is disabled.
void | normalisePeptideRatios ()
Normalise peptide ratios, or do nothing if normalisation is disabled.
void | removeCombinedReportRatio (const std::string &ratioName)
Remove the combined quantitation ratio matching the given name from all files.
void | removeIntensityNormalisationBase (const std::string &componentName)
Reset the intensity normalisation base of the given ratio name.
void | removeIntensityNormalisationBases ()
Reset all Intensity normalisation bases.
void | removePeptideRatioNormalisationBase (const std::string &ratioName)
Reset the peptide ratio normalisation base of the given ratio name.
void | removePeptideRatioNormalisationBases ()
Reset all peptide ratio normalisation bases.
void | removeReportRatioInFile (unsigned int fileNum, const std::string &ratioName)
Remove the quantitation ratio matching the given name from the given file.
bool | saveCdbFile (const std::string &cdbFilename)
Save the user edited protein-peptide quantitation settings to a cdb file.
bool | saveXmlFile (const std::string &xmlFilename, bool completeReport)
Save the quantitation results to an XML file.
void | setCombinedReportRatio (const std::string &ratioName, const ms_quant_ratio &ratioDef)
Add or modify the combined quantitation ratio matching the given name in all files.
void | setIntensityNormalisationBase (const std::string &componentName, double b)
Set the intensity normalisation base of the given component name.
void | setMinNumPeptides (int value)
Set the minimum number of peptides needed for protein ratio calculation.
virtual void | setPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally exclude a particular peptide ratio from protein ratio calculation.
virtual void | setPeptideRatioIncluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally include a particular peptide ratio in protein ratio calculation.
void | setPeptideRatioNormalisationBase (const std::string &ratioName, double b)
Set the peptide ratio normalisation base of the given ratio name.
virtual void | setProteinRatioType (const char *value)
Set the protein ratio type.
void | setQuantNormalisation (const ms_quant_normalisation *norm)
Set new peptide and protein ratio normalisation settings.
virtual void | setQuantOutliers (const ms_quant_outliers *)
Set new peptide ratio outlier settings.
void | setReportRatioInFile (unsigned int fileNum, const std::string &ratioName, const ms_quant_ratio &ratioDef)
Add or modify the quantitation ratio matching the given name in the given file.

Protected Member Functions

ms_protein_quant_ratio | calculateGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the geometric mean and standard deviation.
ms_protein_quant_ratio | calculateMedianRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the median and standard deviation from the median.
ms_protein_quant_ratio | calculateWeightedGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.
int | getMinNumPeptides () const
Get the minimum number of peptides needed for protein ratio calculation.
void | getProteinRatioSample (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const
Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.
virtual void | getSortedFinitePeptideRatioValues (const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const
Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.
bool | initialiseBaseSettings (const ms_quant_method &qmBase, const ms_quant_method &qmConfig)
Initialise quantitation method settings from the two method objects.

Protected Attributes

protein_to_peptide_quant_key_t proteinKeys_
Protein-to-peptide mapping.

Detailed Description

Peptide and protein quantitation in a Reporter or Multiplex Mascot results file.

ms_ms2quantitation implements a single use case: given a Mascot results file of a search whose quantitation protocol is Reporter (e.g. iTRAQ) or Multiplex (e.g. 18O), it will calculate, on demand, peptide and proteins ratios from component intensities extracted from the MS/MS spectra.

Peptide ratios are identified by q,p peptide quant keys (ms_peptide_quant_key(int q, int p)). Not all peptide matches in the results file have an associated peptide ratio; for example, the Reporter ions could be missing from the input query.

Protein ratios are identified by protein accession and database index. There are three types of ratio: median, average and weighted. Median is the median of all peptide ratios associated with the protein hit, and average is the geometric mean (equivalently, the arithmetic mean of log-transformed peptide ratios). Weighted is a weighted mean of peptide ratios, where the weights are channel intensities. The weighted ratio type is only available for Reporter data.

All values are read-only. If you need to edit anything, apart from protein ratio calculation settings, or if you need to use some other protocol, use ms_customquantitation instead.

The class supports all types of normalisation configurable in the quantitation method. However, you need to explicitly ask for the normalisation constants to be calculated (see normalisePeptideRatios()). This is because normalisation may require calculating peptide ratios for all quantifiable peptide matches in the results file, which can be a time-consuming operation. Thus, if you change parameters or ratio definitions, and normalisation is enabled, you will need to call normalisePeptideRatios() to recalculate the normalisation constants. (If normalisation is not enabled, there is no penalty in calling normalisePeptideRatios().)

You can skip the remainder of this section if you are not combining results files (see Combining multiple results files for background reading).

If the results file is a merged file, peptide ratios will be merged across the files in the following way. Imagine peptide ratios are arranged in a table, so that a row contains the report ratios for a particular peptide (q,p), and the columns are indexed by report ratio names. Each report ratio with a unique name becomes its own column. If a report ratio with the same name appears in more than one file, these are treated as the same column (regardless of whether the formulas are exactly the same).

There are three complications which you must address:

  1. Two report ratios with the same formula may not actually have the same name in different files (e.g. the iTRAQ 115/114 ratio is called "115/114" in one file but "Control" in another).
  2. Two report ratios with the same name may not actually have the same formulas in different files (e.g. the report ratio named "Control" in one file is not calculated the same way "Control" is in another).
  3. Two report ratios with the same name and same formula may mean different things in different files (e.g. "115/114" is control in one file, patient in another).

The solution is to modify report ratios in different files using setCombinedReportRatio(), so that the names, formulas and meanings match between files. Of course, if you want to keep ratios from different files separate, you need to rename ratios in each file (using setReportRatioInFile()) so that they are all different across all files.

Note the naming convention: methods with "InFile" (e.g. setReportRatioInFile()) modify report ratios in a single file (in the combined results file), while methods with "Combined" (e.g. setCombinedReportRatio()) modify report ratios across all files (in the combined results file).

Constructor & Destructor Documentation

◆ ms_ms2quantitation() [1/2]

ms_ms2quantitation ( const ms_peptidesummary & pepsum )
explicit

Default constructor: load the quantitation method from the results file and quantitate all peptides that pass the quality thresholds.

The constructor performs the following steps. If any of them fail, the corresponding error will be set and the object left in invalid state. Use isValid() to check for this and getLastErrorString() to fetch the error description:

  • Load the quantitation method from the results file. If the results file has no quantitation method, or it doesn't validate against the schema, the process ends here.
  • If protocol isn't Reporter or Multiplex, the process ends here. (Use ms_customquantitation instead, as outlined in Peptide and protein quantitation.)
  • Prepare combined report ratios, if the input file is a combined results file.

Note that the constructor will not normalise peptide ratios or component intensities automatically, even if normalisation is enabled and configured. You need to call normalisePeptideRatios() and normaliseIntensities().

Parameters
pepsum Mascot results file to quantitate. Note that you must first validate the embedded XML sections of the results file. Either pass the schema directory to the ms_mascotresfilebase constructor or use ms_mascotresfilebase::setXMLschemaFilePath().

◆ ms_ms2quantitation() [2/2]

ms_ms2quantitation | ( | const ms_peptidesummary & | pepsum,
 |  | const ms_quant_method & | qm
 | ) |  |

Quantitate all peptides that pass the quality thresholds using the given quantitation method.

The constructor performs the following steps. If any of them fail, the corresponding error will be set and the object left in invalid state. Use isValid() to check for this and getLastErrorString() to fetch the error description:

  • Load the quantitation method from the results file. If the results file has no quantitation method, or it doesn't validate against the default quantitation schema, the process ends here.
  • If protocol isn't Reporter or Multiplex, the process ends here. (Use ms_customquantitation instead, as outlined in Peptide and protein quantitation.)
  • If the protocol or component definitions between the embedded quantitation method and qm do not match, as tested with ms_quant_method::isMethodCompatible(), the process ends here with an error.
  • Prepare combined report ratios, if the input file is a combined results file.

Note that the constructor will not normalise peptide ratios or component intensities automatically, even if normalisation is enabled and configured. You need to call normalisePeptideRatios() and normaliseIntensities().

Parameters
pepsum | Mascot results file to quantitate. Note that you must first validate the embedded XML sections of the results file. Either pass the schema directory to the ms_mascotresfilebase constructor or use ms_mascotresfilebase::setXMLschemaFilePath().
qm | Quantitation method to use. The protocol and component definitions must match exactly those defined in the results file. It is best to use the return value from ms_mascotresfilebase::getQuantitationMethod() as the base and then alter peptide quality settings as needed.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ calculateGeometricMeanRatio()

ms_protein_quant_ratio calculateGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protectedinherited

Given a sample of peptide ratios, calculate the geometric mean and standard deviation.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.

◆ calculateMedianRatio()

ms_protein_quant_ratio calculateMedianRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protectedinherited

Given a sample of peptide ratios, calculate the median and standard deviation from the median.

See ms_quant_stats::sortedMedian for details of how this is calculated.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-values, if relevant.

◆ calculateWeightedGeometricMeanRatio()

ms_protein_quant_ratio calculateWeightedGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< double > & | weights,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protectedinherited

Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ countDistinctPeptides()

int countDistinctPeptides ( const std::vector< ms_peptide_quant_key > & activeKeys ) const
virtual

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

Parameters
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns
The number of distinct peptides.

Reimplemented from ms_quantitation.

◆ excludeProteinPeptideRatioKeys()

void excludeProteinPeptideRatioKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | excludeKeys
 | ) |  |

Excludes the passed peptide ratio values from the protein ratio calculation.

Sets the user excluded list of peptide ratio keys for the specified protein hit and ratio.

Parameters
accession | The accession of the protein.
dbIdx | The database the protein is from.
ratioName | The name of the ratio to calculate.
excludeKeys | The vector of peptide ratio keys to exclude

◆ getCombinedReportRatio()

const ms_quant_ratio * getCombinedReportRatio ( const std::string & ratioName ) const

Return a combined quantitation ratio matching the given name.

Even if the report ratio formulas of ratio ratioName differ between the files, they are considered the same (merged in the same "column"), since they have the same name. This method returns the ratio definition from the first file (in numerical order) that has a definition with the name ratioName. You should always verify, using getReportRatioFromFile() and related methods, that the definitions with the same names are actually the same before relying on the return value of this method.

Parameters
ratioName The name of the report ratio. This must match exactly (case sensitively) the desired report ratio name.
Returns
If no such report ratio exists, this method returns NULL. Otherwise the corresponding object is returned.

◆ getCombinedReportRatioNames()

std::vector< std::string > getCombinedReportRatioNames ( ) const

Return a list of current combined report ratio names.

This method returns the unique report ratio names across all files (i.e. the "columns" in the peptide ratio table).

Returns
The list of combined report ratio names in the order they appear in each file. Duplicate ratio names are removed.

◆ getComponentIntensities()

std::vector< double > getComponentIntensities | ( | const ms_peptide_quant_key & | key,
 |  | bool | raw = false
 | ) |  | const

Return the component intensities for the given peptide-spectrum match, if available.

In the Reporter protocol, component intensities are extracted from a given input spectrum q based on the presence of reporter ion peaks, regardless of which peptide was matched to the spectrum. In this case all peptide matches in the same query that pass the quality threshold will have the same component intensities.

In the Multiplex protocol, component intensity extraction requires both the input spectrum q and the peptide that was matched to it, identified by (q,p). In this case, if component intensity extraction succeeded, then you may get different component intensities (or none at all) for different values of p.

Parameters
key | Peptide quant key created with ms_peptide_quant_key(int q, int p).
raw | (optional) If true, return raw intensities. Corrected intensities are returned by default. Note that if Reporter "sum" normalisation is in use, the corrected intensities will be normalised, whereas the raw intensities will not be.
Returns
A vector of component intensities, in the same order as components are defined in the quantitation method. This can be empty if there is no component intensity data for the peptide-spectrum match or if it did not pass the quality thresholds.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getIntensityNormalisationBase()

double getIntensityNormalisationBase ( const std::string & componentName ) const

Get the intensity normalisation base of the given component name.

Parameters
componentName Name of one of the components defined in the quantitation method.
Returns
The current intensity normalisation base, or 1 if it hasn't been set.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMinNumPeptides()

int getMinNumPeptides ( ) const
protectedinherited

Get the minimum number of peptides needed for protein ratio calculation.

Returns
The minimum number of peptides needed for protein ratio calculation.

◆ getPeptideQuantKeys()

ms_peptide_quant_key_vector getPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const
 inherited

Look up peptide quant keys associated with a given protein, if any.

In ms_ms2quantitation, the list of peptide quant keys associated with the given protein is immutable, as the keys are derived from q,p values in the Mascot results file. The list does not contain all q,p values, but only those that 1) have component intensities and 2) pass the quality thresholds. Unless the data quality is extremely good, this list will always have fewer elements than the actual peptide matches assigned to the protein hit.

In ms_customquantitation, the peptide-to-protein mapping can be altered with ms_customquantitation::addPeptideQuantKey() and ms_customquantitation::removePeptideQuantKey().

Parameters
accession | The protein accession.
dbIdx | The protein database index.
Returns
A vector of peptide quant keys associated with the protein.

◆ getPeptideRatio()

ms_peptide_quant_ratio getPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 virtual

Given peptide quant key and ratio name, return the corresponding peptide ratio data.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

If hasPeptideRatio(const ms_peptide_quant_key&, std::string) const returns false for the given peptide quant key and ratio name, then the peptide ratio object returned by this method represents an undefined ("missing") value.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
The peptide ratio. If hasPeptideRatio() returns false, the field values of the object returned by this method are undefined.

Implements ms_quantitation.

◆ getPeptideRatioNormalisationBase()

double getPeptideRatioNormalisationBase ( const std::string & ratioName ) const
inherited

Get the peptide ratio normalisation base of the given ratio name.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters
ratioName Peptide ratio name.
Returns
The current peptide ratio normalisation base, or 1 if it hasn't been set.

◆ getPeptideSummary()

const matrix_science::ms_peptidesummary & getPeptideSummary ( ) const

The summary is needed to recover the proteins and peptides.

Returns
The summary that was passed to the constructor.

◆ getProgressInfo()

const matrix_science::ms_progress_info & getProgressInfo ( )
inherited

Get information about the progress of a currently running long operation (e.g. loading from a file).

Returns
Progress information about the most recent long operation.

◆ getProteinRatio() [1/2]

ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName
 | ) |  | const
 virtual

See ms_quantitation::getProteinRatio for further details of how the ratio is calculated

The list of any user included and excluded keys are retrieved from the result before being passed to the base class for processing. These will override the lists of keys set by setPeptideRatioExcluded() and setPeptideRatioIncluded() so that the same result can be obtained as was set when the results were calculated.

See also
includeProteinPeptideRatioKeys()
excludeProteinPeptideRatioKeys()
Parameters
accession | The accession of the protein.
dbIdx | The database the protein is from.
ratioName | The name of the ratio to calculate.
Returns
The match from the list of matches associated with the protein hit, or null if the index or match identifiers are invalid.

Implements ms_quantitation.

◆ getProteinRatio() [2/2]

ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | includeKeys,
 |  | const ms_peptide_quant_key_vector & | excludeKeys
 | ) |  | const
 virtual

Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.

The protein ratio is calculated as described in getProteinRatio(const std::string &, int, const std::string &) const, but the two peptide quant key vectors includeKeys and excludeKeys can be used to override default decisions about globally excluded and outlier peptide ratios. The rules are as follows:

  1. If a peptide quant key is globally excluded with setPeptideRatioExcluded(), then giving the peptide quant key in includeKeys causes the peptide quant key to be included regardless ("undo global exclusion").
  2. If a peptide quant key is given in excludeKeys, then the peptide quant key will be always excluded ("exclude locally").

If the peptide quant key is in both includeKeys and excludeKeys, the latter takes precedence and the peptide quant key is excluded.

Note that if outlier detection is enabled, then a peptide quant key determined to be an outlier cannot be included back using includeKeys, i.e. the inclusion mechanism does not undo outlier removal. You can disable outlier removal entirely before calling getProteinRatio() if you do not want peptide quant keys to be removed.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, then the effect of excludeKeys depends on whether the peptide quant key describes a "top N" peptide intensity. If the peptide intensity is one of the top N intensities assigned to this protein, then excluding it means the next highest outside the top N intensities will take its place. No peptide quant keys will ever be excluded automatically as outliers, since outlier removal has no meaning in this protocol.

Parameters
accession | The protein accession.
dbIdx | The protein database index.
ratioName | The name of the ratio.
includeKeys | Peptide quant keys to always include, even if they are globally excluded or would be marked as outliers.
excludeKeys | Peptide quant keys to always exclude, even if they are not outliers.
Returns
The protein ratio as calculated from peptide ratios associated with this protein accession. If the ratio could not be calculated (e.g. there are no associated peptide ratios), then the returned object will represent an undefined ("missing") value.

Implements ms_quantitation.

◆ getProteinRatioSample()

void getProteinRatioSample | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< ms_peptide_quant_key > & | includeKeys,
 |  | const std::vector< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | sample,
 |  | std::vector< double > & | logSample,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double & | normalityPvalue
 | ) |  | const
 protectedinherited

Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.

This method uses getSortedFinitePeptideRatioValues() internally to collect the vector of peptide ratios. If there are no peptide quant keys associated with the protein, or if no peptide ratios are associated with with those peptide quant keys, then sample, logSample, activeKeys and inactiveKeys will be empty and normalityPvalue will have an undefined value.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
ratioName | Name of the ratio.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
sample | Peptide ratios associated with ratioName and the protein's peptide quant keys, in numerically increasing order.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
activeKeys | Peptide quant keys corresponding to the order of sample (and logSample).
inactiveKeys | Peptide quant keys marked as skipped, excluded or outlier.
normalityPvalue | The p-value that the sample appears to be normally distributed after outlier removal. If less than 0.05, no outliers will have been removed.

◆ getQuantitationMethod()

const ms_quant_method & getQuantitationMethod ( ) const
inherited

Return the current quantitation method.

The current (or effective) quantitation method is the original quantitation method given as argument to the constructor (or loaded from the Mascot results file), with possible later modifications, such as changing normalisation or outlier settings.

For ms_ms2quantitation, you cannot change the protocol settings, component definitions or peptide quality settings. You must create a new object with the new settings instead. You are free to change how protein ratios are calculated and set new normalisation parameters. These changes will be reflected in this method's output value.

For ms_customquantitation, same restrictions apply, although it makes little difference, as the class does not use any protocol settings, component definitions or peptide quality settings.

Returns
The current quantitation method.

◆ getReportRatioFromFile()

const ms_quant_ratio * getReportRatioFromFile | ( | unsigned int | fileNum,
 |  | const std::string & | ratioName
 | ) |  | const

Return a quantitation ratio matching the given name in the given file.

Parameters
fileNum | Integer between 1 and ms_mascotresfilebase::getNumberOfResfiles().
ratioName | The name of the report ratio. This must match exactly (case sensitively) the desired report ratio name.
Returns
If no such report ratio exists, this method returns NULL. Otherwise the corresponding object is returned.

◆ getReportRatioNamesInFile()

std::vector< std::string > getReportRatioNamesInFile ( unsigned int fileNum ) const

Return a list of current report ratio names in the given file.

This method simply returns the names of the report ratios as defined in that file. This is the same order they are defined in the file's embedded quantitation method, unless the report ratios have been later changed with setReportRatioInFile() or setCombinedReportRatio().

Parameters
fileNum Integer between 1 and ms_mascotresfilebase::getNumberOfResfiles().
Returns
The list of report ratio names in file fileNum.

◆ getSortedFinitePeptideRatioValues()

void getSortedFinitePeptideRatioValues | ( | const std::string & | ratioName,
 |  | const std::set< ms_peptide_quant_key > & | keys,
 |  | const std::set< ms_peptide_quant_key > & | includeKeys,
 |  | const std::set< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | values,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys
 | ) |  | const
 protectedvirtual

Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.

The method looks up all peptide ratios associated with keys (ignoring duplicates) and returns them in numerically increasing order in values. Infinite and missing ratios are ignored. The vector activeKeys contains active peptide quant keys in the same order as values, and the map inactiveKeys contains peptide quant keys associated with the protein ratio but for indicated reasons not included in ratio calculation.

Parameters
ratioName | The name of the peptide ratio.
keys | A list of (sorted or unsorted) peptide quant keys for which to look up the ratios.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
values | Peptide ratios associated with ratioName and the given peptide quant keys.
weights | Weighting factors of corresponding to the order of values.
activeKeys | Peptide quant keys corresponding to the order of values.
inactiveKeys | Peptide quant keys skipped or excluded.

Implements ms_quantitation.

◆ hasIntensityNormalisation()

bool hasIntensityNormalisation ( ) const

Return true if intensity normalisation is enabled and configured.

You can enable and disable component intensity normalisation with setQuantNormalisation(). Note that only the "sum" normalisation is supported and only with the Reporter protocol.

If intensity normalisation is enabled, peptide ratio normalisation will be disabled, and vice versa.

Returns
True if normalisation is enabled and configured, false otherwise.

◆ hasPeptideRatio()

bool hasPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 virtual

Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
True if the peptide ratio exists; false otherwise.

Implements ms_quantitation.

◆ hasPeptideRatioNormalisation()

bool hasPeptideRatioNormalisation ( ) const

Return true if peptide ratio normalisation is enabled and configured.

You can enable and disable peptide ratio normalisation with setQuantNormalisation().

If intensity normalisation is enabled, peptide ratio normalisation will be disabled, and vice versa.

Returns
True if normalisation is enabled and configured, false otherwise.

◆ includeProteinPeptideRatioKeys()

void includeProteinPeptideRatioKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | includeKeys
 | ) |  |

Includes the passed peptide ratio values in the protein ratio calculation.

Sets the user included list of peptide ratio keys for the specified protein hit and ratio.

Parameters
accession | The accession of the protein.
dbIdx | The database the protein is from.
ratioName | The name of the ratio to calculate.
includeKeys | The vector of peptide ratio keys to include

◆ initialiseBaseSettings()

bool initialiseBaseSettings | ( | const ms_quant_method & | qmBase,
 |  | const ms_quant_method & | qmConfig
 | ) |  |
protectedinherited

Initialise quantitation method settings from the two method objects.

For any method settings which are not consistent between the passed qmBase and qmConfig, the values from qmConfig will be used.

Parameters
qmBase | The base quantitation method as defined on the Mascot server.
qmConfig | The quantitation method to use to calculate quantitation results using.
Returns
True.

◆ isPeptideRatioExcluded()

bool isPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 virtual

Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?

(This method is redundant; you could also look up the peptide ratio and use ms_peptide_quant_ratio::isExcluded().)

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
True if the peptide ratio should be excluded from protein ratio calculation; false otherwise.

Implements ms_quantitation.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ loadCdbFile()

bool loadCdbFile ( const char * path )

Load user adjusted protein-peptide quantitation ratio settings from a cdb file.

Updates the user protein-peptide ratio inclusions and exclusions from the cdbfile, overwriting any selections already made. If there is a problem loading the file and the method returns false, check getLastError() for further details.

Parameters
path The path to the cdbfile to load
Returns
True if the cdbfile was valid and has been loaded, false if there was an error.

◆ loadCdbFiles()

bool loadCdbFiles ( const std::vector< std::string > & cdbFiles )

Merges the settings from multiple protein-peptide user selection cdbfiles.

For multfile merged datasets, thie method will update the user protein-peptide ratio inclusions and exclusions from the cdbfiles, overwriting any selections already made. If there is a problem loading any of the cdb files, this method will return false. Check getLastError() for further details.

Parameters
cdbFiles The paths of the cdb files to load
Returns
True if all the cdb files were valid and have been loaded, false if there was an error.

◆ normaliseIntensities()

void normaliseIntensities ( )

Normalise component intensities, or do nothing if intensity normalisation is disabled.

Component intensity normalisation will require loading query data for most or all queries in the file, which can be a time-consuming process. This is why normalisation is not performed automatically once the constructor finishes.

Note that if hasIntensityNormalisation() returns false, then this method does nothing.

◆ normalisePeptideRatios()

void normalisePeptideRatios ( )

Normalise peptide ratios, or do nothing if normalisation is disabled.

Normalisation may require calculating all peptide ratios for all quantifiable peptide matches in the file, which can be a time-consuming process. This is why normalisation is not performed automatically once the constructor finishes. Automatic normalisation is also skipped when you change quantitation method parameters or report ratios, for the same reason.

Note that if hasPeptideRatioNormalisation() returns false, then this method does nothing.

◆ removeCombinedReportRatio()

void removeCombinedReportRatio ( const std::string & ratioName )

Remove the combined quantitation ratio matching the given name from all files.

The report ratio with name ratioName will be removed from all files where it is found. Other files remain unchanged.

Removing a combined report ratio does not alter normalisation constants, because the report ratio is removed from all files simultaneously (and because report ratios are independent of each other with respect to normalisation).

Parameters
ratioName The name of the ratio to remove. If this is the empty string, nothing will be removed.

◆ removeIntensityNormalisationBase()

void removeIntensityNormalisationBase ( const std::string & componentName )

Reset the intensity normalisation base of the given ratio name.

Resetting means the component intensity normalisation constant is set to 1.0. This has the same effect as calling setIntensityNormalisationBase() with b = 1.

Resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normaliseIntensities() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

Parameters
componentName Component name whose normalisation base is to be reset.

◆ removeIntensityNormalisationBases()

void removeIntensityNormalisationBases ( )

Reset all Intensity normalisation bases.

Resetting all intensity normalisation bases means all component intensities become unnormalised.

Resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normaliseIntensities() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

◆ removePeptideRatioNormalisationBase()

void removePeptideRatioNormalisationBase ( const std::string & ratioName )
inherited

Reset the peptide ratio normalisation base of the given ratio name.

Resetting means the report ratio normalisation constant is set to 1.0. This has the same effect as calling setPeptideRatioNormalisationBase() with b = 1.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

Parameters
ratioName Ratio name whose normalisation base is to be reset.

◆ removePeptideRatioNormalisationBases()

void removePeptideRatioNormalisationBases ( )
inherited

Reset all peptide ratio normalisation bases.

Resetting all report ratio normalisation bases means all peptide and protein ratios become unnormalised.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

◆ removeReportRatioInFile()

void removeReportRatioInFile | ( | unsigned int | fileNum,
 |  | const std::string & | ratioName
 | ) |  |

Remove the quantitation ratio matching the given name from the given file.

The report ratio with name ratioName will be removed from file fileNum, if it exists. Otherwise nothing is removed.

Removing a report ratio from one file resets its normalisation constant across the whole combined file. You will need to use normalisePeptideRatios() to (re)calculate it. If you are changing multiple report ratios at the same time, it is best to wait until all changes are done before calling normalisePeptideRatios(), as that way you only need to normalise once.

Parameters
fileNum | Integer between 1 and ms_mascotresfilebase::getNumberOfResfiles().
ratioName | The name of the ratio to remove. If this is the empty string, nothing will be removed.

◆ saveCdbFile()

bool saveCdbFile ( const std::string & cdbFilename )

Save the user edited protein-peptide quantitation settings to a cdb file.

Distiller stores this in an MDRO project file (*.rov) in stream 0xC350+n where n is the value in the projectStream attribute of the QuantResult from the Quantitation folder.

The generated cdb file does not contain the complete quantitation report. It records only the details of any user selected or deselected protein-peptide quantitation ratios. If you wish to export the complete report, use the saveXmlFile() method instead.

Parameters
cdbFilename The path and filename of the cdbfile to save
Returns
True if the file was saved successfully.

◆ saveXmlFile()

bool saveXmlFile | ( | const std::string & | xmlFilename,
 |  | bool | completeReport
 | ) |  |

Save the quantitation results to an XML file.

Parameters
xmlFilename | The path and filename of the file to save.
completeReport | True if a complete report of all data is to be generated, or false to generate concise report data.
Returns
True if the file was saved successfully.

◆ setCombinedReportRatio()

void setCombinedReportRatio | ( | const std::string & | ratioName,
 |  | const ms_quant_ratio & | ratioDef
 | ) |  |

Add or modify the combined quantitation ratio matching the given name in all files.

This method has does two things, in order:

  1. The report ratio with name ratioName is modified to match ratioDef in all files where it is found.
  2. A new report ratio will be added to files which don't have a report ratio with name ratioName.

Afterwards, all files will have a report ratio definition matching ratioDef, which will be merged in one "column" (since its name is the same in all files).

Note that the name defined in ratioDef can differ from ratioName. There are two use cases:

  1. Adding a new definition: set ratioName to the name of a report ratio that does not yet exist and ratioDef to the definition itself.
    • The name set in ratioDef is ignored.
  2. Updating, replacing and renaming a definition: set ratioName to the name of an existing report ratio and pass in ratioDef.
    • If ratioDef name is empty or equals ratioName, then the existing definition will be updated.
    • If ratioDef name differs from ratioName, then the existing definition will be replaced with ratioDef. (If the body of ratioDef is the same as before, this is a rename and otherwise a replace operation.)

Note that if ratioName is the empty string, this method does nothing and returns immediately.

Changing a combined report ratio resets all normalisation constants – that is, peptide ratios become unnormalised. Use normalisePeptideRatios() to recalculate the normalisation constants.

Parameters
ratioName | The name of the ratio to replace, or the name of the new ratio to add. If this is the empty string, a new report ratio will be added.
ratioDef | The ratio definition.

◆ setIntensityNormalisationBase()

void setIntensityNormalisationBase | ( | const std::string & | componentName,
 |  | double | b
 | ) |  |

Set the intensity normalisation base of the given component name.

Setting component intensity normalisation to a particular value means all peptide ratios calculated from componentName will be affected. However, the underlying compnent intensities remain unaffected, which means this method will always return immediately without computing anything.

It is not a good idea to define both peptide ratio normalisation and component intensity normalisation at the same time. In fact, you can only configure one or the other using setQuantNormalisation(), and neither normalisePeptideRatios() nor normaliseIntensities() will step on each other's toes.

It is possible, but not recommended, to manually set normalisation bases for both peptide ratios and component intensities. The resulting peptide ratios are most likely meaningless.

You can always set b to 1 to disable component intensity componentName normalisation.

Parameters
componentName | Component name to normalise.
b | New normalisation base. If it is zero, the old base will be kept. If this is the first time the base is set, a value of 0 means it is set to 1.0.

◆ setMinNumPeptides()

void setMinNumPeptides ( int value )
inherited

Set the minimum number of peptides needed for protein ratio calculation.

Changing the minimum number of peptides changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: The Average protocol has two settings for minimum number of peptides. This setting defines how many peptide intensities are needed for a protein before its ratio can be calculated. It is usually meaningless to choose a value other than 1. Use ms_customquantitation::setAverageNumPeptides() to define how many intensities should be used in protein ratio calculation.

Parameters
value The minimum number of peptide ratios (the sample size) a protein must have for protein ratio calculation purposes. Values less than 1 are interpreted as 1.

◆ setPeptideRatioExcluded()

void setPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |
virtual

Globally exclude a particular peptide ratio from protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

◆ setPeptideRatioIncluded()

void setPeptideRatioIncluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |
virtual

Globally include a particular peptide ratio in protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

◆ setPeptideRatioNormalisationBase()

void setPeptideRatioNormalisationBase | ( | const std::string & | ratioName,
 |  | double | b
 | ) |  |
inherited

Set the peptide ratio normalisation base of the given ratio name.

Setting peptide ratio normalisation to a particular value means all peptide ratios with ratioName will be divided by b before they are returned by getPeptideRatio(). That is, the underlying peptide ratios remain unaffected, which means this method will always return immediately without computing anything.

In ms_ms2quantitation, normalisation constants can most easily be calculated with ms_ms2quantitation::normalisePeptideRatios(), if normalisation is enabled and configured in the quantitation method. You are free to override this, but keeping track of who calculated which constant is up to you.

It is not a good idea to define both peptide ratio normalisation and component intensity normalisation at the same time. In fact, you can only configure one or the other using setQuantNormalisation(), and neither normalisePeptideRatios() nor normaliseIntensities() will step on each other's toes.

It is possible, but not recommended, to manually set normalisation bases for both peptide ratios and component intensities. The resulting peptide ratios are most likely meaningless.

In ms_customquantitation, you can use ms_customquantitation::getUnnormalisedAveragePeptideRatio() to calculate the mean or median of peptide ratios currently stored in the class, for normalisation purposes.

You can always set b to 1 to disable peptide ratio ratioName normalisation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters
ratioName | Peptide ratio name to normalise.
b | New normalisation base. If it is zero, the old base will be kept. If this is the first time the base is set, a value of 0 means it is set to 1.0.

◆ setProteinRatioType()

void setProteinRatioType ( const char * value )
virtual

Set the protein ratio type.

Changing the protein ratio type changes the current quantitation method. It does not alter the original quantitation method object.

ms_ms2quantitation supports "median", "average" and "weighted", and ms_customquantitation supports "median" and "average. If the ratio type is not implemented, it is set to "median". <strong>Using the Average protocol in ms_customquantitation</strong>: If quantitation protocol is Average, the only supported protein ratio type is "average". Setting it to anything else will result in an error. You should inspect isValid() and use clearAllErrors() should you accidentally do so.

Parameters
value Protein ratio type (e.g. median, average, weighted). Accepted values are defined in the quantitation XML schema.

Implements ms_quantitation.

◆ setQuantNormalisation()

void setQuantNormalisation ( const ms_quant_normalisation * norm )

Set new peptide and protein ratio normalisation settings.

Peptide and protein ratios can be normalised in several ways. Please consult the quantitation configuration help page for details. Changing ratio normalisation settings may involve a delay as the normalisation base is computed from ratio data.

Changing normalisation settings changes the current quantitation method. It does not alter the original quantitation method object.

Changing the settings resets all normalisation constants – that is, peptide ratios become unnormalised. Use normalisePeptideRatios() to recalculate the normalisation constants.

Parameters
norm A normalisation configuration object. If this is NULL, normalisation will be disabled (equivalent to "none").

◆ setQuantOutliers()

void setQuantOutliers ( const ms_quant_outliers * qo )
virtual

Set new peptide ratio outlier settings.

Peptide ratio outlier detection can be configured in several ways. Please consult the quantitation configuration help page for details.

Changing outlier settings changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: It is an error to define outlier removal if quantitation protocol is Average. You will need to inspect isValid() and clear the error with clearAllErrors() should you accidentally do so.

Parameters
qo An outlier configuration object. If this is NULL, outlier detection will be disabled (equivalent to "none").

Implements ms_quantitation.

◆ setReportRatioInFile()

void setReportRatioInFile | ( | unsigned int | fileNum,
 |  | const std::string & | ratioName,
 |  | const ms_quant_ratio & | ratioDef
 | ) |  |

Add or modify the quantitation ratio matching the given name in the given file.

This method does two things, in order:

  1. The report ratio with name ratioName in file fileNum is modified to match ratioDef, if it exists.
  2. Otherwise a new report ratio will be added to file fileNum.

The new report ratio will be merged with report ratios from other files if its name matches any other report ratio's name.

Note that the name defined in ratioDef can differ from ratioName. There are two use cases:

  1. Adding a new definition: set ratioName to the name of a report ratio that does not yet exist in this file and ratioDef to the definition itself.
    • The name set in ratioDef is ignored.
  2. Updating, replacing and renaming a definition: set ratioName to the name of an existing report ratio and pass in ratioDef.
    • If ratioDef name is empty or equals ratioName, then the existing definition will be updated.
    • If ratioDef name differs from ratioName, then the existing definition will be replaced with ratioDef. (If the body of ratioDef is the same as before, this is a rename and otherwise a replace operation.)

Note that if ratioName is the empty string, this method does nothing and returns immediately.

Changing a report ratio resets its normalisation constant across the whole combined file, while a fresh report ratio starts out with a constant of 1.0. You will need to use normalisePeptideRatios() to (re)calculate it. If you are changing multiple report ratios at the same time, it is best to wait until all changes are done before calling normalisePeptideRatios(), as that way you only need to normalise once.

Parameters
fileNum | Integer between 1 and ms_mascotresfilebase::getNumberOfResfiles().
ratioName | The name of the ratio to replace, or the name of the new ratio to add. If this is the empty string, a new report ratio will be added.
ratioDef | The ratio definition.
The documentation for this class was generated from the following files:
  • ms_ms2quantitation.hpp
  • ms_ms2quantitation.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide_quant_key Class Reference

  • matrix_science
  • ms_peptide_quant_key
Public Member Functions | List of all members
ms_peptide_quant_key Class Reference
Quantitation analysis for Mascot Server and Distiller

Feature key identifying a peptide ratio. More...

#include <ms_peptide_quant_key.hpp>

Public Member Functions

ms_peptide_quant_key ()
Create a nil peptide quant key.
ms_peptide_quant_key (const ms_peptide_quant_key &src)
Copying constructor.
ms_peptide_quant_key (const std::string &opaqueString)
Create a peptide quant key corresponding to an opaque string.
ms_peptide_quant_key (const std::string &opaqueString, int ID)
Create a peptide quant key corresponding to an opaque string and an integer ID.
ms_peptide_quant_key (int ID)
Create a peptide quant key corresponding to an integer ID.
ms_peptide_quant_key (int q, int p)
Create a peptide quant key corresponding to a peptide match.
ms_peptide_quant_key (int q, int p, int charge)
Create a peptide quant key corresponding to a peptide match with a specified charge state.
~ms_peptide_quant_key ()
Destructor.
bool | getCharge (int &charge) const
Return the charge of the peptide associated with this peptide quant key, if available.
bool | getID (int &ID) const
Return the integer ID of this peptide quant key, if available.
bool | getOpaqueString (std::string &opaqueStringRef) const
Return the opaque string of this peptide quant key, if available.
bool | getOpaqueStringAndID (std::string &opaqueStringRef, int &ID) const
Return the opaque string of this peptide quant key, if available.
bool | getQueryAndRank (int &q, int &p) const
Return the query number and rank of the peptide associated with this peptide quant key, if available.
bool | isNil () const
Return true if the peptide key is the nil key.
bool | operator!= (const ms_peptide_quant_key &right) const
C++ inequality.
bool | operator< (const ms_peptide_quant_key &right) const
C++ strict weak ordering.
bool | operator<= (const ms_peptide_quant_key &right) const
C++ strict weak ordering.
ms_peptide_quant_key & | operator= (const ms_peptide_quant_key &right)
C++ assignment operator.
bool | operator== (const ms_peptide_quant_key &right) const
C++ equality.
bool | operator> (const ms_peptide_quant_key &right) const
C++ strict weak ordering.
bool | operator>= (const ms_peptide_quant_key &right) const
C++ strict weak ordering.

Detailed Description

Feature key identifying a peptide ratio.

A peptide ratio is a ratio of component intensities. The components can be reporter ions, XICs from different runs, or something else depending on quantitation protocol. In each case, the peptide ratio is identified by a particular set of features, which are encapsulated in its peptide quant key.

Sometimes there is a one-to-one mapping between identified peptides and peptide ratios, such as in the Multiplex protocol (e.g. SILAC), or between input spectra and peptide ratios, such as the Reporter protocol (e.g. iTRAQ). In this case the peptide quant key can be the query number and peptide rank (ms_peptide_quant_key(int q, int p)).

In the general case, the peptide quant key can be a free-form string (ms_peptide_quant_key(const std::string &opaqueKey)) or any integer ID (ms_peptide_quant_key(int ID)). The string is not interpreted by the constructor; in other words it is considered opaque.

C++ only: The class specifies a full strict weak ordering, which means ms_peptide_quant_key objects can be used as STL map and set keys.

Perl and Python only: Ensure all parameters passed to the constructor are cast to the right type. Both Perl and Python tend to convert variables internally to strings, and even if the string value looks like a number, it may not be converted to an integer when the constructor is called. This is because the constructors differ only by type, and the string version tends to be chosen by default. For example, the Perl code

my $key = msparser::ms_peptide_quant_key->new($q, $p);

can choose either ms_peptide_quant_key(int, int) or ms_peptide_quant_key(const std::string &, int), depending on whether $q has ever been used in string context. To use the correct q,p form, cast both arguments to integers:

my $key = msparser::ms_peptide_quant_key->new(0+$q, 0+$p);

Constructor & Destructor Documentation

◆ ms_peptide_quant_key() [1/6]

ms_peptide_quant_key ( )

Create a nil peptide quant key.

The nil peptide quant key is equivalent to the zero value. All other peptide quant keys are "larger" than the nil key.

◆ ms_peptide_quant_key() [2/6]

ms_peptide_quant_key | ( | int | q,
 |  | int | p
 | ) |  |

Create a peptide quant key corresponding to a peptide match.

Use case: the peptide ratio is derived from a single peptide match, such as in Multiplex (e.g. SILAC) and Reporter (e.g. iTRAQ). The query and rank refer to the query and rank in a Mascot results file.

Parameters
q | Peptide query.
p | Peptide rank.

◆ ms_peptide_quant_key() [3/6]

ms_peptide_quant_key | ( | int | q,
 |  | int | p,
 |  | int | charge
 | ) |  |

Create a peptide quant key corresponding to a peptide match with a specified charge state.

Use case: the peptide ratio is linked to an identified peptide and a particular charge state.

Parameters
q | Peptide query.
p | Peptide rank.
charge | Charge state.

◆ ms_peptide_quant_key() [4/6]

ms_peptide_quant_key ( int ID )
explicit

Create a peptide quant key corresponding to an integer ID.

Use case: each peptide ratio has a unique integer ID.

Parameters
ID The peptide ratio ID.

◆ ms_peptide_quant_key() [5/6]

ms_peptide_quant_key ( const std::string & opaqueString )
explicit

Create a peptide quant key corresponding to an opaque string.

Use case: each peptide ratio has a unique string ID.

The string ID is opaque in the sense that this class will not try to parse it. This means that even if the string ID encoded query, rank or charge, the corresponding accessor methods will not return parsed values.

Parameters
opaqueString The peptide ratio ID.

◆ ms_peptide_quant_key() [6/6]

ms_peptide_quant_key | ( | const std::string & | opaqueString,
 |  | int | ID
 | ) |  |
explicit

Create a peptide quant key corresponding to an opaque string and an integer ID.

Use case: each peptide ratio has a unique string and interger ID pair. This could be used for example when combining multiple Distiller XML files where the opaqueString might be the name of the Fxxxxx.dat file and the ID is the would be the id attribute value in the peptideMatch element. The combination of the two values will therefore be unique.

The string opaqueString is opaque in the sense that this class will not try to parse it.

Parameters
opaqueString | with 'user defined' meaning.
ID | is a user defined integer.

Member Function Documentation

◆ getCharge()

bool getCharge ( int & charge ) const

Return the charge of the peptide associated with this peptide quant key, if available.

See Multiple return values in Perl, Java, Python and C#.

Charge is only available if the peptide quant key was constructed with the query, rank and charge constructor.

Parameters
[out] charge Charge state.
Returns
True if the peptide quant key is based on query, rank and charge; false otherwise. If this method returns false, then charge is set to -1.

◆ getID()

bool getID ( int & ID ) const

Return the integer ID of this peptide quant key, if available.

See Multiple return values in Perl, Java, Python and C#.

Integer ID is only available if the peptide quant key was constructed with the integer ID constructor.

Parameters
[out] ID Integer ID of the peptide quant key.
Returns
True if the peptide quant key is based on integer IDs; false otherwise. If this method returns false, then ID is set to -1.

◆ getOpaqueString()

bool getOpaqueString ( std::string & opaqueStringRef ) const

Return the opaque string of this peptide quant key, if available.

See Multiple return values in Perl, Java, Python and C#.

String ID is only available if the peptide quant key was constructed with the string ID constructor.

Parameters
[out] opaqueStringRef The opaque string on which the feature ID is based. When calling from Java, use a StringBuffer for this parameter.
Returns
True if the peptide quant key is based on an opaque string; false otherwise. If this method returns false, opaqueStringRef is set to the empty string.

◆ getOpaqueStringAndID()

bool getOpaqueStringAndID | ( | std::string & | opaqueStringRef,
 |  | int & | ID
 | ) |  | const

Return the opaque string of this peptide quant key, if available.

See Multiple return values in Perl, Java, Python and C#.

opaqueString and ID are only available if the peptide quant key was constructed with a constructor specifying the opaqueString and/or integer ID.

Parameters
[out] | opaqueStringRef | The opaque string on which the feature ID is based. When calling from Java, use a StringBuffer for this parameter.
[out] | ID | is the integer ID on which the feature ID is based.
Returns
True if the peptide quant key is based on an opaque string and/or an integer ID; false otherwise. If this method returns false, opaqueStringRef is set to the empty string and ID is set to -1.

◆ getQueryAndRank()

bool getQueryAndRank | ( | int & | q,
 |  | int & | p
 | ) |  | const

Return the query number and rank of the peptide associated with this peptide quant key, if available.

See Multiple return values in Perl, Java, Python and C#.

Query and rank are only available if the peptide quant key was constructed with the query and rank constructor, or the query, rank and charge constructor.

Parameters
[out] | q | Query number of the peptide quant key.
[out] | p | Rank of the peptide quant key.
Returns
True if the peptide quant key is based on query and rank; false otherwise. If this method returns false, both q and p are set to -1.
The documentation for this class was generated from the following files:
  • ms_peptide_quant_key.hpp
  • ms_peptide_quant_key.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide_quant_key_vector Class Reference

  • matrix_science
  • ms_peptide_quant_key_vector
Public Member Functions | List of all members
ms_peptide_quant_key_vector Class Reference
Quantitation analysis for Mascot Server and Distiller

A vector of peptide quant keys. More...

#include <ms_peptide_quant_key_vector.hpp>

Public Member Functions

ms_peptide_quant_key_vector ()
Create an empty peptide quant key vector.
ms_peptide_quant_key_vector (const ms_peptide_quant_key_vector &src)
Copying constructor.
ms_peptide_quant_key_vector (const std::list< ms_peptide_quant_key > &v)
Create a peptide quant key vector from an STL list.
ms_peptide_quant_key_vector (const std::vector< ms_peptide_quant_key > &v)
Create a peptide quant key vector from an STL vector.
~ms_peptide_quant_key_vector ()
Destructor.
void | append (const ms_peptide_quant_key_vector &src)
Appends all content from another instance of the class.
void | clear ()
Clear the vector.
void | copyFrom (const ms_peptide_quant_key_vector *src)
Copies all content from another instance of the class.
bool | empty () const
Boolean test: is the vector empty?
ms_peptide_quant_key | get (int idx) const
Return the peptide quant key at the given index.
ms_peptide_quant_key_vector & | operator= (const ms_peptide_quant_key_vector &right)
C++ assignment operator.
ms_peptide_quant_key pop ()
Pop a value from the end of the vector.
void | push (const ms_peptide_quant_key &key)
Push a new peptide quant key at the end of the vector.
void | set (int idx, const ms_peptide_quant_key &key)
Set the value at the given index.
int | size () const
Return the size of the container.
void | swap (ms_peptide_quant_key_vector &right)
Swap the contents with another peptide quant key vector.
const std::vector< ms_peptide_quant_key > & | toVector () const
C++ conversion to std::vector.

Detailed Description

A vector of peptide quant keys.

ms_peptide_quant_key_vector is a wrapper around the C++ vector class std::vector, specialised to contain ms_peptide_quant_key objects. The ms_quantitation and ms_protein_quant_ratio classes return such peptide quant key vectors.

The interface to this class follows that of vectori and vectorString, as described in Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Constructor & Destructor Documentation

◆ ms_peptide_quant_key_vector() [1/2]

ms_peptide_quant_key_vector ( const std::vector< ms_peptide_quant_key > & v )
explicit

Create a peptide quant key vector from an STL vector.

Note
This constructor can only be used from C++.
Parameters
v STL vector to initialise with.

◆ ms_peptide_quant_key_vector() [2/2]

ms_peptide_quant_key_vector ( const std::list< ms_peptide_quant_key > & v )
explicit

Create a peptide quant key vector from an STL list.

Note
This constructor can only be used from C++.
Parameters
v STL list to initialise with.

Member Function Documentation

◆ append()

void append ( const ms_peptide_quant_key_vector & src )

Appends all content from another instance of the class.

Parameters
src is another ms_peptide_quant_key_vector to append the keys from.

◆ clear()

void clear ( )

Clear the vector.

After clear, the vector will be empty.

◆ empty()

bool empty ( ) const

Boolean test: is the vector empty?

Returns
True if the vector is empty (has size 0); false otherwise.

◆ get()

ms_peptide_quant_key get ( int idx ) const

Return the peptide quant key at the given index.

To use this function from R, call getKey(int idx) instead

Note that idx must be within the 0-indexed range. Otherwise the method will throw an exception.

Parameters
idx The element index, 0..size()-1.
Returns
The element at the corresponding index.

◆ pop()

ms_peptide_quant_key pop ( )

Pop a value from the end of the vector.

Note that the vector must be nonempty (it must contain at least one element). If it doesn't, the method throws an exception.

Returns
The value popped from the end of the vector.

◆ push()

void push ( const ms_peptide_quant_key & key )

Push a new peptide quant key at the end of the vector.

Parameters
key Key to append to the vector.

◆ set()

void set | ( | int | idx,
 |  | const ms_peptide_quant_key & | key
 | ) |  |

Set the value at the given index.

Note that idx must be within the 0-indexed range. Otherwise the method will throw an exception. If you need to extend the vector, use push().

Parameters
idx | The element index, 0..size()-1.
key | The new value to be set at that index.

◆ size()

int size ( ) const

Return the size of the container.

Returns
The number of elements in the vector, or 0 if the vector is empty.

◆ swap()

void swap ( ms_peptide_quant_key_vector & src )

Swap the contents with another peptide quant key vector.

After this method returns, the data of src is stored inside this object, and src stores the old contents of this object.

Parameters
src Peptide quant key vector to swap contents with.

◆ toVector()

const std::vector< ms_peptide_quant_key > & toVector ( ) const

C++ conversion to std::vector.

Note
This method can only be used from C++.
Returns
A copy of the peptide quant key vector as an STL vector.
The documentation for this class was generated from the following files:
  • ms_peptide_quant_key_vector.hpp
  • ms_peptide_quant_key.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide_quant_ratio Class Reference

  • matrix_science
  • ms_peptide_quant_ratio
Public Member Functions | List of all members
ms_peptide_quant_ratio Class Reference
Quantitation analysis for Mascot Server and Distiller

Peptide abundance in one component relative to another in a quantitation experiment. More...

#include <ms_peptide_quant_ratio.hpp>

Public Member Functions

ms_peptide_quant_ratio (const ms_peptide_quant_key &key, const std::string &ratioName, bool isInfinite=false)
Default constructor: create an infinite or undefined ("missing") peptide ratio associated with a particular peptide quant key and a ratio name.
ms_peptide_quant_ratio (const ms_peptide_quant_key &key, const std::string &ratioName, double value, bool isExcluded=false, double weight=1.0)
Create a peptide ratio associated with a particular peptide quant key and ratio name.
ms_peptide_quant_ratio (const ms_peptide_quant_ratio &src)
Copying constructor.
~ms_peptide_quant_ratio ()
Destructor.
void | copyFrom (const ms_peptide_quant_ratio *src)
Copies all content from another instance of the class.
ms_peptide_quant_key | getKey () const
Return the peptide quant key associated with this peptide ratio.
std::string | getRatioName () const
Return the name of the peptide ratio.
double | getValue () const
Return the numerical value of the ratio.
double | getWeight () const
Return the weighting factor of the peptide ratio, or 1.0 if not set.
bool | isExcluded () const
Boolean flag: is this peptide ratio excluded from protein ratio calculation?
bool | isInfinite () const
Boolean flag: is this ratio infinite?
bool | isMissing () const
Boolean flag: is this ratio undefined ("missing")?
ms_peptide_quant_ratio & | operator= (const ms_peptide_quant_ratio &right)
C++ assignment operator.

Detailed Description

Peptide abundance in one component relative to another in a quantitation experiment.

Peptide ratios can be calculated in many different ways depending on quantitation protocol. This class is merely a container of numerical values. It does not contain information about the quantitation method, protocol or parameters used in deriving the component intensities or the calculating ratio.

Each peptide ratio must be associated with a particular peptide quant key. For Reporter, this is the query number; for Multiplex, the query and rank of the identified peptide; and for other protocols, the peptide quant key can be a combination of peptide features. Query and rank refer to the standard Mascot convention, where query is the index of an input spectrum and rank is the index of an identified peptide matching the input spectrum.

Each peptide ratio object is associated with a ratio name. The ratio name is the name of a report ratio in a particular quantitation experiment. This can be any free form text, for example "115/114" or "control/diseased".

A peptide ratio may have an optional weighting factor, which by default is 1.0. Weighting factors are used in protein ratio calculation by ms_customquantitation.

Constructor & Destructor Documentation

◆ ms_peptide_quant_ratio() [1/2]

ms_peptide_quant_ratio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName,
 |  | bool | isInfinite = false
 | ) |  |

Default constructor: create an infinite or undefined ("missing") peptide ratio associated with a particular peptide quant key and a ratio name.

An infinite or undefined ("missing") ratio is always excluded from protein ratio calculations. The return value of getValue() is undefined.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio, e.g. "115/114".
isInfinite | If false (default), this peptide ratio is undefined ("missing"); if true, it is infinite. Use ms_peptide_quant_ratio(const ms_peptide_quant_key&, std::string, double, bool) to construct a finite peptide ratio.

◆ ms_peptide_quant_ratio() [2/2]

ms_peptide_quant_ratio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName,
 |  | double | value,
 |  | bool | isExcluded = false,
 |  | double | weight = 1.0
 | ) |  |

Create a peptide ratio associated with a particular peptide quant key and ratio name.

If value is negative or 0, isExcluded will always be set to true, regardless of the argument value.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio, e.g. "115/114".
value | The numerical value of this ratio. Usually ratios should be positive, but it is possible to give 0 or a negative value. Interpretation of such values is the caller's responsibility.
isExcluded | (optional) If false (default for positive ratios), the peptide ratio can be included in protein ratio calculation; otherwise it should be excluded.
weight | (optional) Weighting factor to use in weighted protein ratio calculation.

Member Function Documentation

◆ isExcluded()

bool isExcluded ( ) const

Boolean flag: is this peptide ratio excluded from protein ratio calculation?

If isInfinite() or isMissing() is true, so is the return value of this function. Otherwise, for a finite ratio, exclusion can depend on e.g. if the ratio is an outlier.

Returns
True if this peptide ratio should be excluded from protein ratio calculations.

◆ isInfinite()

bool isInfinite ( ) const

Boolean flag: is this ratio infinite?

Infinite ratios can arise if the denominator is zero. Note that an infinite ratio is considered defined (not "missing"); that is, isMissing() will return false, even if the value is infinite.

If this method returns true, the return value of getValue() is undefined.

Returns
True if the ratio is infinite; false otherwise.

◆ isMissing()

bool isMissing ( ) const

Boolean flag: is this ratio undefined ("missing")?

The ratio can be undefined ("missing") if there is not enough data to calculate it. If this method returns true, the values of isInfinite() and getValue() are undefined.

Returns
True if the ratio is missing; false otherwise.
The documentation for this class was generated from the following files:
  • ms_peptide_quant_ratio.hpp
  • ms_quant_ratios.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_progress_info Class Reference

  • matrix_science
  • ms_progress_info
Public Types | Public Member Functions | List of all members
ms_progress_info Class Reference
Quantitation analysis for Mascot Server and Distiller

Contains information of the current progress of a task being performed. More...

#include <ms_progress_info.hpp>

Public Types

enum STATUS {
S_NOT_STARTED ,
S_RUNNING ,
S_RUNNING_INDETERMINATE ,
S_STOPPED_FAIL ,
S_STOPPED_BREAK ,
S_STOPPED_COMPLETE
}
Enum containing progress status information values. More...

Public Member Functions

ms_progress_info ()
Default constructor; for standard library collections.
ms_progress_info (const std::string &description, size_t total)
Constructor.
~ms_progress_info ()
Destructor.
void | addSubtask (const ms_progress_info *task)
Adds the passed ms_progress_info item as a subtask.
ms_progress_info * | addSubtask (const std::string &description, size_t total)
Adds a subtask with the specified description and total number of items.
void | clear (const std::string &description="", size_t total=0)
Clear any existing progress information ready to start a new long running operation using the same process names.
const std::string & | getDescription () const
Returns the task description.
int | getNumberOfSubtasks () const
Returns the total number of child ms_progress_info objects associated directly with the ms_progress_info instance.
size_t | getProgress () const
Returns the number of work items currently completed by the process running the task.
STATUS | getStatus () const
Gets the current ms_progress_info::STATUS associated with the task.
const ms_progress_info * | getSubtaskProgress (int index) const
Returns the child ms_progress_info object at the specified index.
size_t | getTotal () const
Returns the total number of work items the task is expected to complete.
bool | isBreaking () const
Returns whether or not a break request has been made by the user/client software.
void | removeSubtask (int index)
Removes and deletes the child ms_progress_info object at the specified index.
void | setBreak () const
Sends a break/cancel request to this and all child ms_progress_info tasks.
void | updateBreak ()
Updates the status to a break state.
void | updateComplete ()
Updates the status to a completed state.
void | updateFail ()
Updates the status to a fail state.
void | updateIndeterminate ()
Updates the status to an indeterminate running state.
void | updateProgress (size_t progress, size_t total)
Updates the current progress and total number of work items with the passed values.

Detailed Description

Contains information of the current progress of a task being performed.

If there are sub-jobs that are carried out then these are represented as child objects.

Member Enumeration Documentation

◆ STATUS

enum STATUS

Enum containing progress status information values.

Enumerator
S_NOT_STARTED | Task has not started.
S_RUNNING | Task is currently running.
S_RUNNING_INDETERMINATE | Task is running but progress is indeterminate.
S_STOPPED_FAIL | Task failed.
S_STOPPED_BREAK | Task was cancelled by the user.
S_STOPPED_COMPLETE | Task completed successfully.

Constructor & Destructor Documentation

◆ ms_progress_info()

ms_progress_info | ( | const std::string & | description,
 |  | size_t | total
 | ) |  |

Constructor.

Creates a new ms_progress_info object with the specified description and total number of items

Parameters
description | The task description associated with the generated ms_progress_info object
total | The total number of jobs the task will complete

◆ ~ms_progress_info()

~ms_progress_info ( )

Destructor.

The desctrutor deletes all subtasks that it has created

If a subtask has been created by calling addSubtask(const std::string & description, size_t) then the object will be deleted here by the parent object.

If an ms_progress_info object was created separately, and then added as a subtask, by calling: addSubtask(const ms_progress_info *), then it won't be deleted in this destructor. It's up to the code that created it to perform the deletion after any object(s) it was added to have been deleted.

Member Function Documentation

◆ getDescription()

const std::string & getDescription ( ) const

Returns the task description.

Returns
The task description

◆ getNumberOfSubtasks()

int getNumberOfSubtasks ( ) const

Returns the total number of child ms_progress_info objects associated directly with the ms_progress_info instance.

Only the number of direct child items is returned.

Returns
The number of child ms_progress_info objects

◆ getProgress()

size_t getProgress ( ) const

Returns the number of work items currently completed by the process running the task.

See also
getTotal()
Returns
The number of items the task has completed.

◆ getStatus()

ms_progress_info::STATUS getStatus ( ) const

Gets the current ms_progress_info::STATUS associated with the task.

Returns
The current status of the task associated with the ms_progress_info object

◆ getSubtaskProgress()

const ms_progress_info * getSubtaskProgress ( int index ) const

Returns the child ms_progress_info object at the specified index.

See also
getNumberOfSubtasks()
Parameters
index The index of the subtask to return. Must be in the range 1 .. getNumberOfSubtasks()
Returns
The ms_progress_info object at the specified index, or NULL is the passed value of index is invalid.

◆ getTotal()

size_t getTotal ( ) const

Returns the total number of work items the task is expected to complete.

See also
getProgress()
Returns
The total number of items the task is expected to complete

◆ setBreak()

void setBreak ( ) const

Sends a break/cancel request to this and all child ms_progress_info tasks.

Use from the client code to request that a long running process is cancelled. It is the responsibility of the process running the task to honour the break request.

The documentation for this class was generated from the following files:
  • ms_progress_info.hpp
  • ms_progress_info.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_protein_quant_ratio Class Reference

  • matrix_science
  • ms_protein_quant_ratio
Public Member Functions | List of all members
ms_protein_quant_ratio Class Reference
Quantitation analysis for Mascot Server and Distiller

Protein abundance in one component relative to another in a quantitation experiment, derived from a sample of peptide ratios. More...

#include <ms_protein_quant_ratio.hpp>

Public Member Functions

ms_protein_quant_ratio (const ms_protein_quant_ratio &src)
Copying constructor.
ms_protein_quant_ratio (const std::string &accession, int dbIdx, const std::string &ratioName)
ms_protein_quant_ratio (const std::string &accession, int dbIdx, const std::string &ratioName, double value, double stdev, double stderror, double hypothesisPvalue, double normalityPvalue, unsigned int sampleSize)
~ms_protein_quant_ratio ()
Destructor.
void | copyFrom (const ms_protein_quant_ratio *src)
Copies all content from another instance of the class.
std::string | getAccession () const
Return the protein accession associated with this ratio.
ms_peptide_quant_key_vector | getActiveKeys () const
Return the peptide quant keys used in calculating the protein ratio.
int | getDB () const
Return the protein database index associated with this ratio.
ms_peptide_quant_key_vector | getExcludedKeys () const
Return peptide quant keys associated with the protein accession that were skipped due to being excluded from protein ratio calculation.
double | getHypothesisPvalue () const
Return the p-value of this protein ratio under the null hypothesis.
double | getHypothesisPvalue (std::string &whyUnavailable) const
Return the p-value of this protein ratio under the null hypothesis.
double | getNormalityPvalue () const
Return the p-value of the hypothesis that the peptide ratios were (log)normally distributed.
double | getNormalityPvalue (std::string &whyUnavailable) const
Return the p-value of the hypothesis that the peptide ratios were (log)normally distributed.
ms_peptide_quant_key_vector | getOutlierKeys () const
Return peptide quant keys associated with the protein accession that were excluded due to being outliers.
std::string | getRatioName () const
Return the name of the ratio.
unsigned int | getSampleSize () const
Return the size of the sample of peptide ratios used in deriving this protein ratio.
ms_peptide_quant_key_vector | getSkippedKeys () const
Return peptide quant keys associated with the protein accession that were skipped due to being negative or infinite.
double | getStandardDeviation () const
Return the sample standard deviation of the protein ratio, calculated from the sample of peptide ratios.
double | getStandardDeviation (std::string &whyUnavailable) const
Return the sample standard deviation of the protein ratio, calculated from the sample of peptide ratios.
double | getStandardError () const
Return the standard error of the protein ratio, calculated from the standard deviation of the sample.
double | getStandardError (std::string &whyUnavailable) const
Return the standard error of the protein ratio, calculated from the standard deviation of the sample.
double | getValue () const
Return the numerical value of the ratio.
bool | isLogNormal (double threshold=0.05) const
Boolean flag: do the peptide ratios used in calculating this protein ratio appear to be (log)normally distributed?
bool | isMissing () const
Boolean flag: is this ratio defined?
bool | isSignificant (double threshold=0.05) const
Boolean flag: is the protein ratio statistically significantly different from the null hypothesis?
bool | operator!= (const ms_protein_quant_ratio &right) const
C++ inequality.
ms_protein_quant_ratio & | operator= (const ms_protein_quant_ratio &right)
C++ assignment operator.
bool | operator== (const ms_protein_quant_ratio &right) const
C++ equality.

Detailed Description

Protein abundance in one component relative to another in a quantitation experiment, derived from a sample of peptide ratios.

A protein ratio in Mascot is calculated from a sample of peptide ratios, where the peptides form a subset of identified peptides associated with a given protein accession; not all identified peptides have ratios. Protein ratios are usually calculated by ms_quantitation and classes derived from it.

Each protein ratio must be associated with a particular protein accession, database index and ratio name. The database index refers to databases used in a Mascot search, and can be 0 if the protein accession does not arise from a Mascot search. The ratio name is the name of a report ratio in a particular quantitation experiment. This can be any free form text, for example "115/114" or "control/diseased", defined in the quantitation method.

This class is merely a container of numerical values. It does not contain information how the protein ratio was calculated from peptide ratios, nor what kind of statistical significance testing was done, if any.

The following conventions are followed:

  • If the ratio is undefined ("missing"), the value, sample size, standard deviation and p-values are meaningless. They will be set to 0 or false, whichever is appropriate.
  • If sample size is 1, standard deviation must be 0. (This is by definition of how standard deviation is calculated.) If standard deviation could not be calculated for some other reason, it must be -1.
  • A negative p-value means no hypothesis testing was conducted. A value of 0 is implausibly small and should be disregarded.

Constructor & Destructor Documentation

◆ ms_protein_quant_ratio() [1/2]

ms_protein_quant_ratio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName
 | ) |  |
Parameters
accession | The protein accession associated with this ratio.
dbIdx | The database index associated with this ratio, usually related to databases used in a Mascot search.
ratioName | The name of the ratio, e.g. "115/114".

◆ ms_protein_quant_ratio() [2/2]

ms_protein_quant_ratio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | double | value,
 |  | double | stdev,
 |  | double | stderror,
 |  | double | hypothesisPvalue,
 |  | double | normalityPvalue,
 |  | unsigned int | sampleSize
 | ) |  |
Parameters
accession | The protein accession associated with this ratio.
dbIdx | The database index associated with this ratio, usually related to databases used in a Mascot search.
ratioName | The name of the ratio, e.g. "115/114".
value | The numerical value of this ratio. Usually ratios should be positive, but it is possible to give 0 or a negative value. Interpretation of such values is the caller's responsibility.
stdev | The sample standard deviation of the ratio, based on the peptide ratios. Use 0 if sample size is 1, and -1 if it is unavailable.
stderror | The standard error of the protein ratio, based on the standard deviation and sample size. Use 0 if sample size is 1, and -1 if it is unavailable.
hypothesisPvalue | The p-value of a hypothesis test about this protein ratio. Use -1 if it is unavailable.
normalityPvalue | The p-value that the peptide ratios appear to be normally (lognormally) distributed. Use -1 if it is unavailable.
sampleSize | The sample size, which must be at least 1. Use the constructor for the undefined ("missing") protein ratio if sample size is 0.

Member Function Documentation

◆ getActiveKeys()

ms_peptide_quant_key_vector getActiveKeys ( ) const

Return the peptide quant keys used in calculating the protein ratio.

Returns
The vector of peptide quant keys used in calculating this protein ratio. The vector has either size zero or its size is the sample size, depending on which constructor was used to create the protein ratio object.

◆ getExcludedKeys()

ms_peptide_quant_key_vector getExcludedKeys ( ) const

Return peptide quant keys associated with the protein accession that were skipped due to being excluded from protein ratio calculation.

A peptide ratio may be excluded manually from peptide ratio calculation, for reasons other than having negative value or being an outlier. For example, visual inspection may reveal the quality of a particular peptide ratio may be too poor, and that peptide ratio is excluded from all protein ratio calculation. The peptide quant key of the ratio would then appear here if it is associated with this protein ratio.

Returns
vector of excluded keys

◆ getHypothesisPvalue() [1/2]

double getHypothesisPvalue ( ) const

Return the p-value of this protein ratio under the null hypothesis.

Note that you need to know how the protein ratio was calculated, what statistical assumptions have been made and what the null hypothesis is as well as what statistic the protein ratio is compared against, to interpret the meaning of the p-value.

Python: note that the name of this method in Python is getHypothesisPvalue_only().

Returns
The p-value of this protein ratio under some hypothesis. A negative value (-1) means hypothesis testing was not conducted or the p-value could not be calculated.

◆ getHypothesisPvalue() [2/2]

double getHypothesisPvalue ( std::string & whyUnavailable ) const

Return the p-value of this protein ratio under the null hypothesis.

Same functionality as getHypothesisPvalue(), except that if the value is unavailable (negative), the reason is returned in the string argument.

See Multiple return values in Perl, Java, Python and C#.

Perl: note that this method does not return multiple values. If you want to receive the explanation string, give an empty string object as argument; for example

    my $str = ''; # ensure the variable is defined
    my $pvalue = $ratio->getHypothesisPvalue($str);
Parameters
whyUnavailable If p-value is unavailable, the reason is returned in this string argument.
Returns
The p-value of this protein ratio under some hypothesis. A negative value (-1) means hypothesis testing was not conducted or the p-value could not be calculated.

◆ getNormalityPvalue() [1/2]

double getNormalityPvalue ( ) const

Return the p-value of the hypothesis that the peptide ratios were (log)normally distributed.

Peptide ratios are multiplicative, and it is reasonable to assume they are log-normally distributed, that is, the log-transformed peptide ratios have normal distribution. Normality is usually required for outlier testing and hypothesis testing. The hypothesis p-value may be meaningless if the normality p-value is not below a threshold; the threshold value is up to you to decide.

Python: note that the name of this method in Python is getNormalityPvalue_only().

Returns
The p-value that the peptide ratios used in calculating this protein ratio seem log-normally distributed. A very low value, e.g. below 0.05, indicates non-normality. A negative value (-1) means sample size was too small for normality testing or the value could not be calculated.

◆ getNormalityPvalue() [2/2]

double getNormalityPvalue ( std::string & whyUnavailable ) const

Return the p-value of the hypothesis that the peptide ratios were (log)normally distributed.

Same functionality as getNormalityPvalue(), except that if the value is unavailable (negative), the reason is returned in the string argument.

See Multiple return values in Perl, Java, Python and C#.

Perl: note that this method does not return multiple values. If you want to receive the explanation string, give an empty string object as argument; for example

    my $str = ''; # ensure the variable is defined
    my $pvalue = $ratio->getNormalityPvalue($str);
Parameters
whyUnavailable If p-value is unavailable, the reason is returned in this string argument.
Returns
The p-value that the peptide ratios used in calculating this protein ratio seem log-normally distributed. A very low value, e.g. below 0.05, indicates non-normality. A negative value (-1) means sample size was too small for normality testing or the value could not be calculated..

◆ getOutlierKeys()

ms_peptide_quant_key_vector getOutlierKeys ( ) const

Return peptide quant keys associated with the protein accession that were excluded due to being outliers.

The vector of outlier peptide quant keys may be empty if outlier detection is disabled or there were no outliers. It may be possible to override this decision and manually include peptide quant keys that would otherwise be ignored as outliers.

Returns
vector of outlier keys

◆ getSampleSize()

unsigned int getSampleSize ( ) const

Return the size of the sample of peptide ratios used in deriving this protein ratio.

Returns
The number of peptide ratios used in ratio calculation. This is the same size as getActiveKeys().

◆ getSkippedKeys()

ms_peptide_quant_key_vector getSkippedKeys ( ) const

Return peptide quant keys associated with the protein accession that were skipped due to being negative or infinite.

The vector of skipped keys may be empty if there were no negative or infinite peptide ratios. It is never possible to include skipped keys in protein ratio calculation.

This collection will also include peptide ratios that were left out of the calculation of the ratio for the Average protocol because they were not one of the highest available peptide intentities.

Returns
vector of skipped keys

◆ getStandardDeviation() [1/2]

double getStandardDeviation ( ) const

Return the sample standard deviation of the protein ratio, calculated from the sample of peptide ratios.

Sample standard deviation is usually calculated using the standard formula: compute the sample variance as variance = 1/(n-1) * sum( (x_i - avg)^2 ), where x_i are the log peptide ratios, i is iterated from 1 to n (the sample size) and avg is the sample mean, and then take the square root to get the standard deviation. The value returned by this function is transformed back from the log space: exp(sqrt(variance)).

A related but different quantity is the standard error of the protein ratio estimator; see getStandardError().

Python: note that the name of this method in Python is getStandardDeviation_only().

Returns
The sample standard deviation of this protein ratio. Negative (-1) means the value is unavailable.

◆ getStandardDeviation() [2/2]

double getStandardDeviation ( std::string & whyUnavailable ) const

Return the sample standard deviation of the protein ratio, calculated from the sample of peptide ratios.

Same functionality as getStandardDeviation(), except that if the value is unavailable (negative), the reason is returned in the string argument.

See Multiple return values in Perl, Java, Python and C#.

Perl: note that this method does not return multiple values. If you want to receive the explanation string, give an empty string object as argument; for example

    my $str = ''; # ensure the variable is defined
    my $stdev = $ratio->getStandardDeviation($str);
Parameters
whyUnavailable If standard deviation is unavailable, the reason is returned in this string argument.
Returns
The sample standard deviation of this protein ratio. Negative (-1) means the value is unavailable.

◆ getStandardError() [1/2]

double getStandardError ( ) const

Return the standard error of the protein ratio, calculated from the standard deviation of the sample.

The standard error of the protein ratio estimate is a function of sample standard deviation and sample size. In the simplest case when the log protein ratio is the mean of log peptide ratios, the log standard error is s/sqrt(n), where s is the standard deviation and n is the sample size. In that case, the value returned by this function is transformed back from log space: exp(s/sqrt(n)).

The formula depends on the protein ratio type. For details of the calculation, see ms_quant_stats::arithmeticStandardErrorOfMean(), ms_quant_stats::arithmeticStandardErrorOfMedian(), and ms_quant_stats::weightedArithmeticStandardError().

Python: note that the name of this method in Python is getStandardError_only().

Returns
The standard error of the protein ratio. Negative (-1) means the value is unavailable.

◆ getStandardError() [2/2]

double getStandardError ( std::string & whyUnavailable ) const

Return the standard error of the protein ratio, calculated from the standard deviation of the sample.

Same functionality as getStandardError(), except that if the value is unavailable (negative), the reason is returned in the string argument.

See Multiple return values in Perl, Java, Python and C#.

Perl: note that this method does not return multiple values. If you want to receive the explanation string, give an empty string object as argument; for example

    my $str = ''; # ensure the variable is defined
    my $stderr = $ratio->getStandardError($str);
Parameters
whyUnavailable If standard error is unavailable, the reason is returned in this string argument.
Returns
The standard error of the protein ratio. Negative (-1) means the value is unavailable.

◆ getValue()

double getValue ( ) const

Return the numerical value of the ratio.

Note that you need to know the context and how the protein ratio has been calculated to interpret the value.

Returns
The numerical value of this protein ratio.

◆ isLogNormal()

bool isLogNormal ( double threshold = 0.05 ) const

Boolean flag: do the peptide ratios used in calculating this protein ratio appear to be (log)normally distributed?

The normality test hypothesis is that the peptide ratios are log-normally distributed, or equivalently that the log-transformed peptide ratios are normally distributed. If the p-value is below a threshold, say 0.05, then the hypothesis should be rejected. This method returns true if the p-value does not fall below threshold, which means you have no evidence to reject the normality hypothesis.

(Strictly speaking p above threshold is not enough evidence to explicitly accept the hypothesis, although that is what the method name implies.)

If the p-value is -1 (no testing was conducted), then there is no evidence against the hypothesis and the method returns true.

Parameters
threshold The significance threshold; default 0.05.
Returns
True if the normality p-value is not below the threshold; false otherwise. If the normality p-value is not available, the method returns false.

◆ isMissing()

bool isMissing ( ) const

Boolean flag: is this ratio defined?

The ratio can be undefined ("missing") if there is not enough data to calculate it. If this method returns true, then the return values of other methods are undefined.

Returns
True if the ratio is missing; false otherwise.

◆ isSignificant()

bool isSignificant ( double threshold = 0.05 ) const

Boolean flag: is the protein ratio statistically significantly different from the null hypothesis?

The null hypothesis depends on the context where the protein ratio was calculated. If the p-value is below threshold, then there is evidence against the hypothesis and this method returns true; in other words, the protein ratio differs from the hypothesised value in a "statistically significant" way.

If the p-value is -1 (no testing was conducted), then there is no evidence against the hypothesis and the method returns false.

Parameters
threshold The significance threshold; default 0.05.
Returns
True if the hypothesis p-value is below the threshold; false otherwise. If the p-value is not available, the method returns false.
The documentation for this class was generated from the following files:
  • ms_protein_quant_ratio.hpp
  • ms_quant_ratios.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_helper Class Reference

  • matrix_science
  • ms_quant_helper
Public Types | Public Member Functions | List of all members
ms_quant_helper Class Reference
Quantitation analysis for Mascot Server and Distiller

Helper routines for peptide quantitation. More...

#include <ms_quant_helper.hpp>

Inheritance diagram for ms_quant_helper:
[legend]
Collaboration diagram for ms_quant_helper:
[legend]

Public Types

enum PEPTIDE_QUALITY {
PEPTIDE_QUALITY_IS_OK = 0x0000 ,
PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN = 0x0001 ,
PEPTIDE_SCORE_BELOW_SCORE_THR = 0x0002 ,
PEPTIDE_EXPECT_ABOVE_THRESHOLD = 0x0003 ,
PEPTIDE_SCORE_BELOW_IDENTITY_THR = 0x0004 ,
PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM = 0x0005 ,
PEPTIDE_SCORE_BELOW_HOMOLOGY_THR = 0x0006 ,
PEPTIDE_NOT_UNIQUE = 0x0007 ,
PEPTIDE_QUALITY_UNAVAILABLE = 0xf000
}
Possible reasons why a peptide does not pass quality tests using a given quantitation method. More...
enum PEPTIDE_QUANTIFIABILITY {
PEPTIDE_IS_QUANTIFIABLE = 0x0000 ,
PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD = 0x0001 ,
PEPTIDE_HAS_NO_REQUIRED_VARMOD = 0x0002 ,
PEPTIDE_HAS_EXCLUDED_FIXEDMOD = 0x0010 ,
PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD = 0x0011 ,
PEPTIDE_HAS_EXCLUDED_VARMOD = 0x0012 ,
PEPTIDE_HAS_UNMODIFIED_SITE = 0x0013 ,
PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD = 0x0014 ,
PEPTIDE_HAS_NO_EXCLUSIVE_MODS = 0x0015 ,
PEPTIDE_QUANTIFIABILITY_UNAVAILABLE = 0xf000
}
Possible reasons a peptide is not quantifiable using a given quantitation method. More...

Public Member Functions

ms_quant_helper (const ms_peptidesummary &pepsum, const ms_quant_method &qm, const ms_umod_configfile &umodfile, const int file_index=ms_quant_file_index::file_index_value_not_set)
Default constructor.
~ms_quant_helper ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
int | createMissingComponents (matrix_science::ms_ms1quant_match *match) const
Create any missing components and return the number of new components created.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getFraction (const int file_index) const
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | isPeptideQualityOK (int q, int p, std::string &reasonStrRef) const
Given a peptide, test whether it passes the quality thresholds.
int | isPeptideQuantifiable (int q, int p, const ms_protein *protein, int peptideIndex, std::string &reasonStrRef) const
Given a peptide and the residues before and after, test whether it is quantifiable.
bool | isValid () const
Call this function to determine if there have been any errors.

Detailed Description

Helper routines for peptide quantitation.

Member Enumeration Documentation

◆ PEPTIDE_QUALITY

enum PEPTIDE_QUALITY

Possible reasons why a peptide does not pass quality tests using a given quantitation method.

Enumerator
PEPTIDE_QUALITY_IS_OK | Peptide passes quality thresholds.
PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN | Peptide charge is less than minimum precursor charge.
PEPTIDE_SCORE_BELOW_SCORE_THR | Peptide score is below threshold.
PEPTIDE_EXPECT_ABOVE_THRESHOLD | Peptide expect value exceeds threshold.
PEPTIDE_SCORE_BELOW_IDENTITY_THR | Peptide score is below identity threshold.
PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM | Peptide score is below identity threshold (no homology threshold available).
PEPTIDE_SCORE_BELOW_HOMOLOGY_THR | Peptide score is below homology threshold.
PEPTIDE_NOT_UNIQUE | Peptide is not unique.
PEPTIDE_QUALITY_UNAVAILABLE | Quality cannot be determined.

◆ PEPTIDE_QUANTIFIABILITY

enum PEPTIDE_QUANTIFIABILITY

Possible reasons a peptide is not quantifiable using a given quantitation method.

Enumerator
PEPTIDE_IS_QUANTIFIABLE | Peptide is quantifiable using the given quantitation method.
PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD | Peptide is missing a required fixed modification.
PEPTIDE_HAS_NO_REQUIRED_VARMOD | Peptide is missing a required variable modification.
PEPTIDE_HAS_EXCLUDED_FIXEDMOD | Peptide has an excluded fixed modification.
PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD | Peptide has an excluded fixed modification, defined in the local modification definitions.
PEPTIDE_HAS_EXCLUDED_VARMOD | Peptide has an excluded variable modification.
PEPTIDE_HAS_UNMODIFIED_SITE | Peptide has an unmodified site where required modification should be.
PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD | Peptide has an excluded variable modification, defined in the local modification definitions.
PEPTIDE_HAS_NO_EXCLUSIVE_MODS | Peptide has none of the exclusive modifications (only tested when constrain search is disabled).
PEPTIDE_QUANTIFIABILITY_UNAVAILABLE | Quantifiability cannot be determined.

Constructor & Destructor Documentation

◆ ms_quant_helper()

ms_quant_helper | ( | const ms_peptidesummary & | pepsum,
 |  | const ms_quant_method & | qm,
 |  | const ms_umod_configfile & | umodfile,
 |  | const int | file_index = ms_quant_file_index::file_index_value_not_set
 | ) |  |

Default constructor.

The object should receive the full quantitation method, including, in particular, component definitions and peptide quality settings. If the quantitation method is missing either set of settings, the corresponding methods will return the status "unavailable".

The constructor creates a copy of the relevant bits of the quantitation method and stores those internally. If you change the quantitation method later, you must create a new ms_quant_helper object.

Parameters
pepsum | Mascot results file whose peptide matches are to be tested.
qm | Quantitation method with component definitions, peptide quality settings and report ratio definitions.
umodfile | Unimod configuration file for looking up modification specificities.
file_index | is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ createMissingComponents()

int createMissingComponents ( matrix_science::ms_ms1quant_match * match ) const

Create any missing components and return the number of new components created.

Only supports the "precursor" protocol. Other protocols do nothing and return 0

For precursor, this will add the 'derived' matches. For example, if there is a peptide match to the light component, it will add an expected heavy match, even though there is no search ID for the heavy match.

Parameters
match contains the peptide match to which new 'components' are to be added.
Returns
the number of new components added to the match

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFraction()

int getFraction ( const int file_index ) const
Parameters
file_index is used for replicate, where the samples have been prefractionated and there is a raw data file for each fraction, the method can be set up so that each component (i.e. sample) has a number of file_index values, one for each file.
Returns
the fraction, if one has been specified in the method, otherwise return matrix_science::ms_quant_file_index::file_index_value_not_set

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ isPeptideQualityOK()

int isPeptideQualityOK | ( | int | q,
 |  | int | p,
 |  | std::string & | reasonStrRef
 | ) |  | const

Given a peptide, test whether it passes the quality thresholds.

The peptide identified by query q and rank p is tested against peptide quality settings in the quantitation method. If it does not pass all of the quality tests (e.g. score thresholds), the corresponding status is returned; see PEPTIDE_QUALITY for details.

The method defers loading the full peptide object until it is really needed, if at all. Significance tests and score and expect value thresholds can be conducted without loading the peptide object in its entirety. This means the method is fast both when caching is in use and without caching.

See Multiple return values in Perl, Java, Python and C#.

Thread safe
This method is safe to use from multiple threads. See also Using Parser in multithreaded applications.
Parameters
[in] | q | Peptide query.
[in] | p | Peptide rank.
[out] | reasonStrRef | is a free-text description of the return status is assigned to the variable. If status is PEPTIDE_QUALITY_IS_OK, reasonStrRef will be the empty string. If status is PEPTIDE_QUALITY_UNAVAILABLE, reasonStrRef will not be changed by this method.
Returns
Status describing whether the peptide meets all the requirements to be quantifiable using the quantitation method.

◆ isPeptideQuantifiable()

int isPeptideQuantifiable | ( | int | q,
 |  | int | p,
 |  | const ms_protein * | protein,
 |  | int | peptideIndex,
 |  | std::string & | reasonStrRef
 | ) |  | const

Given a peptide and the residues before and after, test whether it is quantifiable.

The method first loads the peptide with query q and rank p. The peptide is tested against component definitions in the quantitation method. If it is missing required modifications, or if it contains excluded modifications, the corresponding status is returned; see PEPTIDE_QUANTIFIABILITY for details.

If the quantitation method does not contain suitable component definitions, the return status is PEPTIDE_QUANTIFIABILITY_UNAVAILABLE.

See Multiple return values in Perl, Java, Python and C#

Parameters
[in] | q | Peptide query.
[in] | p | Peptide rank.
[in] | protein | Protein hit to which the peptide match is assigned. This is only needed in the case where a quality parameter is specified to exclude an unmodified protein N- or C-terminus residue. In this case, this code needs to know if the flanking residue is the corresponding protein terminus. The same peptide may appear in multiple proteins, and may be at the terminus of just one of them, so if you need all peptides that may be quantifiable, pass 0 or NULL.
[in] | peptideIndex | Integer index of the peptide match in the protein hit, between 1 and protein->getNumPeptides(). If protein is null, use 0.
[out] | reasonStrRef | is a free-text description of the return status is assigned to the variable. If status is PEPTIDE_IS_QUANTIFIABLE, reasonStrRef will be the empty string. If status is PEPTIDE_QUANTIFIABILITY_UNAVAILABLE, reasonStrRef will not be changed by this method.
Returns
Status describing whether the peptide meets all the requirements to be quantifiable using the quantitation method.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_quant_helper.hpp
  • ms_quant_helper.cpp
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_stats Class Reference

  • matrix_science
  • ms_quant_stats
Static Public Member Functions | List of all members
ms_quant_stats Class Reference
Quantitation analysis for Mascot Server and Distiller

Mathematical and statistical routines for peptide and protein quantitation. More...

#include <ms_quant_stats.hpp>

Static Public Member Functions

static double | arithmeticMean (const std::vector< double > &data)
Calculate the arithmetic mean.
static double | arithmeticStandardDeviation (const std::vector< double > &data, double arithmeticMean)
Calculate the arithmetic sample standard deviation.
static double | arithmeticStandardErrorOfMean (double arithmeticStdev, unsigned long sampleSize)
Calculate the standard error of the arithmetic sample mean.
static double | arithmeticStandardErrorOfMedian (double arithmeticStdev, unsigned long sampleSize)
Calculate the standard error of the sample median.
static double | binomialCoefficient (unsigned int n, unsigned int k)
Compute the binomial coefficient.
static double | calculateNormalMeanPvalue (double populationMean, double mean, double stdev, unsigned long sampleSize)
Calculate the p-value that the population mean is populationMean, given the sample statistics and assuming the population is normally distributed.
static double | calculateNormalMedianPvalue (double populationMedian, double median, double stdev, unsigned long sampleSize)
Calculate the p-value that the population median is populationMedian, given the sample statistics and assuming the population is normally distributed.
static double | calculateNormalWeightedPvalue (double populationMean, double weightedMean, const std::vector< double > &weights, double weightedStdev, unsigned long sampleSize)
Calculate the p-value that the population mean is populationMean, given the weighted sample statistics and assuming the population is normally distributed.
static double | chisqLowerCriticalValue (unsigned int df, double sigLevel)
Return the lower critical value of the chi-square distribution at the given significance level.
static double | chisqUpperCriticalValue (unsigned int df, double sigLevel)
Return the upper critical value of the chi-square distribution at the given significance level.
static void | detectOutliers (const std::vector< double > &sample, std::string outlierMethod, double sigLevel, unsigned int *const numLow, unsigned int *const numHigh)
Given a sample and an outlier method, return the number of outliers at low and high extreme at the given significance level.
static void | detectOutliers (const std::vector< double > &sample, std::string outlierMethod, unsigned int *const numLow, unsigned int *const numHigh)
Given a sample and an outlier method, return the number of outliers at low and high extreme at significance level 0.05.
static std::vector< double > | expTransform (const std::vector< double > &logData)
Antilog (exp) transform of the input data.
static double | geometricMean (const std::vector< double > &data)
Calculate the geometric mean.
static double | geometricStandardDeviation (const std::vector< double > &data, double geometricMean)
Calculate the geometric sample standard deviation.
static std::vector< double > | logTransform (const std::vector< double > &data)
Log transform of the input data.
static std::vector< double > | meanCentre (const std::vector< double > &data, double mean)
Centre the data values about the given mean.
static double | medianStandardErrorCorrection (unsigned long sampleSize)
Return the correction for the standard error of the median.
static double | normalCriticalValue (double p)
Return the critical value of the standard normal distribution at the given cumulative probability.
static double | normalCumulativeProbability (double x0)
Return the cumulative probability that the standard normal statistic is at most x0.
static double | poissonDensity (double lambda, unsigned int k)
Calculate the probability density of the Poisson distribution.
static double | snedecorsCriticalValue (unsigned int df1, unsigned int df2, double sigLevel)
Return the critical value of Snedecor's F distribution at the given significance level.
static double | sortedMedian (const std::deque< double > &data)
Find the median of a sorted data deque.
static double | sortedMedian (const std::vector< double > &data)
Find the median of a sorted data vector.
static double | studentsCriticalValue (unsigned int df, double sigLevel)
Return the critical value of Student's t distribution at the given significance level.
static double | sum (const std::vector< double > &data)
Calculate the sum of a sample vector.
static double | sumsq (const std::vector< double > &data)
Calculate the sum of squares of a sample vector.
static int | testDixonsN9 (unsigned long sampleSize, double min, double x2, double xn_1, double max, double sigLevel)
Apply Dixon's N9 (r11) outlier test to the sample.
static int | testGrubbsN2 (unsigned long sampleSize, double min, double mean, double max, double stdev, double sigLevel)
Apply Grubb's N2 outlier test to the sample statistics.
static void | testRosners (const std::vector< double > &sample, unsigned int maxOutliers, double sigLevel, unsigned int *const numLow, unsigned int *const numHigh)
Apply the generalised extreme Studentised deviate (ESD) outlier test (aka Rosner's test) to the sample.
static bool | testShapiroWilkW (const std::vector< double > &sample, double *const W, double *const pValue)
Apply Shapiro-Wilk W normality test to the sample.
static double | unsortedMedian (const std::vector< double > &data)
Find the median of an unsorted data vector.
static double | weightedArithmeticMean (const std::vector< double > &data, const std::vector< double > &weights)
Calculate the weighted arithmetic mean.
static double | weightedArithmeticStandardDeviation (const std::vector< double > &data, const std::vector< double > &weights, double weightedMean)
Calculate the weighted arithmetic sample standard deviation.
static double | weightedArithmeticStandardError (const std::vector< double > &weights, double weightedStdev, unsigned long sampleSize)
Calculate the standard error of the weighted arithmetic sample mean.
static double | weightedGeometricMean (const std::vector< double > &data, const std::vector< double > &weights)
Calculate the weighted geometric mean.
static double | weightedGeometricStandardDeviation (const std::vector< double > &data, const std::vector< double > &weights, double weightedMean)
Calculate the weighted geometric sample standard deviation.

Detailed Description

Mathematical and statistical routines for peptide and protein quantitation.

ms_quant_stats is a collection of mathematical and statistical routines used in peptide and protein quantitation by ms_ms2quantitation and ms_customquantitation. It is possible to use the routines outside this context, as they are not tied to either class.

The class contains only static class methods; it is impossible and meaningless to create instances of ms_quant_stats.

Member Function Documentation

◆ arithmeticMean()

double arithmeticMean ( const std::vector< double > & data )
static

Calculate the arithmetic mean.

The arithmetic mean is the usual average:

mean(data) = (1/N)sumi xi

where N is the number of elements in data and the summation is over all elements xi.

Parameters
data Any vector of numbers.
Returns
The arithmetic mean of data, or 0 if the vector is empty.

◆ arithmeticStandardDeviation()

double arithmeticStandardDeviation | ( | const std::vector< double > & | data,
 |  | double | arithmeticMean
 | ) |  |
static

Calculate the arithmetic sample standard deviation.

The arithmetic sample deviation is the square root of the arithmetic sample variance. The sample variance is the second sample moment about the sample mean, scaled by N - 1, where N is the sample size. That is,

var(data) = 1/(N - 1)sumi( (xi - arithmeticMean)2 )

where the sum is over all elements xi.

Parameters
data | A sample of data.
arithmeticMean | Sample arithmetic mean.
Returns
Sample standard deviation, or 0 if sample size is 0 or 1.

◆ arithmeticStandardErrorOfMean()

double arithmeticStandardErrorOfMean | ( | double | arithmeticStdev,
 |  | unsigned long | sampleSize
 | ) |  |
static

Calculate the standard error of the arithmetic sample mean.

The standard error of the arithmetic sample mean in a normally distributed sample is simple: standard deviation divided by the square root of the sample size.

Parameters
arithmeticStdev | Arithmetic standard deviation, for example from arithmeticStandardDeviation().
sampleSize | The sample size.
Returns
Standard error of the mean. If sample size is 0 or 1, this function returns 0.

◆ arithmeticStandardErrorOfMedian()

double arithmeticStandardErrorOfMedian | ( | double | arithmeticStdev,
 |  | unsigned long | sampleSize
 | ) |  |
static

Calculate the standard error of the sample median.

The standard error of the sample median in a normally distributed sample is the same as the standard error of the sample mean, times a correction factor. The correction factor is documented in medianStandardErrorCorrection().

Parameters
arithmeticStdev | Arithmetic standard deviation, for example from arithmeticStandardDeviation().
sampleSize | The sample size.
Returns
Standard error of the mean. If sample size is 0 or 1, this function returns 0.

◆ binomialCoefficient()

double binomialCoefficient | ( | unsigned int | n,
 |  | unsigned int | k
 | ) |  |
static

Compute the binomial coefficient.

The method returns 1 in the following cases, by definition:

  • n = 0
  • k = 0
  • n < k

Note that although the binomial coefficient is an integer, the return value is double to allow values beyond about 4 billion on 32-bit systems. The value is exact up to about 74C37.

Parameters
n | Population size.
k | Sample size.
Returns
The binomial coefficient nCk or "n choose k".

◆ calculateNormalMeanPvalue()

double calculateNormalMeanPvalue | ( | double | populationMean,
 |  | double | mean,
 |  | double | stdev,
 |  | unsigned long | sampleSize
 | ) |  |
static

Calculate the p-value that the population mean is populationMean, given the sample statistics and assuming the population is normally distributed.

Hypothesis: the population you are sampling from is normally distributed with mean populationMean and unknown variance.

Statistic: Student's t = (mean - populationMean)/(stdev/sqrt(sampleSize))

Assume the hypothesis is true. This method returns the probability (the p-value) that the statistic t could have a value as extreme (or more extreme) as the one observed. Low p-value means that either the hypothesis is wrong or the sample is exceptionally rare.

(Note that there is no alternative hypothesis. The p-value with this interpretation is part of Fisher's significance test, which does not decide between hypotheses. Recommended reading: Hubbard, R. et al. (2003): Confusion over Measures of Evidence (p's) versus Errors (alphas) in Classical Statistical Testing. The American Statistician 57(3):171-182.)

Parameters
populationMean | Assumed population mean. (Population variance is assumed unknown.)
mean | Sample arithmetic mean.
stdev | Sample standard deviation. This must be positive.
sampleSize | Sample size. This must be at least 1.
Returns
The p-value of the statistic under the hypothesis of normality.

◆ calculateNormalMedianPvalue()

double calculateNormalMedianPvalue | ( | double | populationMedian,
 |  | double | median,
 |  | double | stdev,
 |  | unsigned long | sampleSize
 | ) |  |
static

Calculate the p-value that the population median is populationMedian, given the sample statistics and assuming the population is normally distributed.

Hypothesis: the population you are sampling from is normally distributed with median populationMedian and unknown variance. In particular, the population median is equal to the population mean.

Statistic: Student's t for sample median, t = 1/C*(median - populationMedian)/(stdev/sqrt(sampleSize))

Assume the hypothesis is true. This method returns the probability (the p-value) that the statistic t could have a value as extreme (or more extreme) as the one observed. Low p-value means that either the hypothesis is wrong or the sample is exceptionally rare.

(Note that there is no alternative hypothesis. The p-value with this interpretation is part of Fisher's significance test, which does not decide between hypotheses. Recommended reading: Hubbard, R. et al. (2003): Confusion over Measures of Evidence (p's) versus Errors (alphas) in Classical Statistical Testing. The American Statistician 57(3):171-182.)

The constant C is a correction to the standard error of the median, retrieved from medianStandardErrorCorrection().

Parameters
populationMedian | Assumed population median. (Population variance is assumed unknown.)
median | Sample median.
stdev | Sample standard deviation. This must be positive.
sampleSize | Sample size. This must be at least 1.
Returns
The p-value of the statistic under the hypothesis of normality.

◆ calculateNormalWeightedPvalue()

double calculateNormalWeightedPvalue | ( | double | populationMean,
 |  | double | weightedMean,
 |  | const std::vector< double > & | weights,
 |  | double | weightedStdev,
 |  | unsigned long | sampleSize
 | ) |  |
static

Calculate the p-value that the population mean is populationMean, given the weighted sample statistics and assuming the population is normally distributed.

Hypothesis: the population you are sampling from is normally distributed with mean populationMean and unknown variance.

Statistic: Student's t = (weightedMean - populationMean)/(stdev sqrt(W)/b)),

where stdev is the sample standard deviation, W is the sum of weights and b is the effective base, as defined in weightedArithmeticStandardError(). Note that this function takes as argument the weighted standard deviation and the weights, not stdev.

Assume the hypothesis is true. This method returns the probability (the p-value) that the statistic t could have a value as extreme (or more extreme) as the one observed. Low p-value means that either the hypothesis is wrong or the sample is exceptionally rare.

(Note that there is no alternative hypothesis. The p-value with this interpretation is part of Fisher's significance test, which does not decide between hypotheses. Recommended reading: Hubbard, R. et al. (2003): Confusion over Measures of Evidence (p's) versus Errors (alphas) in Classical Statistical Testing. The American Statistician 57(3):171-182.)

Parameters
populationMean | Assumed population mean. (Population variance is assumed unknown.)
weightedMean | Weighted sample arithmetic mean.
weights | Positive weight for each datum. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than sampleSize, the weights of those elements are taken to be 1.0.
weightedStdev | Weighted sample standard deviation. This must be positive.
sampleSize | Sample size. This must be at least 1.
Returns
The p-value of the statistic under the hypothesis of normality.

◆ chisqLowerCriticalValue()

double chisqLowerCriticalValue | ( | unsigned int | df,
 |  | double | sigLevel
 | ) |  |
static

Return the lower critical value of the chi-square distribution at the given significance level.

Suppose the random variable X has the chi-square distribution with df degrees of freedom. This routine returns the lower critical value x0 for which

P(X <= x0) = p

where p is the desired significance level. Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.050 < s <= 0.100 | 0.1
0.025 < s <= 0.050 | 0.05
0.010 < s <= 0.025 | 0.025
0.001 < s <= 0.010 | 0.01
s <= 0.001 | 0.001

If sigLevel exceeds 0.100, it is truncated to 0.100.

Parameters
df | The degrees of freedom between 1 and 100 inclusive.
sigLevel | Significance level. See the above table for supported values.
Returns
The lower critical value x0.

◆ chisqUpperCriticalValue()

double chisqUpperCriticalValue | ( | unsigned int | df,
 |  | double | sigLevel
 | ) |  |
static

Return the upper critical value of the chi-square distribution at the given significance level.

Suppose the random variable X has the chi-square distribution with df degrees of freedom. This routine returns the upper critical value x0 for which

P(X <= x0) = 1 - p

where p is the desired significance level. Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.050 < s <= 0.100 | 0.1
0.025 < s <= 0.050 | 0.05
0.010 < s <= 0.025 | 0.025
0.005 < s <= 0.010 | 0.01
0.001 < s <= 0.005 | 0.005
s <= 0.001 | 0.001

If sigLevel exceeds 0.100, it is truncated to 0.100.

Parameters
df | The degrees of freedom between 1 and 100 inclusive.
sigLevel | Significance level. See the above table for supported values.
Returns
The upper critical value x0.

◆ detectOutliers() [1/2]

void detectOutliers | ( | const std::vector< double > & | sample,
 |  | std::string | outlierMethod,
 |  | double | sigLevel,
 |  | unsigned int *const | numLow,
 |  | unsigned int *const | numHigh
 | ) |  |
static

Given a sample and an outlier method, return the number of outliers at low and high extreme at the given significance level.

If outlierMethod is "none" or the empty string, or if outlierMethod is not listed in Type mqm:outlierType, then the method simply returns with 0 outliers. Otherwise the corresponding outlier test will be used to count the number of low and high outliers at the given significance level.

If outlierMethod is "auto", then the method uses Dixon's N9 if sample size is less than 25 and Rosner's test otherwise.

Note that not all tests support the same set of significance levels. The common values between all three tests are as follows:

sigLevel (s) | p
0.100 < s <= 0.200 | 0.2
0.050 < s <= 0.100 | 0.1
0.020 < s <= 0.050 | 0.05
0.010 < s <= 0.020 | 0.02
0.005 < s <= 0.010 | 0.01

If you specify a significance level that is outside these ranges, then the effective significance levels depends on which test is being used. Please refer to testDixonsN9(), testGrubbsN2() and testRosners() for more details.

Note that this method does not modify sample. You will need to remove the indicated outliers yourself if desired.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | sample | A sample of data sorted in increasing numerical order. If the sample size is not large enough for outlierMethod, both numLow and numHigh will be 0 and no testing will be done.
[in] | outlierMethod | Outlier method to use. Outlier methods are listed in Type mqm:outlierType. Note that the value is case sensitive.
[in] | sigLevel | Significance level to use in tests.
[out] | numLow | Number of outliers at the low end of sample; values at indices from 0 to numLow - 1 are outliers based on the chosen test. If numLow is 0, the sample has no outliers at the low end.
[out] | numHigh | Number of outliers at the high end of sample; values at indices from N - numHigh to N - 1 are outliers based on the chosen test (N is the size of sample). If numHigh is 0, the sample has no outliers at the high end.

◆ detectOutliers() [2/2]

void detectOutliers | ( | const std::vector< double > & | sample,
 |  | std::string | outlierMethod,
 |  | unsigned int *const | numLow,
 |  | unsigned int *const | numHigh
 | ) |  |
static

Given a sample and an outlier method, return the number of outliers at low and high extreme at significance level 0.05.

If outlierMethod is "none" or the empty string, or if outlierMethod is not listed in Type mqm:outlierType, then the method simply returns with 0 outliers. Otherwise the corresponding outlier test will be used to count the number of low and high outliers at significance level 0.05. If you wish to specify a different significance level, use detectOutliers(const std::vector<double>&, std::string, double, unsigned int*const, unsigned int*const).

If outlierMethod is "auto", then the method uses Dixon's N9 if sample size is less than 25 and Rosner's test otherwise.

Note that this method does not modify sample. You will need to remove the indicated outliers yourself if desired.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | sample | A sample of data sorted in increasing numerical order. If the sample size is not large enough for outlierMethod, both numLow and numHigh will be 0 and no testing will be done.
[in] | outlierMethod | Outlier method to use. Outlier methods are listed in Type mqm:outlierType. Note that the value is case sensitive.
[out] | numLow | Number of outliers at the low end of sample; values at indices from 0 to numLow - 1 are outliers based on the chosen test. If numLow is 0, the sample has no outliers at the low end.
[out] | numHigh | Number of outliers at the high end of sample; values at indices from N - numHigh to N - 1 are outliers based on the chosen test (N is the size of sample). If numHigh is 0, the sample has no outliers at the high end.

◆ expTransform()

std::vector< double > expTransform ( const std::vector< double > & logData )
static

Antilog (exp) transform of the input data.

Parameters
logData Any vector of logarithms.
Returns
The elementwise exp transform of the input vector.

◆ geometricMean()

double geometricMean ( const std::vector< double > & data )
static

Calculate the geometric mean.

The geometric mean is

geom(data) = (prodi xi)1/N

where N is the number of elements in data and the product is over all the elements xi. That is, the geometric mean is the Nth root of the product of all input values.

Equivalently, the logarithm of the geometric mean is equal to the arithmetic mean of the data in log space. This is actually how the mean is calculated by the method.

Parameters
data Any vector of numbers.
Returns
The geometric mean of data, or 1 if the vector is empty. If any of the data elements are 0 or negative, the mean is 0.

◆ geometricStandardDeviation()

double geometricStandardDeviation | ( | const std::vector< double > & | data,
 |  | double | geometricMean
 | ) |  |
static

Calculate the geometric sample standard deviation.

The geometric sample deviation is the square root of the geometric sample variance. The geometric sample variance is the second sample moment about the sample mean, scaled by N - 1, where N is the sample size. That is,

var(data) = e1/(N - 1)sumi( (log(xi) - log(geometricMean))2 )

where the sum is over all elements xi.

Equivalently, the logarithm of the geometric standard deviation is equal to the arithmetic standard deviation of the data in log space.

Parameters
data | A sample of data.
geometricMean | Sample geometric mean.
Returns
Sample standard deviation, or 0 if sample size is 0 or 1. If any data element is 0 or negative, or if the geometric mean is 0 or negative, then the standard deviation is 0.

◆ logTransform()

std::vector< double > logTransform ( const std::vector< double > & data )
static

Log transform of the input data.

Parameters
data Any vector of positive numbers.
Returns
The elementwise log transform of the input vector. If any element is 0 or negative, its logarithm will be substituted with a large negative number (but not negative infinity).

◆ meanCentre()

std::vector< double > meanCentre | ( | const std::vector< double > & | data,
 |  | double | mean
 | ) |  |
static

Centre the data values about the given mean.

Parameters
data | Any vector of numbers.
mean | Sample mean.
Returns
A mean centred vector of the same size as data.

◆ medianStandardErrorCorrection()

double medianStandardErrorCorrection ( unsigned long sampleSize )
static

Return the correction for the standard error of the median.

The standard error of the median is the same as the standard error of the mean, times a correction factor. That is, the standard error of the mean is s/sqrt(n), where s is the estimated standard deviation of the sample and n is the sample size. The standard error of the median is C * s/sqrt(n), where the constant C is the correction factor returned by this function.

The correction factor C is a function of sample size and is always between 1 and about 1.25. The sample median is an unbiased estimator of the population mean, but it has larger sampling variance than the sample mean (it is less efficient). For a normal population, the ratio between the variance of the sample mean and sample median tends to pi/2 as the sample size tends to infinity, which means C = sqrt(pi/2).

If the sample size is small (below about 100), then the constant is less than sqrt(pi/2) and depends on whether the sample size is even or odd. This method uses exact values for sample size between 1 and 12, and an accurate polynomial approximation for sample sizes between 13 and 100. These numbers and the polynomial are described in the following two publications, respectively:

  • Hojo, T. and K. Pearson (1931): Distribution of the Median, Quartiles and Interquartile Distance in Samples From a Normal Population. Biometrika 23(3/4):315-363.
  • Cadwell, J. H. (1952): The Distribution of Quantiles of Small Samples. Biometrika 39(1/2):207-211.

(Lower efficiency means that although the median is a robust estimator, this statistic always has a less extreme value than if the sample mean had been used. In other words, the p-value will be higher than for calculateNormalMeanPvalue() for the same sample.)

Parameters
sampleSize The sample size.
Returns
Correction constant as described above.

◆ normalCriticalValue()

double normalCriticalValue ( double p )
static

Return the critical value of the standard normal distribution at the given cumulative probability.

Suppose the random variable X has standard normal distribution. This routine returns the critical value x0 in the right tail such that

P(X <= abs(x0)) = p

where p is the desired cumulative probability.

Note that due to implementation reasons, the precision of the calculated critical value is limited to 3 decimal places. That is, the return value ranges from 0.000 to 4.090.

Parameters
p The cumulative probability between 0.5 and 1.0. If you need critical values for the left tail, give 1 - p as the argument and negate the result.
Returns
The critical value x0.

◆ normalCumulativeProbability()

double normalCumulativeProbability ( double x0 )
static

Return the cumulative probability that the standard normal statistic is at most x0.

Suppose the random variable X has standard normal distribution. This routine returns the cumulative probability p such that

p = P(0 <= X <= abs(x0))

where abs is the absolute value function. That is, the routine calculates the cumulative probability in the right tail. Since the normal distribution is symmetric, this can be used to calculate any cumulative probability of the distribution. Refer to a standard text on statistics for details.

Note that due to implementation reasons, the precision of the calculated critical value is limited to 6 decimal places. That is, the return value ranges from 0.000000 to 0.500000.

Parameters
x0 The critical value between 0.000 and 4.090, inclusive. Values beyond 4.090 are taken to be infinite (so cumulative probability is 0.50000), while the sign of negative value is changed to positive.
Returns
The cumulative probability that 0 <= X <= abs(x0).

◆ poissonDensity()

double poissonDensity | ( | double | lambda,
 |  | unsigned int | k
 | ) |  |
static

Calculate the probability density of the Poisson distribution.

Poisson probability density is the probability of observing exactly k events, when the events occur at mean rate per unit lambda.

Parameters
lambda | The rate parameter, which must be positive. If lambda is negative or zero, the function returns 0.
k | The number of events.
Returns
The probability density, or 0 if lambda is not positive.

◆ snedecorsCriticalValue()

double snedecorsCriticalValue | ( | unsigned int | df1,
 |  | unsigned int | df2,
 |  | double | sigLevel
 | ) |  |
static

Return the critical value of Snedecor's F distribution at the given significance level.

Suppose the random variable F has Snedecor's F distribution with df1 and df2 degrees of freedom. This routine returns the critical value f0 for which

P(F <= f0) = 1 - p

where p is the desired significance level. Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.050 < s <= 0.100 | 0.1
0.010 < s <= 0.050 | 0.05
s <= 0.010 | 0.01

If sigLevel exceeds 0.100, it is truncated to 0.100.

Parameters
df1 | The degrees of freedom for the "numerator" between 1 and 20, inclusive.
df2 | The degrees of freedom for the "denominator" between 1 and 100 inclusive.
sigLevel | Significance level. See the above table for supported values.
Returns
The critical value f0.

◆ sortedMedian() [1/2]

double sortedMedian ( const std::deque< double > & data )
static

Find the median of a sorted data deque.

The median of a sorted input deque can be found very easily:

  • If the deque has an odd number of elements N, then the median is simply the element at index m = (N-1)/2.
  • If the deque has an even number of elements N, then the median is the mean between the two central elements m1 = floor((N-1)/2) = N/2 - 1 and m2 = ceil((N-1)/2) = N/2.

If data is empty the method returns zero.

Parameters
data Any sorted deque of numbers.
Returns
The median value of the input deque.

◆ sortedMedian() [2/2]

double sortedMedian ( const std::vector< double > & data )
static

Find the median of a sorted data vector.

The median of a sorted input vector can be found very easily:

  • If the vector has an odd number of elements N, then the median is simply the element at index m = (N-1)/2.
  • If the vector has an even number of elements N, then the median is the mean between the two central elements m1 = floor((N-1)/2) = N/2 - 1 and m2 = ceil((N-1)/2) = N/2.

If data is empty the method returns zero.

Parameters
data Any sorted vector of numbers.
Returns
The median value of the input vector.

◆ studentsCriticalValue()

double studentsCriticalValue | ( | unsigned int | df,
 |  | double | sigLevel
 | ) |  |
static

Return the critical value of Student's t distribution at the given significance level.

Suppose the random variable t has Student's t distribution with df degrees of freedom. This routine returns the critical value t0 for which

P(t <= t0) = 1 - p

where p is the desired significance level. Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.050 < s <= 0.100 | 0.1
0.025 < s <= 0.050 | 0.05
0.010 < s <= 0.025 | 0.025
0.005 < s <= 0.010 | 0.01
0.001 < s <= 0.005 | 0.005
s <= 0.001 | 0.001

If sigLevel exceeds 0.100, it is truncated to 0.100.

If you need critical values for df exceeding 100, you can use the standard normal critical values as a good approximation; see normalCriticalValue().

Parameters
df | The degrees of freedom. If df exceeds 100, it is taken to be infinite.
sigLevel | Significance level. See the above table for supported values.
Returns
The critical value t0.

◆ sum()

double sum ( const std::vector< double > & data )
static

Calculate the sum of a sample vector.

Parameters
data Any vector of numbers.
Returns
The sum of the elements of data.

◆ sumsq()

double sumsq ( const std::vector< double > & data )
static

Calculate the sum of squares of a sample vector.

Parameters
data Any vector of numbers.
Returns
The sum of the squares of elements of data.

◆ testDixonsN9()

int testDixonsN9 | ( | unsigned long | sampleSize,
 |  | double | min,
 |  | double | x2,
 |  | double | xn_1,
 |  | double | max,
 |  | double | sigLevel
 | ) |  |
static

Apply Dixon's N9 (r11) outlier test to the sample.

Dixon's N9 outlier test assumes that the data is normally distributed with unknown mean and variance, and that it could be contaminated by value(s) from another normal distribution with a different mean or variance. (For example, such contamination could result from gross measurement errors.) A related but different test is Grubbs N2; see testGrubbsN2().

Dixon's N9 is based on sample order statistics, which are used to estimate sample standard deviation. The test tries to remove one of two extremes: sample maximum or sample minimum. The extreme with the higher statistic will be chosen for possible removal. The method returns -1 or +1 if the chosen extreme is an outlier (statistic exceeds a critical value) and 0 otherwise. If you suspect the sample contains multiple outliers, use the test repeatedly until it returns 0, removing the corresponding outlier at each step. (Note that in sequential use, sigLevel is a significance level strictly speaking only for the first test.)

If your data is multiplicative, for example log-normal (such as peptide ratios), then you need to do a log transformation first before calling this method. See logTransform().

Description of the test procedure and critical values are presented in the following references:

  • Dixon, W. J. (1950): Analysis of Extreme Values. The Annals of Mathematical Statistics 21(4):488-506.
  • Dixon, W. J. (1951): Ratios Involving Extreme Values. The Annals of Mathematical Statistics 22(1):68-78.
  • Verma, S. P. and A. Quiroz-Ruiz (2006): Critical values for six Dixon tests for outliers in normal samples up to sizes 100, and applications in science and engineering. Revista Mexicana de Ciencias Geológicas 23(2):133-161.

Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.200 < s <= 0.300 | 0.3
0.100 < s <= 0.200 | 0.2
0.050 < s <= 0.100 | 0.1
0.020 < s <= 0.050 | 0.05
0.010 < s <= 0.020 | 0.02
0.005 < s <= 0.010 | 0.01
s <= 0.005 | 0.005

If sigLevel exceeds 0.300, it is truncated to 0.300.

Parameters
sampleSize | Sample size. If this is not between 4 and 100, the method returns 0.
min | Minimum value in the sample.
x2 | Second smallest value in the sample.
xn_1 | Second largest value in the sample.
max | Maximum value in the sample.
sigLevel | Significance level. See the above table for supported values.
Returns
One of three values: 0 if neither extreme is an outlier; -1 if min is an outlier; and +1 if max is an outlier.

◆ testGrubbsN2()

int testGrubbsN2 | ( | unsigned long | sampleSize,
 |  | double | min,
 |  | double | mean,
 |  | double | max,
 |  | double | stdev,
 |  | double | sigLevel
 | ) |  |
static

Apply Grubb's N2 outlier test to the sample statistics.

Grubbs N2 outlier test tries to remove one of two extremes: sample minimum or sample maximum. The data is assumed normally distributed with unknown mean and variance, and a statistic is computed for both extremes. The extreme with the higher statistic will be chosen for possible removal. The method returns -1 or +1 if the chosen extreme is an outlier (statistic exceeds a critical value) and 0 otherwise.

It is usually best to use a normal probability plot to assess whether outlier removal is needed and how many outliers there seem to be. The Grubbs N2 test assumes the data has at most one outlier, and may fail to remove the outlier if there are actually two or more outliers in the data (this is called masking). If you suspect more than one outlier, the generalised ESD test is more appropriate; see testRosners().

If your data is multiplicative, for example log-normal (such as peptide ratios), then you need to do a log transformation first before calling this method. See logTransform().

If you suspect the data is contaminated by values from another normal distribution with a different mean or variance, then Dixon's N9 test could be more appropriate. See testDixonsN9().

Details of the test procedure and critical values are presented in the following references:

  • Grubbs, F. E. (1969): Procedures for Detecting Outlying Observations in Samples. Technometrics 11:1-21.
  • Verma, S. P. and A. Quiroz-Ruiz (2006): Critical values for 22 discordancy test variants for outliers in normal samples up to sizes 100, and applications in science and engineering. Revista Mexicana de Ciencias Geológicas 23(3):302-319.
  • NIST/SEMATECH e-Handbook of Statistical Methods, section 1.3.5.17.1

Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.200 < s <= 0.300 | 0.3
0.100 < s <= 0.200 | 0.2
0.050 < s <= 0.100 | 0.1
0.020 < s <= 0.050 | 0.05
0.010 < s <= 0.020 | 0.02
0.005 < s <= 0.010 | 0.01
s <= 0.005 | 0.005

If sigLevel exceeds 0.300, it is truncated to 0.300.

Parameters
sampleSize | Sample size. If this is not between 3 and 100, the method returns 0.
min | Minimum value in the sample.
mean | Sample arithmetic mean.
max | Maximum value in the sample.
stdev | Sample standard deviation. If stdev is not positive, the method returns 0.
sigLevel | Significance level. See the above table for supported values.
Returns
One of three values: 0 if neither extreme is an outlier; -1 if min is an outlier; and +1 if max is an outlier.

◆ testRosners()

void testRosners | ( | const std::vector< double > & | sample,
 |  | unsigned int | maxOutliers,
 |  | double | sigLevel,
 |  | unsigned int *const | numLow,
 |  | unsigned int *const | numHigh
 | ) |  |
static

Apply the generalised extreme Studentised deviate (ESD) outlier test (aka Rosner's test) to the sample.

The generalised ESD test tries to remove at least 1 and up to maxOutliers outliers from the sample. If you suspect there is at most one outlier in the data, the Grubbs N2 test may be more appropriate; see testGrubbsN2().

The data is assumed normally distributed with unknown mean and variance. If your data is multiplicative, for example log-normal (such as peptide ratios), then you need to do a log transformation first before calling this method. See logTransform().

Description of the test procedure can be found in the following references:

  • Rosner, B. (1983): Percentage Points for a Generalized ESD Many-Outlier Procedure. Technometrics, 25(2):165-172.
  • NIST/SEMATECH e-Handbook of Statistical Methods, section 1.3.5.17.3

Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.100 < s <= 0.200 | 0.2
0.050 < s <= 0.100 | 0.1
0.020 < s <= 0.050 | 0.05
0.010 < s <= 0.020 | 0.02
0.002 < s <= 0.010 | 0.01
s <= 0.002 | 0.002

If sigLevel exceeds 0.200, it is truncated to 0.200.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | sample | A sample of data sorted in increasing numerical order. Sample size must be at least 25 for meaningful results.
[in] | maxOutliers | Number between 1 and 10 (inclusive) indicating the maximum number of suspected outliers in the sample.
[in] | sigLevel | Significance level. See the above table for supported values.
[out] | numLow | Number of outliers at the low end of sample; values at indices from 0 to numLow - 1 are outliers based on the test. If numLow is 0, the sample has no outliers at the low end.
[out] | numHigh | Number of outliers at the high end of sample; values at indices from N - numHigh to the end of the vector are outliers based on the test (N is the size of sample). If numHigh is 0, the sample has no outliers at the high end.

◆ testShapiroWilkW()

bool testShapiroWilkW | ( | const std::vector< double > & | sample,
 |  | double *const | W,
 |  | double *const | pValue
 | ) |  |
static

Apply Shapiro-Wilk W normality test to the sample.

See Multiple return values in Perl, Java, Python and C#.

See ms_shapiro_wilk for the test details. This method returns false if any of the following conditions apply:

  • Sample size is less than 3.
  • Sample range (max - min) is not positive.

In these cases the test is not conducted, and the values of W and pValue are not defined.

The number of right-censored values is assumed to be 0. If your sample contains censored values, use ms_shapiro_wilk directly.

Parameters
[in] | sample | A sample of data sorted in increasing numerical order. The number of elements should be between 3 and 5000, inclusive. If sample size exceeds 5000, the test statistic and p-value will be calculated successfully, but the p-value is not guaranteed to be accurate.
[out] | W | The Shapiro-Wilk W statistic calculated from the data.
[out] | pValue | The p-value of W under the null hypothesis.
Returns
True if the test was conducted; false otherwise.

◆ unsortedMedian()

double unsortedMedian ( const std::vector< double > & data )
static

Find the median of an unsorted data vector.

This method works for both sorted and unsorted input, although in the former case it is faster to call sortedMedian() instead.

The trivial implementation is to create a copy of the input data, sort and then call sortedMedian(). This method is slightly faster: If the input vector has an odd number of elements N, then the median would be at index m = (N-1)/2; otherwise the median is between elements m1 = floor((N-1)/2) and m2 = ceil((N-1)/2). The method uses partial sorting to find the mth element (or the m1st and m2nd elements) which means time complexity is slightly less than O(N log(N)) (which is the average time complexity of quicksort).

Parameters
data Any vector of numbers.
Returns
The median of data, or 0 if the vector is empty.

◆ weightedArithmeticMean()

double weightedArithmeticMean | ( | const std::vector< double > & | data,
 |  | const std::vector< double > & | weights
 | ) |  |
static

Calculate the weighted arithmetic mean.

The weighted arithmetic mean is

mean(data, weights) = (1/W)sumi wixi

where W is the sum of weights, wi is an individual weight, and the summation is over all elements xi.

Parameters
data | Any vector of numbers.
weights | Positive weight for each datum in data. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than data, the missing weights are taken to be 1.0.
Returns
The weighted arithmetic mean of data, or 0 if the vector is empty.

◆ weightedArithmeticStandardDeviation()

double weightedArithmeticStandardDeviation | ( | const std::vector< double > & | data,
 |  | const std::vector< double > & | weights,
 |  | double | weightedMean
 | ) |  |
static

Calculate the weighted arithmetic sample standard deviation.

The weighted arithmetic sample deviation is the square root of the weighted arithmetic sample variance. The weighted sample variance is

var(data,weights) = var(data)/b(weights)

where the effective base b is

b(weights) = (sumi wi)2/sumi(wi2)

Parameters
data | A sample of data.
weights | Positive weight for each datum in data. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than data, the weights of those elements are taken to be 1.0.
weightedMean | Sample weighted arithmetic mean.
Returns
Sample standard deviation, or 0 if sample size is 0 or 1.

◆ weightedArithmeticStandardError()

double weightedArithmeticStandardError | ( | const std::vector< double > & | weights,
 |  | double | weightedStdev,
 |  | unsigned long | sampleSize
 | ) |  |
static

Calculate the standard error of the weighted arithmetic sample mean.

The standard error of the weighted arithmetic mean is slightly different from the standard error of the mean. Like the weighted standard deviation, the weights must be taken into account. The effective base b is

b(weights) = (sumi wi)2/sumi(wi2) = W2/S,

where W2 is the squared sum of the weights, and S is the sum of squared weights. As the weighted mean is

mean(data, weights) = (1/W)sumi wixi,

we can use the usual sample properties (independent, identically distributed random variables) to easily derive

var(mean) = sigma2/(b/W)

where sigma2 is the population variance. The sample estimate of the standard error is then

sqrt(W s2/b2) = sqrt(W) s/b,

which is the value returned by this function.

Parameters
weights | Positive weight for each datum. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than sampleSize, the weights of those elements are taken to be 1.0.
weightedStdev | Sample weighted arithmetic standard deviation. It is recommended to use weightedArithmeticStandardDeviation() with the same weights.
sampleSize | The sample size.
Returns
Weighted standard error, or 0 if sample size is 0 or 1.

◆ weightedGeometricMean()

double weightedGeometricMean | ( | const std::vector< double > & | data,
 |  | const std::vector< double > & | weights
 | ) |  |
static

Calculate the weighted geometric mean.

The weighted geometric mean is

geom(data,weights) = (prodi xiwi)1/W

where W is the sum of weights, wi is an individual weight and the product is over all the elements xi. That is, the geometric mean is the Wth root of the product of the with roots of the input values.

Equivalently, the logarithm of the weighted geometric mean is equal to the weighted arithmetic mean of the data in log space. This is actually how the mean is calculated by the method.

Parameters
data | Any vector of numbers.
weights | Positive weight for each datum in data. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than data, the missing weights are taken to be 1.0.
Returns
The weighted geometric mean of data, or 1 if the vector is empty. If any of the data elements are 0, the mean is 0.

◆ weightedGeometricStandardDeviation()

double weightedGeometricStandardDeviation | ( | const std::vector< double > & | data,
 |  | const std::vector< double > & | weights,
 |  | double | weightedMean
 | ) |  |
static

Calculate the weighted geometric sample standard deviation.

The weighted geometric sample deviation is the square root of the weighted geometric sample variance. The geometric sample variance is

var(logdata,weights) = evar(logdata)/b

where the effective base b is

b(weights) = (sumi wi)2/sumi(wi2)

and logdata is the log-transformed data.

Equivalently, the logarithm of the weighted geometric standard deviation is equal to the weighted arithmetic standard deviation of the data in log space.

Parameters
data | A sample of data.
weights | Positive weight for each datum in data. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than data, the weights of those elements are taken to be 1.0.
weightedMean | Sample weighted geometric mean.
Returns
Sample standard deviation, or 0 if sample size is 0 or 1.
The documentation for this class was generated from the following files:
  • ms_quant_stats.hpp
  • ms_quant_stats.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quantitation Class Reference

  • matrix_science
  • ms_quantitation
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ms_quantitation Class Referenceabstract
Quantitation analysis for Mascot Server and Distiller

Base class for peptide and protein quantitation. More...

#include <ms_quantitation.hpp>

Inheritance diagram for ms_quantitation:
[legend]
Collaboration diagram for ms_quantitation:
[legend]

Public Member Functions

virtual | ~ms_quantitation ()=0
Destructor.
void | addHeaderField (const std::string &name, const std::string &value)
Adds an item of project or search header information.
void | addRawFileField (const unsigned int id, const std::string &name, const std::string &value)
Adds an item of raw file header information.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearHeaderFields ()
Clears any header information from the result.
void | clearRawFileFields ()
Clears any raw file header information from the result.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual int | countDistinctPeptides (const ms_peptide_quant_key_vector &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
virtual int | countDistinctPeptides (const std::vector< ms_peptide_quant_key > &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
ms_peptide_quant_key_vector | getPeptideQuantKeys (const std::string &accession, int dbIdx) const
Look up peptide quant keys associated with a given protein, if any.
virtual ms_peptide_quant_ratio | getPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const =0
Given peptide quant key and ratio name, return the corresponding peptide ratio data.
double | getPeptideRatioNormalisationBase (const std::string &ratioName) const
Get the peptide ratio normalisation base of the given ratio name.
const ms_progress_info & | getProgressInfo ()
Get information about the progress of a currently running long operation (e.g. loading from a file).
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName) const =0
Given the protein accession, database ID and ratio name, return the protein ratio data.
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const =0
Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.
const ms_quant_method & | getQuantitationMethod () const
Return the current quantitation method.
virtual bool | hasPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const =0
Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.
virtual bool | isPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName) const =0
Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?
bool | isValid () const
Call this function to determine if there have been any errors.
void | removePeptideRatioNormalisationBase (const std::string &ratioName)
Reset the peptide ratio normalisation base of the given ratio name.
void | removePeptideRatioNormalisationBases ()
Reset all peptide ratio normalisation bases.
void | setMinNumPeptides (int value)
Set the minimum number of peptides needed for protein ratio calculation.
virtual void | setPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName)=0
Globally exclude a particular peptide ratio from protein ratio calculation.
virtual void | setPeptideRatioIncluded (const ms_peptide_quant_key &key, const std::string &ratioName)=0
Globally include a particular peptide ratio in protein ratio calculation.
void | setPeptideRatioNormalisationBase (const std::string &ratioName, double b)
Set the peptide ratio normalisation base of the given ratio name.
virtual void | setProteinRatioType (const char *value)=0
Set the protein ratio type.
virtual void | setQuantOutliers (const ms_quant_outliers *)=0
Set new peptide ratio outlier settings.

Protected Member Functions

ms_protein_quant_ratio | calculateGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the geometric mean and standard deviation.
ms_protein_quant_ratio | calculateMedianRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the median and standard deviation from the median.
ms_protein_quant_ratio | calculateWeightedGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.
int | getMinNumPeptides () const
Get the minimum number of peptides needed for protein ratio calculation.
void | getProteinRatioSample (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const
Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.
virtual void | getSortedFinitePeptideRatioValues (const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKeys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const =0
Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.
bool | initialiseBaseSettings (const ms_quant_method &qmBase, const ms_quant_method &qmConfig)
Initialise quantitation method settings from the two method objects.

Protected Attributes

protein_to_peptide_quant_key_t proteinKeys_
Protein-to-peptide mapping.

Detailed Description

Base class for peptide and protein quantitation.

ms_quantitation is an abstract class and cannot be instantiated. It provides shared read access methods for two child classes: ms_ms2quantitation and ms_customquantitation. See Peptide and protein quantitation and child class documentation for details and use cases.

You always need to define a quantitation method when creating an object of either kind. For ms_ms2quantitation, a full quantitation method definition is needed, including protocol settings, component definitions, peptide quality settings and protein ratio settings. Usually it is easiest to use the quantitation method from the Mascot results file and customise it as needed; see ms_mascotresfilebase::getQuantitationMethod() and the ms_ms2quantitation constructor for details.

For ms_customquantitation, the minimum the quantitation method needs to define is protein ratio settings. If you have a Mascot results file, it won't hurt to use the quantitation method from the results file as base configuration. However, the class will not use any component or peptide quality settings.

The input quantitation method needs to be distinguished from the current (or effective) quantitation method. The class will always create a copy of the quantitation method used as input, and allows changing some of its parameters later to alter how protein ratios are calculated or to change normalisation settings. You have read-only access to the current quantitation method with getQuantitationMethod().

The base class provides three kinds of functionality:

  1. Access peptide ratios:
    • hasPeptideRatio(const ms_peptide_quant_key&, const std::string &) const
    • getPeptideRatio(const ms_peptide_quant_key&, const std::string &) const
  2. Access protein ratios and associated peptide quant keys:
    • getProteinRatio(const std::string &, int, const std::string &) const
    • getProteinRatio(const std::string &, int, const std::string &, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const
    • getPeptideQuantKeys(const std::string &, int) const
  3. Access and modify quantitation method settings related to protein ratio calculation:
    • getQuantitationMethod() const
    • setPeptideRatioExcluded(const ms_peptide_quant_key &, const std::string &)
    • setQuantOutliers(const ms_quant_outliers *)
    • setMinNumPeptides(int value)
    • setProteinRatioType(const char *value)

Protein ratios are calculated from peptide ratios on demand, which means changing any of the protein ratio related quantitation method settings will take effect immediately. Depending on child class, peptide ratios are either extracted from a Mascot results file (ms_ms2quantitation) or constructed manually (ms_customquantitation).

Two kinds of indexing are used: peptide ratios are identified by the tuple (peptide quant key, ratio name) and protein ratios are identified by the triplet (accession, database index, ratio name). Ratio name refers to the name of report ratios defined in the quantitation method. For example, for iTRAQ 4-plex this could be "115/114", "116/114" and "117/114". You can find the ratio names from the quantitation method object using ms_quant_method::getReportRatioByNumber().

In ms_ms2quantitation, the mapping between peptide ratios and the peptide ID triplet is one-to-one; that is, each peptide ratio has a single associated query and rank (q,p value), from which its peptide quant key is constructed.

In ms_customquantitation, peptide quant keys are free-form.

In both cases, the protein database index is usually the return value of ms_protein::getDB() for Mascot search results, but need not be in ms_customquantitation. See the latter's documentation for details.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ calculateGeometricMeanRatio()

ms_protein_quant_ratio calculateGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protected

Given a sample of peptide ratios, calculate the geometric mean and standard deviation.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.

◆ calculateMedianRatio()

ms_protein_quant_ratio calculateMedianRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protected

Given a sample of peptide ratios, calculate the median and standard deviation from the median.

See ms_quant_stats::sortedMedian for details of how this is calculated.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-values, if relevant.

◆ calculateWeightedGeometricMeanRatio()

ms_protein_quant_ratio calculateWeightedGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< double > & | weights,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const
 protected

Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.

Parameters
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ countDistinctPeptides() [1/2]

int countDistinctPeptides ( const ms_peptide_quant_key_vector & activeKeys ) const
virtual

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

This function just calls countDistinctPeptides() relevant to the implementing class (ms_ms1quantitation or ms_ms2quantitation).

Parameters
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns
The number of distinct peptides.

Reimplemented in ms_ms1quantitation, and ms_ms2quantitation.

◆ countDistinctPeptides() [2/2]

int countDistinctPeptides ( const std::vector< ms_peptide_quant_key > & activeKeys ) const
virtual

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

Parameters
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns
The number of distinct peptides.

Reimplemented in ms_ms1quantitation, ms_ms1quantitation, ms_ms2quantitation, and ms_ms2quantitation.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMinNumPeptides()

int getMinNumPeptides ( ) const
protected

Get the minimum number of peptides needed for protein ratio calculation.

Returns
The minimum number of peptides needed for protein ratio calculation.

◆ getPeptideQuantKeys()

ms_peptide_quant_key_vector getPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const

Look up peptide quant keys associated with a given protein, if any.

In ms_ms2quantitation, the list of peptide quant keys associated with the given protein is immutable, as the keys are derived from q,p values in the Mascot results file. The list does not contain all q,p values, but only those that 1) have component intensities and 2) pass the quality thresholds. Unless the data quality is extremely good, this list will always have fewer elements than the actual peptide matches assigned to the protein hit.

In ms_customquantitation, the peptide-to-protein mapping can be altered with ms_customquantitation::addPeptideQuantKey() and ms_customquantitation::removePeptideQuantKey().

Parameters
accession | The protein accession.
dbIdx | The protein database index.
Returns
A vector of peptide quant keys associated with the protein.

◆ getPeptideRatio()

ms_peptide_quant_ratio getPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 pure virtual

Given peptide quant key and ratio name, return the corresponding peptide ratio data.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

If hasPeptideRatio(const ms_peptide_quant_key&, std::string) const returns false for the given peptide quant key and ratio name, then the peptide ratio object returned by this method represents an undefined ("missing") value.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
The peptide ratio. If hasPeptideRatio() returns false, the field values of the object returned by this method are undefined.

Implemented in ms_customquantitation, and ms_ms2quantitation.

◆ getPeptideRatioNormalisationBase()

double getPeptideRatioNormalisationBase ( const std::string & ratioName ) const

Get the peptide ratio normalisation base of the given ratio name.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters
ratioName Peptide ratio name.
Returns
The current peptide ratio normalisation base, or 1 if it hasn't been set.

◆ getProgressInfo()

const matrix_science::ms_progress_info & getProgressInfo ( )

Get information about the progress of a currently running long operation (e.g. loading from a file).

Returns
Progress information about the most recent long operation.

◆ getProteinRatio() [1/2]

ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName
 | ) |  | const
 pure virtual

Given the protein accession, database ID and ratio name, return the protein ratio data.

Protein ratios are calculated on demand from the current protein-peptide mapping using the current quantitation method and taking peptide exclusion into account. You can exclude peptides from protein ratio calculation by using setPeptideRatioExcluded(). The current outlier detection method may also change which peptide ratios are used for any given protein.

For ms_ms2quantitation, the protein-peptide mapping is immutable. There are three types of protein ratio, which can be changed with setProteinRatioType(): median, average and weighted. Median is the median of all peptide ratios associated with the protein hit, and average is the geometric mean (equivalently, the arithmetic mean of log-transformed peptide ratios). Weighted is a weighted mean of peptide ratios, where the weights are channel intensities. The weighted ratio type is only available for Reporter data.

For ms_customquantitation, you can change the protein-peptide mapping by associating different peptide quant keys with the protein accession; see ms_customquantitation::addPeptideQuantKey() for details. There are three types of protein ratio: median, average and weighted. Median and average are the same as in ms_ms2quantitation, except in the Average protocol (see below). Weighted is the weighted geometric mean, where the weighting factor of each peptide ratio must be specified when the peptide ratio is added to the class. This is not the same weighting as in ms_ms2quantitation.

ms1, ms2 and custom protein ratios are calculated using:

  • median - See ms_quant_stats::sortedMedian
  • average - See ms_quant_stats::geometricMean
  • weighted - See ms_quant_stats::weightedArithmeticMean

It is possible for the protein ratio to be undefined ("missing") even when it has associated peptide ratios, if there are not enough peptide ratios (setMinNumPeptides()), if all of them are marked excluded, or if too many of them are infinite.

If quantitation protocol is Reporter, Multiplex, Replicate or Precursor, the returned protein ratio object contains two p-values: the normality test value and the null hypothesis value.

The log-transformed peptide ratios are assumed normally distributed, and this hypothesis is tested using the Shapiro-Wilk W test. The normality p-value is -1 when the test could not be run (e.g. too few peptide ratios) and otherwise a positive number between 0 and 1. In the latter case, a value of less than 0.05 (or similar threshold) is usually taken as evidence that the log-transformed peptide ratios are not normally distributed, or equivalently that the peptide ratios are not log-normally distributed.

If outlier removal is configured, then outliers will be removed before normality testing. If this makes the normality p-value fall below 0.05, then the outliers will be restored. In this case the original sample was likely not normal to start with, and the normality p-value is calculated based on the original sample. If outlier removal is successful, then the normality p-value is based on the sample from which outliers have been removed, and it always exceeds 0.05.

The second p-value is for the null hypothesis. The null hypothesis is that the protein ratio equals 1.0 (component intensities have equal values). The p-value is -1 if there is only one peptide ratio, and otherwise a positive number between 0 and 1. The test is conducted after outlier removal, if any.

Note that the hypothesis test is done regardless of the p-value of the normality test. This means that you need to decide first if you accept peptide ratio normality before deciding whether to reject or not reject the null hypothesis. If normality is violated, then the hypothesis p-value is meaningless.

You can inspect which peptide quant keys were used in protein ratio calculation and which were ignored, due to being excluded or being outliers, with ms_protein_quant_ratio::getActiveKeys(), ms_protein_quant_ratio::getExcludedKeys() and ms_protein_quant_ratio::getOutlierKeys(). You can "move" peptide quant keys between the last two categories and the first by using the method getProteinRatio(const std::string &, int, const std::string &, const ms_peptide_quant_key_vector &, const ms_peptide_quant_key_vector &) const.

Note about weighted protein ratios: Parser 2.5 and 2.6 do not calculate the standard deviation, standard error or p-values when protein ratio type is weighted in Reporter data. The values are set to -1 ("unavailable"); see ms_protein_quant_ratio::getStandardDeviation(). The values are available in ms_customquantitation, which uses a different weighting formula.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, the only supported protein ratio type is "average", which does not mean a geometric average. Rather, the protein ratio is the sum of the "top N" peptide intensities, divided by the sum of the top N peptide intensities of the reference protein (see ms_customquantitation::setAverageReferenceProtein()). Neither outlier removal nor normalisation have any meaning in this protocol, which means no significance tests are done and the returned protein ratio object will not contain any p-values.

For more details on configuring other aspects of protein ratio calculation, please consult the quantitation help pages.

Parameters
accession | The protein accession.
dbIdx | The protein database index.
ratioName | The name of the ratio.
Returns
The protein ratio as calculated from peptide ratios associated with this protein accession. If the ratio could not be calculated (e.g. there are no associated peptide ratios), then the returned object will represent an undefined ("missing") value.

Implemented in ms_customquantitation, ms_ms1quantitation, and ms_ms2quantitation.

◆ getProteinRatio() [2/2]

ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | includeKeys,
 |  | const ms_peptide_quant_key_vector & | excludeKeys
 | ) |  | const
 pure virtual

Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.

The protein ratio is calculated as described in getProteinRatio(const std::string &, int, const std::string &) const, but the two peptide quant key vectors includeKeys and excludeKeys can be used to override default decisions about globally excluded and outlier peptide ratios. The rules are as follows:

  1. If a peptide quant key is globally excluded with setPeptideRatioExcluded(), then giving the peptide quant key in includeKeys causes the peptide quant key to be included regardless ("undo global exclusion").
  2. If a peptide quant key is given in excludeKeys, then the peptide quant key will be always excluded ("exclude locally").

If the peptide quant key is in both includeKeys and excludeKeys, the latter takes precedence and the peptide quant key is excluded.

Note that if outlier detection is enabled, then a peptide quant key determined to be an outlier cannot be included back using includeKeys, i.e. the inclusion mechanism does not undo outlier removal. You can disable outlier removal entirely before calling getProteinRatio() if you do not want peptide quant keys to be removed.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, then the effect of excludeKeys depends on whether the peptide quant key describes a "top N" peptide intensity. If the peptide intensity is one of the top N intensities assigned to this protein, then excluding it means the next highest outside the top N intensities will take its place. No peptide quant keys will ever be excluded automatically as outliers, since outlier removal has no meaning in this protocol.

Parameters
accession | The protein accession.
dbIdx | The protein database index.
ratioName | The name of the ratio.
includeKeys | Peptide quant keys to always include, even if they are globally excluded or would be marked as outliers.
excludeKeys | Peptide quant keys to always exclude, even if they are not outliers.
Returns
The protein ratio as calculated from peptide ratios associated with this protein accession. If the ratio could not be calculated (e.g. there are no associated peptide ratios), then the returned object will represent an undefined ("missing") value.

Implemented in ms_customquantitation, ms_ms1quantitation, and ms_ms2quantitation.

◆ getProteinRatioSample()

void getProteinRatioSample | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< ms_peptide_quant_key > & | includeKeys,
 |  | const std::vector< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | sample,
 |  | std::vector< double > & | logSample,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double & | normalityPvalue
 | ) |  | const
 protected

Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.

This method uses getSortedFinitePeptideRatioValues() internally to collect the vector of peptide ratios. If there are no peptide quant keys associated with the protein, or if no peptide ratios are associated with with those peptide quant keys, then sample, logSample, activeKeys and inactiveKeys will be empty and normalityPvalue will have an undefined value.

Parameters
accession | Protein accession.
dbIdx | Protein database index.
ratioName | Name of the ratio.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
sample | Peptide ratios associated with ratioName and the protein's peptide quant keys, in numerically increasing order.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
activeKeys | Peptide quant keys corresponding to the order of sample (and logSample).
inactiveKeys | Peptide quant keys marked as skipped, excluded or outlier.
normalityPvalue | The p-value that the sample appears to be normally distributed after outlier removal. If less than 0.05, no outliers will have been removed.

◆ getQuantitationMethod()

const ms_quant_method & getQuantitationMethod ( ) const

Return the current quantitation method.

The current (or effective) quantitation method is the original quantitation method given as argument to the constructor (or loaded from the Mascot results file), with possible later modifications, such as changing normalisation or outlier settings.

For ms_ms2quantitation, you cannot change the protocol settings, component definitions or peptide quality settings. You must create a new object with the new settings instead. You are free to change how protein ratios are calculated and set new normalisation parameters. These changes will be reflected in this method's output value.

For ms_customquantitation, same restrictions apply, although it makes little difference, as the class does not use any protocol settings, component definitions or peptide quality settings.

Returns
The current quantitation method.

◆ getSortedFinitePeptideRatioValues()

void getSortedFinitePeptideRatioValues | ( | const std::string & | ratioName,
 |  | const std::set< ms_peptide_quant_key > & | keys,
 |  | const std::set< ms_peptide_quant_key > & | includeKeys,
 |  | const std::set< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | values,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys
 | ) |  | const
 protectedpure virtual

Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.

The method looks up all peptide ratios associated with keys (ignoring duplicates) and returns them in numerically increasing order in values. Infinite and missing ratios are ignored. The vector activeKeys contains active peptide quant keys in the same order as values, and the map inactiveKeys contains peptide quant keys associated with the protein ratio but for indicated reasons not included in ratio calculation.

Parameters
ratioName | The name of the peptide ratio.
keys | A list of (sorted or unsorted) peptide quant keys for which to look up the ratios.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
values | Peptide ratios associated with ratioName and the given peptide quant keys.
weights | Weighting factors of corresponding to the order of values.
activeKeys | Peptide quant keys corresponding to the order of values.
inactiveKeys | Peptide quant keys skipped or excluded.

Implemented in ms_customquantitation, and ms_ms2quantitation.

◆ hasPeptideRatio()

bool hasPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 pure virtual

Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
True if the peptide ratio exists; false otherwise.

Implemented in ms_customquantitation, and ms_ms2quantitation.

◆ initialiseBaseSettings()

bool initialiseBaseSettings | ( | const ms_quant_method & | qmBase,
 |  | const ms_quant_method & | qmConfig
 | ) |  |
protected

Initialise quantitation method settings from the two method objects.

For any method settings which are not consistent between the passed qmBase and qmConfig, the values from qmConfig will be used.

Parameters
qmBase | The base quantitation method as defined on the Mascot server.
qmConfig | The quantitation method to use to calculate quantitation results using.
Returns
True.

◆ isPeptideRatioExcluded()

bool isPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const
 pure virtual

Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?

(This method is redundant; you could also look up the peptide ratio and use ms_peptide_quant_ratio::isExcluded().)

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns
True if the peptide ratio should be excluded from protein ratio calculation; false otherwise.

Implemented in ms_customquantitation, and ms_ms2quantitation.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ removePeptideRatioNormalisationBase()

void removePeptideRatioNormalisationBase ( const std::string & ratioName )

Reset the peptide ratio normalisation base of the given ratio name.

Resetting means the report ratio normalisation constant is set to 1.0. This has the same effect as calling setPeptideRatioNormalisationBase() with b = 1.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

Parameters
ratioName Ratio name whose normalisation base is to be reset.

◆ removePeptideRatioNormalisationBases()

void removePeptideRatioNormalisationBases ( )

Reset all peptide ratio normalisation bases.

Resetting all report ratio normalisation bases means all peptide and protein ratios become unnormalised.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

◆ setMinNumPeptides()

void setMinNumPeptides ( int value )

Set the minimum number of peptides needed for protein ratio calculation.

Changing the minimum number of peptides changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: The Average protocol has two settings for minimum number of peptides. This setting defines how many peptide intensities are needed for a protein before its ratio can be calculated. It is usually meaningless to choose a value other than 1. Use ms_customquantitation::setAverageNumPeptides() to define how many intensities should be used in protein ratio calculation.

Parameters
value The minimum number of peptide ratios (the sample size) a protein must have for protein ratio calculation purposes. Values less than 1 are interpreted as 1.

◆ setPeptideRatioExcluded()

void setPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |
pure virtual

Globally exclude a particular peptide ratio from protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implemented in ms_customquantitation, and ms_ms2quantitation.

◆ setPeptideRatioIncluded()

void setPeptideRatioIncluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |
pure virtual

Globally include a particular peptide ratio in protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implemented in ms_customquantitation, and ms_ms2quantitation.

◆ setPeptideRatioNormalisationBase()

void setPeptideRatioNormalisationBase | ( | const std::string & | ratioName,
 |  | double | b
 | ) |  |

Set the peptide ratio normalisation base of the given ratio name.

Setting peptide ratio normalisation to a particular value means all peptide ratios with ratioName will be divided by b before they are returned by getPeptideRatio(). That is, the underlying peptide ratios remain unaffected, which means this method will always return immediately without computing anything.

In ms_ms2quantitation, normalisation constants can most easily be calculated with ms_ms2quantitation::normalisePeptideRatios(), if normalisation is enabled and configured in the quantitation method. You are free to override this, but keeping track of who calculated which constant is up to you.

It is not a good idea to define both peptide ratio normalisation and component intensity normalisation at the same time. In fact, you can only configure one or the other using setQuantNormalisation(), and neither normalisePeptideRatios() nor normaliseIntensities() will step on each other's toes.

It is possible, but not recommended, to manually set normalisation bases for both peptide ratios and component intensities. The resulting peptide ratios are most likely meaningless.

In ms_customquantitation, you can use ms_customquantitation::getUnnormalisedAveragePeptideRatio() to calculate the mean or median of peptide ratios currently stored in the class, for normalisation purposes.

You can always set b to 1 to disable peptide ratio ratioName normalisation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters
ratioName | Peptide ratio name to normalise.
b | New normalisation base. If it is zero, the old base will be kept. If this is the first time the base is set, a value of 0 means it is set to 1.0.

◆ setProteinRatioType()

void setProteinRatioType ( const char * value )
pure virtual

Set the protein ratio type.

Changing the protein ratio type changes the current quantitation method. It does not alter the original quantitation method object.

ms_ms2quantitation supports "median", "average" and "weighted", and ms_customquantitation supports "median" and "average. If the ratio type is not implemented, it is set to "median". <strong>Using the Average protocol in ms_customquantitation</strong>: If quantitation protocol is Average, the only supported protein ratio type is "average". Setting it to anything else will result in an error. You should inspect isValid() and use clearAllErrors() should you accidentally do so.

Parameters
value Protein ratio type (e.g. median, average, weighted). Accepted values are defined in the quantitation XML schema.

Implemented in ms_customquantitation, and ms_ms2quantitation.

◆ setQuantOutliers()

void setQuantOutliers ( const ms_quant_outliers * qo )
pure virtual

Set new peptide ratio outlier settings.

Peptide ratio outlier detection can be configured in several ways. Please consult the quantitation configuration help page for details.

Changing outlier settings changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: It is an error to define outlier removal if quantitation protocol is Average. You will need to inspect isValid() and clear the error with clearAllErrors() should you accidentally do so.

Parameters
qo An outlier configuration object. If this is NULL, outlier detection will be disabled (equivalent to "none").

Implemented in ms_customquantitation, and ms_ms2quantitation.

The documentation for this class was generated from the following files:
  • ms_quantitation.hpp
  • ms_quantitation.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_shapiro_wilk Class Reference

  • matrix_science
  • ms_shapiro_wilk
Public Member Functions | Static Public Member Functions | List of all members
ms_shapiro_wilk Class Reference
Quantitation analysis for Mascot Server and Distiller

The Shapiro-Wilk W test. More...

#include <ms_shapiro_wilk.hpp>

Public Member Functions

ms_shapiro_wilk ()
ms_shapiro_wilk (std::deque< std::pair< size_t, double > > x, long n, long n1, long n2)
The Shapiro-Wilk W test.
void | appendSampleValue (double y)
Add a new sample value to the list to be tested.
void | calculate (long n, long n1, long n2)
Calculate results using values previously added using appendSampleValue().
void | clearSampleValues ()
Clear current vector of X values.
double | getErrorCode () const
Returns the error code for the Shapiro-Wilks W-statistic.
double | getPValue () const
Returns the P-value for the Shapiro-Wilks W-statistic.
double | getResult () const
Returns the Shapiro-Wilks W-statistic.

Static Public Member Functions

static void swilk (bool init, std::deque< std::pair< size_t, double > > x, long n, long n1, long n2, std::deque< double > &a, double &w, double &pw, int &ifault)
AS R94: Calculate the Shapiro-Wilk W test statistic and p-value directly.

Detailed Description

The Shapiro-Wilk W test.

Testing for normality

Testing for outliers and reporting a standard deviation for the protein ratio can only be performed if the peptide ratios are consistent with a sample from a normal distribution (in log space). If the peptide ratios do not appear to be from a normal distribution, this may indicate that the values are meaningless, and something went systematically wrong with the the analysis. On the other hand, it may indicate something interesting, like the peptides have been mis-assigned and actually come from two proteins with very different ratios, so that the distribution is bimodal. Interpretation of test success or failure must be done on a case by case basis.

Shapiro-Wilk W test

In the Shapiro-Wilk W test, the null hypothesis is that the sample is taken from a normal distribution. This hypothesis is rejected if the critical value P for the test statistic W is less than 0.05. The routine used is valid for sample sizes between 3 and 2000.

Source code for the Shapiro-Wilk W test algorithm

References:

  1. Royston, J. P. (1982): An Extension of Shapiro and Wilk's W Test for Normality to Large Samples. Journal of the Royal Statistical Society Series C (Applied Statistics) 31(2):115-124.
  2. Royston, J. P. (1982): Algorithm AS 181: The W Test for Normality. Journal of the Royal Statistical Society Series C (Applied Statistics) 31(2):176-180.
  3. Royston, P. (1995): Remark AS R94: A Remark on Algorithm AS 181: The W-test for Normality. Journal of the Royal Statistical Society Series C (Applied Statistics) 44(4):547-551.
  4. Algorithms AS R94, AS 66 and AS 241 from StatLib: http://lib.stat.cmu.edu/

Constructor & Destructor Documentation

◆ ms_shapiro_wilk() [1/2]

ms_shapiro_wilk ( )

Default constructor.

◆ ms_shapiro_wilk() [2/2]

ms_shapiro_wilk | ( | std::deque< std::pair< size_t, double > > | x,
 |  | long | n,
 |  | long | n1,
 |  | long | n2
 | ) |  |

The Shapiro-Wilk W test.

Note
This constructor can only be called from C++. For other languages, use the appendSampleValue() and calculate() functions.

After calling this constructor, check for any error using getErrorCode() and then check that getPValue() returns a value greater than 0.05 to determine if it is a normal distribution.

Parameters
x | is a list of the sample values in increasing order. The first (optional) item in the pair is typically used for an index. This value is not used by the algorithm, but provided as a convenience. The second item in the pair is the sample value.
n | is the total sample size (including any right-censored values).
n1 | is the number of uncensored cases (n1 <= n).
n2 | is the integer part of n/2.

Member Function Documentation

◆ appendSampleValue()

void appendSampleValue ( double x )

Add a new sample value to the list to be tested.

Add a new sample value to the list to be tested when calling calculate(). Sample values must be added in increasing order.

Parameters
x is the sample value to be added to the list.

◆ calculate()

void calculate | ( | long | n,
 |  | long | n1,
 |  | long | n2
 | ) |  |

Calculate results using values previously added using appendSampleValue().

Calculate results using values previously added using appendSampleValue().

◆ clearSampleValues()

void clearSampleValues ( )

Clear current vector of X values.

If multiple calls to calculate() are to be made for different sample values, then call this function before calling appendSampleValue().

◆ getErrorCode()

double getErrorCode ( ) const

Returns the error code for the Shapiro-Wilks W-statistic.

Possible error codes are:

  • 0 for no error
  • 1 if n1 < 3
  • 2 if n > 5000 (a non-fatal error, but the accuracy of the p-value is not guaranteed in this case)
  • 3 if n2 < n/2
  • 4 if n1 > n or (n1 < n and n < 20).
  • 5 if the proportion censored (n - n1)/n > 0.8.
  • 6 if the data have zero range.
  • 7 if the sample values are not sorted in increasing order
  • 8 if error return from ppnd7 (which should never occur in normal operation)
Returns
error code

◆ swilk()

void swilk | ( | bool | init,
 |  | std::deque< std::pair< size_t, double > > | x,
 |  | long | n,
 |  | long | n1,
 |  | long | n2,
 |  | std::deque< double > & | a,
 |  | double & | w,
 |  | double & | pw,
 |  | int & | ifault
 | ) |  |
static

AS R94: Calculate the Shapiro-Wilk W test statistic and p-value directly.

Translated to C++ from the F77 version of AS R94 in StatLib.

Royston, P. (1995): Remark AS R94: A Remark on Algorithm AS 181: The W-test for Normality. Journal of the Royal Statistical Society Series C (Applied Statistics) 44(4):547-551.

In the F77 version of this function, the w parameter could be used to alter the function's behaviour. That feature has not been retained here.

Parameters
[in] | init | If false, initialise the scratch vector a.
[in] | x | Sample values sorted in increasing order.
[in] | n | Total sample size (usually x.size() cast to long).
[in] | n1 | Sample size less censored cases (n1 <= n; often n1 = x.size()).
[in] | n2 | (long)(n/2)
[in,out] | a | Scratch vector used by the algorithm.
[out] | w | The Shapiro-Wilk W statistic calculated from the data.
[out] | pw | The P-value of the statistic under the null hypothesis.
[out] | ifault | Error code, documented in getErrorCode(). If 0 or 2, then both w and pw were calculated. Otherwise an error occurred.
The documentation for this class was generated from the following files:
  • ms_shapiro_wilk.hpp
  • ms_shapiro_wilk.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_xic Class Reference

  • matrix_science
  • ms_xic
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_xic Class Reference
Quantitation analysis for Mascot Server and Distiller

An eXtracted Ion Chromatogram (XIC). More...

#include <ms_xic.hpp>

Inherits ms_handle.

Public Types

enum peakState {
PEAK_STATE_UNKNOWN = 0 ,
PEAK_STATE_OK = 1 ,
PEAK_STATE_DISCARD =3
}
Status codes from fitting peaks. More...

Public Member Functions

ms_xic ()
Default constructor.
ms_xic (const ms_xic_body &body)
Populated constructor. Performs a deep copy of the passed object.
ms_xic (ms_xic_body *body)
Constructor that use the same pointer as passed.
void | copyFrom (const ms_xic *src)
Perform a deep copy of the contents.
void | defaultValues ()
Use this member to re-initialise internal members.
double | getElutionTimeShift () const
Get the elution time shift in seconds.
int | getEndIndex () const
Get the end index. Only valid if the XIC was processed separately.
int | getEndScanId () const
Get the id of the end scan.
int | getNumPoints () const
Get the number of points.
int | getPeakEndIndex () const
Get the end of the peak. Only valid if the XIC was processed separately.
int | getPeakEndScanId () const
Get the index of the peak end.
int | getPeakStartIndex () const
Get the start of the peak. Only valid if the XIC was processed separately.
int | getPeakStartScanId () const
Get the index of the peak start.
peakState | getPeakState () const
Get the state of the peak.
void | getPoint (int index, double &rt, int &scanId, double &intensity) const
Get a point's values; retention time, scan number and intensity (index 1..n).
int | getRegionEndIndex () const
Get the end of the region. Only valid if the XIC was processed separately.
int | getRegionEndScanId () const
Get the index of the region end.
int | getRegionStartIndex () const
Get the start of the region. Only valid if the XIC was processed separately.
int | getRegionStartScanId () const
Get the index of the region start.
double | getRtPeakEnd () const
Get the retention time of the peak end.
double | getRtPeakStart () const
Get the retention time of the peak start.
double | getRtRegionEnd () const
Get the retention time of the region end.
double | getRtRegionStart () const
Get the retention time of the region start.
int | getStartIndex () const
Get the start index. Only valid if the XIC was processed separately.
int | getStartScanId () const
Get the id of the start scan.
bool | getUseTimeShift () const
Returns true if XIC are aligned based on time instead of scans.
bool | hasIndexes () const
Return true if the functions that return indexes have valid data available to return.

Static Public Member Functions

static peakState | getCodeFromXml (std::string text)
Get the status code for an XML attribute value.
static std::string | getXmlCode (peakState code)
Get the XML attribute value for a status code.

Detailed Description

An eXtracted Ion Chromatogram (XIC).

This consists of a number of individual intensity values.

It also has start and end values and indices for the peaks, regions and the chromatogram itself

This is stored in XML in a "xic" entity.

Member Enumeration Documentation

◆ peakState

enum peakState

Status codes from fitting peaks.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
PEAK_STATE_UNKNOWN | initial value
PEAK_STATE_OK | element is ok
PEAK_STATE_DISCARD | discard element from calc

Constructor & Destructor Documentation

◆ ms_xic() [1/3]

ms_xic ( )

Default constructor.

Assigns reasonable default values to all internal members.

◆ ms_xic() [2/3]

ms_xic ( const ms_xic_body & body )
explicit

Populated constructor. Performs a deep copy of the passed object.

Parameters
body The data loaded from the result file.

◆ ms_xic() [3/3]

ms_xic ( ms_xic_body * body )
explicit

Constructor that use the same pointer as passed.

Parameters
body Is a pointer to existing data. The reference count for this will be incremented by this call.

Member Function Documentation

◆ defaultValues()

void defaultValues ( )

Use this member to re-initialise internal members.

Clears all values

◆ getCodeFromXml()

ms_xic::peakState getCodeFromXml ( std::string text )
static

Get the status code for an XML attribute value.

Parameters
text The string used to encode the peak state in the XML file.
Returns
The peak state corresponding to the XML encoded string.

◆ getElutionTimeShift()

double getElutionTimeShift ( ) const

Get the elution time shift in seconds.

Returns
The value of the elution time shift.

◆ getEndIndex()

int getEndIndex ( ) const

Get the end index. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is typically a zero based index of MS1 scans (either Survey or zoom) that have been 'filtered out' from all scan types

Returns
Index at which the the XIC ends.

◆ getEndScanId()

int getEndScanId ( ) const

Get the id of the end scan.

Returns
The scan identifier at which the XIC ends.

◆ getNumPoints()

int getNumPoints ( ) const

Get the number of points.

Returns
The number of points in the XIC.

◆ getPeakEndIndex()

int getPeakEndIndex ( ) const

Get the end of the peak. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is a zero based index into the points array and should be 0..getNumPoints()

Returns
Index at which the peak ends.

◆ getPeakEndScanId()

int getPeakEndScanId ( ) const

Get the index of the peak end.

Returns
The scan identifier at which the peak ends.

◆ getPeakStartIndex()

int getPeakStartIndex ( ) const

Get the start of the peak. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is a zero based index into the points array and should be 0..getNumPoints()

Returns
Index at which the peak starts.

◆ getPeakStartScanId()

int getPeakStartScanId ( ) const

Get the index of the peak start.

Returns
The scan identifier at which the peak starts.

◆ getPeakState()

ms_xic::peakState getPeakState ( ) const

Get the state of the peak.

Returns
The peak state.

◆ getPoint()

void getPoint | ( | int | index,
 |  | double & | rt,
 |  | int & | scanId,
 |  | double & | intensity
 | ) |  | const

Get a point's values; retention time, scan number and intensity (index 1..n).

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | index | The index of the point to be queried (1..number of points).
[out] | rt | Filled with the retention time of the point.
[out] | scanId | Filled with the scan identifier of the point.
[out] | intensity | Filled with the intensity of the point.

◆ getRegionEndIndex()

int getRegionEndIndex ( ) const

Get the end of the region. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is a zero based index into the points array and should be 0..getNumPoints()

Returns
Index at which the region ends.

◆ getRegionEndScanId()

int getRegionEndScanId ( ) const

Get the index of the region end.

Returns
The scan identifier at which the region ends.

◆ getRegionStartIndex()

int getRegionStartIndex ( ) const

Get the start of the region. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is a zero based index into the points array and should be 0..getNumPoints()

Returns
Index at which the region starts.

◆ getRegionStartScanId()

int getRegionStartScanId ( ) const

Get the index of the region start.

Returns
The scan identifier at which the region starts.

◆ getRtPeakEnd()

double getRtPeakEnd ( ) const

Get the retention time of the peak end.

Returns
The retention time of the peak end.

◆ getRtPeakStart()

double getRtPeakStart ( ) const

Get the retention time of the peak start.

Returns
The retention time of the peak start.

◆ getRtRegionEnd()

double getRtRegionEnd ( ) const

Get the retention time of the region end.

Returns
The retention time of the region end.

◆ getRtRegionStart()

double getRtRegionStart ( ) const

Get the retention time of the region start.

Returns
The retention time of the region start.

◆ getStartIndex()

int getStartIndex ( ) const

Get the start index. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is typically a zero based index of MS1 scans (either Survey or zoom) that have been 'filtered out' from all scan types

Returns
Index at which the the XIC starts.

◆ getStartScanId()

int getStartScanId ( ) const

Get the id of the start scan.

Returns
The scan identifier at which the XIC starts.

◆ getUseTimeShift()

bool getUseTimeShift ( ) const

Returns true if XIC are aligned based on time instead of scans.

Returns
True if the elution time shift should be used.

◆ getXmlCode()

std::string getXmlCode ( ms_xic::peakState code )
static

Get the XML attribute value for a status code.

Parameters
code The peak state to get the XML excoding string for.
Returns
The string used to encode the peak state in the XML file.

◆ hasIndexes()

bool hasIndexes ( ) const

Return true if the functions that return indexes have valid data available to return.

XML version 1 does not store this information and considerable recalculate would be required to reproduce it. And it's optional in the XML anyway.

Returns
True if the XIC has all the index information, otherwise false.
The documentation for this class was generated from the following files:
  • ms_xic.hpp
  • ms_xic.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_xic_point Class Reference

  • matrix_science
  • ms_xic_point
List of all members
ms_xic_point Class Reference
Quantitation analysis for Mascot Server and Distiller

A single point from a matrix_science::ms_xic object. More...

#include <ms_xic.hpp>

Detailed Description

A single point from a matrix_science::ms_xic object.

Contains, the retention time, scanId and intensity

The documentation for this class was generated from the following files:
  • ms_xic.hpp
  • ms_xic.cpp
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Classes for calculating masses of peptides and fragments.

Modules | Classes
Classes for calculating masses of peptides and fragments.

Modules

Examples for the mass calculation module

Classes

class | ms_aahelper
This class facilitates creation of peptides and calculation of MS-fragment masses. More...
class | ms_fragment
Class representing a single peptide fragment. More...
class | ms_fragmentvector
Class for holding a list of ms_fragment objects. More...

Detailed Description

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Examples for the mass calculation module

Examples for the mass calculation module
Classes for calculating masses of peptides and fragments.

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
For calculating peptide and fragment masses | tools_aahelper.pl | tools_aahelper.cpp | tools_aahelper.java | tools_aahelper.py | tools_aahelper.cs
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_aahelper Class Reference

  • matrix_science
  • ms_aahelper
Public Types | Public Member Functions | List of all members
ms_aahelper Class Reference
Classes for calculating masses of peptides and fragments.

This class facilitates creation of peptides and calculation of MS-fragment masses. More...

#include <ms_aahelper.hpp>

Inheritance diagram for ms_aahelper:
[legend]
Collaboration diagram for ms_aahelper:
[legend]

Public Types

enum FRAG_NL {
FRAG_NL_PRIMARY = 0x0001 ,
FRAG_NL_SECONDARY = 0x0010
}
Flag for controlling iteration over multiple neutral losses. More...

Public Member Functions

ms_aahelper ()
Default constructor.
ms_aahelper (const ms_aahelper &right)
Copying constructor.
ms_aahelper (const ms_mascotresfilebase &resfile, const char *enzymeFileName, const char *quantSchemaFilePath="http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd", const char *unimodSchemaFilePath="http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd")
Constructor from results file.
ms_aahelper (const ms_mascotresults &summary, const char *enzymeFileName, const char *quantSchemaFilePath="http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd", const char *unimodSchemaFilePath="http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd")
Constructor from peptide summary or protein summary.
~ms_aahelper ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
std::vector< double > | calcFragments (const ms_peptide *peptide, const int seriesID, const bool doubleCharged, const double minMass, const double maxMass, const MASS_TYPE massType, ms_fragmentvector *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const
Returns a vector of ion masses for the given series and peptide.
std::vector< double > | calcFragments (const ms_peptide *peptide, const int seriesID, const bool doubleCharged, const double minMass, const double maxMass, const MASS_TYPE massType, std::vector< ms_fragment > *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const
Returns a vector of ion masses for the given series and peptide.
bool | calcFragmentsEx (const ms_peptide *peptide, const int seriesID, const int fragCharge, const double minMass, const double maxMass, const MASS_TYPE massType, ms_fragmentvector *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const
Returns a vector of ion masses for the given series and peptide.
bool | calcFragmentsEx (const ms_peptide *peptide, const int seriesID, const int fragCharge, const double minMass, const double maxMass, const MASS_TYPE massType, std::vector< ms_fragment > *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const
Returns a vector of ion masses for the given series and peptide.
double | calcPeptideMZ (const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > numThatMustBeModded, const int charge, const MASS_TYPE massType, ms_errs *err) const
Calculates and returns a peptide m/z (or Mr) value without specifying exact positions of modified residues.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_aahelper *right)
Copies all data from another instance of the class.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
ms_peptide | createCrosslinkedPeptide (const ms_peptide &pepAlpha, const ms_peptide &pepBeta, const ms_linker_site_vector &linkedSites, ms_errs *err) const
Creates and returns a crosslinked peptide object.
ms_peptide | createPeptide (const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > varMods, const std::vector< int > varModsWhichNl, const int charge, const MASS_TYPE massType, ms_errs *err) const
Creates and returns a peptide object.
ms_peptide | createPeptide (const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > varMods, const std::vector< int > varModsWhichNl, const std::vector< int > summedMods, const std::vector< int > summedModsWhichNl, const int charge, const MASS_TYPE massType, ms_errs *err) const
Creates and returns a peptide object.
void | defaultValues ()
Initialises the instance.
const ms_enzyme * | getEnzyme () const
Returns a pointer to the current enzyme.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
ms_modvector | getFixedMods () const
Returns a list of fixed modifications that have been successfully applied i.e. don't have conflicts.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
const ms_masses * | getMasses () const
Returns a pointer to the internal copy of the masses file.
int | getMissed () const
Returns number of missed cleavage sites for the current peptide.
bool | getNextPeptide ()
Call to iterate to the next peptide.
int | getPepEnd () const
Returns the last position of the current peptide.
int | getPepStart () const
Returns the first position of the current peptide.
ms_modvector | getVarMods () const
Returns a list of variable modifications that have no conflicts with fixed modifications.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_aahelper & | operator= (const ms_aahelper &right)
Assignment operator.
void | setAvailableModifications (const ms_modvector *fixedModVector, const ms_modvector *varModVector)
Applies fixed modifications to residue masses and stores variable modifications for later use.
void | setEnzyme (const ms_enzyme *enzyme)
Sets an enzyme to use.
void | setMasses (const ms_masses *masses)
Copies all residue and chemical element masses from the masses file instance.
void | startIteratePeptides (const char *sequenceProtein, const int sizeProtein, const int pfa)
Initialises internal members in preparation for generating peptides.
void | stopIteratePeptides ()
Stop iterating.

Detailed Description

This class facilitates creation of peptides and calculation of MS-fragment masses.

Examples
tools_aahelper.cpp.

Member Enumeration Documentation

◆ FRAG_NL

enum FRAG_NL

Flag for controlling iteration over multiple neutral losses.

If any modification has multiple neutral losses, ms_aahelper::calcFragments() and ms_aahelper::calcFragmentsEx() default to calculating fragments for the primary neutral loss. The primary NL choice is encoded in the peptide's neutral loss string (ms_peptide::getPrimaryNlStr()) – or strings if the peptide has some combination of variable mods, summed mods, ET mods or local mods.

Enumerator
FRAG_NL_PRIMARY | Calculate fragments for primary neutral loss.
FRAG_NL_SECONDARY | Calculate fragments for non-primary neutral losses.

Constructor & Destructor Documentation

◆ ms_aahelper() [1/2]

ms_aahelper | ( | const ms_mascotresfilebase & | resfile,
 |  | const char * | enzymeFileName,
 |  | const char * | quantSchemaFilePath = "http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd",
 |  | const char * | unimodSchemaFilePath = "http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd"
 | ) |  |

Constructor from results file.

This constructor extracts the enzyme information if available from the passed results file object. The masses information is loaded from the file using the matrix_science::ms_mascotresfilebase::getMasses() function. The modifications are read from the results file and added using setAvailableModifications().

Results files prior to Mascot 2.2 did not include specificity information. If the enzyme definition is not in the results file, the function attempts to load the enzymes file and find the correct enzyme defintion. It then calls the setEnzyme() function. Also, the modification information in the results file doesn't record specificities unambiguously, so these are derived when calcFragmentsEx() or similar are called.

The application should call isValid() after creating the object. If isValid() returns false, error messages are available, see Error Handling

Parameters
resfile | needs to be a valid resfile object.
enzymeFileName | will only be used for Mascot results files from versions prior to Mascot 2.2 which don't have the specificities in the results file.
quantSchemaFilePath is required for when the results file contains a quantitation method that needs to be loaded and validated against a schema. There are three possible values for this function:
  • NULL or 0 - In this case, the schema directory must have been specified using the XMLschemaDirectory parameter in the ms_mascotresfilebase constructor. This is the easiest method to use, and is the preferred parameter for Mascot Parser 2.5 and later.
  • If not specified, the default is suitable for when Parser is being used on a Mascot Server.
  • Explicitly passing a string in the appropriate format. This is passed to ms_quant_configfile::setSchemaFileName before calling ms_mascotresfilebase::getQuantitation(). When using this function on a system where Mascot Server is not installed, it will be necessary to supply the xsd files. The quantitation_1.xsd and quantitation_2.xsd files are supplied with Mascot Parser and will need to be installed with any application that uses this function in Mascot Parser. The format of the string should be the same as the default parameter, just replace the paths for the .xsd files with the path of the installed xsd fils.
unimodSchemaFilePath is required for results files from Mascot 2.2 and later where the modification information is in the results file in XML format and needs a schema for validation. There are three possible values for this function:
  • NULL or 0 - In this case, the schema directory must have been specified using the XMLschemaDirectory parameter in the ms_mascotresfilebase constructor. This is the easiest method to use, and is the preferred parameter for Mascot Parser 2.5 and later.
  • If not specified, the default is suitable for when Parser is being used on a Mascot Server.
  • Explicitly passing a string in the appropriate format. This is passed to ms_umod_configfile::setSchemaFileName before calling: ms_mascotresfilebase::getUnimod(). When using this function on a system where Mascot Server is not installed, it will be necessary to supply the xsd file. The unimod_2.xsd file is supplied with Mascot Parser and will need to be installed with any application that uses this function in Mascot Parser. The format of the string should be the same as the default parameter, just replace the path for the .xsd with the path of the installed unimod_2.xsd file.

◆ ms_aahelper() [2/2]

ms_aahelper | ( | const ms_mascotresults & | summary,
 |  | const char * | enzymeFileName,
 |  | const char * | quantSchemaFilePath = "http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd",
 |  | const char * | unimodSchemaFilePath = "http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd"
 | ) |  |

Constructor from peptide summary or protein summary.

This constructor is similar to ms_aahelper(const ms_mascotresfilebase&, const char*, const char*, const char*), but additionally allows ms_aahelper::calcFragmentsEx() to look up error tolerant modifications and spectral library modifications from the results file.

The constructor extracts the enzyme information if available from the passed results file object. The masses information is loaded from the file using the matrix_science::ms_mascotresfilebase::getMasses() function. The modifications are read from the results file and added using setAvailableModifications().

Results files prior to Mascot 2.2 did not include specificity information. If the enzyme definition is not in the results file, the function attempts to load the enzymes file and find the correct enzyme defintion. It then calls the setEnzyme() function. Also, the modification information in the results file doesn't record specificities unambiguously, so these are derived when calcFragmentsEx() or similar are called.

The application should call isValid() after creating the object. If isValid() returns false, error messages are available, see Error Handling

Parameters
summary | needs to be a valid ms_mascotresults object, either ms_peptidesummary or ms_proteinsummary.
enzymeFileName | will only be used for Mascot results files from versions prior to Mascot 2.2 which don't have the specificities in the results file.
quantSchemaFilePath is required for when the results file contains a quantitation method that needs to be loaded and validated against a schema. There are three possible values for this function:
  • NULL or 0 - In this case, the schema directory must have been specified using the XMLschemaDirectory parameter in the ms_mascotresfilebase constructor. This is the easiest method to use, and is the preferred parameter for Mascot Parser 2.5 and later.
  • If not specified, the default is suitable for when Parser is being used on a Mascot Server.
  • Explicitly passing a string in the appropriate format. This is passed to ms_quant_configfile::setSchemaFileName before calling ms_mascotresfilebase::getQuantitation(). When using this function on a system where Mascot Server is not installed, it will be necessary to supply the xsd files. The quantitation_1.xsd and quantitation_2.xsd files are supplied with Mascot Parser and will need to be installed with any application that uses this function in Mascot Parser. The format of the string should be the same as the default parameter, just replace the paths for the .xsd files with the path of the installed xsd fils.
unimodSchemaFilePath is required for results files from Mascot 2.2 and later where the modification information is in the results file in XML format and needs a schema for validation. There are three possible values for this function:
  • NULL or 0 - In this case, the schema directory must have been specified using the XMLschemaDirectory parameter in the ms_mascotresfilebase constructor. This is the easiest method to use, and is the preferred parameter for Mascot Parser 2.5 and later.
  • If not specified, the default is suitable for when Parser is being used on a Mascot Server.
  • Explicitly passing a string in the appropriate format. This is passed to ms_umod_configfile::setSchemaFileName before calling: ms_mascotresfilebase::getUnimod(). When using this function on a system where Mascot Server is not installed, it will be necessary to supply the xsd file. The unimod_2.xsd file is supplied with Mascot Parser and will need to be installed with any application that uses this function in Mascot Parser. The format of the string should be the same as the default parameter, just replace the path for the .xsd with the path of the installed unimod_2.xsd file.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ calcFragments() [1/2]

std::vector< double > calcFragments | ( | const ms_peptide * | peptide,
 |  | const int | seriesID,
 |  | const bool | doubleCharged,
 |  | const double | minMass,
 |  | const double | maxMass,
 |  | const MASS_TYPE | massType,
 |  | ms_fragmentvector * | fragments,
 |  | ms_errs * | err,
 |  | const FRAG_NL | fragNlType = FRAG_NL_PRIMARY
 | ) |  | const

Returns a vector of ion masses for the given series and peptide.

For 'regular' sequence type ions, the final fragment mass (approximately the peptide mass less the terminus) will not be returned.

Note that this method does not take the peptide object's seriesUsedStr into account (see ms_peptide::getSeriesUsedStr()). The rules in Mascot state that fragments for neutral loss series (A_MINUS_NH3, A_MINUS_H2O, and corresponding series for B and Y) should only be generated if the peptide match has a statistically significant number of matches to the corresponding singly charged parent ion series (e.g. A_MINUS_NH3 requires enough matches to singly charged A series fragments). You can take this into account by testing whether seriesUsedStr contains 1 or 2 for the singly charged parent ion series. See ms_peptide::getSeriesUsedStr().

Parameters
peptide | peptide object to generate ion masses for.
seriesID | series number from ms_fragmentationrules::FRAG_SERIES_TYPE.
doubleCharged | some ion series allow double charged fragment; supply TRUE if you want to get mass over charge values for double charged ions only. Otherwise single charged ions will be generated. If the given series doesn't allow double charged ions then an empty list will be returned and err will reflect the inconsistency.
minMass | minimal possible mass value to return.
maxMass | maximal possible mass value to return.
massType | Specify matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
fragments | a vector of items with more detailed information about each peptide fragment. Any existing items in the fragment vector will be overwritten by this function.
err | error object that accumulates messages without affecting the object validity.
fragNlType | (optional) Either ms_aahelper::FRAG_NL_PRIMARY or ms_aahelper::FRAG_NL_SECONDARY. Default is FRAG_NL_PRIMARY.
Returns
A vector of ions masses. Use of the return value is deprecated.
Examples
tools_aahelper.cpp.

◆ calcFragments() [2/2]

std::vector< double > calcFragments | ( | const ms_peptide * | peptide,
 |  | const int | seriesID,
 |  | const bool | doubleCharged,
 |  | const double | minMass,
 |  | const double | maxMass,
 |  | const MASS_TYPE | massType,
 |  | std::vector< ms_fragment > * | fragments,
 |  | ms_errs * | err,
 |  | const FRAG_NL | fragNlType = FRAG_NL_PRIMARY
 | ) |  | const

Returns a vector of ion masses for the given series and peptide.

Note
This method can only be used in C++. Use the other calcFragments() method from other programming languages.

For 'regular' sequence type ions, the final fragment mass (approximately the peptide mass less the terminus) will not be returned.

Note that this method does not take the peptide object's seriesUsedStr into account (see ms_peptide::getSeriesUsedStr()). The rules in Mascot state that fragments for neutral loss series (A_MINUS_NH3, A_MINUS_H2O, and corresponding series for B and Y) should only be generated if the peptide match has a statistically significant number of matches to the corresponding singly charged parent ion series (e.g. A_MINUS_NH3 requires enough matches to singly charged A series fragments). You can take this into account by testing whether seriesUsedStr contains 1 or 2 for the singly charged parent ion series. See ms_peptide::getSeriesUsedStr().

Parameters
peptide | peptide object to generate ion masses for.
seriesID | series number from ms_fragmentationrules::FRAG_SERIES_TYPE.
doubleCharged | some ion series allow double charged fragment; supply TRUE if you want to get mass over charge values for double charged ions only. Otherwise single charged ions will be generated. If the given series doesn't allow double charged ions then an empty list will be returned and err will reflect the inconsistency.
minMass | minimal possible mass value to return.
maxMass | maximal possible mass value to return.
massType | Specify matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
fragments | a vector of items with more detailed information about each peptide fragment. Any existing items in the fragment vector will be overwritten by this function.
err | error object that accumulates messages without affecting the object validity.
fragNlType | (optional) Either ms_aahelper::FRAG_NL_PRIMARY or ms_aahelper::FRAG_NL_SECONDARY. Default is FRAG_NL_PRIMARY.
Returns
A vector of ions masses. Use of the return value is deprecated.

◆ calcFragmentsEx() [1/2]

bool calcFragmentsEx | ( | const ms_peptide * | peptide,
 |  | const int | seriesID,
 |  | const int | fragCharge,
 |  | const double | minMass,
 |  | const double | maxMass,
 |  | const MASS_TYPE | massType,
 |  | ms_fragmentvector * | fragments,
 |  | ms_errs * | err,
 |  | const FRAG_NL | fragNlType = FRAG_NL_PRIMARY
 | ) |  | const

Returns a vector of ion masses for the given series and peptide.

The difference to calcFragments() is that you can specify explicitly what charge state should all the generated fragments be. The charge state of the peptide-object is ignored then completely. When you need to obtain fragment m/z values for several different charge states just call this method several times and merge the results. For 'regular' sequence type ions, the final fragment mass (approximately the peptide mass less the terminus) will not be returned.

Note that this method does not take the peptide object's seriesUsedStr into account (see ms_peptide::getSeriesUsedStr()). The rules in Mascot state that fragments for neutral loss series (A_MINUS_NH3, A_MINUS_H2O, and corresponding series for B and Y) should only be generated if the peptide match has a statistically significant number of matches to the corresponding singly charged parent ion series (e.g. A_MINUS_NH3 requires enough matches to singly charged A series fragments). You can take this into account by testing whether seriesUsedStr contains 1 or 2 for the singly charged parent ion series. See ms_peptide::getSeriesUsedStr().

Parameters
peptide | peptide object to generate ion masses for.
seriesID | series number from: ms_fragmentationrules::FRAG_SERIES_TYPE.
fragCharge | explicit charge state of the fragments being generated (peptide charge is ignored), zero value for this parameter means "Mr".
minMass | minimal possible mass value to return.
maxMass | maximal possible mass value to return.
massType | Specify matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
fragments | a vector of items with more detailed information about each peptide fragment. Any items in the fragment vector are overwritten by this function.
err | error object that accumulates messages without affecting the object validity.
fragNlType | (optional) Either ms_aahelper::FRAG_NL_PRIMARY or ms_aahelper::FRAG_NL_SECONDARY. Default is FRAG_NL_PRIMARY.
Returns
TRUE if succeeded, FALSE if there are any errors.
Examples
tools_aahelper.cpp.

◆ calcFragmentsEx() [2/2]

bool calcFragmentsEx | ( | const ms_peptide * | peptide,
 |  | const int | seriesID,
 |  | const int | fragCharge,
 |  | const double | minMass,
 |  | const double | maxMass,
 |  | const MASS_TYPE | massType,
 |  | std::vector< ms_fragment > * | fragments,
 |  | ms_errs * | err,
 |  | const FRAG_NL | fragNlType = FRAG_NL_PRIMARY
 | ) |  | const

Returns a vector of ion masses for the given series and peptide.

Note
This method can only be used in C++. Use the other calcFragmentsEx() method from other programming languages.

The difference to calcFragments() is that you can specify explicitly what charge state should all the generated fragments be. The charge state of the peptide-object is ignored then completely. When you need to obtain fragment m/z values for several different charge states just call this method several times and merge the results. For 'regular' sequence type ions, the final fragment mass (approximately the peptide mass less the terminus) will not be returned.

Note that this method does not take the peptide object's seriesUsedStr into account (see ms_peptide::getSeriesUsedStr()). The rules in Mascot state that fragments for neutral loss series (A_MINUS_NH3, A_MINUS_H2O, and corresponding series for B and Y) should only be generated if the peptide match has a statistically significant number of matches to the corresponding singly charged parent ion series (e.g. A_MINUS_NH3 requires enough matches to singly charged A series fragments). You can take this into account by testing whether seriesUsedStr contains 1 or 2 for the singly charged parent ion series. See ms_peptide::getSeriesUsedStr().

Parameters
peptide | peptide object to generate ion masses for.
seriesID | series number from: ms_fragmentationrules::FRAG_SERIES_TYPE.
fragCharge | explicit charge state of the fragments being generated (peptide charge is ignored), zero value for this parameter means "Mr".
minMass | minimal possible mass value to return.
maxMass | maximal possible mass value to return.
massType | Specify matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
fragments | a vector of items with more detailed information about each peptide fragment. Any items in the fragment vector are overwritten by this function.
err | error object that accumulates messages without affecting the object validity.
fragNlType | (optional) Either ms_aahelper::FRAG_NL_PRIMARY or ms_aahelper::FRAG_NL_SECONDARY. Default is FRAG_NL_PRIMARY.
Returns
TRUE if succeeded, FALSE if there are any errors.

◆ calcPeptideMZ()

double calcPeptideMZ | ( | const char * | proteinStr,
 |  | const int | proteinLen,
 |  | const int | startPos,
 |  | const int | endPos,
 |  | const std::vector< int > | numThatMustBeModded,
 |  | const int | charge,
 |  | const MASS_TYPE | massType,
 |  | ms_errs * | err
 | ) |  | const

Calculates and returns a peptide m/z (or Mr) value without specifying exact positions of modified residues.

This method can be called when only minimal (e.g. PMF search) information is available:

  • Terminus positions.
  • Fixed mods.
  • Number of modified residues , but not modified positions.

Before calling this function, call setAvailableModifications() to set up any modifications.

This function does not currently support Multiple modifications for the same site

numThatMustBeModded is a vector of integers. Each element of the vector corresponds to a variable modification. The first element corresponds to the first variable modification pushed onto the vector. So, pushing three values, 3,0,2 onto the vector would specify that 3 residues are modified by the first variable mod, and 2 residues are modified by the third variable mod. The size of this vector can be less than the number of available variable modifications - missing elements are assumed to be zeros.

The err object should be checked after calling this function to see if there are inconsistencies.

Parameters
proteinStr | a protein sequence string. C++: it does not need to be null terminated.
proteinLen | protein sequence length.
startPos | the first peptide position. Specify 1 for the peptide to start at the first amino acid.
endPos | the last peptide position. For example, startPos=1 and endPos=3 would give a peptide 3 residues long.
numThatMustBeModded | is a vector of integers. See above, and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
charge | 0 for de-charged mass, n for n-charged peptides.
massType | should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
err | error object that accumulates messages without affecting the object validity
Returns
The peptide m/z. If the charge specified was zero, then the relative mass (Mr) value will be returned.
Examples
tools_aahelper.cpp.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ createCrosslinkedPeptide()

ms_peptide createCrosslinkedPeptide | ( | const ms_peptide & | pepAlpha,
 |  | const ms_peptide & | pepBeta,
 |  | const ms_linker_site_vector & | linkedSites,
 |  | ms_errs * | err
 | ) |  | const

Creates and returns a crosslinked peptide object.

The following conditions are checked. If any one is not satisfied, the method sets a corresponding error and returns an "empty" ms_peptide object.

  • pepAlpha must be a valid linear peptide (not crosslinked).
  • pepBeta must be a valid linear peptide (not crosslinked).
  • pepAlpha must not have a variable modification at the linker site.
  • pepBeta must not have a variable modification at the linker site.
  • linkedSites must contain exactly 1 element.
  • The linker site in alpha must be within the range 0..n, where n is the length of alpha's variable mods string.
  • The linker site in beta must be within the range 0..m, where m is the length of beta's variable mods string.

Standard terminology recommends that alpha should be the longer or heavier molecule than beta, but there is no check for this.

Linker mass can be positive, zero or negative, although typically it is positive.

Parameters
pepAlpha | is the alpha peptide.
pepBeta | is the beta peptide.
linkedSites | is the vector of links between alpha and beta.
err | is an error object that accumulates messages without affecting the object validity.
Returns
a crosslinked alpha-beta peptide.

◆ createPeptide() [1/2]

ms_peptide createPeptide | ( | const char * | proteinStr,
 |  | const int | proteinLen,
 |  | const int | startPos,
 |  | const int | endPos,
 |  | const std::vector< int > | varMods,
 |  | const std::vector< int > | varModsWhichNl,
 |  | const int | charge,
 |  | const MASS_TYPE | massType,
 |  | ms_errs * | err
 | ) |  | const

Creates and returns a peptide object.

This method can be called if full peptide information is available. It creates and returns a peptide object instance that can then be passed to the calcFragments() method. Only available modifications will be applied

varMods is a vector of integers. It has the same content as modification strings in result files. The first element specifies how N-terminus of the peptide is modified. The next one corresponds to the first residue in the peptide etc. The last element refers to the C-terminus. Each element contain either '0' for non-modified positions or a variable modification number to apply. The size of this vector can also be less than (peptide length + 2) – missing elements are assumed to be zeros.

varModsWhichNl is also a vector of integers. There is one entry in the vector for each terminus and each residue. For a residue not modified by a modification with neutral loss(es), the value should be zero. For a site modified by a modification with neutral loss(es), a one-based index of neutral loss value to use for this peptide should be supplied. If a value of 0 is specified for a modification with a neutral loss, then the first neutral loss is assumed.

The err object should be checked after calling this function to see if there are inconsistencies.

See also
getVarMods(), setAvailableModifications()
Parameters
proteinStr | a protein sequence string. C++: it does not need to be null-terminated.
proteinLen | protein sequence length .
startPos | the first peptide position. Specify 1 for the peptide to start at the first amino acid.
endPos | the last peptide position. For example, startPos=1 and endPos=3 would give a peptide 3 residues long.
varMods | is a vector of modified positions. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
varModsWhichNl | is a similar vector to varMods. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
charge | charge state of the peptide.
massType | should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
err | error object that accumulates messages without affecting the object validity
Returns
An ms_peptide object that can be used with calcFragments().
Examples
tools_aahelper.cpp.

◆ createPeptide() [2/2]

ms_peptide createPeptide | ( | const char * | proteinStr,
 |  | const int | proteinLen,
 |  | const int | startPos,
 |  | const int | endPos,
 |  | const std::vector< int > | varMods,
 |  | const std::vector< int > | varModsWhichNl,
 |  | const std::vector< int > | summedMods,
 |  | const std::vector< int > | summedModsWhichNl,
 |  | const int | charge,
 |  | const MASS_TYPE | massType,
 |  | ms_errs * | err
 | ) |  | const

Creates and returns a peptide object.

This method can be called if full peptide information is available. It creates and returns a peptide object instance that can then be passed to the calcFragments() method. Only available modifications will be applied

varMods is a vector of integers. It has the same content as modification strings in result files. The first element specifies how N-terminus of the peptide is modified. The next one corresponds to the first residue in the peptide etc. The last element refers to the C-terminus. Each element contain either '0' for non-modified positions or a variable modification number to apply. The size of this vector can also be less than (peptide length + 2) – missing elements are assumed to be zeros.

varModsWhichNl is also a vector of integers. There is one entry in the vector for each terminus and each residue. For a residue not modified by a modification with neutral loss(es), the value should be zero. For a site modified by a modification with neutral loss(es), a one-based index of neutral loss value to use for this peptide should be supplied. If a value of 0 is specified for a modification with a neutral loss, then the first neutral loss is assumed.

summedMods and summedModsWhichNl are identical to varMods and varModsWhichNl except that they apply to Multiple modifications for the same site

The err object should be checked after calling this function to see if there are inconsistencies.

See also
getVarMods(), setAvailableModifications()
Parameters
proteinStr | a protein sequence string. C++: it does not need to be null-terminated.
proteinLen | protein sequence length .
startPos | the first peptide position. Specify 1 for the peptide to start at the first amino acid.
endPos | the last peptide position. For example, startPos=1 and endPos=3 would give a peptide 3 residues long.
varMods | is a vector of modified positions. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
varModsWhichNl | is a similar vector to varMods. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
summedMods | is a vector of modified positions. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
summedModsWhichNl | is a similar vector to varMods. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
charge | charge state of the peptide.
massType | should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
err | error object that accumulates messages without affecting the object validity
Returns
An ms_peptide object that can be used with calcFragments().

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getFixedMods()

ms_modvector getFixedMods ( ) const

Returns a list of fixed modifications that have been successfully applied i.e. don't have conflicts.

Every member of the vector returned is a non-empty modification object. All conflicting modifications have been rejected.

Returns
Vector of the fixed modifications

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getMissed()

int getMissed ( ) const

Returns number of missed cleavage sites for the current peptide.

This will return 0 if getNextPeptide() returned false or if stopIteratePeptides() has been called.

Returns
Number of missed cleavages in the current peptide

◆ getNextPeptide()

bool getNextPeptide ( )

Call to iterate to the next peptide.

Finds a new unique peptide. Call getPepStart() and getPepEnd() to get the new peptide start and end positions.

Returns
TRUE if successful and FALSE otherwise (e.g. when no more peptides are available).
Examples
tools_aahelper.cpp.

◆ getPepEnd()

int getPepEnd ( ) const

Returns the last position of the current peptide.

This will return -1 if getNextPeptide() returned false or if stopIteratePeptides() has been called.

Returns
Last position of the current peptide
Examples
tools_aahelper.cpp.

◆ getPepStart()

int getPepStart ( ) const

Returns the first position of the current peptide.

This will return -1 if getNextPeptide() returned false or if stopIteratePeptides() has been called.

Returns
First position of the current peptide
Examples
tools_aahelper.cpp.

◆ getVarMods()

ms_modvector getVarMods ( ) const

Returns a list of variable modifications that have no conflicts with fixed modifications.

The vector returned contains null pointers in place of conflicting modifications. The reason for that is to keep the original order of modifications.

Returns
Vector of the variable modifications

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ setAvailableModifications()

void setAvailableModifications | ( | const ms_modvector * | fixedModVector,
 |  | const ms_modvector * | varModVector
 | ) |  |

Applies fixed modifications to residue masses and stores variable modifications for later use.

The object should be checked for validity after calling this method.

No checking for overlapping modifications is performed.

It is important to remember the order of modifications submitted here as all future calcPeptideMZ(), createPeptide() and calcFragments() method calls will refer to this original order. The modifications are numbered from 1 to n.

There is no need to call this function if an ms_mascotresfilebase object is passed to the relevant ms_aahelper constructor. When that constructor is called, the mapping of the numbers is exactly as in the deltaX lines of the masses section in the results file. To retrieve the relevant names, use ms_searchparams::getVarModsName() with num=X. The numbers in the strings returned from ms_peptide::getVarModsStr() then correspond to the modification numbers supplied to this function.

If a fixed modification and a variable modification are applied to the same residue or terminus, then the fixed modification is substituted with the variable modification.

Parameters
fixedModVector | A valid pointer to a vector of fixed modifications
varModVector | A valid pointer to a vector of variable modifications
See also
getFixedMods(), getVarMods()
Examples
tools_aahelper.cpp.

◆ setMasses()

void setMasses ( const ms_masses * masses )

Copies all residue and chemical element masses from the masses file instance.

An ms_umod_configfile object can also be used as a source of masses. In that case call the corresponding method ms_masses::copyFrom() and supply an ms_umod_configfile instance as a parameter.

Parameters
masses A valid pointer to an ms_masses object
Examples
tools_aahelper.cpp.

◆ startIteratePeptides()

void startIteratePeptides | ( | const char * | sequenceProtein,
 |  | const int | sizeProtein,
 |  | const int | pfa
 | ) |  |

Initialises internal members in preparation for generating peptides.

The first peptide ends are not available after calling this method. You have to call getNextPeptide() and check its returned value before calling getPepStart(), getPepEnd(), getMissed().

Parameters
sequenceProtein | protein sequence string (not null-terminated)
sizeProtein | length of the protein string
pfa | maximal number of missed cleavages
Examples
tools_aahelper.cpp.

◆ stopIteratePeptides()

void stopIteratePeptides ( )

Stop iterating.

Call this method after you have finished retrieving peptides. All calls to getPepStart(), getPepEnd() will return -1 as invalid peptide ends, and getNextPeptide() will return only FALSE until the iteration mechanism is re-initiated with startIteratePeptides().

The documentation for this class was generated from the following files:
  • ms_aahelper.hpp
  • ms_aahelper.cpp
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fragment Class Reference

  • matrix_science
  • ms_fragment
Public Types | Public Member Functions | List of all members
ms_fragment Class Reference
Classes for calculating masses of peptides and fragments.

Class representing a single peptide fragment. More...

#include <ms_fragment.hpp>

Public Types

enum LABEL_FORMAT {
LABEL_FORMAT_TRADITIONAL = 0 ,
LABEL_FORMAT_PEPTIDE_VIEW = 1
}
Format of fragment labels returned by getLabel(). More...

Public Member Functions

ms_fragment ()
Default constructor (don't use it).
ms_fragment (const char *seriesName, const double massValue, const double nlValue, const int col, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for regular series ions.
ms_fragment (const char residueName, const double massValue, const double nlValue, const int col=-1, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for immonium ion.
ms_fragment (const double massValue, const double nlValue, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for precursor neutral loss peak.
ms_fragment (const int seriesID, const double massValue, const double nlValue, const char *peptideStr, const int startPos, const int endPos, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for internal series ions only.
ms_fragment (const int seriesID, const double massValue, const double nlValue, const int col, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for regular series ions.
ms_fragment (const ms_fragment &src)
Copying constructor.
ms_fragment (const ms_peptide::PSM psmComponent, const char *seriesName, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for regular series ions of a crosslinked peptide.
ms_fragment (const ms_peptide::PSM psmComponent, const char residueName, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for immonium ion of a crosslinked peptide.
ms_fragment (const ms_peptide::PSM psmComponent, const int seriesID, const double massValue, const double nlValue, const char *peptideStr, const int startPos, const int endPos, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for internal series ions of a crosslinked peptide.
ms_fragment (const ms_peptide::PSM psmComponent, const int seriesID, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for regular series ions of a crosslinked peptide.
void | clearMatchedIon ()
Sets the fragment to be 'unmatched'.
void | copyFrom (const ms_fragment *src)
Copies the whole content of another instance.
int | getAllMatchedIons (std::vector< double > &masses, std::vector< double > &intensities) const
Returns the list of all experimental data that matched the calculated fragment mass.
int | getCharge () const
Returns the charge state (1, 2, 3 etc.) for the ion.
int | getColumn () const
Returns the 1-based position index in case of a regular series.
int | getEnd () const
Returns the 1-based last position in case of an internal fragment.
std::string | getLabel (const LABEL_FORMAT fmt=LABEL_FORMAT_TRADITIONAL) const
Returns a symbolic label like "a*(6)++".
double | getMass () const
Returns the ion mass (m/z) value.
double | getMatchedIonIntensity () const
Returns the intensity of an experimental peak that matched the calculated mass value.
double | getMatchedIonMass () const
Returns the m/z value of an experimental peak that matched the calculated mass value.
double | getNeutralLoss () const
Returns the neutral loss (m/z) values applied to the fragment.
std::string | getPeptideSubstring () const
Returns the peptide substring for internal fragments, residue name for immonium.
std::string | getSeriesName () const
Returns the ion series name.
int | getStart () const
Returns the 1-based start position within the peptide sequence.
bool | isCTerminal () const
Returns TRUE for y, v, w, x, z series, and FALSE for other series, internal ions and immonium ions.
bool | isFromAlpha () const
Returns TRUE if this fragment comes from the alpha peptide of a crosslinked match.
bool | isFromBeta () const
Returns TRUE if this fragment comes from the beta peptide of a crosslinked match.
bool | isImmonium () const
Returns TRUE for immonium ions.
bool | isInternal () const
Returns TRUE for internal fragments ya and yb.
bool | isNTerminal () const
Returns TRUE for a, b, c, d series, and FALSE for other series, internal ions and immonium ions.
bool | isPrecursorNL () const
Returns TRUE for precursor neutral loss peaks.
bool | isRegular () const
Returns TRUE for a, b, c, d, y, v, w, x, z series and their derivatives.
ms_fragment & | operator= (const ms_fragment &right)
Assignment operator for C++ programs.
void | setMatchedIon (const double mass, const double intensity)

Detailed Description

Class representing a single peptide fragment.

Examples
tools_aahelper.cpp.

Member Enumeration Documentation

◆ LABEL_FORMAT

enum LABEL_FORMAT

Format of fragment labels returned by getLabel().

The traditional label format was introduced in Parser 2.2. It has three parts, in this order: fragment ID, charge state and neutral loss. NL is separated from charge state by a space. If NL is zero, there is no space. Fragment ID depends on the series:

  • Regular ion series: series name followed by column in parentheses, e.g. "a(1)" or "y(15)"
  • Immoniums: amino acid residue, e.g. "R" or "K"
  • Internal series: peptide substring, e.g. "LVIK" or "LV"
  • Precursor NL peaks: "M"

Examples of labels in traditional format: "b(3)++ -64", "LVIK -16", "a(1)++", "y(15)"

The Peptide View label format was introduced in Mascot 2.1. The format contains the same three parts as the traditional format, but the order is different: fragment ID, neutral loss, charge state. There is no space between the elements. Peptide View format supports negative doubly charged ions.

Examples of labels in Peptide View format: "b(3)-64++", "LVIK-16", "a(1)++", "y(15)", "b(3)-64--"

Enumerator
LABEL_FORMAT_TRADITIONAL | Format introduced in Parser 2.2.
LABEL_FORMAT_PEPTIDE_VIEW | Format used by Peptide View since Mascot 2.1.

Constructor & Destructor Documentation

◆ ms_fragment() [1/11]

ms_fragment ( )

Default constructor (don't use it).

Initialises all values to defaults.

◆ ms_fragment() [2/11]

ms_fragment ( const ms_fragment & src )

Copying constructor.

Note
This constructor can only be used from C++. Use copyFrom() from other programming languages.
Parameters
src is the original fragment to base the new one on.

◆ ms_fragment() [3/11]

ms_fragment | ( | const int | seriesID,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col,
 |  | const int | chargeState = 1,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for regular series ions.

Parameters
seriesID | ion series number. It must be one of the values in matrix_science::ms_fragmentationrules::FRAG_SERIES_TYPE.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.

◆ ms_fragment() [4/11]

ms_fragment | ( | const ms_peptide::PSM | psmComponent,
 |  | const int | seriesID,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col,
 |  | const int | chargeState,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for regular series ions of a crosslinked peptide.

Parameters
psmComponent | One of the values for ms_peptide::PSM. If ms_peptide::PSM_COMPLETE, the object is the same as if it had been constructed with ms_fragment(const int, const double, const double, const int, const int, const double, const double).
seriesID | ion series number. It must be one of the values in matrix_science::ms_fragmentationrules::FRAG_SERIES_TYPE.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.

◆ ms_fragment() [5/11]

ms_fragment | ( | const char * | seriesName,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col,
 |  | const int | chargeState = 1,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for regular series ions.

Parameters
seriesName | ion series name.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.

◆ ms_fragment() [6/11]

ms_fragment | ( | const ms_peptide::PSM | psmComponent,
 |  | const char * | seriesName,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col,
 |  | const int | chargeState,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for regular series ions of a crosslinked peptide.

Parameters
psmComponent | One of the values for ms_peptide::PSM. If ms_peptide::PSM_COMPLETE, the object is the same as if it had been constructed with ms_fragment(const char*, const double, const double, const int, const int, const double, const double).
seriesName | ion series name.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.

◆ ms_fragment() [7/11]

ms_fragment | ( | const int | seriesID,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const char * | peptideStr,
 |  | const int | startPos,
 |  | const int | endPos,
 |  | const int | chargeState = 1,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for internal series ions only.

Parameters
seriesID | ion series number. It must be one of the values in matrix_science::ms_fragmentationrules::FRAG_SERIES_TYPE.
massValue | ion mass value.
nlValue | neutral loss value.
peptideStr | peptide sequence string.
startPos | first position of the fragment.
endPos | last position of the fragment.
chargeState | for the internals ions series – should be 1 or 2.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.

◆ ms_fragment() [8/11]

ms_fragment | ( | const ms_peptide::PSM | psmComponent,
 |  | const int | seriesID,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const char * | peptideStr,
 |  | const int | startPos,
 |  | const int | endPos,
 |  | const int | chargeState,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for internal series ions of a crosslinked peptide.

Parameters
psmComponent | One of the values for ms_peptide::PSM. If ms_peptide::PSM_COMPLETE, the object is the same as if it had been constructed with ms_fragment(const int, const double, const double, const char*, const int, const int, const int, const double, const double).
seriesID | ion series number. It must be one of the values in matrix_science::ms_fragmentationrules::FRAG_SERIES_TYPE.
massValue | ion mass value.
nlValue | neutral loss value.
peptideStr | peptide sequence string.
startPos | first position of the fragment.
endPos | last position of the fragment.
chargeState | for the internals ions series – should be 1 or 2.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.

◆ ms_fragment() [9/11]

ms_fragment | ( | const char | residueName,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col = -1,
 |  | const int | chargeState = 1,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for immonium ion.

This constructor is only used for immonium ions.

Parameters
residueName | amino-acid name.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.

◆ ms_fragment() [10/11]

ms_fragment | ( | const ms_peptide::PSM | psmComponent,
 |  | const char | residueName,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col,
 |  | const int | chargeState,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for immonium ion of a crosslinked peptide.

This constructor is only used for immonium ions.

Parameters
psmComponent | One of the values for ms_peptide::PSM. If ms_peptide::PSM_COMPLETE, the object is the same as if it had been constructed with ms_fragment(const char, const double, const double, const int, const int, const double, const double).
residueName | amino-acid name.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.

◆ ms_fragment() [11/11]

ms_fragment | ( | const double | massValue,
 |  | const double | nlValue,
 |  | const int | chargeState,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for precursor neutral loss peak.

This constructor is only used for precursor neutral loss peaks. Normally massValue = (mrCalc - nlValue + protonMass * chargeState) / chargeState, where mrCalc is the relative precursor mass.

Parameters
massValue | ion mass value.
nlValue | neutral loss value.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_fragment * src )

Copies the whole content of another instance.

Copy everything from src onto this fragment object.

Parameters
src valid pointer to a ms_fragment object

◆ getAllMatchedIons()

int getAllMatchedIons | ( | std::vector< double > & | masses,
 |  | std::vector< double > & | intensities
 | ) |  | const

Returns the list of all experimental data that matched the calculated fragment mass.

See ms_fragmentvector::addExperimentalData().

Parameters
masses | is used to return a vector of mass values. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
intensities | is used to return a corresponding vector of intensity values. Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
the number of mass/intensity values returned.

◆ getEnd()

int getEnd ( ) const

Returns the 1-based last position in case of an internal fragment.

This will be -1 for a 'regular' series, immonium ions and precursor NL ions.

Returns
end of the series
Examples
tools_aahelper.cpp.

◆ getLabel()

std::string getLabel ( const LABEL_FORMAT fmt = LABEL_FORMAT_TRADITIONAL ) const

Returns a symbolic label like "a*(6)++".

Parameters
fmt Output format of the label. Default is ms_fragment::LABEL_FORMAT_TRADITIONAL.
Returns
Formatted label; see ms_fragment::LABEL_FORMAT for examples.
Examples
tools_aahelper.cpp.

◆ getMatchedIonIntensity()

double getMatchedIonIntensity ( ) const

Returns the intensity of an experimental peak that matched the calculated mass value.

See ms_fragmentvector::addExperimentalData().

Returns
the intensity of the most intense experimental m/z value that matched the peak. This value will be zero if no peak matched.

◆ getMatchedIonMass()

double getMatchedIonMass ( ) const

Returns the m/z value of an experimental peak that matched the calculated mass value.

See ms_fragmentvector::addExperimentalData().

Returns
the mass of the most intense experimental m/z value that matched the peak. This value will be zero if no peak matched.

◆ getSeriesName()

std::string getSeriesName ( ) const

Returns the ion series name.

The ions series name will be one of:

  • a
  • a*
  • a0
  • b
  • b*
  • b0
  • c
  • x
  • y
  • y*
  • y0
  • z
  • z+1
  • d
  • v
  • w
  • z+2
  • ya
  • yb
  • immonium
  • precursor
Returns
name of the series
Examples
tools_aahelper.cpp.

◆ getStart()

int getStart ( ) const

Returns the 1-based start position within the peptide sequence.

Returns
1-based position in case of an internal fragment, which will also be valid for a 'regular' series. Returns 0 if this is a precursor NL peak.
Examples
tools_aahelper.cpp.

◆ isFromAlpha()

bool isFromAlpha ( ) const

Returns TRUE if this fragment comes from the alpha peptide of a crosslinked match.

Returns
False if the fragment is from the beta peptide or from a linear (non-crosslinked) peptide. True otherwise.

◆ isFromBeta()

bool isFromBeta ( ) const

Returns TRUE if this fragment comes from the beta peptide of a crosslinked match.

Returns
False if the fragment is from the alpha peptide or from a linear (non-crosslinked) peptide. True otherwise.

◆ operator=()

ms_fragment & operator= ( const ms_fragment & right )

Assignment operator for C++ programs.

Parameters
right is the original fragment to copy to the new one.
Returns
reference to the current object

◆ setMatchedIon()

void setMatchedIon | ( | const double | mass,
 |  | const double | intensity
 | ) |  |

Sets the mass and intensity of experimental data that matched the calculated mass value.

See ms_fragmentvector::addExperimentalData().

These values will be zero if no peak matched.

Parameters
mass | is the experimental m/z value that matched the peak.
intensity | is the experimental intensity value that matched the peak.
The documentation for this class was generated from the following files:
  • ms_fragment.hpp
  • ms_fragment.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fragmentvector Class Reference

  • matrix_science
  • ms_fragmentvector
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_fragmentvector Class Reference
Classes for calculating masses of peptides and fragments.

Class for holding a list of ms_fragment objects. More...

#include <ms_fragmentvector.hpp>

Public Types

enum MATCH_PEAKS {
MATCH_MOST_INTENSE_PEAK = 0x0000 ,
MATCH_CLOSEST_PEAK = 0x0001
}
Flags for matching experimental peaks to calculated peaks. More...
enum TOLERANCE_UNIT {
TOLERANCE_DALTON ,
TOLERANCE_MMU ,
TOLERANCE_PERCENT ,
TOLERANCE_PPM
}
Flags for tolerance units used for matching peaks. More...

Public Member Functions

ms_fragmentvector ()
Default constructor.
ms_fragmentvector (const ms_fragmentvector &src)
Copying constructor.
virtual | ~ms_fragmentvector ()
Destructor.
bool | addExperimentalData (const ms_mascotresfilebase *resfile, const int query, const int flags=MATCH_MOST_INTENSE_PEAK, const int peaksUsedFromIons1=-1, const int peaksUsedFromIons2=-1, const int peaksUsedFromIons3=-1)
Find matches to peaks lists from a Mascot results file.
bool | addExperimentalData (const peaklist_t &peakList, const double tolerance, const std::string &toleranceUnits, const bool updateMatchList=true)
Find matches to peak list.
bool | addExperimentalData (const std::string &peakList, const int numPeaks, const double tolerance, const std::string &toleranceUnits, const bool updateMatchList=true)
Find matches to peak list.
void | appendFragment (const ms_fragment *item)
Adds a new fragment to the end of the vector.
void | clearFragments ()
Deletes all fragments from the vector.
void | copyFrom (const ms_fragmentvector *right)
Copies all content from another instance.
const ms_fragment * | getFragmentByNumber (const unsigned int numFrag) const
Return a fragment object by its number.
int | getNumberOfFragments () const
Returns a number of fragments currently held in the vector.
frag_vector * | getVector ()
Return a pointer to the STL vector of ms_fragment objects.
const frag_vector * | getVector () const
Return a const pointer to the STL vector of ms_fragment objects.
ms_fragmentvector & | operator= (const ms_fragmentvector &right)
C++ style assignment operator.

Static Public Member Functions

static void getMassesWithinTolerance (const double mass, const double toleranceValue, const TOLERANCE_UNIT toleranceUnit, double &minMass, double &maxMass)
Get minimum and maximum masses within tolerance for a specified mass.

Detailed Description

Class for holding a list of ms_fragment objects.

This class is necessary when using Mascot Parser from programming language other than C++. It is used when calling ms_aahelper::calcFragments().

C++ users will generally just want to use a std::vector<ms_fragment> as it is easier.

Examples
tools_aahelper.cpp.

Member Enumeration Documentation

◆ MATCH_PEAKS

enum MATCH_PEAKS

Flags for matching experimental peaks to calculated peaks.

Used as flags for addExperimentalData() when passing a ms_mascotresfilebase object.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
MATCH_MOST_INTENSE_PEAK | Match the most intense peak in the region.
MATCH_CLOSEST_PEAK | Match the peak with the closest m/z value (not currently supported).

◆ TOLERANCE_UNIT

enum TOLERANCE_UNIT

Flags for tolerance units used for matching peaks.

Used as flags for getMassesWithinTolerance()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
TOLERANCE_DALTON | Simple Daltons.
TOLERANCE_MMU | milli mass units (1000th of a Dalton)
TOLERANCE_PERCENT | Percentage of the fragment or peptide mass.
TOLERANCE_PPM | Parts per million of the fragment or peptide mass.

Constructor & Destructor Documentation

◆ ms_fragmentvector() [1/2]

ms_fragmentvector ( )

Default constructor.

Create a default empty list of fragments.

◆ ms_fragmentvector() [2/2]

ms_fragmentvector ( const ms_fragmentvector & src )

Copying constructor.

Note
This constructor can only be used from C++. Use copyFrom() from other programming languages.
Parameters
src is the original list to base the new list on.

◆ ~ms_fragmentvector()

~ms_fragmentvector ( )
virtual

Destructor.

No need to call this directly. Frees the list of fragments.

Member Function Documentation

◆ addExperimentalData() [1/2]

bool addExperimentalData | ( | const ms_mascotresfilebase * | resfile,
 |  | const int | query,
 |  | const int | flags = MATCH_MOST_INTENSE_PEAK,
 |  | const int | peaksUsedFromIons1 = -1,
 |  | const int | peaksUsedFromIons2 = -1,
 |  | const int | peaksUsedFromIons3 = -1
 | ) |  |

Find matches to peaks lists from a Mascot results file.

This function matches experimental data to the calculated fragment matches. To find which peaks are matched, use ms_fragment::getMatchedIonMass() and ms_fragment::getMatchedIonIntensity(). The peak list is extracted from the results file using the query number specified.

Parameters
resfile | is the Mascot results file from which the fragments were initially calculated. The results file is used to find the peak list and the tolerances to be used for matching.
query | is the query number in the range 1..ms_mascotresfilebase::getNumQueries().
flags | is a MATCH_PEAKS value. Currently only MATCH_MOST_INTENSE_PEAK is supported.
peaksUsedFromIons1 | is the number of peaks from the peak list in the passed the results file to be used for matching. Use -1 to indicate all peaks. See also ms_peptide::getPeaksUsedFromIons1() and ms_inputquery::getStringIons1().
peaksUsedFromIons2 | is the number of peaks from the peak list in the passed the results file to be used for matching. Use -1 to indicate all peaks. See also ms_peptide::getPeaksUsedFromIons2() and ms_inputquery::getStringIons2().
peaksUsedFromIons3 | is the number of peaks from the peak list in the passed the results file to be used for matching. Use -1 to indicate all peaks. See also ms_peptide::getPeaksUsedFromIons3() and ms_inputquery::getStringIons3().
Returns
indicates if the function was successful. It will only fail if the results file is invalid or if the query number is invalid.

◆ addExperimentalData() [2/2]

bool addExperimentalData | ( | const std::string & | peakList,
 |  | const int | numPeaks,
 |  | const double | tolerance,
 |  | const std::string & | toleranceUnits,
 |  | const bool | updateMatchList = true
 | ) |  |

Find matches to peak list.

This function matches the peakList to the calculated fragment matches. To find which peaks are matched, use ms_fragment::getMatchedIonMass() and ms_fragment::getMatchedIonIntensity().

Parameters
peakList | will be of the form 136.070000:42.95,175.110000:133.1, 299.060000:710.1,415.030000:144.6 . and may be retrieved using ms_inputquery::getStringIons1().
numPeaks | is the number of peaks to be used from the list. If this is -1, then all peaks are used. To only match peaks used for matching by the search engine, pass ms_peptide::getPeaksUsedFromIons1().
tolerance | is the tolerance to be used for matching the ions. This can be found from ms_searchparams::getITOL().
toleranceUnits | must be "Da", "mmu" or "ppm". This can be found from ms_searchparams::getITOLU().
updateMatchList | should be set to true if you want to recalculate the list of matches. If this function is to be called multiple times, then set it to false except for the last call.
Returns
indicates if the function was successful. It will only fail if toleranceUnits are invalid.

◆ appendFragment()

void appendFragment ( const ms_fragment * item )

Adds a new fragment to the end of the vector.

A copy of the ms_fragment is made and added to the list, so there is no requirement to keep the original in memory.

Parameters
item is a new item to add to the list.
Examples
tools_aahelper.cpp.

◆ clearFragments()

void clearFragments ( )

Deletes all fragments from the vector.

After calling this, getNumberOfFragments() will return 0.

◆ copyFrom()

void copyFrom ( const ms_fragmentvector * right )

Copies all content from another instance.

Copy everything from right onto this fragment object.

Parameters
right const pointer to a valid ms_fragmentvector object
Examples
tools_aahelper.cpp.

◆ getFragmentByNumber()

const ms_fragment * getFragmentByNumber ( const unsigned int numFrag ) const

Return a fragment object by its number.

Parameters
numFrag is the fragment to return. This must be in the range 0 to getNumberOfFragments() -1.
Returns
A pointer to the ms_fragment object. See Maintaining object references: two rules of thumb.
Examples
tools_aahelper.cpp.

◆ getMassesWithinTolerance()

void getMassesWithinTolerance | ( | const double | mass,
 |  | const double | toleranceValue,
 |  | const TOLERANCE_UNIT | toleranceUnit,
 |  | double & | minMass,
 |  | double & | maxMass
 | ) |  |
static

Get minimum and maximum masses within tolerance for a specified mass.

This function can be used with any masses - fragments or peptides, and works with relative masses or m/z values. Mascot server applies tolerances to observed m/z values.

See Static functions in Perl, Java, Python and C#

Parameters
[in] | mass | is the mass of the fragment or peptide or protein
[in] | toleranceValue | the tolerance in the units specified by toleranceUnit
[in] | toleranceUnit | any of the four ms_fragmentvector::TOLERANCE_UNIT values
[out] | minMass | Used to return the minimum mass in the range
[out] | maxMass | Used to return the maximum mass in the range

◆ getNumberOfFragments()

int getNumberOfFragments ( ) const

Returns a number of fragments currently held in the vector.

See also
getFragmentByNumber().
Returns
number of fragments
Examples
tools_aahelper.cpp.

◆ getVector() [1/2]

ms_fragmentvector::frag_vector * getVector ( )

Return a pointer to the STL vector of ms_fragment objects.

Note
This function would only ever be of use in C++.

This class is just a wrapper for std::vector<ms_fragment> so it possible to get a pointer to the STL vector if required.

Returns
A pointer to the STL vector.

◆ getVector() [2/2]

const ms_fragmentvector::frag_vector * getVector ( ) const

Return a const pointer to the STL vector of ms_fragment objects.

See also
getVector()
Returns
A pointer to the STL vector.

◆ operator=()

ms_fragmentvector & operator= ( const ms_fragmentvector & right )

C++ style assignment operator.

Parameters
right is the original list to copy to the new list.
Returns
reference to the current object
The documentation for this class was generated from the following files:
  • ms_fragmentvector.hpp
  • ms_fragmentvector.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Accessing a Mascot Server using HTTP

Modules | Classes
Accessing a Mascot Server using HTTP

Modules

HTTP Communication to a Mascot Server
Examples for the Mascot http client module

Classes

class | ms_connection_settings
Settings required to make an HTTP connection to a Mascot server. More...
class | ms_http_client
This class enables access to a Mascot server using HTTP. More...
class | ms_http_client_mime
The class eases the building of a MIME section. More...
class | ms_http_client_search
Used for submitting searches to a Mascot server and retrieving search results using HTTP(S). More...
class | ms_http_client_session
This gives access to a Mascot session so searches may be submitted. More...
class | ms_http_helper
The class provides HTTP, FTP and FILE protocol access to a server. More...
class | ms_http_helper_handles
The class holds HTTP to allow a POST request to be kept alive and retrieve any output received from that request. More...
class | ms_http_helper_progress
This holds information on the progress of a running HTTP transfer. More...
class | ms_http_helper_return
Indicates any problem that may have occurred during a request to an ms_http_helper object. More...

Detailed Description

Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: HTTP Communication to a Mascot Server

HTTP Communication to a Mascot Server
Accessing a Mascot Server using HTTP

HTTP Communication Overview

It is highly advisable to use HTTP for all communication with a Mascot server. One reason is that the HTTP API is uniform across different platforms (Windows, Linux). A second reason is that even if you are prepared to write platform-dependent code, direct access to the server by users may not be permitted by the IT department.

The HTTP Client classes provided a high level interface to allow access to the Mascot server.

There are three main levels at which to access the Mascot server:

HTTP Client
Remote access to the server is made available by ms_http_client. This holds the base URL to the server (e.g. "http://myserver/mascot/cgi/") that is the root address for all the server applications, typically ending in "/cgi/". Queries allow you to find out such things as the server version and operating system. This is also where you login to get a session.
HTTP Client Session
ms_http_client_session gives access to a single Mascot session. The client session is created by logging into the HTTP Client. You must login to create the session, even if security is not enabled on the server. The username and password can be left blank if security is disabled or the guest account is to be used. It holds the Mascot session ID and allows access to functions that require you to be logged into the server, such as submitting new searches or accessing old searches.
HTTP CLient Search
ms_http_client_search gives access to a single search on the Mascot server. With this new searches can be submitted, their progress monitored and results downloaded. The new search is created by submitting a search with the Client Session. An old search is accessed by creating a new ms_http_client_search using the Client Session and the search task id (the one used when the search was originally run).

Lower level access is available using ms_http_helper and its associated classes (ms_http_helper_handles, ms_http_helper_progress, ms_http_helper_response and ms_http_helper_return). The higher level HTTP client classes are implemented using these low level classes. On Windows, these low level classes are implemented using the WinHTTP 5.1 API and as such requires at least Windows 2000, Service Pack 3 or later.

Obtaining Parameter Lists

Some of the search parameters are chosen from controlled lists of terms that are server specific. For example, the name of the sequence database to be searched. Mascot is very configurable, and you should not make any assumptions about what choices will be available. It is possible for people to define their own databases, instrument types, modifications, and enzymes.

The most flexible way to obtain these lists is using Mascot Parser. The URL of the Mascot server is passed to the relevant constructor. See the example code in the Mascot Parser documentation for config_enzymes, config_fragrules, config_mascotdat, config_masses, config_config_modfile and config_taxonomy.

Creating Searches

The MIME format is described in Chapter 8 of the Mascot Installation and Setup manual and RFC's 2045 - 2049. A file of the required format is created automatically, when the search form is submitted. You can capture this output by setting the option SaveLastQueryAsc in mascot.dat to 1. See Chapter 6 of the manual for further information.

The data passed to the server is a concentenation of the prologue, the file and the epilogue. It is often more convenient to save just the peak list in a file. The prologue and epilogue can then be created for the search and sent directly to the server without having to save them to a file.

If the peak list is relatively small, then it can be stored in memory and passed in one parameter (e.g. as the prologue) along with all the other informaion. The other parameters (e.g. the file and epilogue) can be left blank.

When creating MIME format information (e.g. the prologue), a ms_http_client_mime provides a simple mechanism for formatting the data correctly.

Connect to a Server

Create a new ms_http_client, passing the base URL and suitable settings.

matrix_science::ms_connection_settings settings;
settings.setUserAgent("your_application_name");
matrix_science::ms_http_client server("http://your_mascot_server/mascot/cgi/", settings);

Get a Session

Login, passing a username and password if required, to obtain a new ms_http_client_session (not to be confused with ms_session, which is used locally on the server only and does not communicate via HTTP). If security has not been enabled, then the username and password can be blank.

matrix_science::ms_http_client_session session;
matrix_science::ms_http_client::LoginResultCode loginResult = server.userLogin("your_username", "your_password", session);
// ... check success

Create a Search

Get a new ms_http_client_search from the session.

std::string httpHeader = "Content-Type: multipart/mixed; boundary=---MascotDistillerMascotSearch";
matrix_science::ms_http_client_search search;
matrix_science::ms_http_helper_progress progress;
bool isOk = session->submitSearch(search, httpHeader, "", "your_source_mime_filename", "", progress);
// ... check success

Follow its Progress

Follow the progress of the search on the server until is is complete.

matrix_science::ms_http_client_search::SearchStatusCode code;
int progressPercent;
do {
    bool isOk = search.getStatus(code, progressPercent);
    // ... check success
    // ... waiting for search to complete
    double x = progressPercent;
} while (code == matrix_science::ms_http_client_search_status::TS_RUNNING);

Download the Results
Download the results.
bool isOk = search.downloadResultsFile("your_target_download_filename");
// ... check success

Previous Search Results

To retrieve the results from a previously run search you will need to know its search task identifier.

Connect to a Server

Create a new ms_http_client.

matrix_science::ms_connection_settings settings;
settings.setUserAgent("your_application_name");
matrix_science::ms_http_client server("http://your_mascot_server/mascot/cgi/", settings);

Get a Session

Login, passing a username and password if required, to obtain a new ms_http_client_session.

matrix_science::ms_http_client_session session;
matrix_science::ms_http_client::LoginResultCode loginResult = server.userLogin("your_username", "your_password", session);
// ... check success

Attach to the Search

Get a new ms_http_client_search using the ms_http_client_session and the task identifier.

matrix_science::ms_http_client_search search(session, "search_task_identifier");

Download the Results
Download the results.
bool isOk = search.downloadResultsFile("your_target_download_filename");
// ... check success

Sequence Retrieval using getseq.pl

To retrieve the sequence for a particular accession:

Connect to a Server

Create a server object, passing the base URL and suitable settings.

matrix_science::ms_connection_settings settings;
settings.setUserAgent("your_application_name");
matrix_science::ms_http_client server("http://your_mascot_server/mascot/cgi/", settings);

Get a Session

Login, passing a username and password if required, to obtain a session.

matrix_science::ms_http_client_session session;
matrix_science::ms_http_client::LoginResultCode loginResult = server.userLogin("your_username", "your_password", session);
// ... check success

Get sequence
Query the sequence data for an accession number (e.g. "041R_FRG3G") from the database (e.g. "SwissProt").
const std::vector<std::string> & accessionNames;
accessionNames.push_back("041R_FRG3G");
const std::vector<int> accessionFrames; // not using NA frames so leave empty
bool isOk = session.getSequenceFile("SwissProt", accessionNames, accessionFrames, "target_file_name");
// ... check success

Error handling and logging

All the classes inherit from ms_errors. A logging level and logging file can be set on the initial ms_http_client object, for example:

my $objHttpClient = new msparser::ms_http_client($url, $objSettings);
if ($objHttpClient->isValid) {
  $objHttpClient->getErrorHandler->setLoggingFile("log.txt", $msparser::ms_errs::sev_debug3);
}

When ms_http_client::userLogin is called, the logging values are copied to the ms_http_client_session object passed to the function.

When ms_http_client_session::submitSearch is called, the logging values are copied to the ms_http_client_search object passed to the function.

to HTTPS websites

It is possible to connect to websites using https on Linux or Windows systems. To do so, the target website must have a valid certificate. The certificate may be refused by Parser for three main reasons.

  • The certificate is valid and signed by a recognised authority, but Parser uses an outdated certificate bundle.
  • The certificate is self-signed, the root certificate of the target server must be added to Parser.
  • The certificate is missing or invalid, a valid connection cannot be established over https.

To update the list of certificates or to add a self-signed certificate on Linux, two methods are possible.

Note that on Linux, all certificates to be added must be in a valid PEM format. Namely, the certificates must be between —–BEGIN CERTIFICATE—– and —–END CERTIFICATE—– in the file. There are some tools to convert from other formats to the PEM format, for example on this website : https://www.sslshopper.com/ssl-converter.html, Linux packages also contain similar tools.

Add a root certificate to a Linux system

This method is preferred when it is required to update the system's bundle of certificates. For example, if it not possible to connect to https://www.google.com/, it may be due to the system's bundle. It is however not recommanded to use this method for a self-signed certificate, unless you want to grant access to this website for all other programs on your system.

An up-to-date list of certificates can be downloaded from any of the following links, either over http or https.

  • http://curl.haxx.se/ca/cacert.pem
  • https://raw.githubusercontent.com/bagder/ca-bundle/master/ca-bundle.crt

Debian and Ubuntu systems To add a root certificate to a Debian-based Linux system, type the following commands.

sudo cp newCertificate.crt /usr/local/share/ca-certificates/
sudo update-ca-certificates

Fedora, RedHat and CentOS systems To add a root certificate to a Fedora-based Linux system, type the following commands as root.

yum install ca-certificates
update-ca-trust force-enable
cp newCertificate.crt /etc/pki/ca-trust/source/anchors/
update-ca-trust extract

Add a certificate to Parser on Linux

This method is preferred for a self-signed certificate. To download the root certificate of a website, you can do so from your browser or ask its administrator, and convert it to PEM format as mentioned above. The extension of root certificates are usually .crt, although it does not matter for this method to work.

Once the certificate has been downloaded on your system, type the following commands, the access rights depend on your installation.

mkdir -p /usr/local/mascot/cert
chmod 755 /usr/local/mascot/cert
cp selfSignedCertificate.crt /usr/local/mascot/cert/
chmod 644 /usr/local/mascot/cert/selfSignedCertificate.crt

It is also possible to add a self-signed certificate on Windows. Note that, on Windows, the certificate must be in one of the following formats : .PFX, .P12, .P7B, .SST .

Add a certificate to a Windows system

To download the root certificate of a website, you can do so from your browser or ask its administrator, and make sure it is in a correct format as mentioned above.

Once the certificate has been downloaded on your system, do the following

Click Start, click the text box Search Program and files
Type mmc and type Enter
Click File -> Add/Remove Snap-in...
Click Certificates, click Add >, select Computer account, click Next, click Finish, click OK
On the left panel, Navigate to Console Root/Certificates (Local Computer)/Personal/Third-Party Root Certification Authorities, Certificates
Right click on Certificates, click on All tasks -> Import...
Click Next, click Browse..., change the file filter to match your file type, click your file, click Open, click Next, click Next, click Finish, click OK, close the Console.
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Examples for the Mascot http client module

Examples for the Mascot http client module
Accessing a Mascot Server using HTTP

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
Accessing a Mascot Server using http | http_client.pl |  |  | http_client.py | http_client.cs
Accessing any server using http(s) | http_helper_getstring.pl | http_helper_getstring.cpp |  | http_helper_getstring.py |
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_connection_settings Class Reference

  • matrix_science
  • ms_connection_settings
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_connection_settings Class Reference
Accessing a Mascot Server using HTTP

Settings required to make an HTTP connection to a Mascot server. More...

#include <ms_connection_settings.hpp>

Public Types

enum HTTP_PROTOCOL {
HTTP_1_0 = 0x0000 ,
HTTP_1_1 = 0x0001 ,
HTTP_SYSTEM_DEFAULT = 0x0002
}
enum PROXY_TYPE {
PROXY_TYPE_NO_PROXY = 0x0000 ,
PROXY_TYPE_FROM_REGISTRY = 0x0001 ,
PROXY_TYPE_SPECIFY = 0x0002 ,
PROXY_TYPE_WPAD = 0x0003 ,
PROXY_TYPE_ENVIRONMENT = 0x0004 ,
PROXY_TYPE_AUTO = 0x0005
}
Definitions for types of setting. More...
enum REDIRECT_POLICY {
REDIRECT_POLICY_ALWAYS = 0x0000 ,
REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP = 0x0001 ,
REDIRECT_POLICY_NEVER = 0x0002
}

Public Member Functions

ms_connection_settings ()
Default constructor used to create an ms_connection_settings object.
ms_connection_settings (const std::string sessionID, const std::string proxyServer, const std::string proxyUserName, const std::string proxyUserPassword)
Constructor to set some parameters.
~ms_connection_settings ()
Destructor.
void | copyFrom (const ms_connection_settings *right)
Call this member to copy all the information from another instance.
void | defaultValues ()
Called by the default constructor and may be called to re-initialise all values.
int | getConnectionTimeout () const
Returns the HTTP connection timeout.
std::string | getHttpPassword () const
Gets the password for an authenticated web server.
ms_connection_settings::HTTP_PROTOCOL | getHttpProtocol () const
Returns the version of HTTP protocol to be used.
std::string | getHttpUsername () const
Gets the username for an authenticated web server.
std::string | getProxyPassword () const
Gets the password for an authenticated proxy server.
std::string | getProxyServer () const
Gets the name of the proxy server.
ms_connection_settings::PROXY_TYPE | getProxyServerType () const
Returns how proxy server information will be obtained.
std::string | getProxyUserAndPassword () const
Get the combined username and password – if any.
std::string | getProxyUsername () const
Gets the user name for an authenticated proxy server.
ms_connection_settings::REDIRECT_POLICY | getRedirectPolicy () const
Gets the policy for HTTP redirection.
std::string | getSessionID () const
Gets the sessionID to be used for the connection.
std::string | getUserAgent () const
Get the user agent string.
bool | isUseHTTPProxyForFTP () const
Return true if HTTP proxy settings should be used for FTP.
bool | isUseHTTPProxyForHTTPS () const
Return true if HTTP proxy settings should be used for HTTPS.
ms_connection_settings & | operator= (const ms_connection_settings &right)
C++ style assignment operator.
void | setConnectionTimeout (int timeout)
Sets the HTTP connection timeout.
void | setHttpPassword (const std::string httpPassword)
Sets the password for an authenticated web server.
void | setHttpProtocol (ms_connection_settings::HTTP_PROTOCOL httpProtocol)
Sets the version of the HTTP protocol to be used.
void | setHttpUsername (const std::string httpUsername)
Sets the username for an authenticated web server.
void | setProxyPassword (const std::string proxyUserPassword)
Sets the password for an authenticated proxy server.
void | setProxyServer (const std::string proxyServer)
Sets the name of the proxy server.
void | setProxyServerType (ms_connection_settings::PROXY_TYPE proxyType)
Specifies how proxy server information will be obtained.
void | setProxyUsername (const std::string proxyUserName)
Sets the user name for an authenticated proxy server.
void | setRedirectPolicy (ms_connection_settings::REDIRECT_POLICY redirectPolicy)
Sets the policy for HTTP redirection.
void | setSessionID (const std::string sessionID)
Sets the Mascot security sessionID to be used for the connection.
void | setUseHTTPProxyForFTP (bool value)
Enable or disable use of an HTTP proxy server for an FTP request.
void | setUseHTTPProxyForHTTPS (bool value)
Enable or disable use of an HTTP proxy server for an HTTPS request.
void | setUserAgent (const std::string userAgent)
Set the user agent string.

Static Public Member Functions

static int | proxyTypeStringToEnum (std::string str)
Convert proxy type string to PROXY_TYPE.
static std::string | proxyTypeToString (int type)
Convert PROXY_TYPE to canonical string.

Detailed Description

Settings required to make an HTTP connection to a Mascot server.

A sessionID parameter may be required if Mascot security is enabled.

This class holds these settings and is used from:

  • ms_datfile::ms_datfile(const char *filename, const int timeoutSec, const ms_connection_settings *cs)
  • ms_umod_configfile::ms_umod_configfile(const char *filename, const char *schemaFileName, const ms_connection_settings *cs)
  • ms_modfile::ms_modfile(const char *filename, const ms_masses *massFile, const bool fromSubstitutions, const ms_connection_settings *cs)
  • ms_masses::ms_masses(const char* filename, const ms_connection_settings *cs)
  • ms_fragrulesfile::ms_fragrulesfile(const char *filename, const ms_connection_settings *cs)
  • ms_taxonomyfile::ms_taxonomyfile(const char *filename, const ms_connection_settings *cs)
  • ms_enzymefile::ms_enzymefile(const char *filename, const ms_connection_settings *cs)
Examples
config_enzymes.cpp, config_fragrules.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_quantitation.cpp, config_taxonomy.cpp, and http_helper_getstring.cpp.

Member Enumeration Documentation

◆ HTTP_PROTOCOL

enum HTTP_PROTOCOL

Definitions for HTTP protocol to use.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
HTTP_1_0 | Use HTTP 1.0.
HTTP_1_1 | Use HTTP 1.1.
HTTP_SYSTEM_DEFAULT | Use system default. For Windows, this is set in Internet Explorer or the Control Panel.

◆ PROXY_TYPE

enum PROXY_TYPE

Definitions for types of setting.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
PROXY_TYPE_NO_PROXY | No proxy server will be used. For Windows, the INTERNET_OPEN_TYPE_DIRECT flag is specified in the InternetOpen call.
PROXY_TYPE_FROM_REGISTRY | Windows version of Mascot Parser only. The proxy server will be discovered using the WinHttpGetIEProxyConfigForCurrentUser call (the no proxy is used if no proxy is set in Internet Explorer).
PROXY_TYPE_SPECIFY | The proxy server must be specified using setProxyServer(). The INTERNET_OPEN_TYPE_PROXY flag is specified in the InternetOpen call.
PROXY_TYPE_WPAD | Windows version of Mascot Parser only. The proxy server will be discovered using the WinHttpGetProxyForUrl call (the default proxy is used if no proxy can be auto-discovered).
PROXY_TYPE_ENVIRONMENT | Proxy settings will be loaded from the system environment variables http_proxy and https_proxy, depending on protocol.
PROXY_TYPE_AUTO | The proxy server will be discovered automatically. This is the default. On Windows the order is PROXY_TYPE_FROM_REGISTRY, then PROXY_TYPE_WPAD and finally the system default proxy. On Linux, the order is PROXY_TYPE_ENVIRONMENT, PROXY_TYPE_SPECIFY and PROXY_TYPE_NONE.

◆ REDIRECT_POLICY

enum REDIRECT_POLICY

Definitions for HTTP redirection policy.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
REDIRECT_POLICY_ALWAYS | All redirects are followed automatically.
REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP | All redirects are followed, except those that originate from a secure (https) URL to an unsecure (http) URL. This is the default setting.
REDIRECT_POLICY_NEVER | Redirects are never followed.

Constructor & Destructor Documentation

◆ ms_connection_settings() [1/2]

ms_connection_settings ( )

Default constructor used to create an ms_connection_settings object.

The values are all set to the defaults as detailed in defaultValues().

To set up the object correctly, it may be necessary to call one or more of the following functions, depending on the network environment.

  • setSessionID()
  • setProxyServerType()
  • setProxyServer()
  • setProxyUsername()
  • setProxyPassword()
  • setConnectionTimeout()
  • setHttpProtocol()
  • setHttpUsername()
  • setHttpPassword()
  • setRedirectPolicy()
  • setUseHTTPProxyForFTP()
  • setUseHTTPProxyForHTTPS()
  • setUserAgent()

◆ ms_connection_settings() [2/2]

ms_connection_settings | ( | const std::string | sessionID,
 |  | const std::string | proxyServer,
 |  | const std::string | proxyUserName,
 |  | const std::string | proxyUserPassword
 | ) |  |

Constructor to set some parameters.

It is generally easier and clearer to create an object using the default constructor and then set all of the required values.

For this constructor, values not passed are set by calling defaultValues())

Parameters
sessionID | is the session ID string retrieved either from login.pl or from ms_session::ms_session().
proxyServer | is the URL of the proxy server, if any.
proxyUserName | is the user name for an authenticated proxy server.
proxyUserPassword | is the password for an authenticated proxy server.

◆ ~ms_connection_settings()

~ms_connection_settings ( )

Destructor.

Called automatically.

Member Function Documentation

◆ copyFrom()

void copyFrom ( const ms_connection_settings * right )

Call this member to copy all the information from another instance.

Useful in cases where the language doesn't support copying objects.

Parameters
right Valid pointer to a ms_connection_settings object

◆ defaultValues()

void defaultValues ( )

Called by the default constructor and may be called to re-initialise all values.

Sets all members to their default values:

  • sessionID is cleared.
  • connection timeout is set to 60 seconds.
  • proxy server settings are cleared.
  • proxy server type is set to ms_connection_settings::PROXY_TYPE_AUTO
  • For Windows, the http protocol is set to ms_connection_settings::HTTP_SYSTEM_DEFAULT
  • For Linux, the http protocol is set to ms_connection_settings::HTTP_1_1
  • For Windows, the user agent string is set to "MascotParser/[parser_version] winhttp/5.1".
  • For Linux, the user agent string is set to "MascotParser/[parser_version] curl/[curl version]."
  • The redirect policy is set to ms_connection_settings::REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP

◆ getConnectionTimeout()

int getConnectionTimeout ( ) const

Returns the HTTP connection timeout.

The default value is 60 seconds.

Returns
The timeout in seconds before a connection will fail.

◆ getHttpPassword()

std::string getHttpPassword ( ) const

Gets the password for an authenticated web server.

Returns
The HTTP password.

◆ getHttpProtocol()

ms_connection_settings::HTTP_PROTOCOL getHttpProtocol ( ) const

Returns the version of HTTP protocol to be used.

The default value for Windows is HTTP_SYSTEM_DEFAULT and the default type for all the Unix platforms is HTTP_1_1.

Returns
An enumerated value which specifies whether HTTP 1.0, 1.1 or the system default is used when connecting via HTTP to a Mascot Server.

◆ getHttpUsername()

std::string getHttpUsername ( ) const

Gets the username for an authenticated web server.

Returns
The HTTP user name.

◆ getProxyPassword()

std::string getProxyPassword ( ) const

Gets the password for an authenticated proxy server.

When, for example ms_enzymefile::ms_enzymefile(const char* filename, const ms_connection_settings * cs) is called, that function will use the proxy server details when connecting to the Mascot server to retrieve the enzymes definitions.

Returns
The Proxy server password.

◆ getProxyServer()

std::string getProxyServer ( ) const

Gets the name of the proxy server.

When, for example ms_enzymefile::ms_enzymefile(const char* filename, const ms_connection_settings * cs) is called, that function will use the proxy server details when connecting to the Mascot server to retrieve the enzymes definitions.

This is the proxy server name specified to setProxyServer(). This is only valid if the proxy server type is PROXY_TYPE_SPECIFY. If the proxy server type is something other value then getProxyList() should be used.

Returns
The specified proxy server name.

◆ getProxyServerType()

ms_connection_settings::PROXY_TYPE getProxyServerType ( ) const

Returns how proxy server information will be obtained.

The default value is PROXY_TYPE_AUTO. If setProxyServer() is called with a non zero length string, then this type is automatically set to PROXY_TYPE_SPECIFY.

See also
setProxyServer()
Returns
An enumerated value PROXY_TYPE which specifies the way in which information about the proxy server can be obtained.

◆ getProxyUserAndPassword()

std::string getProxyUserAndPassword ( ) const

Get the combined username and password – if any.

Returns
A string in the format username:password.

◆ getProxyUsername()

std::string getProxyUsername ( ) const

Gets the user name for an authenticated proxy server.

When, for example ms_enzymefile::ms_enzymefile(const char* filename, const ms_connection_settings * cs) is called, that function will use the proxy server details when connecting to the Mascot server to retrieve the enzymes definitions.

Returns
The Proxy server user name.

◆ getRedirectPolicy()

ms_connection_settings::REDIRECT_POLICY getRedirectPolicy ( ) const

Gets the policy for HTTP redirection.

The default value for Windows is REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP.

Returns
An enumerated value controls what types of redirection request are allowed.

◆ getSessionID()

std::string getSessionID ( ) const

Gets the sessionID to be used for the connection.

A session ID is used if Mascot Security is enabled; see Mascot security and authentication module. The sessionID is originally retrieved by the calling application either from login.pl or from ms_session::ms_session(). This is then set using setSessionID(). When, for example ms_enzymefile::ms_enzymefile(const char* filename, const ms_connection_settings * cs) is called, that function will get the sessionID and use it to retrieve the enzymes definitions from the Mascot server.

Returns
The session ID string that has been set by calling setSessionID().

◆ getUserAgent()

std::string getUserAgent ( ) const

Get the user agent string.

With HTTP, the identity of a client application is transmitted to the server via the User-Agent request header, as described by RFC 1945. For a browser, this might be:

  "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6.6)"

For other applications, the unofficial 'standard' is to use pairs of space separated ApplicationName/version values. The default value for Mascot Parser version 2.3.4 and later is

  • "MascotParser/version wininet/version" for Windows and
  • "MascotParser/version curl/version" for Linux.

The default value for Mascot Parser version 2.3.3 and earlier is

  • "msparser wininet 1.0" for Windows and
  • "ms-parser (curllib) V1.0" for all the Unix platforms.

It is normally more useful to prepend this with the the name and version of the client application. For example, for Mascot Distiller, suitable code might be:

   setUserAgent("Mascot Distiller/2.3.0 " + getUserAgent());
Returns
the current agent string.
Examples
http_helper_getstring.cpp.

◆ isUseHTTPProxyForFTP()

bool isUseHTTPProxyForFTP ( ) const

Return true if HTTP proxy settings should be used for FTP.

This setting allows making FTP requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

Returns
Enabled (true) or disabled (false).

◆ isUseHTTPProxyForHTTPS()

bool isUseHTTPProxyForHTTPS ( ) const

Return true if HTTP proxy settings should be used for HTTPS.

This setting allows making HTTPS requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

Returns
Enabled (true) or disabled (false).

◆ operator=()

ms_connection_settings & operator= ( const ms_connection_settings & right )

C++ style assignment operator.

Note
Only used by C++ programs, and internally.
Parameters
right An ms_connection_settings object
Returns
Reference to the ms_connection_settings instance.

◆ proxyTypeStringToEnum()

int proxyTypeStringToEnum ( std::string str )
static

Convert proxy type string to PROXY_TYPE.

Parameters
str Case-insensitive proxy type, one of "none", "auto", "specify", "registry", "wpad", "environment".
Returns
The matching value in PROXY_TYPE, or -1 if str matches no known proxy type.

◆ proxyTypeToString()

std::string proxyTypeToString ( int type )
static

Convert PROXY_TYPE to canonical string.

Parameters
type One of the PROXY_TYPE values.
Returns
String representation of the value, one of None, Auto, Registry, Specify, WPAD, Environment. If type does not match any known value, the function returns the empty string.

◆ setConnectionTimeout()

void setConnectionTimeout ( int timeout )

Sets the HTTP connection timeout.

The default value is 60 seconds.

Parameters
timeout is the timeout in seconds before a connection will fail.

◆ setHttpPassword()

void setHttpPassword ( const std::string httpPassword )

Sets the password for an authenticated web server.

Parameters
httpPassword is the password required to access an authenticated web server.
Examples
http_helper_getstring.cpp.

◆ setHttpProtocol()

void setHttpProtocol ( ms_connection_settings::HTTP_PROTOCOL httpProtocol )

Sets the version of the HTTP protocol to be used.

The default value for Windows is HTTP_SYSTEM_DEFAULT and the default type for all the Unix platforms is HTTP_1_1.

Parameters
httpProtocol Specifies whether HTTP 1.0, 1.1 or the system default is used when connecting via HTTP to a Mascot Server.

◆ setHttpUsername()

void setHttpUsername ( const std::string httpUsername )

Sets the username for an authenticated web server.

Parameters
httpUsername is the user name required to access an authenticated web server.
Examples
http_helper_getstring.cpp.

◆ setProxyPassword()

void setProxyPassword ( const std::string proxyUserPassword )

Sets the password for an authenticated proxy server.

Parameters
proxyUserPassword is the password required to access an authenticated proxy server.

◆ setProxyServer()

void setProxyServer ( const std::string proxyServer )

Sets the name of the proxy server.

Calling this function with a non-zero length string will also set the proxy type to ms_connection_settings::PROXY_TYPE_SPECIFY.

See also
setProxyServerType()
Parameters
proxyServer is the URL of the proxy server.

◆ setProxyServerType()

void setProxyServerType ( ms_connection_settings::PROXY_TYPE proxyType )

Specifies how proxy server information will be obtained.

The default value is PROXY_TYPE_AUTO. If setProxyServer() is called with a non zero length string, then this type is automatically set to PROXY_TYPE_SPECIFY.

See also
setProxyServer()
Parameters
proxyType is the way in which information about the proxy server can be obtained.

◆ setProxyUsername()

void setProxyUsername ( const std::string proxyUserName )

Sets the user name for an authenticated proxy server.

Parameters
proxyUserName is the user name required to access an authenticated proxy server.

◆ setRedirectPolicy()

void setRedirectPolicy ( ms_connection_settings::REDIRECT_POLICY redirectPolicy )

Sets the policy for HTTP redirection.

The default value for Windows is REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP.

Parameters
redirectPolicy controls what types of redirection request are allowed.

◆ setSessionID()

void setSessionID ( const std::string sessionID )

Sets the Mascot security sessionID to be used for the connection.

A session ID is used if Mascot Security is enabled; see Mascot security and authentication module.

Parameters
sessionID is the session ID string which can be retrieved using ms_session::ms_session() when running on the Mascot Server or, for an application using http, by calling ms_http_client::userLogin (which in turn calls the login.pl script on the Mascot Server.
Examples
config_enzymes.cpp, config_fragrules.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_quantitation.cpp, and config_taxonomy.cpp.

◆ setUseHTTPProxyForFTP()

void setUseHTTPProxyForFTP ( bool value )

Enable or disable use of an HTTP proxy server for an FTP request.

This setting allows making FTP requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

Parameters
value Enable (true) or disable (false).

◆ setUseHTTPProxyForHTTPS()

void setUseHTTPProxyForHTTPS ( bool value )

Enable or disable use of an HTTP proxy server for an HTTPS request.

This setting allows making HTTPS requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

Parameters
value Enable (true) or disable (false).

◆ setUserAgent()

void setUserAgent ( const std::string userAgent )

Set the user agent string.

With HTTP, the identity of a client application is transmitted to the server via the User-Agent request header, as described by RFC 1945. For a browser, this might be:

  "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6.6)"

For other applications, the unofficial 'standard' is to use pairs of space separated ApplicationName/version values.

The default value for Mascot Parser version 2.5.0 and later is

  • "MascotParser/version winhttp/5.1" for Windows and
  • "MascotParser/version curl/version" for Linux.

The default value for Mascot Parser version 2.3.4 to 2.4.x is

  • "MascotParser/version wininet/version" for Windows and
  • "MascotParser/version curl/version" for Linux.

The default value for Mascot Parser version 2.3.3 and earlier is

  • "msparser wininet 1.0" for Windows and
  • "ms-parser (curllib) V1.0" for all the Unix platforms.

It is normally more useful to prepend this with the the name and version of the client application. For example, for Mascot Distiller, suitable code might be:

   setUserAgent("Mascot Distiller/2.3.0 " + getUserAgent());
Parameters
userAgent is the new agent string.
Examples
http_helper_getstring.cpp.
The documentation for this class was generated from the following files:
  • ms_connection_settings.hpp
  • ms_connection_settings.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_client Class Reference

  • matrix_science
  • ms_http_client
Public Types | Public Member Functions | List of all members
ms_http_client Class Reference
Accessing a Mascot Server using HTTP

This class enables access to a Mascot server using HTTP. More...

#include <ms_http_client.hpp>

Inheritance diagram for ms_http_client:
[legend]
Collaboration diagram for ms_http_client:
[legend]

Public Types

enum ChangePasswordResultCode {
CP_SUCCESS ,
CP_UNKNOWNUSER ,
CP_INCORRECTPASSWORD ,
CP_BADNEWPASSWORD ,
CP_UNSPECIFIEDERROR
}
Definitions for the possible responses to an attempt to change a password. More...
enum LoginResultCode {
L_SUCCESS ,
L_SECURITYDISABLED ,
L_UNKNOWNUSER ,
L_INCORRECTPASSWORD ,
L_PASSWORDEXPIRED ,
L_WEBAUTHENTICATIONFAILED ,
L_GUESTLOGINDISABLED ,
L_UNSPECIFIEDERROR
}
Definitions for the types of response from the login program on the Mascot server. More...

Public Member Functions

ms_http_client (const ms_http_client &src)
ms_http_client (const std::string &baseUrl, ms_connection_settings settings)
Constructor to provide access to the Mascot server.
virtual | ~ms_http_client ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
std::string | baseUrl () const
Returns the base URL for the Mascot server.
ChangePasswordResultCode | changePassword (const std::string &userName, const std::string &oldPassword, const std::string &newPassword)
Change the password for a user. The user's old password must be supplied.
void | clearAllErrors ()
Remove all errors from the current list of errors.
ms_connection_settings | connectionSettings () const
Returns the HTTP connection settings.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_http_client *right)
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
bool | getIsDatabaseActive (const std::string &databaseName, bool &returnIsActive)
Queries whether the specified database is available for searching. Returns true if successful.
bool | getIsSecurityEnabled (bool &returnIsSecurityEnabled, std::string &returnUnsecuredSessionId)
Determine if Mascot Security is enabled on the Mascot Server.
bool | getIsWebAuthenticationEnabled (bool &returnIsWebAuthenticationEnabled, std::string &returnWebAuthenticatedSessionId)
Determine if Mascot Security is setup to use Web Authentication.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getOsName (std::string &osname)
Queries the operating system running on the server. Returns true if successful.
bool | getVersion (int &major, int &minor, int &part3, int &part4)
Queries the version of Mascot running on the server. Returns true if successful.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_http_client & | operator= (const ms_http_client &right)
void | setBaseUrl (const std::string &baseUrl)
Sets the base URL for the Mascot server.
void | setConnectionSettings (const ms_connection_settings &settings)
Sets the HTTP connection settings.
LoginResultCode | userLogin (const std::string &username, const std::string &password, ms_http_client_session &returnSession)
Attempts to log into the Mascot server using the supplied credentials.

Detailed Description

This class enables access to a Mascot server using HTTP.

Creating an ms_http_client object establishes an HTTP connection to the Mascot Server and provides a number of utility functions:

  • Log in to Mascot Security
  • Determine the version of Mascot running on the server
  • Discover the OS being run on the server
  • Change the password of a Mascot user (if permitted)
  • Determine if a particular database is active

Once the userLogin function has been called, searches can be submitted and results retrieved using ms_http_client_search

Member Enumeration Documentation

◆ ChangePasswordResultCode

enum ChangePasswordResultCode

Definitions for the possible responses to an attempt to change a password.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
CP_SUCCESS | The password was changed successfully.
CP_UNKNOWNUSER | The user ID was not recognised. No password was changed.
CP_INCORRECTPASSWORD | The old password supplied was incorrect. No password was changed.
CP_BADNEWPASSWORD | The new password could not be used (e.g. too short). No password was changed.
CP_UNSPECIFIEDERROR | An error occurred. No further information is available.

◆ LoginResultCode

enum LoginResultCode

Definitions for the types of response from the login program on the Mascot server.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
L_SUCCESS | The function completed successfully.
L_SECURITYDISABLED | Security is disabled on the Mascot server.
L_UNKNOWNUSER | The user ID supplied was not recognised by the Mascot server.
L_INCORRECTPASSWORD | The password supplied for the specified user was incorrect.
L_PASSWORDEXPIRED | The password supplied for the specified user has expired.
L_WEBAUTHENTICATIONFAILED | Web authentication failed for the currently logged in user.
L_GUESTLOGINDISABLED | The guest login could not be accessed because it is disabled on the server.
L_UNSPECIFIEDERROR | An error occurred. No further information is available.

Constructor & Destructor Documentation

◆ ms_http_client() [1/2]

ms_http_client | ( | const std::string & | baseUrl,
 |  | ms_connection_settings | settings
 | ) |  |

Constructor to provide access to the Mascot server.

Make a connection to a Mascot Server using HTTP.

Parameters
baseUrl | The URL of the Mascot server CGI directory. For example "http://your-server/mascot/cgi/". Must end with the /cgi/
settings | Settings that control the connection to the Mascot server.

◆ ~ms_http_client()

~ms_http_client ( )
virtual

Destructor.

Called automatically.

◆ ms_http_client() [2/2]

ms_http_client ( const ms_http_client & src )
Parameters
src is the source to initialise from

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ baseUrl()

std::string baseUrl ( ) const

Returns the base URL for the Mascot server.

This typically ends with '/cgi/'.

Returns
The URL of the Mascot server CGI directory. For example "http://your-server/mascot/cgi/".

◆ changePassword()

ms_http_client::ChangePasswordResultCode changePassword | ( | const std::string & | username,
 |  | const std::string & | oldPassword,
 |  | const std::string & | newPassword
 | ) |  |

Change the password for a user. The user's old password must be supplied.

The function is implemented by calling ms_http_helper::httpGetString with the command:

login.pl?action=newpassword&username=username&password=oldPassword&newpw1=newPassword&newpw2=newPassword

Parameters
username | The name of the user for whom the password is to be changed.
oldPassword | The current (before the change) password for the user.
newPassword | The new password that is to be set for the user.
Returns
The final result of the attempt to change the password.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ connectionSettings()

ms_connection_settings connectionSettings ( ) const

Returns the HTTP connection settings.

Returns
Settings that control the HTTP connection to the Mascot server.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_http_client * right )
Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getIsDatabaseActive()

bool getIsDatabaseActive | ( | const std::string & | databaseName,
 |  | bool & | returnIsActive
 | ) |  |

Queries whether the specified database is available for searching. Returns true if successful.

If the function fails then the return value is false; error messages may be retrieved from the ms_errors base class.

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?db_active&db_name=databaseName

If the databaseName is not available for searching on the server, the function can still return true, but returnIsActive will be false.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | databaseName | The name of the database to look for on the Mascot server.
[out] | returnIsActive | Returns true if the named database is available on the Mascot server.
Returns
True if the function completed successfully.

◆ getIsSecurityEnabled()

bool getIsSecurityEnabled | ( | bool & | returnIsSecurityEnabled,
 |  | std::string & | returnUnsecuredSessionId
 | ) |  |

Determine if Mascot Security is enabled on the Mascot Server.

If the function fails then the return value is false; error messages may be retrieved from the ms_errors base class.

The function is implemented by calling ms_http_helper::httpGetString with the command:

login.pl?action=issecuritydisabled

If security is disabled then the session ID 'all_secdisabledsession ' will be returned in returnUnsecuredSessionId. If security is enabled, then an empty string will be returned, even if the guest account is enabled. See matrix_science::ms_session for further information.

Many client applications will not need to call this function but it is useful for determining if it is necessary to prompt the user for a username and password.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | returnIsSecurityEnabled | Returns true if security is enabled. This is only valid if the function succeeds.
[out] | returnUnsecuredSessionId | Returns a session ID or an empty string. If security is disabled, this will return all_secdisabledsession This value is only valid if the function succeeds.
Returns
True if the function completed successfully.

◆ getIsWebAuthenticationEnabled()

bool getIsWebAuthenticationEnabled | ( | bool & | returnIsWebAuthenticationEnabled,
 |  | std::string & | returnWebAuthenticatedSessionId
 | ) |  |

Determine if Mascot Security is setup to use Web Authentication.

If the function fails then the return value is false; error messages may be retrieved from the ms_errors base class.

The function is implemented by calling ms_http_helper::httpGetString with the command:

login.pl?action=webauthentication

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | returnIsWebAuthenticationEnabled | Returns true if web authentication is enabled for the user logged into the web server.
[out] | returnWebAuthenticatedSessionId | Returns a session ID that can be used, or blank if web authentication failed or is not enabled for this user. This is only valid if the function succeeds.
Returns
True if the function completed successfully.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getOsName()

bool getOsName ( std::string & osname )

Queries the operating system running on the server. Returns true if successful.

If the function fails then the return value is false; error messages may be retrieved from the ms_errors base class.

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?osname

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] osname Returns name of the Mascot server's operating system; either 'linux' or 'MSWin32'
Returns
True if the function completed successfully.

◆ getVersion()

bool getVersion | ( | int & | major,
 |  | int & | minor,
 |  | int & | part3,
 |  | int & | part4
 | ) |  |

Queries the version of Mascot running on the server. Returns true if successful.

If the version returned by the Mascot server does not contain all four parts, the remaining parts are set to zero.

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?version

If the function fails then the return value is false; error messages may be retrieved from the ms_errors base class.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | major | Returns the major version number. For example, version 2.4.1.24 would return 2.
[out] | minor | Returns the minor version number. For example, version 2.4.1.24 would return 4.
[out] | part3 | Returns part 3 of the version number. For example, version 2.4.1.24 would return 1.
[out] | part4 | Returns part 4 of the version number. For example, version 2.4.1.24 would return 24.
Returns
True if the function completed successfully.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_http_client & operator= ( const ms_http_client & right )
Parameters
right is the source to initialise from
Returns
reference to the current object

◆ setBaseUrl()

void setBaseUrl ( const std::string & baseUrl )

Sets the base URL for the Mascot server.

This typically ends with '/cgi/'. The baseUrl would normally be passed in the constructor.

Parameters
baseUrl The URL of the Mascot server CGI directory.

◆ setConnectionSettings()

void setConnectionSettings ( const ms_connection_settings & settings )

Sets the HTTP connection settings.

The settings control the HTTP connection to the Mascot server.

Parameters
settings The new settings for the server connection.

◆ userLogin()

ms_http_client::LoginResultCode userLogin | ( | const std::string & | username,
 |  | const std::string & | password,
 |  | ms_http_client_session & | returnSession
 | ) |  |

Attempts to log into the Mascot server using the supplied credentials.

If security is disabled on the Mascot server (or the server version is 2.1 or earlier) then the supplied username and password are ignored and an anonymous session is created.

If a username is supplied then the username and password combination will be authenticated on the Mascot server before a session is created.

If no username is supplied, a session using web authentication will be attempted. This can only succeed if the user name supplied for web server authentication matches a user name configured in Mascot security as a web authenticated user.

If no username is supplied and web authentication fails, a session using the guest account will be attempted (however, the guest account may be disabled, in which case the function will fail).

The logging level and logging file (if any) in the returnSession are set to be the same as in the ms_http_client object. Any existing errors in returnSession are cleared.

The function is implemented by calling ms_http_helper::httpGetString with a number of different commands, for example:

login.pl?action=login&username=username&password=password

Parameters
[in] | username | The name of the user to login with, or blank for a web authenticated or anonymous session.
[in] | password | The password associated with the user name.
[out] | returnSession | Returns a session if the login was successful. The ms_http_client_session object passed should be created using the default constructor and when calling from Perl, pass the object in the parameter list.
Returns
The result of the Mascot login attempt.
The documentation for this class was generated from the following files:
  • ms_http_client.hpp
  • ms_http_client.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_client_mime Class Reference

  • matrix_science
  • ms_http_client_mime
Public Member Functions | Static Public Member Functions | List of all members
ms_http_client_mime Class Reference
Accessing a Mascot Server using HTTP

The class eases the building of a MIME section. More...

#include <ms_http_client_mime.hpp>

Public Member Functions

virtual | ~ms_http_client_mime ()
Destructor. HTTP Communication to a Mascot Server.
void | append (const std::string &name, const std::string &value)
Adds a name-value pair element to the end of the MIME string.
void | appendFile (const std::string &name, const std::string &filename, const std::string &contentType, const std::string &prefixData="")
Adds a name-value pair element with a filename attribute to the end of the MIME string.
void | erase (int oneBasedIndex)
Remove an element.
std::string | format (const std::string &boundary, matrix_science::ms_http_client_mime::Continuation continuation) const
Gets the complete MIME string.
int | getCount () const
Returns the number of items.
std::string | getFilename (int oneBasedIndex) const
Returns the filename attribute of an item.
std::string | getName (int oneBasedIndex) const
Returns the name of an item.
std::string | getValue (int oneBasedIndex) const
Returns the value of an item.
bool | hasFilename (int oneBasedIndex) const
Returns true if the item has a filename attribute.
void | setValue (int oneBasedIndex, const std::string &value)
Change the value of an element.
void | setValueWithFilename (int oneBasedIndex, const std::string &value, const std::string &filename, const std::string &contentType)
Change the value of an element and set a filename attribute on it.

Static Public Member Functions

static std::string formatHeader (const std::string &boundary, ContentType contentType)
Gets the MIME header string.

Detailed Description

The class eases the building of a MIME section.

Each element can be added individually as a name-value pair. The MIME content text can then be retrieved.

The text can have a MIME terminator added, as required.

The boundary string can be changed if desired.

Constructor & Destructor Documentation

◆ ~ms_http_client_mime()

~ms_http_client_mime ( )
virtual

Destructor. HTTP Communication to a Mascot Server.

Called automatically.

Member Function Documentation

◆ append()

void append | ( | const std::string & | name,
 |  | const std::string & | value
 | ) |  |

Adds a name-value pair element to the end of the MIME string.

Parameters
name | The name of the item.
value | The value of the item.

◆ appendFile()

void appendFile | ( | const std::string & | name,
 |  | const std::string & | filename,
 |  | const std::string & | contentType,
 |  | const std::string & | prefixData = ""
 | ) |  |

Adds a name-value pair element with a filename attribute to the end of the MIME string.

Parameters
name | The name of the item.
filename | The filename specified for the item.
contentType | The MIME type string for the type of content (e.g. "text/xml").
prefixData | The filename specified for the item. Data added to the start of the file. Optional.

◆ erase()

void erase ( int oneBasedIndex )

Remove an element.

Parameters
oneBasedIndex The index is 1..Count() inclusive (not zero based).

◆ format()

std::string format | ( | const std::string & | boundary,
 |  | matrix_science::ms_http_client_mime::Continuation | continuation
 | ) |  | const

Gets the complete MIME string.

Parameters
boundary | The string to be used as a separator between MIME sections.
continuation | Indicates whether the MIME content will be continued after this section, or whether the MIME terminates here (and should have a terminator boundary appended).
Returns
The formatted MIME text.

◆ formatHeader()

std::string formatHeader | ( | const std::string & | boundary,
 |  | ContentType | contentType
 | ) |  |
static

Gets the MIME header string.

The header consists of a content type and a boundary.

For example, "Content-Type: multipart/mixed; boundary=----------MascotMimeContent"

Parameters
boundary | The string to be used as a separator between MIME sections.
contentType | The type of content in the MIME; typically "multipart/form-data" or "multipart/mixed".
Returns
formatted header

◆ getCount()

int getCount ( ) const

Returns the number of items.

Returns
The number of items present.

◆ getFilename()

std::string getFilename ( int oneBasedIndex ) const

Returns the filename attribute of an item.

Parameters
oneBasedIndex The index is 1..Count() inclusive (not zero based).
Returns
file name from index

◆ getName()

std::string getName ( int oneBasedIndex ) const

Returns the name of an item.

Parameters
oneBasedIndex The index is 1..Count() inclusive (not zero based).
Returns
name from index

◆ getValue()

std::string getValue ( int oneBasedIndex ) const

Returns the value of an item.

Parameters
oneBasedIndex The index is 1..Count() inclusive (not zero based).
Returns
value from index

◆ hasFilename()

bool hasFilename ( int oneBasedIndex ) const

Returns true if the item has a filename attribute.

Parameters
oneBasedIndex The index is 1..Count() inclusive (not zero based).
Returns
file name from index

◆ setValue()

void setValue | ( | int | oneBasedIndex,
 |  | const std::string & | value
 | ) |  |

Change the value of an element.

Parameters
oneBasedIndex | The index is 1..Count() inclusive (not zero based).
value | The new value for the element.

Any filename attribute wil be removed.

◆ setValueWithFilename()

void setValueWithFilename | ( | int | oneBasedIndex,
 |  | const std::string & | value,
 |  | const std::string & | filename,
 |  | const std::string & | contentType
 | ) |  |

Change the value of an element and set a filename attribute on it.

Parameters
oneBasedIndex | The index is 1..Count() inclusive (not zero based).
value | The value of the element.
filename | The name to be given to the MIME file.
contentType | The MIME type string for the type of content (e.g. "text/xml").
The documentation for this class was generated from the following files:
  • ms_http_client_mime.hpp
  • ms_http_client_mime.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_client_search Class Reference

  • matrix_science
  • ms_http_client_search
Public Types | Public Member Functions | List of all members
ms_http_client_search Class Reference
Accessing a Mascot Server using HTTP

Used for submitting searches to a Mascot server and retrieving search results using HTTP(S). More...

#include <ms_http_client_search.hpp>

Inheritance diagram for ms_http_client_search:
[legend]
Collaboration diagram for ms_http_client_search:
[legend]

Public Types

enum DownloadOption {
DO_NORMAL = 0 ,
DO_WITH_IONS = 1
}
Definitions for downloading results. More...
enum ReportTopSpecialValues {
RT_auto = 0 ,
RT_file = -1
}
Definitions for special 'report top' values when requesting results in XML format. More...
enum SearchStatusCode {
SS_UNKNOWN ,
SS_ASSIGNED ,
SS_QUEUED ,
SS_RUNNING ,
SS_COMPLETE ,
SS_ERROR ,
SS_SEARCH_CONTROL_ERROR
}
Definitions for the various states possible when querying about a running Mascot search. More...
enum UploadResponseCode {
UR_SUCCESS ,
UR_ACCESS_DENIED ,
UR_INVALID_TASKID ,
UR_NO_RESULT_FILENAME ,
UR_NO_RESULT_FILE ,
UR_FILE_ALREADY_EXISTS ,
UR_ERROR
}
Definitions for the various responses possible when uploading data to Mascot. More...

Public Member Functions

ms_http_client_search (const ms_http_client_search &src)
ms_http_client_search (ms_http_client_session &session, const std::string &searchTaskId)
Access previously run search results.
virtual | ~ms_http_client_search ()
Destructor;.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_http_client_search *right)
bool | downloadDaemonResultsFile (std::string filename, ms_http_helper_progress &progress)
Download the summary results of a search in the format used by Mascot Daemon.
bool | downloadPercolatorFile (std::string filename, ms_http_helper_progress &progress)
Download the Percolator input and output files for the associated search.
bool | downloadResultsFile (std::string filename, ms_http_helper_progress &progress, DownloadOption options=DO_WITH_IONS)
Download the results in dat28 (MIME) format.
bool | downloadResultsFileMSR (std::string filename, ms_http_helper_progress &progress, DownloadOption options=DO_WITH_IONS)
Download the results in Mascot Search Results (MSR) format.
bool | downloadXmlResultsFile (std::string filename, ms_http_helper_progress &progress, int reportTop=RT_auto)
Download the results of the search in XML format.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getResultsFileName (std::string &returnFileName)
Return the path to the result file on the server (usually relative to the cgi directory).
std::string | getSearchTaskID () const
Get the task ID of the associated Mascot search.
std::string | getSessionID () const
Get the associated session ID.
bool | getStage (std::string &stage, int &step)
Return the current stage and step of the search (Mascot 2.8.1 or later required).
bool | getStatus (SearchStatusCode &returnCode, int &statusValue)
Return the current status of the search.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_http_client_search & | operator= (const ms_http_client_search &right)
std::string | sessionId () const
Get the associated session ID.
bool | uploadDistillerXmlResultsFile (std::string filename, UploadResponseCode &responseCode, std::string &responseText)
Upload a Mascot Distiller quantitation XML file to the server.

Detailed Description

Used for submitting searches to a Mascot server and retrieving search results using HTTP(S).

Use ms_http_client_search to follow the progress of a new search as it runs on the Mascot server and to retrieve the results from both new searches and old searches stored on the server.

The Mascot search must be run on the server within a Mascot session created by ms_http_client_session.

A previous search can be accessed by constructing a ms_http_client_search with a task identifier.

Member Enumeration Documentation

◆ DownloadOption

enum DownloadOption

Definitions for downloading results.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
DO_NORMAL | Downloads a compressed results file with the peak list data removed. This is the normal download mode for Mascot Distiller, but most other applications should use DO_WITH_IONS.
DO_WITH_IONS | Download the complete results file. The file is downloaded as uncompressed text.

◆ ReportTopSpecialValues

enum ReportTopSpecialValues

Definitions for special 'report top' values when requesting results in XML format.

Otherwise can use a small positive integer (eg 1..50) See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
RT_auto | Automatically determine the number of protein hits included in the report.
RT_file | Honour the number of hits specified when the search was submitted.

◆ SearchStatusCode

enum SearchStatusCode

Definitions for the various states possible when querying about a running Mascot search.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
SS_UNKNOWN | The search task ID was not recognised as a recent Mascot task.
SS_ASSIGNED | The search task has been assigned but no search has been submitted.
SS_QUEUED | The search has been submitted, but it has been queued by the server.
SS_RUNNING | The search has started. The approximate percentage that has been completed is available.
SS_COMPLETE | The search has completed.
SS_ERROR | An error occurred when running the search. The Mascot error number is available from the getStatus call.
SS_SEARCH_CONTROL_ERROR | An error has occurred in the Mascot server application trying to get the search status. The error code is available and is documented in the Mascot Installation and Setup Manual (For example, ERR_TASKID_FAILOPEN = 1)

◆ UploadResponseCode

enum UploadResponseCode

Definitions for the various responses possible when uploading data to Mascot.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
UR_SUCCESS | The upload completed successfully.
UR_ACCESS_DENIED | The upload was not permitted by Mascot Security.
UR_INVALID_TASKID | The upload failed due to not having a task identifier.
UR_NO_RESULT_FILENAME | The upload failed due to not having a result file name.
UR_NO_RESULT_FILE | The upload failed due to the result file not existing.
UR_FILE_ALREADY_EXISTS | The upload failed because the file already exists.
UR_ERROR | The upload failed due to an unspecified error.

Constructor & Destructor Documentation

◆ ms_http_client_search() [1/2]

ms_http_client_search | ( | ms_http_client_session & | session,
 |  | const std::string & | searchTaskId
 | ) |  |

Access previously run search results.

This constructor does not validate the searchTaskId or session and does not call any scripts on the Mascot Server. It is recommended that getStatus() is called before calling other functions so that the searchTaskId and session can be validated.

Parameters
session | The associated session object.
searchTaskId | The Mascot task identifier used for the associated search.

◆ ~ms_http_client_search()

~ms_http_client_search ( )
virtual

Destructor;.

Called automatically.

◆ ms_http_client_search() [2/2]

ms_http_client_search ( const ms_http_client_search & src )
Parameters
src is the source to initialise from

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_http_client_search * right )

The session object is copied, it is not created anew, cf the other constructors

Parameters
right is the source to initialise from

◆ downloadDaemonResultsFile()

bool downloadDaemonResultsFile | ( | std::string | filename,
 |  | ms_http_helper_progress & | progress
 | ) |  |

Download the summary results of a search in the format used by Mascot Daemon.

Parameters
filename | The name of the local file for the results to be written to.
progress | The progress information is maintained as the data is downloaded from the server. The download may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
Returns
Returns true if the function completed successfully.

◆ downloadPercolatorFile()

bool downloadPercolatorFile | ( | std::string | filename,
 |  | ms_http_helper_progress & | progress
 | ) |  |

Download the Percolator input and output files for the associated search.

Parameters
filename | The name of the local file for the results to be written to.
progress | The progress information is maintained as the data is downloaded from the server. The download may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
Returns
Returns true if the function completed successfully.

◆ downloadResultsFile()

bool downloadResultsFile | ( | std::string | filename,
 |  | ms_http_helper_progress & | progress,
 |  | DownloadOption | options = DO_WITH_IONS
 | ) |  |

Download the results in dat28 (MIME) format.

It is safest to call getStatus() before calling this function to validate the searchTaskId, because this function has more limited error reporting.

The results data is downloaded as dat28 (MIME) format file. This is the F1234.dat format created by Mascot Server 2.8 and earlier. See ms_http_client_search::downloadResultsFileMSR() for downloading the data in the Mascot Search Results (MSR) format, introduced in Mascot Server 3.0.

Downloading can fail if the task ID doesn't exist or there is some other server-side problem. These are reported as "problem=" lines by Mascot. In this case, downloadResultsFile() saves the text in filename and returns true (not false!) because the HTTP(S) transfer did succeed.

The caller should always check the file contents: 1) If it's a gzipped file, uncompress it; 2) if it starts with "problem=", report the error string; and 3) finally, use ms_mascotresfilebase::resfileType() to detect the file type.

Error conditions for HTTP(S) transfer:

  • ms_errs::ERR_MSP_HTTP_NORESPONSE - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_TRANSMISSION_FAILED - if HTTP(s) transfer fails
  • ms_errs::ERR_MSP_HTTP_OPENSESSIONFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_CLOSESESSIONFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_OPENCONNECTIONFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_CLOSECONNECTIONFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_OPENREQUESTFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_CLOSEREQUESTFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_QUERYSTATUSFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_OPENOUTPUTFILEFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_DOWNLOADFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_ABORTEDBYUSER - if aborted by user
Parameters
filename | The name of the local file for the results to be written to.
progress | The progress information is maintained as the data is downloaded from the server. The download may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
options | This contains the bit flags that controls how the file will be downloaded. It should be DO_NORMAL or a bitwise accumulation (boolean OR) of the other flags.
Returns
Returns true if the function completed successfully.

◆ downloadResultsFileMSR()

bool downloadResultsFileMSR | ( | std::string | filename,
 |  | ms_http_helper_progress & | progress,
 |  | DownloadOption | options = DO_WITH_IONS
 | ) |  |

Download the results in Mascot Search Results (MSR) format.

It is safest to call getStatus() before calling this function to validate the searchTaskId. This function has more limited error reporting.

The results data is saved as Mascot Search Results (MSR) file. This is an SQLite database, introduced in Mascot Server 3.0. See ms_http_client_search::downloadResultsFile() for downloading the data in the traditional, dat28 (MIME) format.

The data sent by the server is an SQL dump, which is saved in a temporary file in the same location as filename. If download succeeds, the MSR file is restored from the SQL dump and saved as filename. The temporary file is removed in both cases.

Downloading the results as MSR may fail if 1) the server is Mascot Server 2.8 or earlier or 2) if creating MSR files has been disabled by a configuration option. In this case, try ms_http_client_search::downloadResultsFile(), which should always succeed.

Downloading can fail if the task ID doesn't exist or there is some other server-side problem. These are reported as "problem=" lines by Mascot. In this case, downloadResultsFileMSR() reports the problem string as a fatal error and returns false. Note: This behaviour is different from downloadResultsFile(), which saves string in the output file and returns true if there is a "problem=" line.

The caller should always check the file contents using ms_mascotresfilebase::resfileType() to confirm it is an MSR file.

Error conditions for HTTP(S) transfer:

  • ms_errs::ERR_MSP_HTTP_NORESPONSE - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_TRANSMISSION_FAILED - if HTTP(s) transfer fails
  • ms_errs::ERR_MSP_HTTP_OPENSESSIONFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_CLOSESESSIONFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_OPENCONNECTIONFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_CLOSECONNECTIONFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_OPENREQUESTFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_CLOSEREQUESTFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_QUERYSTATUSFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_OPENOUTPUTFILEFAILED - if HTTP(S) transfer fails
  • ms_errs::ERR_MSP_HTTP_DOWNLOADFAILED - if HTTP(S) transfer fails or there is a "problem=" line
  • ms_errs::ERR_MSP_HTTP_ABORTEDBYUSER - if aborted by user

Error conditions for restoring the file from the SQL dump:

  • ms_errs::ERR_MSP_FAILED_TO_OPEN_FILE - if failing to open temp file
  • ms_errs::ERR_MSP_FAILED_TO_READ_FILE - if failing to read from temp file
  • ms_errs::ERR_MSP_MSR_CREATING_FILE - if failing to create the target file
  • ms_errs::ERR_MSP_MSR_WRITING_FILE - if failing to write to the target file
  • ms_zip::decompressMore() error conditions - if input is gzipped and fails to decompress
  • ms_errs::ERR_MSP_HTTP_ABORTEDBYUSER - if aborted by user
Parameters
filename | The name of the local file for the results to be written to.
progress | Progress information for the data downloaded from the server. The download and post-processing may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
options | This contains the bit flags that controls how the file will be downloaded. It should be DO_NORMAL or a bitwise accumulation (boolean OR) of the other flags.
Returns
Returns true if the function completed successfully.

◆ downloadXmlResultsFile()

bool downloadXmlResultsFile | ( | std::string | filename,
 |  | ms_http_helper_progress & | progress,
 |  | int | reportTop = RT_auto
 | ) |  |

Download the results of the search in XML format.

Use of this function is deprecated. Use downloadResultsFile instead.

Parameters
filename | The name of the local file for the results to be written to.
progress | The progress information is maintained as the data is downloaded from the server. The download may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
reportTop | The number of protein hits to include in the results.
Returns
Returns true if the function completed successfully.

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getResultsFileName()

bool getResultsFileName ( std::string & returnFileName )

Return the path to the result file on the server (usually relative to the cgi directory).

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?result_file_name&task_id=searchTaskId

If the function fails because an invalid searchTaskId has been set, then the function will return false, returnFileName will be empty and the ms_errs::ERR_MSP_HTTP_GETRESULTSFILENAME error will be set.

It is safest to call getStatus() before calling this function to validate the searchTaskId etc. because this function has more limited error reporting.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] returnFileName Returns the path to the result file on the server (usually relative to the cgi directory).
Returns
Returns true if the function completed successfully.

◆ getSearchTaskID()

std::string getSearchTaskID ( ) const

Get the task ID of the associated Mascot search.

Returns
The Mascot task identifier used for the associated search.

◆ getSessionID()

std::string getSessionID ( ) const

Get the associated session ID.

Returns
The associated Mascot Server session ID.

◆ getStage()

bool getStage | ( | std::string & | stage,
 |  | int & | step
 | ) |  |

Return the current stage and step of the search (Mascot 2.8.1 or later required).

Can be called regularly while a submitted search is runing in order to determine search stage.

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?status_current_stage&task_id=searchTaskId

If the function fails because an invalid searchTaskId has been set, or if the Mascot Server version is earlier than 2.8.1 then the function will return false, stage will be empty and step set to -1 and the ms_errs::ERR_MSP_HTTP_GETSEARCHSTAGE error will be set.

It is safest to call getStatus() before calling this function to validate the searchTaskId etc. because this function has more limited error reporting.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | stage | Returns the search stage text
[out] | step | Returns the search stage step
Returns
Returns true if the function completed successfully.

◆ getStatus()

bool getStatus | ( | SearchStatusCode & | returnCode,
 |  | int & | statusValue
 | ) |  |

Return the current status of the search.

Can be called regularly while a submitted search is runing in order to determine status.

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?status&task_id=searchTaskId

The value returned in statusValue depends on the returnCode:

  • SS_UNKNOWN - statusValue will be 0
  • SS_ASSIGNED - statusValue will be 0
  • SS_ERROR -
    • a positive statusValue will be a Mascot Error code. A full list of value are available here
    • A statusValue of -1 indicates that the search crashed without an error.
    • A statusValue of -2 indicates that the search was terminated by a user.
  • SS_QUEUED - statusValue will be 0
  • SS_RUNNING - statusValue will be the percentage complete for the search.
  • SS_COMPLETE - statusValue will be 0
  • SS_SEARCH_CONTROL_ERROR - statusValue will be:
    • ERR_TASKID_NOERROR = 0
    • ERR_TASKID_FAILOPEN = 1
    • ERR_TASKID_FAILCREATE = 2
    • ERR_TASKID_FAILREAD = 3
    • ERR_TASKID_FAILWRITE = 4
    • ERR_TASKID_FAILCLOSE = 5
    • ERR_TASKID_CHANGEDRECORD = 6
    • ERR_TASKID_INVALIDMASCOTDAT = 7
    • ERR_TASKID_MISSINGRESULTSFILE = 8
    • ERR_TASKID_FILENAMETOOLONG = 9
    • ERR_TASKID_SESSIONTIMEDOUT = 10
    • ERR_TASKID_PERMISSIONDENIED = 11

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | returnCode | Returns the current status code of the search task.
[out] | statusValue | Returns an optional value depending on the returnCode.
Returns
Returns true if the function completed successfully.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

ms_http_client_search & operator= ( const ms_http_client_search & right )
Parameters
right is the source to initialise from
Returns
reference to the current object

◆ sessionId()

std::string sessionId ( ) const
inline

Get the associated session ID.

Deprecated:
Use getSessionID()
Returns
session id

◆ uploadDistillerXmlResultsFile()

bool uploadDistillerXmlResultsFile | ( | std::string | filename,
 |  | ms_http_client_search::UploadResponseCode & | responseCode,
 |  | std::string & | responseText
 | ) |  |

Upload a Mascot Distiller quantitation XML file to the server.

Uploads a Mascot Distiller quantitation XML file to the Mascot Server.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | filename | The path of the file to be uploaded.
[out] | responseCode | If the return value is true then this should be checked to see if the upload was accepted as valid.
[out] | responseText | The response from the Mascot server.
Returns
Returns true if the file was uploaded, not whether the upload was accepted as valid.
The documentation for this class was generated from the following files:
  • ms_http_client_search.hpp
  • ms_http_client_search.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_client_session Class Reference

  • matrix_science
  • ms_http_client_session
Public Types | Public Member Functions | List of all members
ms_http_client_session Class Reference
Accessing a Mascot Server using HTTP

This gives access to a Mascot session so searches may be submitted. More...

#include <ms_http_client_session.hpp>

Inheritance diagram for ms_http_client_session:
[legend]
Collaboration diagram for ms_http_client_session:
[legend]

Public Types

enum SequenceShowOptions {
SHOW_PI = 0x0001 ,
SHOW_TITLE = 0x0002 ,
SHOW_LENGTH = 0x0004 ,
SHOW_SEQUENCE = 0x0008 ,
SHOW_REFERENCE = 0x0010 ,
SHOW_NONE = 0 ,
SHOW_ALL = 0xFFFF
}
Information to include in a request for sequence data. More...

Public Member Functions

ms_http_client_session ()
Create an empty session.
ms_http_client_session (const ms_http_client_session &src)
ms_http_client_session (const ms_http_helper connection, const std::string sessionId)
Construct a session object that can be used to access the Mascot Server.
virtual | ~ms_http_client_session ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_http_client_session *right)
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
bool | getIsPermitted (ms_security_tasks::TASKID taskType, bool &returnIsPermitted)
Returns true if the security token is allowed for this session.
bool | getIsXmlUploadedList (const std::vector< std::string > &taskIds, std::vector< int > &xmlUploaded)
Queries if the specified searches have had Mascot Distiller quantitation XML uploaded.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getSequenceFile (const std::string &database, const std::vector< std::string > &accessionNames, const std::vector< int > &accessionFrames, const std::string &filename, const SequenceShowOptions options=SHOW_ALL)
Download sequence information for a set of accessions.
std::string | getSessionID () const
Returns the Mascot session ID.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | logout ()
Close the Mascot session.
ms_http_client_session & | operator= (const ms_http_client_session &right)
bool | submitSearch (ms_http_client_search &returnTask, const std::string &httpHeader, const std::string &prologue, const std::string &filename, const std::string &epilogue, ms_http_helper_progress &progress, bool batch=false)
Submit a search to the Mascot server.

Detailed Description

This gives access to a Mascot session so searches may be submitted.

Create an ms_http_client_session object by calling: ms_http_client::userLogin and this object can then be used to submit a search by calling ms_http_client_session::submitSearch

Multiple searches and data requests may be made using the same ms_http_client_session. When access to the Mascot Server is complete, call logout

Server side documentation for sessions is here

Member Enumeration Documentation

◆ SequenceShowOptions

enum SequenceShowOptions

Information to include in a request for sequence data.

Add the flags together to include multiple data items per sequence. Pass the enum to getSequenceFile

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
SHOW_PI | Show the isoelectric point (as a pH).
SHOW_TITLE | Show the single-line title.
SHOW_LENGTH | Show the length of the sequence.
SHOW_SEQUENCE | Show the sequence itself.
SHOW_REFERENCE | Show the full entry annotation text.
SHOW_NONE | Show none of the information.
SHOW_ALL | Show all available information.

Constructor & Destructor Documentation

◆ ms_http_client_session() [1/3]

ms_http_client_session ( )

Create an empty session.

Create an empty session. This is normally passed to ms_http_client::userLogin to populate it.

◆ ms_http_client_session() [2/3]

ms_http_client_session | ( | const ms_http_helper | connection,
 |  | const std::string | sessionId
 | ) |  |

Construct a session object that can be used to access the Mascot Server.

This is used internally by ms_http_client and should not normally be called by a client application.

Parameters
connection | The associated ms_http_helper.
sessionId | The Mascot Server session ID.

◆ ~ms_http_client_session()

~ms_http_client_session ( )
virtual

Destructor.

This tidies up any HTTP connection that is still open by calling logout() if necessary.

◆ ms_http_client_session() [3/3]

ms_http_client_session ( const ms_http_client_session & src )
Parameters
src is the source to initialise from

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_http_client_session * right )
Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getIsPermitted()

bool getIsPermitted | ( | ms_security_tasks::TASKID | taskType,
 |  | bool & | returnIsPermitted
 | ) |  |

Returns true if the security token is allowed for this session.

Permissions are set in the Mascot Security Administration pages.

The most relevant tokens for third party clients are:

  • SECTASK_ALLOWPMF - Allow pmf searches.
  • SECTASK_ALLOWMSMS - Allow ms/ms (and SQ) searches.
  • SECTASK_ALLOWMSMSNOENZYME - Allow ms/ms no enzyme searches.
  • SECTASK_ALLOWPMFNOENZYME - Allow no enzyme pmf searches.
  • SECTASK_ALLFASTA - Allow all fasta databases to be searched.
  • SECTASK_NAMEDFASTA - Special fasta databases that override the default setting.
  • SECTASK_DAEMONCLIENT - Mascot Daemon is allowed to submit searches.
  • SECTASK_DISTILLERCLIENT - Mascot Distiller is allowed to submit searches.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | taskType | The security token being queried.
[out] | returnIsPermitted | Returns true if the security task type is permitted on this session, false if not.
Returns
Returns true if the function completed successfully.

◆ getIsXmlUploadedList()

bool getIsXmlUploadedList | ( | const std::vector< std::string > & | taskIds,
 |  | std::vector< int > & | xmlUploaded
 | ) |  |

Queries if the specified searches have had Mascot Distiller quantitation XML uploaded.

The query can be for any number of searches. If the number of searches is too large for a single query to the server then multiple queries will be made.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | taskIds | The task IDs of the searches.
[out] | xmlUploaded | Set to the same size as taskIds. Non-zero if Mascot Distiller quantitation XML has been uploaded for that search.
Returns
True if the query completed successfully.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getSequenceFile()

bool getSequenceFile | ( | const std::string & | database,
 |  | const std::vector< std::string > & | accessionNames,
 |  | const std::vector< int > & | accessionFrames,
 |  | const std::string & | filename,
 |  | const SequenceShowOptions | options = SHOW_ALL
 | ) |  |

Download sequence information for a set of accessions.

The retrieved file is in XML.

If the database is not active on the Mascot server then the body opf the XML document will be empty.

The frame number is used if the frames collection has an entry for a name and it is not -1.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters
database | The name of the database on the Mascot server fromn which the data is to be retrieved.
accessionNames | A collection of accession names for the peptides or NA sequences to be retrieved.
accessionFrames | A collection of frames. This only has meaning for an NA database. 0 means return the NA sequence. A number between 1 and 6 means translate the NA sequence in that frame and return the AA sequence.
filename | The name of the local file to be populated with the retrieved information. S
options | The types of information to be included in the output file.
Returns
Returns true if the function completed successfully.

◆ getSessionID()

std::string getSessionID ( ) const

Returns the Mascot session ID.

This may change during any call that accesses the Mascot server as the session on the server may have expired and a new one will be automatically created.

Returns
the current session id

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ logout()

bool logout ( )

Close the Mascot session.

Called automatically by the destructor.

You must login again to create a new Mascot session in order to use the Mascot server again.

Returns
The final result of the attempt to logout.

◆ operator=()

ms_http_client_session & operator= ( const ms_http_client_session & right )
Parameters
right is the source to initialise from
Returns
reference to the current object

◆ submitSearch()

bool submitSearch | ( | ms_http_client_search & | returnTask,
 |  | const std::string & | httpHeader,
 |  | const std::string & | prologue,
 |  | const std::string & | filename,
 |  | const std::string & | epilogue,
 |  | ms_http_helper_progress & | progress,
 |  | bool | batch = false
 | ) |  |

Submit a search to the Mascot server.

The search is submitted using a POST request to the search executable (normally nph-mascot.exe) on the Mascot Server.

This function makes http calls to the Mascot Server to create a unique taskID and this is returned in the ms_http_client_search object and can be accessed using ms_http_client_search::getSearchTaskID . The name of the search application in use on the Mascot server is also retrieved from the server as part of this process.

The search parameters and peak list are combined into a MIME format file using the prologue, filename and epilogue parameters.

This function normally only returns when all the data has been sent. If the abort submission function is called then it will stop sending data at a convenient point and return early.

The logging level and logging file (if any) in the returnTask are set to be the same as in the ms_http_client_session object. Any existing errors in returnTask are cleared.

Parameters
returnTask | The search object that can be used to monitor progress and then retrieve results. See Maintaining object references: two rules of thumb.
httpHeader | The HTTP header line, specifying the content type and the MIME separator string. For example: "Content-Type: multipart/mixed; boundary=---------FormBoundary4C9ByKKVofH"
prologue | Text sent as the first part of the content of the HTTP POST. This will normally contain the search parameters. For an example, see http_client.pl
filename | The name of a file, the content of which is sent after the prologue text and before the epilogue text. This can be an MGF or other peak list data file.
epilogue | Text sent as the last part of the content of the HTTP POST. For example, "-----------FormBoundary4C9ByKKVofH--"
progress | The progress information is maintained as the data is uploaded to the server. The upload may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
batch | If true, the search will be submitted with the -batch switch, which will keep the search alive on IIS if the connection is broken. This can only be used with Mascot 2.5 or later, and will cause an error if set to true when submitting a search on an older version of Mascot [default=false].
Returns
Returns true if the function completed successfully.
The documentation for this class was generated from the following files:
  • ms_http_client_session.hpp
  • ms_http_client_session.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper Class Reference

  • matrix_science
  • ms_http_helper
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_http_helper Class Reference
Accessing a Mascot Server using HTTP

The class provides HTTP, FTP and FILE protocol access to a server. More...

#include <ms_http_helper.hpp>

Inheritance diagram for ms_http_helper:
[legend]
Collaboration diagram for ms_http_helper:
[legend]

Public Types

enum FileMode {
FM_binary ,
FM_text
}
Definitions for types of file content transfer. More...

Public Member Functions

ms_http_helper ()
C++ STL collection support.
ms_http_helper (const ms_http_helper &copy)
Copy constructor.
ms_http_helper (const std::string &baseUrl, const ms_connection_settings &settings)
Constructor for a connection to a server.
~ms_http_helper ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
const std::string & | baseUrl () const
Returns the base URL to the server.
void | clearAllErrors ()
Remove all errors from the current list of errors.
const ms_connection_settings & | connectionSettings () const
Returns the internet settings used for the HTTP connection.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_http_helper *right)
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getProxyConfig (std::vector< std::string > &proxyServers, std::vector< std::string > &proxyUsernames, std::vector< std::string > &proxyPasswords)
Get the proxy server configuration settings.
ms_http_helper_return httpBufferedClose ()
Closes the current buffered read session.
ms_http_helper_return | httpBufferedGetString (std::string &httpBuffer, unsigned long requiredSize)
Get available data from the open session. Writes data into the supplied buffer up to at least the required size.
ms_http_helper_return | httpBufferedOpen (const std::string &action)
Creates and opens a session for buffered reading from the supplied base URL and action.
ms_http_helper_return | httpGetFile (const std::string &action, const std::string &filename, ms_http_helper_progress &progress, FileMode fileMode=FM_binary)
Sends an HTTP GET message to the server and store the reply in a file.
ms_http_helper_return | httpGetHeader (const std::string &action, std::string &httpHeaderInfo)
Sends an HTTP HEAD message to the server and returns the header information separated with CR LF.
ms_http_helper_return | httpGetString (const std::string &action, std::string &httpGETString)
Sends an HTTP GET message to the server and returns the reply in a string.
ms_http_helper_return | httpPostFile (const std::string &action, const std::string &httpHeader, const std::string &prologue, const std::string &filename, const std::string &epilogue, ms_http_helper_handles &handles, ms_http_helper_progress &progress)
Sends an HTTP POST message to the server and returns handles to allow the HTTP connection to be managed.
bool | isValid () const
Call this function to determine if there have been any errors.
const ms_http_helper & | operator= (const ms_http_helper &copy)
Copy assignment.

Static Public Member Functions

static std::string getHeaderValue (const std::string &name, const std::string &header)
Returns the value for a name-value pair in an http header.

Detailed Description

The class provides HTTP, FTP and FILE protocol access to a server.

The following tasks are supported:

  • Sending GET commands to an HTTP server and getting the response string.
  • Sending GET commands to an HTTP server and getting the response as a file.
  • POSTing a file to an HTTP server.
  • Sending GET commands to HTTP, FTP or FILE protocol based servers and buffering the response as strings. This is useful for large downloads into memory where the size is not known.
Examples
http_helper_getstring.cpp.

Member Enumeration Documentation

◆ FileMode

enum FileMode

Definitions for types of file content transfer.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
FM_binary | Binary - the data is saved in exactly the form as it is received.
FM_text | Text - the data is translated to a more text friendly form (new lines become cariage return/line feed pairs).

Constructor & Destructor Documentation

◆ ms_http_helper() [1/3]

ms_http_helper ( )

C++ STL collection support.

No network activity occurs during the constructor.

◆ ms_http_helper() [2/3]

ms_http_helper ( const ms_http_helper & copy )

Copy constructor.

Required because there is a dynamically added data member.

Parameters
copy reference to a ms_http_helper object

◆ ms_http_helper() [3/3]

ms_http_helper | ( | const std::string & | baseUrl,
 |  | const ms_connection_settings & | settings
 | ) |  |

Constructor for a connection to a server.

No network activity occurs during the constructor.

Parameters
baseUrl | The base URL of the target server. For example "http://www.matrixscience.com/cgi/".
settings | Settings that control the behaviour of the network link to the server.

◆ ~ms_http_helper()

~ms_http_helper ( )

Destructor.

Called automatically.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ baseUrl()

const std::string & baseUrl ( ) const

Returns the base URL to the server.

The base URL cannot be altered once the HTTP connection has been created.

Typically, the base URL will have the form "http://server_name/optional_path/cgi/".

Returns
The base URL of the target server and file location. For example "http://www.matrixscience.com/cgi/".

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ connectionSettings()

const matrix_science::ms_connection_settings & connectionSettings ( ) const

Returns the internet settings used for the HTTP connection.

The settings cannot be altered once the HTTP connection has been created.

Returns
Settings that control the behaviour of the network link to the server.

◆ copyFrom() [1/2]

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ copyFrom() [2/2]

void copyFrom ( const ms_http_helper * right )
Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getHeaderValue()

std::string getHeaderValue | ( | const std::string & | name,
 |  | const std::string & | header
 | ) |  |
static

Returns the value for a name-value pair in an http header.

Returns the value for a name-value pair in an http header.

Parameters
name | Required name key of name value pair in header.
header | The header text seperated by CR LF.
Returns
The value string if it exists otherwise empty.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getProxyConfig()

bool getProxyConfig | ( | std::vector< std::string > & | proxyServers,
 |  | std::vector< std::string > & | proxyUsernames,
 |  | std::vector< std::string > & | proxyPasswords
 | ) |  |

Get the proxy server configuration settings.

If unsuccessful, no output parameters are altered.

On Windows and depending on the proxy type in the ms_connection_settings, this uses the WinHttpGetIEProxyConfigForCurrentUser and WinHttpGetProxyForUrl Windows API functions to retrieve the information. For details, see: http://msdn.microsoft.com/en-us/library/windows/desktop/aa384097.aspx and http://msdn.microsoft.com/en-us/library/windows/desktop/aa384096.aspx

On Windows, the proxy server list is typically either set explicitly or retrieved, by the operating system, using Web Proxy Autodiscovery Protocol (WPAD) or Proxy auto-config (PAC). These protocols allow for different proxies to be configured for different domains, paths, ports or schemes (although Windows may imposes restrictions that limit the scope of this functionality - only the domain name should be used to determine the proxy server). Some further information is available at http://findproxyforurl.com/

On Linux, autoconfiguration is of more rudimentary type: proxy settings are pulled from the system environment variables, then from ms_connection_settings::getProxyServer().

Within Parser, Windows only tries the first entry in the proxy server list, and does not 'roll over' to try the next entry when one proxy cannot be reached. On Linux, on the other hand, each proxy server is tried in turn. If they all fail, a no-proxy configuration is tried as the last alternative.

Parameters
proxyServers is filled in with the list of proxy server URLs. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
  • The format of the proxy will be, for example, http://proxy:3128
  • On Windows, if the system specifies a direct connection for url, then proxyServers will be an empty array.
  • On Linux, if the system should try a no-proxy configuration, the last item in proxyServers will be the empty string.
  • The array will contain more than one item when a fall back system is in place, in which case the application should try the first proxy, and then if this fails, it should try the next etc.
proxyUsernames | is filled with usernames to be used with proxyServers. If a proxy server does not need authentication, the corresponding element will be the empty string. proxyUsernames.size() equals proxyServers.size(). See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
proxyPasswords | is filled with passwords to be used with proxyUsernames. If a proxy server does not need authentication or if a password is not needed, the corresponding element will be the empty string. proxyPasswords.size() equals proxyServers.size(). See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns
Returns true if the function completed successfully.

◆ httpBufferedClose()

matrix_science::ms_http_helper_return httpBufferedClose ( )

Closes the current buffered read session.

Closes a currently open buffered read session and connection. Refer to httpBufferedOpen() for example code and aditional information.

Returns
Any errors detected during closing
Examples
http_helper_getstring.cpp.

◆ httpBufferedGetString()

matrix_science::ms_http_helper_return httpBufferedGetString | ( | std::string & | httpBuffer,
 |  | unsigned long | requiredSize
 | ) |  |

Get available data from the open session. Writes data into the supplied buffer up to at least the required size.

Reads to at least the requiredSize (or until empty) from currently open buffered read session. Overwrites data in the supplied buffer. If no data read then the buffer will set to zero length. Refer to httpBufferedOpen() for example code and aditional information.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | httpBuffer | Receives any data read from the connection.
[in] | requiredSize | The method returns when the buffer is greater than or equal to this size or when no more data available.
Returns
Any errors detected during reading.
Examples
http_helper_getstring.cpp.

◆ httpBufferedOpen()

matrix_science::ms_http_helper_return httpBufferedOpen ( const std::string & action )

Creates and opens a session for buffered reading from the supplied base URL and action.

Opens a buffered read session using the current URL, action and connection settings. Allows data to be read in chunks and processed by using subsequent calls to httpBufferedGetString().

Support for HTTP, FTP and FILE protocols. HTTPS not currently supported.

Only one session for each ms_http_helper instance is supported at a time. Use the ms_connection_settings instance to setup any required proxy and security settings.

Parameters
action The action string, appended to the base URL, to be sent to the server.

Example URL's:

  • "ftp://username:password@hostname/file.txt"
  • "file://hostname/file.txt"
  • "http://localhost/sitename/file.txt"

Example code:

ms_connection_settings cs; // This uses default local security settings.
ms_http_helper helper("http://localhost/sitename/", cs);
if (helper.httpBufferedOpen("file.txt").isOk())
{
    // Loop reading chunks of data until no more is available.
    while (true)
    {
        std::string buffer;
        // Reads at least 10000 bytes if available.
        ms_http_helper_return result = helper.httpBufferedGetString(buffer, 10000);
        // If the buffer size is empty then no more data is available.
        if (buffer.length() == 0 || !result.isOk())
            break;
        // Process buffer contents here.
    }
    helper.httpBufferedClose();
}
Returns
Returns any errors occurring during connection.
Examples
http_helper_getstring.cpp.

◆ httpGetFile()

matrix_science::ms_http_helper_return httpGetFile | ( | const std::string & | action,
 |  | const std::string & | filename,
 |  | matrix_science::ms_http_helper_progress & | progress,
 |  | FileMode | fileMode = FM_binary
 | ) |  |

Sends an HTTP GET message to the server and store the reply in a file.

The progress information is updated as the download proceeds. The total amount of data to be returned is not known until the end of the download and so the total field is left at zero. The percentage complete will keep moving upward but is not a valid indicator of how much download is still remaining.

Parameters
action | The action string, appended to the base URL, to be sent to the server.
filename | The name of the file to write the downloaded reply to.
progress | An object to keep up-to-date with the current progress of request. See Maintaining object references: two rules of thumb.
fileMode | The mode (text or binary) in which to write the downloaded reply to the file.
Returns
The final outcome of the HTTP GET request.

◆ httpGetHeader()

matrix_science::ms_http_helper_return httpGetHeader | ( | const std::string & | action,
 |  | std::string & | httpHeaderInfo
 | ) |  |

Sends an HTTP HEAD message to the server and returns the header information separated with CR LF.

Retrieves the HTTP header text if present for the current URL, action and connection settings.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | action | The action string, appended to the base URL, to be sent to the server.
[out] | httpHeaderInfo | The string to receive the header text. Each section is seperated with CR LF
Returns
Returns any errors occurring during connection.
Examples
http_helper_getstring.cpp.

◆ httpGetString()

matrix_science::ms_http_helper_return httpGetString | ( | const std::string & | action,
 |  | std::string & | httpGETString
 | ) |  |

Sends an HTTP GET message to the server and returns the reply in a string.

Called by many higher level functions.

This will log the ms_errs::ERR_MSP_HTTP_URLSTRING message.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[in] | action | The action string, appended to the base URL, to be sent to the server.
[out] | httpGETString | Returns the raw HTTP text received in reply from the server.
Returns
The final outcome of the HTTP GET request.
Examples
http_helper_getstring.cpp.

◆ httpPostFile()

matrix_science::ms_http_helper_return httpPostFile | ( | const std::string & | action,
 |  | const std::string & | httpHeader,
 |  | const std::string & | prologue,
 |  | const std::string & | filename,
 |  | const std::string & | epilogue,
 |  | matrix_science::ms_http_helper_handles & | returnHandles,
 |  | matrix_science::ms_http_helper_progress & | progress
 | ) |  |

Sends an HTTP POST message to the server and returns handles to allow the HTTP connection to be managed.

The progress information is updated as the upload proceeds. The total amount of data to be determined before the upload begins and this is placed in the proess total field.

The POST message contains the data from the prologue string, the file contents and then the epilogue string.

This will log the ms_errs::ERR_MSP_HTTP_URLSTRING message.

The function returns when the upload is complete.

Parameters
action | The action string, appended to the base URL, to be sent to the server.
httpHeader | The HTTP headers passed when creating a new query. Typically this identifies the content type and the MIME separator string.
prologue | Text sent as the first part of the content of the HTTP POST.
filename | The name of a file, the content of which is sent after the prologue text and before the epilogue text.
epilogue | Text sent as the last part of the content of the HTTP POST.
returnHandles | Returns handles that can be used to dowload the response from the server. See Maintaining object references: two rules of thumb.
progress | An object to keep up-to-date with the current progress of request. See Maintaining object references: two rules of thumb.
Returns
Returns true if the function completed successfully.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

◆ operator=()

const ms_http_helper & operator= ( const ms_http_helper & copy )

Copy assignment.

Required because there is a dynamically added data member.

Parameters
copy reference to a ms_http_helper object
Returns
reference to the current object
The documentation for this class was generated from the following files:
  • ms_http_helper.hpp
  • ms_http_helper.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper_handles Class Reference

  • matrix_science
  • ms_http_helper_handles
Public Member Functions | List of all members
ms_http_helper_handles Class Reference
Accessing a Mascot Server using HTTP

The class holds HTTP to allow a POST request to be kept alive and retrieve any output received from that request. More...

#include <ms_http_helper_handles.hpp>

Inheritance diagram for ms_http_helper_handles:
[legend]
Collaboration diagram for ms_http_helper_handles:
[legend]

Public Member Functions

ms_http_helper_handles ()
Default constructor.
virtual | ~ms_http_helper_handles ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
bool | closeHandles ()
Closes the HTTP handles.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getRequestData (bool &isStillActive, std::string &requestDataRef)
Retrieves data from the HTTP reply and indicates whether the request is still active (and could produce more data).
bool | isValid () const
Call this function to determine if there have been any errors.

Detailed Description

The class holds HTTP to allow a POST request to be kept alive and retrieve any output received from that request.

Mascot searches will terminate immediately if the HTTP request times out. It is important to keep the request alive by frequently checking for request data. The Mascot server sends occasional data packets that can be collected. Once the request has completed there could be several packets of uncollected data before the function indicates that the request is no longer active. Once it is inactive the handles can be closed. An object of this class is initialised by ms_http_helper::httpPostFile

Constructor & Destructor Documentation

◆ ~ms_http_helper_handles()

~ms_http_helper_handles ( )
virtual

Destructor.

The handles will be automatically closed when there are no more handles object referencing them.

Called automatically.

Member Function Documentation

◆ appendErrors()

void appendErrors ( const ms_errors & src )
inherited

Copies all errors from another instance and appends them at the end of own list.

Parameters
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.

◆ clearAllErrors()

void clearAllErrors ( )
inherited

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.

◆ closeHandles()

bool closeHandles ( )

Closes the HTTP handles.

On Windows IIS, closing the handles will terminate a search being done for that task on the Mascot server.

Returns
True if the function completes successfully.

◆ copyFrom()

void copyFrom ( const ms_errors * right )
inherited

Use this member to make a copy of another instance.

Parameters
right is the source to initialise from

◆ getErrorHandler()

const ms_errs * getErrorHandler ( ) const
inherited

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns
Constant pointer to the error handler
See also
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, and http_helper_getstring.cpp.

◆ getLastError()

int getLastError ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns
the error number of the last error, or 0 if there have been no errors.

◆ getLastErrorString()

std::string getLastErrorString ( ) const
inherited

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns
Most recent error, warning, information or debug message

See Error Handling.

See also
isValid(), getLastError(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.

◆ getRequestData()

bool getRequestData | ( | bool & | isStillActive,
 |  | std::string & | requestDataRef
 | ) |  |

Retrieves data from the HTTP reply and indicates whether the request is still active (and could produce more data).

The data is whatever is produced by the server as it progresses with the task. The function blocks until dat is available or the server task has finished.

The data from a Mascot server does not reflect any result of a search.

Use the ms_http_client_search::getStatus() function to monitor how the task is progressing.

See Multiple return values in Perl, Java, Python and C#.

Parameters
[out] | isStillActive | True if any data was retrieved from the request.
[out] | requestDataRef | The data retrieved from the request.
Returns
True if the function completed successfully.

◆ isValid()

bool isValid ( ) const
inherited

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns
True if no fatal error occured
See also
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_http_helper_handles.hpp
  • ms_http_helper_handles.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper_progress Class Reference

  • matrix_science
  • ms_http_helper_progress
Public Member Functions | List of all members
ms_http_helper_progress Class Reference
Accessing a Mascot Server using HTTP

This holds information on the progress of a running HTTP transfer. More...

#include <ms_http_helper_progress.hpp>

Public Member Functions

ms_http_helper_progress ()
C++ STL collection support.
ms_http_helper_progress (const ms_http_helper_progress &src)
Copying constructor.
ms_http_helper_progress (ms_http_helper_progress &parentProgress, double proportionOffset, UINT64 byteOffset, double scale)
Initialise the object with a link to a parent progress reporter.
~ms_http_helper_progress ()
Destructor.
void | copyFrom (const ms_http_helper_progress *right)
Copies all data from another instance of the class.
UINT64 | getCurrentBytes () const
Returns the number of bytes sent or received.
double | getProportion () const
Returns a number from 0 to 1.0 that indicates how far the transaction has progressed.
UINT64 | getTotalBytes () const
Returns the total number of bytes that are due to be sent or received, or zero if the number is unknown.
bool | hasParent () const
Returns true if progress proportion is being forwarded to a parent object.
bool | isAbortSet () const
Returns true if the transaction has been asked to abort.
bool | isComplete () const
Returns true if the transaction has run to completion (not terminated by error or abort).
bool | isStarted () const
Returns true if the transaction has started running.
void | setAbort ()
Cause the transaction to abort at the next available point.

Detailed Description

This holds information on the progress of a running HTTP transfer.

A progress object is passed to the connection when an extended transaction is started. The transaction updates the information as the transaction is going on.

Often, extended transactions are started on a worker thread so that other task (for example, the user interface) may continue to function while the transaction is in progress). An object of this class allows communication with the transaction while being processed on that thread.

This object can also be used to cancel the transaction prematurely if required.

Constructor & Destructor Documentation

◆ ms_http_helper_progress() [1/2]

ms_http_helper_progress ( )

C++ STL collection support.

STL collections, such as vector, need a default constructor.

◆ ms_http_helper_progress() [2/2]

ms_http_helper_progress | ( | ms_http_helper_progress & | parentProgress,
 |  | double | proportionOffset,
 |  | UINT64 | byteOffset,
 |  | double | scale
 | ) |  |

Initialise the object with a link to a parent progress reporter.

When the progress helper is linked to a parent progress helper, all setProgress() calls are forwarded to the parent. You need to specify the offset and scale. For example, if you have two tasks, then use scale=0.5 for child progress helper 1 and child progress helper 2; and use offset=0.0 for the first one and offset=0.5 for the second one.

Only the proportion and current bytes are forwarded to the parent. Task start, abort or completion are not forwarded.

Parameters
parentProgress | All setProgress() calls are forwarded to this parent. If null, nothing is forwarded.
proportionOffset | An offset to add to forwarded proportion.
byteOffset | An offset to add to forwarded current bytes.
scale | A scale by which the subtask proportion is multiplied.

Member Function Documentation

◆ getCurrentBytes()

UINT64 getCurrentBytes ( ) const

Returns the number of bytes sent or received.

This is the number of characters actually transferred so far.

Returns
The number of characters transferred so far.

◆ getProportion()

double getProportion ( ) const

Returns a number from 0 to 1.0 that indicates how far the transaction has progressed.

If the total amount to be transferred is unknown then the proportion value will change but does not represent any indication of the amount remaining.

Returns
The proportion of the task that has been completed. Zero if the amount is unknown.

◆ getTotalBytes()

UINT64 getTotalBytes ( ) const

Returns the total number of bytes that are due to be sent or received, or zero if the number is unknown.

This is the size (in characters) of the file to be transferred.

For a download, the number of characters that are going to be sent by the server is not usually known until after the transfer is complete. In this case, this number remains zero.

Returns
The number of characters to be transferred (including those already transferred).

◆ hasParent()

bool hasParent ( ) const

Returns true if progress proportion is being forwarded to a parent object.

Returns
True if the object was initialised with a parent progress link.

◆ isAbortSet()

bool isAbortSet ( ) const

Returns true if the transaction has been asked to abort.

This will return true after the setAbort() function has been called.

Returns
True if the task is to be aborted at user request (i.e. setAbort() has been called).

◆ isComplete()

bool isComplete ( ) const

Returns true if the transaction has run to completion (not terminated by error or abort).

If the transfer ended for any reason other than a successful transfer of all the data then this will continue to return false. The submit/download function will exit once the data transfer has ceased (for whatever reason).

Returns
True if the task has completed.

◆ isStarted()

bool isStarted ( ) const

Returns true if the transaction has started running.

Once the file transfer function has been called, there may be a delay before the transfer itself actually starts. This will only return true once the transfer of data has begun.

Returns
True if the task has started (i.e. setStarted() has been called).

◆ setAbort()

void setAbort ( )

Cause the transaction to abort at the next available point.

The file transfer, running on another thread, will continue until it gets to a suitable point and then exit.

The documentation for this class was generated from the following files:
  • ms_http_helper_progress.hpp
  • ms_http_helper_progress.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper_return Class Reference

  • matrix_science
  • ms_http_helper_return
Public Types | Public Member Functions | Static Public Member Functions | List of all members
ms_http_helper_return Class Reference
Accessing a Mascot Server using HTTP

Indicates any problem that may have occurred during a request to an ms_http_helper object. More...

#include <ms_http_helper_return.hpp>

Public Types

enum ErrorTypeCode {
ERR_NONE ,
ERR_ABORTEDBYUSER ,
ERR_SYSTEM ,
ERR_HTTP ,
ERR_UNSPECIFIED
}
Definitions for types of problem that can be encountered. More...

Public Member Functions

ms_http_helper_return ()
C++ STL collection support.
std::string | getErrorText () const
Returns the text, if any, associated with the error.
ErrorTypeCode | getErrorType () const
Returns type of any error that was encountered.
int | getHttpStatusCode () const
Returns the HTTP response code (if the type is ERR_http).
int | getSystemError () const
Returns the operating system error code for the problem (if the type is ERR_system).
bool | isOk () const
Returns true if no problem was encountered.
operator bool () const
Returns the same value as the IsOk function.

Static Public Member Functions

static ms_http_helper_return | abortedByUser ()
Creates an object to indicate that the operation has been aborted at the request of the user.
static ms_http_helper_return | httpError (int httpStatusCode, std::string errorText)
Creates an object with the specified HTTP response code (200 represents a success ).
static ms_http_helper_return | systemError (int systemError)
Creates an object with the specified system error code.
static ms_http_helper_return | unspecifiedError ()
Creates an error object with no specific cause.

Detailed Description

Indicates any problem that may have occurred during a request to an ms_http_helper object.

The soecific error information is returned to allow detailed or specific action to be taken in response. If no specific action is warranted then IsOk can be used to determine success or failure. Any failure will have been logged in the error handler for the ms_http_helper object.

Examples
http_helper_getstring.cpp.

Member Enumeration Documentation

◆ ErrorTypeCode

enum ErrorTypeCode

Definitions for types of problem that can be encountered.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator
ERR_NONE | No problem was encountered; the operation completed successfully.
ERR_ABORTEDBYUSER | The operation was aborted prematurely at the request of the operator.
ERR_SYSTEM | A problem was found with one of the operating system functions.
ERR_HTTP | A problem was reported via the HTTP channel.
ERR_UNSPECIFIED | An error that was not categorised as one of the more specific types.

Constructor & Destructor Documentation

◆ ms_http_helper_return()

ms_http_helper_return ( )

C++ STL collection support.

STL collections, such as vector need a default constructor.

Member Function Documentation

◆ abortedByUser()

ms_http_helper_return abortedByUser ( )
static

Creates an object to indicate that the operation has been aborted at the request of the user.

There is no text associated with this type of return.

Returns
An object representing the fact that the task was aborted ath the request of the user.

◆ getErrorText()

std::string getErrorText ( ) const

Returns the text, if any, associated with the error.

The content depends on the type of error (see errorType()).

Returns
The text for the error/reply represented.
Examples
http_helper_getstring.cpp.

◆ getErrorType()

ms_http_helper_return::ErrorTypeCode getErrorType ( ) const

Returns type of any error that was encountered.

This can be ERR_NONE to indicate that there was no error.

Returns
The type of return that this represents.

◆ getHttpStatusCode()

int getHttpStatusCode ( ) const

Returns the HTTP response code (if the type is ERR_http).

The meanings of HTTP status codes are defined by the Internet Engineering Task Force (IETF) (e.g. 200 = OK).

Returns
The HTTP reply code encountered.
Examples
http_helper_getstring.cpp.

◆ getSystemError()

int getSystemError ( ) const

Returns the operating system error code for the problem (if the type is ERR_system).

The meaning of the return code depends on the underlying operating system (e.g. Windows, Linux).

Returns
The system error code encountered.

◆ httpError()

ms_http_helper_return httpError | ( | int | httpStatusCode,
 |  | std::string | httpStatusText
 | ) |  |
static

Creates an object with the specified HTTP response code (200 represents a success ).

The error text will contain the descriptive text returned in the HTTP reply.

Parameters
httpStatusCode | The number of the HTTP error encountered.
httpStatusText | The text of the HTTP error encountered.
Returns
An object representing the given HTTP error.

◆ isOk()

bool isOk ( ) const

Returns true if no problem was encountered.

If this returns false, then errorType() can be used to determine the cause.

Returns
True if this does not represent any type of error.
Examples
http_helper_getstring.cpp.

◆ operator bool()

operator bool ( ) const

Returns the same value as the IsOk function.

If this returns false, then errorType() can be used to determine the cause.

Returns
True if this does not represent any type of error.

◆ systemError()

ms_http_helper_return systemError ( int systemError )
static

Creates an object with the specified system error code.

The error text will contain the operating system provided description for the error.

Parameters
systemError The number of the system error encountered.
Returns
An object representing the given system error.

◆ unspecifiedError()

ms_http_helper_return unspecifiedError ( )
static

Creates an error object with no specific cause.

There is no diagnostic information available for this type of error.

Returns
An object representing a non-specific error.
The documentation for this class was generated from the following files:
  • ms_http_helper_return.hpp
  • ms_http_helper_return.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • abortedByUser() : ms_http_helper_return
  • addAccessionUnigenePair() : ms_unigene
  • addComponent() : ms_ms1quant_match
  • addCreatedComponent() : ms_ms1quant_match
  • addCutter() : ms_enzyme
  • addDoubleParam() : ms_security_task
  • addExperimentalData() : ms_fragmentvector
  • addHeaderField() : ms_quantitation
  • addLogEventsHandler() : ms_loggingmonitor
  • addLongParam() : ms_security_task
  • addMatchInferred() : ms_ms1quantitation
  • addMatchPeptide() : ms_ms1quantitation
  • addMatchStatus() : ms_ms1quantitation
  • addNewGroup() : ms_security
  • addNewUser() : ms_security
  • addPeaks() : ms_spectral_lib_peak_list
  • addPeptideQuantKey() : ms_customquantitation
  • addPeptideQuantKeys() : ms_customquantitation
  • addPeptideRatio() : ms_customquantitation
  • addPermittedTask() : ms_group
  • addRawFileField() : ms_quantitation
  • addStringParam() : ms_security_task
  • addSubtask() : ms_progress_info
  • addTask() : ms_security_tasks
  • addToCatalog() : ms_log
  • addUser() : ms_group
  • allComponentsIdentified() : ms_ms1quant_match
  • ANNOT_LVL_CANNOT_ANNOTATE : ms_spectral_lib_peak_list
  • ANNOT_LVL_NONE : ms_spectral_lib_peak_list
  • ANNOT_LVL_QUESTION_MARKS : ms_spectral_lib_peak_list
  • ANNOT_LVL_SOME_PEAKS : ms_spectral_lib_peak_list
  • ANNOTATE_NONE : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_ALL : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_IF_ALL_EMPTY : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_QUESTION_MARKS : ms_spectral_lib_entry
  • annotatePeaks() : ms_spectral_lib_entry, ms_spectral_lib_peak_list
  • anyBoldRedPeptides() : ms_protein
  • anyCrosslinkedMatches() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anyEmPAI() : ms_mascotresults, ms_peptidesummary
  • anyErrorTolerantMatches() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anyFastaMatches() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anyMatchToQuery() : ms_protein
  • anyMatchToQueryAndP() : ms_protein
  • anyMSMS() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anyNLseriesUsed() : ms_fragmentationrules
  • anyNumDiscoveredMods() : ms_mascotresults
  • anyPeptideSummaryMatches() : ms_mascotresfile_dat
  • anyPercolatorResults() : ms_peptide
  • anyPMF() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anySpectralLibraryMatches() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anySQ() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anyTag() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • append() : ms_http_client_mime, ms_linker_site_vector, ms_peptide_quant_key_vector
  • appendAccession() : ms_crosslinking_accessions
  • appendAltName() : ms_umod_modification
  • appendAminoAcid() : ms_umod_configfile
  • appendComponent() : ms_quant_method
  • appendCorrection() : ms_quant_component
  • appendCronJob() : ms_cronoptions
  • appendDatabase() : ms_databases, ms_processoroptions
  • appendDenominator() : ms_quant_ratio
  • appendDoesNotPairWith() : ms_crosslinking_linker
  • appendElement() : ms_quant_composition, ms_umod_configfile
  • appendElemRef() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • appendEntry() : ms_taxonomyfile, ms_wwwoptions
  • appendEnzyme() : ms_enzymefile
  • appendErrors() : ms_errors, ms_errs
  • appendExcludeTaxonomy() : ms_taxonomychoice
  • appendExclusion() : ms_quant_method
  • appendFile() : ms_http_client_mime
  • appendFileIndex() : ms_quant_component
  • appendFragment() : ms_fragmentvector
  • appendGencodeFile() : ms_taxonomyrules
  • appendIgnore() : ms_quant_localdef, ms_umod_modification
  • appendIgnoreDupeAccession() : ms_mascotoptions
  • appendIgnoreMass() : ms_modification
  • appendIncludeTaxonomy() : ms_taxonomychoice
  • appendInstrument() : ms_fragrulesfile
  • appendIonSeries() : ms_quant_multiplex
  • appendIsotope() : ms_quant_component
  • appendLinker() : ms_crosslinking_linkers
  • appendLocalDefinition() : ms_quant_modgroup
  • appendMethod() : ms_crosslinking_configfile, ms_quant_configfile
  • appendModBrick() : ms_umod_configfile
  • appendModFile() : ms_quant_modgroup
  • appendModification() : ms_modfile, ms_modvector, ms_umod_configfile
  • appendModificationGroup() : ms_quant_component, ms_quant_method
  • appendModifications() : ms_modvector
  • appendModifiedResidue() : ms_modification
  • appendMonoLink() : ms_crosslinking_linker
  • appendNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • appendNoBreakDescLineIf() : ms_taxonomyrules
  • appendNodesFile() : ms_taxonomyrules
  • appendNumerator() : ms_quant_ratio
  • appendParameter() : ms_crosslinking_parameters, ms_quant_parameters
  • appendPepNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • appendPeptide() : ms_quant_normalisation_peptides
  • appendPerDbSrcRule() : ms_taxonomyrules
  • appendPrefixRemove() : ms_taxonomyrules
  • appendProcessor() : ms_processoroptions
  • appendProperty() : ms_customproperty
  • appendProtein() : ms_quant_normalisation_proteins
  • appendReportNumberChoice() : ms_mascotoptions
  • appendReportRatio() : ms_quant_method
  • appendResfile() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • appendSampleValue() : ms_shapiro_wilk
  • appendSeq() : ms_quant_method
  • appendSpeciesFile() : ms_taxonomyrules
  • appendSpecificity() : ms_quant_localdef, ms_umod_modification
  • appendStrFile() : ms_taxonomyrules
  • appendSubCluster() : ms_clusterparams
  • appendSuffixRemove() : ms_taxonomyrules
  • appendTargetFDRPercentage() : ms_mascotoptions
  • appendText() : ms_customproperty
  • appendThreadProcessorID() : ms_dbprocessors
  • appendUnmodified() : ms_quant_modgroup
  • appendXref() : ms_umod_modification
  • applyFixedMods() : ms_masses
  • applyIsotopes() : ms_masses
  • applyVisibility() : ms_umod_configfile
  • arithmeticMean() : ms_quant_stats
  • arithmeticStandardDeviation() : ms_quant_stats
  • arithmeticStandardErrorOfMean() : ms_quant_stats
  • arithmeticStandardErrorOfMedian() : ms_quant_stats
  • asText() : ms_spectral_lib_peak, ms_spectral_lib_peak_list
  • averageFindAverage() : ms_imputation_method
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • baseUrl() : ms_http_client, ms_http_helper
  • binomialCoefficient() : ms_quant_stats
  • BUGFIX_10780 : ms_peptidesummary
  • BUGFIX_10995 : ms_peptidesummary
  • BUGFIX_11002 : ms_peptidesummary
  • BUGFIX_11018 : ms_peptidesummary
  • BUGFIX_11235 : ms_peptidesummary
  • BUGFIX_11254 : ms_peptidesummary
  • BUGFIX_11344 : ms_peptidesummary
  • BUGFIX_11411 : ms_peptidesummary
  • BUGFIX_11425 : ms_peptidesummary
  • BUGFIX_11438 : ms_peptidesummary
  • BUGFIX_11481 : ms_peptidesummary
  • BUGFIX_11483 : ms_peptidesummary
  • BUGFIX_11499 : ms_peptidesummary
  • BUGFIX_11856 : ms_peptidesummary
  • BUGFIX_12123 : ms_peptidesummary
  • BUGFIX_12317 : ms_peptidesummary
  • BUGFIX_12409 : ms_ms1quantitation
  • BUGFIX_12447 : ms_peptidesummary
  • BUGFIX_12538 : ms_peptidesummary
  • BUGFIX_12729 : ms_peptidesummary
  • BUGFIX_12740 : ms_peptidesummary
  • BUGFIX_13324 : ms_peptidesummary
  • BUGFIX_13759 : ms_peptidesummary
  • BUGFIX_NUM : ms_peptidesummary
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CACHE_MISSING_RESFILE : ms_peptidesummary
  • CACHE_STATUS : ms_peptidesummary
  • calcFragments() : ms_aahelper
  • calcFragmentsEx() : ms_aahelper
  • calcPeptideMZ() : ms_aahelper
  • calculate() : ms_shapiro_wilk
  • calculateFromConsensuValues() : ms_ms1quant_time_align
  • calculateGeometricMeanRatio() : ms_quantitation
  • calculateMedianRatio() : ms_quantitation
  • calculateNormalMeanPvalue() : ms_quant_stats
  • calculateNormalMedianPvalue() : ms_quant_stats
  • calculateNormalWeightedPvalue() : ms_quant_stats
  • calculateWeightedGeometricMeanRatio() : ms_quantitation
  • cancelCreateSummary() : ms_mascotresults
  • canCleave() : ms_enzyme
  • canResultsFileBeViewed() : ms_session
  • changems_imputation_missing_valArrayToDoubleArray() : ms_imputation_method
  • changems_imputation_missing_valVecToDoubleVec() : ms_imputation_method
  • changePassword() : ms_http_client
  • ChangePasswordResultCode : ms_http_client
  • chargeType : ms_ms1quant_match
  • CHARGETYPE_ALL : ms_ms1quant_match
  • CHARGETYPE_ORIGINAL : ms_ms1quant_match
  • checkSeqDBInstallRequest() : ms_datfile
  • chisqLowerCriticalValue() : ms_quant_stats
  • chisqUpperCriticalValue() : ms_quant_stats
  • clear() : ms_linker_site_vector, ms_peptide_quant_key_vector, ms_progress_info
  • clearAccessions() : ms_crosslinking_accessions
  • clearAllCutters() : ms_enzyme
  • clearAllErrors() : ms_errors, ms_errs
  • clearAltNames() : ms_umod_modification
  • clearAminoAcids() : ms_umod_configfile
  • clearAnnotation() : ms_spectral_lib_entry, ms_spectral_lib_peak, ms_spectral_lib_peak_list
  • clearComponents() : ms_quant_method
  • clearCorrections() : ms_quant_component
  • clearCronJobs() : ms_cronoptions
  • clearDatabases() : ms_databases, ms_processoroptions
  • clearDBLevelTaxId() : ms_taxonomyrules
  • clearDenominators() : ms_quant_ratio
  • clearDoesNotPairWiths() : ms_crosslinking_linker
  • clearElements() : ms_quant_composition, ms_umod_configfile
  • clearElemRefs() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • clearEntries() : ms_taxonomyfile, ms_wwwoptions
  • clearEnzymes() : ms_enzymefile
  • clearExcludeTaxonomies() : ms_taxonomychoice
  • clearExclusions() : ms_quant_method
  • clearFileIndexes() : ms_quant_component
  • clearFragments() : ms_fragmentvector
  • clearGencodeFiles() : ms_taxonomyrules
  • clearHeaderFields() : ms_quantitation
  • clearHitRatioExcluded() : ms_ms1quant_match
  • clearHitRatioOutlier() : ms_ms1quant_match
  • clearIgnoreDupeAccessions() : ms_mascotoptions
  • clearIgnoreMasses() : ms_modification
  • clearIgnores() : ms_quant_localdef, ms_umod_modification
  • clearIncludeTaxonomies() : ms_taxonomychoice
  • clearInstruments() : ms_fragrulesfile
  • clearIonSeries() : ms_quant_multiplex
  • clearIsotopes() : ms_quant_component
  • clearLinkers() : ms_crosslinking_linkers
  • clearLocalDefinitions() : ms_quant_modgroup
  • clearMatchedIon() : ms_fragment
  • clearMethods() : ms_crosslinking_configfile, ms_quant_configfile
  • clearModBricks() : ms_umod_configfile
  • clearModFiles() : ms_quant_modgroup
  • clearModificationGroups() : ms_quant_component, ms_quant_method
  • clearModifications() : ms_modfile, ms_modvector, ms_umod_configfile
  • clearModifiedResidues() : ms_modification
  • clearMonoLinks() : ms_crosslinking_linker
  • clearNeutralLosses() : ms_quant_specificity, ms_umod_specificity
  • clearNoBreakDescLineIf() : ms_taxonomyrules
  • clearNodesFiles() : ms_taxonomyrules
  • clearNumerators() : ms_quant_ratio
  • clearParam() : ms_group, ms_session, ms_user
  • clearParameters() : ms_crosslinking_parameters, ms_quant_parameters, ms_xml_parameters
  • clearParams() : ms_security_task
  • clearParseRules() : ms_parseoptions
  • clearPepNeutralLosses() : ms_quant_specificity, ms_umod_specificity
  • clearPeptideQuantKeys() : ms_customquantitation
  • clearPeptideRatios() : ms_customquantitation
  • clearPeptides() : ms_quant_normalisation_peptides
  • clearPerDbSrcRules() : ms_taxonomyrules
  • clearPrefixRemoves() : ms_taxonomyrules
  • clearProcessors() : ms_processoroptions
  • clearProteins() : ms_quant_normalisation_proteins
  • clearRawFileFields() : ms_quantitation
  • clearReloadableInfo() : ms_peptide
  • clearReportNumberChoices() : ms_mascotoptions
  • clearReportRatios() : ms_quant_method
  • clearSampleValues() : ms_shapiro_wilk
  • clearSeqs() : ms_quant_method
  • clearSeries() : ms_fragmentationrules
  • clearSpeciesFiles() : ms_taxonomyrules
  • clearSpecificities() : ms_quant_localdef, ms_umod_modification
  • clearSubClusters() : ms_clusterparams
  • clearSuffixRemoves() : ms_taxonomyrules
  • clearTargetFDRPercentages() : ms_mascotoptions
  • clearThreads() : ms_dbprocessors
  • clearUnmodified() : ms_quant_modgroup
  • clearXrefs() : ms_umod_modification
  • closeHandles() : ms_http_helper_handles
  • closeIndexFile() : ms_tinycdb
  • cluster() : ms_treecluster
  • CMD_ARGUMENT_PARSE_COLLISION : ms_fileutilities
  • CMD_ARGUMENT_PARSE_INVALIDCHAR : ms_fileutilities
  • CMD_ARGUMENT_PARSE_OK : ms_fileutilities
  • CMD_ARGUMENT_PARSE_RESULT : ms_fileutilities
  • CMD_ARGUMENT_PARSE_UNBALANCED : ms_fileutilities
  • CMPXML_IGN_COL_SIZE_EQ_ONE : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_100_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_10_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_1_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_IDENTICAL : ms_fileutilities
  • CMPXML_IGN_FILE_URL : ms_fileutilities
  • CMPXML_IGN_INF_999999 : ms_fileutilities
  • CMPXML_IGN_RAWFILE_NAME : ms_fileutilities
  • CMPXML_IGN_TODAY_DATE : ms_fileutilities
  • CMPXML_NO_FLAG : ms_fileutilities
  • CMPXML_STRIP_TRAILING_ZEROS : ms_fileutilities
  • COL_ASC_TIME : ms_logger
  • COL_HEADERS : ms_logger
  • COL_IP_ADDRESS : ms_logger
  • COL_ISO8601_TIME : ms_logger
  • COL_LOGGER_DEFAULTS : ms_logger
  • COL_MSG : ms_logger
  • COL_MSG_NUM_DEC : ms_logger
  • COL_MSG_NUM_HEX : ms_logger
  • COL_MSG_SOURCE_TXT : ms_logger
  • COL_QUOTES : ms_logger
  • COL_SEVERITY_NUM : ms_logger
  • COL_SEVERITY_TXT : ms_logger
  • COL_SRC_FILE : ms_logger
  • COL_SRC_LINENUM : ms_logger
  • COL_THREAD_ID : ms_logger
  • COL_TSV : ms_logger
  • columnMatrix() : ms_matrix
  • combinedRT_t : ms_ms1quant_time_align_limits
  • combinedRTinterval : ms_ms1quant_time_align_limits
  • compareXmlFiles() : ms_fileutilities
  • compareXMLFiles_flags : ms_fileutilities
  • COMPATIBLE : ms_quant_method
  • COMPATIBLE_DIFF_INTEGRATION_PARAM : ms_quant_method
  • COMPATIBLE_DIFF_LOCAL_MOD : ms_quant_method
  • COMPATIBLE_DIFF_NUM_COMPONENTS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_ISOTOPES : ms_quant_method
  • COMPATIBLE_DIFF_NUM_LOCAL_MODS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_MOD_GROUPS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_MODS : ms_quant_method
  • COMPATIBLE_DIFF_PROTOCOL : ms_quant_method
  • COMPATIBLE_MISSING_COMPONENT : ms_quant_method
  • COMPATIBLE_MISSING_INTEGRATION : ms_quant_method
  • COMPATIBLE_MISSING_INTEGRATION_PARAM : ms_quant_method
  • COMPATIBLE_MISSING_MOD : ms_quant_method
  • COMPATIBLE_MISSING_MOD_GROUP : ms_quant_method
  • compressMore() : ms_zip
  • connectionSettings() : ms_http_client, ms_http_helper
  • containsVarModIdx() : ms_linker_site_vector
  • convertFromLogLevel() : ms_errs
  • convertToLogLevel() : ms_errs
  • copyFrom() : ms_aahelper, ms_clusterparams, ms_computeraddress, ms_connection_settings, ms_cronjob, ms_cronoptions, ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_configfile, ms_crosslinking_does_not_pair_with, ms_crosslinking_filters, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_crosslinking_parameter, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_customproperty, ms_databaseoptions, ms_databases, ms_datfile, ms_dbprocessors, ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list, ms_enzyme, ms_enzymefile, ms_errors, ms_fragment, ms_fragmentationrules, ms_fragmentvector, ms_fragrulesfile, ms_http_client, ms_http_client_search, ms_http_client_session, ms_http_helper, ms_http_helper_progress, ms_libraryoptions, ms_license, ms_linker_site, ms_linker_site_vector, ms_mascotfiles, ms_mascotoptions, ms_mascotresults_params, ms_masses, ms_modfile, ms_modification, ms_modvector, ms_obofile, ms_parseoptions, ms_parserule, ms_parserule_plus, ms_peptide, ms_peptide_quant_key_vector, ms_peptide_quant_ratio, ms_processoroptions, ms_processors, ms_protein, ms_protein_quant_ratio, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_configfile, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_parameter, ms_quant_parameters, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_security_options, ms_spectral_lib_entry, ms_spectral_lib_peak, ms_spectral_lib_peak_list, ms_taxnodesfiles, ms_taxonomychoice, ms_taxonomyfile, ms_taxonomyrules, ms_taxonomytree, ms_taxspeciesfiles, ms_treecluster, ms_umod_aminoacid, ms_umod_composition, ms_umod_configfile, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_unigeneoptions, ms_wwwentry, ms_wwwoptions, ms_xic, ms_xml_parameter, ms_zip
  • copyMassFile() : ms_modification
  • countDistinctPeptides() : ms_ms1quantitation, ms_ms2quantitation, ms_quantitation
  • CP_BADNEWPASSWORD : ms_http_client
  • CP_INCORRECTPASSWORD : ms_http_client
  • CP_SUCCESS : ms_http_client
  • CP_UNKNOWNUSER : ms_http_client
  • CP_UNSPECIFIEDERROR : ms_http_client
  • createCrosslinkedPeptide() : ms_aahelper
  • createDefaults() : ms_security
  • createDirectory() : ms_fileutilities
  • createMissingComponents() : ms_quant_helper
  • createPeptide() : ms_aahelper
  • createResfile() : ms_mascotresfilebase
  • createSummary() : ms_mascotresults, ms_peptidesummary
  • createUnassignedList() : ms_mascotresults
  • CTERM_CUTTER : ms_enzyme
  • cuttertype : ms_enzyme
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • data() : ms_matrix
  • DB_MATCH_TYPE : ms_mascotresults
  • decompressMore() : ms_zip
  • DECOY_ALGORITHM : ms_mascotoptions
  • DECOY_ALGORITHM_NONE : ms_mascotoptions
  • DECOY_PEPTIDE_RANDOM : ms_mascotoptions
  • DECOY_PEPTIDE_RANDOM_DIPEP : ms_mascotoptions
  • DECOY_PEPTIDE_REVERSE : ms_mascotoptions
  • DECOY_PEPTIDE_SHUFFLE : ms_mascotoptions
  • DECOY_PROTEIN_BASED_MASK : ms_mascotoptions
  • DECOY_PROTEIN_RANDOM : ms_mascotoptions
  • DECOY_PROTEIN_RANDOM_DIPEP : ms_mascotoptions
  • DECOY_PROTEIN_REVERSE : ms_mascotoptions
  • DECOY_PROTEIN_SHUFFLE : ms_mascotoptions
  • DECOY_STATS_COUNT_TYPE : ms_mascotresults
  • defaultValues() : ms_aahelper, ms_clusterparams, ms_computeraddress, ms_connection_settings, ms_cronjob, ms_cronoptions, ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_configfile, ms_crosslinking_does_not_pair_with, ms_crosslinking_filters, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_crosslinking_parameter, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_customproperty, ms_databaseoptions, ms_databases, ms_datfile, ms_dbprocessors, ms_enzyme, ms_enzymefile, ms_fragmentationrules, ms_fragrulesfile, ms_libraryoptions, ms_license, ms_mascotfiles, ms_mascotoptions, ms_masses, ms_modfile, ms_modification, ms_obofile, ms_parseoptions, ms_parserule, ms_parserule_plus, ms_processoroptions, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_configfile, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_parameters, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_taxnodesfiles, ms_taxonomychoice, ms_taxonomyfile, ms_taxonomyrules, ms_taxspeciesfiles, ms_treecluster, ms_umod_aminoacid, ms_umod_composition, ms_umod_configfile, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_unigeneoptions, ms_wwwentry, ms_wwwoptions, ms_xic, ms_xml_parameter, ms_xml_parameters
  • deleteAccessionByNumber() : ms_crosslinking_accessions
  • deleteAltName() : ms_umod_modification
  • deleteAminoAcidByName() : ms_umod_configfile
  • deleteAminoAcidByNumber() : ms_umod_configfile
  • deleteComponentByName() : ms_quant_method
  • deleteComponentByNumber() : ms_quant_method
  • deleteCorrection() : ms_quant_component
  • deleteCronJob() : ms_cronoptions
  • deleteDatabaseByName() : ms_databases
  • deleteDatabaseByNumber() : ms_databases
  • deleteDenominatorByName() : ms_quant_ratio
  • deleteDenominatorByNumber() : ms_quant_ratio
  • deleteDirectory() : ms_fileutilities
  • deleteDoesNotPairWithByNumber() : ms_crosslinking_linker
  • deleteElement() : ms_quant_composition
  • deleteElementByName() : ms_umod_configfile
  • deleteElementByNumber() : ms_umod_configfile
  • deleteElemRef() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • deleteEnzymeByName() : ms_enzymefile
  • deleteEnzymeByNumber() : ms_enzymefile
  • deleteExclusion() : ms_quant_method
  • deleteFileIndex() : ms_quant_component
  • deleteGroup() : ms_security
  • deleteIgnore() : ms_quant_localdef, ms_umod_modification
  • deleteInstrumentByName() : ms_fragrulesfile
  • deleteInstrumentByNumber() : ms_fragrulesfile
  • deleteIonSeries() : ms_quant_multiplex
  • deleteIsotope() : ms_quant_component
  • deleteLinkerByNumber() : ms_crosslinking_linkers
  • deleteLocalDefinition() : ms_quant_modgroup
  • deleteMethodByName() : ms_crosslinking_configfile, ms_quant_configfile
  • deleteMethodByNumber() : ms_crosslinking_configfile, ms_quant_configfile
  • deleteModBrickByName() : ms_umod_configfile
  • deleteModBrickByNumber() : ms_umod_configfile
  • deleteModFile() : ms_quant_modgroup
  • deleteModificationByName() : ms_modfile, ms_umod_configfile
  • deleteModificationByNumber() : ms_modfile, ms_umod_configfile
  • deleteModificationGroupByName() : ms_quant_component, ms_quant_method
  • deleteModificationGroupByNumber() : ms_quant_component, ms_quant_method
  • deleteMonoLinkByNumber() : ms_crosslinking_linker
  • deleteNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • deleteNumeratorByName() : ms_quant_ratio
  • deleteNumeratorByNumber() : ms_quant_ratio
  • deleteParameterByName() : ms_crosslinking_parameters, ms_quant_parameters, ms_xml_parameters
  • deleteParameterByNumber() : ms_crosslinking_parameters, ms_quant_parameters, ms_xml_parameters
  • deletePepNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • deletePeptide() : ms_quant_normalisation_peptides
  • deleteProtein() : ms_quant_normalisation_proteins
  • deleteReportRatioByName() : ms_quant_method
  • deleteReportRatioByNumber() : ms_quant_method
  • deleteSeq() : ms_quant_method
  • deleteSpecificity() : ms_quant_localdef, ms_umod_modification
  • deleteUnmodified() : ms_quant_modgroup
  • deleteUser() : ms_group, ms_security
  • deleteXref() : ms_umod_modification
  • delNonEmpty() : ms_customproperty
  • delProp() : ms_customproperty
  • delPropByNumber() : ms_customproperty
  • delPropStart() : ms_customproperty
  • DEPRECATED_MAX_CORES_PER_LICENSE : ms_processors
  • destroy() : ms_session
  • detectOutliers() : ms_quant_stats
  • diagonalMatrix() : ms_matrix
  • DISTINCT_PEPTIDE_FLAGS : ms_protein
  • DM_BOTH : ms_mascotresults
  • DM_FASTA : ms_mascotresults
  • DM_FASTA_FIRST_PASS : ms_mascotresults
  • DM_FASTA_SECOND_PASS : ms_mascotresults
  • DM_SPECTRAL_LIBRARY : ms_mascotresults
  • DO_NORMAL : ms_http_client_search
  • DO_WITH_IONS : ms_http_client_search
  • doesFileExist() : ms_fileutilities
  • doesSectionExist() : ms_mascotresfile_dat
  • downloadDaemonResultsFile() : ms_http_client_search
  • DownloadOption : ms_http_client_search
  • downloadPercolatorFile() : ms_http_client_search
  • downloadResultsFile() : ms_http_client_search
  • downloadResultsFileMSR() : ms_http_client_search
  • downloadXmlResultsFile() : ms_http_client_search
  • DPF_CHARGE : ms_protein
  • DPF_MODS : ms_protein
  • DPF_NODUPSAMEQUERY : ms_protein
  • DPF_SEQUENCE : ms_protein
  • DPF_UNIQUE : ms_protein
  • dropAccession() : ms_quant_normalisation_protein
  • dropAccessions() : ms_crosslinking_method
  • dropAllChargeStates() : ms_quant_integration, ms_quant_precursor
  • dropAllChargeStatesThreshold() : ms_quant_integration
  • dropAllowElutionShift() : ms_quant_integration, ms_quant_precursor
  • dropAllowMassTimeMatch() : ms_quant_precursor
  • dropApproved() : ms_umod_modification
  • dropAverage() : ms_quant_moverz
  • dropAvgeMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • dropClassification() : ms_umod_specificity
  • dropCode() : ms_umod_neutralloss
  • dropCoefficient() : ms_quant_numerator
  • dropComp() : ms_quant_method
  • dropCompositionString() : ms_umod_composition
  • dropConstrainSearch() : ms_quant_method
  • dropDatabaseName() : ms_crosslinking_accession
  • dropDateTimeModified() : ms_umod_modification
  • dropDateTimePosted() : ms_umod_modification
  • dropDelta() : ms_quant_localdef, ms_umod_modification
  • dropDescription() : ms_crosslinking_method, ms_quant_method, ms_umod_neutralloss, ms_xml_parameter
  • dropElement() : ms_quant_correction
  • dropElutionProfileCorrelationThreshold() : ms_quant_integration
  • dropElutionTimeDelta() : ms_quant_integration
  • dropElutionTimeDeltaUnit() : ms_quant_integration
  • dropEntry() : ms_wwwoptions
  • dropExcludeInternalLabel() : ms_quant_multiplex
  • dropExcludeIsobaricFragments() : ms_quant_multiplex
  • dropFileIndex() : ms_quant_component
  • dropFilters() : ms_crosslinking_method
  • dropFlag() : ms_quant_neutralloss, ms_umod_neutralloss
  • dropFraction() : ms_quant_file_index
  • dropFullName() : ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • dropGroupOfPoster() : ms_umod_modification
  • dropHidden() : ms_umod_specificity
  • dropIntegration() : ms_quant_method
  • dropIonIntensityThreshold() : ms_quant_multiplex
  • dropIonSeries() : ms_quant_multiplex
  • dropIsolatedPrecursor() : ms_quant_quality
  • dropIsolatedPrecursorThreshold() : ms_quant_quality
  • dropLinkers() : ms_crosslinking_method
  • dropMassDelta() : ms_quant_integration
  • dropMassDeltaUnit() : ms_quant_integration
  • dropMatchedRho() : ms_quant_integration
  • dropMethod() : ms_quant_integration, ms_quant_normalisation, ms_quant_outliers
  • dropMinimumA1() : ms_quant_quality
  • dropMinIonPairs() : ms_quant_multiplex
  • dropMinNumPeptides() : ms_quant_method
  • dropMinPrecursorCharge() : ms_quant_quality
  • dropMiscNotes() : ms_umod_modification, ms_umod_specificity
  • dropMode() : ms_quant_modgroup
  • dropModFileName() : ms_crosslinking_does_not_pair_with, ms_crosslinking_linker
  • dropModifications() : ms_quant_satellite
  • dropMonoisotopic() : ms_quant_moverz
  • dropMonoMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • dropMoverz() : ms_quant_component
  • dropName() : ms_crosslinking_method, ms_quant_component, ms_quant_method, ms_quant_modgroup, ms_quant_numerator, ms_quant_ratio, ms_xml_parameter
  • dropNew() : ms_quant_isotope
  • dropNormalisation() : ms_quant_method
  • dropNumber() : ms_quant_element, ms_umod_elemref
  • dropNumPeptides() : ms_quant_average
  • dropOld() : ms_quant_isotope
  • dropOutliers() : ms_quant_method
  • dropPairsWith() : ms_umod_neutralloss
  • dropParseRule() : ms_parseoptions
  • dropPepThresholdType() : ms_quant_quality
  • dropPepThresholdValue() : ms_quant_quality
  • dropPeptides() : ms_quant_normalisation
  • dropPosition() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • dropPrecursorRange() : ms_quant_integration
  • dropProcessingOptions() : ms_quant_integration
  • dropProteinRatioType() : ms_quant_method
  • dropProteins() : ms_quant_normalisation
  • dropProtocol() : ms_quant_method
  • dropProtScoreType() : ms_quant_method
  • dropQuality() : ms_quant_method
  • dropRecordID() : ms_umod_modification
  • dropReferenceAccession() : ms_quant_average
  • dropReferenceAmount() : ms_quant_average
  • dropReferenceDatabase() : ms_quant_average
  • dropReportDetail() : ms_quant_method
  • dropReporterTol() : ms_quant_reporter
  • dropReporterTolUnit() : ms_quant_reporter
  • dropRequireBoldRed() : ms_quant_method
  • dropRequired() : ms_quant_modgroup, ms_quant_pepneutralloss
  • dropSatellite() : ms_quant_component
  • dropScope() : ms_crosslinking_method
  • dropSelection() : ms_quant_average
  • dropSequence() : ms_quant_normalisation_peptide
  • dropSettings() : ms_crosslinking_method
  • dropShift() : ms_quant_correction
  • dropShowSubSets() : ms_quant_method
  • dropSigThresholdValue() : ms_quant_method
  • dropSimpleRatio() : ms_quant_integration
  • dropSite() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • dropSource() : ms_quant_integration, ms_umod_xref
  • dropSpecGroup() : ms_umod_specificity
  • dropSpectralLibrary() : ms_libraryoptions
  • dropStrategy() : ms_crosslinking_method
  • dropSymbol() : ms_quant_element, ms_umod_elemref
  • dropText() : ms_umod_xref
  • dropThreeLetter() : ms_umod_aminoacid
  • dropTimeAlignmentAlgorithm() : ms_quant_replicate
  • dropTitle() : ms_quant_localdef, ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • dropTotalIntensity() : ms_quant_quality
  • dropTotalIntensityThreshold() : ms_quant_quality
  • dropType() : ms_quant_correction
  • dropUniquePepseq() : ms_quant_quality
  • dropUrl() : ms_umod_xref
  • dropUsernameOfPoster() : ms_umod_modification
  • dropValue() : ms_crosslinking_accession
  • dropXicMaxWidth() : ms_quant_integration
  • dropXicSmoothing() : ms_quant_integration
  • dropXicThreshold() : ms_quant_integration
  • DS_COUNT_PSM : ms_mascotresults
  • DS_COUNT_SEQUENCE : ms_mascotresults
  • dumpCDB() : ms_peptidesummary
  • DUPE_Duplicate : ms_protein
  • DUPE_DuplicateSameQuery : ms_protein
  • DUPE_HighestScoringDuplicate : ms_protein
  • DUPE_Ignored : ms_protein
  • DUPE_NotDuplicate : ms_protein
  • DUPLICATE : ms_protein
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • eAuto : ms_distiller_data_search
  • editedByDatabaseManager() : ms_datfile
  • eFASTA : ms_distiller_data_search
  • eGroupAuto : ms_distiller_data_search
  • eGroupFamily : ms_distiller_data_search
  • eGrouping : ms_distiller_data_search
  • eGroupStandard : ms_distiller_data_search
  • eIntegrated : ms_distiller_data_search
  • eLibrary : ms_distiller_data_search
  • empty() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • eMudpit : ms_distiller_data_search
  • enumerateQuerySectionKeys() : ms_mascotresfile_dat
  • enumerateSectionKeys() : ms_mascotresfile_dat
  • erase() : ms_http_client_mime
  • err : ms_errs, ms_mascotresfile_dat
  • ERR_ABORTEDBYUSER : ms_http_helper_return
  • ERR_ACCINPEPTIDESTR : ms_errs, ms_mascotresfile_dat
  • ERR_ADDPEPTIDES : ms_errs, ms_mascotresfile_dat
  • ERR_CANNOT_APPEND_RESFILE : ms_errs, ms_mascotresfile_dat
  • ERR_CANNOT_APPEND_RESFILE_NO_FNAMES : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_64_BIT_REMAKE : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_BEING_CREATED : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_FAIL_LOCK : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_FAIL_REMOVE : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_FAIL_UNLOCK : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_INCOMPLETE_NO_RETRY : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_INCOMPLETE_RETRY : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_OLD_VER_NO_RETRY : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_OLD_VER_RETRY : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_SOURCE_CHANGE_NO_RETRY : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_SOURCE_CHANGE_RETRY : ms_errs, ms_mascotresfile_dat
  • ERR_CDB_TOO_LARGE : ms_errs, ms_mascotresfile_dat
  • ERR_DUPE_ACCESSION : ms_errs, ms_mascotresfile_dat
  • ERR_DUPLICATE_KEY : ms_errs, ms_mascotresfile_dat
  • ERR_FAIL_CDB_INIT : ms_errs, ms_mascotresfile_dat
  • ERR_FAIL_CLOSE_FILE : ms_errs, ms_mascotresfile_dat
  • ERR_FAIL_MK_CACHE_DIR : ms_errs, ms_mascotresfile_dat
  • ERR_FAIL_MK_CDB_FILE : ms_errs, ms_mascotresfile_dat
  • ERR_FAIL_OPEN_DAT_FILE : ms_errs, ms_mascotresfile_dat
  • ERR_HTTP : ms_http_helper_return
  • ERR_INVALID_CACHE_DIR : ms_errs, ms_mascotresfile_dat
  • ERR_INVALID_CDB_FILE : ms_errs, ms_mascotresfile_dat
  • ERR_INVALID_NUMQUERIES : ms_errs, ms_mascotresfile_dat
  • ERR_INVALID_PROTDB : ms_errs, ms_mascotresfile_dat
  • ERR_INVALID_RESFILE : ms_errs, ms_mascotresfile_dat
  • ERR_MALFORMED_DRANGE : ms_errs, ms_mascotresfile_dat
  • ERR_MALFORMED_ERR_TOL : ms_errs, ms_mascotresfile_dat
  • ERR_MALFORMED_TAG : ms_errs, ms_mascotresfile_dat
  • ERR_MALFORMED_TERMS : ms_errs, ms_mascotresfile_dat
  • ERR_MISSING_CDB_FILE : ms_errs, ms_mascotresfile_dat
  • ERR_MISSING_PERCOLATOR_FILE : ms_errs, ms_mascotresfile_dat
  • ERR_MISSINGENTRY : ms_errs, ms_mascotresfile_dat
  • ERR_MISSINGHIT : ms_errs, ms_mascotresfile_dat
  • ERR_MISSINGSECTION : ms_errs, ms_mascotresfile_dat
  • ERR_MISSINGSECTIONEND : ms_errs, ms_mascotresfile_dat
  • ERR_MSP_BIND_INVALID_CPU : ms_errs
  • ERR_MSP_CACHE_DATAOFFSETINVALID : ms_errs
  • ERR_MSP_CACHE_DUPLICATESTREAMID : ms_errs
  • ERR_MSP_CACHE_FILESEEKFAILED : ms_errs
  • ERR_MSP_CACHE_INVALIDFORMAT : ms_errs
  • ERR_MSP_CACHE_INVALIDSTREAMID : ms_errs
  • ERR_MSP_CACHE_INVALIDSTREAMPOSITION : ms_errs
  • ERR_MSP_CACHE_INVALIDVERSION : ms_errs
  • ERR_MSP_CACHE_MODIFYCLOSED : ms_errs
  • ERR_MSP_CACHE_MODIFYREADONLYMODE : ms_errs
  • ERR_MSP_CACHE_OPENFAILED : ms_errs
  • ERR_MSP_CACHE_PROT_NUMPEPTIDES_RELOAD : ms_errs
  • ERR_MSP_CACHE_READFAILED : ms_errs
  • ERR_MSP_CACHE_SIGNATUREINVALID : ms_errs
  • ERR_MSP_CACHE_SLREF_UPDATE : ms_errs
  • ERR_MSP_CACHE_STREAMNOTFOUND : ms_errs
  • ERR_MSP_CACHE_UNINITIALISEDSTREAM : ms_errs
  • ERR_MSP_CACHE_WRITEFAILED : ms_errs
  • ERR_MSP_CACHE_WRITETRUNCATED : ms_errs
  • ERR_MSP_CLOSEST_FDR_FOR_ET : ms_errs
  • ERR_MSP_CLOSEST_FDR_FOR_FIRST_PASS : ms_errs
  • ERR_MSP_COLOURSCHEME_INVALID : ms_errs
  • ERR_MSP_COMPILE_PARSE_RULE : ms_errs
  • ERR_MSP_CONFLICT_BETWEEN_MODS : ms_errs
  • ERR_MSP_CRON_INVALID_CHAR : ms_errs
  • ERR_MSP_CRON_INVALID_NUMBER : ms_errs
  • ERR_MSP_CRON_INVALID_STAR : ms_errs
  • ERR_MSP_CRON_NO_NUM_BEFORE_COMMA : ms_errs
  • ERR_MSP_CRON_NO_NUM_BEFORE_MINUS : ms_errs
  • ERR_MSP_CRON_TOO_MANY_JOBS : ms_errs
  • ERR_MSP_CROSSLINKING_FAILEDLOAD : ms_errs
  • ERR_MSP_CROSSLINKING_FAILEDSAVE : ms_errs
  • ERR_MSP_CROSSLINKING_INVALID_LINK : ms_errs
  • ERR_MSP_CROSSLINKING_MULTI_LINKS : ms_errs
  • ERR_MSP_CROSSLINKING_MULTI_PEPTIDE : ms_errs
  • ERR_MSP_CROSSLINKING_VARMOD_CONFLICT : ms_errs
  • ERR_MSP_CUSTQUANT_FAILEDINIT : ms_errs
  • ERR_MSP_CUSTQUANT_PROTR_UNIM : ms_errs
  • ERR_MSP_DB_USES_MISSING_RULE : ms_errs
  • ERR_MSP_DIFFERENT_1ST_PASS_THR_ET : ms_errs
  • ERR_MSP_DOUBLE_CHARGE_NOT_ALLOWED : ms_errs
  • ERR_MSP_DUP_TAXONOMYRULE : ms_errs
  • ERR_MSP_DUPLICATE_MOD : ms_errs
  • ERR_MSP_EMPTY_MOD : ms_errs
  • ERR_MSP_ENZYME_DEFINITION_PROBLEM : ms_errs
  • ERR_MSP_ENZYME_FILE_FORMAT : ms_errs
  • ERR_MSP_ENZYME_TOO_MANY_RULES : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_DEPENDS : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_INVALID : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_LOGGING : ms_errs
  • ERR_MSP_FAIL_GET_PROCESS_AFFINITY : ms_errs
  • ERR_MSP_FAIL_GET_SYSINFO : ms_errs
  • ERR_MSP_FAIL_HWLOC_INIT : ms_errs
  • ERR_MSP_FAIL_HWLOC_LOAD : ms_errs
  • ERR_MSP_FAIL_PROCESSOR_BIND : ms_errs
  • ERR_MSP_FAIL_STAT : ms_errs
  • ERR_MSP_FAIL_THREAD_BIND : ms_errs
  • ERR_MSP_FAIL_UTIME : ms_errs
  • ERR_MSP_FAILED_TO_CLOSE_FILE : ms_errs
  • ERR_MSP_FAILED_TO_OPEN_FILE : ms_errs
  • ERR_MSP_FAILED_TO_READ_FILE : ms_errs
  • ERR_MSP_FAILED_TO_WRITE_FILE : ms_errs
  • ERR_MSP_FILE_DOESNT_EXIST : ms_errs
  • ERR_MSP_FRAGMENTATION_RULES : ms_errs
  • ERR_MSP_GET_VOLUME_INFO : ms_errs
  • ERR_MSP_HTTP_ABORTEDBYUSER : ms_errs
  • ERR_MSP_HTTP_BADHTTPSTATUS : ms_errs
  • ERR_MSP_HTTP_CHANGEPASSWORDDISABLED : ms_errs
  • ERR_MSP_HTTP_CLOSECONNECTIONFAILED : ms_errs
  • ERR_MSP_HTTP_CLOSEREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_CLOSESESSIONFAILED : ms_errs
  • ERR_MSP_HTTP_DOWNLOADFAILED : ms_errs
  • ERR_MSP_HTTP_ERROR : ms_errs
  • ERR_MSP_HTTP_GETPROXYFAILED : ms_errs
  • ERR_MSP_HTTP_GETRESULTSFILENAME : ms_errs
  • ERR_MSP_HTTP_GETSEARCHSTAGE : ms_errs
  • ERR_MSP_HTTP_HEADERFAILED : ms_errs
  • ERR_MSP_HTTP_INVALID_URL : ms_errs
  • ERR_MSP_HTTP_LOGINERROR : ms_errs
  • ERR_MSP_HTTP_LOGINERRORINT : ms_errs
  • ERR_MSP_HTTP_LOGINPARSERERROR : ms_errs
  • ERR_MSP_HTTP_LOGINPARSERERRORINT : ms_errs
  • ERR_MSP_HTTP_LOGINSERVERERROR : ms_errs
  • ERR_MSP_HTTP_LOGINSERVERERRORINT : ms_errs
  • ERR_MSP_HTTP_MAXCONECTIONS10FAILED : ms_errs
  • ERR_MSP_HTTP_MAXCONECTIONSFAILED : ms_errs
  • ERR_MSP_HTTP_MISSINGLOGINERROR : ms_errs
  • ERR_MSP_HTTP_MISSINGLOGININFO : ms_errs
  • ERR_MSP_HTTP_NORESPONSE : ms_errs
  • ERR_MSP_HTTP_OPENCONNECTIONFAILED : ms_errs
  • ERR_MSP_HTTP_OPENOUTPUTFILEFAILED : ms_errs
  • ERR_MSP_HTTP_OPENREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_OPENSESSIONFAILED : ms_errs
  • ERR_MSP_HTTP_QUERYDATAFAILED : ms_errs
  • ERR_MSP_HTTP_QUERYSTATUSFAILED : ms_errs
  • ERR_MSP_HTTP_READDATAFAILED : ms_errs
  • ERR_MSP_HTTP_READRESPONSEFAILED : ms_errs
  • ERR_MSP_HTTP_RELOGINFAILED : ms_errs
  • ERR_MSP_HTTP_SENDREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_SESSIONALREADYOPEN : ms_errs
  • ERR_MSP_HTTP_SETHTTPPASSWORDFAILED : ms_errs
  • ERR_MSP_HTTP_SETHTTPUSERNAMEFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYPASSWORDFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYUSERNAMEFAILED : ms_errs
  • ERR_MSP_HTTP_SETREDIRECTFAILED : ms_errs
  • ERR_MSP_HTTP_TRANSMISSION_FAILED : ms_errs
  • ERR_MSP_HTTP_VERSIONERROR : ms_errs
  • ERR_MSP_HTTP_WEBAUTHERROR : ms_errs
  • ERR_MSP_HTTP_WRITEOUTPUTFILEFAILED : ms_errs
  • ERR_MSP_HTTP_XMLUPLOADFAILED : ms_errs
  • ERR_MSP_IMPUTATION_AVERAGE_PROGRESS : ms_errs
  • ERR_MSP_IMPUTATION_CONSTRUCTOR : ms_errs
  • ERR_MSP_IMPUTATION_DEBUG1 : ms_errs
  • ERR_MSP_IMPUTATION_DEBUG2 : ms_errs
  • ERR_MSP_IMPUTATION_DEBUG3 : ms_errs
  • ERR_MSP_IMPUTATION_EMPTY_DATA : ms_errs
  • ERR_MSP_IMPUTATION_FAIL : ms_errs
  • ERR_MSP_IMPUTATION_FIXED_PROGRESS : ms_errs
  • ERR_MSP_IMPUTATION_KNN_BLANK_ROW : ms_errs
  • ERR_MSP_IMPUTATION_KNN_PROGRESS : ms_errs
  • ERR_MSP_IMPUTATION_MISSFOR_PROGRESS : ms_errs
  • ERR_MSP_IMPUTATION_NO_RATIOS_PEPTIDE : ms_errs
  • ERR_MSP_IMPUTATION_NO_RATIOS_PROTEIN : ms_errs
  • ERR_MSP_IMPUTATION_NO_TIMES : ms_errs
  • ERR_MSP_IMPUTATION_VARIABLE : ms_errs
  • ERR_MSP_IMPUTATION_WARNING : ms_errs
  • ERR_MSP_IN_CLUSTER_SECTION : ms_errs
  • ERR_MSP_IN_MASCOT_DAT_DB_SECT : ms_errs
  • ERR_MSP_IN_MASSES_FILE : ms_errs
  • ERR_MSP_IN_MODS_FILE : ms_errs
  • ERR_MSP_IN_OPTIONS_SECTION : ms_errs
  • ERR_MSP_IN_TAXONOMY_SECTION : ms_errs
  • ERR_MSP_INCOMPATIBLE_TAX_RULES : ms_errs
  • ERR_MSP_INST_CANTGETHOSTNAME : ms_errs
  • ERR_MSP_INST_FAILADDPARSERULE : ms_errs
  • ERR_MSP_INST_INVALIDCPUINFO : ms_errs
  • ERR_MSP_INST_MISSINGDATABASE : ms_errs
  • ERR_MSP_INVALID_CPU_PACKAGE_NUM : ms_errs
  • ERR_MSP_INVALID_LOGICAL_CPU_NUM : ms_errs
  • ERR_MSP_INVALID_MASS_IN_MASSES_FILE : ms_errs
  • ERR_MSP_INVALID_NUM_LICENSED : ms_errs
  • ERR_MSP_INVALID_PARSE_RULE : ms_errs
  • ERR_MSP_INVALID_PARSE_RULE_NO : ms_errs
  • ERR_MSP_INVALID_PROCESSOR_LINE : ms_errs
  • ERR_MSP_LEGACY_DATA_NOT_AVAILABLE : ms_errs
  • ERR_MSP_LEGACY_DATA_READ_ERROR : ms_errs
  • ERR_MSP_LEGACY_DATA_SQL_ERROR : ms_errs
  • ERR_MSP_LEGACY_DATA_WRONG_FORMAT : ms_errs
  • ERR_MSP_LICENSE_DES_CHECKSUM : ms_errs
  • ERR_MSP_LICENSE_EXPIRED : ms_errs
  • ERR_MSP_LICENSE_INTERNAL_CONFIG : ms_errs
  • ERR_MSP_LICENSE_LINE_CHECKSUM : ms_errs
  • ERR_MSP_LICENSE_LINE_INVALID : ms_errs
  • ERR_MSP_LICENSE_NOT_YET_AVAIL : ms_errs
  • ERR_MSP_LOOPLINKING_NOT_IMPLEMENTED : ms_errs
  • ERR_MSP_MALFORMED_PEPTIDE : ms_errs
  • ERR_MSP_MASCOT_NOT_RUNNING : ms_errs
  • ERR_MSP_MAX_PREFIX_REMOVES : ms_errs
  • ERR_MSP_MAX_SUFFIX_REMOVES : ms_errs
  • ERR_MSP_MAX_TAX_NO_BREAKS : ms_errs
  • ERR_MSP_MISSING_DEFINITION_END : ms_errs
  • ERR_MSP_MISSING_ENZYME_TITLE : ms_errs
  • ERR_MSP_MISSING_ET_MOD : ms_errs
  • ERR_MSP_MISSING_MASCOT_DAT : ms_errs
  • ERR_MSP_MISSING_MONOLINK_MOD : ms_errs
  • ERR_MSP_MISSING_QUOTE_IN_PARSE_RULE : ms_errs
  • ERR_MSP_MISSING_SECTION : ms_errs
  • ERR_MSP_MISSING_SL_MOD : ms_errs
  • ERR_MSP_MOD_MUST_BE_VAR : ms_errs
  • ERR_MSP_MS1QUANT_CDB_BYTES : ms_errs
  • ERR_MSP_MS1QUANT_CDB_MISSING_KEY : ms_errs
  • ERR_MSP_MS1QUANT_CDB_VERSION : ms_errs
  • ERR_MSP_MS1QUANT_GET_COMBINED_LIMITS : ms_errs
  • ERR_MSP_MS1QUANT_INVALID_PROJECT_ID : ms_errs
  • ERR_MSP_MS1QUANT_NO_EST_WIDTH : ms_errs
  • ERR_MSP_MS1QUANT_RTOFFSET_DIFF_FRACT : ms_errs
  • ERR_MSP_MS1QUANT_TIME_ALIGIN_CALCFRM : ms_errs
  • ERR_MSP_MS1QUANT_TIME_ALIGN_INDEX : ms_errs
  • ERR_MSP_MS1QUANT_XML_INVALID_BIN1 : ms_errs
  • ERR_MSP_MS1QUANT_XML_INVALID_BIN2 : ms_errs
  • ERR_MSP_MS1QUANT_XML_INVALID_RT : ms_errs
  • ERR_MSP_MS1QUANT_XML_LOAD_PROJECT_ID : ms_errs
  • ERR_MSP_MS1QUANT_XML_PARSE : ms_errs
  • ERR_MSP_MS1QUANT_XML_SAX_ELEMENT : ms_errs
  • ERR_MSP_MS1QUANT_XML_SAX_STATE : ms_errs
  • ERR_MSP_MS1QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_MS1QUANTITATION_HITREF_DROP : ms_errs
  • ERR_MSP_MS1QUANTITATION_HITREF_NEW : ms_errs
  • ERR_MSP_MS2QUANTITATION_COMPONENTS : ms_errs
  • ERR_MSP_MS2QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_MS2QUANTITATION_NORM_NO_SUM : ms_errs
  • ERR_MSP_MS2QUANTITATION_NORM_UNIMP : ms_errs
  • ERR_MSP_MS2QUANTITATION_PROTR_UNIM : ms_errs
  • ERR_MSP_MS2QUANTITATION_PROTWEIGH : ms_errs
  • ERR_MSP_MS2QUANTITATION_QUERY_SECS : ms_errs
  • ERR_MSP_MSR_CREATING_FILE : ms_errs
  • ERR_MSP_MSR_READING_FILE : ms_errs
  • ERR_MSP_MSR_WRITING_FILE : ms_errs
  • ERR_MSP_NEED_1_EXP_IN_PARSE_RULE : ms_errs
  • ERR_MSP_NIST_CANNOT_ANNOTATE_PEAK : ms_errs
  • ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY : ms_errs
  • ERR_MSP_NIST_INDEX_OUT_OF_RANGE : ms_errs
  • ERR_MSP_NIST_MODIFICATION_NOT_FOUND : ms_errs
  • ERR_MSP_NIST_MSP_INCONSISTENT_MODS : ms_errs
  • ERR_MSP_NIST_MSP_INVALID_LINE : ms_errs
  • ERR_MSP_NIST_MSP_MISSING_PARAMETER : ms_errs
  • ERR_MSP_NIST_MSP_NO_CREATE_CDB : ms_errs
  • ERR_MSP_NIST_MSP_NO_SPECTRA : ms_errs
  • ERR_MSP_NIST_NO_PEAKS_IN_SPECTRUM : ms_errs
  • ERR_MSP_NIST_NO_PRECURSOR_MZ_VALUE : ms_errs
  • ERR_MSP_NIST_SAVE_ZERO_SPECTRA : ms_errs
  • ERR_MSP_NO_COMMAS_IN_MOD_NAME : ms_errs
  • ERR_MSP_NO_ENZYME_SET : ms_errs
  • ERR_MSP_NO_LICENSE_FILE : ms_errs
  • ERR_MSP_NO_REGEX_MATCH : ms_errs
  • ERR_MSP_NO_SUCH_MOD : ms_errs
  • ERR_MSP_PARSE_LEN_EXCEED : ms_errs
  • ERR_MSP_PERCOLATOR_USE_RT_OBSOLETE : ms_errs
  • ERR_MSP_PROCESSOR_NOT_IN_SET : ms_errs
  • ERR_MSP_QUANT_ACCESSION_NOT_FOUND : ms_errs
  • ERR_MSP_QUANT_CDB_MATCH_STREAM : ms_errs
  • ERR_MSP_QUANT_CDB_MISSING_KEY : ms_errs
  • ERR_MSP_QUANT_EMPTY_REF_ACCESSION : ms_errs
  • ERR_MSP_QUANT_FAIL_LOAD_MATCH : ms_errs
  • ERR_MSP_QUANT_FAIL_LOAD_PEPTIDE : ms_errs
  • ERR_MSP_QUANT_FAILEDLOAD : ms_errs
  • ERR_MSP_QUANT_FAILEDSAVE : ms_errs
  • ERR_MSP_QUANT_HELPER_FAILEDINIT : ms_errs
  • ERR_MSP_QUANT_INVALID_REF_AMOUNT : ms_errs
  • ERR_MSP_QUANT_MISSING_COMPONENT : ms_errs
  • ERR_MSP_QUANTITATION_BADCOMPONENT : ms_errs
  • ERR_MSP_QUANTITATION_BADMETHOD : ms_errs
  • ERR_MSP_QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_QUANTITATION_NOMETHOD : ms_errs
  • ERR_MSP_REGEX_ERROR : ms_errs
  • ERR_MSP_REPORTBUILDERCOLARR_INVALID : ms_errs
  • ERR_MSP_RESIDUE_AND_TERMINUS_MOD : ms_errs
  • ERR_MSP_RULE_NO_ALREADY_DEFINED : ms_errs
  • ERR_MSP_SECURITY_ACCOUNT_DISABLED : ms_errs
  • ERR_MSP_SECURITY_ADDGROUP : ms_errs
  • ERR_MSP_SECURITY_ADDUSER : ms_errs
  • ERR_MSP_SECURITY_BAD_GROUP_NAME : ms_errs
  • ERR_MSP_SECURITY_BAD_USER_NAME : ms_errs
  • ERR_MSP_SECURITY_CMDLINE_CGI : ms_errs
  • ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP : ms_errs
  • ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS : ms_errs
  • ERR_MSP_SECURITY_DEL_SPECIAL_GROUP : ms_errs
  • ERR_MSP_SECURITY_DEL_SPECIAL_USER : ms_errs
  • ERR_MSP_SECURITY_DELETEGROUP : ms_errs
  • ERR_MSP_SECURITY_DELUSER : ms_errs
  • ERR_MSP_SECURITY_DIFFERENTIPADDR : ms_errs
  • ERR_MSP_SECURITY_DISABLE_ADMIN : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_ID : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_NAME : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_NAME_U : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_ID : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_NAME : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_NAME_U : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_GROUP : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_SEC : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_USER : ms_errs
  • ERR_MSP_SECURITY_FAIL_SAVE_SEC : ms_errs
  • ERR_MSP_SECURITY_FAILGETINTEGRA : ms_errs
  • ERR_MSP_SECURITY_FAILGETINTEGRAURL : ms_errs
  • ERR_MSP_SECURITY_GETALLGROUPIDS : ms_errs
  • ERR_MSP_SECURITY_GETALLUSERIDS : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFAIL : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFROMIDFAIL : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFROMIDOK : ms_errs
  • ERR_MSP_SECURITY_GETGROUPOK : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS1 : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS2 : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS3 : ms_errs
  • ERR_MSP_SECURITY_GETPERMTASKSFAIL : ms_errs
  • ERR_MSP_SECURITY_GETPERMTASKSOK : ms_errs
  • ERR_MSP_SECURITY_GETUSERFAIL : ms_errs
  • ERR_MSP_SECURITY_GETUSERFROMIDFAIL : ms_errs
  • ERR_MSP_SECURITY_GETUSERFROMIDOK : ms_errs
  • ERR_MSP_SECURITY_GETUSEROK : ms_errs
  • ERR_MSP_SECURITY_GROUPID_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_INTEGRACONNFORMAT : ms_errs
  • ERR_MSP_SECURITY_INTEGRAINVALIDCO : ms_errs
  • ERR_MSP_SECURITY_INTEGRAINVALIDPW : ms_errs
  • ERR_MSP_SECURITY_INVALID_SESSION_ID : ms_errs
  • ERR_MSP_SECURITY_INVALIDPASSWORD : ms_errs
  • ERR_MSP_SECURITY_INVALIDSESSION : ms_errs
  • ERR_MSP_SECURITY_INVALIDUSER : ms_errs
  • ERR_MSP_SECURITY_LOADINGSESS : ms_errs
  • ERR_MSP_SECURITY_LOADSESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_MISSINGSESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_MSSESSCOOKIE : ms_errs
  • ERR_MSP_SECURITY_MSSESSINTEGRA : ms_errs
  • ERR_MSP_SECURITY_MSSESSIONCTOR : ms_errs
  • ERR_MSP_SECURITY_MSSESSLOGIN : ms_errs
  • ERR_MSP_SECURITY_MSSESSRESULTSPERM : ms_errs
  • ERR_MSP_SECURITY_NO_GUEST_PWD : ms_errs
  • ERR_MSP_SECURITY_NO_INTEGRA_LOGIN : ms_errs
  • ERR_MSP_SECURITY_NO_RIGHTS_UPD_USR : ms_errs
  • ERR_MSP_SECURITY_NOCREATEGUEST : ms_errs
  • ERR_MSP_SECURITY_NOSAVEPARAMS : ms_errs
  • ERR_MSP_SECURITY_NOT_ADMIN_SESSION : ms_errs
  • ERR_MSP_SECURITY_NOT_ENABLED : ms_errs
  • ERR_MSP_SECURITY_NOT_INTEGRA_USER : ms_errs
  • ERR_MSP_SECURITY_NOTLOGGEDIN : ms_errs
  • ERR_MSP_SECURITY_NOTNORMALUSER : ms_errs
  • ERR_MSP_SECURITY_OLD_PW_INVALID : ms_errs
  • ERR_MSP_SECURITY_PASSWORD_TOO_SHORT : ms_errs
  • ERR_MSP_SECURITY_PASSWORDEXPIRED : ms_errs
  • ERR_MSP_SECURITY_SAMEPASSWORD : ms_errs
  • ERR_MSP_SECURITY_SAVESESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_SESSIONDESTROYED : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT1 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT2 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT3 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT4 : ms_errs
  • ERR_MSP_SECURITY_TIMEDOUT : ms_errs
  • ERR_MSP_SECURITY_UPDATEALLSESSFILES : ms_errs
  • ERR_MSP_SECURITY_UPDATEGROUP : ms_errs
  • ERR_MSP_SECURITY_UPDATEPW : ms_errs
  • ERR_MSP_SECURITY_UPDATESESS : ms_errs
  • ERR_MSP_SECURITY_UPDATEUSER : ms_errs
  • ERR_MSP_SECURITY_USERID_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_USERNAME_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRACO1 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRACO2 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW1 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW2 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW3 : ms_errs
  • ERR_MSP_SESSION_UTIME_FAIL : ms_errs
  • ERR_MSP_SL_SCORING_MODEL_FAIL : ms_errs
  • ERR_MSP_SL_SCORING_MODEL_WARN : ms_errs
  • ERR_MSP_SPECIFY_UNAVAILABLE_PROCESSOR : ms_errs
  • ERR_MSP_SYSMP_FAIL : ms_errs
  • ERR_MSP_TARGET_FDR_FAILED_FOR_ET : ms_errs
  • ERR_MSP_TARGET_FDR_FAILED_FOR_FIRST_PASS : ms_errs
  • ERR_MSP_TAXONOMY_CONFLICT_PARENTS : ms_errs
  • ERR_MSP_TAXONOMY_DEFINITION_END : ms_errs
  • ERR_MSP_TAXONOMY_INVALID_NODE_FILE : ms_errs
  • ERR_MSP_TAXONOMY_MISSING_NODE_FILE : ms_errs
  • ERR_MSP_TAXONOMY_NO_COMMAS : ms_errs
  • ERR_MSP_TAXONOMY_NO_TITLE : ms_errs
  • ERR_MSP_TAXONOMY_WRONG_LINE : ms_errs
  • ERR_MSP_TOO_MANY_MODS_IN_MOD_FILE : ms_errs
  • ERR_MSP_TOO_MANY_PROCESSORS : ms_errs
  • ERR_MSP_TOO_MANY_TH_PROCESSORS : ms_errs
  • ERR_MSP_UMOD_FAILEDLOAD : ms_errs
  • ERR_MSP_UMOD_FAILEDSAVE : ms_errs
  • ERR_MSP_UNEXPECTED_LINE_OUT_OF_SECT : ms_errs
  • ERR_MSP_WRONG_ICAT_FILTER : ms_errs
  • ERR_MSP_WRONG_MOD_VECTOR : ms_errs
  • ERR_MSP_WWW_SECTION : ms_errs
  • ERR_MSP_XHUNTER_WRONG_FORMAT : ms_errs
  • ERR_MSP_XML_ELEMENT_NOT_FOUND : ms_errs
  • ERR_MSP_XML_FAILEDLOAD : ms_errs
  • ERR_MSP_XML_FAILEDSAVE : ms_errs
  • ERR_MSP_XML_FIELD_NOTFOUND : ms_errs
  • ERR_MSP_XML_INVALID_FIELD_FORMAT : ms_errs
  • ERR_MSP_XML_LOCAL_SCHEMA_NOT_STORED : ms_errs
  • ERR_MSP_XML_MEMORY_ERROR : ms_errs
  • ERR_MSP_XML_NO_ROOT_ELEMENT : ms_errs
  • ERR_MSP_XML_SYSTEM_FAILED : ms_errs
  • ERR_MSP_XML_TABLE_NOTFOUND : ms_errs
  • ERR_MSP_XMLSCHEMA_FAILEDLOAD : ms_errs
  • ERR_MSP_XMLSCHEMA_FAILEDSAVE : ms_errs
  • ERR_MSP_ZIP_BUFTOOSMALL : ms_errs
  • ERR_MSP_ZIP_COMPRESSEDDATATOOLONG : ms_errs
  • ERR_MSP_ZIP_ENDIAN : ms_errs
  • ERR_MSP_ZIP_INVALID_STREAMING_MODE : ms_errs
  • ERR_MSP_ZIP_INVALIDDATA : ms_errs
  • ERR_MSP_ZIP_LENGTHDIFFERS : ms_errs
  • ERR_MSP_ZIP_NOTSTREAMING : ms_errs
  • ERR_MSP_ZIP_OUTOFMEMORY : ms_errs
  • ERR_MSP_ZIP_STREAMERROR : ms_errs
  • ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG : ms_errs
  • ERR_MSP_ZIP_UNKNOWN : ms_errs
  • ERR_MSP_ZIP_VERSIONERROR : ms_errs
  • ERR_MSP_ZIP_ZEROLENGTH : ms_errs
  • ERR_NEED_64_BIT : ms_errs, ms_mascotresfile_dat
  • ERR_NO_ERR_TOL_PARENT : ms_errs, ms_mascotresfile_dat
  • ERR_NO_ERROR : ms_errs, ms_mascotresfile_dat
  • ERR_NO_UNIGENE_FILE : ms_errs, ms_mascotresfile_dat
  • ERR_NOMEM : ms_errs, ms_mascotresfile_dat
  • ERR_NONE : ms_http_helper_return
  • ERR_NOSUCHFILE : ms_errs, ms_mascotresfile_dat
  • ERR_NULL_ACC_PEP_SUM : ms_errs, ms_mascotresfile_dat
  • ERR_NULL_ACC_PROT_SUM : ms_errs, ms_mascotresfile_dat
  • ERR_OLDRESULTSFILE : ms_errs, ms_mascotresfile_dat
  • ERR_PEPSUMMPEPGET : ms_errs, ms_mascotresfile_dat
  • ERR_PEPTIDESTR : ms_errs, ms_mascotresfile_dat
  • ERR_PROTSUMM : ms_errs, ms_mascotresfile_dat
  • ERR_PROTSUMMPEP : ms_errs, ms_mascotresfile_dat
  • ERR_QUERYOUTOFRANGE : ms_errs, ms_mascotresfile_dat
  • ERR_READINGFILE : ms_errs, ms_mascotresfile_dat
  • ERR_RESFILE_FUTURE_VERSION : ms_errs
  • ERR_RESFILE_INVALID_DB_TYPE : ms_errs
  • ERR_RESFILE_LINKED_SITES : ms_errs
  • ERR_RESFILE_LOOPLINKED_SITES : ms_errs
  • ERR_RESFILE_MISSING_QEXP : ms_errs
  • ERR_RESULTS_NOT_CREATED : ms_errs, ms_mascotresfile_dat
  • err_sar : ms_fileutilities
  • ERR_SYSTEM : ms_http_helper_return
  • ERR_UNASSIGNED_PROG : ms_errs, ms_mascotresfile_dat
  • ERR_UNASSIGNED_RANGE : ms_errs, ms_mascotresfile_dat
  • ERR_UNASSIGNED_UNK : ms_errs, ms_mascotresfile_dat
  • ERR_UNIGENE_MULTIDB : ms_errs, ms_mascotresfile_dat
  • ERR_UNSPECIFIED : ms_http_helper_return
  • ERR_WRITE_CDB_FILE : ms_errs, ms_mascotresfile_dat
  • ErrorTypeCode : ms_http_helper_return
  • eScoring : ms_distiller_data_search
  • eSpectralLibrary : ms_distiller_data_search
  • eStandard : ms_distiller_data_search
  • eUnknown : ms_distiller_data_search
  • excludeProteinPeptideRatioKeys() : ms_ms2quantitation
  • EXEC_AFTER_SEARCH : ms_mascotoptions
  • expTransform() : ms_quant_stats
  • extend() : ms_ms1quant_match_range
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FC_ALL_PEPTIDES : ms_mascotresults
  • FC_ALL_PEPTITDES : ms_mascotresults
  • FC_CASE_INSENSITIVE : ms_mascotresults
  • FC_CASE_SENSITIVE : ms_mascotresults
  • FC_COMPLETESTR : ms_mascotresults
  • FC_FORWARD : ms_mascotresults
  • FC_LOOP_FROM_UNASSIGNED : ms_mascotresults
  • FC_LOOP_INTO_UNASSIGNED : ms_mascotresults
  • FC_MASK_CASE : ms_mascotresults
  • FC_MASK_DIRECTION : ms_mascotresults
  • FC_MASK_STR_PART : ms_mascotresults
  • FC_PROTEIN_IGN_FAMILY : ms_mascotresults
  • FC_PROTEIN_IGN_MASK : ms_mascotresults
  • FC_PROTEIN_IGN_SAMESETS : ms_mascotresults
  • FC_PROTEIN_IGN_SUBSETS : ms_mascotresults
  • FC_PROTEIN_INC_ALT_ACC : ms_mascotresults
  • FC_RESTRICT_TO_HIT : ms_mascotresults
  • FC_REVERSE : ms_mascotresults
  • FC_SCORING_MASK : ms_mascotresults
  • FC_SEARCH_ALL_RANKS : ms_mascotresults
  • FC_SEARCH_IGNORED_RANKS : ms_mascotresults
  • FC_SIGNIFICANT_PEPTIDES : ms_mascotresults
  • FC_STARTSTR : ms_mascotresults
  • FC_STRTOK : ms_mascotresults
  • FC_SUBSTR : ms_mascotresults
  • FC_UNASSIGNED_MASK : ms_mascotresults
  • featureWidths_t : ms_ms1quant_time_align
  • file_index_value_not_set : ms_quant_file_index
  • FileMode : ms_http_helper
  • FIND_COMPARE_FLAGS : ms_mascotresults
  • FIND_FLAGS : ms_mascotresults
  • findClose() : ms_fileutilities
  • findDatabase() : ms_databases
  • findEntries() : ms_spectral_lib_file
  • findEntry() : ms_unigene
  • findIDFromTagValue() : ms_obofile
  • findMascotDat() : ms_fileutilities
  • findMatch() : ms_ms1quantitation
  • findModFile() : ms_quant_modgroup
  • findModFileName() : ms_umod_configfile
  • findModification() : ms_umod_configfile
  • findNext() : ms_fileutilities
  • findOpen() : ms_fileutilities
  • findPeptides() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • findPeptideStatus() : ms_ms1quantitation
  • findProperty() : ms_customproperty
  • findPropertyBeginning() : ms_customproperty
  • findProteins() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • findProteinsByAccession() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • findProteinsByDescription() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • findSpecGroup() : ms_umod_modification
  • finishCreate() : ms_tinycdb
  • FLAGS : ms_mascotresfilebase, ms_mascotresults
  • flush() : ms_buffer_logger
  • FM_binary : ms_http_helper
  • FM_text : ms_http_helper
  • format() : ms_http_client_mime
  • formatHeader() : ms_http_client_mime
  • formatMessage() : ms_logger
  • forwardToParentInstance() : ms_errs
  • fractionToSubProject_t : ms_ms1quant_time_align
  • FRAG_A_MINUS_H2O : ms_fragmentationrules
  • FRAG_A_MINUS_NH3 : ms_fragmentationrules
  • FRAG_A_SERIES : ms_fragmentationrules
  • FRAG_B_MINUS_H2O : ms_fragmentationrules
  • FRAG_B_MINUS_NH3 : ms_fragmentationrules
  • FRAG_B_SERIES : ms_fragmentationrules
  • FRAG_C_SERIES : ms_fragmentationrules
  • FRAG_D_SERIES : ms_fragmentationrules
  • FRAG_IMMONIUM : ms_fragmentationrules
  • FRAG_INTERNAL_YA : ms_fragmentationrules
  • FRAG_INTERNAL_YB : ms_fragmentationrules
  • FRAG_NL : ms_aahelper
  • FRAG_NL_PRIMARY : ms_aahelper
  • FRAG_NL_SECONDARY : ms_aahelper
  • FRAG_SERIES_TYPE : ms_fragmentationrules
  • FRAG_V_SERIES : ms_fragmentationrules
  • FRAG_W_SERIES : ms_fragmentationrules
  • FRAG_X_SERIES : ms_fragmentationrules
  • FRAG_Y_MINUS_H2O : ms_fragmentationrules
  • FRAG_Y_MINUS_NH3 : ms_fragmentationrules
  • FRAG_Y_SERIES : ms_fragmentationrules
  • FRAG_Z_PLUS_1 : ms_fragmentationrules
  • FRAG_Z_PLUS_2 : ms_fragmentationrules
  • FRAG_Z_SERIES : ms_fragmentationrules
  • freeHit() : ms_mascotresults, ms_peptidesummary
  • FT_PEPTIDE_CALC_MR : ms_mascotresults
  • FT_PEPTIDE_CALC_MZ : ms_mascotresults
  • FT_PEPTIDE_ETMOD : ms_mascotresults
  • FT_PEPTIDE_EXP_MR : ms_mascotresults
  • FT_PEPTIDE_EXP_MZ : ms_mascotresults
  • FT_PEPTIDE_FIND_MASK : ms_mascotresults
  • FT_PEPTIDE_FIXMOD : ms_mascotresults
  • FT_PEPTIDE_QUERY : ms_mascotresults
  • FT_PEPTIDE_SLMOD : ms_mascotresults
  • FT_PEPTIDE_STRING : ms_mascotresults
  • FT_PEPTIDE_VARMOD : ms_mascotresults
  • FT_PEPTIDE_VARMOD_BYNAME : ms_mascotresults
  • FT_PROTEIN_ACCESSION : ms_mascotresults
  • FT_PROTEIN_DESCRIPTION : ms_mascotresults
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • geometricMean() : ms_quant_stats
  • geometricStandardDeviation() : ms_quant_stats
  • get() : ms_linker_site_vector, ms_peptide_quant_key_vector, ms_spectral_lib_entry
  • get_ms_mascotresults_params() : ms_distiller_data, ms_mascotresfilebase
  • getA() : ms_fitexy_result
  • getAbsoluteValue() : ms_ms1quant_match_component
  • getAccession() : ms_protein, ms_protein_quant_ratio, ms_quant_normalisation_protein
  • getACCESSION() : ms_searchparams
  • getAccessionByNumber() : ms_crosslinking_accessions
  • getAccessionFromNumber() : ms_spectral_lib_file
  • getAccessionParseRuleIndex() : ms_databaseoptions
  • getAccessionRefParseRuleIndex() : ms_databaseoptions
  • getAccessions() : ms_crosslinking_method
  • getAccessionSchemaType() : ms_crosslinking_accessions, ms_quant_normalisation_protein
  • getAccessionsSchemaType() : ms_crosslinking_method
  • getAccFromSpeciesLine() : ms_taxonomyrules
  • getActiveKeys() : ms_protein_quant_ratio
  • getAlgorithmName() : ms_ms1quant_time_align
  • getAllChargeStatesSchemaType() : ms_quant_integration, ms_quant_precursor
  • getAllChargeStatesThreshold() : ms_quant_integration
  • getAllChargeStatesThresholdSchemaType() : ms_quant_integration
  • getAllCustomParamsForUser() : ms_security
  • getAllFamilyMembersWithThisPepMatch() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getAllGroupIDs() : ms_security
  • getAllMatchedIons() : ms_fragment
  • getAllMods() : ms_spectral_lib_file
  • getAllowElutionShiftSchemaType() : ms_quant_integration, ms_quant_precursor
  • getAllowMassTimeMatchSchemaType() : ms_quant_precursor
  • getAllParamsAsString() : ms_security_task
  • getAllProteinsWithThisPepMatch() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getAllUserIDs() : ms_group, ms_security
  • getAllUSERParams() : ms_searchparams
  • getAllValuesFromKey() : ms_tinycdb
  • getAlphaVarModsStrLength() : ms_linker_site_vector
  • getAltName() : ms_umod_modification
  • getAltNameSchemaType() : ms_umod_modification
  • getAmbiguityString() : ms_peptide
  • getAminoAcidByName() : ms_umod_configfile
  • getAminoAcidByNumber() : ms_umod_configfile
  • getAnnotation() : ms_spectral_lib_peak
  • getAnyMatch() : ms_peptide
  • getAnyProteinTermination() : ms_peptide
  • getApprovedSchemaType() : ms_umod_modification
  • getAutoDetectNumThreads() : ms_processors
  • getAvePeptideIdentityThreshold() : ms_mascotresults
  • getAverage() : ms_quant_moverz, ms_quant_protocol
  • getAverageCharge() : ms_inputquery
  • getAveragePeptideIntensity() : ms_ms1quantitation
  • getAverageResults() : ms_ms1quantitation
  • getAverageSchemaType() : ms_quant_moverz, ms_quant_protocol
  • getAverageValues() : ms_imputation_average_value
  • getAvgeMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • getAvgeMassAsNumber() : ms_umod_element
  • getAvgeMassSchemaType() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • getB() : ms_fitexy_result
  • getBetaVarModsStrLength() : ms_linker_site_vector
  • getBinSize() : ms_ms1quant_time_align
  • getBoolParam() : ms_session
  • getBucket() : ms_ms1quant_charge_state
  • getBucketWidth() : ms_ms1quant_charge_state
  • getCacheDirectory() : ms_mascotoptions, ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getCacheFileName() : ms_distiller_data_search
  • getCacheFilename() : ms_distiller_master_search
  • getCacheFileName() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getCacheFilename() : ms_peptidesummary
  • getCacheFileName() : ms_peptidesummary
  • getCacheStreamName() : ms_distiller_data_quant
  • getCarbonMass() : ms_masses, ms_searchparams
  • getCentroidWidth() : ms_mascotoptions
  • getCentroidWidthCount() : ms_mascotoptions
  • getCharge() : ms_fragment, ms_inputquery, ms_peptide, ms_peptide_quant_key
  • getCHARGE() : ms_searchparams
  • getCharge() : ms_spectral_lib_entry
  • getChargeState() : ms_ms1quant_match
  • getChargeStateData() : ms_ms1quant_match
  • getChargeType() : ms_ms1quant_match
  • getCheckNodesAliveFreq() : ms_clusterparams
  • getChecksum() : ms_spectral_lib_peak_list
  • getChecksumFromNumber() : ms_spectral_lib_file
  • getChi2() : ms_fitexy_result
  • getChopSource() : ms_parserule_plus
  • getChromosome() : ms_unigene_entry
  • getClassification() : ms_modification, ms_umod_specificity
  • getClassificationSchemaType() : ms_umod_specificity
  • getCLE() : ms_searchparams
  • getCleave() : ms_enzyme
  • getClusterParams() : ms_datfile
  • getCode() : ms_modification, ms_umod_neutralloss
  • getCodeFromXml() : ms_ms1quant_match, ms_ms1quant_match_ratio, ms_ms1quant_peptide_status, ms_xic
  • getCodeInfo() : ms_ms1quant_match_ratio
  • getCodeSchemaType() : ms_umod_neutralloss
  • getCoefficient() : ms_quant_numerator
  • getCoefficientSchemaType() : ms_quant_numerator
  • getColsToOutput() : ms_logger
  • getColumn() : ms_fragment
  • getCOM() : ms_searchparams
  • getCombinedLimits() : ms_ms1quant_time_align
  • getCombinedMaxBinNum() : ms_ms1quant_time_align_limits
  • getCombinedMaxRT() : ms_ms1quant_time_align_limits
  • getCombinedMinBinNum() : ms_ms1quant_time_align_limits
  • getCombinedMinRT() : ms_ms1quant_time_align_limits
  • getCombinedPeptideSummaryCacheStreamName() : ms_distiller_master_search
  • getCombinedReportRatio() : ms_ms2quantitation
  • getCombinedReportRatioNames() : ms_ms2quantitation
  • getCombineRepeats() : ms_errs
  • getCommandStr() : ms_cronjob
  • getComment() : ms_spectral_lib_entry
  • getCommentField() : ms_spectral_lib_entry
  • getComp() : ms_inputquery, ms_quant_method
  • getComponent() : ms_ms1quant_match, ms_ms1quant_match_component, ms_ms1quant_peptide_status, ms_protein
  • getComponentByName() : ms_quant_method
  • getComponentByNumber() : ms_quant_method
  • getComponentIntensities() : ms_ms2quantitation
  • getComponentIntensity() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getComponentProtein() : ms_mascotresults, ms_peptidesummary
  • getComponentSchemaType() : ms_quant_method
  • getComponentStr() : ms_peptide
  • getComponentString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getCompositionString() : ms_umod_composition
  • getCompositionStringSchemaType() : ms_umod_composition
  • getCompressToolAA() : ms_mascotoptions
  • getCompressToolCommandLineFasta() : ms_mascotoptions
  • getCompressToolCommandLineLibrary() : ms_mascotoptions
  • getCompressToolNA() : ms_mascotoptions
  • getCompressToolSL() : ms_mascotoptions
  • getCompSchemaType() : ms_quant_method
  • getConciseLabelFreeVarMods() : ms_ms1quant_match
  • getConnectionSettings() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile, ms_masses, ms_modfile, ms_quant_configfile, ms_taxonomyfile, ms_umod_configfile
  • getConnectionTimeout() : ms_connection_settings
  • getConsensusData() : ms_spectral_lib_peak
  • getConstantName() : ms_security_task
  • getConstrainSearchSchemaType() : ms_quant_method
  • getContent() : ms_quant_correction, ms_quant_file_index, ms_quant_numerator, ms_quant_unmodified
  • getContentSchemaType() : ms_quant_correction, ms_quant_file_index, ms_quant_numerator, ms_quant_unmodified
  • getCoreFromLogical() : ms_processors
  • getCorrectedMaxSPPwidth() : ms_ms1quant_charge_state
  • getCorrectedMinSPPwidth() : ms_ms1quant_charge_state
  • getCorrectedSPPwidth() : ms_ms1quant_charge_state
  • getCorrection() : ms_quant_component
  • getCorrectionMatrix() : ms_ms1quant_match
  • getCorrectionSchemaType() : ms_quant_component
  • getCount() : ms_http_client_mime
  • getCoverage() : ms_protein
  • getCR() : ms_matrix
  • getCrawlerNumPeaksPer100Da() : ms_mascotoptions
  • getCreatePipThreadBlockSize() : ms_mascotoptions
  • getCreatePipThreads() : ms_mascotoptions
  • getCreateSummaryProgress() : ms_mascotresults
  • getCronJob() : ms_cronoptions
  • getCronOptions() : ms_datfile
  • getCrosslinking() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getCROSSLINKING() : ms_searchparams
  • getCrosslinkingMethod() : ms_mascotresfilebase, ms_peptidesummary
  • getCtermDelta() : ms_masses
  • getCterminalMass() : ms_masses
  • getCTerminusMass() : ms_modification
  • getCTermMass() : ms_searchparams
  • getCtermNeutralLoss() : ms_masses
  • getCurrentBytes() : ms_http_helper_progress
  • getCurrentLineNumber() : ms_msr2dat28
  • getCutterType() : ms_enzyme
  • getCytoBand() : ms_unigene_entry
  • getDatabase() : ms_databases, ms_processoroptions
  • getDatabaseName() : ms_crosslinking_accession
  • getDatabaseNameSchemaType() : ms_crosslinking_accession
  • getDatabases() : ms_datfile
  • getDatabaseType() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getDataSourceId() : ms_ms1quant_match
  • getDATAURL() : ms_searchparams
  • getDataWithMissing() : ms_imputation_method
  • getDate() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getDateTimeModified() : ms_umod_modification
  • getDateTimeModifiedSchemaType() : ms_umod_modification
  • getDateTimePosted() : ms_umod_modification
  • getDateTimePostedSchemaType() : ms_umod_modification
  • getDatfile() : ms_distiller_data
  • getDB() : ms_protein, ms_protein_quant_ratio, ms_searchparams
  • getDBLevelTaxId() : ms_taxonomyrules
  • getDBType() : ms_databaseoptions
  • getDechargeFragmentPeaks() : ms_mascotoptions
  • getDECOY() : ms_searchparams
  • getDecoyTypeForDB() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getDecoyTypeNoEnzyme() : ms_mascotoptions
  • getDecoyTypeSpecific() : ms_mascotoptions
  • getDefaultDelimiter() : ms_customproperty
  • getDefaultMonitor() : ms_loggingmonitor
  • getDefaultNodeHomeDir() : ms_clusterparams
  • getDefaultNodeHomeDirFromMaster() : ms_clusterparams
  • getDefaultNodeOS() : ms_clusterparams
  • getDefaultPasswordExpiryTime() : ms_security_options
  • getDefaultPort() : ms_clusterparams
  • getDefaultRule() : ms_taxonomyrules
  • getDefaultSchemaFileName() : ms_crosslinking_configfile, ms_umod_configfile
  • getDelimiterByNumber() : ms_customproperty
  • getDelta() : ms_modification, ms_peptide, ms_quant_localdef, ms_spectral_lib_peak, ms_umod_modification
  • getDeltaSchemaType() : ms_quant_localdef, ms_umod_modification
  • getDenominatorByName() : ms_quant_ratio
  • getDenominatorByNumber() : ms_quant_ratio
  • getDenominatorSchemaType() : ms_quant_ratio
  • getDescription() : ms_crosslinking_method, ms_progress_info, ms_quant_method, ms_security_task, ms_umod_neutralloss, ms_xml_parameter
  • getDescriptionLineSep() : ms_taxonomyrules
  • getDescriptionParseRuleIndex() : ms_databaseoptions
  • getDescriptionSchemaType() : ms_crosslinking_method, ms_crosslinking_parameter, ms_quant_method, ms_quant_parameter, ms_umod_neutralloss, ms_xml_parameter
  • getDiffsAsText() : ms_security_tasks
  • getDiscoveredErrTolModDeltas() : ms_mascotresults
  • getDiscoveredErrTolModNames() : ms_mascotresults
  • getDiscoveredLocalModDeltas() : ms_mascotresults
  • getDiscoveredLocalModNames() : ms_mascotresults
  • getDisplayIntensity() : ms_ms1quant_match
  • getDisplayNonSignificantMatches() : ms_mascotoptions
  • getDistillerExperimentType() : ms_distiller_data
  • getDistillerProjectStreamName() : ms_distiller_data
  • getDistillerResfileTimestamp() : ms_distiller_data
  • getDistillerVersion() : ms_distiller_data
  • getDistinctPeptide() : ms_protein
  • getDistributor() : ms_license
  • getDoesNotPairWithByNumber() : ms_crosslinking_linker
  • getDoesNotPairWithSchemaType() : ms_crosslinking_linker
  • getDoThisRuleFirst() : ms_taxonomyrules
  • getDoubleParam() : ms_session
  • getDoubleParams() : ms_security_task
  • getElectronMass() : ms_masses, ms_searchparams
  • getElement() : ms_quant_composition, ms_quant_correction
  • getElementByName() : ms_umod_configfile
  • getElementByNumber() : ms_umod_configfile
  • getElementSchemaType() : ms_quant_composition, ms_quant_correction
  • getElemRef() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • getElemRefSchemaType() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • getElutionProfileCorrelationThreshold() : ms_quant_integration
  • getElutionProfileCorrelationThresholdSchemaType() : ms_quant_integration
  • getElutionTimeDelta() : ms_quant_integration
  • getElutionTimeDeltaSchemaType() : ms_quant_integration
  • getElutionTimeDeltaUnit() : ms_quant_integration
  • getElutionTimeDeltaUnitSchemaType() : ms_quant_integration
  • getElutionTimeShift() : ms_xic
  • getEmailAddress() : ms_session, ms_user
  • getEmailFromTextName() : ms_mascotoptions
  • getEmailFromUser() : ms_mascotoptions
  • getEmailPassword() : ms_mascotoptions
  • getEmailProfile() : ms_mascotoptions
  • getEmailService() : ms_mascotoptions
  • getEmailTimeOutPeriod() : ms_mascotoptions
  • getEncryptedPassword() : ms_user
  • getEnd() : ms_fragment
  • getEndDate() : ms_license
  • getEndIndex() : ms_xic
  • getEndScanId() : ms_xic
  • getEntry() : ms_wwwoptions
  • getEntryByName() : ms_taxonomyfile
  • getEntryByNumber() : ms_taxonomyfile
  • getEntryFromNumber() : ms_spectral_lib_file
  • getEntryFromNumberAsText() : ms_spectral_lib_file
  • getEnzyme() : ms_aahelper, ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getEnzymeByName() : ms_enzymefile
  • getEnzymeByNumber() : ms_enzymefile
  • getEnzymes() : ms_mascotfiles
  • getErrMessageEmailTo() : ms_mascotoptions
  • getError() : ms_distiller_search_status
  • getErrorCode() : ms_shapiro_wilk
  • getErrorHandler() : ms_errors
  • getErrorInfoAsString() : ms_mascotresfilebase
  • getErrorLevel() : ms_taxonomyrules
  • getErrorLogFile() : ms_mascotoptions
  • getErrorNumber() : ms_errs, ms_mascotresfilebase
  • getErrorRepeats() : ms_errs
  • getErrorSeverity() : ms_errs
  • getErrorString() : ms_errs, ms_mascotresfilebase
  • getErrorText() : ms_http_helper_return
  • getERRORTOLERANT() : ms_searchparams
  • getErrorType() : ms_http_helper_return
  • getErrTolMaxAccessions() : ms_mascotoptions
  • getErrTolModDelta() : ms_mascotresults
  • getErrTolModifiedNaSeq() : ms_mascotresults
  • getErrTolModMasterNeutralLoss() : ms_mascotresults
  • getErrTolModMasterString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getErrTolModName() : ms_mascotresults
  • getErrTolModNeutralLoss() : ms_mascotresults
  • getErrTolModPepNeutralLoss() : ms_mascotresults
  • getErrTolModPepString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getErrTolModReqPepNeutralLoss() : ms_mascotresults
  • getErrTolModReqPepString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getErrTolModSlaveNeutralLoss() : ms_mascotresults
  • getErrTolModSlaveString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getErrTolModString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getErrTolOriginalNaSeq() : ms_mascotresults
  • getErrTolParentFilename() : ms_searchparams
  • getErrTolPeptide() : ms_distiller_data_search
  • getErrTolProbabilityThreshold() : ms_mascotresults
  • getEstimatedFeatureWidth() : ms_ms1quant_time_align
  • getEvaluation() : ms_ms1quant_time_align
  • getExcludedKeys() : ms_protein_quant_ratio
  • getExcludeInternalLabelSchemaType() : ms_quant_multiplex
  • getExcludeIsobaricFragmentsSchemaType() : ms_quant_multiplex
  • getExcludeTaxonomy() : ms_taxonomychoice
  • getExclusion() : ms_quant_method
  • getExclusionSchemaType() : ms_quant_method
  • getExecAfterSearch() : ms_mascotoptions
  • getExecTime() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getExpectationValue() : ms_peptide
  • getExpress() : ms_unigene_entry
  • getFastaPath() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getFastaVer() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getFDRCountType() : ms_distiller_data_search
  • getFeatures() : ms_license
  • getFeatureTableLength() : ms_mascotoptions
  • getFeatureTableMinScore() : ms_mascotoptions
  • getFeatureWidths() : ms_ms1quant_time_align
  • getFileIndex() : ms_ms1quant_match_component, ms_quant_component
  • getFileIndexSchemaType() : ms_quant_component
  • getFileName() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile
  • getFilename() : ms_http_client_mime
  • getFileName() : ms_license, ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase, ms_masses, ms_modfile, ms_quant_configfile
  • getFILENAME() : ms_searchparams
  • getFileName() : ms_spectral_lib_entry, ms_spectral_lib_file, ms_taxnodesfiles, ms_taxonomyfile, ms_taxspeciesfiles, ms_umod_configfile
  • getFileOffset() : ms_unigene_entry
  • getFileOffsetFromKey() : ms_tinycdb
  • getFileSize() : ms_fileutilities
  • getFileTypeToSearch() : ms_parserule_plus
  • getFilters() : ms_crosslinking_method
  • getFiltersSchemaType() : ms_crosslinking_method
  • getFinalResults() : ms_ms1quant_time_align
  • getFindFileTimeout() : ms_datfile
  • getFirstPassThreshold() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getFirstProtAppearedIn() : ms_peptide
  • getFirstSerie() : ms_fragmentationrules
  • getFirstSeries() : ms_fragmentationrules
  • getFirstXicScanId() : ms_ms1quant_match
  • getFitexy() : ms_ms1quant_match_ratio
  • getFixedMods() : ms_aahelper
  • getFixedModsDelta() : ms_searchparams
  • getFixedModsName() : ms_searchparams
  • getFixedModsNeutralLoss() : ms_searchparams
  • getFixedModsResidues() : ms_searchparams
  • getFixedValue() : ms_imputation_fixed_value
  • getFlags() : ms_mascotresults, ms_mascotresults_params
  • getFlags2() : ms_mascotresults, ms_mascotresults_params
  • getFlagSchemaType() : ms_quant_neutralloss, ms_umod_neutralloss
  • getFORMAT() : ms_searchparams
  • getFormat() : ms_spectral_lib_file, ms_taxnodesfiles, ms_taxspeciesfiles
  • getFORMVER() : ms_searchparams
  • getFormVersion() : ms_mascotoptions
  • getFraction() : ms_quant_file_index, ms_quant_helper
  • getFractionSchemaType() : ms_quant_file_index
  • getFractionToSubProjectMap() : ms_ms1quant_time_align
  • getFragmentByNumber() : ms_fragmentvector
  • getFragResidueMass() : ms_masses
  • getFragRulesFile() : ms_distiller_data
  • getFrame() : ms_protein
  • getFrequencies() : ms_mascotfiles
  • getFromUnimod() : ms_modification
  • getFullName() : ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification, ms_user
  • getFullNameSchemaType() : ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • getFullUserName() : ms_session
  • getGencodeFile() : ms_taxonomyrules
  • getGene() : ms_unigene_entry
  • getGetSeqBlastAccession() : ms_mascotoptions
  • getGetSeqJobIdFile() : ms_mascotoptions
  • getGroup() : ms_security
  • getGroupFromID() : ms_security
  • getGrouping() : ms_protein
  • getGroupOfPoster() : ms_umod_modification
  • getGroupOfPosterSchemaType() : ms_umod_modification
  • getHavePeakList() : ms_distiller_sub_project
  • getHeaderComments() : ms_datfile
  • getHeaderKeyValues() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getHeaderLine() : ms_logger
  • getHeaderValue() : ms_http_helper, ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getHiddenSchemaType() : ms_umod_specificity
  • getHit() : ms_mascotresults, ms_ms1quant_match, ms_ms1quantitation, ms_peptidesummary
  • getHitNumber() : ms_protein
  • getHomologyThreshold() : ms_mascotresults
  • getHomologyThresholdForHistogram() : ms_mascotresults
  • getHostName() : ms_computeraddress, ms_wwwentry
  • getHT_IDFromLogical() : ms_processors
  • getHttpPassword() : ms_connection_settings
  • getHttpProtocol() : ms_connection_settings
  • getHttpStatusCode() : ms_http_helper_return
  • getHttpUsername() : ms_connection_settings
  • getHydrogenMass() : ms_masses, ms_searchparams
  • getHyperThreadedCPUsMask() : ms_processors
  • getHyperThreadingState() : ms_processors
  • getHypothesisPvalue() : ms_protein_quant_ratio
  • getICAT() : ms_searchparams
  • getICATFilter() : ms_mascotoptions
  • getICATHeavy() : ms_mascotoptions
  • getICATLight() : ms_mascotoptions
  • getICATQuantitationMethod() : ms_mascotoptions
  • getId() : ms_distiller_master_search, ms_distiller_search_status, ms_distiller_sub_project
  • getID() : ms_group, ms_peptide_quant_key, ms_security_task, ms_session, ms_unigene_entry, ms_user
  • getIdentifier() : ms_taxonomyrules
  • getIdxFromFileIndex() : ms_ms1quant_match_component
  • getIgnore() : ms_quant_localdef, ms_umod_modification
  • getIgnoredQPs() : ms_protein
  • getIgnoreDupeAccession() : ms_mascotoptions
  • getIgnoreIonsScoreBelow() : ms_mascotoptions, ms_mascotresults_params
  • getIgnoreMass() : ms_modification
  • getIgnoreSchemaType() : ms_quant_localdef, ms_umod_modification
  • getImputationVariableChoice() : ms_imputation
  • getImputeExcludedMs2PeptideRatios() : ms_imputation
  • getImputeMs1PeptideExcludedByCorrelationThr() : ms_imputation
  • getImputeMs1PeptideExcludedByFractionThr() : ms_imputation
  • getImputeMs1PeptideExcludedByStdErrThr() : ms_imputation
  • getImputeMs1PeptideNegativeRatio() : ms_imputation
  • getIncludeTaxonomy() : ms_taxonomychoice
  • getIndex() : ms_inputquery
  • getIndexFileName() : ms_tinycdb
  • getInetAddress() : ms_computeraddress
  • getInputQuery() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getINSTRUMENT() : ms_inputquery, ms_searchparams
  • getInstrumentByName() : ms_fragrulesfile
  • getInstrumentByNumber() : ms_fragrulesfile
  • getInstrumentName() : ms_fragrulesfile
  • getIntactLinks() : ms_peptide
  • getIntegraAppServerURL() : ms_security_options
  • getIntegraDatabaseName() : ms_security_options
  • getIntegraOracleServerName() : ms_security_options
  • getIntegration() : ms_quant_method
  • getIntegrationSchemaType() : ms_quant_method
  • getIntegraUsers() : ms_security
  • getIntensity() : ms_spectral_lib_peak
  • getIntensityNormalisationBase() : ms_ms2quantitation
  • getIntensitySigFigs() : ms_mascotoptions
  • getInterFileBasePath() : ms_mascotoptions
  • getInterFileRelPath() : ms_mascotoptions
  • getINTERMEDIATE() : ms_searchparams
  • getIntFromKey() : ms_tinycdb
  • getIntMax() : ms_inputquery
  • getIntMin() : ms_inputquery
  • getIntParam() : ms_session
  • getIonIntensityThreshold() : ms_quant_multiplex
  • getIonIntensityThresholdSchemaType() : ms_quant_multiplex
  • getIonMobility() : ms_inputquery
  • getIonsDecimalPlaces() : ms_mascotoptions
  • getIonSeries() : ms_quant_multiplex
  • getIonSeriesSchemaType() : ms_quant_multiplex
  • getIonsIntensity() : ms_peptide
  • getIonsScore() : ms_mascotresults, ms_peptide, ms_peptidesummary, ms_proteinsummary
  • getIonsScoreCorrected() : ms_mascotresults
  • getIonsScoreHistogram() : ms_mascotresults
  • getIPAddress() : ms_session
  • getIPCLogfile() : ms_clusterparams
  • getIPCLogging() : ms_clusterparams
  • getIPCTimeout() : ms_clusterparams
  • getIsDatabaseActive() : ms_http_client
  • getIsFromErrorTolerant() : ms_peptide
  • getIsFromLibrary() : ms_peptide
  • getIsolatedPrecursorSchemaType() : ms_quant_quality
  • getIsolatedPrecursorThreshold() : ms_quant_quality
  • getIsolatedPrecursorThresholdSchemaType() : ms_quant_quality
  • getIsotope() : ms_quant_component
  • getIsotopeSchemaType() : ms_quant_component
  • getIsPermitted() : ms_http_client_session
  • getIsSecurityEnabled() : ms_http_client
  • getIsWebAuthenticationEnabled() : ms_http_client
  • getIsXmlUploadedList() : ms_http_client_session
  • getIT_MODS() : ms_inputquery, ms_searchparams
  • getItemFromId() : ms_obofile
  • getITOL() : ms_searchparams
  • getITOLU() : ms_searchparams
  • getJobNumber() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getKeepAlive() : ms_mascotresfilebase
  • getKey() : ms_ms1quant_match, ms_peptide_quant_ratio
  • getKnnNumNeighbours() : ms_imputation_knn
  • getKnnUseWeightedAverage() : ms_imputation_knn
  • getKnownValues() : ms_imputation_method
  • getLabel() : ms_fragment
  • getLabelFree() : ms_ms1quantitation
  • getLabelFreeVarMods() : ms_ms1quant_match
  • getLastAccessed() : ms_session
  • getLastError() : ms_errors, ms_errs, ms_mascotresfilebase
  • getLastErrorString() : ms_errors, ms_errs, ms_mascotresfilebase
  • getLastModificationTime() : ms_fileutilities
  • getLastQueryAscFile() : ms_mascotoptions
  • getLastSerie() : ms_fragmentationrules
  • getLastSeries() : ms_fragmentationrules
  • getLastXicScanId() : ms_ms1quant_match
  • getLessThanMinPepLen() : ms_peptide
  • getLIBRARY_SEARCH() : ms_searchparams
  • getLibraryEntryId() : ms_peptidesummary
  • getLibraryModDelta() : ms_searchparams
  • getLibraryModName() : ms_searchparams
  • getLibraryMods() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getLibraryModString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getLibraryName() : ms_libraryoptions
  • getLibraryOptions() : ms_datfile
  • getLICENSE() : ms_searchparams
  • getLicensee() : ms_license
  • getLicenseString() : ms_license
  • getLicenseVersion() : ms_license
  • getLine() : ms_spectral_lib_entry
  • getLinkerByNumber() : ms_crosslinking_linkers
  • getLinkerMass() : ms_linker_site
  • getLinkers() : ms_crosslinking_method
  • getLinkerSchemaType() : ms_crosslinking_linkers
  • getLinkersSchemaType() : ms_crosslinking_method
  • getLinkFrom() : ms_linker_site
  • getLinkTo() : ms_linker_site
  • getLoaded() : ms_distiller_data_search
  • getLoadedSearchIndex() : ms_distiller_data
  • getLoadUnassigned() : ms_distiller_data_search
  • getLocalDefinition() : ms_quant_modgroup
  • getLocalDefinitionSchemaType() : ms_quant_modgroup
  • getLocalModifications() : ms_quant_method
  • getLocalModsNlStr() : ms_peptide
  • getLocalModsStr() : ms_peptide
  • getLocalVarModName() : ms_inputquery
  • getLocus() : ms_inputquery
  • getLocusLink() : ms_unigene_entry
  • getLogEventsHandler() : ms_loggingmonitor
  • getLogFileName() : ms_cronoptions
  • getLogFilename() : ms_file_logger
  • getLogFileName() : ms_security_options
  • getLoggingFileName() : ms_errs
  • getLoggingLevel() : ms_cronoptions, ms_errs, ms_log, ms_security_options
  • getLogMask() : ms_loggingmonitor
  • getLogoImageFile() : ms_mascotoptions
  • getLongestPeptideLen() : ms_protein
  • getLongestSigPeptideLen() : ms_protein
  • getLongParam() : ms_session
  • getLongParams() : ms_security_task
  • getLoopLinks() : ms_peptide
  • getMailTempFile() : ms_mascotoptions
  • getMailTransport() : ms_mascotoptions
  • getMajorVersion() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • getMascNodeCtrlFile() : ms_mascotoptions
  • getMascotCmdLine() : ms_mascotoptions
  • getMascotControlFile() : ms_mascotoptions
  • getMascotFileProcessingThreads() : ms_mascotoptions
  • getMascotFiles() : ms_datfile
  • getMascotJobIdFile() : ms_mascotoptions
  • getMascotMessage() : ms_mascotoptions
  • getMascotNodeRebootScript() : ms_clusterparams
  • getMascotNodeScript() : ms_clusterparams
  • getMascotOptions() : ms_datfile
  • getMascotSearchURL() : ms_distiller_data_search
  • getMascotSecurityOptions() : ms_security
  • getMascotServerURL() : ms_distiller_data_search
  • getMascotVer() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getMass() : ms_fragment
  • getMASS() : ms_searchparams
  • getMassDecimalPlaces() : ms_mascotoptions
  • getMassDelta() : ms_quant_integration
  • getMassDeltaSchemaType() : ms_quant_integration
  • getMassDeltaUnit() : ms_quant_integration
  • getMassDeltaUnitSchemaType() : ms_quant_integration
  • getMasses() : ms_aahelper, ms_mascotresfilebase, ms_protein
  • getMassesKeyValues() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getMassesWithinTolerance() : ms_fragmentvector
  • getMassFile() : ms_modfile, ms_modification
  • getMassMax() : ms_inputquery
  • getMassMin() : ms_inputquery
  • getMassType() : ms_searchparams
  • getMassValue() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getMasterComputer() : ms_clusterparams
  • getMasterProjectStreamName() : ms_distiller_master_project
  • getMatch() : ms_ms1quantitation
  • getMatchedFraction() : ms_ms1quant_charge_state, ms_ms1quant_match_component
  • getMatchedIonIntensity() : ms_fragment
  • getMatchedIonMass() : ms_fragment
  • getMatchedRho() : ms_ms1quant_charge_state, ms_ms1quant_match_component, ms_quant_integration
  • getMatchedRhoSchemaType() : ms_quant_integration
  • getMatchForHit() : ms_ms1quantitation
  • getMaxAlignment() : ms_ms1quant_charge_state
  • getMaxConcurrentSearches() : ms_mascotoptions
  • getMaxDatabases() : ms_mascotoptions
  • getMaxDescriptionLen() : ms_mascotoptions
  • getMaxEtagMassDelta() : ms_mascotoptions
  • getMaxEtVarMods() : ms_mascotoptions
  • getMaxHitsToReport() : ms_mascotresults_params
  • getMaxIntactCrosslinkPeptides() : ms_mascotoptions
  • getMaxInternalMass() : ms_fragmentationrules, ms_inputquery, ms_searchparams
  • getMaxMZ() : ms_ms1quant_time_align_limits
  • getMaxNumOfReportBuilderColumnArrangements() : ms_mascotoptions
  • getMaxNumPeptides() : ms_mascotoptions
  • getMaxPepModArrangements() : ms_mascotoptions
  • getMaxPepNumModifiedSites() : ms_mascotoptions
  • getMaxPepNumVarMods() : ms_mascotoptions
  • getMaxPeptideIdentityThreshold() : ms_mascotresults
  • getMaxQueries() : ms_mascotoptions
  • getMaxRankValue() : ms_mascotresults
  • getMaxRT() : ms_ms1quant_time_align_limits
  • getMaxSearchesPerUser() : ms_mascotoptions
  • getMaxSequenceLen() : ms_mascotoptions
  • getMaxTaxonomyRules() : ms_datfile
  • getMaxVarMods() : ms_mascotoptions
  • getMD5Sum() : ms_fileutilities
  • getMemberNumber() : ms_protein
  • getMessageSource() : ms_log
  • getMethod() : ms_quant_integration, ms_quant_normalisation, ms_quant_outliers
  • getMethodByName() : ms_crosslinking_configfile, ms_quant_configfile
  • getMethodByNumber() : ms_crosslinking_configfile, ms_quant_configfile
  • getMethodSchemaType() : ms_quant_integration, ms_quant_normalisation, ms_quant_outliers
  • getMinEtagMassDelta() : ms_mascotoptions
  • getMinimumA1() : ms_quant_quality
  • getMinimumA1SchemaType() : ms_quant_quality
  • getMinimumPasswordLength() : ms_security_options
  • getMinInternalMass() : ms_fragmentationrules, ms_inputquery, ms_searchparams
  • getMinIonPairs() : ms_quant_multiplex
  • getMinIonPairsSchemaType() : ms_quant_multiplex
  • getMinMZ() : ms_ms1quant_time_align_limits
  • getMinNumPeptides() : ms_quant_method, ms_quantitation
  • getMinNumPeptidesSchemaType() : ms_quant_method
  • getMinNumSigUniqueSequences() : ms_mascotresults_params
  • getMinorVersion() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • getMinPepLenInPepSummary() : ms_distiller_data_search, ms_mascotoptions, ms_mascotresults
  • getMinPepLenInPeptideSummary() : ms_mascotresults_params
  • getMinPepLenInSearch() : ms_mascotoptions
  • getMinPrecursorCharge() : ms_quant_quality
  • getMinPrecursorChargeSchemaType() : ms_quant_quality
  • getMinProbability() : ms_mascotresults_params
  • getMinProbabilityForSLScore() : ms_peptidesummary
  • getMinRT() : ms_ms1quant_time_align_limits
  • getMiscNotes() : ms_umod_modification, ms_umod_specificity
  • getMiscNotesSchemaType() : ms_umod_modification, ms_umod_specificity
  • getMissed() : ms_aahelper
  • getMissedCleavages() : ms_peptide
  • getMissingIndexes() : ms_imputation_method
  • getML_ADAPTER_PARAM() : ms_searchparams
  • getModBrickByName() : ms_umod_configfile
  • getModBrickByNumber() : ms_umod_configfile
  • getMode() : ms_quant_modgroup
  • getModeSchemaType() : ms_quant_modgroup
  • getModFile() : ms_quant_modgroup
  • getModFileList() : ms_umod_configfile, ms_umod_modification
  • getModFileName() : ms_crosslinking_does_not_pair_with, ms_crosslinking_linker
  • getModFileNameSchemaType() : ms_crosslinking_does_not_pair_with, ms_crosslinking_linker
  • getModFileSchemaType() : ms_quant_modgroup
  • getModificationByName() : ms_modfile, ms_modvector, ms_umod_configfile
  • getModificationByNumber() : ms_modfile, ms_modvector, ms_umod_configfile
  • getModificationGroupByName() : ms_quant_component, ms_quant_method
  • getModificationGroupByNumber() : ms_quant_component, ms_quant_method
  • getModificationGroupSchemaType() : ms_quant_component, ms_quant_method
  • getModifications() : ms_mascotfiles, ms_quant_satellite
  • getModificationsSchemaType() : ms_quant_satellite
  • getModificationType() : ms_modification
  • getModifiedResidue() : ms_modification
  • getMODS() : ms_searchparams
  • getMods() : ms_spectral_lib_entry
  • getModsFromNumber() : ms_spectral_lib_file
  • getMonitorEmailCheckFreq() : ms_mascotoptions
  • getMonitorLogFile() : ms_mascotoptions
  • getMonitorPidFile() : ms_mascotoptions
  • getMonitorTestTimeout() : ms_mascotoptions
  • getMonoisotopic() : ms_quant_moverz
  • getMonoisotopicSchemaType() : ms_quant_moverz
  • getMonoLinkByNumber() : ms_crosslinking_linker
  • getMonoLinkModification() : ms_mascotresfilebase
  • getMonoLinkSchemaType() : ms_crosslinking_linker
  • getMonoLinkStr() : ms_peptide
  • getMonoLinkTitle() : ms_modification
  • getMonoMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • getMonoMassAsNumber() : ms_umod_element
  • getMonoMassSchemaType() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • getMoverz() : ms_ms1quant_match_component, ms_quant_component
  • getMoverzSchemaType() : ms_quant_component
  • getMrCalc() : ms_peptide
  • getMrExperimental() : ms_peptide
  • getMSParserVersion() : ms_mascotresfilebase
  • getMudpit() : ms_mascotoptions
  • getMudpitSwitch() : ms_mascotoptions
  • getMULTI_SITE_MODS() : ms_searchparams
  • getMultiFileQueryNumber() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getMultiplex() : ms_quant_protocol
  • getMultiplexSchemaType() : ms_quant_protocol
  • getMultithreadedName() : ms_processors
  • getMW() : ms_spectral_lib_entry
  • getMz() : ms_spectral_lib_peak
  • getName() : ms_crosslinking_method, ms_databaseoptions, ms_dbprocessors, ms_distiller_sub_project, ms_group, ms_http_client_mime, ms_quant_component, ms_quant_method, ms_quant_modgroup, ms_quant_numerator, ms_quant_ratio, ms_spectral_lib_entry, ms_user, ms_wwwentry, ms_xml_parameter
  • getNameOfDB() : ms_parserule_plus
  • getNameSchemaType() : ms_crosslinking_method, ms_crosslinking_parameter, ms_quant_component, ms_quant_method, ms_quant_modgroup, ms_quant_numerator, ms_quant_parameter, ms_quant_ratio, ms_xml_parameter
  • getNeutralLoss() : ms_fragment, ms_modification, ms_quant_specificity, ms_umod_specificity
  • getNeutralLossRequired() : ms_modification
  • getNeutralLossSchemaType() : ms_quant_specificity, ms_umod_specificity
  • getNew() : ms_quant_isotope
  • getNewSchemaType() : ms_quant_isotope
  • getNextFamilyProtein() : ms_mascotresults
  • getNextLine() : ms_msr2dat28
  • getNextPeptide() : ms_aahelper
  • getNextSimilarProtein() : ms_mascotresults
  • getNextSimilarProteinOf() : ms_mascotresults
  • getNextSubsetProtein() : ms_mascotresults
  • getNextSubsetProteinOf() : ms_mascotresults
  • getNitrogenMass() : ms_masses, ms_searchparams
  • getNoBreakDescLineIf() : ms_taxonomyrules
  • getNodeListFile() : ms_mascotfiles
  • getNodeSequenceDatabaseDir() : ms_clusterparams
  • getNodesFile() : ms_taxonomyrules
  • getNonMudpitScore() : ms_protein
  • getNoResultsScript() : ms_mascotoptions
  • getNormalisation() : ms_quant_method
  • getNormalisationSchemaType() : ms_quant_method
  • getNormalityPvalue() : ms_protein_quant_ratio
  • getNotes() : ms_security_task
  • getNtermDelta() : ms_masses
  • getNterminalMass() : ms_masses
  • getNTerminusMass() : ms_modification
  • getNTermMass() : ms_searchparams
  • getNtermNeutralLoss() : ms_masses
  • getNTIUserGroup() : ms_mascotoptions
  • getNTMonitorGroup() : ms_mascotoptions
  • getNum13C() : ms_peptide
  • getNumAccessions() : ms_unigene_entry
  • getNumAvailableToProcess() : ms_processors
  • getNumber() : ms_quant_element, ms_umod_elemref
  • getNumberOfAccessionDBTypes() : ms_peptidesummary
  • getNumberOfAccessions() : ms_crosslinking_accessions
  • getNumberOfAltNames() : ms_umod_modification
  • getNumberOfAminoAcids() : ms_umod_configfile
  • getNumberOfBuckets() : ms_ms1quant_charge_state
  • getNumberOfComponents() : ms_quant_method
  • getNumberOfCorrections() : ms_quant_component
  • getNumberOfCronJobs() : ms_cronoptions
  • getNumberOfCutters() : ms_enzyme
  • getNumberOfDatabases() : ms_databases, ms_processoroptions, ms_searchparams
  • getNumberOfDenominators() : ms_quant_ratio
  • getNumberOfDoesNotPairWiths() : ms_crosslinking_linker
  • getNumberOfElements() : ms_quant_composition, ms_umod_configfile
  • getNumberOfElemRefs() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • getNumberOfEntries() : ms_obofile, ms_taxonomyfile, ms_wwwoptions
  • getNumberOfEnzymes() : ms_enzymefile
  • getNumberOfErrors() : ms_errs, ms_mascotresfilebase
  • getNumberOfExcludeTaxonomies() : ms_taxonomychoice
  • getNumberOfExclusions() : ms_quant_method
  • getNumberOfFamilyAccessionDBTypes() : ms_peptidesummary
  • getNumberOfFamilyMembers() : ms_mascotresults
  • getNumberOfFileIndexes() : ms_quant_component
  • getNumberOfFragments() : ms_fragmentvector
  • getNumberOfGencodeFiles() : ms_taxonomyrules
  • getNumberOfHits() : ms_mascotresults
  • getNumberOfIgnoreDupeAccessions() : ms_mascotoptions
  • getNumberOfIgnoreMasses() : ms_modification
  • getNumberOfIgnores() : ms_quant_localdef, ms_umod_modification
  • getNumberOfIncludeTaxonomies() : ms_taxonomychoice
  • getNumberOfInstruments() : ms_fragrulesfile
  • getNumberOfIonSeries() : ms_quant_multiplex
  • getNumberOfIsotopes() : ms_quant_component
  • getNumberOfLibraries() : ms_libraryoptions
  • getNumberOfLibraryMods() : ms_searchparams
  • getNumberOfLinkedPeptides() : ms_peptide
  • getNumberOfLinkers() : ms_crosslinking_linkers
  • getNumberOfLocalDefinitions() : ms_quant_modgroup
  • getNumberOfLocalVarMods() : ms_inputquery
  • getNumberOfMethods() : ms_crosslinking_configfile, ms_quant_configfile
  • getNumberOfModBricks() : ms_umod_configfile
  • getNumberOfModFiles() : ms_quant_modgroup
  • getNumberOfModificationGroups() : ms_quant_component, ms_quant_method
  • getNumberOfModifications() : ms_modfile, ms_modvector, ms_umod_configfile
  • getNumberOfModifiedResidues() : ms_modification
  • getNumberOfMonoLinks() : ms_crosslinking_linker
  • getNumberOfNeutralLosses() : ms_quant_specificity, ms_umod_specificity
  • getNumberOfNoBreakDescLineIf() : ms_taxonomyrules
  • getNumberOfNodesFiles() : ms_taxonomyrules
  • getNumberOfNumerators() : ms_quant_ratio
  • getNumberOfParameters() : ms_crosslinking_parameters, ms_quant_parameters, ms_xml_parameters
  • getNumberOfParseRules() : ms_parseoptions
  • getNumberOfPeaks() : ms_inputquery
  • getNumberOfPepNeutralLosses() : ms_quant_specificity, ms_umod_specificity
  • getNumberOfPeptides() : ms_quant_normalisation_peptides
  • getNumberOfPerDbSrcRules() : ms_taxonomyrules
  • getNumberOfPrefixRemoves() : ms_taxonomyrules
  • getNumberOfProcessors() : ms_processoroptions
  • getNumberOfProperties() : ms_customproperty
  • getNumberOfProteins() : ms_quant_normalisation_proteins
  • getNumberOfReportNumberChoices() : ms_mascotoptions
  • getNumberOfReportRatios() : ms_quant_method
  • getNumberOfResfiles() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getNumberOfSeqs() : ms_quant_method
  • getNumberOfSpeciesFiles() : ms_taxonomyrules
  • getNumberOfSpecificities() : ms_quant_localdef, ms_umod_modification
  • getNumberOfStrFiles() : ms_taxonomyrules
  • getNumberOfSubClusters() : ms_clusterparams
  • getNumberOfSubtasks() : ms_progress_info
  • getNumberOfSuffixRemoves() : ms_taxonomyrules
  • getNumberOfTargetFDRPercentages() : ms_mascotoptions
  • getNumberOfTasks() : ms_security_tasks
  • getNumberOfThreads() : ms_databaseoptions, ms_dbprocessors
  • getNumberOfUnassigned() : ms_mascotresults
  • getNumberOfUnmodified() : ms_quant_modgroup
  • getNumberOfXrefs() : ms_umod_modification
  • getNumberSchemaType() : ms_quant_element, ms_umod_elemref
  • getNumComponents() : ms_ms1quant_match, ms_protein
  • getNumCores() : ms_processors
  • getNumDecoyHitsAboveHomology() : ms_mascotresults
  • getNumDecoyHitsAboveIdentity() : ms_mascotresults
  • getNumDiscoveredErrTolMods() : ms_mascotresults
  • getNumDiscoveredFixedMods() : ms_mascotresults
  • getNumDiscoveredIntactLinks() : ms_mascotresults
  • getNumDiscoveredLibraryMods() : ms_mascotresults
  • getNumDiscoveredLocalMods() : ms_mascotresults
  • getNumDiscoveredNonSpecCleavage() : ms_mascotresults
  • getNumDiscoveredVariableMods() : ms_mascotresults
  • getNumDisplayPeptides() : ms_protein
  • getNumDistinctPeptideRepeats() : ms_protein
  • getNumDistinctPeptides() : ms_protein
  • getNumEntries() : ms_spectral_lib_file
  • getNumeratorByName() : ms_quant_ratio
  • getNumeratorByNumber() : ms_quant_ratio
  • getNumeratorSchemaType() : ms_quant_ratio
  • getNumEtSeqsSearched() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getNumFileIndexesMatched() : ms_ms1quant_match_component
  • getNumGroups() : ms_ms1quantitation
  • getNumHits() : ms_mascotresfile_dat, ms_ms1quant_match, ms_ms1quantitation
  • getNumHitsAboveHomology() : ms_mascotresults
  • getNumHitsAboveIdentity() : ms_mascotresults
  • getNumIonsMatched() : ms_peptide
  • getNumLibraryEntries() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getNumLogEventsHandlers() : ms_loggingmonitor
  • getNumLogicalPerPhysical() : ms_processors
  • getNumMatches() : ms_ms1quantitation
  • getNumMatchesForGroup() : ms_ms1quantitation
  • getNumMatchesForHit() : ms_ms1quantitation
  • getNumObservedForEmPAI() : ms_protein
  • getNumOnSystem() : ms_processors
  • getNumPeaks() : ms_spectral_lib_entry, ms_spectral_lib_peak_list
  • getNumPeptideRatios() : ms_ms1quant_match
  • getNumPeptides() : ms_ms1quant_match_component, ms_protein, ms_quant_average
  • getNumPeptidesSchemaType() : ms_quant_average
  • getNumPeptideStatuses() : ms_ms1quantitation
  • getNumPhysicalOnSystem() : ms_processors
  • getNumPmfQueriesUsed() : ms_proteinsummary
  • getNumPoints() : ms_xic
  • getNumProcessorGroups() : ms_processors
  • getNumProcessorsLicensed() : ms_license
  • getNumProteinFamilies() : ms_ms1quantitation
  • getNumProteins() : ms_peptide
  • getNumQueries() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase, ms_ms1quant_time_align_limits
  • getNumQueriesAboveThreshold() : ms_ms1quant_time_align_limits
  • getNumRanges() : ms_ms1quant_match_component
  • getNumResidues() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase, ms_spectral_lib_file
  • getNumSearches() : ms_distiller_master_project, ms_distiller_search_status_list
  • getNumSeqs() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getNumSeqsAfterTax() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getNumSubprojects() : ms_distiller_master_project
  • getNumSubsearches() : ms_distiller_master_search
  • getNumUsed() : ms_inputquery
  • getNumVals() : ms_inputquery
  • getObserved() : ms_peptide
  • getObservedCharge() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getObservedIntensity() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getObservedMass() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getObservedMrValue() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getOld() : ms_quant_isotope
  • getOldSchemaType() : ms_quant_isotope
  • getOpaqueString() : ms_peptide_quant_key
  • getOpaqueStringAndID() : ms_peptide_quant_key
  • getOsName() : ms_http_client
  • getOutlierKeys() : ms_protein_quant_ratio
  • getOutliers() : ms_quant_method
  • getOutliersSchemaType() : ms_quant_method
  • getOVERVIEW() : ms_searchparams
  • getOxygenMass() : ms_masses, ms_searchparams
  • getPairsWith() : ms_modification, ms_umod_neutralloss
  • getPairsWithSchemaType() : ms_umod_neutralloss
  • getParameterByName() : ms_crosslinking_parameters, ms_quant_parameters
  • getParameterByNumber() : ms_crosslinking_parameters, ms_quant_parameters
  • getParameterSchemaType() : ms_crosslinking_filters, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_quant_parameters, ms_xml_parameters
  • getParams() : ms_session
  • getParent() : ms_taxonomytree
  • getParseOptions() : ms_datfile
  • getParseRule() : ms_parseoptions, ms_wwwentry
  • getPasswordExpiry() : ms_user
  • getPath() : ms_databaseoptions, ms_wwwentry
  • getPeak() : ms_spectral_lib_peak_list
  • getPeakAnnotationLevel() : ms_spectral_lib_peak_list
  • getPeakCharge() : ms_inputquery
  • getPeakEndIndex() : ms_xic
  • getPeakEndScanId() : ms_xic
  • getPeakIntensity() : ms_inputquery
  • getPeakList() : ms_inputquery, ms_spectral_lib_entry
  • getPeakListChecksum() : ms_spectral_lib_entry
  • getPeakListObject() : ms_spectral_lib_entry
  • getPeakMass() : ms_inputquery
  • getPeakStartIndex() : ms_xic
  • getPeakStartScanId() : ms_xic
  • getPeakState() : ms_xic
  • getPeaksUsedFromIons1() : ms_peptide
  • getPeaksUsedFromIons2() : ms_peptide
  • getPeaksUsedFromIons3() : ms_peptide
  • getPEP_ISOTOPE_ERROR() : ms_searchparams
  • getPepEnd() : ms_aahelper
  • getPepNeutralLoss() : ms_modification, ms_quant_specificity, ms_umod_specificity
  • getPepNeutralLossSchemaType() : ms_quant_specificity, ms_umod_specificity
  • getPepNumber() : ms_protein
  • getPepSearchTool() : ms_mascotoptions
  • getPepSearchToolCommandLine() : ms_mascotoptions
  • getPepStart() : ms_aahelper
  • getPepsWithSameScore() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getPepThresholdType() : ms_quant_quality
  • getPepThresholdTypeSchemaType() : ms_quant_quality
  • getPepThresholdValue() : ms_quant_quality
  • getPepThresholdValueSchemaType() : ms_quant_quality
  • getPeptide() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary, ms_quant_normalisation_peptides
  • getPeptideAmbiguityRanks() : ms_peptidesummary
  • getPeptideComponentID() : ms_protein
  • getPeptideDuplicate() : ms_protein
  • getPeptideEnd() : ms_protein
  • getPeptideExpectationValue() : ms_mascotresults
  • getPeptideFrame() : ms_protein
  • getPeptideIdentityThreshold() : ms_mascotresults
  • getPeptideIonsScore() : ms_protein
  • getPeptideIsBold() : ms_protein
  • getPeptideKey() : ms_ms1quant_match_component
  • getPeptideLength() : ms_peptide
  • getPeptideMultiplicity() : ms_protein
  • getPeptideP() : ms_protein
  • getPeptideQuantKeys() : ms_quantitation
  • getPeptideQuery() : ms_protein
  • getPeptideRatio() : ms_customquantitation, ms_ms1quant_match, ms_ms2quantitation, ms_quantitation
  • getPeptideRatioNormalisationBase() : ms_quantitation
  • getPeptideResidueAfter() : ms_protein
  • getPeptideResidueBefore() : ms_protein
  • getPeptides() : ms_quant_normalisation
  • getPeptideSchemaType() : ms_quant_normalisation_peptides
  • getPeptideSection() : ms_mascotresfile_dat
  • getPeptideShowCheckbox() : ms_protein
  • getPeptidesSchemaType() : ms_quant_normalisation
  • getPeptideStart() : ms_protein
  • getPeptideStatus() : ms_ms1quantitation
  • getPeptideStr() : ms_peptide
  • getPeptideString() : ms_ms1quant_match
  • getPeptideSubstring() : ms_fragment
  • getPeptideSummary() : ms_ms1quantitation, ms_ms2quantitation
  • getPeptideSummaryCacheStreamName() : ms_distiller_search_status
  • getPeptideSummaryFlags() : ms_distiller_data_search
  • getPeptideSummaryFlags2() : ms_distiller_data_search
  • getPeptideThreshold() : ms_mascotresults
  • getPepTol() : ms_inputquery
  • getPepTolString() : ms_inputquery
  • getPepTolUnits() : ms_inputquery
  • getPERCOLATE() : ms_searchparams
  • getPercolator() : ms_distiller_data_search
  • getPercolatorExeFlags() : ms_mascotoptions
  • getPercolatorFeatures() : ms_mascotoptions
  • getPercolatorFileNames() : ms_mascotresfilebase
  • getPercolatorMinQueries() : ms_mascotoptions
  • getPercolatorMinSequences() : ms_mascotoptions
  • getPercolatorRtFlags() : ms_mascotoptions
  • getPercolatorScores() : ms_peptide
  • getPercolatorTargetRankRelativeThreshold() : ms_mascotoptions
  • getPercolatorTargetRankScoreThreshold() : ms_mascotoptions
  • getPercolatorUseProteins() : ms_distiller_data_search
  • getPercolatorUseRT() : ms_distiller_data_search
  • getPerDbSrcRule() : ms_taxonomyrules
  • getPerfectObservedMatrix() : ms_ms1quant_match
  • getPermittedTasks() : ms_group, ms_session
  • getPermittedTasksForUser() : ms_security
  • getPFA() : ms_searchparams
  • getPhysicalFromLogical() : ms_processors
  • getPoint() : ms_xic
  • getPort() : ms_computeraddress
  • getPortNumber() : ms_wwwentry
  • getPosition() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • getPositionSchemaType() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • getPreceedingComments() : ms_customproperty, ms_databaseoptions
  • getPrecursor() : ms_quant_protocol
  • getPRECURSOR() : ms_searchparams
  • getPrecursorChargeFromNumber() : ms_spectral_lib_file
  • getPrecursorCutOutLowerLimit() : ms_mascotoptions
  • getPrecursorCutOutUpperLimit() : ms_mascotoptions
  • getPrecursorMZ() : ms_spectral_lib_entry
  • getPrecursorMZFromNumber() : ms_spectral_lib_file
  • getPrecursorRange() : ms_quant_integration
  • getPrecursorRangeSchemaType() : ms_quant_integration
  • getPrecursorSchemaType() : ms_quant_protocol
  • getPredictionMatrix() : ms_ms1quant_match
  • getPrefixRemove() : ms_taxonomyrules
  • getPrettyRank() : ms_peptide
  • getPrimaryNlStr() : ms_peptide
  • getProbabilityThreshold() : ms_mascotresults
  • getProbFromScore() : ms_mascotresults
  • getProbOfPepBeingRandomMatch() : ms_mascotresults
  • getProbOfProteinBeingRandomMatch() : ms_mascotresults
  • getProcessingOptions() : ms_quant_integration
  • getProcessingOptionsSchemaType() : ms_quant_integration
  • getProcessor() : ms_processoroptions
  • getProcessorName() : ms_processors
  • getProcessors() : ms_datfile
  • getProgress() : ms_progress_info
  • getProgressInfo() : ms_mascotresfilebase, ms_quantitation
  • getProjectRelativePath() : ms_distiller_sub_project
  • getPropertyName() : ms_customproperty
  • getProportion() : ms_http_helper_progress
  • getPropValStringByName() : ms_customproperty
  • getPropValStringByNumber() : ms_customproperty
  • getProtein() : ms_mascotresults, ms_peptide, ms_peptidesummary, ms_quant_normalisation_proteins
  • getProteinDescription() : ms_mascotresults
  • getProteinEmPAI() : ms_mascotresults, ms_peptidesummary
  • getProteinExpectationValue() : ms_mascotresults
  • getProteinFamilySwitch() : ms_mascotoptions
  • getProteinGrouping() : ms_distiller_data_search
  • getProteinId() : ms_protein
  • getProteinMass() : ms_mascotresults
  • getProteinRatio() : ms_customquantitation, ms_ms1quantitation, ms_ms2quantitation, ms_quantitation
  • getProteinRatioSample() : ms_quantitation
  • getProteinRatioType() : ms_quant_method
  • getProteinRatioTypeSchemaType() : ms_quant_method
  • getProteins() : ms_peptide, ms_quant_normalisation
  • getProteinSchemaType() : ms_quant_normalisation_proteins
  • getProteinScoreCutoff() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getProteinScoreForHistogram() : ms_mascotresults
  • getProteinsInResultsFile() : ms_mascotoptions
  • getProteinsSchemaType() : ms_quant_normalisation
  • getProteinSummaryHit() : ms_protein
  • getProteinsWithThisPepMatch() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getProteinTaxonomyIDs() : ms_mascotresults
  • getProteinThreshold() : ms_mascotresults
  • getProtocol() : ms_quant_method
  • getProtocolSchemaType() : ms_quant_method
  • getProtScoreType() : ms_quant_method
  • getProtScoreTypeSchemaType() : ms_quant_method
  • getProxyConfig() : ms_http_helper
  • getProxyPassword() : ms_connection_settings, ms_mascotoptions
  • getProxyServer() : ms_connection_settings, ms_mascotoptions
  • getProxyServerType() : ms_connection_settings
  • getProxyType() : ms_mascotoptions
  • getProxyUserAndPassword() : ms_connection_settings
  • getProxyUsername() : ms_connection_settings, ms_mascotoptions
  • getPValue() : ms_shapiro_wilk
  • getQ() : ms_fitexy_result
  • getQmatch() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase, ms_mascotresults, ms_spectral_lib_file
  • getQplughole() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getQuality() : ms_ms1quant_match_ratio, ms_quant_method
  • getQualitySchemaType() : ms_quant_method
  • getQuant() : ms_distiller_data
  • getQuantCount() : ms_distiller_data
  • getQuantForSearch() : ms_distiller_data
  • getQuantitation() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getQUANTITATION() : ms_searchparams
  • getQuantitationComponentForPeptide() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getQuantitationDatasources() : ms_ms1quantitation
  • getQuantitationMethod() : ms_mascotresfilebase, ms_quantitation
  • getQuantMethod() : ms_distiller_data, ms_peptidesummary
  • getQuantMethodXml() : ms_distiller_data_search
  • getQUE() : ms_searchparams
  • getQuery() : ms_ms1quant_peptide_status, ms_peptide
  • getQueryAndRank() : ms_peptide_quant_key
  • getQueryList() : ms_peptidesummary
  • getQueryNumber() : ms_inputquery
  • getQuerySectionValue() : ms_mascotresfile_dat
  • getQuerySectionValueDouble() : ms_mascotresfile_dat
  • getQuerySectionValueInt() : ms_mascotresfile_dat
  • getQuerySectionValueStr() : ms_mascotresfile_dat
  • getQuickRefSearch() : ms_taxonomyrules
  • getRange() : ms_ms1quant_match_component
  • getRank() : ms_ms1quant_peptide_status, ms_peptide
  • getRatioName() : ms_ms1quant_match_ratio, ms_peptide_quant_ratio, ms_protein_quant_ratio
  • getRawAbsolutePath() : ms_distiller_sub_project
  • getRawfile() : ms_inputquery
  • getRawFormat() : ms_distiller_sub_project
  • getRawRelativePath() : ms_distiller_sub_project
  • getRawSampleNumber() : ms_distiller_sub_project
  • getRawScans() : ms_inputquery
  • getRC() : ms_matrix
  • getReadableLabelFreeVarMods() : ms_ms1quant_match
  • getReadableVarMods() : ms_mascotresults, ms_ms1quantitation
  • getReadableVarModsConcise() : ms_ms1quantitation
  • getRecordID() : ms_umod_modification
  • getRecordIDSchemaType() : ms_umod_modification
  • getRedirectPolicy() : ms_connection_settings
  • getReferenceAccession() : ms_quant_average
  • getReferenceAccessionSchemaType() : ms_quant_average
  • getReferenceAmount() : ms_quant_average
  • getReferenceAmountSchemaType() : ms_quant_average
  • getReferenceDatabase() : ms_quant_average
  • getReferenceDatabaseNumberOfSL() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getReferenceDatabaseSchemaType() : ms_quant_average
  • getReferenceFasta() : ms_libraryoptions
  • getReferenceFastaTaxonomyTitle() : ms_libraryoptions
  • getReferenceHitId() : ms_ms1quant_average_results
  • getReferenceMemberNumber() : ms_ms1quant_average_results
  • getRegionEndIndex() : ms_xic
  • getRegionEndScanId() : ms_xic
  • getRegionStartIndex() : ms_xic
  • getRegionStartScanId() : ms_xic
  • getRelativeMass() : ms_ms1quant_match_component
  • getRepeatSearchString() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getRepEntryByName() : ms_wwwoptions
  • getReplicate() : ms_quant_protocol
  • getReplicateSchemaType() : ms_quant_protocol
  • getREPORT() : ms_searchparams
  • getReportBuilderColumnArrangement() : ms_mascotoptions
  • getReportDetailSchemaType() : ms_quant_method
  • getReporter() : ms_quant_protocol
  • getReporterSchemaType() : ms_quant_protocol
  • getReporterTol() : ms_quant_reporter
  • getReporterTolSchemaType() : ms_quant_reporter
  • getReporterTolUnit() : ms_quant_reporter
  • getReporterTolUnitSchemaType() : ms_quant_reporter
  • getReportNumberChoice() : ms_mascotoptions
  • getReportRatioByName() : ms_quant_method
  • getReportRatioByNumber() : ms_quant_method
  • getReportRatioFromFile() : ms_ms2quantitation
  • getReportRatioNamesInFile() : ms_ms2quantitation
  • getReportRatioSchemaType() : ms_quant_method
  • getReporttop() : ms_distiller_data_search
  • getREPTYPE() : ms_searchparams
  • getReqPepNeutralLoss() : ms_modification
  • getRequestData() : ms_http_helper_handles
  • getRequireBoldRed() : ms_distiller_data_search
  • getRequireBoldRedSchemaType() : ms_quant_method
  • getRequiredSchemaFileNames() : ms_distiller_data
  • getRequiredSchemaType() : ms_quant_modgroup, ms_quant_pepneutralloss
  • getResfile() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase, ms_mascotresults
  • getResfileCache() : ms_mascotoptions
  • getResfileStreamName() : ms_distiller_search_status
  • getResidueMass() : ms_masses, ms_modification, ms_searchparams
  • getRestrict() : ms_enzyme
  • getResult() : ms_shapiro_wilk
  • getResultsCache() : ms_mascotoptions
  • getResultsFile() : ms_distiller_search_status, ms_distiller_subsearch
  • getResultsFileFormatVersion() : ms_mascotoptions
  • getResultsFileName() : ms_http_client_search
  • getResultsFullURL() : ms_mascotoptions
  • getResultsFullURL_2() : ms_mascotoptions
  • getResultsListStreamName() : ms_distiller_sub_project
  • getResultsParameters() : ms_mascotresults
  • getResultsPerlScript() : ms_mascotoptions
  • getResultsPerlScript_2() : ms_mascotoptions
  • getResultsStreamName() : ms_distiller_data_quant
  • getRetentionTimes() : ms_inputquery
  • getReviewColDisplay() : ms_mascotoptions
  • getReviewColWidth() : ms_mascotoptions
  • getRMSDeltas() : ms_protein
  • getRt() : ms_ms1quant_match_range
  • getRToffset() : ms_ms1quant_time_align
  • getRtPeakEnd() : ms_xic
  • getRtPeakStart() : ms_xic
  • getRtRegionEnd() : ms_xic
  • getRtRegionStart() : ms_xic
  • getRule() : ms_parserule_plus
  • getRULES() : ms_inputquery, ms_searchparams
  • getRuleStr() : ms_parserule
  • getSampleSize() : ms_protein_quant_ratio
  • getSARExtendedErrorCode() : ms_fileutilities
  • getSatellite() : ms_quant_component
  • getSatelliteSchemaType() : ms_quant_component
  • getScan() : ms_ms1quant_match_range
  • getScanNumbers() : ms_inputquery
  • getSchemaDirectory() : ms_quant_configfile
  • getSchemaFileName() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • getSchemaType() : ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_does_not_pair_with, ms_crosslinking_filters, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_crosslinking_parameter, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_parameter, ms_quant_parameters, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_xml_parameter, ms_xml_parameters
  • getScope() : ms_crosslinking_method
  • getScopeSchemaType() : ms_crosslinking_method
  • getScore() : ms_protein
  • getScoreExpectCutOff() : ms_distiller_data_search
  • getScoreWithET() : ms_protein
  • getScoring() : ms_distiller_data_search
  • getSearch() : ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list
  • getSEARCH() : ms_searchparams
  • getSearchCount() : ms_distiller_data
  • getSearchLogFile() : ms_mascotoptions
  • getSearchParameter() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSearchParametersKeyValues() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSearchStatusListStreamName() : ms_distiller_search_status_list
  • getSearchSubmitAcceptedFileTypes() : ms_mascotoptions
  • getSearchSubmitDefaultPeptideCharge() : ms_mascotoptions
  • getSearchSubmitMode() : ms_mascotoptions
  • getSearchSubmitOutputFormat() : ms_mascotoptions
  • getSearchTaskID() : ms_http_client_search
  • getSecsToWaitForNodeAtStartup() : ms_clusterparams
  • getSectionName() : ms_mascotresfile_dat
  • getSectionValue() : ms_mascotresfile_dat
  • getSectionValueDouble() : ms_mascotresfile_dat
  • getSectionValueInt() : ms_mascotresfile_dat
  • getSectionValueStr() : ms_mascotresfile_dat
  • getSEG() : ms_searchparams
  • getSelection() : ms_quant_average
  • getSelectionSchemaType() : ms_quant_average
  • getSelectSwitch() : ms_mascotoptions
  • getSendmailPath() : ms_mascotoptions
  • getSeq() : ms_inputquery, ms_quant_method
  • getSeqEntryByName() : ms_wwwoptions
  • getSeqSchemaType() : ms_quant_method
  • getSequence() : ms_quant_normalisation_peptide, ms_spectral_lib_entry
  • getSequenceFile() : ms_http_client_session
  • getSequenceFromNumber() : ms_spectral_lib_file
  • getSequenceMass() : ms_mascotresults
  • getSequenceSchemaType() : ms_quant_normalisation_peptide
  • getSeriesDescription() : ms_fragmentationrules
  • getSeriesName() : ms_fragment, ms_fragmentationrules
  • getSeriesUsedStr() : ms_peptide
  • getServer() : ms_distiller_search_status
  • getSessionID() : ms_connection_settings, ms_http_client_search, ms_http_client_session
  • getSessionTimeout() : ms_security_options
  • getSettings() : ms_crosslinking_method
  • getSettingsSchemaType() : ms_crosslinking_method
  • getShift() : ms_quant_correction
  • getShiftSchemaType() : ms_quant_correction
  • getShiftsFromConsensus() : ms_ms1quant_time_align
  • getShiftsToConsensus() : ms_ms1quant_time_align
  • getShowSamesets() : ms_distiller_data_search
  • getShowSamesetsFamily() : ms_distiller_data_search
  • getShowSubset() : ms_distiller_data_search
  • getShowSubsetFamily() : ms_distiller_data_search
  • getShowSubsets() : ms_mascotoptions
  • getShowSubSets() : ms_quant_method
  • getShowSubSetsSchemaType() : ms_quant_method
  • getSigmaA() : ms_fitexy_result
  • getSigmaB() : ms_fitexy_result
  • getSigmaX() : ms_fitexy_result
  • getSigmaY() : ms_fitexy_result
  • getSignificanceThreshold() : ms_distiller_data_search
  • getSigThreshold() : ms_mascotoptions
  • getSigThresholdValue() : ms_quant_method
  • getSigThresholdValueSchemaType() : ms_quant_method
  • getSimilarProteinDB() : ms_protein
  • getSimilarProteinName() : ms_protein
  • getSimilarProteins() : ms_protein
  • getSimpleRatioSchemaType() : ms_quant_integration
  • getSingleHit() : ms_mascotresults_params
  • getSite() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • getSiteAnalysisMD10Prob() : ms_mascotoptions
  • getSiteFrom() : ms_linker_site
  • getSiteSchemaType() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • getSiteTo() : ms_linker_site
  • getSkippedKeys() : ms_protein_quant_ratio
  • getSLDatabaseNumbersOfReference() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSLExecCommand() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSLFragmentTolerance() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSLFragmentToleranceUnit() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSLThresholdFromMinProbability() : ms_peptidesummary
  • getSortedFinitePeptideRatioValues() : ms_customquantitation, ms_ms2quantitation, ms_quantitation
  • getSortUnassigned() : ms_mascotoptions
  • getSource() : ms_quant_integration, ms_umod_xref
  • getSourceSchemaType() : ms_quant_integration, ms_umod_xref
  • getSpecGroup() : ms_umod_specificity
  • getSpecGroupSchemaType() : ms_umod_specificity
  • getSpeciesFile() : ms_taxonomyrules
  • getSpeciesFormatRegex() : ms_taxonomyrules
  • getSpecificity() : ms_quant_localdef, ms_umod_modification
  • getSpecificityBySite() : ms_umod_modification
  • getSpecificityBySiteAndPosition() : ms_umod_modification
  • getSpecificitySchemaType() : ms_quant_localdef, ms_umod_modification
  • getSpectralLibraryDisplayOption() : ms_distiller_data_search
  • getSpectraPerLibraryBlock() : ms_mascotoptions
  • getSpectrumViewerColourSchemeNames() : ms_mascotoptions
  • getSpectrumViewerColourSchemeString() : ms_mascotoptions
  • getSpectrumViewerDefaultColourSchemeName() : ms_mascotoptions
  • getSplitDataFileSize() : ms_mascotoptions
  • getSplitNumberOfQueries() : ms_mascotoptions
  • getSpoofableUsers() : ms_session
  • getSrcDatabaseRule() : ms_taxonomyrules
  • getSrcQueryAndFileIdForMultiFile() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSrcRank() : ms_peptidesummary
  • getSrcSection() : ms_peptidesummary
  • getStage() : ms_http_client_search
  • getStandardDeviation() : ms_protein_quant_ratio
  • getStandardError() : ms_protein_quant_ratio
  • getStart() : ms_fragment
  • getStartDate() : ms_license
  • getStartIndex() : ms_xic
  • getStartScanId() : ms_xic
  • getStatsInformation() : ms_spectral_lib_file
  • getStatus() : ms_http_client_search, ms_ms1quant_match_ratio, ms_ms1quant_peptide_status, ms_ms1quant_time_align, ms_progress_info
  • getStatusAsText() : ms_ms1quant_time_align
  • getStatusList() : ms_ms1quant_match_ratio
  • getStatusMsg() : ms_distiller_search_status
  • getStrategy() : ms_crosslinking_method
  • getStrategySchemaType() : ms_crosslinking_method
  • getStreamNumber() : ms_distiller_data_quant
  • getStrFile() : ms_taxonomyrules
  • getStringIons1() : ms_inputquery
  • getStringIons2() : ms_inputquery
  • getStringIons3() : ms_inputquery
  • getStringParam() : ms_group, ms_session, ms_user
  • getStringParams() : ms_security_task
  • getStringTitle() : ms_inputquery
  • getStrRule() : ms_taxonomyrules
  • getSUBCLUSTER() : ms_searchparams
  • getSubClusterID() : ms_clusterparams
  • getSubClusterMaxCPU() : ms_clusterparams
  • getSubmitTime() : ms_distiller_search_status
  • getSubproject() : ms_distiller_master_project
  • getSubProjectToFractionMap() : ms_ms1quant_time_align
  • getSubsearch() : ms_distiller_master_search
  • getSubtaskProgress() : ms_progress_info
  • getSuffixRemove() : ms_taxonomyrules
  • getSummary() : ms_ms1quantitation
  • getSummarySection() : ms_mascotresfile_dat
  • getSummedModsNlStr() : ms_peptide
  • getSummedModsStr() : ms_ms1quant_match_component, ms_peptide
  • getSVGSpectrumSwitch() : ms_mascotoptions
  • getSymbol() : ms_quant_element, ms_umod_elemref
  • getSymbolSchemaType() : ms_quant_element, ms_umod_elemref
  • getSystemError() : ms_http_helper_return
  • getTag() : ms_inputquery
  • getTagDeltaRangeEnd() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getTagDeltaRangeStart() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getTagEnd() : ms_mascotresults
  • getTagSeries() : ms_mascotresults
  • getTagStart() : ms_mascotresults
  • getTagString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getTARGET_FDR_PERCENT() : ms_searchparams
  • getTargetFDR() : ms_distiller_data_search, ms_mascotresults_params
  • getTargetFDRPercentage() : ms_mascotoptions
  • getTargetFDRStr() : ms_distiller_data_search
  • getTargetFDRType() : ms_distiller_data_search, ms_mascotresults_params
  • getTask() : ms_security_tasks
  • getTaskFromID() : ms_security_tasks
  • getTaskId() : ms_distiller_data_quant, ms_distiller_data_search, ms_distiller_search_status, ms_distiller_subsearch
  • getTasks() : ms_security
  • getTaxBrowserUrl() : ms_mascotoptions
  • getTaxIDArray() : ms_taxonomytree
  • getTaxonomy() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getTAXONOMY() : ms_searchparams
  • getTaxonomyParseRuleIndex() : ms_databaseoptions
  • getTaxonomyRules() : ms_datfile
  • getTerminalResiduesString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getTestDirectory() : ms_mascotoptions
  • getText() : ms_umod_xref
  • getTextSchemaType() : ms_umod_xref
  • getThreadProcessorID() : ms_dbprocessors
  • getThreeLetter() : ms_umod_aminoacid
  • getThreeLetterSchemaType() : ms_umod_aminoacid
  • getThresholdForFDRAboveHomology() : ms_mascotresults
  • getThresholdForFDRAboveIdentity() : ms_mascotresults
  • getTimeAlignmentAlgorithm() : ms_quant_replicate
  • getTimeAlignmentAlgorithmSchemaType() : ms_quant_replicate
  • getTimeAlignmentData() : ms_ms1quantitation
  • getTimeout() : ms_session
  • getTimeParam() : ms_session
  • getTitle() : ms_distiller_search_status, ms_distiller_subsearch, ms_enzyme, ms_fragmentationrules, ms_modification, ms_quant_localdef, ms_taxonomychoice, ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification, ms_unigene_entry
  • getTitleSchemaType() : ms_quant_localdef, ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • getTOL() : ms_searchparams
  • getToleranceInDa() : ms_libraryoptions
  • getToleranceInDalton() : ms_mascotresults
  • getToleranceInPPM() : ms_libraryoptions
  • getTOLU() : ms_searchparams
  • getTotal() : ms_progress_info
  • getTotalBytes() : ms_http_helper_progress
  • getTotalIntensity() : ms_ms1quant_charge_state
  • getTotalIntensitySchemaType() : ms_quant_quality
  • getTotalIntensityThreshold() : ms_quant_quality
  • getTotalIntensityThresholdSchemaType() : ms_quant_quality
  • getTotalIonsIntensity() : ms_inputquery
  • getTotalSeriesOutput() : ms_fragmentationrules
  • getTreeClusterNodes() : ms_mascotresults, ms_peptidesummary
  • getType() : ms_distiller_sub_project, ms_quant_correction, ms_quant_protocol, ms_security_task, ms_wwwentry
  • getTypeSchemaType() : ms_quant_correction
  • getUnassigned() : ms_mascotresults
  • getUnassignedIsBold() : ms_mascotresults
  • getUnassignedShowCheckbox() : ms_mascotresults
  • getUnigeneForAccession() : ms_unigene
  • getUnigeneIndexFile() : ms_mascotresults_params
  • getUniGeneOptions() : ms_datfile
  • getUnimod() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getUnimodXL() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getUniqueJobStartNumber() : ms_mascotoptions
  • getUniquePepseqSchemaType() : ms_quant_quality
  • getUniqueTaskID() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getUnixDirPerm() : ms_mascotoptions
  • getUnixWebUserGroup() : ms_mascotoptions
  • getUnmatchedAnnotationStr() : ms_spectral_lib_peak
  • getUnmatchedMasses() : ms_protein
  • getUnmodified() : ms_quant_modgroup
  • getUnmodifiedSchemaType() : ms_quant_modgroup
  • getUnnormalisedAveragePeptideRatio() : ms_customquantitation
  • getUnZipped() : ms_zip
  • getUnZippedLen() : ms_zip
  • getUrl() : ms_umod_xref
  • getUrlSchemaType() : ms_umod_xref
  • getUser() : ms_security
  • getUserAgent() : ms_connection_settings
  • getUSEREMAIL() : ms_searchparams
  • getUSERField() : ms_searchparams
  • getUserFromID() : ms_security
  • getUSERID() : ms_searchparams
  • getUserID() : ms_session
  • getUSERNAME() : ms_searchparams
  • getUserName() : ms_session
  • getUsernameOfPoster() : ms_umod_modification
  • getUsernameOfPosterSchemaType() : ms_umod_modification
  • getUserType() : ms_session, ms_user
  • getUseSessionCookies() : ms_security_options
  • getUseTimeShift() : ms_xic
  • getVal() : ms_imputation_missing_val
  • getValue() : ms_crosslinking_accession, ms_crosslinking_monolink, ms_http_client_mime, ms_ms1quant_match_ratio, ms_peptide_quant_ratio, ms_protein_quant_ratio, ms_xml_parameter
  • getValueFromKey() : ms_tinycdb
  • getValueSchemaType() : ms_crosslinking_accession, ms_crosslinking_monolink, ms_crosslinking_parameter, ms_quant_parameter, ms_xml_parameter
  • getVarModIdxFrom() : ms_linker_site
  • getVarModIdxOfLinkedSite() : ms_linker_site_vector
  • getVarModIdxTo() : ms_linker_site
  • getVarMods() : ms_aahelper, ms_ms1quant_match
  • getVarModsDelta() : ms_searchparams
  • getVarModsName() : ms_searchparams
  • getVarModsNeutralLoss() : ms_searchparams
  • getVarModsNeutralLosses() : ms_searchparams
  • getVarModsPepNeutralLoss() : ms_searchparams
  • getVarModsReqPepNeutralLoss() : ms_searchparams
  • getVarModsStr() : ms_ms1quant_match_component, ms_peptide
  • getVector() : ms_fragmentvector
  • getVerifySessionIPAddress() : ms_security_options
  • getVersion() : ms_http_client
  • getVmemory() : ms_mascotoptions
  • getWeight() : ms_peptide_quant_ratio
  • getWhichAvailableForMascot() : ms_processors
  • getWhichAvailableForMascot2() : ms_processors
  • getWWWOptions() : ms_datfile
  • getXic() : ms_ms1quant_match_component
  • getXicMaxWidth() : ms_quant_integration
  • getXicMaxWidthSchemaType() : ms_quant_integration
  • getXicSmoothing() : ms_quant_integration
  • getXicSmoothingSchemaType() : ms_quant_integration
  • getXicThreshold() : ms_quant_integration
  • getXicThresholdSchemaType() : ms_quant_integration
  • getXmlCode() : ms_ms1quant_match, ms_ms1quant_match_ratio, ms_ms1quant_peptide_status, ms_xic
  • getXMLschemaFilePath() : ms_mascotresfilebase
  • getXref() : ms_umod_modification
  • getXrefSchemaType() : ms_umod_modification
  • getZipped() : ms_zip
  • getZippedLen() : ms_zip
  • GROUP : ms_protein
  • GROUP_COMPLETE : ms_protein
  • GROUP_FAMILY : ms_protein
  • GROUP_NO : ms_protein
  • GROUP_SUBSET : ms_protein
  • GROUP_UNKNOWN : ms_protein
  • GROUPID_ADMINISTRATORS : ms_group
  • GROUPID_DAEMONS : ms_group
  • GROUPID_GUESTS : ms_group
  • GROUPID_INTEGRA_SYSTEM : ms_group
  • GROUPID_LAST : ms_group
  • GROUPID_POWERUSERS : ms_group
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • hasAbsoluteValue() : ms_ms1quant_match_component
  • hasComponent() : ms_ms1quant_match
  • hasCrosslinkingMethod() : ms_peptidesummary
  • hasEnzyme() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • hasFilename() : ms_http_client_mime
  • hasIdentifiedComponent() : ms_ms1quant_match
  • hasIndexes() : ms_xic
  • hasIntensityNormalisation() : ms_ms2quantitation
  • hasINTERNALS() : ms_inputquery, ms_searchparams
  • hasMatchedFraction() : ms_ms1quant_match_component
  • hasMatchedRho() : ms_ms1quant_match_component
  • hasParent() : ms_http_helper_progress
  • hasPasswordExpired() : ms_user
  • hasPeptideRatio() : ms_customquantitation, ms_ms1quant_match, ms_ms2quantitation, ms_quantitation
  • hasPeptideRatioNormalisation() : ms_ms2quantitation
  • hasQuantitation() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • hasQuantMethod() : ms_peptidesummary
  • hasRT() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • haveAccession() : ms_quant_normalisation_protein
  • haveAccessions() : ms_crosslinking_method
  • haveAllChargeStates() : ms_quant_integration, ms_quant_precursor
  • haveAllChargeStatesThreshold() : ms_quant_integration
  • haveAllowElutionShift() : ms_quant_integration, ms_quant_precursor
  • haveAllowMassTimeMatch() : ms_quant_precursor
  • haveApproved() : ms_umod_modification
  • haveAverage() : ms_quant_moverz
  • haveAvgeMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • haveClassification() : ms_umod_specificity
  • haveCode() : ms_umod_neutralloss
  • haveCoefficient() : ms_quant_numerator
  • haveComp() : ms_quant_method
  • haveCompositionString() : ms_umod_composition
  • haveConstrainSearch() : ms_quant_method
  • haveDatabaseName() : ms_crosslinking_accession
  • haveDateTimeModified() : ms_umod_modification
  • haveDateTimePosted() : ms_umod_modification
  • haveDelta() : ms_quant_localdef, ms_umod_modification
  • haveDescription() : ms_crosslinking_method, ms_quant_method, ms_umod_neutralloss, ms_xml_parameter
  • haveElement() : ms_quant_correction
  • haveElutionProfileCorrelationThreshold() : ms_quant_integration
  • haveElutionTimeDelta() : ms_quant_integration
  • haveElutionTimeDeltaUnit() : ms_quant_integration
  • haveExcludeInternalLabel() : ms_quant_multiplex
  • haveExcludeIsobaricFragments() : ms_quant_multiplex
  • haveFileIndex() : ms_quant_component
  • haveFilters() : ms_crosslinking_method
  • haveFlag() : ms_quant_neutralloss, ms_umod_neutralloss
  • haveFraction() : ms_quant_file_index
  • haveFullName() : ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • haveGroupOfPoster() : ms_umod_modification
  • haveHidden() : ms_umod_specificity
  • haveIntegration() : ms_quant_method
  • haveIonIntensityThreshold() : ms_quant_multiplex
  • haveIonSeries() : ms_quant_multiplex
  • haveIsolatedPrecursor() : ms_quant_quality
  • haveIsolatedPrecursorThreshold() : ms_quant_quality
  • haveLinkers() : ms_crosslinking_method
  • haveMassDelta() : ms_quant_integration
  • haveMassDeltaUnit() : ms_quant_integration
  • haveMatchedRho() : ms_quant_integration
  • haveMethod() : ms_quant_integration, ms_quant_normalisation, ms_quant_outliers
  • haveMinimumA1() : ms_quant_quality
  • haveMinIonPairs() : ms_quant_multiplex
  • haveMinNumPeptides() : ms_quant_method
  • haveMinPrecursorCharge() : ms_quant_quality
  • haveMiscNotes() : ms_umod_modification, ms_umod_specificity
  • haveMode() : ms_quant_modgroup
  • haveModFileName() : ms_crosslinking_does_not_pair_with, ms_crosslinking_linker
  • haveModifications() : ms_quant_satellite
  • haveMonoisotopic() : ms_quant_moverz
  • haveMonoMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • haveMoverz() : ms_quant_component
  • haveName() : ms_crosslinking_method, ms_quant_component, ms_quant_method, ms_quant_modgroup, ms_quant_numerator, ms_quant_ratio, ms_xml_parameter
  • haveNew() : ms_quant_isotope
  • haveNormalisation() : ms_quant_method
  • haveNumber() : ms_quant_element, ms_umod_elemref
  • haveNumPeptides() : ms_quant_average
  • haveOld() : ms_quant_isotope
  • haveOutliers() : ms_quant_method
  • havePairsWith() : ms_umod_neutralloss
  • havePepThresholdType() : ms_quant_quality
  • havePepThresholdValue() : ms_quant_quality
  • havePeptides() : ms_quant_normalisation
  • havePosition() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • havePrecursorRange() : ms_quant_integration
  • haveProcessingOptions() : ms_quant_integration
  • haveProteinRatioType() : ms_quant_method
  • haveProteins() : ms_quant_normalisation
  • haveProtocol() : ms_quant_method
  • haveProtScoreType() : ms_quant_method
  • haveQuality() : ms_quant_method
  • haveRecordID() : ms_umod_modification
  • haveReferenceAccession() : ms_quant_average
  • haveReferenceAmount() : ms_quant_average
  • haveReferenceDatabase() : ms_quant_average
  • haveReportDetail() : ms_quant_method
  • haveReporterTol() : ms_quant_reporter
  • haveReporterTolUnit() : ms_quant_reporter
  • haveRequireBoldRed() : ms_quant_method
  • haveRequired() : ms_quant_modgroup, ms_quant_pepneutralloss
  • haveSatellite() : ms_quant_component
  • haveScope() : ms_crosslinking_method
  • haveSelection() : ms_quant_average
  • haveSequence() : ms_quant_normalisation_peptide
  • haveSettings() : ms_crosslinking_method
  • haveShift() : ms_quant_correction
  • haveShowSubSets() : ms_quant_method
  • haveSigThresholdValue() : ms_quant_method
  • haveSimpleRatio() : ms_quant_integration
  • haveSite() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • haveSource() : ms_quant_integration, ms_umod_xref
  • haveSpecGroup() : ms_umod_specificity
  • haveStrategy() : ms_crosslinking_method
  • haveSymbol() : ms_quant_element, ms_umod_elemref
  • haveText() : ms_umod_xref
  • haveThreeLetter() : ms_umod_aminoacid
  • haveTimeAlignmentAlgorithm() : ms_quant_replicate
  • haveTitle() : ms_quant_localdef, ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • haveTotalIntensity() : ms_quant_quality
  • haveTotalIntensityThreshold() : ms_quant_quality
  • haveType() : ms_quant_correction
  • haveUniquePepseq() : ms_quant_quality
  • haveUrl() : ms_umod_xref
  • haveUsernameOfPoster() : ms_umod_modification
  • haveValue() : ms_crosslinking_accession
  • haveXicMaxWidth() : ms_quant_integration
  • haveXicSmoothing() : ms_quant_integration
  • haveXicThreshold() : ms_quant_integration
  • HOMOLOGY_THRESHOLD_SOURCE : ms_mascotresults
  • HOMTHR_FASTA : ms_mascotresults
  • HOMTHR_SL : ms_mascotresults
  • HT_CANNOT_DETECT : ms_processors
  • HT_DISABLED : ms_processors
  • HT_ENABLED : ms_processors
  • HT_NOT_CAPABLE : ms_processors
  • HT_SUPPORTED_NOT_ENABLED : ms_processors
  • HTTP_1_0 : ms_connection_settings
  • HTTP_1_1 : ms_connection_settings
  • HTTP_PROTOCOL : ms_connection_settings
  • HTTP_SYSTEM_DEFAULT : ms_connection_settings
  • httpBufferedClose() : ms_http_helper
  • httpBufferedGetString() : ms_http_helper
  • httpBufferedOpen() : ms_http_helper
  • httpError() : ms_http_helper_return
  • httpGetFile() : ms_http_helper
  • httpGetHeader() : ms_http_helper
  • httpGetString() : ms_http_helper
  • httpPostFile() : ms_http_helper
  • HYPERTHREADING : ms_processors
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • identityMatrix() : ms_matrix
  • IFLG_ADDMISSINGOPTIONS : ms_datfile
  • IFLG_ADDPERCOLATOROPT : ms_datfile
  • IFLG_ADDREPORTAUTO : ms_datfile
  • IFLG_DEFAULTNEWINSTALL : ms_datfile
  • IFLG_DEFAULTUPGRADE : ms_datfile
  • IFLG_UPDATEAPACHEFORKOPT : ms_datfile
  • IFLG_UPDATECLUSTER : ms_datfile
  • IFLG_UPDATEDBMANAGERPERLPATH : ms_datfile
  • IFLG_UPDATEESTTAX : ms_datfile
  • IFLG_UPDATEEXECAFTERSEARCH : ms_datfile
  • IFLG_UPDATEMSPEPSEARCHOPTS : ms_datfile
  • IFLG_UPDATENCBIHTTPS : ms_datfile
  • IFLG_UPDATEPARSERULES : ms_datfile
  • IFLG_UPDATEPERCOLATORFEATS : ms_datfile
  • IFLG_UPDATEPERCOLATORUSERT : ms_datfile
  • IFLG_UPDATEPRIDECONTAMINANTS : ms_datfile
  • IFLG_UPDATEPROTFAMILYSWITCH : ms_datfile
  • IFLG_UPDATESPLITDATAFILESIZE : ms_datfile
  • IFLG_UPDATESPLITNUMOFQUERIES : ms_datfile
  • IFLG_UPDATESWISSPROT : ms_datfile
  • IFLG_UPDATETAXONOMY : ms_datfile
  • IH_INCLUDE_TOP_10_MATCHES : ms_mascotresults
  • IH_INCLUDE_TOP_MATCHES : ms_mascotresults
  • IMPUTATION_VARIABLE : ms_imputation
  • impute() : ms_imputation, ms_imputation_average_value, ms_imputation_fixed_value, ms_imputation_knn, ms_imputation_missforest
  • IMPUTE_PEPTIDE_RATIO : ms_imputation
  • IMPUTE_PROTEIN_RATIO : ms_imputation
  • IMPUTE_RETENTION_TIME : ms_imputation
  • includeIndexSection() : ms_msr2dat28
  • includeProteinPeptideRatioKeys() : ms_ms2quantitation
  • includeQuerySectionIonsLines() : ms_msr2dat28
  • inErrorTolerant() : ms_modification, ms_umod_specificity
  • initGroupChargeStates() : ms_ms1quantitation
  • initialiseBaseSettings() : ms_quantitation
  • inLongList() : ms_modification, ms_umod_specificity
  • inShortList() : ms_modification, ms_umod_specificity
  • INST_FLAGS : ms_datfile
  • INTENSITY : ms_mascotresults
  • IONS_HISTOGRAM : ms_mascotresults
  • isAbortSet() : ms_http_helper_progress
  • isAccountEnabled() : ms_user
  • isActive() : ms_databaseoptions
  • isAllChargeStates() : ms_quant_integration, ms_quant_precursor
  • isAllowElutionShift() : ms_quant_integration, ms_quant_precursor
  • isAllowMassTimeMatch() : ms_quant_precursor
  • isAlwaysCreateDat28ResultsFile() : ms_mascotoptions
  • isAlwaysEnableAutoDecoySearch() : ms_mascotoptions
  • isApproved() : ms_umod_modification
  • isASimilarProtein() : ms_protein
  • isAutoSelectCharge() : ms_mascotoptions
  • isAvailable() : ms_parserule
  • isAverageProtocol() : ms_ms1quantitation
  • isBackboneSeries() : ms_fragmentationrules
  • isBreaking() : ms_progress_info
  • isCharged2Plus() : ms_fragmentationrules
  • isCharged3Plus() : ms_fragmentationrules
  • isComplete() : ms_http_helper_progress
  • isComponentIdentified() : ms_ms1quant_match_component
  • isConcatRefFileLines() : ms_taxonomyrules
  • isConstrainSearch() : ms_quant_method
  • isConversionSupported() : ms_msr2dat28
  • isCreateLegacyModAndSubstitutionFiles() : ms_mascotoptions
  • isCreating() : ms_tinycdb
  • isCronEnabled() : ms_cronoptions
  • isCTerminal() : ms_fragment
  • isDatabaseTypeAvailable() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • isDataCached() : ms_ms1quantitation, ms_peptidesummary
  • isDayOfMonth() : ms_cronjob
  • isDayOfWeek() : ms_cronjob
  • isDBLevelTaxId() : ms_taxonomyrules
  • isDefaultTargetFDRPercentage() : ms_mascotoptions
  • isDirectory() : ms_fileutilities
  • isEmailErrorsEnabled() : ms_mascotoptions
  • isEmailUsersEnabled() : ms_mascotoptions
  • isEmPAIallowed() : ms_mascotresults
  • isEnabled() : ms_clusterparams, ms_cronjob, ms_taxonomyrules
  • isErrorTolerant() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • isExcluded() : ms_peptide_quant_ratio
  • isExcludeInternalLabel() : ms_quant_multiplex
  • isExcludeIsobaricFragments() : ms_quant_multiplex
  • isFastaPermitted() : ms_security_tasks, ms_session
  • isFileWritable() : ms_fileutilities
  • isFlag() : ms_quant_neutralloss, ms_umod_neutralloss
  • isForkForUnixApache() : ms_mascotoptions
  • isFromAlpha() : ms_fragment
  • isFromBeta() : ms_fragment
  • isFromRefFile() : ms_taxonomyrules
  • isFromSubstitutions() : ms_modfile
  • isGeneratedMonoLinker() : ms_modification
  • isHidden() : ms_modification, ms_umod_specificity
  • isHitRatioExcluded() : ms_ms1quant_match
  • isHitRatioOutlier() : ms_ms1quant_match
  • isHitRatioUsedForAverage() : ms_ms1quant_match
  • isHour() : ms_cronjob
  • isImmonium() : ms_fragment
  • isIncluded() : ms_ms1quant_match_ratio
  • isIncludedIn() : ms_taxonomytree
  • isIndependent() : ms_enzyme
  • isIndexSectionIncluded() : ms_msr2dat28
  • isInfinite() : ms_peptide_quant_ratio
  • isInIgnoreDupeAccessionList() : ms_mascotoptions
  • isInternal() : ms_fragment
  • isIsolatedPrecursor() : ms_quant_quality
  • isIteratePMFIntensities() : ms_mascotoptions
  • isLabelAll() : ms_mascotoptions
  • isLicenseValid() : ms_license
  • isLocalRefFile() : ms_databaseoptions
  • isLockMemory() : ms_databaseoptions
  • isLogicalCPUAvailableForMascot() : ms_processors
  • isLogNormal() : ms_protein_quant_ratio
  • isLoopLinker() : ms_modification
  • isMatchedToCalculatedPeak() : ms_spectral_lib_peak
  • isMatchOppositeCrosslinkPairs() : ms_mascotoptions
  • isMemoryMapFiles() : ms_databaseoptions
  • isMethodCompatible() : ms_quant_method
  • isMinute() : ms_cronjob
  • isMissing() : ms_imputation_missing_val, ms_peptide_quant_ratio, ms_protein_quant_ratio
  • isMitochondrialTranslation() : ms_taxonomyrules
  • isMonthOfYear() : ms_cronjob
  • isMoveOldDbToOldDir() : ms_mascotoptions
  • isMSMS() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • isNA() : ms_mascotresults
  • isNeutralLossSeries() : ms_fragmentationrules
  • isNil() : ms_peptide_quant_key
  • isNoneFound() : ms_enzymefile
  • isNTerminal() : ms_fragment
  • isOk() : ms_http_helper_return
  • isOpenForReading() : ms_tinycdb
  • isPeptideComponentMatch() : ms_peptidesummary
  • isPeptideModificationMatch() : ms_peptidesummary
  • isPeptideQualityOK() : ms_quant_helper
  • isPeptideQuantifiable() : ms_quant_helper
  • isPeptideRatioExcluded() : ms_customquantitation, ms_ms2quantitation, ms_quantitation
  • isPeptideUnique() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • isPercolator() : ms_mascotoptions
  • isPercolatorUseProteins() : ms_mascotoptions
  • isPercolatorUseRT() : ms_mascotoptions
  • isPermitted() : ms_security_task, ms_security_tasks, ms_session
  • isPermitted_double() : ms_security_task, ms_security_tasks, ms_session
  • isPermitted_long() : ms_security_task, ms_security_tasks, ms_session
  • isPermitted_string() : ms_security_task, ms_security_tasks, ms_session
  • isPMF() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • isPMFMixture() : ms_protein
  • isPmfQueryUsed() : ms_proteinsummary
  • isPossibleToCreate() : ms_tinycdb
  • isPrecursorNL() : ms_fragment
  • isPrimaryLogicalProcessor() : ms_processors
  • isPrivacyEnabled() : ms_umod_modification
  • isPrivate() : ms_umod_modification
  • isProcessAffinitySupported() : ms_processors
  • isQuerySectionIonsLinesIncluded() : ms_msr2dat28
  • isReferenceUserSelected() : ms_ms1quant_average_results
  • isRegular() : ms_fragment
  • isRemoveOldIndexFiles() : ms_mascotoptions
  • isReportDetail() : ms_quant_method
  • isRequireBoldRed() : ms_mascotoptions, ms_quant_method
  • isRequired() : ms_quant_modgroup, ms_quant_pepneutralloss
  • isResidueModified() : ms_masses, ms_modification
  • isSame() : ms_masses
  • isSameAs() : ms_umod_composition, ms_umod_modification, ms_umod_specificity, ms_umod_xref
  • isSamePeptideStr() : ms_peptide
  • isSameSummedModsStr() : ms_peptide
  • isSameVarModsStr() : ms_peptide
  • isSaveEveryLastQueryAsc() : ms_mascotoptions
  • isSaveLastQueryAsc() : ms_mascotoptions
  • isSectionAvailable() : ms_clusterparams, ms_cronoptions, ms_databases, ms_libraryoptions, ms_mascotoptions, ms_parseoptions, ms_processoroptions, ms_taxonomyrules, ms_unigeneoptions, ms_wwwoptions
  • isSecurityEnabled() : ms_security_options, ms_session
  • isSemiSpecific() : ms_enzyme
  • isSeriesUsed() : ms_fragmentationrules
  • isSet() : ms_ms1quant_match_ratio
  • isShowAllFromErrorTolerant() : ms_mascotoptions
  • isShowSubsets() : ms_mascotoptions
  • isSignificant() : ms_protein_quant_ratio
  • isSimilarProtein() : ms_protein
  • isSimpleRatio() : ms_quant_integration
  • isSinglyCharged() : ms_fragmentationrules
  • isSpeciesDescendantOf() : ms_taxonomytree
  • isSQ() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • isStarted() : ms_http_helper_progress
  • isStoreModPermutations() : ms_mascotoptions
  • isSubstitution() : ms_modification
  • isSuspectAssignment() : ms_spectral_lib_peak
  • isTargetFDR() : ms_distiller_data_search
  • isTaskExists() : ms_security, ms_security_tasks
  • isThreadedLogicalProcessor() : ms_processors
  • isTimedOut() : ms_session
  • isTotalIntensity() : ms_quant_quality
  • isUnigene() : ms_protein
  • isUniquePepseq() : ms_quant_quality
  • isUnixDirPermDefined() : ms_mascotoptions
  • isUpdateScoreFromPepScores() : ms_protein
  • isUsedForAverage() : ms_ms1quant_match_ratio
  • isUseHTTPProxyForFTP() : ms_connection_settings, ms_mascotoptions
  • isUseHTTPProxyForHTTPS() : ms_connection_settings, ms_mascotoptions
  • isUsePeptideSummary() : ms_mascotresults_params
  • isUseProcessesNotThreads() : ms_processors
  • isUserExists() : ms_security
  • isUserInGroup() : ms_group
  • isValid() : ms_enzyme, ms_errors, ms_errs, ms_fragmentationrules, ms_ms1quant_match_ratio, ms_spectral_lib_peak
  • isZero() : ms_matrix
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • KA_ASSIGNPROTEINS_AP : ms_mascotresfilebase
  • KA_CREATECACHE_CC : ms_mascotresfilebase
  • KA_CREATEINDEX_CI : ms_mascotresfilebase
  • KA_GROUPPROTEINS_GP : ms_mascotresfilebase
  • KA_LAST : ms_mascotresfilebase
  • KA_QUANTITATION : ms_mascotresfilebase
  • KA_READFILE_RF : ms_mascotresfilebase
  • KA_TASK : ms_mascotresfilebase
  • KA_THRESHFORFDR_FDR : ms_mascotresfilebase
  • KA_UNASSIGNEDLIST_UL : ms_mascotresfilebase
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • L_GUESTLOGINDISABLED : ms_http_client
  • L_INCORRECTPASSWORD : ms_http_client
  • L_PASSWORDEXPIRED : ms_http_client
  • L_SECURITYDISABLED : ms_http_client
  • L_SUCCESS : ms_http_client
  • L_UNKNOWNUSER : ms_http_client
  • L_UNSPECIFIEDERROR : ms_http_client
  • L_WEBAUTHENTICATIONFAILED : ms_http_client
  • LABEL_FORMAT : ms_fragment
  • LABEL_FORMAT_PEPTIDE_VIEW : ms_fragment
  • LABEL_FORMAT_TRADITIONAL : ms_fragment
  • Level_e : ms_loggingmonitor
  • loadCdbFile() : ms_ms1quantitation, ms_ms2quantitation
  • loadCdbFiles() : ms_ms2quantitation
  • loadFromFile() : ms_security_tasks
  • loadXml() : ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list
  • loadXmlFile() : ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list, ms_ms1quant_time_align, ms_ms1quantitation
  • loadXmlStream() : ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list
  • logContents() : ms_matrix
  • LoginResultCode : ms_http_client
  • logMessage() : ms_loggingmonitor
  • LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER : ms_log
  • LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK : ms_log
  • LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK : ms_log
  • LOGMSG_AAHELPER_CFR_MASSES_VALUE : ms_log
  • LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE : ms_log
  • LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS : ms_log
  • LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT : ms_log
  • LOGMSG_AAHELPER_CFR_START_FRAGMENTS : ms_log
  • LOGMSG_AAHELPER_CROSSLINKED_END : ms_log
  • LOGMSG_AAHELPER_CROSSLINKED_START : ms_log
  • LOGMSG_AAHELPER_CUMULATIVE_MASS_NL : ms_log
  • LOGMSG_AAHELPER_ETMOD_LOOKUP : ms_log
  • LOGMSG_AAHELPER_IMMONIUM_ION_ADD : ms_log
  • LOGMSG_AAHELPER_IMMONIUM_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_INTERNAL_ION_ADD : ms_log
  • LOGMSG_AAHELPER_INTERNAL_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_MASTER_NL_VALS : ms_log
  • LOGMSG_AAHELPER_MULTINL_INDICES : ms_log
  • LOGMSG_AAHELPER_REGULAR_ION_ADD : ms_log
  • LOGMSG_AAHELPER_REGULAR_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD : ms_log
  • LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_SERIES_PARAMS : ms_log
  • LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG : ms_log
  • LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT : ms_log
  • LOGMSG_AAHELPER_TOTAL_NL_VALS : ms_log
  • LOGMSG_CUSTQUANT_ADD_QUANT_KEY : ms_log
  • LOGMSG_CUSTQUANT_REMOVE_ALL_KEY : ms_log
  • LOGMSG_CUSTQUANT_REMOVE_KEY : ms_log
  • LOGMSG_DBG1_NUM_PROCESSOR_GROUPS : ms_log
  • LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS : ms_log
  • LOGMSG_DBG2_CPU_INF_GETAUTODETECT : ms_log
  • LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS : ms_log
  • LOGMSG_DBG2_CPU_INF_MT_NAME : ms_log
  • LOGMSG_DBG2_CPU_INF_MT_STATUS : ms_log
  • LOGMSG_DBG2_CPU_INF_NAME : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_AVAIL : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_GROUPS : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_ON_SYS : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL : ms_log
  • LOGMSG_DBG2_CPU_INF_PROC_AFFINITY : ms_log
  • LOGMSG_DBG2_CPU_INF_TABLE_LINE : ms_log
  • LOGMSG_DBG2_CPU_INF_TABLE_TITLE : ms_log
  • LOGMSG_DBG2_CPU_INF_USE_PROCESSES : ms_log
  • LOGMSG_DBG2_NUM_CONFIG_MISMATCH : ms_log
  • LOGMSG_DBG2_NUM_ONLINE_MISMATCH : ms_log
  • LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD : ms_log
  • LOGMSG_DBG3_BINDING_PROCESSORS : ms_log
  • LOGMSG_DBG3_BINDING_THREAD : ms_log
  • LOGMSG_DBG3_CALL_GET_CHIP_MFCTR : ms_log
  • LOGMSG_DBG3_HWLOC_GROUPS : ms_log
  • LOGMSG_DBG3_HWLOC_TREE : ms_log
  • LOGMSG_DBG3_PROCESSOR_NAME : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_START : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT : ms_log
  • LOGMSG_GET_THR_REACH_COND : ms_log
  • LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET : ms_log
  • LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR : ms_log
  • LOGMSG_HTTP_GETRETURNSTRING : ms_log
  • LOGMSG_HTTP_MAXCONECTIONS10FAILED : ms_log
  • LOGMSG_HTTP_MAXCONECTIONSFAILED : ms_log
  • LOGMSG_HTTP_QUERYSTATUSRESULT : ms_log
  • LOGMSG_HTTP_URLSTRING : ms_log
  • LOGMSG_INST_ADDINGDATABASE : ms_log
  • LOGMSG_INST_ADDOPTIONSSECTION : ms_log
  • LOGMSG_INST_APPENDPARSERULE : ms_log
  • LOGMSG_INST_APPENDTAXONOMY : ms_log
  • LOGMSG_INST_CHANGEDBTAXONOMY : ms_log
  • LOGMSG_INST_CHANGEPARSERULE : ms_log
  • LOGMSG_INST_CHANGEPERCOLATORFEATS : ms_log
  • LOGMSG_INST_CHANGEPERCOLATORUSERT : ms_log
  • LOGMSG_INST_CHANGEPROTFAMILYSWITCH : ms_log
  • LOGMSG_INST_CHANGERESULTSCACHE : ms_log
  • LOGMSG_INST_CHANGESPLITDATAFILESIZE : ms_log
  • LOGMSG_INST_CHANGESPLITNUMOFQUERIES : ms_log
  • LOGMSG_INST_CLUSTERSECTION : ms_log
  • LOGMSG_INST_FAILSAVEPOSTINSTALLFILE : ms_log
  • LOGMSG_INST_LOGICALPERPHYSICALCPU : ms_log
  • LOGMSG_INST_MASCOTDATOK : ms_log
  • LOGMSG_INST_NOSUBCLUSTERSET : ms_log
  • LOGMSG_INST_NOTMASCOTDATOK : ms_log
  • LOGMSG_INST_NUMTHREADS : ms_log
  • LOGMSG_INST_REMOVEOPTIONSSECTION : ms_log
  • LOGMSG_INST_SAVEDPOSTINSTALLFILE : ms_log
  • LOGMSG_INST_SETOPTIONSSECTION : ms_log
  • LOGMSG_MATRIX_OUTPUT_VALS : ms_log
  • LOGMSG_MSR2DAT28_SQL_TRACING : ms_log
  • LOGMSG_NON_DEFAULT_HOMOLOGY_THRESHOLD : ms_log
  • LOGMSG_PEPSUM_GETHIT : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_START : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST : ms_log
  • LOGMSG_PROTINFER_CLUSTER_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_END : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_QUEUE : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_START : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_START : ms_log
  • LOGMSG_PROTINFER_GROUP_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY : ms_log
  • LOGMSG_PROTINFER_PEPTIDE_MATRIX : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_START : ms_log
  • LOGMSG_PROTINFER_SINGLETON_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_DONE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_START : ms_log
  • LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT : ms_log
  • LOGMSG_QUANT_ADDED_PROTEIN_HIT : ms_log
  • LOGMSG_QUANT_ADDING_PROTEIN_HIT : ms_log
  • LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED : ms_log
  • LOGMSG_QUANT_CLOSING_CACHE_FILE : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN : ms_log
  • LOGMSG_QUANT_FINISH_CALC_COMPLETE : ms_log
  • LOGMSG_QUANT_FINISH_LOAD_CDB : ms_log
  • LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE : ms_log
  • LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES : ms_log
  • LOGMSG_QUANT_HELPER_TEST_REQUIRED : ms_log
  • LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES : ms_log
  • LOGMSG_QUANT_LOADING_MATCHES : ms_log
  • LOGMSG_QUANT_MERGE_COMPONENT_DUPE_FI : ms_log
  • LOGMSG_QUANT_MERGE_COMPONENT_INCONSIST : ms_log
  • LOGMSG_QUANT_MERGE_COMPONENT_SUCCESS : ms_log
  • LOGMSG_QUANT_OPENING_CACHE_FILE : ms_log
  • LOGMSG_QUANT_REAPPLY_THRESHOLDS : ms_log
  • LOGMSG_QUANT_REMATCHING_INFERRED : ms_log
  • LOGMSG_QUANT_REMOVE_INFERRED_MATCH : ms_log
  • LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE : ms_log
  • LOGMSG_QUANT_RT_OFFSET_LOOKUP : ms_log
  • LOGMSG_QUANT_START_CALC_COMPLETE : ms_log
  • LOGMSG_QUANT_START_LOAD_CDB : ms_log
  • LOGMSG_QUANT_START_REORDER_AFTER_MERGE : ms_log
  • LOGMSG_QUANT_START_UPDATE_PROT_MATCHES : ms_log
  • LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE : ms_log
  • LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE1 : ms_log
  • LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES : ms_log
  • LOGMSG_QUANT_UPDATING_PEP_EVIDENCE : ms_log
  • LOGMSG_REPORT_FUNCTION_CALLED_BY : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 : ms_log
  • LOGMSG_REPORT_FUNCTION_EXIT : ms_log
  • LOGMSG_REPORT_FUNCTION_EXIT_WITH : ms_log
  • LOGMSG_RESFILE_APPEND : ms_log
  • logout() : ms_http_client_session
  • LogOutputColumns_e : ms_logger
  • logTransform() : ms_quant_stats
  • LVL_DEBUG1 : ms_loggingmonitor
  • LVL_DEBUG2 : ms_loggingmonitor
  • LVL_DEBUG3 : ms_loggingmonitor
  • LVL_ERROR : ms_loggingmonitor
  • LVL_INFO : ms_loggingmonitor
  • LVL_NONE : ms_loggingmonitor
  • LVL_WARNING : ms_loggingmonitor
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • makeExists() : ms_tinycdb
  • mascotresfile() : ms_peptidesummary
  • MASS_DECIMAL_PLACES : ms_mascotoptions
  • MASS_FLAGS : ms_protein
  • MASS_NON_SELECT_MATCH : ms_protein
  • MASS_NON_SELECT_NON_MATCH : ms_protein
  • MASS_SELECT_MATCH : ms_protein
  • MASS_SELECT_NON_MATCH : ms_protein
  • MATCH_CLOSEST_PEAK : ms_fragmentvector
  • MATCH_MOST_INTENSE_PEAK : ms_fragmentvector
  • MATCH_PEAKS : ms_fragmentvector
  • MAX_EXEC_AFTER_SEARCH : ms_mascotoptions
  • meanCentre() : ms_quant_stats
  • medianStandardErrorCorrection() : ms_quant_stats
  • MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE : ms_ms1quantitation
  • MERGE_QUANT_DEFAULT_PRECURSOR_METHOD : ms_ms1quantitation
  • MERGE_QUANT_DEFAULT_REPLICATE_METHOD : ms_ms1quantitation
  • MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH : ms_ms1quantitation
  • MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS : ms_ms1quantitation
  • MERGE_QUANT_RESULTS_FLAGS : ms_ms1quantitation
  • MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC : ms_ms1quantitation
  • mergeQuantitationResults() : ms_ms1quantitation
  • messageSourceAsText() : ms_loggingmonitor
  • METHOD_COMPATIBLE : ms_quant_method
  • MISECTASK_ACCESS : ms_security_tasks
  • MISECTASK_ADDCUSTOMREPORT : ms_security_tasks
  • MISECTASK_ADDEXCLUSIONFILE : ms_security_tasks
  • MISECTASK_ADDIMPORTFILTER : ms_security_tasks
  • MISECTASK_ADMIN : ms_security_tasks
  • MISECTASK_DELETECUSTOMREPORT : ms_security_tasks
  • MISECTASK_DELETEEXCLUSIONFILE : ms_security_tasks
  • MISECTASK_PROTEINAPPROVAL : ms_security_tasks
  • MISECTASK_SENDNOTIFICATION : ms_security_tasks
  • MODFILE_FLAGS : ms_umod_configfile
  • MODFILE_FLAGS_AASUBST : ms_umod_configfile
  • MODFILE_FLAGS_ALL : ms_umod_configfile
  • MODFILE_FLAGS_EMPTY : ms_umod_configfile
  • MODFILE_FLAGS_HIDDEN : ms_umod_configfile
  • MODFILE_FLAGS_REGULAR : ms_umod_configfile
  • MS1QUANT_BUGFIX_NUM : ms_ms1quantitation
  • ms_aahelper() : ms_aahelper
  • ms_buffer_logger() : ms_buffer_logger
  • ms_clusterparams() : ms_clusterparams
  • ms_computeraddress() : ms_computeraddress
  • ms_connection_settings() : ms_connection_settings
  • ms_cronjob() : ms_cronjob
  • ms_cronoptions() : ms_cronoptions
  • ms_crosslinking_accession() : ms_crosslinking_accession
  • ms_crosslinking_accessions() : ms_crosslinking_accessions
  • ms_crosslinking_configfile() : ms_crosslinking_configfile
  • ms_crosslinking_does_not_pair_with() : ms_crosslinking_does_not_pair_with
  • ms_crosslinking_filters() : ms_crosslinking_filters
  • ms_crosslinking_linker() : ms_crosslinking_linker
  • ms_crosslinking_linkers() : ms_crosslinking_linkers
  • ms_crosslinking_method() : ms_crosslinking_method
  • ms_crosslinking_monolink() : ms_crosslinking_monolink
  • ms_crosslinking_parameter() : ms_crosslinking_parameter
  • ms_crosslinking_parameters() : ms_crosslinking_parameters
  • ms_crosslinking_scope() : ms_crosslinking_scope
  • ms_crosslinking_settings() : ms_crosslinking_settings
  • ms_customproperty() : ms_customproperty
  • ms_customquantitation() : ms_customquantitation
  • ms_databaseoptions() : ms_databaseoptions
  • ms_databases() : ms_databases
  • ms_datfile() : ms_datfile
  • ms_dbprocessors() : ms_dbprocessors
  • ms_distiller_data() : ms_distiller_data
  • ms_distiller_data_search() : ms_distiller_data_search
  • ms_distiller_master_project() : ms_distiller_master_project
  • ms_distiller_search_status_list() : ms_distiller_search_status_list
  • ms_enzyme() : ms_enzyme
  • ms_enzymefile() : ms_enzymefile
  • ms_errors() : ms_errors
  • ms_errs() : ms_errs
  • ms_file_logger() : ms_file_logger
  • ms_fileutilities() : ms_fileutilities
  • ms_fitexy_result() : ms_fitexy_result
  • ms_fragment() : ms_fragment
  • ms_fragmentationrules() : ms_fragmentationrules
  • ms_fragmentvector() : ms_fragmentvector
  • ms_fragrulesfile() : ms_fragrulesfile
  • ms_group() : ms_group
  • ms_http_client() : ms_http_client
  • ms_http_client_search() : ms_http_client_search
  • ms_http_client_session() : ms_http_client_session
  • ms_http_helper() : ms_http_helper
  • ms_http_helper_handles() : ms_http_helper_handles
  • ms_http_helper_progress() : ms_http_helper_progress
  • ms_http_helper_return() : ms_http_helper_return
  • ms_imputation() : ms_imputation
  • ms_imputation_method() : ms_imputation_method
  • ms_imputation_missing_val() : ms_imputation_missing_val
  • ms_imputation_peptide_data() : ms_imputation_peptide_data
  • ms_inputquery() : ms_inputquery
  • ms_libraryoptions() : ms_libraryoptions
  • ms_license() : ms_license
  • ms_linker_site() : ms_linker_site
  • ms_linker_site_vector() : ms_linker_site_vector
  • ms_log() : ms_log
  • ms_logger() : ms_logger
  • ms_loggingmonitor() : ms_loggingmonitor
  • ms_mascotfiles() : ms_mascotfiles
  • ms_mascotoptions() : ms_mascotoptions
  • ms_mascotresfile_dat() : ms_mascotresfile_dat
  • ms_mascotresfile_msr() : ms_mascotresfile_msr
  • ms_mascotresfilebase() : ms_mascotresfilebase
  • ms_mascotresults() : ms_mascotresults
  • ms_mascotresults_params() : ms_mascotresults_params
  • ms_masses() : ms_masses
  • ms_matrix() : ms_matrix
  • ms_modfile() : ms_modfile
  • ms_modification() : ms_modification
  • ms_modvector() : ms_modvector
  • ms_ms1quant_average_results() : ms_ms1quant_average_results
  • ms_ms1quant_charge_state() : ms_ms1quant_charge_state
  • ms_ms1quant_match() : ms_ms1quant_match
  • ms_ms1quant_match_component() : ms_ms1quant_match_component
  • ms_ms1quant_match_range() : ms_ms1quant_match_range
  • ms_ms1quant_match_ratio() : ms_ms1quant_match_ratio
  • ms_ms1quant_peptide_status() : ms_ms1quant_peptide_status
  • ms_ms1quant_time_align() : ms_ms1quant_time_align
  • ms_ms1quant_time_align_limits() : ms_ms1quant_time_align_limits
  • ms_ms1quantitation() : ms_ms1quantitation
  • ms_ms2quantitation() : ms_ms2quantitation
  • ms_msr2dat28() : ms_msr2dat28
  • ms_obofile() : ms_obofile
  • ms_parseoptions() : ms_parseoptions
  • ms_parserule() : ms_parserule
  • ms_parserule_plus() : ms_parserule_plus
  • ms_peptide() : ms_peptide
  • ms_peptide_quant_key() : ms_peptide_quant_key
  • ms_peptide_quant_key_vector() : ms_peptide_quant_key_vector
  • ms_peptide_quant_ratio() : ms_peptide_quant_ratio
  • ms_peptidesummary() : ms_peptidesummary
  • ms_processoroptions() : ms_processoroptions
  • ms_processors() : ms_processors
  • ms_progress_info() : ms_progress_info
  • ms_protein() : ms_protein
  • ms_protein_quant_ratio() : ms_protein_quant_ratio
  • ms_proteinsummary() : ms_proteinsummary
  • ms_quant_average() : ms_quant_average
  • ms_quant_component() : ms_quant_component
  • ms_quant_composition() : ms_quant_composition
  • ms_quant_configfile() : ms_quant_configfile
  • ms_quant_correction() : ms_quant_correction
  • ms_quant_element() : ms_quant_element
  • ms_quant_file_index() : ms_quant_file_index
  • ms_quant_helper() : ms_quant_helper
  • ms_quant_integration() : ms_quant_integration
  • ms_quant_isotope() : ms_quant_isotope
  • ms_quant_localdef() : ms_quant_localdef
  • ms_quant_method() : ms_quant_method
  • ms_quant_modgroup() : ms_quant_modgroup
  • ms_quant_moverz() : ms_quant_moverz
  • ms_quant_multiplex() : ms_quant_multiplex
  • ms_quant_neutralloss() : ms_quant_neutralloss
  • ms_quant_normalisation() : ms_quant_normalisation
  • ms_quant_normalisation_peptide() : ms_quant_normalisation_peptide
  • ms_quant_normalisation_peptides() : ms_quant_normalisation_peptides
  • ms_quant_normalisation_protein() : ms_quant_normalisation_protein
  • ms_quant_normalisation_proteins() : ms_quant_normalisation_proteins
  • ms_quant_numerator() : ms_quant_numerator
  • ms_quant_outliers() : ms_quant_outliers
  • ms_quant_parameter() : ms_quant_parameter
  • ms_quant_parameters() : ms_quant_parameters
  • ms_quant_pepneutralloss() : ms_quant_pepneutralloss
  • ms_quant_precursor() : ms_quant_precursor
  • ms_quant_protocol() : ms_quant_protocol
  • ms_quant_quality() : ms_quant_quality
  • ms_quant_ratio() : ms_quant_ratio
  • ms_quant_replicate() : ms_quant_replicate
  • ms_quant_reporter() : ms_quant_reporter
  • ms_quant_satellite() : ms_quant_satellite
  • ms_quant_specificity() : ms_quant_specificity
  • ms_quant_unmodified() : ms_quant_unmodified
  • MS_REVIEW_COL : ms_mascotoptions
  • MS_REVIEW_COL____LAST___ : ms_mascotoptions
  • MS_REVIEW_COL_DATABASE : ms_mascotoptions
  • MS_REVIEW_COL_DURATION : ms_mascotoptions
  • MS_REVIEW_COL_ENZYMEUSED : ms_mascotoptions
  • MS_REVIEW_COL_IPADDRESS : ms_mascotoptions
  • MS_REVIEW_COL_JOB : ms_mascotoptions
  • MS_REVIEW_COL_PEAKLISTDATAFILE : ms_mascotoptions
  • MS_REVIEW_COL_PID : ms_mascotoptions
  • MS_REVIEW_COL_PRIORITY : ms_mascotoptions
  • MS_REVIEW_COL_RESULTS_FILE : ms_mascotoptions
  • MS_REVIEW_COL_SEARCHTYPE : ms_mascotoptions
  • MS_REVIEW_COL_START_TIME : ms_mascotoptions
  • MS_REVIEW_COL_STATUS : ms_mascotoptions
  • MS_REVIEW_COL_TITLE : ms_mascotoptions
  • MS_REVIEW_COL_USEREMAIL : ms_mascotoptions
  • MS_REVIEW_COL_USERID : ms_mascotoptions
  • MS_REVIEW_COL_USERNAME : ms_mascotoptions
  • ms_searchparams() : ms_searchparams
  • ms_security() : ms_security
  • ms_security_options() : ms_security_options
  • ms_security_task() : ms_security_task
  • ms_security_tasks() : ms_security_tasks
  • ms_session() : ms_session
  • ms_shapiro_wilk() : ms_shapiro_wilk
  • ms_spectral_lib_entry() : ms_spectral_lib_entry
  • ms_spectral_lib_file() : ms_spectral_lib_file
  • ms_spectral_lib_peak() : ms_spectral_lib_peak
  • ms_spectral_lib_peak_list() : ms_spectral_lib_peak_list
  • ms_stdout_logger() : ms_stdout_logger
  • ms_taxnodesfiles() : ms_taxnodesfiles
  • ms_taxonomychoice() : ms_taxonomychoice
  • ms_taxonomyfile() : ms_taxonomyfile
  • ms_taxonomyrules() : ms_taxonomyrules
  • ms_taxonomytree() : ms_taxonomytree
  • ms_taxspeciesfiles() : ms_taxspeciesfiles
  • ms_tinycdb() : ms_tinycdb
  • ms_treecluster() : ms_treecluster
  • ms_umod_aminoacid() : ms_umod_aminoacid
  • ms_umod_composition() : ms_umod_composition
  • ms_umod_configfile() : ms_umod_configfile
  • ms_umod_element() : ms_umod_element
  • ms_umod_elemref() : ms_umod_elemref
  • ms_umod_modbrick() : ms_umod_modbrick
  • ms_umod_modification() : ms_umod_modification
  • ms_umod_neutralloss() : ms_umod_neutralloss
  • ms_umod_specificity() : ms_umod_specificity
  • ms_umod_xref() : ms_umod_xref
  • ms_unigene() : ms_unigene
  • ms_unigene_entry() : ms_unigene_entry
  • ms_unigeneoptions() : ms_unigeneoptions
  • ms_user() : ms_user
  • ms_wwwentry() : ms_wwwentry
  • ms_wwwoptions() : ms_wwwoptions
  • ms_xic() : ms_xic
  • ms_xml_parameter() : ms_xml_parameter
  • ms_xml_parameters() : ms_xml_parameters
  • ms_zip() : ms_zip
  • msg_num_t : ms_log
  • msg_sev : ms_log
  • MSM_EXCLUSIVE_PLUS_VARIABLE : ms_searchparams
  • MSM_NOT_PERMITTED : ms_searchparams
  • MSPEPSUM : ms_peptidesummary
  • MSPEPSUM_CACHE_IGNORE_DATE_CHANGE : ms_peptidesummary
  • MSPEPSUM_CROSSLINK_INTEGRATED : ms_peptidesummary
  • MSPEPSUM_CROSSLINK_ONLY : ms_peptidesummary
  • MSPEPSUM_DEFERRED_CREATE : ms_peptidesummary
  • MSPEPSUM_DISCARD_RELOADABLE : ms_peptidesummary
  • MSPEPSUM_NO_PROTEIN_GROUPING : ms_peptidesummary
  • MSPEPSUM_NONE : ms_peptidesummary
  • MSPEPSUM_PERCOLATOR : ms_peptidesummary
  • MSPEPSUM_REMOVE_CHIMERIC_DUPES : ms_peptidesummary
  • MSPEPSUM_SINGLE_HIT_DBIDX : ms_peptidesummary
  • MSPEPSUM_SL_INTEGRATED : ms_peptidesummary
  • MSPEPSUM_SL_ONLY : ms_peptidesummary
  • MSPEPSUM_USE_CACHE : ms_peptidesummary
  • MSPEPSUM_USE_HOMOLOGY_THRESH : ms_peptidesummary
  • MSRES_CLUSTER_PROTEINS : ms_mascotresults
  • MSRES_DECOY : ms_mascotresults
  • MSRES_DUPE_DEFAULT : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_A : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_B : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_C : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_D : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_E : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_F : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_G : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_H : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_I : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_NONE : ms_mascotresults
  • MSRES_DUPE_REMOVE_A : ms_mascotresults
  • MSRES_DUPE_REMOVE_B : ms_mascotresults
  • MSRES_DUPE_REMOVE_C : ms_mascotresults
  • MSRES_DUPE_REMOVE_D : ms_mascotresults
  • MSRES_DUPE_REMOVE_E : ms_mascotresults
  • MSRES_DUPE_REMOVE_F : ms_mascotresults
  • MSRES_DUPE_REMOVE_G : ms_mascotresults
  • MSRES_DUPE_REMOVE_H : ms_mascotresults
  • MSRES_DUPE_REMOVE_I : ms_mascotresults
  • MSRES_DUPE_REMOVE_NONE : ms_mascotresults
  • MSRES_ERR_TOL : ms_mascotresults
  • MSRES_GROUP_PROTEINS : ms_mascotresults
  • MSRES_IGNORE_PMF_MIXTURE : ms_mascotresults
  • MSRES_INTEGRATED_ERR_TOL : ms_mascotresults
  • MSRES_MAXHITS_OVERRIDES_MINPROB : ms_mascotresults
  • MSRES_MUDPIT_PROTEIN_SCORE : ms_mascotresults
  • MSRES_NOFLAG : ms_mascotresults
  • MSRES_REQUIRE_BOLD_RED : ms_mascotresults
  • MSRES_SHOW_ALL_FROM_ERR_TOL : ms_mascotresults
  • MSRES_SHOW_SUBSETS : ms_mascotresults
  • MSRES_SUBSETS_DIFF_PROT : ms_mascotresults
  • MULTI_SITE_MODS : ms_searchparams
  • multiplyByRow() : ms_matrix
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • normalCriticalValue() : ms_quant_stats
  • normalCumulativeProbability() : ms_quant_stats
  • normaliseIntensities() : ms_ms2quantitation
  • normalisePeptideRatios() : ms_ms2quantitation
  • NTERM_CUTTER : ms_enzyme
  • NUM_PROCESSORS_AUTO_DETECT : ms_clusterparams
  • NUM_THREADS_AUTO_DETECT : ms_databaseoptions
  • NUMERICAL_VALUE_STORAGE : ms_mascotoptions
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • onLogMessage() : ms_buffer_logger, ms_file_logger, ms_logger, ms_stdout_logger
  • openIndexFile() : ms_tinycdb
  • openQuantitationCdbResults() : ms_ms1quantitation
  • openQuantitationXmlResults() : ms_ms1quantitation
  • operator bool() : ms_http_helper_return
  • operator!=() : ms_matrix, ms_peptide_quant_key, ms_protein_quant_ratio
  • operator*() : ms_matrix
  • operator<() : ms_peptide_quant_key, ms_protein
  • operator<=() : ms_peptide_quant_key
  • operator=() : ms_aahelper, ms_clusterparams, ms_computeraddress, ms_connection_settings, ms_cronjob, ms_cronoptions, ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_configfile, ms_crosslinking_does_not_pair_with, ms_crosslinking_filters, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_crosslinking_parameter, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_databaseoptions, ms_databases, ms_datfile, ms_dbprocessors, ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list, ms_enzyme, ms_enzymefile, ms_fragment, ms_fragmentationrules, ms_fragmentvector, ms_fragrulesfile, ms_http_client, ms_http_client_search, ms_http_client_session, ms_http_helper, ms_libraryoptions, ms_license, ms_linker_site, ms_linker_site_vector, ms_mascotfiles, ms_mascotoptions, ms_mascotresults_params, ms_masses, ms_modfile, ms_modification, ms_modvector, ms_obofile, ms_parseoptions, ms_parserule, ms_parserule_plus, ms_peptide, ms_peptide_quant_key, ms_peptide_quant_key_vector, ms_peptide_quant_ratio, ms_processoroptions, ms_processors, ms_protein, ms_protein_quant_ratio, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_configfile, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_parameter, ms_quant_parameters, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_security_options, ms_spectral_lib_entry, ms_spectral_lib_peak, ms_spectral_lib_peak_list, ms_taxnodesfiles, ms_taxonomychoice, ms_taxonomyfile, ms_taxonomyrules, ms_taxonomytree, ms_taxspeciesfiles, ms_treecluster, ms_umod_aminoacid, ms_umod_composition, ms_umod_configfile, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_unigeneoptions, ms_wwwentry, ms_wwwoptions, ms_xml_parameter, ms_zip
  • operator==() : ms_matrix, ms_peptide_quant_key, ms_protein_quant_ratio
  • operator>() : ms_peptide_quant_key
  • operator>=() : ms_peptide_quant_key
  • operator[]() : ms_matrix
  • outputKeepAlive() : ms_mascotresfilebase
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • params() : ms_mascotresfilebase
  • paramType : ms_security_task
  • parseCommandLineArgumentString() : ms_fileutilities
  • parseLine() : ms_obofile
  • PEAK_ANNOTATION_LEVEL : ms_spectral_lib_peak_list
  • PEAK_STATE_DISCARD : ms_xic
  • PEAK_STATE_OK : ms_xic
  • PEAK_STATE_UNKNOWN : ms_xic
  • peakState : ms_xic
  • PEPSUMMARY_CACHE_BEING_CREATED : ms_peptidesummary
  • PEPSUMMARY_CACHE_CAN_CREATE : ms_peptidesummary
  • PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS : ms_peptidesummary
  • PEPSUMMARY_CACHE_FILE_NOT_PRESENT : ms_peptidesummary
  • PEPSUMMARY_CACHE_NOT_FOR_PMF : ms_peptidesummary
  • PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE : ms_peptidesummary
  • PEPSUMMARY_CACHE_VALID : ms_peptidesummary
  • PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN : ms_quant_helper
  • PEPTIDE_EXPECT_ABOVE_THRESHOLD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_NO_EXCLUSIVE_MODS : ms_quant_helper
  • PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_NO_REQUIRED_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_UNMODIFIED_SITE : ms_quant_helper
  • PEPTIDE_IS_QUANTIFIABLE : ms_quant_helper
  • PEPTIDE_NOT_UNIQUE : ms_quant_helper
  • PEPTIDE_QUALITY : ms_quant_helper
  • PEPTIDE_QUALITY_IS_OK : ms_quant_helper
  • PEPTIDE_QUALITY_UNAVAILABLE : ms_quant_helper
  • PEPTIDE_QUANTIFIABILITY : ms_quant_helper
  • PEPTIDE_QUANTIFIABILITY_UNAVAILABLE : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_HOMOLOGY_THR : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_IDENTITY_THR : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_SCORE_THR : ms_quant_helper
  • peptideStatus : ms_ms1quant_peptide_status
  • PERC_EXE_RT : ms_mascotoptions
  • PERC_EXE_RT_FORCE_OFF : ms_mascotoptions
  • PERC_EXE_RT_FORCE_ON : ms_mascotoptions
  • PERC_EXE_RT_USE_DEFAULT : ms_mascotoptions
  • PERCOLATOR_FILE_NAMES : ms_mascotresfilebase
  • PERCOLATOR_INPUT_FILE : ms_mascotresfilebase
  • PERCOLATOR_OUTPUT_DECOY : ms_mascotresfilebase
  • PERCOLATOR_OUTPUT_TARGET : ms_mascotresfilebase
  • poissonDensity() : ms_quant_stats
  • pop() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • prepareToCreate() : ms_tinycdb
  • proteinKeys_ : ms_quantitation
  • PROXY_TYPE : ms_connection_settings
  • PROXY_TYPE_AUTO : ms_connection_settings
  • PROXY_TYPE_ENVIRONMENT : ms_connection_settings
  • PROXY_TYPE_FROM_REGISTRY : ms_connection_settings
  • PROXY_TYPE_NO_PROXY : ms_connection_settings
  • PROXY_TYPE_SPECIFY : ms_connection_settings
  • PROXY_TYPE_WPAD : ms_connection_settings
  • proxyTypeStringToEnum() : ms_connection_settings
  • proxyTypeToString() : ms_connection_settings
  • PS_DUPLICATESAMEQUERY : ms_ms1quant_peptide_status
  • PS_EXCLUDE_LOCALDEF : ms_ms1quant_peptide_status
  • PS_EXCLUDE_MODFILE : ms_ms1quant_peptide_status
  • PS_EXCLUDE_UNMODIFIED : ms_ms1quant_peptide_status
  • PS_EXPECTGREATERTHAN : ms_ms1quant_peptide_status
  • PS_LESSTHANIDENTITY : ms_ms1quant_peptide_status
  • PS_MAX : ms_ms1quant_peptide_status
  • PS_MINCHARGE : ms_ms1quant_peptide_status
  • PS_NOMATCHINTHISFRACTION : ms_ms1quant_peptide_status
  • PS_NOTPARTOFQUANTITATION : ms_ms1quant_peptide_status
  • PS_NOTUNIQUE : ms_ms1quant_peptide_status
  • PS_OK : ms_ms1quant_peptide_status
  • PS_SCORELESSHOMOLOGY : ms_ms1quant_peptide_status
  • PS_SCORELESSIDENTITY_NOHOMO : ms_ms1quant_peptide_status
  • PS_SCORELESSTHRESHOLD : ms_ms1quant_peptide_status
  • PSM : ms_peptide
  • PSM_COMPLETE : ms_peptide
  • PSM_CROSSLINK : ms_peptide
  • PSM_CROSSLINK_ALPHA : ms_peptide
  • PSM_CROSSLINK_BETA : ms_peptide
  • PSM_DECOY : ms_peptide
  • PSM_ERRTOL : ms_peptide
  • PSM_ERRTOLDECOY : ms_peptide
  • PSM_LIBRARY : ms_peptide
  • PSM_STANDARD : ms_peptide
  • PSM_TYPE : ms_peptide
  • push() : ms_linker_site_vector, ms_peptide_quant_key_vector
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QCS_ERROR_BAD_COMPONENT_NAME : ms_mascotresults
  • QCS_ERROR_NO_COMPONENTS : ms_mascotresults
  • QCS_ERROR_NO_METHOD : ms_mascotresults
  • QCS_OK : ms_mascotresults
  • QCS_OK_MULTIPLE_MATCHES : ms_mascotresults
  • QCS_OK_NO_MATCH : ms_mascotresults
  • QL_ALL : ms_peptidesummary
  • QL_BELOW_HOMOLOGY : ms_peptidesummary
  • QL_BELOW_IDENTITY : ms_peptidesummary
  • QL_FLAG : ms_peptidesummary
  • QL_IGNORE_IONS_SCORE_BELOW : ms_peptidesummary
  • QL_LAST : ms_peptidesummary
  • QL_UNASSIGNED : ms_peptidesummary
  • QUANT_COMPONENT_STATUS : ms_mascotresults
  • QUERY : ms_mascotresults
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • ratioStatusCode : ms_ms1quant_match_ratio
  • read_buffer() : ms_crosslinking_configfile, ms_enzymefile, ms_fragrulesfile, ms_quant_configfile, ms_taxonomyfile, ms_umod_configfile
  • read_file() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile, ms_license, ms_masses, ms_modfile, ms_quant_configfile, ms_taxonomyfile, ms_umod_configfile
  • readResultCounters() : ms_ms1quantitation
  • REDIRECT_POLICY : ms_connection_settings
  • REDIRECT_POLICY_ALWAYS : ms_connection_settings
  • REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP : ms_connection_settings
  • REDIRECT_POLICY_NEVER : ms_connection_settings
  • removeAllTasks() : ms_security_tasks
  • removeCombinedReportRatio() : ms_ms2quantitation
  • removeComponent() : ms_ms1quant_match
  • removeDuplicateIndexes() : ms_imputation_method
  • removeIntensityNormalisationBase() : ms_ms2quantitation
  • removeIntensityNormalisationBases() : ms_ms2quantitation
  • removeLogEventsHandler() : ms_loggingmonitor
  • removeMatch() : ms_ms1quantitation
  • removePeptideQuantKey() : ms_customquantitation
  • removePeptideRatio() : ms_customquantitation
  • removePeptideRatioNormalisationBase() : ms_quantitation
  • removePeptideRatioNormalisationBases() : ms_quantitation
  • removePermittedTask() : ms_group
  • removeReportRatioInFile() : ms_ms2quantitation
  • removeSubtask() : ms_progress_info
  • removeTask() : ms_security_tasks
  • ReportTopSpecialValues : ms_http_client_search
  • resetKeepAlive() : ms_mascotresfilebase
  • RESFILE_CACHE_BEING_CREATED : ms_peptidesummary
  • RESFILE_CACHE_CAN_CREATE : ms_peptidesummary
  • RESFILE_CACHE_DISABLED_IN_OPTIONS : ms_peptidesummary
  • RESFILE_CACHE_FILE_NOT_PRESENT : ms_peptidesummary
  • RESFILE_CACHE_IGNORE_ACC_DUPES : ms_mascotresfilebase
  • RESFILE_CACHE_IGNORE_DATE_CHANGE : ms_mascotresfilebase
  • RESFILE_CACHE_VALID : ms_peptidesummary
  • RESFILE_DAT28 : ms_mascotresfilebase
  • RESFILE_MSR : ms_mascotresfilebase
  • RESFILE_NOFLAG : ms_mascotresfilebase
  • RESFILE_TYPE : ms_mascotresfilebase
  • RESFILE_UNKNOWN : ms_mascotresfilebase
  • RESFILE_USE_CACHE : ms_mascotresfilebase
  • RESFILE_USE_PARENT_PARAMS : ms_mascotresfilebase
  • resfileType() : ms_mascotresfilebase
  • resize() : ms_matrix
  • retentionTime() : ms_imputation_peptide_data
  • rewind() : ms_msr2dat28
  • rowMatrix() : ms_matrix
  • RS_DO_NOT_USE : ms_ms1quant_match_ratio
  • RS_EMPTY : ms_ms1quant_match_ratio
  • RS_FITEXYSIGMA : ms_ms1quant_match_ratio
  • RS_INFINITERATIO : ms_ms1quant_match_ratio
  • RS_INTEFERENCEFAILED : ms_ms1quant_match_ratio
  • RS_ISOLATEDPRECURSORFAILED : ms_ms1quant_match_ratio
  • RS_NEGATIVERATIO : ms_ms1quant_match_ratio
  • RS_NODATA : ms_ms1quant_match_ratio
  • RS_OK : ms_ms1quant_match_ratio
  • RS_TOTALINTENSITYFAILED : ms_ms1quant_match_ratio
  • RS_ZERORATIO : ms_ms1quant_match_ratio
  • RT_auto : ms_http_client_search
  • RT_file : ms_http_client_search
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • S_NOT_STARTED : ms_progress_info
  • S_RUNNING : ms_progress_info
  • S_RUNNING_INDETERMINATE : ms_progress_info
  • S_STOPPED_BREAK : ms_progress_info
  • S_STOPPED_COMPLETE : ms_progress_info
  • S_STOPPED_FAIL : ms_progress_info
  • SAR_FAIL_CHMOD : ms_fileutilities
  • SAR_FAIL_CHOWN : ms_fileutilities
  • SAR_FAIL_GET_NAMED_SECURITY_INFO : ms_fileutilities
  • SAR_FAIL_SET_ENTRIES_IN_ACL : ms_fileutilities
  • SAR_FAIL_SET_NAMED_SECURITY_INFO : ms_fileutilities
  • SAR_SUCCESS : ms_fileutilities
  • save_buffer() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • save_file() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile, ms_masses, ms_modfile, ms_quant_configfile, ms_taxonomyfile, ms_umod_configfile
  • saveAs() : ms_spectral_lib_file
  • saveBoolParam() : ms_session
  • saveCdbFile() : ms_ms1quantitation, ms_ms2quantitation
  • saveDoubleParam() : ms_session
  • saveFileOffsetForKey() : ms_tinycdb
  • saveIntForKey() : ms_tinycdb
  • saveIntParam() : ms_session
  • saveLongParam() : ms_session
  • saveStringParam() : ms_group, ms_session, ms_user
  • saveTimeParam() : ms_session
  • saveToFile() : ms_security_tasks
  • saveToString() : ms_masses, ms_modfile
  • saveValueForKey() : ms_tinycdb
  • saveXmlFile() : ms_ms1quant_time_align, ms_ms1quantitation, ms_ms2quantitation
  • SCORE : ms_mascotresults
  • SearchStatusCode : ms_http_client_search
  • SEC_CROSSLINK_PEPTIDES : ms_mascotresfile_dat
  • SEC_CROSSLINK_SUMMARY : ms_mascotresfile_dat
  • SEC_CROSSLINKING : ms_mascotresfile_dat
  • SEC_DECOYMIXTURE : ms_mascotresfile_dat
  • SEC_DECOYPEPTIDES : ms_mascotresfile_dat
  • SEC_DECOYPROTEINS : ms_mascotresfile_dat
  • SEC_DECOYSUMMARY : ms_mascotresfile_dat
  • SEC_ENZYME : ms_mascotresfile_dat
  • SEC_ERRTOLDECOYPEPTIDES : ms_mascotresfile_dat
  • SEC_ERRTOLDECOYSUMMARY : ms_mascotresfile_dat
  • SEC_ERRTOLPEPTIDES : ms_mascotresfile_dat
  • SEC_ERRTOLSUMMARY : ms_mascotresfile_dat
  • SEC_HEADER : ms_mascotresfile_dat
  • SEC_INDEX : ms_mascotresfile_dat
  • SEC_LIBRARYPEPTIDES : ms_mascotresfile_dat
  • SEC_LIBRARYSUMMARY : ms_mascotresfile_dat
  • SEC_MASSES : ms_mascotresfile_dat
  • SEC_MIXTURE : ms_mascotresfile_dat
  • SEC_NUMSECTIONS : ms_mascotresfile_dat
  • SEC_PARAMETERS : ms_mascotresfile_dat
  • SEC_PEPTIDES : ms_mascotresfile_dat
  • SEC_PROTEINS : ms_mascotresfile_dat
  • SEC_QUANTITATION : ms_mascotresfile_dat
  • SEC_QUERY1 : ms_mascotresfile_dat
  • SEC_SPECTRAL_LIBRARY : ms_mascotresfile_dat
  • SEC_SUMMARY : ms_mascotresfile_dat
  • SEC_TAXONOMY : ms_mascotresfile_dat
  • SEC_UNIMOD : ms_mascotresfile_dat
  • SEC_UNIMOD_XL : ms_mascotresfile_dat
  • SECTASK_ACCESSDBSETUP : ms_security_tasks
  • SECTASK_ADMINPAGES : ms_security_tasks
  • SECTASK_ALLFASTA : ms_security_tasks
  • SECTASK_ALLOWMSMS : ms_security_tasks
  • SECTASK_ALLOWMSMSNOENZYME : ms_security_tasks
  • SECTASK_ALLOWPMF : ms_security_tasks
  • SECTASK_ALLOWPMFNOENZYME : ms_security_tasks
  • SECTASK_ALLOWSPOOFOTHERUSER : ms_security_tasks
  • SECTASK_BIOTOOLSBATCH : ms_security_tasks
  • SECTASK_DAEMONCLIENT : ms_security_tasks
  • SECTASK_DATAURLMAXSIZE : ms_security_tasks
  • SECTASK_DATAURLPROTOCOLS : ms_security_tasks
  • SECTASK_DENYQUANT : ms_security_tasks
  • SECTASK_DISTILLERCLIENT : ms_security_tasks
  • SECTASK_DOWNLOAD_DISTILLER_XML : ms_security_tasks
  • SECTASK_EDITCONFIG : ms_security_tasks
  • SECTASK_INTEGRASYSTEMACCOUNT : ms_security_tasks
  • SECTASK_KILLALLTASK : ms_security_tasks
  • SECTASK_KILLTASKINGROUP : ms_security_tasks
  • SECTASK_MAXCONCURRENTSEARCHES : ms_security_tasks
  • SECTASK_MAXETACCESSIONS : ms_security_tasks
  • SECTASK_MAXETVARMODS : ms_security_tasks
  • SECTASK_MAXEXECUTIONTIME : ms_security_tasks
  • SECTASK_MAXFASTAFILES : ms_security_tasks
  • SECTASK_MAXJOBPRIORITY : ms_security_tasks
  • SECTASK_MAXNOENZQUERIES : ms_security_tasks
  • SECTASK_MAXQUERIES : ms_security_tasks
  • SECTASK_MAXVARMODS : ms_security_tasks
  • SECTASK_MODIFYOWNPROFILE : ms_security_tasks
  • SECTASK_MSSTATUSEXECLUSTER : ms_security_tasks
  • SECTASK_MSSTATUSEXERETRYDB : ms_security_tasks
  • SECTASK_NAMEDFASTA : ms_security_tasks
  • SECTASK_SEEALLSEARCHESWITHUSERID : ms_security_tasks
  • SECTASK_SEEOLDSEARCHES : ms_security_tasks
  • SECTASK_SEESEARCHINANYGROUP : ms_security_tasks
  • SECTASK_SEESEARCHINGROUP : ms_security_tasks
  • SECTASK_SPOOFNAMEDGROUPSONLY : ms_security_tasks
  • SECTASK_UPLOAD_DISTILLER_XML : ms_security_tasks
  • SECTASK_USEMSREVIEWEXE : ms_security_tasks
  • SECTASK_USEMSSTATUSEXE : ms_security_tasks
  • SECTASK_VIEWCONFIG : ms_security_tasks
  • SECTASK_VIEWCONFIGUSINGMSSTATUS : ms_security_tasks
  • section : ms_mascotresfile_dat
  • SEQDB_INSTALL : ms_datfile
  • SEQDB_INSTALL_CURRENT_RULES : ms_datfile
  • SEQDB_INSTALL_CUSTOMISED : ms_datfile
  • SEQDB_INSTALL_EXISTING_LARGER : ms_datfile
  • SEQDB_INSTALL_INACTIVE : ms_datfile
  • SEQDB_INSTALL_INVALID_CONFIG : ms_datfile
  • SEQDB_INSTALL_INVALID_DBNAME : ms_datfile
  • SEQDB_INSTALL_MISSING_CONFIG : ms_datfile
  • SEQDB_INSTALL_MUST_UPDATE_CFG : ms_datfile
  • SEQDB_INSTALL_OLD_RULES : ms_datfile
  • SEQDB_INSTALL_SHOULD_QUERY_USER : ms_datfile
  • SEQDB_INSTALL_WRONG_WILDCARD : ms_datfile
  • SequenceShowOptions : ms_http_client_session
  • serverVersionNewerOrSameAs() : ms_distiller_data_search
  • sessionId() : ms_http_client_search
  • set() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • setAbort() : ms_http_helper_progress
  • setAccession() : ms_quant_normalisation_protein
  • setAccessionParseRuleIndex() : ms_databaseoptions
  • setAccessionRefParseRuleIndex() : ms_databaseoptions
  • setAccessions() : ms_crosslinking_method
  • setAccessRights() : ms_fileutilities
  • setAccFromSpeciesLine() : ms_taxonomyrules
  • setAccountEnabled() : ms_user
  • setActive() : ms_databaseoptions
  • setAlgorithmName() : ms_ms1quant_time_align
  • setAllChargeStates() : ms_quant_integration
  • setAllChargeStatesThreshold() : ms_quant_integration
  • setAllowElutionShift() : ms_quant_integration
  • setAllowMassTimeMatch() : ms_quant_precursor
  • setAlwaysCreateDat28ResultsFile() : ms_mascotoptions
  • setAlwaysEnableAutoDecoySearch() : ms_mascotoptions
  • setAnnotation() : ms_spectral_lib_peak
  • setAnnotationLevel() : ms_spectral_lib_peak_list
  • setAPI() : ms_errs
  • setApproved() : ms_umod_modification
  • setAutoSelectCharge() : ms_mascotoptions
  • setAvailable() : ms_parserule
  • setAvailableModifications() : ms_aahelper
  • setAverage() : ms_quant_moverz, ms_quant_protocol
  • setAverageFeatureWidths() : ms_ms1quant_time_align
  • setAverageNumPeptides() : ms_ms1quantitation
  • setAverageReferenceProtein() : ms_ms1quantitation
  • setAverageSelection() : ms_ms1quantitation
  • setAverageValues() : ms_imputation_average_value
  • setAvgeMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • setBaseUrl() : ms_http_client
  • setBreak() : ms_progress_info
  • setCacheDirectory() : ms_mascotoptions
  • setCarbonMass() : ms_masses
  • setCentroidWidth() : ms_mascotoptions
  • setCentroidWidthCount() : ms_mascotoptions
  • setCharged2Plus() : ms_fragmentationrules
  • setCharged3Plus() : ms_fragmentationrules
  • setCheckNodesAliveFreq() : ms_clusterparams
  • setChopSource() : ms_parserule_plus
  • setClassification() : ms_umod_specificity
  • setClusterParams() : ms_datfile
  • setCode() : ms_umod_neutralloss
  • setCoefficient() : ms_quant_numerator
  • setColsToOutput() : ms_logger
  • setColumnDown() : ms_matrix
  • setColumnUp() : ms_matrix
  • setCombinedReportRatio() : ms_ms2quantitation
  • setCombineRepeats() : ms_errs
  • setCommandStr() : ms_cronjob
  • setComp() : ms_quant_method
  • setCompositionString() : ms_umod_composition
  • setCompressToolAA() : ms_mascotoptions
  • setCompressToolNA() : ms_mascotoptions
  • setCompressToolSL() : ms_mascotoptions
  • setConcatRefFileLines() : ms_taxonomyrules
  • setConnectionSettings() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile, ms_http_client, ms_masses, ms_modfile, ms_quant_configfile, ms_taxonomyfile, ms_umod_configfile
  • setConnectionTimeout() : ms_connection_settings
  • setConstrainSearch() : ms_quant_method
  • setContent() : ms_quant_correction, ms_quant_file_index, ms_quant_numerator, ms_quant_unmodified
  • setCR() : ms_matrix
  • setCrawlerNumPeaksPer100Da() : ms_mascotoptions
  • setCreateLegacyModAndSubstitutionFiles() : ms_mascotoptions
  • setCreatePipThreadBlockSize() : ms_mascotoptions
  • setCreatePipThreads() : ms_mascotoptions
  • setCronEnabled() : ms_cronoptions
  • setCronJob() : ms_cronoptions
  • setCronOptions() : ms_datfile
  • setCTerminusMass() : ms_modification
  • setCtermModification() : ms_masses
  • setDatabaseName() : ms_crosslinking_accession
  • setDatabases() : ms_datfile
  • setDataWithMissing() : ms_imputation_method
  • setDateTimeModified() : ms_umod_modification
  • setDateTimePosted() : ms_umod_modification
  • setDayOfMonth() : ms_cronjob
  • setDayOfWeek() : ms_cronjob
  • setDB() : ms_protein
  • setDBLevelTaxId() : ms_taxonomyrules
  • setDBType() : ms_databaseoptions
  • setDechargeFragmentPeaks() : ms_mascotoptions
  • setDecoyTypeNoEnzyme() : ms_mascotoptions
  • setDecoyTypeSpecific() : ms_mascotoptions
  • setDefaultDelimiter() : ms_customproperty
  • setDefaultMonitor() : ms_loggingmonitor
  • setDefaultNodeHomeDir() : ms_clusterparams
  • setDefaultNodeHomeDirFromMaster() : ms_clusterparams
  • setDefaultNodeOS() : ms_clusterparams
  • setDefaultPasswordExpiryTime() : ms_security_options
  • setDefaultPort() : ms_clusterparams
  • setDefaultRule() : ms_taxonomyrules
  • setDefaultTargetFDRPercentage() : ms_mascotoptions
  • setDelta() : ms_modification, ms_quant_localdef, ms_umod_modification
  • setDescription() : ms_crosslinking_method, ms_quant_method, ms_umod_neutralloss, ms_xml_parameter
  • setDescriptionLineSep() : ms_taxonomyrules
  • setDescriptionParseRuleIndex() : ms_databaseoptions
  • setDisplayNonSignificantMatches() : ms_mascotoptions
  • setDoThisRuleFirst() : ms_taxonomyrules
  • setElectronMass() : ms_masses
  • setElement() : ms_quant_correction
  • setElutionProfileCorrelationThreshold() : ms_quant_integration
  • setElutionTimeDelta() : ms_quant_integration
  • setElutionTimeDeltaUnit() : ms_quant_integration
  • setEmailAddress() : ms_user
  • setEmailErrorsEnabled() : ms_mascotoptions
  • setEmailFromTextName() : ms_mascotoptions
  • setEmailFromUser() : ms_mascotoptions
  • setEmailPassword() : ms_mascotoptions
  • setEmailProfile() : ms_mascotoptions
  • setEmailService() : ms_mascotoptions
  • setEmailTimeOutPeriod() : ms_mascotoptions
  • setEmailUsersEnabled() : ms_mascotoptions
  • setEnabled() : ms_clusterparams, ms_cronjob, ms_taxonomyrules
  • setEncryptedPassword() : ms_user
  • setEntry() : ms_wwwoptions
  • setEnzyme() : ms_aahelper
  • setEnzymes() : ms_mascotfiles
  • setErrMessageEmailTo() : ms_mascotoptions
  • setErrorInfoFromString() : ms_mascotresfilebase
  • setErrorLevel() : ms_taxonomyrules
  • setErrorLogFile() : ms_mascotoptions
  • setErrTolMaxAccessions() : ms_mascotoptions
  • setEvaluation() : ms_ms1quant_time_align
  • setExcludeInternalLabel() : ms_quant_multiplex
  • setExcludeIsobaricFragments() : ms_quant_multiplex
  • setExecAfterSearch() : ms_mascotoptions
  • setFeatureTableLength() : ms_mascotoptions
  • setFeatureTableMinScore() : ms_mascotoptions
  • setFileIndex() : ms_quant_component
  • setFileName() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile, ms_license, ms_masses, ms_modfile, ms_quant_configfile, ms_taxnodesfiles, ms_taxonomyfile, ms_taxspeciesfiles, ms_umod_configfile
  • setFileTypeToSearch() : ms_parserule_plus
  • setFilters() : ms_crosslinking_method
  • setFindFileTimeout() : ms_datfile
  • setFixedValue() : ms_imputation_fixed_value
  • setFlag() : ms_mascotresults_params, ms_quant_neutralloss, ms_umod_neutralloss
  • setFlag2() : ms_mascotresults_params
  • setFlags() : ms_mascotresults_params
  • setFlags2() : ms_mascotresults_params
  • setForkForUnixApache() : ms_mascotoptions
  • setFormat() : ms_taxnodesfiles, ms_taxspeciesfiles
  • setFormVersion() : ms_mascotoptions
  • setFraction() : ms_quant_file_index
  • setFrequencies() : ms_mascotfiles
  • setFromRefFile() : ms_taxonomyrules
  • setFromSubstitutions() : ms_modfile
  • setFullName() : ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification, ms_user
  • setGetSeqBlastAccession() : ms_mascotoptions
  • setGetSeqJobIdFile() : ms_mascotoptions
  • setGroupOfPoster() : ms_umod_modification
  • setHeaderComments() : ms_datfile
  • setHidden() : ms_modification, ms_umod_specificity
  • setHitRatioExcluded() : ms_ms1quant_match
  • setHitRatioOutlier() : ms_ms1quant_match
  • setHostName() : ms_computeraddress, ms_wwwentry
  • setHour() : ms_cronjob
  • setHttpPassword() : ms_connection_settings
  • setHttpProtocol() : ms_connection_settings
  • setHttpUsername() : ms_connection_settings
  • setHydrogenMass() : ms_masses
  • setICATFilter() : ms_mascotoptions
  • setICATHeavy() : ms_mascotoptions
  • setICATLight() : ms_mascotoptions
  • setICATQuantitationMethod() : ms_mascotoptions
  • setID() : ms_group, ms_user
  • setIdentifier() : ms_taxonomyrules
  • setIgnoreDupeAccession() : ms_mascotoptions
  • setIgnoreIonsScoreBelow() : ms_mascotoptions, ms_mascotresults_params
  • setImputationVariableChoice() : ms_imputation
  • setImputeExcludedMs2PeptideRatios() : ms_imputation
  • setImputeMs1PeptideExcludedByCorrelationThr() : ms_imputation
  • setImputeMs1PeptideExcludedByFractionThr() : ms_imputation
  • setImputeMs1PeptideExcludedByStdErrThr() : ms_imputation
  • setImputeMs1PeptideNegativeRatio() : ms_imputation
  • setIndependent() : ms_enzyme
  • setIndexFileName() : ms_tinycdb
  • setInErrorTolerant() : ms_modification
  • setInetAddress() : ms_computeraddress
  • setInLongList() : ms_modification
  • setInShortList() : ms_modification
  • setIntegraAppServerURL() : ms_security_options
  • setIntegraDatabaseName() : ms_security_options
  • setIntegraOracleServerName() : ms_security_options
  • setIntegration() : ms_quant_method
  • setIntensityNormalisationBase() : ms_ms2quantitation
  • setIntensitySigFigs() : ms_mascotoptions
  • setInterFileBasePath() : ms_mascotoptions
  • setInterFileRelPath() : ms_mascotoptions
  • setIonIntensityThreshold() : ms_quant_multiplex
  • setIonsDecimalPlaces() : ms_mascotoptions
  • setIonSeries() : ms_quant_multiplex
  • setIPCLogfile() : ms_clusterparams
  • setIPCLogging() : ms_clusterparams
  • setIPCTimeout() : ms_clusterparams
  • setIsolatedPrecursor() : ms_quant_quality
  • setIsolatedPrecursorThreshold() : ms_quant_quality
  • setIteratePMFIntensities() : ms_mascotoptions
  • setKnnNumNeighbours() : ms_imputation_knn
  • setKnnUseWeightedAverage() : ms_imputation_knn
  • setLabelAll() : ms_mascotoptions
  • setLastModificationTime() : ms_fileutilities
  • setLastQueryAscFile() : ms_mascotoptions
  • setLibraryOptions() : ms_datfile
  • setLinkers() : ms_crosslinking_method
  • setLocalModsStr() : ms_peptide
  • setLocalRefFile() : ms_databaseoptions
  • setLockMemory() : ms_databaseoptions
  • setLogFileName() : ms_cronoptions, ms_security_options
  • setLoggingFile() : ms_errs
  • setLoggingLevel() : ms_cronoptions, ms_errs, ms_security_options
  • setLogMask() : ms_loggingmonitor
  • setLogoImageFile() : ms_mascotoptions
  • setMailTempFile() : ms_mascotoptions
  • setMailTransport() : ms_mascotoptions
  • setMajorVersion() : ms_umod_configfile
  • setMascNodeCtrlFile() : ms_mascotoptions
  • setMascotCmdLine() : ms_mascotoptions
  • setMascotControlFile() : ms_mascotoptions
  • setMascotFileProcessingThreads() : ms_mascotoptions
  • setMascotFiles() : ms_datfile
  • setMascotJobIdFile() : ms_mascotoptions
  • setMascotMessage() : ms_mascotoptions
  • setMascotNodeRebootScript() : ms_clusterparams
  • setMascotNodeScript() : ms_clusterparams
  • setMascotOptions() : ms_datfile
  • setMassDecimalPlaces() : ms_mascotoptions
  • setMassDelta() : ms_quant_integration
  • setMassDeltaUnit() : ms_quant_integration
  • setMasses() : ms_aahelper
  • setMassFile() : ms_modfile, ms_modification
  • setMasterComputer() : ms_clusterparams
  • setMatchedIon() : ms_fragment
  • setMatchedRho() : ms_quant_integration
  • setMatchOppositeCrosslinkPairs() : ms_mascotoptions
  • setMaxBinNum() : ms_ms1quant_time_align_limits
  • setMaxConcurrentSearches() : ms_mascotoptions
  • setMaxDatabases() : ms_mascotoptions
  • setMaxDescriptionLen() : ms_mascotoptions
  • setMaxEtagMassDelta() : ms_mascotoptions
  • setMaxEtVarMods() : ms_mascotoptions
  • setMaxHitsToReport() : ms_mascotresults_params
  • setMaxIntactCrosslinkPeptides() : ms_mascotoptions
  • setMaxInternalMass() : ms_fragmentationrules
  • setMaxMZ() : ms_ms1quant_time_align_limits
  • setMaxNumPeptides() : ms_mascotoptions
  • setMaxPepModArrangements() : ms_mascotoptions
  • setMaxPepNumModifiedSites() : ms_mascotoptions
  • setMaxPepNumVarMods() : ms_mascotoptions
  • setMaxQueries() : ms_mascotoptions
  • setMaxRT() : ms_ms1quant_time_align_limits
  • setMaxSearchesPerUser() : ms_mascotoptions
  • setMaxSequenceLen() : ms_mascotoptions
  • setMaxVarMods() : ms_mascotoptions
  • setMemoryMapFiles() : ms_databaseoptions
  • setMethod() : ms_quant_integration, ms_quant_normalisation, ms_quant_outliers
  • setMinBinNum() : ms_ms1quant_time_align_limits
  • setMinEtagMassDelta() : ms_mascotoptions
  • setMinimumA1() : ms_quant_quality
  • setMinimumPasswordLength() : ms_security_options
  • setMinInternalMass() : ms_fragmentationrules
  • setMinIonPairs() : ms_quant_multiplex
  • setMinMZ() : ms_ms1quant_time_align_limits
  • setMinNumPeptides() : ms_quant_method, ms_quantitation
  • setMinNumSigUniqueSequences() : ms_mascotresults_params
  • setMinorVersion() : ms_umod_configfile
  • setMinPepLenInPepSummary() : ms_mascotoptions
  • setMinPepLenInPeptideSummary() : ms_mascotresults_params
  • setMinPepLenInSearch() : ms_mascotoptions
  • setMinPrecursorCharge() : ms_quant_quality
  • setMinProbability() : ms_mascotresults_params
  • setMinRT() : ms_ms1quant_time_align_limits
  • setMinute() : ms_cronjob
  • setMiscNotes() : ms_umod_modification, ms_umod_specificity
  • setMissing() : ms_imputation_missing_val
  • setMitochondrialTranslation() : ms_taxonomyrules
  • setMode() : ms_quant_modgroup
  • setModFileName() : ms_crosslinking_does_not_pair_with, ms_crosslinking_linker
  • setModifications() : ms_mascotfiles, ms_quant_satellite
  • setModificationType() : ms_modification
  • setMonitorEmailCheckFreq() : ms_mascotoptions
  • setMonitorLogFile() : ms_mascotoptions
  • setMonitorPidFile() : ms_mascotoptions
  • setMonitorTestTimeout() : ms_mascotoptions
  • setMonoisotopic() : ms_quant_moverz
  • setMonoMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • setMonthOfYear() : ms_cronjob
  • setMoveOldDbToOldDir() : ms_mascotoptions
  • setMoverz() : ms_quant_component
  • setMudpit() : ms_mascotoptions
  • setMudpitSwitch() : ms_mascotoptions
  • setMultiplex() : ms_quant_protocol
  • setName() : ms_crosslinking_method, ms_databaseoptions, ms_dbprocessors, ms_group, ms_quant_component, ms_quant_method, ms_quant_modgroup, ms_quant_numerator, ms_quant_ratio, ms_user, ms_wwwentry, ms_xml_parameter
  • setNameOfDB() : ms_parserule_plus
  • setNeutralLoss() : ms_modification
  • setNew() : ms_quant_isotope
  • setNitrogenMass() : ms_masses
  • setNodeListFile() : ms_mascotfiles
  • setNodeSequenceDatabaseDir() : ms_clusterparams
  • setNoResultsScript() : ms_mascotoptions
  • setNormalisation() : ms_quant_method
  • setNTerminusMass() : ms_modification
  • setNtermModification() : ms_masses
  • setNTIUserGroup() : ms_mascotoptions
  • setNTMonitorGroup() : ms_mascotoptions
  • setNull() : ms_quant_protocol
  • setNumber() : ms_quant_element, ms_umod_elemref
  • setNumberOfThreads() : ms_databaseoptions
  • setNumPeptides() : ms_quant_average
  • setNumQueries() : ms_ms1quant_time_align_limits
  • setNumQueriesAboveThreshold() : ms_ms1quant_time_align_limits
  • setOld() : ms_quant_isotope
  • setOutliers() : ms_quant_method
  • setOxygenMass() : ms_masses
  • setPairsWith() : ms_umod_neutralloss
  • setParams() : ms_security_task
  • setParseOptions() : ms_datfile
  • setParseRule() : ms_parseoptions, ms_wwwentry
  • setPassword() : ms_user
  • setPasswordExpiry() : ms_user
  • setPath() : ms_databaseoptions, ms_wwwentry
  • setPepNeutralLoss() : ms_modification
  • setPepSearchTool() : ms_mascotoptions
  • setPepThresholdType() : ms_quant_quality
  • setPepThresholdValue() : ms_quant_quality
  • setPeptideIsBold() : ms_protein
  • setPeptideRatioExcluded() : ms_customquantitation, ms_ms2quantitation, ms_quantitation
  • setPeptideRatioIncluded() : ms_customquantitation, ms_ms2quantitation, ms_quantitation
  • setPeptideRatioNormalisationBase() : ms_quantitation
  • setPeptides() : ms_quant_normalisation
  • setPeptideShowCheckbox() : ms_protein
  • setPercolator() : ms_mascotoptions
  • setPercolatorExeFlags() : ms_mascotoptions
  • setPercolatorFeatures() : ms_mascotoptions, ms_mascotresfilebase
  • setPercolatorMinQueries() : ms_mascotoptions
  • setPercolatorMinSequences() : ms_mascotoptions
  • setPercolatorTargetRankRelativeThreshold() : ms_mascotoptions
  • setPercolatorTargetRankScoreThreshold() : ms_mascotoptions
  • setPercolatorUseProteins() : ms_mascotoptions
  • setPercolatorUseRT() : ms_mascotoptions
  • setPermittedTasks() : ms_group, ms_session
  • setPort() : ms_computeraddress
  • setPortNumber() : ms_wwwentry
  • setPosition() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • setPreceedingComments() : ms_customproperty, ms_databaseoptions
  • setPrecursor() : ms_quant_protocol
  • setPrecursorCutOutLowerLimit() : ms_mascotoptions
  • setPrecursorCutOutUpperLimit() : ms_mascotoptions
  • setPrecursorRange() : ms_quant_integration
  • setPrivacyEnabled() : ms_umod_modification
  • setPrivate() : ms_umod_modification
  • setProcessingOptions() : ms_quant_integration
  • setProcessors() : ms_datfile
  • setPropertyName() : ms_customproperty
  • setPropValBoolByName() : ms_customproperty
  • setPropValCharByName() : ms_customproperty
  • setPropValFloatByName() : ms_customproperty
  • setPropValInt64ByName() : ms_customproperty
  • setPropValIntByName() : ms_customproperty
  • setPropValStringByName() : ms_customproperty
  • setPropValStringByNumber() : ms_customproperty
  • setProteinFamilySwitch() : ms_mascotoptions
  • setProteinId() : ms_protein
  • setProteinRatioType() : ms_customquantitation, ms_ms2quantitation, ms_quant_method, ms_quantitation
  • setProteins() : ms_quant_normalisation
  • setProteinsInResultsFile() : ms_mascotoptions
  • setProtocol() : ms_quant_method
  • setProtScoreType() : ms_quant_method
  • setProxyPassword() : ms_connection_settings, ms_mascotoptions
  • setProxyServer() : ms_connection_settings, ms_mascotoptions
  • setProxyServerType() : ms_connection_settings
  • setProxyType() : ms_mascotoptions
  • setProxyUsername() : ms_connection_settings, ms_mascotoptions
  • setQuality() : ms_quant_method
  • setQuantNormalisation() : ms_ms2quantitation
  • setQuantOutliers() : ms_customquantitation, ms_ms2quantitation, ms_quantitation
  • setQuickRefSearch() : ms_taxonomyrules
  • setRC() : ms_matrix
  • setRecordID() : ms_umod_modification
  • setRedirectPolicy() : ms_connection_settings
  • setReferenceAccession() : ms_quant_average
  • setReferenceAmount() : ms_quant_average
  • setReferenceDatabase() : ms_quant_average
  • setReferenceFasta() : ms_libraryoptions
  • setRemoveOldIndexFiles() : ms_mascotoptions
  • setReplicate() : ms_quant_protocol
  • setReportBuilderColumnArrangement() : ms_mascotoptions
  • setReportDetail() : ms_quant_method
  • setReporter() : ms_quant_protocol
  • setReporterTol() : ms_quant_reporter
  • setReporterTolUnit() : ms_quant_reporter
  • setReportNumberChoice() : ms_mascotoptions
  • setReportRatioInFile() : ms_ms2quantitation
  • setReqPepNeutralLoss() : ms_modification
  • setRequireBoldRed() : ms_mascotoptions, ms_quant_method
  • setRequired() : ms_quant_modgroup, ms_quant_pepneutralloss
  • setResfileCache() : ms_mascotoptions
  • setResidueMasses() : ms_masses
  • setResidueModification() : ms_masses
  • setResultsCache() : ms_mascotoptions
  • setResultsFileFormatVersion() : ms_mascotoptions
  • setResultsFullURL() : ms_mascotoptions
  • setResultsFullURL_2() : ms_mascotoptions
  • setResultsPerlScript() : ms_mascotoptions
  • setResultsPerlScript_2() : ms_mascotoptions
  • setReviewColDisplay() : ms_mascotoptions
  • setReviewColWidth() : ms_mascotoptions
  • setRow() : ms_treecluster
  • setRule() : ms_parserule_plus
  • setRuleStr() : ms_parserule
  • setSatellite() : ms_quant_component
  • setSaveEveryLastQueryAsc() : ms_mascotoptions
  • setSaveLastQueryAsc() : ms_mascotoptions
  • setSchemaDirectory() : ms_quant_configfile
  • setSchemaFileName() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • setScope() : ms_crosslinking_method
  • setSearchLogFile() : ms_mascotoptions
  • setSearchSubmitAcceptedFileTypes() : ms_mascotoptions
  • setSearchSubmitDefaultPeptideCharge() : ms_mascotoptions
  • setSearchSubmitMode() : ms_mascotoptions
  • setSearchSubmitOutputFormat() : ms_mascotoptions
  • setSecsToWaitForNodeAtStartup() : ms_clusterparams
  • setSectionAvailable() : ms_clusterparams, ms_cronoptions, ms_databases, ms_libraryoptions, ms_mascotoptions, ms_parseoptions, ms_processoroptions, ms_taxonomyrules, ms_unigeneoptions, ms_wwwoptions
  • setSecurityEnabled() : ms_security_options
  • setSelection() : ms_quant_average
  • setSelectSwitch() : ms_mascotoptions
  • setSemiSpecific() : ms_enzyme
  • setSendmailPath() : ms_mascotoptions
  • setSequence() : ms_quant_normalisation_peptide
  • setSeriesUsed() : ms_fragmentationrules
  • setSessionID() : ms_connection_settings
  • setSessionTimeout() : ms_security_options
  • setSettings() : ms_crosslinking_method
  • setShift() : ms_quant_correction
  • setShowAllFromErrorTolerant() : ms_mascotoptions
  • setShowSubsets() : ms_mascotoptions
  • setShowSubSets() : ms_quant_method
  • setSigThreshold() : ms_mascotoptions
  • setSigThresholdValue() : ms_quant_method
  • setSimpleRatio() : ms_quant_integration
  • setSingleHit() : ms_mascotresults_params
  • setSinglyCharged() : ms_fragmentationrules
  • setSite() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • setSiteAnalysisMD10Prob() : ms_mascotoptions
  • setSortUnassigned() : ms_mascotoptions
  • setSource() : ms_quant_integration, ms_umod_xref
  • setSpecGroup() : ms_umod_specificity
  • setSpeciesFormatRegex() : ms_taxonomyrules
  • setSpectraPerLibraryBlock() : ms_mascotoptions
  • setSpectrumViewerColourSchemeString() : ms_mascotoptions
  • setSpectrumViewerDefaultColourSchemeName() : ms_mascotoptions
  • setSplitDataFileSize() : ms_mascotoptions
  • setSplitNumberOfQueries() : ms_mascotoptions
  • setSrcDatabaseRule() : ms_taxonomyrules
  • setStoreModPermutations() : ms_mascotoptions
  • setStrategy() : ms_crosslinking_method
  • setStrRule() : ms_taxonomyrules
  • setSubsetsThreshold() : ms_mascotresults
  • setSummedModsStr() : ms_peptide
  • setSVGSpectrumSwitch() : ms_mascotoptions
  • setSymbol() : ms_quant_element, ms_umod_elemref
  • setTargetFDR() : ms_mascotresults_params
  • setTargetFDRPercentage() : ms_mascotoptions
  • setTargetFDRType() : ms_mascotresults_params
  • setTaxBrowserUrl() : ms_mascotoptions
  • setTaxonomyParseRuleIndex() : ms_databaseoptions
  • setTaxonomyRules() : ms_datfile
  • setTestDirectory() : ms_mascotoptions
  • setText() : ms_umod_xref
  • setThreeLetter() : ms_umod_aminoacid
  • setTimeAlignmentAlgorithm() : ms_quant_replicate
  • setTimeAlignmentData() : ms_ms1quantitation
  • setTitle() : ms_enzyme, ms_fragmentationrules, ms_modification, ms_quant_localdef, ms_taxonomychoice, ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • setTitleSource() : ms_modification
  • setToleranceInDa() : ms_libraryoptions
  • setToleranceInPPM() : ms_libraryoptions
  • setTotalIntensity() : ms_quant_quality
  • setTotalIntensityThreshold() : ms_quant_quality
  • setType() : ms_quant_correction, ms_wwwentry
  • setUnigeneIndexFile() : ms_mascotresults_params
  • setUniGeneOptions() : ms_datfile
  • setUniqueJobStartNumber() : ms_mascotoptions
  • setUniquePepseq() : ms_quant_quality
  • setUnixDirPerm() : ms_mascotoptions
  • setUnixWebUserGroup() : ms_mascotoptions
  • setUrl() : ms_umod_xref
  • setUseHTTPProxyForFTP() : ms_connection_settings, ms_mascotoptions
  • setUseHTTPProxyForHTTPS() : ms_connection_settings, ms_mascotoptions
  • setUsePeptideSummary() : ms_mascotresults_params
  • setUserAgent() : ms_connection_settings
  • setUsernameOfPoster() : ms_umod_modification
  • setUserType() : ms_user
  • setUseSessionCookies() : ms_security_options
  • setVal() : ms_imputation_missing_val
  • setValue() : ms_crosslinking_accession, ms_crosslinking_monolink, ms_http_client_mime, ms_xml_parameter
  • setValueWithFilename() : ms_http_client_mime
  • setVarModsStr() : ms_peptide
  • setVerifySessionIPAddress() : ms_security_options
  • setVmemory() : ms_mascotoptions
  • setWWWOptions() : ms_datfile
  • setXicMaxWidth() : ms_quant_integration
  • setXicSmoothing() : ms_quant_integration
  • setXicThreshold() : ms_quant_integration
  • setXMLschemaFilePath() : ms_mascotresfilebase
  • sev_debug1 : ms_log
  • sev_debug2 : ms_log
  • sev_debug3 : ms_log
  • sev_fatal : ms_log
  • sev_info : ms_log
  • sev_warn : ms_log
  • severityAsText() : ms_loggingmonitor
  • SHOW_ALL : ms_http_client_session
  • SHOW_LENGTH : ms_http_client_session
  • SHOW_NONE : ms_http_client_session
  • SHOW_PI : ms_http_client_session
  • SHOW_REFERENCE : ms_http_client_session
  • SHOW_SEQUENCE : ms_http_client_session
  • SHOW_TITLE : ms_http_client_session
  • showInLongList() : ms_umod_specificity
  • showInShortList() : ms_umod_specificity
  • size() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • sizei() : ms_matrix
  • sizej() : ms_matrix
  • snedecorsCriticalValue() : ms_quant_stats
  • sortBy : ms_mascotresults
  • sortedMedian() : ms_quant_stats
  • sortModifications() : ms_modfile
  • sortPeptides() : ms_protein
  • sortUsers() : ms_security
  • Source_e : ms_loggingmonitor
  • SRC_ALL : ms_loggingmonitor
  • SRC_APPLICATION : ms_loggingmonitor
  • SRC_DENOVOLIB : ms_loggingmonitor
  • SRC_MASCOTSERVER : ms_loggingmonitor
  • SRC_MDRO : ms_loggingmonitor
  • SRC_MSPARSER : ms_loggingmonitor
  • SRC_MSQUANTLIB : ms_loggingmonitor
  • SRC_PURIFIERAPI : ms_loggingmonitor
  • SRC_PURIFIERAPP : ms_loggingmonitor
  • SRC_VENDORSTART : ms_loggingmonitor
  • SS_ASSIGNED : ms_http_client_search
  • SS_COMPLETE : ms_http_client_search
  • SS_ERROR : ms_http_client_search
  • SS_QUEUED : ms_http_client_search
  • SS_RUNNING : ms_http_client_search
  • SS_SEARCH_CONTROL_ERROR : ms_http_client_search
  • SS_UNKNOWN : ms_http_client_search
  • ST_TA_CALCULATED : ms_ms1quant_time_align
  • ST_TA_LOADED_FROM_CDB : ms_ms1quant_time_align
  • ST_TA_LOADED_FROM_XML : ms_ms1quant_time_align
  • ST_TA_NO_DATA : ms_ms1quant_time_align
  • startIteratePeptides() : ms_aahelper
  • staticGetPercolatorFileNames() : ms_mascotresfilebase
  • STATUS : ms_progress_info
  • status_t : ms_ms1quant_time_align
  • stopIteratePeptides() : ms_aahelper
  • stripLastFolder() : ms_fileutilities
  • studentsCriticalValue() : ms_quant_stats
  • submitSearch() : ms_http_client_session
  • subproject() : ms_imputation_peptide_data
  • sum() : ms_quant_stats
  • sumsq() : ms_quant_stats
  • swap() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • swilk() : ms_shapiro_wilk
  • systemError() : ms_http_helper_return
  • systemids : ms_group, ms_user
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TASKID : ms_security_tasks
  • TAX_CHOP_PREFIX : ms_parserule_plus
  • TAX_CHOP_SRC : ms_parserule_plus
  • TAX_CHOP_SUFFIX : ms_parserule_plus
  • TAX_CHOP_TYPES : ms_parserule_plus
  • TAX_CHOP_WORDS : ms_parserule_plus
  • TCD_ABS_CORRELATION : ms_treecluster
  • TCD_ABS_UNCENTERED_CORRELATION : ms_treecluster
  • TCD_CITY_BLOCK : ms_treecluster
  • TCD_CORRELATION : ms_treecluster
  • TCD_EUCLIDEAN : ms_treecluster
  • TCD_KENDALLS_TAU_CORRELATION : ms_treecluster
  • TCD_SPEARMANS_RANK_CORRELATION : ms_treecluster
  • TCD_UNCENTERED_CORRELATION : ms_treecluster
  • TCM_PAIRWISE_AVERAGE : ms_mascotresults
  • TCM_PAIRWISE_MAXIMUM : ms_mascotresults
  • TCM_PAIRWISE_SINGLE : ms_mascotresults
  • testDixonsN9() : ms_quant_stats
  • testGrubbsN2() : ms_quant_stats
  • testRosners() : ms_quant_stats
  • testShapiroWilkW() : ms_quant_stats
  • THRESHOLD_TYPE : ms_mascotresults
  • TOLERANCE_DALTON : ms_fragmentvector
  • TOLERANCE_MMU : ms_fragmentvector
  • TOLERANCE_PERCENT : ms_fragmentvector
  • TOLERANCE_PPM : ms_fragmentvector
  • TOLERANCE_UNIT : ms_fragmentvector
  • toVector() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • transpose() : ms_matrix
  • TREE_CLUSTER_DISTANCE : ms_treecluster
  • TREE_CLUSTER_METHOD : ms_mascotresults
  • TT_HOMOLOGY : ms_mascotresults
  • TT_IDENTITY : ms_mascotresults
  • TT_PEPSUM_DEFAULT : ms_mascotresults
  • TYPE_ALL_USERS_ARRAY : ms_security_task
  • TYPE_BOOL : ms_security_task
  • TYPE_DOUBLE_ARRAY : ms_security_task
  • TYPE_EQ_DOUBLE : ms_security_task
  • TYPE_EQ_LONG : ms_security_task
  • TYPE_EQ_STRING : ms_security_task
  • TYPE_GTE_DOUBLE : ms_security_task
  • TYPE_GTE_LONG : ms_security_task
  • TYPE_LONG_ARRAY : ms_security_task
  • TYPE_LTE_DOUBLE : ms_security_task
  • TYPE_LTE_LONG : ms_security_task
  • TYPE_STRING_ARRAY : ms_security_task
  • TYPE_USERS_ARRAY : ms_security_task
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • uncommentProp() : ms_customproperty
  • UNDEFINED_CUTTER : ms_enzyme
  • UNIQUE_PEP_RULES : ms_mascotresults
  • unsortedMedian() : ms_quant_stats
  • unspecifiedError() : ms_http_helper_return
  • update() : ms_session
  • updateAccessionByNumber() : ms_crosslinking_accessions
  • updateAllSessionFiles() : ms_security
  • updateAltName() : ms_umod_modification
  • updateAminoAcidByName() : ms_umod_configfile
  • updateAminoAcidByNumber() : ms_umod_configfile
  • updateBreak() : ms_progress_info
  • updateComplete() : ms_progress_info
  • updateComponentByName() : ms_quant_method
  • updateComponentByNumber() : ms_quant_method
  • updateCorrection() : ms_quant_component
  • updateDatabaseByName() : ms_databases
  • updateDatabaseByNumber() : ms_databases
  • updateDenominatorByName() : ms_quant_ratio
  • updateDenominatorByNumber() : ms_quant_ratio
  • updateDoesNotPairWithByNumber() : ms_crosslinking_linker
  • updateElement() : ms_quant_composition
  • updateElementByName() : ms_umod_configfile
  • updateElementByNumber() : ms_umod_configfile
  • updateElemRef() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • updateEnzymeByName() : ms_enzymefile
  • updateEnzymeByNumber() : ms_enzymefile
  • updateExclusion() : ms_quant_method
  • updateFail() : ms_progress_info
  • updateFileIndex() : ms_quant_component
  • updateForInstaller() : ms_datfile
  • updateGroup() : ms_security
  • updateIgnore() : ms_quant_localdef, ms_umod_modification
  • updateIndeterminate() : ms_progress_info
  • updateInstrumentByName() : ms_fragrulesfile
  • updateInstrumentByNumber() : ms_fragrulesfile
  • updateIonSeries() : ms_quant_multiplex
  • updateIsotope() : ms_quant_component
  • updateLinkerByNumber() : ms_crosslinking_linkers
  • updateLocalDefinition() : ms_quant_modgroup
  • updateMasses() : ms_umod_composition, ms_umod_configfile, ms_umod_modification
  • updateMethodByName() : ms_crosslinking_configfile, ms_quant_configfile
  • updateMethodByNumber() : ms_crosslinking_configfile, ms_quant_configfile
  • updateModBrickByName() : ms_umod_configfile
  • updateModBrickByNumber() : ms_umod_configfile
  • updateModificationByName() : ms_modfile, ms_umod_configfile
  • updateModificationByNumber() : ms_modfile, ms_umod_configfile
  • updateModificationGroupByName() : ms_quant_component, ms_quant_method
  • updateModificationGroupByNumber() : ms_quant_component, ms_quant_method
  • updateMonoLinkByNumber() : ms_crosslinking_linker
  • updateNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • updateNumeratorByName() : ms_quant_ratio
  • updateNumeratorByNumber() : ms_quant_ratio
  • updateParameterByName() : ms_crosslinking_parameters, ms_quant_parameters
  • updateParameterByNumber() : ms_crosslinking_parameters, ms_quant_parameters
  • updatePassword() : ms_security
  • updatePepNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • updatePeptide() : ms_quant_normalisation_peptides
  • updateProgress() : ms_progress_info
  • updateProtein() : ms_quant_normalisation_proteins
  • updateReportRatioByName() : ms_quant_method
  • updateReportRatioByNumber() : ms_quant_method
  • updateSeq() : ms_quant_method
  • updateSpecificity() : ms_quant_localdef, ms_umod_modification
  • updateTask() : ms_security_tasks
  • updateUnmodified() : ms_quant_modgroup
  • updateUser() : ms_security
  • updateXref() : ms_umod_modification
  • uploadDistillerXmlResultsFile() : ms_http_client_search
  • UploadResponseCode : ms_http_client_search
  • UPR_DEFAULT : ms_mascotresults
  • UPR_IGNORE_SUBSET_PROTEINS : ms_mascotresults
  • UPR_WITHIN_FAMILY : ms_mascotresults
  • UPR_WITHIN_FAMILY_MEMBER : ms_mascotresults
  • UR_ACCESS_DENIED : ms_http_client_search
  • UR_ERROR : ms_http_client_search
  • UR_FILE_ALREADY_EXISTS : ms_http_client_search
  • UR_INVALID_TASKID : ms_http_client_search
  • UR_NO_RESULT_FILE : ms_http_client_search
  • UR_NO_RESULT_FILENAME : ms_http_client_search
  • UR_SUCCESS : ms_http_client_search
  • useInErrorTolerant() : ms_umod_specificity
  • USER_AGENT_STRING : ms_user
  • USER_COMPUTER_NAME : ms_user
  • USER_INTEGRA : ms_user
  • USER_IP_ADDRESS : ms_user
  • USER_NORMAL : ms_user
  • USER_SECURITY_DISABLED : ms_user
  • USER_WEBAUTH : ms_user
  • USERID_ADMINISTRATOR : ms_user
  • USERID_CMDLINE : ms_user
  • USERID_DAEMON : ms_user
  • USERID_GUEST : ms_user
  • USERID_INTEGRA_SYSTEM : ms_user
  • USERID_LAST : ms_user
  • USERID_PUBLIC_SEARCHES : ms_user
  • USERID_SECURITY_DISABLED : ms_user
  • USERID_SORTBY : ms_security
  • USERID_SORTBY_FULLNAME : ms_security
  • USERID_SORTBY_ID : ms_security
  • USERID_SORTBY_LOGINNAME : ms_security
  • userLogin() : ms_http_client
  • usertype : ms_user
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • validateDeep() : ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_does_not_pair_with, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_xml_parameter, ms_xml_parameters
  • validateDocument() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • validatePassword() : ms_user
  • validateShallow() : ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_does_not_pair_with, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_xml_parameter, ms_xml_parameters
  • verifyEnzyme() : ms_enzyme
  • verifyRule() : ms_fragmentationrules
  • verifyThatModsAreInUnimod() : ms_spectral_lib_file
  • versionGreaterOrEqual() : ms_mascotresfilebase
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • weightedArithmeticMean() : ms_quant_stats
  • weightedArithmeticStandardDeviation() : ms_quant_stats
  • weightedArithmeticStandardError() : ms_quant_stats
  • weightedGeometricMean() : ms_quant_stats
  • weightedGeometricStandardDeviation() : ms_quant_stats
  • WHAT_TO_ANNOTATE : ms_spectral_lib_entry
  • willCreateCache() : ms_mascotresfilebase, ms_peptidesummary
  • willMessageBeLogged() : ms_errs, ms_log
  • WST : ms_datfile
  • WST_APACHE : ms_datfile
  • WST_IIS : ms_datfile
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • XML_SCHEMA : ms_mascotresfilebase
  • XML_SCHEMA_CROSSLINKING : ms_mascotresfilebase
  • XML_SCHEMA_DIRECTORY : ms_mascotresfilebase
  • XML_SCHEMA_LAST : ms_mascotresfilebase
  • XML_SCHEMA_QUANTITATION : ms_mascotresfilebase
  • XML_SCHEMA_UNIMOD : ms_mascotresfilebase
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~ms_aahelper() : ms_aahelper
  • ~ms_buffer_logger() : ms_buffer_logger
  • ~ms_clusterparams() : ms_clusterparams
  • ~ms_computeraddress() : ms_computeraddress
  • ~ms_connection_settings() : ms_connection_settings
  • ~ms_cronjob() : ms_cronjob
  • ~ms_cronoptions() : ms_cronoptions
  • ~ms_crosslinking_accession() : ms_crosslinking_accession
  • ~ms_crosslinking_accessions() : ms_crosslinking_accessions
  • ~ms_crosslinking_configfile() : ms_crosslinking_configfile
  • ~ms_crosslinking_does_not_pair_with() : ms_crosslinking_does_not_pair_with
  • ~ms_crosslinking_filters() : ms_crosslinking_filters
  • ~ms_crosslinking_linker() : ms_crosslinking_linker
  • ~ms_crosslinking_linkers() : ms_crosslinking_linkers
  • ~ms_crosslinking_method() : ms_crosslinking_method
  • ~ms_crosslinking_monolink() : ms_crosslinking_monolink
  • ~ms_crosslinking_parameter() : ms_crosslinking_parameter
  • ~ms_crosslinking_parameters() : ms_crosslinking_parameters
  • ~ms_crosslinking_scope() : ms_crosslinking_scope
  • ~ms_crosslinking_settings() : ms_crosslinking_settings
  • ~ms_customproperty() : ms_customproperty
  • ~ms_customquantitation() : ms_customquantitation
  • ~ms_databaseoptions() : ms_databaseoptions
  • ~ms_databases() : ms_databases
  • ~ms_datfile() : ms_datfile
  • ~ms_dbprocessors() : ms_dbprocessors
  • ~ms_enzyme() : ms_enzyme
  • ~ms_enzymefile() : ms_enzymefile
  • ~ms_errors() : ms_errors
  • ~ms_errs() : ms_errs
  • ~ms_file_logger() : ms_file_logger
  • ~ms_fragmentationrules() : ms_fragmentationrules
  • ~ms_fragmentvector() : ms_fragmentvector
  • ~ms_fragrulesfile() : ms_fragrulesfile
  • ~ms_http_client() : ms_http_client
  • ~ms_http_client_mime() : ms_http_client_mime
  • ~ms_http_client_search() : ms_http_client_search
  • ~ms_http_client_session() : ms_http_client_session
  • ~ms_http_helper() : ms_http_helper
  • ~ms_http_helper_handles() : ms_http_helper_handles
  • ~ms_http_helper_progress() : ms_http_helper_progress
  • ~ms_imputation() : ms_imputation
  • ~ms_libraryoptions() : ms_libraryoptions
  • ~ms_license() : ms_license
  • ~ms_linker_site() : ms_linker_site
  • ~ms_linker_site_vector() : ms_linker_site_vector
  • ~ms_log() : ms_log
  • ~ms_logger() : ms_logger
  • ~ms_loggingmonitor() : ms_loggingmonitor
  • ~ms_mascotfiles() : ms_mascotfiles
  • ~ms_mascotoptions() : ms_mascotoptions
  • ~ms_masses() : ms_masses
  • ~ms_modfile() : ms_modfile
  • ~ms_modification() : ms_modification
  • ~ms_modvector() : ms_modvector
  • ~ms_ms2quantitation() : ms_ms2quantitation
  • ~ms_obofile() : ms_obofile
  • ~ms_parseoptions() : ms_parseoptions
  • ~ms_parserule() : ms_parserule
  • ~ms_parserule_plus() : ms_parserule_plus
  • ~ms_peptide() : ms_peptide
  • ~ms_peptide_quant_key() : ms_peptide_quant_key
  • ~ms_peptide_quant_key_vector() : ms_peptide_quant_key_vector
  • ~ms_peptide_quant_ratio() : ms_peptide_quant_ratio
  • ~ms_processoroptions() : ms_processoroptions
  • ~ms_processors() : ms_processors
  • ~ms_progress_info() : ms_progress_info
  • ~ms_protein() : ms_protein
  • ~ms_protein_quant_ratio() : ms_protein_quant_ratio
  • ~ms_quant_average() : ms_quant_average
  • ~ms_quant_component() : ms_quant_component
  • ~ms_quant_composition() : ms_quant_composition
  • ~ms_quant_configfile() : ms_quant_configfile
  • ~ms_quant_correction() : ms_quant_correction
  • ~ms_quant_element() : ms_quant_element
  • ~ms_quant_file_index() : ms_quant_file_index
  • ~ms_quant_helper() : ms_quant_helper
  • ~ms_quant_integration() : ms_quant_integration
  • ~ms_quant_isotope() : ms_quant_isotope
  • ~ms_quant_localdef() : ms_quant_localdef
  • ~ms_quant_method() : ms_quant_method
  • ~ms_quant_modgroup() : ms_quant_modgroup
  • ~ms_quant_moverz() : ms_quant_moverz
  • ~ms_quant_multiplex() : ms_quant_multiplex
  • ~ms_quant_neutralloss() : ms_quant_neutralloss
  • ~ms_quant_normalisation() : ms_quant_normalisation
  • ~ms_quant_normalisation_peptide() : ms_quant_normalisation_peptide
  • ~ms_quant_normalisation_peptides() : ms_quant_normalisation_peptides
  • ~ms_quant_normalisation_protein() : ms_quant_normalisation_protein
  • ~ms_quant_normalisation_proteins() : ms_quant_normalisation_proteins
  • ~ms_quant_numerator() : ms_quant_numerator
  • ~ms_quant_outliers() : ms_quant_outliers
  • ~ms_quant_parameter() : ms_quant_parameter
  • ~ms_quant_parameters() : ms_quant_parameters
  • ~ms_quant_pepneutralloss() : ms_quant_pepneutralloss
  • ~ms_quant_precursor() : ms_quant_precursor
  • ~ms_quant_protocol() : ms_quant_protocol
  • ~ms_quant_quality() : ms_quant_quality
  • ~ms_quant_ratio() : ms_quant_ratio
  • ~ms_quant_replicate() : ms_quant_replicate
  • ~ms_quant_reporter() : ms_quant_reporter
  • ~ms_quant_satellite() : ms_quant_satellite
  • ~ms_quant_specificity() : ms_quant_specificity
  • ~ms_quant_unmodified() : ms_quant_unmodified
  • ~ms_quantitation() : ms_quantitation
  • ~ms_searchparams() : ms_searchparams
  • ~ms_security_task() : ms_security_task
  • ~ms_security_tasks() : ms_security_tasks
  • ~ms_spectral_lib_entry() : ms_spectral_lib_entry
  • ~ms_spectral_lib_file() : ms_spectral_lib_file
  • ~ms_spectral_lib_peak_list() : ms_spectral_lib_peak_list
  • ~ms_stdout_logger() : ms_stdout_logger
  • ~ms_taxnodesfiles() : ms_taxnodesfiles
  • ~ms_taxonomychoice() : ms_taxonomychoice
  • ~ms_taxonomyfile() : ms_taxonomyfile
  • ~ms_taxonomyrules() : ms_taxonomyrules
  • ~ms_taxonomytree() : ms_taxonomytree
  • ~ms_taxspeciesfiles() : ms_taxspeciesfiles
  • ~ms_tinycdb() : ms_tinycdb
  • ~ms_treecluster() : ms_treecluster
  • ~ms_umod_aminoacid() : ms_umod_aminoacid
  • ~ms_umod_composition() : ms_umod_composition
  • ~ms_umod_configfile() : ms_umod_configfile
  • ~ms_umod_element() : ms_umod_element
  • ~ms_umod_elemref() : ms_umod_elemref
  • ~ms_umod_modbrick() : ms_umod_modbrick
  • ~ms_umod_modification() : ms_umod_modification
  • ~ms_umod_neutralloss() : ms_umod_neutralloss
  • ~ms_umod_specificity() : ms_umod_specificity
  • ~ms_umod_xref() : ms_umod_xref
  • ~ms_unigene_entry() : ms_unigene_entry
  • ~ms_unigeneoptions() : ms_unigeneoptions
  • ~ms_wwwentry() : ms_wwwentry
  • ~ms_wwwoptions() : ms_wwwoptions
  • ~ms_xml_parameter() : ms_xml_parameter
  • ~ms_xml_parameters() : ms_xml_parameters
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- a -

  • abortedByUser() : ms_http_helper_return
  • addAccessionUnigenePair() : ms_unigene
  • addComponent() : ms_ms1quant_match
  • addCreatedComponent() : ms_ms1quant_match
  • addCutter() : ms_enzyme
  • addDoubleParam() : ms_security_task
  • addExperimentalData() : ms_fragmentvector
  • addHeaderField() : ms_quantitation
  • addLogEventsHandler() : ms_loggingmonitor
  • addLongParam() : ms_security_task
  • addMatchInferred() : ms_ms1quantitation
  • addMatchPeptide() : ms_ms1quantitation
  • addMatchStatus() : ms_ms1quantitation
  • addNewGroup() : ms_security
  • addNewUser() : ms_security
  • addPeaks() : ms_spectral_lib_peak_list
  • addPeptideQuantKey() : ms_customquantitation
  • addPeptideQuantKeys() : ms_customquantitation
  • addPeptideRatio() : ms_customquantitation
  • addPermittedTask() : ms_group
  • addRawFileField() : ms_quantitation
  • addStringParam() : ms_security_task
  • addSubtask() : ms_progress_info
  • addTask() : ms_security_tasks
  • addToCatalog() : ms_log
  • addUser() : ms_group
  • allComponentsIdentified() : ms_ms1quant_match
  • annotatePeaks() : ms_spectral_lib_entry, ms_spectral_lib_peak_list
  • anyBoldRedPeptides() : ms_protein
  • anyCrosslinkedMatches() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anyEmPAI() : ms_mascotresults, ms_peptidesummary
  • anyErrorTolerantMatches() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anyFastaMatches() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anyMatchToQuery() : ms_protein
  • anyMatchToQueryAndP() : ms_protein
  • anyMSMS() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anyNLseriesUsed() : ms_fragmentationrules
  • anyNumDiscoveredMods() : ms_mascotresults
  • anyPeptideSummaryMatches() : ms_mascotresfile_dat
  • anyPercolatorResults() : ms_peptide
  • anyPMF() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anySpectralLibraryMatches() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anySQ() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • anyTag() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • append() : ms_http_client_mime, ms_linker_site_vector, ms_peptide_quant_key_vector
  • appendAccession() : ms_crosslinking_accessions
  • appendAltName() : ms_umod_modification
  • appendAminoAcid() : ms_umod_configfile
  • appendComponent() : ms_quant_method
  • appendCorrection() : ms_quant_component
  • appendCronJob() : ms_cronoptions
  • appendDatabase() : ms_databases, ms_processoroptions
  • appendDenominator() : ms_quant_ratio
  • appendDoesNotPairWith() : ms_crosslinking_linker
  • appendElement() : ms_quant_composition, ms_umod_configfile
  • appendElemRef() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • appendEntry() : ms_taxonomyfile, ms_wwwoptions
  • appendEnzyme() : ms_enzymefile
  • appendErrors() : ms_errors, ms_errs
  • appendExcludeTaxonomy() : ms_taxonomychoice
  • appendExclusion() : ms_quant_method
  • appendFile() : ms_http_client_mime
  • appendFileIndex() : ms_quant_component
  • appendFragment() : ms_fragmentvector
  • appendGencodeFile() : ms_taxonomyrules
  • appendIgnore() : ms_quant_localdef, ms_umod_modification
  • appendIgnoreDupeAccession() : ms_mascotoptions
  • appendIgnoreMass() : ms_modification
  • appendIncludeTaxonomy() : ms_taxonomychoice
  • appendInstrument() : ms_fragrulesfile
  • appendIonSeries() : ms_quant_multiplex
  • appendIsotope() : ms_quant_component
  • appendLinker() : ms_crosslinking_linkers
  • appendLocalDefinition() : ms_quant_modgroup
  • appendMethod() : ms_crosslinking_configfile, ms_quant_configfile
  • appendModBrick() : ms_umod_configfile
  • appendModFile() : ms_quant_modgroup
  • appendModification() : ms_modfile, ms_modvector, ms_umod_configfile
  • appendModificationGroup() : ms_quant_component, ms_quant_method
  • appendModifications() : ms_modvector
  • appendModifiedResidue() : ms_modification
  • appendMonoLink() : ms_crosslinking_linker
  • appendNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • appendNoBreakDescLineIf() : ms_taxonomyrules
  • appendNodesFile() : ms_taxonomyrules
  • appendNumerator() : ms_quant_ratio
  • appendParameter() : ms_crosslinking_parameters, ms_quant_parameters
  • appendPepNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • appendPeptide() : ms_quant_normalisation_peptides
  • appendPerDbSrcRule() : ms_taxonomyrules
  • appendPrefixRemove() : ms_taxonomyrules
  • appendProcessor() : ms_processoroptions
  • appendProperty() : ms_customproperty
  • appendProtein() : ms_quant_normalisation_proteins
  • appendReportNumberChoice() : ms_mascotoptions
  • appendReportRatio() : ms_quant_method
  • appendResfile() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • appendSampleValue() : ms_shapiro_wilk
  • appendSeq() : ms_quant_method
  • appendSpeciesFile() : ms_taxonomyrules
  • appendSpecificity() : ms_quant_localdef, ms_umod_modification
  • appendStrFile() : ms_taxonomyrules
  • appendSubCluster() : ms_clusterparams
  • appendSuffixRemove() : ms_taxonomyrules
  • appendTargetFDRPercentage() : ms_mascotoptions
  • appendText() : ms_customproperty
  • appendThreadProcessorID() : ms_dbprocessors
  • appendUnmodified() : ms_quant_modgroup
  • appendXref() : ms_umod_modification
  • applyFixedMods() : ms_masses
  • applyIsotopes() : ms_masses
  • applyVisibility() : ms_umod_configfile
  • arithmeticMean() : ms_quant_stats
  • arithmeticStandardDeviation() : ms_quant_stats
  • arithmeticStandardErrorOfMean() : ms_quant_stats
  • arithmeticStandardErrorOfMedian() : ms_quant_stats
  • asText() : ms_spectral_lib_peak, ms_spectral_lib_peak_list
  • averageFindAverage() : ms_imputation_method
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- b -

  • baseUrl() : ms_http_client, ms_http_helper
  • binomialCoefficient() : ms_quant_stats
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- c -

  • calcFragments() : ms_aahelper
  • calcFragmentsEx() : ms_aahelper
  • calcPeptideMZ() : ms_aahelper
  • calculate() : ms_shapiro_wilk
  • calculateFromConsensuValues() : ms_ms1quant_time_align
  • calculateGeometricMeanRatio() : ms_quantitation
  • calculateMedianRatio() : ms_quantitation
  • calculateNormalMeanPvalue() : ms_quant_stats
  • calculateNormalMedianPvalue() : ms_quant_stats
  • calculateNormalWeightedPvalue() : ms_quant_stats
  • calculateWeightedGeometricMeanRatio() : ms_quantitation
  • cancelCreateSummary() : ms_mascotresults
  • canCleave() : ms_enzyme
  • canResultsFileBeViewed() : ms_session
  • changems_imputation_missing_valArrayToDoubleArray() : ms_imputation_method
  • changems_imputation_missing_valVecToDoubleVec() : ms_imputation_method
  • changePassword() : ms_http_client
  • checkSeqDBInstallRequest() : ms_datfile
  • chisqLowerCriticalValue() : ms_quant_stats
  • chisqUpperCriticalValue() : ms_quant_stats
  • clear() : ms_linker_site_vector, ms_peptide_quant_key_vector, ms_progress_info
  • clearAccessions() : ms_crosslinking_accessions
  • clearAllCutters() : ms_enzyme
  • clearAllErrors() : ms_errors, ms_errs
  • clearAltNames() : ms_umod_modification
  • clearAminoAcids() : ms_umod_configfile
  • clearAnnotation() : ms_spectral_lib_entry, ms_spectral_lib_peak, ms_spectral_lib_peak_list
  • clearComponents() : ms_quant_method
  • clearCorrections() : ms_quant_component
  • clearCronJobs() : ms_cronoptions
  • clearDatabases() : ms_databases, ms_processoroptions
  • clearDBLevelTaxId() : ms_taxonomyrules
  • clearDenominators() : ms_quant_ratio
  • clearDoesNotPairWiths() : ms_crosslinking_linker
  • clearElements() : ms_quant_composition, ms_umod_configfile
  • clearElemRefs() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • clearEntries() : ms_taxonomyfile, ms_wwwoptions
  • clearEnzymes() : ms_enzymefile
  • clearExcludeTaxonomies() : ms_taxonomychoice
  • clearExclusions() : ms_quant_method
  • clearFileIndexes() : ms_quant_component
  • clearFragments() : ms_fragmentvector
  • clearGencodeFiles() : ms_taxonomyrules
  • clearHeaderFields() : ms_quantitation
  • clearHitRatioExcluded() : ms_ms1quant_match
  • clearHitRatioOutlier() : ms_ms1quant_match
  • clearIgnoreDupeAccessions() : ms_mascotoptions
  • clearIgnoreMasses() : ms_modification
  • clearIgnores() : ms_quant_localdef, ms_umod_modification
  • clearIncludeTaxonomies() : ms_taxonomychoice
  • clearInstruments() : ms_fragrulesfile
  • clearIonSeries() : ms_quant_multiplex
  • clearIsotopes() : ms_quant_component
  • clearLinkers() : ms_crosslinking_linkers
  • clearLocalDefinitions() : ms_quant_modgroup
  • clearMatchedIon() : ms_fragment
  • clearMethods() : ms_crosslinking_configfile, ms_quant_configfile
  • clearModBricks() : ms_umod_configfile
  • clearModFiles() : ms_quant_modgroup
  • clearModificationGroups() : ms_quant_component, ms_quant_method
  • clearModifications() : ms_modfile, ms_modvector, ms_umod_configfile
  • clearModifiedResidues() : ms_modification
  • clearMonoLinks() : ms_crosslinking_linker
  • clearNeutralLosses() : ms_quant_specificity, ms_umod_specificity
  • clearNoBreakDescLineIf() : ms_taxonomyrules
  • clearNodesFiles() : ms_taxonomyrules
  • clearNumerators() : ms_quant_ratio
  • clearParam() : ms_group, ms_session, ms_user
  • clearParameters() : ms_crosslinking_parameters, ms_quant_parameters, ms_xml_parameters
  • clearParams() : ms_security_task
  • clearParseRules() : ms_parseoptions
  • clearPepNeutralLosses() : ms_quant_specificity, ms_umod_specificity
  • clearPeptideQuantKeys() : ms_customquantitation
  • clearPeptideRatios() : ms_customquantitation
  • clearPeptides() : ms_quant_normalisation_peptides
  • clearPerDbSrcRules() : ms_taxonomyrules
  • clearPrefixRemoves() : ms_taxonomyrules
  • clearProcessors() : ms_processoroptions
  • clearProteins() : ms_quant_normalisation_proteins
  • clearRawFileFields() : ms_quantitation
  • clearReloadableInfo() : ms_peptide
  • clearReportNumberChoices() : ms_mascotoptions
  • clearReportRatios() : ms_quant_method
  • clearSampleValues() : ms_shapiro_wilk
  • clearSeqs() : ms_quant_method
  • clearSeries() : ms_fragmentationrules
  • clearSpeciesFiles() : ms_taxonomyrules
  • clearSpecificities() : ms_quant_localdef, ms_umod_modification
  • clearSubClusters() : ms_clusterparams
  • clearSuffixRemoves() : ms_taxonomyrules
  • clearTargetFDRPercentages() : ms_mascotoptions
  • clearThreads() : ms_dbprocessors
  • clearUnmodified() : ms_quant_modgroup
  • clearXrefs() : ms_umod_modification
  • closeHandles() : ms_http_helper_handles
  • closeIndexFile() : ms_tinycdb
  • cluster() : ms_treecluster
  • columnMatrix() : ms_matrix
  • compareXmlFiles() : ms_fileutilities
  • compressMore() : ms_zip
  • connectionSettings() : ms_http_client, ms_http_helper
  • containsVarModIdx() : ms_linker_site_vector
  • convertFromLogLevel() : ms_errs
  • convertToLogLevel() : ms_errs
  • copyFrom() : ms_aahelper, ms_clusterparams, ms_computeraddress, ms_connection_settings, ms_cronjob, ms_cronoptions, ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_configfile, ms_crosslinking_does_not_pair_with, ms_crosslinking_filters, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_crosslinking_parameter, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_customproperty, ms_databaseoptions, ms_databases, ms_datfile, ms_dbprocessors, ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list, ms_enzyme, ms_enzymefile, ms_errors, ms_fragment, ms_fragmentationrules, ms_fragmentvector, ms_fragrulesfile, ms_http_client, ms_http_client_search, ms_http_client_session, ms_http_helper, ms_http_helper_progress, ms_libraryoptions, ms_license, ms_linker_site, ms_linker_site_vector, ms_mascotfiles, ms_mascotoptions, ms_mascotresults_params, ms_masses, ms_modfile, ms_modification, ms_modvector, ms_obofile, ms_parseoptions, ms_parserule, ms_parserule_plus, ms_peptide, ms_peptide_quant_key_vector, ms_peptide_quant_ratio, ms_processoroptions, ms_processors, ms_protein, ms_protein_quant_ratio, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_configfile, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_parameter, ms_quant_parameters, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_security_options, ms_spectral_lib_entry, ms_spectral_lib_peak, ms_spectral_lib_peak_list, ms_taxnodesfiles, ms_taxonomychoice, ms_taxonomyfile, ms_taxonomyrules, ms_taxonomytree, ms_taxspeciesfiles, ms_treecluster, ms_umod_aminoacid, ms_umod_composition, ms_umod_configfile, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_unigeneoptions, ms_wwwentry, ms_wwwoptions, ms_xic, ms_xml_parameter, ms_zip
  • copyMassFile() : ms_modification
  • countDistinctPeptides() : ms_ms1quantitation, ms_ms2quantitation, ms_quantitation
  • createCrosslinkedPeptide() : ms_aahelper
  • createDefaults() : ms_security
  • createDirectory() : ms_fileutilities
  • createMissingComponents() : ms_quant_helper
  • createPeptide() : ms_aahelper
  • createResfile() : ms_mascotresfilebase
  • createSummary() : ms_mascotresults, ms_peptidesummary
  • createUnassignedList() : ms_mascotresults
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- d -

  • data() : ms_matrix
  • decompressMore() : ms_zip
  • defaultValues() : ms_aahelper, ms_clusterparams, ms_computeraddress, ms_connection_settings, ms_cronjob, ms_cronoptions, ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_configfile, ms_crosslinking_does_not_pair_with, ms_crosslinking_filters, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_crosslinking_parameter, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_customproperty, ms_databaseoptions, ms_databases, ms_datfile, ms_dbprocessors, ms_enzyme, ms_enzymefile, ms_fragmentationrules, ms_fragrulesfile, ms_libraryoptions, ms_license, ms_mascotfiles, ms_mascotoptions, ms_masses, ms_modfile, ms_modification, ms_obofile, ms_parseoptions, ms_parserule, ms_parserule_plus, ms_processoroptions, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_configfile, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_parameters, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_taxnodesfiles, ms_taxonomychoice, ms_taxonomyfile, ms_taxonomyrules, ms_taxspeciesfiles, ms_treecluster, ms_umod_aminoacid, ms_umod_composition, ms_umod_configfile, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_unigeneoptions, ms_wwwentry, ms_wwwoptions, ms_xic, ms_xml_parameter, ms_xml_parameters
  • deleteAccessionByNumber() : ms_crosslinking_accessions
  • deleteAltName() : ms_umod_modification
  • deleteAminoAcidByName() : ms_umod_configfile
  • deleteAminoAcidByNumber() : ms_umod_configfile
  • deleteComponentByName() : ms_quant_method
  • deleteComponentByNumber() : ms_quant_method
  • deleteCorrection() : ms_quant_component
  • deleteCronJob() : ms_cronoptions
  • deleteDatabaseByName() : ms_databases
  • deleteDatabaseByNumber() : ms_databases
  • deleteDenominatorByName() : ms_quant_ratio
  • deleteDenominatorByNumber() : ms_quant_ratio
  • deleteDirectory() : ms_fileutilities
  • deleteDoesNotPairWithByNumber() : ms_crosslinking_linker
  • deleteElement() : ms_quant_composition
  • deleteElementByName() : ms_umod_configfile
  • deleteElementByNumber() : ms_umod_configfile
  • deleteElemRef() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • deleteEnzymeByName() : ms_enzymefile
  • deleteEnzymeByNumber() : ms_enzymefile
  • deleteExclusion() : ms_quant_method
  • deleteFileIndex() : ms_quant_component
  • deleteGroup() : ms_security
  • deleteIgnore() : ms_quant_localdef, ms_umod_modification
  • deleteInstrumentByName() : ms_fragrulesfile
  • deleteInstrumentByNumber() : ms_fragrulesfile
  • deleteIonSeries() : ms_quant_multiplex
  • deleteIsotope() : ms_quant_component
  • deleteLinkerByNumber() : ms_crosslinking_linkers
  • deleteLocalDefinition() : ms_quant_modgroup
  • deleteMethodByName() : ms_crosslinking_configfile, ms_quant_configfile
  • deleteMethodByNumber() : ms_crosslinking_configfile, ms_quant_configfile
  • deleteModBrickByName() : ms_umod_configfile
  • deleteModBrickByNumber() : ms_umod_configfile
  • deleteModFile() : ms_quant_modgroup
  • deleteModificationByName() : ms_modfile, ms_umod_configfile
  • deleteModificationByNumber() : ms_modfile, ms_umod_configfile
  • deleteModificationGroupByName() : ms_quant_component, ms_quant_method
  • deleteModificationGroupByNumber() : ms_quant_component, ms_quant_method
  • deleteMonoLinkByNumber() : ms_crosslinking_linker
  • deleteNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • deleteNumeratorByName() : ms_quant_ratio
  • deleteNumeratorByNumber() : ms_quant_ratio
  • deleteParameterByName() : ms_crosslinking_parameters, ms_quant_parameters, ms_xml_parameters
  • deleteParameterByNumber() : ms_crosslinking_parameters, ms_quant_parameters, ms_xml_parameters
  • deletePepNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • deletePeptide() : ms_quant_normalisation_peptides
  • deleteProtein() : ms_quant_normalisation_proteins
  • deleteReportRatioByName() : ms_quant_method
  • deleteReportRatioByNumber() : ms_quant_method
  • deleteSeq() : ms_quant_method
  • deleteSpecificity() : ms_quant_localdef, ms_umod_modification
  • deleteUnmodified() : ms_quant_modgroup
  • deleteUser() : ms_group, ms_security
  • deleteXref() : ms_umod_modification
  • delNonEmpty() : ms_customproperty
  • delProp() : ms_customproperty
  • delPropByNumber() : ms_customproperty
  • delPropStart() : ms_customproperty
  • destroy() : ms_session
  • detectOutliers() : ms_quant_stats
  • diagonalMatrix() : ms_matrix
  • doesFileExist() : ms_fileutilities
  • doesSectionExist() : ms_mascotresfile_dat
  • downloadDaemonResultsFile() : ms_http_client_search
  • downloadPercolatorFile() : ms_http_client_search
  • downloadResultsFile() : ms_http_client_search
  • downloadResultsFileMSR() : ms_http_client_search
  • downloadXmlResultsFile() : ms_http_client_search
  • dropAccession() : ms_quant_normalisation_protein
  • dropAccessions() : ms_crosslinking_method
  • dropAllChargeStates() : ms_quant_integration, ms_quant_precursor
  • dropAllChargeStatesThreshold() : ms_quant_integration
  • dropAllowElutionShift() : ms_quant_integration, ms_quant_precursor
  • dropAllowMassTimeMatch() : ms_quant_precursor
  • dropApproved() : ms_umod_modification
  • dropAverage() : ms_quant_moverz
  • dropAvgeMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • dropClassification() : ms_umod_specificity
  • dropCode() : ms_umod_neutralloss
  • dropCoefficient() : ms_quant_numerator
  • dropComp() : ms_quant_method
  • dropCompositionString() : ms_umod_composition
  • dropConstrainSearch() : ms_quant_method
  • dropDatabaseName() : ms_crosslinking_accession
  • dropDateTimeModified() : ms_umod_modification
  • dropDateTimePosted() : ms_umod_modification
  • dropDelta() : ms_quant_localdef, ms_umod_modification
  • dropDescription() : ms_crosslinking_method, ms_quant_method, ms_umod_neutralloss, ms_xml_parameter
  • dropElement() : ms_quant_correction
  • dropElutionProfileCorrelationThreshold() : ms_quant_integration
  • dropElutionTimeDelta() : ms_quant_integration
  • dropElutionTimeDeltaUnit() : ms_quant_integration
  • dropEntry() : ms_wwwoptions
  • dropExcludeInternalLabel() : ms_quant_multiplex
  • dropExcludeIsobaricFragments() : ms_quant_multiplex
  • dropFileIndex() : ms_quant_component
  • dropFilters() : ms_crosslinking_method
  • dropFlag() : ms_quant_neutralloss, ms_umod_neutralloss
  • dropFraction() : ms_quant_file_index
  • dropFullName() : ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • dropGroupOfPoster() : ms_umod_modification
  • dropHidden() : ms_umod_specificity
  • dropIntegration() : ms_quant_method
  • dropIonIntensityThreshold() : ms_quant_multiplex
  • dropIonSeries() : ms_quant_multiplex
  • dropIsolatedPrecursor() : ms_quant_quality
  • dropIsolatedPrecursorThreshold() : ms_quant_quality
  • dropLinkers() : ms_crosslinking_method
  • dropMassDelta() : ms_quant_integration
  • dropMassDeltaUnit() : ms_quant_integration
  • dropMatchedRho() : ms_quant_integration
  • dropMethod() : ms_quant_integration, ms_quant_normalisation, ms_quant_outliers
  • dropMinimumA1() : ms_quant_quality
  • dropMinIonPairs() : ms_quant_multiplex
  • dropMinNumPeptides() : ms_quant_method
  • dropMinPrecursorCharge() : ms_quant_quality
  • dropMiscNotes() : ms_umod_modification, ms_umod_specificity
  • dropMode() : ms_quant_modgroup
  • dropModFileName() : ms_crosslinking_does_not_pair_with, ms_crosslinking_linker
  • dropModifications() : ms_quant_satellite
  • dropMonoisotopic() : ms_quant_moverz
  • dropMonoMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • dropMoverz() : ms_quant_component
  • dropName() : ms_crosslinking_method, ms_quant_component, ms_quant_method, ms_quant_modgroup, ms_quant_numerator, ms_quant_ratio, ms_xml_parameter
  • dropNew() : ms_quant_isotope
  • dropNormalisation() : ms_quant_method
  • dropNumber() : ms_quant_element, ms_umod_elemref
  • dropNumPeptides() : ms_quant_average
  • dropOld() : ms_quant_isotope
  • dropOutliers() : ms_quant_method
  • dropPairsWith() : ms_umod_neutralloss
  • dropParseRule() : ms_parseoptions
  • dropPepThresholdType() : ms_quant_quality
  • dropPepThresholdValue() : ms_quant_quality
  • dropPeptides() : ms_quant_normalisation
  • dropPosition() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • dropPrecursorRange() : ms_quant_integration
  • dropProcessingOptions() : ms_quant_integration
  • dropProteinRatioType() : ms_quant_method
  • dropProteins() : ms_quant_normalisation
  • dropProtocol() : ms_quant_method
  • dropProtScoreType() : ms_quant_method
  • dropQuality() : ms_quant_method
  • dropRecordID() : ms_umod_modification
  • dropReferenceAccession() : ms_quant_average
  • dropReferenceAmount() : ms_quant_average
  • dropReferenceDatabase() : ms_quant_average
  • dropReportDetail() : ms_quant_method
  • dropReporterTol() : ms_quant_reporter
  • dropReporterTolUnit() : ms_quant_reporter
  • dropRequireBoldRed() : ms_quant_method
  • dropRequired() : ms_quant_modgroup, ms_quant_pepneutralloss
  • dropSatellite() : ms_quant_component
  • dropScope() : ms_crosslinking_method
  • dropSelection() : ms_quant_average
  • dropSequence() : ms_quant_normalisation_peptide
  • dropSettings() : ms_crosslinking_method
  • dropShift() : ms_quant_correction
  • dropShowSubSets() : ms_quant_method
  • dropSigThresholdValue() : ms_quant_method
  • dropSimpleRatio() : ms_quant_integration
  • dropSite() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • dropSource() : ms_quant_integration, ms_umod_xref
  • dropSpecGroup() : ms_umod_specificity
  • dropSpectralLibrary() : ms_libraryoptions
  • dropStrategy() : ms_crosslinking_method
  • dropSymbol() : ms_quant_element, ms_umod_elemref
  • dropText() : ms_umod_xref
  • dropThreeLetter() : ms_umod_aminoacid
  • dropTimeAlignmentAlgorithm() : ms_quant_replicate
  • dropTitle() : ms_quant_localdef, ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • dropTotalIntensity() : ms_quant_quality
  • dropTotalIntensityThreshold() : ms_quant_quality
  • dropType() : ms_quant_correction
  • dropUniquePepseq() : ms_quant_quality
  • dropUrl() : ms_umod_xref
  • dropUsernameOfPoster() : ms_umod_modification
  • dropValue() : ms_crosslinking_accession
  • dropXicMaxWidth() : ms_quant_integration
  • dropXicSmoothing() : ms_quant_integration
  • dropXicThreshold() : ms_quant_integration
  • dumpCDB() : ms_peptidesummary
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- e -

  • editedByDatabaseManager() : ms_datfile
  • empty() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • enumerateQuerySectionKeys() : ms_mascotresfile_dat
  • enumerateSectionKeys() : ms_mascotresfile_dat
  • erase() : ms_http_client_mime
  • excludeProteinPeptideRatioKeys() : ms_ms2quantitation
  • expTransform() : ms_quant_stats
  • extend() : ms_ms1quant_match_range
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- f -

  • findClose() : ms_fileutilities
  • findDatabase() : ms_databases
  • findEntries() : ms_spectral_lib_file
  • findEntry() : ms_unigene
  • findIDFromTagValue() : ms_obofile
  • findMascotDat() : ms_fileutilities
  • findMatch() : ms_ms1quantitation
  • findModFile() : ms_quant_modgroup
  • findModFileName() : ms_umod_configfile
  • findModification() : ms_umod_configfile
  • findNext() : ms_fileutilities
  • findOpen() : ms_fileutilities
  • findPeptides() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • findPeptideStatus() : ms_ms1quantitation
  • findProperty() : ms_customproperty
  • findPropertyBeginning() : ms_customproperty
  • findProteins() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • findProteinsByAccession() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • findProteinsByDescription() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • findSpecGroup() : ms_umod_modification
  • finishCreate() : ms_tinycdb
  • flush() : ms_buffer_logger
  • format() : ms_http_client_mime
  • formatHeader() : ms_http_client_mime
  • formatMessage() : ms_logger
  • forwardToParentInstance() : ms_errs
  • freeHit() : ms_mascotresults, ms_peptidesummary
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- g -

  • geometricMean() : ms_quant_stats
  • geometricStandardDeviation() : ms_quant_stats
  • get() : ms_linker_site_vector, ms_peptide_quant_key_vector, ms_spectral_lib_entry
  • get_ms_mascotresults_params() : ms_distiller_data, ms_mascotresfilebase
  • getA() : ms_fitexy_result
  • getAbsoluteValue() : ms_ms1quant_match_component
  • getAccession() : ms_protein, ms_protein_quant_ratio, ms_quant_normalisation_protein
  • getACCESSION() : ms_searchparams
  • getAccessionByNumber() : ms_crosslinking_accessions
  • getAccessionFromNumber() : ms_spectral_lib_file
  • getAccessionParseRuleIndex() : ms_databaseoptions
  • getAccessionRefParseRuleIndex() : ms_databaseoptions
  • getAccessions() : ms_crosslinking_method
  • getAccessionSchemaType() : ms_crosslinking_accessions, ms_quant_normalisation_protein
  • getAccessionsSchemaType() : ms_crosslinking_method
  • getAccFromSpeciesLine() : ms_taxonomyrules
  • getActiveKeys() : ms_protein_quant_ratio
  • getAlgorithmName() : ms_ms1quant_time_align
  • getAllChargeStatesSchemaType() : ms_quant_integration, ms_quant_precursor
  • getAllChargeStatesThreshold() : ms_quant_integration
  • getAllChargeStatesThresholdSchemaType() : ms_quant_integration
  • getAllCustomParamsForUser() : ms_security
  • getAllFamilyMembersWithThisPepMatch() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getAllGroupIDs() : ms_security
  • getAllMatchedIons() : ms_fragment
  • getAllMods() : ms_spectral_lib_file
  • getAllowElutionShiftSchemaType() : ms_quant_integration, ms_quant_precursor
  • getAllowMassTimeMatchSchemaType() : ms_quant_precursor
  • getAllParamsAsString() : ms_security_task
  • getAllProteinsWithThisPepMatch() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getAllUserIDs() : ms_group, ms_security
  • getAllUSERParams() : ms_searchparams
  • getAllValuesFromKey() : ms_tinycdb
  • getAlphaVarModsStrLength() : ms_linker_site_vector
  • getAltName() : ms_umod_modification
  • getAltNameSchemaType() : ms_umod_modification
  • getAmbiguityString() : ms_peptide
  • getAminoAcidByName() : ms_umod_configfile
  • getAminoAcidByNumber() : ms_umod_configfile
  • getAnnotation() : ms_spectral_lib_peak
  • getAnyMatch() : ms_peptide
  • getAnyProteinTermination() : ms_peptide
  • getApprovedSchemaType() : ms_umod_modification
  • getAutoDetectNumThreads() : ms_processors
  • getAvePeptideIdentityThreshold() : ms_mascotresults
  • getAverage() : ms_quant_moverz, ms_quant_protocol
  • getAverageCharge() : ms_inputquery
  • getAveragePeptideIntensity() : ms_ms1quantitation
  • getAverageResults() : ms_ms1quantitation
  • getAverageSchemaType() : ms_quant_moverz, ms_quant_protocol
  • getAverageValues() : ms_imputation_average_value
  • getAvgeMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • getAvgeMassAsNumber() : ms_umod_element
  • getAvgeMassSchemaType() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • getB() : ms_fitexy_result
  • getBetaVarModsStrLength() : ms_linker_site_vector
  • getBinSize() : ms_ms1quant_time_align
  • getBoolParam() : ms_session
  • getBucket() : ms_ms1quant_charge_state
  • getBucketWidth() : ms_ms1quant_charge_state
  • getCacheDirectory() : ms_mascotoptions, ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getCacheFileName() : ms_distiller_data_search
  • getCacheFilename() : ms_distiller_master_search
  • getCacheFileName() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getCacheFilename() : ms_peptidesummary
  • getCacheFileName() : ms_peptidesummary
  • getCacheStreamName() : ms_distiller_data_quant
  • getCarbonMass() : ms_masses, ms_searchparams
  • getCentroidWidth() : ms_mascotoptions
  • getCentroidWidthCount() : ms_mascotoptions
  • getCharge() : ms_fragment, ms_inputquery, ms_peptide, ms_peptide_quant_key
  • getCHARGE() : ms_searchparams
  • getCharge() : ms_spectral_lib_entry
  • getChargeState() : ms_ms1quant_match
  • getChargeStateData() : ms_ms1quant_match
  • getChargeType() : ms_ms1quant_match
  • getCheckNodesAliveFreq() : ms_clusterparams
  • getChecksum() : ms_spectral_lib_peak_list
  • getChecksumFromNumber() : ms_spectral_lib_file
  • getChi2() : ms_fitexy_result
  • getChopSource() : ms_parserule_plus
  • getChromosome() : ms_unigene_entry
  • getClassification() : ms_modification, ms_umod_specificity
  • getClassificationSchemaType() : ms_umod_specificity
  • getCLE() : ms_searchparams
  • getCleave() : ms_enzyme
  • getClusterParams() : ms_datfile
  • getCode() : ms_modification, ms_umod_neutralloss
  • getCodeFromXml() : ms_ms1quant_match, ms_ms1quant_match_ratio, ms_ms1quant_peptide_status, ms_xic
  • getCodeInfo() : ms_ms1quant_match_ratio
  • getCodeSchemaType() : ms_umod_neutralloss
  • getCoefficient() : ms_quant_numerator
  • getCoefficientSchemaType() : ms_quant_numerator
  • getColsToOutput() : ms_logger
  • getColumn() : ms_fragment
  • getCOM() : ms_searchparams
  • getCombinedLimits() : ms_ms1quant_time_align
  • getCombinedMaxBinNum() : ms_ms1quant_time_align_limits
  • getCombinedMaxRT() : ms_ms1quant_time_align_limits
  • getCombinedMinBinNum() : ms_ms1quant_time_align_limits
  • getCombinedMinRT() : ms_ms1quant_time_align_limits
  • getCombinedPeptideSummaryCacheStreamName() : ms_distiller_master_search
  • getCombinedReportRatio() : ms_ms2quantitation
  • getCombinedReportRatioNames() : ms_ms2quantitation
  • getCombineRepeats() : ms_errs
  • getCommandStr() : ms_cronjob
  • getComment() : ms_spectral_lib_entry
  • getCommentField() : ms_spectral_lib_entry
  • getComp() : ms_inputquery, ms_quant_method
  • getComponent() : ms_ms1quant_match, ms_ms1quant_match_component, ms_ms1quant_peptide_status, ms_protein
  • getComponentByName() : ms_quant_method
  • getComponentByNumber() : ms_quant_method
  • getComponentIntensities() : ms_ms2quantitation
  • getComponentIntensity() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getComponentProtein() : ms_mascotresults, ms_peptidesummary
  • getComponentSchemaType() : ms_quant_method
  • getComponentStr() : ms_peptide
  • getComponentString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getCompositionString() : ms_umod_composition
  • getCompositionStringSchemaType() : ms_umod_composition
  • getCompressToolAA() : ms_mascotoptions
  • getCompressToolCommandLineFasta() : ms_mascotoptions
  • getCompressToolCommandLineLibrary() : ms_mascotoptions
  • getCompressToolNA() : ms_mascotoptions
  • getCompressToolSL() : ms_mascotoptions
  • getCompSchemaType() : ms_quant_method
  • getConciseLabelFreeVarMods() : ms_ms1quant_match
  • getConnectionSettings() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile, ms_masses, ms_modfile, ms_quant_configfile, ms_taxonomyfile, ms_umod_configfile
  • getConnectionTimeout() : ms_connection_settings
  • getConsensusData() : ms_spectral_lib_peak
  • getConstantName() : ms_security_task
  • getConstrainSearchSchemaType() : ms_quant_method
  • getContent() : ms_quant_correction, ms_quant_file_index, ms_quant_numerator, ms_quant_unmodified
  • getContentSchemaType() : ms_quant_correction, ms_quant_file_index, ms_quant_numerator, ms_quant_unmodified
  • getCoreFromLogical() : ms_processors
  • getCorrectedMaxSPPwidth() : ms_ms1quant_charge_state
  • getCorrectedMinSPPwidth() : ms_ms1quant_charge_state
  • getCorrectedSPPwidth() : ms_ms1quant_charge_state
  • getCorrection() : ms_quant_component
  • getCorrectionMatrix() : ms_ms1quant_match
  • getCorrectionSchemaType() : ms_quant_component
  • getCount() : ms_http_client_mime
  • getCoverage() : ms_protein
  • getCR() : ms_matrix
  • getCrawlerNumPeaksPer100Da() : ms_mascotoptions
  • getCreatePipThreadBlockSize() : ms_mascotoptions
  • getCreatePipThreads() : ms_mascotoptions
  • getCreateSummaryProgress() : ms_mascotresults
  • getCronJob() : ms_cronoptions
  • getCronOptions() : ms_datfile
  • getCrosslinking() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getCROSSLINKING() : ms_searchparams
  • getCrosslinkingMethod() : ms_mascotresfilebase, ms_peptidesummary
  • getCtermDelta() : ms_masses
  • getCterminalMass() : ms_masses
  • getCTerminusMass() : ms_modification
  • getCTermMass() : ms_searchparams
  • getCtermNeutralLoss() : ms_masses
  • getCurrentBytes() : ms_http_helper_progress
  • getCurrentLineNumber() : ms_msr2dat28
  • getCutterType() : ms_enzyme
  • getCytoBand() : ms_unigene_entry
  • getDatabase() : ms_databases, ms_processoroptions
  • getDatabaseName() : ms_crosslinking_accession
  • getDatabaseNameSchemaType() : ms_crosslinking_accession
  • getDatabases() : ms_datfile
  • getDatabaseType() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getDataSourceId() : ms_ms1quant_match
  • getDATAURL() : ms_searchparams
  • getDataWithMissing() : ms_imputation_method
  • getDate() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getDateTimeModified() : ms_umod_modification
  • getDateTimeModifiedSchemaType() : ms_umod_modification
  • getDateTimePosted() : ms_umod_modification
  • getDateTimePostedSchemaType() : ms_umod_modification
  • getDatfile() : ms_distiller_data
  • getDB() : ms_protein, ms_protein_quant_ratio, ms_searchparams
  • getDBLevelTaxId() : ms_taxonomyrules
  • getDBType() : ms_databaseoptions
  • getDechargeFragmentPeaks() : ms_mascotoptions
  • getDECOY() : ms_searchparams
  • getDecoyTypeForDB() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getDecoyTypeNoEnzyme() : ms_mascotoptions
  • getDecoyTypeSpecific() : ms_mascotoptions
  • getDefaultDelimiter() : ms_customproperty
  • getDefaultMonitor() : ms_loggingmonitor
  • getDefaultNodeHomeDir() : ms_clusterparams
  • getDefaultNodeHomeDirFromMaster() : ms_clusterparams
  • getDefaultNodeOS() : ms_clusterparams
  • getDefaultPasswordExpiryTime() : ms_security_options
  • getDefaultPort() : ms_clusterparams
  • getDefaultRule() : ms_taxonomyrules
  • getDefaultSchemaFileName() : ms_crosslinking_configfile, ms_umod_configfile
  • getDelimiterByNumber() : ms_customproperty
  • getDelta() : ms_modification, ms_peptide, ms_quant_localdef, ms_spectral_lib_peak, ms_umod_modification
  • getDeltaSchemaType() : ms_quant_localdef, ms_umod_modification
  • getDenominatorByName() : ms_quant_ratio
  • getDenominatorByNumber() : ms_quant_ratio
  • getDenominatorSchemaType() : ms_quant_ratio
  • getDescription() : ms_crosslinking_method, ms_progress_info, ms_quant_method, ms_security_task, ms_umod_neutralloss, ms_xml_parameter
  • getDescriptionLineSep() : ms_taxonomyrules
  • getDescriptionParseRuleIndex() : ms_databaseoptions
  • getDescriptionSchemaType() : ms_crosslinking_method, ms_crosslinking_parameter, ms_quant_method, ms_quant_parameter, ms_umod_neutralloss, ms_xml_parameter
  • getDiffsAsText() : ms_security_tasks
  • getDiscoveredErrTolModDeltas() : ms_mascotresults
  • getDiscoveredErrTolModNames() : ms_mascotresults
  • getDiscoveredLocalModDeltas() : ms_mascotresults
  • getDiscoveredLocalModNames() : ms_mascotresults
  • getDisplayIntensity() : ms_ms1quant_match
  • getDisplayNonSignificantMatches() : ms_mascotoptions
  • getDistillerExperimentType() : ms_distiller_data
  • getDistillerProjectStreamName() : ms_distiller_data
  • getDistillerResfileTimestamp() : ms_distiller_data
  • getDistillerVersion() : ms_distiller_data
  • getDistinctPeptide() : ms_protein
  • getDistributor() : ms_license
  • getDoesNotPairWithByNumber() : ms_crosslinking_linker
  • getDoesNotPairWithSchemaType() : ms_crosslinking_linker
  • getDoThisRuleFirst() : ms_taxonomyrules
  • getDoubleParam() : ms_session
  • getDoubleParams() : ms_security_task
  • getElectronMass() : ms_masses, ms_searchparams
  • getElement() : ms_quant_composition, ms_quant_correction
  • getElementByName() : ms_umod_configfile
  • getElementByNumber() : ms_umod_configfile
  • getElementSchemaType() : ms_quant_composition, ms_quant_correction
  • getElemRef() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • getElemRefSchemaType() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • getElutionProfileCorrelationThreshold() : ms_quant_integration
  • getElutionProfileCorrelationThresholdSchemaType() : ms_quant_integration
  • getElutionTimeDelta() : ms_quant_integration
  • getElutionTimeDeltaSchemaType() : ms_quant_integration
  • getElutionTimeDeltaUnit() : ms_quant_integration
  • getElutionTimeDeltaUnitSchemaType() : ms_quant_integration
  • getElutionTimeShift() : ms_xic
  • getEmailAddress() : ms_session, ms_user
  • getEmailFromTextName() : ms_mascotoptions
  • getEmailFromUser() : ms_mascotoptions
  • getEmailPassword() : ms_mascotoptions
  • getEmailProfile() : ms_mascotoptions
  • getEmailService() : ms_mascotoptions
  • getEmailTimeOutPeriod() : ms_mascotoptions
  • getEncryptedPassword() : ms_user
  • getEnd() : ms_fragment
  • getEndDate() : ms_license
  • getEndIndex() : ms_xic
  • getEndScanId() : ms_xic
  • getEntry() : ms_wwwoptions
  • getEntryByName() : ms_taxonomyfile
  • getEntryByNumber() : ms_taxonomyfile
  • getEntryFromNumber() : ms_spectral_lib_file
  • getEntryFromNumberAsText() : ms_spectral_lib_file
  • getEnzyme() : ms_aahelper, ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getEnzymeByName() : ms_enzymefile
  • getEnzymeByNumber() : ms_enzymefile
  • getEnzymes() : ms_mascotfiles
  • getErrMessageEmailTo() : ms_mascotoptions
  • getError() : ms_distiller_search_status
  • getErrorCode() : ms_shapiro_wilk
  • getErrorHandler() : ms_errors
  • getErrorInfoAsString() : ms_mascotresfilebase
  • getErrorLevel() : ms_taxonomyrules
  • getErrorLogFile() : ms_mascotoptions
  • getErrorNumber() : ms_errs, ms_mascotresfilebase
  • getErrorRepeats() : ms_errs
  • getErrorSeverity() : ms_errs
  • getErrorString() : ms_errs, ms_mascotresfilebase
  • getErrorText() : ms_http_helper_return
  • getERRORTOLERANT() : ms_searchparams
  • getErrorType() : ms_http_helper_return
  • getErrTolMaxAccessions() : ms_mascotoptions
  • getErrTolModDelta() : ms_mascotresults
  • getErrTolModifiedNaSeq() : ms_mascotresults
  • getErrTolModMasterNeutralLoss() : ms_mascotresults
  • getErrTolModMasterString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getErrTolModName() : ms_mascotresults
  • getErrTolModNeutralLoss() : ms_mascotresults
  • getErrTolModPepNeutralLoss() : ms_mascotresults
  • getErrTolModPepString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getErrTolModReqPepNeutralLoss() : ms_mascotresults
  • getErrTolModReqPepString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getErrTolModSlaveNeutralLoss() : ms_mascotresults
  • getErrTolModSlaveString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getErrTolModString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getErrTolOriginalNaSeq() : ms_mascotresults
  • getErrTolParentFilename() : ms_searchparams
  • getErrTolPeptide() : ms_distiller_data_search
  • getErrTolProbabilityThreshold() : ms_mascotresults
  • getEstimatedFeatureWidth() : ms_ms1quant_time_align
  • getEvaluation() : ms_ms1quant_time_align
  • getExcludedKeys() : ms_protein_quant_ratio
  • getExcludeInternalLabelSchemaType() : ms_quant_multiplex
  • getExcludeIsobaricFragmentsSchemaType() : ms_quant_multiplex
  • getExcludeTaxonomy() : ms_taxonomychoice
  • getExclusion() : ms_quant_method
  • getExclusionSchemaType() : ms_quant_method
  • getExecAfterSearch() : ms_mascotoptions
  • getExecTime() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getExpectationValue() : ms_peptide
  • getExpress() : ms_unigene_entry
  • getFastaPath() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getFastaVer() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getFDRCountType() : ms_distiller_data_search
  • getFeatures() : ms_license
  • getFeatureTableLength() : ms_mascotoptions
  • getFeatureTableMinScore() : ms_mascotoptions
  • getFeatureWidths() : ms_ms1quant_time_align
  • getFileIndex() : ms_ms1quant_match_component, ms_quant_component
  • getFileIndexSchemaType() : ms_quant_component
  • getFileName() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile
  • getFilename() : ms_http_client_mime
  • getFileName() : ms_license, ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase, ms_masses, ms_modfile, ms_quant_configfile
  • getFILENAME() : ms_searchparams
  • getFileName() : ms_spectral_lib_entry, ms_spectral_lib_file, ms_taxnodesfiles, ms_taxonomyfile, ms_taxspeciesfiles, ms_umod_configfile
  • getFileOffset() : ms_unigene_entry
  • getFileOffsetFromKey() : ms_tinycdb
  • getFileSize() : ms_fileutilities
  • getFileTypeToSearch() : ms_parserule_plus
  • getFilters() : ms_crosslinking_method
  • getFiltersSchemaType() : ms_crosslinking_method
  • getFinalResults() : ms_ms1quant_time_align
  • getFindFileTimeout() : ms_datfile
  • getFirstPassThreshold() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getFirstProtAppearedIn() : ms_peptide
  • getFirstSerie() : ms_fragmentationrules
  • getFirstSeries() : ms_fragmentationrules
  • getFirstXicScanId() : ms_ms1quant_match
  • getFitexy() : ms_ms1quant_match_ratio
  • getFixedMods() : ms_aahelper
  • getFixedModsDelta() : ms_searchparams
  • getFixedModsName() : ms_searchparams
  • getFixedModsNeutralLoss() : ms_searchparams
  • getFixedModsResidues() : ms_searchparams
  • getFixedValue() : ms_imputation_fixed_value
  • getFlags() : ms_mascotresults, ms_mascotresults_params
  • getFlags2() : ms_mascotresults, ms_mascotresults_params
  • getFlagSchemaType() : ms_quant_neutralloss, ms_umod_neutralloss
  • getFORMAT() : ms_searchparams
  • getFormat() : ms_spectral_lib_file, ms_taxnodesfiles, ms_taxspeciesfiles
  • getFORMVER() : ms_searchparams
  • getFormVersion() : ms_mascotoptions
  • getFraction() : ms_quant_file_index, ms_quant_helper
  • getFractionSchemaType() : ms_quant_file_index
  • getFractionToSubProjectMap() : ms_ms1quant_time_align
  • getFragmentByNumber() : ms_fragmentvector
  • getFragResidueMass() : ms_masses
  • getFragRulesFile() : ms_distiller_data
  • getFrame() : ms_protein
  • getFrequencies() : ms_mascotfiles
  • getFromUnimod() : ms_modification
  • getFullName() : ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification, ms_user
  • getFullNameSchemaType() : ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • getFullUserName() : ms_session
  • getGencodeFile() : ms_taxonomyrules
  • getGene() : ms_unigene_entry
  • getGetSeqBlastAccession() : ms_mascotoptions
  • getGetSeqJobIdFile() : ms_mascotoptions
  • getGroup() : ms_security
  • getGroupFromID() : ms_security
  • getGrouping() : ms_protein
  • getGroupOfPoster() : ms_umod_modification
  • getGroupOfPosterSchemaType() : ms_umod_modification
  • getHavePeakList() : ms_distiller_sub_project
  • getHeaderComments() : ms_datfile
  • getHeaderKeyValues() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getHeaderLine() : ms_logger
  • getHeaderValue() : ms_http_helper, ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getHiddenSchemaType() : ms_umod_specificity
  • getHit() : ms_mascotresults, ms_ms1quant_match, ms_ms1quantitation, ms_peptidesummary
  • getHitNumber() : ms_protein
  • getHomologyThreshold() : ms_mascotresults
  • getHomologyThresholdForHistogram() : ms_mascotresults
  • getHostName() : ms_computeraddress, ms_wwwentry
  • getHT_IDFromLogical() : ms_processors
  • getHttpPassword() : ms_connection_settings
  • getHttpProtocol() : ms_connection_settings
  • getHttpStatusCode() : ms_http_helper_return
  • getHttpUsername() : ms_connection_settings
  • getHydrogenMass() : ms_masses, ms_searchparams
  • getHyperThreadedCPUsMask() : ms_processors
  • getHyperThreadingState() : ms_processors
  • getHypothesisPvalue() : ms_protein_quant_ratio
  • getICAT() : ms_searchparams
  • getICATFilter() : ms_mascotoptions
  • getICATHeavy() : ms_mascotoptions
  • getICATLight() : ms_mascotoptions
  • getICATQuantitationMethod() : ms_mascotoptions
  • getId() : ms_distiller_master_search, ms_distiller_search_status, ms_distiller_sub_project
  • getID() : ms_group, ms_peptide_quant_key, ms_security_task, ms_session, ms_unigene_entry, ms_user
  • getIdentifier() : ms_taxonomyrules
  • getIdxFromFileIndex() : ms_ms1quant_match_component
  • getIgnore() : ms_quant_localdef, ms_umod_modification
  • getIgnoredQPs() : ms_protein
  • getIgnoreDupeAccession() : ms_mascotoptions
  • getIgnoreIonsScoreBelow() : ms_mascotoptions, ms_mascotresults_params
  • getIgnoreMass() : ms_modification
  • getIgnoreSchemaType() : ms_quant_localdef, ms_umod_modification
  • getImputationVariableChoice() : ms_imputation
  • getImputeExcludedMs2PeptideRatios() : ms_imputation
  • getImputeMs1PeptideExcludedByCorrelationThr() : ms_imputation
  • getImputeMs1PeptideExcludedByFractionThr() : ms_imputation
  • getImputeMs1PeptideExcludedByStdErrThr() : ms_imputation
  • getImputeMs1PeptideNegativeRatio() : ms_imputation
  • getIncludeTaxonomy() : ms_taxonomychoice
  • getIndex() : ms_inputquery
  • getIndexFileName() : ms_tinycdb
  • getInetAddress() : ms_computeraddress
  • getInputQuery() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getINSTRUMENT() : ms_inputquery, ms_searchparams
  • getInstrumentByName() : ms_fragrulesfile
  • getInstrumentByNumber() : ms_fragrulesfile
  • getInstrumentName() : ms_fragrulesfile
  • getIntactLinks() : ms_peptide
  • getIntegraAppServerURL() : ms_security_options
  • getIntegraDatabaseName() : ms_security_options
  • getIntegraOracleServerName() : ms_security_options
  • getIntegration() : ms_quant_method
  • getIntegrationSchemaType() : ms_quant_method
  • getIntegraUsers() : ms_security
  • getIntensity() : ms_spectral_lib_peak
  • getIntensityNormalisationBase() : ms_ms2quantitation
  • getIntensitySigFigs() : ms_mascotoptions
  • getInterFileBasePath() : ms_mascotoptions
  • getInterFileRelPath() : ms_mascotoptions
  • getINTERMEDIATE() : ms_searchparams
  • getIntFromKey() : ms_tinycdb
  • getIntMax() : ms_inputquery
  • getIntMin() : ms_inputquery
  • getIntParam() : ms_session
  • getIonIntensityThreshold() : ms_quant_multiplex
  • getIonIntensityThresholdSchemaType() : ms_quant_multiplex
  • getIonMobility() : ms_inputquery
  • getIonsDecimalPlaces() : ms_mascotoptions
  • getIonSeries() : ms_quant_multiplex
  • getIonSeriesSchemaType() : ms_quant_multiplex
  • getIonsIntensity() : ms_peptide
  • getIonsScore() : ms_mascotresults, ms_peptide, ms_peptidesummary, ms_proteinsummary
  • getIonsScoreCorrected() : ms_mascotresults
  • getIonsScoreHistogram() : ms_mascotresults
  • getIPAddress() : ms_session
  • getIPCLogfile() : ms_clusterparams
  • getIPCLogging() : ms_clusterparams
  • getIPCTimeout() : ms_clusterparams
  • getIsDatabaseActive() : ms_http_client
  • getIsFromErrorTolerant() : ms_peptide
  • getIsFromLibrary() : ms_peptide
  • getIsolatedPrecursorSchemaType() : ms_quant_quality
  • getIsolatedPrecursorThreshold() : ms_quant_quality
  • getIsolatedPrecursorThresholdSchemaType() : ms_quant_quality
  • getIsotope() : ms_quant_component
  • getIsotopeSchemaType() : ms_quant_component
  • getIsPermitted() : ms_http_client_session
  • getIsSecurityEnabled() : ms_http_client
  • getIsWebAuthenticationEnabled() : ms_http_client
  • getIsXmlUploadedList() : ms_http_client_session
  • getIT_MODS() : ms_inputquery, ms_searchparams
  • getItemFromId() : ms_obofile
  • getITOL() : ms_searchparams
  • getITOLU() : ms_searchparams
  • getJobNumber() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getKeepAlive() : ms_mascotresfilebase
  • getKey() : ms_ms1quant_match, ms_peptide_quant_ratio
  • getKnnNumNeighbours() : ms_imputation_knn
  • getKnnUseWeightedAverage() : ms_imputation_knn
  • getKnownValues() : ms_imputation_method
  • getLabel() : ms_fragment
  • getLabelFree() : ms_ms1quantitation
  • getLabelFreeVarMods() : ms_ms1quant_match
  • getLastAccessed() : ms_session
  • getLastError() : ms_errors, ms_errs, ms_mascotresfilebase
  • getLastErrorString() : ms_errors, ms_errs, ms_mascotresfilebase
  • getLastModificationTime() : ms_fileutilities
  • getLastQueryAscFile() : ms_mascotoptions
  • getLastSerie() : ms_fragmentationrules
  • getLastSeries() : ms_fragmentationrules
  • getLastXicScanId() : ms_ms1quant_match
  • getLessThanMinPepLen() : ms_peptide
  • getLIBRARY_SEARCH() : ms_searchparams
  • getLibraryEntryId() : ms_peptidesummary
  • getLibraryModDelta() : ms_searchparams
  • getLibraryModName() : ms_searchparams
  • getLibraryMods() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getLibraryModString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getLibraryName() : ms_libraryoptions
  • getLibraryOptions() : ms_datfile
  • getLICENSE() : ms_searchparams
  • getLicensee() : ms_license
  • getLicenseString() : ms_license
  • getLicenseVersion() : ms_license
  • getLine() : ms_spectral_lib_entry
  • getLinkerByNumber() : ms_crosslinking_linkers
  • getLinkerMass() : ms_linker_site
  • getLinkers() : ms_crosslinking_method
  • getLinkerSchemaType() : ms_crosslinking_linkers
  • getLinkersSchemaType() : ms_crosslinking_method
  • getLinkFrom() : ms_linker_site
  • getLinkTo() : ms_linker_site
  • getLoaded() : ms_distiller_data_search
  • getLoadedSearchIndex() : ms_distiller_data
  • getLoadUnassigned() : ms_distiller_data_search
  • getLocalDefinition() : ms_quant_modgroup
  • getLocalDefinitionSchemaType() : ms_quant_modgroup
  • getLocalModifications() : ms_quant_method
  • getLocalModsNlStr() : ms_peptide
  • getLocalModsStr() : ms_peptide
  • getLocalVarModName() : ms_inputquery
  • getLocus() : ms_inputquery
  • getLocusLink() : ms_unigene_entry
  • getLogEventsHandler() : ms_loggingmonitor
  • getLogFileName() : ms_cronoptions
  • getLogFilename() : ms_file_logger
  • getLogFileName() : ms_security_options
  • getLoggingFileName() : ms_errs
  • getLoggingLevel() : ms_cronoptions, ms_errs, ms_log, ms_security_options
  • getLogMask() : ms_loggingmonitor
  • getLogoImageFile() : ms_mascotoptions
  • getLongestPeptideLen() : ms_protein
  • getLongestSigPeptideLen() : ms_protein
  • getLongParam() : ms_session
  • getLongParams() : ms_security_task
  • getLoopLinks() : ms_peptide
  • getMailTempFile() : ms_mascotoptions
  • getMailTransport() : ms_mascotoptions
  • getMajorVersion() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • getMascNodeCtrlFile() : ms_mascotoptions
  • getMascotCmdLine() : ms_mascotoptions
  • getMascotControlFile() : ms_mascotoptions
  • getMascotFileProcessingThreads() : ms_mascotoptions
  • getMascotFiles() : ms_datfile
  • getMascotJobIdFile() : ms_mascotoptions
  • getMascotMessage() : ms_mascotoptions
  • getMascotNodeRebootScript() : ms_clusterparams
  • getMascotNodeScript() : ms_clusterparams
  • getMascotOptions() : ms_datfile
  • getMascotSearchURL() : ms_distiller_data_search
  • getMascotSecurityOptions() : ms_security
  • getMascotServerURL() : ms_distiller_data_search
  • getMascotVer() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getMass() : ms_fragment
  • getMASS() : ms_searchparams
  • getMassDecimalPlaces() : ms_mascotoptions
  • getMassDelta() : ms_quant_integration
  • getMassDeltaSchemaType() : ms_quant_integration
  • getMassDeltaUnit() : ms_quant_integration
  • getMassDeltaUnitSchemaType() : ms_quant_integration
  • getMasses() : ms_aahelper, ms_mascotresfilebase, ms_protein
  • getMassesKeyValues() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getMassesWithinTolerance() : ms_fragmentvector
  • getMassFile() : ms_modfile, ms_modification
  • getMassMax() : ms_inputquery
  • getMassMin() : ms_inputquery
  • getMassType() : ms_searchparams
  • getMassValue() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getMasterComputer() : ms_clusterparams
  • getMasterProjectStreamName() : ms_distiller_master_project
  • getMatch() : ms_ms1quantitation
  • getMatchedFraction() : ms_ms1quant_charge_state, ms_ms1quant_match_component
  • getMatchedIonIntensity() : ms_fragment
  • getMatchedIonMass() : ms_fragment
  • getMatchedRho() : ms_ms1quant_charge_state, ms_ms1quant_match_component, ms_quant_integration
  • getMatchedRhoSchemaType() : ms_quant_integration
  • getMatchForHit() : ms_ms1quantitation
  • getMaxAlignment() : ms_ms1quant_charge_state
  • getMaxConcurrentSearches() : ms_mascotoptions
  • getMaxDatabases() : ms_mascotoptions
  • getMaxDescriptionLen() : ms_mascotoptions
  • getMaxEtagMassDelta() : ms_mascotoptions
  • getMaxEtVarMods() : ms_mascotoptions
  • getMaxHitsToReport() : ms_mascotresults_params
  • getMaxIntactCrosslinkPeptides() : ms_mascotoptions
  • getMaxInternalMass() : ms_fragmentationrules, ms_inputquery, ms_searchparams
  • getMaxMZ() : ms_ms1quant_time_align_limits
  • getMaxNumOfReportBuilderColumnArrangements() : ms_mascotoptions
  • getMaxNumPeptides() : ms_mascotoptions
  • getMaxPepModArrangements() : ms_mascotoptions
  • getMaxPepNumModifiedSites() : ms_mascotoptions
  • getMaxPepNumVarMods() : ms_mascotoptions
  • getMaxPeptideIdentityThreshold() : ms_mascotresults
  • getMaxQueries() : ms_mascotoptions
  • getMaxRankValue() : ms_mascotresults
  • getMaxRT() : ms_ms1quant_time_align_limits
  • getMaxSearchesPerUser() : ms_mascotoptions
  • getMaxSequenceLen() : ms_mascotoptions
  • getMaxTaxonomyRules() : ms_datfile
  • getMaxVarMods() : ms_mascotoptions
  • getMD5Sum() : ms_fileutilities
  • getMemberNumber() : ms_protein
  • getMessageSource() : ms_log
  • getMethod() : ms_quant_integration, ms_quant_normalisation, ms_quant_outliers
  • getMethodByName() : ms_crosslinking_configfile, ms_quant_configfile
  • getMethodByNumber() : ms_crosslinking_configfile, ms_quant_configfile
  • getMethodSchemaType() : ms_quant_integration, ms_quant_normalisation, ms_quant_outliers
  • getMinEtagMassDelta() : ms_mascotoptions
  • getMinimumA1() : ms_quant_quality
  • getMinimumA1SchemaType() : ms_quant_quality
  • getMinimumPasswordLength() : ms_security_options
  • getMinInternalMass() : ms_fragmentationrules, ms_inputquery, ms_searchparams
  • getMinIonPairs() : ms_quant_multiplex
  • getMinIonPairsSchemaType() : ms_quant_multiplex
  • getMinMZ() : ms_ms1quant_time_align_limits
  • getMinNumPeptides() : ms_quant_method, ms_quantitation
  • getMinNumPeptidesSchemaType() : ms_quant_method
  • getMinNumSigUniqueSequences() : ms_mascotresults_params
  • getMinorVersion() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • getMinPepLenInPepSummary() : ms_distiller_data_search, ms_mascotoptions, ms_mascotresults
  • getMinPepLenInPeptideSummary() : ms_mascotresults_params
  • getMinPepLenInSearch() : ms_mascotoptions
  • getMinPrecursorCharge() : ms_quant_quality
  • getMinPrecursorChargeSchemaType() : ms_quant_quality
  • getMinProbability() : ms_mascotresults_params
  • getMinProbabilityForSLScore() : ms_peptidesummary
  • getMinRT() : ms_ms1quant_time_align_limits
  • getMiscNotes() : ms_umod_modification, ms_umod_specificity
  • getMiscNotesSchemaType() : ms_umod_modification, ms_umod_specificity
  • getMissed() : ms_aahelper
  • getMissedCleavages() : ms_peptide
  • getMissingIndexes() : ms_imputation_method
  • getML_ADAPTER_PARAM() : ms_searchparams
  • getModBrickByName() : ms_umod_configfile
  • getModBrickByNumber() : ms_umod_configfile
  • getMode() : ms_quant_modgroup
  • getModeSchemaType() : ms_quant_modgroup
  • getModFile() : ms_quant_modgroup
  • getModFileList() : ms_umod_configfile, ms_umod_modification
  • getModFileName() : ms_crosslinking_does_not_pair_with, ms_crosslinking_linker
  • getModFileNameSchemaType() : ms_crosslinking_does_not_pair_with, ms_crosslinking_linker
  • getModFileSchemaType() : ms_quant_modgroup
  • getModificationByName() : ms_modfile, ms_modvector, ms_umod_configfile
  • getModificationByNumber() : ms_modfile, ms_modvector, ms_umod_configfile
  • getModificationGroupByName() : ms_quant_component, ms_quant_method
  • getModificationGroupByNumber() : ms_quant_component, ms_quant_method
  • getModificationGroupSchemaType() : ms_quant_component, ms_quant_method
  • getModifications() : ms_mascotfiles, ms_quant_satellite
  • getModificationsSchemaType() : ms_quant_satellite
  • getModificationType() : ms_modification
  • getModifiedResidue() : ms_modification
  • getMODS() : ms_searchparams
  • getMods() : ms_spectral_lib_entry
  • getModsFromNumber() : ms_spectral_lib_file
  • getMonitorEmailCheckFreq() : ms_mascotoptions
  • getMonitorLogFile() : ms_mascotoptions
  • getMonitorPidFile() : ms_mascotoptions
  • getMonitorTestTimeout() : ms_mascotoptions
  • getMonoisotopic() : ms_quant_moverz
  • getMonoisotopicSchemaType() : ms_quant_moverz
  • getMonoLinkByNumber() : ms_crosslinking_linker
  • getMonoLinkModification() : ms_mascotresfilebase
  • getMonoLinkSchemaType() : ms_crosslinking_linker
  • getMonoLinkStr() : ms_peptide
  • getMonoLinkTitle() : ms_modification
  • getMonoMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • getMonoMassAsNumber() : ms_umod_element
  • getMonoMassSchemaType() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • getMoverz() : ms_ms1quant_match_component, ms_quant_component
  • getMoverzSchemaType() : ms_quant_component
  • getMrCalc() : ms_peptide
  • getMrExperimental() : ms_peptide
  • getMSParserVersion() : ms_mascotresfilebase
  • getMudpit() : ms_mascotoptions
  • getMudpitSwitch() : ms_mascotoptions
  • getMULTI_SITE_MODS() : ms_searchparams
  • getMultiFileQueryNumber() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getMultiplex() : ms_quant_protocol
  • getMultiplexSchemaType() : ms_quant_protocol
  • getMultithreadedName() : ms_processors
  • getMW() : ms_spectral_lib_entry
  • getMz() : ms_spectral_lib_peak
  • getName() : ms_crosslinking_method, ms_databaseoptions, ms_dbprocessors, ms_distiller_sub_project, ms_group, ms_http_client_mime, ms_quant_component, ms_quant_method, ms_quant_modgroup, ms_quant_numerator, ms_quant_ratio, ms_spectral_lib_entry, ms_user, ms_wwwentry, ms_xml_parameter
  • getNameOfDB() : ms_parserule_plus
  • getNameSchemaType() : ms_crosslinking_method, ms_crosslinking_parameter, ms_quant_component, ms_quant_method, ms_quant_modgroup, ms_quant_numerator, ms_quant_parameter, ms_quant_ratio, ms_xml_parameter
  • getNeutralLoss() : ms_fragment, ms_modification, ms_quant_specificity, ms_umod_specificity
  • getNeutralLossRequired() : ms_modification
  • getNeutralLossSchemaType() : ms_quant_specificity, ms_umod_specificity
  • getNew() : ms_quant_isotope
  • getNewSchemaType() : ms_quant_isotope
  • getNextFamilyProtein() : ms_mascotresults
  • getNextLine() : ms_msr2dat28
  • getNextPeptide() : ms_aahelper
  • getNextSimilarProtein() : ms_mascotresults
  • getNextSimilarProteinOf() : ms_mascotresults
  • getNextSubsetProtein() : ms_mascotresults
  • getNextSubsetProteinOf() : ms_mascotresults
  • getNitrogenMass() : ms_masses, ms_searchparams
  • getNoBreakDescLineIf() : ms_taxonomyrules
  • getNodeListFile() : ms_mascotfiles
  • getNodeSequenceDatabaseDir() : ms_clusterparams
  • getNodesFile() : ms_taxonomyrules
  • getNonMudpitScore() : ms_protein
  • getNoResultsScript() : ms_mascotoptions
  • getNormalisation() : ms_quant_method
  • getNormalisationSchemaType() : ms_quant_method
  • getNormalityPvalue() : ms_protein_quant_ratio
  • getNotes() : ms_security_task
  • getNtermDelta() : ms_masses
  • getNterminalMass() : ms_masses
  • getNTerminusMass() : ms_modification
  • getNTermMass() : ms_searchparams
  • getNtermNeutralLoss() : ms_masses
  • getNTIUserGroup() : ms_mascotoptions
  • getNTMonitorGroup() : ms_mascotoptions
  • getNum13C() : ms_peptide
  • getNumAccessions() : ms_unigene_entry
  • getNumAvailableToProcess() : ms_processors
  • getNumber() : ms_quant_element, ms_umod_elemref
  • getNumberOfAccessionDBTypes() : ms_peptidesummary
  • getNumberOfAccessions() : ms_crosslinking_accessions
  • getNumberOfAltNames() : ms_umod_modification
  • getNumberOfAminoAcids() : ms_umod_configfile
  • getNumberOfBuckets() : ms_ms1quant_charge_state
  • getNumberOfComponents() : ms_quant_method
  • getNumberOfCorrections() : ms_quant_component
  • getNumberOfCronJobs() : ms_cronoptions
  • getNumberOfCutters() : ms_enzyme
  • getNumberOfDatabases() : ms_databases, ms_processoroptions, ms_searchparams
  • getNumberOfDenominators() : ms_quant_ratio
  • getNumberOfDoesNotPairWiths() : ms_crosslinking_linker
  • getNumberOfElements() : ms_quant_composition, ms_umod_configfile
  • getNumberOfElemRefs() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • getNumberOfEntries() : ms_obofile, ms_taxonomyfile, ms_wwwoptions
  • getNumberOfEnzymes() : ms_enzymefile
  • getNumberOfErrors() : ms_errs, ms_mascotresfilebase
  • getNumberOfExcludeTaxonomies() : ms_taxonomychoice
  • getNumberOfExclusions() : ms_quant_method
  • getNumberOfFamilyAccessionDBTypes() : ms_peptidesummary
  • getNumberOfFamilyMembers() : ms_mascotresults
  • getNumberOfFileIndexes() : ms_quant_component
  • getNumberOfFragments() : ms_fragmentvector
  • getNumberOfGencodeFiles() : ms_taxonomyrules
  • getNumberOfHits() : ms_mascotresults
  • getNumberOfIgnoreDupeAccessions() : ms_mascotoptions
  • getNumberOfIgnoreMasses() : ms_modification
  • getNumberOfIgnores() : ms_quant_localdef, ms_umod_modification
  • getNumberOfIncludeTaxonomies() : ms_taxonomychoice
  • getNumberOfInstruments() : ms_fragrulesfile
  • getNumberOfIonSeries() : ms_quant_multiplex
  • getNumberOfIsotopes() : ms_quant_component
  • getNumberOfLibraries() : ms_libraryoptions
  • getNumberOfLibraryMods() : ms_searchparams
  • getNumberOfLinkedPeptides() : ms_peptide
  • getNumberOfLinkers() : ms_crosslinking_linkers
  • getNumberOfLocalDefinitions() : ms_quant_modgroup
  • getNumberOfLocalVarMods() : ms_inputquery
  • getNumberOfMethods() : ms_crosslinking_configfile, ms_quant_configfile
  • getNumberOfModBricks() : ms_umod_configfile
  • getNumberOfModFiles() : ms_quant_modgroup
  • getNumberOfModificationGroups() : ms_quant_component, ms_quant_method
  • getNumberOfModifications() : ms_modfile, ms_modvector, ms_umod_configfile
  • getNumberOfModifiedResidues() : ms_modification
  • getNumberOfMonoLinks() : ms_crosslinking_linker
  • getNumberOfNeutralLosses() : ms_quant_specificity, ms_umod_specificity
  • getNumberOfNoBreakDescLineIf() : ms_taxonomyrules
  • getNumberOfNodesFiles() : ms_taxonomyrules
  • getNumberOfNumerators() : ms_quant_ratio
  • getNumberOfParameters() : ms_crosslinking_parameters, ms_quant_parameters, ms_xml_parameters
  • getNumberOfParseRules() : ms_parseoptions
  • getNumberOfPeaks() : ms_inputquery
  • getNumberOfPepNeutralLosses() : ms_quant_specificity, ms_umod_specificity
  • getNumberOfPeptides() : ms_quant_normalisation_peptides
  • getNumberOfPerDbSrcRules() : ms_taxonomyrules
  • getNumberOfPrefixRemoves() : ms_taxonomyrules
  • getNumberOfProcessors() : ms_processoroptions
  • getNumberOfProperties() : ms_customproperty
  • getNumberOfProteins() : ms_quant_normalisation_proteins
  • getNumberOfReportNumberChoices() : ms_mascotoptions
  • getNumberOfReportRatios() : ms_quant_method
  • getNumberOfResfiles() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getNumberOfSeqs() : ms_quant_method
  • getNumberOfSpeciesFiles() : ms_taxonomyrules
  • getNumberOfSpecificities() : ms_quant_localdef, ms_umod_modification
  • getNumberOfStrFiles() : ms_taxonomyrules
  • getNumberOfSubClusters() : ms_clusterparams
  • getNumberOfSubtasks() : ms_progress_info
  • getNumberOfSuffixRemoves() : ms_taxonomyrules
  • getNumberOfTargetFDRPercentages() : ms_mascotoptions
  • getNumberOfTasks() : ms_security_tasks
  • getNumberOfThreads() : ms_databaseoptions, ms_dbprocessors
  • getNumberOfUnassigned() : ms_mascotresults
  • getNumberOfUnmodified() : ms_quant_modgroup
  • getNumberOfXrefs() : ms_umod_modification
  • getNumberSchemaType() : ms_quant_element, ms_umod_elemref
  • getNumComponents() : ms_ms1quant_match, ms_protein
  • getNumCores() : ms_processors
  • getNumDecoyHitsAboveHomology() : ms_mascotresults
  • getNumDecoyHitsAboveIdentity() : ms_mascotresults
  • getNumDiscoveredErrTolMods() : ms_mascotresults
  • getNumDiscoveredFixedMods() : ms_mascotresults
  • getNumDiscoveredIntactLinks() : ms_mascotresults
  • getNumDiscoveredLibraryMods() : ms_mascotresults
  • getNumDiscoveredLocalMods() : ms_mascotresults
  • getNumDiscoveredNonSpecCleavage() : ms_mascotresults
  • getNumDiscoveredVariableMods() : ms_mascotresults
  • getNumDisplayPeptides() : ms_protein
  • getNumDistinctPeptideRepeats() : ms_protein
  • getNumDistinctPeptides() : ms_protein
  • getNumEntries() : ms_spectral_lib_file
  • getNumeratorByName() : ms_quant_ratio
  • getNumeratorByNumber() : ms_quant_ratio
  • getNumeratorSchemaType() : ms_quant_ratio
  • getNumEtSeqsSearched() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getNumFileIndexesMatched() : ms_ms1quant_match_component
  • getNumGroups() : ms_ms1quantitation
  • getNumHits() : ms_mascotresfile_dat, ms_ms1quant_match, ms_ms1quantitation
  • getNumHitsAboveHomology() : ms_mascotresults
  • getNumHitsAboveIdentity() : ms_mascotresults
  • getNumIonsMatched() : ms_peptide
  • getNumLibraryEntries() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getNumLogEventsHandlers() : ms_loggingmonitor
  • getNumLogicalPerPhysical() : ms_processors
  • getNumMatches() : ms_ms1quantitation
  • getNumMatchesForGroup() : ms_ms1quantitation
  • getNumMatchesForHit() : ms_ms1quantitation
  • getNumObservedForEmPAI() : ms_protein
  • getNumOnSystem() : ms_processors
  • getNumPeaks() : ms_spectral_lib_entry, ms_spectral_lib_peak_list
  • getNumPeptideRatios() : ms_ms1quant_match
  • getNumPeptides() : ms_ms1quant_match_component, ms_protein, ms_quant_average
  • getNumPeptidesSchemaType() : ms_quant_average
  • getNumPeptideStatuses() : ms_ms1quantitation
  • getNumPhysicalOnSystem() : ms_processors
  • getNumPmfQueriesUsed() : ms_proteinsummary
  • getNumPoints() : ms_xic
  • getNumProcessorGroups() : ms_processors
  • getNumProcessorsLicensed() : ms_license
  • getNumProteinFamilies() : ms_ms1quantitation
  • getNumProteins() : ms_peptide
  • getNumQueries() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase, ms_ms1quant_time_align_limits
  • getNumQueriesAboveThreshold() : ms_ms1quant_time_align_limits
  • getNumRanges() : ms_ms1quant_match_component
  • getNumResidues() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase, ms_spectral_lib_file
  • getNumSearches() : ms_distiller_master_project, ms_distiller_search_status_list
  • getNumSeqs() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getNumSeqsAfterTax() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getNumSubprojects() : ms_distiller_master_project
  • getNumSubsearches() : ms_distiller_master_search
  • getNumUsed() : ms_inputquery
  • getNumVals() : ms_inputquery
  • getObserved() : ms_peptide
  • getObservedCharge() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getObservedIntensity() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getObservedMass() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getObservedMrValue() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getOld() : ms_quant_isotope
  • getOldSchemaType() : ms_quant_isotope
  • getOpaqueString() : ms_peptide_quant_key
  • getOpaqueStringAndID() : ms_peptide_quant_key
  • getOsName() : ms_http_client
  • getOutlierKeys() : ms_protein_quant_ratio
  • getOutliers() : ms_quant_method
  • getOutliersSchemaType() : ms_quant_method
  • getOVERVIEW() : ms_searchparams
  • getOxygenMass() : ms_masses, ms_searchparams
  • getPairsWith() : ms_modification, ms_umod_neutralloss
  • getPairsWithSchemaType() : ms_umod_neutralloss
  • getParameterByName() : ms_crosslinking_parameters, ms_quant_parameters
  • getParameterByNumber() : ms_crosslinking_parameters, ms_quant_parameters
  • getParameterSchemaType() : ms_crosslinking_filters, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_quant_parameters, ms_xml_parameters
  • getParams() : ms_session
  • getParent() : ms_taxonomytree
  • getParseOptions() : ms_datfile
  • getParseRule() : ms_parseoptions, ms_wwwentry
  • getPasswordExpiry() : ms_user
  • getPath() : ms_databaseoptions, ms_wwwentry
  • getPeak() : ms_spectral_lib_peak_list
  • getPeakAnnotationLevel() : ms_spectral_lib_peak_list
  • getPeakCharge() : ms_inputquery
  • getPeakEndIndex() : ms_xic
  • getPeakEndScanId() : ms_xic
  • getPeakIntensity() : ms_inputquery
  • getPeakList() : ms_inputquery, ms_spectral_lib_entry
  • getPeakListChecksum() : ms_spectral_lib_entry
  • getPeakListObject() : ms_spectral_lib_entry
  • getPeakMass() : ms_inputquery
  • getPeakStartIndex() : ms_xic
  • getPeakStartScanId() : ms_xic
  • getPeakState() : ms_xic
  • getPeaksUsedFromIons1() : ms_peptide
  • getPeaksUsedFromIons2() : ms_peptide
  • getPeaksUsedFromIons3() : ms_peptide
  • getPEP_ISOTOPE_ERROR() : ms_searchparams
  • getPepEnd() : ms_aahelper
  • getPepNeutralLoss() : ms_modification, ms_quant_specificity, ms_umod_specificity
  • getPepNeutralLossSchemaType() : ms_quant_specificity, ms_umod_specificity
  • getPepNumber() : ms_protein
  • getPepSearchTool() : ms_mascotoptions
  • getPepSearchToolCommandLine() : ms_mascotoptions
  • getPepStart() : ms_aahelper
  • getPepsWithSameScore() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getPepThresholdType() : ms_quant_quality
  • getPepThresholdTypeSchemaType() : ms_quant_quality
  • getPepThresholdValue() : ms_quant_quality
  • getPepThresholdValueSchemaType() : ms_quant_quality
  • getPeptide() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary, ms_quant_normalisation_peptides
  • getPeptideAmbiguityRanks() : ms_peptidesummary
  • getPeptideComponentID() : ms_protein
  • getPeptideDuplicate() : ms_protein
  • getPeptideEnd() : ms_protein
  • getPeptideExpectationValue() : ms_mascotresults
  • getPeptideFrame() : ms_protein
  • getPeptideIdentityThreshold() : ms_mascotresults
  • getPeptideIonsScore() : ms_protein
  • getPeptideIsBold() : ms_protein
  • getPeptideKey() : ms_ms1quant_match_component
  • getPeptideLength() : ms_peptide
  • getPeptideMultiplicity() : ms_protein
  • getPeptideP() : ms_protein
  • getPeptideQuantKeys() : ms_quantitation
  • getPeptideQuery() : ms_protein
  • getPeptideRatio() : ms_customquantitation, ms_ms1quant_match, ms_ms2quantitation, ms_quantitation
  • getPeptideRatioNormalisationBase() : ms_quantitation
  • getPeptideResidueAfter() : ms_protein
  • getPeptideResidueBefore() : ms_protein
  • getPeptides() : ms_quant_normalisation
  • getPeptideSchemaType() : ms_quant_normalisation_peptides
  • getPeptideSection() : ms_mascotresfile_dat
  • getPeptideShowCheckbox() : ms_protein
  • getPeptidesSchemaType() : ms_quant_normalisation
  • getPeptideStart() : ms_protein
  • getPeptideStatus() : ms_ms1quantitation
  • getPeptideStr() : ms_peptide
  • getPeptideString() : ms_ms1quant_match
  • getPeptideSubstring() : ms_fragment
  • getPeptideSummary() : ms_ms1quantitation, ms_ms2quantitation
  • getPeptideSummaryCacheStreamName() : ms_distiller_search_status
  • getPeptideSummaryFlags() : ms_distiller_data_search
  • getPeptideSummaryFlags2() : ms_distiller_data_search
  • getPeptideThreshold() : ms_mascotresults
  • getPepTol() : ms_inputquery
  • getPepTolString() : ms_inputquery
  • getPepTolUnits() : ms_inputquery
  • getPERCOLATE() : ms_searchparams
  • getPercolator() : ms_distiller_data_search
  • getPercolatorExeFlags() : ms_mascotoptions
  • getPercolatorFeatures() : ms_mascotoptions
  • getPercolatorFileNames() : ms_mascotresfilebase
  • getPercolatorMinQueries() : ms_mascotoptions
  • getPercolatorMinSequences() : ms_mascotoptions
  • getPercolatorRtFlags() : ms_mascotoptions
  • getPercolatorScores() : ms_peptide
  • getPercolatorTargetRankRelativeThreshold() : ms_mascotoptions
  • getPercolatorTargetRankScoreThreshold() : ms_mascotoptions
  • getPercolatorUseProteins() : ms_distiller_data_search
  • getPercolatorUseRT() : ms_distiller_data_search
  • getPerDbSrcRule() : ms_taxonomyrules
  • getPerfectObservedMatrix() : ms_ms1quant_match
  • getPermittedTasks() : ms_group, ms_session
  • getPermittedTasksForUser() : ms_security
  • getPFA() : ms_searchparams
  • getPhysicalFromLogical() : ms_processors
  • getPoint() : ms_xic
  • getPort() : ms_computeraddress
  • getPortNumber() : ms_wwwentry
  • getPosition() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • getPositionSchemaType() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • getPreceedingComments() : ms_customproperty, ms_databaseoptions
  • getPrecursor() : ms_quant_protocol
  • getPRECURSOR() : ms_searchparams
  • getPrecursorChargeFromNumber() : ms_spectral_lib_file
  • getPrecursorCutOutLowerLimit() : ms_mascotoptions
  • getPrecursorCutOutUpperLimit() : ms_mascotoptions
  • getPrecursorMZ() : ms_spectral_lib_entry
  • getPrecursorMZFromNumber() : ms_spectral_lib_file
  • getPrecursorRange() : ms_quant_integration
  • getPrecursorRangeSchemaType() : ms_quant_integration
  • getPrecursorSchemaType() : ms_quant_protocol
  • getPredictionMatrix() : ms_ms1quant_match
  • getPrefixRemove() : ms_taxonomyrules
  • getPrettyRank() : ms_peptide
  • getPrimaryNlStr() : ms_peptide
  • getProbabilityThreshold() : ms_mascotresults
  • getProbFromScore() : ms_mascotresults
  • getProbOfPepBeingRandomMatch() : ms_mascotresults
  • getProbOfProteinBeingRandomMatch() : ms_mascotresults
  • getProcessingOptions() : ms_quant_integration
  • getProcessingOptionsSchemaType() : ms_quant_integration
  • getProcessor() : ms_processoroptions
  • getProcessorName() : ms_processors
  • getProcessors() : ms_datfile
  • getProgress() : ms_progress_info
  • getProgressInfo() : ms_mascotresfilebase, ms_quantitation
  • getProjectRelativePath() : ms_distiller_sub_project
  • getPropertyName() : ms_customproperty
  • getProportion() : ms_http_helper_progress
  • getPropValStringByName() : ms_customproperty
  • getPropValStringByNumber() : ms_customproperty
  • getProtein() : ms_mascotresults, ms_peptide, ms_peptidesummary, ms_quant_normalisation_proteins
  • getProteinDescription() : ms_mascotresults
  • getProteinEmPAI() : ms_mascotresults, ms_peptidesummary
  • getProteinExpectationValue() : ms_mascotresults
  • getProteinFamilySwitch() : ms_mascotoptions
  • getProteinGrouping() : ms_distiller_data_search
  • getProteinId() : ms_protein
  • getProteinMass() : ms_mascotresults
  • getProteinRatio() : ms_customquantitation, ms_ms1quantitation, ms_ms2quantitation, ms_quantitation
  • getProteinRatioSample() : ms_quantitation
  • getProteinRatioType() : ms_quant_method
  • getProteinRatioTypeSchemaType() : ms_quant_method
  • getProteins() : ms_peptide, ms_quant_normalisation
  • getProteinSchemaType() : ms_quant_normalisation_proteins
  • getProteinScoreCutoff() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getProteinScoreForHistogram() : ms_mascotresults
  • getProteinsInResultsFile() : ms_mascotoptions
  • getProteinsSchemaType() : ms_quant_normalisation
  • getProteinSummaryHit() : ms_protein
  • getProteinsWithThisPepMatch() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getProteinTaxonomyIDs() : ms_mascotresults
  • getProteinThreshold() : ms_mascotresults
  • getProtocol() : ms_quant_method
  • getProtocolSchemaType() : ms_quant_method
  • getProtScoreType() : ms_quant_method
  • getProtScoreTypeSchemaType() : ms_quant_method
  • getProxyConfig() : ms_http_helper
  • getProxyPassword() : ms_connection_settings, ms_mascotoptions
  • getProxyServer() : ms_connection_settings, ms_mascotoptions
  • getProxyServerType() : ms_connection_settings
  • getProxyType() : ms_mascotoptions
  • getProxyUserAndPassword() : ms_connection_settings
  • getProxyUsername() : ms_connection_settings, ms_mascotoptions
  • getPValue() : ms_shapiro_wilk
  • getQ() : ms_fitexy_result
  • getQmatch() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase, ms_mascotresults, ms_spectral_lib_file
  • getQplughole() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getQuality() : ms_ms1quant_match_ratio, ms_quant_method
  • getQualitySchemaType() : ms_quant_method
  • getQuant() : ms_distiller_data
  • getQuantCount() : ms_distiller_data
  • getQuantForSearch() : ms_distiller_data
  • getQuantitation() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getQUANTITATION() : ms_searchparams
  • getQuantitationComponentForPeptide() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getQuantitationDatasources() : ms_ms1quantitation
  • getQuantitationMethod() : ms_mascotresfilebase, ms_quantitation
  • getQuantMethod() : ms_distiller_data, ms_peptidesummary
  • getQuantMethodXml() : ms_distiller_data_search
  • getQUE() : ms_searchparams
  • getQuery() : ms_ms1quant_peptide_status, ms_peptide
  • getQueryAndRank() : ms_peptide_quant_key
  • getQueryList() : ms_peptidesummary
  • getQueryNumber() : ms_inputquery
  • getQuerySectionValue() : ms_mascotresfile_dat
  • getQuerySectionValueDouble() : ms_mascotresfile_dat
  • getQuerySectionValueInt() : ms_mascotresfile_dat
  • getQuerySectionValueStr() : ms_mascotresfile_dat
  • getQuickRefSearch() : ms_taxonomyrules
  • getRange() : ms_ms1quant_match_component
  • getRank() : ms_ms1quant_peptide_status, ms_peptide
  • getRatioName() : ms_ms1quant_match_ratio, ms_peptide_quant_ratio, ms_protein_quant_ratio
  • getRawAbsolutePath() : ms_distiller_sub_project
  • getRawfile() : ms_inputquery
  • getRawFormat() : ms_distiller_sub_project
  • getRawRelativePath() : ms_distiller_sub_project
  • getRawSampleNumber() : ms_distiller_sub_project
  • getRawScans() : ms_inputquery
  • getRC() : ms_matrix
  • getReadableLabelFreeVarMods() : ms_ms1quant_match
  • getReadableVarMods() : ms_mascotresults, ms_ms1quantitation
  • getReadableVarModsConcise() : ms_ms1quantitation
  • getRecordID() : ms_umod_modification
  • getRecordIDSchemaType() : ms_umod_modification
  • getRedirectPolicy() : ms_connection_settings
  • getReferenceAccession() : ms_quant_average
  • getReferenceAccessionSchemaType() : ms_quant_average
  • getReferenceAmount() : ms_quant_average
  • getReferenceAmountSchemaType() : ms_quant_average
  • getReferenceDatabase() : ms_quant_average
  • getReferenceDatabaseNumberOfSL() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getReferenceDatabaseSchemaType() : ms_quant_average
  • getReferenceFasta() : ms_libraryoptions
  • getReferenceFastaTaxonomyTitle() : ms_libraryoptions
  • getReferenceHitId() : ms_ms1quant_average_results
  • getReferenceMemberNumber() : ms_ms1quant_average_results
  • getRegionEndIndex() : ms_xic
  • getRegionEndScanId() : ms_xic
  • getRegionStartIndex() : ms_xic
  • getRegionStartScanId() : ms_xic
  • getRelativeMass() : ms_ms1quant_match_component
  • getRepeatSearchString() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getRepEntryByName() : ms_wwwoptions
  • getReplicate() : ms_quant_protocol
  • getReplicateSchemaType() : ms_quant_protocol
  • getREPORT() : ms_searchparams
  • getReportBuilderColumnArrangement() : ms_mascotoptions
  • getReportDetailSchemaType() : ms_quant_method
  • getReporter() : ms_quant_protocol
  • getReporterSchemaType() : ms_quant_protocol
  • getReporterTol() : ms_quant_reporter
  • getReporterTolSchemaType() : ms_quant_reporter
  • getReporterTolUnit() : ms_quant_reporter
  • getReporterTolUnitSchemaType() : ms_quant_reporter
  • getReportNumberChoice() : ms_mascotoptions
  • getReportRatioByName() : ms_quant_method
  • getReportRatioByNumber() : ms_quant_method
  • getReportRatioFromFile() : ms_ms2quantitation
  • getReportRatioNamesInFile() : ms_ms2quantitation
  • getReportRatioSchemaType() : ms_quant_method
  • getReporttop() : ms_distiller_data_search
  • getREPTYPE() : ms_searchparams
  • getReqPepNeutralLoss() : ms_modification
  • getRequestData() : ms_http_helper_handles
  • getRequireBoldRed() : ms_distiller_data_search
  • getRequireBoldRedSchemaType() : ms_quant_method
  • getRequiredSchemaFileNames() : ms_distiller_data
  • getRequiredSchemaType() : ms_quant_modgroup, ms_quant_pepneutralloss
  • getResfile() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase, ms_mascotresults
  • getResfileCache() : ms_mascotoptions
  • getResfileStreamName() : ms_distiller_search_status
  • getResidueMass() : ms_masses, ms_modification, ms_searchparams
  • getRestrict() : ms_enzyme
  • getResult() : ms_shapiro_wilk
  • getResultsCache() : ms_mascotoptions
  • getResultsFile() : ms_distiller_search_status, ms_distiller_subsearch
  • getResultsFileFormatVersion() : ms_mascotoptions
  • getResultsFileName() : ms_http_client_search
  • getResultsFullURL() : ms_mascotoptions
  • getResultsFullURL_2() : ms_mascotoptions
  • getResultsListStreamName() : ms_distiller_sub_project
  • getResultsParameters() : ms_mascotresults
  • getResultsPerlScript() : ms_mascotoptions
  • getResultsPerlScript_2() : ms_mascotoptions
  • getResultsStreamName() : ms_distiller_data_quant
  • getRetentionTimes() : ms_inputquery
  • getReviewColDisplay() : ms_mascotoptions
  • getReviewColWidth() : ms_mascotoptions
  • getRMSDeltas() : ms_protein
  • getRt() : ms_ms1quant_match_range
  • getRToffset() : ms_ms1quant_time_align
  • getRtPeakEnd() : ms_xic
  • getRtPeakStart() : ms_xic
  • getRtRegionEnd() : ms_xic
  • getRtRegionStart() : ms_xic
  • getRule() : ms_parserule_plus
  • getRULES() : ms_inputquery, ms_searchparams
  • getRuleStr() : ms_parserule
  • getSampleSize() : ms_protein_quant_ratio
  • getSARExtendedErrorCode() : ms_fileutilities
  • getSatellite() : ms_quant_component
  • getSatelliteSchemaType() : ms_quant_component
  • getScan() : ms_ms1quant_match_range
  • getScanNumbers() : ms_inputquery
  • getSchemaDirectory() : ms_quant_configfile
  • getSchemaFileName() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • getSchemaType() : ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_does_not_pair_with, ms_crosslinking_filters, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_crosslinking_parameter, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_parameter, ms_quant_parameters, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_xml_parameter, ms_xml_parameters
  • getScope() : ms_crosslinking_method
  • getScopeSchemaType() : ms_crosslinking_method
  • getScore() : ms_protein
  • getScoreExpectCutOff() : ms_distiller_data_search
  • getScoreWithET() : ms_protein
  • getScoring() : ms_distiller_data_search
  • getSearch() : ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list
  • getSEARCH() : ms_searchparams
  • getSearchCount() : ms_distiller_data
  • getSearchLogFile() : ms_mascotoptions
  • getSearchParameter() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSearchParametersKeyValues() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSearchStatusListStreamName() : ms_distiller_search_status_list
  • getSearchSubmitAcceptedFileTypes() : ms_mascotoptions
  • getSearchSubmitDefaultPeptideCharge() : ms_mascotoptions
  • getSearchSubmitMode() : ms_mascotoptions
  • getSearchSubmitOutputFormat() : ms_mascotoptions
  • getSearchTaskID() : ms_http_client_search
  • getSecsToWaitForNodeAtStartup() : ms_clusterparams
  • getSectionName() : ms_mascotresfile_dat
  • getSectionValue() : ms_mascotresfile_dat
  • getSectionValueDouble() : ms_mascotresfile_dat
  • getSectionValueInt() : ms_mascotresfile_dat
  • getSectionValueStr() : ms_mascotresfile_dat
  • getSEG() : ms_searchparams
  • getSelection() : ms_quant_average
  • getSelectionSchemaType() : ms_quant_average
  • getSelectSwitch() : ms_mascotoptions
  • getSendmailPath() : ms_mascotoptions
  • getSeq() : ms_inputquery, ms_quant_method
  • getSeqEntryByName() : ms_wwwoptions
  • getSeqSchemaType() : ms_quant_method
  • getSequence() : ms_quant_normalisation_peptide, ms_spectral_lib_entry
  • getSequenceFile() : ms_http_client_session
  • getSequenceFromNumber() : ms_spectral_lib_file
  • getSequenceMass() : ms_mascotresults
  • getSequenceSchemaType() : ms_quant_normalisation_peptide
  • getSeriesDescription() : ms_fragmentationrules
  • getSeriesName() : ms_fragment, ms_fragmentationrules
  • getSeriesUsedStr() : ms_peptide
  • getServer() : ms_distiller_search_status
  • getSessionID() : ms_connection_settings, ms_http_client_search, ms_http_client_session
  • getSessionTimeout() : ms_security_options
  • getSettings() : ms_crosslinking_method
  • getSettingsSchemaType() : ms_crosslinking_method
  • getShift() : ms_quant_correction
  • getShiftSchemaType() : ms_quant_correction
  • getShiftsFromConsensus() : ms_ms1quant_time_align
  • getShiftsToConsensus() : ms_ms1quant_time_align
  • getShowSamesets() : ms_distiller_data_search
  • getShowSamesetsFamily() : ms_distiller_data_search
  • getShowSubset() : ms_distiller_data_search
  • getShowSubsetFamily() : ms_distiller_data_search
  • getShowSubsets() : ms_mascotoptions
  • getShowSubSets() : ms_quant_method
  • getShowSubSetsSchemaType() : ms_quant_method
  • getSigmaA() : ms_fitexy_result
  • getSigmaB() : ms_fitexy_result
  • getSigmaX() : ms_fitexy_result
  • getSigmaY() : ms_fitexy_result
  • getSignificanceThreshold() : ms_distiller_data_search
  • getSigThreshold() : ms_mascotoptions
  • getSigThresholdValue() : ms_quant_method
  • getSigThresholdValueSchemaType() : ms_quant_method
  • getSimilarProteinDB() : ms_protein
  • getSimilarProteinName() : ms_protein
  • getSimilarProteins() : ms_protein
  • getSimpleRatioSchemaType() : ms_quant_integration
  • getSingleHit() : ms_mascotresults_params
  • getSite() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • getSiteAnalysisMD10Prob() : ms_mascotoptions
  • getSiteFrom() : ms_linker_site
  • getSiteSchemaType() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • getSiteTo() : ms_linker_site
  • getSkippedKeys() : ms_protein_quant_ratio
  • getSLDatabaseNumbersOfReference() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSLExecCommand() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSLFragmentTolerance() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSLFragmentToleranceUnit() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSLThresholdFromMinProbability() : ms_peptidesummary
  • getSortedFinitePeptideRatioValues() : ms_customquantitation, ms_ms2quantitation, ms_quantitation
  • getSortUnassigned() : ms_mascotoptions
  • getSource() : ms_quant_integration, ms_umod_xref
  • getSourceSchemaType() : ms_quant_integration, ms_umod_xref
  • getSpecGroup() : ms_umod_specificity
  • getSpecGroupSchemaType() : ms_umod_specificity
  • getSpeciesFile() : ms_taxonomyrules
  • getSpeciesFormatRegex() : ms_taxonomyrules
  • getSpecificity() : ms_quant_localdef, ms_umod_modification
  • getSpecificityBySite() : ms_umod_modification
  • getSpecificityBySiteAndPosition() : ms_umod_modification
  • getSpecificitySchemaType() : ms_quant_localdef, ms_umod_modification
  • getSpectralLibraryDisplayOption() : ms_distiller_data_search
  • getSpectraPerLibraryBlock() : ms_mascotoptions
  • getSpectrumViewerColourSchemeNames() : ms_mascotoptions
  • getSpectrumViewerColourSchemeString() : ms_mascotoptions
  • getSpectrumViewerDefaultColourSchemeName() : ms_mascotoptions
  • getSplitDataFileSize() : ms_mascotoptions
  • getSplitNumberOfQueries() : ms_mascotoptions
  • getSpoofableUsers() : ms_session
  • getSrcDatabaseRule() : ms_taxonomyrules
  • getSrcQueryAndFileIdForMultiFile() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getSrcRank() : ms_peptidesummary
  • getSrcSection() : ms_peptidesummary
  • getStage() : ms_http_client_search
  • getStandardDeviation() : ms_protein_quant_ratio
  • getStandardError() : ms_protein_quant_ratio
  • getStart() : ms_fragment
  • getStartDate() : ms_license
  • getStartIndex() : ms_xic
  • getStartScanId() : ms_xic
  • getStatsInformation() : ms_spectral_lib_file
  • getStatus() : ms_http_client_search, ms_ms1quant_match_ratio, ms_ms1quant_peptide_status, ms_ms1quant_time_align, ms_progress_info
  • getStatusAsText() : ms_ms1quant_time_align
  • getStatusList() : ms_ms1quant_match_ratio
  • getStatusMsg() : ms_distiller_search_status
  • getStrategy() : ms_crosslinking_method
  • getStrategySchemaType() : ms_crosslinking_method
  • getStreamNumber() : ms_distiller_data_quant
  • getStrFile() : ms_taxonomyrules
  • getStringIons1() : ms_inputquery
  • getStringIons2() : ms_inputquery
  • getStringIons3() : ms_inputquery
  • getStringParam() : ms_group, ms_session, ms_user
  • getStringParams() : ms_security_task
  • getStringTitle() : ms_inputquery
  • getStrRule() : ms_taxonomyrules
  • getSUBCLUSTER() : ms_searchparams
  • getSubClusterID() : ms_clusterparams
  • getSubClusterMaxCPU() : ms_clusterparams
  • getSubmitTime() : ms_distiller_search_status
  • getSubproject() : ms_distiller_master_project
  • getSubProjectToFractionMap() : ms_ms1quant_time_align
  • getSubsearch() : ms_distiller_master_search
  • getSubtaskProgress() : ms_progress_info
  • getSuffixRemove() : ms_taxonomyrules
  • getSummary() : ms_ms1quantitation
  • getSummarySection() : ms_mascotresfile_dat
  • getSummedModsNlStr() : ms_peptide
  • getSummedModsStr() : ms_ms1quant_match_component, ms_peptide
  • getSVGSpectrumSwitch() : ms_mascotoptions
  • getSymbol() : ms_quant_element, ms_umod_elemref
  • getSymbolSchemaType() : ms_quant_element, ms_umod_elemref
  • getSystemError() : ms_http_helper_return
  • getTag() : ms_inputquery
  • getTagDeltaRangeEnd() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getTagDeltaRangeStart() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getTagEnd() : ms_mascotresults
  • getTagSeries() : ms_mascotresults
  • getTagStart() : ms_mascotresults
  • getTagString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getTARGET_FDR_PERCENT() : ms_searchparams
  • getTargetFDR() : ms_distiller_data_search, ms_mascotresults_params
  • getTargetFDRPercentage() : ms_mascotoptions
  • getTargetFDRStr() : ms_distiller_data_search
  • getTargetFDRType() : ms_distiller_data_search, ms_mascotresults_params
  • getTask() : ms_security_tasks
  • getTaskFromID() : ms_security_tasks
  • getTaskId() : ms_distiller_data_quant, ms_distiller_data_search, ms_distiller_search_status, ms_distiller_subsearch
  • getTasks() : ms_security
  • getTaxBrowserUrl() : ms_mascotoptions
  • getTaxIDArray() : ms_taxonomytree
  • getTaxonomy() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getTAXONOMY() : ms_searchparams
  • getTaxonomyParseRuleIndex() : ms_databaseoptions
  • getTaxonomyRules() : ms_datfile
  • getTerminalResiduesString() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • getTestDirectory() : ms_mascotoptions
  • getText() : ms_umod_xref
  • getTextSchemaType() : ms_umod_xref
  • getThreadProcessorID() : ms_dbprocessors
  • getThreeLetter() : ms_umod_aminoacid
  • getThreeLetterSchemaType() : ms_umod_aminoacid
  • getThresholdForFDRAboveHomology() : ms_mascotresults
  • getThresholdForFDRAboveIdentity() : ms_mascotresults
  • getTimeAlignmentAlgorithm() : ms_quant_replicate
  • getTimeAlignmentAlgorithmSchemaType() : ms_quant_replicate
  • getTimeAlignmentData() : ms_ms1quantitation
  • getTimeout() : ms_session
  • getTimeParam() : ms_session
  • getTitle() : ms_distiller_search_status, ms_distiller_subsearch, ms_enzyme, ms_fragmentationrules, ms_modification, ms_quant_localdef, ms_taxonomychoice, ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification, ms_unigene_entry
  • getTitleSchemaType() : ms_quant_localdef, ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • getTOL() : ms_searchparams
  • getToleranceInDa() : ms_libraryoptions
  • getToleranceInDalton() : ms_mascotresults
  • getToleranceInPPM() : ms_libraryoptions
  • getTOLU() : ms_searchparams
  • getTotal() : ms_progress_info
  • getTotalBytes() : ms_http_helper_progress
  • getTotalIntensity() : ms_ms1quant_charge_state
  • getTotalIntensitySchemaType() : ms_quant_quality
  • getTotalIntensityThreshold() : ms_quant_quality
  • getTotalIntensityThresholdSchemaType() : ms_quant_quality
  • getTotalIonsIntensity() : ms_inputquery
  • getTotalSeriesOutput() : ms_fragmentationrules
  • getTreeClusterNodes() : ms_mascotresults, ms_peptidesummary
  • getType() : ms_distiller_sub_project, ms_quant_correction, ms_quant_protocol, ms_security_task, ms_wwwentry
  • getTypeSchemaType() : ms_quant_correction
  • getUnassigned() : ms_mascotresults
  • getUnassignedIsBold() : ms_mascotresults
  • getUnassignedShowCheckbox() : ms_mascotresults
  • getUnigeneForAccession() : ms_unigene
  • getUnigeneIndexFile() : ms_mascotresults_params
  • getUniGeneOptions() : ms_datfile
  • getUnimod() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getUnimodXL() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getUniqueJobStartNumber() : ms_mascotoptions
  • getUniquePepseqSchemaType() : ms_quant_quality
  • getUniqueTaskID() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • getUnixDirPerm() : ms_mascotoptions
  • getUnixWebUserGroup() : ms_mascotoptions
  • getUnmatchedAnnotationStr() : ms_spectral_lib_peak
  • getUnmatchedMasses() : ms_protein
  • getUnmodified() : ms_quant_modgroup
  • getUnmodifiedSchemaType() : ms_quant_modgroup
  • getUnnormalisedAveragePeptideRatio() : ms_customquantitation
  • getUnZipped() : ms_zip
  • getUnZippedLen() : ms_zip
  • getUrl() : ms_umod_xref
  • getUrlSchemaType() : ms_umod_xref
  • getUser() : ms_security
  • getUserAgent() : ms_connection_settings
  • getUSEREMAIL() : ms_searchparams
  • getUSERField() : ms_searchparams
  • getUserFromID() : ms_security
  • getUSERID() : ms_searchparams
  • getUserID() : ms_session
  • getUSERNAME() : ms_searchparams
  • getUserName() : ms_session
  • getUsernameOfPoster() : ms_umod_modification
  • getUsernameOfPosterSchemaType() : ms_umod_modification
  • getUserType() : ms_session, ms_user
  • getUseSessionCookies() : ms_security_options
  • getUseTimeShift() : ms_xic
  • getVal() : ms_imputation_missing_val
  • getValue() : ms_crosslinking_accession, ms_crosslinking_monolink, ms_http_client_mime, ms_ms1quant_match_ratio, ms_peptide_quant_ratio, ms_protein_quant_ratio, ms_xml_parameter
  • getValueFromKey() : ms_tinycdb
  • getValueSchemaType() : ms_crosslinking_accession, ms_crosslinking_monolink, ms_crosslinking_parameter, ms_quant_parameter, ms_xml_parameter
  • getVarModIdxFrom() : ms_linker_site
  • getVarModIdxOfLinkedSite() : ms_linker_site_vector
  • getVarModIdxTo() : ms_linker_site
  • getVarMods() : ms_aahelper, ms_ms1quant_match
  • getVarModsDelta() : ms_searchparams
  • getVarModsName() : ms_searchparams
  • getVarModsNeutralLoss() : ms_searchparams
  • getVarModsNeutralLosses() : ms_searchparams
  • getVarModsPepNeutralLoss() : ms_searchparams
  • getVarModsReqPepNeutralLoss() : ms_searchparams
  • getVarModsStr() : ms_ms1quant_match_component, ms_peptide
  • getVector() : ms_fragmentvector
  • getVerifySessionIPAddress() : ms_security_options
  • getVersion() : ms_http_client
  • getVmemory() : ms_mascotoptions
  • getWeight() : ms_peptide_quant_ratio
  • getWhichAvailableForMascot() : ms_processors
  • getWhichAvailableForMascot2() : ms_processors
  • getWWWOptions() : ms_datfile
  • getXic() : ms_ms1quant_match_component
  • getXicMaxWidth() : ms_quant_integration
  • getXicMaxWidthSchemaType() : ms_quant_integration
  • getXicSmoothing() : ms_quant_integration
  • getXicSmoothingSchemaType() : ms_quant_integration
  • getXicThreshold() : ms_quant_integration
  • getXicThresholdSchemaType() : ms_quant_integration
  • getXmlCode() : ms_ms1quant_match, ms_ms1quant_match_ratio, ms_ms1quant_peptide_status, ms_xic
  • getXMLschemaFilePath() : ms_mascotresfilebase
  • getXref() : ms_umod_modification
  • getXrefSchemaType() : ms_umod_modification
  • getZipped() : ms_zip
  • getZippedLen() : ms_zip
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- h -

  • hasAbsoluteValue() : ms_ms1quant_match_component
  • hasComponent() : ms_ms1quant_match
  • hasCrosslinkingMethod() : ms_peptidesummary
  • hasEnzyme() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • hasFilename() : ms_http_client_mime
  • hasIdentifiedComponent() : ms_ms1quant_match
  • hasIndexes() : ms_xic
  • hasIntensityNormalisation() : ms_ms2quantitation
  • hasINTERNALS() : ms_inputquery, ms_searchparams
  • hasMatchedFraction() : ms_ms1quant_match_component
  • hasMatchedRho() : ms_ms1quant_match_component
  • hasParent() : ms_http_helper_progress
  • hasPasswordExpired() : ms_user
  • hasPeptideRatio() : ms_customquantitation, ms_ms1quant_match, ms_ms2quantitation, ms_quantitation
  • hasPeptideRatioNormalisation() : ms_ms2quantitation
  • hasQuantitation() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • hasQuantMethod() : ms_peptidesummary
  • hasRT() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • haveAccession() : ms_quant_normalisation_protein
  • haveAccessions() : ms_crosslinking_method
  • haveAllChargeStates() : ms_quant_integration, ms_quant_precursor
  • haveAllChargeStatesThreshold() : ms_quant_integration
  • haveAllowElutionShift() : ms_quant_integration, ms_quant_precursor
  • haveAllowMassTimeMatch() : ms_quant_precursor
  • haveApproved() : ms_umod_modification
  • haveAverage() : ms_quant_moverz
  • haveAvgeMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • haveClassification() : ms_umod_specificity
  • haveCode() : ms_umod_neutralloss
  • haveCoefficient() : ms_quant_numerator
  • haveComp() : ms_quant_method
  • haveCompositionString() : ms_umod_composition
  • haveConstrainSearch() : ms_quant_method
  • haveDatabaseName() : ms_crosslinking_accession
  • haveDateTimeModified() : ms_umod_modification
  • haveDateTimePosted() : ms_umod_modification
  • haveDelta() : ms_quant_localdef, ms_umod_modification
  • haveDescription() : ms_crosslinking_method, ms_quant_method, ms_umod_neutralloss, ms_xml_parameter
  • haveElement() : ms_quant_correction
  • haveElutionProfileCorrelationThreshold() : ms_quant_integration
  • haveElutionTimeDelta() : ms_quant_integration
  • haveElutionTimeDeltaUnit() : ms_quant_integration
  • haveExcludeInternalLabel() : ms_quant_multiplex
  • haveExcludeIsobaricFragments() : ms_quant_multiplex
  • haveFileIndex() : ms_quant_component
  • haveFilters() : ms_crosslinking_method
  • haveFlag() : ms_quant_neutralloss, ms_umod_neutralloss
  • haveFraction() : ms_quant_file_index
  • haveFullName() : ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • haveGroupOfPoster() : ms_umod_modification
  • haveHidden() : ms_umod_specificity
  • haveIntegration() : ms_quant_method
  • haveIonIntensityThreshold() : ms_quant_multiplex
  • haveIonSeries() : ms_quant_multiplex
  • haveIsolatedPrecursor() : ms_quant_quality
  • haveIsolatedPrecursorThreshold() : ms_quant_quality
  • haveLinkers() : ms_crosslinking_method
  • haveMassDelta() : ms_quant_integration
  • haveMassDeltaUnit() : ms_quant_integration
  • haveMatchedRho() : ms_quant_integration
  • haveMethod() : ms_quant_integration, ms_quant_normalisation, ms_quant_outliers
  • haveMinimumA1() : ms_quant_quality
  • haveMinIonPairs() : ms_quant_multiplex
  • haveMinNumPeptides() : ms_quant_method
  • haveMinPrecursorCharge() : ms_quant_quality
  • haveMiscNotes() : ms_umod_modification, ms_umod_specificity
  • haveMode() : ms_quant_modgroup
  • haveModFileName() : ms_crosslinking_does_not_pair_with, ms_crosslinking_linker
  • haveModifications() : ms_quant_satellite
  • haveMonoisotopic() : ms_quant_moverz
  • haveMonoMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • haveMoverz() : ms_quant_component
  • haveName() : ms_crosslinking_method, ms_quant_component, ms_quant_method, ms_quant_modgroup, ms_quant_numerator, ms_quant_ratio, ms_xml_parameter
  • haveNew() : ms_quant_isotope
  • haveNormalisation() : ms_quant_method
  • haveNumber() : ms_quant_element, ms_umod_elemref
  • haveNumPeptides() : ms_quant_average
  • haveOld() : ms_quant_isotope
  • haveOutliers() : ms_quant_method
  • havePairsWith() : ms_umod_neutralloss
  • havePepThresholdType() : ms_quant_quality
  • havePepThresholdValue() : ms_quant_quality
  • havePeptides() : ms_quant_normalisation
  • havePosition() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • havePrecursorRange() : ms_quant_integration
  • haveProcessingOptions() : ms_quant_integration
  • haveProteinRatioType() : ms_quant_method
  • haveProteins() : ms_quant_normalisation
  • haveProtocol() : ms_quant_method
  • haveProtScoreType() : ms_quant_method
  • haveQuality() : ms_quant_method
  • haveRecordID() : ms_umod_modification
  • haveReferenceAccession() : ms_quant_average
  • haveReferenceAmount() : ms_quant_average
  • haveReferenceDatabase() : ms_quant_average
  • haveReportDetail() : ms_quant_method
  • haveReporterTol() : ms_quant_reporter
  • haveReporterTolUnit() : ms_quant_reporter
  • haveRequireBoldRed() : ms_quant_method
  • haveRequired() : ms_quant_modgroup, ms_quant_pepneutralloss
  • haveSatellite() : ms_quant_component
  • haveScope() : ms_crosslinking_method
  • haveSelection() : ms_quant_average
  • haveSequence() : ms_quant_normalisation_peptide
  • haveSettings() : ms_crosslinking_method
  • haveShift() : ms_quant_correction
  • haveShowSubSets() : ms_quant_method
  • haveSigThresholdValue() : ms_quant_method
  • haveSimpleRatio() : ms_quant_integration
  • haveSite() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • haveSource() : ms_quant_integration, ms_umod_xref
  • haveSpecGroup() : ms_umod_specificity
  • haveStrategy() : ms_crosslinking_method
  • haveSymbol() : ms_quant_element, ms_umod_elemref
  • haveText() : ms_umod_xref
  • haveThreeLetter() : ms_umod_aminoacid
  • haveTimeAlignmentAlgorithm() : ms_quant_replicate
  • haveTitle() : ms_quant_localdef, ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • haveTotalIntensity() : ms_quant_quality
  • haveTotalIntensityThreshold() : ms_quant_quality
  • haveType() : ms_quant_correction
  • haveUniquePepseq() : ms_quant_quality
  • haveUrl() : ms_umod_xref
  • haveUsernameOfPoster() : ms_umod_modification
  • haveValue() : ms_crosslinking_accession
  • haveXicMaxWidth() : ms_quant_integration
  • haveXicSmoothing() : ms_quant_integration
  • haveXicThreshold() : ms_quant_integration
  • httpBufferedClose() : ms_http_helper
  • httpBufferedGetString() : ms_http_helper
  • httpBufferedOpen() : ms_http_helper
  • httpError() : ms_http_helper_return
  • httpGetFile() : ms_http_helper
  • httpGetHeader() : ms_http_helper
  • httpGetString() : ms_http_helper
  • httpPostFile() : ms_http_helper
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- i -

  • identityMatrix() : ms_matrix
  • impute() : ms_imputation, ms_imputation_average_value, ms_imputation_fixed_value, ms_imputation_knn, ms_imputation_missforest
  • includeIndexSection() : ms_msr2dat28
  • includeProteinPeptideRatioKeys() : ms_ms2quantitation
  • includeQuerySectionIonsLines() : ms_msr2dat28
  • inErrorTolerant() : ms_modification, ms_umod_specificity
  • initGroupChargeStates() : ms_ms1quantitation
  • initialiseBaseSettings() : ms_quantitation
  • inLongList() : ms_modification, ms_umod_specificity
  • inShortList() : ms_modification, ms_umod_specificity
  • isAbortSet() : ms_http_helper_progress
  • isAccountEnabled() : ms_user
  • isActive() : ms_databaseoptions
  • isAllChargeStates() : ms_quant_integration, ms_quant_precursor
  • isAllowElutionShift() : ms_quant_integration, ms_quant_precursor
  • isAllowMassTimeMatch() : ms_quant_precursor
  • isAlwaysCreateDat28ResultsFile() : ms_mascotoptions
  • isAlwaysEnableAutoDecoySearch() : ms_mascotoptions
  • isApproved() : ms_umod_modification
  • isASimilarProtein() : ms_protein
  • isAutoSelectCharge() : ms_mascotoptions
  • isAvailable() : ms_parserule
  • isAverageProtocol() : ms_ms1quantitation
  • isBackboneSeries() : ms_fragmentationrules
  • isBreaking() : ms_progress_info
  • isCharged2Plus() : ms_fragmentationrules
  • isCharged3Plus() : ms_fragmentationrules
  • isComplete() : ms_http_helper_progress
  • isComponentIdentified() : ms_ms1quant_match_component
  • isConcatRefFileLines() : ms_taxonomyrules
  • isConstrainSearch() : ms_quant_method
  • isConversionSupported() : ms_msr2dat28
  • isCreateLegacyModAndSubstitutionFiles() : ms_mascotoptions
  • isCreating() : ms_tinycdb
  • isCronEnabled() : ms_cronoptions
  • isCTerminal() : ms_fragment
  • isDatabaseTypeAvailable() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • isDataCached() : ms_ms1quantitation, ms_peptidesummary
  • isDayOfMonth() : ms_cronjob
  • isDayOfWeek() : ms_cronjob
  • isDBLevelTaxId() : ms_taxonomyrules
  • isDefaultTargetFDRPercentage() : ms_mascotoptions
  • isDirectory() : ms_fileutilities
  • isEmailErrorsEnabled() : ms_mascotoptions
  • isEmailUsersEnabled() : ms_mascotoptions
  • isEmPAIallowed() : ms_mascotresults
  • isEnabled() : ms_clusterparams, ms_cronjob, ms_taxonomyrules
  • isErrorTolerant() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • isExcluded() : ms_peptide_quant_ratio
  • isExcludeInternalLabel() : ms_quant_multiplex
  • isExcludeIsobaricFragments() : ms_quant_multiplex
  • isFastaPermitted() : ms_security_tasks, ms_session
  • isFileWritable() : ms_fileutilities
  • isFlag() : ms_quant_neutralloss, ms_umod_neutralloss
  • isForkForUnixApache() : ms_mascotoptions
  • isFromAlpha() : ms_fragment
  • isFromBeta() : ms_fragment
  • isFromRefFile() : ms_taxonomyrules
  • isFromSubstitutions() : ms_modfile
  • isGeneratedMonoLinker() : ms_modification
  • isHidden() : ms_modification, ms_umod_specificity
  • isHitRatioExcluded() : ms_ms1quant_match
  • isHitRatioOutlier() : ms_ms1quant_match
  • isHitRatioUsedForAverage() : ms_ms1quant_match
  • isHour() : ms_cronjob
  • isImmonium() : ms_fragment
  • isIncluded() : ms_ms1quant_match_ratio
  • isIncludedIn() : ms_taxonomytree
  • isIndependent() : ms_enzyme
  • isIndexSectionIncluded() : ms_msr2dat28
  • isInfinite() : ms_peptide_quant_ratio
  • isInIgnoreDupeAccessionList() : ms_mascotoptions
  • isInternal() : ms_fragment
  • isIsolatedPrecursor() : ms_quant_quality
  • isIteratePMFIntensities() : ms_mascotoptions
  • isLabelAll() : ms_mascotoptions
  • isLicenseValid() : ms_license
  • isLocalRefFile() : ms_databaseoptions
  • isLockMemory() : ms_databaseoptions
  • isLogicalCPUAvailableForMascot() : ms_processors
  • isLogNormal() : ms_protein_quant_ratio
  • isLoopLinker() : ms_modification
  • isMatchedToCalculatedPeak() : ms_spectral_lib_peak
  • isMatchOppositeCrosslinkPairs() : ms_mascotoptions
  • isMemoryMapFiles() : ms_databaseoptions
  • isMethodCompatible() : ms_quant_method
  • isMinute() : ms_cronjob
  • isMissing() : ms_imputation_missing_val, ms_peptide_quant_ratio, ms_protein_quant_ratio
  • isMitochondrialTranslation() : ms_taxonomyrules
  • isMonthOfYear() : ms_cronjob
  • isMoveOldDbToOldDir() : ms_mascotoptions
  • isMSMS() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • isNA() : ms_mascotresults
  • isNeutralLossSeries() : ms_fragmentationrules
  • isNil() : ms_peptide_quant_key
  • isNoneFound() : ms_enzymefile
  • isNTerminal() : ms_fragment
  • isOk() : ms_http_helper_return
  • isOpenForReading() : ms_tinycdb
  • isPeptideComponentMatch() : ms_peptidesummary
  • isPeptideModificationMatch() : ms_peptidesummary
  • isPeptideQualityOK() : ms_quant_helper
  • isPeptideQuantifiable() : ms_quant_helper
  • isPeptideRatioExcluded() : ms_customquantitation, ms_ms2quantitation, ms_quantitation
  • isPeptideUnique() : ms_mascotresults, ms_peptidesummary, ms_proteinsummary
  • isPercolator() : ms_mascotoptions
  • isPercolatorUseProteins() : ms_mascotoptions
  • isPercolatorUseRT() : ms_mascotoptions
  • isPermitted() : ms_security_task, ms_security_tasks, ms_session
  • isPermitted_double() : ms_security_task, ms_security_tasks, ms_session
  • isPermitted_long() : ms_security_task, ms_security_tasks, ms_session
  • isPermitted_string() : ms_security_task, ms_security_tasks, ms_session
  • isPMF() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • isPMFMixture() : ms_protein
  • isPmfQueryUsed() : ms_proteinsummary
  • isPossibleToCreate() : ms_tinycdb
  • isPrecursorNL() : ms_fragment
  • isPrimaryLogicalProcessor() : ms_processors
  • isPrivacyEnabled() : ms_umod_modification
  • isPrivate() : ms_umod_modification
  • isProcessAffinitySupported() : ms_processors
  • isQuerySectionIonsLinesIncluded() : ms_msr2dat28
  • isReferenceUserSelected() : ms_ms1quant_average_results
  • isRegular() : ms_fragment
  • isRemoveOldIndexFiles() : ms_mascotoptions
  • isReportDetail() : ms_quant_method
  • isRequireBoldRed() : ms_mascotoptions, ms_quant_method
  • isRequired() : ms_quant_modgroup, ms_quant_pepneutralloss
  • isResidueModified() : ms_masses, ms_modification
  • isSame() : ms_masses
  • isSameAs() : ms_umod_composition, ms_umod_modification, ms_umod_specificity, ms_umod_xref
  • isSamePeptideStr() : ms_peptide
  • isSameSummedModsStr() : ms_peptide
  • isSameVarModsStr() : ms_peptide
  • isSaveEveryLastQueryAsc() : ms_mascotoptions
  • isSaveLastQueryAsc() : ms_mascotoptions
  • isSectionAvailable() : ms_clusterparams, ms_cronoptions, ms_databases, ms_libraryoptions, ms_mascotoptions, ms_parseoptions, ms_processoroptions, ms_taxonomyrules, ms_unigeneoptions, ms_wwwoptions
  • isSecurityEnabled() : ms_security_options, ms_session
  • isSemiSpecific() : ms_enzyme
  • isSeriesUsed() : ms_fragmentationrules
  • isSet() : ms_ms1quant_match_ratio
  • isShowAllFromErrorTolerant() : ms_mascotoptions
  • isShowSubsets() : ms_mascotoptions
  • isSignificant() : ms_protein_quant_ratio
  • isSimilarProtein() : ms_protein
  • isSimpleRatio() : ms_quant_integration
  • isSinglyCharged() : ms_fragmentationrules
  • isSpeciesDescendantOf() : ms_taxonomytree
  • isSQ() : ms_mascotresfile_dat, ms_mascotresfile_msr, ms_mascotresfilebase
  • isStarted() : ms_http_helper_progress
  • isStoreModPermutations() : ms_mascotoptions
  • isSubstitution() : ms_modification
  • isSuspectAssignment() : ms_spectral_lib_peak
  • isTargetFDR() : ms_distiller_data_search
  • isTaskExists() : ms_security, ms_security_tasks
  • isThreadedLogicalProcessor() : ms_processors
  • isTimedOut() : ms_session
  • isTotalIntensity() : ms_quant_quality
  • isUnigene() : ms_protein
  • isUniquePepseq() : ms_quant_quality
  • isUnixDirPermDefined() : ms_mascotoptions
  • isUpdateScoreFromPepScores() : ms_protein
  • isUsedForAverage() : ms_ms1quant_match_ratio
  • isUseHTTPProxyForFTP() : ms_connection_settings, ms_mascotoptions
  • isUseHTTPProxyForHTTPS() : ms_connection_settings, ms_mascotoptions
  • isUsePeptideSummary() : ms_mascotresults_params
  • isUseProcessesNotThreads() : ms_processors
  • isUserExists() : ms_security
  • isUserInGroup() : ms_group
  • isValid() : ms_enzyme, ms_errors, ms_errs, ms_fragmentationrules, ms_ms1quant_match_ratio, ms_spectral_lib_peak
  • isZero() : ms_matrix
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- l -

  • loadCdbFile() : ms_ms1quantitation, ms_ms2quantitation
  • loadCdbFiles() : ms_ms2quantitation
  • loadFromFile() : ms_security_tasks
  • loadXml() : ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list
  • loadXmlFile() : ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list, ms_ms1quant_time_align, ms_ms1quantitation
  • loadXmlStream() : ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list
  • logContents() : ms_matrix
  • logMessage() : ms_loggingmonitor
  • logout() : ms_http_client_session
  • logTransform() : ms_quant_stats
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- m -

  • makeExists() : ms_tinycdb
  • mascotresfile() : ms_peptidesummary
  • meanCentre() : ms_quant_stats
  • medianStandardErrorCorrection() : ms_quant_stats
  • mergeQuantitationResults() : ms_ms1quantitation
  • messageSourceAsText() : ms_loggingmonitor
  • ms_aahelper() : ms_aahelper
  • ms_buffer_logger() : ms_buffer_logger
  • ms_clusterparams() : ms_clusterparams
  • ms_computeraddress() : ms_computeraddress
  • ms_connection_settings() : ms_connection_settings
  • ms_cronjob() : ms_cronjob
  • ms_cronoptions() : ms_cronoptions
  • ms_crosslinking_accession() : ms_crosslinking_accession
  • ms_crosslinking_accessions() : ms_crosslinking_accessions
  • ms_crosslinking_configfile() : ms_crosslinking_configfile
  • ms_crosslinking_does_not_pair_with() : ms_crosslinking_does_not_pair_with
  • ms_crosslinking_filters() : ms_crosslinking_filters
  • ms_crosslinking_linker() : ms_crosslinking_linker
  • ms_crosslinking_linkers() : ms_crosslinking_linkers
  • ms_crosslinking_method() : ms_crosslinking_method
  • ms_crosslinking_monolink() : ms_crosslinking_monolink
  • ms_crosslinking_parameter() : ms_crosslinking_parameter
  • ms_crosslinking_parameters() : ms_crosslinking_parameters
  • ms_crosslinking_scope() : ms_crosslinking_scope
  • ms_crosslinking_settings() : ms_crosslinking_settings
  • ms_customproperty() : ms_customproperty
  • ms_customquantitation() : ms_customquantitation
  • ms_databaseoptions() : ms_databaseoptions
  • ms_databases() : ms_databases
  • ms_datfile() : ms_datfile
  • ms_dbprocessors() : ms_dbprocessors
  • ms_distiller_data() : ms_distiller_data
  • ms_distiller_data_search() : ms_distiller_data_search
  • ms_distiller_master_project() : ms_distiller_master_project
  • ms_distiller_search_status_list() : ms_distiller_search_status_list
  • ms_enzyme() : ms_enzyme
  • ms_enzymefile() : ms_enzymefile
  • ms_errors() : ms_errors
  • ms_errs() : ms_errs
  • ms_file_logger() : ms_file_logger
  • ms_fileutilities() : ms_fileutilities
  • ms_fitexy_result() : ms_fitexy_result
  • ms_fragment() : ms_fragment
  • ms_fragmentationrules() : ms_fragmentationrules
  • ms_fragmentvector() : ms_fragmentvector
  • ms_fragrulesfile() : ms_fragrulesfile
  • ms_group() : ms_group
  • ms_http_client() : ms_http_client
  • ms_http_client_search() : ms_http_client_search
  • ms_http_client_session() : ms_http_client_session
  • ms_http_helper() : ms_http_helper
  • ms_http_helper_handles() : ms_http_helper_handles
  • ms_http_helper_progress() : ms_http_helper_progress
  • ms_http_helper_return() : ms_http_helper_return
  • ms_imputation() : ms_imputation
  • ms_imputation_method() : ms_imputation_method
  • ms_imputation_missing_val() : ms_imputation_missing_val
  • ms_imputation_peptide_data() : ms_imputation_peptide_data
  • ms_inputquery() : ms_inputquery
  • ms_libraryoptions() : ms_libraryoptions
  • ms_license() : ms_license
  • ms_linker_site() : ms_linker_site
  • ms_linker_site_vector() : ms_linker_site_vector
  • ms_log() : ms_log
  • ms_logger() : ms_logger
  • ms_loggingmonitor() : ms_loggingmonitor
  • ms_mascotfiles() : ms_mascotfiles
  • ms_mascotoptions() : ms_mascotoptions
  • ms_mascotresfile_dat() : ms_mascotresfile_dat
  • ms_mascotresfile_msr() : ms_mascotresfile_msr
  • ms_mascotresfilebase() : ms_mascotresfilebase
  • ms_mascotresults() : ms_mascotresults
  • ms_mascotresults_params() : ms_mascotresults_params
  • ms_masses() : ms_masses
  • ms_matrix() : ms_matrix
  • ms_modfile() : ms_modfile
  • ms_modification() : ms_modification
  • ms_modvector() : ms_modvector
  • ms_ms1quant_average_results() : ms_ms1quant_average_results
  • ms_ms1quant_charge_state() : ms_ms1quant_charge_state
  • ms_ms1quant_match() : ms_ms1quant_match
  • ms_ms1quant_match_component() : ms_ms1quant_match_component
  • ms_ms1quant_match_range() : ms_ms1quant_match_range
  • ms_ms1quant_match_ratio() : ms_ms1quant_match_ratio
  • ms_ms1quant_peptide_status() : ms_ms1quant_peptide_status
  • ms_ms1quant_time_align() : ms_ms1quant_time_align
  • ms_ms1quant_time_align_limits() : ms_ms1quant_time_align_limits
  • ms_ms1quantitation() : ms_ms1quantitation
  • ms_ms2quantitation() : ms_ms2quantitation
  • ms_msr2dat28() : ms_msr2dat28
  • ms_obofile() : ms_obofile
  • ms_parseoptions() : ms_parseoptions
  • ms_parserule() : ms_parserule
  • ms_parserule_plus() : ms_parserule_plus
  • ms_peptide() : ms_peptide
  • ms_peptide_quant_key() : ms_peptide_quant_key
  • ms_peptide_quant_key_vector() : ms_peptide_quant_key_vector
  • ms_peptide_quant_ratio() : ms_peptide_quant_ratio
  • ms_peptidesummary() : ms_peptidesummary
  • ms_processoroptions() : ms_processoroptions
  • ms_processors() : ms_processors
  • ms_progress_info() : ms_progress_info
  • ms_protein() : ms_protein
  • ms_protein_quant_ratio() : ms_protein_quant_ratio
  • ms_proteinsummary() : ms_proteinsummary
  • ms_quant_average() : ms_quant_average
  • ms_quant_component() : ms_quant_component
  • ms_quant_composition() : ms_quant_composition
  • ms_quant_configfile() : ms_quant_configfile
  • ms_quant_correction() : ms_quant_correction
  • ms_quant_element() : ms_quant_element
  • ms_quant_file_index() : ms_quant_file_index
  • ms_quant_helper() : ms_quant_helper
  • ms_quant_integration() : ms_quant_integration
  • ms_quant_isotope() : ms_quant_isotope
  • ms_quant_localdef() : ms_quant_localdef
  • ms_quant_method() : ms_quant_method
  • ms_quant_modgroup() : ms_quant_modgroup
  • ms_quant_moverz() : ms_quant_moverz
  • ms_quant_multiplex() : ms_quant_multiplex
  • ms_quant_neutralloss() : ms_quant_neutralloss
  • ms_quant_normalisation() : ms_quant_normalisation
  • ms_quant_normalisation_peptide() : ms_quant_normalisation_peptide
  • ms_quant_normalisation_peptides() : ms_quant_normalisation_peptides
  • ms_quant_normalisation_protein() : ms_quant_normalisation_protein
  • ms_quant_normalisation_proteins() : ms_quant_normalisation_proteins
  • ms_quant_numerator() : ms_quant_numerator
  • ms_quant_outliers() : ms_quant_outliers
  • ms_quant_parameter() : ms_quant_parameter
  • ms_quant_parameters() : ms_quant_parameters
  • ms_quant_pepneutralloss() : ms_quant_pepneutralloss
  • ms_quant_precursor() : ms_quant_precursor
  • ms_quant_protocol() : ms_quant_protocol
  • ms_quant_quality() : ms_quant_quality
  • ms_quant_ratio() : ms_quant_ratio
  • ms_quant_replicate() : ms_quant_replicate
  • ms_quant_reporter() : ms_quant_reporter
  • ms_quant_satellite() : ms_quant_satellite
  • ms_quant_specificity() : ms_quant_specificity
  • ms_quant_unmodified() : ms_quant_unmodified
  • ms_searchparams() : ms_searchparams
  • ms_security() : ms_security
  • ms_security_options() : ms_security_options
  • ms_security_task() : ms_security_task
  • ms_security_tasks() : ms_security_tasks
  • ms_session() : ms_session
  • ms_shapiro_wilk() : ms_shapiro_wilk
  • ms_spectral_lib_entry() : ms_spectral_lib_entry
  • ms_spectral_lib_file() : ms_spectral_lib_file
  • ms_spectral_lib_peak() : ms_spectral_lib_peak
  • ms_spectral_lib_peak_list() : ms_spectral_lib_peak_list
  • ms_stdout_logger() : ms_stdout_logger
  • ms_taxnodesfiles() : ms_taxnodesfiles
  • ms_taxonomychoice() : ms_taxonomychoice
  • ms_taxonomyfile() : ms_taxonomyfile
  • ms_taxonomyrules() : ms_taxonomyrules
  • ms_taxonomytree() : ms_taxonomytree
  • ms_taxspeciesfiles() : ms_taxspeciesfiles
  • ms_tinycdb() : ms_tinycdb
  • ms_treecluster() : ms_treecluster
  • ms_umod_aminoacid() : ms_umod_aminoacid
  • ms_umod_composition() : ms_umod_composition
  • ms_umod_configfile() : ms_umod_configfile
  • ms_umod_element() : ms_umod_element
  • ms_umod_elemref() : ms_umod_elemref
  • ms_umod_modbrick() : ms_umod_modbrick
  • ms_umod_modification() : ms_umod_modification
  • ms_umod_neutralloss() : ms_umod_neutralloss
  • ms_umod_specificity() : ms_umod_specificity
  • ms_umod_xref() : ms_umod_xref
  • ms_unigene() : ms_unigene
  • ms_unigene_entry() : ms_unigene_entry
  • ms_unigeneoptions() : ms_unigeneoptions
  • ms_user() : ms_user
  • ms_wwwentry() : ms_wwwentry
  • ms_wwwoptions() : ms_wwwoptions
  • ms_xic() : ms_xic
  • ms_xml_parameter() : ms_xml_parameter
  • ms_xml_parameters() : ms_xml_parameters
  • ms_zip() : ms_zip
  • multiplyByRow() : ms_matrix
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- n -

  • normalCriticalValue() : ms_quant_stats
  • normalCumulativeProbability() : ms_quant_stats
  • normaliseIntensities() : ms_ms2quantitation
  • normalisePeptideRatios() : ms_ms2quantitation
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- o -

  • onLogMessage() : ms_buffer_logger, ms_file_logger, ms_logger, ms_stdout_logger
  • openIndexFile() : ms_tinycdb
  • openQuantitationCdbResults() : ms_ms1quantitation
  • openQuantitationXmlResults() : ms_ms1quantitation
  • operator bool() : ms_http_helper_return
  • operator!=() : ms_matrix, ms_peptide_quant_key, ms_protein_quant_ratio
  • operator*() : ms_matrix
  • operator<() : ms_peptide_quant_key
  • operator<=() : ms_peptide_quant_key
  • operator=() : ms_aahelper, ms_clusterparams, ms_computeraddress, ms_connection_settings, ms_cronjob, ms_cronoptions, ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_configfile, ms_crosslinking_does_not_pair_with, ms_crosslinking_filters, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_crosslinking_parameter, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_databaseoptions, ms_databases, ms_datfile, ms_dbprocessors, ms_distiller_data, ms_distiller_master_project, ms_distiller_search_status_list, ms_enzyme, ms_enzymefile, ms_fragment, ms_fragmentationrules, ms_fragmentvector, ms_fragrulesfile, ms_http_client, ms_http_client_search, ms_http_client_session, ms_http_helper, ms_libraryoptions, ms_license, ms_linker_site, ms_linker_site_vector, ms_mascotfiles, ms_mascotoptions, ms_mascotresults_params, ms_masses, ms_modfile, ms_modification, ms_modvector, ms_obofile, ms_parseoptions, ms_parserule, ms_parserule_plus, ms_peptide, ms_peptide_quant_key, ms_peptide_quant_key_vector, ms_peptide_quant_ratio, ms_processoroptions, ms_processors, ms_protein, ms_protein_quant_ratio, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_configfile, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_parameter, ms_quant_parameters, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_security_options, ms_spectral_lib_entry, ms_spectral_lib_peak, ms_spectral_lib_peak_list, ms_taxnodesfiles, ms_taxonomychoice, ms_taxonomyfile, ms_taxonomyrules, ms_taxonomytree, ms_taxspeciesfiles, ms_treecluster, ms_umod_aminoacid, ms_umod_composition, ms_umod_configfile, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_unigeneoptions, ms_wwwentry, ms_wwwoptions, ms_xml_parameter, ms_zip
  • operator==() : ms_matrix, ms_peptide_quant_key, ms_protein_quant_ratio
  • operator>() : ms_peptide_quant_key
  • operator>=() : ms_peptide_quant_key
  • operator[]() : ms_matrix
  • outputKeepAlive() : ms_mascotresfilebase
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- p -

  • params() : ms_mascotresfilebase
  • parseCommandLineArgumentString() : ms_fileutilities
  • parseLine() : ms_obofile
  • poissonDensity() : ms_quant_stats
  • pop() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • prepareToCreate() : ms_tinycdb
  • proxyTypeStringToEnum() : ms_connection_settings
  • proxyTypeToString() : ms_connection_settings
  • push() : ms_linker_site_vector, ms_peptide_quant_key_vector
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- r -

  • read_buffer() : ms_crosslinking_configfile, ms_enzymefile, ms_fragrulesfile, ms_quant_configfile, ms_taxonomyfile, ms_umod_configfile
  • read_file() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile, ms_license, ms_masses, ms_modfile, ms_quant_configfile, ms_taxonomyfile, ms_umod_configfile
  • readResultCounters() : ms_ms1quantitation
  • removeAllTasks() : ms_security_tasks
  • removeCombinedReportRatio() : ms_ms2quantitation
  • removeComponent() : ms_ms1quant_match
  • removeDuplicateIndexes() : ms_imputation_method
  • removeIntensityNormalisationBase() : ms_ms2quantitation
  • removeIntensityNormalisationBases() : ms_ms2quantitation
  • removeLogEventsHandler() : ms_loggingmonitor
  • removeMatch() : ms_ms1quantitation
  • removePeptideQuantKey() : ms_customquantitation
  • removePeptideRatio() : ms_customquantitation
  • removePeptideRatioNormalisationBase() : ms_quantitation
  • removePeptideRatioNormalisationBases() : ms_quantitation
  • removePermittedTask() : ms_group
  • removeReportRatioInFile() : ms_ms2quantitation
  • removeSubtask() : ms_progress_info
  • removeTask() : ms_security_tasks
  • resetKeepAlive() : ms_mascotresfilebase
  • resfileType() : ms_mascotresfilebase
  • resize() : ms_matrix
  • retentionTime() : ms_imputation_peptide_data
  • rewind() : ms_msr2dat28
  • rowMatrix() : ms_matrix
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- s -

  • save_buffer() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • save_file() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile, ms_masses, ms_modfile, ms_quant_configfile, ms_taxonomyfile, ms_umod_configfile
  • saveAs() : ms_spectral_lib_file
  • saveBoolParam() : ms_session
  • saveCdbFile() : ms_ms1quantitation, ms_ms2quantitation
  • saveDoubleParam() : ms_session
  • saveFileOffsetForKey() : ms_tinycdb
  • saveIntForKey() : ms_tinycdb
  • saveIntParam() : ms_session
  • saveLongParam() : ms_session
  • saveStringParam() : ms_group, ms_session, ms_user
  • saveTimeParam() : ms_session
  • saveToFile() : ms_security_tasks
  • saveToString() : ms_masses, ms_modfile
  • saveValueForKey() : ms_tinycdb
  • saveXmlFile() : ms_ms1quant_time_align, ms_ms1quantitation, ms_ms2quantitation
  • serverVersionNewerOrSameAs() : ms_distiller_data_search
  • sessionId() : ms_http_client_search
  • set() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • setAbort() : ms_http_helper_progress
  • setAccession() : ms_quant_normalisation_protein
  • setAccessionParseRuleIndex() : ms_databaseoptions
  • setAccessionRefParseRuleIndex() : ms_databaseoptions
  • setAccessions() : ms_crosslinking_method
  • setAccessRights() : ms_fileutilities
  • setAccFromSpeciesLine() : ms_taxonomyrules
  • setAccountEnabled() : ms_user
  • setActive() : ms_databaseoptions
  • setAlgorithmName() : ms_ms1quant_time_align
  • setAllChargeStates() : ms_quant_integration
  • setAllChargeStatesThreshold() : ms_quant_integration
  • setAllowElutionShift() : ms_quant_integration
  • setAllowMassTimeMatch() : ms_quant_precursor
  • setAlwaysCreateDat28ResultsFile() : ms_mascotoptions
  • setAlwaysEnableAutoDecoySearch() : ms_mascotoptions
  • setAnnotation() : ms_spectral_lib_peak
  • setAnnotationLevel() : ms_spectral_lib_peak_list
  • setAPI() : ms_errs
  • setApproved() : ms_umod_modification
  • setAutoSelectCharge() : ms_mascotoptions
  • setAvailable() : ms_parserule
  • setAvailableModifications() : ms_aahelper
  • setAverage() : ms_quant_moverz, ms_quant_protocol
  • setAverageFeatureWidths() : ms_ms1quant_time_align
  • setAverageNumPeptides() : ms_ms1quantitation
  • setAverageReferenceProtein() : ms_ms1quantitation
  • setAverageSelection() : ms_ms1quantitation
  • setAverageValues() : ms_imputation_average_value
  • setAvgeMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • setBaseUrl() : ms_http_client
  • setBreak() : ms_progress_info
  • setCacheDirectory() : ms_mascotoptions
  • setCarbonMass() : ms_masses
  • setCentroidWidth() : ms_mascotoptions
  • setCentroidWidthCount() : ms_mascotoptions
  • setCharged2Plus() : ms_fragmentationrules
  • setCharged3Plus() : ms_fragmentationrules
  • setCheckNodesAliveFreq() : ms_clusterparams
  • setChopSource() : ms_parserule_plus
  • setClassification() : ms_umod_specificity
  • setClusterParams() : ms_datfile
  • setCode() : ms_umod_neutralloss
  • setCoefficient() : ms_quant_numerator
  • setColsToOutput() : ms_logger
  • setColumnDown() : ms_matrix
  • setColumnUp() : ms_matrix
  • setCombinedReportRatio() : ms_ms2quantitation
  • setCombineRepeats() : ms_errs
  • setCommandStr() : ms_cronjob
  • setComp() : ms_quant_method
  • setCompositionString() : ms_umod_composition
  • setCompressToolAA() : ms_mascotoptions
  • setCompressToolNA() : ms_mascotoptions
  • setCompressToolSL() : ms_mascotoptions
  • setConcatRefFileLines() : ms_taxonomyrules
  • setConnectionSettings() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile, ms_http_client, ms_masses, ms_modfile, ms_quant_configfile, ms_taxonomyfile, ms_umod_configfile
  • setConnectionTimeout() : ms_connection_settings
  • setConstrainSearch() : ms_quant_method
  • setContent() : ms_quant_correction, ms_quant_file_index, ms_quant_numerator, ms_quant_unmodified
  • setCR() : ms_matrix
  • setCrawlerNumPeaksPer100Da() : ms_mascotoptions
  • setCreateLegacyModAndSubstitutionFiles() : ms_mascotoptions
  • setCreatePipThreadBlockSize() : ms_mascotoptions
  • setCreatePipThreads() : ms_mascotoptions
  • setCronEnabled() : ms_cronoptions
  • setCronJob() : ms_cronoptions
  • setCronOptions() : ms_datfile
  • setCTerminusMass() : ms_modification
  • setCtermModification() : ms_masses
  • setDatabaseName() : ms_crosslinking_accession
  • setDatabases() : ms_datfile
  • setDataWithMissing() : ms_imputation_method
  • setDateTimeModified() : ms_umod_modification
  • setDateTimePosted() : ms_umod_modification
  • setDayOfMonth() : ms_cronjob
  • setDayOfWeek() : ms_cronjob
  • setDB() : ms_protein
  • setDBLevelTaxId() : ms_taxonomyrules
  • setDBType() : ms_databaseoptions
  • setDechargeFragmentPeaks() : ms_mascotoptions
  • setDecoyTypeNoEnzyme() : ms_mascotoptions
  • setDecoyTypeSpecific() : ms_mascotoptions
  • setDefaultDelimiter() : ms_customproperty
  • setDefaultMonitor() : ms_loggingmonitor
  • setDefaultNodeHomeDir() : ms_clusterparams
  • setDefaultNodeHomeDirFromMaster() : ms_clusterparams
  • setDefaultNodeOS() : ms_clusterparams
  • setDefaultPasswordExpiryTime() : ms_security_options
  • setDefaultPort() : ms_clusterparams
  • setDefaultRule() : ms_taxonomyrules
  • setDefaultTargetFDRPercentage() : ms_mascotoptions
  • setDelta() : ms_modification, ms_quant_localdef, ms_umod_modification
  • setDescription() : ms_crosslinking_method, ms_quant_method, ms_umod_neutralloss, ms_xml_parameter
  • setDescriptionLineSep() : ms_taxonomyrules
  • setDescriptionParseRuleIndex() : ms_databaseoptions
  • setDisplayNonSignificantMatches() : ms_mascotoptions
  • setDoThisRuleFirst() : ms_taxonomyrules
  • setElectronMass() : ms_masses
  • setElement() : ms_quant_correction
  • setElutionProfileCorrelationThreshold() : ms_quant_integration
  • setElutionTimeDelta() : ms_quant_integration
  • setElutionTimeDeltaUnit() : ms_quant_integration
  • setEmailAddress() : ms_user
  • setEmailErrorsEnabled() : ms_mascotoptions
  • setEmailFromTextName() : ms_mascotoptions
  • setEmailFromUser() : ms_mascotoptions
  • setEmailPassword() : ms_mascotoptions
  • setEmailProfile() : ms_mascotoptions
  • setEmailService() : ms_mascotoptions
  • setEmailTimeOutPeriod() : ms_mascotoptions
  • setEmailUsersEnabled() : ms_mascotoptions
  • setEnabled() : ms_clusterparams, ms_cronjob, ms_taxonomyrules
  • setEncryptedPassword() : ms_user
  • setEntry() : ms_wwwoptions
  • setEnzyme() : ms_aahelper
  • setEnzymes() : ms_mascotfiles
  • setErrMessageEmailTo() : ms_mascotoptions
  • setErrorInfoFromString() : ms_mascotresfilebase
  • setErrorLevel() : ms_taxonomyrules
  • setErrorLogFile() : ms_mascotoptions
  • setErrTolMaxAccessions() : ms_mascotoptions
  • setEvaluation() : ms_ms1quant_time_align
  • setExcludeInternalLabel() : ms_quant_multiplex
  • setExcludeIsobaricFragments() : ms_quant_multiplex
  • setExecAfterSearch() : ms_mascotoptions
  • setFeatureTableLength() : ms_mascotoptions
  • setFeatureTableMinScore() : ms_mascotoptions
  • setFileIndex() : ms_quant_component
  • setFileName() : ms_crosslinking_configfile, ms_datfile, ms_enzymefile, ms_fragrulesfile, ms_license, ms_masses, ms_modfile, ms_quant_configfile, ms_taxnodesfiles, ms_taxonomyfile, ms_taxspeciesfiles, ms_umod_configfile
  • setFileTypeToSearch() : ms_parserule_plus
  • setFilters() : ms_crosslinking_method
  • setFindFileTimeout() : ms_datfile
  • setFixedValue() : ms_imputation_fixed_value
  • setFlag() : ms_mascotresults_params, ms_quant_neutralloss, ms_umod_neutralloss
  • setFlag2() : ms_mascotresults_params
  • setFlags() : ms_mascotresults_params
  • setFlags2() : ms_mascotresults_params
  • setForkForUnixApache() : ms_mascotoptions
  • setFormat() : ms_taxnodesfiles, ms_taxspeciesfiles
  • setFormVersion() : ms_mascotoptions
  • setFraction() : ms_quant_file_index
  • setFrequencies() : ms_mascotfiles
  • setFromRefFile() : ms_taxonomyrules
  • setFromSubstitutions() : ms_modfile
  • setFullName() : ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification, ms_user
  • setGetSeqBlastAccession() : ms_mascotoptions
  • setGetSeqJobIdFile() : ms_mascotoptions
  • setGroupOfPoster() : ms_umod_modification
  • setHeaderComments() : ms_datfile
  • setHidden() : ms_modification, ms_umod_specificity
  • setHitRatioExcluded() : ms_ms1quant_match
  • setHitRatioOutlier() : ms_ms1quant_match
  • setHostName() : ms_computeraddress, ms_wwwentry
  • setHour() : ms_cronjob
  • setHttpPassword() : ms_connection_settings
  • setHttpProtocol() : ms_connection_settings
  • setHttpUsername() : ms_connection_settings
  • setHydrogenMass() : ms_masses
  • setICATFilter() : ms_mascotoptions
  • setICATHeavy() : ms_mascotoptions
  • setICATLight() : ms_mascotoptions
  • setICATQuantitationMethod() : ms_mascotoptions
  • setID() : ms_group, ms_user
  • setIdentifier() : ms_taxonomyrules
  • setIgnoreDupeAccession() : ms_mascotoptions
  • setIgnoreIonsScoreBelow() : ms_mascotoptions, ms_mascotresults_params
  • setImputationVariableChoice() : ms_imputation
  • setImputeExcludedMs2PeptideRatios() : ms_imputation
  • setImputeMs1PeptideExcludedByCorrelationThr() : ms_imputation
  • setImputeMs1PeptideExcludedByFractionThr() : ms_imputation
  • setImputeMs1PeptideExcludedByStdErrThr() : ms_imputation
  • setImputeMs1PeptideNegativeRatio() : ms_imputation
  • setIndependent() : ms_enzyme
  • setIndexFileName() : ms_tinycdb
  • setInErrorTolerant() : ms_modification
  • setInetAddress() : ms_computeraddress
  • setInLongList() : ms_modification
  • setInShortList() : ms_modification
  • setIntegraAppServerURL() : ms_security_options
  • setIntegraDatabaseName() : ms_security_options
  • setIntegraOracleServerName() : ms_security_options
  • setIntegration() : ms_quant_method
  • setIntensityNormalisationBase() : ms_ms2quantitation
  • setIntensitySigFigs() : ms_mascotoptions
  • setInterFileBasePath() : ms_mascotoptions
  • setInterFileRelPath() : ms_mascotoptions
  • setIonIntensityThreshold() : ms_quant_multiplex
  • setIonsDecimalPlaces() : ms_mascotoptions
  • setIonSeries() : ms_quant_multiplex
  • setIPCLogfile() : ms_clusterparams
  • setIPCLogging() : ms_clusterparams
  • setIPCTimeout() : ms_clusterparams
  • setIsolatedPrecursor() : ms_quant_quality
  • setIsolatedPrecursorThreshold() : ms_quant_quality
  • setIteratePMFIntensities() : ms_mascotoptions
  • setKnnNumNeighbours() : ms_imputation_knn
  • setKnnUseWeightedAverage() : ms_imputation_knn
  • setLabelAll() : ms_mascotoptions
  • setLastModificationTime() : ms_fileutilities
  • setLastQueryAscFile() : ms_mascotoptions
  • setLibraryOptions() : ms_datfile
  • setLinkers() : ms_crosslinking_method
  • setLocalModsStr() : ms_peptide
  • setLocalRefFile() : ms_databaseoptions
  • setLockMemory() : ms_databaseoptions
  • setLogFileName() : ms_cronoptions, ms_security_options
  • setLoggingFile() : ms_errs
  • setLoggingLevel() : ms_cronoptions, ms_errs, ms_security_options
  • setLogMask() : ms_loggingmonitor
  • setLogoImageFile() : ms_mascotoptions
  • setMailTempFile() : ms_mascotoptions
  • setMailTransport() : ms_mascotoptions
  • setMajorVersion() : ms_umod_configfile
  • setMascNodeCtrlFile() : ms_mascotoptions
  • setMascotCmdLine() : ms_mascotoptions
  • setMascotControlFile() : ms_mascotoptions
  • setMascotFileProcessingThreads() : ms_mascotoptions
  • setMascotFiles() : ms_datfile
  • setMascotJobIdFile() : ms_mascotoptions
  • setMascotMessage() : ms_mascotoptions
  • setMascotNodeRebootScript() : ms_clusterparams
  • setMascotNodeScript() : ms_clusterparams
  • setMascotOptions() : ms_datfile
  • setMassDecimalPlaces() : ms_mascotoptions
  • setMassDelta() : ms_quant_integration
  • setMassDeltaUnit() : ms_quant_integration
  • setMasses() : ms_aahelper
  • setMassFile() : ms_modfile, ms_modification
  • setMasterComputer() : ms_clusterparams
  • setMatchedIon() : ms_fragment
  • setMatchedRho() : ms_quant_integration
  • setMatchOppositeCrosslinkPairs() : ms_mascotoptions
  • setMaxBinNum() : ms_ms1quant_time_align_limits
  • setMaxConcurrentSearches() : ms_mascotoptions
  • setMaxDatabases() : ms_mascotoptions
  • setMaxDescriptionLen() : ms_mascotoptions
  • setMaxEtagMassDelta() : ms_mascotoptions
  • setMaxEtVarMods() : ms_mascotoptions
  • setMaxHitsToReport() : ms_mascotresults_params
  • setMaxIntactCrosslinkPeptides() : ms_mascotoptions
  • setMaxInternalMass() : ms_fragmentationrules
  • setMaxMZ() : ms_ms1quant_time_align_limits
  • setMaxNumPeptides() : ms_mascotoptions
  • setMaxPepModArrangements() : ms_mascotoptions
  • setMaxPepNumModifiedSites() : ms_mascotoptions
  • setMaxPepNumVarMods() : ms_mascotoptions
  • setMaxQueries() : ms_mascotoptions
  • setMaxRT() : ms_ms1quant_time_align_limits
  • setMaxSearchesPerUser() : ms_mascotoptions
  • setMaxSequenceLen() : ms_mascotoptions
  • setMaxVarMods() : ms_mascotoptions
  • setMemoryMapFiles() : ms_databaseoptions
  • setMethod() : ms_quant_integration, ms_quant_normalisation, ms_quant_outliers
  • setMinBinNum() : ms_ms1quant_time_align_limits
  • setMinEtagMassDelta() : ms_mascotoptions
  • setMinimumA1() : ms_quant_quality
  • setMinimumPasswordLength() : ms_security_options
  • setMinInternalMass() : ms_fragmentationrules
  • setMinIonPairs() : ms_quant_multiplex
  • setMinMZ() : ms_ms1quant_time_align_limits
  • setMinNumPeptides() : ms_quant_method, ms_quantitation
  • setMinNumSigUniqueSequences() : ms_mascotresults_params
  • setMinorVersion() : ms_umod_configfile
  • setMinPepLenInPepSummary() : ms_mascotoptions
  • setMinPepLenInPeptideSummary() : ms_mascotresults_params
  • setMinPepLenInSearch() : ms_mascotoptions
  • setMinPrecursorCharge() : ms_quant_quality
  • setMinProbability() : ms_mascotresults_params
  • setMinRT() : ms_ms1quant_time_align_limits
  • setMinute() : ms_cronjob
  • setMiscNotes() : ms_umod_modification, ms_umod_specificity
  • setMissing() : ms_imputation_missing_val
  • setMitochondrialTranslation() : ms_taxonomyrules
  • setMode() : ms_quant_modgroup
  • setModFileName() : ms_crosslinking_does_not_pair_with, ms_crosslinking_linker
  • setModifications() : ms_mascotfiles, ms_quant_satellite
  • setModificationType() : ms_modification
  • setMonitorEmailCheckFreq() : ms_mascotoptions
  • setMonitorLogFile() : ms_mascotoptions
  • setMonitorPidFile() : ms_mascotoptions
  • setMonitorTestTimeout() : ms_mascotoptions
  • setMonoisotopic() : ms_quant_moverz
  • setMonoMass() : ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_modbrick
  • setMonthOfYear() : ms_cronjob
  • setMoveOldDbToOldDir() : ms_mascotoptions
  • setMoverz() : ms_quant_component
  • setMudpit() : ms_mascotoptions
  • setMudpitSwitch() : ms_mascotoptions
  • setMultiplex() : ms_quant_protocol
  • setName() : ms_crosslinking_method, ms_databaseoptions, ms_dbprocessors, ms_group, ms_quant_component, ms_quant_method, ms_quant_modgroup, ms_quant_numerator, ms_quant_ratio, ms_user, ms_wwwentry, ms_xml_parameter
  • setNameOfDB() : ms_parserule_plus
  • setNeutralLoss() : ms_modification
  • setNew() : ms_quant_isotope
  • setNitrogenMass() : ms_masses
  • setNodeListFile() : ms_mascotfiles
  • setNodeSequenceDatabaseDir() : ms_clusterparams
  • setNoResultsScript() : ms_mascotoptions
  • setNormalisation() : ms_quant_method
  • setNTerminusMass() : ms_modification
  • setNtermModification() : ms_masses
  • setNTIUserGroup() : ms_mascotoptions
  • setNTMonitorGroup() : ms_mascotoptions
  • setNull() : ms_quant_protocol
  • setNumber() : ms_quant_element, ms_umod_elemref
  • setNumberOfThreads() : ms_databaseoptions
  • setNumPeptides() : ms_quant_average
  • setNumQueries() : ms_ms1quant_time_align_limits
  • setNumQueriesAboveThreshold() : ms_ms1quant_time_align_limits
  • setOld() : ms_quant_isotope
  • setOutliers() : ms_quant_method
  • setOxygenMass() : ms_masses
  • setPairsWith() : ms_umod_neutralloss
  • setParams() : ms_security_task
  • setParseOptions() : ms_datfile
  • setParseRule() : ms_parseoptions, ms_wwwentry
  • setPassword() : ms_user
  • setPasswordExpiry() : ms_user
  • setPath() : ms_databaseoptions, ms_wwwentry
  • setPepNeutralLoss() : ms_modification
  • setPepSearchTool() : ms_mascotoptions
  • setPepThresholdType() : ms_quant_quality
  • setPepThresholdValue() : ms_quant_quality
  • setPeptideIsBold() : ms_protein
  • setPeptideRatioExcluded() : ms_customquantitation, ms_ms2quantitation, ms_quantitation
  • setPeptideRatioIncluded() : ms_customquantitation, ms_ms2quantitation, ms_quantitation
  • setPeptideRatioNormalisationBase() : ms_quantitation
  • setPeptides() : ms_quant_normalisation
  • setPeptideShowCheckbox() : ms_protein
  • setPercolator() : ms_mascotoptions
  • setPercolatorExeFlags() : ms_mascotoptions
  • setPercolatorFeatures() : ms_mascotoptions, ms_mascotresfilebase
  • setPercolatorMinQueries() : ms_mascotoptions
  • setPercolatorMinSequences() : ms_mascotoptions
  • setPercolatorTargetRankRelativeThreshold() : ms_mascotoptions
  • setPercolatorTargetRankScoreThreshold() : ms_mascotoptions
  • setPercolatorUseProteins() : ms_mascotoptions
  • setPercolatorUseRT() : ms_mascotoptions
  • setPermittedTasks() : ms_group, ms_session
  • setPort() : ms_computeraddress
  • setPortNumber() : ms_wwwentry
  • setPosition() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • setPreceedingComments() : ms_customproperty, ms_databaseoptions
  • setPrecursor() : ms_quant_protocol
  • setPrecursorCutOutLowerLimit() : ms_mascotoptions
  • setPrecursorCutOutUpperLimit() : ms_mascotoptions
  • setPrecursorRange() : ms_quant_integration
  • setPrivacyEnabled() : ms_umod_modification
  • setPrivate() : ms_umod_modification
  • setProcessingOptions() : ms_quant_integration
  • setProcessors() : ms_datfile
  • setPropertyName() : ms_customproperty
  • setPropValBoolByName() : ms_customproperty
  • setPropValCharByName() : ms_customproperty
  • setPropValFloatByName() : ms_customproperty
  • setPropValInt64ByName() : ms_customproperty
  • setPropValIntByName() : ms_customproperty
  • setPropValStringByName() : ms_customproperty
  • setPropValStringByNumber() : ms_customproperty
  • setProteinFamilySwitch() : ms_mascotoptions
  • setProteinId() : ms_protein
  • setProteinRatioType() : ms_customquantitation, ms_ms2quantitation, ms_quant_method, ms_quantitation
  • setProteins() : ms_quant_normalisation
  • setProteinsInResultsFile() : ms_mascotoptions
  • setProtocol() : ms_quant_method
  • setProtScoreType() : ms_quant_method
  • setProxyPassword() : ms_connection_settings, ms_mascotoptions
  • setProxyServer() : ms_connection_settings, ms_mascotoptions
  • setProxyServerType() : ms_connection_settings
  • setProxyType() : ms_mascotoptions
  • setProxyUsername() : ms_connection_settings, ms_mascotoptions
  • setQuality() : ms_quant_method
  • setQuantNormalisation() : ms_ms2quantitation
  • setQuantOutliers() : ms_customquantitation, ms_ms2quantitation, ms_quantitation
  • setQuickRefSearch() : ms_taxonomyrules
  • setRC() : ms_matrix
  • setRecordID() : ms_umod_modification
  • setRedirectPolicy() : ms_connection_settings
  • setReferenceAccession() : ms_quant_average
  • setReferenceAmount() : ms_quant_average
  • setReferenceDatabase() : ms_quant_average
  • setReferenceFasta() : ms_libraryoptions
  • setRemoveOldIndexFiles() : ms_mascotoptions
  • setReplicate() : ms_quant_protocol
  • setReportBuilderColumnArrangement() : ms_mascotoptions
  • setReportDetail() : ms_quant_method
  • setReporter() : ms_quant_protocol
  • setReporterTol() : ms_quant_reporter
  • setReporterTolUnit() : ms_quant_reporter
  • setReportNumberChoice() : ms_mascotoptions
  • setReportRatioInFile() : ms_ms2quantitation
  • setReqPepNeutralLoss() : ms_modification
  • setRequireBoldRed() : ms_mascotoptions, ms_quant_method
  • setRequired() : ms_quant_modgroup, ms_quant_pepneutralloss
  • setResfileCache() : ms_mascotoptions
  • setResidueMasses() : ms_masses
  • setResidueModification() : ms_masses
  • setResultsCache() : ms_mascotoptions
  • setResultsFileFormatVersion() : ms_mascotoptions
  • setResultsFullURL() : ms_mascotoptions
  • setResultsFullURL_2() : ms_mascotoptions
  • setResultsPerlScript() : ms_mascotoptions
  • setResultsPerlScript_2() : ms_mascotoptions
  • setReviewColDisplay() : ms_mascotoptions
  • setReviewColWidth() : ms_mascotoptions
  • setRow() : ms_treecluster
  • setRule() : ms_parserule_plus
  • setRuleStr() : ms_parserule
  • setSatellite() : ms_quant_component
  • setSaveEveryLastQueryAsc() : ms_mascotoptions
  • setSaveLastQueryAsc() : ms_mascotoptions
  • setSchemaDirectory() : ms_quant_configfile
  • setSchemaFileName() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • setScope() : ms_crosslinking_method
  • setSearchLogFile() : ms_mascotoptions
  • setSearchSubmitAcceptedFileTypes() : ms_mascotoptions
  • setSearchSubmitDefaultPeptideCharge() : ms_mascotoptions
  • setSearchSubmitMode() : ms_mascotoptions
  • setSearchSubmitOutputFormat() : ms_mascotoptions
  • setSecsToWaitForNodeAtStartup() : ms_clusterparams
  • setSectionAvailable() : ms_clusterparams, ms_cronoptions, ms_databases, ms_libraryoptions, ms_mascotoptions, ms_parseoptions, ms_processoroptions, ms_taxonomyrules, ms_unigeneoptions, ms_wwwoptions
  • setSecurityEnabled() : ms_security_options
  • setSelection() : ms_quant_average
  • setSelectSwitch() : ms_mascotoptions
  • setSemiSpecific() : ms_enzyme
  • setSendmailPath() : ms_mascotoptions
  • setSequence() : ms_quant_normalisation_peptide
  • setSeriesUsed() : ms_fragmentationrules
  • setSessionID() : ms_connection_settings
  • setSessionTimeout() : ms_security_options
  • setSettings() : ms_crosslinking_method
  • setShift() : ms_quant_correction
  • setShowAllFromErrorTolerant() : ms_mascotoptions
  • setShowSubsets() : ms_mascotoptions
  • setShowSubSets() : ms_quant_method
  • setSigThreshold() : ms_mascotoptions
  • setSigThresholdValue() : ms_quant_method
  • setSimpleRatio() : ms_quant_integration
  • setSingleHit() : ms_mascotresults_params
  • setSinglyCharged() : ms_fragmentationrules
  • setSite() : ms_quant_specificity, ms_quant_unmodified, ms_umod_specificity
  • setSiteAnalysisMD10Prob() : ms_mascotoptions
  • setSortUnassigned() : ms_mascotoptions
  • setSource() : ms_quant_integration, ms_umod_xref
  • setSpecGroup() : ms_umod_specificity
  • setSpeciesFormatRegex() : ms_taxonomyrules
  • setSpectraPerLibraryBlock() : ms_mascotoptions
  • setSpectrumViewerColourSchemeString() : ms_mascotoptions
  • setSpectrumViewerDefaultColourSchemeName() : ms_mascotoptions
  • setSplitDataFileSize() : ms_mascotoptions
  • setSplitNumberOfQueries() : ms_mascotoptions
  • setSrcDatabaseRule() : ms_taxonomyrules
  • setStoreModPermutations() : ms_mascotoptions
  • setStrategy() : ms_crosslinking_method
  • setStrRule() : ms_taxonomyrules
  • setSubsetsThreshold() : ms_mascotresults
  • setSummedModsStr() : ms_peptide
  • setSVGSpectrumSwitch() : ms_mascotoptions
  • setSymbol() : ms_quant_element, ms_umod_elemref
  • setTargetFDR() : ms_mascotresults_params
  • setTargetFDRPercentage() : ms_mascotoptions
  • setTargetFDRType() : ms_mascotresults_params
  • setTaxBrowserUrl() : ms_mascotoptions
  • setTaxonomyParseRuleIndex() : ms_databaseoptions
  • setTaxonomyRules() : ms_datfile
  • setTestDirectory() : ms_mascotoptions
  • setText() : ms_umod_xref
  • setThreeLetter() : ms_umod_aminoacid
  • setTimeAlignmentAlgorithm() : ms_quant_replicate
  • setTimeAlignmentData() : ms_ms1quantitation
  • setTitle() : ms_enzyme, ms_fragmentationrules, ms_modification, ms_quant_localdef, ms_taxonomychoice, ms_umod_aminoacid, ms_umod_element, ms_umod_modbrick, ms_umod_modification
  • setTitleSource() : ms_modification
  • setToleranceInDa() : ms_libraryoptions
  • setToleranceInPPM() : ms_libraryoptions
  • setTotalIntensity() : ms_quant_quality
  • setTotalIntensityThreshold() : ms_quant_quality
  • setType() : ms_quant_correction, ms_wwwentry
  • setUnigeneIndexFile() : ms_mascotresults_params
  • setUniGeneOptions() : ms_datfile
  • setUniqueJobStartNumber() : ms_mascotoptions
  • setUniquePepseq() : ms_quant_quality
  • setUnixDirPerm() : ms_mascotoptions
  • setUnixWebUserGroup() : ms_mascotoptions
  • setUrl() : ms_umod_xref
  • setUseHTTPProxyForFTP() : ms_connection_settings, ms_mascotoptions
  • setUseHTTPProxyForHTTPS() : ms_connection_settings, ms_mascotoptions
  • setUsePeptideSummary() : ms_mascotresults_params
  • setUserAgent() : ms_connection_settings
  • setUsernameOfPoster() : ms_umod_modification
  • setUserType() : ms_user
  • setUseSessionCookies() : ms_security_options
  • setVal() : ms_imputation_missing_val
  • setValue() : ms_crosslinking_accession, ms_crosslinking_monolink, ms_http_client_mime, ms_xml_parameter
  • setValueWithFilename() : ms_http_client_mime
  • setVarModsStr() : ms_peptide
  • setVerifySessionIPAddress() : ms_security_options
  • setVmemory() : ms_mascotoptions
  • setWWWOptions() : ms_datfile
  • setXicMaxWidth() : ms_quant_integration
  • setXicSmoothing() : ms_quant_integration
  • setXicThreshold() : ms_quant_integration
  • setXMLschemaFilePath() : ms_mascotresfilebase
  • severityAsText() : ms_loggingmonitor
  • showInLongList() : ms_umod_specificity
  • showInShortList() : ms_umod_specificity
  • size() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • sizei() : ms_matrix
  • sizej() : ms_matrix
  • snedecorsCriticalValue() : ms_quant_stats
  • sortedMedian() : ms_quant_stats
  • sortModifications() : ms_modfile
  • sortPeptides() : ms_protein
  • sortUsers() : ms_security
  • startIteratePeptides() : ms_aahelper
  • staticGetPercolatorFileNames() : ms_mascotresfilebase
  • stopIteratePeptides() : ms_aahelper
  • stripLastFolder() : ms_fileutilities
  • studentsCriticalValue() : ms_quant_stats
  • submitSearch() : ms_http_client_session
  • subproject() : ms_imputation_peptide_data
  • sum() : ms_quant_stats
  • sumsq() : ms_quant_stats
  • swap() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • swilk() : ms_shapiro_wilk
  • systemError() : ms_http_helper_return
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- t -

  • testDixonsN9() : ms_quant_stats
  • testGrubbsN2() : ms_quant_stats
  • testRosners() : ms_quant_stats
  • testShapiroWilkW() : ms_quant_stats
  • toVector() : ms_linker_site_vector, ms_peptide_quant_key_vector
  • transpose() : ms_matrix
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- u -

  • uncommentProp() : ms_customproperty
  • unsortedMedian() : ms_quant_stats
  • unspecifiedError() : ms_http_helper_return
  • update() : ms_session
  • updateAccessionByNumber() : ms_crosslinking_accessions
  • updateAllSessionFiles() : ms_security
  • updateAltName() : ms_umod_modification
  • updateAminoAcidByName() : ms_umod_configfile
  • updateAminoAcidByNumber() : ms_umod_configfile
  • updateBreak() : ms_progress_info
  • updateComplete() : ms_progress_info
  • updateComponentByName() : ms_quant_method
  • updateComponentByNumber() : ms_quant_method
  • updateCorrection() : ms_quant_component
  • updateDatabaseByName() : ms_databases
  • updateDatabaseByNumber() : ms_databases
  • updateDenominatorByName() : ms_quant_ratio
  • updateDenominatorByNumber() : ms_quant_ratio
  • updateDoesNotPairWithByNumber() : ms_crosslinking_linker
  • updateElement() : ms_quant_composition
  • updateElementByName() : ms_umod_configfile
  • updateElementByNumber() : ms_umod_configfile
  • updateElemRef() : ms_umod_aminoacid, ms_umod_composition, ms_umod_modbrick
  • updateEnzymeByName() : ms_enzymefile
  • updateEnzymeByNumber() : ms_enzymefile
  • updateExclusion() : ms_quant_method
  • updateFail() : ms_progress_info
  • updateFileIndex() : ms_quant_component
  • updateForInstaller() : ms_datfile
  • updateGroup() : ms_security
  • updateIgnore() : ms_quant_localdef, ms_umod_modification
  • updateIndeterminate() : ms_progress_info
  • updateInstrumentByName() : ms_fragrulesfile
  • updateInstrumentByNumber() : ms_fragrulesfile
  • updateIonSeries() : ms_quant_multiplex
  • updateIsotope() : ms_quant_component
  • updateLinkerByNumber() : ms_crosslinking_linkers
  • updateLocalDefinition() : ms_quant_modgroup
  • updateMasses() : ms_umod_composition, ms_umod_configfile, ms_umod_modification
  • updateMethodByName() : ms_crosslinking_configfile, ms_quant_configfile
  • updateMethodByNumber() : ms_crosslinking_configfile, ms_quant_configfile
  • updateModBrickByName() : ms_umod_configfile
  • updateModBrickByNumber() : ms_umod_configfile
  • updateModificationByName() : ms_modfile, ms_umod_configfile
  • updateModificationByNumber() : ms_modfile, ms_umod_configfile
  • updateModificationGroupByName() : ms_quant_component, ms_quant_method
  • updateModificationGroupByNumber() : ms_quant_component, ms_quant_method
  • updateMonoLinkByNumber() : ms_crosslinking_linker
  • updateNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • updateNumeratorByName() : ms_quant_ratio
  • updateNumeratorByNumber() : ms_quant_ratio
  • updateParameterByName() : ms_crosslinking_parameters, ms_quant_parameters
  • updateParameterByNumber() : ms_crosslinking_parameters, ms_quant_parameters
  • updatePassword() : ms_security
  • updatePepNeutralLoss() : ms_quant_specificity, ms_umod_specificity
  • updatePeptide() : ms_quant_normalisation_peptides
  • updateProgress() : ms_progress_info
  • updateProtein() : ms_quant_normalisation_proteins
  • updateReportRatioByName() : ms_quant_method
  • updateReportRatioByNumber() : ms_quant_method
  • updateSeq() : ms_quant_method
  • updateSpecificity() : ms_quant_localdef, ms_umod_modification
  • updateTask() : ms_security_tasks
  • updateUnmodified() : ms_quant_modgroup
  • updateUser() : ms_security
  • updateXref() : ms_umod_modification
  • uploadDistillerXmlResultsFile() : ms_http_client_search
  • useInErrorTolerant() : ms_umod_specificity
  • userLogin() : ms_http_client
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- v -

  • validateDeep() : ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_does_not_pair_with, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_xml_parameter, ms_xml_parameters
  • validateDocument() : ms_crosslinking_configfile, ms_quant_configfile, ms_umod_configfile
  • validatePassword() : ms_user
  • validateShallow() : ms_crosslinking_accession, ms_crosslinking_accessions, ms_crosslinking_does_not_pair_with, ms_crosslinking_linker, ms_crosslinking_linkers, ms_crosslinking_method, ms_crosslinking_monolink, ms_quant_average, ms_quant_component, ms_quant_composition, ms_quant_correction, ms_quant_element, ms_quant_file_index, ms_quant_integration, ms_quant_isotope, ms_quant_localdef, ms_quant_method, ms_quant_modgroup, ms_quant_moverz, ms_quant_multiplex, ms_quant_neutralloss, ms_quant_normalisation, ms_quant_normalisation_peptide, ms_quant_normalisation_peptides, ms_quant_normalisation_protein, ms_quant_normalisation_proteins, ms_quant_numerator, ms_quant_outliers, ms_quant_pepneutralloss, ms_quant_precursor, ms_quant_protocol, ms_quant_quality, ms_quant_ratio, ms_quant_replicate, ms_quant_reporter, ms_quant_satellite, ms_quant_specificity, ms_quant_unmodified, ms_umod_aminoacid, ms_umod_composition, ms_umod_element, ms_umod_elemref, ms_umod_modbrick, ms_umod_modification, ms_umod_neutralloss, ms_umod_specificity, ms_umod_xref, ms_xml_parameter, ms_xml_parameters
  • verifyEnzyme() : ms_enzyme
  • verifyRule() : ms_fragmentationrules
  • verifyThatModsAreInUnimod() : ms_spectral_lib_file
  • versionGreaterOrEqual() : ms_mascotresfilebase
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- w -

  • weightedArithmeticMean() : ms_quant_stats
  • weightedArithmeticStandardDeviation() : ms_quant_stats
  • weightedArithmeticStandardError() : ms_quant_stats
  • weightedGeometricMean() : ms_quant_stats
  • weightedGeometricStandardDeviation() : ms_quant_stats
  • willCreateCache() : ms_mascotresfilebase, ms_peptidesummary
  • willMessageBeLogged() : ms_errs, ms_log
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Functions

- ~ -

  • ~ms_aahelper() : ms_aahelper
  • ~ms_buffer_logger() : ms_buffer_logger
  • ~ms_clusterparams() : ms_clusterparams
  • ~ms_computeraddress() : ms_computeraddress
  • ~ms_connection_settings() : ms_connection_settings
  • ~ms_cronjob() : ms_cronjob
  • ~ms_cronoptions() : ms_cronoptions
  • ~ms_crosslinking_accession() : ms_crosslinking_accession
  • ~ms_crosslinking_accessions() : ms_crosslinking_accessions
  • ~ms_crosslinking_configfile() : ms_crosslinking_configfile
  • ~ms_crosslinking_does_not_pair_with() : ms_crosslinking_does_not_pair_with
  • ~ms_crosslinking_filters() : ms_crosslinking_filters
  • ~ms_crosslinking_linker() : ms_crosslinking_linker
  • ~ms_crosslinking_linkers() : ms_crosslinking_linkers
  • ~ms_crosslinking_method() : ms_crosslinking_method
  • ~ms_crosslinking_monolink() : ms_crosslinking_monolink
  • ~ms_crosslinking_parameter() : ms_crosslinking_parameter
  • ~ms_crosslinking_parameters() : ms_crosslinking_parameters
  • ~ms_crosslinking_scope() : ms_crosslinking_scope
  • ~ms_crosslinking_settings() : ms_crosslinking_settings
  • ~ms_customproperty() : ms_customproperty
  • ~ms_customquantitation() : ms_customquantitation
  • ~ms_databaseoptions() : ms_databaseoptions
  • ~ms_databases() : ms_databases
  • ~ms_datfile() : ms_datfile
  • ~ms_dbprocessors() : ms_dbprocessors
  • ~ms_enzyme() : ms_enzyme
  • ~ms_enzymefile() : ms_enzymefile
  • ~ms_errors() : ms_errors
  • ~ms_errs() : ms_errs
  • ~ms_file_logger() : ms_file_logger
  • ~ms_fragmentationrules() : ms_fragmentationrules
  • ~ms_fragmentvector() : ms_fragmentvector
  • ~ms_fragrulesfile() : ms_fragrulesfile
  • ~ms_http_client() : ms_http_client
  • ~ms_http_client_mime() : ms_http_client_mime
  • ~ms_http_client_search() : ms_http_client_search
  • ~ms_http_client_session() : ms_http_client_session
  • ~ms_http_helper() : ms_http_helper
  • ~ms_http_helper_handles() : ms_http_helper_handles
  • ~ms_http_helper_progress() : ms_http_helper_progress
  • ~ms_imputation() : ms_imputation
  • ~ms_libraryoptions() : ms_libraryoptions
  • ~ms_license() : ms_license
  • ~ms_linker_site() : ms_linker_site
  • ~ms_linker_site_vector() : ms_linker_site_vector
  • ~ms_log() : ms_log
  • ~ms_logger() : ms_logger
  • ~ms_loggingmonitor() : ms_loggingmonitor
  • ~ms_mascotfiles() : ms_mascotfiles
  • ~ms_mascotoptions() : ms_mascotoptions
  • ~ms_masses() : ms_masses
  • ~ms_modfile() : ms_modfile
  • ~ms_modification() : ms_modification
  • ~ms_modvector() : ms_modvector
  • ~ms_ms2quantitation() : ms_ms2quantitation
  • ~ms_obofile() : ms_obofile
  • ~ms_parseoptions() : ms_parseoptions
  • ~ms_parserule() : ms_parserule
  • ~ms_parserule_plus() : ms_parserule_plus
  • ~ms_peptide() : ms_peptide
  • ~ms_peptide_quant_key() : ms_peptide_quant_key
  • ~ms_peptide_quant_key_vector() : ms_peptide_quant_key_vector
  • ~ms_peptide_quant_ratio() : ms_peptide_quant_ratio
  • ~ms_processoroptions() : ms_processoroptions
  • ~ms_processors() : ms_processors
  • ~ms_progress_info() : ms_progress_info
  • ~ms_protein() : ms_protein
  • ~ms_protein_quant_ratio() : ms_protein_quant_ratio
  • ~ms_quant_average() : ms_quant_average
  • ~ms_quant_component() : ms_quant_component
  • ~ms_quant_composition() : ms_quant_composition
  • ~ms_quant_configfile() : ms_quant_configfile
  • ~ms_quant_correction() : ms_quant_correction
  • ~ms_quant_element() : ms_quant_element
  • ~ms_quant_file_index() : ms_quant_file_index
  • ~ms_quant_helper() : ms_quant_helper
  • ~ms_quant_integration() : ms_quant_integration
  • ~ms_quant_isotope() : ms_quant_isotope
  • ~ms_quant_localdef() : ms_quant_localdef
  • ~ms_quant_method() : ms_quant_method
  • ~ms_quant_modgroup() : ms_quant_modgroup
  • ~ms_quant_moverz() : ms_quant_moverz
  • ~ms_quant_multiplex() : ms_quant_multiplex
  • ~ms_quant_neutralloss() : ms_quant_neutralloss
  • ~ms_quant_normalisation() : ms_quant_normalisation
  • ~ms_quant_normalisation_peptide() : ms_quant_normalisation_peptide
  • ~ms_quant_normalisation_peptides() : ms_quant_normalisation_peptides
  • ~ms_quant_normalisation_protein() : ms_quant_normalisation_protein
  • ~ms_quant_normalisation_proteins() : ms_quant_normalisation_proteins
  • ~ms_quant_numerator() : ms_quant_numerator
  • ~ms_quant_outliers() : ms_quant_outliers
  • ~ms_quant_parameter() : ms_quant_parameter
  • ~ms_quant_parameters() : ms_quant_parameters
  • ~ms_quant_pepneutralloss() : ms_quant_pepneutralloss
  • ~ms_quant_precursor() : ms_quant_precursor
  • ~ms_quant_protocol() : ms_quant_protocol
  • ~ms_quant_quality() : ms_quant_quality
  • ~ms_quant_ratio() : ms_quant_ratio
  • ~ms_quant_replicate() : ms_quant_replicate
  • ~ms_quant_reporter() : ms_quant_reporter
  • ~ms_quant_satellite() : ms_quant_satellite
  • ~ms_quant_specificity() : ms_quant_specificity
  • ~ms_quant_unmodified() : ms_quant_unmodified
  • ~ms_quantitation() : ms_quantitation
  • ~ms_searchparams() : ms_searchparams
  • ~ms_security_task() : ms_security_task
  • ~ms_security_tasks() : ms_security_tasks
  • ~ms_spectral_lib_entry() : ms_spectral_lib_entry
  • ~ms_spectral_lib_file() : ms_spectral_lib_file
  • ~ms_spectral_lib_peak_list() : ms_spectral_lib_peak_list
  • ~ms_stdout_logger() : ms_stdout_logger
  • ~ms_taxnodesfiles() : ms_taxnodesfiles
  • ~ms_taxonomychoice() : ms_taxonomychoice
  • ~ms_taxonomyfile() : ms_taxonomyfile
  • ~ms_taxonomyrules() : ms_taxonomyrules
  • ~ms_taxonomytree() : ms_taxonomytree
  • ~ms_taxspeciesfiles() : ms_taxspeciesfiles
  • ~ms_tinycdb() : ms_tinycdb
  • ~ms_treecluster() : ms_treecluster
  • ~ms_umod_aminoacid() : ms_umod_aminoacid
  • ~ms_umod_composition() : ms_umod_composition
  • ~ms_umod_configfile() : ms_umod_configfile
  • ~ms_umod_element() : ms_umod_element
  • ~ms_umod_elemref() : ms_umod_elemref
  • ~ms_umod_modbrick() : ms_umod_modbrick
  • ~ms_umod_modification() : ms_umod_modification
  • ~ms_umod_neutralloss() : ms_umod_neutralloss
  • ~ms_umod_specificity() : ms_umod_specificity
  • ~ms_umod_xref() : ms_umod_xref
  • ~ms_unigene_entry() : ms_unigene_entry
  • ~ms_unigeneoptions() : ms_unigeneoptions
  • ~ms_wwwentry() : ms_wwwentry
  • ~ms_wwwoptions() : ms_wwwoptions
  • ~ms_xml_parameter() : ms_xml_parameter
  • ~ms_xml_parameters() : ms_xml_parameters
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Variables

- c -

  • combinedRTinterval : ms_ms1quant_time_align_limits
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Variables

- e -

  • ERR_ACCINPEPTIDESTR : ms_errs
  • ERR_ADDPEPTIDES : ms_errs
  • ERR_CANNOT_APPEND_RESFILE : ms_errs
  • ERR_CANNOT_APPEND_RESFILE_NO_FNAMES : ms_errs
  • ERR_CDB_64_BIT_REMAKE : ms_errs
  • ERR_CDB_BEING_CREATED : ms_errs
  • ERR_CDB_FAIL_LOCK : ms_errs
  • ERR_CDB_FAIL_REMOVE : ms_errs
  • ERR_CDB_FAIL_UNLOCK : ms_errs
  • ERR_CDB_INCOMPLETE_NO_RETRY : ms_errs
  • ERR_CDB_INCOMPLETE_RETRY : ms_errs
  • ERR_CDB_OLD_VER_NO_RETRY : ms_errs
  • ERR_CDB_OLD_VER_RETRY : ms_errs
  • ERR_CDB_SOURCE_CHANGE_NO_RETRY : ms_errs
  • ERR_CDB_SOURCE_CHANGE_RETRY : ms_errs
  • ERR_CDB_TOO_LARGE : ms_errs
  • ERR_DUPE_ACCESSION : ms_errs
  • ERR_DUPLICATE_KEY : ms_errs
  • ERR_FAIL_CDB_INIT : ms_errs
  • ERR_FAIL_CLOSE_FILE : ms_errs
  • ERR_FAIL_MK_CACHE_DIR : ms_errs
  • ERR_FAIL_MK_CDB_FILE : ms_errs
  • ERR_FAIL_OPEN_DAT_FILE : ms_errs
  • ERR_INVALID_CACHE_DIR : ms_errs
  • ERR_INVALID_CDB_FILE : ms_errs
  • ERR_INVALID_NUMQUERIES : ms_errs
  • ERR_INVALID_PROTDB : ms_errs
  • ERR_INVALID_RESFILE : ms_errs
  • ERR_MALFORMED_DRANGE : ms_errs
  • ERR_MALFORMED_ERR_TOL : ms_errs
  • ERR_MALFORMED_TAG : ms_errs
  • ERR_MALFORMED_TERMS : ms_errs
  • ERR_MISSING_CDB_FILE : ms_errs
  • ERR_MISSING_PERCOLATOR_FILE : ms_errs
  • ERR_MISSINGENTRY : ms_errs
  • ERR_MISSINGHIT : ms_errs
  • ERR_MISSINGSECTION : ms_errs
  • ERR_MISSINGSECTIONEND : ms_errs
  • ERR_MSP_BIND_INVALID_CPU : ms_errs
  • ERR_MSP_CACHE_DATAOFFSETINVALID : ms_errs
  • ERR_MSP_CACHE_DUPLICATESTREAMID : ms_errs
  • ERR_MSP_CACHE_FILESEEKFAILED : ms_errs
  • ERR_MSP_CACHE_INVALIDFORMAT : ms_errs
  • ERR_MSP_CACHE_INVALIDSTREAMID : ms_errs
  • ERR_MSP_CACHE_INVALIDSTREAMPOSITION : ms_errs
  • ERR_MSP_CACHE_INVALIDVERSION : ms_errs
  • ERR_MSP_CACHE_MODIFYCLOSED : ms_errs
  • ERR_MSP_CACHE_MODIFYREADONLYMODE : ms_errs
  • ERR_MSP_CACHE_OPENFAILED : ms_errs
  • ERR_MSP_CACHE_PROT_NUMPEPTIDES_RELOAD : ms_errs
  • ERR_MSP_CACHE_READFAILED : ms_errs
  • ERR_MSP_CACHE_SIGNATUREINVALID : ms_errs
  • ERR_MSP_CACHE_SLREF_UPDATE : ms_errs
  • ERR_MSP_CACHE_STREAMNOTFOUND : ms_errs
  • ERR_MSP_CACHE_UNINITIALISEDSTREAM : ms_errs
  • ERR_MSP_CACHE_WRITEFAILED : ms_errs
  • ERR_MSP_CACHE_WRITETRUNCATED : ms_errs
  • ERR_MSP_CLOSEST_FDR_FOR_ET : ms_errs
  • ERR_MSP_CLOSEST_FDR_FOR_FIRST_PASS : ms_errs
  • ERR_MSP_COLOURSCHEME_INVALID : ms_errs
  • ERR_MSP_COMPILE_PARSE_RULE : ms_errs
  • ERR_MSP_CONFLICT_BETWEEN_MODS : ms_errs
  • ERR_MSP_CRON_INVALID_CHAR : ms_errs
  • ERR_MSP_CRON_INVALID_NUMBER : ms_errs
  • ERR_MSP_CRON_INVALID_STAR : ms_errs
  • ERR_MSP_CRON_NO_NUM_BEFORE_COMMA : ms_errs
  • ERR_MSP_CRON_NO_NUM_BEFORE_MINUS : ms_errs
  • ERR_MSP_CRON_TOO_MANY_JOBS : ms_errs
  • ERR_MSP_CROSSLINKING_FAILEDLOAD : ms_errs
  • ERR_MSP_CROSSLINKING_FAILEDSAVE : ms_errs
  • ERR_MSP_CROSSLINKING_INVALID_LINK : ms_errs
  • ERR_MSP_CROSSLINKING_MULTI_LINKS : ms_errs
  • ERR_MSP_CROSSLINKING_MULTI_PEPTIDE : ms_errs
  • ERR_MSP_CROSSLINKING_VARMOD_CONFLICT : ms_errs
  • ERR_MSP_CUSTQUANT_FAILEDINIT : ms_errs
  • ERR_MSP_CUSTQUANT_PROTR_UNIM : ms_errs
  • ERR_MSP_DB_USES_MISSING_RULE : ms_errs
  • ERR_MSP_DIFFERENT_1ST_PASS_THR_ET : ms_errs
  • ERR_MSP_DOUBLE_CHARGE_NOT_ALLOWED : ms_errs
  • ERR_MSP_DUP_TAXONOMYRULE : ms_errs
  • ERR_MSP_DUPLICATE_MOD : ms_errs
  • ERR_MSP_EMPTY_MOD : ms_errs
  • ERR_MSP_ENZYME_DEFINITION_PROBLEM : ms_errs
  • ERR_MSP_ENZYME_FILE_FORMAT : ms_errs
  • ERR_MSP_ENZYME_TOO_MANY_RULES : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_DEPENDS : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_INVALID : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_LOGGING : ms_errs
  • ERR_MSP_FAIL_GET_PROCESS_AFFINITY : ms_errs
  • ERR_MSP_FAIL_GET_SYSINFO : ms_errs
  • ERR_MSP_FAIL_HWLOC_INIT : ms_errs
  • ERR_MSP_FAIL_HWLOC_LOAD : ms_errs
  • ERR_MSP_FAIL_PROCESSOR_BIND : ms_errs
  • ERR_MSP_FAIL_STAT : ms_errs
  • ERR_MSP_FAIL_THREAD_BIND : ms_errs
  • ERR_MSP_FAIL_UTIME : ms_errs
  • ERR_MSP_FAILED_TO_CLOSE_FILE : ms_errs
  • ERR_MSP_FAILED_TO_OPEN_FILE : ms_errs
  • ERR_MSP_FAILED_TO_READ_FILE : ms_errs
  • ERR_MSP_FAILED_TO_WRITE_FILE : ms_errs
  • ERR_MSP_FILE_DOESNT_EXIST : ms_errs
  • ERR_MSP_FRAGMENTATION_RULES : ms_errs
  • ERR_MSP_GET_VOLUME_INFO : ms_errs
  • ERR_MSP_HTTP_ABORTEDBYUSER : ms_errs
  • ERR_MSP_HTTP_BADHTTPSTATUS : ms_errs
  • ERR_MSP_HTTP_CHANGEPASSWORDDISABLED : ms_errs
  • ERR_MSP_HTTP_CLOSECONNECTIONFAILED : ms_errs
  • ERR_MSP_HTTP_CLOSEREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_CLOSESESSIONFAILED : ms_errs
  • ERR_MSP_HTTP_DOWNLOADFAILED : ms_errs
  • ERR_MSP_HTTP_ERROR : ms_errs
  • ERR_MSP_HTTP_GETPROXYFAILED : ms_errs
  • ERR_MSP_HTTP_GETRESULTSFILENAME : ms_errs
  • ERR_MSP_HTTP_GETSEARCHSTAGE : ms_errs
  • ERR_MSP_HTTP_HEADERFAILED : ms_errs
  • ERR_MSP_HTTP_INVALID_URL : ms_errs
  • ERR_MSP_HTTP_LOGINERROR : ms_errs
  • ERR_MSP_HTTP_LOGINERRORINT : ms_errs
  • ERR_MSP_HTTP_LOGINPARSERERROR : ms_errs
  • ERR_MSP_HTTP_LOGINPARSERERRORINT : ms_errs
  • ERR_MSP_HTTP_LOGINSERVERERROR : ms_errs
  • ERR_MSP_HTTP_LOGINSERVERERRORINT : ms_errs
  • ERR_MSP_HTTP_MAXCONECTIONS10FAILED : ms_errs
  • ERR_MSP_HTTP_MAXCONECTIONSFAILED : ms_errs
  • ERR_MSP_HTTP_MISSINGLOGINERROR : ms_errs
  • ERR_MSP_HTTP_MISSINGLOGININFO : ms_errs
  • ERR_MSP_HTTP_NORESPONSE : ms_errs
  • ERR_MSP_HTTP_OPENCONNECTIONFAILED : ms_errs
  • ERR_MSP_HTTP_OPENOUTPUTFILEFAILED : ms_errs
  • ERR_MSP_HTTP_OPENREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_OPENSESSIONFAILED : ms_errs
  • ERR_MSP_HTTP_QUERYDATAFAILED : ms_errs
  • ERR_MSP_HTTP_QUERYSTATUSFAILED : ms_errs
  • ERR_MSP_HTTP_READDATAFAILED : ms_errs
  • ERR_MSP_HTTP_READRESPONSEFAILED : ms_errs
  • ERR_MSP_HTTP_RELOGINFAILED : ms_errs
  • ERR_MSP_HTTP_SENDREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_SESSIONALREADYOPEN : ms_errs
  • ERR_MSP_HTTP_SETHTTPPASSWORDFAILED : ms_errs
  • ERR_MSP_HTTP_SETHTTPUSERNAMEFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYPASSWORDFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYUSERNAMEFAILED : ms_errs
  • ERR_MSP_HTTP_SETREDIRECTFAILED : ms_errs
  • ERR_MSP_HTTP_TRANSMISSION_FAILED : ms_errs
  • ERR_MSP_HTTP_VERSIONERROR : ms_errs
  • ERR_MSP_HTTP_WEBAUTHERROR : ms_errs
  • ERR_MSP_HTTP_WRITEOUTPUTFILEFAILED : ms_errs
  • ERR_MSP_HTTP_XMLUPLOADFAILED : ms_errs
  • ERR_MSP_IMPUTATION_AVERAGE_PROGRESS : ms_errs
  • ERR_MSP_IMPUTATION_CONSTRUCTOR : ms_errs
  • ERR_MSP_IMPUTATION_DEBUG1 : ms_errs
  • ERR_MSP_IMPUTATION_DEBUG2 : ms_errs
  • ERR_MSP_IMPUTATION_DEBUG3 : ms_errs
  • ERR_MSP_IMPUTATION_EMPTY_DATA : ms_errs
  • ERR_MSP_IMPUTATION_FAIL : ms_errs
  • ERR_MSP_IMPUTATION_FIXED_PROGRESS : ms_errs
  • ERR_MSP_IMPUTATION_KNN_BLANK_ROW : ms_errs
  • ERR_MSP_IMPUTATION_KNN_PROGRESS : ms_errs
  • ERR_MSP_IMPUTATION_MISSFOR_PROGRESS : ms_errs
  • ERR_MSP_IMPUTATION_NO_RATIOS_PEPTIDE : ms_errs
  • ERR_MSP_IMPUTATION_NO_RATIOS_PROTEIN : ms_errs
  • ERR_MSP_IMPUTATION_NO_TIMES : ms_errs
  • ERR_MSP_IMPUTATION_VARIABLE : ms_errs
  • ERR_MSP_IMPUTATION_WARNING : ms_errs
  • ERR_MSP_IN_CLUSTER_SECTION : ms_errs
  • ERR_MSP_IN_MASCOT_DAT_DB_SECT : ms_errs
  • ERR_MSP_IN_MASSES_FILE : ms_errs
  • ERR_MSP_IN_MODS_FILE : ms_errs
  • ERR_MSP_IN_OPTIONS_SECTION : ms_errs
  • ERR_MSP_IN_TAXONOMY_SECTION : ms_errs
  • ERR_MSP_INCOMPATIBLE_TAX_RULES : ms_errs
  • ERR_MSP_INST_CANTGETHOSTNAME : ms_errs
  • ERR_MSP_INST_FAILADDPARSERULE : ms_errs
  • ERR_MSP_INST_INVALIDCPUINFO : ms_errs
  • ERR_MSP_INST_MISSINGDATABASE : ms_errs
  • ERR_MSP_INVALID_CPU_PACKAGE_NUM : ms_errs
  • ERR_MSP_INVALID_LOGICAL_CPU_NUM : ms_errs
  • ERR_MSP_INVALID_MASS_IN_MASSES_FILE : ms_errs
  • ERR_MSP_INVALID_NUM_LICENSED : ms_errs
  • ERR_MSP_INVALID_PARSE_RULE : ms_errs
  • ERR_MSP_INVALID_PARSE_RULE_NO : ms_errs
  • ERR_MSP_INVALID_PROCESSOR_LINE : ms_errs
  • ERR_MSP_LEGACY_DATA_NOT_AVAILABLE : ms_errs
  • ERR_MSP_LEGACY_DATA_READ_ERROR : ms_errs
  • ERR_MSP_LEGACY_DATA_SQL_ERROR : ms_errs
  • ERR_MSP_LEGACY_DATA_WRONG_FORMAT : ms_errs
  • ERR_MSP_LICENSE_DES_CHECKSUM : ms_errs
  • ERR_MSP_LICENSE_EXPIRED : ms_errs
  • ERR_MSP_LICENSE_INTERNAL_CONFIG : ms_errs
  • ERR_MSP_LICENSE_LINE_CHECKSUM : ms_errs
  • ERR_MSP_LICENSE_LINE_INVALID : ms_errs
  • ERR_MSP_LICENSE_NOT_YET_AVAIL : ms_errs
  • ERR_MSP_LOOPLINKING_NOT_IMPLEMENTED : ms_errs
  • ERR_MSP_MALFORMED_PEPTIDE : ms_errs
  • ERR_MSP_MASCOT_NOT_RUNNING : ms_errs
  • ERR_MSP_MAX_PREFIX_REMOVES : ms_errs
  • ERR_MSP_MAX_SUFFIX_REMOVES : ms_errs
  • ERR_MSP_MAX_TAX_NO_BREAKS : ms_errs
  • ERR_MSP_MISSING_DEFINITION_END : ms_errs
  • ERR_MSP_MISSING_ENZYME_TITLE : ms_errs
  • ERR_MSP_MISSING_ET_MOD : ms_errs
  • ERR_MSP_MISSING_MASCOT_DAT : ms_errs
  • ERR_MSP_MISSING_MONOLINK_MOD : ms_errs
  • ERR_MSP_MISSING_QUOTE_IN_PARSE_RULE : ms_errs
  • ERR_MSP_MISSING_SECTION : ms_errs
  • ERR_MSP_MISSING_SL_MOD : ms_errs
  • ERR_MSP_MOD_MUST_BE_VAR : ms_errs
  • ERR_MSP_MS1QUANT_CDB_BYTES : ms_errs
  • ERR_MSP_MS1QUANT_CDB_MISSING_KEY : ms_errs
  • ERR_MSP_MS1QUANT_CDB_VERSION : ms_errs
  • ERR_MSP_MS1QUANT_GET_COMBINED_LIMITS : ms_errs
  • ERR_MSP_MS1QUANT_INVALID_PROJECT_ID : ms_errs
  • ERR_MSP_MS1QUANT_NO_EST_WIDTH : ms_errs
  • ERR_MSP_MS1QUANT_RTOFFSET_DIFF_FRACT : ms_errs
  • ERR_MSP_MS1QUANT_TIME_ALIGIN_CALCFRM : ms_errs
  • ERR_MSP_MS1QUANT_TIME_ALIGN_INDEX : ms_errs
  • ERR_MSP_MS1QUANT_XML_INVALID_BIN1 : ms_errs
  • ERR_MSP_MS1QUANT_XML_INVALID_BIN2 : ms_errs
  • ERR_MSP_MS1QUANT_XML_INVALID_RT : ms_errs
  • ERR_MSP_MS1QUANT_XML_LOAD_PROJECT_ID : ms_errs
  • ERR_MSP_MS1QUANT_XML_PARSE : ms_errs
  • ERR_MSP_MS1QUANT_XML_SAX_ELEMENT : ms_errs
  • ERR_MSP_MS1QUANT_XML_SAX_STATE : ms_errs
  • ERR_MSP_MS1QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_MS1QUANTITATION_HITREF_DROP : ms_errs
  • ERR_MSP_MS1QUANTITATION_HITREF_NEW : ms_errs
  • ERR_MSP_MS2QUANTITATION_COMPONENTS : ms_errs
  • ERR_MSP_MS2QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_MS2QUANTITATION_NORM_NO_SUM : ms_errs
  • ERR_MSP_MS2QUANTITATION_NORM_UNIMP : ms_errs
  • ERR_MSP_MS2QUANTITATION_PROTR_UNIM : ms_errs
  • ERR_MSP_MS2QUANTITATION_PROTWEIGH : ms_errs
  • ERR_MSP_MS2QUANTITATION_QUERY_SECS : ms_errs
  • ERR_MSP_MSR_CREATING_FILE : ms_errs
  • ERR_MSP_MSR_READING_FILE : ms_errs
  • ERR_MSP_MSR_WRITING_FILE : ms_errs
  • ERR_MSP_NEED_1_EXP_IN_PARSE_RULE : ms_errs
  • ERR_MSP_NIST_CANNOT_ANNOTATE_PEAK : ms_errs
  • ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY : ms_errs
  • ERR_MSP_NIST_INDEX_OUT_OF_RANGE : ms_errs
  • ERR_MSP_NIST_MODIFICATION_NOT_FOUND : ms_errs
  • ERR_MSP_NIST_MSP_INCONSISTENT_MODS : ms_errs
  • ERR_MSP_NIST_MSP_INVALID_LINE : ms_errs
  • ERR_MSP_NIST_MSP_MISSING_PARAMETER : ms_errs
  • ERR_MSP_NIST_MSP_NO_CREATE_CDB : ms_errs
  • ERR_MSP_NIST_MSP_NO_SPECTRA : ms_errs
  • ERR_MSP_NIST_NO_PEAKS_IN_SPECTRUM : ms_errs
  • ERR_MSP_NIST_NO_PRECURSOR_MZ_VALUE : ms_errs
  • ERR_MSP_NIST_SAVE_ZERO_SPECTRA : ms_errs
  • ERR_MSP_NO_COMMAS_IN_MOD_NAME : ms_errs
  • ERR_MSP_NO_ENZYME_SET : ms_errs
  • ERR_MSP_NO_LICENSE_FILE : ms_errs
  • ERR_MSP_NO_REGEX_MATCH : ms_errs
  • ERR_MSP_NO_SUCH_MOD : ms_errs
  • ERR_MSP_PARSE_LEN_EXCEED : ms_errs
  • ERR_MSP_PERCOLATOR_USE_RT_OBSOLETE : ms_errs
  • ERR_MSP_PROCESSOR_NOT_IN_SET : ms_errs
  • ERR_MSP_QUANT_ACCESSION_NOT_FOUND : ms_errs
  • ERR_MSP_QUANT_CDB_MATCH_STREAM : ms_errs
  • ERR_MSP_QUANT_CDB_MISSING_KEY : ms_errs
  • ERR_MSP_QUANT_EMPTY_REF_ACCESSION : ms_errs
  • ERR_MSP_QUANT_FAIL_LOAD_MATCH : ms_errs
  • ERR_MSP_QUANT_FAIL_LOAD_PEPTIDE : ms_errs
  • ERR_MSP_QUANT_FAILEDLOAD : ms_errs
  • ERR_MSP_QUANT_FAILEDSAVE : ms_errs
  • ERR_MSP_QUANT_HELPER_FAILEDINIT : ms_errs
  • ERR_MSP_QUANT_INVALID_REF_AMOUNT : ms_errs
  • ERR_MSP_QUANT_MISSING_COMPONENT : ms_errs
  • ERR_MSP_QUANTITATION_BADCOMPONENT : ms_errs
  • ERR_MSP_QUANTITATION_BADMETHOD : ms_errs
  • ERR_MSP_QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_QUANTITATION_NOMETHOD : ms_errs
  • ERR_MSP_REGEX_ERROR : ms_errs
  • ERR_MSP_REPORTBUILDERCOLARR_INVALID : ms_errs
  • ERR_MSP_RESIDUE_AND_TERMINUS_MOD : ms_errs
  • ERR_MSP_RULE_NO_ALREADY_DEFINED : ms_errs
  • ERR_MSP_SECURITY_ACCOUNT_DISABLED : ms_errs
  • ERR_MSP_SECURITY_ADDGROUP : ms_errs
  • ERR_MSP_SECURITY_ADDUSER : ms_errs
  • ERR_MSP_SECURITY_BAD_GROUP_NAME : ms_errs
  • ERR_MSP_SECURITY_BAD_USER_NAME : ms_errs
  • ERR_MSP_SECURITY_CMDLINE_CGI : ms_errs
  • ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP : ms_errs
  • ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS : ms_errs
  • ERR_MSP_SECURITY_DEL_SPECIAL_GROUP : ms_errs
  • ERR_MSP_SECURITY_DEL_SPECIAL_USER : ms_errs
  • ERR_MSP_SECURITY_DELETEGROUP : ms_errs
  • ERR_MSP_SECURITY_DELUSER : ms_errs
  • ERR_MSP_SECURITY_DIFFERENTIPADDR : ms_errs
  • ERR_MSP_SECURITY_DISABLE_ADMIN : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_ID : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_NAME : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_NAME_U : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_ID : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_NAME : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_NAME_U : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_GROUP : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_SEC : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_USER : ms_errs
  • ERR_MSP_SECURITY_FAIL_SAVE_SEC : ms_errs
  • ERR_MSP_SECURITY_FAILGETINTEGRA : ms_errs
  • ERR_MSP_SECURITY_FAILGETINTEGRAURL : ms_errs
  • ERR_MSP_SECURITY_GETALLGROUPIDS : ms_errs
  • ERR_MSP_SECURITY_GETALLUSERIDS : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFAIL : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFROMIDFAIL : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFROMIDOK : ms_errs
  • ERR_MSP_SECURITY_GETGROUPOK : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS1 : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS2 : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS3 : ms_errs
  • ERR_MSP_SECURITY_GETPERMTASKSFAIL : ms_errs
  • ERR_MSP_SECURITY_GETPERMTASKSOK : ms_errs
  • ERR_MSP_SECURITY_GETUSERFAIL : ms_errs
  • ERR_MSP_SECURITY_GETUSERFROMIDFAIL : ms_errs
  • ERR_MSP_SECURITY_GETUSERFROMIDOK : ms_errs
  • ERR_MSP_SECURITY_GETUSEROK : ms_errs
  • ERR_MSP_SECURITY_GROUPID_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_INTEGRACONNFORMAT : ms_errs
  • ERR_MSP_SECURITY_INTEGRAINVALIDCO : ms_errs
  • ERR_MSP_SECURITY_INTEGRAINVALIDPW : ms_errs
  • ERR_MSP_SECURITY_INVALID_SESSION_ID : ms_errs
  • ERR_MSP_SECURITY_INVALIDPASSWORD : ms_errs
  • ERR_MSP_SECURITY_INVALIDSESSION : ms_errs
  • ERR_MSP_SECURITY_INVALIDUSER : ms_errs
  • ERR_MSP_SECURITY_LOADINGSESS : ms_errs
  • ERR_MSP_SECURITY_LOADSESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_MISSINGSESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_MSSESSCOOKIE : ms_errs
  • ERR_MSP_SECURITY_MSSESSINTEGRA : ms_errs
  • ERR_MSP_SECURITY_MSSESSIONCTOR : ms_errs
  • ERR_MSP_SECURITY_MSSESSLOGIN : ms_errs
  • ERR_MSP_SECURITY_MSSESSRESULTSPERM : ms_errs
  • ERR_MSP_SECURITY_NO_GUEST_PWD : ms_errs
  • ERR_MSP_SECURITY_NO_INTEGRA_LOGIN : ms_errs
  • ERR_MSP_SECURITY_NO_RIGHTS_UPD_USR : ms_errs
  • ERR_MSP_SECURITY_NOCREATEGUEST : ms_errs
  • ERR_MSP_SECURITY_NOSAVEPARAMS : ms_errs
  • ERR_MSP_SECURITY_NOT_ADMIN_SESSION : ms_errs
  • ERR_MSP_SECURITY_NOT_ENABLED : ms_errs
  • ERR_MSP_SECURITY_NOT_INTEGRA_USER : ms_errs
  • ERR_MSP_SECURITY_NOTLOGGEDIN : ms_errs
  • ERR_MSP_SECURITY_NOTNORMALUSER : ms_errs
  • ERR_MSP_SECURITY_OLD_PW_INVALID : ms_errs
  • ERR_MSP_SECURITY_PASSWORD_TOO_SHORT : ms_errs
  • ERR_MSP_SECURITY_PASSWORDEXPIRED : ms_errs
  • ERR_MSP_SECURITY_SAMEPASSWORD : ms_errs
  • ERR_MSP_SECURITY_SAVESESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_SESSIONDESTROYED : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT1 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT2 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT3 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT4 : ms_errs
  • ERR_MSP_SECURITY_TIMEDOUT : ms_errs
  • ERR_MSP_SECURITY_UPDATEALLSESSFILES : ms_errs
  • ERR_MSP_SECURITY_UPDATEGROUP : ms_errs
  • ERR_MSP_SECURITY_UPDATEPW : ms_errs
  • ERR_MSP_SECURITY_UPDATESESS : ms_errs
  • ERR_MSP_SECURITY_UPDATEUSER : ms_errs
  • ERR_MSP_SECURITY_USERID_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_USERNAME_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRACO1 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRACO2 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW1 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW2 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW3 : ms_errs
  • ERR_MSP_SESSION_UTIME_FAIL : ms_errs
  • ERR_MSP_SL_SCORING_MODEL_FAIL : ms_errs
  • ERR_MSP_SL_SCORING_MODEL_WARN : ms_errs
  • ERR_MSP_SPECIFY_UNAVAILABLE_PROCESSOR : ms_errs
  • ERR_MSP_SYSMP_FAIL : ms_errs
  • ERR_MSP_TARGET_FDR_FAILED_FOR_ET : ms_errs
  • ERR_MSP_TARGET_FDR_FAILED_FOR_FIRST_PASS : ms_errs
  • ERR_MSP_TAXONOMY_CONFLICT_PARENTS : ms_errs
  • ERR_MSP_TAXONOMY_DEFINITION_END : ms_errs
  • ERR_MSP_TAXONOMY_INVALID_NODE_FILE : ms_errs
  • ERR_MSP_TAXONOMY_MISSING_NODE_FILE : ms_errs
  • ERR_MSP_TAXONOMY_NO_COMMAS : ms_errs
  • ERR_MSP_TAXONOMY_NO_TITLE : ms_errs
  • ERR_MSP_TAXONOMY_WRONG_LINE : ms_errs
  • ERR_MSP_TOO_MANY_MODS_IN_MOD_FILE : ms_errs
  • ERR_MSP_TOO_MANY_PROCESSORS : ms_errs
  • ERR_MSP_TOO_MANY_TH_PROCESSORS : ms_errs
  • ERR_MSP_UMOD_FAILEDLOAD : ms_errs
  • ERR_MSP_UMOD_FAILEDSAVE : ms_errs
  • ERR_MSP_UNEXPECTED_LINE_OUT_OF_SECT : ms_errs
  • ERR_MSP_WRONG_ICAT_FILTER : ms_errs
  • ERR_MSP_WRONG_MOD_VECTOR : ms_errs
  • ERR_MSP_WWW_SECTION : ms_errs
  • ERR_MSP_XHUNTER_WRONG_FORMAT : ms_errs
  • ERR_MSP_XML_ELEMENT_NOT_FOUND : ms_errs
  • ERR_MSP_XML_FAILEDLOAD : ms_errs
  • ERR_MSP_XML_FAILEDSAVE : ms_errs
  • ERR_MSP_XML_FIELD_NOTFOUND : ms_errs
  • ERR_MSP_XML_INVALID_FIELD_FORMAT : ms_errs
  • ERR_MSP_XML_LOCAL_SCHEMA_NOT_STORED : ms_errs
  • ERR_MSP_XML_MEMORY_ERROR : ms_errs
  • ERR_MSP_XML_NO_ROOT_ELEMENT : ms_errs
  • ERR_MSP_XML_SYSTEM_FAILED : ms_errs
  • ERR_MSP_XML_TABLE_NOTFOUND : ms_errs
  • ERR_MSP_XMLSCHEMA_FAILEDLOAD : ms_errs
  • ERR_MSP_XMLSCHEMA_FAILEDSAVE : ms_errs
  • ERR_MSP_ZIP_BUFTOOSMALL : ms_errs
  • ERR_MSP_ZIP_COMPRESSEDDATATOOLONG : ms_errs
  • ERR_MSP_ZIP_ENDIAN : ms_errs
  • ERR_MSP_ZIP_INVALID_STREAMING_MODE : ms_errs
  • ERR_MSP_ZIP_INVALIDDATA : ms_errs
  • ERR_MSP_ZIP_LENGTHDIFFERS : ms_errs
  • ERR_MSP_ZIP_NOTSTREAMING : ms_errs
  • ERR_MSP_ZIP_OUTOFMEMORY : ms_errs
  • ERR_MSP_ZIP_STREAMERROR : ms_errs
  • ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG : ms_errs
  • ERR_MSP_ZIP_UNKNOWN : ms_errs
  • ERR_MSP_ZIP_VERSIONERROR : ms_errs
  • ERR_MSP_ZIP_ZEROLENGTH : ms_errs
  • ERR_NEED_64_BIT : ms_errs
  • ERR_NO_ERR_TOL_PARENT : ms_errs
  • ERR_NO_ERROR : ms_errs
  • ERR_NO_UNIGENE_FILE : ms_errs
  • ERR_NOMEM : ms_errs
  • ERR_NOSUCHFILE : ms_errs
  • ERR_NULL_ACC_PEP_SUM : ms_errs
  • ERR_NULL_ACC_PROT_SUM : ms_errs
  • ERR_OLDRESULTSFILE : ms_errs
  • ERR_PEPSUMMPEPGET : ms_errs
  • ERR_PEPTIDESTR : ms_errs
  • ERR_PROTSUMM : ms_errs
  • ERR_PROTSUMMPEP : ms_errs
  • ERR_QUERYOUTOFRANGE : ms_errs
  • ERR_READINGFILE : ms_errs
  • ERR_RESFILE_FUTURE_VERSION : ms_errs
  • ERR_RESFILE_INVALID_DB_TYPE : ms_errs
  • ERR_RESFILE_LINKED_SITES : ms_errs
  • ERR_RESFILE_LOOPLINKED_SITES : ms_errs
  • ERR_RESFILE_MISSING_QEXP : ms_errs
  • ERR_RESULTS_NOT_CREATED : ms_errs
  • ERR_UNASSIGNED_PROG : ms_errs
  • ERR_UNASSIGNED_RANGE : ms_errs
  • ERR_UNASSIGNED_UNK : ms_errs
  • ERR_UNIGENE_MULTIDB : ms_errs
  • ERR_WRITE_CDB_FILE : ms_errs
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Variables

- f -

  • file_index_value_not_set : ms_quant_file_index
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Variables

- l -

  • LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER : ms_log
  • LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK : ms_log
  • LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK : ms_log
  • LOGMSG_AAHELPER_CFR_MASSES_VALUE : ms_log
  • LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE : ms_log
  • LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS : ms_log
  • LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT : ms_log
  • LOGMSG_AAHELPER_CFR_START_FRAGMENTS : ms_log
  • LOGMSG_AAHELPER_CROSSLINKED_END : ms_log
  • LOGMSG_AAHELPER_CROSSLINKED_START : ms_log
  • LOGMSG_AAHELPER_CUMULATIVE_MASS_NL : ms_log
  • LOGMSG_AAHELPER_ETMOD_LOOKUP : ms_log
  • LOGMSG_AAHELPER_IMMONIUM_ION_ADD : ms_log
  • LOGMSG_AAHELPER_IMMONIUM_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_INTERNAL_ION_ADD : ms_log
  • LOGMSG_AAHELPER_INTERNAL_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_MASTER_NL_VALS : ms_log
  • LOGMSG_AAHELPER_MULTINL_INDICES : ms_log
  • LOGMSG_AAHELPER_REGULAR_ION_ADD : ms_log
  • LOGMSG_AAHELPER_REGULAR_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD : ms_log
  • LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_SERIES_PARAMS : ms_log
  • LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG : ms_log
  • LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT : ms_log
  • LOGMSG_AAHELPER_TOTAL_NL_VALS : ms_log
  • LOGMSG_CUSTQUANT_ADD_QUANT_KEY : ms_log
  • LOGMSG_CUSTQUANT_REMOVE_ALL_KEY : ms_log
  • LOGMSG_CUSTQUANT_REMOVE_KEY : ms_log
  • LOGMSG_DBG1_NUM_PROCESSOR_GROUPS : ms_log
  • LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS : ms_log
  • LOGMSG_DBG2_CPU_INF_GETAUTODETECT : ms_log
  • LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS : ms_log
  • LOGMSG_DBG2_CPU_INF_MT_NAME : ms_log
  • LOGMSG_DBG2_CPU_INF_MT_STATUS : ms_log
  • LOGMSG_DBG2_CPU_INF_NAME : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_AVAIL : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_GROUPS : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_ON_SYS : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL : ms_log
  • LOGMSG_DBG2_CPU_INF_PROC_AFFINITY : ms_log
  • LOGMSG_DBG2_CPU_INF_TABLE_LINE : ms_log
  • LOGMSG_DBG2_CPU_INF_TABLE_TITLE : ms_log
  • LOGMSG_DBG2_CPU_INF_USE_PROCESSES : ms_log
  • LOGMSG_DBG2_NUM_CONFIG_MISMATCH : ms_log
  • LOGMSG_DBG2_NUM_ONLINE_MISMATCH : ms_log
  • LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD : ms_log
  • LOGMSG_DBG3_BINDING_PROCESSORS : ms_log
  • LOGMSG_DBG3_BINDING_THREAD : ms_log
  • LOGMSG_DBG3_CALL_GET_CHIP_MFCTR : ms_log
  • LOGMSG_DBG3_HWLOC_GROUPS : ms_log
  • LOGMSG_DBG3_HWLOC_TREE : ms_log
  • LOGMSG_DBG3_PROCESSOR_NAME : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_START : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT : ms_log
  • LOGMSG_GET_THR_REACH_COND : ms_log
  • LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET : ms_log
  • LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR : ms_log
  • LOGMSG_HTTP_GETRETURNSTRING : ms_log
  • LOGMSG_HTTP_MAXCONECTIONS10FAILED : ms_log
  • LOGMSG_HTTP_MAXCONECTIONSFAILED : ms_log
  • LOGMSG_HTTP_QUERYSTATUSRESULT : ms_log
  • LOGMSG_HTTP_URLSTRING : ms_log
  • LOGMSG_INST_ADDINGDATABASE : ms_log
  • LOGMSG_INST_ADDOPTIONSSECTION : ms_log
  • LOGMSG_INST_APPENDPARSERULE : ms_log
  • LOGMSG_INST_APPENDTAXONOMY : ms_log
  • LOGMSG_INST_CHANGEDBTAXONOMY : ms_log
  • LOGMSG_INST_CHANGEPARSERULE : ms_log
  • LOGMSG_INST_CHANGEPERCOLATORFEATS : ms_log
  • LOGMSG_INST_CHANGEPERCOLATORUSERT : ms_log
  • LOGMSG_INST_CHANGEPROTFAMILYSWITCH : ms_log
  • LOGMSG_INST_CHANGERESULTSCACHE : ms_log
  • LOGMSG_INST_CHANGESPLITDATAFILESIZE : ms_log
  • LOGMSG_INST_CHANGESPLITNUMOFQUERIES : ms_log
  • LOGMSG_INST_CLUSTERSECTION : ms_log
  • LOGMSG_INST_FAILSAVEPOSTINSTALLFILE : ms_log
  • LOGMSG_INST_LOGICALPERPHYSICALCPU : ms_log
  • LOGMSG_INST_MASCOTDATOK : ms_log
  • LOGMSG_INST_NOSUBCLUSTERSET : ms_log
  • LOGMSG_INST_NOTMASCOTDATOK : ms_log
  • LOGMSG_INST_NUMTHREADS : ms_log
  • LOGMSG_INST_REMOVEOPTIONSSECTION : ms_log
  • LOGMSG_INST_SAVEDPOSTINSTALLFILE : ms_log
  • LOGMSG_INST_SETOPTIONSSECTION : ms_log
  • LOGMSG_MATRIX_OUTPUT_VALS : ms_log
  • LOGMSG_MSR2DAT28_SQL_TRACING : ms_log
  • LOGMSG_NON_DEFAULT_HOMOLOGY_THRESHOLD : ms_log
  • LOGMSG_PEPSUM_GETHIT : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_START : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST : ms_log
  • LOGMSG_PROTINFER_CLUSTER_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_END : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_QUEUE : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_START : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_START : ms_log
  • LOGMSG_PROTINFER_GROUP_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY : ms_log
  • LOGMSG_PROTINFER_PEPTIDE_MATRIX : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_START : ms_log
  • LOGMSG_PROTINFER_SINGLETON_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_DONE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_START : ms_log
  • LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT : ms_log
  • LOGMSG_QUANT_ADDED_PROTEIN_HIT : ms_log
  • LOGMSG_QUANT_ADDING_PROTEIN_HIT : ms_log
  • LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED : ms_log
  • LOGMSG_QUANT_CLOSING_CACHE_FILE : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN : ms_log
  • LOGMSG_QUANT_FINISH_CALC_COMPLETE : ms_log
  • LOGMSG_QUANT_FINISH_LOAD_CDB : ms_log
  • LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE : ms_log
  • LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES : ms_log
  • LOGMSG_QUANT_HELPER_TEST_REQUIRED : ms_log
  • LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES : ms_log
  • LOGMSG_QUANT_LOADING_MATCHES : ms_log
  • LOGMSG_QUANT_MERGE_COMPONENT_DUPE_FI : ms_log
  • LOGMSG_QUANT_MERGE_COMPONENT_INCONSIST : ms_log
  • LOGMSG_QUANT_MERGE_COMPONENT_SUCCESS : ms_log
  • LOGMSG_QUANT_OPENING_CACHE_FILE : ms_log
  • LOGMSG_QUANT_REAPPLY_THRESHOLDS : ms_log
  • LOGMSG_QUANT_REMATCHING_INFERRED : ms_log
  • LOGMSG_QUANT_REMOVE_INFERRED_MATCH : ms_log
  • LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE : ms_log
  • LOGMSG_QUANT_RT_OFFSET_LOOKUP : ms_log
  • LOGMSG_QUANT_START_CALC_COMPLETE : ms_log
  • LOGMSG_QUANT_START_LOAD_CDB : ms_log
  • LOGMSG_QUANT_START_REORDER_AFTER_MERGE : ms_log
  • LOGMSG_QUANT_START_UPDATE_PROT_MATCHES : ms_log
  • LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE : ms_log
  • LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE1 : ms_log
  • LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES : ms_log
  • LOGMSG_QUANT_UPDATING_PEP_EVIDENCE : ms_log
  • LOGMSG_REPORT_FUNCTION_CALLED_BY : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 : ms_log
  • LOGMSG_REPORT_FUNCTION_EXIT : ms_log
  • LOGMSG_REPORT_FUNCTION_EXIT_WITH : ms_log
  • LOGMSG_RESFILE_APPEND : ms_log
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Variables

- p -

  • proteinKeys_ : ms_quantitation
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Typedefs

  • combinedRT_t : ms_ms1quant_time_align_limits
  • err : ms_errs
  • featureWidths_t : ms_ms1quant_time_align
  • fractionToSubProject_t : ms_ms1quant_time_align
  • msg_num_t : ms_log
  • TAX_CHOP_SRC : ms_parserule_plus
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerations

- b -

  • BUGFIX_NUM : ms_peptidesummary

- c -

  • CACHE_STATUS : ms_peptidesummary
  • ChangePasswordResultCode : ms_http_client
  • chargeType : ms_ms1quant_match
  • CMD_ARGUMENT_PARSE_RESULT : ms_fileutilities
  • compareXMLFiles_flags : ms_fileutilities
  • cuttertype : ms_enzyme

- d -

  • DB_MATCH_TYPE : ms_mascotresults
  • DECOY_ALGORITHM : ms_mascotoptions
  • DECOY_STATS_COUNT_TYPE : ms_mascotresults
  • DISTINCT_PEPTIDE_FLAGS : ms_protein
  • DownloadOption : ms_http_client_search
  • DUPLICATE : ms_protein

- e -

  • eGrouping : ms_distiller_data_search
  • err : ms_mascotresfile_dat
  • err_sar : ms_fileutilities
  • ErrorTypeCode : ms_http_helper_return
  • eScoring : ms_distiller_data_search
  • eSpectralLibrary : ms_distiller_data_search
  • EXEC_AFTER_SEARCH : ms_mascotoptions

- f -

  • FileMode : ms_http_helper
  • FIND_COMPARE_FLAGS : ms_mascotresults
  • FIND_FLAGS : ms_mascotresults
  • FLAGS : ms_mascotresfilebase, ms_mascotresults
  • FRAG_NL : ms_aahelper
  • FRAG_SERIES_TYPE : ms_fragmentationrules

- g -

  • GROUP : ms_protein

- h -

  • HOMOLOGY_THRESHOLD_SOURCE : ms_mascotresults
  • HTTP_PROTOCOL : ms_connection_settings
  • HYPERTHREADING : ms_processors

- i -

  • IMPUTATION_VARIABLE : ms_imputation
  • INST_FLAGS : ms_datfile
  • IONS_HISTOGRAM : ms_mascotresults

- k -

  • KA_TASK : ms_mascotresfilebase

- l -

  • LABEL_FORMAT : ms_fragment
  • Level_e : ms_loggingmonitor
  • LoginResultCode : ms_http_client
  • LogOutputColumns_e : ms_logger

- m -

  • MASS_FLAGS : ms_protein
  • MATCH_PEAKS : ms_fragmentvector
  • MERGE_QUANT_RESULTS_FLAGS : ms_ms1quantitation
  • METHOD_COMPATIBLE : ms_quant_method
  • MODFILE_FLAGS : ms_umod_configfile
  • MS1QUANT_BUGFIX_NUM : ms_ms1quantitation
  • MS_REVIEW_COL : ms_mascotoptions
  • msg_sev : ms_log
  • MSPEPSUM : ms_peptidesummary
  • MULTI_SITE_MODS : ms_searchparams

- n -

  • NUMERICAL_VALUE_STORAGE : ms_mascotoptions

- p -

  • paramType : ms_security_task
  • PEAK_ANNOTATION_LEVEL : ms_spectral_lib_peak_list
  • peakState : ms_xic
  • PEPTIDE_QUALITY : ms_quant_helper
  • PEPTIDE_QUANTIFIABILITY : ms_quant_helper
  • peptideStatus : ms_ms1quant_peptide_status
  • PERC_EXE_RT : ms_mascotoptions
  • PERCOLATOR_FILE_NAMES : ms_mascotresfilebase
  • PROXY_TYPE : ms_connection_settings
  • PSM : ms_peptide
  • PSM_TYPE : ms_peptide

- q -

  • QL_FLAG : ms_peptidesummary
  • QUANT_COMPONENT_STATUS : ms_mascotresults

- r -

  • ratioStatusCode : ms_ms1quant_match_ratio
  • REDIRECT_POLICY : ms_connection_settings
  • ReportTopSpecialValues : ms_http_client_search
  • RESFILE_TYPE : ms_mascotresfilebase

- s -

  • SearchStatusCode : ms_http_client_search
  • section : ms_mascotresfile_dat
  • SEQDB_INSTALL : ms_datfile
  • SequenceShowOptions : ms_http_client_session
  • sortBy : ms_mascotresults
  • Source_e : ms_loggingmonitor
  • STATUS : ms_progress_info
  • status_t : ms_ms1quant_time_align
  • systemids : ms_group, ms_user

- t -

  • TASKID : ms_security_tasks
  • TAX_CHOP_TYPES : ms_parserule_plus
  • THRESHOLD_TYPE : ms_mascotresults
  • TOLERANCE_UNIT : ms_fragmentvector
  • TREE_CLUSTER_DISTANCE : ms_treecluster
  • TREE_CLUSTER_METHOD : ms_mascotresults

- u -

  • UNIQUE_PEP_RULES : ms_mascotresults
  • UploadResponseCode : ms_http_client_search
  • USERID_SORTBY : ms_security
  • usertype : ms_user

- w -

  • WHAT_TO_ANNOTATE : ms_spectral_lib_entry
  • WST : ms_datfile

- x -

  • XML_SCHEMA : ms_mascotresfilebase
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- a -

  • ANNOT_LVL_CANNOT_ANNOTATE : ms_spectral_lib_peak_list
  • ANNOT_LVL_NONE : ms_spectral_lib_peak_list
  • ANNOT_LVL_QUESTION_MARKS : ms_spectral_lib_peak_list
  • ANNOT_LVL_SOME_PEAKS : ms_spectral_lib_peak_list
  • ANNOTATE_NONE : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_ALL : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_IF_ALL_EMPTY : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_QUESTION_MARKS : ms_spectral_lib_entry
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- b -

  • BUGFIX_10780 : ms_peptidesummary
  • BUGFIX_10995 : ms_peptidesummary
  • BUGFIX_11002 : ms_peptidesummary
  • BUGFIX_11018 : ms_peptidesummary
  • BUGFIX_11235 : ms_peptidesummary
  • BUGFIX_11254 : ms_peptidesummary
  • BUGFIX_11344 : ms_peptidesummary
  • BUGFIX_11411 : ms_peptidesummary
  • BUGFIX_11425 : ms_peptidesummary
  • BUGFIX_11438 : ms_peptidesummary
  • BUGFIX_11481 : ms_peptidesummary
  • BUGFIX_11483 : ms_peptidesummary
  • BUGFIX_11499 : ms_peptidesummary
  • BUGFIX_11856 : ms_peptidesummary
  • BUGFIX_12123 : ms_peptidesummary
  • BUGFIX_12317 : ms_peptidesummary
  • BUGFIX_12409 : ms_ms1quantitation
  • BUGFIX_12447 : ms_peptidesummary
  • BUGFIX_12538 : ms_peptidesummary
  • BUGFIX_12729 : ms_peptidesummary
  • BUGFIX_12740 : ms_peptidesummary
  • BUGFIX_13324 : ms_peptidesummary
  • BUGFIX_13759 : ms_peptidesummary
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- c -

  • CACHE_MISSING_RESFILE : ms_peptidesummary
  • CHARGETYPE_ALL : ms_ms1quant_match
  • CHARGETYPE_ORIGINAL : ms_ms1quant_match
  • CMD_ARGUMENT_PARSE_COLLISION : ms_fileutilities
  • CMD_ARGUMENT_PARSE_INVALIDCHAR : ms_fileutilities
  • CMD_ARGUMENT_PARSE_OK : ms_fileutilities
  • CMD_ARGUMENT_PARSE_UNBALANCED : ms_fileutilities
  • CMPXML_IGN_COL_SIZE_EQ_ONE : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_100_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_10_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_1_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_IDENTICAL : ms_fileutilities
  • CMPXML_IGN_FILE_URL : ms_fileutilities
  • CMPXML_IGN_INF_999999 : ms_fileutilities
  • CMPXML_IGN_RAWFILE_NAME : ms_fileutilities
  • CMPXML_IGN_TODAY_DATE : ms_fileutilities
  • CMPXML_NO_FLAG : ms_fileutilities
  • CMPXML_STRIP_TRAILING_ZEROS : ms_fileutilities
  • COL_ASC_TIME : ms_logger
  • COL_HEADERS : ms_logger
  • COL_IP_ADDRESS : ms_logger
  • COL_ISO8601_TIME : ms_logger
  • COL_LOGGER_DEFAULTS : ms_logger
  • COL_MSG : ms_logger
  • COL_MSG_NUM_DEC : ms_logger
  • COL_MSG_NUM_HEX : ms_logger
  • COL_MSG_SOURCE_TXT : ms_logger
  • COL_QUOTES : ms_logger
  • COL_SEVERITY_NUM : ms_logger
  • COL_SEVERITY_TXT : ms_logger
  • COL_SRC_FILE : ms_logger
  • COL_SRC_LINENUM : ms_logger
  • COL_THREAD_ID : ms_logger
  • COL_TSV : ms_logger
  • COMPATIBLE : ms_quant_method
  • COMPATIBLE_DIFF_INTEGRATION_PARAM : ms_quant_method
  • COMPATIBLE_DIFF_LOCAL_MOD : ms_quant_method
  • COMPATIBLE_DIFF_NUM_COMPONENTS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_ISOTOPES : ms_quant_method
  • COMPATIBLE_DIFF_NUM_LOCAL_MODS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_MOD_GROUPS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_MODS : ms_quant_method
  • COMPATIBLE_DIFF_PROTOCOL : ms_quant_method
  • COMPATIBLE_MISSING_COMPONENT : ms_quant_method
  • COMPATIBLE_MISSING_INTEGRATION : ms_quant_method
  • COMPATIBLE_MISSING_INTEGRATION_PARAM : ms_quant_method
  • COMPATIBLE_MISSING_MOD : ms_quant_method
  • COMPATIBLE_MISSING_MOD_GROUP : ms_quant_method
  • CP_BADNEWPASSWORD : ms_http_client
  • CP_INCORRECTPASSWORD : ms_http_client
  • CP_SUCCESS : ms_http_client
  • CP_UNKNOWNUSER : ms_http_client
  • CP_UNSPECIFIEDERROR : ms_http_client
  • CTERM_CUTTER : ms_enzyme
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- d -

  • DECOY_ALGORITHM_NONE : ms_mascotoptions
  • DECOY_PEPTIDE_RANDOM : ms_mascotoptions
  • DECOY_PEPTIDE_RANDOM_DIPEP : ms_mascotoptions
  • DECOY_PEPTIDE_REVERSE : ms_mascotoptions
  • DECOY_PEPTIDE_SHUFFLE : ms_mascotoptions
  • DECOY_PROTEIN_BASED_MASK : ms_mascotoptions
  • DECOY_PROTEIN_RANDOM : ms_mascotoptions
  • DECOY_PROTEIN_RANDOM_DIPEP : ms_mascotoptions
  • DECOY_PROTEIN_REVERSE : ms_mascotoptions
  • DECOY_PROTEIN_SHUFFLE : ms_mascotoptions
  • DEPRECATED_MAX_CORES_PER_LICENSE : ms_processors
  • DM_BOTH : ms_mascotresults
  • DM_FASTA : ms_mascotresults
  • DM_FASTA_FIRST_PASS : ms_mascotresults
  • DM_FASTA_SECOND_PASS : ms_mascotresults
  • DM_SPECTRAL_LIBRARY : ms_mascotresults
  • DO_NORMAL : ms_http_client_search
  • DO_WITH_IONS : ms_http_client_search
  • DPF_CHARGE : ms_protein
  • DPF_MODS : ms_protein
  • DPF_NODUPSAMEQUERY : ms_protein
  • DPF_SEQUENCE : ms_protein
  • DPF_UNIQUE : ms_protein
  • DS_COUNT_PSM : ms_mascotresults
  • DS_COUNT_SEQUENCE : ms_mascotresults
  • DUPE_Duplicate : ms_protein
  • DUPE_DuplicateSameQuery : ms_protein
  • DUPE_HighestScoringDuplicate : ms_protein
  • DUPE_Ignored : ms_protein
  • DUPE_NotDuplicate : ms_protein
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- e -

  • eAuto : ms_distiller_data_search
  • eFASTA : ms_distiller_data_search
  • eGroupAuto : ms_distiller_data_search
  • eGroupFamily : ms_distiller_data_search
  • eGroupStandard : ms_distiller_data_search
  • eIntegrated : ms_distiller_data_search
  • eLibrary : ms_distiller_data_search
  • eMudpit : ms_distiller_data_search
  • ERR_ABORTEDBYUSER : ms_http_helper_return
  • ERR_ACCINPEPTIDESTR : ms_mascotresfile_dat
  • ERR_ADDPEPTIDES : ms_mascotresfile_dat
  • ERR_CANNOT_APPEND_RESFILE : ms_mascotresfile_dat
  • ERR_CANNOT_APPEND_RESFILE_NO_FNAMES : ms_mascotresfile_dat
  • ERR_CDB_64_BIT_REMAKE : ms_mascotresfile_dat
  • ERR_CDB_BEING_CREATED : ms_mascotresfile_dat
  • ERR_CDB_FAIL_LOCK : ms_mascotresfile_dat
  • ERR_CDB_FAIL_REMOVE : ms_mascotresfile_dat
  • ERR_CDB_FAIL_UNLOCK : ms_mascotresfile_dat
  • ERR_CDB_INCOMPLETE_NO_RETRY : ms_mascotresfile_dat
  • ERR_CDB_INCOMPLETE_RETRY : ms_mascotresfile_dat
  • ERR_CDB_OLD_VER_NO_RETRY : ms_mascotresfile_dat
  • ERR_CDB_OLD_VER_RETRY : ms_mascotresfile_dat
  • ERR_CDB_SOURCE_CHANGE_NO_RETRY : ms_mascotresfile_dat
  • ERR_CDB_SOURCE_CHANGE_RETRY : ms_mascotresfile_dat
  • ERR_CDB_TOO_LARGE : ms_mascotresfile_dat
  • ERR_DUPE_ACCESSION : ms_mascotresfile_dat
  • ERR_DUPLICATE_KEY : ms_mascotresfile_dat
  • ERR_FAIL_CDB_INIT : ms_mascotresfile_dat
  • ERR_FAIL_CLOSE_FILE : ms_mascotresfile_dat
  • ERR_FAIL_MK_CACHE_DIR : ms_mascotresfile_dat
  • ERR_FAIL_MK_CDB_FILE : ms_mascotresfile_dat
  • ERR_FAIL_OPEN_DAT_FILE : ms_mascotresfile_dat
  • ERR_HTTP : ms_http_helper_return
  • ERR_INVALID_CACHE_DIR : ms_mascotresfile_dat
  • ERR_INVALID_CDB_FILE : ms_mascotresfile_dat
  • ERR_INVALID_NUMQUERIES : ms_mascotresfile_dat
  • ERR_INVALID_PROTDB : ms_mascotresfile_dat
  • ERR_INVALID_RESFILE : ms_mascotresfile_dat
  • ERR_MALFORMED_DRANGE : ms_mascotresfile_dat
  • ERR_MALFORMED_ERR_TOL : ms_mascotresfile_dat
  • ERR_MALFORMED_TAG : ms_mascotresfile_dat
  • ERR_MALFORMED_TERMS : ms_mascotresfile_dat
  • ERR_MISSING_CDB_FILE : ms_mascotresfile_dat
  • ERR_MISSING_PERCOLATOR_FILE : ms_mascotresfile_dat
  • ERR_MISSINGENTRY : ms_mascotresfile_dat
  • ERR_MISSINGHIT : ms_mascotresfile_dat
  • ERR_MISSINGSECTION : ms_mascotresfile_dat
  • ERR_MISSINGSECTIONEND : ms_mascotresfile_dat
  • ERR_NEED_64_BIT : ms_mascotresfile_dat
  • ERR_NO_ERR_TOL_PARENT : ms_mascotresfile_dat
  • ERR_NO_ERROR : ms_mascotresfile_dat
  • ERR_NO_UNIGENE_FILE : ms_mascotresfile_dat
  • ERR_NOMEM : ms_mascotresfile_dat
  • ERR_NONE : ms_http_helper_return
  • ERR_NOSUCHFILE : ms_mascotresfile_dat
  • ERR_NULL_ACC_PEP_SUM : ms_mascotresfile_dat
  • ERR_NULL_ACC_PROT_SUM : ms_mascotresfile_dat
  • ERR_OLDRESULTSFILE : ms_mascotresfile_dat
  • ERR_PEPSUMMPEPGET : ms_mascotresfile_dat
  • ERR_PEPTIDESTR : ms_mascotresfile_dat
  • ERR_PROTSUMM : ms_mascotresfile_dat
  • ERR_PROTSUMMPEP : ms_mascotresfile_dat
  • ERR_QUERYOUTOFRANGE : ms_mascotresfile_dat
  • ERR_READINGFILE : ms_mascotresfile_dat
  • ERR_RESULTS_NOT_CREATED : ms_mascotresfile_dat
  • ERR_SYSTEM : ms_http_helper_return
  • ERR_UNASSIGNED_PROG : ms_mascotresfile_dat
  • ERR_UNASSIGNED_RANGE : ms_mascotresfile_dat
  • ERR_UNASSIGNED_UNK : ms_mascotresfile_dat
  • ERR_UNIGENE_MULTIDB : ms_mascotresfile_dat
  • ERR_UNSPECIFIED : ms_http_helper_return
  • ERR_WRITE_CDB_FILE : ms_mascotresfile_dat
  • eStandard : ms_distiller_data_search
  • eUnknown : ms_distiller_data_search
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- f -

  • FC_ALL_PEPTIDES : ms_mascotresults
  • FC_ALL_PEPTITDES : ms_mascotresults
  • FC_CASE_INSENSITIVE : ms_mascotresults
  • FC_CASE_SENSITIVE : ms_mascotresults
  • FC_COMPLETESTR : ms_mascotresults
  • FC_FORWARD : ms_mascotresults
  • FC_LOOP_FROM_UNASSIGNED : ms_mascotresults
  • FC_LOOP_INTO_UNASSIGNED : ms_mascotresults
  • FC_MASK_CASE : ms_mascotresults
  • FC_MASK_DIRECTION : ms_mascotresults
  • FC_MASK_STR_PART : ms_mascotresults
  • FC_PROTEIN_IGN_FAMILY : ms_mascotresults
  • FC_PROTEIN_IGN_MASK : ms_mascotresults
  • FC_PROTEIN_IGN_SAMESETS : ms_mascotresults
  • FC_PROTEIN_IGN_SUBSETS : ms_mascotresults
  • FC_PROTEIN_INC_ALT_ACC : ms_mascotresults
  • FC_RESTRICT_TO_HIT : ms_mascotresults
  • FC_REVERSE : ms_mascotresults
  • FC_SCORING_MASK : ms_mascotresults
  • FC_SEARCH_ALL_RANKS : ms_mascotresults
  • FC_SEARCH_IGNORED_RANKS : ms_mascotresults
  • FC_SIGNIFICANT_PEPTIDES : ms_mascotresults
  • FC_STARTSTR : ms_mascotresults
  • FC_STRTOK : ms_mascotresults
  • FC_SUBSTR : ms_mascotresults
  • FC_UNASSIGNED_MASK : ms_mascotresults
  • FM_binary : ms_http_helper
  • FM_text : ms_http_helper
  • FRAG_A_MINUS_H2O : ms_fragmentationrules
  • FRAG_A_MINUS_NH3 : ms_fragmentationrules
  • FRAG_A_SERIES : ms_fragmentationrules
  • FRAG_B_MINUS_H2O : ms_fragmentationrules
  • FRAG_B_MINUS_NH3 : ms_fragmentationrules
  • FRAG_B_SERIES : ms_fragmentationrules
  • FRAG_C_SERIES : ms_fragmentationrules
  • FRAG_D_SERIES : ms_fragmentationrules
  • FRAG_IMMONIUM : ms_fragmentationrules
  • FRAG_INTERNAL_YA : ms_fragmentationrules
  • FRAG_INTERNAL_YB : ms_fragmentationrules
  • FRAG_NL_PRIMARY : ms_aahelper
  • FRAG_NL_SECONDARY : ms_aahelper
  • FRAG_V_SERIES : ms_fragmentationrules
  • FRAG_W_SERIES : ms_fragmentationrules
  • FRAG_X_SERIES : ms_fragmentationrules
  • FRAG_Y_MINUS_H2O : ms_fragmentationrules
  • FRAG_Y_MINUS_NH3 : ms_fragmentationrules
  • FRAG_Y_SERIES : ms_fragmentationrules
  • FRAG_Z_PLUS_1 : ms_fragmentationrules
  • FRAG_Z_PLUS_2 : ms_fragmentationrules
  • FRAG_Z_SERIES : ms_fragmentationrules
  • FT_PEPTIDE_CALC_MR : ms_mascotresults
  • FT_PEPTIDE_CALC_MZ : ms_mascotresults
  • FT_PEPTIDE_ETMOD : ms_mascotresults
  • FT_PEPTIDE_EXP_MR : ms_mascotresults
  • FT_PEPTIDE_EXP_MZ : ms_mascotresults
  • FT_PEPTIDE_FIND_MASK : ms_mascotresults
  • FT_PEPTIDE_FIXMOD : ms_mascotresults
  • FT_PEPTIDE_QUERY : ms_mascotresults
  • FT_PEPTIDE_SLMOD : ms_mascotresults
  • FT_PEPTIDE_STRING : ms_mascotresults
  • FT_PEPTIDE_VARMOD : ms_mascotresults
  • FT_PEPTIDE_VARMOD_BYNAME : ms_mascotresults
  • FT_PROTEIN_ACCESSION : ms_mascotresults
  • FT_PROTEIN_DESCRIPTION : ms_mascotresults
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- g -

  • GROUP_COMPLETE : ms_protein
  • GROUP_FAMILY : ms_protein
  • GROUP_NO : ms_protein
  • GROUP_SUBSET : ms_protein
  • GROUP_UNKNOWN : ms_protein
  • GROUPID_ADMINISTRATORS : ms_group
  • GROUPID_DAEMONS : ms_group
  • GROUPID_GUESTS : ms_group
  • GROUPID_INTEGRA_SYSTEM : ms_group
  • GROUPID_LAST : ms_group
  • GROUPID_POWERUSERS : ms_group
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- h -

  • HOMTHR_FASTA : ms_mascotresults
  • HOMTHR_SL : ms_mascotresults
  • HT_CANNOT_DETECT : ms_processors
  • HT_DISABLED : ms_processors
  • HT_ENABLED : ms_processors
  • HT_NOT_CAPABLE : ms_processors
  • HT_SUPPORTED_NOT_ENABLED : ms_processors
  • HTTP_1_0 : ms_connection_settings
  • HTTP_1_1 : ms_connection_settings
  • HTTP_SYSTEM_DEFAULT : ms_connection_settings
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- i -

  • IFLG_ADDMISSINGOPTIONS : ms_datfile
  • IFLG_ADDPERCOLATOROPT : ms_datfile
  • IFLG_ADDREPORTAUTO : ms_datfile
  • IFLG_DEFAULTNEWINSTALL : ms_datfile
  • IFLG_DEFAULTUPGRADE : ms_datfile
  • IFLG_UPDATEAPACHEFORKOPT : ms_datfile
  • IFLG_UPDATECLUSTER : ms_datfile
  • IFLG_UPDATEDBMANAGERPERLPATH : ms_datfile
  • IFLG_UPDATEESTTAX : ms_datfile
  • IFLG_UPDATEEXECAFTERSEARCH : ms_datfile
  • IFLG_UPDATEMSPEPSEARCHOPTS : ms_datfile
  • IFLG_UPDATENCBIHTTPS : ms_datfile
  • IFLG_UPDATEPARSERULES : ms_datfile
  • IFLG_UPDATEPERCOLATORFEATS : ms_datfile
  • IFLG_UPDATEPERCOLATORUSERT : ms_datfile
  • IFLG_UPDATEPRIDECONTAMINANTS : ms_datfile
  • IFLG_UPDATEPROTFAMILYSWITCH : ms_datfile
  • IFLG_UPDATESPLITDATAFILESIZE : ms_datfile
  • IFLG_UPDATESPLITNUMOFQUERIES : ms_datfile
  • IFLG_UPDATESWISSPROT : ms_datfile
  • IFLG_UPDATETAXONOMY : ms_datfile
  • IH_INCLUDE_TOP_10_MATCHES : ms_mascotresults
  • IH_INCLUDE_TOP_MATCHES : ms_mascotresults
  • IMPUTE_PEPTIDE_RATIO : ms_imputation
  • IMPUTE_PROTEIN_RATIO : ms_imputation
  • IMPUTE_RETENTION_TIME : ms_imputation
  • INTENSITY : ms_mascotresults
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- k -

  • KA_ASSIGNPROTEINS_AP : ms_mascotresfilebase
  • KA_CREATECACHE_CC : ms_mascotresfilebase
  • KA_CREATEINDEX_CI : ms_mascotresfilebase
  • KA_GROUPPROTEINS_GP : ms_mascotresfilebase
  • KA_LAST : ms_mascotresfilebase
  • KA_QUANTITATION : ms_mascotresfilebase
  • KA_READFILE_RF : ms_mascotresfilebase
  • KA_THRESHFORFDR_FDR : ms_mascotresfilebase
  • KA_UNASSIGNEDLIST_UL : ms_mascotresfilebase
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- l -

  • L_GUESTLOGINDISABLED : ms_http_client
  • L_INCORRECTPASSWORD : ms_http_client
  • L_PASSWORDEXPIRED : ms_http_client
  • L_SECURITYDISABLED : ms_http_client
  • L_SUCCESS : ms_http_client
  • L_UNKNOWNUSER : ms_http_client
  • L_UNSPECIFIEDERROR : ms_http_client
  • L_WEBAUTHENTICATIONFAILED : ms_http_client
  • LABEL_FORMAT_PEPTIDE_VIEW : ms_fragment
  • LABEL_FORMAT_TRADITIONAL : ms_fragment
  • LVL_DEBUG1 : ms_loggingmonitor
  • LVL_DEBUG2 : ms_loggingmonitor
  • LVL_DEBUG3 : ms_loggingmonitor
  • LVL_ERROR : ms_loggingmonitor
  • LVL_INFO : ms_loggingmonitor
  • LVL_NONE : ms_loggingmonitor
  • LVL_WARNING : ms_loggingmonitor
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- m -

  • MASS_DECIMAL_PLACES : ms_mascotoptions
  • MASS_NON_SELECT_MATCH : ms_protein
  • MASS_NON_SELECT_NON_MATCH : ms_protein
  • MASS_SELECT_MATCH : ms_protein
  • MASS_SELECT_NON_MATCH : ms_protein
  • MATCH_CLOSEST_PEAK : ms_fragmentvector
  • MATCH_MOST_INTENSE_PEAK : ms_fragmentvector
  • MAX_EXEC_AFTER_SEARCH : ms_mascotoptions
  • MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE : ms_ms1quantitation
  • MERGE_QUANT_DEFAULT_PRECURSOR_METHOD : ms_ms1quantitation
  • MERGE_QUANT_DEFAULT_REPLICATE_METHOD : ms_ms1quantitation
  • MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH : ms_ms1quantitation
  • MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS : ms_ms1quantitation
  • MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC : ms_ms1quantitation
  • MISECTASK_ACCESS : ms_security_tasks
  • MISECTASK_ADDCUSTOMREPORT : ms_security_tasks
  • MISECTASK_ADDEXCLUSIONFILE : ms_security_tasks
  • MISECTASK_ADDIMPORTFILTER : ms_security_tasks
  • MISECTASK_ADMIN : ms_security_tasks
  • MISECTASK_DELETECUSTOMREPORT : ms_security_tasks
  • MISECTASK_DELETEEXCLUSIONFILE : ms_security_tasks
  • MISECTASK_PROTEINAPPROVAL : ms_security_tasks
  • MISECTASK_SENDNOTIFICATION : ms_security_tasks
  • MODFILE_FLAGS_AASUBST : ms_umod_configfile
  • MODFILE_FLAGS_ALL : ms_umod_configfile
  • MODFILE_FLAGS_EMPTY : ms_umod_configfile
  • MODFILE_FLAGS_HIDDEN : ms_umod_configfile
  • MODFILE_FLAGS_REGULAR : ms_umod_configfile
  • MS_REVIEW_COL____LAST___ : ms_mascotoptions
  • MS_REVIEW_COL_DATABASE : ms_mascotoptions
  • MS_REVIEW_COL_DURATION : ms_mascotoptions
  • MS_REVIEW_COL_ENZYMEUSED : ms_mascotoptions
  • MS_REVIEW_COL_IPADDRESS : ms_mascotoptions
  • MS_REVIEW_COL_JOB : ms_mascotoptions
  • MS_REVIEW_COL_PEAKLISTDATAFILE : ms_mascotoptions
  • MS_REVIEW_COL_PID : ms_mascotoptions
  • MS_REVIEW_COL_PRIORITY : ms_mascotoptions
  • MS_REVIEW_COL_RESULTS_FILE : ms_mascotoptions
  • MS_REVIEW_COL_SEARCHTYPE : ms_mascotoptions
  • MS_REVIEW_COL_START_TIME : ms_mascotoptions
  • MS_REVIEW_COL_STATUS : ms_mascotoptions
  • MS_REVIEW_COL_TITLE : ms_mascotoptions
  • MS_REVIEW_COL_USEREMAIL : ms_mascotoptions
  • MS_REVIEW_COL_USERID : ms_mascotoptions
  • MS_REVIEW_COL_USERNAME : ms_mascotoptions
  • MSM_EXCLUSIVE_PLUS_VARIABLE : ms_searchparams
  • MSM_NOT_PERMITTED : ms_searchparams
  • MSPEPSUM_CACHE_IGNORE_DATE_CHANGE : ms_peptidesummary
  • MSPEPSUM_CROSSLINK_INTEGRATED : ms_peptidesummary
  • MSPEPSUM_CROSSLINK_ONLY : ms_peptidesummary
  • MSPEPSUM_DEFERRED_CREATE : ms_peptidesummary
  • MSPEPSUM_DISCARD_RELOADABLE : ms_peptidesummary
  • MSPEPSUM_NO_PROTEIN_GROUPING : ms_peptidesummary
  • MSPEPSUM_NONE : ms_peptidesummary
  • MSPEPSUM_PERCOLATOR : ms_peptidesummary
  • MSPEPSUM_REMOVE_CHIMERIC_DUPES : ms_peptidesummary
  • MSPEPSUM_SINGLE_HIT_DBIDX : ms_peptidesummary
  • MSPEPSUM_SL_INTEGRATED : ms_peptidesummary
  • MSPEPSUM_SL_ONLY : ms_peptidesummary
  • MSPEPSUM_USE_CACHE : ms_peptidesummary
  • MSPEPSUM_USE_HOMOLOGY_THRESH : ms_peptidesummary
  • MSRES_CLUSTER_PROTEINS : ms_mascotresults
  • MSRES_DECOY : ms_mascotresults
  • MSRES_DUPE_DEFAULT : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_A : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_B : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_C : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_D : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_E : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_F : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_G : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_H : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_I : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_NONE : ms_mascotresults
  • MSRES_DUPE_REMOVE_A : ms_mascotresults
  • MSRES_DUPE_REMOVE_B : ms_mascotresults
  • MSRES_DUPE_REMOVE_C : ms_mascotresults
  • MSRES_DUPE_REMOVE_D : ms_mascotresults
  • MSRES_DUPE_REMOVE_E : ms_mascotresults
  • MSRES_DUPE_REMOVE_F : ms_mascotresults
  • MSRES_DUPE_REMOVE_G : ms_mascotresults
  • MSRES_DUPE_REMOVE_H : ms_mascotresults
  • MSRES_DUPE_REMOVE_I : ms_mascotresults
  • MSRES_DUPE_REMOVE_NONE : ms_mascotresults
  • MSRES_ERR_TOL : ms_mascotresults
  • MSRES_GROUP_PROTEINS : ms_mascotresults
  • MSRES_IGNORE_PMF_MIXTURE : ms_mascotresults
  • MSRES_INTEGRATED_ERR_TOL : ms_mascotresults
  • MSRES_MAXHITS_OVERRIDES_MINPROB : ms_mascotresults
  • MSRES_MUDPIT_PROTEIN_SCORE : ms_mascotresults
  • MSRES_NOFLAG : ms_mascotresults
  • MSRES_REQUIRE_BOLD_RED : ms_mascotresults
  • MSRES_SHOW_ALL_FROM_ERR_TOL : ms_mascotresults
  • MSRES_SHOW_SUBSETS : ms_mascotresults
  • MSRES_SUBSETS_DIFF_PROT : ms_mascotresults
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- n -

  • NTERM_CUTTER : ms_enzyme
  • NUM_PROCESSORS_AUTO_DETECT : ms_clusterparams
  • NUM_THREADS_AUTO_DETECT : ms_databaseoptions
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- p -

  • PEAK_STATE_DISCARD : ms_xic
  • PEAK_STATE_OK : ms_xic
  • PEAK_STATE_UNKNOWN : ms_xic
  • PEPSUMMARY_CACHE_BEING_CREATED : ms_peptidesummary
  • PEPSUMMARY_CACHE_CAN_CREATE : ms_peptidesummary
  • PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS : ms_peptidesummary
  • PEPSUMMARY_CACHE_FILE_NOT_PRESENT : ms_peptidesummary
  • PEPSUMMARY_CACHE_NOT_FOR_PMF : ms_peptidesummary
  • PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE : ms_peptidesummary
  • PEPSUMMARY_CACHE_VALID : ms_peptidesummary
  • PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN : ms_quant_helper
  • PEPTIDE_EXPECT_ABOVE_THRESHOLD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_NO_EXCLUSIVE_MODS : ms_quant_helper
  • PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_NO_REQUIRED_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_UNMODIFIED_SITE : ms_quant_helper
  • PEPTIDE_IS_QUANTIFIABLE : ms_quant_helper
  • PEPTIDE_NOT_UNIQUE : ms_quant_helper
  • PEPTIDE_QUALITY_IS_OK : ms_quant_helper
  • PEPTIDE_QUALITY_UNAVAILABLE : ms_quant_helper
  • PEPTIDE_QUANTIFIABILITY_UNAVAILABLE : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_HOMOLOGY_THR : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_IDENTITY_THR : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_SCORE_THR : ms_quant_helper
  • PERC_EXE_RT_FORCE_OFF : ms_mascotoptions
  • PERC_EXE_RT_FORCE_ON : ms_mascotoptions
  • PERC_EXE_RT_USE_DEFAULT : ms_mascotoptions
  • PERCOLATOR_INPUT_FILE : ms_mascotresfilebase
  • PERCOLATOR_OUTPUT_DECOY : ms_mascotresfilebase
  • PERCOLATOR_OUTPUT_TARGET : ms_mascotresfilebase
  • PROXY_TYPE_AUTO : ms_connection_settings
  • PROXY_TYPE_ENVIRONMENT : ms_connection_settings
  • PROXY_TYPE_FROM_REGISTRY : ms_connection_settings
  • PROXY_TYPE_NO_PROXY : ms_connection_settings
  • PROXY_TYPE_SPECIFY : ms_connection_settings
  • PROXY_TYPE_WPAD : ms_connection_settings
  • PS_DUPLICATESAMEQUERY : ms_ms1quant_peptide_status
  • PS_EXCLUDE_LOCALDEF : ms_ms1quant_peptide_status
  • PS_EXCLUDE_MODFILE : ms_ms1quant_peptide_status
  • PS_EXCLUDE_UNMODIFIED : ms_ms1quant_peptide_status
  • PS_EXPECTGREATERTHAN : ms_ms1quant_peptide_status
  • PS_LESSTHANIDENTITY : ms_ms1quant_peptide_status
  • PS_MAX : ms_ms1quant_peptide_status
  • PS_MINCHARGE : ms_ms1quant_peptide_status
  • PS_NOMATCHINTHISFRACTION : ms_ms1quant_peptide_status
  • PS_NOTPARTOFQUANTITATION : ms_ms1quant_peptide_status
  • PS_NOTUNIQUE : ms_ms1quant_peptide_status
  • PS_OK : ms_ms1quant_peptide_status
  • PS_SCORELESSHOMOLOGY : ms_ms1quant_peptide_status
  • PS_SCORELESSIDENTITY_NOHOMO : ms_ms1quant_peptide_status
  • PS_SCORELESSTHRESHOLD : ms_ms1quant_peptide_status
  • PSM_COMPLETE : ms_peptide
  • PSM_CROSSLINK : ms_peptide
  • PSM_CROSSLINK_ALPHA : ms_peptide
  • PSM_CROSSLINK_BETA : ms_peptide
  • PSM_DECOY : ms_peptide
  • PSM_ERRTOL : ms_peptide
  • PSM_ERRTOLDECOY : ms_peptide
  • PSM_LIBRARY : ms_peptide
  • PSM_STANDARD : ms_peptide
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- q -

  • QCS_ERROR_BAD_COMPONENT_NAME : ms_mascotresults
  • QCS_ERROR_NO_COMPONENTS : ms_mascotresults
  • QCS_ERROR_NO_METHOD : ms_mascotresults
  • QCS_OK : ms_mascotresults
  • QCS_OK_MULTIPLE_MATCHES : ms_mascotresults
  • QCS_OK_NO_MATCH : ms_mascotresults
  • QL_ALL : ms_peptidesummary
  • QL_BELOW_HOMOLOGY : ms_peptidesummary
  • QL_BELOW_IDENTITY : ms_peptidesummary
  • QL_IGNORE_IONS_SCORE_BELOW : ms_peptidesummary
  • QL_LAST : ms_peptidesummary
  • QL_UNASSIGNED : ms_peptidesummary
  • QUERY : ms_mascotresults
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- r -

  • REDIRECT_POLICY_ALWAYS : ms_connection_settings
  • REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP : ms_connection_settings
  • REDIRECT_POLICY_NEVER : ms_connection_settings
  • RESFILE_CACHE_BEING_CREATED : ms_peptidesummary
  • RESFILE_CACHE_CAN_CREATE : ms_peptidesummary
  • RESFILE_CACHE_DISABLED_IN_OPTIONS : ms_peptidesummary
  • RESFILE_CACHE_FILE_NOT_PRESENT : ms_peptidesummary
  • RESFILE_CACHE_IGNORE_ACC_DUPES : ms_mascotresfilebase
  • RESFILE_CACHE_IGNORE_DATE_CHANGE : ms_mascotresfilebase
  • RESFILE_CACHE_VALID : ms_peptidesummary
  • RESFILE_DAT28 : ms_mascotresfilebase
  • RESFILE_MSR : ms_mascotresfilebase
  • RESFILE_NOFLAG : ms_mascotresfilebase
  • RESFILE_UNKNOWN : ms_mascotresfilebase
  • RESFILE_USE_CACHE : ms_mascotresfilebase
  • RESFILE_USE_PARENT_PARAMS : ms_mascotresfilebase
  • RS_DO_NOT_USE : ms_ms1quant_match_ratio
  • RS_EMPTY : ms_ms1quant_match_ratio
  • RS_FITEXYSIGMA : ms_ms1quant_match_ratio
  • RS_INFINITERATIO : ms_ms1quant_match_ratio
  • RS_INTEFERENCEFAILED : ms_ms1quant_match_ratio
  • RS_ISOLATEDPRECURSORFAILED : ms_ms1quant_match_ratio
  • RS_NEGATIVERATIO : ms_ms1quant_match_ratio
  • RS_NODATA : ms_ms1quant_match_ratio
  • RS_OK : ms_ms1quant_match_ratio
  • RS_TOTALINTENSITYFAILED : ms_ms1quant_match_ratio
  • RS_ZERORATIO : ms_ms1quant_match_ratio
  • RT_auto : ms_http_client_search
  • RT_file : ms_http_client_search
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- s -

  • S_NOT_STARTED : ms_progress_info
  • S_RUNNING : ms_progress_info
  • S_RUNNING_INDETERMINATE : ms_progress_info
  • S_STOPPED_BREAK : ms_progress_info
  • S_STOPPED_COMPLETE : ms_progress_info
  • S_STOPPED_FAIL : ms_progress_info
  • SAR_FAIL_CHMOD : ms_fileutilities
  • SAR_FAIL_CHOWN : ms_fileutilities
  • SAR_FAIL_GET_NAMED_SECURITY_INFO : ms_fileutilities
  • SAR_FAIL_SET_ENTRIES_IN_ACL : ms_fileutilities
  • SAR_FAIL_SET_NAMED_SECURITY_INFO : ms_fileutilities
  • SAR_SUCCESS : ms_fileutilities
  • SCORE : ms_mascotresults
  • SEC_CROSSLINK_PEPTIDES : ms_mascotresfile_dat
  • SEC_CROSSLINK_SUMMARY : ms_mascotresfile_dat
  • SEC_CROSSLINKING : ms_mascotresfile_dat
  • SEC_DECOYMIXTURE : ms_mascotresfile_dat
  • SEC_DECOYPEPTIDES : ms_mascotresfile_dat
  • SEC_DECOYPROTEINS : ms_mascotresfile_dat
  • SEC_DECOYSUMMARY : ms_mascotresfile_dat
  • SEC_ENZYME : ms_mascotresfile_dat
  • SEC_ERRTOLDECOYPEPTIDES : ms_mascotresfile_dat
  • SEC_ERRTOLDECOYSUMMARY : ms_mascotresfile_dat
  • SEC_ERRTOLPEPTIDES : ms_mascotresfile_dat
  • SEC_ERRTOLSUMMARY : ms_mascotresfile_dat
  • SEC_HEADER : ms_mascotresfile_dat
  • SEC_INDEX : ms_mascotresfile_dat
  • SEC_LIBRARYPEPTIDES : ms_mascotresfile_dat
  • SEC_LIBRARYSUMMARY : ms_mascotresfile_dat
  • SEC_MASSES : ms_mascotresfile_dat
  • SEC_MIXTURE : ms_mascotresfile_dat
  • SEC_NUMSECTIONS : ms_mascotresfile_dat
  • SEC_PARAMETERS : ms_mascotresfile_dat
  • SEC_PEPTIDES : ms_mascotresfile_dat
  • SEC_PROTEINS : ms_mascotresfile_dat
  • SEC_QUANTITATION : ms_mascotresfile_dat
  • SEC_QUERY1 : ms_mascotresfile_dat
  • SEC_SPECTRAL_LIBRARY : ms_mascotresfile_dat
  • SEC_SUMMARY : ms_mascotresfile_dat
  • SEC_TAXONOMY : ms_mascotresfile_dat
  • SEC_UNIMOD : ms_mascotresfile_dat
  • SEC_UNIMOD_XL : ms_mascotresfile_dat
  • SECTASK_ACCESSDBSETUP : ms_security_tasks
  • SECTASK_ADMINPAGES : ms_security_tasks
  • SECTASK_ALLFASTA : ms_security_tasks
  • SECTASK_ALLOWMSMS : ms_security_tasks
  • SECTASK_ALLOWMSMSNOENZYME : ms_security_tasks
  • SECTASK_ALLOWPMF : ms_security_tasks
  • SECTASK_ALLOWPMFNOENZYME : ms_security_tasks
  • SECTASK_ALLOWSPOOFOTHERUSER : ms_security_tasks
  • SECTASK_BIOTOOLSBATCH : ms_security_tasks
  • SECTASK_DAEMONCLIENT : ms_security_tasks
  • SECTASK_DATAURLMAXSIZE : ms_security_tasks
  • SECTASK_DATAURLPROTOCOLS : ms_security_tasks
  • SECTASK_DENYQUANT : ms_security_tasks
  • SECTASK_DISTILLERCLIENT : ms_security_tasks
  • SECTASK_DOWNLOAD_DISTILLER_XML : ms_security_tasks
  • SECTASK_EDITCONFIG : ms_security_tasks
  • SECTASK_INTEGRASYSTEMACCOUNT : ms_security_tasks
  • SECTASK_KILLALLTASK : ms_security_tasks
  • SECTASK_KILLTASKINGROUP : ms_security_tasks
  • SECTASK_MAXCONCURRENTSEARCHES : ms_security_tasks
  • SECTASK_MAXETACCESSIONS : ms_security_tasks
  • SECTASK_MAXETVARMODS : ms_security_tasks
  • SECTASK_MAXEXECUTIONTIME : ms_security_tasks
  • SECTASK_MAXFASTAFILES : ms_security_tasks
  • SECTASK_MAXJOBPRIORITY : ms_security_tasks
  • SECTASK_MAXNOENZQUERIES : ms_security_tasks
  • SECTASK_MAXQUERIES : ms_security_tasks
  • SECTASK_MAXVARMODS : ms_security_tasks
  • SECTASK_MODIFYOWNPROFILE : ms_security_tasks
  • SECTASK_MSSTATUSEXECLUSTER : ms_security_tasks
  • SECTASK_MSSTATUSEXERETRYDB : ms_security_tasks
  • SECTASK_NAMEDFASTA : ms_security_tasks
  • SECTASK_SEEALLSEARCHESWITHUSERID : ms_security_tasks
  • SECTASK_SEEOLDSEARCHES : ms_security_tasks
  • SECTASK_SEESEARCHINANYGROUP : ms_security_tasks
  • SECTASK_SEESEARCHINGROUP : ms_security_tasks
  • SECTASK_SPOOFNAMEDGROUPSONLY : ms_security_tasks
  • SECTASK_UPLOAD_DISTILLER_XML : ms_security_tasks
  • SECTASK_USEMSREVIEWEXE : ms_security_tasks
  • SECTASK_USEMSSTATUSEXE : ms_security_tasks
  • SECTASK_VIEWCONFIG : ms_security_tasks
  • SECTASK_VIEWCONFIGUSINGMSSTATUS : ms_security_tasks
  • SEQDB_INSTALL_CURRENT_RULES : ms_datfile
  • SEQDB_INSTALL_CUSTOMISED : ms_datfile
  • SEQDB_INSTALL_EXISTING_LARGER : ms_datfile
  • SEQDB_INSTALL_INACTIVE : ms_datfile
  • SEQDB_INSTALL_INVALID_CONFIG : ms_datfile
  • SEQDB_INSTALL_INVALID_DBNAME : ms_datfile
  • SEQDB_INSTALL_MISSING_CONFIG : ms_datfile
  • SEQDB_INSTALL_MUST_UPDATE_CFG : ms_datfile
  • SEQDB_INSTALL_OLD_RULES : ms_datfile
  • SEQDB_INSTALL_SHOULD_QUERY_USER : ms_datfile
  • SEQDB_INSTALL_WRONG_WILDCARD : ms_datfile
  • sev_debug1 : ms_log
  • sev_debug2 : ms_log
  • sev_debug3 : ms_log
  • sev_fatal : ms_log
  • sev_info : ms_log
  • sev_warn : ms_log
  • SHOW_ALL : ms_http_client_session
  • SHOW_LENGTH : ms_http_client_session
  • SHOW_NONE : ms_http_client_session
  • SHOW_PI : ms_http_client_session
  • SHOW_REFERENCE : ms_http_client_session
  • SHOW_SEQUENCE : ms_http_client_session
  • SHOW_TITLE : ms_http_client_session
  • SRC_ALL : ms_loggingmonitor
  • SRC_APPLICATION : ms_loggingmonitor
  • SRC_DENOVOLIB : ms_loggingmonitor
  • SRC_MASCOTSERVER : ms_loggingmonitor
  • SRC_MDRO : ms_loggingmonitor
  • SRC_MSPARSER : ms_loggingmonitor
  • SRC_MSQUANTLIB : ms_loggingmonitor
  • SRC_PURIFIERAPI : ms_loggingmonitor
  • SRC_PURIFIERAPP : ms_loggingmonitor
  • SRC_VENDORSTART : ms_loggingmonitor
  • SS_ASSIGNED : ms_http_client_search
  • SS_COMPLETE : ms_http_client_search
  • SS_ERROR : ms_http_client_search
  • SS_QUEUED : ms_http_client_search
  • SS_RUNNING : ms_http_client_search
  • SS_SEARCH_CONTROL_ERROR : ms_http_client_search
  • SS_UNKNOWN : ms_http_client_search
  • ST_TA_CALCULATED : ms_ms1quant_time_align
  • ST_TA_LOADED_FROM_CDB : ms_ms1quant_time_align
  • ST_TA_LOADED_FROM_XML : ms_ms1quant_time_align
  • ST_TA_NO_DATA : ms_ms1quant_time_align
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- t -

  • TAX_CHOP_PREFIX : ms_parserule_plus
  • TAX_CHOP_SUFFIX : ms_parserule_plus
  • TAX_CHOP_WORDS : ms_parserule_plus
  • TCD_ABS_CORRELATION : ms_treecluster
  • TCD_ABS_UNCENTERED_CORRELATION : ms_treecluster
  • TCD_CITY_BLOCK : ms_treecluster
  • TCD_CORRELATION : ms_treecluster
  • TCD_EUCLIDEAN : ms_treecluster
  • TCD_KENDALLS_TAU_CORRELATION : ms_treecluster
  • TCD_SPEARMANS_RANK_CORRELATION : ms_treecluster
  • TCD_UNCENTERED_CORRELATION : ms_treecluster
  • TCM_PAIRWISE_AVERAGE : ms_mascotresults
  • TCM_PAIRWISE_MAXIMUM : ms_mascotresults
  • TCM_PAIRWISE_SINGLE : ms_mascotresults
  • TOLERANCE_DALTON : ms_fragmentvector
  • TOLERANCE_MMU : ms_fragmentvector
  • TOLERANCE_PERCENT : ms_fragmentvector
  • TOLERANCE_PPM : ms_fragmentvector
  • TT_HOMOLOGY : ms_mascotresults
  • TT_IDENTITY : ms_mascotresults
  • TT_PEPSUM_DEFAULT : ms_mascotresults
  • TYPE_ALL_USERS_ARRAY : ms_security_task
  • TYPE_BOOL : ms_security_task
  • TYPE_DOUBLE_ARRAY : ms_security_task
  • TYPE_EQ_DOUBLE : ms_security_task
  • TYPE_EQ_LONG : ms_security_task
  • TYPE_EQ_STRING : ms_security_task
  • TYPE_GTE_DOUBLE : ms_security_task
  • TYPE_GTE_LONG : ms_security_task
  • TYPE_LONG_ARRAY : ms_security_task
  • TYPE_LTE_DOUBLE : ms_security_task
  • TYPE_LTE_LONG : ms_security_task
  • TYPE_STRING_ARRAY : ms_security_task
  • TYPE_USERS_ARRAY : ms_security_task
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- u -

  • UNDEFINED_CUTTER : ms_enzyme
  • UPR_DEFAULT : ms_mascotresults
  • UPR_IGNORE_SUBSET_PROTEINS : ms_mascotresults
  • UPR_WITHIN_FAMILY : ms_mascotresults
  • UPR_WITHIN_FAMILY_MEMBER : ms_mascotresults
  • UR_ACCESS_DENIED : ms_http_client_search
  • UR_ERROR : ms_http_client_search
  • UR_FILE_ALREADY_EXISTS : ms_http_client_search
  • UR_INVALID_TASKID : ms_http_client_search
  • UR_NO_RESULT_FILE : ms_http_client_search
  • UR_NO_RESULT_FILENAME : ms_http_client_search
  • UR_SUCCESS : ms_http_client_search
  • USER_AGENT_STRING : ms_user
  • USER_COMPUTER_NAME : ms_user
  • USER_INTEGRA : ms_user
  • USER_IP_ADDRESS : ms_user
  • USER_NORMAL : ms_user
  • USER_SECURITY_DISABLED : ms_user
  • USER_WEBAUTH : ms_user
  • USERID_ADMINISTRATOR : ms_user
  • USERID_CMDLINE : ms_user
  • USERID_DAEMON : ms_user
  • USERID_GUEST : ms_user
  • USERID_INTEGRA_SYSTEM : ms_user
  • USERID_LAST : ms_user
  • USERID_PUBLIC_SEARCHES : ms_user
  • USERID_SECURITY_DISABLED : ms_user
  • USERID_SORTBY_FULLNAME : ms_security
  • USERID_SORTBY_ID : ms_security
  • USERID_SORTBY_LOGINNAME : ms_security
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- w -

  • WST_APACHE : ms_datfile
  • WST_IIS : ms_datfile
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Enumerator

- x -

  • XML_SCHEMA_CROSSLINKING : ms_mascotresfilebase
  • XML_SCHEMA_DIRECTORY : ms_mascotresfilebase
  • XML_SCHEMA_LAST : ms_mascotresfilebase
  • XML_SCHEMA_QUANTITATION : ms_mascotresfilebase
  • XML_SCHEMA_UNIMOD : ms_mascotresfilebase
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Members - Related Functions

  • operator< : ms_protein
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Class Index

Class Index
M
M
ms_aahelper (matrix_science)
ms_buffer_logger (matrix_science)
ms_clusterparams (matrix_science)
ms_computeraddress (matrix_science)
ms_connection_settings (matrix_science)
ms_cronjob (matrix_science)
ms_cronoptions (matrix_science)
ms_crosslinking_accession (matrix_science)
ms_crosslinking_accessions (matrix_science)
ms_crosslinking_configfile (matrix_science)
ms_crosslinking_does_not_pair_with (matrix_science)
ms_crosslinking_filters (matrix_science)
ms_crosslinking_linker (matrix_science)
ms_crosslinking_linkers (matrix_science)
ms_crosslinking_method (matrix_science)
ms_crosslinking_monolink (matrix_science)
ms_crosslinking_parameter (matrix_science)
ms_crosslinking_parameters (matrix_science)
ms_crosslinking_scope (matrix_science)
ms_crosslinking_settings (matrix_science)
ms_customproperty (matrix_science)
ms_customquantitation (matrix_science)
ms_databaseoptions (matrix_science)
ms_databases (matrix_science)
ms_datfile (matrix_science)
ms_dbprocessors (matrix_science)
ms_distiller_data (matrix_science)
ms_distiller_data_quant (matrix_science)
ms_distiller_data_search (matrix_science)
ms_distiller_master_project (matrix_science)
ms_distiller_master_search (matrix_science)
ms_distiller_search_status (matrix_science)
ms_distiller_search_status_list (matrix_science)
ms_distiller_sub_project (matrix_science)
ms_distiller_subsearch (matrix_science)
ms_enzyme (matrix_science)
ms_enzymefile (matrix_science)
ms_errors (matrix_science)
ms_errs (matrix_science)
ms_file_logger (matrix_science)
ms_fileutilities (matrix_science)
ms_fitexy_result (matrix_science)
ms_fragment (matrix_science)
ms_fragmentationrules (matrix_science)
ms_fragmentvector (matrix_science)
ms_fragrulesfile (matrix_science)
ms_group (matrix_science)
ms_http_client (matrix_science)
ms_http_client_mime (matrix_science)
ms_http_client_search (matrix_science)
ms_http_client_session (matrix_science)
ms_http_helper (matrix_science)
ms_http_helper_handles (matrix_science)
ms_http_helper_progress (matrix_science)
ms_http_helper_return (matrix_science)
ms_imputation (matrix_science)
ms_imputation_average_value (matrix_science)
ms_imputation_fixed_value (matrix_science)
ms_imputation_knn (matrix_science)
ms_imputation_method (matrix_science)
ms_imputation_missforest (matrix_science)
ms_imputation_missing_val (matrix_science)
ms_imputation_peptide_data (matrix_science)
ms_inputquery (matrix_science)
ms_libraryoptions (matrix_science)
ms_license (matrix_science)
ms_linker_site (matrix_science)
ms_linker_site_vector (matrix_science)
ms_log (matrix_science)
ms_logger (matrix_science)
ms_loggingmonitor (matrix_science)
ms_mascotfiles (matrix_science)
ms_mascotoptions (matrix_science)
ms_mascotresfile_dat (matrix_science)
ms_mascotresfile_msr (matrix_science)
ms_mascotresfilebase (matrix_science)
ms_mascotresults (matrix_science)
ms_mascotresults_params (matrix_science)
ms_masses (matrix_science)
ms_matrix (matrix_science)
ms_modfile (matrix_science)
ms_modification (matrix_science)
ms_modvector (matrix_science)
ms_ms1quant_average_results (matrix_science)
ms_ms1quant_charge_state (matrix_science)
ms_ms1quant_match (matrix_science)
ms_ms1quant_match_component (matrix_science)
ms_ms1quant_match_range (matrix_science)
ms_ms1quant_match_ratio (matrix_science)
ms_ms1quant_peptide_status (matrix_science)
ms_ms1quant_time_align (matrix_science)
ms_ms1quant_time_align_limits (matrix_science)
ms_ms1quantitation (matrix_science)
ms_ms2quantitation (matrix_science)
ms_msr2dat28 (matrix_science)
ms_obofile (matrix_science)
ms_parseoptions (matrix_science)
ms_parserule (matrix_science)
ms_parserule_plus (matrix_science)
ms_peptide (matrix_science)
ms_peptide_quant_key (matrix_science)
ms_peptide_quant_key_vector (matrix_science)
ms_peptide_quant_ratio (matrix_science)
ms_peptidesummary (matrix_science)
ms_processoroptions (matrix_science)
ms_processors (matrix_science)
ms_progress_info (matrix_science)
ms_protein (matrix_science)
ms_protein_quant_ratio (matrix_science)
ms_proteinsummary (matrix_science)
ms_quant_average (matrix_science)
ms_quant_component (matrix_science)
ms_quant_composition (matrix_science)
ms_quant_configfile (matrix_science)
ms_quant_correction (matrix_science)
ms_quant_element (matrix_science)
ms_quant_file_index (matrix_science)
ms_quant_helper (matrix_science)
ms_quant_integration (matrix_science)
ms_quant_isotope (matrix_science)
ms_quant_localdef (matrix_science)
ms_quant_method (matrix_science)
ms_quant_modgroup (matrix_science)
ms_quant_moverz (matrix_science)
ms_quant_multiplex (matrix_science)
ms_quant_neutralloss (matrix_science)
ms_quant_normalisation (matrix_science)
ms_quant_normalisation_peptide (matrix_science)
ms_quant_normalisation_peptides (matrix_science)
ms_quant_normalisation_protein (matrix_science)
ms_quant_normalisation_proteins (matrix_science)
ms_quant_numerator (matrix_science)
ms_quant_outliers (matrix_science)
ms_quant_parameter (matrix_science)
ms_quant_parameters (matrix_science)
ms_quant_pepneutralloss (matrix_science)
ms_quant_precursor (matrix_science)
ms_quant_protocol (matrix_science)
ms_quant_quality (matrix_science)
ms_quant_ratio (matrix_science)
ms_quant_replicate (matrix_science)
ms_quant_reporter (matrix_science)
ms_quant_satellite (matrix_science)
ms_quant_specificity (matrix_science)
ms_quant_stats (matrix_science)
ms_quant_unmodified (matrix_science)
ms_quantitation (matrix_science)
ms_searchparams (matrix_science)
ms_security (matrix_science)
ms_security_options (matrix_science)
ms_security_task (matrix_science)
ms_security_tasks (matrix_science)
ms_session (matrix_science)
ms_shapiro_wilk (matrix_science)
ms_spectral_lib_entry (matrix_science)
ms_spectral_lib_file (matrix_science)
ms_spectral_lib_peak (matrix_science)
ms_spectral_lib_peak_list (matrix_science)
ms_stdout_logger (matrix_science)
ms_taxnodesfiles (matrix_science)
ms_taxonomychoice (matrix_science)
ms_taxonomyfile (matrix_science)
ms_taxonomyrules (matrix_science)
ms_taxonomytree (matrix_science)
ms_taxspeciesfiles (matrix_science)
ms_tinycdb (matrix_science)
ms_treecluster (matrix_science)
ms_umod_aminoacid (matrix_science)
ms_umod_composition (matrix_science)
ms_umod_configfile (matrix_science)
ms_umod_element (matrix_science)
ms_umod_elemref (matrix_science)
ms_umod_modbrick (matrix_science)
ms_umod_modification (matrix_science)
ms_umod_neutralloss (matrix_science)
ms_umod_specificity (matrix_science)
ms_umod_xref (matrix_science)
ms_unigene (matrix_science)
ms_unigene_entry (matrix_science)
ms_unigeneoptions (matrix_science)
ms_user (matrix_science)
ms_wwwentry (matrix_science)
ms_wwwoptions (matrix_science)
ms_xic (matrix_science)
ms_xic_point (matrix_science)
ms_xml_parameter (matrix_science)
ms_xml_parameters (matrix_science)
ms_zip (matrix_science)
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Examples

Examples
Here is a list of all examples:
  • resfile_error.pl
  • resfile_error.cpp
  • resfile_error.java
  • resfile_error.py
  • resfile_error.cs
  • resfile_info.pl
  • resfile_info.cpp
  • resfile_info.java
  • resfile_info.py
  • resfile_info.cs
  • resfile_input.pl
  • resfile_input.cpp
  • resfile_input.java
  • resfile_input.py
  • resfile_input.cs
  • resfile_params.pl
  • resfile_params.cpp
  • resfile_params.java
  • resfile_params.py
  • resfile_params.cs
  • resfile_summary.pl
  • resfile_summary.cpp
  • resfile_summary.java
  • resfile_summary.py
  • resfile_summary.cs
  • resfile_ms2quantitation.pl
  • resfile_ms2quantitation.java
  • resfile_ms2quantitation.py
  • resfile_ms2quantitation.cs
  • resfile_ms2quant_to_custom.pl
  • resfile_ms2quant_to_custom.py
  • resfile_ms2quant_to_custom.cs
  • resfile_customquantitation.pl
  • resfile_customquantitation.java
  • resfile_customquantitation.py
  • resfile_customquantitation.cs
  • display_quant_time_align.py
  • repeat_search.pl
  • repeat_search.cpp
  • repeat_search.java
  • repeat_search.py
  • repeat_search.cs
  • create_mgf.pl
  • create_mgf.py
  • create_mgf.cs
  • msparser.pl
  • msparser_full.py
  • peptide_list.cpp
  • config_enzymes.cpp
  • config_enzymes.pl
  • config_enzymes.java
  • config_enzymes.py
  • config_enzymes.cs
  • config_fragrules.cpp
  • config_fragrules.pl
  • config_fragrules.java
  • config_fragrules.py
  • config_fragrules.cs
  • config_license.cpp
  • config_license.pl
  • config_license.java
  • config_license.py
  • config_mascotdat.cpp
  • config_mascotdat.pl
  • config_mascotdat.java
  • config_mascotdat.py
  • config_mascotdat.cs
  • config_masses.cpp
  • config_masses.pl
  • config_masses.java
  • config_masses.py
  • config_masses.cs
  • config_modfile.cpp
  • config_modfile.pl
  • config_modfile.java
  • config_modfile.py
  • config_modfile.cs
  • config_procs.cpp
  • config_procs.pl
  • config_procs.java
  • config_procs.py
  • config_procs.cs
  • config_taxonomy.cpp
  • config_taxonomy.pl
  • config_taxonomy.java
  • config_taxonomy.py
  • config_taxonomy.cs
  • config_quantitation.cpp
  • config_quantitation.pl
  • config_quantitation.java
  • config_quantitation.py
  • config_quantitation.cs
  • tools_aahelper.cpp
  • tools_aahelper.pl
  • tools_aahelper.java
  • tools_aahelper.py
  • tools_aahelper.cs
  • tools_ms_zip.pl
  • tools_quant_helper.pl
  • tools_quant_helper.py
  • tools_quant_helper.cs
  • tools_tinycdb.pl
  • tools_tinycdb.py
  • tools_tinycdb.cs
  • tools_treecluster.pl
  • tools_treecluster.py
  • tools_treecluster.cs
  • tools_shapiro_wilk.pl
  • tools_shapiro_wilk.py
  • tools_shapiro_wilk.cs
  • tools_stats.pl
  • tools_stats.py
  • tools_stats.cs
  • tools_imputation.cs
  • common_error.cpp
  • common_error.pl
  • common_error.py
  • common_error.cs
  • security_session.pl
  • security_session.java
  • java_helper.pl
  • login.pl
  • http_client.pl
  • http_client.cs
  • http_client.py
  • http_helper_getstring.cpp
  • http_helper_getstring.pl
  • http_helper_getstring.py
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_error.pl

resfile_error.pl

Example program for handling errors in the Mascot results files.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_error_handling.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/resfile_error.pl $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) { die "Must specify results filename as parameter"; }
my $file = msparser::ms_mascotresfilebase::createResfile($ARGV[0]);
if ($file->isValid) {
checkErrorHandler($file);
}
##############################################################################
# checkErrorHandler #
# - parameter 0 ms_mascotresfilebase #
# Calls a couple of functions with invalid arguments #
##############################################################################
sub checkErrorHandler {
my ($resfile) = @_;
print "Testing the error handling... \n";
print "=========================================\n";
my $numQueries = $resfile->getNumQueries();
$resfile->getObservedCharge($numQueries + 40); # Should fail
print "Error number: ", $resfile->getLastError(), "\n";
print "Error string: ", $resfile->getLastErrorString(), "\n";
$resfile->clearAllErrors();
print "Cleared all errors - should have no errors left: ", $resfile->getNumberOfErrors();
print " errors left\n\n";
for my $x (1 .. 20) {
$resfile->getObservedCharge($numQueries + $x); # Should fail
}
# Now, the best way, print out all errors.
print "More errors added - there are now ", $resfile->getNumberOfErrors();
print " errors\n";
for my $i (1 .. $resfile->getNumberOfErrors) {
print "Error number: ", $resfile->getErrorNumber($i);
print " : ", $resfile->getErrorString($i);
print "\n";
}
print "\n";
$resfile->clearAllErrors();
}
=pod
Running the program as 'perl resfile_error.pl ../data/F981123.dat' will
give the following output under Mascot Server 2.3:
Testing the error handling...
=========================================
Error number: 4
Error string: Query out of range. In function getObservedCharge. Request query 107, num queries: 67
Cleared all errors - should have no errors left: 0 errors left
More errors added - there are now 2 errors
Error number: 4 : Query out of range. In function getObservedCharge. Request query 68, num queries: 67
Error number: 4 : Query out of range. In function getObservedCharge. Request query 69, num queries: 67 (Error repeated 19 times)
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_error.cpp

resfile_error.cpp

Example program for handling errors in the Mascot results files.

/*
##############################################################################
# file: resfile_error.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/resfile_error.cpp $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
#include <time.h>
#include <iomanip>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
/*****************************************************************************/
/* Local functions */
/* (This test harness is 'C' and not C++) */
/*****************************************************************************/
static void checkErrorHandler(ms_mascotresfilebase & file);
/*****************************************************************************/
/* main */
/* Call this program with a single argument - the name of the .dat file */
/*****************************************************************************/
int main(int argc, char * argv[])
{
if (argc == 2)
{
ms_mascotresfilebase file = ms_mascotresfilebase::createResfile(argv[1]);
if (file.isValid())
{
checkErrorHandler(file);
}
else
std::cout << "Error: " << file.getLastErrorString() << std::endl;
}
else
std::cout << "Must supply the name of a .dat file as a command line argument" << std::endl;
return 0;
}
/*****************************************************************************/
/* checkErrorHandler */
/* Calls a couple of functions with invalid arguments */
/*****************************************************************************/
static void checkErrorHandler(ms_mascotresfilebase & file)
{
std::cout << "Testing the error handling... " << std::endl;
std::cout << "=========================================" << std::endl;
int numQueries = file.getNumQueries();
file.getObservedCharge(numQueries + 40); // Should fail
std::cout << "Error number: " << file.getLastError() << std::endl;
std::cout << "Error string: " << file.getLastErrorString() << std::endl;
file.clearAllErrors();
std::cout << "Cleared all errors - should have no errors left: "
<< file.getNumberOfErrors()
<< " errors left"
<< std::endl << std::endl;
for (int x=1; x <= 20; x++)
file.getObservedCharge(numQueries + x); // Should fail
// Now, the best way, print out all errors.
std::cout << "More errors added - there are now "
<< file.getNumberOfErrors()
<< " errors"
<< std::endl;
for (int i=1; i <= file.getNumberOfErrors(); i++)
{
std::cout << "Error number: "
<< file.getErrorNumber(i)
<< " : "
<< file.getErrorString(i)
<< std::endl;
}
std::cout << std::endl;
file.clearAllErrors();
}
/*
will give the output:
# resfile_error_handling F981123.dat
Testing the error handling...
=========================================
Error number: 4
Error string: c:\inetpub\mascot\data\F981123.dat. Query out of range.
In function getObservedCharge. Request query 44, num queries: 4
Cleared all errors - should have no errors left: 0 errors left
More errors added - there are now 2 errors
Error number: 4 : c:\inetpub\mascot\data\F981123.dat. Query out of range. In function
getObservedCharge. Request query 5, num queries: 4
Error number: 4 : c:\inetpub\mascot\data\F981123.dat. Query out of range. In function
getObservedCharge. Request query 6, num queries: 4 (Error repeated 19 times)
*/
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_errors::clearAllErrors
void clearAllErrors()
Remove all errors from the current list of errors.
Definition: ms_errors.cpp:1457
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresfilebase::getLastErrorString
std::string getLastErrorString() const
Return the last error number - or an empty string.
Definition: ms_mascotresfilebase.cpp:824
matrix_science::ms_mascotresfilebase::getObservedCharge
virtual int getObservedCharge(const int query, const bool decoy=false) const =0
The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc....
matrix_science::ms_mascotresfilebase::getErrorNumber
int getErrorNumber(const int num=-1) const
Return a specific error number - or ms_errs::ERR_NO_ERROR.
Definition: ms_mascotresfilebase.cpp:776
matrix_science::ms_mascotresfilebase::getLastError
int getLastError() const
Return the last error number - or ms_erros::ERR_NO_ERROR.
Definition: ms_mascotresfilebase.cpp:786
matrix_science::ms_mascotresfilebase::getErrorString
std::string getErrorString(const int num) const
Return a specific error as a string.
Definition: ms_mascotresfilebase.cpp:814
matrix_science::ms_mascotresfilebase::getNumQueries
virtual int getNumQueries(const int resfileID=0) const =0
Returns the number of queries (peptide masses or ms-ms spectra).
matrix_science::ms_mascotresfilebase::getNumberOfErrors
int getNumberOfErrors() const
Return the number of errors since the last call to clearAllErrors.
Definition: ms_mascotresfilebase.cpp:749
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_error.java

resfile_error.java

Example program for handling errors in the Mascot results files.

/*
##############################################################################
# file: resfile_error.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2004 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_errorha $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class resfile_error {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// ----- Object creation -----
if(argv.length < 1) {
System.out.println("Must specify results filename as parameter");
System.exit(0);
}
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(argv[0], 0, "");
if (file.isValid()) {
checkErrorHandler(file);
} else {
System.out.println("Error number: "+file.getLastError());
System.out.println("Error string: "+file.getLastErrorString());
System.exit(0);
}
}
private static void checkErrorHandler(ms_mascotresfilebase file) {
int numberOfQueries;
int loop;
int loopTwo;
System.out.println("Testing the error handling... ");
System.out.println("=========================================");
numberOfQueries = file.getNumQueries();
file.getObservedCharge(numberOfQueries+40); // should fail
System.out.println("Error number: "+file.getLastError());
System.out.println("Error string: "+file.getLastErrorString());
file.clearAllErrors();
System.out.print("Cleared all errors - should have no errors left: "+file.getNumberOfErrors());
System.out.println(" errors left\n");
for(loop=1; loop <= 20; loop++) {
file.getObservedCharge(numberOfQueries+loop); // should fail
}
// Now, the best way, print out all errors.
System.out.println("More errors added - there are now "+file.getNumberOfErrors()+" errors");
for(loopTwo=1; loopTwo <= file.getNumberOfErrors(); loopTwo++) {
System.out.print("Error number: "+file.getErrorNumber(loopTwo));
System.out.print(" : "+file.getErrorString(loopTwo));
System.out.println("");
}
System.out.println("");
file.clearAllErrors();
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar test_errorhandler F981123.dat
Testing the error handling...
=========================================
Error number: 4
Error string: Query out of range. In function getObservedCharge. Request query 44, num queries: 4
Cleared all errors - should have no errors left: 0 errors left
More errors added - there are now 2 errors
Error number: 4 : Query out of range. In function getObservedCharge. Request query 5, num queries: 4
Error number: 4 : Query out of range. In function getObservedCharge. Request query 6, num queries: 4 (Error repeated 19 times)
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_error.py

resfile_error.py

Example program for handling errors in the Mascot results files.

1#!/usr/bin/python
2
17
18import sys
19import msparser
20
21def main() :
22 if len(sys.argv) < 2 :
23 print("Must specify results filename as parameter")
24 return 1
25
26 file = msparser.ms_mascotresfilebase.createResfile(sys.argv[1])
27
28 if file.isValid() :
29 checkErrorHandler(file)
30 else :
31 print("Invalid file: %s" % file.getLastErrorString())
32
33
34
35def checkErrorHandler(resfile) :
36 """
37 Calls a couple of functions with invalid arguments, then prints
38 their error messages.
39 """
40
41 print("Testing the error handling... ")
42 print("=========================================")
43
44 numQueries = resfile.getNumQueries()
45 resfile.getObservedCharge(numQueries + 40); # Should fail
46
47 print("Error number: %s" % resfile.getLastError())
48 print("Error string: %s" % resfile.getLastErrorString())
49
50 resfile.clearAllErrors()
51 print("Cleared all errors - should have no errors left: %s errors left" %resfile.getNumberOfErrors())
52
53 for x in range(1, 21) :
54 resfile.getObservedCharge(numQueries + x); # Should fail
55
56 # Now, the best way, print out all errors.
57 print("More errors added - there are now %s errors" % resfile.getNumberOfErrors())
58
59 for i in range(1, 1 + resfile.getNumberOfErrors()) :
60 print("Error number: %s : %s" % (resfile.getErrorNumber(i), resfile.getErrorString(i)))
61
62
63 print(" ")
64 resfile.clearAllErrors()
65
66
67
68if __name__ == "__main__":
69 sys.exit(main())
70
71""" Running the program as
72
73python resfile_error.py F981123.dat
74
75will give the following output:
76
77
78Testing the error handling...
79=========================================
80Error number: 4
81Error string: Query out of range. In function getObservedCharge. Request query 107, num queries: 67
82Cleared all errors - should have no errors left: 0 errors left
83More errors added - there are now 2 errors
84Error number: 4 : Query out of range. In function getObservedCharge. Request query 68, num queries: 67
85Error number: 4 : Query out of range. In function getObservedCharge. Request query 69, num queries: 67 (Error repeated 19 times)
86
87
88"""
89
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_error.cs

resfile_error.cs

Example program for handling errors in the Mascot results files.

/*
##############################################################################
# file: resfile_error.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/resfile_error.cs $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class resfile_error
{
public static void Main(string[] argv)
{
// ----- Object creation -----
if (argv.Length < 1)
{
Console.WriteLine("Must specify results filename as parameter");
return;
}
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(argv[0], 0, "");
if (file.isValid())
{
checkErrorHandler(file);
}
else
{
Console.WriteLine("Error number: {0}", file.getLastError());
Console.WriteLine("Error string: {0}", file.getLastErrorString());
return;
}
}
private static void checkErrorHandler(ms_mascotresfilebase file)
{
int numberOfQueries, loop, loopTwo;
Console.WriteLine("Testing the error handling... ");
Console.WriteLine("=========================================");
numberOfQueries = file.getNumQueries();
file.getObservedCharge(numberOfQueries + 40); // should fail
Console.WriteLine("Error number: {0}", file.getLastError());
Console.WriteLine("Error string: {0}", file.getLastErrorString());
file.clearAllErrors();
Console.WriteLine("Cleared all errors - should have no errors left: {0} errors left", file.getNumberOfErrors());
for (loop = 1; loop <= 20; loop++)
{
file.getObservedCharge(numberOfQueries + loop); // should fail
}
// Now, the best way, print out all errors
Console.WriteLine("More errors added - there are now {0} errors", file.getNumberOfErrors());
for (loopTwo = 1; loopTwo <= file.getNumberOfErrors(); loopTwo++)
{
Console.WriteLine("Error number: {0} : {1}", file.getErrorNumber(loopTwo), file.getErrorString(loopTwo));
}
Console.WriteLine();
file.clearAllErrors();
}
}
}
/*
resfile_error.exe c:\inetpub\mascot\data\F001261.dat
Will give the following output:
Testing the error handling...
=========================================
Error number: 4
Error string: Query out of range. In function getObservedCharge. Request query 7
7368, num queries: 77328
Cleared all errors - should have no errors left: 0 errors left
More errors added - there are now 2 errors
Error number: 4 : Query out of range. In function getObservedCharge. Request query 77329, num queries: 77328
Error number: 4 : Query out of range. In function getObservedCharge. Request query 77330, num queries: 77328 (Error repeated 19 times)
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_info.pl

resfile_info.pl

Example program for retrieving general search information.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_info.pl #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/resfile_info.pl $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) { die "Must specify results filename as parameter"; }
my $file = msparser::ms_mascotresfilebase::createResfile($ARGV[0]);
if ($file->isValid) {
searchInformation($file);
}
##############################################################################
# searchInformation #
# - parameter 0 ms_mascotresfilebase #
# Display parameters from the ms_mascotresfilebase object. The functions #
# anyPMF, anyMSMS, anySQ should normally be used in preference to isPMF etc #
# because some people submit MSMS though the sequence query window etc. #
##############################################################################
sub searchInformation {
my ($resfile) = @_;
my $fmt = "%-20s: %s\n";
print "Search information from ms_mascotresfilebase", "\n";
print "========================================", "\n";
printf $fmt, "Number of queries" , $resfile->getNumQueries();
printf $fmt, "Number of sequences" , $resfile->getNumSeqs();
printf $fmt, "Sequences after tax" , $resfile->getNumSeqsAfterTax();
printf $fmt, "Number of residues" , $resfile->getNumResidues();
printf $fmt, "Execution time" , $resfile->getExecTime();
printf $fmt, "Date (seconds)" , $resfile->getDate();
# Let's jump through a few hoops to get the equivalent of a 'C' asctime call
my ($sec, $min, $hour, $mday, $mon, $year, $wday, $yday, $isdst)
= localtime($resfile->getDate);
printf $fmt, "Date", sprintf("%s %s %d %02d:%02d:%02d %d",
(qw(Sun Mon Tue Wed Thu Fri Sat))[$wday],
(qw(Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec))[$mon],
$mday,
$hour,
$min,
$sec,
$year+1900
);
printf $fmt, "Mascot version" , $resfile->getMascotVer();
printf $fmt, "Fasta version" , $resfile->getFastaVer();
printf $fmt, "Is PMF?" , $resfile->isPMF();
printf $fmt, "Is MSMS?" , $resfile->isMSMS();
printf $fmt, "Is SQ?" , $resfile->isSQ();
printf $fmt, "Is Error tolerant" , $resfile->isErrorTolerant();
printf $fmt, "Any PMF?" , $resfile->anyPMF();
printf $fmt, "Any MSMS?" , $resfile->anyMSMS();
printf $fmt, "Any SQ?" , $resfile->anySQ();
printf $fmt, "Any peptide matches" , $resfile->anyFastaMatches();
print "\n";
}
=pod
Running the program as
perl -I../bin resfile_info.pl ../data/F981123.dat
will give the following output under Mascot Server 2.3
Search information from ms_mascotresfilebase
========================================
Number of queries : 67
Number of hits : 50
Number of sequences : 257964
Sequences after tax : 257964
Number of residues : 93947433
Execution time : 6
Date (seconds) : 1171894187
Date : Mon Feb 19 14:09:47 2007
Mascot version : 2.1.119
Fasta version : SwissProt_51.6.fasta
Is PMF? :
Is MSMS? : 1
Is SQ? :
Is Error tolerant :
Any PMF? :
Any MSMS? : 1
Any SQ? :
Any peptide matches : 1
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_info.cpp

resfile_info.cpp

Example program for retrieving general search information.

/*
##############################################################################
# file: resfile_info.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/resfile_info.cpp $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
/*****************************************************************************/
/* Local functions */
/* (This test harness is 'C' and not C++) */
/*****************************************************************************/
static void searchInformation(ms_mascotresfilebase & file);
/*****************************************************************************/
/* main */
/* Call this program with a single argument - the name of the .dat file */
/*****************************************************************************/
int main(int argc, char * argv[])
{
if (argc == 2)
{
ms_mascotresfilebase file = ms_mascotresfilebase::createResfile(argv[1]);
if (file.isValid())
{
searchInformation(file);
}
else
std::cout << "Error: " << file.getLastErrorString() << std::endl;
}
else
std::cout << "Must supply the name of a .dat file as a command line argument" << std::endl;
return 0;
}
/*****************************************************************************/
/* searchInformation */
/* Display parameters from the ms_mascotresfilebase object. The functions */
/* anyPMF, anyMSMS, anySQ should normally be used in preference to isPMF */
/* etc. because some people submit MSMS though the sequence query window. */
/*****************************************************************************/
static void searchInformation(ms_mascotresfilebase & file)
{
time_t t = (time_t)file.getDate();
struct tm * t1 = localtime(&t);
std::cout << "Search information from ms_mascotresfilebase" << std::endl;
std::cout << "========================================" << std::endl;
std::cout << "Number of queries : " << file.getNumQueries() << std::endl;
std::cout << "Number of sequences : " << file.getNumSeqs() << std::endl;
std::cout << "Sequences after tax : " << file.getNumSeqsAfterTax()
<< std::endl;
std::cout << "Number of residues : " << file.getNumResidues() << std::endl;
std::cout << "Execution time : " << file.getExecTime() << std::endl;
std::cout << "Date (seconds) : " << file.getDate() << std::endl;
std::cout << "Date : " << asctime(t1);
std::cout << "Mascot version : " << file.getMascotVer() << std::endl;
std::cout << "Fasta version : " << file.getFastaVer() << std::endl;
std::cout << "Is PMF? : " << file.isPMF() << std::endl;
std::cout << "Is MSMS? : " << file.isMSMS() << std::endl;
std::cout << "Is SQ? : " << file.isSQ() << std::endl;
std::cout << "Is Error tolerant : " << file.isErrorTolerant()<< std::endl;
std::cout << "Any PMF? : " << file.anyPMF() << std::endl;
std::cout << "Any MSMS? : " << file.anyMSMS() << std::endl;
std::cout << "Any SQ? : " << file.anySQ() << std::endl;
std::cout << "Any peptide matches : " << file.anyFastaMatches()
<< std::endl;
std::cout << std::endl;
}
/*
will give the output:
# test.exe F981123.dat
Search information from ms_mascotresfilebase
========================================
Number of queries : 4
Number of hits : 50
Number of sequences : 820227
Sequences after tax : 820227
Number of residues : 2.55697e+008
Execution time : 14
Date (seconds) : 1014568786
Date : Sun Feb 24 16:39:46 2002
Mascot version : 1.7.17
Fasta version : MSDB_20020121.fasta
Is PMF? : 0
Is MSMS? : 1
Is SQ? : 0
Is Error tolerant : 0
Any PMF? : 0
Any MSMS? : 1
Any SQ? : 0
Any peptide matches : 1
*/
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresfilebase::getExecTime
virtual int getExecTime() const =0
Returns the time taken for the search.
matrix_science::ms_mascotresfilebase::getLastErrorString
std::string getLastErrorString() const
Return the last error number - or an empty string.
Definition: ms_mascotresfilebase.cpp:824
matrix_science::ms_mascotresfilebase::anyFastaMatches
virtual bool anyFastaMatches(const bool isDecoy=false) const =0
Returns true if there are any FASTA matches.
matrix_science::ms_mascotresfilebase::getDate
virtual int getDate() const =0
Returns the date and time of the search in seconds since midnight January 1st 1970.
matrix_science::ms_mascotresfilebase::getNumResidues
virtual double getNumResidues(const int idx=0) const =0
Returns the number of residues in the FASTA file(s) searched.
matrix_science::ms_mascotresfilebase::getNumSeqs
virtual int getNumSeqs(const int idx=0) const =0
Returns the number of sequences in the FASTA file(s) searched.
matrix_science::ms_mascotresfilebase::getNumSeqsAfterTax
virtual int getNumSeqsAfterTax(const int idx=0) const =0
Returns the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.
matrix_science::ms_mascotresfilebase::anyMSMS
virtual bool anyMSMS() const =0
Returns true if any of the queries in the search contain ions data.
matrix_science::ms_mascotresfilebase::isPMF
virtual bool isPMF() const =0
Returns true if the search was a PMF search (SEARCH=PMF).
matrix_science::ms_mascotresfilebase::getMascotVer
virtual std::string getMascotVer() const =0
Returns the version of Mascot used to perform the search.
matrix_science::ms_mascotresfilebase::isMSMS
virtual bool isMSMS() const =0
Returns true if the search was an MSMS search (SEARCH=MIS).
matrix_science::ms_mascotresfilebase::isErrorTolerant
virtual bool isErrorTolerant() const =0
Returns true if the search was an error tolerant search.
matrix_science::ms_mascotresfilebase::isSQ
virtual bool isSQ() const =0
Returns true if the search was a sequence query search (SEARCH=SQ).
matrix_science::ms_mascotresfilebase::getFastaVer
virtual std::string getFastaVer(int idx=1) const =0
Returns the FASTA file version.
matrix_science::ms_mascotresfilebase::anyPMF
virtual bool anyPMF() const =0
Returns true if any of the queries in the search just contain a single peptide mass.
matrix_science::ms_mascotresfilebase::getNumQueries
virtual int getNumQueries(const int resfileID=0) const =0
Returns the number of queries (peptide masses or ms-ms spectra).
matrix_science::ms_mascotresfilebase::anySQ
virtual bool anySQ() const =0
Returns true if any of the queries in the search contain seq or comp commands.
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_info.java

resfile_info.java

Example program for retrieving general search information.

/*
##############################################################################
# file: resfile_info.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchi $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class resfile_info {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// ----- Object creation -----
if(argv.length < 1) {
System.out.println("Must specify results filename as parameter");
System.exit(0);
}
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(argv[0], 0, "");
if (file.isValid()) {
searchInformation(file);
} else {
System.out.println("Error number: "+file.getLastError());
System.out.println("Error string: "+file.getLastErrorString());
System.exit(0);
}
}
private static void searchInformation(ms_mascotresfilebase file) {
Date searchDate = null; // Java.util.date object
int seconds = file.getDate(); // get date of search in seconds since midnight GMT Jan 1st 1970
long milliseconds = (long) seconds * 1000; // convert to milliseconds
searchDate=new Date(milliseconds); // create the date object
System.out.println("Search information from ms_mascotresfilebase");
System.out.println("========================================");
System.out.println("Number of queries : "+file.getNumQueries());
System.out.println("Number of sequences : "+file.getNumSeqs());
System.out.println("Sequences after tax : "+file.getNumSeqsAfterTax());
System.out.println("Number of residues : "+(int)file.getNumResidues());
System.out.println("Execution time : "+file.getExecTime());
System.out.println("Date (seconds) : "+file.getDate());
// make java output identical to perl output
System.out.print("Date : ");
String toPerlDate = searchDate.toString();
if(toPerlDate.indexOf("GMT ") > -1) {
String beforeGMT = toPerlDate.substring(0,toPerlDate.indexOf("GMT"));
String afterGMT = toPerlDate.substring(toPerlDate.indexOf("GMT ")+4,toPerlDate.length());
System.out.println(beforeGMT+afterGMT);
} else {
System.out.println(searchDate);
}
System.out.println("Mascot version : "+file.getMascotVer());
System.out.println("Fasta version : "+file.getFastaVer());
// make java output identical to perl output
System.out.println("Is PMF? : "+toBinary(file.isPMF()));
System.out.println("Is MSMS? : "+toBinary(file.isMSMS()));
System.out.println("Is SQ? : "+toBinary(file.isSQ()));
System.out.println("Is Error tolerant : "+toBinary(file.isErrorTolerant()));
System.out.println("Any PMF? : "+toBinary(file.anyPMF()));
System.out.println("Any MSMS? : "+toBinary(file.anyMSMS()));
System.out.println("Any SQ? : "+toBinary(file.anySQ()));
System.out.println("Any peptides section: "+toBinary(file.doesSectionExist(ms_mascotresfilebase.SEC_PEPTIDES)));
System.out.println("Any peptide matches : "+toBinary(file.anyFastaMatches()));
System.out.println();
}
private static int toBinary(boolean bool) {
if(bool) return 1;
return 0;
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar resfile_info F981123.dat
Search information from ms_mascotresfilebase
========================================
Number of queries : 4
Number of hits : 50
Number of sequences : 820227
Sequences after tax : 820227
Number of residues : 255696937
Execution time : 14
Date (seconds) : 1014568786
Date : Sun Feb 24 16:39:46 2002
Mascot version : 1.7.17
Fasta version : MSDB_20020121.fasta
Is PMF? : 0
Is MSMS? : 1
Is SQ? : 0
Is Error tolerant : 0
Any PMF? : 0
Any MSMS? : 1
Any SQ? : 0
Any peptides section: 1
Any peptide matches : 1
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_info.py

resfile_info.py

Example program for retrieving general search information.

1#!/usr/bin/python
2
17
18import sys
19import time
20import msparser
21
22def main() :
23 if len(sys.argv) < 2 :
24 print("Must specify results filename as parameter")
25 return 1
26
27 file = msparser.ms_mascotresfilebase.createResfile(sys.argv[1])
28
29 if file.isValid() :
30 searchInformation(file)
31 return 0
32
33 print("Failure")
34 return -1
35
36
37def searchInformation(resfile) :
38 """
39 Display parameters from the ms_mascotresfilebase object. The functions
40 anyPMF, anyMSMS, anySQ should normally be used in preference to isPMF etc
41 because some people submit MSMS though the sequence query window etc.
42 """
43
44 fmt = "%-20s: %s"
45
46 print("Search information from ms_mascotresfilebase")
47 print("========================================")
48 print(fmt % ("Number of queries" , resfile.getNumQueries()))
49 print(fmt % ("Number of sequences" , resfile.getNumSeqs()))
50 print(fmt % ("Sequences after tax" , resfile.getNumSeqsAfterTax()))
51 print(fmt % ("Number of residues" , resfile.getNumResidues()))
52 print(fmt % ("Execution time" , resfile.getExecTime()))
53 print(fmt % ("Date (seconds)" , resfile.getDate()))
54
55 date = time.localtime(resfile.getDate())
56 Wdays = "Mon Tue Wed Thu Fri Sat Sun".split(" ")
57 Mons = "Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec".split(" ")
58
59 print(fmt %( "Date", "%s %s %d %02d:%02d:%02d %d" % (
60 Wdays[date.tm_wday],
61 Mons[date.tm_mon - 1],
62 date.tm_mday,
63 date.tm_hour,
64 date.tm_min,
65 date.tm_sec,
66 date.tm_year
67 )))
68
69 print(fmt % ("Mascot version" , resfile.getMascotVer()))
70 print(fmt % ("Fasta version" , resfile.getFastaVer()))
71 print(fmt % ("Is PMF?" , resfile.isPMF()))
72 print(fmt % ("Is MSMS?" , resfile.isMSMS()))
73 print(fmt % ("Is SQ?" , resfile.isSQ()))
74 print(fmt % ("Is Error tolerant" , resfile.isErrorTolerant()))
75 print(fmt % ("Any PMF?" , resfile.anyPMF()))
76 print(fmt % ("Any MSMS?" , resfile.anyMSMS()))
77 print(fmt % ("Any SQ?" , resfile.anySQ()))
78 print(fmt % ("Any peptide matches" , resfile.anyFastaMatches()))
79
80 print(" ")
81
82
83if __name__ == "__main__":
84 sys.exit(main())
85
86
87""" Running the program as
88
89python resfile_info.py F981123.dat
90
91will give the following output under Mascot Server 2.3:
92
93Search information from ms_mascotresfilebase
94========================================
95Number of queries : 67
96Number of hits : 50
97Number of sequences : 257964
98Sequences after tax : 257964
99Number of residues : 93947433.0
100Execution time : 6
101Date (seconds) : 1171894187
102Date : Mon Feb 19 14:09:47 2007
103Mascot version : 2.1.119
104Fasta version : SwissProt_51.6.fasta
105Is PMF? : False
106Is MSMS? : True
107Is SQ? : False
108Is Error tolerant : False
109Any PMF? : False
110Any MSMS? : True
111Any SQ? : False
112Any peptide matches : True
113
114
115"""
116
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_info.cs

resfile_info.cs

Example program for retrieving general search information.

/*
##############################################################################
# file: resfile_info.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/resfile_info.cs $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class resfile_info
{
public static void Main(string[] argv)
{
// ----- Object creation -----
if (argv.Length < 1)
{
Console.WriteLine("Must specify results filename as parameter");
return;
}
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(argv[0], 0, "");
if (file.isValid())
{
searchInformation(file);
}
else
{
Console.WriteLine("Error number: {0}", file.getLastError());
Console.WriteLine("Error string: {0}", file.getLastErrorString());
return;
}
}
private static void searchInformation(ms_mascotresfilebase file)
{
DateTime searchDate; // C# DateTime struct
int seconds = file.getDate(); // get date of search in seconds since midnight GMT Jan 1st 1970
long milliseconds = (long) seconds * 1000; // convert to milliseconds
searchDate = (new DateTime(1970, 1, 1)).AddMilliseconds(milliseconds); // create the DateTime struct. .NET DateTime
// are intialised to 1/1/0001, so we need to reset to
// 1/1/1970
Console.WriteLine("Search information from ms_mascotresfilebase");
Console.WriteLine("========================================");
Console.WriteLine("Number of queries : {0}", file.getNumQueries());
Console.WriteLine("Number of sequences : {0}", file.getNumSeqs());
Console.WriteLine("Sequences after tax : {0}", file.getNumSeqsAfterTax());
Console.WriteLine("Number of residues : {0}", (int) file.getNumResidues());
Console.WriteLine("Execution time : {0}", file.getExecTime());
Console.WriteLine("Date (seconds) : {0}", file.getDate());
Console.WriteLine("Date : {0}", searchDate.ToString("ddd MMM dd hh:mm:ss yyyy")); // Change output format to match Perl
Console.WriteLine("Mascot version : {0}", file.getMascotVer());
Console.WriteLine("Fasta version : {0}", file.getFastaVer());
// make C# output identical to perl output
Console.WriteLine("Is PMF? : {0}", toBinary(file.isPMF()));
Console.WriteLine("Is MSMS? : {0}", toBinary(file.isMSMS()));
Console.WriteLine("Is SQ? : {0}", toBinary(file.isSQ()));
Console.WriteLine("Is Error tolerant : {0}", toBinary(file.isErrorTolerant()));
Console.WriteLine("Any PMF? : {0}", toBinary(file.anyPMF()));
Console.WriteLine("Any MSMS? : {0}", toBinary(file.anyMSMS()));
Console.WriteLine("Any SQ? : {0}", toBinary(file.anySQ()));
// C++ enum converted to C# enum, so we need to use the enum name when referencing the
// required section constant
Console.WriteLine("Any peptide matches : {0}", toBinary(file.anyFastaMatches()));
Console.WriteLine();
}
public static int toBinary(bool b)
{
return (b) ? 1 : 0;
}
}
}
/*
resfile_info.exe c:\inetpub\mascot\data\F981118.dat
Will give the following output:
Search information from ms_mascotresfilebase
========================================
Number of queries : 6
Number of hits : 50
Number of sequences : 257964
Sequences after tax : 15720
Number of residues : 93947433
Execution time : 8
Date (seconds) : 1171893592
Date : Mon Feb 19 01:59:52 2007
Mascot version : 2.1.119
Fasta version : SwissProt_51.6.fasta
Is PMF? : 1
Is MSMS? : 0
Is SQ? : 0
Is Error tolerant : 0
Any PMF? : 1
Any MSMS? : 0
Any SQ? : 0
Any peptides section : 0
Any peptide matches : 0
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_input.pl

resfile_input.pl

Example program for retrieving input spectrum data.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_input.pl #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/resfile_input.pl $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) { die "Must specify results filename as parameter"; }
my $file = msparser::ms_mascotresfilebase::createResfile($ARGV[0]);
if ($file->isValid) {
inputData($file);
}
##############################################################################
# inputData #
# - parameter 0 ms_mascotresfilebase #
# Display input data #
##############################################################################
sub inputData {
my ($resfile) = @_;
# display input data via inputquery get functions
for my $i (1 .. 1) {
# replace 1 .. 1 with 1 .. $resfile->getNumQueries() to get all input
# data.
print "Input data for query number ", $i , "\n";
print "=========================================", "\n";
my $q = new msparser::ms_inputquery($resfile, $i);
my $fmt = " %-16s: %s\n";
printf $fmt, "title" , $q->getStringTitle(1);
printf $fmt, "mass_min" , $q->getMassMin();
printf $fmt, "mass_max" , $q->getMassMax();
printf $fmt, "int_min" , $q->getIntMin();
printf $fmt, "int_max" , $q->getIntMax();
printf $fmt, "num_vals" , $q->getNumVals();
printf $fmt, "num_used1" , $q->getNumUsed();
printf $fmt, "ions1" , $q->getStringIons1();
printf $fmt, "ions2" , $q->getStringIons2();
printf $fmt, "ions3" , $q->getStringIons3();
printf $fmt, "peptol" , $q->getPepTol();
printf $fmt, "peptol units", $q->getPepTolUnits();
printf $fmt, "peptol str" , $q->getPepTolString();
printf $fmt, "repeat srch" , $resfile->getRepeatSearchString($i);
my $num_peaks = $q->getNumberOfPeaks(1);
for my $j (1 .. $num_peaks) {
print $q->getPeakMass(1, $j), ", ", $q->getPeakIntensity(1, $j), "\n";
}
}
print "\n\n";
}
=pod
Running the program as
perl -I../bin resfile_input.pl ../data/F981123.dat
will give the following output under Mascot Server 2.3:
Input data for query number 1
=========================================
title :
mass_min : 72.09
mass_max : 1711.52
int_min : 1.103
int_max : 80.7
num_vals : 425
num_used1 : 0
ions1 : 157.096962:23.72,185.160000:26.69,286.134951:80.7,385.210000:13.49,480.270000:4.363,129.102412:18.84,187.070000:22.51,354.189124:13.57,399.246727:9.489,482.140542:3.205,130.110251:9.257,258.132661:15.93,357.210000:13.57,443.810000:6.256,481.210000:3.182,136.070000:7.387,213.139215:13.84,371.204929:11.24,459.280000:6.216,489.233770:3.157,147.117662:6.333,229.120000:9.72,326.133204:5.268,423.125582:4.262,483.115000:2.205,159.080000:5.222,240.130000:7.562,298.110000:5.231,444.168974:3.247,474.300000:1.103,158.090000:4.301,270.180000:7.432,324.170000:5.17,411.200000:3.23,475.270000:1.103,86.110000:3.276,175.110000:7.308,312.150879:4.235,463.265712:3.205,476.700000:1.103,102.060000:3.276,241.085275:5.361,293.110000:4.178,445.810000:3.182,478.180000:1.103,115.088725:3.255,243.139772:4.378,353.155308:4.149,401.150000:3.138,486.880000:1.103,72.090000:2.174,76.400000:1.103,84.075000:2.111,87.110000:1.103,88.100000:1.103,98.060000:1.103,103.060000:1.103,105.070000:1.103,116.070000:1.103,117.110000:1.103,118.400000:1.103,120.090000:2.205,126.070000:1.103,127.090000:1.103,128.090000:2.103,131.085000:2.118,132.090000:1.103,135.800000:1.103,137.080000:1.103,138.070000:1.103,139.090000:1.103,140.150000:2.174,141.060000:2.174,143.120000:2.174,146.080000:1.103,152.060000:1.103,155.070000:2.205,156.100000:1.103,159.450000:1.103,165.080000:2.136,166.110000:1.103,167.110000:1.103,169.710000:1.103,170.450000:1.103,171.090000:1.103,173.120000:2.174,177.090000:1.103,178.080000:1.103,181.160000:1.103,182.030000:1.103,183.110000:2.174,183.930000:1.103,186.131024:4.374,188.070000:1.103,188.760000:1.103,189.070000:1.103,190.065000:2.103,191.300000:1.103,197.130000:1.103,199.180000:1.103,200.080000:1.103,201.100000:3.138,202.110000:2.091,203.080000:2.174,203.610000:1.103,211.140000:4.189,212.115000:2.103,212.490000:1.103,214.985000:2.205,216.110000:2.103,217.100000:1.103,218.080000:1.103,219.090000:2.103,223.090000:3.154,224.130000:1.103,225.130000:1.103,227.170000:1.103,227.880000:1.103,228.170000:2.136,229.760000:1.103,231.950000:1.103,233.130000:1.103,234.430000:1.103,235.080000:2.103,236.590000:1.103,238.080000:4.332,239.139997:3.131,242.170000:2.205,244.090000:2.136,244.430000:2.091,245.165685:3.205,246.160000:2.197,247.110000:2.102,248.145000:2.118,249.110000:2.136,250.080000:1.103,251.160000:1.103,253.100000:1.103,254.130000:1.103,255.165000:2.22,256.170000:1.103,257.060000:1.103,259.150000:2.197,260.000000:1.103,260.490000:1.103,262.110000:1.103,265.120000:1.103,266.130000:2.159,266.950000:1.103,267.210000:1.103,268.120000:3.214,269.090000:1.103,271.150000:2.136,272.170000:2.103,274.120000:1.103,275.030000:1.103,276.175000:2.22,278.190000:1.103,279.720000:2.205,281.120000:1.103,283.070000:1.103,284.110000:1.103,285.070000:1.103,287.140000:3.296,287.780000:1.103,288.090000:2.103,290.130000:1.103,294.110000:2.174,295.150000:3.114,295.730000:1.103,297.180000:2.136,300.160000:3.143,302.070000:1.103,303.160000:1.103,303.590000:1.103,304.600000:1.103,305.130000:1.103,306.140000:3.182,307.050000:1.103,308.150000:2.174,308.490000:1.103,312.610000:1.103,312.880000:1.103,314.120000:1.103,316.085000:2.111,317.150000:3.183,318.140000:1.103,320.140000:1.103,322.149731:3.255,323.034482:3.149,327.020000:1.103,328.020000:1.103,331.140000:2.091,332.165000:2.103,333.140000:1.103,335.500000:1.103,336.190000:1.103,337.030000:2.118,338.620000:1.103,338.940000:1.103,339.200000:3.261,341.210000:2.103,342.180000:1.103,342.800000:1.103,343.225000:2.111,343.800000:1.103,344.150000:2.174,346.010000:1.103,347.660000:1.103,348.200000:2.197,349.800000:1.103,350.110000:2.118,351.130000:3.276,352.130000:2.136,353.910000:1.103,354.470000:1.103,355.193955:3.376,358.200000:1.103,359.210000:2.174,359.910000:1.103,360.470000:1.103,361.080000:1.103,362.190000:1.103,363.040000:1.103,364.080000:1.103,366.120000:1.103,367.150000:1.103,368.330000:1.103,368.730000:1.103,369.230000:3.15,369.820000:1.103,370.177065:3.279,373.130000:2.197,374.055000:2.217,374.510000:2.205,376.040000:1.103,377.040000:1.103,380.160000:2.103,382.180000:3.102,383.115000:2.209,385.890000:2.205,386.370000:1.103,387.170000:3.114,387.680000:2.217,388.050000:1.103,389.620000:1.103,390.190000:1.103,390.610000:1.103,394.260000:1.103,395.180000:1.103,396.140000:2.205,397.980000:1.103,400.165000:2.209,403.210000:1.103,404.150000:1.103,404.470000:1.103,410.165000:2.111,411.550000:1.103,413.240000:1.103,414.080000:1.103,415.000000:1.103,416.190000:1.103,416.830000:1.103,417.230000:1.103,417.760000:1.103,418.285000:2.111,418.680000:1.103,420.650000:1.103,421.170000:2.136,422.580000:1.103,425.215000:2.103,425.690000:1.103,426.220000:3.125,428.140000:2.155,428.650000:1.103,430.260000:1.103,430.995000:2.205,433.200000:1.103,433.690000:1.103,435.000000:1.103,435.260000:1.103,437.180000:1.103,438.710000:2.174,439.230000:1.103,440.210000:1.103,442.190000:1.103,443.120000:1.103,444.680000:1.103,445.120000:1.103,449.110000:1.103,450.710000:1.103,452.150000:2.209,453.240000:3.12,454.200000:1.103,454.700000:1.103,458.310000:1.103,460.290000:1.103,461.250000:1.103,461.830000:1.103,462.195000:2.103,463.850000:1.103,464.250000:1.103,467.180000:2.174,470.210000:1.103,471.120000:1.103,489.700000:1.103,493.200000:1.103,494.200000:1.103,505.200000:1.103,508.170000:2.197,508.840000:1.103,509.200000:2.103,511.450000:1.103,522.170000:2.197,523.190000:1.103,524.150000:2.174,527.160000:1.103,528.410000:2.19,529.280000:1.103,530.230000:1.103,531.250000:1.103,533.130000:1.103,533.670000:1.103,536.720000:1.103,537.240000:1.103,538.080000:1.103,538.450000:1.103,540.220000:1.103,545.210000:2.174,545.490000:1.103,546.250000:1.103,547.350000:1.103,550.750000:2.205,558.070000:1.103,561.360000:1.103,562.200000:1.103,563.330000:1.103,568.230000:1.103,571.290000:3.136,573.010000:1.103,575.410000:1.103,580.240000:1.103,581.260000:1.103,585.160000:1.103,588.380000:1.103,590.120000:1.103,599.450000:1.103,605.210000:2.197,607.285000:4.499,608.270000:3.143,613.330000:2.103,614.330000:1.103,617.320000:1.103,621.230000:1.103,622.310000:1.103,625.320000:3.23,626.210000:1.103,633.275000:2.205,640.350000:1.103,642.220000:1.103,644.280000:1.103,646.250000:1.103,648.390000:1.103,651.335000:2.103,653.360000:2.136,658.300000:1.103,662.320000:1.103,663.800000:1.103,668.275000:2.209,674.370000:1.103,676.090000:1.103,677.350000:1.103,678.070000:1.103,683.370000:1.103,684.920000:1.103,685.380000:2.091,686.390000:1.103,701.410000:1.103,702.380000:7.387,703.420000:3.12,707.360000:1.103,713.340000:1.103,718.370000:2.197,720.400000:1.103,724.180000:1.103,728.390000:1.103,734.380000:1.103,735.430000:1.103,736.360000:1.103,737.310000:1.103,741.070000:1.103,745.480000:1.103,747.290000:1.103,748.320000:1.103,754.358237:6.383,755.370000:2.136,760.490000:1.103,765.360000:1.103,767.500000:1.103,770.370000:1.103,775.230000:1.103,778.490000:1.103,792.360000:1.103,796.420000:1.103,801.380000:1.103,814.390000:2.118,815.390000:1.103,816.410000:1.103,820.470000:1.103,825.350000:1.103,841.510000:1.103,848.450000:1.103,883.450000:1.103,884.470000:1.103,896.410000:1.103,907.420000:1.103,908.430000:1.103,916.380000:1.103,1074.300000:1.103,1092.600000:1.103,1164.300000:1.103,1231.540000:1.103,1397.690000:1.103,1660.400000:1.103,1711.520000:1.103
ions2 :
ions3 :
peptol : 0
peptol units :
peptol str :
repeat srch : 497.265612 from(498.272888,1+) query(1)
157.096962, 23.72
185.16, 26.69
286.134951, 80.7
385.21, 13.49
480.27, 4.363
129.102412, 18.84
187.07, 22.51
354.189124, 13.57
399.246727, 9.489
482.140542, 3.205
130.110251, 9.257
258.132661, 15.93
357.21, 13.57
443.81, 6.256
481.21, 3.182
136.07, 7.387
213.139215, 13.84
371.204929, 11.24
459.28, 6.216
489.23377, 3.157
147.117662, 6.333
229.12, 9.72
326.133204, 5.268
423.125582, 4.262
483.115, 2.205
159.08, 5.222
240.13, 7.562
298.11, 5.231
444.168974, 3.247
474.3, 1.103
158.09, 4.301
270.18, 7.432
324.17, 5.17
411.2, 3.23
475.27, 1.103
86.11, 3.276
175.11, 7.308
312.150879, 4.235
463.265712, 3.205
476.7, 1.103
102.06, 3.276
241.085275, 5.361
293.11, 4.178
445.81, 3.182
478.18, 1.103
115.088725, 3.255
243.139772, 4.378
353.155308, 4.149
401.15, 3.138
486.88, 1.103
72.09, 2.174
76.4, 1.103
84.075, 2.111
87.11, 1.103
88.1, 1.103
98.06, 1.103
103.06, 1.103
105.07, 1.103
116.07, 1.103
117.11, 1.103
118.4, 1.103
120.09, 2.205
126.07, 1.103
127.09, 1.103
128.09, 2.103
131.085, 2.118
132.09, 1.103
135.8, 1.103
137.08, 1.103
138.07, 1.103
139.09, 1.103
140.15, 2.174
141.06, 2.174
143.12, 2.174
146.08, 1.103
152.06, 1.103
155.07, 2.205
156.1, 1.103
159.45, 1.103
165.08, 2.136
166.11, 1.103
167.11, 1.103
169.71, 1.103
170.45, 1.103
171.09, 1.103
173.12, 2.174
177.09, 1.103
178.08, 1.103
181.16, 1.103
182.03, 1.103
183.11, 2.174
183.93, 1.103
186.131024, 4.374
188.07, 1.103
188.76, 1.103
189.07, 1.103
190.065, 2.103
191.3, 1.103
197.13, 1.103
199.18, 1.103
200.08, 1.103
201.1, 3.138
202.11, 2.091
203.08, 2.174
203.61, 1.103
211.14, 4.189
212.115, 2.103
212.49, 1.103
214.985, 2.205
216.11, 2.103
217.1, 1.103
218.08, 1.103
219.09, 2.103
223.09, 3.154
224.13, 1.103
225.13, 1.103
227.17, 1.103
227.88, 1.103
228.17, 2.136
229.76, 1.103
231.95, 1.103
233.13, 1.103
234.43, 1.103
235.08, 2.103
236.59, 1.103
238.08, 4.332
239.139997, 3.131
242.17, 2.205
244.09, 2.136
244.43, 2.091
245.165685, 3.205
246.16, 2.197
247.11, 2.102
248.145, 2.118
249.11, 2.136
250.08, 1.103
251.16, 1.103
253.1, 1.103
254.13, 1.103
255.165, 2.22
256.17, 1.103
257.06, 1.103
259.15, 2.197
260, 1.103
260.49, 1.103
262.11, 1.103
265.12, 1.103
266.13, 2.159
266.95, 1.103
267.21, 1.103
268.12, 3.214
269.09, 1.103
271.15, 2.136
272.17, 2.103
274.12, 1.103
275.03, 1.103
276.175, 2.22
278.19, 1.103
279.72, 2.205
281.12, 1.103
283.07, 1.103
284.11, 1.103
285.07, 1.103
287.14, 3.296
287.78, 1.103
288.09, 2.103
290.13, 1.103
294.11, 2.174
295.15, 3.114
295.73, 1.103
297.18, 2.136
300.16, 3.143
302.07, 1.103
303.16, 1.103
303.59, 1.103
304.6, 1.103
305.13, 1.103
306.14, 3.182
307.05, 1.103
308.15, 2.174
308.49, 1.103
312.61, 1.103
312.88, 1.103
314.12, 1.103
316.085, 2.111
317.15, 3.183
318.14, 1.103
320.14, 1.103
322.149731, 3.255
323.034482, 3.149
327.02, 1.103
328.02, 1.103
331.14, 2.091
332.165, 2.103
333.14, 1.103
335.5, 1.103
336.19, 1.103
337.03, 2.118
338.62, 1.103
338.94, 1.103
339.2, 3.261
341.21, 2.103
342.18, 1.103
342.8, 1.103
343.225, 2.111
343.8, 1.103
344.15, 2.174
346.01, 1.103
347.66, 1.103
348.2, 2.197
349.8, 1.103
350.11, 2.118
351.13, 3.276
352.13, 2.136
353.91, 1.103
354.47, 1.103
355.193955, 3.376
358.2, 1.103
359.21, 2.174
359.91, 1.103
360.47, 1.103
361.08, 1.103
362.19, 1.103
363.04, 1.103
364.08, 1.103
366.12, 1.103
367.15, 1.103
368.33, 1.103
368.73, 1.103
369.23, 3.15
369.82, 1.103
370.177065, 3.279
373.13, 2.197
374.055, 2.217
374.51, 2.205
376.04, 1.103
377.04, 1.103
380.16, 2.103
382.18, 3.102
383.115, 2.209
385.89, 2.205
386.37, 1.103
387.17, 3.114
387.68, 2.217
388.05, 1.103
389.62, 1.103
390.19, 1.103
390.61, 1.103
394.26, 1.103
395.18, 1.103
396.14, 2.205
397.98, 1.103
400.165, 2.209
403.21, 1.103
404.15, 1.103
404.47, 1.103
410.165, 2.111
411.55, 1.103
413.24, 1.103
414.08, 1.103
415, 1.103
416.19, 1.103
416.83, 1.103
417.23, 1.103
417.76, 1.103
418.285, 2.111
418.68, 1.103
420.65, 1.103
421.17, 2.136
422.58, 1.103
425.215, 2.103
425.69, 1.103
426.22, 3.125
428.14, 2.155
428.65, 1.103
430.26, 1.103
430.995, 2.205
433.2, 1.103
433.69, 1.103
435, 1.103
435.26, 1.103
437.18, 1.103
438.71, 2.174
439.23, 1.103
440.21, 1.103
442.19, 1.103
443.12, 1.103
444.68, 1.103
445.12, 1.103
449.11, 1.103
450.71, 1.103
452.15, 2.209
453.24, 3.12
454.2, 1.103
454.7, 1.103
458.31, 1.103
460.29, 1.103
461.25, 1.103
461.83, 1.103
462.195, 2.103
463.85, 1.103
464.25, 1.103
467.18, 2.174
470.21, 1.103
471.12, 1.103
489.7, 1.103
493.2, 1.103
494.2, 1.103
505.2, 1.103
508.17, 2.197
508.84, 1.103
509.2, 2.103
511.45, 1.103
522.17, 2.197
523.19, 1.103
524.15, 2.174
527.16, 1.103
528.41, 2.19
529.28, 1.103
530.23, 1.103
531.25, 1.103
533.13, 1.103
533.67, 1.103
536.72, 1.103
537.24, 1.103
538.08, 1.103
538.45, 1.103
540.22, 1.103
545.21, 2.174
545.49, 1.103
546.25, 1.103
547.35, 1.103
550.75, 2.205
558.07, 1.103
561.36, 1.103
562.2, 1.103
563.33, 1.103
568.23, 1.103
571.29, 3.136
573.01, 1.103
575.41, 1.103
580.24, 1.103
581.26, 1.103
585.16, 1.103
588.38, 1.103
590.12, 1.103
599.45, 1.103
605.21, 2.197
607.285, 4.499
608.27, 3.143
613.33, 2.103
614.33, 1.103
617.32, 1.103
621.23, 1.103
622.31, 1.103
625.32, 3.23
626.21, 1.103
633.275, 2.205
640.35, 1.103
642.22, 1.103
644.28, 1.103
646.25, 1.103
648.39, 1.103
651.335, 2.103
653.36, 2.136
658.3, 1.103
662.32, 1.103
663.8, 1.103
668.275, 2.209
674.37, 1.103
676.09, 1.103
677.35, 1.103
678.07, 1.103
683.37, 1.103
684.92, 1.103
685.38, 2.091
686.39, 1.103
701.41, 1.103
702.38, 7.387
703.42, 3.12
707.36, 1.103
713.34, 1.103
718.37, 2.197
720.4, 1.103
724.18, 1.103
728.39, 1.103
734.38, 1.103
735.43, 1.103
736.36, 1.103
737.31, 1.103
741.07, 1.103
745.48, 1.103
747.29, 1.103
748.32, 1.103
754.358237, 6.383
755.37, 2.136
760.49, 1.103
765.36, 1.103
767.5, 1.103
770.37, 1.103
775.23, 1.103
778.49, 1.103
792.36, 1.103
796.42, 1.103
801.38, 1.103
814.39, 2.118
815.39, 1.103
816.41, 1.103
820.47, 1.103
825.35, 1.103
841.51, 1.103
848.45, 1.103
883.45, 1.103
884.47, 1.103
896.41, 1.103
907.42, 1.103
908.43, 1.103
916.38, 1.103
1074.3, 1.103
1092.6, 1.103
1164.3, 1.103
1231.54, 1.103
1397.69, 1.103
1660.4, 1.103
1711.52, 1.103
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_input.cpp

resfile_input.cpp

Example program for retrieving input spectrum data.

/*
##############################################################################
# file: resfile_input.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/resfile_input.cpp $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
#include <vector>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
/*****************************************************************************/
/* Local functions */
/* (This test harness is 'C' and not C++) */
/*****************************************************************************/
static void inputData(ms_mascotresfilebase & file);
/*****************************************************************************/
/* main */
/* Call this program with a single argument - the name of the .dat file */
/*****************************************************************************/
int main(int argc, char * argv[])
{
if (argc == 2)
{
ms_mascotresfilebase file = ms_mascotresfilebase::createResfileBase(argv[1]);
if (file.isValid())
{
inputData(file);
}
else
std::cout << "Error: " << file.getLastErrorString() << std::endl;
}
else
std::cout << "Must supply the name of a .dat file as a command line argument" << std::endl;
return 0;
}
/*****************************************************************************/
/* inputData */
/* Display input data */
/*****************************************************************************/
static void inputData(ms_mascotresfilebase & file)
{
//display input data via inputquery get functions
for (int i = 1; i <= 1 /* file.getNumQueries()*/; i++)
{
std::cout << "Input data for query number " << i << std::endl;
std::cout << "=========================================" << std::endl;
ms_inputquery q(file, i);
std::cout << " title : " << q.getStringTitle(1).c_str()<< std::endl;
std::cout << " mass_min : " << q.getMassMin() << std::endl;
std::cout << " mass_max : " << q.getMassMax() << std::endl;
std::cout << " int_min : " << q.getIntMin() << std::endl;
std::cout << " int_max : " << q.getIntMax() << std::endl;
std::cout << " num_vals : " << q.getNumVals() << std::endl;
std::cout << " num_used1 : " << q.getNumUsed() << std::endl;
std::cout << " ions1 : " << q.getStringIons1().c_str() << std::endl;
std::cout << " ions2 : " << q.getStringIons2().c_str() << std::endl;
std::cout << " ions3 : " << q.getStringIons3().c_str() << std::endl;
std::cout << " peptol : " << q.getPepTol() << std::endl;
std::cout << " peptol units: " << q.getPepTolUnits().c_str() << std::endl;
std::cout << " peptol str : " << q.getPepTolString().c_str()<< std::endl;
std::cout << " INSTRUMENT : " << q.getINSTRUMENT().c_str() << std::endl;
std::cout << " RULES : " << q.getRULES().c_str() << std::endl;
std::cout << " IT_MODS : " << q.getIT_MODS().c_str() << std::endl;
std::cout << " repeat srch : " << file.getRepeatSearchString(i).c_str() << std::endl;
std::vector< std::pair< double, double > > tmp = q.getPeakList(1);
for (unsigned int j=0; j < tmp.size(); j++)
{
std::cout << tmp[j].first << ", " << tmp[j].second << std::endl;
}
}
std::cout << std::endl;
}
/*
will give the output:
Input data for query number 1
=========================================
title : dp210198c 21 Jan 98 DERIVED SPECTRUM P9
mass_min : 214.8
mass_max : 1228.7
int_min : 7
int_max : 114465
num_vals : 443
num_used1 : 0
ions1 : 288.200000:2137,371.127841:1663,472.096295:2.939e+04,567.000000:5.469e+04,663.100000:1.145e+05,758
.200000:7.356e+04,871.200000:2.539e+04,956.100000:2241,1055.000000:1.227e+04,1167.994665:1.725e+04,1215.400000:257,314.2
00000:1308,377.992647:1088,501.400000:1.043e+04,584.997427:3.906e+04,654.180103:3.006e+04,759.300000:1.557e+04,841.90000
0:1.917e+04,972.292156:1874,1056.300000:3799,1169.100000:1.123e+04,1225.200000:58,242.800000:417,377.000000:828,454.1000
00:5162,586.200000:5258,662.700000:1.83e+04,728.800000:1397,842.900000:4893,956.800000:443,1029.300000:1846,1170.200000:
1280,1216.200000:51,313.900000:187,387.200000:656,473.200000:1342,568.100000:5122,663.600000:9782,729.200000:626,872.300
000:4300,973.515686:255,1100.300000:1290,1198.200000:117,1217.500000:45,243.200000:159,379.100000:231,502.400000:556,599
.100000:1504,655.000000:1672,814.100000:277,841.200000:215,958.138974:195,1056.000000:492,1196.900000:96,1226.400000:38,
286.100000:83,408.200000:187,428.200000:283,614.400000:1403,710.900000:1144,730.000000:214,843.600000:194,1011.400000:78
,1057.200000:416,1198.900000:80,1227.000000:20,289.000000:60,353.300000:136,500.700000:143,551.300000:800,665.994513:565
,757.300000:182,873.300000:166,955.000000:51,1101.262914:302,1197.600000:53,1228.700000:19,253.900000:44,394.000000:115,
426.400000:75,566.263208:424,665.300000:563,801.800000:171,827.400000:165,1002.100000:46,1030.500000:193,1168.500000:42,
290.200000:25,388.100000:63,444.100000:75,542.000000:399,664.600000:388,760.000000:160,825.200000:76,937.900000:38,1082.
400000:126,1170.500000:40,287.100000:23,342.800000:48,454.900000:64,614.100000:373,644.000000:290,769.300000:111,902.100
000:67,917.300000:37,1029.800000:125,1149.800000:38,214.800000:18,242.100000:19,252.100000:20,315.200000:44,325.800000:1
7,333.100000:21,347.500000:19,348.700000:13,349.500000:23,352.600000:47,359.100000:28,366.000000:36,367.900000:7,376.100
000:14,380.100000:46,407.300000:11,410.900000:22,412.400000:31,418.000000:17,429.900000:57,431.000000:15,436.400000:11,4
44.900000:27,447.200000:18,453.200000:11,455.500000:33,456.100000:14,459.900000:15,461.600000:19,463.300000:7,465.600000
:22,470.400000:12,470.900000:51,474.200000:44,477.100000:15,477.900000:32,483.900000:37,486.200000:20,496.900000:11,497.
600000:14,499.100000:41,503.800000:24,505.400000:22,508.300000:12,508.900000:17,511.800000:19,513.000000:20,515.000000:1
8,517.000000:16,522.100000:58,523.900000:15,524.600000:78,525.300000:19,525.900000:370,526.700000:36,532.900000:11,533.5
00000:14,536.900000:19,538.200000:44,539.261607:224,540.200000:39,541.100000:133,543.043902:41,545.100000:9,545.600000:3
0,547.300000:23,547.900000:13,548.700000:340,549.600000:81,550.200000:41,551.700000:16,552.300000:69,555.500000:29,557.0
68975:361,558.300000:54,560.100000:7,561.100000:24,563.400000:39,564.100000:101,567.600000:35,568.900000:37,569.500000:1
4,570.000000:49,571.100000:45,572.300000:76,574.000000:99,574.600000:22,576.300000:18,580.800000:34,582.300000:41,587.10
0000:131,587.900000:53,590.300000:12,591.800000:17,592.500000:18,594.800000:9,595.300000:56,596.100000:97,596.600000:62,
597.100000:27,597.700000:63,600.000000:57,602.100000:28,603.900000:16,605.200000:69,606.800000:24,607.500000:13,608.5000
00:57,608.800000:12,610.200000:50,610.500000:12,611.200000:96,612.200000:24,613.200000:13,615.000000:194,615.600000:19,6
16.200000:23,618.400000:15,619.100000:31,621.100000:120,621.700000:36,622.600000:11,623.200000:43,624.100000:147,624.800
000:32,626.000000:22,627.000000:53,627.900000:21,628.900000:16,629.500000:29,630.500000:14,631.400000:45,633.200000:61,6
35.000000:58,635.736413:184,636.600000:29,637.500000:78,638.600000:14,639.800000:72,640.500000:51,641.100000:33,641.7000
00:40,642.400000:121,642.800000:170,643.300000:57,644.600000:48,645.700000:36,646.500000:39,647.400000:28,648.500000:30,
649.500000:108,650.000000:13,650.600000:43,651.800000:107,652.300000:33,652.900000:33,656.300000:178,657.100000:78,658.2
00000:19,658.800000:76,660.590741:108,661.900000:216,667.000000:193,677.300000:8,680.500000:13,683.500000:38,684.500000:
28,685.500000:24,686.200000:13,687.275862:87,688.200000:28,688.900000:28,689.400000:50,691.500000:28,692.700000:25,693.2
00000:15,694.000000:31,697.100000:8,698.300000:42,700.300000:17,700.900000:21,703.500000:39,704.200000:20,704.900000:14,
708.300000:15,709.000000:42,711.500000:90,711.800000:119,713.100000:35,715.200000:29,718.500000:57,719.900000:52,721.500
000:78,722.400000:29,725.400000:30,731.100000:13,731.800000:13,734.500000:36,735.300000:46,735.700000:28,738.600000:23,7
39.900000:20,740.500000:81,741.800000:64,744.700000:23,745.500000:18,747.400000:23,751.100000:21,751.900000:34,755.20000
0:13,756.200000:28,760.900000:21,762.800000:19,764.100000:19,767.600000:41,768.200000:75,771.200000:9,771.800000:10,773.
800000:10,776.100000:21,777.500000:39,783.400000:39,785.100000:26,786.800000:15,788.200000:23,789.300000:14,791.700000:2
1,792.600000:29,795.700000:53,796.200000:25,798.900000:13,799.400000:14,800.200000:12,800.700000:32,802.300000:25,802.80
0000:103,804.000000:26,805.200000:83,807.900000:15,808.700000:25,809.800000:36,810.900000:50,811.500000:85,812.100000:36
,813.400000:22,814.600000:78,815.100000:52,815.900000:25,817.300000:21,821.300000:30,822.000000:9,827.800000:33,828.9000
00:20,832.100000:13,834.800000:18,835.700000:25,836.600000:20,846.700000:8,851.100000:25,852.054545:66,853.200000:20,854
.400000:28,857.000000:21,857.800000:21,859.500000:14,861.100000:17,864.500000:20,867.800000:49,868.800000:47,869.100000:
19,869.700000:22,872.900000:22,877.100000:16,880.800000:20,885.000000:21,885.800000:12,886.300000:16,888.800000:11,890.5
00000:10,899.339024:41,907.800000:39,909.400000:8,911.200000:27,911.900000:9,925.900000:10,928.800000:30,930.700000:26,9
33.700000:9,935.700000:13,945.100000:20,948.900000:10,953.600000:14,960.500000:14,974.100000:36,994.000000:37,1003.30000
0:18,1010.200000:18,1010.800000:27,1012.100000:21,1014.000000:14,1020.100000:20,1021.000000:31,1028.900000:118,1031.0000
00:18,1031.600000:40,1033.100000:14,1037.900000:55,1041.100000:17,1045.300000:13,1054.000000:92,1057.700000:19,1061.9000
00:20,1069.100000:16,1083.600000:41,1093.400000:49,1098.500000:32,1099.800000:46,1102.500000:52,1103.200000:18,1104.5000
00:9,1125.400000:16,1131.800000:24,1132.400000:21,1139.800000:12,1150.800000:22,1152.900000:15,1157.600000:8,1165.300000
:14,1166.700000:11,1178.700000:25,1179.500000:23,1180.400000:25,1185.800000:12,1192.800000:18,1194.800000:12,1214.700000
:35
ions2 :
ions3 :
ions2 :
ions3 :
peptol : 0
peptol units:
peptol str :
repeat srch : 1341.784350 from(671.900000,2+) title(dp210198c%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20
%20%20%20%2021%2dJan%2d98%20DERIVED%20SPECTRUM%20%20%20%20%239) query(1)
371.128, 1663
472.096, 29390
567, 54690
663.1, 114500
758.2, 73560
871.2, 25390
956.1, 2241
1055, 12270
1167.99, 17250
1215.4, 257
314.2, 1308
377.993, 1088
501.4, 10430
584.997, 39060
654.18, 30060
759.3, 15570
841.9, 19170
972.292, 1874
1056.3, 3799
1169.1, 11230
1225.2, 58
242.8, 417
377, 828
454.1, 5162
586.2, 5258
662.7, 18300
728.8, 1397
842.9, 4893
956.8, 443
1029.3, 1846
1170.2, 1280
1216.2, 51
313.9, 187
387.2, 656
473.2, 1342
568.1, 5122
663.6, 9782
729.2, 626
872.3, 4300
973.516, 255
1100.3, 1290
1198.2, 117
1217.5, 45
243.2, 159
379.1, 231
502.4, 556
599.1, 1504
655, 1672
814.1, 277
841.2, 215
958.139, 195
1056, 492
1196.9, 96
1226.4, 38
286.1, 83
408.2, 187
428.2, 283
614.4, 1403
710.9, 1144
730, 214
843.6, 194
1011.4, 78
1057.2, 416
1198.9, 80
1227, 20
289, 60
353.3, 136
500.7, 143
551.3, 800
665.995, 565
757.3, 182
873.3, 166
955, 51
1101.26, 302
1197.6, 53
1228.7, 19
253.9, 44
394, 115
426.4, 75
566.263, 424
665.3, 563
801.8, 171
827.4, 165
1002.1, 46
1030.5, 193
1168.5, 42
290.2, 25
388.1, 63
444.1, 75
542, 399
664.6, 388
760, 160
825.2, 76
937.9, 38
1082.4, 126
1170.5, 40
287.1, 23
342.8, 48
454.9, 64
614.1, 373
644, 290
769.3, 111
902.1, 67
917.3, 37
1029.8, 125
1149.8, 38
214.8, 18
242.1, 19
252.1, 20
315.2, 44
325.8, 17
333.1, 21
347.5, 19
348.7, 13
349.5, 23
352.6, 47
359.1, 28
366, 36
367.9, 7
376.1, 14
380.1, 46
407.3, 11
410.9, 22
412.4, 31
418, 17
429.9, 57
431, 15
436.4, 11
444.9, 27
447.2, 18
453.2, 11
455.5, 33
456.1, 14
459.9, 15
461.6, 19
463.3, 7
465.6, 22
470.4, 12
470.9, 51
474.2, 44
477.1, 15
477.9, 32
483.9, 37
486.2, 20
496.9, 11
497.6, 14
499.1, 41
503.8, 24
505.4, 22
508.3, 12
508.9, 17
511.8, 19
513, 20
515, 18
517, 16
522.1, 58
523.9, 15
524.6, 78
525.3, 19
525.9, 370
526.7, 36
532.9, 11
533.5, 14
536.9, 19
538.2, 44
539.262, 224
540.2, 39
541.1, 133
543.044, 41
545.1, 9
545.6, 30
547.3, 23
547.9, 13
548.7, 340
549.6, 81
550.2, 41
551.7, 16
552.3, 69
555.5, 29
557.069, 361
558.3, 54
560.1, 7
561.1, 24
563.4, 39
564.1, 101
567.6, 35
568.9, 37
569.5, 14
570, 49
571.1, 45
572.3, 76
574, 99
574.6, 22
576.3, 18
580.8, 34
582.3, 41
587.1, 131
587.9, 53
590.3, 12
591.8, 17
592.5, 18
594.8, 9
595.3, 56
596.1, 97
596.6, 62
597.1, 27
597.7, 63
600, 57
602.1, 28
603.9, 16
605.2, 69
606.8, 24
607.5, 13
608.5, 57
608.8, 12
610.2, 50
610.5, 12
611.2, 96
612.2, 24
613.2, 13
615, 194
615.6, 19
616.2, 23
618.4, 15
619.1, 31
621.1, 120
621.7, 36
622.6, 11
623.2, 43
624.1, 147
624.8, 32
626, 22
627, 53
627.9, 21
628.9, 16
629.5, 29
630.5, 14
631.4, 45
633.2, 61
635, 58
635.736, 184
636.6, 29
637.5, 78
638.6, 14
639.8, 72
640.5, 51
641.1, 33
641.7, 40
642.4, 121
642.8, 170
643.3, 57
644.6, 48
645.7, 36
646.5, 39
647.4, 28
648.5, 30
649.5, 108
650, 13
650.6, 43
651.8, 107
652.3, 33
652.9, 33
656.3, 178
657.1, 78
658.2, 19
658.8, 76
660.591, 108
661.9, 216
667, 193
677.3, 8
680.5, 13
683.5, 38
684.5, 28
685.5, 24
686.2, 13
687.276, 87
688.2, 28
688.9, 28
689.4, 50
691.5, 28
692.7, 25
693.2, 15
694, 31
697.1, 8
698.3, 42
700.3, 17
700.9, 21
703.5, 39
704.2, 20
704.9, 14
708.3, 15
709, 42
711.5, 90
711.8, 119
713.1, 35
715.2, 29
718.5, 57
719.9, 52
721.5, 78
722.4, 29
725.4, 30
731.1, 13
731.8, 13
734.5, 36
735.3, 46
735.7, 28
738.6, 23
739.9, 20
740.5, 81
741.8, 64
744.7, 23
745.5, 18
747.4, 23
751.1, 21
751.9, 34
755.2, 13
756.2, 28
760.9, 21
762.8, 19
764.1, 19
767.6, 41
768.2, 75
771.2, 9
771.8, 10
773.8, 10
776.1, 21
777.5, 39
783.4, 39
785.1, 26
786.8, 15
788.2, 23
789.3, 14
791.7, 21
792.6, 29
795.7, 53
796.2, 25
798.9, 13
799.4, 14
800.2, 12
800.7, 32
802.3, 25
802.8, 103
804, 26
805.2, 83
807.9, 15
808.7, 25
809.8, 36
810.9, 50
811.5, 85
812.1, 36
813.4, 22
814.6, 78
815.1, 52
815.9, 25
817.3, 21
821.3, 30
822, 9
827.8, 33
828.9, 20
832.1, 13
834.8, 18
835.7, 25
836.6, 20
846.7, 8
851.1, 25
852.055, 66
853.2, 20
854.4, 28
857, 21
857.8, 21
859.5, 14
861.1, 17
864.5, 20
867.8, 49
868.8, 47
869.1, 19
869.7, 22
872.9, 22
877.1, 16
880.8, 20
885, 21
885.8, 12
886.3, 16
888.8, 11
890.5, 10
899.339, 41
907.8, 39
909.4, 8
911.2, 27
911.9, 9
925.9, 10
928.8, 30
930.7, 26
933.7, 9
935.7, 13
945.1, 20
948.9, 10
953.6, 14
960.5, 14
974.1, 36
994, 37
1003.3, 18
1010.2, 18
1010.8, 27
1012.1, 21
1014, 14
1020.1, 20
1021, 31
1028.9, 118
1031, 18
1031.6, 40
v1033.1, 14
1037.9, 55
1041.1, 17
1045.3, 13
1054, 92
1057.7, 19
1061.9, 20
1069.1, 16
1083.6, 41
1093.4, 49
1098.5, 32
1099.8, 46
1102.5, 52
1103.2, 18
1104.5, 9
1125.4, 16
1131.8, 24
1132.4, 21
1139.8, 12
1150.8, 22
1152.9, 15
1157.6, 8
1165.3, 14
1166.7, 11
1178.7, 25
1179.5, 23
1180.4, 25
1185.8, 12
1192.8, 18
1194.8, 12
1214.7, 35
*/
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_inputquery
This class encapsulates the input queries (peak lists) in the Mascot results file.
Definition: ms_inputquery.hpp:43
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresfilebase::getLastErrorString
std::string getLastErrorString() const
Return the last error number - or an empty string.
Definition: ms_mascotresfilebase.cpp:824
matrix_science::ms_mascotresfilebase::getRepeatSearchString
virtual std::string getRepeatSearchString(const int query, const bool fullQuery=false) const =0
To perform a repeat search need to build up appropriate string.
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_input.java

resfile_input.java

Example program for retrieving input spectrum data.

/*
##############################################################################
# file: resfile_input.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_inputda $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class resfile_input {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// ----- Object creation -----
if(argv.length < 1) {
System.out.println("Must specify results filename as parameter");
System.exit(0);
}
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(argv[0], 0, "");
if (file.isValid()) {
inputData(file);
} else {
System.out.println("Error number: "+file.getLastError());
System.out.println("Error string: "+file.getLastErrorString());
System.exit(0);
}
}
private static void inputData(ms_mascotresfilebase file) {
int i;
int j;
int num_peaks;
// display input data via inputquery get functions
for(i=1; i <=1; i++) { // replace i<=1 with i<=file.getNumQueries() for complete dataset
System.out.println("Input data for query number "+i);
System.out.println("=========================================");
ms_inputquery q=new ms_inputquery(file,i);
System.out.println(" title : "+q.getStringTitle(true));
System.out.println(" mass_min : "+q.getMassMin());
System.out.println(" mass_max : "+q.getMassMax());
System.out.println(" int_min : "+q.getIntMin());
System.out.println(" int_max : "+q.getIntMax());
System.out.println(" num_vals : "+q.getNumVals());
System.out.println(" num_used1 : "+q.getNumUsed());
System.out.println(" ions1 : "+q.getStringIons1());
System.out.println(" ions2 : "+q.getStringIons2());
System.out.println(" ions3 : "+q.getStringIons3());
System.out.println(" peptol : "+q.getPepTol());
System.out.println(" peptol units: "+q.getPepTolUnits());
System.out.println(" peptol str : "+q.getPepTolString());
System.out.println(" INSTRUMENT : "+q.getINSTRUMENT());
System.out.println(" RULES : "+q.getRULES());
System.out.println(" IT_MODS : "+q.getIT_MODS());
System.out.println(" repeat srch : "+file.getRepeatSearchString(i));
num_peaks = q.getNumberOfPeaks(1);
for(j=1; j <= num_peaks; j++) {
System.out.println(roundWholeNumber(q.getPeakMass(1,j))+", "+roundWholeNumber(q.getPeakIntensity(1,j)));
}
}
System.out.println("\n");
}
private static int toBinary(boolean bool) {
if(bool) return 1;
return 0;
}
private static String roundWholeNumber (double toRound) {
String myInt = ""+toRound;
myInt += "\n";
if(myInt.indexOf(".0\n")>-1) {
return myInt.substring(0,myInt.indexOf(".0\n"));
}
return ""+toRound;
}
}
/*
will give the output:
C>java -classpath .;../java/msparser.jar resfile_input F981123.dat
Input data for query number 1
=========================================
title : dp210198c 21-Jan-98 DERIVED SPECTRUM #9
mass_min : 214.8
mass_max : 1228.7
int_min : 7.0
int_max : 114465.0
num_vals : 443
num_used1 : 0
ions1 : 288.200000:2137,371.127841:1663,472.096295:2.939e+04,567.000000:5.469e+04,663.100000:1.145e+05,758.2
00000:7.356e+04,871.200000:2.539e+04,956.100000:2241,1055.000000:1.227e+04,1167.994665:1.725e+04,1215.400000:257,314.200
000:1308,377.992647:1088,501.400000:1.043e+04,584.997427:3.906e+04,654.180103:3.006e+04,759.300000:1.557e+04,841.900000:
1.917e+04,972.292156:1874,1056.300000:3799,1169.100000:1.123e+04,1225.200000:58,242.800000:417,377.000000:828,454.100000
:5162,586.200000:5258,662.700000:1.83e+04,728.800000:1397,842.900000:4893,956.800000:443,1029.300000:1846,1170.200000:12
80,1216.200000:51,313.900000:187,387.200000:656,473.200000:1342,568.100000:5122,663.600000:9782,729.200000:626,872.30000
0:4300,973.515686:255,1100.300000:1290,1198.200000:117,1217.500000:45,243.200000:159,379.100000:231,502.400000:556,599.1
00000:1504,655.000000:1672,814.100000:277,841.200000:215,958.138974:195,1056.000000:492,1196.900000:96,1226.400000:38,28
6.100000:83,408.200000:187,428.200000:283,614.400000:1403,710.900000:1144,730.000000:214,843.600000:194,1011.400000:78,1
057.200000:416,1198.900000:80,1227.000000:20,289.000000:60,353.300000:136,500.700000:143,551.300000:800,665.994513:565,7
57.300000:182,873.300000:166,955.000000:51,1101.262914:302,1197.600000:53,1228.700000:19,253.900000:44,394.000000:115,42
6.400000:75,566.263208:424,665.300000:563,801.800000:171,827.400000:165,1002.100000:46,1030.500000:193,1168.500000:42,29
0.200000:25,388.100000:63,444.100000:75,542.000000:399,664.600000:388,760.000000:160,825.200000:76,937.900000:38,1082.40
0000:126,1170.500000:40,287.100000:23,342.800000:48,454.900000:64,614.100000:373,644.000000:290,769.300000:111,902.10000
0:67,917.300000:37,1029.800000:125,1149.800000:38,214.800000:18,242.100000:19,252.100000:20,315.200000:44,325.800000:17,
333.100000:21,347.500000:19,348.700000:13,349.500000:23,352.600000:47,359.100000:28,366.000000:36,367.900000:7,376.10000
0:14,380.100000:46,407.300000:11,410.900000:22,412.400000:31,418.000000:17,429.900000:57,431.000000:15,436.400000:11,444
.900000:27,447.200000:18,453.200000:11,455.500000:33,456.100000:14,459.900000:15,461.600000:19,463.300000:7,465.600000:2
2,470.400000:12,470.900000:51,474.200000:44,477.100000:15,477.900000:32,483.900000:37,486.200000:20,496.900000:11,497.60
0000:14,499.100000:41,503.800000:24,505.400000:22,508.300000:12,508.900000:17,511.800000:19,513.000000:20,515.000000:18,
517.000000:16,522.100000:58,523.900000:15,524.600000:78,525.300000:19,525.900000:370,526.700000:36,532.900000:11,533.500
000:14,536.900000:19,538.200000:44,539.261607:224,540.200000:39,541.100000:133,543.043902:41,545.100000:9,545.600000:30,
547.300000:23,547.900000:13,548.700000:340,549.600000:81,550.200000:41,551.700000:16,552.300000:69,555.500000:29,557.068
975:361,558.300000:54,560.100000:7,561.100000:24,563.400000:39,564.100000:101,567.600000:35,568.900000:37,569.500000:14,
570.000000:49,571.100000:45,572.300000:76,574.000000:99,574.600000:22,576.300000:18,580.800000:34,582.300000:41,587.1000
00:131,587.900000:53,590.300000:12,591.800000:17,592.500000:18,594.800000:9,595.300000:56,596.100000:97,596.600000:62,59
7.100000:27,597.700000:63,600.000000:57,602.100000:28,603.900000:16,605.200000:69,606.800000:24,607.500000:13,608.500000
:57,608.800000:12,610.200000:50,610.500000:12,611.200000:96,612.200000:24,613.200000:13,615.000000:194,615.600000:19,616
.200000:23,618.400000:15,619.100000:31,621.100000:120,621.700000:36,622.600000:11,623.200000:43,624.100000:147,624.80000
0:32,626.000000:22,627.000000:53,627.900000:21,628.900000:16,629.500000:29,630.500000:14,631.400000:45,633.200000:61,635
.000000:58,635.736413:184,636.600000:29,637.500000:78,638.600000:14,639.800000:72,640.500000:51,641.100000:33,641.700000
:40,642.400000:121,642.800000:170,643.300000:57,644.600000:48,645.700000:36,646.500000:39,647.400000:28,648.500000:30,64
9.500000:108,650.000000:13,650.600000:43,651.800000:107,652.300000:33,652.900000:33,656.300000:178,657.100000:78,658.200
000:19,658.800000:76,660.590741:108,661.900000:216,667.000000:193,677.300000:8,680.500000:13,683.500000:38,684.500000:28
,685.500000:24,686.200000:13,687.275862:87,688.200000:28,688.900000:28,689.400000:50,691.500000:28,692.700000:25,693.200
000:15,694.000000:31,697.100000:8,698.300000:42,700.300000:17,700.900000:21,703.500000:39,704.200000:20,704.900000:14,70
8.300000:15,709.000000:42,711.500000:90,711.800000:119,713.100000:35,715.200000:29,718.500000:57,719.900000:52,721.50000
0:78,722.400000:29,725.400000:30,731.100000:13,731.800000:13,734.500000:36,735.300000:46,735.700000:28,738.600000:23,739
.900000:20,740.500000:81,741.800000:64,744.700000:23,745.500000:18,747.400000:23,751.100000:21,751.900000:34,755.200000:
13,756.200000:28,760.900000:21,762.800000:19,764.100000:19,767.600000:41,768.200000:75,771.200000:9,771.800000:10,773.80
0000:10,776.100000:21,777.500000:39,783.400000:39,785.100000:26,786.800000:15,788.200000:23,789.300000:14,791.700000:21,
792.600000:29,795.700000:53,796.200000:25,798.900000:13,799.400000:14,800.200000:12,800.700000:32,802.300000:25,802.8000
00:103,804.000000:26,805.200000:83,807.900000:15,808.700000:25,809.800000:36,810.900000:50,811.500000:85,812.100000:36,8
13.400000:22,814.600000:78,815.100000:52,815.900000:25,817.300000:21,821.300000:30,822.000000:9,827.800000:33,828.900000
:20,832.100000:13,834.800000:18,835.700000:25,836.600000:20,846.700000:8,851.100000:25,852.054545:66,853.200000:20,854.4
00000:28,857.000000:21,857.800000:21,859.500000:14,861.100000:17,864.500000:20,867.800000:49,868.800000:47,869.100000:19
,869.700000:22,872.900000:22,877.100000:16,880.800000:20,885.000000:21,885.800000:12,886.300000:16,888.800000:11,890.500
000:10,899.339024:41,907.800000:39,909.400000:8,911.200000:27,911.900000:9,925.900000:10,928.800000:30,930.700000:26,933
.700000:9,935.700000:13,945.100000:20,948.900000:10,953.600000:14,960.500000:14,974.100000:36,994.000000:37,1003.300000:
18,1010.200000:18,1010.800000:27,1012.100000:21,1014.000000:14,1020.100000:20,1021.000000:31,1028.900000:118,1031.000000
:18,1031.600000:40,1033.100000:14,1037.900000:55,1041.100000:17,1045.300000:13,1054.000000:92,1057.700000:19,1061.900000
:20,1069.100000:16,1083.600000:41,1093.400000:49,1098.500000:32,1099.800000:46,1102.500000:52,1103.200000:18,1104.500000
:9,1125.400000:16,1131.800000:24,1132.400000:21,1139.800000:12,1150.800000:22,1152.900000:15,1157.600000:8,1165.300000:1
4,1166.700000:11,1178.700000:25,1179.500000:23,1180.400000:25,1185.800000:12,1192.800000:18,1194.800000:12,1214.700000:3
5
ions2 :
ions3 :
peptol : 0.0
peptol units:
peptol str :
repeat srch : 1341.784350 from(671.900000,2+) title(dp210198c%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%
20%20%20%20%2021%2dJan%2d98%20DERIVED%20SPECTRUM%20%20%20%20%239) query(1)
288.2, 2137
371.127841, 1663
472.096295, 29390
567, 54690
663.1, 114500
758.2, 73560
871.2, 25390
956.1, 2241
1055, 12270
1167.994665, 17250
1215.4, 257
314.2, 1308
377.992647, 1088
501.4, 10430
584.997427, 39060
654.180103, 30060
759.3, 15570
841.9, 19170
972.292156, 1874
1056.3, 3799
1169.1, 11230
1225.2, 58
242.8, 417
377, 828
454.1, 5162
586.2, 5258
662.7, 18300
728.8, 1397
842.9, 4893
956.8, 443
1029.3, 1846
1170.2, 1280
1216.2, 51
313.9, 187
387.2, 656
473.2, 1342
568.1, 5122
663.6, 9782
729.2, 626
872.3, 4300
973.515686, 255
1100.3, 1290
1198.2, 117
1217.5, 45
243.2, 159
379.1, 231
502.4, 556
599.1, 1504
655, 1672
814.1, 277
841.2, 215
958.138974, 195
1056, 492
1196.9, 96
1226.4, 38
286.1, 83
408.2, 187
428.2, 283
614.4, 1403
710.9, 1144
730, 214
843.6, 194
1011.4, 78
1057.2, 416
1198.9, 80
1227, 20
289, 60
353.3, 136
500.7, 143
551.3, 800
665.994513, 565
757.3, 182
873.3, 166
955, 51
1101.262914, 302
1197.6, 53
1228.7, 19
253.9, 44
394, 115
426.4, 75
566.263208, 424
665.3, 563
801.8, 171
827.4, 165
1002.1, 46
1030.5, 193
1168.5, 42
290.2, 25
388.1, 63
444.1, 75
542, 399
664.6, 388
760, 160
825.2, 76
937.9, 38
1082.4, 126
1170.5, 40
287.1, 23
342.8, 48
454.9, 64
614.1, 373
644, 290
769.3, 111
902.1, 67
917.3, 37
1029.8, 125
1149.8, 38
214.8, 18
242.1, 19
252.1, 20
315.2, 44
325.8, 17
333.1, 21
347.5, 19
348.7, 13
349.5, 23
352.6, 47
359.1, 28
366, 36
367.9, 7
376.1, 14
380.1, 46
407.3, 11
410.9, 22
412.4, 31
418, 17
429.9, 57
431, 15
436.4, 11
444.9, 27
447.2, 18
453.2, 11
455.5, 33
456.1, 14
459.9, 15
461.6, 19
463.3, 7
465.6, 22
470.4, 12
470.9, 51
474.2, 44
477.1, 15
477.9, 32
483.9, 37
486.2, 20
496.9, 11
497.6, 14
499.1, 41
503.8, 24
505.4, 22
508.3, 12
508.9, 17
511.8, 19
513, 20
515, 18
517, 16
522.1, 58
523.9, 15
524.6, 78
525.3, 19
525.9, 370
526.7, 36
532.9, 11
533.5, 14
536.9, 19
538.2, 44
539.261607, 224
540.2, 39
541.1, 133
543.043902, 41
545.1, 9
545.6, 30
547.3, 23
547.9, 13
548.7, 340
549.6, 81
550.2, 41
551.7, 16
552.3, 69
555.5, 29
557.068975, 361
558.3, 54
560.1, 7
561.1, 24
563.4, 39
564.1, 101
567.6, 35
568.9, 37
569.5, 14
570, 49
571.1, 45
572.3, 76
574, 99
574.6, 22
576.3, 18
580.8, 34
582.3, 41
587.1, 131
587.9, 53
590.3, 12
591.8, 17
592.5, 18
594.8, 9
595.3, 56
596.1, 97
596.6, 62
597.1, 27
597.7, 63
600, 57
602.1, 28
603.9, 16
605.2, 69
606.8, 24
607.5, 13
608.5, 57
608.8, 12
610.2, 50
610.5, 12
611.2, 96
612.2, 24
613.2, 13
615, 194
615.6, 19
616.2, 23
618.4, 15
619.1, 31
621.1, 120
621.7, 36
622.6, 11
623.2, 43
624.1, 147
624.8, 32
626, 22
627, 53
627.9, 21
628.9, 16
629.5, 29
630.5, 14
631.4, 45
633.2, 61
635, 58
635.736413, 184
636.6, 29
637.5, 78
638.6, 14
639.8, 72
640.5, 51
641.1, 33
641.7, 40
642.4, 121
642.8, 170
643.3, 57
644.6, 48
645.7, 36
646.5, 39
647.4, 28
648.5, 30
649.5, 108
650, 13
650.6, 43
651.8, 107
652.3, 33
652.9, 33
656.3, 178
657.1, 78
658.2, 19
658.8, 76
660.590741, 108
661.9, 216
667, 193
677.3, 8
680.5, 13
683.5, 38
684.5, 28
685.5, 24
686.2, 13
687.275862, 87
688.2, 28
688.9, 28
689.4, 50
691.5, 28
692.7, 25
693.2, 15
694, 31
697.1, 8
698.3, 42
700.3, 17
700.9, 21
703.5, 39
704.2, 20
704.9, 14
708.3, 15
709, 42
711.5, 90
711.8, 119
713.1, 35
715.2, 29
718.5, 57
719.9, 52
721.5, 78
722.4, 29
725.4, 30
731.1, 13
731.8, 13
734.5, 36
735.3, 46
735.7, 28
738.6, 23
739.9, 20
740.5, 81
741.8, 64
744.7, 23
745.5, 18
747.4, 23
751.1, 21
751.9, 34
755.2, 13
756.2, 28
760.9, 21
762.8, 19
764.1, 19
767.6, 41
768.2, 75
771.2, 9
771.8, 10
773.8, 10
776.1, 21
777.5, 39
783.4, 39
785.1, 26
786.8, 15
788.2, 23
789.3, 14
791.7, 21
792.6, 29
795.7, 53
796.2, 25
798.9, 13
799.4, 14
800.2, 12
800.7, 32
802.3, 25
802.8, 103
804, 26
805.2, 83
807.9, 15
808.7, 25
809.8, 36
810.9, 50
811.5, 85
812.1, 36
813.4, 22
814.6, 78
815.1, 52
815.9, 25
817.3, 21
821.3, 30
822, 9
827.8, 33
828.9, 20
832.1, 13
834.8, 18
835.7, 25
836.6, 20
846.7, 8
851.1, 25
852.054545, 66
853.2, 20
854.4, 28
857, 21
857.8, 21
859.5, 14
861.1, 17
864.5, 20
867.8, 49
868.8, 47
869.1, 19
869.7, 22
872.9, 22
877.1, 16
880.8, 20
885, 21
885.8, 12
886.3, 16
888.8, 11
890.5, 10
899.339024, 41
907.8, 39
909.4, 8
911.2, 27
911.9, 9
925.9, 10
928.8, 30
930.7, 26
933.7, 9
935.7, 13
945.1, 20
948.9, 10
953.6, 14
960.5, 14
974.1, 36
994, 37
1003.3, 18
1010.2, 18
1010.8, 27
1012.1, 21
1014, 14
1020.1, 20
1021, 31
1028.9, 118
1031, 18
1031.6, 40
1033.1, 14
1037.9, 55
1041.1, 17
1045.3, 13
1054, 92
1057.7, 19
1061.9, 20
1069.1, 16
1083.6, 41
1093.4, 49
1098.5, 32
1099.8, 46
1102.5, 52
1103.2, 18
1104.5, 9
1125.4, 16
1131.8, 24
1132.4, 21
1139.8, 12
1150.8, 22
1152.9, 15
1157.6, 8
1165.3, 14
1166.7, 11
1178.7, 25
1179.5, 23
1180.4, 25
1185.8, 12
1192.8, 18
1194.8, 12
1214.7, 35
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_input.py

resfile_input.py

Example program for retrieving input spectrum data.

1#!/usr/bin/python
2
17
18import msparser
19import sys
20
21def main() :
22 if len(sys.argv) < 2 :
23 print("Must specify results filename as parameter")
24 return 1
25
26 resfile = msparser.ms_mascotresfilebase.createResfile(sys.argv[1])
27
28 if resfile.isValid() :
29 inputData(resfile)
30
31
32def inputData(resfile) :
33 # display input data via inputquery get functions
34 for i in range(1, 2) :
35 # replace range with (1, 1 + resfile.getNumQueries()) to get all input
36 # data.
37
38 print("Input data for query number %d" % i)
39 print("=========================================")
40
41 q = msparser.ms_inputquery(resfile, i)
42 fmt = " %-16s: %s"
43
44 print(fmt % ("title" , q.getStringTitle(True)))
45 print(fmt % ("mass_min" , q.getMassMin()))
46 print(fmt % ("mass_max" , q.getMassMax()))
47 print(fmt % ("int_min" , q.getIntMin()))
48 print(fmt % ("int_max" , q.getIntMax()))
49 print(fmt % ("num_vals" , q.getNumVals()))
50 print(fmt % ("num_used1" , q.getNumUsed()))
51 print(fmt % ("ions1" , q.getStringIons1()))
52 print(fmt % ("ions2" , q.getStringIons2()))
53 print(fmt % ("ions3" , q.getStringIons3()))
54 print(fmt % ("peptol" , q.getPepTol()))
55 print(fmt % ("peptol units", q.getPepTolUnits()))
56 print(fmt % ("peptol str" , q.getPepTolString()))
57 print(fmt % ("repeat srch" , resfile.getRepeatSearchString(i)))
58
59 num_peaks = q.getNumberOfPeaks(1)
60 for j in range (1, 1+ num_peaks) :
61 print("%f, %f" % (q.getPeakMass(1, j), q.getPeakIntensity(1, j)))
62
63 print(" ")
64
65
66
67if __name__ == "__main__" :
68 sys.exit(main())
69
70
71"""
72
73Running the program as
74
75python resfile_input.pl F981123.dat
76
77will give the following output under Mascot Server 2.3:
78
79
80Input data for query number 1
81=========================================
82 title :
83 mass_min : 72.09
84 mass_max : 1711.52
85 int_min : 1.103
86 int_max : 80.7
87 num_vals : 425
88 num_used1 : 0
89 ions1 : 157.096962:23.72,185.160000:26.69,286.134951:80.7,385.210000:13.49,480.270000:4.363,129.102412:18.84,187.070000:22.51,354.189124:13.57,399.246727:9.489,482.140542:3.205,130.110251:9.257,258.132661:15.93,357.210000:13.57,443.810000:6.256,481.210000:3.182,136.070000:7.387,213.139215:13.84,371.204929:11.24,459.280000:6.216,489.233770:3.157,147.117662:6.333,229.120000:9.72,326.133204:5.268,423.125582:4.262,483.115000:2.205,159.080000:5.222,240.130000:7.562,298.110000:5.231,444.168974:3.247,474.300000:1.103,158.090000:4.301,270.180000:7.432,324.170000:5.17,411.200000:3.23,475.270000:1.103,86.110000:3.276,175.110000:7.308,312.150879:4.235,463.265712:3.205,476.700000:1.103,102.060000:3.276,241.085275:5.361,293.110000:4.178,445.810000:3.182,478.180000:1.103,115.088725:3.255,243.139772:4.378,353.155308:4.149,401.150000:3.138,486.880000:1.103,72.090000:2.174,76.400000:1.103,84.075000:2.111,87.110000:1.103,88.100000:1.103,98.060000:1.103,103.060000:1.103,105.070000:1.103,116.070000:1.103,117.110000:1.103,118.400000:1.103,120.090000:2.205,126.070000:1.103,127.090000:1.103,128.090000:2.103,131.085000:2.118,132.090000:1.103,135.800000:1.103,137.080000:1.103,138.070000:1.103,139.090000:1.103,140.150000:2.174,141.060000:2.174,143.120000:2.174,146.080000:1.103,152.060000:1.103,155.070000:2.205,156.100000:1.103,159.450000:1.103,165.080000:2.136,166.110000:1.103,167.110000:1.103,169.710000:1.103,170.450000:1.103,171.090000:1.103,173.120000:2.174,177.090000:1.103,178.080000:1.103,181.160000:1.103,182.030000:1.103,183.110000:2.174,183.930000:1.103,186.131024:4.374,188.070000:1.103,188.760000:1.103,189.070000:1.103,190.065000:2.103,191.300000:1.103,197.130000:1.103,199.180000:1.103,200.080000:1.103,201.100000:3.138,202.110000:2.091,203.080000:2.174,203.610000:1.103,211.140000:4.189,212.115000:2.103,212.490000:1.103,214.985000:2.205,216.110000:2.103,217.100000:1.103,218.080000:1.103,219.090000:2.103,223.090000:3.154,224.130000:1.103,225.130000:1.103,227.170000:1.103,227.880000:1.103,228.170000:2.136,229.760000:1.103,231.950000:1.103,233.130000:1.103,234.430000:1.103,235.080000:2.103,236.590000:1.103,238.080000:4.332,239.139997:3.131,242.170000:2.205,244.090000:2.136,244.430000:2.091,245.165685:3.205,246.160000:2.197,247.110000:2.102,248.145000:2.118,249.110000:2.136,250.080000:1.103,251.160000:1.103,253.100000:1.103,254.130000:1.103,255.165000:2.22,256.170000:1.103,257.060000:1.103,259.150000:2.197,260.000000:1.103,260.490000:1.103,262.110000:1.103,265.120000:1.103,266.130000:2.159,266.950000:1.103,267.210000:1.103,268.120000:3.214,269.090000:1.103,271.150000:2.136,272.170000:2.103,274.120000:1.103,275.030000:1.103,276.175000:2.22,278.190000:1.103,279.720000:2.205,281.120000:1.103,283.070000:1.103,284.110000:1.103,285.070000:1.103,287.140000:3.296,287.780000:1.103,288.090000:2.103,290.130000:1.103,294.110000:2.174,295.150000:3.114,295.730000:1.103,297.180000:2.136,300.160000:3.143,302.070000:1.103,303.160000:1.103,303.590000:1.103,304.600000:1.103,305.130000:1.103,306.140000:3.182,307.050000:1.103,308.150000:2.174,308.490000:1.103,312.610000:1.103,312.880000:1.103,314.120000:1.103,316.085000:2.111,317.150000:3.183,318.140000:1.103,320.140000:1.103,322.149731:3.255,323.034482:3.149,327.020000:1.103,328.020000:1.103,331.140000:2.091,332.165000:2.103,333.140000:1.103,335.500000:1.103,336.190000:1.103,337.030000:2.118,338.620000:1.103,338.940000:1.103,339.200000:3.261,341.210000:2.103,342.180000:1.103,342.800000:1.103,343.225000:2.111,343.800000:1.103,344.150000:2.174,346.010000:1.103,347.660000:1.103,348.200000:2.197,349.800000:1.103,350.110000:2.118,351.130000:3.276,352.130000:2.136,353.910000:1.103,354.470000:1.103,355.193955:3.376,358.200000:1.103,359.210000:2.174,359.910000:1.103,360.470000:1.103,361.080000:1.103,362.190000:1.103,363.040000:1.103,364.080000:1.103,366.120000:1.103,367.150000:1.103,368.330000:1.103,368.730000:1.103,369.230000:3.15,369.820000:1.103,370.177065:3.279,373.130000:2.197,374.055000:2.217,374.510000:2.205,376.040000:1.103,377.040000:1.103,380.160000:2.103,382.180000:3.102,383.115000:2.209,385.890000:2.205,386.370000:1.103,387.170000:3.114,387.680000:2.217,388.050000:1.103,389.620000:1.103,390.190000:1.103,390.610000:1.103,394.260000:1.103,395.180000:1.103,396.140000:2.205,397.980000:1.103,400.165000:2.209,403.210000:1.103,404.150000:1.103,404.470000:1.103,410.165000:2.111,411.550000:1.103,413.240000:1.103,414.080000:1.103,415.000000:1.103,416.190000:1.103,416.830000:1.103,417.230000:1.103,417.760000:1.103,418.285000:2.111,418.680000:1.103,420.650000:1.103,421.170000:2.136,422.580000:1.103,425.215000:2.103,425.690000:1.103,426.220000:3.125,428.140000:2.155,428.650000:1.103,430.260000:1.103,430.995000:2.205,433.200000:1.103,433.690000:1.103,435.000000:1.103,435.260000:1.103,437.180000:1.103,438.710000:2.174,439.230000:1.103,440.210000:1.103,442.190000:1.103,443.120000:1.103,444.680000:1.103,445.120000:1.103,449.110000:1.103,450.710000:1.103,452.150000:2.209,453.240000:3.12,454.200000:1.103,454.700000:1.103,458.310000:1.103,460.290000:1.103,461.250000:1.103,461.830000:1.103,462.195000:2.103,463.850000:1.103,464.250000:1.103,467.180000:2.174,470.210000:1.103,471.120000:1.103,489.700000:1.103,493.200000:1.103,494.200000:1.103,505.200000:1.103,508.170000:2.197,508.840000:1.103,509.200000:2.103,511.450000:1.103,522.170000:2.197,523.190000:1.103,524.150000:2.174,527.160000:1.103,528.410000:2.19,529.280000:1.103,530.230000:1.103,531.250000:1.103,533.130000:1.103,533.670000:1.103,536.720000:1.103,537.240000:1.103,538.080000:1.103,538.450000:1.103,540.220000:1.103,545.210000:2.174,545.490000:1.103,546.250000:1.103,547.350000:1.103,550.750000:2.205,558.070000:1.103,561.360000:1.103,562.200000:1.103,563.330000:1.103,568.230000:1.103,571.290000:3.136,573.010000:1.103,575.410000:1.103,580.240000:1.103,581.260000:1.103,585.160000:1.103,588.380000:1.103,590.120000:1.103,599.450000:1.103,605.210000:2.197,607.285000:4.499,608.270000:3.143,613.330000:2.103,614.330000:1.103,617.320000:1.103,621.230000:1.103,622.310000:1.103,625.320000:3.23,626.210000:1.103,633.275000:2.205,640.350000:1.103,642.220000:1.103,644.280000:1.103,646.250000:1.103,648.390000:1.103,651.335000:2.103,653.360000:2.136,658.300000:1.103,662.320000:1.103,663.800000:1.103,668.275000:2.209,674.370000:1.103,676.090000:1.103,677.350000:1.103,678.070000:1.103,683.370000:1.103,684.920000:1.103,685.380000:2.091,686.390000:1.103,701.410000:1.103,702.380000:7.387,703.420000:3.12,707.360000:1.103,713.340000:1.103,718.370000:2.197,720.400000:1.103,724.180000:1.103,728.390000:1.103,734.380000:1.103,735.430000:1.103,736.360000:1.103,737.310000:1.103,741.070000:1.103,745.480000:1.103,747.290000:1.103,748.320000:1.103,754.358237:6.383,755.370000:2.136,760.490000:1.103,765.360000:1.103,767.500000:1.103,770.370000:1.103,775.230000:1.103,778.490000:1.103,792.360000:1.103,796.420000:1.103,801.380000:1.103,814.390000:2.118,815.390000:1.103,816.410000:1.103,820.470000:1.103,825.350000:1.103,841.510000:1.103,848.450000:1.103,883.450000:1.103,884.470000:1.103,896.410000:1.103,907.420000:1.103,908.430000:1.103,916.380000:1.103,1074.300000:1.103,1092.600000:1.103,1164.300000:1.103,1231.540000:1.103,1397.690000:1.103,1660.400000:1.103,1711.520000:1.103
90 ions2 :
91 ions3 :
92 peptol : 0.0
93 peptol units :
94 peptol str :
95 repeat srch : 497.265612 from(498.272888,1+) query(1)
96157.096962, 23.720000
97185.160000, 26.690000
98286.134951, 80.700000
99385.210000, 13.490000
100480.270000, 4.363000
101129.102412, 18.840000
102187.070000, 22.510000
103354.189124, 13.570000
104399.246727, 9.489000
105482.140542, 3.205000
106130.110251, 9.257000
107258.132661, 15.930000
108357.210000, 13.570000
109443.810000, 6.256000
110481.210000, 3.182000
111136.070000, 7.387000
112213.139215, 13.840000
113371.204929, 11.240000
114459.280000, 6.216000
115489.233770, 3.157000
116147.117662, 6.333000
117229.120000, 9.720000
118326.133204, 5.268000
119423.125582, 4.262000
120483.115000, 2.205000
121159.080000, 5.222000
122240.130000, 7.562000
123298.110000, 5.231000
124444.168974, 3.247000
125474.300000, 1.103000
126158.090000, 4.301000
127270.180000, 7.432000
128324.170000, 5.170000
129411.200000, 3.230000
130475.270000, 1.103000
13186.110000, 3.276000
132175.110000, 7.308000
133312.150879, 4.235000
134463.265712, 3.205000
135476.700000, 1.103000
136102.060000, 3.276000
137241.085275, 5.361000
138293.110000, 4.178000
139445.810000, 3.182000
140478.180000, 1.103000
141115.088725, 3.255000
142243.139772, 4.378000
143353.155308, 4.149000
144401.150000, 3.138000
145486.880000, 1.103000
14672.090000, 2.174000
14776.400000, 1.103000
14884.075000, 2.111000
14987.110000, 1.103000
15088.100000, 1.103000
15198.060000, 1.103000
152103.060000, 1.103000
153105.070000, 1.103000
154116.070000, 1.103000
155117.110000, 1.103000
156118.400000, 1.103000
157120.090000, 2.205000
158126.070000, 1.103000
159127.090000, 1.103000
160128.090000, 2.103000
161131.085000, 2.118000
162132.090000, 1.103000
163135.800000, 1.103000
164137.080000, 1.103000
165138.070000, 1.103000
166139.090000, 1.103000
167140.150000, 2.174000
168141.060000, 2.174000
169143.120000, 2.174000
170146.080000, 1.103000
171152.060000, 1.103000
172155.070000, 2.205000
173156.100000, 1.103000
174159.450000, 1.103000
175165.080000, 2.136000
176166.110000, 1.103000
177167.110000, 1.103000
178169.710000, 1.103000
179170.450000, 1.103000
180171.090000, 1.103000
181173.120000, 2.174000
182177.090000, 1.103000
183178.080000, 1.103000
184181.160000, 1.103000
185182.030000, 1.103000
186183.110000, 2.174000
187183.930000, 1.103000
188186.131024, 4.374000
189188.070000, 1.103000
190188.760000, 1.103000
191189.070000, 1.103000
192190.065000, 2.103000
193191.300000, 1.103000
194197.130000, 1.103000
195199.180000, 1.103000
196200.080000, 1.103000
197201.100000, 3.138000
198202.110000, 2.091000
199203.080000, 2.174000
200203.610000, 1.103000
201211.140000, 4.189000
202212.115000, 2.103000
203212.490000, 1.103000
204214.985000, 2.205000
205216.110000, 2.103000
206217.100000, 1.103000
207218.080000, 1.103000
208219.090000, 2.103000
209223.090000, 3.154000
210224.130000, 1.103000
211225.130000, 1.103000
212227.170000, 1.103000
213227.880000, 1.103000
214228.170000, 2.136000
215229.760000, 1.103000
216231.950000, 1.103000
217233.130000, 1.103000
218234.430000, 1.103000
219235.080000, 2.103000
220236.590000, 1.103000
221238.080000, 4.332000
222239.139997, 3.131000
223242.170000, 2.205000
224244.090000, 2.136000
225244.430000, 2.091000
226245.165685, 3.205000
227246.160000, 2.197000
228247.110000, 2.102000
229248.145000, 2.118000
230249.110000, 2.136000
231250.080000, 1.103000
232251.160000, 1.103000
233253.100000, 1.103000
234254.130000, 1.103000
235255.165000, 2.220000
236256.170000, 1.103000
237257.060000, 1.103000
238259.150000, 2.197000
239260.000000, 1.103000
240260.490000, 1.103000
241262.110000, 1.103000
242265.120000, 1.103000
243266.130000, 2.159000
244266.950000, 1.103000
245267.210000, 1.103000
246268.120000, 3.214000
247269.090000, 1.103000
248271.150000, 2.136000
249272.170000, 2.103000
250274.120000, 1.103000
251275.030000, 1.103000
252276.175000, 2.220000
253278.190000, 1.103000
254279.720000, 2.205000
255281.120000, 1.103000
256283.070000, 1.103000
257284.110000, 1.103000
258285.070000, 1.103000
259287.140000, 3.296000
260287.780000, 1.103000
261288.090000, 2.103000
262290.130000, 1.103000
263294.110000, 2.174000
264295.150000, 3.114000
265295.730000, 1.103000
266297.180000, 2.136000
267300.160000, 3.143000
268302.070000, 1.103000
269303.160000, 1.103000
270303.590000, 1.103000
271304.600000, 1.103000
272305.130000, 1.103000
273306.140000, 3.182000
274307.050000, 1.103000
275308.150000, 2.174000
276308.490000, 1.103000
277312.610000, 1.103000
278312.880000, 1.103000
279314.120000, 1.103000
280316.085000, 2.111000
281317.150000, 3.183000
282318.140000, 1.103000
283320.140000, 1.103000
284322.149731, 3.255000
285323.034482, 3.149000
286327.020000, 1.103000
287328.020000, 1.103000
288331.140000, 2.091000
289332.165000, 2.103000
290333.140000, 1.103000
291335.500000, 1.103000
292336.190000, 1.103000
293337.030000, 2.118000
294338.620000, 1.103000
295338.940000, 1.103000
296339.200000, 3.261000
297341.210000, 2.103000
298342.180000, 1.103000
299342.800000, 1.103000
300343.225000, 2.111000
301343.800000, 1.103000
302344.150000, 2.174000
303346.010000, 1.103000
304347.660000, 1.103000
305348.200000, 2.197000
306349.800000, 1.103000
307350.110000, 2.118000
308351.130000, 3.276000
309352.130000, 2.136000
310353.910000, 1.103000
311354.470000, 1.103000
312355.193955, 3.376000
313358.200000, 1.103000
314359.210000, 2.174000
315359.910000, 1.103000
316360.470000, 1.103000
317361.080000, 1.103000
318362.190000, 1.103000
319363.040000, 1.103000
320364.080000, 1.103000
321366.120000, 1.103000
322367.150000, 1.103000
323368.330000, 1.103000
324368.730000, 1.103000
325369.230000, 3.150000
326369.820000, 1.103000
327370.177065, 3.279000
328373.130000, 2.197000
329374.055000, 2.217000
330374.510000, 2.205000
331376.040000, 1.103000
332377.040000, 1.103000
333380.160000, 2.103000
334382.180000, 3.102000
335383.115000, 2.209000
336385.890000, 2.205000
337386.370000, 1.103000
338387.170000, 3.114000
339387.680000, 2.217000
340388.050000, 1.103000
341389.620000, 1.103000
342390.190000, 1.103000
343390.610000, 1.103000
344394.260000, 1.103000
345395.180000, 1.103000
346396.140000, 2.205000
347397.980000, 1.103000
348400.165000, 2.209000
349403.210000, 1.103000
350404.150000, 1.103000
351404.470000, 1.103000
352410.165000, 2.111000
353411.550000, 1.103000
354413.240000, 1.103000
355414.080000, 1.103000
356415.000000, 1.103000
357416.190000, 1.103000
358416.830000, 1.103000
359417.230000, 1.103000
360417.760000, 1.103000
361418.285000, 2.111000
362418.680000, 1.103000
363420.650000, 1.103000
364421.170000, 2.136000
365422.580000, 1.103000
366425.215000, 2.103000
367425.690000, 1.103000
368426.220000, 3.125000
369428.140000, 2.155000
370428.650000, 1.103000
371430.260000, 1.103000
372430.995000, 2.205000
373433.200000, 1.103000
374433.690000, 1.103000
375435.000000, 1.103000
376435.260000, 1.103000
377437.180000, 1.103000
378438.710000, 2.174000
379439.230000, 1.103000
380440.210000, 1.103000
381442.190000, 1.103000
382443.120000, 1.103000
383444.680000, 1.103000
384445.120000, 1.103000
385449.110000, 1.103000
386450.710000, 1.103000
387452.150000, 2.209000
388453.240000, 3.120000
389454.200000, 1.103000
390454.700000, 1.103000
391458.310000, 1.103000
392460.290000, 1.103000
393461.250000, 1.103000
394461.830000, 1.103000
395462.195000, 2.103000
396463.850000, 1.103000
397464.250000, 1.103000
398467.180000, 2.174000
399470.210000, 1.103000
400471.120000, 1.103000
401489.700000, 1.103000
402493.200000, 1.103000
403494.200000, 1.103000
404505.200000, 1.103000
405508.170000, 2.197000
406508.840000, 1.103000
407509.200000, 2.103000
408511.450000, 1.103000
409522.170000, 2.197000
410523.190000, 1.103000
411524.150000, 2.174000
412527.160000, 1.103000
413528.410000, 2.190000
414529.280000, 1.103000
415530.230000, 1.103000
416531.250000, 1.103000
417533.130000, 1.103000
418533.670000, 1.103000
419536.720000, 1.103000
420537.240000, 1.103000
421538.080000, 1.103000
422538.450000, 1.103000
423540.220000, 1.103000
424545.210000, 2.174000
425545.490000, 1.103000
426546.250000, 1.103000
427547.350000, 1.103000
428550.750000, 2.205000
429558.070000, 1.103000
430561.360000, 1.103000
431562.200000, 1.103000
432563.330000, 1.103000
433568.230000, 1.103000
434571.290000, 3.136000
435573.010000, 1.103000
436575.410000, 1.103000
437580.240000, 1.103000
438581.260000, 1.103000
439585.160000, 1.103000
440588.380000, 1.103000
441590.120000, 1.103000
442599.450000, 1.103000
443605.210000, 2.197000
444607.285000, 4.499000
445608.270000, 3.143000
446613.330000, 2.103000
447614.330000, 1.103000
448617.320000, 1.103000
449621.230000, 1.103000
450622.310000, 1.103000
451625.320000, 3.230000
452626.210000, 1.103000
453633.275000, 2.205000
454640.350000, 1.103000
455642.220000, 1.103000
456644.280000, 1.103000
457646.250000, 1.103000
458648.390000, 1.103000
459651.335000, 2.103000
460653.360000, 2.136000
461658.300000, 1.103000
462662.320000, 1.103000
463663.800000, 1.103000
464668.275000, 2.209000
465674.370000, 1.103000
466676.090000, 1.103000
467677.350000, 1.103000
468678.070000, 1.103000
469683.370000, 1.103000
470684.920000, 1.103000
471685.380000, 2.091000
472686.390000, 1.103000
473701.410000, 1.103000
474702.380000, 7.387000
475703.420000, 3.120000
476707.360000, 1.103000
477713.340000, 1.103000
478718.370000, 2.197000
479720.400000, 1.103000
480724.180000, 1.103000
481728.390000, 1.103000
482734.380000, 1.103000
483735.430000, 1.103000
484736.360000, 1.103000
485737.310000, 1.103000
486741.070000, 1.103000
487745.480000, 1.103000
488747.290000, 1.103000
489748.320000, 1.103000
490754.358237, 6.383000
491755.370000, 2.136000
492760.490000, 1.103000
493765.360000, 1.103000
494767.500000, 1.103000
495770.370000, 1.103000
496775.230000, 1.103000
497778.490000, 1.103000
498792.360000, 1.103000
499796.420000, 1.103000
500801.380000, 1.103000
501814.390000, 2.118000
502815.390000, 1.103000
503816.410000, 1.103000
504820.470000, 1.103000
505825.350000, 1.103000
506841.510000, 1.103000
507848.450000, 1.103000
508883.450000, 1.103000
509884.470000, 1.103000
510896.410000, 1.103000
511907.420000, 1.103000
512908.430000, 1.103000
513916.380000, 1.103000
5141074.300000, 1.103000
5151092.600000, 1.103000
5161164.300000, 1.103000
5171231.540000, 1.103000
5181397.690000, 1.103000
5191660.400000, 1.103000
5201711.520000, 1.103000
521
522
523"""
524
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_input.cs

resfile_input.cs

Example program for retrieving input spectrum data.

/*
##############################################################################
# file: resfile_input.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/resfile_input.cs $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class resfile_input
{
public static void Main(string[] argv)
{
// ----- Object creation -----
if (argv.Length < 1)
{
Console.WriteLine("Must specify results filename as parameter");
return;
}
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(argv[0], 0, "");
if (file.isValid())
{
inputData(file);
}
else
{
Console.WriteLine("Error number: {0}", file.getLastError());
Console.WriteLine("Error string: {0}", file.getLastErrorString());
return;
}
}
private static void inputData(ms_mascotresfilebase file)
{
int i, j, num_peaks;
// display input data via inputquery get functions
for (i = 1; i <= 1; i++)
{
Console.WriteLine("Input data for query number {0}", i);
Console.WriteLine("=========================================");
ms_inputquery q = new ms_inputquery(file, i);
Console.WriteLine(" title : {0}", q.getStringTitle(true));
Console.WriteLine(" mass_min : {0}", q.getMassMin());
Console.WriteLine(" mass_max : {0}", q.getMassMax());
Console.WriteLine(" int_min : {0}", q.getIntMin());
Console.WriteLine(" int_max : {0}", q.getIntMax());
Console.WriteLine(" num_vals : {0}", q.getNumVals());
Console.WriteLine(" num_used1 : {0}", q.getNumUsed());
Console.WriteLine(" ions1 : {0}", q.getStringIons1());
Console.WriteLine(" ions2 : {0}", q.getStringIons2());
Console.WriteLine(" ions3 : {0}", q.getStringIons3());
Console.WriteLine(" peptol : {0}", q.getPepTol());
Console.WriteLine(" peptol units: {0}", q.getPepTolUnits());
Console.WriteLine(" peptol str : {0}", q.getPepTolString());
Console.WriteLine(" INSTRUMENT : {0}", q.getINSTRUMENT());
Console.WriteLine(" RULES : {0}", q.getRULES());
Console.WriteLine(" IT_MODS : {0}", q.getIT_MODS());
Console.WriteLine(" repeat srch : {0}", file.getRepeatSearchString(i));
num_peaks = q.getNumberOfPeaks(1);
for (j = 1; j <= num_peaks; j++)
{
Console.WriteLine("{0:#}, {1:#}",q.getPeakMass(1,j), q.getPeakIntensity(1,j));
}
}
}
}
}
/*
resfile_input.exe c:\inetpub\mascot\data\F981123.dat >resfile_input_output.txt
Will give the following output:
Input data for query number 1
=========================================
title :
mass_min : 72.09
mass_max : 1711.52
int_min : 1.103
int_max : 80.7
num_vals : 425
num_used1 : 0
ions1 : 157.096962:23.72,185.160000:26.69,286.134951:80.7,385.210000:13.49,480.270000:4.363,129.102412:18.84,187.070000:22.51,354.189124:13.57,399.246727:9.489,482.140542:3.205,130.110251:9.257,258.132661:15.93,357.210000:13.57,443.810000:6.256,481.210000:3.182,136.070000:7.387,213.139215:13.84,371.204929:11.24,459.280000:6.216,489.233770:3.157,147.117662:6.333,229.120000:9.72,326.133204:5.268,423.125582:4.262,483.115000:2.205,159.080000:5.222,240.130000:7.562,298.110000:5.231,444.168974:3.247,474.300000:1.103,158.090000:4.301,270.180000:7.432,324.170000:5.17,411.200000:3.23,475.270000:1.103,86.110000:3.276,175.110000:7.308,312.150879:4.235,463.265712:3.205,476.700000:1.103,102.060000:3.276,241.085275:5.361,293.110000:4.178,445.810000:3.182,478.180000:1.103,115.088725:3.255,243.139772:4.378,353.155308:4.149,401.150000:3.138,486.880000:1.103,72.090000:2.174,76.400000:1.103,84.075000:2.111,87.110000:1.103,88.100000:1.103,98.060000:1.103,103.060000:1.103,105.070000:1.103,116.070000:1.103,117.110000:1.103,118.400000:1.103,120.090000:2.205,126.070000:1.103,127.090000:1.103,128.090000:2.103,131.085000:2.118,132.090000:1.103,135.800000:1.103,137.080000:1.103,138.070000:1.103,139.090000:1.103,140.150000:2.174,141.060000:2.174,143.120000:2.174,146.080000:1.103,152.060000:1.103,155.070000:2.205,156.100000:1.103,159.450000:1.103,165.080000:2.136,166.110000:1.103,167.110000:1.103,169.710000:1.103,170.450000:1.103,171.090000:1.103,173.120000:2.174,177.090000:1.103,178.080000:1.103,181.160000:1.103,182.030000:1.103,183.110000:2.174,183.930000:1.103,186.131024:4.374,188.070000:1.103,188.760000:1.103,189.070000:1.103,190.065000:2.103,191.300000:1.103,197.130000:1.103,199.180000:1.103,200.080000:1.103,201.100000:3.138,202.110000:2.091,203.080000:2.174,203.610000:1.103,211.140000:4.189,212.115000:2.103,212.490000:1.103,214.985000:2.205,216.110000:2.103,217.100000:1.103,218.080000:1.103,219.090000:2.103,223.090000:3.154,224.130000:1.103,225.130000:1.103,227.170000:1.103,227.880000:1.103,228.170000:2.136,229.760000:1.103,231.950000:1.103,233.130000:1.103,234.430000:1.103,235.080000:2.103,236.590000:1.103,238.080000:4.332,239.139997:3.131,242.170000:2.205,244.090000:2.136,244.430000:2.091,245.165685:3.205,246.160000:2.197,247.110000:2.102,248.145000:2.118,249.110000:2.136,250.080000:1.103,251.160000:1.103,253.100000:1.103,254.130000:1.103,255.165000:2.22,256.170000:1.103,257.060000:1.103,259.150000:2.197,260.000000:1.103,260.490000:1.103,262.110000:1.103,265.120000:1.103,266.130000:2.159,266.950000:1.103,267.210000:1.103,268.120000:3.214,269.090000:1.103,271.150000:2.136,272.170000:2.103,274.120000:1.103,275.030000:1.103,276.175000:2.22,278.190000:1.103,279.720000:2.205,281.120000:1.103,283.070000:1.103,284.110000:1.103,285.070000:1.103,287.140000:3.296,287.780000:1.103,288.090000:2.103,290.130000:1.103,294.110000:2.174,295.150000:3.114,295.730000:1.103,297.180000:2.136,300.160000:3.143,302.070000:1.103,303.160000:1.103,303.590000:1.103,304.600000:1.103,305.130000:1.103,306.140000:3.182,307.050000:1.103,308.150000:2.174,308.490000:1.103,312.610000:1.103,312.880000:1.103,314.120000:1.103,316.085000:2.111,317.150000:3.183,318.140000:1.103,320.140000:1.103,322.149731:3.255,323.034482:3.149,327.020000:1.103,328.020000:1.103,331.140000:2.091,332.165000:2.103,333.140000:1.103,335.500000:1.103,336.190000:1.103,337.030000:2.118,338.620000:1.103,338.940000:1.103,339.200000:3.261,341.210000:2.103,342.180000:1.103,342.800000:1.103,343.225000:2.111,343.800000:1.103,344.150000:2.174,346.010000:1.103,347.660000:1.103,348.200000:2.197,349.800000:1.103,350.110000:2.118,351.130000:3.276,352.130000:2.136,353.910000:1.103,354.470000:1.103,355.193955:3.376,358.200000:1.103,359.210000:2.174,359.910000:1.103,360.470000:1.103,361.080000:1.103,362.190000:1.103,363.040000:1.103,364.080000:1.103,366.120000:1.103,367.150000:1.103,368.330000:1.103,368.730000:1.103,369.230000:3.15,369.820000:1.103,370.177065:3.279,373.130000:2.197,374.055000:2.217,374.510000:2.205,376.040000:1.103,377.040000:1.103,380.160000:2.103,382.180000:3.102,383.115000:2.209,385.890000:2.205,386.370000:1.103,387.170000:3.114,387.680000:2.217,388.050000:1.103,389.620000:1.103,390.190000:1.103,390.610000:1.103,394.260000:1.103,395.180000:1.103,396.140000:2.205,397.980000:1.103,400.165000:2.209,403.210000:1.103,404.150000:1.103,404.470000:1.103,410.165000:2.111,411.550000:1.103,413.240000:1.103,414.080000:1.103,415.000000:1.103,416.190000:1.103,416.830000:1.103,417.230000:1.103,417.760000:1.103,418.285000:2.111,418.680000:1.103,420.650000:1.103,421.170000:2.136,422.580000:1.103,425.215000:2.103,425.690000:1.103,426.220000:3.125,428.140000:2.155,428.650000:1.103,430.260000:1.103,430.995000:2.205,433.200000:1.103,433.690000:1.103,435.000000:1.103,435.260000:1.103,437.180000:1.103,438.710000:2.174,439.230000:1.103,440.210000:1.103,442.190000:1.103,443.120000:1.103,444.680000:1.103,445.120000:1.103,449.110000:1.103,450.710000:1.103,452.150000:2.209,453.240000:3.12,454.200000:1.103,454.700000:1.103,458.310000:1.103,460.290000:1.103,461.250000:1.103,461.830000:1.103,462.195000:2.103,463.850000:1.103,464.250000:1.103,467.180000:2.174,470.210000:1.103,471.120000:1.103,489.700000:1.103,493.200000:1.103,494.200000:1.103,505.200000:1.103,508.170000:2.197,508.840000:1.103,509.200000:2.103,511.450000:1.103,522.170000:2.197,523.190000:1.103,524.150000:2.174,527.160000:1.103,528.410000:2.19,529.280000:1.103,530.230000:1.103,531.250000:1.103,533.130000:1.103,533.670000:1.103,536.720000:1.103,537.240000:1.103,538.080000:1.103,538.450000:1.103,540.220000:1.103,545.210000:2.174,545.490000:1.103,546.250000:1.103,547.350000:1.103,550.750000:2.205,558.070000:1.103,561.360000:1.103,562.200000:1.103,563.330000:1.103,568.230000:1.103,571.290000:3.136,573.010000:1.103,575.410000:1.103,580.240000:1.103,581.260000:1.103,585.160000:1.103,588.380000:1.103,590.120000:1.103,599.450000:1.103,605.210000:2.197,607.285000:4.499,608.270000:3.143,613.330000:2.103,614.330000:1.103,617.320000:1.103,621.230000:1.103,622.310000:1.103,625.320000:3.23,626.210000:1.103,633.275000:2.205,640.350000:1.103,642.220000:1.103,644.280000:1.103,646.250000:1.103,648.390000:1.103,651.335000:2.103,653.360000:2.136,658.300000:1.103,662.320000:1.103,663.800000:1.103,668.275000:2.209,674.370000:1.103,676.090000:1.103,677.350000:1.103,678.070000:1.103,683.370000:1.103,684.920000:1.103,685.380000:2.091,686.390000:1.103,701.410000:1.103,702.380000:7.387,703.420000:3.12,707.360000:1.103,713.340000:1.103,718.370000:2.197,720.400000:1.103,724.180000:1.103,728.390000:1.103,734.380000:1.103,735.430000:1.103,736.360000:1.103,737.310000:1.103,741.070000:1.103,745.480000:1.103,747.290000:1.103,748.320000:1.103,754.358237:6.383,755.370000:2.136,760.490000:1.103,765.360000:1.103,767.500000:1.103,770.370000:1.103,775.230000:1.103,778.490000:1.103,792.360000:1.103,796.420000:1.103,801.380000:1.103,814.390000:2.118,815.390000:1.103,816.410000:1.103,820.470000:1.103,825.350000:1.103,841.510000:1.103,848.450000:1.103,883.450000:1.103,884.470000:1.103,896.410000:1.103,907.420000:1.103,908.430000:1.103,916.380000:1.103,1074.300000:1.103,1092.600000:1.103,1164.300000:1.103,1231.540000:1.103,1397.690000:1.103,1660.400000:1.103,1711.520000:1.103
ions2 :
ions3 :
peptol : 0
peptol units:
peptol str :
INSTRUMENT :
RULES :
IT_MODS :
repeat srch : 497.265612 from(498.272888,1+) query(1)
157, 24
185, 27
286, 81
385, 13
480, 4
129, 19
187, 23
354, 14
399, 9
482, 3
130, 9
258, 16
357, 14
444, 6
481, 3
136, 7
213, 14
371, 11
459, 6
489, 3
147, 6
229, 10
326, 5
423, 4
483, 2
159, 5
240, 8
298, 5
444, 3
474, 1
158, 4
270, 7
324, 5
411, 3
475, 1
86, 3
175, 7
312, 4
463, 3
477, 1
102, 3
241, 5
293, 4
446, 3
478, 1
115, 3
243, 4
353, 4
401, 3
487, 1
72, 2
76, 1
84, 2
87, 1
88, 1
98, 1
103, 1
105, 1
116, 1
117, 1
118, 1
120, 2
126, 1
127, 1
128, 2
131, 2
132, 1
136, 1
137, 1
138, 1
139, 1
140, 2
141, 2
143, 2
146, 1
152, 1
155, 2
156, 1
159, 1
165, 2
166, 1
167, 1
170, 1
170, 1
171, 1
173, 2
177, 1
178, 1
181, 1
182, 1
183, 2
184, 1
186, 4
188, 1
189, 1
189, 1
190, 2
191, 1
197, 1
199, 1
200, 1
201, 3
202, 2
203, 2
204, 1
211, 4
212, 2
212, 1
215, 2
216, 2
217, 1
218, 1
219, 2
223, 3
224, 1
225, 1
227, 1
228, 1
228, 2
230, 1
232, 1
233, 1
234, 1
235, 2
237, 1
238, 4
239, 3
242, 2
244, 2
244, 2
245, 3
246, 2
247, 2
248, 2
249, 2
250, 1
251, 1
253, 1
254, 1
255, 2
256, 1
257, 1
259, 2
260, 1
260, 1
262, 1
265, 1
266, 2
267, 1
267, 1
268, 3
269, 1
271, 2
272, 2
274, 1
275, 1
276, 2
278, 1
280, 2
281, 1
283, 1
284, 1
285, 1
287, 3
288, 1
288, 2
290, 1
294, 2
295, 3
296, 1
297, 2
300, 3
302, 1
303, 1
304, 1
305, 1
305, 1
306, 3
307, 1
308, 2
308, 1
313, 1
313, 1
314, 1
316, 2
317, 3
318, 1
320, 1
322, 3
323, 3
327, 1
328, 1
331, 2
332, 2
333, 1
336, 1
336, 1
337, 2
339, 1
339, 1
339, 3
341, 2
342, 1
343, 1
343, 2
344, 1
344, 2
346, 1
348, 1
348, 2
350, 1
350, 2
351, 3
352, 2
354, 1
354, 1
355, 3
358, 1
359, 2
360, 1
360, 1
361, 1
362, 1
363, 1
364, 1
366, 1
367, 1
368, 1
369, 1
369, 3
370, 1
370, 3
373, 2
374, 2
375, 2
376, 1
377, 1
380, 2
382, 3
383, 2
386, 2
386, 1
387, 3
388, 2
388, 1
390, 1
390, 1
391, 1
394, 1
395, 1
396, 2
398, 1
400, 2
403, 1
404, 1
404, 1
410, 2
412, 1
413, 1
414, 1
415, 1
416, 1
417, 1
417, 1
418, 1
418, 2
419, 1
421, 1
421, 2
423, 1
425, 2
426, 1
426, 3
428, 2
429, 1
430, 1
431, 2
433, 1
434, 1
435, 1
435, 1
437, 1
439, 2
439, 1
440, 1
442, 1
443, 1
445, 1
445, 1
449, 1
451, 1
452, 2
453, 3
454, 1
455, 1
458, 1
460, 1
461, 1
462, 1
462, 2
464, 1
464, 1
467, 2
470, 1
471, 1
490, 1
493, 1
494, 1
505, 1
508, 2
509, 1
509, 2
511, 1
522, 2
523, 1
524, 2
527, 1
528, 2
529, 1
530, 1
531, 1
533, 1
534, 1
537, 1
537, 1
538, 1
538, 1
540, 1
545, 2
545, 1
546, 1
547, 1
551, 2
558, 1
561, 1
562, 1
563, 1
568, 1
571, 3
573, 1
575, 1
580, 1
581, 1
585, 1
588, 1
590, 1
599, 1
605, 2
607, 4
608, 3
613, 2
614, 1
617, 1
621, 1
622, 1
625, 3
626, 1
633, 2
640, 1
642, 1
644, 1
646, 1
648, 1
651, 2
653, 2
658, 1
662, 1
664, 1
668, 2
674, 1
676, 1
677, 1
678, 1
683, 1
685, 1
685, 2
686, 1
701, 1
702, 7
703, 3
707, 1
713, 1
718, 2
720, 1
724, 1
728, 1
734, 1
735, 1
736, 1
737, 1
741, 1
745, 1
747, 1
748, 1
754, 6
755, 2
760, 1
765, 1
768, 1
770, 1
775, 1
778, 1
792, 1
796, 1
801, 1
814, 2
815, 1
816, 1
820, 1
825, 1
842, 1
848, 1
883, 1
884, 1
896, 1
907, 1
908, 1
916, 1
1074, 1
1093, 1
1164, 1
1232, 1
1398, 1
1660, 1
1712, 1
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_params.pl

resfile_params.pl

Example program for retrieving search parameter data.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_params.pl #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/resfile_params.pl $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) { die "Must specify results filename as parameter"; }
my $file = msparser::ms_mascotresfilebase::createResfile($ARGV[0]);
if ($file->isValid) {
searchParameters($file);
}
##############################################################################
# searchParameters #
# Display parameters from the ms_searchparams object. #
# The values come from the parameters and the masses sections of the file #
##############################################################################
sub searchParameters {
my ($resfile) = @_;
my $params = $resfile->params;
my $fmt = "%-20s: %s\n";
print "Search parameters from ms_searchparams" , "\n";
print "=========================================" , "\n";
printf $fmt, "License" , $params->getLICENSE();
printf $fmt, "Search title" , $params->getCOM();
printf $fmt, "SEG mass" , $params->getSEG();
printf $fmt, "Peptide tol" , $params->getTOL();
printf $fmt, "Peptide tol units" , $params->getTOLU();
printf $fmt, "Fragment tol" , $params->getITOL();
printf $fmt, "Fragment tol units" , $params->getITOLU();
printf $fmt, "Missed cleavages" , $params->getPFA();
printf $fmt, "Database" , $params->getDB();
printf $fmt, "Static mods" , $params->getMODS();
printf $fmt, "Average/monoisotopic", $params->getMASS();
printf $fmt, "Enzyme" , $params->getCLE();
printf $fmt, "Raw data file name" , $params->getFILENAME();
printf $fmt, "Input data" , $params->getQUE();
printf $fmt, "Type of search" , $params->getSEARCH();
printf $fmt, "User name" , $params->getUSERNAME();
printf $fmt, "User email" , $params->getUSEREMAIL();
printf $fmt, "Charge state" , $params->getCHARGE();
printf $fmt, "Repeat search file" , $params->getINTERMEDIATE();
printf $fmt, "Num hits to display" , $params->getREPORT();
printf $fmt, "Show overview" , $params->getOVERVIEW();
printf $fmt, "Data file format" , $params->getFORMAT();
printf $fmt, "Form version" , $params->getFORMVER();
printf $fmt, "Variable mods" , $params->getIT_MODS();
for my $i (0 .. 12) {
printf $fmt, sprintf("User%02d", $i), $params->getUSERField($i);
}
printf $fmt, "Precursor mass" , $params->getPRECURSOR();
printf $fmt, "Taxonomy filter" , $params->getTAXONOMY();
printf $fmt, "Type of report" , $params->getREPTYPE();
printf $fmt, "Accessions to search", $params->getACCESSION();
printf $fmt, "Subcluster used" , $params->getSUBCLUSTER();
printf $fmt, "ICAT search?" , $params->getICAT();
printf $fmt, "Instrument type" , $params->getINSTRUMENT();
printf $fmt, "Error tolerant?" , $params->getERRORTOLERANT();
printf $fmt, "Rules (ions series)" , $params->getRULES();
for my $ch (ord('A') .. ord('Z')) {
printf $fmt, join(' ', "Residue", chr($ch)), $params->getResidueMass(chr($ch));
}
printf $fmt, "C terminus mass" , $params->getCTermMass();
printf $fmt, "N terminus mass" , $params->getNTermMass();
printf $fmt, "Mass of hydrogen", $params->getHydrogenMass();
printf $fmt, "Mass of oxygen" , $params->getOxygenMass();
printf $fmt, "Mass of carbon" , $params->getCarbonMass();
printf $fmt, "Mass of nitrogen", $params->getNitrogenMass();
printf $fmt, "Mass of electron", $params->getElectronMass();
my $i = 1;
while ($params->getVarModsName($i)) {
printf $fmt, "Variable mod name" , $params->getVarModsName($i);
printf $fmt, "Variable mod delta" , $params->getVarModsDelta($i), "\n";
printf $fmt, "Variable mod neutral", $params->getVarModsNeutralLoss($i), "\n";
$i++;
}
print "\n\n";
}
=pod
Running the program as
perl -I../bin resfile_params.pl ../data/F981123.dat
will give the following output under Mascot Server 2.3:
Search parameters from ms_searchparams
=========================================
License : Licensed to: Matrix Science Internal use only - Frill, (4 processors).
Search title : MS/MS Example
SEG mass : -1
Peptide tol : 0.2
Peptide tol units : Da
Fragment tol : 0.2
Fragment tol units : Da
Missed cleavages : 1
Database : SwissProt
Static mods :
Average/monoisotopic: Monoisotopic
Enzyme : Trypsin
Raw data file name : C:\Auto MSMS output\Sample 1.pkl
Input data :
Type of search : MIS
User name :
User email :
Charge state : 2+
Repeat search file : ../data/F981123.dat
Num hits to display : 0
Show overview :
Data file format : Mascot generic
Form version : 1.01
Variable mods : Oxidation (M)
User00 :
User01 :
User02 :
User03 :
User04 :
User05 :
User06 :
User07 :
User08 :
User09 :
User10 :
User11 :
User12 :
Precursor mass : 0
Taxonomy filter : All entries
Type of report : Peptide
Accessions to search:
Subcluster used : -1
ICAT search? :
Instrument type : ESI-QUAD-TOF
Error tolerant? :
Rules (ions series) : 1,2,8,9,10,13,14,15
Residue A : 71.037114
Residue B : 114.53494
Residue C : 103.009185
Residue D : 115.026943
Residue E : 129.042593
Residue F : 147.068414
Residue G : 57.021464
Residue H : 137.058912
Residue I : 113.084064
Residue J : 0
Residue K : 128.094963
Residue L : 113.084064
Residue M : 131.040485
Residue N : 114.042927
Residue O : 0
Residue P : 97.052764
Residue Q : 128.058578
Residue R : 156.101111
Residue S : 87.032028
Residue T : 101.047679
Residue U : 150.95363
Residue V : 99.068414
Residue W : 186.079313
Residue X : 111
Residue Y : 163.063329
Residue Z : 128.55059
C terminus mass : 17.00274
N terminus mass : 1.007825
Mass of hydrogen : 1.007825
Mass of oxygen : 15.994915
Mass of carbon : 12
Mass of nitrogen : 14.003074
Mass of electron : 0.000549
Variable mod name : Oxidation (M)
Variable mod delta : 15.994919
Variable mod neutral: 0
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_params.cpp

resfile_params.cpp

Example program for retrieving search parameter data.

/*
##############################################################################
# file: resfile_params.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/resfile_params.cpp $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
#include <iomanip>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
/*****************************************************************************/
/* Local functions */
/* (This test harness is 'C' and not C++) */
/*****************************************************************************/
static void searchParameters(ms_mascotresfilebase & file);
/*****************************************************************************/
/* main */
/* Call this program with a single argument - the name of the .dat file */
/*****************************************************************************/
int main(int argc, char * argv[])
{
if (argc == 2)
{
ms_mascotresfilebase file = ms_mascotresfilebase::createResfile(argv[1]);
if (file.isValid())
{
searchParameters(file);
}
else
std::cout << "Error: " << file.getLastErrorString() << std::endl;
}
else
std::cout << "Must supply the name of a .dat file as a command line argument" << std::endl;
return 0;
}
/*****************************************************************************/
/* searchParameters */
/* Display parameters from the ms_searchparams object. */
/* The values come from the parameters and the masses sections of the file */
/*****************************************************************************/
static void searchParameters(ms_mascotresfilebase & file)
{
ms_searchparams p(file);
std::cout << "Search parameters from ms_searchparams" << std::endl;
std::cout << "=========================================" << std::endl;
std::cout << "License : " << p.getLICENSE() << std::endl;
std::cout << "Search title : " << p.getCOM() << std::endl;
std::cout << "SEG mass : " << p.getSEG() << std::endl;
std::cout << "Peptide tol : " << p.getTOL() << std::endl;
std::cout << "Peptide tol units : " << p.getTOLU() << std::endl;
std::cout << "Fragment tol : " << p.getITOL() << std::endl;
std::cout << "Fragment tol units : " << p.getITOLU() << std::endl;
std::cout << "Missed cleavages : " << p.getPFA() << std::endl;
std::cout << "Database : " << p.getDB() << std::endl;
std::cout << "Static mods : " << p.getMODS() << std::endl;
std::cout << "Average/monoisotopic: " << p.getMASS() << std::endl;
std::cout << "Enzyme : " << p.getCLE() << std::endl;
std::cout << "Raw data file name : " << p.getFILENAME() << std::endl;
std::cout << "Input data : " << p.getQUE() << std::endl;
std::cout << "Type of search : " << p.getSEARCH() << std::endl;
std::cout << "User name : " << p.getUSERNAME() << std::endl;
std::cout << "User email : " << p.getUSEREMAIL() << std::endl;
std::cout << "Charge state : " << p.getCHARGE() << std::endl;
std::cout << "Repeat search file : " << p.getINTERMEDIATE() << std::endl;
std::cout << "Num hits to display : " << p.getREPORT() << std::endl;
std::cout << "Show overview : " << p.getOVERVIEW() << std::endl;
std::cout << "Data file format : " << p.getFORMAT() << std::endl;
std::cout << "Form version : " << p.getFORMVER() << std::endl;
std::cout << "Variable mods : " << p.getIT_MODS() << std::endl;
for (int u=0; u <=12; u++)
std::cout << "User"
<< std::setw(2) << std::setfill('0') << u
<< " : " << p.getUSERField(u) << std::endl;
std::cout << "Precursor mass : " << p.getPRECURSOR() << std::endl;
std::cout << "Taxonomy filter : " << p.getTAXONOMY() << std::endl;
std::cout << "Type of report : " << p.getREPTYPE() << std::endl;
std::cout << "Accessions to search: " << p.getACCESSION() << std::endl;
std::cout << "Subcluster used : " << p.getSUBCLUSTER() << std::endl;
std::cout << "ICAT search? : " << p.getICAT() << std::endl;
std::cout << "Instrument type : " << p.getINSTRUMENT() << std::endl;
std::cout << "Error tolerant? : " << p.getERRORTOLERANT() << std::endl;
std::cout << "Rules (ions series) : " << p.getRULES() << std::endl;
std::cout << "Quantitation method : " << p.getQUANTITATION() << std::endl;
std::cout << "Peptide isotope err : " << p.getPEP_ISOTOPE_ERROR() << std::endl;
std::cout << "Decoy database : " << p.getDECOY() << std::endl;
for (char ch='A'; ch <= 'Z'; ch++)
{
std::cout << "Residue " << ch << " : "
<< p.getResidueMass(ch)
<< std::endl;
}
std::cout << "C terminus mass : " << p.getCTermMass() << std::endl;
std::cout << "N terminus mass : " << p.getNTermMass() << std::endl;
std::cout << "Mass of hydrogen : " << p.getHydrogenMass() << std::endl;
std::cout << "Mass of oxygen : " << p.getOxygenMass() << std::endl;
std::cout << "Mass of carbon : " << p.getCarbonMass() << std::endl;
std::cout << "Mass of nitrogen : " << p.getNitrogenMass() << std::endl;
std::cout << "Mass of electron : " << p.getElectronMass() << std::endl;
int i = 1;
while (p.getVarModsName(i).length())
{
std::cout << "Variable mod name : " << p.getVarModsName(i) << std::endl;
std::cout << "Variable mod delta : " << p.getVarModsDelta(i) << std::endl;
std::cout << "Variable mod neutral: " << p.getVarModsNeutralLoss(i)<< std::endl;
i++;
}
std::cout << std::endl << std::endl;
}
/*
will give the output:
Search parameters from ms_searchparams
=========================================
License :
Search title : A few peptides from an LCMS run
SEG mass : -1
Peptide tol : 2
Peptide tol units : Da
Fragment tol : 1
Fragment tol units : Da
Missed cleavages : 1
Database : MSDB
Static mods : Oxidation (M),SMA (K),SMA (N-term)
Average/monoisotopic: Monoisotopic
Enzyme : Trypsin
Raw data file name : U:\\Mascot test data\\TSQ\\dyckall_1.asc
Input data :
Type of search : MIS
User name : Cat R. Piller
User email : crp@brassica.com
Charge state : 2+
Repeat search file :
Num hits to display : 5
Show overview : 0
Data file format : Finnigan (.ASC)
Form version : 1.01
Variable mods :
User00 :
User01 :
User02 :
User03 :
User04 :
User05 :
User06 :
User07 :
User08 :
User09 :
User10 :
User11 :
User12 :
Precursor mass : 0
Taxonomy filter : All entries
Type of report : peptide
Accessions to search:
Subcluster used : -1
ICAT search? : 0
Instrument type : ESI-QUAD-TOF
Error tolerant? : 0
Rules (ions series) : 1,2,8,9,10,13,14,15
Quantitation method : ICAT
Peptide isotope err : 2
Decoy database : 1
Residue A : 71.0371
Residue B : 114.535
Residue C : 103.009
Residue D : 115.027
Residue E : 129.043
Residue F : 147.068
Residue G : 57.0215
Residue H : 137.059
Residue I : 113.084
Residue J : 0
Residue K : 255.158
Residue L : 113.084
Residue M : 147.035
Residue N : 114.043
Residue O : 0
Residue P : 97.0528
Residue Q : 128.059
Residue R : 156.101
Residue S : 87.032
Residue T : 101.048
Residue U : 0
Residue V : 99.0684
Residue W : 186.079
Residue X : 111
Residue Y : 163.063
Residue Z : 128.551
C terminus mass : 17.0027
N terminus mass : 128.071
Mass of hydrogen : 1.00783
Mass of oxygen : 15.9949
Mass of carbon : 12
Mass of nitrogen : 14.0031
Mass of electron : 0
*/
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresfilebase::getLastErrorString
std::string getLastErrorString() const
Return the last error number - or an empty string.
Definition: ms_mascotresfilebase.cpp:824
matrix_science::ms_searchparams
This class encapsulates the search parameters in the Mascot results file.
Definition: ms_searchparams.hpp:47
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_params.java

resfile_params.java

Example program for retrieving search parameter data.

/*
##############################################################################
# file: resfile_params.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchp $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class resfile_params {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// ----- Object creation -----
if(argv.length < 1) {
System.out.println("Must specify results filename as parameter");
System.exit(0);
}
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(argv[0], 0, "");
if (file.isValid()) {
searchParameters(file);
} else {
System.out.println("Error number: "+file.getLastError());
System.out.println("Error string: "+file.getLastErrorString());
System.exit(0);
}
}
private static void searchParameters(ms_mascotresfilebase file) {
int i;
char ch;
ms_searchparams p = file.params();
System.out.println("Search parameters from ms_searchparams");
System.out.println("=========================================");
System.out.println("License : "+p.getLICENSE());
System.out.println("Search title : "+p.getCOM());
System.out.println("SEG mass : "+p.getSEG());
System.out.println("Peptide tol : "+p.getTOL());
System.out.println("Peptide tol units : "+p.getTOLU());
System.out.println("Fragment tol : "+p.getITOL());
System.out.println("Fragment tol units : "+p.getITOLU());
System.out.println("Missed cleavages : "+p.getPFA());
System.out.println("Database : "+p.getDB());
System.out.println("Static mods : "+p.getMODS());
System.out.println("Average/monoisotopic: "+p.getMASS());
System.out.println("Enzyme : "+p.getCLE());
System.out.println("Raw data file name : "+p.getFILENAME());
System.out.println("Input data : "+p.getQUE());
System.out.println("Type of search : "+p.getSEARCH());
System.out.println("User name : "+p.getUSERNAME());
System.out.println("User email : "+p.getUSEREMAIL());
System.out.println("Charge state : "+p.getCHARGE());
System.out.println("Repeat search file : "+p.getINTERMEDIATE());
System.out.println("Num hits to display : "+p.getREPORT());
System.out.println("Show overview : "+toBinary(p.getOVERVIEW()));
System.out.println("Data file format : "+p.getFORMAT());
System.out.println("Form version : "+p.getFORMVER());
System.out.println("Variable mods : "+p.getIT_MODS());
// java lacks a printf equivalent by default
for(i=0; i <=12; i++) {
String output = "User";
if(i < 10) output += "0";
output += i+" : "+p.getUSERField(i);
System.out.println(output);
}
System.out.println("Precursor mass : "+roundWholeNumber(p.getPRECURSOR()));
System.out.println("Taxonomy filter : "+p.getTAXONOMY());
System.out.println("Type of report : "+p.getREPTYPE());
System.out.println("Accessions to search: "+p.getACCESSION());
System.out.println("Subcluster used : "+p.getSUBCLUSTER());
System.out.println("ICAT search? : "+toBinary(p.getICAT()));
System.out.println("Instrument type : "+p.getINSTRUMENT());
System.out.println("Error tolerant? : "+toBinary(p.getERRORTOLERANT()));
System.out.println("Rules (ions series) : "+p.getRULES());
System.out.println("Quantitation method : "+p.getQUANTITATION());
System.out.println("Peptide isotope err : "+p.getPEP_ISOTOPE_ERROR());
System.out.println("Decoy database : "+p.getDECOY());
for(ch='A'; ch <= 'Z'; ch++) {
System.out.println("Residue "+ch+" : "+roundWholeNumber(p.getResidueMass(ch)));
}
System.out.println("C terminus mass : "+roundWholeNumber(p.getCTermMass()));
System.out.println("N terminus mass : "+roundWholeNumber(p.getNTermMass()));
System.out.println("Mass of hydrogen : "+roundWholeNumber(p.getHydrogenMass()));
System.out.println("Mass of oxygen : "+roundWholeNumber(p.getOxygenMass()));
System.out.println("Mass of carbon : "+roundWholeNumber(p.getCarbonMass()));
System.out.println("Mass of nitrogen : "+roundWholeNumber(p.getNitrogenMass()));
System.out.println("Mass of electron : "+roundWholeNumber(p.getElectronMass()));
i=1;
while(!(p.getVarModsName(i).equals(""))) {
System.out.println("Variable mod name : "+p.getVarModsName(i));
System.out.println("Variable mod delta : "+roundWholeNumber(p.getVarModsDelta(i)));
System.out.println("Variable mod neutral: "+roundWholeNumber(p.getVarModsNeutralLoss(i)));
i++;
}
System.out.println("\n");
}
private static int toBinary(boolean bool) {
if(bool) return 1;
return 0;
}
private static String roundWholeNumber (double toRound) {
String myInt = ""+toRound;
myInt += "\n";
if(myInt.indexOf(".0\n")>-1) {
return myInt.substring(0,myInt.indexOf(".0\n"));
}
return ""+toRound;
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar resfile_params F981123.dat
Search parameters from ms_searchparams
=========================================
License :
Search title : A few peptides from an LCMS run
SEG mass : -1
Peptide tol : 2.0
Peptide tol units : Da
Fragment tol : 1.0
Fragment tol units : Da
Missed cleavages : 1
Database : MSDB
Static mods : Oxidation (M),SMA (K),SMA (N-term)
Average/monoisotopic: Monoisotopic
Enzyme : Trypsin
Raw data file name : U:\\Mascot test data\\TSQ\\dyckall_1.asc
Input data :
Type of search : MIS
User name : Cat R. Piller
User email : crp@brassica.com
Charge state : 2+
Repeat search file :
Num hits to display : 5
Show overview : 0
Data file format : Finnigan (.ASC)
Form version : 1.01
Variable mods :
User00 :
User01 :
User02 :
User03 :
User04 :
User05 :
User06 :
User07 :
User08 :
User09 :
User10 :
User11 :
User12 :
Precursor mass : 0
Taxonomy filter : All entries
Type of report : peptide
Accessions to search:
Subcluster used : -1
ICAT search? : 0
Instrument type : ESI-QUAD-TOF
Error tolerant? : 0
Rules (ions series) : 1,2,8,9,10,13,14,15
Quantitation method : ICAT
Peptide isotope err : 2
Decoy database : 1
Residue A : 71.03711
Residue B : 114.53493
Residue C : 103.00919
Residue D : 115.02694
Residue E : 129.04259
Residue F : 147.06841
Residue G : 57.02146
Residue H : 137.05891
Residue I : 113.08406
Residue J : 0
Residue K : 255.15829
Residue L : 113.08406
Residue M : 147.03541
Residue N : 114.04293
Residue O : 0
Residue P : 97.05276
Residue Q : 128.05858
Residue R : 156.10111
Residue S : 87.03203
Residue T : 101.04768
Residue U : 0
Residue V : 99.06841
Residue W : 186.07931
Residue X : 111
Residue Y : 163.06333
Residue Z : 128.55059
C terminus mass : 17.002735
N terminus mass : 128.07116
Mass of hydrogen : 1.007825
Mass of oxygen : 15.99491
Mass of carbon : 12
Mass of nitrogen : 14.00307
Mass of electron : 0
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_params.py

resfile_params.py

Example program for retrieving search parameter data.

1#!/usr/bin/perl
2
17
18import msparser
19import sys
20
21def main() :
22 if len(sys.argv) < 2 :
23 print("Must specify results filename as parameter")
24 return 1
25
26 resfile = msparser.ms_mascotresfilebase.createResfile(sys.argv[1])
27
28 if resfile.isValid() :
29 searchParameters(resfile)
30
31
32def searchParameters(resfile) :
33 """
34 Display parameters from the ms_searchparams object.
35 The values come from the parameters and the masses sections of the file.
36 """
37
38 params = resfile.params()
39 fmt = "%-20s: %s"
40
41 print("Search parameters from ms_searchparams")
42 print("=========================================")
43 print(fmt % ("License" , params.getLICENSE()))
44 print(fmt % ("Search title" , params.getCOM()))
45 print(fmt % ("SEG mass" , params.getSEG()))
46 print(fmt % ("Peptide tol" , params.getTOL()))
47 print(fmt % ("Peptide tol units" , params.getTOLU()))
48 print(fmt % ("Fragment tol" , params.getITOL()))
49 print(fmt % ("Fragment tol units" , params.getITOLU()))
50 print(fmt % ("Missed cleavages" , params.getPFA()))
51 print(fmt % ("Database" , params.getDB()))
52 print(fmt % ("Static mods" , params.getMODS()))
53 print(fmt % ("Average/monoisotopic", params.getMASS()))
54 print(fmt % ("Enzyme" , params.getCLE()))
55 print(fmt % ("Raw data file name" , params.getFILENAME()))
56 print(fmt % ("Input data" , params.getQUE()))
57 print(fmt % ("Type of search" , params.getSEARCH()))
58 print(fmt % ("User name" , params.getUSERNAME()))
59 print(fmt % ("User email" , params.getUSEREMAIL()))
60 print(fmt % ("Charge state" , params.getCHARGE()))
61 print(fmt % ("Repeat search file" , params.getINTERMEDIATE()))
62 print(fmt % ("Num hits to display" , params.getREPORT()))
63 print(fmt % ("Show overview" , params.getOVERVIEW()))
64 print(fmt % ("Data file format" , params.getFORMAT()))
65 print(fmt % ("Form version" , params.getFORMVER()))
66 print(fmt % ("Variable mods" , params.getIT_MODS()))
67
68 for i in range(12) :
69 print(fmt % ( "User%02d" % i, params.getUSERField(i)))
70
71 print(fmt % ("Precursor mass" , params.getPRECURSOR()))
72 print(fmt % ("Taxonomy filter" , params.getTAXONOMY()))
73 print(fmt % ("Type of report" , params.getREPTYPE()))
74 print(fmt % ("Accessions to search", params.getACCESSION()))
75 print(fmt % ("Subcluster used" , params.getSUBCLUSTER()))
76 print(fmt % ("ICAT search?" , params.getICAT()))
77 print(fmt % ("Instrument type" , params.getINSTRUMENT()))
78 print(fmt % ("Error tolerant?" , params.getERRORTOLERANT()))
79 print(fmt % ("Rules (ions series)" , params.getRULES()))
80
81 for ch in range(ord('A'), 1 + ord('Z')) :
82 print(fmt % ("Residue " + chr(ch), params.getResidueMass(chr(ch))))
83
84 print(fmt % ("C terminus mass" , params.getCTermMass()))
85 print(fmt % ("N terminus mass" , params.getNTermMass()))
86 print(fmt % ("Mass of hydrogen", params.getHydrogenMass()))
87 print(fmt % ("Mass of oxygen" , params.getOxygenMass()))
88 print(fmt % ("Mass of carbon" , params.getCarbonMass()))
89 print(fmt % ("Mass of nitrogen", params.getNitrogenMass()))
90 print(fmt % ("Mass of electron", params.getElectronMass()))
91
92 i = 1
93 while params.getVarModsName(i) :
94 print(fmt % ("Variable mod name" , params.getVarModsName(i)))
95 print(fmt % ("Variable mod delta" , params.getVarModsDelta(i)))
96 print(fmt % ("Variable mod neutral", params.getVarModsNeutralLoss(i)))
97 i += 1
98
99 print(" ")
100
101
102if __name__ == "__main__" :
103 sys.exit(main())
104
105
106"""
107
108Running the program as
109
110python resfile_params.pl F981123.dat
111
112will give the following output under Mascot Server 2.3:
113
114
115Search parameters from ms_searchparams
116=========================================
117License : Licensed to: Matrix Science Internal use only - Frill, (4 processors).
118Search title : MS/MS Example
119SEG mass : -1
120Peptide tol : 0.2
121Peptide tol units : Da
122Fragment tol : 0.2
123Fragment tol units : Da
124Missed cleavages : 1
125Database : SwissProt
126Static mods :
127Average/monoisotopic: Monoisotopic
128Enzyme : Trypsin
129Raw data file name : C:\Auto MSMS output\Sample 1.pkl
130Input data :
131Type of search : MIS
132User name :
133User email :
134Charge state : 2+
135Repeat search file : ../data/F981123.dat
136Num hits to display : 0
137Show overview : False
138Data file format : Mascot generic
139Form version : 1.01
140Variable mods : Oxidation (M)
141User00 :
142User01 :
143User02 :
144User03 :
145User04 :
146User05 :
147User06 :
148User07 :
149User08 :
150User09 :
151User10 :
152User11 :
153Precursor mass : 0.0
154Taxonomy filter : All entries
155Type of report : Peptide
156Accessions to search:
157Subcluster used : -1
158ICAT search? : False
159Instrument type : ESI-QUAD-TOF
160Error tolerant? : False
161Rules (ions series) : 1,2,8,9,10,13,14,15
162Residue A : 71.037114
163Residue B : 114.53494
164Residue C : 103.009185
165Residue D : 115.026943
166Residue E : 129.042593
167Residue F : 147.068414
168Residue G : 57.021464
169Residue H : 137.058912
170Residue I : 113.084064
171Residue J : 0.0
172Residue K : 128.094963
173Residue L : 113.084064
174Residue M : 131.040485
175Residue N : 114.042927
176Residue O : 0.0
177Residue P : 97.052764
178Residue Q : 128.058578
179Residue R : 156.101111
180Residue S : 87.032028
181Residue T : 101.047679
182Residue U : 150.95363
183Residue V : 99.068414
184Residue W : 186.079313
185Residue X : 111.0
186Residue Y : 163.063329
187Residue Z : 128.55059
188C terminus mass : 17.00274
189N terminus mass : 1.007825
190Mass of hydrogen : 1.007825
191Mass of oxygen : 15.994915
192Mass of carbon : 12.0
193Mass of nitrogen : 14.003074
194Mass of electron : 0.000549
195Variable mod name : Oxidation (M)
196Variable mod delta : 15.994919
197Variable mod neutral: 0.0
198
199
200"""
201
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_params.cs

resfile_params.cs

Example program for retrieving search parameter data.

/*
##############################################################################
# file: resfile_params.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/resfile_params.cs $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class resfile_params
{
public static void Main(string[] argv)
{
// ----- Object creation -----
if (argv.Length < 1)
{
Console.WriteLine("Must specify results filename as parameter");
return;
}
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(argv[0], 0, "");
if (file.isValid())
{
searchParameters(file);
}
else
{
Console.WriteLine("Error number: {0}", file.getLastError());
Console.WriteLine("Error string: {0}", file.getLastErrorString());
return;
}
}
private static void searchParameters(ms_mascotresfilebase file)
{
int i;
char ch;
ms_searchparams p = file._params();
Console.WriteLine("Search parameters from ms_searchparams");
Console.WriteLine("=========================================");
Console.WriteLine("License : {0}", p.getLICENSE());
Console.WriteLine("Search title : {0}", p.getCOM());
Console.WriteLine("SEG mass : {0}", p.getSEG());
Console.WriteLine("Peptide tol : {0}", p.getTOL());
Console.WriteLine("Peptide tol units : {0}", p.getTOLU());
Console.WriteLine("Fragment tol : {0}", p.getITOL());
Console.WriteLine("Fragment tol units : {0}", p.getITOLU());
Console.WriteLine("Missed cleavages : {0}", p.getPFA());
Console.WriteLine("Database : {0}", p.getDB());
Console.WriteLine("Static mods : {0}", p.getMODS());
Console.WriteLine("Average/monoisotopic: {0}", p.getMASS());
Console.WriteLine("Enzyme : {0}", p.getCLE());
Console.WriteLine("Raw data file name : {0}", p.getFILENAME());
Console.WriteLine("Input data : {0}", p.getQUE());
Console.WriteLine("Type of search : {0}", p.getSEARCH());
Console.WriteLine("User name : {0}", p.getUSERNAME());
Console.WriteLine("User email : {0}", p.getUSEREMAIL());
Console.WriteLine("Charge state : {0}", p.getCHARGE());
Console.WriteLine("Repeat searhc file : {0}", p.getINTERMEDIATE());
Console.WriteLine("Num hits to display : {0}", p.getREPORT());
Console.WriteLine("Show overview : {0}", ((p.getOVERVIEW()) ? 1 : 0));
Console.WriteLine("Data file format : {0}", p.getFORMAT());
Console.WriteLine("Form version : {0}", p.getFORMVER());
Console.WriteLine("Variable mods : {0}", p.getIT_MODS());
for (i = 0; i <= 12; i++)
{
Console.WriteLine("User{0} : {1}", "" + i.ToString("D2"), p.getUSERField(i));
}
Console.WriteLine("Precursor mass : {0:#}", p.getPRECURSOR());
Console.WriteLine("Taxonomy filter : {0}", p.getTAXONOMY());
Console.WriteLine("Type of report : {0}", p.getREPTYPE());
Console.WriteLine("Accessions to search: {0}", p.getACCESSION());
Console.WriteLine("Subcluster used : {0}", p.getSUBCLUSTER());
Console.WriteLine("ICAT search? : {0}", ((p.getICAT()) ? 1 : 0));
Console.WriteLine("Instrument type : {0}", p.getINSTRUMENT());
Console.WriteLine("Error tolerant? : {0}", ((p.getERRORTOLERANT()) ? 1 : 0));
Console.WriteLine("Rules (ions series) : {0}", p.getRULES());
Console.WriteLine("Quantitation method : {0}", p.getQUANTITATION());
Console.WriteLine("Peptide isotope err : {0}", p.getPEP_ISOTOPE_ERROR());
Console.WriteLine("Decoy database : {0}", p.getDECOY());
for (ch = 'A'; ch <= 'Z'; ch++)
{
Console.WriteLine("Residue {0} : {1:#}", ch, p.getResidueMass(ch));
}
Console.WriteLine("C terminus mass : {0:#}", p.getCTermMass());
Console.WriteLine("N terminus mass : {0:#}", p.getNTermMass());
Console.WriteLine("Mass of hydrogen : {0:#}", p.getHydrogenMass());
Console.WriteLine("Mass of oxygen : {0:#}", p.getOxygenMass());
Console.WriteLine("Mass of carbon : {0:#}", p.getCarbonMass());
Console.WriteLine("Mass of nitrogen : {0:#}", p.getNitrogenMass());
Console.WriteLine("Mass of electron : {0:#}", p.getElectronMass());
i = 1;
while (p.getVarModsName(i).Length > 0)
{
Console.WriteLine("Variable mod name : {0}", p.getVarModsName(i));
Console.WriteLine("Variable mod delta : {0:#}", p.getVarModsDelta(i));
Console.WriteLine("Variable mod neutral: {0:#}", p.getVarModsNeutralLoss(i));
i++;
}
Console.WriteLine();
}
}
}
/*
resfile_params.exe c:\inetpub\mascot\data\F981123.dat
Will give the following output:
Search parameters from ms_searchparams
=========================================
License : Matrix Science (ECUK-U3C2-5RS5-AAQL-H2X5)
Search title : MS/MS Example
SEG mass : -1
Peptide tol : 0.2
Peptide tol units : Da
Fragment tol : 0.2
Fragment tol units : Da
Missed cleavages : 1
Database : SwissProt
Static mods :
Average/monoisotopic: Monoisotopic
Enzyme : Trypsin
Raw data file name :
Input data :
Type of search : MIS
User name :
User email :
Charge state : 2+
Repeat searhc file : ../data/F981123.dat
Num hits to display : 0
Show overview : 0
Data file format : Mascot generic
Form version : 1.01
Variable mods : Oxidation (M)
User00 :
User01 :
User02 :
User03 :
User04 :
User05 :
User06 :
User07 :
User08 :
User09 :
User10 :
User11 :
User12 :
Precursor mass :
Taxonomy filter : All entries
Type of report : Peptide
Accessions to search:
Subcluster used : -1
ICAT search? : 0
Instrument type : ESI-QUAD-TOF
Error tolerant? : 0
Rules (ions series) : 1,2,8,9,10,13,14,15
Quantitation method : None
Peptide isotope err : 0
Decoy database : -1
Residue A : 71
Residue B : 115
Residue C : 103
Residue D : 115
Residue E : 129
Residue F : 147
Residue G : 57
Residue H : 137
Residue I : 113
Residue J : 113
Residue K : 128
Residue L : 113
Residue M : 131
Residue N : 114
Residue O : 237
Residue P : 97
Residue Q : 128
Residue R : 156
Residue S : 87
Residue T : 101
Residue U : 151
Residue V : 99
Residue W : 186
Residue X : 111
Residue Y : 163
Residue Z : 129
C terminus mass : 17
N terminus mass : 1
Mass of hydrogen : 1
Mass of oxygen : 16
Mass of carbon : 12
Mass of nitrogen : 14
Mass of electron :
Variable mod name : Oxidation (M)
Variable mod delta : 16
Variable mod neutral:
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_summary.pl

resfile_summary.pl

Example program for extracting the peptide or protein summary.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_summary.pl #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/resfile_summary.pl $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) { die "Must specify results filename as parameter"; }
my $returnValue = 1;
my $resfile = msparser::ms_mascotresfilebase::createResfile($ARGV[0]);
if (checkErrors($resfile)) {
# The parameters passed to ms_peptidesummary or ms_proteinsummary determine
# the type of grouping and the number of proteins and peptides displayed.
# Default parameters can be returned using ms_mascotresfilebase::get_ms_mascotresults_params().
# The return values from this function depend on the type of search,
# and also on values in the mascot.dat configuration file if that is available.
my $datfile = new msparser::ms_datfile("../config/mascot.dat"); # You may need to change this path
# if the mascot.dat isn't available, use defaults
my $mascotOptions;
if ($datfile->isValid()) {
$mascotOptions = $datfile->getMascotOptions();
}
my ($scriptName,
$flags,
$minProbability,
$maxHitsToReport,
$ignoreIonsScoreBelow,
$minPepLenInPepSummary,
$usePeptideSummary,
$flags2
) = $resfile->get_ms_mascotresults_params($datfile->getMascotOptions);
my $bResult;
if ($usePeptideSummary) {
# For peptide summary
#
# Flags defined for hierarchical clustering algorithm:
# flags: ms_mascotresults::MSRES_CLUSTER_PROTEINS
# | ms_mascotresults::MSRES_SHOW_SUBSETS
# | ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE;
# flags2: ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH;
#
# Flags defined for original simple parsimony algorithm:
# flags: ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS;
print "-------------------------------------------------------------\n";
print "--- Peptide summary report ---\n";
print "-------------------------------------------------------------\n";
$bResult = show_results(
$resfile,
$usePeptideSummary,
$flags,
$minProbability,
$maxHitsToReport,
$ignoreIonsScoreBelow,
$minPepLenInPepSummary,
$flags2
);
} else {
# Show results from full protein summary, remove grouping
$flags &= ~$msparser::ms_mascotresults::MSRES_GROUP_PROTEINS;
$flags &= ~$msparser::ms_mascotresults::MSRES_SHOW_SUBSETS;
print "-------------------------------------------------------------\n";
print "--- Full Protein summary report ---\n";
print "-------------------------------------------------------------\n";
$bResult = show_results(
$resfile,
$usePeptideSummary,
$flags,
$minProbability,
$maxHitsToReport,
$ignoreIonsScoreBelow,
$minPepLenInPepSummary,
$flags2
);
if($bResult and checkErrors($resfile)) {
# Show results from concise protein summary, add grouping
$flags |= $msparser::ms_mascotresults::MSRES_GROUP_PROTEINS;
$flags |= $msparser::ms_mascotresults::MSRES_SHOW_SUBSETS;
print "-------------------------------------------------------------\n";
print "--- Concise Protein summary report ---\n";
print "-------------------------------------------------------------\n";
$bResult = show_results(
$resfile,
$usePeptideSummary,
$flags,
$minProbability,
$maxHitsToReport,
$ignoreIonsScoreBelow,
$minPepLenInPepSummary,
$flags2
);
}
}
if($bResult and checkErrors($resfile)) {
$returnValue = 0;
}
}
exit($returnValue);
##############################################################################
# show_results #
# - parameter 0 is ms_mascotresfilebase #
# - parameter 1 is true for peptide summary, false for protein #
# - parameter 2 is the flags for display #
# - parameter 3 is the minimum protein probability to display #
# - parameter 4 is the maximum number of hits to display #
# - parameter 5 is the minimum ions score to use #
# - parameter 6 is the minPepLenInPepSummary to use #
##############################################################################
sub show_results {
my($file, $usePeptideSummary, $flags, $minProteinProb, $maxHits,
$minIonsScore, $minPepLenInPepSummary, $flags2) = @_;
my $results;
if ($usePeptideSummary) {
$results = new msparser::ms_peptidesummary(
$file, $flags, $minProteinProb, $maxHits, "", $minIonsScore, $minPepLenInPepSummary, "", $flags2
);
} else {
$results = new msparser::ms_proteinsummary(
$file, $flags, $minProteinProb, $maxHits
);
}
# Stop there is any fatal error occurred
if (not checkErrors($file)) {
return 0;
}
my $family = 1;
my $hit = 1;
my $prot = $results->getHit($hit);
while ($prot) {
my $accession = $prot->getAccession();
my $description = $results->getProteinDescription($accession);
my $mass = $results->getProteinMass($accession);
my $dbIdx = $prot->getDB();
if ($flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS) {
print "Protein Hit ", $hit, ".", $family, "\n===================\n";
}
else {
print "Protein Hit ", $hit, "\n===================\n";
}
print "Accession : " , $accession, "\n";
print "Description : " , $description , "\n";
print "Score : " , $prot->getScore() , "\n";
print "Mass : " , $mass , "\n";
print "Frame : " , $prot->getFrame() , "\n";
print "Coverage : " , $prot->getCoverage() , "\n";
print "RMS error : " , $prot->getRMSDeltas($results), "\n";
print "Peptides : " , $prot->getNumDisplayPeptides(),"\n";
# Each protein has a number of peptides that matched - list them:
my $num_peps = $prot->getNumPeptides();
for my $i (1 .. $num_peps) {
my $query = $prot->getPeptideQuery($i);
my $p = $prot->getPeptideP($i);
if (
$p != -1
and $query != -1
and $prot->getPeptideDuplicate($i) != $msparser::ms_protein::DUPE_DuplicateSameQuery
) {
my $pep = $results->getPeptide($query, $p);
next unless defined $pep;
displayPeptideInfo(
0, $pep, $results,
$prot->getPeptideDuplicate($i) == $msparser::ms_protein::DUPE_Duplicate,
$prot->getPeptideIsBold($i),
$prot->getPeptideShowCheckbox($i)
);
}
}
# Now display list of all proteins that contained subsets or and
# identical list of the matching peptides
if ($flags & $msparser::ms_mascotresults::MSRES_GROUP_PROTEINS or
$flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS) {
print "Proteins matching the same set of peptides:\n";
my $i = 1;
while (my $prot = $results->getNextSimilarProteinOf($accession, $dbIdx, $i)) {
my $accession = $prot->getAccession();
my $dbIdx = $prot->getDB();
if($flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS and $dbIdx > 1) {
print $dbIdx, "::";
}
print $accession, " - Total score: ", $prot->getScore();
print " - Peptides matched: ", $prot->getNumDisplayPeptides(), "\n";
$i++;
}
if ($flags & $msparser::ms_mascotresults::MSRES_SHOW_SUBSETS) {
print "Proteins matching a subset of these peptides:\n";
my $i = 1;
while ($prot = $results->getNextSubsetProteinOf($accession, $dbIdx, $i)) {
my $accession = $prot->getAccession();
my $dbIdx = $prot->getDB();
if($flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS and $dbIdx > 1) {
print $dbIdx, "::";
}
print $accession, " - Total score: ", $prot->getScore();
print " - Peptides matched: ", $prot->getNumDisplayPeptides(), "\n";
if ($flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS) {
my $j = 1;
if($results->getNextSimilarProteinOf($accession, $dbIdx, $j)){
print " Proteins matching the same set of peptides for this subset:\n";
}
while (my $similar_subset_prot = $results->getNextSimilarProteinOf($accession, $dbIdx, $j)) {
my $similar_subset_accession = $similar_subset_prot->getAccession();
my $similar_subset_dbIdx = $similar_subset_prot->getDB();
print " ";
if($similar_subset_dbIdx > 1) {
print $similar_subset_dbIdx, "::";
}
print $similar_subset_accession, " - Total score: ", $similar_subset_prot->getScore();
print " - Peptides matched: ", $similar_subset_prot->getNumDisplayPeptides(), "\n";
$j++;
}
}
$i++;
}
}
}
if ($flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS) {
$prot = $results->getNextFamilyProtein($hit, $family++);
if(!$prot) {
$hit++;
$prot = $results->getHit($hit);
$family = 1;
}
}
else {
$hit++;
$prot = $results->getHit($hit);
}
print "\n";
}
$results->createUnassignedList($msparser::ms_mascotresults::SCORE);
if ($results->getNumberOfUnassigned()) {
print "Unassigned list\n";
print "---------------\n";
for my $u (1 .. $results->getNumberOfUnassigned) {
my $pep = $results->getUnassigned($u);
displayPeptideInfo(0, $pep, $results, 0, 1, 1);
}
}
if ($usePeptideSummary) {
print "\n";
displayYellowPopupInfo($results, 1);
}
return 1;
}
##############################################################################
# displayYellowPopupInfo #
# Shows the equivalent of the yellow popup box for given query #
# - parameter 0 is the results object #
# - parameter 1 is the query number #
##############################################################################
sub displayYellowPopupInfo {
my ($results, $q) = @_;
my $fmt = "%5s %5s %9s %7s %7s\n";
printf $fmt, qw(Score Delta Hit Protein Peptide);
for my $p (1 .. 10) {
my $pep = $results->getPeptide($q, $p);
next unless defined $pep;
my $seq = $pep->getPeptideStr();
next unless defined $seq;
my $tmp = $results->getProteinsWithThisPepMatch($q, $p);
my ($hit, $protein) = ('', '');
if ($tmp) {
($hit, $protein, my $morethan) = $tmp =~ /(\d+):([^ ]*)[ ]*(.*)/;
if ($morethan) {
$hit .= "+";
}
}
printf $fmt, $pep->getIonsScore(), $pep->getDelta(), $hit, $protein, $seq;
}
my $p = 1;
print "Accessions that matched query ", $q, " rank ", $p, ":- ",
$results->getProteinsWithThisPepMatch($q, $p), "\n";
}
##############################################################################
# displayPeptideInfo #
# - parameter 0 showFullDetails? #
# - parameter 1 p #
# - parameter 2 ms_mascotresults #
# - parameter 3 isDuplicate? #
# - parameter 4 isBold? #
# - parameter 5 showCheckBox? #
##############################################################################
sub displayPeptideInfo {
my ($showFullDetails, $p, $r, $isDuplicate, $isBold, $showCheckBox) = @_;
my $q = $p->getQuery();
if (!$showFullDetails) {
my $fmt = "%2s %4s %4d %11f %4d(%4d) %-20s %s%3.2f%s %3d\n";
printf $fmt,
$showCheckBox ? "CB" : "--",
$isBold ? "BOLD" : "dim",
$q,
$p->getObserved,
$p->getRank,
$p->getPrettyRank,
$p->getPeptideStr,
$isDuplicate ? '(' : '',
$p->getIonsScore,
$isDuplicate ? ')' : '',
$r->getReadableVarMods($q, $p->getRank),
;
return;
}
print "Peptide hit\n";
if ($p->getAnyMatch()) {
my $fmt = " %-12s: %s\n";
printf $fmt, 'Query' , $q;
printf $fmt, 'Rank' , $p->getRank;
printf $fmt, 'Matched' , $p->getAnyMatch;
printf $fmt, 'missedCleave', $p->getMissedCleavages;
printf $fmt, 'mrCalc' , $p->getMrCalc;
printf $fmt, 'delta' , $p->getDelta;
printf $fmt, 'observed' , $p->getObserved;
printf $fmt, 'charge' , $p->getCharge;
printf $fmt, 'mrExp' , $p->getMrExperimental;
printf $fmt, 'ionsMatched' , $p->getNumIonsMatched;
printf $fmt, 'peptideStr' , $p->getPeptideStr;
printf $fmt, 'peaksUsed1' , $p->getPeaksUsedFromIons1;
printf $fmt, 'varModsStr' , $p->getVarModsStr;
printf $fmt, 'readable mod', $r->getReadableVarMods($q, $p->getRank);
printf $fmt, 'ionsScore' , $p->getIonsScore;
printf $fmt, 'seriesUsedS' , $p->getSeriesUsedStr;
printf $fmt, 'peaksUsed2' , $p->getPeaksUsedFromIons3;
printf $fmt, 'peaksUsed3' , $p->getPeaksUsedFromIons3;
printf $fmt, 'idth, hth, p', join(', ',
$r->getPeptideIdentityThreshold($q, 20),
$r->getHomologyThreshold($q, 20),
$r->getProbOfPepBeingRandomMatch($p->getIonsScore, $q)
);
print "\n";
} else {
print " No match\n";
}
}
##############################################################################
# checkErrors #
# - parameter 0 file is a ms_mascotresfilebase #
##############################################################################
sub checkErrors() {
my ($file) = @_;
if ($file->getLastError()) {
for my $i (1 .. $file->getNumberOfErrors) {
print "Error number: ", $file->getErrorNumber($i);
print " : ", $file->getErrorString($i);
print "\n";
}
}
#Call isValid before clearAllErrors, otherwise this method always returns true
my $bIsValid = $file->isValid();
$file->clearAllErrors();
return $bIsValid;
}
=pod
Running the program as
perl -I../bin resfile_summary.pl ../data/F981123.dat
will give the following output under Mascot Server 2.3:
-------------------------------------------------------------
--- Peptide summary report ---
-------------------------------------------------------------
Protein Hit 1
===================
Accession : CH60_HUMAN
Description : 60 kDa heat shock protein, mitochondrial precursor (Hsp60) (60 kDa chaperonin) (CPN60) (Heat shock
Score : 1225.18623376928
Mass : 61016.38
Frame : 0
Coverage : 283
RMS error : 30.4200726378481
Peptides : 31
CB BOLD 11 417.182190 1( 1) APGFGDNR 45.35 0
CB BOLD 12 422.743286 1( 1) VGEVIVTK 45.74 0
CB BOLD 13 430.732788 1( 1) IPAMTIAK 36.27 0
CB BOLD 15 451.249908 1( 1) LSDGVAVLK 51.95 0
CB BOLD 16 456.780609 1( 1) VGLQVVAVK 59.00 0
CB BOLD 21 480.744690 1( 1) VTDALNATR 45.33 0
CB BOLD 24 595.785522 1( 1) EIGNIISDAMK (56.55) 0
CB BOLD 25 603.771973 1( 1) EIGNIISDAMK 59.52 0
CB BOLD 26 608.309875 1( 1) NAGVEGSLIVEK 73.21 0
CB BOLD 27 617.285706 1( 1) VGGTSDVEVNEK 80.63 0
CB BOLD 31 672.837524 1( 1) TVIIEQSWGSPK 64.38 0
CB BOLD 34 714.888428 1( 1) GVMLAVDAVIAELK (64.52) 0
CB BOLD 35 714.893799 1( 1) GVMLAVDAVIAELK (72.61) 0
CB BOLD 36 722.884888 1( 1) GVMLAVDAVIAELK 75.19 0
CB BOLD 37 722.893372 1( 1) GVMLAVDAVIAELK (72.57) 0
CB BOLD 39 752.864319 1( 1) TLNDELEIIEGMK 89.56 0
CB BOLD 40 760.846130 1( 1) TLNDELEIIEGMK (88.82) 0
CB BOLD 45 640.328125 1( 1) ISSIQSIVPALEIANAHR 101.50 0
CB BOLD 46 960.032715 1( 1) ISSIQSIVPALEIANAHR (87.34) 0
CB BOLD 48 1019.510620 1( 1) IQEIIEQLDVTTSEYEK 52.42 0
CB BOLD 51 1057.053711 1( 1) ALMLQGVDLLADAVAVTMGPK 115.78 0
CB BOLD 52 1065.039917 1( 1) ALMLQGVDLLADAVAVTMGPK (71.79) 0
CB BOLD 53 1065.062256 1( 1) ALMLQGVDLLADAVAVTMGPK (26.17) 0
CB BOLD 54 1073.047729 1( 1) ALMLQGVDLLADAVAVTMGPK (92.82) 2
CB BOLD 58 789.106201 1( 1) KPLVIIAEDVDGEALSTLVLNR (55.53) 0
CB BOLD 59 1183.156982 1( 1) KPLVIIAEDVDGEALSTLVLNR (65.46) 0
CB BOLD 60 789.109375 1( 1) KPLVIIAEDVDGEALSTLVLNR 94.59 0
CB BOLD 61 828.123779 1( 1) TALLDAAGVASLLTTAEVVVTEIPK (26.50) 0
CB BOLD 62 828.132202 1( 1) TALLDAAGVASLLTTAEVVVTEIPK 47.53 0
CB BOLD 64 854.058777 1( 1) LVQDVANNTNEEAGDGTTTATVLAR 75.15 0
CB BOLD 65 1038.503052 1( 1) DMAIATGGAVFGEEGLTLNLEDVQPHDLGK 13.05 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
CH60_PONPY Total score: 1007.90623376928 Peptides matched: 25
CH60_CRIGR Total score: 951.166233769285 Peptides matched: 23
CH60_MOUSE Total score: 951.166233769285 Peptides matched: 23
CH60_RAT Total score: 951.166233769285 Peptides matched: 23
CH60_BOVIN Total score: 917.68246753857 Peptides matched: 22
CH60_CHICK Total score: 875.976233769285 Peptides matched: 19
CH60C_DROME Total score: 120.5 Peptides matched: 2
CH60C_ARATH Total score: 90.68 Peptides matched: 2
HSP60_CANAL Total score: 45.35 Peptides matched: 1
HSP60_PARBR Total score: 45.35 Peptides matched: 1
HSP60_YEAST Total score: 45.35 Peptides matched: 1
CH602_VIBPA Total score: 45.35 Peptides matched: 1
CH602_VIBVU Total score: 45.35 Peptides matched: 1
CH602_VIBVY Total score: 45.35 Peptides matched: 1
CH60_EUGGR Total score: 45.33 Peptides matched: 1
Protein Hit 2
===================
Accession : CH60_DROME
Description : 60 kDa heat shock protein, mitochondrial precursor (Hsp60) (60 kDa chaperonin) (CPN60) (Heat shock
Score : 174.39
Mass : 60770.89
Frame : 0
Coverage : 67
RMS error : 29.5905072791318
Peptides : 4
-- dim 11 417.182190 1( 1) APGFGDNR 45.35 0
-- dim 27 617.285706 2( 2) VGGSSEVEVNEK 41.69 0
-- dim 59 1183.156982 2( 2) KPLVIIAEDIDGEALSTLVVNR 12.20 0
-- dim 64 854.058777 1( 1) LVQDVANNTNEEAGDGTTTATVLAR 75.15 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
HSP60_SCHPO Total score: 87.04 Peptides matched: 2
Protein Hit 3
===================
Accession : CH60_CAEEL
Description : Chaperonin homolog Hsp-60, mitochondrial precursor (Heat shock protein 60) (HSP-60) - Caenorhabditi
Score : 134.91
Mass : 60063.75
Frame : 0
Coverage : 21
RMS error : 36.5383063193603
Peptides : 3
-- dim 11 417.182190 1( 1) APGFGDNR 45.35 0
-- dim 39 752.864319 2( 1) TLNDELELIEGMK 89.56 0
-- dim 40 760.846130 2( 1) TLNDELELIEGMK (88.82) 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Protein Hit 4
===================
Accession : CH60_XANAC
Description : 60 kDa chaperonin (Protein Cpn60) (groEL protein) - Xanthomonas axonopodis pv. citri
Score : 42.2
Mass : 57130.83
Frame : 0
Coverage : 9
RMS error : 76.92376960617
Peptides : 1
-- dim 16 456.780609 2( 2) GIVKVVAVK 42.20 0
Proteins matching the same set of peptides:
CH60_XANC5 Total score: 42.2 Peptides matched: 1
CH60_XANC8 Total score: 42.2 Peptides matched: 1
CH60_XANCH Total score: 42.2 Peptides matched: 1
CH60_XANCP Total score: 42.2 Peptides matched: 1
CH60_XANOM Total score: 42.2 Peptides matched: 1
CH60_XANOR Total score: 42.2 Peptides matched: 1
Proteins matching a subset of these peptides:
Protein Hit 5
===================
Accession : NMDE4_HUMAN
Description :
Score : 37.24
Mass : 0
Frame : 0
Coverage : 10
RMS error : 9.41906700790969
Peptides : 1
-- dim 16 456.780609 3( 3) VAAGVAVVAR 37.24 0
Proteins matching the same set of peptides:
NMDE4_MOUSE Total score: 37.24 Peptides matched: 1
NMDE4_RAT Total score: 36.2762337692848 Peptides matched: 1
Proteins matching a subset of these peptides:
Protein Hit 6
===================
Accession : YF81_THET2
Description :
Score : 34.76
Mass : 0
Frame : 0
Coverage : 9
RMS error : 37.0214184966023
Peptides : 1
-- dim 16 456.780609 4( 4) VAQVLGVVK 34.76 0
Proteins matching the same set of peptides:
Y1944_THET8 Total score: 34.76 Peptides matched: 1
Proteins matching a subset of these peptides:
Protein Hit 7
===================
Accession : F4ST_FLACH
Description :
Score : 33.85
Mass : 0
Frame : 0
Coverage : 9
RMS error : 87.8815544838649
Peptides : 1
-- dim 15 451.249908 2( 2) LSATGLVLK 33.85 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Protein Hit 8
===================
Accession : ZN711_HUMAN
Description : Zinc finger protein 711 (Zinc finger protein 6) - Homo sapiens (Human)
Score : 30.84
Mass : 87153.77
Frame : 0
Coverage : 13
RMS error : 69.4028633218151
Peptides : 1
CB BOLD 33 714.364929 1( 1) EASPLSSNKLILR 30.84 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Unassigned list
---------------
CB BOLD 14 442.228302 1( 1) LIAQTPLK 25.09 0
CB BOLD 9 747.396179 1( 1) EGETRR 15.03 0
CB BOLD 4 662.275574 1( 1) KNAMAK 14.09 0
CB BOLD 23 1101.621704 1( 1) QLLMVAGVDR 12.04 0
CB BOLD 5 662.417175 1( 1) AIACER 11.79 0
CB BOLD 8 714.372498 1( 1) LAPAQSK 10.69 0
CB BOLD 6 673.349487 1( 1) AVNDVR 10.63 0
CB BOLD 22 1101.536621 1( 1) ENVIPADSEK 8.65 0
CB BOLD 55 1099.094727 1( 1) LNAEAVRTLLSANGQKPSEAK 8.05 0
CB BOLD 29 642.353577 1( 1) VVGVAGQGASALVR 7.91 0
CB BOLD 28 642.352600 1( 1) KNVSVSQGPDPR 7.22 0
CB BOLD 30 663.837891 1( 1) TPLLVGVAKGESR 7.20 0
CB BOLD 50 1048.561523 1( 1) ALDEILEYQNYPVVCAKK 5.70 0
CB BOLD 57 747.036072 1( 1) VMGSAFTALLDANEDAQKAMR 4.83 0
CB BOLD 49 1020.987915 1( 1) HQRLSGLMQTALEEQQR 4.11 0
CB BOLD 19 932.364380 1( 1) TGMTRNPR 4.09 0
CB BOLD 2 500.256012 1( 1) LAVPT 3.87 0
CB BOLD 38 749.383972 1( 1) IDLLADMMWDDK 3.43 2
CB BOLD 20 933.499023 1( 1) SRDPGMVR 3.21 0
CB BOLD 41 886.405884 1( 1) DRVALNQEVMAPEATK 1.85 0
CB BOLD 10 747.412476 1( 1) MAPSTPK 1.68 0
CB BOLD 18 930.703003 1( 1) LGSGIKAER 1.60 0
CB BOLD 7 711.364685 1( 1) GGAHEIK 1.34 0
CB BOLD 17 930.683105 1( 1) KIQAEITK 1.00 0
CB BOLD 44 949.550720 1( 1) LLSWDSVFFIKNITSK 0.30 0
CB BOLD 1 498.272888 1( 1) 0.00 0
CB BOLD 3 575.558411 1( 1) 0.00 0
CB BOLD 32 711.370728 1( 1) 0.00 0
CB BOLD 42 932.460815 1( 1) 0.00 0
CB BOLD 43 933.003784 1( 1) 0.00 0
CB BOLD 47 665.009583 1( 1) 0.00 0
CB BOLD 56 1119.045166 1( 1) 0.00 0
CB BOLD 63 832.798584 1( 1) 0.00 0
CB BOLD 66 1113.894653 1( 1) 0.00 0
CB BOLD 67 1116.177490 1( 1) 0.00 0
Score Delta Hit Protein Peptide
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0
Accessions that matched query 97 rank 1:-
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_summary.cpp

resfile_summary.cpp

Example program for extracting the peptide or protein summary.

/*
##############################################################################
# file: resfile_summary.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/resfile_summary.cpp $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
#include <iomanip>
#include <fstream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
/*****************************************************************************/
/* Local functions */
/*****************************************************************************/
static void displayPeptideInfo(bool showFullDetails,
ms_peptide * pep,
ms_mascotresults * r,
bool isDuplicate,
bool isBold,
bool showCheckBox);
static bool showResults(ms_mascotresfilebase & file,
bool peptideSummary,
const int flags,
const double minProbability = 0,
const int maxHitsToDisplay = 50,
const double ignoreIonsScoreBelow = 0,
const int minPepLenInPepSummary = 0,
const int flags2 = ms_peptidesummary::MSPEPSUM_NONE);
static void displayYellowPopupInfo(ms_mascotresults * results, int q);
static bool checkErrors(ms_mascotresfilebase & file);
/*****************************************************************************/
/* main */
/* Call this program with a single argument - the name of the .dat file */
/*****************************************************************************/
int main(int argc, char * argv[])
{
int returnValue = EXIT_FAILURE;
if (argc == 2)
{
ms_mascotresfilebase file = ms_mascotresfilebase::createResfile(argv[1]);
if (checkErrors(file))
{
bool usePeptideSummary;
unsigned int flags, flags2, minPepLenInPepSummary;
int maxHitsToReport;
double minProbability, ignoreIonsScoreBelow;
/*
* The parameters passed to ms_peptidesummary or ms_proteinsummary determine
* the type of grouping and the number of proteins and peptides displayed.
* Default parameters can be returned using ms_mascotresfilebase::get_ms_mascotresults_params().
* The return values from this function depend on the type of search,
* and also on values in the mascot.dat configuration file if that is available.
*/
ms_datfile datfile("../config/mascot.dat"); //You may need to change this path
//if the mascot.dat isn't available, use defaults
ms_mascotoptions mascotOptions;
if (datfile.isValid())
{
mascotOptions = *(datfile.getMascotOptions());
}
std::string scriptName = file.get_ms_mascotresults_params(
mascotOptions,
&flags,
&minProbability,
&maxHitsToReport,
&ignoreIonsScoreBelow,
&minPepLenInPepSummary,
&usePeptideSummary,
&flags2);
bool bResult;
if (usePeptideSummary)
{
/*
* For peptide summary
*
* Flags defined for hierarchical clustering algorithm:
* flags: ms_mascotresults::MSRES_CLUSTER_PROTEINS
* | ms_mascotresults::MSRES_SHOW_SUBSETS
* | ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE;
* flags2: ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH;
*
* Flags defined for original simple parsimony algorithm:
* flags: ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS;
*/
std::cout << "-------------------------------------------------------------" << std::endl;
std::cout << "--- Peptide summary report ---" << std::endl;
std::cout << "-------------------------------------------------------------" << std::endl;
bResult = showResults(file,
usePeptideSummary,
flags,
minProbability,
maxHitsToReport,
ignoreIonsScoreBelow,
minPepLenInPepSummary,
flags2);
}
else
{
// Show results from full protein summary, remove grouping
flags &= ~ms_mascotresults::MSRES_GROUP_PROTEINS;
flags &= ~ms_mascotresults::MSRES_SHOW_SUBSETS;
std::cout << "-------------------------------------------------------------" << std::endl;
std::cout << "--- Full Protein summary report ---" << std::endl;
std::cout << "-------------------------------------------------------------" << std::endl;
bResult = showResults(file,
usePeptideSummary,
flags,
minProbability,
maxHitsToReport,
ignoreIonsScoreBelow,
minPepLenInPepSummary,
flags2);
if (bResult && checkErrors(file))
{
std::cout << std::endl;
// Show results from concise protein summary, add grouping
flags |= ms_mascotresults::MSRES_GROUP_PROTEINS;
flags |= ms_mascotresults::MSRES_SHOW_SUBSETS;
std::cout << "-------------------------------------------------------------" << std::endl;
std::cout << "--- Concise Protein summary report ---" << std::endl;
std::cout << "-------------------------------------------------------------" << std::endl;
bResult = showResults(file,
usePeptideSummary,
flags,
minProbability,
maxHitsToReport,
ignoreIonsScoreBelow,
minPepLenInPepSummary,
flags2);
}
}
if (bResult && checkErrors(file))
{
returnValue = EXIT_SUCCESS;
}
}
}
else
{
std::cout << "Must supply the name of a .dat file as a command line argument" << std::endl;
}
return returnValue;
}
/*****************************************************************************/
/* showResults */
/* Shows results using either the peptide summary or the protein summary */
/*****************************************************************************/
static bool showResults(ms_mascotresfilebase & file,
bool peptideSummary,
const int flags,
const double minProbability,
const int maxHitsToDisplay,
const double ignoreIonsScoreBelow,
const int minPepLenInPepSummary,
const int flags2)
{
ms_mascotresults * results;
if (peptideSummary)
{
results = new ms_peptidesummary(file, flags, minProbability, maxHitsToDisplay,
0, ignoreIonsScoreBelow, minPepLenInPepSummary, "", flags2);
}
else
{
results = new ms_proteinsummary(file, flags, minProbability, maxHitsToDisplay);
}
//Stop there is any fatal error occurred
if (!checkErrors(file))
{
return false;
}
int family = 1;
int hit = 1;
ms_protein * prot = results->getHit(hit);
while (prot)
{
std::string accession = prot->getAccession();
std::string description = results->getProteinDescription(accession.c_str());
double mass = results->getProteinMass(accession.c_str());
int dbIdx = prot->getDB();
std::cout << "Protein Hit " << hit;
if (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS)
{
std::cout << "." << family;
}
std::cout << "\n===================\n";
std::cout << "Accession : " << accession << std::endl;
std::cout << "Description : " << description << std::endl;
std::cout << "Score : " << prot->getScore() << std::endl;
std::cout << "Mass : " << mass << std::endl;
std::cout << "Frame : " << prot->getFrame() << std::endl;
std::cout << "Coverage : " << prot->getCoverage() << std::endl;
std::cout << "Peptides : " << prot->getNumDisplayPeptides()<< std::endl;
int i;
// Each protein has a number of peptides that matched - list them:
for (i=1; i <= prot->getNumPeptides(); i++)
{
int query = prot->getPeptideQuery(i);
int p = prot->getPeptideP(i);
if (p != -1
&& query != -1
&& prot->getPeptideDuplicate(i) != ms_protein::DUPE_DuplicateSameQuery)
{
ms_peptide * pep;
if (results->getPeptide(query, p, pep))
{
displayPeptideInfo(false, pep, results,
prot->getPeptideDuplicate(i) == ms_protein::DUPE_Duplicate,
prot->getPeptideIsBold(i),
prot->getPeptideShowCheckbox(i));
}
}
}
// Now display list of all proteins that contain a subset or a same set of the matching peptides
if ( (flags & ms_mascotresults::MSRES_GROUP_PROTEINS) || (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS) )
{
std::cout << "Proteins matching the same set of peptides:" << std::endl;
i = 1;
while ((prot = results->getNextSimilarProteinOf(accession.c_str(), dbIdx, i)) != 0)
{
std::string accession = prot->getAccession();
if (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS)
{
int dbIdx = prot->getDB();
if (dbIdx > 1)
{
std::cout << dbIdx << "::";
}
}
std::cout << accession.c_str()
<< " - Total score: " << prot->getScore()
<< " - Peptides matched: " << prot->getNumDisplayPeptides()
<< std::endl;
i++;
}
if (flags & ms_mascotresults::MSRES_SHOW_SUBSETS)
{
std::cout << "Proteins matching a subset of these peptides:" << std::endl;
i = 1;
while ((prot = results->getNextSubsetProteinOf(accession.c_str(), dbIdx, i)) != 0)
{
std::string accession = prot->getAccession();
int dbIdx = prot->getDB();
if ( (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS) && dbIdx > 1)
{
std::cout << dbIdx << "::";
}
std::cout << accession.c_str()
<< " - Total score: " << prot->getScore()
<< " - Peptides matched: " << prot->getNumDisplayPeptides()
<< std::endl;
if (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS)
{
int j = 1;
if (results->getNextSimilarProteinOf(accession.c_str(), dbIdx, j))
{
std::cout << " Proteins matching the same set of peptides for this subset:" << std::endl;
}
ms_protein * similar_subset_prot;
while ((similar_subset_prot =
results->getNextSimilarProteinOf(accession.c_str(), dbIdx, j)) != 0)
{
std::string similar_subset_accession = similar_subset_prot->getAccession();
int similar_subset_dbIdx = similar_subset_prot->getDB();
std::cout << " ";
if (similar_subset_dbIdx > 1)
{
std::cout << similar_subset_dbIdx << "::";
}
std::cout << similar_subset_accession.c_str()
<< " - Total score:" << similar_subset_prot->getScore()
<< " - Peptides matched: " << similar_subset_prot->getNumDisplayPeptides()
<< std::endl;
j++;
}
}
i++;
}
}
}
if (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS)
{
prot = results->getNextFamilyProtein(hit, family++);
if (!prot)
{
hit++;
prot = results->getHit(hit);
family = 1;
}
}
else
{
hit++;
prot = results->getHit(hit);
}
std::cout << std::endl;
}
results->createUnassignedList(ms_mascotresults::SCORE);
if (results->getNumberOfUnassigned())
{
std::cout << "Unassigned list" << std::endl
<< "---------------" << std::endl;
for (int u = 1; u <= results->getNumberOfUnassigned(); u++)
{
ms_peptide pep = results->getUnassigned(u);
displayPeptideInfo(false, &pep, results, false, true, true);
}
}
if (peptideSummary)
displayYellowPopupInfo(results, 1);
delete results;
return true;
}
/*****************************************************************************/
/* displayYellowPopupInfo */
/* Shows the equivalent of the yellow popup box for given query */
/*****************************************************************************/
static void displayYellowPopupInfo(ms_mascotresults * results, int q)
{
std::cout << "Score Delta Hit Protein Peptide" << std::endl;
int p;
for (p=1; p <= 10; p++)
{
ms_peptide pep = results->getPeptide(q, p);
std::string seq = pep.getPeptideStr();
if (!seq.empty())
{
std::string tmp = results->getProteinsWithThisPepMatch(q, p, true);
std::string hit = " ";
std::string protein = " ";
if (!tmp.empty())
{
hit = tmp.substr(0, tmp.find(':'));
std::string::size_type start = tmp.find(":\"");
if (start != tmp.rfind(":\""))
hit += "+";
protein = tmp.substr(2 + start, tmp.find("\" ") - start -2);
}
std::cout << pep.getIonsScore() << " "
<< pep.getDelta() << " "
<< hit << " "
<< protein << " "
<< pep.getPeptideStr() << std::endl;
}
}
p = 1;
std::cout << "Accessions that matched query " << q
<< " rank " << p << ":- "
<< results->getProteinsWithThisPepMatch(q, p)
<< std::endl << std::endl;
}
/*****************************************************************************/
/* displayPeptideInfo */
/* Shows information about a peptide */
/*****************************************************************************/
static void displayPeptideInfo(bool showFullDetails,
ms_peptide * p,
ms_mascotresults * r,
bool isDuplicate,
bool isBold,
bool showCheckBox)
{
int q = p->getQuery();
if (showFullDetails)
{
std::cout << "Peptide hit" << std::endl;
if (p->getAnyMatch())
{
std::cout << " Query : " << q << std::endl;
std::cout << " Rank : " << p->getRank() << std::endl;
std::cout << " Matched : " << p->getAnyMatch() << std::endl;
std::cout << " missedCleave: " << p->getMissedCleavages() << std::endl;
std::cout << " mrCalc : " << p->getMrCalc() << std::endl;
std::cout << " delta : " << p->getDelta() << std::endl;
std::cout << " observed : " << p->getObserved() << std::endl;
std::cout << " charge : " << p->getCharge() << std::endl;
std::cout << " mrExp : " << p->getMrExperimental() << std::endl;
std::cout << " ionsMatched : " << p->getNumIonsMatched() << std::endl;
std::cout << " peptideStr : " << p->getPeptideStr() << std::endl;
std::cout << " peaksUsed1 : " << p->getPeaksUsedFromIons1() << std::endl;
std::cout << " varModsStr : " << p->getVarModsStr() << std::endl;
std::cout << " readable mod: " << r->getReadableVarMods(q, p->getRank()) << std::endl;
std::cout << " tag matches : " << r->getTagString(q, 1) << std::endl;
std::cout << " first tag : 1:" << r->getTagStart(q,1,1)
<< ":" << r->getTagEnd(q,1,1)
<< ":" << r->getTagSeries(q,1,1) << std::endl;
std::cout << " etag drange : " << r->getTagDeltaRangeStart(q, 1)
<< "," << r->getTagDeltaRangeEnd(q, 1) << std::endl;
std::cout << " ionsScore : " << p->getIonsScore() << std::endl;
std::cout << " seriesUsed : " << p->getSeriesUsedStr() << std::endl;
std::cout << " peaksUsed2 : " << p->getPeaksUsedFromIons2() << std::endl;
std::cout << " peaksUsed3 : " << p->getPeaksUsedFromIons3() << std::endl;
std::cout << " idth, hth, p: "
<< r->getPeptideIdentityThreshold(q,20) << ", "
<< r->getHomologyThreshold(q, 20) << ", "
<< r->getProbOfPepBeingRandomMatch(p->getIonsScore(), q)
<< std::endl;
}
else
std::cout << " No match" << std::endl;
}
else
{
if (showCheckBox)
std::cout << "CB ";
else
std::cout << "-- ";
if (isBold)
std::cout << "BOLD ";
else
std::cout << "dim ";
std::cout << std::setiosflags(std::ios::left) << std::setw(4) << std::setfill(' ') << q;
std::cout << std::setiosflags(std::ios::left) << std::setw(11) << std::setfill(' ') << p->getObserved();
std::cout << std::setiosflags(std::ios::left) << std::setw(3) << std::setfill(' ') << p->getRank();
std::cout << "(";
std::cout << std::setiosflags(std::ios::left) << std::setw(3) << std::setfill(' ') << p->getPrettyRank();
std::cout << ")";
std::cout << std::setiosflags(std::ios::left) << std::setw(20) << std::setfill(' ') << p->getPeptideStr()
<< "\t";
if (isDuplicate)
std::cout << "(" << p->getIonsScore() << ")";
else
std::cout << p->getIonsScore();
std::cout << "\t";
std::cout << r->getReadableVarMods(q, p->getRank());
std::cout << std::endl;
}
}
/*****************************************************************************/
/* checkErrors */
/* Print errors and return false if a critical error occurred */
/*****************************************************************************/
static bool checkErrors(ms_mascotresfilebase & file)
{
if (file.getLastError())
{
for (int i=1; i <= file.getNumberOfErrors(); i++)
{
std::cout << "Error number: "
<< file.getErrorNumber(i)
<< " : "
<< file.getErrorString(i)
<< std::endl;
}
}
//Call isValid before clearAllErrors, otherwise this method always returns true
bool bIsValid = file.isValid();
file.clearAllErrors();
return bIsValid;
}
/*
will give the output:
-------------------------------------------------------------
--- Peptide summary report ---
-------------------------------------------------------------
Protein Hit 1
===================
Accession : Q9XZJ2
Description : HEAT SHOCK PROTEIN 70.- Crassostrea gigas (Pacific oyster).
Score : 286.477
Mass : 79480.1
Frame : 0
Coverage : 57
CB BOLD 1 671.9 1 (1 )DAGTISGLNVLR 95.12
CB BOLD 2 808.3 1 (1 )TTPSYVAFTDTER 74.55
CB BOLD 3 973.9 1 (1 )NQVAMNPNNTIFDAK 89.84
-- BOLD 4 1084.9 3 (3 )IINEPTAAAIAYGLDKK 30.07
Proteins matching the same set of peptides:
Q94805 Total score: 283.374
Proteins matching a subset of these peptides:
AAF09496 Total score: 211.927 Peptides matched: 3
BAB72169 Total score: 199.74 Peptides matched: 3
Q24789 Total score: 199.74 Peptides matched: 3
Q9I9Q5 Total score: 199.74 Peptides matched: 3
AAB93665 Total score: 196.637 Peptides matched: 3
Q9W6Y1 Total score: 196.637 Peptides matched: 3
Q95V47 Total score: 194.46 Peptides matched: 3
Q91993 Total score: 193.534 Peptides matched: 3
T45476 Total score: 191.357 Peptides matched: 3
O01948 Total score: 169.67 Peptides matched: 2
O97150 Total score: 166.567 Peptides matched: 2
AAA64872 Total score: 125.19 Peptides matched: 2
B44261 Total score: 125.19 Peptides matched: 2
P81159 Total score: 125.19 Peptides matched: 2
Q9NJ92 Total score: 125.19 Peptides matched: 2
Q9NJ93 Total score: 125.19 Peptides matched: 2
Q9PUF9 Total score: 125.19 Peptides matched: 2
S21175 Total score: 125.19 Peptides matched: 2
T45473 Total score: 125.19 Peptides matched: 2
JC4610 Total score: 122.087 Peptides matched: 2
O73788 Total score: 122.087 Peptides matched: 2
1ATR Total score: 104.62 Peptides matched: 2
1ATS Total score: 104.62 Peptides matched: 2
1BA0 Total score: 104.62 Peptides matched: 2
1BA1 Total score: 104.62 Peptides matched: 2
1BUPA Total score: 104.62 Peptides matched: 2
1HSC Total score: 104.62 Peptides matched: 2
1KAX Total score: 104.62 Peptides matched: 2
1KAY Total score: 104.62 Peptides matched: 2
1KAZ Total score: 104.62 Peptides matched: 2
1NGC Total score: 104.62 Peptides matched: 2
1NGD Total score: 104.62 Peptides matched: 2
1NGE Total score: 104.62 Peptides matched: 2
1NGF Total score: 104.62 Peptides matched: 2
1NGG Total score: 104.62 Peptides matched: 2
1NGH Total score: 104.62 Peptides matched: 2
1NGI Total score: 104.62 Peptides matched: 2
2BUPA Total score: 104.62 Peptides matched: 2
A25646 Total score: 104.62 Peptides matched: 2
A27077 Total score: 104.62 Peptides matched: 2
A35922 Total score: 104.62 Peptides matched: 2
A44985 Total score: 104.62 Peptides matched: 2
A45635 Total score: 104.62 Peptides matched: 2
A45935 Total score: 104.62 Peptides matched: 2
A48439 Total score: 104.62 Peptides matched: 2
AAA30130 Total score: 104.62 Peptides matched: 2
AAA30569 Total score: 104.62 Peptides matched: 2
AAA33009 Total score: 104.62 Peptides matched: 2
CAA81523 Total score: 104.62 Peptides matched: 2
HHKW7A Total score: 104.62 Peptides matched: 2
HHUM7B Total score: 104.62 Peptides matched: 2
JC2215 Total score: 104.62 Peptides matched: 2
JC4786 Total score: 104.62 Peptides matched: 2
JC5642 Total score: 104.62 Peptides matched: 2
O61003 Total score: 104.62 Peptides matched: 2
O61004 Total score: 104.62 Peptides matched: 2
O73885 Total score: 104.62 Peptides matched: 2
O76274 Total score: 104.62 Peptides matched: 2
O96541 Total score: 104.62 Peptides matched: 2
O96911 Total score: 104.62 Peptides matched: 2
P79984 Total score: 104.62 Peptides matched: 2
PQ0138 Total score: 104.62 Peptides matched: 2
Q27031 Total score: 104.62 Peptides matched: 2
Q43532 Total score: 104.62 Peptides matched: 2
Q93146 Total score: 104.62 Peptides matched: 2
Q93147 Total score: 104.62 Peptides matched: 2
Q94614 Total score: 104.62 Peptides matched: 2
Q95LN9 Total score: 104.62 Peptides matched: 2
Q9GPK0 Total score: 104.62 Peptides matched: 2
Q9GRE8 Total score: 104.62 Peptides matched: 2
Q9H3R6 Total score: 104.62 Peptides matched: 2
Q9M4E6 Total score: 104.62 Peptides matched: 2
Q9M6R1 Total score: 104.62 Peptides matched: 2
Q9NCC8 Total score: 104.62 Peptides matched: 2
Q9NGK9 Total score: 104.62 Peptides matched: 2
Q9NJB7 Total score: 104.62 Peptides matched: 2
Q9SAU8 Total score: 104.62 Peptides matched: 2
Q9TW75 Total score: 104.62 Peptides matched: 2
Q9U545 Total score: 104.62 Peptides matched: 2
Q9UAE9 Total score: 104.62 Peptides matched: 2
S07197 Total score: 104.62 Peptides matched: 2
S11456 Total score: 104.62 Peptides matched: 2
S27004 Total score: 104.62 Peptides matched: 2
S31716 Total score: 104.62 Peptides matched: 2
S36753 Total score: 104.62 Peptides matched: 2
S37165 Total score: 104.62 Peptides matched: 2
T21394 Total score: 104.62 Peptides matched: 2
T45478 Total score: 104.62 Peptides matched: 2
T45479 Total score: 104.62 Peptides matched: 2
A55719 Total score: 101.517 Peptides matched: 2
AAA37859 Total score: 101.517 Peptides matched: 2
AAD11466 Total score: 101.517 Peptides matched: 2
B36590 Total score: 101.517 Peptides matched: 2
B86295 Total score: 101.517 Peptides matched: 2
CAA33735 Total score: 101.517 Peptides matched: 2
HS74_YEAST Total score: 101.517 Peptides matched: 2
Q99KD7 Total score: 101.517 Peptides matched: 2
Q9TUG3 Total score: 101.517 Peptides matched: 2
Q9TX61 Total score: 101.517 Peptides matched: 2
S08211 Total score: 101.517 Peptides matched: 2
S10859 Total score: 101.517 Peptides matched: 2
AAA49563 Total score: 95.12 Peptides matched: 1
1HJOA Total score: 74.55 Peptides matched: 1
1NGA Total score: 74.55 Peptides matched: 1
1QQMA Total score: 74.55 Peptides matched: 1
1QQNA Total score: 74.55 Peptides matched: 1
1QQOA Total score: 74.55 Peptides matched: 1
A25773 Total score: 74.55 Peptides matched: 1
A29160 Total score: 74.55 Peptides matched: 1
A45871 Total score: 74.55 Peptides matched: 1
A48872 Total score: 74.55 Peptides matched: 1
A49242 Total score: 74.55 Peptides matched: 1
AAA03451 Total score: 74.55 Peptides matched: 1
AAA17441 Total score: 74.55 Peptides matched: 1
AAA57233 Total score: 74.55 Peptides matched: 1
AAA78276 Total score: 74.55 Peptides matched: 1
AAB03704 Total score: 74.55 Peptides matched: 1
AAD21815 Total score: 74.55 Peptides matched: 1
AAD21816 Total score: 74.55 Peptides matched: 1
AAL34314 Total score: 74.55 Peptides matched: 1
BAB72167 Total score: 74.55 Peptides matched: 1
BAB72168 Total score: 74.55 Peptides matched: 1
BAB72233 Total score: 74.55 Peptides matched: 1
BAB78505 Total score: 74.55 Peptides matched: 1
CAA52328 Total score: 74.55 Peptides matched: 1
E980236 Total score: 74.55 Peptides matched: 1
HS71_SCHPO Total score: 74.55 Peptides matched: 1
I37564 Total score: 74.55 Peptides matched: 1
I51129 Total score: 74.55 Peptides matched: 1
I54542 Total score: 74.55 Peptides matched: 1
JH0095 Total score: 74.55 Peptides matched: 1
JU0164 Total score: 74.55 Peptides matched: 1
O18474 Total score: 74.55 Peptides matched: 1
O73922 Total score: 74.55 Peptides matched: 1
PC1156 Total score: 74.55 Peptides matched: 1
Q26357 Total score: 74.55 Peptides matched: 1
Q26936 Total score: 74.55 Peptides matched: 1
Q26937 Total score: 74.55 Peptides matched: 1
Q63256 Total score: 74.55 Peptides matched: 1
Q63718 Total score: 74.55 Peptides matched: 1
Q98896 Total score: 74.55 Peptides matched: 1
Q98899 Total score: 74.55 Peptides matched: 1
Q98900 Total score: 74.55 Peptides matched: 1
Q98901 Total score: 74.55 Peptides matched: 1
Q9I8F9 Total score: 74.55 Peptides matched: 1
Q9IAC1 Total score: 74.55 Peptides matched: 1
Q9LU13 Total score: 74.55 Peptides matched: 1
Q9N1U2 Total score: 74.55 Peptides matched: 1
Q9NFT1 Total score: 74.55 Peptides matched: 1
Q9QWJ5 Total score: 74.55 Peptides matched: 1
S09036 Total score: 74.55 Peptides matched: 1
S25585 Total score: 74.55 Peptides matched: 1
S31766 Total score: 74.55 Peptides matched: 1
S37394 Total score: 74.55 Peptides matched: 1
S53357 Total score: 74.55 Peptides matched: 1
S67431 Total score: 74.55 Peptides matched: 1
T19211 Total score: 74.55 Peptides matched: 1
T22169 Total score: 74.55 Peptides matched: 1
T41121 Total score: 74.55 Peptides matched: 1
T43724 Total score: 74.55 Peptides matched: 1
T45468 Total score: 74.55 Peptides matched: 1
JQ1515 Total score: 71.4471 Peptides matched: 1
PC7036 Total score: 71.4471 Peptides matched: 1
Q9UVM0 Total score: 71.4471 Peptides matched: 1
A25089 Total score: 30.07 Peptides matched: 1
A32475 Total score: 30.07 Peptides matched: 1
A42582 Total score: 30.07 Peptides matched: 1
A48469 Total score: 30.07 Peptides matched: 1
AAA28075 Total score: 30.07 Peptides matched: 1
AAA34139 Total score: 30.07 Peptides matched: 1
AAA65099 Total score: 30.07 Peptides matched: 1
AAA92743 Total score: 30.07 Peptides matched: 1
AAA99920 Total score: 30.07 Peptides matched: 1
AAB06397 Total score: 30.07 Peptides matched: 1
AAB53051 Total score: 30.07 Peptides matched: 1
AAB63968 Total score: 30.07 Peptides matched: 1
AAF88019 Total score: 30.07 Peptides matched: 1
BAA13948 Total score: 30.07 Peptides matched: 1
BAB08435 Total score: 30.07 Peptides matched: 1
CAA02784 Total score: 30.07 Peptides matched: 1
CAA27330 Total score: 30.07 Peptides matched: 1
CAA28976 Total score: 30.07 Peptides matched: 1
CAA31393 Total score: 30.07 Peptides matched: 1
CAA31663 Total score: 30.07 Peptides matched: 1
CAA54419 Total score: 30.07 Peptides matched: 1
CAC84456 Total score: 30.07 Peptides matched: 1
D44261 Total score: 30.07 Peptides matched: 1
D90093 Total score: 30.07 Peptides matched: 1
H96605 Total score: 30.07 Peptides matched: 1
HHBYA1 Total score: 30.07 Peptides matched: 1
HS71_CANAL Total score: 30.07 Peptides matched: 1
HS71_PICAN Total score: 30.07 Peptides matched: 1
HS71_YEAST Total score: 30.07 Peptides matched: 1
HS72_PICAN Total score: 30.07 Peptides matched: 1
HS72_YEAST Total score: 30.07 Peptides matched: 1
HS7E_SPIOL Total score: 30.07 Peptides matched: 1
JC7132 Total score: 30.07 Peptides matched: 1
JQ0966 Total score: 30.07 Peptides matched: 1
O45038 Total score: 30.07 Peptides matched: 1
O48563 Total score: 30.07 Peptides matched: 1
O62564 Total score: 30.07 Peptides matched: 1
O65171 Total score: 30.07 Peptides matched: 1
O76306 Total score: 30.07 Peptides matched: 1
O93935 Total score: 30.07 Peptides matched: 1
O94104 Total score: 30.07 Peptides matched: 1
O94106 Total score: 30.07 Peptides matched: 1
P90655 Total score: 30.07 Peptides matched: 1
P91738 Total score: 30.07 Peptides matched: 1
P97966 Total score: 30.07 Peptides matched: 1
Q05829 Total score: 30.07 Peptides matched: 1
Q17310 Total score: 30.07 Peptides matched: 1
Q23712 Total score: 30.07 Peptides matched: 1
Q24895 Total score: 30.07 Peptides matched: 1
Q24928 Total score: 30.07 Peptides matched: 1
Q24952 Total score: 30.07 Peptides matched: 1
Q27078 Total score: 30.07 Peptides matched: 1
Q27121 Total score: 30.07 Peptides matched: 1
Q27146 Total score: 30.07 Peptides matched: 1
Q27147 Total score: 30.07 Peptides matched: 1
Q40924 Total score: 30.07 Peptides matched: 1
Q91624 Total score: 30.07 Peptides matched: 1
Q943K7 Total score: 30.07 Peptides matched: 1
Q94439 Total score: 30.07 Peptides matched: 1
Q961X6 Total score: 30.07 Peptides matched: 1
Q96IS6 Total score: 30.07 Peptides matched: 1
Q96W30 Total score: 30.07 Peptides matched: 1
Q9ATB8 Total score: 30.07 Peptides matched: 1
Q9DC27 Total score: 30.07 Peptides matched: 1
Q9FSY7 Total score: 30.07 Peptides matched: 1
Q9GPM5 Total score: 30.07 Peptides matched: 1
Q9GTX3 Total score: 30.07 Peptides matched: 1
Q9LHA8 Total score: 30.07 Peptides matched: 1
Q9M4E7 Total score: 30.07 Peptides matched: 1
Q9M4E8 Total score: 30.07 Peptides matched: 1
Q9NAX9 Total score: 30.07 Peptides matched: 1
Q9NCC9 Total score: 30.07 Peptides matched: 1
Q9NCD0 Total score: 30.07 Peptides matched: 1
Q9NCD1 Total score: 30.07 Peptides matched: 1
Q9NCD2 Total score: 30.07 Peptides matched: 1
Q9NCD3 Total score: 30.07 Peptides matched: 1
Q9NCD4 Total score: 30.07 Peptides matched: 1
Q9NCD5 Total score: 30.07 Peptides matched: 1
Q9NCD6 Total score: 30.07 Peptides matched: 1
Q9NCD7 Total score: 30.07 Peptides matched: 1
Q9NCD8 Total score: 30.07 Peptides matched: 1
Q9NCD9 Total score: 30.07 Peptides matched: 1
Q9NCE0 Total score: 30.07 Peptides matched: 1
Q9NHB4 Total score: 30.07 Peptides matched: 1
Q9P8E0 Total score: 30.07 Peptides matched: 1
Q9U540 Total score: 30.07 Peptides matched: 1
Q9ZS55 Total score: 30.07 Peptides matched: 1
S03250 Total score: 30.07 Peptides matched: 1
S14949 Total score: 30.07 Peptides matched: 1
S14950 Total score: 30.07 Peptides matched: 1
S18181 Total score: 30.07 Peptides matched: 1
S20139 Total score: 30.07 Peptides matched: 1
S21879 Total score: 30.07 Peptides matched: 1
S21880 Total score: 30.07 Peptides matched: 1
S24782 Total score: 30.07 Peptides matched: 1
S41372 Total score: 30.07 Peptides matched: 1
S42488 Total score: 30.07 Peptides matched: 1
S44168 Total score: 30.07 Peptides matched: 1
S46302 Total score: 30.07 Peptides matched: 1
S49303 Total score: 30.07 Peptides matched: 1
S51682 Total score: 30.07 Peptides matched: 1
S51712 Total score: 30.07 Peptides matched: 1
S53126 Total score: 30.07 Peptides matched: 1
S71171 Total score: 30.07 Peptides matched: 1
T03581 Total score: 30.07 Peptides matched: 1
T04078 Total score: 30.07 Peptides matched: 1
T04080 Total score: 30.07 Peptides matched: 1
T06358 Total score: 30.07 Peptides matched: 1
T06598 Total score: 30.07 Peptides matched: 1
T15513 Total score: 30.07 Peptides matched: 1
T34037 Total score: 30.07 Peptides matched: 1
T45298 Total score: 30.07 Peptides matched: 1
T45474 Total score: 30.07 Peptides matched: 1
T45475 Total score: 30.07 Peptides matched: 1
T45477 Total score: 30.07 Peptides matched: 1
T45517 Total score: 30.07 Peptides matched: 1
T45522 Total score: 30.07 Peptides matched: 1
T46574 Total score: 30.07 Peptides matched: 1
T46650 Total score: 30.07 Peptides matched: 1
T48270 Total score: 30.07 Peptides matched: 1
T48271 Total score: 30.07 Peptides matched: 1
AAB08760 Total score: 26.9671 Peptides matched: 1
AAC05418 Total score: 26.9671 Peptides matched: 1
AAF23276 Total score: 26.9671 Peptides matched: 1
P93937 Total score: 26.9671 Peptides matched: 1
Q91688 Total score: 26.9671 Peptides matched: 1
Q9NCC5 Total score: 26.9671 Peptides matched: 1
Q9NCC6 Total score: 26.9671 Peptides matched: 1
Q9NCC7 Total score: 26.9671 Peptides matched: 1
Protein Hit 2
===================
Accession : S14992
Description : dnaK-type molecular chaperone hsp70 - soybean
Score : 166.04
Mass : 78349.7
Frame : 0
Coverage : 45
-- dim 2 808.3 1 (1 )TTPSYVAFTDTER 74.55
-- dim 3 973.9 2 (2 )NQVAMNPQNTVFDAK 61.42
-- dim 4 1084.9 3 (3 )IINEPTAAAIAYGLDKK 30.07
Proteins matching the same set of peptides:
S53498 Total score: 166.04
Proteins matching a subset of these peptides:
AAA74906 Total score: 135.97 Peptides matched: 2
B45871 Total score: 135.97 Peptides matched: 2
HHXL70 Total score: 135.97 Peptides matched: 2
I49761 Total score: 135.97 Peptides matched: 2
O75634 Total score: 135.97 Peptides matched: 2
O88686 Total score: 135.97 Peptides matched: 2
Q96QC9 Total score: 135.97 Peptides matched: 2
Q9R2A1 Total score: 135.97 Peptides matched: 2
S21365 Total score: 135.97 Peptides matched: 2
S41415 Total score: 135.97 Peptides matched: 2
AAA27868 Total score: 61.42 Peptides matched: 1
Q17228 Total score: 61.42 Peptides matched: 1
Q17289 Total score: 61.42 Peptides matched: 1
Q27379 Total score: 61.42 Peptides matched: 1
A34041 Total score: 58.3171 Peptides matched: 1
Protein Hit 3
===================
Accession : A36333
Description : dnaK-type molecular chaperone Hsc70-4 - fruit fly (Drosophila melanogaster)
Score : 147.45
Mass : 77814.5
Frame : 0
Coverage : 45
-- dim 2 808.3 1 (1 )TTPSYVAFTDTER 74.55
-- dim 3 973.9 3 (3 )NQVAMNPTQTIFDAK 42.83
-- dim 4 1084.9 3 (3 )IINEPTAAAIAYGLDKK 30.07
Proteins matching the same set of peptides:
AAF55150 Total score: 147.45
Proteins matching a subset of these peptides:
Protein Hit 4
===================
Accession : A03309
Description : dnaK-type molecular chaperone Dsim/Hsc70-1 - fruit fly (Drosophila simulans) (fragments)
Score : 147.03
Mass : 25558.9
Frame : 0
Coverage : 28
-- dim 2 808.3 3 (3 )TTPSYVAFTESER 57.19
-- dim 3 973.9 1 (1 )NQVAMNPNNTIFDAK 89.84
Proteins matching the same set of peptides:
AAA28632 Total score: 147.03
JN0668 Total score: 143.927
Proteins matching a subset of these peptides:
B03309 Total score: 57.19 Peptides matched: 1
Q9BIS1 Total score: 57.19 Peptides matched: 1
Q9BIS3 Total score: 57.19 Peptides matched: 1
Protein Hit 5
===================
Accession : Q95PU3
Description : HEAT SHOCK PROTEIN (HSP70).- Euplotes crassus.
Score : 113.66
Mass : 80429.7
Frame : 0
Coverage : 30
-- dim 2 808.3 1 (1 )TTPSYVAFTDTER 74.55
CB dim 4 1084.9 1 (1 )IIIEPTAAAIAYGLDKK 39.11
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Protein Hit 6
===================
Accession : 1NGB
Description : Heat-shock cognate 70kd protein (44kd atpase n-terminal Fragment) (EC 3.6.1.3) mutant with glu 175 replace
d by Gln (e175q) - bovine
Score : 109.89
Mass : 45220.2
Frame : 0
Coverage : 30
-- dim 2 808.3 1 (1 )TTPSYVAFTDTER 74.55
-- dim 4 1084.9 2 (2 )IINQPTAAAIAYGLDKK 35.34
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Protein Hit 7
===================
Accession : O61226
Description :
Score : 90.71
Mass : 0
Frame : 0
Coverage : 30
-- dim 2 808.3 2 (2 )TTPSYVAFTNTER 60.64
-- dim 4 1084.9 3 (3 )IINEPTAAAIAYGLDKK 30.07
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Protein Hit 8
===================
Accession : P87036
Description :
Score : 81.27
Mass : 0
Frame : 0
Coverage : 29
-- dim 1 671.9 3 (3 )DAGTIAGLEVLR 51.2
-- dim 4 1084.9 3 (3 )IINEPTAAAIAYGLDKK 30.07
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
A25398 Total score: 51.2 Peptides matched: 1
AAA30204 Total score: 51.2 Peptides matched: 1
AG2111 Total score: 51.2 Peptides matched: 1
CAB59514 Total score: 51.2 Peptides matched: 1
O76958 Total score: 51.2 Peptides matched: 1
S06158 Total score: 51.2 Peptides matched: 1
S74372 Total score: 51.2 Peptides matched: 1
A45515 Total score: 48.0971 Peptides matched: 1
CAA36551 Total score: 48.0971 Peptides matched: 1
Q94594 Total score: 48.0971 Peptides matched: 1
Q9GYW3 Total score: 48.0971 Peptides matched: 1
Q9HG01 Total score: 48.0971 Peptides matched: 1
S11448 Total score: 48.0971 Peptides matched: 1
S52727 Total score: 48.0971 Peptides matched: 1
Score Delta Hit Protein Peptide
Accessions that matched query 97 rank 1:-
*/
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_errors::clearAllErrors
void clearAllErrors()
Remove all errors from the current list of errors.
Definition: ms_errors.cpp:1457
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresfilebase::getErrorNumber
int getErrorNumber(const int num=-1) const
Return a specific error number - or ms_errs::ERR_NO_ERROR.
Definition: ms_mascotresfilebase.cpp:776
matrix_science::ms_mascotresfilebase::getLastError
int getLastError() const
Return the last error number - or ms_erros::ERR_NO_ERROR.
Definition: ms_mascotresfilebase.cpp:786
matrix_science::ms_mascotresfilebase::get_ms_mascotresults_params
std::string get_ms_mascotresults_params(const ms_mascotoptions &opts, ms_mascotresults_params &params) const
Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.
Definition: ms_mascotresfilebase.cpp:1380
matrix_science::ms_mascotresfilebase::getErrorString
std::string getErrorString(const int num) const
Return a specific error as a string.
Definition: ms_mascotresfilebase.cpp:814
matrix_science::ms_mascotresfilebase::getNumberOfErrors
int getNumberOfErrors() const
Return the number of errors since the last call to clearAllErrors.
Definition: ms_mascotresfilebase.cpp:749
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_mascotresults::getTagStart
virtual int getTagStart(const int q, const int p, const int tagNumber) const
Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.
Definition: ms_mascotresults.cpp:2174
matrix_science::ms_mascotresults::getProteinDescription
std::string getProteinDescription(const char *accession, const int dbIdx=1) const
Return protein description if available.
Definition: ms_mascotresults.cpp:243
matrix_science::ms_mascotresults::getProteinMass
double getProteinMass(const char *accession, const int dbIdx=1) const
Return protein mass if available.
Definition: ms_mascotresults.cpp:299
matrix_science::ms_mascotresults::getNextFamilyProtein
virtual ms_protein * getNextFamilyProtein(const int masterHit, const int id) const
Find the next protein in the family masterHit.
Definition: ms_mascotresults.cpp:1144
matrix_science::ms_mascotresults::getPeptideIdentityThreshold
virtual int getPeptideIdentityThreshold(const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the threshold value for this ms-ms data being a random match.
Definition: ms_mascotresults.cpp:605
matrix_science::ms_mascotresults::getPeptide
virtual ms_peptide getPeptide(const int q, const int p) const =0
Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_p...
matrix_science::ms_mascotresults::getTagDeltaRangeEnd
virtual int getTagDeltaRangeEnd(const int q, const int p) const =0
Return the second number from h1_q2_drange=0,256.
matrix_science::ms_mascotresults::getNextSimilarProteinOf
virtual ms_protein * getNextSimilarProteinOf(const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
Definition: ms_mascotresults.cpp:1122
matrix_science::ms_mascotresults::getTagString
virtual std::string getTagString(const int q, const int p) const =0
Return the complete tag string from h1_q2_tag or q1_p1_tag.
matrix_science::ms_mascotresults::getNumberOfUnassigned
int getNumberOfUnassigned() const
Return the number of peptides in the unassigned list.
Definition: ms_mascotresults.cpp:2316
matrix_science::ms_mascotresults::getNextSubsetProteinOf
virtual ms_protein * getNextSubsetProteinOf(const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains some of the peptides in the 'master' protein.
Definition: ms_mascotresults.cpp:1193
matrix_science::ms_mascotresults::createUnassignedList
bool createUnassignedList(sortBy s=QUERY)
To have a list of unassigned peptides, need to call this first.
Definition: ms_mascotresults.cpp:2295
matrix_science::ms_mascotresults::getTagDeltaRangeStart
virtual int getTagDeltaRangeStart(const int q, const int p) const =0
Return the first number from h1_q2_drange=0,256.
matrix_science::ms_mascotresults::getTagSeries
virtual int getTagSeries(const int q, const int p, const int tagNumber) const
Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.
Definition: ms_mascotresults.cpp:2257
matrix_science::ms_mascotresults::getProbOfPepBeingRandomMatch
virtual double getProbOfPepBeingRandomMatch(const double score, const int query) const
Definition: ms_mascotresults.cpp:901
matrix_science::ms_mascotresults::getHomologyThreshold
virtual int getHomologyThreshold(const int query, double OneInXprobRnd, const int rank=1) const
Returns the 'homology' threshold.
Definition: ms_mascotresults.cpp:828
matrix_science::ms_mascotresults::getUnassigned
ms_peptide getUnassigned(const int num) const
Need to call createUnassignedList() before calling this.
Definition: ms_mascotresults.cpp:2337
matrix_science::ms_mascotresults::getHit
virtual ms_protein * getHit(const int hit, const int memberNumber=0) const
Return the ms_protein hit - returns null if hit > number of hits.
Definition: ms_mascotresults.cpp:1030
matrix_science::ms_mascotresults::getTagEnd
virtual int getTagEnd(const int q, const int p, const int tagNumber) const
Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.
Definition: ms_mascotresults.cpp:2197
matrix_science::ms_mascotresults::getProteinsWithThisPepMatch
virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false)=0
Return a partial list of proteins that matched the same peptide.
matrix_science::ms_mascotresults::getReadableVarMods
virtual std::string getReadableVarMods(const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return a 'human readable' string with the variable, summed and error tolerant mods.
Definition: ms_mascotresults.cpp:1608
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::getPrettyRank
int getPrettyRank() const
Similar to getRank() except that equivalent scores get the same rank.
Definition: ms_peptide.cpp:517
matrix_science::ms_peptide::getRank
int getRank() const
Return the 'rank' of the peptide match.
Definition: ms_peptide.cpp:458
matrix_science::ms_peptide::getMissedCleavages
int getMissedCleavages(const PSM psmComponent=PSM_COMPLETE) const
Returns the number of missed cleavages.
Definition: ms_peptide.cpp:583
matrix_science::ms_peptide::getAnyMatch
bool getAnyMatch() const
Returns true if there was a peptide match to this spectrum.
Definition: ms_peptide.cpp:557
matrix_science::ms_peptide::getVarModsStr
std::string getVarModsStr(const PSM psmComponent=PSM_COMPLETE) const
Variable modifications as a string of digits.
Definition: ms_peptide.cpp:834
matrix_science::ms_peptide::getNumIonsMatched
int getNumIonsMatched() const
Returns the number of ions matched.
Definition: ms_peptide.cpp:685
matrix_science::ms_peptide::getPeaksUsedFromIons1
int getPeaksUsedFromIons1() const
Returns number of peaks used from ions1.
Definition: ms_peptide.cpp:748
matrix_science::ms_peptide::getCharge
int getCharge() const
Returns the charge state for the parent mass.
Definition: ms_peptide.cpp:658
matrix_science::ms_peptide::getSeriesUsedStr
std::string getSeriesUsedStr() const
Returns the series used as a string.
Definition: ms_peptide.cpp:1100
matrix_science::ms_peptide::getObserved
double getObserved() const
Returns the observed mass / charge value.
Definition: ms_peptide.cpp:629
matrix_science::ms_peptide::getDelta
double getDelta() const
Returns the difference between the calculated and experimental relative masses.
Definition: ms_peptide.cpp:619
matrix_science::ms_peptide::getMrExperimental
double getMrExperimental() const
Returns the observed mz value as a relative mass.
Definition: ms_peptide.cpp:644
matrix_science::ms_peptide::getPeaksUsedFromIons2
int getPeaksUsedFromIons2() const
Returns number of peaks used from ions2.
Definition: ms_peptide.cpp:774
matrix_science::ms_peptide::getIonsScore
double getIonsScore() const
Returns the ions score.
Definition: ms_peptide.cpp:1050
matrix_science::ms_peptide::getMrCalc
double getMrCalc(const PSM psmComponent=PSM_COMPLETE) const
Returns the calculated relative mass for this peptide .
Definition: ms_peptide.cpp:610
matrix_science::ms_peptide::getPeptideStr
std::string getPeptideStr(bool substituteAmbiguous=true, const PSM psmComponent=PSM_COMPLETE) const
Returns the sequence found for the peptide.
Definition: ms_peptide.cpp:710
matrix_science::ms_peptide::getQuery
int getQuery() const
Each peptide is associate with a query.
Definition: ms_peptide.cpp:441
matrix_science::ms_peptide::getPeaksUsedFromIons3
int getPeaksUsedFromIons3() const
Returns number of peaks used from ions3.
Definition: ms_peptide.cpp:800
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_protein::getScore
double getScore() const
Return the protein score for this protein.
Definition: ms_protein.cpp:574
matrix_science::ms_protein::getNumPeptides
int getNumPeptides() const
Return the number of peptides that had a match in this protein.
Definition: ms_protein.cpp:621
matrix_science::ms_protein::getNumDisplayPeptides
int getNumDisplayPeptides(bool aboveThreshold=false) const
Return the number of peptides excluding those that with duplicate matches to same query.
Definition: ms_protein.cpp:1587
matrix_science::ms_protein::getPeptideDuplicate
DUPLICATE getPeptideDuplicate(const int pepNumber, const bool allowErrTolDuplicate=true) const
Return the DUPLICATE status given the peptide 'number'.
Definition: ms_protein.cpp:966
matrix_science::ms_protein::getPeptideP
int getPeptideP(const int pepNumber) const
Return the 'rank' number given the peptide 'number'.
Definition: ms_protein.cpp:751
matrix_science::ms_protein::getPeptideQuery
int getPeptideQuery(const int pepNumber) const
Return the query number given the peptide 'number'.
Definition: ms_protein.cpp:727
matrix_science::ms_protein::getDB
int getDB() const
Return the index of the database where the sequence is found.
Definition: ms_protein.cpp:494
matrix_science::ms_protein::getPeptideIsBold
bool getPeptideIsBold(const int pepNumber) const
Returns true if this peptide should be displayed in bold in a Mascot report.
Definition: ms_protein.cpp:1448
matrix_science::ms_protein::getAccession
std::string getAccession() const
Return the accession string for a protein.
Definition: ms_protein.cpp:479
matrix_science::ms_protein::getPeptideShowCheckbox
bool getPeptideShowCheckbox(const int pepNumber) const
Returns true if a check box for repeat searches should be shown in a Mascot report.
Definition: ms_protein.cpp:1490
matrix_science::ms_protein::getFrame
int getFrame() const
Returns the frame number for the protein.
Definition: ms_protein.cpp:1403
matrix_science::ms_protein::getCoverage
long getCoverage() const
Return the number of residues covered.
Definition: ms_protein.cpp:1244
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_summary.java

resfile_summary.java

Example program for extracting the peptide or protein summary.

/*
##############################################################################
# file: resfile_summary.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_java/resfile_summary.java $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
// Note - uses java.util.regex - some lines will need to be commented out
// before this will work on JDK versions older than 1.4. There are marked
// in the code
import java.util.Date;
import matrix_science.msparser.*;
import java.util.regex.*; // comment out if using version of JDK prior to 1.4
import java.io.File;
public class resfile_summary {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
int returnValue = -1;
// ----- Object creation -----
if (argv.length < 1) {
System.out.println("Must specify results filename as parameter");
System.exit(returnValue);
}
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(argv[0]);
if (checkErrors(file)) {
/*
* The parameters passed to ms_peptidesummary or ms_proteinsummary determine
* the type of grouping and the number of proteins and peptides displayed.
* Default parameters can be returned using ms_mascotresfilebase::get_ms_mascotresults_params().
* The return values from this function depend on the type of search,
* and also on values in the mascot.dat configuration file if that is available.
*/
ms_datfile datfile = new ms_datfile("../config/mascot.dat"); //You may need to change this path
//if the mascot.dat isn't available, use defaults
ms_mascotoptions mascotOptions = new ms_mascotoptions();
if (datfile.isValid())
{
mascotOptions = datfile.getMascotOptions();
}
boolean[] usePeptideSummary = {false};
long[] flags = {0};
double[] minProbability = {0};
int[] maxHitsToReport = {0};
double[] ignoreIonsScoreBelow = {0};
long[] minPepLenInPepSummary = {0};
long[] flags2 = {0};
String scriptName = file.get_ms_mascotresults_params(
mascotOptions,
flags,
minProbability,
maxHitsToReport,
ignoreIonsScoreBelow,
minPepLenInPepSummary,
usePeptideSummary,
flags2
);
boolean bResult;
if (usePeptideSummary[0]) {
/*
* For peptide summary
*
* Flags defined for hierarchical clustering algorithm:
* flags: ms_mascotresults::MSRES_CLUSTER_PROTEINS
* | ms_mascotresults::MSRES_SHOW_SUBSETS
* | ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE;
* flags2: ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH;
*
* Flags defined for original simple parsimony algorithm:
* flags: ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS;
*/
System.out.println("-------------------------------------------------------------");
System.out.println("--- Peptide summary report ---");
System.out.println("-------------------------------------------------------------");
bResult = showResults(file,
usePeptideSummary[0],
(int)flags[0],
minProbability[0],
maxHitsToReport[0],
"", // Unigene file name
ignoreIonsScoreBelow[0],
(int)minPepLenInPepSummary[0],
(int)flags2[0]
);
} else {
// Show results from full protein summary, remove grouping
flags[0] &= ~ms_mascotresults.MSRES_GROUP_PROTEINS;
flags[0] &= ~ms_mascotresults.MSRES_SHOW_SUBSETS;
System.out.println("-------------------------------------------------------------");
System.out.println("--- Full Protein summary report ---");
System.out.println("-------------------------------------------------------------");
bResult = showResults(file,
usePeptideSummary[0],
(int)flags[0],
minProbability[0],
maxHitsToReport[0],
"", // Unigene file name
ignoreIonsScoreBelow[0],
(int)minPepLenInPepSummary[0],
(int)flags2[0]
);
if(bResult && checkErrors(file)) {
System.out.println();
// Show results from concise protein summary, add grouping
flags[0] |= ms_mascotresults.MSRES_GROUP_PROTEINS;
flags[0] |= ms_mascotresults.MSRES_SHOW_SUBSETS;
System.out.println("-------------------------------------------------------------");
System.out.println("--- Concise Protein summary report ---");
System.out.println("-------------------------------------------------------------");
bResult = showResults(file,
usePeptideSummary[0],
(int)flags[0],
minProbability[0],
maxHitsToReport[0],
"", // Unigene file name
ignoreIonsScoreBelow[0],
(int)minPepLenInPepSummary[0],
(int)flags2[0]
);
}
}
if (bResult && checkErrors(file)) {
returnValue = 0;
}
}
System.exit(returnValue);
}
private static boolean showResults(ms_mascotresfilebase file,
boolean pepSum,
int flags,
double minProteinProb,
int maxHits,
String unigeneFile,
double minIonsScore,
int minPepLenInPepSummary,
int flags2){
ms_mascotresults results=null;
int family;
int hit;
ms_protein prot;
String accession;
String description;
double mass;
int dbIdx;
int num_peps;
int i;
int query;
int p;
int u;
ms_peptide pep;
if(pepSum) {
results = new ms_peptidesummary(file,
flags,
minProteinProb,
maxHits,
unigeneFile,
minIonsScore,
minPepLenInPepSummary,
null,
flags2);
} else {
results = new ms_proteinsummary(file,
flags,
minProteinProb,
maxHits,
null,
null);
}
//Stop there is any fatal error occurred
if (!checkErrors(file))
{
return false;
}
if (results.isNA())
System.out.println("Nucleic acid database\n");
else
System.out.println("Amino acid database ");
// get hit one
family = 1;
hit = 1;
prot = results.getHit(hit);
while(hit <= results.getNumberOfHits()) {
accession = prot.getAccession();
description = results.getProteinDescription(accession);
mass = results.getProteinMass(accession);
dbIdx = prot.getDB();
String protein_hit = "Protein Hit " + hit;
if((flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS) {
protein_hit += "." + family;
}
System.out.println(protein_hit+"\n===================");
System.out.println("Accession : "+accession);
System.out.println("Description : "+description);
System.out.println("Score : "+roundWholeNumber(prot.getScore()));
System.out.println("Mass : "+mass);
System.out.println("Frame : "+prot.getFrame());
System.out.println("Coverage : "+prot.getCoverage());
System.out.println("RMS error : "+prot.getRMSDeltas(results));
System.out.println("Peptides : "+prot.getNumDisplayPeptides());
// Each protein has a number of peptides that matched - list them
num_peps = prot.getNumPeptides();
for(i=1; i <= num_peps; i++) {
query = prot.getPeptideQuery(i);
p = prot.getPeptideP(i);
if((p != -1) && (query != -1) && (prot.getPeptideDuplicate(i) !=
ms_protein.DUPE_DuplicateSameQuery)) {
pep = results.getPeptide(query,p);
if(pep != null) {
displayPeptideInfo(false,pep,results,prot.getPeptideDuplicate(i)
== ms_protein.DUPE_Duplicate, prot.getPeptideIsBold(i),
prot.getPeptideShowCheckbox(i));
}
}
}
// Now display list of all proteins that contain a subset or a same set of the matching peptides
if((flags & ms_mascotresults.MSRES_GROUP_PROTEINS) == ms_mascotresults.MSRES_GROUP_PROTEINS
|| (flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS) {
System.out.println("Proteins matching the same set of peptides:");
i = 1;
while((prot = results.getNextSimilarProteinOf(accession, dbIdx, i)) != null) {
String similar_accession = prot.getAccession();
int similar_dbIdx = prot.getDB();
if((flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS
&& similar_dbIdx > 1) {
System.out.print(similar_dbIdx + "::");
}
System.out.print(similar_accession + " - Total score: " + roundWholeNumber(prot.getScore()));
System.out.println(" - Peptides matched: " + prot.getNumDisplayPeptides());
i++;
}
if((flags & ms_mascotresults.MSRES_SHOW_SUBSETS) == ms_mascotresults.MSRES_SHOW_SUBSETS) {
System.out.println("Proteins matching a subset of these peptides:");
i = 1;
while((prot = results.getNextSubsetProteinOf(accession, dbIdx, i)) != null) {
String subset_accession = prot.getAccession();
int subset_dbIdx = prot.getDB();
if((flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS
&& subset_dbIdx > 1) {
System.out.print(subset_dbIdx + "::");
}
System.out.print(subset_accession + " - Total score: " + roundWholeNumber(prot.getScore()));
System.out.println(" - Peptides matched: " + prot.getNumDisplayPeptides());
if((flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS) {
int j = 1;
if(results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j) != null) {
System.out.println(" Proteins matching the same set of peptides for this subset:");
}
ms_protein similar_subset_prot;
while((similar_subset_prot = results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j)) != null) {
String similar_subset_accession = similar_subset_prot.getAccession();
int similar_subset_dbIdx = similar_subset_prot.getDB();
System.out.print(" ");
if(similar_subset_dbIdx > 1) {
System.out.print(similar_subset_dbIdx + "::");
}
System.out.print(similar_subset_accession + " - Total score: " + roundWholeNumber(similar_subset_prot.getScore()));
System.out.println(" - Peptides matched: " + similar_subset_prot.getNumDisplayPeptides());
j++;
}
}
i++;
}
}
}
if((flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS) {
prot = results.getNextFamilyProtein(hit, family++);
if(prot == null) {
hit++;
prot = results.getHit(hit);
family = 1;
}
} else {
hit++;
prot = results.getHit(hit);
}
System.out.println("\n");
}
results.createUnassignedList(ms_mascotresults.SCORE);
if(results.getNumberOfUnassigned() > 0) {
System.out.println("Unassigned list");
System.out.println("---------------");
for(u=1; u <= results.getNumberOfUnassigned(); u++) {
pep = results.getUnassigned(u);
displayPeptideInfo(false, pep, results, false, true, true);
}
}
if(pepSum) displayYellowPopupInfo(results,97);
return true;
}
private static void displayYellowPopupInfo (ms_mascotresults results, int queryNo) {
int p;
ms_peptide pep;
String seq;
String tmp;
String hit;
String protein;
String morethan="";
System.out.println("Score Delta Hit Protein Peptide");
for(p=1; p <= 10; p++) {
pep = results.getPeptide(queryNo,p);
if(pep != null) {
seq = pep.getPeptideStr();
if(!(seq.equals(""))) {
tmp = results.getProteinsWithThisPepMatch(queryNo,p,true);
hit = " ";
protein = " ";
// comment from here
if(!(tmp.equals(""))) {
// uses Java 1.4 regex
String regex = "(\\d):([^ ]*)[ ]*(.*)";
Pattern pat = Pattern.compile(regex);
Matcher m = pat.matcher(tmp);
if(m.matches()) {
int groupCount = m.groupCount();
if (groupCount >= 1) hit = m.group(1);
if (groupCount >= 2) protein = m.group(2);
if (groupCount >= 3) morethan = m.group(3);
}
if(!(morethan.equals(""))) {
hit = hit+"+";
}
}
// to here out if using versions of java prior to 1.4
System.out.print(pep.getIonsScore()+ " "+ pep.getDelta()+ " ");
System.out.println(hit+ " "+ protein+ " "+ pep.getPeptideStr());
}
}
}
p=1;
System.out.println("Accessions that matched query "+ queryNo+ " rank "
+ p+ ":- "+results.getProteinsWithThisPepMatch(queryNo,p, false));
}
private static void displayPeptideInfo(boolean showFullDetails, ms_peptide p,
ms_mascotresults r,
boolean isDuplicate,
boolean isBold,
boolean showCheckBox) {
int q;
q=p.getQuery();
if(showFullDetails) {
System.out.println("Peptide hit");
if(p.getAnyMatch()) {
System.out.println(" Query : "+q);
System.out.println(" Rank : "+p.getRank());
System.out.println(" Matched : "+p.getAnyMatch());
System.out.println(" missedCleave: "+p.getMissedCleavages());
System.out.println(" mrCalc : "+p.getMrCalc());
System.out.println(" delta : "+p.getDelta());
System.out.println(" observed : "+p.getObserved());
System.out.println(" charge : "+p.getCharge());
System.out.println(" mrExp : "+p.getMrExperimental());
System.out.println(" ionsMatched : "+p.getNumIonsMatched());
System.out.println(" peptideStr : "+p.getPeptideStr());
System.out.println(" peaksUsed1 : "+p.getPeaksUsedFromIons1());
System.out.println(" varModsStr : "+p.getVarModsStr());
System.out.println(" readable mod: "+r.getReadableVarMods(q, p.getRank(),2));
System.out.println(" ionsScore : "+p.getIonsScore());
System.out.println(" seriesUsedS : "+p.getSeriesUsedStr());
System.out.println(" peaksUsed2 : "+p.getPeaksUsedFromIons2());
System.out.println(" peaksUsed3 : "+p.getPeaksUsedFromIons3());
System.out.print(" idth, hth, p: " +r.getPeptideIdentityThreshold(q,20));
System.out.print(", " +r.getHomologyThreshold(q,20));
System.out.println(", " +r.getProbOfPepBeingRandomMatch(p.getIonsScore(),q));
System.out.println();
} else {
System.out.println(" No match");
}
} else {
if(showCheckBox) System.out.print("CB ");
else System.out.print("-- ");
if(isBold) System.out.print("BOLD ");
else System.out.print("dim ");
// java has no printf :
String query = ""+q;
String observed = ""+p.getObserved();
System.out.print(padout(query,4," "));
if(observed.indexOf(".")>-1) {
String one = observed.substring(0,observed.indexOf("."));
String two = observed.substring(observed.indexOf(".")+1,observed.length());
two = padend(two,6,"0");
observed = one+"."+two;
}
System.out.print(padout(observed,11," "));
System.out.print(padout(""+p.getRank(),4," "));
System.out.print("("+padout(""+p.getPrettyRank(),4," ")+")");
System.out.print(padout(p.getPeptideStr(),20," "));
double score = p.getIonsScore();
String scoreString = ""+score;
if(scoreString.indexOf(".")>-1) {
String one = scoreString.substring(0,scoreString.indexOf("."));
String two = scoreString.substring(scoreString.indexOf(".")+1,
scoreString.length());
if(isDuplicate) {
System.out.print("("+padout(one,3,"")+"."+padend(two,2,"0")+")");
} else {
System.out.print(" "+padout(one,3,"")+"."+padend(two,2,"0")+" ");
}
} else {
System.out.println(scoreString);
}
// perl seems to take 1st letter of the readable mod, pad with 2 spaces
// and ignore (set to 0) any letters, so this does the same (quick & nasty)
if(r.getReadableVarMods(q,p.getRank(),2).equals("")) System.out.println(" 0");
else {
String let = r.getReadableVarMods(q,p.getRank(),2).substring(0,1);
try {
int intLet = Integer.parseInt(let);
System.out.println(" "+let);
} catch (NumberFormatException notNumber) {
System.out.println(" 0");
}
}
}
}
private static String padout(String toPrint, int length,String padding) {
String returnValue="";
if(toPrint.length() < length) {
for(int queryLoop = 1; queryLoop <= length - toPrint.length(); queryLoop++) {
returnValue += padding;
}
returnValue += toPrint;
}
else returnValue = toPrint;
return returnValue;
}
private static String padend(String toPrint, int length,String padding) {
String returnValue=toPrint;
if(toPrint.length() < length) {
for(int queryLoop = 1; queryLoop <= length - toPrint.length(); queryLoop++) {
returnValue += padding;
}
}
return returnValue;
}
private static String roundWholeNumber (double toRound) {
String myInt = ""+toRound;
myInt += "\n";
if(myInt.indexOf(".0\n")>-1) {
return myInt.substring(0,myInt.indexOf(".0\n"));
}
return ""+toRound;
}
private static boolean checkErrors(ms_mascotresfilebase file) {
if((file.getLastError())>0) {
for(int loopErrors=1; loopErrors <= file.getNumberOfErrors(); loopErrors++) {
System.out.print("Error number: "+file.getErrorNumber(loopErrors));
System.out.print(" : "+file.getErrorString(loopErrors));
System.out.println("");
}
}
//Call isValid before clearAllErrors, otherwise this method always returns true
boolean bIsValid = file.isValid();
file.clearAllErrors();
return bIsValid;
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar resfile_summary F981123.dat
-------------------------------------------------------------
--- Peptide summary report ---
-------------------------------------------------------------
Amino acid database
Protein Hit 1
===================
Accession : Q9XZJ2
Description : HEAT SHOCK PROTEIN 70.- Crassostrea gigas (Pacific oyster).
Score : 286.47705382849546
Mass : 79480.13
Frame : 0
Coverage : 57
RMS error : 274.58772054111273
Peptides : 4
CB BOLD 1 671.900000 1( 1) DAGTISGLNVLR 95.12 0
CB BOLD 2 808.300000 1( 1) TTPSYVAFTDTER 74.55 0
CB BOLD 3 973.900000 1( 1) NQVAMNPNNTIFDAK 89.84 0
-- BOLD 41084.900000 3( 3) IINEPTAAAIAYGLDKK 30.07 0
Proteins matching the same set of peptides:
Q94805 Total score: 283.3741076569909 Peptides matched: 4
Proteins matching a subset of these peptides:
AAF09496 Total score: 211.92705382849545 Peptides matched: 3
Q9I9Q5 Total score: 199.74 Peptides matched: 3
Q24789 Total score: 199.74 Peptides matched: 3
BAB72169 Total score: 199.74 Peptides matched: 3
Q9W6Y1 Total score: 196.63705382849543 Peptides matched: 3
AAB93665 Total score: 196.63705382849543 Peptides matched: 3
Q95V47 Total score: 194.45999999999998 Peptides matched: 3
Q91993 Total score: 193.5341076569909 Peptides matched: 3
T45476 Total score: 191.35705382849545 Peptides matched: 3
O01948 Total score: 169.67000000000002 Peptides matched: 2
O97150 Total score: 166.56705382849543 Peptides matched: 2
Q9NJ92 Total score: 125.19 Peptides matched: 2
Q9NJ93 Total score: 125.19 Peptides matched: 2
Q9PUF9 Total score: 125.19 Peptides matched: 2
S21175 Total score: 125.19 Peptides matched: 2
B44261 Total score: 125.19 Peptides matched: 2
T45473 Total score: 125.19 Peptides matched: 2
AAA64872 Total score: 125.19 Peptides matched: 2
P81159 Total score: 125.19 Peptides matched: 2
JC4610 Total score: 122.08705382849546 Peptides matched: 2
O73788 Total score: 122.08705382849544 Peptides matched: 2
1ATR Total score: 104.62 Peptides matched: 2
1ATS Total score: 104.62 Peptides matched: 2
1BA0 Total score: 104.62 Peptides matched: 2
1BA1 Total score: 104.62 Peptides matched: 2
1BUPA Total score: 104.62 Peptides matched: 2
1HSC Total score: 104.62 Peptides matched: 2
1KAX Total score: 104.62 Peptides matched: 2
1KAY Total score: 104.62 Peptides matched: 2
1KAZ Total score: 104.62 Peptides matched: 2
1NGC Total score: 104.62 Peptides matched: 2
1NGD Total score: 104.62 Peptides matched: 2
1NGE Total score: 104.62 Peptides matched: 2
1NGF Total score: 104.62 Peptides matched: 2
1NGG Total score: 104.62 Peptides matched: 2
1NGH Total score: 104.62 Peptides matched: 2
1NGI Total score: 104.62 Peptides matched: 2
2BUPA Total score: 104.62 Peptides matched: 2
HHKW7A Total score: 104.62 Peptides matched: 2
HHUM7B Total score: 104.62 Peptides matched: 2
Q9GPK0 Total score: 104.62 Peptides matched: 2
Q9GRE8 Total score: 104.62 Peptides matched: 2
Q9H3R6 Total score: 104.62 Peptides matched: 2
Q9M4E6 Total score: 104.62 Peptides matched: 2
Q9M6R1 Total score: 104.62 Peptides matched: 2
Q9NCC8 Total score: 104.62 Peptides matched: 2
Q9NGK9 Total score: 104.62 Peptides matched: 2
Q9NJB7 Total score: 104.62 Peptides matched: 2
Q9SAU8 Total score: 104.62 Peptides matched: 2
Q9TW75 Total score: 104.62 Peptides matched: 2
Q9U545 Total score: 104.62 Peptides matched: 2
Q9UAE9 Total score: 104.62 Peptides matched: 2
Q95LN9 Total score: 104.62 Peptides matched: 2
PQ0138 Total score: 104.62 Peptides matched: 2
JC2215 Total score: 104.62 Peptides matched: 2
JC4786 Total score: 104.62 Peptides matched: 2
JC5642 Total score: 104.62 Peptides matched: 2
S07197 Total score: 104.62 Peptides matched: 2
S11456 Total score: 104.62 Peptides matched: 2
T21394 Total score: 104.62 Peptides matched: 2
A25646 Total score: 104.62 Peptides matched: 2
S27004 Total score: 104.62 Peptides matched: 2
Q27031 Total score: 104.62 Peptides matched: 2
A27077 Total score: 104.62 Peptides matched: 2
AAA30130 Total score: 104.62 Peptides matched: 2
AAA30569 Total score: 104.62 Peptides matched: 2
S31716 Total score: 104.62 Peptides matched: 2
AAA33009 Total score: 104.62 Peptides matched: 2
A35922 Total score: 104.62 Peptides matched: 2
S36753 Total score: 104.62 Peptides matched: 2
S37165 Total score: 104.62 Peptides matched: 2
Q43532 Total score: 104.62 Peptides matched: 2
A44985 Total score: 104.62 Peptides matched: 2
T45478 Total score: 104.62 Peptides matched: 2
T45479 Total score: 104.62 Peptides matched: 2
A45635 Total score: 104.62 Peptides matched: 2
A45935 Total score: 104.62 Peptides matched: 2
A48439 Total score: 104.62 Peptides matched: 2
O61003 Total score: 104.62 Peptides matched: 2
O61004 Total score: 104.62 Peptides matched: 2
O73885 Total score: 104.62 Peptides matched: 2
O76274 Total score: 104.62 Peptides matched: 2
P79984 Total score: 104.62 Peptides matched: 2
CAA81523 Total score: 104.62 Peptides matched: 2
Q93146 Total score: 104.62 Peptides matched: 2
Q93147 Total score: 104.62 Peptides matched: 2
Q94614 Total score: 104.62 Peptides matched: 2
O96541 Total score: 104.62 Peptides matched: 2
O96911 Total score: 104.62 Peptides matched: 2
Q9TUG3 Total score: 101.51705382849545 Peptides matched: 2
Q9TX61 Total score: 101.51705382849545 Peptides matched: 2
HS74_YEAST Total score: 101.51705382849545 Peptides matched: 2
Q99KD7 Total score: 101.51705382849545 Peptides matched: 2
S08211 Total score: 101.51705382849545 Peptides matched: 2
S10859 Total score: 101.51705382849545 Peptides matched: 2
AAD11466 Total score: 101.51705382849545 Peptides matched: 2
CAA33735 Total score: 101.51705382849545 Peptides matched: 2
B36590 Total score: 101.51705382849545 Peptides matched: 2
AAA37859 Total score: 101.51705382849545 Peptides matched: 2
A55719 Total score: 101.51705382849545 Peptides matched: 2
B86295 Total score: 101.51705382849545 Peptides matched: 2
AAA49563 Total score: 95.12 Peptides matched: 1
1HJOA Total score: 74.55 Peptides matched: 1
1NGA Total score: 74.55 Peptides matched: 1
1QQMA Total score: 74.55 Peptides matched: 1
1QQNA Total score: 74.55 Peptides matched: 1
1QQOA Total score: 74.55 Peptides matched: 1
Q9I8F9 Total score: 74.55 Peptides matched: 1
Q9IAC1 Total score: 74.55 Peptides matched: 1
Q9LU13 Total score: 74.55 Peptides matched: 1
Q9N1U2 Total score: 74.55 Peptides matched: 1
Q9NFT1 Total score: 74.55 Peptides matched: 1
Q9QWJ5 Total score: 74.55 Peptides matched: 1
HS71_SCHPO Total score: 74.55 Peptides matched: 1
JH0095 Total score: 74.55 Peptides matched: 1
JU0164 Total score: 74.55 Peptides matched: 1
PC1156 Total score: 74.55 Peptides matched: 1
AAA03451 Total score: 74.55 Peptides matched: 1
AAB03704 Total score: 74.55 Peptides matched: 1
S09036 Total score: 74.55 Peptides matched: 1
AAA17441 Total score: 74.55 Peptides matched: 1
O18474 Total score: 74.55 Peptides matched: 1
T19211 Total score: 74.55 Peptides matched: 1
AAD21815 Total score: 74.55 Peptides matched: 1
AAD21816 Total score: 74.55 Peptides matched: 1
T22169 Total score: 74.55 Peptides matched: 1
S25585 Total score: 74.55 Peptides matched: 1
A25773 Total score: 74.55 Peptides matched: 1
Q26357 Total score: 74.55 Peptides matched: 1
Q26936 Total score: 74.55 Peptides matched: 1
Q26937 Total score: 74.55 Peptides matched: 1
A29160 Total score: 74.55 Peptides matched: 1
S31766 Total score: 74.55 Peptides matched: 1
AAL34314 Total score: 74.55 Peptides matched: 1
S37394 Total score: 74.55 Peptides matched: 1
I37564 Total score: 74.55 Peptides matched: 1
T41121 Total score: 74.55 Peptides matched: 1
T43724 Total score: 74.55 Peptides matched: 1
T45468 Total score: 74.55 Peptides matched: 1
A45871 Total score: 74.55 Peptides matched: 1
A48872 Total score: 74.55 Peptides matched: 1
A49242 Total score: 74.55 Peptides matched: 1
I51129 Total score: 74.55 Peptides matched: 1
CAA52328 Total score: 74.55 Peptides matched: 1
S53357 Total score: 74.55 Peptides matched: 1
I54542 Total score: 74.55 Peptides matched: 1
AAA57233 Total score: 74.55 Peptides matched: 1
Q63256 Total score: 74.55 Peptides matched: 1
Q63718 Total score: 74.55 Peptides matched: 1
S67431 Total score: 74.55 Peptides matched: 1
BAB72167 Total score: 74.55 Peptides matched: 1
BAB72168 Total score: 74.55 Peptides matched: 1
BAB72233 Total score: 74.55 Peptides matched: 1
O73922 Total score: 74.55 Peptides matched: 1
AAA78276 Total score: 74.55 Peptides matched: 1
BAB78505 Total score: 74.55 Peptides matched: 1
Q98896 Total score: 74.55 Peptides matched: 1
Q98899 Total score: 74.55 Peptides matched: 1
Q98900 Total score: 74.55 Peptides matched: 1
Q98901 Total score: 74.55 Peptides matched: 1
E980236 Total score: 74.55 Peptides matched: 1
Q9UVM0 Total score: 71.44705382849544 Peptides matched: 1
JQ1515 Total score: 71.44705382849544 Peptides matched: 1
PC7036 Total score: 71.44705382849544 Peptides matched: 1
HHBYA1 Total score: 30.07 Peptides matched: 1
HS7E_SPIOL Total score: 30.07 Peptides matched: 1
Q9ATB8 Total score: 30.07 Peptides matched: 1
Q9DC27 Total score: 30.07 Peptides matched: 1
Q9FSY7 Total score: 30.07 Peptides matched: 1
Q9GPM5 Total score: 30.07 Peptides matched: 1
Q9GTX3 Total score: 30.07 Peptides matched: 1
Q9LHA8 Total score: 30.07 Peptides matched: 1
Q9M4E7 Total score: 30.07 Peptides matched: 1
Q9M4E8 Total score: 30.07 Peptides matched: 1
Q9NAX9 Total score: 30.07 Peptides matched: 1
Q9NCC9 Total score: 30.07 Peptides matched: 1
Q9NCD0 Total score: 30.07 Peptides matched: 1
Q9NCD1 Total score: 30.07 Peptides matched: 1
Q9NCD2 Total score: 30.07 Peptides matched: 1
Q9NCD3 Total score: 30.07 Peptides matched: 1
Q9NCD4 Total score: 30.07 Peptides matched: 1
Q9NCD5 Total score: 30.07 Peptides matched: 1
Q9NCD6 Total score: 30.07 Peptides matched: 1
Q9NCD7 Total score: 30.07 Peptides matched: 1
Q9NCD8 Total score: 30.07 Peptides matched: 1
Q9NCD9 Total score: 30.07 Peptides matched: 1
Q9NCE0 Total score: 30.07 Peptides matched: 1
Q9NHB4 Total score: 30.07 Peptides matched: 1
Q9P8E0 Total score: 30.07 Peptides matched: 1
Q9U540 Total score: 30.07 Peptides matched: 1
Q9ZS55 Total score: 30.07 Peptides matched: 1
HS71_CANAL Total score: 30.07 Peptides matched: 1
HS71_PICAN Total score: 30.07 Peptides matched: 1
HS71_YEAST Total score: 30.07 Peptides matched: 1
HS72_PICAN Total score: 30.07 Peptides matched: 1
HS72_YEAST Total score: 30.07 Peptides matched: 1
Q96IS6 Total score: 30.07 Peptides matched: 1
Q96W30 Total score: 30.07 Peptides matched: 1
Q943K7 Total score: 30.07 Peptides matched: 1
Q961X6 Total score: 30.07 Peptides matched: 1
JQ0966 Total score: 30.07 Peptides matched: 1
CAA02784 Total score: 30.07 Peptides matched: 1
S03250 Total score: 30.07 Peptides matched: 1
T03581 Total score: 30.07 Peptides matched: 1
T04078 Total score: 30.07 Peptides matched: 1
T04080 Total score: 30.07 Peptides matched: 1
Q05829 Total score: 30.07 Peptides matched: 1
T06358 Total score: 30.07 Peptides matched: 1
AAB06397 Total score: 30.07 Peptides matched: 1
T06598 Total score: 30.07 Peptides matched: 1
JC7132 Total score: 30.07 Peptides matched: 1
BAB08435 Total score: 30.07 Peptides matched: 1
BAA13948 Total score: 30.07 Peptides matched: 1
S14949 Total score: 30.07 Peptides matched: 1
S14950 Total score: 30.07 Peptides matched: 1
T15513 Total score: 30.07 Peptides matched: 1
Q17310 Total score: 30.07 Peptides matched: 1
S18181 Total score: 30.07 Peptides matched: 1
S20139 Total score: 30.07 Peptides matched: 1
S21879 Total score: 30.07 Peptides matched: 1
S21880 Total score: 30.07 Peptides matched: 1
Q23712 Total score: 30.07 Peptides matched: 1
S24782 Total score: 30.07 Peptides matched: 1
Q24895 Total score: 30.07 Peptides matched: 1
Q24928 Total score: 30.07 Peptides matched: 1
Q24952 Total score: 30.07 Peptides matched: 1
A25089 Total score: 30.07 Peptides matched: 1
Q27078 Total score: 30.07 Peptides matched: 1
Q27121 Total score: 30.07 Peptides matched: 1
Q27146 Total score: 30.07 Peptides matched: 1
Q27147 Total score: 30.07 Peptides matched: 1
CAA27330 Total score: 30.07 Peptides matched: 1
AAA28075 Total score: 30.07 Peptides matched: 1
CAA28976 Total score: 30.07 Peptides matched: 1
CAA31393 Total score: 30.07 Peptides matched: 1
CAA31663 Total score: 30.07 Peptides matched: 1
A32475 Total score: 30.07 Peptides matched: 1
T34037 Total score: 30.07 Peptides matched: 1
AAA34139 Total score: 30.07 Peptides matched: 1
Q40924 Total score: 30.07 Peptides matched: 1
S41372 Total score: 30.07 Peptides matched: 1
S42488 Total score: 30.07 Peptides matched: 1
A42582 Total score: 30.07 Peptides matched: 1
S44168 Total score: 30.07 Peptides matched: 1
D44261 Total score: 30.07 Peptides matched: 1
O45038 Total score: 30.07 Peptides matched: 1
T45298 Total score: 30.07 Peptides matched: 1
T45474 Total score: 30.07 Peptides matched: 1
T45475 Total score: 30.07 Peptides matched: 1
T45477 Total score: 30.07 Peptides matched: 1
T45517 Total score: 30.07 Peptides matched: 1
T45522 Total score: 30.07 Peptides matched: 1
S46302 Total score: 30.07 Peptides matched: 1
T46574 Total score: 30.07 Peptides matched: 1
T46650 Total score: 30.07 Peptides matched: 1
T48270 Total score: 30.07 Peptides matched: 1
T48271 Total score: 30.07 Peptides matched: 1
A48469 Total score: 30.07 Peptides matched: 1
O48563 Total score: 30.07 Peptides matched: 1
S49303 Total score: 30.07 Peptides matched: 1
S51682 Total score: 30.07 Peptides matched: 1
S51712 Total score: 30.07 Peptides matched: 1
AAB53051 Total score: 30.07 Peptides matched: 1
S53126 Total score: 30.07 Peptides matched: 1
CAA54419 Total score: 30.07 Peptides matched: 1
O62564 Total score: 30.07 Peptides matched: 1
AAB63968 Total score: 30.07 Peptides matched: 1
AAA65099 Total score: 30.07 Peptides matched: 1
O65171 Total score: 30.07 Peptides matched: 1
S71171 Total score: 30.07 Peptides matched: 1
O76306 Total score: 30.07 Peptides matched: 1
CAC84456 Total score: 30.07 Peptides matched: 1
AAF88019 Total score: 30.07 Peptides matched: 1
D90093 Total score: 30.07 Peptides matched: 1
P90655 Total score: 30.07 Peptides matched: 1
Q91624 Total score: 30.07 Peptides matched: 1
P91738 Total score: 30.07 Peptides matched: 1
AAA92743 Total score: 30.07 Peptides matched: 1
O93935 Total score: 30.07 Peptides matched: 1
O94104 Total score: 30.07 Peptides matched: 1
O94106 Total score: 30.07 Peptides matched: 1
Q94439 Total score: 30.07 Peptides matched: 1
H96605 Total score: 30.07 Peptides matched: 1
P97966 Total score: 30.07 Peptides matched: 1
AAA99920 Total score: 30.07 Peptides matched: 1
Q9NCC5 Total score: 26.967053828495448 Peptides matched: 1
Q9NCC6 Total score: 26.967053828495448 Peptides matched: 1
Q9NCC7 Total score: 26.967053828495448 Peptides matched: 1
AAC05418 Total score: 26.967053828495448 Peptides matched: 1
AAB08760 Total score: 26.967053828495448 Peptides matched: 1
AAF23276 Total score: 26.967053828495448 Peptides matched: 1
Q91688 Total score: 26.967053828495448 Peptides matched: 1
P93937 Total score: 26.967053828495448 Peptides matched: 1
Protein Hit 2
===================
Accession : S14992
Description : dnaK-type molecular chaperone hsp70 - soybean
Score : 166.04
Mass : 78349.66
Frame : 0
Coverage : 45
RMS error : 316.0424369822863
Peptides : 3
-- dim 2 808.300000 1( 1) TTPSYVAFTDTER 74.55 0
-- dim 3 973.900000 2( 2) NQVAMNPQNTVFDAK 61.42 0
-- dim 41084.900000 3( 3) IINEPTAAAIAYGLDKK 30.07 0
Proteins matching the same set of peptides:
S53498 Total score: 166.04 Peptides matched: 3
Proteins matching a subset of these peptides:
Q9R2A1 Total score: 135.97 Peptides matched: 2
HHXL70 Total score: 135.97 Peptides matched: 2
Q96QC9 Total score: 135.97 Peptides matched: 2
S21365 Total score: 135.97 Peptides matched: 2
S41415 Total score: 135.97 Peptides matched: 2
B45871 Total score: 135.97 Peptides matched: 2
I49761 Total score: 135.97 Peptides matched: 2
AAA74906 Total score: 135.97 Peptides matched: 2
O75634 Total score: 135.97 Peptides matched: 2
O88686 Total score: 135.97 Peptides matched: 2
Q17228 Total score: 61.42 Peptides matched: 1
Q17289 Total score: 61.42 Peptides matched: 1
Q27379 Total score: 61.42 Peptides matched: 1
AAA27868 Total score: 61.42 Peptides matched: 1
A34041 Total score: 58.317053828495446 Peptides matched: 1
Protein Hit 3
===================
Accession : A36333
Description : dnaK-type molecular chaperone Hsc70-4 - fruit fly (Drosophila melanogaster)
Score : 147.45
Mass : 77814.51
Frame : 0
Coverage : 45
RMS error : 464.59967503590167
Peptides : 3
-- dim 2 808.300000 1( 1) TTPSYVAFTDTER 74.55 0
-- dim 3 973.900000 3( 3) NQVAMNPTQTIFDAK 42.83 0
-- dim 41084.900000 3( 3) IINEPTAAAIAYGLDKK 30.07 0
Proteins matching the same set of peptides:
AAF55150 Total score: 147.45 Peptides matched: 3
Proteins matching a subset of these peptides:
Protein Hit 4
===================
Accession : A03309
Description : dnaK-type molecular chaperone Dsim/Hsc70-1 - fruit fly (Drosophila simulans) (fragments)
Score : 147.03
Mass : 25558.88
Frame : 0
Coverage : 28
RMS error : 365.7556240028131
Peptides : 2
-- dim 2 808.300000 3( 3) TTPSYVAFTESER 57.19 0
-- dim 3 973.900000 1( 1) NQVAMNPNNTIFDAK 89.84 0
Proteins matching the same set of peptides:
AAA28632 Total score: 147.03 Peptides matched: 2
JN0668 Total score: 143.92705382849545 Peptides matched: 2
Proteins matching a subset of these peptides:
Q9BIS1 Total score: 57.19 Peptides matched: 1
Q9BIS3 Total score: 57.19 Peptides matched: 1
B03309 Total score: 57.19 Peptides matched: 1
Protein Hit 5
===================
Accession : Q95PU3
Description : HEAT SHOCK PROTEIN (HSP70).- Euplotes crassus.
Score : 113.66
Mass : 80429.66
Frame : 0
Coverage : 30
RMS error : 407.38524706491955
Peptides : 2
-- dim 2 808.300000 1( 1) TTPSYVAFTDTER 74.55 0
CB dim 41084.900000 1( 1) IIIEPTAAAIAYGLDKK 39.11 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Protein Hit 6
===================
Accession : 1NGB
Description : Heat-shock cognate 70kd protein (44kd atpase n-terminal Fragment) (EC 3.6.1.3) mutant with glu 175 replace
d by Gln (e175q) - bovine
Score : 109.89
Mass : 45220.22
Frame : 0
Coverage : 30
RMS error : 411.19901615189326
Peptides : 2
-- dim 2 808.300000 1( 1) TTPSYVAFTDTER 74.55 0
-- dim 41084.900000 2( 2) IINQPTAAAIAYGLDKK 35.34 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Protein Hit 7
===================
Accession : O61226
Description :
Score : 90.71000000000001
Mass : 0.0
Frame : 0
Coverage : 30
RMS error : 804.0968914838121
Peptides : 2
-- dim 2 808.300000 2( 2) TTPSYVAFTNTER 60.64 0
-- dim 41084.900000 3( 3) IINEPTAAAIAYGLDKK 30.07 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Protein Hit 8
===================
Accession : P87036
Description :
Score : 81.27000000000001
Mass : 0.0
Frame : 0
Coverage : 29
RMS error : 570.361400922183
Peptides : 2
-- dim 1 671.900000 3( 3) DAGTIAGLEVLR 51.20 0
-- dim 41084.900000 3( 3) IINEPTAAAIAYGLDKK 30.07 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
AG2111 Total score: 51.2 Peptides matched: 1
S06158 Total score: 51.2 Peptides matched: 1
A25398 Total score: 51.2 Peptides matched: 1
AAA30204 Total score: 51.2 Peptides matched: 1
CAB59514 Total score: 51.2 Peptides matched: 1
S74372 Total score: 51.2 Peptides matched: 1
O76958 Total score: 51.2 Peptides matched: 1
Q9GYW3 Total score: 48.09705382849545 Peptides matched: 1
Q9HG01 Total score: 48.09705382849545 Peptides matched: 1
S11448 Total score: 48.09705382849545 Peptides matched: 1
CAA36551 Total score: 48.09705382849545 Peptides matched: 1
A45515 Total score: 48.09705382849545 Peptides matched: 1
S52727 Total score: 48.09705382849545 Peptides matched: 1
Q94594 Total score: 48.09705382849545 Peptides matched: 1
Score Delta Hit Protein Peptide
Accessions that matched query 97 rank 1:-
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_summary.py

resfile_summary.py

Example program for extracting the peptide or protein summary.

1#!/usr/bin/python
2
17
18import msparser
19import sys
20import re
21
22def main() :
23 returnValue = 1
24
25 if len(sys.argv) < 2 :
26 print("Must specify results filename as parameter" )
27 return returnValue
28
29 resfile = msparser.ms_mascotresfilebase.createResfile(sys.argv[1])
30
31 if checkErrors(resfile) :
32
33 # The parameters passed to ms_peptidesummary or ms_proteinsummary determine
34 # the type of grouping and the number of proteins and peptides displayed.
35 # Default parameters can be returned using ms_mascotresfilebase::get_ms_mascotresults_params().
36 # The return values from this function depend on the type of search,
37 # and also on values in the mascot.dat configuration file if that is available.
38
39 # You may need to change this path
40 datfile = msparser.ms_datfile("../config/mascot.dat")
41
42 # if the mascot.dat isn't available, use defaults
43 mascotOptions = msparser.ms_mascotoptions()
44
45 if (datfile.isValid()) :
46 mascotOptions = datfile.getMascotOptions()
47
48 (scriptName,
49 flags,
50 minProbability,
51 maxHitsToReport,
52 ignoreIonsScoreBelow,
53 minPepLenInPepSummary,
54 usePeptideSummary,
55 flags2) = resfile.get_ms_mascotresults_params(mascotOptions)
56
57 bResult = False
58 if (usePeptideSummary) :
59
60 # For peptide summary
61 #
62 # Flags defined for hierarchical clustering algorithm:
63 # flags: ms_mascotresults::MSRES_CLUSTER_PROTEINS
64 # | ms_mascotresults::MSRES_SHOW_SUBSETS
65 # | ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE;
66 # flags2: ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH;
67 #
68 # Flags defined for original simple parsimony algorithm:
69 # flags: ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS;
70
71 print("-------------------------------------------------------------")
72 print("--- Peptide summary report ---")
73 print("-------------------------------------------------------------")
74
75 bResult = show_results(resfile,
76 usePeptideSummary,
77 flags,
78 minProbability,
79 maxHitsToReport,
80 ignoreIonsScoreBelow,
81 minPepLenInPepSummary,
82 flags2)
83 else :
84 # Show results from full protein summary, remove grouping
85 flags &= ~msparser.ms_mascotresults.MSRES_GROUP_PROTEINS
86 flags &= ~msparser.ms_mascotresults.MSRES_SHOW_SUBSETS
87
88 print("-------------------------------------------------------------")
89 print("--- Full Protein summary report ---")
90 print("-------------------------------------------------------------")
91 bResult = show_results(resfile,
92 usePeptideSummary,
93 flags,
94 minProbability,
95 maxHitsToReport,
96 ignoreIonsScoreBelow,
97 minPepLenInPepSummary,
98 flags2)
99
100 if (bResult and checkErrors(resfile)) :
101 print("")
102
103 # Show results from concise protein summary, add grouping
104 flags |= msparser.ms_mascotresults.MSRES_GROUP_PROTEINS
105 flags |= msparser.ms_mascotresults.MSRES_SHOW_SUBSETS
106
107 print("-------------------------------------------------------------")
108 print("--- Concise Protein summary report ---")
109 print("-------------------------------------------------------------")
110 bResult = show_results(resfile,
111 usePeptideSummary,
112 flags,
113 minProbability,
114 maxHitsToReport,
115 ignoreIonsScoreBelow,
116 minPepLenInPepSummary,
117 flags2)
118
119 if (bResult and checkErrors(resfile)) :
120 returnValue = 0
121
122 return returnValue
123
124
125def show_results(resfile, usePeptideSummary, flags, minProteinProb, maxHits, minIonsScore, minPepLenInPepSummary, flags2) :
126
127 if usePeptideSummary :
128 results = msparser.ms_peptidesummary(
129 resfile, flags, minProteinProb, maxHits, "", minIonsScore, minPepLenInPepSummary, "", flags2
130 )
131 else :
132 results = msparser.ms_proteinsummary(
133 resfile, flags, minProteinProb, maxHits
134 )
135
136 if not checkErrors(resfile) :
137 return False
138
139 family = 1
140 hit = 1
141 prot = results.getHit(hit)
142
143 while prot :
144 accession = prot.getAccession()
145 description = results.getProteinDescription(accession)
146 mass = results.getProteinMass(accession)
147 dbIdx = prot.getDB()
148
149 protein_hit = "Protein Hit %d" % hit
150 if flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS :
151 protein_hit = protein_hit + "." + str(family)
152
153 print( protein_hit )
154 print("===================")
155 print("Accession : %s" % accession)
156 print("Description : %s" % description)
157 print("Score : %s" % prot.getScore())
158 print("Mass : %s" % mass)
159 print("Frame : %s" % prot.getFrame())
160 print("Coverage : %s" % prot.getCoverage())
161 print("RMS error : %s" % prot.getRMSDeltas(results))
162 print("Peptides : %s" % prot.getNumDisplayPeptides())
163
164 # Each protein has a number of peptides that matched - list them:
165 num_peps = prot.getNumPeptides()
166
167 for i in range(1, 1+ num_peps) :
168 query = prot.getPeptideQuery(i)
169 p = prot.getPeptideP(i)
170
171 isDupSameQuery = prot.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_DuplicateSameQuery
172 if p != -1 and query != -1 and not isDupSameQuery :
173 pep = results.getPeptide(query, p)
174 if not pep:
175 continue
176
177 displayPeptideInfo(
178 0, pep, results,
179 prot.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_Duplicate,
180 prot.getPeptideIsBold(i),
181 prot.getPeptideShowCheckbox(i)
182 )
183
184 # Now display list of all proteins that contain a subset or a same set of the matching peptides
185
186 if flags & msparser.ms_mascotresults.MSRES_GROUP_PROTEINS or flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS :
187 print("Proteins matching the same set of peptides:")
188
189 i = 1
190 similar_prot = results.getNextSimilarProteinOf(accession, dbIdx, 1)
191 while similar_prot :
192 similar_accession = similar_prot.getAccession()
193 similar_dbIdx = similar_prot.getDB()
194 if(flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS and similar_dbIdx > 1) :
195 print(str(similar_dbIdx) + "::"),
196 print(similar_accession + " - Total score:" + str(similar_prot.getScore())),
197 print(" - Peptides matched:" + str(similar_prot.getNumDisplayPeptides()))
198 i += 1
199 similar_prot = results.getNextSimilarProteinOf(accession, dbIdx, i)
200
201 if flags & msparser.ms_mascotresults.MSRES_SHOW_SUBSETS :
202 print("Proteins matching a subset of these peptides:")
203
204 i = 1
205 subset_prot = results.getNextSubsetProteinOf(accession, dbIdx, 1)
206 while subset_prot :
207 subset_accession = subset_prot.getAccession()
208 subset_dbIdx = subset_prot.getDB()
209 if(flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS and subset_dbIdx > 1) :
210 print(str(subset_dbIdx) + "::"),
211 print(subset_accession + " - Total score:" + str(subset_prot.getScore())),
212 print(" - Peptides matched:" + str(subset_prot.getNumDisplayPeptides()))
213
214 if(flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS) :
215 j = 1
216 similar_subset_prot = results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j)
217 if similar_subset_prot :
218 print(" Proteins matching the same set of peptides for this subset:")
219 while similar_subset_prot :
220 similar_subset_accession = similar_subset_prot.getAccession()
221 similar_subset_dbIdx = similar_subset_prot.getDB()
222 print(" "),
223 if similar_subset_dbIdx > 1 :
224 print(str(similar_subset_dbIdx) + "::"),
225 print(similar_subset_accession + " - Total score:" + str(similar_subset_prot.getScore())),
226 print(" Peptides matched:" + str(similar_subset_prot.getNumDisplayPeptides()))
227 j += 1
228 similar_subset_prot = results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j)
229
230 i += 1
231 subset_prot = results.getNextSubsetProteinOf(accession, dbIdx, i)
232
233 if flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS :
234 prot = results.getNextFamilyProtein(hit, family)
235 family += 1
236 if not prot :
237 hit += 1
238 prot = results.getHit(hit)
239 family = 1
240 else :
241 hit += 1
242 prot = results.getHit(hit)
243
244 print(" ")
245
246 results.createUnassignedList(msparser.ms_mascotresults.SCORE)
247
248 if results.getNumberOfUnassigned() :
249 print("Unassigned list")
250 print("---------------")
251
252 for u in range(1, 1 + results.getNumberOfUnassigned()) :
253 pep = results.getUnassigned(u)
254 displayPeptideInfo(0, pep, results, 0, 1, 1)
255
256 if usePeptideSummary :
257 print(" ")
258 displayYellowPopupInfo(results, 1)
259
260 return True
261
262
263def displayYellowPopupInfo(results, q) :
264 """
265 Shows the equivalent of the yellow popup box for given query
266 - results is the results object
267 - q is the query number
268 """
269
270 fmt = "%5s %5s %9s %7s %7s"
271 print(fmt % ("Score", "Delta", "Hit", "Protein", "Peptide"))
272
273 for p in range(1, 11) :
274 pep = results.getPeptide(q, p)
275 if not pep: continue
276
277 seq = pep.getPeptideStr()
278 if not seq: continue
279
280 tmp = results.getProteinsWithThisPepMatch(q, p)
281
282 (hit, protein) = ('', '')
283
284 if tmp :
285 hit, protein, morethan = re.search('(\d+):([^ ]*)[ ]*(.*)', tmp).groups()
286
287 if morethan :
288 hit += "+"
289
290 print(fmt % (pep.getIonsScore(), pep.getDelta(), hit, protein, seq))
291
292 p = 1
293 print("Accessions that matched query %s rank %s :- %s" % (q, p, results.getProteinsWithThisPepMatch(q, p)))
294
295
296def displayPeptideInfo(showFullDetails, p, results, isDuplicate, isBold, showCheckBox) :
297 q = p.getQuery()
298
299 if not showFullDetails :
300 fmt = "%2s %4s %4d %11f %4d(%4d) %-20s %s%3.2f%s %3s"
301
302 cb, bold = "--", "dim"
303 if showCheckBox : cb = "CB"
304 if isBold : bold = "BOLD"
305
306 paren1, paren2 = "", ""
307 if isDuplicate : paren1 = "(" ; paren2 = ")"
308
309 print(fmt % (
310 cb,
311 bold,
312 q,
313 p.getObserved(),
314 p.getRank(),
315 p.getPrettyRank(),
316 p.getPeptideStr(),
317 paren1,
318 p.getIonsScore(),
319 paren2,
320 results.getReadableVarMods(q, p.getRank())
321 ))
322
323 return
324
325
326 print("Peptide hit")
327
328 if p.getAnyMatch() :
329 fmt = " %-12s: %s"
330 print(fmt % ('Query' , q))
331 print(fmt % ('Rank' , p.getRank()))
332 print(fmt % ('Matched' , p.getAnyMatch()))
333 print(fmt % ('missedCleave', p.getMissedCleavages()))
334 print(fmt % ('mrCalc' , p.getMrCalc()))
335 print(fmt % ('delta' , p.getDelta()))
336 print(fmt % ('observed' , p.getObserved()))
337 print(fmt % ('charge' , p.getCharge()))
338 print(fmt % ('mrExp' , p.getMrExperimental()))
339 print(fmt % ('ionsMatched' , p.getNumIonsMatched()))
340 print(fmt % ('peptideStr' , p.getPeptideStr()))
341 print(fmt % ('peaksUsed1' , p.getPeaksUsedFromIons1()))
342 print(fmt % ('varModsStr' , p.getVarModsStr()))
343 print(fmt % ('readable mod', results.getReadableVarMods(q, p.getRank)))
344 print(fmt % ('ionsScore' , p.getIonsScore()))
345 print(fmt % ('seriesUsedS' , p.getSeriesUsedStr()))
346 print(fmt % ('peaksUsed2' , p.getPeaksUsedFromIons2()))
347 print(fmt % ('peaksUsed3' , p.getPeaksUsedFromIons3()))
348 print(fmt % ('idth, hth, p', ', '.join(
349 results.getPeptideIdentityThreshold(q, 20),
350 results.getHomologyThreshold(q, 20),
351 results.getProbOfPepBeingRandomMatch(p.getIonsScore(), q)
352 )))
353 print(" ")
354 else :
355 print(" No match")
356
357def checkErrors(resfile) :
358 if resfile.getLastError() :
359 for i in range(1, 1 + resfile.getNumberOfErrors()) :
360 print("Error number: %s : %s" % (resfile.getErrorNumber(i), resfile.getErrorString(i)))
361
362 #Call isValid before clearAllErrors, otherwise this method always returns true
363 bIsValid = resfile.isValid()
364 resfile.clearAllErrors()
365 return bIsValid
366
367if __name__ == "__main__" :
368 sys.exit(main())
369
370
371"""
372
373Running the program as
374
375python resfile_summary.py F981123.dat
376
377will give the following output under Mascot Server 2.3:
378
379
380-------------------------------------------------------------
381--- Peptide summary report ---
382-------------------------------------------------------------
383Protein Hit 1
384===================
385Accession : CH60_HUMAN
386Description : 60 kDa heat shock protein, mitochondrial precursor (Hsp60) (60 kDa chaperonin) (CPN60) (Heat shock
387Score : 1225.18623377
388Mass : 61016.38
389Frame : 0
390Coverage : 283
391RMS error : 30.4200726378
392Peptides : 31
393-- dim 52 1065.039917 2( 2) ALMLQGVDLLADAVAVTMGPK 57.90 Oxidation (M)
394-- dim 53 1065.062256 2( 2) ALMLQGVDLLADAVAVTMGPK 7.49 Oxidation (M)
395Proteins matching the same set of peptides:
396Proteins matching a subset of these peptides:
397CH60_PONPY Total score: 1007.90623377 Peptides matched: 25
398CH60_CRIGR Total score: 951.166233769 Peptides matched: 23
399CH60_MOUSE Total score: 951.166233769 Peptides matched: 23
400CH60_RAT Total score: 951.166233769 Peptides matched: 23
401CH60_BOVIN Total score: 917.682467539 Peptides matched: 22
402CH60_CHICK Total score: 875.976233769 Peptides matched: 19
403CH60C_DROME Total score: 120.5 Peptides matched: 2
404CH60C_ARATH Total score: 90.68 Peptides matched: 2
405HSP60_CANAL Total score: 45.35 Peptides matched: 1
406HSP60_PARBR Total score: 45.35 Peptides matched: 1
407HSP60_YEAST Total score: 45.35 Peptides matched: 1
408CH602_VIBPA Total score: 45.35 Peptides matched: 1
409CH602_VIBVU Total score: 45.35 Peptides matched: 1
410CH602_VIBVY Total score: 45.35 Peptides matched: 1
411CH60_EUGGR Total score: 45.33 Peptides matched: 1
412
413Protein Hit 2
414===================
415Accession : CH60_DROME
416Description : 60 kDa heat shock protein, mitochondrial precursor (Hsp60) (60 kDa chaperonin) (CPN60) (Heat shock
417Score : 174.39
418Mass : 60770.89
419Frame : 0
420Coverage : 67
421RMS error : 29.5905072791
422Peptides : 4
423Proteins matching the same set of peptides:
424Proteins matching a subset of these peptides:
425HSP60_SCHPO Total score: 87.04 Peptides matched: 2
426
427Protein Hit 3
428===================
429Accession : CH60_CAEEL
430Description : Chaperonin homolog Hsp-60, mitochondrial precursor (Heat shock protein 60) (HSP-60) - Caenorhabditi
431Score : 134.91
432Mass : 60063.75
433Frame : 0
434Coverage : 21
435RMS error : 36.5383063194
436Peptides : 3
437Proteins matching the same set of peptides:
438Proteins matching a subset of these peptides:
439
440Protein Hit 4
441===================
442Accession : CH60_XANAC
443Description : 60 kDa chaperonin (Protein Cpn60) (groEL protein) - Xanthomonas axonopodis pv. citri
444Score : 42.2
445Mass : 57130.83
446Frame : 0
447Coverage : 9
448RMS error : 76.9237696062
449Peptides : 1
450Proteins matching the same set of peptides:
451CH60_XANAC Total score: 42.2 Peptides matched: 1
452CH60_XANAC Total score: 42.2 Peptides matched: 1
453CH60_XANAC Total score: 42.2 Peptides matched: 1
454CH60_XANAC Total score: 42.2 Peptides matched: 1
455CH60_XANAC Total score: 42.2 Peptides matched: 1
456CH60_XANAC Total score: 42.2 Peptides matched: 1
457Proteins matching a subset of these peptides:
458
459Protein Hit 5
460===================
461Accession : NMDE4_HUMAN
462Description :
463Score : 37.24
464Mass : 0.0
465Frame : 0
466Coverage : 10
467RMS error : 9.41906700791
468Peptides : 1
469Proteins matching the same set of peptides:
470NMDE4_HUMAN Total score: 37.24 Peptides matched: 1
471NMDE4_HUMAN Total score: 36.2762337693 Peptides matched: 1
472Proteins matching a subset of these peptides:
473
474Protein Hit 6
475===================
476Accession : YF81_THET2
477Description :
478Score : 34.76
479Mass : 0.0
480Frame : 0
481Coverage : 9
482RMS error : 37.0214184966
483Peptides : 1
484Proteins matching the same set of peptides:
485YF81_THET2 Total score: 34.76 Peptides matched: 1
486Proteins matching a subset of these peptides:
487
488Protein Hit 7
489===================
490Accession : F4ST_FLACH
491Description :
492Score : 33.85
493Mass : 0.0
494Frame : 0
495Coverage : 9
496RMS error : 87.8815544839
497Peptides : 1
498Proteins matching the same set of peptides:
499Proteins matching a subset of these peptides:
500
501Protein Hit 8
502===================
503Accession : ZN711_HUMAN
504Description : Zinc finger protein 711 (Zinc finger protein 6) - Homo sapiens (Human)
505Score : 30.84
506Mass : 87153.77
507Frame : 0
508Coverage : 13
509RMS error : 69.4028633218
510Peptides : 1
511Proteins matching the same set of peptides:
512Proteins matching a subset of these peptides:
513
514Unassigned list
515---------------
516CB BOLD 14 442.228302 1( 1) LIAQTPLK 25.09
517CB BOLD 9 747.396179 1( 1) EGETRR 15.03
518CB BOLD 4 662.275574 1( 1) KNAMAK 14.09
519CB BOLD 23 1101.621704 1( 1) QLLMVAGVDR 12.04
520CB BOLD 5 662.417175 1( 1) AIACER 11.79
521CB BOLD 8 714.372498 1( 1) LAPAQSK 10.69
522CB BOLD 6 673.349487 1( 1) AVNDVR 10.63
523CB BOLD 22 1101.536621 1( 1) ENVIPADSEK 8.65
524CB BOLD 55 1099.094727 1( 1) LNAEAVRTLLSANGQKPSEAK 8.05
525CB BOLD 29 642.353577 1( 1) VVGVAGQGASALVR 7.91
526CB BOLD 28 642.352600 1( 1) KNVSVSQGPDPR 7.22
527CB BOLD 30 663.837891 1( 1) TPLLVGVAKGESR 7.20
528CB BOLD 50 1048.561523 1( 1) ALDEILEYQNYPVVCAKK 5.70
529CB BOLD 57 747.036072 1( 1) VMGSAFTALLDANEDAQKAMR 4.83
530CB BOLD 49 1020.987915 1( 1) HQRLSGLMQTALEEQQR 4.11 Oxidation (M)
531CB BOLD 19 932.364380 1( 1) TGMTRNPR 4.09
532CB BOLD 2 500.256012 1( 1) LAVPT 3.87
533CB BOLD 38 749.383972 1( 1) IDLLADMMWDDK 3.43 2 Oxidation (M)
534CB BOLD 20 933.499023 1( 1) SRDPGMVR 3.21 Oxidation (M)
535CB BOLD 41 886.405884 1( 1) DRVALNQEVMAPEATK 1.85
536CB BOLD 10 747.412476 1( 1) MAPSTPK 1.68 Oxidation (M)
537CB BOLD 18 930.703003 1( 1) LGSGIKAER 1.60
538CB BOLD 7 711.364685 1( 1) GGAHEIK 1.34
539CB BOLD 17 930.683105 1( 1) KIQAEITK 1.00
540CB BOLD 44 949.550720 1( 1) LLSWDSVFFIKNITSK 0.30
541CB BOLD 1 498.272888 1( 1) 0.00
542CB BOLD 3 575.558411 1( 1) 0.00
543CB BOLD 32 711.370728 1( 1) 0.00
544CB BOLD 42 932.460815 1( 1) 0.00
545CB BOLD 43 933.003784 1( 1) 0.00
546CB BOLD 47 665.009583 1( 1) 0.00
547CB BOLD 56 1119.045166 1( 1) 0.00
548CB BOLD 63 832.798584 1( 1) 0.00
549CB BOLD 66 1113.894653 1( 1) 0.00
550CB BOLD 67 1116.177490 1( 1) 0.00
551
552Score Delta Hit Protein Peptide
553
554Accessions that matched query 97 rank 1 :-
555
556"""
557
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_summary.cs

resfile_summary.cs

Example program for extracting the peptide or protein summary.

/*
##############################################################################
# file: resfile_summary.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/resfile_summary.cs $#
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.Text.RegularExpressions;
using matrix_science.msparser;
namespace MsParserExamples
{
public class resfile_summary
{
public static int Main(string[] argv)
{
// ----- Object creation -----
if (argv.Length < 1)
{
Console.WriteLine("Must specify results filename as parameter");
return 1;
}
int returnValue = 1; //failure
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(argv[0], 0, "");
if (checkErrors(file))
{
/*
* The parameters passed to ms_peptidesummary or ms_proteinsummary determine
* the type of grouping and the number of proteins and peptides displayed.
* Default parameters can be returned using ms_mascotresfilebase::get_ms_mascotresults_params().
* The return values from this function depend on the type of search,
* and also on values in the mascot.dat configuration file if that is available.
*/
ms_datfile datfile = new ms_datfile("../config/mascot.dat"); //You may need to change this path
//if the mascot.dat isn't available, use defaults
ms_mascotoptions mascotOptions = new ms_mascotoptions();
if (datfile.isValid())
{
mascotOptions = datfile.getMascotOptions();
}
uint flags, flags2, minPepLenInPepSummary;
int maxHitsToReport;
double minProbability, ignoreIonsScoreBelow;
bool usePeptideSummary;
string scriptName = file.get_ms_mascotresults_params(
mascotOptions,
out flags,
out minProbability,
out maxHitsToReport,
out ignoreIonsScoreBelow,
out minPepLenInPepSummary,
out usePeptideSummary,
out flags2);
bool bResult;
if (usePeptideSummary)
{
/*
* For peptide summary
*
* Flags defined for hierarchical clustering algorithm:
* flags: ms_mascotresults::MSRES_CLUSTER_PROTEINS
* | ms_mascotresults::MSRES_SHOW_SUBSETS
* | ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE;
* flags2: ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH;
*
* Flags defined for original simple parsimony algorithm:
* flags: ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS;
*/
Console.WriteLine("-------------------------------------------------------------");
Console.WriteLine("--- Peptide summary report ---");
Console.WriteLine("-------------------------------------------------------------");
bResult = showResults(file,
usePeptideSummary,
flags,
minProbability,
maxHitsToReport,
ignoreIonsScoreBelow,
(int)minPepLenInPepSummary,
flags2);
}
else
{
// Show results from full protein summary, remove grouping
flags &= ~(uint)ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS;
flags &= ~(uint)ms_mascotresults.FLAGS.MSRES_SHOW_SUBSETS;
Console.WriteLine("-------------------------------------------------------------");
Console.WriteLine("--- Full Protein summary report ---");
Console.WriteLine("-------------------------------------------------------------");
bResult = showResults(file,
usePeptideSummary,
flags,
minProbability,
maxHitsToReport,
ignoreIonsScoreBelow,
(int)minPepLenInPepSummary,
flags2);
if (bResult && checkErrors(file))
{
// Show results from concise protein summary, add grouping
flags |= (uint)ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS;
flags |= (uint)ms_mascotresults.FLAGS.MSRES_SHOW_SUBSETS;
Console.WriteLine("-------------------------------------------------------------");
Console.WriteLine("--- Concise Protein summary report ---");
Console.WriteLine("-------------------------------------------------------------");
bResult = showResults(file,
usePeptideSummary,
flags,
minProbability,
maxHitsToReport,
ignoreIonsScoreBelow,
(int)minPepLenInPepSummary,
flags2);
}
}
if (bResult && checkErrors(file))
{
returnValue = 0; //success
}
}
//ms_mascotresults has a reference on ms_mascotresfilebase, therefore the GC must not delete it too early
GC.KeepAlive(file);
return returnValue;
}
private static bool showResults(ms_mascotresfilebase file,
bool pepSum,
uint flags,
double minProteinProb,
int maxHits,
double minIonsScore,
int minPepLenInPepSummary,
uint flags2)
{
int hit, num_peps, i, query, p, u, family, dbIdx;
string accession, description;
double mass;
ms_mascotresults results;
ms_protein prot;
ms_peptide pep;
if (pepSum)
{
results = new ms_peptidesummary(file,
flags,
minProteinProb,
maxHits,
"", //unigene file
minIonsScore,
minPepLenInPepSummary,
null,
flags2);
}
else
{
results = new ms_proteinsummary(file,
flags,
minProteinProb,
maxHits,
null,
null);
}
if (!checkErrors(file))
{
return false;
}
Console.WriteLine("{0} acid database", ((results.isNA()) ? "Nucleic" : "Amino"));
family = 1;
// get hit one
hit = 1;
prot = results.getHit(hit);
while (hit <= results.getNumberOfHits())
{
accession = prot.getAccession();
dbIdx = prot.getDB();
description = results.getProteinDescription(accession);
mass = results.getProteinMass(accession);
if ((flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0)
{
Console.WriteLine("Protein Hit {0}.{1}\n===================", hit, family);
}
else
{
Console.WriteLine("Protein Hit {0}\n===================", hit);
}
Console.WriteLine("Accession : {0}", accession);
Console.WriteLine("Description : {0}", description);
Console.WriteLine("Score : {0:#}", prot.getScore());
Console.WriteLine("Mass : {0}", mass);
Console.WriteLine("Frame : {0}", prot.getFrame());
Console.WriteLine("Coverage : {0}", prot.getCoverage());
Console.WriteLine("RMS error : {0}", prot.getRMSDeltas(results));
Console.WriteLine("Peptides : {0}", prot.getNumDisplayPeptides());
// Each protein has a number of peptides that matched - list them
num_peps = prot.getNumPeptides();
for (i = 1; i <= num_peps; i++)
{
query = prot.getPeptideQuery(i);
p = prot.getPeptideP(i);
if (p != -1 && query != -1 && prot.getPeptideDuplicate(i) != ms_protein.DUPLICATE.DUPE_DuplicateSameQuery)
{
pep = results.getPeptide(query, p);
if (pep != null)
{
displayPeptideInfo(false, pep, results, prot.getPeptideDuplicate(i) == ms_protein.DUPLICATE.DUPE_Duplicate,
prot.getPeptideIsBold(i), prot.getPeptideShowCheckbox(i));
}
}
}
// now display list of all proteins that contained subsets or an identical list of the matching peptides
if ((flags & (uint) ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS) > 0 ||
(flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0)
{
Console.WriteLine("Proteins matching the same set of peptides:");
i = 1;
while ((prot = results.getNextSimilarProteinOf(accession, dbIdx, i)) != null)
{
string similar_accession = prot.getAccession();
int similar_dbIdx = prot.getDB();
if ((flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0 && similar_dbIdx > 1)
{
Console.Write("{0}::", similar_dbIdx);
}
Console.WriteLine("{0} Total score: {1:#} Peptides matched: {2}", similar_accession,
prot.getScore(), prot.getNumDisplayPeptides());
i++;
}
if ((flags & ((uint) ms_mascotresults.FLAGS.MSRES_SHOW_SUBSETS)) > 0)
{
Console.WriteLine("Proteins matching a subset of these peptides:");
i = 1;
while ((prot = results.getNextSubsetProteinOf(accession, dbIdx, i)) != null)
{
string subset_accession = prot.getAccession();
int subset_dbIdx = prot.getDB();
if ((flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0 && subset_dbIdx > 1)
{
Console.Write("{0}::", subset_dbIdx);
}
Console.WriteLine("{0} Total score: {1:#} Peptides matched: {2}", subset_accession,
prot.getScore(), prot.getNumDisplayPeptides());
if ((flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0)
{
int j = 1;
if (results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j) != null)
{
Console.WriteLine(" Proteins matching the same set of peptides for this subset:");
}
ms_protein similar_subset_prot;
while ((similar_subset_prot =
results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j)) != null)
{
string similar_subset_accession = similar_subset_prot.getAccession();
int similar_subset_dbIdx = similar_subset_prot.getDB();
Console.Write(" ");
if (similar_subset_dbIdx > 1)
{
Console.Write("{0}::", similar_subset_dbIdx);
}
Console.WriteLine("{0} Total score: {1:#} Peptides matched: {2}",
similar_subset_accession, similar_subset_prot.getScore(),
similar_subset_prot.getNumDisplayPeptides());
j++;
}
}
i++;
}
}
}
Console.WriteLine();
Console.WriteLine();
if ((flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0)
{
prot = results.getNextFamilyProtein(hit, family++);
if(prot == null)
{
hit++;
prot = results.getHit(hit);
family = 1;
}
}
else
{
hit++;
prot = results.getHit(hit);
}
}
results.createUnassignedList(ms_mascotresults.sortBy.SCORE);
if (results.getNumberOfUnassigned() > 0)
{
Console.WriteLine("Unassigned list");
Console.WriteLine("---------------");
for (u = 1; u <= results.getNumberOfUnassigned(); u++)
{
pep = results.getUnassigned(u);
displayPeptideInfo(false, pep, results, false, true, true);
}
}
if (pepSum) displayYellowPopupInfo(results, 1);
return true;
} //method
private static void displayYellowPopupInfo(ms_mascotresults results, int queryNo)
{
int p;
ms_peptide pep;
String seq, tmp, hit, protein, morethan = "";
Regex regex = new Regex(@"(\d):([^ ]*)[ ]*(.*)");
Console.WriteLine("Score Delta Hit Protein Peptide");
for (p = 1; p <= 10; p++)
{
if ((pep = results.getPeptide(queryNo, p)) != null)
{
seq = pep.getPeptideStr();
if (seq.Length > 0)
{
tmp = results.getProteinsWithThisPepMatch(queryNo, p, true);
hit = " ";
protein = " ";
morethan = "";
if (tmp.Length > 0)
{
if (regex.IsMatch(tmp))
{
Match OneMatch = regex.Match(tmp);
if (OneMatch.Success)
{
int groupCount = OneMatch.Groups.Count;
if (groupCount >= 2) hit = OneMatch.Groups[1].Value;
if (groupCount >= 3) protein = OneMatch.Groups[2].Value;
if (groupCount >= 4) morethan = OneMatch.Groups[3].Value;
}
}
if (morethan.Length > 0)
{
hit = hit+"+";
}
}
Console.WriteLine("{0} {1} {2} {3} {4}", pep.getIonsScore(), pep.getDelta(), hit, protein, pep.getPeptideStr());
}
}
}
p = 1;
Console.WriteLine("Accessions that matched query {0} rank {1}:- {2}", queryNo, p, results.getProteinsWithThisPepMatch(queryNo, p, false));
} //method
private static void displayPeptideInfo(bool showFullDetails, ms_peptide p, ms_mascotresults r, bool isDuplicate, bool isBold, bool showCheckBox)
{
int q = p.getQuery();
if (showFullDetails)
{
Console.WriteLine("Peptide hit");
if (p.getAnyMatch())
{
Console.WriteLine(" Query : {0}", q);
Console.WriteLine(" Rank : {0}", p.getRank());
Console.WriteLine(" Matched : {0}", p.getAnyMatch());
Console.WriteLine(" missedCleave: {0}", p.getMissedCleavages());
Console.WriteLine(" mrCalc : {0}", p.getMrCalc());
Console.WriteLine(" delta : {0}", p.getDelta());
Console.WriteLine(" observed : {0}", p.getObserved());
Console.WriteLine(" charge : {0}", p.getCharge());
Console.WriteLine(" mrExp : {0}", p.getMrExperimental());
Console.WriteLine(" ionsMatched : {0}", p.getNumIonsMatched());
Console.WriteLine(" peptideStr : {0}", p.getPeptideStr());
Console.WriteLine(" peaksUsed1 : {0}", p.getPeaksUsedFromIons1());
Console.WriteLine(" varModsStr : {0}", p.getVarModsStr());
Console.WriteLine(" readable mod: {0}", r.getReadableVarMods(q, p.getRank(), 2));
Console.WriteLine(" ionsScore : {0}", p.getIonsScore());
Console.WriteLine(" seriesUsedS : {0}", p.getSeriesUsedStr());
Console.WriteLine(" peaksUsed2 : {0}", p.getPeaksUsedFromIons2());
Console.WriteLine(" peaksUsed3 : {0}", p.getPeaksUsedFromIons3());
Console.WriteLine(" idth, hth, p: {0}, {1}, {2}", r.getPeptideIdentityThreshold(q, 20),
r.getHomologyThreshold(q, 20), r.getProbOfPepBeingRandomMatch(p.getIonsScore(), q));
Console.WriteLine();
}
else
{
Console.WriteLine(" No match");
}
}
else
{
if (showCheckBox) Console.Write("CB ");
else Console.Write("-- ");
if (isBold) Console.Write("BOLD ");
else Console.Write("dim ");
Console.Write(q.ToString().PadLeft(4));
Console.Write(" ");
double observed = p.getObserved();
Console.Write(" ");
Console.Write(string.Format("{0}", observed.ToString("0.000000")).PadLeft(11));
Console.Write(" ");
Console.Write(p.getRank().ToString().PadLeft(4));
Console.Write("({0})", p.getPrettyRank().ToString().PadLeft(4));
Console.Write(" ");
Console.Write(p.getPeptideStr().ToString().PadLeft(20));
Console.Write(" ");
double score = p.getIonsScore();
Console.Write(string.Format("{0}{1}{2}", (isDuplicate) ? "(" : "", score.ToString("0.00"), (isDuplicate) ? ")" : "").PadLeft(8));
Console.Write(" ");
if (r.getReadableVarMods(q, p.getRank(), 2).Length == 0) Console.WriteLine(" 0");
else
{
string let = r.getReadableVarMods(q, p.getRank(), 2).Substring(0, 1);
int iLet;
if (int.TryParse(let, out iLet))
{
Console.WriteLine(" {0}", iLet);
}
else Console.WriteLine(" 0");
}
}
} //method
private static bool checkErrors(ms_mascotresfilebase file)
{
for (int loop = 1; loop <= file.getNumberOfErrors(); loop++)
{
Console.WriteLine("Error number: {0} : {1}", file.getErrorNumber(loop), file.getErrorString(loop));
}
// Call isValid before clearAllErrors, otherwise this method always returns true
bool isValid = file.isValid();
file.clearAllErrors();
return isValid;
} //method
} //class
} //namespace
/*
resfile_summary.exe c:\inetpub\mascot\data\F981123.dat
Will give the following output:
-------------------------------------------------------------
--- Peptide summary report ---
-------------------------------------------------------------
Amino acid database
Protein Hit 1
===================
Accession : CH60_HUMAN
Description : 60 kDa heat shock protein, mitochondrial OS=Homo sapiens GN=HSPD1
PE=1 SV=2
Score : 1225
Mass : 61016.38
Frame : 0
Coverage : 283
RMS error : 30.4200726378481
Peptides : 31
CB BOLD 11 417.182190 1( 1) APGFGDNR 45.35 0
CB BOLD 12 422.743286 1( 1) VGEVIVTK 45.74 0
CB BOLD 13 430.732788 1( 1) IPAMTIAK 36.27 0
CB BOLD 15 451.249908 1( 1) LSDGVAVLK 51.95 0
CB BOLD 16 456.780609 1( 1) VGLQVVAVK 59.00 0
CB BOLD 21 480.744690 1( 1) VTDALNATR 45.33 0
CB BOLD 24 595.785522 1( 1) EIGNIISDAMK (56.55) 0
CB BOLD 25 603.771973 1( 1) EIGNIISDAMK 59.52 0
CB BOLD 26 608.309875 1( 1) NAGVEGSLIVEK 73.21 0
CB BOLD 27 617.285706 1( 1) VGGTSDVEVNEK 80.63 0
CB BOLD 31 672.837524 1( 1) TVIIEQSWGSPK 64.38 0
CB BOLD 34 714.888428 1( 1) GVMLAVDAVIAELK (64.52) 0
CB BOLD 35 714.893799 1( 1) GVMLAVDAVIAELK (72.61) 0
CB BOLD 36 722.884888 1( 1) GVMLAVDAVIAELK 75.19 0
CB BOLD 37 722.893372 1( 1) GVMLAVDAVIAELK (72.57) 0
CB BOLD 39 752.864319 1( 1) TLNDELEIIEGMK 89.56 0
CB BOLD 40 760.846130 1( 1) TLNDELEIIEGMK (88.82) 0
CB BOLD 45 640.328125 1( 1) ISSIQSIVPALEIANAHR 101.50 0
CB BOLD 46 960.032715 1( 1) ISSIQSIVPALEIANAHR (87.34) 0
CB BOLD 48 1019.510620 1( 1) IQEIIEQLDVTTSEYEK 52.42 0
CB BOLD 51 1057.053711 1( 1) ALMLQGVDLLADAVAVTMGPK 115.78 0
CB BOLD 52 1065.039917 1( 1) ALMLQGVDLLADAVAVTMGPK (71.79) 0
CB BOLD 53 1065.062256 1( 1) ALMLQGVDLLADAVAVTMGPK (26.17) 0
CB BOLD 54 1073.047729 1( 1) ALMLQGVDLLADAVAVTMGPK (92.82) 2
CB BOLD 58 789.106201 1( 1) KPLVIIAEDVDGEALSTLVLNR (55.53) 0
CB BOLD 59 1183.156982 1( 1) KPLVIIAEDVDGEALSTLVLNR (65.46) 0
CB BOLD 60 789.109375 1( 1) KPLVIIAEDVDGEALSTLVLNR 94.59 0
CB BOLD 61 828.123779 1( 1) TALLDAAGVASLLTTAEVVVTEIPK (26.50) 0
CB BOLD 62 828.132202 1( 1) TALLDAAGVASLLTTAEVVVTEIPK 47.53 0
CB BOLD 64 854.058777 1( 1) LVQDVANNTNEEAGDGTTTATVLAR 75.15 0
CB BOLD 65 1038.503052 1( 1) DMAIATGGAVFGEEGLTLNLEDVQPHDLGK 13.05 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
CH60_PONAB Total score: 1008 Peptides matched: 25
CH60_CRIGR Total score: 951 Peptides matched: 23
CH60_MOUSE Total score: 951 Peptides matched: 23
CH60_RAT Total score: 951 Peptides matched: 23
CH60_BOVIN Total score: 918 Peptides matched: 22
CH60_CHICK Total score: 876 Peptides matched: 19
CH60_MESAU Total score: 664 Peptides matched: 18
CH60C_DROME Total score: 121 Peptides matched: 2
CH60C_ARATH Total score: 91 Peptides matched: 2
HSP60_CANAL Total score: 45 Peptides matched: 1
HSP60_EMENI Total score: 45 Peptides matched: 1
HSP60_PARBA Total score: 45 Peptides matched: 1
HSP60_YEAST Total score: 45 Peptides matched: 1
CH602_VIBPA Total score: 45 Peptides matched: 1
CH602_VIBVU Total score: 45 Peptides matched: 1
CH602_VIBVY Total score: 45 Peptides matched: 1
CH60_EUGGR Total score: 45 Peptides matched: 1
Protein Hit 2
===================
Accession : CH60_DROME
Description : 60 kDa heat shock protein, mitochondrial OS=Drosophila melanogaste
r GN=Hsp60 PE=1 SV=3
Score : 174
Mass : 60770.89
Frame : 0
Coverage : 67
RMS error : 29.5905072791318
Peptides : 4
-- dim 11 417.182190 1( 1) APGFGDNR 45.35 0
-- dim 27 617.285706 2( 2) VGGSSEVEVNEK 41.69 0
-- dim 59 1183.156982 2( 2) KPLVIIAEDIDGEALSTLVVNR 12.20 0
-- dim 64 854.058777 1( 1) LVQDVANNTNEEAGDGTTTATVLAR 75.15 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
HSP60_SCHPO Total score: 87 Peptides matched: 2
Protein Hit 3
===================
Accession : CH60_CAEEL
Description : Chaperonin homolog Hsp-60, mitochondrial OS=Caenorhabditis elegans
GN=hsp-60 PE=1 SV=2
Score : 135
Mass : 60063.75
Frame : 0
Coverage : 21
RMS error : 36.5383063193603
Peptides : 3
-- dim 11 417.182190 1( 1) APGFGDNR 45.35 0
-- dim 39 752.864319 2( 1) TLNDELELIEGMK 89.56 0
-- dim 40 760.846130 2( 1) TLNDELELIEGMK (88.82) 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Protein Hit 4
===================
Accession : CH60_STRM5
Description : 60 kDa chaperonin OS=Stenotrophomonas maltophilia (strain R551-3)
GN=groL PE=3 SV=1
Score : 42
Mass : 57311.84
Frame : 0
Coverage : 9
RMS error : 76.92376960617
Peptides : 1
-- dim 16 456.780609 2( 2) GIVKVVAVK 42.20 0
Proteins matching the same set of peptides:
CH60_STRMK Total score: 42 Peptides matched: 1
CH60_XANAC Total score: 42 Peptides matched: 1
CH60_XANC5 Total score: 42 Peptides matched: 1
CH60_XANC8 Total score: 42 Peptides matched: 1
CH60_XANCB Total score: 42 Peptides matched: 1
CH60_XANCH Total score: 42 Peptides matched: 1
CH60_XANCP Total score: 42 Peptides matched: 1
CH60_XANOM Total score: 42 Peptides matched: 1
CH60_XANOP Total score: 42 Peptides matched: 1
CH60_XANOR Total score: 42 Peptides matched: 1
Proteins matching a subset of these peptides:
Protein Hit 5
===================
Accession : NMDE4_HUMAN
Description :
Score : 37
Mass : 0
Frame : 0
Coverage : 10
RMS error : 9.41906700790969
Peptides : 1
-- dim 16 456.780609 3( 3) VAAGVAVVAR 37.24 0
Proteins matching the same set of peptides:
NMDE4_MOUSE Total score: 37 Peptides matched: 1
NMDE4_RAT Total score: 36 Peptides matched: 1
Proteins matching a subset of these peptides:
Protein Hit 6
===================
Accession : YF81_THET2
Description :
Score : 35
Mass : 0
Frame : 0
Coverage : 9
RMS error : 37.0214184966023
Peptides : 1
-- dim 16 456.780609 4( 4) VAQVLGVVK 34.76 0
Proteins matching the same set of peptides:
Y1944_THET8 Total score: 35 Peptides matched: 1
Proteins matching a subset of these peptides:
Protein Hit 7
===================
Accession : F4ST_FLACH
Description :
Score : 34
Mass : 0
Frame : 0
Coverage : 9
RMS error : 87.8815544838649
Peptides : 1
-- dim 15 451.249908 2( 2) LSATGLVLK 33.85 0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
Protein Hit 8
===================
Accession : ZN711_HUMAN
Description : Zinc finger protein 711 OS=Homo sapiens GN=ZNF711 PE=1 SV=2
Score : 31
Mass : 86190.24
Frame : 0
Coverage : 13
RMS error : 69.4028633218151
Peptides : 1
CB BOLD 33 714.364929 1( 1) EASPLSSNKLILR 30.84 0
Proteins matching the same set of peptides:
ZN711_MOUSE Total score: 31 Peptides matched: 1
Proteins matching a subset of these peptides:
Unassigned list
---------------
CB BOLD 14 442.228302 1( 1) IAIRGLLK 28.47 0
CB BOLD 22 1101.536621 1( 1) ITVSTSGLVPK 14.40 0
CB BOLD 9 747.396179 1( 1) DAEDVAK 13.59 0
CB BOLD 23 1101.621704 1( 1) QLLMVAGVDR 12.04 0
CB BOLD 8 714.372498 1( 1) LAPAQSK 10.69 0
CB BOLD 4 662.275574 1( 1) AGNAVCK 9.73 0
CB BOLD 30 663.837891 1( 1) AQLLEINEKLR 9.54 0
CB BOLD 57 747.036072 1( 1) AMWRLVDEMVQDGFPTTAR 9.05 0
CB BOLD 55 1099.094727 1( 1) LNAEAVRTLLSANGQKPSEAK 8.05 0
CB BOLD 29 642.353577 1( 1) VVGVAGQGASALVR 7.91 0
CB BOLD 6 673.349487 1( 1) AVLGGTR 7.59 0
CB BOLD 28 642.352600 1( 1) KNVSVSQGPDPR 7.22 0
CB BOLD 38 749.383972 1( 1) QSTMQRSAAGTSTR 7.10 0
CB BOLD 50 1048.561523 1( 1) ALDEILEYQNYPVVCAKK 5.70 0
CB BOLD 49 1020.987915 1( 1) VEPPGDKTLKPGPGAHSPEK 5.49 0
CB BOLD 19 932.364380 1( 1) MHNLMDR 4.61 0
CB BOLD 20 933.499023 1( 1) SRDPGMVR 3.21 0
CB BOLD 47 665.009583 1( 1) QTLQVFKYYLMDENGK 2.25 0
CB BOLD 41 886.405884 1( 1) AGLELADSPVTPEMLGR 1.93 0
CB BOLD 18 930.703003 1( 1) ASRAQLER 1.60 0
CB BOLD 7 711.364685 1( 1) GGAHEIK 1.34 0
CB BOLD 32 711.370728 1( 1) DKAIGYTSCGNHR 1.20 0
CB BOLD 17 930.683105 1( 1) KIQAEITK 1.00 0
CB BOLD 44 949.550720 1( 1) LAARWLAEHPHAPSSVR 0.76 0
CB BOLD 43 933.003784 1( 1) ISATCVPSAVQKWFAEK 0.70 0
CB BOLD 1 498.272888 1( 1) 0.00 0
CB BOLD 2 500.256012 1( 1) 0.00 0
CB BOLD 3 575.558411 1( 1) 0.00 0
CB BOLD 5 662.417175 1( 1) 0.00 0
CB BOLD 10 747.412476 1( 1) 0.00 0
CB BOLD 42 932.460815 1( 1) 0.00 0
CB BOLD 56 1119.045166 1( 1) 0.00 0
CB BOLD 63 832.798584 1( 1) 0.00 0
CB BOLD 66 1113.894653 1( 1) 0.00 0
CB BOLD 67 1116.177490 1( 1) 0.00 0
Score Delta Hit Protein Peptide
Accessions that matched query 97 rank 1:-
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_ms2quantitation.pl

resfile_ms2quantitation.pl

Example program extracting peptide ratios from a Reporter or Multiplex file.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_ms2quantitation.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/resfile_ms2quantitation.pl $
# $Author: robertog@matrixscience.com $
# $Date: 2024-09-04 10:23:46 +0100 $
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
use warnings;
##############################################################################
use msparser;
if (@ARGV != 4) {
print STDERR "Usage: $0 <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>\n";
print STDERR "The location of schema files should be e.g.\n";
print STDERR " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd\n";
print STDERR " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd\n";
print STDERR " ../html/xmlns/schema/unimod_2/unimod_2.xsd\n";
print STDERR "if running from the Mascot cgi directory.\n";
exit 1;
}
my $quant_schema1_filepath = $ARGV[0];
my $quant_schema2_filepath = $ARGV[1];
my $unimod_schema_filepath = $ARGV[2];
my $resfile = msparser::ms_mascotresfilebase::createResfile($ARGV[3], 1);
if (not $resfile->isValid) {
print STDERR $resfile->getLastErrorString(), "\n";
exit 1;
}
# And print out related warnings, if any (we know these are only warnings,
# because isValid() returned true earlier):
dump_warnings($resfile->getErrorHandler());
$resfile->clearAllErrors();
$resfile->setXMLschemaFilePath(
$msparser::ms_mascotresfilebase::XML_SCHEMA_QUANTITATION,
"http://www.matrixscience.com/xmlns/schema/quantitation_2 $quant_schema2_filepath http://www.matrixscience.com/xmlns/schema/quantitation_1 $quant_schema1_filepath"
);
$resfile->setXMLschemaFilePath(
$msparser::ms_mascotresfilebase::XML_SCHEMA_UNIMOD,
"http://www.unimod.org/xmlns/schema/unimod_2 $unimod_schema_filepath",
);
my $qmethod = msparser::ms_quant_method->new();
if (not $resfile->getQuantitationMethod($qmethod)) {
print STDERR $resfile->getLastErrorString(), "\n";
exit 1;
}
my $pepsum;
do {
my $datfile = msparser::ms_datfile->new();
my (undef, $flags, $minprob, $maxhits, $iisb, $minpeplen, $use_pepsum, $flags2)
= $resfile->get_ms_mascotresults_params($datfile->getMascotOptions());
if (not $use_pepsum) {
print STDERR "Results file cannot be opened as a peptide summary\n";
exit 1;
}
$pepsum = msparser::ms_peptidesummary->new(
$resfile, $flags, $minprob, $maxhits, '', $iisb, $minpeplen, '', $flags2
);
if (not $resfile->isValid) {
print STDERR $resfile->getLastErrorString, "\n";
exit 1;
}
dump_warnings($resfile->getErrorHandler());
$resfile->clearAllErrors();
};
# Quantitate the file using ms_ms2quantitation:
my $ms2quant = msparser::ms_ms2quantitation->new($pepsum, $qmethod);
if (not $ms2quant->isValid) {
print STDERR $ms2quant->getLastErrorString(), "\n";
exit 1;
}
if ($ms2quant->hasIntensityNormalisation()) {
$ms2quant->normaliseIntensities();
} elsif ($ms2quant->hasPeptideRatioNormalisation()) {
$ms2quant->normalisePeptideRatios();
}
# Update the quantitation method in case ms_ms2quantitation changed any of
# the parameters:
$qmethod = $ms2quant->getQuantitationMethod();
dump_warnings($ms2quant->getErrorHandler());
$ms2quant->clearAllErrors();
# Now we can inspect peptide and protein data in $ms2quant.
# But first, dump quantitation method parameters to see what we have:
do {
my @comps = ();
for my $i (0 .. $qmethod->getNumberOfComponents()-1) {
my $comp = $qmethod->getComponentByNumber($i);
$comps[$i] = $comp->getName();
}
printf "Components: [%s]\n", join(', ', @comps);
};
my @rationames = ();
for my $i (0 .. $qmethod->getNumberOfReportRatios()-1) {
push @rationames, $qmethod->getReportRatioByNumber($i)->getName();
}
printf "Report ratios: [%s]\n", join(', ', @rationames);
printf "Protein ratio type = %s\n", $qmethod->getProteinRatioType();
printf "Min. number of peptides = %d\n", $qmethod->getMinNumPeptides();
if ($qmethod->haveQuality()) {
my $q = $qmethod->getQuality();
printf "Quality: min. precursor charge = %s\n", $q->getMinPrecursorCharge();
printf "Quality: pep. threshold type = %s\n", $q->getPepThresholdType();
printf "Quality: pep. threshold value = %s\n", $q->getPepThresholdValue();
} else {
printf "Quality: no restrictions\n";
}
if ($qmethod->haveNormalisation()) {
my $q = $qmethod->getNormalisation();
printf "Normalisation = %s\n", $q->getMethod();
if ($q->haveProteins()) {
my $p = $q->getProteins();
printf " - Accessions = %s\n", join(', ',
map { $p->getProtein($_)->getAccession() } 0 .. $p->getNumberOfProteins()-1
);
}
if ($q->havePeptides()) {
my $p = $q->getPeptides();
printf " - Sequences = %s\n", join(', ',
map { $p->getPeptide($_)->getSequence() } 0 .. $p->getNumberOfPeptides()-1
);
}
my @component_bases = ();
for (1 .. $qmethod->getNumberOfComponents()) {
my $base = $ms2quant->getIntensityNormalisationBase($qmethod->getComponentByNumber($_-1)->getName());
push @component_bases, $base;
}
printf "Intensity normalisation constants: [%s]\n", join(', ', @component_bases);
printf "Ratio normalisation constants: [%s]\n", join(', ',
map { $ms2quant->getPeptideRatioNormalisationBase($_) } @rationames
);
} else {
printf "Normalisation: none\n";
}
if ($qmethod->haveOutliers()) {
my $q = $qmethod->getOutliers();
printf "Outliers = %s\n", $q->getMethod();
} else {
printf "Outliers: none\n";
}
print "\n";
# Collect proteins we're interested in:
my @proteins = ();
for my $i (1 .. $pepsum->getNumberOfHits()) {
my $hit = $pepsum->getHit($i);
push @proteins, $hit;
my $j = 0;
while (my $protein = $pepsum->getNextFamilyProtein($i, ++$j)) {
push @proteins, $protein;
}
}
for my $protein (@proteins) {
printf "%d::%s:\n", $protein->getDB(), $protein->getAccession();
for (@rationames) {
my $ratio = $ms2quant->getProteinRatio($protein->getAccession(), $protein->getDB(), $_);
if ($ratio->isMissing()) {
printf "%10s: ---\n", $_;
} else {
printf "%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g\n",
$_, $ratio->getValue(), $ratio->getStandardError(),
$ratio->getSampleSize(), $ratio->getNormalityPvalue(),
$ratio->getHypothesisPvalue();
}
}
print "\n";
print join(' ', map { sprintf("%10s", $_) } 'Peptide', @rationames), "\n";
for my $i (1 .. $protein->getNumPeptides()) {
next if $protein->getPeptideDuplicate($i) == $msparser::ms_protein::DUPE_DuplicateSameQuery;
my $q = $protein->getPeptideQuery($i);
my $p = $protein->getPeptideP($i);
my $peptide = $pepsum->getPeptide($q, $p);
next if not $peptide;
my @values = ();
for (@rationames) {
# Note that the q,p arguments to ms_peptide_quant_key must be
# integers. Otherwise the wrong constructor is chosen. Here they
# are integers, as they are return values from Parser functions
# that return ints.
my $ratio = $ms2quant->getPeptideRatio(msparser::ms_peptide_quant_key->new($q, $p), $_);
if ($ratio->isMissing()) {
push @values, sprintf("%10s", '---');
next;
}
if ($ratio->isInfinite()) {
push @values, sprintf("%10s", '###');
} else {
push @values, sprintf("%10g", $ratio->getValue());
}
}
printf "%10s %s\n", sprintf("q%d_p%d", $q, $p), join(' ', @values);
}
print "\n";
}
sub dump_warnings {
my ($err) = @_;
for my $i (1 .. $err->getNumberOfErrors()) {
print 'Warning: ', $err->getErrorString($i), "\n";
}
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_ms2quantitation.java

resfile_ms2quantitation.java

Example program extracting peptide ratios from a Reporter or Multiplex file.

/*
* ##############################################################################
* # file: resfile_ms2quantitation.java #
* # Mascot Parser toolkit example code #
* ##############################################################################
* # COPYRIGHT NOTICE #
* # Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
* # #
* ##############################################################################
*
*/
import java.util.ArrayList;
import java.util.Arrays;
import java.util.List;
import matrix_science.msparser.ms_peptide_quant_key;
import matrix_science.msparser.ms_mascotresfilebase;
import matrix_science.msparser.ms_quant_method;
import matrix_science.msparser.ms_mascotoptions;
import matrix_science.msparser.ms_peptidesummary;
import matrix_science.msparser.ms_ms2quantitation;
import matrix_science.msparser.ms_peptide;
import matrix_science.msparser.ms_peptide_quant_ratio;
import matrix_science.msparser.ms_protein;
import matrix_science.msparser.ms_protein_quant_ratio;
import matrix_science.msparser.ms_quant_normalisation;
import matrix_science.msparser.ms_quant_outliers;
import matrix_science.msparser.ms_quant_quality;
public class resfile_ms2quantitation {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String[] args) {
if(args.length < 4) {
System.err.println("Usage: <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>");
System.err.println("The location of schema files should be e.g.");
System.err.println(" ../html/xmlns/schema/quantitation_1/quantitation_1.xsd");
System.err.println(" ../html/xmlns/schema/quantitation_2/quantitation_2.xsd");
System.err.println(" ../html/xmlns/schema/unimod_2/unimod_2.xsd");
System.err.println("if running from the Mascot cgi directory.");
System.exit(1);
}
String sQuantSchema1Filepath = args[0];
String sQuantSchema2Filepath = args[1];
String sUnimodSchemaFilepath = args[2];
ms_mascotresfilebase oResfile = ms_mascotresfilebase.createResfile(args[3],1);
if(!oResfile.isValid()) {
System.err.println(oResfile.getLastErrorString());
System.exit(1);
}
oResfile.setXMLschemaFilePath(ms_mascotresfilebase.XML_SCHEMA_QUANTITATION,
"http://www.matrixscience.com/xmlns/schema/quantitation_2 "+sQuantSchema2Filepath+" http://www.matrixscience.com/xmlns/schema/quantitation_1 "+sQuantSchema1Filepath);
oResfile.setXMLschemaFilePath(ms_mascotresfilebase.XML_SCHEMA_UNIMOD, "http://www.unimod.org/xmlns/schema/unimod_2 "+sUnimodSchemaFilepath);
ms_quant_method oQMethod = new ms_quant_method();
if(!oResfile.getQuantitationMethod(oQMethod)) {
System.err.println(oResfile.getLastErrorString());
System.exit(1);
}
// See section 'Multiple return values in Perl, Java and Python' in ms_parser help
long[] iFlags = {0};
double[] dMinProb = {0};
int[] iMaxHits = {0};
double[] dIgnoreIonsBelow = {0};
long[] iMinPepLen = {0};
boolean[] bUsePepSum = {false};
long[] iFlags2 = {0};
ms_mascotoptions oOptions = new ms_mascotoptions();
oResfile.get_ms_mascotresults_params(oOptions, iFlags, dMinProb, iMaxHits, dIgnoreIonsBelow, iMinPepLen, bUsePepSum, iFlags2);
if(!bUsePepSum[0]) {
System.err.println("Results file cannot be used to open as a peptide summary");
System.exit(1);
}
ms_peptidesummary oPepsum = new ms_peptidesummary(oResfile, (int) iFlags[0], dMinProb[0], iMaxHits[0], "", dIgnoreIonsBelow[0], (int) iMinPepLen[0], "", (int) iFlags2[0]);
if(!oResfile.isValid()) {
System.err.println(oResfile.getLastErrorString());
System.exit(1);
}
// Quantitate the file using ms_ms2quantitation:
ms_ms2quantitation oMs2Quant = new ms_ms2quantitation(oPepsum, oQMethod);
if(!oMs2Quant.isValid()) {
System.err.println(oMs2Quant.getLastErrorString());
System.exit(1);
}
// Now we can inspect protein and peptide data in oMs2Quant
// But first, dump the quantitation method parameters to see what we have:
String[] aComps = new String[oQMethod.getNumberOfComponents()];
for(int i = 0; i < oQMethod.getNumberOfComponents(); i++) {
aComps[i] = oQMethod.getComponentByNumber(i).getName();
}
System.out.printf("Components: %s\n", Arrays.toString(aComps));
String[] aRationames = new String[oQMethod.getNumberOfReportRatios()];
for(int i = 0; i < oQMethod.getNumberOfReportRatios(); i++) {
aRationames[i] = oQMethod.getReportRatioByNumber(i).getName();
}
System.out.printf("Report ratios: %s\n", Arrays.toString(aRationames));
System.out.printf("Protein ratio type = %s\n", oQMethod.getProteinRatioType());
System.out.printf("Min. number of peptides = %d\n", oQMethod.getMinNumPeptides());
if (oQMethod.haveQuality()) {
ms_quant_quality oQuality = oQMethod.getQuality();
System.out.printf("Quality: min. precursor charge = %s\n", oQuality.getMinPrecursorCharge());
System.out.printf("Quality: pep. threshold type = %s\n", oQuality.getPepThresholdType());
System.out.printf("Quality: pep. threshold value = %s\n", oQuality.getPepThresholdValue());
} else {
System.out.print("Quality: no restrictions\n");
}
if (oQMethod.haveNormalisation()) {
ms_quant_normalisation oNormalisation = oQMethod.getNormalisation();
System.out.printf("Normalisation = %s\n", oNormalisation.getMethod());
} else {
System.out.print("Normalisation: none\n");
}
if (oQMethod.haveOutliers()) {
ms_quant_outliers oOutliers = oQMethod.getOutliers();
System.out.printf("Outliers = %s\n", oOutliers.getMethod());
} else {
System.out.print("Outliers: none\n");
}
System.out.println();
// collect proteins we're interested in
List<ms_protein> aProteins = new ArrayList<ms_protein>();
for(int i = 1; i <= oPepsum.getNumberOfHits(); i++) {
aProteins.add(oPepsum.getHit(i));
int j = 0;
ms_protein oProtein;
while((oProtein = oPepsum.getNextFamilyProtein(i, ++j)) != null) {
aProteins.add(oProtein);
}
}
for(ms_protein oProtein : aProteins) {
System.out.printf("%d::%s:\n", oProtein.getDB(), oProtein.getAccession());
for(String sRationame : aRationames) {
ms_protein_quant_ratio oRatio = oMs2Quant.getProteinRatio(oProtein.getAccession(), oProtein.getDB(), sRationame);
if(oRatio.isMissing()) {
System.out.printf("%10s: ---\n", sRationame);
} else {
System.out.printf("%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g\n",
sRationame, oRatio.getValue(), oRatio.getStandardError(),
oRatio.getSampleSize(), oRatio.getNormalityPvalue(),
oRatio.getHypothesisPvalue());
}
}
System.out.println();
StringBuilder sbPeptideRatioHeader = new StringBuilder();
sbPeptideRatioHeader.append(String.format("%10s", "Peptide"));
for(String sRationame : aRationames) {
sbPeptideRatioHeader.append(" ");
sbPeptideRatioHeader.append(String.format("%10s",sRationame));
}
System.out.println(sbPeptideRatioHeader);
for(int i = 1; i <= oProtein.getNumPeptides(); i++) {
if(oProtein.getPeptideDuplicate(i) == ms_protein.DUPE_DuplicateSameQuery) continue;
int q = oProtein.getPeptideQuery(i);
int p = oProtein.getPeptideP(i);
ms_peptide oPeptide = oPepsum.getPeptide(q, p);
if(oPeptide == null) continue;
List<String> aValues = new ArrayList<String>();
for(String sRationame : aRationames) {
// Note that the q,p arguments to ms_peptide_quant_key must be integers.
// Otherwise the wrong constructor is chosen. Here they are
// integers, as they are return values from Parser functions that
// return ints.
ms_peptide_quant_ratio oRatio = oMs2Quant.getPeptideRatio(new ms_peptide_quant_key(q,p), sRationame);
if(oRatio.isMissing()) {
aValues.add(String.format("%10s", "---"));
continue;
}
if(oRatio.isInfinite()) {
aValues.add(String.format("%10s", "---"));
} else {
aValues.add(String.format("%10g", oRatio.getValue()));
}
}
StringBuilder sbValues = new StringBuilder();
for(String sValue : aValues) {
if(sbValues.length() > 0) sbValues.append(" ");
sbValues.append(sValue);
}
System.out.printf("%10s %s\n", String.format("q%d_p%d", q, p), sbValues);
}
System.out.println();
}
}
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_ms2quantitation.py

resfile_ms2quantitation.py

Example program extracting peptide ratios from a Reporter or Multiplex file.

1#!/usr/bin/python
2
16
17import msparser
18import sys
19
20# If no arguments supplied, print help and exit
21
22if len(sys.argv) != 5:
23 print("Usage: %s <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>" % sys.argv[0])
24 print("The location of schema files should be e.g.")
25 print(" ../html/xmlns/schema/quantitation_1/quantitation_1.xsd")
26 print(" ../html/xmlns/schema/quantitation_2/quantitation_2.xsd")
27 print(" ../html/xmlns/schema/unimod_2/unimod_2.xsd")
28 print("if running from the Mascot cgi directory.")
29 sys.exit(1)
30
31quant_schema1_filepath = sys.argv[1]
32quant_schema2_filepath = sys.argv[2]
33unimod_schema_filepath = sys.argv[3]
34
35resfile = msparser.ms_mascotresfilebase.createResfile(sys.argv[4], 1)
36
37if not resfile.isValid():
38 print(resfile.getLastErrorString())
39 sys.exit(1)
40
41def dump_warnings(err):
42
43 for i in ms_range(1, err.getNumberOfErrors()):
44 print('Warning: %s' %(err.getErrorString(i)))
45
46# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
47def ms_range(start, stop, step=1):
48 i = start
49 while i <= stop:
50 yield i
51 i += step
52
53# And print out related warnings, if any (we know these are only warnings,
54# because isValid() returned true earlier):
55
56dump_warnings(resfile.getErrorHandler())
57resfile.clearAllErrors()
58
59resfile.setXMLschemaFilePath(msparser.ms_mascotresfilebase.XML_SCHEMA_QUANTITATION, "http://www.matrixscience.com/xmlns/schema/quantitation_2 " + quant_schema2_filepath + " http://www.matrixscience.com/xmlns/schema/quantitation_1 " + quant_schema1_filepath)
60resfile.setXMLschemaFilePath(msparser.ms_mascotresfilebase.XML_SCHEMA_UNIMOD, "http://www.unimod.org/xmlns/schema/unimod_2 " + unimod_schema_filepath)
61
62qmethod = msparser.ms_quant_method()
63
64if not resfile.getQuantitationMethod(qmethod):
65 print(resfile.getLastErrorString())
66 sys.exit(1)
67
68
69datfile = msparser.ms_datfile()
70undef, flags, minprob, maxhits, iisb, minpeplen, use_pepsum, flags2 = resfile.get_ms_mascotresults_params(datfile.getMascotOptions())
71
72if not use_pepsum:
73 print("Results File cannot be opened as a peptide summary")
74 sys.exit(1)
75
76pepsum = msparser.ms_peptidesummary(resfile, flags, minprob, maxhits, '', iisb, minpeplen, '', flags2)
77
78if not resfile.isValid():
79 print(resfile.getLastErrorString)
80 sys.exit(1)
81
82dump_warnings(resfile.getErrorHandler())
83resfile.clearAllErrors()
84
85# Quantitate the file using ms_ms2quantitation:
86
87ms2quant = msparser.ms_ms2quantitation(pepsum, qmethod)
88
89if not ms2quant.isValid():
90 sys.exit(1)
91
92if ms2quant.hasIntensityNormalisation():
93 ms2quant.normaliseIntensities()
94elif ms2quant.hasPeptideRatioNormalisation():
95 ms2quant.normalisePeptideRatios()
96
97# Update the quantitation method in case ms_ms2quantitation changed any of
98# the parameters:
99qmethod = ms2quant.getQuantitationMethod()
100
101dump_warnings(ms2quant.getErrorHandler())
102ms2quant.clearAllErrors()
103
104# Now we can inspect peptide and protein data in ms2quant.
105# But first, dump quantitation method parameters to see what we have:
106
107comps = []
108for i in ms_range(0, qmethod.getNumberOfComponents()-1):
109 comp = qmethod.getComponentByNumber(i)
110 comps.append(comp.getName())
111
112print("Components: %s" %(comps))
113
114rationames = []
115for i in ms_range(0, qmethod.getNumberOfReportRatios()-1):
116 reportratio = qmethod.getReportRatioByNumber(i)
117 reportrationame = reportratio.getName()
118 rationames.append(reportrationame)
119print("Report ratios: %s" %(rationames))
120
121print("Protein ratio type = %s" %(qmethod.getProteinRatioType()))
122print("Min. number of peptides = %d" %(qmethod.getMinNumPeptides()))
123
124if qmethod.haveQuality():
125 q = qmethod.getQuality()
126 print("Quality: min. precursor charge = %s" %(q.getMinPrecursorCharge()))
127 print("Quality: pep. threshold type = %s" %(q.getPepThresholdType()))
128 print("Quality: pep. threshold value = %s" %(q.getPepThresholdValue()))
129else:
130 print("Quality: no restrictions")
131
132# Check for Normalisation
133
134if qmethod.haveNormalisation():
135 q = qmethod.getNormalisation()
136 print("Normalisation = %s" %(q.getMethod()))
137
138 if q.haveProteins():
139 p = q.getProteins()
140 for i in ms_range(0, p.getNumberOfProteins()-1):
141 accessions = []
142 accessions.append(p.getProtein().getAccession())
143 print(" - Accessions = %s" %(accessions))
144
145 if q.havePeptides():
146 p = q.getPeptides()
147 for i in ms_range(0, p.getNumberOfPeptides()-1):
148 peptides = []
149 peptides.append(p.getPeptide().getSequence())
150 print(" - Sequences = %s" %(peptides))
151
152 component_bases = []
153
154 for i in ms_range(0, qmethod.getNumberOfComponents()-1):
155 component = qmethod.getComponentByNumber(i)
156 compname = component.getName()
157 baseNormalisation = ms2quant.getIntensityNormalisationBase(compname)
158 component_bases.append(baseNormalisation)
159 for rationame in rationames:
160 ms2gprn = ms2quant.getPeptideRatioNormalisationBase(rationame)
161 print("Intensity normalisation constants: %s" %(component_bases))
162 print("Ratio normalisation constants: %s" %(ms2gprn))
163
164else:
165 print("Normalisation: none")
166
167if qmethod.haveOutliers():
168 q = qmethod.getOutliers()
169 print("Outliers = %s" %(q.getMethod()))
170else:
171 print("Outliers: none")
172
173print("\n")
174
175# Collect proteins we're interested in:
176proteins = []
177
178for i in ms_range(1, pepsum.getNumberOfHits()):
179 hit = pepsum.getHit(i)
180 proteins.append(hit)
181 j = 0
182 protein = pepsum.getNextFamilyProtein(i, j)
183 while protein !=None:
184 proteins.append(protein)
185 j += 1
186
187protein = ''
188for protein in proteins:
189 print("%d::%s:" %(protein.getDB(), protein.getAccession()))
190
191 for rationame in rationames:
192 ratio = ms2quant.getProteinRatio(protein.getAccession(), protein.getDB(), rationame)
193 print(rationame)
194 if ratio.isMissing():
195 print("%10s: ---" %(rationame))
196 else:
197 print("%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g" %(rationame, ratio.getValue(), ratio.getStandardError_only(), ratio.getSampleSize(), ratio.getNormalityPvalue_only(), ratio.getHypothesisPvalue_only()))
198 print(rationame)
199 print(" %10s %s" %('Peptide:', rationame))
200 for i in ms_range(1, protein.getNumPeptides()):
201 if protein.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_DuplicateSameQuery:
202 continue
203
204 q = protein.getPeptideQuery(i)
205 p = protein.getPeptideP(i)
206
207 peptide = pepsum.getPeptide(q, p)
208
209 if not peptide:
210 continue
211
212 values = ''
213 for rationame in rationames:
214 # Note that the q,p arguments to ms_peptide_quant_key must be
215 # integers. Otherwise the wrong constructor is chosen. Here they
216 # are integers, as they are return values from Parser functions
217 # that return ints.
218 quantKey = msparser.ms_peptide_quant_key(q, p)
219 ratio = ms2quant.getPeptideRatio(quantKey, rationame)
220
221 if ratio.isMissing():
222 values = "---"
223 continue
224
225 if ratio.isInfinite():
226 values = "###"
227 else:
228 values = ratio.getValue()
229
230 print(" %-9s %-10s" %("q%d_p%d" %(q, p), str(values)))
231
232 print("\n")
233
234
235
236
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_ms2quantitation.cs

resfile_ms2quantitation.cs

Example program extracting peptide ratios from a Reporter or Multiplex file.

/*
##############################################################################
# file: resfile_ms2quantitaion.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/resfile_ms2quantitation.cs $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.Collections.Generic;
using System.IO;
using System.Text;
using matrix_science.msparser;
namespace MsParserExamples
{
class resfile_ms2quantitation
{
public static void Main(string[] argv)
{
if (argv.Length < 4)
{
Console.Error.WriteLine("Usage: {0} <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>", Path.GetFileName((new resfile_ms2quantitation()).GetType().Assembly.Location));
Console.Error.WriteLine(@"The location of schema files should be e.g.
../html/xmlns/schema/quantitation_1/quantitation_1.xsd
../html/xmlns/schema/quantitation_2/quantitation_2.xsd
../html/xmlns/schema/unimod_2/unimod_2.xsd
if running from the Mascot cgi directory.");
return;
}
string sQuantSchema1Filepath = argv[0], sQuantSchema2Filepath = argv[1], sUnimodSchemaFilepath = argv[2], sResultFile = argv[3];
ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile(sResultFile, 0);
if (!resfile.isValid())
{
Console.Error.WriteLine(resfile.getLastErrorString());
return;
}
resfile.setXMLschemaFilePath(ms_mascotresfilebase.XML_SCHEMA.XML_SCHEMA_QUANTITATION, "http://www.matrixscience.com/xmlns/schema/quantitation_2 " +
sQuantSchema2Filepath + " http://www.matrixscience.com/xmlns/schema/quantitation_1 " + sQuantSchema1Filepath);
resfile.setXMLschemaFilePath(ms_mascotresfilebase.XML_SCHEMA.XML_SCHEMA_UNIMOD, "http://www.unimod.org/xmlns/schema/unimod_2 " + sUnimodSchemaFilepath);
ms_quant_method qMethod = new ms_quant_method();
if (!resfile.getQuantitationMethod(qMethod))
{
Console.Error.WriteLine(resfile.getLastErrorString());
return;
}
// calls to generate ms_peptidesummary object are not important for this example,
// see loadPeptideSummary at the end of the file for details
ms_peptidesummary pepsum;
if (!loadPeptideSummary(resfile, out pepsum))
{
return;
}
// Quantitation the file using ms_ms2quantitation:
ms_ms2quantitation ms2quant = new ms_ms2quantitation(pepsum, qMethod);
if (!ms2quant.isValid())
{
Console.Error.WriteLine(ms2quant.getLastErrorString());
return;
}
if (ms2quant.hasIntensityNormalisation())
{
ms2quant.normaliseIntensities();
}
else if (ms2quant.hasPeptideRatioNormalisation())
{
ms2quant.normalisePeptideRatios();
}
// Update the quantitation method in case ms_ms2quantitation changed any
// of the parameters:
qMethod = ms2quant.getQuantitationMethod();
dumpWarnings(ms2quant.getErrorHandler());
ms2quant.clearAllErrors();
// Now we can inspect protein and peptide data in ms2quant
// But first, dump the quantitation method parameters we have:
{
string[] comps = new string[qMethod.getNumberOfComponents()];
for (int i = 0; i < comps.Length; i++)
{
comps[i] = qMethod.getComponentByNumber(i).getName();
}
Console.WriteLine("Components: [{0}]", string.Join(", ", comps));
}
string[] ratioNames = new string[qMethod.getNumberOfReportRatios()];
for (int i = 0; i < ratioNames.Length; i++)
{
ratioNames[i] = qMethod.getReportRatioByNumber(i).getName();
}
Console.WriteLine("Report ratios [{0}]", string.Join(", ", ratioNames));
Console.WriteLine("Report ratio type = {0}", qMethod.getProteinRatioType());
Console.WriteLine("Min. number of peptides = {0}", qMethod.getMinNumPeptides());
if (qMethod.haveQuality())
{
ms_quant_quality q = qMethod.getQuality();
Console.WriteLine("Quality: min. precursor charge = {0}", q.getMinPrecursorCharge());
Console.WriteLine("Quality: pep. threshold type = {0}", q.getPepThresholdType());
Console.WriteLine("Quality: pep. threshold value = {0}", q.getPepThresholdValue());
}
else
{
Console.WriteLine("Quality: no restrictions");
}
if (qMethod.haveNormalisation())
{
ms_quant_normalisation _n = qMethod.getNormalisation();
Console.WriteLine("Normalisation = {0}", _n.getMethod());
if (_n.haveProteins())
{
ms_quant_normalisation_proteins _p = _n.getProteins();
StringBuilder sbJoin = new StringBuilder();
for (int i = 0; i < _p.getNumberOfProteins(); i++)
{
if (i > 0) sbJoin.Append(", ");
sbJoin.Append(_p.getProtein(i).getAccession());
}
Console.WriteLine(" - Accessions = {0}", sbJoin);
}
if (_n.havePeptides())
{
ms_quant_normalisation_peptides _p = _n.getPeptides();
StringBuilder sbJoin = new StringBuilder();
for (int i = 0; i < _p.getNumberOfPeptides(); i++)
{
if (i > 0) sbJoin.Append(", ");
sbJoin.Append(_p.getPeptide(i).getSequence());
}
Console.WriteLine(" - Sequences = {0}", sbJoin);
}
double[] intensityComponentBases = new double[qMethod.getNumberOfComponents()];
for (int i = 0; i < qMethod.getNumberOfComponents(); i++)
{
intensityComponentBases[i] = ms2quant.getIntensityNormalisationBase(qMethod.getComponentByNumber(i).getName());
}
double[] ratioComponentBases = new double[ratioNames.Length];
for (int i = 0; i < ratioComponentBases.Length; i++)
{
ratioComponentBases[i] = ms2quant.getPeptideRatioNormalisationBase(ratioNames[i]);
}
Console.WriteLine("Intensity normalisation constants: [{0}]", string.Join(", ", intensityComponentBases));
Console.WriteLine("Ratio normalisation constants: [{0}]", string.Join(", ", ratioComponentBases));
}
else
{
Console.WriteLine("Normalisation: none");
}
if (qMethod.haveOutliers())
{
Console.WriteLine("Outliers = {0}", qMethod.getOutliers().getMethod());
}
else
{
Console.WriteLine("Outliers: none");
}
Console.WriteLine();
// Collect the proteins we're interested in
List<ms_protein> proteins = new List<ms_protein>();
for (int i = 1; i <= pepsum.getNumberOfHits(); i++)
{
proteins.Add(pepsum.getHit(i));
int j = 0;
ms_protein protein;
while ((protein = pepsum.getNextFamilyProtein(i, ++j)) != null)
{
proteins.Add(protein);
}
}
foreach (ms_protein protein in proteins)
{
Console.WriteLine("{0}::{1}", protein.getDB(), protein.getAccession());
foreach (string rationame in ratioNames)
{
ms_protein_quant_ratio ratio = ms2quant.getProteinRatio(protein.getAccession(), protein.getDB(), rationame);
if (ratio.isMissing())
{
Console.WriteLine("{0}: ---", rationame.PadLeft(10));
}
else
{
Console.WriteLine("{0} = {1}, stderr = {2}, n = {3} normal-p = {4}, hypo-p = {5}",
rationame, ratio.getValue(), ratio.getStandardError(),
ratio.getSampleSize(), ratio.getNormalityPvalue(),
ratio.getHypothesisPvalue()
);
}
ratio.Dispose();
ratio = null;
}
Console.WriteLine();
StringBuilder sbHeader = new StringBuilder();
sbHeader.Append("Peptide".PadRight(11));
foreach (string rationame in ratioNames)
{
sbHeader.Append(" ").Append(rationame.PadRight(9));
}
Console.WriteLine(sbHeader);
for (int i = 1; i <= protein.getNumPeptides(); i++)
{
if (protein.getPeptideDuplicate(i) == ms_protein.DUPLICATE.DUPE_DuplicateSameQuery) continue;
int q = protein.getPeptideQuery(i), p = protein.getPeptideP(i);
ms_peptide peptide = pepsum.getPeptide(q, p);
if (peptide == null) continue;
List<string> aValues = new List<string>();
foreach (string rationame in ratioNames)
{
ms_peptide_quant_ratio ratio = ms2quant.getPeptideRatio(new ms_peptide_quant_key(q, p), rationame);
if (ratio.isMissing())
{
aValues.Add("---".PadRight(9));
continue;
}
if (ratio.isInfinite())
{
aValues.Add("###".PadRight(9));
}
else
{
string sValue = ratio.getValue().ToString("0.####").PadRight(9);
aValues.Add(sValue);
}
}
Console.WriteLine("{0} {1}", string.Format("q{0}_p{1}", q, p).PadRight(11), string.Join(" ", aValues));
}
Console.WriteLine();
}
pepsum.getNumberOfHits();
resfile._params();
}
private static void dumpWarnings(ms_errs ms_errs)
{
for (int i = 0; i < ms_errs.getNumberOfErrors(); i++)
{
Console.WriteLine("Warning: {0}", ms_errs.getErrorString(i));
}
}
private static bool loadPeptideSummary(ms_mascotresfilebase resfile, out ms_peptidesummary pepsum)
{
// set pepsum to null so we can return out with false if the method fails
pepsum = null;
ms_mascotoptions opts = new ms_mascotoptions();
uint flags, flags2, minpeplen;
int maxhits;
double minprob, iisb;
bool usePepsum;
resfile.get_ms_mascotresults_params(opts, out flags, out minprob, out maxhits, out iisb, out minpeplen, out usePepsum, out flags2);
if (!usePepsum)
{
Console.Error.WriteLine("Results file cannot be opened as a peptide summary");
return false;
}
pepsum = new ms_peptidesummary(resfile, flags, minprob, maxhits, "", iisb, (int)minpeplen, "", flags2);
if (!resfile.isValid())
{
Console.Error.WriteLine(resfile.getLastErrorString());
return false;
}
return true;
}
}
}
/*
resfile_ms2quantitation.exe c:\inetpub\mascot\html\xmlns\schema\quantitation_1\quantitation_1.xsd c:\inetpub\mascot\html\xmlns\schema\quantitation_2\quantitation_2.xsd c:\inetpub\mascot\html\xmlns\schema\unimod_2\unimod_2.xsd c:\inetpub\mascot\data\F981133.dat
Will give the following output:
Warning:
Components: [light, heavy]
Report ratios [Heavy/Light]
Report ratio type = median
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = at least homology
Quality: pep. threshold value = 0.05
Normalisation: none
Outliers = auto
1::K2C1_PANTR
Heavy/Light = 0.0579803721548197, stderr = 1.43947598358519, n = 5 normal-p = 0.636188020087278, hypo-p = 0.0014453988365255
Peptide Heavy/Light
q18_p1 ---
q28_p1 0
q33_p2 0.153
q38_p1 0.0406
q39_p1 0.0309
q40_p1 0.1156
q55_p1 0.058
1::TRYP_PIG
Heavy/Light = 0.0953455094336426, stderr = 1.24484972786916, n = 10 normal-p = 0.325749316021252, hypo-p = 1.98308193710695E-06
Peptide Heavy/Light
q1_p1 0
q2_p1 ---
q3_p1 0.1477
q9_p1 0
q72_p1 0.0829
q73_p1 0.0843
q74_p1 0.059
q75_p1 0.0552
q76_p1 0.0936
q77_p1 0.3288
q78_p1 0.2642
q81_p1 ---
q82_p1 0.1249
q90_p1 ---
q91_p1 0.0972
1::IGG2B_MOUSE
Heavy/Light: ---
Peptide Heavy/Light
q12_p1 0
q57_p1 ---
q58_p1 ---
q62_p1 -0.0007
q66_p1 -0.0008
1::ALBU_BOVIN
Heavy/Light = 0.0213058637909053, stderr = 1.21840219076313, n = 2 normal-p = -1, hypo-p = 0.0326462021178481
Peptide Heavy/Light
q16_p1 ---
q30_p1 0.0175
q46_p1 0.026
q49_p1 -0.0006
q50_p1 ---
1::ENPL_MOUSE
Heavy/Light = 0.826726169499555, stderr = 1.47145311768354, n = 3 normal-p = 0.429488582555117, hypo-p = 0.671039840711699
Peptide Heavy/Light
q4_p1 ---
q19_p1 ---
q20_p1 ---
q24_p2 0.3551
q26_p2 1.0692
q41_p1 0.8267
q42_p1 ---
1::NUCL_MOUSE
Heavy/Light = 1.32117663975823, stderr = 1.26401425891289, n = 3 normal-p = 0.980416559320101, hypo-p = 0.356540636322033
Peptide Heavy/Light
q5_p1 ---
q6_p1 ---
q7_p1 ---
q8_p1 ---
q44_p1 ---
q45_p1 0.937
q92_p1 1.8861
q93_p1 1.3212
1::EPHB2_HUMAN
Heavy/Light = 10.9654930264722, stderr = 1.03789418103362, n = 2 normal-p = -1,hypo-p = 0.00988679141070892
Peptide Heavy/Light
q13_p1 10.5651
q21_p1 ---
q53_p1 11.381
q88_p1 ---
1::K2C1_RAT
Heavy/Light = 0.0405615762807822, stderr = 1.59441776859148, n = 3 normal-p = 0.374888347489863, hypo-p = 0.0205371306366633
Peptide Heavy/Light
q33_p4 ---
q38_p1 0.0406
q39_p1 0.0309
q40_p1 0.1156
1::K2C75_BOVIN
Heavy/Light: ---
Peptide Heavy/Light
q28_p1 0
q38_p4 ---
q40_p6 ---
1::HNRPU_HUMAN
Heavy/Light = 0.870877403713838, stderr = 1.12071669533565, n = 2 normal-p = -1, hypo-p = 0.438890343357515
Peptide Heavy/Light
q32_p1 ---
q34_p1 ---
q51_p1 0.976
q52_p1 0.7771
1::SFPQ_HUMAN
Heavy/Light = 0.890580462682766, stderr = 1.58916835083167, n = 3 normal-p = 0.968098028626276, hypo-p = 0.825807022031107
Peptide Heavy/Light
q14_p1 0.8906
q15_p1 ---
q22_p1 ---
q69_p1 0.4372
q70_p1 1.7429
1::CAPR1_MOUSE
Heavy/Light = 1.19967671408572, stderr = 1.06348879302472, n = 3 normal-p = 0.901608333526897, hypo-p = 0.0978334823884838
Peptide Heavy/Light
q23_p1 1.0855
q36_p1 1.3043
q37_p1 1.1997
1::K2C1B_HUMAN
Heavy/Light = 0.0684746549583752, stderr = 1.68816553095394, n = 2 normal-p = -1, hypo-p = 0.122783146524372
Peptide Heavy/Light
q18_p2 ---
q38_p1 0.0406
q40_p1 0.1156
q53_p3 ---
1::ENPL_ARATH
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351
Peptide Heavy/Light
q24_p2 0.3551
q26_p2 1.0692
q41_p2 ---
q42_p10 ---
q67_p10 ---
1::VIME_CRIGR
Heavy/Light: ---
Peptide Heavy/Light
q17_p1 0.4569
q35_p1 ---
1::BCAR1_MOUSE
Heavy/Light: ---
Peptide Heavy/Light
q10_p1 ---
q11_p1 ---
q63_p1 1.025
1::HTPG_ALKEH
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351
Peptide Heavy/Light
q24_p1 0.3551
q26_p1 1.0692
q67_p9 ---
1::FAK1_MOUSE
Heavy/Light: ---
Peptide Heavy/Light
q29_p1 0.4906
1::HTPG_BDEBA
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351
Peptide Heavy/Light
q24_p3 0.3551
q26_p3 1.0692
1::K2C8_MOUSE
Heavy/Light: ---
Peptide Heavy/Light
q33_p1 0.153
1::TRY1_RAT
Heavy/Light: ---
Peptide Heavy/Light
q72_p10 ---
q73_p2 ---
q74_p2 0.2836
q75_p2 ---
q76_p2 ---
q78_p2 ---
q81_p4 ---
q82_p2 ---
1::IGKC_MOUSE
Heavy/Light: ---
Peptide Heavy/Light
q47_p1 -0.0002
q48_p1 0
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_ms2quant_to_custom.pl

resfile_ms2quant_to_custom.pl

Example program converting ms_ms2quantitation to ms_customquantitation.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_ms2quant_to_custom.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/resfile_ms2quant_to_custom.pl $
# $Author: robertog@matrixscience.com $
# $Date: 2024-09-04 10:23:46 +0100 $
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
use warnings;
##############################################################################
use msparser;
if (@ARGV != 4) {
print STDERR "Usage: $0 <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>\n";
print STDERR "The location of schema files should be e.g.\n";
print STDERR " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd\n";
print STDERR " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd\n";
print STDERR " ../html/xmlns/schema/unimod_2/unimod_2.xsd\n";
print STDERR "if running from the Mascot cgi directory.\n";
exit 1;
}
my $quant_schema1_filepath = $ARGV[0];
my $quant_schema2_filepath = $ARGV[1];
my $unimod_schema_filepath = $ARGV[2];
my $resfile = msparser::ms_mascotresfilebase::createResfile($ARGV[3], 1);
if (not $resfile->isValid) {
print STDERR $resfile->getLastErrorString(), "\n";
exit 1;
}
# And print out related warnings, if any (we know these are only warnings,
# because isValid() returned true earlier):
dump_warnings($resfile->getErrorHandler());
$resfile->clearAllErrors();
my $qmethod = msparser::ms_quant_method->new();
$resfile->setXMLschemaFilePath(
$msparser::ms_mascotresfilebase::XML_SCHEMA_QUANTITATION,
"http://www.matrixscience.com/xmlns/schema/quantitation_2 $quant_schema2_filepath http://www.matrixscience.com/xmlns/schema/quantitation_1 $quant_schema1_filepath"
);
$resfile->setXMLschemaFilePath(
$msparser::ms_mascotresfilebase::XML_SCHEMA_UNIMOD,
"http://www.unimod.org/xmlns/schema/unimod_2 $unimod_schema_filepath",
);
my $qmethod = msparser::ms_quant_method->new();
if (not $resfile->getQuantitationMethod($qmethod)) {
print STDERR $resfile->getLastErrorString(), "\n";
exit 1;
}
my $pepsum;
do {
my $datfile = msparser::ms_datfile->new();
my (undef, $flags, $minprob, $maxhits, $iisb, $minpeplen, $use_pepsum, $flags2)
= $resfile->get_ms_mascotresults_params($datfile->getMascotOptions());
if (not $use_pepsum) {
print STDERR "Results file cannot be opened as a peptide summary\n";
exit 1;
}
$pepsum = msparser::ms_peptidesummary->new(
$resfile, $flags, $minprob, $maxhits, '', $iisb, $minpeplen, '', $flags2
);
if (not $resfile->isValid) {
print STDERR $resfile->getLastErrorString, "\n";
exit 1;
}
dump_warnings($resfile->getErrorHandler());
$resfile->clearAllErrors();
};
# First quantitate the file using ms_ms2quantitation:
my $ms2quant = msparser::ms_ms2quantitation->new($pepsum, $qmethod);
if (not $ms2quant->isValid) {
print STDERR $ms2quant->getLastErrorString(), "\n";
exit 1;
}
if ($ms2quant->hasIntensityNormalisation()) {
$ms2quant->normaliseIntensities();
} elsif ($ms2quant->hasPeptideRatioNormalisation()) {
$ms2quant->normalisePeptideRatios();
}
dump_warnings($ms2quant->getErrorHandler());
$ms2quant->clearAllErrors();
# Then import the data into ms_customquantitation:
my $customquant = msparser::ms_customquantitation->new($ms2quant);
if (not $customquant->isValid) {
print STDERR $customquant->getLastErrorString(), "\n";
exit 1;
}
do {
my $err = $customquant->getErrorHandler();
# And print out related warnings, if any (we know these are only warnings,
# because isValid() returned true earlier):
for my $i (1 .. $err->getNumberOfErrors()) {
print 'Warning: ', $err->getErrorString($i), "\n";
}
};
$customquant->clearAllErrors();
# Refresh the quantitation method object, in case $customquant altered
# some of the parameters during conversion:
$qmethod = $customquant->getQuantitationMethod();
# Now we can inspect peptide and protein data in $customquant.
# But first, dump quantitation method parameters to see what we have:
do {
my @comps = ();
for my $i (0 .. $qmethod->getNumberOfComponents()-1) {
my $comp = $qmethod->getComponentByNumber($i);
$comps[$i] = $comp->getName();
}
printf "Components: [%s]\n", join(', ', @comps);
};
my @rationames = ();
for my $i (0 .. $qmethod->getNumberOfReportRatios()-1) {
push @rationames, $qmethod->getReportRatioByNumber($i)->getName();
}
printf "Report ratios: [%s]\n", join(', ', @rationames);
printf "Protein ratio type = %s\n", $qmethod->getProteinRatioType();
printf "Min. number of peptides = %d\n", $qmethod->getMinNumPeptides();
if ($qmethod->haveQuality()) {
my $q = $qmethod->getQuality();
printf "Quality: min. precursor charge = %s\n", $q->getMinPrecursorCharge();
printf "Quality: pep. threshold type = %s\n", $q->getPepThresholdType();
printf "Quality: pep. threshold value = %s\n", $q->getPepThresholdValue();
} else {
printf "Quality: no restrictions\n";
}
if ($qmethod->haveNormalisation()) {
my $q = $qmethod->getNormalisation();
printf "Normalisation = %s\n", $q->getMethod();
if ($q->haveProteins()) {
my $p = $q->getProteins();
printf " - Accessions = %s\n", join(', ',
map { $p->getProtein($_)->getAccession() } 0 .. $p->getNumberOfProteins()-1
);
}
if ($q->havePeptides()) {
my $p = $q->getPeptides();
printf " - Sequences = %s\n", join(', ',
map { $p->getPeptide($_)->getSequence() } 0 .. $p->getNumberOfPeptides()-1
);
}
my @component_bases = ();
for (1 .. $qmethod->getNumberOfComponents()) {
my $base = $ms2quant->getIntensityNormalisationBase($qmethod->getComponentByNumber($_-1)->getName());
push @component_bases, $base;
}
printf "Intensity normalisation constants: [%s]\n", join(', ', @component_bases);
printf "Ratio normalisation constants: [%s]\n", join(', ',
map { $ms2quant->getNormalisationBase($_) } @rationames
);
} else {
printf "Normalisation: none\n";
}
if ($qmethod->haveOutliers()) {
my $q = $qmethod->getOutliers();
printf "Outliers = %s\n", $q->getMethod();
} else {
printf "Outliers: none\n";
}
print "\n";
# Collect proteins we're interested in:
my @proteins = ();
for my $i (1 .. $pepsum->getNumberOfHits()) {
my $hit = $pepsum->getHit($i);
push @proteins, $hit;
my $j = 0;
while (my $protein = $pepsum->getNextFamilyProtein($i, ++$j)) {
push @proteins, $protein;
}
}
for my $protein (@proteins) {
printf "%d::%s:\n", $protein->getDB(), $protein->getAccession();
for (@rationames) {
my $ratio = $customquant->getProteinRatio($protein->getAccession(), $protein->getDB(), $_);
if ($ratio->isMissing()) {
printf "%10s: ---\n", $_;
} else {
printf "%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g\n",
$_, $ratio->getValue(), $ratio->getStandardError(),
$ratio->getSampleSize(), $ratio->getNormalityPvalue(),
$ratio->getHypothesisPvalue();
}
}
print "\n";
print join(' ', map { sprintf("%10s", $_) } 'Peptide', @rationames), "\n";
for my $i (1 .. $protein->getNumPeptides()) {
next if $protein->getPeptideDuplicate($i) == $msparser::ms_protein::DUPE_DuplicateSameQuery;
my $q = $protein->getPeptideQuery($i);
my $p = $protein->getPeptideP($i);
my $peptide = $pepsum->getPeptide($q, $p);
next if not $peptide;
my @values = ();
for (@rationames) {
# Note that the q,p arguments to ms_peptide_quant_key must be
# integers. Otherwise the wrong constructor is chosen. Here they
# are integers, as they are return values from Parser functions
# that return ints.
my $ratio = $customquant->getPeptideRatio(msparser::ms_peptide_quant_key->new($q, $p), $_);
if ($ratio->isMissing()) {
push @values, sprintf("%10s", '---');
next;
}
if ($ratio->isInfinite()) {
push @values, sprintf("%10s", '###');
} else {
push @values, sprintf("%10g", $ratio->getValue());
}
}
printf "%10s %s\n", sprintf("q%d_p%d", $q, $p), join(' ', @values);
}
print "\n";
}
sub dump_warnings {
my ($err) = @_;
for my $i (1 .. $err->getNumberOfErrors()) {
print 'Warning: ', $err->getErrorString($i), "\n";
}
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_ms2quant_to_custom.py

resfile_ms2quant_to_custom.py

Example program converting ms_ms2quantitation to ms_customquantitation.

1#!/usr/bin/python
2
15
16import msparser
17import sys
18
19# If no arguments supplied, print help and exit
20
21if len(sys.argv) != 5:
22 print("Usage: %s <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>" % sys.argv[0])
23 print("The location of schema files should be e.g.")
24 print(" ../html/xmlns/schema/quantitation_1/quantitation_1.xsd")
25 print(" ../html/xmlns/schema/quantitation_2/quantitation_2.xsd")
26 print(" ../html/xmlns/schema/unimod_2/unimod_2.xsd")
27 print("if running from the Mascot cgi directory.")
28 sys.exit(1)
29
30quant_schema1_filepath = sys.argv[1]
31quant_schema2_filepath = sys.argv[2]
32unimod_schema_filepath = sys.argv[3]
33
34resfile = msparser.ms_mascotresfilebase.createResfile(sys.argv[4], 1)
35
36if not resfile.isValid():
37 print(resfile.getLastErrorString())
38 sys.exit(1)
39
40# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
41def ms_range(start, stop, step=1):
42 i = start
43 while i <= stop:
44 yield i
45 i += step
46
47def dump_warnings(err):
48
49 for i in ms_range(1, err.getNumberOfErrors()):
50 print('Warning: %s' %(err.getErrorString(i)))
51
52# And print out related warnings, if any (we know these are only warnings,
53# because isValid() returned true earlier):
54
55dump_warnings(resfile.getErrorHandler())
56resfile.clearAllErrors()
57
58resfile.setXMLschemaFilePath(msparser.ms_mascotresfilebase.XML_SCHEMA_QUANTITATION, "http://www.matrixscience.com/xmlns/schema/quantitation_2 " + quant_schema2_filepath + " http://www.matrixscience.com/xmlns/schema/quantitation_1 " + quant_schema1_filepath)
59resfile.setXMLschemaFilePath(msparser.ms_mascotresfilebase.XML_SCHEMA_UNIMOD, "http://www.unimod.org/xmlns/schema/unimod_2 " + unimod_schema_filepath)
60
61qmethod = msparser.ms_quant_method()
62
63if not resfile.getQuantitationMethod(qmethod):
64 print(resfile.getLastErrorString())
65 sys.exit(1)
66
67datfile = msparser.ms_datfile()
68undef, flags, minprob, maxhits, iisb, minpeplen, use_pepsum, flags2 = resfile.get_ms_mascotresults_params(datfile.getMascotOptions())
69
70if not use_pepsum:
71 print("Results File cannot be opened as a peptide summary")
72 sys.exit(1)
73
74pepsum = msparser.ms_peptidesummary(resfile, flags, minprob, maxhits, '', iisb, minpeplen, '', flags2)
75
76if not resfile.isValid():
77 print(resfile.getLastErrorString)
78 sys.exit(1)
79
80dump_warnings(resfile.getErrorHandler())
81resfile.clearAllErrors()
82
83# Quantitate the file using ms_ms2quantitation:
84
85ms2quant = msparser.ms_ms2quantitation(pepsum, qmethod)
86
87if not ms2quant.isValid():
88 print(ms2quant.getLastErrorString())
89 sys.exit(1)
90
91if ms2quant.hasIntensityNormalisation():
92 ms2quant.normaliseIntensities()
93elif ms2quant.hasPeptideRatioNormalisation():
94 ms2quant.normalisePeptideRatios()
95
96dump_warnings(ms2quant.getErrorHandler())
97ms2quant.clearAllErrors()
98
99# Then import the data into ms_customquantitation:
100customquant = msparser.ms_ms1quantitation(pepsum, qmethod)
101
102if not customquant.isValid():
103 print(customquant.getLastErrorString())
104 sys.exit(1)
105
106err = customquant.getErrorHandler()
107# And print out related warnings, if any (we know these are only warnings,
108# because isValid() returned true earlier):
109
110for i in range(1, err.getNumberOfErrors()):
111 print("Warning: %s" %(err.getErrorString(i)))
112
113customquant.clearAllErrors()
114
115# Refresh the quantitation method object, in case customquant altered
116# some of the parameters during conversion:
117
118qmethod = customquant.getQuantitationMethod()
119
120# Now we can inspect peptide and protein data in customquant.
121# But first, dump quantitation method parameters to see what we have:
122
123comps = []
124
125for i in ms_range(0, qmethod.getNumberOfComponents()-1):
126 comp = qmethod.getComponentByNumber(i)
127 comps.append(comp.getName())
128
129print("Components: %s" %(comps))
130
131rationames = []
132
133for i in ms_range(0, qmethod.getNumberOfReportRatios()-1):
134 ratioByNumber = qmethod.getReportRatioByNumber(i)
135 rationames.append(ratioByNumber.getName())
136
137print("Report Ratios: %s" %(rationames))
138print("Protein ratio type = %s" %(qmethod.getProteinRatioType()))
139print("Min. number of peptides = %d" %(qmethod.getMinNumPeptides()))
140
141if qmethod.haveQuality():
142 q = qmethod.getQuality()
143 print("Quality: min. precursor charge = %s" %(q.getMinPrecursorCharge()))
144 print("Quality: pep. threshold type = %s" %(q.getPepThresholdType()))
145 print("Quality: pep. threshold value = %s" %(q.getPepThresholdValue()))
146else:
147 print("Quality: no restrictions")
148
149if qmethod.haveNormalisation():
150 q = qmethod.getNormalisation()
151 print("Normalisation = %s" %(q.getMethod()))
152 if q.haveProteins():
153 p = q.getProteins()
154 print("getProteins")
155 for i in ms_range(0, p.getNumberOfProteins()-1):
156 proteins = p.getProteins(i)
157 protein = proteins.getAccession()
158 print(" - Accessions = %s" %(protein))
159
160 if q.havePeptides():
161 p = q.getPeptides()
162 peptides = p.getPeptides()
163 for i in ms_range(0, p.getNumberOfPeptides()-1):
164 peptides = p.getPeptides(i)
165 peptide = peptides.getSequence()
166 print(" - Sequences = %s" %(peptide))
167
168 component_bases = []
169 for i in ms_range(0, qmethod.getNumberOfComponents()-1):
170 gcbn = qmethod.getComponentByNumber(i)
171 base = ms2quant.getIntensityNormalisationBase(gcbn.getName())
172 component_bases.append(base)
173
174 print("Intensity normalisation constants: %s" %(component_bases))
175 print("Ration normalisation constants: %s" %(rationames))
176
177else:
178 print("Normalisation: none")
179
180if qmethod.haveOutliers():
181 q = qmethod.getOutliers()
182 print("Outliers = %s" %(q.getMethod()))
183else:
184 print("Outliers: none")
185
186print("\n")
187
188# Collect proteins we're interested in:
189
190proteins = []
191
192for i in ms_range(1, pepsum.getNumberOfHits()):
193 hit = pepsum.getHit(i)
194 proteins.append(hit)
195 j = 0
196 protein = pepsum.getNextFamilyProtein(i, j)
197 while protein !=None:
198 proteins.append(protein)
199 j += 1
200
201for protein in proteins:
202 print("%d::%s:" %(protein.getDB(), protein.getAccession()))
203
204 for rationame in rationames:
205 ratio = customquant.getProteinRatio(protein.getAccession(), protein.getDB(), rationame)
206
207 if ratio.isMissing():
208 print("%10s: ---" %(rationame))
209 else:
210 print("%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hyp-p = %6g" %(rationame, ratio.getValue(), ratio.getStandardError_only(), ratio.getSampleSize(), ratio.getNormalityPvalue_only(), ratio.getHypothesisPvalue_only()))
211
212 print(" %10s %s" %('Peptide:', rationame))
213
214 for i in ms_range(1, protein.getNumPeptides()):
215 if protein.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_DuplicateSameQuery:
216 continue
217 q = protein.getPeptideQuery(i)
218 p = protein.getPeptideP(i)
219
220 peptide = pepsum.getPeptide(q, p)
221
222 if not peptide:
223 continue
224
225 values = ''
226 for rationame in rationames:
227 # Note that the q,p arguments to ms_peptide_quant_key must be
228 # integers. Otherwise the wrong constructor is chosen. Here they
229 # are integers, as they are return values from Parser functions
230 # that return ints.
231 quantKey = msparser.ms_peptide_quant_key(q, p)
232 ratio = ms2quant.getPeptideRatio(quantKey, rationame)
233
234 if ratio.isMissing():
235 values = "---"
236 continue
237
238 if ratio.isInfinite():
239 values = "###"
240 else:
241 values = ratio.getValue()
242
243 print(" %-9s %-10s" %("q%d_p%d" %(q, p), str(values)))
244
245 print("\n")
246
247
248
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_ms2quant_to_custom.cs

resfile_ms2quant_to_custom.cs

Example program converting ms_ms2quantitation to ms_customquantitation.

/*
##############################################################################
# file: resfile_ms2quant_to_custom.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/resfile_ms2quant_to_custom.cs $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.Collections.Generic;
using System.Text;
using System.IO;
using matrix_science.msparser;
namespace MsParserExamples
{
class resfile_ms2quant_to_custom
{
public static int Main(string[] argv)
{
if (argv.Length < 4)
{
Console.Error.WriteLine("Usage: {0} <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>", Path.GetFileName((new resfile_ms2quant_to_custom()).GetType().Assembly.Location));
Console.Error.WriteLine(@"The location of schema files should be e.g.
../html/xmlns/schema/quantitation_1/quantitation_1.xsd
../html/xmlns/schema/quantitation_2/quantitation_2.xsd
../html/xmlns/schema/unimod_2/unimod_2.xsd
if running from the Mascot cgi directory.");
return 1;
}
string sQuantSchema1Filepath = argv[0], sQuantSchema2Filepath = argv[1], sUnimodSchemaFilepath = argv[2], sResultFile = argv[3];
ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile(sResultFile);
if (!resfile.isValid())
{
Console.Error.WriteLine(resfile.getLastErrorString());
return 1;
}
// print out any warnings, if any (we know these are only warnings,
// because isValid() returned true
dumpWarnings(resfile.getErrorHandler());
resfile.clearAllErrors();
resfile.setXMLschemaFilePath(ms_mascotresfilebase.XML_SCHEMA.XML_SCHEMA_QUANTITATION, "http://www.matrixscience.com/xmlns/schema/quantitation_2 " +
sQuantSchema2Filepath + " http://www.matrixscience.com/xmlns/schema/quantitation_1 " + sQuantSchema1Filepath);
resfile.setXMLschemaFilePath(ms_mascotresfilebase.XML_SCHEMA.XML_SCHEMA_UNIMOD, "http://www.unimod.org/xmlns/schema/unimod_2 " + sUnimodSchemaFilepath);
ms_quant_method qmethod = new ms_quant_method();
if (!resfile.getQuantitationMethod(qmethod))
{
Console.Error.WriteLine(resfile.getLastErrorString());
return 1;
}
ms_peptidesummary pepsum;
{
ms_datfile datfile = new ms_datfile();
uint flags, flags2, minpeplen;
int maxhits;
double minprob, iisb;
bool usePepsum;
resfile.get_ms_mascotresults_params(datfile.getMascotOptions(), out flags, out minprob, out maxhits, out iisb, out minpeplen, out usePepsum, out flags2);
if (!usePepsum)
{
Console.Error.WriteLine("Results file cannot be opened as a peptide summary");
return 1;
}
pepsum = new ms_peptidesummary(resfile, flags, minprob, maxhits, "", iisb, (int)minpeplen, "", flags2);
if (!resfile.isValid())
{
Console.Error.WriteLine(resfile.getLastErrorString());
return 1;
}
dumpWarnings(resfile.getErrorHandler());
resfile.clearAllErrors();
}
// First quantitate the file using ms_ms2quantitation:
ms_ms2quantitation ms2quant = new ms_ms2quantitation(pepsum, qmethod);
if (!ms2quant.isValid())
{
Console.Error.WriteLine(ms2quant.getLastErrorString());
return 1;
}
if (ms2quant.hasIntensityNormalisation())
{
ms2quant.normaliseIntensities();
}
else if (ms2quant.hasPeptideRatioNormalisation())
{
ms2quant.normalisePeptideRatios();
}
dumpWarnings(ms2quant.getErrorHandler());
ms2quant.clearAllErrors();
// Then import the data into ms_customquantitation:
ms_customquantitation customquant = new ms_customquantitation(ms2quant);
if (!customquant.isValid())
{
Console.Error.WriteLine(customquant.getLastErrorString());
return 1;
}
dumpWarnings(customquant.getErrorHandler());
customquant.clearAllErrors();
// Refresh the quantitation method object, incase customquant altered
// some of the parameters during conversion
qmethod = customquant.getQuantitationMethod();
// Now we can inspect peptide and protein data in customquant
// But first, dump the quantitation method parameters to see what we have:
{
List<string> comps = new List<string>();
for (int i = 0; i < qmethod.getNumberOfComponents(); i++)
{
comps.Add(qmethod.getComponentByNumber(i).getName());
}
Console.WriteLine("Components: {0}", string.Join(", ", comps));
}
List<string> ratioNames = new List<string>();
for(int i = 0; i < qmethod.getNumberOfReportRatios(); i++) {
ratioNames.Add(qmethod.getReportRatioByNumber(i).getName());
}
Console.WriteLine("Report ratios: [{0}]", string.Join(", ", ratioNames));
Console.WriteLine("Protein ratio type = {0}", qmethod.getProteinRatioType());
Console.WriteLine("Min. number of peptides = {0}", qmethod.getMinNumPeptides());
if(qmethod.haveQuality()) {
ms_quant_quality q = qmethod.getQuality();
Console.WriteLine("Quality: min. precursor charge = {0}", q.getMinPrecursorCharge());
Console.WriteLine("Quality: pep. threshold type = {0}", q.getPepThresholdType());
Console.WriteLine("Quality: pep. threshold value = {0}", q.getPepThresholdValue());
} else {
Console.WriteLine("Quality: no restrictions");
}
if (qmethod.haveNormalisation())
{
ms_quant_normalisation _n = qmethod.getNormalisation();
Console.WriteLine("Normalisation = {0}", _n.getMethod());
if (_n.haveProteins())
{
ms_quant_normalisation_proteins _p = _n.getProteins();
StringBuilder sbJoin = new StringBuilder();
for (int i = 0; i < _p.getNumberOfProteins(); i++)
{
if (i > 0) sbJoin.Append(", ");
sbJoin.Append(_p.getProtein(i).getAccession());
}
Console.WriteLine(" - Accessions = {0}", sbJoin);
}
if (_n.havePeptides())
{
ms_quant_normalisation_peptides _p = _n.getPeptides();
StringBuilder sbJoin = new StringBuilder();
for (int i = 0; i < _p.getNumberOfPeptides(); i++)
{
if (i > 0) sbJoin.Append(", ");
sbJoin.Append(_p.getPeptide(i).getSequence());
}
Console.WriteLine(" - Sequences = {0}", sbJoin);
}
double[] intensityComponentBases = new double[qmethod.getNumberOfComponents()];
for (int i = 0; i < qmethod.getNumberOfComponents(); i++)
{
intensityComponentBases[i] = ms2quant.getIntensityNormalisationBase(qmethod.getComponentByNumber(i).getName());
}
double[] ratioComponentBases = new double[ratioNames.Count];
for (int i = 0; i < ratioComponentBases.Length; i++)
{
ratioComponentBases[i] = ms2quant.getPeptideRatioNormalisationBase(ratioNames[i]);
}
Console.WriteLine("Intensity normalisation constants: [{0}]", string.Join(", ", intensityComponentBases));
Console.WriteLine("Ratio normalisation constants: [{0}]", string.Join(", ", ratioComponentBases));
}
else
{
Console.WriteLine("Normalisation: none");
}
if (qmethod.haveOutliers())
{
Console.WriteLine("Outliers = {0}", qmethod.getOutliers().getMethod());
}
else
{
Console.WriteLine("Outliers: none");
}
Console.WriteLine();
//Collect the proteins we're interested in
List<ms_protein> proteins = new List<ms_protein>();
for (int i = 1; i <= pepsum.getNumberOfHits(); i++)
{
proteins.Add(pepsum.getHit(i));
int j = 0;
ms_protein protein;
while ((protein = pepsum.getNextFamilyProtein(i, ++j)) != null)
{
proteins.Add(protein);
}
}
foreach (ms_protein protein in proteins)
{
Console.WriteLine("{0}::{1}", protein.getDB(), protein.getAccession());
foreach (string rationame in ratioNames)
{
ms_protein_quant_ratio ratio = ms2quant.getProteinRatio(protein.getAccession(), protein.getDB(), rationame);
if (ratio.isMissing())
{
Console.WriteLine("{0}: ---", rationame.PadLeft(10));
}
else
{
Console.WriteLine("{0} = {1}, stderr = {2}, n = {3} normal-p = {4}, hypo-p = {5}",
rationame, ratio.getValue(), ratio.getStandardError(),
ratio.getSampleSize(), ratio.getNormalityPvalue(),
ratio.getHypothesisPvalue()
);
}
ratio.Dispose();
ratio = null;
}
Console.WriteLine();
StringBuilder sbHeader = new StringBuilder();
sbHeader.Append("Peptide".PadRight(11));
foreach (string rationame in ratioNames)
{
sbHeader.Append(" ").Append(rationame.PadRight(9));
}
Console.WriteLine(sbHeader);
for (int i = 1; i <= protein.getNumPeptides(); i++)
{
if (protein.getPeptideDuplicate(i) == ms_protein.DUPLICATE.DUPE_DuplicateSameQuery) continue;
int q = protein.getPeptideQuery(i), p = protein.getPeptideP(i);
ms_peptide peptide = pepsum.getPeptide(q, p);
if (peptide == null) continue;
List<string> aValues = new List<string>();
foreach (string rationame in ratioNames)
{
ms_peptide_quant_ratio ratio = ms2quant.getPeptideRatio(new ms_peptide_quant_key(q, p), rationame);
if (ratio.isMissing())
{
aValues.Add("---".PadRight(9));
continue;
}
if (ratio.isInfinite())
{
aValues.Add("###".PadRight(9));
}
else
{
string sValue = ratio.getValue().ToString("0.####").PadRight(9);
aValues.Add(sValue);
}
}
Console.WriteLine("{0} {1}", string.Format("q{0}_p{1}", q, p).PadRight(11), string.Join(" ", aValues));
}
Console.WriteLine();
}
pepsum.getNumberOfHits();
resfile._params();
return 0;
}
private static void dumpWarnings(ms_errs ms_errs)
{
for (int i = 1; i <= ms_errs.getNumberOfErrors(); i++)
{
Console.Error.WriteLine("Warning: {0}", ms_errs.getErrorString(i));
}
}
}
}
/*
resfile_ms2quant_to_custom.exe c:\inetpub\mascot\html\xmlns\schema\quantitation_1\quantitation_1.xsd c:\inetpub\mascot\html\xmlns\schema\quantitation_2\quantitation_2.xsd c:\inetpub\mascot\html\xmlns\schema\unimod_2\unimod_2.xsd c:\inetpub\mascot\data\F981133.dat
Will give the following output:
Warning: Protein ratio type weighted is only implemented in Reporter (current protocol is multiplex); resetting to median
Components: light, heavy
Report ratios: [Heavy/Light]
Protein ratio type = median
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = at least homology
Quality: pep. threshold value = 0.05
Normalisation: none
Outliers = auto
1::K2C1_PANTR
Heavy/Light = 0.0579803721548197, stderr = 1.43947598358519, n = 5 normal-p = 0.636188020087278, hypo-p = 0.0014453988365255
Peptide Heavy/Light
q18_p1 ---
q28_p1 0
q33_p2 0.153
q38_p1 0.0406
q39_p1 0.0309
q40_p1 0.1156
q55_p1 0.058
1::TRYP_PIG
Heavy/Light = 0.0953455094336426, stderr = 1.24484972786916, n = 10 normal-p = 0.325749316021252, hypo-p = 1.98308193710695E-06
Peptide Heavy/Light
q1_p1 0
q2_p1 ---
q3_p1 0.1477
q9_p1 0
q72_p1 0.0829
q73_p1 0.0843
q74_p1 0.059
q75_p1 0.0552
q76_p1 0.0936
q77_p1 0.3288
q78_p1 0.2642
q81_p1 ---
q82_p1 0.1249
q90_p1 ---
q91_p1 0.0972
1::IGG2B_MOUSE
Heavy/Light: ---
Peptide Heavy/Light
q12_p1 0
q57_p1 ---
q58_p1 ---
q62_p1 -0.0007
q66_p1 -0.0008
1::ALBU_BOVIN
Heavy/Light = 0.0213058637909053, stderr = 1.21840219076313, n = 2 normal-p = -1, hypo-p = 0.0326462021178481
Peptide Heavy/Light
q16_p1 ---
q30_p1 0.0175
q46_p1 0.026
q49_p1 -0.0006
q50_p1 ---
1::ENPL_MOUSE
Heavy/Light = 0.826726169499555, stderr = 1.47145311768354, n = 3 normal-p = 0.429488582555117, hypo-p = 0.671039840711699
Peptide Heavy/Light
q4_p1 ---
q19_p1 ---
q20_p1 ---
q24_p2 0.3551
q26_p2 1.0692
q41_p1 0.8267
q42_p1 ---
1::NUCL_MOUSE
Heavy/Light = 1.32117663975823, stderr = 1.26401425891289, n = 3 normal-p = 0.980416559320101, hypo-p = 0.356540636322033
Peptide Heavy/Light
q5_p1 ---
q6_p1 ---
q7_p1 ---
q8_p1 ---
q44_p1 ---
q45_p1 0.937
q92_p1 1.8861
q93_p1 1.3212
1::EPHB2_HUMAN
Heavy/Light = 10.9654930264722, stderr = 1.03789418103362, n = 2 normal-p = -1,hypo-p = 0.00988679141070892
Peptide Heavy/Light
q13_p1 10.5651
q21_p1 ---
q53_p1 11.381
q88_p1 ---
1::K2C1_RAT
Heavy/Light = 0.0405615762807822, stderr = 1.59441776859148, n = 3 normal-p = 0.374888347489863, hypo-p = 0.0205371306366633
Peptide Heavy/Light
q33_p4 ---
q38_p1 0.0406
q39_p1 0.0309
q40_p1 0.1156
1::K2C75_BOVIN
Heavy/Light: ---
Peptide Heavy/Light
q28_p1 0
q38_p4 ---
q40_p6 ---
1::HNRPU_HUMAN
Heavy/Light = 0.870877403713838, stderr = 1.12071669533565, n = 2 normal-p = -1, hypo-p = 0.438890343357515
Peptide Heavy/Light
q32_p1 ---
q34_p1 ---
q51_p1 0.976
q52_p1 0.7771
1::SFPQ_HUMAN
Heavy/Light = 0.890580462682766, stderr = 1.58916835083167, n = 3 normal-p = 0.968098028626276, hypo-p = 0.825807022031107
Peptide Heavy/Light
q14_p1 0.8906
q15_p1 ---
q22_p1 ---
q69_p1 0.4372
q70_p1 1.7429
1::CAPR1_MOUSE
Heavy/Light = 1.19967671408572, stderr = 1.06348879302472, n = 3 normal-p = 0.901608333526897, hypo-p = 0.0978334823884838
Peptide Heavy/Light
q23_p1 1.0855
q36_p1 1.3043
q37_p1 1.1997
1::K2C1B_HUMAN
Heavy/Light = 0.0684746549583752, stderr = 1.68816553095394, n = 2 normal-p = -1, hypo-p = 0.122783146524372
Peptide Heavy/Light
q18_p2 ---
q38_p1 0.0406
q40_p1 0.1156
q53_p3 ---
1::ENPL_ARATH
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351
Peptide Heavy/Light
q24_p2 0.3551
q26_p2 1.0692
q41_p2 ---
q42_p10 ---
q67_p10 ---
1::VIME_CRIGR
Heavy/Light: ---
Peptide Heavy/Light
q17_p1 0.4569
q35_p1 ---
1::BCAR1_MOUSE
Heavy/Light: ---
Peptide Heavy/Light
q10_p1 ---
q11_p1 ---
q63_p1 1.025
1::HTPG_ALKEH
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351
Peptide Heavy/Light
q24_p1 0.3551
q26_p1 1.0692
q67_p9 ---
1::FAK1_MOUSE
Heavy/Light: ---
Peptide Heavy/Light
q29_p1 0.4906
1::HTPG_BDEBA
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351
Peptide Heavy/Light
q24_p3 0.3551
q26_p3 1.0692
1::K2C8_MOUSE
Heavy/Light: ---
Peptide Heavy/Light
q33_p1 0.153
1::TRY1_RAT
Heavy/Light: ---
Peptide Heavy/Light
q72_p10 ---
q73_p2 ---
q74_p2 0.2836
q75_p2 ---
q76_p2 ---
q78_p2 ---
q81_p4 ---
q82_p2 ---
1::IGKC_MOUSE
Heavy/Light: ---
Peptide Heavy/Light
q47_p1 -0.0002
q48_p1 0
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_customquantitation.pl

resfile_customquantitation.pl

Example program illustrating basic usage of ms_customquantitation.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_customquantitation.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/resfile_customquantitation.pl $
# $Author: villek@matrixscience.com $
# $Date: 2018-07-30 16:23:53 +0100 $
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
use warnings;
##############################################################################
use msparser;
# This example uses fictitious data to illustrate how ms_customquantitation can
# be used with the Average protocol. In a real situation peptide intensities
# and the protein-peptide mapping would come from some external source.
my @protein_peptide_mapping = (
{ accession => 'ALBU_HUMAN', peptides => [ [1, 1], [2, 1], [3, 1] ] },
{ accession => 'ALBU_BOVIN', peptides => [ [2, 2], [5, 1], [7, 1] ] },
);
my %peptide_intensities = (
'q1p1' => 1_000,
'q2p1' => 500,
'q3p1' => 750,
'q2p2' => 750,
'q5p1' => 2_000,
'q7p1' => 1_000,
);
my $qmethod = msparser::ms_quant_method->new();
do {
my $average = msparser::ms_quant_average->new;
$average->setReferenceAccession('ALBU_HUMAN');
$average->setReferenceAmount('1.0');
# We set the number of top N peptides to 2, so we expect the following
# peptide intensities to be used:
# ALBU_HUMAN = 1000, 750
# ALBU_BOVIN = 2000, 1000
$average->setNumPeptides(2);
my $p = msparser::ms_quant_protocol->new;
$p->setAverage($average);
$qmethod->setProtocol($p);
};
# Since ms_customquantitation does not use the ratio definitions in the
# quantitation method, we need not define them at all. Ratios are meaningless
# in the Average protocol anyway, so we can use any name we want to denote
# the intensity values.
my $rationame = "amount";
set_params($qmethod,
normalisation => 'none',
outliers => 'none',
protein_ratio_type => 'average',
min_num_peptides => 1,
);
my $customquant = msparser::ms_customquantitation->new($qmethod);
if (not $customquant->isValid) {
print STDERR $customquant->getLastErrorString(), "\n";
exit 1;
}
dump_warnings($customquant->getErrorHandler());
$customquant->clearAllErrors();
dump_quant_method($qmethod, [$rationame]);
# Create the protein-peptide mapping:
for (@protein_peptide_mapping) {
my ($acc, $peptides) = @$_{qw(accession peptides)};
for (@$peptides) {
# Note that the q,p arguments to ms_peptide_quant_key must be integers.
# Otherwise the wrong constructor is chosen. Adding to 0 converts the
# values to integers.
$customquant->addPeptideQuantKey($acc, 0, msparser::ms_peptide_quant_key->new(0+$$_[0], 0+$$_[1]));
}
}
# Add peptide intensities:
for (keys %peptide_intensities) {
my ($q, $p) = $_ =~ /q(\d+)p(\d+)/;
my $ratio = msparser::ms_peptide_quant_ratio->new(msparser::ms_peptide_quant_key->new(0+$q, 0+$p), $rationame, $peptide_intensities{$_});
$customquant->addPeptideRatio($ratio);
}
print "\n";
# Print it all out immediately:
for my $mapping (@protein_peptide_mapping) {
printf "%s:\n", $$mapping{'accession'};
my $ratio = $customquant->getProteinRatio($$mapping{'accession'}, 0, $rationame);
if ($ratio->isMissing()) {
printf "%10s: ---\n", $rationame;
} else {
printf "%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g\n",
$rationame, $ratio->getValue(), $ratio->getStandardError(),
$ratio->getSampleSize(), $ratio->getNormalityPvalue(),
$ratio->getHypothesisPvalue();
}
print "\n";
print join(' ', map { sprintf("%10s", $_) } 'Peptide', $rationame), "\n";
for (@{ $$mapping{'peptides'} }) {
my ($q, $p) = @$_;
my @values = ();
my $ratio = $customquant->getPeptideRatio(msparser::ms_peptide_quant_key->new(0+$q, 0+$p), $rationame);
if ($ratio->isMissing()) {
push @values, sprintf("%10s", '---');
} elsif ($ratio->isInfinite()) {
push @values, sprintf("%10s", '###');
} else {
push @values, sprintf("%10g", $ratio->getValue());
}
printf "%10s %s\n", sprintf("q%d_p%d", $q, $p), join(' ', @values);
}
print "\n";
}
sub set_params {
my ($qmethod, %h) = @_;
my $quality;
if ($qmethod->haveQuality) {
$quality = $qmethod->getQuality();
} else {
$quality = msparser::ms_quant_quality->new();
}
my $normalisation;
if ($qmethod->haveNormalisation) {
$normalisation = $qmethod->getNormalisation();
} else {
$normalisation = msparser::ms_quant_normalisation->new();
}
my $outliers;
if ($qmethod->haveOutliers) {
$outliers = $qmethod->getOutliers();
} else {
$outliers = msparser::ms_quant_outliers->new();
}
$normalisation->setMethod($h{'normalisation'} || 'none');
$outliers->setMethod($h{'outliers'} || 'none');
$qmethod->setMinNumPeptides($h{'min_num_peptides'} || 2);
$qmethod->setProteinRatioType($h{'protein_ratio_type'} || 'average');
$quality->setMinPrecursorCharge($h{'min_precursor_charge'} || 1);
$quality->setPepThresholdType($h{'pep_threshold_type'} || 'maximum expect');
$quality->setPepThresholdValue($h{'pep_threshold_value'} || '0.05');
$qmethod->setQuality($quality);
$qmethod->setNormalisation($normalisation);
$qmethod->setOutliers($outliers);
}
sub dump_quant_method {
my ($qmethod, $rationames) = @_;
do {
my @comps = ();
for my $i (0 .. $qmethod->getNumberOfComponents()-1) {
my $comp = $qmethod->getComponentByNumber($i);
$comps[$i] = $comp->getName();
}
printf "Components: [%s]\n", join(', ', @comps);
};
printf "Report ratios: [%s]\n", join(', ', @$rationames);
printf "Protein ratio type = %s\n", $qmethod->getProteinRatioType();
printf "Min. number of peptides = %d\n", $qmethod->getMinNumPeptides();
if ($qmethod->haveQuality()) {
my $q = $qmethod->getQuality();
printf "Quality: min. precursor charge = %s\n", $q->getMinPrecursorCharge();
printf "Quality: pep. threshold type = %s\n", $q->getPepThresholdType();
printf "Quality: pep. threshold value = %s\n", $q->getPepThresholdValue();
} else {
printf "Quality: no restrictions\n";
}
if ($qmethod->haveNormalisation()) {
my $q = $qmethod->getNormalisation();
printf "Normalisation = %s\n", $q->getMethod();
} else {
printf "Normalisation: none\n";
}
if ($qmethod->haveOutliers()) {
my $q = $qmethod->getOutliers();
printf "Outliers = %s\n", $q->getMethod();
} else {
printf "Outliers: none\n";
}
}
sub dump_warnings {
my ($err) = @_;
for my $i (1 .. $err->getNumberOfErrors()) {
print 'Warning: ', $err->getErrorString($i), "\n";
}
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_customquantitation.java

resfile_customquantitation.java

Example program illustrating basic usage of ms_customquantitation.

/*
* ##############################################################################
* # file: resfile_customquantitation #
* # Mascot Parser toolkit example code #
* ##############################################################################
* # COPYRIGHT NOTICE #
* # Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
* # #
* ##############################################################################
*/
import java.util.ArrayList;
import java.util.Arrays;
import java.util.HashMap;
import java.util.List;
import java.util.Set;
import matrix_science.msparser.ms_customquantitation;
import matrix_science.msparser.ms_errs;
import matrix_science.msparser.ms_peptide_quant_key;
import matrix_science.msparser.ms_peptide_quant_ratio;
import matrix_science.msparser.ms_protein_quant_ratio;
import matrix_science.msparser.ms_quant_average;
import matrix_science.msparser.ms_quant_method;
import matrix_science.msparser.ms_quant_normalisation;
import matrix_science.msparser.ms_quant_outliers;
import matrix_science.msparser.ms_quant_protocol;
import matrix_science.msparser.ms_quant_quality;
public class resfile_customquantitation {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String[] args) {
HashMap<String, List<Integer[]>> hmProteinPeptideMapping = new HashMap<String, List<Integer[]>>();
ArrayList<Integer[]> aAlbuHuman = new ArrayList<Integer[]>();
aAlbuHuman.add(new Integer[]{1,1});
aAlbuHuman.add(new Integer[]{2,1});
aAlbuHuman.add(new Integer[]{3,1});
hmProteinPeptideMapping.put("ALBU_HUMAN", aAlbuHuman);
ArrayList<Integer[]> aAlbuBovin = new ArrayList<Integer[]>();
aAlbuBovin.add(new Integer[]{2,2});
aAlbuBovin.add(new Integer[]{5,1});
aAlbuBovin.add(new Integer[]{7,1});
hmProteinPeptideMapping.put("ALBU_BOVIN", aAlbuBovin);
HashMap<String, Double> hmPeptideIntensities = new HashMap<String,Double>();
hmPeptideIntensities.put("q1p1",1000d);
hmPeptideIntensities.put("q2p1",500d);
hmPeptideIntensities.put("q3p1",750d);
hmPeptideIntensities.put("q2p2",750d);
hmPeptideIntensities.put("q5p1",2000d);
hmPeptideIntensities.put("q7p1",1000d);
ms_quant_method qmethod = new ms_quant_method();
ms_quant_average average = new ms_quant_average();
average.setReferenceAccession("ALBU_HUMAN");
average.setReferenceAmount("1.0");
// We set the number of top N peptides to 2, so we expect the following
// peptide intensities to be used:
// ALBU_HUMAN = 1000, 750
// ALBU_BOVIN = 2000, 1000
average.setNumPeptides(2);
ms_quant_protocol protocol = new ms_quant_protocol();
protocol.setAverage(average);
qmethod.setProtocol(protocol);
// Since ms_customquantitation does not use the ratio definitions in the
// quantitation method, we need not define them at all. Ratios are meaningless
// in the Average protocol anyway, so we can use any name we want to denote
// the intensity values.
String rationame = "amount";
setParams(qmethod, "none", "none", "average", 1);
ms_customquantitation customquant = new ms_customquantitation(qmethod);
if(!customquant.isValid()) {
System.err.println(customquant.getLastErrorString());
System.exit(1);
}
dumpWarnings(customquant.getErrorHandler());
customquant.clearAllErrors();
dumpQuantMethod(qmethod, new String[] {rationame});
// create the protein-peptide mapping
Set<String> aProteinAccessions = hmProteinPeptideMapping.keySet();
for(String sAccession : aProteinAccessions) {
List<Integer[]> aPeptides = hmProteinPeptideMapping.get(sAccession);
for(Integer[] aQP : aPeptides) {
customquant.addProteinPeptideKey(sAccession, 0, new ms_peptide_quant_key(aQP[0], aQP[1]));
}
}
// add peptide intensities
Set<String> aPeptideQP = hmPeptideIntensities.keySet();
for(String qp : aPeptideQP) {
double dIntensity = hmPeptideIntensities.get(qp);
int[] aQP = extractQP(qp);
ms_peptide_quant_ratio ratio = new ms_peptide_quant_ratio(new ms_peptide_quant_key(aQP[0], aQP[1]), rationame, dIntensity);
customquant.addPeptideRatio(ratio);
}
System.out.println();
// print is all out immediately
for(String sAccession : aProteinAccessions) {
System.out.printf("%s\n", sAccession);
List<Integer[]> aPeptides = hmProteinPeptideMapping.get(sAccession);
ms_protein_quant_ratio ratio = customquant.getProteinRatio(sAccession, 0, rationame);
if(ratio.isMissing()) {
System.out.printf("%10s: ---", rationame);
} else {
System.out.printf("%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g\n", rationame, ratio.getValue(), ratio.getStandardError(), ratio.getSampleSize(), ratio.getNormalityPvalue(), ratio.getHypothesisPvalue());
}
System.out.println();
StringBuilder sbPeptideRatioHeader = new StringBuilder();
sbPeptideRatioHeader.append(String.format("%10s", "Peptide"));
sbPeptideRatioHeader.append(" ");
sbPeptideRatioHeader.append(String.format("%10s",rationame));
System.out.println(sbPeptideRatioHeader);
for(Integer[] aQP : aPeptides) {
List<String> aValues = new ArrayList<String>();
ms_peptide_quant_ratio oRatio = customquant.getPeptideRatio(new ms_peptide_quant_key(aQP[0],aQP[1]), rationame);
if(oRatio.isMissing()) {
aValues.add(String.format("%10s", "---"));
}
if(oRatio.isInfinite()) {
aValues.add(String.format("%10s", "---"));
} else {
aValues.add(String.format("%10g", oRatio.getValue()));
}
StringBuilder sbValues = new StringBuilder();
for(String sValue : aValues) {
if(sbValues.length() > 0) sbValues.append(" ");
sbValues.append(sValue);
}
System.out.printf("%10s %s\n", String.format("q%d_p%d", aQP[0], aQP[1]), sbValues);
}
System.out.println();
}
}
private static void setParams(ms_quant_method qmethod, String normalisation, String outliers, String proteinRatioType, int iMinNoPeptides) {
ms_quant_quality oQuality = null;
if(qmethod.haveQuality()) {
oQuality = qmethod.getQuality();
} else {
oQuality = new ms_quant_quality();
}
ms_quant_normalisation oNormalisation = null;
if(qmethod.haveNormalisation()) {
oNormalisation = qmethod.getNormalisation();
} else {
oNormalisation = new ms_quant_normalisation();
}
ms_quant_outliers oOutliers = null;
if(qmethod.haveOutliers()) {
oOutliers = qmethod.getOutliers();
} else {
oOutliers = new ms_quant_outliers();
}
if(normalisation == null || normalisation.length() == 0) normalisation = "none";
if(outliers == null || outliers.length() == 0) outliers = "none";
if(iMinNoPeptides <= 0) iMinNoPeptides = 2;
if(proteinRatioType == null || proteinRatioType.length() == 0) proteinRatioType="Average";
oNormalisation.setMethod(normalisation);
oOutliers.setMethod(outliers);
qmethod.setMinNumPeptides(iMinNoPeptides);
qmethod.setProteinRatioType(proteinRatioType);
oQuality.setMinPrecursorCharge(1);
oQuality.setPepThresholdType("maximum expect");
oQuality.setPepThresholdValue("0.05");
qmethod.setQuality(oQuality);
qmethod.setNormalisation(oNormalisation);
qmethod.setOutliers(oOutliers);
}
private static void dumpWarnings(ms_errs errorHandler) {
for(int i = 1; i <= errorHandler.getNumberOfErrors(); i++) {
System.out.println("Warning: "+errorHandler.getErrorString(i));
}
}
private static void dumpQuantMethod(ms_quant_method qmethod, String[] aRatioNames) {
String[] aComps = new String[qmethod.getNumberOfComponents()];
for(int i = 0; i < qmethod.getNumberOfComponents(); i++) {
aComps[i] = qmethod.getComponentByNumber(i).getName();
}
System.out.printf("Components: [%s]\n", Arrays.toString(aComps));
System.out.printf("Report ratios: [%s]\n", Arrays.toString(aRatioNames));
System.out.printf("Protein ratio type = %s\n", qmethod.getProteinRatioType());
System.out.printf("Min. number of peptides = %d\n", qmethod.getMinNumPeptides());
if(qmethod.haveQuality()) {
ms_quant_quality quality = qmethod.getQuality();
System.out.printf("Quality: min. precursor charge = %s\n", quality.getMinPrecursorCharge());
System.out.printf("Quality: pep. threshold type = %s\n", quality.getPepThresholdType());
System.out.printf("Quality: pep. threshold value = %s\n", quality.getPepThresholdValue());
} else {
System.out.print("Quality: no restrictions\n");
}
if(qmethod.haveNormalisation()) {
System.out.printf("Normalisation = %s\n", qmethod.getNormalisation().getMethod());
} else {
System.out.print("Normalisation: none\n");
}
if(qmethod.haveOutliers()) {
System.out.printf("Outliers = %s\n", qmethod.getOutliers().getMethod());
} else {
System.out.print("Outliers: none\n");
}
}
private static int[] extractQP(String qp) {
String[] aBits = qp.split("p");
aBits[0] = aBits[0].replace("q", "");
return new int[] {Integer.parseInt(aBits[0]), Integer.parseInt(aBits[1])};
}
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_customquantitation.py

resfile_customquantitation.py

Example program illustrating basic usage of ms_customquantitation.

1#!/usr/bin/python
2
15
16import msparser
17import sys
18import re
19
20def main():
21
22# This example uses fictitious data to illustrate how ms_customquantitation can
23# be used with the Average protocol. In a real situation peptide intensities
24# and the protein-peptide mapping would come from some external source.
25
26 protein_peptide_mapping = {'ALBU_HUMAN': [ [1, 1], [2, 1], [3, 1] ],
27 'ALBU_BOVIN': [ [2, 2], [5, 1], [7, 1] ]}
28
29 peptide_intensities = {'q1p1': 1000, 'q2p1': 500, 'q3p1': 750, 'q2p2': 750, 'q5p1': 2000, 'q7p1': 1000}
30
31 qmethod = msparser.ms_quant_method()
32 average = msparser.ms_quant_average()
33
34 average.setReferenceAccession("ALBU_HUMAN")
35 average.setReferenceAmount("1.0")
36
37# We set the number of top N peptides to 2, so we expect the following
38# peptide intensities to be used:
39# ALBU_HUMAN = 1000, 750
40# ALBU_BOVIN = 2000, 1000
41 average.setNumPeptides(2)
42
43 p = msparser.ms_quant_protocol()
44 p.setAverage(average)
45 qmethod.setProtocol(p)
46
47# Since ms_customquantitation does not use the ratio definitions in the
48# quantitation method, we need not define them at all. Ratios are meaningless
49# in the Average protocol anyway, so we can use any name we want to denote
50# the intensity values.
51
52 rationame = "amount"
53 h = {'normalisation': 'none', 'outliers': 'none', 'protein_ratio_type': 'average', 'min_num_peptides': 2}
54 set_params(qmethod, h)
55
56 customquant = msparser.ms_customquantitation(qmethod)
57
58 if not customquant.isValid():
59 print(customquant.getLastErrorString())
60 sys.exit(1)
61
62 dump_warnings(customquant.getErrorHandler())
63 customquant.clearAllErrors()
64
65 dump_quant_method(qmethod, rationame)
66
67# Create the protein-peptide mapping
68
69 for accession in protein_peptide_mapping:
70 peptides = protein_peptide_mapping[accession]
71 for peptide in peptides:
72 customquant.addPeptideQuantKey(accession, 0, msparser.ms_peptide_quant_key(peptide[0], peptide[1]))
73
74# Add peptide intensities
75
76 for keys in peptide_intensities:
77 match = re.match(r"[a-z](\d+)[a-z](\d+)", keys)
78 q = int(match.group(1))
79 p = int(match.group(2))
80 ratioValue = peptide_intensities[keys]
81 quantKey = msparser.ms_peptide_quant_key(q, p)
82 ratio = msparser.ms_peptide_quant_ratio(quantKey, rationame, ratioValue)
83 customquant.addPeptideRatio(ratio)
84
85 print("\n")
86
87# Print it all out immediately:
88
89 for accession in protein_peptide_mapping:
90 print("%s:" %(accession))
91 ratio = customquant.getProteinRatio(accession, 0, rationame)
92
93 if ratio.isMissing():
94 print("%10s: ---" %(rationame))
95 else:
96 print("%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g" %(rationame, ratio.getValue(), ratio.getStandardError_only(), ratio.getSampleSize(), ratio.getNormalityPvalue_only(), ratio.getHypothesisPvalue_only()))
97
98 print(" %10s %s" %('Peptide', rationame))
99
100 peptides = protein_peptide_mapping[accession]
101 for i in ms_range(1, len(peptides)-1):
102 peptide = peptides[i]
103 for i in range(len(peptide)):
104 q = peptide[0]
105 p = peptide[1]
106
107 values = ''
108
109 ratio = customquant.getPeptideRatio(msparser.ms_peptide_quant_key(q, p), rationame)
110
111 if ratio.isMissing():
112 values = "---"
113 elif ratio.isInfinite():
114 values = "###"
115 else:
116 values = ratio.getValue()
117
118 print(" %-9s %-10s" %("q%d_p%d" %(q, p), str(values)))
119
120 print("\n")
121
122# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
123def ms_range(start, stop, step=1):
124 i = start
125 while i <= stop:
126 yield i
127 i += step
128
129def set_params(qmethod, h):
130
131 if qmethod.haveQuality():
132 quality = qmethod.getQuality()
133 else:
134 quality = msparser.ms_quant_quality()
135
136 if qmethod.haveNormalisation():
137 normalisation = qmethod.getNormalisation()
138 else:
139 normalisation = msparser.ms_quant_normalisation()
140
141 if qmethod.haveOutliers():
142 outliers = qmethod.getOutliers()
143 else:
144 outliers = msparser.ms_quant_outliers()
145
146 normalisation.setMethod(h['normalisation'])
147 outliers.setMethod(h['outliers'])
148 qmethod.setMinNumPeptides(h['min_num_peptides'])
149 qmethod.setProteinRatioType(h['protein_ratio_type'])
150 quality.setMinPrecursorCharge(1)
151 quality.setPepThresholdType('maximum expect')
152 quality.setPepThresholdValue('0.05')
153
154 qmethod.setQuality(quality)
155 qmethod.setNormalisation(normalisation)
156 qmethod.setOutliers(outliers)
157
158def dump_quant_method(qmethod, rationames):
159
160 comps = []
161
162 for i in ms_range(1, qmethod.getNumberOfComponents()-1):
163 comp = qmethod.getComponentByNumber(i)
164 comps.append(comp.getName())
165
166 print("Components: %s" %(comps))
167 print("Report ratios: %s" %(rationames))
168
169 print("Protein ratio type = %s" %(qmethod.getProteinRatioType()))
170 print("Min. number of peptides: %d" %(qmethod.getMinNumPeptides()))
171
172 if qmethod.haveQuality():
173 q = qmethod.getQuality()
174 print("Quality: min. precursor charge = %s" %(q.getMinPrecursorCharge()))
175 print("QualityL pep. threshold type = %s" %(q.getPepThresholdType()))
176 print("Quality: pep. threshold value = %s" %(q.getPepThresholdValue()))
177 else:
178 print("Quality: no restrictions")
179
180 if qmethod.haveNormalisation():
181 q = qmethod.getNormalisation()
182 print("Normalisation = %s" %(q.getMethod()))
183 else:
184 print("Normalisation: none")
185
186 if qmethod.haveOutliers():
187 q = qmethod.getOutliers()
188 print("Outliers = %s" %(q.getMethod()))
189 else:
190 print("Outliers: none")
191
192
193def dump_warnings(err):
194 for i in range(1, err.getNumberOfErrors()):
195 print("Warning: %s" %(err.getErrorString(i)))
196
197
198if __name__ == "__main__":
199 main()
200
201'''
202resfile_customquantitation.py
203Will give the following output:
204
205Components: []
206Report ratios: amount
207Protein ratio type = average
208Min. number of peptides: 2
209Quality: min. precursor charge = 1
210QualityL pep. threshold type = maximum expect
211Quality: pep. threshold value = 0.05
212Normalisation = none
213Outliers = none
214
215
216ALBU_HUMAN:
217 amount = 721.125, stderr = 1.22269, N = 3, normal-p = 0.813228, hypo-p = 0.000932101
218 Peptide amount
219 q1_p1 1000.0
220 q2_p1 500.0
221 q3_p1 750.0
222
223
224ALBU_BOVIN:
225 amount = 1144.71, stderr = 1.33789, N = 3, normal-p = 0.552542, hypo-p = 0.00170392
226 Peptide amount
227 q2_p2 750.0
228 q5_p1 2000.0
229 q7_p1 1000.0
230
231'''
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile_customquantitation.cs

resfile_customquantitation.cs

Example program illustrating basic usage of ms_customquantitation.

/*
##############################################################################
# file: resfile_customquantitation.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/resfile_customquantitation.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.Collections.Generic;
using matrix_science.msparser;
namespace MsParserExamples
{
class resfile_customquantitation
{
public static int Main(string[] argv)
{
Dictionary<string, List<int[]>> proteinPeptideMap = new Dictionary<string, List<int[]>>()
{
{"ALBU_HUMAN", new List<int[]> {
{new int[] {1,1}},
{new int[] {2,1}},
{new int[] {3,1}}
}},
{"ALBU_BOVIN", new List<int[]> {
{new int[] {2,2}},
{new int[] {5,1}},
{new int[] {7,1}}
}}
};
Dictionary<string, int> peptideIntensities = new Dictionary<string, int>
{
{"q1p1", 1000},
{"q2p1", 500},
{"q3p1", 750},
{"q2p2", 750},
{"q5p1", 2000},
{"q7p1", 1000}
};
ms_quant_method qmethod = new ms_quant_method();
ms_quant_average average = new ms_quant_average();
average.setReferenceAccession("ALBU_HUMAN");
average.setReferenceAmount("1.0");
// We set the number of top N peptides to 2, so we expect the following
// peptide intensities to be used:
// ALBU_HUMAN = 1000, 750
// ALBU_BOVIN = 2000, 1000
average.setNumPeptides(2);
ms_quant_protocol protocol = new ms_quant_protocol();
protocol.setAverage(average);
qmethod.setProtocol(protocol);
// Since ms_customquantitation does not use the ratio definitions in the
// quantitation method, we need not define them at all. Ratios are meaningless
// in the Average protocol anyway, so we can use any name we want to denote
// the intensity values.
String rationame = "amount";
setParams(qmethod, "none", "none", "average", 1);
ms_customquantitation customquant = new ms_customquantitation(qmethod);
if (!customquant.isValid())
{
Console.Error.WriteLine(customquant.getLastErrorString());
return 1;
}
dumpWarnings(customquant.getErrorHandler());
customquant.clearAllErrors();
dumpQuantMethod(qmethod, new string[] {rationame});
// Create the protein-peptide mapping
foreach (string accession in proteinPeptideMap.Keys)
{
List<int[]> peptides = proteinPeptideMap[accession];
foreach (int[] peptide in peptides)
{
customquant.addPeptideQuantKey(accession, 0, new ms_peptide_quant_key(peptide[0], peptide[1]));
}
}
// Add peptide intensities
foreach (string qp in peptideIntensities.Keys)
{
double intensity = peptideIntensities[qp];
int q, p;
extractQP(qp, out q, out p);
ms_peptide_quant_ratio ratio = new ms_peptide_quant_ratio(new ms_peptide_quant_key(q, p), rationame, intensity);
customquant.addPeptideRatio(ratio);
}
Console.WriteLine();
// print it all out immediately
foreach (string accession in proteinPeptideMap.Keys)
{
Console.WriteLine(accession);
List<int[]> aPeptides = proteinPeptideMap[accession];
ms_protein_quant_ratio ratio = customquant.getProteinRatio(accession, 0, rationame);
if (ratio.isMissing())
{
Console.WriteLine("{0} ---", rationame);
}
else
{
Console.WriteLine("{0} = {1}, stderr = {2}, n = {3} normal-p = {4}, hypo-p = {5}",
rationame, ratio.getValue(), ratio.getStandardError(),
ratio.getSampleSize(), ratio.getNormalityPvalue(),
ratio.getHypothesisPvalue()
);
}
Console.WriteLine("{0} {1}", "Peptide".PadRight(10), rationame.PadRight(10));
foreach(int[] peptide in aPeptides)
{
ms_peptide_quant_ratio pepRatio = customquant.getPeptideRatio(new ms_peptide_quant_key(peptide[0], peptide[1]), rationame);
string ratioValue;
if (pepRatio.isMissing())
{
ratioValue = "---".PadLeft(10);
}
else if (pepRatio.isInfinite())
{
ratioValue = "###".PadLeft(10);
}
else
{
ratioValue = string.Format("{0:0.######}", pepRatio.getValue()).PadLeft(10);
}
Console.WriteLine("{0} {1}", string.Format("q{0}_p{1}", peptide[0], peptide[1]).PadLeft(10), ratioValue);
}
Console.WriteLine();
}
return 0;
}
private static void extractQP(string qp, out int q, out int p)
{
string[] bits = qp.Split('p');
bits[0] = bits[0].Replace("q", "");
q = Int32.Parse(bits[0]);
p = Int32.Parse(bits[1]);
}
private static void dumpQuantMethod(ms_quant_method qmethod, string[] ratioNames)
{
{
List<string> comps = new List<string>();
for (int i = 0; i < qmethod.getNumberOfComponents(); i++)
{
comps.Add(qmethod.getComponentByNumber(i).getName());
}
Console.WriteLine("Components: [{0}]", string.Join(", ", comps));
}
Console.WriteLine("Report ratios: [{0}]", string.Join(", ", ratioNames));
Console.WriteLine("Protein ratio type = {0}", qmethod.getProteinRatioType());
Console.WriteLine("Min. number of peptides = {0}", qmethod.getMinNumPeptides());
if (qmethod.haveQuality())
{
var q = qmethod.getQuality();
Console.WriteLine("Quality: min. precursor charge = {0}", q.getMinPrecursorCharge());
Console.WriteLine("Quality: pep. threshold type = {0}", q.getPepThresholdType());
Console.WriteLine("Quality: pep. threshold value = {0}", q.getPepThresholdValue());
}
else
{
Console.WriteLine("Quality: no restrictions");
}
if (qmethod.haveNormalisation())
{
var q = qmethod.getNormalisation();
Console.WriteLine("Normalisation = {0}", q.getMethod());
}
else
{
Console.WriteLine("Normalisation: none");
}
if (qmethod.haveOutliers())
{
var q = qmethod.getOutliers();
Console.WriteLine("Outliers = {0}", q.getMethod());
}
else
{
Console.WriteLine("Outliers: none");
}
}
private static void dumpWarnings(ms_errs ms_errs)
{
for (int i = 1; i <= ms_errs.getNumberOfErrors(); i++)
{
Console.Error.WriteLine("Warning: {0}", ms_errs.getErrorString(i));
}
}
private static void setParams(ms_quant_method qmethod, string normalisationMethod, string outliersMethod, string proteinRatioType, int minNoPeptides)
{
ms_quant_quality quality = (qmethod.haveQuality()) ? qmethod.getQuality() : new ms_quant_quality();
ms_quant_normalisation normalisation = (qmethod.haveNormalisation()) ? qmethod.getNormalisation() : new ms_quant_normalisation();
ms_quant_outliers outliers = (qmethod.haveOutliers()) ? qmethod.getOutliers() : new ms_quant_outliers();
normalisation.setMethod((string.IsNullOrEmpty(normalisationMethod)) ? "none" : normalisationMethod);
outliers.setMethod((string.IsNullOrEmpty(outliersMethod)) ? "none" : outliersMethod);
qmethod.setMinNumPeptides((minNoPeptides > 1) ? minNoPeptides : 2);
qmethod.setProteinRatioType((string.IsNullOrEmpty(proteinRatioType)) ? "none" : proteinRatioType);
quality.setMinPrecursorCharge(1);
quality.setPepThresholdType("maximum expect");
quality.setPepThresholdValue("0.05");
qmethod.setQuality(quality);
qmethod.setNormalisation(normalisation);
qmethod.setOutliers(outliers);
}
}
}
/*
resfile_customquantitation.exe
Will give the following output:
Components: []
Report ratios: [amount]
Protein ratio type = average
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = maximum expect
Quality: pep. threshold value = 0.05
Normalisation = none
Outliers = none
ALBU_HUMAN
amount = 721.124785153704, stderr = 1.2226920025227, n = 3 normal-p = 0.813227565666875, hypo-p = 0.000932101414662601
Peptide amount
q1_p1 1000
q2_p1 500
q3_p1 750
ALBU_BOVIN
amount = 1144.71424255333, stderr = 1.33788997067188, n = 3 normal-p = 0.552542164299708, hypo-p = 0.00170392414333331
Peptide amount
q2_p2 750
q5_p1 2000
q7_p1 1000
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: display_quant_time_align.py

display_quant_time_align.py

Example program illustrating usage of ms_ms1quant_time_align.

1#!/usr/bin/python
2
15
16from __future__ import print_function
17
18import sys
19from datetime import datetime
20import msparser
21
22
23def checkErrorHandler(errs) :
24 for i in range(1, 1 + errs.getNumberOfErrors()) :
25 print("Error number: %s : %s" % (errs.getErrorNumber(i), errs.getErrorString(i)))
26
27
28# If no arguments supplied, print help and exit
29
30if len(sys.argv) < 3:
31 print("Usage: %s <time_alignment.xml> <schema_directory>" % sys.argv[0])
32 sys.exit(1)
33
34timeAlignmentXmlFile = sys.argv[1]
35schemaDirectory = sys.argv[2]
36start_time = datetime.now()
37
38time_align = msparser.ms_ms1quant_time_align()
39if time_align.loadXmlFile(timeAlignmentXmlFile, schemaDirectory) :
40 elapsed = datetime.now() - start_time
41 print("File loaded: %s in %d seconds" % (timeAlignmentXmlFile, elapsed.seconds))
42 print("")
43
44 data = time_align.getFinalResults()
45 num_sub_projects = len(data)
46 fraction_numbers = time_align.getSubProjectToFractionMap()
47
48 # Print project details
49 print("Prj\tFractn\tmeanErrsRaw\tmeanErrsAlig\tstdevErrsRaw\tstdevErrsAlig\tpearsonRaw\tpearsonAlign")
50 for prj in range(num_sub_projects):
51 fraction = fraction_numbers[prj]
52 (success, meanErrorsRaw, meanErrorsAligned, stdevErrorsRaw, stdevErrorsAligned, pearsonCoefficientRaw, pearsonCoefficientAligned) = time_align.getEvaluation(1 + prj)
53 print("%d\t%d\t%f\t%f\t%f\t%f\t%f\t%f\t" % (1+prj, fraction, meanErrorsRaw, meanErrorsAligned, stdevErrorsRaw, stdevErrorsAligned, pearsonCoefficientRaw, pearsonCoefficientAligned))
54 print("")
55
56 # Print fraction limits
57 print("Fract\tminimum m/z\tmaximum mz\tminimum rt\tmaximum rt\tminbin\tmaxbin\tminrt\tmaxrt\tnum q\t#q>thr\tprojects")
58 fraction_to_prj = time_align.getFractionToSubProjectMap()
59 for fraction,proj in fraction_to_prj.items():
60 sub_proj_str = ""
61 for x in proj:
62 if sub_proj_str:
63 sub_proj_str += ", "
64 sub_proj_str = sub_proj_str + str(1+x)
65 limits = time_align.getCombinedLimits(fraction)
66 print("%d\t%f\t%f\t%f\t%f\t%d\t%d\t%d\t%d\t%d\t%d\t%s" % (fraction, limits.getMinMZ(), limits.getMaxMZ(), limits.getMinRT(), limits.getMaxRT(),limits.getCombinedMinBinNum(), limits.getCombinedMaxBinNum(), limits.getCombinedMinRT(), limits.getCombinedMaxRT(), limits.getNumQueries(), limits.getNumQueriesAboveThreshold(), sub_proj_str))
67 print("")
68
69
70 showAllNonZero = 0
71 if (showAllNonZero) :
72 for prj in range(num_sub_projects):
73 fraction = fraction_numbers[prj]
74 limits = time_align.getCombinedLimits(fraction)
75 print("Sub project: %d, fraction: %d" % (prj, fraction))
76 num_bins = len(data[prj])
77 print(" Number of bins: %d" % (num_bins))
78 for bin_num in range(num_bins) :
79 print(" Bin: %d" % (bin_num))
80 num_rts = len(data[prj][bin_num])
81 print(" Num rts: %d" % (num_rts))
82 for rt in range(num_rts) :
83 # print("data[%d][%d][%d]: %f" % (prj, bin_num, rt, data[prj][bin_num][rt]))
84 if (data[prj][bin_num][rt] != 0) :
85 print("SubProj: %d, bin: %d, rt: %d, offset: %f" % (1+prj, bin_num + limits.getCombinedMinBinNum(), rt + limits.getCombinedMinRT(), data[prj][bin_num][rt]))
86 else :
87 mid_project = int(num_sub_projects /2) -1
88 mid_bin = int(len(data[mid_project]) /2)
89 num_rts = len(data[mid_project][mid_bin])
90 fraction = fraction_numbers[mid_project]
91 limits = time_align.getCombinedLimits(fraction)
92 numNonZero = 0
93 elapsed = datetime.now() - start_time
94 print("Calculated mid points for: %s, elapsed time: %d seconds" % (timeAlignmentXmlFile, elapsed.seconds))
95 print("Showing first 50 non zero deltas from sub project: %d, bin number: %d, Num rts: %d, Min rt: %d" % (1 + mid_project, mid_bin + limits.getCombinedMinBinNum(),num_rts, limits.getCombinedMinRT()))
96 for rt in range(num_rts) :
97 if (data[mid_project][mid_bin][rt] != 0) :
98 if (numNonZero < 50) :
99 numNonZero = 1 + numNonZero
100 print("SubProj: %d, bin: %d, rt: %d, offset: %f" % (1+mid_project, mid_bin + limits.getCombinedMinBinNum(), rt + limits.getCombinedMinRT(), data[mid_project][mid_bin][rt]))
101
102 print("")
103 print("Showing all the feature widths for sub project: %d, bin number: %d" % (1 + mid_project, mid_bin + limits.getCombinedMinBinNum()))
104 feature_widths = time_align.getFeatureWidths()
105 features = feature_widths[mid_project][mid_bin]
106 for rt, width in features.items() :
107 print("%f\t%f" % (rt, width))
108
109 print("Time: %s" % (str(datetime.now())))
110
111checkErrorHandler(time_align.getErrorHandler())
112
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: repeat_search.pl

repeat_search.pl

Repeating a search from a Mascot results file.

#!/usr/local/bin/perl
##############################################################################
# file: repeat_search.pl #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/repeat_search.pl $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-10 15:47:19 +0100 $ #
# $Revision: 5cb3eebb919bbd2919409b6a166299325b2a1a58 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
# This script must be run in the Mascot Server cgi directory.
use lib '../bin';
use msparser;
if (!defined($ARGV[0])) {
usage();
exit(1);
}
# If this script is being run as a cgi script, then a
# boundary string may be set in the environment.
# This will be different from the simple boundary string defined
# below, so nph-mascot.exe will fail. The following two
# lines clear the relevant environment variables.
delete $ENV{'CONTENT_TYPE'};
delete $ENV{'CONTENT_LENGTH'};
repeatSearch($ARGV[0]);
sub repeatSearch {
my ($filename) = @_;
my $resfile = msparser::ms_mascotresfilebase::createResfile($filename);
if (!$resfile->isValid) {
print "Cannot open results file ", $filename, ": ";
print $resfile->getLastErrorString(), "\n";
return;
}
my @s = ();
push @s, "----12345";
push @s, 'Content-Disposition: form-data; name="QUE"';
push @s, '';
# Parameters section
my $keys = msparser::VectorString->new;
my $vals = msparser::VectorString->new;
$resfile->getSearchParametersKeyValues($keys, $vals);
for my $i (0 .. $keys->size-1) {
my $key = $keys->get($i);
my $val = $vals->get($i);
# To search against a different database, add 'and key ne "DB"'
if ($val
and ($key ne "INTERMEDIATE")
and ($key ne "RULES")
and ($key ne "INTERNALS")
and ($key ne "SEARCH")) {
push @s, $key . "=" . $val;
}
}
# To search against a different DB add e.g.
# push @s, "DB=MY_DB";
# Most flexible to repeat each search as a 'sequence' search.
push @s, "SEARCH=SQ";
# For ms-ms data, tell nph-mascot where to find the ions data
push @s, "INTERMEDIATE=" . $filename;
# Now the repeat search data
for my $q (1 .. $resfile->getNumQueries) {
push @s, $resfile->getRepeatSearchString($q);
}
# Terminating line for MIME format file
push @s, "----12345--";
# Start nph-mascot.exe, and redirect the output to tmp.txt
# (Could use open2 here, but this can be unreliable with nph-mascot.exe)
# For Unix systems, change nph-mascot.exe to ./nph-mascot.exe
open (my $sock, "| nph-mascot.exe 4 -commandline > tmp.txt");
print $sock $_, "\n" for @s;
close $sock;
open(my $fh, '<', 'tmp.txt');
while (<$fh>) {
if ( /SUCCESS/ ) {
# Next line contains the results file name
chomp(my $buffer = <$fh>);
compareResults($resfile, $buffer);
next;
}
if ( /ERROR/ ) {
print "Search failed: ", $_;
# Print details of error messages
print while <$fh>;
next;
}
}
}
sub compareResults {
my ($originalSearch, $repeatedSearchFileName) = @_;
my $repeatedSearch = msparser::ms_mascotresfilebase::createResfile($repeatedSearchFileName);
my $anyReport = 0;
if (!$repeatedSearch->isValid()) {
print "Invalid repeat search: ",$repeatedSearch->getLastErrorString(), "\n";
return;
}
if ($originalSearch->anyPMF()) {
# Use protein summary
my $originalResults = new msparser::ms_proteinsummary($originalSearch);
my $repeatedResults = new msparser::ms_proteinsummary($repeatedSearch);
my $originalProt = $originalResults->getHit(1);
my $repeatedProt = $repeatedResults->getHit(1);
if ($originalProt and $repeatedProt) {
my $diff = $repeatedProt->getScore() - $originalProt->getScore();
if ($diff > 10.0) {
print "Protein score is ", $diff, " higher for search ";
print $originalSearch->getFileName();
print " than ";
print $repeatedSearchFileName;
print "\n";
$anyReport = 1;
}
}
} else {
# Use peptide summary
my $originalResults = new msparser::ms_peptidesummary($originalSearch);
my $repeatedResults = new msparser::ms_peptidesummary($repeatedSearch);
# Compare peptide scores
for my $q (1 .. $originalSearch->getNumQueries) {
my $pepOriginal = $originalResults->getPeptide($q, 1);
my $pepRepeated = $repeatedResults->getPeptide($q, 1);
my $diff = $pepRepeated->getIonsScore() - $pepOriginal->getIonsScore();
if ($diff > 10.0) {
print "Query ", $q, " has score ", $diff;
print " higher for search ", $originalSearch->getFileName();
print " than ", $repeatedSearchFileName, "\n";
$anyReport = 1;
}
}
}
if (!$anyReport) {
print "Similar results for ", $originalSearch->getFileName();
print " and ", $repeatedSearchFileName, "\n";
}
}
sub usage {
print <<EOF;
Usage: repeat_search.pl <results file>
Given an mascot results file name, repeat the search against the same data.
The program must be run from the mascot cgi directory.
EOF
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: repeat_search.cpp

repeat_search.cpp

Repeating a search from a Mascot results file.

/*
##############################################################################
# file: repeat_search.cpp #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/repeat_search.cpp $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <stdio.h> // For 'popen'
#include <iostream>
#include <sstream>
#include <string>
#ifdef _WIN32
#define popen _popen
#define pclose _pclose
#endif
using namespace matrix_science;
// forward declarations
static bool repeatSearch(const char * filename);
static int usage(const char * progName);
static void compareResults(ms_mascotresfilebase & originalSearch,
const char * repeatedSearchFileName);
int main(int argc, char * argv[])
{
if (argc == 2)
return repeatSearch(argv[1]);
else
return usage(argv[0]);
}
static bool repeatSearch(const char * filename)
{
bool success = false;
ms_mascotresfilebase file = ms_mascotresfilebase::createResfile(filename);
if (file.isValid())
{
std::ostringstream s; // Build up a MIME format string with all parameters
s << "----12345\n"
<< "Content-Disposition: form-data; name=\"QUE\""
<< std::endl << std::endl;
// Parameters section
std::vector<std::string> keys, values;
file. getSearchParametersKeyValues(keys, values);
for (std::vector<std::string>::size_type i = 0; i < keys.size(); ++i) {
std::string key = keys[i];
std::string val = values[i];
// To search against a different database, add && key != "DB"
if (!val.empty() && key != "INTERMEDIATE" && key != "RULES" && key != "SEARCH")
s << key << "=" << val << std::endl;
}
// To search against a different DB add: s << "DB=MY_DB" << std::endl;
// Most flexible to repeat each search as a 'sequence' search.
s << "SEARCH=SQ" << std::endl;
// For ms-ms data, tell nph-mascot where to find the ions data
s << "INTERMEDIATE=" << filename << std::endl;
// Now the repeat search data
for (int q=1; q <= file.getNumQueries(); q++)
s << file.getRepeatSearchString(q) << std::endl;
s << "----12345--\n"; // terminating line for MIME format file
// Start nph-mascot.exe, and redirect the output to tmp.txt
// Note that for Unix, you may need to use ./nph-mascot.exe
FILE * f = popen("./nph-mascot.exe 4 -commandline > tmp.txt", "w"); // 4 = repeat search
if (f)
{
fwrite(s.str().c_str(), s.str().length(), 1, f);
pclose(f);
if ((f = fopen("tmp.txt", "r")) != 0)
{
char buf[1000];
while (fgets(buf, sizeof(buf), f))
{
if (strstr(buf, "SUCCESS") && fgets(buf, sizeof(buf), f))
{
if (buf[strlen(buf)-1] == '\n')
buf[strlen(buf)-1] = '\0';
compareResults(file, buf);
success = true;
}
else if (strstr(buf, "ERROR"))
{
std::cout << "Search failed: " << buf;
while (fgets(buf, sizeof(buf), f))
{
std::cout << buf;
}
}
}
fclose(f);
}
else
{
std::cout << "Can't open tmp file. \n";
}
}
else
{
std::cout << "Cannot open pipe to nph-mascot.exe to repeat search for file "
<< filename << std::endl;
}
}
else
{
std::cout << "Cannot open results file " << filename
<< " " << file.getLastErrorString() << std::endl;
}
return success;
}
static void compareResults(ms_mascotresfilebase & originalSearch,
const char * repeatedSearchFileName)
{
ms_mascotresfilebase repeatedSearch = ms_mascotresfilebase::createResfile(repeatedSearchFileName);
bool anyReport = false;
if (repeatedSearch.isValid())
{
if (originalSearch.anyPMF())
{
// Use protein summary
ms_proteinsummary originalResults(originalSearch);
ms_proteinsummary repeatedResults(repeatedSearch);
ms_protein * originalProt = originalResults.getHit(1);
ms_protein * repeatedProt = repeatedResults.getHit(1);
if (originalProt && repeatedProt)
{
double diff = repeatedProt->getScore()-originalProt->getScore();
if (diff > 10.0)
{
std::cout << "Protein score is "
<< diff
<< " higher for search "
<< originalSearch.getFileName()
<< " than "
<< repeatedSearchFileName
<< std::endl;
anyReport = true;
}
}
}
else
{
// Use peptide summary
ms_peptidesummary originalResults(originalSearch);
ms_peptidesummary repeatedResults(repeatedSearch);
// Compare peptide scores
for (int q=1; q <= originalSearch.getNumQueries(); q++)
{
ms_peptide * pepOriginal, *pepRepeated;
if (originalResults.getPeptide(q, 1, pepOriginal)
&& repeatedResults.getPeptide(q, 1, pepRepeated))
{
double diff = pepRepeated->getIonsScore()
- pepOriginal->getIonsScore();
if (diff > 10.0)
{
std::cout << "Query " << q
<< "has score " << diff
<< " higher for search "
<< originalSearch.getFileName()
<< " than "
<< repeatedSearchFileName
<< std::endl;
anyReport = true;
}
}
}
}
if (!anyReport)
std::cout << "Similar results for "
<< originalSearch.getFileName()
<< " and "
<< repeatedSearchFileName
<< std::endl;
}
else
std::cout << "Invalid repeat search "
<< repeatedSearch.getLastErrorString();
}
static int usage(const char * progName)
{
std::cout << progName << " results_file " << std::endl
<< "Given an mascot results file name, repeat the search "
<< "against the same data" << std::endl
<< " results_file is a full path to a results file" << std::endl
<< "The program must be run from the mascot cgi directory"
<< std::endl;
return 1;
}
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresfilebase::getLastErrorString
std::string getLastErrorString() const
Return the last error number - or an empty string.
Definition: ms_mascotresfilebase.cpp:824
matrix_science::ms_mascotresfilebase::anyPMF
virtual bool anyPMF() const =0
Returns true if any of the queries in the search just contain a single peptide mass.
matrix_science::ms_mascotresfilebase::getRepeatSearchString
virtual std::string getRepeatSearchString(const int query, const bool fullQuery=false) const =0
To perform a repeat search need to build up appropriate string.
matrix_science::ms_mascotresfilebase::getNumQueries
virtual int getNumQueries(const int resfileID=0) const =0
Returns the number of queries (peptide masses or ms-ms spectra).
matrix_science::ms_mascotresfilebase::getFileName
virtual std::string getFileName(const int id=1) const =0
Returns the name of the results file passed into the constructor.
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::getIonsScore
double getIonsScore() const
Returns the ions score.
Definition: ms_peptide.cpp:1050
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_protein::getScore
double getScore() const
Return the protein score for this protein.
Definition: ms_protein.cpp:574
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: repeat_search.java

repeat_search.java

Repeating a search from a Mascot results file.

/*
##############################################################################
# file: repeat_search.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/repeat_searc $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
import java.io.*;
public class repeat_search {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load.\n" + e);
System.exit(0);
}
}
public static void main(String argv[]) {
// ----- Object creation -----
if(argv.length < 1) {
usage();
System.exit(0);
}
repeatSearch(argv[0]);
}
private static boolean repeatSearch(String filename) {
boolean success = false;
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(filename, 0, "");
if (file.isValid()) {
String s; // Build up a MIME format string with all parameters
s = "----12345\n";
s += "Content-Disposition: form-data; name=\"QUE\"";
s += "\n\n";
// Parameters section
int count = 1;
String key = file.enumerateSectionKeys(ms_mascotresfilebase.SEC_PARAMETERS,
count);
while (key.length() != 0)
{
String val = file.getSectionValueStr(ms_mascotresfilebase.SEC_PARAMETERS,
key);
// To search against a different database, add && key != "DB"
if ((val.length()) != 0 && !key.equals("INTERMEDIATE") && !key.equals("RULES") && !key.equals("INTERNALS") && !key.equals("SEARCH"))
s += key+ "=" +val+ "\n";
key = file.enumerateSectionKeys(ms_mascotresfilebase.SEC_PARAMETERS, ++count);
}
// To search against a different DB add: s += "DB=MY_DB\n";
s += "DB=repeat\n";
// Most flexible to repeat each search as a 'sequence' search.
s += "SEARCH=SQ\n";
// For ms-ms data, tell nph-mascot where to find the ions data
s += "INTERMEDIATE=" +filename+ "\n";
// Now the repeat search data
for (int q=1; q <= file.getNumQueries(); q++) {
s += file.getRepeatSearchString(q) + "\n";
}
s += "----12345--\n"; // terminating line for MIME format file
System.out.println(s);
// Start nph-mascot.exe, and redirect the output to tmp.txt
// Note that for Unix, you may need to use ./nph-mascot.exe
try {
String runTimeCommand;
runTimeCommand = "./nph-mascot.exe 4 -commandline > tmp.txt";
Process p = Runtime.getRuntime().exec(runTimeCommand);
OutputStream output = p.getOutputStream();
BufferedWriter bwrite = new BufferedWriter(new OutputStreamWriter(output));
InputStream input = p.getInputStream();
BufferedReader bread = new BufferedReader(new InputStreamReader(input));
bwrite.write(s);
bwrite.close();
int returnValue = p.waitFor();
String buf = null;
while((buf = bread.readLine()) != null){
if (buf.indexOf("SUCCESS") != -1) {
if ((buf = bread.readLine()) != null){
System.out.println(buf);
compareResults(file, buf);
success = true;
}
} else if (buf.indexOf("ERROR") != -1) {
System.out.println("Search failed: " +buf);
while ((buf = bread.readLine()) != null) {
System.out.println(buf);
}
}
}
bread.close();
}
catch(java.io.IOException e){
e.printStackTrace();
}
catch(java.lang.InterruptedException e){
e.printStackTrace();
}
}
else
{
System.out.println("Cannot open results file " +filename);
System.out.println(file.getLastErrorString() + "\n");
}
return success;
}
private static void compareResults(ms_mascotresfilebase originalSearch,
String repeatedSearchFileName)
{
ms_mascotresfilebase repeatedSearch = ms_mascotresfilebase.createResfile(repeatedSearchFileName, 0, "");
boolean anyReport = false;
if (repeatedSearch.isValid()) {
if (originalSearch.anyPMF()) {
// Use protein summary
ms_proteinsummary originalResults
= new ms_proteinsummary(originalSearch,
ms_mascotresults.MSRES_GROUP_PROTEINS,
0, 1, null, null);
ms_proteinsummary repeatedResults
= new ms_proteinsummary(repeatedSearch,
ms_mascotresults.MSRES_GROUP_PROTEINS,
0, 1, null, null);
ms_protein originalProt = originalResults.getHit(1);
ms_protein repeatedProt = repeatedResults.getHit(1);
if (originalProt != null && repeatedProt != null) {
double diff = repeatedProt.getScore() - originalProt.getScore();
if (diff > 10.0) {
System.out.println("Protein score is "
+ diff
+ " higher for search "
+ originalSearch.getFileName()
+ " than "
+ repeatedSearchFileName
+ "\n");
anyReport = true;
}
}
} else {
// Use peptide summary
ms_peptidesummary originalResults
= new ms_peptidesummary(originalSearch,
ms_mascotresults.MSRES_GROUP_PROTEINS,
0, 1, null, 0, 0, null);
ms_peptidesummary repeatedResults
= new ms_peptidesummary(repeatedSearch,
ms_mascotresults.MSRES_GROUP_PROTEINS,
0, 1, null, 0, 0, null);
// Compare peptide scores
for (int q=1; q <= originalSearch.getNumQueries(); q++) {
ms_peptide pepOriginal = originalResults.getPeptide(q, 1);
ms_peptide pepRepeated = repeatedResults.getPeptide(q, 1);
if (pepOriginal != null && pepRepeated != null) {
double diff = pepRepeated.getIonsScore()
- pepOriginal.getIonsScore();
if (diff > 10.0) {
System.out.println("Query "
+ q
+ "has score " + diff
+ " higher for search "
+ originalSearch.getFileName()
+ " than "
+ repeatedSearchFileName
+ "\n");
anyReport = true;
}
}
}
}
if (!anyReport) {
System.out.println("Similar results for "
+ originalSearch.getFileName()
+ " and "
+ repeatedSearchFileName
+ "\n");
}
} else {
System.out.println("Invalid repeat search "
+ repeatedSearch.getLastErrorString());
}
}
private static void usage()
{
System.out.println("Usage: java repeat_search <results_file> ");
System.out.println("Given an mascot results file name, repeat the search ");
System.out.println("against the same data");
System.out.println(" results_file is a full path to a results file");
System.out.println("The program must be run from the mascot cgi directory");
}
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: repeat_search.py

repeat_search.py

Repeating a search from a Mascot results file.

1#!/usr/bin/perl
2
17
18import msparser
19import sys
20import subprocess
21import re
22
23def main() :
24 if len(sys.argv) < 2 :
25 usage()
26 return 1
27
28 return repeatSearch(sys.argv[1])
29
30
31def repeatSearch(filename) :
32 resfile = msparser.ms_mascotresfilebase.createResfile(filename)
33
34 if not resfile.isValid() :
35 print("Cannot open results file %s : %s" % (filename, resfile.getLastErrorString()))
36 return 1
37
38 s = []
39
40 s.append("----12345")
41 s.append('Content-Disposition: form-data; name="QUE"')
42 s.append('')
43
44 # Parameters section
45 keys, values = resfile.getSearchParametersKeyValues()
46 for key, val in zip(keys, values):
47 # To search against a different database, add 'and key ne "DB"'
48 if len(val) > 0 and key != "INTERMEDIATE" and key != "RULES" and key != "INTERNALS" and key != "SEARCH" :
49 s.append("%s=%s" % (key, val))
50
51 # To search against a different DB add e.g.
52 # s.append("DB=MY_DB")
53
54 # Most flexible to repeat each search as a 'sequence' search.
55 s.append("SEARCH=SQ")
56
57 # For ms-ms data, tell nph-mascot where to find the ions data
58 s.append("INTERMEDIATE=" + filename)
59
60 # Now the repeat search data.
61 for q in range(1, 1 + resfile.getNumQueries()) :
62 s.append(resfile.getRepeatSearchString(q))
63
64 # Terminating line for MIME format file
65 s.append("----12345--")
66
67 # Start nph-mascot.exe, and redirect the output to tmp.txt.
68 try :
69 tmp = open("tmp.txt", "w")
70
71 except IOError as err:
72 errno, strerror = err.args
73 print("Cannot open tmp.txt for writing: %s" % strerror)
74 return 1
75 # Replace 'nph-mascot.exe' with './nph-mascot.exe' in Unix.
76
77 try :
78 proc = subprocess.Popen(
79 ['./nph-mascot.exe', '4', '-commandline'],
80 stdin=subprocess.PIPE,
81 stdout=tmp
82 )
83 except OSError as e :
84 print("Cannot run nph-mascot.exe: %s" % e)
85 return 1
86
87 for line in s :
88 proc.stdin.write(line.encode('utf-8'))
89 proc.stdin.write("\n".encode('utf-8'))
90
91
92 proc.stdin.close()
93 proc.wait()
94
95 tmp.close()
96
97 try :
98 tmp = open("tmp.txt", "r")
99 except IOError as err:
100 errno, strerror = err.args
101 print("Cannot open tmp.txt for reading: %s" % strerror)
102 return 1
103
104 while True :
105 line = tmp.readline()
106
107 if len(line) == 0 : break
108
109 if re.match('.*SUCCESS.*', line) :
110 # Next line contains the results file name
111 line = tmp.readline()
112
113 compareResults(resfile, line.rstrip('\n'))
114 continue
115
116 if re.match('.*ERROR.*', line) :
117 print("Search failed:", line.rstrip('\n'))
118 # Print details of error messages
119
120 while len(line) != 0 :
121 line = tmp.readline()
122 print(line.rstrip('\n'))
123
124 break
125
126
127def compareResults(originalSearch, repeatedSearchFileName) :
128 repeatedSearch = msparser.ms_mascotresfilebase.createResfile(repeatedSearchFileName)
129 anyReport = 0
130
131 if not repeatedSearch.isValid() :
132 print("Invalid repeat search: %s" % repeatedSearch.getLastErrorString())
133 return
134
135 if originalSearch.anyPMF() :
136 # Use protein summary
137 originalResults = msparser.ms_proteinsummary(originalSearch)
138 repeatedResults = msparser.ms_proteinsummary(repeatedSearch)
139
140 originalProt = originalResults.getHit(1)
141 repeatedProt = repeatedResults.getHit(1)
142
143 if originalProt and repeatedProt :
144 diff = repeatedProt.getScore() - originalProt.getScore()
145
146 if diff > 10.0 :
147 print("Protein score is %d higher for search" % diff)
148 print("%s than %s " % (originalSearch.getFileName(), repeatedSearchFileName))
149
150
151 anyReport = 1
152 else :
153 # Use peptide summary
154 originalResults = msparser.ms_peptidesummary(originalSearch)
155 repeatedResults = msparser.ms_peptidesummary(repeatedSearch)
156
157 # Compare peptide scores
158 for q in range(1, 1 + originalSearch.getNumQueries()) :
159 pepOriginal = originalResults.getPeptide(q, 1)
160 pepRepeated = repeatedResults.getPeptide(q, 1)
161 diff = pepRepeated.getIonsScore() - pepOriginal.getIonsScore()
162
163 if diff > 10.0 :
164 print("Query %d has score %d higher for search %s than %s" % (q, diff, originalSearch.getFileName(), repeatedSearchFileName))
165
166
167 anyReport = 1
168
169 if not anyReport :
170 print("Similar results for %s and %s" % (originalSearch.getFileName(), repeatedSearchFileName))
171
172
173
174def usage() :
175 print("""
176Usage: repeat_search.py <results file>
177
178Given an mascot results file name, repeat the search against the same data.
179
180This program must be run in the Mascot Server cgi directory.
181""")
182
183if __name__ == "__main__" :
184 sys.exit(main())
185
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: repeat_search.cs

repeat_search.cs

Repeating a search from a Mascot results file.

/*
##############################################################################
# file: repeat_search.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/repeat_search.cs $ #
# $Author: patricke@matrixscience.com $ #
# $Date: 2024-09-20 14:01:59 +0100 $ #
# $Revision: 35ee9fdfd7f3492b33e84cefbdd9b0c936c3c9a4 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.Diagnostics;
using System.IO;
using System.Text;
using matrix_science.msparser;
namespace MsParserExamples
{
public class repeat_search
{
public static void Main(string[] argv)
{
if (argv.Length < 1)
{
usage();
return;
}
repeatSearch(argv[0]);
}
private static bool repeatSearch(string filename)
{
bool success = false;
ms_mascotresfilebase file = ms_mascotresfilebase.createResfile(filename, 0, "");
if (file.isValid())
{
StringBuilder s = new StringBuilder(); // Build up a MIME format string with all parameters
s.Append("----12345\n");
s.Append("Content-Disposition: form-data; name=\"QUE\"");
s.Append("\n\n");
// Parameters section
VectorString keys = new VectorString();
VectorString values = new VectorString();
file.getSearchParametersKeyValues(keys, values);
for (int i = 0; i < keys.Count; ++i) {
string key = keys[i];
string val = values[i];
// To search against a different database, add && key != "DB"
if (val.Length > 0 && !key.Equals("INTERMEDIATE") && !key.Equals("RULES") && !key.Equals("INTERNALS") && !key.Equals("SEARCH"))
{
s.Append(string.Format("{0}={1}\n", key, val));
}
}
// To search against a different DB add: s.Append("DB=MY_DB\n");
//s.Append("DB=repeat\n");
// Most flexible to repeat each search as a 'sequence' search.
s.Append("SEARCH=SQ\n");
// For ms-ms data, tell nph-mascot where to find the ions data
s.Append("INTERMEDIATE=").Append(filename).Append("\n");
// Now the repeat search data
for (int q = 1; q <= file.getNumQueries(); q++)
{
s.Append(file.getRepeatSearchString(q)).Append("\n");
}
s.Append("----12345--\n");
// Start nph-mascot.exe, and redirect the output to tmp.txt
// Note that for Unix, you may need to use ./nph-mascot.exe
try
{
ProcessStartInfo start = new ProcessStartInfo();
start.FileName = @"./nph-mascot.exe";
start.Arguments = "4 -commandline";
start.RedirectStandardOutput = true;
start.RedirectStandardInput = true;
start.UseShellExecute = false;
using (Process process = Process.Start(start))
{
using (StreamWriter writer = process.StandardInput)
{
writer.Write(s.ToString());
writer.Flush();
}
using (StreamReader reader = process.StandardOutput)
{
string buf;
while ((buf = reader.ReadLine()) != null)
{
if (buf.Contains("SUCCESS"))
{
if ((buf = reader.ReadLine()) != null)
{
Console.WriteLine(buf);
compareResults(file, buf);
success = true;
}
}
else if (buf.Contains("ERROR"))
{
}
}
}
}
}
catch (Exception e)
{
Console.WriteLine(e.Message);
}
}
else
{
Console.WriteLine("Cannot open results file {0}", filename);
Console.WriteLine(file.getLastErrorString());
}
return success;
}
private static void compareResults(ms_mascotresfilebase originalSearch, string repeatedSearchFileName)
{
ms_mascotresfilebase repeatedSearch = ms_mascotresfilebase.createResfile(repeatedSearchFileName, 0, "");
Boolean anyReport = false;
if (repeatedSearch.isValid())
{
if (originalSearch.anyPMF())
{
// Use protein summary
ms_proteinsummary originalResults = new ms_proteinsummary(originalSearch,
(uint) ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS, 0, 1, null, null);
ms_proteinsummary repeatedResults = new ms_proteinsummary(repeatedSearch,
(uint)ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS, 0, 1, null, null);
ms_protein originalProt = originalResults.getHit(1);
ms_protein repeatedProt = repeatedResults.getHit(1);
if (originalProt != null & repeatedProt != null)
{
double diff = repeatedProt.getScore() - originalProt.getScore();
if (diff > 10)
{
Console.WriteLine("Protein score is {0} higher for search {1} than {2}",
diff, repeatedSearchFileName, originalSearch.getFileName());
anyReport = true;
}
}
}
else
{
// use peptide summary
ms_peptidesummary originalResults = new ms_peptidesummary(originalSearch,
(uint)ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS, 0, 1, null, 0, 0, null);
ms_peptidesummary repeatedResults = new ms_peptidesummary(repeatedSearch,
(uint)ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS, 0, 1, null, 0, 0, null);
// Compare peptide scores
for (int q = 1; q <= originalSearch.getNumQueries(); q++)
{
ms_peptide pepOriginal = originalResults.getPeptide(q, 1);
ms_peptide pepRepeated = repeatedResults.getPeptide(q, 1);
if (pepOriginal != null && pepRepeated != null)
{
double diff = pepRepeated.getIonsScore() - pepOriginal.getIonsScore();
if (diff > 10)
{
Console.WriteLine("Query {0} has core {1} higher for search {2} than {3}",
q, diff, repeatedSearchFileName, originalSearch.getFileName());
anyReport = true;
}
}
}
}
if (!anyReport)
{
Console.WriteLine("Similar results for {0} and {1}", originalSearch.getFileName(), repeatedSearchFileName);
}
}
else
{
Console.WriteLine("Invalid repeat search: {0}", repeatedSearch.getLastErrorString());
}
}
private static void usage()
{
Console.WriteLine("Usage: repeat_search <results_file> ");
Console.WriteLine("Given a mascot results file name, repeat the search ");
Console.WriteLine("against the same data");
Console.WriteLine(" result_file is a full path to a result file");
Console.WriteLine("The program must be run from the mascot cgi directory");
}
}
}
/*
C:\inetpub\mascot\cgi>repeat_search.exe ..\data\F981123.dat
Will give the following output:
../data/20150728/F002065.dat
Similar results for ..\data\F981123.dat and ../data/20150728/F002065.dat
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: create_mgf.pl

create_mgf.pl

Create an mgf file from a Mascot results file.

#!/usr/local/bin/perl
##############################################################################
# file: create_mgf.pl #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/create_mgf.pl $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) {
usage();
exit(1);
}
createMGF($ARGV[0]);
sub createMGF {
my ($filename) = @_;
my $resfile = msparser::ms_mascotresfilebase::createResfile($filename);
if (!$resfile->isValid) {
print STDERR "Cannot open results file ", $filename, ": ";
print STDERR $resfile->getLastErrorString(), "\n";
return;
}
my $output_filename = $filename.'.mgf';
if (-e $output_filename) {
print STDERR "$output_filename already exists; will not overwrite\n";
return;
}
open(my $fh, '>', $output_filename)
or die "Cannot open $output_filename for writing: $!";
for my $q (1 .. $resfile->getNumQueries) {
my $inp_query = new msparser::ms_inputquery($resfile, $q);
if ($inp_query->getNumberOfPeaks(1) == 0) {
# PMF - just the mass
print $fh $resfile->getObservedMass($q), "\n";
next;
}
print $fh "BEGIN_IONS\n";
print $fh "PEPMASS=", $resfile->getObservedMass($q), "\n";
if ($resfile->getObservedCharge($q) > 0) {
print $fh "CHARGE=", $resfile->getObservedCharge($q), "+\n";
} else {
print $fh "CHARGE=Mr\n";
}
if ($inp_query->getStringTitle(1)) {
print $fh "TITLE=", $inp_query->getStringTitle(1), "\n";
}
for my $i (1 .. $inp_query->getNumberOfPeaks(1)) {
print $fh $inp_query->getPeakMass(1, $i), " ", $inp_query->getPeakIntensity(1, $i), "\n";
}
print $fh "END IONS\n\n";
}
}
sub usage {
print <<EOF;
Usage: create_mgf.pl <results file>
Given an mascot results file name, create an MGF file. The MGF file
will be named <results file>.mgf in the same directory where <results file>
is located.
EOF
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: create_mgf.py

create_mgf.py

Create an mgf file from a Mascot results file.

1#!/usr/bin/python
2
17
18import msparser
19import sys
20import os.path
21
22def main() :
23 if len(sys.argv) < 2 :
24 usage()
25 return 1
26
27 createMGF(sys.argv[1])
28
29
30def createMGF(filename) :
31 resfile = msparser.ms_mascotresfilebase.createResfile(filename)
32
33 if not resfile.isValid() :
34 print("Cannot open results file %s : %s" % (filename, resfile.getLastErrorString()))
35 return
36
37 output_filename = filename + '.mgf'
38
39 if os.path.isfile(output_filename) :
40 print("%s already exists; will not overwrite" % output_filename)
41 return
42
43 try :
44 fh = open(output_filename, "w")
45
46 except IOError as err:
47 errno, strerror = err.args
48 print("Cannot open output_filename for writing: I/O error(%d): %s" % (
49 errno, strerror
50 ))
51 sys.exit(1)
52
53 for q in range(1, 1 + resfile.getNumQueries()) :
54 inp_query = msparser.ms_inputquery(resfile, q)
55
56 if inp_query.getNumberOfPeaks(1) == 0 :
57 # PMF - just the mass
58 fh.write("%f\n" % resfile.getObservedMass(q))
59 continue
60
61 fh.write("BEGIN_IONS\n");
62 fh.write("PEPMASS=%f\n" % resfile.getObservedMass(q))
63
64 if resfile.getObservedCharge(q) > 0 :
65 fh.write("CHARGE=%f+\n" % resfile.getObservedCharge(q))
66 else :
67 fh.write("CHARGE=Mr\n")
68
69 if inp_query.getStringTitle(True) :
70 fh.write("TITLE=%s\n" % inp_query.getStringTitle(True))
71
72 for i in range(1, 1 + inp_query.getNumberOfPeaks(1)) :
73 fh.write("%f %f\n" % (inp_query.getPeakMass(1, i), inp_query.getPeakIntensity(1, i)))
74
75 fh.write("END IONS\n")
76
77 fh.close()
78
79
80def usage() :
81 print("""
82Usage: create_mgf.py <results file>
83
84Given a mascot results file name, create an MGF file. The MGF file
85will be named <results file>.mgf in the same directory where <results file>
86is located.
87""")
88
89if __name__ == "__main__" :
90 sys.exit(main())
91
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: create_mgf.cs

create_mgf.cs

Create an mgf file from a Mascot results file.

/*
##############################################################################
# file: create_mgf.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/create_mgf.cs $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.IO;
using matrix_science.msparser;
namespace MsParserExamples
{
public class create_mgf
{
public static void Main(string[] argv)
{
if (argv.Length < 1)
{
usage();
return;
}
createMGF(argv[0]);
}
private static void createMGF(string filename)
{
ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile(filename);
if (!resfile.isValid())
{
Console.WriteLine("Cannot open results file {0}: {1}", filename, resfile.getLastErrorString());
return;
}
string outputFilename = filename + ".mgf";
// check if the mgf file already exists - do not overwrite if it does
if (File.Exists(outputFilename))
{
Console.WriteLine("{0} already exists; will not overwrite", outputFilename);
return;
}
// create the file
using (TextWriter tw = new StreamWriter(outputFilename))
{
for (int q = 1; q <= resfile.getNumQueries(); q++)
{
ms_inputquery inpQuery = new ms_inputquery(resfile, q);
if (inpQuery.getNumberOfPeaks(1) == 0)
{
// PMF - just the mass
tw.WriteLine(resfile.getObservedMass(q));
continue;
}
tw.WriteLine("BEGIN IONS");
tw.WriteLine("PEPMASS={0}", resfile.getObservedMass(q));
if (Math.Abs(resfile.getObservedCharge(q)) > 0)
{
tw.WriteLine("CHARGE={0}", resfile.getObservedCharge(q));
}
else
{
tw.WriteLine("CHARGE=Mr");
}
if (inpQuery.getStringTitle(true).Length > 0)
{
tw.WriteLine("TITLE={0}", inpQuery.getStringTitle(true));
}
for (int i = 1; i <= inpQuery.getNumberOfPeaks(1); i++)
{
tw.WriteLine("{0} {1}", inpQuery.getPeakMass(1, i), inpQuery.getPeakIntensity(1, i));
}
tw.WriteLine("END IONS");
}
}
}
private static void usage()
{
Console.WriteLine(@"Usage: create_mgf <results file>.
Given a mascot results file name, create an MGF file. The MGF file
will be named <results file>.mgf in the same directory where <results file>
is located.");
}
}
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: msparser.pl

msparser.pl

Large example / test program that illustrates most functionality.

#!/usr/local/bin/perl
##############################################################################
# file: msparser.pl #
# This file illustrates how to call the Mascot perl module 'msparser' #
# It mirrors the C++ test harness #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
# This program may be used and modified within the licensee's organisation #
# provided that this copyright notice remains intact. Distribution of this #
# program or parts thereof outside the licensee's organisation without the #
# prior written consent of Matrix Science Limited is expressly forbidden. #
##############################################################################
# $Source: parser/examples/test_perl/msparser.pl $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
die "Must specify results filename as parameter" unless defined $ARGV[0];
my $resfile = msparser::ms_mascotresfilebase::createResfile($ARGV[0]);
if (!$resfile->isValid) {
print STDERR "Cannot process file '$ARGV[0]':\n";
print STDERR "Error number: ", $resfile->getLastError(), "\n";
print STDERR "Error string: ", $resfile->getLastErrorString(), "\n";
exit(1);
}
checkErrorHandler($resfile);
searchInformation($resfile);
searchParameters($resfile);
inputData($resfile);
print "-------------------------------------------------------------\n";
print "--- Full Protein summary report ---\n";
print "-------------------------------------------------------------\n";
show_results(
$resfile,
0,
$msparser::ms_mascotresults::MSRES_NOFLAG,
1.0 / 20.0, # minProbability
5 # Number of hits
);
print "-------------------------------------------------------------\n";
print "--- Concise Protein summary report ---\n";
print "-------------------------------------------------------------\n";
show_results(
$resfile,
0,
$msparser::ms_mascotresults::MSRES_GROUP_PROTEINS
| $msparser::ms_mascotresults::MSRES_SHOW_SUBSETS,
0, # minProbability
3 # Number of hits
);
if ($resfile->isMSMS()) {
print "-------------------------------------------------------------\n";
print "--- Peptide summary report ---\n";
print "-------------------------------------------------------------\n";
show_results(
$resfile,
1, # peptide summary
$msparser::ms_mascotresults::MSRES_GROUP_PROTEINS
| $msparser::ms_mascotresults::MSRES_SHOW_SUBSETS,
0, # minProbability
8, # number of hits
0, # ignoreIonsScoreBelow
0 # minimum peptide length
);
} else {
print "Not an MS-MS results file - cannot show peptide summary report\n";
}
##############################################################################
# show_results #
# - parameter 0 is ms_mascotresfilebase #
# - parameter 1 is true for peptide summary, false for protein #
# - parameter 2 is the flags for display #
# - parameter 3 is the minimum protein probability to display #
# - parameter 4 is the maximum number of hits to display #
# - parameter 5 is the minimum ions score to use #
# - parameter 6 is the minPepLenInPepSummary to use #
##############################################################################
sub show_results {
my($file, $usePeptideSummary, $flags, $minProteinProb, $maxHits,
$minIonsScore, $minPepLenInPepSummary) = @_;
my $results;
if ($usePeptideSummary) {
$results = new msparser::ms_peptidesummary(
$resfile, $flags, $minProteinProb, $maxHits, "", $minIonsScore, $minPepLenInPepSummary
);
} else {
$results = new msparser::ms_proteinsummary(
$file, $flags, $minProteinProb, $maxHits
);
}
if ($resfile->getLastError()) {
print STDERR "Error : ", $file->getLastErrorString(), "\n";
return;
}
my $hit = 1;
my $prot = $results->getHit($hit);
while (defined($prot)) {
my $accession = $prot->getAccession();
my $description = $results->getProteinDescription($accession);
my $mass = $results->getProteinMass($accession);
print "Protein Hit ", $hit, "\n===================\n";
print "Accession : " , $accession, "\n";
print "Description : " , $description , "\n";
print "Score : " , $prot->getScore() , "\n";
print "Mass : " , $mass , "\n";
print "Frame : " , $prot->getFrame() , "\n";
print "Coverage : " , $prot->getCoverage() , "\n";
print "RMS error : " , $prot->getRMSDeltas($results), "\n";
print "Peptides : " , $prot->getNumDisplayPeptides(),"\n";
# Each protein has a number of peptides that matched - list them:
my $num_peps = $prot->getNumPeptides();
for my $i (1 .. $num_peps) {
my $query = $prot->getPeptideQuery($i);
my $p = $prot->getPeptideP($i);
if (
$p != -1
and $query != -1
and $prot->getPeptideDuplicate($i) != $msparser::ms_protein::DUPE_DuplicateSameQuery
) {
my $pep = $results->getPeptide($query, $p);
next unless defined $pep;
displayPeptideInfo(
0, $pep, $results,
$prot->getPeptideDuplicate($i) == $msparser::ms_protein::DUPE_Duplicate,
$prot->getPeptideIsBold($i),
$prot->getPeptideShowCheckbox($i)
);
}
}
# Now display list of all proteins that contained subsets or and
# identical list of the matching peptides
if ($flags & $msparser::ms_mascotresults::MSRES_GROUP_PROTEINS) {
print "Proteins matching the same set of peptides:\n";
my $i = 1;
while (my $prot = $results->getNextSimilarProtein($hit, $i)) {
my $accession = $prot->getAccession();
print $accession, " Total score: ", $prot->getScore();
print " Peptides matched: ", $prot->getNumDisplayPeptides(), "\n";
$i++;
}
if ($flags & $msparser::ms_mascotresults::MSRES_SHOW_SUBSETS) {
print "Proteins matching a subset of these peptides:\n";
my $i = 1;
while ($prot = $results->getNextSubsetProtein($hit, $i)) {
my $accession = $prot->getAccession();
print $accession, " Total score: ", $prot->getScore();
print " Peptides matched: ", $prot->getNumDisplayPeptides(), "\n";
$i++;
}
}
}
print "\n\n";
$hit++;
$prot = $results->getHit($hit);
}
$results->createUnassignedList($msparser::ms_mascotresults::SCORE);
if ($results->getNumberOfUnassigned()) {
print "Unassigned list\n";
print "---------------\n";
for my $u (1 .. $results->getNumberOfUnassigned) {
my $pep = $results->getUnassigned($u);
displayPeptideInfo(0, $pep, $results, 0, 1, 1);
}
}
if ($usePeptideSummary) {
print "\n";
displayYellowPopupInfo($results, 97);
}
}
##############################################################################
# displayYellowPopupInfo #
# Shows the equivalent of the yellow popup box for given query #
# - parameter 0 is the results object #
# - parameter 1 is the query number #
##############################################################################
sub displayYellowPopupInfo {
my ($results, $q) = @_;
my $fmt = "%5s %5s %9s %7s %7s\n";
printf $fmt, qw(Score Delta Hit Protein Peptide);
for my $p (1 .. 10) {
my $pep = $results->getPeptide($q, $p);
next unless defined $pep;
my $seq = $pep->getPeptideStr();
next unless defined $seq;
my $tmp = $results->getProteinsWithThisPepMatch($q, $p);
my ($hit, $protein) = ('', '');
if ($tmp) {
($hit, $protein, my $morethan) = $tmp =~ /(\d+):([^ ]*)[ ]*(.*)/;
if ($morethan) {
$hit .= "+";
}
}
printf $fmt, $pep->getIonsScore(), $pep->getDelta(), $hit, $protein, $seq;
}
my $p = 1;
print "Accessions that matched query ", $q, " rank ", $p, ":- ",
$results->getProteinsWithThisPepMatch($q, $p), "\n";
}
##############################################################################
# displayPeptideInfo #
# - parameter 0 showFullDetails? #
# - parameter 1 p #
# - parameter 2 ms_mascotresults #
# - parameter 3 isDuplicate? #
# - parameter 4 isBold? #
# - parameter 5 showCheckBox? #
##############################################################################
sub displayPeptideInfo {
my ($showFullDetails, $p, $r, $isDuplicate, $isBold, $showCheckBox) = @_;
my $q = $p->getQuery();
if (!$showFullDetails) {
my $fmt = "%2s %4s %4d %11f %4d(%4d) %-20s %s%3.2f%s %3s\n";
printf $fmt,
$showCheckBox ? "CB" : "--",
$isBold ? "BOLD" : "dim",
$q,
$p->getObserved,
$p->getRank,
$p->getPrettyRank,
$p->getPeptideStr,
$isDuplicate ? '(' : '',
$p->getIonsScore,
$isDuplicate ? ')' : '',
$r->getReadableVarMods($q, $p->getRank),
;
return;
}
print "Peptide hit\n";
if ($p->getAnyMatch()) {
my $fmt = " %-12s: %s\n";
printf $fmt, 'Query' , $q;
printf $fmt, 'Rank' , $p->getRank;
printf $fmt, 'Matched' , $p->getAnyMatch;
printf $fmt, 'missedCleave', $p->getMissedCleavages;
printf $fmt, 'mrCalc' , $p->getMrCalc;
printf $fmt, 'delta' , $p->getDelta;
printf $fmt, 'observed' , $p->getObserved;
printf $fmt, 'charge' , $p->getCharge;
printf $fmt, 'mrExp' , $p->getMrExperimental;
printf $fmt, 'ionsMatched' , $p->getNumIonsMatched;
printf $fmt, 'peptideStr' , $p->getPeptideStr;
printf $fmt, 'peaksUsed1' , $p->getPeaksUsedFromIons1;
printf $fmt, 'varModsStr' , $p->getVarModsStr;
printf $fmt, 'readable mod', $r->getReadableVarMods($q, $p->getRank);
printf $fmt, 'ionsScore' , $p->getIonsScore;
printf $fmt, 'seriesUsedS' , $p->getSeriesUsedStr;
printf $fmt, 'peaksUsed2' , $p->getPeaksUsedFromIons2;
printf $fmt, 'peaksUsed3' , $p->getPeaksUsedFromIons3;
printf $fmt, 'idth, hth, p', join(', ',
$r->getPeptideIdentityThreshold($q, 20),
$r->getHomologyThreshold($q, 20),
$r->getProbOfPepBeingRandomMatch($p->getIonsScore, $q)
);
print "\n";
} else {
print " No match\n";
}
}
##############################################################################
# checkErrorHandler #
# - parameter 0 ms_mascotresfilebase #
# Calls a couple of functions with invalid arguments #
##############################################################################
sub checkErrorHandler {
my ($resfile) = @_;
print "Testing the error handling... \n";
print "=========================================\n";
my $numQueries = $resfile->getNumQueries();
$resfile->getObservedCharge($numQueries + 40); # Should fail
print "Error number: ", $resfile->getLastError(), "\n";
print "Error string: ", $resfile->getLastErrorString(), "\n";
$resfile->clearAllErrors();
print "Cleared all errors - should have no errors left: ", $resfile->getNumberOfErrors();
print " errors left\n\n";
for my $x (1 .. 20) {
$resfile->getObservedCharge($numQueries + $x); # Should fail
}
# Now, the best way, print out all errors.
print "More errors added - there are now ", $resfile->getNumberOfErrors();
print " errors\n";
for my $i (1 .. $resfile->getNumberOfErrors) {
print "Error number: ", $resfile->getErrorNumber($i);
print " : ", $resfile->getErrorString($i);
print "\n";
}
print "\n";
$resfile->clearAllErrors();
}
##############################################################################
# searchInformation #
# - parameter 0 ms_mascotresfilebase #
# Display parameters from the ms_mascotresfilebase object. The functions #
# anyPMF, anyMSMS, anySQ should normally be used in preference to isPMF etc #
# because some people submit MSMS though the sequence query window etc. #
##############################################################################
sub searchInformation {
my ($resfile) = @_;
my $fmt = "%-20s: %s\n";
print "Search information from ms_mascotresfilebase", "\n";
print "========================================", "\n";
printf $fmt, "Number of queries" , $resfile->getNumQueries();
printf $fmt, "Number of sequences" , $resfile->getNumSeqs();
printf $fmt, "Sequences after tax" , $resfile->getNumSeqsAfterTax();
printf $fmt, "Number of residues" , $resfile->getNumResidues();
printf $fmt, "Execution time" , $resfile->getExecTime();
printf $fmt, "Date (seconds)" , $resfile->getDate();
# Let's jump through a few hoops to get the equivalent of a 'C' asctime call
my ($sec, $min, $hour, $mday, $mon, $year, $wday, $yday, $isdst)
= localtime($resfile->getDate);
printf $fmt, "Date", sprintf("%s %s %d %02d:%02d:%02d %d",
(qw(Sun Mon Tue Wed Thu Fri Sat))[$wday],
(qw(Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec))[$mon],
$mday,
$hour,
$min,
$sec,
$year+1900
);
printf $fmt, "Mascot version" , $resfile->getMascotVer();
printf $fmt, "Fasta version" , $resfile->getFastaVer();
printf $fmt, "Is PMF?" , $resfile->isPMF();
printf $fmt, "Is MSMS?" , $resfile->isMSMS();
printf $fmt, "Is SQ?" , $resfile->isSQ();
printf $fmt, "Is Error tolerant" , $resfile->isErrorTolerant();
printf $fmt, "Any PMF?" , $resfile->anyPMF();
printf $fmt, "Any MSMS?" , $resfile->anyMSMS();
printf $fmt, "Any SQ?" , $resfile->anySQ();
printf $fmt, "Any peptide matches" , $resfile->anyFastaMatches();
print "\n";
}
##############################################################################
# searchParameters #
# Display parameters from the ms_searchparams object. #
# The values come from the parameters and the masses sections of the file #
##############################################################################
sub searchParameters {
my ($resfile) = @_;
my $params = $resfile->params;
my $fmt = "%-20s: %s\n";
print "Search parameters from ms_searchparams" , "\n";
print "=========================================" , "\n";
printf $fmt, "License" , $params->getLICENSE();
printf $fmt, "Search title" , $params->getCOM();
printf $fmt, "SEG mass" , $params->getSEG();
printf $fmt, "Peptide tol" , $params->getTOL();
printf $fmt, "Peptide tol units" , $params->getTOLU();
printf $fmt, "Fragment tol" , $params->getITOL();
printf $fmt, "Fragment tol units" , $params->getITOLU();
printf $fmt, "Missed cleavages" , $params->getPFA();
printf $fmt, "Database" , $params->getDB();
printf $fmt, "Static mods" , $params->getMODS();
printf $fmt, "Average/monoisotopic", $params->getMASS();
printf $fmt, "Enzyme" , $params->getCLE();
printf $fmt, "Raw data file name" , $params->getFILENAME();
printf $fmt, "Input data" , $params->getQUE();
printf $fmt, "Type of search" , $params->getSEARCH();
printf $fmt, "User name" , $params->getUSERNAME();
printf $fmt, "User email" , $params->getUSEREMAIL();
printf $fmt, "Charge state" , $params->getCHARGE();
printf $fmt, "Repeat search file" , $params->getINTERMEDIATE();
printf $fmt, "Num hits to display" , $params->getREPORT();
printf $fmt, "Show overview" , $params->getOVERVIEW();
printf $fmt, "Data file format" , $params->getFORMAT();
printf $fmt, "Form version" , $params->getFORMVER();
printf $fmt, "Variable mods" , $params->getIT_MODS();
for my $i (0 .. 12) {
printf $fmt, sprintf("User%02d", $i), $params->getUSERField($i);
}
printf $fmt, "Precursor mass" , $params->getPRECURSOR();
printf $fmt, "Taxonomy filter" , $params->getTAXONOMY();
printf $fmt, "Type of report" , $params->getREPTYPE();
printf $fmt, "Accessions to search", $params->getACCESSION();
printf $fmt, "Subcluster used" , $params->getSUBCLUSTER();
printf $fmt, "ICAT search?" , $params->getICAT();
printf $fmt, "Instrument type" , $params->getINSTRUMENT();
printf $fmt, "Error tolerant?" , $params->getERRORTOLERANT();
printf $fmt, "Rules (ions series)" , $params->getRULES();
for my $ch (ord('A') .. ord('Z')) {
printf $fmt, join(' ', "Residue", chr($ch)), $params->getResidueMass(chr($ch));
}
printf $fmt, "C terminus mass" , $params->getCTermMass();
printf $fmt, "N terminus mass" , $params->getNTermMass();
printf $fmt, "Mass of hydrogen", $params->getHydrogenMass();
printf $fmt, "Mass of oxygen" , $params->getOxygenMass();
printf $fmt, "Mass of carbon" , $params->getCarbonMass();
printf $fmt, "Mass of nitrogen", $params->getNitrogenMass();
printf $fmt, "Mass of electron", $params->getElectronMass();
my $i = 1;
while ($params->getVarModsName($i)) {
printf $fmt, "Variable mod name" , $params->getVarModsName($i);
printf $fmt, "Variable mod delta" , $params->getVarModsDelta($i), "\n";
printf $fmt, "Variable mod neutral", $params->getVarModsNeutralLoss($i), "\n";
$i++;
}
print "\n\n";
}
##############################################################################
# inputData #
# - parameter 0 ms_mascotresfilebase #
# Display input data #
##############################################################################
sub inputData {
my ($resfile) = @_;
# display input data via inputquery get functions
for my $i (1 .. 1) {
# replace 1 .. 1 with 1 .. $resfile->getNumQueries() to get all input
# data.
print "Input data for query number ", $i , "\n";
print "=========================================", "\n";
my $q = new msparser::ms_inputquery($resfile, $i);
my $fmt = " %-16s: %s\n";
printf $fmt, "title" , $q->getStringTitle(1);
printf $fmt, "mass_min" , $q->getMassMin();
printf $fmt, "mass_max" , $q->getMassMax();
printf $fmt, "int_min" , $q->getIntMin();
printf $fmt, "int_max" , $q->getIntMax();
printf $fmt, "num_vals" , $q->getNumVals();
printf $fmt, "num_used1" , $q->getNumUsed();
printf $fmt, "ions1" , $q->getStringIons1();
printf $fmt, "ions2" , $q->getStringIons2();
printf $fmt, "ions3" , $q->getStringIons3();
printf $fmt, "peptol" , $q->getPepTol();
printf $fmt, "peptol units", $q->getPepTolUnits();
printf $fmt, "peptol str" , $q->getPepTolString();
printf $fmt, "repeat srch" , $resfile->getRepeatSearchString($i);
my $num_peaks = $q->getNumberOfPeaks(1);
for my $j (1 .. $num_peaks) {
print $q->getPeakMass(1, $j), ", ", $q->getPeakIntensity(1, $j), "\n";
}
}
print "\n\n";
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: msparser_full.py

msparser_full.py

Large example / test program that illustrates most functionality.

1#!/usr/bin/python
2
21
22import msparser
23import sys
24import re
25import time
26
27def main() :
28 if len(sys.argv) < 2 :
29 print("Must specify results filename as parameter")
30 return 1
31
32 resfile = msparser.ms_mascotresfilebase.createResfile(sys.argv[1])
33
34 if not resfile.isValid() :
35 print("Cannot process file '%s':" % sys.argv[1])
36 print("Error number: %s" % resfile.getLastError())
37 print("Error string: %s" % resfile.getLastErrorString())
38 return 1
39
40 checkErrorHandler(resfile)
41 searchInformation(resfile)
42 searchParameters(resfile)
43 inputData(resfile)
44
45 print("-------------------------------------------------------------")
46 print("--- Full Protein summary report ---")
47 print("-------------------------------------------------------------")
48
49 show_results(
50 resfile,
51 0,
52 msparser.ms_mascotresults.MSRES_NOFLAG,
53 1.0 / 20.0, # minProbability
54 5 # Number of hits
55 )
56
57 print("-------------------------------------------------------------")
58 print("--- Concise Protein summary report ---")
59 print("-------------------------------------------------------------")
60
61 show_results(
62 resfile,
63 0,
64 msparser.ms_mascotresults.MSRES_GROUP_PROTEINS
65 | msparser.ms_mascotresults.MSRES_SHOW_SUBSETS,
66 0, # minProbability
67 3 # Number of hits
68 )
69
70 if resfile.isMSMS() :
71 print("-------------------------------------------------------------")
72 print( "--- Peptide summary report ---")
73 print("-------------------------------------------------------------")
74
75 show_results(
76 resfile,
77 1, # peptide summary
78 msparser.ms_mascotresults.MSRES_GROUP_PROTEINS
79 | msparser.ms_mascotresults.MSRES_SHOW_SUBSETS,
80 0, # minProbability
81 8, # number of hits
82 0, # ignoreIonsScoreBelow
83 0 # minimum peptide length
84 )
85 else :
86 print("Not an MS-MS results file - cannot show peptide summary report")
87
88
89def show_results(resfile, usePeptideSummary, flags, minProteinProb, maxHits, minIonsScore = 0, minPepLenInPepSummary = 0) :
90 """
91 - file is ms_mascotresfilebase
92 - usePeptideSummary is true for peptide summary, false for protein
93 - flags is the flags for display
94 - minProteinProb is the minimum protein probability to display
95 - maxHits is the maximum number of hits to display
96 - minIonsScore is the minimum ions score to use
97 - minPepLenInPepSummary is the minPepLenInPepSummary to use
98 """
99
100 if usePeptideSummary :
101 results = msparser.ms_peptidesummary(
102 resfile, flags, minProteinProb, maxHits, "", minIonsScore, minPepLenInPepSummary
103 )
104 else :
105 results = msparser.ms_proteinsummary(
106 resfile, flags, minProteinProb, maxHits
107 )
108
109 if resfile.getLastError() :
110 print("Error : %s" % resfile.getLastErrorString())
111 return
112
113 hit = 1
114 prot = results.getHit(hit)
115
116 while prot :
117 accession = prot.getAccession()
118 description = results.getProteinDescription(accession)
119 mass = results.getProteinMass(accession)
120
121 print("Protein Hit %d" % hit)
122 print("===================")
123 print("Accession : %s" % accession)
124 print("Description : %s" % description)
125 print("Score : %s" % prot.getScore())
126 print("Mass : %s" % mass)
127 print("Frame : %s" % prot.getFrame())
128 print("Coverage : %s" % prot.getCoverage())
129 print("RMS error : %s" % prot.getRMSDeltas(results))
130 print("Peptides : %s" % prot.getNumDisplayPeptides())
131
132 # Each protein has a number of peptides that matched - list them:
133 num_peps = prot.getNumPeptides()
134
135 for i in range(1, 1+ num_peps) :
136 query = prot.getPeptideQuery(i)
137 p = prot.getPeptideP(i)
138
139 isDupSameQuery = prot.getPeptideDuplicate(i) != msparser.ms_protein.DUPE_DuplicateSameQuery
140 if p != -1 and query != -1 and not isDupSameQuery :
141 pep = results.getPeptide(query, p)
142 if not pep:
143 continue
144
145 displayPeptideInfo(
146 0, pep, results,
147 prot.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_Duplicate,
148 prot.getPeptideIsBold(i),
149 prot.getPeptideShowCheckbox(i)
150 )
151
152 # Now display list of all proteins that contained subsets or and
153 # identical list of the matching peptides
154
155 if flags & msparser.ms_mascotresults.MSRES_GROUP_PROTEINS :
156 print("Proteins matching the same set of peptides:")
157
158 i = 1
159 similar_prot = results.getNextSimilarProtein(hit, 1)
160 while similar_prot :
161 accession = prot.getAccession()
162 print(accession, "Total score:", similar_prot.getScore(),)
163 print(" Peptides matched:", similar_prot.getNumDisplayPeptides())
164 i += 1
165 similar_prot = results.getNextSimilarProtein(hit, i)
166
167 if flags & msparser.ms_mascotresults.MSRES_SHOW_SUBSETS :
168 print("Proteins matching a subset of these peptides:")
169
170 i = 1
171 subset_prot = results.getNextSubsetProtein(hit, 1)
172 while subset_prot :
173 accession = subset_prot.getAccession()
174 print(accession, "Total score:", subset_prot.getScore(),)
175 print(" Peptides matched:", subset_prot.getNumDisplayPeptides(), "")
176 i += 1
177 subset_prot = results.getNextSubsetProtein(hit, i)
178
179 print(" ")
180
181 hit += 1
182 prot = results.getHit(hit)
183
184
185 results.createUnassignedList(msparser.ms_mascotresults.SCORE)
186
187 if results.getNumberOfUnassigned() :
188 print("Unassigned list")
189 print("---------------")
190
191 for u in range(1, 1 + results.getNumberOfUnassigned()) :
192 pep = results.getUnassigned(u)
193 displayPeptideInfo(0, pep, results, 0, 1, 1)
194
195
196 if usePeptideSummary :
197 print(" ")
198 displayYellowPopupInfo(results, 97)
199
200
201def displayYellowPopupInfo(results, q) :
202 """
203 Shows the equivalent of the yellow popup box for given query
204 - results is the results object
205 - q is the query number
206 """
207
208 fmt = "%5s %5s %9s %7s %7s"
209 print(fmt % ("Score", "Delta", "Hit", "Protein", "Peptide"))
210
211 for p in range(1, 11) :
212 pep = results.getPeptide(q, p)
213 if not pep: continue
214
215 seq = pep.getPeptideStr()
216 if not seq: continue
217
218 tmp = results.getProteinsWithThisPepMatch(q, p)
219
220 (hit, protein) = ('', '')
221
222 if tmp :
223 match = re.search('(\d+):([^ ]*)[ ]*(.*)', tmp)
224 hit, protein, morethan = match.group(1), match.group(2), match.group(3)
225
226 if morethan :
227 hit += "+"
228
229 print(fmt % (pep.getIonsScore(), pep.getDelta(), hit, protein, seq))
230
231 p = 1
232 print("Accessions that matched query %s rank %s :- %s" % (q, p, results.getProteinsWithThisPepMatch(q, p)))
233
234
235def displayPeptideInfo(showFullDetails, p, results, isDuplicate, isBold, showCheckBox) :
236 q = p.getQuery()
237
238 if not showFullDetails :
239 fmt = "%2s %4s %4d %11f %4d(%4d) %-20s %s%3.2f%s %3s"
240
241 cb, bold = "--", "dim"
242 if showCheckBox : cb = "CB"
243 if isBold : bold = "BOLD"
244
245 paren1, paren2 = "", ""
246 if isDuplicate : paren1 = "(" ; paren2 = ")"
247
248 print(fmt % (
249 cb,
250 bold,
251 q,
252 p.getObserved(),
253 p.getRank(),
254 p.getPrettyRank(),
255 p.getPeptideStr(),
256 paren1,
257 p.getIonsScore(),
258 paren2,
259 results.getReadableVarMods(q, p.getRank())
260 ))
261
262 return
263
264
265 print("Peptide hit")
266
267 if p.getAnyMatch() :
268 fmt = " %-12s: %s"
269 print(fmt % ('Query' , q))
270 print(fmt % ('Rank' , p.getRank()))
271 print(fmt % ('Matched' , p.getAnyMatch()))
272 print(fmt % ('missedCleave', p.getMissedCleavages()))
273 print(fmt % ('mrCalc' , p.getMrCalc()))
274 print(fmt % ('delta' , p.getDelta()))
275 print(fmt % ('observed' , p.getObserved()))
276 print(fmt % ('charge' , p.getCharge()))
277 print(fmt % ('mrExp' , p.getMrExperimental()))
278 print(fmt % ('ionsMatched' , p.getNumIonsMatched()))
279 print(fmt % ('peptideStr' , p.getPeptideStr()))
280 print(fmt % ('peaksUsed1' , p.getPeaksUsedFromIons1()))
281 print(fmt % ('varModsStr' , p.getVarModsStr()))
282 print(fmt % ('readable mod', results.getReadableVarMods(q, p.getRank)))
283 print(fmt % ('ionsScore' , p.getIonsScore()))
284 print(fmt % ('seriesUsedS' , p.getSeriesUsedStr()))
285 print(fmt % ('peaksUsed2' , p.getPeaksUsedFromIons2()))
286 print(fmt % ('peaksUsed3' , p.getPeaksUsedFromIons3()))
287 print(fmt % ('idth, hth, p', ', '.join(
288 results.getPeptideIdentityThreshold(q, 20),
289 results.getHomologyThreshold(q, 20),
290 results.getProbOfPepBeingRandomMatch(p.getIonsScore(), q)
291 )))
292 print(" ")
293 else :
294 print(" No match")
295
296
297def checkErrorHandler(resfile) :
298 """
299 Calls a couple of functions with invalid arguments, then prints
300 their error messages.
301 """
302
303 print("Testing the error handling... ")
304 print("=========================================")
305
306 numQueries = resfile.getNumQueries()
307 resfile.getObservedCharge(numQueries + 40); # Should fail
308
309 print("Error number: %s" % resfile.getLastError())
310 print("Error string: %s" % resfile.getLastErrorString())
311
312 resfile.clearAllErrors()
313 print("Cleared all errors - should have no errors left: %s errors left" %resfile.getNumberOfErrors())
314
315 for x in range(1, 21) :
316 resfile.getObservedCharge(numQueries + x); # Should fail
317
318 # Now, the best way, print out all errors.
319 print("More errors added - there are now %s errors" % resfile.getNumberOfErrors())
320
321 for i in range(1, 1 + resfile.getNumberOfErrors()) :
322 print("Error number: %s : %s" % (resfile.getErrorNumber(i), resfile.getErrorString(i)))
323
324
325 print(" ")
326 resfile.clearAllErrors()
327
328
329def searchInformation(resfile) :
330 """
331 Display parameters from the ms_mascotresfilebase object. The functions
332 anyPMF, anyMSMS, anySQ should normally be used in preference to isPMF etc
333 because some people submit MSMS though the sequence query window etc.
334 """
335
336 fmt = "%-20s: %s"
337
338 print("Search information from ms_mascotresfilebase")
339 print("========================================")
340 print(fmt % ("Number of queries" , resfile.getNumQueries()))
341 print(fmt % ("Number of sequences" , resfile.getNumSeqs()))
342 print(fmt % ("Sequences after tax" , resfile.getNumSeqsAfterTax()))
343 print(fmt % ("Number of residues" , resfile.getNumResidues()))
344 print(fmt % ("Execution time" , resfile.getExecTime()))
345 print(fmt % ("Date (seconds)" , resfile.getDate()))
346
347 date = time.localtime(resfile.getDate())
348 Wdays = "Mon Tue Wed Thu Fri Sat Sun".split(" ")
349 Mons = "Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec".split(" ")
350
351 print(fmt %( "Date", "%s %s %d %02d:%02d:%02d %d" % (
352 Wdays[date.tm_wday],
353 Mons[date.tm_mon - 1],
354 date.tm_mday,
355 date.tm_hour,
356 date.tm_min,
357 date.tm_sec,
358 date.tm_year
359 )))
360
361 print(fmt % ("Mascot version" , resfile.getMascotVer()))
362 print(fmt % ("Fasta version" , resfile.getFastaVer()))
363 print(fmt % ("Is PMF?" , resfile.isPMF()))
364 print(fmt % ("Is MSMS?" , resfile.isMSMS()))
365 print(fmt % ("Is SQ?" , resfile.isSQ()))
366 print(fmt % ("Is Error tolerant" , resfile.isErrorTolerant()))
367 print(fmt % ("Any PMF?" , resfile.anyPMF()))
368 print(fmt % ("Any MSMS?" , resfile.anyMSMS()))
369 print(fmt % ("Any SQ?" , resfile.anySQ()))
370 print(fmt % ("Any peptide matches" , resfile.anyFastaMatches()))
371
372 print(" ")
373
374
375
376def searchParameters(resfile) :
377 """
378 Display parameters from the ms_searchparams object.
379 The values come from the parameters and the masses sections of the file.
380 """
381
382 params = resfile.params()
383 fmt = "%-20s: %s"
384
385 print("Search parameters from ms_searchparams")
386 print("=========================================")
387 print(fmt % ("License" , params.getLICENSE()))
388 print(fmt % ("Search title" , params.getCOM()))
389 print(fmt % ("SEG mass" , params.getSEG()))
390 print(fmt % ("Peptide tol" , params.getTOL()))
391 print(fmt % ("Peptide tol units" , params.getTOLU()))
392 print(fmt % ("Fragment tol" , params.getITOL()))
393 print(fmt % ("Fragment tol units" , params.getITOLU()))
394 print(fmt % ("Missed cleavages" , params.getPFA()))
395 print(fmt % ("Database" , params.getDB()))
396 print(fmt % ("Static mods" , params.getMODS()))
397 print(fmt % ("Average/monoisotopic", params.getMASS()))
398 print(fmt % ("Enzyme" , params.getCLE()))
399 print(fmt % ("Raw data file name" , params.getFILENAME()))
400 print(fmt % ("Input data" , params.getQUE()))
401 print(fmt % ("Type of search" , params.getSEARCH()))
402 print(fmt % ("User name" , params.getUSERNAME()))
403 print(fmt % ("User email" , params.getUSEREMAIL()))
404 print(fmt % ("Charge state" , params.getCHARGE()))
405 print(fmt % ("Repeat search file" , params.getINTERMEDIATE()))
406 print(fmt % ("Num hits to display" , params.getREPORT()))
407 print(fmt % ("Show overview" , params.getOVERVIEW()))
408 print(fmt % ("Data file format" , params.getFORMAT()))
409 print(fmt % ("Form version" , params.getFORMVER()))
410 print(fmt % ("Variable mods" , params.getIT_MODS()))
411
412 for i in range(12) :
413 print(fmt % ( "User%02d" % i, params.getUSERField(i)))
414
415 print(fmt % ("Precursor mass" , params.getPRECURSOR()))
416 print(fmt % ("Taxonomy filter" , params.getTAXONOMY()))
417 print(fmt % ("Type of report" , params.getREPTYPE()))
418 print(fmt % ("Accessions to search", params.getACCESSION()))
419 print(fmt % ("Subcluster used" , params.getSUBCLUSTER()))
420 print(fmt % ("ICAT search?" , params.getICAT()))
421 print(fmt % ("Instrument type" , params.getINSTRUMENT()))
422 print(fmt % ("Error tolerant?" , params.getERRORTOLERANT()))
423 print(fmt % ("Rules (ions series)" , params.getRULES()))
424
425 for ch in range(ord('A'), 1 + ord('Z')) :
426 print(fmt % ("Residue " + chr(ch), params.getResidueMass(chr(ch))))
427
428 print(fmt % ("C terminus mass" , params.getCTermMass()))
429 print(fmt % ("N terminus mass" , params.getNTermMass()))
430 print(fmt % ("Mass of hydrogen", params.getHydrogenMass()))
431 print(fmt % ("Mass of oxygen" , params.getOxygenMass()))
432 print(fmt % ("Mass of carbon" , params.getCarbonMass()))
433 print(fmt % ("Mass of nitrogen", params.getNitrogenMass()))
434 print(fmt % ("Mass of electron", params.getElectronMass()))
435
436 i = 1
437 while params.getVarModsName(i) :
438 print(fmt % ("Variable mod name" , params.getVarModsName(i)))
439 print(fmt % ("Variable mod delta" , params.getVarModsDelta(i)))
440 print(fmt % ("Variable mod neutral", params.getVarModsNeutralLoss(i)))
441 i += 1
442
443 print(" ")
444
445
446def inputData(resfile) :
447 # display input data via inputquery get functions
448 for i in range(1, 2) :
449 # replace range with (1, 1 + resfile.getNumQueries()) to get all input
450 # data.
451
452 print("Input data for query number %d" % i)
453 print("=========================================")
454
455 q = msparser.ms_inputquery(resfile, i)
456 fmt = " %-16s: %s"
457
458 print(fmt % ("title" , q.getStringTitle(True)))
459 print(fmt % ("mass_min" , q.getMassMin()))
460 print(fmt % ("mass_max" , q.getMassMax()))
461 print(fmt % ("int_min" , q.getIntMin()))
462 print(fmt % ("int_max" , q.getIntMax()))
463 print(fmt % ("num_vals" , q.getNumVals()))
464 print(fmt % ("num_used1" , q.getNumUsed()))
465 print(fmt % ("ions1" , q.getStringIons1()))
466 print(fmt % ("ions2" , q.getStringIons2()))
467 print(fmt % ("ions3" , q.getStringIons3()))
468 print(fmt % ("peptol" , q.getPepTol()))
469 print(fmt % ("peptol units", q.getPepTolUnits()))
470 print(fmt % ("peptol str" , q.getPepTolString()))
471 print(fmt % ("repeat srch" , resfile.getRepeatSearchString(i)))
472
473 num_peaks = q.getNumberOfPeaks(1)
474 for j in range (1, 1+ num_peaks) :
475 print("%f, %f" % (q.getPeakMass(1, j), q.getPeakIntensity(1, j)))
476
477 print(" ")
478
479
480if __name__ == "__main__" :
481 sys.exit(main())
482
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: peptide_list.cpp

peptide_list.cpp

Show the list of peptides in a table - for use as a CGI application.

/*
##############################################################################
# file: peptide_list.cpp #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/peptide_list.cpp $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
/*
##############################################################################
# Print out a table of results - peptide based list for QA
# Table should contain a list of unique peptides - every significant match
# Copy the executable to the mascot/cgi directory, and then, when looking
# at a report replace the master_results.pl in the URL with peptide_list.exe
##############################################################################
*/
#include "msparser.hpp"
#include <set>
#include <iostream>
#include <time.h>
#include <iomanip>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
/*****************************************************************************/
/* main */
/* Call this program with a single argument - file=[name of the .dat file] */
/*****************************************************************************/
int main(int argc, char * argv[])
{
#ifdef _DEBUG
putenv("QUERY_STRING=file=../data/20021123/F018521.dat");
#endif
std::cout << "Content-type: text/html" << std::endl << std::endl;
std::cout << "<HTML>" << std::endl;
std::cout << "<HEAD>" << std::endl;
std::cout << " <TITLE>Mascot summary</TITLE>" << std::endl;
std::cout << "</HEAD>" << std::endl;
std::cout << "<BODY BGCOLOR=\"#ffffff\">" << std::endl;;
if (getenv("QUERY_STRING") && strncmp(getenv("QUERY_STRING"), "file=", 5) == 0)
{
ms_mascotresfilebase file = ms_mascotresfilebase::createResfile(getenv("QUERY_STRING")+strlen("file="));
if (file.isValid())
{
if (file.isMSMS())
{
ms_mascotresults * results;
results = new ms_peptidesummary(file,
ms_mascotresults::MSRES_GROUP_PROTEINS |
ms_mascotresults::MSRES_SHOW_SUBSETS,
0, // minProbability
1000, // number of hits
0, // ignoreIonsScoreBelow
0); // minimum peptide length
ms_protein * prot = results->getHit(1);
if (!prot)
std::cout << "No significant matches" << std::endl;
else
{
std::set<std::string> pep_strings;
std::cout << "<TABLE BORDER=1>" << std::endl;
std::cout << " <TR>" << std::endl;
std::cout << " <TD><B>Peptide</B></TD>" << std::endl
<< " <TD><B>Score</B></TD>" << std::endl
<< " <TD><B>Query</B></TD>" << std::endl
<< " <TD><B>Rank</B></TD>" << std::endl
<< " <TD><B>Proteins</B></TD>" << std::endl;
std::cout << " </TR>" << std::endl;
for (int query=1; query <= file.getNumQueries(); query++)
{
for (int p=1; p <= 10; p++)
{
double threshold = results->getPeptideIdentityThreshold(query, 20);
ms_peptide * pep;
if ( results->getPeptide(query, p, pep)
&& (pep->getIonsScore() >= threshold))
{
if (pep_strings.insert(pep->getPeptideStr()).second)
{
std::cout << " <TR>" << std::endl;
std::cout << " <TD>"
<< pep->getPeptideStr().c_str()
<< " </TD>"
<< std::endl;
std::cout << " <TD>"
<< pep->getIonsScore()
<< " </TD>"
<< std::endl;
std::cout << " <TD>" << query << " </TD>" << std::endl;
std::cout << " <TD>" << p << " </TD>" << std::endl;
std::cout << " <TD>"
<< results->getProteinsWithThisPepMatch(query, p).c_str()
<< " </TD>"
<< std::endl;
std::cout << " </TR>" << std::endl;
}
}
}
}
std::cout << "</TABLE>" << std::endl;
}
if (file.getLastError())
{
std::cout << "There was an error..." << std::endl;
std::cout << "Error: " << file.getLastErrorString() << std::endl;
}
}
}
else
std::cout << "Error: " << file.getLastErrorString() << std::endl;
}
else
std::cout << "Must supply 'file=[name of a .dat file]'"
<< "Number of args = " << argc
<< "QS=" << getenv("QUERY_STRING")
<<std::endl;
std::cout << "</BODY>" << std::endl;;
std::cout << "</HTML>" << std::endl;;
return 0;
}
/* Will give for example the following output:
<TABLE BORDER=1>
<TR>
<TD><B>Peptide</B></TD>
<TD><B>Score</B></TD>
<TD><B>Query</B></TD>
<TD><B>Rank</B></TD>
<TD><B>Proteins</B></TD>
</TR>
<TR>
<TD>GPSSVEDIK </TD>
<TD>68.06 </TD>
<TD>17 </TD>
<TD>1 </TD>
<TD>9:Q96AT6 </TD>
</TR>
<TR>
<TD>SGEVLVNVK </TD>
<TD>79.37 </TD>
<TD>18 </TD>
<TD>1 </TD>
<TD>13:S60335 15:Q9QZD9 </TD>
</TR>
<TR>
<TD>MSDGLFLQK </TD>
<TD>54.93 </TD>
<TD>29 </TD>
<TD>1 </TD>
<TD>16:S55282 </TD>
</TR>
<TR>
<TD>LGGSQEDQIK </TD>
<TD>67.93 </TD>
<TD>31 </TD>
<TD>1 </TD>
<TD>2:AAH10103 </TD>
</TR>
<TR>
<TD>AGLGHPAAFGR </TD>
<TD>57.48 </TD>
<TD>34 </TD>
<TD>1 </TD>
<TD>19:DDH1_HUMAN </TD>
</TR>
<TR>
<TD>TPEEYPESAK </TD>
<TD>54.88 </TD>
<TD>37 </TD>
<TD>1 </TD>
<TD>19:DDH1_HUMAN </TD>
</TR>
<TR>
<TD>SSGTSYPDVLK </TD>
<TD>63.42 </TD>
<TD>38 </TD>
<TD>1 </TD>
<TD>4:TRBOTR 6:1NTP </TD>
</TR>
<TR>
<TD>VCNYVSWIK </TD>
<TD>55.78 </TD>
<TD>41 </TD>
<TD>1 </TD>
<TD>4:TRBOTR 6:1NTP </TD>
</TR>
<TR>
<TD>IDTIEIITDR </TD>
<TD>69.04 </TD>
<TD>43 </TD>
<TD>1 </TD>
<TD>8:AAC26867 11:Q9TTV2 </TD>
</TR>
<TR>
<TD>DITSDTSGDFR </TD>
<TD>69.53 </TD>
<TD>45 </TD>
<TD>1 </TD>
<TD>1:LUHU 3:AAB19866 7:ANX1_MOUSE </TD>
</TR>
<TR>
<TD>LLGELLQDNAK </TD>
<TD>64.14 </TD>
<TD>46 </TD>
<TD>1 </TD>
<TD>2:AAH10103 </TD>
</TR>
<TR>
<TD>VGMIPVPYVEK </TD>
<TD>54.23 </TD>
<TD>52 </TD>
<TD>1 </TD>
<TD>18:S41754 </TD>
</TR>
<TR>
<TD>TPAQFDADELR </TD>
<TD>66.27 </TD>
<TD>53 </TD>
<TD>1 </TD>
<TD>1:LUHU 3:AAB19866 5:AAC78495 7:ANX1_MOUSE 27:CAA64477 </TD>
</TR>
<TR>
<TD>LSSTWEGIQAGK </TD>
<TD>77.53 </TD>
<TD>54 </TD>
<TD>1 </TD>
<TD>2:AAH10103 </TD>
</TR>
<TR>
<TD>SLDLDSIIAEVK </TD>
<TD>80.49 </TD>
<TD>56 </TD>
<TD>1 </TD>
<TD>17:AAG41947 </TD>
</TR>
<TR>
<TD>AVLENNLGAAVLR </TD>
<TD>57.63 </TD>
<TD>63 </TD>
<TD>1 </TD>
<TD>36:Q9BS89 </TD>
</TR>
<TR>
<TD>ALEESNYELEGK </TD>
<TD>59.06 </TD>
<TD>67 </TD>
<TD>1 </TD>
<TD>22:KRMSE1 </TD>
</TR>
<TR>
<TD>VLGTEELYGYLK </TD>
<TD>65.31 </TD>
<TD>68 </TD>
<TD>1 </TD>
<TD>14:B35838 </TD>
</TR>
<TR>
<TD>VLGTDELYGYLK </TD>
<TD>65.31 </TD>
<TD>68 </TD>
<TD>2 </TD>
<TD>12:B38611 </TD>
</TR>
<TR>
<TD>GVDEATIIDILTK </TD>
<TD>73.44 </TD>
<TD>69 </TD>
<TD>1 </TD>
<TD>1:LUHU 3:AAB19866 5:AAC78495 7:ANX1_MOUSE 20:LUGP1 </TD>
</TR>
<TR>
<TD>QSLEASLAETEGR </TD>
<TD>60.48 </TD>
<TD>70 </TD>
<TD>1 </TD>
<TD>22:KRMSE1 </TD>
</TR>
<TR>
<TD>TPYTDVNIVTIR </TD>
<TD>73.23 </TD>
<TD>71 </TD>
<TD>1 </TD>
<TD>16:S55282 </TD>
</TR>
<TR>
<TD>ALAGCDFLTISPK </TD>
<TD>58.07 </TD>
<TD>72 </TD>
<TD>1 </TD>
<TD>2:AAH10103 </TD>
</TR>
<TR>
<TD>WELLQQVDTSTR </TD>
<TD>64.49 </TD>
<TD>80 </TD>
<TD>1 </TD>
<TD>17:AAG41947 </TD>
</TR>
<TR>
<TD>EVYQQQQYGSGGR </TD>
<TD>66.95 </TD>
<TD>83 </TD>
<TD>1 </TD>
<TD>10:Q9BQ99 </TD>
</TR>
<TR>
<TD>IFVGGLNPEATEEK </TD>
<TD>62.15 </TD>
<TD>84 </TD>
<TD>1 </TD>
<TD>10:Q9BQ99 </TD>
</TR>
<TR>
<TD>IFVGGINPEATEEK </TD>
<TD>62.15 </TD>
<TD>84 </TD>
<TD>2 </TD>
<TD>23:PC4375 </TD>
</TR>
<TR>
<TD>QLYQILTDFDIR </TD>
<TD>63.62 </TD>
<TD>87 </TD>
<TD>1 </TD>
<TD>12:B38611 14:B35838 </TD>
</TR>
<TR>
<TD>GTDVNVFNTILTTR </TD>
<TD>71.62 </TD>
<TD>93 </TD>
<TD>1 </TD>
<TD>1:LUHU 3:AAB19866 </TD>
</TR>
<TR>
<TD>SDSEKLNLDSIIGR </TD>
<TD>58.2 </TD>
<TD>96 </TD>
<TD>1 </TD>
<TD>39:Q9Z1G2 </TD>
</TR>
<TR>
<TD>DSCQGDSGGPVVCSGK </TD>
<TD>71.13 </TD>
<TD>97 </TD>
<TD>1 </TD>
<TD>4:TRBOTR 6:1NTP </TD>
</TR>
<TR>
<TD>DLAKDITSDTSGDFR </TD>
<TD>57.65 </TD>
<TD>99 </TD>
<TD>1 </TD>
<TD>1:LUHU 3:AAB19866 7:ANX1_MOUSE </TD>
</TR>
<TR>
<TD>GLGTDEDTLIEILASR </TD>
<TD>87.32 </TD>
<TD>103 </TD>
<TD>1 </TD>
<TD>1:LUHU 5:AAC78495 </TD>
</TR>
<TR>
<TD>GAGTEEACLIDILASR </TD>
<TD>54.48 </TD>
<TD>103 </TD>
<TD>2 </TD>
<TD>33:O93444 </TD>
</TR>
<TR>
<TD>SEDFGVNEDLADSDAR </TD>
<TD>103.46 </TD>
<TD>105 </TD>
<TD>1 </TD>
<TD>1:LUHU </TD>
</TR>
<TR>
<TD>LISWYDNEFGYSNR </TD>
<TD>58.42 </TD>
<TD>107 </TD>
<TD>1 </TD>
<TD>28:DEHUG3 30:AAC16069 </TD>
</TR>
<TR>
<TD>LVTWYDNEFGYSNR </TD>
<TD>57.61 </TD>
<TD>107 </TD>
<TD>2 </TD>
<TD>37:Q90Z48 </TD>
</TR>
<TR>
<TD>TPALVFEYINNTDFK </TD>
<TD>69.27 </TD>
<TD>108 </TD>
<TD>1 </TD>
<TD>12:B38611 14:B35838 </TD>
</TR>
<TR>
<TD>IFVGGLNPEATEEKIR </TD>
<TD>54.63 </TD>
<TD>109 </TD>
<TD>1 </TD>
<TD>10:Q9BQ99 </TD>
</TR>
<TR>
<TD>IFVGGINPEATEEKIR </TD>
<TD>54.63 </TD>
<TD>109 </TD>
<TD>2 </TD>
<TD>23:PC4375 </TD>
</TR>
<TR>
<TD>VGAVAGNDWLIWDITR </TD>
<TD>63.06 </TD>
<TD>113 </TD>
<TD>1 </TD>
<TD>35:Q9H644 </TD>
</TR>
<TR>
<TD>VGAVAGNDWIIWDITR </TD>
<TD>63.06 </TD>
<TD>113 </TD>
<TD>2 </TD>
<TD>32:Q9CWU9 </TD>
</TR>
<TR>
<TD>LFIGGLSFETTDESLR </TD>
<TD>61.89 </TD>
<TD>117 </TD>
<TD>1 </TD>
<TD>25:1HA11 </TD>
</TR>
<TR>
<TD>LFIGGLSFETTEESLR </TD>
<TD>61.89 </TD>
<TD>117 </TD>
<TD>2 </TD>
<TD>8:AAC26867 21:S40776 </TD>
</TR>
<TR>
<TD>LFIGGLSFETTDDSLR </TD>
<TD>61.89 </TD>
<TD>117 </TD>
<TD>3 </TD>
<TD>26:Q9CRI0 </TD>
</TR>
<TR>
<TD>MTDQEAIQDLWQWR </TD>
<TD>58.31 </TD>
<TD>118 </TD>
<TD>1 </TD>
<TD>9:Q96AT6 </TD>
</TR>
<TR>
<TD>GFSEGLWEIENNPTVK </TD>
<TD>54.12 </TD>
<TD>119 </TD>
<TD>1 </TD>
<TD>24:Q9XSK7 </TD>
</TR>
<TR>
<TD>QAWFIENEEQEYVQTVK </TD>
<TD>71.47 </TD>
<TD>132 </TD>
<TD>1 </TD>
<TD>1:LUHU </TD>
</TR>
<TR>
<TD>LGEDNINVVEGNEQFISASK </TD>
<TD>83.36 </TD>
<TD>134 </TD>
<TD>1 </TD>
<TD>4:TRBOTR 6:1NTP </TD>
</TR>
<TR>
<TD>MSVQPTVSLGGFEITPPVVLR </TD>
<TD>81.19 </TD>
<TD>140 </TD>
<TD>1 </TD>
<TD>9:Q96AT6 </TD>
</TR>
<TR>
<TD>GGPGSAVSPYPTFNPSSDVAALHK </TD>
<TD>64.58 </TD>
<TD>149 </TD>
<TD>1 </TD>
<TD>1:LUHU </TD>
</TR>
</TABLE>
*/
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresfilebase::getLastErrorString
std::string getLastErrorString() const
Return the last error number - or an empty string.
Definition: ms_mascotresfilebase.cpp:824
matrix_science::ms_mascotresfilebase::getLastError
int getLastError() const
Return the last error number - or ms_erros::ERR_NO_ERROR.
Definition: ms_mascotresfilebase.cpp:786
matrix_science::ms_mascotresfilebase::isMSMS
virtual bool isMSMS() const =0
Returns true if the search was an MSMS search (SEARCH=MIS).
matrix_science::ms_mascotresfilebase::getNumQueries
virtual int getNumQueries(const int resfileID=0) const =0
Returns the number of queries (peptide masses or ms-ms spectra).
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_mascotresults::getPeptideIdentityThreshold
virtual int getPeptideIdentityThreshold(const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the threshold value for this ms-ms data being a random match.
Definition: ms_mascotresults.cpp:605
matrix_science::ms_mascotresults::getPeptide
virtual ms_peptide getPeptide(const int q, const int p) const =0
Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_p...
matrix_science::ms_mascotresults::getHit
virtual ms_protein * getHit(const int hit, const int memberNumber=0) const
Return the ms_protein hit - returns null if hit > number of hits.
Definition: ms_mascotresults.cpp:1030
matrix_science::ms_mascotresults::getProteinsWithThisPepMatch
virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false)=0
Return a partial list of proteins that matched the same peptide.
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::getIonsScore
double getIonsScore() const
Returns the ions score.
Definition: ms_peptide.cpp:1050
matrix_science::ms_peptide::getPeptideStr
std::string getPeptideStr(bool substituteAmbiguous=true, const PSM psmComponent=PSM_COMPLETE) const
Returns the sequence found for the peptide.
Definition: ms_peptide.cpp:710
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_enzymes.cpp

config_enzymes.cpp

Read in the enzymes file.

/*
##############################################################################
# file: config_enzymes.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/config_enzymes.cpp $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
int main(int argc, char * argv[])
{
if ( argc < 2 )
{
std::cout << "The location of enzymes file has to be specified as a parameter" << std::endl;
std::cout << "The location should either be the full path to the enzymes file" << std::endl;
std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
return 1;
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_connection_settings cs;
if (argc > 2)
{
cs.setSessionID(argv[2]);
}
ms_enzymefile file(argv[1], &cs);
if (!file.isValid())
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << file.getLastErrorString() << std::endl;
return 1;
}
// how many do we have in total?
int n = file.getNumberOfEnzymes();
std::cout << "There are " << n << " enzymes definitions available" << std::endl;
// now get them all!
int i;
for(i=0; i < n ; i++)
{
const ms_enzyme * enzyme = file.getEnzymeByNumber(i);
std::cout << enzyme->getTitle() << ": ";
for (int c=0; c < enzyme->getNumberOfCutters(); c++) {
if (enzyme->getCutterType(c) == matrix_science::ms_enzyme::NTERM_CUTTER) {
std::cout << "nTerm - ";
} else {
std::cout << "cTerm - ";
}
std::cout << enzyme->getCleave(c) << "!" << enzyme->getRestrict(c);
std::cout << "; ";
}
std::cout << std::endl;
}
// Now try updating the first one in the list to semi-specific
ms_enzyme enzyme = *file.getEnzymeByNumber(0);
enzyme.setSemiSpecific(true);
file.updateEnzymeByNumber(0, enzyme);
// And delete V8-DE
if (file.deleteEnzymeByName("V8-DE")) {
std::cout << "Deleted the enzyme V8-DE " << std::endl;
}
//Finally, save the file under a new name - but only if not http:
if (strncmp("http:", argv[1], 5) != 0) {
std::string filename = argv[1];
filename += ".new";
file.setFileName(filename.c_str());
file.save_file();
}
std::cout << "There are now " << file.getNumberOfEnzymes() << " enzymes definitions available" << std::endl;
return 0;
}
/*
will give the output:
# test.exe ../config/enzymes
There are 19 enzymes definitions available
Trypsin: cTerm - KR!P;
Arg-C: cTerm - R!P;
Asp-N: nTerm - BD!;
Asp-N_ambic: nTerm - DE!;
Chymotrypsin: cTerm - FLWY!P;
CNBr: cTerm - M!;
CNBr+Trypsin: cTerm - M!; cTerm - KR!P;
Formic_acid: cTerm - D!;
Lys-C: cTerm - K!P;
Lys-C/P: cTerm - K!;
PepsinA: cTerm - FL!;
Tryp-CNBr: cTerm - KMR!P;
TrypChymo: cTerm - FKLRWY!P;
Trypsin/P: cTerm - KR!;
V8-DE: cTerm - BDEZ!P;
V8-E: cTerm - EZ!P;
semiTrypsin: cTerm - KR!P;
LysC+AspN: nTerm - BD!; cTerm - K!P;
None: cTerm - KR!P;
There are now 18 enzymes definitions available
*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_connection_settings::setSessionID
void setSessionID(const std::string sessionID)
Sets the Mascot security sessionID to be used for the connection.
Definition: ms_connection_settings.cpp:242
matrix_science::ms_enzyme
Represent a single entry in the enzymes file.
Definition: ms_enzyme.hpp:67
matrix_science::ms_enzyme::getNumberOfCutters
int getNumberOfCutters() const
Returns the number of cutters.
Definition: ms_enzyme.cpp:454
matrix_science::ms_enzyme::getCleave
std::string getCleave(const int cutterNum) const
Returns the list of cleavage points for a cutter.
Definition: ms_enzyme.cpp:593
matrix_science::ms_enzyme::getRestrict
std::string getRestrict(const int cutterNum) const
Returns the list of restriction points for a cutter.
Definition: ms_enzyme.cpp:632
matrix_science::ms_enzyme::getCutterType
ms_enzyme::cuttertype getCutterType(const int cutterNum) const
Return the number of cutters that make up the enzyme definition.
Definition: ms_enzyme.cpp:573
matrix_science::ms_enzyme::NTERM_CUTTER
@ NTERM_CUTTER
N Terminus cutter - cuts before the specified residue(s).
Definition: ms_enzyme.hpp:78
matrix_science::ms_enzyme::getTitle
std::string getTitle() const
Returns a name of the enzyme as appears in the file.
Definition: ms_enzyme.cpp:318
matrix_science::ms_enzyme::setSemiSpecific
void setSemiSpecific(const bool value)
Sets a new value for the semi specific flag.
Definition: ms_enzyme.cpp:380
matrix_science::ms_enzymefile
Reads and parses the enzymes file that contains multiple enzyme definitions.
Definition: ms_enzyme.hpp:194
matrix_science::ms_enzymefile::save_file
void save_file()
Stores enzyme definitions in a file.
Definition: ms_enzyme.cpp:1442
matrix_science::ms_enzymefile::getNumberOfEnzymes
int getNumberOfEnzymes() const
Returns a number of enzymes successfully read from the file.
Definition: ms_enzyme.cpp:910
matrix_science::ms_enzymefile::updateEnzymeByNumber
bool updateEnzymeByNumber(const int num, const ms_enzyme enzyme)
Update the information for a specific enzyme.
Definition: ms_enzyme.cpp:936
matrix_science::ms_enzymefile::setFileName
void setFileName(const char *filename)
Call this member before reading the file if you want to specify a non-default name.
Definition: ms_enzyme.cpp:868
matrix_science::ms_enzymefile::getEnzymeByNumber
const ms_enzyme * getEnzymeByNumber(const int num) const
Returns a pointer to an internally stored enzyme.
Definition: ms_enzyme.cpp:921
matrix_science::ms_enzymefile::deleteEnzymeByName
bool deleteEnzymeByName(const char *name)
Remove an enzyme from the list in memory.
Definition: ms_enzyme.cpp:1016
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_enzymes.pl

config_enzymes.pl

Read in the enzymes file.

#!/usr/local/bin/perl
##############################################################################
# file: config_enzymes.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/config_enzymes.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) {
print <<EOF;
The location of 'enzymes' file has to be specified as a parameter.
The location should either be the full path to the 'enzymes' file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
exit 1;
}
# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);
# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
$cs = new msparser::ms_connection_settings;
$cs->setSessionID($ARGV[1]);
$file = new msparser::ms_enzymefile($ARGV[0], $cs);
} else {
$file = new msparser::ms_enzymefile($ARGV[0]);
}
if (!$file->isValid) {
print "There are errors. Cannot continue. The last error description:\n";
print $file->getLastErrorString(), "\n";
exit 1;
}
my $n = $file->getNumberOfEnzymes();
print "There are ", $n, " enzyme definitions available\n";
for my $i (0 .. $n-1) {
my $enzyme = $file->getEnzymeByNumber($i);
print $enzyme->getTitle(), ": ";
for my $c (0 .. $enzyme->getNumberOfCutters - 1) {
if ($enzyme->getCutterType($c) == $msparser::ms_enzyme::NTERM_CUTTER) {
print "nTerm - ";
} else {
print "cTerm - ";
}
print $enzyme->getCleave($c), "!", $enzyme->getRestrict($c);
print "; ";
}
print "\n";
}
# Now try updating the first one in the list to semi-specific.
my $enzyme = $file->getEnzymeByNumber(0);
$enzyme->setSemiSpecific(1);
$file->updateEnzymeByNumber(0, $enzyme);
# And delete V8-DE.
$file->deleteEnzymeByName("V8-DE");
# Finally, save the file under a new name.
$file->setFileName($ARGV[0] . ".new");
$file->save_file;
if (!$file->isValid) {
print "Failed to save: ", $file->getLastErrorString, "\n";
} else {
print $ARGV[0], ".new now has ", $file->getNumberOfEnzymes, " enzyme definitions available\n";
}
=pod
Running the program as
perl -I../bin config_enzymes.pl ../config/enzymes
will give the following output under Mascot Server 2.3:
There are 21 enzyme definitions available
Trypsin: cTerm - KR!P;
Trypsin/P: cTerm - KR!;
Arg-C: cTerm - R!P;
Asp-N: nTerm - BD!;
Asp-N_ambic: nTerm - DE!;
Chymotrypsin: cTerm - FLWY!P;
CNBr: cTerm - M!;
CNBr+Trypsin: cTerm - M!; cTerm - KR!P;
Formic_acid: nTerm - D!; cTerm - D!;
Lys-C: cTerm - K!P;
Lys-C/P: cTerm - K!;
LysC+AspN: nTerm - BD!; cTerm - K!P;
Lys-N: nTerm - K!;
PepsinA: cTerm - FL!;
semiTrypsin: cTerm - KR!P;
TrypChymo: cTerm - FKLRWY!P;
TrypsinMSIPI: nTerm - J!; cTerm - KR!P; cTerm - J!;
TrypsinMSIPI/P: nTerm - J!; cTerm - JKR!;
V8-DE: cTerm - BDEZ!P;
V8-E: cTerm - EZ!P;
None: cTerm - KR!P;
../config/enzymes.new now has 20 enzyme definitions available
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_enzymes.java

config_enzymes.java

Read in the enzymes file.

/*
##############################################################################
# file: config_quantitation.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchi $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2022-07-21 11:07:25 +0100 $ #
# $Revision: 11e243bdaeaabd63950eb86ad86ce3acc1116e78 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class config_enzymes {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// ----- Object creation -----
if(argv.length < 1) {
System.out.println("The location of enzymes file has to be specified as a parameter");
System.out.println("The location should either be the full path to the enzymes file");
System.out.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
System.exit(0);
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_enzymefile file;
if (argv.length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setSessionID(argv[1]);
file = new ms_enzymefile(argv[0], cs);
}
else
{
file = new ms_enzymefile(argv[0]);
}
if (!file.isValid())
{
System.out.println("Error number: "+file.getLastError());
System.out.println("Error string: "+file.getLastErrorString());
System.exit(0);
}
// how many do we have in total?
int n = file.getNumberOfEnzymes();
System.out.println("There are " + n + " enzymes definitions available");
//now get them all!
for (int i=0; i < n ; i++)
{
ms_enzyme enzyme = file.getEnzymeByNumber(i);
System.out.print(enzyme.getTitle() + ": ");
for (int c=0; c < enzyme.getNumberOfCutters(); c++)
{
if (enzyme.getCutterType(c) == ms_enzyme.NTERM_CUTTER)
{
System.out.print("nTerm - ");
}
else
{
System.out.print("cTerm - ");
}
System.out.print(enzyme.getCleave(c) + "!");
System.out.print(enzyme.getRestrict(c));
System.out.print("; ");
}
System.out.println("");
}
// Now try updating the first one in the list to semi-specific
ms_enzyme enzyme = file.getEnzymeByNumber(0);
enzyme.setSemiSpecific(true);
file.updateEnzymeByNumber(0, enzyme);
// And delete V8-DE
file.deleteEnzymeByName("V8-DE");
// Finally, save the file under a new name
file.setFileName(argv[0] + ".new");
file.save_file();
System.out.println("There are now " + file.getNumberOfEnzymes() + " enzymes definitions available");
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar config_enzymes enzymes
There are 19 enzymes definitions available
Trypsin: cTerm - KR!P;
Arg-C: cTerm - R!P;
Asp-N: nTerm - BD!;
Asp-N_ambic: nTerm - DE!;
Chymotrypsin: cTerm - FLWY!P;
CNBr: cTerm - M!;
CNBr+Trypsin: cTerm - M!; cTerm - KR!P;
Formic_acid: cTerm - D!;
Lys-C: cTerm - K!P;
Lys-C/P: cTerm - K!;
PepsinA: cTerm - FL!;
Tryp-CNBr: cTerm - KMR!P;
TrypChymo: cTerm - FKLRWY!P;
Trypsin/P: cTerm - KR!;
V8-DE: cTerm - BDEZ!P;
V8-E: cTerm - EZ!P;
semiTrypsin: cTerm - KR!P;
LysC+AspN: nTerm - BD!; cTerm - K!P;
None: cTerm - KR!P;
There are now 18 enzymes definitions available
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_enzymes.py

config_enzymes.py

Read in the enzymes file.

1#!/usr/bin/python
2
16
17import msparser
18import sys
19
20if len(sys.argv) < 2 :
21 print("""
22The location of enzymes file has to be specified as a parameter.
23The location should either be the full path to the enzymes file
24or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
25""")
26 sys.exit(1)
27
28# A sessionID can optionally be passed as the second parameter.
29# This will only be required if the 'file' is a URL.
30if len(sys.argv) > 2 :
31 cs = msparser.ms_connection_settings()
32 cs.setSessionID(sys.argv[2])
33 file = msparser.ms_enzymefile(sys.argv[1], cs)
34else :
35 file = msparser.ms_enzymefile(sys.argv[1])
36
37if not file.isValid() :
38 print("There are errors. Cannot continue. The last error description:")
39 print(file.getLastErrorString())
40 sys.exit(1)
41
42
43n = file.getNumberOfEnzymes()
44print("There are " + str(n) + " enzyme definitions available")
45
46for i in range(n) :
47 enzyme = file.getEnzymeByNumber(i)
48 defs = []
49
50 for c in range(enzyme.getNumberOfCutters()) :
51 if enzyme.getCutterType(c) == msparser.ms_enzyme.NTERM_CUTTER :
52 term = "nTerm"
53 else :
54 term = "cTerm"
55
56 defs.append("%s - %s!%s" % (term, enzyme.getCleave(c), enzyme.getRestrict(c)))
57
58 print("%s: %s" % (enzyme.getTitle(), "; ".join(defs)))
59
60
61# Now try updating the first one in the list to semi-specific.
62enzyme = file.getEnzymeByNumber(0)
63enzyme.setSemiSpecific(True)
64file.updateEnzymeByNumber(0, enzyme)
65
66# And delete V8-DE.
67file.deleteEnzymeByName("V8-DE")
68
69# Finally, save the file under a new name.
70file.setFileName(sys.argv[1] + ".new")
71file.save_file()
72
73if not file.isValid() :
74 print("Failed to save: %s" % file.getLastErrorString())
75else :
76 print("%s.new now has %d enzyme definitions available" % (sys.argv[1], file.getNumberOfEnzymes()))
77
78
79""" Running the program as
80
81python config_enzymes.pl /usr/local/mascot/config/enzymes
82
83will give the following output under Mascot Server 2.3
84
85
86There are 21 enzyme definitions available
87Trypsin: cTerm - KR!P
88Trypsin/P: cTerm - KR!
89Arg-C: cTerm - R!P
90Asp-N: nTerm - BD!
91Asp-N_ambic: nTerm - DE!
92Chymotrypsin: cTerm - FLWY!P
93CNBr: cTerm - M!
94CNBr+Trypsin: cTerm - M!; cTerm - KR!P
95Formic_acid: nTerm - D!; cTerm - D!
96Lys-C: cTerm - K!P
97Lys-C/P: cTerm - K!
98LysC+AspN: nTerm - BD!; cTerm - K!P
99Lys-N: nTerm - K!
100PepsinA: cTerm - FL!
101semiTrypsin: cTerm - KR!P
102TrypChymo: cTerm - FKLRWY!P
103TrypsinMSIPI: nTerm - J!; cTerm - KR!P; cTerm - J!
104TrypsinMSIPI/P: nTerm - J!; cTerm - JKR!
105V8-DE: cTerm - BDEZ!P
106V8-E: cTerm - EZ!P
107None: cTerm - KR!P
108/usr/local/mascot/config/enzymes.new now has 20 enzyme definitions available
109
110
111"""
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_enzymes.cs

config_enzymes.cs

Read in the enzymes file.

/*
##############################################################################
# file: config_enzymes.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/config_enzymes.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.IO;
using matrix_science.msparser;
namespace MsParserExamples
{
public class config_enzymes
{
public static void Main(string[] argv)
{
// ----- Object creation -----
if (argv.Length < 1)
{
using (TextWriter errorWriter = Console.Error)
{
errorWriter.WriteLine(@"The location of the enzymes file has to be specified as a parameter
The location should either be the full path to the enzymes file
or a URL to a Mascot server - e.g. http://mascot-searver/mascot/cgi
A Mascot security sessionID can optionally be passed as a second
parameter");
return;
}
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_enzymefile file;
if (argv.Length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
cs.setSessionID(argv[1]);
file = new ms_enzymefile(argv[0], cs);
}
else file = new ms_enzymefile(argv[0]);
if (!file.isValid())
{
using (TextWriter errorWriter = Console.Error)
{
errorWriter.WriteLine("Error number: {0}", file.getLastError());
errorWriter.WriteLine("Error string: {0}", file.getLastErrorString());
}
return;
}
// how many enzymes do we have in total?
int n = file.getNumberOfEnzymes();
Console.WriteLine("There are {0} enzymes definitions available", n);
// now get them all!
for (int i = 0; i < n; i++)
{
ms_enzyme _enzyme = file.getEnzymeByNumber(i);
Console.Write("{0}: ", _enzyme.getTitle());
for (int c = 0; c < _enzyme.getNumberOfCutters(); c++)
{
if (_enzyme.getCutterType(c) == ms_enzyme.cuttertype.NTERM_CUTTER)
{
Console.Write("nTerm - ");
}
else
{
Console.Write("cTerm - ");
}
Console.Write("{0}!{1}; ", _enzyme.getCleave(c), _enzyme.getRestrict(c));
}
Console.WriteLine();
_enzyme = null;
}
// Now try updating the first one in the list to semi-specific
ms_enzyme enzyme = file.getEnzymeByNumber(0);
enzyme.setSemiSpecific(true);
file.updateEnzymeByNumber(0, enzyme);
// And delete V8-DE
file.deleteEnzymeByName("V8-DE");
// Finally, save the file under a new name
if (argv[0].ToLower().StartsWith("http"))
{
file.setFileName("copy_enzymes.new");
}
else
{
//create a new file locally
file.setFileName(argv[0] + ".new");
}
file.save_file();
Console.WriteLine("Updated enzymes file saved to {0}", Path.GetFullPath(file.getFileName()));
Console.WriteLine("There are now {0} enzymes definitions available", file.getNumberOfEnzymes());
}
}
}
/*
* Running the program as
*
* config_enzymes.exe c:\inetpub\mascot\config\enzymes
*
* will give the following output under Mascot Server 2.5
*
* There are 22 enzymes definitions available
* Trypsin: cTerm - KR!P;
* Trypsin/P: cTerm - KR!;
* Arg-C: cTerm - R!P;
* Asp-N: nTerm - BD!;
* Asp-N_ambic: nTerm - DE!;
* Chymotrypsin: cTerm - FLWY!P;
* CNBr: cTerm - M!;
* CNBr+Trypsin: cTerm - M!; cTerm - KR!P;
* Formic_acid: nTerm - D!; cTerm - D!;
* Lys-C: cTerm - K!P;
* Lys-C/P: cTerm - K!;
* LysC+AspN: nTerm - BD!; cTerm - K!P;
* Lys-N: nTerm - K!;
* PepsinA: cTerm - FL!;
* semiTrypsin: cTerm - KR!P;
* TrypChymo: cTerm - FKLRWY!P;
* TrypsinMSIPI: nTerm - J!; cTerm - KR!P; cTerm - J!;
* TrypsinMSIPI/P: nTerm - J!; cTerm - JKR!;
* V8-DE: cTerm - BDEZ!P;
* V8-E: cTerm - EZ!P;
* NoCleave: cTerm - J!ABCDEFGHIJKLMNOPQRSTUVWXYZ;
* None: cTerm - KR!P;
* Updated enzymes file saved to c:\inetpub\mascot\config\enzymes.new
* There are now 21 enzymes definitions available
*
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_fragrules.cpp

config_fragrules.cpp

Read in the fragmentation_rules file.

/*
##############################################################################
# file: config_fragrules.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/config_fragrules.cpp $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
int main(int argc, char * argv[])
{
if ( argc < 2 )
{
std::cout << "The location of fragmentation_rules file has to be specified as a parameter" << std::endl;
std::cout << "The location should either be the full path to the fragmentation_rules file" << std::endl;
std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
return 1;
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_connection_settings cs;
if (argc > 2)
{
cs.setSessionID(argv[2]);
}
ms_fragrulesfile file(argv[1], &cs);
if ( !file.isValid() )
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << file.getLastErrorString() << std::endl;
return 1;
}
int n = file.getNumberOfInstruments();
std::cout << n << " instruments are configured:" << std::endl;
int i;
for(i=0; i < n; i++)
{
std::cout << file.getInstrumentName(i) << std::endl;
}
// Now change ESI-QUAD-TOF
ms_fragmentationrules instrument = *file.getInstrumentByName("ESI-QUAD-TOF");
instrument.setSeriesUsed(23, true); // Add v series
file.updateInstrumentByName("ESI-QUAD-TOF", instrument);
// And delete MALDI-QIT-TOF
file.deleteInstrumentByName("MALDI-QIT-TOF");
//Finally, save the file under a new name - but only if not http:
if (strncmp("http:", argv[1], 5) != 0) {
std::string filename = argv[1];
filename += ".new";
file.setFileName(filename.c_str());
file.save_file();
}
std::cout << "There are now " << file.getNumberOfInstruments() << " instruments configured." << std::endl;
return 0;
}
/*
will give the output:
# config_fragrules.exe ../config/fragmentation_rules
11 instruments are configured:
Default
ESI-QUAD-TOF
MALDI-TOF-PSD
ESI-TRAP
ESI-QUAD
ESI-FTICR
MALDI-TOF-TOF
ESI-4SECTOR
FTMS-ECD
MALDI-QUAD-TOF
LCQ
There are now 10 instruments configured.
*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_connection_settings::setSessionID
void setSessionID(const std::string sessionID)
Sets the Mascot security sessionID to be used for the connection.
Definition: ms_connection_settings.cpp:242
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_fragmentationrules
This class encapsulates a single entry (an instrument) from a fragmentation_rules file.
Definition: ms_fragmentationrules.hpp:56
matrix_science::ms_fragmentationrules::setSeriesUsed
void setSeriesUsed(const int series, const bool val)
Sets availability on a given series.
Definition: ms_fragmentationrules.cpp:343
matrix_science::ms_fragrulesfile
This class encapsulates a complete fragmentation_rules file.
Definition: ms_fragmentationrules.hpp:209
matrix_science::ms_fragrulesfile::getInstrumentByName
const ms_fragmentationrules * getInstrumentByName(const char *name) const
Returns a configuration for an instrument by name.
Definition: ms_fragmentationrules.cpp:1313
matrix_science::ms_fragrulesfile::updateInstrumentByName
bool updateInstrumentByName(const char *name, const ms_fragmentationrules item)
Update the information for a specific instrument.
Definition: ms_fragmentationrules.cpp:1369
matrix_science::ms_fragrulesfile::save_file
void save_file()
Stores instrument definitions in a file.
Definition: ms_fragmentationrules.cpp:1245
matrix_science::ms_fragrulesfile::setFileName
void setFileName(const char *filename)
Use this member to set a non-default file name.
Definition: ms_fragmentationrules.cpp:959
matrix_science::ms_fragrulesfile::deleteInstrumentByName
bool deleteInstrumentByName(const char *name)
Remove an instrument from the list in memory.
Definition: ms_fragmentationrules.cpp:1432
matrix_science::ms_fragrulesfile::getInstrumentName
std::string getInstrumentName(const int instrumentNum) const
Returns an instrument name by its number from 0 to (getNumberOfInstruments()-1).
Definition: ms_fragmentationrules.cpp:1297
matrix_science::ms_fragrulesfile::getNumberOfInstruments
int getNumberOfInstruments() const
Returns a number of instruments configured.
Definition: ms_fragmentationrules.cpp:997
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_fragrules.pl

config_fragrules.pl

Read in the fragmentation_rules file.

#!/usr/local/bin/perl
##############################################################################
# file: config_fragrules.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/config_fragrules.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) {
print <<EOF;
The location of 'fragmentation_rules' file has to be specified as a parameter.
The location should either be the full path to the 'fragmentation_rules' file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
exit 1;
}
# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);
# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
$cs = new msparser::ms_connection_settings;
$cs->setSessionID($ARGV[1]);
$file = new msparser::ms_fragrulesfile($ARGV[0], $cs);
} else {
$file = new msparser::ms_fragrulesfile($ARGV[0]);
}
if (!$file->isValid) {
print "There are errors. Cannot continue. The last error description:\n";
print $file->getLastErrorString(), "\n";
exit 1;
}
my $n = $file->getNumberOfInstruments;
print $n, " instruments are configured:\n";
for my $i (0 .. $n-1) {
print $file->getInstrumentName($i), "\n";
}
# Now change ESI-QUAD-TOF.
my $instrument = $file->getInstrumentByName("ESI-QUAD-TOF");
$instrument->setSeriesUsed(23, 1); # Add v series
$file->updateInstrumentByName("ESI-QUAD-TOF", $instrument);
# And delete MALDI-QIT-TOF
$file->deleteInstrumentByName("MALDI-QIT-TOF");
# Finally, save the file under a new name
$file->setFileName($ARGV[0] . ".new");
$file->save_file;
if (!$file->isValid) {
print "Failed to save: ", $file->getLastErrorString, "\n";
} else {
print $ARGV[0], ".new now has ", $file->getNumberOfInstruments(), " instruments configured.\n";
}
my $firstSeries = msparser::ms_fragmentationrules::getFirstSeries();
my $lastSeries = msparser::ms_fragmentationrules::getLastSeries();
print "First series: ", $firstSeries, "\n";
print "Last series : ", $lastSeries , "\n";
for my $i ($firstSeries .. $lastSeries) {
print "--------- $i ---------\n";
print msparser::ms_fragmentationrules::getSeriesName($i), "\n";
print msparser::ms_fragmentationrules::getSeriesDescription ($i), "\n";
}
=pod
Running the program as
perl -I../bin config_fragfules.pl ../config/fragmentation_rules
will give the following output under Mascot Server 2.3:
14 instruments are configured:
Default
ESI-QUAD-TOF
MALDI-TOF-PSD
ESI-TRAP
ESI-QUAD
ESI-FTICR
MALDI-TOF-TOF
ESI-4SECTOR
FTMS-ECD
ETD-TRAP
MALDI-QUAD-TOF
MALDI-QIT-TOF
MALDI-ISD
CID+ETD
../config/fragmentation_rules.new now has 13 instruments configured
First series: 4
Last series : 25
--------- 4 ---------
immonium
immonium
--------- 5 ---------
a
a series
--------- 6 ---------
a*
a - NH3 if a significant and fragment includes RKNQ
--------- 7 ---------
a0
a - H2O if a significant and fragment includes STED
--------- 8 ---------
b
b series
--------- 9 ---------
b*
b - NH3 if b significant and fragment includes RKNQ
--------- 10 ---------
b0
b - H2O if b significant and fragment includes STED
--------- 11 ---------
c
c series
--------- 12 ---------
x
x series
--------- 13 ---------
y
y series
--------- 14 ---------
y*
y - NH3 if y significant and fragment includes RKNQ
--------- 15 ---------
y0
y - H2O if y significant and fragment includes STED
--------- 16 ---------
z
z series
--------- 17 ---------
yb
internal yb < 700 Da
--------- 18 ---------
ya
internal ya < 700 Da
--------- 19 ---------
y must be significant
y or y++ must be significant
--------- 20 ---------
y must be highest score
y or y++ must be highest scoring series
--------- 21 ---------
z+1
z+1 series
--------- 22 ---------
d
d and d' series
--------- 23 ---------
v
v series
--------- 24 ---------
w
w and w' series
--------- 25 ---------
z+2
z+2 series
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_fragrules.java

config_fragrules.java

Read in the fragmentation_rules file.

/*
##############################################################################
# file: config_quantitation.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchi $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2022-07-21 11:07:25 +0100 $ #
# $Revision: 11e243bdaeaabd63950eb86ad86ce3acc1116e78 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class config_fragrules {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// ----- Object creation -----
if(argv.length < 1) {
System.out.println("The location of 'fragmentation_rules' file has to be specified as a parameter");
System.out.println("The location should either be the full path to the fragmentation_rules file");
System.out.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
System.exit(0);
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_fragrulesfile file;
if (argv.length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setSessionID(argv[1]);
file = new ms_fragrulesfile(argv[0], cs);
}
else
{
file = new ms_fragrulesfile(argv[0]);
}
if (!file.isValid())
{
System.out.println("Error number: "+file.getLastError());
System.out.println("Error string: "+file.getLastErrorString());
System.exit(0);
}
int n = file.getNumberOfInstruments();
System.out.println(n + " instruments are configured:");
for(int i=0; i < n; i++)
{
System.out.println(file.getInstrumentName(i));
}
// Now change ESI-QUAD-TOF
ms_fragmentationrules instrument = file.getInstrumentByName("ESI-QUAD-TOF");
instrument.setSeriesUsed(23, true); // Add v series
file.updateInstrumentByName("ESI-QUAD-TOF", instrument);
// And delete MALDI-QIT-TOF
file.deleteInstrumentByName("MALDI-QIT-TOF");
// Finally, save the file under a new name
file.setFileName(argv[0] + ".new");
file.save_file();
System.out.println("There are now " + file.getNumberOfInstruments() + " instruments configured.");
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar config_fragrules fragmentation_rules
12 instruments are configured:
Default
ESI-QUAD-TOF
MALDI-TOF-PSD
ESI-TRAP
ESI-QUAD
ESI-FTICR
MALDI-TOF-TOF
ESI-4SECTOR
FTMS-ECD
MALDI-QUAD-TOF
MALDI-QIT-TOF
ALL
There are now 11 instruments configured.
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_fragrules.py

config_fragrules.py

Read in the fragmentation_rules file.

1#!/usr/bin/python
2
16
17import msparser
18import sys
19
20if len(sys.argv) < 2 :
21 print("""
22The location of 'fragmentation_rules' file has to be specified as a parameter.
23The location should either be the full path to the 'fragmentation_rules' file
24or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
25""")
26
27 sys.exit(1)
28
29# A sessionID can optionally be passed as the second parameter.
30# This will only be required if the 'file' is a URL.
31if len(sys.argv) > 2 :
32 cs = msparser.ms_connection_settings()
33 cs.setSessionID(sys.argv[2])
34 file = msparser.ms_fragrulesfile(sys.argv[1], cs)
35else :
36 file = msparser.ms_fragrulesfile(sys.argv[1])
37
38if not file.isValid() :
39 print("There are errors. Cannot continue. The last error description:")
40 print(file.getLastErrorString())
41 sys.exit(1)
42
43
44n = file.getNumberOfInstruments()
45print("%d instruments are configured:" % n)
46
47for i in range(n) :
48 print(file.getInstrumentName(i))
49
50
51# Now change ESI-QUAD-TOF.
52instrument = file.getInstrumentByName("ESI-QUAD-TOF")
53instrument.setSeriesUsed(23, True) # Add v series
54file.updateInstrumentByName("ESY-QUAD-TOF", instrument)
55
56# And delete MALDI-QIT-TOF.
57file.deleteInstrumentByName("MALDI-QIT-TOF")
58
59# Finally, save the file under a new name.
60file.setFileName(sys.argv[1] + ".new");
61file.save_file();
62
63if not file.isValid() :
64 print("Failed to save: %s" % file.getLastErrorString())
65else :
66 print("%s.new now has %d instruments configured" % (sys.argv[1], file.getNumberOfInstruments()))
67
68firstSeries = msparser.ms_fragmentationrules.getFirstSeries()
69
70firstSeries = msparser.ms_fragmentationrules.getFirstSeries()
71lastSeries = msparser.ms_fragmentationrules.getLastSeries()
72
73print("First series: %s" % firstSeries)
74print("Last series : %s" % lastSeries)
75
76for i in range(firstSeries, 1 + lastSeries) :
77 print("--------- %d ---------" % i)
78 print(msparser.ms_fragmentationrules.getSeriesName(i))
79 print(msparser.ms_fragmentationrules.getSeriesDescription(i))
80
81
82""" Running the program as
83
84python config_fragfules.py /usr/local/mascot/config/fragmentation_rules
85
86will give the following output under Mascot Server 2.3:
87
88
8914 instruments are configured:
90Default
91ESI-QUAD-TOF
92MALDI-TOF-PSD
93ESI-TRAP
94ESI-QUAD
95ESI-FTICR
96MALDI-TOF-TOF
97ESI-4SECTOR
98FTMS-ECD
99ETD-TRAP
100MALDI-QUAD-TOF
101MALDI-QIT-TOF
102MALDI-ISD
103CID+ETD
104/usr/local/mascot/config/fragmentation_rules.new now has 13 instruments configured
105First series: 4
106Last series : 25
107--------- 4 ---------
108immonium
109immonium
110--------- 5 ---------
111a
112a series
113--------- 6 ---------
114a*
115a - NH3 if a significant and fragment includes RKNQ
116--------- 7 ---------
117a0
118a - H2O if a significant and fragment includes STED
119--------- 8 ---------
120b
121b series
122--------- 9 ---------
123b*
124b - NH3 if b significant and fragment includes RKNQ
125--------- 10 ---------
126b0
127b - H2O if b significant and fragment includes STED
128--------- 11 ---------
129c
130c series
131--------- 12 ---------
132x
133x series
134--------- 13 ---------
135y
136y series
137--------- 14 ---------
138y*
139y - NH3 if y significant and fragment includes RKNQ
140--------- 15 ---------
141y0
142y - H2O if y significant and fragment includes STED
143--------- 16 ---------
144z
145z series
146--------- 17 ---------
147yb
148internal yb < 700 Da
149--------- 18 ---------
150ya
151internal ya < 700 Da
152--------- 19 ---------
153y must be significant
154y or y++ must be significant
155--------- 20 ---------
156y must be highest score
157y or y++ must be highest scoring series
158--------- 21 ---------
159z+1
160z+1 series
161--------- 22 ---------
162d
163d and d' series
164--------- 23 ---------
165v
166v series
167--------- 24 ---------
168w
169w and w' series
170--------- 25 ---------
171z+2
172z+2 series
173
174"""
175
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_fragrules.cs

config_fragrules.cs

Read in the fragmentation_rules file.

/*
##############################################################################
# file: config_fragrules.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/config_fragrules.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.IO;
using matrix_science.msparser;
namespace MsParserExamples
{
public class config_fragrules
{
public static void Main(string[] argv)
{
// ----- Object creation -----
if (argv.Length < 1)
{
Console.Error.WriteLine(@"The location of the 'fragmentation_rules' file has to be specified as a parameter
The location should either be the full path to the fragmentation_rules file
or a URL to a Mascot server - e.g. http://mascot-searver/mascot/cgi
A Mascot security sessionID can optionally be passed as a second
parameter");
return;
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_fragrulesfile file;
if (argv.Length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
cs.setSessionID(argv[1]);
file = new ms_fragrulesfile(argv[0], cs);
}
else file = new ms_fragrulesfile(argv[0]);
if (!file.isValid())
{
Console.Error.WriteLine("Error number: {0}", file.getLastError());
Console.Error.WriteLine("Error string: {0}", file.getLastErrorString());
return;
}
int n = file.getNumberOfInstruments();
Console.WriteLine("{0} instruments are configured:", n);
for (int i = 0; i < n; i++)
{
Console.WriteLine(file.getInstrumentName(i));
}
// Now change ESI-QUAD-TOF
ms_fragmentationrules instrument = file.getInstrumentByName("ESI-QUAD-TOF");
instrument.setSeriesUsed(23, true); // Add v series
file.updateInstrumentByName("ESI-QUAD-TOF", instrument);
// And delete MALDI-QIT-TOF
file.deleteInstrumentByName("MALDI-QIT-TOF");
// Finally, save the file under a new name
if (argv[0].ToLower().StartsWith("http"))
{
file.setFileName("copy_enzymes.new");
}
else
{
//create a new file locally
file.setFileName(argv[0] + ".new");
}
file.save_file();
Console.WriteLine("There are now {0} instruments configured. The updated configuration file was saved to {1}",
file.getNumberOfInstruments(),
Path.GetFullPath(file.getFileName()));
}
}
}
/*
Running the program as
config_fragrules.exe c:\inetpub\mascot\config\fragmentation_rules
Will give the output
14 instruments are configured:
Default
ESI-QUAD-TOF
MALDI-TOF-PSD
ESI-TRAP
ESI-QUAD
ESI-FTICR
MALDI-TOF-TOF
ESI-4SECTOR
FTMS-ECD
ETD-TRAP
MALDI-QUAD-TOF
MALDI-QIT-TOF
MALDI-ISD
CID+ETD
There are now 13 instruments configured. The updated configuration file was saved to c:\inetpub\mascot\config\fragmentation_rules.new
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_license.cpp

config_license.cpp

Read in the mascot.license file.

/*
##############################################################################
# file: config_license.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/config_license.cpp $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
int main(int argc, char * argv[])
{
if ( argc < 2 )
{
std::cout << "Location of 'mascot.license'-file has to be specified as a parameter" << std::endl;
return 0;
}
ms_license file(argv[1]);
if ( !file.isValid() )
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << file.getLastErrorString() << std::endl;
return 1;
}
if ( file.isLicenseValid() )
{
std::cout << "Mascot license is still valid. Other information:" << std::endl;
std::cout << file.getLicenseString() << std::endl;
}
else
{
std::cout << "Mascot license has either expired or been corrupted" << std::endl;
}
return 0;
}
/*
will give the output, for instance:
# config_license ../config/mascot.license
Mascot license has either expired or been corrupted
*/
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_license
The class provides access license details in read-only mode.
Definition: ms_license.hpp:52
matrix_science::ms_license::isLicenseValid
bool isLicenseValid() const
Returns TRUE if the license has been sucessfully read, parsed and checked.
Definition: ms_license.cpp:267
matrix_science::ms_license::getLicenseString
std::string getLicenseString() const
Returns a compound license string that can be used for displaying license information.
Definition: ms_license.cpp:285
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_license.pl

config_license.pl

Read in the mascot.license file.

#!/usr/local/bin/perl
##############################################################################
# file: config_license.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/config_license.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) {
print "Location of 'mascot.license' file has to be specified as a parameter\n";
exit 1;
}
my $file = new msparser::ms_license($ARGV[0]);
if (!$file->isValid) {
print "There are errors. Cannot continue. The last error description:\n";
print $file->getLastErrorString(), "\n";
exit 1;
}
if ($file->isLicenseValid) {
print "Mascot license is still valid. Other information:\n";
print $file->getLicenseString(), "\n";
} else {
print "Mascot license has either expired or been corrupted\n";
}
=pod
Running the program as
perl -I../bin config_license.pl mascot.license
will give, without a Mascot license file:
There are errors. Cannot continue. The last error description:
Missing license file: mascot.license.
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_license.java

config_license.java

Read in the mascot.license file.

/*
##############################################################################
# file: config_quantitation.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchi $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2022-07-21 11:07:25 +0100 $ #
# $Revision: 11e243bdaeaabd63950eb86ad86ce3acc1116e78 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class config_license {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// ----- Object creation -----
if(argv.length < 1) {
System.out.println("Location of 'mascot.license'-file has to be specified as a parameter");
System.exit(0);
}
ms_license file = new ms_license(argv[0]);
if (!file.isValid())
{
System.out.println("Error number: "+file.getLastError());
System.out.println("Error string: "+file.getLastErrorString());
System.exit(0);
}
if (file.isLicenseValid())
{
System.out.println("Mascot license is still valid. Other information:");
System.out.println(file.getLicenseString());
}
else
{
System.out.println("Mascot license has either expired or been corrupted");
}
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar config_license mascot.license
Mascot license has either expired or been corrupted
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_license.py

config_license.py

Read in the mascot.license file.

1#!/usr/bin/python
2
16
17import msparser
18import sys
19
20if len(sys.argv) < 2 :
21 print("Location of 'mascot.license' file has to be specified as a parameter")
22 sys.exit(1)
23
24file = msparser.ms_license(sys.argv[1])
25
26if not file.isValid() :
27 print("There are errors. Cannot continue. The last error description:")
28 print(file.getLastErrorString())
29 sys.exit(1)
30
31if file.isLicenseValid() :
32 print("Mascot license is still valid. Other information:")
33 print(file.getLicenseString())
34else :
35 print("Mascot license has either expired or been corrupted")
36
37
38"""
39
40Running the program as
41
42python config_license.pl mascot.license
43
44will give, without a Mascot license file:
45
46
47There are errors. Cannot continue. The last error description:
48Missing license file: mascot.license.
49
50"""
51
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_mascotdat.cpp

config_mascotdat.cpp

Read in the mascot.dat file.

/*
##############################################################################
# file: config_mascotdat.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/config_mascotdat.cpp $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
int main(int argc, char * argv[])
{
if ( argc < 2 )
{
std::cout << "The location of mascot.dat file has to be specified as a parameter" << std::endl;
std::cout << "The location should either be the full path to the mascot.dat file" << std::endl;
std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
return 1;
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_connection_settings cs;
if (argc > 2)
{
cs.setSessionID(argv[2]);
}
ms_datfile file(argv[1], 0, &cs);
if ( !file.isValid() )
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << file.getLastErrorString() << std::endl;
return 1;
}
// retrieving Databases-section content
const ms_databases* dbs = file.getDatabases();
// check if there is 'Databases' section in the file actually
if ( dbs->isSectionAvailable() )
{
int n = dbs->getNumberOfDatabases();
std::cout << "There are " << n << " databases configured:" << std::endl;
int i;
for(i=0; i < n; i++)
{
std::cout << dbs->getDatabase(i)->getName() << " : ";
std::cout << (dbs->getDatabase(i)->isActive() ? "active" : "inactive");
std::cout << std::endl;
}
}
else
{
std::cout << "Databases-section is missing" << std::endl;
}
std::cout << std::endl;
// retrieving Parse-section content
const ms_parseoptions* parseOptions = file.getParseOptions();
// check if there is 'Parse' section in the file actually
if ( parseOptions->isSectionAvailable() )
{
int n = parseOptions->getNumberOfParseRules();
std::cout << "Parse rules configured:" << std::endl;
int i;
for(i=0; i < n; i++)
{
// not all of them can be specified
if ( parseOptions->getParseRule(i)->isAvailable() )
{
std::cout << "Rule_" << i << " : ";
std::cout << parseOptions->getParseRule(i)->getRuleStr();
std::cout << std::endl;
}
}
}
else
{
std::cout << "Parse-section is missing" << std::endl;
}
std::cout << std::endl;
// retrieving WWW-section content
const ms_wwwoptions* wwwOptions = file.getWWWOptions();
// check if there is 'WWW' section in the file actually
if ( wwwOptions->isSectionAvailable() )
{
int n = wwwOptions->getNumberOfEntries();
std::cout << "There are " << n << " sequence report sources configured:" << std::endl;
int i;
for(i=0; i < n; i++)
{
std::cout << wwwOptions->getEntry(i)->getName() << "_";
std::cout << ((wwwOptions->getEntry(i)->getType() == WWW_SEQ) ? "SEQ" : "REP");
std::cout << std::endl;
}
}
else
{
std::cout << "WWW-section is missing" << std::endl;
}
std::cout << std::endl;
// retrieving Taxonomy-sections
std::cout << "Available taxonomy sources:" << std::endl;
int maxtax = file.getMaxTaxonomyRules();
int taxind;
for(taxind = 1; taxind <= maxtax; taxind++)
{
// check whether a certain taxonomy section exists
if ( file.getTaxonomyRules(taxind) != NULL )
{
std::cout << "TAXONOMY_" << taxind;
std::cout << file.getTaxonomyRules(taxind)->getIdentifier();
std::cout << std::endl;
}
}
std::cout << std::endl;
// retrieving Cluster-section content
const ms_clusterparams* clusterParams = file.getClusterParams();
// check if there is 'Cluster' section in the file actually
if ( clusterParams->isSectionAvailable() )
{
std::cout << "Cluster mode : ";
std::cout << (clusterParams->isEnabled() ? "enabled" : "disabled");
std::cout << std::endl;
}
else
{
std::cout << "Cluster-section is missing" << std::endl;
}
std::cout << std::endl;
// retrieving Processor-section content
const ms_processoroptions* procOptions = file.getProcessors();
// check if there is 'Processor' section in the file actually
if ( procOptions->isSectionAvailable() )
{
std::cout << procOptions->getNumberOfProcessors() << " CPU(s) configured";
std::cout << std::endl;
}
else
{
std::cout << "Processor-section is missing" << std::endl;
}
std::cout << std::endl;
// retrieving Options-section content
const ms_mascotoptions* mascotOptions = file.getMascotOptions();
// check if there is 'Options' section in the file actually
if ( mascotOptions->isSectionAvailable() )
{
std::cout << "MascotCmdLine : ";
std::cout << mascotOptions->getMascotCmdLine();
std::cout << std::endl;
}
else
{
std::cout << "Options-section is missing" << std::endl;
}
std::cout << std::endl;
// retrieving Cron-section content
const ms_cronoptions* cronOptions = file.getCronOptions();
// check if there is 'Cron' section in the file actually
if ( cronOptions->isSectionAvailable() )
{
if ( cronOptions->isCronEnabled() )
{
int n = cronOptions->getNumberOfCronJobs();
std::cout << "There are " << n << " cron-jobs configured:" << std::endl;
int i;
for(i=0; i < n; i++)
{
std::cout << cronOptions->getCronJob(i).getCommandStr() << std::endl;
}
}
else
{
std::cout << "Cron functionality is disabled" << std::endl;
}
}
else
{
std::cout << "Cron-section is missing" << std::endl;
}
std::cout << std::endl;
return 0;
}
/*
will give the output:
# test.exe ../config/mascot.dat
There are 4 databases configured:
MSDB : active
NCBInr : active
EST_human : inactive
EST_mouse : inactive
Parse rules configured:
Rule_1 : >owl[^ ]*|\‍([^ ]*\‍)
Rule_2 : >owl[^ ]*|[^ ]*[ ]\‍(.*\‍)
Rule_3 : >[A-Z][1-9];\‍([^ ]*\‍)
Rule_4 : >\‍([^ ]*\‍)
Rule_5 : >[^ ]* \‍(.*\‍)
There are 8 sequence report sources configured:
NCBInr_SEQ
NCBInr_REP
MSDB_SEQ
MSDB_REP
IPI_human_SEQ
IPI_human_REP
IPI_mouse_SEQ
IPI_mouse_REP
Available taxonomy sources:
TAXONOMY_1NCBI nr FASTA
TAXONOMY_2OWL REF
TAXONOMY_3Swiss-prot FASTA
TAXONOMY_4NCBI dbEST FASTA
Cluster mode : disabled
Processor-section is missing
MascotCmdLine : ../cgi/nph-mascot.exe
Cron functionality is disabled
*/
matrix_science::ms_clusterparams
An instance of this class represents all the parameters specified in the Cluster section of mascot....
Definition: ms_clusterparams.hpp:72
matrix_science::ms_clusterparams::isEnabled
bool isEnabled() const
Returns TRUE if Enabled parameter is set to 1 and FALSE otherwise.
Definition: ms_clusterparams.cpp:131
matrix_science::ms_clusterparams::isSectionAvailable
bool isSectionAvailable() const
Check whether the section has been actually read from the file.
Definition: ms_clusterparams.cpp:113
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_connection_settings::setSessionID
void setSessionID(const std::string sessionID)
Sets the Mascot security sessionID to be used for the connection.
Definition: ms_connection_settings.cpp:242
matrix_science::ms_cronjob::getCommandStr
std::string getCommandStr() const
Returns a string that is executed by the shell (command prompt) at the specified times.
Definition: ms_cronoptions.cpp:249
matrix_science::ms_cronoptions
Contains parameters from the cron section of mascot.dat.
Definition: ms_cronoptions.hpp:150
matrix_science::ms_cronoptions::isCronEnabled
bool isCronEnabled() const
Returns true if parameter CronEnabled is set to 1 and false otherwise.
Definition: ms_cronoptions.cpp:452
matrix_science::ms_cronoptions::getCronJob
const ms_cronjob getCronJob(const int idx) const
Returns an object describing a single cron job by its number.
Definition: ms_cronoptions.cpp:495
matrix_science::ms_cronoptions::getNumberOfCronJobs
int getNumberOfCronJobs() const
Returns the total number of cron-jobs configured.
Definition: ms_cronoptions.cpp:475
matrix_science::ms_cronoptions::isSectionAvailable
bool isSectionAvailable() const
Returns TRUE if the section was actually read from a file.
Definition: ms_cronoptions.cpp:431
matrix_science::ms_databaseoptions::isActive
bool isActive() const
Returns true if the database definition is active and false otherwise.
Definition: ms_databaseoptions.cpp:91
matrix_science::ms_databaseoptions::getName
std::string getName() const
Returns the value of Name.
Definition: ms_databaseoptions.cpp:123
matrix_science::ms_databases
An instance of this class represents the Databases section of mascot.dat.
Definition: ms_databaseoptions.hpp:225
matrix_science::ms_databases::getDatabase
const ms_databaseoptions * getDatabase(const int index) const
Returns a database definition by its number.
Definition: ms_databaseoptions.cpp:611
matrix_science::ms_databases::getNumberOfDatabases
int getNumberOfDatabases() const
Returns the total number of database definitions including inactive (commented out) databases.
Definition: ms_databaseoptions.cpp:600
matrix_science::ms_databases::isSectionAvailable
bool isSectionAvailable() const
Check if the section has been actually read form the file or have to be saved.
Definition: ms_databaseoptions.cpp:585
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_datfile::getProcessors
const ms_processoroptions * getProcessors() const
Returns an instance of the class representing the Processors section.
Definition: ms_datfile.cpp:2219
matrix_science::ms_datfile::getCronOptions
const ms_cronoptions * getCronOptions() const
Returns an instance of the class representing the Cron section.
Definition: ms_datfile.cpp:2256
matrix_science::ms_datfile::getParseOptions
const ms_parseoptions * getParseOptions() const
Returns an instance of the class representing the PARSE section.
Definition: ms_datfile.cpp:2145
matrix_science::ms_datfile::getMascotOptions
const ms_mascotoptions * getMascotOptions() const
Returns an instance of the class representing the Options section.
Definition: ms_datfile.cpp:2071
matrix_science::ms_datfile::getTaxonomyRules
const ms_taxonomyrules * getTaxonomyRules(const int idx) const
Returns an instance of the class representing one of the Taxonomy_XXX sections.
Definition: ms_datfile.cpp:2376
matrix_science::ms_datfile::getDatabases
const ms_databases * getDatabases() const
Returns an instance of the class representing the Databases section.
Definition: ms_datfile.cpp:2016
matrix_science::ms_datfile::getClusterParams
const ms_clusterparams * getClusterParams() const
Returns an instance of the class representing the Cluster section.
Definition: ms_datfile.cpp:2293
matrix_science::ms_datfile::getWWWOptions
const ms_wwwoptions * getWWWOptions() const
Returns an instance of the class representing the WWW section.
Definition: ms_datfile.cpp:2182
matrix_science::ms_datfile::getMaxTaxonomyRules
int getMaxTaxonomyRules() const
Returns a maximum possible Taxonomy section number that can be used to retrieve/set the section conte...
Definition: ms_datfile.cpp:2421
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_mascotoptions::getMascotCmdLine
std::string getMascotCmdLine() const
Returns the value of MascotCmdLine.
Definition: ms_mascotoptions.cpp:872
matrix_science::ms_mascotoptions::isSectionAvailable
bool isSectionAvailable() const
Indicates whether the section has been actually read from the file.
Definition: ms_mascotoptions.cpp:569
matrix_science::ms_parseoptions
Represents the PARSE section of mascot.dat.
Definition: ms_parserule.hpp:102
matrix_science::ms_parseoptions::getNumberOfParseRules
int getNumberOfParseRules() const
Can be used to get upper limit for a parse rule number.
Definition: ms_parserule.cpp:289
matrix_science::ms_parseoptions::getParseRule
const ms_parserule * getParseRule(const int index) const
Returns a parse rule by number.
Definition: ms_parserule.cpp:252
matrix_science::ms_parseoptions::isSectionAvailable
bool isSectionAvailable() const
Check whether the section has been actually read from the file.
Definition: ms_parserule.cpp:232
matrix_science::ms_parserule::isAvailable
bool isAvailable() const
Call this member to check if this rule has been specified in the file or just a placeholder.
Definition: ms_parserule.cpp:89
matrix_science::ms_parserule::getRuleStr
std::string getRuleStr() const
Returns a string representing the rule.
Definition: ms_parserule.cpp:103
matrix_science::ms_processoroptions
An instance of this class represents all the parameters specified in the Processors section of mascot...
Definition: ms_processoroptions.hpp:109
matrix_science::ms_processoroptions::getNumberOfProcessors
int getNumberOfProcessors() const
Returns a number of processors specified in the ProcessorSet parameter.
Definition: ms_processoroptions.cpp:190
matrix_science::ms_processoroptions::isSectionAvailable
bool isSectionAvailable() const
Check whether the section has been actually read from the file.
Definition: ms_processoroptions.cpp:161
matrix_science::ms_taxonomyrules::getIdentifier
std::string getIdentifier() const
Returns the value of Identifier.
Definition: ms_taxonomyrules.cpp:537
matrix_science::ms_wwwentry::getType
WWW_TYPE getType() const
Returns the name of the database the entry refers to.
Definition: ms_wwwoptions.cpp:90
matrix_science::ms_wwwentry::getName
std::string getName() const
Returns the name of the database the entry refers to.
Definition: ms_wwwoptions.cpp:69
matrix_science::ms_wwwoptions
Represents the whole WWW section.
Definition: ms_wwwoptions.hpp:157
matrix_science::ms_wwwoptions::getNumberOfEntries
int getNumberOfEntries() const
Returns the total number of entries in the section.
Definition: ms_wwwoptions.cpp:314
matrix_science::ms_wwwoptions::getEntry
const ms_wwwentry * getEntry(const int index) const
Returns an entry by its index.
Definition: ms_wwwoptions.cpp:325
matrix_science::ms_wwwoptions::isSectionAvailable
bool isSectionAvailable() const
Check whether the section has been actually read from the file.
Definition: ms_wwwoptions.cpp:294
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_mascotdat.pl

config_mascotdat.pl

Read in the mascot.dat file.

#!/usr/local/bin/perl
##############################################################################
# file: config_mascotdat.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/config_mascotdat.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) {
print <<EOF;
Location of mascot.dat has to be specified as a parameter.
The location should either be the full path to the mascot.dat file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
exit 1;
}
# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);
# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
$cs = new msparser::ms_connection_settings;
$cs->setSessionID($ARGV[1]);
$file = new msparser::ms_datfile($ARGV[0], 0, $cs);
} else {
$file = new msparser::ms_datfile($ARGV[0]);
}
if (!$file->isValid) {
print "There are errors. Cannot continue. The last error description:\n";
print $file->getLastErrorString(), "\n";
exit 1;
}
# Retrieving section 'Databases' content.
my $dbs = $file->getDatabases;
# Check if there is actually a 'Databases' section in the file before
# continuing.
if ($dbs->isSectionAvailable) {
my $n = $dbs->getNumberOfDatabases;
print "There are ", $n, " databases configured:\n";
for my $i (0 .. $n-1) {
print $dbs->getDatabase($i)->getName, " : ";
if ($dbs->getDatabase($i)->isActive()) {
print "active\n";
} else {
print "inactive\n";
}
}
} else {
print "Section 'Databases' is missing\n";
}
print "\n";
# Retrieving section 'Parse' content.
my $parseOptions = $file->getParseOptions();
# Check if there is a 'Parse' section in the file before continuing.
if ($parseOptions->isSectionAvailable) {
my $n = $parseOptions->getNumberOfParseRules();
print "There are ", $n, " parse rules in the file; the following are specified:\n";
for my $i (0 .. $n-1) {
# Not all of them need be specified in the file.
if ($parseOptions->getParseRule($i)->isAvailable()) {
print "Rule_", $i, " : ";
print $parseOptions->getParseRule($i)->getRuleStr(), "\n";
}
}
} else {
print "Section 'Parse' is missing\n";
}
print "\n";
# Retrieving section 'WWW' content.
my $wwwOptions = $file->getWWWOptions();
# Check if there is a 'WWW' section in the file before continuing.
if ($wwwOptions->isSectionAvailable) {
my $n = $wwwOptions->getNumberOfEntries();
print "There are ", $n, " sequence report sources configured:\n";
for my $i (0 .. $n-1) {
print $wwwOptions->getEntry($i)->getName(), "_";
if ($wwwOptions->getEntry($i)->getType() == $msparser::WWW_SEQ) {
print "SEQ\n";
} else {
print "REP\n";
}
}
} else {
print "Section 'WWW' is missing\n";
}
print "\n";
# Retrieving section 'Taxonomy' content.
print "Available taxonomy sources:\n";
my $maxtax = $file->getMaxTaxonomyRules();
my $activetax = 0;
for my $taxind (1 .. $maxtax) {
# Check whether the taxonomy section exists.
if ($file->getTaxonomyRules($taxind)) {
++$activetax;
print "TAXONOMY_", $taxind, " ";
print $file->getTaxonomyRules($taxind)->getIdentifier(), "\n";
}
}
if ($activetax == 0) {
print "(none)\n";
}
print "\n";
# Retrieving section 'Cluster' content.
my $clusterParams = $file->getClusterParams();
# Check if there is a 'Cluster' section in the file before continuing.
if ($clusterParams->isSectionAvailable) {
print "Cluster mode : ";
if ($clusterParams->isEnabled) {
print "enabled\n";
} else {
print "disabled\n";
}
} else {
print "Section 'Cluster' is missing\n";
}
print "\n";
# Retrieving section 'Processor' content.
my $procOptions = $file->getProcessors();
# Check if there is a 'Processor' section in the file before continuing.
if ($procOptions->isSectionAvailable) {
print $procOptions->getNumberOfProcessors, " CPU(s) configured\n";
} else {
print "Section 'Processor' is missing\n";
}
print "\n";
# Retrieving section 'Options' content.
my $mascotOptions = $file->getMascotOptions();
# Check if there is an 'Options' section in the file before continuing.
if ($mascotOptions->isSectionAvailable) {
print "MascotCmdLine : ", $mascotOptions->getMascotCmdLine(), "\n";
} else {
print "Section 'Options' is missing\n";
}
print "\n";
# Retrieving section 'Cron' content.
my $cronOptions = $file->getCronOptions();
# Check if there is a 'Cron' section in the file before continuing.
if ($cronOptions->isSectionAvailable) {
if ($cronOptions->isCronEnabled) {
my $n = $cronOptions->getNumberOfCronJobs;
if ($n == 0) {
print "There are ", $n, " cron jobs configured\n";
} else {
print "There are ", $n, " cron jobs configured:\n";
}
for my $i (0 .. $n-1) {
print $cronOptions->getCronJob($i)->getCommandStr(), "\n";
}
} else {
print "Cron functionality is disabled\n";
}
} else {
print "Section 'Cron' is missing\n";
}
print "\n";
=pod
Running the program as
perl -I../bin config_mascotdat.pl ../config/mascot.dat
will give the following output under Mascot Server 2.3 (exact details depend
on how the server has been configured):
There are 29 databases configured:
contaminants : active
cRAP : active
EST_human : inactive
EST_mouse : inactive
EST_others : inactive
IPI_arabidopsis : inactive
IPI_bovine : inactive
IPI_chicken : inactive
IPI_human : inactive
IPI_mouse : inactive
IPI_rat : inactive
IPI_zebrafish : inactive
MSIPI_human : inactive
MSIPI_mouse : inactive
NCBInr : active
SwissProt : active
Trembl : inactive
UniRef100 : inactive
Environmental_EST : inactive
Fungi_EST : inactive
Human_EST : inactive
Invertebrates_EST : inactive
Mammals_EST : inactive
Mus_EST : inactive
Plants_EST : inactive
Prokaryotes_EST : inactive
Rodents_EST : inactive
Unclassified_EST : inactive
Vertebrates_EST : inactive
There are 256 parse rules in the file; the following are specified:
Rule_1 : >owl[^ ]*|\‍([^ ]*\‍)
Rule_2 : >owl[^ ]*|[^ ]*[ ]\‍(.*\‍)
Rule_3 : >[A-Z][0-9];\‍([^ ]*\‍)
Rule_4 : >\‍([^ ]*\‍)
Rule_5 : >[^ ]* \‍(.*\‍)
Rule_6 : >\‍(gi|[0-9]*\‍)
Rule_7 : >[^ ]* \‍(.*\‍)
Rule_8 : \*\‍(.*\‍)>
Rule_9 : \*.*\‍(>[A-Z][0-9];.*\‍)
Rule_10 : \‍(LOCUS .*\‍)ORIGIN
Rule_11 : \‍(LOCUS .*\‍)
Rule_12 : >\‍([^ ]*\‍)
Rule_13 : >[^ ]* \‍(.*\‍)
Rule_14 : <pre>\‍(.*\‍)</pre>
Rule_15 : ^ID \‍([^ ]*\‍)
Rule_16 : \*.*\‍(ID [A-Z0-9]*_[A-Z0-9]* .*\‍)
Rule_17 : >\‍([^ ]*\‍)
Rule_18 : >[^ ]* \‍(.*\‍)
Rule_19 : >[A-Z][0-9];\‍([^ ]*\‍)[ ]*
Rule_20 : >\‍(.*\‍)
Rule_21 : >IPI:\‍([^| .]*\‍)
Rule_22 : \*.*\‍(ID IPI[0-9]* .*\‍)
Rule_23 : \‍(.*\‍)
Rule_24 : \*.*\‍(ID [-A-Z0-9_].*\‍)
Rule_25 : >[^(]*.\‍([^)]*\‍)
Rule_26 : ^AC \‍([^ ;]*\‍)
Rule_27 : \*.*\‍(AC \S.*\‍)
Rule_28 : ^ID \‍([^ .]*\‍)
Rule_29 : \*.*\‍(ID IPI[0-9.]* .*\‍)
Rule_30 : >UniRef100_\‍([^ ]*\‍)
Rule_31 : >[^|]*|\‍([^ ]*\‍)
Rule_32 : >\‍([^|]*\‍)
Rule_33 : >..|[^|]*|\‍([^ ]*\‍)
Rule_34 : >..|\‍([^|]*\‍)
Rule_35 : >sp|\‍([^|]*\‍)
Rule_36 : >IPI:CON_\‍([^|]*\‍)
Rule_37 : >MSIPI:s*p*|*\‍([^| .]*\‍)
Rule_38 : >EM_EST:\‍([A-Z0-9]*\‍);
Rule_39 : >EM_ENV:\‍([A-Z0-9]*\‍);
There are 56 sequence report sources configured:
contaminants_SEQ
cRAP_SEQ
EST_human_REP
EST_human_SEQ
EST_mouse_REP
EST_mouse_SEQ
EST_others_REP
EST_others_SEQ
IPI_arabidopsis_REP
IPI_arabidopsis_SEQ
IPI_bovine_REP
IPI_bovine_SEQ
IPI_chicken_REP
IPI_chicken_SEQ
IPI_human_REP
IPI_human_SEQ
IPI_mouse_REP
IPI_mouse_SEQ
IPI_rat_REP
IPI_rat_SEQ
IPI_zebrafish_REP
IPI_zebrafish_SEQ
MSIPI_human_REP
MSIPI_human_SEQ
MSIPI_mouse_REP
MSIPI_mouse_SEQ
NCBInr_REP
NCBInr_SEQ
SwissProt_REP
SwissProt_SEQ
Trembl_REP
Trembl_SEQ
UniRef100_REP
UniRef100_SEQ
Environmental_EST_SEQ
Environmental_EST_REP
Fungi_EST_SEQ
Fungi_EST_REP
Human_EST_SEQ
Human_EST_REP
Invertebrates_EST_SEQ
Invertebrates_EST_REP
Mammals_EST_SEQ
Mammals_EST_REP
Mus_EST_SEQ
Mus_EST_REP
Plants_EST_SEQ
Plants_EST_REP
Prokaryotes_EST_SEQ
Prokaryotes_EST_REP
Rodents_EST_SEQ
Rodents_EST_REP
Unclassified_EST_SEQ
Unclassified_EST_REP
Vertebrates_EST_SEQ
Vertebrates_EST_REP
Available taxonomy sources:
TAXONOMY_1 Obsolete
TAXONOMY_2 OWL REF
TAXONOMY_3 SwissProt FASTA
TAXONOMY_4 Obsolete
TAXONOMY_5 Swiss-prot DAT
TAXONOMY_6 MSDB REF (pre 20000621)
TAXONOMY_7 MSDB REF
TAXONOMY_8 NCBI nr FASTA using GI2TAXID
TAXONOMY_9 dbEST FASTA using GI2TAXID
TAXONOMY_10 EST_human FASTA with TaxID
TAXONOMY_11 EST_mouse FASTA with TaxID
TAXONOMY_12 UniRef Fasta
TAXONOMY_13 EMBL EST Fasta
Cluster mode : disabled
Section 'Processor' is missing
MascotCmdLine : ../cgi/nph-mascot.exe
Cron functionality is disabled
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_mascotdat.java

config_mascotdat.java

Read in the mascot.dat file.

/*
##############################################################################
# file: config_quantitation.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchi #
# Author: yuryr #
# Date: 2006/02/06 17:53:44 #
# Revision: 1.1 #
# NoKeywords:: #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class config_mascotdat {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// ----- Object creation -----
if(argv.length < 1) {
System.err.println("Location of mascot.dat has to be specified as a parameter");
System.err.println("The location should either be the full path to the enzymes file");
System.err.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
System.exit(0);
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_datfile file;
if (argv.length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setSessionID(argv[1]);
file = new ms_datfile(argv[0], 0, cs);
}
else
{
file = new ms_datfile(argv[0]);
}
if (!file.isValid())
{
System.err.println("There are errors. Cannot continue. The last error description:");
System.err.println(file.getLastErrorString());
System.exit(0);
}
// retrieving Databases-section content
ms_databases dbs = file.getDatabases();
// check if there is actually a 'Databases' section in the file
if (dbs.isSectionAvailable())
{
int n = dbs.getNumberOfDatabases();
System.out.println("There are " + n + " databases configured:");
for(int i=0; i < n; i++)
{
System.out.print(dbs.getDatabase(i).getName() + " : ");
if (dbs.getDatabase(i).isActive())
{
System.out.println("active");
}
else
{
System.out.println("inactive");
}
}
}
else
{
System.out.println("Databases-section is missing");
}
System.out.println("");
// retrieving Parse-section content
ms_parseoptions parseOptions = file.getParseOptions();
// check if there is 'Parse' section in the file actually
if (parseOptions.isSectionAvailable())
{
int n = parseOptions.getNumberOfParseRules();
System.out.println("Parse rules configured:");
for (int i=0; i < n; i++)
{
// not all of them can be specified
if (parseOptions.getParseRule(i).isAvailable())
{
System.out.print("Rule_" + i + " : ");
System.out.println(parseOptions.getParseRule(i).getRuleStr());
}
}
}
else
{
System.out.println("Parse-section is missing");
}
System.out.println();
// retrieving WWW-section content
ms_wwwoptions wwwOptions = file.getWWWOptions();
// check if there is 'WWW' section in the file actually
if (wwwOptions.isSectionAvailable())
{
int n = wwwOptions.getNumberOfEntries();
System.out.println("There are " + n + " sequence report sources configured:");
for(int i=0; i < n; i++)
{
System.out.print(wwwOptions.getEntry(i).getName() + "_");
if (wwwOptions.getEntry(i).getType() == msparser.WWW_SEQ)
{
System.out.println("SEQ");
}
else
{
System.out.println("REP");
}
}
}
else
{
System.out.println("WWW-section is missing");
}
System.out.println();
// retrieving Taxonomy-sections
System.out.println("Available taxonomy sources:");
int maxtax = file.getMaxTaxonomyRules();
for (int taxind = 1; taxind <= maxtax; taxind++)
{
// check whether a certain taxonomy section exists
if (file.getTaxonomyRules(taxind) != null)
{
System.out.print("TAXONOMY_" + taxind + " ");
System.out.println(file.getTaxonomyRules(taxind).getIdentifier());
}
}
System.out.println();
// retrieving Cluster-section content
ms_clusterparams clusterParams = file.getClusterParams();
// check if there is 'Cluster' section in the file actually
if (clusterParams.isSectionAvailable())
{
System.out.print("Cluster mode : ");
if (clusterParams.isEnabled())
{
System.out.println("enabled");
}
else
{
System.out.println("disabled");
}
}
else
{
System.out.println("Cluster-section is missing");
}
System.out.println();
// retrieving Processor-section content
ms_processoroptions procOptions = file.getProcessors();
// check if there is actually a 'Processor' section in the file
if (procOptions.isSectionAvailable())
{
System.out.println(procOptions.getNumberOfProcessors() + " CPU(s) configured");
}
else
{
System.out.println("Processor-section is missing");
}
System.out.println();
// retrieving Options-section content
ms_mascotoptions mascotOptions = file.getMascotOptions();
// check if there is actually an 'Options' section in the file
if (mascotOptions.isSectionAvailable())
{
System.out.print("MascotCmdLine : ");
System.out.println(mascotOptions.getMascotCmdLine());
}
else
{
System.out.println("Options-section is missing");
}
System.out.println();
// retrieving Cron-section content
ms_cronoptions cronOptions = file.getCronOptions();
// check if there is actually a 'Cron' section in the file
if (cronOptions.isSectionAvailable())
{
if (cronOptions.isCronEnabled())
{
int n = cronOptions.getNumberOfCronJobs();
System.out.println("There are " + n + " cron-jobs configured:");
for (int i=0; i < n; i++)
{
System.out.println(cronOptions.getCronJob(i).getCommandStr());
}
}
else
{
System.out.println("Cron functionality is disabled");
}
}
else
{
System.out.println("Cron-section is missing");
}
System.out.println();
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar config_mascotdat mascot.dat
There are 10 databases configured:
MSDB : active
NCBInr : active
EST_human : inactive
EST_mouse : inactive
EST_others : active
SwissProt : active
Trembl : inactive
IPI_human : inactive
IPI_mouse : inactive
yeastorfn : active
Parse rules configured:
Rule_1 : >owl[^ ]*|\‍([^ ]*\‍)
Rule_2 : >owl[^ ]*|[^ ]*[ ]\‍(.*\‍)
Rule_3 : >[A-Z][0-9];\‍([^ ]*\‍)
Rule_4 : >\‍([^ ]*\‍)
Rule_5 : >[^ ]* \‍(.*\‍)
Rule_6 : >\‍(gi|[0-9]*\‍)
Rule_7 : >[^ ]* \‍(.*\‍)
Rule_8 : \*\‍(.*\‍)>
Rule_9 : \*.*\‍(>[A-Z][0-9];.*\‍)
Rule_10 : \‍(LOCUS .*\‍)ORIGIN
Rule_11 : \‍(LOCUS .*\‍)
Rule_12 : >\‍([^ ]*\‍)
Rule_13 : >[^ ]* \‍(.*\‍)
Rule_14 : <pre>\‍(.*\‍)</pre>
Rule_15 : ^AC \‍([^ ;]*\‍)
Rule_16 : \*.*\‍(ID [A-Z0-9]*_[A-Z0-9]* .*\‍)
Rule_17 : >\‍([^ ]*\‍)
Rule_18 : >[^ ]* \‍(.*\‍)
Rule_19 : >[A-Z][0-9];\‍([^ ]*\‍)[ ]*
Rule_20 : >\‍(.*\‍)
Rule_21 : >IPI:\‍([^| .]*\‍)
Rule_22 : \*.*\‍(ID IPI[0-9]* .*\‍)
Rule_23 : \‍(.*\‍)
Rule_24 : \*.*\‍(ID [-A-Z0-9_].*\‍)
Rule_25 : >[^(]*.\‍([^)]*\‍)
Rule_26 : ^AC \‍([^ ;]*\‍)
Rule_27 : \*.*\‍(AC [A-Z0-9]*;.*\‍)
There are 19 sequence report sources configured:
NCBInr_SEQ
NCBInr_REP
EST_human_SEQ
EST_human_REP
EST_mouse_SEQ
EST_mouse_REP
EST_others_SEQ
EST_others_REP
SwissProt_SEQ
SwissProt_REP
Trembl_SEQ
Trembl_REP
MSDB_SEQ
MSDB_REP
IPI_human_SEQ
IPI_human_REP
IPI_mouse_SEQ
IPI_mouse_REP
yeastorfn_SEQ
Available taxonomy sources:
TAXONOMY_1 NCBI nr FASTA
TAXONOMY_2 OWL REF
TAXONOMY_3 Swiss-prot FASTA
TAXONOMY_4 NCBI dbEST FASTA
TAXONOMY_5 Swiss-prot DAT
TAXONOMY_6 MSDB REF (pre 20000621)
TAXONOMY_7 MSDB REF
TAXONOMY_8 NCBI nr FASTA using GI2TAXID
TAXONOMY_9 dbEST FASTA using GI2TAXID
TAXONOMY_10 EST_human FASTA with TaxID
TAXONOMY_11 EST_mouse FASTA with TaxID
Cluster mode : disabled
Processor-section is missing
MascotCmdLine : ../cgi/nph-mascot.exe
Cron functionality is disabled
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_mascotdat.py

config_mascotdat.py

Read in the mascot.dat file.

1#!/usr/bin/python
2
16
17import msparser
18import sys
19
20if len(sys.argv) < 2 :
21 print("""
22Location of mascot.dat has to be specified as a parameter.
23The location should either be the full path to the mascot.dat file
24or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
25""")
26 sys.exit(1)
27
28# A sessionID can optionally be passed as the second parameter.
29# This will only be required if the 'file' is a URL.
30if len(sys.argv) > 2 :
31 cs = msparser.ms_connection_settings()
32 cs.setSessionID(sys.argv[2])
33 file = msparser.ms_datfile(sys.argv[1], 0, cs)
34else :
35 file = msparser.ms_datfile(sys.argv[1])
36
37if not file.isValid() :
38 print("There are errors. Cannot continue. The last error description:")
39 print(file.getLastErrorString())
40 sys.exit(1)
41
42# Retrieving section 'Databases' content.
43dbs = file.getDatabases()
44
45# Check if there is actually a 'Databases' section in the file before
46# continuing.
47if dbs.isSectionAvailable() :
48 n = dbs.getNumberOfDatabases()
49 print("There are %d databases configured:" % n)
50
51 for i in range(n) :
52 database = dbs.getDatabase(i).getName()
53
54 if dbs.getDatabase(i).isActive() :
55 inuse = "active"
56 else :
57 inuse = "inactive"
58 print('{:<20}'.format(database) + '{:<}'.format(inuse))
59else :
60 print("Section 'Databases' is missing")
61
62print("")
63
64# Retrieving section 'Parse' content.
65parseOptions = file.getParseOptions()
66
67# Check if there is a 'Parse' section in the file before continuing.
68if parseOptions.isSectionAvailable() :
69 n = parseOptions.getNumberOfParseRules()
70 print("There are %d parse rules in the file; the following are specified:" % n)
71
72 for i in range(n) :
73 # Not all of them need be specified in the file.
74 if parseOptions.getParseRule(i).isAvailable() :
75 print("Rule_%d : %s" % (i, parseOptions.getParseRule(i).getRuleStr()))
76else :
77 print("Section 'Parse' is missing")
78
79print("")
80
81# Retrieving section 'WWW' content.
82wwwOptions = file.getWWWOptions()
83
84# Check if there is a 'WWW' section in the file before continuing.
85if wwwOptions.isSectionAvailable() :
86 n = wwwOptions.getNumberOfEntries()
87 print("There are %d sequence report sources configured:" % n)
88
89 for i in range(n) :
90 if wwwOptions.getEntry(i).getType() == msparser.WWW_SEQ :
91 type = "SEQ"
92 else :
93 type = "REP"
94
95 print("%s_%s" % (wwwOptions.getEntry(i).getName(), type))
96else :
97 print("Section 'WWW' is missing")
98
99print("")
100
101# Retrieving section 'Taxonomy' content.
102print("Available taxonomy sources:")
103
104maxtax = file.getMaxTaxonomyRules()
105activetax = 0
106
107for taxind in range(1, 1 + maxtax) :
108 # Check whether the taxonomy section exists.
109 if file.getTaxonomyRules(taxind) :
110 activetax += 1
111 print("TAXONOMY_%d" % taxind)
112 print(file.getTaxonomyRules(taxind).getIdentifier())
113
114if activetax == 0 :
115 print("(none)")
116
117print("")
118
119# Retrieving section 'Cluster' content.
120clusterParams = file.getClusterParams()
121
122# Check if there is a 'Cluster' section in the file before continuing.
123if clusterParams.isSectionAvailable() :
124
125 if clusterParams.isEnabled() :
126 print("Cluster mode: enabled")
127 else :
128 print("Cluster mode: disabled")
129else :
130 print("Section 'Cluster' is missing")
131
132print("")
133
134# Retrieving section 'Processor' content.
135procOptions = file.getProcessors()
136
137# Check if there is a 'Processor' section in the file before continuing.
138if procOptions.isSectionAvailable() :
139 print("%d CPU(s) configured" % procOptions.getNumberOfProcessors())
140else :
141 print("Section 'Processor' is missing")
142
143print("")
144
145# Retrieving section 'Options' content.
146mascotOptions = file.getMascotOptions()
147
148# Check if there is an 'Options' section in the file before continuing.
149if mascotOptions.isSectionAvailable() :
150 print("MascotCmdLine: %s" % mascotOptions.getMascotCmdLine())
151else :
152 print("Section 'Options' is missing")
153
154print("")
155
156# Retrieving section 'Cron' content.
157cronOptions = file.getCronOptions()
158
159# Check if there is a 'Cron' section in the file before continuing.
160if cronOptions.isSectionAvailable() :
161 if cronOptions.isCronEnabled() :
162 n = cronOptions.getNumberOfCronJobs()
163
164 if n == 0 :
165 print("There are %d cron jobs configured" % n)
166 else :
167 print("There are %d cron jobs configured:" % n)
168
169 for i in range(n) :
170 print(cronOptions.getCronJob(i).getCommandStr())
171 else :
172 print("Cron functionality is disabled")
173else :
174 print("Section 'Cron' is missing")
175
176print("")
177
178
179"""
180
181Running the program as
182
183python config_mascotdat.py /usr/local/mascot/config/mascot.dat
184
185will give the following output under Mascot Server 2.3 (exact details depend
186on how the server has been configured):
187
188
189There are 29 databases configured:
190contaminants : active
191cRAP : active
192EST_human : inactive
193EST_mouse : inactive
194EST_others : inactive
195IPI_arabidopsis : inactive
196IPI_bovine : inactive
197IPI_chicken : inactive
198IPI_human : inactive
199IPI_mouse : inactive
200IPI_rat : inactive
201IPI_zebrafish : inactive
202MSIPI_human : inactive
203MSIPI_mouse : inactive
204NCBInr : active
205SwissProt : active
206Trembl : inactive
207UniRef100 : inactive
208Environmental_EST : inactive
209Fungi_EST : inactive
210Human_EST : inactive
211Invertebrates_EST : inactive
212Mammals_EST : inactive
213Mus_EST : inactive
214Plants_EST : inactive
215Prokaryotes_EST : inactive
216Rodents_EST : inactive
217Unclassified_EST : inactive
218Vertebrates_EST : inactive
219
220There are 256 parse rules in the file; the following are specified:
221Rule_1 : >owl[^ ]*|\‍([^ ]*\‍)
222Rule_2 : >owl[^ ]*|[^ ]*[ ]\‍(.*\‍)
223Rule_3 : >[A-Z][0-9];\‍([^ ]*\‍)
224Rule_4 : >\‍([^ ]*\‍)
225Rule_5 : >[^ ]* \‍(.*\‍)
226Rule_6 : >\‍(gi|[0-9]*\‍)
227Rule_7 : >[^ ]* \‍(.*\‍)
228Rule_8 : \*\‍(.*\‍)>
229Rule_9 : \*.*\‍(>[A-Z][0-9];.*\‍)
230Rule_10 : \‍(LOCUS .*\‍)ORIGIN
231Rule_11 : \‍(LOCUS .*\‍)
232Rule_12 : >\‍([^ ]*\‍)
233Rule_13 : >[^ ]* \‍(.*\‍)
234Rule_14 : <pre>\‍(.*\‍)</pre>
235Rule_15 : ^ID \([^ ]*\)
236Rule_16 : \*.*\(ID [A-Z0-9]*_[A-Z0-9]* .*\)
237Rule_17 : >\([^ ]*\)
238Rule_18 : >[^ ]* \(.*\)
239Rule_19 : >[A-Z][0-9];\([^ ]*\)[ ]*
240Rule_20 : >\(.*\)
241Rule_21 : >IPI:\([^| .]*\)
242Rule_22 : \*.*\(ID IPI[0-9]* .*\)
243Rule_23 : \(.*\)
244Rule_24 : \*.*\(ID [-A-Z0-9_].*\)
245Rule_25 : >[^(]*.\([^)]*\)
246Rule_26 : ^AC \([^ ;]*\)
247Rule_27 : \*.*\(AC \S.*\)
248Rule_28 : ^ID \([^ .]*\)
249Rule_29 : \*.*\(ID IPI[0-9.]* .*\)
250Rule_30 : >UniRef100_\([^ ]*\)
251Rule_31 : >[^|]*|\([^ ]*\)
252Rule_32 : >\([^|]*\)
253Rule_33 : >..|[^|]*|\([^ ]*\)
254Rule_34 : >..|\([^|]*\)
255Rule_35 : >sp|\([^|]*\)
256Rule_36 : >IPI:CON_\([^|]*\)
257Rule_37 : >MSIPI:s*p*|*\([^| .]*\)
258Rule_38 : >EM_EST:\([A-Z0-9]*\);
259Rule_39 : >EM_ENV:\([A-Z0-9]*\);
260
261There are 56 sequence report sources configured:
262contaminants_SEQ
263cRAP_SEQ
264EST_human_REP
265EST_human_SEQ
266EST_mouse_REP
267EST_mouse_SEQ
268EST_others_REP
269EST_others_SEQ
270IPI_arabidopsis_REP
271IPI_arabidopsis_SEQ
272IPI_bovine_REP
273IPI_bovine_SEQ
274IPI_chicken_REP
275IPI_chicken_SEQ
276IPI_human_REP
277IPI_human_SEQ
278IPI_mouse_REP
279IPI_mouse_SEQ
280IPI_rat_REP
281IPI_rat_SEQ
282IPI_zebrafish_REP
283IPI_zebrafish_SEQ
284MSIPI_human_REP
285MSIPI_human_SEQ
286MSIPI_mouse_REP
287MSIPI_mouse_SEQ
288NCBInr_REP
289NCBInr_SEQ
290SwissProt_REP
291SwissProt_SEQ
292Trembl_REP
293Trembl_SEQ
294UniRef100_REP
295UniRef100_SEQ
296Environmental_EST_SEQ
297Environmental_EST_REP
298Fungi_EST_SEQ
299Fungi_EST_REP
300Human_EST_SEQ
301Human_EST_REP
302Invertebrates_EST_SEQ
303Invertebrates_EST_REP
304Mammals_EST_SEQ
305Mammals_EST_REP
306Mus_EST_SEQ
307Mus_EST_REP
308Plants_EST_SEQ
309Plants_EST_REP
310Prokaryotes_EST_SEQ
311Prokaryotes_EST_REP
312Rodents_EST_SEQ
313Rodents_EST_REP
314Unclassified_EST_SEQ
315Unclassified_EST_REP
316Vertebrates_EST_SEQ
317Vertebrates_EST_REP
318
319Available taxonomy sources:
320TAXONOMY_1 Obsolete
321TAXONOMY_2 OWL REF
322TAXONOMY_3 SwissProt FASTA
323TAXONOMY_4 Obsolete
324TAXONOMY_5 Swiss-prot DAT
325TAXONOMY_6 MSDB REF (pre 20000621)
326TAXONOMY_7 MSDB REF
327TAXONOMY_8 NCBI nr FASTA using GI2TAXID
328TAXONOMY_9 dbEST FASTA using GI2TAXID
329TAXONOMY_10 EST_human FASTA with TaxID
330TAXONOMY_11 EST_mouse FASTA with TaxID
331TAXONOMY_12 UniRef Fasta
332TAXONOMY_13 EMBL EST Fasta
333
334Cluster mode : disabled
335
336Section 'Processor' is missing
337
338MascotCmdLine : ../cgi/nph-mascot.exe
339
340Cron functionality is disabled
341
342"""
343
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_mascotdat.cs

config_mascotdat.cs

Read in the mascot.dat file.

/*
##############################################################################
# file: config_mascotdat.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/config_mascotdat.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class config_mascotdat
{
public static void Main(string[] argv)
{
// ----- Object creation -----
if (argv.Length < 1)
{
Console.Error.WriteLine(@"The location of the mascot.dat has to be specified as a parameter
The location should either be the full path to the mascot.dat file
or a URL to a Mascot server - e.g. http://mascot-searver/mascot/cgi
A Mascot security sessionID can optionally be passed as a second
parameter");
return;
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_datfile file;
if (argv.Length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
cs.setSessionID(argv[1]);
file = new ms_datfile(argv[0], 0, cs);
} else file = new ms_datfile(argv[0]);
if (!file.isValid())
{
Console.Error.WriteLine("There are errors. Cannot continue. The last error description:");
Console.Error.WriteLine(file.getLastErrorString());
return;
}
// retrieving Databases-section content
ms_databases dbs = file.getDatabases();
// check if there is actually a 'Databases' section in the file
if (dbs.isSectionAvailable())
{
int n = dbs.getNumberOfDatabases();
Console.WriteLine("There are {0} databases configured:", n);
for (int i = 0; i < n; i++)
{
Console.WriteLine("{0} : {1}", dbs.getDatabase(i).getName(), dbs.getDatabase(i).isActive() ? "active" : "inactive");
}
}
else
{
Console.WriteLine("Databases-section is missing");
}
Console.WriteLine();
// retrieving Parse-section content
ms_parseoptions parseOptions = file.getParseOptions();
// check if there is actually a 'Parse' section in the file
if (parseOptions.isSectionAvailable())
{
int n = parseOptions.getNumberOfParseRules();
Console.WriteLine("Parse rules configured:");
for (int i = 0; i < n; i++)
{
// not all of them can be specified
if (parseOptions.getParseRule(i).isAvailable())
{
Console.WriteLine("Rule_{0} : {1}", i, parseOptions.getParseRule(i).getRuleStr());
}
}
}
else
{
Console.WriteLine("Parse-section is missing");
}
Console.WriteLine();
// retrieving WWW-section content
ms_wwwoptions wwwOptions = file.getWWWOptions();
// check if there is actually a 'WWWW' section in the file
if (wwwOptions.isSectionAvailable())
{
int n = wwwOptions.getNumberOfEntries();
Console.WriteLine("There are {0} sequence report sources configured:", n);
for (int i = 0; i < n; i++)
{
Console.WriteLine("{0}_{1}", wwwOptions.getEntry(i).getName(),
wwwOptions.getEntry(i).getType() == WWW_TYPE.WWW_SEQ ? "SEQ" : "REP");
}
}
else
{
Console.WriteLine("WWW-section is missing");
}
Console.WriteLine();
// retrieving Taxonomy-sections
Console.WriteLine("Available taxonomy sources:");
int maxTax = file.getMaxTaxonomyRules();
for (int taxInd = 1; taxInd <= maxTax; taxInd++)
{
// check whether a certain taxonomy section exists
if (file.getTaxonomyRules(taxInd) != null)
{
Console.WriteLine("TAXONOMY_{0} {1}", taxInd, file.getTaxonomyRules(taxInd).getIdentifier());
}
}
Console.WriteLine();
// retrieving Cluster-section content
ms_clusterparams clusterParams = file.getClusterParams();
// Check if there is a 'Cluster' section available
if (clusterParams.isSectionAvailable())
{
Console.WriteLine("Cluster mode : {0}", clusterParams.isEnabled() ? "enabled" : "disabled");
}
else
{
Console.WriteLine("Cluster-section is missing");
}
Console.WriteLine();
// retrieving Processor-section content
ms_processoroptions procOptions = file.getProcessors();
// check if the 'Processor' section is available
if (procOptions.isSectionAvailable())
{
Console.WriteLine("{0} CPU(s) configured", procOptions.getNumberOfProcessors());
}
else
{
Console.WriteLine("Processor-section is missing");
}
Console.WriteLine();
// retrieving Options-section content
ms_mascotoptions mascotOptions = file.getMascotOptions();
// check if there is actually an 'Options' section in the file
if (mascotOptions.isSectionAvailable())
{
Console.WriteLine("MascotCmdLine : {0}", mascotOptions.getMascotCmdLine());
}
else
{
Console.WriteLine("Options-section is missing");
}
Console.WriteLine();
// retrieving Cron-section content
ms_cronoptions cronOptions = file.getCronOptions();
if (cronOptions.isCronEnabled())
{
int n = cronOptions.getNumberOfCronJobs();
Console.WriteLine("There are {0} cron-jobs configured:", n);
for (int i = 0; i < n; i++)
{
Console.WriteLine(cronOptions.getCronJob(i).getCommandStr());
}
}
else
{
Console.WriteLine("Cron functionality is disabled");
}
Console.WriteLine();
}
}
}
/*
Running the program as
config_mascotdat.exe c:\inetpub\mascot\config\mascot.dat
Will give the output:
There are 18 databases configured:
B_subtilis : inactive
Bug_11795 : inactive
contaminants : active
cRAP : active
Human_NoIsoforms : active
IPI-human : active
IPI_human : active
IPI_human_decoy : active
Mixed_M_2013-02-07_TruncWithReverse4 : active
PRIDE_PXD0000001 : active
Proteome_EBV_B95.8_GenBank : inactive
SwissProt : active
UniProt_Arabidopsis : active
UniProt_Chlamydomonas_reinhardtii : active
UniProt_Human : active
UniProt_Papillomaviridae : active
UniProt_Pig : active
UniProt_Rat : active
Parse rules configured:
Rule_1 : >[^|]*|[ABCDEFGHIJKLMNOPQRSTUVWXYZ]\‍([^ |]*\‍)
Rule_2 : >[^ ]* [^ ]* \‍(.*\‍)
Rule_3 : \*\‍(.*\‍)>
Rule_4 : >\‍(gi|[0-9]*\‍)
Rule_5 : >[^ ]* \‍(.*\‍)
Rule_6 : >\‍([^ ]*\‍)
Rule_7 : >[^ ]* \‍(.*\‍)
Rule_8 : \*\‍(.*\‍)>
Rule_9 : >..|\‍([^|]*\‍)
Rule_10 : \‍(.*\‍)
Rule_11 : >..|[ABCDEFGHIJKLMNOPQRSTUVWXYZ]\‍([^|]*\‍)
Rule_12 : >IPI:\‍([^| ]*\‍)
Rule_13 : ^ID \‍([^ .]*\‍)
Rule_14 : \*\‍(.*\‍)>
Rule_15 : \*.*\‍(ID IPI[0-9.]* .*\‍)
Rule_16 : >IPI:\‍([^| .]*\‍)
Rule_17 : ^ID \‍([^ .]*\‍)
Rule_18 : >[^ ]* \‍(.*\‍)
Rule_19 : \*\‍(.*\‍)>
Rule_20 : \*.*\‍(ID IPI[0-9.]* .*\‍)
Rule_21 : >\‍([^|]*\‍)
Rule_22 : >\‍([^ ]*\‍)
Rule_23 : >\‍(.*\‍)
Rule_24 : >..|[^|]*|\‍([^ ]*\‍)
Rule_25 : ^ID \‍([^ ]*\‍)
Rule_26 : >[^ ]* \‍(.*\‍)
Rule_27 : \*\‍(.*\‍)>
Rule_28 : \*.*\‍(ID [-A-Z0-9_].*\‍)
Rule_29 : human *release *\‍([0-9.][0-9.]*\‍)
Rule_30 : Swiss-Prot *.*Release *\‍([0-9._][0-9._]*\‍)
Rule_31 : >IPI:\‍([^| .]*\‍)
Rule_32 : >[^|]*|\\w\‍([^ |]*\‍)
Rule_33 : >..|\\w\‍([^|]*\‍)
Rule_34 : human *release *\‍([0-9.][0-9.]*\‍)
There are 27 sequence report sources configured:
B_subtilis_SEQ
Bug_11795_SEQ
contaminants_SEQ
cRAP_SEQ
Human_NoIsoforms_SEQ
IPI-human_SEQ
IPI_human_SEQ
IPI_human_decoy_SEQ
Mixed_M_2013-02-07_TruncWithReverse4_SEQ
PRIDE_PXD0000001_SEQ
Proteome_EBV_B95.8_GenBank_SEQ
SwissProt_SEQ
UniProt_Arabidopsis_SEQ
UniProt_Chlamydomonas_reinhardtii_SEQ
UniProt_Human_SEQ
UniProt_Papillomaviridae_SEQ
UniProt_Pig_SEQ
UniProt_Rat_SEQ
IPI-human_REP
IPI_human_REP
SwissProt_REP
UniProt_Arabidopsis_REP
UniProt_Chlamydomonas_reinhardtii_REP
UniProt_Human_REP
UniProt_Papillomaviridae_REP
UniProt_Pig_REP
UniProt_Rat_REP
Available taxonomy sources:
TAXONOMY_1 All human with TaxID 9606
TAXONOMY_2 SwissProt FASTA
TAXONOMY_3 All human with TaxID 9606
TAXONOMY_4 All mouse with TaxID 10090
TAXONOMY_5 EMBL EST Fasta
TAXONOMY_6 HUPO PSI PEFF Format
TAXONOMY_7 MSDB REF
TAXONOMY_8 NCBI nucleotide FASTA using GI2TAXID
TAXONOMY_9 NCBI protein FASTA using GI2TAXID
TAXONOMY_10 OWL REF
TAXONOMY_11 Obsolete_1
TAXONOMY_12 Obsolete_2
TAXONOMY_13 Obsolete_3
TAXONOMY_14 Swiss-prot DAT
TAXONOMY_15 SwissProt FASTA
TAXONOMY_16 UniRef Fasta
Cluster mode : disabled
Processor-section is missing
MascotCmdLine : ../cgi/nph-mascot.exe
There are 5 cron-jobs configured:
C:\Perl64\bin\perl.exe C:/inetpub/mascot/bin/dbman_add_task.pl SwissProt
C:\Perl64\bin\perl.exe C:/inetpub/mascot/bin/dbman_add_task.pl UniProt_Chlamydomonas_reinhardtii
C:\Perl64\bin\perl.exe C:/inetpub/mascot/bin/dbman_add_task.pl UniProt_Rat
C:\Perl64\bin\perl.exe C:/inetpub/mascot/bin/dbman_add_task.pl UniProt_Pig
C:\Perl64\bin\perl.exe C:/inetpub/mascot/bin/dbman_process_tasks.pl
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_masses.cpp

config_masses.cpp

Read in the masses file.

/*
##############################################################################
# file: config_masses.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/config_masses.cpp $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
int main(int argc, char * argv[])
{
if ( argc < 2 )
{
std::cout << "The location of masses file has to be specified as a parameter" << std::endl;
std::cout << "The location should either be the full path to the masses file" << std::endl;
std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
return 1;
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_connection_settings cs;
if (argc > 2)
{
cs.setSessionID(argv[2]);
}
ms_masses file(argv[1], &cs);
if ( !file.isValid() )
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << file.getLastErrorString() << std::endl;
return 1;
}
std::cout << "Average amino acid masses as read from 'masses' file:" << std::endl;
int i;
for(i='A'; i <= 'Z'; i++)
{
std::cout << (char)i << ": " << file.getResidueMass(MASS_TYPE_AVE, i) << std::endl;
}
return 0;
}
/*
will give the output, for instance:
# config_masses ../config/masses
Average amino acid masses as read from 'masses' file:
A: 71.0788
B: 114.596
C: 103.139
D: 115.089
E: 129.116
F: 147.177
G: 57.052
H: 137.141
I: 113.159
J: 0
K: 128.172
L: 113.159
M: 131.193
N: 114.104
O: 0
P: 97.1167
Q: 128.131
R: 156.188
S: 87.0782
T: 101.105
U: 150.034
V: 99.1326
W: 186.213
X: 111
Y: 163.176
Z: 128.623
*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_connection_settings::setSessionID
void setSessionID(const std::string sessionID)
Sets the Mascot security sessionID to be used for the connection.
Definition: ms_connection_settings.cpp:242
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_masses
Reads and parses the masses file with residue and atom masses.
Definition: ms_masses.hpp:48
matrix_science::ms_masses::getResidueMass
double getResidueMass(const matrix_science::MASS_TYPE massType, const char residue) const
Returns a mass for a given amino acid.
Definition: ms_masses.cpp:872
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_masses.pl

config_masses.pl

Read in the masses file.

#!/usr/local/bin/perl
##############################################################################
# file: config_masses.pl #
# This file illustrates how to use ms_masses-class from the Mascot perl #
# module 'msparser' #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/config_masses.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) {
print <<EOF;
The location of masses file has to be specified as a parameter.
The location should either be the full path to the masses file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
exit 1;
}
# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);
# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
$cs = new msparser::ms_connection_settings;
$cs->setSessionID($ARGV[1]);
$file = new msparser::ms_masses($ARGV[0], $cs);
} else {
$file = new msparser::ms_masses($ARGV[0]);
}
# Unlike the other configuration files, it is possible to use ms_masses
# without specifying the filename - in which case it defaults to
# '../config/masses'.
if (!$file->isValid) {
print "Error when reading file: ", $file->getFileName(), "\n";
checkErrorHandler($file);
exit(1);
}
print "Name of the file: ", $file->getFileName(), "\n";
print "-------------------------------------------------------------\n";
print "--- Content of masses file ---\n";
print "-------------------------------------------------------------\n";
print "# Amino acid masses (monoisotopic and average)\n";
for my $i (0 .. 25) {
my $res = chr(ord('A') + $i);
printf(
"%1s:%5.5f,%5.5f\n",
$res,
$file->getResidueMass($msparser::MASS_TYPE_MONO, $res),
$file->getResidueMass($msparser::MASS_TYPE_AVE, $res)
);
}
print "\n";
print "# Atomic masses used for terminus values\n";
printf(
"HYDROGEN:%5.5f,%5.5f\n",
$file->getHydrogenMass($msparser::MASS_TYPE_MONO),
$file->getHydrogenMass($msparser::MASS_TYPE_AVE)
);
printf(
"CARBON:%5.5f,%5.5f\n",
$file->getCarbonMass($msparser::MASS_TYPE_MONO),
$file->getCarbonMass($msparser::MASS_TYPE_AVE)
);
printf(
"NITROGEN:%5.5f,%5.5f\n",
$file->getNitrogenMass($msparser::MASS_TYPE_MONO),
$file->getNitrogenMass($msparser::MASS_TYPE_AVE)
);
printf(
"OXYGEN:%5.5f,%5.5f\n",
$file->getOxygenMass($msparser::MASS_TYPE_MONO),
$file->getOxygenMass($msparser::MASS_TYPE_AVE)
);
printf(
"ELECTRON:%5.7f\n",
$file->getElectronMass()
);
sub checkErrorHandler {
my ($obj) = @_;
print "Last error description \n";
print "=========================================\n";
print "Error: ", $obj->getLastErrorString(), "\n";
print "=========================================\n";
print "Testing the error handling... \n";
print "=========================================\n";
my $err = $obj->getErrorHandler();
my $i;
for my $i (1 .. $err->getNumberOfErrors) {
print "Error number: ";
print $err->getErrorNumber($i);
print " (";
print $err->getErrorRepeats($i) + 1;
print " times) : ";
print $err->getErrorString($i), "\n";
}
print "\n";
$obj->clearAllErrors();
}
=pod
Running the program as
perl -I../bin config_masses.pl ../config/masses
will give the following output under Mascot Server 2.3:
Name of the file: ../config/masses
-------------------------------------------------------------
--- Content of masses file ---
-------------------------------------------------------------
# Amino acid masses (monoisotopic and average)
A:71.03711,71.07790
B:114.53494,114.59500
C:103.00919,103.14290
D:115.02694,115.08740
E:129.04259,129.11400
F:147.06841,147.17390
G:57.02146,57.05130
H:137.05891,137.13930
I:113.08406,113.15760
J:0.00000,0.00000
K:128.09496,128.17230
L:113.08406,113.15760
M:131.04048,131.19610
N:114.04293,114.10260
O:0.00000,0.00000
P:97.05276,97.11520
Q:128.05858,128.12920
R:156.10111,156.18570
S:87.03203,87.07730
T:101.04768,101.10390
U:150.95363,150.03790
V:99.06841,99.13110
W:186.07931,186.20990
X:111.00000,111.00000
Y:163.06333,163.17330
Z:128.55059,128.62160
# Atomic masses used for terminus values
HYDROGEN:1.00783,1.00794
CARBON:12.00000,12.01070
NITROGEN:14.00307,14.00670
OXYGEN:15.99491,15.99940
ELECTRON:0.0005490
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_masses.java

config_masses.java

Read in the masses file.

/*
##############################################################################
# file: config_quantitation.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchi #
# Author: yuryr #
# Date: 2006/02/06 17:53:44 #
# Revision: 1.1 #
# NoKeywords:: #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class config_masses {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
if (argv.length < 1)
{
System.out.println("The location of masses file has to be specified as a parameter");
System.out.println("The location should either be the full path to the masses file");
System.out.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
System.exit(0);
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_masses file;
if (argv.length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setSessionID(argv[1]);
file = new ms_masses(argv[0], cs);
}
else
{
file = new ms_masses(argv[0]);
}
// unlike the other configuration files, it is possible to use ms_masses
// without specifying the filename - in which case it defaults to '../config/masses'\n";
if (!file.isValid())
{
System.out.println("Error when reading file: " + file.getFileName());
checkErrorHandler(file);
System.exit(0);
}
System.out.println("Name of the file: " + file.getFileName());
System.out.println("-------------------------------------------------------------");
System.out.println("--- Content of masses file ---");
System.out.println("-------------------------------------------------------------");
System.out.println("Amino acid masses (monoisotopic and average)");
// we need this object for outputting floating point numbers
String doubleFormat = "#####.#####";
java.text.DecimalFormat formatted = new java.text.DecimalFormat(doubleFormat);
char res;
for(res='A'; res <= 'Z'; res++)
{
System.out.print(res + ":");
System.out.print(formatted.format(file.getResidueMass(msparser.MASS_TYPE_MONO, res)));
System.out.print("," + formatted.format(file.getResidueMass(msparser.MASS_TYPE_AVE, res)));
System.out.println();
}
System.out.println();
System.out.println("# Atomic masses used for terminus values");
System.out.println("HYDROGEN:"
+ formatted.format(file.getHydrogenMass(msparser.MASS_TYPE_MONO))
+ ","
+ formatted.format(file.getHydrogenMass(msparser.MASS_TYPE_AVE)));
System.out.println("CARBON:"
+ formatted.format(file.getCarbonMass(msparser.MASS_TYPE_MONO))
+ ","
+ formatted.format(file.getCarbonMass(msparser.MASS_TYPE_AVE)));
System.out.println("NITROGEN:"
+ formatted.format(file.getNitrogenMass(msparser.MASS_TYPE_MONO))
+ ","
+ formatted.format(file.getNitrogenMass(msparser.MASS_TYPE_AVE)));
System.out.println("OXYGEN:"
+ formatted.format(file.getOxygenMass(msparser.MASS_TYPE_MONO))
+ ","
+ formatted.format(file.getOxygenMass(msparser.MASS_TYPE_AVE)));
System.out.println("ELECTRON:"
+ formatted.format(file.getElectronMass()));
}
static void checkErrorHandler(ms_masses file)
{
System.out.println("Testing the error handling... ");
System.out.println("=========================================");
System.out.println("Error string: " + file.getLastErrorString());
ms_errs errObject = file.getErrorHandler();
int numErrors = errObject.getNumberOfErrors();
System.out.println("Number of errors: " + numErrors);
int i;
for(i=1; i <= numErrors; i++)
{
System.out.println("Error number " + i + ": " + errObject.getErrorString(i));
}
file.clearAllErrors();
System.out.println("Cleared all errors - should have no errors left: " + file.getLastErrorString());
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar config_masses masses
Name of the file: ../config/masses
-------------------------------------------------------------
--- Content of masses file ---
-------------------------------------------------------------
Amino acid masses (monoisotopic and average)
A:71.03711,71.03711
B:114.53493,114.53493
C:103.00919,103.00919
D:115.02694,115.02694
E:129.04259,129.04259
F:147.06841,147.06841
G:57.02146,57.02146
H:137.05891,137.05891
I:113.08406,113.08406
J:0.00000,0.00000
K:128.09496,128.09496
L:113.08406,113.08406
M:131.04049,131.04049
N:114.04293,114.04293
O:0.00000,0.00000
P:97.05276,97.05276
Q:128.05858,128.05858
R:156.10111,156.10111
S:87.03203,87.03203
T:101.04768,101.04768
U:150.95364,150.95364
V:99.06841,99.06841
W:186.07931,186.07931
X:111.00000,111.00000
Y:163.06333,163.06333
Z:128.55059,128.55059
# Atomic masses used for terminus values
HYDROGEN:1.00783,1.00783
CARBON:12.00000,12.00000
NITROGEN:14.00307,14.00307
OXYGEN:15.99491,15.99491
ELECTRON:0.0005490
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_masses.py

config_masses.py

Read in the masses file.

1#!/usr/bin/python
2
17
18import msparser
19import sys
20if len(sys.argv) < 3:
21 print("Usage: %s UNIMOD SCHEMA [SESSION_ID]" % sys.argv[0])
22 print("UNIMOD is the file path to the unimod.xml file, e.g., ../config/unimod.xml or a fully formed URL such as http://www.matrixscience.com/cgi .")
23 print("SCHEMA is the unimod schema file path, e.g., ../html/xmlns/schema/unimod_2/unimod_2.xsd")
24 print("SESSION_ID is the session id. Only needed if UNIMOD is a URL.")
25 sys.exit(1)
26
27def checkErrorHandler(obj) :
28 print("Last error description ")
29 print("=========================================")
30 print("Error: %s" % obj.getLastErrorString())
31 print("=========================================")
32 print("Testing the error handling... ")
33 print("=========================================")
34
35 err = obj.getErrorHandler()
36
37 for i in range(1, 1 + err.getNumberOfErrors()) :
38 print("Error number: %d (%d times): %s" % (
39 err.getErrorNumber(i),
40 err.getErrorRepeats(i) + 1,
41 err.getErrorString(i)
42 ))
43
44 print(" ")
45
46 obj.clearAllErrors()
47
48# A sessionID can optionally be passed as the second parameter.
49# This will only be required if the 'file' is a URL.
50if len(sys.argv) > 3:
51 cs = msparser.ms_connection_settings()
52 cs.setSessionID(sys.argv[3])
53 umodFile = msparser.ms_umod_configfile(sys.argv[1], sys.argv[2], cs)
54else :
55 umodFile = msparser.ms_umod_configfile(sys.argv[1], sys.argv[2])
56file = msparser.ms_masses(umodFile)
57
58
59if not file.isValid() :
60 print("Error when reading file: %s" % file.getFileName())
61 checkErrorHandler(file)
62 sys.exit(1)
63
64
65print("Name of the file: %s" % file.getFileName())
66print("-------------------------------------------------------------")
67print("--- Content of masses file ---")
68print("-------------------------------------------------------------")
69print("# Amino acid masses (monoisotopic and average)")
70
71for i in range(0, 26) :
72 res = chr(ord('A') + i)
73 print("%1s:%5.5f,%5.5f" % (
74 res,
75 file.getResidueMass(msparser.MASS_TYPE_MONO, res),
76 file.getResidueMass(msparser.MASS_TYPE_AVE, res)
77 ))
78
79print (" ")
80print("# Atomic masses used for terminus values")
81
82print("HYDROGEN:%5.5f,%5.5f" % (
83 file.getHydrogenMass(msparser.MASS_TYPE_MONO),
84 file.getHydrogenMass(msparser.MASS_TYPE_AVE)
85 ))
86
87print("CARBON:%5.5f,%5.5f" % (
88 file.getCarbonMass(msparser.MASS_TYPE_MONO),
89 file.getCarbonMass(msparser.MASS_TYPE_AVE)
90 ))
91
92print("NITROGEN:%5.5f,%5.5f" % (
93 file.getNitrogenMass(msparser.MASS_TYPE_MONO),
94 file.getNitrogenMass(msparser.MASS_TYPE_AVE)
95 ))
96
97print("OXYGEN:%5.5f,%5.5f" % (
98 file.getOxygenMass(msparser.MASS_TYPE_MONO),
99 file.getOxygenMass(msparser.MASS_TYPE_AVE)
100 ))
101
102print("ELECTRON:%5.7f" % (
103 file.getElectronMass()
104 ))
105
106
107
108
109"""
110
111Running the program as
112
113python config_masses.pl /usr/local/mascot/config/masses
114
115will give the following output under Mascot Server 2.3:
116
117
118Name of the file: /usr/local/mascot/config/masses
119-------------------------------------------------------------
120--- Content of masses file ---
121-------------------------------------------------------------
122# Amino acid masses (monoisotopic and average)
123A:71.03711,71.07790
124B:114.53494,114.59500
125C:103.00919,103.14290
126D:115.02694,115.08740
127E:129.04259,129.11400
128F:147.06841,147.17390
129G:57.02146,57.05130
130H:137.05891,137.13930
131I:113.08406,113.15760
132J:0.00000,0.00000
133K:128.09496,128.17230
134L:113.08406,113.15760
135M:131.04048,131.19610
136N:114.04293,114.10260
137O:0.00000,0.00000
138P:97.05276,97.11520
139Q:128.05858,128.12920
140R:156.10111,156.18570
141S:87.03203,87.07730
142T:101.04768,101.10390
143U:150.95363,150.03790
144V:99.06841,99.13110
145W:186.07931,186.20990
146X:111.00000,111.00000
147Y:163.06333,163.17330
148Z:128.55059,128.62160
149
150# Atomic masses used for terminus values
151HYDROGEN:1.00783,1.00794
152CARBON:12.00000,12.01070
153NITROGEN:14.00307,14.00670
154OXYGEN:15.99491,15.99940
155ELECTRON:0.0005490
156
157
158"""
159
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_masses.cs

config_masses.cs

Read in the masses file.

/*
##############################################################################
# file: config_masses.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/config_masses.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class config_masses
{
public static void Main(string[] argv)
{
// ----- Object creation -----
if (argv.Length < 1)
{
Console.Error.WriteLine(@"The location of the masses file has to be specified as a parameter
The location should either be the full path to the masses file
or a URL to a Mascot server - e.g. http://mascot-searver/mascot/cgi
A Mascot security sessionID can optionally be passed as a second
parameter");
return;
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_masses file;
if (argv.Length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
cs.setSessionID(argv[1]);
file = new ms_masses(argv[0], cs);
}
else
{
file = new ms_masses(argv[0]);
}
// unlike the other configuration files, it is possible to use ms_masses
// without specifying the filename - in which case it defaults to '../config/masses'
if (!file.isValid())
{
Console.Error.WriteLine("Error when reading file {0}", file.getFileName());
checkErrorHandler(file);
return;
}
Console.WriteLine("Name of the file: {0}", file.getFileName());
Console.WriteLine("-------------------------------------------------------------");
Console.WriteLine("--- Content of masses file ---");
Console.WriteLine("-------------------------------------------------------------");
Console.WriteLine("Amino acid masses (monoisotopic and average)");
char res;
for (res = 'A'; res <= 'Z'; res++)
{
Console.WriteLine("{0}:{1:#####.00000},{2:#####.00000}", res,
file.getResidueMass(MASS_TYPE.MASS_TYPE_MONO, res),
file.getResidueMass(MASS_TYPE.MASS_TYPE_AVE, res));
}
Console.WriteLine();
Console.WriteLine("# Atomic masses used for terminus values");
Console.WriteLine("HYDROGEN:{0:#####.00000},{1:#####.00000}",
file.getHydrogenMass(MASS_TYPE.MASS_TYPE_MONO),
file.getHydrogenMass(MASS_TYPE.MASS_TYPE_AVE));
Console.WriteLine("CARBON:{0:#####.00000},{1:#####.00000}",
file.getCarbonMass(MASS_TYPE.MASS_TYPE_MONO),
file.getCarbonMass(MASS_TYPE.MASS_TYPE_AVE));
Console.WriteLine("NITROGEN:{0:#####.00000},{1:#####.00000}",
file.getNitrogenMass(MASS_TYPE.MASS_TYPE_MONO),
file.getNitrogenMass(MASS_TYPE.MASS_TYPE_AVE));
Console.WriteLine("OXYGEN:{0:#####.00000},{1:#####.00000}",
file.getOxygenMass(MASS_TYPE.MASS_TYPE_MONO),
file.getOxygenMass(MASS_TYPE.MASS_TYPE_AVE));
Console.WriteLine("ELECTRON:{0:####0.00000}",
file.getElectronMass());
}
private static void checkErrorHandler(ms_masses file)
{
Console.WriteLine("Testing the error handling... ");
Console.WriteLine("=========================================");
Console.WriteLine("Error string: {0}", file.getLastErrorString());
ms_errs errObject = file.getErrorHandler();
int numErrors = errObject.getNumberOfErrors();
Console.WriteLine("Number of errors: {0}", numErrors);
for (int i = 1; i <= numErrors; i++)
{
Console.WriteLine("Error number {0}: {1}", i, errObject.getErrorString(i));
}
file.clearAllErrors();
Console.WriteLine("Cleared all errors - should have no errors left: {0}", file.getLastErrorString());
}
}
}
/*
Running the program as
config_masses.exe c:\inetpub\mascot\config\masses
Will give the following output:
Name of the file: c:\inetpub\mascot\config\masses
-------------------------------------------------------------
--- Content of masses file ---
-------------------------------------------------------------
Amino acid masses (monoisotopic and average)
A:71.03711,71.07790
B:114.53494,114.59500
C:103.00919,103.14290
D:115.02694,115.08740
E:129.04259,129.11400
F:147.06841,147.17390
G:57.02146,57.05130
H:137.05891,137.13930
I:113.08406,113.15760
J:113.08406,113.15760
K:128.09496,128.17230
L:113.08406,113.15760
M:131.04049,131.19610
N:114.04293,114.10260
O:237.14773,237.29820
P:97.05276,97.11520
Q:128.05858,128.12920
R:156.10111,156.18570
S:87.03203,87.07730
T:101.04768,101.10390
U:150.95363,150.03790
V:99.06841,99.13110
W:186.07931,186.20990
X:111.00000,111.00000
Y:163.06333,163.17330
Z:128.55059,128.62160
# Atomic masses used for terminus values
HYDROGEN:1.00783,1.00794
CARBON:12.00000,12.01070
NITROGEN:14.00307,14.00670
OXYGEN:15.99491,15.99940
ELECTRON:0.00055
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_modfile.cpp

config_modfile.cpp

Read in the modifications file - modfile.

/*
##############################################################################
# file: config_modfile.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/config_modfile.cpp $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
int main(int argc, char * argv[])
{
if ( argc < 2 )
{
std::cout << "The location of modifications file has to be specified as a parameter" << std::endl;
std::cout << "The location should either be the full path to the modifications file" << std::endl;
std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
return 1;
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_connection_settings cs;
if (argc > 2)
{
cs.setSessionID(argv[2]);
}
// we need ms_masses class instance
// in practice, it has to be also read from a disc file
// but, for simplicity, we will use default masses
ms_masses massesFile;
ms_modfile file(argv[1], &massesFile, false, &cs);
if ( !file.isValid() )
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << file.getLastErrorString() << std::endl;
return 1;
}
int n = file.getNumberOfModifications();
std::cout << "There are " << n << " modifications configured:" << std::endl;
// now get'em all!
int i = 0;
for(i=0; i < n; i++)
{
std::cout << file.getModificationByNumber(i)->getTitle() << std::endl;
}
// Now change Acetyl (K)
ms_modification mod = *file.getModificationByName("Acetyl (K)");
mod.setHidden(true);
file.updateModificationByName("Acetyl (K)", mod);
// And delete Methyl (R)
file.deleteModificationByName("Methyl (R)");
//Finally, save the file under a new name - but only if not http:
if (strncmp("http:", argv[1], 5) != 0) {
std::string filename = argv[1];
filename += ".new";
file.setFileName(filename.c_str());
file.save_file();
}
std::cout << "There are now " << file.getNumberOfModifications() << " modifications configured:" << std::endl;
return 0;
}
/*
will give the output, for instance:
# config_modfile ../config/mod_file
There are 12 modifications configured:
Acetyl (N-term)
Acetyl (K)
Acetyl/Methyl (K)
Propionyl/Methyl (K)
Methyl (R)
Dimethyl (R)
Succininyl (K)
Succininyl+Methyl (K)
Biotinylated (N-term)
Biotinylated (K)
Carbamidomethyl (C)
Carbamyl (N-term)
*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_connection_settings::setSessionID
void setSessionID(const std::string sessionID)
Sets the Mascot security sessionID to be used for the connection.
Definition: ms_connection_settings.cpp:242
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_masses
Reads and parses the masses file with residue and atom masses.
Definition: ms_masses.hpp:48
matrix_science::ms_modfile
Use this class in order to read in the amino acid modification file.
Definition: ms_modfile.hpp:407
matrix_science::ms_modfile::updateModificationByName
bool updateModificationByName(const char *name, const ms_modification mod)
Update the information for a specific modification.
Definition: ms_modfile.cpp:1762
matrix_science::ms_modfile::save_file
void save_file()
Stores modification information in the file.
Definition: ms_modfile.cpp:1605
matrix_science::ms_modfile::getModificationByNumber
const ms_modification * getModificationByNumber(const int numMod) const
Returns a modification object by its number.
Definition: ms_modfile.cpp:1717
matrix_science::ms_modfile::getModificationByName
const ms_modification * getModificationByName(const char *nameMod) const
Returns a modification object by its name or NULL in case of not found.
Definition: ms_modfile.cpp:1725
matrix_science::ms_modfile::getNumberOfModifications
int getNumberOfModifications() const
Returns a number of modifications currently held in memory.
Definition: ms_modfile.cpp:1687
matrix_science::ms_modfile::setFileName
void setFileName(const char *name)
Call this member to set a custom file name to read from a different location.
Definition: ms_modfile.cpp:1129
matrix_science::ms_modfile::deleteModificationByName
bool deleteModificationByName(const char *name)
Remove a modification from the list in memory.
Definition: ms_modfile.cpp:1825
matrix_science::ms_modification
The class represents a single modification-entry in mod_file.
Definition: ms_modfile.hpp:134
matrix_science::ms_modification::setHidden
void setHidden(const bool value)
Sets the value of Hidden parameter.
Definition: ms_modfile.cpp:282
matrix_science::ms_modification::getTitle
std::string getTitle() const
Returns the modification title.
Definition: ms_modfile.cpp:171
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_modfile.pl

config_modfile.pl

Read in the modifications file - modfile.

#!/usr/local/bin/perl
##############################################################################
# file: config_modfile.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/config_modfile.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) {
print <<EOF;
The location of mod_file has to be specified as a parameter.
The location should either be the full path to the mod_file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
exit 1;
}
# We need an ms_masses object. In practice, it has to be read from a file but
# for simplicity, we will use default masses.
my $massesFile = new msparser::ms_masses;
# Note: $cs and $massesFile must not be lexically scoped; you need to keep them
# in scope for as long as you use $file. See "Using the toolkit from Perl,
# Java and Python" in Mascot Parser manual.
my ($file, $cs);
# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
$cs = new msparser::ms_connection_settings;
$cs->setSessionID($ARGV[1]);
$file = new msparser::ms_modfile($ARGV[0], $massesFile, 0, $cs);
} else {
$file = new msparser::ms_modfile($ARGV[0], $massesFile, 0);
}
if (!$file->isValid) {
print "There are errors. Cannot continue. The last error description:\n";
print $file->getLastErrorString(), "\n";
exit 1;
}
my $n = $file->getNumberOfModifications();
print "There are ", $n, " modifications configured:\n";
for my $i (0 .. $n-1) {
print $file->getModificationByNumber($i)->getTitle(), "\n";
}
# Now change Acetyl (K).
my $mod = $file->getModificationByName("Acetyl (K)");
$mod->setHidden(1);
$file->updateModificationByName("Acetyl (K)", $mod);
# And delete Methyl (R).
$file->deleteModificationByName("Methyl (R)");
# Finally, save the file under a new name.
$file->setFileName($ARGV[0] . ".new");
$file->save_file;
if (!$file->isValid) {
print "Failed to save: ", $file->getLastErrorString, "\n";
} else {
print $ARGV[0], ".new now has ", $file->getNumberOfModifications(), " modifications configured\n";
}
=pod
Running the program as
perl -I../bin config_modfile.pl ../config/mod_file
will give the following output under Mascot Server 2.3:
There are 886 modifications configured:
15dB-biotin (C)
2-succinyl (C)
2HPG (R)
3-deoxyglucosone (R)
3sulfo (N-term)
4-ONE (C)
4-ONE (H)
4-ONE (K)
4-ONE+Delta:H(-2)O(-1) (C)
4-ONE+Delta:H(-2)O(-1) (H)
4-ONE+Delta:H(-2)O(-1) (K)
4AcAllylGal (C)
a-type-ion (C-term)
AccQTag (K)
AccQTag (N-term)
Acetyl (C)
[ ... ]
Xlink:B10621 (C)
Xlink:DMP (K)
Xlink:DMP (Protein N-term)
Xlink:DMP-s (K)
Xlink:DMP-s (Protein N-term)
Xlink:novobiocin (N-term)
Xlink:SSD (K)
ZGB (K)
ZGB (N-term)
../config/mod_file.new now has 885 modifications configured
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_modfile.java

config_modfile.java

Read in the modifications file - modfile.

/*
##############################################################################
# file: config_quantitation.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchi #
# Author: yuryr #
# Date: 2006/02/06 17:53:44 #
# Revision: 1.1 #
# NoKeywords:: #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class config_modfile {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
if (argv.length < 1)
{
System.out.println("The location of mod_file has to be specified as a parameter");
System.out.println("The location should either be the full path to the mod_file");
System.out.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
System.exit(0);
}
// we need ms_masses class instance
// in practice, it has to be also read from a disc file
// but, for simplicity, we will use default masses
ms_masses massesFile = new ms_masses();
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_modfile file;
if (argv.length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setSessionID(argv[1]);
file = new ms_modfile(argv[0], massesFile, false, cs);
}
else
{
file = new ms_modfile(argv[0], massesFile, false);
}
if (!file.isValid())
{
System.out.println("There are errors. Cannot continue. The last error description:");
System.out.println(file.getLastErrorString());
System.exit(0);
}
int n = file.getNumberOfModifications();
System.out.println("There are " + n + " modifications configured:");
// now get'em all!
for (int i=0; i < n; i++)
{
System.out.println(file.getModificationByNumber(i).getTitle());
}
// Now change Acetyl (K)
ms_modification mod = file.getModificationByName("Acetyl (K)");
mod.setHidden(true);
file.updateModificationByName("Acetyl (K)", mod);
// And delete Methyl (R)
file.deleteModificationByName("Methyl (R)");
// Finally, save the file under a new name
file.setFileName(argv[0] + ".new");
file.save_file();
System.out.println("There are now " + file.getNumberOfModifications() + " modifications configured:");
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar config_modfile mod_file
There are 12 modifications configured:
Acetyl (N-term)
Acetyl (K)
Acetyl/Methyl (K)
Propionyl/Methyl (K)
Methyl (R)
Dimethyl (R)
Succininyl (K)
Succininyl+Methyl (K)
Biotinylated (N-term)
Biotinylated (K)
Carbamidomethyl (C)
Carbamyl (N-term)
...
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_modfile.py

config_modfile.py

Read in the modifications file - modfile.

1#!/usr/bin/python
2
16
17import msparser
18import sys
19
20if len(sys.argv) < 3:
21 print("Usage: %s UNIMOD SCHEMA" % sys.argv[0])
22 print("UNIMOD is the file path to the unimod.xml file, e.g., ../config/unimod.xml or a fully formed URL such as http://www.matrixscience.com/cgi .")
23 print("SCHEMA is the unimod schema file path, e.g., ../html/xmlns/schema/unimod_2/unimod_2.xsd")
24 sys.exit(1)
25
26umodFile = msparser.ms_umod_configfile(sys.argv[1], sys.argv[2])
27file = msparser.ms_modfile(umodFile)
28
29if not file.isValid() :
30 print("There are errors. Cannot continue. The last error description:")
31 print(file.getLastErrorString())
32 sys.exit(1)
33
34n = file.getNumberOfModifications()
35print("There are %d modifications configured:" % n)
36
37for i in range(n) :
38 print(file.getModificationByNumber(i).getTitle())
39
40
41# Now change Acetyl (K).
42mod = file.getModificationByName("Acetyl (K)")
43mod.setHidden(True)
44file.updateModificationByName("Acetyl (K)", mod)
45
46# And delete Methyl (R).
47file.deleteModificationByName("Methyl (R)")
48
49# Finally, save the file under a new name.
50file.setFileName(sys.argv[1] + ".new")
51file.save_file()
52
53if not file.isValid() :
54 print("Failed to save: %s" % file.getLastErrorString())
55else :
56 print("%s.new now has %d modifications configured" % (sys.argv[1], file.getNumberOfModifications()))
57
58
59
60"""
61
62Running the program as
63
64python config_modfile.py ../config/unimod.xml ../html/xmlns/schema/unimod_2/unimod_2.xsd
65
66will give the following output under Mascot Server 2.3:
67
68
69There are 886 modifications configured:
7015dB-biotin (C)
712-succinyl (C)
722HPG (R)
733-deoxyglucosone (R)
743sulfo (N-term)
754-ONE (C)
764-ONE (H)
774-ONE (K)
784-ONE+Delta:H(-2)O(-1) (C)
794-ONE+Delta:H(-2)O(-1) (H)
804-ONE+Delta:H(-2)O(-1) (K)
814AcAllylGal (C)
82a-type-ion (C-term)
83AccQTag (K)
84AccQTag (N-term)
85Acetyl (C)
86 [...]
87Xlink:B10621 (C)
88Xlink:DMP (K)
89Xlink:DMP (Protein N-term)
90Xlink:DMP-s (K)
91Xlink:DMP-s (Protein N-term)
92Xlink:novobiocin (N-term)
93Xlink:SSD (K)
94ZGB (K)
95ZGB (N-term)
96/usr/local/mascot/config/mod_file.new now has 885 modifications configured
97
98
99"""
100
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_modfile.cs

config_modfile.cs

Read in the modifications file - modfile.

/*
##############################################################################
# file: config_modfile.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/config_modfile.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class config_modfile
{
public static void Main(string[] argv)
{
if (argv.Length < 1)
{
Console.WriteLine(@"The location of the mod_file has to be specified as a parameter
The location should either be the full path to the mod file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi.
A Mascot security sessionID can optionally be passed as a second
parameter");
return;
}
// we need ms_masses class instance
// in practive, it has to be also read from a disc file
// but, for simplicity, we will use default masses
ms_masses massesFile = new ms_masses();
// A sessionID can optionally be passed as the second
// parameter. This will only be required if the 'file' is a URL
ms_modfile file;
if (argv.Length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
cs.setSessionID(argv[1]);
file = new ms_modfile(argv[0], massesFile, false, cs);
}
else
{
file = new ms_modfile(argv[0], massesFile, false);
}
if (!file.isValid())
{
Console.WriteLine("There are errors. Cannot continue. The last error description:");
Console.WriteLine(file.getLastErrorString());
return;
}
int n = file.getNumberOfModifications();
Console.WriteLine("There are {0} modifications configured:", n);
// now get 'em all!
for (int i = 0; i < n; i++)
{
Console.WriteLine(file.getModificationByNumber(i).getTitle());
}
// Now change Acetyl (K)
ms_modification mod = file.getModificationByName("Acetyl (K)");
mod.setHidden(true);
file.updateModificationByName("Acetyl (K)", mod);
// And delete Methyl
file.deleteModificationByName("Methyl (R)");
// Finally, save the file under a new name
if (argv[0].ToLower().StartsWith("http"))
{
file.setFileName("copy_enzymes.new");
}
else
{
//create a new file locally
file.setFileName(argv[0] + ".new");
}
file.save_file();
Console.WriteLine("There are now " + file.getNumberOfModifications() + " modifications configured.");
}
}
}
/*
Running the program as:
config_modfile.exe c:\inetpub\mascot\config\mod_file
Will give the following output:
There are 1268 modifications configured:
2-dimethylsuccinyl (C)
2-monomethylsuccinyl (C)
2-nitrobenzyl (Y)
2-succinyl (C)
2HPG (R)
3-deoxyglucosone (R)
3-phosphoglyceryl (K)
3sulfo (N-term)
4-ONE (C)
4-ONE (H)
4-ONE (K)
4-ONE+Delta:H(-2)O(-1) (C)
4-ONE+Delta:H(-2)O(-1) (H)
4-ONE+Delta:H(-2)O(-1) (K)
4AcAllylGal (C)
a-type-ion (C-term)
AccQTag (K)
AccQTag (N-term)
Acetyl (C)
[...]
Xlink:B10621 (C)
Xlink:DMP (K)
Xlink:DMP (Protein N-term)
Xlink:DMP-de (K)
Xlink:DMP-de (Protein N-term)
Xlink:DMP-s (K)
Xlink:DMP-s (Protein N-term)
Xlink:DSS (K)
Xlink:DSS (Protein N-term)
Xlink:DST (K)
Xlink:DST (Protein N-term)
Xlink:DTSSP (K)
Xlink:DTSSP (Protein N-term)
Xlink:EGS (K)
Xlink:EGS (Protein N-term)
Xlink:EGScleaved (K)
Xlink:EGScleaved (Protein N-term)
Xlink:SMCC (C)
Xlink:SSD (K)
ZGB (K)
ZGB (N-term)
There are now 1267 modifications configured.
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_procs.cpp

config_procs.cpp

Determine computer processor information.

/*
##############################################################################
# file: config_procs.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/config_procs.cpp $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
int main(int argc, char * argv[])
{
// Don't check for Linux hyperthreading, assume 4 cpu license
ms_processors cpus(false, 1);
if ( !cpus.isValid() )
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << cpus.getLastErrorString() << std::endl;
return 1;
}
std::cout << "Number of CPUS available on the system: " << cpus.getNumOnSystem() << std::endl;
return 0;
}
/*
will give the output, for instance:
# config_procs
Number of CPUS available on the system: 2
*/
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_processors
This class is designed to retrieve current CPU configuration on the computer and set affinity.
Definition: ms_processors.hpp:50
matrix_science::ms_processors::getNumOnSystem
int getNumOnSystem() const
Returns the number of logical CPUs installed in the system.
Definition: ms_processors.cpp:69
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_procs.pl

config_procs.pl

Determine computer processor information.

#!/usr/local/bin/perl
##############################################################################
# file: config_procs.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/config_procs.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
# When running under Linux 2.4, don't set to 1 unless you are prepared to wait.
my $checkLinuxHT = 0;
my $numLicensed = 1;
my $cpus = new msparser::ms_processors($checkLinuxHT, $numLicensed);
if (!$cpus->isValid) {
print "There are errors. Cannot continue. The last error description:\n";
print $cpus->getLastErrorString(), "\n";
exit 1;
}
print "Number of CPUS available on the system: ", $cpus->getNumOnSystem(), "\n";
=pod
Running the program, for example with
perl -I../bin config_procs.pl
will give the following output (depending on the number of processors on your
system):
Number of CPUS available on the system: 4
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_procs.java

config_procs.java

Determine computer processor information.

/*
##############################################################################
# file: config_quantitation.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchi #
# Author: yuryr #
# Date: 2006/02/06 17:53:44 #
# Revision: 1.1 #
# NoKeywords:: #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class config_procs {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// Don't check for Linux hyperthreading
ms_processors cpus = new ms_processors(false, 1);
if (!cpus.isValid())
{
System.out.println("There are errors. Cannot continue. The last error description:");
System.out.println(cpus.getLastErrorString());
System.exit(0);
}
System.out.println("Number of CPUS available on the system: " + cpus.getNumOnSystem());
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar config_procs
Number of CPUS available on the system: 2
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_procs.py

config_procs.py

Determine computer processor information.

1#!/usr/bin/python
2
16
17import msparser
18
19# When running under Linux 2.4, don't set to True unless you are prepared to wait.
20checkLinuxHT = False
21numLicensed = 1
22cpus = msparser.ms_processors(checkLinuxHT, numLicensed)
23
24if not cpus.isValid() :
25 print("There are errors. Cannot continue. The last error description:")
26 print(cpus.getLastErrorString())
27 sys.exit(1)
28
29print("Number of CPUS available on the system: %d" % cpus.getNumOnSystem())
30
31
32"""
33
34Running the program, for example with
35
36python config_procs.pl
37
38will give the following output (depending on the number of processors on your
39system):
40
41
42Number of CPUS available on the system: 4
43
44
45"""
46
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_procs.cs

config_procs.cs

Determine computer processor information.

/*
##############################################################################
# file: config_modprocs.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/config_procs.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class config_procs
{
public static void Main(string[] argv)
{
// Don't check for Linux hyperthreading
ms_processors cpus = new ms_processors(false, 1);
if (!cpus.isValid())
{
Console.WriteLine("There are errors. Cannot continue. The last error description:");
Console.WriteLine(cpus.getLastErrorString());
return;
}
Console.WriteLine("Number of CPUs available on the system: {0}", cpus.getNumOnSystem());
}
}
}
/*
Running the program as
config_procs.exe
On a dual core Microsoft Windows system with hyperthreading will give the following output:
Number of CPUs available on the system: 4
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_taxonomy.cpp

config_taxonomy.cpp

Read in the taxonomy file.

/*
##############################################################################
# file: config_taxonomy.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/config_taxonomy.cpp $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
int main(int argc, char * argv[])
{
if ( argc < 2 )
{
std::cout << "The location of taxonomy file has to be specified as a parameter" << std::endl;
std::cout << "The location should either be the full path to the taxonomy file" << std::endl;
std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
return 1;
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_connection_settings cs;
if (argc > 2)
{
cs.setSessionID(argv[2]);
}
ms_taxonomyfile file(argv[1], &cs);
if (!file.isValid())
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << file.getLastErrorString() << std::endl;
return 1;
}
int n = file.getNumberOfEntries();
std::cout << "There are " << n << " taxonomy choice entries configured:" << std::endl;
// now get'em all!
int i = 0;
for(i=0; i < n; i++)
{
std::cout << file.getEntryByNumber(i)->getTitle() << std::endl;
std::cout << "Include: ";
int j;
for(j=0; j < file.getEntryByNumber(i)->getNumberOfIncludeTaxonomies(); j++)
{
if ( j > 0 )
std::cout << ",";
std::cout << file.getEntryByNumber(i)->getIncludeTaxonomy(j);
}
std::cout << std::endl;
std::cout << "Exclude: ";
for(j=0; j < file.getEntryByNumber(i)->getNumberOfExcludeTaxonomies(); j++)
{
if ( j > 0 )
std::cout << ",";
std::cout << file.getEntryByNumber(i)->getExcludeTaxonomy(j);
}
std::cout << std::endl;
}
return 0;
}
/*
will give the output, for instance:
# config_taxonomy ../config/taxonomy
There are 64 taxonomy choice entries configured:
All entries
Include: 1
Exclude: 0
. . Archaea (Archaeobacteria)
Include: 2157
Exclude:
. . Eukaryota (eucaryotes)
Include: 2759
Exclude:
. . . . Alveolata (alveolates)
Include: 33630
Exclude:
. . . . . . Plasmodium falciparum (malaria parasite)
Include: 5833
Exclude:
. . . . . . Other Alveolata
Include: 33630
Exclude: 5833
...
*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_connection_settings::setSessionID
void setSessionID(const std::string sessionID)
Sets the Mascot security sessionID to be used for the connection.
Definition: ms_connection_settings.cpp:242
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_taxonomychoice::getIncludeTaxonomy
int getIncludeTaxonomy(const int n) const
Traverse the included taxonomy IDs.
Definition: ms_taxonomyfile.cpp:107
matrix_science::ms_taxonomychoice::getTitle
std::string getTitle() const
Returns the taxonomy choice title.
Definition: ms_taxonomyfile.cpp:91
matrix_science::ms_taxonomychoice::getExcludeTaxonomy
int getExcludeTaxonomy(const int n) const
Traverse the excluded taxonomy IDs.
Definition: ms_taxonomyfile.cpp:141
matrix_science::ms_taxonomyfile
Use this class in order to read in a taxonomy file.
Definition: ms_taxonomyfile.hpp:145
matrix_science::ms_taxonomyfile::getNumberOfEntries
int getNumberOfEntries() const
Returns a number of taxonomy choices currently held in memory.
Definition: ms_taxonomyfile.cpp:469
matrix_science::ms_taxonomyfile::getEntryByNumber
const ms_taxonomychoice * getEntryByNumber(const int index) const
Returns a taxonomy choice entry by its number.
Definition: ms_taxonomyfile.cpp:493
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_taxonomy.pl

config_taxonomy.pl

Read in the taxonomy file.

#!/usr/local/bin/perl
##############################################################################
# file: config_taxonomy.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/config_taxonomy.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) {
print <<EOF;
The location of taxonomy file has to be specified as a parameter.
The location should either be the full path to the taxonomy file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
exit 1;
}
# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);
# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
$cs = new msparser::ms_connection_settings;
$cs->setSessionID($ARGV[1]);
$file = new msparser::ms_taxonomyfile($ARGV[0], $cs);
} else {
$file = new msparser::ms_taxonomyfile($ARGV[0]);
}
if (!$file->isValid) {
print "There are errors. Cannot continue. The last error description:\n";
print $file->getLastErrorString(), "\n";
exit 1;
}
my $n = $file->getNumberOfEntries;
print "There are ", $n, " taxonomy choice entries configured:\n";
for my $i (0 .. $n-1) {
my $entry = $file->getEntryByNumber($i);
print $entry->getTitle() . "\n";
print "Include: ";
print join(', ',
map { $entry->getIncludeTaxonomy($_) }
0 .. $entry->getNumberOfIncludeTaxonomies - 1
);
print "\n";
print "Exclude: ";
print join(', ',
map { $entry->getExcludeTaxonomy($_) }
0 .. $entry->getNumberOfExcludeTaxonomies - 1
);
print "\n";
}
=pod
Running the program as
perl -I../bin config_taxonomy.pl ../config/taxonomy
will give the following output under Mascot Server 2.3:
There are 65 taxonomy choice entries configured:
All entries
Include: 1
Exclude: 0
. . Archaea (Archaeobacteria)
Include: 2157
Exclude:
. . Eukaryota (eucaryotes)
Include: 2759
Exclude:
. . . . Alveolata (alveolates)
Include: 33630
Exclude:
. . . . . . Plasmodium falciparum (malaria parasite)
Include: 5833
Exclude:
. . . . . . Other Alveolata
Include: 33630
Exclude: 5833
[ ... ]
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_taxonomy.java

config_taxonomy.java

Read in the taxonomy file.

/*
##############################################################################
# file: config_quantitation.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchi #
# Author: yuryr #
# Date: 2006/02/06 17:53:44 #
# Revision: 1.1 #
# NoKeywords:: #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class config_taxonomy
{
static
{
try
{
System.loadLibrary("msparserj");
}
catch (UnsatisfiedLinkError e)
{
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
if (argv.length < 1)
{
System.out.println("The location of taxonomy file has to be specified as a parameter");
System.out.println("The location should either be the full path to the taxonomy file");
System.out.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
System.exit(0);
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_taxonomyfile file;
if (argv.length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setSessionID(argv[1]);
file = new ms_taxonomyfile(argv[0], cs);
}
else
{
file = new ms_taxonomyfile(argv[0]);
}
if (!file.isValid())
{
System.out.println("There are errors. Cannot continue. The last error description:");
System.out.println(file.getLastErrorString());;
System.exit(0);
}
int n = file.getNumberOfEntries();
System.out.println("There are " + n + " taxonomy choice entries configured:");
// now get'em all!
for (int i=0; i < n; i++)
{
System.out.println(file.getEntryByNumber(i).getTitle());
System.out.print("Include: ");
for (int j=0; j < file.getEntryByNumber(i).getNumberOfIncludeTaxonomies(); j++)
{
if (j > 0)
{
System.out.print(",");
}
System.out.print(file.getEntryByNumber(i).getIncludeTaxonomy(j));
}
System.out.println();
System.out.print("Exclude: ");
for (int j=0; j < file.getEntryByNumber(i).getNumberOfExcludeTaxonomies(); j++)
{
if (j > 0)
{
System.out.print(",");
}
System.out.print(file.getEntryByNumber(i).getExcludeTaxonomy(j));
}
System.out.println();
}
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar config_taxonomy taxonomy
There are 64 taxonomy choice entries configured:
All entries
Include: 1
Exclude: 0
. . Archaea (Archaeobacteria)
Include: 2157
Exclude:
. . Eukaryota (eucaryotes)
Include: 2759
Exclude:
. . . . Alveolata (alveolates)
Include: 33630
Exclude:
. . . . . . Plasmodium falciparum (malaria parasite)
Include: 5833
Exclude:
. . . . . . Other Alveolata
Include: 33630
Exclude: 5833
...
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_taxonomy.py

config_taxonomy.py

Read in the taxonomy file.

1#!/usr/bin/python
2
16
17import msparser
18import sys
19
20if len(sys.argv) < 2 :
21 print("""
22The location of taxonomy file has to be specified as a parameter.
23The location should either be the full path to the taxonomy file
24or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
25""")
26 sys.exit(1)
27
28# A sessionID can optionally be passed as the second parameter.
29# This will only be required if the 'file' is a URL.
30if len(sys.argv) > 2 :
31 cs = msparser.ms_connection_settings()
32 cs.setSessionID(sys.argv[2])
33 file = msparser.ms_taxonomyfile(sys.argv[1], cs)
34else :
35 file = msparser.ms_taxonomyfile(sys.argv[1])
36
37if not file.isValid() :
38 print("There are errors. Cannot continue. The last error description:")
39 print(file.getLastErrorString())
40 sys.exit(1)
41
42n = file.getNumberOfEntries()
43print("There are %d taxonomy choice entries configured:" % n)
44
45for i in range(n) :
46 entry = file.getEntryByNumber(i)
47 print(entry.getTitle())
48
49 tax = []
50 for i in range(entry.getNumberOfIncludeTaxonomies()) :
51 tax.append("%d" % entry.getIncludeTaxonomy(i))
52
53 print("Include: " + ', '.join(tax))
54
55 tax = []
56 for i in range(entry.getNumberOfExcludeTaxonomies()) :
57 tax.append("%d" % entry.getExcludeTaxonomy(i))
58
59 print("Exclude: " + ', '.join(tax))
60
61
62
63"""
64
65Running the program as
66
67python config_taxonomy.pl /usr/local/mascot/config/taxonomy
68
69will give the following output under Mascot Server 2.3:
70
71
72There are 65 taxonomy choice entries configured:
73All entries
74Include: 1
75Exclude: 0
76. . Archaea (Archaeobacteria)
77Include: 2157
78Exclude:
79. . Eukaryota (eucaryotes)
80Include: 2759
81Exclude:
82. . . . Alveolata (alveolates)
83Include: 33630
84Exclude:
85. . . . . . Plasmodium falciparum (malaria parasite)
86Include: 5833
87Exclude:
88. . . . . . Other Alveolata
89 [ ... ]
90
91"""
92
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_taxonomy.cs

config_taxonomy.cs

Read in the taxonomy file.

/*
##############################################################################
# file: config_taxonomy.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/config_taxonomy.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class config_taxonomy
{
public static void Main(string[] argv)
{
if (argv.Length < 1)
{
Console.WriteLine(@"The location of the taxonomy file has to be specified as a parameter
The location should either be the full path to the taxonomy file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi.
A Mascot security sessionID can optionally be passed as a second
parameter");
return;
}
// A sessionID can optionally be passed as the second parameter
// This will only be required if the 'file' is a URL
ms_taxonomyfile file;
if (argv.Length > 1)
{
ms_connection_settings cs = new ms_connection_settings();
cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
cs.setSessionID(argv[1]);
file = new ms_taxonomyfile(argv[0], cs);
}
else
{
file = new ms_taxonomyfile(argv[0]);
}
if (!file.isValid())
{
Console.WriteLine("There are errors. Cannot continue. The last error description:");
Console.WriteLine(file.getLastErrorString());
return;
}
int n = file.getNumberOfEntries();
Console.WriteLine("There are {0} taxonomy choice entries configured:", n);
// now get them all!
for (int i = 0; i < n; i++)
{
Console.WriteLine(file.getEntryByNumber(i).getTitle());
Console.Write("Include: ");
for (int j = 0; j < file.getEntryByNumber(i).getNumberOfIncludeTaxonomies(); j++)
{
if (j > 0) Console.Write(",");
Console.Write(file.getEntryByNumber(i).getIncludeTaxonomy(j));
}
Console.WriteLine();
Console.Write("Exclude: ");
for (int j = 0; j < file.getEntryByNumber(i).getNumberOfExcludeTaxonomies(); j++)
{
if (j > 0) Console.Write(",");
Console.Write(file.getEntryByNumber(i).getExcludeTaxonomy(j));
}
Console.WriteLine();
}
}
}
}
/*
config_taxonomy.exe c:\inetpub\mascot\config\taxonomy
Will give the following output:
There are 65 taxonomy choice entries configured:
All entries
Include: 1
Exclude: 0
. . Archaea (Archaeobacteria)
Include: 2157
Exclude:
. . Eukaryota (eucaryotes)
Include: 2759
Exclude:
. . . . Alveolata (alveolates)
Include: 33630
Exclude:
. . . . . . Plasmodium falciparum (malaria parasite)
Include: 5833
Exclude:
. . . . . . Other Alveolata
Include: 33630
Exclude: 5833
[...]
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_quantitation.cpp

config_quantitation.cpp

Example program for reading and manipulating the quantitation.xml file.

/*
##############################################################################
# file: config_quantitation.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/config_quantitation.cpp $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
int main(int argc, char * argv[])
{
if ( argc < 3 )
{
std::cout << "The location of quantitation.xml file has to be specified as a parameter" << std::endl;
std::cout << "The location should either be the full path to the file" << std::endl;
std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
std::cout << "The second parameter should specify schema file path, for instance C:\\quantitation_1.xsd" << std::endl;
std::cout << "It should be either relative to the local quantitation.xml path or to the current folder" << std::endl;
return 1;
}
// A sessionID can optionally be passed as the third parameter
// This will only be required if the 'file' is a URL
ms_connection_settings cs;
if (argc > 3)
{
cs.setSessionID(argv[3]);
}
ms_quant_configfile file(argv[1], argv[2], &cs);
if (!file.isValid())
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << file.getLastErrorString() << std::endl;
return 1;
}
int n = file.getNumberOfMethods();
std::cout << "There are " << n << " methods available:" << std::endl;
// now get'em all!
int i = 0;
for(i=0; i < n; i++)
{
std::cout << file.getMethodByNumber(i)->getName() << std::endl;
}
// now try to retrieve typeinfo from the schema file
ms_xml_schema schemaFile;
schemaFile.setFileName(argv[2]);
schemaFile.read_file();
if (!schemaFile.isValid())
{
std::cout << "Errors while reading schema-file. The last error description:" << std::endl;
std::cout << schemaFile.getLastErrorString() << std::endl;
return 1;
}
// validate the original document
std::string strValidationErrors = file.validateDocument();
if ( !strValidationErrors.empty() )
{
printf("Initial document validation errors: %s\n", strValidationErrors.c_str());
}
// the document can be validated programmatically
// but it is not schema-validation!!!
for(i = 0; i < n; i++)
{
// Shallow validation: we check only presence of required attributes and elements
const ms_quant_method *pMethod = file.getMethodByNumber(i);
std::string strErrors = pMethod->validateShallow(&schemaFile); // pass the schema object as a parameter
if ( !strErrors.empty() )
{
printf("Method %s\n", pMethod->getName().c_str());
printf("Shallow validation errors: %s\n\n", strErrors.c_str());
}
// Deep validation: we check attributes and elements recursively applying basic constraints
strErrors = pMethod->validateDeep(&schemaFile);
if ( !strErrors.empty() )
{
printf("Method %s\n", pMethod->getName().c_str());
printf("Deep validation errors: %s\n\n", strErrors.c_str());
}
}
// create a new invalid document
ms_quant_configfile configFileInvalid;
// copy the first method from the original file (method "null")
ms_quant_method myMethodInvalid(*file.getMethodByNumber(0));
myMethodInvalid.setName(""); // invalid name with less than allowed string length
// one way to validate an object
// 1. shallow validation - only presence of attributes and elements is checked
std::string strErr1 = myMethodInvalid.validateShallow(&schemaFile);
printf("shallow validation of a method: %s\n", strErr1.c_str());
// 2. deep validation - data types of attributes and elements are checked and a base type too
std::string strErr2 = myMethodInvalid.validateDeep(&schemaFile);
printf("deep validation of a method: %s\n", strErr2.c_str());
// another way to validate an object - by using schema-object (not schema-document!!!)
// the result is absolutely equivalent to the previous call
std::string strErr3 = schemaFile.validateComplexObject(&myMethodInvalid, true); // "true" for deep validation
printf("deep validation using schema-object: %s\n", strErr3.c_str());
// one can validate an attribute separately
// also methods validateSimpleInteger(), validateSimpleDouble() and validateSimpleBool() can be used
std::string strErr4 = schemaFile.validateSimpleString(myMethodInvalid.getName().c_str(), // attribute value
myMethodInvalid.getNameSchemaType().c_str()); // attribute data type
printf("attribute validation: %s\n", strErr4.c_str());
// and finally, the whole document validation
configFileInvalid.appendMethod(&myMethodInvalid);
std::string errMethod = configFileInvalid.validateDocument();
printf("document validation errors: %s\n", errMethod.c_str());
// however, the config-file object itself stays valid
if (!configFileInvalid.isValid())
{
std::cout << "Errors in config-file object. The last error description:" << std::endl;
std::cout << configFileInvalid.getLastErrorString() << std::endl;
}
// file is going to be saved even if its invalid
// but the errors will be stored in the config-file object and the object will become invalid
configFileInvalid.setFileName("quantitation_temp.xml"); // give it another name
configFileInvalid.save_file();
if (!configFileInvalid.isValid())
{
std::cout << "Errors in config-file object. The last error description:" << std::endl;
std::cout << configFileInvalid.getLastErrorString() << std::endl;
}
return 0;
}
/*
will give the output, for instance:
# config_quantitation ../config/quantitation.xml quantitation_1.xsd
There are 10 methods available:
None
iTRAQ
ICAT C+9
ICPL C+6 pre-digest
ICPL C+6 post-digest
SILAC K+6 R+10
18O corrected, single scan
18O simple, single scan
SILAC K+6 R+4 multiplex
15N Metabolic
shallow validation of a method:
deep validation of a method: Attribute 'name' -> String is shorter than minLength-limit
deep validation using schema-object: Attribute 'name' -> String is shorter than minLength-limit
attribute validation: String is shorter than minLength-limit
document validation errors: XML library failure with error: quantitation.xml: line 4, col 240 - Datatype error: Type:InvalidDatatypeValueException, Message:Value '' with length '0' is less than minimum length facet of '1' .
Errors in config-file object. The last error description:
Failed to save quantitation configuration file
*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_connection_settings::setSessionID
void setSessionID(const std::string sessionID)
Sets the Mascot security sessionID to be used for the connection.
Definition: ms_connection_settings.cpp:242
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_quant_configfile
Use this class in order to read/write quantitation.xml.
Definition: ms_quant_configfile.hpp:52
matrix_science::ms_quant_configfile::getNumberOfMethods
int getNumberOfMethods() const
Returns a number of quantitation methods currently held in memory.
Definition: ms_quant_configfile.cpp:294
matrix_science::ms_quant_configfile::save_file
void save_file()
Stores modification information in the file.
Definition: ms_quant_configfile.cpp:245
matrix_science::ms_quant_configfile::validateDocument
std::string validateDocument() const
Validates the whole document against the schema and return errors as a string.
Definition: ms_quant_configfile.cpp:286
matrix_science::ms_quant_configfile::appendMethod
void appendMethod(const ms_quant_method *item)
Adds a new quantitation method at the end of the list.
Definition: ms_quant_configfile.cpp:310
matrix_science::ms_quant_configfile::getMethodByNumber
const ms_quant_method * getMethodByNumber(const int idx) const
Returns a quantitation method object by its number.
Definition: ms_quant_configfile.cpp:319
matrix_science::ms_quant_configfile::setFileName
void setFileName(const char *name)
Call this member to set a custom file name to read from a different location.
Definition: ms_quant_configfile.cpp:123
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_quant_method::validateShallow
virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.
Definition: ms_quant_method.cpp:120
matrix_science::ms_quant_method::getName
std::string getName() const
Returns the value of the name attribute.
Definition: ms_quant_method.cpp:923
matrix_science::ms_quant_method::setName
void setName(const char *value)
Set a custom value for the name attribute.
Definition: ms_quant_method.cpp:931
matrix_science::ms_quant_method::validateDeep
virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
Definition: ms_quant_method.cpp:148
matrix_science::ms_quant_method::getNameSchemaType
std::string getNameSchemaType() const
Obtain a symbolic name for the "name attribute" schema type.
Definition: ms_quant_method.cpp:950
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_quantitation.pl

config_quantitation.pl

Example program for reading and manipulating the quantitation.xml file.

#!/usr/local/bin/perl
##############################################################################
# file: config_quantitation.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/config_quantitation.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0])) {
print <<EOF;
The location of quantitation.xml file has to be specified as a parameter.
The location should either be the full path to the quantitation.xml file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
exit 1;
}
if (!defined($ARGV[1])) {
print <<EOF;
The location of schema file quantitation_XXX.xsd has to be specified as the
second parameter. The location should only be a full or relative path to the
quantitation_XXX.xsd file.
EOF
exit 1;
}
# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);
# A sessionID can optionally be passed as the third parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[2])) {
$cs = new msparser::ms_connection_settings;
$cs->setSessionID($ARGV[2]);
$file = new msparser::ms_quant_configfile($ARGV[0], $ARGV[1], $cs);
} else {
$file = new msparser::ms_quant_configfile($ARGV[0], $ARGV[1]);
}
if (!$file->isValid) {
print "There are errors. Cannot continue. The last error description:\n";
print $file->getLastErrorString(), "\n";
exit 1;
}
my $n = $file->getNumberOfMethods;
print "There are ", $n, " quantitation methods available:\n";
for my $i (0 .. $n-1) {
print $file->getMethodByNumber($i)->getName(), "\n";
}
# Validate the original document.
if (my $errs = $file->validateDocument())
{
print "Initial document validation errors:\n";
print $errs, "\n";
}
# Now try to read in the schema file.
my $schemaFile = new msparser::ms_xml_schema;
$schemaFile->setFileName($ARGV[1]);
$schemaFile->read_file;
if (!$schemaFile->isValid) {
print "Errors while reading schema-file. The last error description:\n";
print $schemaFile->getLastErrorString(), "\n";
exit 1;
}
# The document can be validated programmatically, but this is different from
# real validation against a schema. We'll validate each quantitation
# method separately.
for my $i (0 .. $n-1) {
# Shallow validation: only check the presence of required attributes and
# elements.
my $pMethod = $file->getMethodByNumber($i);
if (my $errs = $pMethod->validateShallow($schemaFile)) {
print "Shallow validation errors (method ", $pMethod->getName, "): ";
print $errs, "\n\n";
}
# Deep validation: check attributes and elements recursively applying basic
# constraints.
if (my $errs = $pMethod->validateDeep($schemaFile)) {
print "Deep validation errors (method ", $pMethod->getName, "): ";
print $errs, "\n\n";
}
}
# We can validate objects as well. First, copy the first method from the
# original file (method "null").
my $myMethodInvalid = new msparser::ms_quant_method($file->getMethodByNumber(0));
# And set an invalid name with less than allowed string length.
$myMethodInvalid->setName("");
# First way: use shallow and deep validation as above.
if (my $errs = $myMethodInvalid->validateShallow($schemaFile)) {
print "Shallow validation of a method: ", $errs, "\n";
}
if (my $errs = $myMethodInvalid->validateDeep($schemaFile)) {
print "Deep validation of a method: ", $errs, "\n";
}
# Second way: use the schema object. This is equivalent to the previous
# two-step process as long as you pass 'true' as the second parameter
# for deep validation.
if (my $errs = $schemaFile->validateComplexObject($myMethodInvalid, 1)) {
print "Deep validation using schema-object: ", $errs, "\n";
}
# Third way: validate an attribute separately. Available validation methods
# are validateSimpleInteger(), validateSimpleDouble(), validateSimpleBool()
# and validateSimpleString().
if (my $errs = $schemaFile->validateSimpleString($myMethodInvalid->getName(), $myMethodInvalid->getNameSchemaType())) {
print "Attribute validation: ", $errs, "\n";
}
# Fourth way: validate an entire document. For this, we need to create
# a new document and append the invalid method definition.
my $configFileInvalid = new msparser::ms_quant_configfile;
$configFileInvalid->appendMethod($myMethodInvalid);
if (my $errs = $configFileInvalid->validateDocument()) {
print "Document validation errors: ", $errs, "\n";
}
# The config file object itself stays valid, even if it has an invalid
# method definition.
if ( !$configFileInvalid->isValid() ) {
# Control flow never comes here!
print "Errors in config file object. The last error description:\n";
print $configFileInvalid->getLastErrorString(), "\n";
}
# The file can be saved even if it has invalid definitions.
$configFileInvalid->setFileName("quantitation_temp.xml");
$configFileInvalid->save_file();
if ( !$configFileInvalid->isValid() ) {
print "Failed to save: ", $configFileInvalid->getLastErrorString(), "\n";
}
=pod
Running the program as
perl -I../bin config_quantitation.pl ../config/quantitation.xml ../html/xmlns/schema/quantitation_2/quantitation_2.xsd
will give the following output under Mascot Server 2.3 (depending on how
quantitation methods have been configured):
There are 26 quantitation methods available:
None
iTRAQ 4plex
iTRAQ 8plex
TMT 6plex
TMT 2plex
18O multiplex
SILAC K+6 R+6 multiplex
IPTL (Succinyl and IMID) multiplex
ICPL duplex pre-digest [MD]
ICPL duplex post-digest [MD]
ICPL triplex pre-digest [MD]
18O corrected [MD]
15N Metabolic [MD]
15N + 13C Metabolic [MD]
SILAC K+6 R+10 [MD]
SILAC K+6 R+10 Arg-Pro [MD]
SILAC K+6 R+6 [MD]
SILAC R+6 R+10 [MD]
SILAC K+8 R+10 [MD]
SILAC K+4 K+8 R+6 R+10 [MD]
ICAT ABI Cleavable [MD]
ICAT D8 [MD]
Dimethylation [MD]
NBS Shimadzu [MD]
Label-free [MD]
Average [MD]
Deep validation of a method: Attribute 'name' -> String is shorter than minLength-limit
Deep validation using schema-object: Attribute 'name' -> String is shorter than minLength-limit
Attribute validation: String is shorter than minLength-limit
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_quantitation.java

config_quantitation.java

Example program for reading and manipulating the quantitation.xml file.

/*
##############################################################################
# file: config_quantitation.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/test_java/test_searchi $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2022-07-21 11:07:25 +0100 $ #
# $Revision: 11e243bdaeaabd63950eb86ad86ce3acc1116e78 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
import java.util.Date;
import matrix_science.msparser.*;
public class config_quantitation {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// ----- Object creation -----
if(argv.length < 2) {
System.out.println("Must specify results quantitation.xml location as the first parameter and schema path as the second.");
System.exit(0);
}
ms_quant_configfile file = new ms_quant_configfile(argv[0], argv[1]);
if ( !file.isValid() )
{
System.out.println("Error number: "+file.getLastError());
System.out.println("Error string: "+file.getLastErrorString());
System.exit(0);
}
System.out.print("There are " + file.getNumberOfMethods());
System.out.println(" methods available");
for (int i=0; i < file.getNumberOfMethods(); i++)
{
System.out.println(file.getMethodByNumber(i).getName());
}
// now try to retrieve typeinfo from the schema file
ms_xml_schema schemaFile = new ms_xml_schema();
schemaFile.setFileName(argv[1]);
schemaFile.read_file();
if ( !schemaFile.isValid() )
{
System.out.println("Errors while reading schema-file. The last error description:");
System.out.println("Error string: " + schemaFile.getLastErrorString());
System.exit(0);
}
// validate the original document
String strValidationErrors = file.validateDocument();
if ( (strValidationErrors != null) && (strValidationErrors.length() > 0) )
{
System.out.println("Initial document validation errors: " + strValidationErrors);
}
// the document can be validated programmatically
// but it is not schema-validation!!!
for(int i = 0; i < file.getNumberOfMethods(); i++)
{
// Shallow validation: we check only presence of required attributes and elements
ms_quant_method pMethod = file.getMethodByNumber(i);
String strErrors = pMethod.validateShallow(schemaFile); // pass the schema object as a parameter
if ( (strErrors != null) && (strErrors.length() > 0) )
{
System.out.println("Method " + pMethod.getName());
System.out.println("Shallow validation errors: " + strErrors);
System.out.println();
}
// Deep validation: we check attributes and elements recursively applying basic constraints
strErrors = pMethod.validateDeep(schemaFile);
if ( (strErrors != null) && (strErrors.length() > 0) )
{
System.out.println("Method " + pMethod.getName());
System.out.println("Deep validation errors: " + strErrors);
System.out.println();
}
}
// create a new invalid document
ms_quant_configfile configFileInvalid = new ms_quant_configfile();
// copy the first method from the original file (method "null")
ms_quant_method myMethodInvalid = new ms_quant_method(file.getMethodByNumber(0));
myMethodInvalid.setName(""); // invalid name with less than allowed string length
// one way to validate an object
// 1. shallow validation - only presence of attributes and elements is checked
String strErr1 = myMethodInvalid.validateShallow(schemaFile);
System.out.println("Shallow validation of a method: " + strErr1);
// 2. deep validation - data types of attributes and elements are checked and a base type too
String strErr2 = myMethodInvalid.validateDeep(schemaFile);
System.out.println("Deep validation of a method: " + strErr2);
// another way to validate an object - by using schema-object (not schema-document!!!)
// the result is absolutely equivalent to the previous call
String strErr3 = schemaFile.validateComplexObject(myMethodInvalid, true); // "true" for deep validation
System.out.println("Deep validation using schema-object: " + strErr3);
// one can validate an attribute separately
// also methods validateSimpleInteger(), validateSimpleDouble() and validateSimpleBool() can be used
String strErr4 = schemaFile.validateSimpleString(myMethodInvalid.getName(), // attribute value
myMethodInvalid.getNameSchemaType()); // attribute data type
System.out.println("Attribute validation: " + strErr4);
// and finally, the whole document validation
configFileInvalid.appendMethod(myMethodInvalid);
String errMethod = configFileInvalid.validateDocument();
System.out.println("Document validation errors: " + errMethod);
// however, the config-file object itself stays valid
if ( !configFileInvalid.isValid() )
{
System.out.println("Errors in config-file object. The last error description:");
System.out.println(configFileInvalid.getLastErrorString());
}
// file is going to be saved even if its invalid
// but the errors will be stored in the config-file object and the object will become invalid
configFileInvalid.setFileName("quantitation_temp.xml"); // give it another name
configFileInvalid.save_file();
if ( !configFileInvalid.isValid() )
{
System.out.println("Errors in config-file object. The last error description:");
System.out.println(configFileInvalid.getLastErrorString());
}
}
}
/*
will give the output:
C:>java -classpath .;../java/msparser.jar config_quantitation quantitation.xml quantitation_1.xsd
There are 10 methods available
None
iTRAQ
ICAT C+9
ICPL C+6 pre-digest
ICPL C+6 post-digest
SILAC K+6 R+10
18O corrected, single scan
18O simple, single scan
SILAC K+6 R+4 multiplex
15N Metabolic
Shallow validation of a method:
Deep validation of a method: Attribute 'name' -> String is shorter than minLength-limit
Deep validation using schema-object: Attribute 'name' -> String is shorter than minLength-limit
Attribute validation: String is shorter than minLength-limit
Document validation errors: XML library failure with error: quantitation.xml: line 4, col 240 - Datatype error: Type:InvalidDatatypeValueException, Message:Value '' with length '0' is less than minimum length facet of '1' .
Errors in config-file object. The last error description:
Failed to save quantitation configuration file
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_quantitation.py

config_quantitation.py

Example program for reading and manipulating the quantitation.xml file.

1#!/usr/bin/python
2
16
17import msparser
18import sys
19
20if len(sys.argv) < 2 :
21 print("""
22The location of quantitation.xml file has to be specified as a parameter.
23The location should either be the full path to the quantitation.xml file
24or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
25""")
26 sys.exit(1)
27
28if len(sys.argv) < 3 :
29 print("""
30The location of schema file quantitation_XXX.xsd has to be specified as the
31second parameter. The location should only be a full or relative path to the
32quantitation_XXX.xsd file.
33""")
34 sys.exit(1)
35
36# A sessionID can optionally be passed as the third parameter.
37# This will only be required if the 'file' is a URL.
38if len(sys.argv) > 3 :
39 cs = msparser.ms_connection_settings()
40 cs.setSessionID(sys.argv[3])
41 file = msparser.ms_quant_configfile(sys.argv[1], sys.argv[2], cs)
42else :
43 file = msparser.ms_quant_configfile(sys.argv[1], sys.argv[2])
44
45if not file.isValid() :
46 print("There are errors. Cannot continue. The last error description:")
47 print(file.getLastErrorString())
48 sys.exit(1)
49
50n = file.getNumberOfMethods()
51print("There are %d quantitation methods available:" % n)
52
53for i in range(n) :
54 print(file.getMethodByNumber(i).getName())
55
56# Validate the original document.
57errs = file.validateDocument()
58if errs :
59 print("Initial document validation errors: %s" % errs)
60
61# Now try to read in the schema file.
62schemaFile = msparser.ms_xml_schema()
63schemaFile.setFileName(sys.argv[2])
64schemaFile.read_file()
65
66if not schemaFile.isValid() :
67 print("Errors while reading schema-file. The last error description: %s" % schemaFile.getLastErrorString())
68 sys.exit(1)
69
70# The document can be validated programmatically, but this is different from
71# real validation against a schema. We'll validate each quantitation
72# method separately.
73for i in range(n) :
74 # Shallow validation: only check the presence of required attributes and
75 # elements.
76 pMethod = file.getMethodByNumber(i)
77
78 errs = pMethod.validateShallow(schemaFile)
79 if errs :
80 print("Shallow validation errors (method %s): %s" % (pMethod.getName(), errs))
81
82 # Deep validation: check attributes and elements recursively applying basic
83 # constraints.
84 errs = pMethod.validateDeep(schemaFile)
85 if errs :
86 print("Deep validation errors (method %s): %s" % (pMethod.getName(), errs))
87
88# We can validate objects as well. First, copy the first method from the
89# original file (method "null").
90myMethodInvalid = msparser.ms_quant_method(file.getMethodByNumber(0))
91# And set an invalid name with less than allowed string length.
92myMethodInvalid.setName("")
93
94# First way: use shallow and deep validation as above.
95errs = myMethodInvalid.validateShallow(schemaFile)
96if errs :
97 print("Shallow validation of a method: %s" % errs)
98
99errs = myMethodInvalid.validateDeep(schemaFile)
100if errs :
101 print("Deep validation of a method: %s" % errs)
102
103# Second way: use the schema object. This is equivalent to the previous
104# two-step process as long as you pass 'true' as the second parameter
105# for deep validation.
106
107errs = schemaFile.validateComplexObject(myMethodInvalid, True)
108if errs :
109 print("Deep validation using schema-object: %s" % errs)
110
111# Third way: validate an attribute separately. Available validation methods
112# are validateSimpleInteger(), validateSimpleDouble(), validateSimpleBool()
113# and validateSimpleString().
114errs = schemaFile.validateSimpleString(myMethodInvalid.getName(), myMethodInvalid.getNameSchemaType())
115if errs :
116 print("Attribute validation: %s" % errs)
117
118# Fourth way: validate an entire document. For this, we need to create
119# a new document and append the invalid method definition.
120configFileInvalid = msparser.ms_quant_configfile()
121configFileInvalid.appendMethod(myMethodInvalid)
122
123errs = configFileInvalid.validateDocument()
124if errs :
125 print("Document validation errors: %s" % errs)
126
127# The config file object itself stays valid, even if it has an invalid
128# method definition.
129if not configFileInvalid.isValid() :
130 # Control flow never comes here!
131 print("Errors in config file object. The last error description: %s" % configFileInvalid.getLastErrorString())
132
133# The file can be saved even if it has invalid definitions.
134configFileInvalid.setFileName("quantitation_temp.xml")
135configFileInvalid.save_file()
136
137if not configFileInvalid.isValid() :
138 print("Failed to save: %s" % configFileInvalid.getLastErrorString())
139
140
141"""
142
143Running the program as
144
145python config_quantitation.pl /usr/local/mascot/config/quantitation.xml /usr/local/mascot/html/xmlns/schema/quantitation_2/quantitation_2.xsd
146
147will give the following output under Mascot Server 2.3 (depending on how
148quantitation methods have been configured):
149
150
151There are 26 quantitation methods available:
152None
153iTRAQ 4plex
154iTRAQ 8plex
155TMT 6plex
156TMT 2plex
15718O multiplex
158SILAC K+6 R+6 multiplex
159IPTL (Succinyl and IMID) multiplex
160ICPL duplex pre-digest [MD]
161ICPL duplex post-digest [MD]
162ICPL triplex pre-digest [MD]
16318O corrected [MD]
16415N Metabolic [MD]
16515N + 13C Metabolic [MD]
166SILAC K+6 R+10 [MD]
167SILAC K+6 R+10 Arg-Pro [MD]
168SILAC K+6 R+6 [MD]
169SILAC R+6 R+10 [MD]
170SILAC K+8 R+10 [MD]
171SILAC K+4 K+8 R+6 R+10 [MD]
172ICAT ABI Cleavable [MD]
173ICAT D8 [MD]
174Dimethylation [MD]
175NBS Shimadzu [MD]
176Label-free [MD]
177Average [MD]
178Deep validation of a method: Attribute 'name' -> String is shorter than minLength-limit
179Deep validation using schema-object: Attribute 'name' -> String is shorter than minLength-limit
180Attribute validation: String is shorter than minLength-limit
181
182
183"""
184
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: config_quantitation.cs

config_quantitation.cs

Example program for reading and manipulating the quantitation.xml file.

/*
##############################################################################
# file: config_quantitation.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/config_quantitation.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class config_quantitation
{
public static void Main(string[] argv)
{
// ----- Object creation -----
if (argv.Length < 2)
{
Console.WriteLine("You must specify quantitation.xml location as the first parameter and the schema path as the second.");
return;
}
ms_quant_configfile file = new ms_quant_configfile(argv[0], argv[1]);
if (!file.isValid())
{
Console.WriteLine("Error number: {0}", file.getLastError());
Console.WriteLine("Error string: {0}", file.getLastErrorString());
return;
}
Console.WriteLine("There are {0} methods available", file.getNumberOfMethods());
for (int i = 0; i < file.getNumberOfMethods(); i++)
{
Console.WriteLine(file.getMethodByNumber(i).getName());
}
// now try to retrieve typeinfo from the schema file
ms_xml_schema schemaFile = new ms_xml_schema();
schemaFile.setFileName(argv[1]);
schemaFile.read_file();
if (!schemaFile.isValid())
{
Console.WriteLine("Error while reading schema-file. The last error description:");
Console.WriteLine("Error string: {0}", schemaFile.getLastErrorString());
return;
}
// validate the original document
string strValidationErrors = file.validateDocument();
if (strValidationErrors != null && strValidationErrors.Length > 0)
{
Console.WriteLine("Initial document validation errors: {0}", strValidationErrors);
}
// the document can be validated programmatically
// but it is not schema-validation
for (int i = 0; i < file.getNumberOfMethods(); i++)
{
// Shallow validation: we check on presence of required attributes and elements
ms_quant_method pMethod = file.getMethodByNumber(i);
String strErrors = pMethod.validateShallow(schemaFile); // pass the schema object as a parameter
if (strErrors != null && strErrors.Length > 0)
{
Console.WriteLine("Method {0}", pMethod.getName());
Console.WriteLine("Shallow validation errors: {0}", strErrors);
Console.WriteLine();
}
// Deep validation: we check attributes and elements recursively applying basic constrains
strErrors = pMethod.validateDeep(schemaFile);
if (strErrors != null && strErrors.Length > 0)
{
Console.WriteLine("Method {0}", pMethod.getName());
Console.WriteLine("Deep validation errors: {0}", strErrors);
Console.WriteLine();
}
}
// create a new invalid document
ms_quant_configfile configFileInvalid = new ms_quant_configfile();
// copy the first method from original file
ms_quant_method myMethodInvalid = new ms_quant_method(file.getMethodByNumber(0));
myMethodInvalid.setName(""); // invalid name with less than allowed string length
// one way to validate an object
// 1. shallow validation - only presence of attributes and elements is checked
string strErr1 = myMethodInvalid.validateShallow(schemaFile);
Console.WriteLine("Shallow validation of a method: {0}", strErr1);
// 2. deep validation data type of attributes and elements are checked and a base type too
string strErr2 = myMethodInvalid.validateDeep(schemaFile);
Console.WriteLine("Deep validation of a method: {0}", strErr2);
// another way to validate an object - by using schema-object (but not schema-document)
// the result is absolutely equivalent to the previous call
string strErr3 = schemaFile.validateComplexObject(myMethodInvalid, true); // true for deep validation
Console.WriteLine("Deep validation using schema-object: {0}", strErr3);
// one can validate an attribute separately
// also methods validateSimpleInteger(), validateSimpleDouble() and validateSimpleBool() can be used
string strErr4 = schemaFile.validateSimpleString(myMethodInvalid.getName(), // attribute value,
myMethodInvalid.getNameSchemaType()); // attribute data type
Console.WriteLine("Attribute validation: {0}", strErr4);
// and finally, the whole document validation
configFileInvalid.appendMethod(myMethodInvalid);
string errMethod = configFileInvalid.validateDocument();
Console.WriteLine("Document validation errors: {0}", errMethod);
// however, the config-file object itself stays valid
if (!configFileInvalid.isValid())
{
Console.WriteLine("Errors in config-file object. The last error description:");
Console.WriteLine(configFileInvalid.getLastErrorString());
}
// file is going to be saved even if it is invalid
// but the errors will be stored in the config-file object and the object will become invalid
configFileInvalid.setFileName("quantitation_temp.xml"); // give it another name
configFileInvalid.save_file();
if (!configFileInvalid.isValid())
{
Console.WriteLine("Errors in config-file object. The last error description:");
Console.WriteLine(configFileInvalid.getLastErrorString());
}
}
}
}
/*
config_quantitation.exe c:\inetpub\mascot\config\quantitation.xml c:\inetpub\mascot\html\xmlns\schema\quantitation_2\quantitation_2.xsd
Will give the output (depending on your configuration):
There are 32 methods available
None
iTRAQ 4plex
iTRAQ 4plex (protein)
iTRAQ 8plex
TMT 6plex
TMT 2plex
TMT 10plex
DiLeu 4plex
18O multiplex
SILAC K+6 R+6 multiplex
IPTL (Succinyl and IMID) multiplex
ICPL duplex pre-digest [MD]
ICPL duplex post-digest [MD]
ICPL triplex pre-digest [MD]
ICPL quadruplex pre-digest [MD]
18O corrected [MD]
15N Metabolic [MD]
15N + 13C Metabolic [MD]
SILAC K+6 R+10 [MD]
SILAC K+6 R+10 Arg-Pro [MD]
SILAC K+6 R+6 [MD]
SILAC R+6 R+10 [MD]
SILAC K+8 R+10 [MD]
SILAC K+4 K+8 R+6 R+10 [MD]
ICAT ABI Cleavable [MD]
ICAT D8 [MD]
Dimethylation [MD]
NBS Shimadzu [MD]
Acetylation [MD]
Label-free [MD]
Average [MD]
iTRAQ 8plex PXD001253
Shallow validation of a method:
Deep validation of a method: Attribute 'name' -> String is shorter than minLengt
h-limit
Deep validation using schema-object: Attribute 'name' -> String is shorter than
minLength-limit
Attribute validation: String is shorter than minLength-limit
Document validation errors:
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_aahelper.cpp

tools_aahelper.cpp

For calculating peptide and fragment masses.

/*
##############################################################################
# File: tools_aahelper.cpp #
# Mascot Parser toolkit example code #
# Example code for generating peptides, peptide and fragment masses #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/tools_aahelper.cpp $
# $Author: villek@matrixscience.com $
# $Date: 2018-07-30 16:23:53 +0100 $
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
#include <iomanip>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
static void printFragmentsTable(ms_fragmentvector & fragments);
static void displayMascotTestSearch(const ms_modvector vecFixed,
const ms_modvector vecVariable,
const ms_enzyme * enzyme,
const double mr,
const ms_fragmentvector fragments);
int main(int argc, char * argv[])
{
// We need an enzyme to build a list of peptides
// and mod_file file if we want to apply any modifications
if ( argc < 3 )
{
std::cout << "Location of enzymes file and mod_file has to be specified as parameters" << std::endl;
return 0;
}
ms_enzymefile enzymefile(argv[1]);
if ( !enzymefile.isValid() )
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << enzymefile.getLastErrorString() << std::endl;
return 1;
}
const ms_enzyme *enzyme = enzymefile.getEnzymeByName("Trypsin");
if ( enzyme == NULL )
{
std::cout << "Cannot find Trypsin enzyme in the file. Cannot continue." << std::endl;
return 1;
}
// we need masses file, but can use default masses anyway
ms_masses masses;
ms_modfile modfile(argv[2], &masses);
if ( !modfile.isValid() )
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << modfile.getLastErrorString() << std::endl;
return 1;
}
const ms_modification *oxidation = modfile.getModificationByName("Oxidation (M)");
const ms_modification *acetylNterm = modfile.getModificationByName("Acetyl (N-term)");
const ms_modification *phospho = modfile.getModificationByName("Phospho (STY)");
if ( oxidation == NULL || acetylNterm == NULL || phospho == NULL)
{
std::cout << "Cannot find necessary modifications in the mod_file. Cannot continue." << std::endl;
return 1;
}
ms_aahelper aahelper;
aahelper.setMasses(&masses);
aahelper.setEnzyme(enzyme);
// Now we can generate peptides for a given protein
char proteinStr[] = "MAIFRIDEIRNMSSEELEEELRKLEVELIRERGAVRAGGAPEKPGRIREIRRTIARMKTVQRERVRK";
aahelper.startIteratePeptides(proteinStr, static_cast<int>(strlen(proteinStr)), 0);// no missed cleavages are allowed
std::cout << "List of peptides" << std::endl;
while(aahelper.getNextPeptide())
{
int start = aahelper.getPepStart()-1; // the method returns 1-based position
int len = aahelper.getPepEnd() - aahelper.getPepStart()+1;
std::string peptideStr;
peptideStr.assign(proteinStr+start, len);
std::cout << peptideStr << std::endl;
}
std::cout << "End of list" << std::endl;
// create a list of fixed modifications
ms_modvector vecFixed;
vecFixed.appendModification(phospho);
// create a list of variable modifications
ms_modvector vecVariable;
vecVariable.appendModification(oxidation);
vecVariable.appendModification(acetylNterm);
aahelper.setAvailableModifications(&vecFixed, &vecVariable);
// ms_aahelper can also contain errors that might happen when applying modifications
// for instance, when we have a conflict between two modifications (same residue or same peptide end)
if ( !aahelper.isValid() )
{
std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
std::cout << aahelper.getLastErrorString() << std::endl;
return 1;
}
// we will need also a separate error-object for collecting peptide-specific errors
ms_errs err;
// Example of how to call calcPeptideMZ
// It will often be more convenient to create an ms_peptide and then
// call getMrCalc() on that object.
std::vector< int > numThatMustBeModded;
numThatMustBeModded.push_back(1); // 1 acetylNterm modification
numThatMustBeModded.push_back(1); // 1 site is oxidised
double mr = aahelper.calcPeptideMZ(proteinStr,
static_cast<int>(strlen(proteinStr)),
1, 10, // peptide ends (1-based)
numThatMustBeModded,
0, // no charge - i.e. mr
matrix_science::MASS_TYPE_MONO,
&err);
if ( !err.isValid() )
{
std::cout << "There have been errors while calculating peptide mass: " << std::endl;
std::cout << err.getLastErrorString() << std::endl;
// don't need to halt as they are not fatal errors
err.clearAllErrors(); // prepare to re-use it
}
else
{
std::cout << "Peptide mass calculated using 'calcPeptideMZ' is "
<< std::setprecision(3)
<< std::fixed
<< std::setw(8)
<< mr
<< std::endl << std::endl << std::endl;
}
// Create a peptide - which we can then fragment
//
// Specify which residues are modified by which modification.
// as it has to correspond to a modification string
// Nterm modification + 9 residues + Cterm modification
std::vector< int > numModded;
numModded.push_back(2); // N-term - modified by "Acetyl (N-term)"
numModded.push_back(1); // M - modified by "Oxidation (M)"
numModded.push_back(0); // A
numModded.push_back(0); // I
numModded.push_back(0); // F
numModded.push_back(0); // R
numModded.push_back(0); // I
numModded.push_back(0); // D
numModded.push_back(0); // E
numModded.push_back(0); // I
numModded.push_back(0); // R
numModded.push_back(0); // C-term
// we have to specify (or at least supply an empty vector) which neutral loss value to use
// in case there are more than one available for a modification
std::vector< int > whichNl;
whichNl.push_back(0); // N-term
whichNl.push_back(1); // M - has 2 neutral losses. Specify the first (-98)
whichNl.push_back(0); // A
whichNl.push_back(0); // I
whichNl.push_back(0); // F
whichNl.push_back(0); // R
whichNl.push_back(0); // I
whichNl.push_back(0); // D
whichNl.push_back(0); // E
whichNl.push_back(0); // I
whichNl.push_back(0); // R
whichNl.push_back(0); // C-term
ms_peptide peptide = aahelper.createPeptide(proteinStr,
static_cast<int>(strlen(proteinStr)),
1,10, // start, end positions
numModded, // modification string-like vector
whichNl, // which neutral loss to use
0, // no charge
matrix_science::MASS_TYPE_MONO,
&err); // collect errors in it
if ( !err.isValid() )
{
std::cout << "There have been errors while creating a peptide: " << std::endl;
std::cout << err.getLastErrorString() << std::endl;
// don't need to halt as they are not fatal errors
err.clearAllErrors(); // prepare to re-use it
}
else
{
std::cout
<< "Peptide has been created successfully: "
<< peptide.getPeptideStr()
<< std::endl;
}
std::vector< double > ions;
ms_fragmentvector fragments;
ms_fragmentvector all_fragments; // Keep a list of fragments from all series
ions = aahelper.calcFragments(&peptide, // that is why we needed to create a peptide object first
ms_fragmentationrules::FRAG_B_SERIES, // ions series ID
false, // single-charged ions only
100.0, // minimal fragment mass to return
mr, // maximal fragment mass to return
matrix_science::MASS_TYPE_MONO,
&fragments,
&err); // collect peptide-specific errors
std::cout << "b-ion series fragments: " << std::endl;
printFragmentsTable(fragments);
all_fragments.copyFrom(&fragments);
ms_fragmentvector b_ions;
b_ions.copyFrom(&fragments);
ions = aahelper.calcFragments(&peptide, // that is why we needed to create a peptide object first
ms_fragmentationrules::FRAG_Y_SERIES, // ions series ID
false, // single-charged ions only
100.0, // minimal fragment mass to return
mr, // maximal fragment mass to return
matrix_science::MASS_TYPE_MONO,
&fragments,
&err); // collect peptide-specific errors
std::cout << "y-ion series fragments: " << std::endl;
printFragmentsTable(fragments);
int i;
for (i=0; i < fragments.getNumberOfFragments(); i++)
all_fragments.appendFragment(fragments.getFragmentByNumber(i));
aahelper.calcFragmentsEx(&peptide, // that is why we needed to create a peptide object first
ms_fragmentationrules::FRAG_Y_SERIES, // ions series ID
2, // double-charged ions only
100.0, // minimal fragment mass to return
mr, // maximal fragment mass to return
matrix_science::MASS_TYPE_MONO,
&fragments,
&err); // collect peptide-specific errors
std::cout << "y++-ion series fragments: " << std::endl;
printFragmentsTable(fragments);
for (i=0; i < fragments.getNumberOfFragments(); i++)
all_fragments.appendFragment(fragments.getFragmentByNumber(i));
ions = aahelper.calcFragments(&peptide, // that is why we created a peptide object first
ms_fragmentationrules::FRAG_INTERNAL_YB, // ions series ID
false, // single-charged ions only
100.0, // minimal fragment mass to return
700, // maximal fragment mass to return
matrix_science::MASS_TYPE_MONO,
&fragments,
&err); // collect peptide-specific errors
std::cout << "internal yb-ion series fragments: " << std::endl;
printFragmentsTable(fragments);
for (i=0; i < fragments.getNumberOfFragments(); i++)
all_fragments.appendFragment(fragments.getFragmentByNumber(i));
std::cout << "Run a search under Mascot to verify the output above" << std::endl;
std::cout << "Paste the following into a Mascot search query window:" << std::endl;
displayMascotTestSearch(vecFixed, vecVariable,
enzyme,
mr,
b_ions); // Or you can use all_fragments
return 0;
}
static void printFragmentsTable(ms_fragmentvector & fragments)
{
std::cout << "Number of fragments: " << fragments.getNumberOfFragments() << std::endl;
std::cout << "Col\tStart\tEnd\tLabel\t\t Mass\t NL\tName\tImmon\tIntern\tReg" << std::endl;
for (int i=0; i < fragments.getNumberOfFragments(); i++)
{
const ms_fragment * frag = fragments.getFragmentByNumber(i);
std::cout << frag->getColumn() << "\t";
std::cout << frag->getStart() << "\t";
std::cout << frag->getEnd() << "\t";
std::cout << std::setw(10) << frag->getLabel() << "\t";
std::cout << std::fixed << std::setprecision(2) << std::setw(7) << frag->getMass() << "\t";
std::cout << frag->getNeutralLoss()<< "\t";
std::cout << frag->getSeriesName() << "\t";
std::cout << frag->isImmonium() << "\t";
std::cout << frag->isInternal() << "\t";
std::cout << frag->isRegular() << std::endl;
}
std::cout << std::endl;
}
static void displayMascotTestSearch(const ms_modvector vecFixed,
const ms_modvector vecVariable,
const ms_enzyme * enzyme,
const double mr,
const ms_fragmentvector fragments)
{
/* fragments contains a list of b-ions from a peptide
* vecVariable contains a list of variable mods applied to the peptide
* vecFixed contains a list of fixed mods applied to the peptide
* Use this information to generate an test search that can be run on Mascot.
*/
int i;
for (i=0; i < vecFixed.getNumberOfModifications(); i++)
{
std::cout << "MODS="
<< vecFixed.getModificationByNumber(i)->getTitle()
<< std::endl;
}
for (i=0; i < vecVariable.getNumberOfModifications(); i++)
{
std::cout << "IT_MODS="
<< vecVariable.getModificationByNumber(i)->getTitle()
<< std::endl;
}
std::cout << "CHARGE=Mr" << std::endl;
std::cout << "CLE=" << enzyme->getTitle() << std::endl;
std::cout << "INSTRUMENT=MALDI-TOF-TOF" << std::endl;
std::cout << std::setprecision(3) << mr << " ions(";
for(i=0; i < fragments.getNumberOfFragments(); i++)
{
if (i > 0)
std::cout << ", ";
std::cout << fragments.getFragmentByNumber(i)->getMass();
}
std::cout << ")" << std::endl;
}
/*
will give the output, for instance:
# tools_aahelper ../config/enzymes ../config/mod_file
List of peptides
M
MEDYLDELR
EDYLDELR
HK
IPSFIVELLK
NNLK
NR
NLTR
NQLNK
IVNR
VSDLYFGK
KPEDK
K
AAELTNK
INDLSHK
LDALMK
VATVSSATK
VSDDIK
K
EIDNLDELDL
End of list
Peptide mass calculated using 'calcPeptideMZ' is 1320.494
Peptide has been created successfully: MEDYLDELR
b-ion series fragments:
Number of fragments: 8
Col Start End Label Mass NL Name Immon Intern Reg
1 1 -1 b(1) 190.05 0.00 b 0 0 1
2 2 -1 b(2) 319.10 0.00 b 0 0 1
3 3 -1 b(3) 434.12 0.00 b 0 0 1
4 4 -1 b(4) -97 579.18 97.98 b 0 0 1
5 5 -1 b(5) -97 692.26 97.98 b 0 0 1
6 6 -1 b(6) -97 807.29 97.98 b 0 0 1
7 7 -1 b(7) -97 936.33 97.98 b 0 0 1
8 8 -1 b(8) -97 1049.41 97.98 b 0 0 1
y-ion series fragments:
Number of fragments: 8
Col Start End Label Mass NL Name Immon Intern Reg
8 8 -1 y(8) -97 1034.48 97.98 y 0 0 1
7 7 -1 y(7) -97 905.44 97.98 y 0 0 1
6 6 -1 y(6) -97 790.41 97.98 y 0 0 1
5 5 -1 y(5) 645.36 0.00 y 0 0 1
4 4 -1 y(4) 532.27 0.00 y 0 0 1
3 3 -1 y(3) 417.25 0.00 y 0 0 1
2 2 -1 y(2) 288.20 0.00 y 0 0 1
1 1 -1 y(1) 175.12 0.00 y 0 0 1
internal yb-ion series fragments:
Number of fragments: 18
Col Start End Label Mass NL Name Immon Intern Reg
2 2 3 ED 245.08 0.00 yb 0 1 0
2 2 4 EDY -97 390.13 97.98 yb 0 1 0
2 2 5 EDYL -97 503.21 97.98 yb 0 1 0
2 2 6 EDYLD -97 618.24 97.98 yb 0 1 0
3 3 4 DY -97 261.09 97.98 yb 0 1 0
3 3 5 DYL -97 374.17 97.98 yb 0 1 0
3 3 6 DYLD -97 489.20 97.98 yb 0 1 0
3 3 7 DYLDE -97 618.24 97.98 yb 0 1 0
4 4 5 YL -97 259.14 97.98 yb 0 1 0
4 4 6 YLD -97 374.17 97.98 yb 0 1 0
4 4 7 YLDE -97 503.21 97.98 yb 0 1 0
4 4 8 YLDEL -97 616.30 97.98 yb 0 1 0
5 5 6 LD 229.12 0.00 yb 0 1 0
5 5 7 LDE 358.16 0.00 yb 0 1 0
5 5 8 LDEL 471.24 0.00 yb 0 1 0
6 6 7 DE 245.08 0.00 yb 0 1 0
6 6 8 DEL 358.16 0.00 yb 0 1 0
7 7 8 EL 243.13 0.00 yb 0 1 0
Run a search under Mascot to verify the output above
Paste the following into a Mascot search query window:
MODS=Oxidation (M)
IT_MODS=Acetyl (N-term)
IT_MODS=Phospho (STY)
CHARGE=Mr
CLE=Trypsin
INSTRUMENT=MALDI-TOF-TOF
1320.494 ions(190.053, 319.096, 434.123, 579.176, 692.260, 807.287, 936.329, 1049.413)
*/
matrix_science::ms_aahelper
This class facilitates creation of peptides and calculation of MS-fragment masses.
Definition: ms_aahelper.hpp:35
matrix_science::ms_aahelper::calcFragments
std::vector< double > calcFragments(const ms_peptide *peptide, const int seriesID, const bool doubleCharged, const double minMass, const double maxMass, const MASS_TYPE massType, ms_fragmentvector *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const
Returns a vector of ion masses for the given series and peptide.
Definition: ms_aahelper.cpp:4072
matrix_science::ms_aahelper::getPepEnd
int getPepEnd() const
Returns the last position of the current peptide.
Definition: ms_aahelper.cpp:1105
matrix_science::ms_aahelper::calcFragmentsEx
bool calcFragmentsEx(const ms_peptide *peptide, const int seriesID, const int fragCharge, const double minMass, const double maxMass, const MASS_TYPE massType, ms_fragmentvector *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const
Returns a vector of ion masses for the given series and peptide.
Definition: ms_aahelper.cpp:4124
matrix_science::ms_aahelper::calcPeptideMZ
double calcPeptideMZ(const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > numThatMustBeModded, const int charge, const MASS_TYPE massType, ms_errs *err) const
Calculates and returns a peptide m/z (or Mr) value without specifying exact positions of modified res...
Definition: ms_aahelper.cpp:1163
matrix_science::ms_aahelper::setEnzyme
void setEnzyme(const ms_enzyme *enzyme)
Sets an enzyme to use.
Definition: ms_aahelper.cpp:494
matrix_science::ms_aahelper::setAvailableModifications
void setAvailableModifications(const ms_modvector *fixedModVector, const ms_modvector *varModVector)
Applies fixed modifications to residue masses and stores variable modifications for later use.
Definition: ms_aahelper.cpp:550
matrix_science::ms_aahelper::getNextPeptide
bool getNextPeptide()
Call to iterate to the next peptide.
Definition: ms_aahelper.cpp:885
matrix_science::ms_aahelper::setMasses
void setMasses(const ms_masses *masses)
Copies all residue and chemical element masses from the masses file instance.
Definition: ms_aahelper.cpp:512
matrix_science::ms_aahelper::startIteratePeptides
void startIteratePeptides(const char *sequenceProtein, const int sizeProtein, const int pfa)
Initialises internal members in preparation for generating peptides.
Definition: ms_aahelper.cpp:837
matrix_science::ms_aahelper::createPeptide
ms_peptide createPeptide(const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > varMods, const std::vector< int > varModsWhichNl, const int charge, const MASS_TYPE massType, ms_errs *err) const
Creates and returns a peptide object.
Definition: ms_aahelper.cpp:1558
matrix_science::ms_aahelper::getPepStart
int getPepStart() const
Returns the first position of the current peptide.
Definition: ms_aahelper.cpp:1094
matrix_science::ms_enzyme
Represent a single entry in the enzymes file.
Definition: ms_enzyme.hpp:67
matrix_science::ms_enzyme::getTitle
std::string getTitle() const
Returns a name of the enzyme as appears in the file.
Definition: ms_enzyme.cpp:318
matrix_science::ms_enzymefile
Reads and parses the enzymes file that contains multiple enzyme definitions.
Definition: ms_enzyme.hpp:194
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_errs::getLastErrorString
std::string getLastErrorString() const
Return the last error number or an empty string.
Definition: ms_errors.cpp:1126
matrix_science::ms_errs::isValid
bool isValid() const
Returns TRUE if no errors occurred, FALSE otherwise.
Definition: ms_errors.cpp:707
matrix_science::ms_errs::clearAllErrors
void clearAllErrors()
Remove all errors from the current list of errors.
Definition: ms_errors.cpp:1019
matrix_science::ms_fragment
Class representing a single peptide fragment.
Definition: ms_fragment.hpp:38
matrix_science::ms_fragment::getColumn
int getColumn() const
Returns the 1-based position index in case of a regular series.
Definition: ms_fragment.cpp:809
matrix_science::ms_fragment::getLabel
std::string getLabel(const LABEL_FORMAT fmt=LABEL_FORMAT_TRADITIONAL) const
Returns a symbolic label like "a*(6)++".
Definition: ms_fragment.cpp:758
matrix_science::ms_fragment::getSeriesName
std::string getSeriesName() const
Returns the ion series name.
Definition: ms_fragment.cpp:804
matrix_science::ms_fragment::isImmonium
bool isImmonium() const
Returns TRUE for immonium ions.
Definition: ms_fragment.cpp:733
matrix_science::ms_fragment::getStart
int getStart() const
Returns the 1-based start position within the peptide sequence.
Definition: ms_fragment.cpp:818
matrix_science::ms_fragment::getNeutralLoss
double getNeutralLoss() const
Returns the neutral loss (m/z) values applied to the fragment.
Definition: ms_fragment.cpp:748
matrix_science::ms_fragment::getEnd
int getEnd() const
Returns the 1-based last position in case of an internal fragment.
Definition: ms_fragment.cpp:828
matrix_science::ms_fragment::isInternal
bool isInternal() const
Returns TRUE for internal fragments ya and yb.
Definition: ms_fragment.cpp:728
matrix_science::ms_fragment::getMass
double getMass() const
Returns the ion mass (m/z) value.
Definition: ms_fragment.cpp:743
matrix_science::ms_fragment::isRegular
bool isRegular() const
Returns TRUE for a, b, c, d, y, v, w, x, z series and their derivatives.
Definition: ms_fragment.cpp:713
matrix_science::ms_fragmentvector
Class for holding a list of ms_fragment objects.
Definition: ms_fragmentvector.hpp:47
matrix_science::ms_fragmentvector::getNumberOfFragments
int getNumberOfFragments() const
Returns a number of fragments currently held in the vector.
Definition: ms_fragmentvector.cpp:88
matrix_science::ms_fragmentvector::getFragmentByNumber
const ms_fragment * getFragmentByNumber(const unsigned int numFrag) const
Return a fragment object by its number.
Definition: ms_fragmentvector.cpp:121
matrix_science::ms_fragmentvector::appendFragment
void appendFragment(const ms_fragment *item)
Adds a new fragment to the end of the vector.
Definition: ms_fragmentvector.cpp:109
matrix_science::ms_fragmentvector::copyFrom
void copyFrom(const ms_fragmentvector *right)
Copies all content from another instance.
Definition: ms_fragmentvector.cpp:60
matrix_science::ms_masses
Reads and parses the masses file with residue and atom masses.
Definition: ms_masses.hpp:48
matrix_science::ms_modfile
Use this class in order to read in the amino acid modification file.
Definition: ms_modfile.hpp:407
matrix_science::ms_modification
The class represents a single modification-entry in mod_file.
Definition: ms_modfile.hpp:134
matrix_science::ms_modification::getTitle
std::string getTitle() const
Returns the modification title.
Definition: ms_modfile.cpp:171
matrix_science::ms_modvector
General usage class for creating lists of modifications to be passed as parameters.
Definition: ms_modfile.hpp:339
matrix_science::ms_modvector::getModificationByNumber
const ms_modification * getModificationByNumber(const int numMod) const
Returns a modification object by its number.
Definition: ms_modfile.cpp:955
matrix_science::ms_modvector::getNumberOfModifications
int getNumberOfModifications() const
Returns the number of modifications currently held in the vector.
Definition: ms_modfile.cpp:918
matrix_science::ms_modvector::appendModification
void appendModification(const ms_modification *item)
Adds a new modification at the end of the vector.
Definition: ms_modfile.cpp:933
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::getPeptideStr
std::string getPeptideStr(bool substituteAmbiguous=true, const PSM psmComponent=PSM_COMPLETE) const
Returns the sequence found for the peptide.
Definition: ms_peptide.cpp:710
matrix_science::MASS_TYPE_MONO
@ MASS_TYPE_MONO
monoisotopic mass index
Definition: ms_modfile.hpp:66
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_aahelper.pl

tools_aahelper.pl

For calculating peptide and fragment masses.

#!/usr/local/bin/perl
##############################################################################
# file: tools_aahelper.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/tools_aahelper.pl $
# $Author: villek@matrixscience.com $
# $Date: 2018-07-30 16:23:53 +0100 $
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
##############################################################################
use msparser;
if (!defined($ARGV[0]) || !defined($ARGV[1])) {
# We need an enzyme to build a list of peptides and mod_file file if we
# want to apply any modifications.
print "Location of enzymes file and mod_file has to be specified as parameters\n";
exit 1;
}
my $enzymefile = open_enzymefile($ARGV[0]);
# Note: both $enzymefile *must* be kept in scope for as long as you use
# $Trypsin. See "Using the toolkit from Perl, Java and Python" in Mascot Parser
# manual.
my $Trypsin = $enzymefile->getEnzymeByName('Trypsin');
if (!$Trypsin) {
print "Cannot find 'Trypsin' in the enzyme file. Cannot continue.\n";
exit 1;
}
my $modfile = open_modfile($ARGV[1]);
my $aahelper = new msparser::ms_aahelper;
# Note: both $modfile and $Trypsin *must* be kept in scope for as
# long as you use $aahelper. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
$aahelper->setMasses($modfile->getMassFile);
$aahelper->setEnzyme($Trypsin);
# Now we can generate peptides for a given protein. This is
# RL29_METTP (50S ribosomal protein L29P OS=Methanosaeta thermophila (strain
# DSM 6194 / PT) GN=rpl29p PE=3 SV=1) from SwissProt 2010_09.
my $proteinStr = "MAIFRIDEIRNMSSEELEEELRKLEVELIRERGAVRAGGAPEKPGRIREIRRTIARMKTVQRERVRK";
# No missed cleavages are allowed (third parameter).
$aahelper->startIteratePeptides($proteinStr, length($proteinStr), 0);
print "List of peptides\n";
while ($aahelper->getNextPeptide) {
my $start = $aahelper->getPepStart();
my $len = $aahelper->getPepEnd() - $aahelper->getPepStart() + 1;
# getPepStart() returns one-based index.
my $peptideStr = substr($proteinStr, $start - 1, $len);
print $peptideStr, "\n";
}
print "End of list\n\n";
# Create a list of fixed modifications.
my $vecFixed = new msparser::ms_modvector();
$vecFixed->appendModification(
$modfile->getModificationByName('Phospho (Y)')
);
# Create a list of variable modifications.
my $vecVariable = new msparser::ms_modvector();
$vecVariable->appendModification(
$modfile->getModificationByName('Oxidation (M)')
);
$vecVariable->appendModification(
$modfile->getModificationByName('Acetyl (N-term)')
);
# Note: both $vecFixed and $vecVariable *must* be kept in scope for as
# long as you use $aahelper. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
$aahelper->setAvailableModifications($vecFixed, $vecVariable);
# ms_aahelper can also contain errors that might happen when applying
# modifications, for instance when we have a conflict between two
# modifications (same residue or same peptide end).
if (!$aahelper->isValid()) {
print "Error while setting available modifications: ";
print $aahelper->getLastErrorString(), "\n";
exit(1);
}
# We will need also a separate error object for collecting peptide-specific
# errors.
my $err = new msparser::ms_errs();
# Example of how to call calcPeptideMZ(). It will often be more convenient to
# create an ms_peptide instead, and then call getMrCalc() on that object.
my $numThatMustBeModded = new msparser::vectori();
$numThatMustBeModded->push(1); # 1 acetylNterm modification
$numThatMustBeModded->push(1); # 1 site is oxidised
my $mr = $aahelper->calcPeptideMZ(
$proteinStr,
length($proteinStr),
1,
10, # peptide ends (1-based)
$numThatMustBeModded,
0, # no charge - i.e. Mr
$msparser::MASS_TYPE_MONO,
$err
);
if (!$err->isValid()) {
print "Error while calculating peptide mass: ";
print $err->getLastErrorString(), "\n";
# Don't need to halt as they are not fatal errors.
$err->clearAllErrors();
} else {
printf "Peptide mass calculated using 'calcPeptideMZ' is %8.3f\n", $mr;
}
# Create a peptide - which we can then fragment.
#
# Specify which residues are modified by which modification as it has to
# correspond to a modification string:
#
# Nterm modification + 9 residues + Cterm modification
my $numModded = new msparser::vectori();
$numModded->push(2); # N-term - modified by "Acetyl (N-term)"
$numModded->push(1); # M - modified by "Oxidation (M)"
$numModded->push(0); # A
$numModded->push(0); # I
$numModded->push(0); # F
$numModded->push(0); # R
$numModded->push(0); # I
$numModded->push(0); # D
$numModded->push(0); # E
$numModded->push(0); # I
$numModded->push(0); # R
$numModded->push(0); # C-term
# We have to specify (or at least supply an empty vector) which neutral loss
# value to use, in case there are more than one available for a modification.
my $whichNl = new msparser::vectori();
$whichNl->push(0); # N-term
$whichNl->push(1); # M - has 2 neutral losses. Specify the first (-98)
$whichNl->push(0); # A
$whichNl->push(0); # I
$whichNl->push(0); # F
$whichNl->push(0); # R
$whichNl->push(0); # I
$whichNl->push(0); # D
$whichNl->push(0); # E
$whichNl->push(0); # I
$whichNl->push(0); # R
$whichNl->push(0); # C-term
my $peptide = $aahelper->createPeptide(
$proteinStr,
length($proteinStr),
1,
10, # end positions
$numModded, # modification string-like vector
$whichNl, # which neutral loss to use
0, # no charge
$msparser::MASS_TYPE_MONO,
$err
);
if (!$err->isValid()) {
print "Error while creating a peptide: ";
print $err->getLastErrorString(), "\n";
# Don't need to halt as they are not fatal errors.
$err->clearAllErrors();
} else {
print "\n\nPeptide has been created successfully: ";
print $peptide->getPeptideStr(), "\n";
}
# Keep a list of fragments from all series
my $all_fragments = new msparser::ms_fragmentvector;
my $b_ions = fragmentPeptide(
$aahelper,
$peptide,
$msparser::ms_fragmentationrules::FRAG_B_SERIES,
'b-ion series',
0, # single-charged ions only
$mr, # maximal fragment mass to return
);
# copyFrom() can only be used to populate the list for the first time.
$all_fragments->copyFrom($b_ions);
my $fragments = fragmentPeptide(
$aahelper,
$peptide,
$msparser::ms_fragmentationrules::FRAG_Y_SERIES,
'y-ion series',
0, # single-charged ions only
$mr, # maximal fragment mass to return
);
for my $i (0 .. $fragments->getNumberOfFragments - 1) {
$all_fragments->appendFragment($fragments->getFragmentByNumber($i));
}
$fragments = fragmentPeptide(
$aahelper,
$peptide,
$msparser::ms_fragmentationrules::FRAG_Y_SERIES,
'y++-ion series',
2, # double-charged ions only
$mr, # maximal fragment mass to return
);
for my $i (0 .. $fragments->getNumberOfFragments - 1) {
$all_fragments->appendFragment($fragments->getFragmentByNumber($i));
}
$fragments = fragmentPeptide(
$aahelper,
$peptide,
$msparser::ms_fragmentationrules::FRAG_INTERNAL_YB,
'internal yb-ion series',
0, # single-charged ions only
700, # maximal fragment mass to return
);
for my $i (0 .. $fragments->getNumberOfFragments - 1) {
$all_fragments->appendFragment($fragments->getFragmentByNumber($i));
}
print "Paste the following into a Mascot search query window to verify this output:\n";
displayMascotTestSearch(
$vecFixed, $vecVariable, $Trypsin, $peptide->getMrCalc,
$b_ions # or you can use $all_fragments
);
sub open_enzymefile {
my ($filename) = @_;
my $enzymefile = new msparser::ms_enzymefile($filename);
if (!$enzymefile->isValid) {
print "Error while opening enzyme file: ";
print $enzymefile->getLastErrorString() . "\n";
exit 1;
}
return $enzymefile;
}
sub open_modfile {
my ($filename) = @_;
# We can use the default masses in this example.
my $masses = new msparser::ms_masses;
my $modfile = new msparser::ms_modfile($filename, $masses);
if (!$modfile->isValid) {
print "Error while opening mod file: ";
print $modfile->getLastErrorString . "\n";
exit 1;
}
for ('Oxidation (M)', 'Acetyl (N-term)', 'Phospho (Y)') {
if (not $modfile->getModificationByName($_)) {
print "Cannot find '$_' in the mod file. Cannot continue.\n";
exit(1);
}
}
return $modfile;
}
sub fragmentPeptide {
my ($aa_helper, $peptide, $series, $series_label, $doubleCharged, $mass_max) = @_;
my $fragments = new msparser::ms_fragmentvector;
my $err = new msparser::ms_errs();
$aahelper->calcFragments(
$peptide,
$series,
$doubleCharged ? 1 : 0,
100.0,
$mass_max,
$msparser::MASS_TYPE_MONO,
$fragments,
$err
);
# Check $err here.
print $series_label, " fragments: \n";
printFragmentsTable($fragments);
return $fragments;
}
sub printFragmentsTable {
my ($fragments) = @_;
print "Number of fragments: ", $fragments->getNumberOfFragments(), "\n";
my $headerfmt = "%5s %5s %5s %-10s %7s %7s %4s %5s %6s %4s\n";
my $fmt = "%5s %5s %5s %-10s %7.2f %7.2f %4s %5s %6s %4s\n";
printf $headerfmt, qw(Col Start End Label Mass NL Name Immon Intern Reg);
for my $i (0 .. $fragments->getNumberOfFragments - 1) {
my $frag = $fragments->getFragmentByNumber($i);
printf $fmt,
$frag->getColumn(),
$frag->getStart(),
$frag->getEnd(),
$frag->getLabel(),
$frag->getMass(),
$frag->getNeutralLoss(),
$frag->getSeriesName(),
$frag->isImmonium(),
$frag->isInternal(),
$frag->isRegular(),
;
}
print "\n";
}
# $vecFixed contains a list of fixed mods applied to the peptide
# $vecVariable contains a list of variable mods applied to the peptide
# $enzyme is the enzyme used in fragmentation
# $mr is the peptide Mr(calc)
# $fragments contains a list of b-ions from a peptide
#
# Use this information to generate an test search that can be run on Mascot.
sub displayMascotTestSearch {
my ($vecFixed, $vecVariable, $enzyme, $mr, $fragments) = @_;
for my $i (0 .. $vecFixed->getNumberOfModifications-1) {
printf "MODS=%s\n", $vecFixed->getModificationByNumber($i)->getTitle();
}
for my $i (0 .. $vecVariable->getNumberOfModifications-1) {
printf "IT_MODS=%s\n", $vecVariable->getModificationByNumber($i)->getTitle();
}
print "CHARGE=Mr\n";
print "CLE=", $enzyme->getTitle(), "\n";
print "INSTRUMENT=MALDI-TOF-TOF\n";
printf "%.3f ions(", $mr;
print join(', ', map {
sprintf("%.3f", $fragments->getFragmentByNumber($_)->getMass)
} 0 .. $fragments->getNumberOfFragments-1
);
print ")\n";
}
=pod
Running the program as
perl -I../bin tools_aahelper.pl ../config/enzymes ../config/mod_file
will give the following output under Mascot 2.3:
List of peptides
M
MAIFR
AIFR
IDEIR
NMSSEELEEELR
K
LEVELIR
ER
GAVR
AGGAPEKPGR
IR
EIR
R
TIAR
MK
TVQR
ER
VR
K
End of list
Peptide mass calculated using 'calcPeptideMZ' is 1320.686
Peptide has been created successfully: MAIFRIDEIR
b-ion series fragments:
Number of fragments: 9
Col Start End Label Mass NL Name Immon Intern Reg
1 1 -1 b(1) 190.05 0.00 b 1
2 2 -1 b(2) 261.09 0.00 b 1
3 3 -1 b(3) 374.17 0.00 b 1
4 4 -1 b(4) 521.24 0.00 b 1
5 5 -1 b(5) 677.34 0.00 b 1
6 6 -1 b(6) 790.43 0.00 b 1
7 7 -1 b(7) 905.45 0.00 b 1
8 8 -1 b(8) 1034.50 0.00 b 1
9 9 -1 b(9) 1147.58 0.00 b 1
y-ion series fragments:
Number of fragments: 9
Col Start End Label Mass NL Name Immon Intern Reg
9 9 -1 y(9) 1132.65 0.00 y 1
8 8 -1 y(8) 1061.61 0.00 y 1
7 7 -1 y(7) 948.53 0.00 y 1
6 6 -1 y(6) 801.46 0.00 y 1
5 5 -1 y(5) 645.36 0.00 y 1
4 4 -1 y(4) 532.27 0.00 y 1
3 3 -1 y(3) 417.25 0.00 y 1
2 2 -1 y(2) 288.20 0.00 y 1
1 1 -1 y(1) 175.12 0.00 y 1
y++-ion series fragments:
Number of fragments: 8
Col Start End Label Mass NL Name Immon Intern Reg
9 9 -1 y(9)++ 566.83 0.00 y 1
8 8 -1 y(8)++ 531.31 0.00 y 1
7 7 -1 y(7)++ 474.77 0.00 y 1
6 6 -1 y(6)++ 401.23 0.00 y 1
5 5 -1 y(5)++ 323.18 0.00 y 1
4 4 -1 y(4)++ 266.64 0.00 y 1
3 3 -1 y(3)++ 209.13 0.00 y 1
2 2 -1 y(2)++ 144.61 0.00 y 1
internal yb-ion series fragments:
Number of fragments: 22
Col Start End Label Mass NL Name Immon Intern Reg
2 2 3 AI 185.13 0.00 yb 1
2 2 4 AIF 332.20 0.00 yb 1
2 2 5 AIFR 488.30 0.00 yb 1
2 2 6 AIFRI 601.38 0.00 yb 1
3 3 4 IF 261.16 0.00 yb 1
3 3 5 IFR 417.26 0.00 yb 1
3 3 6 IFRI 530.34 0.00 yb 1
3 3 7 IFRID 645.37 0.00 yb 1
4 4 5 FR 304.18 0.00 yb 1
4 4 6 FRI 417.26 0.00 yb 1
4 4 7 FRID 532.29 0.00 yb 1
4 4 8 FRIDE 661.33 0.00 yb 1
5 5 6 RI 270.19 0.00 yb 1
5 5 7 RID 385.22 0.00 yb 1
5 5 8 RIDE 514.26 0.00 yb 1
5 5 9 RIDEI 627.35 0.00 yb 1
6 6 7 ID 229.12 0.00 yb 1
6 6 8 IDE 358.16 0.00 yb 1
6 6 9 IDEI 471.24 0.00 yb 1
7 7 8 DE 245.08 0.00 yb 1
7 7 9 DEI 358.16 0.00 yb 1
8 8 9 EI 243.13 0.00 yb 1
Paste the following into a Mascot search query window to verify this output:
MODS=Phospho (Y)
IT_MODS=Oxidation (M)
IT_MODS=Acetyl (N-term)
CHARGE=Mr
CLE=Trypsin
INSTRUMENT=MALDI-TOF-TOF
1320.686 ions(190.053, 261.090, 374.174, 521.243, 677.344, 790.428, 905.455, 1034.498, 1147.582)
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_aahelper.java

tools_aahelper.java

For calculating peptide and fragment masses.

/*
##############################################################################
# File: tools_aahelper.java #
# Mascot Parser toolkit example code #
# Acknowledgment: Thanks to Tony Major, Celera Genomics for converting this #
# file from the C++ example #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_java/tools_aahelper.java $
# $Author: villek@matrixscience.com $
# $Date: 2018-07-30 16:23:53 +0100 $
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
*/
import matrix_science.msparser.ms_enzymefile;
import matrix_science.msparser.ms_fragmentationrules;
import matrix_science.msparser.msparserConstants;
import matrix_science.msparser.*;
import java.text.*;
public class tools_aahelper {
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. "
+ "Is msparserj.dll on the path?\n" + e);
System.exit(0);
}
}
public static void main(String argv[])
{
// We need an enzyme to build a list of peptides
// and mod_file file if we want to apply any modifications
if(argv.length < 2) {
System.out.println("Location of enzymes file and mod_file has to be specified as parameters");
System.exit(0);
}
ms_enzymefile enzymefile = new ms_enzymefile(argv[0]);
if ( !enzymefile.isValid() )
{
System.out.println("There are errors. Cannot continue. The last error description:");
System.out.println(enzymefile.getLastErrorString());
System.exit(1);
}
ms_enzyme enzyme = enzymefile.getEnzymeByName("Trypsin");
if ( enzyme == null )
{
System.out.println("Cannot find Trypsin enzyme in the file. Cannot continue.");
System.exit(1);
}
// we need masses file, but can use default masses anyway
ms_masses masses = new ms_masses();
ms_modfile modfile = new ms_modfile(argv[1], masses);
if ( !modfile.isValid() )
{
System.out.println("There are errors. Cannot continue. The last error description:");
System.out.println(modfile.getLastErrorString());
System.exit(1);
}
ms_modification oxidation = modfile.getModificationByName("Oxidation (M)");
ms_modification acetylNterm = modfile.getModificationByName("Acetyl (N-term)");
ms_modification phospho = modfile.getModificationByName("Phospho (STY)");
if ( oxidation == null || acetylNterm == null || phospho == null )
{
System.out.println("Cannot find necessary modifications in the mod_file. Cannot continue.");
System.exit(1);
}
ms_aahelper aahelper = new ms_aahelper();
aahelper.setMasses(masses);
aahelper.setEnzyme(enzyme);
// Now we can generate peptides for a given protein
String proteinStr = "MAIFRIDEIRNMSSEELEEELRKLEVELIRERGAVRAGGAPEKPGRIREIRRTIARMKTVQRERVRK";
aahelper.startIteratePeptides(proteinStr, proteinStr.length(), 0);// no missed cleavages are allowed
System.out.println("List of peptides");
while(aahelper.getNextPeptide())
{
int start = aahelper.getPepStart()-1; // the method returns 1-based position
int end = aahelper.getPepEnd();
String peptideStr = proteinStr.substring(start, end);
//peptideStr.assign(proteinStr+start, len);
System.out.println(peptideStr);
}
System.out.println("End of list");
// create a list of fixed modifications
ms_modvector vecFixed = new ms_modvector();
vecFixed.appendModification(phospho);
// create a list of variable modifications
ms_modvector vecVariable = new ms_modvector();
vecVariable.appendModification(oxidation);
vecVariable.appendModification(acetylNterm);
aahelper.setAvailableModifications(vecFixed, vecVariable);
// ms_aahelper can also contain errors that might happen when applying modifications
// for instance, when we have a conflict between two modifications (same residue or same peptide end)
if ( !aahelper.isValid() )
{
System.out.println("There are errors. Cannot continue. The last error description:");
System.out.println(aahelper.getLastErrorString());
System.exit(1);
}
// we will need also a separate error-object for collecting peptide-specific errors
ms_errs err = new ms_errs();
// Example of how to call calcPeptideMZ
// It will often be more convenient to create an ms_peptide and then
// call getMrCalc() on that object.
vectori numThatMustBeModded = new vectori();
numThatMustBeModded.add(1); // 1 acetylNterm modification
numThatMustBeModded.add(1); // 1 site is phosphorylated
double mr = aahelper.calcPeptideMZ(proteinStr, proteinStr.length(),
1, 10, // peptide ends (1-based)
numThatMustBeModded,
0, // no charge
msparserConstants.MASS_TYPE_MONO,
err);
if ( !err.isValid() )
{
System.out.println("There have been errors while calculating peptide mass: ");
System.out.println(err.getLastErrorString());
// don't need to halt as they are not fatal errors
err.clearAllErrors(); // prepare to re-use it
}
else
{
DecimalFormat massFmt = new DecimalFormat("0.000");
System.out.println("Peptide mass calculated using 'calcPeptideMZ' is " + massFmt.format(mr));
}
// Create a peptide - which we can then fragment
//
// Specify which residues are modified by which modification.
// as it has to correspond to a modification string
// Nterm modification + 9 residues + Cterm modification
vectori numModded = new vectori();
numModded.add(2); // N-term - modified by "Acetyl (N-term)"
numModded.add(1); // M - modified by "Oxidation (M)"
numModded.add(0); // A
numModded.add(0); // I
numModded.add(0); // F
numModded.add(0); // R
numModded.add(0); // I
numModded.add(0); // D
numModded.add(0); // E
numModded.add(0); // I
numModded.add(0); // R
numModded.add(0); // C-term
// we have to specify (or at least supply an empty vector) which neutral loss value to use
// in case there are more than one available for a modification
vectori whichNl = new vectori();
whichNl.add(0); // N-term
whichNl.add(1); // M - has 2 neutral losses. Specify the first (-98)
whichNl.add(0); // A
whichNl.add(0); // I
whichNl.add(0); // F
whichNl.add(0); // R
whichNl.add(0); // I
whichNl.add(0); // D
whichNl.add(0); // E
whichNl.add(0); // I
whichNl.add(0); // R
whichNl.add(0); // C-term
ms_peptide peptide = aahelper.createPeptide(proteinStr, proteinStr.length(),
1,10, // end positions
numModded, // modification string-like vector
whichNl, // which neutral loss to use
0, // no charge
msparserConstants.MASS_TYPE_MONO,
err); // collect errors in it
if ( !err.isValid() )
{
System.out.println("There have been errors while creating a peptide: ");
System.out.println(err.getLastErrorString());
// don't need to halt as they are not fatal errors
err.clearAllErrors(); // prepare to re-use it
}
else
{
System.out.println();
System.out.println();
System.out.print("Peptide has been created successfully: ");
System.out.println(peptide.getPeptideStr());
}
vectord ions;
ms_fragmentvector fragments = new ms_fragmentvector();
ms_fragmentvector all_fragments = new ms_fragmentvector(); // Keep a list of fragments from all series
ions = aahelper.calcFragments(peptide, // that is why we needed to create a peptide object first
ms_fragmentationrules.FRAG_B_SERIES, // ions series ID
false, // single-charged ions only
100.0, // minimal fragment mass to return
mr, // maximal fragment mass to return
msparserConstants.MASS_TYPE_MONO,
fragments,
err); // collect peptide-specific errors
System.out.println("b-ion series fragments: ");
printFragmentsTable(fragments);
all_fragments.copyFrom(fragments);
ms_fragmentvector b_ions = new ms_fragmentvector();
b_ions.copyFrom(fragments);
ions = aahelper.calcFragments(peptide, // that is why we needed to create a peptide object first
ms_fragmentationrules.FRAG_Y_SERIES, // ions series ID
false, // single-charged ions only
100.0, // minimal fragment mass to return
mr, // maximal fragment mass to return
msparserConstants.MASS_TYPE_MONO,
fragments,
err); // collect peptide-specific errors
System.out.println("y-ion series fragments: ");
printFragmentsTable(fragments);
for (int i=0; i < fragments.getNumberOfFragments(); i++)
all_fragments.appendFragment(fragments.getFragmentByNumber(i));
aahelper.calcFragmentsEx(peptide, // that is why we needed to create a peptide object first
ms_fragmentationrules.FRAG_Y_SERIES, // ions series ID
2, // double-charged only
100.0, // minimal fragment mass to return
mr, // maximal fragment mass to return
msparserConstants.MASS_TYPE_MONO,
fragments,
err); // collect peptide-specific errors
System.out.println("y++-ion series fragments: ");
printFragmentsTable(fragments);
for (int i=0; i < fragments.getNumberOfFragments(); i++)
all_fragments.appendFragment(fragments.getFragmentByNumber(i));
ions = aahelper.calcFragments(peptide, // that is why we needed to create a peptide object first
ms_fragmentationrules.FRAG_INTERNAL_YB, // ions series ID
false, // single-charged ions only
100.0, // minimal fragment mass to return
700.0, // maximal fragment mass to return
msparserConstants.MASS_TYPE_MONO,
fragments,
err); // collect peptide-specific errors
System.out.println("internal yb-ion series fragments: ");
printFragmentsTable(fragments);
for (int i=0; i < fragments.getNumberOfFragments(); i++)
all_fragments.appendFragment(fragments.getFragmentByNumber(i));
System.out.println("Run a search under Mascot to verify the output above");
System.out.println("Paste the following into a Mascot search query window:");
displayMascotTestSearch(vecFixed, vecVariable,
enzyme,
mr,
b_ions); // Or you can use all_fragments
System.exit(0);
}
public static void printFragmentsTable(ms_fragmentvector fragments)
{
System.out.print("Number of fragments: ");
System.out.println(fragments.getNumberOfFragments());
System.out.println("Col\tStart\tEnd\tLabel\t\t Mass\t NL\tName\tImmon\tIntern\tReg");
int i;
for (i=0; i < fragments.getNumberOfFragments(); i++)
{
ms_fragment frag = fragments.getFragmentByNumber(i);
DecimalFormat fragMassFmt = new DecimalFormat("0.00");
System.out.print(frag.getColumn());
System.out.print("\t");
System.out.print(frag.getStart());
System.out.print("\t");
System.out.print(frag.getEnd());
System.out.print("\t");
System.out.print(padding(frag.getLabel(), 10, " "));
System.out.print("\t");
System.out.print(padout(fragMassFmt.format(frag.getMass()),7," "));
System.out.print("\t");
System.out.print(fragMassFmt.format(frag.getNeutralLoss()));
System.out.print("\t");
System.out.print(frag.getSeriesName());
System.out.print("\t");
if (frag.isImmonium())
System.out.print("1\t");
else
System.out.print("0\t");
if (frag.isInternal())
System.out.print("1\t");
else
System.out.print("0\t");
if (frag.isRegular())
System.out.print("1\n");
else
System.out.print("0\n");
}
System.out.println();
}
public static void displayMascotTestSearch(ms_modvector vecFixed,
ms_modvector vecVariable,
ms_enzyme enzyme,
double mr,
ms_fragmentvector fragments)
{
/* fragments contains a list of b-ions from a peptide
* vecVariable contains a list of variable mods applied to the peptide
* vecFixed contains a list of fixed mods applied to the peptide
* Use this information to generate an test search that can be run on Mascot.
*/
int i;
for (i=0; i < vecFixed.getNumberOfModifications(); i++)
{
System.out.print("MODS=");
System.out.println(vecFixed.getModificationByNumber(i).getTitle());
}
for (i=0; i < vecVariable.getNumberOfModifications(); i++)
{
System.out.print("IT_MODS=");
System.out.println(vecVariable.getModificationByNumber(i).getTitle());
}
System.out.println("CHARGE=Mr");
System.out.print("CLE=");
System.out.println(enzyme.getTitle());
System.out.println("INSTRUMENT=MALDI-TOF-TOF");
DecimalFormat massFmt = new DecimalFormat("#0.000");
System.out.print(massFmt.format(mr) + " ions(" );
for(i=0; i < fragments.getNumberOfFragments(); i++)
{
if (i > 0)
System.out.print(", ");
double mz = fragments.getFragmentByNumber(i).getMass();
System.out.print(massFmt.format(mz));
}
System.out.println(")");
}
private static String padout(String toPrint, int length,String padding) {
String returnValue="";
if(toPrint.length() < length) {
for(int queryLoop = 1; queryLoop <= length - toPrint.length(); queryLoop++) {
returnValue += padding;
}
returnValue += toPrint;
}
else returnValue = toPrint;
return returnValue;
}
private static String padding(String toPrint, int length,String padding) {
String returnValue=toPrint;
if(toPrint.length() < length) {
for(int queryLoop = 1; queryLoop <= length - toPrint.length(); queryLoop++) {
returnValue += padding;
}
}
return returnValue;
}
}
/*
will give the output:
C:\msparser\example_java>java -classpath .;../java/msparser.jar tools_aahelper c:\Inetpub\MASCOT\config\enzymes c:\Inetpub\MASCOT\config\mod_file
List of peptides
M
MEDYLDELR
EDYLDELR
HK
IPSFIVELLK
NNLK
NR
NLTR
NQLNK
IVNR
VSDLYFGK
KPEDK
K
AAELTNK
INDLSHK
LDALMK
VATVSSATK
VSDDIK
K
EIDNLDELDL
End of list
Peptide mass calculated using 'calcPeptideMZ' is 1320.494
Peptide has been created successfully: MEDYLDELR
b-ion series fragments:
Number of fragments: 8
Col Start End Label Mass NL Name Immon Intern Reg
1 1 -1 b(1) 190.05 0.00 b 0 0 1
2 2 -1 b(2) 319.10 0.00 b 0 0 1
3 3 -1 b(3) 434.12 0.00 b 0 0 1
4 4 -1 b(4) -97 579.18 97.98 b 0 0 1
5 5 -1 b(5) -97 692.26 97.98 b 0 0 1
6 6 -1 b(6) -97 807.29 97.98 b 0 0 1
7 7 -1 b(7) -97 936.33 97.98 b 0 0 1
8 8 -1 b(8) -97 1049.41 97.98 b 0 0 1
y-ion series fragments:
Number of fragments: 8
Col Start End Label Mass NL Name Immon Intern Reg
8 8 -1 y(8) -97 1034.48 97.98 y 0 0 1
7 7 -1 y(7) -97 905.44 97.98 y 0 0 1
6 6 -1 y(6) -97 790.41 97.98 y 0 0 1
5 5 -1 y(5) 645.36 0.00 y 0 0 1
4 4 -1 y(4) 532.27 0.00 y 0 0 1
3 3 -1 y(3) 417.25 0.00 y 0 0 1
2 2 -1 y(2) 288.20 0.00 y 0 0 1
1 1 -1 y(1) 175.12 0.00 y 0 0 1
internal yb-ion series fragments:
Number of fragments: 18
Col Start End Label Mass NL Name Immon Intern Reg
2 2 3 ED 245.08 0.00 yb 0 1 0
2 2 4 EDY -97 390.13 97.98 yb 0 1 0
2 2 5 EDYL -97 503.21 97.98 yb 0 1 0
2 2 6 EDYLD -97 618.24 97.98 yb 0 1 0
3 3 4 DY -97 261.09 97.98 yb 0 1 0
3 3 5 DYL -97 374.17 97.98 yb 0 1 0
3 3 6 DYLD -97 489.20 97.98 yb 0 1 0
3 3 7 DYLDE -97 618.24 97.98 yb 0 1 0
4 4 5 YL -97 259.14 97.98 yb 0 1 0
4 4 6 YLD -97 374.17 97.98 yb 0 1 0
4 4 7 YLDE -97 503.21 97.98 yb 0 1 0
4 4 8 YLDEL -97 616.30 97.98 yb 0 1 0
5 5 6 LD 229.12 0.00 yb 0 1 0
5 5 7 LDE 358.16 0.00 yb 0 1 0
5 5 8 LDEL 471.24 0.00 yb 0 1 0
6 6 7 DE 245.08 0.00 yb 0 1 0
6 6 8 DEL 358.16 0.00 yb 0 1 0
7 7 8 EL 243.13 0.00 yb 0 1 0
Run a search under Mascot to verify the output above
Paste the following into a Mascot search query window:
MODS=Oxidation (M)
IT_MODS=Acetyl (N-term)
IT_MODS=Phospho (STY)
CHARGE=Mr
CLE=Trypsin
INSTRUMENT=MALDI-TOF-TOF
1320.494 ions(190.053, 319.096, 434.123, 579.176, 692.260, 807.287, 936.329, 1049.413)
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_aahelper.py

tools_aahelper.py

For calculating peptide and fragment masses.

1#!/usr/bin/python
2
15
16import msparser
17import sys
18
19def main() :
20 if len(sys.argv) < 4 :
21 print("Usage: %s ENZYMES_FILE UNIMOD SCHEMA" % sys.argv[0])
22 print("ENZYMES_FILE is the enzymes file path, e.g., ../config/enzymes")
23 print("UNIMOD is the file path to the unimod.xml file, e.g., ../config/unimod.xml or a fully formed URL such as http://www.matrixscience.com/cgi .")
24 print("SCHEMA is the unimod schema file path, e.g., ../html/xmlns/schema/unimod_2/unimod_2.xsd")
25 sys.exit(1)
26
27
28 enzymefile = open_enzymefile(sys.argv[1])
29
30 # Note: both enzymefile *must* be kept in scope for as long as you use
31 # Trypsin. See "Using the toolkit from Perl, Java and Python" in Mascot Parser
32 # manual.
33 Trypsin = enzymefile.getEnzymeByName('Trypsin')
34
35 if not Trypsin :
36 print("Cannot find 'Trypsin' in the enzyme file. Cannot continue.")
37 return 1
38
39
40 modfile = open_modfile(sys.argv[2], sys.argv[3])
41
42 aahelper = msparser.ms_aahelper()
43 # Note: both modfile and Trypsin *must* be kept in scope for as
44 # long as you use aahelper. See "Using the toolkit from Perl, Java and
45 # Python" in Mascot Parser manual.
46 aahelper.setMasses(modfile.getMassFile())
47 aahelper.setEnzyme(Trypsin)
48
49 # Now we can generate peptides for a given protein. This is
50 # RL29_METTP (50S ribosomal protein L29P OS=Methanosaeta thermophila (strain
51 # DSM 6194 / PT) GN=rpl29p PE=3 SV=1) from SwissProt 2010_09.
52 proteinStr = "MAIFRIDEIRNMSSEELEEELRKLEVELIRERGAVRAGGAPEKPGRIREIRRTIARMKTVQRERVRK"
53
54 # No missed cleavages are allowed (third parameter).
55 aahelper.startIteratePeptides(proteinStr, len(proteinStr), 0);
56
57 print("List of peptides")
58
59 while aahelper.getNextPeptide() :
60 start = aahelper.getPepStart();
61 end = aahelper.getPepEnd()
62
63 # getPepStart() and getPeptideEnd() return one-based index.
64 peptideStr = proteinStr[start - 1 : end]
65 print(peptideStr)
66
67 print("End of list")
68
69 # Create a list of fixed modifications.
70 vecFixed = msparser.ms_modvector()
71 vecFixed.appendModification( modfile.getModificationByName('Phospho (Y)') )
72
73 # Create a list of variable modifications.
74 vecVariable = msparser.ms_modvector()
75 vecVariable.appendModification( modfile.getModificationByName('Oxidation (M)') )
76 vecVariable.appendModification( modfile.getModificationByName('Acetyl (N-term)') )
77
78 # Note: both vecFixed and vecVariable *must* be kept in scope for as
79 # long as you use aahelper. See "Using the toolkit from Perl, Java and
80 # Python" in Mascot Parser manual.
81 aahelper.setAvailableModifications(vecFixed, vecVariable)
82
83 # ms_aahelper can also contain errors that might happen when applying
84 # modifications, for instance when we have a conflict between two
85 # modifications (same residue or same peptide end).
86 if not aahelper.isValid() :
87 print("Error while setting available modifications: %s" % aahelper.getLastErrorString())
88 return 1
89
90 # We will need also a separate error object for collecting peptide-specific
91 # errors.
92 err = msparser.ms_errs()
93
94 # Example of how to call calcPeptideMZ(). It will often be more convenient to
95 # create an ms_peptide instead, and then call getMrCalc() on that object.
96 numThatMustBeModded = msparser.vectori()
97 numThatMustBeModded.append(1); # 1 acetylNterm modification
98 numThatMustBeModded.append(1); # 1 site is oxidised
99
100 mr = aahelper.calcPeptideMZ(
101 proteinStr,
102 len(proteinStr),
103 1,
104 10, # peptide ends (1-based)
105 numThatMustBeModded,
106 0, # no charge - i.e. Mr
107 msparser.MASS_TYPE_MONO,
108 err
109 )
110
111 if err.isValid() :
112 print("Peptide mass calculated using 'calcPeptideMZ' is %8.3f" % mr)
113 else :
114 print("Error while calculating peptide mass: %s" % err.getLastErrorString())
115 # Don't need to halt as they are not fatal errors.
116 err.clearAllErrors();
117
118 # Create a peptide - which we can then fragment.
119 #
120 # Specify which residues are modified by which modification as it has to
121 # correspond to a modification string:
122 #
123 # Nterm modification + 9 residues + Cterm modification
124 numModded = msparser.vectori()
125 numModded.append(2) # N-term - modified by "Acetyl (N-term)"
126 numModded.append(1) # M - modified by "Oxidation (M)"
127 numModded.append(0) # A
128 numModded.append(0) # I
129 numModded.append(0) # F
130 numModded.append(0) # R
131 numModded.append(0) # I
132 numModded.append(0) # D
133 numModded.append(0) # E
134 numModded.append(0) # I
135 numModded.append(0) # R
136 numModded.append(0) # C-term
137
138 # We have to specify (or at least supply an empty vector) which neutral loss
139 # value to use, in case there are more than one available for a modification.
140 whichNl = msparser.vectori()
141 whichNl.append(0) # N-term
142 whichNl.append(1) # M - has 2 neutral losses. Specify the first (-98)
143 whichNl.append(0) # A
144 whichNl.append(0) # I
145 whichNl.append(0) # F
146 whichNl.append(0) # R
147 whichNl.append(0) # I
148 whichNl.append(0) # D
149 whichNl.append(0) # E
150 whichNl.append(0) # I
151 whichNl.append(0) # R
152 whichNl.append(0) # C-term
153
154 peptide = aahelper.createPeptide(
155 proteinStr,
156 len(proteinStr),
157 1,
158 10, # end positions
159 numModded, # modification string-like vector
160 whichNl, # which neutral loss to use
161 0, # no charge
162 msparser.MASS_TYPE_MONO,
163 err
164 )
165
166 if not err.isValid() :
167 print("Error while creating a peptide: %s" % err.getLastErrorString())
168 # Don't need to halt as they are not fatal errors.
169 err.clearAllErrors()
170 else :
171 print("Peptide has been created successfully: %s" % peptide.getPeptideStr())
172
173
174 # Keep a list of fragments from all series
175 all_fragments = msparser.ms_fragmentvector()
176
177 b_ions = fragmentPeptide(
178 aahelper,
179 peptide,
180 msparser.ms_fragmentationrules.FRAG_B_SERIES,
181 'b-ion series',
182 0, # single-charged ions only
183 mr # maximal fragment mass to return
184 )
185
186 # copyFrom() can only be used to populate the list for the first time.
187 all_fragments.copyFrom(b_ions)
188
189 fragments = fragmentPeptide(
190 aahelper,
191 peptide,
192 msparser.ms_fragmentationrules.FRAG_Y_SERIES,
193 'y-ion series',
194 0, # single-charged ions only
195 mr # maximal fragment mass to return
196 )
197
198 for i in range(fragments.getNumberOfFragments()) :
199 all_fragments.appendFragment(fragments.getFragmentByNumber(i))
200
201
202 fragments = fragmentPeptide(
203 aahelper,
204 peptide,
205 msparser.ms_fragmentationrules.FRAG_Y_SERIES,
206 'y++-ion series',
207 2, # double-charged ions only
208 mr # maximal fragment mass to return
209 )
210
211 for i in range(fragments.getNumberOfFragments()) :
212 all_fragments.appendFragment(fragments.getFragmentByNumber(i))
213
214
215 fragments = fragmentPeptide(
216 aahelper,
217 peptide,
218 msparser.ms_fragmentationrules.FRAG_INTERNAL_YB,
219 'internal yb-ion series',
220 0, # single-charged ions only
221 700 # maximal fragment mass to return
222 )
223
224 for i in range(fragments.getNumberOfFragments()) :
225 all_fragments.appendFragment(fragments.getFragmentByNumber(i))
226
227
228 print("Paste the following into a Mascot search query window to verify this output:")
229
230 displayMascotTestSearch(
231 vecFixed, vecVariable, Trypsin, peptide.getMrCalc(),
232 b_ions # or you can use all_fragments
233 )
234
235
236def open_enzymefile(filename) :
237 enzymefile = msparser.ms_enzymefile(filename)
238
239 if not enzymefile.isValid :
240 print("Error while opening enzyme file: %s " % enzymefile.getLastErrorString())
241 sys.exit(1)
242
243 return enzymefile
244
245
246def open_modfile(umod_filename, schema_filename) :
247 umodFile = msparser.ms_umod_configfile(umod_filename, schema_filename)
248 modfile = msparser.ms_modfile(umodFile)
249
250 if not modfile.isValid() :
251 print("Error while opening mod file: %s" % modfile.getLastErrorString())
252 sys.exit(1)
253
254 for mod in ['Oxidation (M)', 'Acetyl (N-term)', 'Phospho (Y)'] :
255 if not modfile.getModificationByName(mod) :
256 print("Cannot find '%s' in the mod file. Cannot continue." % mod)
257 sys.exit(1)
258
259 return modfile
260
261
262def fragmentPeptide(aahelper, peptide, series, series_label, doubleCharged, mass_max) :
263 fragments = msparser.ms_fragmentvector()
264 err = msparser.ms_errs()
265
266 aahelper.calcFragments(
267 peptide,
268 series,
269 doubleCharged,
270 100.0,
271 mass_max,
272 msparser.MASS_TYPE_MONO,
273 fragments,
274 err
275 )
276
277 # Check err here.
278
279 print(series_label + " fragments:")
280 printFragmentsTable(fragments)
281
282 return fragments
283
284
285def printFragmentsTable(fragments) :
286
287 print("Number of fragments: %d" % fragments.getNumberOfFragments())
288
289 headerfmt = "%5s %5s %5s %-10s %7s %7s %4s %5s %6s %4s"
290 fmt = "%5s %5s %5s %-10s %7.2f %7.2f %4s %5s %6s %4s"
291
292 print(headerfmt % ("Col", "Start", "End", "Label", "Mass", "NL", "Name", "Immon", "Intern", "Reg"))
293
294 for i in range(fragments.getNumberOfFragments()) :
295 frag = fragments.getFragmentByNumber(i)
296
297 print(fmt % (
298 frag.getColumn(),
299 frag.getStart(),
300 frag.getEnd(),
301 frag.getLabel(),
302 frag.getMass(),
303 frag.getNeutralLoss(),
304 frag.getSeriesName(),
305 frag.isImmonium(),
306 frag.isInternal(),
307 frag.isRegular()
308 ))
309
310 print(" ")
311
312
313def displayMascotTestSearch(vecFixed, vecVariable, enzyme, mr, fragments) :
314 """
315 vecFixed contains a list of fixed mods applied to the peptide
316 vecVariable contains a list of variable mods applied to the peptide
317 enzyme is the enzyme used in fragmentation
318 mr is the peptide Mr(calc)
319 fragments contains a list of b-ions from a peptide
320
321 Use this information to generate an test search that can be run on Mascot.
322 """
323
324 for i in range(vecFixed.getNumberOfModifications()) :
325 print("MODS=%s" % vecFixed.getModificationByNumber(i).getTitle())
326
327
328 for i in range(vecVariable.getNumberOfModifications()) :
329 print("IT_MODS=%s" % vecVariable.getModificationByNumber(i).getTitle())
330
331
332 print("CHARGE=Mr")
333 print("CLE=%s" % enzyme.getTitle())
334 print("INSTRUMENT=MALDI-TOF-TOF")
335
336 masses = []
337 for i in range(fragments.getNumberOfFragments()) :
338 masses.append("%.3f" % fragments.getFragmentByNumber(i).getMass())
339
340 print("%.3f ions(%s)" % (mr, ", ".join(masses)))
341
342
343if __name__ == "__main__" :
344 sys.exit(main())
345
346
347"""
348
349Running the program as
350
351python tools_aahelper.pl /usr/local/mascot/config/enzymes /usr/local/mascot/config/mod_file
352
353will give the following output under Mascot 2.3:
354
355
356List of peptides
357M
358MAIFR
359AIFR
360IDEIR
361NMSSEELEEELR
362K
363LEVELIR
364ER
365GAVR
366AGGAPEKPGR
367IR
368EIR
369R
370TIAR
371MK
372TVQR
373ER
374VR
375K
376End of list
377Peptide mass calculated using 'calcPeptideMZ' is 1320.686
378Peptide has been created successfully: MAIFRIDEIR
379b-ion series fragments:
380Number of fragments: 9
381 Col Start End Label Mass NL Name Immon Intern Reg
382 1 1 -1 b(1) 190.05 0.00 b False False True
383 2 2 -1 b(2) 261.09 0.00 b False False True
384 3 3 -1 b(3) 374.17 0.00 b False False True
385 4 4 -1 b(4) 521.24 0.00 b False False True
386 5 5 -1 b(5) 677.34 0.00 b False False True
387 6 6 -1 b(6) 790.43 0.00 b False False True
388 7 7 -1 b(7) 905.45 0.00 b False False True
389 8 8 -1 b(8) 1034.50 0.00 b False False True
390 9 9 -1 b(9) 1147.58 0.00 b False False True
391
392y-ion series fragments:
393Number of fragments: 9
394 Col Start End Label Mass NL Name Immon Intern Reg
395 9 9 -1 y(9) 1132.65 0.00 y False False True
396 8 8 -1 y(8) 1061.61 0.00 y False False True
397 7 7 -1 y(7) 948.53 0.00 y False False True
398 6 6 -1 y(6) 801.46 0.00 y False False True
399 5 5 -1 y(5) 645.36 0.00 y False False True
400 4 4 -1 y(4) 532.27 0.00 y False False True
401 3 3 -1 y(3) 417.25 0.00 y False False True
402 2 2 -1 y(2) 288.20 0.00 y False False True
403 1 1 -1 y(1) 175.12 0.00 y False False True
404
405y++-ion series fragments:
406Number of fragments: 8
407 Col Start End Label Mass NL Name Immon Intern Reg
408 9 9 -1 y(9)++ 566.83 0.00 y False False True
409 8 8 -1 y(8)++ 531.31 0.00 y False False True
410 7 7 -1 y(7)++ 474.77 0.00 y False False True
411 6 6 -1 y(6)++ 401.23 0.00 y False False True
412 5 5 -1 y(5)++ 323.18 0.00 y False False True
413 4 4 -1 y(4)++ 266.64 0.00 y False False True
414 3 3 -1 y(3)++ 209.13 0.00 y False False True
415 2 2 -1 y(2)++ 144.61 0.00 y False False True
416
417internal yb-ion series fragments:
418Number of fragments: 22
419 Col Start End Label Mass NL Name Immon Intern Reg
420 2 2 3 AI 185.13 0.00 yb False True False
421 2 2 4 AIF 332.20 0.00 yb False True False
422 2 2 5 AIFR 488.30 0.00 yb False True False
423 2 2 6 AIFRI 601.38 0.00 yb False True False
424 3 3 4 IF 261.16 0.00 yb False True False
425 3 3 5 IFR 417.26 0.00 yb False True False
426 3 3 6 IFRI 530.34 0.00 yb False True False
427 3 3 7 IFRID 645.37 0.00 yb False True False
428 4 4 5 FR 304.18 0.00 yb False True False
429 4 4 6 FRI 417.26 0.00 yb False True False
430 4 4 7 FRID 532.29 0.00 yb False True False
431 4 4 8 FRIDE 661.33 0.00 yb False True False
432 5 5 6 RI 270.19 0.00 yb False True False
433 5 5 7 RID 385.22 0.00 yb False True False
434 5 5 8 RIDE 514.26 0.00 yb False True False
435 5 5 9 RIDEI 627.35 0.00 yb False True False
436 6 6 7 ID 229.12 0.00 yb False True False
437 6 6 8 IDE 358.16 0.00 yb False True False
438 6 6 9 IDEI 471.24 0.00 yb False True False
439 7 7 8 DE 245.08 0.00 yb False True False
440 7 7 9 DEI 358.16 0.00 yb False True False
441 8 8 9 EI 243.13 0.00 yb False True False
442
443Paste the following into a Mascot search query window to verify this output:
444MODS=Phospho (Y)
445IT_MODS=Oxidation (M)
446IT_MODS=Acetyl (N-term)
447CHARGE=Mr
448CLE=Trypsin
449INSTRUMENT=MALDI-TOF-TOF
4501320.686 ions(190.053, 261.090, 374.174, 521.243, 677.344, 790.428, 905.455, 1034.498, 1147.582)
451
452"""
453
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_aahelper.cs

tools_aahelper.cs

For calculating peptide and fragment masses.

/*
##############################################################################
# file: tools_aahelper.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/tools_aahelper.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.Collections.Generic;
using matrix_science.msparser;
using System.Text;
namespace MsParserExamples
{
class tools_aahelper
{
public static int Main(string[] argv)
{
if (argv.Length < 2)
{
// We need an enzyme to build a list of peptides and mod_file file if we
// want to apply any modifications
Console.Error.WriteLine("Location of enzymes file and mod_file have to be specified as parameters");
return 1;
}
ms_enzymefile enzymefile;
if (!openEnzymefile(argv[0], out enzymefile))
{
return 1;
}
// Note: enzymefile *must* me kept in scope for as long as you use 'trypsin'.
// See "Using the toolkit from Perl, Java, Python and C#" in the Mascot Parser
// manual.
ms_enzyme trypsin = enzymefile.getEnzymeByName("Trypsin");
if (trypsin == null)
{
Console.Error.WriteLine("Cannot find 'Trypsin' in the enzyme file. Cannot continue.");
return 1;
}
ms_modfile modfile;
if(!openModfile(argv[1], out modfile)) {
return 1;
}
ms_aahelper aahelper = new ms_aahelper();
// Note: both modfile and trypsin *must* be kept in score for as long as
// you use aahelper. See "Using the toolkit from Perl, Java, Python and C#" in the
// Mascot Parser manual.
aahelper.setMasses(modfile.getMassFile());
aahelper.setEnzyme(trypsin);
// Now we can generate peptides for a given protein. This is
// RL29_METTP (50S ribosomal protein L29P OS=Methanosaeta thermophila (strain
// DSM 6194 / PT) GN=rpl29p PE=3 SV=1) from SwissProt 2010_09.
string proteinStr = "MAIFRIDEIRNMSSEELEEELRKLEVELIRERGAVRAGGAPEKPGRIREIRRTIARMKTVQRERVRK";
// No missed cleavages are allowed (third parameter)
aahelper.startIteratePeptides(proteinStr, proteinStr.Length, 0);
Console.WriteLine("List of peptides");
while (aahelper.getNextPeptide())
{
int start = aahelper.getPepStart(), len = aahelper.getPepEnd() - aahelper.getPepStart() + 1;
// getPepStart() returns one-based index
string peptideStr = proteinStr.Substring(start - 1, len);
Console.WriteLine(peptideStr);
}
Console.WriteLine("End of list\n");
// Create a list of fixed modifications
ms_modvector vecFixed = new ms_modvector();
vecFixed.appendModification(modfile.getModificationByName("Phospho (Y)"));
// Create a list of variable modifications
ms_modvector vecVariable = new ms_modvector();
vecVariable.appendModification(modfile.getModificationByName("Oxidation (M)"));
vecVariable.appendModification(modfile.getModificationByName("Acetyl (N-term)"));
// Note: Both vecFixed and vecVariable *must* be kept in scope for as long as you use
// aahelper. See "Using the toolkit from Perl, Java, Python and C#" in the
// Mascot Parser manual
aahelper.setAvailableModifications(vecFixed, vecVariable);
// ms_aahelper can also contain errors that might happen when applying modifications,
// for example when we have a conflict between two modifications (same residue or same
// peptide end).
if (!aahelper.isValid())
{
Console.WriteLine("Error while setting available modifications: {0}", aahelper.getLastErrorString());
return 1;
}
// We will also need a separate error object for collecting peptide specific errors
ms_errs err = new ms_errs();
// Example of hot to call calcPeptideMZ(). It will often be more convenient to
// create an ms_peptide instead, and the call getMrCalc() on that object
vectori numThatMustBeModded = new vectori();
numThatMustBeModded.Add(1); // 1 acetylNterm modification
numThatMustBeModded.Add(1); // 1 site is oxidised
double mr = aahelper.calcPeptideMZ(proteinStr,
proteinStr.Length,
1,
10, // peptide ends (1-based)
numThatMustBeModded,
0, // No charge - i.e. Mr
MASS_TYPE.MASS_TYPE_MONO,
err);
if (!err.isValid())
{
Console.Error.WriteLine("Error while calculating peptide mass: {0}", err.getLastErrorString());
// Don't need to halt as they are not fatal errors
err.clearAllErrors();
}
else
{
Console.WriteLine("Peptide mass calculated using 'calcPeptideMZ' is {0:########.###}", mr);
}
// Create a peptide - which we can then fragment
//
// Specify which residues are modified and by whoch modification as it has to
// correspond to a modification string:
//
// Nterm modification + 9 residues + Cterm modification
vectori numModded = new vectori()
{
{2}, // N-term - modified by 'Acetyl (N-term)'
{1}, // M - modified by 'Oxidation (M)'
{0}, // A
{0}, // I
{0}, // F
{0}, // R
{0}, // I
{0}, // D
{0}, // E
{0}, // I
{0}, // R
{0} // C-Term
};
// We have to specify (or at least supply an empty vector) which neutral loss
// value to use, in case there are more than one available for a modification
vectori whichNL = new vectori() {
{0}, // N-term
{1}, // M - has 2 neutral losses. Specify the first (-98)
{0}, // A
{0}, // I
{0}, // F
{0}, // R
{0}, // I
{0}, // D
{0}, // E
{0}, // I
{0}, // R
{0} // C-term
};
ms_peptide peptide = aahelper.createPeptide(
proteinStr,
proteinStr.Length,
1,
10, // end position
numModded, // modification string-like vector
whichNL, // which neutral loss to use
0, // no charge
MASS_TYPE.MASS_TYPE_MONO,
err);
if (!err.isValid())
{
Console.Error.WriteLine("Error while creating a peptide: {0}", err.getLastErrorString());
// Don't need to halt as they are not fatal errors
err.clearAllErrors();
}
else
{
Console.WriteLine("\n\nPeptide has been created successfully: {0}", peptide.getPeptideStr());
}
// Keep a list of fragments from all series
ms_fragmentvector allFragments = new ms_fragmentvector();
ms_fragmentvector bions = fragmentPeptide(aahelper,
peptide,
(int) ms_fragmentationrules.FRAG_SERIES_TYPE.FRAG_B_SERIES,
"b-ions series",
false, // singly charged ions only
mr // maximal fragment mass to return
);
// copyFrom() an only be used to populate the list for the first time
allFragments.copyFrom(bions);
ms_fragmentvector fragments = fragmentPeptide(aahelper,
peptide,
(int) ms_fragmentationrules.FRAG_SERIES_TYPE.FRAG_Y_SERIES,
"y-ion series",
false, // singly charged ions only
mr // maximal fragment mass to return
);
for (uint i = 0; i < fragments.getNumberOfFragments(); i++)
{
allFragments.appendFragment(fragments.getFragmentByNumber(i));
}
fragments = fragmentPeptide(aahelper,
peptide,
(int)ms_fragmentationrules.FRAG_SERIES_TYPE.FRAG_INTERNAL_YB,
"internal yb-ion series",
false, // singly charged ions only
700 // maximal fragment mass to return
);
for(uint i = 0; i < fragments.getNumberOfFragments(); i++) {
allFragments.appendFragment(fragments.getFragmentByNumber(i));
}
Console.WriteLine("Paste the following into a Mascot search query window to verify this output:");
displayMascotTestSearch(vecFixed, vecVariable, trypsin, peptide.getMrCalc(),
bions); // or you can use allFragments
return 0;
}
// vecFixed contains a list of fixed mods applied to the peptide
// vecVariable contains a list of variable mods applied to the peptide
// enzyme is the enzyme used
// me if the peptide Mr(calc)
// fragments contains a list of b-ions from a peptide
//
// use this information to generate a test search that can be run on Mascot
private static void displayMascotTestSearch(ms_modvector vecFixed, ms_modvector vecVariable, ms_enzyme enzyme, double mr, ms_fragmentvector fragments)
{
for (int i = 0; i < vecFixed.getNumberOfModifications(); i++)
{
Console.WriteLine("MODS={0}", vecFixed.getModificationByNumber(i).getTitle());
}
for (int i = 0; i < vecVariable.getNumberOfModifications(); i++)
{
Console.WriteLine("IT_MODS={0}", vecVariable.getModificationByNumber(i).getTitle());
}
Console.WriteLine("CHARGE=Mr");
Console.WriteLine("CLE={0}", enzyme.getTitle());
Console.Write("{0:#.###} ions(", mr);
StringBuilder sbIons = new StringBuilder();
for (uint i = 0; i < fragments.getNumberOfFragments(); i++)
{
if (i > 0) sbIons.Append(", ");
sbIons.Append(string.Format("{0:0.###}", fragments.getFragmentByNumber(i).getMass()));
}
Console.Write(sbIons);
Console.WriteLine(")");
}
private static ms_fragmentvector fragmentPeptide(ms_aahelper aahelper, ms_peptide peptide, int series, string seriesLabel, bool doubleCharged, double massMax)
{
ms_fragmentvector fragments = new ms_fragmentvector();
ms_errs err = new ms_errs();
aahelper.calcFragments(
peptide,
series,
doubleCharged,
100d,
massMax,
MASS_TYPE.MASS_TYPE_MONO,
fragments,
err);
if (!err.isValid())
{
Console.Error.WriteLine("Error while creating peptide {0} fragments: {1}", seriesLabel, err.getLastErrorString());
err.clearAllErrors();
}
Console.WriteLine("{0} fragments", seriesLabel);
printFragmentsTable(fragments);
return fragments;
}
private static void printFragmentsTable(ms_fragmentvector fragments)
{
Console.WriteLine("Number of fragments: {0}", fragments.getNumberOfFragments());
string fmt = "{0} {1} {2} {3} {4} {5} {6} {7} {8} {9}";
Console.WriteLine(fmt, "Col".PadLeft(5),
"Start".PadLeft(5),
"End".PadLeft(5),
"Label".PadLeft(10),
"Mass".PadLeft(10),
"NL".PadLeft(10),
"Name",
"Immon",
"Intern",
"Reg".PadLeft(4));
for (uint i = 0; i < fragments.getNumberOfFragments(); i++)
{
ms_fragment frag = fragments.getFragmentByNumber(i);
Console.WriteLine(fmt,
frag.getColumn().ToString().PadLeft(5),
frag.getStart().ToString().PadLeft(5),
frag.getEnd().ToString().PadLeft(5),
frag.getLabel().PadLeft(10),
string.Format("{0:######0.00}", frag.getMass()).PadLeft(10),
string.Format("{0:######0.00}", frag.getNeutralLoss()).PadLeft(10),
frag.getSeriesName().PadLeft(4),
(frag.isImmonium() ? "1" : "").PadLeft(5),
(frag.isInternal() ? "1" : "").PadLeft(6),
(frag.isRegular() ? "1" : "").PadLeft(4));
}
Console.WriteLine();
}
private static bool openModfile(string filename, out ms_modfile modfile)
{
// We can use the default masses in this example
ms_masses masses = new ms_masses();
modfile = new ms_modfile(filename, masses);
if (!modfile.isValid())
{
Console.Error.WriteLine("Error while opening mod file: {0}", modfile.getLastErrorString());
return false;
}
string[] aTargetMods = new string[]{"Oxidation (M)", "Acetyl (N-term)", "Phospho (Y)"};
foreach(string mod in aTargetMods) {
if (modfile.getModificationByName(mod) == null)
{
Console.Error.WriteLine("Cannot find '{0}' in the mod file. Cannot continue.", mod);
return false;
}
}
return true;
}
private static bool openEnzymefile(string filename, out ms_enzymefile enzymefile)
{
enzymefile = new ms_enzymefile(filename);
if (!enzymefile.isValid())
{
Console.Error.WriteLine("Error while opening enzyme file: {0}", enzymefile.getLastErrorString());
return false;
}
return true;
}
}
}
/*
tools_aahelper.exe c:\inetpub\mascot\config\enzymes c:\inetpub\mascot\config\mod_file
Will give the following output:
List of peptides
M
MAIFR
AIFR
IDEIR
NMSSEELEEELR
K
LEVELIR
ER
GAVR
AGGAPEKPGR
IR
EIR
R
TIAR
MK
TVQR
ER
VR
K
End of list
Peptide mass calculated using 'calcPeptideMZ' is 1320.686
Peptide has been created successfully: MAIFRIDEIR
b-ions series fragments
Number of fragments: 9
Col Start End Label Mass NL Name Immon Intern Reg
1 1 -1 b(1) 190.05 0.00 b 1
2 2 -1 b(2) 261.09 0.00 b 1
3 3 -1 b(3) 374.17 0.00 b 1
4 4 -1 b(4) 521.24 0.00 b 1
5 5 -1 b(5) 677.34 0.00 b 1
6 6 -1 b(6) 790.43 0.00 b 1
7 7 -1 b(7) 905.45 0.00 b 1
8 8 -1 b(8) 1034.50 0.00 b 1
9 9 -1 b(9) 1147.58 0.00 b 1
y-ion series fragments
Number of fragments: 9
Col Start End Label Mass NL Name Immon Intern Reg
9 9 -1 y(9) 1132.65 0.00 y 1
8 8 -1 y(8) 1061.61 0.00 y 1
7 7 -1 y(7) 948.53 0.00 y 1
6 6 -1 y(6) 801.46 0.00 y 1
5 5 -1 y(5) 645.36 0.00 y 1
4 4 -1 y(4) 532.27 0.00 y 1
3 3 -1 y(3) 417.25 0.00 y 1
2 2 -1 y(2) 288.20 0.00 y 1
1 1 -1 y(1) 175.12 0.00 y 1
internal yb-ion series fragments
Number of fragments: 22
Col Start End Label Mass NL Name Immon Intern Reg
2 2 3 AI 185.13 0.00 yb 1
2 2 4 AIF 332.20 0.00 yb 1
2 2 5 AIFR 488.30 0.00 yb 1
2 2 6 AIFRI 601.38 0.00 yb 1
3 3 4 IF 261.16 0.00 yb 1
3 3 5 IFR 417.26 0.00 yb 1
3 3 6 IFRI 530.34 0.00 yb 1
3 3 7 IFRID 645.37 0.00 yb 1
4 4 5 FR 304.18 0.00 yb 1
4 4 6 FRI 417.26 0.00 yb 1
4 4 7 FRID 532.29 0.00 yb 1
4 4 8 FRIDE 661.33 0.00 yb 1
5 5 6 RI 270.19 0.00 yb 1
5 5 7 RID 385.22 0.00 yb 1
5 5 8 RIDE 514.26 0.00 yb 1
5 5 9 RIDEI 627.35 0.00 yb 1
6 6 7 ID 229.12 0.00 yb 1
6 6 8 IDE 358.16 0.00 yb 1
6 6 9 IDEI 471.24 0.00 yb 1
7 7 8 DE 245.08 0.00 yb 1
7 7 9 DEI 358.16 0.00 yb 1
8 8 9 EI 243.13 0.00 yb 1
Paste the following into a Mascot search query window to verify this output:
MODS=Phospho (Y)
IT_MODS=Oxidation (M)
IT_MODS=Acetyl (N-term)
CHARGE=Mr
CLE=Trypsin
1320.686 ions(190.053, 261.09, 374.174, 521.243, 677.344, 790.428, 905.455, 1034.498, 1147.582)
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_ms_zip.pl

tools_ms_zip.pl

Using the tinycdb index files.

#!/usr/local/bin/perl
##############################################################################
# file: tools_ms_zip.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/tools_ms_zip.pl $
# $Author: villek@matrixscience.com $
# $Date: 2023-11-22 16:25:28 +0000 $
# $Revision: 7442fec13bcb3ca4853591b3e3f55ce546d17719 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
use v5.14;
use msparser;
use constant {
# Buffer size for reading the input file.
BUFSIZE => 1 * 1048576,
};
my $decompressed_fileIn = shift @ARGV or die "Usage: $0 infile.dat";
my $outfile = "example_ms_zip.$$.gz";
open(my $infile_fh, '<', $decompressed_fileIn) or die "unable to '$decompressed_fileIn' for reading: $!";
binmode($infile_fh);
my $zipper = msparser::ms_zip->new(0);
if (not $zipper->isValid) {
die "unable to initialise ms_zip: " . $zipper->getLastErrorString();
}
open(my $outfile_fh, '>', $outfile) or die "unable to open '$outfile' for writing: $!";
binmode($outfile_fh);
my $num_bytes = 0;
my $buffer;
while (1) {
my $r = read($infile_fh, $buffer, BUFSIZE);
if (not defined $r) {
die "error while reading '$decompressed_fileIn': $!";
}
say "(read $r uncompressed bytes)";
# When $r > 0, there is more data to compress, so do it.
#
# When $r == 0, it's EOF and $buffer is empty. Give it to
# compressMore() so we begin flushing.
my $data = $zipper->compressMore($buffer);
if (length($data) > 0) {
say "(received ", length($data), " compressed bytes)";
print $outfile_fh $data;
$num_bytes += length($data);
}
last if not $zipper->isValid();
last if $r == 0;
}
while ($zipper->isValid()) {
my $s = $zipper->compressMore('');
if (length($s) > 0) {
say "(received ", length($s), " compressed bytes)";
print $outfile_fh $s;
$num_bytes += length($s);
} else {
last;
}
}
close $outfile_fh or die "unable to close '$outfile': $!";
say "Wrote $num_bytes Compressed data in: $outfile";
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_quant_helper.pl

tools_quant_helper.pl

Testing peptides for quantifiability.

#!/usr/local/bin/perl
##############################################################################
# file: tools_quant_helper.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/tools_quant_helper.pl $
# $Author: robertog@matrixscience.com $
# $Date: 2024-09-04 10:23:46 +0100 $
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
##############################################################################
use msparser;
use constant {
QUANT_SCHEMA => 'http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd',
UNIMOD_SCHEMA => 'http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd',
};
if (not @ARGV) {
print STDERR "Usage: $0 <quantitation results.dat>\n";
exit 1;
}
my $resfile = msparser::ms_mascotresfilebase::createResfile($ARGV[0]);
if (not $resfile->isValid) {
print STDERR $resfile->getLastErrorString(), "\n";
exit 1;
}
# The details of loading the quantitation method and peptide summary object
# are not relevant to this example (see end of file for implementation).
my ($quant_config_file, $qmethod) = load_method_or_exit($resfile);
my $umodfile = load_umod_configfile_or_exit($resfile);
my $pepsum = open_peptidesummary_or_exit($resfile);
my $quant_helper = msparser::ms_quant_helper->new($pepsum, $qmethod, $umodfile);
if (not $quant_helper->isValid) {
printf STDERR "ms_quant_helper is not valid: %s\n", $quant_helper->getLastErrorString();
exit 1;
}
my @proteins = pull_proteins_from($pepsum);
printf "File %s uses %s and has %d family proteins\n\n",
$ARGV[0], $qmethod->getName(), scalar(@proteins);
dump_quant_method($qmethod);
print "\n";
# Reverse map of test result values for pretty printing purposes:
my (%peptide_quality_str, %peptide_quant_str);
do {
no strict 'refs';
%peptide_quality_str = map { ${"msparser::ms_quant_helper::$_"} => $_ } qw(
PEPTIDE_QUALITY_IS_OK
PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN
PEPTIDE_SCORE_BELOW_SCORE_THR
PEPTIDE_EXPECT_ABOVE_THRESHOLD
PEPTIDE_SCORE_BELOW_IDENTITY_THR
PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM
PEPTIDE_SCORE_BELOW_HOMOLOGY_THR
PEPTIDE_HAS_NO_EXCLUSIVE_MODS
PEPTIDE_QUALITY_UNAVAILABLE
);
%peptide_quant_str = map { ${"msparser::ms_quant_helper::$_"} => $_ } qw(
PEPTIDE_IS_QUANTIFIABLE
PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD
PEPTIDE_HAS_NO_REQUIRED_VARMOD
PEPTIDE_HAS_EXCLUDED_FIXEDMOD
PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD
PEPTIDE_HAS_EXCLUDED_VARMOD
PEPTIDE_HAS_UNMODIFIED_SITE
PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD
PEPTIDE_QUANTIFIABILITY_UNAVAILABLE
);
};
for my $protein (@proteins) {
printf "Protein %d::%s\n", $protein->getDB(), $protein->getAccession();
for my $i (1 .. $protein->getNumPeptides()) {
next if $protein->getPeptideDuplicate($i) == $msparser::ms_protein::DUPE_DuplicateSameQuery;
my $q = $protein->getPeptideQuery($i);
my $p = $protein->getPeptideP($i);
my $peptide = $pepsum->getPeptide($q, $p);
next if not $peptide;
# Each peptide can be tested for two things:
# a) is it quantifiable?
# b) is it of high enough quality for quantification?
#
# The test parameters are defined in the quantitation method object.
# The two tests are orthogonal: the peptide need not pass test (a)
# in order to pass test (b), and vice versa. Normally, for quantitation
# purposes, you can ignore peptides which fail either test, so you
# can continue straight to the next peptide if test (a) fails.
# Test (a):
do {
my ($ok, $reason) = $quant_helper->isPeptideQuantifiable($q, $p, $protein, $i);
printf "\tq%d_p%d quantifiable? %s (%s)\n", $q, $p, $peptide_quant_str{$ok}, (defined $reason ? $reason : '<undef>');
};
# Test (b):
do {
my ($ok, $reason) = $quant_helper->isPeptideQualityOK($q, $p);
printf "\tq%d_p%d quality? %s (%s)\n", $q, $p, $peptide_quality_str{$ok}, (defined $reason ? $reason : '<undef>');
};
}
}
# Load the quantitation method from the results file or exit with an error.
sub load_method_or_exit {
my ($resfile) = @_;
my $quant_method_name = $resfile->params->getQUANTITATION();
if (not $quant_method_name or lc($quant_method_name) eq 'none') {
print STDERR "File has no quantitation method\n";
exit 1;
}
my $qf = msparser::ms_quant_configfile->new();
$qf->setSchemaFileName(QUANT_SCHEMA);
if (not $resfile->getQuantitation($qf)) {
printf STDERR "File has no quantitation method (%s)\n", $resfile->getLastErrorString();
exit 1;
}
if (not $qf->isValid) {
printf STDERR "Quantitation file is not valid (%s)\n", $qf->getLastErrorString();
exit 1;
}
if ('' ne (my $str = $qf->validateDocument())) {
printf STDERR "Quantitation file does not validate (%s)\n", $str;
exit 1;
}
my $qmethod = $qf->getMethodByName($quant_method_name);
if (not $qmethod) {
printf STDERR "Quantitation file has no method called '%s'\n", $quant_method_name;
exit 1;
}
return ($qf, $qmethod);
}
# Load the Unimod section from the results file or exit with an error.
sub load_umod_configfile_or_exit {
my ($resfile) = @_;
my $umodfile = msparser::ms_umod_configfile->new();
$umodfile->setSchemaFileName(UNIMOD_SCHEMA);
if (not $resfile->getUnimod($umodfile)) {
print STDERR "Results file does not have a Unimod section\n";
exit 1;
}
if (not $umodfile->isValid) {
printf STDERR "Unimod file is not valid (%s)\n", $umodfile->getLastErrorString();
exit 1;
}
if ('' ne (my $str = $umodfile->validateDocument())) {
printf STDERR "Unimod file does not validate (%s)\n", $str;
exit 1;
}
return $umodfile;
}
# Load the results file as ms_peptidesummary or exit with an error.
sub open_peptidesummary_or_exit {
my ($resfile) = @_;
my $opts = msparser::ms_mascotoptions->new();
my (undef, $flags, $minprob, $maxhits, $iisb, $minpeplen, $use_pepsum, $flags2)
= $resfile->get_ms_mascotresults_params($opts);
if (not $use_pepsum) {
print STDERR "Results file cannot be opened as a peptide summary\n";
exit 1;
}
my $pepsum = msparser::ms_peptidesummary->new(
$resfile, $flags, $minprob, $maxhits, '', $iisb, $minpeplen, '', $flags2
);
if (not $resfile->isValid) {
print STDERR $resfile->getLastErrorString, "\n";
exit 1;
}
return $pepsum;
}
# Return a list of all top-level protein hits.
sub pull_proteins_from {
my ($pepsum) = @_;
my @proteins = ();
for my $i (1 .. $pepsum->getNumberOfHits()) {
my $hit = $pepsum->getHit($i);
push @proteins, $hit;
my $j = 0;
while (my $protein = $pepsum->getNextFamilyProtein($i, ++$j)) {
push @proteins, $protein;
}
}
return @proteins;
}
# Print quantitation method parameters relevant to ms_quant_helper.
sub dump_quant_method {
my ($qmethod) = @_;
do {
my @comps = ();
for my $i (0 .. $qmethod->getNumberOfComponents()-1) {
my $comp = $qmethod->getComponentByNumber($i);
$comps[$i] = $comp->getName();
}
printf "Components: [%s]\n", join(', ', @comps);
};
printf "Protein ratio type = %s\n", $qmethod->getProteinRatioType();
printf "Min. number of peptides = %d\n", $qmethod->getMinNumPeptides();
if ($qmethod->haveQuality()) {
my $q = $qmethod->getQuality();
printf "Quality: min. precursor charge = %s\n", $q->getMinPrecursorCharge();
printf "Quality: pep. threshold type = %s\n", $q->getPepThresholdType();
printf "Quality: pep. threshold value = %s\n", $q->getPepThresholdValue();
} else {
printf "Quality: no restrictions\n";
}
if ($qmethod->haveNormalisation()) {
my $q = $qmethod->getNormalisation();
printf "Normalisation = %s\n", $q->getMethod();
} else {
printf "Normalisation: none\n";
}
if ($qmethod->haveOutliers()) {
my $q = $qmethod->getOutliers();
printf "Outliers = %s\n", $q->getMethod();
} else {
printf "Outliers: none\n";
}
}
=pod
Running the program as
perl -I../bin tools_quant_helper.pl ../data/F981133.dat
will give the following output under Mascot 2.5:
File ../data/F981133.dat uses SILAC K+6 R+6 multiplex and has 23 family proteins
Components: [light, heavy]
Protein ratio type = weighted
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = at least homology
Quality: pep. threshold value = 0.05
Normalisation: none
Outliers = auto
Protein 1::K2C1_HUMAN
q18_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q18_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q33_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q33_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q55_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q55_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::TRYP_PIG
q1_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q1_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q2_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q2_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q3_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q3_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q9_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q9_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q72_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q72_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q73_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q73_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q74_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q74_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q75_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q75_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q76_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q76_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q77_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q77_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q78_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q78_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q81_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q81_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q82_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q82_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q90_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q90_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q91_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q91_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::IGG2B_MOUSE
q12_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q12_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q57_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q57_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q58_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q58_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q62_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q62_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q66_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q66_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::ALBU_BOVIN
q16_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q16_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q30_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q30_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q46_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q46_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q49_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q49_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q50_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q50_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::ENPL_MOUSE
q4_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q4_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q19_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q19_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q20_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q20_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q41_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q41_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q42_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q42_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::NUCL_MOUSE
q5_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q5_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q6_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q6_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q7_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q7_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q8_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q8_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q44_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q44_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q45_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q45_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q92_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q92_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q93_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q93_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::EPHB2_HUMAN
q13_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q13_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q21_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q21_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q53_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q53_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q88_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q88_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::K2C1_RAT
q33_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q33_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C75_BOVIN
q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q38_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q38_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q40_p6 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q40_p6 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::HNRPU_HUMAN
q32_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q32_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q34_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q34_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q51_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q51_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q52_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q52_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::SFPQ_HUMAN
q14_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q14_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q15_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q15_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q22_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q22_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q69_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q69_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q70_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q70_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::CAPR1_MOUSE
q23_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q23_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q36_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q36_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q37_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q37_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::ENPL_ARATH
q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q41_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q41_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q42_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q42_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q67_p8 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q67_p8 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::VIME_CRIGR
q17_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q17_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q35_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q35_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::BCAR1_MOUSE
q10_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q10_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q11_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q11_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q63_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q63_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::HTPG_ALHEH
q24_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q24_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q26_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q26_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q67_p7 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q67_p7 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::HTPG_HALHL
q24_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q24_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q26_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q26_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q67_p9 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q67_p9 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::HSC90_DICDI
q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q67_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q67_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::FAK1_MOUSE
q29_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q29_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::HTPG_BDEBA
q24_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q24_p3 quality? PEPTIDE_QUALITY_IS_OK ()
q26_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q26_p3 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C8_MOUSE
q33_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q33_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::TRY1_RAT
q72_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q72_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q73_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q73_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q74_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q74_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q75_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q75_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q76_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q76_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q78_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q78_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q81_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q81_p3 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q82_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q82_p2 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::IGKC_MOUSE
q47_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q47_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q48_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q48_p1 quality? PEPTIDE_QUALITY_IS_OK ()
=cut
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_quant_helper.py

tools_quant_helper.py

Testing peptides for quantifiability.

1#!/usr/bin/python
2
15
16import msparser
17import sys
18
19QUANT_SCHEMA = 'http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd'
20UNIMOD_SCHEMA = 'http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd'
21
22# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
23def ms_range(start, stop, step=1):
24 i = start
25 while i <= stop:
26 yield i
27 i += step
28
29# Load the quantitation method from the results file or exit with an error.
30def load_method_or_exit(resfile):
31 params = msparser.ms_searchparams(resfile)
32 quant_method_name = params.getQUANTITATION()
33 if not quant_method_name or quant_method_name.lower() == 'none':
34 print("File has no quantitation method")
35 sys.exit(1)
36
37 qf = msparser.ms_quant_configfile()
38 qf.setSchemaFileName(QUANT_SCHEMA)
39
40 if not resfile.getQuantitation(qf):
41 print("File has no quantitation method (%s)" %(resfile.getLastErrorString()))
42 sys.exit(1)
43
44 if not qf.isValid():
45 print("Quantitation file is not valid (%s)" %(qf.getLastErrorString()))
46 sys.exit(1)
47
48 str = qf.validateDocument()
49 if str != '':
50 print("Quantitation file does not vaidate (%s)" %(str))
51 sys.exit(1)
52
53 qmethod = qf.getMethodByName(quant_method_name)
54
55 if not qmethod:
56 print("Quantitation file has no method called %s" %(quant_method_name))
57 sys.exit(1)
58
59 return(qf, qmethod)
60
61# Load the Unimod section from the results file or exit with an error.
62def load_umod_configfile_or_exit(resfile):
63 umodfile = msparser.ms_umod_configfile()
64 umodfile.setSchemaFileName(UNIMOD_SCHEMA)
65 if not resfile.getUnimod(umodfile):
66 print("Results file does not have a Unimod section")
67 sys.exit(1)
68
69 if not umodfile.isValid():
70 print("Unimod file is not valid (%s)" %(umodfile.getLastErrorString))
71 sys.exit(1)
72
73 str = umodfile.validateDocument()
74 if not str == '':
75 print("Unimod file does not validate (%s)" %(str))
76 sys.exit(1)
77
78 return umodfile
79
80# Load the results file as ms_peptidesummary or exit with an error.
81def open_peptidesummary_or_exit(resfile):
82 opts = msparser.ms_mascotoptions()
83 undef, flags, minprob, maxhits, iisb, minpeplen, use_pepsum, flags2 = resfile.get_ms_mascotresults_params(opts)
84
85 if not use_pepsum:
86 print("Results file cannot be opened as a peptide summary")
87 sys.exit(1)
88
89 pepsum = msparser.ms_peptidesummary(resfile, flags, minprob, maxhits, '', iisb, minpeplen, '', flags2)
90 if not resfile.isValid():
91 print(resfile.getLastErrorString)
92 sys.exit(1)
93
94 return pepsum
95
96# Return a list of all top-level protein hits.
97def pull_proteins_from(pepsum):
98 proteins = []
99
100 for i in ms_range(1, pepsum.getNumberOfHits()-1):
101 hit = pepsum.getHit(i)
102 proteins.append(hit)
103 j = 1
104 protein = pepsum.getNextFamilyProtein(i, j)
105
106 while protein !=None:
107 proteins.append(protein)
108 j += 1
109 protein = pepsum.getNextFamilyProtein(i, j)
110
111 return proteins
112
113# Print quantitation method parameters relevant to ms_quant_helper.
114def dump_quant_method(qmethod):
115 comps=[]
116 for i in ms_range(0, qmethod.getNumberOfComponents()-1):
117 comp = qmethod.getComponentByNumber(i)
118 comps.append(comp.getName())
119
120 print("Components: %s" %(comps))
121
122 print("Protein ratio type = %s" %(qmethod.getProteinRatioType()))
123 print("Min. number of peptides = %d" %(qmethod.getMinNumPeptides()))
124
125 if qmethod.haveQuality():
126 q = qmethod.getQuality()
127 print("Quality: min. precursor charge = %s" %(q.getMinPrecursorCharge()))
128 print("Quality: pep. threshold type = %s" %(q.getPepThresholdType()))
129 print("Quality: pep. threshold value = %s" %(q.getPepThresholdValue()))
130 else:
131 print("Quality: no restrictions")
132
133 if qmethod.haveNormalisation():
134 q = qmethod.getNormalisation()
135 print("Normalisation = %s" %(q.getMethod()))
136 else:
137 print("Normalisation: none")
138
139 if qmethod.haveOutliers():
140 q = qmethod.getOutliers()
141 print("Outliers = %s" %(q.getMethod()))
142 else:
143 print("Outliers: none")
144
145
146
147
148# If no arguments supplied, print help and exit
149
150if len(sys.argv) < 2:
151 print("Usage: %s <quantitation results.dat>" % sys.argv[0])
152 sys.exit(1)
153
154resfile = msparser.ms_mascotresfilebase.createResfile(sys.argv[1],1)
155
156if not resfile.isValid():
157 print(resfile.getLastErrorString())
158 sys.exit(1)
159
160# The details of loading the quantitation method and peptide summary object
161# are not relevant to this example (see end of file for implementation).
162quant_config_file, qmethod = load_method_or_exit(resfile)
163umodfile = load_umod_configfile_or_exit(resfile)
164pepsum = open_peptidesummary_or_exit(resfile)
165
166
167quant_helper = msparser.ms_quant_helper(pepsum, qmethod, umodfile)
168
169if not quant_helper.isValid():
170 print("ms_quant_helper is not valid: %s" %(quant_helper.getLastErrorString()))
171 sys.exit(1)
172
173proteins = pull_proteins_from(pepsum)
174
175print("File %s uses %s and has %d family proteins\n" %(sys.argv[1], qmethod.getName(), len(proteins)))
176
177dump_quant_method(qmethod)
178
179print("\n")
180
181peptide_quant_str = {
182msparser.ms_quant_helper.PEPTIDE_HAS_EXCLUDED_FIXEDMOD: "PEPTIDE_HAS_EXCLUDED_FIXEDMOD",
183msparser.ms_quant_helper.PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD: "PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD",
184msparser.ms_quant_helper.PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD: "PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD",
185msparser.ms_quant_helper.PEPTIDE_HAS_EXCLUDED_VARMOD: "PEPTIDE_HAS_EXCLUDED_VARMOD",
186msparser.ms_quant_helper.PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD: "PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD",
187msparser.ms_quant_helper.PEPTIDE_HAS_NO_REQUIRED_VARMOD: "PEPTIDE_HAS_NO_REQUIRED_VARMOD",
188msparser.ms_quant_helper.PEPTIDE_HAS_UNMODIFIED_SITE: "PEPTIDE_HAS_UNMODIFIED_SITE",
189msparser.ms_quant_helper.PEPTIDE_IS_QUANTIFIABLE: "PEPTIDE_IS_QUANTIFIABLE",
190msparser.ms_quant_helper.PEPTIDE_QUANTIFIABILITY_UNAVAILABLE: "PEPTIDE_QUANTIFIABILITY_UNAVAILABLE"
191};
192
193peptide_quality_str = {
194msparser.ms_quant_helper.PEPTIDE_EXPECT_ABOVE_THRESHOLD: "PEPTIDE_EXPECT_ABOVE_THRESHOLD",
195msparser.ms_quant_helper.PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN: "PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN",
196msparser.ms_quant_helper.PEPTIDE_HAS_NO_EXCLUSIVE_MODS: "PEPTIDE_HAS_NO_EXCLUSIVE_MODS",
197msparser.ms_quant_helper.PEPTIDE_NOT_UNIQUE: "PEPTIDE_NOT_UNIQUE",
198msparser.ms_quant_helper.PEPTIDE_QUALITY_IS_OK: "PEPTIDE_QUALITY_IS_OK",
199msparser.ms_quant_helper.PEPTIDE_QUALITY_UNAVAILABLE: "PEPTIDE_QUALITY_UNAVAILABLE",
200msparser.ms_quant_helper.PEPTIDE_SCORE_BELOW_HOMOLOGY_THR: "PEPTIDE_SCORE_BELOW_HOMOLOGY_THR",
201msparser.ms_quant_helper.PEPTIDE_SCORE_BELOW_IDENTITY_THR: "PEPTIDE_SCORE_BELOW_IDENTITY_THR",
202msparser.ms_quant_helper.PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM: "PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM",
203msparser.ms_quant_helper.PEPTIDE_SCORE_BELOW_SCORE_THR: "PEPTIDE_SCORE_BELOW_SCORE_THR"
204};
205
206
207for protein in proteins:
208
209 print("Protein %d::%s" %(protein.getDB(), protein.getAccession()))
210
211 for i in ms_range(1, protein.getNumPeptides()-1):
212
213 if protein.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_DuplicateSameQuery:
214 continue
215
216 q = protein.getPeptideQuery(i)
217 p = protein.getPeptideP(i)
218
219 peptide = pepsum.getPeptide(q, p)
220
221 if not peptide:
222 continue
223
224# Each peptide can be tested for two things:
225# a) is it quantifiable?
226# b) is it of high enough quality for quantification?
227#
228# The test parameters are defined in the quantitation method object.
229# The two tests are orthogonal: the peptide need not pass test (a)
230# in order to pass test (b), and vice versa. Normally, for quantitation
231# purposes, you can ignore peptides which fail either test, so you
232# can continue straight to the next peptide if test (a) fails.
233
234# Test (a):
235 ok, reason = quant_helper.isPeptideQuantifiable(q, p, protein, i)
236 if reason == None:
237 reason = '<undef>'
238 print("\tq%d_p%d quantifiable? %s (%s)" %(q, p, peptide_quant_str[ok], reason))
239
240# Test (b):
241 ok, reason = quant_helper.isPeptideQualityOK(q, p)
242 if reason == None:
243 reason = '<undef>'
244 print("\tq%d_p%d quality? %s (%s)" %(q, p, peptide_quality_str[ok], reason))
245
246
247'''
248When run from bin, tools_quant_helper.py ../data/F981133.dat
249Will give the following output:
250
251File ../data/F981133.dat uses SILAC K+6 R+6 multiplex and has 21 family proteins
252
253Components: ['light', 'heavy']
254Protein ratio type = weighted
255Min. number of peptides = 2
256Quality: min. precursor charge = 1
257Quality: pep. threshold type = at least homology
258Quality: pep. threshold value = 0.05
259Normalisation: none
260Outliers = auto
261
262
263Protein 1::K2C1_PANTR
264 q18_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
265 q18_p1 quality? PEPTIDE_QUALITY_IS_OK ()
266 q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
267 q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
268 q33_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
269 q33_p2 quality? PEPTIDE_QUALITY_IS_OK ()
270 q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
271 q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
272 q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
273 q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
274 q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
275 q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
276Protein 1::TRYP_PIG
277 q1_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
278 q1_p1 quality? PEPTIDE_QUALITY_IS_OK ()
279 q2_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
280 q2_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
281 q3_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
282 q3_p1 quality? PEPTIDE_QUALITY_IS_OK ()
283 q9_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
284 q9_p1 quality? PEPTIDE_QUALITY_IS_OK ()
285 q72_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
286 q72_p1 quality? PEPTIDE_QUALITY_IS_OK ()
287 q73_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
288 q73_p1 quality? PEPTIDE_QUALITY_IS_OK ()
289 q74_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
290 q74_p1 quality? PEPTIDE_QUALITY_IS_OK ()
291 q75_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
292 q75_p1 quality? PEPTIDE_QUALITY_IS_OK ()
293 q76_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
294 q76_p1 quality? PEPTIDE_QUALITY_IS_OK ()
295 q77_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
296 q77_p1 quality? PEPTIDE_QUALITY_IS_OK ()
297 q78_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
298 q78_p1 quality? PEPTIDE_QUALITY_IS_OK ()
299 q81_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
300 q81_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
301 q82_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
302 q82_p1 quality? PEPTIDE_QUALITY_IS_OK ()
303 q90_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
304 q90_p1 quality? PEPTIDE_QUALITY_IS_OK ()
305Protein 1::IGG2B_MOUSE
306 q12_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
307 q12_p1 quality? PEPTIDE_QUALITY_IS_OK ()
308 q57_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
309 q57_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
310 q58_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
311 q58_p1 quality? PEPTIDE_QUALITY_IS_OK ()
312 q62_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
313 q62_p1 quality? PEPTIDE_QUALITY_IS_OK ()
314Protein 1::ALBU_BOVIN
315 q16_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
316 q16_p1 quality? PEPTIDE_QUALITY_IS_OK ()
317 q30_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
318 q30_p1 quality? PEPTIDE_QUALITY_IS_OK ()
319 q46_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
320 q46_p1 quality? PEPTIDE_QUALITY_IS_OK ()
321 q49_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
322 q49_p1 quality? PEPTIDE_QUALITY_IS_OK ()
323Protein 1::ENPL_MOUSE
324 q4_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
325 q4_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
326 q19_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
327 q19_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
328 q20_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
329 q20_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
330 q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
331 q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
332 q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
333 q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
334 q41_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
335 q41_p1 quality? PEPTIDE_QUALITY_IS_OK ()
336Protein 1::NUCL_MOUSE
337 q5_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
338 q5_p1 quality? PEPTIDE_QUALITY_IS_OK ()
339 q6_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
340 q6_p1 quality? PEPTIDE_QUALITY_IS_OK ()
341 q7_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
342 q7_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
343 q8_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
344 q8_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
345 q44_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
346 q44_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
347 q45_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
348 q45_p1 quality? PEPTIDE_QUALITY_IS_OK ()
349 q92_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
350 q92_p1 quality? PEPTIDE_QUALITY_IS_OK ()
351Protein 1::EPHB2_HUMAN
352 q13_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
353 q13_p1 quality? PEPTIDE_QUALITY_IS_OK ()
354 q21_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
355 q21_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
356 q53_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
357 q53_p1 quality? PEPTIDE_QUALITY_IS_OK ()
358Protein 1::K2C1_RAT
359 q33_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
360 q33_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
361 q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
362 q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
363 q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
364 q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
365Protein 1::K2C75_BOVIN
366 q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
367 q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
368 q38_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
369 q38_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
370Protein 1::HNRPU_HUMAN
371 q32_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
372 q32_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
373 q34_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
374 q34_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
375 q51_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
376 q51_p1 quality? PEPTIDE_QUALITY_IS_OK ()
377Protein 1::SFPQ_HUMAN
378 q14_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
379 q14_p1 quality? PEPTIDE_QUALITY_IS_OK ()
380 q15_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
381 q15_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
382 q22_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
383 q22_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
384 q69_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
385 q69_p1 quality? PEPTIDE_QUALITY_IS_OK ()
386Protein 1::CAPR1_MOUSE
387 q23_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
388 q23_p1 quality? PEPTIDE_QUALITY_IS_OK ()
389 q36_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
390 q36_p1 quality? PEPTIDE_QUALITY_IS_OK ()
391Protein 1::K2C1B_HUMAN
392 q18_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
393 q18_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
394 q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
395 q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
396 q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
397 q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
398Protein 1::ENPL_ARATH
399 q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
400 q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
401 q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
402 q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
403 q41_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
404 q41_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
405 q42_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
406 q42_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
407Protein 1::VIME_CRIGR
408 q17_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
409 q17_p1 quality? PEPTIDE_QUALITY_IS_OK ()
410Protein 1::BCAR1_MOUSE
411 q10_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
412 q10_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
413 q11_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
414 q11_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
415Protein 1::HTPG_ALKEH
416 q24_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
417 q24_p1 quality? PEPTIDE_QUALITY_IS_OK ()
418 q26_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
419 q26_p1 quality? PEPTIDE_QUALITY_IS_OK ()
420Protein 1::FAK1_MOUSE
421Protein 1::HTPG_BDEBA
422 q24_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
423 q24_p3 quality? PEPTIDE_QUALITY_IS_OK ()
424Protein 1::K2C8_MOUSE
425Protein 1::TRY1_RAT
426 q72_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
427 q72_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
428 q73_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
429 q73_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
430 q74_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
431 q74_p2 quality? PEPTIDE_QUALITY_IS_OK ()
432 q75_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
433 q75_p2 quality? PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM (Peptide score is below identity threshold (no homology threshold))
434 q76_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
435 q76_p2 quality? PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM (Peptide score is below identity threshold (no homology threshold))
436 q78_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
437 q78_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
438 q81_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
439 q81_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
440
441'''
442
443
444
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_quant_helper.cs

tools_quant_helper.cs

Testing peptides for quantifiability.

/*
##############################################################################
# file: tools_quant_helper.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/tools_quant_helper.cs $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.IO;
using System.Collections.Generic;
using matrix_science.msparser;
namespace MsParserExamples
{
class tools_quant_helper
{
private const string QUANT_SCHEMA = @"http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd", UNIMOD_SCHEMA = @"http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd";
public static int Main(string[] argv)
{
if (argv.Length == 0)
{
Console.Error.WriteLine("Usage: {0} <quantitation results.dat>", Path.GetFileName((new tools_quant_helper()).GetType().Assembly.Location));
return 1;
}
ms_mascotresfilebase resfile = ms_mascotresfilebase.createResfile(argv[0]);
if (!resfile.isValid())
{
Console.Error.WriteLine(resfile.getLastErrorString());
return 1;
}
// the details of loading the quantitation method and peptide summary object
// are not relevant to this example (see methods at the end of the file for
// implementation).
ms_quant_configfile quantConfigFile;
ms_quant_method qmethod;
ms_peptidesummary pepSum;
if (!loadMethod(resfile, out quantConfigFile, out qmethod)) return 1;
ms_umod_configfile umodfile = null;
if (!loadUmodConfigFile(resfile, out umodfile)) return 1;
if (!loadPeptideSummary(resfile, out pepSum)) return 1;
ms_quant_helper quantHelper = new ms_quant_helper(pepSum, qmethod, umodfile);
if (!quantHelper.isValid())
{
Console.WriteLine("ms_quant_helper is not value: {0}", quantHelper.getLastErrorString());
return 1;
}
List<ms_protein> proteins = pullProteinsFrom(pepSum);
Console.WriteLine("File {0} uses {1} and has {2} family proteins", argv[0], qmethod.getName(), proteins.Count);
dumpQuantMethod(qmethod);
Console.WriteLine();
Dictionary<int, string> peptideQuantStr = new Dictionary<int, string>()
{
{(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_EXCLUDED_FIXEDMOD, "PEPTIDE_HAS_EXCLUDED_FIXEDMOD"},
{(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD, "PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD"},
{(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD, "PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD"},
{(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_EXCLUDED_VARMOD, "PEPTIDE_HAS_EXCLUDED_VARMOD"},
{(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD, "PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD"},
{(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_NO_REQUIRED_VARMOD, "PEPTIDE_HAS_NO_REQUIRED_VARMOD"},
{(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_UNMODIFIED_SITE, "PEPTIDE_HAS_UNMODIFIED_SITE"},
{(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_IS_QUANTIFIABLE, "PEPTIDE_IS_QUANTIFIABLE"},
{(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_QUANTIFIABILITY_UNAVAILABLE, "PEPTIDE_QUANTIFIABILITY_UNAVAILABLE"}
};
Dictionary<int, string> peptideQualityStr = new Dictionary<int, string>()
{
{(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_EXPECT_ABOVE_THRESHOLD, "PEPTIDE_EXPECT_ABOVE_THRESHOLD"},
{(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN, "PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN"},
{(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_HAS_NO_EXCLUSIVE_MODS, "PEPTIDE_HAS_NO_EXCLUSIVE_MODS"},
{(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_NOT_UNIQUE, "PEPTIDE_NOT_UNIQUE"},
{(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_QUALITY_IS_OK, "PEPTIDE_QUALITY_IS_OK"},
{(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_QUALITY_UNAVAILABLE, "PEPTIDE_QUALITY_UNAVAILABLE"},
{(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_SCORE_BELOW_HOMOLOGY_THR, "PEPTIDE_SCORE_BELOW_HOMOLOGY_THR"},
{(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_SCORE_BELOW_IDENTITY_THR, "PEPTIDE_SCORE_BELOW_IDENTITY_THR"},
{(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM, "PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM"},
{(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_SCORE_BELOW_SCORE_THR, "PEPTIDE_SCORE_BELOW_SCORE_THR"}
};
foreach (ms_protein protein in proteins)
{
Console.WriteLine("Protein {0}::{1}", protein.getDB(), protein.getAccession());
for (int i = 1; i <= protein.getNumPeptides(); i++)
{
int q = protein.getPeptideQuery(i), p = protein.getPeptideP(i);
ms_peptide peptide = pepSum.getPeptide(q, p);
if (peptide == null) continue;
// Each peptide can be tested for two things:
// a) is it quantifiable?
// b) is it of high enough quality for quantification
//
// The two parameters are defined in the quantitation method object
// The two tests are orthogonal: the peptide need not pass test (a)
// in order to pass test (b), and vice versa. Normally, for
// quantitation purposes, you can ignore peptides which fail either test,
// so you can continue straight to the next peptide if test (a) fails
// Test (a):
{
string reason;
int ok = quantHelper.isPeptideQuantifiable(q, p, protein, i, out reason);
Console.WriteLine("\tq{0}_p{1} quantifiable? {2} ({3})", q, p, peptideQuantStr[ok], (string.IsNullOrEmpty(reason) ? "" : reason));
}
// Test (b):
{
string reason;
int ok = quantHelper.isPeptideQualityOK(q, p, out reason);
Console.WriteLine("\tq{0}_p{1} quality? {2} ({3})", q, p, peptideQualityStr[ok], (string.IsNullOrEmpty(reason) ? "" : reason));
}
}
}
pepSum.getNumberOfHits();
resfile._params();
return 0;
}
private static void dumpQuantMethod(ms_quant_method qmethod)
{
{
List<string> comps = new List<string>();
for (int i = 0; i < qmethod.getNumberOfComponents(); i++)
{
comps.Add(qmethod.getComponentByNumber(i).getName());
}
Console.WriteLine("Components: [{0}]", string.Join(", ", comps));
}
Console.WriteLine("Protein ratio type = {0}", qmethod.getProteinRatioType());
Console.WriteLine("Min. number of peptides = {0}", qmethod.getMinNumPeptides());
if (qmethod.haveQuality())
{
var q = qmethod.getQuality();
Console.WriteLine("Quality: min. precursor charge = {0}", q.getMinPrecursorCharge());
Console.WriteLine("Quality: pep. threshold type = {0}", q.getPepThresholdType());
Console.WriteLine("Quality: pep. threshold value = {0}", q.getPepThresholdValue());
}
else
{
Console.WriteLine("Quality: no restrictions");
}
if (qmethod.haveNormalisation())
{
var q = qmethod.getNormalisation();
Console.WriteLine("Normalisation = {0}", q.getMethod());
}
else
{
Console.WriteLine("Normalisation: none");
}
if (qmethod.haveOutliers())
{
var q = qmethod.getOutliers();
Console.WriteLine("Outliers = {0}", q.getMethod());
}
else
{
Console.WriteLine("Outliers: none");
}
}
private static List<ms_protein> pullProteinsFrom(ms_peptidesummary pepsum)
{
List<ms_protein> proteins = new List<ms_protein>();
for (int i = 1; i <= pepsum.getNumberOfHits(); i++)
{
ms_protein hit = pepsum.getHit(i);
proteins.Add(hit);
int j = 0;
ms_protein protein;
while((protein = pepsum.getNextFamilyProtein(i, ++j)) != null) {
proteins.Add(protein);
}
}
return proteins;
}
private static bool loadPeptideSummary(ms_mascotresfilebase resfile, out ms_peptidesummary pepSum)//, out ms_peptidesummary pepsum)
{
// set pepsum to null so we can return out with false if the method fails
pepSum = null;
ms_mascotoptions opts = new ms_mascotoptions();
uint flags, flags2, minpeplen;
int maxhits;
double minprob, iisb;
bool usePepsum;
resfile.get_ms_mascotresults_params(opts, out flags, out minprob, out maxhits, out iisb, out minpeplen, out usePepsum, out flags2);
if (!usePepsum)
{
Console.Error.WriteLine("Results file cannot be opened as a peptide summary");
return false;
}
pepSum = new ms_peptidesummary(resfile, flags, minprob, maxhits, "", iisb, (int) minpeplen, "", flags2);
if (!resfile.isValid())
{
Console.Error.WriteLine(resfile.getLastErrorString());
return false;
}
return true;
}
private static bool loadUmodConfigFile(ms_mascotresfilebase resfile, out ms_umod_configfile umodfile)
{
umodfile = new ms_umod_configfile();
umodfile.setSchemaFileName(UNIMOD_SCHEMA);
if (!resfile.getUnimod(umodfile))
{
Console.Error.WriteLine("Result file does not have a Unimod section");
return false;
}
if (!umodfile.isValid())
{
Console.Error.WriteLine("Unimod file is not value: {0}", umodfile.getLastErrorString());
return false;
}
string str = umodfile.validateDocument();
if (str.Length > 0)
{
Console.Error.WriteLine("Unimod file does not validate: {0}", str);
return false;
}
return true;
}
private static bool loadMethod(ms_mascotresfilebase resfile, out ms_quant_configfile quantConfigFile, out ms_quant_method qmethod)
{
// set the out values to null so we can return false without defining them
quantConfigFile = null;
qmethod = null;
string quantMethodName = resfile._params().getQUANTITATION();
if (quantMethodName == null || quantMethodName.Length == 0 || quantMethodName.Equals("none", StringComparison.OrdinalIgnoreCase))
{
Console.Error.WriteLine("File has no quantitation method");
return false;
}
quantConfigFile = new ms_quant_configfile();
quantConfigFile.setSchemaFileName(QUANT_SCHEMA);
if (!resfile.getQuantitation(quantConfigFile))
{
Console.Error.WriteLine("File has no quantitation method: {0}", resfile.getLastErrorString());
return false;
}
if (!quantConfigFile.isValid())
{
Console.Error.WriteLine("Quantitation file is not valid: {0}", quantConfigFile.getLastErrorString());
return false;
}
string str = quantConfigFile.validateDocument();
if (str.Length > 0)
{
Console.Error.WriteLine("Quantitation file does not validate: {0}", str);
return false;
}
qmethod = quantConfigFile.getMethodByName(quantMethodName);
if (qmethod == null)
{
Console.Error.WriteLine("Quantitation file has no method called: '{0}'", quantMethodName);
return false;
}
return true;
}
}
}
/*
tools_quant_helper.exe ..\data\F981133.dat
Will give the following output:
File ..\data\F981133.dat uses SILAC K+6 R+6 multiplex and has 22 family proteins
Components: [light, heavy]
Protein ratio type = weighted
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = at least homology
Quality: pep. threshold value = 0.05
Normalisation: none
Outliers = auto
Protein 1::K2C1_PANTR
q18_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q18_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q33_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q33_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q55_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q55_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::TRYP_PIG
q1_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q1_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q2_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q2_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q3_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q3_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q9_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q9_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q72_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q72_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q73_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q73_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q74_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q74_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q75_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q75_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q76_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q76_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q77_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q77_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q78_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q78_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q81_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q81_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q82_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q82_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q90_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q90_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q91_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q91_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::IGG2B_MOUSE
q12_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q12_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q57_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q57_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q58_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q58_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q62_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q62_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q66_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q66_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::ALBU_BOVIN
q16_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q16_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q30_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q30_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q46_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q46_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q49_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q49_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q50_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q50_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::ENPL_MOUSE
q4_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q4_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q19_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q19_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q20_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q20_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q41_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q41_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q42_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q42_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::NUCL_MOUSE
q5_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q5_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q6_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q6_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q7_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q7_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q8_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q8_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q44_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q44_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q45_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q45_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q92_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q92_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q93_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q93_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::EPHB2_HUMAN
q13_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q13_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q21_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q21_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q53_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q53_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q88_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q88_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::K2C1_RAT
q33_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q33_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C75_BOVIN
q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q38_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q38_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q40_p6 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q40_p6 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::HNRPU_HUMAN
q32_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q32_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q34_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q34_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q51_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q51_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q52_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q52_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::SFPQ_HUMAN
q14_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q14_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q15_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q15_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q22_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q22_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q69_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q69_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q70_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q70_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::CAPR1_MOUSE
q23_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q23_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q36_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q36_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q37_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q37_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C1B_HUMAN
q18_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q18_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q53_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q53_p3 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::ENPL_ARATH
q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q41_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q41_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q42_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q42_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q67_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q67_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::VIME_CRIGR
q17_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q17_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q35_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q35_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::BCAR1_MOUSE
q10_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q10_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q11_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q11_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q63_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q63_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::HTPG_ALKEH
q24_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q24_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q26_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q26_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q67_p9 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q67_p9 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::FAK1_MOUSE
q29_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q29_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::HTPG_BDEBA
q24_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q24_p3 quality? PEPTIDE_QUALITY_IS_OK ()
q26_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q26_p3 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C8_MOUSE
q33_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q33_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::TRY1_RAT
q72_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q72_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q73_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q73_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q74_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q74_p2 quality? PEPTIDE_QUALITY_IS_OK ()
q75_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q75_p2 quality? PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM (Peptide score is below identity threshold (no homology threshold))
q76_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q76_p2 quality? PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM (Peptide score is below identity threshold (no homology threshold))
q78_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q78_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q81_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q81_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
q82_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q82_p2 quality? PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM (Peptide score is below identity threshold (no homology threshold))
Protein 1::IGKC_MOUSE
q47_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q47_p1 quality? PEPTIDE_QUALITY_IS_OK ()
q48_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
q48_p1 quality? PEPTIDE_QUALITY_IS_OK ()
*/
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_tinycdb.pl

tools_tinycdb.pl

Using the tinycdb index files.

#!/usr/local/bin/perl
##############################################################################
# file: tools_tinycdb.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/tools_tinycdb.pl $
# $Author: villek@matrixscience.com $
# $Date: 2018-07-30 16:23:53 +0100 $
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
##############################################################################
use msparser;
# This next line just creates the object. It doesn't open a file
# The 'source file' is (unusually!) this perl script ($0), meaning that
# if this file is changed, the index will be re-created.
my $version = "1.1";
my $sourceFile = $0;
my $cdbname = $0.'.cdb';
my $cdb = new msparser::ms_tinycdb($cdbname, $version, $sourceFile);
if (!$cdb->isValid()) {
showErrors($cdb);
exit;
}
if (!$cdb->openIndexFile(1)) {
if ($cdb->isPossibleToCreate) {
print "Creating file because: " . $cdb->getLastErrorString . "\n";
$cdb->prepareToCreate();
$cdb->saveValueForKey("Hello", "world");
# It is unusual to use the same key for 2 values, but it can be done:
$cdb->saveValueForKey("HELP", "me");
$cdb->saveValueForKey("HELP", "me too");
# Example of saving a file offset. Can use a binary offset into the file
# with the ms_tincycdb::saveFileOffsetForKey() function, but this example
# uses saveIntForKey and a line offset. This facile example uses this
# perl source file as the input!
# and saves an offset to THIS line!
open(my $fh, '<', $0) or die $!;
my @list = <$fh>;
close $fh;
my $line=0;
while ($list[$line] !~ m/# and saves an/) {
$line++;
}
$cdb->saveIntForKey("Line", $line);
$cdb->finishCreate();
}
}
if ($cdb->isValid) {
print "Retrieving value for Hello : ", $cdb->getValueFromKey("Hello"), "\n";
print "Retrieving 1st value for HELP : ", $cdb->getValueFromKey("HELP", 0), "\n";
print "Retrieving 2nd value for HELP : ", $cdb->getValueFromKey("HELP", 1), "\n";
# Check saved line index
open(my $fh, '<', $0) or die $!;
my @list = <$fh>;
close $fh;
my $line = $cdb->getIntFromKey("Line");
print "Testing line index. Line ", ($line + 1), ": ", $list[$line], "\n";
} else {
showErrors($cdb);
}
sub showErrors {
my ($obj) = @_;
my $err = $obj->getErrorHandler();
my $i;
for my $i (1 .. $err->getNumberOfErrors) {
print "Error number: ";
print $err->getErrorNumber($i);
print " (";
print $err->getErrorRepeats($i)+1 . " times) : ";
print $err->getErrorString($i) . "\n";
}
print "\n";
$obj->clearAllErrors();
}
Generated on Tue Sep 24 2024 11:06:09 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_tinycdb.py

tools_tinycdb.py

Using the tinycdb index files.

1#!/usr/bin/python
2
15
16import msparser
17import sys
18import re
19
20def main() :
21 # This next line just creates the object. It doesn't open a file
22 # The 'source file' is (unusually!) this Python script (sys.argv[0]),
23 # meaning that if this file is changed, the index will be re-created.
24 version = "1.1"
25 sourceFile = sys.argv[0]
26 cdbname = sys.argv[0] + '.cdb'
27 cdb = msparser.ms_tinycdb(cdbname, version, sourceFile)
28
29 if not cdb.isValid() :
30 showErrors(cdb)
31 return 1
32
33 if not cdb.openIndexFile(True) :
34 if cdb.isPossibleToCreate() :
35 print("Creating file because: %s" % cdb.getLastErrorString())
36 cdb.prepareToCreate()
37 cdb.saveValueForKey("Hello", "world")
38
39 # It is unusual to use the same key for 2 values, but it can be done:
40 cdb.saveValueForKey("HELP", "me")
41 cdb.saveValueForKey("HELP", "me too")
42
43 # Example of saving a file offset. Can use a binary offset into the
44 # file with the ms_tincycdb.saveFileOffsetForKey() function, but this
45 # example uses saveIntForKey and a line offset. This facile example
46 # uses this source file as the input!
47 # and saves an offset to THIS line!
48 try :
49 fh = open(sys.argv[0], 'r')
50 except IOError as err:
51 errno, strerror = err.args
52 print("Cannot open " + sys.argv[0] + " for reading: " + strerror)
53 return 1
54 sys.exit(1)
55 line_nr = 1
56 for line in fh :
57 if re.search('\s*# and saves an.*', line) :
58 break
59
60 line_nr += 1
61
62 fh.close();
63
64 cdb.saveIntForKey("Line", line_nr)
65 cdb.finishCreate()
66
67
68 if cdb.isValid() :
69 print("Retrieving value for Hello : %s" % cdb.getValueFromKey("Hello"))
70 print("Retrieving 1st value for HELP : %s" % cdb.getValueFromKey("HELP", 0))
71 print("Retrieving 2nd value for HELP : %s" % cdb.getValueFromKey("HELP", 1))
72
73 # Check saved line index
74 try :
75 fh = open(sys.argv[0], 'r')
76 except IOError as err:
77 errno, strerror = err.args
78 print("Cannot open " + sys.argv[0] + " for reading: " + strerror)
79 return 1
80
81 line_nr = cdb.getIntFromKey("Line")
82
83 i = 1
84 for line in fh :
85 if i == line_nr : break
86 i += 1
87
88 print("Testing line index. Line " + str(line_nr + 1) + " : " + line)
89 fh.close()
90 else :
91 showErrors(cdb)
92
93
94def showErrors(obj) :
95 err = obj.getErrorHandler()
96
97 for i in range(1, 1 + err.getNumberOfErrors()) :
98 print("Error number: %d (%d times): %s" % (err.getErrorNumber(i), err.getErrorRepeats(i) + 1, err.getErrorString(i)))
99
100 print(" ")
101 obj.clearAllErrors()
102
103if __name__ == "__main__" :
104 sys.exit(main())
105
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_tinycdb.cs

tools_tinycdb.cs

Using the tinycdb index files.

/*
##############################################################################
# file: tools_tinycdb.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/tools_tinycdb.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.IO;
using matrix_science.msparser;
namespace MsParserExamples
{
public class tools_tinycdb
{
public static void Main(string[] argv)
{
if (argv.Length < 1)
{
Console.WriteLine("The location of the source file for this application (tools_tinycdb.cs) should be specified as a parameter");
return;
}
string version = "1.1";
// this should return the current executable name and full path
string sourceFile = System.IO.Path.GetFileName((new tools_tinycdb()).GetType().Assembly.Location);
string cdbname = sourceFile + ".cdb";
// this section just creates the object. it doesn't open a file
// the 'source file' is (unusually!) the executable for this class, meaning
// that if this file is changed, the index will be re-created
ms_tinycdb cdb = new ms_tinycdb(cdbname, version, sourceFile);
if (!cdb.isValid())
{
showErrors(cdb);
return;
}
if (!cdb.openIndexFile(true))
{
if (cdb.isPossibleToCreate())
{
Console.WriteLine("Creating file because: {0}", cdb.getLastErrorString());
cdb.prepareToCreate();
cdb.saveValueForKey("Hello", "world");
// it is unusual to use the same key for 2 values, but it can be done:
cdb.saveValueForKey("HELP", "me");
cdb.saveValueForKey("HELP", "me too");
// Example of saving a file offset using the binary offset into the file
// with the saveFileOffsetForKey() function. This example uses the
// C# source file as the input
// and saves an offset to THIS line!
using (StreamReader fh = new StreamReader(argv[0]))
{
long _pos = -1;
string line;
while ((line = fh.ReadLine()) != null)
{
if (line.Contains("// and saves an offset to THIS line!"))
{
break;
}
// fetch the current position in the file
_pos = GetActualPosition(fh);
}
cdb.saveFileOffsetForKey("Line", _pos);
}
cdb.finishCreate();
}
}
if (cdb.isValid())
{
Console.WriteLine("Retrieving value for Hello : {0}", cdb.getValueFromKey("Hello"));
Console.WriteLine("Retrieving first value for HELP : {0}", cdb.getValueFromKey("HELP", 0));
Console.WriteLine("Retrieving second value for HELP: {0}", cdb.getValueFromKey("HELP", 1));
// check saved position index
long pos = cdb.getFileOffsetFromKey("Line");
if (pos != -1)
{
using (FileStream fs = new FileStream(argv[0], FileMode.Open, FileAccess.Read))
{
fs.Seek(pos, SeekOrigin.Begin);
using (StreamReader sr = new StreamReader(fs))
{
Console.WriteLine("Testing file offset. Offset {0}: {1}", pos, sr.ReadLine());
}
}
}
else
{
Console.WriteLine("Target line was not found during .cdb file creation");
}
}
else
{
showErrors(cdb);
}
}
// Finds the current position in the underlying Stream for the passed StreamReader
// See http://stackoverflow.com/questions/5404267/streamreader-and-seeking
private static long GetActualPosition(StreamReader reader)
{
// The current buffer of decoded characters
char[] charBuffer = (char[])reader.GetType().InvokeMember("charBuffer"
, System.Reflection.BindingFlags.DeclaredOnly | System.Reflection.BindingFlags.NonPublic | System.Reflection.BindingFlags.Instance | System.Reflection.BindingFlags.GetField
, null, reader, null);
// The current position in the buffer of decoded characters
int charPos = (int)reader.GetType().InvokeMember("charPos"
, System.Reflection.BindingFlags.DeclaredOnly | System.Reflection.BindingFlags.NonPublic | System.Reflection.BindingFlags.Instance | System.Reflection.BindingFlags.GetField
, null, reader, null);
// The number of bytes that the already-read characters need when encoded.
int numReadBytes = reader.CurrentEncoding.GetByteCount(charBuffer, 0, charPos);
// The number of encoded bytes that are in the current buffer
int byteLen = (int)reader.GetType().InvokeMember("byteLen"
, System.Reflection.BindingFlags.DeclaredOnly | System.Reflection.BindingFlags.NonPublic | System.Reflection.BindingFlags.Instance | System.Reflection.BindingFlags.GetField
, null, reader, null);
return reader.BaseStream.Position - byteLen + numReadBytes;
}
private static void showErrors(ms_tinycdb cdb)
{
ms_errs err = cdb.getErrorHandler();
for (int i = 1; i <= err.getNumberOfErrors(); i++)
{
Console.WriteLine("Error number: {0} ({1} times) : {2}", err.getErrorNumber(i), err.getErrorRepeats(i) + 1, err.getErrorString(i));
}
}
}
}
/*
tools_tinycdb.exe .\tools_tinycdb.cs
Will give the following output:
Creating file because: Cache file tools_tinycdb.exe.cdb is missing or cannot be opened
Retrieving value for Hello : world
Retrieving first value for HELP : me
Retrieving second value for HELP: me too
Testing file offset. Offset 3060: // and saves an offset to THIS line!
*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_treecluster.pl

tools_treecluster.pl

Using the matrix_science::ms_treecluster class.

#!/usr/local/bin/perl
##############################################################################
# file: tools_treecluster.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/tools_treecluster.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
use warnings;
##############################################################################
use msparser;
my $rows = 11;
my $cols = 5;
my $tc = msparser::ms_treecluster->new($rows, $cols);
my $data = new msparser::vectord;
my $mask = new msparser::vectori;
$data->push(1.623866862); $data->push(-0.052894948); $data->push(1.182692298); $data->push(2.298658316); $data->push(1.13422094);
$mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(0 , $data, $mask); $data->clear(); $mask->clear();
$data->push(1.156396617); $data->push(0.0000000000); $data->push(0.521050737); $data->push(1.544979883); $data->push(0.65718266);
$mask->push(1); $mask->push(0); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(1 , $data, $mask); $data->clear(); $mask->clear();
$data->push(1.523561956); $data->push(-0.017417053); $data->push(1.168000125); $data->push(2.459693903); $data->push(1.308011315);
$mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(2 , $data, $mask); $data->clear(); $mask->clear();
$data->push(1.55875743); $data->push(-0.241270432); $data->push(0.440420721); $data->push(2.427337989); $data->push(1.043344505);
$mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(3 , $data, $mask); $data->clear(); $mask->clear();
$data->push(1.449957484); $data->push(-0.169744676); $data->push(0.867896464); $data->push(2.418999465); $data->push(1.171206827);
$mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(4 , $data, $mask); $data->clear(); $mask->clear();
$data->push(1.171206827); $data->push(0.0000000000); $data->push(0.854394678); $data->push(2.075532631); $data->push(0.950095094);
$mask->push(1); $mask->push(0); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(5 , $data, $mask); $data->clear(); $mask->clear();
$data->push(1.361768359); $data->push(-0.120294234); $data->push(0.992043276); $data->push(2.238786860); $data->push(1.090175950);
$mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(6 , $data, $mask); $data->clear(); $mask->clear();
$data->push(1.781149852); $data->push(0.0028825090); $data->push(1.079975377); $data->push(2.464929601); $data->push(1.301002256);
$mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(7 , $data, $mask); $data->clear(); $mask->clear();
$data->push(-1.227692025);$data->push(-3.522840789); $data->push(-2.434402824);$data->push(-0.873027144);$data->push(-1.977099598);
$mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(8 , $data, $mask); $data->clear(); $mask->clear();
$data->push(1.272023189); $data->push(-0.535331733); $data->push(0.608809243); $data->push(2.004681156); $data->push(0.826192536);
$mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(9 , $data, $mask);
$data->clear(); $mask->clear();
$data->push(1.069014678); $data->push(-0.623709617); $data->push(0.412510571); $data->push(1.82822536); $data->push(0.650764559);
$mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1); $mask->push(1);
$tc->setRow(10, $data, $mask);
$data->clear(); $mask->clear();
my $weights = new msparser::vectord;
my $left = new msparser::vectori;
my $right = new msparser::vectori;
my $distance = new msparser::vectord;
if (!$tc->cluster($msparser::ms_treecluster::TCD_EUCLIDEAN,
$msparser::ms_mascotresults::TCM_PAIRWISE_AVERAGE,
$weights,
$left,
$right,
$distance)) {
print "Failed\n";
} else {
print "Node\tleft\tright\tdistance\n";
for my $i (0 .. $left->size-1) {
my $node = -1 -$i;
print $node . "\t" . $left->get($i) . "\t" . $right->get($i) . "\t" . $distance->get($i), "\n";
}
}
=pod
Running the program with no arguments, for example with
perl -I../bin treecluster.pl
will give the output:
Node left right distance
-1 6 4 0.0129355369880599
-2 2 0 0.0135342339743674
-3 7 -2 0.0168450469179865
-4 5 9 0.0227119800299183
-5 10 1 0.0249214407900278
-6 -1 -3 0.0358259860933716
-7 -4 -5 0.0759763042954681
-8 3 -6 0.098592161220467
-9 -7 -8 0.225907496391906
-10 8 -9 9.24612595642236
=cut
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_treecluster.py

tools_treecluster.py

Using the matrix_science::ms_treecluster class.

1#!/usr/bin/python
2
16
17import msparser
18
19rows = 11
20cols = 5
21tc = msparser.ms_treecluster(rows, cols)
22
23data = msparser.vectord()
24mask = msparser.vectori()
25
26data.append(1.623866862); data.append(-0.052894948); data.append(1.182692298); data.append(2.298658316); data.append(1.13422094)
27mask.append(1); mask.append(1); mask.append(1); mask.append(1); mask.append(1)
28tc.setRow(0 , data, mask); data.clear(); mask.clear()
29
30data.append(1.156396617); data.append(0.0000000000); data.append(0.521050737); data.append(1.544979883); data.append(0.65718266)
31mask.append(1); mask.append(0); mask.append(1); mask.append(1); mask.append(1)
32tc.setRow(1 , data, mask); data.clear(); mask.clear()
33
34data.append(1.523561956); data.append(-0.017417053); data.append(1.168000125); data.append(2.459693903); data.append(1.308011315)
35mask.append(1); mask.append(1); mask.append(1); mask.append(1); mask.append(1)
36tc.setRow(2 , data, mask); data.clear(); mask.clear()
37
38data.append(1.55875743); data.append(-0.241270432); data.append(0.440420721); data.append(2.427337989); data.append(1.043344505)
39mask.append(1); mask.append(1); mask.append(1); mask.append(1); mask.append(1)
40tc.setRow(3 , data, mask); data.clear(); mask.clear()
41
42data.append(1.449957484); data.append(-0.169744676); data.append(0.867896464); data.append(2.418999465); data.append(1.171206827)
43mask.append(1); mask.append(1); mask.append(1); mask.append(1); mask.append(1)
44tc.setRow(4 , data, mask); data.clear(); mask.clear()
45
46data.append(1.171206827); data.append(0.0000000000); data.append(0.854394678); data.append(2.075532631); data.append(0.950095094)
47mask.append(1); mask.append(0); mask.append(1); mask.append(1); mask.append(1)
48tc.setRow(5 , data, mask); data.clear(); mask.clear()
49
50data.append(1.361768359); data.append(-0.120294234); data.append(0.992043276); data.append(2.238786860); data.append(1.090175950)
51mask.append(1); mask.append(1); mask.append(1); mask.append(1); mask.append(1)
52tc.setRow(6 , data, mask); data.clear(); mask.clear()
53
54data.append(1.781149852); data.append(0.0028825090); data.append(1.079975377); data.append(2.464929601); data.append(1.301002256)
55mask.append(1); mask.append(1); mask.append(1); mask.append(1); mask.append(1)
56tc.setRow(7 , data, mask); data.clear(); mask.clear()
57
58data.append(-1.227692025); data.append(-3.522840789);data.append(-2.434402824);data.append(-0.873027144);data.append(-1.977099598)
59mask.append(1); mask.append(1); mask.append(1); mask.append(1); mask.append(1)
60tc.setRow(8 , data, mask); data.clear(); mask.clear()
61
62data.append(1.272023189); data.append(-0.535331733); data.append(0.608809243); data.append(2.004681156); data.append(0.826192536)
63mask.append(1); mask.append(1); mask.append(1); mask.append(1); mask.append(1)
64tc.setRow(9 , data, mask); data.clear(); mask.clear()
65
66data.append(1.069014678); data.append(-0.623709617); data.append(0.412510571); data.append(1.82822536); data.append(0.650764559)
67mask.append(1); mask.append(1); mask.append(1); mask.append(1); mask.append(1)
68tc.setRow(10 , data, mask); data.clear(); mask.clear()
69
70weights = msparser.vectord()
71left = msparser.vectori()
72right = msparser.vectori()
73distance = msparser.vectord()
74
75if not tc.cluster(msparser.ms_treecluster.TCD_EUCLIDEAN, msparser.ms_mascotresults.TCM_PAIRWISE_AVERAGE, weights, left, right, distance):
76 print("Failed")
77else:
78 print("Node\tleft\tright\tdistance\n")
79 for i in range(0, len(left)):
80 node = -1 - i
81 print("%d \t %d \t %d \t %.16f " % (node, left[i], right[i], distance[i]))
82
83"""
84tools_treecluster.py
85Will give the following output:
86
87Node left right distance
88
89-1 6 4 0.0129355369880599
90-2 2 0 0.0135342339743674
91-3 7 -2 0.0168450469179865
92-4 5 9 0.0227119800299183
93-5 10 1 0.0249214407900277
94-6 -1 -3 0.0358259860933716
95-7 -4 -5 0.0759763042954681
96-8 3 -6 0.0985921612204670
97-9 -7 -8 0.2259074963919064
98-10 8 -9 9.2461259564223610
99"""
100
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_treecluster.cs

tools_treecluster.cs

Using the matrix_science::ms_treecluster class.

/*
##############################################################################
# file: tools_treecluster.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/tools_treecluster.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
public class tools_treecluster
{
public static void Main(string[] argv)
{
int rows = 11;
int cols = 5;
ms_treecluster tc = new ms_treecluster(rows, cols);
var data = new vectord();
var mask = new vectori();
data.Add(1.623866862); data.Add(-0.052894948); data.Add(1.182692298); data.Add(2.298658316); data.Add(1.13422094);
mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1);
tc.setRow(0 , data, mask); data.Clear(); mask.Clear();
data.Add(1.156396617); data.Add(0.0000000000); data.Add(0.521050737); data.Add(1.544979883); data.Add(0.65718266);
mask.Add(1); mask.Add(0); mask.Add(1); mask.Add(1); mask.Add(1);
tc.setRow(1 , data, mask); data.Clear(); mask.Clear();
data.Add(1.523561956); data.Add(-0.017417053); data.Add(1.168000125); data.Add(2.459693903); data.Add(1.308011315);
mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1);
tc.setRow(2 , data, mask); data.Clear(); mask.Clear();
data.Add(1.55875743); data.Add(-0.241270432); data.Add(0.440420721); data.Add(2.427337989); data.Add(1.043344505);
mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1);
tc.setRow(3 , data, mask); data.Clear(); mask.Clear();
data.Add(1.449957484); data.Add(-0.169744676); data.Add(0.867896464); data.Add(2.418999465); data.Add(1.171206827);
mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1);
tc.setRow(4 , data, mask); data.Clear(); mask.Clear();
data.Add(1.171206827); data.Add(0.0000000000); data.Add(0.854394678); data.Add(2.075532631); data.Add(0.950095094);
mask.Add(1); mask.Add(0); mask.Add(1); mask.Add(1); mask.Add(1);
tc.setRow(5 , data, mask); data.Clear(); mask.Clear();
data.Add(1.361768359); data.Add(-0.120294234); data.Add(0.992043276); data.Add(2.238786860); data.Add(1.090175950);
mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1);
tc.setRow(6 , data, mask); data.Clear(); mask.Clear();
data.Add(1.781149852); data.Add(0.0028825090); data.Add(1.079975377); data.Add(2.464929601); data.Add(1.301002256);
mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1);
tc.setRow(7 , data, mask); data.Clear(); mask.Clear();
data.Add(-1.227692025);data.Add(-3.522840789); data.Add(-2.434402824);data.Add(-0.873027144);data.Add(-1.977099598);
mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1);
tc.setRow(8 , data, mask); data.Clear(); mask.Clear();
data.Add(1.272023189); data.Add(-0.535331733); data.Add(0.608809243); data.Add(2.004681156); data.Add(0.826192536);
mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1);
tc.setRow(9 , data, mask);
data.Clear(); mask.Clear();
data.Add(1.069014678); data.Add(-0.623709617); data.Add(0.412510571); data.Add(1.82822536); data.Add(0.650764559);
mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1); mask.Add(1);
var weights = new vectord();
var left = new vectori();
var right = new vectori();
var distance = new vectord();
if (!tc.cluster(ms_treecluster.TREE_CLUSTER_DISTANCE.TCD_EUCLIDEAN, ms_mascotresults.TREE_CLUSTER_METHOD.TCM_PAIRWISE_AVERAGE,
weights, left, right, distance))
{
Console.WriteLine("Failed");
}
else
{
Console.WriteLine("Node\tleft\tright\tdistance\t");
for (int i = 0; i < left.Count; i++)
{
int _node = -1 - i;
Console.WriteLine("{0}\t{1}\t{2}\t{3}", _node, left[i], right[i], distance[i]);
}
}
}
}
}
/*
tools_treecluster.exe
Will give the following output:
Node left right distance
-1 6 4 0.0129355369880599
-2 2 0 0.0135342339743674
-3 7 -2 0.0168450469179865
-4 5 9 0.0227119800299183
-5 -1 -3 0.0358259860933716
-6 -4 1 0.0924477619793738
-7 3 -5 0.098592161220467
-8 -6 -7 0.201808959296598
-9 10 -8 1.88084728645169
-10 8 -9 9.01668349698743
*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_shapiro_wilk.pl

tools_shapiro_wilk.pl

Using the Shapiro-Wilk W test algorithm.

#!/usr/local/bin/perl
##############################################################################
# file: tools_shapiro_wilk.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/tools_shapiro_wilk.pl $
# $Author: villek@matrixscience.com $
# $Date: 2018-07-30 16:23:53 +0100 $
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
##############################################################################
use msparser;
my $sw = new msparser::ms_shapiro_wilk;
$sw->appendSampleValue(-0.1420);
$sw->appendSampleValue(-0.1184);
$sw->appendSampleValue(-0.0583);
$sw->appendSampleValue(-0.0402);
$sw->appendSampleValue(-0.0363);
$sw->appendSampleValue(-0.0363);
$sw->appendSampleValue(-0.0348);
$sw->appendSampleValue(-0.0333);
$sw->appendSampleValue(-0.0222);
$sw->appendSampleValue(-0.0139);
$sw->appendSampleValue(-0.0114);
$sw->appendSampleValue(-0.0042);
$sw->appendSampleValue(-0.0036);
$sw->appendSampleValue(-0.0026);
$sw->appendSampleValue( 0.0000);
$sw->appendSampleValue( 0.0016);
$sw->appendSampleValue( 0.0058);
$sw->appendSampleValue( 0.0077);
$sw->appendSampleValue( 0.0084);
$sw->appendSampleValue( 0.0102);
$sw->appendSampleValue( 0.0132);
$sw->appendSampleValue( 0.0172);
$sw->appendSampleValue( 0.0180);
$sw->appendSampleValue( 0.0191);
$sw->appendSampleValue( 0.0194);
$sw->appendSampleValue( 0.0200);
$sw->appendSampleValue( 0.0246);
$sw->appendSampleValue( 0.0293);
$sw->appendSampleValue( 0.0533);
$sw->appendSampleValue( 0.0987);
$sw->calculate(30,30,15);
my $fmt = "%16s W = %8.6f and P = %8.6f%s\n";
printf $fmt, "Test should give", 0.892184, 0.0054, '';
printf $fmt, "Results:", $sw->getResult, $sw->getPValue(), "; error code = " . $sw->getErrorCode();
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_shapiro_wilk.py

tools_shapiro_wilk.py

Using the Shapiro-Wilk W test algorithm.

1#!/usr/bin/python
2
15
16import msparser
17
18sw = msparser.ms_shapiro_wilk()
19
20sw.appendSampleValue(-0.1420)
21sw.appendSampleValue(-0.1184)
22sw.appendSampleValue(-0.0583)
23sw.appendSampleValue(-0.0402)
24sw.appendSampleValue(-0.0363)
25sw.appendSampleValue(-0.0363)
26sw.appendSampleValue(-0.0348)
27sw.appendSampleValue(-0.0333)
28sw.appendSampleValue(-0.0222)
29sw.appendSampleValue(-0.0139)
30sw.appendSampleValue(-0.0114)
31sw.appendSampleValue(-0.0042)
32sw.appendSampleValue(-0.0036)
33sw.appendSampleValue(-0.0026)
34sw.appendSampleValue( 0.0000)
35sw.appendSampleValue( 0.0016)
36sw.appendSampleValue( 0.0058)
37sw.appendSampleValue( 0.0077)
38sw.appendSampleValue( 0.0084)
39sw.appendSampleValue( 0.0102)
40sw.appendSampleValue( 0.0132)
41sw.appendSampleValue( 0.0172)
42sw.appendSampleValue( 0.0180)
43sw.appendSampleValue( 0.0191)
44sw.appendSampleValue( 0.0194)
45sw.appendSampleValue( 0.0200)
46sw.appendSampleValue( 0.0246)
47sw.appendSampleValue( 0.0293)
48sw.appendSampleValue( 0.0533)
49sw.appendSampleValue( 0.0987)
50
51sw.calculate(30,30,15)
52
53print("Test should give W = %8.6f and P = %8.6f" % (0.892184, 0.0054))
54print("Results: W = %8.6f and P = %8.6f; error code = %d" % (
55 sw.getResult(), sw.getPValue(), sw.getErrorCode()
56 ))
57
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_shapiro_wilk.cs

tools_shapiro_wilk.cs

Using the Shapiro-Wilk W test algorithm.

/*
##############################################################################
# file: tools_shapiro_wilk.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/tools_shapiro_wilk.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
class tools_shapiro_wilk
{
public static void Main(string[] argv)
{
ms_shapiro_wilk sw = new ms_shapiro_wilk();
sw.appendSampleValue(-0.1420);
sw.appendSampleValue(-0.1184);
sw.appendSampleValue(-0.0583);
sw.appendSampleValue(-0.0402);
sw.appendSampleValue(-0.0363);
sw.appendSampleValue(-0.0363);
sw.appendSampleValue(-0.0348);
sw.appendSampleValue(-0.0333);
sw.appendSampleValue(-0.0222);
sw.appendSampleValue(-0.0139);
sw.appendSampleValue(-0.0114);
sw.appendSampleValue(-0.0042);
sw.appendSampleValue(-0.0036);
sw.appendSampleValue(-0.0026);
sw.appendSampleValue( 0.0000);
sw.appendSampleValue( 0.0016);
sw.appendSampleValue( 0.0058);
sw.appendSampleValue( 0.0077);
sw.appendSampleValue( 0.0084);
sw.appendSampleValue( 0.0102);
sw.appendSampleValue( 0.0132);
sw.appendSampleValue( 0.0172);
sw.appendSampleValue( 0.0180);
sw.appendSampleValue( 0.0191);
sw.appendSampleValue( 0.0194);
sw.appendSampleValue( 0.0200);
sw.appendSampleValue( 0.0246);
sw.appendSampleValue( 0.0293);
sw.appendSampleValue( 0.0533);
sw.appendSampleValue( 0.0987);
sw.calculate(30, 30, 15);
string format = "{0} W = {1:0.######} and P = {2:0.######}{3}";
Console.WriteLine(format, "Test should give", 0.892184, 0.0054, "");
Console.WriteLine(format, "Results:", sw.getResult(), sw.getPValue(), "; error code = " + sw.getErrorCode());
}
}
}
/*
tools_shapiro_wilk.exe
Will give the following output:
Test should give W = 0.892184 and P = 0.0054
Results: W = 0.892184 and P = 0.005437; error code = 0
*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_stats.pl

tools_stats.pl

Using statistical routines.

#!/usr/local/bin/perl
##############################################################################
# file: tools_stats.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/tools_stats.pl $
# $Author: villek@matrixscience.com $
# $Date: 2018-07-30 16:23:53 +0100 $
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
##############################################################################
use msparser;
print "Binomial coefficients for sample size 6:\n";
for my $i (0 .. 6) {
printf "\t6 choose %d = %g\n", $i, msparser::ms_quant_stats::binomialCoefficient(6, $i);
}
print "First 10 values of the Poisson(lambda = 1) distribution:\n";
for my $i (1 .. 10) {
printf "\tPoisson(lambda 1, k %d) = %g\n", $i, msparser::ms_quant_stats::poissonDensity(1, $i);
}
print "Common values of the standard normal distribution:\n";
for (0.001, 0.01, 0.025, 0.05, 0.1, 0.5, 0.9, 0.95, 0.975, 0.99, 0.999) {
# Note that normalCriticalValue() takes an argument between 0.5 and 1.0;
# that is, it returns only the right tail critical values.
my $critval;
if ($_ < 0.5) {
$critval = -msparser::ms_quant_stats::normalCriticalValue(1 - $_);
} else {
$critval = msparser::ms_quant_stats::normalCriticalValue($_);
}
printf "\tNormal-1(%g) = %g\n", $_, $critval;
}
for (-3.09, -2.32, -1.96, -1.64, -1.28, 0, 1.28, 1.64, 1.96, 2.32, 3.09) {
# Note that normalCumulativeProbability() takes an argument between 0 and
# 4.09; that is, it reports only the right tail probability.
my $p;
if ($_ < 0) {
$p = 0.5 - msparser::ms_quant_stats::normalCumulativeProbability(-$_);
} else {
$p = 0.5 + msparser::ms_quant_stats::normalCumulativeProbability($_);
}
printf "\tNormal(x <= %g) = %g\n", $_, $p;
}
print "Common values of the chi-square distribution at 10 degrees of freedom:\n";
# Note the significance levels the chi-square functions support.
for (0.001, 0.01, 0.025, 0.05, 0.1) {
my $lowcrit = msparser::ms_quant_stats::chisqLowerCriticalValue(10, $_);
my $upcrit = msparser::ms_quant_stats::chisqUpperCriticalValue(10, $_);
printf "\tchi-sq(df 10, sigLevel %g) = <%g, %g>\n", $_, $lowcrit, $upcrit;
}
print "Common values of the Student's t distribution at 10 degrees of freedom:\n";
# Note the significance levels the Student's t function supports.
for (0.001, 0.005, 0.01, 0.025, 0.05, 0.1) {
printf "\tt(df 10, sigLevel %g) = %g\n",
$_,
msparser::ms_quant_stats::studentsCriticalValue(10, $_);
}
print "Common values of the F distribution at 10 and 1 degrees of freedom:\n";
# Note the significance levels the F function supports.
for (0.01, 0.05, 0.1) {
printf "\tF(df1 10, df2 1, sigLevel %g) = %g\n",
$_,
msparser::ms_quant_stats::snedecorsCriticalValue(10, 1, $_);
}
my @samples = (
# Uniform data generated with
# perl -e 'print join "\n", map {+ rand() } 0 .. 9'
{ name => 'uniform(0,1)', popmean => 0.5, data => [split /\s+/, <<EOD] },
0.400313346021907
0.635154745166318
0.795328049493161
0.465079196585926
0.709667388012424
0.76161797692474
0.617230566355229
0.282583560369936
0.251706165020014
0.2962014901575
EOD
# Normal(5, 2.5) data generated in R with
# > rnorm(10, 5, 2.5)
{ name => 'normal(5,2.5)', popmean => 5, data => [split /\s+/, <<EOD] },
3.1476833
9.2061900
2.6079399
4.4361054
6.4133568
4.3745899
3.5588195
3.0542840
0.6643241
4.3697818
EOD
# Beta(0.5, 0.5) data generated in R with
# > rbeta(10, 0.5, 0.5)
{ name => 'beta(0.5,0.5)', popmean => 0.5, data => [split /\s+/, <<EOD] },
0.754152463
0.008992998
0.221637853
0.426146895
0.656421042
0.224818243
0.022050868
0.539143737
0.877643550
0.128030530
EOD
);
print "\n";
for my $sample (@samples) {
printf "Sample '%s' = [%s]\n", $sample->{'name'}, join(', ', @{ $$sample{'data'} });
# ms_quant_stats takes as input STL vectors of type double. We can easily
# convert a Perl array into one:
my $vec = msparser::vectord->new(scalar(@{ $$sample{'data'} }));
for (0 .. $#{ $$sample{'data'} }) {
$vec->set($_, $$sample{'data'}[$_]);
}
# The sorted sample vector is needed for the Shapiro-Wilk W test.
# It also makes finding the sample median fast.
my $vec_sorted;
do {
my @sorted = sort { $a <=> $b } @{ $$sample{'data'} };
$vec_sorted = msparser::vectord->new(scalar(@sorted));
for (0 .. $#{ $$sample{'data'} }) {
$vec_sorted->set($_, $sorted[$_]);
}
};
# Auxiliary helper functions:
printf "\tSum = %g\n", msparser::ms_quant_stats::sum($vec);
printf "\tSum of squares = %g\n", msparser::ms_quant_stats::sumsq($vec);
printf "\tLog transformed = [%s]\n", join(', ', @{ msparser::ms_quant_stats::logTransform($vec) });
printf "\tExp transformed = [%s]\n", join(', ', @{ msparser::ms_quant_stats::expTransform($vec) });
# Basic sample statistics:
my $xbar = msparser::ms_quant_stats::arithmeticMean($vec);
my $stdev = msparser::ms_quant_stats::arithmeticStandardDeviation($vec, $xbar);
my $median = msparser::ms_quant_stats::sortedMedian($vec_sorted);
# If the vector isn't sorted:
# my $median = msparser::ms_quant_stats::unsortedMedian($vec);
my $geombar = msparser::ms_quant_stats::geometricMean($vec);
my $geomdev = msparser::ms_quant_stats::geometricStandardDeviation($vec, $geombar);
printf "\tArithmetic stdev = %g\n", $stdev;
printf "\tArithmetic mean = %g\n", $xbar;
printf "\tStandard error of mean = %g\n", msparser::ms_quant_stats::arithmeticStandardErrorOfMean($stdev, $vec->size());
printf "\tMedian = %g\n", $median;
printf "\tStandard error of median = %g\n", msparser::ms_quant_stats::arithmeticStandardErrorOfMedian($stdev, $vec->size());
printf "\tGeometric mean = %g\n", $geombar;
printf "\tGeometric stdev = %g\n", $geomdev;
# Basic distribution tests for normally distributed data:
printf "\tHypothesis: distribution is N(%g, sigma^2) (mean test). p-value = %g\n",
$$sample{'popmean'},
msparser::ms_quant_stats::calculateNormalMeanPvalue($$sample{'popmean'}, $xbar, $stdev, $vec->size());
printf "\tHypothesis: distribution is N(%g, sigma^2) (median test). p-value = %g\n",
$$sample{'popmean'},
msparser::ms_quant_stats::calculateNormalMedianPvalue($$sample{'popmean'}, $median, $stdev, $vec->size());
# (We would expect the normal sample to have the highest p-value, i.e.
# least evidence against the hypothesis, while the uniform and beta
# distribution should have fairly low p-values. However, sample size is
# so small that the tests are not very reliable.)
do {
my ($ok, $W, $p) = msparser::ms_quant_stats::testShapiroWilkW($vec_sorted);
printf "\tShapiro-Wilk ok = %d, W = %s, p-value = %s\n", $ok, (defined $W ? $W : '(none)'), (defined $p ? $p : '(none)');
};
# Outlier detection can be done even when the above tests indicate that
# the sample is not normally distributed. However, don't trust the results!
do {
# Note that the input vector must be sorted for outlier testing to
# work.
my ($numL, $numH) = msparser::ms_quant_stats::detectOutliers($vec_sorted, "auto", 0.05);
# $numL and $numH are the number of elements at each end of $vec_sorted
# which seem to be outliers. That is, elements between 0 and $numL-1,
# and $vec_sorted->size()-$numH to $vec_sorted->size()-1.
printf "\tOutlier detection('auto', 0.05') = <%s, %s>\n", (defined $numL ? $numL : '(none)'), (defined $numH ? $numH : '(none)');
};
print "\n";
}
=pod
Running the program as
perl -I../bin tools_stats.pl
will give the following output under Mascot 2.5:
Binomial coefficients for sample size 6:
6 choose 0 = 1
6 choose 1 = 6
6 choose 2 = 15
6 choose 3 = 20
6 choose 4 = 15
6 choose 5 = 6
6 choose 6 = 1
First 10 values of the Poisson(lambda = 1) distribution:
Poisson(lambda 1, k 1) = 0.367879
Poisson(lambda 1, k 2) = 0.18394
Poisson(lambda 1, k 3) = 0.0613132
Poisson(lambda 1, k 4) = 0.0153283
Poisson(lambda 1, k 5) = 0.00306566
Poisson(lambda 1, k 6) = 0.000510944
Poisson(lambda 1, k 7) = 7.2992e-05
Poisson(lambda 1, k 8) = 9.12399e-06
Poisson(lambda 1, k 9) = 1.01378e-06
Poisson(lambda 1, k 10) = 1.01378e-07
Common values of the standard normal distribution:
Normal-1(0.001) = -3.09
Normal-1(0.01) = -2.318
Normal-1(0.025) = -1.959
Normal-1(0.05) = -1.642
Normal-1(0.1) = -1.282
Normal-1(0.5) = 0
Normal-1(0.9) = 1.282
Normal-1(0.95) = 1.642
Normal-1(0.975) = 1.959
Normal-1(0.99) = 2.318
Normal-1(0.999) = 3.09
Normal(x <= -3.09) = 0.001
Normal(x <= -2.32) = 0.00554
Normal(x <= -1.96) = 0.025
Normal(x <= -1.64) = 0.0505
Normal(x <= -1.28) = 0.10027
Normal(x <= 0) = 0.5
Normal(x <= 1.28) = 0.89973
Normal(x <= 1.64) = 0.9495
Normal(x <= 1.96) = 0.975
Normal(x <= 2.32) = 0.99446
Normal(x <= 3.09) = 0.999
Common values of the chi-square distribution at 10 degrees of freedom:
chi-sq(df 10, sigLevel 0.001) = <1.479, 29.588>
chi-sq(df 10, sigLevel 0.01) = <2.558, 23.209>
chi-sq(df 10, sigLevel 0.025) = <3.247, 20.483>
chi-sq(df 10, sigLevel 0.05) = <3.94, 18.307>
chi-sq(df 10, sigLevel 0.1) = <4.865, 15.987>
Common values of the Student's t distribution at 10 degrees of freedom:
t(df 10, sigLevel 0.001) = 4.143
t(df 10, sigLevel 0.005) = 3.169
t(df 10, sigLevel 0.01) = 2.764
t(df 10, sigLevel 0.025) = 2.228
t(df 10, sigLevel 0.05) = 1.812
t(df 10, sigLevel 0.1) = 1.372
Common values of the F distribution at 10 and 1 degrees of freedom:
F(df1 10, df2 1, sigLevel 0.01) = 6055.85
F(df1 10, df2 1, sigLevel 0.05) = 241.882
F(df1 10, df2 1, sigLevel 0.1) = 60.195
Sample 'uniform(0,1)' = [0.400313346021907, 0.635154745166318, 0.795328049493161, 0.465079196585926, 0.709667388012424, 0.76161797692474, 0.617230566355229, 0.282583560369936, 0.251706165020014, 0.2962014901575]
Sum = 5.21488
Sum of squares = 3.10813
Log transformed = [-0.915507673489646, -0.4538866166025, -0.229000608568736, -0.765547572658224, -0.342958886300134, -0.272310191628172, -0.482512635488649, -1.26378098321243, -1.37949288361674, -1.21671534624448]
Exp transformed = [1.49229222822126, 1.88731417160841, 2.2151675622189, 1.59214027596837, 2.03331484127, 2.14173870243289, 1.85378698617621, 1.32655261769313, 1.28621804590024, 1.34474108162913]
Arithmetic stdev = 0.2078
Arithmetic mean = 0.521488
Standard error of mean = 0.065712
Median = 0.541155
Standard error of median = 0.0773299
Geometric mean = 0.480864
Geometric stdev = 1.54969
Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.75114
Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.607474
Shapiro-Wilk ok = 1, W = 0.904955259787869, p-value = 0.248103833545881
Outlier detection('auto', 0.05') = <0, 0>
Sample 'normal(5,2.5)' = [3.1476833, 9.2061900, 2.6079399, 4.4361054, 6.4133568, 4.3745899, 3.5588195, 3.0542840, 0.6643241, 4.3697818]
Sum = 41.8331
Sum of squares = 222.941
Log transformed = [1.14666672193647, 2.21987608389596, 0.958560599320351, 1.48977682935013, 1.85838281560642, 1.47581277827312, 1.26942888874853, 1.11654519526921, -0.408985146179298, 1.47471307651077]
Exp transformed = [23.2820644952793, 9958.58228914508, 13.5710642846326, 84.4454192814535, 609.93768731081, 79.4072679533238, 35.1217114826069, 21.2059965963608, 1.94317668425472, 79.0263862606734]
Arithmetic stdev = 2.30796
Arithmetic mean = 4.18331
Standard error of mean = 0.72984
Median = 3.9643
Standard error of median = 0.858876
Geometric mean = 3.5257
Geometric stdev = 2.00172
Hypothesis: distribution is N(5, sigma^2) (mean test). p-value = 0.292114
Hypothesis: distribution is N(5, sigma^2) (median test). p-value = 0.258609
Shapiro-Wilk ok = 1, W = 0.917418368639979, p-value = 0.335925333025062
Outlier detection('auto', 0.05') = <0, 0>
Sample 'beta(0.5,0.5)' = [0.754152463, 0.008992998, 0.221637853, 0.426146895, 0.656421042, 0.224818243, 0.022050868, 0.539143737, 0.877643550, 0.128030530]
Sum = 3.85904
Sum of squares = 2.3588
Log transformed = [-0.28216072584468, -4.71130900444498, -1.50671052190953, -0.852971168207217, -0.420952863607245, -1.49246301212003, -3.8144033127847, -0.617773070154802, -0.130514747277869, -2.05548652787785]
Exp transformed = [2.12580905780365, 1.00903355649617, 1.24811929335097, 1.53134570563969, 1.92788017044885, 1.2520951184563, 1.02229578528984, 1.71453813789789, 2.40522523023951, 1.13658770218992]
Arithmetic stdev = 0.310837
Arithmetic mean = 0.385904
Standard error of mean = 0.0982953
Median = 0.325483
Standard error of median = 0.115674
Geometric mean = 0.204237
Geometric stdev = 4.71093
Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.275606
Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.165651
Shapiro-Wilk ok = 1, W = 0.930482521074392, p-value = 0.452655082151213
Outlier detection('auto', 0.05') = <0, 0>
=cut
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_stats.py

tools_stats.py

Using statistical routines.

1#!/usr/bin/python
2
16
17import msparser
18
19# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
20def ms_range(start, stop, step=1):
21 i = start
22 while i <= stop:
23 yield i
24 i += step
25
26print("\n")
27print("Bionominal coefficients for sample size 6:")
28
29for i in ms_range(0, 6):
30 print("\t6 choose %d = %f" %(i, msparser.ms_quant_stats.binomialCoefficient(6, i)))
31
32print("\n")
33print("First 10 values of the Poisson(lambda = 1) distribution:")
34
35for i in ms_range(0, 10):
36 print("\tPoisson(lambda 1, k %d) = %f" %(i, msparser.ms_quant_stats.poissonDensity(1, i)))
37
38print("\n")
39print("Common values of the standard normal distribution:")
40
41for i in [0.001, 0.01, 0.025, 0.05, 0.1, 0.5, 0.9, 0.95, 0.975, 0.99, 0.999]:
42# Note that normalCriticalValue() takes an argument between 0.5 and 1.0;
43# that is, it returns only the right tail critical values.
44 if (i < 0.5):
45 critval = msparser.ms_quant_stats.normalCriticalValue(1 - i)
46 else:
47 critval = msparser.ms_quant_stats.normalCriticalValue(i)
48 print("\tNormal-1(%f) = %f" %(i, critval))
49
50print("\n")
51for i in [-3.09, -2.32, -1.96, -1.64, -1.28, 0, 1.28, 1.64, 1.96, 2.32, 3.09]:
52# Note that normalCumulativeProbability() takes an argument between 0 and
53# 4.09; that is, it reports only the right tail probability.
54 if (i < 0):
55 p = 0.5 - msparser.ms_quant_stats.normalCumulativeProbability(-i)
56 else:
57 p = 0.5 + msparser.ms_quant_stats.normalCumulativeProbability(i)
58 print("\tNormal(x <= %f) = %f" %(i, p))
59
60print("\n")
61print("Common values of the chi-square distribution at 10 degrees of freedom:")
62
63# Note the significance levels the chi-square functions support.
64for i in [0.001, 0.01, 0.025, 0.05, 0.1]:
65 lowcrit = msparser.ms_quant_stats.chisqLowerCriticalValue(10, i)
66 upcrit = msparser.ms_quant_stats.chisqUpperCriticalValue(10, i)
67 print("\tchi-sq(df 10, sigLevel %f) = <%f, %f>" %(i, lowcrit, upcrit))
68
69print("\n")
70print("Common values of the Student's t distribution at 10 degrees of freedom:")
71# Note the significance levels the Student's t function supports.
72for i in [0.001, 0.005, 0.01, 0.025, 0.05, 0.1]:
73 print("\tt(df 10, sigLevel %f) = %f" %(i, msparser.ms_quant_stats.studentsCriticalValue(10, i)))
74
75print("\n")
76print("Common values of the F distribution at 10 and 1 degrees of freedom:")
77# Note the significance levels the F function supports.
78for i in [0.01, 0.05, 0.1]:
79 print("\tF(df1 10, df2 1, sigLevel %f) = %f" %(i, msparser.ms_quant_stats.snedecorsCriticalValue(10, 1, i)))
80
81print("\n")
82
83samples = [
84# Uniform data generated with
85# perl -e 'print join "\n", map {+ rand() } 0 .. 9'
86['uniform(0,1)', 0.5, [0.400313346021907, 0.635154745166318, 0.795328049493161, 0.465079196585926, 0.709667388012424, 0.76161797692474, 0.617230566355229, 0.282583560369936, 0.251706165020014, 0.2962014901575]],
87# Normal(5, 2.5) data generated in R with
88# > rnorm(10, 5, 2.5)
89['normal(5,2.5)', 5, [3.1476833, 9.2061900, 2.6079399, 4.4361054, 6.4133568, 4.3745899, 3.5588195, 3.0542840, 0.6643241, 4.3697818]],
90# Beta(0.5, 0.5) data generated in R with
91# > rbeta(10, 0.5, 0.5)
92['beta(0.5,0.5)', 0.5, [0.754152463, 0.008992998, 0.221637853, 0.426146895, 0.656421042, 0.224818243, 0.022050868, 0.539143737, 0.877643550, 0.128030530]]
93]
94
95
96
97# Auxiliary helper functions:
98def aux_helper(vec, vec_sorted):
99 print("\tSum = %g" %(msparser.ms_quant_stats.sum(vec)))
100 print("\tSum of squares = %g" %(msparser.ms_quant_stats.sumsq(vec)))
101 print("\tLog transformed = [%s]" %str((msparser.ms_quant_stats.logTransform(vec))))
102 print("\tExp transformed = [%s]" %str((msparser.ms_quant_stats.expTransform(vec))))
103
104# Basic sample statistics:
105
106 xbar = msparser.ms_quant_stats.arithmeticMean(vec)
107 stdev = msparser.ms_quant_stats.arithmeticStandardDeviation(vec, xbar)
108 median = msparser.ms_quant_stats.sortedMedian(vec_sorted)
109
110# If the vector isn't sorted:
111# median = msparser.ms_quant_stats.unsortedMedian(vec)
112
113 geombar = msparser.ms_quant_stats.geometricMean(vec)
114 geomdev = msparser.ms_quant_stats.geometricStandardDeviation(vec, geombar)
115
116 print("\tArithmetic stdev = %g" %(stdev))
117 print("\tArithmetic mean = %g" %(xbar))
118 print("\tStandard error of mean = %g" %(msparser.ms_quant_stats.arithmeticStandardErrorOfMean(stdev, len(vec))))
119 print("\tMedian = %g" %(median))
120 print("\tStandard error of median = %g" %(msparser.ms_quant_stats.arithmeticStandardErrorOfMedian(stdev, len(vec))))
121 print("\tGeometric mean = %g" %(geombar))
122 print("\tGeometric stdev = %g" %(geomdev))
123
124# Basic distribution tests for normally distributed data:
125
126 print("\tHypothesis: distribution is N(%g, sigma^2) (mean test). p-value = %g" %(sample[1], msparser.ms_quant_stats.calculateNormalMeanPvalue(sample[1], xbar, stdev, len(vec))))
127 print("\tHypothesis: distribution is N(%g, sigma^2) (median test). p-value = %g" %(sample[1], msparser.ms_quant_stats.calculateNormalMedianPvalue(sample[1], median, stdev, len(vec))))
128
129# (We would expect the normal sample to have the highest p-value, i.e.
130# least evidence against the hypothesis, while the uniform and beta
131# distribution should have fairly low p-values. However, sample size is
132# so small that the tests are not very reliable.)
133
134 ok, W, p = msparser.ms_quant_stats.testShapiroWilkW(vec_sorted)
135 if W == None:
136 W = 'None'
137 if p == None:
138 p = 'None'
139 print("\tShapiro-Wilk ok = %d, W = %s, p-value = %s" %(ok, W, p))
140
141# Outlier detection can be done even when the above tests indicate that
142# the sample is not normally distributed. However, don't trust the results!
143
144
145# Note that the input vector must be sorted for outlier testing to
146# work.
147 numL, numH = msparser.ms_quant_stats.detectOutliers(vec_sorted, "auto", 0.05)
148 if numL == None:
149 numL = 'None'
150 if numH == None:
151 numH = 'None'
152# numL and numH are the number of elements at each end of vec_sorted
153# which seem to be outliers. That is, elements between 0 and numL-1,
154# and len(vec_sorted)-numH to len(vec_sorted)-1.
155
156 print("\tOutlier detection('auto', 0.05') = <%s, %s>" %(numL, numH))
157
158
159for sample in samples:
160 print("Sample '%s' = [%s]" %(sample[0], sample[2]))
161# ms_quant_stats takes as input STL vectors of type double. We can easily
162# convert a Python list into one:
163 vec = msparser.vectord()
164 vectors = sample[2]
165 for i in ms_range(0, len(vectors)-1):
166 vec.append(vectors[i])
167
168# The sorted sample vector is needed for the Shapiro-Wilk W test.
169# It also makes finding the sample median fast.
170 vec_sorted = msparser.vectord()
171 vectors_sorted = sample[2]
172 vectors_sorted.sort()
173 for i in ms_range(0, len(vectors_sorted)-1):
174 vec_sorted.append(vectors_sorted[i])
175 aux_helper(vec, vec_sorted)
176 print("\n")
177
178'''
179Running the program as
180
181python tools_stats.pl
182
183will give the following output under Mascot 2.5:
184
185Bionominal coefficients for sample size 6:
186 6 choose 0 = 1.000000
187 6 choose 1 = 6.000000
188 6 choose 2 = 15.000000
189 6 choose 3 = 20.000000
190 6 choose 4 = 15.000000
191 6 choose 5 = 6.000000
192
193
194First 10 values of the Poisson(lambda = 1) distribution:
195 Poisson(lambda 1, k 0) = 0.367879
196 Poisson(lambda 1, k 1) = 0.367879
197 Poisson(lambda 1, k 2) = 0.183940
198 Poisson(lambda 1, k 3) = 0.061313
199 Poisson(lambda 1, k 4) = 0.015328
200 Poisson(lambda 1, k 5) = 0.003066
201 Poisson(lambda 1, k 6) = 0.000511
202 Poisson(lambda 1, k 7) = 0.000073
203 Poisson(lambda 1, k 8) = 0.000009
204 Poisson(lambda 1, k 9) = 0.000001
205
206
207Common values of the standard normal distribution:
208 Normal-1(0.001000) = 3.090000
209 Normal-1(0.010000) = 2.318000
210 Normal-1(0.025000) = 1.959000
211 Normal-1(0.050000) = 1.642000
212 Normal-1(0.100000) = 1.282000
213 Normal-1(0.500000) = 0.000000
214 Normal-1(0.900000) = 1.282000
215 Normal-1(0.950000) = 1.642000
216 Normal-1(0.975000) = 1.959000
217 Normal-1(0.990000) = 2.318000
218 Normal-1(0.999000) = 3.090000
219
220
221 Normal(x <= -3.090000) = 0.001000
222 Normal(x <= -2.320000) = 0.005540
223 Normal(x <= -1.960000) = 0.025000
224 Normal(x <= -1.640000) = 0.050500
225 Normal(x <= -1.280000) = 0.100270
226 Normal(x <= 0.000000) = 0.500000
227 Normal(x <= 1.280000) = 0.899730
228 Normal(x <= 1.640000) = 0.949500
229 Normal(x <= 1.960000) = 0.975000
230 Normal(x <= 2.320000) = 0.994460
231 Normal(x <= 3.090000) = 0.999000
232
233
234Common values of the chi-square distribution at 10 degrees of freedom:
235 chi-sq(df 10, sigLevel 0.001000) = <1.479000, 29.588000>
236 chi-sq(df 10, sigLevel 0.010000) = <2.558000, 23.209000>
237 chi-sq(df 10, sigLevel 0.025000) = <3.247000, 20.483000>
238 chi-sq(df 10, sigLevel 0.050000) = <3.940000, 18.307000>
239 chi-sq(df 10, sigLevel 0.100000) = <4.865000, 15.987000>
240
241
242Common values of the Student's t distribution at 10 degrees of freedom: t(df 10, sigLevel 0.001000) = 4.143000
243 t(df 10, sigLevel 0.005000) = 3.169000
244 t(df 10, sigLevel 0.010000) = 2.764000
245 t(df 10, sigLevel 0.025000) = 2.228000
246 t(df 10, sigLevel 0.050000) = 1.812000
247 t(df 10, sigLevel 0.100000) = 1.372000
248
249
250Common values of the F distribution at 10 and 1 degrees of freedom:
251 F(df1 10, df2 1, sigLevel 0.010000) = 6055.850000
252 F(df1 10, df2 1, sigLevel 0.050000) = 241.882000
253 F(df1 10, df2 1, sigLevel 0.100000) = 60.195000
254
255
256Sample 'uniform(0,1)' = [[0.400313346021907, 0.635154745166318, 0.795328049493161, 0.465079196585926, 0.709667388012424, 0.76161797692474, 0.617230566355229, 0.282583560369936, 0.251706165020014, 0.2962014901575]]
257 Sum = 5.21488
258 Sum of squares = 3.10813
259 Log transformed = [(-0.915507673489646, -0.4538866166025002, -0.22900060856873583, -0.7655475726582238, -0.342958886300134, -0.2723101916281718, -0.48251263548864914, -1.2637809832124323, -1.379492883616736, -1.216715346244483)]
260 Exp transformed = [(1.4922922282212572, 1.8873141716084079, 2.215167562218903, 1.592140275968374, 2.03331484127, 2.1417387024328853, 1.853786986176205, 1.3265526176931346, 1.2862180459002401, 1.3447410816291303)]
261 Arithmetic stdev = 0.2078
262 Arithmetic mean = 0.521488
263 Standard error of mean = 0.065712
264 Median = 0.541155
265 Standard error of median = 0.0773299
266 Geometric mean = 0.480864
267 Geometric stdev = 1.54969
268 Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.75114
269 Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.607474
270 Shapiro-Wilk ok = 1, W = 0.904955259788, p-value = 0.248103833546
271 Outlier detection('auto', 0.05') = <0, 0>
272
273
274Sample 'normal(5,2.5)' = [[3.1476833, 9.20619, 2.6079399, 4.4361054, 6.4133568, 4.3745899, 3.5588195, 3.054284, 0.6643241, 4.3697818]]
275 Sum = 41.8331
276 Sum of squares = 222.941
277 Log transformed = [(1.146666721936465, 2.2198760838959566, 0.9585605993203508, 1.489776829350127, 1.8583828156064155, 1.47581277827312, 1.2694288887485337, 1.1165451952692114, -0.40898514617929754, 1.474713076510773)]
278 Exp transformed = [(23.282064495279258, 9958.582289145075, 13.571064284632554, 84.44541928145347, 609.9376873108102, 79.40726795332382, 35.1217114826069, 21.205996596360794, 1.9431766842547191, 79.02638626067342)]
279 Arithmetic stdev = 2.30796
280 Arithmetic mean = 4.18331
281 Standard error of mean = 0.72984
282 Median = 3.9643
283 Standard error of median = 0.858876
284 Geometric mean = 3.5257
285 Geometric stdev = 2.00172
286 Hypothesis: distribution is N(5, sigma^2) (mean test). p-value = 0.292114
287 Hypothesis: distribution is N(5, sigma^2) (median test). p-value = 0.258609
288 Shapiro-Wilk ok = 1, W = 0.91741836864, p-value = 0.335925333025
289 Outlier detection('auto', 0.05') = <0, 0>
290
291
292Sample 'beta(0.5,0.5)' = [[0.754152463, 0.008992998, 0.221637853, 0.426146895, 0.656421042, 0.224818243, 0.022050868, 0.539143737, 0.87764355, 0.12803053]]
293 Sum = 3.85904
294 Sum of squares = 2.3588
295 Log transformed = [(-0.28216072584468, -4.7113090044449795, -1.506710521909531, -0.8529711682072173, -0.42095286360724493, -1.4924630121200262, -3.8144033127847012, -0.6177730701548017, -0.13051474727786935, -2.055486527877849)]
296 Exp transformed = [(2.1258090578036466, 1.0090335564961697, 1.2481192933509702, 1.5313457056396895, 1.9278801704488464, 1.252095118456305, 1.0222957852898442, 1.7145381378978928, 2.4052252302395134, 1.1365877021899178)]
297 Arithmetic stdev = 0.310837
298 Arithmetic mean = 0.385904
299 Standard error of mean = 0.0982953
300 Median = 0.325483
301 Standard error of median = 0.115674
302 Geometric mean = 0.204237
303 Geometric stdev = 4.71093
304 Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.275606
305 Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.165651
306 Shapiro-Wilk ok = 1, W = 0.930482521074, p-value = 0.452655082151
307 Outlier detection('auto', 0.05') = <0, 0>
308
309'''
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_stats.cs

tools_stats.cs

Using statistical routines.

/*
##############################################################################
# file: tools_stats.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/tools_stats.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.Collections.Generic;
using matrix_science.msparser;
namespace MsParserExamples
{
class tools_stats
{
public static void Main(string[] args)
{
Console.WriteLine("Binomial coefficients for sample size 6:");
for (int i = 0; i <= 6; i++)
{
Console.WriteLine("\t6 choose {0} = {1}", i, ms_quant_stats.binomialCoefficient(6, (uint) i));
}
Console.WriteLine("First 10 values of the Poisson (lambda = 1) distribution");
for (int i = 1; i <= 10; i++)
{
Console.WriteLine("\tPoisson(lambda 1, k {0}) = {1}", i, ms_quant_stats.poissonDensity(1, (uint) i));
}
Console.WriteLine("Common values of the standard normal distribution");
foreach (double t in (new double[] {0.001, 0.01, 0.025, 0.05, 0.1, 0.5, 0.9, 0.95, 0.975, 0.99, 0.999})) {
// Note that normalCriticalValue() takes and argument between 0.5 and 1.0;
// that is, it returns only the right tail critical values
double critval;
if (t < 0.5)
{
critval = -ms_quant_stats.normalCriticalValue(1d - t);
}
else
{
critval = ms_quant_stats.normalCriticalValue(t);
}
Console.WriteLine("\tNormal-1({0}) = {1}", t, critval);
}
foreach (double t in (new double[] {-3.09, -2.32, -1.96, -1.64, -1.28, 0, 1.28, 1.64, 1.96, 2.32, 3.09}))
{
// Note that normalCumulativeProbability() takes and argument between 0 and 4.09; that is
// it reports only the right tail probability
double p;
if (t < 0)
{
p = 0.5 - ms_quant_stats.normalCumulativeProbability(-t);
}
else
{
p = 0.5 + ms_quant_stats.normalCumulativeProbability(t);
}
Console.WriteLine("\tNormal(x <= {0}) = {1:0.######}", t, p);
}
Console.WriteLine("Common values of the chi-squared distribution at 10 degrees of freedom:");
// Note the significance levels the chi-square functions support
foreach (double t in (new double[] {0.001, 0.01, 0.025, 0.05, 0.1})) {
double lowcrit = ms_quant_stats.chisqLowerCriticalValue(10, t);
double upcrit = ms_quant_stats.chisqUpperCriticalValue(10, t);
Console.WriteLine("\tchi-sq(df 10, sigLevel {0}) = <{1}, {2}>", t, lowcrit, upcrit);
}
Console.WriteLine("Common values of the Student's t distribution at 10 degrees of freedom:");
// Note the significance levels the Student's t function supports.
foreach (double t in (new double[] {0.001, 0.005, 0.01, 0.025, 0.05, 0.1}))
{
Console.WriteLine("\tt(df 10, sigLevel {0}) = {1}", t, ms_quant_stats.studentsCriticalValue(10, t));
}
Console.WriteLine("Common values of the F distribution at 10 and 1 degrees of freedom:");
// Note the significance levels the F function supports
foreach(double t in (new double[] {0.01, 0.05, 0.1}))
{
Console.WriteLine("\tF(df1 10, df2 1, sifLevel {0}) = {1}", t, ms_quant_stats.snedecorsCriticalValue(10, 1, t));
}
// see Sample struct below
List<Sample> samples = new List<Sample>();
// uniform data generated with
// perl -e 'print join "\n", map {+ rand() } 0 .. 0'
samples.Add(new Sample("uniform(0,1)",
new double[] { 0.400313346021907, 0.635154745166318, 0.795328049493161, 0.465079196585926, 0.709667388012424 ,
0.76161797692474, 0.617230566355229, 0.282583560369936, 0.251706165020014, 0.2962014901575},
0.5));
// Normal (5, 2.5) data generated in R with
// > rnorm(10, 5, 2.5)
samples.Add(new Sample("normal(5, 2.5)",
new double[] { 3.1476833, 9.2061900, 2.6079399, 4.4361054, 6.4133568, 4.3745899, 3.5588195, 3.0542840, 0.6643241,4.3697818},
5));
// Beta (0.5, 0.5) data generated in R with
// > rbeta(10, 0.5, 0.5)
samples.Add(new Sample("beta(0.5, 0.5)",
new double[] { 0.754152463, 0.008992998, 0.221637853, 0.426146895, 0.656421042, 0.224818243, 0.022050868, 0.539143737 ,
0.877643550 ,0.128030530 },
0.5));
Console.WriteLine();
foreach (Sample sample in samples)
{
vectord vec = sample.Data;
// Note: vectord does not provided a ToArray method as standard. The ToArray method used
// here is an extension implemented in the VectordExtensionMethods class (see below)
Console.WriteLine("Sample '{0}' = [{1}]", sample.SampleName, string.Join(", ", vec.ToArray()));
// The sorted sample vector is needed for the Shapiro-Wilk W test
// it also makes finsing the sample median fast
vectord vecSorted = sample.SortedData;
// Auxiliary helper functions:
Console.WriteLine("\tSum = {0:#.#####}", ms_quant_stats.sum(vec));
Console.WriteLine("\tSum of squares = {0:#.#####}", ms_quant_stats.sumsq(vec));
// Note: vectord does not provided a ToArray method as standard. The ToArray method used
// here is an extension implemented in the VectordExtensionMethods class (see below)
Console.WriteLine("\tLog transformed = [{0}]", string.Join(", ", ms_quant_stats.logTransform(vec).ToArray()));
Console.WriteLine("\tExp transformed = [{0}]", string.Join(", ", ms_quant_stats.expTransform(vec).ToArray()));
// Basic sample statistics
double xbar = ms_quant_stats.arithmeticMean(vec);
double stdev = ms_quant_stats.arithmeticStandardDeviation(vec, xbar);
double median = ms_quant_stats.sortedMedian(vecSorted);
// If the vector isn't sorted:
// double median = ms_quant_stats.unsortedMedian(vec);
double geombar = ms_quant_stats.geometricMean(vec);
double geomdev = ms_quant_stats.geometricStandardDeviation(vec, xbar);
Console.WriteLine("\tArithmetic stdev = {0}", stdev);
Console.WriteLine("\tArithmetic mean = {0}", xbar);
Console.WriteLine("\tStandard error of mean = {0}", ms_quant_stats.arithmeticStandardErrorOfMean(stdev, (uint)vec.Count));
Console.WriteLine("\tMedian = {0}", median);
Console.WriteLine("\tStandard error of median = {0}", ms_quant_stats.arithmeticStandardErrorOfMedian(stdev, (uint)vec.Count));
Console.WriteLine("\tGeometric mean = {0}", geombar);
Console.WriteLine("\tGeometric stdev = {0}", geomdev);
// Basic distribution tests for normally distributed data:
Console.WriteLine("\tHypothesis: distribution is N({0}, sigma^2) (mean test). p-value = {1:0.#####}", sample.PopulationMean,
ms_quant_stats.calculateNormalMeanPvalue(sample.PopulationMean, xbar, stdev, (uint)vec.Count));
Console.WriteLine("\tHypothesis: distribution is N({0}, sigma^2) (median test). p-value = {1:0.#####}", sample.PopulationMean,
ms_quant_stats.calculateNormalMedianPvalue(sample.PopulationMean, median, stdev, (uint)vec.Count));
// (We would expect the normal sample to have the highest p-value, i.e.
// least evidence against the hypothesis, while the uniform and beta
// distributions should have fairly low p-values. However, sample size is
// so small that the tests are not very reliable)
{
double W, p;
bool ok = ms_quant_stats.testShapiroWilkW(vecSorted, out W, out p);
Console.WriteLine("\tShapiro-Wilk ok = {0}, W = {1}, p-value = {2}", ok, W != 0 ? W.ToString() : "(none)",
p != 0 ? p.ToString() : "(none)");
}
// outlier detection can be done even when the above tests indicate that the
// sample is not normally distributed - after outlier removal, the sample may
// be normally distributed!
{
uint numL, numH;
ms_quant_stats.detectOutliers(vecSorted, "auto", 0.05, out numL, out numH);
// numL and numH are the number of elements at each end of vecSorted
// which seem to be outliers. That is, elements between 0 and numL-1, and
// vecSorted.Count-numH to vecSorted.Count-1.
Console.WriteLine("\tOutlier detection('auto',0.05) = <{0}, {1}>", numL,
numH);
}
Console.WriteLine();
}
}
}
public static class VectordExtensionMethods
{
// vectord doesn't provide a ToArray method, instead providing a CopyTo method for
// populating an existing double array. This extension class adds a
// ToArray helper method to vectord
public static double[] ToArray(this vectord vector)
{
double[] data = new double[vector.Count];
vector.CopyTo(data);
return data;
}
}
struct Sample
{
private string Name;
private double[] data;
private double PopMean;
public Sample(string name, double[] data, double popmean)
{
this.Name = name;
this.data = data;
this.PopMean = popmean;
}
public string SampleName
{
get
{
return Name;
}
}
public double PopulationMean
{
get
{
return PopMean;
}
}
public vectord Data
{
get
{
return new vectord(data);
}
}
public vectord SortedData
{
get
{
// maintain the underlying data array unsorted
double[] dataCopy = new double[data.Length];
this.Data.CopyTo(dataCopy);
Array.Sort(dataCopy);
return new vectord(dataCopy);
}
}
}
}
/*
tools_stats.exe
Will give the following output
Binomial coefficients for sample size 6:
6 choose 0 = 1
6 choose 1 = 6
6 choose 2 = 15
6 choose 3 = 20
6 choose 4 = 15
6 choose 5 = 6
6 choose 6 = 1
First 10 values of the Poisson (lambda = 1) distribution
Poisson(lambda 1, k 1) = 0.367879441171442
Poisson(lambda 1, k 2) = 0.183939720585721
Poisson(lambda 1, k 3) = 0.0613132401952405
Poisson(lambda 1, k 4) = 0.0153283100488101
Poisson(lambda 1, k 5) = 0.00306566200976203
Poisson(lambda 1, k 6) = 0.00051094366829367
Poisson(lambda 1, k 7) = 7.29919526133814E-05
Poisson(lambda 1, k 8) = 9.12399407667265E-06
Poisson(lambda 1, k 9) = 1.0137771196303E-06
Poisson(lambda 1, k 10) = 1.01377711963029E-07
Common values of the standard normal distribution
Normal-1(0.001) = -3.09
Normal-1(0.01) = -2.318
Normal-1(0.025) = -1.959
Normal-1(0.05) = -1.642
Normal-1(0.1) = -1.282
Normal-1(0.5) = 0
Normal-1(0.9) = 1.282
Normal-1(0.95) = 1.642
Normal-1(0.975) = 1.959
Normal-1(0.99) = 2.318
Normal-1(0.999) = 3.09
Normal(x <= -3.09) = 0.001
Normal(x <= -2.32) = 0.00554
Normal(x <= -1.96) = 0.025
Normal(x <= -1.64) = 0.0505
Normal(x <= -1.28) = 0.10027
Normal(x <= 0) = 0.5
Normal(x <= 1.28) = 0.89973
Normal(x <= 1.64) = 0.9495
Normal(x <= 1.96) = 0.975
Normal(x <= 2.32) = 0.99446
Normal(x <= 3.09) = 0.999
Common values of the chi-squared distribution at 10 degrees of freedom:
chi-sq(df 10, sigLevel 0.001) = <1.479, 29.588>
chi-sq(df 10, sigLevel 0.01) = <2.558, 23.209>
chi-sq(df 10, sigLevel 0.025) = <3.247, 20.483>
chi-sq(df 10, sigLevel 0.05) = <3.94, 18.307>
chi-sq(df 10, sigLevel 0.1) = <4.865, 15.987>
Common values of the Student's t distribution at 10 degrees of freedom:
t(df 10, sigLevel 0.001) = 4.143
t(df 10, sigLevel 0.005) = 3.169
t(df 10, sigLevel 0.01) = 2.764
t(df 10, sigLevel 0.025) = 2.228
t(df 10, sigLevel 0.05) = 1.812
t(df 10, sigLevel 0.1) = 1.372
Common values of the F distribution at 10 and 1 degrees of freedom:
F(df1 10, df2 1, sifLevel 0.01) = 6055.85
F(df1 10, df2 1, sifLevel 0.05) = 241.882
F(df1 10, df2 1, sifLevel 0.1) = 60.195
Sample 'uniform(0,1)' = [0.400313346021907, 0.635154745166318, 0.795328049493161, 0.465079196585926, 0.709667388012424, 0.76161797692474, 0.617230566355229, 0.282583560369936, 0.251706165020014, 0.2962014901575]
Sum = 5.21488
Sum of squares = 3.10813
Log transformed = [-0.915507673489646, -0.4538866166025, -0.229000608568736, -0.765547572658224, -0.342958886300134, -0.272310191628172, -0.482512635488649, -1.26378098321243, -1.37949288361674, -1.21671534624448]
Exp transformed = [1.49229222822126, 1.88731417160841, 2.2151675622189, 1.59214027596837, 2.03331484127, 2.14173870243289, 1.85378698617621, 1.32655261769313, 1.28621804590024, 1.34474108162913]
Arithmetic stdev = 0.207799545425621
Arithmetic mean = 0.521488248410716
Standard error of mean = 0.0657119860292586
Median = 0.541154881470578
Standard error of median = 0.0773298651592315
Geometric mean = 0.480863737139541
Geometric stdev = 1.56255472576704
Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.75114
Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.60747
Shapiro-Wilk ok = True, W = 0.904955259787869, p-value = 0.248103833545881
Outlier detection('auto',0.05) = <0, 0>
Sample 'normal(5, 2.5)' = [3.1476833, 9.20619, 2.6079399, 4.4361054, 6.4133568, 4.3745899, 3.5588195, 3.054284, 0.6643241, 4.3697818]
Sum = 41.83307
Sum of squares = 222.94057
Log transformed = [1.14666672193647, 2.21987608389596, 0.958560599320351, 1.48977682935013, 1.85838281560642, 1.47581277827312, 1.26942888874853, 1.11654519526921, -0.408985146179298, 1.47471307651077]
Exp transformed = [23.2820644952793, 9958.58228914508, 13.5710642846326, 84.4454192814535, 609.93768731081, 79.4072679533238, 35.1217114826069, 21.2059965963608, 1.94317668425472, 79.0263862606734]
Arithmetic stdev = 2.30795630958355
Arithmetic mean = 4.18330747
Standard error of mean = 0.729839867844071
Median = 3.96430065
Standard error of median = 0.858875556478903
Geometric mean = 3.52569572037875
Geometric stdev = 2.04835540793366
Hypothesis: distribution is N(5, sigma^2) (mean test). p-value = 0.29211
Hypothesis: distribution is N(5, sigma^2) (median test). p-value = 0.25861
Shapiro-Wilk ok = True, W = 0.917418368639979, p-value = 0.335925333025062
Outlier detection('auto',0.05) = <0, 0>
Sample 'beta(0.5, 0.5)' = [0.754152463, 0.008992998, 0.221637853, 0.426146895, 0.656421042, 0.224818243, 0.022050868, 0.539143737, 0.87764355, 0.12803053]
Sum = 3.85904
Sum of squares = 2.3588
Log transformed = [-0.28216072584468, -4.71130900444498, -1.50671052190953, -0.852971168207217, -0.420952863607245, -1.49246301212003, -3.8144033127847, -0.617773070154802, -0.130514747277869, -2.05548652787785]
Exp transformed = [2.12580905780365, 1.00903355649617, 1.24811929335097, 1.53134570563969, 1.92788017044885, 1.2520951184563, 1.02229578528984, 1.71453813789789, 2.40522523023951, 1.13658770218992]
Arithmetic stdev = 0.310837187272829
Arithmetic mean = 0.3859038179
Standard error of mean = 0.0982953493262443
Median = 0.325482569
Standard error of median = 0.115673967087124
Geometric mean = 0.204236938593202
Geometric stdev = 5.41293770078999
Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.27561
Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.16565
Shapiro-Wilk ok = True, W = 0.930482521074392, p-value = 0.452655082151213
Outlier detection('auto',0.05) = <0, 0>
*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools_imputation.cs

tools_imputation.cs

Using matrix_science::ms_imputation class.

/*
##############################################################################
# file: tools_imputation.cs #
# 'msparser' imputation example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2024 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/tools_imputation.cs $ #
# $Author: robertog@matrixscience.com $ #
# $Date: 2024-09-04 10:23:46 +0100 $ #
# $Revision: 526921a73137894bb1eae0b0fc8ccb4bb52ea662 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using matrix_science.msparser;
using System.Numerics;
using static matrix_science.msparser.ms_imputation;
namespace MsParserExamples
{
class tools_imputation
{
public static void Main(string[] args)
{
// Read Distiller log output from peptides-table report for Reading6 repliate project
List<string[]> propsCsv = new List<string[]>();
using (var reader = new StreamReader(@"C:/MSData/Quantitation/ReadingReplicate6/tPeptidesHit9Props.csv"))
{
while (!reader.EndOfStream)
{
var line = reader.ReadLine();
var values = line.Split(',');
for (int i = 0; i < values.Length; i++)
{
if (values[i].Length == 1)
{
values[i] = values[i].Substring(1, values[i].Length - 1);
}
else
{
values[i] = values[i].Substring(1, values[i].Length - 2);
}
}
propsCsv.Add(values);
}
}
// Relevant paths from read csv file
string[] datFilePaths = new string[] { propsCsv[7][1], propsCsv[7][2], propsCsv[7][3], propsCsv[7][4], propsCsv[7][5], propsCsv[7][6] };
string mascotDotDatPath = propsCsv[1][3];
string cdbPath = propsCsv[6][3];
string cachePath = propsCsv[6][4];
string xmlPath = propsCsv[6][propsCsv[6].Count() - 2];
string resCachePath = propsCsv[6].Last();
// Hard coded paths to schema locations
string quantSchema = "http://www.matrixscience.com/xmlns/schema/quantitation_2 " + @"file:///C:\\ProgramData\\Matrix%20Science\\Mascot%20Distiller\\schema\\quantitation_2.xsd" + " http://www.matrixscience.com/xmlns/schema/quantitation_1 " + @"file:///C:\ProgramData\Matrix%20Science\Mascot%20Distiller\schema\quantitation_1.xsd";
string unimodSchema = "http://www.unimod.org/xmlns/schema/unimod_2 " + @"file:///C:\ProgramData\Matrix%20Science\Mascot%20Distiller\schema\unimod_2.xsd";
// Create ms_mascotresfilebase
ms_mascotresfilebase resFile = ms_mascotresfilebase.createResfile(datFilePaths[0], 0, "<!-- %d seconds-->\n", (uint)ms_mascotresfilebase.FLAGS.RESFILE_USE_CACHE, resCachePath);
resFile.setXMLschemaFilePath(ms_mascotresfilebase.XML_SCHEMA.XML_SCHEMA_QUANTITATION, quantSchema);
resFile.setXMLschemaFilePath(ms_mascotresfilebase.XML_SCHEMA.XML_SCHEMA_UNIMOD, unimodSchema);
// Add multi dat files
for (int i = 1; i < datFilePaths.Length; i++)
{
resFile.appendResfile(datFilePaths[i]);
}
// Create mascot dot dat file
ms_datfile mascotDotDat = new ms_datfile(mascotDotDatPath);
// Set percolator features
resFile.setPercolatorFeatures(mascotDotDat.getMascotOptions(), "");
// Create ms_peptidesummary
ms_mascotoptions opts = new ms_mascotoptions();
ms_mascotresults_params resParams = new ms_mascotresults_params();
string returnVals = resFile.get_ms_mascotresults_params(opts, resParams);
ms_peptidesummary pepSum = new ms_peptidesummary(resFile, resParams);
// Create qMethod
ms_quant_method qMethod = new ms_quant_method();
ms_quant_configfile qConfigFile = new ms_quant_configfile(xmlPath, quantSchema);
qMethod = qConfigFile.getMethodByNumber(0);
ms_quant_protocol quantProtocol = qMethod.getProtocol();
string typeStr = quantProtocol.getType();
// Create ms_ms1quantitation
ms_ms1quantitation ms1Quant = new ms_ms1quantitation(pepSum, qMethod);
bool loadQuant = ms1Quant.loadCdbFile(cdbPath, cachePath, false);
// Create KNN Imputation
ms_imputation_knn knnImputation = new ms_imputation_knn();
// Set KNN Parameters
knnImputation.setKnnNumNeighbours(5);
knnImputation.setKnnUseWeightedAverage(true);
// Create ms_imputation
ms_imputation ImputationKnn = new ms_imputation(ms1Quant, knnImputation, IMPUTATION_VARIABLE.IMPUTE_PEPTIDE_RATIO);
// Set handling of ms1 excluded values - default is to impute negative values only.
ImputationKnn.setImputeMs1PeptideExcludedByStdErrThr(true);
// Do Knn Imputation and get results
VecVecdouble imputationResKnn = ImputationKnn.impute();
// Get raw data
VecVecMissingValue imputationRaw = knnImputation.getDataWithMissing();
// Print Raw Data
Console.WriteLine("=/=/=/=/= READING6 HIT9 RAW PEPTIDE RATIOS =/=/=/=/=");
Console.WriteLine("=/=/=/=/= STD ERR THRESHOLD SET TO 0.1 =/=/=/=/=");
for (int i = 0; i < imputationRaw.Count; i++)
{
string tempStr = "";
for (int j = 0; j < imputationRaw[i].Count; j++)
{
if (imputationRaw[i][j].isMissing())
{
tempStr += "MissVal,";
}
else
{
tempStr += Math.Round(imputationRaw[i][j].getVal(), 5) + ",";
}
}
Console.WriteLine(tempStr);
}
// Blank rows for formatting
Console.WriteLine("");
Console.WriteLine("");
// Print Imputed Data
Console.WriteLine("=/=/=/=/= KNN IMPUTED PEPTIDE RATIOS =/=/=/=/=");
Console.WriteLine("=/=/= NB: KNN DOES NOT IMPUTE BLANK ROWS =/=/=");
for (int i = 0; i < imputationResKnn.Count; i++)
{
string tempStr = "";
for (int j = 0; j < imputationResKnn[i].Count; j++)
{
tempStr += Math.Round(imputationResKnn[i][j], 5).ToString() + ",";
}
Console.WriteLine(tempStr);
}
// Create Miss Forest Imputation
ms_imputation_missforest missForestImputation = new ms_imputation_missforest();
// Create another ms_imputation for use with miss forest.
ms_imputation ImputationMissForest = new ms_imputation(ms1Quant, missForestImputation, IMPUTATION_VARIABLE.IMPUTE_PEPTIDE_RATIO);
// Set handling of ms1 excluded values - default is to impute negative values only.
ImputationMissForest.setImputeMs1PeptideExcludedByStdErrThr(true);
// Do Miss Forest Imputation and get results
VecVecdouble imputationMissForestRes = ImputationMissForest.impute();
// Blank row for formatting
Console.WriteLine("");
Console.WriteLine("");
// Print Imputed Data
Console.WriteLine("=/=/=/=/= MISS FOREST IMPUTED PROTEIN RATIOS =/=/=/=/=");
Console.WriteLine("=/=/=/= NB: MISS FOREST HAS IMPUTED BLANK ROWS =/=/=/=");
for (int i = 0; i < imputationMissForestRes.Count; i++)
{
string tempStr = "";
for (int j = 0; j < imputationMissForestRes[i].Count; j++)
{
tempStr += Math.Round(imputationMissForestRes[i][j], 5).ToString() + ",";
}
Console.WriteLine(tempStr);
}
}
}
}
//=/=/=/=/= READING6 HIT9 RAW PEPTIDE RATIOS =/=/=/=/=
//=/=/=/=/= STD ERR THRESHOLD SET TO 0.1 =/=/=/=/=
//2.28732,2.93964,2.94553,2.99029,3.23196,
//MissVal,2.54313,2.92111, MissVal,3.11723,
//2.10104,2.22602,2.22403,2.32379,2.19702,
//2.1067,2.03963,2.08156,2.09965,2.13775,
//2.44945,2.20403,2.46889,2.75888, MissVal,
//2.18101,2.14522,2.13038,2.06266,2.04468,
//1.70053,1.73612,1.76628,1.80507,2.05639,
//3.71123,4.95397,7.00681,5.77567, MissVal,
//2.42429,2.4783,2.52357,2.48775, MissVal,
//2.17554,2.60881,2.80434,3.35736,3.27036,
//2.20251,2.17324,2.12744,2.28025,2.27098,
//2.23966,2.13916,2.18431,2.19506,2.05491,
//2.24945,2.21507,2.36328,2.22853,2.26598,
//2.19153,1.73771, MissVal,2.22835,2.75656,
//2.01395,1.85933, MissVal, MissVal, MissVal,
//MissVal, MissVal, MissVal, MissVal, MissVal,
//MissVal, MissVal, MissVal, MissVal,3.86644,
//2.08719,2.13798,2.21096,2.1524,2.23132,
//2.26798,2.24856,1.99524,2.00491,2.04314,
//3.87692, MissVal,5.85286,4.12125,7.61054,
//2.13265,2.19603,2.10388,2.16322,2.16913,
//2.17102,2.24979,2.08552,1.94413,1.98189,
//2.16255,2.30718,2.19743,2.19632,2.00476,
//2.39249,2.87498,3.27444,3.5588,3.40519,
//1.69698,2.03158,1.8336,2.22068,2.26823,
//1.84005, MissVal, MissVal, MissVal, MissVal,
//2.27795,2.36076,2.37257,2.36192,2.28409,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//1.74423,1.91595,1.93315,2.21298,2.20868,
//2.24148,2.31477,2.38172,2.44899,2.28945,
//2.31746,2.01841,2.15034,2.15422,2.01965,
//2.16648,2.2371,2.17527,2.18308,2.2383,
//2.16726,1.94434,2.36001,2.08456,2.64126,
//MissVal, MissVal, MissVal, MissVal, MissVal,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//MissVal,5.24276, MissVal, MissVal,15.93856,
//2.10792,1.90854,1.97447,1.87013,1.89933,
//2.80549,3.43199,3.74465,3.70837,4.70967,
//2.0601,1.94181,2.29396,2.01845, MissVal,
//2.11873,2.22137,1.99319,1.88892,1.98038,
//2.09306,2.25344,1.99198,1.9527,2.00931,
//2.23777,1.89507,1.79208,1.9828,1.90807,
//MissVal,3.25899,3.14027, MissVal,4.78865,
//2.05658,2.13022,1.79034,1.99281,1.88877,
//1.72383,1.55478,1.30086, MissVal,1.10509,
//MissVal,2.54313,2.92111, MissVal,3.11723,
//2.1067,2.03963,2.08156,2.09965,2.13775,
//3.71123,4.95397,7.00681,5.77567, MissVal,
//2.42429,2.4783,2.52357,2.48775, MissVal,
//2.17554,2.60881,2.80434,3.35736,3.27036,
//2.20251,2.17324,2.12744,2.28025,2.27098,
//2.23966,2.13916,2.18431,2.19506,2.05491,
//2.24945,2.21507,2.36328,2.22853,2.26598,
//2.19153,1.73771, MissVal,2.22835,2.75656,
//MissVal, MissVal, MissVal, MissVal, MissVal,
//MissVal, MissVal, MissVal, MissVal,3.86644,
//2.08719,2.13798,2.21096,2.1524,2.23132,
//2.26798,2.24856,1.99524,2.00491,2.04314,
//3.87692, MissVal,5.85286,4.12125,7.61054,
//2.13265,2.19603,2.10388,2.16322,2.16913,
//2.17102,2.24979,2.08552,1.94413,1.98189,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.24148,2.31477,2.38172,2.44899,2.28945,
//2.31746,2.01841,2.15034,2.15422,2.01965,
//2.16648,2.2371,2.17527,2.18308,2.2383,
//2.16726,1.94434,2.36001,2.08456,2.64126,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//MissVal,5.24276, MissVal, MissVal,15.93856,
//2.09306,2.25344,1.99198,1.9527,2.00931,
//2.05658,2.13022,1.79034,1.99281,1.88877,
//1.72383,1.55478,1.30086, MissVal,1.10509,
//2.23935,1.97996,2.43986,1.70304,2.10461,
//2.09355,2.17266,2.10816,2.05042,2.20883,
//MissVal,1.98668,2.15741, MissVal,2.19651,
//MissVal, MissVal, MissVal,2.0442, MissVal,
//MissVal, MissVal, MissVal, MissVal, MissVal,
//2.29044, MissVal,2.34337,2.17659, MissVal,
//MissVal, MissVal, MissVal, MissVal, MissVal,
//2.43357,2.29485,2.09299,2.21304,2.05638,
//MissVal,1.35263, MissVal, MissVal, MissVal,
//2.28732,2.93964,2.94553,2.99029,3.23196,
//MissVal,2.54313,2.92111, MissVal,3.11723,
//2.1067,2.03963,2.08156,2.09965,2.13775,
//3.71123,4.95397,7.00681,5.77567, MissVal,
//2.42429,2.4783,2.52357,2.48775, MissVal,
//2.17554,2.60881,2.80434,3.35736,3.27036,
//2.20251,2.17324,2.12744,2.28025,2.27098,
//2.23966,2.13916,2.18431,2.19506,2.05491,
//2.01395,1.85933, MissVal, MissVal, MissVal,
//MissVal, MissVal, MissVal, MissVal, MissVal,
//MissVal, MissVal, MissVal, MissVal,3.86644,
//2.08719,2.13798,2.21096,2.1524,2.23132,
//2.26798,2.24856,1.99524,2.00491,2.04314,
//3.87692, MissVal,5.85286,4.12125,7.61054,
//2.17102,2.24979,2.08552,1.94413,1.98189,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.24148,2.31477,2.38172,2.44899,2.28945,
//2.31746,2.01841,2.15034,2.15422,2.01965,
//2.16648,2.2371,2.17527,2.18308,2.2383,
//2.16726,1.94434,2.36001,2.08456,2.64126,
//MissVal, MissVal, MissVal, MissVal, MissVal,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//MissVal,5.24276, MissVal, MissVal,15.93856,
//2.09306,2.25344,1.99198,1.9527,2.00931,
//2.05658,2.13022,1.79034,1.99281,1.88877,
//1.72383,1.55478,1.30086, MissVal,1.10509,
//2.23935,1.97996,2.43986,1.70304,2.10461,
//MissVal, MissVal, MissVal,2.0442, MissVal,
//MissVal,1.35263, MissVal, MissVal, MissVal,
//2.23314,2.83237,2.67282,2.38664,2.17458,
//MissVal,2.54313,2.92111, MissVal,3.11723,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//MissVal,5.24276, MissVal, MissVal,15.93856,
//1.8827,1.98454,2.21712,2.36144,2.25082,
//MissVal, MissVal, MissVal, MissVal, MissVal,
//2.15333,2.26575,2.4063,2.0972,2.32841,
//MissVal,2.59228,2.46514,2.58271,2.6772,
//MissVal,2.15095,2.30981,2.37582,2.50603,
//2.34115,2.62947,2.25557,2.41524,2.33103,
//2.11785,1.76479,2.06785, MissVal, MissVal,
//2.54718,2.54348,2.98224,3.00757,3.02623,
//2.282,2.26129,2.07016,2.13402,2.12106,
//2.24495,2.28488,2.37796,2.36089,2.42768,
//2.33991,2.33838, MissVal,2.12408, MissVal,
//2.48604,3.83616,3.65871,4.18903,4.31684,
//MissVal,2.48445,2.30975,2.34887,2.31431,
//MissVal, MissVal,2.59739, MissVal, MissVal,
//MissVal, MissVal, MissVal, MissVal, MissVal,
//MissVal, MissVal, MissVal, MissVal,2.29587,
//MissVal, MissVal, MissVal,2.15193, MissVal,
//MissVal,1.78524, MissVal, MissVal, MissVal,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//MissVal,5.24276, MissVal, MissVal,15.93856,
//1.8827,1.98454,2.21712,2.36144,2.25082,
//2.33991,2.33838, MissVal,2.12408, MissVal,
//2.48604,3.83616,3.65871,4.18903,4.31684,
//MissVal,2.48445,2.30975,2.34887,2.31431,
//2.02515, MissVal,2.2607,2.29982,1.92539,
//MissVal,2.38214, MissVal,2.77502,2.40252,
//5.68077, MissVal,6.65737, MissVal,6.50563,
//2.65984,2.71265,2.86734,2.75978,2.3408,
//MissVal,2.14336,2.84518,2.66687,2.68445,
//2.62913,3.00089,3.38146,3.91478,3.58221,
//MissVal, MissVal, MissVal, MissVal, MissVal,
//MissVal,2.5489, MissVal,2.26972,2.20756,
//MissVal,2.31406,2.34074, MissVal,2.57514,
//=/=/=/=/= KNN IMPUTED PEPTIDE RATIOS =/=/=/=/=
//=/=/= NB: KNN DOES NOT IMPUTE BLANK ROWS =/=/=
//2.28732,2.93964,2.94553,2.99029,3.23196,
//2.27222,2.54313,2.92111,3.21399,3.11723,
//2.10104,2.22602,2.22403,2.32379,2.19702,
//2.1067,2.03963,2.08156,2.09965,2.13775,
//2.44945,2.20403,2.46889,2.75888,2.31603,
//2.18101,2.14522,2.13038,2.06266,2.04468,
//1.70053,1.73612,1.76628,1.80507,2.05639,
//3.71123,4.95397,7.00681,5.77567,4.06615,
//2.42429,2.4783,2.52357,2.48775,2.2967,
//2.17554,2.60881,2.80434,3.35736,3.27036,
//2.20251,2.17324,2.12744,2.28025,2.27098,
//2.23966,2.13916,2.18431,2.19506,2.05491,
//2.24945,2.21507,2.36328,2.22853,2.26598,
//2.19153,1.73771,2.31709,2.22835,2.75656,
//2.01395,1.85933,2.14959,2.24674,2.05334,
//0,0,0,0,0,
//2.43385,3.2314,3.35553,3.8418,3.86644,
//2.08719,2.13798,2.21096,2.1524,2.23132,
//2.26798,2.24856,1.99524,2.00491,2.04314,
//3.87692,3.39604,5.85286,4.12125,7.61054,
//2.13265,2.19603,2.10388,2.16322,2.16913,
//2.17102,2.24979,2.08552,1.94413,1.98189,
//2.16255,2.30718,2.19743,2.19632,2.00476,
//2.39249,2.87498,3.27444,3.5588,3.40519,
//1.69698,2.03158,1.8336,2.22068,2.26823,
//1.84005,1.93055,1.99345,2.19232,2.20699,
//2.27795,2.36076,2.37257,2.36192,2.28409,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//1.74423,1.91595,1.93315,2.21298,2.20868,
//2.24148,2.31477,2.38172,2.44899,2.28945,
//2.31746,2.01841,2.15034,2.15422,2.01965,
//2.16648,2.2371,2.17527,2.18308,2.2383,
//2.16726,1.94434,2.36001,2.08456,2.64126,
//0,0,0,0,0,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//2.55984,5.24276,3.54359,3.912,15.93856,
//2.10792,1.90854,1.97447,1.87013,1.89933,
//2.80549,3.43199,3.74465,3.70837,4.70967,
//2.0601,1.94181,2.29396,2.01845,2.43985,
//2.11873,2.22137,1.99319,1.88892,1.98038,
//2.09306,2.25344,1.99198,1.9527,2.00931,
//2.23777,1.89507,1.79208,1.9828,1.90807,
//2.55984,3.25899,3.14027,3.912,4.78865,
//2.05658,2.13022,1.79034,1.99281,1.88877,
//1.72383,1.55478,1.30086,1.95326,1.10509,
//2.27222,2.54313,2.92111,3.21399,3.11723,
//2.1067,2.03963,2.08156,2.09965,2.13775,
//3.71123,4.95397,7.00681,5.77567,4.06615,
//2.42429,2.4783,2.52357,2.48775,2.2967,
//2.17554,2.60881,2.80434,3.35736,3.27036,
//2.20251,2.17324,2.12744,2.28025,2.27098,
//2.23966,2.13916,2.18431,2.19506,2.05491,
//2.24945,2.21507,2.36328,2.22853,2.26598,
//2.19153,1.73771,2.31709,2.22835,2.75656,
//0,0,0,0,0,
//2.43385,3.2314,3.35553,3.8418,3.86644,
//2.08719,2.13798,2.21096,2.1524,2.23132,
//2.26798,2.24856,1.99524,2.00491,2.04314,
//3.87692,3.39604,5.85286,4.12125,7.61054,
//2.13265,2.19603,2.10388,2.16322,2.16913,
//2.17102,2.24979,2.08552,1.94413,1.98189,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.24148,2.31477,2.38172,2.44899,2.28945,
//2.31746,2.01841,2.15034,2.15422,2.01965,
//2.16648,2.2371,2.17527,2.18308,2.2383,
//2.16726,1.94434,2.36001,2.08456,2.64126,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//2.55984,5.24276,3.54359,3.912,15.93856,
//2.09306,2.25344,1.99198,1.9527,2.00931,
//2.05658,2.13022,1.79034,1.99281,1.88877,
//1.72383,1.55478,1.30086,1.95326,1.10509,
//2.23935,1.97996,2.43986,1.70304,2.10461,
//2.09355,2.17266,2.10816,2.05042,2.20883,
//2.0171,1.98668,2.15741,2.20436,2.19651,
//2.2157,2.21271,2.04485,2.0442,2.07658,
//0,0,0,0,0,
//2.29044,2.05263,2.34337,2.17659,2.49115,
//0,0,0,0,0,
//2.43357,2.29485,2.09299,2.21304,2.05638,
//1.9693,1.35263,1.92311,2.02354,2.02516,
//2.28732,2.93964,2.94553,2.99029,3.23196,
//2.27222,2.54313,2.92111,3.21399,3.11723,
//2.1067,2.03963,2.08156,2.09965,2.13775,
//3.71123,4.95397,7.00681,5.77567,4.06615,
//2.42429,2.4783,2.52357,2.48775,2.2967,
//2.17554,2.60881,2.80434,3.35736,3.27036,
//2.20251,2.17324,2.12744,2.28025,2.27098,
//2.23966,2.13916,2.18431,2.19506,2.05491,
//2.01395,1.85933,2.14959,2.24674,2.05334,
//0,0,0,0,0,
//2.43385,3.2314,3.35553,3.8418,3.86644,
//2.08719,2.13798,2.21096,2.1524,2.23132,
//2.26798,2.24856,1.99524,2.00491,2.04314,
//3.87692,3.39604,5.85286,4.12125,7.61054,
//2.17102,2.24979,2.08552,1.94413,1.98189,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.24148,2.31477,2.38172,2.44899,2.28945,
//2.31746,2.01841,2.15034,2.15422,2.01965,
//2.16648,2.2371,2.17527,2.18308,2.2383,
//2.16726,1.94434,2.36001,2.08456,2.64126,
//0,0,0,0,0,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//2.55984,5.24276,3.54359,3.912,15.93856,
//2.09306,2.25344,1.99198,1.9527,2.00931,
//2.05658,2.13022,1.79034,1.99281,1.88877,
//1.72383,1.55478,1.30086,1.95326,1.10509,
//2.23935,1.97996,2.43986,1.70304,2.10461,
//2.2157,2.21271,2.04485,2.0442,2.07658,
//1.9693,1.35263,1.92311,2.02354,2.02516,
//2.23314,2.83237,2.67282,2.38664,2.17458,
//2.27222,2.54313,2.92111,3.21399,3.11723,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//2.55984,5.24276,3.54359,3.912,15.93856,
//1.8827,1.98454,2.21712,2.36144,2.25082,
//0,0,0,0,0,
//2.15333,2.26575,2.4063,2.0972,2.32841,
//2.26211,2.59228,2.46514,2.58271,2.6772,
//2.24377,2.15095,2.30981,2.37582,2.50603,
//2.34115,2.62947,2.25557,2.41524,2.33103,
//2.11785,1.76479,2.06785,2.17142,2.02254,
//2.54718,2.54348,2.98224,3.00757,3.02623,
//2.282,2.26129,2.07016,2.13402,2.12106,
//2.24495,2.28488,2.37796,2.36089,2.42768,
//2.33991,2.33838,2.02978,2.12408,2.06137,
//2.48604,3.83616,3.65871,4.18903,4.31684,
//2.26871,2.48445,2.30975,2.34887,2.31431,
//2.20814,2.33337,2.59739,2.24946,2.39651,
//0,0,0,0,0,
//2.24098,2.29566,2.32903,2.39783,2.29587,
//2.1793,2.09015,2.18671,2.15193,2.14665,
//1.9693,1.78524,1.92311,2.02354,2.02516,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//2.55984,5.24276,3.54359,3.912,15.93856,
//1.8827,1.98454,2.21712,2.36144,2.25082,
//2.33991,2.33838,2.02978,2.12408,2.06137,
//2.48604,3.83616,3.65871,4.18903,4.31684,
//2.26871,2.48445,2.30975,2.34887,2.31431,
//2.02515,2.1482,2.2607,2.29982,1.92539,
//2.32585,2.38214,2.47809,2.77502,2.40252,
//5.68077,3.39604,6.65737,3.912,6.50563,
//2.65984,2.71265,2.86734,2.75978,2.3408,
//2.30332,2.14336,2.84518,2.66687,2.68445,
//2.62913,3.00089,3.38146,3.91478,3.58221,
//0,0,0,0,0,
//2.30713,2.5489,2.29691,2.26972,2.20756,
//2.22455,2.31406,2.34074,2.36101,2.57514,
//=/=/=/=/= MISS FOREST IMPUTED PROTEIN RATIOS =/=/=/=/=
//=/=/=/= NB: MISS FOREST HAS IMPUTED BLANK ROWS =/=/=/=
//2.28732,2.93964,2.94553,2.99029,3.23196,
//2.45976,2.54313,2.92111,2.99595,3.11723,
//2.10104,2.22602,2.22403,2.32379,2.19702,
//2.1067,2.03963,2.08156,2.09965,2.13775,
//2.44945,2.20403,2.46889,2.75888,2.55546,
//2.18101,2.14522,2.13038,2.06266,2.04468,
//1.70053,1.73612,1.76628,1.80507,2.05639,
//3.71123,4.95397,7.00681,5.77567,15.93856,
//2.42429,2.4783,2.52357,2.48775,2.51525,
//2.17554,2.60881,2.80434,3.35736,3.27036,
//2.20251,2.17324,2.12744,2.28025,2.27098,
//2.23966,2.13916,2.18431,2.19506,2.05491,
//2.24945,2.21507,2.36328,2.22853,2.26598,
//2.19153,1.73771,2.24307,2.22835,2.75656,
//2.01395,1.85933,2.67569,2.66278,2.79527,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.05613,1.78524,2.57342,2.66731,3.86644,
//2.08719,2.13798,2.21096,2.1524,2.23132,
//2.26798,2.24856,1.99524,2.00491,2.04314,
//3.87692,4.12522,5.85286,4.12125,7.61054,
//2.13265,2.19603,2.10388,2.16322,2.16913,
//2.17102,2.24979,2.08552,1.94413,1.98189,
//2.16255,2.30718,2.19743,2.19632,2.00476,
//2.39249,2.87498,3.27444,3.5588,3.40519,
//1.69698,2.03158,1.8336,2.22068,2.26823,
//1.84005,2.00862,2.13687,2.21001,2.16289,
//2.27795,2.36076,2.37257,2.36192,2.28409,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//1.74423,1.91595,1.93315,2.21298,2.20868,
//2.24148,2.31477,2.38172,2.44899,2.28945,
//2.31746,2.01841,2.15034,2.15422,2.01965,
//2.16648,2.2371,2.17527,2.18308,2.2383,
//2.16726,1.94434,2.36001,2.08456,2.64126,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//3.71123,5.24276,7.0068,5.77567,15.93856,
//2.10792,1.90854,1.97447,1.87013,1.89933,
//2.80549,3.43199,3.74465,3.70837,4.70967,
//2.0601,1.94181,2.29396,2.01845,2.39064,
//2.11873,2.22137,1.99319,1.88892,1.98038,
//2.09306,2.25344,1.99198,1.9527,2.00931,
//2.23777,1.89507,1.79208,1.9828,1.90807,
//2.63647,3.25899,3.14027,3.73393,4.78865,
//2.05658,2.13022,1.79034,1.99281,1.88877,
//1.72383,1.55478,1.30086,1.94008,1.10509,
//2.45976,2.54313,2.92111,2.99595,3.11723,
//2.1067,2.03963,2.08156,2.09965,2.13775,
//3.71123,4.95397,7.00681,5.77567,15.93856,
//2.42429,2.4783,2.52357,2.48775,2.51525,
//2.17554,2.60881,2.80434,3.35736,3.27036,
//2.20251,2.17324,2.12744,2.28025,2.27098,
//2.23966,2.13916,2.18431,2.19506,2.05491,
//2.24945,2.21507,2.36328,2.22853,2.26598,
//2.19153,1.73771,2.24307,2.22835,2.75656,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.05613,1.78524,2.57342,2.66731,3.86644,
//2.08719,2.13798,2.21096,2.1524,2.23132,
//2.26798,2.24856,1.99524,2.00491,2.04314,
//3.87692,4.12522,5.85286,4.12125,7.61054,
//2.13265,2.19603,2.10388,2.16322,2.16913,
//2.17102,2.24979,2.08552,1.94413,1.98189,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.24148,2.31477,2.38172,2.44899,2.28945,
//2.31746,2.01841,2.15034,2.15422,2.01965,
//2.16648,2.2371,2.17527,2.18308,2.2383,
//2.16726,1.94434,2.36001,2.08456,2.64126,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//3.71123,5.24276,7.0068,5.77567,15.93856,
//2.09306,2.25344,1.99198,1.9527,2.00931,
//2.05658,2.13022,1.79034,1.99281,1.88877,
//1.72383,1.55478,1.30086,1.94008,1.10509,
//2.23935,1.97996,2.43986,1.70304,2.10461,
//2.09355,2.17266,2.10816,2.05042,2.20883,
//2.05644,1.98668,2.15741,2.16099,2.19651,
//2.10486,2.09901,2.10677,2.0442,2.26507,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.29044,2.38057,2.34337,2.17659,2.38378,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.43357,2.29485,2.09299,2.21304,2.05638,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.28732,2.93964,2.94553,2.99029,3.23196,
//2.45976,2.54313,2.92111,2.99595,3.11723,
//2.1067,2.03963,2.08156,2.09965,2.13775,
//3.71123,4.95397,7.00681,5.77567,15.93856,
//2.42429,2.4783,2.52357,2.48775,2.51525,
//2.17554,2.60881,2.80434,3.35736,3.27036,
//2.20251,2.17324,2.12744,2.28025,2.27098,
//2.23966,2.13916,2.18431,2.19506,2.05491,
//2.01395,1.85933,2.67569,2.66278,2.79527,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.05613,1.78524,2.57342,2.66731,3.86644,
//2.08719,2.13798,2.21096,2.1524,2.23132,
//2.26798,2.24856,1.99524,2.00491,2.04314,
//3.87692,4.12522,5.85286,4.12125,7.61054,
//2.17102,2.24979,2.08552,1.94413,1.98189,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.24148,2.31477,2.38172,2.44899,2.28945,
//2.31746,2.01841,2.15034,2.15422,2.01965,
//2.16648,2.2371,2.17527,2.18308,2.2383,
//2.16726,1.94434,2.36001,2.08456,2.64126,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//3.71123,5.24276,7.0068,5.77567,15.93856,
//2.09306,2.25344,1.99198,1.9527,2.00931,
//2.05658,2.13022,1.79034,1.99281,1.88877,
//1.72383,1.55478,1.30086,1.94008,1.10509,
//2.23935,1.97996,2.43986,1.70304,2.10461,
//2.10486,2.09901,2.10677,2.0442,2.26507,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.23314,2.83237,2.67282,2.38664,2.17458,
//2.45976,2.54313,2.92111,2.99595,3.11723,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//3.71123,5.24276,7.0068,5.77567,15.93856,
//1.8827,1.98454,2.21712,2.36144,2.25082,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.15333,2.26575,2.4063,2.0972,2.32841,
//2.41851,2.59228,2.46514,2.58271,2.6772,
//2.0839,2.15095,2.30981,2.37582,2.50603,
//2.34115,2.62947,2.25557,2.41524,2.33103,
//2.11785,1.76479,2.06785,2.11764,2.251,
//2.54718,2.54348,2.98224,3.00757,3.02623,
//2.282,2.26129,2.07016,2.13402,2.12106,
//2.24495,2.28488,2.37796,2.36089,2.42768,
//2.33991,2.33838,2.19425,2.12408,2.20371,
//2.48604,3.83616,3.65871,4.18903,4.31684,
//2.28809,2.48445,2.30975,2.34887,2.31431,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.24975,2.27782,2.359,2.34066,2.29587,
//2.10896,2.19319,2.13714,2.15193,2.20934,
//2.05613,1.78524,2.57342,2.66785,3.86644,
//2.03489,2.1482,2.17228,2.17117,2.01231,
//2.05607,1.93286,2.14959,2.24674,2.05334,
//3.71123,5.24276,7.0068,5.77567,15.93856,
//1.8827,1.98454,2.21712,2.36144,2.25082,
//2.33991,2.33838,2.19425,2.12408,2.20371,
//2.48604,3.83616,3.65871,4.18903,4.31684,
//2.28809,2.48445,2.30975,2.34887,2.31431,
//2.02515,2.08341,2.2607,2.29982,1.92539,
//2.40972,2.38214,2.65437,2.77502,2.40252,
//5.68077,4.12522,6.65737,4.63412,6.50563,
//2.65984,2.71265,2.86734,2.75978,2.3408,
//2.31955,2.14336,2.84518,2.66687,2.68445,
//2.62913,3.00089,3.38146,3.91478,3.58221,
//2.09166,1.35263,2.59739,3.22764,3.80954,
//2.27101,2.5489,2.38081,2.26972,2.20756,
//2.27264,2.31406,2.34074,2.3131,2.57514,
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: common_error.cpp

common_error.cpp

Generic error handling example.

/*
##############################################################################
# file: common_error.cpp #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_cxx/common_error.cpp $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
// All the classes are part of the matrix_science namespace
using namespace matrix_science;
/*****************************************************************************/
/* Local functions */
/* Any configuration file class can be cast to ms_errorsorigin */
/*****************************************************************************/
static void checkErrorHandler(ms_errors *obj);
/*****************************************************************************/
/* main */
/* Call this program with a single argument - the name of the .dat file */
/*****************************************************************************/
int main(int argc, char * argv[])
{
ms_datfile file;
if (argc == 2)
{
file.setFileName(argv[1]);
}
else
{
file.setFileName("wrong_name.txt");
}
file.read_file();
if (!file.isValid())
{
checkErrorHandler(&file);
}
else
{
std::cout << "The file has been read and parsed successfully. Congratulations!"
<< std::endl;
}
return 0;
}
/*****************************************************************************/
/* checkErrorHandler */
/* Outputs detailed information about all collected errors */
/*****************************************************************************/
static void checkErrorHandler(ms_errors *obj)
{
std::cout << "Last error description " << std::endl;
std::cout << "=========================================" << std::endl;
std::cout << "Error: " << obj->getLastErrorString() << std::endl;
std::cout << "=========================================" << std::endl;
std::cout << "Testing the error handling... " << std::endl;
std::cout << "=========================================" << std::endl;
const ms_errs *err = obj->getErrorHandler();
for (int i=1; i <= err->getNumberOfErrors(); i++)
{
std::cout << "Error number: "
<< err->getErrorNumber(i)
<< " ("
// one time happened and repeated after that zero or more times
<< (err->getErrorRepeats(i)+1)
<< " times) : "
<< err->getErrorString(i)
<< std::endl;
}
std::cout << std::endl;
obj->clearAllErrors();
}
/*
will give the output:
# common_error.cpp
Last error description
=========================================
Error: Cannot find file 'mascot.dat'. It contains the most important configuration parameters
=========================================
Testing the error handling...
=========================================
Error number: 1537 (1 times) : [F] Cannot find file 'mascot.dat'. It contains the most important configuration parameters
*/
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_datfile::read_file
void read_file()
Call this method in order to read the configuration information from the file.
Definition: ms_datfile.cpp:1857
matrix_science::ms_datfile::setFileName
void setFileName(const char *name)
Set the file name explicitly, before saving or loading.
Definition: ms_datfile.cpp:1670
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::getErrorHandler
const ms_errs * getErrorHandler() const
Retrive the error object using this function to get access to all errors and error parameters.
Definition: ms_errors.cpp:1518
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_errors::clearAllErrors
void clearAllErrors()
Remove all errors from the current list of errors.
Definition: ms_errors.cpp:1457
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_errs::getErrorRepeats
int getErrorRepeats(const int num=-1) const
Returns a number of times the specified error has been repeated.
Definition: ms_errors.cpp:1171
matrix_science::ms_errs::getErrorNumber
int getErrorNumber(const int num=-1) const
Return a specific error number or ERR_NO_ERROR.
Definition: ms_errors.cpp:1044
matrix_science::ms_errs::getErrorString
std::string getErrorString(const int num) const
Returns a specific error as a string.
Definition: ms_errors.cpp:1094
matrix_science::ms_errs::getNumberOfErrors
int getNumberOfErrors() const
Return the number of errors since the last call to clearAllErrors().
Definition: ms_errors.cpp:1004
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: common_error.pl

common_error.pl

Generic error handling example.

#!/usr/local/bin/perl
##############################################################################
# file: common_error.pl #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/common_error.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use msparser;
my $file = new msparser::ms_datfile;
$file->setFileName(defined($ARGV[0]) ? $ARGV[0] : 'wrong_name.txt');
$file->read_file();
if ($file->isValid) {
print "The file has been read and parsed successfully. Congratulations!\n";
} else {
checkErrorHandler($file);
}
sub checkErrorHandler {
my ($obj) = @_;
print "Last error description \n";
print "=========================================\n";
print "Error: ", $obj->getLastErrorString(), "\n";
print "=========================================\n";
print "Testing the error handling... \n";
print "=========================================\n";
my $err = $obj->getErrorHandler();
my $i;
for my $i (1 .. $err->getNumberOfErrors) {
print "Error number: ";
print $err->getErrorNumber($i);
print " (";
print $err->getErrorRepeats($i) + 1;
print " times) : ";
print $err->getErrorString($i), "\n";
}
print "\n";
$obj->clearAllErrors();
}
=pod
Running the program with no arguments, for example with
perl -I../bin common_error.pl
will give the output:
Last error description
=========================================
Error: Cannot find Mascot configuration file 'wrong_name.txt'.
=========================================
Testing the error handling...
=========================================
Error number: 1537 (1 times) : Cannot find Mascot configuration file 'wrong_name.txt'.
=cut
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: common_error.py

common_error.py

Generic error handling example.

1#!/usr/bin/python
2
16
17import msparser
18import sys
19
20def main() :
21 file = msparser.ms_datfile()
22
23 if len(sys.argv) > 1 :
24 file.setFileName(sys.argv[1])
25 else :
26 file.setFileName("wrong_name.txt")
27
28 file.read_file()
29
30 if file.isValid() :
31 print("The file has been read and parsed successfully. Congratulations!")
32 else :
33 checkErrorHandler(file)
34
35
36def checkErrorHandler(obj) :
37 print("Last error description ")
38 print("=========================================")
39 print("Error: %s" % obj.getLastErrorString())
40 print("=========================================")
41 print("Testing the error handling... ")
42 print("=========================================")
43
44 err = obj.getErrorHandler()
45 for i in range(1 + err.getNumberOfErrors()) :
46 print("Error number: %d (%d times): %s" % (
47 err.getErrorNumber(i),
48 err.getErrorRepeats(i) + 1,
49 err.getErrorString(i)
50 ))
51
52 obj.clearAllErrors()
53
54
55if __name__ == "__main__":
56 sys.exit(main())
57
58
59""" Running the program with no arguments, for example with
60
61python common_error.py
62
63will give the output:
64
65
66Last error description
67=========================================
68Error: Cannot find Mascot configuration file 'wrong_name.txt'.
69=========================================
70Testing the error handling...
71=========================================
72Error number: 0 (1 times):
73Error number: 1537 (1 times): Cannot find Mascot configuration file 'wrong_name.txt'.
74
75
76"""
77
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: common_error.cs

common_error.cs

Generic error handling example.

/*
##############################################################################
# file: common_error.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/common_error.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using matrix_science.msparser;
namespace MsParserExamples
{
class common_error
{
static void Main(string[] argv)
{
ms_datfile file = new ms_datfile();
file.setFileName((argv.Length > 0 && argv[0].Length > 0) ? argv[0] : "wrong_name.txt");
file.read_file();
if (file.isValid())
{
Console.WriteLine("The file has been read and parsed successfully. Congratulations!");
}
else
{
checkErrorHandler(file);
}
}
private static void checkErrorHandler(ms_datfile file)
{
Console.WriteLine("Last error description ");
Console.WriteLine("=========================================");
Console.WriteLine("Error: {0}", file.getLastErrorString());
Console.WriteLine("=========================================");
Console.WriteLine("Testing the error handling... ");
Console.WriteLine("=========================================");
ms_errs err = file.getErrorHandler();
for (int i = 1; i <= err.getNumberOfErrors(); i++)
{
Console.WriteLine("Error number: {0} ({1} times) : {2}", err.getErrorNumber(i), err.getErrorRepeats(i) + 1, err.getErrorString(i));
}
Console.WriteLine();
file.clearAllErrors();
}
}
}
/*
common_error.exe
Will give the following output:
Last error description
=========================================
Error: Cannot find Mascot configuration file 'wrong_name.txt'.
=========================================
Testing the error handling...
=========================================
Error number: 1537 (1 times) : Cannot find Mascot configuration file 'wrong_name.txt'.
*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: security_session.pl

security_session.pl

Checking the 'current' session using the security module.

#!/usr/local/bin/perl
##############################################################################
# file: security_session.pl #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/security_session.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
use lib "../bin";
use CGI qw(:standard);
use msparser;
my $thisScript = new CGI;
print $thisScript->header;
print <<STARTHTML;
<html>
<head>
<title>Security session</title>
</head>
<body>
<h1>Security session</h1>
<p>
This utility shows session information for when Mascot Security is enabled.
</p>
<p>
You may be asked to give this information to a support engineer if you have
security problems.
</p>
STARTHTML
my $session;
#$session = new msparser::ms_session("admin", "admin");
if (defined($thisScript->param('sessionID'))) {
print "<p>Using passed sessionID: ", $thisScript->param('sessionID'), "</p>\n";
$session = new msparser::ms_session($thisScript->param('sessionID'));
} else {
$session = new msparser::ms_session;
}
if ($session->isValid) {
if (!$session->isSecurityEnabled) {
print "<p><strong>Mascot Security is not enabled</strong></p>\n";
print "<p>To enable Mascot security, please run 'enable_security' in the <code>mascot/bin</code> directory.</p>\n";
} else {
if (defined($thisScript->cookie(-name=>'MASCOT_SESSION'))) {
print "<p>Retrieved cookie value is: <code>";
print $thisScript->cookie(-name=>'MASCOT_SESSION');
print "</code></p>\n";
}
my ($sec, $min, $hour, $mday, $mon, $year, $wday, $yday, $isdst)
= gmtime ($session->getLastAccessed);
$year += 1900;
my $month = (qw(Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec))[$mon];
my $lastAccessed = join(' ', $mday, $month, $year, $hour.":".$min.":".$sec);
print '<table border="1" cellpadding="3" cellspacing="1">', "\n";
my $fmt = "<tr><td>%s</td><td>%s</td></tr>\n";
printf $fmt, 'ID', $session->getID;
printf $fmt, 'Security enabled?', $session->isSecurityEnabled;
printf $fmt, 'Last accessed', $lastAccessed;
printf $fmt, 'IP address', $session->getIPAddress;
printf $fmt, 'User', $session->getUserName;
printf $fmt, 'User ID', $session->getUserID;
printf $fmt, 'Full username', $session->getFullUserName;
printf $fmt, 'Email address', $session->getEmailAddress;
printf $fmt, 'Valid?', $session->isValid;
if (defined($ENV{'REMOTE_USER'})) {
printf $fmt, 'Web auth user', $ENV{'REMOTE_USER'};
}
print "</table>\n";
showTasks($session);
}
} else {
print "<p>Session is <strong>invalid</strong>.</p>\n";
displayWarningsAndErrors($session);
}
print <<ENDHTML;
</body>
</html>
ENDHTML
sub showTasks {
my ($session) = @_;
my @param_desc = (
"None",
"Integer =",
"Integer &lt;=",
"Integer &gt;=",
"Integer: one of",
"Float =",
"Float &lt;=",
"Float &gt;=",
"Float: one of",
"String = ",
"String: one of",
"User list"
);
my $tasks = $session->getPermittedTasks;
if ($tasks->getNumberOfTasks == 0) {
print "<h2>Permitted tasks</h2>\n<p><em>None</em</p>\n";
} else {
print <<TABLESTART;
<h2>Permitted tasks</h2>
<table border="1" cellspacing="0" cellpadding="3">
<tr><th>Task</th><th nowrap>Param type</th><th>Parameter</th></tr>
TABLESTART
for my $taskno (0 .. $tasks->getNumberOfTasks - 1) {
my $task = $tasks->getTask($taskno);
my $tt = $task->getType;
print <<ROW;
<tr>
<td>$task->getDescription()</td>
<td nowrap>$param_desc[$tt]</td>
<td nowrap>$task->getAllParamsAsString()</td>
</tr>
ROW
}
print "</table>\n";
}
}
sub displayWarningsAndErrors {
my ($obj) = @_;
return if $obj->isValid;
print <<STARTERRORS;
<p>There were one or more errors:</p>
<ul>
STARTERRORS
my $err = $obj->getErrorHandler;
my $numErrs = $err->getNumberOfErrors;
for my $i (1 .. $numErrs) {
print "<li>", $err->getErrorString($i), "</li>\n";
}
print "</ul>\n";
$obj->clearAllErrors;
}
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: security_session.java

security_session.java

Checking the 'current' session using the security module.

/*
##############################################################################
# file: security_session.java #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
*/
/*
This file needs to be compiled and put into the mascot/cgi directory.
The file 'java_helper.pl' also needs to be copied to the mascot/cgi
directory. Run from a browser: http://localhost/mascot/cgi/java_helper.pl
*/
import matrix_science.msparser.*;
import java.util.HashMap;
public class security_session {
// 1st of all, load the .dll
static {
try {
System.loadLibrary("msparserj");
} catch (UnsatisfiedLinkError e) {
System.err.println("Native code library failed to load. See the chapter on Dynamic Linking Problems in the SWIG Java documentation for help.\n" + e);
e.printStackTrace();
System.exit(1);
}
}
public static void main(String[] args) {
// copy the parameters into a HashMap
HashMap parameters = new HashMap();
for(int i = 0; i < args.length; i += 2) {
args[i+1] = args[i+1].replaceAll("-pipe-","\\|");
args[i+1] = args[i+1].replaceAll("SYSTEM","\\(system\\)");
parameters.put(args[i],args[i+1]);
}
ms_session session;
System.out.println("<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\">");
System.out.println("<HTML>");
System.out.println("<HEAD>");
System.out.println("<TITLE>Check Session</TITLE>");
System.out.println("</head>\n");
System.out.println("<body>\n");
System.out.println("<p>This utility shows session information for when Mascot Security is enabled.<br>");
System.out.println("You may be asked to give this information to a support engineer if you have security problems</p>");
if(parameters.containsKey("COOKIE_MASCOT_SESSION")) System.out.println("Retrieved cookie value is: "+parameters.get("COOKIE_MASCOT_SESSION")+
"<br>");
if(parameters.containsKey("sessionID")) {
System.out.println("Using passed sessionID: "+parameters.get("sessionID")+"<br>");
session = new ms_session((String) parameters.get("sessionID"));
} else {
session = new ms_session();
}
if(session.isValid()) {
System.out.println("<table border=\"1\">");
System.out.print(" <tr><td>ID</td><td>"+session.getID()+"</td></tr>\n");
System.out.print(" <tr><td>security enabled</td><td>"+session.isSecurityEnabled()+"</td></tr>\n");
System.out.print(" <tr><td>last accessed</td><td>"+session.getLastAccessed()+"</td></tr>\n");
System.out.print(" <tr><td>ip address</td><td>"+session.getIPAddress()+"</td></tr>\n");
System.out.print(" <tr><td>user</td><td>"+session.getUserName()+"</td></tr>\n");
System.out.print(" <tr><td>user ID</td><td>"+session.getUserID()+"</td></tr>\n");
System.out.print(" <tr><td>full username</td><td>"+session.getFullUserName()+"</td></tr>\n");
System.out.print(" <tr><td>email address</td><td>"+session.getEmailAddress()+"</td></tr>\n");
System.out.print(" <tr><td>valid</td><td>"+session.isValid()+"</td></tr>\n");
if(parameters.containsKey("ENV_ROMOTE_USER")) {
System.out.print(" <tr><td>Web auth user</td><td>"+parameters.get("ENV_REMOTE_USER")+"</td></tr>");
}
System.out.print("</table><br><br>\n");
showTasks(session);
} else {
System.out.print("Session is invalid<br>\n");
displayWarningsAndErrors(session);
}
System.out.println("</body>\n");
System.out.println("</html>\n");
}
private static void showTasks(ms_session session) {
String[] param_desc = {"None","Integer =","Integer &lt;=","Integer &gt;=","Integer: one of",
"Float =", "Float &lt;=", "Float &gt;=", "Float: one of",
"String = ", "String: one of",
"User list"};
ms_security_tasks tasks = session.getPermittedTasks();
System.out.print("<b>Permitted tasks</b>\n");
System.out.print(" <table align=\"left\" border=\"1\" cellspacing=\"0\" cellpadding=\"3\">\n");
System.out.print(" <tr><td>Task</td><td nowrap>Param type</td><td>Parameter</td></tr>\n");
for(int taskNo = 0; taskNo < tasks.getNumberOfTasks(); taskNo++) {
ms_security_task currentTask = tasks.getTask(taskNo);
int currentTT = currentTask.getType();
System.out.print(" <tr>\n");
System.out.print(" <td>"+currentTask.getDescription()+"</td>\n");
System.out.print(" <td nowrap>"+param_desc[currentTT]+"</td>\n");
System.out.print(" <td nowrap>"+currentTask.getAllParamsAsString()+"&nbsp;</td>\n");
System.out.print(" </tr>\n");
}
System.out.print(" </table>\n");
}
private static void displayWarningsAndErrors(ms_session session) {
if(!session.isValid()) {
System.out.print("There were one or more errors:<br>\n");
}
ms_errs err = session.getErrorHandler();
int numErrs = err.getNumberOfErrors();
for(int i = 1; i <= numErrs; i++) {
System.out.print(err.getErrorString(i)+"<br>\n");
}
session.clearAllErrors();
}
}
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: java_helper.pl

java_helper.pl

Used to run security_session.java as a cgi script.

#!/usr/bin/perl
##############################################################################
# file: java_helper.pl #
# 'msparser' toolkit #
# Test harness / example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
#
# Perl helper cgi script to run security_session.java
#
use strict;
use CGI ':standard';
my %param_hash;
my @param_name = param();
my $param_name;
my $param_hash;
my $thisScript = new CGI;
# identify the host OS
my $os = $^O;
my $jarSep = ";";
if ($os !~ /MSWin32/i) {
$jarSep = ":";
}
foreach $param_name (@param_name){
$param_hash{$param_name} =param($param_name);
$param_hash{$param_name} =~s/\|/-pipe-/;
$param_hash{$param_name} =~s/\‍(system\‍)/SYSTEM/;
$param_hash{$param_name} =~tr/\‍(\‍)a-zA-Z0-9\t\@ _:\-\/\.//cd; # remove any potentially dodgy characters
}
my $command = "";
if ($os !~ /MSWin32/i) {
$command = "LD_LIBRARY_PATH=\"\$LD_LIBRARY_PATH:.\"; export LD_LIBRARY_PATH; ";
}
$command .= "java -cp .".$jarSep."msparser.jar security_session ";
foreach $param_name (@param_name) {
$command .= " ".$param_name." ".$param_hash{$param_name};
}
if (defined($thisScript->cookie(-name=>'MASCOT_SESSION'))) {
my $cookieText = $thisScript->cookie(-name=>'MASCOT_SESSION');
$cookieText = "null" if !$cookieText;
$command .= " COOKIE_MASCOT_SESSION ".$cookieText
}
if (defined($ENV{'REMOTE_USER'})) {
$command .= " ENV_ROMOTE_USER ".$ENV{'REMOTE_USER'};
}
system($command);
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: login.pl

login.pl

Logging in using the security module.

#!/usr/local/bin/perl
##############################################################################
# file: login.pl #
# 'msparser' toolkit #
# Mascot general purpose login script #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2004 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Archive:: /www/cgi/login.pl $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
use strict;
##############################################################################
#
# When the script is run, the 'action' (if any) is performed, and then the
# display= is performed.
#
# If display=nothing, onerrdisplay=nothing and referer= is not defined,
# then the output will be of the form:
# error=[error number or 0 for ok]
# errorstring=[error string or empty]
# sessionID=[sessionID or empty]
#
# Postive error numbers are msparser error numbers
# Negative error numbers are login.pl error numbers:
# -1 An error in the parameters
# -2 User is not authorised to perform requested task
# -3 Security is enabled - returned from issecuritydisabled
# -4 If action=webauthentication and webauthentication is not enabled
# -5 If action=guestlogin and the guest account is not enabled
#
# Parameter Default Allowed_values Description
# ------------------------------------------------------------------------------
# action= login Requires username and password
# If sectask is specified and the
# user is not permitted an error
# of -2 will be set and sessionID
# will be empty
# logout Uses sessionID or cookie
# newpassword Requires username, newpw1
# newpw2 and password
# issecuritydisabled Used to determine if
# Mascot security is disabled.
# If it is disabled, it returns
# error=0 and sessionID will be
# a 'disabled' sessionID that
# can be used.blank. If security
# is enabled, then error=-3
# and sessionID is blank.
# webauthentication If web server authentication is
# enabled for the user who is
# submitting this request, then
# then this will return error=0
# and sessionID will be the
# session to use. If it is not
# enabled then error=-4
# guestlogin If the guest account is enabled
# then this will return error=0
# and sessionID will be the
# session to use. If it is not
# enabled then error=-5
# ispermitted Pass sessionID and sectask
# if it fails, the sessionID
# output will be empty. The
# error= output is undefined.
# isfastapermitted Use to determine if the user
# has access to the fasta file
# specified with fasta=
# Also pass sessionID. If it
# fails, the sessionID output
# will be empty. The
# error= output is undefined.
# integralogin Requires username,
# connectionID and integradb.
# Returns a sessionID if it
# succeeds.
# display= login_prompt nothing No display - just text output
# login_prompt Displays prompt for login
# newpw_prompt Displays request for a new
# password.
# logout_prompt Not particularly useful except
# for testing
#
# onerrdisplay= login_prompt as display= If there is an error in the
# action (e.g. invalid password)
# then display this form.
#
# username= any username Performs the actual login.
#
# password= valid password
#
# newpw1= For action=newpassword. User
# newpw2= enters password twice to check
#
# sessionID= valid sessionID Used for logout action, or
# used to logout before logging
# in with action=login
#
# savecookie= 0 or 1 0 or 1 Default is 1 for action=login
# clearcookie= 0 or 1 0 or 1 Default is 1 for action=logout
#
#
# referer= any URL After performing the action go
# to this URL. display= should
# not be set when using this
#
# sectask= any valid integer For login and ispermitted
#
# fasta= name of fasta For example, MSDB. Use with
# action=isfastapermitted
#
# connectionID= integra connection Used with action=integralogin.
# The connection string is the
# integra equivalent of the
# Mascot sessionID
# integradb= integra database Used with action=integralogin.
#
# error= error number For action=nothing or when no
# errorstring= error string action verb supplied. The error
# string will be displayed on the
# login form
#
################################################################################
use lib "../bin";
use CGI;
use msparser 2.000_054;
my ($session,
$thisScript,
$cookie1,
$cookie2,
$sec,
$opts,
$sessionID,
$error,
$errorstring,
$action,
$display,
$onerrdisplay,
$savecookie,
$clearcookie,
$shipper,
);
$thisScript = new CGI;
# pull in common subroutines
require "./common_subs.pl";
$error = 0 unless ($error = $thisScript->param('error'));
$errorstring = "" unless ($errorstring = $thisScript->param('errorstring'));
if (defined($thisScript->param('sessionID'))) {
# sessionID supplied as argument takes priority
# empty string may be useful when debugging
$sessionID = $thisScript->param('sessionID');
} else {
# try to get from cookie
$sessionID = $thisScript->cookie('MASCOT_SESSION');
}
# Set variables according to defaults
if (defined($thisScript->param('action'))) {
$action = $thisScript->param('action');
} else {
$action = 'nothing';
}
# If display is not defined then assume login_prompt
if (defined($thisScript->param('display'))) {
$display = $thisScript->param('display');
} else {
$display = 'login_prompt';
}
if (defined($thisScript->param('savecookie'))) {
$savecookie = $thisScript->param('savecookie');
} else {
if ($action eq 'login' && $display ne 'nothing') {
$savecookie = 1;
} else {
$savecookie = 0;
}
}
if (defined($thisScript->param('clearcookie'))) {
$clearcookie = $thisScript->param('clearcookie');
} else {
if ($action eq 'logout' && $display ne 'nothing') {
$clearcookie = 1;
} else {
$clearcookie = 0;
}
}
if (defined($thisScript->param('onerrdisplay'))) {
$onerrdisplay = $thisScript->param('onerrdisplay');
} else {
$onerrdisplay = 'login_prompt';
}
# Check required parameters
if (($action ne 'nothing')
&& ($action ne 'login')
&& ($action ne 'logout')
&& ($action ne 'newpassword')
&& ($action ne 'issecuritydisabled')
&& ($action ne 'webauthentication')
&& ($action ne 'guestlogin')
&& ($action ne 'ispermitted')
&& ($action ne 'isfastapermitted')
&& ($action ne 'integralogin')) {
$error = -1;
$errorstring = $action . " is not a valid value for the action parameter";
$sessionID="";
}
if (($display ne 'nothing')
&& ($display ne 'login_prompt')
&& ($display ne 'newpw_prompt')
&& ($display ne 'logout_prompt')) {
$error = -1;
$errorstring = $display . " is not a valid value for the display parameter";
$sessionID="";
}
if (($onerrdisplay ne 'nothing')
&& ($onerrdisplay ne 'login_prompt')
&& ($onerrdisplay ne 'newpw_prompt')
&& ($onerrdisplay ne 'logout_prompt')) {
$error = -1;
$errorstring = $onerrdisplay . " is not a valid value for the onerrdisplay parameter";
$sessionID="";
}
if (($action eq 'login')
&& (!defined($thisScript->param('username')) || !defined($thisScript->param('password')))) {
$error = -1;
$errorstring = "action parameter is login, but username and password have not been defined";
$sessionID="";
}
if (($action eq 'integralogin')
&& (!defined($thisScript->param('username')) || !defined($thisScript->param('connectionID')) || !defined($thisScript->param('integradb')))) {
$error = -1;
$errorstring = "action parameter is integralogin, but username, connectionID and integradb have not been defined";
$sessionID="";
}
if ($action eq 'newpassword') {
if (defined($thisScript->param('username'))
&& defined($thisScript->param('newpw1'))
&& defined($thisScript->param('newpw2'))
&& defined($thisScript->param('password'))) {
if ($thisScript->param('newpw1') ne $thisScript->param('newpw2')) {
$error = -1;
$errorstring = "Confirmation password does not match. Please try again.";
$sessionID="";
}
} else {
$error = -1;
$errorstring = "Require username, newpw1, newpw2 and password parameters to change password";
$sessionID="";
}
}
if ($action eq 'ispermitted') {
if (!$sessionID || !$thisScript->param('sectask')) {
$error = -1;
$errorstring = "The ispermitted action requires both sessionID and task identifier";
$sessionID="";
}
}
if ($action eq 'isfastapermitted') {
if (!$sessionID || !$thisScript->param('fasta')) {
$error = -1;
$errorstring = "The isfastapermitted action requires sessionID and fasta file";
$sessionID="";
}
}
# Do any action now. Must not print errors or anything at this stage because
# headers have not been printed.
if (!$error) {
if ($action eq 'login') {
$session = new msparser::ms_session($thisScript->param('username'),
$thisScript->param('password'));
if ($session->isValid) {
$sessionID = $session->getID;
if (defined($thisScript->param('sectask'))) {
unless ($session->isPermitted($thisScript->param('sectask'))) {
$session->destroy;
undef $session;
$error = -2;
$errorstring = 'User is not authorised to perform requested task';
$sessionID="";
}
}
} else {
$error = $session->getLastError;
$errorstring = $session->getLastErrorString;
$sessionID="";
# Special case - if the error is 'new password required' and
# the onerrdisplay is set, need to reset onerrdisplay to
# show the update password form
if (($error == $msparser::ms_errs::ERR_MSP_SECURITY_PASSWORDEXPIRED)
&& ($onerrdisplay ne 'nothing')) {
$onerrdisplay = 'newpw_prompt';
}
}
}
if ($action eq 'logout') {
if ($sessionID) {
$session = new msparser::ms_session($sessionID);
} else {
$session = new msparser::ms_session;
}
if ($session->isValid) {
$session->destroy;
# } else {
# $error = $session->getLastError;
# $errorstring = $session->getLastErrorString;
}
undef $session;
$sessionID="";
}
if ($action eq 'integralogin') {
$session = new msparser::ms_session($thisScript->param('username'),
$thisScript->param('connectionID'),
$thisScript->param('integradb'));
if ($session->isValid) {
$sessionID = $session->getID;
if (defined($thisScript->param('sectask'))) {
unless ($session->isPermitted($thisScript->param('sectask'))) {
$session->destroy;
undef $session;
$error = -2;
$errorstring = 'User is not authorised to perform requested task';
$sessionID="";
}
}
} else {
$error = $session->getLastError;
$errorstring = $session->getLastErrorString;
$sessionID="";
}
}
if ($action eq 'newpassword') {
$sec = new msparser::ms_security;
if (!$sec->updatePassword("", # $session->getID,
$thisScript->param('username'),
$thisScript->param('password'),
$thisScript->param('newpw1'))) {
$error = $sec->getLastError;
$errorstring = $sec->getLastErrorString;
}
}
if ($action eq 'issecuritydisabled') {
$session = new msparser::ms_session;
if ($session->isValid && $session->getUserType == $msparser::ms_user::USER_SECURITY_DISABLED ) {
$sessionID = $session->getID;
$error = 0;
$errorstring = "";
} else {
$error = -3;
$errorstring = "Mascot security is enabled";
$sessionID="";
}
}
if ($action eq 'webauthentication') {
if (defined($ENV{'REMOTE_USER'})) {
my ($sess_name) = $ENV{'REMOTE_USER'} . "_webserverauth";
$session = new msparser::ms_session($sess_name);
if ($session->isValid && $session->getUserType == $msparser::ms_user::USER_WEBAUTH ) {
$sessionID = $session->getID;
} else {
$error = -4;
$errorstring = $ENV{'REMOTE_USER'} . " is not set up to use web server authentication in Mascot";
$sessionID="";
}
} else {
$error = -4;
$errorstring = "Web authentication is not enabled on your web server";
$sessionID="";
}
}
if ($action eq 'guestlogin') {
$session = new msparser::ms_session('guest_guestsession');
if ($session->isValid && $session->getUserID == $msparser::ms_user::USERID_GUEST) {
$sessionID = $session->getID;
} else {
$error = -5;
$errorstring = "Mascot guest account is disabled";
$sessionID="";
}
}
if ($action eq 'ispermitted') {
$session = new msparser::ms_session($sessionID);
if ($session->isValid) {
unless ($session->isPermitted($thisScript->param('sectask'))) {
$sessionID="";
undef $session;
}
} else {
$error = $session->getLastError;
$errorstring = $session->getLastErrorString;
$sessionID = "";
}
}
if ($action eq 'isfastapermitted') {
$session = new msparser::ms_session($sessionID);
if ($session->isValid) {
unless ($session->isFastaPermitted($thisScript->param('fasta'))) {
$sessionID="";
undef $session;
}
} else {
$error = $session->getLastError;
$errorstring = $session->getLastErrorString;
$sessionID = "";
}
}
}
# If from the login or logout button, set/clear cookie.
# Has to be done before outputting any other html, so store up errors.
if ($savecookie && !$error) {
$opts = new msparser::ms_security_options;
if ($opts->getUseSessionCookies) {
$cookie1 = $thisScript->cookie (
-name => 'MASCOT_SESSION',
-value => $session->getID,
-path => '/'); # no expiry
$cookie2 = $thisScript->cookie (
-name => 'MASCOT_USERNAME',
-value => $session->getUserName,
-path => '/'); # no expiry
} else {
$cookie1 = $thisScript->cookie (
-name => 'MASCOT_SESSION',
-value => $session->getID,
-path => '/',
-expires => '+3M'); # 3 months in the future
$cookie2 = $thisScript->cookie (
-name => 'MASCOT_USERNAME',
-value => $session->getUserName,
-path => '/',
-expires => '+3M'); # 3 months in the future
}
# The expires in the next line is for the page, not the cookie
print $thisScript->header(-cookie => [$cookie1,$cookie2], -expires=>'-1d');
} elsif ($clearcookie) {
$cookie1 = $thisScript->cookie (
-name => 'MASCOT_SESSION',
-value => '',
-path => '/',
-expires => '-1d'); # -1d means delete cookie
$cookie2 = $thisScript->cookie (
-name => 'MASCOT_USERNAME',
-value => '',
-path => '/',
-expires => '-1d'); # -1d means delete cookie
# The expires in the next line is for the page, not the cookie
print $thisScript->header(-cookie => [$cookie1,$cookie2], -expires=>'-1d');
} else {
print $thisScript->header(-expires=>'-1d');
}
# Now the display
# Print html 'header' if doing a display
if ((!$error && $display ne 'nothing')
|| ($error && defined($onerrdisplay) && $onerrdisplay ne 'nothing')) {
&printHeader1("Matrix Science - Mascot Login");
&printHeader2("", "Mascot Login", 0);
print "<TABLE BORDER=0 CELLSPACING=0 CELLPADDING=0>\n";
print "<TR><TD COLSPAN=2>\n";
print "<H1>Mascot Login</H1>\n";
if (defined($onerrdisplay) && $error) {
print "<B><FONT COLOR=#FF0000>Error: " . $errorstring . "</FONT></B><p>\n";
if ($onerrdisplay eq 'login_prompt' ) {
&displayLoginForm;
} elsif ($onerrdisplay eq 'newpw_prompt' ) {
&displayNewPasswordForm;
} elsif ($onerrdisplay eq 'logout_prompt') {
&displayLogoutForm;
} else {
print "Error with onerrdisplay parameter<br>\n";
}
} else {
if ($display eq 'login_prompt') {
&displayLoginForm;
} elsif ($display eq 'newpw_prompt') {
&displayNewPasswordForm;
} elsif ($display eq 'logout_prompt') {
&displayLogoutForm;
} else {
print "Error with display parameter<br>\n";
}
}
print "</TD></TR>\n";
print "</TABLE>\n";
&printFooter();
print "</BODY>\n";
print "</HTML>\n";
} elsif (defined($thisScript->param('referer'))) {
&displayReferer();
} else {
# text output
print "error=" . $error . "\n";
print "errorstring=" . $errorstring . "\n";
print "sessionID=" . $sessionID . "\n";
}
sub displayLoginForm {
print "<form ID=\"mascot_login\" NAME=\"mascot_login\" action=\"" . $thisScript->url(-relative=>1) . "\" ENCTYPE=\"multipart/form-data\" METHOD=\"POST\">\n";
print "<table align=\"center\" border=\"0\" cellspacing=\"0\" cellpadding=\"3\">\n";
print "<tr><td>Username:</td><td>\n";
print "<input type=\"text\" ID=\"username\" name=\"username\" value=\""
. $thisScript->cookie('MASCOT_USERNAME')
. "\" maxlength=\"40\">\n";
print "</td></tr>\n";
print "<tr><td>Password:</td><td>\n";
print "<input type=\"password\" name=\"password\" maxlength=\"50\">\n";
print "</td></tr>\n";
print "<tr><td colspan=\"2\" align=\"right\">\n";
print "<input type=\"submit\" name=\"submit\" value=\"Login\">\n";
print "</td></tr>\n";
print "<tr><td colspan=\"2\" align=\"right\">&nbsp;</td></tr>\n";
print "<tr><td>&nbsp;</td><td><A HREF=\"./edit_profile.pl\">Edit profile</A></td></tr>\n";
print "</table>\n";
if (defined($thisScript->param('referer'))) {
print "<input type=\"hidden\" name=\"referer\" value=\"" . $thisScript->param('referer') . "\">\n";
print "<input type=\"hidden\" name=\"display\" value=\"nothing\">\n";
} else {
print "<input type=\"hidden\" name=\"display\" value=\"logout_prompt\">\n";
}
print "<input type=\"hidden\" name=\"savecookie\" value=\"1\">\n";
print "<input type=\"hidden\" name=\"action\" value=\"login\">\n";
print "<input type=\"hidden\" name=\"onerrdisplay\" value=\"login_prompt\">\n";
print "</form>\n";
print "<script type=\"text/javascript\"><!--\n";
if ($thisScript->cookie('MASCOT_USERNAME')) {
print "document.mascot_login.password.focus();\n";
} else {
print "document.mascot_login.username.focus();\n";
}
print "//--></script>\n";
}
sub displayLogoutForm {
print "<form action=\"" . $thisScript->url(-relative=>1) . "\" ENCTYPE=\"multipart/form-data\" METHOD=\"POST\">\n";
if ($sessionID) {
print "<input type=\"hidden\" name=\"sessionID\" value=\"" . $sessionID . "\">\n";
}
print "<input type=\"hidden\" name=\"action\" value=\"logout\">\n";
print "<input type=\"hidden\" name=\"display\" value=\"login_prompt\">\n";
print "Logged in as " . $session->getUserName . "&nbsp;";
print "<input type=\"submit\" name=\"logout\" value=\"Logout\">\n";
print "</form>\n";
}
sub displayNewPasswordForm {
print "<form ID=\"mascot_newpw\" NAME=\"mascot_newpw\" action=\"" . $thisScript->url(-relative=>1) . "\" ENCTYPE=\"multipart/form-data\" METHOD=\"POST\">\n";
print "<table align=\"center\" border=\"0\" cellspacing=\"0\" cellpadding=\"3\">\n";
print "<tr><td>Old password:</td><td>\n";
print "<input type=\"password\" id=\"password\" name=\"password\" maxlength=\"40\">\n";
print "</td></tr>\n";
print "<tr><td>New password:</td><td>\n";
print "<input type=\"password\" name=\"newpw1\" maxlength=\"50\">\n";
print "</td></tr>\n";
print "<tr><td>Confirm new password:</td><td>\n";
print "<input type=\"password\" name=\"newpw2\" maxlength=\"50\">\n";
print "</td></tr>\n";
print "<tr><td colspan=\"2\" align=\"right\">\n";
print "<input type=\"hidden\" name=\"action\" value=\"newpassword\">\n";
print "<input type=\"submit\" name=\"submit\" value=\"Change password\">\n";
print "</td></tr>\n";
print "</table>\n";
if (defined($thisScript->param('referer'))) {
print "<input type=\"hidden\" name=\"referer\" value=\"" . $thisScript->param('referer') . "\">\n";
} else {
print "<input type=\"hidden\" name=\"display\" value=\"login_prompt\">\n";
}
print "<input type=\"hidden\" name=\"onerrdisplay\" value=\"newpw_prompt\">\n";
print "<input type=\"hidden\" name=\"username\" value=\"" . $thisScript->param('username') . "\">\n";
print "</form>\n";
print "<script type=\"text/javascript\"><!--\n";
print "document.mascot_login.username.focus();\n";
print "//--></script>\n";
}
# Cannot just use the cgi redirect function:
# - The redirect() function redirects the browser to a different URL.
# - If you use redirection like this, you should not print out a header as well.
# Which would also mean that you cannot set cookies. So, do it the hard way.
sub displayReferer() {
print "<html>\n";
print "<head>\n";
print "<title>Login</title>\n";
print "</head>\n";
print "<body>\n";
print "Logged in successfuly - please wait<br>\n";
print "<SCRIPT LANGUAGE=\"JavaScript\">\n";
print "<!-- Begin hiding Javascript from old browsers.\n";
print "if(window.navigator.userAgent.indexOf(\"MSIE\") != -1){\n";
print " window.location.replace(\"" . $thisScript->param('referer') . "\");\n";
print "} else if (window.location.replace == null){\n";
print " window.location.assign(\"" . $thisScript->param('referer') . "\");\n";
print "} else {\n";
print " window.location.replace(\"" . $thisScript->param('referer') . "\");\n";
print "}\n";
print "\n";
print "\n";
print "// End hiding Javascript from old browsers. -->\n";
print "</SCRIPT>\n";
print "<NOSCRIPT>\n";
print "<A HREF=\"" . $thisScript->param('referer') . "\">Click here to if you are not redirected automatically</A>",
print "</NOSCRIPT>\n";
print "</body>\n";
print "</html>\n";
}
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: http_client.pl

http_client.pl

Accessing a Mascot Server using http

#!/usr/local/bin/perl
##############################################################################
# File: http_client.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/http_client.pl $
# $Author: villek@matrixscience.com $
# $Date: 2018-07-30 16:23:53 +0100 $
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
use warnings;
##############################################################################
# required Perl packages
use lib "../bin";
use msparser;
use Getopt::Long;
use File::Basename;
my ($url, $cmd, $mgf, $taskID, $accession, $database, $username, $password);
my %allowedCommands = ("search" => 1, "getresults" => 1, "getseq" => 1);
$username = "";
$password = "";
GetOptions('url=s' => \$url,
'cmd=s' => \$cmd,
'mgf=s' => \$mgf,
'taskID=s' => \$taskID,
'accession=s'=> \$accession,
'database=s' => \$database,
'username=s' => \$username,
'password=s' => \$password);
if ((not defined $url or not defined $cmd or not exists($allowedCommands{$cmd}))
or ($cmd eq 'search' and not defined $mgf)
or ($cmd eq 'getresults' and not defined $taskID)
or ($cmd eq 'getseq' and (not defined $accession or not defined $database))
) {
print <<USAGE;
Usage http_client.pl --url=<URL> --cmd=<command> [options]
--url Mascot Server URL of the form
http://your-server/mascot/cgi/
--cmd One of the following
--cmd=search to submit a Mascot search
--cmd=getresults to download the search results file
--cmd=getseq to save protein sequence to XML file
--mgf Path to an MGF peak list file
Required if --cmd=search
--taskID Mascot task ID for the search
Required if --cmd=getresults
--accession Accession string for protein
Required if --cmd=getseq
--database Mascot database name
Required if --cmd=getseq
--username Mascot Server user name
May be required if Mascot Security is enabled
--password Mascot Server password
May be required if Mascot Security is enabled
Note that the Mascot search parameters are hard coded towards the end
of this script, and may need modifying for different peak lists.
USAGE
exit 1;
}
# Common code for all cases
# Create connection settings.
# Any settings for web server authentication or a proxy server should be set here
my $objSettings = new msparser::ms_connection_settings;
$objSettings->setUserAgent("PerlScriptTest/1.0 " . $objSettings->getUserAgent);
# Connect to the server
my $objHttpClient = new msparser::ms_http_client($url, $objSettings);
unless ($objHttpClient->isValid) {
showErrorsAndExit($objHttpClient);
}
# Enable logging, mostly for debugging
$objHttpClient->getErrorHandler->setLoggingFile("log.txt", $msparser::ms_errs::sev_debug3);
# Create a Mascot security session
# If security is disabled, the empty user name and password return the 'all_secdisabledsession' session
my $objSession = new msparser::ms_http_client_session;
my $loginReturnCode = $objHttpClient->userLogin($username, $password, $objSession);
if ($loginReturnCode != $msparser::ms_http_client::L_SUCCESS and $loginReturnCode != $msparser::ms_http_client::L_SECURITYDISABLED) {
die "Failed to login to $url as user $username. return code is $loginReturnCode\n";
} else {
print "Logged in to $url with session: " . $objSession->sessionId() . "\n";
}
if ($cmd eq 'search') {
doSearch();
}
if ($cmd eq 'getresults') {
doGetResults();
}
if ($cmd eq 'getseq') {
doGetSeq();
}
# and finally logout
$objSession->logout();
sub doSearch {
# The input to Mascot is the peak list and search parameters in MIME format
my $httpHeader = "Content-Type: multipart/mixed; boundary=---------FormBoundary4C9ByKKVofH";
my $prologue = "";
while (<DATA>){
$prologue .= $_;
}
my $epilogue = "-----------FormBoundary4C9ByKKVofH--";
# Request a Mascot task id for the search
my $taskID = "";
my $objSearch = new msparser::ms_http_client_search($objSession, $taskID);
unless ($objSearch->isValid) {
showErrorsAndExit($objSearch);
}
# Submit the search
print "Submitting search\n";
my $objProgress = new msparser::ms_http_helper_progress;
if ($objSession->submitSearch($objSearch, $httpHeader, $prologue, $mgf, $epilogue, $objProgress)) {
print "Search submitted. Task ID = " . $objSearch->searchTaskId . "\n";
my ($success, $returnValue);
my $returnCode = $msparser::ms_http_client_search::SS_UNKNOWN;
my $complete = 0;
while (!$complete) {
($success, $returnCode, $returnValue) = $objSearch->getStatus();
if (!$success) {
print "Unable to call getStatus()\n";
exit 1;
}
if ($returnCode == $msparser::ms_http_client_search::SS_UNKNOWN ) {
print "Unknown search id\n"; $complete = 0;
} elsif ($returnCode == $msparser::ms_http_client_search::SS_ASSIGNED) {
print "Search not started\n"; $complete = 0;
} elsif ($returnCode == $msparser::ms_http_client_search::SS_QUEUED ) {
print "Search queued\n"; $complete = 0;
} elsif ($returnCode == $msparser::ms_http_client_search::SS_RUNNING ) {
print "Seach running: $returnValue\% complete\n";
} elsif ($returnCode == $msparser::ms_http_client_search::SS_COMPLETE) {
print "Search complete\n"; $complete = 1;
} elsif ($returnCode == $msparser::ms_http_client_search::SS_ERROR ) {
print "Search error : $returnValue \n"; $complete = 1;
} elsif ($returnCode == $msparser::ms_http_client_search::SS_SEARCH_CONTROL_ERROR) {
print "Search control error: $returnValue\n"; $complete = 1;
}
sleep 1;
}
# Search complete - get the relative path to the result file
my ($ok, $remoteFileName) = $objSearch->getResultsFileName();
unless ($ok) {
print "Unable to get filename for results file";
showErrorsAndExit($objHttpClient);
}
# Display URL for search result report
print "Search result report can be viewed at this URL:\n"
. $objHttpClient->baseUrl
. "master_results_2.pl?file="
. $remoteFileName
. "\n";
} else {
print "Failed to submit search\n";
showErrorsAndExit($objSession);
}
}
sub doGetResults {
my $objSearch = new msparser::ms_http_client_search($objSession, $taskID);
unless ($objSearch->isValid) {
showErrorsAndExit($objSearch);
}
my ($ok, $remoteFileName) = $objSearch->getResultsFileName();
unless ($ok && $remoteFileName) {
print "Unable to get filename for results file";
exit -1;
}
my ($localFileName, undef, undef) = fileparse($remoteFileName);
print "Downloading remote results file ($remoteFileName) to $localFileName\n";
my $objProgress = new msparser::ms_http_helper_progress;
# Download the complete, uncompressed result file
if ($objSearch->downloadResultsFile($localFileName, $objProgress)) {
print "Downloaded remote file to $localFileName \n";
} else {
print "Failed to downloaded remote file to $localFileName \n";
showErrorsAndExit($objSearch);
}
}
sub doGetSeq {
my $accessions = new msparser::VectorString;
my $frames = new msparser::vectori;
$accessions->push($accession);
my $localFileName = "sequence.xml";
if ($objSession->getSequenceFile($database, $accessions, $frames, $localFileName)) {
print "Successfully saved sequence to $localFileName \n";
} else {
print "Failed to get sequence or failed to save it to $localFileName \n";
showErrorsAndExit($objSession);
}
}
sub showErrorsAndExit {
my ($obj) = @_;
print "Error: ", $obj->getLastErrorString(), "\n";
my $err = $obj->getErrorHandler();
my $i;
for my $i (1 .. $err->getNumberOfErrors) {
print "Error number: ";
print $err->getErrorNumber($i);
print " (";
print $err->getErrorRepeats($i) + 1;
print " times) : ";
print $err->getErrorString($i), "\n";
}
print "\n";
exit -1;
}
__END__
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="FORMVER"
1.01
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="SEARCH"
MIS
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="COM"
Perl script test
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="DB"
SwissProt
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="CLE"
Trypsin/P
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="PFA"
1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="QUANTITATION"
None
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="TAXONOMY"
. . . . . . . . . . . . . . . . Homo sapiens (human)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="MODS"
Carbamidomethyl (C)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="IT_MODS"
Oxidation (M)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="TOL"
10
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="TOLU"
ppm
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="PEP_ISOTOPE_ERROR"
1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="ITOL"
0.1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="ITOLU"
Da
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="CHARGE"
2+
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="MASS"
Monoisotopic
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="FORMAT"
Mascot generic
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="INSTRUMENT"
ESI-TRAP
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="REPORT"
AUTO
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="USERNAME"
Mascot Parser Test
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="USEREMAIL"
dcreasy@matrixscience.com
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="FILE"; filename="test.mgf"
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: http_client.cs

http_client.cs

Accessing a Mascot Server using http

/*
##############################################################################
# file: http_client.cs #
# 'msparser' toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_csharp/http_client.cs $ #
# $Author: villek@matrixscience.com $ #
# $Date: 2018-07-30 16:23:53 +0100 $ #
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
# $NoKeywords:: $ #
##############################################################################
*/
using System;
using System.Collections.Generic;
using System.IO;
using System.Threading;
using matrix_science.msparser;
namespace MsParserExamples
{
class http_client
{
public static int Main(string[] argv)
{
Dictionary<string, bool> allowedCommands = new Dictionary<string, bool>
{
{"search", true},
{"getresults", true},
{"getseq", true}
};
Dictionary<string, string> options = GetOptions(argv);
if ((!options.ContainsKey("url") || !options.ContainsKey("cmd") || !allowedCommands.ContainsKey(options["cmd"]))
|| (options["cmd"]=="search" && !options.ContainsKey("mgf"))
|| (options["cmd"]=="getresults" && !options.ContainsKey("taskID"))
|| (options["cmd"]=="getseq" && (!options.ContainsKey("accession") || !options.ContainsKey("database"))))
{
showUsage();
return 1;
}
// Common code for all cases
// Create connection settings
// Any settings for web server authentication or a proxy server should be set here
ms_connection_settings oSettings = new ms_connection_settings();
oSettings.setUserAgent("CSharpTest/1.0 " + oSettings.getUserAgent());
// try to auto detect any proxy settings
oSettings.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
// Connect to the server
ms_http_client oHttpClient = new ms_http_client(options["url"], oSettings);
if (!oHttpClient.isValid())
{
showErrors(oHttpClient.getErrorHandler());
return -1;
}
// Enable logging, mostly for debugging
oHttpClient.getErrorHandler().setLoggingFile("log.txt", ms_errs.msg_sev.sev_debug3);
// Create a Mascot security session
// If security is disabled, the empty user name and password return the
// 'all_secdisabledsession' session
ms_http_client_session oSession = new ms_http_client_session();
ms_http_client.LoginResultCode loginReturnCode = oHttpClient.userLogin((options.ContainsKey("username") ? options["username"] : ""),
(options.ContainsKey("password") ? options["password"] : ""),
oSession);
if (loginReturnCode != ms_http_client.LoginResultCode.L_SUCCESS &&
loginReturnCode != ms_http_client.LoginResultCode.L_SECURITYDISABLED)
{
Console.Error.WriteLine("Failed to login to {0} as user {1}. Return code id {2}",
options["url"], (options.ContainsKey("username") ? options["username"] : ""), (int) loginReturnCode);
return -1;
}
else
{
Console.WriteLine("Logged in to {0} with session: {1}", options["url"], oSession.sessionId());
}
if (options["cmd"] == "search")
{
if (!doSearch(options, oHttpClient, oSession)) return -1;
}
else if (options["cmd"] == "getresults")
{
if (!doGetResults(options, oSession)) return -1;
}
else if (options["cmd"] == "getseq")
{
if(!doGetSeq(options, oSession)) return -1;
}
// and finally logout
oSession.logout();
return 0;
}
private static bool doSearch(Dictionary<string, string> options, ms_http_client oHttpClient, ms_http_client_session oSession)
{
string httpHeader = "Content-Type: multipart/mixed; boundary=---------FormBoundary4C9ByKKVofH";
// You may need to alter the search conditions embedded in this string to match your own
// dataset
string prologue = @"-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""FORMVER""
1.01
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""SEARCH""
MIS
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""COM""
C# test
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""DB""
SwissProt
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""CLE""
Trypsin/P
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""PFA""
1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""QUANTITATION""
None
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""TAXONOMY""
. . . . . . . . . . . . . . . . Homo sapiens (human)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""MODS""
Carbamidomethyl (C)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""IT_MODS""
Oxidation (M)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""TOL""
10
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""TOLU""
ppm
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""PEP_ISOTOPE_ERROR""
1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""ITOL""
0.1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""ITOLU""
Da
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""CHARGE""
2+
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""MASS""
Monoisotopic
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""FORMAT""
Mascot generic
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""INSTRUMENT""
ESI-TRAP
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""REPORT""
AUTO
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""USERNAME""
Mascot Parser Test
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""USEREMAIL""
dcreasy@matrixscience.com
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""FILE""; filename=""test.mgf""";
string epilogue = "-----------FormBoundary4C9ByKKVofH--";
// Request a Mascot task id for the search
string taskID = "";
ms_http_client_search oSearch = new ms_http_client_search(oSession, taskID);
if (!oSearch.isValid())
{
showErrors(oSearch.getErrorHandler());
return false;
}
// Submit the search
Console.WriteLine("Submitting search");
ms_http_helper_progress oProgress = new ms_http_helper_progress();
if (oSession.submitSearch(oSearch, httpHeader, prologue, options["mgf"], epilogue, oProgress))
{
Console.WriteLine("Search submitted. Task ID = {0}", oSearch.searchTaskId());
bool success;
int returnValue;
int returnCode = (int) ms_http_client_search.SearchStatusCode.SS_UNKNOWN;
bool complete = false;
while (!complete)
{
success = oSearch.getStatus(out returnCode, out returnValue);
if (!success)
{
Console.Error.WriteLine("Unable to call getStatus()");
return false;
}
if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_UNKNOWN)
{
Console.WriteLine("Unknown search id");
complete = false;
}
else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_ASSIGNED)
{
Console.WriteLine("Search no started");
complete = false;
}
else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_QUEUED)
{
Console.WriteLine("Search queued");
complete = false;
}
else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_RUNNING)
{
Console.WriteLine("Search running: {0}% complete", returnValue);
complete = false;
}
else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_COMPLETE)
{
Console.WriteLine("Search complete");
complete = true;
}
else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_ERROR)
{
Console.WriteLine("Search error : {0}", returnValue);
complete = true;
}
else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_SEARCH_CONTROL_ERROR)
{
Console.WriteLine("Search control error: {0}", returnValue);
complete = true;
}
// Sleep thread for 1 second
if(!complete) Thread.Sleep(1000);
}
// Search complete - get the relative path to the result file
string remoteFileName;
bool ok = oSearch.getResultsFileName(out remoteFileName);
if (!ok)
{
Console.Error.WriteLine("Unable to get filename for results file");
showErrors(oHttpClient.getErrorHandler());
return false;
}
// Display URL for search result report
Console.WriteLine("Search result report can be viewed at this URL:");
Console.WriteLine("{0}master_results_2.pl?file={1}", oHttpClient.baseUrl(),
remoteFileName);
}
else
{
Console.Error.WriteLine("Failed to submit search");
showErrors(oSession.getErrorHandler());
return false;
}
return true;
}
private static bool doGetResults(Dictionary<string, string> options, ms_http_client_session oSession)
{
ms_http_client_search oSearch = new ms_http_client_search(oSession, options["taskID"]);
if (!oSearch.isValid())
{
showErrors(oSearch.getErrorHandler());
return false;
}
string remoteFileName;
bool ok = oSearch.getResultsFileName(out remoteFileName);
if (!ok || string.IsNullOrWhiteSpace(remoteFileName))
{
Console.Error.WriteLine("Unable to get filename for results file");
return false;
}
string localFileName = Path.GetFileName(remoteFileName);
Console.WriteLine("Downloading remote results file ({0}) to {1}", remoteFileName, localFileName);
ms_http_helper_progress oProgress = new ms_http_helper_progress();
// Download the complete, uncompressed result file
if (oSearch.downloadResultsFile(localFileName, oProgress))
{
Console.WriteLine("Downloaded remote file to {0}", localFileName);
}
else
{
Console.Error.WriteLine("Failed to download remote file to {0}", localFileName);
return false;
}
return true;
}
private static bool doGetSeq(Dictionary<string, string> options, ms_http_client_session oSession)
{
VectorString accessions = new VectorString();
vectori frames = new vectori();
accessions.Add(options["accession"]);
string localFileName = "sequence.xml";
if (oSession.getSequenceFile(options["database"], accessions, frames, localFileName))
{
Console.WriteLine("Successfully saved sequence to {0}", localFileName);
return true;
}
else
{
Console.Error.WriteLine("Failed to get sequence or failed to save it to {0}", localFileName);
showErrors(oSession.getErrorHandler());
return false;
}
}
private static void showErrors(ms_errs ms_errs)
{
Console.Error.WriteLine("Error: {0}", ms_errs.getLastErrorString());
for (int i = 1; i <= ms_errs.getNumberOfErrors(); i++)
{
Console.Error.WriteLine("Error number: {0} ({1} times) : {2}",
ms_errs.getErrorNumber(i),
ms_errs.getErrorRepeats(i) + 1,
ms_errs.getErrorString(i));
}
Console.Error.WriteLine();
}
private static void showUsage()
{
Console.Error.WriteLine(@"Usage {0} --url=<URL> --cmd=<command> [options]
--url Mascot Server URL in the form
http://your-server/mascot/cgi/
--cmd One of the following:
--cmd=search to submit a Mascot search
--cmd=getresults to download the search results file
--cmd=getseq to save protein sequence to XML file
--mgf Path to an MGF peak list file
Required if --cmd=search
--taskID Mascot task ID for the search
Required if --cmd=getresults
--accession Accession string for protein
Required if --cmd=getseq
--database Mascot database name
Required if --cmd=getseq
--username Mascot Server username
Required if Mascot Security is enabled
--password Mascot Server password
May be required if Mascot Security is enabled
Note that the Mascot search parameters are hard coded towards the end of this
class, and may need modifying for different peak lists.", Path.GetFileName((new http_client()).GetType().Assembly.Location));
}
// Parses the passed arguments and returns a Dictionary containing only
// valid commands
private static Dictionary<string, string> GetOptions(string[] argv)
{
Dictionary<string, string> options = new Dictionary<string, string>();
Dictionary<string, bool> allowedCommands = new Dictionary<string, bool>
{
{"url",true},
{"cmd",true},
{"mgf",true},
{"taskID",true},
{"accession",true},
{"database",true},
{"username",true},
{"password",true}
};
foreach (string arg in argv)
{
if(!arg.StartsWith("--")) continue;
string arg2 = ReplaceFirst(arg, "--", "");
string key=null, value=null;
if (arg2.Contains("="))
{
string[] split = arg2.Split('=');
if (split.Length == 2)
{
key = split[0];
value = split[1];
}
else if (split.Length == 1)
{
key = split[0];
value = "";
}
}
else
{
key = arg2;
value = "";
}
if (!string.IsNullOrEmpty(key) && allowedCommands.ContainsKey(key) && allowedCommands[key] && !string.IsNullOrWhiteSpace(value))
{
options.Add(key,value);
}
}
return options;
}
public static string ReplaceFirst(string text, string search, string replace)
{
int pos = text.IndexOf(search);
if (pos < 0)
{
return text;
}
return text.Substring(0, pos) + replace + text.Substring(pos + search.Length);
}
}
}
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: http_client.py

http_client.py

Accessing a Mascot Server using http

1#!/usr/bin/python
2
16
17import msparser
18import sys
19import getopt
20import ntpath
21import time
22
23# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
24def ms_range(start, stop, step=1):
25 i = start
26 while i <= stop:
27 yield i
28 i += step
29
30# Define Global argument variables
31msurl = ''
32mscmd = ''
33msmgf = ''
34mstaskID = ''
35msaccession = ''
36msdatabase = ''
37msusername = ''
38mspassword = ''
39
40# Define help text
41usage = """
42Usage http_client.py --url=<URL> --cmd=<command> [options]
43
44 --help Print this message
45
46 --url Mascot Server URL of the form
47 http://your-server/mascot/cgi/
48 --cmd One of the following
49 --cmd=search to submit a Mascot search
50 --cmd=getresults to download the search results file
51 --cmd=getseq to save protein sequence to XML file
52 --mgf Path to an MGF peak list file
53 Required if --cmd=search
54 --taskID Mascot task ID for the search
55 Required if --cmd=getresults
56 --accession Accession string for protein
57 Required if --cmd=getseq
58 --database Mascot database name
59 Required if --cmd=getseq
60 --username Mascot Server user name
61 May be required if Mascot Security is enabled
62 --password Mascot Server password
63 May be required if Mascot Security is enabled
64"""
65
66# If no arguments supplied, print help and exit
67if len(sys.argv) < 2 :
68 print(usage)
69 sys.exit(1)
70
71# Ensure arguments are legal. if not, exit
72try:
73 opts, args = getopt.getopt(sys.argv[1:],"",["help","url=","cmd=","mgf=","taskID=","accession=","database=","username=","password="])
74except getopt.GetoptError:
75 sys.exit(1)
76
77# If argument is --help, display help then exit
78for opt, arg in opts:
79 if opt == '--help':
80 print(usage)
81 sys.exit(2)
82
83# Read arguments and assign each option to appropriate variables
84 elif opt in ("--url"):
85 msurl = arg
86 elif opt in ("--cmd"):
87 mscmd = arg
88 elif opt in ("--mgf"):
89 msmgf = arg
90 elif opt in ("--taskID"):
91 mstaskID = arg
92 elif opt in ("--accession"):
93 msaccession = arg
94 elif opt in ("--database"):
95 msdatabase = arg
96 elif opt in ("--username"):
97 msusername = arg
98 elif opt in ("--password"):
99 mspassword = arg
100
101# ensure that the correct combinations of arguments are assigned
102if not msurl:
103 print(usage)
104 sys.exit(1)
105elif mscmd == "search":
106 if not msmgf:
107 print(usage)
108 sys.exit(1)
109elif mscmd == "getresults":
110 if not mstaskID:
111 print(usage)
112 sys.exit(1)
113elif mscmd == "getseq":
114 if not msaccession:
115 print(usage)
116 sys.exit(1)
117 elif not msdatabase:
118 print(usage)
119 sys.exit(1)
120
121# Common Code for all cases
122
123# Create connection settings
124# Any settings for web server authentication or a proxy server should be set here
125objSettings = msparser.ms_connection_settings()
126objSettings.setUserAgent("PythonScriptTest/1.0 " + objSettings.getUserAgent())
127# Try to auto detect any proxy settings
128objSettings.setProxyServerType(msparser.ms_connection_settings.PROXY_TYPE_AUTO)
129
130# Connect to the server
131objHttpClient = msparser.ms_http_client(msurl, objSettings)
132if not objHttpClient.isValid():
133 print("Connection to server %s is not valid" % msurl)
134 showErrorsAndExit(objHttpClient)
135
136# Enable Logging, mostly for debugging
137objHttpClient.getErrorHandler().setLoggingFile("log.txt", msparser.ms_errs.sev_debug3)
138
139# Create Mascot Security Session
140# If security is disabled, the empty username and password return the 'all_secdisabledsession' session
141objSession = msparser.ms_http_client_session()
142loginReturnCode = objHttpClient.userLogin(msusername, mspassword, objSession)
143if loginReturnCode != msparser.ms_http_client.L_SUCCESS and loginReturnCode != msparser.ms_http_client.L_SECURITYDISABLED:
144 print("Failed to login to %s as user %s. Return code id %d" % (msurl, msusername, loginReturnCode))
145 sys.exit(1)
146else:
147 print("Logged in to %s with session: %s" % (msurl, objSession.sessionId()))
148
149def doGetSeq():
150 print("Get Sequence")
151 accessions = msparser.VectorString()
152 frames = msparser.vectori()
153 accessions.append(msaccession)
154 localFileName = "sequence.xml"
155 if objSession.getSequenceFile(msdatabase, accessions, frames, localFileName):
156 print("Successfully saved sequence to %s" % localFileName)
157 else:
158 print("Failed to get sequence or failed to save it to %s" % localFileName)
159 showErrorsAndExit(objSession)
160
161def doGetResults():
162 print("Get Results")
163 objSearch = msparser.ms_http_client_search(objSession, mstaskID)
164 if not objSearch.isValid():
165 print("Search is not valid")
166 showErrorsAndExit(objSearch)
167 ok, remoteFileName = objSearch.getResultsFileName()
168 print(remoteFileName)
169 if ok and remoteFileName:
170 print("Found filename for results file")
171 else:
172 print("Unable to find filename for results file")
173 sys.exit(1)
174
175 localFileName = ntpath.basename(remoteFileName)
176 print("Downloading remote results file %s to %s" % (remoteFileName, localFileName))
177 objProgress = msparser.ms_http_helper_progress()
178 # Download the complete, uncompressed results file
179 if objSearch.downloadResultsFile(localFileName, objProgress):
180 print("Downloaded remote file to %s" % localFileName)
181 else:
182 print("Failed to download remote file to %s" % localFileName)
183 return False
184 return True
185
186def doSearch():
187 print("Searching" )
188# The input to Mascot is the peak list and search parameters in MIME format
189 httpHeader = "Content-Type: multipart/mixed; boundary=---------FormBoundary4C9ByKKVofH"
190 prologue = """-----------FormBoundary4C9ByKKVofH
191Content-Disposition: form-data; name="FORMVER"
192
1931.01
194-----------FormBoundary4C9ByKKVofH
195Content-Disposition: form-data; name="SEARCH"
196
197MIS
198-----------FormBoundary4C9ByKKVofH
199Content-Disposition: form-data; name="COM"
200
201Python script test
202-----------FormBoundary4C9ByKKVofH
203Content-Disposition: form-data; name="DB"
204
205SwissProt
206-----------FormBoundary4C9ByKKVofH
207Content-Disposition: form-data; name="CLE"
208
209Trypsin/P
210-----------FormBoundary4C9ByKKVofH
211Content-Disposition: form-data; name="PFA"
212
2131
214-----------FormBoundary4C9ByKKVofH
215Content-Disposition: form-data; name="QUANTITATION"
216
217None
218-----------FormBoundary4C9ByKKVofH
219Content-Disposition: form-data; name="TAXONOMY"
220
221. . . . . . . . . . . . . . . . Homo sapiens (human)
222-----------FormBoundary4C9ByKKVofH
223Content-Disposition: form-data; name="MODS"
224
225Carbamidomethyl (C)
226-----------FormBoundary4C9ByKKVofH
227Content-Disposition: form-data; name="IT_MODS"
228
229Oxidation (M)
230-----------FormBoundary4C9ByKKVofH
231Content-Disposition: form-data; name="TOL"
232
23310
234-----------FormBoundary4C9ByKKVofH
235Content-Disposition: form-data; name="TOLU"
236
237ppm
238-----------FormBoundary4C9ByKKVofH
239Content-Disposition: form-data; name="PEP_ISOTOPE_ERROR"
240
2411
242-----------FormBoundary4C9ByKKVofH
243Content-Disposition: form-data; name="ITOL"
244
2450.1
246-----------FormBoundary4C9ByKKVofH
247Content-Disposition: form-data; name="ITOLU"
248
249Da
250-----------FormBoundary4C9ByKKVofH
251Content-Disposition: form-data; name="CHARGE"
252
2532+
254-----------FormBoundary4C9ByKKVofH
255Content-Disposition: form-data; name="MASS"
256
257Monoisotopic
258-----------FormBoundary4C9ByKKVofH
259Content-Disposition: form-data; name="FORMAT"
260
261Mascot generic
262-----------FormBoundary4C9ByKKVofH
263Content-Disposition: form-data; name="INSTRUMENT"
264
265ESI-TRAP
266-----------FormBoundary4C9ByKKVofH
267Content-Disposition: form-data; name="REPORT"
268
269AUTO
270-----------FormBoundary4C9ByKKVofH
271Content-Disposition: form-data; name="USERNAME"
272
273Mascot Parser Test
274-----------FormBoundary4C9ByKKVofH
275Content-Disposition: form-data; name="USEREMAIL"
276
277dcreasy@matrixscience.com
278-----------FormBoundary4C9ByKKVofH
279Content-Disposition: form-data; name="FILE"; filename="test.mgf"
280"""
281
282 epilogue = "-----------FormBoundary4C9ByKKVofH--"
283
284# Request a Mascot task id for the search
285 objSearch = msparser.ms_http_client_search(objSession, mstaskID)
286 if not objSearch.isValid():
287 showErrorsAndExit(objSearch)
288# Submit the search
289 print("Submitting search")
290 objProgress = msparser.ms_http_helper_progress()
291 if objSession.submitSearch(objSearch, httpHeader, prologue, msmgf, epilogue, objProgress):
292 print("Search submitted. Task ID = %s" % objSearch.searchTaskId())
293 success = False
294 returnValue = 0
295 returnCode = msparser.ms_http_client_search.SS_UNKNOWN
296 complete = False
297 while not complete:
298 success, returnCode, returnValue = objSearch.getStatus()
299 if not success:
300 print("Unable to call getStatus()")
301 sys.exit(1)
302 if returnCode == msparser.ms_http_client_search.SS_UNKNOWN:
303 print("Unkown search id")
304 complete = False
305 elif returnCode == msparser.ms_http_client_search.SS_ASSIGNED:
306 print("Search not started")
307 complete = False
308 elif returnCode == msparser.ms_http_client_search.SS_QUEUED:
309 print("Search Queued")
310 complete = False
311 elif returnCode == msparser.ms_http_client_search.SS_RUNNING:
312 print("Search running: %s complete" % returnValue)
313 complete = False
314 elif returnCode == msparser.ms_http_client_search.SS_COMPLETE:
315 print("Search Complete")
316 complete = True
317 elif returnCode == msparser.ms_http_client_search.SS_ERROR:
318 print("Search Error : %s " % returnValue)
319 complete = True
320 elif returnCode == msparser.ms_http_client_search.SS_SEARCH_CONTROL_ERROR:
321 print("Search control error: %s " % returnValue)
322 complete = True
323 time.sleep(1)
324
325# Search complete - get the relative path to the result file
326 ok, remoteFileName = objSearch.getResultsFileName()
327 if not ok:
328 print("Unable to get filename for results file")
329 showErrorsAndExit(objHttpClient)
330 else:
331 print("Search result report can be viewed at this URL:")
332 print(objHttpClient.baseUrl() + "master_results_2.pl?file=" + remoteFileName)
333 else:
334 print("Failed to submit search")
335 showErrorsAndExit(objSession)
336
337def showErrorsAndExit(ms_errs):
338 print("Error: %s" % ms_errs.getLastErrorString())
339 errs = ms_errs.getErrorHandler()
340 for i in ms_range(1, errs.getNumberOfErrors()):
341 print("Error Number: " + str(errs.getErrorNumber(i)) + " (" + str(errs.getErrorRepeats(i + 1)) + " times :")
342 sys.exit(1)
343
344if mscmd == "search":
345 doSearch()
346
347if mscmd == "getresults":
348 doGetResults()
349
350if mscmd == "getseq":
351 doGetSeq()
352
353# And finally logout
354objSession.logout()
355
356
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: http_helper_getstring.cpp

http_helper_getstring.cpp

Accessing any server using http(s)

#include <iostream>
#include "msparser.hpp"
using namespace matrix_science;
int main(int argc, char ** argv)
{
std::string url, action, httpUserName, httpPassword, username, password;
if (argc == 3 || argc == 5 || argc == 7)
{
url = argv[1];
action = argv[2];
if(argc == 5 || argc == 7)
{
httpUserName = argv[3];
httpPassword = argv[4];
}
if (argc == 7)
{
username = argv[5];
password = argv[6];
}
}
else
{
std::cerr << "Usage: " << argv[0] << " <url> <action> [httpUserName] [httpPassword] [username] [password]" << std::endl;
return 1;
}
std::cout << "url: " << url << " action: " << action;
if(httpUserName != "")
{
std::cout << " httpUserName: " << httpUserName << " httpPassword: " << httpPassword;
}
if(username != "")
{
std::cout << " username: " << username << " password: " << password;
}
std::cout << std::endl;
ms_connection_settings connectionSettings;
connectionSettings.setUserAgent("CppTest/1.0" + connectionSettings.getUserAgent());
if(httpUserName != "")
{
connectionSettings.setHttpUsername(httpUserName);
}
if(httpPassword != "")
{
connectionSettings.setHttpPassword(httpPassword);
}
ms_http_helper httpHelper(url, connectionSettings);
if(!httpHelper.isValid())
{
std::cout << "Error: " << httpHelper.getLastErrorString() << std::endl;
for(int i = 0 ; httpHelper.getErrorHandler() && i < httpHelper.getErrorHandler()->getNumberOfErrors() ; i++ )
{
std::cout << "Error number: " << httpHelper.getErrorHandler()->getErrorNumber(i) << " (" << httpHelper.getErrorHandler()->getErrorRepeats(i) << " times) : "
<< httpHelper.getErrorHandler()->getErrorString(i) << std::endl;
}
std::cout << std::endl;
return -1;
}
std::string httpGETString;
ms_http_helper_return helperReturn_string(httpHelper.httpGetString(action, httpGETString));
if(helperReturn_string.isOk())
{
std::cout << "httpGETString - OK: " << std::endl << httpGETString << std::endl;
}
else
{
std::cout << "httpGETString - Error: " << helperReturn_string.getErrorText() << " (" << helperReturn_string.getHttpStatusCode() << ")" << std::endl;
}
std::string header;
ms_http_helper_return helperReturn_header(httpHelper.httpGetHeader("", header));
if(helperReturn_header.isOk())
{
std::cout << "httpGetHeader - OK : " << std::endl << header << std::endl;
}
else
{
std::cout << "httpGetHeader - Error: " << helperReturn_header.getErrorText() << " (" << helperReturn_header.getHttpStatusCode() << ")" << std::endl;
}
ms_http_helper_return helperReturn_buffer(httpHelper.httpBufferedOpen(""));
if(helperReturn_buffer.isOk())
{
std::cout << "httpBufferedOpen - OK :" << std::endl;
std::string buffer;
while (true)
{
ms_http_helper_return result = httpHelper.httpBufferedGetString(buffer, 10000);
if (buffer.length() == 0 || !result.isOk())
{
break;
}
std::cout << buffer;
}
httpHelper.httpBufferedClose();
}
else
{
std::cout << "httpBufferedOpen - Error: " << helperReturn_buffer.getErrorText() << " (" << helperReturn_buffer.getHttpStatusCode() << ")" << std::endl;
}
std::cout << std::endl;
return 0;
}
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_connection_settings::setUserAgent
void setUserAgent(const std::string userAgent)
Set the user agent string.
Definition: ms_connection_settings.cpp:374
matrix_science::ms_connection_settings::setHttpUsername
void setHttpUsername(const std::string httpUsername)
Sets the username for an authenticated web server.
Definition: ms_connection_settings.cpp:563
matrix_science::ms_connection_settings::getUserAgent
std::string getUserAgent() const
Get the user agent string.
Definition: ms_connection_settings.cpp:486
matrix_science::ms_connection_settings::setHttpPassword
void setHttpPassword(const std::string httpPassword)
Sets the password for an authenticated web server.
Definition: ms_connection_settings.cpp:581
matrix_science::ms_errors::getLastErrorString
std::string getLastErrorString() const
Return the error description of the last error that occurred.
Definition: ms_errors.cpp:1488
matrix_science::ms_errors::getErrorHandler
const ms_errs * getErrorHandler() const
Retrive the error object using this function to get access to all errors and error parameters.
Definition: ms_errors.cpp:1518
matrix_science::ms_errors::isValid
bool isValid() const
Call this function to determine if there have been any errors.
Definition: ms_errors.cpp:1472
matrix_science::ms_errs::getErrorRepeats
int getErrorRepeats(const int num=-1) const
Returns a number of times the specified error has been repeated.
Definition: ms_errors.cpp:1171
matrix_science::ms_errs::getErrorNumber
int getErrorNumber(const int num=-1) const
Return a specific error number or ERR_NO_ERROR.
Definition: ms_errors.cpp:1044
matrix_science::ms_errs::getErrorString
std::string getErrorString(const int num) const
Returns a specific error as a string.
Definition: ms_errors.cpp:1094
matrix_science::ms_errs::getNumberOfErrors
int getNumberOfErrors() const
Return the number of errors since the last call to clearAllErrors().
Definition: ms_errors.cpp:1004
matrix_science::ms_http_helper_return
Indicates any problem that may have occurred during a request to an ms_http_helper object.
Definition: ms_http_helper_return.hpp:37
matrix_science::ms_http_helper_return::isOk
bool isOk() const
Returns true if no problem was encountered.
Definition: ms_http_helper_return.cpp:109
matrix_science::ms_http_helper_return::getHttpStatusCode
int getHttpStatusCode() const
Returns the HTTP response code (if the type is ERR_http).
Definition: ms_http_helper_return.cpp:151
matrix_science::ms_http_helper_return::getErrorText
std::string getErrorText() const
Returns the text, if any, associated with the error.
Definition: ms_http_helper_return.cpp:161
matrix_science::ms_http_helper
The class provides HTTP, FTP and FILE protocol access to a server.
Definition: ms_http_helper.hpp:57
matrix_science::ms_http_helper::httpBufferedOpen
ms_http_helper_return httpBufferedOpen(const std::string &action)
Creates and opens a session for buffered reading from the supplied base URL and action.
Definition: ms_http_helper.cpp:2878
matrix_science::ms_http_helper::httpGetHeader
ms_http_helper_return httpGetHeader(const std::string &action, std::string &httpHeaderInfo)
Sends an HTTP HEAD message to the server and returns the header information separated with CR LF.
Definition: ms_http_helper.cpp:2525
matrix_science::ms_http_helper::httpBufferedGetString
ms_http_helper_return httpBufferedGetString(std::string &httpBuffer, unsigned long requiredSize)
Get available data from the open session. Writes data into the supplied buffer up to at least the req...
Definition: ms_http_helper.cpp:2934
matrix_science::ms_http_helper::httpGetString
ms_http_helper_return httpGetString(const std::string &action, std::string &httpGETString)
Sends an HTTP GET message to the server and returns the reply in a string.
Definition: ms_http_helper.cpp:888
matrix_science::ms_http_helper::httpBufferedClose
ms_http_helper_return httpBufferedClose()
Closes the current buffered read session.
Definition: ms_http_helper.cpp:2684
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: http_helper_getstring.pl

http_helper_getstring.pl

Accessing any server using http(s)

#!/usr/local/bin/perl
##############################################################################
# File: http_helper_getstring.pl #
# Mascot Parser toolkit example code #
##############################################################################
# COPYRIGHT NOTICE #
# Copyright 1998-2015 Matrix Science Limited All Rights Reserved. #
# #
##############################################################################
# $Source: parser/examples/test_perl/http_helper_getstring.pl $
# $Author: villek@matrixscience.com $
# $Date: 2018-07-30 16:23:53 +0100 $
# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
##############################################################################
use strict;
use warnings;
##############################################################################
# required Perl packages
use lib "../bin";
use msparser;
use Getopt::Long;
use File::Basename;
my ($url, $action, $httpUserName, $httpPassword, $username, $password);
$username = "";
$password = "";
GetOptions('url=s' => \$url,
'action=s' => \$action,
'httpUserName=s' => \$httpUserName,
'httpPassword=s' => \$httpPassword,
'username=s' => \$username,
'password=s' => \$password);
if (not defined $url or not defined $action) {
print <<USAGE;
Usage http_client.pl --url=<URL> --action=<command> [options]
--url Base URL, e.g
http://your-server/
--action An action for a get command.
Appended to the base URL
--httpUserName the username for an authenticated web server.
--httpPassword the password for an authenticated web server.
--username Mascot Server user name
May be required if Mascot Security is enabled
--password Mascot Server password
May be required if Mascot Security is enabled
USAGE
exit 1;
}
# Common code for all cases
# Create connection settings.
# Any settings for web server authentication or a proxy server should be set here
my $objSettings = new msparser::ms_connection_settings;
$objSettings->setUserAgent("PerlScriptTest/1.0 " . $objSettings->getUserAgent);
if ($httpUserName) {
$objSettings->setHttpUsername($httpUserName);
}
if ($httpPassword) {
$objSettings->setHttpPassword($httpPassword);
}
# Connect to the server
my $httpHelper = new msparser::ms_http_helper($url, $objSettings);
if (!$httpHelper->isValid()) {
showErrorsAndExit($httpHelper);
}
my ($errCodeString, $retString) = $httpHelper->httpGetString($action);
if ($errCodeString->isOk()) {
print "httpGetString OK : " . $retString . "\n";
} else {
print "Error: " . $errCodeString->getErrorText() . "\n";
}
my ($errCodeHeader, $retHeader) = $httpHelper->httpGetHeader($action);
if ($errCodeHeader->isOk()) {
print "httpGetHeader OK : " . $retHeader . "\n";
} else {
print "Error: " . $errCodeHeader->getErrorText() . "\n";
}
my ($errCodeBufferOpen) = $httpHelper->httpBufferedOpen($action);
if ($errCodeBufferOpen->isOk()) {
print "httpBufferedOpen OK : \n";
while (1)
{
my ($errCodeBufferString, $retBufferString) = $httpHelper->httpBufferedGetString(10000);
if (! length $retBufferString || !$errCodeBufferString->isOk())
{
last;
}
print $retBufferString;
}
$httpHelper->httpBufferedClose();
} else {
print "Error: " . $errCodeBufferOpen->getErrorText() . "\n";
}
sub showErrorsAndExit {
my ($obj) = @_;
print "Error: ", $obj->getLastErrorString(), "\n";
my $err = $obj->getErrorHandler();
my $i;
for my $i (1 .. $err->getNumberOfErrors) {
print "Error number: ";
print $err->getErrorNumber($i);
print " (";
print $err->getErrorRepeats($i) + 1;
print " times) : ";
print $err->getErrorString($i), "\n";
}
print "\n";
exit -1;
}
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: http_helper_getstring.py

http_helper_getstring.py

Accessing any server using http(s)

1#!/usr/bin/python
2
16
17import msparser
18import sys
19import getopt
20import ntpath
21import time
22
23# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
24def ms_range(start, stop, step=1):
25 i = start
26 while i <= stop:
27 yield i
28 i += step
29
30# Define Global argument variables
31msurl = ''
32msaction = ''
33msmgf = ''
34mshttpusername = ''
35mshttppassword = ''
36msusername = ''
37mspassword = ''
38
39# Define help text
40usage = """
41Usage http_client.py --url=<URL> --action=<command> [options]
42
43 --help Display this message
44 --url Base URL, e.g
45 http://your-server/
46 --action An action for a get command.
47 Appended to the base URL
48 --httpUserName the username for an authenticated web server.
49 --httpPassword the password for an authenticated web server.
50 --username Mascot Server user name
51 May be required if Mascot Security is enabled
52 --password Mascot Server password
53 May be required if Mascot Security is enabled
54"""
55# If no arguments supplied, print help and exit
56if len(sys.argv) < 2 :
57 print(usage)
58 sys.exit(1)
59
60# Ensure arguments are legal. if not, exit
61try:
62 opts, args = getopt.getopt(sys.argv[1:],"",["help","url=","action=","httpUserName=","httpPassword=","username=","password="])
63except getopt.GetoptError:
64 sys.exit(1)
65
66# If argument is --help, display help then exit
67for opt, arg in opts:
68 if opt == '--help':
69 print(usage)
70 sys.exit(2)
71
72# Read arguments and assign each option to appropriate variables
73 elif opt in ("--url"):
74 msurl = arg
75 elif opt in ("--action"):
76 msaction = arg
77 elif opt in ("--httpUserName"):
78 mshttpusername = arg
79 elif opt in ("--httpPassword"):
80 mshttppassword = arg
81 elif opt in ("--username"):
82 msusername = arg
83 elif opt in ("--password"):
84 mspassword = arg
85
86# Common Code for all cases
87
88# Create connection settings
89# Any settings for web server authentication or a proxy server should be set here
90objSettings = msparser.ms_connection_settings()
91objSettings.setUserAgent("PythonScriptTest/1.0 " + objSettings.getUserAgent())
92# Try to auto detect any proxy settings
93objSettings.setProxyServerType(msparser.ms_connection_settings.PROXY_TYPE_AUTO)
94
95if mshttpusername:
96 objSettings.setHttpUsername(mshttpusername)
97
98if mshttppassword:
99 objSettings.setHttpPassword(mshttppassword)
100
101# Connect to the server
102httpHelper = msparser.ms_http_helper(msurl, objSettings)
103if not httpHelper.isValid():
104 showErrorsAndExit(httpHelper)
105
106errCodeString, retString = httpHelper.httpGetString(msaction)
107if errCodeString.isOk():
108 print("httpGetString OK : " + retString)
109else:
110 print("Error: " + errCodeString.getErrorText())
111
112errCodeHeader, retHeader = httpHelper.httpGetHeader(msaction)
113if errCodeHeader.isOk():
114 print("httpGetHeader OK : " + retHeader)
115else:
116 print("Error: " + errCodeHeader.getErrorText())
117
118errCodeBufferOpen = httpHelper.httpBufferedOpen(msaction)
119if errCodeBufferOpen.isOk():
120 print("httpBufferedOpen OK : ")
121 while True:
122 errCodeBufferString, retBufferString = httpHelper.httpBufferedGetString(10000)
123 if len(retBufferString) == 0 or not errCodeBufferString.isOk():
124 break
125 print(retBufferString)
126 httpHelper.httpBufferedClose()
127
128
129def showErrorsAndExit(ms_errs):
130 print("Error: %s" % ms_errs.getLastErrorString())
131 errs = ms_errs.getErrorHandler()
132 for i in ms_range(1, errs.getNumberOfErrors()):
133 print("Error Number: " + str(errs.getErrorNumber(i)) + " (" + str(errs.getErrorRepeats(i + 1)) + " times :")
134 sys.exit(1)
135
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_aahelper
ms_aahelper Member List

This is the complete list of members for ms_aahelper, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
calcFragments(const ms_peptide *peptide, const int seriesID, const bool doubleCharged, const double minMass, const double maxMass, const MASS_TYPE massType, ms_fragmentvector *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const | ms_aahelper
calcFragments(const ms_peptide *peptide, const int seriesID, const bool doubleCharged, const double minMass, const double maxMass, const MASS_TYPE massType, std::vector< ms_fragment > *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const | ms_aahelper
calcFragmentsEx(const ms_peptide *peptide, const int seriesID, const int fragCharge, const double minMass, const double maxMass, const MASS_TYPE massType, ms_fragmentvector *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const | ms_aahelper
calcFragmentsEx(const ms_peptide *peptide, const int seriesID, const int fragCharge, const double minMass, const double maxMass, const MASS_TYPE massType, std::vector< ms_fragment > *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const | ms_aahelper
calcPeptideMZ(const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > numThatMustBeModded, const int charge, const MASS_TYPE massType, ms_errs *err) const | ms_aahelper
clearAllErrors() | ms_errors
copyFrom(const ms_aahelper *right) | ms_aahelper
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
createCrosslinkedPeptide(const ms_peptide &pepAlpha, const ms_peptide &pepBeta, const ms_linker_site_vector &linkedSites, ms_errs *err) const | ms_aahelper
createPeptide(const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > varMods, const std::vector< int > varModsWhichNl, const int charge, const MASS_TYPE massType, ms_errs *err) const | ms_aahelper
createPeptide(const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > varMods, const std::vector< int > varModsWhichNl, const std::vector< int > summedMods, const std::vector< int > summedModsWhichNl, const int charge, const MASS_TYPE massType, ms_errs *err) const | ms_aahelper
defaultValues() | ms_aahelper
FRAG_NL enum name | ms_aahelper
FRAG_NL_PRIMARY enum value | ms_aahelper
FRAG_NL_SECONDARY enum value | ms_aahelper
getEnzyme() const | ms_aahelper
getErrorHandler() const | ms_errors
getFixedMods() const | ms_aahelper
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getMasses() const | ms_aahelper
getMissed() const | ms_aahelper
getNextPeptide() | ms_aahelper
getPepEnd() const | ms_aahelper
getPepStart() const | ms_aahelper
getVarMods() const | ms_aahelper
isValid() const | ms_errors
ms_aahelper() | ms_aahelper
ms_aahelper(const ms_mascotresfilebase &resfile, const char *enzymeFileName, const char *quantSchemaFilePath="http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd", const char *unimodSchemaFilePath="http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd") | ms_aahelper
ms_aahelper(const ms_mascotresults &summary, const char *enzymeFileName, const char *quantSchemaFilePath="http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd", const char *unimodSchemaFilePath="http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd") | ms_aahelper
ms_aahelper(const ms_aahelper &right) | ms_aahelper
ms_errors() | ms_errors
operator=(const ms_aahelper &right) | ms_aahelper
setAvailableModifications(const ms_modvector *fixedModVector, const ms_modvector *varModVector) | ms_aahelper
setEnzyme(const ms_enzyme *enzyme) | ms_aahelper
setMasses(const ms_masses *masses) | ms_aahelper
startIteratePeptides(const char *sequenceProtein, const int sizeProtein, const int pfa) | ms_aahelper
stopIteratePeptides() | ms_aahelper
~ms_aahelper() | ms_aahelper
~ms_errors() | ms_errors
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_buffer_logger
ms_buffer_logger Member List

This is the complete list of members for ms_buffer_logger, including all inherited members.

COL_ASC_TIME enum value | ms_logger |
COL_HEADERS enum value | ms_logger |
COL_IP_ADDRESS enum value | ms_logger |
COL_ISO8601_TIME enum value | ms_logger |
COL_LOGGER_DEFAULTS enum value | ms_logger |
COL_MSG enum value | ms_logger |
COL_MSG_NUM_DEC enum value | ms_logger |
COL_MSG_NUM_HEX enum value | ms_logger |
COL_MSG_SOURCE_TXT enum value | ms_logger |
COL_QUOTES enum value | ms_logger |
COL_SEVERITY_NUM enum value | ms_logger |
COL_SEVERITY_TXT enum value | ms_logger |
COL_SRC_FILE enum value | ms_logger |
COL_SRC_LINENUM enum value | ms_logger |
COL_THREAD_ID enum value | ms_logger |
COL_TSV enum value | ms_logger |
flush() | ms_buffer_logger |
formatMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const | ms_logger |
getColsToOutput() const | ms_logger | virtual
getHeaderLine() const | ms_logger |
LogOutputColumns_e enum name | ms_logger |
ms_buffer_logger(unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS) | ms_buffer_logger |
ms_logger(const unsigned int colsToOutput=COL_MSG) | ms_logger |
onLogMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) | ms_buffer_logger | virtual
setColsToOutput(const unsigned int colsToOutput) | ms_logger | virtual
~ms_buffer_logger() | ms_buffer_logger | virtual
~ms_logger() | ms_logger | inlinevirtual
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_clusterparams
ms_clusterparams Member List

This is the complete list of members for ms_clusterparams, including all inherited members.

appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendSubCluster(const int id, const int maxCPUs) | ms_clusterparams
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
clearSubClusters() | ms_clusterparams
copyFrom(const ms_clusterparams *right) | ms_clusterparams
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_clusterparams
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getCheckNodesAliveFreq() const | ms_clusterparams
getDefaultDelimiter() const | ms_customproperty
getDefaultNodeHomeDir() const | ms_clusterparams
getDefaultNodeHomeDirFromMaster() const | ms_clusterparams
getDefaultNodeOS() const | ms_clusterparams
getDefaultPort() const | ms_clusterparams
getDelimiterByNumber(const int index) const | ms_customproperty
getIPCLogfile() const | ms_clusterparams
getIPCLogging() const | ms_clusterparams
getIPCTimeout() const | ms_clusterparams
getMascotNodeRebootScript() const | ms_clusterparams
getMascotNodeScript() const | ms_clusterparams
getMasterComputer() const | ms_clusterparams
getNodeSequenceDatabaseDir() const | ms_clusterparams
getNumberOfProperties() const | ms_customproperty
getNumberOfSubClusters() const | ms_clusterparams
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
getSecsToWaitForNodeAtStartup() const | ms_clusterparams
getSubClusterID(const int index) const | ms_clusterparams
getSubClusterMaxCPU(const int index) const | ms_clusterparams
isEnabled() const | ms_clusterparams
isSectionAvailable() const | ms_clusterparams
ms_clusterparams() | ms_clusterparams
ms_clusterparams(const ms_clusterparams &src) | ms_clusterparams
ms_customproperty() | ms_customproperty
NUM_PROCESSORS_AUTO_DETECT enum value | ms_clusterparams
operator=(const ms_clusterparams &right) | ms_clusterparams
setCheckNodesAliveFreq(const int value) | ms_clusterparams
setDefaultDelimiter(const char *delim) | ms_customproperty
setDefaultNodeHomeDir(const char *str) | ms_clusterparams
setDefaultNodeHomeDirFromMaster(const char *str) | ms_clusterparams
setDefaultNodeOS(const OPERATING_SYS value) | ms_clusterparams
setDefaultPort(const int value) | ms_clusterparams
setEnabled(const bool flag) | ms_clusterparams
setIPCLogfile(const char *str) | ms_clusterparams
setIPCLogging(const int value) | ms_clusterparams
setIPCTimeout(const int value) | ms_clusterparams
setMascotNodeRebootScript(const char *str) | ms_clusterparams
setMascotNodeScript(const char *str) | ms_clusterparams
setMasterComputer(const ms_computeraddress *value) | ms_clusterparams
setNodeSequenceDatabaseDir(const char *str) | ms_clusterparams
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setSecsToWaitForNodeAtStartup(const int value) | ms_clusterparams
setSectionAvailable(const bool value) | ms_clusterparams
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_clusterparams() | ms_clusterparams
~ms_customproperty() | ms_customproperty
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_computeraddress
ms_computeraddress Member List

This is the complete list of members for ms_computeraddress, including all inherited members.

copyFrom(const ms_computeraddress *right) | ms_computeraddress
defaultValues() | ms_computeraddress
getHostName() const | ms_computeraddress
getInetAddress() const | ms_computeraddress
getPort() const | ms_computeraddress
ms_computeraddress() | ms_computeraddress
ms_computeraddress(const ms_computeraddress &src) | ms_computeraddress
operator=(const ms_computeraddress &right) | ms_computeraddress
setHostName(const char *name) | ms_computeraddress
setInetAddress(const char *address) | ms_computeraddress
setPort(const unsigned int value) | ms_computeraddress
~ms_computeraddress() | ms_computeraddress
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_connection_settings
ms_connection_settings Member List

This is the complete list of members for ms_connection_settings, including all inherited members.

copyFrom(const ms_connection_settings *right) | ms_connection_settings |
defaultValues() | ms_connection_settings |
getConnectionTimeout() const | ms_connection_settings |
getHttpPassword() const | ms_connection_settings |
getHttpProtocol() const | ms_connection_settings |
getHttpUsername() const | ms_connection_settings |
getProxyPassword() const | ms_connection_settings |
getProxyServer() const | ms_connection_settings |
getProxyServerType() const | ms_connection_settings |
getProxyUserAndPassword() const | ms_connection_settings |
getProxyUsername() const | ms_connection_settings |
getRedirectPolicy() const | ms_connection_settings |
getSessionID() const | ms_connection_settings |
getUserAgent() const | ms_connection_settings |
HTTP_1_0 enum value | ms_connection_settings |
HTTP_1_1 enum value | ms_connection_settings |
HTTP_PROTOCOL enum name | ms_connection_settings |
HTTP_SYSTEM_DEFAULT enum value | ms_connection_settings |
isUseHTTPProxyForFTP() const | ms_connection_settings |
isUseHTTPProxyForHTTPS() const | ms_connection_settings |
ms_connection_settings() | ms_connection_settings |
ms_connection_settings(const std::string sessionID, const std::string proxyServer, const std::string proxyUserName, const std::string proxyUserPassword) | ms_connection_settings |
operator=(const ms_connection_settings &right) | ms_connection_settings |
PROXY_TYPE enum name | ms_connection_settings |
PROXY_TYPE_AUTO enum value | ms_connection_settings |
PROXY_TYPE_ENVIRONMENT enum value | ms_connection_settings |
PROXY_TYPE_FROM_REGISTRY enum value | ms_connection_settings |
PROXY_TYPE_NO_PROXY enum value | ms_connection_settings |
PROXY_TYPE_SPECIFY enum value | ms_connection_settings |
PROXY_TYPE_WPAD enum value | ms_connection_settings |
proxyTypeStringToEnum(std::string str) | ms_connection_settings | static
proxyTypeToString(int type) | ms_connection_settings | static
REDIRECT_POLICY enum name | ms_connection_settings |
REDIRECT_POLICY_ALWAYS enum value | ms_connection_settings |
REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP enum value | ms_connection_settings |
REDIRECT_POLICY_NEVER enum value | ms_connection_settings |
setConnectionTimeout(int timeout) | ms_connection_settings |
setHttpPassword(const std::string httpPassword) | ms_connection_settings |
setHttpProtocol(ms_connection_settings::HTTP_PROTOCOL httpProtocol) | ms_connection_settings |
setHttpUsername(const std::string httpUsername) | ms_connection_settings |
setProxyPassword(const std::string proxyUserPassword) | ms_connection_settings |
setProxyServer(const std::string proxyServer) | ms_connection_settings |
setProxyServerType(ms_connection_settings::PROXY_TYPE proxyType) | ms_connection_settings |
setProxyUsername(const std::string proxyUserName) | ms_connection_settings |
setRedirectPolicy(ms_connection_settings::REDIRECT_POLICY redirectPolicy) | ms_connection_settings |
setSessionID(const std::string sessionID) | ms_connection_settings |
setUseHTTPProxyForFTP(bool value) | ms_connection_settings |
setUseHTTPProxyForHTTPS(bool value) | ms_connection_settings |
setUserAgent(const std::string userAgent) | ms_connection_settings |
~ms_connection_settings() | ms_connection_settings |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_cronjob
ms_cronjob Member List

This is the complete list of members for ms_cronjob, including all inherited members.

copyFrom(const ms_cronjob *right) | ms_cronjob
defaultValues() | ms_cronjob
getCommandStr() const | ms_cronjob
isDayOfMonth(const int day) const | ms_cronjob
isDayOfWeek(const int day) const | ms_cronjob
isEnabled() const | ms_cronjob
isHour(const int hour) const | ms_cronjob
isMinute(const int min) const | ms_cronjob
isMonthOfYear(const int month) const | ms_cronjob
ms_cronjob() | ms_cronjob
ms_cronjob(const ms_cronjob &src) | ms_cronjob
operator=(const ms_cronjob &right) | ms_cronjob
setCommandStr(const char *str) | ms_cronjob
setDayOfMonth(const int day, const bool value) | ms_cronjob
setDayOfWeek(const int day, const bool value) | ms_cronjob
setEnabled(const bool enabled) | ms_cronjob
setHour(const int hour, const bool value) | ms_cronjob
setMinute(const int min, const bool value) | ms_cronjob
setMonthOfYear(const int month, const bool value) | ms_cronjob
~ms_cronjob() | ms_cronjob
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_cronoptions
ms_cronoptions Member List

This is the complete list of members for ms_cronoptions, including all inherited members.

appendCronJob(const ms_cronjob *job) | ms_cronoptions
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
clearCronJobs() | ms_cronoptions
copyFrom(const ms_cronoptions *right) | ms_cronoptions
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_cronoptions
deleteCronJob(const int idx) | ms_cronoptions
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
matrix_science::ms_customproperty::findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getCronJob(const int idx) const | ms_cronoptions
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getLogFileName() const | ms_cronoptions
getLoggingLevel() const | ms_cronoptions
getNumberOfCronJobs() const | ms_cronoptions
getNumberOfProperties() const | ms_customproperty
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
isCronEnabled() const | ms_cronoptions
isSectionAvailable() const | ms_cronoptions
ms_cronoptions() | ms_cronoptions
ms_cronoptions(const ms_cronoptions &src) | ms_cronoptions
ms_customproperty() | ms_customproperty
operator=(const ms_cronoptions &right) | ms_cronoptions
setCronEnabled(const bool value) | ms_cronoptions
setCronJob(const int idx, const ms_cronjob job) | ms_cronoptions
setDefaultDelimiter(const char *delim) | ms_customproperty
setLogFileName(const std::string &fileName) | ms_cronoptions
setLoggingLevel(const int level) | ms_cronoptions
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setSectionAvailable(const bool value) | ms_cronoptions
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_cronoptions() | ms_cronoptions
~ms_customproperty() | ms_customproperty
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_accession
ms_crosslinking_accession Member List

This is the complete list of members for ms_crosslinking_accession, including all inherited members.

copyFrom(const ms_crosslinking_accession *right) | ms_crosslinking_accession |
defaultValues() | ms_crosslinking_accession |
dropDatabaseName() | ms_crosslinking_accession |
dropValue() | ms_crosslinking_accession |
getDatabaseName() const | ms_crosslinking_accession |
getDatabaseNameSchemaType() const | ms_crosslinking_accession |
getSchemaType() const | ms_crosslinking_accession | virtual
getValue() const | ms_crosslinking_accession |
getValueSchemaType() const | ms_crosslinking_accession |
haveDatabaseName() const | ms_crosslinking_accession |
haveValue() const | ms_crosslinking_accession |
ms_crosslinking_accession() | ms_crosslinking_accession |
ms_crosslinking_accession(const ms_crosslinking_accession &src) | ms_crosslinking_accession |
operator=(const ms_crosslinking_accession &right) | ms_crosslinking_accession |
setDatabaseName(const char *value) | ms_crosslinking_accession |
setValue(const char *value) | ms_crosslinking_accession |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_accession | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_accession | virtual
~ms_crosslinking_accession() | ms_crosslinking_accession | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_accessions
ms_crosslinking_accessions Member List

This is the complete list of members for ms_crosslinking_accessions, including all inherited members.

appendAccession(const ms_crosslinking_accession *item) | ms_crosslinking_accessions |
clearAccessions() | ms_crosslinking_accessions |
copyFrom(const ms_crosslinking_accessions *right) | ms_crosslinking_accessions |
defaultValues() | ms_crosslinking_accessions |
deleteAccessionByNumber(const int idx) | ms_crosslinking_accessions |
getAccessionByNumber(const int idx) const | ms_crosslinking_accessions |
getAccessionSchemaType() const | ms_crosslinking_accessions |
getNumberOfAccessions() const | ms_crosslinking_accessions |
getSchemaType() const | ms_crosslinking_accessions | virtual
ms_crosslinking_accessions() | ms_crosslinking_accessions |
ms_crosslinking_accessions(const ms_crosslinking_accessions &src) | ms_crosslinking_accessions |
operator=(const ms_crosslinking_accessions &right) | ms_crosslinking_accessions |
updateAccessionByNumber(const int idx, const ms_crosslinking_accession *accession) | ms_crosslinking_accessions |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_accessions | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_accessions | virtual
~ms_crosslinking_accessions() | ms_crosslinking_accessions | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_configfile
ms_crosslinking_configfile Member List

This is the complete list of members for ms_crosslinking_configfile, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
appendMethod(const ms_crosslinking_method *elem) | ms_crosslinking_configfile |
clearAllErrors() | ms_errors |
clearMethods() | ms_crosslinking_configfile |
copyFrom(const ms_crosslinking_configfile *right) | ms_crosslinking_configfile |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
defaultValues() | ms_crosslinking_configfile | virtual
deleteMethodByName(const char *name) | ms_crosslinking_configfile |
deleteMethodByNumber(const int idx) | ms_crosslinking_configfile |
getConnectionSettings() const | ms_crosslinking_configfile |
getDefaultSchemaFileName() | ms_crosslinking_configfile | static
getErrorHandler() const | ms_errors |
getFileName() const | ms_crosslinking_configfile |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMajorVersion() const | ms_crosslinking_configfile |
getMethodByName(const char *name) const | ms_crosslinking_configfile |
getMethodByNumber(const int idx) const | ms_crosslinking_configfile |
getMinorVersion() const | ms_crosslinking_configfile |
getNumberOfMethods() const | ms_crosslinking_configfile |
getSchemaFileName() const | ms_crosslinking_configfile |
isValid() const | ms_errors |
ms_crosslinking_configfile() | ms_crosslinking_configfile |
ms_crosslinking_configfile(const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0, bool useSchema=true) | ms_crosslinking_configfile |
ms_crosslinking_configfile(const ms_crosslinking_configfile &right) | ms_crosslinking_configfile |
ms_errors() | ms_errors |
operator=(const ms_crosslinking_configfile &right) | ms_crosslinking_configfile |
read_buffer(const char *buffer) | ms_crosslinking_configfile |
read_file() | ms_crosslinking_configfile |
save_buffer(bool validateAgainstSchema=true) | ms_crosslinking_configfile |
save_file() | ms_crosslinking_configfile |
setConnectionSettings(const ms_connection_settings &cs) | ms_crosslinking_configfile |
setFileName(const char *filename) | ms_crosslinking_configfile |
setSchemaFileName(const char *name) | ms_crosslinking_configfile |
updateMethodByName(const char *name, const ms_crosslinking_method *method) | ms_crosslinking_configfile |
updateMethodByNumber(const int idx, const ms_crosslinking_method *method) | ms_crosslinking_configfile |
validateDocument() const | ms_crosslinking_configfile |
~ms_crosslinking_configfile() | ms_crosslinking_configfile | virtual
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_does_not_pair_with
ms_crosslinking_does_not_pair_with Member List

This is the complete list of members for ms_crosslinking_does_not_pair_with, including all inherited members.

copyFrom(const ms_crosslinking_does_not_pair_with *right) | ms_crosslinking_does_not_pair_with |
defaultValues() | ms_crosslinking_does_not_pair_with |
dropModFileName() | ms_crosslinking_does_not_pair_with |
getModFileName() const | ms_crosslinking_does_not_pair_with |
getModFileNameSchemaType() const | ms_crosslinking_does_not_pair_with |
getSchemaType() const | ms_crosslinking_does_not_pair_with | virtual
haveModFileName() const | ms_crosslinking_does_not_pair_with |
ms_crosslinking_does_not_pair_with() | ms_crosslinking_does_not_pair_with |
ms_crosslinking_does_not_pair_with(const ms_crosslinking_does_not_pair_with &src) | ms_crosslinking_does_not_pair_with |
operator=(const ms_crosslinking_does_not_pair_with &right) | ms_crosslinking_does_not_pair_with |
setModFileName(const char *value) | ms_crosslinking_does_not_pair_with |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_does_not_pair_with | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_does_not_pair_with | virtual
~ms_crosslinking_does_not_pair_with() | ms_crosslinking_does_not_pair_with | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_filters
ms_crosslinking_filters Member List

This is the complete list of members for ms_crosslinking_filters, including all inherited members.

appendParameter(const ms_crosslinking_parameter *item) | ms_crosslinking_parameters |
clearParameters() | ms_crosslinking_parameters | virtual
copyFrom(const ms_crosslinking_filters *right) | ms_crosslinking_filters |
matrix_science::ms_crosslinking_parameters::copyFrom(const ms_crosslinking_parameters *right) | ms_crosslinking_parameters |
defaultValues() | ms_crosslinking_filters |
deleteParameterByName(const char *name) | ms_crosslinking_parameters | virtual
deleteParameterByNumber(const int idx) | ms_crosslinking_parameters | virtual
getNumberOfParameters() const | ms_crosslinking_parameters | virtual
getParameterByName(const char *name) const | ms_crosslinking_parameters |
getParameterByNumber(const int idx) const | ms_crosslinking_parameters |
getParameterSchemaType() const | ms_crosslinking_filters | virtual
getSchemaType() const | ms_crosslinking_filters | virtual
ms_crosslinking_filters() | ms_crosslinking_filters |
ms_crosslinking_filters(const ms_crosslinking_filters &src) | ms_crosslinking_filters |
ms_crosslinking_parameters() | ms_crosslinking_parameters |
ms_crosslinking_parameters(const ms_crosslinking_parameters &src) | ms_crosslinking_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_crosslinking_filters &right) | ms_crosslinking_filters |
matrix_science::ms_crosslinking_parameters::operator=(const ms_crosslinking_parameters &right) | ms_crosslinking_parameters |
updateParameterByName(const char *name, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
updateParameterByNumber(const int idx, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_crosslinking_filters() | ms_crosslinking_filters | virtual
~ms_crosslinking_parameters() | ms_crosslinking_parameters | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_linker
ms_crosslinking_linker Member List

This is the complete list of members for ms_crosslinking_linker, including all inherited members.

appendDoesNotPairWith(const ms_crosslinking_does_not_pair_with *item) | ms_crosslinking_linker |
appendMonoLink(const ms_crosslinking_monolink *item) | ms_crosslinking_linker |
clearDoesNotPairWiths() | ms_crosslinking_linker |
clearMonoLinks() | ms_crosslinking_linker |
copyFrom(const ms_crosslinking_linker *right) | ms_crosslinking_linker |
defaultValues() | ms_crosslinking_linker |
deleteDoesNotPairWithByNumber(const int idx) | ms_crosslinking_linker |
deleteMonoLinkByNumber(const int idx) | ms_crosslinking_linker |
dropModFileName() | ms_crosslinking_linker |
getDoesNotPairWithByNumber(const int idx) const | ms_crosslinking_linker |
getDoesNotPairWithSchemaType() const | ms_crosslinking_linker |
getModFileName() const | ms_crosslinking_linker |
getModFileNameSchemaType() const | ms_crosslinking_linker |
getMonoLinkByNumber(const int idx) const | ms_crosslinking_linker |
getMonoLinkSchemaType() const | ms_crosslinking_linker |
getNumberOfDoesNotPairWiths() const | ms_crosslinking_linker |
getNumberOfMonoLinks() const | ms_crosslinking_linker |
getSchemaType() const | ms_crosslinking_linker | virtual
haveModFileName() const | ms_crosslinking_linker |
ms_crosslinking_linker() | ms_crosslinking_linker |
ms_crosslinking_linker(const ms_crosslinking_linker &src) | ms_crosslinking_linker |
operator=(const ms_crosslinking_linker &right) | ms_crosslinking_linker |
setModFileName(const char *value) | ms_crosslinking_linker |
updateDoesNotPairWithByNumber(const int idx, const ms_crosslinking_does_not_pair_with *does_not_pair_with) | ms_crosslinking_linker |
updateMonoLinkByNumber(const int idx, const ms_crosslinking_monolink *monolink) | ms_crosslinking_linker |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_linker | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_linker | virtual
~ms_crosslinking_linker() | ms_crosslinking_linker | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_linkers
ms_crosslinking_linkers Member List

This is the complete list of members for ms_crosslinking_linkers, including all inherited members.

appendLinker(const ms_crosslinking_linker *item) | ms_crosslinking_linkers |
clearLinkers() | ms_crosslinking_linkers |
copyFrom(const ms_crosslinking_linkers *right) | ms_crosslinking_linkers |
defaultValues() | ms_crosslinking_linkers |
deleteLinkerByNumber(const int idx) | ms_crosslinking_linkers |
getLinkerByNumber(const int idx) const | ms_crosslinking_linkers |
getLinkerSchemaType() const | ms_crosslinking_linkers |
getNumberOfLinkers() const | ms_crosslinking_linkers |
getSchemaType() const | ms_crosslinking_linkers | virtual
ms_crosslinking_linkers() | ms_crosslinking_linkers |
ms_crosslinking_linkers(const ms_crosslinking_linkers &src) | ms_crosslinking_linkers |
operator=(const ms_crosslinking_linkers &right) | ms_crosslinking_linkers |
updateLinkerByNumber(const int idx, const ms_crosslinking_linker *linker) | ms_crosslinking_linkers |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_linkers | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_linkers | virtual
~ms_crosslinking_linkers() | ms_crosslinking_linkers | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_method
ms_crosslinking_method Member List

This is the complete list of members for ms_crosslinking_method, including all inherited members.

copyFrom(const ms_crosslinking_method *right) | ms_crosslinking_method |
defaultValues() | ms_crosslinking_method |
dropAccessions() | ms_crosslinking_method |
dropDescription() | ms_crosslinking_method |
dropFilters() | ms_crosslinking_method |
dropLinkers() | ms_crosslinking_method |
dropName() | ms_crosslinking_method |
dropScope() | ms_crosslinking_method |
dropSettings() | ms_crosslinking_method |
dropStrategy() | ms_crosslinking_method |
getAccessions() const | ms_crosslinking_method |
getAccessionsSchemaType() const | ms_crosslinking_method |
getDescription() const | ms_crosslinking_method |
getDescriptionSchemaType() const | ms_crosslinking_method |
getFilters() const | ms_crosslinking_method |
getFiltersSchemaType() const | ms_crosslinking_method |
getLinkers() const | ms_crosslinking_method |
getLinkersSchemaType() const | ms_crosslinking_method |
getName() const | ms_crosslinking_method |
getNameSchemaType() const | ms_crosslinking_method |
getSchemaType() const | ms_crosslinking_method | virtual
getScope() const | ms_crosslinking_method |
getScopeSchemaType() const | ms_crosslinking_method |
getSettings() const | ms_crosslinking_method |
getSettingsSchemaType() const | ms_crosslinking_method |
getStrategy() const | ms_crosslinking_method |
getStrategySchemaType() const | ms_crosslinking_method |
haveAccessions() const | ms_crosslinking_method |
haveDescription() const | ms_crosslinking_method |
haveFilters() const | ms_crosslinking_method |
haveLinkers() const | ms_crosslinking_method |
haveName() const | ms_crosslinking_method |
haveScope() const | ms_crosslinking_method |
haveSettings() const | ms_crosslinking_method |
haveStrategy() const | ms_crosslinking_method |
ms_crosslinking_method() | ms_crosslinking_method |
ms_crosslinking_method(const ms_crosslinking_method &src) | ms_crosslinking_method |
operator=(const ms_crosslinking_method &right) | ms_crosslinking_method |
setAccessions(const ms_crosslinking_accessions *accessions) | ms_crosslinking_method |
setDescription(const char *value) | ms_crosslinking_method |
setFilters(const ms_crosslinking_filters *filters) | ms_crosslinking_method |
setLinkers(const ms_crosslinking_linkers *linkers) | ms_crosslinking_method |
setName(const char *value) | ms_crosslinking_method |
setScope(const ms_crosslinking_scope *scope) | ms_crosslinking_method |
setSettings(const ms_crosslinking_settings *settings) | ms_crosslinking_method |
setStrategy(const char *value) | ms_crosslinking_method |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_method | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_method | virtual
~ms_crosslinking_method() | ms_crosslinking_method | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_monolink
ms_crosslinking_monolink Member List

This is the complete list of members for ms_crosslinking_monolink, including all inherited members.

copyFrom(const ms_crosslinking_monolink *right) | ms_crosslinking_monolink |
defaultValues() | ms_crosslinking_monolink |
getSchemaType() const | ms_crosslinking_monolink | virtual
getValue() const | ms_crosslinking_monolink |
getValueSchemaType() const | ms_crosslinking_monolink |
ms_crosslinking_monolink() | ms_crosslinking_monolink |
ms_crosslinking_monolink(const ms_crosslinking_monolink &src) | ms_crosslinking_monolink |
operator=(const ms_crosslinking_monolink &right) | ms_crosslinking_monolink |
setValue(const char *value) | ms_crosslinking_monolink |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_monolink | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_monolink | virtual
~ms_crosslinking_monolink() | ms_crosslinking_monolink | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_parameter
ms_crosslinking_parameter Member List

This is the complete list of members for ms_crosslinking_parameter, including all inherited members.

copyFrom(const ms_crosslinking_parameter *right) | ms_crosslinking_parameter |
matrix_science::ms_xml_parameter::copyFrom(const ms_xml_parameter *right) | ms_xml_parameter |
defaultValues() | ms_crosslinking_parameter |
dropDescription() | ms_xml_parameter |
dropName() | ms_xml_parameter |
getDescription() const | ms_xml_parameter |
getDescriptionSchemaType() const | ms_crosslinking_parameter | virtual
getName() const | ms_xml_parameter |
getNameSchemaType() const | ms_crosslinking_parameter | virtual
getSchemaType() const | ms_crosslinking_parameter | virtual
getValue() const | ms_xml_parameter |
getValueSchemaType() const | ms_crosslinking_parameter | virtual
haveDescription() const | ms_xml_parameter |
haveName() const | ms_xml_parameter |
ms_crosslinking_parameter() | ms_crosslinking_parameter |
ms_crosslinking_parameter(const ms_crosslinking_parameter &src) | ms_crosslinking_parameter |
ms_xml_parameter() | ms_xml_parameter |
ms_xml_parameter(const ms_xml_parameter &src) | ms_xml_parameter |
operator=(const ms_crosslinking_parameter &right) | ms_crosslinking_parameter |
matrix_science::ms_xml_parameter::operator=(const ms_xml_parameter &right) | ms_xml_parameter |
setDescription(const char *value) | ms_xml_parameter |
setName(const char *value) | ms_xml_parameter |
setValue(const char *value) | ms_xml_parameter |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
~ms_crosslinking_parameter() | ms_crosslinking_parameter | virtual
~ms_xml_parameter() | ms_xml_parameter | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_parameters
ms_crosslinking_parameters Member List

This is the complete list of members for ms_crosslinking_parameters, including all inherited members.

appendParameter(const ms_crosslinking_parameter *item) | ms_crosslinking_parameters |
clearParameters() | ms_crosslinking_parameters | virtual
copyFrom(const ms_crosslinking_parameters *right) | ms_crosslinking_parameters |
defaultValues() | ms_crosslinking_parameters |
deleteParameterByName(const char *name) | ms_crosslinking_parameters | virtual
deleteParameterByNumber(const int idx) | ms_crosslinking_parameters | virtual
getNumberOfParameters() const | ms_crosslinking_parameters | virtual
getParameterByName(const char *name) const | ms_crosslinking_parameters |
getParameterByNumber(const int idx) const | ms_crosslinking_parameters |
getParameterSchemaType() const | ms_crosslinking_parameters | virtual
getSchemaType() const | ms_crosslinking_parameters | virtual
ms_crosslinking_parameters() | ms_crosslinking_parameters |
ms_crosslinking_parameters(const ms_crosslinking_parameters &src) | ms_crosslinking_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_crosslinking_parameters &right) | ms_crosslinking_parameters |
updateParameterByName(const char *name, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
updateParameterByNumber(const int idx, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_crosslinking_parameters() | ms_crosslinking_parameters | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_scope
ms_crosslinking_scope Member List

This is the complete list of members for ms_crosslinking_scope, including all inherited members.

appendParameter(const ms_crosslinking_parameter *item) | ms_crosslinking_parameters |
clearParameters() | ms_crosslinking_parameters | virtual
copyFrom(const ms_crosslinking_scope *right) | ms_crosslinking_scope |
matrix_science::ms_crosslinking_parameters::copyFrom(const ms_crosslinking_parameters *right) | ms_crosslinking_parameters |
defaultValues() | ms_crosslinking_scope |
deleteParameterByName(const char *name) | ms_crosslinking_parameters | virtual
deleteParameterByNumber(const int idx) | ms_crosslinking_parameters | virtual
getNumberOfParameters() const | ms_crosslinking_parameters | virtual
getParameterByName(const char *name) const | ms_crosslinking_parameters |
getParameterByNumber(const int idx) const | ms_crosslinking_parameters |
getParameterSchemaType() const | ms_crosslinking_scope | virtual
getSchemaType() const | ms_crosslinking_scope | virtual
ms_crosslinking_parameters() | ms_crosslinking_parameters |
ms_crosslinking_parameters(const ms_crosslinking_parameters &src) | ms_crosslinking_parameters |
ms_crosslinking_scope() | ms_crosslinking_scope |
ms_crosslinking_scope(const ms_crosslinking_scope &src) | ms_crosslinking_scope |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_crosslinking_scope &right) | ms_crosslinking_scope |
matrix_science::ms_crosslinking_parameters::operator=(const ms_crosslinking_parameters &right) | ms_crosslinking_parameters |
updateParameterByName(const char *name, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
updateParameterByNumber(const int idx, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_crosslinking_parameters() | ms_crosslinking_parameters | virtual
~ms_crosslinking_scope() | ms_crosslinking_scope | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_crosslinking_settings
ms_crosslinking_settings Member List

This is the complete list of members for ms_crosslinking_settings, including all inherited members.

appendParameter(const ms_crosslinking_parameter *item) | ms_crosslinking_parameters |
clearParameters() | ms_crosslinking_parameters | virtual
copyFrom(const ms_crosslinking_settings *right) | ms_crosslinking_settings |
matrix_science::ms_crosslinking_parameters::copyFrom(const ms_crosslinking_parameters *right) | ms_crosslinking_parameters |
defaultValues() | ms_crosslinking_settings |
deleteParameterByName(const char *name) | ms_crosslinking_parameters | virtual
deleteParameterByNumber(const int idx) | ms_crosslinking_parameters | virtual
getNumberOfParameters() const | ms_crosslinking_parameters | virtual
getParameterByName(const char *name) const | ms_crosslinking_parameters |
getParameterByNumber(const int idx) const | ms_crosslinking_parameters |
getParameterSchemaType() const | ms_crosslinking_settings | virtual
getSchemaType() const | ms_crosslinking_settings | virtual
ms_crosslinking_parameters() | ms_crosslinking_parameters |
ms_crosslinking_parameters(const ms_crosslinking_parameters &src) | ms_crosslinking_parameters |
ms_crosslinking_settings() | ms_crosslinking_settings |
ms_crosslinking_settings(const ms_crosslinking_settings &src) | ms_crosslinking_settings |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_crosslinking_settings &right) | ms_crosslinking_settings |
matrix_science::ms_crosslinking_parameters::operator=(const ms_crosslinking_parameters &right) | ms_crosslinking_parameters |
updateParameterByName(const char *name, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
updateParameterByNumber(const int idx, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_crosslinking_parameters() | ms_crosslinking_parameters | virtual
~ms_crosslinking_settings() | ms_crosslinking_settings | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_customproperty Class Reference

  • matrix_science
  • ms_customproperty
Public Member Functions | List of all members
ms_customproperty Class Reference

The class is used as a base for property-containing classes, such as ms_mascotoptions. More...

#include <ms_customproperty.hpp>

Inheritance diagram for ms_customproperty:
[legend]

Public Member Functions

ms_customproperty ()
Default constructor.
~ms_customproperty ()
Destructor.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | defaultValues ()
Removes all property entries and comments.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

The class is used as a base for property-containing classes, such as ms_mascotoptions.

This class functionality is designed to allow users store and retrieve specified and unspecified (custom) properties as well as comments.

Not every configuration file can hold custom properties and/or comments. Whether a configuration file can have custom properties or not depends on its format. For example, almost all sections of the main configuration file mascot.dat can have unspecified properties and comments, whereas Databases section of the same file cannot have either of them. Another example of non-supported custom properties is unimod.xml whose structure and syntax is defined in a corresponding xml-schema file and cannot be altered temporarily.

Normally, custom properties are used in the following cases:

  • future releases of software can introduce additional properties that can still be retrieved using old msparser-library;
  • when a client application needs to know exactly whether a certain property is explicitly specified in the configuration file or set to it's default value;
  • additional comments can be added/accessed programmatically and then stored in the disc file;
  • client application needs a raw text representation of a property instead of a set of parsed values.

Note that functionality related to comments is not particularly advanced. Comments are all treated uniformly like properties with empty names and can be retrieved only by number. New comments can be added only at the end of existing properties list using either appendText("# comment line preceded by a hash-character") or appendProperty("", "# comment line", ""). They can also be dropped/altered by number.

All properties in configuration files have three elements associated with them:

  • Name - an empty case-insensitive string in case of comments.
  • Value - raw text representation (comment line will normally start with # character).
  • Delimiter - a string between name and value in the configuration file. It can be a space character, comma, colon, tab or a combination of them. Delimiting characters are usually stripped out of property name and value and stored separately. When adding a new property without explicitly specified delimiter string a default one will be used.

Not necessarily all these elements are used and stored in a file – consult the documentation of the particular configuration file format. An instance of the class rather serves as a container of properties only. It doesn't have any file reading/writing functionality.

Member Function Documentation

◆ appendProperty()

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |

Adds a new property with the given parameters.

Parameters
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.

◆ appendText()

void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.

◆ delProp()

void delProp ( const char * str )

Deletes all properties with the specified name.

Parameters
str Property name to find a match and then delete.

◆ delPropStart()

void delPropStart ( const char * str )

Deletes all properties whose names start with the given string.

Parameters
str Beginning a first part of the property name to delete.

◆ findProperty()

int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ findPropertyBeginning()

int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns
a property index or -1 if no property found.

◆ getDefaultDelimiter()

std::string getDefaultDelimiter ( ) const

Return current default delimiter string used for parsing/storing properties.

Returns
default delimiter

◆ getDelimiterByNumber()

std::string getDelimiterByNumber ( const int index ) const

Returns a specific delimiter used for the property.

Parameters
index Index for which to get a delimiter
Returns
corresponding delimiter

◆ getNumberOfProperties()

int getNumberOfProperties ( ) const

Returns a total number of property/comment entries.

Returns
Number of property/comment entries

◆ getPreceedingComments()

std::string getPreceedingComments ( ) const

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
setPreceedingComments()
Returns
any comments preceeding the section

◆ getPropertyName()

std::string getPropertyName ( const int index ) const

Returns a property name for a given index.

Parameters
index property number from 0 to (getNumberOfProperties()-1).
Returns
Rroperty name of an empty string for comments.

◆ getPropValStringByName()

std::string getPropValStringByName ( const char * name ) const

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . – only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters
name Name for which to get a property value
Returns
corresponding property value

◆ getPropValStringByNumber()

std::string getPropValStringByNumber ( const int index ) const

Retrieves property raw text values by number.

Parameters
index Index for which to get a property value
Returns
corresponding property value

◆ setDefaultDelimiter()

void setDefaultDelimiter ( const char * delim )

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters
delim String to set the default delimiter

◆ setPreceedingComments()

void setPreceedingComments ( const std::string & comments )

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also
getPreceedingComments()
Parameters
comments any comments preceeding the section

◆ setPropertyName()

void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |

Changes name of the property with the given index.

Parameters
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.

◆ setPropValBoolByName()

void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValCharByName()

void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValFloatByName()

void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValInt64ByName()

void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValIntByName()

void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByName()

void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.

◆ setPropValStringByNumber()

void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |

Changes an string value of an existing property with the given index.

Parameters
index | an index of an existing property.
str | String value for the property.

◆ uncommentProp()

bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_customproperty.hpp
  • ms_customproperty.cpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_customproperty
ms_customproperty Member List

This is the complete list of members for ms_customproperty, including all inherited members.

appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_customproperty
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getNumberOfProperties() const | ms_customproperty
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
ms_customproperty() | ms_customproperty
setDefaultDelimiter(const char *delim) | ms_customproperty
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_customquantitation
ms_customquantitation Member List

This is the complete list of members for ms_customquantitation, including all inherited members.

addHeaderField(const std::string &name, const std::string &value) | ms_quantitation |
addPeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key) | ms_customquantitation |
addPeptideQuantKeys(const std::string &accession, int dbIdx, const std::vector< ms_peptide_quant_key > &keys) | ms_customquantitation |
addPeptideQuantKeys(const std::string &accession, int dbIdx, const ms_peptide_quant_key_vector &keys) | ms_customquantitation |
addPeptideRatio(const ms_peptide_quant_ratio &ratio) | ms_customquantitation |
addRawFileField(const unsigned int id, const std::string &name, const std::string &value) | ms_quantitation |
appendErrors(const ms_errors &src) | ms_errors |
calculateGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
calculateMedianRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
calculateWeightedGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
clearAllErrors() | ms_errors |
clearHeaderFields() | ms_quantitation |
clearPeptideQuantKeys(const std::string &accession, int dbIdx) | ms_customquantitation |
clearPeptideRatios() | ms_customquantitation |
clearRawFileFields() | ms_quantitation |
copyFrom(const ms_errors *right) | ms_errors |
countDistinctPeptides(const std::vector< ms_peptide_quant_key > &activeKeys) const | ms_quantitation | virtual
countDistinctPeptides(const ms_peptide_quant_key_vector &activeKeys) const | ms_quantitation | virtual
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMinNumPeptides() const | ms_quantitation | protected
getPeptideQuantKeys(const std::string &accession, int dbIdx) const | ms_quantitation |
getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | virtual
getPeptideRatioNormalisationBase(const std::string &ratioName) const | ms_quantitation |
getProgressInfo() | ms_quantitation |
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const | ms_customquantitation | virtual
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const | ms_customquantitation | virtual
getProteinRatioSample(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const | ms_quantitation | protected
getQuantitationMethod() const | ms_quantitation |
getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const | ms_customquantitation | protectedvirtual
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType) const | ms_customquantitation |
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const ms_peptide_quant_key_vector &keys) const | ms_customquantitation |
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const std::string &accession, int dbIdx) const | ms_customquantitation |
hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | virtual
initialiseBaseSettings(const ms_quant_method &qmBase, const ms_quant_method &qmConfig) | ms_quantitation | protected
isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | virtual
isValid() const | ms_errors |
ms_customquantitation(const ms_quant_method &qm) | ms_customquantitation | explicit
ms_customquantitation(const ms_peptidesummary &initFrom) | ms_customquantitation | explicit
ms_customquantitation(const ms_peptidesummary &initFrom, const ms_quant_method &qm) | ms_customquantitation |
ms_customquantitation(const ms_ms2quantitation &copyFrom) | ms_customquantitation | explicit
ms_errors() | ms_errors |
proteinKeys_ | ms_quantitation | protected
removePeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key) | ms_customquantitation |
removePeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation |
removePeptideRatioNormalisationBase(const std::string &ratioName) | ms_quantitation |
removePeptideRatioNormalisationBases() | ms_quantitation |
setMinNumPeptides(int value) | ms_quantitation |
setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation | virtual
setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation | virtual
setPeptideRatioNormalisationBase(const std::string &ratioName, double b) | ms_quantitation |
setProteinRatioType(const char *value) | ms_customquantitation | virtual
setQuantOutliers(const ms_quant_outliers *) | ms_customquantitation | virtual
~ms_customquantitation() | ms_customquantitation | virtual
~ms_errors() | ms_errors |
~ms_quantitation()=0 | ms_quantitation | pure virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_databaseoptions
ms_databaseoptions Member List

This is the complete list of members for ms_databaseoptions, including all inherited members.

copyFrom(const ms_databaseoptions *right) | ms_databaseoptions
defaultValues() | ms_databaseoptions
getAccessionParseRuleIndex() const | ms_databaseoptions
getAccessionRefParseRuleIndex() const | ms_databaseoptions
getDBType() const | ms_databaseoptions
getDescriptionParseRuleIndex() const | ms_databaseoptions
getName() const | ms_databaseoptions
getNumberOfThreads() const | ms_databaseoptions
getPath() const | ms_databaseoptions
getPreceedingComments() const | ms_databaseoptions
getTaxonomyParseRuleIndex() const | ms_databaseoptions
isActive() const | ms_databaseoptions
isLocalRefFile() const | ms_databaseoptions
isLockMemory() const | ms_databaseoptions
isMemoryMapFiles() const | ms_databaseoptions
ms_databaseoptions() | ms_databaseoptions
ms_databaseoptions(const ms_databaseoptions &src) | ms_databaseoptions
NUM_THREADS_AUTO_DETECT enum value | ms_databaseoptions
operator=(const ms_databaseoptions &right) | ms_databaseoptions
setAccessionParseRuleIndex(const int index) | ms_databaseoptions
setAccessionRefParseRuleIndex(const int index) | ms_databaseoptions
setActive(const bool value) | ms_databaseoptions
setDBType(const int type) | ms_databaseoptions
setDescriptionParseRuleIndex(const int index) | ms_databaseoptions
setLocalRefFile(const bool flag) | ms_databaseoptions
setLockMemory(const bool flag) | ms_databaseoptions
setMemoryMapFiles(const bool flag) | ms_databaseoptions
setName(const char *name) | ms_databaseoptions
setNumberOfThreads(const int number) | ms_databaseoptions
setPath(const char *path) | ms_databaseoptions
setPreceedingComments(const std::string &str) | ms_databaseoptions
setTaxonomyParseRuleIndex(const int index) | ms_databaseoptions
~ms_databaseoptions() | ms_databaseoptions
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_databases
ms_databases Member List

This is the complete list of members for ms_databases, including all inherited members.

appendDatabase(const ms_databaseoptions *item) | ms_databases
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
clearDatabases() | ms_databases
copyFrom(const ms_databases *right) | ms_databases
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_databases
deleteDatabaseByName(const char *name) | ms_databases
deleteDatabaseByNumber(const int num) | ms_databases
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
findDatabase(const char *dbName, const bool searchInactive=false) const | ms_databases
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getDatabase(const int index) const | ms_databases
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getNumberOfDatabases() const | ms_databases
getNumberOfProperties() const | ms_customproperty
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
isSectionAvailable() const | ms_databases
ms_customproperty() | ms_customproperty
ms_databases() | ms_databases
ms_databases(const ms_databases &src) | ms_databases
operator=(const ms_databases &right) | ms_databases
setDefaultDelimiter(const char *delim) | ms_customproperty
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setSectionAvailable(const bool value) | ms_databases
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
updateDatabaseByName(const char *name, const ms_databaseoptions db) | ms_databases
updateDatabaseByNumber(const int num, const ms_databaseoptions db) | ms_databases
~ms_customproperty() | ms_customproperty
~ms_databases() | ms_databases
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_datfile
ms_datfile Member List

This is the complete list of members for ms_datfile, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
checkSeqDBInstallRequest(const std::string &dbName, const double newFastaSize) const | ms_datfile
clearAllErrors() | ms_errors
copyFrom(const ms_datfile *right) | ms_datfile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_datfile
editedByDatabaseManager() const | ms_datfile
getClusterParams() const | ms_datfile
getConnectionSettings() const | ms_datfile
getCronOptions() const | ms_datfile
getDatabases() const | ms_datfile
getErrorHandler() const | ms_errors
getFileName() const | ms_datfile
getFindFileTimeout() const | ms_datfile
getHeaderComments() const | ms_datfile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getLibraryOptions() const | ms_datfile
getMascotFiles() const | ms_datfile
getMascotOptions() const | ms_datfile
getMaxTaxonomyRules() const | ms_datfile
getParseOptions() const | ms_datfile
getProcessors() const | ms_datfile
getTaxonomyRules(const int idx) const | ms_datfile
getUniGeneOptions() const | ms_datfile
getWWWOptions() const | ms_datfile
IFLG_ADDMISSINGOPTIONS enum value | ms_datfile
IFLG_ADDPERCOLATOROPT enum value | ms_datfile
IFLG_ADDREPORTAUTO enum value | ms_datfile
IFLG_DEFAULTNEWINSTALL enum value | ms_datfile
IFLG_DEFAULTUPGRADE enum value | ms_datfile
IFLG_UPDATEAPACHEFORKOPT enum value | ms_datfile
IFLG_UPDATECLUSTER enum value | ms_datfile
IFLG_UPDATEDBMANAGERPERLPATH enum value | ms_datfile
IFLG_UPDATEESTTAX enum value | ms_datfile
IFLG_UPDATEEXECAFTERSEARCH enum value | ms_datfile
IFLG_UPDATEMSPEPSEARCHOPTS enum value | ms_datfile
IFLG_UPDATENCBIHTTPS enum value | ms_datfile
IFLG_UPDATEPARSERULES enum value | ms_datfile
IFLG_UPDATEPERCOLATORFEATS enum value | ms_datfile
IFLG_UPDATEPERCOLATORUSERT enum value | ms_datfile
IFLG_UPDATEPRIDECONTAMINANTS enum value | ms_datfile
IFLG_UPDATEPROTFAMILYSWITCH enum value | ms_datfile
IFLG_UPDATESPLITDATAFILESIZE enum value | ms_datfile
IFLG_UPDATESPLITNUMOFQUERIES enum value | ms_datfile
IFLG_UPDATESWISSPROT enum value | ms_datfile
IFLG_UPDATETAXONOMY enum value | ms_datfile
INST_FLAGS enum name | ms_datfile
isValid() const | ms_errors
ms_datfile() | ms_datfile
ms_datfile(const ms_datfile &src) | ms_datfile
ms_datfile(const char *filename, const int timeoutSec=0, const matrix_science::ms_connection_settings *cs=0) | ms_datfile
ms_errors() | ms_errors
operator=(const ms_datfile &right) | ms_datfile
read_file() | ms_datfile
save_file() | ms_datfile
SEQDB_INSTALL enum name | ms_datfile
SEQDB_INSTALL_CURRENT_RULES enum value | ms_datfile
SEQDB_INSTALL_CUSTOMISED enum value | ms_datfile
SEQDB_INSTALL_EXISTING_LARGER enum value | ms_datfile
SEQDB_INSTALL_INACTIVE enum value | ms_datfile
SEQDB_INSTALL_INVALID_CONFIG enum value | ms_datfile
SEQDB_INSTALL_INVALID_DBNAME enum value | ms_datfile
SEQDB_INSTALL_MISSING_CONFIG enum value | ms_datfile
SEQDB_INSTALL_MUST_UPDATE_CFG enum value | ms_datfile
SEQDB_INSTALL_OLD_RULES enum value | ms_datfile
SEQDB_INSTALL_SHOULD_QUERY_USER enum value | ms_datfile
SEQDB_INSTALL_WRONG_WILDCARD enum value | ms_datfile
setClusterParams(const ms_clusterparams *params) | ms_datfile
setConnectionSettings(const matrix_science::ms_connection_settings &cs) | ms_datfile
setCronOptions(const ms_cronoptions *options) | ms_datfile
setDatabases(const ms_databases *dbs) | ms_datfile
setFileName(const char *name) | ms_datfile
setFindFileTimeout(const int seconds) | ms_datfile
setHeaderComments(const std::string headerComments) | ms_datfile
setLibraryOptions(const ms_libraryoptions *spectralLibraryOptions) | ms_datfile
setMascotFiles(const ms_mascotfiles *src) | ms_datfile
setMascotOptions(const ms_mascotoptions *opt) | ms_datfile
setParseOptions(const ms_parseoptions *rules) | ms_datfile
setProcessors(const ms_processoroptions *info) | ms_datfile
setTaxonomyRules(const int idx, const ms_taxonomyrules *rules) | ms_datfile
setUniGeneOptions(const ms_unigeneoptions *uoptions) | ms_datfile
setWWWOptions(const ms_wwwoptions *www) | ms_datfile
updateForInstaller(ms_errs &log, const char *not_mascot_dat_path, const char *mascot_dat_path, const char *licenseFilePath, const char *pathToMascot, const char *mascotURL, const char *sequenceDatabases, const bool clusterEnable, const WST wst, const char *NTGuestName, const char *NTAdminName, const unsigned int flags) | ms_datfile
WST enum name | ms_datfile
WST_APACHE enum value | ms_datfile
WST_IIS enum value | ms_datfile
~ms_datfile() | ms_datfile
~ms_errors() | ms_errors
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_dbprocessors
ms_dbprocessors Member List

This is the complete list of members for ms_dbprocessors, including all inherited members.

appendThreadProcessorID(const int proccessorID) | ms_dbprocessors
clearThreads() | ms_dbprocessors
copyFrom(const ms_dbprocessors *right) | ms_dbprocessors
defaultValues() | ms_dbprocessors
getName() const | ms_dbprocessors
getNumberOfThreads() const | ms_dbprocessors
getThreadProcessorID(const int threadIndex) const | ms_dbprocessors
ms_dbprocessors() | ms_dbprocessors
ms_dbprocessors(const ms_dbprocessors &src) | ms_dbprocessors
operator=(const ms_dbprocessors &right) | ms_dbprocessors
setName(const char *str) | ms_dbprocessors
~ms_dbprocessors() | ms_dbprocessors
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_distiller_data
ms_distiller_data Member List

This is the complete list of members for ms_distiller_data, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_distiller_data *right) | ms_distiller_data |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
get_ms_mascotresults_params(const int searchIndex) const | ms_distiller_data | virtual
getDatfile() const | ms_distiller_data | virtual
getDistillerExperimentType() const | ms_distiller_data | virtual
getDistillerProjectStreamName() | ms_distiller_data | static
getDistillerResfileTimestamp() | ms_distiller_data | static
getDistillerVersion() const | ms_distiller_data | virtual
getErrorHandler() const | ms_errors |
getFragRulesFile() const | ms_distiller_data | virtual
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getLoadedSearchIndex() const | ms_distiller_data | virtual
getQuant(int index) const | ms_distiller_data | virtual
getQuantCount() const | ms_distiller_data | virtual
getQuantForSearch(const std::string &taskId) const | ms_distiller_data | virtual
getQuantMethod() const | ms_distiller_data | virtual
getRequiredSchemaFileNames() | ms_distiller_data | static
getSearch(int index) const | ms_distiller_data | virtual
getSearchCount() const | ms_distiller_data | virtual
isValid() const | ms_errors |
loadXml(const char *xmlSchemaPath, const std::string &xmlText) | ms_distiller_data | virtual
loadXmlFile(const char *xmlSchemaPath, const std::string &xmlFilename) | ms_distiller_data | virtual
loadXmlStream(const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream) | ms_distiller_data | virtual
ms_distiller_data(const ms_distiller_data &copy) | ms_distiller_data |
ms_errors() | ms_errors |
operator=(const ms_distiller_data &copy) | ms_distiller_data |
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_distiller_data_quant
ms_distiller_data_quant Member List

This is the complete list of members for ms_distiller_data_quant, including all inherited members.

getCacheStreamName() const | ms_distiller_data_quant
getResultsStreamName() const | ms_distiller_data_quant
getStreamNumber() const | ms_distiller_data_quant
getTaskId() const | ms_distiller_data_quant
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_distiller_data_search
ms_distiller_data_search Member List

This is the complete list of members for ms_distiller_data_search, including all inherited members.

eAuto enum value | ms_distiller_data_search
eFASTA enum value | ms_distiller_data_search
eGroupAuto enum value | ms_distiller_data_search
eGroupFamily enum value | ms_distiller_data_search
eGrouping enum name | ms_distiller_data_search
eGroupStandard enum value | ms_distiller_data_search
eIntegrated enum value | ms_distiller_data_search
eLibrary enum value | ms_distiller_data_search
eMudpit enum value | ms_distiller_data_search
eScoring enum name | ms_distiller_data_search
eSpectralLibrary enum name | ms_distiller_data_search
eStandard enum value | ms_distiller_data_search
eUnknown enum value | ms_distiller_data_search
getCacheFileName() const | ms_distiller_data_search
getErrTolPeptide() const | ms_distiller_data_search
getFDRCountType() const | ms_distiller_data_search
getLoaded() const | ms_distiller_data_search
getLoadUnassigned() const | ms_distiller_data_search
getMascotSearchURL(const std::string &resultsFilePath) const | ms_distiller_data_search
getMascotServerURL() const | ms_distiller_data_search
getMinPepLenInPepSummary() const | ms_distiller_data_search
getPeptideSummaryFlags() const | ms_distiller_data_search
getPeptideSummaryFlags2() const | ms_distiller_data_search
getPercolator() const | ms_distiller_data_search
getPercolatorUseProteins() const | ms_distiller_data_search
getPercolatorUseRT() const | ms_distiller_data_search
getProteinGrouping() const | ms_distiller_data_search
getQuantMethodXml() const | ms_distiller_data_search
getReporttop() const | ms_distiller_data_search
getRequireBoldRed() const | ms_distiller_data_search
getScoreExpectCutOff() const | ms_distiller_data_search
getScoring() const | ms_distiller_data_search
getShowSamesets() const | ms_distiller_data_search
getShowSamesetsFamily() const | ms_distiller_data_search
getShowSubset() const | ms_distiller_data_search
getShowSubsetFamily() const | ms_distiller_data_search
getSignificanceThreshold() const | ms_distiller_data_search
getSpectralLibraryDisplayOption() const | ms_distiller_data_search
getTargetFDR() const | ms_distiller_data_search
getTargetFDRStr() const | ms_distiller_data_search
getTargetFDRType() const | ms_distiller_data_search
getTaskId() const | ms_distiller_data_search
isTargetFDR() const | ms_distiller_data_search
ms_distiller_data_search() | ms_distiller_data_search
ms_distiller_data_search(const std::string &taskId, bool isLoaded, const std::string &cacheFileName, const std::string &quantMethodXml, const std::string &mascotServerURL, const std::string &mascotServerVersion, unsigned int flags, unsigned int flags2, bool requireBoldRed, bool showSameset, double showSubset, bool loadUnassigned, double significanceThreshold, eScoring scoring, int reporttop, bool errTolPeptide, eGrouping proteinGrouping, bool percolator, double scoreExpectCutOff, bool showSamesetFamily, bool showSubsetFamily, eSpectralLibrary libraryDisplayOption, bool percolatorUseProteins, bool percolatorUseRT, int minPepLenInPepSummary, bool isTargetFDR=false, const std::string &targetFDRType="", const std::string &targetFDRStr="") | ms_distiller_data_search
serverVersionNewerOrSameAs(int major, int minor, int patch) const | ms_distiller_data_search
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_distiller_master_project
ms_distiller_master_project Member List

This is the complete list of members for ms_distiller_master_project, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_distiller_master_project *right) | ms_distiller_master_project |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMasterProjectStreamName() | ms_distiller_master_project | static
getNumSearches() const | ms_distiller_master_project | virtual
getNumSubprojects() const | ms_distiller_master_project | virtual
getSearch(int index) const | ms_distiller_master_project | virtual
getSubproject(int index) const | ms_distiller_master_project | virtual
isValid() const | ms_errors |
loadXml(const char *xmlSchemaPath, std::string xmlText) | ms_distiller_master_project | virtual
loadXmlFile(const char *xmlSchemaPath, std::string xmlFilename) | ms_distiller_master_project | virtual
loadXmlStream(const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream) | ms_distiller_master_project | virtual
ms_distiller_master_project(const ms_distiller_master_project &src) | ms_distiller_master_project |
ms_errors() | ms_errors |
operator=(const ms_distiller_master_project &right) | ms_distiller_master_project |
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_distiller_master_search
ms_distiller_master_search Member List

This is the complete list of members for ms_distiller_master_search, including all inherited members.

getCacheFilename() const | ms_distiller_master_search | virtual
getCombinedPeptideSummaryCacheStreamName() const | ms_distiller_master_search | virtual
getId() const | ms_distiller_master_search | virtual
getNumSubsearches() const | ms_distiller_master_search | virtual
getSubsearch(int index) const | ms_distiller_master_search | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_distiller_search_status
ms_distiller_search_status Member List

This is the complete list of members for ms_distiller_search_status, including all inherited members.

getError() const | ms_distiller_search_status
getId() const | ms_distiller_search_status
getPeptideSummaryCacheStreamName() const | ms_distiller_search_status
getResfileStreamName() const | ms_distiller_search_status
getResultsFile() const | ms_distiller_search_status
getServer() const | ms_distiller_search_status
getStatusMsg() const | ms_distiller_search_status
getSubmitTime() const | ms_distiller_search_status
getTaskId() const | ms_distiller_search_status
getTitle() const | ms_distiller_search_status
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_distiller_search_status_list
ms_distiller_search_status_list Member List

This is the complete list of members for ms_distiller_search_status_list, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_distiller_search_status_list *right) | ms_distiller_search_status_list |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getNumSearches() const | ms_distiller_search_status_list |
getSearch(int index) const | ms_distiller_search_status_list |
getSearchStatusListStreamName() | ms_distiller_search_status_list | static
isValid() const | ms_errors |
loadXml(const char *xmlSchemaPath, const std::string &xmlText) | ms_distiller_search_status_list |
loadXmlFile(const char *xmlSchemaPath, const std::string &xmlFilename) | ms_distiller_search_status_list |
loadXmlStream(const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream) | ms_distiller_search_status_list |
ms_distiller_search_status_list(const ms_distiller_search_status_list &src) | ms_distiller_search_status_list |
ms_errors() | ms_errors |
operator=(const ms_distiller_search_status_list &right) | ms_distiller_search_status_list |
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_distiller_sub_project
ms_distiller_sub_project Member List

This is the complete list of members for ms_distiller_sub_project, including all inherited members.

getHavePeakList() const | ms_distiller_sub_project | virtual
getId() const | ms_distiller_sub_project | virtual
getName() const | ms_distiller_sub_project | virtual
getProjectRelativePath() const | ms_distiller_sub_project | virtual
getRawAbsolutePath() const | ms_distiller_sub_project | virtual
getRawFormat() const | ms_distiller_sub_project | virtual
getRawRelativePath() const | ms_distiller_sub_project | virtual
getRawSampleNumber() const | ms_distiller_sub_project | virtual
getResultsListStreamName() | ms_distiller_sub_project | static
getType() const | ms_distiller_sub_project | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_distiller_subsearch
ms_distiller_subsearch Member List

This is the complete list of members for ms_distiller_subsearch, including all inherited members.

getResultsFile() const | ms_distiller_subsearch | virtual
getTaskId() const | ms_distiller_subsearch | virtual
getTitle() const | ms_distiller_subsearch | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_enzyme
ms_enzyme Member List

This is the complete list of members for ms_enzyme, including all inherited members.

addCutter(const cuttertype type, const char *cleaveAtStr, const char *restrictStr) | ms_enzyme
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
canCleave(const int cutterNum, const char leftResidue, const char rightResidue) const | ms_enzyme
clearAllCutters() | ms_enzyme
copyFrom(const ms_enzyme *right) | ms_enzyme
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
CTERM_CUTTER enum value | ms_enzyme
cuttertype enum name | ms_enzyme
defaultValues() | ms_enzyme
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getCleave(const int cutterNum) const | ms_enzyme
getCutterType(const int cutterNum) const | ms_enzyme
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getNumberOfCutters() const | ms_enzyme
getNumberOfProperties() const | ms_customproperty
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
getRestrict(const int cutterNum) const | ms_enzyme
getTitle() const | ms_enzyme
isIndependent() const | ms_enzyme
isSemiSpecific() const | ms_enzyme
isValid() const | ms_enzyme
ms_customproperty() | ms_customproperty
ms_enzyme() | ms_enzyme
ms_enzyme(const ms_enzyme &src) | ms_enzyme
NTERM_CUTTER enum value | ms_enzyme
operator=(const ms_enzyme &right) | ms_enzyme
setDefaultDelimiter(const char *delim) | ms_customproperty
setIndependent(const bool bit) | ms_enzyme
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setSemiSpecific(const bool value) | ms_enzyme
setTitle(const char *str) | ms_enzyme
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
UNDEFINED_CUTTER enum value | ms_enzyme
verifyEnzyme(ms_errs *errObj) const | ms_enzyme
~ms_customproperty() | ms_customproperty
~ms_enzyme() | ms_enzyme
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_enzymefile
ms_enzymefile Member List

This is the complete list of members for ms_enzymefile, including all inherited members.

appendEnzyme(const ms_enzyme *item) | ms_enzymefile
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
clearEnzymes() | ms_enzymefile
copyFrom(const ms_enzymefile *right) | ms_enzymefile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_enzymefile
deleteEnzymeByName(const char *name) | ms_enzymefile
deleteEnzymeByNumber(const int num) | ms_enzymefile
getConnectionSettings() const | ms_enzymefile
getEnzymeByName(const char *name) const | ms_enzymefile
getEnzymeByNumber(const int num) const | ms_enzymefile
getErrorHandler() const | ms_errors
getFileName() const | ms_enzymefile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumberOfEnzymes() const | ms_enzymefile
isNoneFound() const | ms_enzymefile
isValid() const | ms_errors
ms_enzymefile() | ms_enzymefile
ms_enzymefile(const ms_enzymefile &src) | ms_enzymefile
ms_enzymefile(const char *filename, const matrix_science::ms_connection_settings *cs=0) | ms_enzymefile
ms_errors() | ms_errors
operator=(const ms_enzymefile &right) | ms_enzymefile
read_buffer(const char *buffer) | ms_enzymefile
read_file() | ms_enzymefile
save_file() | ms_enzymefile
setConnectionSettings(const matrix_science::ms_connection_settings &cs) | ms_enzymefile
setFileName(const char *filename) | ms_enzymefile
updateEnzymeByName(const char *name, const ms_enzyme enzyme) | ms_enzymefile
updateEnzymeByNumber(const int num, const ms_enzyme enzyme) | ms_enzymefile
~ms_enzymefile() | ms_enzymefile
~ms_errors() | ms_errors
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_errors
ms_errors Member List

This is the complete list of members for ms_errors, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_errors *right) | ms_errors
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
isValid() const | ms_errors
ms_errors() | ms_errors
~ms_errors() | ms_errors
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_errs
ms_errs Member List

This is the complete list of members for ms_errs, including all inherited members.

addToCatalog(const msg_catalog_t catalog[], size_t numEntries, ms_loggingmonitor::Source_e src, errorOrLogMessages_e errorOrLogMessages) | ms_log |
appendErrors(const ms_errs &src) | ms_errs |
clearAllErrors() | ms_errs |
convertFromLogLevel(ms_loggingmonitor::Level_e logLevel) | ms_errs | static
convertToLogLevel(ms_errs::msg_sev severity) | ms_errs | static
err typedef | ms_errs |
ERR_ACCINPEPTIDESTR | ms_errs | static
ERR_ADDPEPTIDES | ms_errs | static
ERR_CANNOT_APPEND_RESFILE | ms_errs | static
ERR_CANNOT_APPEND_RESFILE_NO_FNAMES | ms_errs | static
ERR_CDB_64_BIT_REMAKE | ms_errs | static
ERR_CDB_BEING_CREATED | ms_errs | static
ERR_CDB_FAIL_LOCK | ms_errs | static
ERR_CDB_FAIL_REMOVE | ms_errs | static
ERR_CDB_FAIL_UNLOCK | ms_errs | static
ERR_CDB_INCOMPLETE_NO_RETRY | ms_errs | static
ERR_CDB_INCOMPLETE_RETRY | ms_errs | static
ERR_CDB_OLD_VER_NO_RETRY | ms_errs | static
ERR_CDB_OLD_VER_RETRY | ms_errs | static
ERR_CDB_SOURCE_CHANGE_NO_RETRY | ms_errs | static
ERR_CDB_SOURCE_CHANGE_RETRY | ms_errs | static
ERR_CDB_TOO_LARGE | ms_errs | static
ERR_DUPE_ACCESSION | ms_errs | static
ERR_DUPLICATE_KEY | ms_errs | static
ERR_FAIL_CDB_INIT | ms_errs | static
ERR_FAIL_CLOSE_FILE | ms_errs | static
ERR_FAIL_MK_CACHE_DIR | ms_errs | static
ERR_FAIL_MK_CDB_FILE | ms_errs | static
ERR_FAIL_OPEN_DAT_FILE | ms_errs | static
ERR_INVALID_CACHE_DIR | ms_errs | static
ERR_INVALID_CDB_FILE | ms_errs | static
ERR_INVALID_NUMQUERIES | ms_errs | static
ERR_INVALID_PROTDB | ms_errs | static
ERR_INVALID_RESFILE | ms_errs | static
ERR_MALFORMED_DRANGE | ms_errs | static
ERR_MALFORMED_ERR_TOL | ms_errs | static
ERR_MALFORMED_TAG | ms_errs | static
ERR_MALFORMED_TERMS | ms_errs | static
ERR_MISSING_CDB_FILE | ms_errs | static
ERR_MISSING_PERCOLATOR_FILE | ms_errs | static
ERR_MISSINGENTRY | ms_errs | static
ERR_MISSINGHIT | ms_errs | static
ERR_MISSINGSECTION | ms_errs | static
ERR_MISSINGSECTIONEND | ms_errs | static
ERR_MSP_BIND_INVALID_CPU | ms_errs | static
ERR_MSP_CACHE_DATAOFFSETINVALID | ms_errs | static
ERR_MSP_CACHE_DUPLICATESTREAMID | ms_errs | static
ERR_MSP_CACHE_FILESEEKFAILED | ms_errs | static
ERR_MSP_CACHE_INVALIDFORMAT | ms_errs | static
ERR_MSP_CACHE_INVALIDSTREAMID | ms_errs | static
ERR_MSP_CACHE_INVALIDSTREAMPOSITION | ms_errs | static
ERR_MSP_CACHE_INVALIDVERSION | ms_errs | static
ERR_MSP_CACHE_MODIFYCLOSED | ms_errs | static
ERR_MSP_CACHE_MODIFYREADONLYMODE | ms_errs | static
ERR_MSP_CACHE_OPENFAILED | ms_errs | static
ERR_MSP_CACHE_PROT_NUMPEPTIDES_RELOAD | ms_errs | static
ERR_MSP_CACHE_READFAILED | ms_errs | static
ERR_MSP_CACHE_SIGNATUREINVALID | ms_errs | static
ERR_MSP_CACHE_SLREF_UPDATE | ms_errs | static
ERR_MSP_CACHE_STREAMNOTFOUND | ms_errs | static
ERR_MSP_CACHE_UNINITIALISEDSTREAM | ms_errs | static
ERR_MSP_CACHE_WRITEFAILED | ms_errs | static
ERR_MSP_CACHE_WRITETRUNCATED | ms_errs | static
ERR_MSP_CLOSEST_FDR_FOR_ET | ms_errs | static
ERR_MSP_CLOSEST_FDR_FOR_FIRST_PASS | ms_errs | static
ERR_MSP_COLOURSCHEME_INVALID | ms_errs | static
ERR_MSP_COMPILE_PARSE_RULE | ms_errs | static
ERR_MSP_CONFLICT_BETWEEN_MODS | ms_errs | static
ERR_MSP_CRON_INVALID_CHAR | ms_errs | static
ERR_MSP_CRON_INVALID_NUMBER | ms_errs | static
ERR_MSP_CRON_INVALID_STAR | ms_errs | static
ERR_MSP_CRON_NO_NUM_BEFORE_COMMA | ms_errs | static
ERR_MSP_CRON_NO_NUM_BEFORE_MINUS | ms_errs | static
ERR_MSP_CRON_TOO_MANY_JOBS | ms_errs | static
ERR_MSP_CROSSLINKING_FAILEDLOAD | ms_errs | static
ERR_MSP_CROSSLINKING_FAILEDSAVE | ms_errs | static
ERR_MSP_CROSSLINKING_INVALID_LINK | ms_errs | static
ERR_MSP_CROSSLINKING_MULTI_LINKS | ms_errs | static
ERR_MSP_CROSSLINKING_MULTI_PEPTIDE | ms_errs | static
ERR_MSP_CROSSLINKING_VARMOD_CONFLICT | ms_errs | static
ERR_MSP_CUSTQUANT_FAILEDINIT | ms_errs | static
ERR_MSP_CUSTQUANT_PROTR_UNIM | ms_errs | static
ERR_MSP_DB_USES_MISSING_RULE | ms_errs | static
ERR_MSP_DIFFERENT_1ST_PASS_THR_ET | ms_errs | static
ERR_MSP_DOUBLE_CHARGE_NOT_ALLOWED | ms_errs | static
ERR_MSP_DUP_TAXONOMYRULE | ms_errs | static
ERR_MSP_DUPLICATE_MOD | ms_errs | static
ERR_MSP_EMPTY_MOD | ms_errs | static
ERR_MSP_ENZYME_DEFINITION_PROBLEM | ms_errs | static
ERR_MSP_ENZYME_FILE_FORMAT | ms_errs | static
ERR_MSP_ENZYME_TOO_MANY_RULES | ms_errs | static
ERR_MSP_EXEC_AFTER_SEARCH_DEPENDS | ms_errs | static
ERR_MSP_EXEC_AFTER_SEARCH_INVALID | ms_errs | static
ERR_MSP_EXEC_AFTER_SEARCH_LOGGING | ms_errs | static
ERR_MSP_FAIL_GET_PROCESS_AFFINITY | ms_errs | static
ERR_MSP_FAIL_GET_SYSINFO | ms_errs | static
ERR_MSP_FAIL_HWLOC_INIT | ms_errs | static
ERR_MSP_FAIL_HWLOC_LOAD | ms_errs | static
ERR_MSP_FAIL_PROCESSOR_BIND | ms_errs | static
ERR_MSP_FAIL_STAT | ms_errs | static
ERR_MSP_FAIL_THREAD_BIND | ms_errs | static
ERR_MSP_FAIL_UTIME | ms_errs | static
ERR_MSP_FAILED_TO_CLOSE_FILE | ms_errs | static
ERR_MSP_FAILED_TO_OPEN_FILE | ms_errs | static
ERR_MSP_FAILED_TO_READ_FILE | ms_errs | static
ERR_MSP_FAILED_TO_WRITE_FILE | ms_errs | static
ERR_MSP_FILE_DOESNT_EXIST | ms_errs | static
ERR_MSP_FRAGMENTATION_RULES | ms_errs | static
ERR_MSP_GET_VOLUME_INFO | ms_errs | static
ERR_MSP_HTTP_ABORTEDBYUSER | ms_errs | static
ERR_MSP_HTTP_BADHTTPSTATUS | ms_errs | static
ERR_MSP_HTTP_CHANGEPASSWORDDISABLED | ms_errs | static
ERR_MSP_HTTP_CLOSECONNECTIONFAILED | ms_errs | static
ERR_MSP_HTTP_CLOSEREQUESTFAILED | ms_errs | static
ERR_MSP_HTTP_CLOSESESSIONFAILED | ms_errs | static
ERR_MSP_HTTP_DOWNLOADFAILED | ms_errs | static
ERR_MSP_HTTP_ERROR | ms_errs | static
ERR_MSP_HTTP_GETPROXYFAILED | ms_errs | static
ERR_MSP_HTTP_GETRESULTSFILENAME | ms_errs | static
ERR_MSP_HTTP_GETSEARCHSTAGE | ms_errs | static
ERR_MSP_HTTP_HEADERFAILED | ms_errs | static
ERR_MSP_HTTP_INVALID_URL | ms_errs | static
ERR_MSP_HTTP_LOGINERROR | ms_errs | static
ERR_MSP_HTTP_LOGINERRORINT | ms_errs | static
ERR_MSP_HTTP_LOGINPARSERERROR | ms_errs | static
ERR_MSP_HTTP_LOGINPARSERERRORINT | ms_errs | static
ERR_MSP_HTTP_LOGINSERVERERROR | ms_errs | static
ERR_MSP_HTTP_LOGINSERVERERRORINT | ms_errs | static
ERR_MSP_HTTP_MAXCONECTIONS10FAILED | ms_errs | static
ERR_MSP_HTTP_MAXCONECTIONSFAILED | ms_errs | static
ERR_MSP_HTTP_MISSINGLOGINERROR | ms_errs | static
ERR_MSP_HTTP_MISSINGLOGININFO | ms_errs | static
ERR_MSP_HTTP_NORESPONSE | ms_errs | static
ERR_MSP_HTTP_OPENCONNECTIONFAILED | ms_errs | static
ERR_MSP_HTTP_OPENOUTPUTFILEFAILED | ms_errs | static
ERR_MSP_HTTP_OPENREQUESTFAILED | ms_errs | static
ERR_MSP_HTTP_OPENSESSIONFAILED | ms_errs | static
ERR_MSP_HTTP_QUERYDATAFAILED | ms_errs | static
ERR_MSP_HTTP_QUERYSTATUSFAILED | ms_errs | static
ERR_MSP_HTTP_READDATAFAILED | ms_errs | static
ERR_MSP_HTTP_READRESPONSEFAILED | ms_errs | static
ERR_MSP_HTTP_RELOGINFAILED | ms_errs | static
ERR_MSP_HTTP_SENDREQUESTFAILED | ms_errs | static
ERR_MSP_HTTP_SESSIONALREADYOPEN | ms_errs | static
ERR_MSP_HTTP_SETHTTPPASSWORDFAILED | ms_errs | static
ERR_MSP_HTTP_SETHTTPUSERNAMEFAILED | ms_errs | static
ERR_MSP_HTTP_SETPROXYFAILED | ms_errs | static
ERR_MSP_HTTP_SETPROXYPASSWORDFAILED | ms_errs | static
ERR_MSP_HTTP_SETPROXYUSERNAMEFAILED | ms_errs | static
ERR_MSP_HTTP_SETREDIRECTFAILED | ms_errs | static
ERR_MSP_HTTP_TRANSMISSION_FAILED | ms_errs | static
ERR_MSP_HTTP_VERSIONERROR | ms_errs | static
ERR_MSP_HTTP_WEBAUTHERROR | ms_errs | static
ERR_MSP_HTTP_WRITEOUTPUTFILEFAILED | ms_errs | static
ERR_MSP_HTTP_XMLUPLOADFAILED | ms_errs | static
ERR_MSP_IMPUTATION_AVERAGE_PROGRESS | ms_errs | static
ERR_MSP_IMPUTATION_CONSTRUCTOR | ms_errs | static
ERR_MSP_IMPUTATION_DEBUG1 | ms_errs | static
ERR_MSP_IMPUTATION_DEBUG2 | ms_errs | static
ERR_MSP_IMPUTATION_DEBUG3 | ms_errs | static
ERR_MSP_IMPUTATION_EMPTY_DATA | ms_errs | static
ERR_MSP_IMPUTATION_FAIL | ms_errs | static
ERR_MSP_IMPUTATION_FIXED_PROGRESS | ms_errs | static
ERR_MSP_IMPUTATION_KNN_BLANK_ROW | ms_errs | static
ERR_MSP_IMPUTATION_KNN_PROGRESS | ms_errs | static
ERR_MSP_IMPUTATION_MISSFOR_PROGRESS | ms_errs | static
ERR_MSP_IMPUTATION_NO_RATIOS_PEPTIDE | ms_errs | static
ERR_MSP_IMPUTATION_NO_RATIOS_PROTEIN | ms_errs | static
ERR_MSP_IMPUTATION_NO_TIMES | ms_errs | static
ERR_MSP_IMPUTATION_VARIABLE | ms_errs | static
ERR_MSP_IMPUTATION_WARNING | ms_errs | static
ERR_MSP_IN_CLUSTER_SECTION | ms_errs | static
ERR_MSP_IN_MASCOT_DAT_DB_SECT | ms_errs | static
ERR_MSP_IN_MASSES_FILE | ms_errs | static
ERR_MSP_IN_MODS_FILE | ms_errs | static
ERR_MSP_IN_OPTIONS_SECTION | ms_errs | static
ERR_MSP_IN_TAXONOMY_SECTION | ms_errs | static
ERR_MSP_INCOMPATIBLE_TAX_RULES | ms_errs | static
ERR_MSP_INST_CANTGETHOSTNAME | ms_errs | static
ERR_MSP_INST_FAILADDPARSERULE | ms_errs | static
ERR_MSP_INST_INVALIDCPUINFO | ms_errs | static
ERR_MSP_INST_MISSINGDATABASE | ms_errs | static
ERR_MSP_INVALID_CPU_PACKAGE_NUM | ms_errs | static
ERR_MSP_INVALID_LOGICAL_CPU_NUM | ms_errs | static
ERR_MSP_INVALID_MASS_IN_MASSES_FILE | ms_errs | static
ERR_MSP_INVALID_NUM_LICENSED | ms_errs | static
ERR_MSP_INVALID_PARSE_RULE | ms_errs | static
ERR_MSP_INVALID_PARSE_RULE_NO | ms_errs | static
ERR_MSP_INVALID_PROCESSOR_LINE | ms_errs | static
ERR_MSP_LEGACY_DATA_NOT_AVAILABLE | ms_errs | static
ERR_MSP_LEGACY_DATA_READ_ERROR | ms_errs | static
ERR_MSP_LEGACY_DATA_SQL_ERROR | ms_errs | static
ERR_MSP_LEGACY_DATA_WRONG_FORMAT | ms_errs | static
ERR_MSP_LICENSE_DES_CHECKSUM | ms_errs | static
ERR_MSP_LICENSE_EXPIRED | ms_errs | static
ERR_MSP_LICENSE_INTERNAL_CONFIG | ms_errs | static
ERR_MSP_LICENSE_LINE_CHECKSUM | ms_errs | static
ERR_MSP_LICENSE_LINE_INVALID | ms_errs | static
ERR_MSP_LICENSE_NOT_YET_AVAIL | ms_errs | static
ERR_MSP_LOOPLINKING_NOT_IMPLEMENTED | ms_errs | static
ERR_MSP_MALFORMED_PEPTIDE | ms_errs | static
ERR_MSP_MASCOT_NOT_RUNNING | ms_errs | static
ERR_MSP_MAX_PREFIX_REMOVES | ms_errs | static
ERR_MSP_MAX_SUFFIX_REMOVES | ms_errs | static
ERR_MSP_MAX_TAX_NO_BREAKS | ms_errs | static
ERR_MSP_MISSING_DEFINITION_END | ms_errs | static
ERR_MSP_MISSING_ENZYME_TITLE | ms_errs | static
ERR_MSP_MISSING_ET_MOD | ms_errs | static
ERR_MSP_MISSING_MASCOT_DAT | ms_errs | static
ERR_MSP_MISSING_MONOLINK_MOD | ms_errs | static
ERR_MSP_MISSING_QUOTE_IN_PARSE_RULE | ms_errs | static
ERR_MSP_MISSING_SECTION | ms_errs | static
ERR_MSP_MISSING_SL_MOD | ms_errs | static
ERR_MSP_MOD_MUST_BE_VAR | ms_errs | static
ERR_MSP_MS1QUANT_CDB_BYTES | ms_errs | static
ERR_MSP_MS1QUANT_CDB_MISSING_KEY | ms_errs | static
ERR_MSP_MS1QUANT_CDB_VERSION | ms_errs | static
ERR_MSP_MS1QUANT_GET_COMBINED_LIMITS | ms_errs | static
ERR_MSP_MS1QUANT_INVALID_PROJECT_ID | ms_errs | static
ERR_MSP_MS1QUANT_NO_EST_WIDTH | ms_errs | static
ERR_MSP_MS1QUANT_RTOFFSET_DIFF_FRACT | ms_errs | static
ERR_MSP_MS1QUANT_TIME_ALIGIN_CALCFRM | ms_errs | static
ERR_MSP_MS1QUANT_TIME_ALIGN_INDEX | ms_errs | static
ERR_MSP_MS1QUANT_XML_INVALID_BIN1 | ms_errs | static
ERR_MSP_MS1QUANT_XML_INVALID_BIN2 | ms_errs | static
ERR_MSP_MS1QUANT_XML_INVALID_RT | ms_errs | static
ERR_MSP_MS1QUANT_XML_LOAD_PROJECT_ID | ms_errs | static
ERR_MSP_MS1QUANT_XML_PARSE | ms_errs | static
ERR_MSP_MS1QUANT_XML_SAX_ELEMENT | ms_errs | static
ERR_MSP_MS1QUANT_XML_SAX_STATE | ms_errs | static
ERR_MSP_MS1QUANTITATION_FAILEDINIT | ms_errs | static
ERR_MSP_MS1QUANTITATION_HITREF_DROP | ms_errs | static
ERR_MSP_MS1QUANTITATION_HITREF_NEW | ms_errs | static
ERR_MSP_MS2QUANTITATION_COMPONENTS | ms_errs | static
ERR_MSP_MS2QUANTITATION_FAILEDINIT | ms_errs | static
ERR_MSP_MS2QUANTITATION_NORM_NO_SUM | ms_errs | static
ERR_MSP_MS2QUANTITATION_NORM_UNIMP | ms_errs | static
ERR_MSP_MS2QUANTITATION_PROTR_UNIM | ms_errs | static
ERR_MSP_MS2QUANTITATION_PROTWEIGH | ms_errs | static
ERR_MSP_MS2QUANTITATION_QUERY_SECS | ms_errs | static
ERR_MSP_MSR_CREATING_FILE | ms_errs | static
ERR_MSP_MSR_READING_FILE | ms_errs | static
ERR_MSP_MSR_WRITING_FILE | ms_errs | static
ERR_MSP_NEED_1_EXP_IN_PARSE_RULE | ms_errs | static
ERR_MSP_NIST_CANNOT_ANNOTATE_PEAK | ms_errs | static
ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY | ms_errs | static
ERR_MSP_NIST_INDEX_OUT_OF_RANGE | ms_errs | static
ERR_MSP_NIST_MODIFICATION_NOT_FOUND | ms_errs | static
ERR_MSP_NIST_MSP_INCONSISTENT_MODS | ms_errs | static
ERR_MSP_NIST_MSP_INVALID_LINE | ms_errs | static
ERR_MSP_NIST_MSP_MISSING_PARAMETER | ms_errs | static
ERR_MSP_NIST_MSP_NO_CREATE_CDB | ms_errs | static
ERR_MSP_NIST_MSP_NO_SPECTRA | ms_errs | static
ERR_MSP_NIST_NO_PEAKS_IN_SPECTRUM | ms_errs | static
ERR_MSP_NIST_NO_PRECURSOR_MZ_VALUE | ms_errs | static
ERR_MSP_NIST_SAVE_ZERO_SPECTRA | ms_errs | static
ERR_MSP_NO_COMMAS_IN_MOD_NAME | ms_errs | static
ERR_MSP_NO_ENZYME_SET | ms_errs | static
ERR_MSP_NO_LICENSE_FILE | ms_errs | static
ERR_MSP_NO_REGEX_MATCH | ms_errs | static
ERR_MSP_NO_SUCH_MOD | ms_errs | static
ERR_MSP_PARSE_LEN_EXCEED | ms_errs | static
ERR_MSP_PERCOLATOR_USE_RT_OBSOLETE | ms_errs | static
ERR_MSP_PROCESSOR_NOT_IN_SET | ms_errs | static
ERR_MSP_QUANT_ACCESSION_NOT_FOUND | ms_errs | static
ERR_MSP_QUANT_CDB_MATCH_STREAM | ms_errs | static
ERR_MSP_QUANT_CDB_MISSING_KEY | ms_errs | static
ERR_MSP_QUANT_EMPTY_REF_ACCESSION | ms_errs | static
ERR_MSP_QUANT_FAIL_LOAD_MATCH | ms_errs | static
ERR_MSP_QUANT_FAIL_LOAD_PEPTIDE | ms_errs | static
ERR_MSP_QUANT_FAILEDLOAD | ms_errs | static
ERR_MSP_QUANT_FAILEDSAVE | ms_errs | static
ERR_MSP_QUANT_HELPER_FAILEDINIT | ms_errs | static
ERR_MSP_QUANT_INVALID_REF_AMOUNT | ms_errs | static
ERR_MSP_QUANT_MISSING_COMPONENT | ms_errs | static
ERR_MSP_QUANTITATION_BADCOMPONENT | ms_errs | static
ERR_MSP_QUANTITATION_BADMETHOD | ms_errs | static
ERR_MSP_QUANTITATION_FAILEDINIT | ms_errs | static
ERR_MSP_QUANTITATION_NOMETHOD | ms_errs | static
ERR_MSP_REGEX_ERROR | ms_errs | static
ERR_MSP_REPORTBUILDERCOLARR_INVALID | ms_errs | static
ERR_MSP_RESIDUE_AND_TERMINUS_MOD | ms_errs | static
ERR_MSP_RULE_NO_ALREADY_DEFINED | ms_errs | static
ERR_MSP_SECURITY_ACCOUNT_DISABLED | ms_errs | static
ERR_MSP_SECURITY_ADDGROUP | ms_errs | static
ERR_MSP_SECURITY_ADDUSER | ms_errs | static
ERR_MSP_SECURITY_BAD_GROUP_NAME | ms_errs | static
ERR_MSP_SECURITY_BAD_USER_NAME | ms_errs | static
ERR_MSP_SECURITY_CMDLINE_CGI | ms_errs | static
ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP | ms_errs | static
ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS | ms_errs | static
ERR_MSP_SECURITY_DEL_SPECIAL_GROUP | ms_errs | static
ERR_MSP_SECURITY_DEL_SPECIAL_USER | ms_errs | static
ERR_MSP_SECURITY_DELETEGROUP | ms_errs | static
ERR_MSP_SECURITY_DELUSER | ms_errs | static
ERR_MSP_SECURITY_DIFFERENTIPADDR | ms_errs | static
ERR_MSP_SECURITY_DISABLE_ADMIN | ms_errs | static
ERR_MSP_SECURITY_DUPE_GROUP_ID | ms_errs | static
ERR_MSP_SECURITY_DUPE_GROUP_NAME | ms_errs | static
ERR_MSP_SECURITY_DUPE_GROUP_NAME_U | ms_errs | static
ERR_MSP_SECURITY_DUPE_USER_ID | ms_errs | static
ERR_MSP_SECURITY_DUPE_USER_NAME | ms_errs | static
ERR_MSP_SECURITY_DUPE_USER_NAME_U | ms_errs | static
ERR_MSP_SECURITY_FAIL_LOAD_GROUP | ms_errs | static
ERR_MSP_SECURITY_FAIL_LOAD_SEC | ms_errs | static
ERR_MSP_SECURITY_FAIL_LOAD_USER | ms_errs | static
ERR_MSP_SECURITY_FAIL_SAVE_SEC | ms_errs | static
ERR_MSP_SECURITY_FAILGETINTEGRA | ms_errs | static
ERR_MSP_SECURITY_FAILGETINTEGRAURL | ms_errs | static
ERR_MSP_SECURITY_GETALLGROUPIDS | ms_errs | static
ERR_MSP_SECURITY_GETALLUSERIDS | ms_errs | static
ERR_MSP_SECURITY_GETGROUPFAIL | ms_errs | static
ERR_MSP_SECURITY_GETGROUPFROMIDFAIL | ms_errs | static
ERR_MSP_SECURITY_GETGROUPFROMIDOK | ms_errs | static
ERR_MSP_SECURITY_GETGROUPOK | ms_errs | static
ERR_MSP_SECURITY_GETINTEGRAUSERS1 | ms_errs | static
ERR_MSP_SECURITY_GETINTEGRAUSERS2 | ms_errs | static
ERR_MSP_SECURITY_GETINTEGRAUSERS3 | ms_errs | static
ERR_MSP_SECURITY_GETPERMTASKSFAIL | ms_errs | static
ERR_MSP_SECURITY_GETPERMTASKSOK | ms_errs | static
ERR_MSP_SECURITY_GETUSERFAIL | ms_errs | static
ERR_MSP_SECURITY_GETUSERFROMIDFAIL | ms_errs | static
ERR_MSP_SECURITY_GETUSERFROMIDOK | ms_errs | static
ERR_MSP_SECURITY_GETUSEROK | ms_errs | static
ERR_MSP_SECURITY_GROUPID_NOT_FOUND | ms_errs | static
ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND | ms_errs | static
ERR_MSP_SECURITY_INTEGRACONNFORMAT | ms_errs | static
ERR_MSP_SECURITY_INTEGRAINVALIDCO | ms_errs | static
ERR_MSP_SECURITY_INTEGRAINVALIDPW | ms_errs | static
ERR_MSP_SECURITY_INVALID_SESSION_ID | ms_errs | static
ERR_MSP_SECURITY_INVALIDPASSWORD | ms_errs | static
ERR_MSP_SECURITY_INVALIDSESSION | ms_errs | static
ERR_MSP_SECURITY_INVALIDUSER | ms_errs | static
ERR_MSP_SECURITY_LOADINGSESS | ms_errs | static
ERR_MSP_SECURITY_LOADSESSIONFILE | ms_errs | static
ERR_MSP_SECURITY_MISSINGSESSIONFILE | ms_errs | static
ERR_MSP_SECURITY_MSSESSCOOKIE | ms_errs | static
ERR_MSP_SECURITY_MSSESSINTEGRA | ms_errs | static
ERR_MSP_SECURITY_MSSESSIONCTOR | ms_errs | static
ERR_MSP_SECURITY_MSSESSLOGIN | ms_errs | static
ERR_MSP_SECURITY_MSSESSRESULTSPERM | ms_errs | static
ERR_MSP_SECURITY_NO_GUEST_PWD | ms_errs | static
ERR_MSP_SECURITY_NO_INTEGRA_LOGIN | ms_errs | static
ERR_MSP_SECURITY_NO_RIGHTS_UPD_USR | ms_errs | static
ERR_MSP_SECURITY_NOCREATEGUEST | ms_errs | static
ERR_MSP_SECURITY_NOSAVEPARAMS | ms_errs | static
ERR_MSP_SECURITY_NOT_ADMIN_SESSION | ms_errs | static
ERR_MSP_SECURITY_NOT_ENABLED | ms_errs | static
ERR_MSP_SECURITY_NOT_INTEGRA_USER | ms_errs | static
ERR_MSP_SECURITY_NOTLOGGEDIN | ms_errs | static
ERR_MSP_SECURITY_NOTNORMALUSER | ms_errs | static
ERR_MSP_SECURITY_OLD_PW_INVALID | ms_errs | static
ERR_MSP_SECURITY_PASSWORD_TOO_SHORT | ms_errs | static
ERR_MSP_SECURITY_PASSWORDEXPIRED | ms_errs | static
ERR_MSP_SECURITY_SAMEPASSWORD | ms_errs | static
ERR_MSP_SECURITY_SAVESESSIONFILE | ms_errs | static
ERR_MSP_SECURITY_SESSIONDESTROYED | ms_errs | static
ERR_MSP_SECURITY_SPOOFATTEMPT1 | ms_errs | static
ERR_MSP_SECURITY_SPOOFATTEMPT2 | ms_errs | static
ERR_MSP_SECURITY_SPOOFATTEMPT3 | ms_errs | static
ERR_MSP_SECURITY_SPOOFATTEMPT4 | ms_errs | static
ERR_MSP_SECURITY_TIMEDOUT | ms_errs | static
ERR_MSP_SECURITY_UPDATEALLSESSFILES | ms_errs | static
ERR_MSP_SECURITY_UPDATEGROUP | ms_errs | static
ERR_MSP_SECURITY_UPDATEPW | ms_errs | static
ERR_MSP_SECURITY_UPDATESESS | ms_errs | static
ERR_MSP_SECURITY_UPDATEUSER | ms_errs | static
ERR_MSP_SECURITY_USERID_NOT_FOUND | ms_errs | static
ERR_MSP_SECURITY_USERNAME_NOT_FOUND | ms_errs | static
ERR_MSP_SECURITY_VALIDATEINTEGRACO1 | ms_errs | static
ERR_MSP_SECURITY_VALIDATEINTEGRACO2 | ms_errs | static
ERR_MSP_SECURITY_VALIDATEINTEGRAPW1 | ms_errs | static
ERR_MSP_SECURITY_VALIDATEINTEGRAPW2 | ms_errs | static
ERR_MSP_SECURITY_VALIDATEINTEGRAPW3 | ms_errs | static
ERR_MSP_SESSION_UTIME_FAIL | ms_errs | static
ERR_MSP_SL_SCORING_MODEL_FAIL | ms_errs | static
ERR_MSP_SL_SCORING_MODEL_WARN | ms_errs | static
ERR_MSP_SPECIFY_UNAVAILABLE_PROCESSOR | ms_errs | static
ERR_MSP_SYSMP_FAIL | ms_errs | static
ERR_MSP_TARGET_FDR_FAILED_FOR_ET | ms_errs | static
ERR_MSP_TARGET_FDR_FAILED_FOR_FIRST_PASS | ms_errs | static
ERR_MSP_TAXONOMY_CONFLICT_PARENTS | ms_errs | static
ERR_MSP_TAXONOMY_DEFINITION_END | ms_errs | static
ERR_MSP_TAXONOMY_INVALID_NODE_FILE | ms_errs | static
ERR_MSP_TAXONOMY_MISSING_NODE_FILE | ms_errs | static
ERR_MSP_TAXONOMY_NO_COMMAS | ms_errs | static
ERR_MSP_TAXONOMY_NO_TITLE | ms_errs | static
ERR_MSP_TAXONOMY_WRONG_LINE | ms_errs | static
ERR_MSP_TOO_MANY_MODS_IN_MOD_FILE | ms_errs | static
ERR_MSP_TOO_MANY_PROCESSORS | ms_errs | static
ERR_MSP_TOO_MANY_TH_PROCESSORS | ms_errs | static
ERR_MSP_UMOD_FAILEDLOAD | ms_errs | static
ERR_MSP_UMOD_FAILEDSAVE | ms_errs | static
ERR_MSP_UNEXPECTED_LINE_OUT_OF_SECT | ms_errs | static
ERR_MSP_WRONG_ICAT_FILTER | ms_errs | static
ERR_MSP_WRONG_MOD_VECTOR | ms_errs | static
ERR_MSP_WWW_SECTION | ms_errs | static
ERR_MSP_XHUNTER_WRONG_FORMAT | ms_errs | static
ERR_MSP_XML_ELEMENT_NOT_FOUND | ms_errs | static
ERR_MSP_XML_FAILEDLOAD | ms_errs | static
ERR_MSP_XML_FAILEDSAVE | ms_errs | static
ERR_MSP_XML_FIELD_NOTFOUND | ms_errs | static
ERR_MSP_XML_INVALID_FIELD_FORMAT | ms_errs | static
ERR_MSP_XML_LOCAL_SCHEMA_NOT_STORED | ms_errs | static
ERR_MSP_XML_MEMORY_ERROR | ms_errs | static
ERR_MSP_XML_NO_ROOT_ELEMENT | ms_errs | static
ERR_MSP_XML_SYSTEM_FAILED | ms_errs | static
ERR_MSP_XML_TABLE_NOTFOUND | ms_errs | static
ERR_MSP_XMLSCHEMA_FAILEDLOAD | ms_errs | static
ERR_MSP_XMLSCHEMA_FAILEDSAVE | ms_errs | static
ERR_MSP_ZIP_BUFTOOSMALL | ms_errs | static
ERR_MSP_ZIP_COMPRESSEDDATATOOLONG | ms_errs | static
ERR_MSP_ZIP_ENDIAN | ms_errs | static
ERR_MSP_ZIP_INVALID_STREAMING_MODE | ms_errs | static
ERR_MSP_ZIP_INVALIDDATA | ms_errs | static
ERR_MSP_ZIP_LENGTHDIFFERS | ms_errs | static
ERR_MSP_ZIP_NOTSTREAMING | ms_errs | static
ERR_MSP_ZIP_OUTOFMEMORY | ms_errs | static
ERR_MSP_ZIP_STREAMERROR | ms_errs | static
ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG | ms_errs | static
ERR_MSP_ZIP_UNKNOWN | ms_errs | static
ERR_MSP_ZIP_VERSIONERROR | ms_errs | static
ERR_MSP_ZIP_ZEROLENGTH | ms_errs | static
ERR_NEED_64_BIT | ms_errs | static
ERR_NO_ERR_TOL_PARENT | ms_errs | static
ERR_NO_ERROR | ms_errs | static
ERR_NO_UNIGENE_FILE | ms_errs | static
ERR_NOMEM | ms_errs | static
ERR_NOSUCHFILE | ms_errs | static
ERR_NULL_ACC_PEP_SUM | ms_errs | static
ERR_NULL_ACC_PROT_SUM | ms_errs | static
ERR_OLDRESULTSFILE | ms_errs | static
ERR_PEPSUMMPEPGET | ms_errs | static
ERR_PEPTIDESTR | ms_errs | static
ERR_PROTSUMM | ms_errs | static
ERR_PROTSUMMPEP | ms_errs | static
ERR_QUERYOUTOFRANGE | ms_errs | static
ERR_READINGFILE | ms_errs | static
ERR_RESFILE_FUTURE_VERSION | ms_errs | static
ERR_RESFILE_INVALID_DB_TYPE | ms_errs | static
ERR_RESFILE_LINKED_SITES | ms_errs | static
ERR_RESFILE_LOOPLINKED_SITES | ms_errs | static
ERR_RESFILE_MISSING_QEXP | ms_errs | static
ERR_RESULTS_NOT_CREATED | ms_errs | static
ERR_UNASSIGNED_PROG | ms_errs | static
ERR_UNASSIGNED_RANGE | ms_errs | static
ERR_UNASSIGNED_UNK | ms_errs | static
ERR_UNIGENE_MULTIDB | ms_errs | static
ERR_WRITE_CDB_FILE | ms_errs | static
forwardToParentInstance(ms_errs *parent) | ms_errs |
getCombineRepeats() const | ms_errs |
getErrorNumber(const int num=-1) const | ms_errs |
getErrorRepeats(const int num=-1) const | ms_errs |
getErrorSeverity(const int num=-1) const | ms_errs |
getErrorString(const int num) const | ms_errs |
getLastError() const | ms_errs |
getLastErrorString() const | ms_errs |
getLoggingFileName() const | ms_errs |
getLoggingLevel() const | ms_errs | virtual
getMessageSource(const ms_log::msg_num_t msgNum) const | ms_log |
getNumberOfErrors() const | ms_errs |
isValid() const | ms_errs |
LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED | ms_log | static
LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES | ms_log | static
LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE | ms_log | static
LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE | ms_log | static
LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES | ms_log | static
LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE | ms_log | static
LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER | ms_log | static
LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK | ms_log | static
LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK | ms_log | static
LOGMSG_AAHELPER_CFR_MASSES_VALUE | ms_log | static
LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE | ms_log | static
LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS | ms_log | static
LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT | ms_log | static
LOGMSG_AAHELPER_CFR_START_FRAGMENTS | ms_log | static
LOGMSG_AAHELPER_CROSSLINKED_END | ms_log | static
LOGMSG_AAHELPER_CROSSLINKED_START | ms_log | static
LOGMSG_AAHELPER_CUMULATIVE_MASS_NL | ms_log | static
LOGMSG_AAHELPER_ETMOD_LOOKUP | ms_log | static
LOGMSG_AAHELPER_IMMONIUM_ION_ADD | ms_log | static
LOGMSG_AAHELPER_IMMONIUM_ION_REJECT | ms_log | static
LOGMSG_AAHELPER_INTERNAL_ION_ADD | ms_log | static
LOGMSG_AAHELPER_INTERNAL_ION_REJECT | ms_log | static
LOGMSG_AAHELPER_MASTER_NL_VALS | ms_log | static
LOGMSG_AAHELPER_MULTINL_INDICES | ms_log | static
LOGMSG_AAHELPER_REGULAR_ION_ADD | ms_log | static
LOGMSG_AAHELPER_REGULAR_ION_REJECT | ms_log | static
LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD | ms_log | static
LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT | ms_log | static
LOGMSG_AAHELPER_SERIES_PARAMS | ms_log | static
LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG | ms_log | static
LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT | ms_log | static
LOGMSG_AAHELPER_TOTAL_NL_VALS | ms_log | static
LOGMSG_CUSTQUANT_ADD_QUANT_KEY | ms_log | static
LOGMSG_CUSTQUANT_REMOVE_ALL_KEY | ms_log | static
LOGMSG_CUSTQUANT_REMOVE_KEY | ms_log | static
LOGMSG_DBG1_NUM_PROCESSOR_GROUPS | ms_log | static
LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS | ms_log | static
LOGMSG_DBG2_CPU_INF_GETAUTODETECT | ms_log | static
LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS | ms_log | static
LOGMSG_DBG2_CPU_INF_MT_NAME | ms_log | static
LOGMSG_DBG2_CPU_INF_MT_STATUS | ms_log | static
LOGMSG_DBG2_CPU_INF_NAME | ms_log | static
LOGMSG_DBG2_CPU_INF_NUM_AVAIL | ms_log | static
LOGMSG_DBG2_CPU_INF_NUM_GROUPS | ms_log | static
LOGMSG_DBG2_CPU_INF_NUM_ON_SYS | ms_log | static
LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL | ms_log | static
LOGMSG_DBG2_CPU_INF_PROC_AFFINITY | ms_log | static
LOGMSG_DBG2_CPU_INF_TABLE_LINE | ms_log | static
LOGMSG_DBG2_CPU_INF_TABLE_TITLE | ms_log | static
LOGMSG_DBG2_CPU_INF_USE_PROCESSES | ms_log | static
LOGMSG_DBG2_NUM_CONFIG_MISMATCH | ms_log | static
LOGMSG_DBG2_NUM_ONLINE_MISMATCH | ms_log | static
LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD | ms_log | static
LOGMSG_DBG3_BINDING_PROCESSORS | ms_log | static
LOGMSG_DBG3_BINDING_THREAD | ms_log | static
LOGMSG_DBG3_CALL_GET_CHIP_MFCTR | ms_log | static
LOGMSG_DBG3_HWLOC_GROUPS | ms_log | static
LOGMSG_DBG3_HWLOC_TREE | ms_log | static
LOGMSG_DBG3_PROCESSOR_NAME | ms_log | static
LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND | ms_log | static
LOGMSG_GET_THR_LOOP_BODY_START | ms_log | static
LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT | ms_log | static
LOGMSG_GET_THR_REACH_COND | ms_log | static
LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET | ms_log | static
LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR | ms_log | static
LOGMSG_HTTP_GETRETURNSTRING | ms_log | static
LOGMSG_HTTP_MAXCONECTIONS10FAILED | ms_log | static
LOGMSG_HTTP_MAXCONECTIONSFAILED | ms_log | static
LOGMSG_HTTP_QUERYSTATUSRESULT | ms_log | static
LOGMSG_HTTP_URLSTRING | ms_log | static
LOGMSG_INST_ADDINGDATABASE | ms_log | static
LOGMSG_INST_ADDOPTIONSSECTION | ms_log | static
LOGMSG_INST_APPENDPARSERULE | ms_log | static
LOGMSG_INST_APPENDTAXONOMY | ms_log | static
LOGMSG_INST_CHANGEDBTAXONOMY | ms_log | static
LOGMSG_INST_CHANGEPARSERULE | ms_log | static
LOGMSG_INST_CHANGEPERCOLATORFEATS | ms_log | static
LOGMSG_INST_CHANGEPERCOLATORUSERT | ms_log | static
LOGMSG_INST_CHANGEPROTFAMILYSWITCH | ms_log | static
LOGMSG_INST_CHANGERESULTSCACHE | ms_log | static
LOGMSG_INST_CHANGESPLITDATAFILESIZE | ms_log | static
LOGMSG_INST_CHANGESPLITNUMOFQUERIES | ms_log | static
LOGMSG_INST_CLUSTERSECTION | ms_log | static
LOGMSG_INST_FAILSAVEPOSTINSTALLFILE | ms_log | static
LOGMSG_INST_LOGICALPERPHYSICALCPU | ms_log | static
LOGMSG_INST_MASCOTDATOK | ms_log | static
LOGMSG_INST_NOSUBCLUSTERSET | ms_log | static
LOGMSG_INST_NOTMASCOTDATOK | ms_log | static
LOGMSG_INST_NUMTHREADS | ms_log | static
LOGMSG_INST_REMOVEOPTIONSSECTION | ms_log | static
LOGMSG_INST_SAVEDPOSTINSTALLFILE | ms_log | static
LOGMSG_INST_SETOPTIONSSECTION | ms_log | static
LOGMSG_MATRIX_OUTPUT_VALS | ms_log | static
LOGMSG_MSR2DAT28_SQL_TRACING | ms_log | static
LOGMSG_NON_DEFAULT_HOMOLOGY_THRESHOLD | ms_log | static
LOGMSG_PEPSUM_GETHIT | ms_log | static
LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP | ms_log | static
LOGMSG_PROTINFER_CHOOSE_NEXT_START | ms_log | static
LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY | ms_log | static
LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST | ms_log | static
LOGMSG_PROTINFER_CLUSTER_FROM_ACC | ms_log | static
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO | ms_log | static
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT | ms_log | static
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST | ms_log | static
LOGMSG_PROTINFER_FIND_FAMILY_END | ms_log | static
LOGMSG_PROTINFER_FIND_FAMILY_QUEUE | ms_log | static
LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS | ms_log | static
LOGMSG_PROTINFER_FIND_FAMILY_START | ms_log | static
LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END | ms_log | static
LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START | ms_log | static
LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_START | ms_log | static
LOGMSG_PROTINFER_GROUP_FROM_ACC | ms_log | static
LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY | ms_log | static
LOGMSG_PROTINFER_PEPTIDE_MATRIX | ms_log | static
LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD | ms_log | static
LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP | ms_log | static
LOGMSG_PROTINFER_REMOVE_CONFLICTING_START | ms_log | static
LOGMSG_PROTINFER_SINGLETON_FROM_ACC | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_DONE | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_START | ms_log | static
LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT | ms_log | static
LOGMSG_QUANT_ADDED_PROTEIN_HIT | ms_log | static
LOGMSG_QUANT_ADDING_PROTEIN_HIT | ms_log | static
LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED | ms_log | static
LOGMSG_QUANT_CLOSING_CACHE_FILE | ms_log | static
LOGMSG_QUANT_EXCLUDING_PEPTIDE | ms_log | static
LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN | ms_log | static
LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN | ms_log | static
LOGMSG_QUANT_FINISH_CALC_COMPLETE | ms_log | static
LOGMSG_QUANT_FINISH_LOAD_CDB | ms_log | static
LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE | ms_log | static
LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES | ms_log | static
LOGMSG_QUANT_HELPER_TEST_REQUIRED | ms_log | static
LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES | ms_log | static
LOGMSG_QUANT_LOADING_MATCHES | ms_log | static
LOGMSG_QUANT_MERGE_COMPONENT_DUPE_FI | ms_log | static
LOGMSG_QUANT_MERGE_COMPONENT_INCONSIST | ms_log | static
LOGMSG_QUANT_MERGE_COMPONENT_SUCCESS | ms_log | static
LOGMSG_QUANT_OPENING_CACHE_FILE | ms_log | static
LOGMSG_QUANT_REAPPLY_THRESHOLDS | ms_log | static
LOGMSG_QUANT_REMATCHING_INFERRED | ms_log | static
LOGMSG_QUANT_REMOVE_INFERRED_MATCH | ms_log | static
LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE | ms_log | static
LOGMSG_QUANT_RT_OFFSET_LOOKUP | ms_log | static
LOGMSG_QUANT_START_CALC_COMPLETE | ms_log | static
LOGMSG_QUANT_START_LOAD_CDB | ms_log | static
LOGMSG_QUANT_START_REORDER_AFTER_MERGE | ms_log | static
LOGMSG_QUANT_START_UPDATE_PROT_MATCHES | ms_log | static
LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE | ms_log | static
LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE1 | ms_log | static
LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES | ms_log | static
LOGMSG_QUANT_UPDATING_PEP_EVIDENCE | ms_log | static
LOGMSG_REPORT_FUNCTION_CALLED_BY | ms_log | static
LOGMSG_REPORT_FUNCTION_ENTRY | ms_log | static
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 | ms_log | static
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 | ms_log | static
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 | ms_log | static
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 | ms_log | static
LOGMSG_REPORT_FUNCTION_EXIT | ms_log | static
LOGMSG_REPORT_FUNCTION_EXIT_WITH | ms_log | static
LOGMSG_RESFILE_APPEND | ms_log | static
ms_errs(msg_sev loglevel=sev_warn, bool combineRepeats=true, ms_loggingmonitor::Source_e api=ms_loggingmonitor::SRC_MSPARSER) | ms_errs |
ms_log() | ms_log |
msg_num_t typedef | ms_log |
msg_sev enum name | ms_log |
setAPI(ms_loggingmonitor::Source_e api) | ms_errs |
setCombineRepeats(const bool flag) | ms_errs |
setLoggingFile(const std::string filename, const msg_sev level) | ms_errs |
setLoggingLevel(const msg_sev level) | ms_errs |
sev_debug1 enum value | ms_log |
sev_debug2 enum value | ms_log |
sev_debug3 enum value | ms_log |
sev_fatal enum value | ms_log |
sev_info enum value | ms_log |
sev_warn enum value | ms_log |
willMessageBeLogged(const ms_errs::err errorNum) const | ms_errs |
~ms_errs() | ms_errs | virtual
~ms_log() | ms_log | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_file_logger
ms_file_logger Member List

This is the complete list of members for ms_file_logger, including all inherited members.

COL_ASC_TIME enum value | ms_logger |
COL_HEADERS enum value | ms_logger |
COL_IP_ADDRESS enum value | ms_logger |
COL_ISO8601_TIME enum value | ms_logger |
COL_LOGGER_DEFAULTS enum value | ms_logger |
COL_MSG enum value | ms_logger |
COL_MSG_NUM_DEC enum value | ms_logger |
COL_MSG_NUM_HEX enum value | ms_logger |
COL_MSG_SOURCE_TXT enum value | ms_logger |
COL_QUOTES enum value | ms_logger |
COL_SEVERITY_NUM enum value | ms_logger |
COL_SEVERITY_TXT enum value | ms_logger |
COL_SRC_FILE enum value | ms_logger |
COL_SRC_LINENUM enum value | ms_logger |
COL_THREAD_ID enum value | ms_logger |
COL_TSV enum value | ms_logger |
formatMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const | ms_logger |
getColsToOutput() const | ms_logger | virtual
getHeaderLine() const | ms_logger |
getLogFilename() | ms_file_logger |
LogOutputColumns_e enum name | ms_logger |
ms_file_logger(const std::string logFileName, unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS) | ms_file_logger |
ms_logger(const unsigned int colsToOutput=COL_MSG) | ms_logger |
onLogMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) | ms_file_logger | virtual
setColsToOutput(const unsigned int colsToOutput) | ms_logger | virtual
~ms_file_logger() | ms_file_logger | virtual
~ms_logger() | ms_logger | inlinevirtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_fileutilities
ms_fileutilities Member List

This is the complete list of members for ms_fileutilities, including all inherited members.

CMD_ARGUMENT_PARSE_COLLISION enum value | ms_fileutilities |
CMD_ARGUMENT_PARSE_INVALIDCHAR enum value | ms_fileutilities |
CMD_ARGUMENT_PARSE_OK enum value | ms_fileutilities |
CMD_ARGUMENT_PARSE_RESULT enum name | ms_fileutilities |
CMD_ARGUMENT_PARSE_UNBALANCED enum value | ms_fileutilities |
CMPXML_IGN_COL_SIZE_EQ_ONE enum value | ms_fileutilities |
CMPXML_IGN_DBL_DIFF_100_PPM enum value | ms_fileutilities |
CMPXML_IGN_DBL_DIFF_10_PPM enum value | ms_fileutilities |
CMPXML_IGN_DBL_DIFF_1_PPM enum value | ms_fileutilities |
CMPXML_IGN_DBL_IDENTICAL enum value | ms_fileutilities |
CMPXML_IGN_FILE_URL enum value | ms_fileutilities |
CMPXML_IGN_INF_999999 enum value | ms_fileutilities |
CMPXML_IGN_RAWFILE_NAME enum value | ms_fileutilities |
CMPXML_IGN_TODAY_DATE enum value | ms_fileutilities |
CMPXML_NO_FLAG enum value | ms_fileutilities |
CMPXML_STRIP_TRAILING_ZEROS enum value | ms_fileutilities |
compareXmlFiles(const std::string &filePath1, const std::string &filePath2, const std::string &schemaPath, const int flags, const std::vector< std::string > &ignoreElements, const std::vector< std::string > &ignoreAttributes, ms_errs &errs, std::string &differences, std::string &lhsOnly, std::string &rhsOnly) | ms_fileutilities | static
compareXMLFiles_flags enum name | ms_fileutilities |
createDirectory(const std::string &directory, std::string &errorDirectory) | ms_fileutilities | static
deleteDirectory(const std::string &directory, const bool bDeleteSubdirectories=true) | ms_fileutilities | static
doesFileExist(const char *filename) | ms_fileutilities | static
err_sar enum name | ms_fileutilities |
findClose() | ms_fileutilities |
findMascotDat(const char *szMascotDatFilename, ms_errs *err=NULL, const int timeoutSec=0) | ms_fileutilities | static
findNext(std::string &fileName) | ms_fileutilities |
findOpen(const std::string directory, const std::string wildcard) | ms_fileutilities |
getFileSize(const char *filename, ms_errs *err=NULL) | ms_fileutilities | static
getLastModificationTime(const char *filename, ms_errs *err=NULL) | ms_fileutilities | static
getMD5Sum(const std::string &str, const bool b32bitEncoding=true) | ms_fileutilities | static
getSARExtendedErrorCode() const | ms_fileutilities |
isDirectory(const char *path) | ms_fileutilities | static
isFileWritable(const char *filePath) | ms_fileutilities | static
ms_fileutilities() | ms_fileutilities |
parseCommandLineArgumentString(const std::string &command, std::vector< std::string > &components) | ms_fileutilities | static
SAR_FAIL_CHMOD enum value | ms_fileutilities |
SAR_FAIL_CHOWN enum value | ms_fileutilities |
SAR_FAIL_GET_NAMED_SECURITY_INFO enum value | ms_fileutilities |
SAR_FAIL_SET_ENTRIES_IN_ACL enum value | ms_fileutilities |
SAR_FAIL_SET_NAMED_SECURITY_INFO enum value | ms_fileutilities |
SAR_SUCCESS enum value | ms_fileutilities |
setAccessRights(const char *filename, const bool bWrite, const bool bExecute, const bool isFile, const ms_mascotoptions &Options, const bool avoid_reapply=false) | ms_fileutilities |
setLastModificationTime(const char *filename, time_t modificationTime, ms_errs *err=NULL) | ms_fileutilities | static
stripLastFolder(const std::string pathname) | ms_fileutilities | static
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_fitexy_result
ms_fitexy_result Member List

This is the complete list of members for ms_fitexy_result, including all inherited members.

getA() const | ms_fitexy_result
getB() const | ms_fitexy_result
getChi2() const | ms_fitexy_result
getQ() const | ms_fitexy_result
getSigmaA() const | ms_fitexy_result
getSigmaB() const | ms_fitexy_result
getSigmaX() const | ms_fitexy_result
getSigmaY() const | ms_fitexy_result
ms_fitexy_result() | ms_fitexy_result
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_fragment
ms_fragment Member List

This is the complete list of members for ms_fragment, including all inherited members.

clearMatchedIon() | ms_fragment
copyFrom(const ms_fragment *src) | ms_fragment
getAllMatchedIons(std::vector< double > &masses, std::vector< double > &intensities) const | ms_fragment
getCharge() const | ms_fragment
getColumn() const | ms_fragment
getEnd() const | ms_fragment
getLabel(const LABEL_FORMAT fmt=LABEL_FORMAT_TRADITIONAL) const | ms_fragment
getMass() const | ms_fragment
getMatchedIonIntensity() const | ms_fragment
getMatchedIonMass() const | ms_fragment
getNeutralLoss() const | ms_fragment
getPeptideSubstring() const | ms_fragment
getSeriesName() const | ms_fragment
getStart() const | ms_fragment
isCTerminal() const | ms_fragment
isFromAlpha() const | ms_fragment
isFromBeta() const | ms_fragment
isImmonium() const | ms_fragment
isInternal() const | ms_fragment
isNTerminal() const | ms_fragment
isPrecursorNL() const | ms_fragment
isRegular() const | ms_fragment
LABEL_FORMAT enum name | ms_fragment
LABEL_FORMAT_PEPTIDE_VIEW enum value | ms_fragment
LABEL_FORMAT_TRADITIONAL enum value | ms_fragment
ms_fragment() | ms_fragment
ms_fragment(const ms_fragment &src) | ms_fragment
ms_fragment(const int seriesID, const double massValue, const double nlValue, const int col, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const ms_peptide::PSM psmComponent, const int seriesID, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const char *seriesName, const double massValue, const double nlValue, const int col, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const ms_peptide::PSM psmComponent, const char *seriesName, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const int seriesID, const double massValue, const double nlValue, const char *peptideStr, const int startPos, const int endPos, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const ms_peptide::PSM psmComponent, const int seriesID, const double massValue, const double nlValue, const char *peptideStr, const int startPos, const int endPos, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const char residueName, const double massValue, const double nlValue, const int col=-1, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const ms_peptide::PSM psmComponent, const char residueName, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const double massValue, const double nlValue, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
operator=(const ms_fragment &right) | ms_fragment
setMatchedIon(const double mass, const double intensity) | ms_fragment
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_fragmentationrules
ms_fragmentationrules Member List

This is the complete list of members for ms_fragmentationrules, including all inherited members.

anyNLseriesUsed(const int series) const | ms_fragmentationrules |
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty |
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty |
clearSeries() | ms_fragmentationrules |
copyFrom(const ms_fragmentationrules *right) | ms_fragmentationrules |
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty |
defaultValues() | ms_fragmentationrules |
delNonEmpty() | ms_customproperty |
delProp(const char *name) | ms_customproperty |
delPropByNumber(const int index) | ms_customproperty |
delPropStart(const char *nameBeginning) | ms_customproperty |
findProperty(const char *name, const int startFrom=0) const | ms_customproperty |
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty |
FRAG_A_MINUS_H2O enum value | ms_fragmentationrules |
FRAG_A_MINUS_NH3 enum value | ms_fragmentationrules |
FRAG_A_SERIES enum value | ms_fragmentationrules |
FRAG_B_MINUS_H2O enum value | ms_fragmentationrules |
FRAG_B_MINUS_NH3 enum value | ms_fragmentationrules |
FRAG_B_SERIES enum value | ms_fragmentationrules |
FRAG_C_SERIES enum value | ms_fragmentationrules |
FRAG_D_SERIES enum value | ms_fragmentationrules |
FRAG_IMMONIUM enum value | ms_fragmentationrules |
FRAG_INTERNAL_YA enum value | ms_fragmentationrules |
FRAG_INTERNAL_YB enum value | ms_fragmentationrules |
FRAG_SERIES_TYPE enum name | ms_fragmentationrules |
FRAG_V_SERIES enum value | ms_fragmentationrules |
FRAG_W_SERIES enum value | ms_fragmentationrules |
FRAG_X_SERIES enum value | ms_fragmentationrules |
FRAG_Y_MINUS_H2O enum value | ms_fragmentationrules |
FRAG_Y_MINUS_NH3 enum value | ms_fragmentationrules |
FRAG_Y_SERIES enum value | ms_fragmentationrules |
FRAG_Z_PLUS_1 enum value | ms_fragmentationrules |
FRAG_Z_PLUS_2 enum value | ms_fragmentationrules |
FRAG_Z_SERIES enum value | ms_fragmentationrules |
getDefaultDelimiter() const | ms_customproperty |
getDelimiterByNumber(const int index) const | ms_customproperty |
getFirstSerie() | ms_fragmentationrules | static
getFirstSeries() | ms_fragmentationrules | static
getLastSerie() | ms_fragmentationrules | static
getLastSeries() | ms_fragmentationrules | static
getMaxInternalMass() const | ms_fragmentationrules |
getMinInternalMass() const | ms_fragmentationrules |
getNumberOfProperties() const | ms_customproperty |
getPreceedingComments() const | ms_customproperty |
getPropertyName(const int index) const | ms_customproperty |
getPropValStringByName(const char *name) const | ms_customproperty |
getPropValStringByNumber(const int index) const | ms_customproperty |
getSeriesDescription(const int series) | ms_fragmentationrules | static
getSeriesName(const int series) | ms_fragmentationrules | static
getTitle() const | ms_fragmentationrules |
getTotalSeriesOutput() | ms_fragmentationrules | static
isBackboneSeries(const int series) | ms_fragmentationrules | static
isCharged2Plus() const | ms_fragmentationrules |
isCharged3Plus() const | ms_fragmentationrules |
isNeutralLossSeries(const int series) | ms_fragmentationrules | static
isSeriesUsed(const int series) const | ms_fragmentationrules |
isSinglyCharged() const | ms_fragmentationrules |
isValid() const | ms_fragmentationrules |
ms_customproperty() | ms_customproperty |
ms_fragmentationrules() | ms_fragmentationrules |
ms_fragmentationrules(const ms_fragmentationrules &src) | ms_fragmentationrules |
operator=(const ms_fragmentationrules &right) | ms_fragmentationrules |
setCharged2Plus(const bool value) | ms_fragmentationrules |
setCharged3Plus(const bool value) | ms_fragmentationrules |
setDefaultDelimiter(const char *delim) | ms_customproperty |
setMaxInternalMass(const double mass) | ms_fragmentationrules |
setMinInternalMass(const double mass) | ms_fragmentationrules |
setPreceedingComments(const std::string &comments) | ms_customproperty |
setPropertyName(const int index, const char *name) | ms_customproperty |
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty |
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty |
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty |
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty |
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty |
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty |
setPropValStringByNumber(const int index, const char *value) | ms_customproperty |
setSeriesUsed(const int series, const bool val) | ms_fragmentationrules |
setSinglyCharged(const bool value) | ms_fragmentationrules |
setTitle(const char *title) | ms_fragmentationrules |
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty |
verifyRule(ms_errs *err_, const bool tryToFix) | ms_fragmentationrules |
~ms_customproperty() | ms_customproperty |
~ms_fragmentationrules() | ms_fragmentationrules |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_fragmentvector
ms_fragmentvector Member List

This is the complete list of members for ms_fragmentvector, including all inherited members.

addExperimentalData(const std::string &peakList, const int numPeaks, const double tolerance, const std::string &toleranceUnits, const bool updateMatchList=true) | ms_fragmentvector |
addExperimentalData(const ms_mascotresfilebase *resfile, const int query, const int flags=MATCH_MOST_INTENSE_PEAK, const int peaksUsedFromIons1=-1, const int peaksUsedFromIons2=-1, const int peaksUsedFromIons3=-1) | ms_fragmentvector |
addExperimentalData(const peaklist_t &peakList, const double tolerance, const std::string &toleranceUnits, const bool updateMatchList=true) | ms_fragmentvector |
appendFragment(const ms_fragment *item) | ms_fragmentvector |
clearFragments() | ms_fragmentvector |
copyFrom(const ms_fragmentvector *right) | ms_fragmentvector |
getFragmentByNumber(const unsigned int numFrag) const | ms_fragmentvector |
getMassesWithinTolerance(const double mass, const double toleranceValue, const TOLERANCE_UNIT toleranceUnit, double &minMass, double &maxMass) | ms_fragmentvector | static
getNumberOfFragments() const | ms_fragmentvector |
getVector() | ms_fragmentvector |
getVector() const | ms_fragmentvector |
MATCH_CLOSEST_PEAK enum value | ms_fragmentvector |
MATCH_MOST_INTENSE_PEAK enum value | ms_fragmentvector |
MATCH_PEAKS enum name | ms_fragmentvector |
ms_fragmentvector() | ms_fragmentvector |
ms_fragmentvector(const ms_fragmentvector &src) | ms_fragmentvector |
operator=(const ms_fragmentvector &right) | ms_fragmentvector |
TOLERANCE_DALTON enum value | ms_fragmentvector |
TOLERANCE_MMU enum value | ms_fragmentvector |
TOLERANCE_PERCENT enum value | ms_fragmentvector |
TOLERANCE_PPM enum value | ms_fragmentvector |
TOLERANCE_UNIT enum name | ms_fragmentvector |
~ms_fragmentvector() | ms_fragmentvector | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_fragrulesfile
ms_fragrulesfile Member List

This is the complete list of members for ms_fragrulesfile, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
appendInstrument(const ms_fragmentationrules *item) | ms_fragrulesfile
clearAllErrors() | ms_errors
clearInstruments() | ms_fragrulesfile
copyFrom(const ms_fragrulesfile *right) | ms_fragrulesfile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_fragrulesfile
deleteInstrumentByName(const char *name) | ms_fragrulesfile
deleteInstrumentByNumber(const int num) | ms_fragrulesfile
getConnectionSettings() const | ms_fragrulesfile
getErrorHandler() const | ms_errors
getFileName() const | ms_fragrulesfile
getInstrumentByName(const char *name) const | ms_fragrulesfile
getInstrumentByNumber(const int instrumentNum) const | ms_fragrulesfile
getInstrumentName(const int instrumentNum) const | ms_fragrulesfile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumberOfInstruments() const | ms_fragrulesfile
isValid() const | ms_errors
ms_errors() | ms_errors
ms_fragrulesfile() | ms_fragrulesfile
ms_fragrulesfile(const char *filename, const matrix_science::ms_connection_settings *cs=0) | ms_fragrulesfile
ms_fragrulesfile(const ms_fragrulesfile &src) | ms_fragrulesfile
operator=(const ms_fragrulesfile &right) | ms_fragrulesfile
read_buffer(const char *buffer) | ms_fragrulesfile
read_file() | ms_fragrulesfile
save_file() | ms_fragrulesfile
setConnectionSettings(const matrix_science::ms_connection_settings &cs) | ms_fragrulesfile
setFileName(const char *filename) | ms_fragrulesfile
updateInstrumentByName(const char *name, const ms_fragmentationrules item) | ms_fragrulesfile
updateInstrumentByNumber(const int num, const ms_fragmentationrules item) | ms_fragrulesfile
~ms_errors() | ms_errors
~ms_fragrulesfile() | ms_fragrulesfile
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_group
ms_group Member List

This is the complete list of members for ms_group, including all inherited members.

addPermittedTask(const matrix_science::ms_security_task &task) | ms_group
addUser(const int userID) | ms_group
clearParam(const std::string name) | ms_group
deleteUser(const int userID) | ms_group
getAllUserIDs(const void *const security=NULL, const int voidSortby=1) const | ms_group
getID() const | ms_group
getName() const | ms_group
getPermittedTasks() const | ms_group
getStringParam(const std::string name, std::string &param) const | ms_group
getStringParam(const std::string name) const | ms_group
GROUPID_ADMINISTRATORS enum value | ms_group
GROUPID_DAEMONS enum value | ms_group
GROUPID_GUESTS enum value | ms_group
GROUPID_INTEGRA_SYSTEM enum value | ms_group
GROUPID_LAST enum value | ms_group
GROUPID_POWERUSERS enum value | ms_group
isUserInGroup(const int userID) const | ms_group
ms_group() | ms_group
ms_group(const int groupID, const std::string groupName) | ms_group
removePermittedTask(const int taskID) | ms_group
saveStringParam(const std::string name, const std::string param) | ms_group
setID(int newVal) | ms_group
setName(const std::string newVal) | ms_group
setPermittedTasks(matrix_science::ms_security_tasks &tasks) | ms_group
systemids enum name | ms_group
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_http_client
ms_http_client Member List

This is the complete list of members for ms_http_client, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
baseUrl() const | ms_http_client |
changePassword(const std::string &userName, const std::string &oldPassword, const std::string &newPassword) | ms_http_client |
ChangePasswordResultCode enum name | ms_http_client |
clearAllErrors() | ms_errors |
connectionSettings() const | ms_http_client |
copyFrom(const ms_http_client *right) | ms_http_client |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
CP_BADNEWPASSWORD enum value | ms_http_client |
CP_INCORRECTPASSWORD enum value | ms_http_client |
CP_SUCCESS enum value | ms_http_client |
CP_UNKNOWNUSER enum value | ms_http_client |
CP_UNSPECIFIEDERROR enum value | ms_http_client |
getErrorHandler() const | ms_errors |
getIsDatabaseActive(const std::string &databaseName, bool &returnIsActive) | ms_http_client |
getIsSecurityEnabled(bool &returnIsSecurityEnabled, std::string &returnUnsecuredSessionId) | ms_http_client |
getIsWebAuthenticationEnabled(bool &returnIsWebAuthenticationEnabled, std::string &returnWebAuthenticatedSessionId) | ms_http_client |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getOsName(std::string &osname) | ms_http_client |
getVersion(int &major, int &minor, int &part3, int &part4) | ms_http_client |
isValid() const | ms_errors |
L_GUESTLOGINDISABLED enum value | ms_http_client |
L_INCORRECTPASSWORD enum value | ms_http_client |
L_PASSWORDEXPIRED enum value | ms_http_client |
L_SECURITYDISABLED enum value | ms_http_client |
L_SUCCESS enum value | ms_http_client |
L_UNKNOWNUSER enum value | ms_http_client |
L_UNSPECIFIEDERROR enum value | ms_http_client |
L_WEBAUTHENTICATIONFAILED enum value | ms_http_client |
LoginResultCode enum name | ms_http_client |
ms_errors() | ms_errors |
ms_http_client(const std::string &baseUrl, ms_connection_settings settings) | ms_http_client |
ms_http_client(const ms_http_client &src) | ms_http_client |
operator=(const ms_http_client &right) | ms_http_client |
setBaseUrl(const std::string &baseUrl) | ms_http_client |
setConnectionSettings(const ms_connection_settings &settings) | ms_http_client |
userLogin(const std::string &username, const std::string &password, ms_http_client_session &returnSession) | ms_http_client |
~ms_errors() | ms_errors |
~ms_http_client() | ms_http_client | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_http_client_mime
ms_http_client_mime Member List

This is the complete list of members for ms_http_client_mime, including all inherited members.

append(const std::string &name, const std::string &value) | ms_http_client_mime |
appendFile(const std::string &name, const std::string &filename, const std::string &contentType, const std::string &prefixData="") | ms_http_client_mime |
erase(int oneBasedIndex) | ms_http_client_mime |
format(const std::string &boundary, matrix_science::ms_http_client_mime::Continuation continuation) const | ms_http_client_mime |
formatHeader(const std::string &boundary, ContentType contentType) | ms_http_client_mime | static
getCount() const | ms_http_client_mime |
getFilename(int oneBasedIndex) const | ms_http_client_mime |
getName(int oneBasedIndex) const | ms_http_client_mime |
getValue(int oneBasedIndex) const | ms_http_client_mime |
hasFilename(int oneBasedIndex) const | ms_http_client_mime |
setValue(int oneBasedIndex, const std::string &value) | ms_http_client_mime |
setValueWithFilename(int oneBasedIndex, const std::string &value, const std::string &filename, const std::string &contentType) | ms_http_client_mime |
~ms_http_client_mime() | ms_http_client_mime | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_http_client_search
ms_http_client_search Member List

This is the complete list of members for ms_http_client_search, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_http_client_search *right) | ms_http_client_search |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
DO_NORMAL enum value | ms_http_client_search |
DO_WITH_IONS enum value | ms_http_client_search |
downloadDaemonResultsFile(std::string filename, ms_http_helper_progress &progress) | ms_http_client_search |
DownloadOption enum name | ms_http_client_search |
downloadPercolatorFile(std::string filename, ms_http_helper_progress &progress) | ms_http_client_search |
downloadResultsFile(std::string filename, ms_http_helper_progress &progress, DownloadOption options=DO_WITH_IONS) | ms_http_client_search |
downloadResultsFileMSR(std::string filename, ms_http_helper_progress &progress, DownloadOption options=DO_WITH_IONS) | ms_http_client_search |
downloadXmlResultsFile(std::string filename, ms_http_helper_progress &progress, int reportTop=RT_auto) | ms_http_client_search |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getResultsFileName(std::string &returnFileName) | ms_http_client_search |
getSearchTaskID() const | ms_http_client_search |
getSessionID() const | ms_http_client_search |
getStage(std::string &stage, int &step) | ms_http_client_search |
getStatus(SearchStatusCode &returnCode, int &statusValue) | ms_http_client_search |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_http_client_search(ms_http_client_session &session, const std::string &searchTaskId) | ms_http_client_search |
ms_http_client_search(const ms_http_client_search &src) | ms_http_client_search |
operator=(const ms_http_client_search &right) | ms_http_client_search |
ReportTopSpecialValues enum name | ms_http_client_search |
RT_auto enum value | ms_http_client_search |
RT_file enum value | ms_http_client_search |
SearchStatusCode enum name | ms_http_client_search |
sessionId() const | ms_http_client_search | inline
SS_ASSIGNED enum value | ms_http_client_search |
SS_COMPLETE enum value | ms_http_client_search |
SS_ERROR enum value | ms_http_client_search |
SS_QUEUED enum value | ms_http_client_search |
SS_RUNNING enum value | ms_http_client_search |
SS_SEARCH_CONTROL_ERROR enum value | ms_http_client_search |
SS_UNKNOWN enum value | ms_http_client_search |
uploadDistillerXmlResultsFile(std::string filename, UploadResponseCode &responseCode, std::string &responseText) | ms_http_client_search |
UploadResponseCode enum name | ms_http_client_search |
UR_ACCESS_DENIED enum value | ms_http_client_search |
UR_ERROR enum value | ms_http_client_search |
UR_FILE_ALREADY_EXISTS enum value | ms_http_client_search |
UR_INVALID_TASKID enum value | ms_http_client_search |
UR_NO_RESULT_FILE enum value | ms_http_client_search |
UR_NO_RESULT_FILENAME enum value | ms_http_client_search |
UR_SUCCESS enum value | ms_http_client_search |
~ms_errors() | ms_errors |
~ms_http_client_search() | ms_http_client_search | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_http_client_session
ms_http_client_session Member List

This is the complete list of members for ms_http_client_session, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_http_client_session *right) | ms_http_client_session |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
getErrorHandler() const | ms_errors |
getIsPermitted(ms_security_tasks::TASKID taskType, bool &returnIsPermitted) | ms_http_client_session |
getIsXmlUploadedList(const std::vector< std::string > &taskIds, std::vector< int > &xmlUploaded) | ms_http_client_session |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getSequenceFile(const std::string &database, const std::vector< std::string > &accessionNames, const std::vector< int > &accessionFrames, const std::string &filename, const SequenceShowOptions options=SHOW_ALL) | ms_http_client_session |
getSessionID() const | ms_http_client_session |
isValid() const | ms_errors |
logout() | ms_http_client_session |
ms_errors() | ms_errors |
ms_http_client_session() | ms_http_client_session |
ms_http_client_session(const ms_http_helper connection, const std::string sessionId) | ms_http_client_session |
ms_http_client_session(const ms_http_client_session &src) | ms_http_client_session |
operator=(const ms_http_client_session &right) | ms_http_client_session |
SequenceShowOptions enum name | ms_http_client_session |
SHOW_ALL enum value | ms_http_client_session |
SHOW_LENGTH enum value | ms_http_client_session |
SHOW_NONE enum value | ms_http_client_session |
SHOW_PI enum value | ms_http_client_session |
SHOW_REFERENCE enum value | ms_http_client_session |
SHOW_SEQUENCE enum value | ms_http_client_session |
SHOW_TITLE enum value | ms_http_client_session |
submitSearch(ms_http_client_search &returnTask, const std::string &httpHeader, const std::string &prologue, const std::string &filename, const std::string &epilogue, ms_http_helper_progress &progress, bool batch=false) | ms_http_client_session |
~ms_errors() | ms_errors |
~ms_http_client_session() | ms_http_client_session | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_http_helper
ms_http_helper Member List

This is the complete list of members for ms_http_helper, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
baseUrl() const | ms_http_helper |
clearAllErrors() | ms_errors |
connectionSettings() const | ms_http_helper |
copyFrom(const ms_http_helper *right) | ms_http_helper |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
FileMode enum name | ms_http_helper |
FM_binary enum value | ms_http_helper |
FM_text enum value | ms_http_helper |
getErrorHandler() const | ms_errors |
getHeaderValue(const std::string &name, const std::string &header) | ms_http_helper | static
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getProxyConfig(std::vector< std::string > &proxyServers, std::vector< std::string > &proxyUsernames, std::vector< std::string > &proxyPasswords) | ms_http_helper |
httpBufferedClose() | ms_http_helper |
httpBufferedGetString(std::string &httpBuffer, unsigned long requiredSize) | ms_http_helper |
httpBufferedOpen(const std::string &action) | ms_http_helper |
httpGetFile(const std::string &action, const std::string &filename, ms_http_helper_progress &progress, FileMode fileMode=FM_binary) | ms_http_helper |
httpGetHeader(const std::string &action, std::string &httpHeaderInfo) | ms_http_helper |
httpGetString(const std::string &action, std::string &httpGETString) | ms_http_helper |
httpPostFile(const std::string &action, const std::string &httpHeader, const std::string &prologue, const std::string &filename, const std::string &epilogue, ms_http_helper_handles &handles, ms_http_helper_progress &progress) | ms_http_helper |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_http_helper() | ms_http_helper |
ms_http_helper(const ms_http_helper &copy) | ms_http_helper |
ms_http_helper(const std::string &baseUrl, const ms_connection_settings &settings) | ms_http_helper |
operator=(const ms_http_helper &copy) | ms_http_helper |
~ms_errors() | ms_errors |
~ms_http_helper() | ms_http_helper |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_http_helper_handles
ms_http_helper_handles Member List

This is the complete list of members for ms_http_helper_handles, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
closeHandles() | ms_http_helper_handles |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getRequestData(bool &isStillActive, std::string &requestDataRef) | ms_http_helper_handles |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_http_helper_handles() | ms_http_helper_handles |
~ms_errors() | ms_errors |
~ms_http_helper_handles() | ms_http_helper_handles | virtual
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_http_helper_progress
ms_http_helper_progress Member List

This is the complete list of members for ms_http_helper_progress, including all inherited members.

copyFrom(const ms_http_helper_progress *right) | ms_http_helper_progress
getCurrentBytes() const | ms_http_helper_progress
getProportion() const | ms_http_helper_progress
getTotalBytes() const | ms_http_helper_progress
hasParent() const | ms_http_helper_progress
isAbortSet() const | ms_http_helper_progress
isComplete() const | ms_http_helper_progress
isStarted() const | ms_http_helper_progress
ms_http_helper_progress() | ms_http_helper_progress
ms_http_helper_progress(const ms_http_helper_progress &src) | ms_http_helper_progress
ms_http_helper_progress(ms_http_helper_progress &parentProgress, double proportionOffset, UINT64 byteOffset, double scale) | ms_http_helper_progress
setAbort() | ms_http_helper_progress
~ms_http_helper_progress() | ms_http_helper_progress
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_http_helper_return
ms_http_helper_return Member List

This is the complete list of members for ms_http_helper_return, including all inherited members.

abortedByUser() | ms_http_helper_return | static
ERR_ABORTEDBYUSER enum value | ms_http_helper_return |
ERR_HTTP enum value | ms_http_helper_return |
ERR_NONE enum value | ms_http_helper_return |
ERR_SYSTEM enum value | ms_http_helper_return |
ERR_UNSPECIFIED enum value | ms_http_helper_return |
ErrorTypeCode enum name | ms_http_helper_return |
getErrorText() const | ms_http_helper_return |
getErrorType() const | ms_http_helper_return |
getHttpStatusCode() const | ms_http_helper_return |
getSystemError() const | ms_http_helper_return |
httpError(int httpStatusCode, std::string errorText) | ms_http_helper_return | static
isOk() const | ms_http_helper_return |
ms_http_helper_return() | ms_http_helper_return |
operator bool() const | ms_http_helper_return |
systemError(int systemError) | ms_http_helper_return | static
unspecifiedError() | ms_http_helper_return | static
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_imputation
ms_imputation Member List

This is the complete list of members for ms_imputation, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
getErrorHandler() const | ms_errors |
getImputationVariableChoice() const | ms_imputation | inline
getImputeExcludedMs2PeptideRatios() | ms_imputation | inline
getImputeMs1PeptideExcludedByCorrelationThr() | ms_imputation | inline
getImputeMs1PeptideExcludedByFractionThr() | ms_imputation | inline
getImputeMs1PeptideExcludedByStdErrThr() | ms_imputation | inline
getImputeMs1PeptideNegativeRatio() | ms_imputation | inline
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
IMPUTATION_VARIABLE enum name | ms_imputation |
impute() | ms_imputation |
IMPUTE_PEPTIDE_RATIO enum value | ms_imputation |
IMPUTE_PROTEIN_RATIO enum value | ms_imputation |
IMPUTE_RETENTION_TIME enum value | ms_imputation |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_imputation(const ms_ms1quantitation *ms1quantitation, ms_imputation_method &m, IMPUTATION_VARIABLE imputationVariableChoice) | ms_imputation |
ms_imputation(const ms_ms2quantitation *ms2quantitation, ms_imputation_method &m, IMPUTATION_VARIABLE imputationVariableChoice) | ms_imputation |
setImputationVariableChoice(const IMPUTATION_VARIABLE imputationVariableChoiceIn) | ms_imputation | inline
setImputeExcludedMs2PeptideRatios(bool imputationMs2PeptideChoiceIn) | ms_imputation | inline
setImputeMs1PeptideExcludedByCorrelationThr(bool imputeMs1PeptideExcludedByCorrelationThr) | ms_imputation |
setImputeMs1PeptideExcludedByFractionThr(bool imputeMs1PeptideExcludedByFractionThr) | ms_imputation |
setImputeMs1PeptideExcludedByStdErrThr(bool imputeMs1PeptideExcludedByStdErrThr) | ms_imputation |
setImputeMs1PeptideNegativeRatio(bool imputeMs1PeptideNegativeRatio) | ms_imputation |
~ms_errors() | ms_errors |
~ms_imputation() | ms_imputation |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_imputation_average_value
ms_imputation_average_value Member List

This is the complete list of members for ms_imputation_average_value, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
averageFindAverage() | ms_imputation_method | protected
changems_imputation_missing_valArrayToDoubleArray(std::vector< std::vector< ms_imputation_missing_val > > dataProcess) | ms_imputation_method | protected
changems_imputation_missing_valVecToDoubleVec(std::vector< ms_imputation_missing_val > missingObservation) | ms_imputation_method | protected
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
getAverageValues() | ms_imputation_average_value | inline
getDataWithMissing() | ms_imputation_method | inline
getErrorHandler() const | ms_errors |
getKnownValues(std::vector< ms_imputation_missing_val >) | ms_imputation_method | protected
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMissingIndexes(std::vector< ms_imputation_missing_val >) | ms_imputation_method | protected
impute() override | ms_imputation_average_value | virtual
isValid() const | ms_errors |
ms_errors() | ms_errors |
removeDuplicateIndexes(std::vector< std::vector< int > > duplicateIndexes) | ms_imputation_method | protected
setAverageValues(std::vector< double > averageValuesIn) | ms_imputation_average_value | inline
setDataWithMissing(const std::vector< std::vector< ms_imputation_missing_val > > &dataWithMissingIn) | ms_imputation_method | protected
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_imputation_fixed_value
ms_imputation_fixed_value Member List

This is the complete list of members for ms_imputation_fixed_value, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
averageFindAverage() | ms_imputation_method | protected
changems_imputation_missing_valArrayToDoubleArray(std::vector< std::vector< ms_imputation_missing_val > > dataProcess) | ms_imputation_method | protected
changems_imputation_missing_valVecToDoubleVec(std::vector< ms_imputation_missing_val > missingObservation) | ms_imputation_method | protected
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
getDataWithMissing() | ms_imputation_method | inline
getErrorHandler() const | ms_errors |
getFixedValue() | ms_imputation_fixed_value | inline
getKnownValues(std::vector< ms_imputation_missing_val >) | ms_imputation_method | protected
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMissingIndexes(std::vector< ms_imputation_missing_val >) | ms_imputation_method | protected
impute() override | ms_imputation_fixed_value | virtual
isValid() const | ms_errors |
ms_errors() | ms_errors |
removeDuplicateIndexes(std::vector< std::vector< int > > duplicateIndexes) | ms_imputation_method | protected
setDataWithMissing(const std::vector< std::vector< ms_imputation_missing_val > > &dataWithMissingIn) | ms_imputation_method | protected
setFixedValue(double fixedValueIn) | ms_imputation_fixed_value | inline
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_imputation_knn
ms_imputation_knn Member List

This is the complete list of members for ms_imputation_knn, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
averageFindAverage() | ms_imputation_method | protected
changems_imputation_missing_valArrayToDoubleArray(std::vector< std::vector< ms_imputation_missing_val > > dataProcess) | ms_imputation_method | protected
changems_imputation_missing_valVecToDoubleVec(std::vector< ms_imputation_missing_val > missingObservation) | ms_imputation_method | protected
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
getDataWithMissing() | ms_imputation_method | inline
getErrorHandler() const | ms_errors |
getKnnNumNeighbours() | ms_imputation_knn | inline
getKnnUseWeightedAverage() | ms_imputation_knn | inline
getKnownValues(std::vector< ms_imputation_missing_val >) | ms_imputation_method | protected
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMissingIndexes(std::vector< ms_imputation_missing_val >) | ms_imputation_method | protected
impute() override | ms_imputation_knn | virtual
isValid() const | ms_errors |
ms_errors() | ms_errors |
removeDuplicateIndexes(std::vector< std::vector< int > > duplicateIndexes) | ms_imputation_method | protected
setDataWithMissing(const std::vector< std::vector< ms_imputation_missing_val > > &dataWithMissingIn) | ms_imputation_method | protected
setKnnNumNeighbours(int knnNumNeighboursIn) | ms_imputation_knn | inline
setKnnUseWeightedAverage(bool knnUseWeightedAverageIn) | ms_imputation_knn | inline
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_imputation_method
ms_imputation_method Member List

This is the complete list of members for ms_imputation_method, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
averageFindAverage() | ms_imputation_method | protected
changems_imputation_missing_valArrayToDoubleArray(std::vector< std::vector< ms_imputation_missing_val > > dataProcess) | ms_imputation_method | protected
changems_imputation_missing_valVecToDoubleVec(std::vector< ms_imputation_missing_val > missingObservation) | ms_imputation_method | protected
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
getDataWithMissing() | ms_imputation_method | inline
getErrorHandler() const | ms_errors |
getKnownValues(std::vector< ms_imputation_missing_val >) | ms_imputation_method | protected
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMissingIndexes(std::vector< ms_imputation_missing_val >) | ms_imputation_method | protected
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_imputation_method()=default | ms_imputation_method | protected
removeDuplicateIndexes(std::vector< std::vector< int > > duplicateIndexes) | ms_imputation_method | protected
setDataWithMissing(const std::vector< std::vector< ms_imputation_missing_val > > &dataWithMissingIn) | ms_imputation_method | protected
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_imputation_missforest
ms_imputation_missforest Member List

This is the complete list of members for ms_imputation_missforest, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
averageFindAverage() | ms_imputation_method | protected
changems_imputation_missing_valArrayToDoubleArray(std::vector< std::vector< ms_imputation_missing_val > > dataProcess) | ms_imputation_method | protected
changems_imputation_missing_valVecToDoubleVec(std::vector< ms_imputation_missing_val > missingObservation) | ms_imputation_method | protected
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
getDataWithMissing() | ms_imputation_method | inline
getErrorHandler() const | ms_errors |
getKnownValues(std::vector< ms_imputation_missing_val >) | ms_imputation_method | protected
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMissingIndexes(std::vector< ms_imputation_missing_val >) | ms_imputation_method | protected
impute() override | ms_imputation_missforest | virtual
isValid() const | ms_errors |
ms_errors() | ms_errors |
removeDuplicateIndexes(std::vector< std::vector< int > > duplicateIndexes) | ms_imputation_method | protected
setDataWithMissing(const std::vector< std::vector< ms_imputation_missing_val > > &dataWithMissingIn) | ms_imputation_method | protected
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_imputation_missing_val Class Reference

  • matrix_science
  • ms_imputation_missing_val
Public Member Functions | List of all members
ms_imputation_missing_val Class Reference

#include <ms_imputation.hpp>

Public Member Functions

ms_imputation_missing_val ()
Default construtor; initialises the value as missing.
ms_imputation_missing_val (bool isMissing, double val)
Constructor to initialise whether or not a value is missing and, if not missing, the numerical value.
double | getVal () const
Get the numerical value (if this is not missing).
bool | isMissing () const
Get missing status for this value.
void | setMissing ()
Set the status and value as missing.
void | setVal (double val)
Set the numerical value and status as not missing.

Detailed Description

This class is a holder of missing value information within ms_imputation.

EXPERIMENTAL
This class is EXPERIMENTAL. Both the API and the implementation may change in a future version of Parser.
The documentation for this class was generated from the following file:
  • ms_imputation.hpp
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_imputation_missing_val
ms_imputation_missing_val Member List

This is the complete list of members for ms_imputation_missing_val, including all inherited members.

getVal() const | ms_imputation_missing_val | inline
isMissing() const | ms_imputation_missing_val | inline
ms_imputation_missing_val() | ms_imputation_missing_val | inline
ms_imputation_missing_val(bool isMissing, double val) | ms_imputation_missing_val | inline
setMissing() | ms_imputation_missing_val | inline
setVal(double val) | ms_imputation_missing_val | inline
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_imputation_peptide_data
ms_imputation_peptide_data Member List

This is the complete list of members for ms_imputation_peptide_data, including all inherited members.

ms_imputation_peptide_data(double retentionTime, int subproject) | ms_imputation_peptide_data | inline
retentionTime() const | ms_imputation_peptide_data | inline
subproject() const | ms_imputation_peptide_data | inline
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_inputquery
ms_inputquery Member List

This is the complete list of members for ms_inputquery, including all inherited members.

getAverageCharge(int *averageCharge, double *averageChargeDbl=0) const | ms_inputquery
getCharge() const | ms_inputquery
getComp(int comp_no) const | ms_inputquery
getIndex() const | ms_inputquery
getINSTRUMENT(const bool unescaped=true) const | ms_inputquery
getIntMax() const | ms_inputquery
getIntMin() const | ms_inputquery
getIonMobility() const | ms_inputquery
getIT_MODS(const bool unescaped=true) const | ms_inputquery
getLocalVarModName(const int num) const | ms_inputquery
getLocus() const | ms_inputquery
getMassMax() const | ms_inputquery
getMassMin() const | ms_inputquery
getMaxInternalMass() const | ms_inputquery
getMinInternalMass() const | ms_inputquery
getNumberOfLocalVarMods() const | ms_inputquery
getNumberOfPeaks(const int ions) const | ms_inputquery
getNumUsed() const | ms_inputquery
getNumVals() const | ms_inputquery
getPeakCharge(const int ions, const int peakNo) const | ms_inputquery
getPeakIntensity(const int ions, const int peakNo) const | ms_inputquery
getPeakList(const int ions) const | ms_inputquery
getPeakMass(const int ions, const int peakNo) const | ms_inputquery
getPepTol() const | ms_inputquery
getPepTolString() const | ms_inputquery
getPepTolUnits() const | ms_inputquery
getQueryNumber() const | ms_inputquery
getRawfile() const | ms_inputquery
getRawScans(const int rawFileIdx=-1) const | ms_inputquery
getRawScans(std::vector< int > &index, std::vector< std::string > &rawscans) const | ms_inputquery
getRetentionTimes(const int rawFileIdx=-1) const | ms_inputquery
getRetentionTimes(std::vector< int > &index, std::vector< std::string > &times) const | ms_inputquery
getRULES() const | ms_inputquery
getScanNumbers(const int rawFileIdx=-1) const | ms_inputquery
getScanNumbers(std::vector< int > &index, std::vector< std::string > &scans) const | ms_inputquery
getSeq(int seq_no) const | ms_inputquery
getStringIons1(bool includeCharges=false) const | ms_inputquery
getStringIons2(bool includeCharges=false) const | ms_inputquery
getStringIons3(bool includeCharges=false) const | ms_inputquery
getStringTitle(bool unescaped) const | ms_inputquery
getTag(int tag_no) const | ms_inputquery
getTotalIonsIntensity() const | ms_inputquery
hasINTERNALS() const | ms_inputquery
ms_inputquery(const ms_mascotresfilebase &resfile, const int q) | ms_inputquery
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_libraryoptions
ms_libraryoptions Member List

This is the complete list of members for ms_libraryoptions, including all inherited members.

appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
copyFrom(const ms_libraryoptions *right) | ms_libraryoptions
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_libraryoptions
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
dropSpectralLibrary(const char *spectralLibraryName) | ms_libraryoptions
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getLibraryName(const int num) const | ms_libraryoptions
getNumberOfLibraries() const | ms_libraryoptions
getNumberOfProperties() const | ms_customproperty
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
getReferenceFasta(const char *spectralLibraryName) const | ms_libraryoptions
getReferenceFastaTaxonomyTitle(const char *spectralLibraryName) const | ms_libraryoptions
getToleranceInDa(const char *spectralLibraryName) const | ms_libraryoptions
getToleranceInPPM(const char *spectralLibraryName) const | ms_libraryoptions
isSectionAvailable() const | ms_libraryoptions
ms_customproperty() | ms_customproperty
ms_libraryoptions() | ms_libraryoptions
ms_libraryoptions(const ms_libraryoptions &src) | ms_libraryoptions
operator=(const ms_libraryoptions &right) | ms_libraryoptions
setDefaultDelimiter(const char *delim) | ms_customproperty
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setReferenceFasta(const char *spectralLibraryName, const char *fastaDatabaseName, const char *taxonomyTitle) | ms_libraryoptions
setSectionAvailable(const bool value) | ms_libraryoptions
setToleranceInDa(const char *spectralLibraryName, double tolerance) | ms_libraryoptions
setToleranceInPPM(const char *spectralLibraryName, double tolerance) | ms_libraryoptions
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
~ms_libraryoptions() | ms_libraryoptions
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_license
ms_license Member List

This is the complete list of members for ms_license, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_license *right) | ms_license
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_license
getDistributor() const | ms_license
getEndDate() const | ms_license
getErrorHandler() const | ms_errors
getFeatures() const | ms_license
getFileName() const | ms_license
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getLicensee() const | ms_license
getLicenseString() const | ms_license
getLicenseVersion() const | ms_license
getNumProcessorsLicensed() const | ms_license
getStartDate() const | ms_license
isLicenseValid() const | ms_license
isValid() const | ms_errors
ms_errors() | ms_errors
ms_license() | ms_license
ms_license(const ms_license &src) | ms_license
ms_license(const char *filename) | ms_license
operator=(const ms_license &right) | ms_license
read_file() | ms_license
setFileName(const char *filename) | ms_license
~ms_errors() | ms_errors
~ms_license() | ms_license
Generated on Tue Sep 24 2024 11:06:12 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_linker_site
ms_linker_site Member List

This is the complete list of members for ms_linker_site, including all inherited members.

copyFrom(const ms_linker_site *right) | ms_linker_site
getLinkerMass() const | ms_linker_site
getLinkFrom() const | ms_linker_site
getLinkTo() const | ms_linker_site
getSiteFrom() const | ms_linker_site
getSiteTo() const | ms_linker_site
getVarModIdxFrom() const | ms_linker_site
getVarModIdxTo() const | ms_linker_site
ms_linker_site() | ms_linker_site
ms_linker_site(ms_peptide::PSM linkFrom, ms_peptide::PSM linkTo, int siteFrom, int siteTo, int varModIdxFrom, int varModIdxTo, double linkerMass) | ms_linker_site
ms_linker_site(const ms_linker_site &src) | ms_linker_site
operator=(const ms_linker_site &right) | ms_linker_site
~ms_linker_site() | ms_linker_site
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_linker_site_vector
ms_linker_site_vector Member List

This is the complete list of members for ms_linker_site_vector, including all inherited members.

append(const ms_linker_site_vector &src) | ms_linker_site_vector
clear() | ms_linker_site_vector
containsVarModIdx(int idx) const | ms_linker_site_vector
copyFrom(const ms_linker_site_vector *src) | ms_linker_site_vector
empty() const | ms_linker_site_vector
get(int idx) const | ms_linker_site_vector
getAlphaVarModsStrLength() const | ms_linker_site_vector
getBetaVarModsStrLength() const | ms_linker_site_vector
getVarModIdxOfLinkedSite(const ms_peptide::PSM psmComponent, const int i) const | ms_linker_site_vector
ms_linker_site_vector() | ms_linker_site_vector
ms_linker_site_vector(const std::vector< ms_linker_site > &v, const int alphaVarModsLen, const int betaVarModsLen) | ms_linker_site_vector
ms_linker_site_vector(const std::list< ms_linker_site > &v, const int alphaVarModsLen, const int betaVarModsLen) | ms_linker_site_vector
ms_linker_site_vector(const ms_linker_site_vector &src) | ms_linker_site_vector
operator=(const ms_linker_site_vector &right) | ms_linker_site_vector
pop() | ms_linker_site_vector
push(const ms_linker_site &linkerSite) | ms_linker_site_vector
set(int idx, const ms_linker_site &linkerSite) | ms_linker_site_vector
size() const | ms_linker_site_vector
swap(ms_linker_site_vector &right) | ms_linker_site_vector
toVector() const | ms_linker_site_vector
~ms_linker_site_vector() | ms_linker_site_vector
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_log
ms_log Member List

This is the complete list of members for ms_log, including all inherited members.

addToCatalog(const msg_catalog_t catalog[], size_t numEntries, ms_loggingmonitor::Source_e src, errorOrLogMessages_e errorOrLogMessages) | ms_log |
getLoggingLevel() const =0 | ms_log | pure virtual
getMessageSource(const ms_log::msg_num_t msgNum) const | ms_log |
LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED | ms_log | static
LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES | ms_log | static
LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE | ms_log | static
LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE | ms_log | static
LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES | ms_log | static
LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE | ms_log | static
LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER | ms_log | static
LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK | ms_log | static
LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK | ms_log | static
LOGMSG_AAHELPER_CFR_MASSES_VALUE | ms_log | static
LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE | ms_log | static
LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS | ms_log | static
LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT | ms_log | static
LOGMSG_AAHELPER_CFR_START_FRAGMENTS | ms_log | static
LOGMSG_AAHELPER_CROSSLINKED_END | ms_log | static
LOGMSG_AAHELPER_CROSSLINKED_START | ms_log | static
LOGMSG_AAHELPER_CUMULATIVE_MASS_NL | ms_log | static
LOGMSG_AAHELPER_ETMOD_LOOKUP | ms_log | static
LOGMSG_AAHELPER_IMMONIUM_ION_ADD | ms_log | static
LOGMSG_AAHELPER_IMMONIUM_ION_REJECT | ms_log | static
LOGMSG_AAHELPER_INTERNAL_ION_ADD | ms_log | static
LOGMSG_AAHELPER_INTERNAL_ION_REJECT | ms_log | static
LOGMSG_AAHELPER_MASTER_NL_VALS | ms_log | static
LOGMSG_AAHELPER_MULTINL_INDICES | ms_log | static
LOGMSG_AAHELPER_REGULAR_ION_ADD | ms_log | static
LOGMSG_AAHELPER_REGULAR_ION_REJECT | ms_log | static
LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD | ms_log | static
LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT | ms_log | static
LOGMSG_AAHELPER_SERIES_PARAMS | ms_log | static
LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG | ms_log | static
LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT | ms_log | static
LOGMSG_AAHELPER_TOTAL_NL_VALS | ms_log | static
LOGMSG_CUSTQUANT_ADD_QUANT_KEY | ms_log | static
LOGMSG_CUSTQUANT_REMOVE_ALL_KEY | ms_log | static
LOGMSG_CUSTQUANT_REMOVE_KEY | ms_log | static
LOGMSG_DBG1_NUM_PROCESSOR_GROUPS | ms_log | static
LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS | ms_log | static
LOGMSG_DBG2_CPU_INF_GETAUTODETECT | ms_log | static
LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS | ms_log | static
LOGMSG_DBG2_CPU_INF_MT_NAME | ms_log | static
LOGMSG_DBG2_CPU_INF_MT_STATUS | ms_log | static
LOGMSG_DBG2_CPU_INF_NAME | ms_log | static
LOGMSG_DBG2_CPU_INF_NUM_AVAIL | ms_log | static
LOGMSG_DBG2_CPU_INF_NUM_GROUPS | ms_log | static
LOGMSG_DBG2_CPU_INF_NUM_ON_SYS | ms_log | static
LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL | ms_log | static
LOGMSG_DBG2_CPU_INF_PROC_AFFINITY | ms_log | static
LOGMSG_DBG2_CPU_INF_TABLE_LINE | ms_log | static
LOGMSG_DBG2_CPU_INF_TABLE_TITLE | ms_log | static
LOGMSG_DBG2_CPU_INF_USE_PROCESSES | ms_log | static
LOGMSG_DBG2_NUM_CONFIG_MISMATCH | ms_log | static
LOGMSG_DBG2_NUM_ONLINE_MISMATCH | ms_log | static
LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD | ms_log | static
LOGMSG_DBG3_BINDING_PROCESSORS | ms_log | static
LOGMSG_DBG3_BINDING_THREAD | ms_log | static
LOGMSG_DBG3_CALL_GET_CHIP_MFCTR | ms_log | static
LOGMSG_DBG3_HWLOC_GROUPS | ms_log | static
LOGMSG_DBG3_HWLOC_TREE | ms_log | static
LOGMSG_DBG3_PROCESSOR_NAME | ms_log | static
LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND | ms_log | static
LOGMSG_GET_THR_LOOP_BODY_START | ms_log | static
LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT | ms_log | static
LOGMSG_GET_THR_REACH_COND | ms_log | static
LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET | ms_log | static
LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR | ms_log | static
LOGMSG_HTTP_GETRETURNSTRING | ms_log | static
LOGMSG_HTTP_MAXCONECTIONS10FAILED | ms_log | static
LOGMSG_HTTP_MAXCONECTIONSFAILED | ms_log | static
LOGMSG_HTTP_QUERYSTATUSRESULT | ms_log | static
LOGMSG_HTTP_URLSTRING | ms_log | static
LOGMSG_INST_ADDINGDATABASE | ms_log | static
LOGMSG_INST_ADDOPTIONSSECTION | ms_log | static
LOGMSG_INST_APPENDPARSERULE | ms_log | static
LOGMSG_INST_APPENDTAXONOMY | ms_log | static
LOGMSG_INST_CHANGEDBTAXONOMY | ms_log | static
LOGMSG_INST_CHANGEPARSERULE | ms_log | static
LOGMSG_INST_CHANGEPERCOLATORFEATS | ms_log | static
LOGMSG_INST_CHANGEPERCOLATORUSERT | ms_log | static
LOGMSG_INST_CHANGEPROTFAMILYSWITCH | ms_log | static
LOGMSG_INST_CHANGERESULTSCACHE | ms_log | static
LOGMSG_INST_CHANGESPLITDATAFILESIZE | ms_log | static
LOGMSG_INST_CHANGESPLITNUMOFQUERIES | ms_log | static
LOGMSG_INST_CLUSTERSECTION | ms_log | static
LOGMSG_INST_FAILSAVEPOSTINSTALLFILE | ms_log | static
LOGMSG_INST_LOGICALPERPHYSICALCPU | ms_log | static
LOGMSG_INST_MASCOTDATOK | ms_log | static
LOGMSG_INST_NOSUBCLUSTERSET | ms_log | static
LOGMSG_INST_NOTMASCOTDATOK | ms_log | static
LOGMSG_INST_NUMTHREADS | ms_log | static
LOGMSG_INST_REMOVEOPTIONSSECTION | ms_log | static
LOGMSG_INST_SAVEDPOSTINSTALLFILE | ms_log | static
LOGMSG_INST_SETOPTIONSSECTION | ms_log | static
LOGMSG_MATRIX_OUTPUT_VALS | ms_log | static
LOGMSG_MSR2DAT28_SQL_TRACING | ms_log | static
LOGMSG_NON_DEFAULT_HOMOLOGY_THRESHOLD | ms_log | static
LOGMSG_PEPSUM_GETHIT | ms_log | static
LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP | ms_log | static
LOGMSG_PROTINFER_CHOOSE_NEXT_START | ms_log | static
LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY | ms_log | static
LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST | ms_log | static
LOGMSG_PROTINFER_CLUSTER_FROM_ACC | ms_log | static
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO | ms_log | static
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT | ms_log | static
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST | ms_log | static
LOGMSG_PROTINFER_FIND_FAMILY_END | ms_log | static
LOGMSG_PROTINFER_FIND_FAMILY_QUEUE | ms_log | static
LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS | ms_log | static
LOGMSG_PROTINFER_FIND_FAMILY_START | ms_log | static
LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END | ms_log | static
LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START | ms_log | static
LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST | ms_log | static
LOGMSG_PROTINFER_GROUP_FAMILY_START | ms_log | static
LOGMSG_PROTINFER_GROUP_FROM_ACC | ms_log | static
LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY | ms_log | static
LOGMSG_PROTINFER_PEPTIDE_MATRIX | ms_log | static
LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD | ms_log | static
LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP | ms_log | static
LOGMSG_PROTINFER_REMOVE_CONFLICTING_START | ms_log | static
LOGMSG_PROTINFER_SINGLETON_FROM_ACC | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_DONE | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE | ms_log | static
LOGMSG_PROTINFER_SORT_BY_SCORE_START | ms_log | static
LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT | ms_log | static
LOGMSG_QUANT_ADDED_PROTEIN_HIT | ms_log | static
LOGMSG_QUANT_ADDING_PROTEIN_HIT | ms_log | static
LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED | ms_log | static
LOGMSG_QUANT_CLOSING_CACHE_FILE | ms_log | static
LOGMSG_QUANT_EXCLUDING_PEPTIDE | ms_log | static
LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN | ms_log | static
LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN | ms_log | static
LOGMSG_QUANT_FINISH_CALC_COMPLETE | ms_log | static
LOGMSG_QUANT_FINISH_LOAD_CDB | ms_log | static
LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE | ms_log | static
LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES | ms_log | static
LOGMSG_QUANT_HELPER_TEST_REQUIRED | ms_log | static
LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES | ms_log | static
LOGMSG_QUANT_LOADING_MATCHES | ms_log | static
LOGMSG_QUANT_MERGE_COMPONENT_DUPE_FI | ms_log | static
LOGMSG_QUANT_MERGE_COMPONENT_INCONSIST | ms_log | static
LOGMSG_QUANT_MERGE_COMPONENT_SUCCESS | ms_log | static
LOGMSG_QUANT_OPENING_CACHE_FILE | ms_log | static
LOGMSG_QUANT_REAPPLY_THRESHOLDS | ms_log | static
LOGMSG_QUANT_REMATCHING_INFERRED | ms_log | static
LOGMSG_QUANT_REMOVE_INFERRED_MATCH | ms_log | static
LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE | ms_log | static
LOGMSG_QUANT_RT_OFFSET_LOOKUP | ms_log | static
LOGMSG_QUANT_START_CALC_COMPLETE | ms_log | static
LOGMSG_QUANT_START_LOAD_CDB | ms_log | static
LOGMSG_QUANT_START_REORDER_AFTER_MERGE | ms_log | static
LOGMSG_QUANT_START_UPDATE_PROT_MATCHES | ms_log | static
LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE | ms_log | static
LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE1 | ms_log | static
LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES | ms_log | static
LOGMSG_QUANT_UPDATING_PEP_EVIDENCE | ms_log | static
LOGMSG_REPORT_FUNCTION_CALLED_BY | ms_log | static
LOGMSG_REPORT_FUNCTION_ENTRY | ms_log | static
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 | ms_log | static
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 | ms_log | static
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 | ms_log | static
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 | ms_log | static
LOGMSG_REPORT_FUNCTION_EXIT | ms_log | static
LOGMSG_REPORT_FUNCTION_EXIT_WITH | ms_log | static
LOGMSG_RESFILE_APPEND | ms_log | static
ms_log() | ms_log |
msg_num_t typedef | ms_log |
msg_sev enum name | ms_log |
sev_debug1 enum value | ms_log |
sev_debug2 enum value | ms_log |
sev_debug3 enum value | ms_log |
sev_fatal enum value | ms_log |
sev_info enum value | ms_log |
sev_warn enum value | ms_log |
willMessageBeLogged(const msg_num_t msgNum) const | ms_log |
~ms_log() | ms_log | virtual
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_logger
ms_logger Member List

This is the complete list of members for ms_logger, including all inherited members.

COL_ASC_TIME enum value | ms_logger |
COL_HEADERS enum value | ms_logger |
COL_IP_ADDRESS enum value | ms_logger |
COL_ISO8601_TIME enum value | ms_logger |
COL_LOGGER_DEFAULTS enum value | ms_logger |
COL_MSG enum value | ms_logger |
COL_MSG_NUM_DEC enum value | ms_logger |
COL_MSG_NUM_HEX enum value | ms_logger |
COL_MSG_SOURCE_TXT enum value | ms_logger |
COL_QUOTES enum value | ms_logger |
COL_SEVERITY_NUM enum value | ms_logger |
COL_SEVERITY_TXT enum value | ms_logger |
COL_SRC_FILE enum value | ms_logger |
COL_SRC_LINENUM enum value | ms_logger |
COL_THREAD_ID enum value | ms_logger |
COL_TSV enum value | ms_logger |
formatMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const | ms_logger |
getColsToOutput() const | ms_logger | virtual
getHeaderLine() const | ms_logger |
LogOutputColumns_e enum name | ms_logger |
ms_logger(const unsigned int colsToOutput=COL_MSG) | ms_logger |
onLogMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)=0 | ms_logger | pure virtual
setColsToOutput(const unsigned int colsToOutput) | ms_logger | virtual
~ms_logger() | ms_logger | inlinevirtual
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_loggingmonitor
ms_loggingmonitor Member List

This is the complete list of members for ms_loggingmonitor, including all inherited members.

addLogEventsHandler(ms_logger &logger) | ms_loggingmonitor | virtual
getDefaultMonitor() | ms_loggingmonitor | static
getLogEventsHandler(const int uid) | ms_loggingmonitor | virtual
getLogMask(unsigned source=SRC_ALL) | ms_loggingmonitor | virtual
getNumLogEventsHandlers() const | ms_loggingmonitor | virtual
Level_e enum name | ms_loggingmonitor |
logMessage(Level_e eSeverity, Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) const | ms_loggingmonitor | virtual
LVL_DEBUG1 enum value | ms_loggingmonitor |
LVL_DEBUG2 enum value | ms_loggingmonitor |
LVL_DEBUG3 enum value | ms_loggingmonitor |
LVL_ERROR enum value | ms_loggingmonitor |
LVL_INFO enum value | ms_loggingmonitor |
LVL_NONE enum value | ms_loggingmonitor |
LVL_WARNING enum value | ms_loggingmonitor |
messageSourceAsText(Source_e eSource) | ms_loggingmonitor | static
ms_loggingmonitor() | ms_loggingmonitor |
removeLogEventsHandler(const int uid) | ms_loggingmonitor | virtual
setDefaultMonitor(ms_loggingmonitor &loggingMonitor) | ms_loggingmonitor | static
setLogMask(long newVal, unsigned source=SRC_ALL) | ms_loggingmonitor | virtual
severityAsText(Level_e eSeverity) | ms_loggingmonitor | static
Source_e enum name | ms_loggingmonitor |
SRC_ALL enum value | ms_loggingmonitor |
SRC_APPLICATION enum value | ms_loggingmonitor |
SRC_DENOVOLIB enum value | ms_loggingmonitor |
SRC_MASCOTSERVER enum value | ms_loggingmonitor |
SRC_MDRO enum value | ms_loggingmonitor |
SRC_MSPARSER enum value | ms_loggingmonitor |
SRC_MSQUANTLIB enum value | ms_loggingmonitor |
SRC_PURIFIERAPI enum value | ms_loggingmonitor |
SRC_PURIFIERAPP enum value | ms_loggingmonitor |
SRC_VENDORSTART enum value | ms_loggingmonitor |
~ms_loggingmonitor() | ms_loggingmonitor | virtual
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_mascotfiles
ms_mascotfiles Member List

This is the complete list of members for ms_mascotfiles, including all inherited members.

appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
copyFrom(const ms_mascotfiles *right) | ms_mascotfiles
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_mascotfiles
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getEnzymes() const | ms_mascotfiles
getFrequencies() const | ms_mascotfiles
getModifications() const | ms_mascotfiles
getNodeListFile() const | ms_mascotfiles
getNumberOfProperties() const | ms_customproperty
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
ms_customproperty() | ms_customproperty
ms_mascotfiles() | ms_mascotfiles
ms_mascotfiles(const ms_mascotfiles &src) | ms_mascotfiles
operator=(const ms_mascotfiles &right) | ms_mascotfiles
setDefaultDelimiter(const char *delim) | ms_customproperty
setEnzymes(const char *filename) | ms_mascotfiles
setFrequencies(const char *filename) | ms_mascotfiles
setModifications(const char *filename) | ms_mascotfiles
setNodeListFile(const char *filename) | ms_mascotfiles
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
~ms_mascotfiles() | ms_mascotfiles
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_mascotoptions
ms_mascotoptions Member List

This is the complete list of members for ms_mascotoptions, including all inherited members.

appendIgnoreDupeAccession(const std::string value) | ms_mascotoptions
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendReportNumberChoice(const int value) | ms_mascotoptions
appendTargetFDRPercentage(const double value, const bool makeDefault=false) | ms_mascotoptions
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
clearIgnoreDupeAccessions() | ms_mascotoptions
clearReportNumberChoices() | ms_mascotoptions
clearTargetFDRPercentages() | ms_mascotoptions
copyFrom(const ms_mascotoptions *right) | ms_mascotoptions
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
DECOY_ALGORITHM enum name | ms_mascotoptions
DECOY_ALGORITHM_NONE enum value | ms_mascotoptions
DECOY_PEPTIDE_RANDOM enum value | ms_mascotoptions
DECOY_PEPTIDE_RANDOM_DIPEP enum value | ms_mascotoptions
DECOY_PEPTIDE_REVERSE enum value | ms_mascotoptions
DECOY_PEPTIDE_SHUFFLE enum value | ms_mascotoptions
DECOY_PROTEIN_BASED_MASK enum value | ms_mascotoptions
DECOY_PROTEIN_RANDOM enum value | ms_mascotoptions
DECOY_PROTEIN_RANDOM_DIPEP enum value | ms_mascotoptions
DECOY_PROTEIN_REVERSE enum value | ms_mascotoptions
DECOY_PROTEIN_SHUFFLE enum value | ms_mascotoptions
defaultValues() | ms_mascotoptions
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
EXEC_AFTER_SEARCH enum name | ms_mascotoptions
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getCacheDirectory() const | ms_mascotoptions
getCentroidWidth() const | ms_mascotoptions
getCentroidWidthCount() const | ms_mascotoptions
getCompressToolAA() const | ms_mascotoptions
getCompressToolCommandLineFasta(DATABASE_TYPE dbType, const std::string &dbname, const std::string &dbpath) const | ms_mascotoptions
getCompressToolCommandLineLibrary(const std::string &logfilepath, const std::string &inputfile, const std::string &outputdirectory) const | ms_mascotoptions
getCompressToolNA() const | ms_mascotoptions
getCompressToolSL() const | ms_mascotoptions
getCrawlerNumPeaksPer100Da() const | ms_mascotoptions
getCreatePipThreadBlockSize() const | ms_mascotoptions
getCreatePipThreads() const | ms_mascotoptions
getDechargeFragmentPeaks() const | ms_mascotoptions
getDecoyTypeNoEnzyme() const | ms_mascotoptions
getDecoyTypeSpecific() const | ms_mascotoptions
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getDisplayNonSignificantMatches() const | ms_mascotoptions
getEmailFromTextName() const | ms_mascotoptions
getEmailFromUser() const | ms_mascotoptions
getEmailPassword() const | ms_mascotoptions
getEmailProfile() const | ms_mascotoptions
getEmailService() const | ms_mascotoptions
getEmailTimeOutPeriod() const | ms_mascotoptions
getErrMessageEmailTo() const | ms_mascotoptions
getErrorLogFile() const | ms_mascotoptions
getErrTolMaxAccessions() const | ms_mascotoptions
getExecAfterSearch(const char *szResultsFilePath, std::vector< std::string > &commands, std::vector< std::string > &titles, std::vector< int > &waitfor, std::vector< int > &logging, std::vector< std::string > &additionalFlags, const char *sessionID=0, const char *taskID=0) const | ms_mascotoptions
getFeatureTableLength() const | ms_mascotoptions
getFeatureTableMinScore() const | ms_mascotoptions
getFormVersion() const | ms_mascotoptions
getGetSeqBlastAccession() const | ms_mascotoptions
getGetSeqJobIdFile() const | ms_mascotoptions
getICATFilter() const | ms_mascotoptions
getICATHeavy() const | ms_mascotoptions
getICATLight() const | ms_mascotoptions
getICATQuantitationMethod() const | ms_mascotoptions
getIgnoreDupeAccession(const unsigned int index) const | ms_mascotoptions
getIgnoreIonsScoreBelow() const | ms_mascotoptions
getIntensitySigFigs() const | ms_mascotoptions
getInterFileBasePath() const | ms_mascotoptions
getInterFileRelPath() const | ms_mascotoptions
getIonsDecimalPlaces() const | ms_mascotoptions
getLastQueryAscFile() const | ms_mascotoptions
getLogoImageFile() const | ms_mascotoptions
getMailTempFile() const | ms_mascotoptions
getMailTransport() const | ms_mascotoptions
getMascNodeCtrlFile() const | ms_mascotoptions
getMascotCmdLine() const | ms_mascotoptions
getMascotControlFile() const | ms_mascotoptions
getMascotFileProcessingThreads() const | ms_mascotoptions
getMascotJobIdFile() const | ms_mascotoptions
getMascotMessage() const | ms_mascotoptions
getMassDecimalPlaces() const | ms_mascotoptions
getMaxConcurrentSearches() const | ms_mascotoptions
getMaxDatabases() const | ms_mascotoptions
getMaxDescriptionLen() const | ms_mascotoptions
getMaxEtagMassDelta() const | ms_mascotoptions
getMaxEtVarMods() const | ms_mascotoptions
getMaxIntactCrosslinkPeptides() const | ms_mascotoptions
getMaxNumOfReportBuilderColumnArrangements() const | ms_mascotoptions
getMaxNumPeptides() const | ms_mascotoptions
getMaxPepModArrangements() const | ms_mascotoptions
getMaxPepNumModifiedSites() const | ms_mascotoptions
getMaxPepNumVarMods() const | ms_mascotoptions
getMaxQueries() const | ms_mascotoptions
getMaxSearchesPerUser() const | ms_mascotoptions
getMaxSequenceLen() const | ms_mascotoptions
getMaxVarMods() const | ms_mascotoptions
getMinEtagMassDelta() const | ms_mascotoptions
getMinPepLenInPepSummary() const | ms_mascotoptions
getMinPepLenInSearch() const | ms_mascotoptions
getMonitorEmailCheckFreq() const | ms_mascotoptions
getMonitorLogFile() const | ms_mascotoptions
getMonitorPidFile() const | ms_mascotoptions
getMonitorTestTimeout() const | ms_mascotoptions
getMudpit() const | ms_mascotoptions
getMudpitSwitch() const | ms_mascotoptions
getNoResultsScript() const | ms_mascotoptions
getNTIUserGroup() const | ms_mascotoptions
getNTMonitorGroup() const | ms_mascotoptions
getNumberOfIgnoreDupeAccessions() const | ms_mascotoptions
getNumberOfProperties() const | ms_customproperty
getNumberOfReportNumberChoices() const | ms_mascotoptions
getNumberOfTargetFDRPercentages() const | ms_mascotoptions
getPepSearchTool() const | ms_mascotoptions
getPepSearchToolCommandLine(const std::string &peptideToleranceUnit, const double &peptideTolerance, const std::string &ionToleranceUnit, const double &ionTolerance, const std::string &libraryDirectoryPath, const std::string &inputFileRelativePath, const std::string &outputFileRelativePath) const | ms_mascotoptions
getPercolatorExeFlags(bool anyRetentionTimes, const std::vector< std::string > percolatorFiles, const PERC_EXE_RT rt=PERC_EXE_RT_USE_DEFAULT) const | ms_mascotoptions
getPercolatorFeatures() const | ms_mascotoptions
getPercolatorMinQueries() const | ms_mascotoptions
getPercolatorMinSequences() const | ms_mascotoptions
getPercolatorRtFlags(const bool anyRetentionTimes, const bool useRT) const | ms_mascotoptions
getPercolatorTargetRankRelativeThreshold() const | ms_mascotoptions
getPercolatorTargetRankScoreThreshold() const | ms_mascotoptions
getPreceedingComments() const | ms_customproperty
getPrecursorCutOutLowerLimit() const | ms_mascotoptions
getPrecursorCutOutUpperLimit() const | ms_mascotoptions
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
getProteinFamilySwitch() const | ms_mascotoptions
getProteinsInResultsFile() const | ms_mascotoptions
getProxyPassword() const | ms_mascotoptions
getProxyServer() const | ms_mascotoptions
getProxyType() const | ms_mascotoptions
getProxyUsername() const | ms_mascotoptions
getReportBuilderColumnArrangement(const int index) const | ms_mascotoptions
getReportNumberChoice(const int index) const | ms_mascotoptions
getResfileCache() const | ms_mascotoptions
getResultsCache() const | ms_mascotoptions
getResultsFileFormatVersion() const | ms_mascotoptions
getResultsFullURL() const | ms_mascotoptions
getResultsFullURL_2() const | ms_mascotoptions
getResultsPerlScript() const | ms_mascotoptions
getResultsPerlScript_2() const | ms_mascotoptions
getReviewColDisplay(const MS_REVIEW_COL index) const | ms_mascotoptions
getReviewColWidth(const MS_REVIEW_COL index) const | ms_mascotoptions
getSearchLogFile() const | ms_mascotoptions
getSearchSubmitAcceptedFileTypes() const | ms_mascotoptions
getSearchSubmitDefaultPeptideCharge() const | ms_mascotoptions
getSearchSubmitMode() const | ms_mascotoptions
getSearchSubmitOutputFormat() const | ms_mascotoptions
getSelectSwitch() const | ms_mascotoptions
getSendmailPath() const | ms_mascotoptions
getShowSubsets() const | ms_mascotoptions
getSigThreshold() const | ms_mascotoptions
getSiteAnalysisMD10Prob() const | ms_mascotoptions
getSortUnassigned() const | ms_mascotoptions
getSpectraPerLibraryBlock() const | ms_mascotoptions
getSpectrumViewerColourSchemeNames() const | ms_mascotoptions
getSpectrumViewerColourSchemeString(const std::string &name) const | ms_mascotoptions
getSpectrumViewerDefaultColourSchemeName() const | ms_mascotoptions
getSplitDataFileSize() const | ms_mascotoptions
getSplitNumberOfQueries() const | ms_mascotoptions
getSVGSpectrumSwitch() const | ms_mascotoptions
getTargetFDRPercentage(const int index) const | ms_mascotoptions
getTaxBrowserUrl() const | ms_mascotoptions
getTestDirectory() const | ms_mascotoptions
getUniqueJobStartNumber() const | ms_mascotoptions
getUnixDirPerm() const | ms_mascotoptions
getUnixWebUserGroup() const | ms_mascotoptions
getVmemory() const | ms_mascotoptions
isAlwaysCreateDat28ResultsFile() const | ms_mascotoptions
isAlwaysEnableAutoDecoySearch() const | ms_mascotoptions
isAutoSelectCharge() const | ms_mascotoptions
isCreateLegacyModAndSubstitutionFiles() const | ms_mascotoptions
isDefaultTargetFDRPercentage(const int index) const | ms_mascotoptions
isEmailErrorsEnabled() const | ms_mascotoptions
isEmailUsersEnabled() const | ms_mascotoptions
isForkForUnixApache() const | ms_mascotoptions
isInIgnoreDupeAccessionList(const std::string value) const | ms_mascotoptions
isIteratePMFIntensities() const | ms_mascotoptions
isLabelAll() const | ms_mascotoptions
isMatchOppositeCrosslinkPairs() const | ms_mascotoptions
isMoveOldDbToOldDir() const | ms_mascotoptions
isPercolator() const | ms_mascotoptions
isPercolatorUseProteins() const | ms_mascotoptions
isPercolatorUseRT() const | ms_mascotoptions
isRemoveOldIndexFiles() const | ms_mascotoptions
isRequireBoldRed() const | ms_mascotoptions
isSaveEveryLastQueryAsc() const | ms_mascotoptions
isSaveLastQueryAsc() const | ms_mascotoptions
isSectionAvailable() const | ms_mascotoptions
isShowAllFromErrorTolerant() const | ms_mascotoptions
isShowSubsets() const | ms_mascotoptions
isStoreModPermutations() const | ms_mascotoptions
isUnixDirPermDefined() const | ms_mascotoptions
isUseHTTPProxyForFTP() const | ms_mascotoptions
isUseHTTPProxyForHTTPS() const | ms_mascotoptions
MASS_DECIMAL_PLACES enum value | ms_mascotoptions
MAX_EXEC_AFTER_SEARCH enum value | ms_mascotoptions
ms_customproperty() | ms_customproperty
ms_mascotoptions() | ms_mascotoptions
ms_mascotoptions(const ms_mascotoptions &src) | ms_mascotoptions
MS_REVIEW_COL enum name | ms_mascotoptions
MS_REVIEW_COL____LAST___ enum value | ms_mascotoptions
MS_REVIEW_COL_DATABASE enum value | ms_mascotoptions
MS_REVIEW_COL_DURATION enum value | ms_mascotoptions
MS_REVIEW_COL_ENZYMEUSED enum value | ms_mascotoptions
MS_REVIEW_COL_IPADDRESS enum value | ms_mascotoptions
MS_REVIEW_COL_JOB enum value | ms_mascotoptions
MS_REVIEW_COL_PEAKLISTDATAFILE enum value | ms_mascotoptions
MS_REVIEW_COL_PID enum value | ms_mascotoptions
MS_REVIEW_COL_PRIORITY enum value | ms_mascotoptions
MS_REVIEW_COL_RESULTS_FILE enum value | ms_mascotoptions
MS_REVIEW_COL_SEARCHTYPE enum value | ms_mascotoptions
MS_REVIEW_COL_START_TIME enum value | ms_mascotoptions
MS_REVIEW_COL_STATUS enum value | ms_mascotoptions
MS_REVIEW_COL_TITLE enum value | ms_mascotoptions
MS_REVIEW_COL_USEREMAIL enum value | ms_mascotoptions
MS_REVIEW_COL_USERID enum value | ms_mascotoptions
MS_REVIEW_COL_USERNAME enum value | ms_mascotoptions
NUMERICAL_VALUE_STORAGE enum name | ms_mascotoptions
operator=(const ms_mascotoptions &right) | ms_mascotoptions
PERC_EXE_RT enum name | ms_mascotoptions
PERC_EXE_RT_FORCE_OFF enum value | ms_mascotoptions
PERC_EXE_RT_FORCE_ON enum value | ms_mascotoptions
PERC_EXE_RT_USE_DEFAULT enum value | ms_mascotoptions
setAlwaysCreateDat28ResultsFile(const bool value) | ms_mascotoptions
setAlwaysEnableAutoDecoySearch(const bool value) | ms_mascotoptions
setAutoSelectCharge(const bool value) | ms_mascotoptions
setCacheDirectory(const char *value) | ms_mascotoptions
setCentroidWidth(const double value) | ms_mascotoptions
setCentroidWidthCount(const int value) | ms_mascotoptions
setCompressToolAA(const std::string value) | ms_mascotoptions
setCompressToolNA(const std::string value) | ms_mascotoptions
setCompressToolSL(const std::string value) | ms_mascotoptions
setCrawlerNumPeaksPer100Da(const int value) | ms_mascotoptions
setCreateLegacyModAndSubstitutionFiles(const bool value) | ms_mascotoptions
setCreatePipThreadBlockSize(const int blockSize) | ms_mascotoptions
setCreatePipThreads(const int nThreads) | ms_mascotoptions
setDechargeFragmentPeaks(const int maxCharge) | ms_mascotoptions
setDecoyTypeNoEnzyme(const int value) | ms_mascotoptions
setDecoyTypeSpecific(const int value) | ms_mascotoptions
setDefaultDelimiter(const char *delim) | ms_customproperty
setDefaultTargetFDRPercentage(const int index) | ms_mascotoptions
setDisplayNonSignificantMatches(const int value) | ms_mascotoptions
setEmailErrorsEnabled(const bool value) | ms_mascotoptions
setEmailFromTextName(const char *str) | ms_mascotoptions
setEmailFromUser(const char *str) | ms_mascotoptions
setEmailPassword(const char *str) | ms_mascotoptions
setEmailProfile(const char *str) | ms_mascotoptions
setEmailService(const char *str) | ms_mascotoptions
setEmailTimeOutPeriod(const int value) | ms_mascotoptions
setEmailUsersEnabled(const bool value) | ms_mascotoptions
setErrMessageEmailTo(const char *str) | ms_mascotoptions
setErrorLogFile(const char *str) | ms_mascotoptions
setErrTolMaxAccessions(const int value) | ms_mascotoptions
setExecAfterSearch(const int num, std::string value) | ms_mascotoptions
setFeatureTableLength(const int value) | ms_mascotoptions
setFeatureTableMinScore(const double value) | ms_mascotoptions
setForkForUnixApache(const bool value) | ms_mascotoptions
setFormVersion(const char *str) | ms_mascotoptions
setGetSeqBlastAccession(const ms_blastaccession *value) | ms_mascotoptions
setGetSeqJobIdFile(const char *str) | ms_mascotoptions
setICATFilter(const char *filterString) | ms_mascotoptions
setICATHeavy(const char *modName) | ms_mascotoptions
setICATLight(const char *modName) | ms_mascotoptions
setICATQuantitationMethod(const char *methodName) | ms_mascotoptions
setIgnoreDupeAccession(const unsigned int index, const std::string value) | ms_mascotoptions
setIgnoreIonsScoreBelow(const double value) | ms_mascotoptions
setIntensitySigFigs(const int value) | ms_mascotoptions
setInterFileBasePath(const char *str) | ms_mascotoptions
setInterFileRelPath(const char *str) | ms_mascotoptions
setIonsDecimalPlaces(const int value) | ms_mascotoptions
setIteratePMFIntensities(const bool value) | ms_mascotoptions
setLabelAll(const bool value) | ms_mascotoptions
setLastQueryAscFile(const char *str) | ms_mascotoptions
setLogoImageFile(const char *str) | ms_mascotoptions
setMailTempFile(const char *str) | ms_mascotoptions
setMailTransport(const int value) | ms_mascotoptions
setMascNodeCtrlFile(const char *str) | ms_mascotoptions
setMascotCmdLine(const char *str) | ms_mascotoptions
setMascotControlFile(const char *str) | ms_mascotoptions
setMascotFileProcessingThreads(const int value) | ms_mascotoptions
setMascotJobIdFile(const char *str) | ms_mascotoptions
setMascotMessage(const char *str) | ms_mascotoptions
setMassDecimalPlaces(const int value) | ms_mascotoptions
setMatchOppositeCrosslinkPairs(const bool value) | ms_mascotoptions
setMaxConcurrentSearches(const int value) | ms_mascotoptions
setMaxDatabases(const int value) | ms_mascotoptions
setMaxDescriptionLen(const int value) | ms_mascotoptions
setMaxEtagMassDelta(const double value) | ms_mascotoptions
setMaxEtVarMods(const int value) | ms_mascotoptions
setMaxIntactCrosslinkPeptides(const int value) | ms_mascotoptions
setMaxNumPeptides(const int value) | ms_mascotoptions
setMaxPepModArrangements(const int value) | ms_mascotoptions
setMaxPepNumModifiedSites(const int value) | ms_mascotoptions
setMaxPepNumVarMods(const int value) | ms_mascotoptions
setMaxQueries(const int value) | ms_mascotoptions
setMaxSearchesPerUser(const int value) | ms_mascotoptions
setMaxSequenceLen(const int value) | ms_mascotoptions
setMaxVarMods(const int value) | ms_mascotoptions
setMinEtagMassDelta(const double value) | ms_mascotoptions
setMinPepLenInPepSummary(const int value) | ms_mascotoptions
setMinPepLenInSearch(const int value) | ms_mascotoptions
setMonitorEmailCheckFreq(const int value) | ms_mascotoptions
setMonitorLogFile(const char *str) | ms_mascotoptions
setMonitorPidFile(const char *str) | ms_mascotoptions
setMonitorTestTimeout(const int value) | ms_mascotoptions
setMoveOldDbToOldDir(const bool value) | ms_mascotoptions
setMudpit(const int value) | ms_mascotoptions
setMudpitSwitch(const double value) | ms_mascotoptions
setNoResultsScript(const char *str) | ms_mascotoptions
setNTIUserGroup(const char *str) | ms_mascotoptions
setNTMonitorGroup(const char *str) | ms_mascotoptions
setPepSearchTool(const std::string value) | ms_mascotoptions
setPercolator(const bool value) | ms_mascotoptions
setPercolatorExeFlags(const char *value) | ms_mascotoptions
setPercolatorFeatures(std::string value) | ms_mascotoptions
setPercolatorMinQueries(const int value) | ms_mascotoptions
setPercolatorMinSequences(const int value) | ms_mascotoptions
setPercolatorTargetRankRelativeThreshold(const double threshold) | ms_mascotoptions
setPercolatorTargetRankScoreThreshold(const int threshold) | ms_mascotoptions
setPercolatorUseProteins(const bool value) | ms_mascotoptions
setPercolatorUseRT(const bool value) | ms_mascotoptions
setPreceedingComments(const std::string &comments) | ms_customproperty
setPrecursorCutOutLowerLimit(const double value) | ms_mascotoptions
setPrecursorCutOutUpperLimit(const double value) | ms_mascotoptions
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setProteinFamilySwitch(const int value) | ms_mascotoptions
setProteinsInResultsFile(const int value) | ms_mascotoptions
setProxyPassword(const char *str) | ms_mascotoptions
setProxyServer(const char *str) | ms_mascotoptions
setProxyType(const std::string &value) | ms_mascotoptions
setProxyUsername(const char *str) | ms_mascotoptions
setRemoveOldIndexFiles(const bool value) | ms_mascotoptions
setReportBuilderColumnArrangement(const int index, const std::string str) | ms_mascotoptions
setReportNumberChoice(const int index, const int value) | ms_mascotoptions
setRequireBoldRed(const bool value) | ms_mascotoptions
setResfileCache(const char *value) | ms_mascotoptions
setResultsCache(const char *value) | ms_mascotoptions
setResultsFileFormatVersion(const char *value) | ms_mascotoptions
setResultsFullURL(const char *str) | ms_mascotoptions
setResultsFullURL_2(std::string value) | ms_mascotoptions
setResultsPerlScript(const char *str) | ms_mascotoptions
setResultsPerlScript_2(std::string value) | ms_mascotoptions
setReviewColDisplay(const MS_REVIEW_COL index, const bool value) | ms_mascotoptions
setReviewColWidth(const MS_REVIEW_COL index, const int value) | ms_mascotoptions
setSaveEveryLastQueryAsc(const bool flag) | ms_mascotoptions
setSaveLastQueryAsc(const bool flag) | ms_mascotoptions
setSearchLogFile(const char *str) | ms_mascotoptions
setSearchSubmitAcceptedFileTypes(const std::string value) | ms_mascotoptions
setSearchSubmitDefaultPeptideCharge(const std::string value) | ms_mascotoptions
setSearchSubmitMode(const std::string value) | ms_mascotoptions
setSearchSubmitOutputFormat(const std::string value) | ms_mascotoptions
setSectionAvailable(const bool value) | ms_mascotoptions
setSelectSwitch(const int value) | ms_mascotoptions
setSendmailPath(const char *str) | ms_mascotoptions
setShowAllFromErrorTolerant(const bool value) | ms_mascotoptions
setShowSubsets(const bool value) | ms_mascotoptions
setShowSubsets(const double value) | ms_mascotoptions
setSigThreshold(const double value) | ms_mascotoptions
setSiteAnalysisMD10Prob(const double value) | ms_mascotoptions
setSortUnassigned(const std::string newValue) | ms_mascotoptions
setSpectraPerLibraryBlock(const int value) | ms_mascotoptions
setSpectrumViewerColourSchemeString(const std::string &name, const std::string &str, bool doCheck=true) | ms_mascotoptions
setSpectrumViewerDefaultColourSchemeName(const std::string &name) | ms_mascotoptions
setSplitDataFileSize(const int value) | ms_mascotoptions
setSplitNumberOfQueries(const int value) | ms_mascotoptions
setStoreModPermutations(const bool value) | ms_mascotoptions
setSVGSpectrumSwitch(const int value) | ms_mascotoptions
setTargetFDRPercentage(const int index, const double value, const bool makeDefault=false) | ms_mascotoptions
setTaxBrowserUrl(const std::string value) | ms_mascotoptions
setTestDirectory(const char *str) | ms_mascotoptions
setUniqueJobStartNumber(const int value) | ms_mascotoptions
setUnixDirPerm(const int value) | ms_mascotoptions
setUnixWebUserGroup(const int value) | ms_mascotoptions
setUseHTTPProxyForFTP(const bool value) | ms_mascotoptions
setUseHTTPProxyForHTTPS(const bool value) | ms_mascotoptions
setVmemory(const INT64 value) | ms_mascotoptions
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
~ms_mascotoptions() | ms_mascotoptions
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_mascotresfile_dat
ms_mascotresfile_dat Member List

This is the complete list of members for ms_mascotresfile_dat, including all inherited members.

anyCrosslinkedMatches(const bool isDecoy=false) const override | ms_mascotresfile_dat | virtual
anyErrorTolerantMatches(const bool isDecoy=false) const override | ms_mascotresfile_dat | virtual
anyFastaMatches(const bool isDecoy=false) const override | ms_mascotresfile_dat | virtual
anyMSMS() const override | ms_mascotresfile_dat | virtual
anyPeptideSummaryMatches(const section sec=SEC_PEPTIDES) const | ms_mascotresfile_dat |
anyPMF() const override | ms_mascotresfile_dat | virtual
anySpectralLibraryMatches(const bool isDecoy=false) const override | ms_mascotresfile_dat | virtual
anySQ() const override | ms_mascotresfile_dat | virtual
anyTag() const override | ms_mascotresfile_dat | virtual
matrix_science::ms_errors::appendErrors(const ms_errors &src) | ms_errors |
appendResfile(const char *filename, int flags=RESFILE_USE_PARENT_PARAMS, const char *cacheDirectory=0) override | ms_mascotresfile_dat | virtual
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
createResfile(const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, matrix_science::ms_progress_info *progressMonitor=0) | ms_mascotresfilebase | static
doesSectionExist(const section sec) const | ms_mascotresfile_dat |
enumerateQuerySectionKeys(const int query, const int num, int *pPreviousNum=0, OFFSET64_T *pPreviousOffset=0) const | ms_mascotresfile_dat |
enumerateSectionKeys(const section sec, const int num, int *pPreviousNum=0, OFFSET64_T *pPreviousOffset=0) const | ms_mascotresfile_dat |
err enum name | ms_mascotresfile_dat |
ERR_ACCINPEPTIDESTR enum value | ms_mascotresfile_dat |
ERR_ADDPEPTIDES enum value | ms_mascotresfile_dat |
ERR_CANNOT_APPEND_RESFILE enum value | ms_mascotresfile_dat |
ERR_CANNOT_APPEND_RESFILE_NO_FNAMES enum value | ms_mascotresfile_dat |
ERR_CDB_64_BIT_REMAKE enum value | ms_mascotresfile_dat |
ERR_CDB_BEING_CREATED enum value | ms_mascotresfile_dat |
ERR_CDB_FAIL_LOCK enum value | ms_mascotresfile_dat |
ERR_CDB_FAIL_REMOVE enum value | ms_mascotresfile_dat |
ERR_CDB_FAIL_UNLOCK enum value | ms_mascotresfile_dat |
ERR_CDB_INCOMPLETE_NO_RETRY enum value | ms_mascotresfile_dat |
ERR_CDB_INCOMPLETE_RETRY enum value | ms_mascotresfile_dat |
ERR_CDB_OLD_VER_NO_RETRY enum value | ms_mascotresfile_dat |
ERR_CDB_OLD_VER_RETRY enum value | ms_mascotresfile_dat |
ERR_CDB_SOURCE_CHANGE_NO_RETRY enum value | ms_mascotresfile_dat |
ERR_CDB_SOURCE_CHANGE_RETRY enum value | ms_mascotresfile_dat |
ERR_CDB_TOO_LARGE enum value | ms_mascotresfile_dat |
ERR_DUPE_ACCESSION enum value | ms_mascotresfile_dat |
ERR_DUPLICATE_KEY enum value | ms_mascotresfile_dat |
ERR_FAIL_CDB_INIT enum value | ms_mascotresfile_dat |
ERR_FAIL_CLOSE_FILE enum value | ms_mascotresfile_dat |
ERR_FAIL_MK_CACHE_DIR enum value | ms_mascotresfile_dat |
ERR_FAIL_MK_CDB_FILE enum value | ms_mascotresfile_dat |
ERR_FAIL_OPEN_DAT_FILE enum value | ms_mascotresfile_dat |
ERR_INVALID_CACHE_DIR enum value | ms_mascotresfile_dat |
ERR_INVALID_CDB_FILE enum value | ms_mascotresfile_dat |
ERR_INVALID_NUMQUERIES enum value | ms_mascotresfile_dat |
ERR_INVALID_PROTDB enum value | ms_mascotresfile_dat |
ERR_INVALID_RESFILE enum value | ms_mascotresfile_dat |
ERR_MALFORMED_DRANGE enum value | ms_mascotresfile_dat |
ERR_MALFORMED_ERR_TOL enum value | ms_mascotresfile_dat |
ERR_MALFORMED_TAG enum value | ms_mascotresfile_dat |
ERR_MALFORMED_TERMS enum value | ms_mascotresfile_dat |
ERR_MISSING_CDB_FILE enum value | ms_mascotresfile_dat |
ERR_MISSING_PERCOLATOR_FILE enum value | ms_mascotresfile_dat |
ERR_MISSINGENTRY enum value | ms_mascotresfile_dat |
ERR_MISSINGHIT enum value | ms_mascotresfile_dat |
ERR_MISSINGSECTION enum value | ms_mascotresfile_dat |
ERR_MISSINGSECTIONEND enum value | ms_mascotresfile_dat |
ERR_NEED_64_BIT enum value | ms_mascotresfile_dat |
ERR_NO_ERR_TOL_PARENT enum value | ms_mascotresfile_dat |
ERR_NO_ERROR enum value | ms_mascotresfile_dat |
ERR_NO_UNIGENE_FILE enum value | ms_mascotresfile_dat |
ERR_NOMEM enum value | ms_mascotresfile_dat |
ERR_NOSUCHFILE enum value | ms_mascotresfile_dat |
ERR_NULL_ACC_PEP_SUM enum value | ms_mascotresfile_dat |
ERR_NULL_ACC_PROT_SUM enum value | ms_mascotresfile_dat |
ERR_OLDRESULTSFILE enum value | ms_mascotresfile_dat |
ERR_PEPSUMMPEPGET enum value | ms_mascotresfile_dat |
ERR_PEPTIDESTR enum value | ms_mascotresfile_dat |
ERR_PROTSUMM enum value | ms_mascotresfile_dat |
ERR_PROTSUMMPEP enum value | ms_mascotresfile_dat |
ERR_QUERYOUTOFRANGE enum value | ms_mascotresfile_dat |
ERR_READINGFILE enum value | ms_mascotresfile_dat |
ERR_RESULTS_NOT_CREATED enum value | ms_mascotresfile_dat |
ERR_UNASSIGNED_PROG enum value | ms_mascotresfile_dat |
ERR_UNASSIGNED_RANGE enum value | ms_mascotresfile_dat |
ERR_UNASSIGNED_UNK enum value | ms_mascotresfile_dat |
ERR_UNIGENE_MULTIDB enum value | ms_mascotresfile_dat |
ERR_WRITE_CDB_FILE enum value | ms_mascotresfile_dat |
FLAGS enum name | ms_mascotresfilebase |
get_ms_mascotresults_params(const ms_mascotoptions &opts, ms_mascotresults_params &params) const | ms_mascotresfilebase |
get_ms_mascotresults_params(const ms_mascotoptions &opts, unsigned int *gpFlags, double *gpMinProbability, int *gpMaxHitsToReport, double *gpIgnoreIonsScoreBelow, unsigned int *gpMinPepLenInPepSummary, bool *gpUsePeptideSummary, unsigned int *gpFlags2) const | ms_mascotresfilebase |
getCacheDirectory(bool processed=true) const override | ms_mascotresfile_dat | virtual
getCacheFileName() const override | ms_mascotresfile_dat | virtual
getCrosslinking(ms_crosslinking_configfile *crosslinkingFile) const override | ms_mascotresfile_dat | protectedvirtual
getCrosslinkingMethod(ms_crosslinking_method *method) const | ms_mascotresfilebase |
getDatabaseType(const int idx) const override | ms_mascotresfile_dat | virtual
getDate() const override | ms_mascotresfile_dat | inlinevirtual
getDecoyTypeForDB(const int idx=1) const override | ms_mascotresfile_dat | virtual
getEnzyme(ms_enzymefile *efile, const char *enzymeFileName=0) const override | ms_mascotresfile_dat | virtual
getErrorHandler() const | ms_errors |
getErrorInfoAsString(const int num) const | ms_mascotresfilebase | protected
getErrorNumber(const int num=-1) const | ms_mascotresfilebase |
getErrorString(const int num) const | ms_mascotresfilebase |
getExecTime() const override | ms_mascotresfile_dat | inlinevirtual
getFastaPath(int idx=1) const override | ms_mascotresfile_dat | virtual
getFastaVer(int idx=1) const override | ms_mascotresfile_dat | virtual
getFileName(const int id=1) const override | ms_mascotresfile_dat | virtual
getFirstPassThreshold() const override | ms_mascotresfile_dat | virtual
getHeaderKeyValues(std::vector< std::string > &keys, std::vector< std::string > &values) const override | ms_mascotresfile_dat | virtual
getHeaderValue(const std::string &key) const override | ms_mascotresfile_dat | virtual
getInputQuery(const int queryNum) const override | ms_mascotresfile_dat | virtual
getJobNumber(const int resfileID=1) const override | ms_mascotresfile_dat | virtual
getKeepAlive(KA_TASK &kaTask, int &kaPercentage, std::string &kaAccession, int &kaHit, int &kaQuery, std::string &kaText) const | ms_mascotresfilebase |
getLastError() const | ms_mascotresfilebase |
getLastErrorString() const | ms_mascotresfilebase |
getLibraryMods(std::vector< std::string > &modNames, std::vector< double > &modDeltas) const override | ms_mascotresfile_dat | virtual
getMascotVer() const override | ms_mascotresfile_dat | inlinevirtual
getMasses(ms_masses *masses) const | ms_mascotresfilebase |
getMassesKeyValues(std::vector< std::string > &keys, std::vector< double > &values) const override | ms_mascotresfile_dat | virtual
getMassValue(const std::string &key) const override | ms_mascotresfile_dat | virtual
getMonoLinkModification(const int modNum, const int monoLink) const | ms_mascotresfilebase |
getMSParserVersion() const | ms_mascotresfilebase |
getMultiFileQueryNumber(const int localQuery, const int fileId) const override | ms_mascotresfile_dat | virtual
getNumberOfErrors() const | ms_mascotresfilebase |
getNumberOfResfiles() const override | ms_mascotresfile_dat | virtual
getNumEtSeqsSearched(const int idx=0) const override | ms_mascotresfile_dat | virtual
getNumHits(const section sec=SEC_SUMMARY) const | ms_mascotresfile_dat |
getNumLibraryEntries(const int idx=0) const override | ms_mascotresfile_dat | virtual
getNumQueries(const int resfileID=0) const override | ms_mascotresfile_dat | virtual
getNumResidues(const int idx=0) const override | ms_mascotresfile_dat | virtual
getNumSeqs(const int idx=0) const override | ms_mascotresfile_dat | virtual
getNumSeqsAfterTax(const int idx=0) const override | ms_mascotresfile_dat | virtual
getObservedCharge(const int query, const bool decoy=false) const override | ms_mascotresfile_dat | virtual
getObservedIntensity(const int query) const override | ms_mascotresfile_dat | virtual
getObservedMass(const int query) const override | ms_mascotresfile_dat | virtual
getObservedMrValue(const int query, const bool decoy=false) const override | ms_mascotresfile_dat | virtual
getPeptideSection(const ms_peptide::PSM_TYPE pepType) | ms_mascotresfile_dat | static
getPercolatorFileNames() const | ms_mascotresfilebase |
getProgressInfo(bool forPeptideSummary=false) const | ms_mascotresfilebase |
getQmatch(const int query, const ms_peptide::PSM_TYPE pepType) const override | ms_mascotresfile_dat | virtual
getQplughole(const int query, const ms_peptide::PSM_TYPE pepType) const override | ms_mascotresfile_dat | virtual
getQuantitation(ms_quant_configfile *qfile) const override | ms_mascotresfile_dat | virtual
getQuantitationMethod(ms_quant_method *qmethod) const | ms_mascotresfilebase |
getQuerySectionValue(const int query, const char *key, char *str, int maxLen) const | ms_mascotresfile_dat |
getQuerySectionValueDouble(const int query, const char *key) const | ms_mascotresfile_dat |
getQuerySectionValueInt(const int query, const char *key) const | ms_mascotresfile_dat |
getQuerySectionValueStr(const int query, const char *key) const | ms_mascotresfile_dat |
getReferenceDatabaseNumberOfSL(const int idx) const override | ms_mascotresfile_dat | virtual
getRepeatSearchString(const int query, const bool fullQuery=false) const override | ms_mascotresfile_dat | virtual
getResfile(int id) const override | ms_mascotresfile_dat | virtual
getSearchParameter(const std::string &key) const override | ms_mascotresfile_dat | virtual
getSearchParametersKeyValues(std::vector< std::string > &keys, std::vector< std::string > &values) const override | ms_mascotresfile_dat | virtual
getSectionName(const section sec) | ms_mascotresfile_dat | static
getSectionValue(const section sec, const char *key, char *str, int maxLen) const | ms_mascotresfile_dat |
getSectionValueDouble(const section sec, const char *key) const | ms_mascotresfile_dat |
getSectionValueInt(const section sec, const char *key) const | ms_mascotresfile_dat |
getSectionValueStr(const section sec, const char *key) const | ms_mascotresfile_dat |
getSLDatabaseNumbersOfReference(const int idx) const override | ms_mascotresfile_dat | virtual
getSLExecCommand(int idx=1) const override | ms_mascotresfile_dat | virtual
getSLFragmentTolerance(int idx=1) const override | ms_mascotresfile_dat | virtual
getSLFragmentToleranceUnit(int idx=1) const override | ms_mascotresfile_dat | virtual
getSrcQueryAndFileIdForMultiFile(const int q, int &gsqNewQuery, int &gsqFileId) const override | ms_mascotresfile_dat | virtual
getSummarySection(const ms_peptide::PSM_TYPE pepType) | ms_mascotresfile_dat | static
getTaxonomy(ms_taxonomyfile *tfile) const override | ms_mascotresfile_dat | virtual
getUnimod(ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const override | ms_mascotresfile_dat | virtual
getUnimodXL(ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const override | ms_mascotresfile_dat | virtual
getUniqueTaskID() const override | ms_mascotresfile_dat | virtual
getXMLschemaFilePath(XML_SCHEMA XMLschema) const | ms_mascotresfilebase |
hasEnzyme() const override | ms_mascotresfile_dat | virtual
hasQuantitation() const override | ms_mascotresfile_dat | virtual
hasRT() const override | ms_mascotresfile_dat | virtual
isDatabaseTypeAvailable() const override | ms_mascotresfile_dat | virtual
isErrorTolerant() const override | ms_mascotresfile_dat | virtual
isMSMS() const override | ms_mascotresfile_dat | virtual
isPMF() const override | ms_mascotresfile_dat | virtual
isSQ() const override | ms_mascotresfile_dat | virtual
isValid() const | ms_errors |
KA_ASSIGNPROTEINS_AP enum value | ms_mascotresfilebase |
KA_CREATECACHE_CC enum value | ms_mascotresfilebase |
KA_CREATEINDEX_CI enum value | ms_mascotresfilebase |
KA_GROUPPROTEINS_GP enum value | ms_mascotresfilebase |
KA_LAST enum value | ms_mascotresfilebase |
KA_QUANTITATION enum value | ms_mascotresfilebase |
KA_READFILE_RF enum value | ms_mascotresfilebase |
KA_TASK enum name | ms_mascotresfilebase |
KA_THRESHFORFDR_FDR enum value | ms_mascotresfilebase |
KA_UNASSIGNEDLIST_UL enum value | ms_mascotresfilebase |
ms_errors() | ms_errors |
ms_mascotresfile_dat(const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0) | ms_mascotresfile_dat |
ms_mascotresfilebase(const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory=0, const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0) | ms_mascotresfilebase |
outputKeepAlive() const | ms_mascotresfilebase |
params() const | ms_mascotresfilebase | inline
PERCOLATOR_FILE_NAMES enum name | ms_mascotresfilebase |
PERCOLATOR_INPUT_FILE enum value | ms_mascotresfilebase |
PERCOLATOR_OUTPUT_DECOY enum value | ms_mascotresfilebase |
PERCOLATOR_OUTPUT_TARGET enum value | ms_mascotresfilebase |
resetKeepAlive(const int keepAliveInterval, const char *keepAliveText, const bool propagateToAppended=true, const bool resetStartTime=false) | ms_mascotresfilebase |
RESFILE_CACHE_IGNORE_ACC_DUPES enum value | ms_mascotresfilebase |
RESFILE_CACHE_IGNORE_DATE_CHANGE enum value | ms_mascotresfilebase |
RESFILE_DAT28 enum value | ms_mascotresfilebase |
RESFILE_MSR enum value | ms_mascotresfilebase |
RESFILE_NOFLAG enum value | ms_mascotresfilebase |
RESFILE_TYPE enum name | ms_mascotresfilebase |
RESFILE_UNKNOWN enum value | ms_mascotresfilebase |
RESFILE_USE_CACHE enum value | ms_mascotresfilebase |
RESFILE_USE_PARENT_PARAMS enum value | ms_mascotresfilebase |
resfileType(const std::string &fileName) | ms_mascotresfilebase | static
SEC_CROSSLINK_PEPTIDES enum value | ms_mascotresfile_dat |
SEC_CROSSLINK_SUMMARY enum value | ms_mascotresfile_dat |
SEC_CROSSLINKING enum value | ms_mascotresfile_dat |
SEC_DECOYMIXTURE enum value | ms_mascotresfile_dat |
SEC_DECOYPEPTIDES enum value | ms_mascotresfile_dat |
SEC_DECOYPROTEINS enum value | ms_mascotresfile_dat |
SEC_DECOYSUMMARY enum value | ms_mascotresfile_dat |
SEC_ENZYME enum value | ms_mascotresfile_dat |
SEC_ERRTOLDECOYPEPTIDES enum value | ms_mascotresfile_dat |
SEC_ERRTOLDECOYSUMMARY enum value | ms_mascotresfile_dat |
SEC_ERRTOLPEPTIDES enum value | ms_mascotresfile_dat |
SEC_ERRTOLSUMMARY enum value | ms_mascotresfile_dat |
SEC_HEADER enum value | ms_mascotresfile_dat |
SEC_INDEX enum value | ms_mascotresfile_dat |
SEC_LIBRARYPEPTIDES enum value | ms_mascotresfile_dat |
SEC_LIBRARYSUMMARY enum value | ms_mascotresfile_dat |
SEC_MASSES enum value | ms_mascotresfile_dat |
SEC_MIXTURE enum value | ms_mascotresfile_dat |
SEC_NUMSECTIONS enum value | ms_mascotresfile_dat |
SEC_PARAMETERS enum value | ms_mascotresfile_dat |
SEC_PEPTIDES enum value | ms_mascotresfile_dat |
SEC_PROTEINS enum value | ms_mascotresfile_dat |
SEC_QUANTITATION enum value | ms_mascotresfile_dat |
SEC_QUERY1 enum value | ms_mascotresfile_dat |
SEC_SPECTRAL_LIBRARY enum value | ms_mascotresfile_dat |
SEC_SUMMARY enum value | ms_mascotresfile_dat |
SEC_TAXONOMY enum value | ms_mascotresfile_dat |
SEC_UNIMOD enum value | ms_mascotresfile_dat |
SEC_UNIMOD_XL enum value | ms_mascotresfile_dat |
section enum name | ms_mascotresfile_dat |
setErrorInfoFromString(const std::string &e) | ms_mascotresfilebase | protected
setPercolatorFeatures(const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes) | ms_mascotresfilebase |
setPercolatorFeatures(const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters=std::vector< std::string >()) | ms_mascotresfilebase |
setXMLschemaFilePath(XML_SCHEMA XMLschema, const char *path) | ms_mascotresfilebase |
staticGetPercolatorFileNames(const char *szFileName, const char *cacheDirectory, const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes, std::vector< std::string > &filenames, std::vector< bool > &exists) | ms_mascotresfilebase | static
staticGetPercolatorFileNames(const char *szFileName, const char *cacheDirectory, const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters, std::vector< std::string > &filenames, std::vector< bool > &exists) | ms_mascotresfilebase | static
versionGreaterOrEqual(int major, int minor, int revision) const | ms_mascotresfilebase |
willCreateCache(const char *szFileName, const unsigned int flags, const char *cacheDirectory, std::string *cacheFileName) | ms_mascotresfilebase | static
willCreateCache(const char *szFileName, const ms_mascotoptions &opts, const char *applicationName, std::string &resfileCacheFileName, unsigned int &cacheStatus) | ms_mascotresfilebase | static
XML_SCHEMA enum name | ms_mascotresfilebase |
XML_SCHEMA_CROSSLINKING enum value | ms_mascotresfilebase |
XML_SCHEMA_DIRECTORY enum value | ms_mascotresfilebase |
XML_SCHEMA_LAST enum value | ms_mascotresfilebase |
XML_SCHEMA_QUANTITATION enum value | ms_mascotresfilebase |
XML_SCHEMA_UNIMOD enum value | ms_mascotresfilebase |
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_mascotresfile_msr
ms_mascotresfile_msr Member List

This is the complete list of members for ms_mascotresfile_msr, including all inherited members.

anyCrosslinkedMatches(const bool isDecoy=false) const override | ms_mascotresfile_msr | virtual
anyErrorTolerantMatches(const bool isDecoy=false) const override | ms_mascotresfile_msr | virtual
anyFastaMatches(const bool isDecoy=false) const override | ms_mascotresfile_msr | virtual
anyMSMS() const override | ms_mascotresfile_msr | virtual
anyPMF() const override | ms_mascotresfile_msr | virtual
anySpectralLibraryMatches(const bool isDecoy=false) const override | ms_mascotresfile_msr | virtual
anySQ() const override | ms_mascotresfile_msr | virtual
anyTag() const override | ms_mascotresfile_msr | virtual
matrix_science::ms_errors::appendErrors(const ms_errors &src) | ms_errors |
appendResfile(const char *filename, int flags=RESFILE_USE_PARENT_PARAMS, const char *cacheDirectory=0) override | ms_mascotresfile_msr | virtual
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
createResfile(const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, matrix_science::ms_progress_info *progressMonitor=0) | ms_mascotresfilebase | static
FLAGS enum name | ms_mascotresfilebase |
get_ms_mascotresults_params(const ms_mascotoptions &opts, ms_mascotresults_params &params) const | ms_mascotresfilebase |
get_ms_mascotresults_params(const ms_mascotoptions &opts, unsigned int *gpFlags, double *gpMinProbability, int *gpMaxHitsToReport, double *gpIgnoreIonsScoreBelow, unsigned int *gpMinPepLenInPepSummary, bool *gpUsePeptideSummary, unsigned int *gpFlags2) const | ms_mascotresfilebase |
getCacheDirectory(bool processed=true) const override | ms_mascotresfile_msr | virtual
getCacheFileName() const override | ms_mascotresfile_msr | virtual
getCrosslinking(ms_crosslinking_configfile *crosslinkingFile) const override | ms_mascotresfile_msr | protectedvirtual
getCrosslinkingMethod(ms_crosslinking_method *method) const | ms_mascotresfilebase |
getDatabaseType(const int idx) const override | ms_mascotresfile_msr | virtual
getDate() const override | ms_mascotresfile_msr | virtual
getDecoyTypeForDB(const int idx=1) const override | ms_mascotresfile_msr | virtual
getEnzyme(ms_enzymefile *efile, const char *enzymeFileName=0) const override | ms_mascotresfile_msr | virtual
getErrorHandler() const | ms_errors |
getErrorInfoAsString(const int num) const | ms_mascotresfilebase | protected
getErrorNumber(const int num=-1) const | ms_mascotresfilebase |
getErrorString(const int num) const | ms_mascotresfilebase |
getExecTime() const override | ms_mascotresfile_msr | virtual
getFastaPath(int idx=1) const override | ms_mascotresfile_msr | virtual
getFastaVer(int idx=1) const override | ms_mascotresfile_msr | virtual
getFileName(const int id=1) const override | ms_mascotresfile_msr | virtual
getFirstPassThreshold() const override | ms_mascotresfile_msr | virtual
getHeaderKeyValues(std::vector< std::string > &keys, std::vector< std::string > &values) const override | ms_mascotresfile_msr | virtual
getHeaderValue(const std::string &key) const override | ms_mascotresfile_msr | virtual
getInputQuery(const int queryNum) const override | ms_mascotresfile_msr | virtual
getJobNumber(const int resfileID=1) const override | ms_mascotresfile_msr | virtual
getKeepAlive(KA_TASK &kaTask, int &kaPercentage, std::string &kaAccession, int &kaHit, int &kaQuery, std::string &kaText) const | ms_mascotresfilebase |
getLastError() const | ms_mascotresfilebase |
getLastErrorString() const | ms_mascotresfilebase |
getLibraryMods(std::vector< std::string > &modNames, std::vector< double > &modDeltas) const override | ms_mascotresfile_msr | virtual
getMascotVer() const override | ms_mascotresfile_msr | virtual
getMasses(ms_masses *masses) const | ms_mascotresfilebase |
getMassesKeyValues(std::vector< std::string > &keys, std::vector< double > &values) const override | ms_mascotresfile_msr | virtual
getMassValue(const std::string &key) const override | ms_mascotresfile_msr | virtual
getMonoLinkModification(const int modNum, const int monoLink) const | ms_mascotresfilebase |
getMSParserVersion() const | ms_mascotresfilebase |
getMultiFileQueryNumber(const int localQuery, const int fileId) const override | ms_mascotresfile_msr | virtual
getNumberOfErrors() const | ms_mascotresfilebase |
getNumberOfResfiles() const override | ms_mascotresfile_msr | virtual
getNumEtSeqsSearched(const int idx=0) const override | ms_mascotresfile_msr | virtual
getNumLibraryEntries(const int idx=0) const override | ms_mascotresfile_msr | virtual
getNumQueries(const int resfileID=0) const override | ms_mascotresfile_msr | virtual
getNumResidues(const int idx=0) const override | ms_mascotresfile_msr | virtual
getNumSeqs(const int idx=0) const override | ms_mascotresfile_msr | virtual
getNumSeqsAfterTax(const int idx=0) const override | ms_mascotresfile_msr | virtual
getObservedCharge(const int query, const bool decoy=false) const override | ms_mascotresfile_msr | virtual
getObservedIntensity(const int query) const override | ms_mascotresfile_msr | virtual
getObservedMass(const int query) const override | ms_mascotresfile_msr | virtual
getObservedMrValue(const int query, const bool decoy=false) const override | ms_mascotresfile_msr | virtual
getPercolatorFileNames() const | ms_mascotresfilebase |
getProgressInfo(bool forPeptideSummary=false) const | ms_mascotresfilebase |
getQmatch(const int query, const ms_peptide::PSM_TYPE pepType) const override | ms_mascotresfile_msr | virtual
getQplughole(const int query, const ms_peptide::PSM_TYPE pepType) const override | ms_mascotresfile_msr | virtual
getQuantitation(ms_quant_configfile *qfile) const override | ms_mascotresfile_msr | virtual
getQuantitationMethod(ms_quant_method *qmethod) const | ms_mascotresfilebase |
getReferenceDatabaseNumberOfSL(const int idx) const override | ms_mascotresfile_msr | virtual
getRepeatSearchString(const int query, const bool fullQuery=false) const override | ms_mascotresfile_msr | virtual
getResfile(int id) const override | ms_mascotresfile_msr | virtual
getSearchParameter(const std::string &key) const override | ms_mascotresfile_msr | virtual
getSearchParametersKeyValues(std::vector< std::string > &keys, std::vector< std::string > &values) const override | ms_mascotresfile_msr | virtual
getSLDatabaseNumbersOfReference(const int idx) const override | ms_mascotresfile_msr | virtual
getSLExecCommand(int idx=1) const override | ms_mascotresfile_msr | virtual
getSLFragmentTolerance(int idx=1) const override | ms_mascotresfile_msr | virtual
getSLFragmentToleranceUnit(int idx=1) const override | ms_mascotresfile_msr | virtual
getSrcQueryAndFileIdForMultiFile(const int q, int &gsqNewQuery, int &gsqFileId) const override | ms_mascotresfile_msr | virtual
getTaxonomy(ms_taxonomyfile *tfile) const override | ms_mascotresfile_msr | virtual
getUnimod(ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const override | ms_mascotresfile_msr | virtual
getUnimodXL(ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const override | ms_mascotresfile_msr | virtual
getUniqueTaskID() const override | ms_mascotresfile_msr | virtual
getXMLschemaFilePath(XML_SCHEMA XMLschema) const | ms_mascotresfilebase |
hasEnzyme() const override | ms_mascotresfile_msr | virtual
hasQuantitation() const override | ms_mascotresfile_msr | virtual
hasRT() const override | ms_mascotresfile_msr | virtual
isDatabaseTypeAvailable() const override | ms_mascotresfile_msr | virtual
isErrorTolerant() const override | ms_mascotresfile_msr | virtual
isMSMS() const override | ms_mascotresfile_msr | virtual
isPMF() const override | ms_mascotresfile_msr | virtual
isSQ() const override | ms_mascotresfile_msr | virtual
isValid() const | ms_errors |
KA_ASSIGNPROTEINS_AP enum value | ms_mascotresfilebase |
KA_CREATECACHE_CC enum value | ms_mascotresfilebase |
KA_CREATEINDEX_CI enum value | ms_mascotresfilebase |
KA_GROUPPROTEINS_GP enum value | ms_mascotresfilebase |
KA_LAST enum value | ms_mascotresfilebase |
KA_QUANTITATION enum value | ms_mascotresfilebase |
KA_READFILE_RF enum value | ms_mascotresfilebase |
KA_TASK enum name | ms_mascotresfilebase |
KA_THRESHFORFDR_FDR enum value | ms_mascotresfilebase |
KA_UNASSIGNEDLIST_UL enum value | ms_mascotresfilebase |
ms_errors() | ms_errors |
ms_mascotresfile_msr(const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0) | ms_mascotresfile_msr |
ms_mascotresfilebase(const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory=0, const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0) | ms_mascotresfilebase |
outputKeepAlive() const | ms_mascotresfilebase |
params() const | ms_mascotresfilebase | inline
PERCOLATOR_FILE_NAMES enum name | ms_mascotresfilebase |
PERCOLATOR_INPUT_FILE enum value | ms_mascotresfilebase |
PERCOLATOR_OUTPUT_DECOY enum value | ms_mascotresfilebase |
PERCOLATOR_OUTPUT_TARGET enum value | ms_mascotresfilebase |
resetKeepAlive(const int keepAliveInterval, const char *keepAliveText, const bool propagateToAppended=true, const bool resetStartTime=false) | ms_mascotresfilebase |
RESFILE_CACHE_IGNORE_ACC_DUPES enum value | ms_mascotresfilebase |
RESFILE_CACHE_IGNORE_DATE_CHANGE enum value | ms_mascotresfilebase |
RESFILE_DAT28 enum value | ms_mascotresfilebase |
RESFILE_MSR enum value | ms_mascotresfilebase |
RESFILE_NOFLAG enum value | ms_mascotresfilebase |
RESFILE_TYPE enum name | ms_mascotresfilebase |
RESFILE_UNKNOWN enum value | ms_mascotresfilebase |
RESFILE_USE_CACHE enum value | ms_mascotresfilebase |
RESFILE_USE_PARENT_PARAMS enum value | ms_mascotresfilebase |
resfileType(const std::string &fileName) | ms_mascotresfilebase | static
setErrorInfoFromString(const std::string &e) | ms_mascotresfilebase | protected
setPercolatorFeatures(const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes) | ms_mascotresfilebase |
setPercolatorFeatures(const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters=std::vector< std::string >()) | ms_mascotresfilebase |
setXMLschemaFilePath(XML_SCHEMA XMLschema, const char *path) | ms_mascotresfilebase |
staticGetPercolatorFileNames(const char *szFileName, const char *cacheDirectory, const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes, std::vector< std::string > &filenames, std::vector< bool > &exists) | ms_mascotresfilebase | static
staticGetPercolatorFileNames(const char *szFileName, const char *cacheDirectory, const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters, std::vector< std::string > &filenames, std::vector< bool > &exists) | ms_mascotresfilebase | static
versionGreaterOrEqual(int major, int minor, int revision) const | ms_mascotresfilebase |
willCreateCache(const char *szFileName, const unsigned int flags, const char *cacheDirectory, std::string *cacheFileName) | ms_mascotresfilebase | static
willCreateCache(const char *szFileName, const ms_mascotoptions &opts, const char *applicationName, std::string &resfileCacheFileName, unsigned int &cacheStatus) | ms_mascotresfilebase | static
XML_SCHEMA enum name | ms_mascotresfilebase |
XML_SCHEMA_CROSSLINKING enum value | ms_mascotresfilebase |
XML_SCHEMA_DIRECTORY enum value | ms_mascotresfilebase |
XML_SCHEMA_LAST enum value | ms_mascotresfilebase |
XML_SCHEMA_QUANTITATION enum value | ms_mascotresfilebase |
XML_SCHEMA_UNIMOD enum value | ms_mascotresfilebase |
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_mascotresfilebase
ms_mascotresfilebase Member List

This is the complete list of members for ms_mascotresfilebase, including all inherited members.

anyCrosslinkedMatches(const bool isDecoy=false) const =0 | ms_mascotresfilebase | pure virtual
anyErrorTolerantMatches(const bool isDecoy=false) const =0 | ms_mascotresfilebase | pure virtual
anyFastaMatches(const bool isDecoy=false) const =0 | ms_mascotresfilebase | pure virtual
anyMSMS() const =0 | ms_mascotresfilebase | pure virtual
anyPMF() const =0 | ms_mascotresfilebase | pure virtual
anySpectralLibraryMatches(const bool isDecoy=false) const =0 | ms_mascotresfilebase | pure virtual
anySQ() const =0 | ms_mascotresfilebase | pure virtual
anyTag() const =0 | ms_mascotresfilebase | pure virtual
matrix_science::ms_errors::appendErrors(const ms_errors &src) | ms_errors |
appendResfile(const char *filename, int flags=RESFILE_USE_PARENT_PARAMS, const char *cacheDirectory=0)=0 | ms_mascotresfilebase | pure virtual
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
createResfile(const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, matrix_science::ms_progress_info *progressMonitor=0) | ms_mascotresfilebase | static
FLAGS enum name | ms_mascotresfilebase |
get_ms_mascotresults_params(const ms_mascotoptions &opts, ms_mascotresults_params &params) const | ms_mascotresfilebase |
get_ms_mascotresults_params(const ms_mascotoptions &opts, unsigned int *gpFlags, double *gpMinProbability, int *gpMaxHitsToReport, double *gpIgnoreIonsScoreBelow, unsigned int *gpMinPepLenInPepSummary, bool *gpUsePeptideSummary, unsigned int *gpFlags2) const | ms_mascotresfilebase |
getCacheDirectory(bool processed=true) const =0 | ms_mascotresfilebase | pure virtual
getCacheFileName() const =0 | ms_mascotresfilebase | pure virtual
getCrosslinking(ms_crosslinking_configfile *crosslinkingFile) const =0 | ms_mascotresfilebase | protectedpure virtual
getCrosslinkingMethod(ms_crosslinking_method *method) const | ms_mascotresfilebase |
getDatabaseType(const int idx) const =0 | ms_mascotresfilebase | pure virtual
getDate() const =0 | ms_mascotresfilebase | pure virtual
getDecoyTypeForDB(const int idx=1) const =0 | ms_mascotresfilebase | pure virtual
getEnzyme(ms_enzymefile *efile, const char *enzymeFileName=0) const =0 | ms_mascotresfilebase | pure virtual
getErrorHandler() const | ms_errors |
getErrorInfoAsString(const int num) const | ms_mascotresfilebase | protected
getErrorNumber(const int num=-1) const | ms_mascotresfilebase |
getErrorString(const int num) const | ms_mascotresfilebase |
getExecTime() const =0 | ms_mascotresfilebase | pure virtual
getFastaPath(int idx=1) const =0 | ms_mascotresfilebase | pure virtual
getFastaVer(int idx=1) const =0 | ms_mascotresfilebase | pure virtual
getFileName(const int id=1) const =0 | ms_mascotresfilebase | pure virtual
getFirstPassThreshold() const =0 | ms_mascotresfilebase | pure virtual
getHeaderKeyValues(std::vector< std::string > &keys, std::vector< std::string > &values) const =0 | ms_mascotresfilebase | pure virtual
getHeaderValue(const std::string &key) const =0 | ms_mascotresfilebase | pure virtual
getInputQuery(const int queryNum) const =0 | ms_mascotresfilebase | pure virtual
getJobNumber(const int resfileID=1) const =0 | ms_mascotresfilebase | pure virtual
getKeepAlive(KA_TASK &kaTask, int &kaPercentage, std::string &kaAccession, int &kaHit, int &kaQuery, std::string &kaText) const | ms_mascotresfilebase |
getLastError() const | ms_mascotresfilebase |
getLastErrorString() const | ms_mascotresfilebase |
getLibraryMods(std::vector< std::string > &modNames, std::vector< double > &modDeltas) const =0 | ms_mascotresfilebase | pure virtual
getMascotVer() const =0 | ms_mascotresfilebase | pure virtual
getMasses(ms_masses *masses) const | ms_mascotresfilebase |
getMassesKeyValues(std::vector< std::string > &keys, std::vector< double > &values) const =0 | ms_mascotresfilebase | pure virtual
getMassValue(const std::string &key) const =0 | ms_mascotresfilebase | pure virtual
getMonoLinkModification(const int modNum, const int monoLink) const | ms_mascotresfilebase |
getMSParserVersion() const | ms_mascotresfilebase |
getMultiFileQueryNumber(const int localQuery, const int fileId) const =0 | ms_mascotresfilebase | pure virtual
getNumberOfErrors() const | ms_mascotresfilebase |
getNumberOfResfiles() const =0 | ms_mascotresfilebase | pure virtual
getNumEtSeqsSearched(const int idx=0) const =0 | ms_mascotresfilebase | pure virtual
getNumLibraryEntries(const int idx=0) const =0 | ms_mascotresfilebase | pure virtual
getNumQueries(const int resfileID=0) const =0 | ms_mascotresfilebase | pure virtual
getNumResidues(const int idx=0) const =0 | ms_mascotresfilebase | pure virtual
getNumSeqs(const int idx=0) const =0 | ms_mascotresfilebase | pure virtual
getNumSeqsAfterTax(const int idx=0) const =0 | ms_mascotresfilebase | pure virtual
getObservedCharge(const int query, const bool decoy=false) const =0 | ms_mascotresfilebase | pure virtual
getObservedIntensity(const int query) const =0 | ms_mascotresfilebase | pure virtual
getObservedMass(const int query) const =0 | ms_mascotresfilebase | pure virtual
getObservedMrValue(const int query, const bool decoy=false) const =0 | ms_mascotresfilebase | pure virtual
getPercolatorFileNames() const | ms_mascotresfilebase |
getProgressInfo(bool forPeptideSummary=false) const | ms_mascotresfilebase |
getQmatch(const int query, const ms_peptide::PSM_TYPE pepType) const =0 | ms_mascotresfilebase | pure virtual
getQplughole(const int query, const ms_peptide::PSM_TYPE pepType) const =0 | ms_mascotresfilebase | pure virtual
getQuantitation(ms_quant_configfile *qfile) const =0 | ms_mascotresfilebase | pure virtual
getQuantitationMethod(ms_quant_method *qmethod) const | ms_mascotresfilebase |
getReferenceDatabaseNumberOfSL(const int idx) const =0 | ms_mascotresfilebase | pure virtual
getRepeatSearchString(const int query, const bool fullQuery=false) const =0 | ms_mascotresfilebase | pure virtual
getResfile(int id) const =0 | ms_mascotresfilebase | pure virtual
getSearchParameter(const std::string &key) const =0 | ms_mascotresfilebase | pure virtual
getSearchParametersKeyValues(std::vector< std::string > &keys, std::vector< std::string > &values) const =0 | ms_mascotresfilebase | pure virtual
getSLDatabaseNumbersOfReference(const int idx) const =0 | ms_mascotresfilebase | pure virtual
getSLExecCommand(int idx=1) const =0 | ms_mascotresfilebase | pure virtual
getSLFragmentTolerance(int idx=1) const =0 | ms_mascotresfilebase | pure virtual
getSLFragmentToleranceUnit(int idx=1) const =0 | ms_mascotresfilebase | pure virtual
getSrcQueryAndFileIdForMultiFile(const int q, int &gsqNewQuery, int &gsqFileId) const =0 | ms_mascotresfilebase | pure virtual
getTaxonomy(ms_taxonomyfile *tfile) const =0 | ms_mascotresfilebase | pure virtual
getUnimod(ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const =0 | ms_mascotresfilebase | pure virtual
getUnimodXL(ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const =0 | ms_mascotresfilebase | pure virtual
getUniqueTaskID() const =0 | ms_mascotresfilebase | pure virtual
getXMLschemaFilePath(XML_SCHEMA XMLschema) const | ms_mascotresfilebase |
hasEnzyme() const =0 | ms_mascotresfilebase | pure virtual
hasQuantitation() const =0 | ms_mascotresfilebase | pure virtual
hasRT() const =0 | ms_mascotresfilebase | pure virtual
isDatabaseTypeAvailable() const =0 | ms_mascotresfilebase | pure virtual
isErrorTolerant() const =0 | ms_mascotresfilebase | pure virtual
isMSMS() const =0 | ms_mascotresfilebase | pure virtual
isPMF() const =0 | ms_mascotresfilebase | pure virtual
isSQ() const =0 | ms_mascotresfilebase | pure virtual
isValid() const | ms_errors |
KA_ASSIGNPROTEINS_AP enum value | ms_mascotresfilebase |
KA_CREATECACHE_CC enum value | ms_mascotresfilebase |
KA_CREATEINDEX_CI enum value | ms_mascotresfilebase |
KA_GROUPPROTEINS_GP enum value | ms_mascotresfilebase |
KA_LAST enum value | ms_mascotresfilebase |
KA_QUANTITATION enum value | ms_mascotresfilebase |
KA_READFILE_RF enum value | ms_mascotresfilebase |
KA_TASK enum name | ms_mascotresfilebase |
KA_THRESHFORFDR_FDR enum value | ms_mascotresfilebase |
KA_UNASSIGNEDLIST_UL enum value | ms_mascotresfilebase |
ms_errors() | ms_errors |
ms_mascotresfilebase(const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory=0, const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0) | ms_mascotresfilebase |
outputKeepAlive() const | ms_mascotresfilebase |
params() const | ms_mascotresfilebase | inline
PERCOLATOR_FILE_NAMES enum name | ms_mascotresfilebase |
PERCOLATOR_INPUT_FILE enum value | ms_mascotresfilebase |
PERCOLATOR_OUTPUT_DECOY enum value | ms_mascotresfilebase |
PERCOLATOR_OUTPUT_TARGET enum value | ms_mascotresfilebase |
resetKeepAlive(const int keepAliveInterval, const char *keepAliveText, const bool propagateToAppended=true, const bool resetStartTime=false) | ms_mascotresfilebase |
RESFILE_CACHE_IGNORE_ACC_DUPES enum value | ms_mascotresfilebase |
RESFILE_CACHE_IGNORE_DATE_CHANGE enum value | ms_mascotresfilebase |
RESFILE_DAT28 enum value | ms_mascotresfilebase |
RESFILE_MSR enum value | ms_mascotresfilebase |
RESFILE_NOFLAG enum value | ms_mascotresfilebase |
RESFILE_TYPE enum name | ms_mascotresfilebase |
RESFILE_UNKNOWN enum value | ms_mascotresfilebase |
RESFILE_USE_CACHE enum value | ms_mascotresfilebase |
RESFILE_USE_PARENT_PARAMS enum value | ms_mascotresfilebase |
resfileType(const std::string &fileName) | ms_mascotresfilebase | static
setErrorInfoFromString(const std::string &e) | ms_mascotresfilebase | protected
setPercolatorFeatures(const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes) | ms_mascotresfilebase |
setPercolatorFeatures(const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters=std::vector< std::string >()) | ms_mascotresfilebase |
setXMLschemaFilePath(XML_SCHEMA XMLschema, const char *path) | ms_mascotresfilebase |
staticGetPercolatorFileNames(const char *szFileName, const char *cacheDirectory, const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes, std::vector< std::string > &filenames, std::vector< bool > &exists) | ms_mascotresfilebase | static
staticGetPercolatorFileNames(const char *szFileName, const char *cacheDirectory, const ms_mascotoptions &options, const char *additionalFeatures, const std::vector< std::string > &adapterParameters, std::vector< std::string > &filenames, std::vector< bool > &exists) | ms_mascotresfilebase | static
versionGreaterOrEqual(int major, int minor, int revision) const | ms_mascotresfilebase |
willCreateCache(const char *szFileName, const unsigned int flags, const char *cacheDirectory, std::string *cacheFileName) | ms_mascotresfilebase | static
willCreateCache(const char *szFileName, const ms_mascotoptions &opts, const char *applicationName, std::string &resfileCacheFileName, unsigned int &cacheStatus) | ms_mascotresfilebase | static
XML_SCHEMA enum name | ms_mascotresfilebase |
XML_SCHEMA_CROSSLINKING enum value | ms_mascotresfilebase |
XML_SCHEMA_DIRECTORY enum value | ms_mascotresfilebase |
XML_SCHEMA_LAST enum value | ms_mascotresfilebase |
XML_SCHEMA_QUANTITATION enum value | ms_mascotresfilebase |
XML_SCHEMA_UNIMOD enum value | ms_mascotresfilebase |
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_mascotresults
ms_mascotresults Member List

This is the complete list of members for ms_mascotresults, including all inherited members.

anyEmPAI() const | ms_mascotresults | virtual
anyNumDiscoveredMods() const | ms_mascotresults | virtual
cancelCreateSummary(bool newValue=true) | ms_mascotresults |
createSummary() | ms_mascotresults | virtual
createUnassignedList(sortBy s=QUERY) | ms_mascotresults |
DB_MATCH_TYPE enum name | ms_mascotresults |
DECOY_STATS_COUNT_TYPE enum name | ms_mascotresults |
DM_BOTH enum value | ms_mascotresults |
DM_FASTA enum value | ms_mascotresults |
DM_FASTA_FIRST_PASS enum value | ms_mascotresults |
DM_FASTA_SECOND_PASS enum value | ms_mascotresults |
DM_SPECTRAL_LIBRARY enum value | ms_mascotresults |
DS_COUNT_PSM enum value | ms_mascotresults |
DS_COUNT_SEQUENCE enum value | ms_mascotresults |
FC_ALL_PEPTIDES enum value | ms_mascotresults |
FC_ALL_PEPTITDES enum value | ms_mascotresults |
FC_CASE_INSENSITIVE enum value | ms_mascotresults |
FC_CASE_SENSITIVE enum value | ms_mascotresults |
FC_COMPLETESTR enum value | ms_mascotresults |
FC_FORWARD enum value | ms_mascotresults |
FC_LOOP_FROM_UNASSIGNED enum value | ms_mascotresults |
FC_LOOP_INTO_UNASSIGNED enum value | ms_mascotresults |
FC_MASK_CASE enum value | ms_mascotresults |
FC_MASK_DIRECTION enum value | ms_mascotresults |
FC_MASK_STR_PART enum value | ms_mascotresults |
FC_PROTEIN_IGN_FAMILY enum value | ms_mascotresults |
FC_PROTEIN_IGN_MASK enum value | ms_mascotresults |
FC_PROTEIN_IGN_SAMESETS enum value | ms_mascotresults |
FC_PROTEIN_IGN_SUBSETS enum value | ms_mascotresults |
FC_PROTEIN_INC_ALT_ACC enum value | ms_mascotresults |
FC_RESTRICT_TO_HIT enum value | ms_mascotresults |
FC_REVERSE enum value | ms_mascotresults |
FC_SCORING_MASK enum value | ms_mascotresults |
FC_SEARCH_ALL_RANKS enum value | ms_mascotresults |
FC_SEARCH_IGNORED_RANKS enum value | ms_mascotresults |
FC_SIGNIFICANT_PEPTIDES enum value | ms_mascotresults |
FC_STARTSTR enum value | ms_mascotresults |
FC_STRTOK enum value | ms_mascotresults |
FC_SUBSTR enum value | ms_mascotresults |
FC_UNASSIGNED_MASK enum value | ms_mascotresults |
FIND_COMPARE_FLAGS enum name | ms_mascotresults |
FIND_FLAGS enum name | ms_mascotresults |
findPeptides(const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const =0 | ms_mascotresults | pure virtual
findProteins(const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0 | ms_mascotresults | pure virtual
findProteinsByAccession(const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0 | ms_mascotresults | pure virtual
findProteinsByDescription(const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0 | ms_mascotresults | pure virtual
FLAGS enum name | ms_mascotresults |
freeHit(const int hit) | ms_mascotresults | virtual
FT_PEPTIDE_CALC_MR enum value | ms_mascotresults |
FT_PEPTIDE_CALC_MZ enum value | ms_mascotresults |
FT_PEPTIDE_ETMOD enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MR enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MZ enum value | ms_mascotresults |
FT_PEPTIDE_FIND_MASK enum value | ms_mascotresults |
FT_PEPTIDE_FIXMOD enum value | ms_mascotresults |
FT_PEPTIDE_QUERY enum value | ms_mascotresults |
FT_PEPTIDE_SLMOD enum value | ms_mascotresults |
FT_PEPTIDE_STRING enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD_BYNAME enum value | ms_mascotresults |
FT_PROTEIN_ACCESSION enum value | ms_mascotresults |
FT_PROTEIN_DESCRIPTION enum value | ms_mascotresults |
getAllFamilyMembersWithThisPepMatch(const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const =0 | ms_mascotresults | pure virtual
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const =0 | ms_mascotresults | pure virtual
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const =0 | ms_mascotresults | pure virtual
getAvePeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getComponentIntensity(const int q, const int p, const std::string &componentName, double &value, double &rawValue) const =0 | ms_mascotresults | pure virtual
getComponentProtein(const char *accession, const int dbIdx=1) const | ms_mascotresults | virtual
getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const =0 | ms_mascotresults | pure virtual
getCreateSummaryProgress(int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const | ms_mascotresults |
getDiscoveredErrTolModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | virtual
getDiscoveredErrTolModNames() const | ms_mascotresults | virtual
getDiscoveredLocalModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | virtual
getDiscoveredLocalModNames() const | ms_mascotresults | virtual
getErrTolModDelta(const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const | ms_mascotresults | virtual
getErrTolModifiedNaSeq(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModMasterNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModMasterString(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getErrTolModName(const int q, const int p, std::string *modString=NULL) const | ms_mascotresults | virtual
getErrTolModNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModPepNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModPepString(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getErrTolModReqPepNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModReqPepString(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getErrTolModSlaveNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModSlaveString(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getErrTolModString(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getErrTolOriginalNaSeq(const int q, const int p) const | ms_mascotresults | virtual
getErrTolProbabilityThreshold() const | ms_mascotresults | virtual
getFlags() const | ms_mascotresults |
getFlags2() const | ms_mascotresults |
getHit(const int hit, const int memberNumber=0) const | ms_mascotresults | virtual
getHomologyThreshold(const int query, double OneInXprobRnd, const int rank=1) const | ms_mascotresults | virtual
getHomologyThresholdForHistogram(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getIonsScore(const int q, const int p, const bool decoy) const =0 | ms_mascotresults | pure virtual
getIonsScoreCorrected(const double ionsScore, const long multiplicity) const | ms_mascotresults | protected
getIonsScoreHistogram(IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getLibraryModString(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getMaxPeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getMaxRankValue() const | ms_mascotresults | virtual
getMinPepLenInPepSummary() const | ms_mascotresults |
getNextFamilyProtein(const int masterHit, const int id) const | ms_mascotresults | virtual
getNextSimilarProtein(const int masterHit, const int id) const | ms_mascotresults | virtual
getNextSimilarProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | virtual
getNextSubsetProtein(const int masterHit, const int id, const bool searchWholeFamily=true) const | ms_mascotresults | virtual
getNextSubsetProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | virtual
getNumberOfFamilyMembers() const | ms_mascotresults | virtual
getNumberOfHits() const | ms_mascotresults | virtual
getNumberOfUnassigned() const | ms_mascotresults |
getNumDecoyHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getNumDecoyHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getNumDiscoveredErrTolMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumDiscoveredFixedMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumDiscoveredIntactLinks(std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const | ms_mascotresults |
getNumDiscoveredLibraryMods(const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults |
getNumDiscoveredLocalMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumDiscoveredNonSpecCleavage() const | ms_mascotresults | virtual
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const | ms_mascotresults | virtual
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getNumHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getPepsWithSameScore(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getPeptide(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getPeptide(const int q, const int p, ms_peptide *&pep) const =0 | ms_mascotresults | pure virtual
getPeptideExpectationValue(const double score, const int query, const int rank=0) const | ms_mascotresults | virtual
getPeptideIdentityThreshold(const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getPeptideThreshold(const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const | ms_mascotresults |
getProbabilityThreshold() const | ms_mascotresults | virtual
getProbFromScore(const double score) const | ms_mascotresults | virtual
getProbOfPepBeingRandomMatch(const double score, const int query) const | ms_mascotresults | virtual
getProbOfProteinBeingRandomMatch(const double score) const | ms_mascotresults | virtual
getProtein(const char *accession, const int dbIdx=1) const | ms_mascotresults | virtual
getProteinDescription(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinEmPAI(const char *accession, const int dbIdx=1, const int length=-1) const | ms_mascotresults | virtual
getProteinExpectationValue(const double score) const | ms_mascotresults | virtual
getProteinMass(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinScoreCutoff(double OneInXprobRnd) const =0 | ms_mascotresults | pure virtual
getProteinScoreForHistogram(const int num) const | ms_mascotresults | virtual
getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false)=0 | ms_mascotresults | pure virtual
getProteinTaxonomyIDs(const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const | ms_mascotresults |
getProteinThreshold(double OneInXprobRnd) const | ms_mascotresults | virtual
getQmatch(const int query) const | ms_mascotresults | virtual
getQmatch(const int query, const ms_mascotresfile_dat::section sec) const | ms_mascotresults | virtual
getQuantitationComponentForPeptide(const matrix_science::ms_peptide &peptide, matrix_science::ms_quant_component &component, const matrix_science::ms_quant_method *method=NULL) const =0 | ms_mascotresults | pure virtual
getReadableVarMods(const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_mascotresults | virtual
getResfile() const | ms_mascotresults |
getResultsParameters() const | ms_mascotresults |
getSequenceMass(const char *seq) const | ms_mascotresults |
getTagDeltaRangeEnd(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getTagDeltaRangeStart(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getTagEnd(const int q, const int p, const int tagNumber) const | ms_mascotresults | virtual
getTagSeries(const int q, const int p, const int tagNumber) const | ms_mascotresults | virtual
getTagStart(const int q, const int p, const int tagNumber) const | ms_mascotresults | virtual
getTagString(const int q, const int p) const =0 | ms_mascotresults | pure virtual
getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const =0 | ms_mascotresults | pure virtual
getThresholdForFDRAboveHomology(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveHomology(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getToleranceInDalton(bool &needMass, const double *const pMass=NULL) const | ms_mascotresults |
getTreeClusterNodes(const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, TREE_CLUSTER_METHOD tcm=TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const | ms_mascotresults | virtual
getUnassigned(const int num) const | ms_mascotresults |
getUnassignedIsBold(const int num) const | ms_mascotresults |
getUnassignedShowCheckbox(const int num) const | ms_mascotresults |
HOMOLOGY_THRESHOLD_SOURCE enum name | ms_mascotresults |
HOMTHR_FASTA enum value | ms_mascotresults |
HOMTHR_SL enum value | ms_mascotresults |
IH_INCLUDE_TOP_10_MATCHES enum value | ms_mascotresults |
IH_INCLUDE_TOP_MATCHES enum value | ms_mascotresults |
INTENSITY enum value | ms_mascotresults |
IONS_HISTOGRAM enum name | ms_mascotresults |
isEmPAIallowed() const | ms_mascotresults |
isNA() const | ms_mascotresults |
isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const =0 | ms_mascotresults | pure virtual
ms_mascotresults() | ms_mascotresults |
MSRES_CLUSTER_PROTEINS enum value | ms_mascotresults |
MSRES_DECOY enum value | ms_mascotresults |
MSRES_DUPE_DEFAULT enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_A enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_B enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_C enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_D enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_E enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_F enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_G enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_H enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_I enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_NONE enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_A enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_B enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_C enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_D enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_E enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_F enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_G enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_H enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_I enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_NONE enum value | ms_mascotresults |
MSRES_ERR_TOL enum value | ms_mascotresults |
MSRES_GROUP_PROTEINS enum value | ms_mascotresults |
MSRES_IGNORE_PMF_MIXTURE enum value | ms_mascotresults |
MSRES_INTEGRATED_ERR_TOL enum value | ms_mascotresults |
MSRES_MAXHITS_OVERRIDES_MINPROB enum value | ms_mascotresults |
MSRES_MUDPIT_PROTEIN_SCORE enum value | ms_mascotresults |
MSRES_NOFLAG enum value | ms_mascotresults |
MSRES_REQUIRE_BOLD_RED enum value | ms_mascotresults |
MSRES_SHOW_ALL_FROM_ERR_TOL enum value | ms_mascotresults |
MSRES_SHOW_SUBSETS enum value | ms_mascotresults |
MSRES_SUBSETS_DIFF_PROT enum value | ms_mascotresults |
QCS_ERROR_BAD_COMPONENT_NAME enum value | ms_mascotresults |
QCS_ERROR_NO_COMPONENTS enum value | ms_mascotresults |
QCS_ERROR_NO_METHOD enum value | ms_mascotresults |
QCS_OK enum value | ms_mascotresults |
QCS_OK_MULTIPLE_MATCHES enum value | ms_mascotresults |
QCS_OK_NO_MATCH enum value | ms_mascotresults |
QUANT_COMPONENT_STATUS enum name | ms_mascotresults |
QUERY enum value | ms_mascotresults |
SCORE enum value | ms_mascotresults |
setSubsetsThreshold(const double scoreFraction) | ms_mascotresults | virtual
sortBy enum name | ms_mascotresults |
TCM_PAIRWISE_AVERAGE enum value | ms_mascotresults |
TCM_PAIRWISE_MAXIMUM enum value | ms_mascotresults |
TCM_PAIRWISE_SINGLE enum value | ms_mascotresults |
THRESHOLD_TYPE enum name | ms_mascotresults |
TREE_CLUSTER_METHOD enum name | ms_mascotresults |
TT_HOMOLOGY enum value | ms_mascotresults |
TT_IDENTITY enum value | ms_mascotresults |
TT_PEPSUM_DEFAULT enum value | ms_mascotresults |
UNIQUE_PEP_RULES enum name | ms_mascotresults |
UPR_DEFAULT enum value | ms_mascotresults |
UPR_IGNORE_SUBSET_PROTEINS enum value | ms_mascotresults |
UPR_WITHIN_FAMILY enum value | ms_mascotresults |
UPR_WITHIN_FAMILY_MEMBER enum value | ms_mascotresults |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_mascotresults_params
ms_mascotresults_params Member List

This is the complete list of members for ms_mascotresults_params, including all inherited members.

copyFrom(const ms_mascotresults_params *right) | ms_mascotresults_params
getFlags() const | ms_mascotresults_params
getFlags2() const | ms_mascotresults_params
getIgnoreIonsScoreBelow() const | ms_mascotresults_params
getMaxHitsToReport() const | ms_mascotresults_params
getMinNumSigUniqueSequences() const | ms_mascotresults_params
getMinPepLenInPeptideSummary() const | ms_mascotresults_params
getMinProbability() const | ms_mascotresults_params
getSingleHit() const | ms_mascotresults_params
getTargetFDR() const | ms_mascotresults_params
getTargetFDRType() const | ms_mascotresults_params
getUnigeneIndexFile() const | ms_mascotresults_params
isUsePeptideSummary() const | ms_mascotresults_params
ms_mascotresults_params(const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS, double minProbability=0.05, int maxHitsToReport=0, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=ms_peptidesummary::MSPEPSUM_NONE) | ms_mascotresults_params
ms_mascotresults_params(const ms_mascotresults_params &src) | ms_mascotresults_params
operator=(const ms_mascotresults_params &right) | ms_mascotresults_params
setFlag(const ms_mascotresults::FLAGS flag, bool enabled) | ms_mascotresults_params
setFlag2(const ms_peptidesummary::MSPEPSUM flag, bool enabled) | ms_mascotresults_params
setFlags(const unsigned int flags) | ms_mascotresults_params
setFlags2(const unsigned int flags2) | ms_mascotresults_params
setIgnoreIonsScoreBelow(const double ignoreIonsScoreBelow) | ms_mascotresults_params
setMaxHitsToReport(const int maxHitsToReport) | ms_mascotresults_params
setMinNumSigUniqueSequences(const int n) | ms_mascotresults_params
setMinPepLenInPeptideSummary(const int minPepLenInPeptideSummary) | ms_mascotresults_params
setMinProbability(const double minProbability) | ms_mascotresults_params
setSingleHit(const char *singleHit) | ms_mascotresults_params
setTargetFDR(double fdr) | ms_mascotresults_params
setTargetFDRType(ms_mascotresults::DECOY_STATS_COUNT_TYPE fdrType) | ms_mascotresults_params
setUnigeneIndexFile(const char *unigeneIndexFile) | ms_mascotresults_params
setUsePeptideSummary(const bool usePeptideSummary) | ms_mascotresults_params
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_masses
ms_masses Member List

This is the complete list of members for ms_masses, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
applyFixedMods(const ms_modvector *mods, ms_errs *err) | ms_masses
applyIsotopes(const ms_umod_configfile *umodFile, const ms_quant_component *quantComp) | ms_masses
clearAllErrors() | ms_errors
copyFrom(const ms_masses *right) | ms_masses
copyFrom(const ms_umod_configfile *right, bool addMissingResidueMasses=true) | ms_masses
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues(bool useDefaultResidueMasses=true) | ms_masses
getCarbonMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getConnectionSettings() const | ms_masses
getCtermDelta(const matrix_science::MASS_TYPE massType) const | ms_masses
getCterminalMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getCtermNeutralLoss(const matrix_science::MASS_TYPE massType) const | ms_masses
getElectronMass() const | ms_masses
getErrorHandler() const | ms_errors
getFileName() const | ms_masses
getFragResidueMass(const matrix_science::MASS_TYPE massType, const char residue) const | ms_masses
getHydrogenMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNitrogenMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getNtermDelta(const matrix_science::MASS_TYPE massType) const | ms_masses
getNterminalMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getNtermNeutralLoss(const matrix_science::MASS_TYPE massType) const | ms_masses
getOxygenMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getResidueMass(const matrix_science::MASS_TYPE massType, const char residue) const | ms_masses
isResidueModified(const char residue) const | ms_masses
isSame(const ms_masses &other, const MASS_TYPE massType) const | ms_masses
isValid() const | ms_errors
ms_errors() | ms_errors
ms_masses() | ms_masses
ms_masses(const ms_masses &src) | ms_masses
ms_masses(const ms_umod_configfile &src, bool addMissingResidueMasses=true) | ms_masses
ms_masses(const ms_umod_configfile &src, const ms_quant_component &quantComp) | ms_masses
ms_masses(const char *filename, const matrix_science::ms_connection_settings *cs=0) | ms_masses
operator=(const ms_masses &right) | ms_masses
read_file() | ms_masses
save_file() | ms_masses
saveToString(std::string &modfileAsStr) | ms_masses
setCarbonMass(const double massMono, const double massAve) | ms_masses
setConnectionSettings(const matrix_science::ms_connection_settings &cs) | ms_masses
setCtermModification(const double monoDelta, const double aveDelta, const double monoNeutralLoss=0.0, const double aveNeutralLoss=0.0) | ms_masses
setElectronMass(const double mass) | ms_masses
setFileName(const char *name) | ms_masses
setHydrogenMass(const double massMono, const double massAve) | ms_masses
setNitrogenMass(const double massMono, const double massAve) | ms_masses
setNtermModification(const double monoDelta, const double aveDelta, const double monoNeutralLoss=0.0, const double aveNeutralLoss=0.0) | ms_masses
setOxygenMass(const double massMono, const double massAve) | ms_masses
setResidueMasses(const char residue, const double massMono, const double massAve) | ms_masses
setResidueModification(const double monoDelta, const double aveDelta, const double monoNeutralLoss, const double aveNeutralLoss, const char *residues) | ms_masses
~ms_errors() | ms_errors
~ms_masses() | ms_masses
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_matrix
ms_matrix Member List

This is the complete list of members for ms_matrix, including all inherited members.

columnMatrix(const std::vector< double > &v) | ms_matrix | static
data() const | ms_matrix |
diagonalMatrix(size_t s, double v) | ms_matrix | static
getCR(size_t i, size_t j) const | ms_matrix |
getRC(size_t i, size_t j) const | ms_matrix | inline
identityMatrix(size_t s) | ms_matrix | static
isZero() const | ms_matrix |
logContents(ms_errs &errs, const char *description) const | ms_matrix |
ms_matrix() | ms_matrix |
ms_matrix(const matrix_t &m) | ms_matrix |
ms_matrix(size_t si, size_t sj, double v=0.0) | ms_matrix |
multiplyByRow(const std::vector< double > &column, size_t row) const | ms_matrix |
operator!=(const ms_matrix &m) const | ms_matrix |
operator*(const ms_matrix &m) const | ms_matrix |
operator==(const ms_matrix &m) const | ms_matrix |
operator[](size_t i) | ms_matrix |
operator[](size_t i) const | ms_matrix |
resize(size_t si, size_t sj, double v=0.0) | ms_matrix |
rowMatrix(const std::vector< double > &v) | ms_matrix | static
setColumnDown(size_t row, size_t col, const std::vector< double > &vec) | ms_matrix |
setColumnUp(size_t row, size_t col, const std::vector< double > &vec) | ms_matrix |
setCR(size_t i, size_t j, double value) | ms_matrix |
setRC(size_t i, size_t j, double value) | ms_matrix | inline
sizei() const | ms_matrix |
sizej() const | ms_matrix |
transpose() | ms_matrix |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_modfile
ms_modfile Member List

This is the complete list of members for ms_modfile, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
appendModification(const ms_modification *item) | ms_modfile
clearAllErrors() | ms_errors
clearModifications() | ms_modfile
copyFrom(const ms_modfile *right) | ms_modfile
copyFrom(const ms_umod_configfile *right, const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL) | ms_modfile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_modfile
deleteModificationByName(const char *name) | ms_modfile
deleteModificationByNumber(const int num) | ms_modfile
getConnectionSettings() const | ms_modfile
getErrorHandler() const | ms_errors
getFileName() const | ms_modfile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getMassFile() const | ms_modfile
getModificationByName(const char *nameMod) const | ms_modfile
getModificationByNumber(const int numMod) const | ms_modfile
getNumberOfModifications() const | ms_modfile
isFromSubstitutions() const | ms_modfile
isValid() const | ms_errors
ms_errors() | ms_errors
ms_modfile() | ms_modfile
ms_modfile(const ms_modfile &src) | ms_modfile
ms_modfile(const ms_umod_configfile &src, const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL) | ms_modfile
ms_modfile(const char *filename, const ms_masses *massFile, const bool fromSubstitutions=false, const ms_connection_settings *cs=0) | ms_modfile
operator=(const ms_modfile &right) | ms_modfile
read_file() | ms_modfile
save_file() | ms_modfile
saveToString(std::string &modfileAsStr) | ms_modfile
setConnectionSettings(const ms_connection_settings &cs) | ms_modfile
setFileName(const char *name) | ms_modfile
setFromSubstitutions(const bool value) | ms_modfile
setMassFile(const ms_masses *massFile) | ms_modfile
sortModifications() | ms_modfile
updateModificationByName(const char *name, const ms_modification mod) | ms_modfile
updateModificationByNumber(const int num, const ms_modification mod) | ms_modfile
~ms_errors() | ms_errors
~ms_modfile() | ms_modfile
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_modification
ms_modification Member List

This is the complete list of members for ms_modification, including all inherited members.

appendIgnoreMass(const double massMono, const double massAve) | ms_modification
appendModifiedResidue(const char residue, const double massMono, const double massAve) | ms_modification
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
clearIgnoreMasses() | ms_modification
clearModifiedResidues() | ms_modification
copyFrom(const ms_modification *src) | ms_modification
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
copyMassFile(const ms_masses *massFile) | ms_modification
defaultValues() | ms_modification
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getClassification() const | ms_modification
getCode() const | ms_modification
getCTerminusMass(const MASS_TYPE massType) const | ms_modification
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getDelta(const MASS_TYPE massType) const | ms_modification
getFromUnimod(const char *modName, const ms_umod_configfile *umod_file) | ms_modification
getIgnoreMass(const MASS_TYPE massType, const int idx) const | ms_modification
getMassFile() const | ms_modification
getModificationType() const | ms_modification
getModifiedResidue(const int n) const | ms_modification
getMonoLinkTitle() const | ms_modification
getNeutralLoss(const MASS_TYPE massType) const | ms_modification
getNeutralLossRequired() const | ms_modification
getNTerminusMass(const MASS_TYPE massType) const | ms_modification
getNumberOfIgnoreMasses() const | ms_modification
getNumberOfModifiedResidues() const | ms_modification
getNumberOfProperties() const | ms_customproperty
getPairsWith() const | ms_modification
getPepNeutralLoss(const MASS_TYPE massType) const | ms_modification
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
getReqPepNeutralLoss(const MASS_TYPE massType) const | ms_modification
getResidueMass(const MASS_TYPE massType, const char residue) const | ms_modification
getTitle() const | ms_modification
inErrorTolerant() const | ms_modification
inLongList() const | ms_modification
inShortList() const | ms_modification
isGeneratedMonoLinker() const | ms_modification
isHidden() const | ms_modification
isLoopLinker() const | ms_modification
isResidueModified(const char residue) const | ms_modification
isSubstitution() const | ms_modification
ms_customproperty() | ms_customproperty
ms_modification(const ms_masses *massFile=NULL) | ms_modification
ms_modification(const ms_modification &src) | ms_modification
operator=(const ms_modification &right) | ms_modification
setCTerminusMass(const double massMono, const double massAve) | ms_modification
setDefaultDelimiter(const char *delim) | ms_customproperty
setDelta(const double massMono, const double massAve) | ms_modification
setHidden(const bool value) | ms_modification
setInErrorTolerant(const bool value) | ms_modification
setInLongList(const bool value) | ms_modification
setInShortList(const bool value) | ms_modification
setMassFile(const ms_masses *massFile) | ms_modification
setModificationType(const int type) | ms_modification
setNeutralLoss(const ms_vectorDouble massMono, const ms_vectorDouble massAve, const ms_vectorBool required) | ms_modification
setNTerminusMass(const double massMono, const double massAve) | ms_modification
setPepNeutralLoss(const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve) | ms_modification
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setReqPepNeutralLoss(const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve) | ms_modification
setTitle(const char *value) | ms_modification
setTitleSource(const char *unimodName, const char *specString) | ms_modification
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
~ms_modification() | ms_modification
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_modvector
ms_modvector Member List

This is the complete list of members for ms_modvector, including all inherited members.

appendModification(const ms_modification *item) | ms_modvector
appendModifications(ms_modvector &right) | ms_modvector
clearModifications() | ms_modvector
copyFrom(const ms_modvector *right) | ms_modvector
copyFrom(const ms_umod_modification *right, const ms_umod_configfile *umod_file) | ms_modvector
getModificationByName(const std::string &name) const | ms_modvector
getModificationByNumber(const int numMod) const | ms_modvector
getNumberOfModifications() const | ms_modvector
ms_modvector() | ms_modvector
ms_modvector(const ms_modvector &src) | ms_modvector
ms_modvector(const ms_umod_modification &src, const ms_umod_configfile &umod_file) | ms_modvector
operator=(const ms_modvector &right) | ms_modvector
~ms_modvector() | ms_modvector
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms1quant_average_results
ms_ms1quant_average_results Member List

This is the complete list of members for ms_ms1quant_average_results, including all inherited members.

getReferenceHitId() const | ms_ms1quant_average_results
getReferenceMemberNumber() const | ms_ms1quant_average_results
isReferenceUserSelected() const | ms_ms1quant_average_results
ms_ms1quant_average_results() | ms_ms1quant_average_results
ms_ms1quant_average_results(const ms_ms1quant_average_results_body &body) | ms_ms1quant_average_results
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms1quant_charge_state
ms_ms1quant_charge_state Member List

This is the complete list of members for ms_ms1quant_charge_state, including all inherited members.

getBucket(int index, unsigned &scanId, double &area) const | ms_ms1quant_charge_state
getBucket(const int file_index, int index, unsigned &scanId, double &area) const | ms_ms1quant_charge_state
getBucketWidth() const | ms_ms1quant_charge_state
getCorrectedMaxSPPwidth() const | ms_ms1quant_charge_state
getCorrectedMinSPPwidth() const | ms_ms1quant_charge_state
getCorrectedSPPwidth() const | ms_ms1quant_charge_state
getMatchedFraction() const | ms_ms1quant_charge_state
getMatchedRho() const | ms_ms1quant_charge_state
getMaxAlignment() const | ms_ms1quant_charge_state
getNumberOfBuckets(const int file_index=ms_quant_file_index::file_index_value_not_set) const | ms_ms1quant_charge_state
getTotalIntensity() const | ms_ms1quant_charge_state
ms_ms1quant_charge_state() | ms_ms1quant_charge_state
ms_ms1quant_charge_state(const ms_ms1quant_charge_state_body &body) | ms_ms1quant_charge_state
ms_ms1quant_charge_state(const double correctSppWidthMin, const double correctSppWidthMax, const double correctSppWidth, const double bucketWidth, const double maxAlignment, const double matchedRho, const double matchedFraction, const double totalIntensity, const std::map< int, std::map< int, double > > &bucketAreas, const std::vector< double > &calcMzVar, const std::vector< int > &idx2Comp) | ms_ms1quant_charge_state
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms1quant_match
ms_ms1quant_match Member List

This is the complete list of members for ms_ms1quant_match, including all inherited members.

addComponent(const matrix_science::ms_ms1quant_match_component &component) | ms_ms1quant_match |
addCreatedComponent(const std::string &componentName) | ms_ms1quant_match |
addCreatedComponent(const matrix_science::ms_ms1quant_match_component &component) | ms_ms1quant_match |
allComponentsIdentified() const | ms_ms1quant_match |
chargeType enum name | ms_ms1quant_match |
CHARGETYPE_ALL enum value | ms_ms1quant_match |
CHARGETYPE_ORIGINAL enum value | ms_ms1quant_match |
clearHitRatioExcluded(const std::string &ratioName, int hitId, int memberNumber) | ms_ms1quant_match |
clearHitRatioOutlier(const std::string &ratioName, int hitId, int memberNumber) | ms_ms1quant_match |
getChargeState() const | ms_ms1quant_match |
getChargeStateData() const | ms_ms1quant_match |
getChargeType() const | ms_ms1quant_match |
getCodeFromXml(std::string text) | ms_ms1quant_match | static
getComponent(int index) const | ms_ms1quant_match |
getComponent(std::string componentName) const | ms_ms1quant_match |
getConciseLabelFreeVarMods() const | ms_ms1quant_match |
getCorrectionMatrix() const | ms_ms1quant_match |
getDataSourceId() const | ms_ms1quant_match |
getDisplayIntensity() const | ms_ms1quant_match |
getFirstXicScanId() const | ms_ms1quant_match |
getHit(int index1) const | ms_ms1quant_match |
getKey() const | ms_ms1quant_match |
getLabelFreeVarMods() const | ms_ms1quant_match |
getLastXicScanId() const | ms_ms1quant_match |
getNumComponents() const | ms_ms1quant_match |
getNumHits() const | ms_ms1quant_match |
getNumPeptideRatios() const | ms_ms1quant_match |
getPeptideRatio(int index) const | ms_ms1quant_match |
getPeptideRatio(const std::string &ratioName) const | ms_ms1quant_match |
getPeptideString() const | ms_ms1quant_match |
getPerfectObservedMatrix() const | ms_ms1quant_match |
getPredictionMatrix() const | ms_ms1quant_match |
getReadableLabelFreeVarMods() const | ms_ms1quant_match |
getVarMods() const | ms_ms1quant_match |
getXmlCode(chargeType code) | ms_ms1quant_match | static
hasComponent(std::string componentName) const | ms_ms1quant_match |
hasIdentifiedComponent() const | ms_ms1quant_match |
hasPeptideRatio(const std::string &ratioName) const | ms_ms1quant_match |
isHitRatioExcluded(const std::string &ratioName, int hitId, int memberNumber) const | ms_ms1quant_match |
isHitRatioOutlier(const std::string &ratioName, int hitId, int memberNumber) const | ms_ms1quant_match |
isHitRatioUsedForAverage(const std::string &ratioName, int hitId, int memberNumber) const | ms_ms1quant_match |
ms_ms1quant_match() | ms_ms1quant_match |
ms_ms1quant_match(const ms_ms1quant_match_body &body) | ms_ms1quant_match |
removeComponent(const std::string &componentName) | ms_ms1quant_match |
setHitRatioExcluded(const std::string &ratioName, int hitId, int memberNumber) | ms_ms1quant_match |
setHitRatioOutlier(const std::string &ratioName, int hitId, int memberNumber) | ms_ms1quant_match |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms1quant_match_component
ms_ms1quant_match_component Member List

This is the complete list of members for ms_ms1quant_match_component, including all inherited members.

getAbsoluteValue(const int file_index=-1) const | ms_ms1quant_match_component |
getComponent() const | ms_ms1quant_match_component |
getFileIndex(const int idx) const | ms_ms1quant_match_component |
getIdxFromFileIndex(const int file_index) const | ms_ms1quant_match_component | protected
getMatchedFraction(const int file_index=-1) const | ms_ms1quant_match_component |
getMatchedRho(const int file_index=-1) const | ms_ms1quant_match_component |
getMoverz() const | ms_ms1quant_match_component |
getNumFileIndexesMatched() const | ms_ms1quant_match_component |
getNumPeptides(const int file_index=ms_quant_file_index::file_index_value_not_set) const | ms_ms1quant_match_component |
getNumRanges(const int file_index=ms_quant_file_index::file_index_value_not_set) const | ms_ms1quant_match_component |
getPeptideKey(int index, int &q, int &p) const | ms_ms1quant_match_component |
getPeptideKey(const int file_index, int index, int &q, int &p) const | ms_ms1quant_match_component |
getRange(int index) const | ms_ms1quant_match_component |
getRange(const int file_index, int index) const | ms_ms1quant_match_component |
getRelativeMass() const | ms_ms1quant_match_component |
getSummedModsStr() const | ms_ms1quant_match_component |
getVarModsStr() const | ms_ms1quant_match_component |
getXic(const int file_index=ms_quant_file_index::file_index_value_not_set) const | ms_ms1quant_match_component |
hasAbsoluteValue(const int file_index=-1) const | ms_ms1quant_match_component |
hasMatchedFraction(const int file_index=-1) const | ms_ms1quant_match_component |
hasMatchedRho(const int file_index=-1) const | ms_ms1quant_match_component |
isComponentIdentified(const int file_index=-1) const | ms_ms1quant_match_component |
ms_ms1quant_match_component() | ms_ms1quant_match_component |
ms_ms1quant_match_component(const ms_ms1quant_match_component_body &body) | ms_ms1quant_match_component |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms1quant_match_range
ms_ms1quant_match_range Member List

This is the complete list of members for ms_ms1quant_match_range, including all inherited members.

extend(int scanId, double rt) | ms_ms1quant_match_range
getRt(double &start, double &end) const | ms_ms1quant_match_range
getScan(int &start, int &end) const | ms_ms1quant_match_range
ms_ms1quant_match_range() | ms_ms1quant_match_range
ms_ms1quant_match_range(const ms_ms1quant_match_range_body &body) | ms_ms1quant_match_range
ms_ms1quant_match_range(int scanId, double rt) | ms_ms1quant_match_range
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms1quant_match_ratio
ms_ms1quant_match_ratio Member List

This is the complete list of members for ms_ms1quant_match_ratio, including all inherited members.

getCodeFromXml(std::string text) | ms_ms1quant_match_ratio | static
getCodeInfo(ratioStatusCode code, const ms_quant_method &method, double &info) | ms_ms1quant_match_ratio | static
getFitexy(ms_fitexy_result &value) const | ms_ms1quant_match_ratio |
getQuality() const | ms_ms1quant_match_ratio |
getRatioName() const | ms_ms1quant_match_ratio |
getStatus() const | ms_ms1quant_match_ratio |
getStatusList() const | ms_ms1quant_match_ratio |
getValue() const | ms_ms1quant_match_ratio |
getXmlCode(ratioStatusCode code) | ms_ms1quant_match_ratio | static
isIncluded() const | ms_ms1quant_match_ratio |
isSet() const | ms_ms1quant_match_ratio |
isUsedForAverage() const | ms_ms1quant_match_ratio |
isValid() const | ms_ms1quant_match_ratio |
ms_ms1quant_match_ratio() | ms_ms1quant_match_ratio |
ms_ms1quant_match_ratio(const ms_ms1quant_match_ratio_body &body) | ms_ms1quant_match_ratio |
ratioStatusCode enum name | ms_ms1quant_match_ratio |
RS_DO_NOT_USE enum value | ms_ms1quant_match_ratio |
RS_EMPTY enum value | ms_ms1quant_match_ratio |
RS_FITEXYSIGMA enum value | ms_ms1quant_match_ratio |
RS_INFINITERATIO enum value | ms_ms1quant_match_ratio |
RS_INTEFERENCEFAILED enum value | ms_ms1quant_match_ratio |
RS_ISOLATEDPRECURSORFAILED enum value | ms_ms1quant_match_ratio |
RS_NEGATIVERATIO enum value | ms_ms1quant_match_ratio |
RS_NODATA enum value | ms_ms1quant_match_ratio |
RS_OK enum value | ms_ms1quant_match_ratio |
RS_TOTALINTENSITYFAILED enum value | ms_ms1quant_match_ratio |
RS_ZERORATIO enum value | ms_ms1quant_match_ratio |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms1quant_peptide_status
ms_ms1quant_peptide_status Member List

This is the complete list of members for ms_ms1quant_peptide_status, including all inherited members.

getCodeFromXml(std::string str) | ms_ms1quant_peptide_status | static
getComponent() const | ms_ms1quant_peptide_status |
getQuery() const | ms_ms1quant_peptide_status |
getRank() const | ms_ms1quant_peptide_status |
getStatus() const | ms_ms1quant_peptide_status |
getXmlCode(peptideStatus code) | ms_ms1quant_peptide_status | static
ms_ms1quant_peptide_status() | ms_ms1quant_peptide_status |
ms_ms1quant_peptide_status(const ms_ms1quant_peptide_status_body &body) | ms_ms1quant_peptide_status |
peptideStatus enum name | ms_ms1quant_peptide_status |
PS_DUPLICATESAMEQUERY enum value | ms_ms1quant_peptide_status |
PS_EXCLUDE_LOCALDEF enum value | ms_ms1quant_peptide_status |
PS_EXCLUDE_MODFILE enum value | ms_ms1quant_peptide_status |
PS_EXCLUDE_UNMODIFIED enum value | ms_ms1quant_peptide_status |
PS_EXPECTGREATERTHAN enum value | ms_ms1quant_peptide_status |
PS_LESSTHANIDENTITY enum value | ms_ms1quant_peptide_status |
PS_MAX enum value | ms_ms1quant_peptide_status |
PS_MINCHARGE enum value | ms_ms1quant_peptide_status |
PS_NOMATCHINTHISFRACTION enum value | ms_ms1quant_peptide_status |
PS_NOTPARTOFQUANTITATION enum value | ms_ms1quant_peptide_status |
PS_NOTUNIQUE enum value | ms_ms1quant_peptide_status |
PS_OK enum value | ms_ms1quant_peptide_status |
PS_SCORELESSHOMOLOGY enum value | ms_ms1quant_peptide_status |
PS_SCORELESSIDENTITY_NOHOMO enum value | ms_ms1quant_peptide_status |
PS_SCORELESSTHRESHOLD enum value | ms_ms1quant_peptide_status |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms1quant_time_align
ms_ms1quant_time_align Member List

This is the complete list of members for ms_ms1quant_time_align, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
calculateFromConsensuValues(bool replaceExisting=false) | ms_ms1quant_time_align |
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
featureWidths_t typedef | ms_ms1quant_time_align |
fractionToSubProject_t typedef | ms_ms1quant_time_align |
getAlgorithmName() const | ms_ms1quant_time_align |
getBinSize() const | ms_ms1quant_time_align |
getCombinedLimits(const int fractionNum) | ms_ms1quant_time_align |
getCombinedLimits(const int fractionNum) const | ms_ms1quant_time_align |
getErrorHandler() const | ms_errors |
getEstimatedFeatureWidth(const int subProjectId, const double mOverZ, const double rt) const | ms_ms1quant_time_align |
getEvaluation(const int subProject, double &meanErrorsRaw, double &meanErrorsAligned, double &stdevErrorsRaw, double &stdevErrorsAligned, double &pearsonCoefficientRaw, double &pearsonCoefficientAligned) | ms_ms1quant_time_align |
getFeatureWidths() const | ms_ms1quant_time_align |
getFinalResults() | ms_ms1quant_time_align |
getFinalResults() const | ms_ms1quant_time_align |
getFractionToSubProjectMap() const | ms_ms1quant_time_align |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getRToffset(const int myProjectId, const int otherProjectId, const double rtInOtherProject, const double mOverZ) const | ms_ms1quant_time_align |
getShiftsFromConsensus() const | ms_ms1quant_time_align |
getShiftsToConsensus() const | ms_ms1quant_time_align |
getStatus(void) const | ms_ms1quant_time_align |
getStatusAsText(void) const | ms_ms1quant_time_align |
getSubProjectToFractionMap() const | ms_ms1quant_time_align |
isValid() const | ms_errors |
loadXmlFile(const std::string &xmlFilename, const std::string &schemaDirectory) | ms_ms1quant_time_align |
ms_errors() | ms_errors |
ms_ms1quant_time_align(const int binSize=12) | ms_ms1quant_time_align |
ms_ms1quant_time_align(const ms_ms1quant_time_align_body &body) | ms_ms1quant_time_align |
saveXmlFile(const std::string &xmlFilename, const std::string &schemaDirectory) const | ms_ms1quant_time_align |
setAlgorithmName(const char *algorithmName) | ms_ms1quant_time_align |
setAverageFeatureWidths(const std::vector< double > &featureWidths) | ms_ms1quant_time_align |
setEvaluation(int subProject, double meanErrorsRaw, double meanErrorsAligned, double stdevErrorsRaw, double stdevErrorsAligned, double pearsonCoefficientRaw, double pearsonCoefficientAligned) | ms_ms1quant_time_align | protected
ST_TA_CALCULATED enum value | ms_ms1quant_time_align |
ST_TA_LOADED_FROM_CDB enum value | ms_ms1quant_time_align |
ST_TA_LOADED_FROM_XML enum value | ms_ms1quant_time_align |
ST_TA_NO_DATA enum value | ms_ms1quant_time_align |
status_t enum name | ms_ms1quant_time_align |
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms1quant_time_align_limits
ms_ms1quant_time_align_limits Member List

This is the complete list of members for ms_ms1quant_time_align_limits, including all inherited members.

combinedRT_t typedef | ms_ms1quant_time_align_limits |
combinedRTinterval | ms_ms1quant_time_align_limits | static
getCombinedMaxBinNum() const | ms_ms1quant_time_align_limits |
getCombinedMaxRT() const | ms_ms1quant_time_align_limits |
getCombinedMinBinNum() const | ms_ms1quant_time_align_limits |
getCombinedMinRT() const | ms_ms1quant_time_align_limits |
getMaxMZ() const | ms_ms1quant_time_align_limits |
getMaxRT() const | ms_ms1quant_time_align_limits |
getMinMZ() const | ms_ms1quant_time_align_limits |
getMinRT() const | ms_ms1quant_time_align_limits |
getNumQueries() const | ms_ms1quant_time_align_limits |
getNumQueriesAboveThreshold() const | ms_ms1quant_time_align_limits |
ms_ms1quant_time_align_limits() | ms_ms1quant_time_align_limits |
setMaxBinNum(const int value) | ms_ms1quant_time_align_limits |
setMaxMZ(const double value) | ms_ms1quant_time_align_limits |
setMaxRT(const double value) | ms_ms1quant_time_align_limits |
setMinBinNum(const int value) | ms_ms1quant_time_align_limits |
setMinMZ(const double value) | ms_ms1quant_time_align_limits |
setMinRT(const double value) | ms_ms1quant_time_align_limits |
setNumQueries(const int value) | ms_ms1quant_time_align_limits |
setNumQueriesAboveThreshold(const int value) | ms_ms1quant_time_align_limits |
Generated on Tue Sep 24 2024 11:06:13 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms1quantitation
ms_ms1quantitation Member List

This is the complete list of members for ms_ms1quantitation, including all inherited members.

addHeaderField(const std::string &name, const std::string &value) | ms_quantitation |
addMatchInferred(const ms_ms1quant_match &siblingMatch, int newCharge) | ms_ms1quantitation |
addMatchPeptide(matrix_science::ms_protein *hit, matrix_science::ms_peptide *peptide, const matrix_science::ms_quant_component &component, const std::string &matchBelongsToComponent, const int thisSubProjectId=matrix_science::ms_quant_file_index::file_index_value_not_set) | ms_ms1quantitation |
addMatchStatus(matrix_science::ms_peptide *peptide, matrix_science::ms_ms1quant_peptide_status::peptideStatus status, matrix_science::ms_protein *hit=0) | ms_ms1quantitation |
addPeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key) | ms_customquantitation |
addPeptideQuantKeys(const std::string &accession, int dbIdx, const std::vector< ms_peptide_quant_key > &keys) | ms_customquantitation |
addPeptideQuantKeys(const std::string &accession, int dbIdx, const ms_peptide_quant_key_vector &keys) | ms_customquantitation |
addPeptideRatio(const ms_peptide_quant_ratio &ratio) | ms_customquantitation |
addRawFileField(const unsigned int id, const std::string &name, const std::string &value) | ms_quantitation |
appendErrors(const ms_errors &src) | ms_errors |
BUGFIX_12409 enum value | ms_ms1quantitation |
calculateGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
calculateMedianRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
calculateWeightedGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
clearAllErrors() | ms_errors |
clearHeaderFields() | ms_quantitation |
clearPeptideQuantKeys(const std::string &accession, int dbIdx) | ms_customquantitation |
clearPeptideRatios() | ms_customquantitation |
clearRawFileFields() | ms_quantitation |
copyFrom(const ms_errors *right) | ms_errors |
countDistinctPeptides(const std::vector< ms_peptide_quant_key > &activeKeys) const | ms_ms1quantitation | virtual
countDistinctPeptides(const std::vector< ms_peptide_quant_key > &activeKeys) const | ms_ms1quantitation | virtual
countDistinctPeptides(const ms_peptide_quant_key_vector &activeKeys) const | ms_ms1quantitation | virtual
findMatch(matrix_science::ms_peptide_quant_key matchKey, ms_ms1quant_match *match) const | ms_ms1quantitation |
findPeptideStatus(int query, int rank, ms_ms1quant_peptide_status *peptideStatus) const | ms_ms1quantitation |
getAveragePeptideIntensity(const std::string &accession, int dbIdx, double *averageIntensity, int *sampleSize, ms_peptide_quant_key_vector *includeKeys, ms_peptide_quant_key_vector *excludeKeys) const | ms_ms1quantitation |
getAverageResults() const | ms_ms1quantitation |
getErrorHandler() const | ms_errors |
getHit(int index1) const | ms_ms1quantitation |
getLabelFree(std::string peptideStr, std::string varMods, std::string summedMods, const matrix_science::ms_quant_component &comp) const | ms_ms1quantitation |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMatch(int index) const | ms_ms1quantitation |
getMatch(const ms_peptide_quant_key &key) const | ms_ms1quantitation |
getMatchForHit(int index, int hitId, int memberNumber) const | ms_ms1quantitation |
getMinNumPeptides() const | ms_quantitation | protected
getNumGroups() const | ms_ms1quantitation |
getNumHits() const | ms_ms1quantitation |
getNumMatches() const | ms_ms1quantitation |
getNumMatchesForGroup(int groupIndex1) const | ms_ms1quantitation |
getNumMatchesForHit(int hitId, int memberNumber) const | ms_ms1quantitation |
getNumPeptideStatuses() const | ms_ms1quantitation |
getNumProteinFamilies() const | ms_ms1quantitation |
getPeptideQuantKeys(const std::string &accession, int dbIdx) const | ms_quantitation |
getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | virtual
getPeptideRatioNormalisationBase(const std::string &ratioName) const | ms_quantitation |
getPeptideStatus(int index) const | ms_ms1quantitation |
getPeptideSummary() const | ms_ms1quantitation |
getProgressInfo() | ms_quantitation |
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const | ms_ms1quantitation | virtual
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const | ms_ms1quantitation | virtual
getProteinRatioSample(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const | ms_quantitation | protected
getQuantitationDatasources() const | ms_ms1quantitation |
getQuantitationMethod() const | ms_quantitation |
getReadableVarMods(std::string varmods) | ms_ms1quantitation |
getReadableVarModsConcise(std::string varmods) | ms_ms1quantitation |
getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const | ms_customquantitation | protectedvirtual
getSummary() const | ms_ms1quantitation |
getTimeAlignmentData() const | ms_ms1quantitation |
getTimeAlignmentData() | ms_ms1quantitation |
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType) const | ms_customquantitation |
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const ms_peptide_quant_key_vector &keys) const | ms_customquantitation |
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const std::string &accession, int dbIdx) const | ms_customquantitation |
hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | virtual
initGroupChargeStates(std::set< int > *calc_chargestates, int iGroup1, int minCharge, int maxCharge) | ms_ms1quantitation |
initialiseBaseSettings(const ms_quant_method &qmBase, const ms_quant_method &qmConfig) | ms_quantitation | protected
isAverageProtocol() const | ms_ms1quantitation |
isDataCached(MS1QUANT_BUGFIX_NUM bugNum) const | ms_ms1quantitation |
isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | virtual
isValid() const | ms_errors |
loadCdbFile(const std::string &cdbFilename, const std::string &cacheFilename, bool revalidateQualityThresholds=true) | ms_ms1quantitation |
loadXmlFile(const std::string &filename, const std::string &xmlSchemaPath) | ms_ms1quantitation |
MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE enum value | ms_ms1quantitation |
MERGE_QUANT_DEFAULT_PRECURSOR_METHOD enum value | ms_ms1quantitation |
MERGE_QUANT_DEFAULT_REPLICATE_METHOD enum value | ms_ms1quantitation |
MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH enum value | ms_ms1quantitation |
MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS enum value | ms_ms1quantitation |
MERGE_QUANT_RESULTS_FLAGS enum name | ms_ms1quantitation |
MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC enum value | ms_ms1quantitation |
mergeQuantitationResults(const std::vector< std::string > &cdbFilenames, const std::vector< std::string > &cacheFilenames, const MERGE_QUANT_RESULTS_FLAGS flags, const matrix_science::ms_quant_method *originalMethod=0) | ms_ms1quantitation |
mergeQuantitationResults(const std::vector< std::string > &xmlFilenames, const MERGE_QUANT_RESULTS_FLAGS flags, const std::string &xmlSchemaPath="", const matrix_science::ms_quant_method *originalMethod=0) | ms_ms1quantitation |
MS1QUANT_BUGFIX_NUM enum name | ms_ms1quantitation |
ms_customquantitation(const ms_quant_method &qm) | ms_customquantitation | explicit
ms_customquantitation(const ms_peptidesummary &initFrom) | ms_customquantitation | explicit
ms_customquantitation(const ms_peptidesummary &initFrom, const ms_quant_method &qm) | ms_customquantitation |
ms_customquantitation(const ms_ms2quantitation &copyFrom) | ms_customquantitation | explicit
ms_errors() | ms_errors |
ms_ms1quantitation(const ms_peptidesummary &summary, const ms_quant_method &method) | ms_ms1quantitation |
openQuantitationCdbResults(const matrix_science::ms_peptidesummary &summary, const matrix_science::ms_quant_method &method, const std::string &cdbFilename, const std::string &cacheFilename, const matrix_science::ms_quant_method *originalMethod=0) | ms_ms1quantitation | static
openQuantitationXmlResults(const matrix_science::ms_peptidesummary &summary, const matrix_science::ms_quant_method &method, const std::string &filename, const std::string &xmlSchemaPath="", const matrix_science::ms_quant_method *originalMethod=0) | ms_ms1quantitation | static
proteinKeys_ | ms_quantitation | protected
readResultCounters(const std::string &cdbFile, int &numMatches, int &numHits, int &numPepGrp, int &numPeptideComponents) | ms_ms1quantitation | static
removeMatch(matrix_science::ms_peptide_quant_key matchKey) | ms_ms1quantitation |
removePeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key) | ms_customquantitation |
removePeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation |
removePeptideRatioNormalisationBase(const std::string &ratioName) | ms_quantitation |
removePeptideRatioNormalisationBases() | ms_quantitation |
saveCdbFile(const std::string &cdbFilename, const std::string &cacheFilename, bool createEmptyMissingComponents=false) | ms_ms1quantitation |
saveXmlFile(const std::string &xmlFilename, bool completeReport, bool saveTimeAlignmentData=false) | ms_ms1quantitation |
setAverageNumPeptides(unsigned int num=3) | ms_ms1quantitation |
setAverageReferenceProtein(const char *accession, int dbIdx, bool isReferenceUserSelected) | ms_ms1quantitation |
setAverageSelection(const char *value) | ms_ms1quantitation |
setMinNumPeptides(int value) | ms_quantitation |
setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation | virtual
setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation | virtual
setPeptideRatioNormalisationBase(const std::string &ratioName, double b) | ms_quantitation |
setProteinRatioType(const char *value) | ms_customquantitation | virtual
setQuantOutliers(const ms_quant_outliers *) | ms_customquantitation | virtual
setTimeAlignmentData(matrix_science::ms_ms1quant_time_align &alignmentData) | ms_ms1quantitation |
~ms_customquantitation() | ms_customquantitation | virtual
~ms_errors() | ms_errors |
~ms_quantitation()=0 | ms_quantitation | pure virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_ms2quantitation
ms_ms2quantitation Member List

This is the complete list of members for ms_ms2quantitation, including all inherited members.

addHeaderField(const std::string &name, const std::string &value) | ms_quantitation |
addRawFileField(const unsigned int id, const std::string &name, const std::string &value) | ms_quantitation |
appendErrors(const ms_errors &src) | ms_errors |
calculateGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
calculateMedianRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
calculateWeightedGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
clearAllErrors() | ms_errors |
clearHeaderFields() | ms_quantitation |
clearRawFileFields() | ms_quantitation |
copyFrom(const ms_errors *right) | ms_errors |
countDistinctPeptides(const std::vector< ms_peptide_quant_key > &activeKeys) const | ms_ms2quantitation | virtual
countDistinctPeptides(const std::vector< ms_peptide_quant_key > &activeKeys) const | ms_ms2quantitation | virtual
countDistinctPeptides(const ms_peptide_quant_key_vector &activeKeys) const | ms_ms2quantitation | virtual
excludeProteinPeptideRatioKeys(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &excludeKeys) | ms_ms2quantitation |
getCombinedReportRatio(const std::string &ratioName) const | ms_ms2quantitation |
getCombinedReportRatioNames() const | ms_ms2quantitation |
getComponentIntensities(const ms_peptide_quant_key &key, bool raw=false) const | ms_ms2quantitation |
getErrorHandler() const | ms_errors |
getIntensityNormalisationBase(const std::string &componentName) const | ms_ms2quantitation |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMinNumPeptides() const | ms_quantitation | protected
getPeptideQuantKeys(const std::string &accession, int dbIdx) const | ms_quantitation |
getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_ms2quantitation | virtual
getPeptideRatioNormalisationBase(const std::string &ratioName) const | ms_quantitation |
getPeptideSummary() const | ms_ms2quantitation |
getProgressInfo() | ms_quantitation |
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const | ms_ms2quantitation | virtual
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const | ms_ms2quantitation | virtual
getProteinRatioSample(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const | ms_quantitation | protected
getQuantitationMethod() const | ms_quantitation |
getReportRatioFromFile(unsigned int fileNum, const std::string &ratioName) const | ms_ms2quantitation |
getReportRatioNamesInFile(unsigned int fileNum) const | ms_ms2quantitation |
getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const | ms_ms2quantitation | protectedvirtual
hasIntensityNormalisation() const | ms_ms2quantitation |
hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_ms2quantitation | virtual
hasPeptideRatioNormalisation() const | ms_ms2quantitation |
includeProteinPeptideRatioKeys(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys) | ms_ms2quantitation |
initialiseBaseSettings(const ms_quant_method &qmBase, const ms_quant_method &qmConfig) | ms_quantitation | protected
isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_ms2quantitation | virtual
isValid() const | ms_errors |
loadCdbFile(const char *path) | ms_ms2quantitation |
loadCdbFiles(const std::vector< std::string > &cdbFiles) | ms_ms2quantitation |
ms_errors() | ms_errors |
ms_ms2quantitation(const ms_peptidesummary &pepsum) | ms_ms2quantitation | explicit
ms_ms2quantitation(const ms_peptidesummary &pepsum, const ms_quant_method &qm) | ms_ms2quantitation |
normaliseIntensities() | ms_ms2quantitation |
normalisePeptideRatios() | ms_ms2quantitation |
proteinKeys_ | ms_quantitation | protected
removeCombinedReportRatio(const std::string &ratioName) | ms_ms2quantitation |
removeIntensityNormalisationBase(const std::string &componentName) | ms_ms2quantitation |
removeIntensityNormalisationBases() | ms_ms2quantitation |
removePeptideRatioNormalisationBase(const std::string &ratioName) | ms_quantitation |
removePeptideRatioNormalisationBases() | ms_quantitation |
removeReportRatioInFile(unsigned int fileNum, const std::string &ratioName) | ms_ms2quantitation |
saveCdbFile(const std::string &cdbFilename) | ms_ms2quantitation |
saveXmlFile(const std::string &xmlFilename, bool completeReport) | ms_ms2quantitation |
setCombinedReportRatio(const std::string &ratioName, const ms_quant_ratio &ratioDef) | ms_ms2quantitation |
setIntensityNormalisationBase(const std::string &componentName, double b) | ms_ms2quantitation |
setMinNumPeptides(int value) | ms_quantitation |
setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_ms2quantitation | virtual
setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_ms2quantitation | virtual
setPeptideRatioNormalisationBase(const std::string &ratioName, double b) | ms_quantitation |
setProteinRatioType(const char *value) | ms_ms2quantitation | virtual
setQuantNormalisation(const ms_quant_normalisation *norm) | ms_ms2quantitation |
setQuantOutliers(const ms_quant_outliers *) | ms_ms2quantitation | virtual
setReportRatioInFile(unsigned int fileNum, const std::string &ratioName, const ms_quant_ratio &ratioDef) | ms_ms2quantitation |
~ms_errors() | ms_errors |
~ms_ms2quantitation() | ms_ms2quantitation | virtual
~ms_quantitation()=0 | ms_quantitation | pure virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_msr2dat28
ms_msr2dat28 Member List

This is the complete list of members for ms_msr2dat28, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
getCurrentLineNumber() const | ms_msr2dat28 |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getNextLine() | ms_msr2dat28 |
includeIndexSection(bool maybe) | ms_msr2dat28 |
includeQuerySectionIonsLines(bool maybe) | ms_msr2dat28 |
isConversionSupported() const | ms_msr2dat28 |
isIndexSectionIncluded() const | ms_msr2dat28 |
isQuerySectionIonsLinesIncluded() const | ms_msr2dat28 |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_msr2dat28(const ms_mascotresfile_msr &resfile) | ms_msr2dat28 | explicit
rewind() | ms_msr2dat28 |
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_obofile
ms_obofile Member List

This is the complete list of members for ms_obofile, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_obofile *right) | ms_obofile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_obofile
findIDFromTagValue(const char *tag, const char *value) const | ms_obofile
getErrorHandler() const | ms_errors
getItemFromId(const char *id) const | ms_obofile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumberOfEntries() const | ms_obofile
isValid() const | ms_errors
ms_errors() | ms_errors
ms_obofile() | ms_obofile
ms_obofile(const char *oboFileName) | ms_obofile
ms_obofile(const ms_obofile &right) | ms_obofile
operator=(const ms_obofile &right) | ms_obofile
parseLine(const std::string str, std::string &tag, std::string &value, std::string &comment) const | ms_obofile
~ms_errors() | ms_errors
~ms_obofile() | ms_obofile
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_parseoptions
ms_parseoptions Member List

This is the complete list of members for ms_parseoptions, including all inherited members.

appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
clearParseRules() | ms_parseoptions
copyFrom(const ms_parseoptions *right) | ms_parseoptions
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_parseoptions
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
dropParseRule(const int index) | ms_parseoptions
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getNumberOfParseRules() const | ms_parseoptions
getNumberOfProperties() const | ms_customproperty
getParseRule(const int index) const | ms_parseoptions
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
isSectionAvailable() const | ms_parseoptions
ms_customproperty() | ms_customproperty
ms_parseoptions() | ms_parseoptions
ms_parseoptions(const ms_parseoptions &src) | ms_parseoptions
operator=(const ms_parseoptions &right) | ms_parseoptions
setDefaultDelimiter(const char *delim) | ms_customproperty
setParseRule(const int index, const ms_parserule *rule) | ms_parseoptions
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setSectionAvailable(const bool value) | ms_parseoptions
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
~ms_parseoptions() | ms_parseoptions
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_parserule
ms_parserule Member List

This is the complete list of members for ms_parserule, including all inherited members.

copyFrom(const ms_parserule *right) | ms_parserule
defaultValues() | ms_parserule
getRuleStr() const | ms_parserule
isAvailable() const | ms_parserule
ms_parserule() | ms_parserule
ms_parserule(const ms_parserule &src) | ms_parserule
operator=(const ms_parserule &right) | ms_parserule
setAvailable(const bool value) | ms_parserule
setRuleStr(const char *str) | ms_parserule
~ms_parserule() | ms_parserule
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_parserule_plus
ms_parserule_plus Member List

This is the complete list of members for ms_parserule_plus, including all inherited members.

copyFrom(const ms_parserule_plus *right) | ms_parserule_plus
defaultValues() | ms_parserule_plus
getChopSource() const | ms_parserule_plus
getFileTypeToSearch() const | ms_parserule_plus
getNameOfDB() const | ms_parserule_plus
getRule() const | ms_parserule_plus
ms_parserule_plus() | ms_parserule_plus
ms_parserule_plus(const ms_parserule_plus &src) | ms_parserule_plus
operator=(const ms_parserule_plus &right) | ms_parserule_plus
setChopSource(const TAX_CHOP_SRC value) | ms_parserule_plus
setFileTypeToSearch(const TAX_SPECIES_FORMAT value) | ms_parserule_plus
setNameOfDB(const char *name) | ms_parserule_plus
setRule(const ms_parserule *src) | ms_parserule_plus
TAX_CHOP_PREFIX enum value | ms_parserule_plus
TAX_CHOP_SRC typedef | ms_parserule_plus
TAX_CHOP_SUFFIX enum value | ms_parserule_plus
TAX_CHOP_TYPES enum name | ms_parserule_plus
TAX_CHOP_WORDS enum value | ms_parserule_plus
~ms_parserule_plus() | ms_parserule_plus
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_peptide
ms_peptide Member List

This is the complete list of members for ms_peptide, including all inherited members.

anyPercolatorResults() const | ms_peptide
clearReloadableInfo() | ms_peptide
copyFrom(const ms_peptide *src) | ms_peptide
getAmbiguityString(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getAnyMatch() const | ms_peptide
getAnyProteinTermination(bool &isNterminus, bool &isCterminus, const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getCharge() const | ms_peptide
getComponentStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getDelta() const | ms_peptide
getExpectationValue() const | ms_peptide
getFirstProtAppearedIn() const | ms_peptide
getIntactLinks(ms_linker_site_vector &vec) const | ms_peptide
getIntactLinks() const | ms_peptide
getIonsIntensity() const | ms_peptide
getIonsScore() const | ms_peptide
getIsFromErrorTolerant() const | ms_peptide
getIsFromLibrary() const | ms_peptide
getLessThanMinPepLen() const | ms_peptide
getLocalModsNlStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getLocalModsStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getLoopLinks(ms_linker_site_vector &vec, const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getLoopLinks(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getMissedCleavages(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getMonoLinkStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getMrCalc(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getMrExperimental() const | ms_peptide
getNum13C(const double tol, const std::string tolu, const std::string mass_type) const | ms_peptide
getNumberOfLinkedPeptides() const | ms_peptide
getNumIonsMatched() const | ms_peptide
getNumProteins() const | ms_peptide
getObserved() const | ms_peptide
getPeaksUsedFromIons1() const | ms_peptide
getPeaksUsedFromIons2() const | ms_peptide
getPeaksUsedFromIons3() const | ms_peptide
getPeptideLength(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getPeptideStr(bool substituteAmbiguous=true, const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getPercolatorScores(double *posteriorErrorProbability, double *qValue, double *internalPercolatorScore, double *mascotIonsScore) const | ms_peptide
getPrettyRank() const | ms_peptide
getPrimaryNlStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getProtein(int num) const | ms_peptide
getProteins() const | ms_peptide
getQuery() const | ms_peptide
getRank() const | ms_peptide
getSeriesUsedStr() const | ms_peptide
getSummedModsNlStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getSummedModsStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getVarModsStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
isSamePeptideStr(ms_peptide *peptide, bool substituteAmbiguous=true) const | ms_peptide
isSameSummedModsStr(ms_peptide *peptide) const | ms_peptide
isSameVarModsStr(ms_peptide *peptide) const | ms_peptide
ms_peptide() | ms_peptide
ms_peptide(int query, int rank, int missedCleavages, double mrCalc, double delta, double observed, int charge, int numIonsMatched, std::string peptideStr, int peaksUsedFromIons1, std::string varModsStr, double ionsScore, std::string seriesUsedStr, int peaksUsedFromIons2, int peaksUsedFromIons3, const ms_mascotresults *pResults=0, bool storeReloadableInfo=true) | ms_peptide
ms_peptide(const int query, const int rank, const SEARCH_PHASE searchPhase, const int missedCleavages, const double mrCalc, const double delta, const double observed, const int charge, const int numIonsMatched, const std::string &peptideStr, const int peaksUsedFromIons1, const std::string &varModsStr, const std::string &summedModsStr, const std::string &localModsStr, const std::string &monoLinkStr, const ms_linker_site_vector &loopLinks, const double ionsScore, const std::string &seriesUsedStr, const int peaksUsedFromIons2, const int peaksUsedFromIons3, const std::string &primaryNlStr, const std::string &summedModsNlStr, const std::string &localModsNlStr, const std::string &substStr, const std::string &componentStr, const ms_mascotresults *pResults=0, const bool storeReloadableInfo=true) | ms_peptide
ms_peptide(const int query, const int rank, const SEARCH_PHASE searchPhase, const double delta, const double observed, const int charge, const int numIonsMatched, const int peaksUsedFromIons1, const double ionsScore, const std::string &seriesUsedStr, const int peaksUsedFromIons2, const int peaksUsedFromIons3, const ms_peptide &pepAlpha, const ms_peptide &pepBeta, const ms_linker_site &linkerSite, const ms_mascotresults *pResults=0, const bool storeReloadableInfo=true) | ms_peptide
ms_peptide(const ms_peptide &src) | ms_peptide
operator=(const ms_peptide &right) | ms_peptide
PSM enum name | ms_peptide
PSM_COMPLETE enum value | ms_peptide
PSM_CROSSLINK enum value | ms_peptide
PSM_CROSSLINK_ALPHA enum value | ms_peptide
PSM_CROSSLINK_BETA enum value | ms_peptide
PSM_DECOY enum value | ms_peptide
PSM_ERRTOL enum value | ms_peptide
PSM_ERRTOLDECOY enum value | ms_peptide
PSM_LIBRARY enum value | ms_peptide
PSM_STANDARD enum value | ms_peptide
PSM_TYPE enum name | ms_peptide
setLocalModsStr(const std::string str, const PSM psmComponent=PSM_COMPLETE) | ms_peptide
setSummedModsStr(const std::string str, const PSM psmComponent=PSM_COMPLETE) | ms_peptide
setVarModsStr(const std::string str, const PSM psmComponent=PSM_COMPLETE) | ms_peptide
~ms_peptide() | ms_peptide
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_peptide_quant_key
ms_peptide_quant_key Member List

This is the complete list of members for ms_peptide_quant_key, including all inherited members.

getCharge(int &charge) const | ms_peptide_quant_key |
getID(int &ID) const | ms_peptide_quant_key |
getOpaqueString(std::string &opaqueStringRef) const | ms_peptide_quant_key |
getOpaqueStringAndID(std::string &opaqueStringRef, int &ID) const | ms_peptide_quant_key |
getQueryAndRank(int &q, int &p) const | ms_peptide_quant_key |
isNil() const | ms_peptide_quant_key |
ms_peptide_quant_key() | ms_peptide_quant_key |
ms_peptide_quant_key(int q, int p) | ms_peptide_quant_key |
ms_peptide_quant_key(int q, int p, int charge) | ms_peptide_quant_key |
ms_peptide_quant_key(int ID) | ms_peptide_quant_key | explicit
ms_peptide_quant_key(const std::string &opaqueString) | ms_peptide_quant_key | explicit
ms_peptide_quant_key(const std::string &opaqueString, int ID) | ms_peptide_quant_key | explicit
ms_peptide_quant_key(const ms_peptide_quant_key &src) | ms_peptide_quant_key |
operator!=(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
operator<(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
operator<=(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
operator=(const ms_peptide_quant_key &right) | ms_peptide_quant_key |
operator==(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
operator>(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
operator>=(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
~ms_peptide_quant_key() | ms_peptide_quant_key |
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_peptide_quant_key_vector
ms_peptide_quant_key_vector Member List

This is the complete list of members for ms_peptide_quant_key_vector, including all inherited members.

append(const ms_peptide_quant_key_vector &src) | ms_peptide_quant_key_vector |
clear() | ms_peptide_quant_key_vector |
copyFrom(const ms_peptide_quant_key_vector *src) | ms_peptide_quant_key_vector |
empty() const | ms_peptide_quant_key_vector |
get(int idx) const | ms_peptide_quant_key_vector |
ms_peptide_quant_key_vector() | ms_peptide_quant_key_vector |
ms_peptide_quant_key_vector(const std::vector< ms_peptide_quant_key > &v) | ms_peptide_quant_key_vector | explicit
ms_peptide_quant_key_vector(const std::list< ms_peptide_quant_key > &v) | ms_peptide_quant_key_vector | explicit
ms_peptide_quant_key_vector(const ms_peptide_quant_key_vector &src) | ms_peptide_quant_key_vector |
operator=(const ms_peptide_quant_key_vector &right) | ms_peptide_quant_key_vector |
pop() | ms_peptide_quant_key_vector |
push(const ms_peptide_quant_key &key) | ms_peptide_quant_key_vector |
set(int idx, const ms_peptide_quant_key &key) | ms_peptide_quant_key_vector |
size() const | ms_peptide_quant_key_vector |
swap(ms_peptide_quant_key_vector &right) | ms_peptide_quant_key_vector |
toVector() const | ms_peptide_quant_key_vector |
~ms_peptide_quant_key_vector() | ms_peptide_quant_key_vector |
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_peptide_quant_ratio
ms_peptide_quant_ratio Member List

This is the complete list of members for ms_peptide_quant_ratio, including all inherited members.

copyFrom(const ms_peptide_quant_ratio *src) | ms_peptide_quant_ratio
getKey() const | ms_peptide_quant_ratio
getRatioName() const | ms_peptide_quant_ratio
getValue() const | ms_peptide_quant_ratio
getWeight() const | ms_peptide_quant_ratio
isExcluded() const | ms_peptide_quant_ratio
isInfinite() const | ms_peptide_quant_ratio
isMissing() const | ms_peptide_quant_ratio
ms_peptide_quant_ratio(const ms_peptide_quant_key &key, const std::string &ratioName, bool isInfinite=false) | ms_peptide_quant_ratio
ms_peptide_quant_ratio(const ms_peptide_quant_key &key, const std::string &ratioName, double value, bool isExcluded=false, double weight=1.0) | ms_peptide_quant_ratio
ms_peptide_quant_ratio(const ms_peptide_quant_ratio &src) | ms_peptide_quant_ratio
operator=(const ms_peptide_quant_ratio &right) | ms_peptide_quant_ratio
~ms_peptide_quant_ratio() | ms_peptide_quant_ratio
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_peptidesummary
ms_peptidesummary Member List

This is the complete list of members for ms_peptidesummary, including all inherited members.

anyEmPAI() const | ms_peptidesummary | virtual
anyNumDiscoveredMods() const | ms_mascotresults | virtual
BUGFIX_10780 enum value | ms_peptidesummary |
BUGFIX_10995 enum value | ms_peptidesummary |
BUGFIX_11002 enum value | ms_peptidesummary |
BUGFIX_11018 enum value | ms_peptidesummary |
BUGFIX_11235 enum value | ms_peptidesummary |
BUGFIX_11254 enum value | ms_peptidesummary |
BUGFIX_11344 enum value | ms_peptidesummary |
BUGFIX_11411 enum value | ms_peptidesummary |
BUGFIX_11425 enum value | ms_peptidesummary |
BUGFIX_11438 enum value | ms_peptidesummary |
BUGFIX_11481 enum value | ms_peptidesummary |
BUGFIX_11483 enum value | ms_peptidesummary |
BUGFIX_11499 enum value | ms_peptidesummary |
BUGFIX_11856 enum value | ms_peptidesummary |
BUGFIX_12123 enum value | ms_peptidesummary |
BUGFIX_12317 enum value | ms_peptidesummary |
BUGFIX_12447 enum value | ms_peptidesummary |
BUGFIX_12538 enum value | ms_peptidesummary |
BUGFIX_12729 enum value | ms_peptidesummary |
BUGFIX_12740 enum value | ms_peptidesummary |
BUGFIX_13324 enum value | ms_peptidesummary |
BUGFIX_13759 enum value | ms_peptidesummary |
BUGFIX_NUM enum name | ms_peptidesummary |
CACHE_MISSING_RESFILE enum value | ms_peptidesummary |
CACHE_STATUS enum name | ms_peptidesummary |
cancelCreateSummary(bool newValue=true) | ms_mascotresults |
createSummary() | ms_peptidesummary | virtual
createUnassignedList(sortBy s=QUERY) | ms_mascotresults |
DB_MATCH_TYPE enum name | ms_mascotresults |
DECOY_STATS_COUNT_TYPE enum name | ms_mascotresults |
DM_BOTH enum value | ms_mascotresults |
DM_FASTA enum value | ms_mascotresults |
DM_FASTA_FIRST_PASS enum value | ms_mascotresults |
DM_FASTA_SECOND_PASS enum value | ms_mascotresults |
DM_SPECTRAL_LIBRARY enum value | ms_mascotresults |
DS_COUNT_PSM enum value | ms_mascotresults |
DS_COUNT_SEQUENCE enum value | ms_mascotresults |
dumpCDB(const std::string dumpFileName) | ms_peptidesummary |
FC_ALL_PEPTIDES enum value | ms_mascotresults |
FC_ALL_PEPTITDES enum value | ms_mascotresults |
FC_CASE_INSENSITIVE enum value | ms_mascotresults |
FC_CASE_SENSITIVE enum value | ms_mascotresults |
FC_COMPLETESTR enum value | ms_mascotresults |
FC_FORWARD enum value | ms_mascotresults |
FC_LOOP_FROM_UNASSIGNED enum value | ms_mascotresults |
FC_LOOP_INTO_UNASSIGNED enum value | ms_mascotresults |
FC_MASK_CASE enum value | ms_mascotresults |
FC_MASK_DIRECTION enum value | ms_mascotresults |
FC_MASK_STR_PART enum value | ms_mascotresults |
FC_PROTEIN_IGN_FAMILY enum value | ms_mascotresults |
FC_PROTEIN_IGN_MASK enum value | ms_mascotresults |
FC_PROTEIN_IGN_SAMESETS enum value | ms_mascotresults |
FC_PROTEIN_IGN_SUBSETS enum value | ms_mascotresults |
FC_PROTEIN_INC_ALT_ACC enum value | ms_mascotresults |
FC_RESTRICT_TO_HIT enum value | ms_mascotresults |
FC_REVERSE enum value | ms_mascotresults |
FC_SCORING_MASK enum value | ms_mascotresults |
FC_SEARCH_ALL_RANKS enum value | ms_mascotresults |
FC_SEARCH_IGNORED_RANKS enum value | ms_mascotresults |
FC_SIGNIFICANT_PEPTIDES enum value | ms_mascotresults |
FC_STARTSTR enum value | ms_mascotresults |
FC_STRTOK enum value | ms_mascotresults |
FC_SUBSTR enum value | ms_mascotresults |
FC_UNASSIGNED_MASK enum value | ms_mascotresults |
FIND_COMPARE_FLAGS enum name | ms_mascotresults |
FIND_FLAGS enum name | ms_mascotresults |
findPeptides(const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const | ms_peptidesummary | virtual
findProteins(const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_peptidesummary | virtual
findProteinsByAccession(const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_peptidesummary | virtual
findProteinsByDescription(const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_peptidesummary | virtual
FLAGS enum name | ms_mascotresults |
freeHit(const int hit) | ms_peptidesummary | virtual
FT_PEPTIDE_CALC_MR enum value | ms_mascotresults |
FT_PEPTIDE_CALC_MZ enum value | ms_mascotresults |
FT_PEPTIDE_ETMOD enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MR enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MZ enum value | ms_mascotresults |
FT_PEPTIDE_FIND_MASK enum value | ms_mascotresults |
FT_PEPTIDE_FIXMOD enum value | ms_mascotresults |
FT_PEPTIDE_QUERY enum value | ms_mascotresults |
FT_PEPTIDE_SLMOD enum value | ms_mascotresults |
FT_PEPTIDE_STRING enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD_BYNAME enum value | ms_mascotresults |
FT_PROTEIN_ACCESSION enum value | ms_mascotresults |
FT_PROTEIN_DESCRIPTION enum value | ms_mascotresults |
getAllFamilyMembersWithThisPepMatch(const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const | ms_peptidesummary | virtual
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const | ms_peptidesummary | virtual
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const | ms_peptidesummary | virtual
getAvePeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getCacheFileName() const | ms_peptidesummary |
getCacheFilename(const ms_mascotresfilebase &resfile, const unsigned int flags, double minProbability=0.0, int maxHitsToReport=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE) | ms_peptidesummary | static
getCacheFilename(const ms_mascotresfilebase &resfile, const ms_mascotresults_params &parameters) | ms_peptidesummary | static
getComponentIntensity(const int q, const int p, const std::string &componentName, double &value, double &rawValue) const | ms_peptidesummary | virtual
getComponentProtein(const char *accession, const int dbIdx=1) const | ms_peptidesummary | virtual
getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_peptidesummary | virtual
getCreateSummaryProgress(int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const | ms_mascotresults |
getCrosslinkingMethod() const | ms_peptidesummary |
getDiscoveredErrTolModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | virtual
getDiscoveredErrTolModNames() const | ms_mascotresults | virtual
getDiscoveredLocalModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | virtual
getDiscoveredLocalModNames() const | ms_mascotresults | virtual
getErrTolModDelta(const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const | ms_mascotresults | virtual
getErrTolModifiedNaSeq(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModMasterNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModMasterString(const int q, const int p) const | ms_peptidesummary | virtual
getErrTolModName(const int q, const int p, std::string *modString=NULL) const | ms_mascotresults | virtual
getErrTolModNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModPepNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModPepString(const int q, const int p) const | ms_peptidesummary | virtual
getErrTolModReqPepNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModReqPepString(const int q, const int p) const | ms_peptidesummary | virtual
getErrTolModSlaveNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModSlaveString(const int q, const int p) const | ms_peptidesummary | virtual
getErrTolModString(const int q, const int p) const | ms_peptidesummary | virtual
getErrTolOriginalNaSeq(const int q, const int p) const | ms_mascotresults | virtual
getErrTolProbabilityThreshold() const | ms_mascotresults | virtual
getFlags() const | ms_mascotresults |
getFlags2() const | ms_mascotresults |
getHit(const int hit, const int memberNumber=0) const | ms_peptidesummary | virtual
getHomologyThreshold(const int query, double OneInXprobRnd, const int rank=1) const | ms_mascotresults | virtual
getHomologyThresholdForHistogram(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getIonsScore(const int q, const int p, const bool decoy) const | ms_peptidesummary | virtual
getIonsScoreCorrected(const double ionsScore, const long multiplicity) const | ms_mascotresults | protected
getIonsScoreHistogram(IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getLibraryEntryId(const int q, const int p, std::vector< int > &dbIdx, std::vector< int > &offset, std::vector< std::string > &checksum, std::vector< std::string > &mods) const | ms_peptidesummary |
getLibraryModString(const int q, const int p) const | ms_peptidesummary | virtual
getMaxPeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getMaxRankValue() const | ms_mascotresults | virtual
getMinPepLenInPepSummary() const | ms_mascotresults |
getMinProbabilityForSLScore(double score) | ms_peptidesummary | static
getNextFamilyProtein(const int masterHit, const int id) const | ms_mascotresults | virtual
getNextSimilarProtein(const int masterHit, const int id) const | ms_mascotresults | virtual
getNextSimilarProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | virtual
getNextSubsetProtein(const int masterHit, const int id, const bool searchWholeFamily=true) const | ms_mascotresults | virtual
getNextSubsetProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | virtual
getNumberOfAccessionDBTypes(int q, int p) const | ms_peptidesummary |
getNumberOfFamilyAccessionDBTypes(int hit, int q, int p, bool includeSamesets=true) const | ms_peptidesummary |
getNumberOfFamilyMembers() const | ms_mascotresults | virtual
getNumberOfHits() const | ms_mascotresults | virtual
getNumberOfUnassigned() const | ms_mascotresults |
getNumDecoyHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getNumDecoyHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getNumDiscoveredErrTolMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumDiscoveredFixedMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumDiscoveredIntactLinks(std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const | ms_mascotresults |
getNumDiscoveredLibraryMods(const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults |
getNumDiscoveredLocalMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumDiscoveredNonSpecCleavage() const | ms_mascotresults | virtual
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const | ms_mascotresults | virtual
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getNumHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getPepsWithSameScore(const int q, const int p) const | ms_peptidesummary | virtual
getPeptide(const int q, const int p) const | ms_peptidesummary | virtual
getPeptide(const int q, const int p, ms_peptide *&pep) const | ms_peptidesummary | virtual
getPeptideAmbiguityRanks(const int q, const int p) | ms_peptidesummary |
getPeptideExpectationValue(const double score, const int query, const int rank=0) const | ms_mascotresults | virtual
getPeptideIdentityThreshold(const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getPeptideThreshold(const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const | ms_mascotresults |
getProbabilityThreshold() const | ms_mascotresults | virtual
getProbFromScore(const double score) const | ms_mascotresults | virtual
getProbOfPepBeingRandomMatch(const double score, const int query) const | ms_mascotresults | virtual
getProbOfProteinBeingRandomMatch(const double score) const | ms_mascotresults | virtual
getProtein(const char *accession, const int dbIdx=1) const | ms_peptidesummary | virtual
getProteinDescription(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinEmPAI(const char *accession, const int dbIdx=1, const int length=-1) const | ms_peptidesummary | virtual
getProteinExpectationValue(const double score) const | ms_mascotresults | virtual
getProteinMass(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinScoreCutoff(double OneInXprobRnd) const | ms_peptidesummary | virtual
getProteinScoreForHistogram(const int num) const | ms_mascotresults | virtual
getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) | ms_peptidesummary | virtual
getProteinTaxonomyIDs(const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const | ms_mascotresults |
getProteinThreshold(double OneInXprobRnd) const | ms_mascotresults | virtual
getQmatch(const int query) const | ms_mascotresults | virtual
getQmatch(const int query, const ms_mascotresfile_dat::section sec) const | ms_mascotresults | virtual
getQuantitationComponentForPeptide(const ms_peptide &peptide, ms_quant_component &component, const ms_quant_method *method=NULL) const | ms_peptidesummary | virtual
getQuantMethod() const | ms_peptidesummary |
getQueryList(QL_FLAG flag, bool outputListOfQueries=true) | ms_peptidesummary |
getReadableVarMods(const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_mascotresults | virtual
getResfile() const | ms_mascotresults |
getResultsParameters() const | ms_mascotresults |
getSequenceMass(const char *seq) const | ms_mascotresults |
getSLThresholdFromMinProbability(double minProbability) | ms_peptidesummary | static
getSrcRank(int q, int p) const | ms_peptidesummary |
getSrcSection(int q, int p) const | ms_peptidesummary |
getTagDeltaRangeEnd(const int q, const int p) const | ms_peptidesummary | virtual
getTagDeltaRangeStart(const int q, const int p) const | ms_peptidesummary | virtual
getTagEnd(const int q, const int p, const int tagNumber) const | ms_mascotresults | virtual
getTagSeries(const int q, const int p, const int tagNumber) const | ms_mascotresults | virtual
getTagStart(const int q, const int p, const int tagNumber) const | ms_mascotresults | virtual
getTagString(const int q, const int p) const | ms_peptidesummary | virtual
getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_peptidesummary | virtual
getThresholdForFDRAboveHomology(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveHomology(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getToleranceInDalton(bool &needMass, const double *const pMass=NULL) const | ms_mascotresults |
getTreeClusterNodes(const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, ms_mascotresults::TREE_CLUSTER_METHOD tcm=ms_mascotresults::TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const | ms_peptidesummary | virtual
getUnassigned(const int num) const | ms_mascotresults |
getUnassignedIsBold(const int num) const | ms_mascotresults |
getUnassignedShowCheckbox(const int num) const | ms_mascotresults |
hasCrosslinkingMethod() const | ms_peptidesummary |
hasQuantMethod() const | ms_peptidesummary |
HOMOLOGY_THRESHOLD_SOURCE enum name | ms_mascotresults |
HOMTHR_FASTA enum value | ms_mascotresults |
HOMTHR_SL enum value | ms_mascotresults |
IH_INCLUDE_TOP_10_MATCHES enum value | ms_mascotresults |
IH_INCLUDE_TOP_MATCHES enum value | ms_mascotresults |
INTENSITY enum value | ms_mascotresults |
IONS_HISTOGRAM enum name | ms_mascotresults |
isDataCached(ms_peptidesummary::BUGFIX_NUM bugNum) const | ms_peptidesummary |
isEmPAIallowed() const | ms_mascotresults |
isNA() const | ms_mascotresults |
isPeptideComponentMatch(const ms_quant_component &component, const ms_peptide &peptide) const | ms_peptidesummary |
isPeptideModificationMatch(const ms_quant_modgroup &group, const ms_peptide &peptide) const | ms_peptidesummary |
isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const | ms_peptidesummary | virtual
mascotresfile() const | ms_peptidesummary |
ms_mascotresults() | ms_mascotresults |
ms_peptidesummary(const ms_mascotresfilebase &resfile, const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS, double minProbability=0.0, int maxHits=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE) | ms_peptidesummary |
ms_peptidesummary(const ms_mascotresfilebase &resfile, const ms_mascotresults_params &parameters) | ms_peptidesummary |
MSPEPSUM enum name | ms_peptidesummary |
MSPEPSUM_CACHE_IGNORE_DATE_CHANGE enum value | ms_peptidesummary |
MSPEPSUM_CROSSLINK_INTEGRATED enum value | ms_peptidesummary |
MSPEPSUM_CROSSLINK_ONLY enum value | ms_peptidesummary |
MSPEPSUM_DEFERRED_CREATE enum value | ms_peptidesummary |
MSPEPSUM_DISCARD_RELOADABLE enum value | ms_peptidesummary |
MSPEPSUM_NO_PROTEIN_GROUPING enum value | ms_peptidesummary |
MSPEPSUM_NONE enum value | ms_peptidesummary |
MSPEPSUM_PERCOLATOR enum value | ms_peptidesummary |
MSPEPSUM_REMOVE_CHIMERIC_DUPES enum value | ms_peptidesummary |
MSPEPSUM_SINGLE_HIT_DBIDX enum value | ms_peptidesummary |
MSPEPSUM_SL_INTEGRATED enum value | ms_peptidesummary |
MSPEPSUM_SL_ONLY enum value | ms_peptidesummary |
MSPEPSUM_USE_CACHE enum value | ms_peptidesummary |
MSPEPSUM_USE_HOMOLOGY_THRESH enum value | ms_peptidesummary |
MSRES_CLUSTER_PROTEINS enum value | ms_mascotresults |
MSRES_DECOY enum value | ms_mascotresults |
MSRES_DUPE_DEFAULT enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_A enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_B enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_C enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_D enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_E enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_F enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_G enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_H enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_I enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_NONE enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_A enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_B enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_C enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_D enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_E enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_F enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_G enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_H enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_I enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_NONE enum value | ms_mascotresults |
MSRES_ERR_TOL enum value | ms_mascotresults |
MSRES_GROUP_PROTEINS enum value | ms_mascotresults |
MSRES_IGNORE_PMF_MIXTURE enum value | ms_mascotresults |
MSRES_INTEGRATED_ERR_TOL enum value | ms_mascotresults |
MSRES_MAXHITS_OVERRIDES_MINPROB enum value | ms_mascotresults |
MSRES_MUDPIT_PROTEIN_SCORE enum value | ms_mascotresults |
MSRES_NOFLAG enum value | ms_mascotresults |
MSRES_REQUIRE_BOLD_RED enum value | ms_mascotresults |
MSRES_SHOW_ALL_FROM_ERR_TOL enum value | ms_mascotresults |
MSRES_SHOW_SUBSETS enum value | ms_mascotresults |
MSRES_SUBSETS_DIFF_PROT enum value | ms_mascotresults |
PEPSUMMARY_CACHE_BEING_CREATED enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_CAN_CREATE enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_FILE_NOT_PRESENT enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_NOT_FOR_PMF enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_VALID enum value | ms_peptidesummary |
QCS_ERROR_BAD_COMPONENT_NAME enum value | ms_mascotresults |
QCS_ERROR_NO_COMPONENTS enum value | ms_mascotresults |
QCS_ERROR_NO_METHOD enum value | ms_mascotresults |
QCS_OK enum value | ms_mascotresults |
QCS_OK_MULTIPLE_MATCHES enum value | ms_mascotresults |
QCS_OK_NO_MATCH enum value | ms_mascotresults |
QL_ALL enum value | ms_peptidesummary |
QL_BELOW_HOMOLOGY enum value | ms_peptidesummary |
QL_BELOW_IDENTITY enum value | ms_peptidesummary |
QL_FLAG enum name | ms_peptidesummary |
QL_IGNORE_IONS_SCORE_BELOW enum value | ms_peptidesummary |
QL_LAST enum value | ms_peptidesummary |
QL_UNASSIGNED enum value | ms_peptidesummary |
QUANT_COMPONENT_STATUS enum name | ms_mascotresults |
QUERY enum value | ms_mascotresults |
RESFILE_CACHE_BEING_CREATED enum value | ms_peptidesummary |
RESFILE_CACHE_CAN_CREATE enum value | ms_peptidesummary |
RESFILE_CACHE_DISABLED_IN_OPTIONS enum value | ms_peptidesummary |
RESFILE_CACHE_FILE_NOT_PRESENT enum value | ms_peptidesummary |
RESFILE_CACHE_VALID enum value | ms_peptidesummary |
SCORE enum value | ms_mascotresults |
setSubsetsThreshold(const double scoreFraction) | ms_mascotresults | virtual
sortBy enum name | ms_mascotresults |
TCM_PAIRWISE_AVERAGE enum value | ms_mascotresults |
TCM_PAIRWISE_MAXIMUM enum value | ms_mascotresults |
TCM_PAIRWISE_SINGLE enum value | ms_mascotresults |
THRESHOLD_TYPE enum name | ms_mascotresults |
TREE_CLUSTER_METHOD enum name | ms_mascotresults |
TT_HOMOLOGY enum value | ms_mascotresults |
TT_IDENTITY enum value | ms_mascotresults |
TT_PEPSUM_DEFAULT enum value | ms_mascotresults |
UNIQUE_PEP_RULES enum name | ms_mascotresults |
UPR_DEFAULT enum value | ms_mascotresults |
UPR_IGNORE_SUBSET_PROTEINS enum value | ms_mascotresults |
UPR_WITHIN_FAMILY enum value | ms_mascotresults |
UPR_WITHIN_FAMILY_MEMBER enum value | ms_mascotresults |
willCreateCache(const ms_mascotresfilebase &resfile, const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS, double minProbability=0.0, int maxHits=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE) | ms_peptidesummary | static
willCreateCache(const ms_mascotresfilebase &resfile, const ms_mascotresults_params &parameters) | ms_peptidesummary | static
willCreateCache(const char *resultsFileName, const ms_mascotoptions &opts, const char *unigeneIndexFile, const char *singleHit, const char *applicationName, std::string &resfileCacheFileName, std::string &peptideSummaryCacheFileName, unsigned int &cacheStatus) | ms_peptidesummary | static
willCreateCache(const ms_mascotresfilebase &resfile, const ms_mascotresults_params &parameters, const ms_mascotoptions &opts, std::string &peptideSummaryCacheFileName, unsigned int &cacheStatus) | ms_peptidesummary | static
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_processoroptions
ms_processoroptions Member List

This is the complete list of members for ms_processoroptions, including all inherited members.

appendDatabase(const ms_dbprocessors *db) | ms_processoroptions
appendProcessor(const int processorID) | ms_processoroptions
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
clearDatabases() | ms_processoroptions
clearProcessors() | ms_processoroptions
copyFrom(const ms_processoroptions *right) | ms_processoroptions
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_processoroptions
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getDatabase(const int index) const | ms_processoroptions
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getNumberOfDatabases() const | ms_processoroptions
getNumberOfProcessors() const | ms_processoroptions
getNumberOfProperties() const | ms_customproperty
getPreceedingComments() const | ms_customproperty
getProcessor(const int index) const | ms_processoroptions
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
isSectionAvailable() const | ms_processoroptions
ms_customproperty() | ms_customproperty
ms_processoroptions() | ms_processoroptions
ms_processoroptions(const ms_processoroptions &src) | ms_processoroptions
operator=(const ms_processoroptions &right) | ms_processoroptions
setDefaultDelimiter(const char *delim) | ms_customproperty
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setSectionAvailable(const bool value) | ms_processoroptions
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
~ms_processoroptions() | ms_processoroptions
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_processors
ms_processors Member List

This is the complete list of members for ms_processors, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_processors *right) | ms_processors
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
DEPRECATED_MAX_CORES_PER_LICENSE enum value | ms_processors
getAutoDetectNumThreads(const int numLicensed, const int numCoresPerCpuLicense) const | ms_processors
getCoreFromLogical(const int cpu) const | ms_processors
getErrorHandler() const | ms_errors
getHT_IDFromLogical(const int cpu) const | ms_processors
getHyperThreadedCPUsMask() const | ms_processors
getHyperThreadingState() const | ms_processors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getMultithreadedName() const | ms_processors
getNumAvailableToProcess() const | ms_processors
getNumCores(const int packageID=-1) const | ms_processors
getNumLogicalPerPhysical(const int packageID=0) const | ms_processors
getNumOnSystem() const | ms_processors
getNumPhysicalOnSystem() const | ms_processors
getNumProcessorGroups() const | ms_processors
getPhysicalFromLogical(const int cpu) const | ms_processors
getProcessorName() const | ms_processors
getWhichAvailableForMascot() const | ms_processors
getWhichAvailableForMascot2() const | ms_processors
HT_CANNOT_DETECT enum value | ms_processors
HT_DISABLED enum value | ms_processors
HT_ENABLED enum value | ms_processors
HT_NOT_CAPABLE enum value | ms_processors
HT_SUPPORTED_NOT_ENABLED enum value | ms_processors
HYPERTHREADING enum name | ms_processors
isLogicalCPUAvailableForMascot(const int cpu) const | ms_processors
isPrimaryLogicalProcessor(const int cpu) const | ms_processors
isProcessAffinitySupported() const | ms_processors
isThreadedLogicalProcessor(const int cpu) const | ms_processors
isUseProcessesNotThreads() const | ms_processors
isValid() const | ms_errors
ms_errors() | ms_errors
ms_processors(bool checkLinuxHT, int unused) | ms_processors
ms_processors(const ms_processors &src) | ms_processors
operator=(const ms_processors &right) | ms_processors
~ms_errors() | ms_errors
~ms_processors() | ms_processors
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_progress_info
ms_progress_info Member List

This is the complete list of members for ms_progress_info, including all inherited members.

addSubtask(const std::string &description, size_t total) | ms_progress_info
addSubtask(const ms_progress_info *task) | ms_progress_info
clear(const std::string &description="", size_t total=0) | ms_progress_info
getDescription() const | ms_progress_info
getNumberOfSubtasks() const | ms_progress_info
getProgress() const | ms_progress_info
getStatus() const | ms_progress_info
getSubtaskProgress(int index) const | ms_progress_info
getTotal() const | ms_progress_info
isBreaking() const | ms_progress_info
ms_progress_info() | ms_progress_info
ms_progress_info(const std::string &description, size_t total) | ms_progress_info
removeSubtask(int index) | ms_progress_info
S_NOT_STARTED enum value | ms_progress_info
S_RUNNING enum value | ms_progress_info
S_RUNNING_INDETERMINATE enum value | ms_progress_info
S_STOPPED_BREAK enum value | ms_progress_info
S_STOPPED_COMPLETE enum value | ms_progress_info
S_STOPPED_FAIL enum value | ms_progress_info
setBreak() const | ms_progress_info
STATUS enum name | ms_progress_info
updateBreak() | ms_progress_info
updateComplete() | ms_progress_info
updateFail() | ms_progress_info
updateIndeterminate() | ms_progress_info
updateProgress(size_t progress, size_t total) | ms_progress_info
~ms_progress_info() | ms_progress_info
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_protein
ms_protein Member List

This is the complete list of members for ms_protein, including all inherited members.

anyBoldRedPeptides(const ms_mascotresults &results) const | ms_protein |
anyMatchToQuery(const int query) const | ms_protein |
anyMatchToQueryAndP(const int query, const int P) const | ms_protein |
copyFrom(const ms_protein *src) | ms_protein |
DISTINCT_PEPTIDE_FLAGS enum name | ms_protein |
DPF_CHARGE enum value | ms_protein |
DPF_MODS enum value | ms_protein |
DPF_NODUPSAMEQUERY enum value | ms_protein |
DPF_SEQUENCE enum value | ms_protein |
DPF_UNIQUE enum value | ms_protein |
DUPE_Duplicate enum value | ms_protein |
DUPE_DuplicateSameQuery enum value | ms_protein |
DUPE_HighestScoringDuplicate enum value | ms_protein |
DUPE_Ignored enum value | ms_protein |
DUPE_NotDuplicate enum value | ms_protein |
DUPLICATE enum name | ms_protein |
getAccession() const | ms_protein |
getComponent(const int componentNumber) const | ms_protein |
getCoverage() const | ms_protein |
getDB() const | ms_protein |
getDistinctPeptide(int distinctIndex, int repeatIndex=1, bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const | ms_protein |
getFrame() const | ms_protein |
getGrouping() const | ms_protein |
getHitNumber() const | ms_protein |
getIgnoredQPs(std::vector< int > &q, std::vector< int > &p) const | ms_protein |
getLongestPeptideLen() const | ms_protein |
getLongestSigPeptideLen() const | ms_protein |
getMasses(ms_mascotresfilebase &resfile, const ms_proteinsummary &summary, const unsigned int flags=MASS_SELECT_MATCH, const int numDecimalPlaces=2) const | ms_protein |
getMemberNumber() const | ms_protein |
getNonMudpitScore() const | ms_protein |
getNumComponents() const | ms_protein |
getNumDisplayPeptides(bool aboveThreshold=false) const | ms_protein |
getNumDistinctPeptideRepeats(int distinctIndex, bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const | ms_protein |
getNumDistinctPeptides(bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const | ms_protein |
getNumObservedForEmPAI() const | ms_protein |
getNumPeptides() const | ms_protein |
getPepNumber(const int q, const int p) const | ms_protein |
getPeptideComponentID(const int pepNumber) const | ms_protein |
getPeptideDuplicate(const int pepNumber, const bool allowErrTolDuplicate=true) const | ms_protein |
getPeptideEnd(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getPeptideFrame(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getPeptideIonsScore(const int pepNumber) const | ms_protein |
getPeptideIsBold(const int pepNumber) const | ms_protein |
getPeptideMultiplicity(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getPeptideP(const int pepNumber) const | ms_protein |
getPeptideQuery(const int pepNumber) const | ms_protein |
getPeptideResidueAfter(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getPeptideResidueBefore(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getPeptideShowCheckbox(const int pepNumber) const | ms_protein |
getPeptideStart(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getProteinId() const | ms_protein |
getProteinSummaryHit() const | ms_protein |
getRMSDeltas(const ms_mascotresults &results) const | ms_protein |
getScore() const | ms_protein |
getScoreWithET() const | ms_protein |
getSimilarProteinDB() const | ms_protein |
getSimilarProteinName() const | ms_protein |
getSimilarProteins(std::vector< std::string > &accessions, std::vector< int > &dbIdxs) const | ms_protein |
getUnmatchedMasses(ms_mascotresfilebase &resfile, const int numDecimalPlaces=2) const | ms_protein |
GROUP enum name | ms_protein |
GROUP_COMPLETE enum value | ms_protein |
GROUP_FAMILY enum value | ms_protein |
GROUP_NO enum value | ms_protein |
GROUP_SUBSET enum value | ms_protein |
GROUP_UNKNOWN enum value | ms_protein |
isASimilarProtein(const ms_protein *prot, const ms_mascotresults *results, const bool groupByQueryNumber=false) | ms_protein |
isPMFMixture() const | ms_protein |
isSimilarProtein(const std::string &acc, const int dbIdx) const | ms_protein |
isUnigene() const | ms_protein |
isUpdateScoreFromPepScores() const | ms_protein |
MASS_FLAGS enum name | ms_protein |
MASS_NON_SELECT_MATCH enum value | ms_protein |
MASS_NON_SELECT_NON_MATCH enum value | ms_protein |
MASS_SELECT_MATCH enum value | ms_protein |
MASS_SELECT_NON_MATCH enum value | ms_protein |
ms_protein(const double score, const std::string accession, const bool updateScoreFromPepScores, const int proteinSummaryHit=0) | ms_protein |
ms_protein(const ms_protein &src) | ms_protein |
operator< | ms_protein | friend
operator=(const ms_protein &right) | ms_protein |
setDB(int dbIdx) | ms_protein |
setPeptideIsBold(const int pepNumber) | ms_protein |
setPeptideShowCheckbox(const int pepNumber) | ms_protein |
setProteinId(int64_t proteinId) | ms_protein |
sortPeptides(const ms_mascotresults &results, bool keepAlive=false, int keepAlivePercent=0, const char *keepAliveAccession="", int keepAliveCount=0) | ms_protein |
~ms_protein() | ms_protein |
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_protein_quant_ratio
ms_protein_quant_ratio Member List

This is the complete list of members for ms_protein_quant_ratio, including all inherited members.

copyFrom(const ms_protein_quant_ratio *src) | ms_protein_quant_ratio
getAccession() const | ms_protein_quant_ratio
getActiveKeys() const | ms_protein_quant_ratio
getDB() const | ms_protein_quant_ratio
getExcludedKeys() const | ms_protein_quant_ratio
getHypothesisPvalue() const | ms_protein_quant_ratio
getHypothesisPvalue(std::string &whyUnavailable) const | ms_protein_quant_ratio
getNormalityPvalue() const | ms_protein_quant_ratio
getNormalityPvalue(std::string &whyUnavailable) const | ms_protein_quant_ratio
getOutlierKeys() const | ms_protein_quant_ratio
getRatioName() const | ms_protein_quant_ratio
getSampleSize() const | ms_protein_quant_ratio
getSkippedKeys() const | ms_protein_quant_ratio
getStandardDeviation() const | ms_protein_quant_ratio
getStandardDeviation(std::string &whyUnavailable) const | ms_protein_quant_ratio
getStandardError() const | ms_protein_quant_ratio
getStandardError(std::string &whyUnavailable) const | ms_protein_quant_ratio
getValue() const | ms_protein_quant_ratio
isLogNormal(double threshold=0.05) const | ms_protein_quant_ratio
isMissing() const | ms_protein_quant_ratio
isSignificant(double threshold=0.05) const | ms_protein_quant_ratio
ms_protein_quant_ratio(const std::string &accession, int dbIdx, const std::string &ratioName) | ms_protein_quant_ratio
ms_protein_quant_ratio(const std::string &accession, int dbIdx, const std::string &ratioName, double value, double stdev, double stderror, double hypothesisPvalue, double normalityPvalue, unsigned int sampleSize) | ms_protein_quant_ratio
ms_protein_quant_ratio(const ms_protein_quant_ratio &src) | ms_protein_quant_ratio
operator!=(const ms_protein_quant_ratio &right) const | ms_protein_quant_ratio
operator=(const ms_protein_quant_ratio &right) | ms_protein_quant_ratio
operator==(const ms_protein_quant_ratio &right) const | ms_protein_quant_ratio
~ms_protein_quant_ratio() | ms_protein_quant_ratio
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_proteinsummary
ms_proteinsummary Member List

This is the complete list of members for ms_proteinsummary, including all inherited members.

anyEmPAI() const | ms_mascotresults | virtual
anyNumDiscoveredMods() const | ms_mascotresults | virtual
cancelCreateSummary(bool newValue=true) | ms_mascotresults |
createSummary() | ms_mascotresults | virtual
createUnassignedList(sortBy s=QUERY) | ms_mascotresults |
DB_MATCH_TYPE enum name | ms_mascotresults |
DECOY_STATS_COUNT_TYPE enum name | ms_mascotresults |
DM_BOTH enum value | ms_mascotresults |
DM_FASTA enum value | ms_mascotresults |
DM_FASTA_FIRST_PASS enum value | ms_mascotresults |
DM_FASTA_SECOND_PASS enum value | ms_mascotresults |
DM_SPECTRAL_LIBRARY enum value | ms_mascotresults |
DS_COUNT_PSM enum value | ms_mascotresults |
DS_COUNT_SEQUENCE enum value | ms_mascotresults |
FC_ALL_PEPTIDES enum value | ms_mascotresults |
FC_ALL_PEPTITDES enum value | ms_mascotresults |
FC_CASE_INSENSITIVE enum value | ms_mascotresults |
FC_CASE_SENSITIVE enum value | ms_mascotresults |
FC_COMPLETESTR enum value | ms_mascotresults |
FC_FORWARD enum value | ms_mascotresults |
FC_LOOP_FROM_UNASSIGNED enum value | ms_mascotresults |
FC_LOOP_INTO_UNASSIGNED enum value | ms_mascotresults |
FC_MASK_CASE enum value | ms_mascotresults |
FC_MASK_DIRECTION enum value | ms_mascotresults |
FC_MASK_STR_PART enum value | ms_mascotresults |
FC_PROTEIN_IGN_FAMILY enum value | ms_mascotresults |
FC_PROTEIN_IGN_MASK enum value | ms_mascotresults |
FC_PROTEIN_IGN_SAMESETS enum value | ms_mascotresults |
FC_PROTEIN_IGN_SUBSETS enum value | ms_mascotresults |
FC_PROTEIN_INC_ALT_ACC enum value | ms_mascotresults |
FC_RESTRICT_TO_HIT enum value | ms_mascotresults |
FC_REVERSE enum value | ms_mascotresults |
FC_SCORING_MASK enum value | ms_mascotresults |
FC_SEARCH_ALL_RANKS enum value | ms_mascotresults |
FC_SEARCH_IGNORED_RANKS enum value | ms_mascotresults |
FC_SIGNIFICANT_PEPTIDES enum value | ms_mascotresults |
FC_STARTSTR enum value | ms_mascotresults |
FC_STRTOK enum value | ms_mascotresults |
FC_SUBSTR enum value | ms_mascotresults |
FC_UNASSIGNED_MASK enum value | ms_mascotresults |
FIND_COMPARE_FLAGS enum name | ms_mascotresults |
FIND_FLAGS enum name | ms_mascotresults |
findPeptides(const int startHit, const std::string &str, ms_mascotresults::FIND_FLAGS item, ms_mascotresults::FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const | ms_proteinsummary | protectedvirtual
findProteins(const int startHit, const std::string &str, const int dbIdx, ms_mascotresults::FIND_FLAGS item, ms_mascotresults::FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_proteinsummary | protectedvirtual
findProteinsByAccession(const int startHit, const std::string &str, const int dbIdx, ms_mascotresults::FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_proteinsummary | protectedvirtual
findProteinsByDescription(const int startHit, const std::string &str, ms_mascotresults::FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_proteinsummary | protectedvirtual
FLAGS enum name | ms_mascotresults |
freeHit(const int hit) | ms_mascotresults | virtual
FT_PEPTIDE_CALC_MR enum value | ms_mascotresults |
FT_PEPTIDE_CALC_MZ enum value | ms_mascotresults |
FT_PEPTIDE_ETMOD enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MR enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MZ enum value | ms_mascotresults |
FT_PEPTIDE_FIND_MASK enum value | ms_mascotresults |
FT_PEPTIDE_FIXMOD enum value | ms_mascotresults |
FT_PEPTIDE_QUERY enum value | ms_mascotresults |
FT_PEPTIDE_SLMOD enum value | ms_mascotresults |
FT_PEPTIDE_STRING enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD_BYNAME enum value | ms_mascotresults |
FT_PROTEIN_ACCESSION enum value | ms_mascotresults |
FT_PROTEIN_DESCRIPTION enum value | ms_mascotresults |
getAllFamilyMembersWithThisPepMatch(const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const | ms_proteinsummary | virtual
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const | ms_proteinsummary | virtual
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const | ms_proteinsummary | virtual
getAvePeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getComponentIntensity(const int q, const int p, const std::string &componentName, double &value, double &rawValue) const | ms_proteinsummary | virtual
getComponentProtein(const char *accession, const int dbIdx=1) const | ms_mascotresults | virtual
getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_proteinsummary | virtual
getCreateSummaryProgress(int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const | ms_mascotresults |
getDiscoveredErrTolModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | virtual
getDiscoveredErrTolModNames() const | ms_mascotresults | virtual
getDiscoveredLocalModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | virtual
getDiscoveredLocalModNames() const | ms_mascotresults | virtual
getErrTolModDelta(const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const | ms_mascotresults | virtual
getErrTolModifiedNaSeq(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModMasterNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModMasterString(const int q, const int p) const | ms_proteinsummary | virtual
getErrTolModName(const int q, const int p, std::string *modString=NULL) const | ms_mascotresults | virtual
getErrTolModNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModPepNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModPepString(const int q, const int p) const | ms_proteinsummary | virtual
getErrTolModReqPepNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModReqPepString(const int q, const int p) const | ms_proteinsummary | virtual
getErrTolModSlaveNeutralLoss(const int q, const int p) const | ms_mascotresults | virtual
getErrTolModSlaveString(const int q, const int p) const | ms_proteinsummary | virtual
getErrTolModString(const int q, const int p) const | ms_proteinsummary | virtual
getErrTolOriginalNaSeq(const int q, const int p) const | ms_mascotresults | virtual
getErrTolProbabilityThreshold() const | ms_mascotresults | virtual
getFlags() const | ms_mascotresults |
getFlags2() const | ms_mascotresults |
getHit(const int hit, const int memberNumber=0) const | ms_mascotresults | virtual
getHomologyThreshold(const int query, double OneInXprobRnd, const int rank=1) const | ms_mascotresults | virtual
getHomologyThresholdForHistogram(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getIonsScore(const int q, const int p, const bool decoy) const | ms_proteinsummary | virtual
getIonsScoreCorrected(const double ionsScore, const long multiplicity) const | ms_mascotresults | protected
getIonsScoreHistogram(IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getLibraryModString(const int q, const int p) const | ms_proteinsummary | virtual
getMaxPeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getMaxRankValue() const | ms_mascotresults | virtual
getMinPepLenInPepSummary() const | ms_mascotresults |
getNextFamilyProtein(const int masterHit, const int id) const | ms_mascotresults | virtual
getNextSimilarProtein(const int masterHit, const int id) const | ms_mascotresults | virtual
getNextSimilarProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | virtual
getNextSubsetProtein(const int masterHit, const int id, const bool searchWholeFamily=true) const | ms_mascotresults | virtual
getNextSubsetProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | virtual
getNumberOfFamilyMembers() const | ms_mascotresults | virtual
getNumberOfHits() const | ms_mascotresults | virtual
getNumberOfUnassigned() const | ms_mascotresults |
getNumDecoyHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getNumDecoyHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getNumDiscoveredErrTolMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumDiscoveredFixedMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumDiscoveredIntactLinks(std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const | ms_mascotresults |
getNumDiscoveredLibraryMods(const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults |
getNumDiscoveredLocalMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumDiscoveredNonSpecCleavage() const | ms_mascotresults | virtual
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const | ms_mascotresults | virtual
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | virtual
getNumHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getNumHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | virtual
getNumPmfQueriesUsed() const | ms_proteinsummary |
getPepsWithSameScore(const int q, const int p) const | ms_proteinsummary | virtual
getPeptide(const int q, const int p) const | ms_proteinsummary | virtual
getPeptide(const int q, const int p, ms_peptide *&pep) const | ms_proteinsummary | virtual
getPeptideExpectationValue(const double score, const int query, const int rank=0) const | ms_mascotresults | virtual
getPeptideIdentityThreshold(const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | virtual
getPeptideThreshold(const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const | ms_mascotresults |
getProbabilityThreshold() const | ms_mascotresults | virtual
getProbFromScore(const double score) const | ms_mascotresults | virtual
getProbOfPepBeingRandomMatch(const double score, const int query) const | ms_mascotresults | virtual
getProbOfProteinBeingRandomMatch(const double score) const | ms_mascotresults | virtual
getProtein(const char *accession, const int dbIdx=1) const | ms_mascotresults | virtual
getProteinDescription(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinEmPAI(const char *accession, const int dbIdx=1, const int length=-1) const | ms_mascotresults | virtual
getProteinExpectationValue(const double score) const | ms_mascotresults | virtual
getProteinMass(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinScoreCutoff(double OneInXprobRnd) const | ms_proteinsummary | virtual
getProteinScoreForHistogram(const int num) const | ms_mascotresults | virtual
getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) | ms_proteinsummary | virtual
getProteinTaxonomyIDs(const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const | ms_mascotresults |
getProteinThreshold(double OneInXprobRnd) const | ms_mascotresults | virtual
getQmatch(const int query) const | ms_mascotresults | virtual
getQmatch(const int query, const ms_mascotresfile_dat::section sec) const | ms_mascotresults | virtual
getQuantitationComponentForPeptide(const matrix_science::ms_peptide &peptide, matrix_science::ms_quant_component &component, const matrix_science::ms_quant_method *method=NULL) const | ms_proteinsummary | virtual
getReadableVarMods(const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_mascotresults | virtual
getResfile() const | ms_mascotresults |
getResultsParameters() const | ms_mascotresults |
getSequenceMass(const char *seq) const | ms_mascotresults |
getTagDeltaRangeEnd(const int q, const int p) const | ms_proteinsummary | virtual
getTagDeltaRangeStart(const int q, const int p) const | ms_proteinsummary | virtual
getTagEnd(const int q, const int p, const int tagNumber) const | ms_mascotresults | virtual
getTagSeries(const int q, const int p, const int tagNumber) const | ms_mascotresults | virtual
getTagStart(const int q, const int p, const int tagNumber) const | ms_mascotresults | virtual
getTagString(const int q, const int p) const | ms_proteinsummary | virtual
getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_proteinsummary | virtual
getThresholdForFDRAboveHomology(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveHomology(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getToleranceInDalton(bool &needMass, const double *const pMass=NULL) const | ms_mascotresults |
getTreeClusterNodes(const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, TREE_CLUSTER_METHOD tcm=TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const | ms_mascotresults | virtual
getUnassigned(const int num) const | ms_mascotresults |
getUnassignedIsBold(const int num) const | ms_mascotresults |
getUnassignedShowCheckbox(const int num) const | ms_mascotresults |
HOMOLOGY_THRESHOLD_SOURCE enum name | ms_mascotresults |
HOMTHR_FASTA enum value | ms_mascotresults |
HOMTHR_SL enum value | ms_mascotresults |
IH_INCLUDE_TOP_10_MATCHES enum value | ms_mascotresults |
IH_INCLUDE_TOP_MATCHES enum value | ms_mascotresults |
INTENSITY enum value | ms_mascotresults |
IONS_HISTOGRAM enum name | ms_mascotresults |
isEmPAIallowed() const | ms_mascotresults |
isNA() const | ms_mascotresults |
isPeptideUnique(const int q, const int p, const ms_mascotresults::UNIQUE_PEP_RULES rules=ms_mascotresults::UPR_DEFAULT) const | ms_proteinsummary | virtual
isPmfQueryUsed(const int queryIdx) const | ms_proteinsummary |
ms_mascotresults() | ms_mascotresults |
ms_proteinsummary(const ms_mascotresfilebase &resfile, const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS|ms_mascotresults::MSRES_SHOW_SUBSETS, double minProbability=0.0, int maxHitsToReport=50, const char *unigeneIndexFile=0, const char *singleHit=0) | ms_proteinsummary |
ms_proteinsummary(const ms_mascotresfilebase &resfile, const ms_mascotresults_params &parameters) | ms_proteinsummary |
MSRES_CLUSTER_PROTEINS enum value | ms_mascotresults |
MSRES_DECOY enum value | ms_mascotresults |
MSRES_DUPE_DEFAULT enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_A enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_B enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_C enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_D enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_E enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_F enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_G enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_H enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_I enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_NONE enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_A enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_B enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_C enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_D enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_E enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_F enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_G enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_H enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_I enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_NONE enum value | ms_mascotresults |
MSRES_ERR_TOL enum value | ms_mascotresults |
MSRES_GROUP_PROTEINS enum value | ms_mascotresults |
MSRES_IGNORE_PMF_MIXTURE enum value | ms_mascotresults |
MSRES_INTEGRATED_ERR_TOL enum value | ms_mascotresults |
MSRES_MAXHITS_OVERRIDES_MINPROB enum value | ms_mascotresults |
MSRES_MUDPIT_PROTEIN_SCORE enum value | ms_mascotresults |
MSRES_NOFLAG enum value | ms_mascotresults |
MSRES_REQUIRE_BOLD_RED enum value | ms_mascotresults |
MSRES_SHOW_ALL_FROM_ERR_TOL enum value | ms_mascotresults |
MSRES_SHOW_SUBSETS enum value | ms_mascotresults |
MSRES_SUBSETS_DIFF_PROT enum value | ms_mascotresults |
QCS_ERROR_BAD_COMPONENT_NAME enum value | ms_mascotresults |
QCS_ERROR_NO_COMPONENTS enum value | ms_mascotresults |
QCS_ERROR_NO_METHOD enum value | ms_mascotresults |
QCS_OK enum value | ms_mascotresults |
QCS_OK_MULTIPLE_MATCHES enum value | ms_mascotresults |
QCS_OK_NO_MATCH enum value | ms_mascotresults |
QUANT_COMPONENT_STATUS enum name | ms_mascotresults |
QUERY enum value | ms_mascotresults |
SCORE enum value | ms_mascotresults |
setSubsetsThreshold(const double scoreFraction) | ms_mascotresults | virtual
sortBy enum name | ms_mascotresults |
TCM_PAIRWISE_AVERAGE enum value | ms_mascotresults |
TCM_PAIRWISE_MAXIMUM enum value | ms_mascotresults |
TCM_PAIRWISE_SINGLE enum value | ms_mascotresults |
THRESHOLD_TYPE enum name | ms_mascotresults |
TREE_CLUSTER_METHOD enum name | ms_mascotresults |
TT_HOMOLOGY enum value | ms_mascotresults |
TT_IDENTITY enum value | ms_mascotresults |
TT_PEPSUM_DEFAULT enum value | ms_mascotresults |
UNIQUE_PEP_RULES enum name | ms_mascotresults |
UPR_DEFAULT enum value | ms_mascotresults |
UPR_IGNORE_SUBSET_PROTEINS enum value | ms_mascotresults |
UPR_WITHIN_FAMILY enum value | ms_mascotresults |
UPR_WITHIN_FAMILY_MEMBER enum value | ms_mascotresults |
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_average
ms_quant_average Member List

This is the complete list of members for ms_quant_average, including all inherited members.

appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | virtual
copyFrom(const ms_quant_average *right) | ms_quant_average |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_average |
deleteParameterByName(const char *name) | ms_quant_parameters | virtual
deleteParameterByNumber(const int idx) | ms_quant_parameters | virtual
dropNumPeptides() | ms_quant_average |
dropReferenceAccession() | ms_quant_average |
dropReferenceAmount() | ms_quant_average |
dropReferenceDatabase() | ms_quant_average |
dropSelection() | ms_quant_average |
getNumberOfParameters() const | ms_quant_parameters | virtual
getNumPeptides() const | ms_quant_average |
getNumPeptidesSchemaType() const | ms_quant_average |
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | virtual
getReferenceAccession() const | ms_quant_average |
getReferenceAccessionSchemaType() const | ms_quant_average |
getReferenceAmount() const | ms_quant_average |
getReferenceAmountSchemaType() const | ms_quant_average |
getReferenceDatabase() const | ms_quant_average |
getReferenceDatabaseSchemaType() const | ms_quant_average |
getSchemaType() const | ms_quant_average | virtual
getSelection() const | ms_quant_average |
getSelectionSchemaType() const | ms_quant_average |
haveNumPeptides() const | ms_quant_average |
haveReferenceAccession() const | ms_quant_average |
haveReferenceAmount() const | ms_quant_average |
haveReferenceDatabase() const | ms_quant_average |
haveSelection() const | ms_quant_average |
ms_quant_average() | ms_quant_average |
ms_quant_average(const ms_quant_average &src) | ms_quant_average |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_average &right) | ms_quant_average |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setNumPeptides(int value) | ms_quant_average |
setReferenceAccession(const char *value) | ms_quant_average |
setReferenceAmount(const char *value) | ms_quant_average |
setReferenceDatabase(const char *value) | ms_quant_average |
setSelection(const char *value) | ms_quant_average |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_average | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_average | virtual
~ms_quant_average() | ms_quant_average | virtual
~ms_quant_parameters() | ms_quant_parameters | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_component
ms_quant_component Member List

This is the complete list of members for ms_quant_component, including all inherited members.

appendCorrection(const ms_quant_correction *correction) | ms_quant_component |
appendFileIndex(const ms_quant_file_index *file_index) | ms_quant_component |
appendIsotope(const ms_quant_isotope *isotope) | ms_quant_component |
appendModificationGroup(const ms_quant_modgroup *item) | ms_quant_component |
clearCorrections() | ms_quant_component |
clearFileIndexes() | ms_quant_component |
clearIsotopes() | ms_quant_component |
clearModificationGroups() | ms_quant_component |
copyFrom(const ms_quant_component *right) | ms_quant_component |
defaultValues() | ms_quant_component |
deleteCorrection(const int idx) | ms_quant_component |
deleteFileIndex(const int idx) | ms_quant_component |
deleteIsotope(const int idx) | ms_quant_component |
deleteModificationGroupByName(const char *name) | ms_quant_component |
deleteModificationGroupByNumber(const int idx) | ms_quant_component |
dropFileIndex() | ms_quant_component |
dropMoverz() | ms_quant_component |
dropName() | ms_quant_component |
dropSatellite() | ms_quant_component |
getCorrection(const int idx) const | ms_quant_component |
getCorrectionSchemaType() const | ms_quant_component |
getFileIndex() const | ms_quant_component |
getFileIndex(const int idx) const | ms_quant_component |
getFileIndexSchemaType() const | ms_quant_component |
getIsotope(const int idx) const | ms_quant_component |
getIsotopeSchemaType() const | ms_quant_component |
getModificationGroupByName(const char *name) const | ms_quant_component |
getModificationGroupByNumber(const int idx) const | ms_quant_component |
getModificationGroupSchemaType() const | ms_quant_component |
getMoverz() const | ms_quant_component |
getMoverzSchemaType() const | ms_quant_component |
getName() const | ms_quant_component |
getNameSchemaType() const | ms_quant_component |
getNumberOfCorrections() const | ms_quant_component |
getNumberOfFileIndexes() const | ms_quant_component |
getNumberOfIsotopes() const | ms_quant_component |
getNumberOfModificationGroups() const | ms_quant_component |
getSatellite() const | ms_quant_component |
getSatelliteSchemaType() const | ms_quant_component |
getSchemaType() const | ms_quant_component | virtual
haveFileIndex() const | ms_quant_component |
haveMoverz() const | ms_quant_component |
haveName() const | ms_quant_component |
haveSatellite() const | ms_quant_component |
ms_quant_component() | ms_quant_component |
ms_quant_component(const ms_quant_component &src) | ms_quant_component |
operator=(const ms_quant_component &right) | ms_quant_component |
setFileIndex(const int file_index) | ms_quant_component |
setMoverz(const ms_quant_moverz *moverz) | ms_quant_component |
setName(const char *value) | ms_quant_component |
setSatellite(const ms_quant_satellite *satellite) | ms_quant_component |
updateCorrection(const int idx, const ms_quant_correction *isotope) | ms_quant_component |
updateFileIndex(const int idx, const ms_quant_file_index *file_index) | ms_quant_component |
updateIsotope(const int idx, const ms_quant_isotope *isotope) | ms_quant_component |
updateModificationGroupByName(const char *name, const ms_quant_modgroup *modgroup) | ms_quant_component |
updateModificationGroupByNumber(const int idx, const ms_quant_modgroup *modgroup) | ms_quant_component |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_component | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_component | virtual
~ms_quant_component() | ms_quant_component | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_composition
ms_quant_composition Member List

This is the complete list of members for ms_quant_composition, including all inherited members.

appendElement(const ms_quant_element *element) | ms_quant_composition |
clearElements() | ms_quant_composition |
copyFrom(const ms_quant_composition *right) | ms_quant_composition |
defaultValues() | ms_quant_composition |
deleteElement(const int idx) | ms_quant_composition |
getElement(const int idx) const | ms_quant_composition |
getElementSchemaType() const | ms_quant_composition |
getNumberOfElements() const | ms_quant_composition |
getSchemaType() const | ms_quant_composition | virtual
ms_quant_composition() | ms_quant_composition |
ms_quant_composition(const ms_quant_composition &src) | ms_quant_composition |
operator=(const ms_quant_composition &right) | ms_quant_composition |
updateElement(const int idx, const ms_quant_element *element) | ms_quant_composition |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_composition | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_composition | virtual
~ms_quant_composition() | ms_quant_composition | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_configfile
ms_quant_configfile Member List

This is the complete list of members for ms_quant_configfile, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
appendMethod(const ms_quant_method *item) | ms_quant_configfile
clearAllErrors() | ms_errors
clearMethods() | ms_quant_configfile
copyFrom(const ms_quant_configfile *right) | ms_quant_configfile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_quant_configfile
deleteMethodByName(const char *name) | ms_quant_configfile
deleteMethodByNumber(const int idx) | ms_quant_configfile
getConnectionSettings() const | ms_quant_configfile
getErrorHandler() const | ms_errors
getFileName() const | ms_quant_configfile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getMajorVersion() const | ms_quant_configfile
getMethodByName(const char *name) const | ms_quant_configfile
getMethodByNumber(const int idx) const | ms_quant_configfile
getMinorVersion() const | ms_quant_configfile
getNumberOfMethods() const | ms_quant_configfile
getSchemaDirectory() const | ms_quant_configfile
getSchemaFileName() const | ms_quant_configfile
isValid() const | ms_errors
ms_errors() | ms_errors
ms_quant_configfile() | ms_quant_configfile
ms_quant_configfile(const ms_quant_configfile &src) | ms_quant_configfile
ms_quant_configfile(const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0) | ms_quant_configfile
operator=(const ms_quant_configfile &right) | ms_quant_configfile
read_buffer(const char *buffer) | ms_quant_configfile
read_file() | ms_quant_configfile
save_buffer() | ms_quant_configfile
save_file() | ms_quant_configfile
setConnectionSettings(const ms_connection_settings &cs) | ms_quant_configfile
setFileName(const char *name) | ms_quant_configfile
setSchemaDirectory(const char *dir) | ms_quant_configfile
setSchemaFileName(const char *name) | ms_quant_configfile
updateMethodByName(const char *name, const ms_quant_method *mod) | ms_quant_configfile
updateMethodByNumber(const int idx, const ms_quant_method *mod) | ms_quant_configfile
validateDocument() const | ms_quant_configfile
~ms_errors() | ms_errors
~ms_quant_configfile() | ms_quant_configfile
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_correction
ms_quant_correction Member List

This is the complete list of members for ms_quant_correction, including all inherited members.

copyFrom(const ms_quant_correction *right) | ms_quant_correction |
defaultValues() | ms_quant_correction |
dropElement() | ms_quant_correction |
dropShift() | ms_quant_correction |
dropType() | ms_quant_correction |
getContent() const | ms_quant_correction |
getContentSchemaType() const | ms_quant_correction |
getElement() const | ms_quant_correction |
getElementSchemaType() const | ms_quant_correction |
getSchemaType() const | ms_quant_correction | virtual
getShift() const | ms_quant_correction |
getShiftSchemaType() const | ms_quant_correction |
getType() const | ms_quant_correction |
getTypeSchemaType() const | ms_quant_correction |
haveElement() const | ms_quant_correction |
haveShift() const | ms_quant_correction |
haveType() const | ms_quant_correction |
ms_quant_correction() | ms_quant_correction |
ms_quant_correction(const ms_quant_correction &src) | ms_quant_correction |
operator=(const ms_quant_correction &right) | ms_quant_correction |
setContent(const char *value) | ms_quant_correction |
setElement(const char *value) | ms_quant_correction |
setShift(const int value) | ms_quant_correction |
setType(const char *value) | ms_quant_correction |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_correction | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_correction | virtual
~ms_quant_correction() | ms_quant_correction | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_element
ms_quant_element Member List

This is the complete list of members for ms_quant_element, including all inherited members.

copyFrom(const ms_quant_element *right) | ms_quant_element |
defaultValues() | ms_quant_element |
dropNumber() | ms_quant_element |
dropSymbol() | ms_quant_element |
getNumber() const | ms_quant_element |
getNumberSchemaType() const | ms_quant_element |
getSchemaType() const | ms_quant_element | virtual
getSymbol() const | ms_quant_element |
getSymbolSchemaType() const | ms_quant_element |
haveNumber() const | ms_quant_element |
haveSymbol() const | ms_quant_element |
ms_quant_element() | ms_quant_element |
ms_quant_element(const ms_quant_element &src) | ms_quant_element |
operator=(const ms_quant_element &right) | ms_quant_element |
setNumber(const int number) | ms_quant_element |
setSymbol(const char *symbol) | ms_quant_element |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_element | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_element | virtual
~ms_quant_element() | ms_quant_element | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_file_index
ms_quant_file_index Member List

This is the complete list of members for ms_quant_file_index, including all inherited members.

copyFrom(const ms_quant_file_index *right) | ms_quant_file_index |
defaultValues() | ms_quant_file_index |
dropFraction() | ms_quant_file_index |
file_index_value_not_set | ms_quant_file_index | static
getContent() const | ms_quant_file_index |
getContentSchemaType() const | ms_quant_file_index |
getFraction() const | ms_quant_file_index |
getFractionSchemaType() const | ms_quant_file_index |
getSchemaType() const | ms_quant_file_index | virtual
haveFraction() const | ms_quant_file_index |
ms_quant_file_index() | ms_quant_file_index |
ms_quant_file_index(const ms_quant_file_index &src) | ms_quant_file_index |
operator=(const ms_quant_file_index &right) | ms_quant_file_index |
setContent(const int fileIndex) | ms_quant_file_index |
setFraction(const int value) | ms_quant_file_index |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_file_index | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_file_index | virtual
~ms_quant_file_index() | ms_quant_file_index | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_helper
ms_quant_helper Member List

This is the complete list of members for ms_quant_helper, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_errors *right) | ms_errors
createMissingComponents(matrix_science::ms_ms1quant_match *match) const | ms_quant_helper
getErrorHandler() const | ms_errors
getFraction(const int file_index) const | ms_quant_helper
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
isPeptideQualityOK(int q, int p, std::string &reasonStrRef) const | ms_quant_helper
isPeptideQuantifiable(int q, int p, const ms_protein *protein, int peptideIndex, std::string &reasonStrRef) const | ms_quant_helper
isValid() const | ms_errors
ms_errors() | ms_errors
ms_quant_helper(const ms_peptidesummary &pepsum, const ms_quant_method &qm, const ms_umod_configfile &umodfile, const int file_index=ms_quant_file_index::file_index_value_not_set) | ms_quant_helper
PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN enum value | ms_quant_helper
PEPTIDE_EXPECT_ABOVE_THRESHOLD enum value | ms_quant_helper
PEPTIDE_HAS_EXCLUDED_FIXEDMOD enum value | ms_quant_helper
PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD enum value | ms_quant_helper
PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD enum value | ms_quant_helper
PEPTIDE_HAS_EXCLUDED_VARMOD enum value | ms_quant_helper
PEPTIDE_HAS_NO_EXCLUSIVE_MODS enum value | ms_quant_helper
PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD enum value | ms_quant_helper
PEPTIDE_HAS_NO_REQUIRED_VARMOD enum value | ms_quant_helper
PEPTIDE_HAS_UNMODIFIED_SITE enum value | ms_quant_helper
PEPTIDE_IS_QUANTIFIABLE enum value | ms_quant_helper
PEPTIDE_NOT_UNIQUE enum value | ms_quant_helper
PEPTIDE_QUALITY enum name | ms_quant_helper
PEPTIDE_QUALITY_IS_OK enum value | ms_quant_helper
PEPTIDE_QUALITY_UNAVAILABLE enum value | ms_quant_helper
PEPTIDE_QUANTIFIABILITY enum name | ms_quant_helper
PEPTIDE_QUANTIFIABILITY_UNAVAILABLE enum value | ms_quant_helper
PEPTIDE_SCORE_BELOW_HOMOLOGY_THR enum value | ms_quant_helper
PEPTIDE_SCORE_BELOW_IDENTITY_THR enum value | ms_quant_helper
PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM enum value | ms_quant_helper
PEPTIDE_SCORE_BELOW_SCORE_THR enum value | ms_quant_helper
~ms_errors() | ms_errors
~ms_quant_helper() | ms_quant_helper
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_integration
ms_quant_integration Member List

This is the complete list of members for ms_quant_integration, including all inherited members.

appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | virtual
copyFrom(const ms_quant_integration *right) | ms_quant_integration |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_integration |
deleteParameterByName(const char *name) | ms_quant_parameters | virtual
deleteParameterByNumber(const int idx) | ms_quant_parameters | virtual
dropAllChargeStates() | ms_quant_integration |
dropAllChargeStatesThreshold() | ms_quant_integration |
dropAllowElutionShift() | ms_quant_integration |
dropElutionProfileCorrelationThreshold() | ms_quant_integration |
dropElutionTimeDelta() | ms_quant_integration |
dropElutionTimeDeltaUnit() | ms_quant_integration |
dropMassDelta() | ms_quant_integration |
dropMassDeltaUnit() | ms_quant_integration |
dropMatchedRho() | ms_quant_integration |
dropMethod() | ms_quant_integration |
dropPrecursorRange() | ms_quant_integration |
dropProcessingOptions() | ms_quant_integration |
dropSimpleRatio() | ms_quant_integration |
dropSource() | ms_quant_integration |
dropXicMaxWidth() | ms_quant_integration |
dropXicSmoothing() | ms_quant_integration |
dropXicThreshold() | ms_quant_integration |
getAllChargeStatesSchemaType() const | ms_quant_integration |
getAllChargeStatesThreshold() const | ms_quant_integration |
getAllChargeStatesThresholdSchemaType() const | ms_quant_integration |
getAllowElutionShiftSchemaType() const | ms_quant_integration |
getElutionProfileCorrelationThreshold() const | ms_quant_integration |
getElutionProfileCorrelationThresholdSchemaType() const | ms_quant_integration |
getElutionTimeDelta() const | ms_quant_integration |
getElutionTimeDeltaSchemaType() const | ms_quant_integration |
getElutionTimeDeltaUnit() const | ms_quant_integration |
getElutionTimeDeltaUnitSchemaType() const | ms_quant_integration |
getMassDelta() const | ms_quant_integration |
getMassDeltaSchemaType() const | ms_quant_integration |
getMassDeltaUnit() const | ms_quant_integration |
getMassDeltaUnitSchemaType() const | ms_quant_integration |
getMatchedRho() const | ms_quant_integration |
getMatchedRhoSchemaType() const | ms_quant_integration |
getMethod() const | ms_quant_integration |
getMethodSchemaType() const | ms_quant_integration |
getNumberOfParameters() const | ms_quant_parameters | virtual
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | virtual
getPrecursorRange() const | ms_quant_integration |
getPrecursorRangeSchemaType() const | ms_quant_integration |
getProcessingOptions() const | ms_quant_integration |
getProcessingOptionsSchemaType() const | ms_quant_integration |
getSchemaType() const | ms_quant_integration | virtual
getSimpleRatioSchemaType() const | ms_quant_integration |
getSource() const | ms_quant_integration |
getSourceSchemaType() const | ms_quant_integration |
getXicMaxWidth() const | ms_quant_integration |
getXicMaxWidthSchemaType() const | ms_quant_integration |
getXicSmoothing() const | ms_quant_integration |
getXicSmoothingSchemaType() const | ms_quant_integration |
getXicThreshold() const | ms_quant_integration |
getXicThresholdSchemaType() const | ms_quant_integration |
haveAllChargeStates() const | ms_quant_integration |
haveAllChargeStatesThreshold() const | ms_quant_integration |
haveAllowElutionShift() const | ms_quant_integration |
haveElutionProfileCorrelationThreshold() const | ms_quant_integration |
haveElutionTimeDelta() const | ms_quant_integration |
haveElutionTimeDeltaUnit() const | ms_quant_integration |
haveMassDelta() const | ms_quant_integration |
haveMassDeltaUnit() const | ms_quant_integration |
haveMatchedRho() const | ms_quant_integration |
haveMethod() const | ms_quant_integration |
havePrecursorRange() const | ms_quant_integration |
haveProcessingOptions() const | ms_quant_integration |
haveSimpleRatio() const | ms_quant_integration |
haveSource() const | ms_quant_integration |
haveXicMaxWidth() const | ms_quant_integration |
haveXicSmoothing() const | ms_quant_integration |
haveXicThreshold() const | ms_quant_integration |
isAllChargeStates() const | ms_quant_integration |
isAllowElutionShift() const | ms_quant_integration |
isSimpleRatio() const | ms_quant_integration |
ms_quant_integration() | ms_quant_integration |
ms_quant_integration(const ms_quant_integration &src) | ms_quant_integration |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_integration &right) | ms_quant_integration |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setAllChargeStates(const bool value) | ms_quant_integration |
setAllChargeStatesThreshold(const char *value) | ms_quant_integration |
setAllowElutionShift(const bool value) | ms_quant_integration |
setElutionProfileCorrelationThreshold(const char *value) | ms_quant_integration |
setElutionTimeDelta(const char *value) | ms_quant_integration |
setElutionTimeDeltaUnit(const char *value) | ms_quant_integration |
setMassDelta(const char *value) | ms_quant_integration |
setMassDeltaUnit(const char *value) | ms_quant_integration |
setMatchedRho(const char *value) | ms_quant_integration |
setMethod(const char *value) | ms_quant_integration |
setPrecursorRange(const char *value) | ms_quant_integration |
setProcessingOptions(const std::string value) | ms_quant_integration |
setSimpleRatio(const bool value) | ms_quant_integration |
setSource(const char *value) | ms_quant_integration |
setXicMaxWidth(int value) | ms_quant_integration |
setXicSmoothing(int value) | ms_quant_integration |
setXicThreshold(const char *value) | ms_quant_integration |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_integration | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_integration | virtual
~ms_quant_integration() | ms_quant_integration | virtual
~ms_quant_parameters() | ms_quant_parameters | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_isotope
ms_quant_isotope Member List

This is the complete list of members for ms_quant_isotope, including all inherited members.

copyFrom(const ms_quant_isotope *right) | ms_quant_isotope |
defaultValues() | ms_quant_isotope |
dropNew() | ms_quant_isotope |
dropOld() | ms_quant_isotope |
getNew() const | ms_quant_isotope |
getNewSchemaType() const | ms_quant_isotope |
getOld() const | ms_quant_isotope |
getOldSchemaType() const | ms_quant_isotope |
getSchemaType() const | ms_quant_isotope | virtual
haveNew() const | ms_quant_isotope |
haveOld() const | ms_quant_isotope |
ms_quant_isotope() | ms_quant_isotope |
ms_quant_isotope(const ms_quant_isotope &src) | ms_quant_isotope |
operator=(const ms_quant_isotope &right) | ms_quant_isotope |
setNew(const char *value) | ms_quant_isotope |
setOld(const char *value) | ms_quant_isotope |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_isotope | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_isotope | virtual
~ms_quant_isotope() | ms_quant_isotope | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_localdef
ms_quant_localdef Member List

This is the complete list of members for ms_quant_localdef, including all inherited members.

appendIgnore(const ms_quant_composition *ignore) | ms_quant_localdef |
appendSpecificity(const ms_quant_specificity *specificity) | ms_quant_localdef |
clearIgnores() | ms_quant_localdef |
clearSpecificities() | ms_quant_localdef |
copyFrom(const ms_quant_localdef *right) | ms_quant_localdef |
defaultValues() | ms_quant_localdef |
deleteIgnore(const int idx) | ms_quant_localdef |
deleteSpecificity(const int idx) | ms_quant_localdef |
dropDelta() | ms_quant_localdef |
dropTitle() | ms_quant_localdef |
getDelta() const | ms_quant_localdef |
getDeltaSchemaType() const | ms_quant_localdef |
getIgnore(const int idx) const | ms_quant_localdef |
getIgnoreSchemaType() const | ms_quant_localdef |
getNumberOfIgnores() const | ms_quant_localdef |
getNumberOfSpecificities() const | ms_quant_localdef |
getSchemaType() const | ms_quant_localdef | virtual
getSpecificity(const int idx) const | ms_quant_localdef |
getSpecificitySchemaType() const | ms_quant_localdef |
getTitle() const | ms_quant_localdef |
getTitleSchemaType() const | ms_quant_localdef |
haveDelta() const | ms_quant_localdef |
haveTitle() const | ms_quant_localdef |
ms_quant_localdef() | ms_quant_localdef |
ms_quant_localdef(const ms_quant_localdef &src) | ms_quant_localdef |
operator=(const ms_quant_localdef &right) | ms_quant_localdef |
setDelta(const ms_quant_composition *delta) | ms_quant_localdef |
setTitle(const char *value) | ms_quant_localdef |
updateIgnore(const int idx, const ms_quant_composition *ignore) | ms_quant_localdef |
updateSpecificity(const int idx, const ms_quant_specificity *specificity) | ms_quant_localdef |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_localdef | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_localdef | virtual
~ms_quant_localdef() | ms_quant_localdef | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_method
ms_quant_method Member List

This is the complete list of members for ms_quant_method, including all inherited members.

appendComponent(const ms_quant_component *item) | ms_quant_method |
appendExclusion(const char *exclusion) | ms_quant_method |
appendModificationGroup(const ms_quant_modgroup *item) | ms_quant_method |
appendReportRatio(const ms_quant_ratio *ratio) | ms_quant_method |
appendSeq(const char *seq) | ms_quant_method |
clearComponents() | ms_quant_method |
clearExclusions() | ms_quant_method |
clearModificationGroups() | ms_quant_method |
clearReportRatios() | ms_quant_method |
clearSeqs() | ms_quant_method |
COMPATIBLE enum value | ms_quant_method |
COMPATIBLE_DIFF_INTEGRATION_PARAM enum value | ms_quant_method |
COMPATIBLE_DIFF_LOCAL_MOD enum value | ms_quant_method |
COMPATIBLE_DIFF_NUM_COMPONENTS enum value | ms_quant_method |
COMPATIBLE_DIFF_NUM_ISOTOPES enum value | ms_quant_method |
COMPATIBLE_DIFF_NUM_LOCAL_MODS enum value | ms_quant_method |
COMPATIBLE_DIFF_NUM_MOD_GROUPS enum value | ms_quant_method |
COMPATIBLE_DIFF_NUM_MODS enum value | ms_quant_method |
COMPATIBLE_DIFF_PROTOCOL enum value | ms_quant_method |
COMPATIBLE_MISSING_COMPONENT enum value | ms_quant_method |
COMPATIBLE_MISSING_INTEGRATION enum value | ms_quant_method |
COMPATIBLE_MISSING_INTEGRATION_PARAM enum value | ms_quant_method |
COMPATIBLE_MISSING_MOD enum value | ms_quant_method |
COMPATIBLE_MISSING_MOD_GROUP enum value | ms_quant_method |
copyFrom(const ms_quant_method *right) | ms_quant_method |
defaultValues() | ms_quant_method |
deleteComponentByName(const char *name) | ms_quant_method |
deleteComponentByNumber(const int idx) | ms_quant_method |
deleteExclusion(const int idx) | ms_quant_method |
deleteModificationGroupByName(const char *name) | ms_quant_method |
deleteModificationGroupByNumber(const int idx) | ms_quant_method |
deleteReportRatioByName(const char *name) | ms_quant_method |
deleteReportRatioByNumber(const int idx) | ms_quant_method |
deleteSeq(const int idx) | ms_quant_method |
dropComp() | ms_quant_method |
dropConstrainSearch() | ms_quant_method |
dropDescription() | ms_quant_method |
dropIntegration() | ms_quant_method |
dropMinNumPeptides() | ms_quant_method |
dropName() | ms_quant_method |
dropNormalisation() | ms_quant_method |
dropOutliers() | ms_quant_method |
dropProteinRatioType() | ms_quant_method |
dropProtocol() | ms_quant_method |
dropProtScoreType() | ms_quant_method |
dropQuality() | ms_quant_method |
dropReportDetail() | ms_quant_method |
dropRequireBoldRed() | ms_quant_method |
dropShowSubSets() | ms_quant_method |
dropSigThresholdValue() | ms_quant_method |
getComp() const | ms_quant_method |
getComponentByName(const char *name) const | ms_quant_method |
getComponentByNumber(const int idx) const | ms_quant_method |
getComponentSchemaType() const | ms_quant_method |
getCompSchemaType() const | ms_quant_method |
getConstrainSearchSchemaType() const | ms_quant_method |
getDescription() const | ms_quant_method |
getDescriptionSchemaType() const | ms_quant_method |
getExclusion(const int idx) const | ms_quant_method |
getExclusionSchemaType() const | ms_quant_method |
getIntegration() const | ms_quant_method |
getIntegrationSchemaType() const | ms_quant_method |
getLocalModifications(std::vector< const ms_quant_localdef * > &localDefVector) | ms_quant_method |
getMinNumPeptides() const | ms_quant_method |
getMinNumPeptidesSchemaType() const | ms_quant_method |
getModificationGroupByName(const char *name) const | ms_quant_method |
getModificationGroupByNumber(const int idx) const | ms_quant_method |
getModificationGroupSchemaType() const | ms_quant_method |
getName() const | ms_quant_method |
getNameSchemaType() const | ms_quant_method |
getNormalisation() const | ms_quant_method |
getNormalisationSchemaType() const | ms_quant_method |
getNumberOfComponents() const | ms_quant_method |
getNumberOfExclusions() const | ms_quant_method |
getNumberOfModificationGroups() const | ms_quant_method |
getNumberOfReportRatios() const | ms_quant_method |
getNumberOfSeqs() const | ms_quant_method |
getOutliers() const | ms_quant_method |
getOutliersSchemaType() const | ms_quant_method |
getProteinRatioType() const | ms_quant_method |
getProteinRatioTypeSchemaType() const | ms_quant_method |
getProtocol() const | ms_quant_method |
getProtocolSchemaType() const | ms_quant_method |
getProtScoreType() const | ms_quant_method |
getProtScoreTypeSchemaType() const | ms_quant_method |
getQuality() const | ms_quant_method |
getQualitySchemaType() const | ms_quant_method |
getReportDetailSchemaType() const | ms_quant_method |
getReportRatioByName(const char *name) const | ms_quant_method |
getReportRatioByNumber(const int idx) const | ms_quant_method |
getReportRatioSchemaType() const | ms_quant_method |
getRequireBoldRedSchemaType() const | ms_quant_method |
getSchemaType() const | ms_quant_method | virtual
getSeq(const int idx) const | ms_quant_method |
getSeqSchemaType() const | ms_quant_method |
getShowSubSets() const | ms_quant_method |
getShowSubSetsSchemaType() const | ms_quant_method |
getSigThresholdValue() const | ms_quant_method |
getSigThresholdValueSchemaType() const | ms_quant_method |
haveComp() const | ms_quant_method |
haveConstrainSearch() const | ms_quant_method |
haveDescription() const | ms_quant_method |
haveIntegration() const | ms_quant_method |
haveMinNumPeptides() const | ms_quant_method |
haveName() const | ms_quant_method |
haveNormalisation() const | ms_quant_method |
haveOutliers() const | ms_quant_method |
haveProteinRatioType() const | ms_quant_method |
haveProtocol() const | ms_quant_method |
haveProtScoreType() const | ms_quant_method |
haveQuality() const | ms_quant_method |
haveReportDetail() const | ms_quant_method |
haveRequireBoldRed() const | ms_quant_method |
haveShowSubSets() const | ms_quant_method |
haveSigThresholdValue() const | ms_quant_method |
isConstrainSearch() const | ms_quant_method |
isMethodCompatible(const ms_quant_method &other, std::string &reasonStrRef) const | ms_quant_method |
isReportDetail() const | ms_quant_method |
isRequireBoldRed() const | ms_quant_method |
METHOD_COMPATIBLE enum name | ms_quant_method |
ms_quant_method() | ms_quant_method |
ms_quant_method(const ms_quant_method &src) | ms_quant_method |
operator=(const ms_quant_method &right) | ms_quant_method |
setComp(const char *value) | ms_quant_method |
setConstrainSearch(const bool value) | ms_quant_method |
setDescription(const char *value) | ms_quant_method |
setIntegration(const ms_quant_integration *integration) | ms_quant_method |
setMinNumPeptides(const int value) | ms_quant_method |
setName(const char *value) | ms_quant_method |
setNormalisation(const ms_quant_normalisation *normalisation) | ms_quant_method |
setOutliers(const ms_quant_outliers *outliers) | ms_quant_method |
setProteinRatioType(const char *value) | ms_quant_method |
setProtocol(const ms_quant_protocol *protocol) | ms_quant_method |
setProtScoreType(const char *value) | ms_quant_method |
setQuality(const ms_quant_quality *quality) | ms_quant_method |
setReportDetail(const bool value) | ms_quant_method |
setRequireBoldRed(const bool value) | ms_quant_method |
setShowSubSets(const char *value) | ms_quant_method |
setSigThresholdValue(const char *value) | ms_quant_method |
updateComponentByName(const char *name, const ms_quant_component *comp) | ms_quant_method |
updateComponentByNumber(const int idx, const ms_quant_component *comp) | ms_quant_method |
updateExclusion(const int idx, const char *exclusion) | ms_quant_method |
updateModificationGroupByName(const char *name, const ms_quant_modgroup *modgroup) | ms_quant_method |
updateModificationGroupByNumber(const int idx, const ms_quant_modgroup *modgroup) | ms_quant_method |
updateReportRatioByName(const char *name, const ms_quant_ratio *ratio) | ms_quant_method |
updateReportRatioByNumber(const int idx, const ms_quant_ratio *ratio) | ms_quant_method |
updateSeq(const int idx, const char *seq) | ms_quant_method |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_method | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_method | virtual
~ms_quant_method() | ms_quant_method | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_modgroup
ms_quant_modgroup Member List

This is the complete list of members for ms_quant_modgroup, including all inherited members.

appendLocalDefinition(const ms_quant_localdef *localdef) | ms_quant_modgroup |
appendModFile(const char *mod) | ms_quant_modgroup |
appendUnmodified(const ms_quant_unmodified *unmodified) | ms_quant_modgroup |
clearLocalDefinitions() | ms_quant_modgroup |
clearModFiles() | ms_quant_modgroup |
clearUnmodified() | ms_quant_modgroup |
copyFrom(const ms_quant_modgroup *right) | ms_quant_modgroup |
defaultValues() | ms_quant_modgroup |
deleteLocalDefinition(const int idx) | ms_quant_modgroup |
deleteModFile(const int idx) | ms_quant_modgroup |
deleteUnmodified(const int idx) | ms_quant_modgroup |
dropMode() | ms_quant_modgroup |
dropName() | ms_quant_modgroup |
dropRequired() | ms_quant_modgroup |
findModFile(const char *mod) const | ms_quant_modgroup |
getLocalDefinition(const int idx) const | ms_quant_modgroup |
getLocalDefinitionSchemaType() const | ms_quant_modgroup |
getMode() const | ms_quant_modgroup |
getModeSchemaType() const | ms_quant_modgroup |
getModFile(const int idx) const | ms_quant_modgroup |
getModFileSchemaType() const | ms_quant_modgroup |
getName() const | ms_quant_modgroup |
getNameSchemaType() const | ms_quant_modgroup |
getNumberOfLocalDefinitions() const | ms_quant_modgroup |
getNumberOfModFiles() const | ms_quant_modgroup |
getNumberOfUnmodified() const | ms_quant_modgroup |
getRequiredSchemaType() const | ms_quant_modgroup |
getSchemaType() const | ms_quant_modgroup | virtual
getUnmodified(const int idx) const | ms_quant_modgroup |
getUnmodifiedSchemaType() const | ms_quant_modgroup |
haveMode() const | ms_quant_modgroup |
haveName() const | ms_quant_modgroup |
haveRequired() const | ms_quant_modgroup |
isRequired() const | ms_quant_modgroup |
ms_quant_modgroup() | ms_quant_modgroup |
ms_quant_modgroup(const ms_quant_modgroup &src) | ms_quant_modgroup |
operator=(const ms_quant_modgroup &right) | ms_quant_modgroup |
setMode(const char *value) | ms_quant_modgroup |
setName(const char *value) | ms_quant_modgroup |
setRequired(bool value) | ms_quant_modgroup |
updateLocalDefinition(const int idx, const ms_quant_localdef *localdef) | ms_quant_modgroup |
updateUnmodified(const int idx, const ms_quant_unmodified *unmodified) | ms_quant_modgroup |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_modgroup | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_modgroup | virtual
~ms_quant_modgroup() | ms_quant_modgroup | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_moverz
ms_quant_moverz Member List

This is the complete list of members for ms_quant_moverz, including all inherited members.

copyFrom(const ms_quant_moverz *right) | ms_quant_moverz |
defaultValues() | ms_quant_moverz |
dropAverage() | ms_quant_moverz |
dropMonoisotopic() | ms_quant_moverz |
getAverage() const | ms_quant_moverz |
getAverageSchemaType() const | ms_quant_moverz |
getMonoisotopic() const | ms_quant_moverz |
getMonoisotopicSchemaType() const | ms_quant_moverz |
getSchemaType() const | ms_quant_moverz | virtual
haveAverage() const | ms_quant_moverz |
haveMonoisotopic() const | ms_quant_moverz |
ms_quant_moverz() | ms_quant_moverz |
ms_quant_moverz(const ms_quant_moverz &src) | ms_quant_moverz |
operator=(const ms_quant_moverz &right) | ms_quant_moverz |
setAverage(const char *value) | ms_quant_moverz |
setMonoisotopic(const char *value) | ms_quant_moverz |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_moverz | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_moverz | virtual
~ms_quant_moverz() | ms_quant_moverz | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_multiplex
ms_quant_multiplex Member List

This is the complete list of members for ms_quant_multiplex, including all inherited members.

appendIonSeries(const std::string ionSeries) | ms_quant_multiplex |
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearIonSeries() | ms_quant_multiplex |
clearParameters() | ms_quant_parameters | virtual
copyFrom(const ms_quant_multiplex *right) | ms_quant_multiplex |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_multiplex |
deleteIonSeries(const int idx) | ms_quant_multiplex |
deleteParameterByName(const char *name) | ms_quant_parameters | virtual
deleteParameterByNumber(const int idx) | ms_quant_parameters | virtual
dropExcludeInternalLabel() | ms_quant_multiplex |
dropExcludeIsobaricFragments() | ms_quant_multiplex |
dropIonIntensityThreshold() | ms_quant_multiplex |
dropIonSeries() | ms_quant_multiplex |
dropMinIonPairs() | ms_quant_multiplex |
getExcludeInternalLabelSchemaType() const | ms_quant_multiplex |
getExcludeIsobaricFragmentsSchemaType() const | ms_quant_multiplex |
getIonIntensityThreshold() const | ms_quant_multiplex |
getIonIntensityThresholdSchemaType() const | ms_quant_multiplex |
getIonSeries(const int idx=0) const | ms_quant_multiplex |
getIonSeriesSchemaType() const | ms_quant_multiplex |
getMinIonPairs() const | ms_quant_multiplex |
getMinIonPairsSchemaType() const | ms_quant_multiplex |
getNumberOfIonSeries() const | ms_quant_multiplex |
getNumberOfParameters() const | ms_quant_parameters | virtual
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | virtual
getSchemaType() const | ms_quant_multiplex | virtual
haveExcludeInternalLabel() const | ms_quant_multiplex |
haveExcludeIsobaricFragments() const | ms_quant_multiplex |
haveIonIntensityThreshold() const | ms_quant_multiplex |
haveIonSeries() const | ms_quant_multiplex |
haveMinIonPairs() const | ms_quant_multiplex |
isExcludeInternalLabel() const | ms_quant_multiplex |
isExcludeIsobaricFragments() const | ms_quant_multiplex |
ms_quant_multiplex() | ms_quant_multiplex |
ms_quant_multiplex(const ms_quant_multiplex &src) | ms_quant_multiplex |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_multiplex &right) | ms_quant_multiplex |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setExcludeInternalLabel(const bool value) | ms_quant_multiplex |
setExcludeIsobaricFragments(const bool value) | ms_quant_multiplex |
setIonIntensityThreshold(const char *value) | ms_quant_multiplex |
setIonSeries(const std::string ionSeries) | ms_quant_multiplex |
setMinIonPairs(const int value) | ms_quant_multiplex |
updateIonSeries(const int idx, const std::string ionSeries) | ms_quant_multiplex |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_multiplex | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_multiplex | virtual
~ms_quant_multiplex() | ms_quant_multiplex | virtual
~ms_quant_parameters() | ms_quant_parameters | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_neutralloss
ms_quant_neutralloss Member List

This is the complete list of members for ms_quant_neutralloss, including all inherited members.

appendElement(const ms_quant_element *element) | ms_quant_composition |
clearElements() | ms_quant_composition |
copyFrom(const ms_quant_neutralloss *right) | ms_quant_neutralloss |
matrix_science::ms_quant_composition::copyFrom(const ms_quant_composition *right) | ms_quant_composition |
defaultValues() | ms_quant_neutralloss |
deleteElement(const int idx) | ms_quant_composition |
dropFlag() | ms_quant_neutralloss |
getElement(const int idx) const | ms_quant_composition |
getElementSchemaType() const | ms_quant_composition |
getFlagSchemaType() const | ms_quant_neutralloss |
getNumberOfElements() const | ms_quant_composition |
getSchemaType() const | ms_quant_neutralloss | virtual
haveFlag() const | ms_quant_neutralloss |
isFlag() const | ms_quant_neutralloss |
ms_quant_composition() | ms_quant_composition |
ms_quant_composition(const ms_quant_composition &src) | ms_quant_composition |
ms_quant_neutralloss() | ms_quant_neutralloss |
ms_quant_neutralloss(const ms_quant_neutralloss &src) | ms_quant_neutralloss |
operator=(const ms_quant_neutralloss &right) | ms_quant_neutralloss |
matrix_science::ms_quant_composition::operator=(const ms_quant_composition &right) | ms_quant_composition |
setFlag(const bool flag) | ms_quant_neutralloss |
updateElement(const int idx, const ms_quant_element *element) | ms_quant_composition |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_neutralloss | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_neutralloss | virtual
~ms_quant_composition() | ms_quant_composition | virtual
~ms_quant_neutralloss() | ms_quant_neutralloss | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_normalisation
ms_quant_normalisation Member List

This is the complete list of members for ms_quant_normalisation, including all inherited members.

appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | virtual
copyFrom(const ms_quant_normalisation *right) | ms_quant_normalisation |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_normalisation |
deleteParameterByName(const char *name) | ms_quant_parameters | virtual
deleteParameterByNumber(const int idx) | ms_quant_parameters | virtual
dropMethod() | ms_quant_normalisation |
dropPeptides() | ms_quant_normalisation |
dropProteins() | ms_quant_normalisation |
getMethod() const | ms_quant_normalisation |
getMethodSchemaType() const | ms_quant_normalisation |
getNumberOfParameters() const | ms_quant_parameters | virtual
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | virtual
getPeptides() const | ms_quant_normalisation |
getPeptidesSchemaType() const | ms_quant_normalisation |
getProteins() const | ms_quant_normalisation |
getProteinsSchemaType() const | ms_quant_normalisation |
getSchemaType() const | ms_quant_normalisation | virtual
haveMethod() const | ms_quant_normalisation |
havePeptides() const | ms_quant_normalisation |
haveProteins() const | ms_quant_normalisation |
ms_quant_normalisation() | ms_quant_normalisation |
ms_quant_normalisation(const ms_quant_normalisation &src) | ms_quant_normalisation |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_normalisation &right) | ms_quant_normalisation |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setMethod(const char *value) | ms_quant_normalisation |
setPeptides(const ms_quant_normalisation_peptides *peptides) | ms_quant_normalisation |
setProteins(const ms_quant_normalisation_proteins *proteins) | ms_quant_normalisation |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation | virtual
~ms_quant_normalisation() | ms_quant_normalisation | virtual
~ms_quant_parameters() | ms_quant_parameters | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_normalisation_peptide
ms_quant_normalisation_peptide Member List

This is the complete list of members for ms_quant_normalisation_peptide, including all inherited members.

copyFrom(const ms_quant_normalisation_peptide *right) | ms_quant_normalisation_peptide |
defaultValues() | ms_quant_normalisation_peptide |
dropSequence() | ms_quant_normalisation_peptide |
getSchemaType() const | ms_quant_normalisation_peptide | virtual
getSequence() const | ms_quant_normalisation_peptide |
getSequenceSchemaType() const | ms_quant_normalisation_peptide |
haveSequence() const | ms_quant_normalisation_peptide |
ms_quant_normalisation_peptide() | ms_quant_normalisation_peptide |
ms_quant_normalisation_peptide(const ms_quant_normalisation_peptide &src) | ms_quant_normalisation_peptide |
operator=(const ms_quant_normalisation_peptide &right) | ms_quant_normalisation_peptide |
setSequence(const char *value) | ms_quant_normalisation_peptide |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_peptide | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_peptide | virtual
~ms_quant_normalisation_peptide() | ms_quant_normalisation_peptide | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_normalisation_peptides
ms_quant_normalisation_peptides Member List

This is the complete list of members for ms_quant_normalisation_peptides, including all inherited members.

appendPeptide(const ms_quant_normalisation_peptide *pep) | ms_quant_normalisation_peptides |
clearPeptides() | ms_quant_normalisation_peptides |
copyFrom(const ms_quant_normalisation_peptides *right) | ms_quant_normalisation_peptides |
defaultValues() | ms_quant_normalisation_peptides |
deletePeptide(const int idx) | ms_quant_normalisation_peptides |
getNumberOfPeptides() const | ms_quant_normalisation_peptides |
getPeptide(const int idx) const | ms_quant_normalisation_peptides |
getPeptideSchemaType() const | ms_quant_normalisation_peptides |
getSchemaType() const | ms_quant_normalisation_peptides | virtual
ms_quant_normalisation_peptides() | ms_quant_normalisation_peptides |
ms_quant_normalisation_peptides(const ms_quant_normalisation_peptides &src) | ms_quant_normalisation_peptides |
operator=(const ms_quant_normalisation_peptides &right) | ms_quant_normalisation_peptides |
updatePeptide(const int idx, const ms_quant_normalisation_peptide *pep) | ms_quant_normalisation_peptides |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_peptides | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_peptides | virtual
~ms_quant_normalisation_peptides() | ms_quant_normalisation_peptides | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_normalisation_protein
ms_quant_normalisation_protein Member List

This is the complete list of members for ms_quant_normalisation_protein, including all inherited members.

copyFrom(const ms_quant_normalisation_protein *right) | ms_quant_normalisation_protein |
defaultValues() | ms_quant_normalisation_protein |
dropAccession() | ms_quant_normalisation_protein |
getAccession() const | ms_quant_normalisation_protein |
getAccessionSchemaType() const | ms_quant_normalisation_protein |
getSchemaType() const | ms_quant_normalisation_protein | virtual
haveAccession() const | ms_quant_normalisation_protein |
ms_quant_normalisation_protein() | ms_quant_normalisation_protein |
ms_quant_normalisation_protein(const ms_quant_normalisation_protein &src) | ms_quant_normalisation_protein |
operator=(const ms_quant_normalisation_protein &right) | ms_quant_normalisation_protein |
setAccession(const char *value) | ms_quant_normalisation_protein |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_protein | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_protein | virtual
~ms_quant_normalisation_protein() | ms_quant_normalisation_protein | virtual
Generated on Tue Sep 24 2024 11:06:14 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_normalisation_proteins
ms_quant_normalisation_proteins Member List

This is the complete list of members for ms_quant_normalisation_proteins, including all inherited members.

appendProtein(const ms_quant_normalisation_protein *protein) | ms_quant_normalisation_proteins |
clearProteins() | ms_quant_normalisation_proteins |
copyFrom(const ms_quant_normalisation_proteins *right) | ms_quant_normalisation_proteins |
defaultValues() | ms_quant_normalisation_proteins |
deleteProtein(const int idx) | ms_quant_normalisation_proteins |
getNumberOfProteins() const | ms_quant_normalisation_proteins |
getProtein(const int idx) const | ms_quant_normalisation_proteins |
getProteinSchemaType() const | ms_quant_normalisation_proteins |
getSchemaType() const | ms_quant_normalisation_proteins | virtual
ms_quant_normalisation_proteins() | ms_quant_normalisation_proteins |
ms_quant_normalisation_proteins(const ms_quant_normalisation_proteins &src) | ms_quant_normalisation_proteins |
operator=(const ms_quant_normalisation_proteins &right) | ms_quant_normalisation_proteins |
updateProtein(const int idx, const ms_quant_normalisation_protein *protein) | ms_quant_normalisation_proteins |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_proteins | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_proteins | virtual
~ms_quant_normalisation_proteins() | ms_quant_normalisation_proteins | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_numerator
ms_quant_numerator Member List

This is the complete list of members for ms_quant_numerator, including all inherited members.

copyFrom(const ms_quant_numerator *right) | ms_quant_numerator |
defaultValues() | ms_quant_numerator |
dropCoefficient() | ms_quant_numerator |
dropName() | ms_quant_numerator |
getCoefficient() const | ms_quant_numerator |
getCoefficientSchemaType() const | ms_quant_numerator |
getContent() const | ms_quant_numerator |
getContentSchemaType() const | ms_quant_numerator |
getName() const | ms_quant_numerator |
getNameSchemaType() const | ms_quant_numerator |
getSchemaType() const | ms_quant_numerator | virtual
haveCoefficient() const | ms_quant_numerator |
haveName() const | ms_quant_numerator |
ms_quant_numerator() | ms_quant_numerator |
ms_quant_numerator(const ms_quant_numerator &src) | ms_quant_numerator |
operator=(const ms_quant_numerator &right) | ms_quant_numerator |
setCoefficient(const char *value) | ms_quant_numerator |
setContent(const char *value) | ms_quant_numerator |
setName(const char *value) | ms_quant_numerator |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_numerator | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_numerator | virtual
~ms_quant_numerator() | ms_quant_numerator | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_outliers
ms_quant_outliers Member List

This is the complete list of members for ms_quant_outliers, including all inherited members.

appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | virtual
copyFrom(const ms_quant_outliers *right) | ms_quant_outliers |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_outliers |
deleteParameterByName(const char *name) | ms_quant_parameters | virtual
deleteParameterByNumber(const int idx) | ms_quant_parameters | virtual
dropMethod() | ms_quant_outliers |
getMethod() const | ms_quant_outliers |
getMethodSchemaType() const | ms_quant_outliers |
getNumberOfParameters() const | ms_quant_parameters | virtual
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | virtual
getSchemaType() const | ms_quant_outliers | virtual
haveMethod() const | ms_quant_outliers |
ms_quant_outliers() | ms_quant_outliers |
ms_quant_outliers(const ms_quant_outliers &src) | ms_quant_outliers |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_outliers &right) | ms_quant_outliers |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setMethod(const char *value) | ms_quant_outliers |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_outliers | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_outliers | virtual
~ms_quant_outliers() | ms_quant_outliers | virtual
~ms_quant_parameters() | ms_quant_parameters | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_parameter
ms_quant_parameter Member List

This is the complete list of members for ms_quant_parameter, including all inherited members.

copyFrom(const ms_quant_parameter *right) | ms_quant_parameter |
matrix_science::ms_xml_parameter::copyFrom(const ms_xml_parameter *right) | ms_xml_parameter |
defaultValues() | ms_xml_parameter |
dropDescription() | ms_xml_parameter |
dropName() | ms_xml_parameter |
getDescription() const | ms_xml_parameter |
getDescriptionSchemaType() const | ms_quant_parameter | virtual
getName() const | ms_xml_parameter |
getNameSchemaType() const | ms_quant_parameter | virtual
getSchemaType() const | ms_quant_parameter | virtual
getValue() const | ms_xml_parameter |
getValueSchemaType() const | ms_quant_parameter | virtual
haveDescription() const | ms_xml_parameter |
haveName() const | ms_xml_parameter |
ms_quant_parameter() | ms_quant_parameter |
ms_quant_parameter(const ms_quant_parameter &src) | ms_quant_parameter |
ms_xml_parameter() | ms_xml_parameter |
ms_xml_parameter(const ms_xml_parameter &src) | ms_xml_parameter |
operator=(const ms_quant_parameter &right) | ms_quant_parameter |
matrix_science::ms_xml_parameter::operator=(const ms_xml_parameter &right) | ms_xml_parameter |
setDescription(const char *value) | ms_xml_parameter |
setName(const char *value) | ms_xml_parameter |
setValue(const char *value) | ms_xml_parameter |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
~ms_quant_parameter() | ms_quant_parameter | virtual
~ms_xml_parameter() | ms_xml_parameter | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_parameters
ms_quant_parameters Member List

This is the complete list of members for ms_quant_parameters, including all inherited members.

appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | virtual
copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_parameters |
deleteParameterByName(const char *name) | ms_quant_parameters | virtual
deleteParameterByNumber(const int idx) | ms_quant_parameters | virtual
getNumberOfParameters() const | ms_quant_parameters | virtual
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | virtual
getSchemaType() const | ms_quant_parameters | virtual
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_parameters &right) | ms_quant_parameters |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_quant_parameters() | ms_quant_parameters | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_pepneutralloss
ms_quant_pepneutralloss Member List

This is the complete list of members for ms_quant_pepneutralloss, including all inherited members.

appendElement(const ms_quant_element *element) | ms_quant_composition |
clearElements() | ms_quant_composition |
copyFrom(const ms_quant_pepneutralloss *right) | ms_quant_pepneutralloss |
matrix_science::ms_quant_composition::copyFrom(const ms_quant_composition *right) | ms_quant_composition |
defaultValues() | ms_quant_pepneutralloss |
deleteElement(const int idx) | ms_quant_composition |
dropRequired() | ms_quant_pepneutralloss |
getElement(const int idx) const | ms_quant_composition |
getElementSchemaType() const | ms_quant_composition |
getNumberOfElements() const | ms_quant_composition |
getRequiredSchemaType() const | ms_quant_pepneutralloss |
getSchemaType() const | ms_quant_pepneutralloss | virtual
haveRequired() const | ms_quant_pepneutralloss |
isRequired() const | ms_quant_pepneutralloss |
ms_quant_composition() | ms_quant_composition |
ms_quant_composition(const ms_quant_composition &src) | ms_quant_composition |
ms_quant_pepneutralloss() | ms_quant_pepneutralloss |
ms_quant_pepneutralloss(const ms_quant_pepneutralloss &src) | ms_quant_pepneutralloss |
operator=(const ms_quant_pepneutralloss &right) | ms_quant_pepneutralloss |
matrix_science::ms_quant_composition::operator=(const ms_quant_composition &right) | ms_quant_composition |
setRequired(const bool required) | ms_quant_pepneutralloss |
updateElement(const int idx, const ms_quant_element *element) | ms_quant_composition |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_pepneutralloss | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_pepneutralloss | virtual
~ms_quant_composition() | ms_quant_composition | virtual
~ms_quant_pepneutralloss() | ms_quant_pepneutralloss | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_precursor
ms_quant_precursor Member List

This is the complete list of members for ms_quant_precursor, including all inherited members.

appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | virtual
copyFrom(const ms_quant_precursor *right) | ms_quant_precursor |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_precursor |
deleteParameterByName(const char *name) | ms_quant_parameters | virtual
deleteParameterByNumber(const int idx) | ms_quant_parameters | virtual
dropAllChargeStates() | ms_quant_precursor |
dropAllowElutionShift() | ms_quant_precursor |
dropAllowMassTimeMatch() | ms_quant_precursor |
getAllChargeStatesSchemaType() const | ms_quant_precursor |
getAllowElutionShiftSchemaType() const | ms_quant_precursor |
getAllowMassTimeMatchSchemaType() const | ms_quant_precursor |
getNumberOfParameters() const | ms_quant_parameters | virtual
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | virtual
getSchemaType() const | ms_quant_precursor | virtual
haveAllChargeStates() const | ms_quant_precursor |
haveAllowElutionShift() const | ms_quant_precursor |
haveAllowMassTimeMatch() const | ms_quant_precursor |
isAllChargeStates() const | ms_quant_precursor |
isAllowElutionShift() const | ms_quant_precursor |
isAllowMassTimeMatch() const | ms_quant_precursor |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_quant_precursor() | ms_quant_precursor |
ms_quant_precursor(const ms_quant_precursor &src) | ms_quant_precursor |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_precursor &right) | ms_quant_precursor |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setAllowMassTimeMatch(const bool value) | ms_quant_precursor |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_precursor | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_precursor | virtual
~ms_quant_parameters() | ms_quant_parameters | virtual
~ms_quant_precursor() | ms_quant_precursor | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_protocol
ms_quant_protocol Member List

This is the complete list of members for ms_quant_protocol, including all inherited members.

copyFrom(const ms_quant_protocol *right) | ms_quant_protocol |
defaultValues() | ms_quant_protocol |
getAverage() const | ms_quant_protocol |
getAverageSchemaType() const | ms_quant_protocol |
getMultiplex() const | ms_quant_protocol |
getMultiplexSchemaType() const | ms_quant_protocol |
getPrecursor() const | ms_quant_protocol |
getPrecursorSchemaType() const | ms_quant_protocol |
getReplicate() const | ms_quant_protocol |
getReplicateSchemaType() const | ms_quant_protocol |
getReporter() const | ms_quant_protocol |
getReporterSchemaType() const | ms_quant_protocol |
getSchemaType() const | ms_quant_protocol | virtual
getType() const | ms_quant_protocol |
ms_quant_protocol() | ms_quant_protocol |
ms_quant_protocol(const ms_quant_protocol &src) | ms_quant_protocol |
operator=(const ms_quant_protocol &right) | ms_quant_protocol |
setAverage(const ms_quant_average *average) | ms_quant_protocol |
setMultiplex(const ms_quant_multiplex *multiplex) | ms_quant_protocol |
setNull() | ms_quant_protocol |
setPrecursor(const ms_quant_precursor *precursor) | ms_quant_protocol |
setReplicate(const ms_quant_replicate *replicate) | ms_quant_protocol |
setReporter(const ms_quant_reporter *reporter) | ms_quant_protocol |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_protocol | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_protocol | virtual
~ms_quant_protocol() | ms_quant_protocol | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_quality
ms_quant_quality Member List

This is the complete list of members for ms_quant_quality, including all inherited members.

appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | virtual
copyFrom(const ms_quant_quality *right) | ms_quant_quality |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_quality |
deleteParameterByName(const char *name) | ms_quant_parameters | virtual
deleteParameterByNumber(const int idx) | ms_quant_parameters | virtual
dropIsolatedPrecursor() | ms_quant_quality |
dropIsolatedPrecursorThreshold() | ms_quant_quality |
dropMinimumA1() | ms_quant_quality |
dropMinPrecursorCharge() | ms_quant_quality |
dropPepThresholdType() | ms_quant_quality |
dropPepThresholdValue() | ms_quant_quality |
dropTotalIntensity() | ms_quant_quality |
dropTotalIntensityThreshold() | ms_quant_quality |
dropUniquePepseq() | ms_quant_quality |
getIsolatedPrecursorSchemaType() const | ms_quant_quality |
getIsolatedPrecursorThreshold() const | ms_quant_quality |
getIsolatedPrecursorThresholdSchemaType() const | ms_quant_quality |
getMinimumA1() const | ms_quant_quality |
getMinimumA1SchemaType() const | ms_quant_quality |
getMinPrecursorCharge() const | ms_quant_quality |
getMinPrecursorChargeSchemaType() const | ms_quant_quality |
getNumberOfParameters() const | ms_quant_parameters | virtual
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | virtual
getPepThresholdType() const | ms_quant_quality |
getPepThresholdTypeSchemaType() const | ms_quant_quality |
getPepThresholdValue() const | ms_quant_quality |
getPepThresholdValueSchemaType() const | ms_quant_quality |
getSchemaType() const | ms_quant_quality | virtual
getTotalIntensitySchemaType() const | ms_quant_quality |
getTotalIntensityThreshold() const | ms_quant_quality |
getTotalIntensityThresholdSchemaType() const | ms_quant_quality |
getUniquePepseqSchemaType() const | ms_quant_quality |
haveIsolatedPrecursor() const | ms_quant_quality |
haveIsolatedPrecursorThreshold() const | ms_quant_quality |
haveMinimumA1() const | ms_quant_quality |
haveMinPrecursorCharge() const | ms_quant_quality |
havePepThresholdType() const | ms_quant_quality |
havePepThresholdValue() const | ms_quant_quality |
haveTotalIntensity() const | ms_quant_quality |
haveTotalIntensityThreshold() const | ms_quant_quality |
haveUniquePepseq() const | ms_quant_quality |
isIsolatedPrecursor() const | ms_quant_quality |
isTotalIntensity() const | ms_quant_quality |
isUniquePepseq() const | ms_quant_quality |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_quant_quality() | ms_quant_quality |
ms_quant_quality(const ms_quant_quality &src) | ms_quant_quality |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_quality &right) | ms_quant_quality |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setIsolatedPrecursor(const bool value) | ms_quant_quality |
setIsolatedPrecursorThreshold(const char *value) | ms_quant_quality |
setMinimumA1(const char *value) | ms_quant_quality |
setMinPrecursorCharge(const int value) | ms_quant_quality |
setPepThresholdType(const char *value) | ms_quant_quality |
setPepThresholdValue(const char *value) | ms_quant_quality |
setTotalIntensity(bool value) | ms_quant_quality |
setTotalIntensityThreshold(std::string value) | ms_quant_quality |
setUniquePepseq(bool value) | ms_quant_quality |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_quality | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_quality | virtual
~ms_quant_parameters() | ms_quant_parameters | virtual
~ms_quant_quality() | ms_quant_quality | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_ratio
ms_quant_ratio Member List

This is the complete list of members for ms_quant_ratio, including all inherited members.

appendDenominator(const ms_quant_numerator *denominator) | ms_quant_ratio |
appendNumerator(const ms_quant_numerator *numerator) | ms_quant_ratio |
clearDenominators() | ms_quant_ratio |
clearNumerators() | ms_quant_ratio |
copyFrom(const ms_quant_ratio *right) | ms_quant_ratio |
defaultValues() | ms_quant_ratio |
deleteDenominatorByName(const char *name) | ms_quant_ratio |
deleteDenominatorByNumber(const int idx) | ms_quant_ratio |
deleteNumeratorByName(const char *name) | ms_quant_ratio |
deleteNumeratorByNumber(const int idx) | ms_quant_ratio |
dropName() | ms_quant_ratio |
getDenominatorByName(const char *name) const | ms_quant_ratio |
getDenominatorByNumber(const int idx) const | ms_quant_ratio |
getDenominatorSchemaType() const | ms_quant_ratio |
getName() const | ms_quant_ratio |
getNameSchemaType() const | ms_quant_ratio |
getNumberOfDenominators() const | ms_quant_ratio |
getNumberOfNumerators() const | ms_quant_ratio |
getNumeratorByName(const char *name) const | ms_quant_ratio |
getNumeratorByNumber(const int idx) const | ms_quant_ratio |
getNumeratorSchemaType() const | ms_quant_ratio |
getSchemaType() const | ms_quant_ratio | virtual
haveName() const | ms_quant_ratio |
ms_quant_ratio() | ms_quant_ratio |
ms_quant_ratio(const ms_quant_ratio &src) | ms_quant_ratio |
operator=(const ms_quant_ratio &right) | ms_quant_ratio |
setName(const char *value) | ms_quant_ratio |
updateDenominatorByName(const char *name, const ms_quant_numerator *denominator) | ms_quant_ratio |
updateDenominatorByNumber(const int idx, const ms_quant_numerator *denominator) | ms_quant_ratio |
updateNumeratorByName(const char *name, const ms_quant_numerator *numerator) | ms_quant_ratio |
updateNumeratorByNumber(const int idx, const ms_quant_numerator *numerator) | ms_quant_ratio |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_ratio | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_ratio | virtual
~ms_quant_ratio() | ms_quant_ratio | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_replicate
ms_quant_replicate Member List

This is the complete list of members for ms_quant_replicate, including all inherited members.

appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | virtual
copyFrom(const ms_quant_replicate *right) | ms_quant_replicate |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_replicate |
deleteParameterByName(const char *name) | ms_quant_parameters | virtual
deleteParameterByNumber(const int idx) | ms_quant_parameters | virtual
dropTimeAlignmentAlgorithm() | ms_quant_replicate |
getNumberOfParameters() const | ms_quant_parameters | virtual
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | virtual
getSchemaType() const | ms_quant_replicate | virtual
getTimeAlignmentAlgorithm() const | ms_quant_replicate |
getTimeAlignmentAlgorithmSchemaType() const | ms_quant_replicate |
haveTimeAlignmentAlgorithm() const | ms_quant_replicate |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_quant_replicate() | ms_quant_replicate |
ms_quant_replicate(const ms_quant_replicate &src) | ms_quant_replicate |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_replicate &right) | ms_quant_replicate |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setTimeAlignmentAlgorithm(const char *value) | ms_quant_replicate |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_replicate | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_replicate | virtual
~ms_quant_parameters() | ms_quant_parameters | virtual
~ms_quant_replicate() | ms_quant_replicate | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_reporter
ms_quant_reporter Member List

This is the complete list of members for ms_quant_reporter, including all inherited members.

appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | virtual
copyFrom(const ms_quant_reporter *right) | ms_quant_reporter |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_reporter |
deleteParameterByName(const char *name) | ms_quant_parameters | virtual
deleteParameterByNumber(const int idx) | ms_quant_parameters | virtual
dropReporterTol() | ms_quant_reporter |
dropReporterTolUnit() | ms_quant_reporter |
getNumberOfParameters() const | ms_quant_parameters | virtual
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | virtual
getReporterTol() const | ms_quant_reporter |
getReporterTolSchemaType() const | ms_quant_reporter |
getReporterTolUnit() const | ms_quant_reporter |
getReporterTolUnitSchemaType() const | ms_quant_reporter |
getSchemaType() const | ms_quant_reporter | virtual
haveReporterTol() const | ms_quant_reporter |
haveReporterTolUnit() const | ms_quant_reporter |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_quant_reporter() | ms_quant_reporter |
ms_quant_reporter(const ms_quant_reporter &src) | ms_quant_reporter |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_reporter &right) | ms_quant_reporter |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setReporterTol(const char *value) | ms_quant_reporter |
setReporterTolUnit(const char *value) | ms_quant_reporter |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_reporter | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_reporter | virtual
~ms_quant_parameters() | ms_quant_parameters | virtual
~ms_quant_reporter() | ms_quant_reporter | virtual
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_satellite
ms_quant_satellite Member List

This is the complete list of members for ms_quant_satellite, including all inherited members.

copyFrom(const ms_quant_satellite *right) | ms_quant_satellite |
defaultValues() | ms_quant_satellite |
dropModifications() | ms_quant_satellite |
getModifications() const | ms_quant_satellite |
getModificationsSchemaType() const | ms_quant_satellite |
getSchemaType() const | ms_quant_satellite | virtual
haveModifications() const | ms_quant_satellite |
ms_quant_satellite() | ms_quant_satellite |
ms_quant_satellite(const ms_quant_satellite &src) | ms_quant_satellite |
operator=(const ms_quant_satellite &right) | ms_quant_satellite |
setModifications(const ms_quant_modgroup *moverz) | ms_quant_satellite |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_satellite | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_satellite | virtual
~ms_quant_satellite() | ms_quant_satellite | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_specificity
ms_quant_specificity Member List

This is the complete list of members for ms_quant_specificity, including all inherited members.

appendNeutralLoss(const ms_quant_neutralloss *neutralloss) | ms_quant_specificity |
appendPepNeutralLoss(const ms_quant_pepneutralloss *neutralloss) | ms_quant_specificity |
clearNeutralLosses() | ms_quant_specificity |
clearPepNeutralLosses() | ms_quant_specificity |
copyFrom(const ms_quant_specificity *right) | ms_quant_specificity |
defaultValues() | ms_quant_specificity |
deleteNeutralLoss(const int idx) | ms_quant_specificity |
deletePepNeutralLoss(const int idx) | ms_quant_specificity |
dropPosition() | ms_quant_specificity |
dropSite() | ms_quant_specificity |
getNeutralLoss(const int idx) const | ms_quant_specificity |
getNeutralLossSchemaType() const | ms_quant_specificity |
getNumberOfNeutralLosses() const | ms_quant_specificity |
getNumberOfPepNeutralLosses() const | ms_quant_specificity |
getPepNeutralLoss(const int idx) const | ms_quant_specificity |
getPepNeutralLossSchemaType() const | ms_quant_specificity |
getPosition() const | ms_quant_specificity |
getPositionSchemaType() const | ms_quant_specificity |
getSchemaType() const | ms_quant_specificity | virtual
getSite() const | ms_quant_specificity |
getSiteSchemaType() const | ms_quant_specificity |
havePosition() const | ms_quant_specificity |
haveSite() const | ms_quant_specificity |
ms_quant_specificity() | ms_quant_specificity |
ms_quant_specificity(const ms_quant_specificity &src) | ms_quant_specificity |
operator=(const ms_quant_specificity &right) | ms_quant_specificity |
setPosition(const char *position) | ms_quant_specificity |
setSite(const char *site) | ms_quant_specificity |
updateNeutralLoss(const int idx, const ms_quant_neutralloss *neutralloss) | ms_quant_specificity |
updatePepNeutralLoss(const int idx, const ms_quant_pepneutralloss *neutralloss) | ms_quant_specificity |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_specificity | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_specificity | virtual
~ms_quant_specificity() | ms_quant_specificity | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_stats
ms_quant_stats Member List

This is the complete list of members for ms_quant_stats, including all inherited members.

arithmeticMean(const std::vector< double > &data) | ms_quant_stats | static
arithmeticStandardDeviation(const std::vector< double > &data, double arithmeticMean) | ms_quant_stats | static
arithmeticStandardErrorOfMean(double arithmeticStdev, unsigned long sampleSize) | ms_quant_stats | static
arithmeticStandardErrorOfMedian(double arithmeticStdev, unsigned long sampleSize) | ms_quant_stats | static
binomialCoefficient(unsigned int n, unsigned int k) | ms_quant_stats | static
calculateNormalMeanPvalue(double populationMean, double mean, double stdev, unsigned long sampleSize) | ms_quant_stats | static
calculateNormalMedianPvalue(double populationMedian, double median, double stdev, unsigned long sampleSize) | ms_quant_stats | static
calculateNormalWeightedPvalue(double populationMean, double weightedMean, const std::vector< double > &weights, double weightedStdev, unsigned long sampleSize) | ms_quant_stats | static
chisqLowerCriticalValue(unsigned int df, double sigLevel) | ms_quant_stats | static
chisqUpperCriticalValue(unsigned int df, double sigLevel) | ms_quant_stats | static
detectOutliers(const std::vector< double > &sample, std::string outlierMethod, unsigned int *const numLow, unsigned int *const numHigh) | ms_quant_stats | static
detectOutliers(const std::vector< double > &sample, std::string outlierMethod, double sigLevel, unsigned int *const numLow, unsigned int *const numHigh) | ms_quant_stats | static
expTransform(const std::vector< double > &logData) | ms_quant_stats | static
geometricMean(const std::vector< double > &data) | ms_quant_stats | static
geometricStandardDeviation(const std::vector< double > &data, double geometricMean) | ms_quant_stats | static
logTransform(const std::vector< double > &data) | ms_quant_stats | static
meanCentre(const std::vector< double > &data, double mean) | ms_quant_stats | static
medianStandardErrorCorrection(unsigned long sampleSize) | ms_quant_stats | static
normalCriticalValue(double p) | ms_quant_stats | static
normalCumulativeProbability(double x0) | ms_quant_stats | static
poissonDensity(double lambda, unsigned int k) | ms_quant_stats | static
snedecorsCriticalValue(unsigned int df1, unsigned int df2, double sigLevel) | ms_quant_stats | static
sortedMedian(const std::vector< double > &data) | ms_quant_stats | static
sortedMedian(const std::deque< double > &data) | ms_quant_stats | static
studentsCriticalValue(unsigned int df, double sigLevel) | ms_quant_stats | static
sum(const std::vector< double > &data) | ms_quant_stats | static
sumsq(const std::vector< double > &data) | ms_quant_stats | static
testDixonsN9(unsigned long sampleSize, double min, double x2, double xn_1, double max, double sigLevel) | ms_quant_stats | static
testGrubbsN2(unsigned long sampleSize, double min, double mean, double max, double stdev, double sigLevel) | ms_quant_stats | static
testRosners(const std::vector< double > &sample, unsigned int maxOutliers, double sigLevel, unsigned int *const numLow, unsigned int *const numHigh) | ms_quant_stats | static
testShapiroWilkW(const std::vector< double > &sample, double *const W, double *const pValue) | ms_quant_stats | static
unsortedMedian(const std::vector< double > &data) | ms_quant_stats | static
weightedArithmeticMean(const std::vector< double > &data, const std::vector< double > &weights) | ms_quant_stats | static
weightedArithmeticStandardDeviation(const std::vector< double > &data, const std::vector< double > &weights, double weightedMean) | ms_quant_stats | static
weightedArithmeticStandardError(const std::vector< double > &weights, double weightedStdev, unsigned long sampleSize) | ms_quant_stats | static
weightedGeometricMean(const std::vector< double > &data, const std::vector< double > &weights) | ms_quant_stats | static
weightedGeometricStandardDeviation(const std::vector< double > &data, const std::vector< double > &weights, double weightedMean) | ms_quant_stats | static
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quant_unmodified
ms_quant_unmodified Member List

This is the complete list of members for ms_quant_unmodified, including all inherited members.

copyFrom(const ms_quant_unmodified *right) | ms_quant_unmodified |
defaultValues() | ms_quant_unmodified |
dropPosition() | ms_quant_unmodified |
dropSite() | ms_quant_unmodified |
getContent() const | ms_quant_unmodified |
getContentSchemaType() const | ms_quant_unmodified |
getPosition() const | ms_quant_unmodified |
getPositionSchemaType() const | ms_quant_unmodified |
getSchemaType() const | ms_quant_unmodified | virtual
getSite() const | ms_quant_unmodified |
getSiteSchemaType() const | ms_quant_unmodified |
havePosition() const | ms_quant_unmodified |
haveSite() const | ms_quant_unmodified |
ms_quant_unmodified() | ms_quant_unmodified |
ms_quant_unmodified(const ms_quant_unmodified &src) | ms_quant_unmodified |
operator=(const ms_quant_unmodified &right) | ms_quant_unmodified |
setContent(const char *value) | ms_quant_unmodified |
setPosition(const char *position) | ms_quant_unmodified |
setSite(const char *site) | ms_quant_unmodified |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_unmodified | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_unmodified | virtual
~ms_quant_unmodified() | ms_quant_unmodified | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_quantitation
ms_quantitation Member List

This is the complete list of members for ms_quantitation, including all inherited members.

addHeaderField(const std::string &name, const std::string &value) | ms_quantitation |
addRawFileField(const unsigned int id, const std::string &name, const std::string &value) | ms_quantitation |
appendErrors(const ms_errors &src) | ms_errors |
calculateGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
calculateMedianRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
calculateWeightedGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | protected
clearAllErrors() | ms_errors |
clearHeaderFields() | ms_quantitation |
clearRawFileFields() | ms_quantitation |
copyFrom(const ms_errors *right) | ms_errors |
countDistinctPeptides(const std::vector< ms_peptide_quant_key > &activeKeys) const | ms_quantitation | virtual
countDistinctPeptides(const ms_peptide_quant_key_vector &activeKeys) const | ms_quantitation | virtual
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMinNumPeptides() const | ms_quantitation | protected
getPeptideQuantKeys(const std::string &accession, int dbIdx) const | ms_quantitation |
getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const =0 | ms_quantitation | pure virtual
getPeptideRatioNormalisationBase(const std::string &ratioName) const | ms_quantitation |
getProgressInfo() | ms_quantitation |
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const =0 | ms_quantitation | pure virtual
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const =0 | ms_quantitation | pure virtual
getProteinRatioSample(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const | ms_quantitation | protected
getQuantitationMethod() const | ms_quantitation |
getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKeys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const =0 | ms_quantitation | protectedpure virtual
hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const =0 | ms_quantitation | pure virtual
initialiseBaseSettings(const ms_quant_method &qmBase, const ms_quant_method &qmConfig) | ms_quantitation | protected
isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const =0 | ms_quantitation | pure virtual
isValid() const | ms_errors |
ms_errors() | ms_errors |
proteinKeys_ | ms_quantitation | protected
removePeptideRatioNormalisationBase(const std::string &ratioName) | ms_quantitation |
removePeptideRatioNormalisationBases() | ms_quantitation |
setMinNumPeptides(int value) | ms_quantitation |
setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName)=0 | ms_quantitation | pure virtual
setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName)=0 | ms_quantitation | pure virtual
setPeptideRatioNormalisationBase(const std::string &ratioName, double b) | ms_quantitation |
setProteinRatioType(const char *value)=0 | ms_quantitation | pure virtual
setQuantOutliers(const ms_quant_outliers *)=0 | ms_quantitation | pure virtual
~ms_errors() | ms_errors |
~ms_quantitation()=0 | ms_quantitation | pure virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_searchparams
ms_searchparams Member List

This is the complete list of members for ms_searchparams, including all inherited members.

getACCESSION() | ms_searchparams |
getAllUSERParams() const | ms_searchparams |
getCarbonMass() const | ms_searchparams |
getCHARGE() | ms_searchparams |
getCLE() | ms_searchparams |
getCOM() | ms_searchparams |
getCROSSLINKING() const | ms_searchparams |
getCTermMass() | ms_searchparams |
getDATAURL() | ms_searchparams |
getDB(int idx=1) | ms_searchparams |
getDECOY() const | ms_searchparams |
getElectronMass() const | ms_searchparams |
getERRORTOLERANT() | ms_searchparams |
getErrTolParentFilename() | ms_searchparams |
getFILENAME() | ms_searchparams |
getFixedModsDelta(int num) | ms_searchparams |
getFixedModsName(int num) const | ms_searchparams |
getFixedModsNeutralLoss(int num) | ms_searchparams |
getFixedModsResidues(int num) const | ms_searchparams |
getFORMAT() | ms_searchparams |
getFORMVER() | ms_searchparams |
getHydrogenMass() const | ms_searchparams |
getICAT() | ms_searchparams |
getINSTRUMENT() | ms_searchparams |
getINTERMEDIATE() | ms_searchparams |
getIT_MODS() | ms_searchparams |
getITOL() | ms_searchparams |
getITOLU() | ms_searchparams |
getLIBRARY_SEARCH() const | ms_searchparams |
getLibraryModDelta(int num) const | ms_searchparams |
getLibraryModName(int num) const | ms_searchparams |
getLICENSE() | ms_searchparams |
getMASS() | ms_searchparams |
getMassType() | ms_searchparams |
getMaxInternalMass() | ms_searchparams |
getMinInternalMass() | ms_searchparams |
getML_ADAPTER_PARAM() const | ms_searchparams |
getMODS() | ms_searchparams |
getMULTI_SITE_MODS() const | ms_searchparams |
getNitrogenMass() const | ms_searchparams |
getNTermMass() | ms_searchparams |
getNumberOfDatabases() | ms_searchparams |
getNumberOfLibraryMods() const | ms_searchparams |
getOVERVIEW() | ms_searchparams |
getOxygenMass() const | ms_searchparams |
getPEP_ISOTOPE_ERROR() const | ms_searchparams |
getPERCOLATE() const | ms_searchparams |
getPFA() | ms_searchparams |
getPRECURSOR() | ms_searchparams |
getQUANTITATION() const | ms_searchparams |
getQUE() | ms_searchparams |
getREPORT() | ms_searchparams |
getREPTYPE() | ms_searchparams |
getResidueMass(char residue) | ms_searchparams |
getRULES() | ms_searchparams |
getSEARCH() | ms_searchparams |
getSEG() | ms_searchparams |
getSUBCLUSTER() | ms_searchparams |
getTARGET_FDR_PERCENT() const | ms_searchparams |
getTAXONOMY() | ms_searchparams |
getTOL() | ms_searchparams |
getTOLU() | ms_searchparams |
getUSEREMAIL() | ms_searchparams |
getUSERField(int num) | ms_searchparams |
getUSERID() | ms_searchparams |
getUSERNAME() | ms_searchparams |
getVarModsDelta(int num) | ms_searchparams |
getVarModsName(int num) const | ms_searchparams |
getVarModsNeutralLoss(int num) | ms_searchparams |
getVarModsNeutralLosses(int num) const | ms_searchparams |
getVarModsPepNeutralLoss(int num) | ms_searchparams |
getVarModsReqPepNeutralLoss(int num) | ms_searchparams |
hasINTERNALS() const | ms_searchparams |
ms_searchparams(const ms_mascotresfilebase &resfile) | ms_searchparams |
MSM_EXCLUSIVE_PLUS_VARIABLE enum value | ms_searchparams |
MSM_NOT_PERMITTED enum value | ms_searchparams |
MULTI_SITE_MODS enum name | ms_searchparams |
~ms_searchparams() | ms_searchparams | inline
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_security
ms_security Member List

This is the complete list of members for ms_security, including all inherited members.

addNewGroup(const std::string sessionID, const int groupID, const std::string groupName) | ms_security
addNewUser(const std::string sessionID, const int userID, const std::string userName, const std::string password, const time_t passwordExpiry, const std::string fullName, const std::string emailAddress, const ms_user::usertype userType, const bool enabled) | ms_security
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_errors *right) | ms_errors
createDefaults(const std::string sessionID="") | ms_security
deleteGroup(const std::string sessionID, const std::string groupName) | ms_security
deleteUser(const std::string sessionID, const std::string userName) | ms_security
getAllCustomParamsForUser(const ms_user &user) const | ms_security
getAllGroupIDs() const | ms_security
getAllUserIDs(const USERID_SORTBY sortby=USERID_SORTBY_ID) const | ms_security
getErrorHandler() const | ms_errors
getGroup(const std::string groupName) const | ms_security
getGroupFromID(const int groupID) const | ms_security
getIntegraUsers() const | ms_security
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getMascotSecurityOptions() const | ms_security
getPermittedTasksForUser(const std::string name) const | ms_security
getTasks() const | ms_security
getUser(const std::string userName) const | ms_security
getUserFromID(const int userID) const | ms_security
isTaskExists(const int taskID) const | ms_security
isUserExists(const int userID) const | ms_security
isValid() const | ms_errors
ms_errors() | ms_errors
ms_security() | ms_security
sortUsers(std::vector< ms_user * > &vecUsers, const USERID_SORTBY sortby) const | ms_security
updateAllSessionFiles(bool deleteOnly=false) | ms_security
updateGroup(const std::string sessionID, const ms_group &group) | ms_security
updatePassword(const std::string sessionID, const std::string userName, const std::string oldPassword, const std::string newPassword) | ms_security
updateUser(const std::string sessionID, const ms_user user) | ms_security
USERID_SORTBY enum name | ms_security
USERID_SORTBY_FULLNAME enum value | ms_security
USERID_SORTBY_ID enum value | ms_security
USERID_SORTBY_LOGINNAME enum value | ms_security
~ms_errors() | ms_errors
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_security_options
ms_security_options Member List

This is the complete list of members for ms_security_options, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_security_options *right) | ms_security_options
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
getDefaultPasswordExpiryTime() const | ms_security_options
getErrorHandler() const | ms_errors
getIntegraAppServerURL() const | ms_security_options
getIntegraDatabaseName() const | ms_security_options
getIntegraOracleServerName() const | ms_security_options
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getLogFileName() | ms_security_options
getLoggingLevel() const | ms_security_options
getMinimumPasswordLength() const | ms_security_options
getSessionTimeout() const | ms_security_options
getUseSessionCookies() const | ms_security_options
getVerifySessionIPAddress() const | ms_security_options
isSecurityEnabled() const | ms_security_options
isValid() const | ms_errors
ms_errors() | ms_errors
ms_security_options() | ms_security_options
ms_security_options(const ms_security_options &src) | ms_security_options
operator=(const ms_security_options &right) | ms_security_options
setDefaultPasswordExpiryTime(time_t newVal) | ms_security_options
setIntegraAppServerURL(std::string newVal) | ms_security_options
setIntegraDatabaseName(std::string newVal) | ms_security_options
setIntegraOracleServerName(std::string newVal) | ms_security_options
setLogFileName(std::string newVal) | ms_security_options
setLoggingLevel(ms_errs::msg_sev newVal) | ms_security_options
setMinimumPasswordLength(unsigned int newVal) | ms_security_options
setSecurityEnabled(bool newVal) | ms_security_options
setSessionTimeout(time_t newVal) | ms_security_options
setUseSessionCookies(bool newVal) | ms_security_options
setVerifySessionIPAddress(bool newVal) | ms_security_options
~ms_errors() | ms_errors
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_security_task
ms_security_task Member List

This is the complete list of members for ms_security_task, including all inherited members.

addDoubleParam(const double value) | ms_security_task
addLongParam(const long value) | ms_security_task
addStringParam(const std::string value) | ms_security_task
clearParams() | ms_security_task
getAllParamsAsString() const | ms_security_task
getConstantName() const | ms_security_task
getDescription() const | ms_security_task
getDoubleParams() const | ms_security_task
getID() const | ms_security_task
getLongParams() const | ms_security_task
getNotes() const | ms_security_task
getStringParams() const | ms_security_task
getType() const | ms_security_task
isPermitted() const | ms_security_task
isPermitted_double(const double value) const | ms_security_task
isPermitted_long(const long value) const | ms_security_task
isPermitted_string(const std::string value) const | ms_security_task
ms_security_task() | ms_security_task
paramType enum name | ms_security_task
setParams(const std::string value) | ms_security_task
TYPE_ALL_USERS_ARRAY enum value | ms_security_task
TYPE_BOOL enum value | ms_security_task
TYPE_DOUBLE_ARRAY enum value | ms_security_task
TYPE_EQ_DOUBLE enum value | ms_security_task
TYPE_EQ_LONG enum value | ms_security_task
TYPE_EQ_STRING enum value | ms_security_task
TYPE_GTE_DOUBLE enum value | ms_security_task
TYPE_GTE_LONG enum value | ms_security_task
TYPE_LONG_ARRAY enum value | ms_security_task
TYPE_LTE_DOUBLE enum value | ms_security_task
TYPE_LTE_LONG enum value | ms_security_task
TYPE_STRING_ARRAY enum value | ms_security_task
TYPE_USERS_ARRAY enum value | ms_security_task
~ms_security_task() | ms_security_task
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_security_tasks
ms_security_tasks Member List

This is the complete list of members for ms_security_tasks, including all inherited members.

addTask(const ms_security_task &task) | ms_security_tasks
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
getDiffsAsText(const ms_security_tasks &old) | ms_security_tasks
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumberOfTasks() const | ms_security_tasks
getTask(const int num) const | ms_security_tasks
getTaskFromID(const int taskID) const | ms_security_tasks
isFastaPermitted(const std::string database) const | ms_security_tasks
isPermitted(const int taskID) const | ms_security_tasks
isPermitted_double(const int taskID, const double value) const | ms_security_tasks
isPermitted_long(const int taskID, const long value) const | ms_security_tasks
isPermitted_string(const int taskID, const std::string value) const | ms_security_tasks
isTaskExists(const int taskID) const | ms_security_tasks
isValid() const | ms_errors
loadFromFile(const char *filename) | ms_security_tasks
MISECTASK_ACCESS enum value | ms_security_tasks
MISECTASK_ADDCUSTOMREPORT enum value | ms_security_tasks
MISECTASK_ADDEXCLUSIONFILE enum value | ms_security_tasks
MISECTASK_ADDIMPORTFILTER enum value | ms_security_tasks
MISECTASK_ADMIN enum value | ms_security_tasks
MISECTASK_DELETECUSTOMREPORT enum value | ms_security_tasks
MISECTASK_DELETEEXCLUSIONFILE enum value | ms_security_tasks
MISECTASK_PROTEINAPPROVAL enum value | ms_security_tasks
MISECTASK_SENDNOTIFICATION enum value | ms_security_tasks
ms_errors() | ms_errors
ms_security_tasks() | ms_security_tasks
ms_security_tasks(const char *filename) | ms_security_tasks
removeAllTasks() | ms_security_tasks
removeTask(const int taskID) | ms_security_tasks
saveToFile(const char *filename) | ms_security_tasks
SECTASK_ACCESSDBSETUP enum value | ms_security_tasks
SECTASK_ADMINPAGES enum value | ms_security_tasks
SECTASK_ALLFASTA enum value | ms_security_tasks
SECTASK_ALLOWMSMS enum value | ms_security_tasks
SECTASK_ALLOWMSMSNOENZYME enum value | ms_security_tasks
SECTASK_ALLOWPMF enum value | ms_security_tasks
SECTASK_ALLOWPMFNOENZYME enum value | ms_security_tasks
SECTASK_ALLOWSPOOFOTHERUSER enum value | ms_security_tasks
SECTASK_BIOTOOLSBATCH enum value | ms_security_tasks
SECTASK_DAEMONCLIENT enum value | ms_security_tasks
SECTASK_DATAURLMAXSIZE enum value | ms_security_tasks
SECTASK_DATAURLPROTOCOLS enum value | ms_security_tasks
SECTASK_DENYQUANT enum value | ms_security_tasks
SECTASK_DISTILLERCLIENT enum value | ms_security_tasks
SECTASK_DOWNLOAD_DISTILLER_XML enum value | ms_security_tasks
SECTASK_EDITCONFIG enum value | ms_security_tasks
SECTASK_INTEGRASYSTEMACCOUNT enum value | ms_security_tasks
SECTASK_KILLALLTASK enum value | ms_security_tasks
SECTASK_KILLTASKINGROUP enum value | ms_security_tasks
SECTASK_MAXCONCURRENTSEARCHES enum value | ms_security_tasks
SECTASK_MAXETACCESSIONS enum value | ms_security_tasks
SECTASK_MAXETVARMODS enum value | ms_security_tasks
SECTASK_MAXEXECUTIONTIME enum value | ms_security_tasks
SECTASK_MAXFASTAFILES enum value | ms_security_tasks
SECTASK_MAXJOBPRIORITY enum value | ms_security_tasks
SECTASK_MAXNOENZQUERIES enum value | ms_security_tasks
SECTASK_MAXQUERIES enum value | ms_security_tasks
SECTASK_MAXVARMODS enum value | ms_security_tasks
SECTASK_MODIFYOWNPROFILE enum value | ms_security_tasks
SECTASK_MSSTATUSEXECLUSTER enum value | ms_security_tasks
SECTASK_MSSTATUSEXERETRYDB enum value | ms_security_tasks
SECTASK_NAMEDFASTA enum value | ms_security_tasks
SECTASK_SEEALLSEARCHESWITHUSERID enum value | ms_security_tasks
SECTASK_SEEOLDSEARCHES enum value | ms_security_tasks
SECTASK_SEESEARCHINANYGROUP enum value | ms_security_tasks
SECTASK_SEESEARCHINGROUP enum value | ms_security_tasks
SECTASK_SPOOFNAMEDGROUPSONLY enum value | ms_security_tasks
SECTASK_UPLOAD_DISTILLER_XML enum value | ms_security_tasks
SECTASK_USEMSREVIEWEXE enum value | ms_security_tasks
SECTASK_USEMSSTATUSEXE enum value | ms_security_tasks
SECTASK_VIEWCONFIG enum value | ms_security_tasks
SECTASK_VIEWCONFIGUSINGMSSTATUS enum value | ms_security_tasks
TASKID enum name | ms_security_tasks
updateTask(const ms_security_task &task) | ms_security_tasks
~ms_errors() | ms_errors
~ms_security_tasks() | ms_security_tasks
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_session
ms_session Member List

This is the complete list of members for ms_session, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
canResultsFileBeViewed(const int userID) const | ms_session
clearAllErrors() | ms_errors
clearParam(const std::string name) | ms_session
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
destroy() | ms_session
getBoolParam(const std::string name, bool &param) const | ms_session
getDoubleParam(const std::string name, double &param) const | ms_session
getDoubleParam(const std::string name) const | ms_session
getEmailAddress() const | ms_session
getErrorHandler() const | ms_errors
getFullUserName() const | ms_session
getID() const | ms_session
getIntParam(const std::string name, int &param) const | ms_session
getIntParam(const std::string name) const | ms_session
getIPAddress() const | ms_session
getLastAccessed() const | ms_session
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getLongParam(const std::string name, long &param) const | ms_session
getLongParam(const std::string name) const | ms_session
getParams() const | ms_session
getPermittedTasks() const | ms_session
getSpoofableUsers() const | ms_session
getStringParam(const std::string name, std::string &param) const | ms_session
getStringParam(const std::string name) const | ms_session
getTimeout() const | ms_session
getTimeParam(const std::string name, time_t &param) const | ms_session
getTimeParam(const std::string name) const | ms_session
getUserID() const | ms_session
getUserName() const | ms_session
getUserType() const | ms_session
isFastaPermitted(const std::string database) const | ms_session
isPermitted(const int taskID) const | ms_session
isPermitted_double(const int taskID, const double value) const | ms_session
isPermitted_long(const int taskID, const long value) const | ms_session
isPermitted_string(const int taskID, const std::string value) const | ms_session
isSecurityEnabled() const | ms_session
isTimedOut() const | ms_session
isValid() const | ms_errors
ms_errors() | ms_errors
ms_session(const std::string session_id="") | ms_session
ms_session(const std::string userName, const std::string userPassword) | ms_session
ms_session(const std::string userName, const std::string connectionID, const std::string database) | ms_session
ms_session(const int timeout, const std::string prefix) | ms_session
saveBoolParam(const std::string name, bool param) | ms_session
saveDoubleParam(const std::string name, double param) | ms_session
saveIntParam(const std::string name, int param) | ms_session
saveLongParam(const std::string name, long param) | ms_session
saveStringParam(const std::string name, const std::string param) | ms_session
saveTimeParam(const std::string name, time_t param) | ms_session
setPermittedTasks(const matrix_science::ms_security_tasks &val) | ms_session
update(const ms_security &sec) | ms_session
~ms_errors() | ms_errors
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_shapiro_wilk
ms_shapiro_wilk Member List

This is the complete list of members for ms_shapiro_wilk, including all inherited members.

appendSampleValue(double y) | ms_shapiro_wilk |
calculate(long n, long n1, long n2) | ms_shapiro_wilk |
clearSampleValues() | ms_shapiro_wilk |
getErrorCode() const | ms_shapiro_wilk |
getPValue() const | ms_shapiro_wilk |
getResult() const | ms_shapiro_wilk |
ms_shapiro_wilk() | ms_shapiro_wilk |
ms_shapiro_wilk(std::deque< std::pair< size_t, double > > x, long n, long n1, long n2) | ms_shapiro_wilk |
swilk(bool init, std::deque< std::pair< size_t, double > > x, long n, long n1, long n2, std::deque< double > &a, double &w, double &pw, int &ifault) | ms_shapiro_wilk | static
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_spectral_lib_entry
ms_spectral_lib_entry Member List

This is the complete list of members for ms_spectral_lib_entry, including all inherited members.

ANNOTATE_NONE enum value | ms_spectral_lib_entry |
ANNOTATE_REPLACE_ALL enum value | ms_spectral_lib_entry |
ANNOTATE_REPLACE_IF_ALL_EMPTY enum value | ms_spectral_lib_entry |
ANNOTATE_REPLACE_QUESTION_MARKS enum value | ms_spectral_lib_entry |
annotatePeaks(const WHAT_TO_ANNOTATE whatToAnnotate, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, const ms_umod_configfile *unimod=0) | ms_spectral_lib_entry |
appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
clearAnnotation() | ms_spectral_lib_entry |
copyFrom(const ms_spectral_lib_entry *right) | ms_spectral_lib_entry |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
get() const | ms_spectral_lib_entry |
getCharge() const | ms_spectral_lib_entry |
getComment() const | ms_spectral_lib_entry |
getCommentField(const char *fieldName) const | ms_spectral_lib_entry |
getErrorHandler() const | ms_errors |
getFileName() const | ms_spectral_lib_entry |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getLine(const char *key) const | ms_spectral_lib_entry |
getMods(std::vector< std::string > &names, std::vector< int > &positions) const | ms_spectral_lib_entry |
getMW() const | ms_spectral_lib_entry |
getName() const | ms_spectral_lib_entry |
getNumPeaks() const | ms_spectral_lib_entry |
getPeakList(bool convertToNISTformat=false) const | ms_spectral_lib_entry |
getPeakListChecksum() const | ms_spectral_lib_entry |
getPeakListObject() const | ms_spectral_lib_entry |
getPrecursorMZ() const | ms_spectral_lib_entry |
getSequence() const | ms_spectral_lib_entry |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_spectral_lib_entry() | ms_spectral_lib_entry |
ms_spectral_lib_entry(const ms_spectral_lib_entry &src) | ms_spectral_lib_entry |
ms_spectral_lib_entry(const std::string &entry, const std::string &fileName, const ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_entry |
ms_spectral_lib_entry(const std::vector< std::string > &entry, const std::string &fileName, const ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_entry |
operator=(const ms_spectral_lib_entry &right) | ms_spectral_lib_entry |
WHAT_TO_ANNOTATE enum name | ms_spectral_lib_entry |
~ms_errors() | ms_errors |
~ms_spectral_lib_entry() | ms_spectral_lib_entry | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_spectral_lib_file
ms_spectral_lib_file Member List

This is the complete list of members for ms_spectral_lib_file, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_errors *right) | ms_errors
findEntries(const char *sequence, const char *checksum=0, const char *accession=0, const char *mods=0) const | ms_spectral_lib_file
getAccessionFromNumber(const int number) const | ms_spectral_lib_file
getAllMods() const | ms_spectral_lib_file
getChecksumFromNumber(const int number) const | ms_spectral_lib_file
getEntryFromNumber(const int number) const | ms_spectral_lib_file
getEntryFromNumberAsText(const int number) const | ms_spectral_lib_file
getErrorHandler() const | ms_errors
getFileName() const | ms_spectral_lib_file
getFormat() const | ms_spectral_lib_file
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getModsFromNumber(const int number) const | ms_spectral_lib_file
getNumEntries() const | ms_spectral_lib_file
getNumResidues() const | ms_spectral_lib_file
getPrecursorChargeFromNumber(const int number) const | ms_spectral_lib_file
getPrecursorMZFromNumber(const int number) const | ms_spectral_lib_file
getQmatch(double minMz, double maxMz) const | ms_spectral_lib_file
getSequenceFromNumber(const int number) const | ms_spectral_lib_file
getStatsInformation() const | ms_spectral_lib_file
isValid() const | ms_errors
ms_errors() | ms_errors
ms_spectral_lib_file(const char *fileName, const char *regexForAccession, const char *cdbFileName=0) | ms_spectral_lib_file
ms_spectral_lib_file(const char *fileName, const char *regexForAccession, const char *cdbFileName, const std::map< std::string, std::string > &modificationAliases) | ms_spectral_lib_file
saveAs(const char *fileName, const bool replaceProteinName=true, ms_spectral_lib::FILE_FORMAT fileFormat=ms_spectral_lib::FORMAT_NIST_MSP, const int startNumber=1, const int endNumber=-1, const ms_spectral_lib_entry::WHAT_TO_ANNOTATE whatToAnnotate=ms_spectral_lib_entry::ANNOTATE_REPLACE_QUESTION_MARKS, const double annotateTol=0.6, const char *annotateTolu="Da", const ms_umod_configfile *unimod=0) const | ms_spectral_lib_file
verifyThatModsAreInUnimod(const ms_umod_configfile &unimod) | ms_spectral_lib_file
~ms_errors() | ms_errors
~ms_spectral_lib_file() | ms_spectral_lib_file
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_spectral_lib_peak
ms_spectral_lib_peak Member List

This is the complete list of members for ms_spectral_lib_peak, including all inherited members.

asText(ms_spectral_lib::FILE_FORMAT format) const | ms_spectral_lib_peak |
clearAnnotation() | ms_spectral_lib_peak |
copyFrom(const ms_spectral_lib_peak *right) | ms_spectral_lib_peak |
getAnnotation(ms_spectral_lib::FILE_FORMAT format=ms_spectral_lib::FORMAT_NIST_MSP) const | ms_spectral_lib_peak |
getConsensusData(int *numerator, int *denominator, double *medianDeviation) const | ms_spectral_lib_peak |
getDelta() const | ms_spectral_lib_peak |
getIntensity() const | ms_spectral_lib_peak |
getMz() const | ms_spectral_lib_peak |
getUnmatchedAnnotationStr(ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_peak | static
isMatchedToCalculatedPeak() const | ms_spectral_lib_peak |
isSuspectAssignment() const | ms_spectral_lib_peak |
isValid() const | ms_spectral_lib_peak |
ms_spectral_lib_peak(const std::string &text, ms_spectral_lib::FILE_FORMAT format, matrix_science::ms_errs &errs) | ms_spectral_lib_peak |
ms_spectral_lib_peak(const double mz, const double intensity, const std::string &annotation, ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_peak |
ms_spectral_lib_peak(const ms_spectral_lib_peak &src) | ms_spectral_lib_peak |
operator=(const ms_spectral_lib_peak &right) | ms_spectral_lib_peak |
setAnnotation(const std::string &annotation, ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_peak |
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_spectral_lib_peak_list
ms_spectral_lib_peak_list Member List

This is the complete list of members for ms_spectral_lib_peak_list, including all inherited members.

addPeaks(const std::vector< double > &vecMz, const std::vector< double > &vecIntensity) | ms_spectral_lib_peak_list
ANNOT_LVL_CANNOT_ANNOTATE enum value | ms_spectral_lib_peak_list
ANNOT_LVL_NONE enum value | ms_spectral_lib_peak_list
ANNOT_LVL_QUESTION_MARKS enum value | ms_spectral_lib_peak_list
ANNOT_LVL_SOME_PEAKS enum value | ms_spectral_lib_peak_list
annotatePeaks(const ms_fragmentvector *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz) | ms_spectral_lib_peak_list
annotatePeaks(const std::vector< ms_fragment > *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz) | ms_spectral_lib_peak_list
appendErrors(const ms_errors &src) | ms_errors
asText(ms_spectral_lib::FILE_FORMAT format) const | ms_spectral_lib_peak_list
clearAllErrors() | ms_errors
clearAnnotation() | ms_spectral_lib_peak_list
copyFrom(const ms_spectral_lib_peak_list *right) | ms_spectral_lib_peak_list
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
getChecksum() const | ms_spectral_lib_peak_list
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumPeaks() const | ms_spectral_lib_peak_list
getPeak(const int pkNum) const | ms_spectral_lib_peak_list
getPeakAnnotationLevel() const | ms_spectral_lib_peak_list
isValid() const | ms_errors
ms_errors() | ms_errors
ms_spectral_lib_peak_list() | ms_spectral_lib_peak_list
ms_spectral_lib_peak_list(std::vector< std::string > input, ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_peak_list
ms_spectral_lib_peak_list(const ms_spectral_lib_peak_list &src) | ms_spectral_lib_peak_list
operator=(const ms_spectral_lib_peak_list &right) | ms_spectral_lib_peak_list
PEAK_ANNOTATION_LEVEL enum name | ms_spectral_lib_peak_list
setAnnotationLevel(PEAK_ANNOTATION_LEVEL level) | ms_spectral_lib_peak_list
~ms_errors() | ms_errors
~ms_spectral_lib_peak_list() | ms_spectral_lib_peak_list
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_stdout_logger
ms_stdout_logger Member List

This is the complete list of members for ms_stdout_logger, including all inherited members.

COL_ASC_TIME enum value | ms_logger |
COL_HEADERS enum value | ms_logger |
COL_IP_ADDRESS enum value | ms_logger |
COL_ISO8601_TIME enum value | ms_logger |
COL_LOGGER_DEFAULTS enum value | ms_logger |
COL_MSG enum value | ms_logger |
COL_MSG_NUM_DEC enum value | ms_logger |
COL_MSG_NUM_HEX enum value | ms_logger |
COL_MSG_SOURCE_TXT enum value | ms_logger |
COL_QUOTES enum value | ms_logger |
COL_SEVERITY_NUM enum value | ms_logger |
COL_SEVERITY_TXT enum value | ms_logger |
COL_SRC_FILE enum value | ms_logger |
COL_SRC_LINENUM enum value | ms_logger |
COL_THREAD_ID enum value | ms_logger |
COL_TSV enum value | ms_logger |
formatMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const | ms_logger |
getColsToOutput() const | ms_logger | virtual
getHeaderLine() const | ms_logger |
LogOutputColumns_e enum name | ms_logger |
ms_logger(const unsigned int colsToOutput=COL_MSG) | ms_logger |
ms_stdout_logger(unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS) | ms_stdout_logger |
onLogMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) | ms_stdout_logger | virtual
setColsToOutput(const unsigned int colsToOutput) | ms_logger | virtual
~ms_logger() | ms_logger | inlinevirtual
~ms_stdout_logger() | ms_stdout_logger | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_taxnodesfiles
ms_taxnodesfiles Member List

This is the complete list of members for ms_taxnodesfiles, including all inherited members.

copyFrom(const ms_taxnodesfiles *right) | ms_taxnodesfiles
defaultValues() | ms_taxnodesfiles
getFileName() const | ms_taxnodesfiles
getFormat() const | ms_taxnodesfiles
ms_taxnodesfiles() | ms_taxnodesfiles
ms_taxnodesfiles(const ms_taxnodesfiles &src) | ms_taxnodesfiles
operator=(const ms_taxnodesfiles &right) | ms_taxnodesfiles
setFileName(const char *name) | ms_taxnodesfiles
setFormat(const TAX_NODE_FORMAT value) | ms_taxnodesfiles
~ms_taxnodesfiles() | ms_taxnodesfiles
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_taxonomychoice
ms_taxonomychoice Member List

This is the complete list of members for ms_taxonomychoice, including all inherited members.

appendExcludeTaxonomy(const int id) | ms_taxonomychoice
appendIncludeTaxonomy(const int id) | ms_taxonomychoice
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
clearExcludeTaxonomies() | ms_taxonomychoice
clearIncludeTaxonomies() | ms_taxonomychoice
copyFrom(const ms_taxonomychoice *src) | ms_taxonomychoice
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_taxonomychoice
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getExcludeTaxonomy(const int n) const | ms_taxonomychoice
getIncludeTaxonomy(const int n) const | ms_taxonomychoice
getNumberOfExcludeTaxonomies() const | ms_taxonomychoice
getNumberOfIncludeTaxonomies() const | ms_taxonomychoice
getNumberOfProperties() const | ms_customproperty
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
getTitle() const | ms_taxonomychoice
ms_customproperty() | ms_customproperty
ms_taxonomychoice() | ms_taxonomychoice
ms_taxonomychoice(const ms_taxonomychoice &src) | ms_taxonomychoice
operator=(const ms_taxonomychoice &right) | ms_taxonomychoice
setDefaultDelimiter(const char *delim) | ms_customproperty
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setTitle(const char *value) | ms_taxonomychoice
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
~ms_taxonomychoice() | ms_taxonomychoice
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_taxonomyfile
ms_taxonomyfile Member List

This is the complete list of members for ms_taxonomyfile, including all inherited members.

appendEntry(const ms_taxonomychoice *item) | ms_taxonomyfile
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
clearEntries() | ms_taxonomyfile
copyFrom(const ms_taxonomyfile *right) | ms_taxonomyfile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_taxonomyfile
getConnectionSettings() const | ms_taxonomyfile
getEntryByName(const char *name) | ms_taxonomyfile
getEntryByNumber(const int index) const | ms_taxonomyfile
getErrorHandler() const | ms_errors
getFileName() const | ms_taxonomyfile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumberOfEntries() const | ms_taxonomyfile
isValid() const | ms_errors
ms_errors() | ms_errors
ms_taxonomyfile() | ms_taxonomyfile
ms_taxonomyfile(const ms_taxonomyfile &src) | ms_taxonomyfile
ms_taxonomyfile(const char *filename, const matrix_science::ms_connection_settings *cs=0) | ms_taxonomyfile
operator=(const ms_taxonomyfile &right) | ms_taxonomyfile
read_buffer(const char *buffer) | ms_taxonomyfile
read_file() | ms_taxonomyfile
save_file() | ms_taxonomyfile
setConnectionSettings(const matrix_science::ms_connection_settings &cs) | ms_taxonomyfile
setFileName(const char *name) | ms_taxonomyfile
~ms_errors() | ms_errors
~ms_taxonomyfile() | ms_taxonomyfile
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_taxonomyrules
ms_taxonomyrules Member List

This is the complete list of members for ms_taxonomyrules, including all inherited members.

appendGencodeFile(const ms_taxnodesfiles *item) | ms_taxonomyrules
appendNoBreakDescLineIf(const char *str) | ms_taxonomyrules
appendNodesFile(const ms_taxnodesfiles *item) | ms_taxonomyrules
appendPerDbSrcRule(const ms_parserule_plus *item) | ms_taxonomyrules
appendPrefixRemove(const char *item) | ms_taxonomyrules
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendSpeciesFile(const ms_taxspeciesfiles *item) | ms_taxonomyrules
appendStrFile(const ms_taxspeciesfiles *item) | ms_taxonomyrules
appendSuffixRemove(const char *item) | ms_taxonomyrules
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
clearDBLevelTaxId() | ms_taxonomyrules
clearGencodeFiles() | ms_taxonomyrules
clearNoBreakDescLineIf() | ms_taxonomyrules
clearNodesFiles() | ms_taxonomyrules
clearPerDbSrcRules() | ms_taxonomyrules
clearPrefixRemoves() | ms_taxonomyrules
clearSpeciesFiles() | ms_taxonomyrules
clearSuffixRemoves() | ms_taxonomyrules
copyFrom(const ms_taxonomyrules *right) | ms_taxonomyrules
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_taxonomyrules
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getAccFromSpeciesLine() const | ms_taxonomyrules
getDBLevelTaxId() const | ms_taxonomyrules
getDefaultDelimiter() const | ms_customproperty
getDefaultRule() const | ms_taxonomyrules
getDelimiterByNumber(const int index) const | ms_customproperty
getDescriptionLineSep() const | ms_taxonomyrules
getDoThisRuleFirst() const | ms_taxonomyrules
getErrorLevel() const | ms_taxonomyrules
getGencodeFile(const int index) const | ms_taxonomyrules
getIdentifier() const | ms_taxonomyrules
getNoBreakDescLineIf(const int index) const | ms_taxonomyrules
getNodesFile(const int index) const | ms_taxonomyrules
getNumberOfGencodeFiles() const | ms_taxonomyrules
getNumberOfNoBreakDescLineIf() const | ms_taxonomyrules
getNumberOfNodesFiles() const | ms_taxonomyrules
getNumberOfPerDbSrcRules() const | ms_taxonomyrules
getNumberOfPrefixRemoves() const | ms_taxonomyrules
getNumberOfProperties() const | ms_customproperty
getNumberOfSpeciesFiles() const | ms_taxonomyrules
getNumberOfStrFiles() const | ms_taxonomyrules
getNumberOfSuffixRemoves() const | ms_taxonomyrules
getPerDbSrcRule(const int index) const | ms_taxonomyrules
getPreceedingComments() const | ms_customproperty
getPrefixRemove(const int index) const | ms_taxonomyrules
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
getQuickRefSearch() const | ms_taxonomyrules
getSpeciesFile(const int index) const | ms_taxonomyrules
getSpeciesFormatRegex(const TAX_SPECIES_FORMAT format) const | ms_taxonomyrules
getSrcDatabaseRule() const | ms_taxonomyrules
getStrFile(const int index) const | ms_taxonomyrules
getStrRule() const | ms_taxonomyrules
getSuffixRemove(const int index) const | ms_taxonomyrules
isConcatRefFileLines() const | ms_taxonomyrules
isDBLevelTaxId() const | ms_taxonomyrules
isEnabled() const | ms_taxonomyrules
isFromRefFile() const | ms_taxonomyrules
isMitochondrialTranslation() const | ms_taxonomyrules
isSectionAvailable() const | ms_taxonomyrules
ms_customproperty() | ms_customproperty
ms_taxonomyrules() | ms_taxonomyrules
ms_taxonomyrules(const ms_taxonomyrules &src) | ms_taxonomyrules
operator=(const ms_taxonomyrules &right) | ms_taxonomyrules
setAccFromSpeciesLine(const ms_parserule *src) | ms_taxonomyrules
setConcatRefFileLines(const bool flag) | ms_taxonomyrules
setDBLevelTaxId(const int value) | ms_taxonomyrules
setDefaultDelimiter(const char *delim) | ms_customproperty
setDefaultRule(const ms_parserule_plus *src) | ms_taxonomyrules
setDescriptionLineSep(const char value) | ms_taxonomyrules
setDoThisRuleFirst(const ms_parserule *src) | ms_taxonomyrules
setEnabled(const bool flag) | ms_taxonomyrules
setErrorLevel(const int value) | ms_taxonomyrules
setFromRefFile(const bool flag) | ms_taxonomyrules
setIdentifier(const char *str) | ms_taxonomyrules
setMitochondrialTranslation(const bool flag) | ms_taxonomyrules
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setQuickRefSearch(const char *str) | ms_taxonomyrules
setSectionAvailable(const bool value) | ms_taxonomyrules
setSpeciesFormatRegex(const TAX_SPECIES_FORMAT format, const std::string regex) | ms_taxonomyrules
setSrcDatabaseRule(const ms_parserule *src) | ms_taxonomyrules
setStrRule(const ms_parserule_plus *src) | ms_taxonomyrules
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
~ms_taxonomyrules() | ms_taxonomyrules
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_taxonomytree
ms_taxonomytree Member List

This is the complete list of members for ms_taxonomytree, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_taxonomytree *right) | ms_taxonomytree
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getParent(const int id, int &ttParent, int &ttGenTable) const | ms_taxonomytree
getTaxIDArray() | ms_taxonomytree
isIncludedIn(const int id, const ms_taxonomychoice *choice) const | ms_taxonomytree
isSpeciesDescendantOf(const int parentID, const int id) const | ms_taxonomytree
isValid() const | ms_errors
ms_errors() | ms_errors
ms_taxonomytree(const ms_taxonomyrules *taxonomyRules, const char *taxonomyDirectory="../taxonomy", const bool useIndex=true, const bool createList=false, const char *preparingDirectory="../taxonomy/preparing", const char *oldDirectory="../taxonomy/old") | ms_taxonomytree
ms_taxonomytree(const ms_taxonomytree &src) | ms_taxonomytree
operator=(const ms_taxonomytree &right) | ms_taxonomytree
~ms_errors() | ms_errors
~ms_taxonomytree() | ms_taxonomytree
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_taxspeciesfiles
ms_taxspeciesfiles Member List

This is the complete list of members for ms_taxspeciesfiles, including all inherited members.

copyFrom(const ms_taxspeciesfiles *right) | ms_taxspeciesfiles
defaultValues() | ms_taxspeciesfiles
getFileName() const | ms_taxspeciesfiles
getFormat() const | ms_taxspeciesfiles
ms_taxspeciesfiles() | ms_taxspeciesfiles
ms_taxspeciesfiles(const ms_taxspeciesfiles &src) | ms_taxspeciesfiles
operator=(const ms_taxspeciesfiles &right) | ms_taxspeciesfiles
setFileName(const char *name) | ms_taxspeciesfiles
setFormat(const TAX_SPECIES_FORMAT value) | ms_taxspeciesfiles
~ms_taxspeciesfiles() | ms_taxspeciesfiles
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_tinycdb
ms_tinycdb Member List

This is the complete list of members for ms_tinycdb, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
closeIndexFile() | ms_tinycdb
copyFrom(const ms_errors *right) | ms_errors
finishCreate() | ms_tinycdb
getAllValuesFromKey(const std::string &keyName) | ms_tinycdb
getErrorHandler() const | ms_errors
getFileOffsetFromKey(const std::string &keyName) | ms_tinycdb
getIndexFileName() const | ms_tinycdb
getIntFromKey(const std::string &keyName) | ms_tinycdb
getIntFromKey(const std::string &keyName, bool &found) | ms_tinycdb
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getValueFromKey(const std::string &keyName, const int count=0) | ms_tinycdb
isCreating() const | ms_tinycdb
isOpenForReading() const | ms_tinycdb
isPossibleToCreate() const | ms_tinycdb
isValid() const | ms_errors
makeExists(const char *key) const | ms_tinycdb
ms_errors() | ms_errors
ms_tinycdb(const char *indexFileName, const char *versionNumber, const char *sourceFileName) | ms_tinycdb
openIndexFile(const bool mayRetryBuilding) | ms_tinycdb
prepareToCreate() | ms_tinycdb
saveFileOffsetForKey(const std::string &keyName, OFFSET64_T offset) | ms_tinycdb
saveIntForKey(const std::string &keyName, int value) | ms_tinycdb
saveValueForKey(const char *keyName, const char *value, const unsigned int keyNameLen=0, const unsigned int valueLen=0) | ms_tinycdb
setIndexFileName(const char *filename) | ms_tinycdb
~ms_errors() | ms_errors
~ms_tinycdb() | ms_tinycdb
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_treecluster
ms_treecluster Member List

This is the complete list of members for ms_treecluster, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
cluster(TREE_CLUSTER_DISTANCE tcd, ms_mascotresults::TREE_CLUSTER_METHOD tcm, const std::vector< double > &weight, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, bool transpose=false) | ms_treecluster
copyFrom(const ms_treecluster *right) | ms_treecluster
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_treecluster
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
isValid() const | ms_errors
ms_errors() | ms_errors
ms_treecluster(int rows, int columns) | ms_treecluster
ms_treecluster(const ms_treecluster &right) | ms_treecluster
operator=(const ms_treecluster &right) | ms_treecluster
setRow(int row, std::vector< double > datarow, std::vector< int > maskrow) | ms_treecluster
TCD_ABS_CORRELATION enum value | ms_treecluster
TCD_ABS_UNCENTERED_CORRELATION enum value | ms_treecluster
TCD_CITY_BLOCK enum value | ms_treecluster
TCD_CORRELATION enum value | ms_treecluster
TCD_EUCLIDEAN enum value | ms_treecluster
TCD_KENDALLS_TAU_CORRELATION enum value | ms_treecluster
TCD_SPEARMANS_RANK_CORRELATION enum value | ms_treecluster
TCD_UNCENTERED_CORRELATION enum value | ms_treecluster
TREE_CLUSTER_DISTANCE enum name | ms_treecluster
~ms_errors() | ms_errors
~ms_treecluster() | ms_treecluster
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_umod_aminoacid
ms_umod_aminoacid Member List

This is the complete list of members for ms_umod_aminoacid, including all inherited members.

appendElemRef(const ms_umod_elemref *elemref) | ms_umod_aminoacid |
clearElemRefs() | ms_umod_aminoacid |
copyFrom(const ms_umod_aminoacid *right) | ms_umod_aminoacid |
defaultValues() | ms_umod_aminoacid |
deleteElemRef(const int idx) | ms_umod_aminoacid |
dropAvgeMass() | ms_umod_aminoacid |
dropFullName() | ms_umod_aminoacid |
dropMonoMass() | ms_umod_aminoacid |
dropThreeLetter() | ms_umod_aminoacid |
dropTitle() | ms_umod_aminoacid |
getAvgeMass() const | ms_umod_aminoacid |
getAvgeMassSchemaType() const | ms_umod_aminoacid |
getElemRef(const int idx) const | ms_umod_aminoacid |
getElemRefSchemaType() const | ms_umod_aminoacid |
getFullName() const | ms_umod_aminoacid |
getFullNameSchemaType() const | ms_umod_aminoacid |
getMonoMass() const | ms_umod_aminoacid |
getMonoMassSchemaType() const | ms_umod_aminoacid |
getNumberOfElemRefs() const | ms_umod_aminoacid |
getSchemaType() const | ms_umod_aminoacid | virtual
getThreeLetter() const | ms_umod_aminoacid |
getThreeLetterSchemaType() const | ms_umod_aminoacid |
getTitle() const | ms_umod_aminoacid |
getTitleSchemaType() const | ms_umod_aminoacid |
haveAvgeMass() const | ms_umod_aminoacid |
haveFullName() const | ms_umod_aminoacid |
haveMonoMass() const | ms_umod_aminoacid |
haveThreeLetter() const | ms_umod_aminoacid |
haveTitle() const | ms_umod_aminoacid |
ms_umod_aminoacid() | ms_umod_aminoacid |
ms_umod_aminoacid(const ms_umod_aminoacid &src) | ms_umod_aminoacid |
operator=(const ms_umod_aminoacid &right) | ms_umod_aminoacid |
setAvgeMass(const double value) | ms_umod_aminoacid |
setFullName(const char *value) | ms_umod_aminoacid |
setMonoMass(const double value) | ms_umod_aminoacid |
setThreeLetter(const char *value) | ms_umod_aminoacid |
setTitle(const char *value) | ms_umod_aminoacid |
updateElemRef(const int idx, const ms_umod_elemref *elemref) | ms_umod_aminoacid |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_aminoacid | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_aminoacid | virtual
~ms_umod_aminoacid() | ms_umod_aminoacid | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_umod_composition
ms_umod_composition Member List

This is the complete list of members for ms_umod_composition, including all inherited members.

appendElemRef(const ms_umod_elemref *elemref) | ms_umod_composition |
clearElemRefs() | ms_umod_composition |
copyFrom(const ms_umod_composition *right) | ms_umod_composition |
copyFrom(const ms_quant_composition *right, const ms_umod_configfile &umodFile) | ms_umod_composition |
defaultValues() | ms_umod_composition |
deleteElemRef(const int idx) | ms_umod_composition |
dropAvgeMass() | ms_umod_composition |
dropCompositionString() | ms_umod_composition |
dropMonoMass() | ms_umod_composition |
getAvgeMass() const | ms_umod_composition |
getAvgeMassSchemaType() const | ms_umod_composition |
getCompositionString() const | ms_umod_composition |
getCompositionStringSchemaType() const | ms_umod_composition |
getElemRef(const int idx) const | ms_umod_composition |
getElemRefSchemaType() const | ms_umod_composition |
getMonoMass() const | ms_umod_composition |
getMonoMassSchemaType() const | ms_umod_composition |
getNumberOfElemRefs() const | ms_umod_composition |
getSchemaType() const | ms_umod_composition | virtual
haveAvgeMass() const | ms_umod_composition |
haveCompositionString() const | ms_umod_composition |
haveMonoMass() const | ms_umod_composition |
isSameAs(const ms_umod_composition &right) const | ms_umod_composition |
ms_umod_composition() | ms_umod_composition |
ms_umod_composition(const ms_umod_composition &src) | ms_umod_composition |
ms_umod_composition(const ms_quant_composition &src, const ms_umod_configfile &umodFile) | ms_umod_composition |
operator=(const ms_umod_composition &right) | ms_umod_composition |
setAvgeMass(const double value) | ms_umod_composition |
setCompositionString(const char *value) | ms_umod_composition |
setMonoMass(const double value) | ms_umod_composition |
updateElemRef(const int idx, const ms_umod_elemref *elemref) | ms_umod_composition |
updateMasses(const ms_umod_configfile &umodFile, const ms_quant_component &quantComp) | ms_umod_composition |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_composition | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_composition | virtual
~ms_umod_composition() | ms_umod_composition | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_umod_configfile
ms_umod_configfile Member List

This is the complete list of members for ms_umod_configfile, including all inherited members.

appendAminoAcid(const ms_umod_aminoacid *aa) | ms_umod_configfile |
appendElement(const ms_umod_element *elem) | ms_umod_configfile |
appendErrors(const ms_errors &src) | ms_errors |
appendModBrick(const ms_umod_modbrick *brick) | ms_umod_configfile |
appendModification(const ms_umod_modification *mod) | ms_umod_configfile |
applyVisibility(const ms_session *session) | ms_umod_configfile |
applyVisibility(const std::vector< int > &groupIds) | ms_umod_configfile |
clearAllErrors() | ms_errors |
clearAminoAcids() | ms_umod_configfile |
clearElements() | ms_umod_configfile |
clearModBricks() | ms_umod_configfile |
clearModifications() | ms_umod_configfile |
copyFrom(const ms_umod_configfile *right) | ms_umod_configfile |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
defaultValues() | ms_umod_configfile | virtual
deleteAminoAcidByName(const char *name) | ms_umod_configfile |
deleteAminoAcidByNumber(const int idx) | ms_umod_configfile |
deleteElementByName(const char *name) | ms_umod_configfile |
deleteElementByNumber(const int idx) | ms_umod_configfile |
deleteModBrickByName(const char *name) | ms_umod_configfile |
deleteModBrickByNumber(const int idx) | ms_umod_configfile |
deleteModificationByName(const char *name) | ms_umod_configfile |
deleteModificationByNumber(const int idx) | ms_umod_configfile |
findModFileName(const char *modFileName) const | ms_umod_configfile |
findModification(const char *modName) const | ms_umod_configfile |
getAminoAcidByName(const char *name) const | ms_umod_configfile |
getAminoAcidByNumber(const int idx) const | ms_umod_configfile |
getConnectionSettings() const | ms_umod_configfile |
getDefaultSchemaFileName() | ms_umod_configfile | static
getElementByName(const char *name) const | ms_umod_configfile |
getElementByNumber(const int idx) const | ms_umod_configfile |
getErrorHandler() const | ms_errors |
getFileName() const | ms_umod_configfile |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMajorVersion() const | ms_umod_configfile |
getMinorVersion() const | ms_umod_configfile |
getModBrickByName(const char *name) const | ms_umod_configfile |
getModBrickByNumber(const int idx) const | ms_umod_configfile |
getModFileList(const unsigned int flags=MODFILE_FLAGS_ALL) const | ms_umod_configfile |
getModificationByName(const char *name) const | ms_umod_configfile |
getModificationByNumber(const int idx) const | ms_umod_configfile |
getNumberOfAminoAcids() const | ms_umod_configfile |
getNumberOfElements() const | ms_umod_configfile |
getNumberOfModBricks() const | ms_umod_configfile |
getNumberOfModifications() const | ms_umod_configfile |
getSchemaFileName() const | ms_umod_configfile |
isValid() const | ms_errors |
MODFILE_FLAGS enum name | ms_umod_configfile |
MODFILE_FLAGS_AASUBST enum value | ms_umod_configfile |
MODFILE_FLAGS_ALL enum value | ms_umod_configfile |
MODFILE_FLAGS_EMPTY enum value | ms_umod_configfile |
MODFILE_FLAGS_HIDDEN enum value | ms_umod_configfile |
MODFILE_FLAGS_REGULAR enum value | ms_umod_configfile |
ms_errors() | ms_errors |
ms_umod_configfile() | ms_umod_configfile |
ms_umod_configfile(const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0, bool useSchema=true) | ms_umod_configfile |
ms_umod_configfile(const ms_umod_configfile &right) | ms_umod_configfile |
operator=(const ms_umod_configfile &right) | ms_umod_configfile |
read_buffer(const char *buffer) | ms_umod_configfile |
read_file() | ms_umod_configfile |
save_buffer(bool validateAgainstSchema=true) | ms_umod_configfile |
save_file() | ms_umod_configfile |
setConnectionSettings(const ms_connection_settings &cs) | ms_umod_configfile |
setFileName(const char *filename) | ms_umod_configfile |
setMajorVersion(const std::string &version) | ms_umod_configfile |
setMinorVersion(const std::string &version) | ms_umod_configfile |
setSchemaFileName(const char *name) | ms_umod_configfile |
updateAminoAcidByName(const char *name, const ms_umod_aminoacid *aa) | ms_umod_configfile |
updateAminoAcidByNumber(const int idx, const ms_umod_aminoacid *aa) | ms_umod_configfile |
updateElementByName(const char *name, const ms_umod_element *element) | ms_umod_configfile |
updateElementByNumber(const int idx, const ms_umod_element *element) | ms_umod_configfile |
updateMasses() | ms_umod_configfile |
updateModBrickByName(const char *name, const ms_umod_modbrick *brick) | ms_umod_configfile |
updateModBrickByNumber(const int idx, const ms_umod_modbrick *brick) | ms_umod_configfile |
updateModificationByName(const char *name, const ms_umod_modification *mod) | ms_umod_configfile |
updateModificationByNumber(const int idx, const ms_umod_modification *mod) | ms_umod_configfile |
validateDocument() const | ms_umod_configfile |
~ms_errors() | ms_errors |
~ms_umod_configfile() | ms_umod_configfile | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_umod_element
ms_umod_element Member List

This is the complete list of members for ms_umod_element, including all inherited members.

copyFrom(const ms_umod_element *right) | ms_umod_element |
defaultValues() | ms_umod_element |
dropAvgeMass() | ms_umod_element |
dropFullName() | ms_umod_element |
dropMonoMass() | ms_umod_element |
dropTitle() | ms_umod_element |
getAvgeMass() const | ms_umod_element |
getAvgeMassAsNumber() const | ms_umod_element |
getAvgeMassSchemaType() const | ms_umod_element |
getFullName() const | ms_umod_element |
getFullNameSchemaType() const | ms_umod_element |
getMonoMass() const | ms_umod_element |
getMonoMassAsNumber() const | ms_umod_element |
getMonoMassSchemaType() const | ms_umod_element |
getSchemaType() const | ms_umod_element | virtual
getTitle() const | ms_umod_element |
getTitleSchemaType() const | ms_umod_element |
haveAvgeMass() const | ms_umod_element |
haveFullName() const | ms_umod_element |
haveMonoMass() const | ms_umod_element |
haveTitle() const | ms_umod_element |
ms_umod_element() | ms_umod_element |
ms_umod_element(const ms_umod_element &src) | ms_umod_element |
operator=(const ms_umod_element &right) | ms_umod_element |
setAvgeMass(const char *value, ms_errs *err=NULL) | ms_umod_element |
setFullName(const char *value) | ms_umod_element |
setMonoMass(const char *value, ms_errs *err=NULL) | ms_umod_element |
setTitle(const char *value) | ms_umod_element |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_element | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_element | virtual
~ms_umod_element() | ms_umod_element | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_umod_elemref
ms_umod_elemref Member List

This is the complete list of members for ms_umod_elemref, including all inherited members.

copyFrom(const ms_umod_elemref *right) | ms_umod_elemref |
copyFrom(const ms_quant_element *right) | ms_umod_elemref |
defaultValues() | ms_umod_elemref |
dropNumber() | ms_umod_elemref |
dropSymbol() | ms_umod_elemref |
getNumber() const | ms_umod_elemref |
getNumberSchemaType() const | ms_umod_elemref |
getSchemaType() const | ms_umod_elemref | virtual
getSymbol() const | ms_umod_elemref |
getSymbolSchemaType() const | ms_umod_elemref |
haveNumber() const | ms_umod_elemref |
haveSymbol() const | ms_umod_elemref |
ms_umod_elemref() | ms_umod_elemref |
ms_umod_elemref(const ms_umod_elemref &src) | ms_umod_elemref |
ms_umod_elemref(const ms_quant_element &src) | ms_umod_elemref |
operator=(const ms_umod_elemref &right) | ms_umod_elemref |
setNumber(const int value) | ms_umod_elemref |
setSymbol(const char *value) | ms_umod_elemref |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_elemref | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_elemref | virtual
~ms_umod_elemref() | ms_umod_elemref | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_umod_modbrick
ms_umod_modbrick Member List

This is the complete list of members for ms_umod_modbrick, including all inherited members.

appendElemRef(const ms_umod_elemref *elemref) | ms_umod_modbrick |
clearElemRefs() | ms_umod_modbrick |
copyFrom(const ms_umod_modbrick *right) | ms_umod_modbrick |
defaultValues() | ms_umod_modbrick |
deleteElemRef(const int idx) | ms_umod_modbrick |
dropAvgeMass() | ms_umod_modbrick |
dropFullName() | ms_umod_modbrick |
dropMonoMass() | ms_umod_modbrick |
dropTitle() | ms_umod_modbrick |
getAvgeMass() const | ms_umod_modbrick |
getAvgeMassSchemaType() const | ms_umod_modbrick |
getElemRef(const int idx) const | ms_umod_modbrick |
getElemRefSchemaType() const | ms_umod_modbrick |
getFullName() const | ms_umod_modbrick |
getFullNameSchemaType() const | ms_umod_modbrick |
getMonoMass() const | ms_umod_modbrick |
getMonoMassSchemaType() const | ms_umod_modbrick |
getNumberOfElemRefs() const | ms_umod_modbrick |
getSchemaType() const | ms_umod_modbrick | virtual
getTitle() const | ms_umod_modbrick |
getTitleSchemaType() const | ms_umod_modbrick |
haveAvgeMass() const | ms_umod_modbrick |
haveFullName() const | ms_umod_modbrick |
haveMonoMass() const | ms_umod_modbrick |
haveTitle() const | ms_umod_modbrick |
ms_umod_modbrick() | ms_umod_modbrick |
ms_umod_modbrick(const ms_umod_modbrick &src) | ms_umod_modbrick |
operator=(const ms_umod_modbrick &right) | ms_umod_modbrick |
setAvgeMass(const double value) | ms_umod_modbrick |
setFullName(const char *value) | ms_umod_modbrick |
setMonoMass(const double value) | ms_umod_modbrick |
setTitle(const char *value) | ms_umod_modbrick |
updateElemRef(const int idx, const ms_umod_elemref *elemref) | ms_umod_modbrick |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_modbrick | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_modbrick | virtual
~ms_umod_modbrick() | ms_umod_modbrick | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_umod_modification
ms_umod_modification Member List

This is the complete list of members for ms_umod_modification, including all inherited members.

appendAltName(const char *alt_name) | ms_umod_modification |
appendIgnore(const ms_umod_composition *ignore) | ms_umod_modification |
appendSpecificity(const ms_umod_specificity *specificity) | ms_umod_modification |
appendXref(const ms_umod_xref *xref) | ms_umod_modification |
clearAltNames() | ms_umod_modification |
clearIgnores() | ms_umod_modification |
clearSpecificities() | ms_umod_modification |
clearXrefs() | ms_umod_modification |
copyFrom(const ms_umod_modification *right) | ms_umod_modification |
copyFrom(const ms_quant_localdef *right, const ms_umod_configfile &umodFile) | ms_umod_modification |
copyFrom(const ms_quant_unmodified *right) | ms_umod_modification |
defaultValues() | ms_umod_modification |
deleteAltName(const int idx) | ms_umod_modification |
deleteIgnore(const int idx) | ms_umod_modification |
deleteSpecificity(const int idx) | ms_umod_modification |
deleteXref(const int idx) | ms_umod_modification |
dropApproved() | ms_umod_modification |
dropDateTimeModified() | ms_umod_modification |
dropDateTimePosted() | ms_umod_modification |
dropDelta() | ms_umod_modification |
dropFullName() | ms_umod_modification |
dropGroupOfPoster() | ms_umod_modification |
dropMiscNotes() | ms_umod_modification |
dropRecordID() | ms_umod_modification |
dropTitle() | ms_umod_modification |
dropUsernameOfPoster() | ms_umod_modification |
findSpecGroup(const char *modFileName) const | ms_umod_modification |
getAltName(const int idx) const | ms_umod_modification |
getAltNameSchemaType() const | ms_umod_modification |
getApprovedSchemaType() const | ms_umod_modification |
getDateTimeModified() const | ms_umod_modification |
getDateTimeModifiedSchemaType() const | ms_umod_modification |
getDateTimePosted() const | ms_umod_modification |
getDateTimePostedSchemaType() const | ms_umod_modification |
getDelta() const | ms_umod_modification |
getDeltaSchemaType() const | ms_umod_modification |
getFullName() const | ms_umod_modification |
getFullNameSchemaType() const | ms_umod_modification |
getGroupOfPoster() const | ms_umod_modification |
getGroupOfPosterSchemaType() const | ms_umod_modification |
getIgnore(const int idx) const | ms_umod_modification |
getIgnoreSchemaType() const | ms_umod_modification |
getMiscNotes() const | ms_umod_modification |
getMiscNotesSchemaType() const | ms_umod_modification |
getModFileList(const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL) const | ms_umod_modification |
getNumberOfAltNames() const | ms_umod_modification |
getNumberOfIgnores() const | ms_umod_modification |
getNumberOfSpecificities() const | ms_umod_modification |
getNumberOfXrefs() const | ms_umod_modification |
getRecordID() const | ms_umod_modification |
getRecordIDSchemaType() const | ms_umod_modification |
getSchemaType() const | ms_umod_modification | virtual
getSpecificity(const int idx) const | ms_umod_modification |
getSpecificityBySite(const char *site) const | ms_umod_modification |
getSpecificityBySiteAndPosition(const char *site, const char *position) const | ms_umod_modification |
getSpecificitySchemaType() const | ms_umod_modification |
getTitle() const | ms_umod_modification |
getTitleSchemaType() const | ms_umod_modification |
getUsernameOfPoster() const | ms_umod_modification |
getUsernameOfPosterSchemaType() const | ms_umod_modification |
getXref(const int idx) const | ms_umod_modification |
getXrefSchemaType() const | ms_umod_modification |
haveApproved() const | ms_umod_modification |
haveDateTimeModified() const | ms_umod_modification |
haveDateTimePosted() const | ms_umod_modification |
haveDelta() const | ms_umod_modification |
haveFullName() const | ms_umod_modification |
haveGroupOfPoster() const | ms_umod_modification |
haveMiscNotes() const | ms_umod_modification |
haveRecordID() const | ms_umod_modification |
haveTitle() const | ms_umod_modification |
haveUsernameOfPoster() const | ms_umod_modification |
isApproved() const | ms_umod_modification |
isPrivacyEnabled() const | ms_umod_modification |
isPrivate() const | ms_umod_modification |
isSameAs(const ms_umod_modification &right_mod) const | ms_umod_modification |
ms_umod_modification() | ms_umod_modification |
ms_umod_modification(const ms_umod_modification &src) | ms_umod_modification |
ms_umod_modification(const ms_quant_localdef &src, const ms_umod_configfile &umodFile) | ms_umod_modification |
ms_umod_modification(const ms_quant_unmodified &src) | ms_umod_modification |
operator=(const ms_umod_modification &right) | ms_umod_modification |
setApproved(const bool value) | ms_umod_modification |
setDateTimeModified(const char *value) | ms_umod_modification |
setDateTimePosted(const char *value) | ms_umod_modification |
setDelta(const ms_umod_composition *delta) | ms_umod_modification |
setFullName(const char *value) | ms_umod_modification |
setGroupOfPoster(const char *value) | ms_umod_modification |
setMiscNotes(const char *value) | ms_umod_modification |
setPrivacyEnabled(bool b) | ms_umod_modification |
setPrivate(bool b) | ms_umod_modification |
setRecordID(const char *value) | ms_umod_modification |
setTitle(const char *value) | ms_umod_modification |
setUsernameOfPoster(const char *value) | ms_umod_modification |
updateAltName(const int idx, const char *alt_name) | ms_umod_modification |
updateIgnore(const int idx, const ms_umod_composition *ignore) | ms_umod_modification |
updateMasses(const ms_umod_configfile &umodFile, const ms_quant_component &quantComp) | ms_umod_modification |
updateSpecificity(const int idx, const ms_umod_specificity *specificity) | ms_umod_modification |
updateXref(const int idx, const ms_umod_xref *xref) | ms_umod_modification |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_modification | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_modification | virtual
~ms_umod_modification() | ms_umod_modification | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_umod_neutralloss
ms_umod_neutralloss Member List

This is the complete list of members for ms_umod_neutralloss, including all inherited members.

appendElemRef(const ms_umod_elemref *elemref) | ms_umod_composition |
clearElemRefs() | ms_umod_composition |
copyFrom(const ms_umod_neutralloss *right) | ms_umod_neutralloss |
copyFrom(const ms_quant_neutralloss *right, const ms_umod_configfile &umodFile) | ms_umod_neutralloss |
copyFrom(const ms_quant_pepneutralloss *right, const ms_umod_configfile &umodFile) | ms_umod_neutralloss |
matrix_science::ms_umod_composition::copyFrom(const ms_umod_composition *right) | ms_umod_composition |
matrix_science::ms_umod_composition::copyFrom(const ms_quant_composition *right, const ms_umod_configfile &umodFile) | ms_umod_composition |
defaultValues() | ms_umod_neutralloss |
deleteElemRef(const int idx) | ms_umod_composition |
dropAvgeMass() | ms_umod_composition |
dropCode() | ms_umod_neutralloss |
dropCompositionString() | ms_umod_composition |
dropDescription() | ms_umod_neutralloss |
dropFlag() | ms_umod_neutralloss |
dropMonoMass() | ms_umod_composition |
dropPairsWith() | ms_umod_neutralloss |
getAvgeMass() const | ms_umod_composition |
getAvgeMassSchemaType() const | ms_umod_composition |
getCode() const | ms_umod_neutralloss |
getCodeSchemaType() const | ms_umod_neutralloss |
getCompositionString() const | ms_umod_composition |
getCompositionStringSchemaType() const | ms_umod_composition |
getDescription() const | ms_umod_neutralloss |
getDescriptionSchemaType() const | ms_umod_neutralloss |
getElemRef(const int idx) const | ms_umod_composition |
getElemRefSchemaType() const | ms_umod_composition |
getFlagSchemaType() const | ms_umod_neutralloss |
getMonoMass() const | ms_umod_composition |
getMonoMassSchemaType() const | ms_umod_composition |
getNumberOfElemRefs() const | ms_umod_composition |
getPairsWith() const | ms_umod_neutralloss |
getPairsWithSchemaType() const | ms_umod_neutralloss |
getSchemaType() const | ms_umod_neutralloss | virtual
haveAvgeMass() const | ms_umod_composition |
haveCode() const | ms_umod_neutralloss |
haveCompositionString() const | ms_umod_composition |
haveDescription() const | ms_umod_neutralloss |
haveFlag() const | ms_umod_neutralloss |
haveMonoMass() const | ms_umod_composition |
havePairsWith() const | ms_umod_neutralloss |
isFlag() const | ms_umod_neutralloss |
isSameAs(const ms_umod_composition &right) const | ms_umod_composition |
ms_umod_composition() | ms_umod_composition |
ms_umod_composition(const ms_umod_composition &src) | ms_umod_composition |
ms_umod_composition(const ms_quant_composition &src, const ms_umod_configfile &umodFile) | ms_umod_composition |
ms_umod_neutralloss() | ms_umod_neutralloss |
ms_umod_neutralloss(const ms_umod_neutralloss &src) | ms_umod_neutralloss |
ms_umod_neutralloss(const ms_quant_neutralloss &src, const ms_umod_configfile &umodFile) | ms_umod_neutralloss |
ms_umod_neutralloss(const ms_quant_pepneutralloss &src, const ms_umod_configfile &umodFile) | ms_umod_neutralloss |
operator=(const ms_umod_neutralloss &right) | ms_umod_neutralloss |
matrix_science::ms_umod_composition::operator=(const ms_umod_composition &right) | ms_umod_composition |
setAvgeMass(const double value) | ms_umod_composition |
setCode(const char *value) | ms_umod_neutralloss |
setCompositionString(const char *value) | ms_umod_composition |
setDescription(const char *value) | ms_umod_neutralloss |
setFlag(const bool value) | ms_umod_neutralloss |
setMonoMass(const double value) | ms_umod_composition |
setPairsWith(const char *value) | ms_umod_neutralloss |
updateElemRef(const int idx, const ms_umod_elemref *elemref) | ms_umod_composition |
updateMasses(const ms_umod_configfile &umodFile, const ms_quant_component &quantComp) | ms_umod_composition |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_neutralloss | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_neutralloss | virtual
~ms_umod_composition() | ms_umod_composition | virtual
~ms_umod_neutralloss() | ms_umod_neutralloss | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_umod_specificity
ms_umod_specificity Member List

This is the complete list of members for ms_umod_specificity, including all inherited members.

appendNeutralLoss(const ms_umod_neutralloss *nl) | ms_umod_specificity |
appendPepNeutralLoss(const ms_umod_neutralloss *pnl) | ms_umod_specificity |
clearNeutralLosses() | ms_umod_specificity |
clearPepNeutralLosses() | ms_umod_specificity |
copyFrom(const ms_umod_specificity *right) | ms_umod_specificity |
copyFrom(const ms_quant_specificity *right, const ms_umod_configfile &umodFile) | ms_umod_specificity |
defaultValues() | ms_umod_specificity |
deleteNeutralLoss(const int idx) | ms_umod_specificity |
deletePepNeutralLoss(const int idx) | ms_umod_specificity |
dropClassification() | ms_umod_specificity |
dropHidden() | ms_umod_specificity |
dropMiscNotes() | ms_umod_specificity |
dropPosition() | ms_umod_specificity |
dropSite() | ms_umod_specificity |
dropSpecGroup() | ms_umod_specificity |
getClassification() const | ms_umod_specificity |
getClassificationSchemaType() const | ms_umod_specificity |
getHiddenSchemaType() const | ms_umod_specificity |
getMiscNotes() const | ms_umod_specificity |
getMiscNotesSchemaType() const | ms_umod_specificity |
getNeutralLoss(const int idx) const | ms_umod_specificity |
getNeutralLossSchemaType() const | ms_umod_specificity |
getNumberOfNeutralLosses() const | ms_umod_specificity |
getNumberOfPepNeutralLosses() const | ms_umod_specificity |
getPepNeutralLoss(const int idx) const | ms_umod_specificity |
getPepNeutralLossSchemaType() const | ms_umod_specificity |
getPosition() const | ms_umod_specificity |
getPositionSchemaType() const | ms_umod_specificity |
getSchemaType() const | ms_umod_specificity | virtual
getSite() const | ms_umod_specificity |
getSiteSchemaType() const | ms_umod_specificity |
getSpecGroup() const | ms_umod_specificity |
getSpecGroupSchemaType() const | ms_umod_specificity |
haveClassification() const | ms_umod_specificity |
haveHidden() const | ms_umod_specificity |
haveMiscNotes() const | ms_umod_specificity |
havePosition() const | ms_umod_specificity |
haveSite() const | ms_umod_specificity |
haveSpecGroup() const | ms_umod_specificity |
inErrorTolerant() const | ms_umod_specificity |
inLongList() const | ms_umod_specificity |
inShortList() const | ms_umod_specificity |
isHidden() const | ms_umod_specificity |
isSameAs(const ms_umod_specificity &right) const | ms_umod_specificity |
ms_umod_specificity() | ms_umod_specificity |
ms_umod_specificity(const ms_umod_specificity &src) | ms_umod_specificity |
ms_umod_specificity(const ms_quant_specificity &src, const ms_umod_configfile &umodFile) | ms_umod_specificity |
operator=(const ms_umod_specificity &right) | ms_umod_specificity |
setClassification(const char *value) | ms_umod_specificity |
setHidden(const bool value) | ms_umod_specificity |
setMiscNotes(const char *value) | ms_umod_specificity |
setPosition(const char *value) | ms_umod_specificity |
setSite(const char *value) | ms_umod_specificity |
setSpecGroup(const int value) | ms_umod_specificity |
showInLongList(bool b) | ms_umod_specificity |
showInShortList(bool b) | ms_umod_specificity |
updateNeutralLoss(const int idx, const ms_umod_neutralloss *nl) | ms_umod_specificity |
updatePepNeutralLoss(const int idx, const ms_umod_neutralloss *pnl) | ms_umod_specificity |
useInErrorTolerant(bool b) | ms_umod_specificity |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_specificity | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_specificity | virtual
~ms_umod_specificity() | ms_umod_specificity | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_umod_xref
ms_umod_xref Member List

This is the complete list of members for ms_umod_xref, including all inherited members.

copyFrom(const ms_umod_xref *right) | ms_umod_xref |
defaultValues() | ms_umod_xref |
dropSource() | ms_umod_xref |
dropText() | ms_umod_xref |
dropUrl() | ms_umod_xref |
getSchemaType() const | ms_umod_xref | virtual
getSource() const | ms_umod_xref |
getSourceSchemaType() const | ms_umod_xref |
getText() const | ms_umod_xref |
getTextSchemaType() const | ms_umod_xref |
getUrl() const | ms_umod_xref |
getUrlSchemaType() const | ms_umod_xref |
haveSource() const | ms_umod_xref |
haveText() const | ms_umod_xref |
haveUrl() const | ms_umod_xref |
isSameAs(const ms_umod_xref &right) const | ms_umod_xref |
ms_umod_xref() | ms_umod_xref |
ms_umod_xref(const ms_umod_xref &src) | ms_umod_xref |
operator=(const ms_umod_xref &right) | ms_umod_xref |
setSource(const char *value) | ms_umod_xref |
setText(const char *value) | ms_umod_xref |
setUrl(const char *value) | ms_umod_xref |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_xref | virtual
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_xref | virtual
~ms_umod_xref() | ms_umod_xref | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_unigene
ms_unigene Member List

This is the complete list of members for ms_unigene, including all inherited members.

addAccessionUnigenePair(const ms_unigene_entry *unigene, const std::string &accession) | ms_unigene | protected
findEntry(const char *id)=0 | ms_unigene | pure virtual
getUnigeneForAccession(const std::string accession, const int index)=0 | ms_unigene | pure virtual
ms_unigene(const ms_mascotresfilebase &resfile, const char *filename) | ms_unigene |
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_unigene_entry
ms_unigene_entry Member List

This is the complete list of members for ms_unigene_entry, including all inherited members.

getChromosome() const | ms_unigene_entry | inline
getCytoBand() const | ms_unigene_entry | inline
getExpress() const | ms_unigene_entry | inline
getFileOffset() const | ms_unigene_entry | inline
getGene() const | ms_unigene_entry | inline
getID() const | ms_unigene_entry | inline
getLocusLink() const | ms_unigene_entry | inline
getNumAccessions() const | ms_unigene_entry | inline
getTitle() const | ms_unigene_entry | inline
ms_unigene_entry(FILE *f, ms_unigene &unigene) | ms_unigene_entry |
ms_unigene_entry(const std::string &id, const std::string &title, const std::string &gene, const std::string &cytoBand, const std::string &locusLink, const std::string &express, const long chromosome, const int numAccessions, const OFFSET64_T fileOffset) | ms_unigene_entry |
~ms_unigene_entry() | ms_unigene_entry |
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_unigeneoptions
ms_unigeneoptions Member List

This is the complete list of members for ms_unigeneoptions, including all inherited members.

appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty |
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty |
copyFrom(const ms_unigeneoptions *right) | ms_unigeneoptions |
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty |
defaultValues() | ms_unigeneoptions | virtual
delNonEmpty() | ms_customproperty |
delProp(const char *name) | ms_customproperty |
delPropByNumber(const int index) | ms_customproperty |
delPropStart(const char *nameBeginning) | ms_customproperty |
findProperty(const char *name, const int startFrom=0) const | ms_customproperty |
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty |
getDefaultDelimiter() const | ms_customproperty |
getDelimiterByNumber(const int index) const | ms_customproperty |
getNumberOfProperties() const | ms_customproperty |
getPreceedingComments() const | ms_customproperty |
getPropertyName(const int index) const | ms_customproperty |
getPropValStringByName(const char *name) const | ms_customproperty |
getPropValStringByNumber(const int index) const | ms_customproperty |
isSectionAvailable() const | ms_unigeneoptions |
ms_customproperty() | ms_customproperty |
ms_unigeneoptions() | ms_unigeneoptions |
ms_unigeneoptions(const ms_unigeneoptions &src) | ms_unigeneoptions |
operator=(const ms_unigeneoptions &right) | ms_unigeneoptions |
setDefaultDelimiter(const char *delim) | ms_customproperty |
setPreceedingComments(const std::string &comments) | ms_customproperty |
setPropertyName(const int index, const char *name) | ms_customproperty |
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty |
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty |
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty |
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty |
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty |
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty |
setPropValStringByNumber(const int index, const char *value) | ms_customproperty |
setSectionAvailable(const bool value) | ms_unigeneoptions |
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty |
~ms_customproperty() | ms_customproperty |
~ms_unigeneoptions() | ms_unigeneoptions | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_user
ms_user Member List

This is the complete list of members for ms_user, including all inherited members.

clearParam(const std::string name) | ms_user
getEmailAddress() const | ms_user
getEncryptedPassword() const | ms_user
getFullName() const | ms_user
getID() const | ms_user
getName() const | ms_user
getPasswordExpiry() const | ms_user
getStringParam(const std::string name, std::string &param) const | ms_user
getStringParam(const std::string name) const | ms_user
getUserType() const | ms_user
hasPasswordExpired() const | ms_user
isAccountEnabled() const | ms_user
ms_user(const int userID, const std::string userName, const std::string password, const long passwordExpiry, const std::string fullName, const std::string emailAddress, const usertype userType, const bool enabled) | ms_user
ms_user() | ms_user
saveStringParam(const std::string name, const std::string param) | ms_user
setAccountEnabled(bool newVal) | ms_user
setEmailAddress(std::string newVal) | ms_user
setEncryptedPassword(std::string newVal) | ms_user
setFullName(std::string newVal) | ms_user
setID(int newVal) | ms_user
setName(std::string newVal) | ms_user
setPassword(std::string barePassword) | ms_user
setPasswordExpiry(time_t newVal) | ms_user
setUserType(usertype newVal) | ms_user
systemids enum name | ms_user
USER_AGENT_STRING enum value | ms_user
USER_COMPUTER_NAME enum value | ms_user
USER_INTEGRA enum value | ms_user
USER_IP_ADDRESS enum value | ms_user
USER_NORMAL enum value | ms_user
USER_SECURITY_DISABLED enum value | ms_user
USER_WEBAUTH enum value | ms_user
USERID_ADMINISTRATOR enum value | ms_user
USERID_CMDLINE enum value | ms_user
USERID_DAEMON enum value | ms_user
USERID_GUEST enum value | ms_user
USERID_INTEGRA_SYSTEM enum value | ms_user
USERID_LAST enum value | ms_user
USERID_PUBLIC_SEARCHES enum value | ms_user
USERID_SECURITY_DISABLED enum value | ms_user
usertype enum name | ms_user
validatePassword(const std::string pwd, int &errorFlag) const | ms_user
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_wwwentry
ms_wwwentry Member List

This is the complete list of members for ms_wwwentry, including all inherited members.

copyFrom(const ms_wwwentry *right) | ms_wwwentry
defaultValues() | ms_wwwentry
getHostName() const | ms_wwwentry
getName() const | ms_wwwentry
getParseRule() const | ms_wwwentry
getPath() const | ms_wwwentry
getPortNumber() const | ms_wwwentry
getType() const | ms_wwwentry
ms_wwwentry() | ms_wwwentry
ms_wwwentry(const ms_wwwentry &src) | ms_wwwentry
operator=(const ms_wwwentry &right) | ms_wwwentry
setHostName(const char *value) | ms_wwwentry
setName(const char *value) | ms_wwwentry
setParseRule(const int value) | ms_wwwentry
setPath(const char *value) | ms_wwwentry
setPortNumber(const int value) | ms_wwwentry
setType(const WWW_TYPE value) | ms_wwwentry
~ms_wwwentry() | ms_wwwentry
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_wwwoptions
ms_wwwoptions Member List

This is the complete list of members for ms_wwwoptions, including all inherited members.

appendEntry(const ms_wwwentry *item) | ms_wwwoptions
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
clearEntries() | ms_wwwoptions
copyFrom(const ms_wwwoptions *right) | ms_wwwoptions
matrix_science::ms_customproperty::copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_wwwoptions
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
dropEntry(const int index) | ms_wwwoptions
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getEntry(const int index) const | ms_wwwoptions
getNumberOfEntries() const | ms_wwwoptions
getNumberOfProperties() const | ms_customproperty
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
getRepEntryByName(const char *dbName) const | ms_wwwoptions
getSeqEntryByName(const char *dbName) const | ms_wwwoptions
isSectionAvailable() const | ms_wwwoptions
ms_customproperty() | ms_customproperty
ms_wwwoptions() | ms_wwwoptions
ms_wwwoptions(const ms_wwwoptions &src) | ms_wwwoptions
operator=(const ms_wwwoptions &right) | ms_wwwoptions
setDefaultDelimiter(const char *delim) | ms_customproperty
setEntry(const int index, const ms_wwwentry *item) | ms_wwwoptions
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
setSectionAvailable(const bool value) | ms_wwwoptions
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
~ms_wwwoptions() | ms_wwwoptions
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_xic
ms_xic Member List

This is the complete list of members for ms_xic, including all inherited members.

copyFrom(const ms_xic *src) | ms_xic |
defaultValues() | ms_xic |
getCodeFromXml(std::string text) | ms_xic | static
getElutionTimeShift() const | ms_xic |
getEndIndex() const | ms_xic |
getEndScanId() const | ms_xic |
getNumPoints() const | ms_xic |
getPeakEndIndex() const | ms_xic |
getPeakEndScanId() const | ms_xic |
getPeakStartIndex() const | ms_xic |
getPeakStartScanId() const | ms_xic |
getPeakState() const | ms_xic |
getPoint(int index, double &rt, int &scanId, double &intensity) const | ms_xic |
getRegionEndIndex() const | ms_xic |
getRegionEndScanId() const | ms_xic |
getRegionStartIndex() const | ms_xic |
getRegionStartScanId() const | ms_xic |
getRtPeakEnd() const | ms_xic |
getRtPeakStart() const | ms_xic |
getRtRegionEnd() const | ms_xic |
getRtRegionStart() const | ms_xic |
getStartIndex() const | ms_xic |
getStartScanId() const | ms_xic |
getUseTimeShift() const | ms_xic |
getXmlCode(peakState code) | ms_xic | static
hasIndexes() const | ms_xic |
ms_xic() | ms_xic |
ms_xic(const ms_xic_body &body) | ms_xic | explicit
ms_xic(ms_xic_body *body) | ms_xic | explicit
PEAK_STATE_DISCARD enum value | ms_xic |
PEAK_STATE_OK enum value | ms_xic |
PEAK_STATE_UNKNOWN enum value | ms_xic |
peakState enum name | ms_xic |
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_xic_point
ms_xic_point Member List

This is the complete list of members for ms_xic_point, including all inherited members.

Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_xml_parameter
ms_xml_parameter Member List

This is the complete list of members for ms_xml_parameter, including all inherited members.

copyFrom(const ms_xml_parameter *right) | ms_xml_parameter |
defaultValues() | ms_xml_parameter |
dropDescription() | ms_xml_parameter |
dropName() | ms_xml_parameter |
getDescription() const | ms_xml_parameter |
getDescriptionSchemaType() const =0 | ms_xml_parameter | pure virtual
getName() const | ms_xml_parameter |
getNameSchemaType() const =0 | ms_xml_parameter | pure virtual
getSchemaType() const =0 | ms_xml_parameter | pure virtual
getValue() const | ms_xml_parameter |
getValueSchemaType() const =0 | ms_xml_parameter | pure virtual
haveDescription() const | ms_xml_parameter |
haveName() const | ms_xml_parameter |
ms_xml_parameter() | ms_xml_parameter |
ms_xml_parameter(const ms_xml_parameter &src) | ms_xml_parameter |
operator=(const ms_xml_parameter &right) | ms_xml_parameter |
setDescription(const char *value) | ms_xml_parameter |
setName(const char *value) | ms_xml_parameter |
setValue(const char *value) | ms_xml_parameter |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
~ms_xml_parameter() | ms_xml_parameter | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_xml_parameters
ms_xml_parameters Member List

This is the complete list of members for ms_xml_parameters, including all inherited members.

clearParameters()=0 | ms_xml_parameters | pure virtual
defaultValues() | ms_xml_parameters |
deleteParameterByName(const char *name)=0 | ms_xml_parameters | pure virtual
deleteParameterByNumber(const int idx)=0 | ms_xml_parameters | pure virtual
getNumberOfParameters() const =0 | ms_xml_parameters | pure virtual
getParameterSchemaType() const =0 | ms_xml_parameters | pure virtual
getSchemaType() const =0 | ms_xml_parameters | pure virtual
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_xml_parameters() | ms_xml_parameters | virtual
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Member List

  • matrix_science
  • ms_zip
ms_zip Member List

This is the complete list of members for ms_zip, including all inherited members.

appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
compressMore(const std::string &dataIn) | ms_zip |
compressMore(const unsigned char *dataIn, const unsigned long inputLen, unsigned char *dataOut, unsigned long *outputLen) | ms_zip |
copyFrom(const ms_zip *right) | ms_zip |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
decompressMore(const std::string &dataIn) | ms_zip |
decompressMore(const unsigned char *dataIn, const unsigned long inputLen, unsigned char *dataOut, unsigned long *outputLen) | ms_zip |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getUnZipped(unsigned char *buffer, const unsigned long len) const | ms_zip |
getUnZipped() const | ms_zip |
getUnZippedLen() const | ms_zip |
getZipped(unsigned char *buffer, const unsigned long len) const | ms_zip |
getZipped() const | ms_zip |
getZippedLen() const | ms_zip |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_zip(const bool isZipped, const unsigned char *buffer, const unsigned long len) | ms_zip |
ms_zip(const bool isZipped, const std::string &buffer) | ms_zip |
ms_zip(const bool isZipped) | ms_zip | explicit
ms_zip(const ms_zip &src) | ms_zip |
operator=(const ms_zip &right) | ms_zip |
~ms_errors() | ms_errors |
Generated on Tue Sep 24 2024 11:06:15 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: unimod Directory Reference

  • src
  • configfiles
  • unimod
unimod Directory Reference
Directory dependency graph for unimod:
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: http Directory Reference

  • src
  • http
http Directory Reference
Directory dependency graph for http:

Directories

directory impl

Files

file ms_http_helper_handles_body.hpp [code]
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: datfile Directory Reference

  • src
  • configfiles
  • datfile
datfile Directory Reference
Directory dependency graph for datfile:
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: configfiles Directory Reference

  • src
  • configfiles
configfiles Directory Reference
Directory dependency graph for configfiles:

Directories

directory | crosslinking
directory | datfile
directory | obo
directory | quantitation
directory | unimod
directory | xml

Files

file | ms_processors_impl.hpp [code]
file | time_utils.hpp [code]
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: obo Directory Reference

  • src
  • configfiles
  • obo
obo Directory Reference
Directory dependency graph for obo:
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: src Directory Reference

  • src
src Directory Reference
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: resfile Directory Reference

  • src
  • resfile
resfile Directory Reference
Directory dependency graph for resfile:

Directories

directory impl

Files

file | ms_fitexy_result_body.hpp [code]
file | ms_ms1quant_average_results_body.hpp [code]
file | ms_ms1quant_charge_state_body.hpp [code]
file | ms_ms1quant_match_body.hpp [code]
file | ms_ms1quant_match_component_body.hpp [code]
file | ms_ms1quant_match_range_body.hpp [code]
file | ms_ms1quant_match_ratio_body.hpp [code]
file | ms_ms1quant_peptide_status_body.hpp [code]
file | ms_ms1quant_time_align_body.hpp [code]
file | ms_ms1quant_time_align_limits_body.hpp [code]
file | ms_ms1quant_time_align_sax.hpp [code]
file | ms_ms2ratiocalculator.hpp [code]
file | ms_xic_body.hpp [code]
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: quantitation Directory Reference

  • src
  • configfiles
  • quantitation
quantitation Directory Reference
Directory dependency graph for quantitation:
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: tools Directory Reference

  • src
  • tools
tools Directory Reference
Directory dependency graph for tools:

Files

file | ms_quant_extractors.hpp [code]
file | ms_quant_mod_parsing.hpp [code]
file | ms_sql_stream_restorer.hpp [code]
file | ms_sql_stream_statement_chopper.hpp [code]
file | ms_sql_stream_statement_executor.hpp [code]
file | numerical_recipes.hpp [code]
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: src Directory Reference

  • src
src Directory Reference

Directories

directory | authentication
directory | common
directory | configfiles
directory | http
directory | resfile
directory | tools
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: xml Directory Reference

  • src
  • configfiles
  • xml
xml Directory Reference
Directory dependency graph for xml:
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: crosslinking Directory Reference

  • src
  • configfiles
  • crosslinking
crosslinking Directory Reference
Directory dependency graph for crosslinking:
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: inc Directory Reference

  • inc
inc Directory Reference

Directories

directory private

Files

file | ms_aahelper.hpp [code]
file | ms_body.hpp [code]
file | ms_cache_file.hpp [code]
file | ms_cache_stream.hpp [code]
file | ms_clusterparams.hpp [code]
file | ms_computeraddress.hpp [code]
file | ms_connection_settings.hpp [code]
file | ms_cronoptions.hpp [code]
file | ms_crosslinking_accession.hpp [code]
file | ms_crosslinking_accessions.hpp [code]
file | ms_crosslinking_configfile.hpp [code]
file | ms_crosslinking_does_not_pair_with.hpp [code]
file | ms_crosslinking_filters.hpp [code]
file | ms_crosslinking_linker.hpp [code]
file | ms_crosslinking_linkers.hpp [code]
file | ms_crosslinking_method.hpp [code]
file | ms_crosslinking_monolink.hpp [code]
file | ms_crosslinking_parameters.hpp [code]
file | ms_crosslinking_scope.hpp [code]
file | ms_crosslinking_settings.hpp [code]
file | ms_customproperty.hpp [code]
file | ms_customquantitation.hpp [code]
file | ms_databaseoptions.hpp [code]
file | ms_datfile.hpp [code]
file | ms_distiller_data.hpp [code]
file | ms_distiller_data_quant.hpp [code]
file | ms_distiller_data_search.hpp [code]
file | ms_distiller_master_project.hpp [code]
file | ms_distiller_master_search.hpp [code]
file | ms_distiller_search_status.hpp [code]
file | ms_distiller_search_status_list.hpp [code]
file | ms_distiller_sub_project.hpp [code]
file | ms_distiller_subsearch.hpp [code]
file | ms_enzyme.hpp [code]
file | ms_errors.hpp [code]
file | ms_fileutilities.hpp [code]
file | ms_fitexy_result.hpp [code]
file | ms_fragment.hpp [code]
file | ms_fragmentationrules.hpp [code]
file | ms_fragmentvector.hpp [code]
file | ms_http_client.hpp [code]
file | ms_http_client_mime.hpp [code]
file | ms_http_client_search.hpp [code]
file | ms_http_client_session.hpp [code]
file | ms_http_helper.hpp [code]
file | ms_http_helper_handles.hpp [code]
file | ms_http_helper_progress.hpp [code]
file | ms_http_helper_response.hpp [code]
file | ms_http_helper_return.hpp [code]
file | ms_imputation.hpp [code]
file | ms_input_stream.hpp [code]
file | ms_inputquery.hpp [code]
file | ms_libraryoptions.hpp [code]
file | ms_license.hpp [code]
file | ms_linker_site.hpp [code]
file | ms_linker_site_vector.hpp [code]
file | ms_log.hpp [code]
file | ms_logging.hpp [code]
file | ms_mascotfiles.hpp [code]
file | ms_mascotoptions.hpp [code]
file | ms_mascotresfile_dat.hpp [code]
file | ms_mascotresfile_msr.hpp [code]
file | ms_mascotresfilebase.hpp [code]
file | ms_mascotresults.hpp [code]
file | ms_mascotresults_params.hpp [code]
file | ms_masses.hpp [code]
file | ms_matrix.hpp [code]
file | ms_mod_visibility_helper.hpp [code]
file | ms_modfile.hpp [code]
file | ms_ms1quant_average_results.hpp [code]
file | ms_ms1quant_charge_state.hpp [code]
file | ms_ms1quant_match.hpp [code]
file | ms_ms1quant_match_component.hpp [code]
file | ms_ms1quant_match_range.hpp [code]
file | ms_ms1quant_match_ratio.hpp [code]
file | ms_ms1quant_peptide_status.hpp [code]
file | ms_ms1quant_time_align.hpp [code]
file | ms_ms1quant_time_align_limits.hpp [code]
file | ms_ms1quantitation.hpp [code]
file | ms_ms2quantitation.hpp [code]
file | ms_msr2dat28.hpp [code]
file | ms_obofile.hpp [code]
file | ms_parserule.hpp [code]
file | ms_peptide.hpp [code]
file | ms_peptide_quant_key.hpp [code]
file | ms_peptide_quant_key_vector.hpp [code]
file | ms_peptide_quant_ratio.hpp [code]
file | ms_peptidesummary.hpp [code]
file | ms_processoroptions.hpp [code]
file | ms_processors.hpp [code]
file | ms_progress_info.hpp [code]
file | ms_protein.hpp [code]
file | ms_protein_quant_ratio.hpp [code]
file | ms_proteinsummary.hpp [code]
file | ms_quant_average.hpp [code]
file | ms_quant_component.hpp [code]
file | ms_quant_composition.hpp [code]
file | ms_quant_configfile.hpp [code]
file | ms_quant_correction.hpp [code]
file | ms_quant_file_index.hpp [code]
file | ms_quant_helper.hpp [code]
file | ms_quant_integration.hpp [code]
file | ms_quant_isotope.hpp [code]
file | ms_quant_localdef.hpp [code]
file | ms_quant_method.hpp [code]
file | ms_quant_modgroup.hpp [code]
file | ms_quant_moverz.hpp [code]
file | ms_quant_multiplex.hpp [code]
file | ms_quant_neutralloss.hpp [code]
file | ms_quant_normalisation.hpp [code]
file | ms_quant_normalisation_peptide.hpp [code]
file | ms_quant_normalisation_protein.hpp [code]
file | ms_quant_numerator.hpp [code]
file | ms_quant_outliers.hpp [code]
file | ms_quant_parameters.hpp [code]
file | ms_quant_pepneutralloss.hpp [code]
file | ms_quant_precursor.hpp [code]
file | ms_quant_protocol.hpp [code]
file | ms_quant_quality.hpp [code]
file | ms_quant_ratio.hpp [code]
file | ms_quant_replicate.hpp [code]
file | ms_quant_reporter.hpp [code]
file | ms_quant_satellite.hpp [code]
file | ms_quant_specificity.hpp [code]
file | ms_quant_stats.hpp [code]
file | ms_quant_unmodified.hpp [code]
file | ms_quantitation.hpp [code]
file | ms_searchparams.hpp [code]
file | ms_security.hpp [code]
file | ms_security_group.hpp [code]
file | ms_security_options.hpp [code]
file | ms_security_session.hpp [code]
file | ms_security_task.hpp [code]
file | ms_security_tasks.hpp [code]
file | ms_security_user.hpp [code]
file | ms_shapiro_wilk.hpp [code]
file | ms_spectral_lib_entry.hpp [code]
file | ms_spectral_lib_file.hpp [code]
file | ms_spectral_lib_peak.hpp [code]
file | ms_spectral_lib_peak_list.hpp [code]
file | ms_taxonomyfile.hpp [code]
file | ms_taxonomyrules.hpp [code]
file | ms_tinycdb.hpp [code]
file | ms_treecluster.hpp [code]
file | ms_umod_aminoacid.hpp [code]
file | ms_umod_composition.hpp [code]
file | ms_umod_configfile.hpp [code]
file | ms_umod_element.hpp [code]
file | ms_umod_elemref.hpp [code]
file | ms_umod_modbrick.hpp [code]
file | ms_umod_modification.hpp [code]
file | ms_umod_neutralloss.hpp [code]
file | ms_umod_specificity.hpp [code]
file | ms_umod_xref.hpp [code]
file | ms_unigene.hpp [code]
file | ms_unigeneoptions.hpp [code]
file | ms_wwwoptions.hpp [code]
file | ms_xic.hpp [code]
file | ms_xml_parameters.hpp [code]
file | ms_zip.hpp [code]
file | msparser.hpp [code]
file | msparser_lim.hpp [code]
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: impl Directory Reference

  • src
  • resfile
  • impl
impl Directory Reference
Directory dependency graph for impl:

Files

file | ms_cached_msr_pepsum_data.hpp [code]
file | ms_cached_msr_query_data.hpp [code]
file | ms_cdb.hpp [code]
file | ms_dat28generator.hpp [code]
file | ms_dat28indexer.hpp [code]
file | ms_decoystats_accumulator.hpp [code]
file | ms_inputquery_dat.hpp [code]
file | ms_inputquery_msr.hpp [code]
file | ms_inputquery_nil.hpp [code]
file | ms_inputquerybase.hpp [code]
file | ms_mascotresfile_nil.hpp [code]
file | ms_mascotresfilebase_util.hpp [code]
file | ms_mascotresults_dat.hpp [code]
file | ms_mascotresults_implbase.hpp [code]
file | ms_mascotresults_msr.hpp [code]
file | ms_mascotresults_nil.hpp [code]
file | ms_mascotresultsbase.hpp [code]
file | ms_modinstancescount.hpp [code]
file | ms_msr2dat28_impl.hpp [code]
file | ms_msr_legacy_blob_stream.hpp [code]
file | ms_peptide_impl_dat.hpp [code]
file | ms_peptide_impl_msr.hpp [code]
file | ms_peptide_impl_nil.hpp [code]
file | ms_peptide_implbase.hpp [code]
file | ms_peptidesumcache.hpp [code]
file | ms_peptidesumcdb.hpp [code]
file | ms_peptidesummary_dat.hpp [code]
file | ms_peptidesummary_msr.hpp [code]
file | ms_peptidesummary_nil.hpp [code]
file | ms_peptidesummarybase.hpp [code]
file | ms_peptidesumnil.hpp [code]
file | ms_peptidesumsql.hpp [code]
file | ms_proteininference.hpp [code]
file | ms_proteinsummary_dat.hpp [code]
file | ms_proteinsummary_msr.hpp [code]
file | ms_proteinsummarybase.hpp [code]
file | ms_searchparams_dat.hpp [code]
file | ms_searchparams_msr.hpp [code]
file | ms_searchparams_nil.hpp [code]
file | ms_searchparamsbase.hpp [code]
file | ms_sql_find.hpp [code]
file | ms_unassigned.hpp [code]
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: private Directory Reference

  • inc
  • private
private Directory Reference
Directory dependency graph for private:

Files

file | ms_cdb_sharding.hpp [code]
file | ms_log_impl.hpp [code]
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: authentication Directory Reference

  • src
  • authentication
authentication Directory Reference
Directory dependency graph for authentication:
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: impl Directory Reference

  • src
  • http
  • impl
impl Directory Reference
Directory dependency graph for impl:

Files

file ms_http_helper_progress_impl.hpp [code]
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: common Directory Reference

  • src
  • common
common Directory Reference
Directory dependency graph for common:

Files

file ms_loggingmonitor_impl.hpp [code]
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };
/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };
/* Class not documented with doxygen comments */
class Undocumented { };
/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };
/*! A template class */
template<class T> class Templ { };
/*! Class that is inherited using protected inheritance */
class ProtectedBase { };
/*! Class that is inherited using private inheritance */
class PrivateBase { };
/*! Class that is used by the Inherited class */
class Used { };
/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
protected ProtectedBase,
private PrivateBase,
public Undocumented,
public Templ<int>
{
private:
Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a gray border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labelled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labelled with the template parameters of the instance.
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_aahelper.hpp Source File

  • inc
ms_aahelper.hpp
1/*
2##############################################################################
3# File: ms_aahelper.hpp #
4# Mascot Parser toolkit #
5# Utility functions for generating peptides, peptide and fragment masses #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source: parser/inc/ms_aahelper.hpp $
12# $Author: robertog@matrixscience.com $
13# $Date: 2022-06-13 11:48:05 +0100 $
14# $Revision: 8fe02c5d122124d6c17183492bfe19018028b6e5 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
15##############################################################################
16*/
17
18#ifndef MS_AAHELPER_HPP
19#define MS_AAHELPER_HPP
20
21
22#include <string>
23#include <vector>
24
25
26namespace matrix_science {
34 class MS_MASCOTRESFILE_API ms_aahelper: public ms_errors
35 {
36 public:
38
47 enum FRAG_NL {
48 FRAG_NL_PRIMARY = 0x0001,
49 FRAG_NL_SECONDARY = 0x0010
50 };
51
53 ms_aahelper();
54
56 ms_aahelper(const ms_mascotresfilebase& resfile,
57 const char * enzymeFileName,
58 const char * quantSchemaFilePath = "http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd",
59 const char * unimodSchemaFilePath = "http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd");
60
62 ms_aahelper(const ms_mascotresults & summary,
63 const char * enzymeFileName,
64 const char * quantSchemaFilePath = "http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd",
65 const char * unimodSchemaFilePath = "http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd");
66
68 ms_aahelper(const ms_aahelper& right);
69
71 ~ms_aahelper();
72
73#ifndef SWIG
75 ms_aahelper& operator=(const ms_aahelper& right);
76#endif
78 void copyFrom(const ms_aahelper* right);
79
81 void defaultValues();
82
84 void setEnzyme(const ms_enzyme* enzyme);
85
87 const ms_enzyme* getEnzyme() const;
88
90 void setMasses(const ms_masses *masses);
91
93 const ms_masses* getMasses() const;
94
96 void setAvailableModifications(const ms_modvector *fixedModVector,
97 const ms_modvector *varModVector);
98
100 ms_modvector getFixedMods() const;
101
103 ms_modvector getVarMods() const;
104
106 void startIteratePeptides(const char* sequenceProtein,
107 const int sizeProtein,
108 const int pfa);
109
111 bool getNextPeptide();
112
114 int getPepStart() const;
115
117 int getPepEnd() const;
118
120 int getMissed() const;
121
123 void stopIteratePeptides();
124
126 double calcPeptideMZ(const char* proteinStr,
127 const int proteinLen,
128 const int startPos,
129 const int endPos,
130 const std::vector< int > numThatMustBeModded,
131 const int charge,
132 const MASS_TYPE massType,
133 ms_errs *err) const;
134
136 ms_peptide createPeptide(const char* proteinStr,
137 const int proteinLen,
138 const int startPos,
139 const int endPos,
140 const std::vector< int > varMods,
141 const std::vector< int > varModsWhichNl,
142 const int charge,
143 const MASS_TYPE massType,
144 ms_errs *err) const;
145
147 ms_peptide createPeptide(const char* proteinStr,
148 const int proteinLen,
149 const int startPos,
150 const int endPos,
151 const std::vector< int > varMods,
152 const std::vector< int > varModsWhichNl,
153 const std::vector< int > summedMods,
154 const std::vector< int > summedModsWhichNl,
155 const int charge,
156 const MASS_TYPE massType,
157 ms_errs *err) const;
158
160 ms_peptide createCrosslinkedPeptide(const ms_peptide &pepAlpha,
161 const ms_peptide &pepBeta,
162 const ms_linker_site_vector &linkedSites,
163 ms_errs *err) const;
164
166 std::vector< double > calcFragments(const ms_peptide* peptide,
167 const int seriesID,
168 const bool doubleCharged,
169 const double minMass,
170 const double maxMass,
171 const MASS_TYPE massType,
172 ms_fragmentvector* fragments,
173 ms_errs* err,
174 const FRAG_NL fragNlType = FRAG_NL_PRIMARY) const;
175
177 bool calcFragmentsEx(const ms_peptide* peptide,
178 const int seriesID,
179 const int fragCharge,
180 const double minMass,
181 const double maxMass,
182 const MASS_TYPE massType,
183 ms_fragmentvector* fragments,
184 ms_errs* err,
185 const FRAG_NL fragNlType = FRAG_NL_PRIMARY) const;
186
187#ifndef SWIG
189 std::vector< double > calcFragments(const ms_peptide* peptide,
190 const int seriesID,
191 const bool doubleCharged,
192 const double minMass,
193 const double maxMass,
194 const MASS_TYPE massType,
195 std::vector< ms_fragment > *fragments,
196 ms_errs* err,
197 const FRAG_NL fragNlType = FRAG_NL_PRIMARY) const;
198
200 bool calcFragmentsEx(const ms_peptide* peptide,
201 const int seriesID,
202 const int fragCharge,
203 const double minMass,
204 const double maxMass,
205 const MASS_TYPE massType,
206 std::vector< ms_fragment > *fragments,
207 ms_errs* err,
208 const FRAG_NL fragNlType = FRAG_NL_PRIMARY) const;
209#endif
210
211
212 private:
213 // Nasty const issue with logging and tracing.
214 ms_errs* getLog() const { return const_cast< ms_errs*>(getErrorHandler()); }
215
216 std::string convertPrimaryNlVectorToString(const std::vector< int > modded,
217 const std::vector< int > whichNl,
218 const ms_modvector &varMods,
219 const ms_modvector &varMods_used,
220 ms_errs* err) const;
221
222 std::vector< int > convertPrimaryNlStringToVector(const std::string varModStr,
223 const std::string primaryNlStr,
224 const ms_modvector &varMods_used,
225 ms_errs* err) const;
226
227 void initialiseFromResfile(const ms_mascotresfilebase& resfile,
228 const char * enzymeFileName,
229 const char * quantSchemaFilePath,
230 const char * unimodSchemaFilePath);
231 bool checkVarModConflicts(const ms_modvector *varModVector, ms_modvector &varMods, std::vector<int> &varModsSrc, ms_modvector &varMods_used, ms_errs &err) const;
232 bool iscleavagepoint(const char left, const char right) const;
233 bool switchIndependent();
234 void updatemissed(const int leftPos);
235 void dropmissed();
236 void clearMods();
237 bool calcUnionFragmentList(const ms_peptide* peptide,
238 const int seriesID,
239 const int fragCharge,
240 const double minMass,
241 const double maxMass,
242 const MASS_TYPE massType,
243 const FRAG_NL fragNlType,
244 std::vector< ms_fragment > *fragments,
245 ms_errs *err,
246 std::vector< double > *vi) const;
247 bool calcCrosslinkedFragments(const ms_peptide *peptide,
248 const int seriesID,
249 const int fragCharge,
250 const double minMass,
251 const double maxMass,
252 const MASS_TYPE massType,
253 const FRAG_NL fragNlType,
254 std::vector< ms_fragment > *fragments,
255 ms_errs *err,
256 std::vector< double > *vi) const;
257 bool cfr(const ms_peptide* peptide,
258 const ms_peptide::PSM psmComponent,
259 const int seriesID,
260 const int fragCharge,
261 const double minMass,
262 const double maxMass,
263 const MASS_TYPE massType,
264 const FRAG_NL fragNlType,
265 const int linkerColumn,
266 const double linkerMassOffset,
267 std::vector< ms_fragment > *fragments,
268 ms_errs* err,
269 std::vector< double > *vi) const;
270
271 void getSeriesParams(const char* pepStr,
272 const int seriesID,
273 const ms_masses & masses,
274 const MASS_TYPE massType,
275 double& delta,
276 int& start,
277 int& end,
278 bool& forward) const;
279
280 void prepareCumulativeMassAndNL(const std::string &pepStr,
281 const ms_masses *pMasses,
282 const MASS_TYPE massType,
283 const std::vector<bool> &residue_has_varmod,
284 const std::vector<double> &fixedModNlVals,
285 const std::vector<double> &totalModDelta,
286 const std::vector<double> &totalNlVals,
287 const bool isMasterNL,
288 std::vector<double> &m,
289 std::vector<double> &cumulativeNlVals) const;
290
291 class IonSet;
292 void calculateSeriesMasses(const int seriesID,
293 const int fragCharge,
294 const MASS_TYPE massType,
295 const ms_peptide::PSM psmComponent,
296 const int linkerColumn,
297 const double linkerMassOffset,
298 const ms_masses *pMasses,
299 const std::string &pepStr,
300 const std::vector<double> &m,
301 const std::vector<double> &cumulativeNlVals,
302 const std::vector<bool> &loopLinkingAllows,
303 IonSet &ionSet) const;
304
305 void setupFromPre2_2ResultsFile(const std::string & peptide, const std::string & varMods);
306
307 class ModLookupHelper;
308 bool initialiseModsAtResidues(const ModLookupHelper &lookupHelper,
309 const std::string &pepStr,
310 const std::string &modStr,
311 const std::vector<int> &primaryNl,
312 const std::string &monoLinkStr,
313 const ms_modvector *varmods,
314 const std::vector<int> *varmods_src,
315 const ms_modvector *varmods_used,
316 const ms_peptide::PSM psmComponent,
317 std::vector< const ms_modification* > &mod_at_residue,
318 ms_errs *err) const;
319
320 bool lookupLocalModVectors(int q, const ms_modvector* &local_mods, const std::vector<int>* &local_mods_src, const ms_modvector* &local_mods_used);
321 void clearLocalModVectors();
322
323 ms_masses massesUnmod_;
324 ms_masses masses_;
325 ms_umod_configfile umodFile_;
326 ms_quant_configfile quantFile_;
327 const ms_mascotresfilebase* pResfile_;
328 const ms_mascotresults * pSummary_;
329
330 ms_modvector fixedMods_;
331 ms_modvector varMods_;
332 std::vector< int > varModsSrc_;
333 ms_modvector varMods_used_;
334
335 typedef std::map<int, ms_modvector > queryParsedLocalMods_t;
336 typedef std::map<int, std::vector<int> > queryParsedLocalModsSrc_t;
337 queryParsedLocalMods_t queryParsedLocalMods_;
338 queryParsedLocalModsSrc_t queryParsedLocalModsSrc_;
339 queryParsedLocalMods_t queryParsedLocalModsUsed_;
340
341 ms_enzyme enzyme_;
342 bool bEnzymeSet_;
343 std::string protStr_;
344 int protLen_;
345 int pfa_; // missed cleavages limit
346
347 // internal iteration parameters
348 int numInd_; // current independent enzyme ID
349 int l_, r_; // the last peptide ends
350 int missed_; // number of missed cleavages in the current peptide
351 int enzymesPassed_;
352
353 // for the sake of semi-specific enzymes
354 bool forward_;
355
356 // For a pre 2.2 results file, need to keep track of what we know
357 enum DERIVED_MOD_SPECIFICITY_STATUS
358 {
359 DMSS_NOT_INITIALISED,
360 DMSS_WORKING,
361 DMSS_COMPLETED,
362 DMSS_FROM_V2_2_OR_LATER_RESFILE,
363 DMSS_NOT_FROM_RESFILE
364 };
365 DERIVED_MOD_SPECIFICITY_STATUS derivedModSpecificityStatus_;
366 std::vector<MOD_TYPES> derivedModSpecificities_;
367 typedef std::vector< std::vector<bool> > modifiedResidues_t;
368 modifiedResidues_t derivedModifiedResidues_;
369
370 }; // ms_aahelper // end of mass_calculation_group
372} // matrix_science
373
374#endif // MS_AAHELPER_HPP
375
376/*------------------------------- End of File -------------------------------*/
matrix_science::ms_aahelper
This class facilitates creation of peptides and calculation of MS-fragment masses.
Definition: ms_aahelper.hpp:35
matrix_science::ms_aahelper::FRAG_NL
FRAG_NL
Flag for controlling iteration over multiple neutral losses.
Definition: ms_aahelper.hpp:47
matrix_science::ms_enzyme
Represent a single entry in the enzymes file.
Definition: ms_enzyme.hpp:67
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_fragmentvector
Class for holding a list of ms_fragment objects.
Definition: ms_fragmentvector.hpp:47
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_masses
Reads and parses the masses file with residue and atom masses.
Definition: ms_masses.hpp:48
matrix_science::ms_modvector
General usage class for creating lists of modifications to be passed as parameters.
Definition: ms_modfile.hpp:339
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::MASS_TYPE
MASS_TYPE
All possible mass types.
Definition: ms_modfile.hpp:65
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_body.hpp Source File

  • inc
ms_body.hpp
1/*
2##############################################################################
3# file: ms_body.hpp
4# 'msparser' toolkit
5# Implements a reference counted body (pimpl) idiom
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_body.hpp $
12 * @(#)$Revision: f7c430569a82a92eac8833564053b59680ac20a8 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2021-01-11 13:23:17 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_BODY_HPP
18#define MS_BODY_HPP
19
20
21namespace matrix_science
22{
23
24 //=========================================================================
29 class MS_MASCOTRESFILE_API ms_body
30 {
31 protected:
32 ms_body() : refcount_(0) {}
33 virtual ~ms_body() {}
34 ms_body(const ms_body &) : refcount_(0) {}
35#ifndef SWIG
36 void operator=(const ms_body &) {}
37#endif
38 private:
39 void addRef();
40 bool release(); // true means final release (refcount now zero)
41 long refcount_;
42 friend class ms_handle;
43 };
44
45 class MS_MASCOTRESFILE_API ms_handle
46 {
47 protected:
48 explicit ms_handle(ms_body * bodyPtr);
49 explicit ms_handle(const ms_handle & copy);
50 virtual ~ms_handle()
51 {
52 attachBody(0);
53 };
54#ifndef SWIG
55 const ms_handle & operator=(const ms_handle & copy);
56 ms_body * body();
57 const ms_body * body() const;
58#endif
59 void attachBody(ms_body * newBody);
60 private:
61 ms_body * body_;
62 };
63 // end of tools_group
65 //=========================================================================
66
67} // namespace matrix_science
68
69#endif // MS_BODY_HPP
70
71/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_cache_file.hpp Source File

  • inc
ms_cache_file.hpp
1/*
2##############################################################################
3# file: ms_cache_file.hpp #
4# 'msparser' toolkit #
5# Used internally in Mascot Parser as well as being available externally #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: $
13# $Author: villek@matrixscience.com $
14# $Date: 2023-02-02 13:47:30 +0000 $
15# $Revision: a80892d71615baa5079d40d1461ed9c24e3bffff | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
16# $NoKeywords:: $
17##############################################################################
18*/
19
20#ifndef MS_CACHE_FILE_HPP
21#define MS_CACHE_FILE_HPP
22
23
24
25// Includes from the standard template library
26#include <map>
27#include <string>
28
29#ifndef SWIG
30 // Helper class - don't use from outside library
31
32namespace matrix_science {
33
39 class ms_cache_stream;
40
41 // internal
42 struct ms_cache_record
43 {
44 UINT64 position;
45 unsigned length;
46
47 inline ms_cache_record()
48 {
49 position = 0;
50 length = 0;
51 }
52 };
53
54 // internal
55 class MS_MASCOTRESFILE_API ms_cache_file :
56 public ms_errors
57 {
58 public:
59 static const unsigned OPEN_FLAG_READ_ONLY = 1;
60
61 public:
62 ms_cache_file();
63 ~ms_cache_file();
64
65 bool open(const std::string & filename, unsigned flags = 0);
66 void close();
67 bool save();
68
69 bool readStream(ms_cache_stream * stream);
70 bool writeStream(ms_cache_stream * stream);
71 bool deleteStream(ms_cache_stream * stream);
72
73 std::string getFileName() const { return filename_; }
74
75 private:
76 //Do not copy this object
77 ms_cache_file(const ms_cache_file & src);
78 ms_cache_file& operator=(const ms_cache_file & right);
79
80 UINT64 appendPos_;
81 INT64 lastAssignedId_;
82 unsigned flags_;
83 std::string filename_;
84 FILE * fileHandle_;
85 unsigned version_;
86 std::map<INT64, ms_cache_record> recordMap_;
87 bool open_;
88 }; // end of tools_group
90} // matrix_science
91
92#endif // SWIG
93
94#endif // MS_CACHE_FILE_HPP
95
96/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_cache_stream.hpp Source File

  • inc
ms_cache_stream.hpp
1/*
2##############################################################################
3# file: ms_cache_stream.hpp #
4# 'msparser' toolkit #
5# Used internally in Mascot Parser as well as being available externally #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: $
13# $Author: villek@matrixscience.com $
14# $Date: 2018-07-30 16:23:53 +0100 $
15# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
16# $NoKeywords:: $
17##############################################################################
18*/
19
20#ifndef MS_CACHE_STREAM_HPP
21#define MS_CACHE_STREAM_HPP
22
23
24
25// Includes from the standard template library
26#include <string>
27#include <vector>
28
29#ifndef SWIG
30 // Helper class - don't use from outside library
31
32namespace matrix_science
33{
34 class ms_cache_file;
35 class ms_tinycdb;
36
37 class MS_MASCOTRESFILE_API ms_cache_stream
38 {
39 public:
40 ms_cache_stream();
41 virtual ~ms_cache_stream();
42
43 INT64 getId() const;
44 void setId(INT64 id);
45
46 void clear(); // clear the stream, free up storage
47 void reserve(size_t byteCount); // pre-allocate space for copying data into
48 unsigned getBytesAvailable() const; // number of bytes currently available for reading
49 bool isOverExhausted() const; // true is attempt has been made to read more data than the stream has avaialble
50
51 void add(int value); // 4 bytes
52 void add(unsigned value); // 4 bytes
53 void add(INT64 value); // 8 bytes
54 void add(UINT64 value); // 8 bytes
55 void add(bool value); // 4 bytes (yes, really)
56 void add(double value); // 8 bytes
57 void add(const char * value, size_t length); // 4 byte unsigned length plus n x char (1 byte each), NOT null terminated
58 void add(const char * value); // 4 byte unsigned length plus n x char (1 byte each), NOT null terminated
59 void add(const std::string & value); // 4 byte unsigned length plus n x char (1 byte each), NOT null terminated
60
61 int getInt32();
62 unsigned getUnsigned32();
63 INT64 getInt64();
64 UINT64 getUnsigned64();
65 bool getBool();
66 double getDouble();
67 std::string getString();
68
69 void addBytes(const void * bytes, size_t size); // add bytes to the end of the stream
70 void getBytes(void * bytes, size_t size); // copy bytes from the stream, extend read position
71
72 const char * getBuffer() const;
73 unsigned getBufferLength() const;
74
75 bool save(matrix_science::ms_tinycdb & cdbFile, const std::string & streamName) const;
76
77 private:
78 INT64 id_;
79 size_t readPosition_;
80 std::vector<char> buffer_;
81 bool isOverExhausted_;
82
83 friend class ms_cache_file;
84 };
85
86} // matrix_science
87
88#endif // SWIG
89
90#endif // MS_CACHE_STREAM_HPP
91
92/*------------------------------- End of File -------------------------------*/
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_cached_msr_pepsum_data.hpp Source File

  • src
  • resfile
  • impl
ms_cached_msr_pepsum_data.hpp
1
2#ifndef MS_CACHED_MSR_DATA_HPP
3#define MS_CACHED_MSR_DATA_HPP
4
5#include <array>
6#include <vector>
7#include <map>
8#include <tuple>
9#include <iostream>
10
11#include "ms_peptide.hpp"
12#include "private/ms_protein_match_data.hpp"
13#include "ms_linker_site.hpp"
14#include "ms_linker_site_vector.hpp"
15
16#include "private/ms_serializer.hpp"
17
18
19namespace msparser_internal
20{
21 namespace msr_cached_data
22 {
23 struct Substitution
24 {
25 int site;
26 char ambiguousResidue,
27 residue;
28
29 std::string stringify() const {
30 std::ostringstream out;
31
32 LOG_TRACE( out << "====SUBSTITUTION====" << std::endl;
33 out << site << ":" << ambiguousResidue << "?" << residue << std::endl;
34 out << "========" << std::endl; )
35
36 return out.str();
37 }
38 };
39
40 struct Monolink
41 {
42 int linkageSite,
43 idxLinker,
44 nlIndex;
45
46 std::string stringify() const {
47 std::ostringstream out;
48 LOG_TRACE( out << "====MONOLINK====" << std::endl;
49 out << linkageSite << ":" << idxLinker << ":" << nlIndex << std::endl;
50 out << "========" << std::endl; )
51
52 return out.str();
53 }
54
55 };
56
57 struct PeptideData
58 {
59 PeptideData()
60 :missedCleavages(-1),
61 peptideMr(0),
62 delta(0),
63 ionsScore(0)
64 {}
65
66 int missedCleavages,
67 peaksUsedFromIons1,
68 peaksUsedFromIons2,
69 peaksUsedFromIons3,
70 drangeStartPos,
71 drangeEndPos,
72 nIonsMatched;
73 matrix_science::ms_linker_site_vector looplinks;
74
75 std::vector<Monolink> monolinks;
76 std::vector<Substitution> substitutions;
77 std::string ionSeriesFound,
78 peptideStr,
79 quantComponentName,
80 varmodsString,
81 summedMods,
82 summedPrimaryNl,
83 localModsString,
84 primaryNl,
85 localPrimaryNl;
86 double peptideMr;
87 double delta;
88 double ionsScore;
89
90 std::string getMonolinksStr(const bool allowEmptyStr=true) const{
91 if ( (allowEmptyStr) && (monolinks.empty()) )
92 {
93 return {};
94 }
95
96 std::string ret(peptideStr.length()+2, '0'); // Include C-term and N-term
97 for (const auto& monolink : monolinks)
98 {
99 ret[monolink.linkageSite] = '0' + monolink.nlIndex;
100 }
101 return ret;
102 }
103
104 // pos + ambiguous res + res
105 std::string getSubstitutionsStr() const{
106 std::string ret {};
107 for (const Substitution& subs : substitutions)
108 {
109 ret += std::to_string(subs.site);
110 ret += ',';
111 ret += subs.ambiguousResidue;
112 ret += ',';
113 ret += subs.residue;
114 ret += ',';
115 }
116 if (!ret.empty())
117 {
118 ret.pop_back();
119 }
120 return ret;
121 }
122
123 bool hasMonolinks() const {
124 return !monolinks.empty();
125 }
126
127 std::string stringify() const {
128 std::ostringstream out;
129 LOG_TRACE( out << "====PEPTIDE_DATA====" << std::endl
130 << "mc " << missedCleavages << std::endl
131 << "ions1 " << peaksUsedFromIons1 << std::endl
132 << "ions2 " << peaksUsedFromIons2 << std::endl
133 << "ions3 " << peaksUsedFromIons3 << std::endl
134 << "drange " << drangeStartPos <<std::endl
135 << "nIons " << nIonsMatched << std::endl
136 << "ionsFound " << ionSeriesFound << std::endl
137 << "pepStr " << peptideStr << std::endl
138 << "quantComp " << quantComponentName << std::endl
139 << "varmodStr " << varmodsString << std::endl
140 << "summedMods " << summedMods << std::endl
141 << "summedNl " << summedPrimaryNl << std::endl
142 << "localModsStr " << localModsString << std::endl
143 << "primaryNl " << primaryNl << std::endl
144 << "localPrimaryNl " << localPrimaryNl << std::endl
145 << "peptideMr " << peptideMr << std::endl
146 << "delta " << delta << std::endl
147 << "ionsScore " << ionsScore << std::endl
148 << "========" << std::endl; )
149 return out.str();
150 }
151 };
152
153 struct PepVec
154 {
155 using RankId = int;
156 int charge;
157 double mZ;
158 std::array<std::map<RankId, PeptideData>, matrix_science::ms_peptide::PSM_CROSSLINK_BETA+1> peps;
159 std::map<RankId, matrix_science::ms_linker_site> intactLinks;
160
161 std::string stringify() const {
162 std::ostringstream out;
163 LOG_TRACE( out << "====PEP_VEC====" << std::endl;
164 out << "charge: " << charge << std::endl;
165 out << "mZ: " << mZ << std::endl;
166 out << "intactLinks: " << intactLinks << std::endl;
167 out << "peps: " << peps << std::endl;
168 out << "========" << std::endl; )
169
170 return out.str();
171 }
172 };
173
174 struct Peptides
175 {
176 Peptides()
177 :q(-1), valid(false)
178 {}
179
180 int q;
181 bool valid;
182
183 std::array<PepVec, matrix_science::ms_peptide::N_PSM_TYPES> data;
184
185 std::string stringify() const {
186 std::ostringstream out;
187 LOG_TRACE( out << "====PEPTIDES====" << std::endl;
188 out << "q: " << q << std::endl;
189 out << "valid: " << valid << std::endl;
190 out << "data: " << data << std::endl;
191 out << "========" << std::endl; )
192
193 return out.str();
194 }
195 };
196
197 // Map proteinId -> (acc, dbId, protein match data)
198 using ProteinMatchData = std::map<int64_t, std::tuple<std::string, int, std::vector<msparser_internal::ms_protein_match_data> >>;
199
200 struct PeptideProteinMatchData
201 {
202 PeptideProteinMatchData()
203 :ionsScore(0.0), peptideStr(), protMatchData()
204 {}
205
206 double ionsScore;
207 std::string peptideStr;
208 ProteinMatchData protMatchData;
209
210 std::string stringify() const {
211 std::ostringstream out;
212 LOG_TRACE( out << ionsScore << " " << peptideStr << " " << protMatchData << std::endl; )
213 return out.str();
214 }
215 };
216 inline std::ostream& operator<<(std::ostream& out, const PeptideProteinMatchData& p) {
217 out << p.stringify();
218 return out;
219 }
220
221 // A Combo of protein match data with ions score and peptide string from peptide data.
222 // Keep them together because they are accessed together when creating the .sdb file.
223 // ms_peptidesummary_msr::addToDecoyStatsAccums() ends up calling getIonsScore() and getPeptideStr()
224 // and massageQuery() ends up accessing protein match data.
225 // These two methods are called together during cache creation.
226 using ComboPeptideProteinMatchData = std::map<matrix_science::ms_peptide::PSM_TYPE, PeptideProteinMatchData>;
227 struct ProteinMatchDataPerQuery
228 {
229 ProteinMatchDataPerQuery()
230 : valid(false), q(-1)
231 {}
232 bool valid;
233 int q;
234
235 // (rank) -> (ComboPeptideProteinMatchData)
236 std::map<int, ComboPeptideProteinMatchData> data;
237
238 std::string stringify() const {
239 std::ostringstream out;
240 out << "====PROTEIN_MATCH_DATA_PER_QUERY====" << std::endl;
241 out << "valid: " << valid << std::endl;
242 out << "q: " << q << std::endl;
243 out << "data:";
244 for(const auto& elem : data) {
245 out << elem.first << ":";
246 for (const auto& combo : elem.second) {
247 out << static_cast<int>(combo.first) << " : " << combo.second;
248 }
249 out << std::endl;
250 }
251 out << std::endl;
252
253 return out.str();
254 }
255 };
256
257
258 inline std::ostream& operator<<(std::ostream& out, const Substitution& s) {
259 out << s.stringify();
260 return out;
261 }
262
263 inline std::ostream& operator<<(std::ostream& out, const Monolink& m) {
264 out << m.stringify();
265 return out;
266 }
267
268 inline std::ostream& operator<<(std::ostream& out, const PeptideData& p) {
269 out << p.stringify();
270 return out;
271 }
272
273 inline std::ostream& operator<<(std::ostream& out, const PepVec& p) {
274 out << p.stringify();
275 return out;
276 }
277
278 inline std::ostream& operator<<(std::ostream& out, const Peptides& p) {
279 out << p.stringify();
280 return out;
281 }
282
283 inline std::ostream& operator<<(std::ostream& out, const ProteinMatchDataPerQuery& p) {
284 out << p.stringify();
285 return out;
286 }
287
288 }
289}
290
291
292#endif // MS_CACHED_MSR_DATA_HPP
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_peptide::PSM_CROSSLINK_BETA
@ PSM_CROSSLINK_BETA
Beta peptide in a crosslinked match.
Definition: ms_peptide.hpp:101
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_cached_msr_query_data.hpp Source File

  • src
  • resfile
  • impl
ms_cached_msr_query_data.hpp
1#include <vector>
2
3#ifndef MS_CACHED_MSR_QUERY_DATA_HPP
4#define MS_CACHED_MSR_QUERY_DATA_HPP
5
6namespace msparser_internal
7{
8 namespace msr_cached_data
9 {
10 struct QueryData
11 {
12 QueryData()
13 : q(-1),
14 querySeq(std::make_pair(std::vector<std::string>(), false)),
15 queryComp(std::make_pair(std::vector<std::string>(), false)),
16 querySeqTag(std::make_pair(std::vector<std::string>(), false)),
17 internalsMaxMass(std::make_pair(0.0, false)),
18 internalsMinMass(std::make_pair(0.0, false)),
19 pepTol(0.0)
20 {}
21
22 int q;
23 int sourceIndex;
24 int numVals;
25
26 std::string charge;
27 std::string instrument;
28 std::string intMax;
29 std::string intMin;
30 std::string ions1;
31 std::string ions1Charge;
32 std::string ions2;
33 std::string ions2Charge;
34 std::string ions3;
35 std::string ions3Charge;
36 std::string itMods;
37 std::string locus;
38 std::string pepTolUnits;
39 std::string rawFile;
40 std::string rawScans;
41 std::pair<std::string, bool> rawScansIndices;
42 std::pair<std::string, bool> rtIndices;
43 std::string rtInSeconds;
44 std::string rules;
45 std::string scans;
46 std::pair<std::string, bool> scansIndices;
47 std::string title;
48
49 // second element in std::pair to flag if initalised
50 std::pair<std::vector<std::string>, bool> querySeq;
51 std::pair<std::vector<std::string>, bool> queryComp;
52 std::pair<std::vector<std::string>, bool> querySeqTag;
53
54 std::pair<double, bool> internalsMaxMass;
55 std::pair<double, bool> internalsMinMass;
56 double ionMobility;
57 double massMin;
58 double massMax;
59 double pepTol;
60 };
61 }
62}
63
64#endif // MS_CACHED_MSR_QUERY_DATA_HPP
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_cdb.hpp Source File

  • src
  • resfile
  • impl
ms_cdb.hpp
1/*
2##############################################################################
3# file: ms_cdb.hpp #
4# 'msparser' toolkit #
5# Encapsulates an cache file for a mascot results file #
6# Just used internally in Mascot Parser - this header not supplied #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2009 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_CDB_HPP
21#define MS_CDB_HPP
22
23// Includes from the standard template library
24#include <time.h>
25#include <string>
26#include <list>
27#include <vector>
28#include <set>
29
30#include <cdb.h>
31
32// Keys for within a section will start with q for a query section
33// and 0-9 A-Z for the other sections. The values (keynames within mascot.dat
34// can contain anything except an = sign, so we define a set of special values
35// =1, =2 etc. Other =? values are defined inline in ms_cdb::makeIndexKey
36#define CDBIDX_START_SECTION "=1"
37#define CDBIDX_END_SECTION "=2"
38
39#define CDBIDX_ANY_TAG "==TAG"
40#define CDBIDX_ANY_SQ "==SQ"
41#define CDBIDX_ANY_MSMS "==MSMS"
42
43
44// The version string stored using the CDBIDX_VERSION key
45#define CDB_MAIN_INDEX_VERSION "0.9.6"
46
47
48using namespace matrix_science;
49
50namespace msparser_internal {
51#ifndef SWIG
52 class MS_MASCOTRESFILE_API ms_cdb : public ms_tinycdb
53 {
54 public:
55 ms_cdb(const unsigned int flags,
56 const std::string cacheDirectory,
57 const std::string datFilePath,
58 ms_mascotresfile_dat * pResfile);
59
60 ~ms_cdb();
61
62 bool addOffset(const ms_mascotresfile_dat::section sec,
63 const int queryNumber,
64 const char * key,
65 const OFFSET64_T pos);
66
67 OFFSET64_T getOffset(const ms_mascotresfile_dat::section sec, const int queryNumber, const char * key);
68 std::string getCacheDirectory() const {return cacheDirectory_;}
69 void openIndexFileForVerification();
70 void createDirectoryAndOpenIndexFile();
71
72 protected:
73 // Not safe to copy or assign this object.
74 ms_cdb(const ms_cdb & rhs);
75 ms_cdb & operator=(const ms_cdb & rhs);
76
77 private:
78 unsigned int flags_;
79 std::string cacheDirectory_;
80 ms_mascotresfile_dat * pResfile_;
81
82 void myOpenIndexFile();
83 std::string makeIndexKey(const ms_mascotresfile_dat::section sec, const int queryNumber, const char * key) const;
84 };
85#endif // SWIG
86} // msparser_internal namespace
87#endif // MS_CDB_HPP
88
89/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfile_dat
Class for parsing and reading files in dat28 format.
Definition: ms_mascotresfile_dat.hpp:121
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_cdb_sharding.hpp Source File

  • inc
  • private
ms_cdb_sharding.hpp
1/*
2##############################################################################
3# file: ms_cdb_sharding.hpp #
4# 'msparser' toolkit #
5# Sharding of the cdb files based on the content and the size #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2021 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Author: francoisr@matrixscience.com $
13# $Date: 2022-02-18 16:21:35 +0000 $
14# $Revision: b37898d7f040eb50775669c2cfd1f9c88ef4d2da | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
15##############################################################################
16*/
17
18#ifndef MS_CDB_SHARDING_HPP
19#define MS_CDB_SHARDING_HPP
20
21#ifndef SWIG
22
23using namespace matrix_science;
24
25namespace msparser_internal {
26
27 class CdbPreparingHelper
28 {
29 public:
38 static bool moveFileSafely(const std::string & sourceFile, const std::string & targetFile, std::string & strError);
39
49 static bool archiveFileToDirectory(const std::string & archiveDir, const std::string & sourceFile, const std::string & targetFile, std::string & strError);
50
60 static bool moveAllFilesInDirectory(const std::string & sourceDir, const std::string & targetDir, std::string & strError, const ms_taxonomyrules * taxRules = nullptr);
61 };
62
63 class CdbShard : public ms_errors
64 {
65 public:
66
76 CdbShard(const std::string & baseFileName, const char letter, const unsigned numCbdFiles, const bool keepFilesOpen, const bool splitShards);
77
78 ~CdbShard();
79
85 bool isGood() const { return success_; };
86
91 void prepareFiles();
92
97 void finaliseFiles();
98
104 std::string openFiles();
105
110 void closeFiles();
111
116 void retargetFiles(const std::string & targetBaseFileName, const std::string & compressionDir, const std::string & targetDir);
117
123 char getLetter() const { return letter_; };
124
130 int getNumCdb() const { return static_cast<int>(vecCdbFiles_.size()); };
131
138 int getIntValue(const std::string & key) const;
139
147 bool setIntValue(const std::string & key, const int intValue);
148
149 private:
150 std::string getCdbFileName(char c, int num) const;
151
152 std::string baseFileName_;
153 char letter_;
154 bool success_;
155 UINT64 currentCdbSize_;
156 unsigned currentCdbFileIdx_;
157 unsigned numCdbFiles_; //only relevant when reading if splitShards is true
158
159 //performance tuning
160 bool keepFilesOpen_;
161 bool splitShards_;
162
163 std::vector<matrix_science::ms_tinycdb *> vecCdbFiles_;
164 };
165
166 class CdbSharding : public ms_errors
167 {
168 public:
169
178 CdbSharding(const std::string & baseFileName, const bool keepFilesOpen, const bool splitShards, const std::string preparingDir = ".");
179
180 ~CdbSharding();
181
187 bool isGood() const;
188
194 bool mustCreate() { return mustCreate_; }
195
201 bool prepareShards();
202
208 std::string getWorkingBaseFileName();
209
215 bool finaliseShards();
216
222 bool openShards();
223
228 void closeShards();
229
236 int getIntValue(const std::string & accession) const;
237
245 bool setIntValue(const std::string & accession, const int intValue);
246
247 private:
248 bool deletePreviousFiles();
249 bool isNumberOrLetter(const char c) const;
250 CdbShard * getShardForAccession(const std::string & accession) const;
251
252 std::string baseFileName_;
253 bool success_;
254
255 bool mustCreate_;
256
257 //performance tuning
258 bool keepFilesOpen_;
259 bool splitShards_;
260
261 matrix_science::ms_tinycdb * mainCdbFile_; //this is used to store how many cdb files each shard has
262 std::vector<CdbShard *> vecCharToShard_;
263 std::vector<CdbShard *> vecShards_;
264
265 std::string preparingDir_;
266 std::string sourceDir_;
267 std::string baseFileName_withoutPath_;
268 bool differentCompressionDir_;
269 std::string working_baseFileName_;
270 };
271
272} // namespace msparser_internal
273
274#endif // SWIG
275
276#endif // MS_CDB_SHARDING_HPP
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_taxonomyrules
This class represents a single Taxonomy_XXX section in mascot.dat.
Definition: ms_taxonomyrules.hpp:247
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_clusterparams.hpp Source File

  • inc
ms_clusterparams.hpp
1/*
2##############################################################################
3# file: ms_clusterparams.hpp #
4# 'msparser' toolkit #
5# Encapsulates "mascot.dat"-file that describes most important parameters #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_clusterparams.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_CLUSTERPARAMS_HPP
20#define MS_CLUSTERPARAMS_HPP
21
22
23#include <string>
24
25
26namespace matrix_science {
40 enum OPERATING_SYS
41 {
42 _OS_UNKNOWN = 0,
43 _OS_WINDOWS_NT = 1,
44 _OS_LINUX = 2,
45 _OS_NUM_OPERATING_SYS = 3
46 };
47
49
71 class MS_MASCOTRESFILE_API ms_clusterparams: public ms_customproperty
72 {
73 friend class ms_datfile;
74 public:
76
83 enum {
84 NUM_PROCESSORS_AUTO_DETECT = -1
85 };
86
88 ms_clusterparams();
89
91 ms_clusterparams(const ms_clusterparams& src);
92
94 ~ms_clusterparams();
95
97 void defaultValues();
98
100 void copyFrom(const ms_clusterparams* right);
101
102#ifndef SWIG
104 ms_clusterparams& operator=(const ms_clusterparams& right);
105#endif
107 bool isSectionAvailable() const;
108
110 void setSectionAvailable(const bool value);
111
113 bool isEnabled() const;
114
116 void setEnabled(const bool flag);
117
119 const ms_computeraddress* getMasterComputer() const;
120
122 void setMasterComputer(const ms_computeraddress* value);
123
125 OPERATING_SYS getDefaultNodeOS() const;
126
128 void setDefaultNodeOS(const OPERATING_SYS value);
129
131 std::string getDefaultNodeHomeDir() const;
132
134 void setDefaultNodeHomeDir(const char* str);
135
137 int getDefaultPort() const;
138
140 void setDefaultPort(const int value);
141
143 std::string getDefaultNodeHomeDirFromMaster() const;
144
146 void setDefaultNodeHomeDirFromMaster(const char* str);
147
149 std::string getMascotNodeScript() const;
150
152 void setMascotNodeScript(const char* str);
153
155 std::string getMascotNodeRebootScript() const;
156
158 void setMascotNodeRebootScript(const char* str);
159
161 int getNumberOfSubClusters() const;
162
164 void clearSubClusters();
165
167 int getSubClusterID(const int index) const;
168
170 int getSubClusterMaxCPU(const int index) const;
171
173 void appendSubCluster(const int id, const int maxCPUs);
174
175 // internal usage only
176 int getThisSubClusterID() const;
177
178 // internal usage only
179 void setThisSubClusterID(const int id);
180
182 int getIPCTimeout() const;
183
185 void setIPCTimeout(const int value);
186
188 int getIPCLogging() const;
189
191 void setIPCLogging(const int value);
192
194 std::string getIPCLogfile() const;
195
197 void setIPCLogfile(const char* str);
198
200 int getCheckNodesAliveFreq() const;
201
203 void setCheckNodesAliveFreq(const int value);
204
206 int getSecsToWaitForNodeAtStartup() const;
207
209 void setSecsToWaitForNodeAtStartup(const int value);
210
212 std::string getNodeSequenceDatabaseDir() const;
213
215 void setNodeSequenceDatabaseDir(const char* str);
216
217#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
218#include "suppress_ms_customproperty.hpp"
219#endif
220
221 private:
222 bool sectionAvailable_;
223 bool enabled_;
224
225 ms_computeraddress masterComputer_;
226
227 OPERATING_SYS defaultNodeOS_;
228 std::string szDefaultNodeHomeDir_;
229 int defaultPort_;
230 std::string szDefaultNodeHomeDirFromMaster_;
231 std::string szMascotNodeScript_;
232 std::string szMascotNodeRebootScript_;
233
234 std::vector<int> subClusterIDs_;
235 std::vector<int> maxCpusPerSubCluster_;
236 bool anySubCluster_;
237
238 int thisSubCluster_;
239
240 int IPCTimeout_;
241 int IPCLogging_;
242 std::string IPCLogfile_;
243 int checkNodesAliveFreq_;
244 int secsToWaitForNodeAtStartup_;
245
246 std::string szNodeSequenceDatabaseDir_;
247 }; // class ms_clusterparams // end of config_group
249} // namespace matrix_science
250
251#endif // MS_CLUSTERPARAMS_HPP
252
253/*------------------------------- End of File -------------------------------*/
matrix_science::ms_clusterparams
An instance of this class represents all the parameters specified in the Cluster section of mascot....
Definition: ms_clusterparams.hpp:72
matrix_science::ms_computeraddress
The class serves as a container for computer address parameters for cluster mode.
Definition: ms_computeraddress.hpp:34
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::OPERATING_SYS
OPERATING_SYS
Definition: ms_clusterparams.hpp:41
matrix_science::_OS_NUM_OPERATING_SYS
@ _OS_NUM_OPERATING_SYS
Placeholder.
Definition: ms_clusterparams.hpp:45
matrix_science::_OS_WINDOWS_NT
@ _OS_WINDOWS_NT
WindowsXXX.
Definition: ms_clusterparams.hpp:43
matrix_science::_OS_LINUX
@ _OS_LINUX
Linux.
Definition: ms_clusterparams.hpp:44
matrix_science::_OS_UNKNOWN
@ _OS_UNKNOWN
Unknown OS.
Definition: ms_clusterparams.hpp:42
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_computeraddress.hpp Source File

  • inc
ms_computeraddress.hpp
1/*
2##############################################################################
3# file: ms_computeraddress.hpp #
4# 'msparser' toolkit #
5# Contains computer address parameters required by cluster mode #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_computeraddress.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_COMPUTERADDRESS_HPP
20#define MS_COMPUTERADDRESS_HPP
21
22
23#include <string>
24#include <vector>
25
26namespace matrix_science {
33 class MS_MASCOTRESFILE_API ms_computeraddress
34 {
35 friend class ms_datfile;
36 friend class ms_clusterparams;
37
38 public:
40 ms_computeraddress();
41
43 ms_computeraddress(const ms_computeraddress& src);
44
46 ~ms_computeraddress();
47
49 void defaultValues();
50
52 void copyFrom(const ms_computeraddress* right);
53
54#ifndef SWIG
56 ms_computeraddress& operator=(const ms_computeraddress& right);
57#endif
59 std::string getInetAddress() const;
60
62 void setInetAddress(const char* address);
63
65 std::string getHostName() const;
66
68 void setHostName(const char* name);
69
71 unsigned int getPort() const;
72
74 void setPort(const unsigned int value);
75
76 private:
77 std::string inetAddress_;
78 std::string hostName_;
79 unsigned short port_;
80
81 void setCustomString();
82 std::string customString_;
83 }; // class ms_computeraddress // end of config_group
85} // namespace matrix_science
86
87#endif // MS_COMPUTERADDRESS_HPP
88
89/*------------------------------- End of File -------------------------------*/
matrix_science::ms_clusterparams
An instance of this class represents all the parameters specified in the Cluster section of mascot....
Definition: ms_clusterparams.hpp:72
matrix_science::ms_computeraddress
The class serves as a container for computer address parameters for cluster mode.
Definition: ms_computeraddress.hpp:34
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_connection_settings.hpp Source File

  • inc
ms_connection_settings.hpp
1/*
2##############################################################################
3# file: ms_connection_settings.hpp #
4# 'msparser' toolkit #
5# Holds the proxy server and Mascot sessionID string #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source: parser/inc/ms_connection_settings.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19
20
21#if !defined(ms_connection_settings_INCLUDED_)
22#define ms_connection_settings_INCLUDED_
23
24
25// Includes from the standard template library
26#include <string>
27
28
29namespace matrix_science {
30 class ms_mascotoptions;
31
39
53 class MS_MASCOTRESFILE_API ms_connection_settings
54 {
55
56 public:
58
61 enum PROXY_TYPE
62 {
63 PROXY_TYPE_NO_PROXY = 0x0000,
64 PROXY_TYPE_FROM_REGISTRY = 0x0001,
65 PROXY_TYPE_SPECIFY = 0x0002,
66 PROXY_TYPE_WPAD = 0x0003,
67 PROXY_TYPE_ENVIRONMENT = 0x0004,
68 PROXY_TYPE_AUTO = 0x0005
69 };
70
75 enum HTTP_PROTOCOL
76 {
77 HTTP_1_0 = 0x0000,
78 HTTP_1_1 = 0x0001,
79 HTTP_SYSTEM_DEFAULT = 0x0002
80 };
81
86 enum REDIRECT_POLICY
87 {
88 REDIRECT_POLICY_ALWAYS = 0x0000,
89 REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP = 0x0001,
90 REDIRECT_POLICY_NEVER = 0x0002
91 };
92
94 ms_connection_settings();
95
97 ms_connection_settings(const std::string sessionID,
98 const std::string proxyServer,
99 const std::string proxyUserName,
100 const std::string proxyUserPassword);
101
103 ~ms_connection_settings();
104
106 void defaultValues();
107
109 void copyFrom(const ms_connection_settings* right);
110
111#ifndef SWIG
113 ms_connection_settings& operator=(const ms_connection_settings & right);
114#endif
116 void setSessionID(const std::string sessionID);
117
119 void setProxyServerType(ms_connection_settings::PROXY_TYPE proxyType);
120
122 ms_connection_settings::PROXY_TYPE getProxyServerType() const;
123
125 void setHttpProtocol(ms_connection_settings::HTTP_PROTOCOL httpProtocol);
126
128 ms_connection_settings::HTTP_PROTOCOL getHttpProtocol() const;
129
131 void setProxyServer(const std::string proxyServer);
132
134 void setProxyUsername(const std::string proxyUserName);
135
137 void setProxyPassword(const std::string proxyUserPassword);
138
140 void setUserAgent(const std::string userAgent);
141
143 void setUseHTTPProxyForFTP(bool value);
144
146 void setUseHTTPProxyForHTTPS(bool value);
147
149 std::string getSessionID() const;
150
152 std::string getProxyServer() const;
153
155 std::string getProxyUsername() const;
156
158 std::string getProxyPassword() const;
159
161 std::string getProxyUserAndPassword() const;
162
164 std::string getUserAgent() const;
165
167 bool isUseHTTPProxyForFTP() const;
168
170 bool isUseHTTPProxyForHTTPS() const;
171
173 void setConnectionTimeout(int timeout);
174
176 int getConnectionTimeout() const;
177
179 void setHttpUsername(const std::string httpUsername);
180
182 std::string getHttpUsername() const;
183
185 void setHttpPassword(const std::string httpPassword);
186
188 std::string getHttpPassword() const;
189
191 void setRedirectPolicy(ms_connection_settings::REDIRECT_POLICY redirectPolicy);
192
194 ms_connection_settings::REDIRECT_POLICY getRedirectPolicy() const;
195
197 void getProxySettings(const ms_mascotoptions &opts);
198
200 static int proxyTypeStringToEnum(std::string str);
201
203 static std::string proxyTypeToString(int type);
204
205 private:
206 std::string sessionID_;
207 std::string proxyServer_;
208 std::string proxyUserName_;
209 std::string proxyUserPassword_;
210 bool useHTTPProxyForFTP_;
211 bool useHTTPProxyForHTTPS_;
212 std::string userAgent_;
213 PROXY_TYPE proxyType_;
214 HTTP_PROTOCOL httpProtocol_;
215 int connectionTimeout_;
216 std::string httpUsername_;
217 std::string httpPassword_;
218 REDIRECT_POLICY redirectPolicy_;
219
220 struct proxy_type_strings_t {
221 const char *str;
222 const char *pretty_str;
223 int type;
224 };
225
226 static const struct proxy_type_strings_t proxy_type_strings[];
227 }; // end of http_client_groupp
229}
230#endif // !defined(ms_connection_settings_INCLUDED_)
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_connection_settings::REDIRECT_POLICY
REDIRECT_POLICY
Definition: ms_connection_settings.hpp:87
matrix_science::ms_connection_settings::HTTP_PROTOCOL
HTTP_PROTOCOL
Definition: ms_connection_settings.hpp:76
matrix_science::ms_connection_settings::PROXY_TYPE
PROXY_TYPE
Definitions for types of setting.
Definition: ms_connection_settings.hpp:62
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_cronoptions.hpp Source File

  • inc
ms_cronoptions.hpp
1/*
2##############################################################################
3# file: ms_cronoptions.hpp #
4# 'msparser' toolkit #
5# Represents parameters from cron-section of 'mascot.dat' configuration file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_cronoptions.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_CRONOPTIONS_HPP
20#define MS_CRONOPTIONS_HPP
21
22
23#include <string>
24#include <vector>
25
26
27namespace matrix_science {
34
37 class MS_MASCOTRESFILE_API ms_cronjob
38 {
39 friend class ms_datfile;
40 friend class ms_cronoptions;
41
42 public:
44 ms_cronjob();
45
47 ms_cronjob(const ms_cronjob& src);
48
50 ~ms_cronjob();
51
53 void defaultValues();
54
56 void copyFrom(const ms_cronjob* right);
57
58#ifndef SWIG
60 ms_cronjob& operator=(const ms_cronjob& right);
61#endif
63 bool isEnabled() const;
64
66 void setEnabled(const bool enabled);
67
69 bool isMinute(const int min) const;
70
72 void setMinute(const int min, const bool value);
73
75 bool isHour(const int hour) const;
76
78 void setHour(const int hour, const bool value);
79
81 bool isDayOfMonth(const int day) const;
82
84 void setDayOfMonth(const int day, const bool value);
85
87 bool isMonthOfYear(const int month) const;
88
90 void setMonthOfYear(const int month, const bool value);
91
93 bool isDayOfWeek(const int day) const;
94
96 void setDayOfWeek(const int day, const bool value);
97
99 std::string getCommandStr() const;
100
102 void setCommandStr(const char* str);
103
104 // used internally
105 std::string getStringValue() const;
106
107 private:
108 bool enabled_; /* If false, then a #[space] at start of line */
109 bool minute_[60]; /* index of 0-59 - Value of true means do it */
110 bool hour_[24]; /* index of 0-23 - Value of true means do it */
111 bool dayOfMonth_[32]; /* index of 1-31 - Value of true means do it */
112 bool monthOfYear_[13]; /* index of 1-12 - Value of true means do it */
113 bool dayOfWeek_[7]; /* index of 0-6 (0 = Sunday) */
114 std::string szCommand_;
115
116 void setCustomString();
117 std::string customString_;
118 }; // class ms_cronjob
119
121
149 class MS_MASCOTRESFILE_API ms_cronoptions: public ms_customproperty
150 {
151 friend class ms_datfile;
152 public:
153
155 ms_cronoptions();
156
158 ms_cronoptions(const ms_cronoptions& src);
159
161 ~ms_cronoptions();
162
164 void defaultValues();
165
167 void copyFrom(const ms_cronoptions* right);
168
169#ifndef SWIG
171 ms_cronoptions& operator=(const ms_cronoptions& right);
172#endif
174 bool isSectionAvailable() const;
175
177 void setSectionAvailable(const bool value);
178
180 bool isCronEnabled() const;
181
183 void setCronEnabled(const bool value);
184
186 int getNumberOfCronJobs() const;
187
189 const ms_cronjob getCronJob(const int idx) const;
190
192 bool setCronJob(const int idx, const ms_cronjob job);
193
195 bool deleteCronJob(const int idx);
196
198 void clearCronJobs();
199
201 void appendCronJob(const ms_cronjob* job);
202
204 int getLoggingLevel() const;
205
207 bool setLoggingLevel(const int level);
208
210 std::string getLogFileName() const;
211
213 bool setLogFileName(const std::string & fileName);
214
215
216#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
217#include "suppress_ms_customproperty.hpp"
218#endif
219
220 private:
221 int findProperty(const ms_cronjob & job) const;
222 bool getPropertyNameValue(const ms_cronjob & job, std::string & name, std::string & value) const;
223 bool sectionAvailable_;
224 bool cronEnabled_;
225 std::vector< ms_cronjob > cronJobArray_;
226 int loggingLevel_;
227 std::string logFileName_;
228 }; // ms_cronoptions // end of config_group
230} // namespace matrix_science
231
232#endif // MS_CRONOPTIONS_HPP
233
234/*------------------------------- End of File -------------------------------*/
matrix_science::ms_cronjob
Represents a single entry from the cron section of mascot.dat.
Definition: ms_cronoptions.hpp:38
matrix_science::ms_cronoptions
Contains parameters from the cron section of mascot.dat.
Definition: ms_cronoptions.hpp:150
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_accession.hpp Source File

  • inc
ms_crosslinking_accession.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_accession.hpp #
4# 'msparser' toolkit #
5# Encapsulates accession element in crosslinking.xml #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_accession.hpp $
12 * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-12-20 12:05:22 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_ACCESSION_HPP
18#define MS_CROSSLINKING_ACCESSION_HPP
19
20
21#include <string>
22
23// forward declarations
24namespace msparser_internal {
25 class ms_crosslinking_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_xml_schema; // forward declaration
30
37
42 class MS_MASCOTRESFILE_API ms_crosslinking_accession: public ms_xml_IValidatable
43 {
44 friend class msparser_internal::ms_crosslinking_xmlloader;
45
46 public:
48 ms_crosslinking_accession();
49
51 ms_crosslinking_accession(const ms_crosslinking_accession& src);
52
54 virtual ~ms_crosslinking_accession();
55
57 void defaultValues();
58
60 void copyFrom(const ms_crosslinking_accession* right);
61
62#ifndef SWIG
64 ms_crosslinking_accession& operator=(const ms_crosslinking_accession& right);
65#endif
66
68 virtual std::string getSchemaType() const;
69
71 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
72
74 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
75
76
78 bool haveDatabaseName() const;
79
81 std::string getDatabaseName() const;
82
84 void setDatabaseName(const char* value);
85
87 void dropDatabaseName();
88
90 std::string getDatabaseNameSchemaType() const;
91
92
94 bool haveValue() const;
95
97 std::string getValue() const;
98
100 void setValue(const char* value);
101
103 void dropValue();
104
106 std::string getValueSchemaType() const;
107
108
109 private:
110 std::string _databaseName;
111 bool _databaseName_set;
112
113 std::string _value;
114
115 }; // class ms_crosslinking_accession
116 // end of config_group
118
119} // namespace matrix_science
120
121#endif // MS_CROSSLINKING_ACCESSION_HPP
122
123/*------------------------------- End of File -------------------------------*/
124
matrix_science::ms_crosslinking_accession
Accession element in crosslinking.xml
Definition: ms_crosslinking_accession.hpp:43
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_accessions.hpp Source File

  • inc
ms_crosslinking_accessions.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_accessions.hpp #
4# 'msparser' toolkit #
5# Encapsulates accessions element in crosslinking.xml #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_accessions.hpp $
12 * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-12-20 12:05:22 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_ACCESSIONS_HPP
18#define MS_CROSSLINKING_ACCESSIONS_HPP
19
20
21#include <string>
22
23// forward declarations
24namespace msparser_internal {
25 class ms_crosslinking_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_crosslinking_accession;
30 class ms_xml_schema; // forward declaration
31
38
43 class MS_MASCOTRESFILE_API ms_crosslinking_accessions: public ms_xml_IValidatable
44 {
45 friend class msparser_internal::ms_crosslinking_xmlloader;
46
47 public:
49 ms_crosslinking_accessions();
50
52 ms_crosslinking_accessions(const ms_crosslinking_accessions& src);
53
55 virtual ~ms_crosslinking_accessions();
56
58 void defaultValues();
59
61 void copyFrom(const ms_crosslinking_accessions* right);
62
63#ifndef SWIG
65 ms_crosslinking_accessions& operator=(const ms_crosslinking_accessions& right);
66#endif
67
69 virtual std::string getSchemaType() const;
70
72 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
73
75 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
76
77
79 int getNumberOfAccessions() const;
80
82 void clearAccessions();
83
85 void appendAccession(const ms_crosslinking_accession *item);
86
88 const ms_crosslinking_accession * getAccessionByNumber(const int idx) const;
89
91 bool updateAccessionByNumber(const int idx, const ms_crosslinking_accession* accession);
92
94 bool deleteAccessionByNumber(const int idx);
95
97 std::string getAccessionSchemaType() const;
98
99
100 private:
101 typedef std::vector< ms_crosslinking_accession * > accession_vector;
102 accession_vector _accessions;
103
104 }; // class ms_crosslinking_accessions
105 // end of config_group
107
108} // namespace matrix_science
109
110#endif // MS_CROSSLINKING_ACCESSIONS_HPP
111
112/*------------------------------- End of File -------------------------------*/
113
matrix_science::ms_crosslinking_accession
Accession element in crosslinking.xml
Definition: ms_crosslinking_accession.hpp:43
matrix_science::ms_crosslinking_accessions
Accessions element in crosslinking.xml
Definition: ms_crosslinking_accessions.hpp:44
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_configfile.hpp Source File

  • inc
ms_crosslinking_configfile.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_configfile.hpp #
4# 'msparser' toolkit #
5# Represents crosslinking.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: villek@matrixscience.com $ #
12# $Date: 2018-12-20 12:05:22 +0000 $ #
13# $Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14##############################################################################
15*/
16
17#ifndef MS_CROSSLINKING_CONFIGFILE_HPP
18#define MS_CROSSLINKING_CONFIGFILE_HPP
19
20
21#include <string>
22#include <vector>
23
24
25namespace matrix_science {
26 class ms_crosslinking_method; // forward declaration
27
34
48 class MS_MASCOTRESFILE_API ms_crosslinking_configfile: public ms_errors
49 {
50 public:
52 ms_crosslinking_configfile();
53
55 ms_crosslinking_configfile(const char* fileName, const char* schemaFileName,
56 const ms_connection_settings * cs = 0, bool useSchema = true);
57
59 ms_crosslinking_configfile(const ms_crosslinking_configfile& right);
60
62 virtual ~ms_crosslinking_configfile();
63
64#ifndef SWIG
66 ms_crosslinking_configfile& operator=(const ms_crosslinking_configfile& right);
67#endif
69 void copyFrom(const ms_crosslinking_configfile* right);
70
72 virtual void defaultValues();
73
75 std::string getFileName() const;
76
78 void setFileName(const char* filename);
79
81 void setSchemaFileName(const char* name);
82
84 std::string getSchemaFileName() const;
85
87 static std::string getDefaultSchemaFileName();
88
90 void setConnectionSettings(const ms_connection_settings & cs);
91
93 ms_connection_settings getConnectionSettings() const;
94
96 void read_file();
97
99 void save_file();
100
102 void read_buffer(const char* buffer);
103
105 std::string save_buffer(bool validateAgainstSchema = true);
106
108 std::string validateDocument() const;
109
111 std::string getMajorVersion() const;
112
114 std::string getMinorVersion() const;
115
116
118 int getNumberOfMethods() const;
119
121 void clearMethods();
122
124 void appendMethod(const ms_crosslinking_method *elem);
125
127 const ms_crosslinking_method * getMethodByNumber(const int idx) const;
128
130 const ms_crosslinking_method * getMethodByName(const char *name) const;
131
133 bool updateMethodByNumber(const int idx, const ms_crosslinking_method* method);
134
136 bool updateMethodByName(const char *name, const ms_crosslinking_method* method);
137
139 bool deleteMethodByNumber(const int idx);
140
142 bool deleteMethodByName(const char *name);
143
144
145 private:
146 std::string m_fileName;
147 std::string m_schemaFileName;
148 ms_connection_settings m_cs;
149
150 std::string m_majorVersion;
151 std::string m_minorVersion;
152
153 std::string m_encodingName;
154 bool m_useSchema;
155
156 typedef std::vector< ms_crosslinking_method* > method_vector;
157 method_vector m_methods;
158
159 }; // class ms_crosslinking_configfile
160 // end of config_group
162
163} // namespace matrix_science
164
165#endif // MS_CROSSLINKING_CONFIGFILE_HPP
166/*------------------------------- End of File -------------------------------*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_crosslinking_configfile
This class represents the file crosslinking.xml.
Definition: ms_crosslinking_configfile.hpp:49
matrix_science::ms_crosslinking_method
Represents a method object in crosslinking.xml
Definition: ms_crosslinking_method.hpp:50
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_does_not_pair_with.hpp Source File

  • inc
ms_crosslinking_does_not_pair_with.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_does_not_pair_with.hpp #
4# 'msparser' toolkit #
5# Encapsulates does_not_pair_with element in crosslinking.xml #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_does_not_pair_with.hpp $
12 * @(#)$Revision: 5a6646e705a1dce6cb8493dec184ed46d0bd6c08 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2019-10-18 16:39:04 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_DOES_NOT_PAIR_WITH_HPP
18#define MS_CROSSLINKING_DOES_NOT_PAIR_WITH_HPP
19
20
21#include <string>
22
23// forward declarations
24namespace msparser_internal {
25 class ms_crosslinking_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_xml_schema; // forward declaration
30
37 class MS_MASCOTRESFILE_API ms_crosslinking_does_not_pair_with: public ms_xml_IValidatable
38 {
39 friend class msparser_internal::ms_crosslinking_xmlloader;
40
41 public:
43 ms_crosslinking_does_not_pair_with();
44
46 ms_crosslinking_does_not_pair_with(const ms_crosslinking_does_not_pair_with& src);
47
49 virtual ~ms_crosslinking_does_not_pair_with();
50
52 void defaultValues();
53
55 void copyFrom(const ms_crosslinking_does_not_pair_with* right);
56
57#ifndef SWIG
59 ms_crosslinking_does_not_pair_with& operator=(const ms_crosslinking_does_not_pair_with& right);
60#endif
61
63 virtual std::string getSchemaType() const;
64
66 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
67
69 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
70
71
73 bool haveModFileName() const;
74
76 std::string getModFileName() const;
77
79 void setModFileName(const char* value);
80
82 void dropModFileName();
83
85 std::string getModFileNameSchemaType() const;
86
87
88 private:
89 std::string _modFileName;
90 bool _modFileName_set;
91
92 }; // class ms_crosslinking_does_not_pair_with
93 // end of config_group
95
96} // namespace matrix_science
97
98#endif // MS_CROSSLINKING_DOES_NOT_PAIR_WITH_HPP
99
100/*------------------------------- End of File -------------------------------*/
101
matrix_science::ms_crosslinking_does_not_pair_with
mxm:does_not_pair_with element in crosslinking.xml
Definition: ms_crosslinking_does_not_pair_with.hpp:38
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_filters.hpp Source File

  • inc
ms_crosslinking_filters.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_filters.hpp #
4# 'msparser' toolkit #
5# Encapsulates the filters element in crosslinking.xml #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_filters.hpp $
12 * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-12-20 12:05:22 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_FILTERS_HPP
18#define MS_CROSSLINKING_FILTERS_HPP
19
20
21#include <string>
22#include <vector>
23
24namespace msparser_internal {
25 class ms_crosslinking_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_xml_schema; // forward declaration
30 class ms_crosslinking_parameters;
31
38
51 class MS_MASCOTRESFILE_API ms_crosslinking_filters: public ms_crosslinking_parameters
52 {
53 friend class msparser_internal::ms_crosslinking_xmlloader;
54
55 public:
57 ms_crosslinking_filters();
58
60 ms_crosslinking_filters(const ms_crosslinking_filters& src);
61
63 virtual ~ms_crosslinking_filters();
64
66 void defaultValues();
67
69 void copyFrom(const ms_crosslinking_filters* right);
70
71#ifndef SWIG
73 ms_crosslinking_filters& operator=(const ms_crosslinking_filters& right);
74#endif
76 virtual std::string getSchemaType() const;
77
79 virtual std::string getParameterSchemaType() const;
80
81 }; // class ms_crosslinking_filters
82 // end of config_group
84
85} // namespace matrix_science
86
87#endif // MS_CROSSLINKING_FILTERS_HPP
88
89/*------------------------------- End of File -------------------------------*/
90
matrix_science::ms_crosslinking_filters
Filters element in crosslinking.xml
Definition: ms_crosslinking_filters.hpp:52
matrix_science::ms_crosslinking_parameters
A class that represents base parametersType in crosslinking_1.xsd.
Definition: ms_crosslinking_parameters.hpp:84
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_linker.hpp Source File

  • inc
ms_crosslinking_linker.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_linker.hpp #
4# 'msparser' toolkit #
5# Encapsulates linker element in crosslinking.xml #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_linker.hpp $
12 * @(#)$Revision: 5a6646e705a1dce6cb8493dec184ed46d0bd6c08 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2019-10-18 16:39:04 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_LINKER_HPP
18#define MS_CROSSLINKING_LINKER_HPP
19
20
21#include <string>
22
23// forward declarations
24namespace msparser_internal {
25 class ms_crosslinking_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_crosslinking_monolink;
30 class ms_crosslinking_does_not_pair_with;
31 class ms_xml_schema; // forward declaration
32
39
56 class MS_MASCOTRESFILE_API ms_crosslinking_linker: public ms_xml_IValidatable
57 {
58 friend class msparser_internal::ms_crosslinking_xmlloader;
59
60 public:
62 ms_crosslinking_linker();
63
65 ms_crosslinking_linker(const ms_crosslinking_linker& src);
66
68 virtual ~ms_crosslinking_linker();
69
71 void defaultValues();
72
74 void copyFrom(const ms_crosslinking_linker* right);
75
76#ifndef SWIG
78 ms_crosslinking_linker& operator=(const ms_crosslinking_linker& right);
79#endif
80
82 virtual std::string getSchemaType() const;
83
85 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
86
88 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
89
91 bool haveModFileName() const;
92
94 std::string getModFileName() const;
95
97 void setModFileName(const char* value);
98
100 void dropModFileName();
101
103 std::string getModFileNameSchemaType() const;
104
105
107 int getNumberOfMonoLinks() const;
108
110 void clearMonoLinks();
111
113 void appendMonoLink(const ms_crosslinking_monolink *item);
114
116 const ms_crosslinking_monolink * getMonoLinkByNumber(const int idx) const;
117
119 bool updateMonoLinkByNumber(const int idx, const ms_crosslinking_monolink* monolink);
120
122 bool deleteMonoLinkByNumber(const int idx);
123
125 std::string getMonoLinkSchemaType() const;
126
127
129 int getNumberOfDoesNotPairWiths() const;
130
132 void clearDoesNotPairWiths();
133
135 void appendDoesNotPairWith(const ms_crosslinking_does_not_pair_with *item);
136
138 const ms_crosslinking_does_not_pair_with * getDoesNotPairWithByNumber(const int idx) const;
139
141 bool updateDoesNotPairWithByNumber(const int idx, const ms_crosslinking_does_not_pair_with* does_not_pair_with);
142
144 bool deleteDoesNotPairWithByNumber(const int idx);
145
147 std::string getDoesNotPairWithSchemaType() const;
148
149 private:
150 typedef std::vector< ms_crosslinking_monolink * > monolink_vector;
151 monolink_vector _monolinks;
152
153 typedef std::vector< ms_crosslinking_does_not_pair_with * > does_not_pair_with_vector;
154 does_not_pair_with_vector _does_not_pair_withs;
155
156 std::string _modFileName;
157 bool _modFileName_set;
158
159 }; // class ms_crosslinking_linker
160 // end of config_group
162
163} // namespace matrix_science
164
165#endif // MS_CROSSLINKING_LINKER_HPP
166
167/*------------------------------- End of File -------------------------------*/
168
matrix_science::ms_crosslinking_does_not_pair_with
mxm:does_not_pair_with element in crosslinking.xml
Definition: ms_crosslinking_does_not_pair_with.hpp:38
matrix_science::ms_crosslinking_linker
Linker element in crosslinking.xml
Definition: ms_crosslinking_linker.hpp:57
matrix_science::ms_crosslinking_monolink
Monolink element in crosslinking.xml
Definition: ms_crosslinking_monolink.hpp:38
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_linkers.hpp Source File

  • inc
ms_crosslinking_linkers.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_linkers.hpp #
4# 'msparser' toolkit #
5# Encapsulates linkers element in crosslinking.xml #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_linkers.hpp $
12 * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-12-20 12:05:22 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_LINKERS_HPP
18#define MS_CROSSLINKING_LINKERS_HPP
19
20
21#include <string>
22
23// forward declarations
24namespace msparser_internal {
25 class ms_crosslinking_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_crosslinking_linker;
30 class ms_xml_schema; // forward declaration
31
38
53 class MS_MASCOTRESFILE_API ms_crosslinking_linkers: public ms_xml_IValidatable
54 {
55 friend class msparser_internal::ms_crosslinking_xmlloader;
56
57 public:
59 ms_crosslinking_linkers();
60
62 ms_crosslinking_linkers(const ms_crosslinking_linkers& src);
63
65 virtual ~ms_crosslinking_linkers();
66
68 void defaultValues();
69
71 void copyFrom(const ms_crosslinking_linkers* right);
72
73#ifndef SWIG
75 ms_crosslinking_linkers& operator=(const ms_crosslinking_linkers& right);
76#endif
77
79 virtual std::string getSchemaType() const;
80
82 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
83
85 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
86
87
89 int getNumberOfLinkers() const;
90
92 void clearLinkers();
93
95 void appendLinker(const ms_crosslinking_linker *item);
96
98 const ms_crosslinking_linker * getLinkerByNumber(const int idx) const;
99
101 bool updateLinkerByNumber(const int idx, const ms_crosslinking_linker* linker);
102
104 bool deleteLinkerByNumber(const int idx);
105
107 std::string getLinkerSchemaType() const;
108
109 private:
110 typedef std::vector< ms_crosslinking_linker * > linker_vector;
111 linker_vector _linkers;
112
113 }; // class ms_crosslinking_linkers
114 // end of config_group
116
117} // namespace matrix_science
118
119#endif // MS_CROSSLINKING_LINKERS_HPP
120
121/*------------------------------- End of File -------------------------------*/
122
matrix_science::ms_crosslinking_linker
Linker element in crosslinking.xml
Definition: ms_crosslinking_linker.hpp:57
matrix_science::ms_crosslinking_linkers
Linkers element in crosslinking.xml
Definition: ms_crosslinking_linkers.hpp:54
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_method.hpp Source File

  • inc
ms_crosslinking_method.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_method.hpp #
4# 'msparser' toolkit #
5# Represents a method object in crosslinking.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_method.hpp $
12 * @(#)$Revision: 20373858f9250b373e137e3d5de4992e9e7d19e6 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2019-01-08 14:42:05 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_METHOD_HPP
18#define MS_CROSSLINKING_METHOD_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_crosslinking_xmlloader;
27}
28
29namespace matrix_science {
30 class ms_crosslinking_linkers; // forward declaration
31 class ms_crosslinking_accessions; // forward declaration
32 class ms_crosslinking_scope; // forward declaration
33 class ms_crosslinking_filters; // forward declaration
34 class ms_crosslinking_settings; // forward declaration
35 class ms_crosslinking_configfile; // forward declaration
36 class ms_xml_schema; // forward declaration
37
44
49 class MS_MASCOTRESFILE_API ms_crosslinking_method: public ms_xml_IValidatable
50 {
51 friend class msparser_internal::ms_crosslinking_xmlloader;
52 friend class ms_crosslinking_configfile;
53
54 public:
56 ms_crosslinking_method();
57
59 ms_crosslinking_method(const ms_crosslinking_method& src);
60
62 virtual ~ms_crosslinking_method();
63
65 void defaultValues();
66
68 void copyFrom(const ms_crosslinking_method* right);
69
70#ifndef SWIG
72 ms_crosslinking_method& operator=(const ms_crosslinking_method& right);
73#endif
74
76 virtual std::string getSchemaType() const;
77
79 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
80
82 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
83
84
86 bool haveName() const;
87
89 std::string getName() const;
90
92 void setName(const char* value);
93
95 void dropName();
96
98 std::string getNameSchemaType() const;
99
100
102 bool haveDescription() const;
103
105 std::string getDescription() const;
106
108 void setDescription(const char* value);
109
111 void dropDescription();
112
114 std::string getDescriptionSchemaType() const;
115
116
118 bool haveStrategy() const;
119
121 std::string getStrategy() const;
122
124 void setStrategy(const char* value);
125
127 void dropStrategy();
128
130 std::string getStrategySchemaType() const;
131
132
134 bool haveLinkers() const;
135
137 const ms_crosslinking_linkers* getLinkers() const;
138
140 void setLinkers(const ms_crosslinking_linkers* linkers);
141
143 void dropLinkers();
144
146 std::string getLinkersSchemaType() const;
147
148
150 bool haveAccessions() const;
151
153 const ms_crosslinking_accessions* getAccessions() const;
154
156 void setAccessions(const ms_crosslinking_accessions* accessions);
157
159 void dropAccessions();
160
162 std::string getAccessionsSchemaType() const;
163
164
166 bool haveScope() const;
167
169 const ms_crosslinking_scope* getScope() const;
170
172 void setScope(const ms_crosslinking_scope* scope);
173
175 void dropScope();
176
178 std::string getScopeSchemaType() const;
179
180
182 bool haveFilters() const;
183
185 const ms_crosslinking_filters* getFilters() const;
186
188 void setFilters(const ms_crosslinking_filters* filters);
189
191 void dropFilters();
192
194 std::string getFiltersSchemaType() const;
195
196
198 bool haveSettings() const;
199
201 const ms_crosslinking_settings* getSettings() const;
202
204 void setSettings(const ms_crosslinking_settings* settings);
205
207 void dropSettings();
208
210 std::string getSettingsSchemaType() const;
211
212
213 private:
214 std::string _name;
215 bool _name_set;
216
217 std::string _strategy;
218 bool _strategy_set;
219
220 std::string _description;
221 bool _description_set;
222
223 ms_crosslinking_linkers *_pLinkers;
224 ms_crosslinking_accessions *_pAccessions;
225 ms_crosslinking_scope *_pScope;
226 ms_crosslinking_filters *_pFilters;
227 ms_crosslinking_settings *_pSettings;
228
229 }; // class ms_crosslinking_method
230 // end of config_group
232
233} // namespace matrix_science
234
235#endif // MS_CROSSLINKING_METHOD_HPP
236
237/*------------------------------- End of File -------------------------------*/
238
matrix_science::ms_crosslinking_accessions
Accessions element in crosslinking.xml
Definition: ms_crosslinking_accessions.hpp:44
matrix_science::ms_crosslinking_configfile
This class represents the file crosslinking.xml.
Definition: ms_crosslinking_configfile.hpp:49
matrix_science::ms_crosslinking_filters
Filters element in crosslinking.xml
Definition: ms_crosslinking_filters.hpp:52
matrix_science::ms_crosslinking_linkers
Linkers element in crosslinking.xml
Definition: ms_crosslinking_linkers.hpp:54
matrix_science::ms_crosslinking_method
Represents a method object in crosslinking.xml
Definition: ms_crosslinking_method.hpp:50
matrix_science::ms_crosslinking_scope
Scope element in crosslinking.xml
Definition: ms_crosslinking_scope.hpp:52
matrix_science::ms_crosslinking_settings
Settings element in crosslinking.xml
Definition: ms_crosslinking_settings.hpp:76
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_monolink.hpp Source File

  • inc
ms_crosslinking_monolink.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_monolink.hpp #
4# 'msparser' toolkit #
5# Encapsulates monolink element in crosslinking.xml #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_monolink.hpp $
12 * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-12-20 12:05:22 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_MONOLINK_HPP
18#define MS_CROSSLINKING_MONOLINK_HPP
19
20
21#include <string>
22
23// forward declarations
24namespace msparser_internal {
25 class ms_crosslinking_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_xml_schema; // forward declaration
30
37 class MS_MASCOTRESFILE_API ms_crosslinking_monolink: public ms_xml_IValidatable
38 {
39 friend class msparser_internal::ms_crosslinking_xmlloader;
40
41 public:
43 ms_crosslinking_monolink();
44
46 ms_crosslinking_monolink(const ms_crosslinking_monolink& src);
47
49 virtual ~ms_crosslinking_monolink();
50
52 void defaultValues();
53
55 void copyFrom(const ms_crosslinking_monolink* right);
56
57#ifndef SWIG
59 ms_crosslinking_monolink& operator=(const ms_crosslinking_monolink& right);
60#endif
61
63 virtual std::string getSchemaType() const;
64
66 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
67
69 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
70
71
73 std::string getValue() const;
74
76 void setValue(const char* value);
77
79 std::string getValueSchemaType() const;
80
81
82 private:
83 std::string _value;
84
85 }; // class ms_crosslinking_monolink
86 // end of config_group
88
89} // namespace matrix_science
90
91#endif // MS_CROSSLINKING_MONOLINK_HPP
92
93/*------------------------------- End of File -------------------------------*/
94
matrix_science::ms_crosslinking_monolink
Monolink element in crosslinking.xml
Definition: ms_crosslinking_monolink.hpp:38
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_parameters.hpp Source File

  • inc
ms_crosslinking_parameters.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_parameters.hpp #
4# 'msparser' toolkit #
5# Encapsulates parameterType-definition from crosslinking_1.xsd #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_parameters.hpp $
12 * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-12-20 12:05:22 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_PARAMETERS_HPP
18#define MS_CROSSLINKING_PARAMETERS_HPP
19
20
21#include <string>
22#include <vector>
23
24namespace msparser_internal {
25 class ms_crosslinking_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_xml_parameters;
30 class ms_xml_schema; // forward declaration
31
38 class MS_MASCOTRESFILE_API ms_crosslinking_parameter: public ms_xml_parameter
39 {
40 friend class msparser_internal::ms_crosslinking_xmlloader;
41
42 public:
44 ms_crosslinking_parameter();
45
47 ms_crosslinking_parameter(const ms_crosslinking_parameter& src);
48
50 virtual ~ms_crosslinking_parameter();
51
53 void defaultValues();
54
56 void copyFrom(const ms_crosslinking_parameter* right);
57
58#ifndef SWIG
60 ms_crosslinking_parameter& operator=(const ms_crosslinking_parameter& right);
61#endif
63 virtual std::string getSchemaType() const;
64
66 virtual std::string getNameSchemaType() const;
67
69 virtual std::string getDescriptionSchemaType() const;
70
72 virtual std::string getValueSchemaType() const;
73
74 protected:
75 virtual bool saveToXML_ParameterByNumber(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const;
76
77 }; // class ms_crosslinking_parameter
78
80
83 class MS_MASCOTRESFILE_API ms_crosslinking_parameters: public ms_xml_parameters
84 {
85 friend class msparser_internal::ms_crosslinking_xmlloader;
86
87 public:
89 ms_crosslinking_parameters();
90
92 ms_crosslinking_parameters(const ms_crosslinking_parameters& src);
93
95 virtual ~ms_crosslinking_parameters();
96
98 void defaultValues();
99
101 void copyFrom(const ms_crosslinking_parameters* right);
102
103#ifndef SWIG
105 ms_crosslinking_parameters& operator=(const ms_crosslinking_parameters& right);
106#endif
108 virtual std::string getSchemaType() const;
109
111 virtual int getNumberOfParameters() const;
112
114 virtual void clearParameters();
115
117 void appendParameter(const ms_crosslinking_parameter *item);
118
120 const ms_crosslinking_parameter * getParameterByNumber(const int idx) const;
121
123 const ms_crosslinking_parameter * getParameterByName(const char *name) const;
124
126 bool updateParameterByNumber(const int idx, const ms_crosslinking_parameter *param);
127
129 bool updateParameterByName(const char *name, const ms_crosslinking_parameter *param);
130
132 virtual bool deleteParameterByNumber(const int idx);
133
135 virtual bool deleteParameterByName(const char *name);
136
138 virtual std::string getParameterSchemaType() const;
139
140 protected:
141 virtual bool saveToXML_Parameters(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const;
142
143 private:
144 typedef std::vector< ms_crosslinking_parameter* > entries_vector;
145 entries_vector _entries;
146
147 }; // class ms_crosslinking_parameters
148 // end of config_group
150
151} // namespace matrix_science
152
153#endif // MS_CROSSLINKING_PARAMETERS_HPP
154
155/*------------------------------- End of File -------------------------------*/
156
matrix_science::ms_crosslinking_parameter
Parameter name and value pair.
Definition: ms_crosslinking_parameters.hpp:39
matrix_science::ms_crosslinking_parameters
A class that represents base parametersType in crosslinking_1.xsd.
Definition: ms_crosslinking_parameters.hpp:84
matrix_science::ms_xml_parameter
Parameter name and value pair.
Definition: ms_xml_parameters.hpp:46
matrix_science::ms_xml_parameters
A class that represents a base parametersType.
Definition: ms_xml_parameters.hpp:140
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_scope.hpp Source File

  • inc
ms_crosslinking_scope.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_scope.hpp #
4# 'msparser' toolkit #
5# Encapsulates the scope element in crosslinking.xml #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_scope.hpp $
12 * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-12-20 12:05:22 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_SCOPE_HPP
18#define MS_CROSSLINKING_SCOPE_HPP
19
20
21#include <string>
22#include <vector>
23
24namespace msparser_internal {
25 class ms_crosslinking_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_xml_schema; // forward declaration
30 class ms_crosslinking_parameters;
31
38
51 class MS_MASCOTRESFILE_API ms_crosslinking_scope: public ms_crosslinking_parameters
52 {
53 friend class msparser_internal::ms_crosslinking_xmlloader;
54
55 public:
57 ms_crosslinking_scope();
58
60 ms_crosslinking_scope(const ms_crosslinking_scope& src);
61
63 virtual ~ms_crosslinking_scope();
64
66 void defaultValues();
67
69 void copyFrom(const ms_crosslinking_scope* right);
70
71#ifndef SWIG
73 ms_crosslinking_scope& operator=(const ms_crosslinking_scope& right);
74#endif
76 virtual std::string getSchemaType() const;
77
79 virtual std::string getParameterSchemaType() const;
80
81 }; // class ms_crosslinking_scope
82 // end of config_group
84
85} // namespace matrix_science
86
87#endif // MS_CROSSLINKING_SCOPE_HPP
88
89/*------------------------------- End of File -------------------------------*/
90
matrix_science::ms_crosslinking_parameters
A class that represents base parametersType in crosslinking_1.xsd.
Definition: ms_crosslinking_parameters.hpp:84
matrix_science::ms_crosslinking_scope
Scope element in crosslinking.xml
Definition: ms_crosslinking_scope.hpp:52
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_crosslinking_settings.hpp Source File

  • inc
ms_crosslinking_settings.hpp
1/*
2##############################################################################
3# file: ms_crosslinking_settings.hpp #
4# 'msparser' toolkit #
5# Encapsulates the settings element in crosslinking.xml #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_crosslinking_settings.hpp $
12 * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-12-20 12:05:22 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_CROSSLINKING_SETTINGS_HPP
18#define MS_CROSSLINKING_SETTINGS_HPP
19
20
21#include <string>
22#include <vector>
23
24namespace msparser_internal {
25 class ms_crosslinking_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_xml_schema; // forward declaration
30 class ms_crosslinking_parameters;
31
38
75 class MS_MASCOTRESFILE_API ms_crosslinking_settings: public ms_crosslinking_parameters
76 {
77 friend class msparser_internal::ms_crosslinking_xmlloader;
78
79 public:
81 ms_crosslinking_settings();
82
84 ms_crosslinking_settings(const ms_crosslinking_settings& src);
85
87 virtual ~ms_crosslinking_settings();
88
90 void defaultValues();
91
93 void copyFrom(const ms_crosslinking_settings* right);
94
95#ifndef SWIG
97 ms_crosslinking_settings& operator=(const ms_crosslinking_settings& right);
98#endif
100 virtual std::string getSchemaType() const;
101
103 virtual std::string getParameterSchemaType() const;
104
105 }; // class ms_crosslinking_settings
106 // end of config_group
108
109} // namespace matrix_science
110
111#endif // MS_CROSSLINKING_SETTINGS_HPP
112
113/*------------------------------- End of File -------------------------------*/
114
matrix_science::ms_crosslinking_parameters
A class that represents base parametersType in crosslinking_1.xsd.
Definition: ms_crosslinking_parameters.hpp:84
matrix_science::ms_crosslinking_settings
Settings element in crosslinking.xml
Definition: ms_crosslinking_settings.hpp:76
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_customproperty.hpp Source File

  • inc
ms_customproperty.hpp
1/*
2##############################################################################
3# file: ms_customproperty.hpp #
4# 'msparser' toolkit #
5# Represents a custom property with unknown structure. It is useful for new #
6# properties or for properties with variable structure that can be explored #
7# at run-time #
8##############################################################################
9# COPYRIGHT NOTICE #
10# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
11# #
12##############################################################################
13# $Archive:: /Mowse/ms_mascotresfile/include/ms_customproperty.hpp $ #
14# $Author: villek@matrixscience.com $ #
15# $Date: 2018-07-30 16:23:53 +0100 $ #
16# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
17# $NoKeywords:: $ #
18##############################################################################
19*/
20
21#ifndef MS_CUSTOMPROPERTY_HPP
22#define MS_CUSTOMPROPERTY_HPP
23
24
25#include <string>
26#include <vector>
27
28#include "msparser_lim.hpp"
29
30namespace matrix_science {
31
33
90 class MS_MASCOTRESFILE_API ms_customproperty
91 {
92 public:
94 ms_customproperty();
95
97 ~ms_customproperty();
98
100 void defaultValues();
101
103 void copyFrom(const ms_customproperty* src);
104
106 int getNumberOfProperties() const;
107
109 std::string getPropertyName(const int index) const;
110
112 void setPropertyName(const int index, const char* name);
113
115 int findProperty(const char* name, const int startFrom = 0) const;
116
118 int findPropertyBeginning(const char* nameBeginning, const int startFrom = 0) const;
119
121 std::string getPropValStringByName(const char* name) const;
122
124 std::string getPropValStringByNumber(const int index) const;
125
127 std::string getDelimiterByNumber(const int index) const;
128
130 void appendProperty
131 ( const char* name
132 , const char* value
133 , const char* delimiter
134 , const bool bFirstPlace = false
135 );
136
138 void appendText
139 ( const char* line
140 , const bool bFirstPlace = false
141 );
142
144 void setPropValStringByName
145 ( const char* name
146 , const char* value
147 , const bool bFirstPlace = false
148 );
149
151 void setPropValCharByName
152 ( const char* name
153 , const char value
154 , const bool bFirstPlace = false
155 );
156
158 void setPropValIntByName
159 ( const char* name
160 , const int value
161 , const bool bFirstPlace = false
162 );
163
165 void setPropValInt64ByName
166 ( const char* name
167 , const INT64 value
168 , const bool bFirstPlace = false
169 );
170
172 void setPropValBoolByName
173 ( const char* name
174 , const bool value
175 , const bool bFirstPlace = false
176 );
177
179 void setPropValFloatByName
180 ( const char* name
181 , const double value
182 , const bool bFirstPlace = false
183 );
184
186 void setPropValStringByNumber
187 ( const int index
188 , const char* value
189 );
190
191
193 std::string getDefaultDelimiter() const;
194
196 void setDefaultDelimiter(const char* delim);
197
199 void delProp(const char* name);
200
202 void delPropStart(const char* nameBeginning);
203
205 void delNonEmpty();
206
208 void delPropByNumber(const int index);
209
211 bool uncommentProp(const int index, const char * delimeter = 0);
212
214 std::string getPreceedingComments() const;
215
217 void setPreceedingComments(const std::string & comments);
218
219 private:
220 std::vector< std::string > names_;
221 std::vector< std::string > values_;
222 std::vector< std::string > delimiters_;
223 std::string defaultDelimiter_;
224 std::string preceedingComments_;
225 }; // class ms_customproperty
226} // namespace matrix_science
227
228#endif // MS_CUSTOMPROPERTY_HPP
229
230/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_customquantitation.hpp Source File

  • inc
ms_customquantitation.hpp
1/*
2##############################################################################
3# file: ms_customquantitation.hpp #
4# 'msparser' toolkit #
5# Quantitation for Reporter and Multiplex protocols #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: francoisr@matrixscience.com $ #
12# $Date: 2018-11-22 11:02:10 +0000 $ #
13# $Revision: b577d675f5daad88ac6730bda521ef7317380154 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_CUSTOMQUANTITATION_HPP
19#define MS_CUSTOMQUANTITATION_HPP
20
21
22// Includes from the standard template library
23#include <string>
24#include <vector>
25#include <utility>
26
27namespace msparser_internal {
28 struct peptide_ratio_data_t;
29}
30
31namespace matrix_science {
32 class ms_peptide_quant_ratio;
33 class ms_quantitation;
34 class ms_peptidesummary;
35 class ms_ms2quantitation;
36 class ms_protein;
37 class ms_peptide_quant_key;
38 class ms_peptide_quant_key_vector;
39 class ms_quant_average;
40
47
118 class MS_MASCOTRESFILE_API ms_customquantitation: public ms_quantitation
119 {
120 public:
122 explicit ms_customquantitation(const ms_quant_method &qm);
123
125 explicit ms_customquantitation(const ms_peptidesummary &initFrom);
126
128 ms_customquantitation(const ms_peptidesummary &initFrom, const ms_quant_method &qm);
129
131 explicit ms_customquantitation(const ms_ms2quantitation &copyFrom);
132
134 virtual ~ms_customquantitation();
135
136 virtual bool hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const;
137 virtual ms_peptide_quant_ratio getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const;
138
139 virtual bool isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const;
140 virtual void setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName);
141 virtual void setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName);
142
143 virtual void setProteinRatioType(const char *value);
144
145 virtual void setQuantOutliers(const ms_quant_outliers *);
146
147 virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const;
148
149 virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const;
150
152 void addPeptideRatio(const ms_peptide_quant_ratio &ratio);
153
155 void removePeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName);
156
158 void clearPeptideRatios();
159
161 void addPeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key);
162
164 void addPeptideQuantKeys(const std::string &accession, int dbIdx, const std::vector<ms_peptide_quant_key> &keys);
165
167 void addPeptideQuantKeys(const std::string &accession, int dbIdx, const ms_peptide_quant_key_vector &keys);
168
170 void removePeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key);
171
173 void clearPeptideQuantKeys(const std::string &accession, int dbIdx);
174
176 double getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType) const;
177
179 double getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const ms_peptide_quant_key_vector &keys) const;
180
182 double getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const std::string &accession, int dbIdx) const;
183
184 protected:
185 virtual void getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set<ms_peptide_quant_key> &keys, const std::set<ms_peptide_quant_key> &includeKeys, const std::set<ms_peptide_quant_key> &excludeKEys, std::vector<double> &values, std::vector<double> &weights, std::vector<ms_peptide_quant_key> &activeKeys, std::map<ms_peptide_quant_key, int> &inactiveKeys) const;
186
187 void addPeptideQuantKeySibling(const ms_peptide_quant_key & originalKey, const ms_peptide_quant_key & newKey);
188 void removePeptideQuantKeySibling(const ms_peptide_quant_key & newKey);
189
190 private:
191 ms_customquantitation(const ms_customquantitation &copyFrom);
192 ms_customquantitation& operator=(const ms_customquantitation &right);
193
194 typedef std::string ratio_name_t;
195
196 typedef std::map< ms_peptide_quant_key, msparser_internal::peptide_ratio_data_t* > peptide_quant_key_to_ratio_pointer_t;
197 typedef std::multimap< msparser_internal::peptide_ratio_data_t*, ms_peptide_quant_key > ratio_pointer_to_peptide_quant_key_t;
198
199 typedef std::map< ratio_name_t, peptide_quant_key_to_ratio_pointer_t > ratio_name_to_peptide_quant_key_map_t;
200 typedef std::map< ratio_name_t, ratio_pointer_to_peptide_quant_key_t > ratio_name_to_pointer_map_t;
201
202 bool lookupPeptideRatioNondestructive(const ms_peptide_quant_key &key, const std::string &ratioName, peptide_quant_key_to_ratio_pointer_t **qpmap, msparser_internal::peptide_ratio_data_t **rp);
203 bool lookupPeptideRatioNondestructive(const ms_peptide_quant_key &key, const std::string &ratioName, const peptide_quant_key_to_ratio_pointer_t **qpmap = NULL, const msparser_internal::peptide_ratio_data_t **rp = NULL) const;
204
205 bool insertPeptideRatio(const ms_peptide_quant_ratio &ratio);
206 msparser_internal::peptide_ratio_data_t* insertPeptideRatio(const std::string &ratioName, bool isMissing, const ms_peptide_quant_key &key, bool isInfinite, bool isExcluded, double value, double weight);
207 void deleteAlias(const std::string &ratioName, const ms_peptide_quant_key &key);
208 void deleteAliases(const std::string &ratioName, const ms_peptide_quant_key &key);
209 void deallocatePeptideRatios();
210
211 double calculateAverageRatio(const std::vector<double> &values, const std::string &kind) const;
212
213 std::set< msparser_internal::peptide_ratio_data_t* > peptideRatioPool_;
214 ratio_name_to_peptide_quant_key_map_t ratioNameToPeptideQuantKeyMap_;
215 ratio_name_to_pointer_map_t ratioNameToPointerMap_;
216
217 enum SUPPORTED_PROTEIN_RATIO_TYPE {
218 PROTEIN_RATIO_TYPE_MEDIAN = 0,
219 PROTEIN_RATIO_TYPE_AVERAGE,
220 PROTEIN_RATIO_TYPE_WEIGHTED
221 };
222
223 int proteinRatioType_;
224
225 bool initialiseProteinMappingFromResultsFile(const ms_peptidesummary &pepsum);
226 bool initialisePeptideQuantKeys(const ms_peptidesummary &pepsum, const ms_protein *protein);
227
228 }; // end of quantitation_group
230} // matrix_science namespace
231
232#endif // MS_CUSTOMQUANTITATION_HPP
233
234/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customquantitation
Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings.
Definition: ms_customquantitation.hpp:119
matrix_science::ms_ms2quantitation
Peptide and protein quantitation in a Reporter or Multiplex Mascot results file.
Definition: ms_ms2quantitation.hpp:127
matrix_science::ms_peptide_quant_key_vector
A vector of peptide quant keys.
Definition: ms_peptide_quant_key_vector.hpp:47
matrix_science::ms_peptide_quant_key
Feature key identifying a peptide ratio.
Definition: ms_peptide_quant_key.hpp:69
matrix_science::ms_peptide_quant_ratio
Peptide abundance in one component relative to another in a quantitation experiment.
Definition: ms_peptide_quant_ratio.hpp:61
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_protein_quant_ratio
Protein abundance in one component relative to another in a quantitation experiment,...
Definition: ms_protein_quant_ratio.hpp:72
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_quant_outliers
An object of this class represent a single OUTLIERS element in quantitation.xml.
Definition: ms_quant_outliers.hpp:44
matrix_science::ms_quantitation
Base class for peptide and protein quantitation.
Definition: ms_quantitation.hpp:138
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_dat28generator.hpp Source File

  • src
  • resfile
  • impl
ms_dat28generator.hpp
1/*
2##############################################################################
3# file: ms_dat28generator.hpp #
4# 'msparser' toolkit #
5# Private helper class for ms_msr2datu2
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author$
12# $Date$
13# $Revision$
14##############################################################################
15*/
16
17#ifndef MS_DAT28GENERATOR_HPP
18#define MS_DAT28GENERATOR_HPP
19
20#include <string>
21
22
23namespace matrix_science {
24 class ms_inputquery;
25}
26
27namespace msparser_internal {
29
36
47 class MS_MASCOTRESFILE_API ms_dat28generator
48 {
49 public:
51 ms_dat28generator();
52
53 ~ms_dat28generator();
54
56 void reset(const std::string &crLf, const std::string &mimeBoundaryString);
57
62 bool isInitialised() const { return !mimeSectionDividerLine_.empty(); }
63
65 static bool inspectLineForMimeStart(const std::string &line, std::string &crLf, std::string &mimeBoundaryString);
66
68 void includeQuerySectionIonsLines(bool maybe);
69
71 bool isQuerySectionIonsLinesIncluded() const;
72
81 std::string mimeSectionDivider_nl() const { return mimeSectionDividerLine_; }
82
91 std::string mimeFormatEndLine_nl() const { return mimeFormatEndLine_; }
92
101 std::string emptyLine() const { return crLf_; }
102
104 std::string queryMimeSectionStart_nl(int) const;
105
107 std::string keyval_nl(const std::string &key, int val) const;
108
110 std::string keyval_nl(const std::string &key, std::string val) const;
111
113 std::string keyval_nl(const std::string &key, double val) const;
114
116 std::string keyval_indexed_nl(const std::string &key, int index, const std::string &val) const;
117
119 std::string keyval_numbered_nl(const std::string &key, int num, const std::string &val) const;
120
122 std::list<std::string> getQuerySectionLines(const matrix_science::ms_inputquery &q) const;
123
124 private:
125 std::unique_ptr<matrix_science::ms_errs> logger_;
126
127 std::string crLf_;
128 std::string mimeSectionDividerLine_;
129 std::string mimeFormatEndLine_;
130
131 bool includeQuerySectionIonsLines_;
132
133 }; // end of resfile_group
135
137
138} // msparser_internal namespace
139
140#endif // MS_DAT28GENERATOR_HPP
141
142/*------------------------------- End of File -------------------------------*/
matrix_science::ms_inputquery
This class encapsulates the input queries (peak lists) in the Mascot results file.
Definition: ms_inputquery.hpp:43
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_dat28indexer.hpp Source File

  • src
  • resfile
  • impl
ms_dat28indexer.hpp
1/*
2##############################################################################
3# file: ms_dat28indexer.hpp #
4# 'msparser' toolkit #
5# Private helper class for ms_msr2dat28
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author$
12# $Date$
13# $Revision$
14##############################################################################
15*/
16
17#ifndef MS_DAT28INDEXER_HPP
18#define MS_DAT28INDEXER_HPP
19
20#include <string>
21
22namespace matrix_science {
23 class ms_errs;
24}
25
26namespace msparser_internal {
28
35
52 class MS_MASCOTRESFILE_API ms_dat28indexer
53 {
54 public:
56 ms_dat28indexer();
57
58 ~ms_dat28indexer();
59
61 void reset() {
62 indexLines_.clear();
63 }
64
70 void setBoundaryString(const std::string &boundaryString) {
71 boundaryString_ = boundaryString;
72 }
73
78 std::string getBoundaryString() const { return boundaryString_; }
79
90 void setLineTerminator(const std::string &crLf) { crLf_ = crLf; }
91
93 void indexThisLine(const std::string &line, int lineNumber);
94
102 std::string mimeSectionDivider_nl() const {
103 return "--" + getBoundaryString() + crLf_;
104 }
105
113 std::string emptyLine() const { return crLf_; }
114
116 std::string keyval_nl(const std::string &key, int val) const;
117
119 std::list<std::string> getIndexSectionLines() const;
120
121 private:
122 std::unique_ptr<matrix_science::ms_errs> logger_;
123
124 std::string crLf_;
125 std::string boundaryString_;
126
127 std::list<std::string> indexLines_;
128
129 }; // end of resfile_group
131
133
134} // msparser_internal namespace
135
136#endif // MS_DAT28INDEXER_HPP
137
138/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_databaseoptions.hpp Source File

  • inc
ms_databaseoptions.hpp
1/*
2##############################################################################
3# file: ms_databaseoptions.hpp #
4# 'msparser' toolkit #
5# Encapsulates "mascot.dat"-file that describes most important parameters #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_databaseoptions.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_DATABASEOPTIONS_HPP
20#define MS_DATABASEOPTIONS_HPP
21
22
23#include <string>
24#include <vector>
25
26
27namespace matrix_science {
38 enum DATABASE_TYPE
39 {
40 AA=0,
41 NA=1,
42 SL=2,
43 SLREF=3,
44 };
45
47
58 class MS_MASCOTRESFILE_API ms_databaseoptions
59 {
60 friend class ms_datfile;
61 friend class ms_databases;
62
63 public:
65
70 enum {
71 NUM_THREADS_AUTO_DETECT = -1
72 };
73
74
76 ms_databaseoptions();
77
79 ms_databaseoptions(const ms_databaseoptions& src);
80
82 ~ms_databaseoptions();
83
85 void defaultValues();
86
88 void copyFrom(const ms_databaseoptions* right);
89
90#ifndef SWIG
92 ms_databaseoptions& operator=(const ms_databaseoptions& right);
93#endif
95 bool isActive() const;
96
98 void setActive(const bool value);
99
101 std::string getName() const;
102
104 void setName(const char* name);
105
107 std::string getPath() const;
108
110 void setPath(const char* path);
111
113 int getDBType() const;
114
116 void setDBType(const int type);
117
119 bool isMemoryMapFiles() const;
120
122 void setMemoryMapFiles(const bool flag);
123
125 int getNumberOfThreads() const;
126
128 void setNumberOfThreads(const int number);
129
131 bool isLockMemory() const;
132
134 void setLockMemory(const bool flag);
135
137 bool isLocalRefFile() const;
138
140 void setLocalRefFile(const bool flag);
141
143 int getAccessionParseRuleIndex() const;
144
146 void setAccessionParseRuleIndex(const int index);
147
149 int getDescriptionParseRuleIndex() const;
150
152 void setDescriptionParseRuleIndex(const int index);
153
155 int getAccessionRefParseRuleIndex() const;
156
158 void setAccessionRefParseRuleIndex(const int index);
159
161 int getTaxonomyParseRuleIndex() const;
162
164 void setTaxonomyParseRuleIndex(const int index);
165
167 bool isBlastIndexFiles() const;
168
170 void setBlastIndexFiles(const bool flag);
171
173 void setPreceedingComments(const std::string &str);
174
176 const std::string& getPreceedingComments() const;
177
178 private:
179 std::string getStringValue() const;
180
181 bool active_;
182 std::string name_;
183 std::string path_;
184 int type_;
185 int __numEntries_; // no longer used
186 int __uniqueID_; // no longer used
187 bool mmapFiles_;
188 bool __useBlastIndexFiles_; // no longer used - was also blocks
189 int numThreads_;
190 bool lockMemory_;
191 bool hasRefFile_;
192 int accessionParseRule_;
193 int descriptionParseRule_;
194 int accessionRefParseRule_;
195 int taxonomyParseRule_;
196 std::string comment_;
197 }; // class ms_databaseoptions
198
200
224 class MS_MASCOTRESFILE_API ms_databases: public ms_customproperty
225 {
226 friend class ms_datfile;
227 public:
229 ms_databases();
230
232 ms_databases(const ms_databases& src);
233
235 ~ms_databases();
236
238 void defaultValues();
239
241 void copyFrom(const ms_databases* right);
242
243#ifndef SWIG
245 ms_databases& operator=(const ms_databases& right);
246#endif
248 bool isSectionAvailable() const;
249
251 void setSectionAvailable(const bool value);
252
254 int getNumberOfDatabases() const;
255
257 const ms_databaseoptions* getDatabase(const int index) const;
258
260 void clearDatabases();
261
263 void appendDatabase(const ms_databaseoptions* item);
264
266 int findDatabase(const char* dbName, const bool searchInactive = false) const;
267
269 bool updateDatabaseByNumber(const int num, const ms_databaseoptions db);
270
272 bool updateDatabaseByName(const char* name, const ms_databaseoptions db);
273
275 bool deleteDatabaseByNumber(const int num);
276
278 bool deleteDatabaseByName(const char* name);
279
280#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
281#include "suppress_ms_customproperty.hpp"
282#endif
283
284 private:
285 void appendDatabase(const ms_databaseoptions* item, const char *propVal);
286 void setFollowingComments(const std::string &str);
287 const std::string& getFollowingComments() const;
288
289 bool sectionAvailable_;
290 std::vector< ms_databaseoptions* > dbases_;
291 std::string followingComments_;
292 }; // class ms_databases // end of config_group
294} // namespace matrix_science
295
296#endif // MS_DATABASEOPTIONS_HPP
297
298/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_databaseoptions
An instance of this class represents a single database definition from the Databases section of masco...
Definition: ms_databaseoptions.hpp:59
matrix_science::ms_databases
An instance of this class represents the Databases section of mascot.dat.
Definition: ms_databaseoptions.hpp:225
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::DATABASE_TYPE
DATABASE_TYPE
Definition: ms_databaseoptions.hpp:39
matrix_science::SLREF
@ SLREF
FASTA reference database of a Spectral Library.
Definition: ms_databaseoptions.hpp:43
matrix_science::SL
@ SL
Spectral Library (MSP file)
Definition: ms_databaseoptions.hpp:42
matrix_science::NA
@ NA
NA sequence database (FASTA file, nucleic acid)
Definition: ms_databaseoptions.hpp:41
matrix_science::AA
@ AA
Protein sequence database (FASTA file, amino acid)
Definition: ms_databaseoptions.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_datfile.hpp Source File

  • inc
ms_datfile.hpp
1/*
2##############################################################################
3# file: ms_datfile.hpp #
4# 'msparser' toolkit #
5# Encapsulates "mascot.dat"-file that describes most important parameters #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_datfile.hpp $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2024-08-27 16:16:41 +0100 $ #
14# $Revision: 5566e3f2f102c2aae2dea328044e0e4030755ddd | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_DATFILE_HPP
20#define MS_DATFILE_HPP
21
22
23#include <string>
24#include <vector>
25
26
27namespace matrix_science {
28
29 class ms_filesource;
30
37
46 class MS_MASCOTRESFILE_API ms_datfile : public ms_errors
47 {
48 public:
49
51
54 enum WST
55 {
56 WST_APACHE=0,
57 WST_IIS=1
58 };
59
61
66 enum SEQDB_INSTALL
67 {
68 // Anything in the lower 16 bits (1..16) should result in asking the user to confirm that they want to update
69 SEQDB_INSTALL_SHOULD_QUERY_USER = 0x0000FFFF,
70 SEQDB_INSTALL_CUSTOMISED = 0x00000001,
71 SEQDB_INSTALL_INACTIVE = 0x00000002,
72 SEQDB_INSTALL_INVALID_CONFIG = 0x00000004,
73 SEQDB_INSTALL_EXISTING_LARGER = 0x00000010,
74
75 // Bit 32 for something really bad.
76 SEQDB_INSTALL_INVALID_DBNAME = 0x00000000,
77
78 // Further information that may be useful in bits 16 to 31
79 SEQDB_INSTALL_MUST_UPDATE_CFG = 0x000F000F,
80 SEQDB_INSTALL_MISSING_CONFIG = 0x00010000,
81 SEQDB_INSTALL_OLD_RULES = 0x00020000,
82 SEQDB_INSTALL_WRONG_WILDCARD = 0x00040000,
83
84 // Additional information, but no need to update
85 SEQDB_INSTALL_CURRENT_RULES = 0x01000000
86 };
87
89
92 enum INST_FLAGS
93 {
94 IFLG_UPDATETAXONOMY = 0x00000001,
95 IFLG_UPDATEPARSERULES = 0x00000002,
96 IFLG_UPDATESWISSPROT = 0x00000004,
97 IFLG_UPDATECLUSTER = 0x00000008,
98 IFLG_UPDATEESTTAX = 0x00000010,
99 IFLG_ADDMISSINGOPTIONS = 0x00000020,
100 IFLG_ADDREPORTAUTO = 0x00000040,
101 IFLG_UPDATEAPACHEFORKOPT = 0x00000080,
102 IFLG_ADDPERCOLATOROPT = 0x00000100,
103 IFLG_UPDATENCBIHTTPS = 0x00000200,
104 IFLG_UPDATEPRIDECONTAMINANTS = 0x00000400,
105 IFLG_UPDATEDBMANAGERPERLPATH = 0x00000800,
106 IFLG_UPDATEMSPEPSEARCHOPTS = 0x00001000,
107 IFLG_UPDATEEXECAFTERSEARCH = 0x00002000,
108 IFLG_UPDATEPERCOLATORFEATS = 0x00004000,
109 IFLG_UPDATEPROTFAMILYSWITCH = 0x00008000,
110 IFLG_UPDATEPERCOLATORUSERT = 0x00010000,
111 IFLG_UPDATESPLITNUMOFQUERIES = 0x00020000,
112 IFLG_UPDATESPLITDATAFILESIZE = 0x00040000,
113 IFLG_UPDATERESULTSCACHE = 0x00080000, //<!Update ResultsCache
114
115 IFLG_DEFAULTNEWINSTALL = IFLG_UPDATECLUSTER |
116 IFLG_UPDATEAPACHEFORKOPT,
117 IFLG_DEFAULTUPGRADE = IFLG_UPDATETAXONOMY |
118 IFLG_UPDATEPARSERULES |
119 IFLG_UPDATEESTTAX |
120 IFLG_ADDMISSINGOPTIONS |
121 IFLG_ADDREPORTAUTO |
122 IFLG_UPDATEAPACHEFORKOPT |
123 IFLG_ADDPERCOLATOROPT |
124 IFLG_UPDATEPERCOLATORFEATS |
125 IFLG_UPDATEPERCOLATORUSERT |
126 IFLG_UPDATENCBIHTTPS |
127 IFLG_UPDATEDBMANAGERPERLPATH |
128 IFLG_UPDATEMSPEPSEARCHOPTS |
129 IFLG_UPDATEEXECAFTERSEARCH |
130 IFLG_UPDATERESULTSCACHE |
131 IFLG_UPDATESPLITNUMOFQUERIES |
132 IFLG_UPDATESPLITDATAFILESIZE |
133 IFLG_UPDATEPROTFAMILYSWITCH
134 };
135
137 ms_datfile();
138
140 ms_datfile(const ms_datfile& src);
141
143 ms_datfile(const char* filename, const int timeoutSec = 0,
144 const matrix_science::ms_connection_settings * cs = 0);
145
147 ~ms_datfile();
148
150 void defaultValues();
151
153 void copyFrom(const ms_datfile* right);
154
155#ifndef SWIG
157 ms_datfile& operator=(const ms_datfile& right);
158#endif
160 std::string getFileName() const;
161
163 void setFileName(const char* name);
164
166 void setConnectionSettings(const matrix_science::ms_connection_settings & cs);
167
169 matrix_science::ms_connection_settings getConnectionSettings() const;
170
172 void read_file();
173
174 void read_buffer(const char * buffer);
175
177 void save_file();
178
180 bool editedByDatabaseManager() const;
181
183 const ms_databases* getDatabases() const;
184
186 void setDatabases(const ms_databases* dbs);
187
189 const ms_libraryoptions* getLibraryOptions() const;
190
192 void setLibraryOptions(const ms_libraryoptions* spectralLibraryOptions);
193
195 const ms_parseoptions* getParseOptions() const;
196
198 void setParseOptions(const ms_parseoptions* rules);
199
201 const ms_wwwoptions* getWWWOptions() const;
202
204 void setWWWOptions(const ms_wwwoptions* www);
205
207 const ms_processoroptions* getProcessors() const;
208
210 void setProcessors(const ms_processoroptions* info);
211
213 const ms_taxonomyrules* getTaxonomyRules(const int idx) const;
214
216 void setTaxonomyRules(const int idx, const ms_taxonomyrules* rules);
217
219 int getMaxTaxonomyRules() const;
220
222 const ms_clusterparams* getClusterParams() const;
223
225 void setClusterParams(const ms_clusterparams* params);
226
228 const ms_unigeneoptions* getUniGeneOptions() const;
229
231 void setUniGeneOptions(const ms_unigeneoptions * uoptions);
232
234 const ms_mascotoptions* getMascotOptions() const;
235
237 void setMascotOptions(const ms_mascotoptions* opt);
238
240 const ms_cronoptions* getCronOptions() const;
241
243 void setCronOptions(const ms_cronoptions* options);
244
246 const ms_mascotfiles* getMascotFiles() const;
247
249 void setMascotFiles(const ms_mascotfiles* src);
250
252 void setFindFileTimeout(const int seconds);
253
255 int getFindFileTimeout() const;
256
258 unsigned int checkSeqDBInstallRequest(const std::string & dbName,
259 const double newFastaSize) const;
260
262 bool updateForInstaller(ms_errs & log,
263 const char * not_mascot_dat_path,
264 const char * mascot_dat_path,
265 const char * licenseFilePath,
266 const char * pathToMascot,
267 const char * mascotURL,
268 const char * sequenceDatabases,
269 const bool clusterEnable,
270 const WST wst,
271 const char * NTGuestName,
272 const char * NTAdminName,
273 const unsigned int flags);
274
276 std::string getHeaderComments() const;
277
279 void setHeaderComments(const std::string headerComments);
280
281 private:
282 std::string filename_;
283
284 int findFileTimeout_;
285
286 ms_databases Databases;
287
288 ms_libraryoptions libraryOptions;
289
290 ms_parseoptions parseOptions;
291
292 ms_wwwoptions wwwOptions;
293
294 ms_processoroptions Processors;
295
296 ms_taxonomyrules **taxonomyRules;
297
298 ms_clusterparams clusterParams;
299
300 ms_unigeneoptions unigeneOptions;
301
302 ms_mascotoptions Options;
303
304 ms_cronoptions cronOptions;
305
306 ms_mascotfiles MascotFiles;
307
308 std::string headerComments_;
309 std::string footerComments_;
310
311 ms_connection_settings cs_;
312
313 private:
314 void defaultFileName();
315
316 void defaultTaxonomyRules();
317 void copyTaxonomyRules(const ms_datfile* right);
318
319 void get_db_info(ms_filesource *f);
320 void save_db_info(void *f);
321
322 void get_library_options(ms_filesource *f, const std::string & preceedingComments);
323 void save_library_options(void *f);
324
325 void get_parse_rules(ms_filesource *f, const std::string & preceedingComments);
326 void save_parse_rules(void *f);
327
328 void get_www(ms_filesource *f, const std::string & preceedingComments);
329 void save_www(void *f);
330
331 void get_taxonomy_rules(ms_filesource *f, const char * sectionTitle, const std::string & preceedingComments);
332 void save_taxonomy(void *f, const int index);
333
334 void get_cluster_params(ms_filesource *f, const std::string & preceedingComments);
335 void save_cluster_params(void *f);
336
337 void get_unigene_options(ms_filesource *f, const std::string & preceedingComments);
338 void save_unigene_options(void *f);
339
340 void get_processors(ms_filesource *f, const std::string & preceedingComments);
341 void save_processors(void *f);
342
343 void get_options(ms_filesource *f, const std::string & preceedingComments);
344 void save_options(void *f);
345
346 void get_cron_job_list(ms_filesource *f, const std::string & preceedingComments);
347 void save_cron_job_list(void *f);
348
349 bool get_parse_rule_plus(const char *lineForError, char *pSrc, ms_parserule_plus *pRulePlus);
350 void setIamParameter();
351 void checkAndCompileParseRules();
352 bool parseStringIntoCron(const char *szBuf, ms_cronjob & cron);
353
354 int parseIntoArray(const char * szBufCopy,
355 bool * array,
356 int minVal,
357 int maxVal,
358 int starMeans,
359 const char * wholeLine);
360
361 bool skipToEndOfSection(ms_filesource *f);
362 bool getStringExcludingQuotes(const char *line, char *pDst);
363 void readToEndOfLine(const char * pSrc, char * pDst, int maximumLength);
364 void replaceHashes(matrix_science::ms_customproperty & section,
365 const std::string & localPath,
366 const std::string & hostname,
367 const std::string & url);
368
369 void read_filesource(ms_filesource & fsource);
370 bool updateForInstallerDatabase(ms_errs & log,
371 const std::string & dbName,
372 const std::string & defaultWildcard,
373 ms_databases & dbs,
374 const ms_databases * not_dbs,
375 ms_parseoptions & thisParse,
376 const ms_parseoptions * notMascotDatParse);
377 void updateForInstaller_ExecAfterSearch(ms_errs & log, matrix_science::ms_mascotoptions & options, const std::string & createPipCompleteString);
378 }; // class ms_datfile // end of config_group
380} // namespace matrix_science
381
382#endif // MS_DATFILE_HPP
383
384/*------------------------------- End of File -------------------------------*/
matrix_science::ms_clusterparams
An instance of this class represents all the parameters specified in the Cluster section of mascot....
Definition: ms_clusterparams.hpp:72
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_cronjob
Represents a single entry from the cron section of mascot.dat.
Definition: ms_cronoptions.hpp:38
matrix_science::ms_cronoptions
Contains parameters from the cron section of mascot.dat.
Definition: ms_cronoptions.hpp:150
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_databases
An instance of this class represents the Databases section of mascot.dat.
Definition: ms_databaseoptions.hpp:225
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_datfile::SEQDB_INSTALL
SEQDB_INSTALL
Flags for checkSeqDBInstallRequest().
Definition: ms_datfile.hpp:67
matrix_science::ms_datfile::WST
WST
Web server type for the updateForInstaller() function.
Definition: ms_datfile.hpp:55
matrix_science::ms_datfile::INST_FLAGS
INST_FLAGS
Flags for the updateForInstaller() function.
Definition: ms_datfile.hpp:93
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_libraryoptions
Represents the LibraryOptions section of mascot.dat.
Definition: ms_libraryoptions.hpp:53
matrix_science::ms_mascotfiles
An instance of this class contains configuration files paths (except for mascot.dat).
Definition: ms_mascotfiles.hpp:53
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_parseoptions
Represents the PARSE section of mascot.dat.
Definition: ms_parserule.hpp:102
matrix_science::ms_parserule_plus
Represents regular expression parse rule plus some additional parameters.
Definition: ms_taxonomyrules.hpp:153
matrix_science::ms_processoroptions
An instance of this class represents all the parameters specified in the Processors section of mascot...
Definition: ms_processoroptions.hpp:109
matrix_science::ms_taxonomyrules
This class represents a single Taxonomy_XXX section in mascot.dat.
Definition: ms_taxonomyrules.hpp:247
matrix_science::ms_unigeneoptions
An instance of this class represents all the parameters specified in UniGene section of mascot....
Definition: ms_unigeneoptions.hpp:59
matrix_science::ms_wwwoptions
Represents the whole WWW section.
Definition: ms_wwwoptions.hpp:157
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_decoystats_accumulator.hpp Source File

  • src
  • resfile
  • impl
ms_decoystats_accumulator.hpp
1
2#ifndef MS_DECOYSTATSACCUMULATOR_HPP
3#define MS_DECOYSTATSACCUMULATOR_HPP
4
5namespace matrix_science {
6 class ms_mascotresfilebase;
7 class ms_peptide;
8}
9using namespace matrix_science;
10
11namespace msparser_internal {
12
13 class ms_peptidesummarybase;
14
15#ifndef SWIG
16 class ms_decoystats_accumulator
17 {
18 public:
19 ms_decoystats_accumulator(const ms_peptidesummarybase& pepSum, const ms_mascotresfilebase& resfile, bool isDecoy, const double dOneInXprobRnd);
20
21 void operator()(const int q);
22
23 double getOneInXprob() const { return dOneInXprobRnd_; }
24
25 std::set<std::string> seq_rank1_identity, seq_rank1_homology;
26 std::set<std::string> seq_FASTA_identity, seq_FASTA_homology;
27 std::set<std::string> seq_FASTA_identity_1st_pass, seq_FASTA_identity_2nd_pass;
28 std::set<std::string> seq_FASTA_homology_1st_pass, seq_FASTA_homology_2nd_pass;
29 std::set<std::string> seq_SL_identity, seq_SL_homology;
30
31 long psm_rank1_identity = 0, psm_rank1_homology = 0;
32 long psm_FASTA_identity = 0, psm_FASTA_homology = 0;
33 long psm_FASTA_identity_1st_pass = 0, psm_FASTA_identity_2nd_pass = 0;
34 long psm_FASTA_homology_1st_pass = 0, psm_FASTA_homology_2nd_pass = 0;
35 long psm_SL_identity = 0, psm_SL_homology = 0;
36
37 bool decoy;
38
39 private:
40 int maxRanksPerQuery_;
41 bool useActiveSection_;
42 double dOneInXprobRnd_;
43 std::shared_ptr<ms_peptide> pep_;
44 const ms_peptidesummarybase& pepSum_;
45 const ms_mascotresfilebase& resfile_;
46 };
47#endif // SWIG
48}
49
50#endif // MS_DECOYSTATSACCUMULATOR_HPP
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_data.hpp Source File

  • inc
ms_distiller_data.hpp
1/*
2##############################################################################
3# file: ms_distiller_data.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_distiller_data.hpp $
12 * @(#)$Revision: a11a1f9693803472f1a72c5139f8c548fb17b396 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2023-11-21 13:38:16 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_DISTILLER_DATA_HPP
18#define MS_DISTILLER_DATA_HPP
19
20
21// Includes from the standard template library
22#include <string>
23#include <vector>
24
25namespace msparser_internal
26{
27 class ms_XMLHelper;
28 class ms_XMLElement;
29}
30
31namespace matrix_science
32{
33 class ms_distiller_data_quant;
34 class ms_distiller_data_search;
35
36 //=========================================================================
43
47 class MS_MASCOTRESFILE_API ms_distiller_data :
48 public matrix_science::ms_errors
49 {
50 public:
51
53 static time_t getDistillerResfileTimestamp();
54
56 static std::vector<std::string> getRequiredSchemaFileNames();
57
59 static std::string getDistillerProjectStreamName();
60
61 ms_distiller_data();
62 virtual ~ms_distiller_data();
63 ms_distiller_data(const ms_distiller_data & copy);
64
66 virtual std::string getDistillerVersion() const;
67
69 virtual int getDistillerExperimentType() const;
70
72 void copyFrom(const ms_distiller_data* right);
73
74#ifndef SWIG
75 const ms_distiller_data & operator=(const ms_distiller_data & copy);
76#endif
77
79 virtual int getSearchCount() const;
81 virtual const ms_distiller_data_search & getSearch(int index) const;
83 virtual int getLoadedSearchIndex() const;
84
86 virtual int getQuantCount() const;
88 virtual const ms_distiller_data_quant & getQuant(int index) const;
89
91 virtual const ms_distiller_data_quant * getQuantForSearch(const std::string & taskId) const;
92
94 virtual const ms_datfile & getDatfile() const;
95
97 virtual const ms_fragrulesfile & getFragRulesFile() const;
98
100 virtual const ms_quant_method & getQuantMethod() const;
101
103 virtual ms_mascotresults_params get_ms_mascotresults_params(const int searchIndex) const;
104
106 virtual bool loadXml(const char * xmlSchemaPath, const std::string & xmlText);
108 virtual bool loadXmlFile(const char * xmlSchemaPath, const std::string & xmlFilename);
110 virtual bool loadXmlStream(const char * xmlSchemaPath, matrix_science::ms_input_string_stream * xmlStream);
111
112 virtual bool saveXmlFile(const char * xmlSchemaPath, const std::string & xmlFilename);
113 virtual int addQuant(const std::string & taskId);
114
115 private:
116 bool extractXml(const char * xmlSchemaPath, msparser_internal::ms_XMLHelper & helper);
117 bool saveXml(const char * xmlSchemaPath, msparser_internal::ms_XMLHelper & helper);
118
119 int quantStreamCounter_;
120 std::vector<ms_distiller_data_search> searches_;
121 std::vector<ms_distiller_data_quant> quantStreams_;
122 ms_datfile datfile_;
123 ms_fragrulesfile fragfile_;
124 ms_quant_method quantMethod_;
125
126 msparser_internal::ms_XMLHelper * helper_;
127 std::string distillerVersion_;
128 std::string serverURL_;
129 std::string serverVersion_;
130 int distillerExperimentType_ = 0;
131 };
132 // end of quantitation_group
134 //=========================================================================
135
136} // namespace matrix_science
137
138#endif // MS_DISTILLER_DATA_HPP
139
140/*------------------------------- End of File -------------------------------*/
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_distiller_data_quant
The details of a Distiller search.
Definition: ms_distiller_data_quant.hpp:44
matrix_science::ms_distiller_data_search
The details of a Distiller search.
Definition: ms_distiller_data_search.hpp:52
matrix_science::ms_distiller_data
Distiller project parameters.
Definition: ms_distiller_data.hpp:49
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_fragrulesfile
This class encapsulates a complete fragmentation_rules file.
Definition: ms_fragmentationrules.hpp:209
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_data_quant.hpp Source File

  • inc
ms_distiller_data_quant.hpp
1/*
2##############################################################################
3# file: ms_distiller_data_quant.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_distiller_data_quant.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_DISTILLER_DATA_QUANT_HPP
18#define MS_DISTILLER_DATA_QUANT_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24
25namespace msparser_internal
26{
27 class ms_XMLHelper;
28 class ms_XMLElement;
29}
30
31namespace matrix_science
32{
33 //=========================================================================
39
43 class MS_MASCOTRESFILE_API ms_distiller_data_quant
44 {
45 public:
46
47 // used internally
48 ms_distiller_data_quant();
49 ms_distiller_data_quant(const std::string & taskId, int streamNumber);
50 bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
51
53 std::string getTaskId() const;
55 int getStreamNumber() const;
56
58 std::string getResultsStreamName() const;
60 std::string getCacheStreamName() const;
61
62 int getResultsStreamNumber() const;
63 int getCacheStreamNumber() const;
64
65 private:
66 std::string taskId_;
67 int streamNumber_;
68 };
69 // end of quantitation_group
71 //=========================================================================
72
73} // namespace matrix_science
74
75#endif // MS_DISTILLER_DATA_QUANT_HPP
76
77/*------------------------------- End of File -------------------------------*/
matrix_science::ms_distiller_data_quant
The details of a Distiller search.
Definition: ms_distiller_data_quant.hpp:44
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_data_search.hpp Source File

  • inc
ms_distiller_data_search.hpp
1/*
2##############################################################################
3# file: ms_distiller_data_search.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11* @(#)$Source: parser/inc/ms_distiller_data_search.hpp $
12* @(#)$Revision: d4d14d514a03ef6b6a52a6c2f014cf8c5c4a3560 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13* @(#)$Date: 2022-07-19 13:33:41 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_DISTILLER_DATA_SEARCH_HPP
18#define MS_DISTILLER_DATA_SEARCH_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24
25namespace msparser_internal
26{
27 class ms_XMLHelper;
28 class ms_XMLElement;
29}
30
31namespace matrix_science
32{
33 class ms_quant_configfile;
34
35
36 //=========================================================================
43
51 class MS_MASCOTRESFILE_API ms_distiller_data_search
52 {
53 friend class ms_distiller_data;
54
55 public:
56
58
61 enum eScoring
62 {
63 eAuto = 0,
64 eMudpit = 1,
65 eStandard = 99999999,
66 };
67
69
72 enum eGrouping
73 {
74 eGroupAuto = 0,
75 eGroupStandard = 1,
76 eGroupFamily = 2
77 };
78
80
83 enum eSpectralLibrary
84 {
85 eUnknown = -1,
86 eFASTA = 0,
87 eLibrary = 1,
88 eIntegrated = 2,
89 };
90
92 ms_distiller_data_search();
93
95 ms_distiller_data_search(
96 const std::string & taskId,
97 bool isLoaded,
98 const std::string & cacheFileName,
99 const std::string & quantMethodXml,
100 const std::string & mascotServerURL,
101 const std::string & mascotServerVersion,
102 unsigned int flags,
103 unsigned int flags2,
104 bool requireBoldRed,
105 bool showSameset,
106 double showSubset,
107 bool loadUnassigned,
108 double significanceThreshold,
109 eScoring scoring,
110 int reporttop,
111 bool errTolPeptide,
112 eGrouping proteinGrouping,
113 bool percolator,
114 double scoreExpectCutOff,
115 bool showSamesetFamily,
116 bool showSubsetFamily,
117 eSpectralLibrary libraryDisplayOption,
118 bool percolatorUseProteins,
119 bool percolatorUseRT,
120 int minPepLenInPepSummary,
121 bool isTargetFDR = false,
122 const std::string & targetFDRType = "",
123 const std::string & targetFDRStr = ""
124 );
125
126 // Copying constructor for c++ programs - don't document
127 ms_distiller_data_search(const ms_distiller_data_search &src);
128
129#ifndef SWIG
130 // Assignment operator for c++ programs - don't document
131 ms_distiller_data_search & operator=(const ms_distiller_data_search & right);
132#endif
134 std::string getTaskId() const;
135
137 bool getLoaded() const;
138
140 std::string getCacheFileName() const;
141
143 std::string getQuantMethodXml() const;
144
146 std::string getMascotServerURL() const;
147
149 bool serverVersionNewerOrSameAs(int major, int minor, int patch) const;
150
152 std::string getMascotSearchURL(const std::string & resultsFilePath) const;
153
155 eGrouping getProteinGrouping() const;
156
158 eScoring getScoring() const;
159
161 double getScoreExpectCutOff() const;
162
164 double getShowSubset() const;
165
167 bool getShowSubsetFamily() const;
168
170 bool getRequireBoldRed() const;
171
173 double getSignificanceThreshold() const; // = minProbability
174
176 int getReporttop() const;
177
179 bool getPercolator() const;
180
182 bool getPercolatorUseProteins() const;
183
185 bool getPercolatorUseRT() const;
186
188 bool getErrTolPeptide() const;
189
191 unsigned int getPeptideSummaryFlags() const;
192
194 unsigned getPeptideSummaryFlags2() const;
195
197 bool getLoadUnassigned() const;
198
200 bool getShowSamesets() const;
201
203 bool getShowSamesetsFamily() const;
204
206 int getMinPepLenInPepSummary() const;
207
209 eSpectralLibrary getSpectralLibraryDisplayOption() const;
210
212 bool isTargetFDR() const;
213
215 std::string getTargetFDRType() const;
216
218 std::string getTargetFDRStr() const;
219
221 double getTargetFDR() const;
222
224 ms_mascotresults::DECOY_STATS_COUNT_TYPE getFDRCountType() const;
225
226 private:
227 // Used internally to read from the rover_data XML file
228 bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
229 void copyFrom(const ms_distiller_data_search * src);
230 void setMissingBlueOptionValues(const std::string & mascotServerURL,
231 const std::string & mascotServerVersion,
232 int minPepLenInPepSummary,
233 bool percolatorUseProteins,
234 bool percolatorUseRT);
235
236 std::string taskId_;
237 bool isLoaded_;
238 std::string cacheFileName_;
239 std::string quantMethodXml_;
240 std::string mascotServerURL_;
241 std::string mascotServerVersion_;
242 unsigned int flags_;
243 unsigned int flags2_;
244
245 // From blueoptions (same order as schema)
246 bool requireBoldRed_;
247 bool showSameset_;
248 double showSubset_;
249 bool loadUnassigned_;
250 double significanceThreshold_; // = minProbability
251 eScoring scoring_;
252 int reporttop_;
253 bool errTolPeptide_;
254 eGrouping proteinGrouping_;
255 bool percolator_;
256 double scoreExpectCutOff_;
257 bool showSamesetFamily_;
258 bool showSubsetFamily_;
259 eSpectralLibrary libraryDisplayOption_;
260 bool percolatorUseProteins_;
261 bool percolatorUseRT_;
262 int minPepLenInPepSummary_;
263
264 // target fdr
265 bool isTargetFDR_;
266 std::string targetFDRType_;
267 std::string targetFDRStr_;
268 double targetFDR_;
269 };
270 // end of quantitation_group
272 //=========================================================================
273
274} // namespace matrix_science
275
276#endif // MS_DISTILLER_DATA_SEARCH_HPP
277
278/*------------------------------- End of File -------------------------------*/
matrix_science::ms_distiller_data_search
The details of a Distiller search.
Definition: ms_distiller_data_search.hpp:52
matrix_science::ms_distiller_data_search::eGrouping
eGrouping
Setting to control how proteins are grouped.
Definition: ms_distiller_data_search.hpp:73
matrix_science::ms_distiller_data_search::eScoring
eScoring
Determine whether to use MudPIT or standard (pre-Mascot 2.2) scoring.
Definition: ms_distiller_data_search.hpp:62
matrix_science::ms_distiller_data_search::eSpectralLibrary
eSpectralLibrary
For integrated FASTA and Spectral Library search, determines the default result display option.
Definition: ms_distiller_data_search.hpp:84
matrix_science::ms_distiller_data
Distiller project parameters.
Definition: ms_distiller_data.hpp:49
matrix_science::ms_mascotresults::DECOY_STATS_COUNT_TYPE
DECOY_STATS_COUNT_TYPE
Type of object counted by getNumHitsAboveIdentity() and friends.
Definition: ms_mascotresults.hpp:382
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_master_project.hpp Source File

  • inc
ms_distiller_master_project.hpp
1/*
2##############################################################################
3# file: ms_distiller_master_project.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_distiller_master_project.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_DISTILLER_MASTER_PROJECT_HPP
18#define MS_DISTILLER_MASTER_PROJECT_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24
25namespace msparser_internal
26{
27 class ms_XMLHelper;
28 class ms_XMLElement;
29}
30
31namespace matrix_science
32{
33 //=========================================================================
39 class ms_distiller_master_search;
40 class ms_distiller_sub_project;
41
43
46 class MS_MASCOTRESFILE_API ms_distiller_master_project :
47 public matrix_science::ms_errors
48 {
49 public:
50 ms_distiller_master_project();
51 virtual ~ms_distiller_master_project() { }
52
53 ms_distiller_master_project(const ms_distiller_master_project & src);
54#ifndef SWIG
55 ms_distiller_master_project& operator=(const ms_distiller_master_project & right);
56#endif
57 void copyFrom(const ms_distiller_master_project * right);
58
60 static std::string getMasterProjectStreamName();
61
63 virtual int getNumSubprojects() const;
65 virtual const ms_distiller_sub_project & getSubproject(int index) const;
66
68 virtual int getNumSearches() const;
70 virtual const ms_distiller_master_search & getSearch(int index) const;
71
73 virtual bool loadXml(const char * xmlSchemaPath, std::string xmlText);
75 virtual bool loadXmlFile(const char * xmlSchemaPath, std::string xmlFilename);
77 virtual bool loadXmlStream(const char * xmlSchemaPath, matrix_science::ms_input_string_stream * xmlStream);
78
79 private:
80 bool extractXml(msparser_internal::ms_XMLHelper & helper);
81
82 std::vector<ms_distiller_sub_project> subprojects;
83 std::vector<ms_distiller_master_search> searches;
84 };
85 // end of quantitation_group
87 //=========================================================================
88
89} // namespace matrix_science
90
91#endif // MS_DISTILLER_MASTER_PROJECT_HPP
92
93/*------------------------------- End of File -------------------------------*/
matrix_science::ms_distiller_master_project
Data for a Distiller master project, includes a list of the subprojects.
Definition: ms_distiller_master_project.hpp:48
matrix_science::ms_distiller_master_search
The details of a Distiller multifile search.
Definition: ms_distiller_master_search.hpp:44
matrix_science::ms_distiller_sub_project
The details of a Distiller multifile subproject.
Definition: ms_distiller_sub_project.hpp:44
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_master_search.hpp Source File

  • inc
ms_distiller_master_search.hpp
1/*
2##############################################################################
3# file: ms_distiller_master_search.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_distiller_master_search.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_DISTILLER_MASTER_SEARCH_HPP
18#define MS_DISTILLER_MASTER_SEARCH_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24
25namespace msparser_internal
26{
27 class ms_XMLHelper;
28 class ms_XMLElement;
29}
30
31namespace matrix_science
32{
33 //=========================================================================
39
43 class MS_MASCOTRESFILE_API ms_distiller_master_search
44 {
45 public:
46 // used internally
47 ms_distiller_master_search();
48 virtual ~ms_distiller_master_search() { }
49
50 bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
51
53 virtual int getId() const;
55 virtual std::string getCacheFilename() const;
56
58 virtual int getNumSubsearches() const;
60 virtual const ms_distiller_subsearch & getSubsearch(int index) const;
61
63 virtual std::string getCombinedPeptideSummaryCacheStreamName() const;
64
65 private:
66 int id;
67 std::string cacheFilename;
68 std::vector<ms_distiller_subsearch> subsearches;
69 };
70 // end of quantitation_group
72 //=========================================================================
73
74} // namespace matrix_science
75
76#endif // MS_DISTILLER_MASTER_SEARCH_HPP
77
78/*------------------------------- End of File -------------------------------*/
matrix_science::ms_distiller_master_search
The details of a Distiller multifile search.
Definition: ms_distiller_master_search.hpp:44
matrix_science::ms_distiller_subsearch
The details of a Distiller multifile subsearch.
Definition: ms_distiller_subsearch.hpp:43
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_search_status.hpp Source File

  • inc
ms_distiller_search_status.hpp
1/*
2##############################################################################
3# file: ms_distiller_search_status.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_distiller_search_status.hpp $
12 * @(#)$Revision: 5f5a3230c85e277f402844ad1dcf49796e9a3e42 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2019-04-03 10:57:19 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_DISTILLER_SEARCH_STATUS_HPP
18#define MS_DISTILLER_SEARCH_STATUS_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24namespace msparser_internal
25{
26 class ms_XMLHelper;
27 class ms_XMLElement;
28}
29
30namespace matrix_science
31{
32 //=========================================================================
38
42 class MS_MASCOTRESFILE_API ms_distiller_search_status
43 {
44 public:
45 // used internally
46 ms_distiller_search_status();
47 bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
48
50 int getId() const;
52 std::string getTaskId() const;
53#ifndef SWIGCSHARP
55 std::string getTitle() const;
56#else
57 std::wstring getTitle() const {
58 return getTitleWide();
59 };
60#endif
62 std::string getServer() const;
64 std::string getSubmitTime() const; // ISO 8601 date and time format, e.g. "2013-05-29T15:55:40"
66 std::string getResultsFile() const;
68 std::string getStatusMsg() const; // usually empty
70 int getError() const; // zero if no error
71
73 std::string getResfileStreamName() const;
75 std::string getPeptideSummaryCacheStreamName() const;
76
77 private:
78 std::wstring getTitleWide() const;
79
80 int id_;
81 std::string taskId_;
82 std::string title_;
83 std::string server_;
84 std::string submitTime_; // ISO 8601 date and time format, e.g. "2013-05-29T15:55:40"
85 std::string resultsFile_;
86 std::string statusMsg_;
87 int error_;
88 };
89 // end of quantitation_group
91 //=========================================================================
92
93} // namespace matrix_science
94
95#endif // MS_DISTILLER_SEARCH_STATUS_HPP
96
97/*------------------------------- End of File -------------------------------*/
matrix_science::ms_distiller_search_status
A Mascot search status from a Distiller project file.
Definition: ms_distiller_search_status.hpp:43
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_search_status_list.hpp Source File

  • inc
ms_distiller_search_status_list.hpp
1/*
2##############################################################################
3# file: ms_distiller_search_status_list.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_distiller_search_status_list.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_DISTILLER_SEARCH_STATUS_LIST_HPP
18#define MS_DISTILLER_SEARCH_STATUS_LIST_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24namespace msparser_internal
25{
26 class ms_XMLHelper;
27 class ms_XMLElement;
28}
29
30namespace matrix_science
31{
32 class ms_input_stream;
33
34 //=========================================================================
40 class ms_distiller_search_status;
41
43
46 class MS_MASCOTRESFILE_API ms_distiller_search_status_list :
47 public matrix_science::ms_errors
48 {
49 public:
50 ms_distiller_search_status_list();
51 ms_distiller_search_status_list(const ms_distiller_search_status_list & src);
52#ifndef SWIG
53 ms_distiller_search_status_list& operator=(const ms_distiller_search_status_list & right);
54#endif
55 void copyFrom(const ms_distiller_search_status_list * right);
56
58 static std::string getSearchStatusListStreamName();
59
61 int getNumSearches() const;
63 const ms_distiller_search_status & getSearch(int index) const; // (index 1..n)
64
66 bool loadXml(const char * xmlSchemaPath, const std::string & xmlText);
68 bool loadXmlFile(const char * xmlSchemaPath, const std::string & xmlFilename);
70 bool loadXmlStream(const char * xmlSchemaPath, matrix_science::ms_input_string_stream * xmlStream);
71
72 private:
73 bool extractXml(msparser_internal::ms_XMLHelper & helper);
74
75 std::vector<ms_distiller_search_status> searches_;
76 };
77 // end of quantitation_group
79 //=========================================================================
80
81} // namespace matrix_science
82
83#endif // MS_DISTILLER_SEARCH_STATUS_LIST_HPP
84
85/*------------------------------- End of File -------------------------------*/
matrix_science::ms_distiller_search_status_list
A list of Mascot search status values, typically stored in a Distiller project file.
Definition: ms_distiller_search_status_list.hpp:48
matrix_science::ms_distiller_search_status
A Mascot search status from a Distiller project file.
Definition: ms_distiller_search_status.hpp:43
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_sub_project.hpp Source File

  • inc
ms_distiller_sub_project.hpp
1/*
2##############################################################################
3# file: ms_distiller_sub_project.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_distiller_sub_project.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_DISTILLER_SUB_PROJECT_HPP
18#define MS_DISTILLER_SUB_PROJECT_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24
25namespace msparser_internal
26{
27 class ms_XMLHelper;
28 class ms_XMLElement;
29}
30
31namespace matrix_science
32{
33 //=========================================================================
39
43 class MS_MASCOTRESFILE_API ms_distiller_sub_project
44 {
45 public:
47 static std::string getResultsListStreamName();
48
49 // used internally
50 ms_distiller_sub_project();
51 virtual ~ms_distiller_sub_project() { }
52
53 bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
54
56 virtual int getId() const;
58 virtual std::string getType() const;
60 virtual std::string getName() const;
62 virtual int getRawSampleNumber() const;
64 virtual int getRawFormat() const;
66 virtual std::string getRawAbsolutePath() const;
68 virtual std::string getRawRelativePath() const;
70 virtual std::string getProjectRelativePath() const;
72 virtual bool getHavePeakList() const;
73
74 private:
75 int id;
76 std::string type; // "project" or "raw"
77 std::string name;
78 int rawSampleNumber;
79 int rawFormat;
80 std::string rawAbsolutePath;
81 std::string rawRelativePath;
82 std::string projectRelativePath;
83 bool havePeakList;
84 };
85 // end of quantitation_group
87 //=========================================================================
88
89} // namespace matrix_science
90
91#endif // MS_DISTILLER_SUB_PROJECT_HPP
92
93/*------------------------------- End of File -------------------------------*/
matrix_science::ms_distiller_sub_project
The details of a Distiller multifile subproject.
Definition: ms_distiller_sub_project.hpp:44
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_distiller_subsearch.hpp Source File

  • inc
ms_distiller_subsearch.hpp
1/*
2##############################################################################
3# file: ms_distiller_subsearch.hpp
4# 'msparser' toolkit
5##############################################################################
6# COPYRIGHT NOTICE
7# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
8#
9##############################################################################
10 * @(#)$Source: parser/inc/ms_distiller_subsearch.hpp $
11 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
12 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
13##############################################################################
14 */
15
16#ifndef MS_DISTILLER_SUBSEARCH_HPP
17#define MS_DISTILLER_SUBSEARCH_HPP
18
19
20// Includes from the standard template library
21#include <string>
22
23
24namespace msparser_internal
25{
26 class ms_XMLHelper;
27 class ms_XMLElement;
28}
29
30namespace matrix_science
31{
32 //=========================================================================
38
42 class MS_MASCOTRESFILE_API ms_distiller_subsearch
43 {
44 public:
45 // used internally
46 ms_distiller_subsearch();
47 virtual ~ms_distiller_subsearch() { }
48
49 bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
50
52 virtual std::string getTaskId() const;
54 virtual std::string getTitle() const;
56 virtual std::string getResultsFile() const;
57
58 private:
59 std::string taskId_;
60 std::string title_;
61 std::string resultsFile_;
62 };
63 // end of quantitation_group
65 //=========================================================================
66
67} // namespace matrix_science
68
69#endif // ms_distiller_subsearch_HPP
70
71/*------------------------------- End of File -------------------------------*/
matrix_science::ms_distiller_subsearch
The details of a Distiller multifile subsearch.
Definition: ms_distiller_subsearch.hpp:43
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_enzyme.hpp Source File

  • inc
ms_enzyme.hpp
1/*
2##############################################################################
3# file: ms_enzyme.hpp #
4# 'msparser' toolkit #
5# Encapsulates "enzymes"-file that describes available enzymes #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2005 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_enzyme.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_ENZYME_HPP
20#define MS_ENZYME_HPP
21
22
23#include <string>
24#include <vector>
25
26
27namespace matrix_science {
34
66 class MS_MASCOTRESFILE_API ms_enzyme : public ms_customproperty
67 {
68 friend class ms_enzymefile;
69
70 public:
72
75 enum cuttertype
76 {
77 UNDEFINED_CUTTER = 0x0000,
78 NTERM_CUTTER = 0x0001,
79 CTERM_CUTTER = 0x0002
80 };
81
83 ms_enzyme();
84
86 ms_enzyme(const ms_enzyme& src);
87
89 ~ms_enzyme();
90
92 void defaultValues();
93
95 void copyFrom(const ms_enzyme* right);
96
97#ifndef SWIG
99 ms_enzyme& operator=(const ms_enzyme& right);
100#endif
102 bool isValid() const;
103
105 bool verifyEnzyme(ms_errs* errObj) const;
106
108 std::string getTitle() const;
109
111 void setTitle(const char* str);
112
114 bool isSemiSpecific() const;
115
117 void setSemiSpecific(const bool value);
118
120 bool isIndependent() const;
121
123 void setIndependent(const bool bit);
124
126 int getNumberOfCutters() const;
127
129 void clearAllCutters();
130
132 void addCutter(const cuttertype type, const char* cleaveAtStr, const char* restrictStr);
133
135 ms_enzyme::cuttertype getCutterType(const int cutterNum) const;
136
138 std::string getCleave(const int cutterNum) const;
139
141 std::string getRestrict(const int cutterNum) const;
142
144 bool canCleave(const int cutterNum,
145 const char leftResidue,
146 const char rightResidue) const;
147
148#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
149#include "suppress_ms_customproperty.hpp"
150#endif
151
152 private:
153 void setNTerm(std::string& cleaveStr, std::string& restrictStr);
154 void setCTerm(std::string& cleaveStr, std::string& restrictStr);
155 std::string::size_type prepareNextNTerm();
156 std::string::size_type prepareNextCTerm();
157 void setIndependentInternal(const bool bit);
158 void setSemiSpecificInternal(const bool bit);
159 void makeCustomPropIndexed();
160
161 private:
162 std::string title_;
163 bool semiSpecific_;
164
165 bool independent_;
166
167 typedef std::vector< bool* > residue_flags_vector;
168
169 residue_flags_vector cleavageNTerm;
170 residue_flags_vector cleavageCTerm;
171 residue_flags_vector restrictNTerm;
172 residue_flags_vector restrictCTerm;
173 };// class ms_enzyme
174
175 class ms_filesource;
176
178
193 class MS_MASCOTRESFILE_API ms_enzymefile : public ms_errors
194 {
195 public:
197 ms_enzymefile();
198
200 ms_enzymefile(const ms_enzymefile& src);
201
203 ms_enzymefile(const char* filename, const matrix_science::ms_connection_settings * cs = 0);
204
206 ~ms_enzymefile();
207
209 void defaultValues();
210
212 void copyFrom(const ms_enzymefile* right);
213
214#ifndef SWIG
216 ms_enzymefile& operator=(const ms_enzymefile& right);
217#endif
219 void setFileName(const char* filename);
220
222 std::string getFileName() const;
223
225 void setConnectionSettings(const matrix_science::ms_connection_settings & cs);
226
228 matrix_science::ms_connection_settings getConnectionSettings() const;
229
231 void read_file();
232
234 void read_buffer(const char* buffer);
235
237 void save_file();
238
240 int getNumberOfEnzymes() const;
241
243 void clearEnzymes();
244
246 void appendEnzyme(const ms_enzyme* item);
247
249 const ms_enzyme* getEnzymeByNumber(const int num) const;
250
252 const ms_enzyme* getEnzymeByName(const char* name) const;
253
255 bool isNoneFound() const;
256
258 bool updateEnzymeByNumber(const int num, const ms_enzyme enzyme);
259
261 bool updateEnzymeByName(const char* name, const ms_enzyme enzyme);
262
264 bool deleteEnzymeByNumber(const int num);
265
267 bool deleteEnzymeByName(const char* name);
268
269
270 private:
271
272 void read_internal(ms_filesource *pFSource);
273
274 std::string filename_;
275 std::vector<ms_enzyme*> entries_;
276 std::vector< std::string > comments_;
277 bool noneFound_;
278 ms_connection_settings cs_;
279
280 }; // class ms_enzymefile // end of config_group
282} // matrix_science
283
284#endif // MS_ENZYME_HPP
285
286/*------------------------------- End of File -------------------------------*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_enzyme
Represent a single entry in the enzymes file.
Definition: ms_enzyme.hpp:67
matrix_science::ms_enzyme::cuttertype
cuttertype
Definitions for types of cutter.
Definition: ms_enzyme.hpp:76
matrix_science::ms_enzymefile
Reads and parses the enzymes file that contains multiple enzyme definitions.
Definition: ms_enzyme.hpp:194
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_errors.hpp Source File

  • inc
ms_errors.hpp
1/*
2##############################################################################
3# file: ms_errors.hpp #
4# 'msparser' toolkit #
5# Encapsulates a general-purpose error object that collects information #
6# about several consecutive erros #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /Mowse/ms_mascotresfile/include/ms_errors.hpp $ #
13# $Author: robertog@matrixscience.com $ #
14# $Date: 2024-08-29 13:57:05 +0100 $ #
15# $Revision: 8cbe2dd49d444fe922eab2e1d711a8413b9c43ac | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_ERRORS_HPP
21#define MS_ERRORS_HPP
22
23
24#include <cstdarg>
25#include <vector>
26#include <string>
27#include <set>
28
29namespace matrix_science {
36 class MS_MASCOTRESFILE_API ms_errs : public ms_log
37 {
38 public:
39
41 typedef msg_num_t err;
42
43 // errors for result files
44 static const err ERR_NO_ERROR = 0x0000;
45 static const err ERR_NOMEM = 0x0001;
46 static const err ERR_NOSUCHFILE = 0x0002;
47 static const err ERR_READINGFILE = 0x0003;
48 static const err ERR_QUERYOUTOFRANGE = 0x0004;
49 static const err ERR_MISSINGENTRY = 0x0005;
50 static const err ERR_PEPSUMMPEPGET = 0x0006;
51 static const err ERR_PEPTIDESTR = 0x0007;
52 static const err ERR_ACCINPEPTIDESTR = 0x0008;
53 static const err ERR_PROTSUMM = 0x0009;
54 static const err ERR_PROTSUMMPEP = 0x000A;
55 static const err ERR_ADDPEPTIDES = 0x000B;
56 static const err ERR_MISSINGHIT = 0x000C;
57 static const err ERR_MISSINGSECTION = 0x000D;
58 static const err ERR_MISSINGSECTIONEND = 0x000E;
59 static const err ERR_MALFORMED_ERR_TOL = 0x000F;
60 static const err ERR_NO_ERR_TOL_PARENT = 0x0010;
61 static const err ERR_NULL_ACC_PEP_SUM = 0x0011;
62 static const err ERR_NULL_ACC_PROT_SUM = 0x0012;
63 static const err ERR_DUPE_ACCESSION = 0x0013;
64 static const err ERR_UNASSIGNED_PROG = 0x0014;
65 static const err ERR_UNASSIGNED_RANGE = 0x0015;
66 static const err ERR_UNASSIGNED_UNK = 0x0016;
67 static const err ERR_NO_UNIGENE_FILE = 0x0017;
68 static const err ERR_DUPLICATE_KEY = 0x0018;
69 static const err ERR_OLDRESULTSFILE = 0x0019;
70 static const err ERR_MALFORMED_TAG = 0x001A;
71 static const err ERR_MALFORMED_DRANGE = 0x001B;
72 static const err ERR_INVALID_NUMQUERIES = 0x001C;
73 static const err ERR_MALFORMED_TERMS = 0x001D;
74 static const err ERR_INVALID_RESFILE = 0x001E;
75 static const err ERR_INVALID_PROTDB = 0x001F;
76 static const err ERR_UNIGENE_MULTIDB = 0x0020;
77 static const err ERR_INVALID_CACHE_DIR = 0x0021;
78 static const err ERR_FAIL_OPEN_DAT_FILE = 0x0022;
79 static const err ERR_MISSING_CDB_FILE = 0x0023;
80 static const err ERR_FAIL_MK_CACHE_DIR = 0x0024;
81 static const err ERR_FAIL_MK_CDB_FILE = 0x0025;
82 static const err ERR_FAIL_CLOSE_FILE = 0x0026;
83 static const err ERR_FAIL_CDB_INIT = 0x0027;
84 static const err ERR_INVALID_CDB_FILE = 0x0028;
85 static const err ERR_WRITE_CDB_FILE = 0x0029;
86 static const err ERR_CDB_TOO_LARGE = 0x002A;
87 static const err ERR_NEED_64_BIT = 0x002B;
88 static const err ERR_CDB_64_BIT_REMAKE = 0x002C;
89 static const err ERR_CDB_OLD_VER_RETRY = 0x002D;
90 static const err ERR_CDB_OLD_VER_NO_RETRY = 0x002E;
91 static const err ERR_CDB_INCOMPLETE_RETRY = 0x002F;
92 static const err ERR_CDB_INCOMPLETE_NO_RETRY = 0x0030;
93 static const err ERR_CDB_BEING_CREATED = 0x0031;
94 static const err ERR_CDB_FAIL_REMOVE = 0x0032;
95 static const err ERR_CDB_FAIL_LOCK = 0x0033;
96 static const err ERR_CDB_FAIL_UNLOCK = 0x0034;
97 static const err ERR_CDB_SOURCE_CHANGE_RETRY = 0x0035;
98 static const err ERR_CDB_SOURCE_CHANGE_NO_RETRY = 0x0036;
99 static const err ERR_MISSING_PERCOLATOR_FILE = 0x0037;
100 static const err ERR_CANNOT_APPEND_RESFILE = 0x0038;
101 static const err ERR_CANNOT_APPEND_RESFILE_NO_FNAMES = 0x0039;
102 static const err ERR_RESULTS_NOT_CREATED = 0x003A;
103 // End of errors for ms_mascotresfile_dat. Above errors are duplicated in ms_mascotresfile_dat.hpp
104 // After fixing bug 11415, should not be necessary to add more errors into the list above.
105
106 // OS errors
107 static const err ERR_MSP_FAILED_TO_OPEN_FILE = 0x0100;
108 static const err ERR_MSP_FAILED_TO_CLOSE_FILE = 0x0101;
109 static const err ERR_MSP_FAIL_STAT = 0x0102;
110 static const err ERR_MSP_GET_VOLUME_INFO = 0x0103;
111 static const err ERR_MSP_FILE_DOESNT_EXIST = 0x0104;
112 static const err ERR_MSP_FAIL_GET_PROCESS_AFFINITY = 0x0105;
113 static const err ERR_MSP_SYSMP_FAIL = 0x0106;
114 static const err ERR_MSP_FAIL_GET_SYSINFO = 0x0107;
115 static const err ERR_MSP_FAILED_TO_WRITE_FILE = 0x0108;
116 static const err ERR_MSP_FAIL_UTIME = 0x0109;
117 static const err ERR_MSP_FAILED_TO_READ_FILE = 0x010A;
118
119 // ms_processors errors
120 static const err ERR_MSP_FAIL_HWLOC_INIT = 0x0150;
121 static const err ERR_MSP_FAIL_HWLOC_LOAD = 0x0151;
122 static const err ERR_MSP_BIND_INVALID_CPU = 0x0152;
123 static const err ERR_MSP_FAIL_PROCESSOR_BIND = 0x0153;
124 static const err ERR_MSP_FAIL_THREAD_BIND = 0x0154;
125 static const err ERR_MSP_INVALID_LOGICAL_CPU_NUM = 0x0155;
126 static const err ERR_MSP_INVALID_CPU_PACKAGE_NUM = 0x0156;
127 static const err ERR_MSP_INVALID_NUM_LICENSED = 0x0157;
128
129 // fragmentation rules file related errors
130 static const err ERR_MSP_FRAGMENTATION_RULES = 0x0200;
131
132 // masses file related errors
133 static const err ERR_MSP_IN_MASSES_FILE = 0x0300;
134 static const err ERR_MSP_INVALID_MASS_IN_MASSES_FILE = 0x0301;
135
136 // mod_file related errors
137 static const err ERR_MSP_DUPLICATE_MOD = 0x0400;
138 static const err ERR_MSP_RESIDUE_AND_TERMINUS_MOD = 0x0401;
139 static const err ERR_MSP_TOO_MANY_MODS_IN_MOD_FILE = 0x0402;
140 static const err ERR_MSP_NO_COMMAS_IN_MOD_NAME = 0x0403;
141 static const err ERR_MSP_IN_MODS_FILE = 0x0404;
142 static const err ERR_MSP_MISSING_DEFINITION_END = 0x0405;
143 static const err ERR_MSP_NO_SUCH_MOD = 0x0406;
144
145 // enzymes file related errors
146 static const err ERR_MSP_ENZYME_FILE_FORMAT = 0x0500;
147 static const err ERR_MSP_MISSING_ENZYME_TITLE = 0x0501;
148 static const err ERR_MSP_ENZYME_DEFINITION_PROBLEM = 0x0502;
149 static const err ERR_MSP_ENZYME_TOO_MANY_RULES = 0x0503;
150
151 // mascot.dat file related errors
152 static const err ERR_MSP_MISSING_MASCOT_DAT = 0x0601;
153 static const err ERR_MSP_DB_USES_MISSING_RULE = 0x0602;
154 static const err ERR_MSP_COMPILE_PARSE_RULE = 0x0603;
155 static const err ERR_MSP_NEED_1_EXP_IN_PARSE_RULE = 0x0604;
156 static const err ERR_MSP_IN_MASCOT_DAT_DB_SECT = 0x0605;
157 static const err ERR_MSP_IN_OPTIONS_SECTION = 0x0606;
158 static const err ERR_MSP_IN_CLUSTER_SECTION = 0x0607;
159 // static const err ERR_MSP_TOO_MANY_CPUS_IN_SUB_CLUSTER = 0x0608; //!< [W] The number of CPUs for the sub cluster is too high.
160 static const err ERR_MSP_CRON_TOO_MANY_JOBS = 0x0609;
161 static const err ERR_MSP_INVALID_PARSE_RULE = 0x060A;
162 static const err ERR_MSP_INVALID_PARSE_RULE_NO = 0x060B;
163 static const err ERR_MSP_RULE_NO_ALREADY_DEFINED = 0x060C;
164 static const err ERR_MSP_MISSING_QUOTE_IN_PARSE_RULE = 0x060D;
165 static const err ERR_MSP_PARSE_LEN_EXCEED = 0x060E;
166 static const err ERR_MSP_IN_TAXONOMY_SECTION = 0x060F;
167 static const err ERR_MSP_INCOMPATIBLE_TAX_RULES = 0x0610;
168 static const err ERR_MSP_MAX_PREFIX_REMOVES = 0x0611;
169 static const err ERR_MSP_MAX_SUFFIX_REMOVES = 0x0612;
170 static const err ERR_MSP_MAX_TAX_NO_BREAKS = 0x0613;
171 static const err ERR_MSP_CRON_INVALID_CHAR = 0x0614;
172 static const err ERR_MSP_CRON_INVALID_NUMBER = 0x0615;
173 static const err ERR_MSP_CRON_INVALID_STAR = 0x0616;
174 static const err ERR_MSP_CRON_NO_NUM_BEFORE_COMMA = 0x0617;
175 static const err ERR_MSP_CRON_NO_NUM_BEFORE_MINUS = 0x0618;
176 static const err ERR_MSP_INVALID_PROCESSOR_LINE = 0x0619;
177 static const err ERR_MSP_PROCESSOR_NOT_IN_SET = 0x061A;
178 static const err ERR_MSP_SPECIFY_UNAVAILABLE_PROCESSOR = 0x061B;
179 static const err ERR_MSP_TOO_MANY_PROCESSORS = 0x061C;
180 static const err ERR_MSP_TOO_MANY_TH_PROCESSORS = 0x061D;
181 static const err ERR_MSP_WWW_SECTION = 0x061E;
182 static const err ERR_MSP_DUP_TAXONOMYRULE = 0x061F;
183 static const err ERR_MSP_WRONG_ICAT_FILTER = 0x0620;
184 static const err ERR_MSP_EXEC_AFTER_SEARCH_INVALID = 0x0621;
185 static const err ERR_MSP_EXEC_AFTER_SEARCH_DEPENDS = 0x0622;
186 static const err ERR_MSP_EXEC_AFTER_SEARCH_LOGGING = 0x0623;
187 static const err ERR_MSP_REPORTBUILDERCOLARR_INVALID = 0x0624;
188 static const err ERR_MSP_UNEXPECTED_LINE_OUT_OF_SECT = 0x0625;
189 static const err ERR_MSP_MISSING_SECTION = 0x0626;
190 static const err ERR_MSP_NO_REGEX_MATCH = 0x0627;
191 static const err ERR_MSP_REGEX_ERROR = 0x0628;
192 static const err ERR_MSP_COLOURSCHEME_INVALID = 0x0629;
193 static const err ERR_MSP_PERCOLATOR_USE_RT_OBSOLETE = 0x0630;
194
195 // license file related errors
196 static const err ERR_MSP_NO_LICENSE_FILE = 0x0700;
197 static const err ERR_MSP_LICENSE_DES_CHECKSUM = 0x0701;
198 static const err ERR_MSP_LICENSE_LINE_CHECKSUM = 0x0702;
199 static const err ERR_MSP_LICENSE_NOT_YET_AVAIL = 0x0703;
200 static const err ERR_MSP_LICENSE_EXPIRED = 0x0704;
201 static const err ERR_MSP_LICENSE_INTERNAL_CONFIG = 0x0705;
202 static const err ERR_MSP_LICENSE_LINE_INVALID = 0x0706;
203
204 static const err ERR_MSP_XML_SYSTEM_FAILED = 0x0801;
205 static const err ERR_MSP_XML_NO_ROOT_ELEMENT = 0x0802;
206 static const err ERR_MSP_XML_TABLE_NOTFOUND = 0x0803;
207 static const err ERR_MSP_XML_FIELD_NOTFOUND = 0x0804;
208 static const err ERR_MSP_XML_INVALID_FIELD_FORMAT = 0x0805;
209 static const err ERR_MSP_XML_LOCAL_SCHEMA_NOT_STORED = 0x0806;
210 static const err ERR_MSP_XML_ELEMENT_NOT_FOUND = 0x0807;
211 static const err ERR_MSP_XML_MEMORY_ERROR = 0x0808;
212 static const err ERR_MSP_XML_FAILEDLOAD = 0x0809;
213 static const err ERR_MSP_XML_FAILEDSAVE = 0x0810;
214
215 static const err ERR_MSP_HTTP_TRANSMISSION_FAILED = 0x0901;
216 static const err ERR_MSP_HTTP_INVALID_URL = 0x0902;
217 static const err ERR_MSP_MASCOT_NOT_RUNNING = 0x0903;
218 // Removed at version 2.5
219 // static const err ERR_MSP_HTTP_WININET_FAILED = 0x0904; //!< [F] Wininet failure.
220
221 // ms_aahelper errors
222 static const err ERR_MSP_CONFLICT_BETWEEN_MODS = 0x0A01;
223 static const err ERR_MSP_WRONG_MOD_VECTOR = 0x0A02;
224 static const err ERR_MSP_MOD_MUST_BE_VAR = 0x0A03;
225 static const err ERR_MSP_MALFORMED_PEPTIDE = 0x0A04;
226 static const err ERR_MSP_DOUBLE_CHARGE_NOT_ALLOWED = 0x0A05;
227 static const err ERR_MSP_NO_ENZYME_SET = 0x0A06;
228 static const err ERR_MSP_EMPTY_MOD = 0x0A07;
229 static const err ERR_MSP_LOOPLINKING_NOT_IMPLEMENTED = 0x0A08;
230 static const err ERR_MSP_CROSSLINKING_MULTI_PEPTIDE = 0x0A09;
231 static const err ERR_MSP_CROSSLINKING_MULTI_LINKS = 0x0A10;
232 static const err ERR_MSP_CROSSLINKING_INVALID_LINK = 0x0A11;
233 static const err ERR_MSP_CROSSLINKING_VARMOD_CONFLICT = 0x0A12;
234 static const err ERR_MSP_MISSING_ET_MOD = 0x0A13;
235 static const err ERR_MSP_MISSING_SL_MOD = 0x0A14;
236 static const err ERR_MSP_MISSING_MONOLINK_MOD = 0x0A15;
237
238 static const err ERR_MSP_TAXONOMY_NO_TITLE = 0x0B01;
239 static const err ERR_MSP_TAXONOMY_NO_COMMAS = 0x0B02;
240 static const err ERR_MSP_TAXONOMY_WRONG_LINE = 0x0B03;
241 static const err ERR_MSP_TAXONOMY_DEFINITION_END = 0x0B04;
242 static const err ERR_MSP_TAXONOMY_CONFLICT_PARENTS = 0x0B05;
243 static const err ERR_MSP_TAXONOMY_INVALID_NODE_FILE = 0x0B06;
244 static const err ERR_MSP_TAXONOMY_MISSING_NODE_FILE = 0x0B07;
245
246 // ms_msr2dat28 errors
247 static const err ERR_MSP_LEGACY_DATA_NOT_AVAILABLE = 0x0C01;
248 static const err ERR_MSP_LEGACY_DATA_WRONG_FORMAT = 0x0C02;
249 static const err ERR_MSP_LEGACY_DATA_SQL_ERROR = 0x0C03;
250 static const err ERR_MSP_LEGACY_DATA_READ_ERROR = 0x0C04;
251
252
253 // ms_mascotresfile_msr errors.
254 static const err ERR_MSP_MSR_READING_FILE = 0x0D01;
255
256 // Internal errors related to MSR files.
257 static const err ERR_MSP_MSR_CREATING_FILE = 0x0E01;
258 static const err ERR_MSP_MSR_WRITING_FILE = 0x0E02;
259
260 // Security related errors
261 static const err ERR_MSP_SECURITY_INVALID_SESSION_ID = 0x1000;
262 static const err ERR_MSP_SECURITY_NOT_ADMIN_SESSION = 0x1001;
263 static const err ERR_MSP_SECURITY_DUPE_USER_ID = 0x1002;
264 static const err ERR_MSP_SECURITY_DUPE_USER_NAME = 0x1003;
265 static const err ERR_MSP_SECURITY_BAD_USER_NAME = 0x1004;
266 static const err ERR_MSP_SECURITY_USERNAME_NOT_FOUND = 0x1005;
267 static const err ERR_MSP_SECURITY_USERID_NOT_FOUND = 0x1006;
268 static const err ERR_MSP_SECURITY_DUPE_GROUP_ID = 0x1007;
269 static const err ERR_MSP_SECURITY_DUPE_GROUP_NAME = 0x1008;
270 static const err ERR_MSP_SECURITY_BAD_GROUP_NAME = 0x1009;
271 static const err ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND = 0x100A;
272 static const err ERR_MSP_SECURITY_GROUPID_NOT_FOUND = 0x100B;
273 static const err ERR_MSP_SECURITY_FAIL_LOAD_SEC = 0x100C;
274 static const err ERR_MSP_SECURITY_FAIL_LOAD_USER = 0x100D;
275 static const err ERR_MSP_SECURITY_FAIL_LOAD_GROUP = 0x100E;
276 static const err ERR_MSP_SECURITY_DEL_SPECIAL_GROUP = 0x100F;
277 static const err ERR_MSP_SECURITY_DEL_SPECIAL_USER = 0x1010;
278 static const err ERR_MSP_SECURITY_DISABLE_ADMIN = 0x1011;
279 static const err ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS = 0x1012;
280 static const err ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP = 0x1013;
281 static const err ERR_MSP_SECURITY_DUPE_GROUP_NAME_U = 0x1014;
282 static const err ERR_MSP_SECURITY_DUPE_USER_NAME_U = 0x1015;
283 static const err ERR_MSP_SECURITY_OLD_PW_INVALID = 0x1016;
284 static const err ERR_MSP_SECURITY_NO_GUEST_PWD = 0x1017;
285 static const err ERR_MSP_SECURITY_PASSWORD_TOO_SHORT = 0x1018;
286 static const err ERR_MSP_SECURITY_FAIL_SAVE_SEC = 0x1019;
287 static const err ERR_MSP_SECURITY_NO_RIGHTS_UPD_USR = 0x101A;
288
289 static const err ERR_MSP_SECURITY_INVALIDUSER = 0x1101;
290 static const err ERR_MSP_SECURITY_INVALIDPASSWORD = 0x1102;
291 static const err ERR_MSP_SECURITY_MISSINGSESSIONFILE = 0x1103;
292 static const err ERR_MSP_SECURITY_SAVESESSIONFILE = 0x1104;
293 static const err ERR_MSP_SECURITY_TIMEDOUT = 0x1105;
294 static const err ERR_MSP_SECURITY_DIFFERENTIPADDR = 0x1106;
295 static const err ERR_MSP_SECURITY_PASSWORDEXPIRED = 0x1107;
296 static const err ERR_MSP_SECURITY_NOTLOGGEDIN = 0x1108;
297 static const err ERR_MSP_SECURITY_INVALIDSESSION = 0x1109;
298 static const err ERR_MSP_SECURITY_NOSAVEPARAMS = 0x110A;
299 static const err ERR_MSP_SECURITY_SESSIONDESTROYED = 0x110B;
300 static const err ERR_MSP_SECURITY_NOCREATEGUEST = 0x110C;
301 static const err ERR_MSP_SECURITY_UPDATESESS = 0x110D;
302 static const err ERR_MSP_SECURITY_ACCOUNT_DISABLED = 0x110E;
303 static const err ERR_MSP_SECURITY_NOTNORMALUSER = 0x110F;
304 static const err ERR_MSP_SECURITY_SAMEPASSWORD = 0x1110;
305 static const err ERR_MSP_SECURITY_SPOOFATTEMPT1 = 0x1111;
306 static const err ERR_MSP_SECURITY_SPOOFATTEMPT2 = 0x1112;
307 static const err ERR_MSP_SECURITY_SPOOFATTEMPT3 = 0x1113;
308 static const err ERR_MSP_SECURITY_SPOOFATTEMPT4 = 0x1114;
309 static const err ERR_MSP_SECURITY_FAILGETINTEGRAURL = 0x1115;
310 static const err ERR_MSP_SECURITY_FAILGETINTEGRA = 0x1116;
311 static const err ERR_MSP_SECURITY_INTEGRACONNFORMAT = 0x1117;
312 static const err ERR_MSP_SECURITY_INTEGRAINVALIDPW = 0x1118;
313 static const err ERR_MSP_SECURITY_INTEGRAINVALIDCO = 0x1119;
314 static const err ERR_MSP_SECURITY_LOADSESSIONFILE = 0x111A;
315 static const err ERR_MSP_SECURITY_NOT_INTEGRA_USER = 0x111B;
316 static const err ERR_MSP_SECURITY_NOT_ENABLED = 0x111C;
317 static const err ERR_MSP_SECURITY_NO_INTEGRA_LOGIN = 0x111D;
318 static const err ERR_MSP_SESSION_UTIME_FAIL = 0x111E;
319 static const err ERR_MSP_SECURITY_CMDLINE_CGI = 0x111F;
320
321
322 // Security logging messages
323 static const err ERR_MSP_SECURITY_ADDUSER = 0x1200;
324 static const err ERR_MSP_SECURITY_DELUSER = 0x1201;
325 static const err ERR_MSP_SECURITY_UPDATEUSER = 0x1202;
326 static const err ERR_MSP_SECURITY_UPDATEPW = 0x1203;
327 static const err ERR_MSP_SECURITY_ADDGROUP = 0x1204;
328 static const err ERR_MSP_SECURITY_DELETEGROUP = 0x1205;
329 static const err ERR_MSP_SECURITY_UPDATEGROUP = 0x1206;
330
331 static const err ERR_MSP_SECURITY_GETALLGROUPIDS = 0x1300;
332 static const err ERR_MSP_SECURITY_GETGROUPOK = 0x1301;
333 static const err ERR_MSP_SECURITY_GETGROUPFAIL = 0x1302;
334 static const err ERR_MSP_SECURITY_GETUSEROK = 0x1303;
335 static const err ERR_MSP_SECURITY_GETUSERFAIL = 0x1304;
336 static const err ERR_MSP_SECURITY_GETUSERFROMIDOK = 0x1305;
337 static const err ERR_MSP_SECURITY_GETUSERFROMIDFAIL = 0x1306;
338 static const err ERR_MSP_SECURITY_GETALLUSERIDS = 0x1307;
339 static const err ERR_MSP_SECURITY_GETGROUPFROMIDOK = 0x1308;
340 static const err ERR_MSP_SECURITY_GETGROUPFROMIDFAIL = 0x1309;
341 static const err ERR_MSP_SECURITY_GETPERMTASKSOK = 0x130A;
342 static const err ERR_MSP_SECURITY_GETPERMTASKSFAIL = 0x130B;
343 static const err ERR_MSP_SECURITY_UPDATEALLSESSFILES = 0x130C;
344 static const err ERR_MSP_SECURITY_GETINTEGRAUSERS1 = 0x130D;
345 static const err ERR_MSP_SECURITY_GETINTEGRAUSERS2 = 0x130E;
346 static const err ERR_MSP_SECURITY_GETINTEGRAUSERS3 = 0x130F;
347 static const err ERR_MSP_SECURITY_VALIDATEINTEGRAPW1 = 0x1310;
348 static const err ERR_MSP_SECURITY_VALIDATEINTEGRAPW2 = 0x1311;
349 static const err ERR_MSP_SECURITY_VALIDATEINTEGRAPW3 = 0x1312;
350 static const err ERR_MSP_SECURITY_VALIDATEINTEGRACO1 = 0x1313;
351 static const err ERR_MSP_SECURITY_VALIDATEINTEGRACO2 = 0x1314;
352
353 static const err ERR_MSP_SECURITY_MSSESSIONCTOR = 0x1330;
354 static const err ERR_MSP_SECURITY_MSSESSCOOKIE = 0x1331;
355 static const err ERR_MSP_SECURITY_LOADINGSESS = 0x1332;
356 static const err ERR_MSP_SECURITY_MSSESSLOGIN = 0x1333;
357 static const err ERR_MSP_SECURITY_MSSESSINTEGRA = 0x1334;
358 static const err ERR_MSP_SECURITY_MSSESSRESULTSPERM = 0x1335;
359
360 static const err ERR_MSP_QUANT_FAILEDLOAD = 0x1400;
361 static const err ERR_MSP_QUANT_FAILEDSAVE = 0x1401;
362
363 static const err ERR_MSP_QUANT_HELPER_FAILEDINIT = 0x1410;
364
365 static const err ERR_MSP_QUANTITATION_FAILEDINIT = 0x1420;
366 static const err ERR_MSP_QUANTITATION_NOMETHOD = 0x1421;
367 static const err ERR_MSP_QUANTITATION_BADMETHOD = 0x1422;
368 static const err ERR_MSP_QUANTITATION_BADCOMPONENT = 0x1423;
369
370 static const err ERR_MSP_MS2QUANTITATION_FAILEDINIT = 0x1430;
371 static const err ERR_MSP_MS2QUANTITATION_NORM_NO_SUM = 0x1431;
372 static const err ERR_MSP_MS2QUANTITATION_NORM_UNIMP = 0x1432;
373 static const err ERR_MSP_MS2QUANTITATION_PROTWEIGH = 0x1433;
374 static const err ERR_MSP_MS2QUANTITATION_PROTR_UNIM = 0x1434;
375 static const err ERR_MSP_MS2QUANTITATION_COMPONENTS = 0x1435;
376 static const err ERR_MSP_MS2QUANTITATION_QUERY_SECS = 0x1436;
377
378 static const err ERR_MSP_CUSTQUANT_FAILEDINIT = 0x1450;
379 static const err ERR_MSP_CUSTQUANT_PROTR_UNIM = 0x1451;
380
381 static const err ERR_MSP_MS1QUANTITATION_HITREF_NEW = 0x1470;
382 static const err ERR_MSP_MS1QUANTITATION_HITREF_DROP = 0x1471;
383 static const err ERR_MSP_MS1QUANTITATION_FAILEDINIT = 0x1472;
384 static const err ERR_MSP_MS1QUANT_GET_COMBINED_LIMITS = 0x1473;
385 static const err ERR_MSP_MS1QUANT_RTOFFSET_DIFF_FRACT = 0x1474;
386 static const err ERR_MSP_MS1QUANT_TIME_ALIGN_INDEX = 0x1475;
387 static const err ERR_MSP_MS1QUANT_INVALID_PROJECT_ID = 0x1476;
388 static const err ERR_MSP_MS1QUANT_XML_LOAD_PROJECT_ID = 0x1477;
389 static const err ERR_MSP_MS1QUANT_XML_INVALID_BIN1 = 0x1478;
390 static const err ERR_MSP_MS1QUANT_XML_INVALID_BIN2 = 0x1479;
391 static const err ERR_MSP_MS1QUANT_XML_INVALID_RT = 0x147A;
392 static const err ERR_MSP_MS1QUANT_XML_SAX_STATE = 0x147B;
393 static const err ERR_MSP_MS1QUANT_XML_SAX_ELEMENT = 0x147C;
394 static const err ERR_MSP_MS1QUANT_XML_PARSE = 0x147D;
395 static const err ERR_MSP_MS1QUANT_NO_EST_WIDTH = 0x147E;
396 static const err ERR_MSP_MS1QUANT_CDB_BYTES = 0x147F;
397 static const err ERR_MSP_MS1QUANT_CDB_VERSION = 0x1480;
398 static const err ERR_MSP_MS1QUANT_CDB_MISSING_KEY = 0x1481;
399 static const err ERR_MSP_MS1QUANT_TIME_ALIGIN_CALCFRM = 0x1482;
400
401 static const err ERR_MSP_UMOD_FAILEDLOAD = 0x1500;
402 static const err ERR_MSP_UMOD_FAILEDSAVE = 0x1501;
403
404 static const err ERR_MSP_XMLSCHEMA_FAILEDLOAD = 0x1600;
405 static const err ERR_MSP_XMLSCHEMA_FAILEDSAVE = 0x1601;
406
407 static const err ERR_MSP_ZIP_ENDIAN = 0x1700;
408 static const err ERR_MSP_ZIP_OUTOFMEMORY = 0x1701;
409 static const err ERR_MSP_ZIP_BUFTOOSMALL = 0x1702;
410 static const err ERR_MSP_ZIP_INVALIDDATA = 0x1703;
411 static const err ERR_MSP_ZIP_UNKNOWN = 0x1704;
412 static const err ERR_MSP_ZIP_LENGTHDIFFERS = 0x1705;
413 static const err ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG = 0x1706;
414 static const err ERR_MSP_ZIP_ZEROLENGTH = 0x1707;
415 static const err ERR_MSP_ZIP_VERSIONERROR = 0x1708;
416 static const err ERR_MSP_ZIP_NOTSTREAMING = 0x1709;
417 static const err ERR_MSP_ZIP_STREAMERROR = 0x1710;
418 static const err ERR_MSP_ZIP_COMPRESSEDDATATOOLONG = 0x1711;
419 static const err ERR_MSP_ZIP_INVALID_STREAMING_MODE = 0x1712;
420
421 // Installer error messages
422 static const err ERR_MSP_INST_INVALIDCPUINFO = 0x1800;
423 static const err ERR_MSP_INST_MISSINGDATABASE = 0x1801;
424 static const err ERR_MSP_INST_FAILADDPARSERULE = 0x1802;
425 static const err ERR_MSP_INST_CANTGETHOSTNAME = 0x1803;
426
427 // HTTP communication
428 static const err ERR_MSP_HTTP_WEBAUTHERROR = 0x1901;
429 static const err ERR_MSP_HTTP_VERSIONERROR = 0x1902;
430 static const err ERR_MSP_HTTP_MISSINGLOGINERROR = 0x1903;
431 static const err ERR_MSP_HTTP_MISSINGLOGININFO = 0x1904;
432 static const err ERR_MSP_HTTP_LOGINPARSERERROR = 0x1905;
433 static const err ERR_MSP_HTTP_LOGINPARSERERRORINT = 0x1906;
434 static const err ERR_MSP_HTTP_LOGINSERVERERROR = 0x1907;
435 static const err ERR_MSP_HTTP_LOGINSERVERERRORINT = 0x1908;
436 static const err ERR_MSP_HTTP_LOGINERROR = 0x1909;
437 static const err ERR_MSP_HTTP_LOGINERRORINT = 0x190A;
438 static const err ERR_MSP_HTTP_CHANGEPASSWORDDISABLED = 0x190B;
439 static const err ERR_MSP_HTTP_OPENOUTPUTFILEFAILED = 0x190C;
440 static const err ERR_MSP_HTTP_WRITEOUTPUTFILEFAILED = 0x190D;
441 static const err ERR_MSP_HTTP_RELOGINFAILED = 0x190E;
442
443 static const err ERR_MSP_HTTP_SETPROXYFAILED = 0x1A01;
444 static const err ERR_MSP_HTTP_SETPROXYUSERNAMEFAILED = 0x1A02;
445 static const err ERR_MSP_HTTP_SETPROXYPASSWORDFAILED = 0x1A03;
446 static const err ERR_MSP_HTTP_SETHTTPUSERNAMEFAILED = 0x1A04;
447 static const err ERR_MSP_HTTP_SETHTTPPASSWORDFAILED = 0x1A05;
448 static const err ERR_MSP_HTTP_SETREDIRECTFAILED = 0x1A06;
449 static const err ERR_MSP_HTTP_NORESPONSE = 0x1A08;
450 static const err ERR_MSP_HTTP_QUERYSTATUSFAILED = 0x1A0A;
451 static const err ERR_MSP_HTTP_OPENSESSIONFAILED = 0x1A0B;
452 static const err ERR_MSP_HTTP_OPENCONNECTIONFAILED = 0x1A0C;
453 static const err ERR_MSP_HTTP_OPENREQUESTFAILED = 0x1A0D;
454 static const err ERR_MSP_HTTP_CLOSESESSIONFAILED = 0x1A0B;
455 static const err ERR_MSP_HTTP_CLOSECONNECTIONFAILED = 0x1A0C;
456 static const err ERR_MSP_HTTP_CLOSEREQUESTFAILED = 0x1A0D;
457 static const err ERR_MSP_HTTP_ABORTEDBYUSER = 0x1A0E;
458 static const err ERR_MSP_HTTP_MAXCONECTIONSFAILED = 0x1A0F;
459 static const err ERR_MSP_HTTP_MAXCONECTIONS10FAILED = 0x1A10;
460 static const err ERR_MSP_HTTP_READRESPONSEFAILED = 0x1A11;
461 static const err ERR_MSP_HTTP_SENDREQUESTFAILED = 0x1A12;
462 static const err ERR_MSP_HTTP_QUERYDATAFAILED = 0x1A13;
463 static const err ERR_MSP_HTTP_READDATAFAILED = 0x1A14;
464 static const err ERR_MSP_HTTP_GETPROXYFAILED = 0x1A15;
465 static const err ERR_MSP_HTTP_BADHTTPSTATUS = 0x1A16;
466 static const err ERR_MSP_HTTP_ERROR = 0x1A17;
467 static const err ERR_MSP_HTTP_SESSIONALREADYOPEN = 0x1A18;
468 static const err ERR_MSP_HTTP_GETRESULTSFILENAME = 0x1A1A;
469 static const err ERR_MSP_HTTP_DOWNLOADFAILED = 0x1A1B;
470 static const err ERR_MSP_HTTP_HEADERFAILED = 0x1A1C;
471 static const err ERR_MSP_HTTP_GETSEARCHSTAGE = 0x1A1D;
472
473 // Error messages related to opening or reading cache files
474 static const err ERR_MSP_CACHE_OPENFAILED = 0x1B01;
475 static const err ERR_MSP_CACHE_READFAILED = 0x1B02;
476 static const err ERR_MSP_CACHE_INVALIDFORMAT = 0x1B03;
477 static const err ERR_MSP_CACHE_SIGNATUREINVALID = 0x1B04;
478 static const err ERR_MSP_CACHE_DATAOFFSETINVALID = 0x1B05;
479 static const err ERR_MSP_CACHE_FILESEEKFAILED = 0x1B06;
480 static const err ERR_MSP_CACHE_INVALIDVERSION = 0x1B07;
481 static const err ERR_MSP_CACHE_INVALIDSTREAMID = 0x1B08;
482 static const err ERR_MSP_CACHE_INVALIDSTREAMPOSITION = 0x1B09;
483 static const err ERR_MSP_CACHE_DUPLICATESTREAMID = 0x1B0A;
484 static const err ERR_MSP_CACHE_WRITEFAILED = 0x1B0B;
485 static const err ERR_MSP_CACHE_STREAMNOTFOUND = 0x1B0C;
486 static const err ERR_MSP_CACHE_WRITETRUNCATED = 0x1B0D;
487 static const err ERR_MSP_CACHE_MODIFYREADONLYMODE = 0x1B0E;
488 static const err ERR_MSP_CACHE_MODIFYCLOSED = 0x1B0F;
489 static const err ERR_MSP_CACHE_UNINITIALISEDSTREAM = 0x1B10;
490 static const err ERR_MSP_CACHE_SLREF_UPDATE = 0x1B11;
491 static const err ERR_MSP_CACHE_PROT_NUMPEPTIDES_RELOAD = 0x1B12;
492
493 static const err ERR_MSP_HTTP_XMLUPLOADFAILED = 0x1C01;
494
495 static const err ERR_MSP_NIST_MSP_INVALID_LINE = 0x1D01;
496 static const err ERR_MSP_NIST_MSP_MISSING_PARAMETER = 0x1D02;
497 static const err ERR_MSP_NIST_MSP_NO_SPECTRA = 0x1D03;
498 static const err ERR_MSP_NIST_MSP_NO_CREATE_CDB = 0x1D04;
499 static const err ERR_MSP_NIST_MSP_INCONSISTENT_MODS = 0x1D05;
500 static const err ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY = 0x1D06;
501 static const err ERR_MSP_NIST_SAVE_ZERO_SPECTRA = 0x1D07;
502 static const err ERR_MSP_NIST_NO_PEAKS_IN_SPECTRUM = 0x1D08;
503 static const err ERR_MSP_NIST_CANNOT_ANNOTATE_PEAK = 0x1D09;
504 static const err ERR_MSP_NIST_INDEX_OUT_OF_RANGE = 0x1D0A;
505 static const err ERR_MSP_NIST_NO_PRECURSOR_MZ_VALUE = 0x1D0B;
506 static const err ERR_MSP_NIST_MODIFICATION_NOT_FOUND = 0x1D0C;
507
508 static const err ERR_MSP_XHUNTER_WRONG_FORMAT = 0x1D20;
509
510 // More results file parsing errors
511 static const err ERR_RESFILE_INVALID_DB_TYPE = 0x1E01;
512 static const err ERR_RESFILE_LINKED_SITES = 0x1E02;
513 static const err ERR_RESFILE_LOOPLINKED_SITES = 0x1E03;
514 static const err ERR_RESFILE_MISSING_QEXP = 0x1E04;
515 static const err ERR_RESFILE_FUTURE_VERSION = 0x1E05;
516
517 // Model fitting and related errors
518 static const err ERR_MSP_SL_SCORING_MODEL_FAIL = 0x1F01;
519 static const err ERR_MSP_SL_SCORING_MODEL_WARN = 0x1F02;
520 static const err ERR_MSP_TARGET_FDR_FAILED_FOR_ET = 0x1F03;
521 static const err ERR_MSP_CLOSEST_FDR_FOR_ET = 0x1F04;
522 static const err ERR_MSP_DIFFERENT_1ST_PASS_THR_ET = 0x1F05;
523 static const err ERR_MSP_TARGET_FDR_FAILED_FOR_FIRST_PASS = 0x1F06;
524 static const err ERR_MSP_CLOSEST_FDR_FOR_FIRST_PASS = 0x1F07;
525
526 static const err ERR_MSP_QUANT_CDB_MATCH_STREAM = 0x2000;
527 static const err ERR_MSP_QUANT_CDB_MISSING_KEY = 0x2001;
528 static const err ERR_MSP_QUANT_MISSING_COMPONENT = 0x2002;
529 static const err ERR_MSP_QUANT_FAIL_LOAD_PEPTIDE = 0x2003;
530 static const err ERR_MSP_QUANT_EMPTY_REF_ACCESSION = 0x2004;
531 static const err ERR_MSP_QUANT_ACCESSION_NOT_FOUND = 0x2005;
532 static const err ERR_MSP_QUANT_INVALID_REF_AMOUNT = 0x2006;
533 static const err ERR_MSP_QUANT_FAIL_LOAD_MATCH = 0x2007;
534
535 static const err ERR_MSP_CROSSLINKING_FAILEDLOAD = 0x2100;
536 static const err ERR_MSP_CROSSLINKING_FAILEDSAVE = 0x2101;
537
538 // Error messages related to ms_imputation
539 static const err ERR_MSP_IMPUTATION_FAIL = 0x2200;
540 static const err ERR_MSP_IMPUTATION_WARNING = 0x2201;
541 static const err ERR_MSP_IMPUTATION_DEBUG1 = 0x2202;
542 static const err ERR_MSP_IMPUTATION_DEBUG2 = 0x2203;
543 static const err ERR_MSP_IMPUTATION_DEBUG3 = 0x2204;
544 static const err ERR_MSP_IMPUTATION_CONSTRUCTOR = 0x2205;
545 static const err ERR_MSP_IMPUTATION_VARIABLE = 0x2206;
546 static const err ERR_MSP_IMPUTATION_NO_RATIOS_PROTEIN = 0x2207;
547 static const err ERR_MSP_IMPUTATION_NO_RATIOS_PEPTIDE = 0x2208;
548 static const err ERR_MSP_IMPUTATION_NO_TIMES = 0x2209;
549 static const err ERR_MSP_IMPUTATION_EMPTY_DATA = 0x220A;
550 static const err ERR_MSP_IMPUTATION_KNN_BLANK_ROW = 0x220B;
551 static const err ERR_MSP_IMPUTATION_FIXED_PROGRESS = 0x220C;
552 static const err ERR_MSP_IMPUTATION_AVERAGE_PROGRESS = 0x220D;
553 static const err ERR_MSP_IMPUTATION_KNN_PROGRESS = 0x220E;
554 static const err ERR_MSP_IMPUTATION_MISSFOR_PROGRESS = 0x220F;
555
556 static const err ERR_MSP_LASTONE = 0xFFFF;
557
558 public:
560 ms_errs(msg_sev loglevel = sev_warn,
561 bool combineRepeats = true,
562 ms_loggingmonitor::Source_e api = ms_loggingmonitor::SRC_MSPARSER);
563
565 virtual ~ms_errs();
566
568 bool isValid() const;
569
570#ifndef SWIG
572 void setError(const ms_errs::err errorNum, ...);
573
575 void vsetError(const ms_errs::err errorNum, va_list argptr, const char * srcFileName = "", const int srcFileLineNum = -1);
576
577
579 void setError(const std::string sessionID,
580 const int userID,
581 const ms_errs::err errorNum, ...);
582
584 void setError(const int errorNum,
585 const char* strBuffer,
586 const msg_sev severity,
587 const int srcLineNumber = -1,
588 const char * srcFileName = "");
589
591 void setErrorPlusErrno(const ms_errs::err errorNum, ...);
592
594 bool anyIoErrors(FILE *f) const;
595
597 void appendError(const ms_errs::err errorNum, const int numRepeats, const std::string & errorString);
598
599#ifdef _WIN32
601 static std::string systemErrorText(unsigned winErrNum);
602#endif
603
604#endif
605
607 void setAPI(ms_loggingmonitor::Source_e api);
608
610 void appendErrors(const ms_errs& src);
611
613 int getNumberOfErrors() const;
614
616 void clearAllErrors();
617
619 int getErrorNumber(const int num = -1) const;
620
622 int getLastError() const;
623
625 std::string getErrorString(const int num) const;
626
628 std::string getLastErrorString() const;
629
631 msg_sev getErrorSeverity(const int num = -1) const;
632
634 int getErrorRepeats(const int num = -1) const;
635
637 void setLoggingFile(const std::string filename, const msg_sev level);
638
640 std::string getLoggingFileName() const;
641
643 virtual msg_sev getLoggingLevel() const;
644
646 void setLoggingLevel(const msg_sev level);
647
649 bool getCombineRepeats() const;
650
652 void setCombineRepeats(const bool flag);
653
655 bool willMessageBeLogged(const ms_errs::err errorNum) const;
656
658 void forwardToParentInstance(ms_errs * parent);
659
661 static ms_loggingmonitor::Level_e convertToLogLevel(ms_errs::msg_sev severity);
662
664 static ms_errs::msg_sev convertFromLogLevel(ms_loggingmonitor::Level_e logLevel);
665
667 static std::string _lookUpError(const ms_errs::err errorNum, ms_errs::msg_sev & severity);
668
669 protected:
670 virtual void _setError(const int /*ms_errs::err*/ errorNum,
671 const char* strBuffer,
672 const msg_sev severity,
673 const std::string & sessionID = "",
674 const int userID = -1,
675 const int srcLineNumber = -1,
676 const char * srcFileName = "");
677
678 private:
679 std::vector<int> errorNumbers_;
680 std::vector<std::string>errorStrings_; // Will include 'user' data
681 std::vector<msg_sev> errorSeverities_;
682 std::vector<int> errorRepeats_; // So that we don't get multiple errors
683 std::string logfileName_;
684 msg_sev loglevel_;
685 bool combineRepeats_;
686 ms_loggingmonitor::Source_e api_;
687
688 ms_errs * pParentToForwardTo_;
689 std::set<ms_errs *> objectsUsingMyData_;
690 }; // class ms_errs
691
692
693
695 class MS_MASCOTRESFILE_API ms_errors
696 {
697 public:
699 ms_errors();
700
702 ~ms_errors();
703
705 void copyFrom(const ms_errors* right);
706
708 void appendErrors(const ms_errors& src);
709
711 void clearAllErrors();
712
714 bool isValid() const;
715
717 std::string getLastErrorString() const;
718
720 int getLastError() const;
721
723 const ms_errs* getErrorHandler() const;
724
725#if !defined(SWIGJAVA) && !defined(SWIGCSHARP)
726 // \internal Internal use only - returning a non-const pointer
727 ms_errs* getErrorHandler();
728#endif
729
730 protected:
731 void appendError(const ms_errs::err errorNum, const int numRepeats, const std::string & errorString);
732 ms_errs err_; // error object that does all the work
733 }; // end of error_handling_group
735} // namespace matrix_science
736
737#endif // MS_ERRORS_HPP
738
739/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_errs::err
msg_num_t err
Definitions for error numbers.
Definition: ms_errors.hpp:41
matrix_science::ms_log
Definitions for logging messages.
Definition: ms_log.hpp:39
matrix_science::ms_log::msg_num_t
int msg_num_t
Typedef for log and error message numbers.
Definition: ms_log.hpp:127
matrix_science::ms_log::msg_sev
msg_sev
Message severity levels.
Definition: ms_log.hpp:47
matrix_science::ms_loggingmonitor::Level_e
Level_e
Logging severity levels.
Definition: ms_logging.hpp:51
matrix_science::ms_loggingmonitor::Source_e
Source_e
Logging event source.
Definition: ms_logging.hpp:65
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fileutilities.hpp Source File

  • inc
ms_fileutilities.hpp
1/*
2##############################################################################
3# file: ms_fileutilities.hpp #
4# 'msparser' toolkit #
5# Utilities class that encompasses all file-system-related functionality #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_fileutilities.hpp $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-01-30 13:52:08 +0000 $ #
14# $Revision: fe39c307262d12f8f7b679ca3ee7d4195657e703 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_FILEUTILITIES_HPP
20#define MS_FILEUTILITIES_HPP
21
22
23#include <string>
24
25// For _finddata_t
26#ifdef _WIN32
27#include <io.h>
28#endif
29
30// For off_t
31#ifdef __GNU__
32#include <unistd.h>
33#endif
34
35namespace matrix_science {
36 class ms_mascotoptions;
42#ifdef _WIN32
43#if defined(_MSC_VER) && (_MSC_VER < 1300)
44#define OFFSET64_C(c) c ## i64
45#else
46#define OFFSET64_C(c) c ## LL
47#endif
48 typedef INT64 OFFSET64_T;
49#else // !_WIN32
50#define OFFSET64_C(c) c ## LL
51 typedef off_t OFFSET64_T;
52#endif // !_WIN32
53
55
60 class MS_MASCOTRESFILE_API ms_fileutilities
61 {
62 public:
64 ms_fileutilities();
65
67 static time_t getLastModificationTime(const char* filename, ms_errs* err = NULL);
68
70 static void setLastModificationTime(const char* filename, time_t modificationTime, ms_errs* err = NULL);
71
73 static UINT64 getFileSize(const char* filename, ms_errs* err = NULL);
74
76 static std::string findMascotDat(const char *szMascotDatFilename,
77 ms_errs * err = NULL,
78 const int timeoutSec = 0 );
79
81 static bool doesFileExist(const char* filename);
82
83 static bool isFileWritable(const char * filePath);
84
86 enum err_sar {
87 SAR_SUCCESS,
88 SAR_FAIL_CHMOD,
89 SAR_FAIL_GET_NAMED_SECURITY_INFO,
90 SAR_FAIL_SET_ENTRIES_IN_ACL,
91 SAR_FAIL_SET_NAMED_SECURITY_INFO,
92 SAR_FAIL_CHOWN
93 };
95
98 err_sar setAccessRights(const char * filename,
99 const bool bWrite,
100 const bool bExecute,
101 const bool isFile,
102 const ms_mascotoptions & Options,
103 const bool avoid_reapply = false);
104 unsigned long getSARExtendedErrorCode() const;
105
107 static bool isDirectory(const char * path);
108
109#ifndef SWIG
111 static int createDirectory(const std::string & directory, std::string & errorDirectory);
112#else // SWIG Multiple return values
113 static int createDirectory(const std::string & directory, std::string & OUTPUT);
114#endif
116 static int deleteDirectory(const std::string & directory, const bool bDeleteSubdirectories = true);
117
119 bool findOpen(const std::string directory,
120 const std::string wildcard);
121
123 bool findNext(std::string & fileName);
124
126 void findClose();
127
129 static std::string stripLastFolder(const std::string pathname);
130
132 static std::string getMD5Sum(const std::string &str, const bool b32bitEncoding = true);
133
135 enum CMD_ARGUMENT_PARSE_RESULT {
136 CMD_ARGUMENT_PARSE_OK = 0,
137 CMD_ARGUMENT_PARSE_UNBALANCED = -1,
138 CMD_ARGUMENT_PARSE_COLLISION = -2,
139 CMD_ARGUMENT_PARSE_INVALIDCHAR = -3,
140 };
141
143 static int parseCommandLineArgumentString(const std::string &command, std::vector<std::string> &components);
144
146 enum compareXMLFiles_flags {
147 CMPXML_NO_FLAG = 0x0000,
148 CMPXML_IGN_DBL_IDENTICAL = 0x0001,
149 CMPXML_IGN_DBL_DIFF_100_PPM = 0x0002,
150 CMPXML_IGN_DBL_DIFF_10_PPM = 0x0004,
151 CMPXML_IGN_DBL_DIFF_1_PPM = 0x0008,
152 CMPXML_IGN_DBL_MASK = (CMPXML_IGN_DBL_IDENTICAL | CMPXML_IGN_DBL_DIFF_100_PPM | CMPXML_IGN_DBL_DIFF_10_PPM | CMPXML_IGN_DBL_DIFF_1_PPM),
153
154 CMPXML_STRIP_TRAILING_ZEROS = 0x0010,
155 CMPXML_IGN_COL_SIZE_EQ_ONE = 0x0020,
156 CMPXML_IGN_TODAY_DATE = 0x0040,
157 CMPXML_IGN_INF_999999 = 0x0080,
158 CMPXML_IGN_FILE_URL = 0x0100,
159 CMPXML_IGN_RAWFILE_NAME = 0x0200,
160
161 // CMPXML_IGN_IF_CWD_INCLUDED = 0x0100, //!< If there's a path name in an attribute and if that contains the current directory, then it's unlikey to match
162 };
163#ifndef SWIG
165 static bool compareXmlFiles(const std::string & filePath1,
166 const std::string & filePath2,
167 const std::string & schemaPath,
168 const int flags,
169 const std::vector<std::string> & ignoreElements,
170 const std::vector<std::string> & ignoreAttributes,
171 ms_errs & errs,
172 std::string & differences,
173 std::string & lhsOnly,
174 std::string & rhsOnly);
175#else // SWIG Multiple return values
176 static bool compareXmlFiles(const std::string & filePath1,
177 const std::string & filePath2,
178 const std::string & schemaPath,
179 const int flags,
180 const std::vector<std::string> & ignoreElements,
181 const std::vector<std::string> & ignoreAttributes,
182 ms_errs & errs,
183 std::string & OUTPUT,
184 std::string & OUTPUT,
185 std::string & OUTPUT);
186#endif
187
188 static std::string getCacheDirectory(const std::string& resFilePath,
189 const std::string& cacheDirPattern,
190 std::string& fileNameNoPath,
191 ms_errs* errorHandler);
192
193 private:
194 unsigned long errorCode_;
195#ifdef _WIN32
196#if defined(_MSC_VER) && (_MSC_VER < 1300)
197 struct _finddata_t fileFindInfo_;
198 int fileFindPtr_;
199#else
200 struct __finddata64_t fileFindInfo_;
201 intptr_t fileFindPtr_;
202#endif
203#else
204 void * fileFindDir_; // void * rather than DIR * so no need to include dirent.h
205#endif
206 std::string fileFindWildcard_;
207 std::string fileFindDirectory_;
208
209 static CMD_ARGUMENT_PARSE_RESULT splitCommandString(const std::string &command, const std::string::size_type j1, const std::string::size_type j2, std::vector<std::string> &argvstr);
210
211 static const std::string ws_delims_;
212 static const char begin_quote_ = '"';
213 static const char end_quote_ = '"';
214 static const std::string invalid_chars_;
215
216 }; // class ms_fileutilities // end of tools_group
218} // namespace matrix_science
219#endif // MS_FILEUTILITIES_HPP
220
221/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_fileutilities
This utility class mainly contains static members.
Definition: ms_fileutilities.hpp:61
matrix_science::ms_fileutilities::compareXMLFiles_flags
compareXMLFiles_flags
Flags for the compareXmlFiles() function.
Definition: ms_fileutilities.hpp:146
matrix_science::ms_fileutilities::CMD_ARGUMENT_PARSE_RESULT
CMD_ARGUMENT_PARSE_RESULT
Return status from parseCommandLineArgumentString().
Definition: ms_fileutilities.hpp:135
matrix_science::ms_fileutilities::err_sar
err_sar
setAccessRights() return value.
Definition: ms_fileutilities.hpp:86
matrix_science::ms_fileutilities::SAR_FAIL_SET_ENTRIES_IN_ACL
@ SAR_FAIL_SET_ENTRIES_IN_ACL
Error returned by call to SetEntriesInAcl().
Definition: ms_fileutilities.hpp:90
matrix_science::ms_fileutilities::SAR_SUCCESS
@ SAR_SUCCESS
Success!
Definition: ms_fileutilities.hpp:87
matrix_science::ms_fileutilities::SAR_FAIL_GET_NAMED_SECURITY_INFO
@ SAR_FAIL_GET_NAMED_SECURITY_INFO
Error returned by call to GetNamedSecurityInfo().
Definition: ms_fileutilities.hpp:89
matrix_science::ms_fileutilities::SAR_FAIL_CHMOD
@ SAR_FAIL_CHMOD
Error returned by call to chmod().
Definition: ms_fileutilities.hpp:88
matrix_science::ms_fileutilities::SAR_FAIL_SET_NAMED_SECURITY_INFO
@ SAR_FAIL_SET_NAMED_SECURITY_INFO
Error returned by call to SetNamedSecurityInfo().
Definition: ms_fileutilities.hpp:91
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fitexy_result.hpp Source File

  • inc
ms_fitexy_result.hpp
1/*
2##############################################################################
3# file: ms_fitexy_result.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_fitexy_result.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_FITEXY_RESULT_HPP
18#define MS_FITEXY_RESULT_HPP
19
20
21namespace matrix_science
22{
23 //=========================================================================
29 class ms_fitexy_result_body;
30
32
38 class MS_MASCOTRESFILE_API ms_fitexy_result :
39 public ms_handle
40 {
41 public:
43 ms_fitexy_result();
44
46 ms_fitexy_result(const ms_fitexy_result_body & body);
47
48#ifndef SWIG
49 ms_fitexy_result_body * body();
50 const ms_fitexy_result_body * body() const;
51
53 ms_fitexy_result(double sigx, double sigy, double a, double siga, double b, double sigb, double chi2, double q);
54#endif
55
57 double getSigmaX() const;
59 double getSigmaY() const;
60
62 double getA() const;
64 double getSigmaA() const;
65
67 double getB() const;
69 double getSigmaB() const;
70
72 double getChi2() const;
73
75 double getQ() const;
76 };
77 // end of quantitation_group
79 //=========================================================================
80
81} // namespace matrix_science
82
83#endif // MS_FITEXY_RESULT_HPP
84
85/*------------------------------- End of File -------------------------------*/
matrix_science::ms_fitexy_result
Parameters and results from least squares fit with errors in both co-ordinates.
Definition: ms_fitexy_result.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fitexy_result_body.hpp Source File

  • src
  • resfile
ms_fitexy_result_body.hpp
1/*
2##############################################################################
3# file: ms_fitexy_result_body.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_FITEXY_RESULT_BODY_HPP
18#define MS_FITEXY_RESULT_BODY_HPP
19
20namespace matrix_science
21{
22 class ms_fitexy_result_body :
23 public ms_body
24 {
25 public:
26 double sigx_;
27 double sigy_;
28 double a_;
29 double siga_;
30 double b_;
31 double sigb_;
32 double chi2_;
33 double q_;
34
35 ms_fitexy_result_body();
36
37 bool loadStream(matrix_science::ms_cache_stream & stream);
38 bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
39
40 bool saveToStream(matrix_science::ms_cache_stream & stream) const;
41 bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element) const;
42 };
43}
44
45#endif // MS_FITEXY_RESULT_BODY_HPP
46
47/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fragment.hpp Source File

  • inc
ms_fragment.hpp
1/*
2##############################################################################
3# File: ms_fragment.hpp #
4# Mascot Parser toolkit #
5# Encapsulates a single fragment ion #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source: parser/inc/ms_fragment.hpp $
12# $Author: villek@matrixscience.com $
13# $Date: 2019-10-25 16:58:28 +0100 $
14# $Revision: 729a9d2d2b60ca4ca4ccf3b95c449b13288dba7d | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
15##############################################################################
16*/
17
18
19#if !defined(ms_fragment_INCLUDED_)
20#define ms_fragment_INCLUDED_
21
22
23// Includes from the standard template library
24#include <string>
25#include <set>
26#include <vector>
27#include <map>
28
29
30namespace matrix_science {
37 class MS_MASCOTRESFILE_API ms_fragment
38 {
39 public:
41
67 enum LABEL_FORMAT {
68 LABEL_FORMAT_TRADITIONAL = 0,
69 LABEL_FORMAT_PEPTIDE_VIEW = 1
70 };
71
73 ms_fragment();
74
76 ms_fragment(const ms_fragment &src);
77
78#ifndef SWIG
80 ms_fragment& operator=(const ms_fragment& right);
81#endif
83 void copyFrom(const ms_fragment* src);
84
86 ms_fragment(const int seriesID,
87 const double massValue,
88 const double nlValue,
89 const int col,
90 const int chargeState = 1,
91 const double matchedExptMass = 0,
92 const double matchedExptIntensity = 0);
93
95 ms_fragment(const ms_peptide::PSM psmComponent,
96 const int seriesID,
97 const double massValue,
98 const double nlValue,
99 const int col,
100 const int chargeState,
101 const double matchedExptMass = 0,
102 const double matchedExptIntensity = 0);
103
105 ms_fragment(const char * seriesName,
106 const double massValue,
107 const double nlValue,
108 const int col,
109 const int chargeState = 1,
110 const double matchedExptMass = 0,
111 const double matchedExptIntensity = 0);
112
114 ms_fragment(const ms_peptide::PSM psmComponent,
115 const char * seriesName,
116 const double massValue,
117 const double nlValue,
118 const int col,
119 const int chargeState,
120 const double matchedExptMass = 0,
121 const double matchedExptIntensity = 0);
122
124 ms_fragment(const int seriesID,
125 const double massValue,
126 const double nlValue,
127 const char * peptideStr,
128 const int startPos,
129 const int endPos,
130 const int chargeState = 1,
131 const double matchedExptMass = 0,
132 const double matchedExptIntensity = 0);
133
135 ms_fragment(const ms_peptide::PSM psmComponent,
136 const int seriesID,
137 const double massValue,
138 const double nlValue,
139 const char * peptideStr,
140 const int startPos,
141 const int endPos,
142 const int chargeState,
143 const double matchedExptMass = 0,
144 const double matchedExptIntensity = 0);
145
147 ms_fragment(const char residueName,
148 const double massValue,
149 const double nlValue,
150 const int col = -1,
151 const int chargeState = 1,
152 const double matchedExptMass = 0,
153 const double matchedExptIntensity = 0);
154
156 ms_fragment(const ms_peptide::PSM psmComponent,
157 const char residueName,
158 const double massValue,
159 const double nlValue,
160 const int col,
161 const int chargeState,
162 const double matchedExptMass = 0,
163 const double matchedExptIntensity = 0);
164
166 ms_fragment(const double massValue,
167 const double nlValue,
168 const int chargeState,
169 const double matchedExptMass = 0,
170 const double matchedExptIntensity = 0);
171
173 bool isFromAlpha() const;
174
176 bool isFromBeta() const;
177
179 bool isRegular() const;
180
182 bool isNTerminal() const;
183
185 bool isCTerminal() const;
186
188 bool isInternal() const;
189
191 bool isImmonium() const;
192
194 bool isPrecursorNL() const;
195
197 double getMass() const;
198
200 double getNeutralLoss() const;
201
203 std::string getLabel(const LABEL_FORMAT fmt = LABEL_FORMAT_TRADITIONAL) const;
204
206 std::string getPeptideSubstring() const;
207
209 std::string getSeriesName() const;
210
212 int getColumn() const;
213
215 int getStart() const;
216
218 int getEnd() const;
219
221 int getCharge() const;
222
224 void clearMatchedIon();
225
227 void setMatchedIon(const double mass, const double intensity);
228
230 double getMatchedIonMass() const;
231
233 double getMatchedIonIntensity() const;
234
236 int getAllMatchedIons(std::vector<double> & masses, std::vector<double> & intensities) const;
237
238 protected:
239 enum ION_TYPE {ION_TYPE_UNKNOWN,
240 ION_TYPE_REGULAR,
241 ION_TYPE_INTERNAL,
242 ION_TYPE_IMMONIUM,
243 ION_TYPE_PRECURSOR_NL};
244 enum ION_TERMINUS {ION_TERM_AMBIGUOUS,
245 ION_TERM_N,
246 ION_TERM_C};
247 ms_peptide::PSM psmComponent_;
248 double mass_;
249 double nl_;
250 std::string labelTraditional_;
251 std::string labelPeptideView_;
252 std::string peptideSubstring_;
253 std::string series_;
254 int start_;
255 int end_;
256 int charge_;
257 ION_TYPE type_;
258 ION_TERMINUS terminus_;
259 bool matchedValueSet_;
260 double matchedExptMass_;
261 double matchedExptIntensity_;
262 std::vector<double> matchedExptMasses_;
263 std::vector<double> matchedExptIntensities_;
264
265 private:
266 void initRegularFragment(const ms_peptide::PSM psmComponent,
267 const int seriesID,
268 const double massValue,
269 const double nlValue,
270 const int col,
271 const int chargeState,
272 const double matchedExptMass,
273 const double matchedExptIntensity);
274
275 void initRegularFragment(const ms_peptide::PSM psmComponent,
276 const char* seriesName,
277 const double massValue,
278 const double nlValue,
279 const int col,
280 const int chargeState,
281 const double matchedExptMass,
282 const double matchedExptIntensity);
283
284 void initInternalFragment(const ms_peptide::PSM psmComponent,
285 const int seriesID,
286 const double massValue,
287 const double nlValue,
288 const char* peptideStr,
289 const int startPos,
290 const int endPos,
291 const int chargeState,
292 const double matchedExptMass,
293 const double matchedExptIntensity);
294
295 void initImmoniumFragment(const ms_peptide::PSM psmComponent,
296 const char residueName,
297 const double massValue,
298 const double nlValue,
299 const int col,
300 const int chargeState,
301 const double matchedExptMass,
302 const double matchedExptIntensity);
303
304 }; //class ms_fragment // end of mass_calculation_group
306} // matrix_science
307
308#endif // !defined(ms_fragment_INCLUDED_)
matrix_science::ms_fragment
Class representing a single peptide fragment.
Definition: ms_fragment.hpp:38
matrix_science::ms_fragment::LABEL_FORMAT
LABEL_FORMAT
Format of fragment labels returned by getLabel().
Definition: ms_fragment.hpp:67
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fragmentationrules.hpp Source File

  • inc
ms_fragmentationrules.hpp
1/*
2##############################################################################
3# file: ms_fragmentationrules.hpp #
4# 'msparser' toolkit #
5# Encapsulates a fragmentation_rules file (mascot configuration files) #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# @(#)$Source: parser/inc/ms_fragmentationrules.hpp $
13# @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
14# @(#)$Date: 2018-07-30 16:23:53 +0100 $
15# @(#)$Author: villek@matrixscience.com $
16##############################################################################
17*/
18
19#ifndef MS_FRAGMENTATIONRULES_HPP
20#define MS_FRAGMENTATIONRULES_HPP
21
22
23// Includes from the standard template library
24#include <vector>
25#include <string>
26
27
28namespace matrix_science {
34 class ms_filesource;
35
37
55 class MS_MASCOTRESFILE_API ms_fragmentationrules : public ms_customproperty
56 {
57 friend class ms_fragrulesfile;
58 public:
59
61
67 enum FRAG_SERIES_TYPE
68 {
69 FRAG_IMMONIUM = 4,
70 FRAG_A_SERIES = 5,
71 FRAG_A_MINUS_NH3 = 6,
72 FRAG_A_MINUS_H2O = 7,
73 FRAG_B_SERIES = 8,
74 FRAG_B_MINUS_NH3 = 9,
75 FRAG_B_MINUS_H2O = 10,
76 FRAG_C_SERIES = 11,
77 FRAG_X_SERIES = 12,
78 FRAG_Y_SERIES = 13,
79 FRAG_Y_MINUS_NH3 = 14,
80 FRAG_Y_MINUS_H2O = 15,
81 FRAG_Z_SERIES = 16,
82 FRAG_INTERNAL_YB = 17,
83 FRAG_INTERNAL_YA = 18,
84 FRAG_Z_PLUS_1 = 21,
85 FRAG_D_SERIES = 22,
86 FRAG_V_SERIES = 23,
87 FRAG_W_SERIES = 24,
88 FRAG_Z_PLUS_2 = 25
89 };
90
92 ms_fragmentationrules();
93
95 ms_fragmentationrules(const ms_fragmentationrules& src);
96
98 ~ms_fragmentationrules();
99
101 void defaultValues();
102
104 void copyFrom(const ms_fragmentationrules* right);
105
106#ifndef SWIG
108 ms_fragmentationrules& operator=(const ms_fragmentationrules& right);
109#endif
111 std::string getTitle() const;
112
114 void setTitle(const char * title);
115
117 static int getFirstSeries();
118
120 static int getFirstSerie();
121
123 static int getLastSeries();
124
126 static int getLastSerie();
127
129 bool isSinglyCharged() const;
130
132 void setSinglyCharged(const bool value);
133
135 bool isCharged2Plus() const;
136
138 void setCharged2Plus(const bool value);
139
141 bool isCharged3Plus() const;
142
144 void setCharged3Plus(const bool value);
145
147 bool isSeriesUsed(const int series) const;
148
150 void clearSeries();
151
153 void setSeriesUsed(const int series, const bool val);
154
156 bool isValid() const;
157
159 bool verifyRule(ms_errs* err_, const bool tryToFix);
160
162 static std::string getSeriesDescription(const int series);
163
165 double getMinInternalMass() const;
166
168 void setMinInternalMass(const double mass);
169
171 double getMaxInternalMass() const;
172
174 void setMaxInternalMass(const double mass);
175
177 static std::string getSeriesName(const int series);
178
180 static bool isBackboneSeries(const int series);
181
183 static bool isNeutralLossSeries(const int series);
184
186 bool anyNLseriesUsed(const int series) const;
187
189 static int getTotalSeriesOutput();
190
191#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
192#include "suppress_ms_customproperty.hpp"
193#endif
194
195 private:
196 std::string title_;
197 bool* which_series_;
198 double minInternalMass_;
199 double maxInternalMass_;
200 }; // class ms_fragmentationrules
201
203
208 class MS_MASCOTRESFILE_API ms_fragrulesfile: public ms_errors
209 {
210 public:
212 ms_fragrulesfile();
213
215 ms_fragrulesfile(const char* filename, const matrix_science::ms_connection_settings * cs = 0);
216
218 ms_fragrulesfile(const ms_fragrulesfile& src);
219
221 ~ms_fragrulesfile();
222
224 void defaultValues();
225
227 void copyFrom(const ms_fragrulesfile* right);
228
229#ifndef SWIG
231 ms_fragrulesfile& operator=(const ms_fragrulesfile& right);
232#endif
234 void setFileName(const char* filename);
235
237 std::string getFileName() const;
238
240 void setConnectionSettings(const matrix_science::ms_connection_settings & cs);
241
243 matrix_science::ms_connection_settings getConnectionSettings() const;
244
246 void read_file();
247
249 void read_buffer(const char * buffer);
250
252 void save_file();
253
255 int getNumberOfInstruments() const;
256
258 void clearInstruments();
259
261 void appendInstrument(const ms_fragmentationrules* item);
262
264 std::string getInstrumentName(const int instrumentNum) const;
265
267 const ms_fragmentationrules* getInstrumentByName(const char * name) const;
268
270 const ms_fragmentationrules* getInstrumentByNumber(const int instrumentNum) const;
271
273 bool updateInstrumentByNumber(const int num, const ms_fragmentationrules item);
274
276 bool updateInstrumentByName(const char* name, const ms_fragmentationrules item);
277
279 bool deleteInstrumentByNumber(const int num);
280
282 bool deleteInstrumentByName(const char* name);
283
284 private:
285 void read_filesource(ms_filesource & fsource);
286
287 std::string filename_;
288 std::vector< ms_fragmentationrules* > rules_;
289 std::vector< std::string > comments_;
290 ms_connection_settings cs_;
291 }; // ms_fragrulesfile // end of config_group
293} // matrix_science namespace
294
295#endif // MS_FRAGMENTATIONRULES_HPP
296
297/*------------------------------- End of File -------------------------------*/
298
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_fragmentationrules
This class encapsulates a single entry (an instrument) from a fragmentation_rules file.
Definition: ms_fragmentationrules.hpp:56
matrix_science::ms_fragmentationrules::FRAG_SERIES_TYPE
FRAG_SERIES_TYPE
Definitions for ID-constants for series used.
Definition: ms_fragmentationrules.hpp:68
matrix_science::ms_fragrulesfile
This class encapsulates a complete fragmentation_rules file.
Definition: ms_fragmentationrules.hpp:209
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_fragmentvector.hpp Source File

  • inc
ms_fragmentvector.hpp
1/*
2##############################################################################
3# File: ms_fragmentvector.hpp #
4# Mascot Parser toolkit #
5# Encapsulates a list (vector) of single fragment ions #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source: parser/inc/ms_fragmentvector.hpp $
12# $Author: villek@matrixscience.com $
13# $Date: 2023-10-31 16:08:54 +0000 $
14# $Revision: 925ec81070097410ba470a308ccae6c56aa345b2 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
15##############################################################################
16*/
17
18#if !defined(ms_fragmentvector_INCLUDED_)
19#define ms_fragmentvector_INCLUDED_
20
21
22// Includes from the standard template library
23#include <string>
24#include <set>
25#include <vector>
26#include <map>
27
28
29namespace matrix_science {
30 class ms_mascotresfilebase;
31
38
46 class MS_MASCOTRESFILE_API ms_fragmentvector
47 {
48 public:
49
51
58 enum MATCH_PEAKS
59 {
60
61 MATCH_MOST_INTENSE_PEAK = 0x0000,
62 MATCH_CLOSEST_PEAK = 0x0001
63 };
64
66
72 enum TOLERANCE_UNIT
73 {
74 TOLERANCE_DALTON,
75 TOLERANCE_MMU,
76 TOLERANCE_PERCENT,
77 TOLERANCE_PPM
78 };
79
81 ms_fragmentvector();
82
84 ms_fragmentvector(const ms_fragmentvector& src);
85
87 virtual ~ms_fragmentvector();
88
90 void copyFrom(const ms_fragmentvector* right);
91
92#ifndef SWIG
94 ms_fragmentvector& operator=(const ms_fragmentvector& right);
95#endif
97 int getNumberOfFragments() const;
98
100 void clearFragments();
101
103 void appendFragment(const ms_fragment * item);
104
106 const ms_fragment * getFragmentByNumber(const unsigned int numFrag) const;
107
108 typedef std::vector<ms_fragment> frag_vector;
109
110#if !defined(SWIGJAVA) && !defined(SWIGCSHARP)
112 frag_vector * getVector();
113#endif
115 const frag_vector * getVector() const;
116
118 bool addExperimentalData(const std::string & peakList,
119 const int numPeaks,
120 const double tolerance,
121 const std::string & toleranceUnits,
122 const bool updateMatchList = true);
123
125 bool addExperimentalData(const ms_mascotresfilebase * resfile,
126 const int query,
127 const int flags = MATCH_MOST_INTENSE_PEAK,
128 const int peaksUsedFromIons1 = -1,
129 const int peaksUsedFromIons2 = -1,
130 const int peaksUsedFromIons3 = -1);
131
132 typedef std::map<double, double> peaklist_t; // Mass, intensity
133
135 bool addExperimentalData(const peaklist_t & peakList,
136 const double tolerance,
137 const std::string & toleranceUnits,
138 const bool updateMatchList = true);
139
141#ifndef SWIG
142 static void getMassesWithinTolerance(const double mass,
143 const double toleranceValue,
144 const TOLERANCE_UNIT toleranceUnit,
145 double & minMass,
146 double & maxMass);
147#else // SWIG Multiple return values
148 static void getMassesWithinTolerance(const double mass,
149 const double toleranceValue,
150 const TOLERANCE_UNIT toleranceUnit,
151 double & OUTPUT,
152 double & OUTPUT);
153#endif
154
155 private:
156 frag_vector entries_;
157 peaklist_t experimentalData_;
158 void matchFragments();
159 double matchingTol_;
160 std::string matchingTolUnits_;
161 }; // class ms_fragmentvector // end of mass_calculation_group
163} // matrix_science
164
165#endif // !defined(ms_fragmentvector_INCLUDED_)
matrix_science::ms_fragment
Class representing a single peptide fragment.
Definition: ms_fragment.hpp:38
matrix_science::ms_fragmentvector
Class for holding a list of ms_fragment objects.
Definition: ms_fragmentvector.hpp:47
matrix_science::ms_fragmentvector::MATCH_PEAKS
MATCH_PEAKS
Flags for matching experimental peaks to calculated peaks.
Definition: ms_fragmentvector.hpp:59
matrix_science::ms_fragmentvector::TOLERANCE_UNIT
TOLERANCE_UNIT
Flags for tolerance units used for matching peaks.
Definition: ms_fragmentvector.hpp:73
matrix_science::ms_fragmentvector::TOLERANCE_PERCENT
@ TOLERANCE_PERCENT
Percentage of the fragment or peptide mass.
Definition: ms_fragmentvector.hpp:76
matrix_science::ms_fragmentvector::TOLERANCE_DALTON
@ TOLERANCE_DALTON
Simple Daltons.
Definition: ms_fragmentvector.hpp:74
matrix_science::ms_fragmentvector::TOLERANCE_MMU
@ TOLERANCE_MMU
milli mass units (1000th of a Dalton)
Definition: ms_fragmentvector.hpp:75
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_client.hpp Source File

  • inc
ms_http_client.hpp
1/*
2##############################################################################
3# file: ms_http_client.hpp #
4# 'msparser' toolkit #
5# Represents a Mascot server, providing communication to that server #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_http_client.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_HTTP_CLIENT_HPP
18#define MS_HTTP_CLIENT_HPP
19
20
21#include <string>
22
23namespace matrix_science
24{
30 class ms_http_client_session;
31
33
46 class MS_MASCOTRESFILE_API ms_http_client :
47 public ms_errors
48 {
49 public:
51
54 enum LoginResultCode
55 {
56 L_SUCCESS,
57 L_SECURITYDISABLED,
58 L_UNKNOWNUSER,
59 L_INCORRECTPASSWORD,
60 L_PASSWORDEXPIRED,
61 L_WEBAUTHENTICATIONFAILED,
62 L_GUESTLOGINDISABLED,
63 L_UNSPECIFIEDERROR
64 };
65
67
70 enum ChangePasswordResultCode
71 {
72 CP_SUCCESS,
73 CP_UNKNOWNUSER,
74 CP_INCORRECTPASSWORD,
75 CP_BADNEWPASSWORD,
76 CP_UNSPECIFIEDERROR
77 };
78
79#ifndef SWIG
80 // C++ STL collection support
81 ms_http_client();
82#endif
84 ms_http_client(const std::string & baseUrl, ms_connection_settings settings);
86 virtual ~ms_http_client();
87
88 ms_http_client(const ms_http_client & src);
89#ifndef SWIG
90 ms_http_client& operator=(const ms_http_client & right);
91#endif
92 void copyFrom(const ms_http_client * right);
93
95 std::string baseUrl() const;
97 ms_connection_settings connectionSettings() const;
98
100 void setBaseUrl(const std::string & baseUrl);
102 void setConnectionSettings(const ms_connection_settings & settings);
103#ifndef SWIG
105 bool getIsDatabaseActive(const std::string & databaseName, bool & returnIsActive);
106
108 bool getVersion(int & major, int & minor, int & part3, int & part4);
109
111 bool getOsName(std::string & osname);
112
113#else // SWIG Multiple return values
114 bool getIsDatabaseActive(const std::string & databaseName, bool & OUTPUT);
115 bool getVersion(int & OUTPUT, int & OUTPUT, int & OUTPUT, int & OUTPUT);
116 bool getOsName(std::string & OUTPUT);
117#endif
119 LoginResultCode userLogin(
120 const std::string & username,
121 const std::string & password,
122 ms_http_client_session & returnSession);
123
125 ChangePasswordResultCode changePassword(
126 const std::string & userName,
127 const std::string & oldPassword,
128 const std::string & newPassword);
129#ifndef SWIG
131 bool getIsSecurityEnabled(bool & returnIsSecurityEnabled, std::string & returnUnsecuredSessionId);
132
134 bool getIsWebAuthenticationEnabled(bool & returnIsWebAuthenticationEnabled, std::string & returnWebAuthenticatedSessionId);
135#else // SWIG Multiple return values
136 bool getIsSecurityEnabled(bool & OUTPUT, std::string & OUTPUT);
137 bool getIsWebAuthenticationEnabled(bool & OUTPUT, std::string & OUTPUT);
138#endif
139
140 private:
141 LoginResultCode secureGuestLogin(
142 ms_http_client_session & session);
143 LoginResultCode secureUserLogin(
144 const std::string & username,
145 const std::string & password,
146 ms_http_client_session & returnSession);
147 bool httpGetString(const std::string & action, std::string & returnString);
148
149 ms_http_helper connection_;
150 };
151 // end of http_client_group
153} // namespace matrix_science
154
155#endif // MS_HTTP_CLIENT_HPP
156
157/*------------------------------- End of File -------------------------------*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_http_client_session
This gives access to a Mascot session so searches may be submitted.
Definition: ms_http_client_session.hpp:48
matrix_science::ms_http_client
This class enables access to a Mascot server using HTTP.
Definition: ms_http_client.hpp:48
matrix_science::ms_http_client::LoginResultCode
LoginResultCode
Definitions for the types of response from the login program on the Mascot server.
Definition: ms_http_client.hpp:55
matrix_science::ms_http_client::L_PASSWORDEXPIRED
@ L_PASSWORDEXPIRED
The password supplied for the specified user has expired.
Definition: ms_http_client.hpp:60
matrix_science::ms_http_client::L_INCORRECTPASSWORD
@ L_INCORRECTPASSWORD
The password supplied for the specified user was incorrect.
Definition: ms_http_client.hpp:59
matrix_science::ms_http_client::L_WEBAUTHENTICATIONFAILED
@ L_WEBAUTHENTICATIONFAILED
Web authentication failed for the currently logged in user.
Definition: ms_http_client.hpp:61
matrix_science::ms_http_client::L_GUESTLOGINDISABLED
@ L_GUESTLOGINDISABLED
The guest login could not be accessed because it is disabled on the server.
Definition: ms_http_client.hpp:62
matrix_science::ms_http_client::L_SECURITYDISABLED
@ L_SECURITYDISABLED
Security is disabled on the Mascot server.
Definition: ms_http_client.hpp:57
matrix_science::ms_http_client::L_SUCCESS
@ L_SUCCESS
The function completed successfully.
Definition: ms_http_client.hpp:56
matrix_science::ms_http_client::L_UNKNOWNUSER
@ L_UNKNOWNUSER
The user ID supplied was not recognised by the Mascot server.
Definition: ms_http_client.hpp:58
matrix_science::ms_http_client::ChangePasswordResultCode
ChangePasswordResultCode
Definitions for the possible responses to an attempt to change a password.
Definition: ms_http_client.hpp:71
matrix_science::ms_http_client::CP_UNKNOWNUSER
@ CP_UNKNOWNUSER
The user ID was not recognised. No password was changed.
Definition: ms_http_client.hpp:73
matrix_science::ms_http_client::CP_BADNEWPASSWORD
@ CP_BADNEWPASSWORD
The new password could not be used (e.g. too short). No password was changed.
Definition: ms_http_client.hpp:75
matrix_science::ms_http_client::CP_SUCCESS
@ CP_SUCCESS
The password was changed successfully.
Definition: ms_http_client.hpp:72
matrix_science::ms_http_client::CP_INCORRECTPASSWORD
@ CP_INCORRECTPASSWORD
The old password supplied was incorrect. No password was changed.
Definition: ms_http_client.hpp:74
matrix_science::ms_http_helper
The class provides HTTP, FTP and FILE protocol access to a server.
Definition: ms_http_helper.hpp:57
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_client_mime.hpp Source File

  • inc
ms_http_client_mime.hpp
1/*
2##############################################################################
3# file: ms_http_client_mime.hpp #
4# 'msparser' toolkit #
5# Builds a MIME string from the boundary separator and the element values #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_http_client_mime.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_HTTP_CLIENT_MIME_HPP
18#define MS_HTTP_CLIENT_MIME_HPP
19
20
21#include <string>
22#include <vector>
23
24namespace matrix_science
25{
31 // for internal use
32 class MS_MASCOTRESFILE_API ms_http_client_mime_item
33 {
34 public:
35 ms_http_client_mime_item();
36 ms_http_client_mime_item(const std::string & name, const std::string & value);
37 ms_http_client_mime_item(const std::string & name, const std::string & value, const std::string & filename, const std::string & contentType);
38
39 std::string name() const;
40 std::string value() const;
41 bool hasFilename() const;
42 std::string filename() const;
43 std::string contentType() const;
44
45 void setName(const std::string & name);
46 void setValue(const std::string & value);
47 void setValueWithFilename(const std::string & value, const std::string & filename, const std::string & contentType);
48
49 private:
50 std::string name_;
51 std::string value_;
52 bool hasFilename_;
53 std::string filename_;
54 std::string contentType_;
55 };
56
58
66 class MS_MASCOTRESFILE_API ms_http_client_mime
67 {
68 public:
69 enum ContentType {
70 CT_MIXED,
71 CT_FORMDATA
72 };
73
74 enum Continuation {
75 CONTENT_CONTINUES,
76 CONTENT_TERMINATES
77 };
78
80 static std::string formatHeader(
81 const std::string & boundary,
82 ContentType contentType);
83
85 virtual ~ms_http_client_mime();
86
88 void append(const std::string & name, const std::string & value);
89
91 void appendFile(const std::string & name, const std::string & filename, const std::string & contentType, const std::string & prefixData = "");
92
93
95 int getCount() const;
96 int count() const { return getCount(); } // Deprecated. Released with 2.5.2
97
98 // index 1..count inclusive (not zero based!)
100 std::string getName(int oneBasedIndex) const;
101 std::string name(int oneBasedIndex) const { return getName(oneBasedIndex); } // Deprecated. Released with 2.5.2
102
104 std::string getValue(int oneBasedIndex) const;
105 std::string value(int oneBasedIndex) const { return getValue(oneBasedIndex); } // Deprecated. Released with 2.5.2
106
108 bool hasFilename(int oneBasedIndex) const;
109
111 std::string getFilename(int oneBasedIndex) const;
112 std::string filename(int oneBasedIndex) const { return getFilename(oneBasedIndex); } // Deprecated. Released with 2.5.2
113
114 // index 1..count inclusive (not zero based!)
116 void setValue(int oneBasedIndex, const std::string & value);
117
119 void setValueWithFilename(int oneBasedIndex, const std::string & value, const std::string & filename, const std::string & contentType);
120
121 // index 1..count inclusive (not zero based!)
123 void erase(int oneBasedIndex);
124
126 std::string format(
127 const std::string & boundary,
128 matrix_science::ms_http_client_mime::Continuation continuation) const;
129
130 private:
131 std::vector<ms_http_client_mime_item> items_;
132 };
133 // end of http_client_group
135
136} // namespace matrix_science
137
138#endif // MS_HTTP_CLIENT_MIME_HPP
139
140/*------------------------------- End of File -------------------------------*/
matrix_science::ms_http_client_mime
The class eases the building of a MIME section.
Definition: ms_http_client_mime.hpp:67
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_client_search.hpp Source File

  • inc
ms_http_client_search.hpp
1/*
2##############################################################################
3# file: ms_http_client_search.hpp #
4# 'msparser' toolkit #
5# Represents a task on a Mascot server and can be used to sumbit and track #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_http_client_search.hpp $
12 * @(#)$Revision: 9f0c123764e41b5a92a31ec7e127cc7e3aa6ce82 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2024-02-01 09:58:21 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_HTTP_CLIENT_SEARCH_HPP
18#define MS_HTTP_CLIENT_SEARCH_HPP
19
20
21#include <string>
22
23namespace matrix_science
24{
30 class ms_http_helper;
31 class ms_http_client_session;
32
34
42 class MS_MASCOTRESFILE_API ms_http_client_search :
43 public ms_errors
44 {
45 public:
46
48
51 enum SearchStatusCode
52 {
53 SS_UNKNOWN,
54 SS_ASSIGNED,
55 SS_QUEUED,
56 SS_RUNNING,
57 SS_COMPLETE,
58 SS_ERROR,
59 SS_SEARCH_CONTROL_ERROR
60 };
61
63
66 enum UploadResponseCode
67 {
68 UR_SUCCESS,
69 UR_ACCESS_DENIED,
70 UR_INVALID_TASKID,
71 UR_NO_RESULT_FILENAME,
72 UR_NO_RESULT_FILE,
73 UR_FILE_ALREADY_EXISTS,
74 UR_ERROR
75 };
76
78
81 enum DownloadOption
82 {
83 DO_NORMAL = 0,
84 DO_WITH_IONS = 1
85 };
86
88
92 enum ReportTopSpecialValues
93 {
94 RT_auto = 0,
95 RT_file = -1
96 };
97
98#ifndef SWIG
99 // C++ STL collection support
100 ms_http_client_search();
101#endif
103 ms_http_client_search(ms_http_client_session & session, const std::string & searchTaskId);
104
106 virtual ~ms_http_client_search();
107
108 ms_http_client_search(const ms_http_client_search & src);
109#ifndef SWIG
110 ms_http_client_search& operator=(const ms_http_client_search & right);
111#endif
112 void copyFrom(const ms_http_client_search * right);
113
115
118 std::string sessionId() const { return getSessionID(); }
119
121 std::string getSessionID() const;
122
124 std::string getSearchTaskID() const;
125
127
132 std::string searchTaskId() const { return getSearchTaskID(); }
133
135 bool getStatus(SearchStatusCode & returnCode, int & statusValue);
136
137#ifndef SWIG
138 // Undocumented for Perl compatibility. Unable to return an enum
139 bool getStatus(int & returnCodeAsInt, int & statusValue);
140
142 bool getResultsFileName(std::string & returnFileName);
143
145 bool getStage(std::string & stage, int & step);
146#else // SWIG Multiple return values
147 bool getStatus(int & OUTPUT, int & OUTPUT);
148 bool getResultsFileName(std::string & OUTPUT);
149 bool getStage(std::string & OUTPUT, int & OUTPUT);
150#endif
151
153
159 bool getResultsFilename(std::string & returnFilename) { return getResultsFileName(returnFilename); }
160
162 bool downloadResultsFile(std::string filename, ms_http_helper_progress & progress, DownloadOption options = DO_WITH_IONS);
163
165 bool downloadResultsFileMSR(std::string filename, ms_http_helper_progress & progress, DownloadOption options = DO_WITH_IONS);
166
168 bool downloadDaemonResultsFile(std::string filename, ms_http_helper_progress & progress);
169
171 bool downloadPercolatorFile(std::string filename, ms_http_helper_progress & progress);
172
174 bool downloadXmlResultsFile(std::string filename, ms_http_helper_progress & progress, int reportTop = RT_auto);
175#ifndef SWIG
177 bool uploadDistillerXmlResultsFile(std::string filename, UploadResponseCode & responseCode, std::string & responseText);
178#else // SWIG Multiple return values
179 bool uploadDistillerXmlResultsFile(std::string filename, UploadResponseCode & OUTPUT, std::string & OUTPUT);
180#endif
181 private:
182 // Constructor for a newly submitted search
183 ms_http_client_search(ms_http_client_session & session, std::string searchTaskId, const std::string & actionString);
184
185 ms_http_client_session * session_;
186 std::string searchTaskId_;
187 std::string actionString_;
188 ms_http_helper_handles postRequestHandles_;
189
190 friend class ms_http_client_session; // access to constructor and private member variables when starting a search
191 };
192 // end of http_client_group
194} // namespace matrix_science
195
196#endif // MS_HTTP_CLIENT_SEARCH_HPP
197
198/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_http_client_search
Used for submitting searches to a Mascot server and retrieving search results using HTTP(S).
Definition: ms_http_client_search.hpp:44
matrix_science::ms_http_client_search::ReportTopSpecialValues
ReportTopSpecialValues
Definitions for special 'report top' values when requesting results in XML format.
Definition: ms_http_client_search.hpp:93
matrix_science::ms_http_client_search::UploadResponseCode
UploadResponseCode
Definitions for the various responses possible when uploading data to Mascot.
Definition: ms_http_client_search.hpp:67
matrix_science::ms_http_client_search::UR_SUCCESS
@ UR_SUCCESS
The upload completed successfully.
Definition: ms_http_client_search.hpp:68
matrix_science::ms_http_client_search::UR_FILE_ALREADY_EXISTS
@ UR_FILE_ALREADY_EXISTS
The upload failed because the file already exists.
Definition: ms_http_client_search.hpp:73
matrix_science::ms_http_client_search::UR_INVALID_TASKID
@ UR_INVALID_TASKID
The upload failed due to not having a task identifier.
Definition: ms_http_client_search.hpp:70
matrix_science::ms_http_client_search::UR_NO_RESULT_FILE
@ UR_NO_RESULT_FILE
The upload failed due to the result file not existing.
Definition: ms_http_client_search.hpp:72
matrix_science::ms_http_client_search::UR_NO_RESULT_FILENAME
@ UR_NO_RESULT_FILENAME
The upload failed due to not having a result file name.
Definition: ms_http_client_search.hpp:71
matrix_science::ms_http_client_search::UR_ACCESS_DENIED
@ UR_ACCESS_DENIED
The upload was not permitted by Mascot Security.
Definition: ms_http_client_search.hpp:69
matrix_science::ms_http_client_search::sessionId
std::string sessionId() const
Get the associated session ID.
Definition: ms_http_client_search.hpp:118
matrix_science::ms_http_client_search::SearchStatusCode
SearchStatusCode
Definitions for the various states possible when querying about a running Mascot search.
Definition: ms_http_client_search.hpp:52
matrix_science::ms_http_client_search::SS_QUEUED
@ SS_QUEUED
The search has been submitted, but it has been queued by the server.
Definition: ms_http_client_search.hpp:55
matrix_science::ms_http_client_search::SS_UNKNOWN
@ SS_UNKNOWN
The search task ID was not recognised as a recent Mascot task.
Definition: ms_http_client_search.hpp:53
matrix_science::ms_http_client_search::SS_COMPLETE
@ SS_COMPLETE
The search has completed.
Definition: ms_http_client_search.hpp:57
matrix_science::ms_http_client_search::SS_ERROR
@ SS_ERROR
An error occurred when running the search. The Mascot error number is available from the getStatus ca...
Definition: ms_http_client_search.hpp:58
matrix_science::ms_http_client_search::SS_ASSIGNED
@ SS_ASSIGNED
The search task has been assigned but no search has been submitted.
Definition: ms_http_client_search.hpp:54
matrix_science::ms_http_client_search::SS_RUNNING
@ SS_RUNNING
The search has started. The approximate percentage that has been completed is available.
Definition: ms_http_client_search.hpp:56
matrix_science::ms_http_client_search::DownloadOption
DownloadOption
Definitions for downloading results.
Definition: ms_http_client_search.hpp:82
matrix_science::ms_http_client_session
This gives access to a Mascot session so searches may be submitted.
Definition: ms_http_client_session.hpp:48
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_client_session.hpp Source File

  • inc
ms_http_client_session.hpp
1/*
2##############################################################################
3# file: ms_http_client_session.hpp #
4# 'msparser' toolkit #
5# Represents a session on a Mascot server #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_http_client_session.hpp $
12 * @(#)$Revision: ad538b116c843eb04f4e6cb8ff8f73b915de025f | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2020-02-14 10:16:25 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_HTTP_CLIENT_SESSION_HPP
18#define MS_HTTP_CLIENT_SESSION_HPP
19
20
21#include <string>
22#include <vector>
23
24namespace matrix_science
25{
31 class ms_http_client;
32 class ms_http_client_search;
33
35
46 class MS_MASCOTRESFILE_API ms_http_client_session :
47 public ms_errors
48 {
49 public:
51
57 enum SequenceShowOptions
58 {
59 SHOW_PI = 0x0001,
60 SHOW_TITLE = 0x0002,
61 SHOW_LENGTH = 0x0004,
62 SHOW_SEQUENCE = 0x0008,
63 SHOW_REFERENCE = 0x0010,
64
65 SHOW_NONE = 0,
66 SHOW_ALL = 0xFFFF
67 };
68
69
71 ms_http_client_session();
72
74 ms_http_client_session(const ms_http_helper connection, const std::string sessionId);
75
77 virtual ~ms_http_client_session();
78
79 ms_http_client_session(const ms_http_client_session & src);
80#ifndef SWIG
81 ms_http_client_session& operator=(const ms_http_client_session & right);
82#endif
83 void copyFrom(const ms_http_client_session * right);
84
86 std::string getSessionID() const;
87 std::string sessionId() const { return getSessionID(); } // Deprecated. Released with 2.5.2
88#ifndef SWIG
90 bool getIsPermitted(ms_security_tasks::TASKID taskType, bool & returnIsPermitted);
91#else // SWIG Multiple return values
92 bool getIsPermitted(ms_security_tasks::TASKID taskType, bool & OUTPUT);
93#endif
94
95#ifndef SWIGCSHARP
97 bool submitSearch(
98 ms_http_client_search & returnTask,
99 const std::string & httpHeader,
100 const std::string & prologue,
101 const std::string & filename,
102 const std::string & epilogue,
103 ms_http_helper_progress & progress,
104 bool batch = false);
105#else
106 bool submitSearch(
107 ms_http_client_search & returnTask,
108 const std::wstring & httpHeader,
109 const std::wstring & prologue,
110 const std::wstring & filename,
111 const std::wstring & epilogue,
112 ms_http_helper_progress & progress,
113 bool batch = false) {
114 return submitSearchWide(returnTask, httpHeader, prologue, filename, epilogue, progress, batch);
115 };
116#endif
117
119 bool getSequenceFile(
120 const std::string & database,
121 const std::vector<std::string> & accessionNames,
122 const std::vector<int> & accessionFrames,
123 const std::string & filename,
124 const SequenceShowOptions options = SHOW_ALL
125 );
126
128 bool logout();
129
131 bool getIsXmlUploadedList(const std::vector<std::string> & taskIds, std::vector<int> & xmlUploaded);
132
133 private:
134
135 // type of login for the session to allow re-login if session has expired
136 enum SessionSecurityType {
137 SECURITY_NONE,
138 SECURITY_DISABLED,
139 SECURITY_GUEST,
140 SECURITY_WEB,
141 SECURITY_USER
142 };
143
144 ms_http_client_session(
145 ms_http_helper connection,
146 std::string sessionId,
147 SessionSecurityType security,
148 const std::string & username = "",
149 const std::string & password = "");
150
151 // Create a new Mascot task attached to this Mascot session.
152 bool createTask(
153 ms_http_client_search & returnTask);
154
155 // http functions to be used by the task class to re-try is Mascot session has expired
156 bool httpGetString(const std::string & action, std::string & result);
157 bool httpGetResponseUsingSessionId(const std::string & action, ms_http_helper_response & response);
158 bool httpGetFileUsingSessionId(
159 const std::string & action,
160 const std::string & filename,
161 ms_http_helper_progress & progress,
162 ms_http_helper::FileMode fileMode = ms_http_helper::FM_binary);
163 bool httpPostFileAppendingSessionId(
164 const std::string & action,
165 const std::string & httpHeader,
166 const std::string & prologue,
167 const std::string & filename,
168 const std::string & epilogue,
169 ms_http_helper_handles & handles,
170 ms_http_helper_progress & progress);
171 bool relogin();
172
173 bool submitSearchWide(
174 ms_http_client_search & returnTask,
175 const std::wstring & httpHeader,
176 const std::wstring & prologue,
177 const std::wstring & filename,
178 const std::wstring & epilogue,
179 ms_http_helper_progress & progress,
180 bool batch = false
181 );
182
183 ms_http_helper connection_;
184 std::string sessionId_;
185
186 SessionSecurityType security_;
187 std::string username_;
188 std::string password_;
189
190 bool isLoggedIn_;
191
192 friend class ms_http_client; // access to private constructor used when logging in
193 friend class ms_http_client_search; // access to useful getString and getFile functions
194 };
195 // end of http_client_group
197} // namespace matrix_science
198
199#endif // MS_HTTP_CLIENT_SESSION_HPP
200
201/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_http_client_session
This gives access to a Mascot session so searches may be submitted.
Definition: ms_http_client_session.hpp:48
matrix_science::ms_http_client_session::SequenceShowOptions
SequenceShowOptions
Information to include in a request for sequence data.
Definition: ms_http_client_session.hpp:58
matrix_science::ms_http_helper
The class provides HTTP, FTP and FILE protocol access to a server.
Definition: ms_http_helper.hpp:57
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper.hpp Source File

  • inc
ms_http_helper.hpp
1/*
2##############################################################################
3# file: ms_http_helper.hpp #
4# 'msparser' toolkit #
5# Provides functions for an HTTP link (eg to a Mascot server) #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_http_helper.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#if !defined(MS_HTTP_HELPER_HPP_)
18#define MS_HTTP_HELPER_HPP_
19
20#ifdef _WIN32
21#ifdef __MINGW__
22// No ATL or MFC support -- use curl
23#else
24#define USE_ATL
25#endif
26#endif
27
28#include <string>
29
30class LocalHelper;
31
32namespace matrix_science
33{
39 class ms_connection_settings;
40 class ms_http_helper_handles;
41 class ms_http_helper_progress;
42 class ms_http_helper_proxy_list;
43
45
55 class MS_MASCOTRESFILE_API ms_http_helper :
56 public ms_errors
57 {
58 public:
60
63 enum FileMode
64 {
65 FM_binary,
66 FM_text
67 };
68
69#ifdef USE_ATL
71 static void yieldToCom();
72#endif
73
75 bool getProxyConfig(std::vector<std::string> &proxyServers, std::vector<std::string> &proxyUsernames, std::vector<std::string> &proxyPasswords);
76
77#ifndef SWIG
79 ms_http_helper();
80
82 ms_http_helper(const ms_http_helper & copy);
83
85 const ms_http_helper & operator =(const ms_http_helper & copy);
86#endif
87 void copyFrom(const ms_http_helper * right);
88
90 ms_http_helper(
91 const std::string & baseUrl,
92 const ms_connection_settings & settings);
93
95 ~ms_http_helper();
96
98 const std::string & baseUrl() const;
99
101 const ms_connection_settings & connectionSettings() const;
102#ifndef SWIG
104 ms_http_helper_return httpGetString(const std::string & action, std::string & httpGETString);
105#else // SWIG Multiple return values
106 ms_http_helper_return httpGetString(const std::string & action, std::string & OUTPUT);
107#endif
109 ms_http_helper_return httpPostFile(
110 const std::string & action,
111 const std::string & httpHeader,
112 const std::string & prologue,
113 const std::string & filename,
114 const std::string & epilogue,
115 ms_http_helper_handles & handles,
116 ms_http_helper_progress & progress);
117
119 ms_http_helper_return httpGetFile(
120 const std::string & action,
121 const std::string & filename,
122 ms_http_helper_progress & progress,
123 FileMode fileMode = FM_binary);
124
126 ms_http_helper_return httpBufferedOpen(const std::string & action);
127#ifndef SWIG
129 ms_http_helper_return httpBufferedGetString(std::string & httpBuffer, unsigned long requiredSize );
130
132 ms_http_helper_return httpGetHeader(const std::string & action, std::string & httpHeaderInfo);
133#else // SWIG Multiple return values
134 ms_http_helper_return httpBufferedGetString(std::string & OUTPUT, unsigned long requiredSize);
135 ms_http_helper_return httpGetHeader(const std::string & action, std::string & OUTPUT);
136#endif
138 ms_http_helper_return httpBufferedClose();
139
140
142 static std::string getHeaderValue(const std::string &name, const std::string & header);
143
144 private:
145
146#ifndef USE_ATL
147 bool analyseCurlResult(void * pVoidCurl, ms_http_helper_return & returnCode, std::string & performError, char * errorBuffer = NULL, std::vector< std::pair<int, std::string> > * pProxyErrors = NULL);
148 void * performCurlAndCheckHttpsCertificate(void * pVoidCurl, std::string & certificateError, std::string & systemCertPath, std::string & userCertPath, bool bCheckCertificate = true);
149#endif // USE_ATL
150
151 const std::string completeUrl(const std::string & action) const;
152
153 ms_http_helper_return httpGetLocal(
154 const std::string & action,
155 std::string & strResult,
156 const std::string & filename,
157 FileMode fileMode,
158 ms_http_helper_progress & progress);
159
160 ms_http_helper_return httpOpenLocal(const std::string & action, bool bHeaderOnly = false);
161
162 ms_http_helper_return httpGetNextLocal(
163 std::string & buffer,
164 unsigned long requiredSize );
165
166 ms_http_helper_return curlOpenLocal(const std::string & action);
167
168 ms_http_helper_return curlGetNextLocal(
169 std::string & buffer,
170 unsigned long requiredSize);
171
172 ms_http_helper_return closeLocal();
173
174 bool determineProxy();
175
176 std::string baseUrl_;
177 ms_connection_settings connectionSettings_;
178
179 // autoproxy detect cache
180 ms_http_helper_proxy_list * proxyList_;
181
182 LocalHelper * localHelper_;
183
184 };
185 // end of http_client_group
187} // namespace matrix_science
188
189#endif // MS_HTTP_HELPER_HPP_
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_http_helper_handles
The class holds HTTP to allow a POST request to be kept alive and retrieve any output received from t...
Definition: ms_http_helper_handles.hpp:47
matrix_science::ms_http_helper_progress
This holds information on the progress of a running HTTP transfer.
Definition: ms_http_helper_progress.hpp:46
matrix_science::ms_http_helper_return
Indicates any problem that may have occurred during a request to an ms_http_helper object.
Definition: ms_http_helper_return.hpp:37
matrix_science::ms_http_helper
The class provides HTTP, FTP and FILE protocol access to a server.
Definition: ms_http_helper.hpp:57
matrix_science::ms_http_helper::FileMode
FileMode
Definitions for types of file content transfer.
Definition: ms_http_helper.hpp:64
matrix_science::ms_http_helper::FM_binary
@ FM_binary
Binary - the data is saved in exactly the form as it is received.
Definition: ms_http_helper.hpp:65
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper_handles.hpp Source File

  • inc
ms_http_helper_handles.hpp
1/*
2##############################################################################
3# file: ms_http_helper_handles.hpp #
4# 'msparser' toolkit #
5# Hold the handles for an internet file post function. #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_http_helper_handles.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_HTTP_HELPER_HANDLES_HPP
18#define MS_HTTP_HELPER_HANDLES_HPP
19
20
21#include <string>
22
23namespace matrix_science
24{
25 class ms_http_helper_handles_body;
26
33
45 class MS_MASCOTRESFILE_API ms_http_helper_handles :
46 public ms_errors
47 {
48 public:
50 ms_http_helper_handles();
51 ms_http_helper_handles(const ms_http_helper_handles &);
52#ifndef SWIG
53 const ms_http_helper_handles & operator=(const ms_http_helper_handles &);
54 ms_http_helper_handles(const ms_http_helper_handles_body & impl);
55#endif
56
58 virtual ~ms_http_helper_handles();
59#ifndef SWIG
61 bool getRequestData(bool & isStillActive, std::string & requestDataRef);
62#else // SWIG Multiple return values
63 bool getRequestData(bool & OUTPUT, std::string & OUTPUT);
64#endif
65
66 void setRequestData(const std::string & strResult);
67
69 bool closeHandles();
70
71 private:
72 void copyFrom(const ms_http_helper_handles & copy);
73 void release();
74
75 ms_http_helper_handles_body * pimpl_;
76 std::string strResult_;
77 };
78 // end of http_client_group
80} // namespace matrix_science
81
82#endif // MS_HTTP_HELPER_HANDLES_HPP
83
84/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_http_helper_handles
The class holds HTTP to allow a POST request to be kept alive and retrieve any output received from t...
Definition: ms_http_helper_handles.hpp:47
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper_handles_body.hpp Source File

  • src
  • http
ms_http_helper_handles_body.hpp
1/*
2##############################################################################
3# file: ms_http_helper_handles_body.hpp
4# 'msparser' toolkit
5# Hold the handles for an internet file post function.
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef _HTTP_HELPER_HANDLES_BODY_HPP
18#define _HTTP_HELPER_HANDLES_BODY_HPP
19
20#include <string>
21
22#ifdef _WIN32
23#define WIN32_LEAN_AND_MEAN // Exclude rarely-used stuff from Windows headers
24#include <windows.h>
25#include <winhttp.h>
26#endif
27
28namespace matrix_science
29{
30 class ms_http_helper_handles_body
31 {
32 public:
33 volatile long refCount;
34 #ifdef _WIN32
35 HINTERNET hSession;
36 HINTERNET hConnection;
37 HINTERNET hRequest;
38
39 ms_http_helper_handles_body()
40 {
41 refCount = 1;
42 hSession = NULL;
43 hConnection = NULL;
44 hRequest = NULL;
45 }
46
47 ms_http_helper_handles_body(
48 HINTERNET hSess,
49 HINTERNET hConn,
50 HINTERNET hRequ)
51 {
52 refCount = 1;
53 hSession = hSess;
54 hConnection = hConn;
55 hRequest = hRequ;
56 }
57 #endif
58 void addRef()
59 {
60 #ifdef _WIN32
61 InterlockedIncrement(&refCount);
62 #endif
63 }
64
65 long release()
66 {
67 long r = 0;
68 #ifdef _WIN32
69 r = InterlockedDecrement(&refCount);
70 #endif
71 return r;
72 }
73 };
74}
75
76#endif // _HTTP_HELPER_HANDLES_BODY_HPP
77
78/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper_progress.hpp Source File

  • inc
ms_http_helper_progress.hpp
1/*
2##############################################################################
3# file: ms_http_helper_progress.hpp #
4# 'msparser' toolkit #
5# Hold information about the progress of an internet file transfer #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2024 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_http_helper_progress.hpp $
12 * @(#)$Revision: 391e7298502ad6bbe2132c2290996c0b12ee8c2b | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2024-02-01 09:55:20 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_HTTP_HELPER_PROGRESS_HPP
18#define MS_HTTP_HELPER_PROGRESS_HPP
19
20#include <memory>
21#include <string>
22
23namespace msparser_internal {
24 class ms_http_helper_progress_impl;
25}
26
27namespace matrix_science
28{
35
45 class MS_MASCOTRESFILE_API ms_http_helper_progress
46 {
47 public:
49 ms_http_helper_progress();
50
52 ~ms_http_helper_progress();
53
55 ms_http_helper_progress(const ms_http_helper_progress &src);
56
58 ms_http_helper_progress(ms_http_helper_progress &parentProgress, double proportionOffset, UINT64 byteOffset, double scale);
59
60#ifndef SWIG
61 ms_http_helper_progress& operator=(const ms_http_helper_progress &right);
62#endif
63
65 void copyFrom(const ms_http_helper_progress * right);
66
68 void setAbort();
69
71 bool isAbortSet() const;
72
74 bool isStarted() const;
75
77 UINT64 getCurrentBytes() const;
78 UINT64 current() const { return getCurrentBytes(); } // Deprecated and undocumented - not a normal Parser function name
79
81 UINT64 getTotalBytes() const;
82 UINT64 total() const { return getTotalBytes(); } // Deprecated and undocumented - not a normal Parser function name
83
85 double getProportion() const;
86 double proportion() const { return getProportion(); } // Deprecated and undocumented - not a normal Parser function name
87
89 bool isComplete() const;
90
92 bool hasParent() const;
93
94 protected:
95 ms_http_helper_progress(msparser_internal::ms_http_helper_progress_impl*);
96
97 private:
98 std::unique_ptr<msparser_internal::ms_http_helper_progress_impl> pImpl_;
99
100 friend class ms_http_helper;
101 friend class ms_http_client_search;
102 };
103 // end of http_client_group
105} // namespace matrix_science
106
107#endif // MS_HTTP_HELPER_PROGRESS_HPP
108
109/*------------------------------- End of File -------------------------------*/
matrix_science::ms_http_client_search
Used for submitting searches to a Mascot server and retrieving search results using HTTP(S).
Definition: ms_http_client_search.hpp:44
matrix_science::ms_http_helper_progress
This holds information on the progress of a running HTTP transfer.
Definition: ms_http_helper_progress.hpp:46
matrix_science::ms_http_helper
The class provides HTTP, FTP and FILE protocol access to a server.
Definition: ms_http_helper.hpp:57
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper_progress_impl.hpp Source File

  • src
  • http
  • impl
ms_http_helper_progress_impl.hpp
1/*
2##############################################################################
3# file: ms_http_helper_progress_impl.hpp #
4# 'msparser' toolkit #
5# Hold information about the progress of an internet file transfer #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2024 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_HTTP_HELPER_PROGRESS_IMPL_HPP
18#define MS_HTTP_HELPER_PROGRESS_IMPL_HPP
19
20
21#include <string>
22
23namespace msparser_internal
24{
26
33
35 class MS_MASCOTRESFILE_API ms_http_helper_progress_impl
36 {
37 public:
38 // Default constructor.
39 ms_http_helper_progress_impl();
40
42 ~ms_http_helper_progress_impl();
43
45 ms_http_helper_progress_impl(const ms_http_helper_progress_impl &src);
46
48 ms_http_helper_progress_impl(ms_http_helper_progress_impl &parentProgress, double proportionOffset, UINT64 byteOffset, double scale);
49
50#ifndef SWIG
51 ms_http_helper_progress_impl& operator=(const ms_http_helper_progress_impl &right);
52#endif
53
55 void copyFrom(const ms_http_helper_progress_impl * right);
56
58 void setAbort();
59
61 bool isAbortSet() const;
62
64 bool isStarted() const;
65
67 UINT64 getCurrentBytes() const;
68
70 UINT64 getTotalBytes() const;
71
73 double getProportion() const;
74
76 bool isComplete() const;
77
79 void setStarted();
80
82 void setProgress(UINT64 current, UINT64 total);
83
85 void setComplete();
86
88 bool hasParent() const;
89
90 private:
91 bool abort_;
92 bool isStarted_;
93 bool isComplete_;
94 UINT64 current_;
95 UINT64 total_;
96 int count_;
97 double proportion_;
98
99 ms_http_helper_progress_impl *parentProgress_;
100 double parentProportionOffset_;
101 UINT64 parentByteOffset_;
102 double parentScale_;
103 };
104 // end of http_client_group
106
108} // namespace matrix_science
109
110#endif // MS_HTTP_HELPER_PROGRESS_IMPL_HPP
111
112/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper_response.hpp Source File

  • inc
ms_http_helper_response.hpp
1/*
2##############################################################################
3# file: ms_http_helper_response.hpp #
4# 'msparser' toolkit #
5# Hold a response from a Mascot server function invocation #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_http_helper_response.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_HTTP_HELPER_RESPONSE_HPP
18#define MS_HTTP_HELPER_RESPONSE_HPP
19
20
21#include <map>
22#include <string>
23
24namespace matrix_science
25{
31 class MS_MASCOTRESFILE_API ms_http_helper_response
32 {
33 public:
35 enum StatusCode {
36 S_SUCCESS = 0,
37 S_LOGINERROR = 1,
38 S_PARSERERROR = 2,
39 S_SERVERERROR = 3,
40 S_MISSING = 4
41 };
42
44
47 enum LoginErrorCode {
48 L_SUCCESS = 0,
49 L_PARAMETER = -1,
50 L_NOT_AUTHORISED = -2,
51 L_SECURITYENABLED = -3,
52 L_WEBAUTHENTICATIONDISABLED = -4,
53 L_GUESTLOGINDISABLED = -5
54 };
55
56#ifndef SWIG
57 // C++ STL collection support.
58 ms_http_helper_response();
59#endif
61 ms_http_helper_response(const std::string & text);
62
64 virtual ~ms_http_helper_response();
65
67 StatusCode getStatus() const;
68 StatusCode status() const { return getStatus(); } // Deprecated and undocumented - not a normal Parser function name
69
71 LoginErrorCode getLoginError() const;
72 LoginErrorCode loginError() const { return getLoginError(); } // Deprecated and undocumented - not a normal Parser function name
73
75 long getParserError() const;
76 long parserError() const { return getParserError(); } // Deprecated and undocumented - not a normal Parser function name
77
79 bool hasErrorText() const;
80
82 std::string getErrorText() const;
83 std::string errorText() const { return getErrorText(); } // Deprecated and undocumented - not a normal Parser function name
84
86 bool hasSessionId() const;
87
89 std::string getSessionID() const;
90 std::string sessionId() const { return getSessionID(); } // Deprecated and undocumented - not a normal Parser function name
91
93 bool hasTaskId() const;
94
96 std::string getTaskID() const;
97 std::string taskId() const { return getTaskID(); } // Deprecated and undocumented - not a normal Parser function name
98
100 std::string getText() const;
101 std::string text() const { return getText(); } // Deprecated and undocumented - not a normal Parser function name
102#ifndef SWIG
104 bool findValue(const std::string & label, std::string & valueFromLabel) const;
105#else // SWIG Multiple return values
106 bool findValue(const std::string & label, std::string & OUTPUT) const;
107#endif
108 private:
109 std::string text_;
110
111 StatusCode status_;
112 LoginErrorCode loginError_;
113 long parserError_;
114
115 bool hasErrorText_;
116 std::string errorText_;
117 bool hasSessionId_;
118 std::string sessionId_;
119 bool hasTaskId_;
120 std::string searchTaskId_;
121
122 std::map<std::string, std::string> values_;
123 };
124 // end of http_client_group
126} // namespace matrix_science
127
128#endif // MS_HTTP_HELPER_RESPONSE_HPP
129
130/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_http_helper_return.hpp Source File

  • inc
ms_http_helper_return.hpp
1/*
2##############################################################################
3# file: ms_http_helper_return.hpp #
4# 'msparser' toolkit #
5# Hold a response from an internet function #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_http_helper_return.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_HTTP_HELPER_RETURN_HPP
18#define MS_HTTP_HELPER_RETURN_HPP
19
20
21#include <string>
22
23namespace matrix_science
24{
31
36 class MS_MASCOTRESFILE_API ms_http_helper_return
37 {
38 public:
40
43 enum ErrorTypeCode
44 {
45 ERR_NONE,
46 ERR_ABORTEDBYUSER,
47 ERR_SYSTEM,
48 ERR_HTTP,
49 ERR_UNSPECIFIED
50 };
51
53 static ms_http_helper_return systemError(int systemError);
55 static ms_http_helper_return httpError(int httpStatusCode, std::string errorText);
57 static ms_http_helper_return unspecifiedError();
59 static ms_http_helper_return abortedByUser();
60
61#ifndef SWIG
63 ms_http_helper_return();
64#endif
65
67 bool isOk() const;
68#ifndef SWIG
70 operator bool () const;
71#endif
72
74 ErrorTypeCode getErrorType() const;
75 ErrorTypeCode errorType() const { return getErrorType(); } // Deprecated and undocumented - not a normal Parser function name
76
78 int getSystemError() const;
79 int systemError() const { return getSystemError(); } // Deprecated and undocumented - not a normal Parser function name
80
82 int getHttpStatusCode() const;
83 int httpStatusCode() const { return getHttpStatusCode(); } // Deprecated and undocumented - not a normal Parser function name
84
86 std::string getErrorText() const;
87 std::string errorText() const { return getErrorText(); } // Deprecated and undocumented - not a normal Parser function name
88
89 private:
90 ErrorTypeCode errorType_;
91 int systemError_;
92 int httpStatusCode_;
93 std::string errorText_;
94 };
95 // end of http_client_group
97} // namespace matrix_science
98
99#endif // MS_HTTP_HELPER_RETURN_HPP
100
101/*------------------------------- End of File -------------------------------*/
matrix_science::ms_http_helper_return
Indicates any problem that may have occurred during a request to an ms_http_helper object.
Definition: ms_http_helper_return.hpp:37
matrix_science::ms_http_helper_return::ErrorTypeCode
ErrorTypeCode
Definitions for types of problem that can be encountered.
Definition: ms_http_helper_return.hpp:44
matrix_science::ms_http_helper_return::ERR_SYSTEM
@ ERR_SYSTEM
A problem was found with one of the operating system functions.
Definition: ms_http_helper_return.hpp:47
matrix_science::ms_http_helper_return::ERR_NONE
@ ERR_NONE
No problem was encountered; the operation completed successfully.
Definition: ms_http_helper_return.hpp:45
matrix_science::ms_http_helper_return::ERR_ABORTEDBYUSER
@ ERR_ABORTEDBYUSER
The operation was aborted prematurely at the request of the operator.
Definition: ms_http_helper_return.hpp:46
matrix_science::ms_http_helper_return::ERR_HTTP
@ ERR_HTTP
A problem was reported via the HTTP channel.
Definition: ms_http_helper_return.hpp:48
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_imputation.hpp Source File

  • inc
ms_imputation.hpp
1/*
2##############################################################################
3# file: ms_imputation.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2024 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11* @(#)$Source: parser/inc/ms_imputation.hpp $
12* @(#)$Revision: bb42496f256d654703dbcb86842d07846b167b8b | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13* @(#)$Date: 2024-09-20 16:45:19 +0100 $
14##############################################################################
15 */
16
17#if !defined(ms_imputation_INCLUDED_)
18#define ms_imputation_INCLUDED_
19#include <vector>
20
21namespace matrix_science
22{
23 // Forward declarations
24 class ms_imputation_method;
25 class ms_imputation_fixed_value;
26 class ms_imputation_average_value;
27 class ms_imputation_knn;
28 class ms_imputation_missforest;
29
33 class MS_MASCOTRESFILE_API ms_imputation_missing_val {
34
35 public:
36
38 ms_imputation_missing_val()
39 : isMissing_(true)
40 , val_(0.0)
41 { }
42
44 ms_imputation_missing_val(
45 bool isMissing,
46 double val)
47 : isMissing_(isMissing)
48 , val_(val) {}
49
51 bool isMissing() const { return isMissing_; }
52
54 void setMissing() { isMissing_ = true; val_ = 0.0; }
55
57 double getVal() const { return val_; }
58
60 void setVal(double val) { val_ = val; isMissing_ = false; }
61
62 private:
63
64 bool isMissing_ = true;
65 double val_ = 0.0;
66 };
67
78 class MS_MASCOTRESFILE_API ms_imputation_peptide_data {
79
80 public:
81
83 ms_imputation_peptide_data(
84 double retentionTime,
85 int subproject)
86 : retentionTime_(retentionTime)
87 , subproject_(subproject) {}
88
89
90 virtual ~ms_imputation_peptide_data() {}
91
93 const double retentionTime() const { return retentionTime_; }
94
96 const int subproject() const { return subproject_; }
97
98 private:
99
100 // Internal variables
101 double retentionTime_;
102 int subproject_; // This is 1 based
103 };
104
110 class MS_MASCOTRESFILE_API ms_imputation : public ms_errors
111 {
112 public:
113
115
120 enum IMPUTATION_VARIABLE {
121 IMPUTE_PROTEIN_RATIO,
122 IMPUTE_PEPTIDE_RATIO,
123 IMPUTE_RETENTION_TIME
124 };
125
127 ms_imputation(const ms_ms1quantitation* ms1quantitation, ms_imputation_method& m, IMPUTATION_VARIABLE imputationVariableChoice);
128
130 ms_imputation(const ms_ms2quantitation* ms2quantitation, ms_imputation_method& m, IMPUTATION_VARIABLE imputationVariableChoice);
131
133 ms_imputation(std::vector<std::vector<ms_imputation_peptide_data>> imputationPeptides, ms_imputation_method& m);
134
135 ~ms_imputation();
136
138 const IMPUTATION_VARIABLE getImputationVariableChoice() const { return IMPUTATION_VARIABLE_; }
139
141 void setImputationVariableChoice(const IMPUTATION_VARIABLE imputationVariableChoiceIn) { IMPUTATION_VARIABLE_ = imputationVariableChoiceIn; }
142
145 bool getImputeMs1PeptideExcludedByFractionThr() { return (IMPUTATION_MS1_PEPTIDE_CHOICE_ & IMPUTATION_MS1_PEPTIDE_CHOICE::IMPUTE_IF_EXCLUDED_BY_FRACTION_THR) != 0; }
146
149 void setImputeMs1PeptideExcludedByFractionThr(bool imputeMs1PeptideExcludedByFractionThr);
150
153 bool getImputeMs1PeptideExcludedByCorrelationThr() { return (IMPUTATION_MS1_PEPTIDE_CHOICE_ & IMPUTATION_MS1_PEPTIDE_CHOICE::IMPUTE_IF_EXCLUDED_BY_CORRELATION_THR) != 0; }
154
157 void setImputeMs1PeptideExcludedByCorrelationThr(bool imputeMs1PeptideExcludedByCorrelationThr);
158
161 bool getImputeMs1PeptideExcludedByStdErrThr() { return (IMPUTATION_MS1_PEPTIDE_CHOICE_ & IMPUTATION_MS1_PEPTIDE_CHOICE::IMPUTE_IF_EXCLUDED_BY_STDERR_THR) != 0; }
162
165 void setImputeMs1PeptideExcludedByStdErrThr(bool imputeMs1PeptideExcludedByStdErrThr);
166
169 bool getImputeMs1PeptideNegativeRatio() { return (IMPUTATION_MS1_PEPTIDE_CHOICE_ & IMPUTATION_MS1_PEPTIDE_CHOICE::IMPUTE_IF_NEGATIVE) != 0; }
170
173 void setImputeMs1PeptideNegativeRatio(bool imputeMs1PeptideNegativeRatio);
174
177 bool getImputeExcludedMs2PeptideRatios() { return imputation_ms2_peptide_choice_; }
178
181 void setImputeExcludedMs2PeptideRatios(bool imputationMs2PeptideChoiceIn) { imputation_ms2_peptide_choice_ = imputationMs2PeptideChoiceIn; }
182
186 std::vector<std::vector<double>> impute();
187
188 private:
189
196 ms_imputation(ms_imputation_method& m);
197
204 void appendImputationPeptides();
205
212 void appendObservation(ms_imputation_peptide_data);
213
215
221 enum IMPUTATION_MS1_PEPTIDE_CHOICE {
222 IMPUTE_ALL_EXCLUDED_RATIOS = 0,
223 IMPUTE_IF_EXCLUDED_BY_FRACTION_THR = 1,
224 IMPUTE_IF_EXCLUDED_BY_CORRELATION_THR = 2,
225 IMPUTE_IF_EXCLUDED_BY_STDERR_THR = 4,
226 IMPUTE_IF_NEGATIVE = 8,
227 IMPUTE_NO_EXCLUDED_RATIOS = 16
228 };
229
230 // Default excluded behaviour
231 int IMPUTATION_MS1_PEPTIDE_CHOICE_ = 8; // i.e. IMPUTATION_PEPTIDE_CHOICE::IMPUTE_IF_NEGATIVE;
232 bool imputation_ms2_peptide_choice_ = true; // Treat excluded ms2 peptide ratios as missing
233 // Initialise member pointers to null
234 const ms_peptidesummary* pepSum_ = nullptr;
235 const ms_quant_method* quantMethod_ = nullptr;
236 const ms_ms1quantitation* ms1_quant_ = nullptr;
237 const ms_ms2quantitation* ms2_quant_ = nullptr;
238 ms_imputation_fixed_value* fixed_value_imputation_ = nullptr;
239 ms_imputation_average_value* average_value_imputation_ = nullptr;
240 ms_imputation_knn* knn_imputation_ = nullptr;
241 ms_imputation_missforest* missforest_imputation_ = nullptr;
242 // Member variables
243 ms_imputation_method& imputation_method_;
244 std::vector<std::vector<ms_imputation_missing_val>> dataWithMissing_;
245 std::vector<std::vector<ms_imputation_peptide_data>> imputationPeptides_;
246 std::vector<ms_imputation_peptide_data> aObservationSet_;
247 // Default ratio choice
248 IMPUTATION_VARIABLE IMPUTATION_VARIABLE_ = IMPUTATION_VARIABLE::IMPUTE_PROTEIN_RATIO;
249 // Methods
250 void populateArraysForImputation();
251 void extractProteinRatios();
252 void extractPeptideRatios();
253 std::vector<ms_ms1quant_match> getMatchesList(int hitNim, int memNum);
254 void pullProteinsFrom(std::vector<matrix_science::ms_protein>& proteinsOut);
255 void extractRetentionTimes();
256 void extractMs1PeptideStatus(int ratioStatus, std::vector<bool>& boolStatus);
257 };
258
262 class MS_MASCOTRESFILE_API ms_imputation_method : public ms_errors
263 {
264 public:
265
267 std::vector<std::vector<ms_imputation_missing_val>>& getDataWithMissing() { return dataWithMissing_; }
268
269 // Overloaded method to execute the imputation calculation
270 virtual std::vector<std::vector<double>> impute() = 0;
271
272 friend class ms_imputation;
273
274 virtual ~ms_imputation_method();
275
276 protected:
277
279 ms_imputation_method() = default;
280 // Internal variables
281 std::vector<std::vector<ms_imputation_missing_val>> dataWithMissing_;
282 std::vector<std::vector<double>> completeObservations_;
283 std::vector<double> averageValues_;
284 // Methods
285 void setDataWithMissing(const std::vector<std::vector<ms_imputation_missing_val>>& dataWithMissingIn);
286 std::vector<double> changems_imputation_missing_valVecToDoubleVec(std::vector<ms_imputation_missing_val> missingObservation);
287 std::vector<std::vector<double>> changems_imputation_missing_valArrayToDoubleArray(std::vector<std::vector<ms_imputation_missing_val>> dataProcess);
288 std::vector<int> getMissingIndexes(std::vector<ms_imputation_missing_val>);
289 std::vector<double> getKnownValues(std::vector<ms_imputation_missing_val>);
290 std::vector<std::vector<int>> removeDuplicateIndexes(std::vector<std::vector<int>> duplicateIndexes);
291 void averageFindAverage();
292 };
293
329 class MS_MASCOTRESFILE_API ms_imputation_fixed_value : public ms_imputation_method
330 {
331 using ms_imputation_method::ms_imputation_method;
332
333 public:
334
336 double getFixedValue() { return fixedValue_; }
337
339 void setFixedValue(double fixedValueIn) { fixedValue_ = fixedValueIn; }
340
342 std::vector<std::vector<double>> impute() override;
343
344 friend class ms_imputation;
345
346 ~ms_imputation_fixed_value();
347
348 private:
349
350 // Internal fixed value
351 double fixedValue_ = 0;
352 };
353
387 class MS_MASCOTRESFILE_API ms_imputation_average_value : public ms_imputation_method
388 {
389 using ms_imputation_method::ms_imputation_method;
390
391 public:
392
394 std::vector<double> getAverageValues() { return averageValues_; }
395
397 void setAverageValues(std::vector<double> averageValuesIn) { averageValues_ = averageValuesIn; }
398
400 std::vector<std::vector<double>> impute() override;
401
402 friend class ms_imputation;
403
404 ~ms_imputation_average_value();
405 };
406
447 class MS_MASCOTRESFILE_API ms_imputation_knn : public ms_imputation_method
448 {
449 using ms_imputation_method::ms_imputation_method;
450
451 public:
452
454 int getKnnNumNeighbours() { return knnNumNeighbours_; }
455
457 void setKnnNumNeighbours(int knnNumNeighboursIn) { knnNumNeighbours_ = knnNumNeighboursIn; }
458
460 bool getKnnUseWeightedAverage() { return knnUseWeightedAverage_; }
461
463 void setKnnUseWeightedAverage(bool knnUseWeightedAverageIn) { knnUseWeightedAverage_ = knnUseWeightedAverageIn; }
464
466 std::vector<std::vector<double>> impute() override;
467
468 friend class ms_imputation;
469
470 ~ms_imputation_knn();
471
472 private:
473
474 // Internal knn parameters
475 int knnNumNeighbours_ = 5;
476 bool knnUseWeightedAverage_ = true;
477 std::vector<std::vector<int>> missingCombinations_;
478
479 // Internal methods
480 void knnImpute();
481 void knnProcess();
482 void getCompleteObsAndMissingIndexes();
483 };
484
525 class MS_MASCOTRESFILE_API ms_imputation_missforest : public ms_imputation_method
526 {
527 using ms_imputation_method::ms_imputation_method;
528
529 public:
530
532 std::vector<std::vector<double>> impute() override;
533
534 friend class ms_imputation;
535
536 ~ms_imputation_missforest();
537
538 private:
539
540 // Internal methods
541 void IdentifyMissing(std::vector<int>& missingCounts, std::vector<std::vector<int>>& missingRows);
542 double GetDifferences(std::vector<std::vector<double>>& currData, std::vector<std::vector<double>>& prevData);
543 double GetDoubleDifferences(std::vector<std::vector<double>>& currData, std::vector<std::vector<double>>& prevData);
544 bool CompareDiffs(std::vector<double> iterationDifferences);
545 };
546 // end of tools_group
548} // namespace matrix_science
549
550#endif // !defined(ms_imputation_INCLUDED_)
551
552/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_imputation_average_value
Definition: ms_imputation.hpp:388
matrix_science::ms_imputation_average_value::setAverageValues
void setAverageValues(std::vector< double > averageValuesIn)
Set the vector of average values, one average per variable, that will be written in place of all miss...
Definition: ms_imputation.hpp:397
matrix_science::ms_imputation_average_value::getAverageValues
std::vector< double > getAverageValues()
Get the vector of average values, one average per variable, that will be written in place of all miss...
Definition: ms_imputation.hpp:394
matrix_science::ms_imputation_fixed_value
Definition: ms_imputation.hpp:330
matrix_science::ms_imputation_fixed_value::setFixedValue
void setFixedValue(double fixedValueIn)
Set the single fixed value that will be written in place of all missing values.
Definition: ms_imputation.hpp:339
matrix_science::ms_imputation_fixed_value::getFixedValue
double getFixedValue()
Get the single fixed value that will be written in place of all missing values.
Definition: ms_imputation.hpp:336
matrix_science::ms_imputation_knn
Definition: ms_imputation.hpp:448
matrix_science::ms_imputation_knn::setKnnNumNeighbours
void setKnnNumNeighbours(int knnNumNeighboursIn)
Set the number of nearest neighbours used when calculating the imputed value. Default value = 5.
Definition: ms_imputation.hpp:457
matrix_science::ms_imputation_knn::getKnnNumNeighbours
int getKnnNumNeighbours()
Get the number of nearest neighbours used when calculating an imputed value. Default value = 5.
Definition: ms_imputation.hpp:454
matrix_science::ms_imputation_knn::setKnnUseWeightedAverage
void setKnnUseWeightedAverage(bool knnUseWeightedAverageIn)
Set the bool to signify if a weighted average of nearest neighbours is used when calculating an imput...
Definition: ms_imputation.hpp:463
matrix_science::ms_imputation_knn::getKnnUseWeightedAverage
bool getKnnUseWeightedAverage()
Get the bool to signify if a weighted average of nearest neighbours is used when calculating an imput...
Definition: ms_imputation.hpp:460
matrix_science::ms_imputation_method
Definition: ms_imputation.hpp:263
matrix_science::ms_imputation_method::getDataWithMissing
std::vector< std::vector< ms_imputation_missing_val > > & getDataWithMissing()
Get the data array that the imputation method will impute.
Definition: ms_imputation.hpp:267
matrix_science::ms_imputation_method::ms_imputation_method
ms_imputation_method()=default
Default constructor.
matrix_science::ms_imputation_missforest
Definition: ms_imputation.hpp:526
matrix_science::ms_imputation_missing_val
Definition: ms_imputation.hpp:33
matrix_science::ms_imputation_missing_val::isMissing
bool isMissing() const
Get missing status for this value.
Definition: ms_imputation.hpp:51
matrix_science::ms_imputation_missing_val::setVal
void setVal(double val)
Set the numerical value and status as not missing.
Definition: ms_imputation.hpp:60
matrix_science::ms_imputation_missing_val::ms_imputation_missing_val
ms_imputation_missing_val()
Default construtor; initialises the value as missing.
Definition: ms_imputation.hpp:38
matrix_science::ms_imputation_missing_val::ms_imputation_missing_val
ms_imputation_missing_val(bool isMissing, double val)
Constructor to initialise whether or not a value is missing and, if not missing, the numerical value.
Definition: ms_imputation.hpp:44
matrix_science::ms_imputation_missing_val::setMissing
void setMissing()
Set the status and value as missing.
Definition: ms_imputation.hpp:54
matrix_science::ms_imputation_missing_val::getVal
double getVal() const
Get the numerical value (if this is not missing).
Definition: ms_imputation.hpp:57
matrix_science::ms_imputation_peptide_data
Definition: ms_imputation.hpp:78
matrix_science::ms_imputation_peptide_data::retentionTime
const double retentionTime() const
Get retention time for this peptide.
Definition: ms_imputation.hpp:93
matrix_science::ms_imputation_peptide_data::ms_imputation_peptide_data
ms_imputation_peptide_data(double retentionTime, int subproject)
Constructor to initialise the parameters required for imputation.
Definition: ms_imputation.hpp:83
matrix_science::ms_imputation_peptide_data::subproject
const int subproject() const
Get the 1-based subproject index.
Definition: ms_imputation.hpp:96
matrix_science::ms_imputation
Definition: ms_imputation.hpp:111
matrix_science::ms_imputation::setImputationVariableChoice
void setImputationVariableChoice(const IMPUTATION_VARIABLE imputationVariableChoiceIn)
Set the imputation object to impute protein/peptide ratios from ms1 or ms2 quantitation,...
Definition: ms_imputation.hpp:141
matrix_science::ms_imputation::getImputeMs1PeptideExcludedByCorrelationThr
bool getImputeMs1PeptideExcludedByCorrelationThr()
Get how the imputation object is currently treating ms1 peptide ratios excluded because of the fracti...
Definition: ms_imputation.hpp:153
matrix_science::ms_imputation::getImputeMs1PeptideExcludedByStdErrThr
bool getImputeMs1PeptideExcludedByStdErrThr()
Get how the imputation object is currently treating ms1 peptide ratios excluded because of the std er...
Definition: ms_imputation.hpp:161
matrix_science::ms_imputation::IMPUTATION_VARIABLE
IMPUTATION_VARIABLE
What type of data is being imputed.
Definition: ms_imputation.hpp:120
matrix_science::ms_imputation::IMPUTE_PROTEIN_RATIO
@ IMPUTE_PROTEIN_RATIO
Missing protein ratios are imputed.
Definition: ms_imputation.hpp:121
matrix_science::ms_imputation::IMPUTE_PEPTIDE_RATIO
@ IMPUTE_PEPTIDE_RATIO
Missing peptide ratios are imputed. How to treat excluded peptide ratios is set via setImputeMs1Pepti...
Definition: ms_imputation.hpp:122
matrix_science::ms_imputation::getImputeExcludedMs2PeptideRatios
bool getImputeExcludedMs2PeptideRatios()
Get how the imputation object is currently treating ms2 excluded ratios. I.e. are excluded ratios tre...
Definition: ms_imputation.hpp:177
matrix_science::ms_imputation::getImputeMs1PeptideExcludedByFractionThr
bool getImputeMs1PeptideExcludedByFractionThr()
Get how the imputation object is currently treating ms1 peptide ratios excluded because of the fracti...
Definition: ms_imputation.hpp:145
matrix_science::ms_imputation::setImputeExcludedMs2PeptideRatios
void setImputeExcludedMs2PeptideRatios(bool imputationMs2PeptideChoiceIn)
Set the imputation object to treat excluded ms2 ratios as missing Not used when imputing ms1 quantita...
Definition: ms_imputation.hpp:181
matrix_science::ms_imputation::getImputeMs1PeptideNegativeRatio
bool getImputeMs1PeptideNegativeRatio()
Get how the imputation object is currently treating negative ms1 peptide ratios. Not used when imputi...
Definition: ms_imputation.hpp:169
matrix_science::ms_imputation::getImputationVariableChoice
const IMPUTATION_VARIABLE getImputationVariableChoice() const
Get what the imputation object is currently imputing. I.e. protein/peptide ratios from ms1 or ms2 qua...
Definition: ms_imputation.hpp:138
matrix_science::ms_ms1quantitation
The result of quantitation calculations applied to peptide summary.
Definition: ms_ms1quantitation.hpp:92
matrix_science::ms_ms2quantitation
Peptide and protein quantitation in a Reporter or Multiplex Mascot results file.
Definition: ms_ms2quantitation.hpp:127
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_input_stream.hpp Source File

  • inc
ms_input_stream.hpp
1/*
2##############################################################################
3# file: ms_input_stream.hpp #
4# 'msparser' toolkit #
5# #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 2014 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: $
12# $Author: villek@matrixscience.com $
13# $Date: 2018-07-30 16:23:53 +0100 $
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
15# $NoKeywords:: $
16##############################################################################
17*/
18
19#ifndef MS_INPUT_STREAM_HPP
20#define MS_INPUT_STREAM_HPP
21
22
23namespace matrix_science
24{
25 class ms_input_string_stream
26 {
27 public:
28 virtual ~ms_input_string_stream() {}
29 virtual void beginRead() {}
30 virtual std::string read(unsigned maxToRead) {
31 std::string emptyString = "";
32 return emptyString;
33 }
34 virtual void endRead() {}
35 };
36}
37
38#endif // MS_INPUT_STREAM_HPP
39
40/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_inputquery.hpp Source File

  • inc
ms_inputquery.hpp
1/*
2##############################################################################
3# file: ms_inputquery.hpp #
4# 'msparser' toolkit #
5# Encapsulates a query from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_inputquery. $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2024-09-23 15:56:58 +0100 $ #
14# $Revision: 47700ac4361244fc5a56b7330a3249bd6fbbe674 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_INPUTQUERY_HPP
20#define MS_INPUTQUERY_HPP
21
22
23#include <string>
24
25namespace msparser_internal
26{
27 class ms_inputquerybase;
28 class ms_inputquery_dat;
29 class ms_inputquery_msr;
30}
31namespace matrix_science
32{
39
42 class MS_MASCOTRESFILE_API ms_inputquery
43 {
44 public:
45
47 ms_inputquery(const ms_mascotresfilebase &resfile, const int q);
48
49 ~ms_inputquery() = default;
50
52 int getQueryNumber() const;
53
54#ifndef DOXYGEN_SHOULD_SKIP_THIS
55 static std::vector<std::string> splitIT_MODS(std::string itmods);
56#endif
57
58#ifndef SWIGCSHARP
60 std::string getStringTitle(bool unescaped) const;
61#else
62 std::wstring getStringTitle(bool unescaped) const
63 {
64 return getStringTitleWide(unescaped);
65 };
66#endif
68 std::string getCharge() const;
69#ifndef SWIG
71 bool getAverageCharge(int* averageCharge, double * averageChargeDbl = 0) const;
72#else // SWIG Multiple return values
73 bool getAverageCharge(int * OUTPUT, double * OUTPUT=0) const;
74#endif
76 std::string getSeq(int seq_no) const;
77
79 std::string getComp(int comp_no) const;
80
82 std::string getTag(int tag_no) const;
83
85 double getMassMin() const;
86
88 double getMassMax() const;
89
91 double getIonMobility() const;
92
94 int getNumVals() const;
95
97 int getNumUsed() const;
98
100 std::string getStringIons1(bool includeCharges = false) const;
101
103 std::string getStringIons2(bool includeCharges = false) const;
104
106 std::string getStringIons3(bool includeCharges = false) const;
107
109 double getIntMax() const;
110
112 double getIntMin() const;
113
115 std::vector<std::pair<double,double> > getPeakList(const int ions) const;
116
118 double getPeakMass(const int ions, const int peakNo) const;
119
121 double getPeakIntensity(const int ions, const int peakNo) const;
122
124 int getPeakCharge(const int ions, const int peakNo) const;
125
127 int getNumberOfPeaks(const int ions) const;
128
130 double getTotalIonsIntensity() const;
131
133 double getPepTol() const;
134
136 std::string getPepTolUnits() const;
137
139 std::string getPepTolString() const;
140
142 std::string getINSTRUMENT(const bool unescaped = true) const;
143
145 std::string getRULES() const;
146
148 double getMinInternalMass() const;
149
151 double getMaxInternalMass() const;
152
154 std::string getIT_MODS(const bool unescaped = true) const;
155
157 int getNumberOfLocalVarMods() const;
158
160 std::string getLocalVarModName(const int num) const;
161
163 std::string getScanNumbers(const int rawFileIdx = -1) const;
164
166 void getScanNumbers(std::vector<int> &index, std::vector<std::string> &scans) const;
167
169 std::string getRawScans(const int rawFileIdx = -1) const;
170
172 void getRawScans(std::vector<int> &index, std::vector<std::string> &rawscans) const;
173
175 std::string getRetentionTimes(const int rawFileIdx = -1) const;
176
178 void getRetentionTimes(std::vector<int> &index, std::vector<std::string> &times) const;
179
181 std::string getRawfile() const;
182
184 std::string getLocus() const;
185
187 int getIndex() const;
188
190 bool hasINTERNALS() const;
191
192 protected:
193
194 ms_inputquery(std::shared_ptr<msparser_internal::ms_inputquerybase>);
195
196 private:
197
198 std::wstring getStringTitleWide(bool unescaped) const;
199
200 std::shared_ptr<msparser_internal::ms_inputquerybase> impl_;
201 }; // end of resfile_group
203} // matrix_science namespace
204
205#endif // !defined(MS_INPUTQUERY_HPP)
matrix_science::ms_inputquery
This class encapsulates the input queries (peak lists) in the Mascot results file.
Definition: ms_inputquery.hpp:43
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_inputquery_dat.hpp Source File

  • src
  • resfile
  • impl
ms_inputquery_dat.hpp
1/*
2##############################################################################
3# file: ms_inputquery_dat.hpp #
4# 'msparser' toolkit #
5# Encapsulates a query from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_inputquery. $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2022-09-08 14:53:26 +0100 $ #
14# $Revision: 814217d33aca89527ab6341d480052491e1026bf | MSPARSER_ALPHA_2_8_100-286-g266675cbae $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_INPUTQUERY_DAT_HPP
20#define MS_INPUTQUERY_DAT_HPP
21
22
23#include <string>
24
25#include "ms_umod_configfile.hpp"
26#include "ms_inputquerybase.hpp"
27
28namespace matrix_science {
29 class ms_mascotresfile_dat;
30}
31namespace msparser_internal {
32
34
41
46 class ms_inputquery_dat : public ms_inputquerybase
47 {
48 public:
49
51 explicit ms_inputquery_dat(const matrix_science::ms_mascotresfile_dat &resfile, const int q);
52
53 virtual ~ms_inputquery_dat();
54
55#ifndef SWIGCSHARP
57 virtual std::string getStringTitle(bool unescaped) const;
58#else
59 virtual std::wstring getStringTitle(bool unescaped) const
60 {
61 return getStringTitleWide(unescaped);
62 };
63#endif
64
66 virtual int getQueryNumber() const;
67
69 virtual std::string getCharge() const;
70
72 virtual std::string getSeq(int seq_no) const;
73
75 virtual std::string getComp(int comp_no) const;
76
78 virtual std::string getTag(int tag_no) const;
79
81 virtual double getMassMin() const;
82
84 virtual double getMassMax() const;
85
87 virtual double getIonMobility() const;
88
90 virtual int getNumVals() const;
91
93 virtual std::string getStringIons1(bool includeCharges = false) const;
94
96 virtual std::string getStringIons2(bool includeCharges = false) const;
97
99 virtual std::string getStringIons3(bool includeCharges = false) const;
100
102 virtual double getIntMax() const;
103
105 virtual double getIntMin() const;
106
108 virtual std::vector<std::pair<double,double> > getPeakList(const int ions) const;
109
111 virtual double getPeakMass(const int ions, const int peakNo) const;
112
114 virtual double getPeakIntensity(const int ions, const int peakNo) const;
115
117 virtual int getPeakCharge(const int ions, const int peakNo) const;
118
120 virtual int getNumberOfPeaks(const int ions) const;
121
123 virtual double getTotalIonsIntensity() const;
124
126 virtual double getPepTol() const;
127
129 virtual std::string getPepTolUnits() const;
130
132 virtual std::string getINSTRUMENT(const bool unescaped = true) const;
133
135 virtual std::string getRULES() const;
136
138 virtual double getMinInternalMass() const;
139
141 virtual double getMaxInternalMass() const;
142
144 virtual std::string getIT_MODS(const bool unescaped = true) const;
145
147 virtual int getNumberOfLocalVarMods() const;
148
150 virtual std::string getLocalVarModName(const int num) const;
151
153 virtual std::string getScanNumbers(const int rawFileIdx = -1) const;
154
156 virtual void getScanNumbers(std::vector<int> &index, std::vector<std::string> &scans) const;
157
159 virtual std::string getRawScans(const int rawFileIdx = -1) const;
160
162 virtual void getRawScans(std::vector<int> &index, std::vector<std::string> &rawscans) const;
163
165 virtual std::string getRetentionTimes(const int rawFileIdx = -1) const;
166
168 virtual void getRetentionTimes(std::vector<int> &index, std::vector<std::string> &times) const;
169
171 virtual std::string getRawfile() const;
172
174 virtual std::string getLocus() const;
175
177 virtual int getIndex() const;
178
180 virtual bool hasINTERNALS() const;
181
182 private:
183 enum { max_seqs_ = 20, max_comps_ = 20, max_tags_ = 20 };
184 const matrix_science::ms_mascotresfile_dat &resfile_;
185 const int q_;
186
187 mutable bool has_title_;
188 mutable std::string title_;
189 mutable std::string unescapedTitle_;
190
191 mutable bool has_charge_;
192 mutable std::string charge_;
193
194 mutable bool has_seq_;
195 mutable std::string seq_[max_seqs_ +1];
196
197 mutable bool has_comp_;
198 mutable std::string comp_[max_comps_ +1];
199
200 mutable bool has_tag_;
201 mutable std::string tag_[max_tags_ + 1];
202
203 mutable bool has_mass_min_;
204 mutable double mass_min_;
205
206 mutable bool has_mass_max_;
207 mutable double mass_max_;
208
209 mutable bool has_ion_mobility_;
210 mutable double ion_mobility_;
211
212 mutable bool has_num_vals_;
213 mutable int num_vals_;
214
215 mutable bool has_ions_;
216 mutable std::string ions_[3], ionsCharges_[3];
217 mutable std::vector<std::pair<double,double> > peakList_[3]; // for ions1, 2 and 3
218 mutable std::vector<std::string> peakListCharges_[3]; // Also for ions1, 2 and 3
219
220 mutable bool has_int_max_;
221 mutable double int_max_;
222
223 mutable bool has_int_min_;
224 mutable double int_min_;
225
226 mutable bool has_tol_;
227 mutable double tol_;
228 mutable std::string tol_units_;
229
230 mutable bool has_instrument_;
231 mutable std::string instrument_;
232 mutable std::string unescaped_instrument_;
233
234 mutable bool has_rules_;
235 mutable std::string rules_;
236
237 mutable bool has_internalMasses_;
238 mutable double minInternalMass_;
239 mutable double maxInternalMass_;
240
241 mutable bool has_it_mods_;
242 mutable std::string it_mods_;
243 mutable std::string unescaped_it_mods_;
244 mutable std::vector<std::string> local_modtitles_;
245
246 matrix_science::ms_umod_configfile umodfile_;
247
248 mutable bool has_rt_;
249 mutable std::vector<int> rtIndices_;
250 mutable std::vector<std::string> rtValues_;
251
252 mutable bool has_scans_;
253 mutable std::vector<int> scansIndices_;
254 mutable std::vector<std::string> scansValues_;
255
256 mutable bool has_rawscans_;
257 mutable std::vector<int> rawscansIndices_;
258 mutable std::vector<std::string> rawscansValues_;
259
260 mutable bool has_rawfile_;
261 mutable std::string rawfile_;
262
263 mutable bool has_locus_;
264 mutable std::string locus_;
265
266 mutable bool has_index_;
267 mutable int index_;
268
269 void fillPeakList(const int ions) const;
270 void loadIons() const;
271 void retrieveAllValuesOf(const std::string &prefix, std::vector<int> &index, std::vector<std::string> &values) const;
272 virtual std::wstring getStringTitleWide(bool unescaped) const;
273 std::wstring getRawfileWide() const;
274 std::string getStringIonsWithCharges(const int index) const;
275 }; // end of resfile_group
277
279
280} // msparser_internal namespace
281
282#endif // !defined(MS_INPUTQUERY_DAT_HPP)
matrix_science::ms_mascotresfile_dat
Class for parsing and reading files in dat28 format.
Definition: ms_mascotresfile_dat.hpp:121
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_inputquery_msr.hpp Source File

  • src
  • resfile
  • impl
ms_inputquery_msr.hpp
1/*
2##############################################################################
3# file: ms_inputquery.hpp #
4# 'msparser' toolkit #
5# Encapsulates a query from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_inputquery. $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-03-28 17:21:52 +0100 $ #
14# $Revision: 35b43edb98ec1e1698e4a280778e133376a6e521 | MSPARSER_ALPHA_2_8_101-84-g23d1aa5a56 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_INPUTQUERY_MSR_HPP
20#define MS_INPUTQUERY_MSR_HPP
21
22
23#include <string>
24
25#include "ms_inputquerybase.hpp"
26
27namespace matrix_science {
28 class ms_mascotresfile_msr;
29}
30namespace msparser_internal {
31
33
40
45 class ms_inputquery_msr : public ms_inputquerybase
46 {
47 public:
48
50 explicit ms_inputquery_msr(const matrix_science::ms_mascotresfile_msr &resfile, const int q);
51
52 virtual ~ms_inputquery_msr() = default;
53
54#ifndef SWIGCSHARP
56 virtual std::string getStringTitle(bool unescaped) const;
57#else
58 virtual std::wstring getStringTitle(bool unescaped) const
59 {
60 return getStringTitleWide(unescaped);
61 };
62#endif
63
65 virtual int getQueryNumber() const;
66
68 virtual std::string getCharge() const;
69
71 virtual std::string getSeq(int seq_no) const;
72
74 virtual std::string getComp(int comp_no) const;
75
77 virtual std::string getTag(int tag_no) const;
78
80 virtual double getMassMin() const;
81
83 virtual double getMassMax() const;
84
86 virtual double getIonMobility() const;
87
89 virtual int getNumVals() const;
90
92 virtual std::string getStringIons1(bool includeCharges = false) const;
93
95 virtual std::string getStringIons2(bool includeCharges = false) const;
96
98 virtual std::string getStringIons3(bool includeCharges = false) const;
99
101 virtual double getIntMax() const;
102
104 virtual double getIntMin() const;
105
107 virtual std::vector<std::pair<double,double> > getPeakList(const int ions) const;
108
110 virtual double getPeakMass(const int ions, const int peakNo) const;
111
113 virtual double getPeakIntensity(const int ions, const int peakNo) const;
114
116 virtual int getPeakCharge(const int ions, const int peakNo) const;
117
119 virtual int getNumberOfPeaks(const int ions) const;
120
122 virtual double getTotalIonsIntensity() const;
123
125 virtual double getPepTol() const;
126
128 virtual std::string getPepTolUnits() const;
129
131 virtual std::string getINSTRUMENT(const bool unescaped = true) const;
132
134 virtual std::string getRULES() const;
135
137 virtual double getMinInternalMass() const;
138
140 virtual double getMaxInternalMass() const;
141
143 virtual std::string getIT_MODS(const bool unescaped = true) const;
144
146 virtual int getNumberOfLocalVarMods() const;
147
149 virtual std::string getLocalVarModName(const int num) const;
150
152 virtual std::string getScanNumbers(const int rawFileIdx = -1) const;
153
155 virtual void getScanNumbers(std::vector<int> &index, std::vector<std::string> &scans) const;
156
158 virtual std::string getRawScans(const int rawFileIdx = -1) const;
159
161 virtual void getRawScans(std::vector<int> &index, std::vector<std::string> &rawscans) const;
162
164 virtual std::string getRetentionTimes(const int rawFileIdx = -1) const;
165
167 virtual void getRetentionTimes(std::vector<int> &index, std::vector<std::string> &times) const;
168
170 virtual std::string getRawfile() const;
171
173 virtual std::string getLocus() const;
174
176 virtual int getIndex() const;
177
178 virtual bool hasINTERNALS() const;
179
180 private:
181 virtual std::wstring getStringTitleWide(bool unescaped) const;
182
183 std::string getStringIonsWithCharges(const std::string& ions, const std::string& charges) const;
184
185 template <size_t I = 0, typename... Ts>
186 typename std::enable_if<I == sizeof...(Ts), void>::type
187 fillPeakList(std::tuple<Ts...> ions, std::tuple<Ts...> charges) const
188 {
189 // If iterated through all queries in the tuple
190 return;
191 }
192
193 template <size_t I = 0, typename... Ts>
194 typename std::enable_if<(I < sizeof...(Ts)), void>::type
195 fillPeakList(std::tuple<Ts...> ions, std::tuple<Ts...> charges) const;
196
197 void loadIons() const;
198 void loadScanNumbers() const;
199 void loadRawScanNumbers() const;
200 void loadRetentionTimes() const;
201
202 static void fillIndicesValues(const std::string& indicesStr, const std::string& valuesStr, const bool singleIndex, std::vector<int>& indices, std::vector<std::string>& values);
203
204 const matrix_science::ms_mascotresfile_msr &resfile_;
205 const int q_;
206
207 mutable bool hasIons_;
208 mutable std::vector<std::pair<double,double> > peakList_[3]; // for ions1, 2 and 3
209 mutable std::vector<std::string> peakListCharges_[3]; // Also for ions1, 2 and 3
210 mutable int nPeaks_[3];
211 mutable double totalIntensity_;
212
213 mutable bool hasScans_;
214 mutable std::vector<int> scansIndices_;
215 mutable std::vector<std::string> scansValues_;
216
217 mutable bool hasRawScans_;
218 mutable std::vector<int> rawScansIndices_;
219 mutable std::vector<std::string> rawScansValues_;
220
221 mutable bool hasRt_;
222 mutable std::vector<int> rtIndices_;
223 mutable std::vector<std::string> rtValues_;
224 }; // end of resfile_group
226
228
229} // msparser_internal namespace
230
231#endif // !defined(MS_INPUTQUERY_MSR_HPP)
matrix_science::ms_mascotresfile_msr
Class for parsing and reading files in MSR format.
Definition: ms_mascotresfile_msr.hpp:105
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_inputquery_nil.hpp Source File

  • src
  • resfile
  • impl
ms_inputquery_nil.hpp
1/*
2##############################################################################
3# file: ms_inputquery_nil.hpp #
4# 'msparser' toolkit #
5# Encapsulates a query from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_inputquery. $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-03-28 17:21:52 +0100 $ #
14# $Revision: 35b43edb98ec1e1698e4a280778e133376a6e521 | MSPARSER_ALPHA_2_8_101-84-g23d1aa5a56 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_INPUTQUERY_NIL_HPP
20#define MS_INPUTQUERY_NIL_HPP
21
22
23#include <string>
24
25#include "ms_inputquerybase.hpp"
26
27namespace msparser_internal {
28
29 class ms_mascotresfile_nil;
30
31 class ms_inputquery_nil : public ms_inputquerybase
32 {
33 public:
34
35 explicit ms_inputquery_nil(const ms_mascotresfile_nil &resfile, const int q) {}
36
37 virtual ~ms_inputquery_nil() = default;
38
39 virtual std::string getStringTitle(bool unescaped) const { return {}; }
40
41 virtual std::wstring getStringTitleWide(bool unescaped) const { return {}; }
42
43 virtual int getQueryNumber() const { return 0; }
44
45 virtual std::string getCharge() const { return {}; }
46
47 virtual std::string getSeq(int seq_no) const { return {}; }
48
49 virtual std::string getComp(int comp_no) const { return {}; }
50
51 virtual std::string getTag(int tag_no) const { return {}; }
52
53 virtual double getMassMin() const { return 0.0; }
54
55 virtual double getMassMax() const { return 0.0; }
56
57 virtual double getIonMobility() const { return 0.0; }
58
59 virtual int getNumVals() const { return 0; }
60
61 virtual std::string getStringIons1(bool includeCharges = false) const { return {}; }
62
63 virtual std::string getStringIons2(bool includeCharges = false) const { return {}; }
64
65 virtual std::string getStringIons3(bool includeCharges = false) const { return {}; }
66
67 virtual double getIntMax() const { return 0.0; }
68
69 virtual double getIntMin() const { return 0.0; }
70
71 virtual std::vector<std::pair<double,double> > getPeakList(const int ions) const { return {}; }
72
73 virtual double getPeakMass(const int ions, const int peakNo) const { return 0.0; }
74
75 virtual double getPeakIntensity(const int ions, const int peakNo) const { return 0.0; }
76
77 virtual int getPeakCharge(const int ions, const int peakNo) const { return 0; }
78
79 virtual int getNumberOfPeaks(const int ions) const { return 0; }
80
81 virtual double getTotalIonsIntensity() const { return 0.0; }
82
83 virtual double getPepTol() const { return 0.0; }
84
85 virtual std::string getPepTolUnits() const { return {}; }
86
87 virtual std::string getINSTRUMENT(const bool unescaped = true) const { return {}; }
88
89 virtual std::string getRULES() const { return {}; }
90
91 virtual double getMinInternalMass() const { return 0.0; }
92
93 virtual double getMaxInternalMass() const { return 0.0; }
94
95 virtual std::string getIT_MODS(const bool unescaped = true) const { return {}; }
96
97 virtual int getNumberOfLocalVarMods() const { return 0; }
98
99 virtual std::string getLocalVarModName(const int num) const { return {}; }
100
101 virtual std::string getScanNumbers(const int rawFileIdx = -1) const { return {}; }
102
103 virtual void getScanNumbers(std::vector<int> &index, std::vector<std::string> &scans) const {}
104
105 virtual std::string getRawScans(const int rawFileIdx = -1) const { return {}; }
106
107 virtual void getRawScans(std::vector<int> &index, std::vector<std::string> &rawscans) const {}
108
109 virtual std::string getRetentionTimes(const int rawFileIdx = -1) const { return {}; }
110
111 virtual void getRetentionTimes(std::vector<int> &index, std::vector<std::string> &times) const {}
112
113 virtual std::string getRawfile() const { return {}; }
114
115 virtual std::string getLocus() const { return {}; }
116
117 virtual int getIndex() const { return 0; }
118
119 virtual bool hasINTERNALS() const { return false; }
120 };
121
122} // msparser_internal namespace
123
124#endif // !defined(MS_INPUTQUERY_NIL_HPP)
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_inputquerybase.hpp Source File

  • src
  • resfile
  • impl
ms_inputquerybase.hpp
1/*
2##############################################################################
3# file: ms_inputquerybase.hpp #
4# 'msparser' toolkit #
5# Encapsulates a query from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_inputquery. $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2023-02-02 13:47:30 +0000 $ #
14# $Revision: a80892d71615baa5079d40d1461ed9c24e3bffff | MSPARSER_ALPHA_2_8_100-378-g5b7ff32217 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_INPUTQUERYBASE_HPP
20#define MS_INPUTQUERYBASE_HPP
21
22
23#include <string>
24
25namespace msparser_internal {
26
28
34 class ms_inputquerybase
35 {
36 public:
37
39 ms_inputquerybase() = default;
40 virtual ~ms_inputquerybase() = default;
41
42#ifndef SWIGCSHARP
44 virtual std::string getStringTitle(bool unescaped) const = 0;
45#else
46 virtual std::wstring getStringTitle(bool unescaped) const = 0;
47
48#endif
50 virtual int getQueryNumber() const = 0;
51
53 virtual std::string getCharge() const = 0;
54
56 bool getAverageCharge(int* averageCharge, double * averageChargeDbl = 0) const;
57
59 virtual std::string getSeq(int seq_no) const = 0;
60
62 virtual std::string getComp(int comp_no) const = 0;
63
65 virtual std::string getTag(int tag_no) const = 0;
66
68 virtual double getMassMin() const = 0;
69
71 virtual double getMassMax() const = 0;
72
74 virtual double getIonMobility() const = 0;
75
77 virtual int getNumVals() const = 0;
78
80 virtual std::string getStringIons1(bool includeCharges = false) const = 0;
81
83 virtual std::string getStringIons2(bool includeCharges = false) const = 0;
84
86 virtual std::string getStringIons3(bool includeCharges = false) const = 0;
87
89 virtual double getIntMax() const = 0;
90
92 virtual double getIntMin() const = 0;
93
95 virtual std::vector<std::pair<double,double> > getPeakList(const int ions) const = 0;
96
98 virtual double getPeakMass(const int ions, const int peakNo) const = 0;
99
101 virtual double getPeakIntensity(const int ions, const int peakNo) const = 0;
102
104 virtual int getPeakCharge(const int ions, const int peakNo) const = 0;
105
107 virtual int getNumberOfPeaks(const int ions) const = 0;
108
110 virtual double getTotalIonsIntensity() const = 0;
111
113 virtual double getPepTol() const = 0;
114
116 virtual std::string getPepTolUnits() const = 0;
117
119 std::string getPepTolString() const;
120
122 virtual std::string getINSTRUMENT(const bool unescaped = true) const = 0;
123
125 virtual std::string getRULES() const = 0;
126
128 virtual double getMinInternalMass() const = 0;
129
131 virtual double getMaxInternalMass() const = 0;
132
134 virtual std::string getIT_MODS(const bool unescaped = true) const = 0;
135
137 virtual int getNumberOfLocalVarMods() const = 0;
138
140 virtual std::string getLocalVarModName(const int num) const = 0;
141
143 virtual std::string getScanNumbers(const int rawFileIdx = -1) const = 0;
144
146 virtual void getScanNumbers(std::vector<int> &index, std::vector<std::string> &scans) const = 0;
147
149 virtual std::string getRawScans(const int rawFileIdx = -1) const = 0;
150
152 virtual void getRawScans(std::vector<int> &index, std::vector<std::string> &rawscans) const = 0;
153
155 virtual std::string getRetentionTimes(const int rawFileIdx = -1) const = 0;
156
158 virtual void getRetentionTimes(std::vector<int> &index, std::vector<std::string> &times) const = 0;
159
161 virtual std::string getRawfile() const = 0;
162
164 virtual std::string getLocus() const = 0;
165
167 virtual int getIndex() const = 0;
168
169 virtual bool hasINTERNALS() const = 0;
170
171#ifndef DOXYGEN_SHOULD_SKIP_THIS
172 static std::vector<std::string> splitIT_MODS(std::string itmods);
173#endif
174 virtual std::wstring getStringTitleWide(bool unescaped) const = 0;
175
176 }; // end of resfile_group
178
180
181} // msparser_internal namespace
182
183#endif // !defined(MS_INPUTQUERYBASE_HPP)
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_libraryoptions.hpp Source File

  • inc
ms_libraryoptions.hpp
1/*
2##############################################################################
3# file: ms_parserule.hpp #
4# 'msparser' toolkit #
5# Represents LibraryOptions section of mascot.dat file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_parserule.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_LIBRARYOPTIONS_HPP
20#define MS_LIBRARYOPTIONS_HPP
21
22
23
24#include <string>
25#include <map>
26
27namespace matrix_science {
35
52 class MS_MASCOTRESFILE_API ms_libraryoptions : public ms_customproperty
53 {
54 friend class ms_datfile;
55 public:
57 ms_libraryoptions();
58
60 ms_libraryoptions(const ms_libraryoptions& src);
61
63 ~ms_libraryoptions();
64
66 void defaultValues();
67
69 void copyFrom(const ms_libraryoptions* right);
70
71#ifndef SWIG
73 ms_libraryoptions& operator=(const ms_libraryoptions& right);
74#endif
76
80 bool isSectionAvailable() const;
81
83 void setSectionAvailable(const bool value);
84
86 double getToleranceInPPM(const char * spectralLibraryName) const;
87
89 void setToleranceInPPM(const char * spectralLibraryName, double tolerance);
90
92 double getToleranceInDa(const char * spectralLibraryName) const;
93
95 void setToleranceInDa(const char * spectralLibraryName, double tolerance);
96
98 std::string getReferenceFasta(const char * spectralLibraryName) const;
99
101 std::string getReferenceFastaTaxonomyTitle(const char * spectralLibraryName) const;
102
104 void setReferenceFasta(const char * spectralLibraryName, const char * fastaDatabaseName, const char * taxonomyTitle);
105
107 void dropSpectralLibrary(const char * spectralLibraryName);
108
110 int getNumberOfLibraries() const;
111
113 std::string getLibraryName(const int num) const;
114
115#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
116#include "suppress_ms_customproperty.hpp"
117#endif
118
119 private:
120 bool sectionAvailable_;
121 struct sl_info_t {
122 public:
123 std::string referenceFastaDB;
124 std::string referenceFastaTaxonomyTitle;
125 double tolInPPM;
126 double tolInDa;
127 };
128 typedef std::map<std::string, sl_info_t> slInfoMap_t;
129 slInfoMap_t slInfoMap_;
130 }; // end of config_group
132} // namespace matrix_science
133
134#endif // MS_LIBRARYOPTIONS_HPP
135
136/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_libraryoptions
Represents the LibraryOptions section of mascot.dat.
Definition: ms_libraryoptions.hpp:53
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_license.hpp Source File

  • inc
ms_license.hpp
1/*
2##############################################################################
3# file: ms_license.hpp #
4# 'msparser' toolkit #
5# Provides read-only interface for mascot license file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_license.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_LICENSE_HPP
20#define MS_LICENSE_HPP
21
22
23#include <string>
24
25
26namespace matrix_science {
33
51 class MS_MASCOTRESFILE_API ms_license: public ms_errors
52 {
53 public:
55 ms_license();
56
58 ms_license(const ms_license& src);
59
61 ms_license(const char* filename);
62
64 ~ms_license();
65
67 void defaultValues();
68
70 void copyFrom(const ms_license* right);
71
72#ifndef SWIG
74 ms_license& operator=(const ms_license& right);
75#endif
77 std::string getFileName() const;
78
80 void setFileName(const char* filename);
81
83 void read_file();
84
86 bool isLicenseValid() const;
87
89 std::string getLicenseString() const;
90
92 std::string getLicenseVersion() const;
93
95 std::string getStartDate() const;
96
98 std::string getEndDate() const;
99
101 int getNumProcessorsLicensed() const;
102
104 std::string getLicensee() const;
105
107 std::string getDistributor() const;
108
110 std::string getFeatures() const;
111
112 int getInternalConfigurationCode() const;
113
114 private:
115 bool loadLicenseFile(FILE *f);
116 bool checkLicenseValid(const char* startDate, const char* endDate);
117 int calcChecksum(void* entity);
118 void formLicenseString();
119 void checkInternalConfiguration();
120
121 bool bLicenseValid_;
122 std::string filename_;
123 std::string strLicenseString_;
124
125 std::string licenseVer_;
126 std::string startDate_;
127 std::string endDate_;
128 int processors_;
129 std::string licensee_;
130 std::string distributor_;
131 std::string features_;
132
133 int internalConfigurationCode_;
134 }; // class ms_license // end of config_group
136} // namespace matrix_science
137
138#endif // MS_LICENSE_HPP
139
140/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_license
The class provides access license details in read-only mode.
Definition: ms_license.hpp:52
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_linker_site.hpp Source File

  • inc
ms_linker_site.hpp
1/*
2##############################################################################
3# file: ms_linker_site.hpp #
4# 'msparser' toolkit #
5# Linker site used in ms_peptide #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2018 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: robertog@matrixscience.com $ #
12# $Date: 2023-04-14 15:33:41 +0100 $ #
13# $Revision: #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_LINKERSITE_HPP
19#define MS_LINKERSITE_HPP
20
21// Includes from the standard template library
22#include <string>
23
24namespace matrix_science {
25 class ms_peptide;
26
33
41 class MS_MASCOTRESFILE_API ms_linker_site
42 {
43 public:
45 ms_linker_site();
46
48 ms_linker_site(ms_peptide::PSM linkFrom,
49 ms_peptide::PSM linkTo,
50 int siteFrom,
51 int siteTo,
52 int varModIdxFrom,
53 int varModIdxTo,
54 double linkerMass);
55
57 ms_linker_site(const ms_linker_site& src);
58
60 ~ms_linker_site();
61
62#ifndef SWIG
64 ms_linker_site& operator=(const ms_linker_site& right);
65
66 bool operator<(const ms_linker_site &right) const;
67#endif
68
70 void copyFrom(const ms_linker_site *right);
71
73 int getSiteFrom() const;
74
76 int getSiteTo() const;
77
79 int getVarModIdxFrom() const;
80
82 int getVarModIdxTo() const;
83
85 ms_peptide::PSM getLinkFrom() const;
86
88 ms_peptide::PSM getLinkTo() const;
89
91 double getLinkerMass() const;
92
93 std::string stringify() const;
94
95 private:
96 ms_peptide::PSM linkFrom_, linkTo_;
97 int siteFrom_, siteTo_;
98 int varModIdxFrom_, varModIdxTo_;
99 double linkerMr_;
100 };
101
102#ifndef SWIG
103 std::ostream& operator<<(std::ostream& out, const ms_linker_site& s);
104#endif
105 // end of resfile_group
107} // matrix_science namespace
108
109#endif // MS_LINKERSITE_HPP
110
111/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_linker_site_vector.hpp Source File

  • inc
ms_linker_site_vector.hpp
1/*
2##############################################################################
3# file: ms_linker_site_vector.hpp #
4# 'msparser' toolkit #
5# A vector of ms_linker_site objects #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2018 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: robertog@matrixscience.com $ #
12# $Date: 2023-04-14 15:33:41 +0100 $ #
13# $Revision: 316087dfcebe5f2dc18d1f35fd47c9d25ab4322d | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_LINKERSITEVECTOR_HPP
19#define MS_LINKERSITEVECTOR_HPP
20
21
22// Includes from the standard template library
23#include <vector>
24#include <list>
25
26namespace matrix_science {
27 class ms_linker_site;
28}
29
30namespace matrix_science {
37
45 class MS_MASCOTRESFILE_API ms_linker_site_vector
46 {
47 public:
49 ms_linker_site_vector();
50
51#ifndef SWIG
53 ms_linker_site_vector(const std::vector<ms_linker_site> &v, const int alphaVarModsLen, const int betaVarModsLen);
54
56 ms_linker_site_vector(const std::list<ms_linker_site> &v, const int alphaVarModsLen, const int betaVarModsLen);
57#endif
58
60 ms_linker_site_vector(const ms_linker_site_vector& src);
61
63 ~ms_linker_site_vector();
64
65#ifndef SWIG
67 ms_linker_site_vector& operator=(const ms_linker_site_vector& right);
68
70 const std::vector<ms_linker_site>& toVector() const;
71#endif
72
74 void copyFrom(const ms_linker_site_vector *src);
75
77 void append(const ms_linker_site_vector & src);
78
80 int size() const;
81
83 bool empty() const;
84
86 void push(const ms_linker_site &linkerSite);
87
89 ms_linker_site pop();
90
92 ms_linker_site get(int idx) const;
93
95 void set(int idx, const ms_linker_site &linkerSite);
96
98 void clear();
99
101 void swap(ms_linker_site_vector &right);
102
104 bool containsVarModIdx(int idx) const;
105
107 int getVarModIdxOfLinkedSite(const ms_peptide::PSM psmComponent, const int i) const;
108
110 int getAlphaVarModsStrLength() const;
111
113 int getBetaVarModsStrLength() const;
114
116 void setVarModsStrLengths(const int alphaVarModsLen, const int betaVarModsLen);
117
119 std::string stringify() const;
120
121 private:
122 std::vector<ms_linker_site> data_;
123 int alphaVarModsLen_, betaVarModsLen_;
124 };
125
126#ifndef SWIG
127 std::ostream& operator<<(std::ostream& out, const ms_linker_site_vector& v);
128#endif
129 // end of resfile_group
131} // matrix_science namespace
132
133#endif // MS_LINKERSITEVECTOR_HPP
134
135/*------------------------------- End of File -------------------------------*/
136
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_log.hpp Source File

  • inc
ms_log.hpp
1/*
2##############################################################################
3# file: ms_log.hpp #
4# 'msparser' toolkit #
5# Encapsulates a general-purpose error object that collects information #
6# about several consecutive erros #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2018 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /Mowse/ms_mascotresfile/include/ms_errors.hpp $ #
13# $Author: robertog@matrixscience.com $ #
14# $Date: 2024-08-27 16:16:41 +0100 $ #
15# $Revision: 5566e3f2f102c2aae2dea328044e0e4030755ddd | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_LOG_HPP
21#define MS_LOG_HPP
22
23
24#include <cstdarg>
25#include <vector>
26#include <string>
27#include <map>
28#include <set>
29#include <utility>
30
31namespace matrix_science {
38 class MS_MASCOTRESFILE_API ms_log
39 {
40 public:
42
47 enum msg_sev {
48 sev_fatal = 1,
49 sev_warn = 2,
50 sev_info = 3,
51 sev_debug1 = 4,
52 sev_debug2 = 5,
53 sev_debug3 = 6
54 };
55
57
127 typedef int msg_num_t;
128
129#ifndef SWIG
130 typedef struct {
131 ms_log::msg_sev severity;
132 ms_log::msg_num_t msgNum;
133 const char * pMsgText;
134 } msg_catalog_t;
135 typedef std::map<ms_log::msg_num_t, const msg_catalog_t *> catalog_map_t;
136#endif
137
138 static const msg_num_t LOGMSG_DBG1_NUM_PROCESSOR_GROUPS = 0x00010160;
139 static const msg_num_t LOGMSG_DBG3_HWLOC_TREE = 0x00010161;
140 static const msg_num_t LOGMSG_DBG3_HWLOC_GROUPS = 0x00010162;
141 static const msg_num_t LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD = 0x00010163;
142 static const msg_num_t LOGMSG_DBG3_CALL_GET_CHIP_MFCTR = 0x00010164;
143 static const msg_num_t LOGMSG_DBG3_PROCESSOR_NAME = 0x00010165;
144 static const msg_num_t LOGMSG_DBG3_BINDING_PROCESSORS = 0x00010166;
145 static const msg_num_t LOGMSG_DBG3_BINDING_THREAD = 0x00010167;
146 static const msg_num_t LOGMSG_DBG2_NUM_CONFIG_MISMATCH = 0x00010168;
147 static const msg_num_t LOGMSG_DBG2_NUM_ONLINE_MISMATCH = 0x00010169;
148 static const msg_num_t LOGMSG_DBG2_CPU_INF_NUM_ON_SYS = 0x00010170;
149 static const msg_num_t LOGMSG_DBG2_CPU_INF_NUM_AVAIL = 0x00010171;
150 static const msg_num_t LOGMSG_DBG2_CPU_INF_NUM_GROUPS = 0x00010172;
151 static const msg_num_t LOGMSG_DBG2_CPU_INF_NAME = 0x00010173;
152 static const msg_num_t LOGMSG_DBG2_CPU_INF_PROC_AFFINITY = 0x00010174;
153 static const msg_num_t LOGMSG_DBG2_CPU_INF_USE_PROCESSES = 0x00010175;
154 static const msg_num_t LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL = 0x00010176;
155 static const msg_num_t LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS = 0x00010177;
156 static const msg_num_t LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS = 0x00010178;
157 static const msg_num_t LOGMSG_DBG2_CPU_INF_GETAUTODETECT = 0x00010179;
158 static const msg_num_t LOGMSG_DBG2_CPU_INF_MT_NAME = 0x0001017A;
159 static const msg_num_t LOGMSG_DBG2_CPU_INF_MT_STATUS = 0x0001017B;
160 static const msg_num_t LOGMSG_DBG2_CPU_INF_TABLE_TITLE = 0x0001017C;
161 static const msg_num_t LOGMSG_DBG2_CPU_INF_TABLE_LINE = 0x0001017D;
162
163 // Installer logging messages
164 static const msg_num_t LOGMSG_INST_LOGICALPERPHYSICALCPU = 0x00010200;
165 static const msg_num_t LOGMSG_INST_NUMTHREADS = 0x00010201;
166 static const msg_num_t LOGMSG_INST_NOTMASCOTDATOK = 0x00010202;
167 static const msg_num_t LOGMSG_INST_MASCOTDATOK = 0x00010203;
168 static const msg_num_t LOGMSG_INST_APPENDTAXONOMY = 0x00010204;
169 static const msg_num_t LOGMSG_INST_ADDINGDATABASE = 0x00010205;
170 static const msg_num_t LOGMSG_INST_CHANGEDBTAXONOMY = 0x00010206;
171 static const msg_num_t LOGMSG_INST_APPENDPARSERULE = 0x00010207;
172 static const msg_num_t LOGMSG_INST_ADDOPTIONSSECTION = 0x00010208;
173 static const msg_num_t LOGMSG_INST_SETOPTIONSSECTION = 0x00010209;
174 static const msg_num_t LOGMSG_INST_CLUSTERSECTION = 0x0001020A;
175 static const msg_num_t LOGMSG_INST_NOSUBCLUSTERSET = 0x0001020B;
176 static const msg_num_t LOGMSG_INST_CHANGEPARSERULE = 0x0001020C;
177 static const msg_num_t LOGMSG_INST_SAVEDPOSTINSTALLFILE = 0x0001020D;
178 static const msg_num_t LOGMSG_INST_FAILSAVEPOSTINSTALLFILE = 0x0001020E;
179 static const msg_num_t LOGMSG_INST_REMOVEOPTIONSSECTION = 0x0001020F;
180 static const msg_num_t LOGMSG_INST_CHANGEPERCOLATORFEATS = 0x00010210;
181 static const msg_num_t LOGMSG_INST_CHANGEPROTFAMILYSWITCH = 0x00010211;
182 static const msg_num_t LOGMSG_INST_CHANGEPERCOLATORUSERT = 0x00010212;
183 static const msg_num_t LOGMSG_INST_CHANGESPLITNUMOFQUERIES = 0x00010213;
184 static const msg_num_t LOGMSG_INST_CHANGESPLITDATAFILESIZE = 0x00010214;
185 static const msg_num_t LOGMSG_INST_CHANGERESULTSCACHE = 0x00010215;
186
187 static const msg_num_t LOGMSG_HTTP_URLSTRING = 0x00010300;
188 static const msg_num_t LOGMSG_HTTP_QUERYSTATUSRESULT = 0x00010301;
189 static const msg_num_t LOGMSG_HTTP_MAXCONECTIONSFAILED = 0x00010302;
190 static const msg_num_t LOGMSG_HTTP_MAXCONECTIONS10FAILED = 0x00010303;
191 static const msg_num_t LOGMSG_HTTP_GETRETURNSTRING = 0x00010304;
192
193
194 // Quantitation logging messages
195 static const msg_num_t LOGMSG_CUSTQUANT_ADD_QUANT_KEY = 0x00010400;
196 static const msg_num_t LOGMSG_CUSTQUANT_REMOVE_ALL_KEY = 0x00010401;
197 static const msg_num_t LOGMSG_CUSTQUANT_REMOVE_KEY = 0x00010402;
198 static const msg_num_t LOGMSG_QUANT_START_UPDATE_PROT_MATCHES = 0x00010403;
199 static const msg_num_t LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES = 0x00010404;
200 static const msg_num_t LOGMSG_QUANT_START_CALC_COMPLETE = 0x00010405;
201 static const msg_num_t LOGMSG_QUANT_FINISH_CALC_COMPLETE = 0x00010406;
202 static const msg_num_t LOGMSG_QUANT_START_LOAD_CDB = 0x00010408;
203 static const msg_num_t LOGMSG_QUANT_FINISH_LOAD_CDB = 0x00010409;
204 static const msg_num_t LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES = 0x0001040A;
205 static const msg_num_t LOGMSG_QUANT_LOADING_MATCHES = 0x0001040B;
206 static const msg_num_t LOGMSG_QUANT_UPDATING_PEP_EVIDENCE = 0x0001040C;
207 static const msg_num_t LOGMSG_QUANT_REAPPLY_THRESHOLDS = 0x0001040D;
208 static const msg_num_t LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES = 0x0001040E;
209 static const msg_num_t LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED = 0x0001040F;
210 static const msg_num_t LOGMSG_QUANT_REMATCHING_INFERRED = 0x00010410;
211 static const msg_num_t LOGMSG_QUANT_EXCLUDING_PEPTIDE = 0x00010411;
212 static const msg_num_t LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN = 0x00010412;
213 static const msg_num_t LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN = 0x00010413;
214 static const msg_num_t LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE = 0x00010414;
215 static const msg_num_t LOGMSG_QUANT_REMOVE_INFERRED_MATCH = 0x00010415;
216 static const msg_num_t LOGMSG_QUANT_ADDING_PROTEIN_HIT = 0x00010416;
217 static const msg_num_t LOGMSG_QUANT_ADDED_PROTEIN_HIT = 0x00010417;
218 static const msg_num_t LOGMSG_QUANT_OPENING_CACHE_FILE = 0x00010418;
219 static const msg_num_t LOGMSG_QUANT_CLOSING_CACHE_FILE = 0x00010419;
220 static const msg_num_t LOGMSG_QUANT_START_REORDER_AFTER_MERGE = 0x0001041A;
221 static const msg_num_t LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE = 0x0001041B;
222 static const msg_num_t LOGMSG_QUANT_MERGE_COMPONENT_INCONSIST = 0x0001041C;
223 static const msg_num_t LOGMSG_QUANT_MERGE_COMPONENT_DUPE_FI = 0x0001041D;
224 static const msg_num_t LOGMSG_QUANT_MERGE_COMPONENT_SUCCESS = 0x0001041E;
225 static const msg_num_t LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE = 0x0001041F;
226 static const msg_num_t LOGMSG_QUANT_RT_OFFSET_LOOKUP = 0x00010420;
227 static const msg_num_t LOGMSG_QUANT_TIME_ALIGN_INDEX_MZ_RANGE1 = 0x00010421;
228
229
230 // ms_matrix (mathematical matrix, not matrix science) debugging
231 static const msg_num_t LOGMSG_MATRIX_OUTPUT_VALS = 0x00010500;
232
233 // ms_aahelper tracing
234 static const msg_num_t LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS = 0x00010600;
235 static const msg_num_t LOGMSG_AAHELPER_REGULAR_ION_REJECT = 0x00010601;
236 static const msg_num_t LOGMSG_AAHELPER_REGULAR_ION_ADD = 0x00010602;
237 static const msg_num_t LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT= 0x00010603;
238 static const msg_num_t LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD = 0x00010604;
239 static const msg_num_t LOGMSG_AAHELPER_IMMONIUM_ION_REJECT = 0x00010605;
240 static const msg_num_t LOGMSG_AAHELPER_IMMONIUM_ION_ADD = 0x00010606;
241 static const msg_num_t LOGMSG_AAHELPER_INTERNAL_ION_REJECT = 0x00010607;
242 static const msg_num_t LOGMSG_AAHELPER_INTERNAL_ION_ADD = 0x00010608;
243 static const msg_num_t LOGMSG_AAHELPER_CROSSLINKED_START = 0x00010609;
244 static const msg_num_t LOGMSG_AAHELPER_MULTINL_INDICES = 0x0001060A;
245 static const msg_num_t LOGMSG_AAHELPER_MASTER_NL_VALS = 0x0001060B;
246 static const msg_num_t LOGMSG_AAHELPER_TOTAL_NL_VALS = 0x0001060C;
247 static const msg_num_t LOGMSG_AAHELPER_CUMULATIVE_MASS_NL = 0x0001060D;
248 static const msg_num_t LOGMSG_AAHELPER_SERIES_PARAMS = 0x0001060E;
249 static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED = 0x0001060F;
250 static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES = 0x00010610;
251 static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE = 0x00010611;
252 static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE = 0x00010612;
253 static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES = 0x00010613;
254 static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE = 0x00010614;
255 static const msg_num_t LOGMSG_AAHELPER_ETMOD_LOOKUP = 0x00010615;
256 static const msg_num_t LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT = 0x00010616;
257 static const msg_num_t LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG = 0x00010617;
258 static const msg_num_t LOGMSG_AAHELPER_CFR_START_FRAGMENTS = 0x00010618;
259 static const msg_num_t LOGMSG_AAHELPER_CROSSLINKED_END = 0x00010619;
260 static const msg_num_t LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT = 0x0001061A;
261 static const msg_num_t LOGMSG_AAHELPER_CFR_MASSES_VALUE = 0x0001061B;
262 static const msg_num_t LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE = 0x0001061C;
263 static const msg_num_t LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER = 0x0001061D;
264 static const msg_num_t LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK = 0x0001061E;
265 static const msg_num_t LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK = 0x0001061F;
266
267 // ms_proteininference tracing
268 static const msg_num_t LOGMSG_PROTINFER_FIND_FAMILY_START = 0x00010700;
269 static const msg_num_t LOGMSG_PROTINFER_FIND_FAMILY_QUEUE = 0x00010701;
270 static const msg_num_t LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS = 0x00010702;
271 static const msg_num_t LOGMSG_PROTINFER_PEPTIDE_MATRIX = 0x00010703;
272 static const msg_num_t LOGMSG_PROTINFER_FIND_FAMILY_END = 0x00010704;
273 static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_START = 0x00010705;
274 static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST = 0x00010706;
275 static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST = 0x00010707;
276 static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST = 0x00010708;
277 static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION = 0x00010709;
278 static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST = 0x0001070A;
279 static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST = 0x0001070B;
280 static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST = 0x0001070C;
281 static const msg_num_t LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO = 0x0001070D;
282 static const msg_num_t LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT = 0x0001070E;
283 static const msg_num_t LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST = 0x0001070F;
284 static const msg_num_t LOGMSG_PROTINFER_CHOOSE_NEXT_START = 0x00010710;
285 static const msg_num_t LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY = 0x00010711;
286 static const msg_num_t LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST = 0x00010712;
287 static const msg_num_t LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP = 0x00010713;
288 static const msg_num_t LOGMSG_PROTINFER_REMOVE_CONFLICTING_START = 0x00010714;
289 static const msg_num_t LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP = 0x00010715;
290 static const msg_num_t LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD = 0x00010716;
291 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_START = 0x00010717;
292 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE = 0x00010718;
293 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED = 0x00010719;
294 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS = 0x0001071A;
295 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE = 0x0001071B;
296 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS = 0x0001071C;
297 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN = 0x0001071D;
298 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN = 0x0001071E;
299 static const msg_num_t LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT = 0x0001071F;
300 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD = 0x00010720;
301 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN = 0x00010721;
302 static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_DONE = 0x00010722;
303 static const msg_num_t LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START = 0x00010723;
304 static const msg_num_t LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START = 0x00010724;
305 static const msg_num_t LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END = 0x00010725;
306 static const msg_num_t LOGMSG_PROTINFER_CLUSTER_FROM_ACC = 0x00010726;
307 static const msg_num_t LOGMSG_PROTINFER_GROUP_FROM_ACC = 0x00010727;
308 static const msg_num_t LOGMSG_PROTINFER_SINGLETON_FROM_ACC = 0x00010728;
309 static const msg_num_t LOGMSG_PEPSUM_GETHIT = 0x00010729;
310 static const msg_num_t LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY = 0x0001072A;
311 static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN = 0x0001072B;
312
313 // ms_quant_helper tracing
314 static const msg_num_t LOGMSG_QUANT_HELPER_TEST_REQUIRED = 0x00010800;
315
316 // Generic tracing messages
317 static const msg_num_t LOGMSG_REPORT_FUNCTION_CALLED_BY = 0x00010900;
318 static const msg_num_t LOGMSG_REPORT_FUNCTION_ENTRY = 0x00010901;
319 static const msg_num_t LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 = 0x00010902;
320 static const msg_num_t LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 = 0x00010903;
321 static const msg_num_t LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 = 0x00010904;
322 static const msg_num_t LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 = 0x00010905;
323
324 static const msg_num_t LOGMSG_REPORT_FUNCTION_EXIT = 0x00010910;
325 static const msg_num_t LOGMSG_REPORT_FUNCTION_EXIT_WITH = 0x00010911;
326
327 // ms_mascotresfilebase or ms_mascotresults tracing
328 static const msg_num_t LOGMSG_RESFILE_APPEND = 0x00010A00;
329 static const msg_num_t LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR = 0x00010A01;
330 static const msg_num_t LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET = 0x00010A02;
331 static const msg_num_t LOGMSG_GET_THR_LOOP_BODY_START = 0x00010A03;
332 static const msg_num_t LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT = 0x00010A04;
333 static const msg_num_t LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND = 0x00010A05;
334 static const msg_num_t LOGMSG_GET_THR_REACH_COND = 0x00010A06;
335 static const msg_num_t LOGMSG_NON_DEFAULT_HOMOLOGY_THRESHOLD = 0x00010A07;
336
337 static const msg_num_t LOGMSG_MSR2DAT28_SQL_TRACING = 0x00010B00;
338
339 public:
341 ms_log();
342
344 virtual ~ms_log();
345
346 public:
347#ifndef SWIG
348#if defined(_INTERNAL_USE_AND_HAVE_BOOST_FORMAT) || defined(DOXYGEN_SHOULD_SKIP_THIS)
349
351
358 void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum) {
359 ms_log::msg_sev severity;
360 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
361 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
362 }
363
364
366 template <typename T1>
367 void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1);
368
370 template <typename T1, typename T2>
371 void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2);
372
374 template <typename T1, typename T2, typename T3>
375 void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3);
376
378 template <typename T1, typename T2, typename T3, typename T4>
379 void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4);
380
382 template <typename T1, typename T2, typename T3, typename T4, typename T5>
383 void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5);
384
386 template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6>
387 void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6);
388
390 template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7>
391 void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7);
392
394 template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7, typename T8>
395 void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7, T8 arg8);
396
398 template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7, typename T8, typename T9>
399 void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7, T8 arg8, T9 arg9);
400#endif
401#endif
402
404 virtual msg_sev getLoggingLevel() const = 0;
405
407 bool willMessageBeLogged(const msg_num_t msgNum) const;
408
410 std::string _lookUpMsg(const ms_log::msg_num_t msgNum, ms_log::msg_sev & severity) const;
411
413 ms_log::msg_sev getMessageSeverity(const ms_log::msg_num_t msgNum) const;
414
416 ms_loggingmonitor::Source_e getMessageSource(const ms_log::msg_num_t msgNum) const;
417
418#ifndef SWIG
419 enum errorOrLogMessages_e { MSG_LOG, MSG_ERR };
420
422 void addToCatalog(const msg_catalog_t catalog[], size_t numEntries, ms_loggingmonitor::Source_e src, errorOrLogMessages_e errorOrLogMessages);
423#endif
424
425 protected:
426 virtual void _setError(const int /* ms_errs::err*/ errorNum,
427 const char* strBuffer,
428 const msg_sev severity,
429 const std::string & sessionID = "",
430 const int userID = -1,
431 const int srcLineNumber = -1,
432 const char * srcFileName = "") = 0;
433
434 private:
435 typedef std::pair<ms_loggingmonitor::Source_e, errorOrLogMessages_e> msgsSrcAndType_t;
436 catalog_map_t& getGlobalCatalog() const;
437 std::set<msgsSrcAndType_t>& getGlobalAddedToCatalog() const;
438 }; // class ms_log
439 // end of error_handling_group
441} // namespace matrix_science
442
443#ifndef SWIG
444#ifdef _INTERNAL_USE_AND_HAVE_BOOST_FORMAT
445#include "private/ms_log_impl.hpp"
446#endif
447#endif
448
449
450#endif // MS_LOG_HPP
451
452/*------------------------------- End of File -------------------------------*/
matrix_science::ms_log
Definitions for logging messages.
Definition: ms_log.hpp:39
matrix_science::ms_log::getLoggingLevel
virtual msg_sev getLoggingLevel() const =0
Get the logging level.
matrix_science::ms_log::msg_num_t
int msg_num_t
Typedef for log and error message numbers.
Definition: ms_log.hpp:127
matrix_science::ms_log::msg_sev
msg_sev
Message severity levels.
Definition: ms_log.hpp:47
matrix_science::ms_loggingmonitor::Source_e
Source_e
Logging event source.
Definition: ms_logging.hpp:65
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_log_impl.hpp Source File

  • inc
  • private
ms_log_impl.hpp
1/*
2##############################################################################
3# file: ms_log_impl.hpp #
4# 'msparser' toolkit #
5# Included from ms_log.hpp - but conditionally for when building the library #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2018 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /Mowse/ms_mascotresfile/include/ms_errors.hpp $ #
13# $Author: dcreasy@matrixscience.com $ #
14# $Date: 2020-02-17 11:03:19 +0000 $ #
15# $Revision: 16a3f4baa19a07d69f3cdf5833b81caa60bbc674 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_LOG_IMPL_HPP
21#define MS_LOG_IMPL_HPP
22
23
24#ifndef SWIG
25#if defined(_INTERNAL_USE_AND_HAVE_BOOST_FORMAT) || defined(DOXYGEN_SHOULD_SKIP_THIS)
26
27#include "boost/format.hpp"
28
29namespace matrix_science {
30
31
32
33// It's OK to have templated functions in this file.
34// If the code for this, non template, function is added here you will
35// get multiply defined link warnings
36/*
37void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum)
38{
39 ms_log::msg_sev severity;
40 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
41 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
42} */
43
52template <typename T1>
53void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1) {
54 if (willMessageBeLogged(msgNum)) {
55 ms_log::msg_sev severity;
56 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
57 boost::format fmter(unformattedMsg);
58 if (fmter.expected_args() == 1) {
59 fmter % arg1;
60 _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
61 } else {
62 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
63 }
64 }
65}
66
76template <typename T1, typename T2>
77void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2) {
78 if (willMessageBeLogged(msgNum)) {
79 ms_log::msg_sev severity;
80 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
81 boost::format fmter(unformattedMsg);
82 if (fmter.expected_args() == 2) {
83 fmter % arg1 %arg2;
84 _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
85 } else {
86 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
87 }
88 }
89}
90
101template <typename T1, typename T2, typename T3>
102void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3) {
103 if (willMessageBeLogged(msgNum)) {
104 ms_log::msg_sev severity;
105 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
106 boost::format fmter(unformattedMsg);
107 if (fmter.expected_args() == 3) {
108 fmter % arg1 %arg2 %arg3;
109 _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
110 } else {
111 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
112 }
113 }
114}
115
116
128template <typename T1, typename T2, typename T3, typename T4>
129void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4) {
130 if (willMessageBeLogged(msgNum)) {
131 ms_log::msg_sev severity;
132 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
133 boost::format fmter(unformattedMsg);
134 if (fmter.expected_args() == 4) {
135 fmter % arg1 %arg2 %arg3 %arg4;
136 _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
137 } else {
138 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
139 }
140 }
141}
142
143
156template <typename T1, typename T2, typename T3, typename T4, typename T5>
157void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5) {
158 if (willMessageBeLogged(msgNum)) {
159 ms_log::msg_sev severity;
160 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
161 boost::format fmter(unformattedMsg);
162 if (fmter.expected_args() == 5) {
163 fmter % arg1 %arg2 %arg3 %arg4 %arg5;
164 _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
165 } else {
166 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
167 }
168 }
169}
170
184template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6>
185void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6) {
186 if (willMessageBeLogged(msgNum)) {
187 ms_log::msg_sev severity;
188 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
189 boost::format fmter(unformattedMsg);
190 if (fmter.expected_args() == 6) {
191 fmter % arg1 %arg2 %arg3 %arg4 %arg5 %arg6;
192 _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
193 } else {
194 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
195 }
196 }
197}
198
213template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7>
214void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7) {
215 if (willMessageBeLogged(msgNum)) {
216 ms_log::msg_sev severity;
217 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
218 boost::format fmter(unformattedMsg);
219 if (fmter.expected_args() == 7) {
220 fmter % arg1 %arg2 %arg3 %arg4 %arg5 %arg6 %arg7;
221 _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
222 }
223 else {
224 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
225 }
226 }
227}
228
244template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7, typename T8>
245void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7, T8 arg8) {
246 if (willMessageBeLogged(msgNum)) {
247 ms_log::msg_sev severity;
248 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
249 boost::format fmter(unformattedMsg);
250 if (fmter.expected_args() == 8) {
251 fmter % arg1 %arg2 %arg3 %arg4 %arg5 %arg6 %arg7 %arg8;
252 _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
253 }
254 else {
255 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
256 }
257 }
258}
259
276template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7, typename T8, typename T9>
277void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7, T8 arg8, T9 arg9) {
278 if (willMessageBeLogged(msgNum)) {
279 ms_log::msg_sev severity;
280 std::string unformattedMsg = _lookUpMsg(msgNum, severity);
281 boost::format fmter(unformattedMsg);
282 if (fmter.expected_args() == 9) {
283 fmter % arg1 %arg2 %arg3 %arg4 %arg5 %arg6 %arg7 %arg8 %arg9;
284 _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
285 }
286 else {
287 _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
288 }
289 }
290}
291
292#endif
293#endif
294
295} // namespace matrix_science
296
297#endif // MS_LOG_IMPL_HPP
298
299/*------------------------------- End of File -------------------------------*/
matrix_science::ms_log::msg_num_t
int msg_num_t
Typedef for log and error message numbers.
Definition: ms_log.hpp:127
matrix_science::ms_log::willMessageBeLogged
bool willMessageBeLogged(const msg_num_t msgNum) const
Check to see if the message will be logged to a file or recorded anywhere.
Definition: ms_log.cpp:277
matrix_science::ms_log::msg_sev
msg_sev
Message severity levels.
Definition: ms_log.hpp:47
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_logging.hpp Source File

  • inc
ms_logging.hpp
1/*
2##############################################################################
3# File: ms_logging.hpp #
4# Mascot Parser toolkit #
5# Encapsulates general purpose objects which act as conduits for receiving #
6# and processing logging events #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 2015-2016 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Source: parser/inc/ms_logging.hpp $
13# $Author: villek@matrixscience.com $
14# $Date: 2023-02-02 12:03:35 +0000 $
15# $Revision: 8c2d6b85f91e6cca912bc94ab2625c1a32b7a55c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
16##############################################################################
17*/
18
19#ifndef MS_LOGGING_HPP
20#define MS_LOGGING_HPP
21
22
23// Includes from the standard template library
24#include <string>
25#include <vector>
26#include <list>
27
28namespace msparser_internal {
29 class ms_loggingmonitor_impl;
30}
31
32namespace matrix_science {
33 class ms_logger;
34
40
43 class MS_MASCOTRESFILE_API ms_loggingmonitor
44 {
45 public:
47
51 enum Level_e {
52 LVL_NONE = 0,
53 LVL_ERROR = 1,
54 LVL_WARNING = 2,
55 LVL_INFO = 4,
56 LVL_DEBUG1 = 8,
57 LVL_DEBUG2 = 16,
58 LVL_DEBUG3 = 32
59 }; // enum LogLevel_e
60
62
65 enum Source_e {
66 SRC_APPLICATION = 1,
67 SRC_MASCOTSERVER = 2,
68 SRC_MSPARSER = 3,
69 SRC_MDRO = 4,
70 SRC_MSQUANTLIB = 5,
71 SRC_PURIFIERAPI = 6,
72 SRC_PURIFIERAPP = 7,
73 SRC_DENOVOLIB = 8,
74 SRC_VENDORSTART = 100,
75 SRC_ALL = 0xFFFF
76 }; // enum LogSource_e
77
78 private:
79 msparser_internal::ms_loggingmonitor_impl *pImpl_;
80 static ms_loggingmonitor defaultLoggingMonitor;
81
82 public:
84 ms_loggingmonitor();
85
87 virtual ~ms_loggingmonitor();
88
90 virtual int addLogEventsHandler(ms_logger& logger);
91
93 virtual bool removeLogEventsHandler(const int uid);
94
96 virtual ms_logger * getLogEventsHandler(const int uid);
97
99 virtual int getNumLogEventsHandlers() const;
100
102 virtual void logMessage(Level_e eSeverity,
103 Source_e eSource,
104 long lMsgId,
105 const std::string & text,
106 const char * srcFileName,
107 const int srcFileLineNum,
108 long lContextId=0) const;
109
111 virtual long getLogMask(unsigned source = SRC_ALL);
112
114 virtual void setLogMask(long newVal, unsigned source = SRC_ALL);
115
117 static matrix_science::ms_loggingmonitor & getDefaultMonitor();
119 static void setDefaultMonitor(ms_loggingmonitor & loggingMonitor);
120
122 static std::string messageSourceAsText(Source_e eSource);
123
125 static std::string severityAsText(Level_e eSeverity);
126
127 }; // class ms_loggingmonitor
128
130
137 class MS_MASCOTRESFILE_API ms_logger {
138 public:
140
151 enum LogOutputColumns_e {
152 COL_ASC_TIME = 0x0001,
153 COL_ISO8601_TIME = 0x0002,
154 COL_IP_ADDRESS = 0x0004,
155 COL_MSG_NUM_DEC = 0x0008,
156 COL_MSG_NUM_HEX = 0x0010,
157 COL_SEVERITY_NUM = 0x0020,
158 COL_SEVERITY_TXT = 0x0040,
159 COL_MSG_SOURCE_TXT = 0x0080,
160 COL_SRC_FILE = 0x0100,
161 COL_SRC_LINENUM = 0x0200,
162 COL_THREAD_ID = 0x0400,
163 COL_MSG = 0x0800,
164
165 COL_TSV = 0x1000,
166 COL_QUOTES = 0x2000,
167 COL_HEADERS = 0x4000,
168
169 COL_LOGGER_DEFAULTS = COL_ISO8601_TIME | COL_MSG_NUM_HEX | COL_SEVERITY_TXT | COL_MSG_SOURCE_TXT | COL_SRC_FILE | COL_SRC_LINENUM | COL_MSG | COL_HEADERS
170 };
171
173 ms_logger(const unsigned int colsToOutput = COL_MSG);
174
176 virtual ~ms_logger() {}
177
179 virtual void onLogMessage(ms_loggingmonitor::Level_e eSeverity,
180 ms_loggingmonitor::Source_e eSource,
181 long lMsgId,
182 const std::string & text,
183 const char * srcFileName,
184 const int srcFileLineNum,
185 long lContextId=0)=0;
186
188 virtual unsigned int getColsToOutput() const;
189
191 virtual void setColsToOutput(const unsigned int colsToOutput);
192
194 std::string formatMessage(ms_loggingmonitor::Level_e eSeverity,
195 ms_loggingmonitor::Source_e eSource,
196 long lMsgId,
197 const std::string & text,
198 const char * srcFileName,
199 const int srcFileLineNum,
200 long lContextId) const;
201
203 std::string getHeaderLine() const;
204
205 protected:
206 unsigned int colsToOutput_;
207 }; // class ms_logger
208
210 class MS_MASCOTRESFILE_API ms_stdout_logger : public ms_logger {
211 public:
213 ms_stdout_logger(unsigned int colsToOutput = ms_logger::COL_LOGGER_DEFAULTS);
215 virtual ~ms_stdout_logger();
216
218 virtual void onLogMessage(ms_loggingmonitor::Level_e eSeverity,
219 ms_loggingmonitor::Source_e eSource,
220 long lMsgId,
221 const std::string & text,
222 const char * srcFileName,
223 const int srcFileLineNum,
224 long lContextId=0);
225
226 }; // class ms_stdout_logger
227
229 class MS_MASCOTRESFILE_API ms_file_logger : public ms_logger {
230 public:
232 ms_file_logger(const std::string logFileName, unsigned int colsToOutput = ms_logger::COL_LOGGER_DEFAULTS);
233
235 virtual ~ms_file_logger();
236
238 std::string getLogFilename();
239
241 virtual void onLogMessage(ms_loggingmonitor::Level_e eSeverity,
242 ms_loggingmonitor::Source_e eSource,
243 long lMsgId,
244 const std::string & text,
245 const char * srcFileName,
246 const int srcFileLineNum,
247 long lContextId=0);
248
249 private:
250 std::string logfilename_;
251
252 }; // class ms_file_logger
253
255 class MS_MASCOTRESFILE_API ms_buffer_logger : public ms_logger {
256 public:
258 ms_buffer_logger(unsigned int colsToOutput = ms_logger::COL_LOGGER_DEFAULTS);
259
261 virtual ~ms_buffer_logger();
262
264 std::vector<std::string> flush();
265
267 virtual void onLogMessage(ms_loggingmonitor::Level_e eSeverity,
268 ms_loggingmonitor::Source_e eSource,
269 long lMsgId,
270 const std::string & text,
271 const char * srcFileName,
272 const int srcFileLineNum,
273 long lContextId=0);
274
275 private:
276 std::list<std::string> messages_;
277 std::list<std::string>::size_type numMessages_;
278
279 }; // class ms_file_logger
280 // end of error_handling_group
282} // namespace matrix_science
283
284#endif // MS_LOGGING_HPP
285
286/*------------------------------- End of File -------------------------------*/
matrix_science::ms_buffer_logger
Concrete class which implements ms_logger and stores log text in memory.
Definition: ms_logging.hpp:255
matrix_science::ms_file_logger
Concrete class which implements ms_logger and outputs log text to the specified file.
Definition: ms_logging.hpp:229
matrix_science::ms_logger
Abstract class which provides the interface used by ms_logging monitor to delegate logging events.
Definition: ms_logging.hpp:137
matrix_science::ms_logger::~ms_logger
virtual ~ms_logger()
Destructor.
Definition: ms_logging.hpp:176
matrix_science::ms_logger::LogOutputColumns_e
LogOutputColumns_e
Logging output columns.
Definition: ms_logging.hpp:151
matrix_science::ms_logger::onLogMessage
virtual void onLogMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)=0
Processes and handles the passed logging message.
matrix_science::ms_loggingmonitor
Monitor class to delegate logging events generated from multiple sources.
Definition: ms_logging.hpp:44
matrix_science::ms_loggingmonitor::Level_e
Level_e
Logging severity levels.
Definition: ms_logging.hpp:51
matrix_science::ms_loggingmonitor::Source_e
Source_e
Logging event source.
Definition: ms_logging.hpp:65
matrix_science::ms_loggingmonitor::logMessage
virtual void logMessage(Level_e eSeverity, Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) const
Logs the passed message with all registered ms_logger objects.
matrix_science::ms_stdout_logger
Concrete class which implements ms_logger and outputs log text to standard out.
Definition: ms_logging.hpp:210
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_loggingmonitor_impl.hpp Source File

  • src
  • common
ms_loggingmonitor_impl.hpp
1/*
2##############################################################################
3# File: ms_loggingmonitor_impl.hpp #
4# Mascot Parser toolkit #
5# Private implementation of ms_loggingmonitor
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 2015-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source$
12# $Author$
13# $Date$
14# $Revision$
15##############################################################################
16*/
17
18#ifndef MS_LOGGINGMONITOR_IMPL_HPP
19#define MS_LOGGINGMONITOR_IMPL_HPP
20
21#include "ms_logging.hpp"
22
23#include <map>
24
25namespace msparser_internal {
26 // Bug 12291: Logging monitor must use the pImpl pattern, because we
27 // don't want to leak the mutex class in the public API.
28
29 class ms_loggingmonitor_impl
30 {
31 public:
32 ms_loggingmonitor_impl();
33 ~ms_loggingmonitor_impl();
34
35 int addLogEventsHandler(matrix_science::ms_logger &logger);
36
37 bool removeLogEventsHandler(const int uid);
38
39 matrix_science::ms_logger* getLogEventsHandler(const int uid);
40
41 int getNumLogEventsHandlers() const;
42
43 void logMessage(matrix_science::ms_loggingmonitor::Level_e eSeverity,
44 matrix_science::ms_loggingmonitor::Source_e eSource,
45 long lMsgId,
46 const std::string & text,
47 const char * srcFileName,
48 const int srcFileLineNum,
49 long lContextId=0) const;
50
51 long getLogMask(unsigned source) const;
52
53 void setLogMask(long newVal, unsigned source);
54
55 private:
56 mutable ms_mutex loggingMutex_;
57 bool _isMaskedOut(matrix_science::ms_loggingmonitor::Level_e eLvl, matrix_science::ms_loggingmonitor::Source_e eSource) const;
58 std::map<long, long> logMask_; // source -> mask
59 int nextuid_;
60 typedef std::map<const int, matrix_science::ms_logger *> loggers_t;
61 loggers_t loggers_;
62
63 };
64} // msparser_internal
65
66#endif // MS_LOGGINGMONITOR_IMPL_HPP
67
68/*------------------------------- End of File -------------------------------*/
matrix_science::ms_logger
Abstract class which provides the interface used by ms_logging monitor to delegate logging events.
Definition: ms_logging.hpp:137
matrix_science::ms_loggingmonitor::Level_e
Level_e
Logging severity levels.
Definition: ms_logging.hpp:51
matrix_science::ms_loggingmonitor::Source_e
Source_e
Logging event source.
Definition: ms_logging.hpp:65
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotfiles.hpp Source File

  • inc
ms_mascotfiles.hpp
1/*
2##############################################################################
3# file: ms_mascotfiles.hpp #
4# 'msparser' toolkit #
5# Contains pathes to some configuration files #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_mascotfiles.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTFILES_HPP
20#define MS_MASCOTFILES_HPP
21
22
23#include <string>
24
25
26namespace matrix_science {
33
52 class MS_MASCOTRESFILE_API ms_mascotfiles: public ms_customproperty
53 {
54 friend class ms_datfile;
55 public:
56
58 ms_mascotfiles();
59
61 ms_mascotfiles(const ms_mascotfiles& src);
62
64 ~ms_mascotfiles();
65
67 void defaultValues();
68
70 void copyFrom(const ms_mascotfiles* right);
71
72#ifndef SWIG
74 ms_mascotfiles& operator=(const ms_mascotfiles& right);
75#endif
77 std::string getModifications() const;
78
80 void setModifications(const char* filename);
81
83 std::string getEnzymes() const;
84
86 void setEnzymes(const char* filename);
87
89 std::string getFrequencies() const;
90
92 void setFrequencies(const char* filename);
93
95 std::string getNodeListFile() const;
96
98 void setNodeListFile(const char* filename);
99
100#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
101#include "suppress_ms_customproperty.hpp"
102#endif
103
104 private:
105 std::string mods_;
106 std::string enzymes_;
107 std::string freqs_;
108 std::string nodeListFile_;
109 };// class ms_mascotfiles // end of config_group
111
112} // namespace matrix_science
113
114#endif // MS_MASCOTFILES_HPP
115
116/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_mascotfiles
An instance of this class contains configuration files paths (except for mascot.dat).
Definition: ms_mascotfiles.hpp:53
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotoptions.hpp Source File

  • inc
ms_mascotoptions.hpp
1/*
2##############################################################################
3# file: ms_mascotoptions.hpp #
4# 'msparser' toolkit #
5# Encapsulates "Options" section of "mascot.dat" file that describes most #
6# important parameters #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /Mowse/ms_mascotresfile/include/ms_mascotoptions.hpp $ #
13# $Author: villek@matrixscience.com $ #
14# $Date: 2024-09-23 16:44:58 +0100 $ #
15# $Revision: 36c172aa7a374da00801ddc253b196c3974597d0 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_MASCOTOPTIONS_HPP
21#define MS_MASCOTOPTIONS_HPP
22
23
24#include <string>
25#include <vector>
26
27namespace matrix_science {
32#ifndef DOXYGEN_SHOULD_SKIP_THIS
33 class MS_MASCOTRESFILE_API ms_blastaccession
34 {
35 friend class ms_datfile;
36
37 public:
38 ms_blastaccession();
39 ms_blastaccession(const ms_blastaccession& src);
40 ~ms_blastaccession();
41
42 void defaultValues();
43 void copyFrom(const ms_blastaccession* right);
44#ifndef SWIG
45 ms_blastaccession& operator=(const ms_blastaccession& right);
46#endif
47 bool isUseRegex() const;
48 void setUseRegex(const bool flag);
49
50 int getMinLength() const;
51 void setMinLength(const int value);
52
53 const char* getStart() const;
54 const char* getStop() const;
55
56 private:
57
58 bool useRegex_;
59 int minLen_;
60 char start_[255];
61 char stop_[255];
62 }; // class ms_blastaccession
63#endif
64
66
90 class MS_MASCOTRESFILE_API ms_mascotoptions: public ms_customproperty
91 {
92 friend class ms_datfile;
93
94 public:
96
99 enum MS_REVIEW_COL
100 {
101 MS_REVIEW_COL_JOB = 0x0000,
102 MS_REVIEW_COL_PID = 0x0001,
103 MS_REVIEW_COL_DATABASE = 0x0002,
104 MS_REVIEW_COL_USERNAME = 0x0003,
105 MS_REVIEW_COL_USEREMAIL = 0x0004,
106 MS_REVIEW_COL_TITLE = 0x0005,
107 MS_REVIEW_COL_RESULTS_FILE = 0x0006,
108 MS_REVIEW_COL_START_TIME = 0x0007,
109 MS_REVIEW_COL_DURATION = 0x0008,
110 MS_REVIEW_COL_STATUS = 0x0009,
111 MS_REVIEW_COL_PRIORITY = 0x000A,
112 MS_REVIEW_COL_SEARCHTYPE = 0x000B,
113 MS_REVIEW_COL_ENZYMEUSED = 0x000C,
114 MS_REVIEW_COL_IPADDRESS = 0x000D,
115 MS_REVIEW_COL_USERID = 0x000E,
116 MS_REVIEW_COL_PEAKLISTDATAFILE = 0x000F,
117 MS_REVIEW_COL____LAST___ = 0x0010
118 };
119
121
124 enum PERC_EXE_RT {
125 PERC_EXE_RT_USE_DEFAULT = 1,
126 PERC_EXE_RT_FORCE_ON = 2,
127 PERC_EXE_RT_FORCE_OFF = 3
128 };
129
131
156 enum DECOY_ALGORITHM {
157 DECOY_ALGORITHM_NONE = 0,
158 DECOY_PROTEIN_REVERSE = 1,
159 DECOY_PEPTIDE_REVERSE = 2,
160 DECOY_PROTEIN_RANDOM = 3,
161 DECOY_PEPTIDE_RANDOM = 4,
162 DECOY_PROTEIN_RANDOM_DIPEP = 5,
163 DECOY_PEPTIDE_RANDOM_DIPEP = 6,
164 DECOY_PROTEIN_SHUFFLE = 7,
165 DECOY_PEPTIDE_SHUFFLE = 8,
166
167 DECOY_PROTEIN_BASED_MASK = 0x0001
168 };
169
170
172
175 enum EXEC_AFTER_SEARCH
176 {
177 MAX_EXEC_AFTER_SEARCH = 10
178 };
179
180 enum REPORTBUILDER_COL_ARR
181 {
182 MAX_REPORTBUILDER_COL_ARR = 10
183 };
184
186 enum NUMERICAL_VALUE_STORAGE
187 {
188 MASS_DECIMAL_PLACES = 6
189 };
190
192 ms_mascotoptions();
193
195 ms_mascotoptions(const ms_mascotoptions& src);
196
198 ~ms_mascotoptions();
199
201 void copyFrom(const ms_mascotoptions* right);
202
203#ifndef SWIG
205 ms_mascotoptions& operator=(const ms_mascotoptions& right);
206#endif
208 void defaultValues();
209
211 bool isSectionAvailable() const;
212
214 void setSectionAvailable(const bool value);
215
217 bool isSaveLastQueryAsc() const;
218
220 void setSaveLastQueryAsc(const bool flag);
221
223 bool isSaveEveryLastQueryAsc() const;
224
226 void setSaveEveryLastQueryAsc(const bool flag);
227
229 std::string getLastQueryAscFile() const;
230
232 void setLastQueryAscFile(const char* str);
233
235 std::string getErrorLogFile() const;
236
238 void setErrorLogFile(const char* str);
239
241 std::string getSearchLogFile() const;
242
244 void setSearchLogFile(const char* str);
245
247 std::string getMonitorLogFile() const;
248
250 void setMonitorLogFile(const char* str);
251
253 std::string getInterFileBasePath() const;
254
256 void setInterFileBasePath(const char* str);
257
259 std::string getInterFileRelPath() const;
260
262 void setInterFileRelPath(const char* str);
263
265 std::string getMascotCmdLine() const;
266
268 void setMascotCmdLine(const char* str);
269
271 std::string getTestDirectory() const;
272
274 void setTestDirectory(const char* str);
275
277 std::string getMascotControlFile() const;
278
280 void setMascotControlFile(const char* str);
281
283 std::string getMascNodeCtrlFile() const;
284
286 void setMascNodeCtrlFile(const char* str);
287
289 std::string getMascotJobIdFile() const;
290
292 void setMascotJobIdFile(const char* str);
293
295 std::string getGetSeqJobIdFile() const;
296
298 void setGetSeqJobIdFile(const char* str);
299
301 int getUniqueJobStartNumber() const;
302
304 void setUniqueJobStartNumber(const int value);
305
307 std::string getResultsPerlScript() const;
308
310 void setResultsPerlScript(const char* str);
311
313 std::string getNoResultsScript() const;
314
316 void setNoResultsScript(const char* str);
317
319 std::string getResultsFullURL() const;
320
322 void setResultsFullURL(const char* str);
323
325 std::string getLogoImageFile() const;
326
328 void setLogoImageFile(const char* str);
329
331 int getMassDecimalPlaces() const;
332
334 void setMassDecimalPlaces(const int value);
335
337 int getIonsDecimalPlaces() const;
338
340 void setIonsDecimalPlaces(const int value);
341
343 int getIntensitySigFigs() const;
344
346 void setIntensitySigFigs(const int value);
347
349 bool isEmailUsersEnabled() const;
350
352 void setEmailUsersEnabled(const bool value);
353
355 bool isEmailErrorsEnabled() const;
356
358 void setEmailErrorsEnabled(const bool value);
359
361 int getMailTransport() const;
362
364 void setMailTransport(const int value);
365
367 std::string getEmailService() const;
368
370 void setEmailService(const char* str);
371
373 std::string getEmailPassword() const;
374
376 void setEmailPassword(const char* str);
377
379 std::string getEmailProfile() const;
380
382 void setEmailProfile(const char* str);
383
385 std::string getSendmailPath() const;
386
388 void setSendmailPath(const char* str);
389
391 std::string getEmailFromUser() const;
392
394 void setEmailFromUser(const char* str);
395
397 std::string getEmailFromTextName() const;
398
400 void setEmailFromTextName(const char* str);
401
403 int getEmailTimeOutPeriod() const;
404
406 void setEmailTimeOutPeriod(const int value);
407
409 int getMonitorEmailCheckFreq() const;
410
412 void setMonitorEmailCheckFreq(const int value);
413
415 std::string getMailTempFile() const;
416
418 void setMailTempFile(const char* str);
419
421 std::string getErrMessageEmailTo() const;
422
424 void setErrMessageEmailTo(const char* str);
425
427 int getMonitorTestTimeout() const;
428
430 void setMonitorTestTimeout(const int value);
431
433 std::string getNTMonitorGroup() const;
434
436 void setNTMonitorGroup(const char* str);
437
439 std::string getNTIUserGroup() const;
440
442 void setNTIUserGroup(const char* str);
443
445 int getUnixWebUserGroup() const;
446
448 void setUnixWebUserGroup(const int value);
449
451 bool isForkForUnixApache() const;
452
454 void setForkForUnixApache(const bool value);
455
457 std::string getFormVersion() const;
458
460 void setFormVersion(const char* str);
461
463 int getMaxSequenceLen() const;
464
466 void setMaxSequenceLen(const int value);
467
469 int getMaxConcurrentSearches() const;
470
472 void setMaxConcurrentSearches(const int value);
473
475 int getMaxSearchesPerUser() const;
476
478 void setMaxSearchesPerUser(const int value);
479
481 double getCentroidWidth() const;
482
484 void setCentroidWidth(const double value);
485
487 int getCentroidWidthCount() const;
488
490 void setCentroidWidthCount(const int value);
491
493 int getMaxDescriptionLen() const;
494
496 void setMaxDescriptionLen(const int value);
497
499 int getMaxNumPeptides() const;
500
502 void setMaxNumPeptides(const int value);
503
505 INT64 getVmemory() const;
506
508 void setVmemory(const INT64 value);
509
511 int getNumberOfReportNumberChoices() const;
512
514 void clearReportNumberChoices();
515
517 int getReportNumberChoice(const int index) const;
518
520 void setReportNumberChoice(const int index, const int value);
521
523 void appendReportNumberChoice(const int value);
524
526 int getNumberOfTargetFDRPercentages() const;
527
529 void clearTargetFDRPercentages();
530
532 double getTargetFDRPercentage(const int index) const;
533
535 void setTargetFDRPercentage(const int index, const double value, const bool makeDefault = false);
536
538 void appendTargetFDRPercentage(const double value, const bool makeDefault = false);
539
541 bool isDefaultTargetFDRPercentage(const int index) const;
542
544 void setDefaultTargetFDRPercentage(const int index);
545
547 int getReviewColWidth(const MS_REVIEW_COL index) const;
548
550 void setReviewColWidth(const MS_REVIEW_COL index, const int value);
551
553 bool getReviewColDisplay(const MS_REVIEW_COL index) const;
554
556 void setReviewColDisplay(const MS_REVIEW_COL index, const bool value);
557
559 std::string getReportBuilderColumnArrangement(const int index) const;
560
562 int getMaxNumOfReportBuilderColumnArrangements() const;
563
565 void setReportBuilderColumnArrangement(const int index, const std::string str);
566
568 std::string getSpectrumViewerColourSchemeString(const std::string &name) const;
569
571 std::vector<std::string> getSpectrumViewerColourSchemeNames() const;
572
574 void setSpectrumViewerColourSchemeString(const std::string &name, const std::string &str, bool doCheck = true);
575
577 std::string getSpectrumViewerDefaultColourSchemeName() const;
578
580 void setSpectrumViewerDefaultColourSchemeName(const std::string &name);
581
583 std::string getProxyType() const;
584
586 void setProxyType(const std::string &value);
587
589 bool isUseHTTPProxyForFTP() const;
590
592 void setUseHTTPProxyForFTP(const bool value);
593
595 bool isUseHTTPProxyForHTTPS() const;
596
598 void setUseHTTPProxyForHTTPS(const bool value);
599
601 std::string getProxyServer() const;
602
604 void setProxyServer(const char* str);
605
607 std::string getProxyUsername() const;
608
610 void setProxyUsername(const char* str);
611
613 std::string getProxyPassword() const;
614
616 void setProxyPassword(const char* str);
617
619 int getMinPepLenInPepSummary() const;
620
622 void setMinPepLenInPepSummary(const int value);
623
625 int getMaxQueries() const;
626
628 void setMaxQueries(const int value);
629
631 bool isShowSubsets() const;
632
634 void setShowSubsets(const bool value);
635
637 double getShowSubsets() const;
638
640 void setShowSubsets(const double value);
641
643 bool isRequireBoldRed() const;
644
646 void setRequireBoldRed(const bool value);
647
649 double getSigThreshold() const;
650
652 void setSigThreshold(const double value);
653
655 double getSiteAnalysisMD10Prob() const;
656
658 void setSiteAnalysisMD10Prob(const double value);
659
661 int getMaxVarMods() const;
662
664 void setMaxVarMods(const int value);
665
667 int getMaxEtVarMods() const;
668
670 void setMaxEtVarMods(const int value);
671
673 int getErrTolMaxAccessions() const;
674
676 void setErrTolMaxAccessions(const int value);
677
679 bool isLabelAll() const;
680
682 void setLabelAll(const bool value);
683
685 bool isShowAllFromErrorTolerant() const;
686
688 void setShowAllFromErrorTolerant(const bool value);
689
691 double getIgnoreIonsScoreBelow() const;
692
694 void setIgnoreIonsScoreBelow(const double value);
695
697 std::string getMonitorPidFile() const;
698
700 void setMonitorPidFile(const char* str);
701
703 bool isStoreModPermutations() const;
704
706 void setStoreModPermutations(const bool value);
707
709 int getProteinsInResultsFile() const;
710
712 void setProteinsInResultsFile(const int value);
713
715 std::string getMascotMessage() const;
716
718 void setMascotMessage(const char* str);
719
721 int getSplitNumberOfQueries() const;
722
724 void setSplitNumberOfQueries(const int value);
725
727 int getSplitDataFileSize() const;
728
730 void setSplitDataFileSize(const int value);
731
733 bool isMoveOldDbToOldDir() const;
734
736 void setMoveOldDbToOldDir(const bool value);
737
739 bool isRemoveOldIndexFiles() const;
740
742 void setRemoveOldIndexFiles(const bool value);
743
745 int getFeatureTableLength() const;
746
748 void setFeatureTableLength(const int value);
749
751 double getFeatureTableMinScore() const;
752
754 void setFeatureTableMinScore(const double value);
755
757 std::string getICATLight() const;
758
760 void setICATLight(const char* modName);
761
763 std::string getICATHeavy() const;
764
766 void setICATHeavy(const char* modName);
767
769 std::string getICATFilter() const;
770
772 void setICATFilter(const char* filterString);
773
775 std::string getICATQuantitationMethod() const;
776
778 void setICATQuantitationMethod(const char* methodName);
779
781 unsigned int getNumberOfIgnoreDupeAccessions() const;
782
784 void clearIgnoreDupeAccessions();
785
787 std::string getIgnoreDupeAccession(const unsigned int index) const;
788
790 void setIgnoreDupeAccession(const unsigned int index, const std::string value);
791
793 void appendIgnoreDupeAccession(const std::string value);
794
796 bool isInIgnoreDupeAccessionList(const std::string value) const;
797
799 int getUnixDirPerm() const;
800
802 void setUnixDirPerm(const int value);
803
805 bool isUnixDirPermDefined() const;
806
808 int getMudpit() const;
809
811 void setMudpit(const int value);
812
814 double getPrecursorCutOutLowerLimit() const;
815
817 void setPrecursorCutOutLowerLimit(const double value);
818
820 double getPrecursorCutOutUpperLimit() const;
821
823 void setPrecursorCutOutUpperLimit(const double value);
824
826 bool isAutoSelectCharge() const;
827
829 void setAutoSelectCharge(const bool value);
830
832 std::string getTaxBrowserUrl() const;
833
835 void setTaxBrowserUrl(const std::string value);
836
838 int getMinPepLenInSearch() const;
839
841 void setMinPepLenInSearch(const int value);
842
844 int getMaxPepModArrangements() const;
845
847 void setMaxPepModArrangements(const int value);
848
850 int getMaxPepNumVarMods() const;
851
853 void setMaxPepNumVarMods(const int value);
854
856 int getMaxPepNumModifiedSites() const;
857
859 void setMaxPepNumModifiedSites(const int value);
860
862 bool isIteratePMFIntensities() const;
863
865 void setIteratePMFIntensities(const bool value);
866
868 double getMinEtagMassDelta() const;
869
871 void setMinEtagMassDelta(const double value);
872
874 double getMaxEtagMassDelta() const;
875
877 void setMaxEtagMassDelta(const double value);
878
880 std::string getResultsFileFormatVersion() const;
881
883 void setResultsFileFormatVersion(const char *value);
884
886 std::string getSortUnassigned() const;
887
889 void setSortUnassigned(const std::string newValue);
890
892 int getSelectSwitch() const;
893
895 void setSelectSwitch(const int value);
896
898 double getMudpitSwitch() const;
899
901 void setMudpitSwitch(const double value);
902
904 int getMaxDatabases() const;
905
907 void setMaxDatabases(const int value);
908
910 std::string getCacheDirectory() const;
911
913 void setCacheDirectory(const char * value);
914
916 std::string getResfileCache() const;
917
919 void setResfileCache(const char * value);
920
922 std::string getResultsCache() const;
923
925 void setResultsCache(const char * value);
926
928 bool isPercolator() const;
929
931 void setPercolator(const bool value);
932
934 std::string getPercolatorFeatures() const;
935
937 void setPercolatorFeatures(std::string value);
938
940 int getPercolatorMinQueries() const;
941
943 void setPercolatorMinQueries(const int value);
944
946 int getPercolatorMinSequences() const;
947
949 void setPercolatorMinSequences(const int value);
950
952 bool isPercolatorUseProteins() const;
953
955 void setPercolatorUseProteins(const bool value);
956
958 bool isPercolatorUseRT() const;
959
961 void setPercolatorUseRT(const bool value);
962
964 std::string getPercolatorExeFlags(bool anyRetentionTimes,
965 const std::vector<std::string> percolatorFiles,
966 const PERC_EXE_RT rt = PERC_EXE_RT_USE_DEFAULT) const;
967
969 void setPercolatorExeFlags(const char * value);
970
972 int getPercolatorTargetRankScoreThreshold() const;
973
975 void setPercolatorTargetRankScoreThreshold(const int threshold);
976
978 double getPercolatorTargetRankRelativeThreshold() const;
979
981 void setPercolatorTargetRankRelativeThreshold(const double threshold);
982
984 int getCreatePipThreads() const;
985
987 void setCreatePipThreads(const int nThreads);
988
990 int getCreatePipThreadBlockSize() const;
991
993 void setCreatePipThreadBlockSize(const int blockSize);
994
996 int getExecAfterSearch(const char * szResultsFilePath,
997 std::vector<std::string> & commands,
998 std::vector<std::string> & titles,
999 std::vector<int> & waitfor,
1000 std::vector<int> & logging,
1001 std::vector<std::string> & additionalFlags,
1002 const char * sessionID = 0,
1003 const char * taskID = 0) const;
1004
1006 void setExecAfterSearch(const int num, std::string value);
1007
1009 std::string getResultsPerlScript_2() const;
1010
1012 void setResultsPerlScript_2(std::string value);
1013
1015 std::string getResultsFullURL_2() const;
1016
1018 void setResultsFullURL_2(std::string value);
1019
1021 int getProteinFamilySwitch() const;
1022
1024 void setProteinFamilySwitch(const int value);
1025
1027 int getDecoyTypeSpecific() const;
1028
1030 void setDecoyTypeSpecific(const int value);
1031
1033 int getDecoyTypeNoEnzyme() const;
1034
1036 void setDecoyTypeNoEnzyme(const int value);
1037
1039 int getSVGSpectrumSwitch() const;
1040
1042 void setSVGSpectrumSwitch(const int value);
1043
1045 int getDisplayNonSignificantMatches() const;
1046
1048 void setDisplayNonSignificantMatches(const int value);
1049
1051 std::string getCompressToolAA() const;
1052
1054 void setCompressToolAA(const std::string value);
1055
1057 std::string getCompressToolNA() const;
1058
1060 void setCompressToolNA(const std::string value);
1061
1063 std::string getCompressToolSL() const;
1064
1066 void setCompressToolSL(const std::string value);
1067
1069 std::string getCompressToolCommandLineFasta(DATABASE_TYPE dbType,
1070 const std::string & dbname,
1071 const std::string & dbpath) const;
1072
1074 std::string getCompressToolCommandLineLibrary(const std::string & logfilepath,
1075 const std::string & inputfile,
1076 const std::string & outputdirectory) const;
1077
1079 std::string getPepSearchTool() const;
1080
1082 void setPepSearchTool(const std::string value);
1083
1085 std::string getPepSearchToolCommandLine(const std::string & peptideToleranceUnit,
1086 const double & peptideTolerance,
1087 const std::string & ionToleranceUnit,
1088 const double & ionTolerance,
1089 const std::string & libraryDirectoryPath,
1090 const std::string & inputFileRelativePath,
1091 const std::string & outputFileRelativePath) const;
1092
1094 int getSpectraPerLibraryBlock() const;
1095
1097 void setSpectraPerLibraryBlock(const int value);
1098
1100 int getCrawlerNumPeaksPer100Da() const;
1101
1103 void setCrawlerNumPeaksPer100Da(const int value);
1104
1106 std::string getSearchSubmitMode() const;
1107
1109 void setSearchSubmitMode(const std::string value);
1110
1112 int getDechargeFragmentPeaks() const;
1113
1115 void setDechargeFragmentPeaks(const int maxCharge);
1116
1118 std::string getSearchSubmitOutputFormat() const;
1119
1121 void setSearchSubmitOutputFormat(const std::string value);
1122
1124 bool isAlwaysCreateDat28ResultsFile() const;
1125
1127 void setAlwaysCreateDat28ResultsFile(const bool value);
1128
1130 bool isCreateLegacyModAndSubstitutionFiles() const;
1131
1133 void setCreateLegacyModAndSubstitutionFiles(const bool value);
1134
1136 bool isAlwaysEnableAutoDecoySearch() const;
1137
1139 void setAlwaysEnableAutoDecoySearch(const bool value);
1140
1142 std::string getSearchSubmitAcceptedFileTypes() const;
1143
1145 void setSearchSubmitAcceptedFileTypes(const std::string value);
1146
1148 std::string getSearchSubmitDefaultPeptideCharge() const;
1149
1151 void setSearchSubmitDefaultPeptideCharge(const std::string value);
1152
1154
1156 const ms_blastaccession* getGetSeqBlastAccession() const;
1157
1159 void setGetSeqBlastAccession(const ms_blastaccession* value);
1160
1161 // MatrixScience internal usage only
1162 int getMinPeakIteration() const;
1163
1164 // MatrixScience internal usage only
1165 void setMinPeakIteration(const int value);
1166
1167 // MatrixScience internal usage only
1168 bool isEncryptURL() const;
1169
1170 // MatrixScience internal usage only
1171 void setEncryptURL(const bool value);
1172
1173 // MatrixScience internal usage only
1174 std::string getPercolatorExeFlags() const;
1175
1177 std::string getPercolatorRtFlags(const bool anyRetentionTimes, const bool useRT) const;
1178
1179 // MatrixScience internal usage only
1180 std::string getExecAfterSearch(const int num) const;
1181
1182 // MatrixScience internal usage only
1183 void checkExecAfterSearch(ms_errs & err);
1184
1185 // MatrixScience internal usage only
1186 void checkReportBuilderColumnArrangement(ms_errs & err);
1187
1188 // MatrixScience internal usage only
1189 void checkSpectrumViewerColourSchemes(ms_errs & err, bool addToList = true);
1190
1192 bool isMatchOppositeCrosslinkPairs() const;
1193
1195 void setMatchOppositeCrosslinkPairs(const bool value);
1196
1198 int getMaxIntactCrosslinkPeptides() const;
1199
1201 void setMaxIntactCrosslinkPeptides(const int value);
1202
1204 bool isTransferParsingToNodes() const;
1205
1207 void setTransferParsingToNodes(const bool value);
1208
1210 int getMascotFileProcessingThreads() const;
1211
1213 void setMascotFileProcessingThreads(const int value);
1214
1216 int getInputFileParsingThreads() const;
1217
1219 void setInputFileParsingThreads(const int value);
1220
1222 int getChunkReadingThreads() const;
1223
1225 void setChunkReadingThreads(const int value);
1226
1228 int getChunkPreparationThreads() const;
1229
1231 void setChunkPreparationThreads(const int value);
1232
1234 bool isMsrSqlQueriesInTransactions() const;
1235
1237 void setMsrSqlQueriesInTransactions(const bool value);
1238
1240 bool getAllowEmbeddedConfigInMimeInput() const;
1241
1243 void setAllowEmbeddedConfigInMimeInput(const bool value);
1244
1245
1246#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
1247#include "suppress_ms_customproperty.hpp"
1248#endif
1249
1250 private:
1251 void synchronizeReportNumberChoices_();
1252 void synchronizeIgnoreDupeAccession_();
1253 void synchronizeTargetFDRPercentages_();
1254
1255 bool sectionAvailable_;
1256
1257 bool saveLastQueryAsc_;
1258 bool saveEveryLastQueryAsc_;
1259 std::string lastQueryAscFile_;
1260
1261 std::string errorLogFile_;
1262 std::string searchLogFile_;
1263 std::string monitorLogFile_;
1264 std::string interFileBasePath_;
1265 std::string interFileRelPath_;
1266
1267 std::string mascotCmdLine_;
1268 std::string testDirectory_;
1269 std::string mascotControlFile_;
1270 std::string mascNodeCtrlFile_;
1271 std::string mascotJobIdFile_;
1272 std::string getSeqJobIdFile_;
1273 int uniqueJobStartNumber_;
1274
1275 std::string resultsPerlScript_;
1276 std::string noResultsScript_;
1277 std::string resultsFullURL_;
1278 std::string logoImageFile_;
1279
1280 int massDecimalPlaces_;
1281 int ionsDecimalPlaces_;
1282 int intensitySigFigs_;
1283
1284 bool emailUsersEnabled_;
1285 bool emailErrorsEnabled_;
1286 int mailTransport_;
1287 std::string emailService_;
1288 std::string emailPassword_;
1289 std::string emailProfile_;
1290 std::string sendmailPath_;
1291 std::string emailFromUser_;
1292 std::string emailFromTextName_;
1293 int emailTimeOutPeriod_;
1294 int monitorEmailCheckFreq_;
1295 std::string mailTempFile_;
1296 std::string errMessageEmailTo_;
1297
1298 int monitorTestTimeout_;
1299 std::string NTMonitorGroup_;
1300 std::string NTIUserGroup_;
1301 int unixWebUserGroup_;
1302 bool forkForUnixApache_;
1303
1304 std::string formVersion_;
1305 int maxSequenceLen_;
1306 int maxConcurrentSearches_;
1307 int maxSearchesPerUser_;
1308 double centroidWidth_;
1309 int centroidWidthCount_;
1310 int maxDescriptionLen_;
1311 int maxNumPeptides_;
1312 INT64 vmemory_;
1313
1314 std::vector< int > reportNumberChoices_;
1315 std::vector< double > targetFDRPercentages_;
1316 int defaultTargetFDRPercentagesIx_;
1317
1318 int reviewColWidths_[MS_REVIEW_COL____LAST___];
1319 bool reviewColDisplay_[MS_REVIEW_COL____LAST___];
1320 std::vector<std::string> reportBuilderColArr_;
1321
1322 std::string defaultColourSchemeName_;
1323 std::vector<std::string> colourSchemeNames_;
1324 std::vector<std::string> colourSchemeStrings_;
1325
1326 std::string proxyType_;
1327 bool useHTTPProxyForFTP_;
1328 bool useHTTPProxyForHTTPS_;
1329 std::string proxy_server_;
1330 std::string proxy_username_;
1331 std::string proxy_password_;
1332
1333 int maxVarMods_;
1334 int maxEtVarMods_;
1335 int errTolMaxAccessions_;
1336 bool labelAll_;
1337 bool showAllFromErrorTolerant_;
1338
1339 int minPepLenInPepSummary_;
1340 int maxPepModArrangements_;
1341 int maxPepNumVarMods_;
1342 int maxPepNumModifiedSites_;
1343 int maxQueries_;
1344 double showSubsets_;
1345 bool requireBoldRed_;
1346 double sigThreshold_;
1347 double siteAnalysisMD10Prob_;
1348 double ignoreIonsScoreBelow_;
1349
1350 std::string monitorPidFile_;
1351 bool storeModPermutations_;
1352 int proteinsInResultsFile_;
1353 std::string mascotMessage_;
1354 int splitNumberOfQueries_;
1355 int splitDataFileSize_;
1356 bool moveOldDbToOldDir_;
1357 bool removeOldIndexFiles_;
1358
1359 int featureTableLength_;
1360 double featureTableMinScore_;
1361
1362 std::string ICATLight_;
1363 std::string ICATHeavy_;
1364 std::string ICATFilter_;
1365 std::string ICATQuantitationMethod_;
1366
1367 int UnixDirPerm_;
1368 bool UnixDirPermDefined_;
1369 int mudpit_;
1370
1371 typedef std::vector<std::string> t_dupeAccs;
1372 t_dupeAccs ignoreDupeAccessions_;
1373
1374 double precursorCutOutLowerLimit_;
1375 double precursorCutOutUpperLimit_;
1376
1377 bool autoSelectCharge_;
1378 std::string taxBrowserUrl_;
1379 int minPepLenInSearch_;
1380 bool iteratePMFIntensities_;
1381
1382 double minEtagMassDelta_;
1383 double maxEtagMassDelta_;
1384
1385 std::string resultsFileFormatVersion_;
1386 std::string sortUnassigned_;
1387 int selectSwitch_;
1388 double mudpitSwitch_;
1389
1390 int maxDatabases_;
1391 std::string cacheDirectory_;
1392
1393 std::string resfileCache_;
1394 std::string resultsCache_;
1395
1396 bool percolator_;
1397 std::string percolatorFeatures_;
1398 int percolatorMinQueries_;
1399 int percolatorMinSequences_;
1400 bool percolatorUseProteins_;
1401 bool percolatorUseRT_;
1402 std::string percolatorExeFlags_;
1403 int percolatorTargetRankScoreThreshold_;
1404 double percolatorTargetRankRelativeThreshold_;
1405
1406 int createPipThreads_;
1407 int createPipThreadBlockSize_;
1408
1409 std::vector<std::string> execAfterSearch_;
1410 std::vector<std::string> execAfterSearchCommands_;
1411 std::vector<std::string> execAfterSearchTitles_;
1412 std::vector<int> execAfterSearchWaitFor_;
1413 std::vector<int> execAfterSearchLogging_;
1414 std::vector<std::string> execAfterSearchAdditionalFlags_;
1415 std::string resultsPerlScript_2_;
1416 std::string resultsFullURL_2_;
1417 int proteinFamilySwitch_;
1418
1419 int decoyTypeSpecific_;
1420 int decoyTypeNoEnzyme_;
1421
1422 int svgSpectrumSwitch_;
1423 int displayNonSigMatches_;
1424
1425 ms_blastaccession getSeqBlastAccession_;
1426 int minPeakIteration_;
1427 bool encryptURL_;
1428
1429 std::string compressToolAA_;
1430 std::string compressToolNA_;
1431 std::string compressToolSL_;
1432 std::string pepSearchTool_;
1433 int spectraPerLibraryBlock_;
1434 int crawlerNumPeaksPer100Da_;
1435 bool matchOppositeCrosslinkPairs_;
1436 int maxIntactCrosslinkPeptides_;
1437 std::string searchSubmitMode_;
1438 int dechargeFragmentPeaks_;
1439 std::string searchSubmitOutputFormat_;
1440 bool alwaysCreateDat28ResultsFile_;
1441 bool transferParsingToNodes_; //internal Mascot debug option
1442 int mascotFileProcessingThreads_;
1443 int inputFileParsingThreads_; //internal Mascot debug option
1444 int chunkReadingThreads_; //internal Mascot debug option
1445 int chunkPreparationThreads_; //internal Mascot debug option
1446 bool msrSqlQueriesInTransactions_; //internal Mascot debug option
1447 bool allowEmbeddedConfigInMimeInput_; //internal
1448 bool createLegacyModAndSubstitutionFiles_; // Enable/disable creation of ../config/mod_file and ../config/substitutions
1449 bool alwaysEnableAutoDecoySearch_; // Enable/disable auto-decoy search
1450 std::string searchSubmitAcceptedFileTypes_; // Comma-separated list of input file types
1451 std::string searchSubmitDefaultPeptideCharge_; // e.g. "2+, 3+ and 4+"
1452 }; // class ms_mascotoptions // end of config_group
1454} // namespace matrix_science
1455
1456#endif // MS_MASCOTOPTIONS_HPP
1457
1458/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_mascotoptions::PERC_EXE_RT
PERC_EXE_RT
Definitions for retention time override when calling getPercolatorExeFlags().
Definition: ms_mascotoptions.hpp:124
matrix_science::ms_mascotoptions::EXEC_AFTER_SEARCH
EXEC_AFTER_SEARCH
Definitions for the ExecAfterSearch_XXX lines in the Options section of mascot.dat.
Definition: ms_mascotoptions.hpp:176
matrix_science::ms_mascotoptions::NUMERICAL_VALUE_STORAGE
NUMERICAL_VALUE_STORAGE
Definitions for storage of numerical values in files.
Definition: ms_mascotoptions.hpp:187
matrix_science::ms_mascotoptions::MS_REVIEW_COL
MS_REVIEW_COL
Definitions for columns in ms-review.exe for use with getReviewColWidth() and getReviewColDisplay().
Definition: ms_mascotoptions.hpp:100
matrix_science::ms_mascotoptions::DECOY_ALGORITHM
DECOY_ALGORITHM
Definitions for how the decoy sequences are generated.
Definition: ms_mascotoptions.hpp:156
matrix_science::DATABASE_TYPE
DATABASE_TYPE
Definition: ms_databaseoptions.hpp:39
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresfile_dat.hpp Source File

  • inc
ms_mascotresfile_dat.hpp
1/*
2##############################################################################
3# file: ms_mascotresfile_dat.hpp #
4# 'msparser' toolkit #
5# Encapsulates a mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/include/ms_mascotresfi $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2024-09-23 15:56:03 +0100 $ #
14# $Revision: 09156baa48968c2f3ca3f6899bf06cc9caec40b7 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESFILE_DAT_HPP
20#define MS_MASCOTRESFILE_DAT_HPP
21
22
23
24// Includes from the standard template library
25#include <stdarg.h>
26#include <time.h>
27#include <string>
28#include <list>
29#include <vector>
30#include <set>
31
32namespace msparser_internal {
33 class ms_cdb;
34 class ms_peptidesumcdb;
35 class ms_mutex;
36 class ms_peptidesummarybase;
37 class ms_proteinsummarybase;
38
39}
40
41namespace matrix_science {
42 class ms_umod_configfile;
43 class ms_masses;
44 class ms_enzymefile;
45 class ms_taxonomyfile;
46 class ms_mascotresults_params;
47
53#ifndef SWIG
54 class multiBuf {
55 public:
56 multiBuf() {pMem_ = 0; len_ = 0; pEnd_ = 0;}
57 public :
58 char *pMem_; // pointer to first block of memory
59 int len_; // excluding any null terminator
60 char *pEnd_; // Pointer to last byte (not the null terminator)
61 private:
62 };
63 typedef std::vector<multiBuf> multiBuf_v;
64
65 class multiBufMemPtr {
66 public:
67 enum MBMP { MBMP_INVALID = -1, MBMP_USING_CDB = -2 };
68 multiBufMemPtr(int bufNum, char *pMem)
69 : bufNum_(bufNum), pMem_(pMem) {};
70 multiBufMemPtr() : bufNum_(MBMP_INVALID), pMem_(0) {};
71 void decrement(const multiBuf_v & buffers);
72 void decrementUntil(const multiBuf_v & buffers, const char * chars);
73 void increment(const multiBuf_v & buffers);
74 bool isValid() const {return bufNum_ != MBMP_INVALID;}
75 bool operator<(const multiBufMemPtr & rhs);
76 bool operator<=(const multiBufMemPtr & rhs);
77
78 public:
79 int bufNum_;
80 char * pMem_;
81 };
82
83 // ms_sortByKeyCriterion class is used internally in the library
84 // to give fast access to the keys. Don't use it from outside the DLL
85 class ms_sortByKeyCriterion
86 {
87 public:
88 enum CMP_MODE {CASE_INSENSITIVE=0x01, CASE_SENSITIVE=0x02, QUOTED=0x04};
89 ms_sortByKeyCriterion(int m=(int)CASE_INSENSITIVE) : mode_(m) {}
90 bool operator() (const char * p1, const char * p2) const;
91
92 private:
93 int mode_;
94 // Unfortunately, when called from Perl in Windows,
95 // the toupper function ends up calling extra functions
96 // to convert to wide char and back again. We don't
97 // want language independent conversion here - the
98 // key names are all single byte.
99 inline char my_toupper(char ch) const
100 {
101 if ((mode_ & CASE_INSENSITIVE) && ch >= 'a' && ch <= 'z')
102 return static_cast<char>('A' + (ch-'a'));
103 else
104 return ch;
105 }
106
107 };
108#endif
109
111
120 class MS_MASCOTRESFILE_API ms_mascotresfile_dat : public ms_mascotresfilebase
121 {
122 friend class msparser_internal::ms_peptidesumcdb;
123 public:
124
126
129 // Developer note: Add new sections to this enum just before
130 // SEC_INDEX, so that existing values are not changed.
131 enum section
132 {
133 SEC_PARAMETERS,
134 SEC_HEADER,
135 SEC_MASSES,
136 SEC_SUMMARY,
137 SEC_MIXTURE,
138 SEC_PEPTIDES,
139 SEC_PROTEINS,
140 SEC_QUERY1,
141 SEC_QUANTITATION,
142 SEC_UNIMOD,
143 SEC_ENZYME,
144 SEC_TAXONOMY,
145 SEC_DECOYSUMMARY,
146 SEC_DECOYMIXTURE,
147 SEC_DECOYPEPTIDES,
148 SEC_DECOYPROTEINS,
149 SEC_ERRTOLSUMMARY,
150 SEC_ERRTOLPEPTIDES,
151 SEC_SPECTRAL_LIBRARY,
152 SEC_LIBRARYPEPTIDES,
153 SEC_LIBRARYSUMMARY,
154 SEC_CROSSLINK_SUMMARY,
155 SEC_CROSSLINK_PEPTIDES,
156 SEC_CROSSLINKING,
157 SEC_UNIMOD_XL,
158 SEC_ERRTOLDECOYSUMMARY,
159 SEC_ERRTOLDECOYPEPTIDES,
160 SEC_INDEX,
161 SEC_NUMSECTIONS
162 };
163
164
166 static const char *getSectionName(const section sec);
167
169 static section getSummarySection(const ms_peptide::PSM_TYPE pepType);
170
172 static section getPeptideSection(const ms_peptide::PSM_TYPE pepType);
173
174
176
183 enum err
184 {
185 ERR_NO_ERROR = 0x0000,
186 ERR_NOMEM = 0x0001,
187 ERR_NOSUCHFILE = 0x0002,
188 ERR_READINGFILE = 0x0003,
189 ERR_QUERYOUTOFRANGE = 0x0004,
190 ERR_MISSINGENTRY = 0x0005,
191 ERR_PEPSUMMPEPGET = 0x0006,
192 ERR_PEPTIDESTR = 0x0007,
193 ERR_ACCINPEPTIDESTR = 0x0008,
194 ERR_PROTSUMM = 0x0009,
195 ERR_PROTSUMMPEP = 0x000A,
196 ERR_ADDPEPTIDES = 0x000B,
197 ERR_MISSINGHIT = 0x000C,
198 ERR_MISSINGSECTION = 0x000D,
199 ERR_MISSINGSECTIONEND = 0x000E,
200 ERR_MALFORMED_ERR_TOL = 0x000F,
201 ERR_NO_ERR_TOL_PARENT = 0x0010,
202 ERR_NULL_ACC_PEP_SUM = 0x0011,
203 ERR_NULL_ACC_PROT_SUM = 0x0012,
204 ERR_DUPE_ACCESSION = 0x0013,
205 ERR_UNASSIGNED_PROG = 0x0014,
206 ERR_UNASSIGNED_RANGE = 0x0015,
207 ERR_UNASSIGNED_UNK = 0x0016,
208 ERR_NO_UNIGENE_FILE = 0x0017,
209 ERR_DUPLICATE_KEY = 0x0018,
210 ERR_OLDRESULTSFILE = 0x0019,
211 ERR_MALFORMED_TAG = 0x001A,
212 ERR_MALFORMED_DRANGE = 0x001B,
213 ERR_INVALID_NUMQUERIES = 0x001C,
214 ERR_MALFORMED_TERMS = 0x001D,
215 ERR_INVALID_RESFILE = 0x001E,
216 ERR_INVALID_PROTDB = 0x001F,
217 ERR_UNIGENE_MULTIDB = 0x0020,
218 ERR_INVALID_CACHE_DIR = 0x0021,
219 ERR_FAIL_OPEN_DAT_FILE = 0x0022,
220 ERR_MISSING_CDB_FILE = 0x0023,
221 ERR_FAIL_MK_CACHE_DIR = 0x0024,
222 ERR_FAIL_MK_CDB_FILE = 0x0025,
223 ERR_FAIL_CLOSE_FILE = 0x0026,
224 ERR_FAIL_CDB_INIT = 0x0027,
225 ERR_INVALID_CDB_FILE = 0x0028,
226 ERR_WRITE_CDB_FILE = 0x0029,
227 ERR_CDB_TOO_LARGE = 0x002A,
228 ERR_NEED_64_BIT = 0x002B,
229 ERR_CDB_64_BIT_REMAKE = 0x002C,
230 ERR_CDB_OLD_VER_RETRY = 0x002D,
231 ERR_CDB_OLD_VER_NO_RETRY = 0x002E,
232 ERR_CDB_INCOMPLETE_RETRY = 0x002F,
233 ERR_CDB_INCOMPLETE_NO_RETRY = 0x0030,
234 ERR_CDB_BEING_CREATED = 0x0031,
235 ERR_CDB_FAIL_REMOVE = 0x0032,
236 ERR_CDB_FAIL_LOCK = 0x0033,
237 ERR_CDB_FAIL_UNLOCK = 0x0034,
238 ERR_CDB_SOURCE_CHANGE_RETRY = 0x0035,
239 ERR_CDB_SOURCE_CHANGE_NO_RETRY = 0x0036,
240 ERR_MISSING_PERCOLATOR_FILE = 0x0037,
241 ERR_CANNOT_APPEND_RESFILE = 0x0038,
242 ERR_CANNOT_APPEND_RESFILE_NO_FNAMES = 0x0039,
243 ERR_RESULTS_NOT_CREATED = 0x003A,
244 ERR_LASTONE = 0x003B
245 };
246 // this list has to be included into ms_errors.hpp file too !!!
247
248
250 ms_mascotresfile_dat(const char * szFileName,
251 const int keepAliveInterval = 0,
252 const char * keepAliveText = "<!-- %d seconds -->\n",
253 const unsigned int flags = RESFILE_NOFLAG,
254 const char * cacheDirectory = "../data/cache/%Y/%m",
255 const char * XMLschemaDirectory = 0,
256 ms_progress_info * progressMonitor = 0);
257
258 virtual ~ms_mascotresfile_dat();
259
260 // ------------------- Basic generic functions -------------------
261
262
264 int appendResfile(const char * filename,
265 int flags=RESFILE_USE_PARENT_PARAMS,
266 const char * cacheDirectory = 0) override; // returns 'id' of added file
267
269 const ms_mascotresfile_dat* getResfile(int id) const override;
270
272 int getNumberOfResfiles() const override;
273
275 bool doesSectionExist(const section sec) const;
276
278 bool anyPeptideSummaryMatches(const section sec=SEC_PEPTIDES) const;
279
280 bool anyFastaMatches(const bool isDecoy=false) const override;
281
282 bool anySpectralLibraryMatches(const bool isDecoy=false) const override;
283
284 bool anyErrorTolerantMatches(const bool isDecoy=false) const override;
285
286 bool anyCrosslinkedMatches(const bool isDecoy=false) const override;
287
288 // When calling 'getSectionValue' from outside the dll, be careful
289 // that enough space is 'reserved' in the string.
290 // Return value is length of the actual string that it wanted to
291 // to return, so if this is larger than maxLen, then you are
292 // missing some of the string. Best to call getSectionValueStr
294 int getSectionValue(const section sec, const char * key, char * str, int maxLen) const;
295
297 int getSectionValueInt(const section sec, const char * key) const;
298
300 double getSectionValueDouble(const section sec, const char * key) const;
301
303 std::string getSectionValueStr(const section sec, const char * key) const;
304
306 int getQuerySectionValue(const int query, const char * key, char * str, int maxLen) const;
307
309 int getQuerySectionValueInt(const int query, const char * key) const;
310
312 double getQuerySectionValueDouble(const int query, const char * key) const;
313
315 std::string getQuerySectionValueStr(const int query, const char * key) const;
316
318 int getJobNumber(const int resfileID = 1) const override;
319
321 std::string enumerateSectionKeys(const section sec,
322 const int num,
323 int * pPreviousNum = 0,
324 OFFSET64_T * pPreviousOffset = 0) const;
325
327 std::string enumerateQuerySectionKeys(const int query,
328 const int num,
329 int * pPreviousNum = 0,
330 OFFSET64_T * pPreviousOffset = 0) const;
331
332 // ----------------- Specific results functions ------------------
334 int getNumQueries(const int resfileID = 0) const override;
335
337 int getNumHits(const section sec=SEC_SUMMARY) const;
338
340 int getNumSeqs(const int idx = 0) const override;
341
343 int getNumSeqsAfterTax(const int idx = 0) const override;
344
346 int getNumEtSeqsSearched(const int idx = 0) const override;
347
349 int getNumLibraryEntries(const int idx = 0) const override;
350
352 double getNumResidues(const int idx = 0) const override;
353
355 bool isDatabaseTypeAvailable() const override;
357 DATABASE_TYPE getDatabaseType(const int idx) const override;
359 int getReferenceDatabaseNumberOfSL(const int idx) const override;
360
362 std::vector<int> getSLDatabaseNumbersOfReference(const int idx) const override;
363
365
367 int getExecTime() const override { return execTime_; }
368
370
372 int getDate() const override { return searchDate_; }
373
375
377 std::string getMascotVer() const override { return version_; }
378
380 std::string getFastaVer(int idx = 1) const override;
381
383 std::string getFastaPath(int idx = 1) const override;
384
386 std::string getUniqueTaskID() const override;
387
389 ms_mascotoptions::DECOY_ALGORITHM getDecoyTypeForDB(const int idx = 1) const override;
390
392 double getSLFragmentTolerance(int idx = 1) const override;
393
395 std::string getSLFragmentToleranceUnit(int idx = 1) const override;
396
398 virtual std::string getSLExecCommand(int idx = 1) const override;
399
401 bool isPMF() const override;
402
404 bool isMSMS() const override;
405
407 bool isSQ() const override;
408
410 bool isErrorTolerant() const override;
411
413 bool anyPMF() const override;
414
416 bool anyMSMS() const override;
417
419 bool anySQ() const override;
420
422 bool anyTag() const override;
423
425 double getObservedMass(const int query) const override;
426
428 int getObservedCharge(const int query, const bool decoy=false) const override;
429
431 double getObservedMrValue(const int query, const bool decoy=false) const override;
432
434 double getObservedIntensity(const int query) const override;
435
437 std::string getRepeatSearchString(const int query, const bool fullQuery = false) const override;
438
440 std::string getFileName(const int id = 1) const override;
441
443 bool getQuantitation(ms_quant_configfile *qfile) const override;
444
446 bool getUnimod(ms_umod_configfile *ufile, bool useSchemaFromResfile = false) const override;
447
449 bool getUnimodXL(ms_umod_configfile *ufile, bool useSchemaFromResfile = false) const override;
450
452 bool getEnzyme(ms_enzymefile *efile, const char * enzymeFileName = 0) const override;
453
455 bool getTaxonomy(ms_taxonomyfile *tfile) const override;
456
458 std::string getCacheDirectory(bool processed = true) const override;
459
461 std::string getCacheFileName() const override;
462
463#ifndef SWIG
465 bool getSrcQueryAndFileIdForMultiFile(const int q, int & gsqNewQuery, int & gsqFileId) const override;
466#else // SWIG Multiple return values
467 bool getSrcQueryAndFileIdForMultiFile(const int q, int & OUTPUT, int & OUTPUT) const override;
468#endif
470 int getMultiFileQueryNumber(const int localQuery, const int fileId) const override;
471
473 bool hasEnzyme() const override;
474
476 bool hasRT() const override;
477
479 bool hasQuantitation() const override;
480
482 ms_inputquery getInputQuery(const int queryNum) const override;
483
484#ifndef SWIG
486 void getHeaderKeyValues(std::vector<std::string> & keys, std::vector<std::string> & values) const override;
487
489 void getSearchParametersKeyValues(std::vector<std::string> & keys, std::vector<std::string> & values) const override;
490
492 void getMassesKeyValues(std::vector<std::string> & keys, std::vector<double> & values) const override;
493#else
494 void getHeaderKeyValues(std::vector<std::string> & OUTPUT, std::vector<std::string> & OUTPUT) const override;
495
496 void getSearchParametersKeyValues(std::vector<std::string> & OUTPUT, std::vector<std::string> & OUTPUT) const override;
497
498 void getMassesKeyValues(std::vector<std::string> & OUTPUT, std::vector<double> & OUTPUT) const override;
499#endif
500
502 virtual std::string getHeaderValue(const std::string& key) const override;
503
505 virtual std::string getSearchParameter(const std::string& key) const override;
506
508 virtual double getMassValue(const std::string& key) const override;
509
511 int getLibraryMods(std::vector<std::string> & modNames, std::vector<double> & modDeltas) const override;
512
514 int64_t getQmatch(const int query, const ms_peptide::PSM_TYPE pepType) const override;
515
517 double getQplughole(const int query, const ms_peptide::PSM_TYPE pepType) const override;
518
520 double getFirstPassThreshold() const override;
521
522
523 protected:
524#ifndef SWIG
525 // Not safe to copy or assign this object.
526 ms_mascotresfile_dat(const ms_mascotresfile_dat & rhs);
527 ms_mascotresfile_dat & operator=(const ms_mascotresfile_dat & rhs);
528#endif
529 bool getCrosslinking(ms_crosslinking_configfile *crosslinkingFile) const override;
530
531 private:
532
533 void validateResfileVersion() override;
534
535 std::string getPepSumCacheFilename(
536 const unsigned int flags,
537 double minProbability,
538 int maxHitsToReport,
539 const char * unigeneIndexFile,
540 double ignoreIonsScoreBelow,
541 int minPepLenInPepSummary,
542 const char * singleHit,
543 const unsigned int flags2) const override;
544
545 std::string getPepSumCacheFilename(const ms_mascotresults_params & parameters) const override;
546
547 int getNumHitsInProteinSummary(const ms_peptide::PSM_TYPE psmType) const override;
548
549 bool willCreatePepSumCache(
550 const unsigned int flags,
551 double minProbability,
552 int maxHitsToReport,
553 const char * unigeneIndexFile,
554 double ignoreIonsScoreBelow,
555 int minPepLenInPepSummary,
556 const char * singleHit,
557 const unsigned int flags2) const override;
558
559 bool willCreatePepSumCache(const ms_mascotresults_params &parameters) const override;
560
561 bool willCreatePepSumCache(const ms_mascotresults_params & parameters,
562 const ms_mascotoptions & opts,
563 std::string & peptideSummaryCacheFileName,
564 unsigned int & cacheStatus) const override;
565
566 void buildPeptideSummaryImpl(ms_peptidesummary & pepSum,
567 const ms_mascotresults_params & parameters,
568 std::shared_ptr<msparser_internal::ms_mascotresultsbase> & results,
569 std::shared_ptr<msparser_internal::ms_peptidesummarybase> & iPepSum) const override;
570
571 void buildProteinSummaryImpl(ms_proteinsummary & protSum,
572 const ms_mascotresults_params & parameters,
573 std::shared_ptr<msparser_internal::ms_mascotresultsbase> & results,
574 std::shared_ptr<msparser_internal::ms_proteinsummarybase> & iProtSum) const override;
575
576 std::shared_ptr<msparser_internal::ms_inputquerybase> buildInputQueryImpl(const int q) const override;
577
578 std::shared_ptr<msparser_internal::ms_searchparamsbase> buildSearchParamsImpl() const override;
579
580 std::vector<int> multifileNumQueries_; // 0 based vector, with 0 being the primary file
581 typedef std::vector<ms_mascotresfile_dat *> resfileV_t; // 0 based vector, with 0 being the primary file
582 resfileV_t multifileResfiles_;
583 int protSummaryHits_;
584 int numSequences_;
585 int numSequencesAfterTax_;
586 double numResidues_;
587 int numLibraryEntries_;
588 int execTime_;
589 int searchDate_;
590
591
592 std::vector<DATABASE_TYPE> dbType_;
593 std::vector<int> slReferenceMap_;
594
595 bool anyMSMS_;
596 bool cachedAnyMSMS_;
597 bool anyPMF_;
598 bool cachedAnyPMF_;
599 bool anySQ_;
600 bool cachedAnySQ_;
601 bool anyTag_;
602 bool cachedAnyTag_;
603 mutable bool isErrorTolerant_;
604 mutable bool cachedIsErrorTolerant_;
605
606 msparser_internal::ms_cdb * pIndexFile_;
607 bool useIndexFile_;
608 int hFile_;
609 mutable char * readlnBuf_;
610 mutable unsigned int readlnBufSize_;
611 msparser_internal::ms_mutex * pMutex_;
612
613
614 const char * sectionTitles_[SEC_NUMSECTIONS];
615
616 multiBufMemPtr sectionStart_[SEC_NUMSECTIONS];
617 multiBufMemPtr sectionEnd_ [SEC_NUMSECTIONS];
618
619 multiBuf_v buffers_;
620
621 std::string endSectionKey_;
622 std::string lineBasedEndSectionKey_;
623 std::string genericQuerySectionKey_;
624 bool isWinIniFormat_;
625 std::vector<double> cachedMrValues_;
626 std::vector<double> cachedExpValues_;
627 std::vector<short> cachedCharges_;
628
629 multiBufMemPtr findSectionStart(const char * szSectionName,
630 const multiBufMemPtr * startLookingAt = 0) const;
631 multiBufMemPtr findSectionEnd(const multiBufMemPtr sectionStart) const;
632
633 // Array of maps for each section
634 typedef std::set<const char *,ms_sortByKeyCriterion> sortedKeys;
635 sortedKeys sorted_[SEC_NUMSECTIONS];
636 bool fillUpSortedList(const int section,
637 const multiBufMemPtr sectionStart,
638 const multiBufMemPtr sectionEnd,
639 sortedKeys & sorted_keys) const;
640
641 // There are an 'unknown' number of query sections
642 bool hasQuerySectionBeenIndexed;
643 std::vector<multiBufMemPtr> querySectionStart_;
644 std::vector<multiBufMemPtr> querySectionEnd_;
645 std::vector<sortedKeys> sortedQueries_;
646
647 // Private function to get string
648 bool inDLLgetSectVal(const section sec,
649 const int queryNumber,
650 const multiBufMemPtr sectionStart,
651 const multiBufMemPtr sectionEnd,
652 sortedKeys & sorted_keys,
653 const char * key,
654 std::string & result) const;
655
656 // Private function to get string
657 bool inDLLgetSectionAsString(const section sec,
658 std::string & result) const;
659
660 bool readFile(const char * szFileName);
661 bool readLine(char * & buf, unsigned int & bufSize) const;
662 void getSectionTitles();
663 void debugCheckReadFileOK();
664 bool createCDBFile();
665
666 int extractObservedCharge(char *szKey, std::string str) const;
667 std::string enumerateQuerySection(const int query,
668 const int num,
669 int * pPreviousNum,
670 OFFSET64_T * pPreviousOffset,
671 OFFSET64_T * pSectionEnd,
672 std::string & value) const;
673
674 void getSLFragmentToleranceAndUnit_Value(int idx, double & tolerance, std::string & toleranceUnit) const;
675
676 void getSectionKeyValues(std::vector<std::string> & keys, std::vector<std::string> & values, section sec, const std::string &startswith="") const;
677
678 void propagateKeepAlive(const int keepAliveInterval,
679 const char * keepAliveText,
680 const bool propagateToAppended,
681 const bool resetStartTime) override;
682
683 std::map<section, bool> mapSectionAnyMatch_;
684
685 }; // end of resfile_group
687} // matrix_science namespace
688#endif // MS_MASCOTRESFILE_DAT_HPP
689
690/*------------------------------- End of File -------------------------------*/
matrix_science::ms_crosslinking_configfile
This class represents the file crosslinking.xml.
Definition: ms_crosslinking_configfile.hpp:49
matrix_science::ms_enzymefile
Reads and parses the enzymes file that contains multiple enzyme definitions.
Definition: ms_enzyme.hpp:194
matrix_science::ms_inputquery
This class encapsulates the input queries (peak lists) in the Mascot results file.
Definition: ms_inputquery.hpp:43
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_mascotoptions::DECOY_ALGORITHM
DECOY_ALGORITHM
Definitions for how the decoy sequences are generated.
Definition: ms_mascotoptions.hpp:156
matrix_science::ms_mascotresfile_dat
Class for parsing and reading files in dat28 format.
Definition: ms_mascotresfile_dat.hpp:121
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresfile_dat::SEC_TAXONOMY
@ SEC_TAXONOMY
taxonomy section
Definition: ms_mascotresfile_dat.hpp:144
matrix_science::ms_mascotresfile_dat::SEC_SPECTRAL_LIBRARY
@ SEC_SPECTRAL_LIBRARY
spectral library section. See also Spectral libraries.
Definition: ms_mascotresfile_dat.hpp:151
matrix_science::ms_mascotresfile_dat::SEC_ERRTOLDECOYPEPTIDES
@ SEC_ERRTOLDECOYPEPTIDES
error tolerant decoy peptides section. See also Error tolerant searches.
Definition: ms_mascotresfile_dat.hpp:159
matrix_science::ms_mascotresfile_dat::SEC_ERRTOLDECOYSUMMARY
@ SEC_ERRTOLDECOYSUMMARY
error tolerant decoy summary section. See also Error tolerant searches.
Definition: ms_mascotresfile_dat.hpp:158
matrix_science::ms_mascotresfile_dat::SEC_MASSES
@ SEC_MASSES
masses section
Definition: ms_mascotresfile_dat.hpp:135
matrix_science::ms_mascotresfile_dat::SEC_DECOYPEPTIDES
@ SEC_DECOYPEPTIDES
decoy_peptides section. See also Target-decoy searches and false discovery rate.
Definition: ms_mascotresfile_dat.hpp:147
matrix_science::ms_mascotresfile_dat::SEC_DECOYSUMMARY
@ SEC_DECOYSUMMARY
decoy_summary section. See also Target-decoy searches and false discovery rate.
Definition: ms_mascotresfile_dat.hpp:145
matrix_science::ms_mascotresfile_dat::SEC_ENZYME
@ SEC_ENZYME
enzyme section
Definition: ms_mascotresfile_dat.hpp:143
matrix_science::ms_mascotresfile_dat::SEC_DECOYPROTEINS
@ SEC_DECOYPROTEINS
decoy_proteins section. See also Target-decoy searches and false discovery rate.
Definition: ms_mascotresfile_dat.hpp:148
matrix_science::ms_mascotresfile_dat::SEC_QUERY1
@ SEC_QUERY1
query1 section. Don't use, see getQuerySectionValueStr() etc.
Definition: ms_mascotresfile_dat.hpp:140
matrix_science::ms_mascotresfile_dat::SEC_INDEX
@ SEC_INDEX
index section
Definition: ms_mascotresfile_dat.hpp:160
matrix_science::ms_mascotresfile_dat::SEC_PARAMETERS
@ SEC_PARAMETERS
parameters section
Definition: ms_mascotresfile_dat.hpp:133
matrix_science::ms_mascotresfile_dat::SEC_LIBRARYPEPTIDES
@ SEC_LIBRARYPEPTIDES
spectral library peptides section. See also Spectral libraries.
Definition: ms_mascotresfile_dat.hpp:152
matrix_science::ms_mascotresfile_dat::SEC_HEADER
@ SEC_HEADER
header section
Definition: ms_mascotresfile_dat.hpp:134
matrix_science::ms_mascotresfile_dat::SEC_SUMMARY
@ SEC_SUMMARY
summary section
Definition: ms_mascotresfile_dat.hpp:136
matrix_science::ms_mascotresfile_dat::SEC_PEPTIDES
@ SEC_PEPTIDES
peptides section
Definition: ms_mascotresfile_dat.hpp:138
matrix_science::ms_mascotresfile_dat::SEC_UNIMOD
@ SEC_UNIMOD
unimod section
Definition: ms_mascotresfile_dat.hpp:142
matrix_science::ms_mascotresfile_dat::SEC_CROSSLINK_PEPTIDES
@ SEC_CROSSLINK_PEPTIDES
crosslink_peptides section. See also Crosslinked search results.
Definition: ms_mascotresfile_dat.hpp:155
matrix_science::ms_mascotresfile_dat::SEC_MIXTURE
@ SEC_MIXTURE
mixture section (pmf mixture)
Definition: ms_mascotresfile_dat.hpp:137
matrix_science::ms_mascotresfile_dat::SEC_PROTEINS
@ SEC_PROTEINS
proteins section
Definition: ms_mascotresfile_dat.hpp:139
matrix_science::ms_mascotresfile_dat::SEC_LIBRARYSUMMARY
@ SEC_LIBRARYSUMMARY
spectral library summary section. See also Spectral libraries.
Definition: ms_mascotresfile_dat.hpp:153
matrix_science::ms_mascotresfile_dat::SEC_QUANTITATION
@ SEC_QUANTITATION
quantitation section
Definition: ms_mascotresfile_dat.hpp:141
matrix_science::ms_mascotresfile_dat::SEC_CROSSLINKING
@ SEC_CROSSLINKING
crosslinking section
Definition: ms_mascotresfile_dat.hpp:156
matrix_science::ms_mascotresfile_dat::SEC_ERRTOLSUMMARY
@ SEC_ERRTOLSUMMARY
error tolerant summary section. See also Error tolerant searches.
Definition: ms_mascotresfile_dat.hpp:149
matrix_science::ms_mascotresfile_dat::SEC_CROSSLINK_SUMMARY
@ SEC_CROSSLINK_SUMMARY
crosslink_summary section. See also Crosslinked search results.
Definition: ms_mascotresfile_dat.hpp:154
matrix_science::ms_mascotresfile_dat::SEC_UNIMOD_XL
@ SEC_UNIMOD_XL
unimod_xl section
Definition: ms_mascotresfile_dat.hpp:157
matrix_science::ms_mascotresfile_dat::SEC_ERRTOLPEPTIDES
@ SEC_ERRTOLPEPTIDES
error tolerant peptides section. See also Error tolerant searches.
Definition: ms_mascotresfile_dat.hpp:150
matrix_science::ms_mascotresfile_dat::SEC_DECOYMIXTURE
@ SEC_DECOYMIXTURE
decoy_mixture section. See also Target-decoy searches and false discovery rate.
Definition: ms_mascotresfile_dat.hpp:146
matrix_science::ms_mascotresfile_dat::err
err
Definitions for error numbers.
Definition: ms_mascotresfile_dat.hpp:184
matrix_science::ms_mascotresfile_dat::getDate
int getDate() const override
Returns the date and time of the search in seconds since midnight January 1st 1970.
Definition: ms_mascotresfile_dat.hpp:372
matrix_science::ms_mascotresfile_dat::getExecTime
int getExecTime() const override
Returns the time taken for the search.
Definition: ms_mascotresfile_dat.hpp:367
matrix_science::ms_mascotresfile_dat::getMascotVer
std::string getMascotVer() const override
Returns the version of Mascot used to perform the search.
Definition: ms_mascotresfile_dat.hpp:377
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_progress_info
Contains information of the current progress of a task being performed.
Definition: ms_progress_info.hpp:40
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
matrix_science::ms_quant_configfile
Use this class in order to read/write quantitation.xml.
Definition: ms_quant_configfile.hpp:52
matrix_science::ms_taxonomyfile
Use this class in order to read in a taxonomy file.
Definition: ms_taxonomyfile.hpp:145
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::DATABASE_TYPE
DATABASE_TYPE
Definition: ms_databaseoptions.hpp:39
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresfile_msr.hpp Source File

  • inc
ms_mascotresfile_msr.hpp
1/*
2##############################################################################
3# file: ms_mascotresfile_msr.hpp #
4# 'msparser' toolkit #
5# Encapsulates a mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2024-09-23 15:56:03 +0100 $ #
14# $Revision: 09156baa48968c2f3ca3f6899bf06cc9caec40b7 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESFILE_MSR_HPP
20#define MS_MASCOTRESFILE_MSR_HPP
21
22
23// Includes from the standard template library
24#include <stdarg.h>
25#include <time.h>
26#include <string>
27#include <list>
28#include <vector>
29#include <set>
30#include <unordered_map>
31#include <array>
32#include <thread>
33#include <atomic>
34
35namespace msparser_internal {
36 class ms_peptidesumsql;
37 class ms_inputquery_msr;
38 class ms_sqlpp11_connection;
39
40#ifndef SWIG
41 namespace msr_cached_data
42 {
43 struct QueryData;
44 struct ResfileCaches
45 {
46 static constexpr int CACHE_SIZE = 10;
47
48 struct SummaryQueryInfoData
49 {
50 //double observedMr; // Stored in summaryQueryInfoL2Cache_
51 double mZ;
52 double intensity;
53 int charge;
54 // int64_t qMatch; // Stored in summaryQueryInfoL2Cache_;
55 //double plughole; // Stored in summaryQueryInfoL2Cache_;
56 };
57
58 // [(queryId, (QueryDataStandard, QueryDataDecoy, ...)), ...]
59 using SummaryQueryInfoCache = std::map<int, std::array<std::pair<int, std::array<SummaryQueryInfoData, matrix_science::ms_peptide::N_PSM_TYPES>>, CACHE_SIZE>>;
60 thread_local static SummaryQueryInfoCache summaryQueryInfoCache_;
61
62 // Store data that is usually not accessed sequentially in a separate long term cache.
63 // e.g. ms_protein::sortPeptides accesses mr in a non sequencial order.
64 struct SummaryQueryInfoHotData
65 {
66 double observedMr;
67 double plughole;
68 int64_t qMatch;
69 };
70
71 // Map queryId -> (SummaryQueryInfoHotData)
72 using SummaryQueryInfoL2Cache = std::map< int, std::unordered_map<int, std::array<SummaryQueryInfoHotData, matrix_science::ms_peptide::N_PSM_TYPES>> >;
73 thread_local static SummaryQueryInfoL2Cache summaryQueryInfoL2Cache_;
74
75 using QueryDataCache = std::map< int, std::array<QueryData, CACHE_SIZE> >;
76 thread_local static QueryDataCache queryCache_;
77 };
78 }
79#endif
80}
81
82namespace matrix_science {
83 class ms_umod_configfile;
84 class ms_masses;
85 class ms_enzymefile;
86 class ms_taxonomyfile;
87 class ms_mascotresults_params;
88
95
104 class MS_MASCOTRESFILE_API ms_mascotresfile_msr : public ms_mascotresfilebase
105 {
106 friend class msparser_internal::ms_peptidesumsql;
107 friend class msparser_internal::ms_inputquery_msr;
108
109 public:
110
112 ms_mascotresfile_msr(const char * szFileName,
113 const int keepAliveInterval = 0,
114 const char * keepAliveText = "<!-- %d seconds -->\n",
115 const unsigned int flags = RESFILE_NOFLAG,
116 const char * cacheDirectory = "../data/cache/%Y/%m",
117 const char * XMLschemaDirectory = 0,
118 ms_progress_info * progressMonitor = 0);
119
120 virtual ~ms_mascotresfile_msr();
121
122 // ------------------- Basic generic functions -------------------
123
124
126 int appendResfile(const char * filename,
127 int flags=RESFILE_USE_PARENT_PARAMS,
128 const char * cacheDirectory = 0) override; // returns 'id' of added file
129
131 const ms_mascotresfile_msr* getResfile(int id) const override;
132
134 int getNumberOfResfiles() const override;
135
137 int getJobNumber(const int resfileID = 1) const override;
138
139 // ----------------- Specific results functions ------------------
141 int getNumQueries(const int resfileID = 0) const override;
142
144 int getNumSeqs(const int idx = 0) const override;
145
147 int getNumSeqsAfterTax(const int idx = 0) const override;
148
150 int getNumEtSeqsSearched(const int idx = 0) const override;
151
153 int getNumLibraryEntries(const int idx = 0) const override;
154
156 double getNumResidues(const int idx = 0) const override;
157
159 bool isDatabaseTypeAvailable() const override;
161 DATABASE_TYPE getDatabaseType(const int idx) const override;
163 int getReferenceDatabaseNumberOfSL(const int idx) const override;
164
166 std::vector<int> getSLDatabaseNumbersOfReference(const int idx) const override;
167
169 int getExecTime() const override;
170
172 int getDate() const override;
173
175 std::string getMascotVer() const override;
176
178 std::string getFastaVer(int idx = 1) const override;
179
181 std::string getFastaPath(int idx = 1) const override;
182
184 std::string getUniqueTaskID() const override;
185
187 ms_mascotoptions::DECOY_ALGORITHM getDecoyTypeForDB(const int idx = 1) const override;
188
190 double getSLFragmentTolerance(int idx = 1) const override;
191
193 std::string getSLFragmentToleranceUnit(int idx = 1) const override;
194
196 virtual std::string getSLExecCommand(int idx = 1) const override;
197
199 bool isPMF() const override;
200
202 bool isMSMS() const override;
203
205 bool isSQ() const override;
206
208 bool isErrorTolerant() const override;
209
211 bool anyPMF() const override;
212
214 bool anyMSMS() const override;
215
217 bool anySQ() const override;
218
220 bool anyTag() const override;
221
223 bool anyFastaMatches(const bool isDecoy=false) const override;
224
226 bool anySpectralLibraryMatches(const bool isDecoy=false) const override;
227
229 bool anyErrorTolerantMatches(const bool isDecoy=false) const override;
230
232 bool anyCrosslinkedMatches(const bool isDecoy=false) const override;
233
235 double getObservedMass(const int query) const override;
236
238 int getObservedCharge(const int query, const bool decoy=false) const override;
239
241 double getObservedMrValue(const int query, const bool decoy=false) const override;
242
244 double getObservedIntensity(const int query) const override;
245
247 std::string getRepeatSearchString(const int query, const bool fullQuery = false) const override;
248
250 std::string getFileName(const int id = 1) const override;
251
253 bool getQuantitation(ms_quant_configfile *qfile) const override;
254
256 bool getUnimod(ms_umod_configfile *ufile, bool useSchemaFromResfile = false) const override;
257
259 bool getUnimodXL(ms_umod_configfile *ufile, bool useSchemaFromResfile = false) const override;
260
262 bool getEnzyme(ms_enzymefile *efile, const char * enzymeFileName = 0) const override;
263
265 bool getTaxonomy(ms_taxonomyfile *tfile) const override;
266
268 std::string getCacheDirectory(bool processed = true) const override;
269
271 std::string getCacheFileName() const override;
272
273
274#ifndef SWIG
276 bool getSrcQueryAndFileIdForMultiFile(const int q, int & gsqNewQuery, int & gsqFileId) const override;
277#else // SWIG Multiple return values
278 bool getSrcQueryAndFileIdForMultiFile(const int q, int & OUTPUT, int & OUTPUT) const override;
279#endif
281 int getMultiFileQueryNumber(const int localQuery, const int fileId) const override;
282
284 bool hasEnzyme() const override;
285
287 bool hasRT() const override;
288
290 bool hasQuantitation() const override;
291
293 ms_inputquery getInputQuery(const int queryNum) const override;
294
295#ifndef SWIG
297 void getHeaderKeyValues(std::vector<std::string> & keys, std::vector<std::string> & values) const override;
298
300 void getSearchParametersKeyValues(std::vector<std::string> & keys, std::vector<std::string> & values) const override;
301
303 void getMassesKeyValues(std::vector<std::string> & keys, std::vector<double> & values) const override;
304#else
305 void getHeaderKeyValues(std::vector<std::string> & OUTPUT, std::vector<std::string> & OUTPUT) const override;
306
307 void getSearchParametersKeyValues(std::vector<std::string> & OUTPUT, std::vector<std::string> & OUTPUT) const override;
308
309 void getMassesKeyValues(std::vector<std::string> & OUTPUT, std::vector<double> & OUTPUT) const override;
310#endif
311
313 virtual std::string getHeaderValue(const std::string& key) const override;
314
316 virtual std::string getSearchParameter(const std::string& key) const override;
317
319 virtual double getMassValue(const std::string& key) const override;
320
322 int getLibraryMods(std::vector<std::string> & modNames, std::vector<double> & modDeltas) const override;
323
325 int64_t getQmatch(const int query, const ms_peptide::PSM_TYPE pepType) const override;
326
328 double getQplughole(const int query, const ms_peptide::PSM_TYPE pepType) const override;
329
331 double getFirstPassThreshold() const override;
332
333#ifndef SWIG
334 msparser_internal::ms_sqlpp11_connection & sqlite3_connection() const { return db_; }
335 std::shared_ptr<msparser_internal::ms_sqlpp11_connection> sqlite3_connection_ptr() const { return msDbPtr_; }
336 msparser_internal::ms_sqlpp11_connection & getSrcQueryAndSqlHandleForMultiFile(const int q, int & gsqNewQuery) const;
337#endif
338
339 protected:
340#ifndef SWIG
341 // Not safe to copy or assign this object.
342 ms_mascotresfile_msr(const ms_mascotresfile_msr & rhs);
343 ms_mascotresfile_msr & operator=(const ms_mascotresfile_msr & rhs);
344#endif
345
346 bool getCrosslinking(ms_crosslinking_configfile *crosslinkingFile) const override;
347
348 private:
349
350 void validateResfileVersion() override;
351
352 void propagateKeepAlive(const int keepAliveInterval,
353 const char * keepAliveText,
354 const bool propagateToAppended,
355 const bool resetStartTime) override;
356
357 std::string getPepSumCacheFilename(
358 const unsigned int flags,
359 double minProbability,
360 int maxHitsToReport,
361 const char * unigeneIndexFile,
362 double ignoreIonsScoreBelow,
363 int minPepLenInPepSummary,
364 const char * singleHit,
365 const unsigned int flags2) const override;
366
367 std::string getPepSumCacheFilename(const ms_mascotresults_params & parameters) const override;
368
369 int getNumHitsInProteinSummary(const ms_peptide::PSM_TYPE psmType) const override;
370
371 bool willCreatePepSumCache(const unsigned int flags,
372 double minProbability,
373 int maxHitsToReport,
374 const char * unigeneIndexFile,
375 double ignoreIonsScoreBelow,
376 int minPepLenInPepSummary,
377 const char * singleHit,
378 const unsigned int flags2) const override;
379
380 bool willCreatePepSumCache(const ms_mascotresults_params &parameters) const override;
381
382 bool willCreatePepSumCache(const ms_mascotresults_params & parameters,
383 const ms_mascotoptions & opts,
384 std::string & peptideSummaryCacheFileName,
385 unsigned int & cacheStatus) const override;
386
387 void buildPeptideSummaryImpl(ms_peptidesummary & pepSum,
388 const ms_mascotresults_params & parameters,
389 std::shared_ptr<msparser_internal::ms_mascotresultsbase> & results,
390 std::shared_ptr<msparser_internal::ms_peptidesummarybase> & iPepSum) const override;
391
392 void buildProteinSummaryImpl(ms_proteinsummary & protSum,
393 const ms_mascotresults_params & parameters,
394 std::shared_ptr<msparser_internal::ms_mascotresultsbase> & results,
395 std::shared_ptr<msparser_internal::ms_proteinsummarybase> & iProtSum) const override;
396
397 std::shared_ptr<msparser_internal::ms_inputquerybase> buildInputQueryImpl(const int q) const override;
398
399 std::shared_ptr<msparser_internal::ms_searchparamsbase> buildSearchParamsImpl() const override;
400
401
402 // Cumulative count of queries
403 // e.g.: file1= 10, file2= 5, file3= 4 => [0, 10, 15, 19]
404 std::vector<int> cumNumQueries_;
405 // std::list because it doesn't require its elements to be copy constructible
406 std::list<ms_mascotresfile_msr> appendedFiles_;
407 // Pointers to this and all the appended files
408 std::vector<ms_mascotresfile_msr*> allFilesPtr_;
409
410 std::shared_ptr<msparser_internal::ms_sqlpp11_connection> msDbPtr_;
411 msparser_internal::ms_sqlpp11_connection & db_;
412 std::unordered_map<std::string, std::string> mapHeader_;
413
414 struct DbMetadata
415 {
416 DbMetadata()
417 : fastaFile{},
418 release{},
419 dbType{},
420 decoyType{},
421 nSequences(-1),
422 nSequencesAfterTax(-1),
423 nResidues(-1),
424 etSequences(-1)
425 {};
426
427 std::string fastaFile,
428 release,
429 dbType;
430 int decoyType,
431 nSequences,
432 nSequencesAfterTax;
433 int64_t nResidues;
434 int etSequences;
435 };
436
437 struct DbDataCache
438 {
439 DbDataCache()
440 : valid(false)
441 {}
442
443 bool valid;
444 std::map<int, DbMetadata> data;
445 };
446 mutable DbDataCache dbDataCache_;
447
448 void _cacheQueryInfoData(const int q) const;
449 void _cacheDbData() const;
450
451 // -1: Not set, 0: False, 1: True
452 mutable char anyPMFCache_;
453 mutable char anyMSMSCache_;
454 mutable char anySQCache_;
455 mutable char anyTagCache_;
456
457 mutable std::array<char, ms_peptide::N_PSM_TYPES> hasAnyPepSumMatchesCache_;
458 bool _hasAnyPeptideSummaryMatches(const ms_peptide::PSM_TYPE type) const;
459
460 int _cacheQueryData(const int q) const;
461 int _cacheQuerySeq(const int q) const;
462 int _cacheQueryComp(const int q) const;
463 int _cacheQuerySeqTag(const int q) const;
464
465 std::string processedCacheDir_;
466 std::string fileBaseName_; // File name without path
467
468 // Keep track of the number of ms_mascotresfile_msr objects created in the process
469 static std::atomic<int> resfileCounter_;
470 int id_;
471
472 msparser_internal::msr_cached_data::ResfileCaches caches_;
473
474 }; // end of resfile_group
476} // matrix_science namespace
477#endif // MS_MASCOTRESFILE_MSR_HPP
478
479/*------------------------------- End of File -------------------------------*/
matrix_science::ms_crosslinking_configfile
This class represents the file crosslinking.xml.
Definition: ms_crosslinking_configfile.hpp:49
matrix_science::ms_enzymefile
Reads and parses the enzymes file that contains multiple enzyme definitions.
Definition: ms_enzyme.hpp:194
matrix_science::ms_inputquery
This class encapsulates the input queries (peak lists) in the Mascot results file.
Definition: ms_inputquery.hpp:43
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_mascotoptions::DECOY_ALGORITHM
DECOY_ALGORITHM
Definitions for how the decoy sequences are generated.
Definition: ms_mascotoptions.hpp:156
matrix_science::ms_mascotresfile_msr
Class for parsing and reading files in MSR format.
Definition: ms_mascotresfile_msr.hpp:105
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_progress_info
Contains information of the current progress of a task being performed.
Definition: ms_progress_info.hpp:40
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
matrix_science::ms_quant_configfile
Use this class in order to read/write quantitation.xml.
Definition: ms_quant_configfile.hpp:52
matrix_science::ms_taxonomyfile
Use this class in order to read in a taxonomy file.
Definition: ms_taxonomyfile.hpp:145
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::DATABASE_TYPE
DATABASE_TYPE
Definition: ms_databaseoptions.hpp:39
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresfile_nil.hpp Source File

  • src
  • resfile
  • impl
ms_mascotresfile_nil.hpp
1/*
2 ##############################################################################
3 # file: ms_mascotresfile_nil.hpp #
4 # 'msparser' toolkit #
5 # Encapsulates a mascot results file #
6 ##############################################################################
7 # COPYRIGHT NOTICE #
8 # Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9 # #
10 ##############################################################################
11 # $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
12 # $Author: robertog@matrixscience.com $ #
13 # $Date: 2023-10-06 12:21:24 +0100 $ #
14 # $Revision: 67b0933d29b9bbbbd2df831506f0a2dd0397e101 | MSPARSER_ALPHA_2_8_101-150-g67b0933d29 $ #
15 # $NoKeywords:: $ #
16 ##############################################################################
17*/
18
19#ifndef MS_MASCOTRESFILE_NIL_HPP
20#define MS_MASCOTRESFILE_NIL_HPP
21
22
23// Includes from the standard template library
24#include <string>
25#include <vector>
26
27namespace matrix_science {
28 class ms_umod_configfile;
29 class ms_enzymefile;
30 class ms_taxonomyfile;
31 class ms_mascotresults_params;
32}
33
34namespace msparser_internal {
35
41 class ms_peptidesummary_nil;
42
43 class ms_mascotresfile_nil : public matrix_science::ms_mascotresfilebase
44 {
45 public:
46
48 ms_mascotresfile_nil(const char * szFileName,
49 const int keepAliveInterval = 0,
50 const char * keepAliveText = "<!-- %d seconds -->\n",
51 const unsigned int flags = RESFILE_NOFLAG,
52 const char * cacheDirectory = "../data/cache/%Y/%m",
53 const char * XMLschemaDirectory = 0,
54 matrix_science::ms_progress_info * progressMonitor = 0)
55 : ms_mascotresfilebase(szFileName, keepAliveInterval, keepAliveText, flags, cacheDirectory, XMLschemaDirectory, progressMonitor),
56 pepSumNil_(nullptr)
57 {
58 setError(matrix_science::ms_errs::ERR_INVALID_RESFILE);
59 params_.reset(new matrix_science::ms_searchparams(*this)); //TODO: use std::make_unique in C++14 and later
60 }
61
62 virtual ~ms_mascotresfile_nil() {}
63
64 // ------------------- Basic generic functions -------------------
65
66
68 int appendResfile(const char * filename,
69 int flags=RESFILE_USE_PARENT_PARAMS,
70 const char * cacheDirectory = 0) override { return -1; }
71
73 const ms_mascotresfile_nil* getResfile(int id) const override { return this; }
74
76 int getNumberOfResfiles() const override { return 1; }
77
79 int getJobNumber(const int resfileID = 1) const override { return -1; }
80
81 // ----------------- Specific results functions ------------------
83 int getNumQueries(const int resfileID = 0) const override { return -1; }
84
86 int getNumSeqs(const int idx = 0) const override { return -1; }
87
89 int getNumSeqsAfterTax(const int idx = 0) const override { return -1; }
90
92 int getNumEtSeqsSearched(const int idx = 0) const override { return -1; }
93
95 int getNumLibraryEntries(const int idx = 0) const override { return -1; }
96
98 double getNumResidues(const int idx = 0) const override { return -1; }
99
101 bool isDatabaseTypeAvailable() const override { return false; }
103 matrix_science::DATABASE_TYPE getDatabaseType(const int idx) const override { return matrix_science::AA; }
105 int getReferenceDatabaseNumberOfSL(const int idx) const override { return -1; }
106
108 std::vector<int> getSLDatabaseNumbersOfReference(const int idx) const override { return {}; }
109
111
116 int getExecTime() const override { return -1; }
117
119
125 int getDate() const override { return -1; }
126
128
135 std::string getMascotVer() const override { return {}; }
136
138 std::string getFastaVer(int idx = 1) const override { return {}; }
139
141 std::string getFastaPath(int idx = 1) const override { return {}; }
142
144 std::string getUniqueTaskID() const override { return {}; }
145
147 matrix_science::ms_mascotoptions::DECOY_ALGORITHM getDecoyTypeForDB(const int idx = 1) const override { return matrix_science::ms_mascotoptions::DECOY_ALGORITHM_NONE; }
148
150 double getSLFragmentTolerance(int idx = 1) const override { return -1.0; }
151
153 std::string getSLFragmentToleranceUnit(int idx = 1) const override { return {}; }
154
156 std::string getSLExecCommand(int idx = 1) const override { return {}; }
157
159 bool isPMF() const override { return false; }
160
162 bool isMSMS() const override { return false; }
163
165 bool isSQ() const override { return false; }
166
168 bool isErrorTolerant() const override { return false; }
169
171 bool anyPMF() const override { return false; }
172
174 bool anyMSMS() const override { return false; }
175
177 bool anySQ() const override { return false; }
178
180 bool anyTag() const override { return false; }
181
183 bool anyFastaMatches(const bool isDecoy=false) const override { return false; }
184
186 bool anySpectralLibraryMatches(const bool isDecoy=false) const override { return false; }
187
189 bool anyErrorTolerantMatches(const bool isDecoy=false) const override { return false; }
190
192 bool anyCrosslinkedMatches(const bool isDecoy=false) const override { return false; }
193
195 double getObservedMass(const int query) const override { return -1.0; }
196
198 int getObservedCharge(const int query, const bool decoy=false) const override { return -1; }
199
201 double getObservedMrValue(const int query, const bool decoy=false) const override { return -1.0; }
202
204 double getObservedIntensity(const int query) const override { return -1.0; }
205
207 std::string getRepeatSearchString(const int query, const bool fullQuery = false) const override { return {}; }
208
210 std::string getFileName(const int id = 1) const override { return {}; }
211
213 bool getQuantitation(matrix_science::ms_quant_configfile *qfile) const override { return false; }
214
216 bool getUnimod(matrix_science::ms_umod_configfile *ufile, bool useSchemaFromResfile = false) const override { return false; }
217
219 bool getUnimodXL(matrix_science::ms_umod_configfile *ufile, bool useSchemaFromResfile = false) const override { return false; }
220
222 bool getEnzyme(matrix_science::ms_enzymefile *efile, const char * enzymeFileName = 0) const override { return false; }
223
225 bool getTaxonomy(matrix_science::ms_taxonomyfile *tfile) const override { return false; }
226
228 std::string getCacheDirectory(bool processed = true) const override { return {}; }
229
231 std::string getCacheFileName() const override { return {}; }
232
234 static bool willCreateCache(const char * szFileName,
235 const unsigned int flags,
236 const char * cacheDirectory,
237 std::string * cacheFileName) { return false; }
238 // Can't / don't want to allow std::string * as OUTPUT in Java and C#
239 static bool willCreateCache(const char * szFileName,
240 const unsigned int flags,
241 const char * cacheDirectory,
242 std::string & cacheFileName) { return false; }
243
245 static bool willCreateCache(const char * szFileName,
246 const matrix_science::ms_mascotoptions & opts,
247 const char * applicationName,
248 std::string & resfileCacheFileName,
249 unsigned int & cacheStatus) { return false; }
250
252 bool getSrcQueryAndFileIdForMultiFile(const int q, int & gsqNewQuery, int & gsqFileId) const override { return false; }
253
255 int getMultiFileQueryNumber(const int localQuery, const int fileId) const override { return -1; }
256
258 bool hasEnzyme() const override { return false; }
259
261 bool hasRT() const override { return false; }
262
264 bool hasQuantitation() const override { return false; }
265
267 matrix_science::ms_inputquery getInputQuery(const int queryNum) const override { return matrix_science::ms_inputquery(*this, 0); }
268
270 void getHeaderKeyValues(std::vector<std::string> & keys, std::vector<std::string> & values) const override {}
271
273 void getSearchParametersKeyValues(std::vector<std::string> & keys, std::vector<std::string> & values) const override {}
274
276 void getMassesKeyValues(std::vector<std::string> & keys, std::vector<double> & values) const override {}
277
278
280 virtual std::string getHeaderValue(const std::string& key) const override { return {}; }
281
283 virtual std::string getSearchParameter(const std::string& key) const override { return {}; }
284
286 virtual double getMassValue(const std::string& key) const override { return -1.0; }
287
289 int getLibraryMods(std::vector<std::string> & modNames, std::vector<double> & modDeltas) const override { return -1; }
290
292 int64_t getQmatch(const int query, const matrix_science::ms_peptide::PSM_TYPE pepType) const override { return -1; }
293
295 double getQplughole(const int query, const matrix_science::ms_peptide::PSM_TYPE pepType) const override { return -1.0; }
296
297
298 std::string getPepSumCacheFilename(
299 const unsigned int flags,
300 double minProbability,
301 int maxHitsToReport,
302 const char * unigeneIndexFile,
303 double ignoreIonsScoreBelow,
304 int minPepLenInPepSummary,
305 const char * singleHit,
306 const unsigned int flags2) const override { return {}; }
307
308 std::string getPepSumCacheFilename(const matrix_science::ms_mascotresults_params & parameters) const override { return {}; }
309
310 // Used for unit testing
311 std::shared_ptr<ms_peptidesummary_nil> getPepSumNil() {
312 return pepSumNil_;
313 }
314
315
316 protected:
317
318 bool getCrosslinking(matrix_science::ms_crosslinking_configfile *crosslinkingFile) const override { return false; }
319
320 mutable std::shared_ptr<msparser_internal::ms_peptidesummary_nil> pepSumNil_;
321
322 private:
323
324 void validateResfileVersion() override {}
325
326 double getFirstPassThreshold() const override { return -1.0; }
327
328 int getNumHitsInProteinSummary(const matrix_science::ms_peptide::PSM_TYPE psmType) const override { return -1; }
329
330 void propagateKeepAlive(const int keepAliveInterval,
331 const char * keepAliveText,
332 const bool propagateToAppended,
333 const bool resetStartTime) override {}
334
335 bool willCreatePepSumCache(const unsigned int flags,
336 double minProbability,
337 int maxHitsToReport,
338 const char * unigeneIndexFile,
339 double ignoreIonsScoreBelow,
340 int minPepLenInPepSummary,
341 const char * singleHit,
342 const unsigned int flags2) const override { return false; }
343
344 bool willCreatePepSumCache(const matrix_science::ms_mascotresults_params &parameters) const override { return false; }
345
346 bool willCreatePepSumCache(const matrix_science::ms_mascotresults_params & parameters,
347 const matrix_science::ms_mascotoptions & opts,
348 std::string & peptideSummaryCacheFileName,
349 unsigned int & cacheStatus) const override { return false; }
350
351 void buildPeptideSummaryImpl(matrix_science::ms_peptidesummary & pepSum,
352 const matrix_science::ms_mascotresults_params & parameters,
353 std::shared_ptr<msparser_internal::ms_mascotresultsbase> & results,
354 std::shared_ptr<msparser_internal::ms_peptidesummarybase> & iPepSum) const override; //Implemented in cpp
355 void buildProteinSummaryImpl(matrix_science::ms_proteinsummary & protSum,
356 const matrix_science::ms_mascotresults_params & parameters,
357 std::shared_ptr<msparser_internal::ms_mascotresultsbase> & results,
358 std::shared_ptr<msparser_internal::ms_proteinsummarybase> & iProtSum) const override; //Imlemented in cpp
359
360 std::shared_ptr<msparser_internal::ms_inputquerybase> buildInputQueryImpl(const int q) const override; // Implemented in cpp
361
362 std::shared_ptr<msparser_internal::ms_searchparamsbase> buildSearchParamsImpl() const override; // Implemented in cpp
363
364 }; // end of resfile_group
366} // matrix_science namespace
367#endif // MS_MASCOTRESFILE_NIL_HPP
368
369/*------------------------------- End of File -------------------------------*/
matrix_science::ms_crosslinking_configfile
This class represents the file crosslinking.xml.
Definition: ms_crosslinking_configfile.hpp:49
matrix_science::ms_enzymefile
Reads and parses the enzymes file that contains multiple enzyme definitions.
Definition: ms_enzyme.hpp:194
matrix_science::ms_errs::ERR_INVALID_RESFILE
static const err ERR_INVALID_RESFILE
[F] Invalid results file format – missing or corrupt headers.
Definition: ms_errors.hpp:74
matrix_science::ms_inputquery
This class encapsulates the input queries (peak lists) in the Mascot results file.
Definition: ms_inputquery.hpp:43
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_mascotoptions::DECOY_ALGORITHM
DECOY_ALGORITHM
Definitions for how the decoy sequences are generated.
Definition: ms_mascotoptions.hpp:156
matrix_science::ms_mascotoptions::DECOY_ALGORITHM_NONE
@ DECOY_ALGORITHM_NONE
(0) No algorithm defined. An invalid value.
Definition: ms_mascotoptions.hpp:157
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresfilebase::ms_mascotresfilebase
ms_mascotresfilebase(const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory=0, const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0)
ms_mascotresfilebase is an abstract class; use createResfile().
Definition: ms_mascotresfilebase.cpp:102
matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG
@ RESFILE_NOFLAG
Dat28 format: Read the whole file into memory. MSR format: Use standard SQLite methods to read the fi...
Definition: ms_mascotresfilebase.hpp:109
matrix_science::ms_mascotresfilebase::RESFILE_USE_PARENT_PARAMS
@ RESFILE_USE_PARENT_PARAMS
For use when Combining multiple results files. The flags and parameters are then inherited from the p...
Definition: ms_mascotresfilebase.hpp:112
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_progress_info
Contains information of the current progress of a task being performed.
Definition: ms_progress_info.hpp:40
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
matrix_science::ms_quant_configfile
Use this class in order to read/write quantitation.xml.
Definition: ms_quant_configfile.hpp:52
matrix_science::ms_searchparams
This class encapsulates the search parameters in the Mascot results file.
Definition: ms_searchparams.hpp:47
matrix_science::ms_taxonomyfile
Use this class in order to read in a taxonomy file.
Definition: ms_taxonomyfile.hpp:145
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::DATABASE_TYPE
DATABASE_TYPE
Definition: ms_databaseoptions.hpp:39
matrix_science::AA
@ AA
Protein sequence database (FASTA file, amino acid)
Definition: ms_databaseoptions.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresfilebase.hpp Source File

  • inc
ms_mascotresfilebase.hpp
1/*
2##############################################################################
3# file: ms_mascotresfilebase.hpp #
4# 'msparser' toolkit #
5# Encapsulates a mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2024-09-23 15:58:21 +0100 $ #
14# $Revision: 341a28550b540d9c21b06012aa60ab0be24409b8 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESFILEBASE_HPP
20#define MS_MASCOTRESFILEBASE_HPP
21
22
23
24// Includes from the standard template library
25#include <stdarg.h>
26#include <time.h>
27#include <string>
28#include <list>
29#include <vector>
30#include <set>
31
32namespace msparser_internal {
33 class ms_peptidesummarybase;
34 class ms_proteinsummarybase;
35 class ms_inputquerybase;
36 class ms_searchparamsbase;
37}
38
39namespace matrix_science {
40 class ms_searchparams;
41 class ms_umod_configfile;
42 class ms_masses;
43 class ms_enzymefile;
44 class ms_taxonomyfile;
45 class ms_mascotresults_params;
46 class ms_proteinsummary;
47 class ms_inputquery;
48
55
71 class MS_MASCOTRESFILE_API ms_mascotresfilebase : public ms_errors
72 {
73 friend class ms_peptidesummary;
74 friend class ms_proteinsummary;
75 friend class ms_inputquery;
76 friend class ms_searchparams;
77 friend class msparser_internal::ms_peptidesummarybase;
78 friend class msparser_internal::ms_proteinsummarybase;
79
80 public:
81
83
88 enum KA_TASK
89 {
90 KA_CREATEINDEX_CI = 0,
91 KA_READFILE_RF = 1,
92 KA_ASSIGNPROTEINS_AP = 2,
93 KA_GROUPPROTEINS_GP = 3,
94 KA_UNASSIGNEDLIST_UL = 4,
95 KA_QUANTITATION = 5,
96 KA_CREATECACHE_CC = 6,
97 KA_THRESHFORFDR_FDR = 7,
98 KA_LAST = 8
99 };
100
102
106 enum FLAGS
107 {
108
109 RESFILE_NOFLAG = 0x00000000,
110 RESFILE_USE_CACHE = 0x00000001,
111 RESFILE_CACHE_IGNORE_ACC_DUPES = 0x00000002,
112 RESFILE_USE_PARENT_PARAMS = 0x00000004,
113 RESFILE_CACHE_IGNORE_DATE_CHANGE = 0x00000008
114 };
115
117
122 enum PERCOLATOR_FILE_NAMES
123 {
124 PERCOLATOR_INPUT_FILE = 0,
125 PERCOLATOR_OUTPUT_TARGET = 1,
126 PERCOLATOR_OUTPUT_DECOY = 2
127 };
128
130
132 enum XML_SCHEMA
133 {
134 XML_SCHEMA_QUANTITATION = 0,
135 XML_SCHEMA_UNIMOD = 1,
136 XML_SCHEMA_DIRECTORY = 2,
137 XML_SCHEMA_CROSSLINKING = 3,
138 XML_SCHEMA_LAST = 4
139 };
140
142
144 enum RESFILE_TYPE
145 {
146 RESFILE_DAT28 = 0,
147 RESFILE_MSR = 1,
148 RESFILE_UNKNOWN = 2
149 };
150
152 ms_mascotresfilebase(const char * szFileName, const int keepAliveInterval = 0,
153 const char * keepAliveText = "<!-- %d seconds -->\n",
154 const unsigned int flags = RESFILE_NOFLAG,
155 const char * cacheDirectory = 0, const char * XMLschemaDirectory = 0, ms_progress_info * progressMonitor = 0);
156
157 virtual ~ms_mascotresfilebase(){};
158
159 // ------------------- Basic generic functions -------------------
160
162 std::string getMSParserVersion() const;
163
165 bool versionGreaterOrEqual(int major, int minor, int revision) const;
166
168 virtual int appendResfile(const char * filename,
169 int flags=RESFILE_USE_PARENT_PARAMS,
170 const char * cacheDirectory = 0) = 0; // returns 'id' of added file
171
172 virtual const ms_mascotresfilebase* getResfile(int id) const = 0;
173
175 virtual int getNumberOfResfiles() const = 0;
176
178 virtual int getJobNumber(const int resfileID = 1) const = 0;
179
180
181#ifndef SWIG
182 // Not used from the outside world...
183 void setError(int error, ...) ;
184 void vsetError(int error, va_list arg);
185#endif
186
188 int getNumberOfErrors() const;
189
191 int getErrorNumber(const int num = -1) const;
192
194 int getLastError() const;
195
197 std::string getErrorString(const int num) const;
198
200 std::string getLastErrorString() const;
201
203 void appendErrors(ms_errs & errs);
204
206 void resetKeepAlive(const int keepAliveInterval, const char * keepAliveText,
207 const bool propagateToAppended = true, const bool resetStartTime = false);
208
209 // ----------------- Specific results functions ------------------
211 virtual int getNumQueries(const int resfileID = 0) const = 0;
212
214 virtual int getNumSeqs(const int idx = 0) const = 0;
215
217 virtual int getNumSeqsAfterTax(const int idx = 0) const = 0;
218
220 virtual int getNumEtSeqsSearched(const int idx = 0) const = 0;
221
223 virtual int getNumLibraryEntries(const int idx = 0) const = 0;
224
226 virtual double getNumResidues(const int idx = 0) const = 0;
227
229 virtual bool isDatabaseTypeAvailable() const = 0;
231 virtual DATABASE_TYPE getDatabaseType(const int idx) const = 0;
233 virtual int getReferenceDatabaseNumberOfSL(const int idx) const = 0;
234
236 virtual std::vector<int> getSLDatabaseNumbersOfReference(const int idx) const = 0;
237
239
249 virtual int getExecTime() const = 0;
250
252
263 virtual int getDate() const = 0;
264
266
276 virtual std::string getMascotVer() const = 0;
277
279 virtual std::string getFastaVer(int idx = 1) const = 0;
280
282 virtual std::string getFastaPath(int idx = 1) const = 0;
283
285 virtual std::string getUniqueTaskID() const = 0;
286
288 virtual ms_mascotoptions::DECOY_ALGORITHM getDecoyTypeForDB(const int idx = 1) const = 0;
289
291 virtual double getSLFragmentTolerance(int idx = 1) const = 0;
292
294 virtual std::string getSLFragmentToleranceUnit(int idx = 1) const = 0;
295
297 virtual std::string getSLExecCommand(int idx = 1) const = 0;
298
300 virtual bool isPMF() const = 0;
301
303 virtual bool isMSMS() const = 0;
304
306 virtual bool isSQ() const = 0;
307
309 virtual bool isErrorTolerant() const = 0;
310
312 virtual bool anyPMF() const = 0;
313
315 virtual bool anyMSMS() const = 0;
316
318 virtual bool anySQ() const = 0;
319
321 virtual bool anyTag() const = 0;
322
324 virtual bool anyFastaMatches(const bool isDecoy=false) const = 0;
325
327 virtual bool anySpectralLibraryMatches(const bool isDecoy=false) const = 0;
328
330 virtual bool anyErrorTolerantMatches(const bool isDecoy=false) const = 0;
331
333 virtual bool anyCrosslinkedMatches(const bool isDecoy=false) const = 0;
334
336 virtual double getObservedMass(const int query) const = 0;
337
339 virtual int getObservedCharge(const int query, const bool decoy=false) const = 0;
340
342 virtual double getObservedMrValue(const int query, const bool decoy=false) const = 0;
343
345 virtual double getObservedIntensity(const int query) const = 0;
346
348 virtual std::string getRepeatSearchString(const int query, const bool fullQuery = false) const = 0;
349
351 virtual std::string getFileName(const int id = 1) const = 0;
352
354
358 ms_searchparams & params() const { return *params_; };
359
361 virtual bool getQuantitation(ms_quant_configfile *qfile) const = 0;
362
364 bool setXMLschemaFilePath(XML_SCHEMA XMLschema, const char * path);
365
367 std::string getXMLschemaFilePath(XML_SCHEMA XMLschema) const;
368
370 bool getQuantitationMethod(ms_quant_method *qmethod) const;
371
373 bool getCrosslinkingMethod(ms_crosslinking_method *method) const;
374
376 virtual bool getUnimod(ms_umod_configfile *ufile, bool useSchemaFromResfile = false) const = 0;
377
379 virtual bool getUnimodXL(ms_umod_configfile *ufile, bool useSchemaFromResfile = false) const = 0;
380
382 const ms_modification* getMonoLinkModification(const int modNum, const int monoLink) const;
383
385 bool getMasses(ms_masses * masses) const;
386
388 virtual bool getEnzyme(ms_enzymefile *efile, const char * enzymeFileName = 0) const = 0;
389
391 virtual bool getTaxonomy(ms_taxonomyfile *tfile) const = 0;
392
394 bool outputKeepAlive() const;
395
396#ifndef SWIG
398 void getKeepAlive(KA_TASK & kaTask,
399 int & kaPercentage,
400 std::string & kaAccession,
401 int & kaHit,
402 int & kaQuery,
403 std::string & kaText) const;
404#else // SWIG Multiple return values
405 void getKeepAlive(KA_TASK & OUTPUT,
406 int & OUTPUT,
407 std::string & OUTPUT,
408 int & OUTPUT,
409 int & OUTPUT,
410 std::string & OUTPUT) const;
411#endif
412 // \internal Internal use only
413 bool outputKeepAlive(KA_TASK kaTask, int percentageComplete, const char * accession, int hit, int query) const;
414
416 ms_progress_info * getProgressInfo(bool forPeptideSummary = false) const;
417
419 virtual std::string getCacheDirectory(bool processed = true) const = 0;
420
422 virtual std::string getCacheFileName() const = 0;
423
425 std::string get_ms_mascotresults_params(const ms_mascotoptions & opts,
426 ms_mascotresults_params & params) const;
427
429 void setPercolatorFeatures(const char * percolatorFeatures,
430 const char * additionalFeatures,
431 const bool useRetentionTimes);
432
434 void setPercolatorFeatures(const ms_mascotoptions & options,
435 const char * additionalFeatures,
436 const std::vector<std::string> &adapterParameters = std::vector<std::string>());
437
439 std::vector<std::string> getPercolatorFileNames() const;
440
441#ifndef SWIG
443 virtual bool getSrcQueryAndFileIdForMultiFile(const int q, int & gsqNewQuery, int & gsqFileId) const = 0;
444#else // SWIG Multiple return values
445 virtual bool getSrcQueryAndFileIdForMultiFile(const int q, int & OUTPUT, int & OUTPUT) const = 0;
446#endif
448 virtual int getMultiFileQueryNumber(const int localQuery, const int fileId) const = 0;
449
451 std::string getEncodedPercolatorFeatures() const { return percolatorFeatures_; }
452
454 static bool staticGetPercolatorFileNames(const char * szFileName,
455 const char * cacheDirectory,
456 const char * percolatorFeatures,
457 const char * additionalFeatures,
458 const bool useRetentionTimes,
459 std::vector<std::string> & filenames,
460 std::vector<bool> & exists);
461
463 static bool staticGetPercolatorFileNames(const char * szFileName,
464 const char * cacheDirectory,
465 const ms_mascotoptions & options,
466 const char * additionalFeatures,
467 const std::vector<std::string> &adapterParameters,
468 std::vector<std::string> & filenames,
469 std::vector<bool> & exists);
470
471
472#ifndef SWIG
474 static bool willCreateCache(const char * szFileName,
475 const unsigned int flags,
476 const char * cacheDirectory,
477 std::string * cacheFileName);
478 // Can't / don't want to allow std::string * as OUTPUT in Java and C#
479 static bool willCreateCache(const char * szFileName,
480 const unsigned int flags,
481 const char * cacheDirectory,
482 std::string & cacheFileName) {
483 return (ms_mascotresfilebase::willCreateCache(szFileName, flags, cacheDirectory, &cacheFileName));
484 }
485
487 static bool willCreateCache(const char * szFileName,
488 const ms_mascotoptions & opts,
489 const char * applicationName,
490 std::string & resfileCacheFileName,
491 unsigned int & cacheStatus);
492
494 std::string get_ms_mascotresults_params(const ms_mascotoptions & opts,
495 unsigned int * gpFlags,
496 double * gpMinProbability,
497 int * gpMaxHitsToReport,
498 double * gpIgnoreIonsScoreBelow,
499 unsigned int * gpMinPepLenInPepSummary,
500 bool * gpUsePeptideSummary,
501 unsigned int * gpFlags2) const;
502
503#else // SWIG Multiple return values
504 static bool willCreateCache(const char * szFileName,
505 const unsigned int flags,
506 const char * cacheDirectory,
507 std::string & OUTPUT);
508
509 static bool willCreateCache(const char * szFileName,
510 const ms_mascotoptions & opts,
511 const char * applicationName,
512 std::string & OUTPUT,
513 unsigned int & OUTPUT);
514
515 std::string get_ms_mascotresults_params(const ms_mascotoptions & opts,
516 unsigned int * OUTPUT,
517 double * OUTPUT,
518 int * OUTPUT,
519 double * OUTPUT,
520 unsigned int * OUTPUT,
521 bool * OUTPUT,
522 unsigned int * OUTPUT) const;
523
524#endif
526 static RESFILE_TYPE resfileType(const std::string& fileName);
527
529 static std::unique_ptr<ms_mascotresfilebase> createResfile(const char * szFileName,
530 const int keepAliveInterval = 0,
531 const char * keepAliveText = "<!-- %d seconds -->\n",
532 const unsigned int flags = matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG,
533 const char * cacheDirectory = "../data/cache/%Y/%m",
534 const char * XMLschemaDirectory = 0,
535 matrix_science::ms_progress_info * progressMonitor = 0);
536
538 virtual bool hasEnzyme() const = 0;
539
541 virtual bool hasRT() const = 0;
542
544 virtual bool hasQuantitation() const = 0;
545
547 virtual ms_inputquery getInputQuery(const int queryNum) const = 0;
548
549
550
551#ifndef SWIG
553 virtual void getHeaderKeyValues(std::vector<std::string> & keys, std::vector<std::string> & values) const = 0;
554
556 virtual void getSearchParametersKeyValues(std::vector<std::string> & keys, std::vector<std::string> & values) const = 0;
557
559 virtual void getMassesKeyValues(std::vector<std::string> & keys, std::vector<double> & values) const = 0;
560#else // SWIG Multiple return values
561 virtual void getHeaderKeyValues(std::vector<std::string> & OUTPUT, std::vector<std::string> & OUTPUT) const = 0;
562
563 virtual void getSearchParametersKeyValues(std::vector<std::string> & OUTPUT, std::vector<std::string> & OUTPUT) const = 0;
564
565 virtual void getMassesKeyValues(std::vector<std::string> & OUTPUT, std::vector<double> & OUTPUT) const = 0;
566#endif
568 virtual std::string getHeaderValue(const std::string& key) const = 0;
569
571 virtual std::string getSearchParameter(const std::string& key) const = 0;
572
574 virtual double getMassValue(const std::string& key) const = 0;
575
577 virtual int getLibraryMods(std::vector<std::string> & modNames, std::vector<double> & modDeltas) const = 0;
578
580 virtual int64_t getQmatch(const int query, const ms_peptide::PSM_TYPE pepType) const = 0;
581
583 virtual double getQplughole(const int query, const ms_peptide::PSM_TYPE pepType) const = 0;
584
586 virtual double getFirstPassThreshold() const = 0;
587
588 protected:
589
590 void setError(int error, ...) const;
591 bool setErrorInfoFromString(const std::string & e);
592 std::string getErrorInfoAsString(const int num) const;
593 bool isErrorAlreadyPresent(const int errNum) const;
594
595 bool getPercolatorUseRetentionTimes() const { return percolatorUseRetentionTimes_; };
596
597 virtual void validateResfileVersion() = 0;
598
599 std::string diffResfiles(const ms_mascotresfilebase * resfile) const;
600 virtual bool getCrosslinking(ms_crosslinking_configfile *crosslinkingFile) const = 0;
601
602 void prepareKeepAlive(const char * keepAliveText, const bool resetStartTime);
603 virtual void propagateKeepAlive(const int keepAliveInterval,
604 const char * keepAliveText,
605 const bool propagateToAppended,
606 const bool resetStartTime) = 0;
607
608 virtual std::string getPepSumCacheFilename(
609 const unsigned int flags,
610 double minProbability,
611 int maxHitsToReport,
612 const char * unigeneIndexFile,
613 double ignoreIonsScoreBelow,
614 int minPepLenInPepSummary,
615 const char * singleHit,
616 const unsigned int flags2) const = 0;
617
618 virtual std::string getPepSumCacheFilename(const ms_mascotresults_params & parameters) const = 0;
619
620 // Equivalent to ms_mascotresfile_dat::getNumHits(const section sec=SEC_SUMMARY)
621 virtual int getNumHitsInProteinSummary(const ms_peptide::PSM_TYPE psmType) const = 0;
622
624 virtual bool willCreatePepSumCache(
625 const unsigned int flags,
626 double minProbability,
627 int maxHitsToReport,
628 const char * unigeneIndexFile,
629 double ignoreIonsScoreBelow,
630 int minPepLenInPepSummary,
631 const char * singleHit,
632 const unsigned int flags2) const = 0;
633
635 virtual bool willCreatePepSumCache(const ms_mascotresults_params &parameters) const = 0;
636
638 virtual bool willCreatePepSumCache(const ms_mascotresults_params & parameters,
639 const ms_mascotoptions & opts,
640 std::string & peptideSummaryCacheFileName,
641 unsigned int & cacheStatus) const = 0;
642
643 virtual void buildPeptideSummaryImpl(ms_peptidesummary & pepSum,
644 const ms_mascotresults_params & parameters,
645 std::shared_ptr<msparser_internal::ms_mascotresultsbase> & results,
646 std::shared_ptr<msparser_internal::ms_peptidesummarybase> & iPepSum
647 ) const = 0;
648
649 virtual void buildProteinSummaryImpl(ms_proteinsummary & protSum,
650 const ms_mascotresults_params & parameters,
651 std::shared_ptr<msparser_internal::ms_mascotresultsbase> & results,
652 std::shared_ptr<msparser_internal::ms_proteinsummarybase> & iProtSum
653 ) const = 0;
654
655 virtual std::shared_ptr<msparser_internal::ms_inputquerybase> buildInputQueryImpl(const int q) const = 0;
656
657 virtual std::shared_ptr<msparser_internal::ms_searchparamsbase> buildSearchParamsImpl() const = 0;
658
659
660 int numQueries_; // For multifile, this is the total of all queries for all files.
661 std::string fileName_;
662 unsigned int flags_;
663 std::string cacheDirectory_;
664 std::string percolatorFeatures_; // Encoded string
665 bool percolatorUseRetentionTimes_; // Already encoded in percolatorFeatures_ but here for convenience.
666 std::vector<std::string> percolatorFileNames_;
667 std::string version_;
668
669 std::unique_ptr<ms_searchparams> params_;
670 std::vector<std::string> xmlSchemaPath_;
671
672 int keepAliveInterval_;
673 std::string keepAliveTextStr_;
674 std::string keepAliveText_[KA_LAST];
675 time_t keepAliveStartTime_;
676 // Following are mutable so outputKeepAlive can be a const function
677 mutable KA_TASK keepAliveTask_;
678 mutable time_t lastKeepAliveTime_;
679 mutable int keepAlivePercentage_;
680 mutable std::string keepAliveAccession_;
681 mutable int keepAliveHit_;
682 mutable int keepAliveQuery_;
683
684 ms_progress_info * progressMonitor_;
685 mutable ms_progress_info * pepSummaryProgressMonitor_;
686
687
688
689 private:
691 static bool willCreateCacheDat(const char * szFileName,
692 const unsigned int flags,
693 const char * cacheDirectory,
694 std::string * cacheFileName);
695
697 static bool willCreateCacheDat(const char * szFileName,
698 const ms_mascotoptions & opts,
699 const char * applicationName,
700 std::string & resfileCacheFileName,
701 unsigned int & cacheStatus);
702
703 std::string getKeepAliveString(const double elapsedTime) const;
704
705 std::vector<int> getPMFqueriesUsed() const;
706
707 void cacheMonoLinkModifications() const;
708
709 mutable std::map< std::pair<int, int>, ms_modification > monoLinkCache_;
710 mutable bool monoLinksCached_;
711
712 }; // end of resfile_group
714} // matrix_science namespace
715#endif // MS_MASCOTRESFILE_HPP
716
717/*------------------------------- End of File -------------------------------*/
matrix_science::ms_crosslinking_configfile
This class represents the file crosslinking.xml.
Definition: ms_crosslinking_configfile.hpp:49
matrix_science::ms_crosslinking_method
Represents a method object in crosslinking.xml
Definition: ms_crosslinking_method.hpp:50
matrix_science::ms_enzymefile
Reads and parses the enzymes file that contains multiple enzyme definitions.
Definition: ms_enzyme.hpp:194
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_inputquery
This class encapsulates the input queries (peak lists) in the Mascot results file.
Definition: ms_inputquery.hpp:43
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_mascotoptions::DECOY_ALGORITHM
DECOY_ALGORITHM
Definitions for how the decoy sequences are generated.
Definition: ms_mascotoptions.hpp:156
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresfilebase::getExecTime
virtual int getExecTime() const =0
Returns the time taken for the search.
matrix_science::ms_mascotresfilebase::PERCOLATOR_FILE_NAMES
PERCOLATOR_FILE_NAMES
Offsets into a vector of Percolator filenames.
Definition: ms_mascotresfilebase.hpp:123
matrix_science::ms_mascotresfilebase::getFastaPath
virtual std::string getFastaPath(int idx=1) const =0
Returns the path to the FASTA file used.
matrix_science::ms_mascotresfilebase::hasRT
virtual bool hasRT() const =0
Return true if the results file contains retention time data.
matrix_science::ms_mascotresfilebase::getSLDatabaseNumbersOfReference
virtual std::vector< int > getSLDatabaseNumbersOfReference(const int idx) const =0
Return the database numbers of the spectral libraries whose reference database is at the given index.
matrix_science::ms_mascotresfilebase::anyFastaMatches
virtual bool anyFastaMatches(const bool isDecoy=false) const =0
Returns true if there are any FASTA matches.
matrix_science::ms_mascotresfilebase::getDate
virtual int getDate() const =0
Returns the date and time of the search in seconds since midnight January 1st 1970.
matrix_science::ms_mascotresfilebase::getNumberOfResfiles
virtual int getNumberOfResfiles() const =0
Multiple results files can be summed together and treated as 'one'.
matrix_science::ms_mascotresfilebase::getNumResidues
virtual double getNumResidues(const int idx=0) const =0
Returns the number of residues in the FASTA file(s) searched.
matrix_science::ms_mascotresfilebase::getNumSeqs
virtual int getNumSeqs(const int idx=0) const =0
Returns the number of sequences in the FASTA file(s) searched.
matrix_science::ms_mascotresfilebase::getHeaderValue
virtual std::string getHeaderValue(const std::string &key) const =0
Return the header value for the given key.
matrix_science::ms_mascotresfilebase::KA_TASK
KA_TASK
Processing some results files is computationally intensive. These are the tasks that can be performed...
Definition: ms_mascotresfilebase.hpp:89
matrix_science::ms_mascotresfilebase::anySpectralLibraryMatches
virtual bool anySpectralLibraryMatches(const bool isDecoy=false) const =0
Returns true if there are any Spectral Library matches.
matrix_science::ms_mascotresfilebase::XML_SCHEMA
XML_SCHEMA
The results file contains embedded files in XML format and these need to be validated against a schem...
Definition: ms_mascotresfilebase.hpp:133
matrix_science::ms_mascotresfilebase::anyErrorTolerantMatches
virtual bool anyErrorTolerantMatches(const bool isDecoy=false) const =0
Returns true if there are any Error Tolerant matches.
matrix_science::ms_mascotresfilebase::getJobNumber
virtual int getJobNumber(const int resfileID=1) const =0
Return the job number for this file - obtained from the file name.
matrix_science::ms_mascotresfilebase::getNumLibraryEntries
virtual int getNumLibraryEntries(const int idx=0) const =0
Returns the number of entries in the spectral library searched.
matrix_science::ms_mascotresfilebase::getObservedIntensity
virtual double getObservedIntensity(const int query) const =0
Returns the experimental intensity for the peptide.
matrix_science::ms_mascotresfilebase::getObservedMrValue
virtual double getObservedMrValue(const int query, const bool decoy=false) const =0
Returns the experimental mass value (as a relative mass) as entered by the user.
matrix_science::ms_mascotresfilebase::getObservedCharge
virtual int getObservedCharge(const int query, const bool decoy=false) const =0
The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc....
matrix_science::ms_mascotresfilebase::getDatabaseType
virtual DATABASE_TYPE getDatabaseType(const int idx) const =0
Return database type if available.
matrix_science::ms_mascotresfilebase::getEnzyme
virtual bool getEnzyme(ms_enzymefile *efile, const char *enzymeFileName=0) const =0
Returns an object that represents the embedded enzyme file as a reduced enzymes file.
matrix_science::ms_mascotresfilebase::getUniqueTaskID
virtual std::string getUniqueTaskID() const =0
Returns the unique task ID used by Mascot Daemon.
matrix_science::ms_mascotresfilebase::getNumSeqsAfterTax
virtual int getNumSeqsAfterTax(const int idx=0) const =0
Returns the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.
matrix_science::ms_mascotresfilebase::getInputQuery
virtual ms_inputquery getInputQuery(const int queryNum) const =0
Return the ms_inputquery object for the query given as argument.
matrix_science::ms_mascotresfilebase::getUnimodXL
virtual bool getUnimodXL(ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const =0
Returns an object that represents the embedded unimod_xl file as a reduced unimod_xl....
matrix_science::ms_mascotresfilebase::getLibraryMods
virtual int getLibraryMods(std::vector< std::string > &modNames, std::vector< double > &modDeltas) const =0
Return all the library mod names and deltas.
matrix_science::ms_mascotresfilebase::isDatabaseTypeAvailable
virtual bool isDatabaseTypeAvailable() const =0
Check whether database types are available.
matrix_science::ms_mascotresfilebase::getSLFragmentToleranceUnit
virtual std::string getSLFragmentToleranceUnit(int idx=1) const =0
Returns the unit of the effective spectral library fragment tolerance.
matrix_science::ms_mascotresfilebase::getQuantitation
virtual bool getQuantitation(ms_quant_configfile *qfile) const =0
Returns an object that represents the embedded quantitation file as a reduced quantitation....
matrix_science::ms_mascotresfilebase::anyTag
virtual bool anyTag() const =0
Returns true if any of the queries in the search contain tag or etag commands.
matrix_science::ms_mascotresfilebase::getCrosslinking
virtual bool getCrosslinking(ms_crosslinking_configfile *crosslinkingFile) const =0
matrix_science::ms_mascotresfilebase::RESFILE_TYPE
RESFILE_TYPE
Supported results file formats.
Definition: ms_mascotresfilebase.hpp:145
matrix_science::ms_mascotresfilebase::hasEnzyme
virtual bool hasEnzyme() const =0
Return true if the results file contains information about the enzyme used.
matrix_science::ms_mascotresfilebase::anyMSMS
virtual bool anyMSMS() const =0
Returns true if any of the queries in the search contain ions data.
matrix_science::ms_mascotresfilebase::getNumEtSeqsSearched
virtual int getNumEtSeqsSearched(const int idx=0) const =0
Returns the number of sequences searched in the second pass of an integrated error tolerant search.
matrix_science::ms_mascotresfilebase::hasQuantitation
virtual bool hasQuantitation() const =0
Return true if the results file contains quantitation data.
matrix_science::ms_mascotresfilebase::isPMF
virtual bool isPMF() const =0
Returns true if the search was a PMF search (SEARCH=PMF).
matrix_science::ms_mascotresfilebase::getMascotVer
virtual std::string getMascotVer() const =0
Returns the version of Mascot used to perform the search.
matrix_science::ms_mascotresfilebase::isMSMS
virtual bool isMSMS() const =0
Returns true if the search was an MSMS search (SEARCH=MIS).
matrix_science::ms_mascotresfilebase::getCacheFileName
virtual std::string getCacheFileName() const =0
Returns the filename of the cache file; see ms_mascotresfile_msr::getCacheFileName() and ms_mascotres...
matrix_science::ms_mascotresfilebase::getUnimod
virtual bool getUnimod(ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const =0
Returns an object that represents the embedded unimod file as a reduced unimod_2.xml file.
matrix_science::ms_mascotresfilebase::anyCrosslinkedMatches
virtual bool anyCrosslinkedMatches(const bool isDecoy=false) const =0
Returns true if there are any Crosslinked matches.
matrix_science::ms_mascotresfilebase::appendResfile
virtual int appendResfile(const char *filename, int flags=RESFILE_USE_PARENT_PARAMS, const char *cacheDirectory=0)=0
Multiple results files can be summed together and treated as 'one'.
matrix_science::ms_mascotresfilebase::getTaxonomy
virtual bool getTaxonomy(ms_taxonomyfile *tfile) const =0
Returns an object that represents the embedded taxonomy file as a reduced taxonomy file.
matrix_science::ms_mascotresfilebase::getMassValue
virtual double getMassValue(const std::string &key) const =0
Return the residue or modification mass for the given key.
matrix_science::ms_mascotresfilebase::getMultiFileQueryNumber
virtual int getMultiFileQueryNumber(const int localQuery, const int fileId) const =0
Return the multi-file query number from the local query number in an appended file.
matrix_science::ms_mascotresfilebase::getFirstPassThreshold
virtual double getFirstPassThreshold() const =0
Return the threshold value for the first pass of an automated error tolerant search.
matrix_science::ms_mascotresfilebase::getSLExecCommand
virtual std::string getSLExecCommand(int idx=1) const =0
Returns the library search command line and parameters (sl_exec_command).
matrix_science::ms_mascotresfilebase::getResfile
virtual const ms_mascotresfilebase * getResfile(int id) const =0
matrix_science::ms_mascotresfilebase::getQplughole
virtual double getQplughole(const int query, const ms_peptide::PSM_TYPE pepType) const =0
Return the threshold score for homologous peptide match (MIS only).
matrix_science::ms_mascotresfilebase::isErrorTolerant
virtual bool isErrorTolerant() const =0
Returns true if the search was an error tolerant search.
matrix_science::ms_mascotresfilebase::getHeaderKeyValues
virtual void getHeaderKeyValues(std::vector< std::string > &keys, std::vector< std::string > &values) const =0
Return all the header key-value pairs.
matrix_science::ms_mascotresfilebase::getSearchParameter
virtual std::string getSearchParameter(const std::string &key) const =0
Return the search parameter the given key.
matrix_science::ms_mascotresfilebase::getQmatch
virtual int64_t getQmatch(const int query, const ms_peptide::PSM_TYPE pepType) const =0
Return the number of peptide masses within precursor tolerance of this query.
matrix_science::ms_mascotresfilebase::getCacheDirectory
virtual std::string getCacheDirectory(bool processed=true) const =0
Returns the directory being used for cache files (if any).
matrix_science::ms_mascotresfilebase::getObservedMass
virtual double getObservedMass(const int query) const =0
Returns the experimental mass value as entered by the user.
matrix_science::ms_mascotresfilebase::isSQ
virtual bool isSQ() const =0
Returns true if the search was a sequence query search (SEARCH=SQ).
matrix_science::ms_mascotresfilebase::getFastaVer
virtual std::string getFastaVer(int idx=1) const =0
Returns the FASTA file version.
matrix_science::ms_mascotresfilebase::anyPMF
virtual bool anyPMF() const =0
Returns true if any of the queries in the search just contain a single peptide mass.
matrix_science::ms_mascotresfilebase::getReferenceDatabaseNumberOfSL
virtual int getReferenceDatabaseNumberOfSL(const int idx) const =0
Return the database number of the reference database of a spectral library.
matrix_science::ms_mascotresfilebase::getSrcQueryAndFileIdForMultiFile
virtual bool getSrcQueryAndFileIdForMultiFile(const int q, int &gsqNewQuery, int &gsqFileId) const =0
Return the query number and file ID in the source results file.
matrix_science::ms_mascotresfilebase::getMassesKeyValues
virtual void getMassesKeyValues(std::vector< std::string > &keys, std::vector< double > &values) const =0
Return all the residue and modification masses as key-value pairs.
matrix_science::ms_mascotresfilebase::getRepeatSearchString
virtual std::string getRepeatSearchString(const int query, const bool fullQuery=false) const =0
To perform a repeat search need to build up appropriate string.
matrix_science::ms_mascotresfilebase::getSearchParametersKeyValues
virtual void getSearchParametersKeyValues(std::vector< std::string > &keys, std::vector< std::string > &values) const =0
Return all the search parameters as key-value pairs.
matrix_science::ms_mascotresfilebase::getDecoyTypeForDB
virtual ms_mascotoptions::DECOY_ALGORITHM getDecoyTypeForDB(const int idx=1) const =0
Returns the decoy algorithm type for a given database.
matrix_science::ms_mascotresfilebase::getSLFragmentTolerance
virtual double getSLFragmentTolerance(int idx=1) const =0
Returns the effective spectral library fragment tolerance.
matrix_science::ms_mascotresfilebase::getNumQueries
virtual int getNumQueries(const int resfileID=0) const =0
Returns the number of queries (peptide masses or ms-ms spectra).
matrix_science::ms_mascotresfilebase::params
ms_searchparams & params() const
Returns a reference to the search parameters class.
Definition: ms_mascotresfilebase.hpp:358
matrix_science::ms_mascotresfilebase::getFileName
virtual std::string getFileName(const int id=1) const =0
Returns the name of the results file passed into the constructor.
matrix_science::ms_mascotresfilebase::anySQ
virtual bool anySQ() const =0
Returns true if any of the queries in the search contain seq or comp commands.
matrix_science::ms_mascotresfilebase::FLAGS
FLAGS
Flags for opening the results file.
Definition: ms_mascotresfilebase.hpp:107
matrix_science::ms_mascotresfilebase::RESFILE_NOFLAG
@ RESFILE_NOFLAG
Dat28 format: Read the whole file into memory. MSR format: Use standard SQLite methods to read the fi...
Definition: ms_mascotresfilebase.hpp:109
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_masses
Reads and parses the masses file with residue and atom masses.
Definition: ms_masses.hpp:48
matrix_science::ms_modification
The class represents a single modification-entry in mod_file.
Definition: ms_modfile.hpp:134
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_progress_info
Contains information of the current progress of a task being performed.
Definition: ms_progress_info.hpp:40
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
matrix_science::ms_quant_configfile
Use this class in order to read/write quantitation.xml.
Definition: ms_quant_configfile.hpp:52
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_searchparams
This class encapsulates the search parameters in the Mascot results file.
Definition: ms_searchparams.hpp:47
matrix_science::ms_taxonomyfile
Use this class in order to read in a taxonomy file.
Definition: ms_taxonomyfile.hpp:145
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::DATABASE_TYPE
DATABASE_TYPE
Definition: ms_databaseoptions.hpp:39
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresfilebase_util.hpp Source File

  • src
  • resfile
  • impl
ms_mascotresfilebase_util.hpp
1/*
2##############################################################################
3# file: ms_mascotresfilebase_util.hpp #
4# Private functions used by ms_mascotresfilebase. #
5##############################################################################
6# COPYRIGHT NOTICE #
7# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
8# #
9##############################################################################
10# $Author: $
11# $Date: $
12# $Revision: $
13# $NoKeywords:: $ #
14##############################################################################
15*/
16
17#ifndef MS_MASCOTRESFILEBASE_UTIL_HPP
18#define MS_MASCOTRESFILEBASE_UTIL_HPP
19
20#include <string>
21#include <vector>
22
23using namespace matrix_science;
24
25namespace msparser_internal {
27
33 namespace ms_mascotresfilebase_util {
34
36 bool staticGetPercolatorFileNames(const char * szFileName,
37 const char * cacheDirectoryTemplate,
38 const std::string & relevantOpts,
39 std::vector<std::string> & filenames,
40 std::vector<bool> & exists);
41
43 std::string percolatorFeatureChecksum(const std::string &relevantOpts);
44
46 std::string getSortedPercolatorFeatures(const ms_mascotoptions & options,
47 const char * additionalFeatures,
48 const std::vector<std::string> & adapterParameters);
49
51 std::string getSortedPercolatorFeatures(const char * percolatorFeatures,
52 const char * additionalFeatures,
53 const bool useRetentionTimes);
54
56 std::string getSortedAdapterFeatures(std::vector<std::string> adapterParameters);
57
58 } // ms_mascotresfilebase_util namespace
59 // end of resfile_group
61
63} // msparser_internal namespace
64
65#endif // MS_MASCOTRESFILEBASE_UTIL_HPP
66
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresults.hpp Source File

  • inc
ms_mascotresults.hpp
1/*
2##############################################################################
3# file: ms_mascotresults.hpp #
4# 'msparser' toolkit #
5# Abstract class for either ms_peptidesummary or ms_proteinsummary #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresul $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2024-09-23 16:49:32 +0100 $ #
14# $Revision: 9380e01cc54b09b4a89586cc2064ed96df95f3bf | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESULTS_HPP
20#define MS_MASCOTRESULTS_HPP
21
22
23// Includes from the standard template library
24#include <string>
25#include <list>
26#include <vector>
27#include <set>
28#include <map>
29#include <algorithm>
30#include <memory>
31
32namespace msparser_internal {
33 class ms_unassigned;
34 class ms_protein_match_data;
35 struct peptide_impl_args;
36 class linearPeptideData_t;
37 class ms_mascotresultsbase;
38}
39
40namespace matrix_science {
46 class ms_unigene;
47 class ms_protein;
48 class ms_peptide;
49 class ms_quant_component;
50 class ms_mascotresults_params;
51
52#ifndef SWIG
53
55 struct LexicoCompare
56 {
57 bool caseSensitive_;
58 LexicoCompare(bool caseSensitive) : caseSensitive_(caseSensitive) { }
59 bool operator()(const std::string& left, const std::string& right ) const;
60 };
61#endif
62
63
65
82 class MS_MASCOTRESFILE_API ms_mascotresults
83 {
84 friend class ms_protein;
85 friend class ms_peptide;
86 friend class msparser_internal::ms_peptidesumcdb;
87
88 public:
89
91
94 enum sortBy
95 {
96 QUERY,
97 SCORE,
98 INTENSITY
99
100 };
101
110 enum dupeStatus
111 {
112 dupe_query_same = 0x0001,
113 dupe_seq_same = 0x0002,
114 dupe_mods_same = 0x0004,
115 dupe_pos_same = 0x0008,
116
117 // Bug 13818: Conceptually different to the other duplicate statuses.
118 // Used to indicate if all the components (alpha and beta in a crosslinked match)
119 // are in the same protein.
120 dupe_protein_same = 0x0010
121 };
122
124
127 enum TREE_CLUSTER_METHOD
128 {
129 TCM_FIRST_VALUE = 0x0001, // For looping - undocumented
130 TCM_PAIRWISE_SINGLE = 0x0001,
131 TCM_PAIRWISE_MAXIMUM = 0x0002,
132 TCM_PAIRWISE_AVERAGE = 0x0003,
133
134 TCM_LAST_VALUE = 0x0003 // For looping - undocumented
135 };
136
138
145 enum FIND_FLAGS
146 {
147 FT_PEPTIDE_EXP_MZ = 0x00000001,
148 FT_PEPTIDE_EXP_MR = 0x00000002,
149 FT_PEPTIDE_CALC_MZ = 0x00000004,
150 FT_PEPTIDE_CALC_MR = 0x00000008,
151 FT_PEPTIDE_STRING = 0x00000010,
152 FT_PEPTIDE_QUERY = 0x00000020,
153
154 FT_PEPTIDE_VARMOD = 0x00000040,
155 FT_PEPTIDE_FIXMOD = 0x00000080,
156 FT_PEPTIDE_ETMOD = 0x00000100,
157 FT_PEPTIDE_SLMOD = 0x00000200,
158 FT_PEPTIDE_VARMOD_BYNAME = 0x00000400,
159
160 FT_PEPTIDE_FIND_MASK = 0x00000FFF,
161
162 FT_PROTEIN_ACCESSION = 0x00001000,
163 FT_PROTEIN_DESCRIPTION = 0x00002000
164 };
165
167
188 enum FIND_COMPARE_FLAGS
189 {
190 FC_COMPLETESTR = 0x00000001,
191 FC_SUBSTR = 0x00000002,
192 FC_STARTSTR = 0x00000003,
193 FC_STRTOK = 0x00000004,
194 FC_MASK_STR_PART = 0x0000000F,
195
196 FC_CASE_INSENSITIVE = 0x00000000,
197 FC_CASE_SENSITIVE = 0x00000010,
198 FC_MASK_CASE = 0x000000F0,
199
200 FC_FORWARD = 0x00000000,
201 FC_REVERSE = 0x00000100,
202 FC_MASK_DIRECTION = 0x00000F00,
203
204 FC_RESTRICT_TO_HIT = 0x00001000,
205 FC_LOOP_INTO_UNASSIGNED = 0x00002000,
206 FC_LOOP_FROM_UNASSIGNED = 0x00004000,
207 FC_UNASSIGNED_MASK = 0x00006000,
208
209 FC_SEARCH_ALL_RANKS = 0x00008000,
210
211 FC_ALL_PEPTIDES = 0x00000000,
212 FC_ALL_PEPTITDES = 0x00000000,
213
214 FC_SIGNIFICANT_PEPTIDES = 0x00010000,
215 FC_SEARCH_IGNORED_RANKS = 0x00020000,
216 FC_SCORING_MASK = 0x000F0000,
217
218 FC_PROTEIN_IGN_SAMESETS = 0x00100000,
219 FC_PROTEIN_IGN_SUBSETS = 0x00200000,
220 FC_PROTEIN_IGN_FAMILY = 0x00400000,
221 FC_PROTEIN_IGN_MASK = 0x00F00000,
222
223 FC_PROTEIN_INC_ALT_ACC = 0x01000000
224 };
225
227
230 enum IONS_HISTOGRAM
231 {
232 IH_INCLUDE_TOP_MATCHES = 0x0000,
233 IH_INCLUDE_TOP_10_MATCHES = 0x0001
234/* IH_INCLUDE_TOP_ERRTOL_MATCHES = 0x0002, //!< Not yet implemented. Include top error tolerant match
235 IH_INCLUDE_TOP_10_ERRTOL_MATCHES = 0x0004, //!< Not yet implemented. Include top 10 error tolerant match
236 IH_INCLUDE_TOP_DECOY_MATCHES = 0x0008, //!< Not yet implemented. Include top decoy matche
237 IH_INCLUDE_TOP_10_DECOY_MATCHES = 0x0010 //!< Not yet implemented. Include top 10 decoy matches */
238 };
239
241
247 enum HOMOLOGY_THRESHOLD_SOURCE
248 {
249 HOMTHR_RANK1 = 1,
250 HOMTHR_RANK2 = 2,
251 HOMTHR_RANK3 = 3,
252 HOMTHR_RANK4 = 4,
253 HOMTHR_RANK5 = 5,
254 HOMTHR_RANK6 = 6,
255 HOMTHR_RANK7 = 7,
256 HOMTHR_RANK8 = 8,
257 HOMTHR_RANK9 = 9,
258 HOMTHR_RANK10 = 10,
259 HOMTHR_RANK11 = 11,
260 HOMTHR_RANK12 = 12,
261 HOMTHR_RANK13 = 13,
262 HOMTHR_RANK14 = 14,
263 HOMTHR_RANK15 = 15,
264 HOMTHR_RANK16 = 16,
265 HOMTHR_RANK17 = 17,
266 HOMTHR_RANK18 = 18,
267 HOMTHR_RANK19 = 19,
268 HOMTHR_RANK20 = 20,
269
270 HOMTHR_FASTA = -1,
271 HOMTHR_SL = -2
272 };
273
275
278 enum QUANT_COMPONENT_STATUS
279 {
280 QCS_OK,
281 QCS_OK_NO_MATCH,
282 QCS_ERROR_NO_METHOD,
283 QCS_ERROR_NO_COMPONENTS,
284 QCS_ERROR_BAD_COMPONENT_NAME,
285 QCS_OK_MULTIPLE_MATCHES
286 };
287
289
296 enum FLAGS
297 {
298
299 MSRES_NOFLAG = 0x00000000,
300 MSRES_GROUP_PROTEINS = 0x00000001,
301 MSRES_SHOW_SUBSETS = 0x00000002,
302 MSRES_SUBSETS_DIFF_PROT = 0x00000004,
303 MSRES_REQUIRE_BOLD_RED = 0x00000008,
304 MSRES_SHOW_ALL_FROM_ERR_TOL = 0x00000010,
305 MSRES_IGNORE_PMF_MIXTURE = 0x00000020,
306 MSRES_MUDPIT_PROTEIN_SCORE = 0x00000040,
307 MSRES_DECOY = 0x00000080,
308 MSRES_INTEGRATED_ERR_TOL = 0x00000100,
309 MSRES_ERR_TOL = 0x00000200,
310 MSRES_MAXHITS_OVERRIDES_MINPROB = 0x00000400,
311 MSRES_CLUSTER_PROTEINS = 0x00000800,
312
313 MSRES_DUPE_INCL_IN_SCORE_NONE = 0x00000000,
314 MSRES_DUPE_INCL_IN_SCORE_A = 0x00002000,
315 MSRES_DUPE_INCL_IN_SCORE_B = 0x00004000,
316 MSRES_DUPE_INCL_IN_SCORE_C = 0x00008000,
317 MSRES_DUPE_INCL_IN_SCORE_D = 0x00010000,
318 MSRES_DUPE_INCL_IN_SCORE_E = 0x00020000,
319 MSRES_DUPE_INCL_IN_SCORE_F = 0x00040000,
320 MSRES_DUPE_INCL_IN_SCORE_G = 0x00080000,
321 MSRES_DUPE_INCL_IN_SCORE_H = 0x00100000,
322 MSRES_DUPE_INCL_IN_SCORE_I = 0x00200000,
323 MSRES_DUPE_REMOVE_NONE = 0x00400000,
324 MSRES_DUPE_REMOVE_A = 0x00800000,
325 MSRES_DUPE_REMOVE_B = 0x01000000,
326 MSRES_DUPE_REMOVE_C = 0x02000000,
327 MSRES_DUPE_REMOVE_D = 0x04000000,
328 MSRES_DUPE_REMOVE_E = 0x08000000,
329 MSRES_DUPE_REMOVE_F = 0x10000000,
330 MSRES_DUPE_REMOVE_G = 0x20000000,
331 MSRES_DUPE_REMOVE_H = 0x40000000,
332 #ifndef SWIG // 'live' version for C++ compiler
333 MSRES_DUPE_REMOVE_I = 0x80000000,
334 #else // SWIG version
335 // The C# 'unchecked' keyword is only used when generating C# bindings.
336 MSRES_DUPE_REMOVE_I = unchecked((int)0x80000000),
337 #endif
338 MSRES_DUPE_DEFAULT = 0x04800000
339 };
340
341
343 enum DB_MATCH_TYPE
344 {
345 DM_FASTA = 0,
346 DM_SPECTRAL_LIBRARY = 1,
347 DM_BOTH = 2,
348
349 DM_FASTA_FIRST_PASS = 3,
350 DM_FASTA_SECOND_PASS = 4,
351 };
352
354
359 enum UNIQUE_PEP_RULES
360 {
361 UPR_WITHIN_FAMILY = 0x0001,
362 UPR_WITHIN_FAMILY_MEMBER = 0x0002,
363 UPR_IGNORE_SUBSET_PROTEINS = 0x0004,
364
365 UPR_DEFAULT = (UPR_WITHIN_FAMILY_MEMBER + UPR_IGNORE_SUBSET_PROTEINS)
366 };
367
369
372 enum THRESHOLD_TYPE
373 {
374 TT_HOMOLOGY = 0x0000,
375 TT_IDENTITY = 0x0001,
376 TT_PEPSUM_DEFAULT = 0x0002
377 };
378
379
381 enum DECOY_STATS_COUNT_TYPE
382 {
383 DS_COUNT_PSM = 0,
384 DS_COUNT_SEQUENCE = 1
385 };
386
387 enum QMATCH_PLUGHOLE_INDEX_SECTIONS {
388 QMATCH_PLUGHOLE_SEC_SUMMARY = 0,
389 QMATCH_PLUGHOLE_SEC_DECOYSUMMARY = 1,
390 QMATCH_PLUGHOLE_SEC_ERRTOLSUMMARY = 2,
391 QMATCH_PLUGHOLE_SEC_LIBRARYSUMMARY= 3,
392 QMATCH_PLUGHOLE_SEC_CROSSLINK_SUMMARY = 4,
393 QMATCH_PLUGHOLE_SEC_ERRTOLDECOYSUMMARY = 5,
394 QMATCH_PLUGHOLE_SEC_LAST = 6
395 };
396
397 enum DECOY_STATS_THRESHOLD_TYPE { DS_IDENTITY = 0, DS_HOMOLOGY = 1 };
398 enum {
399 DECOY_STATS_TD_LEVELS = 2,
400 DECOY_STATS_COUNT_TYPE_LEVELS = 2,
401 DECOY_STATS_THR_TYPE_LEVELS = 3,
402 DECOY_STATS_DB_TYPE_LEVELS = 5
403 };
404
405
406 typedef std::map<std::string, std::set<std::pair<int, int> >, LexicoCompare > map_mod_value_to_qp;
407
408 enum COMPLETED_TASKS {
409 CT_NONE = 0x0000,
410 CT_LOADQUERIES = 0x0001,
411 CT_SRCRANKINITIALISED = 0x0002,
412 CT_PERCOLATORRESULTS = 0x0004,
413 CT_INFERENCING = 0x0008,
414 CT_UNASSIGNEDLIST = 0x0010,
415 CT_COMPONENTINTENSITIES = 0x0020,
416 CT_COUNTMODS = 0x0040,
417 CT_CREATECDB = 0x0080,
418 CT_ALLDONE = 0xFFFF
419 };
420
421 public:
422
423 // Some useful types
424 typedef std::set<ms_protein> proteinSet; // ms_protein has operator< which compares accession and dbIdx
425 typedef std::pair<std::string, int> acc_dbidx_t;
426 typedef std::set<acc_dbidx_t> acc_dbidx_set_t;
427 typedef std::set<std::pair<int, int> > q_p_set_t;
428 typedef std::vector<acc_dbidx_t> acc_dbidx_vect_t;
429 typedef std::vector<std::pair<int, int> > q_p_vect_t;
430
431 // From ms_peptidesummary
432 typedef std::set<std::pair<int,int> > hitAndFamily_t;
433
435 ms_mascotresults();
436
437 virtual ~ms_mascotresults();
438
440 const ms_mascotresfilebase& getResfile() const;
441
442#ifndef SWIG
443 std::shared_ptr<const msparser_internal::ms_mascotresultsbase> getResultsPtr() const;
444 std::shared_ptr<msparser_internal::ms_mascotresultsbase> getResultsPtr();
445#endif
447 virtual bool createSummary();
448
449#ifndef SWIG // Can't / don't want to allow std::string * as OUTPUT in Java and C#
451 bool getCreateSummaryProgress(int * cspTotalPercentComplete,
452 unsigned int * cspCurrTask,
453 int * cspCurrTaskPercentageComplete,
454 std::string * cspAccession,
455 int * cspHit,
456 int * cspQuery,
457 std::string * cspKeepAliveText) const;
458
459 bool getCreateSummaryProgress(int * cspTotalPercentComplete,
460 unsigned int * cspCurrTask,
461 int * cspCurrTaskPercentageComplete,
462 std::string & cspAccession,
463 int * cspHit,
464 int * cspQuery,
465 std::string & cspKeepAliveText) const {
466 return getCreateSummaryProgress(cspTotalPercentComplete, cspCurrTask, cspCurrTaskPercentageComplete, &cspAccession, cspHit, cspQuery, &cspKeepAliveText);
467 }
468#else // SWIG Multiple return values
469 bool getCreateSummaryProgress(int * OUTPUT,
470 unsigned int * OUTPUT,
471 int * OUTPUT,
472 std::string & OUTPUT,
473 int * OUTPUT,
474 int * OUTPUT,
475 std::string & OUTPUT) const;
476#endif
478 void cancelCreateSummary(bool newValue = true);
479
481 virtual ms_protein * getHit(const int hit, const int memberNumber = 0) const;
482
484 virtual void freeHit(const int hit);
485
487 virtual int getNumberOfHits() const;
488
490 virtual int getNumberOfFamilyMembers() const;
491
493 std::string getProteinDescription(const char * accession, const int dbIdx = 1) const;
494
496 double getProteinMass(const char * accession, const int dbIdx = 1) const;
497
499 virtual double getProteinEmPAI(const char *accession, const int dbIdx = 1, const int length = -1) const;
500
502 bool isEmPAIallowed() const;
503
505 virtual bool anyEmPAI() const;
506
508 double getSequenceMass(const char * seq) const;
509
511 void getProteinTaxonomyIDs(const char * accession, const int dbIdx,
512 std::vector<int> & gpt_ids, std::vector<std::string> & gpt_accessions) const;
513
515 virtual const ms_protein * getProtein(const char * accession, const int dbIdx = 1) const;
516
518 virtual const ms_protein * getComponentProtein(const char * accession, const int dbIdx = 1) const;
519
521 virtual ms_protein * getNextSimilarProtein(const int masterHit, const int id) const;
522
524 virtual ms_protein * getNextSimilarProteinOf(const char * masterAccession, const int masterDB, const int id) const;
525
527 virtual ms_protein * getNextFamilyProtein(const int masterHit, const int id) const;
528
529
531 virtual ms_protein * getNextSubsetProtein(const int masterHit, const int id,
532 const bool searchWholeFamily = true) const;
533
535 virtual ms_protein * getNextSubsetProteinOf(const char * masterAccession, const int masterDB, const int id) const;
536
538 virtual ms_peptide getPeptide(const int q, const int p) const = 0;
539
541 virtual bool getPeptide(const int q, const int p, ms_peptide * & pep) const = 0;
542
544 virtual double getIonsScore(const int q, const int p, const bool decoy) const = 0;
545
547 virtual bool isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules = UPR_DEFAULT) const = 0;
548
550 virtual int getQmatch(const int query) const;
551
553 virtual int getQmatch(const int query, const ms_mascotresfile_dat::section sec) const;
554
556 virtual int getPeptideIdentityThreshold(const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType = DM_FASTA) const;
557
559 virtual int getAvePeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType = DM_FASTA) const;
560
562 virtual int getMaxPeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType = DM_FASTA) const;
563
565 double getPeptideThreshold(const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const;
566
567 enum ERROR_TOLERANT_PEPTIDE { ETPEP_YES, ETPEP_NO, ETPEP_UNKNOWN };
568
570 virtual int getProteinScoreCutoff(double OneInXprobRnd) const = 0;
571
573 virtual int getProteinThreshold(double OneInXprobRnd) const;
574
576 virtual int getHomologyThreshold(const int query,
577 double OneInXprobRnd,
578 const int rank=1) const;
579
581 virtual int getHomologyThresholdForHistogram(double OneInXprobRnd, DB_MATCH_TYPE dbType = DM_FASTA) const;
582
584 virtual int getProbFromScore(const double score) const;
585
587 virtual double getPeptideExpectationValue(const double score,
588 const int query,
589 const int rank = 0) const;
590
592 virtual double getProbOfPepBeingRandomMatch(const double score,
593 const int query) const;
594
596 virtual double getProteinExpectationValue(const double score) const;
597
599 virtual double getProbOfProteinBeingRandomMatch(const double score) const;
600
602 virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) = 0;
603
605 virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
606 std::vector<int> & start,
607 std::vector<int> & end,
608 std::vector<std::string> &pre,
609 std::vector<std::string> &post,
610 std::vector<int> & frame,
611 std::vector<int> & multiplicity,
612 std::vector<int> & db) const = 0;
613
615 virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
616 std::vector<int> & start,
617 std::vector<int> & end,
618 std::vector<std::string> &pre,
619 std::vector<std::string> &post,
620 std::vector<int> & frame,
621 std::vector<int> & multiplicity,
622 std::vector<int> & db,
623 std::vector<int> & psmComponent) const = 0;
624
626 virtual int getAllFamilyMembersWithThisPepMatch(const int hit,
627 const int q,
628 const int p,
629 std::vector< int >& db,
630 std::vector< std::string >& acc,
631 std::vector< int >& dupe_status) const = 0;
632
633
635 virtual std::string getErrTolModString(const int q, const int p) const = 0;
636
638 virtual std::string getLibraryModString(const int q, const int p) const = 0;
639
641 virtual std::string getErrTolModMasterString(const int q, const int p) const = 0;
642
644 virtual std::string getErrTolModSlaveString(const int q, const int p) const = 0;
645
647 virtual std::string getErrTolModPepString(const int q, const int p) const = 0;
648
650 virtual std::string getErrTolModReqPepString(const int q, const int p) const = 0;
651
653 virtual std::string getErrTolModName(const int q, const int p, std::string * modString = NULL) const;
654
656 virtual double getErrTolModDelta(const int q, const int p, std::string * modString = NULL, std::string * deltaAsString = NULL) const;
657
659 virtual double getErrTolModNeutralLoss(const int q, const int p) const;
660
662 virtual std::vector<double> getErrTolModMasterNeutralLoss(const int q, const int p) const;
663
665 virtual std::vector<double> getErrTolModSlaveNeutralLoss(const int q, const int p) const;
666
668 virtual std::vector<double> getErrTolModPepNeutralLoss(const int q, const int p) const;
669
671 virtual std::vector<double> getErrTolModReqPepNeutralLoss(const int q, const int p) const;
672
674 virtual std::string getErrTolOriginalNaSeq(const int q, const int p) const;
675
677 virtual std::string getErrTolModifiedNaSeq(const int q, const int p) const;
678
680 std::string getVarModsForQP(const int q, const int p, const ms_peptide & pep,
681 const ms_peptide::PSM psmComponent,
682 int * numETMods = NULL, int * numLibraryMods = NULL,
683 std::set<std::string> * listMods = NULL) const;
684
686 std::string getLocalModsForQP(const int q, const int p, const ms_peptide & pep, const ms_peptide::PSM psmComponent, std::set<std::string> * listMods = NULL) const;
687
689 std::string getLibraryModsForQP(const int q, const int p, const ms_peptide & pep, std::set<std::string> * listMods = NULL) const;
690
692 virtual std::string getReadableVarMods(const int q, const int p,
693 const int numDecimalPlaces=2,
694 const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
695
697 virtual bool anyNumDiscoveredMods() const;
698
700 virtual std::vector<int> getNumDiscoveredFixedMods(const int num,
701 std::vector<std::string> &positions,
702 std::vector<std::string> &sites) const;
703
705 virtual std::vector<int> getNumDiscoveredVariableMods(const int num,
706 std::vector<std::string> &positions,
707 std::vector<std::string> &sites,
708 std::vector<double> &deltas,
709 std::vector<std::string> &names) const;
710
712 virtual std::vector<int> getNumDiscoveredVariableMods(const int num, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
713
715 virtual std::vector<std::string> getDiscoveredLocalModNames() const;
716
718 virtual std::vector<double> getDiscoveredLocalModDeltas(std::vector<std::string> * vecDeltaStrings = NULL) const;
719
721 virtual std::vector<int> getNumDiscoveredLocalMods(const std::string modName, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
722
724 virtual std::vector<std::string> getDiscoveredErrTolModNames() const;
725
727 virtual std::vector<double> getDiscoveredErrTolModDeltas(std::vector<std::string> * vecDeltaStrings = NULL) const;
728
730 virtual std::vector<int> getNumDiscoveredErrTolMods(const std::string modName, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
731
733 std::vector<int> getNumDiscoveredLibraryMods(const int modId, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
734
736 std::vector<int> getNumDiscoveredIntactLinks(std::vector<int> &varModNum1,
737 std::vector<std::string> &position1,
738 std::vector<std::string> &site1,
739 std::vector<int> &varModNum2,
740 std::vector<std::string> &position2,
741 std::vector<std::string> &site2,
742 std::vector<int> &numLinkedPeptides) const;
743
745 virtual int getNumDiscoveredNonSpecCleavage() const;
746
748 virtual std::string getTagString(const int q, const int p) const = 0;
749
751 virtual int getTagStart(const int q, const int p, const int tagNumber) const;
752
754 virtual int getTagEnd(const int q, const int p, const int tagNumber) const;
755
757 virtual int getTagSeries(const int q, const int p, const int tagNumber) const;
758
760 virtual int getTagDeltaRangeStart(const int q, const int p) const = 0;
761
763 virtual int getTagDeltaRangeEnd(const int q, const int p) const = 0;
764
766 virtual std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const = 0;
767
769 virtual std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const = 0;
770
772 virtual int getMaxRankValue() const;
773
775 virtual std::vector<int> getIonsScoreHistogram(IONS_HISTOGRAM flags = IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType = DM_FASTA) const;
776
778 double getToleranceInDalton(bool & needMass, const double * const pMass = NULL) const;
779
781 bool createUnassignedList(sortBy s = QUERY);
782
784 int getNumberOfUnassigned() const;
785
787 ms_peptide getUnassigned(const int num) const;
788
790 bool getUnassignedIsBold(const int num) const;
791
793 bool getUnassignedShowCheckbox(const int num) const;
794
796 ms_mascotresults_params getResultsParameters() const;
797
799 virtual bool getTreeClusterNodes(const int hit,
800 std::vector<int> &left,
801 std::vector<int> &right,
802 std::vector<double> &distance,
803 TREE_CLUSTER_METHOD tcm = TCM_PAIRWISE_MAXIMUM,
804 double *** reserved1 = 0,
805 unsigned int * reserved2 = 0) const;
806
808 virtual int findProteins(const int startHit,
809 const std::string & str,
810 const int dbIdx,
811 FIND_FLAGS item,
812 FIND_COMPARE_FLAGS compareFlags,
813 std::vector<std::string> & accessions,
814 std::vector<int> & dbIndexes) const = 0;
815
817 virtual int findProteinsByAccession(const int startHit,
818 const std::string & str,
819 const int dbIdx,
820 FIND_COMPARE_FLAGS compareFlags,
821 std::vector<std::string> & accessions,
822 std::vector<int> & dbIndexes) const = 0;
823
825 virtual int findProteinsByDescription(const int startHit,
826 const std::string & str,
827 FIND_COMPARE_FLAGS compareFlags,
828 std::vector<std::string> & accessions,
829 std::vector<int> & dbIndexes) const = 0;
830
832 virtual int findPeptides(const int startHit,
833 const std::string & str,
834 FIND_FLAGS item,
835 FIND_COMPARE_FLAGS compareFlags,
836 std::vector<int> & q,
837 std::vector<int> & p) const = 0;
838
840 virtual QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide(
841 const matrix_science::ms_peptide & peptide,
842 matrix_science::ms_quant_component & component,
843 const matrix_science::ms_quant_method * method = NULL) const = 0;
844
846 virtual double getProteinScoreForHistogram(const int num) const;
847
849 bool isNA() const;
850
852
855 unsigned int getFlags() const;
856
858
862 unsigned int getFlags2() const;
863
865 int getMinPepLenInPepSummary() const;
866
868 virtual long getNumHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType = DS_COUNT_PSM, DB_MATCH_TYPE dbType = DM_FASTA);
869
871 virtual long getNumDecoyHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType = DS_COUNT_PSM, DB_MATCH_TYPE dbType = DM_FASTA);
872
874 virtual long getNumHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType = DS_COUNT_PSM, DB_MATCH_TYPE dbType = DM_FASTA);
875
877 virtual long getNumDecoyHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType = DS_COUNT_PSM, DB_MATCH_TYPE dbType = DM_FASTA);
878
880 virtual void setSubsetsThreshold(const double scoreFraction);
881
883 virtual double getProbabilityThreshold() const;
884
885 // //! Return the probability threshold used for error tolerant peptides.
886 virtual double getErrTolProbabilityThreshold() const;
887
888#ifndef SWIG
890 bool getThresholdForFDRAboveIdentity(double targetFDR, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
891
893 bool getThresholdForFDRAboveIdentity(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
894
896 bool getThresholdForFDRAboveHomology(double targetFDR, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
897
899 bool getThresholdForFDRAboveHomology(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
900
902 virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & value, double & rawValue) const = 0;
903#else // SWIG Multiple return values
904 // Don't supply default parameters for perl or python because these are defined as output parameters
905 bool getThresholdForFDRAboveIdentity(double targetFDR, double *OUTPUT, double *OUTPUT, int * OUTPUT, int * OUTPUT);
906 bool getThresholdForFDRAboveIdentity(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *OUTPUT, double *OUTPUT, int * OUTPUT, int * OUTPUT);
907 bool getThresholdForFDRAboveHomology(double targetFDR, double *OUTPUT, double *OUTPUT, int * OUTPUT, int * OUTPUT);
908 bool getThresholdForFDRAboveHomology(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *OUTPUT, double *OUTPUT, int * OUTPUT, int * OUTPUT);
909 virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & OUTPUT, double & OUTPUT) const;
910#endif
911
913 virtual std::vector<int> getPepsWithSameScore(const int q, const int p) const = 0;
931 bool queryRemoveThisPeptide(const unsigned short dupeFlags) const;
932
949 bool queryScoreThisPeptide(const unsigned short dupeFlags) const;
950
952 virtual bool loadPepMatchesForProteinFromCache(ms_protein * prot, const bool loadRelated=true) { return false; /*TODO*/}
953
955 virtual bool isValidQandP(const int q, const int p) const = 0;
956
958 std::string lookupParsedLocalModsStr(const ms_peptide *thisOnePep) const;
959
960
961 protected:
962 // Not safe to copy or assign this object.
963#ifndef SWIG
964 ms_mascotresults(const ms_mascotresults & rhs);
965 ms_mascotresults & operator=(const ms_mascotresults & rhs);
966
967 virtual double getQplughole(const int query, const ms_mascotresfile_dat::section sec) const;
968
969 virtual void getQmatchValuesFromCacheFile(const QMATCH_PLUGHOLE_INDEX_SECTIONS index) const {} ;
970 virtual void getPlugholeValuesFromCacheFile(const QMATCH_PLUGHOLE_INDEX_SECTIONS index) const {};
971
972#endif
973
974 // - Not documented - Get the 'corrected' ions score given multiplicity
975 double getIonsScoreCorrected(const double ionsScore,
976 const long multiplicity) const;
977
978
979 protected:
980 std::shared_ptr<msparser_internal::ms_mascotresultsbase> results_;
981
982 };
983 // end of resfile_group
985} // matrix_science namespace
986
987#endif // MS_MASCOTRESULTS_HPP
988
989/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_mascotresults::getTerminalResiduesString
virtual std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const =0
Return the complete terminal residue string from h1_q1_terms or q1_p1_terms.
matrix_science::ms_mascotresults::getErrTolModReqPepString
virtual std::string getErrTolModReqPepString(const int q, const int p) const =0
Return the error tolerant mod required peptide neutral loss string from h1_q2_et_mods_reqpep or q1_p1...
matrix_science::ms_mascotresults::getErrTolModSlaveString
virtual std::string getErrTolModSlaveString(const int q, const int p) const =0
Return the error tolerant mod slave neutral loss string from h1_q2_et_mods_slave or q1_p1_et_mods_sla...
matrix_science::ms_mascotresults::findProteins
virtual int findProteins(const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
Find the next hit that contains proteins with the specified attributes.
matrix_science::ms_mascotresults::getAllProteinsWithThisPepMatch
virtual std::vector< std::string > getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const =0
Return a complete list of proteins that contain this same peptide match.
matrix_science::ms_mascotresults::getPeptide
virtual ms_peptide getPeptide(const int q, const int p) const =0
Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_p...
matrix_science::ms_mascotresults::FIND_COMPARE_FLAGS
FIND_COMPARE_FLAGS
Flags to specify how comparisons are performed in the find functions.
Definition: ms_mascotresults.hpp:189
matrix_science::ms_mascotresults::isPeptideUnique
virtual bool isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const =0
Returns true if this peptide match is unique to one protein or one protein family.
matrix_science::ms_mascotresults::getProteinScoreCutoff
virtual int getProteinScoreCutoff(double OneInXprobRnd) const =0
Return the 'protein' score value for cutting off results (different for peptide and protein summary).
matrix_science::ms_mascotresults::TREE_CLUSTER_METHOD
TREE_CLUSTER_METHOD
Flags for getTreeClusterNodes().
Definition: ms_mascotresults.hpp:128
matrix_science::ms_mascotresults::sortBy
sortBy
Flags for createUnassignedList().
Definition: ms_mascotresults.hpp:95
matrix_science::ms_mascotresults::QUERY
@ QUERY
Sort the unassigned list by ascending query number - this is the same as ascending relative mass orde...
Definition: ms_mascotresults.hpp:96
matrix_science::ms_mascotresults::SCORE
@ SCORE
Sort the unassigned list by descending score.
Definition: ms_mascotresults.hpp:97
matrix_science::ms_mascotresults::getTagDeltaRangeEnd
virtual int getTagDeltaRangeEnd(const int q, const int p) const =0
Return the second number from h1_q2_drange=0,256.
matrix_science::ms_mascotresults::findProteinsByDescription
virtual int findProteinsByDescription(const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
Find the next hit that contains proteins with the specified description.
matrix_science::ms_mascotresults::getErrTolModPepString
virtual std::string getErrTolModPepString(const int q, const int p) const =0
Return the error tolerant mod peptide neutral loss string from h1_q2_et_mods_pep or q1_p1_et_mods_pep...
matrix_science::ms_mascotresults::getComponentIntensity
virtual bool getComponentIntensity(const int q, const int p, const std::string &componentName, double &value, double &rawValue) const =0
Returns the component intensity for reporter or multiplex methods.
matrix_science::ms_mascotresults::DECOY_STATS_COUNT_TYPE
DECOY_STATS_COUNT_TYPE
Type of object counted by getNumHitsAboveIdentity() and friends.
Definition: ms_mascotresults.hpp:382
matrix_science::ms_mascotresults::getTagString
virtual std::string getTagString(const int q, const int p) const =0
Return the complete tag string from h1_q2_tag or q1_p1_tag.
matrix_science::ms_mascotresults::findProteinsByAccession
virtual int findProteinsByAccession(const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
Find the next hit that contains proteins with the specified accession.
matrix_science::ms_mascotresults::getErrTolModMasterString
virtual std::string getErrTolModMasterString(const int q, const int p) const =0
Return the error tolerant mod primary neutral loss string from h1_q2_et_mods_master or q1_p1_et_mods_...
matrix_science::ms_mascotresults::getLibraryModString
virtual std::string getLibraryModString(const int q, const int p) const =0
Return the modification string of the spectral library match from q1_p1_SLmod.
matrix_science::ms_mascotresults::UNIQUE_PEP_RULES
UNIQUE_PEP_RULES
Flags for isPeptideUnique().
Definition: ms_mascotresults.hpp:360
matrix_science::ms_mascotresults::getErrTolModString
virtual std::string getErrTolModString(const int q, const int p) const =0
Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.
matrix_science::ms_mascotresults::getQuantitationComponentForPeptide
virtual QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide(const matrix_science::ms_peptide &peptide, matrix_science::ms_quant_component &component, const matrix_science::ms_quant_method *method=NULL) const =0
Get the component in the quantitation method that matches the peptide.
matrix_science::ms_mascotresults::FIND_FLAGS
FIND_FLAGS
Flags for findPeptides() and findProteins().
Definition: ms_mascotresults.hpp:146
matrix_science::ms_mascotresults::getAllProteinsWithThisPepMatch
virtual std::vector< std::string > getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const =0
Return a complete list of proteins that contain this same peptide match.
matrix_science::ms_mascotresults::HOMOLOGY_THRESHOLD_SOURCE
HOMOLOGY_THRESHOLD_SOURCE
Flags for getHomologyThreshold()
Definition: ms_mascotresults.hpp:248
matrix_science::ms_mascotresults::findPeptides
virtual int findPeptides(const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const =0
Find the next hit that contains peptides with the specified attribute.
matrix_science::ms_mascotresults::getIonsScore
virtual double getIonsScore(const int q, const int p, const bool decoy) const =0
Returns an ions score quickly without having to load an ms_peptide object.
matrix_science::ms_mascotresults::getTagDeltaRangeStart
virtual int getTagDeltaRangeStart(const int q, const int p) const =0
Return the first number from h1_q2_drange=0,256.
matrix_science::ms_mascotresults::THRESHOLD_TYPE
THRESHOLD_TYPE
Flags for getPeptideThreshold()
Definition: ms_mascotresults.hpp:373
matrix_science::ms_mascotresults::getPeptide
virtual bool getPeptide(const int q, const int p, ms_peptide *&pep) const =0
Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_p...
matrix_science::ms_mascotresults::DB_MATCH_TYPE
DB_MATCH_TYPE
Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreH...
Definition: ms_mascotresults.hpp:344
matrix_science::ms_mascotresults::QUANT_COMPONENT_STATUS
QUANT_COMPONENT_STATUS
Return codes for getQuantitationComponentForPeptide().
Definition: ms_mascotresults.hpp:279
matrix_science::ms_mascotresults::QCS_ERROR_NO_METHOD
@ QCS_ERROR_NO_METHOD
There is no quantitation method available (e.g. for protein summary).
Definition: ms_mascotresults.hpp:282
matrix_science::ms_mascotresults::QCS_OK
@ QCS_OK
The component was retrieved successfully.
Definition: ms_mascotresults.hpp:280
matrix_science::ms_mascotresults::QCS_ERROR_BAD_COMPONENT_NAME
@ QCS_ERROR_BAD_COMPONENT_NAME
The peptide's component name in the Mascot results does not match any component in the quantitation m...
Definition: ms_mascotresults.hpp:284
matrix_science::ms_mascotresults::QCS_ERROR_NO_COMPONENTS
@ QCS_ERROR_NO_COMPONENTS
There are no components specified in the quantitation method (e.g. for non-precursor method).
Definition: ms_mascotresults.hpp:283
matrix_science::ms_mascotresults::QCS_OK_NO_MATCH
@ QCS_OK_NO_MATCH
The quantitation method's components were searched successfully, no matching component was found.
Definition: ms_mascotresults.hpp:281
matrix_science::ms_mascotresults::getAllFamilyMembersWithThisPepMatch
virtual int getAllFamilyMembersWithThisPepMatch(const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const =0
Return a list of (top level) family proteins that have a match to the specified q and p.
matrix_science::ms_mascotresults::getComponentString
virtual std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const =0
Return q1_p2_comp string value; for h1_q2 this string is always empty.
matrix_science::ms_mascotresults::IONS_HISTOGRAM
IONS_HISTOGRAM
Flags for getIonsScoreHistogram().
Definition: ms_mascotresults.hpp:231
matrix_science::ms_mascotresults::getPepsWithSameScore
virtual std::vector< int > getPepsWithSameScore(const int q, const int p) const =0
Returns a list of 'p' values for peptides with the same score.
matrix_science::ms_mascotresults::getProteinsWithThisPepMatch
virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false)=0
Return a partial list of proteins that matched the same peptide.
matrix_science::ms_mascotresults::FLAGS
FLAGS
Flags for the type of results.
Definition: ms_mascotresults.hpp:297
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresults_dat.hpp Source File

  • src
  • resfile
  • impl
ms_mascotresults_dat.hpp
1/*
2##############################################################################
3# file: ms_mascotresults_dat.hpp #
4# 'msparser' toolkit #
5# Abstract class for either ms_peptidesummary or ms_proteinsummary #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresul $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-01-23 14:49:50 +0000 $ #
14# $Revision: 01d2cad44f7f17293fde14d6c92b1776cfaecf7a | MSPARSER_ALPHA_2_8_100-340-gd270de69e1 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESULTS_DAT_HPP
20#define MS_MASCOTRESULTS_DAT_HPP
21
22
23// Includes from the standard template library
24#include <string>
25#include <list>
26#include <vector>
27#include <set>
28#include <map>
29#include <algorithm>
30
31#include "ms_mascotresults_implbase.hpp"
32
33namespace matrix_science {
39 class ms_unigene;
40 class ms_protein;
41 class ms_peptide;
42 class ms_mascotresfile_dat;
43 class ms_quant_component;
44 class ms_mascotresults_params;
45 class ms_mascotresults;
46}
47
48using namespace matrix_science;
49
50namespace msparser_internal {
51 class ms_unassigned;
52 class ms_peptidesumcdb;
53 class ms_protein_match_data;
54 class ms_mutex;
55 class linearPeptideData_t;
56 class ms_mascotresultsbase;
57
59
60
62
79 class MS_MASCOTRESFILE_API ms_mascotresults_dat : public ms_mascotresults_implbase
80 {
81 friend class ms_protein;
82 friend class msparser_internal::ms_peptidesumcdb;
83
84 public:
85
87 ms_mascotresults_dat(const ms_mascotresfile_dat &resfile, ms_mascotresults &results, const ms_mascotresultsbase &resultsBase,
88 const ms_mascotresults_params &params);
89
90 // Not safe to copy or assign this object.
91 ms_mascotresults_dat(const ms_mascotresults_dat & rhs) = delete;
92 ms_mascotresults_dat & operator=(const ms_mascotresults_dat & rhs) = delete;
93
94 virtual ~ms_mascotresults_dat();
95
96 void initialise() override;
97
98 const ms_mascotresfile_dat & getResfile() const override { return resfile_; }
99
100 //
101 std::string getUnigeneDesc(const char* accession) const override;
102
104 double getProteinMass(const char * accession, const int dbIdx = 1) const override;
105
107 void getProteinTaxonomyIDs(const char * accession, const int dbIdx,
108 std::vector<int> & gpt_ids, std::vector<std::string> & gpt_accessions) const override;
109
111 int getQmatch(const int query) const override;
112
114 int getQmatch(const int query, const ms_mascotresfile_dat::section sec) const override;
115
116 double getQplughole(const int query, const ms_mascotresfile_dat::section sec) const override;
117
118 ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored,const int64_t protId=-1) override;
119
121 std::string getErrTolModName(const int q, const int p, std::string * modString = NULL) const override;
122
124 double getErrTolModDelta(const int q, const int p, std::string * modString = NULL, std::string * deltaAsString = NULL) const override;
125
127 double getErrTolModNeutralLoss(const int q, const int p) const override;
128
130 std::vector<double> getErrTolModMasterNeutralLoss(const int q, const int p) const override;
131
133 std::vector<double> getErrTolModSlaveNeutralLoss(const int q, const int p) const override;
134
136 std::vector<double> getErrTolModPepNeutralLoss(const int q, const int p) const override;
137
139 std::vector<double> getErrTolModReqPepNeutralLoss(const int q, const int p) const override;
140
142 int getTagStart(const int q, const int p, const int tagNumber) const override;
143
145 int getTagEnd(const int q, const int p, const int tagNumber) const override;
146
147 int getTagSeries(const int q, const int p, const int tagNumber) const override;
148
150 bool loadPepMatchesForProteinFromCache(ms_protein * prot, const bool loadRelated=true) override { return false; }
151
153 const std::string& lookupParsedLocalModsStr(const int q, const std::string localModsStr) const override;
154
155 const std::vector<std::string>& lookupParsedIT_MODS(int q) const override;
156
158 const std::string& lookupParsedLocalModsStr(const ms_peptide *thisOnePep) const override;
159
160
161 std::unique_ptr<msparser_internal::ms_peptide_implbase> buildPeptideImpl(const msparser_internal::peptide_impl_args & args,
162 const msparser_internal::linearPeptideData_t & concatData,
163 const msparser_internal::linearPeptideData_t & linearAlpha,
164 const msparser_internal::linearPeptideData_t & linearBeta,
165 const matrix_science::ms_linker_site & linkerSite,
166 const bool storeReloadableInfo) const override;
167
168 std::unique_ptr<msparser_internal::ms_peptide_implbase> buildPeptideImpl(const msparser_internal::peptide_impl_args & args,
169 const matrix_science::ms_linker_site_vector & loopLinks,
170 const bool storeReloadableInfo) const override;
171
172 const std::string& unigeneIndexFile() const override { return unigeneIndexFile_; }
173
174 std::vector<int> getSlModifiedPositions(const ms_peptide& pep, const int q, const int p, bool& ok) const override;
175
176 const ms_mascotresfile_dat &resfile_;
177
178 const std::string unigeneIndexFile_;
179 ms_unigene * unigene_;
180
181 ms_mascotresfile_dat::section secSummary_;
182 ms_mascotresfile_dat::section secMixture_;
183 ms_mascotresfile_dat::section secPeptides_;
184 ms_mascotresfile_dat::section secProteins_;
185
186 private:
187
188 mutable std::vector<int> cachedQMatch_[ms_mascotresults::QMATCH_PLUGHOLE_SEC_LAST];
189 mutable std::vector<double> cachedQPlughole_[ms_mascotresults::QMATCH_PLUGHOLE_SEC_LAST];
190 typedef std::map<std::pair<int, std::string>, int> dbIdxPlusAccToId_t;
191 mutable dbIdxPlusAccToId_t summarySectionAccs_;
192
193 mutable bool loadedQmatchFromCacheFile_[ms_mascotresults::QMATCH_PLUGHOLE_SEC_LAST];
194 mutable bool loadedPlugholeFromCacheFile_[ms_mascotresults::QMATCH_PLUGHOLE_SEC_LAST];
195
196 bool getProteinDescriptionAndMass(const char * accession, const int dbIdx,
197 double & mass, std::string & desc) const override;
198
199 int getQmatch(const int query, const ms_peptide::PSM_TYPE psmType) const override;
200
201 double getQplughole(const int query, const ms_peptide::PSM_TYPE psmType) const override;
202
203 void cacheSummarySectionAccs() const;
204 void debugCheckReloadablePeps() const override;
205 bool setQmatch(const int query, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index, const int value) const override;
206 bool setPlughole(const int query, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index, const double value) const override;
207
208
209 //static std::string parseLocalModsStr(const std::string &localModsStr, const std::vector<std::string> &local_modnames);
210
211 };
212 // end of resfile_group
214
216
217} // msparser_internal namespace
218
219#endif // MS_MASCOTRESULTS_DAT_HPP
220
221/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotresfile_dat
Class for parsing and reading files in dat28 format.
Definition: ms_mascotresfile_dat.hpp:121
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_unigene
This class encapsulates a complete unigene file.
Definition: ms_unigene.hpp:162
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresults_implbase.hpp Source File

  • src
  • resfile
  • impl
ms_mascotresults_implbase.hpp
1/*
2##############################################################################
3# file: ms_mascotresults_implbase.hpp #
4# 'msparser' toolkit #
5# Abstract class for either ms_peptidesummary or ms_proteinsummary #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresul $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-01-23 14:49:50 +0000 $ #
14# $Revision: 01d2cad44f7f17293fde14d6c92b1776cfaecf7a | MSPARSER_ALPHA_2_8_100-340-gd270de69e1 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESULTS_IMPLBASE_HPP
20#define MS_MASCOTRESULTS_IMPLBASE_HPP
21
22
23// Includes from the standard template library
24#include <string>
25#include <list>
26#include <vector>
27#include <set>
28#include <map>
29#include <algorithm>
30
31#include "private/strutils.hpp"
32
33namespace matrix_science {
39 class ms_unigene;
40 class ms_protein;
41 class ms_peptide;
42 class ms_mascotresfilebase;
43 class ms_quant_component;
44 class ms_mascotresults_params;
45 class ms_mascotresults;
46}
47
48using namespace matrix_science;
49
50namespace msparser_internal {
51 class ms_unassigned;
52 class ms_peptidesumcdb;
53 class ms_protein_match_data;
54 class ms_mutex;
55 class linearPeptideData_t;
56 struct ms_mod_instances_count;
57 class ms_mascotresultsbase;
58
59
61
62 class MS_MASCOTRESFILE_API ms_mascotresults_implbase
63 {
64 public:
65
67 ms_mascotresults_implbase(const ms_mascotresfilebase &resfile, ms_mascotresults &results, const ms_mascotresultsbase& resultsBase,
68 const ms_mascotresults_params &params)
69 : resultsBase_(resultsBase), resfile_(resfile), params_(params)
70 {}
71
72 // Not safe to copy or assign this object.
73 ms_mascotresults_implbase(const ms_mascotresultsbase & rhs) = delete;
74 ms_mascotresults_implbase & operator=(const ms_mascotresultsbase & rhs) = delete;
75
76 virtual ~ms_mascotresults_implbase() = default;
77
78 virtual void initialise() = 0;
79
80 virtual const ms_mascotresfilebase& getResfile() const = 0;
81
82 virtual std::string getUnigeneDesc(const char* accession) const = 0;
83
84 virtual bool getProteinDescriptionAndMass(const char * accession, const int dbIdx,
85 double & mass, std::string & desc) const = 0;
86
88 virtual double getProteinMass(const char * accession, const int dbIdx = 1) const = 0;
89
91 virtual void getProteinTaxonomyIDs(const char * accession, const int dbIdx,
92 std::vector<int> & gpt_ids, std::vector<std::string> & gpt_accessions) const = 0;
93
95 virtual int getQmatch(const int query) const = 0;
96
98 virtual int getQmatch(const int query, const ms_mascotresfile_dat::section sec) const = 0;
99
100 virtual int getQmatch(const int query, const ms_peptide::PSM_TYPE psmType) const = 0;
101
102 virtual double getQplughole(const int query, const ms_mascotresfile_dat::section sec) const = 0;
103
104 virtual double getQplughole(const int query, const ms_peptide::PSM_TYPE psmType) const = 0;
105
106 virtual bool setQmatch(const int query, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index, const int value) const = 0;
107
108 virtual bool setPlughole(const int query, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index, const double value) const = 0;
109
110
111 virtual ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1) = 0;
112
114 virtual std::string getErrTolModName(const int q, const int p, std::string * modString = NULL) const = 0;
115
117 virtual double getErrTolModDelta(const int q, const int p, std::string * modString = NULL, std::string * deltaAsString = NULL) const = 0;
118
120 virtual double getErrTolModNeutralLoss(const int q, const int p) const = 0;
121
123 virtual std::vector<double> getErrTolModMasterNeutralLoss(const int q, const int p) const = 0;
124
126 virtual std::vector<double> getErrTolModSlaveNeutralLoss(const int q, const int p) const = 0;
127
129 virtual std::vector<double> getErrTolModPepNeutralLoss(const int q, const int p) const = 0;
130
132 virtual std::vector<double> getErrTolModReqPepNeutralLoss(const int q, const int p) const = 0;
133
135 virtual std::vector<int> getSlModifiedPositions(const ms_peptide& pep, const int q, const int p, bool& ok) const = 0;
136
138 virtual int getTagStart(const int q, const int p, const int tagNumber) const = 0;
139
141 virtual int getTagEnd(const int q, const int p, const int tagNumber) const = 0;
142
144 virtual int getTagSeries(const int q, const int p, const int tagNumber) const = 0;
145
147 virtual bool loadPepMatchesForProteinFromCache(ms_protein * prot, const bool loadRelated=true) = 0;
148
150 virtual const std::string& lookupParsedLocalModsStr(const int q, const std::string localModsStr) const = 0;
151
152 virtual const std::vector<std::string>& lookupParsedIT_MODS(int q) const = 0;
153
155 virtual const std::string& lookupParsedLocalModsStr(const ms_peptide *thisOnePep) const = 0;
156
157 virtual void debugCheckReloadablePeps() const = 0;
158
159 virtual std::unique_ptr<msparser_internal::ms_peptide_implbase> buildPeptideImpl(const msparser_internal::peptide_impl_args & args,
160 const msparser_internal::linearPeptideData_t & concatData,
161 const msparser_internal::linearPeptideData_t & linearAlpha,
162 const msparser_internal::linearPeptideData_t & linearBeta,
163 const matrix_science::ms_linker_site & linkerSite,
164 const bool storeReloadableInfo) const = 0;
165
166 virtual std::unique_ptr<msparser_internal::ms_peptide_implbase> buildPeptideImpl(const msparser_internal::peptide_impl_args & args,
167 const matrix_science::ms_linker_site_vector & loopLinks,
168 const bool storeReloadableInfo) const = 0;
169
170 const ms_mascotresfilebase& resfile() const { return resfile_; }
171 const ms_mascotresults_params& params() const { return params_; }
172 const ms_mascotresultsbase& resultsBase() const { return resultsBase_; }
173 virtual const std::string& unigeneIndexFile() const { return emptyStr_; }
174
175 protected:
176 const ms_mascotresultsbase &resultsBase_;
177
178 // Reduce IT_MODS parsing.
179 typedef std::map<int, std::string> queryIT_MODS_t;
180 mutable queryIT_MODS_t queryIT_MODS_;
181 typedef std::map<std::string, std::vector<std::string> > parsedLocalMods_t;
182 mutable parsedLocalMods_t parsedLocalMods_;
183 typedef std::map<std::pair<int, std::string>, std::string> pepParsedLocalMods_t;
184 mutable pepParsedLocalMods_t pepParsedLocalMods_;
185
186 // Helper function for comparing query-level mods.
187static std::string parseLocalModsStr(const std::string &localModsStr, const std::vector<std::string> &local_modnames)
188{
189 // Input: a varmod string of query-level mods and names of those mods
190 // Output: a string of comma-separated elements of the form
191 // "<residue index>-<mod name>"
192 // where <residue index> is between 0 and localModStr.size()-1
193 //
194 // The reason for this format is that two peptide matches are distinct
195 // only when both the query-level mod name and position differ. It's not
196 // enough to compare mod names used, and we can't compare the mod strings
197 // directly as two different queries can have different modifications
198 // at varmod index 1.
199 //
200 // Example:
201 // - Query 1 has IT_MODS=Oxidation(M).
202 // - Query 2 has IT_MODS=Acetyl (K).
203 // - Query 1 has peptide match with localModsStr == "001000".
204 // - Query 2 has peptide match with localModsStr == "001000".
205 //
206 // parseLocalModsStr() for peptide in query 1 is "2-Oxidation (M)"
207 // while for peptide in query 2, it is "2-Acetyl (K)". The two
208 // peptides are distinct with respect to query-level mods.
209
210 std::string mods;
211
212 for (std::string::size_type i = 0; i < localModsStr.size(); ++i) {
213 int j = 0;
214
215 if (localModsStr[i] == 'X') {
216 // Not possible.
217 continue;
218 } else if (localModsStr[i] == 'Y') {
219 // Not possible.
220 continue;
221 } else {
222 j = msparser_internal::varModIndexToInt(localModsStr[i]);
223 }
224
225 if (j > 0 && j <= static_cast<int>(local_modnames.size())) {
226 char szIdx[20];
227 snprintf(szIdx, 20, ",%d-", static_cast<int>(i));
228 mods += szIdx + local_modnames[j-1];
229 }
230 }
231
232 if (mods.empty())
233 return mods;
234
235 return mods.substr(1); // remove initial ","
236}
237
238
239 private:
240 const ms_mascotresfilebase &resfile_;
241 const ms_mascotresults_params &params_;
242 const std::string emptyStr_;
243 };
244 // end of resfile_group
246
248
249} // msparser_internal namespace
250
251#endif // MS_MASCOTRESULTS_IMPLBASE_HPP
252
253/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_unigene
This class encapsulates a complete unigene file.
Definition: ms_unigene.hpp:162
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresults_msr.hpp Source File

  • src
  • resfile
  • impl
ms_mascotresults_msr.hpp
1/*
2##############################################################################
3# file: ms_mascotresults_msr.hpp #
4# 'msparser' toolkit #
5# Abstract class for either ms_peptidesummary_mr or ms_proteinsummary_msr #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresul $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-04-25 16:25:55 +0100 $ #
14# $Revision: dde4bbcc6865eb41b000505fa63e96c98803f386 | MSPARSER_ALPHA_2_8_100-494-geae4995075 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESULTS_MSR_HPP
20#define MS_MASCOTRESULTS_MSR_HPP
21
22
23// Includes from the standard template library
24#include <string>
25#include <list>
26#include <vector>
27#include <set>
28#include <map>
29#include <algorithm>
30
31#include "ms_cached_msr_pepsum_data.hpp"
32#include "ms_mascotresultsbase.hpp" //
33#include "ms_mascotresults_implbase.hpp"
34
35namespace matrix_science {
41 class ms_unigene;
42 class ms_protein;
43 class ms_peptide;
44 class ms_mascotresfile_msr;
45 class ms_quant_component;
46 class ms_mascotresults_params;
47}
48
49using namespace matrix_science;
50
51namespace msparser_internal {
53
54 // TODO: We can't include private/ms_cached_msr_pepsum_data.hpp here
55 // because this file is included in msparser.hpp but it shouldn't
56 // Move this structs to that header file
57 namespace msr_cached_data
58 {
59 struct EtModsData;
60 }
61
62 class MS_MASCOTRESFILE_API ms_mascotresults_msr : public ms_mascotresults_implbase
63 {
64 friend class ms_protein;
65
66 public:
67
69 ms_mascotresults_msr(const ms_mascotresfile_msr &resfile,
70 ms_mascotresults &results,
71 const ms_mascotresultsbase &resultsBase,
72 const ms_mascotresults_params &params);
73
74 ms_mascotresults_msr(const ms_mascotresults_msr & rhs) = delete;
75 ms_mascotresults_msr & operator=(const ms_mascotresults_msr & rhs) = delete;
76
77 virtual ~ms_mascotresults_msr() = default;
78
79 void initialise() override;
80
81 std::string getUnigeneDesc(const char* accession) const override { return {}; } // Unigene is not supported in .msr
82
83 bool getProteinDescriptionAndMass(const char * accession, const int dbIdx,
84 double & mass, std::string & desc) const override;
85
86
87 double getProteinMass(const char * accession, const int dbIdx = 1) const override;
88
89
90 void getProteinTaxonomyIDs(const char * accession, const int dbIdx,
91 std::vector<int> & gpt_ids, std::vector<std::string> & gpt_accessions) const override;
92
94 int getQmatch(const int query) const override;
95
97 int getQmatch(const int query, const ms_mascotresfile_dat::section sec) const override;
98
99 int getQmatch(const int query, const ms_peptide::PSM_TYPE psmType) const override;
100
102 std::string getErrTolModName(const int q, const int p, std::string * modString = NULL) const override;
103
105 double getErrTolModDelta(const int q, const int p, std::string * modString = NULL, std::string * deltaAsString = NULL) const override;
106
108 double getErrTolModNeutralLoss(const int q, const int p) const override;
109
111 std::vector<double> getErrTolModMasterNeutralLoss(const int q, const int p) const override;
112
114 std::vector<double> getErrTolModSlaveNeutralLoss(const int q, const int p) const override;
115
117 std::vector<double> getErrTolModPepNeutralLoss(const int q, const int p) const override;
118
120 std::vector<double> getErrTolModReqPepNeutralLoss(const int q, const int p) const override;
121
123 int getTagStart(const int q, const int p, const int tagNumber) const override;
124
126 int getTagEnd(const int q, const int p, const int tagNumber) const override;
127
128 int getTagSeries(const int q, const int p, const int tagNumber) const override;
129
130 bool loadPepMatchesForProteinFromCache(ms_protein * prot, const bool loadRelated=true) override { return false; }
131
132
133 std::unique_ptr<msparser_internal::ms_peptide_implbase> buildPeptideImpl(const msparser_internal::peptide_impl_args & args,
134 const msparser_internal::linearPeptideData_t & concatData,
135 const msparser_internal::linearPeptideData_t & linearAlpha,
136 const msparser_internal::linearPeptideData_t & linearBeta,
137 const matrix_science::ms_linker_site & linkerSite,
138 const bool storeReloadableInfo) const override;
139
140 std::unique_ptr<msparser_internal::ms_peptide_implbase> buildPeptideImpl(const msparser_internal::peptide_impl_args & args,
141 const matrix_science::ms_linker_site_vector & loopLinks,
142 const bool storeReloadableInfo) const override;
143
144 const ms_mascotresfile_msr & getResfile() const { return resfile_; }
145
146 double getQplughole(const int query, const ms_mascotresfile_dat::section sec) const override;
147 double getQplughole(const int query, const ms_peptide::PSM_TYPE psmType) const override;
148
149 bool setQmatch(const int query, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index, const int value) const override;
150 bool setPlughole(const int query, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index, const double value) const override;
151
152 //ms_mascotresfile_dat::section getSrcSectionProtected(const int query, const int rank) const override;
153
154 const std::string& lookupParsedLocalModsStr(const int q, const std::string localModsStr) const override;
155
156 const std::string& lookupParsedLocalModsStr(const ms_peptide *thisOnePep) const override;
157
158 const std::vector<std::string>& lookupParsedIT_MODS(int q) const override;
159
160 virtual void getQmatchValuesFromCacheFile(const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) const {} ;
161 virtual void getPlugholeValuesFromCacheFile(const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) const {};
162
163
164 ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1) override;
165
166 void debugCheckReloadablePeps() const override;
167
168 std::vector<int> getSlModifiedPositions(const ms_peptide& pep, const int q, const int p, bool& ok) const override;
169
170
171
172 private:
173
174 static constexpr int CACHE_SIZE = 5;
175
176 const ms_mascotresfile_msr &resfile_;
177
178 struct ProteinData
179 {
180 ProteinData()
181 : srcResfile(-1), proteinSeqId(-1), taxId(-1), proteinId(-1)
182 {}
183
184 int srcResfile,
185 proteinSeqId,
186 taxId;
187 int64_t proteinId;
188 std::string title;
189 double mass;
190 };
191
192 mutable std::map<std::pair<int, std::string>, ProteinData> dbIdAcc2ProtData_;
193
194 void _cacheProteinData(const int dbIdx, const char * accession) const;
195
196 void _cacheEtModsData(const int q, const ms_peptide::PSM_TYPE psmType) const;
197 //
198
199 // (QueryId, (RankId -> EtModsData))
200 using Query2Data = std::pair<int, std::map<int, msparser_internal::msr_cached_data::EtModsData>>;
201 using EtModsCache = std::array<Query2Data, CACHE_SIZE>;
202 // TODO: No need to heap allocate once private/ms_cached_msr_pepsum_data.hpp can be included here
203 std::unique_ptr<EtModsCache> etModsCachePtr_;
204 EtModsCache& etModsCache_;
205
206
207 void _cacheTagData(const int q, const ms_peptide::PSM_TYPE psmType) const;
208 //
209
210 using Query2TagData = std::pair<int, std::map<std::pair<int, int>, msparser_internal::msr_cached_data::TagData>>;
211 using TagDataCache = std::array<Query2TagData, CACHE_SIZE>;
212 std::unique_ptr<TagDataCache> tagDataCachePtr_;
213 TagDataCache& tagDataCache_;
214
215 std::map<int, int> refDbOfSl_;
216 };
217 // end of resfile_group
219
221
222} // msparser_internal namespace
223
224#endif // MS_MASCOTRESULTS_MSR_HPP
225
226/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresfile_msr
Class for parsing and reading files in MSR format.
Definition: ms_mascotresfile_msr.hpp:105
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_unigene
This class encapsulates a complete unigene file.
Definition: ms_unigene.hpp:162
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresults_nil.hpp Source File

  • src
  • resfile
  • impl
ms_mascotresults_nil.hpp
1/*
2##############################################################################
3# file: ms_mascotresults_nil.hpp #
4# 'msparser' toolkit #
5# Abstract class for either ms_peptidesummary_mr or ms_proteinsummary_msr #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresul $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-04-25 16:25:55 +0100 $ #
14# $Revision: dde4bbcc6865eb41b000505fa63e96c98803f386 | MSPARSER_ALPHA_2_8_100-494-geae4995075 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESULTS_NIL_HPP
20#define MS_MASCOTRESULTS_NIL_HPP
21
22
23// Includes from the standard template library
24#include <string>
25#include <vector>
26
27#include "ms_mascotresfile_nil.hpp"
28#include "ms_mascotresultsbase.hpp"
29#include "ms_mascotresults_implbase.hpp"
30#include "ms_peptide_impl_nil.hpp"
31
32using namespace matrix_science;
33
34namespace msparser_internal {
35
36 class ms_mascotresults_nil : public ms_mascotresults_implbase
37 {
38 public:
39
40 ms_mascotresults_nil(const ms_mascotresfile_nil &resfile,
41 ms_mascotresults &results,
42 const ms_mascotresultsbase &resultsBase,
43 const ms_mascotresults_params &params)
44 : ms_mascotresults_implbase(resfile, results, resultsBase, params),
45 emptyStr_(), emptyStrVec_(), resfile_(resfile)
46 {}
47
48 ms_mascotresults_nil(const ms_mascotresults_nil & rhs) = delete;
49 ms_mascotresults_nil & operator=(const ms_mascotresults_nil & rhs) = delete;
50 virtual ~ms_mascotresults_nil() {}
51
52 void initialise() override {}
53
54 std::string getUnigeneDesc(const char* accession) const override { return {}; }
55
56 bool getProteinDescriptionAndMass(const char * accession, const int dbIdx,
57 double & mass, std::string & desc) const override { return false; }
58
59 double getProteinMass(const char * accession, const int dbIdx = 1) const override { return 0.0; }
60
61 void getProteinTaxonomyIDs(const char * accession, const int dbIdx,
62 std::vector<int> & gpt_ids, std::vector<std::string> & gpt_accessions) const override
63 {}
64
65 int getQmatch(const int query) const override { return 0;}
66
67 int getQmatch(const int query, const ms_mascotresfile_dat::section sec) const override { return 0; }
68
69 int getQmatch(const int query, const ms_peptide::PSM_TYPE psmType) const override { return 0; }
70
71 std::string getErrTolModName(const int q, const int p, std::string * modString = NULL) const override { return {}; }
72
73 double getErrTolModDelta(const int q, const int p, std::string * modString = NULL, std::string * deltaAsString = NULL) const override
74 { return 0.0; }
75
76 double getErrTolModNeutralLoss(const int q, const int p) const override { return 0.0; }
77
78 std::vector<double> getErrTolModMasterNeutralLoss(const int q, const int p) const override { return {}; }
79
80 std::vector<double> getErrTolModSlaveNeutralLoss(const int q, const int p) const override { return {}; }
81
82 std::vector<double> getErrTolModPepNeutralLoss(const int q, const int p) const override { return {}; }
83
84 std::vector<double> getErrTolModReqPepNeutralLoss(const int q, const int p) const override { return {}; }
85
86 int getTagStart(const int q, const int p, const int tagNumber) const override { return 0; }
87
88 int getTagEnd(const int q, const int p, const int tagNumber) const override { return 0; }
89
90 int getTagSeries(const int q, const int p, const int tagNumber) const override { return 0; }
91
92 bool loadPepMatchesForProteinFromCache(ms_protein * prot, const bool loadRelated=true) override { return false; }
93
94 std::unique_ptr<msparser_internal::ms_peptide_implbase> buildPeptideImpl(const msparser_internal::peptide_impl_args & args,
95 const msparser_internal::linearPeptideData_t & concatData,
96 const msparser_internal::linearPeptideData_t & linearAlpha,
97 const msparser_internal::linearPeptideData_t & linearBeta,
98 const matrix_science::ms_linker_site & linkerSite,
99 const bool storeReloadableInfo) const override
100 { return nullptr; }
101
102 std::unique_ptr<msparser_internal::ms_peptide_implbase> buildPeptideImpl(const msparser_internal::peptide_impl_args & args,
103 const matrix_science::ms_linker_site_vector & loopLinks,
104 const bool storeReloadableInfo) const override
105 { return nullptr; }
106
107 const ms_mascotresfile_nil & getResfile() const { return resfile_; }
108
109 double getQplughole(const int query, const ms_mascotresfile_dat::section sec) const override { return 0.0; }
110
111 double getQplughole(const int query, const ms_peptide::PSM_TYPE psmType) const override { return 0.0; }
112
113 bool setQmatch(const int query, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index, const int value) const override { return false; }
114
115 bool setPlughole(const int query, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index, const double value) const override { return false; }
116
117 const std::string& lookupParsedLocalModsStr(const int q, const std::string localModsStr) const override { return emptyStr_; }
118
119 const std::string& lookupParsedLocalModsStr(const ms_peptide *thisOnePep) const override { return emptyStr_;}
120
121 const std::vector<std::string>& lookupParsedIT_MODS(int q) const override { return emptyStrVec_;}
122
123 virtual void getQmatchValuesFromCacheFile(const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) const {} ;
124
125 virtual void getPlugholeValuesFromCacheFile(const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) const {};
126
127 ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1) override
128 { return {}; }
129
130 void debugCheckReloadablePeps() const override {}
131
132 std::vector<int> getSlModifiedPositions(const ms_peptide& pep, const int q, const int p, bool& ok) const override { return {}; }
133
134 private:
135 std::string emptyStr_;
136 std::vector<std::string> emptyStrVec_;
137 const ms_mascotresfile_nil &resfile_;
138 };
139
140
141} // msparser_internal namespace
142
143#endif // MS_MASCOTRESULTS_NIL_HPP
144
145/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresults_params.hpp Source File

  • inc
ms_mascotresults_params.hpp
1/*
2##############################################################################
3# file: ms_mascotresults_params.hpp #
4# 'msparser' toolkit #
5# Parameter storage for ms_peptidesummary and ms_proteinsummary #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2018 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: robertog@matrixscience.com $ #
12# $Date: 2022-07-13 15:01:20 +0100 $ #
13# $Revision: 01fae171ab6047ffa9ea37b0bdc76a78e10877a7 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_MASCOTRESULTS_PARAMS_HPP
19#define MS_MASCOTRESULTS_PARAMS_HPP
20
21namespace matrix_science {
27 class ms_mascotresults;
28 class ms_peptidesummary;
29
31 class MS_MASCOTRESFILE_API ms_mascotresults_params
32 {
33 public:
35 ms_mascotresults_params(const unsigned int flags = ms_mascotresults::MSRES_GROUP_PROTEINS,
36 double minProbability = 0.05,
37 int maxHitsToReport = 0,
38 const char * unigeneIndexFile = 0,
39 double ignoreIonsScoreBelow = 0.0,
40 int minPepLenInPepSummary = 0,
41 const char * singleHit = 0,
42 const unsigned int flags2 = ms_peptidesummary::MSPEPSUM_NONE);
43
44 virtual ~ms_mascotresults_params();
45
47 ms_mascotresults_params(const ms_mascotresults_params & src);
48
49#ifndef SWIG
51 ms_mascotresults_params& operator=(const ms_mascotresults_params & right);
52#endif
53
55 void copyFrom(const ms_mascotresults_params * right);
56
58 void setFlags(const unsigned int flags);
59
61 void setFlag(const ms_mascotresults::FLAGS flag, bool enabled);
62
64 unsigned int getFlags() const;
65
67 void setFlags2(const unsigned int flags2);
68
70 void setFlag2(const ms_peptidesummary::MSPEPSUM flag, bool enabled);
71
73 unsigned int getFlags2() const;
74
76 double getMinProbability() const;
77
79 void setMinProbability(const double minProbability);
80
82 double getTargetFDR() const;
83
85 void setTargetFDR(double fdr);
86
88 ms_mascotresults::DECOY_STATS_COUNT_TYPE getTargetFDRType() const;
89
91 void setTargetFDRType(ms_mascotresults::DECOY_STATS_COUNT_TYPE fdrType);
92
94 double getIgnoreIonsScoreBelow() const;
95
97 void setIgnoreIonsScoreBelow(const double ignoreIonsScoreBelow);
98
100 int getMinNumSigUniqueSequences() const;
101
103 void setMinNumSigUniqueSequences(const int n);
104
106 int getMaxHitsToReport() const;
107
109 void setMaxHitsToReport(const int maxHitsToReport);
110
112 int getMinPepLenInPeptideSummary() const;
113
115 void setMinPepLenInPeptideSummary(const int minPepLenInPeptideSummary);
116
118 std::string getUnigeneIndexFile() const;
119
121 void setUnigeneIndexFile(const char* unigeneIndexFile);
122
124 std::string getSingleHit() const;
125
127 void setSingleHit(const char* singleHit);
128
130 bool isUsePeptideSummary() const;
131
133 void setUsePeptideSummary(const bool usePeptideSummary);
134
135 private:
136 unsigned int flags_;
137 double minProbability_;
138 double targetFDR_;
139 ms_mascotresults::DECOY_STATS_COUNT_TYPE targetFDRtype_;
140 int maxHitsToReport_;
141 double ignoreIonsScoreBelow_;
142 std::string unigeneIndexFile_;
143 int minPepLenInPepSummary_;
144 std::string singleHit_;
145 unsigned int flags2_;
146 bool usePeptideSummary_;
147
148 int minNumSigUniqueSeqs_;
149 };
150 // end of resfile_group
152} // matrix_science namespace
153
154#endif // MS_MASCOTRESULTS_PARAMS_HPP
155
156/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults::DECOY_STATS_COUNT_TYPE
DECOY_STATS_COUNT_TYPE
Type of object counted by getNumHitsAboveIdentity() and friends.
Definition: ms_mascotresults.hpp:382
matrix_science::ms_mascotresults::FLAGS
FLAGS
Flags for the type of results.
Definition: ms_mascotresults.hpp:297
matrix_science::ms_peptidesummary::MSPEPSUM
MSPEPSUM
flags2 for ms_peptidesummary introduced in Mascot Parser 2.3.
Definition: ms_peptidesummary.hpp:140
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mascotresultsbase.hpp Source File

  • src
  • resfile
  • impl
ms_mascotresultsbase.hpp
1/*
2##############################################################################
3# file: #
4# 'msparser' toolkit #
5# Abstract class for either ms_peptidesummary or ms_proteinsummary #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresul $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-05-19 13:43:13 +0100 $ #
14# $Revision: 966a2766ff449718a5bba1bcdde4f76847f85629 | MSPARSER_ALPHA_2_8_101-88-g8aa3fa95cb $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESULTSBASE_HPP
20#define MS_MASCOTRESULTSBASE_HPP
21
22
23// Includes from the standard template library
24#include <string>
25#include <list>
26#include <vector>
27#include <set>
28#include <map>
29#include <algorithm>
30
31namespace matrix_science {
32
33 class ms_unigene;
34 class ms_protein;
35 class ms_peptide;
36 class ms_mascotresfilebase;
37 class ms_quant_component;
38 class ms_mascotresults_params;
39 class ms_mascotresults;
40}
41
42using namespace matrix_science;
43
44namespace msparser_internal {
45 class ms_proteininference;
46 struct ms_mod_instances_count;
47 class ms_mascotresults_implbase;
48
50
51
52 // TODO: We can't include private/ms_cached_msr_pepsum_data.hpp here
53 // because this file is included in msparser.hpp but it shouldn't
54 // Move this structs to that header file
55 namespace msr_cached_data
56 {
57 struct EtModsData
58 {
59 int psmType;
60 double mass;
61 double nlMass;
62 std::vector<double> scoringNl;
63 std::vector<double> satelliteNl;
64 std::string originalNaSeq;
65 std::string modifiedNaSeq;
66 std::vector<double> reqPepNl;
67 std::vector<double> pepNl;
68 std::string modTitle;
69 };
70
71 struct TagData
72 {
73 int psmType;
74 int startPos;
75 int endPos;
76 int seriesId;
77 };
78 }
79
80
87
104 class MS_MASCOTRESFILE_API ms_mascotresultsbase
105 {
106 friend class matrix_science::ms_protein;
107
108 public:
109
110 ms_mascotresultsbase(std::shared_ptr<ms_mascotresults_implbase> resultsImpl, ms_mascotresults& results);
111
112 virtual ~ms_mascotresultsbase() = default;
113
115 //virtual const ms_mascotresfile & getResfile() const = 0;
116
118 virtual bool createSummary();
119
121 bool getCreateSummaryProgress(int * cspTotalPercentComplete,
122 unsigned int * cspCurrTask,
123 int * cspCurrTaskPercentageComplete,
124 std::string * cspAccession,
125 int * cspHit,
126 int * cspQuery,
127 std::string * cspKeepAliveText) const;
128
129 bool getCreateSummaryProgress(int * cspTotalPercentComplete,
130 unsigned int * cspCurrTask,
131 int * cspCurrTaskPercentageComplete,
132 std::string & cspAccession,
133 int * cspHit,
134 int * cspQuery,
135 std::string & cspKeepAliveText) const;
136
138 void cancelCreateSummary(bool newValue = true);
139
141 virtual ms_protein * getHit(const int hit, const int memberNumber = 0) const;
142
144 virtual void freeHit(const int hit);
145
147 int getNumberOfHits() const;
148
150 int getNumberOfFamilyMembers() const;
151
153 std::string getProteinDescription(const char * accession, const int dbIdx = 1) const;
154
156 double getProteinMass(const char * accession, const int dbIdx = 1) const;
157
159 virtual double getProteinEmPAI(const char *accession, const int dbIdx = 1, int length = -1) const;
160
162 virtual bool isEmPAIallowed() const;
163
165 virtual bool anyEmPAI() const;
166
168 double getSequenceMass(const char * seq) const;
169
171 void getProteinTaxonomyIDs(const char * accession, const int dbIdx,
172 std::vector<int> & gpt_ids, std::vector<std::string> & gpt_accessions) const;
173
175 virtual const ms_protein * getProtein(const char * accession, const int dbIdx = 1) const;
176
178 virtual const ms_protein * getComponentProtein(const char * accession, const int dbIdx = 1) const;
179
181 virtual ms_protein * getNextSimilarProtein(const int masterHit, const int id) const;
182
184 virtual ms_protein * getNextSimilarProteinOf(const char * masterAccession, const int masterDB, const int id) const;
185
187 virtual ms_protein * getNextFamilyProtein(const int masterHit, const int id) const;
188
189
191 virtual ms_protein * getNextSubsetProtein(const int masterHit, const int id,
192 const bool searchWholeFamily = true) const;
193
195 virtual ms_protein * getNextSubsetProteinOf(const char * masterAccession, const int masterDB, const int id) const;
196
198 virtual ms_peptide getPeptide(const int q, const int p) const = 0;
199
201 virtual bool getPeptide(const int q, const int p, ms_peptide* & pep) const = 0;
202
204 virtual double getIonsScore(const int q, const int p, const bool decoy) const = 0;
205
207 virtual bool isPeptideUnique(const int q, const int p, const ms_mascotresults::UNIQUE_PEP_RULES rules = ms_mascotresults::UPR_DEFAULT) const = 0;
208
210 int getQmatch(const int query) const;
211
213 int getQmatch(const int query, const ms_mascotresfile_dat::section sec) const;
214
215 double getQplughole(const int query, const ms_mascotresfile_dat::section sec) const;
216
218 int getPeptideIdentityThreshold(const int query, double OneInXprobRnd, ms_mascotresults::DB_MATCH_TYPE dbType = ms_mascotresults::DM_FASTA) const;
219
221 int getAvePeptideIdentityThreshold(double OneInXprobRnd, ms_mascotresults::DB_MATCH_TYPE dbType = ms_mascotresults::DM_FASTA) const;
222
224 int getMaxPeptideIdentityThreshold(double OneInXprobRnd, ms_mascotresults::DB_MATCH_TYPE dbType = ms_mascotresults::DM_FASTA) const;
225
227 double getPeptideThreshold(const int query, double OneInXprobRnd, const int rank=1, const ms_mascotresults::THRESHOLD_TYPE thresholdType=ms_mascotresults::TT_PEPSUM_DEFAULT) const;
228
230 virtual int getProteinScoreCutoff(double OneInXprobRnd) const = 0;
231
232 virtual int getSrcRankAndPsmType(int q, int p, ms_peptide::PSM_TYPE & psmType, bool * pRejected = 0, bool inactiveSection = false) const = 0;
233
235 virtual int getSrcRank(int q, int p) const = 0;
236
238 int getProteinThreshold(double OneInXprobRnd) const;
239
241 int getHomologyThreshold(const int query,
242 double OneInXprobRnd,
243 const int rank=1) const;
244
246 int getHomologyThresholdForHistogram(double OneInXprobRnd, ms_mascotresults::DB_MATCH_TYPE dbType = ms_mascotresults::DM_FASTA) const;
247
249 virtual int getProbFromScore(const double score) const;
250
252 virtual double getPeptideExpectationValue(const double score,
253 const int query,
254 const int rank = 0) const;
255
257 virtual double getProbOfPepBeingRandomMatch(const double score,
258 const int query) const;
259
261 virtual double getProteinExpectationValue(const double score) const;
262
264 virtual double getProbOfProteinBeingRandomMatch(const double score) const;
265
267 virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) = 0;
268
270 virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
271 std::vector<int> & start,
272 std::vector<int> & end,
273 std::vector<std::string> &pre,
274 std::vector<std::string> &post,
275 std::vector<int> & frame,
276 std::vector<int> & multiplicity,
277 std::vector<int> & db,
278 std::vector<int64_t> & protId) const = 0;
279
281 virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
282 std::vector<int> & start,
283 std::vector<int> & end,
284 std::vector<std::string> &pre,
285 std::vector<std::string> &post,
286 std::vector<int> & frame,
287 std::vector<int> & multiplicity,
288 std::vector<int> & db,
289 std::vector<int64_t> & protId,
290 std::vector<int> & psmComponent) const = 0;
291
293 virtual int getAllFamilyMembersWithThisPepMatch(const int hit,
294 const int q,
295 const int p,
296 std::vector< int >& db,
297 std::vector< std::string >& acc,
298 std::vector< int >& dupe_status) const = 0;
299
301 virtual int getAllFamilyMembersWithThisPepMatchProtected(const int hit,
302 const int q,
303 const int p,
304 std::vector< int >& db,
305 std::vector< std::string >& acc,
306 std::vector<int64_t> & protId,
307 std::vector< int >& dupe_status) const = 0;
308
309
310
312 virtual std::string getErrTolModString(const int q, const int p) const = 0;
313
315 virtual std::string getLibraryModString(const int q, const int p) const = 0;
316
318 virtual std::string getErrTolModMasterString(const int q, const int p) const = 0;
319
321 virtual std::string getErrTolModSlaveString(const int q, const int p) const = 0;
322
324 virtual std::string getErrTolModPepString(const int q, const int p) const = 0;
325
327 virtual std::string getErrTolModReqPepString(const int q, const int p) const = 0;
328
330 std::string getErrTolModName(const int q, const int p, std::string * modString = NULL) const;
331
333 double getErrTolModDelta(const int q, const int p, std::string * modString = NULL, std::string * deltaAsString = NULL) const;
334
336 double getErrTolModNeutralLoss(const int q, const int p) const;
337
339 std::vector<double> getErrTolModMasterNeutralLoss(const int q, const int p) const;
340
342 std::vector<double> getErrTolModSlaveNeutralLoss(const int q, const int p) const;
343
345 std::vector<double> getErrTolModPepNeutralLoss(const int q, const int p) const;
346
348 std::vector<double> getErrTolModReqPepNeutralLoss(const int q, const int p) const;
349
351 virtual std::string getErrTolOriginalNaSeq(const int q, const int p) const = 0;
352
354 virtual std::string getErrTolModifiedNaSeq(const int q, const int p) const = 0;
357 std::string getVarModsForQP(const int q, const int p, const ms_peptide & pep,
358 const ms_peptide::PSM psmComponent,
359 int * numETMods = NULL, int * numLibraryMods = NULL,
360 std::set<std::string> * listMods = NULL) const;
361
363 std::string getLocalModsForQP(const int q, const int p, const ms_peptide & pep, const ms_peptide::PSM psmComponent, std::set<std::string> * listMods = NULL) const;
364
366 std::string getLibraryModsForQP(const int q, const int p, const ms_peptide & pep, std::set<std::string> * listMods = NULL) const;
367
369 std::vector<int> getNumDiscoveredVariableMods(const int num, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
370
372 std::vector<std::string> getDiscoveredLocalModNames() const;
373
375 std::vector<double> getDiscoveredLocalModDeltas(std::vector<std::string> * vecDeltaStrings = NULL) const;
376
378 std::vector<int> getNumDiscoveredLocalMods(const std::string modName, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
379
381 std::vector<std::string> getDiscoveredErrTolModNames() const;
382
384 std::vector<double> getDiscoveredErrTolModDeltas(std::vector<std::string> * vecDeltaStrings = NULL) const;
385
387 std::vector<int> getNumDiscoveredErrTolMods(const std::string modName, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
388
390 std::vector<int> getNumDiscoveredLibraryMods(const int modId, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
391
393 std::vector<int> getNumDiscoveredIntactLinks(std::vector<int> &varModNum1,
394 std::vector<std::string> &position1,
395 std::vector<std::string> &site1,
396 std::vector<int> &varModNum2,
397 std::vector<std::string> &position2,
398 std::vector<std::string> &site2,
399 std::vector<int> &numLinkedPeptides) const;
400
402 int getNumDiscoveredNonSpecCleavage() const;
403
404 double getPeptideThresholdProtected(const int query, double OneInXprobRnd, const int rank,
405 const ms_mascotresults::ERROR_TOLERANT_PEPTIDE etPep,
406 const ms_peptide::PSM_TYPE typeSummary,
407 const ms_mascotresults::THRESHOLD_TYPE thresholdType,
408 const ms_mascotresults::DB_MATCH_TYPE dbType) const;
409
411 virtual std::string getTagString(const int q, const int p) const = 0;
412
414 int getTagStart(const int q, const int p, const int tagNumber) const;
415
417 int getTagEnd(const int q, const int p, const int tagNumber) const;
418
420 int getTagSeries(const int q, const int p, const int tagNumber) const;
421
423 virtual int getTagDeltaRangeStart(const int q, const int p) const = 0;
424
426 virtual int getTagDeltaRangeEnd(const int q, const int p) const = 0;
427
428
430 virtual std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const = 0;
431
432
433
435 virtual std::vector<int> getIonsScoreHistogram(ms_mascotresults::IONS_HISTOGRAM flags = ms_mascotresults::IH_INCLUDE_TOP_MATCHES, ms_mascotresults::DB_MATCH_TYPE dbType = ms_mascotresults::DM_FASTA) const;
436
438 double getToleranceInDalton(bool & needMass, const double * const pMass = NULL) const;
439
441 virtual bool createUnassignedList(ms_mascotresults::sortBy s = ms_mascotresults::QUERY);
442
444 virtual int getNumberOfUnassigned() const;
445
447 virtual ms_peptide getUnassigned(const int num) const;
448
450 virtual bool getUnassignedIsBold(const int num) const;
451
453 virtual bool getUnassignedShowCheckbox(const int num) const;
454
456 ms_mascotresults_params getResultsParameters() const;
457
459 virtual bool getTreeClusterNodes(const int hit,
460 std::vector<int> &left,
461 std::vector<int> &right,
462 std::vector<double> &distance,
463 ms_mascotresults::TREE_CLUSTER_METHOD tcm = ms_mascotresults::TCM_PAIRWISE_MAXIMUM,
464 double *** reserved1 = 0,
465 unsigned int * reserved2 = 0) const;
466
468 virtual int findProteins(const int startHit,
469 const std::string & str,
470 const int dbIdx,
471 ms_mascotresults::FIND_FLAGS item,
472 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
473 std::vector<std::string> & accessions,
474 std::vector<int> & dbIndexes) const = 0;
475
477 virtual int findProteinsByAccession(const int startHit,
478 const std::string & str,
479 const int dbIdx,
480 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
481 std::vector<std::string> & accessions,
482 std::vector<int> & dbIndexes) const = 0;
483
485 virtual int findProteinsByDescription(const int startHit,
486 const std::string & str,
487 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
488 std::vector<std::string> & accessions,
489 std::vector<int> & dbIndexes) const = 0;
490
492 virtual int findPeptides(const int startHit,
493 const std::string & str,
494 ms_mascotresults::FIND_FLAGS item,
495 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
496 std::vector<int> & q,
497 std::vector<int> & p) const = 0;
498
500 virtual ms_mascotresults::QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide(
501 const matrix_science::ms_peptide & peptide,
502 matrix_science::ms_quant_component & component,
503 const matrix_science::ms_quant_method * method = NULL) const = 0;
504
506 double getProteinScoreForHistogram(const int num) const;
507
509 virtual bool isNA() const;
510
512 virtual long getNumHitsAboveIdentity(double OneInXprobRnd, ms_mascotresults::DECOY_STATS_COUNT_TYPE countType = ms_mascotresults::DS_COUNT_PSM, ms_mascotresults::DB_MATCH_TYPE dbType = ms_mascotresults::DM_FASTA);
513
515 virtual long getNumDecoyHitsAboveIdentity(double OneInXprobRnd, ms_mascotresults::DECOY_STATS_COUNT_TYPE countType = ms_mascotresults::DS_COUNT_PSM, ms_mascotresults::DB_MATCH_TYPE dbType = ms_mascotresults::DM_FASTA);
516
518 virtual long getNumHitsAboveHomology(double OneInXprobRnd, ms_mascotresults::DECOY_STATS_COUNT_TYPE countType = ms_mascotresults::DS_COUNT_PSM, ms_mascotresults::DB_MATCH_TYPE dbType = ms_mascotresults::DM_FASTA);
519
521 virtual long getNumDecoyHitsAboveHomology(double OneInXprobRnd, ms_mascotresults::DECOY_STATS_COUNT_TYPE countType = ms_mascotresults::DS_COUNT_PSM, ms_mascotresults::DB_MATCH_TYPE dbType = ms_mascotresults::DM_FASTA);
522
524 virtual void setSubsetsThreshold(const double scoreFraction);
525
526
528 double getErrTolProbabilityThreshold() const;
529
531 bool getThresholdForFDRAboveIdentity(double targetFDR, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
532
534 bool getThresholdForFDRAboveIdentity(double targetFDR, ms_mascotresults::DECOY_STATS_COUNT_TYPE countType, ms_mascotresults::DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
535
537 bool getThresholdForFDRAboveHomology(double targetFDR, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
538
540 bool getThresholdForFDRAboveHomology(double targetFDR, ms_mascotresults::DECOY_STATS_COUNT_TYPE countType, ms_mascotresults::DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
541
543 virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & value, double & rawValue) const = 0;
544
545
547 virtual std::vector<int> getPepsWithSameScore(const int q, const int p) const = 0;
548
549
552 std::string getReadableVarMods(const int q, const int p,
553 const int numDecimalPlaces=2,
554 const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
555
557 bool anyNumDiscoveredMods() const;
558
560 std::vector<int> getNumDiscoveredFixedMods(const int num,
561 std::vector<std::string> &positions,
562 std::vector<std::string> &sites) const;
563
565 std::vector<int> getNumDiscoveredVariableMods(const int num,
566 std::vector<std::string> &positions,
567 std::vector<std::string> &sites,
568 std::vector<double> &deltas,
569 std::vector<std::string> &names) const;
570
571
573 int getMinPepLenInPepSummary() const;
574
576 double getProbabilityThreshold() const;
577
579
582 unsigned int getFlags() const { return flags_; }
583
585
589 unsigned int getFlags2() const { return flags2_; }
590
592 const std::string& lookupParsedLocalModsStr(const int q, const std::string localModsStr) const;
593
595 const std::string& lookupParsedLocalModsStr(const ms_peptide *thisOnePep) const;
596
597
599 bool hasProtein(const ms_protein * const prot) const;
600
602 virtual bool loadPepMatchesForProteinFromCache(ms_protein * prot, const bool loadRelated=true);
603
604
605
607 virtual std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const = 0;
608
610 virtual bool isValidQandP(const int q, const int p) const = 0;
611
612 void debugCheckReloadablePeps() const;
613
615 virtual int getMaxRankValue() const;
616
617 const ms_mascotresfilebase& getResfile() const {return resfile_;}
618
619 ms_mascotresults& getResults() {return results_;}
620
621 const ms_mascotresults& getResults() const {return results_;}
622
623 virtual ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1);
624
625 // - Not documented - Get the 'corrected' ions score given multiplicity
626 double getIonsScoreCorrected(const double ionsScore,
627 const long multiplicity) const;
628
629 bool isCancelling() const;
630
648 bool queryRemoveThisPeptide(const unsigned short dupeFlags) const { return dupeRemoveIDs_.find(dupeFlags) != dupeRemoveIDs_.end(); }
649
666 bool queryScoreThisPeptide(const unsigned short dupeFlags) const { return dupeIncludeInScoreIDs_.find(dupeFlags) != dupeIncludeInScoreIDs_.end(); }
667
668 virtual bool cacheModificationCounts() = 0;
669
670 // Overridden only for msr classes.
671 virtual std::map<int, msparser_internal::msr_cached_data::EtModsData> getEtModsCachedData(const int q, const ms_peptide::PSM_TYPE psmType) const { return {}; }
672 virtual std::map<std::pair<int, int>, msparser_internal::msr_cached_data::TagData> getTagCachedData(const int q, const ms_peptide::PSM_TYPE psmType) const { return {}; }
673
674
675 inline bool checkCreated(const char * funcname, unsigned int t) const {
676 if (!(completedTasks_ & t)) {
677 const_cast< ms_mascotresfilebase&>(resfile_).setError(ms_errs::ERR_RESULTS_NOT_CREATED, funcname);
678 return false;
679 } else {
680 return true;
681 }
682 }
683
684 bool tooOld() const { return tooOld_; }
685 ms_peptide::PSM_TYPE typeSummary() const { return typeSummary_; }
686 ms_peptide::PSM_TYPE typePeptides() const { return typePeptides_; }
687 bool isDecoyMixture() const { return isDecoyMixture_; }
688 bool isDecoyProteins() const { return isDecoyProteins_; }
689
690 double minProbability() const { return minProbability_; }
691 bool useFusionETthresholds() const { return useFusionETthresholds_; }
692
693 int numDatabases() const { return numDatabases_; }
694 int numQueries() const { return numQueries_; }
695
696 int getQmatch(const int query, const ms_peptide::PSM_TYPE psmType) const;
697 bool setQmatch(const int query, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index, const int value) const;
698 double getQplughole(const int query, const ms_peptide::PSM_TYPE psmType) const;
699 bool setPlughole(const int query, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index, const double value) const;
700
701
702 void setResfileError(int error, ...) const;
703
704
705
706 std::unique_ptr<msparser_internal::ms_peptide_implbase> buildPeptideImpl(const msparser_internal::peptide_impl_args & args,
707 const matrix_science::ms_linker_site_vector & loopLinks,
708 const bool storeReloadableInfo) const;
709
710 std::unique_ptr<msparser_internal::ms_peptide_implbase> buildPeptideImpl(const msparser_internal::peptide_impl_args & args,
711 const msparser_internal::linearPeptideData_t & concatData,
712 const msparser_internal::linearPeptideData_t & linearAlpha,
713 const msparser_internal::linearPeptideData_t & linearBeta,
714 const matrix_science::ms_linker_site & linkerSite,
715 const bool storeReloadableInfo) const;
716
717
718 virtual void getQmatchValuesFromCacheFile(const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) const {};
719 virtual void getPlugholeValuesFromCacheFile(const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) const {};
720
721 virtual void addQPinfoToCacheFile(const int q) const {};
722
723 static double getValidMinProbability(double minProbability);
724 static double getValidIgnoreIonsScoreBelow(double ignoreIonsScoreBelow);
725 static int getValidMinNumSigUniqueSeqs(int n);
726 static int getValidFlags1(const ms_mascotresfilebase &resfile, int flags);
727 static double getValidOneInXprobRnd(double OneInXprobRnd);
728 static double getValidTargetFDR(double fdr);
729 static ms_mascotresults::DECOY_STATS_COUNT_TYPE getValidTargetFDRType(ms_mascotresults::DECOY_STATS_COUNT_TYPE type);
730
731 //TODO: Do something about this
732 mutable unsigned int completedTasks_;
733
734 protected:
735
736
737 static const double probability_lower_bound;
738
739 virtual bool queryHasSignificantRank1Match(ms_peptide::PSM_TYPE psmType,
740 int query) const = 0;
741
742 virtual ms_mascotresfile_dat::section getSrcSectionProtected(const int query, const int rank) const;
743 virtual ms_peptide::PSM_TYPE getSrcPsmTypeProtected(const int query, const int rank) const;
744
745 virtual void calculateDecoyStats(double dOneInXprobRnd) = 0;
746
747 virtual bool getThresholdForFDR(bool homology, double targetFDR,
748 ms_mascotresults::DECOY_STATS_COUNT_TYPE countType, ms_mascotresults::DB_MATCH_TYPE dbType,
749 double * closestFDR, double * minProbability,
750 int * pNumTargetMatches, int * pNumDecoyMatches) = 0;
751
752 bool queryHasSecondPassMatches(ms_peptide::PSM_TYPE psmType, int query) const;
753
754 ms_protein* addProtein(const std::string & accession,
755 const int dbIdx,
756 const int64_t proteinId,
757 const int q, const int p,
758 const msparser_internal::ms_protein_match_data &proteinMatchData,
759 const double score,
760 const double uncorrectedScore,
761 const ms_peptide::SEARCH_PHASE searchPhase = ms_peptide::SEARCH_PHASE_PRIMARY,
762 const bool isIgnored = false);
763
764 ms_protein* addMixtureComponentProtein(const std::string & mixAccession,
765 const int q, const int p,
766 const msparser_internal::ms_protein_match_data &proteinMatchData,
767 const double score,
768 const double uncorrectedScore,
769 const ms_protein * master,
770 const ms_peptide::SEARCH_PHASE searchPhase);
771
772 ms_protein * addUniGeneComponentProtein(const std::string & accession,
773 const int dbIdx,
774 const int q, const int p,
775 const msparser_internal::ms_protein_match_data &proteinMatchData,
776 const double score,
777 const double uncorrectedScore,
778 const ms_peptide::SEARCH_PHASE searchPhase,
779 const bool isIgnored = false);
780
781 ms_protein * addUniGeneProtein(const std::string & unigeneID,
782 const int q, const int p,
783 const msparser_internal::ms_protein_match_data &proteinMatchData,
784 const double score,
785 const double uncorrectedScore,
786 const ms_protein * component,
787 const ms_peptide::SEARCH_PHASE searchPhase,
788 const bool isIgnored = false);
789
790
791 bool canAddPeptideToProtein(const int dbIdx,
792 const ms_peptide::SEARCH_PHASE searchPhase,
793 const bool isIgnored) const;
794
795
797 double getPepIdentThreshProtected(const int query,
798 double OneInXprobRnd,
799 ms_peptide::PSM_TYPE psmType,
800 ms_mascotresults::DB_MATCH_TYPE dbType,
801 double * pQmatch = 0) const;
802
803 double getHomologyThreshProtected(const int query,
804 double OneInXprobRnd,
805 ms_peptide::PSM_TYPE psmType,
806 const int rank=1,
807 const ms_mascotresults::ERROR_TOLERANT_PEPTIDE etPep = ms_mascotresults::ETPEP_UNKNOWN ) const;
808
809 double calculateHomologyThreshold(int query,
810 double qplughole,
811 double OneInXprobRnd,
812 double identityThreshold,
813 double qmatch) const;
814
815 double getPeptideExpectationValueProtected(const double score,
816 const int query,
817 const ms_peptide::PSM_TYPE summary_type,
818 const ms_mascotresults::THRESHOLD_TYPE thresholdType,
819 const ms_mascotresults::DB_MATCH_TYPE dbType) const;
820
821 std::vector<int> getSlModifiedPositions(const ms_peptide& pep, const int q, const int p, bool& ok) const;
822
823 bool countModificationInstances(msparser_internal::ms_mod_instances_count& c);
824
825 double calculateFirstPassThreshold(ms_peptide::PSM_TYPE typeSummary,
826 int query,
827 double OneInXprobRnd,
828 ms_mascotresults::THRESHOLD_TYPE tt) const;
829
830 // Not documented - check that minProbability is higher than first_pass_threshold
831 bool isMinProbabilityHigherThanFirstPassThreshold() const;
832
833 double overrideOneInXprobRnd(bool hasSecondPassMatches) const;
834
835 std::shared_ptr<msparser_internal::ms_mod_instances_count> modCount_;
836
837 std::shared_ptr<msparser_internal::ms_proteininference> pProteinInferencer_;
838
839 // The elements in the vector of peptides are accessed by
840 // q + (p * num queries)
841 std::vector<std::shared_ptr<ms_peptide>> peptides_;
842
843 const unsigned int flags_;
844 const unsigned int flags2_;
845 const double minProbability_;
846 const int maxHitsToReport_;
847
848 const int numQueries_;
849 double top50Scores_[50];
850 bool isPercolator_;
851 mutable bool nucleicAcid_; //Set in ms_peptidesummary_msr::_cachePepProteinsData() const
852
853 mutable int cachedAvePepIdentThreshMascot_;
854 mutable int cachedAvePepIdentThreshSL_;
855 std::vector<int> ionsScoreHistogramTopMatchMascot_;
856 std::vector<int> ionsScoreHistogramTop10Mascot_;
857 std::vector<int> ionsScoreHistogramTopMatchSL_;
858 std::vector<int> ionsScoreHistogramTop10SL_;
859 int maxRankValue_;
860 ms_mascotresults::THRESHOLD_TYPE thresholdType_;
861 double minScoreThreshold_;
862 bool useFusionETthresholds_;
863
864 double slScoreStats_[4];
865 double& slScoreStatsMascotMean() { return slScoreStats_[0]; }
866 double& slScoreStatsMascotStdev() { return slScoreStats_[1]; }
867 double& slScoreStatsLibraryMean() { return slScoreStats_[2]; }
868 double& slScoreStatsLibraryStdev() { return slScoreStats_[3]; }
869 const double& slScoreStatsMascotMean() const { return slScoreStats_[0]; }
870 const double& slScoreStatsMascotStdev() const { return slScoreStats_[1]; }
871 const double& slScoreStatsLibraryMean() const { return slScoreStats_[2]; }
872 const double& slScoreStatsLibraryStdev() const { return slScoreStats_[3]; }
873
874 ms_peptide::PSM_TYPE typeSummary_;
875 ms_peptide::PSM_TYPE typePeptides_;
876 bool isDecoyMixture_;
877 bool isDecoyProteins_;
878
879 const int minPepLenInPepSummary_;
880 std::string singleHit_;
881 const double ignoreIonsScoreBelow_;
882 const int minNumSigUniqueSeqs_;
883 const double targetFDR_;
884 const ms_mascotresults::DECOY_STATS_COUNT_TYPE targetFDRtype_;
885 const int numDatabases_;
886 double minErrTolProbability_;
887
888 std::shared_ptr<msparser_internal::ms_unassigned> unassigned_;
889
890 ms_mascotresults::proteinSet proteins_;
891 // For unigene, the original proteins are not saved in proteins_
892 ms_mascotresults::proteinSet componentProteins_;
893
894
895 bool bDecoyStatsCalculated_;
896 double dOneInXprobRndForDecoy_;
897 const bool tooOld_;
898
899 inline long& decoyStatsOf(bool decoy, ms_mascotresults::DECOY_STATS_COUNT_TYPE countType, ms_mascotresults::DECOY_STATS_THRESHOLD_TYPE thrType, ms_mascotresults::DB_MATCH_TYPE dbType)
900 {
901 return decoyStats_[decoy ? 1 : 0][countType][thrType][dbType];
902 }
903 static void checkDecoyStatsArguments(double &OneInXprobRnd, ms_mascotresults::DECOY_STATS_COUNT_TYPE &countType, ms_mascotresults::DB_MATCH_TYPE &dbType);
904 void resetDecoyStats(long c);
905
906 std::shared_ptr<ms_mascotresults_implbase> resultsImpl_;
907
908 const ms_mascotresfilebase& resfile_;
909
910 private:
911
912 ms_mascotresults& results_;
913
914 // resultsParams_ contains the constructor parameters passed in by
915 // the user. Has to be allocated dynamically because of a circular
916 // dependency between ms_mascotresults.hpp and
917 // ms_mascotresults_params.hpp.
918 std::shared_ptr<const ms_mascotresults_params> resultsParams_;
919 const double tolFactor_;
920 double subsetsScoreFraction_;
921
922
923 // Pointer initialised from resfile_.getProgressInfo(),
924 // it's (de)allocated somewhere else.
925 ms_progress_info* progress_;
926 std::shared_ptr<msparser_internal::ms_mutex> pMutex_;
927
928 void initDuplicates();
929 std::set<unsigned short>dupeRemoveIDs_;
930 std::set<unsigned short>dupeIncludeInScoreIDs_;
931
932 void initSeqMassLookup();
933 double sequenceMassResidueLookup_[256];
934
935 mutable std::vector<double> cachedHomologyValues_[2];
936
937 mutable bool cancelCreateSummary_;
938
939 // Array sizes must match the number of factor levels for each enum.
940 long decoyStats_[ms_mascotresults::DECOY_STATS_TD_LEVELS][ms_mascotresults::DECOY_STATS_COUNT_TYPE_LEVELS][ms_mascotresults::DECOY_STATS_THR_TYPE_LEVELS][ms_mascotresults::DECOY_STATS_DB_TYPE_LEVELS];
941
942 void initSrcDataTypes();
943
944 ms_protein*
945 addProteinInternal(ms_mascotresults::proteinSet &proteinSet,
946 const std::string &accession,
947 const int dbIdx,
948 const int64_t proteinId,
949 const int q, const int p,
950 const msparser_internal::ms_protein_match_data &proteinMatchData,
951 const double correctedScore,
952 const double uncorrectedScore,
953 const ms_protein * component,
954 const ms_peptide::SEARCH_PHASE searchPhase,
955 const bool isUnigene,
956 const bool isIgnored);
957
958 };
959 // end of resfile_group
961
963
964} // msparser_internal namespace
965
966#endif // MS_MASCOTRESULTSBASE_HPP
967
968/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errs::ERR_RESULTS_NOT_CREATED
static const err ERR_RESULTS_NOT_CREATED
[W] Attempting to call Mascot Parser function %s before createSummary() has completed.
Definition: ms_errors.hpp:102
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_mascotresults::FIND_COMPARE_FLAGS
FIND_COMPARE_FLAGS
Flags to specify how comparisons are performed in the find functions.
Definition: ms_mascotresults.hpp:189
matrix_science::ms_mascotresults::TREE_CLUSTER_METHOD
TREE_CLUSTER_METHOD
Flags for getTreeClusterNodes().
Definition: ms_mascotresults.hpp:128
matrix_science::ms_mascotresults::TCM_PAIRWISE_MAXIMUM
@ TCM_PAIRWISE_MAXIMUM
'm': pairwise maximum- (or complete-) linkage clustering.
Definition: ms_mascotresults.hpp:131
matrix_science::ms_mascotresults::sortBy
sortBy
Flags for createUnassignedList().
Definition: ms_mascotresults.hpp:95
matrix_science::ms_mascotresults::QUERY
@ QUERY
Sort the unassigned list by ascending query number - this is the same as ascending relative mass orde...
Definition: ms_mascotresults.hpp:96
matrix_science::ms_mascotresults::DECOY_STATS_COUNT_TYPE
DECOY_STATS_COUNT_TYPE
Type of object counted by getNumHitsAboveIdentity() and friends.
Definition: ms_mascotresults.hpp:382
matrix_science::ms_mascotresults::DS_COUNT_PSM
@ DS_COUNT_PSM
Count peptide-spectrum matches (PSMs). This is the default.
Definition: ms_mascotresults.hpp:383
matrix_science::ms_mascotresults::UNIQUE_PEP_RULES
UNIQUE_PEP_RULES
Flags for isPeptideUnique().
Definition: ms_mascotresults.hpp:360
matrix_science::ms_mascotresults::UPR_DEFAULT
@ UPR_DEFAULT
Set to UPR_WITHIN_FAMILY_MEMBER | UPR_IGNORE_SUBSET_PROTEINS.
Definition: ms_mascotresults.hpp:365
matrix_science::ms_mascotresults::FIND_FLAGS
FIND_FLAGS
Flags for findPeptides() and findProteins().
Definition: ms_mascotresults.hpp:146
matrix_science::ms_mascotresults::THRESHOLD_TYPE
THRESHOLD_TYPE
Flags for getPeptideThreshold()
Definition: ms_mascotresults.hpp:373
matrix_science::ms_mascotresults::TT_PEPSUM_DEFAULT
@ TT_PEPSUM_DEFAULT
If ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH is specified in the constructor,...
Definition: ms_mascotresults.hpp:376
matrix_science::ms_mascotresults::DB_MATCH_TYPE
DB_MATCH_TYPE
Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreH...
Definition: ms_mascotresults.hpp:344
matrix_science::ms_mascotresults::DM_FASTA
@ DM_FASTA
Mascot matches to FASTA sequences. This is the default.
Definition: ms_mascotresults.hpp:345
matrix_science::ms_mascotresults::QUANT_COMPONENT_STATUS
QUANT_COMPONENT_STATUS
Return codes for getQuantitationComponentForPeptide().
Definition: ms_mascotresults.hpp:279
matrix_science::ms_mascotresults::IONS_HISTOGRAM
IONS_HISTOGRAM
Flags for getIonsScoreHistogram().
Definition: ms_mascotresults.hpp:231
matrix_science::ms_mascotresults::IH_INCLUDE_TOP_MATCHES
@ IH_INCLUDE_TOP_MATCHES
The default. Just include the top match to each spectrum.
Definition: ms_mascotresults.hpp:232
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_peptide::PSM_COMPLETE
@ PSM_COMPLETE
Peptide-spectrum match, also linear peptide in a non-crosslinked match.
Definition: ms_peptide.hpp:99
matrix_science::ms_progress_info
Contains information of the current progress of a task being performed.
Definition: ms_progress_info.hpp:40
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_unigene
This class encapsulates a complete unigene file.
Definition: ms_unigene.hpp:162
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_masses.hpp Source File

  • inc
ms_masses.hpp
1/*
2##############################################################################
3# file: ms_masses.hpp #
4# 'msparser' toolkit #
5# Encapsulates "masses"-file that defines atom and residue masses #
6# about several consecutive erros #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /Mowse/ms_mascotresfile/include/ms_masses.hpp $ #
13# $Author: villek@matrixscience.com $ #
14# $Date: 2024-08-19 15:33:52 +0100 $ #
15# $Revision: d48a6aa34bb34c80a33469ce907f789f718e62a6 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_MASSES_HPP
21#define MS_MASSES_HPP
22
23
24#include <string>
25
26
27namespace matrix_science {
28
29 class ms_umod_configfile; // forward declaration
30 class ms_quant_component; // forward declaration
31
38
47 class MS_MASCOTRESFILE_API ms_masses: public ms_errors
48 {
49 public:
51 ms_masses();
52
54 ms_masses(const ms_masses& src);
55
57 ms_masses(const ms_umod_configfile& src, bool addMissingResidueMasses=true);
58
60 ms_masses(const ms_umod_configfile& src, const ms_quant_component& quantComp);
61
63 ms_masses(const char* filename, const matrix_science::ms_connection_settings * cs = 0);
64
66 ~ms_masses();
67
69 void defaultValues(bool useDefaultResidueMasses=true);
70
72 void copyFrom(const ms_masses* right);
73
75 void copyFrom(const ms_umod_configfile *right, bool addMissingResidueMasses=true);
76
78 ms_modvector applyFixedMods(const ms_modvector *mods, ms_errs *err);
79
81 void applyIsotopes(const ms_umod_configfile *umodFile, const ms_quant_component *quantComp);
82
84 bool isSame(const ms_masses& other, const MASS_TYPE massType) const;
85
86#ifndef SWIG
88 ms_masses& operator=(const ms_masses& right);
89#endif
91 std::string getFileName() const;
92
94 void setFileName(const char* name);
95
97 void setConnectionSettings(const matrix_science::ms_connection_settings & cs);
98
100 matrix_science::ms_connection_settings getConnectionSettings() const;
101
103 void read_file();
104
106 void save_file();
107
108#ifndef SWIG
110 void saveToString(std::string & modfileAsStr);
111#else // SWIG Multiple return values
112 void saveToString(std::string & OUTPUT);
113#endif
114
116 double getResidueMass(const matrix_science::MASS_TYPE massType, const char residue) const;
117
119 void setResidueMasses(const char residue, const double massMono, const double massAve);
120
122 double getNtermDelta(const matrix_science::MASS_TYPE massType) const;
123
125 double getNterminalMass(const matrix_science::MASS_TYPE massType) const;
126
128 double getNtermNeutralLoss(const matrix_science::MASS_TYPE massType) const;
129
131 void setNtermModification(const double monoDelta,
132 const double aveDelta,
133 const double monoNeutralLoss = 0.0,
134 const double aveNeutralLoss = 0.0);
135
137 double getCtermDelta(const matrix_science::MASS_TYPE massType) const;
138
140 double getCterminalMass(const matrix_science::MASS_TYPE massType) const;
141
143 double getCtermNeutralLoss(const matrix_science::MASS_TYPE massType) const;
144
146 void setCtermModification(const double monoDelta,
147 const double aveDelta,
148 const double monoNeutralLoss = 0.0,
149 const double aveNeutralLoss = 0.0);
150
152 double getFragResidueMass(const matrix_science::MASS_TYPE massType, const char residue) const;
153
155 bool isResidueModified(const char residue) const;
156
158 void setResidueModification(const double monoDelta,
159 const double aveDelta,
160 const double monoNeutralLoss,
161 const double aveNeutralLoss,
162 const char *residues);
163
165 double getHydrogenMass(const matrix_science::MASS_TYPE massType) const;
166
168 void setHydrogenMass(const double massMono, const double massAve);
169
171 double getCarbonMass(const matrix_science::MASS_TYPE massType) const;
172
174 void setCarbonMass(const double massMono, const double massAve);
175
177 double getNitrogenMass(const matrix_science::MASS_TYPE massType) const;
178
180 void setNitrogenMass(const double massMono, const double massAve);
181
183 double getOxygenMass(const matrix_science::MASS_TYPE massType) const;
184
186 void setOxygenMass(const double massMono, const double massAve);
187
189 double getElectronMass() const;
190
192 void setElectronMass(const double mass);
193
195 void setStorage(double* res_mono,
196 double* res_ave,
197 double* hydrogen,
198 double* carbon,
199 double* nitrogen,
200 double* oxygen,
201 double* electron);
202
204 void defaultMasses(double* res_mono,
205 double* res_ave,
206 double* hydrogen,
207 double* carbon,
208 double* nitrogen,
209 double* oxygen,
210 double* electron,
211 bool useDefaultResidueMasses = true);
212
213 private:
214
215 bool getTwoMasses(char * line,
216 char *lineForError,
217 double *pMono,
218 double *pAve,
219 const double dMin,
220 const double dMax);
221
222 void setCustomProperty();
223
224 private:
225 // final destinations - they are assigned either
226 // 1) supplied array pointers
227 // 2) the internal storages
228 double* res_mono;
229 double* res_ave;
230
231 // mass combined with neutral loss for residue-specific mods
232 bool res_mod[26];
233 double* frag_res_mono;
234 double* frag_res_ave;
235
236 // masses of terminal groups for terminus mods
237 double ntermDelta[2];
238 double ctermDelta[2];
239
240 // neutral losses on terminal groups for terminus mods
241 double neutralLossNterm[2];
242 double neutralLossCterm[2];
243
244 double* hydrogen;
245 double* carbon;
246 double* nitrogen;
247 double* oxygen;
248
249 double* electron;
250
251 // internal storages in case they are not supplied with a proper constructor
252 double _res_mono[26];
253 double _res_ave[26];
254 double _frag_res_mono[26];
255 double _frag_res_ave[26];
256
257 double _hydrogen[2];
258 double _carbon[2];
259 double _nitrogen[2];
260 double _oxygen[2];
261
262 double _electron;
263
264 std::string _fn;
265 ms_customproperty _custprop;
266 ms_connection_settings cs_;
267 }; // class ms_masses // end of config_group
269}
270
271#endif // MS_MASSES_HPP
272
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_masses
Reads and parses the masses file with residue and atom masses.
Definition: ms_masses.hpp:48
matrix_science::ms_modvector
General usage class for creating lists of modifications to be passed as parameters.
Definition: ms_modfile.hpp:339
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::MASS_TYPE
MASS_TYPE
All possible mass types.
Definition: ms_modfile.hpp:65
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_matrix.hpp Source File

  • inc
ms_matrix.hpp
1/*
2 * Copyright (C) 2002-2013, Matrix Science Limited, London, UK.
3 * All rights reserved.
4 *
5 * @(#)$Source: parser/inc/ms_matrix.hpp $
6 * @(#)$Revision: 436aa2996c6a3d2d2f0cdb88fab902c2780ae29a | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
7 * @(#)$Date: 2019-05-16 11:53:33 +0100 $
8 */
9
10#ifndef MS_MATRIX_HPP
11#define MS_MATRIX_HPP
12
13
14#include <vector>
15
16namespace matrix_science
17{
24
35 class MS_MASCOTRESFILE_API ms_matrix
36 {
37 public:
38
39 typedef std::vector<double> column_vector_t;
40 typedef std::vector<column_vector_t> matrix_t;
41
43 static ms_matrix diagonalMatrix(size_t s, double v);
44
46 static ms_matrix identityMatrix(size_t s);
47
49 static ms_matrix rowMatrix(const std::vector<double> & v);
50
52 static ms_matrix columnMatrix(const std::vector<double> & v);
53
55 ms_matrix();
56
58 ms_matrix(const matrix_t & m);
59
61 ms_matrix(size_t si, size_t sj, double v = 0.0);
62
64 size_t sizei() const;
65
67 size_t sizej() const;
68
69#ifndef SWIG
71 column_vector_t & operator[](size_t i);
72
74 const column_vector_t & operator[](size_t i) const;
75#endif
77 double getCR(size_t i, size_t j) const;
79 void setCR(size_t i, size_t j, double value);
80
82 double getRC(size_t i, size_t j) const { return getCR(j, i); }
84 void setRC(size_t i, size_t j, double value) { setCR(j, i, value); }
85
87 const matrix_t & data() const;
88#ifndef SWIG
90 bool operator==(const ms_matrix & m) const;
91
93 bool operator!=(const ms_matrix & m) const;
94
96 ms_matrix operator*(const ms_matrix & m) const;
97#endif
99 bool isZero() const;
100
102 void resize(size_t si, size_t sj, double v = 0.0);
103
105 double multiplyByRow(const std::vector<double> & column, size_t row) const;
106
108 void setColumnDown(size_t row, size_t col, const std::vector<double> & vec);
109
111 void setColumnUp(size_t row, size_t col, const std::vector<double> & vec);
112
114 void transpose();
115
117 void logContents(ms_errs & errs, const char * description) const;
118
119 private:
120 matrix_t matrix_;
121 };
122 // end of tools_group
124} // namespace matrix_science
125
126#endif // MS_MATRIX_HPP
127
128/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_matrix
A two-dimensional matrix of numbers.
Definition: ms_matrix.hpp:36
matrix_science::ms_matrix::getRC
double getRC(size_t i, size_t j) const
Get the value for the specified row and column.
Definition: ms_matrix.hpp:82
matrix_science::ms_matrix::setRC
void setRC(size_t i, size_t j, double value)
Set the value for the specified row and column.
Definition: ms_matrix.hpp:84
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_mod_visibility_helper.hpp Source File

  • inc
ms_mod_visibility_helper.hpp
1/*
2##############################################################################
3# File: ms_mod_visibility_helper.hpp #
4# Mascot Parser toolkit #
5# Utility classes for managing modification visibility #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source: parser/inc/ms_mod_visibility_helper.hpp $
12# $Author: francoisr@matrixscience.com $
13# $Date: 2019-03-15 14:15:26 +0000 $
14# $Revision:
15##############################################################################
16*/
17
18#ifndef _MS_SPECIFICITY_VISIBILITY_H
19#define _MS_SPECIFICITY_VISIBILITY_H
20
21
22#include <string>
23#include <vector>
24
25namespace matrix_science {
26
27 class ms_umod_specificity;
28 class ms_umod_configfile;
29 class ms_modfile;
30
36 // \cond INTERNAL
38
48 class MS_MASCOTRESFILE_API ms_spec_visibility
49 {
50 public:
52 ms_spec_visibility();
53
55 ms_spec_visibility(std::string site);
57 ms_spec_visibility(std::string site, std::string position);
59 ~ms_spec_visibility();
60
62 std::string getSite();
64 void setSite(std::string s);
66 std::string getPosition();
68 void setPosition(std::string s);
69
71 bool isHidden();
73 void setHidden(bool bHide);
74
76 bool inShortList() const;
78 void showInShortList(bool b);
80 bool inLongList() const;
82 void showInLongList(bool b);
84 bool inErrorTolerant() const;
86 void useInErrorTolerant(bool b);
87
89 bool isOveridden();
91 void setOveridden(bool b);
92
93 private:
94 void initialise();
95
96 std::string m_site;
97 std::string m_position;
98 bool m_show_in_short_list;
99 bool m_show_in_long_list;
100 bool m_use_in_error_tolerant;
101 bool m_overridden;
102 }; // class ms_spec_visibility
103 // \endcond
104
105
106 // \cond INTERNAL
108
117 class MS_MASCOTRESFILE_API ms_mod_visibility
118 {
119 public:
121 ms_mod_visibility();
122
124 ~ms_mod_visibility();
125
127 std::string getName();
129 void setName(std::string s);
130
132 void setNumberOfSpecs(int spec_count);
134 int getNumberOfSpecs();
136 void getDefaults(int spec_number, const ms_umod_specificity *spec);
138 void setDefaults(int spec_number, const char site, bool hidden);
140 void setDefaults(int spec_number, const char site, std::string position, bool hidden);
141
142
144 void applyVisibilities( ms_umod_specificity *spec);
146 bool updateVisibilities( const ms_umod_specificity *spec);
148 bool updateIsPrivate(bool is_private);
149
151 bool isPrivate() const;
153 void setPrivate(bool b);
154
156 bool isPrivacyEnabled() const;
158 void setPrivacyEnabled(bool b);
159
161 bool hasOverrides();
163 bool isOveridden();
165 void setOveridden(bool b);
166
168 bool isDeleted();
170 void setDeleted(bool b);
171
173 ms_spec_visibility &getSpecVisibility(int index);
175 ms_spec_visibility &getSpecVisibility(std::string site, bool bCreate);
177 ms_spec_visibility &getSpecVisibility(std::string site, std::string position, bool bCreate);
178
179 private:
180
181 typedef std::vector< ms_spec_visibility> spec_vis_vector;
182 spec_vis_vector m_specs;
183
184 std::string m_name;
185 ms_spec_visibility m_default_spec;
186
187 bool m_isPrivacyEnabled;
188 bool m_isPrivate;
189 bool m_overridden;
190 bool m_deleted;
191 }; // class ms_mod_visibility
192 // \endcond
193
194 // \cond INTERNAL
196
203 class MS_MASCOTRESFILE_API ms_mod_visibility_helper : public ms_errors
204 {
205 public:
207 ms_mod_visibility_helper();
208
210 ms_mod_visibility_helper(const matrix_science::ms_session *session, const std::string &visibility_filename, ms_umod_configfile *config);
212 ms_mod_visibility_helper(const std::vector<int> & groupIds, const std::string &visibility_filename, ms_umod_configfile *config);
214 ms_mod_visibility_helper(const matrix_science::ms_session *session, const std::string &visibility_filename, ms_modfile *modfile);
216 ms_mod_visibility_helper(const std::string &visibility_full_filename);
218 ~ms_mod_visibility_helper();
219
221 bool hasPrivacy();
222
224 bool saveToGroupFiles(const matrix_science::ms_session *session, const std::string &visibility_filename, const bool saveAllForCrosslinking = false);
226 bool saveToFile(const std::string &filename, const bool saveAllForCrosslinking = false);
227
229 ms_mod_visibility *getModVisibility(int index);
231 ms_mod_visibility *getModVisibility(const std::string &mod_title, bool bCreate);
233 void removeModVisibilty(const std::string &mod_title);
234
236 void setVisibilities(matrix_science::ms_umod_configfile *config);
238 void setVisibilities(matrix_science::ms_modfile *modfile);
239
241 static void getUserGroupVisibilty(
242 matrix_science::ms_session *session, const std::string &mod_title, std::string &visibility_filename,
243 std::vector<std::string> &excluded_usergroups, std::vector<std::string> &included_usergroups);
245 static void setUserGroupVisibilty(
246 matrix_science::ms_session *session, const std::string &mod_title, std::string &visibility_filename,
247 std::vector<std::string> &excluded_usergroups, std::vector<std::string> &included_usergroups);
248
250 static void getDefaultUserGroups(
251 matrix_science::ms_session *session,
252 std::vector<std::string> &excluded_usergroups, std::vector<std::string> &included_usergroups);
253
254 private:
255 //Do not copy this object
256 ms_mod_visibility_helper(const ms_mod_visibility_helper & src);
257 ms_mod_visibility_helper& operator=(const ms_mod_visibility_helper & right);
258
259 // Setup m_show_in_long_list defaults for config specifity "hidden" attributes.
260 void getDefaults(ms_umod_configfile *config);
261 void getDefaults(ms_modfile *modfile);
262 bool getUserGroupFileNames(const matrix_science::ms_session *session, const std::string &visibility_filename, bool bAllGroups, const std::vector<int> * groupIds = NULL);
263
264 bool loadFromFile(const std::string &filename);
265 void loadVisibility(const matrix_science::ms_session *session, const std::string &visibility_filename, const std::vector<int> * groupIds = NULL);
266
267 void clearOverrideFlags();
268
269 bool getSpecSitesFromModString(std::string modfile_spec_name, std::string &sites, std::string &position);
270
271 typedef std::vector< ms_mod_visibility> mod_vis_vector;
272 mod_vis_vector m_mods;
273
274 ms_mod_visibility m_default_mod;
275
276 std::vector<std::string> m_userGroupVisibilityFiles;
277 bool m_inAdminGroup;
278 bool m_hasPrivacy;
279 }; // class ms_mod_visibility_helper
280 // \endcond
281 // end of config_group
283
284
285
286} // namespace matrix_science
287
288#endif // _MS_SPECIFICITY_VISIBILITY_H
289
290/*------------------------------- End of File -------------------------------*/
matrix_science::ms_modfile
Use this class in order to read in the amino acid modification file.
Definition: ms_modfile.hpp:407
matrix_science::ms_session
Use this class to determine if a user is logged in and if they have 'permission' to perform tasks.
Definition: ms_security_session.hpp:123
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_modfile.hpp Source File

  • inc
ms_modfile.hpp
1/*
2##############################################################################
3# file: ms_modfile.hpp #
4# 'msparser' toolkit #
5# Encapsulates "mod_file"-file that defines amino acid modifications #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_modfile.hpp $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2024-04-30 14:29:58 +0100 $ #
14# $Revision: 514b75f28c7f9636ba624f627dd5cb3f4e495b2e | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MODFILE_HPP
20#define MS_MODFILE_HPP
21
22
23#include <string>
24#include <vector>
25#include <memory>
26
27namespace msparser_internal {
28 class ms_modification_impl;
29}
30
31namespace matrix_science {
32
33 class ms_masses;
34 class ms_umod_modification;
35
46 enum MOD_TYPES
47 {
48 MOD_TYPE_RESIDUE = 0,
49 MOD_TYPE_N_TERM = 1,
50 MOD_TYPE_C_TERM = 2,
51 MOD_TYPE_N_PROTEIN = 3,
52 MOD_TYPE_C_PROTEIN = 4,
53 MOD_TYPE_N_TERM_RESIDUE = 5,
54 MOD_TYPE_C_TERM_RESIDUE = 6,
55 MOD_TYPE_N_PROTEIN_RESIDUE= 7,
56 MOD_TYPE_C_PROTEIN_RESIDUE= 8,
57 MOD_TYPE_______LAST = 9 // This must always be last....
58 };
59
61
64 enum MASS_TYPE
65 {
66 MASS_TYPE_MONO = 0x0000,
67 MASS_TYPE_AVE = 0x0001
68 };
69
71
74 enum
75 {
76 MAX_VAR_MODS = 'W' -'A' + 10
77 };
78
79 typedef std::vector<double> ms_vectorDouble;
80 typedef std::vector< bool > ms_vectorBool;
81
83
133 class MS_MASCOTRESFILE_API ms_modification: public ms_customproperty
134 {
135 friend class ms_modfile;
136 friend class ms_modvector;
137 public:
138
140 ms_modification(const ms_masses* massFile = NULL);
141
143 ms_modification(const ms_modification& src);
144
146 ~ms_modification();
147
149 void defaultValues();
150
152 void copyFrom(const ms_modification* src);
153
154#ifndef SWIG
156 ms_modification& operator=(const ms_modification& right);
157#endif
158
160 std::string getClassification() const;
161
163 bool getFromUnimod(const char* modName, const ms_umod_configfile *umod_file);
164
166 void setMassFile(const ms_masses* massFile);
167
169 const ms_masses* getMassFile() const;
170
172 void copyMassFile(const ms_masses* massFile);
173
175 std::string getTitle() const;
176
178 void setTitle(const char* value);
179
181 int getModificationType() const;
182
184 void setModificationType(const int type);
185
187 bool isHidden() const;
188
190 void setHidden(const bool value);
191
193 bool inShortList() const;
194
196 void setInShortList(const bool value);
197
199 bool inLongList() const;
200
202 void setInLongList(const bool value);
203
205 bool inErrorTolerant() const;
206
208 void setInErrorTolerant(const bool value);
209
211 bool isSubstitution() const;
212
214 double getDelta(const MASS_TYPE massType) const;
215
217 void setDelta(const double massMono, const double massAve);
218
220 ms_vectorDouble getNeutralLoss(const MASS_TYPE massType) const;
221
223 ms_vectorBool getNeutralLossRequired() const;
224
226 //std::vector< double > getNeutralLossFrequencies() const;
227
229 void setNeutralLoss(const ms_vectorDouble massMono, const ms_vectorDouble massAve, const ms_vectorBool required);
230
232 int getNumberOfModifiedResidues() const;
233
235 char getModifiedResidue(const int n) const;
236
238 bool isResidueModified(const char residue) const;
239
241 double getResidueMass(const MASS_TYPE massType, const char residue) const;
242
244 void clearModifiedResidues();
245
247 void appendModifiedResidue(const char residue, const double massMono, const double massAve);
248
250 double getNTerminusMass(const MASS_TYPE massType) const;
251
253 void setNTerminusMass(const double massMono, const double massAve);
254
256 double getCTerminusMass(const MASS_TYPE massType) const;
257
259 void setCTerminusMass(const double massMono, const double massAve);
260
262 int getNumberOfIgnoreMasses() const;
263
265 double getIgnoreMass(const MASS_TYPE massType, const int idx) const;
266
268 void clearIgnoreMasses();
269
271 void appendIgnoreMass(const double massMono, const double massAve);
272
274 ms_vectorDouble getReqPepNeutralLoss(const MASS_TYPE massType) const;
275
277 void setReqPepNeutralLoss(const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve);
278
280 ms_vectorDouble getPepNeutralLoss(const MASS_TYPE massType) const;
281
283 void setPepNeutralLoss(const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve);
284
286 bool isGeneratedMonoLinker() const;
287
289 bool isLoopLinker() const;
290
292 std::string getCode() const;
293
295 std::string getPairsWith() const;
296
298 std::string getMonoLinkTitle() const;
299
301 bool isCrossLinker() const;
302
304 void setIsCrossLinker(const bool value);
305
307 void setIsGeneratedMonoLinker(const bool value);
308
310 void setIsLoopLinker(const bool value);
311
313 int getPositionInUnimodAsNeutralLoss() const;
314
316 void setPositionInUnimodAsNeutralLoss(const int value);
317
319 void setCode(std::string code);
320
322 void setPairsWith(std::string pairsWith);
323
325 void setTitleSource(const char *unimodName, const char *specString);
326
327#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
328#include "suppress_ms_customproperty.hpp"
329#endif
330
331 private:
332 void setCustomProperty();
333
334 msparser_internal::ms_modification_impl * m_pImpl;
335 }; // ms_modification
336
338 class MS_MASCOTRESFILE_API ms_modvector
339 {
340 friend class ms_modfile;
341 public:
343 ms_modvector();
344
346 ms_modvector(const ms_modvector& src);
347
349 ms_modvector(const ms_umod_modification &src, const ms_umod_configfile &umod_file);
350
352 ~ms_modvector();
353
355 void copyFrom(const ms_modvector* right);
356
358 void copyFrom(const ms_umod_modification* right, const ms_umod_configfile *umod_file);
359
360#ifndef SWIG
362 ms_modvector& operator=(const ms_modvector& right);
363#endif
364
366 int getNumberOfModifications() const;
367
369 void clearModifications();
370
372 void appendModification(const ms_modification* item);
373
375 void appendModifications(ms_modvector &right);
376
378 const ms_modification * getModificationByNumber(const int numMod) const;
379
381 const ms_modification * getModificationByName(const std::string &name) const;
382
383 private:
384 typedef std::vector<ms_modification* > mod_vector;
385
386 mod_vector entries_;
387 }; // class ms_modvector
388
390
406 class MS_MASCOTRESFILE_API ms_modfile: public ms_errors
407 {
408 public:
410 ms_modfile();
411
413 ms_modfile(const ms_modfile& src);
414
415
417 ms_modfile(const ms_umod_configfile& src,
418 const unsigned int flags = ms_umod_configfile::MODFILE_FLAGS_ALL);
419
421 ms_modfile(const char* filename,
422 const ms_masses* massFile,
423 const bool fromSubstitutions = false,
424 const ms_connection_settings * cs = 0);
425
427 ~ms_modfile();
428
430 void defaultValues();
431
433 void copyFrom(const ms_modfile* right);
434
436 void copyFrom(const ms_umod_configfile* right,
437 const unsigned int flags = ms_umod_configfile::MODFILE_FLAGS_ALL);
438
439#ifndef SWIG
441 ms_modfile& operator=(const ms_modfile& right);
442#endif
444 void setFileName(const char* name);
445
447 std::string getFileName() const;
448
450 void setConnectionSettings(const ms_connection_settings & cs);
451
453 ms_connection_settings getConnectionSettings() const;
454
456 void setMassFile(const ms_masses* massFile);
457
459 const ms_masses* getMassFile() const;
460
462 bool isFromSubstitutions() const;
463
465 void setFromSubstitutions(const bool value);
466
468 void read_file();
469
471 void save_file();
472#ifndef SWIG
474 void saveToString(std::string & modfileAsStr);
475#else // SWIG Multiple return values
476 void saveToString(std::string & OUTPUT);
477#endif
479 void sortModifications();
480
482 int getNumberOfModifications() const;
483
485 void clearModifications();
486
488 void appendModification(const ms_modification* item);
489
491 const ms_modification * getModificationByNumber(const int numMod) const;
492
494 const ms_modification * getModificationByName(const char* nameMod) const;
495
497 bool updateModificationByNumber(const int num, const ms_modification mod);
498
500 bool updateModificationByName(const char* name, const ms_modification mod);
501
503 bool deleteModificationByNumber(const int num);
504
506 bool deleteModificationByName(const char* name);
507
508 private:
509 void read_text();
510 void save_text();
511 void applyVisibility(const ms_session *session);
512
513 typedef std::vector<ms_modification* > entries_vector;
514 entries_vector entries;
515
516 std::string filename_;
517 std::unique_ptr<ms_masses> m_massFile;
518 std::vector< std::string > comments_;
519 bool bFromSubstitutions_;
520 ms_connection_settings cs_;
521
522 }; // ms_modfile // end of config_group
524} // namespace matrix_science
525
526#endif // MS_MODFILE_HPP
527
528/*------------------------------- End of File -------------------------------*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_masses
Reads and parses the masses file with residue and atom masses.
Definition: ms_masses.hpp:48
matrix_science::ms_modfile
Use this class in order to read in the amino acid modification file.
Definition: ms_modfile.hpp:407
matrix_science::ms_modification
The class represents a single modification-entry in mod_file.
Definition: ms_modfile.hpp:134
matrix_science::ms_modvector
General usage class for creating lists of modifications to be passed as parameters.
Definition: ms_modfile.hpp:339
matrix_science::ms_session
Use this class to determine if a user is logged in and if they have 'permission' to perform tasks.
Definition: ms_security_session.hpp:123
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_modification
Represents a modif object in unimod.xml.
Definition: ms_umod_modification.hpp:47
matrix_science::MOD_TYPES
MOD_TYPES
Definition: ms_modfile.hpp:47
matrix_science::MASS_TYPE
MASS_TYPE
All possible mass types.
Definition: ms_modfile.hpp:65
matrix_science::MOD_TYPE_N_TERM
@ MOD_TYPE_N_TERM
Applies to the peptide N-terminus, independent of residue identity.
Definition: ms_modfile.hpp:49
matrix_science::MOD_TYPE_N_TERM_RESIDUE
@ MOD_TYPE_N_TERM_RESIDUE
Applies to a specific residue only when that residue is at N-terminus.
Definition: ms_modfile.hpp:53
matrix_science::MOD_TYPE_N_PROTEIN_RESIDUE
@ MOD_TYPE_N_PROTEIN_RESIDUE
Applies to a specific residue only when that residue is at N-terminus of a protein.
Definition: ms_modfile.hpp:55
matrix_science::MOD_TYPE_N_PROTEIN
@ MOD_TYPE_N_PROTEIN
Applies to the protein N-terminus, independent of residue identity.
Definition: ms_modfile.hpp:51
matrix_science::MOD_TYPE_C_TERM
@ MOD_TYPE_C_TERM
Applies to the peptide C-terminus, independent of residue identity.
Definition: ms_modfile.hpp:50
matrix_science::MOD_TYPE_C_PROTEIN_RESIDUE
@ MOD_TYPE_C_PROTEIN_RESIDUE
Applies to a specific residue only when that residue is at C-terminus of a protein.
Definition: ms_modfile.hpp:56
matrix_science::MOD_TYPE_C_PROTEIN
@ MOD_TYPE_C_PROTEIN
Applies to the protein C-terminus, independent of residue identity.
Definition: ms_modfile.hpp:52
matrix_science::MOD_TYPE_C_TERM_RESIDUE
@ MOD_TYPE_C_TERM_RESIDUE
Applies to a specific residue only when that residue is at C-terminus.
Definition: ms_modfile.hpp:54
matrix_science::MOD_TYPE_RESIDUE
@ MOD_TYPE_RESIDUE
Applies to specific residues, independent of position within the peptide.
Definition: ms_modfile.hpp:48
matrix_science::MAX_VAR_MODS
@ MAX_VAR_MODS
The results file uses 1..9 and A..W (1..32).
Definition: ms_modfile.hpp:76
matrix_science::MASS_TYPE_MONO
@ MASS_TYPE_MONO
monoisotopic mass index
Definition: ms_modfile.hpp:66
matrix_science::MASS_TYPE_AVE
@ MASS_TYPE_AVE
average mass index
Definition: ms_modfile.hpp:67
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_modinstancescount.hpp Source File

  • src
  • resfile
  • impl
ms_modinstancescount.hpp
1/*
2##############################################################################
3# file: ms_modinstancescount.hpp #
4# 'msparser' toolkit #
5# Private class for grouping proteins for ms_peptidesummary or #
6# ms_proteinsummary #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2009 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresul $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_MODINSTANCESCOUNT_HPP
21#define MS_MODINSTANCESCOUNT_HPP
22
23// Includes from the standard template library
24#include <string>
25#include <list>
26#include <vector>
27#include <set>
28#include <map>
29#include <time.h>
30#include <sstream>
31
32namespace matrix_science
33{
34 class ms_mascotresfilebase;
35}
36
37using namespace matrix_science;
38
39namespace msparser_internal {
40
41 class ms_mascotresultsbase;
42
43 struct ms_mod_instances_count
44 {
45 typedef std::map<char, int> mod_residue_count_t;
46 typedef std::map<std::pair<char, char>, int> linked_residue_count_t;
47
48 static const char mod_residue_count_NTERM;
49 static const char mod_residue_count_CTERM;
50
51 static std::string site_char_to_string(char residue) {
52 if (residue == mod_residue_count_NTERM) {
53 return "N-term";
54 } else if (residue == mod_residue_count_CTERM) {
55 return "C-term";
56 } else {
57 std::string s(1, residue);
58 return s;
59 }
60 }
61
62 ms_mod_instances_count(const ms_mascotresfilebase& resfile, ms_mascotresultsbase& results)
63 : discoveredNonSpecificCleavageNum_(-1),
64 modificationCountsLoaded_(false),
65 modificationCountsAvailable_(false),
66 resfile_(resfile),
67 results_(results)
68 {}
69
70 bool anyNumDiscoveredMods() const;
71
72 std::vector<int> getNumDiscoveredFixedMods(const int num, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
73
74 std::vector<int> getNumDiscoveredVariableMods(const int num, std::vector<std::string> &positions, std::vector<std::string> &sites, std::vector<double> &deltas, std::vector<std::string> &names) const;
75
76 std::vector<int> getNumDiscoveredIntactLinks(std::vector<int> &varModNum1,
77 std::vector<std::string> &position1,
78 std::vector<std::string> &site1,
79 std::vector<int> &varModNum2,
80 std::vector<std::string> &position2,
81 std::vector<std::string> &site2,
82 std::vector<int> &numLinkedPeptides) const;
83
84 std::vector<int> getNumDiscoveredLocalMods(const std::string modName, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
85
86 std::vector<double> getDiscoveredLocalModDeltas(std::vector<std::string> * vecDeltaStrings) const;
87
88 std::vector<int> getNumDiscoveredErrTolMods(const std::string modName, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
89
90 std::vector<std::string> getDiscoveredErrTolModNames() const;
91
92 std::vector<double> getDiscoveredErrTolModDeltas(std::vector<std::string> * vecDeltaStrings) const;
93
94 int getNumDiscoveredNonSpecCleavage() const;
95
96 std::vector<int> getNumDiscoveredLibraryMods(const int modId, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
97
98 std::vector<std::string> getDiscoveredLocalModNames() const;
99
100 std::string stringify() const;
101
102 std::vector<mod_residue_count_t> discoveredFixedMods_;
103 std::vector<mod_residue_count_t> discoveredVariableMods_;
104 std::map<std::pair<int, int>, mod_residue_count_t> discoveredMonoLinks_;
105 std::map<std::pair<int, int>, linked_residue_count_t> discoveredLoopLinks_;
106 std::map<std::pair<int, int>, linked_residue_count_t> discoveredIntactLinks_;
107 std::vector<std::string> discoveredVariableModPositionTypes_;
108 std::map<std::string, std::map<std::string, mod_residue_count_t> > discoveredLocalMods_;
109 std::vector<std::string> discoveredLocalModDeltas_;
110 std::map<std::string, std::map<std::string, mod_residue_count_t> > discoveredErrorTolerantMods_;
111 std::vector<std::string> discoveredErrorTolerantModDeltas_;
112 int discoveredNonSpecificCleavageNum_;
113 std::vector<mod_residue_count_t> discoveredLibraryMods_;
114 bool modificationCountsLoaded_;
115 bool modificationCountsAvailable_;
116
117 const ms_mascotresfilebase& resfile_;
118 ms_mascotresultsbase& results_;
119 };
120
121 std::ostream& operator<<(std::ostream& out, const ms_linker_site& s);
122
123} // msparser_internal namespace
124
125#endif // MS_MODINSTANCESCOUNT_HPP
126
127/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_average_results.hpp Source File

  • inc
ms_ms1quant_average_results.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_average_results.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_ms1quant_average_results.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_AVERAGE_RESULTS_HPP
18#define MS_MS1QUANT_AVERAGE_RESULTS_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24namespace matrix_science
25{
26 //=========================================================================
32 class ms_ms1quant_average_results_body;
33
35
40 class MS_MASCOTRESFILE_API ms_ms1quant_average_results :
41 public ms_handle
42 {
43 public:
44
46 ms_ms1quant_average_results();
47
48#ifndef SWIG
49 ms_ms1quant_average_results_body * body();
50 const ms_ms1quant_average_results_body * body() const;
51#endif
52
54 ms_ms1quant_average_results(const ms_ms1quant_average_results_body & body);
55
57 int getReferenceHitId() const;
59 int getReferenceMemberNumber() const;
61 int isReferenceUserSelected() const;
62 };
63 // end of quantitation_group
65 //=========================================================================
66
67} // namespace matrix_science
68
69#endif // MS_MS1QUANT_AVERAGE_RESULTS_HPP
70
71/*------------------------------- End of File -------------------------------*/
matrix_science::ms_ms1quant_average_results
Results specific to an 'average' type quantitation method.
Definition: ms_ms1quant_average_results.hpp:42
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_average_results_body.hpp Source File

  • src
  • resfile
ms_ms1quant_average_results_body.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_average_results_body.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram - body
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_AVERAGE_RESULTS_BODY_HPP
18#define MS_MS1QUANT_AVERAGE_RESULTS_BODY_HPP
19
20namespace matrix_science
21{
22
23 class ms_ms1quant_average_results_body :
24 public ms_body
25 {
26 public:
27 ms_ms1quant_average_results_body();
28
29 // Load data from a CDB file, extracting the cache stream and then calling loadStream.
30 // Returns true if the data stream is present and there was no error loading it (sets isDataFound to true).
31 // Returns true if the data stream is not present (sets isDataFound to false).
32 // Returns false if an error was encountered; an absent data stream is not an error.
33 bool loadFromCdb(matrix_science::ms_tinycdb & cdbFile, bool & isDataFound);
34 bool loadStream(matrix_science::ms_cache_stream & stream);
35 bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
36
37 bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
38 bool saveToCdb(matrix_science::ms_tinycdb & cdbFile);
39 bool saveToStream(matrix_science::ms_cache_stream & stream);
40
41 int referenceHitId_;
42 int referenceMemberNumber_;
43 bool isReferenceUserSelected_;
44 };
45
46} // namespace matrix_science
47
48#endif // MS_MS1QUANT_AVERAGE_RESULTS_BODY_HPP
49
50/*------------------------------- End of File -------------------------------*/
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_charge_state.hpp Source File

  • inc
ms_ms1quant_charge_state.hpp
1/*
2##############################################################################
3# file: ms_fitexy_result.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_ms1quant_charge_state.hpp $
12 * @(#)$Revision: c462f7f06ab9626f3809cf58ed4501d0305d1696 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2022-02-24 23:12:28 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_CHARGE_STATE_HPP
18#define MS_MS1QUANT_CHARGE_STATE_HPP
19
20
21namespace matrix_science
22{
23 //=========================================================================
29 class ms_ms1quant_charge_state_body;
30
32
35 class MS_MASCOTRESFILE_API ms_ms1quant_charge_state :
36 public ms_handle
37 {
38 public:
40 ms_ms1quant_charge_state();
41
43 ms_ms1quant_charge_state(const ms_ms1quant_charge_state_body & body);
44
45#ifndef SWIG
46 ms_ms1quant_charge_state_body * body();
47 const ms_ms1quant_charge_state_body * body() const;
48
50 ms_ms1quant_charge_state(const double correctSppWidthMin,
51 const double correctSppWidthMax,
52 const double correctSppWidth,
53 const double bucketWidth,
54 const double maxAlignment,
55 const double matchedRho,
56 const double matchedFraction,
57 const double totalIntensity,
58 const std::map<int, std::map<int, double>> & bucketAreas, // file_index -> scanId -> area
59 const std::vector<double> & calcMzVar, // row matrix calcmz
60 const std::vector<int> & idx2Comp
61
62 );
63#endif
64
66 double getCorrectedMinSPPwidth() const;
67
69 double getCorrectedMaxSPPwidth() const;
70
72 double getCorrectedSPPwidth() const;
73
75 double getBucketWidth() const;
76
78 double getMaxAlignment() const;
79
81 double getMatchedRho() const;
82
84 double getMatchedFraction() const;
85
87 double getTotalIntensity() const;
88
90 int getNumberOfBuckets(const int file_index = ms_quant_file_index::file_index_value_not_set) const;
91#ifndef SWIG
93 bool getBucket(int index, unsigned & scanId, double & area) const;
94
96 bool getBucket(const int file_index, int index, unsigned & scanId, double & area) const;
97#else // SWIG Multiple return values
98 bool getBucket(int index, unsigned & OUTPUT, double & OUTPUT) const;
99 bool getBucket(const int file_index, int index, unsigned & OUTPUT, double & OUTPUT) const;
100#endif
101 // \cond INTERNAL
102
104 void setCorrectedMinSPPwidth(double width);
105
107 void setCorrectedMaxSPPwidth(double width);
108
110 void setCorrectedSPPwidth(double width) ;
111
113 void setBucketWidth(double width);
114
116 void setMaxAlignment(double alignemnt);
117
119 void setMatchedRho(double rho);
120
122 void setMatchedFraction(double fraction);
123
125 void setTotalIntensity(double intensity);
126
128 std::vector<double> & getCalcMz();
129
131 const std::vector<double> & getCalcMz() const;
132
134 std::vector<int> & getIdx2Comp();
135
137 int getIdx2Comp(std::size_t index) const;
138
140 std::map<int, double> & getBucketAreas(const int file_index = ms_quant_file_index::file_index_value_not_set);
141
142 // \endcond
143 };
144 // end of quantitation_group
146 //=========================================================================
147
148} // namespace matrix_science
149
150#endif // MS_MS1QUANT_CHARGE_STATE_HPP
151
152/*------------------------------- End of File -------------------------------*/
matrix_science::ms_ms1quant_charge_state
A result from a charge state calculation.
Definition: ms_ms1quant_charge_state.hpp:37
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_charge_state_body.hpp Source File

  • src
  • resfile
ms_ms1quant_charge_state_body.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_charge_state_body.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_CHARGE_STATE_BODY_HPP
18#define MS_MS1QUANT_CHARGE_STATE_BODY_HPP
19
20#include <map>
21
22namespace matrix_science
23{
24 class ms_ms1quant_charge_state_body :
25 public ms_body
26 {
27 public:
28 double correctSppWidthMin_;
29 double correctSppWidthMax_;
30 double correctSppWidth_;
31 double bucketWidth_;
32 double maxAlignment_;
33 double matchedRho_;
34 double matchedFraction_;
35 double totalIntensity_;
36 typedef std::map<int, double> bucketAreasSingleFile_t; // scanId -> area
37 typedef std::map<int, bucketAreasSingleFile_t> bucketAreas_t; // file_index -> scanId -> area
38 bucketAreas_t bucketAreas_; // file_index -> scanId -> area
39 std::vector<double> calcMzVar_; // Saved as a matrix in the xml/cdb, but it's only ever one column
40 std::vector<int> idx2comp_;
41
42 ms_ms1quant_charge_state_body();
43
44 bool loadStream(matrix_science::ms_cache_stream & stream);
45 bool loadCache(matrix_science::ms_cache_stream & stream);
46 bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
47
48 bool saveToStream(matrix_science::ms_cache_stream & stream) const;
49 bool saveCacheToStream(matrix_science::ms_cache_stream & stream) const;
50 bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, bool completeReport) const;
51 };
52}
53
54#endif // MS_MS1QUANT_CHARGE_STATE_BODY_HPP
55
56/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match.hpp Source File

  • inc
ms_ms1quant_match.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_match.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_ms1quant_match.hpp $
12 * @(#)$Revision: 13df8a1acb577c00eb17a154317b079d156f9538 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2022-01-05 16:48:40 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_MATCH_HPP
18#define MS_MS1QUANT_MATCH_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24namespace matrix_science
25{
26 //=========================================================================
32 class ms_ms1quant_match_body;
33 class ms_protein;
34 class ms_peptide;
35 class ms_quant_component;
36
38
45 class MS_MASCOTRESFILE_API ms_ms1quant_match :
46 public ms_handle
47 {
48 public:
50
53 enum chargeType
54 {
55 CHARGETYPE_ORIGINAL,
56 CHARGETYPE_ALL
57 };
58
60 static std::string getXmlCode(chargeType code);
61
63 static chargeType getCodeFromXml(std::string text);
64
66 ms_ms1quant_match();
67
69 ms_ms1quant_match(const ms_ms1quant_match_body & body);
70
71#ifndef SWIG
73 ms_ms1quant_match_body * body();
75 const ms_ms1quant_match_body * body() const;
76
78 bool addProteinHit(const int hit, const int member);
80 void setKey(const int id);
82 void applyThresholds();
83#endif
84
86 matrix_science::ms_peptide_quant_key getKey() const;
87
89 bool hasIdentifiedComponent() const;
90
92 bool allComponentsIdentified() const;
93
95 std::string getPeptideString() const;
96
98 std::string getVarMods() const;
99
101 int getFirstXicScanId() const;
102
104 void setFirstXicScanId(int value) ;
105
107 int getLastXicScanId() const;
108
110 void setLastXicScanId(int value) ;
111
113 double getDisplayIntensity() const;
114
116 void setDisplayIntensity(double value);
117
119 int getChargeState() const;
120
122 chargeType getChargeType() const;
123
125 std::string getLabelFreeVarMods() const;
126
128 std::string getReadableLabelFreeVarMods() const;
129
131 std::string getConciseLabelFreeVarMods() const;
132
134 int getDataSourceId() const;
135
137 const ms_matrix & getCorrectionMatrix() const;
138
139#if !defined(SWIGJAVA) && !defined(SWIGCSHARP)
141 ms_matrix & getCorrectionMatrix();
142#endif
144 const ms_matrix & getPerfectObservedMatrix() const;
145
146#if !defined(SWIGJAVA) && !defined(SWIGCSHARP)
148 ms_matrix & getPerfectObservedMatrix();
149#endif
151 const ms_matrix & getPredictionMatrix() const;
152
153#if !defined(SWIGJAVA) && !defined(SWIGCSHARP)
155 ms_matrix & getPredictionMatrix();
156#endif
158 int getNumHits() const;
160 const ms_protein * getHit(int index1) const;
161
163 int getNumComponents() const;
165 ms_ms1quant_match_component getComponent(int index) const;
166
168 bool hasComponent(std::string componentName) const;
170 ms_ms1quant_match_component getComponent(std::string componentName) const;
171
172 ms_ms1quant_match_component * addCreatedComponent(
173 const matrix_science::ms_peptide & peptide,
174 const matrix_science::ms_quant_component & component,
175 const int file_index = matrix_science::ms_quant_file_index::file_index_value_not_set);
176
177 ms_ms1quant_match_component * addCreatedComponent(const std::string & componentName);
178
180 ms_ms1quant_match_component * addCreatedComponent(
181 const matrix_science::ms_ms1quant_match_component & component);
182
184 ms_ms1quant_match_component * addComponent(const matrix_science::ms_ms1quant_match_component & component);
185
187 bool removeComponent(const std::string & componentName);
188
189 ms_ms1quant_match_component * addIdentifiedComponent(
190 const matrix_science::ms_peptide & peptide,
191 const matrix_science::ms_quant_component & component,
192 const int file_index = matrix_science::ms_quant_file_index::file_index_value_not_set);
193
195 int getNumPeptideRatios() const;
197 ms_ms1quant_match_ratio getPeptideRatio(int index) const;
198
200 bool hasPeptideRatio(const std::string & ratioName) const;
202 ms_ms1quant_match_ratio getPeptideRatio(const std::string & ratioName) const;
204 void setPeptideRatio(const std::string & ratioName, const ms_ms1quant_match_ratio & ratio);
205
207 ms_ms1quant_charge_state getChargeStateData() const;
209 void setChargeStateData(const ms_ms1quant_charge_state & csData);
210
212 bool isHitRatioOutlier(const std::string & ratioName, int hitId, int memberNumber) const;
214 bool isHitRatioUsedForAverage(const std::string & ratioName, int hitId, int memberNumber) const;
216 bool isHitRatioExcluded(const std::string & ratioName, int hitId, int memberNumber) const;
217
219 void setHitRatioExcluded(const std::string & ratioName, int hitId, int memberNumber);
220
222 void clearHitRatioExcluded(const std::string & ratioName, int hitId, int memberNumber);
223
225 void setHitRatioOutlier(const std::string & ratioName, int hitId, int memberNumber);
226
228 void clearHitRatioOutlier(const std::string & ratioName, int hitId, int memberNumber);
229 };
230
231 // end of quantitation_group
233 //=========================================================================
234
235} // namespace matrix_science
236
237#endif // MS_MS1QUANT_MATCH_HPP
238
239/*------------------------------- End of File -------------------------------*/
matrix_science::ms_matrix
A two-dimensional matrix of numbers.
Definition: ms_matrix.hpp:36
matrix_science::ms_ms1quant_charge_state
A result from a charge state calculation.
Definition: ms_ms1quant_charge_state.hpp:37
matrix_science::ms_ms1quant_match_component
A component within a match.
Definition: ms_ms1quant_match_component.hpp:40
matrix_science::ms_ms1quant_match_ratio
The status resulting ratio for a peptide found in a match.
Definition: ms_ms1quant_match_ratio.hpp:43
matrix_science::ms_ms1quant_match
A peptide that has been matched, in quantitation, to a protein hit.
Definition: ms_ms1quant_match.hpp:47
matrix_science::ms_ms1quant_match::chargeType
chargeType
Types of charge state used when matching.
Definition: ms_ms1quant_match.hpp:54
matrix_science::ms_ms1quant_match::CHARGETYPE_ORIGINAL
@ CHARGETYPE_ORIGINAL
Charge state found in result file.
Definition: ms_ms1quant_match.hpp:55
matrix_science::ms_peptide_quant_key
Feature key identifying a peptide ratio.
Definition: ms_peptide_quant_key.hpp:69
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_file_index::file_index_value_not_set
static const int file_index_value_not_set
A file_index value is a 1 based number. In cases where file_index values are not used (e....
Definition: ms_quant_file_index.hpp:112
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match_body.hpp Source File

  • src
  • resfile
ms_ms1quant_match_body.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_match_body.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram - body
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_MATCH_BODY_HPP
18#define MS_MS1QUANT_MATCH_BODY_HPP
19
20// Includes from the standard template library
21#include <string>
22#include <map>
23#include <set>
24
25namespace matrix_science
26{
27 class ms_ms1quantitation;
28 class ms_mascotresfilebase;
29
30 class MS_PARSERINTERNAL_API ms_ms1quant_match_body :
31 public ms_body
32 {
33 public:
34 typedef std::pair<int, int> Hitkey; // hitId, memberNumber (from file, may be different to peptide summary)
35 typedef std::map<Hitkey, Hitkey> HitkeyMap; // map hitkey from the one loaded to the one in the peptide summary (and is actually used)
36 typedef std::set<Hitkey> HitkeySet;
37 typedef std::map<std::string, HitkeySet> ratioHitkeySetMap;
38 typedef std::map<std::string, Hitkey> AccessionLookup; // key = accession, Hitkey = hit/member from peptide summary
39
40 static std::string HitKeyString(const Hitkey & hitkey);
41
42 ms_ms1quant_match_body(ms_ms1quantitation & result);
43 ms_ms1quant_match_body(const ms_ms1quant_match_body & sibling, int newCharge);
44 ms_ms1quant_match_body(const ms_ms1quant_match_body & source, ms_ms1quantitation & result, const matrix_science::ms_mascotresfilebase& resfile, int matchID, int dataSourceID, bool queryNumsAreFromMerged);
45
46
47
48 const ms_ms1quant_match_ratio * getPeptideRatio(const std::string & ratioName) const;
49 const ms_ms1quant_match_component * getComponent(const std::string & componentName) const;
50 // validate the quant match
51 void applyThresholds();
52
53 // Load data from a CDB file, extracting the cache stream and then calling loadStream
54 bool loadFromCdb(matrix_science::ms_tinycdb & cdbFile, size_t iMatch, matrix_science::ms_cache_file & cacheFile, const ms_ms1quant_match_body::HitkeyMap & hitkeyMap);
55 // Load data from a cache stream.
56 bool loadStream(matrix_science::ms_cache_stream & stream, matrix_science::ms_cache_file & cacheFile, const ms_ms1quant_match_body::HitkeyMap & hitkeyMap);
57 // load cache data (from the cache file, not the CDB)
58 bool loadCacheMatrix(matrix_science::ms_matrix & matrix, matrix_science::ms_cache_stream & stream);
59 // Load data from a CDB file, extracting the cache stream and then calling loadStream
60 bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const ms_ms1quant_match_body::HitkeyMap & hitkeyMap);
61
62 bool saveToCdb(matrix_science::ms_tinycdb & cdbFile, matrix_science::ms_cache_file & cacheFile, bool createEmptyMissingComponents = false) const;
63 bool saveCacheToStream(matrix_science::ms_cache_stream & stream) const;
64 bool saveCacheMatrix(const matrix_science::ms_matrix & matrix, matrix_science::ms_cache_stream & stream) const;
65 bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, bool processSeparately, bool completeReport, const std::map<std::string, double> & normalisationBaseValues) const;
66
67 ms_ms1quantitation & result_;
68
69 bool isCacheLoaded_; // when loaded from the cache file this is set, false if not currently loaded
70
71 int matchId_; // when loaded from CDB this is the index 0..n-1
72 mutable INT64 cacheStreamId_; // may change when saved to stream
73 int dataSourceID_;
74 int firstXicScanId_;
75 int lastXicScanId_;
76 double displayIntensity_;
77 int charge_;
78 ms_ms1quant_match::chargeType chargeType_;
79 ms_ms1quant_charge_state chargeState_;
80 std::string peptideString_;
81 std::string labelFreeVarmods_;
82 std::string readableLabelFreeMods_;
83 std::string conciseLabelFreeMods_;
84
85 ms_matrix matA_;
86 ms_matrix matPerfect_;
87 ms_matrix matPredicted_;
88 std::list<ms_ms1quant_match_component> components_;
89 std::map<std::string, matrix_science::ms_ms1quant_match_ratio> ratios_; // key is ratio name
90
91 std::set<Hitkey> matchHitkeys_;
92
93 ratioHitkeySetMap outlierRatioHitkeys_;
94 ratioHitkeySetMap usedForAverageRatioHitkeys_;
95 ratioHitkeySetMap excludeRatioHitkeys_;
96
97 bool isHitRatioSet(const ms_ms1quant_match_body::ratioHitkeySetMap & map, Hitkey hitkey, const std::string & ratioName) const;
98 void setHitRatioSet(ms_ms1quant_match_body::ratioHitkeySetMap * map, Hitkey hitkey, const std::string & ratioName);
99 void clearHitRatioSet(ms_ms1quant_match_body::ratioHitkeySetMap * map, Hitkey hitkey, const std::string & ratioName);
100
101 ms_ms1quant_match_component * insertComponent(const ms_ms1quant_match_component_body & body);
102
103 bool removeComponent(const std::string & componentName);
104
106 bool isMatchInferred() const;
107 private:
108 bool saveToStream(matrix_science::ms_cache_stream & stream, bool createEmptyMissingComponents) const;
109 bool saveToCache(matrix_science::ms_cache_file & cacheFile) const;
110 bool convertHitkey(Hitkey * key, const HitkeyMap & map);
111 };
112
113} // namespace matrix_science
114
115#endif // MS_MS1QUANT_MATCH_BODY_HPP
116
117/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_matrix
A two-dimensional matrix of numbers.
Definition: ms_matrix.hpp:36
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match_component.hpp Source File

  • inc
ms_ms1quant_match_component.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_match_component.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_ms1quant_match_component.hpp $
12 * @(#)$Revision: 81909fd23cef6d5183470d1ca2d9a4677bb0f755 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2022-03-28 14:50:02 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_MATCH_COMPONENT_HPP
18#define MS_MS1QUANT_MATCH_COMPONENT_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24namespace matrix_science
25{
26 //=========================================================================
32 class ms_ms1quant_match_component_body;
33
35
38 class MS_MASCOTRESFILE_API ms_ms1quant_match_component :
39 public ms_handle
40 {
41 public:
43 ms_ms1quant_match_component();
44
46 ms_ms1quant_match_component(const ms_ms1quant_match_component_body & body);
47
48#ifndef SWIG
50 ms_ms1quant_match_component_body * body();
52 const ms_ms1quant_match_component_body * body() const;
53#endif
54
56 std::string getComponent() const;
57
59 int getNumFileIndexesMatched() const;
60
62 int getFileIndex(const int idx) const;
63
65 bool isComponentIdentified(const int file_index = -1) const;
66
68 double getRelativeMass() const;
69
71 double getMoverz() const;
72
74 std::string getVarModsStr() const;
75
77 std::string getSummedModsStr() const;
78
80 bool hasAbsoluteValue(const int file_index = -1) const;
81
83 double getAbsoluteValue(const int file_index = -1) const;
84
86 void setAbsoluteValue(double value);
87
89 void setAbsoluteValue(const int file_index, double value);
90
92 bool hasMatchedRho(const int file_index = -1) const;
93
95 double getMatchedRho(const int file_index = -1) const;
96
98 void setMatchedRho(const int file_index, double value);
99
101 bool hasMatchedFraction(const int file_index = -1) const;
102
104 double getMatchedFraction(const int file_index = -1) const;
105
107 void setMatchedFraction(const int file_index, double value);
108
109
111 ms_xic getXic(const int file_index = ms_quant_file_index::file_index_value_not_set) const;
112
114 ms_xic * getXicPtr(const int file_index = ms_quant_file_index::file_index_value_not_set);
115
117 int getNumRanges(const int file_index = ms_quant_file_index::file_index_value_not_set) const;
118
120 ms_ms1quant_match_range getRange(int index) const;
121
123 ms_ms1quant_match_range getRange(const int file_index, int index) const;
124
125 void setRanges(std::vector<ms_ms1quant_match_range> ranges);
126 void setRanges(const int file_index, std::vector<ms_ms1quant_match_range> ranges);
127
129 int getNumPeptides(const int file_index = ms_quant_file_index::file_index_value_not_set) const;
130#ifndef SWIG
132 void getPeptideKey(int index, int & q, int & p) const;
133
135 void getPeptideKey(const int file_index, int index, int & q, int & p) const;
136
138 void removePeptide(const int file_index, const int q, const int p);
139#else // SWIG Multiple return values
140 void getPeptideKey(int index, int & OUTPUT, int & OUTPUT) const;
141 void getPeptideKey(const int file_index, int index, int & OUTPUT, int & OUTPUT) const;
142#endif
143 protected:
145 std::size_t getIdxFromFileIndex(const int file_index) const;
146 };
147 // end of quantitation_group
149 //=========================================================================
150
151} // namespace matrix_science
152
153#ifndef SWIG
154namespace msparser_internal
155{
156 MS_PARSERINTERNAL_API double calcRelMassFromMz(double mz, long charge);
157 MS_PARSERINTERNAL_API double calcMzFromRelMass(double mr, long charge);
158}
159#endif
160
161#endif // MS_MS1QUANT_MATCH_COMPONENT_HPP
162
163/*------------------------------- End of File -------------------------------*/
matrix_science::ms_ms1quant_match_component
A component within a match.
Definition: ms_ms1quant_match_component.hpp:40
matrix_science::ms_ms1quant_match_range
A range for a component of a peptide match.
Definition: ms_ms1quant_match_range.hpp:37
matrix_science::ms_xic
An eXtracted Ion Chromatogram (XIC).
Definition: ms_xic.hpp:69
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match_component_body.hpp Source File

  • src
  • resfile
ms_ms1quant_match_component_body.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_match_component_body.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_MATCH_COMPONENT_BODY_HPP
18#define MS_MS1QUANT_MATCH_COMPONENT_BODY_HPP
19
20
21// Define this to save CDB files compatible with Distiller 2.5.1 (which are then saved in project files).
22// Commented this out as part of Bug 13354. Files produced with this commented out are compatible with Distiller 2.6 and later
23// #define SAVE_CDB_DISTILLER_2_5_1
24
25// See bug 13355
26// #define SAVE_CDB_DISTILLER_2_7_1
27
28
29// Includes from the standard template library
30#include <string>
31
32namespace matrix_science
33{
34 class ms_peptide_quant_key;
35 class ms_ms1quantitation;
36 class ms_quant_component;
37 class ms_peptide;
38
39 class ms_ms1quant_match_component_body :
40 public matrix_science::ms_body
41 {
42 public:
43 enum ORIGIN
44 {
45 origin_none,
46 origin_identified,
47 origin_created,
48 };
49
50 // For multiple file_index values per component, the following are the same for each match_component
51 std::string component_;
52 double mrcalc_;
53 double moverz_;
54 std::string varModsStr_;
55 std::string summedModsStr_;
56
57 // For multiple file_index values per component, the following are different for each file_index in the match_component
58 typedef struct perFileIndex {
59 bool hasAbsoluteValue_;
60 double absoluteValue_;
61 bool hasMatchedRho_;
62 double matchedRho_;
63 bool hasMatchedFraction_;
64 double matchedFraction_;
65 ORIGIN origin_; // file_index => ORIGIN
66 int file_index_;
67 std::vector<ms_ms1quant_match_range> ranges_;
68 std::set<matrix_science::ms_peptide_quant_key> componentPeptides_;
69 ms_xic xic_;
70
71 perFileIndex()
72 : hasAbsoluteValue_(false)
73 , absoluteValue_(0)
74 , hasMatchedRho_(false)
75 , matchedRho_(0)
76 , hasMatchedFraction_(false)
77 , matchedFraction_(0)
78 , origin_(origin_none)
79 , file_index_(ms_quant_file_index::file_index_value_not_set)
80 {}
81 } perFileIndex;
82 std::vector<perFileIndex> perFileIndex_;
83 mutable std::map<int, std::size_t> file_index_toIdx_;
84
85 ms_ms1quant_match_component_body();
86
87 ms_ms1quant_match_component_body(const matrix_science::ms_quant_component & component, const matrix_science::ms_peptide & peptide, ORIGIN origin, const int file_index);
88 ms_ms1quant_match_component_body(const matrix_science::ms_ms1quant_match_component & component, int newCharge);
89
90 void deepCopy(const ms_ms1quant_match_component_body & src);
91
92 bool loadStream(
93 matrix_science::ms_cache_stream & stream,
94 matrix_science::ms_cache_file & cacheFile,
95 int charge,
96 unsigned int file_idx);
97 bool loadFromXml(
98 msparser_internal::ms_XMLHelper & helper,
99 msparser_internal::ms_XMLElement & element,
100 int charge,
101 matrix_science::ms_ms1quantitation & result);
102
103 void updateMoverZ(int newCharge);
104
105 bool saveToStream(matrix_science::ms_cache_stream & stream, const int index) const;
106 bool saveToCache(matrix_science::ms_cache_file & cacheFile, const int index) const;
107 bool saveToXml(msparser_internal::ms_XMLHelper & helper,
108 msparser_internal::ms_XMLElement & element,
109 const std::string & peptideString,
110 const std::string & labelFreeVarMods,
111 const int index,
112 bool processSeparately,
113 bool completeReport,
114 const std::string & overrideComponent,
115 const matrix_science::ms_ms1quantitation & ms1quantitation) const;
116 std::size_t getIdxFromFileIndex(const int file_index) const;
117 bool mergeFromAnotherFileIndex(const ms_ms1quant_match_component_body & mergeFrom,
118 ms_errs * errs);
119 };
120
121} // namespace matrix_science
122
123#endif // MS_MS1QUANT_MATCH_COMPONENT_BODY_HPP
124
125/*------------------------------- End of File -------------------------------*/
matrix_science::ms_ms1quant_match_component
A component within a match.
Definition: ms_ms1quant_match_component.hpp:40
matrix_science::ms_ms1quantitation
The result of quantitation calculations applied to peptide summary.
Definition: ms_ms1quantitation.hpp:92
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match_range.hpp Source File

  • inc
ms_ms1quant_match_range.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_match_range.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_ms1quant_match_range.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_MATCH_RANGE_HPP
18#define MS_MS1QUANT_MATCH_RANGE_HPP
19
20
21namespace matrix_science
22{
23 //=========================================================================
29 class ms_ms1quant_match_range_body;
30
32
35 class MS_MASCOTRESFILE_API ms_ms1quant_match_range :
36 public ms_handle
37 {
38 public:
40 ms_ms1quant_match_range();
41
43 ms_ms1quant_match_range(const ms_ms1quant_match_range_body & body);
44
46 ms_ms1quant_match_range(int scanId, double rt);
47
49 void extend(int scanId, double rt);
50
51#ifndef SWIG
52 ms_ms1quant_match_range_body * body();
53 const ms_ms1quant_match_range_body * body() const;
54#endif
55#ifndef SWIG
57 void getRt(double & start, double & end) const;
58
60 void getScan(int & start, int & end) const;
61#else // SWIG Multiple return values
62 void getRt(double & OUTPUT, double & OUTPUT) const;
63 void getScan(int & OUTPUT, int & OUTPUT) const;
64#endif
65 };
66 // end of quantitation_group
68 //=========================================================================
69
70} // namespace matrix_science
71
72#endif // MS_MS1QUANT_MATCH_RANGE_HPP
73
74/*------------------------------- End of File -------------------------------*/
matrix_science::ms_ms1quant_match_range
A range for a component of a peptide match.
Definition: ms_ms1quant_match_range.hpp:37
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match_range_body.hpp Source File

  • src
  • resfile
ms_ms1quant_match_range_body.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_match_range_body.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_MATCH_RANGE_BODY_HPP
18#define MS_MS1QUANT_MATCH_RANGE_BODY_HPP
19
20// Includes from the standard template library
21#include <string>
22
23namespace matrix_science
24{
25
26 class ms_ms1quant_match_range_body :
27 public matrix_science::ms_body
28 {
29 public:
30 bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element) const;
31
32 double rtStart_;
33 double rtFinish_;
34 int scanStart_;
35 int scanFinish_;
36 };
37
38} // namespace matrix_science
39
40#endif // MS_MS1QUANT_MATCH_RANGE_BODY_HPP
41
42/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match_ratio.hpp Source File

  • inc
ms_ms1quant_match_ratio.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_match_ratio.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_ms1quant_match_ratio.hpp $
12 * @(#)$Revision: 8e4151b262f3acce03627aeb892da3923c8383b8 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2021-06-15 17:07:47 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_MATCH_RATIO_HPP
18#define MS_MS1QUANT_MATCH_RATIO_HPP
19
20
21// Includes from the standard template library
22#include <string>
23#include <vector>
24
25namespace matrix_science
26{
27 //=========================================================================
33 class ms_ms1quant_match_ratio_body;
34 class ms_quant_method;
35 class ms_fitexy_result;
36
38
41 class MS_MASCOTRESFILE_API ms_ms1quant_match_ratio :
42 public ms_handle
43 {
44 public:
46
55 enum ratioStatusCode
56 {
57 RS_EMPTY = 0,
58 RS_OK = 1,
59 RS_ISOLATEDPRECURSORFAILED = 2,
60 RS_INTEFERENCEFAILED = 4,
61 RS_NODATA = 8,
62 RS_FITEXYSIGMA = 16,
63 RS_NEGATIVERATIO = 32,
64 RS_INFINITERATIO = 64,
65 RS_ZERORATIO = 128,
66 RS_DO_NOT_USE = 256,
67 RS_TOTALINTENSITYFAILED = 512,
68 RS_VALID_FLAGS = RS_OK | RS_ISOLATEDPRECURSORFAILED | RS_INTEFERENCEFAILED | RS_NODATA | RS_FITEXYSIGMA | RS_NEGATIVERATIO | RS_INFINITERATIO | RS_ZERORATIO | RS_TOTALINTENSITYFAILED
69 };
70
72 static std::string getXmlCode(ratioStatusCode code);
73
75 static ratioStatusCode getCodeFromXml(std::string text);
76
78 static bool getCodeInfo(ratioStatusCode code, const ms_quant_method & method, double & info);
79
81 ms_ms1quant_match_ratio();
82
84 ms_ms1quant_match_ratio(const ms_ms1quant_match_ratio_body & body);
85
87 std::string getRatioName() const;
88
90 bool isSet() const;
91
93 double getValue() const;
94
96 double getQuality() const;
97
99 bool isValid() const;
100
102 bool isUsedForAverage() const;
103
105 bool isIncluded() const;
106
108 bool getFitexy(ms_fitexy_result & value) const;
109
111 int getStatus() const;
112
114 std::vector<ratioStatusCode> getStatusList() const;
115
116#ifndef SWIG
118 ms_ms1quant_match_ratio_body * body();
120 const ms_ms1quant_match_ratio_body * body() const;
122 void setStatus(const int status);
124 void setValid(const bool valid);
126 void setInclude(const bool include);
128 void setFitexy(const ms_fitexy_result & value);
130 void setValue(const std::string & ratioName, double value, double quality, bool usedForAverage, bool include);
131#endif
132 };
133 // end of quantitation_group
135 //=========================================================================
136
137} // namespace matrix_science
138
139#endif // MS_MS1QUANT_MATCH_RATIO_HPP
140
141/*------------------------------- End of File -------------------------------*/
matrix_science::ms_fitexy_result
Parameters and results from least squares fit with errors in both co-ordinates.
Definition: ms_fitexy_result.hpp:40
matrix_science::ms_ms1quant_match_ratio
The status resulting ratio for a peptide found in a match.
Definition: ms_ms1quant_match_ratio.hpp:43
matrix_science::ms_ms1quant_match_ratio::ratioStatusCode
ratioStatusCode
Status codes from fitting ratios.
Definition: ms_ms1quant_match_ratio.hpp:56
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_match_ratio_body.hpp Source File

  • src
  • resfile
ms_ms1quant_match_ratio_body.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_match_ratio_body.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram - body
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_MATCH_RATIO_BODY_HPP
18#define MS_MS1QUANT_MATCH_RATIO_BODY_HPP
19
20// Includes from the standard template library
21#include <string>
22
23namespace matrix_science
24{
25
26 class MS_PARSERINTERNAL_API ms_ms1quant_match_ratio_body :
27 public ms_body
28 {
29 public:
30 static bool loadRatioStatesFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, int * returnStates, bool * outlier);
31
32 ms_ms1quant_match_ratio_body();
33
34 // Load data from a cache stream.
35 bool loadStream(matrix_science::ms_cache_stream & stream);
36 bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
37
38 bool saveToStream(matrix_science::ms_cache_stream & stream) const;
39 bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const matrix_science::ms_quant_method & method, bool includeFitexy, bool outlier, const std::map<std::string, double> & normalisationBaseValues) const;
40
41 std::string ratioName_;
42
43 bool valid_;
44 bool set_;
45 bool include_;
46 bool usedForAverage_;
47 double quality_;
48 double value_;
49 int status_;
50 bool hasFitexy_;
51 ms_fitexy_result fitexy_;
52 };
53
54} // namespace matrix_science
55
56#endif // MS_MS1QUANT_MATCH_RATIO_BODY_HPP
57
58/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_peptide_status.hpp Source File

  • inc
ms_ms1quant_peptide_status.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_peptide_status.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_ms1quant_peptide_status.hpp $
12 * @(#)$Revision: 2dcc5a5c97c2ef1f6d52f0f45adbf5cbce43ce2e | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2022-01-10 16:56:39 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_PEPTIDE_STATUS_HPP
18#define MS_MS1QUANT_PEPTIDE_STATUS_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24namespace matrix_science
25{
26 //=========================================================================
32 class ms_ms1quant_peptide_status_body;
33 class ms_peptide;
34
36
39 class MS_MASCOTRESFILE_API ms_ms1quant_peptide_status :
40 public ms_handle
41 {
42 public:
44
47 enum peptideStatus
48 {
49 PS_OK = 0,
50 PS_EXPECTGREATERTHAN = 1,
51 PS_LESSTHANIDENTITY = 2,
52 PS_MINCHARGE = 3,
53 PS_NOTUNIQUE = 4,
54 PS_SCORELESSHOMOLOGY = 5,
55 PS_SCORELESSIDENTITY_NOHOMO = 6,
56 PS_SCORELESSTHRESHOLD = 7,
57 PS_EXCLUDE_LOCALDEF = 8,
58 PS_EXCLUDE_MODFILE = 9,
59 PS_EXCLUDE_UNMODIFIED = 10,
60 PS_NOTPARTOFQUANTITATION = 11,
61 PS_DUPLICATESAMEQUERY = 12,
62 PS_NOMATCHINTHISFRACTION = 13,
63 PS_MAX = 14
64 };
65
67 static std::string getXmlCode(peptideStatus code);
68
70 static peptideStatus getCodeFromXml(std::string str);
71
73 ms_ms1quant_peptide_status();
74
76 ms_ms1quant_peptide_status(const ms_ms1quant_peptide_status_body & body);
77
79 int getQuery() const;
80
82 int getRank() const;
83
85 std::string getComponent() const;
86
88 peptideStatus getStatus() const;
89
90#ifndef SWIG
92 ms_ms1quant_peptide_status(
93 int query,
94 int rank,
95 const std::string & component,
96 ms_ms1quant_peptide_status::peptideStatus status);
98 ms_ms1quant_peptide_status_body * body();
100 const ms_ms1quant_peptide_status_body * body() const;
102 void setStatus(const peptideStatus status);
103#endif
104 };
105 // end of quantitation_group
107 //=========================================================================
108
109} // namespace matrix_science
110
111#endif // MS_MS1QUANT_PEPTIDE_STATUS_HPP
112
113/*------------------------------- End of File -------------------------------*/
matrix_science::ms_ms1quant_peptide_status
An individual peptide's quantitation status.
Definition: ms_ms1quant_peptide_status.hpp:41
matrix_science::ms_ms1quant_peptide_status::peptideStatus
peptideStatus
Status codes from fitting peptides.
Definition: ms_ms1quant_peptide_status.hpp:48
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_peptide_status_body.hpp Source File

  • src
  • resfile
ms_ms1quant_peptide_status_body.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_peptide_status_body.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram - body
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_PEPTIDE_STATUS_BODY_HPP
18#define MS_MS1QUANT_PEPTIDE_STATUS_BODY_HPP
19
20// Includes from the standard template library
21#include <string>
22
23namespace matrix_science
24{
25 class ms_peptidesummary;
26
27 class ms_ms1quant_peptide_status_body :
28 public ms_body
29 {
30 public:
31 static bool greater ( const ms_ms1quant_peptide_status_body & elem1, const ms_ms1quant_peptide_status_body & elem2 );
32
33 int query_;
34 int rank_;
35 std::string component_;
36 ms_ms1quant_peptide_status::peptideStatus status_;
37
38 ms_ms1quant_peptide_status_body();
39
40 // Load data from a cache stream.
41 bool loadStream(matrix_science::ms_cache_stream & stream);
42 // Load data from an XML element.
43 bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
44
45 bool saveToStream(matrix_science::ms_cache_stream & stream);
46 bool saveHitToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const matrix_science::ms_peptidesummary & peptideSummary);
47 };
48
49} // namespace matrix_science
50
51#endif // MS_MS1QUANT_PEPTIDE_STATUS_BODY_HPP
52
53/*------------------------------- End of File -------------------------------*/
matrix_science::ms_ms1quant_peptide_status::peptideStatus
peptideStatus
Status codes from fitting peptides.
Definition: ms_ms1quant_peptide_status.hpp:48
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_time_align.hpp Source File

  • inc
ms_ms1quant_time_align.hpp
1/*
2##############################################################################
3# File: ms_ms1quant_time_align.hpp #
4# Mascot Parser toolkit #
5# Class for accessing the time alignemnt data produced by Distiller for LFQ #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2022 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source: parser/inc/ms_ms1quant_time_align.hpp $
12# $Author: dcreasy@matrixscience.com $
13# $Date: 2024-08-06 14:56:24 +0100 $
14# $Revision: b7e8d5f901bc33b9cf963dd992cadbcca121a891 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
15##############################################################################
16*/
17
18#ifndef MS_MS1QUANT_TIME_ALIGN_HPP
19#define MS_MS1QUANT_TIME_ALIGN_HPP
20
21
22// Includes from the standard template library
23#include <string>
24
25namespace matrix_science
26{
27 //=========================================================================
33 class ms_ms1quant_time_align_body;
34
36
45 class MS_MASCOTRESFILE_API ms_ms1quant_time_align :
46 public ms_handle, public ms_errors
47 {
48 public:
52 enum status_t {
53 ST_TA_NO_DATA,
54 ST_TA_LOADED_FROM_XML,
55 ST_TA_LOADED_FROM_CDB,
56 ST_TA_CALCULATED
57 };
58
60 ms_ms1quant_time_align(const int binSize = 12);
61
63 ms_ms1quant_time_align(const ms_ms1quant_time_align_body & body);
64
66 bool loadXmlFile(const std::string & xmlFilename, const std::string & schemaDirectory);
67
69 bool saveXmlFile(const std::string & xmlFilename, const std::string & schemaDirectory) const;
70
72 double getRToffset(const int myProjectId, const int otherProjectId, const double rtInOtherProject, const double mOverZ) const;
73
75 double getEstimatedFeatureWidth(const int subProjectId, const double mOverZ, const double rt) const;
76
77#ifndef SWIG
79 ms_ms1quant_time_align_limits & getCombinedLimits(const int fractionNum);
80#endif
81
83 ms_ms1quant_time_align_limits getCombinedLimits(const int fractionNum) const;
84
86 int getBinSize() const;
87
88#ifndef SWIG
90 std::vector<std::vector<std::vector<double>>> & getFinalResults();
91
93 std::vector<std::vector<std::vector<double>>>& getShiftsToConsensus();
94
96 std::vector<std::vector<std::vector<double>>>& getShiftsFromConsensus();
97#endif
99 const std::vector<std::vector<std::vector<double>>> & getFinalResults() const;
100
102 const std::vector<std::vector<std::vector<double>>>& getShiftsToConsensus() const;
103
105 const std::vector<std::vector<std::vector<double>>>& getShiftsFromConsensus() const;
106
108 typedef std::vector<std::vector<std::map<double, double>>> featureWidths_t;
109
110#ifndef SWIG
112 featureWidths_t & getFeatureWidths();
113#endif
115 void setAverageFeatureWidths(const std::vector<double> & featureWidths);
116
118 const featureWidths_t & getFeatureWidths() const;
119
120#ifndef SWIG
121 bool getEvaluation(const int subProject, double & meanErrorsRaw, double & meanErrorsAligned, double & stdevErrorsRaw, double & stdevErrorsAligned, double & pearsonCoefficientRaw, double & pearsonCoefficientAligned);
122#else // SWIG Multiple return values
123 bool getEvaluation(const int subProject, double & OUTPUT, double & OUTPUT, double & OUTPUT, double & OUTPUT, double & OUTPUT, double & OUTPUT);
124#endif
125
127 void setStatus(status_t status);
128
130 status_t getStatus(void) const;
131
133 std::string getStatusAsText(void) const;
134
136 void setAlgorithmName(const char* algorithmName);
137
139 std::string getAlgorithmName() const;
140
142 const std::vector<int> getSubProjectToFractionMap() const;
143
144#ifndef SWIG
146 ms_ms1quant_time_align_body * body();
148 const ms_ms1quant_time_align_body * body() const;
149#endif
151 typedef std::map<int, std::vector<int>> fractionToSubProject_t;
152
154 fractionToSubProject_t getFractionToSubProjectMap() const;
155
157 bool calculateFromConsensuValues(bool replaceExisting = false);
158
159
160 protected:
161 void setUpFractions(const std::vector<int> & subProjectToFraction);
162
163 void setEvaluation(int subProject, double meanErrorsRaw, double meanErrorsAligned, double stdevErrorsRaw, double stdevErrorsAligned, double pearsonCoefficientRaw, double pearsonCoefficientAligned);
164 };
165 // end of quantitation_group
167 //=========================================================================
168
169} // namespace matrix_science
170
171
172#endif // MS_MS1QUANT_TIME_ALIGN_HPP
173
174/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_ms1quant_time_align_limits
Limits for m/z and retention time.
Definition: ms_ms1quant_time_align_limits.hpp:39
matrix_science::ms_ms1quant_time_align
Time alignment between multiple runs (raw files) is performed in Mascot Distiller for label free quan...
Definition: ms_ms1quant_time_align.hpp:47
matrix_science::ms_ms1quant_time_align::fractionToSubProject_t
std::map< int, std::vector< int > > fractionToSubProject_t
the vector for each fraction contains 0 based subProject numbers and fraction numbers don't need to b...
Definition: ms_ms1quant_time_align.hpp:151
matrix_science::ms_ms1quant_time_align::featureWidths_t
std::vector< std::vector< std::map< double, double > > > featureWidths_t
[prj][m/z bin][rt->width]
Definition: ms_ms1quant_time_align.hpp:108
matrix_science::ms_ms1quant_time_align::status_t
status_t
Definition: ms_ms1quant_time_align.hpp:52
matrix_science::ms_ms1quant_time_align::ST_TA_LOADED_FROM_XML
@ ST_TA_LOADED_FROM_XML
The time alignment data has been loaded from an xml so does not need to be recalculated.
Definition: ms_ms1quant_time_align.hpp:54
matrix_science::ms_ms1quant_time_align::ST_TA_NO_DATA
@ ST_TA_NO_DATA
No time alignment data. If the protocol is replicate, this indicates time alignment still needs to be...
Definition: ms_ms1quant_time_align.hpp:53
matrix_science::ms_ms1quant_time_align::ST_TA_LOADED_FROM_CDB
@ ST_TA_LOADED_FROM_CDB
The time alignment data has been loaded from a cdb file so does not need to be recalculated.
Definition: ms_ms1quant_time_align.hpp:55
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_time_align_body.hpp Source File

  • src
  • resfile
ms_ms1quant_time_align_body.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_time_align_body.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_TIME_ALIGN_BODY_HPP
18#define MS_MS1QUANT_TIME_ALIGN_BODY_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24namespace matrix_science
25{
26 class ms_ms1quant_time_align_body :
27 public matrix_science::ms_body
28 {
29 public:
30 typedef std::vector<std::vector<std::vector<double>>> shifts_t; // [prj][bin][rt] where prj is zero based and bin==0 for LabelFreeTimeAlignLimits::getCombinedMinBinNum
31
32 ms_ms1quant_time_align_body(matrix_science::ms_errs & errs, const int binSize);
33
34 ms_ms1quant_time_align_limits & getCombinedLimits(const int fractionNum);
35 ms_ms1quant_time_align_limits getCombinedLimits(const int fractionNum) const;
36
37 bool loadFromCdb(matrix_science::ms_tinycdb & cdbFile);
38 bool loadFromXml(msparser_internal::ms_XMLHelper & helper,
39 msparser_internal::ms_XMLElement & element,
40 const std::string & namespacePrefix);
41 bool loadShiftsFromXML(msparser_internal::ms_XMLHelper& helper,
42 msparser_internal::ms_XMLElement& element,
43 const std::string& namespacePrefix,
44 const char* elementName,
45 shifts_t & shiftsVector);
46
47 bool loadXmlUsingSax(const std::string & xmlFilename, const std::string & schemaDirectory);
48
49 bool saveToCdb(matrix_science::ms_tinycdb & cdbFile) const;
50 bool saveToXml(msparser_internal::ms_XMLHelper & helper,
51 msparser_internal::ms_XMLElement & element) const;
52
53 // Required by Quantlib to populate the data
54 void setUpFractions(const std::vector<int> & subProjectToFraction);
55
57 void allocateMemoryForResults();
58
59 // The main 'public' functions
60 double getRToffset(const int myProjectId, const int otherProjectId, const double rtInOtherProject, const double mOverZ) const;
61 double getEstimatedFeatureWidth(const int subProjectId, const double mOverZ, const double rt) const;
62
63 int getBinNumber(const double mOverZ) const;
64
65 bool calculateFromConsensuValues(bool replaceExisting);
66 void interp1d(const std::vector<double>& x, const std::vector<double>& y, const std::vector<int>& newX, std::vector<double>& newY) const;
67
68 matrix_science::ms_errs & errs_;
69 int binSize_;
70 int algorithmVersion_;
71 std::string algorithm_;
72 int numRawFiles_; // in <parameters numRawFiles=3 .... />
73 ms_ms1quant_time_align::status_t status_;
74 std::vector<int> subProjectToFraction_;
75 ms_ms1quant_time_align::fractionToSubProject_t fractionToSubProject_;
76 shifts_t shiftsToConsensus_;
77 shifts_t shiftsFromConsensus_;
78 ms_ms1quant_time_align::featureWidths_t featureWidths_; // [prj][m/z bin][rt->width]
79 std::vector<double> averageFeatureWidths_; // [prj] - just one value per project
80
81 typedef std::map<int, ms_ms1quant_time_align_limits> limits_map_t;
82 limits_map_t combinedRtMzLimits_; // Each fraction has its own limits to make comparison and testing easier
83
84 struct evaluationStruct {
85 evaluationStruct()
86 : meanErrorsRaw_(0)
87 , meanErrorsAligned_(0)
88 , stdevErrorsRaw_(0)
89 , stdevErrorsAligned_(0)
90 , pearsonCoefficientRaw_(0)
91 , pearsonCoefficientAligned_(0)
92 {};
93
94 double meanErrorsRaw_;
95 double meanErrorsAligned_;
96 double stdevErrorsRaw_;
97 double stdevErrorsAligned_;
98 double pearsonCoefficientRaw_;
99 double pearsonCoefficientAligned_;
100 };
101 std::vector<evaluationStruct> evaluation_;
102
103 enum flags_e:unsigned int {
104 FL_HAS_TO_SHIFTS = 0x00000001,
105 FL_HAS_FROM_SHIFTS = 0x00000002,
106 FL_HAS_AVERAGE_FEATURE_WIDTHS = 0x00000004,
107 FL_HAS_EVALUATION = 0x00000008,
108
109 FL_V1_DEFAULTS = (FL_HAS_TO_SHIFTS | FL_HAS_EVALUATION)
110 };
111 mutable /*flags_e*/ unsigned int flags_;
112 };
113
114} // namespace matrix_science
115
116#endif // MS_MS1QUANT_TIME_ALIGN_BODY_HPP
117
118/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_ms1quant_time_align::fractionToSubProject_t
std::map< int, std::vector< int > > fractionToSubProject_t
the vector for each fraction contains 0 based subProject numbers and fraction numbers don't need to b...
Definition: ms_ms1quant_time_align.hpp:151
matrix_science::ms_ms1quant_time_align::featureWidths_t
std::vector< std::vector< std::map< double, double > > > featureWidths_t
[prj][m/z bin][rt->width]
Definition: ms_ms1quant_time_align.hpp:108
matrix_science::ms_ms1quant_time_align::status_t
status_t
Definition: ms_ms1quant_time_align.hpp:52
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_time_align_limits.hpp Source File

  • inc
ms_ms1quant_time_align_limits.hpp
1/*
2##############################################################################
3# File: ms_ms1quant_time_align_limits.hpp #
4# Mascot Parser toolkit #
5# Class for accessing the time alignemnt data produced by Distiller for LFQ #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2022 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source: parser/inc/ms_ms1quant_time_align_limits.hpp $
12# $Author: dcreasy@matrixscience.com $
13# $Date: 2022-11-22 14:16:39 +0000 $
14# $Revision: 995da8fe3a941466ad6288b8d2aeca6eed677aea | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
15##############################################################################
16*/
17
18#ifndef MS_MS1QUANT_TIME_ALIGN_LIMITS_HPP
19#define MS_MS1QUANT_TIME_ALIGN_LIMITS_HPP
20
21
22namespace matrix_science
23{
29 class ms_ms1quant_time_align_limits_body;
30
32
39 class MS_MASCOTRESFILE_API ms_ms1quant_time_align_limits : public ms_handle {
40 public:
42 ms_ms1quant_time_align_limits();
43
45 double getMinRT() const;
46
48 void setMinRT(const double value);
49
51 double getMaxRT() const;
52
54 void setMaxRT(const double value);
55
57 double getMinMZ() const;
58
60 void setMinMZ(const double value);
61
63 double getMaxMZ() const;
64
66 void setMaxMZ(const double value);
67
69 int getNumQueries() const;
70
72 void setNumQueries(const int value);
73
75 int getNumQueriesAboveThreshold() const;
76
78 void setNumQueriesAboveThreshold(const int value);
79
81 typedef int combinedRT_t;
82
84 static const combinedRT_t combinedRTinterval = 1;
85
87 combinedRT_t getCombinedMinRT() const;
88
90 void setMinBinNum(const int value);
91
93 combinedRT_t getCombinedMaxRT() const;
94
96 void setMaxBinNum(const int value);
97
99 int getCombinedMinBinNum() const;
100
102 int getCombinedMaxBinNum() const;
103
104#ifndef SWIG
106 ms_ms1quant_time_align_limits_body * body();
108 const ms_ms1quant_time_align_limits_body * body() const;
109#endif
110
111 protected:
112 };
113 // end of quantitation_group
115}
116
117#endif // MS_MS1QUANT_TIME_ALIGN_LIMITS_HPP
matrix_science::ms_ms1quant_time_align_limits
Limits for m/z and retention time.
Definition: ms_ms1quant_time_align_limits.hpp:39
matrix_science::ms_ms1quant_time_align_limits::combinedRT_t
int combinedRT_t
At the moment, when creating a common grid, integer retention times are used.
Definition: ms_ms1quant_time_align_limits.hpp:81
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_time_align_limits_body.hpp Source File

  • src
  • resfile
ms_ms1quant_time_align_limits_body.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_time_align_limits_body.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANT_TIME_ALIGN_LIMITS_BODY_HPP
18#define MS_MS1QUANT_TIME_ALIGN_LIMITS_BODY_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24namespace matrix_science
25{
26 class ms_ms1quant_time_align_limits_body :
27 public matrix_science::ms_body
28 {
29 public:
30 ms_ms1quant_time_align_limits_body();
31
32 void deepCopy(const ms_ms1quant_time_align_limits_body & src);
33
34 bool loadStream(matrix_science::ms_cache_stream & stream);
35 bool loadFromXml(msparser_internal::ms_XMLHelper & helper,
36 msparser_internal::ms_XMLElement & element);
37
38 bool saveToStream(matrix_science::ms_cache_stream & stream) const;
39 bool saveToXml(msparser_internal::ms_XMLHelper & helper,
40 msparser_internal::ms_XMLElement & element,
41 int fractionNumber) const;
42
43 double minRT_, maxRT_, minMZ_, maxMZ_;
44 int minBinNum_, maxBinNum_, numQueries_, numQueriesAboveThreshold_;
45 };
46
47} // namespace matrix_science
48
49#endif // MS_MS1QUANT_TIME_ALIGN_LIMITS_BODY_HPP
50
51/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quant_time_align_sax.hpp Source File

  • src
  • resfile
ms_ms1quant_time_align_sax.hpp
1/*
2##############################################################################
3# file: ms_ms1quant_time_align_sax.hpp
4# 'msparser' toolkit
5#
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2022 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 */
12
13#ifndef MS_MS1QUANT_TIME_ALIGN_SAX_HPP
14#define MS_MS1QUANT_TIME_ALIGN_SAX_HPP
15
16
17
18// Includes from the standard template library
19#include <string>
20
21namespace msparser_internal
22{
23 class timeAlignErrorHandler
24 : public xmlu::XCS_SAXEventDispatcher
25 {
26 public:
27 timeAlignErrorHandler(matrix_science::ms_errs & errs, const std::string & xmlFileName)
28 : errs_(errs)
29 , xmlFileName_(xmlFileName)
30 { }
31
32 virtual void error(const xercesc::SAXParseException & exception) {
33 errs_.logMessage(matrix_science::ms_errs::ERR_MSP_MS1QUANT_XML_PARSE, __FILE__, __LINE__,
34 exception.getLineNumber(), xmlFileName_, ms_strXML(exception.getMessage()).localForm());
35 }
36 virtual void fatalError(const xercesc::SAXParseException & exception) {
37 errs_.logMessage(matrix_science::ms_errs::ERR_MSP_MS1QUANT_XML_PARSE, __FILE__, __LINE__,
38 exception.getLineNumber(), xmlFileName_, ms_strXML(exception.getMessage()).localForm());
39 }
40 virtual void warning(const xercesc::SAXParseException & exception) {
41 errs_.logMessage(matrix_science::ms_errs::ERR_MSP_MS1QUANT_XML_PARSE, __FILE__, __LINE__,
42 exception.getLineNumber(), xmlFileName_, ms_strXML(exception.getMessage()).localForm());
43 }
44
45 private:
46 matrix_science::ms_errs & errs_;
47 const std::string & xmlFileName_;
48 };
49
50 class timeAlignSaxDoc
51 : public xmlu::XCS_SAXDefaultHandlerExtras
52 {
53 enum state_e
54 {
55 STATE_UNINIT,
56 STATE_BEGIN_DOC,
57 STATE_ROOT_EL,
58 STATE_ROOT_EL_DONE,
59 STATE_END_DOC
60 };
61
62 public:
63 typedef PAL::SmartPtr<timeAlignSaxDoc> ptr_t;
64
65 public:
66 timeAlignSaxDoc(matrix_science::ms_ms1quant_time_align_body & timeAlign, matrix_science::ms_errs & errs);
67
68 public:
69 virtual void startDocument();
70 virtual void endDocument();
71 virtual void startElement(const xmlu::XCS_String & uri,
72 const xmlu::XCS_String & localname,
73 const xmlu::XCS_String & qname,
74 const xmlu::XCS_SAXAttributes & attrs);
75 virtual void endElement(const xmlu::XCS_String & uri,
76 const xmlu::XCS_String & localname,
77 const xmlu::XCS_String & qname);
78 static std::string getFieldString(const xmlu::XCS_SAXAttributes & attrs, const wchar_t * fieldName);
79 static double getFieldDoubleDual(const xmlu::XCS_SAXAttributes & attrs, const wchar_t * fieldName);
80 static int getFieldInt(const xmlu::XCS_SAXAttributes & attrs, const wchar_t * fieldName);
81 static bool getFieldBool(const xmlu::XCS_SAXAttributes& attrs, const wchar_t* fieldName, const bool defaultValue);
82 private:
83 state_e state_;
84 matrix_science::ms_ms1quant_time_align_body & timeAlign_;
85 matrix_science::ms_errs & errs_;
86 };
87
88// --------------------------------------------------------------------------
89
90 class timeAlignSaxDoc_Main
91 : public xmlu::XCS_SAXDefaultHandlerExtras
92 {
93 enum state_e
94 {
95 STATE_BEGIN,
96 STATE_WAIT_TA_GROUP,
97 STATE_PARAMETERS_GROUP, // <parameters>
98 STATE_RAWFILE_GROUP, // <rawfile>
99 STATE_LIMITS_GROUP, // <limits>
100 STATE_EVALUATION_GROUP, // <evaluation>
101 STATE_SHIFTS_GROUP, // <shifts>
102 STATE_END
103 };
104
105 public:
106 typedef PAL::SmartPtr<timeAlignSaxDoc_Main> ptr_t;
107
108 public:
109 timeAlignSaxDoc_Main(matrix_science::ms_ms1quant_time_align_body & timeAlign, matrix_science::ms_errs & errs);
110
111 public:
112 virtual void startElement(const xmlu::XCS_String & uri,
113 const xmlu::XCS_String & localname,
114 const xmlu::XCS_String & qname,
115 const xmlu::XCS_SAXAttributes & attrs);
116 virtual void endElement(const xmlu::XCS_String & uri,
117 const xmlu::XCS_String & localname,
118 const xmlu::XCS_String & qname);
119
120 private:
121 state_e state_;
122 matrix_science::ms_ms1quant_time_align_body & timeAlign_;
123 matrix_science::ms_errs & errs_;
124 int numRawFileElementsFound_;
125 std::vector<int> subProjectToFraction_;
126 };
127
128// --------------------------------------------------------------------------
129
130 class timeAlignSaxDoc_Shifts
131 : public xmlu::XCS_SAXDefaultHandlerExtras
132 {
133 enum state_e
134 {
135 STATE_BEGIN,
136 STATE_WAIT_GROUP,
137 STATE_SHIFT_GROUP, // <shift>
138 STATE_FW_GROUP, // <featureWidth>
139 STATE_END
140 };
141
142 public:
143 typedef PAL::SmartPtr<timeAlignSaxDoc_Shifts> ptr_t;
144
145 public:
146 timeAlignSaxDoc_Shifts(matrix_science::ms_ms1quant_time_align_body & timeAlign, matrix_science::ms_errs & errs, const int numRawfiles);
147
148 public:
149 virtual void startElement(const xmlu::XCS_String & uri,
150 const xmlu::XCS_String & localname,
151 const xmlu::XCS_String & qname,
152 const xmlu::XCS_SAXAttributes & attrs);
153 virtual void endElement(const xmlu::XCS_String & uri,
154 const xmlu::XCS_String & localname,
155 const xmlu::XCS_String & qname);
156
157 private:
158 state_e state_;
159 matrix_science::ms_ms1quant_time_align_body & timeAlign_;
160 matrix_science::ms_errs & errs_;
161 int numRawfiles_;
162 int rawfile_;
163 int bin_;
164 int binOffset_;
165 };
166
167// --------------------------------------------------------------------------
168
169 class timeAlignSaxDoc_Shift
170 : public xmlu::XCS_SAXDefaultHandlerExtras
171 {
172 enum state_e
173 {
174 STATE_BEGIN,
175 STATE_WAIT_GROUP,
176 STATE_END
177 };
178
179 public:
180 typedef PAL::SmartPtr<timeAlignSaxDoc_Shift> ptr_t;
181
182 public:
183 timeAlignSaxDoc_Shift(matrix_science::ms_errs & errs,
184 int rawfile,
185 int bin,
186 std::vector<double> & resultsForThisPrjAndBin);
187
188 public:
189 virtual void startElement(const xmlu::XCS_String & uri,
190 const xmlu::XCS_String & localname,
191 const xmlu::XCS_String & qname,
192 const xmlu::XCS_SAXAttributes & attrs);
193 virtual void endElement(const xmlu::XCS_String & uri,
194 const xmlu::XCS_String & localname,
195 const xmlu::XCS_String & qname);
196
197 private:
198 state_e state_;
199 matrix_science::ms_errs & errs_;
200 int rawfile_;
201 int bin_;
202 std::vector<double> & resultsForThisPrjAndBin_;
203 };
204
205 // --------------------------------------------------------------------------
206
207 class timeAlignSaxDoc_FeatureWidth
208 : public xmlu::XCS_SAXDefaultHandlerExtras
209 {
210 enum state_e
211 {
212 STATE_BEGIN,
213 STATE_WAIT_GROUP,
214 STATE_END
215 };
216
217 public:
218 typedef PAL::SmartPtr<timeAlignSaxDoc_FeatureWidth> ptr_t;
219
220 public:
221 timeAlignSaxDoc_FeatureWidth(matrix_science::ms_errs & errs,
222 int rawfile,
223 int bin,
224 std::map<double, double> & featureWidthsForThisPrjAndBin);
225
226 public:
227 virtual void startElement(const xmlu::XCS_String & uri,
228 const xmlu::XCS_String & localname,
229 const xmlu::XCS_String & qname,
230 const xmlu::XCS_SAXAttributes & attrs);
231 virtual void endElement(const xmlu::XCS_String & uri,
232 const xmlu::XCS_String & localname,
233 const xmlu::XCS_String & qname);
234
235 private:
236 state_e state_;
237 matrix_science::ms_errs & errs_;
238 int rawfile_;
239 int bin_;
240 std::map<double, double> & featureWidthsForThisPrjAndBin_; // rt => width in seconds
241 };
242
243
244} // namespace msparser_internal
245
246#endif // MS_MS1QUANT_TIME_ALIGN_SAX_HPP
247
248/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_errs::ERR_MSP_MS1QUANT_XML_PARSE
static const err ERR_MSP_MS1QUANT_XML_PARSE
[W] Error parsing XML at line: %d of input file: %s. Error: %s
Definition: ms_errors.hpp:394
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms1quantitation.hpp Source File

  • inc
ms_ms1quantitation.hpp
1/*
2##############################################################################
3# file: ms_ms1quantitation.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_ms1quantitation.hpp $
12 * @(#)$Revision: 89fdd131b46df750b15607fe93a5737171311c08 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2024-04-18 14:13:15 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_MS1QUANTITATION_HPP
18#define MS_MS1QUANTITATION_HPP
19
20
21
22
23// Includes from the standard template library
24#include <string>
25#include <vector>
26
27namespace msparser_internal
28{
29 class ms_XMLElement;
30 class ms_XMLHelper;
31}
32
33namespace matrix_science
34{
35 //=========================================================================
41 class ms_msquant1_mod_format;
42 class ms_cache_stream;
43 class ms_progress_info;
44 class ms_mascotresults_params;
45
47
90 class MS_MASCOTRESFILE_API ms_ms1quantitation :
91 public ms_customquantitation
92 {
93 public:
95 enum MERGE_QUANT_RESULTS_FLAGS {
96 MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS = 0x0001,
97 MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH = 0x0002,
98 MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC = 0x0004,
99 MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE = 0x0008,
100
101 MERGE_QUANT_DEFAULT_PRECURSOR_METHOD = MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE,
102 MERGE_QUANT_DEFAULT_REPLICATE_METHOD = (MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS | MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH | MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC)
103 };
104
106
115 enum MS1QUANT_BUGFIX_NUM {
116 BUGFIX_12409 = 12409
117 };
118
120 ms_ms1quantitation(const ms_peptidesummary & summary, const ms_quant_method & method);
121
122 ~ms_ms1quantitation();
123
125 int getNumPeptideStatuses() const;
127 ms_ms1quant_peptide_status getPeptideStatus(int index) const;
128
130 int getNumHits() const;
132 ms_protein * getHit(int index1) const;
133
135 int getNumProteinFamilies() const;
136
138 int getNumMatches() const;
140 ms_ms1quant_match getMatch(int index) const;
142 ms_ms1quant_match getMatch(const ms_peptide_quant_key & key) const;
143
144 void clearMatches();
145
147 void addMatchStatus(
148 matrix_science::ms_peptide * peptide,
149 matrix_science::ms_ms1quant_peptide_status::peptideStatus status,
150 matrix_science::ms_protein * hit = 0);
151
153 void addMatchPeptide(
154 matrix_science::ms_protein * hit,
155 matrix_science::ms_peptide * peptide,
156 const matrix_science::ms_quant_component & component,
157 const std::string & matchBelongsToComponent,
158 const int thisSubProjectId = matrix_science::ms_quant_file_index::file_index_value_not_set);
159
161 matrix_science::ms_ms1quant_match addMatchInferred(
162 const ms_ms1quant_match & siblingMatch,
163 int newCharge);
164
166 void removeMatch(matrix_science::ms_peptide_quant_key matchKey);
167
169 bool findPeptideStatus(int query, int rank, ms_ms1quant_peptide_status * peptideStatus) const;
170
172 bool findMatch(matrix_science::ms_peptide_quant_key matchKey, ms_ms1quant_match * match) const;
173
175 const ms_ms1quant_average_results * getAverageResults() const;
176
178 bool loadXmlFile(const std::string & filename, const std::string & xmlSchemaPath);
179
181 bool saveXmlFile(const std::string & xmlFilename, bool completeReport, bool saveTimeAlignmentData = false);
182
184 bool loadCdbFile(const std::string & cdbFilename, const std::string & cacheFilename, bool revalidateQualityThresholds=true);
185
187 bool saveCdbFile(const std::string & cdbFilename, const std::string & cacheFilename, bool createEmptyMissingComponents = false);
188
190 const ms_peptidesummary & getPeptideSummary() const;
191
193 const ms_peptidesummary & getSummary() const;
194
196 std::string getReadableVarMods(std::string varmods);
197
199 std::string getReadableVarModsConcise(std::string varmods);
200
202 std::string getLabelFree(std::string peptideStr, std::string varMods, std::string summedMods, const matrix_science::ms_quant_component & comp) const;
203
205 int getNumMatchesForHit(int hitId, int memberNumber) const;
207 ms_ms1quant_match getMatchForHit(int index, int hitId, int memberNumber) const;
208
210 int getNumGroups() const;
211
212 int getDatasourceForGroup(int groupIndex1) const;
213
215 int getNumMatchesForGroup(int groupIndex1) const;
216
217 ms_ms1quant_match getMatchForGroup(int matchIndex1, int groupIndex1) const;
218
220 virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const;
221
223 virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const;
224
226 std::vector<double> getAllProteinRatios(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
227
229 std::vector<std::vector<bool> > getAllProteinRatioFlags(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
230
232 std::vector<std::vector<double> > getAllProteinRatioValues(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
233
235 std::vector<std::string> getAllProteinRatioPepSeqs(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
236
238 bool isAverageProtocol() const;
240 void setAverageReferenceProtein(const char *accession, int dbIdx, bool isReferenceUserSelected);
242 void setAverageNumPeptides(unsigned int num = 3);
244 void setAverageSelection(const char * value);
245#ifndef SWIG
247 bool getAveragePeptideIntensity(
248 const std::string &accession,
249 int dbIdx,
250 double * averageIntensity, // average of grouped intensities (each peptide ratio group summed and then average of those sums)
251 int * sampleSize, // number of different peptide groups available (after grouping by selection type)
252 ms_peptide_quant_key_vector * includeKeys, // peptide ratios selected (may be greater then sampleSize)
253 ms_peptide_quant_key_vector * excludeKeys // peptide ratios not selected
254 ) const;
255#else // SWIG Multiple return values
256 bool getAveragePeptideIntensity(
257 const std::string & accession,
258 int dbIdx,
259 double * OUTPUT,
260 int * OUTPUT,
261 ms_peptide_quant_key_vector * includeKeys,
262 ms_peptide_quant_key_vector * excludeKeys
263 ) const;
264#endif
266 std::vector<int> getQuantitationDatasources() const;
267
268 int getNumMatchedPeptideStatuses() const;
269
271 void initGroupChargeStates(
272 std::set<int> * calc_chargestates,
273 int iGroup1,
274 int minCharge,
275 int maxCharge);
276
277 void calc_complete();
278
280 bool isDataCached(MS1QUANT_BUGFIX_NUM bugNum) const;
281
283 const matrix_science::ms_ms1quant_time_align & getTimeAlignmentData() const;
284
285#ifndef SWIG
287 matrix_science::ms_ms1quant_time_align & getTimeAlignmentData();
288
289 void setTimeAlignmentData(matrix_science::ms_ms1quant_time_align & alignmentData);
290#endif
291
293 using ms_quantitation::countDistinctPeptides;
294
295#ifndef SWIG
297 virtual int countDistinctPeptides(const std::vector<ms_peptide_quant_key> & activeKeys) const;
298#endif
300 static matrix_science::ms_ms1quantitation * openQuantitationCdbResults(
301 const matrix_science::ms_peptidesummary & summary,
302 const matrix_science::ms_quant_method & method,
303 const std::string & cdbFilename,
304 const std::string & cacheFilename,
305 const matrix_science::ms_quant_method * originalMethod = 0);
306
308 static matrix_science::ms_ms1quantitation * openQuantitationXmlResults(
309 const matrix_science::ms_peptidesummary & summary,
310 const matrix_science::ms_quant_method & method,
311 const std::string & filename,
312 const std::string & xmlSchemaPath="",
313 const matrix_science::ms_quant_method * originalMethod = 0);
314
316 bool mergeQuantitationResults(const std::vector<std::string> & cdbFilenames,
317 const std::vector<std::string> & cacheFilenames,
318 const MERGE_QUANT_RESULTS_FLAGS flags,
319 const matrix_science::ms_quant_method * originalMethod = 0);
320
322 bool mergeQuantitationResults(const std::vector<std::string> & xmlFilenames,
323 const MERGE_QUANT_RESULTS_FLAGS flags,
324 const std::string & xmlSchemaPath="",
325 const matrix_science::ms_quant_method * originalMethod = 0);
326#ifndef SWIG
328 static bool readResultCounters(const std::string & cdbFile,
329 int &numMatches, int &numHits, int &numPepGrp, int &numPeptideComponents);
330#else // SWIG Multiple return values
331 static bool readResultCounters(const std::string & cdbFile,
332 int &OUTPUT, int &OUTPUT, int &OUTPUT, int &OUTPUT);
333#endif
334
335 protected:
336
337 private:
338 //Do not copy this object
339 ms_ms1quantitation(const ms_ms1quantitation & src);
340 ms_ms1quantitation& operator=(const ms_ms1quantitation & right);
341
342 void initialiseAfterLoad();
343 // normalisation
344 std::list<ms_ms1quant_match> selectMatchesForNormalisation(const ms_quant_normalisation *norm);
345 double calculatePeptideNormalisationBase(const std::string &ratioName) const;
347 void normalisePeptideRatios();
348 // end normalisation
349
350 bool saveHitToCdb(matrix_science::ms_tinycdb & cdbFile, const matrix_science::ms_protein * protein, int streamNumber) const;
351 bool saveHitToStream(matrix_science::ms_cache_stream & stream, const matrix_science::ms_protein * protein) const;
352 bool saveHitToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const matrix_science::ms_protein * protein, int hitId, int memberNumber);
353
354 void getProteinRatioOverrideKeys(
355 ms_peptide_quant_key_vector * incFK,
356 ms_peptide_quant_key_vector * excFK,
357 const std::string & ratioName,
358 int hitId,
359 int memberNumber) const;
360
361 ms_protein_quant_ratio getProteinAverageIntensityRatio(
362 const std::string &accession,
363 int dbIdx
364 ) const;
365
366 void rematchInferredMatches(const bool allowMassTimeMatches); // populates inferredMatchSource_
367 void updatePeptideStatus(matrix_science::ms_ms1quant_peptide_status status, const matrix_science::ms_quant_quality * quality);
368 void updateMatches(const matrix_science::ms_quant_method * method); // removes any ms1 quant matches which don't have any valid ms2 peptide matches
369 void updateMatchPeptideEvidence(); // updates the ms2 matches associated (or not associated) with an ms1 quant match
370 bool updateProteinMatches(); // ensures only valid anchor proteins are returned
371
372 // Can the new settings be handled my ms_ms1quantitation, or do additional values need to be calculated by MsQuantLib
373 static bool canHandleSettings(const matrix_science::ms_quant_method * originalMethod, const matrix_science::ms_quant_method * newMethod, matrix_science::ms_ms1quantitation * quantResults);
374
375 std::map<matrix_science::ms_peptide_quant_key, ms_ms1quant_peptide_status_body> getMatchedPeptideStatuses() const;
376
378 std::vector<ms_ms1quant_match> getMatchesForHit(int hitId, int memberNumber) const;
379
381 bool saveGroupToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const matrix_science::ms_protein * protein, int hitId, int memberNumber) const;
382 void reorderMatchesAfterMerge();
383
385 bool mergeCdbFiles(const std::vector<std::string> & cdbFilenames,
386 const std::vector<std::string> & cacheFilenames,
387 const std::vector<std::string> & resultFilenames,
388 const matrix_science::ms_mascotresults_params & parameters,
389 const std::string & cacheDirectory,
390 const MERGE_QUANT_RESULTS_FLAGS flags);
391
393 bool mergeXmlFiles(
394 const std::vector<std::string> & xmlFilenames,
395 const std::vector<std::string> & resultFilenames,
396 const std::string & cacheDirectory,
397 const std::string & xmlSchemaPath,
398 const MERGE_QUANT_RESULTS_FLAGS flags);
399
401 void getKeyStrings(const int dataSourceId, const std::string & peptideStr, const std::string & labelFreeVarMods, const int chargeState,
402 std::string & groupKey, std::string & uniqueKey) const;
403
404 const ms_peptidesummary & peptideSummary_;
405 int nextMatchId_;
406 std::map<ms_peptide_quant_key, ms_ms1quant_match> matches_; // matchId -> match
407 std::map<std::pair<int, int>, ms_ms1quant_peptide_status> peptideStatuses_; // [query, rank] -> status
408 std::map<std::string, ms_peptide_quant_key> matchKeys_; // peptideStr:datasourceId:labelFree:charge -> matchId
409 std::map<std::string, std::set<ms_peptide_quant_key> > matchGroups_; // "datasource:peptideStr:labelFree" -> matchId[]
410 std::vector<std::string> matchGroupNames_; // names in matchGroups in order of addition (to match with processing order in Distiller)
411
412
413 // matchId -> matchId of the 'source/sibling' identified match - always the most intense sibling if there is more than one possibility
414 std::map<ms_peptide_quant_key, ms_peptide_quant_key> inferredMatchSource_;
415
416 typedef std::pair<int, int> Hitkey; // hitId, memberNumber (0 if not a family)
417 std::vector<Hitkey> hitkeys_;
418
419 bool hasAverageResults_;
420 ms_ms1quant_average_results averageResults_;
421
422 matrix_science::ms_cache_file cacheFile_;
423
424 mutable const ms_msquant1_mod_format * modFormat_;
425
426 std::vector<matrix_science::ms_cache_file *> multifileCacheFiles_;
427
428 std::string bugsfixed_;
429
430 ms_ms1quant_time_align timeAlignment_;
431 };
432 // end of quantitation_group
434 //=========================================================================
435
436} // matrix_science namespace
437
438
439#endif // MS_MS1QUANTITATION_HPP
440
441/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customquantitation
Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings.
Definition: ms_customquantitation.hpp:119
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_ms1quant_average_results
Results specific to an 'average' type quantitation method.
Definition: ms_ms1quant_average_results.hpp:42
matrix_science::ms_ms1quant_match
A peptide that has been matched, in quantitation, to a protein hit.
Definition: ms_ms1quant_match.hpp:47
matrix_science::ms_ms1quant_peptide_status
An individual peptide's quantitation status.
Definition: ms_ms1quant_peptide_status.hpp:41
matrix_science::ms_ms1quant_peptide_status::peptideStatus
peptideStatus
Status codes from fitting peptides.
Definition: ms_ms1quant_peptide_status.hpp:48
matrix_science::ms_ms1quant_time_align
Time alignment between multiple runs (raw files) is performed in Mascot Distiller for label free quan...
Definition: ms_ms1quant_time_align.hpp:47
matrix_science::ms_ms1quantitation
The result of quantitation calculations applied to peptide summary.
Definition: ms_ms1quantitation.hpp:92
matrix_science::ms_ms1quantitation::MERGE_QUANT_RESULTS_FLAGS
MERGE_QUANT_RESULTS_FLAGS
Enum for mergeQuantitationResults()
Definition: ms_ms1quantitation.hpp:95
matrix_science::ms_ms1quantitation::MS1QUANT_BUGFIX_NUM
MS1QUANT_BUGFIX_NUM
bugNum values for isDataCached().
Definition: ms_ms1quantitation.hpp:115
matrix_science::ms_peptide_quant_key_vector
A vector of peptide quant keys.
Definition: ms_peptide_quant_key_vector.hpp:47
matrix_science::ms_peptide_quant_key
Feature key identifying a peptide ratio.
Definition: ms_peptide_quant_key.hpp:69
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_protein_quant_ratio
Protein abundance in one component relative to another in a quantitation experiment,...
Definition: ms_protein_quant_ratio.hpp:72
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_file_index::file_index_value_not_set
static const int file_index_value_not_set
A file_index value is a 1 based number. In cases where file_index values are not used (e....
Definition: ms_quant_file_index.hpp:112
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_quant_normalisation
An object of this class represent a single normalisation element in quantitation.xml.
Definition: ms_quant_normalisation.hpp:42
matrix_science::ms_quant_quality
An object of this class represent a single quality element in quantitation.xml.
Definition: ms_quant_quality.hpp:40
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms2quantitation.hpp Source File

  • inc
ms_ms2quantitation.hpp
1/*
2##############################################################################
3# file: ms_ms2quantitation.hpp #
4# 'msparser' toolkit #
5# Quantitation for Reporter and Multiplex protocols #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: patricke@matrixscience.com $ #
12# $Date: 2024-04-18 14:13:15 +0100 $ #
13# $Revision: 89fdd131b46df750b15607fe93a5737171311c08 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_MS2QUANTITATION_HPP
19#define MS_MS2QUANTITATION_HPP
20
21
22// Includes from the standard template library
23#include <string>
24#include <vector>
25#include <list>
26#include <utility>
27
28namespace msparser_internal {
29 class ms_ms2ratiocalculator;
30 class ms_XMLElement;
31 class ms_XMLHelper;
32}
33
34namespace matrix_science {
35 class ms_quant_ratio;
36 class ms_quantitation;
37 class ms_peptidesummary;
38 class ms_peptide_quant_key;
39 class ms_peptide_quant_key_vector;
40 class ms_quant_helper;
41 class ms_protein;
42 class ms_mascotresfilebase;
43
50
126 class MS_MASCOTRESFILE_API ms_ms2quantitation: public ms_quantitation
127 {
128 friend class ms_customquantitation;
129 public:
131 explicit ms_ms2quantitation(const ms_peptidesummary& pepsum);
132
134 ms_ms2quantitation(const ms_peptidesummary& pepsum, const ms_quant_method &qm);
135
137 virtual ~ms_ms2quantitation();
138
139 virtual bool hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const;
140 virtual ms_peptide_quant_ratio getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const;
141
142 virtual void setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName);
143 virtual void setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName);
144 virtual bool isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const;
145
146 virtual void setProteinRatioType(const char *value);
147
148 virtual void setQuantOutliers(const ms_quant_outliers *);
149
150 virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const;
151
152 virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const;
153
155 const ms_peptidesummary & getPeptideSummary() const;
156
158 bool getAllProteinRatios(const std::string & accession, const int dbIdx,
159 const std::string & ratioName,
160 std::vector<double> & ratios,
161 std::vector<std::vector<bool> > & flags,
162 ms_peptide_quant_key_vector & keys) const;
163
165 std::vector<double> getAllProteinRatios(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
166
168 std::vector<std::vector<bool> > getAllProteinRatioFlags(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
169
171 void setQuantNormalisation(const ms_quant_normalisation *norm);
172
174 bool hasPeptideRatioNormalisation() const;
175
177 void normalisePeptideRatios();
178
180 std::vector<double> getComponentIntensities(const ms_peptide_quant_key &key, bool raw = false) const;
181
183 void includeProteinPeptideRatioKeys(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys);
184
186 void excludeProteinPeptideRatioKeys(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &excludeKeys);
187
189 std::vector<std::string> getReportRatioNamesInFile(unsigned int fileNum) const;
190
192 const ms_quant_ratio* getReportRatioFromFile(unsigned int fileNum, const std::string &ratioName) const;
193
195 void setReportRatioInFile(unsigned int fileNum, const std::string &ratioName, const ms_quant_ratio &ratioDef);
196
198 void removeReportRatioInFile(unsigned int fileNum, const std::string &ratioName);
199
200
202 std::vector<std::string> getCombinedReportRatioNames() const;
203
205 const ms_quant_ratio* getCombinedReportRatio(const std::string &ratioName) const;
206
208 void removeCombinedReportRatio(const std::string &ratioName);
209
211 void setCombinedReportRatio(const std::string &ratioName, const ms_quant_ratio &ratioDef);
212
214 double getIntensityNormalisationBase(const std::string &componentName) const;
215
217 void setIntensityNormalisationBase(const std::string &componentName, double b);
218
220 void removeIntensityNormalisationBase(const std::string &componentName);
221
223 void removeIntensityNormalisationBases();
224
226 bool hasIntensityNormalisation() const;
227
229 void normaliseIntensities();
230
232 bool loadCdbFile(const char* path);
233
235 bool loadCdbFiles(const std::vector<std::string> & cdbFiles);
236
238 bool saveXmlFile(const std::string & xmlFilename, bool completeReport);
239
241 bool saveCdbFile(const std::string & cdbFilename);
242
244 using ms_quantitation::countDistinctPeptides;
245
246#ifndef SWIG
248 virtual int countDistinctPeptides(const std::vector<ms_peptide_quant_key> & activeKeys) const;
249#endif
250 protected:
251 virtual void getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set<ms_peptide_quant_key> &keys, const std::set<ms_peptide_quant_key> &includeKeys, const std::set<ms_peptide_quant_key> &excludeKEys, std::vector<double> &values, std::vector<double> &weights, std::vector<ms_peptide_quant_key> &activeKeys, std::map<ms_peptide_quant_key, int> &inactiveKeys) const;
252
253
254 private:
255 // No copying.
256 ms_ms2quantitation(const ms_ms2quantitation &copyFrom);
257 ms_ms2quantitation& operator=(const ms_ms2quantitation &right);
258
259 enum SUPPORTED_PROTEIN_RATIO_TYPE {
260 PROTEIN_RATIO_TYPE_MEDIAN = 0,
261 PROTEIN_RATIO_TYPE_AVERAGE,
262 PROTEIN_RATIO_TYPE_WEIGHTED
263 };
264
265 int proteinRatioType_;
266
267 const ms_peptidesummary &pepsum_;
268 const unsigned int numResfiles_;
269
270 std::vector<std::string> componentNames_;
271 std::vector<double>::size_type numComponents_;
272
273 std::vector<double> componentIntensityNormalisationBase_;
274 bool normaliseComponentIntensities_;
275
276 bool renormaliseOnDemand_;
277
278 std::map<ms_peptide_quant_key, bool> peptideQuantKeyQualityTest_;
279 bool testPeptideQuantKeyUniqueness_;
280 bool testedAllKeysForNormalisation_;
281 ms_quant_helper *quantHelper_;
282
283 typedef std::map< std::string, std::set<ms_peptide_quant_key> > ratio_name_to_peptide_quant_key_exclusion_t;
284 std::vector< ratio_name_to_peptide_quant_key_exclusion_t > isPeptideQuantKeyExcluded_;
285
286 bool useCanonicalQPvalues_;
287
288 typedef std::pair<int, int> qp_t;
289 qp_t keyToCanonicalQP(const ms_peptide_quant_key &key) const;
290 int rankToCanonicalRank(int p) const;
291
292 std::vector<double> loadIntensities(const ms_peptide_quant_key &key) const;
293 std::vector<double> loadIntensities(int q, int p) const;
294
295 static const unsigned int FILENUM_LOWER_BOUND;
296 static const unsigned int FILENUM_UPPER_BOUND;
297
298 typedef std::pair<std::string, unsigned int> ratio_name_and_file_index_t;
299 typedef std::set<ratio_name_and_file_index_t> ratio_name_in_files_t;
300 ratio_name_in_files_t ratioNamesInFiles_;
301
302 typedef std::list<ms_quant_ratio> quant_ratio_list_t;
303 std::vector<quant_ratio_list_t> fileToQuantRatioList_;
304
305 std::vector<msparser_internal::ms_ms2ratiocalculator> ratioCalculators_;
306
307 typedef std::map<std::string, std::set<ms_peptide_quant_key> > sequence_to_peptide_quant_key_t;
308 sequence_to_peptide_quant_key_t sequencePeptideQuantKeys_;
309 std::map<ms_peptide_quant_key, std::string> peptideQuantKeySequence_;
310
311 typedef std::pair<protein_key_t, std::string> protein_ratio_key_t;
312 typedef std::map<protein_ratio_key_t, ms_peptide_quant_key_vector> user_prot_to_pept_quantkey_override_t;
313 // used to record protein match-peptide keys which have been user excluded
314 user_prot_to_pept_quantkey_override_t userExcludedKeys_;
315 // used to record protein match-peptide keys which have been user included
316 user_prot_to_pept_quantkey_override_t userIncludedKeys_;
317
318 void fixRatioSourceRemovalInQM(const std::string &ratioName);
319 void setRatioContentInQM(const std::string &ratioName, unsigned int fileNum);
320
321 bool calculateUnnormalisedPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName, int *fileNum, bool *isInfinite, double *value) const;
322
323 void setQuantNormalisationOnly(const ms_quant_normalisation *norm);
324
325 double calculatePeptideNormalisationBase(const std::string &ratioName) const;
326 std::map<std::string, double> calculatePeptideNormalisationBases() const;
327 std::list<ms_peptide_quant_key> selectKeysForNormalisation(const ms_quant_normalisation *norm);
328 void selectAllKeysForNormalisation(std::map<int, std::pair<int, ms_peptide_quant_key> > &query_keys);
329 std::vector<double> normalisedComponentIntensities(const std::vector<double> &intensities) const;
330
331 bool initialiseReportRatios();
332
333 bool initialiseQuantHelper();
334
335 void setReportRatioInFileOnly(unsigned int fileNum, const std::string &ratioName, const ms_quant_ratio &ratioDef);
336 void setReportRatioInFileOnly(unsigned int fileNum, const std::string &ratioName, const ms_quant_ratio &ratioDef, std::string &oldName, std::string &newName);
337
338 bool removeReportRatioInFileOnly(unsigned int fileNum, const std::string &ratioName);
339
340 std::map<ms_peptide_quant_key, bool>::const_iterator testPeptideQuantKeyQuality(int q, int p, const ms_peptide_quant_key &key);
341 void initialiseProteinPeptideMapping(const std::string &accession, int dbIdx);
342
343 bool savePeptideGroupingToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const matrix_science::ms_protein * protein, int hitId, int memberNumber) const;
344
345 bool savePeptideMatchXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & root, const ms_peptide_quant_key & key, long matchid) const;
346
347 bool saveEmptyMatrixXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & parent, const std::string matrixName) const;
348
349 bool savePeptideRatioToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const ms_peptide_quant_ratio ratio, const ms_protein * protein = NULL) const;
350
351 bool saveProteinHitRatiosToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const ms_protein * protein, int q, int p) const;
352
354 bool isPeptideRatioUserExcluded(const ms_protein * protein, const std::string & ratioName, const ms_peptide_quant_key & key) const;
355
357 bool isPeptideRatioUserIncluded(const ms_protein * protein, const std::string & ratioName, const ms_peptide_quant_key & key) const;
358
360 static void saveResfileDetailsToCdb(ms_tinycdb & cdbFile, const ms_mascotresfilebase& resfile);
361
363 static bool readCdbCounterData(ms_tinycdb & cdbFile, unsigned & count);
364
365 static bool readUserRatioStream(ms_tinycdb & cdbFile, const unsigned & index, std::string & accession, int & db, std::string & ratio, ms_peptide_quant_key_vector & included, ms_peptide_quant_key_vector & excluded);
366 }; // end of quantitation_group
368} // matrix_science namespace
369
370#endif // MS_MS2QUANTITATION_HPP
371
372/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customquantitation
Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings.
Definition: ms_customquantitation.hpp:119
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_ms2quantitation
Peptide and protein quantitation in a Reporter or Multiplex Mascot results file.
Definition: ms_ms2quantitation.hpp:127
matrix_science::ms_peptide_quant_key_vector
A vector of peptide quant keys.
Definition: ms_peptide_quant_key_vector.hpp:47
matrix_science::ms_peptide_quant_key
Feature key identifying a peptide ratio.
Definition: ms_peptide_quant_key.hpp:69
matrix_science::ms_peptide_quant_ratio
Peptide abundance in one component relative to another in a quantitation experiment.
Definition: ms_peptide_quant_ratio.hpp:61
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_protein_quant_ratio
Protein abundance in one component relative to another in a quantitation experiment,...
Definition: ms_protein_quant_ratio.hpp:72
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_helper
Helper routines for peptide quantitation.
Definition: ms_quant_helper.hpp:50
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_quant_normalisation
An object of this class represent a single normalisation element in quantitation.xml.
Definition: ms_quant_normalisation.hpp:42
matrix_science::ms_quant_outliers
An object of this class represent a single OUTLIERS element in quantitation.xml.
Definition: ms_quant_outliers.hpp:44
matrix_science::ms_quant_ratio
Represents the ratioType type for the report_ratio element in quantitation.xml.
Definition: ms_quant_ratio.hpp:41
matrix_science::ms_quantitation
Base class for peptide and protein quantitation.
Definition: ms_quantitation.hpp:138
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_ms2ratiocalculator.hpp Source File

  • src
  • resfile
ms_ms2ratiocalculator.hpp
1/*
2##############################################################################
3# file: ms_ms2ratiocalculator.hpp #
4# 'msparser' toolkit #
5# Ratio calculation helper class for ms_ms2ratiocalculator #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author$ #
12# $Date$ #
13# $Revision$ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_MS2RATIOCALCULATOR_HPP
19#define MS_MS2RATIOCALCULATOR_HPP
20
21#include <map>
22#include <string>
23#include <vector>
24#include <utility>
25
26namespace matrix_science {
27 class ms_quant_ratio;
28 class ms_quant_numerator;
29}
30
31namespace msparser_internal {
32 using namespace matrix_science;
33
34 class MS_MASCOTRESFILE_API ms_ms2ratiocalculator
35 {
36 public:
37 ms_ms2ratiocalculator(const std::vector<std::string> &componentNames);
38
39 ms_ms2ratiocalculator(const ms_ms2ratiocalculator &copyFrom);
40#ifndef SWIG
41 ms_ms2ratiocalculator& operator=(const ms_ms2ratiocalculator &right);
42#endif
43 void copyFrom(const ms_ms2ratiocalculator *src);
44
45 virtual ~ms_ms2ratiocalculator();
46
47 void removeRatio(const std::string &ratioName);
48 void setRatio(const std::string &ratioName, const ms_quant_ratio &ratioDef);
49
50 bool calculateRatio(const std::string &ratioName, const std::vector<double> &intensities, bool *isInfinite, double *value) const;
51
52 private:
53 std::vector<std::string>::size_type numComponents_;
54 std::vector<std::string> componentNames_;
55
56 typedef std::vector<double> coefficients_t;
57 typedef std::pair<coefficients_t, coefficients_t> ratio_coefficients_t;
58 std::map<std::string, ratio_coefficients_t> ratioCoefficients_;
59
60 long componentNameToIndex(const std::string &name) const;
61 double parseCoefficient(const ms_quant_numerator *numer) const;
62 };
63} // matrix_science namespace
64
65#endif // MS_MS2RATIOCALCULATOR_HPP
66
67/*------------------------------- End of File -------------------------------*/
68
matrix_science::ms_quant_numerator
Represent numerator_component and denominator_component elements.
Definition: ms_quant_numerator.hpp:40
matrix_science::ms_quant_ratio
Represents the ratioType type for the report_ratio element in quantitation.xml.
Definition: ms_quant_ratio.hpp:41
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_msr2dat28.hpp Source File

  • inc
ms_msr2dat28.hpp
1/*
2##############################################################################
3# file: ms_msr2dat28.hpp #
4# 'msparser' toolkit #
5# Converter from MSR to .dat results file format
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: villek@matrixscience.com $
12# $Date: 2024-09-23 15:56:03 +0100 $
13# $Revision: 09156baa48968c2f3ca3f6899bf06cc9caec40b7 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
14##############################################################################
15*/
16
17#ifndef MS_MSR2DAT28_HPP
18#define MS_MSR2DAT28_HPP
19
20#include <list>
21#include <string>
22
23
24namespace msparser_internal {
25 class ms_msr2dat28_impl;
26}
27
28namespace matrix_science {
29 class ms_mascotresfile_msr;
30
37
68 class MS_MASCOTRESFILE_API ms_msr2dat28 : public ms_errors
69 {
70 public:
72 explicit ms_msr2dat28(const ms_mascotresfile_msr &resfile);
73
74 ~ms_msr2dat28();
75
77 bool isConversionSupported() const;
78
80 void includeIndexSection(bool maybe);
81
83 bool isIndexSectionIncluded() const;
84
86 void includeQuerySectionIonsLines(bool maybe);
87
89 bool isQuerySectionIonsLinesIncluded() const;
90
92 void rewind();
93
95 int getCurrentLineNumber() const;
96
98 std::string getNextLine();
99
100 private:
101 ms_msr2dat28();
102
103 private:
104 const ms_mascotresfile_msr &resfile_;
105 std::unique_ptr<msparser_internal::ms_msr2dat28_impl> impl_;
106
107 }; // end of resfile_group
109} // matrix_science namespace
110
111#endif // MS_MSR2DAT28_HPP
112
113/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_mascotresfile_msr
Class for parsing and reading files in MSR format.
Definition: ms_mascotresfile_msr.hpp:105
matrix_science::ms_msr2dat28
This class converts a Mascot Search Results (MSR) file to legacy .dat format.
Definition: ms_msr2dat28.hpp:69
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_msr2dat28_impl.hpp Source File

  • src
  • resfile
  • impl
ms_msr2dat28_impl.hpp
1/*
2##############################################################################
3# file: ms_msr2dat28_impl.hpp #
4# 'msparser' toolkit #
5# Implementation of converter from MSR to .dat results file format
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author$
12# $Date$
13# $Revision$
14##############################################################################
15*/
16
17#ifndef MS_MSR2DAT28_IMPL_HPP
18#define MS_MSR2DAT28_IMPL_HPP
19
20#include <list>
21#include <string>
22
23
24namespace matrix_science {
25 class ms_zip;
26}
27
28namespace msparser_internal {
29 class ms_sqlpp11_connection;
30 class ms_dat28generator;
31 class ms_dat28indexer;
32 class ms_msr_legacy_blob_stream;
33
35
42
61 class MS_MASCOTRESFILE_API ms_msr2dat28_impl : public matrix_science::ms_errors
62 {
63 public:
64 typedef std::function< std::shared_ptr<matrix_science::ms_inputquery>(int q) > GenerateInputQueryFunctor;
65
67 explicit ms_msr2dat28_impl(matrix_science::ms_errs *errs_parent, ms_sqlpp11_connection &db, int numQueries, GenerateInputQueryFunctor generateInputQuery);
68
69 ~ms_msr2dat28_impl();
70
72 bool isConversionSupported() const;
73
75 void includeIndexSection(bool maybe);
76
78 bool isIndexSectionIncluded() const;
79
81 void includeQuerySectionIonsLines(bool maybe);
82
84 bool isQuerySectionIonsLinesIncluded() const;
85
87 void rewind();
88
90 int getCurrentLineNumber() const { return lineNumber_; }
91
93 std::string getNextLine();
94
95 private:
96 ms_msr2dat28_impl();
97
98 int getNumQueries() const { return numQueries_; }
99 matrix_science::ms_errs* getLogger() const;
100
101 void advanceLineNumber() { ++lineNumber_; }
102
103 bool getNextBlobLine(std::string &);
104 bool getNextQuerySectionLine(std::string &);
105 bool getNextIndexSectionLine(std::string &);
106 bool getEofMarkerOnce(std::string &);
107
108 void generateNextQuerySection();
109
110 enum PARSING_STATE {
111 LEGACY_BLOB_CONTENTS = 0,
112 QUERY_SECTIONS = 1,
113 INDEX_SECTION = 2,
114 END_OF_FILE = 3
115 };
116
117 PARSING_STATE getParsingState() const { return parsingState_; }
118 void moveToQuerySections() { parsingState_ = QUERY_SECTIONS; }
119 void moveToIndexSection();
120 void moveToEof() { parsingState_ = END_OF_FILE; }
121
122 private:
123 bool includeIndexSection_;
124
125 PARSING_STATE parsingState_;
126 int lineNumber_;
127
128 std::unique_ptr<msparser_internal::ms_msr_legacy_blob_stream> blobStream_;
129
130 std::unique_ptr<msparser_internal::ms_dat28generator> dat28generator_;
131 std::string mimeFormatEndLineOnce_;
132
133 const int numQueries_;
134 GenerateInputQueryFunctor generateInputQuery_;
135 int querySectionNumber_;
136 std::list<std::string> querySectionLines_;
137
138 std::unique_ptr<msparser_internal::ms_dat28indexer> dat28indexer_;
139 std::list<std::string> indexLines_;
140
141 }; // end of resfile_group
143
145
146} // msparser_internal namespace
147
148#endif // MS_MSR2DAT28_IMPL_HPP
149
150/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_msr_legacy_blob_stream.hpp Source File

  • src
  • resfile
  • impl
ms_msr_legacy_blob_stream.hpp
1/*
2##############################################################################
3# file: ms_msr_legacy_blob_stream.hpp #
4# 'msparser' toolkit #
5# Private helper class for ms_msr2dat28
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author$
12# $Date$
13# $Revision$
14##############################################################################
15*/
16
17#ifndef MS_MSR_LEGACY_BLOB_STREAM_HPP
18#define MS_MSR_LEGACY_BLOB_STREAM_HPP
19
20#include <string>
21
22namespace matrix_science {
23 class ms_errs;
24}
25
26namespace msparser_internal {
28
34 class ms_sqlpp11_connection;
35
37
47 class MS_MASCOTRESFILE_API ms_msr_legacy_blob_stream : public matrix_science::ms_errors
48 {
49 public:
51 ms_msr_legacy_blob_stream(ms_sqlpp11_connection &db);
52
53 ~ms_msr_legacy_blob_stream();
54
56 bool isConversionSupported() const;
57
59 void reset();
60
62 bool getNextBlobLine(std::string &result);
63
65 static bool checkConversionPossibility(ms_sqlpp11_connection &db, matrix_science::ms_errs *errs, matrix_science::ms_errs *logger);
66
67 private:
68 matrix_science::ms_errs* getLogger() const;
69
71 std::string getNextBlobData();
72
73 int maxChunkIndex() const { return maxChunkIndex_; }
74
75 private:
76 std::unique_ptr<matrix_science::ms_errs> logger_;
77
78 ms_sqlpp11_connection &db_;
79
80 bool isConversionSupported_;
81
82 int blobChunkIndex_;
83 int maxChunkIndex_;
84 std::unique_ptr<matrix_science::ms_zip> zipper_;
85 std::string zipperBuffer_;
86 size_t bufLineStart_;
87
88 }; // end of resfile_group
90
92
93} // msparser_internal namespace
94
95#endif // MS_MSR_LEGACY_BLOB_STREAM_HPP
96
97/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_obofile.hpp Source File

  • inc
ms_obofile.hpp
1/*
2##############################################################################
3# File: ms_obofile.hpp #
4# Mascot Parser toolkit #
5# Utility functions for accessing ontology files in the .obo format #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2008 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source: parser/inc/ms_obofile.hpp $
12# $Author: villek@matrixscience.com $
13# $Date: 2018-07-30 16:23:53 +0100 $
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_OBOFILE_HPP
20#define MS_OBOFILE_HPP
21
22
23#include <string>
24#include <vector>
25#include <map>
26
27namespace matrix_science {
34
42 class MS_MASCOTRESFILE_API ms_obofile: public ms_errors
43 {
44 public:
46 ms_obofile();
47
49 ms_obofile(const char * oboFileName);
50
52 ms_obofile(const ms_obofile& right);
53
55 ~ms_obofile();
56
57#ifndef SWIG
59 ms_obofile& operator=(const ms_obofile& right);
60#endif
62 void copyFrom(const ms_obofile* right);
63
65 void defaultValues();
66
68 std::vector<std::string> getItemFromId(const char * id) const;
69
71 std::string findIDFromTagValue(const char * tag, const char * value) const;
72
74 void parseLine(const std::string str, std::string & tag, std::string & value, std::string & comment) const;
75
77 int getNumberOfEntries() const;
78
79
80 private:
81 void clearOntology();
82 typedef std::vector<std::string> ontologyItem_t;
83 typedef std::map<std::string, ontologyItem_t> ontology_t;
84 ontology_t ontology_;
85
86 }; // class ms_obofile // end of config_group
88} // namespace matrix_science
89
90#endif // MS_OBOFILE_HPP
91
92/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_obofile
The class provides simplified access to ontology files in the .obo format.
Definition: ms_obofile.hpp:43
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_parserule.hpp Source File

  • inc
ms_parserule.hpp
1/*
2##############################################################################
3# file: ms_parserule.hpp #
4# 'msparser' toolkit #
5# Represents PARSE section of mascot.dat file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_parserule.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PARSERULE_HPP
20#define MS_PARSERULE_HPP
21
22
23#include <string>
24
25
26namespace matrix_science {
33
37 class MS_MASCOTRESFILE_API ms_parserule
38 {
39 friend class ms_datfile;
40 friend class ms_parseoptions;
41 friend class ms_spectral_lib_file;
42
43 public:
45 ms_parserule();
46
48 ms_parserule(const ms_parserule& src);
49
51 ~ms_parserule();
52
54 void defaultValues();
55
57 void copyFrom(const ms_parserule* right);
58
59#ifndef SWIG
61 ms_parserule& operator=(const ms_parserule& right);
62#endif
64 bool isAvailable() const;
65
67 void setAvailable(const bool value);
68
70 std::string getRuleStr() const;
71
73 void setRuleStr(const char* str);
74
75 private:
76 bool available_;
77 std::string szRule_;
78
79 void *compiledExp_;
80 void compileAccessionRegex(ms_errs* pErr);
81 std::string regexStr(const char * input, ms_errs * pErr, bool reportErrorIfNoMatch) const;
82
83 };// class ms_parserule
84
86
101 class MS_MASCOTRESFILE_API ms_parseoptions : public ms_customproperty
102 {
103 friend class ms_datfile;
104 public:
106 ms_parseoptions();
107
109 ms_parseoptions(const ms_parseoptions& src);
110
112 ~ms_parseoptions();
113
115 void defaultValues();
116
118 void copyFrom(const ms_parseoptions* right);
119
120#ifndef SWIG
122 ms_parseoptions& operator=(const ms_parseoptions& right);
123#endif
125 bool isSectionAvailable() const;
126
128 void setSectionAvailable(const bool value);
129
131 int getNumberOfParseRules() const;
132
134 void clearParseRules();
135
137 const ms_parserule* getParseRule(const int index) const;
138
140 void setParseRule(const int index, const ms_parserule* rule);
141
143 void dropParseRule(const int index);
144
145 int findOrAddParseRule(const char * rule, bool & added);
146
147#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
148#include "suppress_ms_customproperty.hpp"
149#endif
150
151 private:
152 bool sectionAvailable_;
153 ms_parserule *parseRules_;
154 }; // end of config_group
156} // namespace matrix_science
157
158#endif // MS_PARSERULE_HPP
159
160/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_parseoptions
Represents the PARSE section of mascot.dat.
Definition: ms_parserule.hpp:102
matrix_science::ms_parserule
Represents a single regular expression parsing rule.
Definition: ms_parserule.hpp:38
matrix_science::ms_spectral_lib_file
This class is used to encapsulate a complete NIST .msp, SpectraST .sptxt or X!Hunter ASL MGF file.
Definition: ms_spectral_lib_file.hpp:66
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide.hpp Source File

  • inc
ms_peptide.hpp
1/*
2##############################################################################
3# file: ms_mascotrespeptide.hpp #
4# 'msparser' toolkit #
5# Encapsulates a peptide from the summary section or peptides section of the #
6# mascot results file #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
13# $Author: robertog@matrixscience.com $ #
14# $Date: 2024-09-17 12:39:58 +0100 $ #
15# $Revision: 32680bc4ad9a740ac65e549a795c40e355d93076 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_MASCOTRESPEPTIDE_HPP
21#define MS_MASCOTRESPEPTIDE_HPP
22
23
24// Includes from the standard template library
25#include <string>
26#include <vector>
27
28namespace msparser_internal {
29 class ms_peptide_implbase;
30 class ms_mascotresultsbase;
31}
32
33namespace matrix_science {
34 class ms_protein;
35 class ms_mascotresults;
36 class ms_linker_site;
37 class ms_linker_site_vector;
38
45
56 class MS_MASCOTRESFILE_API ms_peptide
57 {
58 public:
60 ms_peptide();
61
63 ms_peptide( int query,
64 int rank,
65 int missedCleavages,
66 double mrCalc,
67 double delta,
68 double observed,
69 int charge,
70 int numIonsMatched,
71 std::string peptideStr,
72 int peaksUsedFromIons1,
73 std::string varModsStr,
74 double ionsScore,
75 std::string seriesUsedStr,
76 int peaksUsedFromIons2,
77 int peaksUsedFromIons3,
78 const ms_mascotresults * pResults = 0,
79 bool storeReloadableInfo = true);
80
81 enum SEARCH_PHASE {
82 SEARCH_PHASE_PRIMARY = 0,
83 SEARCH_PHASE_ERRTOL = 1,
84 SEARCH_PHASE_LIBRARY = 2
85 };
86
88
98 enum PSM {
99 PSM_COMPLETE = 0,
100 PSM_CROSSLINK_ALPHA = 1,
101 PSM_CROSSLINK_BETA = 2
102 };
103
105
107 enum PSM_TYPE {
108 PSM_STANDARD = 0,
109 PSM_DECOY = 1,
110 PSM_ERRTOL = 2,
111 PSM_ERRTOLDECOY = 3,
112 PSM_LIBRARY = 4,
113 PSM_CROSSLINK = 5,
114
115 N_PSM_TYPES = 6
116 };
117
119 ms_peptide( const int query,
120 const int rank,
121 const SEARCH_PHASE searchPhase,
122 const int missedCleavages,
123 const double mrCalc,
124 const double delta,
125 const double observed,
126 const int charge,
127 const int numIonsMatched,
128 const std::string & peptideStr,
129 const int peaksUsedFromIons1,
130 const std::string & varModsStr,
131 const std::string & summedModsStr,
132 const std::string & localModsStr,
133 const std::string & monoLinkStr,
134 const ms_linker_site_vector & loopLinks,
135 const double ionsScore,
136 const std::string & seriesUsedStr,
137 const int peaksUsedFromIons2,
138 const int peaksUsedFromIons3,
139 const std::string & primaryNlStr,
140 const std::string & summedModsNlStr,
141 const std::string & localModsNlStr,
142 const std::string & substStr,
143 const std::string & componentStr,
144 const ms_mascotresults * pResults = 0,
145 const bool storeReloadableInfo = true);
146
147
149 ms_peptide( const int query,
150 const int rank,
151 const SEARCH_PHASE searchPhase,
152 const double delta,
153 const double observed,
154 const int charge,
155 const int numIonsMatched,
156 const int peaksUsedFromIons1,
157 const double ionsScore,
158 const std::string & seriesUsedStr,
159 const int peaksUsedFromIons2,
160 const int peaksUsedFromIons3,
161 const ms_peptide & pepAlpha,
162 const ms_peptide & pepBeta,
163 const ms_linker_site & linkerSite,
164 const ms_mascotresults * pResults = 0,
165 const bool storeReloadableInfo = true);
166
168 ms_peptide(const ms_peptide& src);
169
170#ifndef SWIG
172 ms_peptide(std::unique_ptr<msparser_internal::ms_peptide_implbase> pImpl);
173#endif
174
176 ~ms_peptide();
177
178#ifndef SWIG
180 ms_peptide& operator=(const ms_peptide& right);
181#endif
183 void copyFrom(const ms_peptide* src);
184
186 bool clearReloadableInfo();
187
188#ifndef SWIG
190 bool getAllProperties(int & outQuery,
191 int & outRank,
192 int & outPrettyRank,
193 int & outMissedCleavages,
194 double & outMrCalc,
195 double & outDelta,
196 double & outObserved,
197 int & outCharge,
198 int & outNumIonsMatched,
199 std::string & outPeptideStr,
200 int & outPeaksUsedFromIons1,
201 std::string & outVarModsStr,
202 std::string & outSummedModsStr,
203 std::string & outLocalModsStr,
204 std::string & outMonoLinkStr,
205 double & outIonsScore,
206 std::string & outSeriesUsedStr,
207 int & outPeaksUsedFromIons2,
208 int & outPeaksUsedFromIons3,
209 std::string & outPrimaryNlStr,
210 std::string & outSummedModsNlStr,
211 std::string & outLocalModsNlStr,
212 std::string & outComponentStr) const;
213#else // SWIG Multiple return values
214 bool getAllProperties(int & OUTPUT,
215 int & OUTPUT,
216 int & OUTPUT,
217 int & OUTPUT,
218 double & OUTPUT,
219 double & OUTPUT,
220 double & OUTPUT,
221 int & OUTPUT,
222 int & OUTPUT,
223 std::string & OUTPUT,
224 int & OUTPUT,
225 std::string & OUTPUT,
226 std::string & OUTPUT,
227 std::string & OUTPUT,
228 std::string & OUTPUT,
229 double & OUTPUT,
230 std::string & OUTPUT,
231 int & OUTPUT,
232 int & OUTPUT,
233 std::string & OUTPUT,
234 std::string & OUTPUT,
235 std::string & OUTPUT,
236 std::string & OUTPUT) const;
237#endif
239 int getQuery() const;
240
242 int getRank() const;
243 void setRank(int rank);
244
246 int getPrettyRank() const;
247 void setPrettyRank(int rank);
248
250 int getAmbiguityGroupId() const;
252 void setAmbiguityGroupId(int group);
253
255 bool getAnyMatch() const;
256
258 int getMissedCleavages(const PSM psmComponent = PSM_COMPLETE) const;
259
261 double getMrCalc(const PSM psmComponent = PSM_COMPLETE) const;
262
264 double getDelta() const;
265
267 double getObserved() const;
268
270 double getMrExperimental() const;
271
273 int getCharge() const;
274
276 int getNumIonsMatched() const;
277
279 std::string getPeptideStr(bool substituteAmbiguous = true, const PSM psmComponent = PSM_COMPLETE) const;
280
282 int getPeptideLength(const PSM psmComponent = PSM_COMPLETE) const;
283
285 int getPeaksUsedFromIons1() const;
286
288 int getPeaksUsedFromIons2() const;
289
291 int getPeaksUsedFromIons3() const;
292
294 std::string getVarModsStr(const PSM psmComponent = PSM_COMPLETE) const;
295
297 void setVarModsStr(const std::string str, const PSM psmComponent = PSM_COMPLETE);
298
300 std::string getSummedModsStr(const PSM psmComponent = PSM_COMPLETE) const;
301
303 void setSummedModsStr(const std::string str, const PSM psmComponent = PSM_COMPLETE);
304
306 std::string getLocalModsStr(const PSM psmComponent = PSM_COMPLETE) const;
307
309 void setLocalModsStr(const std::string str, const PSM psmComponent = PSM_COMPLETE);
310
312 std::string getParsedLocalModsStr(const PSM psmComponent = PSM_COMPLETE) const;
313
315 double getIonsScore() const;
316
318 double getExpectationValue() const;
319
321 std::string getSeriesUsedStr() const;
322
324 bool isSamePeptideStr(ms_peptide * peptide,
325 bool substituteAmbiguous = true) const;
326
328 bool isSameVarModsStr(ms_peptide * peptide) const;
329
331 bool isSameSummedModsStr(ms_peptide * peptide) const;
332
334 int getFirstProtAppearedIn() const;
335
338 void setFirstProtAppearedIn(int n);
339
342 void makeUnassigned();
343
345 double getIonsIntensity() const;
347 void setIonsIntensity(double n);
348
350 const ms_protein * getProtein(int num) const;
351
353 const std::vector<int> getProteins() const;
354
356 int getNumProteins() const;
357 void addProtein(const ms_protein * protein);
358 void addProtein(const int hitNumber);
359
361 std::string getAmbiguityString(const PSM psmComponent = PSM_COMPLETE) const;
363 bool setAmbiguityString(const std::string val, const PSM psmComponent = PSM_COMPLETE);
364
366 std::string getPrimaryNlStr(const PSM psmComponent = PSM_COMPLETE) const;
368 void setPrimaryNlStr(const std::string value, const PSM psmComponent = PSM_COMPLETE);
369
371 std::string getSummedModsNlStr(const PSM psmComponent = PSM_COMPLETE) const;
373 void setSummedModsNlStr(const std::string value, const PSM psmComponent = PSM_COMPLETE);
374
376 std::string getLocalModsNlStr(const PSM psmComponent = PSM_COMPLETE) const;
378 void setLocalModsNlStr(const std::string value, const PSM psmComponent = PSM_COMPLETE);
379
381 std::string getMonoLinkStr(const PSM psmComponent = PSM_COMPLETE) const;
383 void setMonoLinkStr(const std::string value, const PSM psmComponent = PSM_COMPLETE);
384
386 bool getIsFromErrorTolerant() const;
388 void setIsFromErrorTolerant(const bool isFromErrorTolerant);
389
391 std::string getComponentStr(const PSM psmComponent = PSM_COMPLETE) const;
393 void setComponentStr(const std::string value, const PSM psmComponent = PSM_COMPLETE);
394
396 bool getLessThanMinPepLen() const;
397
399 int getNum13C(const double tol, const std::string tolu, const std::string mass_type) const;
400
402 void setPercolatorScores(double posteriorErrorProbability,
403 double qValue,
404 double internalPercolatorScore);
405
407 bool anyPercolatorResults() const;
408
409#ifndef SWIG
411 void getPercolatorScores(double * posteriorErrorProbability,
412 double * qValue,
413 double * internalPercolatorScore,
414 double * mascotIonsScore) const;
415#else // SWIG Multiple return values
416 void getPercolatorScores(double * OUTPUT,
417 double * OUTPUT,
418 double * OUTPUT,
419 double * OUTPUT) const;
420#endif
421
423 bool getIsFromLibrary() const;
425 void setIsFromLibrary(const bool isFromLibrary);
426
428 void getAnyProteinTermination(
429 bool & isNterminus,
430 bool & isCterminus,
431 const PSM psmComponent = PSM_COMPLETE) const;
432
434 void setInternalSortingScore(double s);
435
437 double getInternalSortingScore() const;
438
440 int getNumberOfLinkedPeptides() const;
441
443 void getIntactLinks(ms_linker_site_vector &vec) const;
444
446 ms_linker_site_vector getIntactLinks() const;
447
449 void getLoopLinks(ms_linker_site_vector &vec, const PSM psmComponent = PSM_COMPLETE) const;
450
452 ms_linker_site_vector getLoopLinks(const PSM psmComponent = PSM_COMPLETE) const;
453
454 private:
455 std::unique_ptr<msparser_internal::ms_peptide_implbase> pImpl_;
456 }; // end of resfile_group
458} // matrix_science namespace
459
460#endif // MS_MASCOTRESPEPTIDE_HPP
461
462/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptide::ms_peptide
ms_peptide(const int query, const int rank, const SEARCH_PHASE searchPhase, const double delta, const double observed, const int charge, const int numIonsMatched, const int peaksUsedFromIons1, const double ionsScore, const std::string &seriesUsedStr, const int peaksUsedFromIons2, const int peaksUsedFromIons3, const ms_peptide &pepAlpha, const ms_peptide &pepBeta, const ms_linker_site &linkerSite, const ms_mascotresults *pResults=0, const bool storeReloadableInfo=true)
Constructor to initialise a crosslinked peptide.
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_peptide::ms_peptide
ms_peptide(const int query, const int rank, const SEARCH_PHASE searchPhase, const int missedCleavages, const double mrCalc, const double delta, const double observed, const int charge, const int numIonsMatched, const std::string &peptideStr, const int peaksUsedFromIons1, const std::string &varModsStr, const std::string &summedModsStr, const std::string &localModsStr, const std::string &monoLinkStr, const ms_linker_site_vector &loopLinks, const double ionsScore, const std::string &seriesUsedStr, const int peaksUsedFromIons2, const int peaksUsedFromIons3, const std::string &primaryNlStr, const std::string &summedModsNlStr, const std::string &localModsNlStr, const std::string &substStr, const std::string &componentStr, const ms_mascotresults *pResults=0, const bool storeReloadableInfo=true)
Constructor to initialise all values.
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide_impl_dat.hpp Source File

  • src
  • resfile
  • impl
ms_peptide_impl_dat.hpp
1/*
2##############################################################################
3# file: ms_mascotrespeptide.hpp #
4# 'msparser' toolkit #
5# Encapsulates a peptide from the summary section or peptides section of the #
6# mascot results file #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_PEPTIDE_IMPL_HPP
21#define MS_PEPTIDE_IMPL_HPP
22
23// Includes from the standard template library
24#include <string>
25#include <vector>
26
27#include "ms_peptide_implbase.hpp"
28
29namespace matrix_science {
30 class ms_peptide;
31 class ms_protein;
32 class ms_mascotresults;
33}
34
35namespace msparser_internal {
36
37 class ms_mascotresultsbase;
38
40
41// // Flags are stored in unsigned char, so maximum flag is 0x80.
42// #define FL_IS_FROM_ERROR_TOLERANT 0x01
43// #define FL_LESS_THAN_MIN_PEP_LEN 0x02
44// #define FL_STORE_RELOADABLE_INFO 0x04
45// #define FL_PROTEIN_HITS_IS_VECTOR 0x08
46// #define FL_ANY_MATCH 0x10
47// #define FL_IS_FROM_LIBRARY 0x20
48
49
50
51 class ms_peptide_impl_dat : public ms_peptide_implbase
52 {
53 public:
55 ms_peptide_impl_dat();
56
58 ms_peptide_impl_dat(const msparser_internal::peptide_impl_args & args,
59 const matrix_science::ms_linker_site_vector & loopLinks,
60 const ms_mascotresultsbase * pResults,
61 const bool storeReloadableInfo);
62
63 ms_peptide_impl_dat(const msparser_internal::peptide_impl_args & args,
64 const linearPeptideData_t & concatData,
65 const linearPeptideData_t & linearAlpha,
66 const linearPeptideData_t & linearBeta,
67 const matrix_science::ms_linker_site & linkerSite,
68 const ms_mascotresultsbase * pResults,
69 const bool storeReloadableInfo);
70
71 ms_peptide_impl_dat(const ms_peptide_impl_dat& src);
72
73 ~ms_peptide_impl_dat();
74
75 ms_peptide_impl_dat& operator=(const ms_peptide_impl_dat& right);
76
77 std::unique_ptr<ms_peptide_implbase> clone() const override;
78
79
80
81 private:
82
83 bool checkNonPersist() const override;
84
85 std::string serialiseLinearPeptideToCDB(const int missedCleavages,
86 const double mrCalc,
87 const double delta,
88 const double observed,
89 const int charge,
90 const int numIonsMatched,
91 const std::string & peptideStr,
92 const int peaksUsedFromIons1,
93 const std::string & varModsStr,
94 const std::string & summedModsStr,
95 const std::string & localModsStr,
96 const std::string & monoLinkStr,
97 const matrix_science::ms_linker_site_vector & loopLinks,
98 //const double ionsScore,
99 const std::string & seriesUsedStr,
100 const int peaksUsedFromIons2,
101 const int peaksUsedFromIons3,
102 const std::string & primaryNlStr,
103 const std::string & summedModsNlStr,
104 const std::string & localModsNlStr,
105 const std::string & substStr,
106 const std::string & componentStr,
107 const std::string & parsedLocalModsStr) const;
108
109 void parseLinearPeptideFromCDB(const ms_peptidesummary_dat *pPepSum,
110 const std::string &val) const;
111
112 std::string serialiseCrossLinkedPeptideToCDB(const double delta,
113 const double observed,
114 const int charge,
115 const int numIonsMatched,
116 const int peaksUsedFromIons1,
117 const std::string & seriesUsedStr,
118 const int peaksUsedFromIons2,
119 const int peaksUsedFromIons3,
120 const linearPeptideData_t &linearAlpha,
121 const linearPeptideData_t &linearBeta,
122 const matrix_science::ms_linker_site &linkerSite) const;
123
124 void parseCrossLinkedPeptideFromCDB(const ms_peptidesummary_dat *pPepSum,
125 const std::string &val,
126 const int query) const;
127
128 };
129
131
132} // msparser_internal namespace
133
134#endif // MS_PEPTIDE_IMPL_HPP
135
136/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide_impl_msr.hpp Source File

  • src
  • resfile
  • impl
ms_peptide_impl_msr.hpp
1/*
2##############################################################################
3# file: ms_peptide_impl_msr.hpp #
4# 'msparser' toolkit #
5# #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_PEPTIDE_IMPL_MSR_HPP
21#define MS_PEPTIDE_IMPL_MSR_HPP
22
23// Includes from the standard template library
24#include <string>
25#include <vector>
26
27#include "ms_peptide_implbase.hpp"
28
29namespace matrix_science {
30 class ms_peptide;
31 class ms_protein;
32}
33
34namespace msparser_internal {
35
36 class ms_mascotresults_msr;
37
39
40 class ms_peptide_impl_msr : public ms_peptide_implbase
41 {
42 public:
44 ms_peptide_impl_msr() = delete;
45
47 ms_peptide_impl_msr(const msparser_internal::peptide_impl_args & args,
48 const matrix_science::ms_linker_site_vector & loopLinks,
49 const ms_mascotresultsbase * pResults);
50
51 ms_peptide_impl_msr(const msparser_internal::peptide_impl_args & args,
52 const linearPeptideData_t & concatData,
53 const linearPeptideData_t & linearAlpha,
54 const linearPeptideData_t & linearBeta,
55 const matrix_science::ms_linker_site & linkerSite,
56 const ms_mascotresultsbase * pResults);
57
58 ms_peptide_impl_msr(const ms_peptide_impl_msr& src);
59
60 ~ms_peptide_impl_msr() = default;
61
62 std::unique_ptr<ms_peptide_implbase> clone() const override;
63
64 bool checkNonPersist() const override;
65
66 private:
67
68 // int query_;
69 // char rank_;
70 // char prettyRank_;
71 // int ambiguityGroupId_;
72 // unsigned char flags_;
73
74 // std::unique_ptr<ms_peptide_impl_reloadable> pReloadable_;
75
76 // double delta_;
77 // double observed_;
78 // int charge_;
79 // int numIonsMatched_;
80 // int peaksUsedFromIons1_;
81 // std::string seriesUsedStr_;
82 // int peaksUsedFromIons2_;
83 // int peaksUsedFromIons3_;
84 // double ionsIntensity_;
85 };
86
88
89} // msparser_internal namespace
90
91#endif // MS_PEPTIDE_IMPL_MSR_HPP
92
93/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide_impl_nil.hpp Source File

  • src
  • resfile
  • impl
ms_peptide_impl_nil.hpp
1/*
2##############################################################################
3# file: ms_peptide_impl_nil.hpp #
4# 'msparser' toolkit #
5# #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2022 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_PEPTIDE_IMPL_NIL_HPP
21#define MS_PEPTIDE_IMPL_NIL_HPP
22
23// Includes from the standard template library
24#include <string>
25#include <vector>
26
27#include "ms_peptide_implbase.hpp"
28
29namespace matrix_science {
30 class ms_peptide;
31 class ms_protein;
32 class ms_mascotresults;
33}
34
35namespace msparser_internal {
36
37 class ms_peptide_impl_nil : public ms_peptide_implbase
38 {
39 public:
40
41 void copyFrom(const ms_peptide_impl_nil * src) {}
42
43 std::unique_ptr<ms_peptide_implbase> clone() const override { return std::move( std::unique_ptr<ms_peptide_impl_nil>{ new ms_peptide_impl_nil{*this} } ); }
44
45 bool checkNonPersist() const override { return false; }
46 bool clearReloadableInfo() override { return false; }
47 int getQuery() const override { return 0; }
48 int getRank() const override { return 0; }
49 void setRank(int rank) override {}
50 int getPrettyRank() const override { return 0; }
51 void setPrettyRank(int rank) override {}
52 int getAmbiguityGroupId_() const override { return 0; }
53 void setAmbiguityGroupId_(int group) override {}
54
55 bool getAnyMatch() const override { return false; }
56 int getMissedCleavages(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return -1; }
57 double getMrCalc(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return 0; }
58 double getDelta() const override { return 0; }
59 double getObserved() const override { return 0; }
60 double getMrExperimental() const override { return 0; }
61 int getCharge() const override { return 0; }
62 int getNumIonsMatched() const override { return -1; }
63 std::string getPeptideStr(const bool substituteAmbiguous = true) const override { return {}; }
64 std::string getPeptideStr(const matrix_science::ms_peptide::PSM entity, const bool substituteAmbiguous = true) const override { return {}; }
65 int getPeptideLength(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return -1;}
66 int getPeaksUsedFromIons1() const override { return -1; }
67 int getPeaksUsedFromIons2() const override { return -1; }
68 int getPeaksUsedFromIons3() const override { return -1; }
69 std::string getVarModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return {}; }
70 void setVarModsStr(const std::string & str, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) override {}
71 std::string getSummedModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return {}; }
72 void setSummedModsStr(const std::string & str, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) override {}
73 std::string getLocalModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return {}; }
74 void setLocalModsStr(const std::string & str, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) override {}
75 std::string getMonoLinkStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return {}; }
76 void setMonoLinkStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) override {}
77 std::string getParsedLocalModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return {}; }
78 double getIonsScore() const override { return 0; }
79 double getExpectationValue() const override { return 0; }
80 std::string getSeriesUsedStr() const override { return {}; }
81 bool isSamePeptideStr(const ms_peptide_implbase * pImpl, const bool substituteAmbiguous = true) const override { return false; }
82 bool isSameVarModsStr(const ms_peptide_implbase * pImpl) const override { return false; }
83 bool isSameSummedModsStr(const ms_peptide_implbase * pImpl) const override { return false; }
84 int getFirstProtAppearedIn() const override { return 0; }
85 void setFirstProtAppearedIn(int n) override {}
86 void makeUnassigned() override {}
87 double getIonsIntensity() const override { return 0; }
88 void setIonsIntensity(double n) override {}
89 const matrix_science::ms_protein * getProtein(int num) const override { return nullptr; }
90 const std::vector<int> getProteins() const override { return std::vector<int>(); }
91 int getNumProteins() const override { return -1; }
92 std::string getAmbiguityString(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return {}; }
93 bool setAmbiguityString(const std::string & val, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) override { return false; }
94 void addProtein(const matrix_science::ms_protein * protein) override {}
95 void addProtein(const int hitNumber) override {}
96 std::string getPrimaryNlStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return {}; }
97 void setPrimaryNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) override {}
98 std::string getSummedModsNlStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return {}; }
99 void setSummedModsNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) override {}
100 std::string getLocalModsNlStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return {}; }
101 void setLocalModsNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) override {}
102 bool isFlagSet(unsigned char fl) const override { return false; }
103 void setFlag(unsigned char fl, bool val) override {}
104 bool getIsFromErrorTolerant() const override { return false; }
105 void setIsFromErrorTolerant(const bool val) override {}
106 std::string getComponentStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override { return {}; }
107 void setComponentStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) override {}
108 bool getLessThanMinPepLen() const override { return false; }
109 int getNum13C(const double tol, const std::string tolu, const std::string & mass_type) const override { return 1; }
110 void setPercolatorScores(double posteriorErrorProbability,
111 double qValue,
112 double internalPercolatorScore) override {}
113 bool anyPercolatorResults() const override { return false; }
114 void getPercolatorScores(double * posteriorErrorProbability,
115 double * qValue,
116 double * internalPercolatorScore,
117 double * mascotIonsScore) const
118 override {
119 *posteriorErrorProbability = 0;
120 *qValue = 0;
121 *internalPercolatorScore = 0;
122 *mascotIonsScore = 0;
123 }
124
125 bool getIsFromLibrary() const override { return false; }
126 void setIsFromLibrary(const bool val) override {}
127 void getAnyProteinTermination(
128 bool & isNterminus,
129 bool & isCterminus,
130 const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const override {}
131
132 void setInternalSortingScore(double s) override {}
133 double getInternalSortingScore() const override { return 0; }
134
135 int getNumberOfLinkedPeptides() const override { return 0; }
136
137 void getIntactLinks(matrix_science::ms_linker_site_vector &vec) const override {}
138 void getLoopLinks(matrix_science::ms_linker_site_vector &vec, const matrix_science::ms_peptide::PSM entity) const override {}
139
140 bool isNilImpl() const override { return true; }
141 };
142
143} // msparser_internal namespace
144
145#endif // MS_PEPTIDE_IMPL_NIL_HPP
146
147/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_peptide::PSM_COMPLETE
@ PSM_COMPLETE
Peptide-spectrum match, also linear peptide in a non-crosslinked match.
Definition: ms_peptide.hpp:99
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide_implbase.hpp Source File

  • src
  • resfile
  • impl
ms_peptide_implbase.hpp
1/*
2##############################################################################
3# file: ms_peptide_implbase.hpp #
4# 'msparser' toolkit #
5# #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_PEPTIDE_IMPLBASE_HPP
21#define MS_PEPTIDE_IMPLBASE_HPP
22
23// Includes from the standard template library
24#include <string>
25#include <vector>
26
27namespace matrix_science {
28 class ms_peptide;
29 class ms_protein;
30 class ms_linker_site;
31 class ms_linker_site_vector;
32 class ms_mascotresults;
33}
34
35namespace msparser_internal {
36
37 class ms_peptide_impl_reloadable;
38
39// Flags are stored in unsigned char, so maximum flag is 0x80.
40#define FL_IS_FROM_ERROR_TOLERANT 0x01
41#define FL_LESS_THAN_MIN_PEP_LEN 0x02
42#define FL_STORE_RELOADABLE_INFO 0x04
43#define FL_PROTEIN_HITS_IS_VECTOR 0x08
44#define FL_ANY_MATCH 0x10
45#define FL_IS_FROM_LIBRARY 0x20
46
47 struct psmData_t
48 {
49 // Peptide-spectrum match data
50 psmData_t() = default;
51
52 psmData_t(const double delta,
53 const double observed,
54 const int charge,
55 const int numIonsMatched,
56 const int peaksUsedFromIons1,
57 const std::string & seriesUsedStr,
58 const int peaksUsedFromIons2,
59 const int peaksUsedFromIons3)
60 : delta(delta), observed(observed), charge(charge),
61 numIonsMatched(numIonsMatched), peaksUsedFromIons1(peaksUsedFromIons1),
62 seriesUsedStr(seriesUsedStr), peaksUsedFromIons2(peaksUsedFromIons2),
63 peaksUsedFromIons3(peaksUsedFromIons3), ionsIntensity(0)
64 {}
65
66 double delta;
67 double observed;
68 int charge;
69 int numIonsMatched;
70 int peaksUsedFromIons1;
71 std::string seriesUsedStr;
72 int peaksUsedFromIons2;
73 int peaksUsedFromIons3;
74 double ionsIntensity;
75 };
76
77 struct peptide_impl_args
78 {
79 int query;
80 int rank;
81 int searchPhase;
82
83 psmData_t* psmData;
84
85 int missedCleavages;
86 double mrCalc;
87 const std::string * peptideStr;
88 const std::string * varModsStr;
89 const std::string * summedModsStr;
90 const std::string * localModsStr;
91 const std::string * monoLinkStr;
92 double ionsScore;
93 const std::string * primaryNlStr;
94 const std::string * summedModsNlStr;
95 const std::string * localModsNlStr;
96 const std::string * substStr;
97 const std::string * componentStr;
98 };
99
100
101 class ms_peptide_implbase
102 {
103 public:
104
105 ms_peptide_implbase();
106
107 ms_peptide_implbase(const msparser_internal::peptide_impl_args & args,
108 const matrix_science::ms_linker_site_vector & loopLinks,
109 const ms_mascotresultsbase * pResults,
110 const bool storeReloadableInfo);
111
112 ms_peptide_implbase(const msparser_internal::peptide_impl_args & args,
113 const linearPeptideData_t & concatData,
114 const linearPeptideData_t & linearAlpha,
115 const linearPeptideData_t & linearBeta,
116 const matrix_science::ms_linker_site & linkerSite,
117 const ms_mascotresultsbase * pResults,
118 const bool storeReloadableInfo);
119
120 virtual ~ms_peptide_implbase() = default;
121
122 virtual std::unique_ptr<ms_peptide_implbase> clone() const;
123
124 virtual bool clearReloadableInfo();
125 virtual int getQuery() const { return query_; }
126 virtual int getRank() const { return rank_; }
127 virtual void setRank(int rank) { rank_ = static_cast<char>(rank); }
128 virtual int getPrettyRank() const { return prettyRank_; }
129 virtual void setPrettyRank(int rank) { prettyRank_ = static_cast<char>(rank); }
130 virtual int getAmbiguityGroupId_() const { return ambiguityGroupId_; }
131 virtual void setAmbiguityGroupId_(int group) { ambiguityGroupId_ = group; }
132
133 virtual bool getAnyMatch() const { return isFlagSet(FL_ANY_MATCH); }
134 virtual int getMissedCleavages(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
135 virtual double getMrCalc(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
136 virtual double getDelta() const;
137 virtual double getObserved() const;
138 virtual double getMrExperimental() const;
139 virtual int getCharge() const;
140 virtual int getNumIonsMatched() const;
141 virtual std::string getPeptideStr(const bool substituteAmbiguous = true) const {
142 return getPeptideStr(matrix_science::ms_peptide::PSM_COMPLETE, substituteAmbiguous);
143 }
144 virtual std::string getPeptideStr(const matrix_science::ms_peptide::PSM entity, const bool substituteAmbiguous = true) const;
145 virtual int getPeptideLength(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
146 virtual int getPeaksUsedFromIons1() const;
147 virtual int getPeaksUsedFromIons2() const;
148 virtual int getPeaksUsedFromIons3() const;
149 virtual std::string getVarModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
150 virtual void setVarModsStr(const std::string & str, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
151 virtual std::string getSummedModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
152 virtual void setSummedModsStr(const std::string & str, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
153 virtual std::string getLocalModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
154 virtual void setLocalModsStr(const std::string & str, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
155 virtual std::string getMonoLinkStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
156 virtual void setMonoLinkStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
157 virtual std::string getParsedLocalModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
158 virtual double getIonsScore() const { return ionsScore_; }
159 virtual double getExpectationValue() const;
160 virtual std::string getSeriesUsedStr() const;
161 virtual bool isSamePeptideStr(const ms_peptide_implbase * pImpl, const bool substituteAmbiguous = true) const;
162 virtual bool isSameVarModsStr(const ms_peptide_implbase * pImpl) const;
163 virtual bool isSameSummedModsStr(const ms_peptide_implbase * pImpl) const;
164 virtual int getFirstProtAppearedIn() const;
165 virtual void setFirstProtAppearedIn(int n);
166 virtual void makeUnassigned();
167 virtual double getIonsIntensity() const;
168 virtual void setIonsIntensity(double n);
169 virtual const matrix_science::ms_protein * getProtein(int num) const;
170 virtual const std::vector<int> getProteins() const;
171 virtual int getNumProteins() const;
172 virtual std::string getAmbiguityString(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
173 virtual bool setAmbiguityString(const std::string & val, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
174 virtual void addProtein(const matrix_science::ms_protein * protein);
175 virtual void addProtein(const int hitNumber);
176 virtual std::string getPrimaryNlStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
177 virtual void setPrimaryNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
178 virtual std::string getSummedModsNlStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
179 virtual void setSummedModsNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
180 virtual std::string getLocalModsNlStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
181 virtual void setLocalModsNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
182
183 virtual std::string getComponentStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
184 virtual void setComponentStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
185 virtual bool getLessThanMinPepLen() const { return isFlagSet(FL_LESS_THAN_MIN_PEP_LEN); }
186 virtual int getNum13C(const double tol, const std::string tolu, const std::string & mass_type) const;
187 virtual void setPercolatorScores(double posteriorErrorProbability,
188 double qValue,
189 double internalPercolatorScore);
190 virtual bool anyPercolatorResults() const;
191 virtual void getPercolatorScores(double * posteriorErrorProbability,
192 double * qValue,
193 double * internalPercolatorScore,
194 double * mascotIonsScore) const;
195
196 virtual bool getIsFromLibrary() const { return isFlagSet(FL_IS_FROM_LIBRARY); }
197 virtual void setIsFromLibrary(const bool val) {
198 if (val)
199 setFlag(FL_IS_FROM_ERROR_TOLERANT, false);
200 setFlag(FL_IS_FROM_LIBRARY, val);
201 }
202
203 virtual void getAnyProteinTermination(
204 bool & isNterminus,
205 bool & isCterminus,
206 const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
207
208 virtual void setInternalSortingScore(double s) { internalSortingScore_ = s; }
209 virtual double getInternalSortingScore() const { return internalSortingScore_; }
210
211 virtual int getNumberOfLinkedPeptides() const;
212
213 virtual void getIntactLinks(matrix_science::ms_linker_site_vector &vec) const;
214 virtual void getLoopLinks(matrix_science::ms_linker_site_vector &vec, const matrix_science::ms_peptide::PSM entity) const;
215
216 virtual bool isFlagSet(unsigned char fl) const { return (flags_ & fl)?true:false; }
217 virtual void setFlag(unsigned char fl, bool val) {
218 if (val) {
219 flags_ |= fl;
220 } else {
221 //standard says complement must promote to int, performance is equal though
222 flags_ = static_cast<unsigned char>(flags_ & ~fl);
223 }
224 }
225
226 virtual bool getIsFromErrorTolerant() const { return isFlagSet(FL_IS_FROM_ERROR_TOLERANT); }
227 virtual void setIsFromErrorTolerant(const bool val) {
228 if (val)
229 setFlag(FL_IS_FROM_LIBRARY, false);
230 setFlag(FL_IS_FROM_ERROR_TOLERANT, val);
231 }
232
233 virtual bool isNilImpl() const { return false; }
234
235 protected:
236
237 ms_peptide_implbase(const ms_peptide_implbase& src) { copyFrom(&src); }
238 ms_peptide_implbase& operator=(const ms_peptide_implbase& right) {
239 copyFrom(&right);
240 return *this;
241 }
242 ms_peptide_implbase(ms_peptide_implbase&&) = default;
243 ms_peptide_implbase& operator=(ms_peptide_implbase&&) = default;
244
245 void copyFrom(const ms_peptide_implbase* src);
246
247 void initProteinHitNumbers();
248 virtual bool checkNonPersist() const { return (pReloadable_) ? true : false; }
249
250 void initFlags(const int searchPhase,
251 const int missedCleavages,
252 const int peptideLengthAlpha,
253 const int peptideLengthBeta,
254 const ms_mascotresultsbase * pResults,
255 const bool storeReloadableInfo);
256
257 struct percolator_t {
258 percolator_t()
259 : posteriorErrorProbability(0),
260 qValue(0),
261 internalPercolatorScore(0),
262 mascotIonsScore(0)
263 {}
264
265 percolator_t(const percolator_t& other) {
266 posteriorErrorProbability = other.posteriorErrorProbability;
267 qValue = other.qValue;
268 internalPercolatorScore = other.internalPercolatorScore;
269 mascotIonsScore = other.mascotIonsScore;
270 }
271
272 double posteriorErrorProbability;
273 double qValue;
274 double internalPercolatorScore;
275 double mascotIonsScore;
276 };
277
278 std::unique_ptr<ms_peptide_impl_reloadable> pReloadable_;
279 const ms_mascotresultsbase * pResults_;
280 std::unique_ptr<percolator_t> percolator_;
281 double ionsScore_;
282 double internalSortingScore_;
283 union {
284 int proteinHitNumbers_[2];
285 std::vector<int> * pProteinHitVect_;
286 };
287 int query_;
288 char rank_;
289 char prettyRank_;
290 int ambiguityGroupId_;
291 unsigned char flags_;
292
293 };
294
295 // Helper function: reset linkFrom and linkTo to the given value.
296 // Other attributes are copied over verbatim.
297 void adjustLoopLinks(const matrix_science::ms_linker_site_vector & src,
298 const matrix_science::ms_peptide::PSM psmComponent,
299 matrix_science::ms_linker_site_vector & target);
300
301 namespace linker_site_utils {
302 // Note: don't use ms_linker_site_vector::stringify() here. We
303 // need to serialise doubles with toHexStr().
304
305 void serialiseLinkerSite(std::ostringstream &value, const matrix_science::ms_linker_site &linkerSite);
306
307 matrix_science::ms_linker_site parseLinkerSite(std::istringstream &iss);
308
309 void serialiseLinkerSiteVector(std::ostringstream &value, const matrix_science::ms_linker_site_vector *linkerSites);
310
311 void parseLinkerSiteVector(std::istringstream &iss, matrix_science::ms_linker_site_vector &linkerSites);
312 }
313
314
315 /* Bug 13047: The peptide object can contain data either
316 * for a linear peptide, or for a crosslinked alpha-beta
317 * pair. The fields of linearPeptideData_t were previously
318 * members of ms_peptide_impl_reloadable.
319 */
320 class linearPeptideData_t {
321 public:
322 linearPeptideData_t();
323
324 linearPeptideData_t(const int missedCleavages,
325 const double mrCalc,
326 const std::string &peptideStr,
327 const std::string &varModsStr,
328 const std::string &summedModsStr,
329 const std::string &localModsStr,
330 const std::string &parsedLocalModsStr,
331 const std::string &monoLinkStr,
332 const matrix_science::ms_linker_site_vector &loopLinks,
333 const std::string &primaryNlStr,
334 const std::string &summedModsNlStr,
335 const std::string &localModsNlStr,
336 const std::string &substStr,
337 const std::string &componentStr);
338
339 linearPeptideData_t(const ms_peptide_impl_reloadable *parent);
340
341 linearPeptideData_t(const linearPeptideData_t &src);
342
343 linearPeptideData_t& operator=(const linearPeptideData_t& right);
344 void copyFrom(const linearPeptideData_t *src);
345
346 ~linearPeptideData_t();
347
348 // Create a concatenated object (alpha + beta).
349 static linearPeptideData_t concat(const linearPeptideData_t &alpha,
350 const linearPeptideData_t &right,
351 const int query,
352 const double linkerMass,
353 const matrix_science::ms_mascotresults *pResults);
354
355 int getMissedCleavages() const { return missedCleavages_; }
356 double getMrCalc() const { return mrCalc_; }
357
358 std::string getPeptideStr(const bool substituteAmbiguous) const;
359 int getPeptideLength() const { return static_cast<int>(peptideStr_.size()); }
360 std::string getVarModsStr() const { return varModsStr_; }
361 std::string getSummedModsStr() const { return summedModsStr_; }
362 void setVarModsStr(const std::string& str) { varModsStr_ = str; }
363 void setSummedModsStr(const std::string& str) { summedModsStr_ = str; }
364
365 std::string getLocalModsStr() const;
366 void setLocalModsStr(const std::string & strRaw, const std::string & strParsed);
367 std::string getParsedLocalModsStr() const;
368
369 std::string getMonoLinkStr() const { return monoLinkStr_; }
370 void setMonoLinkStr(const std::string & value) { monoLinkStr_ = value; }
371
372 std::string getAmbiguityString() const;
373 bool setAmbiguityString(const std::string & val);
374 std::string getPrimaryNlStr() const;
375 void setPrimaryNlStr(const std::string & value);
376 std::string getSummedModsNlStr() const;
377 void setSummedModsNlStr(const std::string & value);
378 std::string getLocalModsNlStr() const;
379 void setLocalModsNlStr(const std::string & value);
380 std::string getComponentStr() const;
381 void setComponentStr(const std::string & value);
382
383 void getLoopLinks(matrix_science::ms_linker_site_vector& vec) const;
384 void setLoopLinks(const matrix_science::ms_linker_site_vector &vec);
385
386 bool isSamePeptideStr(const linearPeptideData_t *right, const bool substituteAmbiguous) const;
387 bool isSameVarModsStr(const linearPeptideData_t *right) const;
388 bool isSameSummedModsStr(const linearPeptideData_t *right) const;
389
390 void serialise(std::ostringstream &value) const;
391 void setFromStream(std::istringstream &iss, const int alphaLen, const int betaLen);
392
393 private:
394 std::string getUnambiguousStr(const std::string val) const;
395
396 int missedCleavages_;
397 double mrCalc_;
398 std::string peptideStr_;
399 std::string varModsStr_;
400 std::string summedModsStr_;
401 std::string monoLinkStr_;
402
403 matrix_science::ms_linker_site_vector * loopLinks_;
404
405 char * primaryNlStr_;
406 char * summedModsNlStr_;
407 char * localModsNlStr_;
408 char * ambiguousStr_; // The subst string
409 char * unambiguousStr_; // The string with all ambiguous residues substituted
410 char * componentStr_;
411
412 struct localMods_t
413 {
414 std::string localModsStr_;
415 std::string parsedLocalModsStr_;
416 };
417
418 localMods_t * localMods_;
419 };
420
421 class ms_peptide_impl_reloadable
422 {
423 public:
424
425 ms_peptide_impl_reloadable();
426 ms_peptide_impl_reloadable(const psmData_t & psmData);
427 ms_peptide_impl_reloadable(const ms_peptide_impl_reloadable& src);
428 virtual ~ms_peptide_impl_reloadable() = default;
429#ifndef SWIG
430 ms_peptide_impl_reloadable& operator=(const ms_peptide_impl_reloadable& right);
431#endif
432 void copyFrom(const ms_peptide_impl_reloadable * src);
433
434 // Careful with initialiseDerivedFrom(): make sure you
435 // have checked with typeid() or dynamic_cast() that *src
436 // has the same dynamic type as *this.
437 virtual void initialiseDerivedFrom(const ms_peptide_impl_reloadable *src) { copyFrom(src); }
438
439 // clone() always returns a base class pointer, but may
440 // allocate a derived class object.
441 virtual std::unique_ptr<ms_peptide_impl_reloadable> clone() const = 0;
442
443 bool getAnyMatch() const { return PSM_data(matrix_science::ms_peptide::PSM_COMPLETE).getMissedCleavages() != -1;}
444 int getMissedCleavages(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getMissedCleavages(); }
445 double getMrCalc(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getMrCalc(); }
446 double getDelta() const { return psm_.delta; }
447 double getObserved() const { return psm_.observed; }
448 double getMrExperimental() const { return PSM_data(matrix_science::ms_peptide::PSM_COMPLETE).getMrCalc() + getDelta(); }
449 int getCharge() const { return psm_.charge; }
450 int getNumIonsMatched() const { return psm_.numIonsMatched; }
451 std::string getPeptideStr(const bool substituteAmbiguous, const matrix_science::ms_peptide::PSM entity) const {
452 return PSM_data(entity).getPeptideStr(substituteAmbiguous);
453 }
454 int getPeptideLength(const matrix_science::ms_peptide::PSM entity) const { return static_cast<int>(PSM_data(entity).getPeptideLength()); }
455 int getPeaksUsedFromIons1() const { return psm_.peaksUsedFromIons1; }
456 int getPeaksUsedFromIons2() const { return psm_.peaksUsedFromIons2; }
457 int getPeaksUsedFromIons3() const { return psm_.peaksUsedFromIons3; }
458 std::string getVarModsStr(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getVarModsStr(); }
459 void setVarModsStr(const std::string &str, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setVarModsStr(str); }
460 std::string getSummedModsStr(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getSummedModsStr(); }
461 void setSummedModsStr(const std::string &str, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setSummedModsStr(str); }
462 std::string getLocalModsStr(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getLocalModsStr(); }
463 void setLocalModsStr(const std::string & strRaw, const std::string & strParsed, const matrix_science::ms_peptide::PSM entity) {
464 PSM_data(entity).setLocalModsStr(strRaw, strParsed);
465 }
466 std::string getMonoLinkStr(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getMonoLinkStr(); }
467 void setMonoLinkStr(const std::string & value, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setMonoLinkStr(value); }
468 std::string getParsedLocalModsStr(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getParsedLocalModsStr(); }
469 std::string getSeriesUsedStr() const { return psm_.seriesUsedStr; }
470 double getIonsIntensity() const { return psm_.ionsIntensity; }
471 void setIonsIntensity(double n) { psm_.ionsIntensity = n; }
472 std::string getAmbiguityString(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getAmbiguityString(); }
473 bool setAmbiguityString(const std::string & val, const matrix_science::ms_peptide::PSM entity) { return PSM_data(entity).setAmbiguityString(val); }
474 std::string getPrimaryNlStr(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getPrimaryNlStr(); }
475 void setPrimaryNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setPrimaryNlStr(value); }
476 std::string getSummedModsNlStr(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getSummedModsNlStr(); }
477 void setSummedModsNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setSummedModsNlStr(value); }
478 std::string getLocalModsNlStr(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getLocalModsNlStr(); }
479 void setLocalModsNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setLocalModsNlStr(value); }
480 std::string getComponentStr(const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getComponentStr(); }
481 void setComponentStr(const std::string & value, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setComponentStr(value); }
482 int getNum13C(const double tol, const std::string tolu, const std::string & mass_type) const;
483
484 void getLoopLinks(matrix_science::ms_linker_site_vector &vec, const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getLoopLinks(vec); }
485 void setLoopLinks(const matrix_science::ms_linker_site_vector &vec, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setLoopLinks(vec); }
486
487 virtual bool isSamePeptideStr(const ms_peptide_impl_reloadable *pReloadable_, const bool substituteAmbiguous) const = 0;
488 virtual bool isSameVarModsStr(const ms_peptide_impl_reloadable *pReloadable_) const = 0;
489 virtual bool isSameSummedModsStr(const ms_peptide_impl_reloadable *pReloadable_) const = 0;
490
491 virtual int getNumberOfLinkedPeptides() const = 0;
492
493 virtual void getIntactLinks(matrix_science::ms_linker_site_vector &vec) const = 0;
494
495 // Derived classes must implement data access to each entity.
496 virtual const linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM e) const = 0;
497 virtual linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM e) = 0;
498
499 private:
500
501 psmData_t psm_;
502
503 };
504
505 /* Bug 13047: The ms_peptide_impl_reloadable class used to contain
506 * the same data as the new ms_peptide_impl_reloadable_linear
507 * class.
508 */
509 class ms_peptide_impl_reloadable_linear: public ms_peptide_impl_reloadable {
510 public:
511 ms_peptide_impl_reloadable_linear();
512
513 ms_peptide_impl_reloadable_linear(const psmData_t & psmData,
514 const linearPeptideData_t &peptideData);
515
516 ms_peptide_impl_reloadable_linear(const ms_peptide_impl_reloadable_linear &src);
517
518 virtual ~ms_peptide_impl_reloadable_linear() { }
519#ifndef SWIG
520 ms_peptide_impl_reloadable_linear& operator=(const ms_peptide_impl_reloadable_linear& right);
521#endif
522 void copyFrom(const ms_peptide_impl_reloadable_linear * src);
523
524 // Careful with initialiseDerivedFrom(): make sure you
525 // have checked with typeid() or dynamic_cast() that *src
526 // has the same dynamic type as *this.
527 virtual void initialiseDerivedFrom(const ms_peptide_impl_reloadable *src) { copyFrom(dynamic_cast<const ms_peptide_impl_reloadable_linear*>(src)); }
528
529 // clone() always returns a base class pointer, but may
530 // allocate a derived class object.
531 virtual std::unique_ptr<ms_peptide_impl_reloadable> clone() const { return std::unique_ptr<ms_peptide_impl_reloadable_linear>( new ms_peptide_impl_reloadable_linear(*this) ); }
532
533 virtual bool isSamePeptideStr(const ms_peptide_impl_reloadable *pReloadable_, const bool substituteAmbiguous) const;
534 virtual bool isSameVarModsStr(const ms_peptide_impl_reloadable *pReloadable_) const;
535 virtual bool isSameSummedModsStr(const ms_peptide_impl_reloadable *pReloadable_) const;
536
537 virtual int getNumberOfLinkedPeptides() const { return 0; }
538 virtual void getIntactLinks(matrix_science::ms_linker_site_vector &vec) const {
539 vec.setVarModsStrLengths(
540 getPeptideLength(matrix_science::ms_peptide::PSM_COMPLETE) + 2,
541 0
542 );
543 }
544
545 private:
546 virtual const linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM) const { return peptideData_; }
547 virtual linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM) { return peptideData_; }
548
549 linearPeptideData_t peptideData_;
550 };
551
552 class ms_peptide_impl_reloadable_crosslinked: public ms_peptide_impl_reloadable {
553 public:
554 ms_peptide_impl_reloadable_crosslinked();
555
556 ms_peptide_impl_reloadable_crosslinked(const psmData_t & psmData,
557 const linearPeptideData_t & concatPeptideData,
558 const linearPeptideData_t & alphaPeptideData,
559 const linearPeptideData_t & betaPeptideData,
560 const matrix_science::ms_linker_site &linkerSite);
561
562 ms_peptide_impl_reloadable_crosslinked(const ms_peptide_impl_reloadable_crosslinked &src);
563
564 virtual ~ms_peptide_impl_reloadable_crosslinked() { }
565#ifndef SWIG
566 ms_peptide_impl_reloadable_crosslinked& operator=(const ms_peptide_impl_reloadable_crosslinked& right);
567#endif
568 void copyFrom(const ms_peptide_impl_reloadable_crosslinked * src);
569
570 // Careful with initialiseDerivedFrom(): make sure you
571 // have checked with typeid() or dynamic_cast() that *src
572 // has the same dynamic type as *this.
573 virtual void initialiseDerivedFrom(const ms_peptide_impl_reloadable *src) { copyFrom(dynamic_cast<const ms_peptide_impl_reloadable_crosslinked*>(src)); }
574
575 // clone() always returns a base class pointer, but may
576 // allocate a derived class object.
577 virtual std::unique_ptr<ms_peptide_impl_reloadable> clone() const { return std::unique_ptr<ms_peptide_impl_reloadable_crosslinked>( new ms_peptide_impl_reloadable_crosslinked(*this) ); }
578
579 virtual bool isSamePeptideStr(const ms_peptide_impl_reloadable *pReloadable_, const bool substituteAmbiguous) const;
580 virtual bool isSameVarModsStr(const ms_peptide_impl_reloadable *pReloadable_) const;
581 virtual bool isSameSummedModsStr(const ms_peptide_impl_reloadable *pReloadable_) const;
582
583 virtual int getNumberOfLinkedPeptides() const { return 2; }
584 virtual void getIntactLinks(matrix_science::ms_linker_site_vector &vec) const {
585 vec.setVarModsStrLengths(
586 getPeptideLength(matrix_science::ms_peptide::PSM_CROSSLINK_ALPHA) + 2,
587 getPeptideLength(matrix_science::ms_peptide::PSM_CROSSLINK_BETA) + 2
588 );
589 vec.push(linkerSite_);
590 }
591
592 private:
593 virtual const linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM e) const { return peptideData_[PSM_enum_to_index(e)]; }
594 virtual linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM e) { return peptideData_[PSM_enum_to_index(e)]; }
595
596 static int PSM_enum_to_index(const matrix_science::ms_peptide::PSM e) {
597 /* Could do static_cast<int>(e), but it doesn't
598 * provide a failsafe default and there's no warning
599 * if the enum values change.
600 */
601 if (e == matrix_science::ms_peptide::PSM_COMPLETE) {
602 return 0;
603 } else if (e == matrix_science::ms_peptide::PSM_CROSSLINK_ALPHA) {
604 return 1;
605 } else if (e == matrix_science::ms_peptide::PSM_CROSSLINK_BETA) {
606 return 2;
607 }
608 return 0;
609 }
610
611 static const int peptideDataSize = 3;
612 linearPeptideData_t peptideData_[peptideDataSize];
613 matrix_science::ms_linker_site linkerSite_;
614 };
615
616} // msparser_internal namespace
617
618#endif // MS_PEPTIDE_IMPLBASE_HPP
619
620/*------------------------------- End of File -------------------------------*/
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site_vector::push
void push(const ms_linker_site &linkerSite)
Push a new linker site at the end of the vector.
Definition: ms_linker_site.cpp:311
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_peptide::PSM_CROSSLINK_BETA
@ PSM_CROSSLINK_BETA
Beta peptide in a crosslinked match.
Definition: ms_peptide.hpp:101
matrix_science::ms_peptide::PSM_COMPLETE
@ PSM_COMPLETE
Peptide-spectrum match, also linear peptide in a non-crosslinked match.
Definition: ms_peptide.hpp:99
matrix_science::ms_peptide::PSM_CROSSLINK_ALPHA
@ PSM_CROSSLINK_ALPHA
Alpha peptide in a crosslinked match.
Definition: ms_peptide.hpp:100
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide_quant_key.hpp Source File

  • inc
ms_peptide_quant_key.hpp
1/*
2##############################################################################
3# file: ms_peptide_quant_key.hpp #
4# 'msparser' toolkit #
5# Peptide quantitation key used in ms_quantitation #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: villek@matrixscience.com $ #
12# $Date: 2018-07-30 16:23:53 +0100 $ #
13# $Revision: #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_PEPQUANTKEY_HPP
19#define MS_PEPQUANTKEY_HPP
20
21
22// Includes from the standard template library
23#include <string>
24
25namespace matrix_science {
32
68 class MS_MASCOTRESFILE_API ms_peptide_quant_key
69 {
70 public:
72 ms_peptide_quant_key();
73
75 ms_peptide_quant_key(int q, int p);
76
78 ms_peptide_quant_key(int q, int p, int charge);
79
81 explicit ms_peptide_quant_key(int ID);
82
84 explicit ms_peptide_quant_key(const std::string &opaqueString);
85
87 explicit ms_peptide_quant_key(const std::string &opaqueString, int ID);
88
90 ms_peptide_quant_key(const ms_peptide_quant_key& src);
91
93 ~ms_peptide_quant_key();
94
95#ifndef SWIG
97 ms_peptide_quant_key& operator=(const ms_peptide_quant_key& right);
98
100 bool operator<(const ms_peptide_quant_key& right) const;
101
103 bool operator<=(const ms_peptide_quant_key& right) const;
104
106 bool operator>(const ms_peptide_quant_key& right) const;
107
109 bool operator>=(const ms_peptide_quant_key& right) const;
110
112 bool operator==(const ms_peptide_quant_key& right) const;
113
115 bool operator!=(const ms_peptide_quant_key& right) const;
116#endif
117
118
119#ifndef SWIG
121 bool getQueryAndRank(int &q, int &p) const;
122
124 bool getCharge(int &charge) const;
125
127 bool getID(int &ID) const;
128
130 bool getOpaqueString(std::string & opaqueStringRef) const;
131
133 bool getOpaqueStringAndID(std::string & opaqueStringRef, int & ID) const;
134#else // SWIG Multiple return values
135 bool getQueryAndRank(int & OUTPUT, int & OUTPUT) const;
136 bool getCharge(int &OUTPUT) const;
137 bool getID(int &OUTPUT) const;
138 bool getOpaqueString(std::string & OUTPUT) const;
139 bool getOpaqueStringAndID(std::string & OUTPUT, int & OUTPUT) const;
140#endif
141
143 bool isNil() const;
144
146 static ms_peptide_quant_key fromSerialisedString(const std::string &serialisedStr);
147
149 std::string serialise() const;
150
152 static std::string serialisationFormatVersion();
153
154 private:
155 enum PEPQUANTKEY_TYPE {
156 PEPQUANTKEY_NIL,
157 PEPQUANTKEY_QP,
158 PEPQUANTKEY_QPCHARGE,
159 PEPQUANTKEY_ID,
160 PEPQUANTKEY_OPAQUE,
161 PEPQUANTKEY_OPAQUEID
162 };
163
164 int type_, q_, p_, charge_, ID_;
165 std::string *opaqueString_;
166 }; // end of quantitation_group
168} // matrix_science namespace
169
170#endif // MS_PEPQUANTKEY_HPP
171
172/*------------------------------- End of File -------------------------------*/
matrix_science::ms_peptide_quant_key
Feature key identifying a peptide ratio.
Definition: ms_peptide_quant_key.hpp:69
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide_quant_key_vector.hpp Source File

  • inc
ms_peptide_quant_key_vector.hpp
1/*
2##############################################################################
3# file: ms_peptide_quant_key_vector.hpp #
4# 'msparser' toolkit #
5# A vector of ms_peptide_quant_key objects #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: villek@matrixscience.com $ #
12# $Date: 2018-07-30 16:23:53 +0100 $ #
13# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_PEPQUANTKEYVECTOR_HPP
19#define MS_PEPQUANTKEYVECTOR_HPP
20
21
22// Includes from the standard template library
23#include <vector>
24#include <list>
25
26namespace matrix_science {
27 class ms_peptide_quant_key;
28}
29
30namespace matrix_science {
37
46 class MS_MASCOTRESFILE_API ms_peptide_quant_key_vector
47 {
48 public:
50 ms_peptide_quant_key_vector();
51
52#ifndef SWIG
54 explicit ms_peptide_quant_key_vector(const std::vector<ms_peptide_quant_key> &v);
55
57 explicit ms_peptide_quant_key_vector(const std::list<ms_peptide_quant_key> &v);
58#endif
59
61 ms_peptide_quant_key_vector(const ms_peptide_quant_key_vector& src);
62
64 ~ms_peptide_quant_key_vector();
65
66#ifndef SWIG
68 ms_peptide_quant_key_vector& operator=(const ms_peptide_quant_key_vector& right);
69
71 const std::vector<ms_peptide_quant_key>& toVector() const;
72#endif
73
75 void copyFrom(const ms_peptide_quant_key_vector *src);
76
78 void append(const ms_peptide_quant_key_vector & src);
79
81 int size() const;
82
84 bool empty() const;
85
87 void push(const ms_peptide_quant_key &key);
88
90 ms_peptide_quant_key pop();
91
93 ms_peptide_quant_key get(int idx) const;
94
96 void set(int idx, const ms_peptide_quant_key &key);
97
99 void clear();
100
102 void swap(ms_peptide_quant_key_vector &right);
103
104 private:
105 std::vector<ms_peptide_quant_key> data_;
106 }; // end of quantitation_group
108} // matrix_science namespace
109
110#endif // MS_PEPQUANTKEYVECTOR_HPP
111
112/*------------------------------- End of File -------------------------------*/
113
matrix_science::ms_peptide_quant_key_vector
A vector of peptide quant keys.
Definition: ms_peptide_quant_key_vector.hpp:47
matrix_science::ms_peptide_quant_key
Feature key identifying a peptide ratio.
Definition: ms_peptide_quant_key.hpp:69
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptide_quant_ratio.hpp Source File

  • inc
ms_peptide_quant_ratio.hpp
1/*
2##############################################################################
3# file: ms_peptide_quant_ratio.hpp #
4# 'msparser' toolkit #
5# Peptide intensity ratio for relative quantitation #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: villek@matrixscience.com $ #
12# $Date: 2018-07-30 16:23:53 +0100 $ #
13# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_PEPTIDE_QUANT_RATIO_HPP
19#define MS_PEPTIDE_QUANT_RATIO_HPP
20
21
22// Includes from the standard template library
23#include <string>
24#include <vector>
25
26namespace matrix_science {
27 class ms_peptide_quant_key;
28
35
60 class MS_MASCOTRESFILE_API ms_peptide_quant_ratio
61 {
62 public:
64 ms_peptide_quant_ratio(const ms_peptide_quant_key &key, const std::string &ratioName, bool isInfinite = false);
65
67 ms_peptide_quant_ratio(const ms_peptide_quant_key &key, const std::string &ratioName, double value, bool isExcluded = false, double weight = 1.0);
68
70 ms_peptide_quant_ratio(const ms_peptide_quant_ratio& src);
71
73 ~ms_peptide_quant_ratio();
74
75#ifndef SWIG
77 ms_peptide_quant_ratio& operator=(const ms_peptide_quant_ratio& right);
78#endif
80 void copyFrom(const ms_peptide_quant_ratio *src);
81
83 bool isMissing() const;
84
86 bool isInfinite() const;
87
89 double getValue() const;
90
92 ms_peptide_quant_key getKey() const;
93
95 std::string getRatioName() const;
96
98 bool isExcluded() const;
99
101 double getWeight() const;
102
103 private:
104 bool isMissing_;
105 bool isInfinite_;
106 double value_;
107
108 ms_peptide_quant_key *peptideQuantKey_;
109 std::string ratioName_;
110
111 bool isExcluded_;
112 double weight_;
113 }; // end of quantitation_group
115} // matrix_science namespace
116
117#endif // MS_PEPTIDE_QUANT_RATIO_HPP
118
119/*------------------------------- End of File -------------------------------*/
matrix_science::ms_peptide_quant_key
Feature key identifying a peptide ratio.
Definition: ms_peptide_quant_key.hpp:69
matrix_science::ms_peptide_quant_ratio
Peptide abundance in one component relative to another in a quantitation experiment.
Definition: ms_peptide_quant_ratio.hpp:61
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptidesumcache.hpp Source File

  • src
  • resfile
  • impl
ms_peptidesumcache.hpp
1/*
2##############################################################################
3# file: ms_peptidesumcache.hpp #
4# 'msparser' toolkit #
5# Encapsulates an cache file for an ms_peptidesummary #
6# Just used internally in Mascot Parser - this header not supplied #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2022 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_PEPTIDESUMCACHE_HPP
21#define MS_PEPTIDESUMCACHE_HPP
22
23
24// Includes from the standard template library
25#include <time.h>
26#include <string>
27#include <list>
28#include <vector>
29#include <set>
30
31#include "ms_peptidesummarybase.hpp"
32#include "ms_peptidesummary_dat.hpp"
33#include "ms_modinstancescount.hpp"
34
35namespace matrix_science
36{
37 class ms_mascotresfilebase;
38}
39
40using namespace matrix_science;
41
42namespace msparser_internal {
43#ifndef SWIG
44 class ms_peptidesumcache
45 {
46 public:
47
48 virtual bool isOpenForReading() const = 0;
49 virtual bool isPossibleToCreate() const = 0;
50 virtual bool prepareToCreate() = 0;
51
52 virtual void openIndexFileForVerification() = 0;
53 virtual void createDirectoryAndOpenIndexFile() = 0;
54 virtual std::string getFeatures() = 0;
55 virtual bool getIsNA() = 0;
56 virtual void getAvePepIdentThresh(int &aveMascot, int &aveSL) = 0;
57 virtual double getTargetFdrMinProbability() = 0;
58 virtual double getErrTolMinProbability() = 0;
59 virtual void getQueryHasSignificant1stPass(std::vector<bool> &queryHasSignificant1stPassTarget, std::vector<bool> &queryHasSignificant1stPassDecoy) = 0;
60 virtual void getSrcRanks(std::vector<unsigned short> & srcRanksActiveSection, std::vector<unsigned short> & srcRanksInactiveSection) = 0;
61 virtual int getNumHits() = 0;
62 virtual void getTop50scores(double * top50Scores) = 0;
63 virtual ms_mascotresults::acc_dbidx_set_t getAccessionsForHit(const int hit, std::string & masterAcc, int & masterDbIdx) = 0;
64 virtual ms_mascotresults::q_p_vect_t getQPlistForHit(const int hit, bool getIgnored) = 0;
65 virtual ms_mascotresults::q_p_vect_t getFullQPlistForHit(const int hit) = 0;
66 virtual ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1) = 0;
67 virtual std::vector<std::pair<bool, bool> > getBoldRedChkBox(const int hit) = 0;
68 virtual std::vector<int> getQPinfo(int q, int p, int & prettyRank, int & protFirstAppearedIn, bool & isUnique, int & ambiguityGroupId, std::set<int> * pSetAmbiguitySiblings = NULL) = 0;
69 virtual ms_mascotresults::UNIQUE_PEP_RULES getUniqePepRulesSaved() = 0;
70 virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes) = 0;
71 virtual bool getDecoyCounts(double & dOneInXprobRndForDecoy,
72 long & numHitsAboveIdentity,
73 long & numDecoyHitsAboveIdentity,
74 long & numHitsAboveHomology,
75 long & numDecoyHitsAboveHomology) = 0;
76 virtual void getDecoyCounts_seq_FASTA(long & numHitsAboveIdentity,
77 long & numDecoyHitsAboveIdentity,
78 long & numHitsAboveHomology,
79 long & numDecoyHitsAboveHomology) = 0;
80 virtual void getDecoyCounts_PSM_SL(long & numHitsAboveIdentity,
81 long & numDecoyHitsAboveIdentity,
82 long & numHitsAboveHomology,
83 long & numDecoyHitsAboveHomology) = 0;
84 virtual void getDecoyCounts_PSM_both(long & numHitsAboveIdentity,
85 long & numDecoyHitsAboveIdentity,
86 long & numHitsAboveHomology,
87 long & numDecoyHitsAboveHomology) = 0;
88 virtual void getDecoyCounts_seq_SL(long & numHitsAboveIdentity,
89 long & numDecoyHitsAboveIdentity,
90 long & numHitsAboveHomology,
91 long & numDecoyHitsAboveHomology) = 0;
92 virtual void getDecoyCounts_seq_both(long & numHitsAboveIdentity,
93 long & numDecoyHitsAboveIdentity,
94 long & numHitsAboveHomology,
95 long & numDecoyHitsAboveHomology) = 0;
96 virtual void getDecoyCounts_PSM_ET_1st(long & numHitsAboveIdentity,
97 long & numDecoyHitsAboveIdentity,
98 long & numHitsAboveHomology,
99 long & numDecoyHitsAboveHomology) = 0;
100 virtual void getDecoyCounts_PSM_ET_2nd(long & numHitsAboveIdentity,
101 long & numDecoyHitsAboveIdentity,
102 long & numHitsAboveHomology,
103 long & numDecoyHitsAboveHomology) = 0;
104 virtual void getDecoyCounts_seq_ET_1st(long & numHitsAboveIdentity,
105 long & numDecoyHitsAboveIdentity,
106 long & numHitsAboveHomology,
107 long & numDecoyHitsAboveHomology) = 0;
108 virtual void getDecoyCounts_seq_ET_2nd(long & numHitsAboveIdentity,
109 long & numDecoyHitsAboveIdentity,
110 long & numHitsAboveHomology,
111 long & numDecoyHitsAboveHomology) = 0;
112 virtual int getUnassignedList(std::string & str) = 0;
113 virtual void getIonsScoreHistograms(std::vector<int> & ionsScoreHistogramTopMatchMascot,
114 std::vector<int> & ionsScoreHistogramTop10Mascot,
115 std::vector<int> & ionsScoreHistogramTopMatchSL,
116 std::vector<int> & ionsScoreHistogramTop10SL
117 ) = 0;
118 virtual void getPercolatorScores(ms_percolator_scores_vector & percolator, const int numQueries) = 0;
119 virtual void getSLScoreStats(double *slScoreStats) = 0;
120 virtual std::string getQueryList(ms_peptidesummary::QL_FLAG flag) = 0;
121 virtual bool getInference(const std::string & masterAcc, const int masterDbIdx,
122 ms_protein::dbIdxPlusAccVect_t & familyProteins,
123 ms_protein::dbIdxPlusAccVect_t & samesetProteins,
124 ms_protein::dbIdxPlusAccVect_t & subsetProteins,
125 ms_protein::dbIdxPlusAccVect_t & allSubsetProteins) = 0;
126 virtual int getNumberOfFamilyMembers() = 0;
127 virtual std::string getProtein(const std::string & accession,
128 const int dbIdx,
129 ms_protein::dbIdxPlusAccVect_t & supersets,
130 ms_protein::dbIdxPlusAccVect_t & components) = 0;
131 virtual bool getTreeClusterNodes(const int hit,
132 const std::string accession,
133 const int dbIdx,
134 std::vector<int> &left,
135 std::vector<int> &right,
136 std::vector<double> &distance,
137 ms_mascotresults::TREE_CLUSTER_METHOD tcm) = 0;
138 virtual int getAllFamilyMembersWithThisPepMatch(const ms_mascotresultsbase & results,
139 const int hit,
140 const int q,
141 const int p,
142 std::vector< int >& db,
143 std::vector< std::string >& acc,
144 std::vector<int64_t>& protId,
145 std::vector< int >& dupe_status) = 0;
146 virtual bool getIonsScores(const bool decoy,
147 const int rank,
148 std::vector<double> &scores,
149 const int numQueries) = 0;
150
151 virtual bool getComponentIntensities(ms_peptidesummary_dat::componentNames_t & componentNames,
152 ms_peptidesummary_dat::componentIntensities_t & intensities) = 0;
153
154 virtual void getQmatchValues(const ms_mascotresultsbase & results, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) = 0;
155 virtual void getPlugholeValues(const ms_mascotresultsbase & results, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) = 0;
156 virtual bool getemPAIminMaxCleavage(int & emPAIminCleavage, int & emPAImaxCleavage) = 0;
157 virtual bool getModificationCounts(
158 std::vector<ms_mod_instances_count::mod_residue_count_t> &fixed_mod_count,
159 std::vector<ms_mod_instances_count::mod_residue_count_t> &var_mod_count,
160 std::map<std::pair<int, int>, ms_mod_instances_count::mod_residue_count_t> &monolink_count,
161 std::map<std::pair<int, int>, ms_mod_instances_count::linked_residue_count_t> &looplink_count,
162 std::map<std::pair<int, int>, ms_mod_instances_count::linked_residue_count_t> &intact_link_count,
163 std::vector<std::string> &var_mod_position_types,
164 std::map<std::string, std::map<std::string, ms_mod_instances_count::mod_residue_count_t> > &local_mod_count,
165 std::vector<std::string> &local_mod_deltas,
166 std::map<std::string, std::map<std::string, ms_mod_instances_count::mod_residue_count_t> > &et_mod_count,
167 std::vector<std::string> &et_mod_deltas,
168 int &num_nonspecific_cleavage,
169 int num_library_mods,
170 std::vector<ms_mod_instances_count::mod_residue_count_t> &library_mod_count) = 0;
171
172 virtual bool dumper(const std::string & filename) = 0;
173
174 };
175#endif // SWIG
176} // msparser_internal namespace
177#endif // MS_PEPTIDESUMCDB_HPP
178
179/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults::TREE_CLUSTER_METHOD
TREE_CLUSTER_METHOD
Flags for getTreeClusterNodes().
Definition: ms_mascotresults.hpp:128
matrix_science::ms_mascotresults::UNIQUE_PEP_RULES
UNIQUE_PEP_RULES
Flags for isPeptideUnique().
Definition: ms_mascotresults.hpp:360
matrix_science::ms_peptidesummary::QL_FLAG
QL_FLAG
Flags for getQueryList().
Definition: ms_peptidesummary.hpp:124
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptidesumcdb.hpp Source File

  • src
  • resfile
  • impl
ms_peptidesumcdb.hpp
1/*
2##############################################################################
3# file: ms_peptidesumcdb.hpp #
4# 'msparser' toolkit #
5# Encapsulates an cache file for an ms_peptidesummary #
6# Just used internally in Mascot Parser - this header not supplied #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2009 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_PEPTIDESUMCDB_HPP
21#define MS_PEPTIDESUMCDB_HPP
22
23
24// Includes from the standard template library
25#include <time.h>
26#include <string>
27#include <list>
28#include <vector>
29#include <set>
30
31#include <cdb.h>
32
33#include "ms_modinstancescount.hpp"
34#include "ms_peptidesumcache.hpp"
35
36namespace matrix_science
37{
38 class ms_mascotresfilebase;
39 class ms_mascotresfile_dat;
40}
41
42using namespace matrix_science;
43
44namespace msparser_internal {
45 class ms_mascotresultsbase;
46
47#ifndef SWIG
48
49 class ms_peptidesumcdb : public ms_peptidesumcache, public matrix_science::ms_tinycdb
50 {
51 public:
52 static std::string getCacheFilename(
53 const ms_mascotresfilebase & resfile,
54 const ms_mascotresults_params & parameters,
55 double minProbabilityForCache);
56
57 ms_peptidesumcdb(const ms_mascotresfile_dat & resfile,
58 const ms_mascotresults_params & parameters,
59 bool useIndex,
60 double minProbabilityForCache);
61
62 ~ms_peptidesumcdb();
63
64 bool isOpenForReading() const override { return matrix_science::ms_tinycdb::isOpenForReading(); }
65 bool isPossibleToCreate() const override { return matrix_science::ms_tinycdb::isPossibleToCreate(); }
66 bool prepareToCreate() override { return matrix_science::ms_tinycdb::prepareToCreate(); }
67
68 void openIndexFileForVerification() override;
69 void createDirectoryAndOpenIndexFile() override;
70 std::string getFeatures() override;
71 bool getIsNA() override;
72 void getAvePepIdentThresh(int &aveMascot, int &aveSL) override;
73 double getTargetFdrMinProbability() override;
74 double getErrTolMinProbability() override;
75 void getQueryHasSignificant1stPass(std::vector<bool> &queryHasSignificant1stPassTarget, std::vector<bool> &queryHasSignificant1stPassDecoy) override;
76 void getSrcRanks(std::vector<unsigned short> & srcRanksActiveSection, std::vector<unsigned short> & srcRanksInactiveSection) override;
77 int getNumHits() override;
78 void getTop50scores(double * top50Scores) override;
79 ms_mascotresults::acc_dbidx_set_t getAccessionsForHit(const int hit, std::string & masterAcc, int & masterDbIdx) override;
80 ms_mascotresults::q_p_vect_t getQPlistForHit(const int hit, bool getIgnored) override;
81 ms_mascotresults::q_p_vect_t getFullQPlistForHit(const int hit) override;
82 ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1) override;
83 std::vector<std::pair<bool, bool> > getBoldRedChkBox(const int hit) override;
84 std::vector<int> getQPinfo(int q, int p, int & prettyRank, int & protFirstAppearedIn, bool & isUnique, int & ambiguityGroupId, std::set<int> * pSetAmbiguitySiblings = NULL) override;
85 ms_mascotresults::UNIQUE_PEP_RULES getUniqePepRulesSaved() override;
86 std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes) override;
87 bool getDecoyCounts(double & dOneInXprobRndForDecoy,
88 long & numHitsAboveIdentity,
89 long & numDecoyHitsAboveIdentity,
90 long & numHitsAboveHomology,
91 long & numDecoyHitsAboveHomology) override;
92 void getDecoyCounts_seq_FASTA(long & numHitsAboveIdentity,
93 long & numDecoyHitsAboveIdentity,
94 long & numHitsAboveHomology,
95 long & numDecoyHitsAboveHomology) override;
96 void getDecoyCounts_PSM_SL(long & numHitsAboveIdentity,
97 long & numDecoyHitsAboveIdentity,
98 long & numHitsAboveHomology,
99 long & numDecoyHitsAboveHomology) override;
100 void getDecoyCounts_PSM_both(long & numHitsAboveIdentity,
101 long & numDecoyHitsAboveIdentity,
102 long & numHitsAboveHomology,
103 long & numDecoyHitsAboveHomology) override;
104 void getDecoyCounts_seq_SL(long & numHitsAboveIdentity,
105 long & numDecoyHitsAboveIdentity,
106 long & numHitsAboveHomology,
107 long & numDecoyHitsAboveHomology) override;
108 void getDecoyCounts_seq_both(long & numHitsAboveIdentity,
109 long & numDecoyHitsAboveIdentity,
110 long & numHitsAboveHomology,
111 long & numDecoyHitsAboveHomology) override;
112 void getDecoyCounts_PSM_ET_1st(long & numHitsAboveIdentity,
113 long & numDecoyHitsAboveIdentity,
114 long & numHitsAboveHomology,
115 long & numDecoyHitsAboveHomology) override;
116 void getDecoyCounts_PSM_ET_2nd(long & numHitsAboveIdentity,
117 long & numDecoyHitsAboveIdentity,
118 long & numHitsAboveHomology,
119 long & numDecoyHitsAboveHomology) override;
120 void getDecoyCounts_seq_ET_1st(long & numHitsAboveIdentity,
121 long & numDecoyHitsAboveIdentity,
122 long & numHitsAboveHomology,
123 long & numDecoyHitsAboveHomology) override;
124 void getDecoyCounts_seq_ET_2nd(long & numHitsAboveIdentity,
125 long & numDecoyHitsAboveIdentity,
126 long & numHitsAboveHomology,
127 long & numDecoyHitsAboveHomology) override;
128 int getUnassignedList(std::string & str) override;
129 void getIonsScoreHistograms(std::vector<int> & ionsScoreHistogramTopMatchMascot,
130 std::vector<int> & ionsScoreHistogramTop10Mascot,
131 std::vector<int> & ionsScoreHistogramTopMatchSL,
132 std::vector<int> & ionsScoreHistogramTop10SL
133 ) override;
134 void getPercolatorScores(ms_percolator_scores_vector & percolator, const int numQueries) override;
135 void getSLScoreStats(double *slScoreStats) override;
136 std::string getQueryList(ms_peptidesummary::QL_FLAG flag) override;
137 bool getInference(const std::string & masterAcc, const int masterDbIdx,
138 ms_protein::dbIdxPlusAccVect_t & familyProteins,
139 ms_protein::dbIdxPlusAccVect_t & samesetProteins,
140 ms_protein::dbIdxPlusAccVect_t & subsetProteins,
141 ms_protein::dbIdxPlusAccVect_t & allSubsetProteins) override;
142 int getNumberOfFamilyMembers() override;
143 std::string getProtein(const std::string & accession,
144 const int dbIdx,
145 ms_protein::dbIdxPlusAccVect_t & supersets,
146 ms_protein::dbIdxPlusAccVect_t & components) override;
147 bool getTreeClusterNodes(const int hit,
148 const std::string accession,
149 const int dbIdx,
150 std::vector<int> &left,
151 std::vector<int> &right,
152 std::vector<double> &distance,
153 ms_mascotresults::TREE_CLUSTER_METHOD tcm) override;
154 int getAllFamilyMembersWithThisPepMatch(const ms_mascotresultsbase & results,
155 const int hit,
156 const int q,
157 const int p,
158 std::vector< int >& db,
159 std::vector< std::string >& acc,
160 std::vector<int64_t>& protId,
161 std::vector< int >& dupe_status) override;
162 bool getIonsScores(const bool decoy,
163 const int rank,
164 std::vector<double> &scores,
165 const int numQueries) override;
166
167 bool getComponentIntensities(ms_peptidesummarybase::componentNames_t & componentNames,
168 ms_peptidesummarybase::componentIntensities_t & intensities) override;
169
170 void getQmatchValues(const ms_mascotresultsbase & results, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) override;
171 void getPlugholeValues(const ms_mascotresultsbase & results, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) override;
172 bool getemPAIminMaxCleavage(int & emPAIminCleavage, int & emPAImaxCleavage) override;
173 bool getModificationCounts(
174 std::vector<ms_mod_instances_count::mod_residue_count_t> &fixed_mod_count,
175 std::vector<ms_mod_instances_count::mod_residue_count_t> &var_mod_count,
176 std::map<std::pair<int, int>, ms_mod_instances_count::mod_residue_count_t> &monolink_count,
177 std::map<std::pair<int, int>, ms_mod_instances_count::linked_residue_count_t> &looplink_count,
178 std::map<std::pair<int, int>, ms_mod_instances_count::linked_residue_count_t> &intact_link_count,
179 std::vector<std::string> &var_mod_position_types,
180 std::map<std::string, std::map<std::string, ms_mod_instances_count::mod_residue_count_t> > &local_mod_count,
181 std::vector<std::string> &local_mod_deltas,
182 std::map<std::string, std::map<std::string, ms_mod_instances_count::mod_residue_count_t> > &et_mod_count,
183 std::vector<std::string> &et_mod_deltas,
184 int &num_nonspecific_cleavage,
185 int num_library_mods,
186 std::vector<ms_mod_instances_count::mod_residue_count_t> &library_mod_count) override;
187
188 void createCDBFile( ms_peptidesummary_dat & results,
189 const std::vector<unsigned short> & srcRanksActiveSection,
190 const std::vector<unsigned short> & srcRanksInactiveSection,
191 const std::vector<bool> & queryHasSignificant1stPassTarget,
192 const std::vector<bool> & queryHasSignificant1stPassDecoy,
193 const std::string & unassigned,
194 const std::vector<int> & ionsScoreHistogramTopMatchMascot,
195 const std::vector<int> & ionsScoreHistogramTop10Mascot,
196 const std::vector<int> & ionsScoreHistogramTopMatchSL,
197 const std::vector<int> & ionsScoreHistogramTop10SL,
198 const ms_percolator_scores_vector & percolator,
199 const msparser_internal::ms_proteininference * pProteinInferencer,
200 const double *slScoreStats);
201
202
203 bool parseMapModQP(int hit, const std::string & cdbidx_key_mod_count, const std::string & cdbidx_key_mod_value, ms_mascotresults::map_mod_value_to_qp & mapModQP);
204 bool parseMapModQP_ET(int hit, ms_mascotresults::map_mod_value_to_qp & mapModQP);
205 bool parseMapModQP_SL(int hit, ms_mascotresults::map_mod_value_to_qp & mapModQP);
206 bool parseMapModQP_VAR(int hit, ms_mascotresults::map_mod_value_to_qp & mapModQP);
207 double parseDeltaMaxTol(int hit);
208
209 void serialiseDecoyPeptideString(const ms_mascotresfile_dat & resfile, int q, int p, ms_mascotresfile_dat::section sec, int srcRank, std::string * peptideStringToSet = nullptr);
210 std::string getDecoyPeptideString(int q, int p);
211
212 static std::string toHexStr(const double val);
213 static double doubleFromHexStr(const std::string & str);
214 bool dumper(const std::string & filename) override;
215
216
217 protected:
218 // Not safe to copy or assign this object.
219 ms_peptidesumcdb(const ms_peptidesumcdb & rhs);
220 ms_peptidesumcdb & operator=(const ms_peptidesumcdb & rhs);
221
222 private:
223 const ms_mascotresfile_dat & resfile_;
224 unsigned int flags_;
225 unsigned int flags2_;
226 double probabilityThreshold_;
227 int maxHitsToReport_;
228 double ignoreIonsScoreBelow_;
229 int minPepLenInPepSummary_;
230 std::string unigeneIndexFile_;
231 std::string singleHit_;
232 int minNumSigUniqueSeqs_;
233
234 static std::string modCountToStr(const ms_mod_instances_count::mod_residue_count_t &mod_count);
235 static void strToModCount(const std::string &str, ms_mod_instances_count::mod_residue_count_t &mod_count);
236 static std::vector<std::string> parse_variable_mod_names(const std::string &mod_names);
237
238 void myOpenIndexFile();
239 void serialiseAmbiguitySiblings(const ms_peptidesummary_dat & results, const int q, const int p, const ms_peptide * const pep, std::ostringstream & value);
240
241 bool parse_variable_mod_counts(const std::vector<std::string> &names, const std::string &cdbidx_key_count_base, std::map<std::string, std::map<std::string, ms_mod_instances_count::mod_residue_count_t> > &mod_count_map);
242 void serialise_variable_mod_counts(const std::string &cdbidx_key_disco_names, const std::string &cdbidx_key_count_base, const std::map<std::string, std::map<std::string, ms_mod_instances_count::mod_residue_count_t> > &mod_count_map);
243 bool addToMapModQP(ms_mascotresults::map_mod_value_to_qp & mapModQP, const int q, const int p, const std::string & value) const;
244 bool serialiseMapModQP(int hit, const std::string & cdbidx_key_mod_count, const std::string & cdbidx_key_mod_value, ms_mascotresults::map_mod_value_to_qp & mapModQP);
245
246 };
247#endif // SWIG
248} // msparser_internal namespace
249#endif // MS_PEPTIDESUMCDB_HPP
250
251/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfile_dat
Class for parsing and reading files in dat28 format.
Definition: ms_mascotresfile_dat.hpp:121
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults::TREE_CLUSTER_METHOD
TREE_CLUSTER_METHOD
Flags for getTreeClusterNodes().
Definition: ms_mascotresults.hpp:128
matrix_science::ms_mascotresults::UNIQUE_PEP_RULES
UNIQUE_PEP_RULES
Flags for isPeptideUnique().
Definition: ms_mascotresults.hpp:360
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptidesummary::QL_FLAG
QL_FLAG
Flags for getQueryList().
Definition: ms_peptidesummary.hpp:124
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
matrix_science::ms_tinycdb::prepareToCreate
bool prepareToCreate()
Start creating the index file.
Definition: ms_tinycdb.cpp:383
matrix_science::ms_tinycdb::isPossibleToCreate
bool isPossibleToCreate() const
Check to see if the index file can be created.
Definition: ms_tinycdb.cpp:351
matrix_science::ms_tinycdb::isOpenForReading
bool isOpenForReading() const
Check to see that the file is valid and open for reading.
Definition: ms_tinycdb.cpp:360
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptidesummary.hpp Source File

  • inc
ms_peptidesummary.hpp
1/*
2##############################################################################
3# file: ms_mascotrespeptidesum.hpp #
4# 'msparser' toolkit #
5# Encapsulates the peptide summary report from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2024-08-29 17:08:49 +0100 $ #
14# $Revision: 5342f33ad8c8306230f6edda6c723ef3d3ff158b | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESPEPTIDESUM_HPP
20#define MS_MASCOTRESPEPTIDESUM_HPP
21
22
23// Includes from the standard template library
24#include <list>
25#include <map>
26#include <set>
27#include <string>
28#include <vector>
29
30namespace msparser_internal {
31 class ms_peptidesummary_dat;
32 class ms_peptidesummarybase;
33
34}
35
36namespace matrix_science {
37
44
50 class MS_MASCOTRESFILE_API ms_peptidesummary : public matrix_science::ms_mascotresults
51 {
52 public:
53
55
69 enum BUGFIX_NUM
70 {
71 BUGFIX_10780 = 10780,
72 BUGFIX_10995 = 10995,
73 BUGFIX_11002 = 11002,
74 BUGFIX_11018 = 11018,
75 BUGFIX_11235 = 11235,
76 BUGFIX_11254 = 11254,
77 BUGFIX_11344 = 11344,
78 BUGFIX_11411 = 11411,
79 BUGFIX_11425 = 11425,
80 BUGFIX_11438 = 11438,
81 BUGFIX_11483 = 11483,
82 BUGFIX_11499 = 11499,
83 BUGFIX_11856 = 11856,
84 BUGFIX_12123 = 12123,
85 BUGFIX_12317 = 12317,
86 BUGFIX_11481 = 11481,
87 BUGFIX_12538 = 12538,
88 BUGFIX_12729 = 12729,
89 BUGFIX_12740 = 12740,
90 BUGFIX_13324 = 13324,
91 BUGFIX_12447 = 12447,
92 BUGFIX_13759 = 13759
93 };
94
96
101 enum CACHE_STATUS {
102 CACHE_MISSING_RESFILE = 0x10000,
103
104 RESFILE_CACHE_FILE_NOT_PRESENT = 0x00001,
105 RESFILE_CACHE_BEING_CREATED = 0x00002,
106 RESFILE_CACHE_DISABLED_IN_OPTIONS = 0x00004,
107 RESFILE_CACHE_VALID = 0x00008,
108 RESFILE_CACHE_CAN_CREATE = 0x00010,
109
110 PEPSUMMARY_CACHE_FILE_NOT_PRESENT = 0x00100,
111 PEPSUMMARY_CACHE_BEING_CREATED = 0x00200,
112 PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS = 0x00400,
113 PEPSUMMARY_CACHE_VALID = 0x00800,
114 PEPSUMMARY_CACHE_CAN_CREATE = 0x01000,
115 PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE= 0x02000,
116 PEPSUMMARY_CACHE_NOT_FOR_PMF = 0x04000
117 };
118
120
123 enum QL_FLAG
124 {
125 QL_FIRST = 0x0000,
126 QL_ALL = 0x0000,
127 QL_UNASSIGNED = 0x0001,
128 QL_BELOW_IDENTITY = 0x0002,
129 QL_BELOW_HOMOLOGY = 0x0003,
130 QL_IGNORE_IONS_SCORE_BELOW = 0x0004,
131
132 QL_LAST = 0x0004
133 };
134
136
139 enum MSPEPSUM
140 {
141 MSPEPSUM_NONE = 0x0000,
142 MSPEPSUM_PERCOLATOR = 0x0001,
143 MSPEPSUM_USE_CACHE = 0x0002,
144 MSPEPSUM_SINGLE_HIT_DBIDX = 0x0004,
145 MSPEPSUM_USE_HOMOLOGY_THRESH= 0x0008,
146 MSPEPSUM_NO_PROTEIN_GROUPING= 0x0010,
147 MSPEPSUM_DISCARD_RELOADABLE = 0x0020,
148 MSPEPSUM_DEFERRED_CREATE = 0x0040,
149 MSPEPSUM_CACHE_IGNORE_DATE_CHANGE = 0x0080,
150 MSPEPSUM_REMOVE_CHIMERIC_DUPES = 0x0100,
151 MSPEPSUM_SL_INTEGRATED = 0x0200,
152 MSPEPSUM_SL_ONLY = 0x0400,
153 MSPEPSUM_CROSSLINK_INTEGRATED = 0x0800,
154 MSPEPSUM_CROSSLINK_ONLY = 0x1000,
155 };
156
157
158 public:
159
161 static std::string getCacheFilename(
162 const ms_mascotresfilebase & resfile,
163 const unsigned int flags,
164 double minProbability = 0.0,
165 int maxHitsToReport = 50,
166 const char * unigeneIndexFile = 0,
167 double ignoreIonsScoreBelow = 0.0,
168 int minPepLenInPepSummary = 0,
169 const char * singleHit = 0,
170 const unsigned int flags2 = MSPEPSUM_NONE);
171
173 static std::string getCacheFilename(
174 const ms_mascotresfilebase & resfile,
175 const ms_mascotresults_params & parameters);
176
178 ms_peptidesummary(const ms_mascotresfilebase &resfile,
179 const unsigned int flags = ms_mascotresults::MSRES_GROUP_PROTEINS,
180 double minProbability = 0.0,
181 int maxHits = 50,
182 const char * unigeneIndexFile = 0,
183 double ignoreIonsScoreBelow = 0.0,
184 int minPepLenInPepSummary = 0,
185 const char * singleHit = 0,
186 const unsigned int flags2 = MSPEPSUM_NONE);
187
189 ms_peptidesummary(
190 const ms_mascotresfilebase & resfile,
191 const ms_mascotresults_params & parameters);
192
193 virtual ~ms_peptidesummary();
194
196 const ms_mascotresfilebase& mascotresfile() const;
197
199 virtual bool createSummary();
200
201 virtual bool anyEmPAI() const;
202
204 virtual double getProteinEmPAI(const char *accession, const int dbIdx = 1, const int length = -1) const;
205
207 virtual ms_protein * getHit(const int hit, const int memberNumber = 0) const;
208
210 virtual void freeHit(const int hit);
211
212 // This is 'hard-coded' to 10 in Mascot
213 enum { PEPS_PER_QUERY = 10 };
214
216 virtual ms_peptide getPeptide(const int q, const int p) const;
217
219 virtual bool getPeptide(const int q, const int p, ms_peptide * & pep) const;
220
222 virtual double getIonsScore(const int q, const int p, const bool decoy) const;
223
225 virtual bool isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules = UPR_DEFAULT) const;
226
227 virtual bool getHitAndFamilyMember(const ms_protein * prot,
228 ms_mascotresults::hitAndFamily_t & hitAndFamily,
229 const UNIQUE_PEP_RULES rules) const;
230
232 virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false);
233
235 virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
236 std::vector<int> & start,
237 std::vector<int> & end,
238 std::vector<std::string> &pre,
239 std::vector<std::string> &post,
240 std::vector<int> & frame,
241 std::vector<int> & multiplicity,
242 std::vector<int> & db) const;
243
245 virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
246 std::vector<int> & start,
247 std::vector<int> & end,
248 std::vector<std::string> &pre,
249 std::vector<std::string> &post,
250 std::vector<int> & frame,
251 std::vector<int> & multiplicity,
252 std::vector<int> & db,
253 std::vector<int> & psmComponent) const;
254
256 std::vector<int> getNumberOfAccessionDBTypes(int q, int p) const;
257
259 virtual int getAllFamilyMembersWithThisPepMatch(const int hit,
260 const int q,
261 const int p,
262 std::vector< int >& db,
263 std::vector< std::string >& acc,
264 std::vector< int >& dupe_status) const;
265
267 std::vector<int> getNumberOfFamilyAccessionDBTypes(int hit, int q, int p, bool includeSamesets = true) const;
268
270 virtual std::string getErrTolModString(const int q, const int p) const;
271
273 virtual std::string getLibraryModString(const int q, const int p) const;
274
276 virtual std::string getErrTolModMasterString(const int q, const int p) const;
277
279 virtual std::string getErrTolModSlaveString(const int q, const int p) const;
280
282 virtual std::string getErrTolModPepString(const int q, const int p) const;
283
285 virtual std::string getErrTolModReqPepString(const int q, const int p) const;
286
288 virtual std::string getTagString(const int q, const int p) const;
289
291 virtual int getTagDeltaRangeStart(const int q, const int p) const;
292
294 virtual int getTagDeltaRangeEnd(const int q, const int p) const;
295
297 virtual std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
298
300 virtual std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
301
303 virtual int getProteinScoreCutoff(double OneInXprobRnd) const;
304
306 int getSrcRank(int q, int p) const;
307
309 ms_mascotresfile_dat::section getSrcSection(int q, int p)const;
310
312 std::string getQueryList(QL_FLAG flag, bool outputListOfQueries = true);
313
315 virtual std::vector<int> getPepsWithSameScore(const int q, const int p) const;
316#ifndef SWIG
318 virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & value, double & rawValue) const;
319#else // SWIG Multiple return values
320 virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & OUTPUT, double & OUTPUT) const;
321#endif
323 virtual int findProteins(const int startHit,
324 const std::string & str,
325 const int dbIdx,
326 FIND_FLAGS item,
327 FIND_COMPARE_FLAGS compareFlags,
328 std::vector<std::string> & accessions,
329 std::vector<int> & dbIndexes) const;
330
332 virtual int findProteinsByAccession(const int startHit,
333 const std::string & str,
334 const int dbIdx,
335 FIND_COMPARE_FLAGS compareFlags,
336 std::vector<std::string> & accessions,
337 std::vector<int> & dbIndexes) const;
338
340 virtual int findProteinsByDescription(const int startHit,
341 const std::string & str,
342 FIND_COMPARE_FLAGS compareFlags,
343 std::vector<std::string> & accessions,
344 std::vector<int> & dbIndexes) const;
345
347 virtual int findPeptides(const int startHit,
348 const std::string & str,
349 FIND_FLAGS item,
350 FIND_COMPARE_FLAGS compareFlags,
351 std::vector<int> & q,
352 std::vector<int> & p) const;
353
355 virtual QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide(
356 const ms_peptide & peptide,
357 ms_quant_component & component,
358 const ms_quant_method * method = NULL) const;
359
361 virtual const ms_protein * getProtein(const char * accession, const int dbIdx = 1) const;
362
364 virtual const ms_protein * getComponentProtein(const char * accession, const int dbIdx = 1) const;
365
367 virtual bool getTreeClusterNodes(const int hit,
368 std::vector<int> &left,
369 std::vector<int> &right,
370 std::vector<double> &distance,
371 ms_mascotresults::TREE_CLUSTER_METHOD tcm = ms_mascotresults::TCM_PAIRWISE_MAXIMUM,
372 double *** reserved1 = 0,
373 unsigned int * reserved2 = 0) const;
374
375 //virtual bool queryHasSignificantRank1Match(ms_mascotresfile_dat::section secSummary,
376 //int query) const;
377
379 static bool willCreateCache(const ms_mascotresfilebase & resfile,
380 const unsigned int flags = ms_mascotresults::MSRES_GROUP_PROTEINS,
381 double minProbability = 0.0,
382 int maxHits = 50,
383 const char * unigeneIndexFile = 0,
384 double ignoreIonsScoreBelow = 0.0,
385 int minPepLenInPepSummary = 0,
386 const char * singleHit = 0,
387 const unsigned int flags2 = MSPEPSUM_NONE);
388
390 static bool willCreateCache(const ms_mascotresfilebase & resfile,
391 const ms_mascotresults_params & parameters);
392
393#ifndef SWIG
395 static bool willCreateCache(const char * resultsFileName,
396 const ms_mascotoptions & opts,
397 const char * unigeneIndexFile,
398 const char * singleHit,
399 const char * applicationName,
400 std::string & resfileCacheFileName,
401 std::string & peptideSummaryCacheFileName,
402 unsigned int & cacheStatus);
403
405 static bool willCreateCache(const ms_mascotresfilebase & resfile,
406 const ms_mascotresults_params & parameters,
407 const ms_mascotoptions & opts,
408 std::string & peptideSummaryCacheFileName,
409 unsigned int & cacheStatus);
410#else // SWIG Multiple return values
411 static bool willCreateCache(const char * resultsFileName,
412 const ms_mascotoptions & opts,
413 const char * unigeneIndexFile,
414 const char * singleHit,
415 const char * applicationName,
416 std::string & OUTPUT,
417 std::string & OUTPUT,
418 unsigned int & OUTPUT);
419
420 static bool willCreateCache(const ms_mascotresfilebase & resfile,
421 const ms_mascotresults_params & parameters,
422 const ms_mascotoptions & opts,
423 std::string & OUTPUT,
424 unsigned int & OUTPUT);
425#endif
426
428 bool isPeptideModificationMatch(
429 const ms_quant_modgroup & group,
430 const ms_peptide & peptide) const;
431
433 bool isPeptideComponentMatch(
434 const ms_quant_component & component,
435 const ms_peptide & peptide) const;
436
438 bool hasQuantMethod() const;
440 const ms_quant_method * getQuantMethod() const;
441
443 bool hasCrosslinkingMethod() const;
445 const ms_crosslinking_method * getCrosslinkingMethod() const;
446
448 std::string getCacheFileName() const;
449
451 virtual bool loadPepMatchesForProteinFromCache(ms_protein * prot, const bool loadRelated = true);
452
454 virtual bool isValidQandP(const int q, const int p) const;
455
457 bool dumpCDB(const std::string dumpFileName);
458
460 void getLibraryEntryId(const int q, const int p, std::vector<int> &dbIdx, std::vector<int> &offset, std::vector<std::string> &checksum, std::vector<std::string> &mods) const;
461
463 static double getMinProbabilityForSLScore(double score);
464
466 static double getSLThresholdFromMinProbability(double minProbability);
467
469 std::vector<int> getPeptideAmbiguityRanks(const int q, const int p);
470
471 bool isDataCached(ms_peptidesummary::BUGFIX_NUM bugNum) const;
472
473 protected:
474 // Not safe to copy or assign this object.
475#ifndef SWIG
476 ms_peptidesummary(const ms_peptidesummary & rhs);
477 ms_peptidesummary & operator=(const ms_peptidesummary & rhs);
478#endif
479
480 private:
481
482 bool rerankingCouldHappen() const;
483
484 std::shared_ptr<msparser_internal::ms_peptidesummarybase> iPepSum_;
485
486 }; // end of resfile_group
488} // matrix_science namespace
489
490#endif // MS_MASCOTRESPEPTIDESUM_HPP
491
492/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_peptidesummary::BUGFIX_NUM
BUGFIX_NUM
bugNum values for isDataCached().
Definition: ms_peptidesummary.hpp:70
matrix_science::ms_peptidesummary::QL_FLAG
QL_FLAG
Flags for getQueryList().
Definition: ms_peptidesummary.hpp:124
matrix_science::ms_peptidesummary::MSPEPSUM
MSPEPSUM
flags2 for ms_peptidesummary introduced in Mascot Parser 2.3.
Definition: ms_peptidesummary.hpp:140
matrix_science::ms_peptidesummary::CACHE_STATUS
CACHE_STATUS
Returned by the willCreateCache function.
Definition: ms_peptidesummary.hpp:101
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptidesummary_dat.hpp Source File

  • src
  • resfile
  • impl
ms_peptidesummary_dat.hpp
1/*
2##############################################################################
3# file: ms_mascotrespeptidesum.hpp #
4# 'msparser' toolkit #
5# Encapsulates the peptide summary report from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_dat_1.2/include/ms_mascotrespe $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-02-08 10:46:35 +0000 $ #
14# $Revision: 61b805caf9910b1b33024ebe6ec9ec710cf9ff82 | MSPARSER_ALPHA_2_8_100-415-g06b6ad6513 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PEPTIDESUMMARY_DAT_HPP
20#define MS_PEPTIDESUMMARY_DAT_HPP
21
22
23// Includes from the standard template library
24#include <list>
25#include <map>
26#include <set>
27#include <string>
28#include <vector>
29
30
31namespace matrix_science {
32 class ms_tinycdb;
33 class ms_mascotresults_params;
34 class ms_protein;
35 class ms_datfile;
36 class ms_distiller_data;
37 class ms_distiller_data_search;
38 class ms_quant_component;
39 class ms_quant_modgroup;
40 class ms_linker_site;
41}
42
43using namespace matrix_science;
44
45namespace msparser_internal {
46 class ms_mascotresults_dat;
47 class ms_peptidesumcdb;
48 class ms_peptide_impl_dat;
49 class ms_peptide_impl_reloadable;
50 class ms_SEQINFO;
51 class ms_peptidesummary_fdr_query_data_extractor;
52 class ms_peptidesummary_fdr_peptides_vector_extractor;
53 struct structExpectTargetDecoy;
54
55 using PeptidePtr = std::shared_ptr<ms_peptide>;
56
58
65
71 class ms_peptidesummary_dat : public ms_peptidesummarybase
72 {
73 friend class msparser_internal::ms_peptide_impl_dat;
74 friend class ms_protein;
75 friend class msparser_internal::ms_peptidesumcdb;
76 friend class ms_ms2quantitation;
77 friend class ms_customquantitation;
78 friend class ms_quant_helper;
79 friend class msparser_internal::ms_peptidesummary_fdr_query_data_extractor;
80 friend class msparser_internal::ms_peptidesummary_fdr_peptides_vector_extractor;
81 public:
82
83
84
86 static std::string getCacheFilename(
87 const ms_mascotresfile_dat & resfile,
88 const unsigned int flags,
89 double minProbability = 0.0,
90 int maxHitsToReport = 50,
91 const char * unigeneIndexFile = 0,
92 double ignoreIonsScoreBelow = 0.0,
93 int minPepLenInPepSummary = 0,
94 const char * singleHit = 0,
95 const unsigned int flags2 = ms_peptidesummary::MSPEPSUM_NONE);
96
98 static std::string getCacheFilename(
99 const ms_mascotresfile_dat & resfile,
100 const ms_mascotresults_params & parameters);
101
102 ms_peptidesummary_dat(
103 const ms_mascotresults_params & parameters,
104 const ms_mascotresfile_dat & resfile,
105 ms_peptidesummary & pepSum);
106
108 ms_peptidesummary_dat(
109 std::shared_ptr<ms_mascotresults_dat> resultsImpl,
110 ms_peptidesummary& pepSum);
111
112
113 virtual ~ms_peptidesummary_dat();
114
115 void initialise(const ms_mascotresults_params& parameters, double minProbabilityForCache) override;
116
118 const ms_mascotresfile_dat & mascotresfile() const;
119
121 bool createSummary() override;
122
124 std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
125 std::vector<int> & start,
126 std::vector<int> & end,
127 std::vector<std::string> &pre,
128 std::vector<std::string> &post,
129 std::vector<int> & frame,
130 std::vector<int> & multiplicity,
131 std::vector<int> & db,
132 std::vector<int64_t> &protId) const override;
133
135 std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
136 std::vector<int> & start,
137 std::vector<int> & end,
138 std::vector<std::string> &pre,
139 std::vector<std::string> &post,
140 std::vector<int> & frame,
141 std::vector<int> & multiplicity,
142 std::vector<int> & db,
143 std::vector<int64_t> &protId,
144 std::vector<int> & psmComponent) const override;
145
147 std::vector<int> getNumberOfAccessionDBTypes(const int q, const int p) const override;
148
150 std::string getLibraryModString(const int q, const int p) const override;
151
153 std::string getErrTolModMasterString(const int q, const int p) const override;
154
156 std::string getErrTolModSlaveString(const int q, const int p) const override;
157
159 std::string getErrTolModPepString(const int q, const int p) const override;
160
162 std::string getErrTolModReqPepString(const int q, const int p) const override;
163
165 std::string getErrTolOriginalNaSeq(const int q, const int p) const override;
166
168 std::string getErrTolModifiedNaSeq(const int q, const int p) const override;
169
171 std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) override;
172
174 std::string getTagString(const int q, const int p) const override;
175
177 int getTagDeltaRangeStart(const int q, const int p) const override;
178
180 int getTagDeltaRangeEnd(const int q, const int p) const override;
181
183 std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const override;
184
186 std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const override;
187
189 double getIonsScore(const int q, const int p, const bool decoy) const override;
190
192 int getSrcRank(int q, int p) const override;
193
195 ms_mascotresfile_dat::section getSrcSection(int q, int p)const;
196
198 int findProteins(const int startHit,
199 const std::string & str,
200 const int dbIdx,
201 ms_mascotresults::FIND_FLAGS item,
202 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
203 std::vector<std::string> & accessions,
204 std::vector<int> & dbIndexes) const override;
205
207 int findProteinsByAccession(const int startHit,
208 const std::string & str,
209 const int dbIdx,
210 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
211 std::vector<std::string> & accessions,
212 std::vector<int> & dbIndexes) const override;
213
215 int findProteinsByDescription(const int startHit,
216 const std::string & str,
217 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
218 std::vector<std::string> & accessions,
219 std::vector<int> & dbIndexes) const override;
220
222 int findPeptides(const int startHit,
223 const std::string & str,
224 ms_mascotresults::FIND_FLAGS item,
225 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
226 std::vector<int> & q,
227 std::vector<int> & p) const override;
228
230 const ms_protein * getProtein(const char * accession, const int dbIdx = 1) const override;
231
233 const ms_protein * getComponentProtein(const char * accession, const int dbIdx = 1) const override;
234
236 static bool willCreateCache(const ms_mascotresfile_dat &resfile,
237 const unsigned int flags = ms_peptidesummary::MSRES_GROUP_PROTEINS,
238 double minProbability = 0.0,
239 int maxHits = 50,
240 const char * unigeneIndexFile = 0,
241 double ignoreIonsScoreBelow = 0.0,
242 int minPepLenInPepSummary = 0,
243 const char * singleHit = 0,
244 const unsigned int flags2 = ms_peptidesummary::MSPEPSUM_NONE);
245
247 static bool willCreateCache(const ms_mascotresfile_dat &resfile,
248 const ms_mascotresults_params & parameters);
249
250#ifndef SWIG
252 static bool willCreateCache(const char * resultsFileName,
253 const ms_mascotoptions & opts,
254 const char * unigeneIndexFile,
255 const char * singleHit,
256 const char * applicationName,
257 std::string & resfileCacheFileName,
258 std::string & peptideSummaryCacheFileName,
259 unsigned int & cacheStatus);
260
262 static bool willCreateCache(const ms_mascotresfile_dat & resfile,
263 const ms_mascotresults_params & parameters,
264 const ms_mascotoptions & opts,
265 std::string & peptideSummaryCacheFileName,
266 unsigned int & cacheStatus);
267#else // SWIG Multiple return values
268 static bool willCreateCache(const char * resultsFileName,
269 const ms_mascotoptions & opts,
270 const char * unigeneIndexFile,
271 const char * singleHit,
272 const char * applicationName,
273 std::string & OUTPUT,
274 std::string & OUTPUT,
275 unsigned int & OUTPUT);
276
277 static bool willCreateCache(const ms_mascotresfile_dat & resfile,
278 const ms_mascotresults_params & parameters,
279 const ms_mascotoptions & opts,
280 std::string & OUTPUT,
281 unsigned int & OUTPUT);
282#endif
283
285 bool isPeptideModificationMatch(
286 const ms_quant_modgroup & group,
287 const ms_peptide & peptide) const override;
288
290 bool isPeptideComponentMatch(
291 const ms_quant_component & component,
292 const ms_peptide & peptide) const override;
293
295 std::string getCacheFileName() const;
296
298 bool isDataCached(ms_peptidesummary::BUGFIX_NUM bugNum) const;
299
301 bool dumpCDB(const std::string dumpFileName);
302
304 void getLibraryEntryId(const int q, const int p, std::vector<int> &dbIdx, std::vector<int> &offset, std::vector<std::string> &checksum, std::vector<std::string> &mods) const;
305
306 //static ms_mascotresults_params getValidatedResultsParameters(const ms_mascotresfilebase &resfile, const ms_mascotresults_params &params,
307 // double * minProbabilityForCache = 0);
308
309
310 const ms_peptidesummary & getPepSum() const {return pepSum_;}
311
312 protected:
313 // Not safe to copy or assign this object.
314#ifndef SWIG
315 ms_peptidesummary_dat(const ms_peptidesummary_dat & rhs);
316 ms_peptidesummary_dat & operator=(const ms_peptidesummary_dat & rhs);
317#endif
318
319 void getQmatchValuesFromCacheFile(const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) const override;
320 void getPlugholeValuesFromCacheFile(const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) const override;
321 ms_mascotresfile_dat::section getSrcSectionProtected(const int query, const int rank) const override;
322
323 ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1) override;
324
325
326 private:
327
328 void initCache(const ms_mascotresults_params& parameters, double minProbabilityForCache) override;
329
330 void createCacheFile(bool isUsable) override;
331
332 void finishTmpCache() override;
333
334 void loadIonsScoresIntoCache(const bool decoy, const int p=1);
335
336 typedef struct {
337 std::string primaryNlStr;
338 std::string substStr;
339 std::string componentStr;
340 std::string summedModsStr;
341 std::string summedModsNlStr;
342 std::string localModsStr;
343 std::string parsedLocalModsStr;
344 std::string localModsNlStr;
345 std::string monoLinkStr;
346 ms_linker_site_vector loopLinks;
347 } qp_attribute_lines_t;
348
349 struct psm_seq_attributes_t {
350 psm_seq_attributes_t()
351 : mrCalc(0.0)
352 , missedCleavages(-1)
353 , peptideStr()
354 , varModsStr()
355 {}
356 double mrCalc;
357 int missedCleavages;
358 std::string peptideStr, varModsStr;
359 };
360
361 void loadAdditionalMatchAttributes(const ms_mascotresfile_dat::section sec,
362 const int q, const int srcRank,
363 const ms_peptide::PSM psmComponent,
364 const std::string &varModsStr,
365 qp_attribute_lines_t &lines) const;
366
367 int loadPepResCharge(const ms_mascotresfile_dat::section chargeSection, int q) const;
368
369 PeptidePtr loadPepResLinear(const ms_peptide::PSM_TYPE psmType,
370 int q, int srcRank, int p,
371 double observed,
372 ms_peptide::SEARCH_PHASE searchPhase,
373 msparser_internal::ms_peptide_impl_reloadable * * pReloadable,
374 bool *canLoadIntoProteins,
375 bool &etOK) override;
376 PeptidePtr loadPepResCrossLinked(const ms_peptide::PSM_TYPE psmType,
377 int q, int srcRank, int p,
378 double observed,
379 ms_peptide::SEARCH_PHASE searchPhase,
380 msparser_internal::ms_peptide_impl_reloadable * * pReloadable,
381 bool *canLoadIntoProteins,
382 bool &etOK) override;
383
384 bool loadCrossLinkedSequenceData(const int q,
385 const int srcRank,
386 const ms_mascotresfile_dat::section sec,
387 const std::string &str,
388 const ms_peptide::PSM psmComponent,
389 psm_seq_attributes_t &seq,
390 qp_attribute_lines_t &attributeLines) const;
391
392 ms_linker_site parseLinkerSite(const int q,
393 const int srcRank,
394 const ms_mascotresfile_dat::section sec,
395 const int alphaVarModsLen,
396 const int betaVarModsLen) const;
397 bool parseLinkedSiteTriplet(const int q,
398 const int srcRank,
399 const ms_mascotresfile_dat::section sec,
400 const std::string &str,
401 const int alphaVarModsLen,
402 const int betaVarModsLen,
403 ms_peptide::PSM &psmComponent,
404 int &pos,
405 int &varmodIdx) const;
406
407 bool parseLoopLinkedSites(const int q,
408 const int srcRank,
409 const ms_mascotresfile_dat::section sec,
410 const std::string &loopLinkedSitesStr,
411 const ms_peptide::PSM psmComponent,
412 const std::string &varModsStr,
413 ms_linker_site_vector &loopLinks) const;
414
415
416 void loadIntoProteins(const ms_peptide::PSM_TYPE psmType,
417 int q, int srcRank, int p,
418 double ionsScore,
419 ms_mascotresults::acc_dbidx_set_t * pAccessions,
420 bool isIgnored,
421 const int hitId=-1) override;
422
423 typedef std::pair<ms_mascotresults::acc_dbidx_t, msparser_internal::ms_SEQINFO> acc_dbidx_match_tuple_t;
424 typedef std::list<acc_dbidx_match_tuple_t> acc_dbidx_tuple_list_t;
425
426 void gatherProteinMatchData(acc_dbidx_tuple_list_t &proteinInputOrder,
427 const ms_mascotresfile_dat::section sec,
428 std::string str,
429 const int q, const int srcRank, const int p,
430 const ms_peptide::PSM thisPsmComponent,
431 const ms_peptide::SEARCH_PHASE searchPhase,
432 const ms_mascotresults::acc_dbidx_set_t * pAccessions);
433 void insertIntoProtein(const int q,
434 const int p,
435 const std::string &accession,
436 const int dbIdx,
437 const msparser_internal::ms_protein_match_data &proteinMatchData,
438 const ms_peptide::SEARCH_PHASE searchPhase,
439 const double ionsScore,
440 const bool isIgnored);
441
442
443 std::shared_ptr<ms_mascotresults_dat> resultsImpl_;
444 std::shared_ptr<msparser_internal::ms_peptidesumcdb> pCdbCacheFile_;
445
446 mutable std::vector< std::vector<double> > cachedScores_[2]; // Use cachedScores_[decoy][p][q]. Order important for performance with FDR
447 mutable std::vector<bool> attemptedLoadScoresFromCache_[2]; // Use attemptedLoadScoresFromCache_[decoy][p].
448
449
450 const ms_mascotresfile_dat &resfile_;
451
452
453 int getSrcRankAndSection(int q, int p, ms_mascotresfile_dat::section & sec, bool * pRejected = 0, bool inactiveSection = false) const;
454
455 std::string getErrTolModStringProtected(const int q, const int p, const int srcP, const ms_peptide::PSM_TYPE psmType) const override;
456
457 void getUnassignedListAsString(std::string & str);
458 bool findCompareProtein(const std::string & accRequired,
459 const std::string & accToTest,
460 const int dbIdxRequired,
461 const int dbIdxToTest,
462 ms_mascotresults::FIND_FLAGS item,
463 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
464 const ms_protein * prot,
465 const std::vector<int> & q,
466 const std::vector<int> & p) const;
467 bool findCompare(const std::string & find,
468 const std::string & findIn,
469 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags) const;
470 bool findCompare(const double find_value,
471 const double find_range,
472 const double value,
473 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags) const;
474
475
476 ms_tinycdb * pTmpCache_;
477
478
479 std::vector<int> parseDBstr(const std::string &strDB, bool &has_fasta_acc, bool &has_sl_ref_acc) const;
480 void parseMatchAccessionDBTermsLines(const int q,
481 const int p,
482 const int srcRank,
483 const ms_mascotresfile_dat::section sec,
484 const ms_peptide::PSM thisPsmComponent,
485 std::string str,
486 std::vector<std::string> & acc,
487 std::vector<int> & start,
488 std::vector<int> & end,
489 std::vector<std::string> &pre,
490 std::vector<std::string> &post,
491 std::vector<int> & frame,
492 std::vector<int> & multiplicity,
493 std::vector<int> & db,
494 std::vector<int> & psmComponent) const;
495
496 int addExpectationValue(bool homology, ms_mascotresults::DECOY_STATS_COUNT_TYPE countType, bool decoy, int q,
497 std::map<std::string, size_t> & mapSequenceToIndex, std::vector<structExpectTargetDecoy> & vecExpectTargetDecoy);
498 double truncateExpectationValue(double dValue, int sigfig);
499
500 bool getQPsFromMapValueToQP(const std::string & strSearch, const ms_mascotresults::map_mod_value_to_qp & mapValueToQP, std::set<std::pair<int, int> > & setQP, bool bCaseSensitive = true) const;
501
502 std::string getDecoyPeptideString(int q, int p) const override;
503
504 std::string getPeptideString(const int q, const int p, const bool isDecoy) const override;
505
506
507 }; // end of resfile_group
509
511
512} // msparser_internal namespace
513
514#endif // MS_PEPTIDESUMMARY_DAT_HPP
515
516/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customquantitation
Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings.
Definition: ms_customquantitation.hpp:119
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_distiller_data_search
The details of a Distiller search.
Definition: ms_distiller_data_search.hpp:52
matrix_science::ms_distiller_data
Distiller project parameters.
Definition: ms_distiller_data.hpp:49
matrix_science::ms_linker_site_vector
A vector of linker sites.
Definition: ms_linker_site_vector.hpp:46
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_mascotresfile_dat
Class for parsing and reading files in dat28 format.
Definition: ms_mascotresfile_dat.hpp:121
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults::FIND_COMPARE_FLAGS
FIND_COMPARE_FLAGS
Flags to specify how comparisons are performed in the find functions.
Definition: ms_mascotresults.hpp:189
matrix_science::ms_mascotresults::DECOY_STATS_COUNT_TYPE
DECOY_STATS_COUNT_TYPE
Type of object counted by getNumHitsAboveIdentity() and friends.
Definition: ms_mascotresults.hpp:382
matrix_science::ms_mascotresults::FIND_FLAGS
FIND_FLAGS
Flags for findPeptides() and findProteins().
Definition: ms_mascotresults.hpp:146
matrix_science::ms_ms2quantitation
Peptide and protein quantitation in a Reporter or Multiplex Mascot results file.
Definition: ms_ms2quantitation.hpp:127
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_peptide::PSM_COMPLETE
@ PSM_COMPLETE
Peptide-spectrum match, also linear peptide in a non-crosslinked match.
Definition: ms_peptide.hpp:99
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_peptidesummary::BUGFIX_NUM
BUGFIX_NUM
bugNum values for isDataCached().
Definition: ms_peptidesummary.hpp:70
matrix_science::ms_peptidesummary::MSPEPSUM_NONE
@ MSPEPSUM_NONE
Default.
Definition: ms_peptidesummary.hpp:141
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_helper
Helper routines for peptide quantitation.
Definition: ms_quant_helper.hpp:50
matrix_science::ms_quant_modgroup
An object of this class represent a single modification group element in quantitation....
Definition: ms_quant_modgroup.hpp:46
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptidesummary_msr.hpp Source File

  • src
  • resfile
  • impl
ms_peptidesummary_msr.hpp
1/*
2##############################################################################
3# file: ms_mascotrespeptidesum_msr.hpp #
4# 'msparser' toolkit #
5# Encapsulates the peptide summary report from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_msr_1.2/include/ms_mascotrespe $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-08-10 09:04:31 +0100 $ #
14# $Revision: 74ced94100ba2b07d3fc7012fa1e2d91ee6960c6 | MSPARSER_ALPHA_2_8_101-55-gcd2ba8afdf $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PEPTIDESUMMARY_MSR_HPP
20#define MS_PEPTIDESUMMARY_MSR_HPP
21
22
23// Includes from the standard template library
24#include <list>
25#include <map>
26#include <set>
27#include <unordered_set>
28#include <string>
29#include <vector>
30#include <thread>
31
32#include "ms_peptidesummarybase.hpp"
33#include "ms_cached_msr_pepsum_data.hpp"
34
35namespace matrix_science {
36 class ms_mascotresults_params;
37 class ms_protein;
38 class ms_datfile;
39 class ms_distiller_data;
40 class ms_distiller_data_search;
41 class ms_quant_component;
42 class ms_quant_modgroup;
43 class ms_linker_site;
44}
45
46using namespace matrix_science;
47
48namespace msparser_internal {
49 class ms_peptidesumsql;
50 class ms_mascotresults_msr;
51 class ms_peptide_impl_msr;
52 struct psmData_t;
53 class linearPeptideData_t;
54
56
63
69 class ms_peptidesummary_msr : public ms_peptidesummarybase
70 {
71 friend class msparser_internal::ms_peptide_impl_msr;
72 friend class ms_protein;
73 friend class msparser_internal::ms_peptidesumsql;
74 public:
75
77 static std::string getCacheFilename(
78 const ms_mascotresfile_msr & resfile,
79 const unsigned int flags,
80 double minProbability = 0.0,
81 int maxHitsToReport = 50,
82 const char * unigeneIndexFile = 0,
83 double ignoreIonsScoreBelow = 0.0,
84 int minPepLenInPepSummary = 0,
85 const char * singleHit = 0,
86 const unsigned int flags2 = ms_peptidesummary::MSPEPSUM_NONE);
87
89 static std::string getCacheFilename(
90 const ms_mascotresfile_msr & resfile,
91 const ms_mascotresults_params & parameters);
92
93 ms_peptidesummary_msr(
94 const ms_mascotresults_params & parameters,
95 const ms_mascotresfile_msr & resfile,
96 ms_peptidesummary & pepSum,
97 const int resfileId);
98
99
101 ms_peptidesummary_msr(
102 std::shared_ptr<ms_mascotresults_msr> resultsImpl,
103 ms_peptidesummary& pepSum,
104 const int resfileId);
105
106 void initialise(const ms_mascotresults_params& parameters, double minProbabilityForCache);
107
108 virtual ~ms_peptidesummary_msr();
109
111 const ms_mascotresfile_msr & mascotresfile() const;
112
114 bool createSummary() override;
115
116 std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
117 std::vector<int> & start,
118 std::vector<int> & end,
119 std::vector<std::string> &pre,
120 std::vector<std::string> &post,
121 std::vector<int> & frame,
122 std::vector<int> & multiplicity,
123 std::vector<int> & db,
124 std::vector<int64_t> & protId) const override;
125
126
128 std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
129 std::vector<int> & start,
130 std::vector<int> & end,
131 std::vector<std::string> &pre,
132 std::vector<std::string> &post,
133 std::vector<int> & frame,
134 std::vector<int> & multiplicity,
135 std::vector<int> & db,
136 std::vector<int64_t> & protId,
137 std::vector<int> & psmComponent) const override;
138
140 std::vector<int> getNumberOfAccessionDBTypes(const int q, const int p) const override;
141
143 std::string getLibraryModString(const int q, const int p) const override;
144
146 std::string getErrTolModMasterString(const int q, const int p) const override;
147
149 std::string getErrTolModSlaveString(const int q, const int p) const override;
150
152 std::string getErrTolModPepString(const int q, const int p) const override;
153
155 std::string getErrTolModReqPepString(const int q, const int p) const override;
156
158 std::string getErrTolOriginalNaSeq(const int q, const int p) const override;
159
161 std::string getErrTolModifiedNaSeq(const int q, const int p) const override;
162
164 std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) override;
165
167 std::string getTagString(const int q, const int p) const override;
168
170 int getTagDeltaRangeStart(const int q, const int p) const override;
171
173 int getTagDeltaRangeEnd(const int q, const int p) const override;
174
176 std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const override;
177
179 std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const override;
180
182 double getIonsScore(const int q, const int p, const bool decoy) const override;
183
185 int getSrcRank(int q, int p) const override;
186
188 ms_mascotresfile_dat::section getSrcSection(int q, int p)const override;
189
191 int findProteins(const int startHit,
192 const std::string & str,
193 const int dbIdx,
194 ms_mascotresults::FIND_FLAGS item,
195 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
196 std::vector<std::string> & accessions,
197 std::vector<int> & dbIndexes) const override;
198
200 int findProteinsByAccession(const int startHit,
201 const std::string & str,
202 const int dbIdx,
203 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
204 std::vector<std::string> & accessions,
205 std::vector<int> & dbIndexes) const override;
206
208 int findProteinsByDescription(const int startHit,
209 const std::string & str,
210 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
211 std::vector<std::string> & accessions,
212 std::vector<int> & dbIndexes) const override;
213
215 int findPeptides(const int startHit,
216 const std::string & str,
217 ms_mascotresults::FIND_FLAGS item,
218 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
219 std::vector<int> & q,
220 std::vector<int> & p) const override;
221
223 const ms_protein * getProtein(const char * accession, const int dbIdx = 1) const override;
224
226 const ms_protein * getComponentProtein(const char * accession, const int dbIdx = 1) const override;
227
229 static bool willCreateCache(const ms_mascotresfile_msr &resfile,
230 const unsigned int flags = ms_peptidesummary::MSRES_GROUP_PROTEINS,
231 double minProbability = 0.0,
232 int maxHits = 50,
233 const char * unigeneIndexFile = 0,
234 double ignoreIonsScoreBelow = 0.0,
235 int minPepLenInPepSummary = 0,
236 const char * singleHit = 0,
237 const unsigned int flags2 = ms_peptidesummary::MSPEPSUM_NONE);
238
240 static bool willCreateCache(const ms_mascotresfile_msr &resfile,
241 const ms_mascotresults_params & parameters);
242
243#ifndef SWIG
245 static bool willCreateCache(const char * resultsFileName,
246 const ms_mascotoptions & opts,
247 const char * unigeneIndexFile,
248 const char * singleHit,
249 const char * applicationName,
250 std::string & resfileCacheFileName,
251 std::string & peptideSummaryCacheFileName,
252 unsigned int & cacheStatus);
253
255 static bool willCreateCache(const ms_mascotresfile_msr & resfile,
256 const ms_mascotresults_params & parameters,
257 const ms_mascotoptions & opts,
258 std::string & peptideSummaryCacheFileName,
259 unsigned int & cacheStatus);
260#else // SWIG Multiple return values
261 static bool willCreateCache(const char * resultsFileName,
262 const ms_mascotoptions & opts,
263 const char * unigeneIndexFile,
264 const char * singleHit,
265 const char * applicationName,
266 std::string & OUTPUT,
267 std::string & OUTPUT,
268 unsigned int & OUTPUT);
269
270 static bool willCreateCache(const ms_mascotresfile_msr & resfile,
271 const ms_mascotresults_params & parameters,
272 const ms_mascotoptions & opts,
273 std::string & OUTPUT,
274 unsigned int & OUTPUT);
275#endif
276
278 bool isPeptideModificationMatch(
279 const ms_quant_modgroup & group,
280 const ms_peptide & peptide) const override;
281
283 bool isPeptideComponentMatch(
284 const ms_quant_component & component,
285 const ms_peptide & peptide) const override;
286
287
289 std::string getCacheFileName() const override;
290
292 bool isDataCached(ms_peptidesummary::BUGFIX_NUM bugNum) const override;
293
295 bool dumpCDB(const std::string dumpFileName) override;
296
298 void getLibraryEntryId(const int q, const int p, std::vector<int> &dbIdx, std::vector<int> &offset, std::vector<std::string> &checksum, std::vector<std::string> &mods) const override;
299
300 ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1) override;
301
302 bool isSlDb(int dbId) const { return (slDbs_.count(dbId) > 0); }
303
304 protected:
305 // Not safe to copy or assign this object.
306#ifndef SWIG
307 ms_peptidesummary_msr(const ms_peptidesummary_msr & rhs);
308 ms_peptidesummary_msr & operator=(const ms_peptidesummary_msr & rhs);
309#endif
310
311 //virtual bool queryHasSignificantRank1Match(ms_mascotresfile_dat::section secSummary,
312 // int query) const;
313
314 //double getFirstPassRank1Score(int query, bool decoy) const;
315
316 // virtual bool getThresholdForFDR(bool homology, double targetFDR,
317 // ms_mascotresults::DECOY_STATS_COUNT_TYPE countType, ms_mascotresults::DB_MATCH_TYPE dbType,
318 // double * closestFDR, double * minProbability,
319 // int * pNumTargetMatches, int * pNumDecoyMatches);
320 //void calculateDecoyStats(double dOneInXprobRnd);
321 //virtual void getQmatchValuesFromCacheFile(const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) const;
322 //virtual void getPlugholeValuesFromCacheFile(const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) const;
323 //virtual ms_mascotresfile_dat::section getSrcSectionProtected(const int query, const int rank) const;
324 //virtual bool cacheModificationCounts();
325
326
327 private:
328 using MonolinkVec = std::vector<std::pair<int, int>>; // position, modIdx
329
330 void initCache(const ms_mascotresults_params& parameters, double minProbabilityForCache) override;
331 void createCacheFile(bool isUsable) override;
332
333
334 std::string getErrTolModStringProtected(const int q, const int p, const int srcP, const ms_peptide::PSM_TYPE psmType) const override;
335
336 std::string getDecoyPeptideString(int q, int p) const override;
337
338 std::string getPeptideString(const int q, const int p, const bool isDecoy) const override;
339
340 std::map<int, msparser_internal::msr_cached_data::EtModsData> getEtModsCachedData(const int q, const ms_peptide::PSM_TYPE psmType) const override;
341 std::map<std::pair<int, int>, msparser_internal::msr_cached_data::TagData> getTagCachedData(const int q, const ms_peptide::PSM_TYPE psmType) const override;
342
343 TargetDecoyStatsAccums initDecoyStatsAccums() override;
344 void addToDecoyStatsAccums(TargetDecoyStatsAccums& accums, const bool doDecoy, const int q) override;
345 void finaliseDecoyStatsAccums(TargetDecoyStatsAccums& accums, const bool doDecoy) override;
346
347 void loadIntoProteins(const ms_peptide::PSM_TYPE psmType,
348 int q, int srcRank, int p,
349 double ionsScore,
350 ms_mascotresults::acc_dbidx_set_t * pAccessions,
351 bool isIgnored,
352 const int hitId=-1) override;
353
354 PeptidePtr loadPepResCrossLinked(const ms_peptide::PSM_TYPE psmType,
355 int q, int srcRank, int p,
356 double observed,
357 ms_peptide::SEARCH_PHASE searchPhase,
358 msparser_internal::ms_peptide_impl_reloadable * * pReloadable,
359 bool *pCanLoadIntoProteins,
360 bool &etOK) override;
361
362 PeptidePtr loadPepResLinear(const ms_peptide::PSM_TYPE psmType,
363 int q, int srcRank, int p,
364 double observed,
365 ms_peptide::SEARCH_PHASE searchPhase,
366 msparser_internal::ms_peptide_impl_reloadable * * pReloadable,
367 bool *pCanLoadIntoProteins,
368 bool &etOK) override;
369
370 void addQPinfoToCacheFile(const int q ) const override;
371
372 const ms_linker_site* _initImpl(const int q, const int p,
373 double& ionsScore,
374 std::unique_ptr<msparser_internal::psmData_t>& psmData,
375 std::unique_ptr<msparser_internal::linearPeptideData_t>& linearAlpha,
376 std::unique_ptr<msparser_internal::linearPeptideData_t>& linearBeta) const;
377
378 void _makeLookupModNameToChar(std::map<std::string, char>* modNameToChar) const;
379
380 std::shared_ptr<ms_mascotresults_msr> resultsImpl_;
381 const ms_mascotresfile_msr &resfile_;
382 ms_sqlpp11_connection & db_;
383 std::shared_ptr<msparser_internal::ms_peptidesumsql> pSqlCacheFile_;
384 ms_peptidesummary & pepSum_;
385 ms_errs* getLogger() const;
386
387 static constexpr int CACHE_SIZE = 10; // Seems to be better than 5 or 20
388 using PepCache = std::map< int, std::array<msparser_internal::msr_cached_data::Peptides, CACHE_SIZE> >;
389 thread_local static PepCache peptidesCache_;
390 void _cachePeptideData(const int q) const;
391
392 // db index of all the Sls
393 mutable std::unordered_set<int> slDbs_;
394
395 using ProteinMatchDataCache = std::map< int, std::array<msparser_internal::msr_cached_data::ProteinMatchDataPerQuery, CACHE_SIZE> >;
396 // (q, p) -> ProteinMatchData
397 thread_local static ProteinMatchDataCache protMatchDataCache_;
398 void _cachePepProteinsData(const int query) const;
399
400 int resfileId_;
401
402
403 }; // end of resfile_group
405
407
408} // msparser_internal namespace
409
410#endif // MS_PEPTIDESUMMARY_MSR_HPP
411
412/*------------------------------- End of File -------------------------------*/
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_distiller_data_search
The details of a Distiller search.
Definition: ms_distiller_data_search.hpp:52
matrix_science::ms_distiller_data
Distiller project parameters.
Definition: ms_distiller_data.hpp:49
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresfile_msr
Class for parsing and reading files in MSR format.
Definition: ms_mascotresfile_msr.hpp:105
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults::FIND_COMPARE_FLAGS
FIND_COMPARE_FLAGS
Flags to specify how comparisons are performed in the find functions.
Definition: ms_mascotresults.hpp:189
matrix_science::ms_mascotresults::FIND_FLAGS
FIND_FLAGS
Flags for findPeptides() and findProteins().
Definition: ms_mascotresults.hpp:146
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_peptide::PSM_COMPLETE
@ PSM_COMPLETE
Peptide-spectrum match, also linear peptide in a non-crosslinked match.
Definition: ms_peptide.hpp:99
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_peptidesummary::BUGFIX_NUM
BUGFIX_NUM
bugNum values for isDataCached().
Definition: ms_peptidesummary.hpp:70
matrix_science::ms_peptidesummary::MSPEPSUM_NONE
@ MSPEPSUM_NONE
Default.
Definition: ms_peptidesummary.hpp:141
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_modgroup
An object of this class represent a single modification group element in quantitation....
Definition: ms_quant_modgroup.hpp:46
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptidesummary_nil.hpp Source File

  • src
  • resfile
  • impl
ms_peptidesummary_nil.hpp
1/*
2##############################################################################
3# file: ms_mascotrespeptidesum_nil.hpp #
4# 'msparser' toolkit #
5# Encapsulates the peptide summary report from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_msr_1.2/include/ms_mascotrespe $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-08-10 09:04:31 +0100 $ #
14# $Revision: 74ced94100ba2b07d3fc7012fa1e2d91ee6960c6 | MSPARSER_ALPHA_2_8_101-55-gcd2ba8afdf $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PEPTIDESUMMARY_NIL_HPP
20#define MS_PEPTIDESUMMARY_NIL_HPP
21
22
23// Includes from the standard template library
24#include <vector>
25
26#include "ms_peptidesummarybase.hpp"
27#include "ms_peptidesumnil.hpp"
28#include "ms_mascotresults_nil.hpp"
29
30namespace matrix_science {
31 class ms_mascotresults_params;
32 class ms_protein;
33 class ms_datfile;
34 class ms_distiller_data;
35 class ms_distiller_data_search;
36 class ms_quant_component;
37 class ms_quant_modgroup;
38 class ms_linker_site;
39}
40
41using namespace matrix_science;
42
43namespace msparser_internal {
44
45 class ms_peptidesummary_nil : public ms_peptidesummarybase
46 {
47 public:
48
49 static std::string getCacheFilename(
50 const ms_mascotresfile_nil & resfile,
51 const unsigned int flags,
52 double minProbability = 0.0,
53 int maxHitsToReport = 50,
54 const char * unigeneIndexFile = 0,
55 double ignoreIonsScoreBelow = 0.0,
56 int minPepLenInPepSummary = 0,
57 const char * singleHit = 0,
58 const unsigned int flags2 = ms_peptidesummary::MSPEPSUM_NONE)
59 { return {}; }
60
61 static std::string getCacheFilename(
62 const ms_mascotresfile_nil & resfile,
63 const ms_mascotresults_params & parameters)
64 { return {}; }
65
66 ms_peptidesummary_nil(
67 const ms_mascotresults_params & parameters,
68 const ms_mascotresfile_nil & resfile,
69 ms_peptidesummary & pepSum,
70 const int resfileId)
71 : ms_peptidesummary_nil(std::make_shared<ms_mascotresults_nil>(resfile, pepSum, *this, parameters), pepSum, resfileId)
72 {}
73 ms_peptidesummary_nil(
74 std::shared_ptr<ms_mascotresults_nil> resultsImpl,
75 ms_peptidesummary& pepSum,
76 const int resfileId)
77 : ms_peptidesummarybase(resultsImpl, pepSum),
78 resultsImpl_(resultsImpl),
79 resfile_(resultsImpl_->getResfile()),
80 pepSum_(pepSum)
81 {}
82
83
84
85
86 virtual ~ms_peptidesummary_nil(){}
87
88 const ms_mascotresfile_nil & mascotresfile() const { return resfile_;}
89
90 bool createSummary() override { return ms_peptidesummarybase::createSummary(); }
91
92 std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
93 std::vector<int> & start,
94 std::vector<int> & end,
95 std::vector<std::string> &pre,
96 std::vector<std::string> &post,
97 std::vector<int> & frame,
98 std::vector<int> & multiplicity,
99 std::vector<int> & db,
100 std::vector<int64_t> & protId) const override
101 { return {}; }
102
103 std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
104 std::vector<int> & start,
105 std::vector<int> & end,
106 std::vector<std::string> &pre,
107 std::vector<std::string> &post,
108 std::vector<int> & frame,
109 std::vector<int> & multiplicity,
110 std::vector<int> & db,
111 std::vector<int64_t> & protId,
112 std::vector<int> & psmComponent) const override
113 { return {}; }
114
115 std::vector<int> getNumberOfAccessionDBTypes(const int q, const int p) const override { return {}; }
116
117 std::string getLibraryModString(const int q, const int p) const override { return {}; }
118
119 std::string getErrTolModMasterString(const int q, const int p) const override { return {}; }
120
121 std::string getErrTolModSlaveString(const int q, const int p) const override { return {}; }
122
123 std::string getErrTolModPepString(const int q, const int p) const override { return {}; }
124
125 std::string getErrTolModReqPepString(const int q, const int p) const override { return {}; }
126
127 std::string getErrTolOriginalNaSeq(const int q, const int p) const override { return {}; }
128
129 std::string getErrTolModifiedNaSeq(const int q, const int p) const override { return {}; }
130
131 std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) override { return {}; }
132
133 std::string getTagString(const int q, const int p) const override { return {};}
134
135 int getTagDeltaRangeStart(const int q, const int p) const override { return {}; }
136
137 int getTagDeltaRangeEnd(const int q, const int p) const override { return 0; }
138
139 std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const override
140 { return {}; }
141
142 std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const override
143 { return {}; }
144
145 double getIonsScore(const int q, const int p, const bool decoy) const override { return 0.0; }
146
147 int getSrcRank(int q, int p) const override { return 0; }
148
149 ms_mascotresfile_dat::section getSrcSection(int q, int p) const override { return ms_mascotresfile_dat::SEC_PARAMETERS; }
150
151 int findProteins(const int startHit,
152 const std::string & str,
153 const int dbIdx,
154 ms_mascotresults::FIND_FLAGS item,
155 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
156 std::vector<std::string> & accessions,
157 std::vector<int> & dbIndexes) const override
158 { return 0; }
159
160 int findProteinsByAccession(const int startHit,
161 const std::string & str,
162 const int dbIdx,
163 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
164 std::vector<std::string> & accessions,
165 std::vector<int> & dbIndexes) const override
166 { return 0; }
167
168 int findProteinsByDescription(const int startHit,
169 const std::string & str,
170 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
171 std::vector<std::string> & accessions,
172 std::vector<int> & dbIndexes) const override
173 { return 0; }
174
175 int findPeptides(const int startHit,
176 const std::string & str,
177 ms_mascotresults::FIND_FLAGS item,
178 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
179 std::vector<int> & q,
180 std::vector<int> & p) const override
181 { return 0; }
182
183 const ms_protein * getProtein(const char * accession, const int dbIdx = 1) const override
184 { return nullptr; }
185
186 const ms_protein * getComponentProtein(const char * accession, const int dbIdx = 1) const override
187 { return nullptr; }
188
189 static bool willCreateCache(const ms_mascotresfile_nil &resfile,
190 const unsigned int flags = ms_peptidesummary::MSRES_GROUP_PROTEINS,
191 double minProbability = 0.0,
192 int maxHits = 50,
193 const char * unigeneIndexFile = 0,
194 double ignoreIonsScoreBelow = 0.0,
195 int minPepLenInPepSummary = 0,
196 const char * singleHit = 0,
197 const unsigned int flags2 = ms_peptidesummary::MSPEPSUM_NONE)
198 { return false; }
199
200 static bool willCreateCache(const ms_mascotresfile_nil &resfile,
201 const ms_mascotresults_params & parameters) { return false; }
202
203 static bool willCreateCache(const char * resultsFileName,
204 const ms_mascotoptions & opts,
205 const char * unigeneIndexFile,
206 const char * singleHit,
207 const char * applicationName,
208 std::string & resfileCacheFileName,
209 std::string & peptideSummaryCacheFileName,
210 unsigned int & cacheStatus)
211 { return false; }
212
213
214 static bool willCreateCache(const ms_mascotresfile_nil & resfile,
215 const ms_mascotresults_params & parameters,
216 const ms_mascotoptions & opts,
217 std::string & peptideSummaryCacheFileName,
218 unsigned int & cacheStatus)
219 { return false; }
220
221 bool isPeptideModificationMatch(
222 const ms_quant_modgroup & group,
223 const ms_peptide & peptide) const override
224 { return false; }
225
226 bool isPeptideComponentMatch(
227 const ms_quant_component & component,
228 const ms_peptide & peptide) const override
229 { return false; }
230
231 std::string getCacheFileName() const override
232 { return {}; }
233
234 bool isDataCached(ms_peptidesummary::BUGFIX_NUM bugNum) const override { return false; }
235
236 bool dumpCDB(const std::string dumpFileName) override { return false; }
237
238 void getLibraryEntryId(const int q, const int p, std::vector<int> &dbIdx, std::vector<int> &offset, std::vector<std::string> &checksum, std::vector<std::string> &mods) const override {}
239
240 ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1) override { return {}; }
241
242 double getTolerance() const { return 0.0; }
243
244 double getToleranceFactor() const { return 0.0; }
245 void initCache(const ms_mascotresults_params& parameters, double minProbabilityForCache) override {
246 pCacheFile_ = std::make_shared<ms_peptidesumnil>(resfile_, parameters,false, minProbabilityForCache);
247 }
248
249 private:
250
251 void createCacheFile(bool isUsable) override {}
252
253 std::string getErrTolModStringProtected(const int q, const int p, const int srcP, const ms_peptide::PSM_TYPE psmType) const override { return {}; }
254
255 std::string getDecoyPeptideString(int q, int p) const override { return {}; }
256
257 std::string getPeptideString(const int q, const int p, const bool isDecoy) const override { return {}; }
258
259 std::map<int, msparser_internal::msr_cached_data::EtModsData> getEtModsCachedData(const int q, const ms_peptide::PSM_TYPE psmType) const override { return {}; }
260 std::map<std::pair<int, int>, msparser_internal::msr_cached_data::TagData> getTagCachedData(const int q, const ms_peptide::PSM_TYPE psmType) const override { return {}; }
261
262 TargetDecoyStatsAccums initDecoyStatsAccums() override { return {}; }
263 void addToDecoyStatsAccums(TargetDecoyStatsAccums& accums, const bool doDecoy, const int q) override {}
264 void finaliseDecoyStatsAccums(TargetDecoyStatsAccums& accums, const bool doDecoy) override {}
265
266 void loadIntoProteins(const ms_peptide::PSM_TYPE psmType,
267 int q, int srcRank, int p,
268 double ionsScore,
269 ms_mascotresults::acc_dbidx_set_t * pAccessions,
270 bool isIgnored,
271 const int hitId=-1) override {}
272
273 PeptidePtr loadPepResCrossLinked(const ms_peptide::PSM_TYPE psmType,
274 int q, int srcRank, int p,
275 double observed,
276 ms_peptide::SEARCH_PHASE searchPhase,
277 msparser_internal::ms_peptide_impl_reloadable * * pReloadable,
278 bool *pCanLoadIntoProteins,
279 bool &etOK) override { return nullptr; }
280
281 PeptidePtr loadPepResLinear(const ms_peptide::PSM_TYPE psmType,
282 int q, int srcRank, int p,
283 double observed,
284 ms_peptide::SEARCH_PHASE searchPhase,
285 msparser_internal::ms_peptide_impl_reloadable * * pReloadable,
286 bool *pCanLoadIntoProteins,
287 bool &etOK) override { return nullptr; }
288
289 void addQPinfoToCacheFile(const int q ) const override {}
290
291 std::shared_ptr<ms_mascotresults_nil> resultsImpl_;
292 const ms_mascotresfile_nil &resfile_;
293 ms_peptidesummary & pepSum_;
294 };
295} // msparser_internal namespace
296
297#endif // MS_PEPTIDESUMMARY_NIL_HPP
298
299/*------------------------------- End of File -------------------------------*/
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_distiller_data_search
The details of a Distiller search.
Definition: ms_distiller_data_search.hpp:52
matrix_science::ms_distiller_data
Distiller project parameters.
Definition: ms_distiller_data.hpp:49
matrix_science::ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink.
Definition: ms_linker_site.hpp:42
matrix_science::ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot....
Definition: ms_mascotoptions.hpp:91
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresfile_dat::SEC_PARAMETERS
@ SEC_PARAMETERS
parameters section
Definition: ms_mascotresfile_dat.hpp:133
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults::FIND_COMPARE_FLAGS
FIND_COMPARE_FLAGS
Flags to specify how comparisons are performed in the find functions.
Definition: ms_mascotresults.hpp:189
matrix_science::ms_mascotresults::FIND_FLAGS
FIND_FLAGS
Flags for findPeptides() and findProteins().
Definition: ms_mascotresults.hpp:146
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_peptide::PSM_COMPLETE
@ PSM_COMPLETE
Peptide-spectrum match, also linear peptide in a non-crosslinked match.
Definition: ms_peptide.hpp:99
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_peptidesummary::BUGFIX_NUM
BUGFIX_NUM
bugNum values for isDataCached().
Definition: ms_peptidesummary.hpp:70
matrix_science::ms_peptidesummary::MSPEPSUM_NONE
@ MSPEPSUM_NONE
Default.
Definition: ms_peptidesummary.hpp:141
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_modgroup
An object of this class represent a single modification group element in quantitation....
Definition: ms_quant_modgroup.hpp:46
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptidesummarybase.hpp Source File

  • src
  • resfile
  • impl
ms_peptidesummarybase.hpp
1/*
2##############################################################################
3# file: ms_peptidesummarybase.hpp #
4# 'msparser' toolkit #
5# Encapsulates the peptide summary report from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-02-08 10:46:35 +0000 $ #
14# $Revision: 61b805caf9910b1b33024ebe6ec9ec710cf9ff82 | MSPARSER_ALPHA_2_8_100-415-g06b6ad6513 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PEPTIDESUMMARYBASE_HPP
20#define MS_PEPTIDESUMMARYBASE_HPP
21
22
23// Includes from the standard template library
24#include <list>
25#include <map>
26#include <set>
27#include <string>
28#include <vector>
29
30#include "ms_mascotresultsbase.hpp"
31using namespace matrix_science;
32
33namespace msparser_internal {
34 class ms_peptide_impl_reloadable;
35 class ms_peptidesummary_fdr_query_data_extractor;
36 class ms_peptidesummary_fdr_peptides_vector_extractor;
37 class ms_peptidesumcache;
38 class ms_peptidesumcdb;
39 class ms_peptidesumsql;
40 class ms_decoystats_accumulator;
41
43
49 using PeptidePtr = std::shared_ptr<ms_peptide>;
50
51 struct ms_percolator_score {
52 double percolatorScore;
53 double qValue;
54 double percolatorPEP;
55 double mascotScore;
56 bool foundInPopFile;
57 ms_percolator_score()
58 : percolatorScore(0.0)
59 , qValue(1.0)
60 , percolatorPEP(1.0)
61 , mascotScore(0.0)
62 , foundInPopFile(false)
63 {}
64 };
65
66 typedef std::vector<ms_percolator_score> ms_percolator_scores_vector;
67
68 class ms_peptidesummarybase : public ms_mascotresultsbase
69 {
70 friend class ms_peptidesummary_fdr_query_data_extractor;
71 friend class ms_peptidesummary_fdr_peptides_vector_extractor;
72 friend class ms_peptidesumcdb;
73 friend class ms_peptidesumsql;
74 friend class ms_decoystats_accumulator;
75 public:
76
77 static const unsigned int ETT_NONE;
78 static const unsigned int ETT_ORIGINAL;
79 static const unsigned int ETT_STANDARD_FROM_INTEGRATED;
80 static const unsigned int ETT_JUST_ET_FROM_INTEGRATED;
81 static const unsigned int ETT_INTEGRATED_FROM_INTEGRATED;
82
83 struct componentIdentifier_t {
84 int q_;
85 short p_;
86 short componentID_;
87 componentIdentifier_t(int q, short p, short cid) : q_(q), p_(p), componentID_(cid) { };
88 componentIdentifier_t(const std::string & q, const std::string & p, const std::string & componentID);
89 std::string asString() const;
90 bool operator<(const componentIdentifier_t & right) const;
91 };
92 typedef std::map<componentIdentifier_t, std::pair<double, double> > componentIntensities_t;
93 typedef std::map<std::string, short> componentNames_t;
94
95 static ms_mascotresults_params getValidatedResultsParameters(
96 const ms_mascotresfilebase &resfile, const ms_mascotresults_params &params,
97 double * minProbabilityForCache = 0);
98
100 static double getMinProbabilityForSLScore(double score);
101
103 static double getSLThresholdFromMinProbability(double minProbability);
104
105
106 ms_peptidesummarybase(
107 std::shared_ptr<ms_mascotresults_implbase> resultsImpl,
108 ms_peptidesummary& pepSum);
109
110 virtual ~ms_peptidesummarybase() {}
111
113 bool createSummary() override;
114
115 virtual void initialise(const ms_mascotresults_params& parameters, double minProbabilityForCache);
116
117 bool anyEmPAI() const override;
118
120 double getProteinEmPAI(const char *accession, const int dbIdx = 1, int length = -1) const override;
121
122
123 bool queryHasSignificantRank1Match(ms_peptide::PSM_TYPE psmType,
124 int query) const override;
125
127 bool isPeptideUnique(const int q, const int p, const ms_mascotresults::UNIQUE_PEP_RULES rules = ms_mascotresults::UPR_DEFAULT) const override;
128
130 bool isValidQandP(const int q, const int p) const override;
131
133 bool loadPepMatchesForProteinFromCache(ms_protein * prot, const bool loadRelated = true) override;
134
136 bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & value, double & rawValue) const override;
137
139 ms_peptide getPeptide(const int q, const int p) const override;
140
142 bool getPeptide(const int q, const int p, ms_peptide* & pep) const override;
143
145 ms_protein * getHit(const int hit, const int memberNumber = 0) const override;
146
148 void freeHit(const int hit) override;
149
151 int getAllFamilyMembersWithThisPepMatch(const int hit,
152 const int q,
153 const int p,
154 std::vector< int >& db,
155 std::vector< std::string >& acc,
156 std::vector< int >& dupe_status) const override;
157
158 int getAllFamilyMembersWithThisPepMatchProtected(const int hit,
159 const int q,
160 const int p,
161 std::vector< int >& db,
162 std::vector< std::string >& acc,
163 std::vector<int64_t> & protId,
164 std::vector< int >& dupe_status) const override;
165
167 std::vector<int> getNumberOfFamilyAccessionDBTypes(const int hit, const int q, const int p, bool includeSamesets = true) const;
168
169 bool getHitAndFamilyMember(
170 const ms_protein * prot, ms_mascotresults::hitAndFamily_t & hitAndFamily,
171 const ms_mascotresults::UNIQUE_PEP_RULES rules) const;
172
173 virtual void getLibraryEntryId(
174 const int q, const int p, std::vector<int> &dbIdx,
175 std::vector<int> &offset, std::vector<std::string> &checksum,
176 std::vector<std::string> &mods) const = 0;
177
178 virtual std::vector<int> getNumberOfAccessionDBTypes(const int q, const int p) const = 0;
179
180 ms_peptide::PSM_TYPE getSrcPsmType(int q, int p) const;
181
182 virtual int getSrcRank(int q, int p) const = 0;
183
185 std::vector<int> getPepsWithSameScore(const int q, const int p) const override;
186
187 virtual ms_mascotresfile_dat::section getSrcSection(int q, int p) const = 0;
188
190 std::string getQueryList(ms_peptidesummary::QL_FLAG flag, bool outputListOfQueries = true);
191
193 std::vector<int> getPeptideAmbiguityRanks(const int q, const int p);
194
196 int getProteinScoreCutoff(double OneInXprobRnd) const override;
197
199 bool getTreeClusterNodes(const int hit,
200 std::vector<int> &left,
201 std::vector<int> &right,
202 std::vector<double> &distance,
203 ms_mascotresults::TREE_CLUSTER_METHOD tcm = ms_mascotresults::TCM_PAIRWISE_MAXIMUM,
204 double *** reserved1 = 0,
205 unsigned int * reserved2 = 0) const override;
206
207
209 ms_mascotresults::QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide(
210 const ms_peptide & peptide,
211 ms_quant_component & component,
212 const ms_quant_method * method = NULL) const override;
213
214 bool hasQuantMethod() const;
215
216 bool hasCrosslinkingMethod() const;
217
218 const matrix_science::ms_crosslinking_method * getCrosslinkingMethod() const;
219
220 const matrix_science::ms_quant_method * getQuantMethod() const;
221
222 virtual bool isDataCached(ms_peptidesummary::BUGFIX_NUM bugNum) const = 0;
223
224 bool rerankingCouldHappen() const;
225
226 virtual bool isPeptideModificationMatch(
227 const ms_quant_modgroup & group,
228 const ms_peptide & peptide) const = 0;
229
230 virtual bool isPeptideComponentMatch(
231 const matrix_science::ms_quant_component & component,
232 const matrix_science::ms_peptide & peptide) const = 0;
233
234 virtual std::string getCacheFileName() const = 0;
235
236 double getTolerance() const { return tolerance_; }
237 double getToleranceFactor() const { return toleranceFactor_; }
238
239 virtual bool dumpCDB(const std::string dumpFileName) = 0;
240
241 protected:
242
243 enum PEP_SECTIONS { PEP_SEC_INVALID = 0,
244 PEP_SEC_PEPTIDES = 1,
245 PEP_SEC_DECOYPEPTIDES = 2,
246 PEP_SEC_ERRTOLPEPTIDES = 3,
247 // Do not ever add more enums here. Maximum is 4.
248 PEP_SEC_LAST = 4};
249 // For each of these, use SR_MASK_ and then, if required, >> SR_SHIFT_
250 enum SRC_RANK_MASKS { SR_MASK_RANK = 0x0F, // bits 0..3
251 SR_MASK_SEC = 0x30, // bits 4..5
252 SR_MASK_REJECT = 0x40, // bit 6 If discarded because below threshold or other rule
253 SR_MASK_LIBRARY = 0x80, // bit 7
254
255 SR_MASK_CROSSLINK = 0x0100, // bit 8 (bit 1 in upper 8 bits)
256 SR_MASK_ERRTOL = 0x0200, // bit 9 (bit 2 in upper 8 bits)
257
258 SR_SHIFT_RANK = 0x00, // bits 0..3 - no need to shift
259 SR_SHIFT_SEC = 0x04, // bits 4..5
260 SR_SHIFT_REJECT = 0x06, // bit 6 If discarded because below threshold or other rule
261 SR_SHIFT_LIBRARY = 0x07, // bit 7
262
263 SR_SHIFT_CROSSLINK = 0x08, // bit 8 (bit 1 in upper 8 bits)
264 SR_SHIFT_ERRTOL = 0x09 // bit 9 (bit 2 in upper 8 bits)
265 };
266
267 virtual void initCache(const ms_mascotresults_params& parameters, double minProbabilityForCache) = 0;
268 virtual void createCacheFile(bool isUsable) = 0;
269
270 void countDBTypes(const std::vector<int> &db, std::vector<int> &counts) const;
271
272 virtual void finishTmpCache() {}
273
274 double initOriginalErrTol(const int q);
275
276 // Some private variables and functions for error tolerant search
277 bool checkErrorTolerantStatus(ms_peptide::PSM_TYPE psmType,
278 int q, int p, double ionsScore,
279 bool fromET,
280 const std::string & pepStr);
281
282 PeptidePtr loadPepRes(const ms_peptide::PSM_TYPE psmType,
283 int q, int srcRank, int p,
284 msparser_internal::ms_peptide_impl_reloadable * * pReloadable = 0,
285 bool *canLoadIntoProteins = 0);
286
287 virtual PeptidePtr loadPepResCrossLinked(const ms_peptide::PSM_TYPE psmType,
288 int q, int srcRank, int p,
289 double observed,
290 ms_peptide::SEARCH_PHASE searchPhase,
291 msparser_internal::ms_peptide_impl_reloadable * * pReloadable,
292 bool *pCanLoadIntoProteins,
293 bool &etOK) = 0;
294
295 virtual PeptidePtr loadPepResLinear(const ms_peptide::PSM_TYPE psmType,
296 int q, int srcRank, int p,
297 double observed,
298 ms_peptide::SEARCH_PHASE searchPhase,
299 msparser_internal::ms_peptide_impl_reloadable * * pReloadable,
300 bool *pCanLoadIntoProteins,
301 bool &etOK) = 0;
302
303 void determinePrettyRanksAndAmbiguityGroupIds(const int q, std::vector<PeptidePtr> &peptides);
304
305 virtual void loadIntoProteins(const ms_peptide::PSM_TYPE psmType,
306 int q, int srcRank, int p,
307 double ionsScore,
308 ms_mascotresults::acc_dbidx_set_t * pAccessions,
309 bool isIgnored,
310 const int hitId=-1) = 0;
311
312 bool getPeptideFromCache(const int q, const int p, ms_peptide* & pep) const;
313
314 virtual std::string getDecoyPeptideString(int q, int p) const = 0;
315
316 virtual std::string getPeptideString(const int q, const int p, const bool isDecoy) const = 0;
317
318 double getFirstPassRank1Score(int query, bool decoy) const;
319
320
321 ms_peptide::PSM_TYPE getSrcPsmTypeProtected(const int query, const int rank) const override;
322
324 std::string getErrTolModString(const int q, const int p) const override;
325
326 virtual std::string getErrTolModStringProtected(const int q, const int p, const int srcP, const ms_peptide::PSM_TYPE psmType) const = 0;
327
328
329 bool getThresholdForFDR(bool homology, double targetFDR,
330 ms_mascotresults::DECOY_STATS_COUNT_TYPE countType, ms_mascotresults::DB_MATCH_TYPE dbType,
331 double * closestFDR, double * minProbability,
332 int * pNumTargetMatches, int * pNumDecoyMatches) override;
333
334 void setSrcRank(int q, int p, int srcRank, ms_peptide::PSM_TYPE psmType, bool rejected, std::vector<unsigned short> &srcRankVec) const;
335 int getSrcRankAndPsmType(int q, int p, ms_peptide::PSM_TYPE & psmType, bool * pRejected = 0, bool inactiveSection = false) const override;
336
337 ms_errs* getLogger() const;
338
339 void determineSortingScore(ms_peptide *pep) const;
340
341 void calculateDecoyStats(double dOneInXprobRnd) override;
342
343 void setDecoyStats(const ms_decoystats_accumulator& accum);
344
345 using TargetDecoyStatsAccums = std::pair<std::shared_ptr<ms_decoystats_accumulator>, std::shared_ptr<ms_decoystats_accumulator>>;
346 virtual TargetDecoyStatsAccums initDecoyStatsAccums() { return TargetDecoyStatsAccums(); };
347 virtual void addToDecoyStatsAccums(TargetDecoyStatsAccums& accums, const bool doDecoy, const int q) {};
348 virtual void finaliseDecoyStatsAccums(TargetDecoyStatsAccums& accums, const bool doDecoy) {};
349
350 ms_percolator_score calculatePercolatorScores(const int q, const int srcRank, const int p, const ms_peptide::PSM_TYPE psmType, const double ionsScore) const;
351
352 double minIonsScoreForMatch(const int q,
353 const ms_peptide::PSM_TYPE psmType) const;
354
355 bool isPeptideModificationMatch(
356 const ms_quant_modgroup &group,
357 const std::string &varModStr,
358 const std::string &summedModStr,
359 const std::vector<int> &slModifiedPositions,
360 const std::string &pepStr,
361 const bool isAnyProteinNterminus,
362 const bool isAnyProteinCterminus) const;
363
364 bool cacheModificationCounts() override;
365
366 void dumpFlags(std::string fileName);
367
368 int singleHitDbIdx_;
369
370 unsigned int errTolType_;
371 bool missingErrTolParent_;
372 bool acceptAllErrTolMatches_;
373 std::unique_ptr<ms_mascotresfilebase> errTolSource_;
374 std::shared_ptr<ms_peptidesummarybase> errTolPepSummary_;
375
376
377 std::vector<bool> queryHasSignificant1stPassTarget_, queryHasSignificant1stPassDecoy_;
378 mutable std::vector<double> memoFirstPassRank1ScoreTarget_, memoFirstPassRank1ScoreDecoy_;
379
380 ms_peptide::PSM_TYPE typePeptidesInactive_, typePeptidesActiveCompanion_, typePeptidesInactiveCompanion_;
381 std::vector<unsigned short> srcRankActiveSection_, srcRankInactiveSection_;
382 bool srcRankInitialised_;
383
384 ms_percolator_scores_vector targetPercolatorScores_;
385 ms_percolator_scores_vector decoyPercolatorScores_;
386
387 // percolatorScores_ references targetPercolatorScores_ unless
388 // MSRES_DECOY is specified, in which case it references
389 // decoyPercolatorScores_
390 ms_percolator_scores_vector & percolatorScores_;
391
392 //BUG#13406
393 bool usePercolatorQValSigThres_;
394
395 std::shared_ptr<msparser_internal::ms_peptidesumcache> pCacheFile_;
396
397 /* emPAI related values and helper methods */
398 bool emPAIminmaxDone_;
399 int emPAIminCleavageN_;
400 int emPAImaxCleavageN_;
401 bool emPAInetCleavageDone_;
402 double netCleavageAbundance_;
403
404 void init_emPAImzRange();
405 void init_netCleavageAbundance();
406 double calculate_AA_abundance(std::string) const;
407 double calculate_emPAI_num_observable(int) const;
408
409 mutable std::map<std::string, char> modfileLookup_;
410 mutable bool quantMethodCached_;
411 mutable std::shared_ptr<ms_quant_method> quantMethod_;
412 mutable bool crosslinkingMethodCached_;
413 mutable std::shared_ptr<ms_crosslinking_method> crosslinkingMethod_;
414
415
416 unsigned char secLookupFwd_[ms_peptide::N_PSM_TYPES+1];
417 ms_peptide::PSM_TYPE secLookupRev_[PEP_SEC_LAST];
418
419 ms_peptidesummary & pepSum_;
420
421 private:
422
423 struct distanceInfo_t {
424 double scoreExcess;
425 std::string peptideStr;
426 bool isFromLibrary;
427 distanceInfo_t():
428 scoreExcess(0.0), peptideStr(), isFromLibrary(false)
429 {}
430 distanceInfo_t(double se, std::string & pep, bool fromLib):
431 scoreExcess(se), peptideStr(pep), isFromLibrary(fromLib)
432 {}
433 };
434
435
436 void accumulateSameSequenceScores(int q, const std::vector<PeptidePtr> &peptides,
437 std::vector< std::pair<double, double> > *observed_rank_1_same_seq,
438 std::vector<double> *library_rank_1_scores) const;
439
440 typedef std::map<std::pair<int, int>, distanceInfo_t> distanceInfoMap_t;
441 double getDistance(const distanceInfoMap_t & a, const distanceInfoMap_t & b) const;
442
443
444 void detectChimericDuplicates(const std::list<int> &query_set,
445 const std::vector<PeptidePtr> &peptides,
446 std::set<int> &is_chimeric_duplicate) const;
447
448 void massageQuery(int q, std::vector<PeptidePtr> &peptides,
449 ms_peptide::PSM_TYPE typePeptides,
450 ms_peptide::PSM_TYPE typePeptidesCompanion,
451 std::vector<unsigned short> &srcRank,
452 const std::set<int> &is_chimeric_duplicate,
453 bool load_proteins);
454
455 bool readPercolatorOutputFile(bool decoyResults,
456 ms_percolator_scores_vector * pVector = 0,
457 long * pNumAboveIdentity = 0,
458 double threshold = 0.05);
459
460 void loadQuery(int q, std::vector<PeptidePtr> & peptides,
461 int rankStart, int rankEnd,
462 ms_peptide::PSM_TYPE typePeptides,
463 ms_peptide::PSM_TYPE typePeptidesCompanion);
464
465
466 void determineFirstPassSignificance(const std::vector<PeptidePtr> &peptides,
467 ms_peptide::PSM_TYPE typeSummary,
468 std::vector<bool> &queryHasSignificantFirstPass,
469 std::vector<double> &memoFirstPassRank1Score) const;
470
471 bool _hasDecoy() const;
472
473 componentIntensities_t cachedComponentIntensities_;
474 bool cacheComponentIntensities(bool & isUsable);
475 componentNames_t componentNames_;
476 bool componentIntensitiesLoaded_;
477
478 mutable std::map< std::pair<int, int>, bool > uniquePepLookup_; // only used when no cache file
479
480 double tolerance_;
481 double toleranceFactor_; // set to -1 if tolerance is not relative to mass.
482
483 // The only differential data that empty ms_peptides in peptides_ contain is whether they are ET or from SL
484 // (getIsFromErrorTolerant() or getIsFromLibrary()))
485 // Only allocate a new ms_peptide when it is requested from somewhere outside ms_peptidesummarybase with a call to getPeptide()
486 PeptidePtr _getEmptyPeptidePtr(ms_peptide::SEARCH_PHASE searchPhase) const;
487 // All the empty ET peptides in peptides_ point to this:
488 PeptidePtr etEmptyPeptidePtr_,
489 // All the empty SL peptides point to this:
490 slEmptyPeptidePtr_,
491 // The rest of empty peptides point to this:
492 primaryEmptyPeptidePtr_;
493 // This holds the peptide returned by getPeptide()
494 thread_local static ms_peptide emptyPeptide_;
495
496
497 }; // end of resfile_group
499
501
502} // msparser_internal namespace
503
504#endif // MS_PEPTIDESUMMARYBASE_HPP
505
506/*------------------------------- End of File -------------------------------*/
matrix_science::ms_crosslinking_method
Represents a method object in crosslinking.xml
Definition: ms_crosslinking_method.hpp:50
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults::TREE_CLUSTER_METHOD
TREE_CLUSTER_METHOD
Flags for getTreeClusterNodes().
Definition: ms_mascotresults.hpp:128
matrix_science::ms_mascotresults::TCM_PAIRWISE_MAXIMUM
@ TCM_PAIRWISE_MAXIMUM
'm': pairwise maximum- (or complete-) linkage clustering.
Definition: ms_mascotresults.hpp:131
matrix_science::ms_mascotresults::DECOY_STATS_COUNT_TYPE
DECOY_STATS_COUNT_TYPE
Type of object counted by getNumHitsAboveIdentity() and friends.
Definition: ms_mascotresults.hpp:382
matrix_science::ms_mascotresults::UNIQUE_PEP_RULES
UNIQUE_PEP_RULES
Flags for isPeptideUnique().
Definition: ms_mascotresults.hpp:360
matrix_science::ms_mascotresults::UPR_DEFAULT
@ UPR_DEFAULT
Set to UPR_WITHIN_FAMILY_MEMBER | UPR_IGNORE_SUBSET_PROTEINS.
Definition: ms_mascotresults.hpp:365
matrix_science::ms_mascotresults::DB_MATCH_TYPE
DB_MATCH_TYPE
Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreH...
Definition: ms_mascotresults.hpp:344
matrix_science::ms_mascotresults::QUANT_COMPONENT_STATUS
QUANT_COMPONENT_STATUS
Return codes for getQuantitationComponentForPeptide().
Definition: ms_mascotresults.hpp:279
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_peptidesummary::BUGFIX_NUM
BUGFIX_NUM
bugNum values for isDataCached().
Definition: ms_peptidesummary.hpp:70
matrix_science::ms_peptidesummary::QL_FLAG
QL_FLAG
Flags for getQueryList().
Definition: ms_peptidesummary.hpp:124
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_quant_modgroup
An object of this class represent a single modification group element in quantitation....
Definition: ms_quant_modgroup.hpp:46
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptidesumnil.hpp Source File

  • src
  • resfile
  • impl
ms_peptidesumnil.hpp
1/*
2##############################################################################
3# file: ms_peptidesumnil.hpp #
4# 'msparser' toolkit #
5# Encapsulates an cache file for an ms_peptidesummary #
6# Just used internally in Mascot Parser - this header not supplied #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2009 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_PEPTIDESUMNIL_HPP
21#define MS_PEPTIDESUMNIL_HPP
22
23
24// Includes from the standard template library
25#include <time.h>
26#include <string>
27#include <list>
28#include <vector>
29#include <set>
30#include <thread>
31
32
33#include "ms_peptidesumcache.hpp"
34
35namespace matrix_science
36{
37 class ms_mascotresfilebase;
38}
39
40using namespace matrix_science;
41
42namespace msparser_internal {
43 class ms_mascotresultsbase;
44 class ms_mascotresfile_nil;
45
46 class ms_peptidesumnil : public ms_peptidesumcache
47 {
48 public:
49 static std::string getCacheFilename(
50 const ms_mascotresfile_nil & resfile,
51 const ms_mascotresults_params & parameters,
52 double minProbabilityForCache) { return {}; }
53
54 ms_peptidesumnil(const ms_mascotresfile_nil & resfile,
55 const ms_mascotresults_params & parameters,
56 bool useIndex,
57 double minProbabilityForCache){}
58
59 ~ms_peptidesumnil(){}
60
61 bool isOpenForReading() const override { return false; }
62 bool isPossibleToCreate() const override { return false; }
63 bool prepareToCreate() override { return false; }
64
65 void openIndexFileForVerification() override {}
66 void createDirectoryAndOpenIndexFile() override {}
67 std::string getFeatures() override { return {}; }
68 bool getIsNA() override { return false; }
69 void getAvePepIdentThresh(int &aveMascot, int &aveSL) override {}
70 double getTargetFdrMinProbability() override { return 0.0; }
71 double getErrTolMinProbability() override { return 0.0; }
72 void getQueryHasSignificant1stPass(std::vector<bool> &queryHasSignificant1stPassTarget, std::vector<bool> &queryHasSignificant1stPassDecoy) override {}
73 void getSrcRanks(std::vector<unsigned short> & srcRanksActiveSection, std::vector<unsigned short> & srcRanksInactiveSection) override {}
74 int getNumHits() override { return 0; }
75 void getTop50scores(double * top50Scores) override {}
76 ms_mascotresults::acc_dbidx_set_t getAccessionsForHit(const int hit, std::string & masterAcc, int & masterDbIdx) override { return {}; }
77 ms_mascotresults::q_p_vect_t getQPlistForHit(const int hit, bool getIgnored) override { return {}; }
78 ms_mascotresults::q_p_vect_t getFullQPlistForHit(const int hit) override { return {}; }
79 ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1) override { return {}; }
80 std::vector<std::pair<bool, bool> > getBoldRedChkBox(const int hit) override { return {}; }
81 std::vector<int> getQPinfo(int q, int p, int & prettyRank, int & protFirstAppearedIn, bool & isUnique, int & ambiguityGroupId, std::set<int> * pSetAmbiguitySiblings = NULL) override { return {}; }
82 ms_mascotresults::UNIQUE_PEP_RULES getUniqePepRulesSaved() override { return {}; }
83 std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes) override { return {}; }
84 bool getDecoyCounts(double & dOneInXprobRndForDecoy,
85 long & numHitsAboveIdentity,
86 long & numDecoyHitsAboveIdentity,
87 long & numHitsAboveHomology,
88 long & numDecoyHitsAboveHomology) override { return false; }
89 void getDecoyCounts_seq_FASTA(long & numHitsAboveIdentity,
90 long & numDecoyHitsAboveIdentity,
91 long & numHitsAboveHomology,
92 long & numDecoyHitsAboveHomology) override {}
93 void getDecoyCounts_PSM_SL(long & numHitsAboveIdentity,
94 long & numDecoyHitsAboveIdentity,
95 long & numHitsAboveHomology,
96 long & numDecoyHitsAboveHomology) override {}
97 void getDecoyCounts_PSM_both(long & numHitsAboveIdentity,
98 long & numDecoyHitsAboveIdentity,
99 long & numHitsAboveHomology,
100 long & numDecoyHitsAboveHomology) override {}
101 void getDecoyCounts_seq_SL(long & numHitsAboveIdentity,
102 long & numDecoyHitsAboveIdentity,
103 long & numHitsAboveHomology,
104 long & numDecoyHitsAboveHomology) override {}
105 void getDecoyCounts_seq_both(long & numHitsAboveIdentity,
106 long & numDecoyHitsAboveIdentity,
107 long & numHitsAboveHomology,
108 long & numDecoyHitsAboveHomology) override {}
109 void getDecoyCounts_PSM_ET_1st(long & numHitsAboveIdentity,
110 long & numDecoyHitsAboveIdentity,
111 long & numHitsAboveHomology,
112 long & numDecoyHitsAboveHomology) override {}
113 void getDecoyCounts_PSM_ET_2nd(long & numHitsAboveIdentity,
114 long & numDecoyHitsAboveIdentity,
115 long & numHitsAboveHomology,
116 long & numDecoyHitsAboveHomology) override {}
117 void getDecoyCounts_seq_ET_1st(long & numHitsAboveIdentity,
118 long & numDecoyHitsAboveIdentity,
119 long & numHitsAboveHomology,
120 long & numDecoyHitsAboveHomology) override {}
121 void getDecoyCounts_seq_ET_2nd(long & numHitsAboveIdentity,
122 long & numDecoyHitsAboveIdentity,
123 long & numHitsAboveHomology,
124 long & numDecoyHitsAboveHomology) override {}
125 int getUnassignedList(std::string & str) override { return 0; }
126 void getIonsScoreHistograms(std::vector<int> & ionsScoreHistogramTopMatchMascot,
127 std::vector<int> & ionsScoreHistogramTop10Mascot,
128 std::vector<int> & ionsScoreHistogramTopMatchSL,
129 std::vector<int> & ionsScoreHistogramTop10SL
130 ) override {}
131 void getPercolatorScores(ms_percolator_scores_vector & percolator, const int numQueries) override {}
132 void getSLScoreStats(double *slScoreStats) override {}
133 std::string getQueryList(ms_peptidesummary::QL_FLAG flag) override { return {}; }
134 bool getInference(const std::string & masterAcc, const int masterDbIdx,
135 ms_protein::dbIdxPlusAccVect_t & familyProteins,
136 ms_protein::dbIdxPlusAccVect_t & samesetProteins,
137 ms_protein::dbIdxPlusAccVect_t & subsetProteins,
138 ms_protein::dbIdxPlusAccVect_t & allSubsetProteins) override { return false;}
139 int getNumberOfFamilyMembers() override { return 0; }
140 std::string getProtein(const std::string & accession,
141 const int dbIdx,
142 ms_protein::dbIdxPlusAccVect_t & supersets,
143 ms_protein::dbIdxPlusAccVect_t & components) override { return {}; }
144 ms_protein getProtein(const std::string & accession,
145 const int dbIdx,
146 ms_mascotresultsbase & results) { return ms_protein(0.0, "", false, 0); }
147
148 bool getTreeClusterNodes(const int hit,
149 const std::string accession,
150 const int dbIdx,
151 std::vector<int> &left,
152 std::vector<int> &right,
153 std::vector<double> &distance,
154 ms_mascotresults::TREE_CLUSTER_METHOD tcm) override { return false; }
155 int getAllFamilyMembersWithThisPepMatch(const ms_mascotresultsbase & results,
156 const int hit,
157 const int q,
158 const int p,
159 std::vector< int >& db,
160 std::vector< std::string >& acc,
161 std::vector<int64_t>& protId,
162 std::vector< int >& dupe_status) override { return 0; }
163 bool getIonsScores(const bool decoy,
164 const int rank,
165 std::vector<double> &scores,
166 const int numQueries) override { return false; }
167
168 bool getComponentIntensities(ms_peptidesummarybase::componentNames_t & componentNames,
169 ms_peptidesummarybase::componentIntensities_t & intensities) override { return false; }
170
171 void getQmatchValues(const ms_mascotresultsbase & results, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) override {}
172 void getPlugholeValues(const ms_mascotresultsbase & results, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) override {}
173 bool getemPAIminMaxCleavage(int & emPAIminCleavage, int & emPAImaxCleavage) override { return false; }
174 bool getModificationCounts(
175 std::vector<ms_mod_instances_count::mod_residue_count_t> &fixed_mod_count,
176 std::vector<ms_mod_instances_count::mod_residue_count_t> &var_mod_count,
177 std::map<std::pair<int, int>, ms_mod_instances_count::mod_residue_count_t> &monolink_count,
178 std::map<std::pair<int, int>, ms_mod_instances_count::linked_residue_count_t> &looplink_count,
179 std::map<std::pair<int, int>, ms_mod_instances_count::linked_residue_count_t> &intact_link_count,
180 std::vector<std::string> &var_mod_position_types,
181 std::map<std::string, std::map<std::string, ms_mod_instances_count::mod_residue_count_t> > &local_mod_count,
182 std::vector<std::string> &local_mod_deltas,
183 std::map<std::string, std::map<std::string, ms_mod_instances_count::mod_residue_count_t> > &et_mod_count,
184 std::vector<std::string> &et_mod_deltas,
185 int &num_nonspecific_cleavage,
186 int num_library_mods,
187 std::vector<ms_mod_instances_count::mod_residue_count_t> &library_mod_count) override { return false;}
188
189
190
191 bool dumper(const std::string & filename) override { return false; }
192
193 std::string getCacheFileName() const { return {}; }
194
195 int getParamsId() const { return 0; }
196
197 int findPeptides(const ms_peptidesummary_nil & results,
198 const int startHit,
199 const std::string & str,
200 ms_mascotresults::FIND_FLAGS item,
201 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
202 std::vector<int> & q,
203 std::vector<int> & p) const { return 0; }
204
205 int findProteins(const ms_peptidesummary_nil & results,
206 const int startHit,
207 const std::string & str,
208 const int dbIdx,
209 ms_mascotresults::FIND_FLAGS item,
210 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
211 std::vector<std::string> & accessions,
212 std::vector<int> & dbIndexes) const { return 0;}
213
214 void addQPinfo(const int q) {}
215
216 protected:
217 // Not safe to copy or assign this object.
218 ms_peptidesumnil(const ms_peptidesumnil & rhs);
219 ms_peptidesumnil & operator=(const ms_peptidesumnil & rhs);
220 };
221} // msparser_internal namespace
222#endif // MS_PEPTIDESUMSQL_HPP
223
224/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults::FIND_COMPARE_FLAGS
FIND_COMPARE_FLAGS
Flags to specify how comparisons are performed in the find functions.
Definition: ms_mascotresults.hpp:189
matrix_science::ms_mascotresults::TREE_CLUSTER_METHOD
TREE_CLUSTER_METHOD
Flags for getTreeClusterNodes().
Definition: ms_mascotresults.hpp:128
matrix_science::ms_mascotresults::UNIQUE_PEP_RULES
UNIQUE_PEP_RULES
Flags for isPeptideUnique().
Definition: ms_mascotresults.hpp:360
matrix_science::ms_mascotresults::FIND_FLAGS
FIND_FLAGS
Flags for findPeptides() and findProteins().
Definition: ms_mascotresults.hpp:146
matrix_science::ms_peptidesummary::QL_FLAG
QL_FLAG
Flags for getQueryList().
Definition: ms_peptidesummary.hpp:124
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_peptidesumsql.hpp Source File

  • src
  • resfile
  • impl
ms_peptidesumsql.hpp
1/*
2##############################################################################
3# file: ms_peptidesumsql.hpp #
4# 'msparser' toolkit #
5# Encapsulates an cache file for an ms_peptidesummary #
6# Just used internally in Mascot Parser - this header not supplied #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2009 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_PEPTIDESUMSQL_HPP
21#define MS_PEPTIDESUMSQL_HPP
22
23
24// Includes from the standard template library
25#include <time.h>
26#include <string>
27#include <list>
28#include <vector>
29#include <set>
30#include <thread>
31
32#include "private/ms_sqlpp11_connection.hpp"
33
34#include "ms_peptidesummary_msr.hpp"
35#include "ms_modinstancescount.hpp"
36#include "ms_peptidesumcache.hpp"
37#include "ms_cached_msr_pepsum_data.hpp"
38
39#include "private/sql/parser_cached_data_v1_0.hpp"
40
41namespace matrix_science
42{
43 class ms_mascotresfilebase;
44 class ms_mascotresfile_msr;
45}
46
47using namespace matrix_science;
48
49namespace msparser_internal {
50 class ms_mascotresultsbase;
51 class ms_unassignedItem;
52 class ms_sqlpp11_connection;
53
54#ifndef SWIG
55
56 // Class to implement a pool of attached msr dbs.
57 // It keeps a LRU cache with a maximum size of MAX_MSRS_ATTACHED
58 // to prevent reaching the SQLITE_MAX_ATTACHED limit in SQLite
59 class AttachedMsrs
60 {
61 public:
62
63 using VecSize = std::vector<int>::size_type;
64 using AttachedMsrPtr = std::shared_ptr<sqlpp::schema_t>;
65 AttachedMsrs(const ms_mascotresfile_msr & resfile, std::shared_ptr<ms_sqlpp11_connection> dbPtr)
66 : resfile_(resfile), dbPtr_(dbPtr){
67 }
68
69 AttachedMsrPtr get(const int fileId) {
70 if (itemsMap_.count(fileId)>0) {
71 if (items_.front().first != fileId) {
72 // Move the item to the front
73 items_.splice(items_.begin(), items_, itemsMap_[fileId]);
74 }
75 return itemsMap_[fileId]->second;
76 }
77
78 // Cache is full, remove the LRU item
79 if (items_.size() >= MAX_MSRS_ATTACHED) {
80 int oldFileId = items_.back().first;
81 const std::string oldSchemaName = "msr_db_" + std::to_string(oldFileId);
82 (*dbPtr_)( custom_query(sqlpp::verbatim("DETACH DATABASE "), oldSchemaName) ); // sqlpp11 doesn't support detach.
83 itemsMap_.erase(oldFileId);
84 items_.pop_back();
85 }
86
87 const auto& msrFile = resfile_.getFileName(fileId+1);
88 const std::string schemaName = "msr_db_" + std::to_string(fileId);
89 AttachedMsrPtr attachedMsr = std::make_shared<sqlpp::schema_t>(dbPtr_->connection().attach(sqlpp::msl_sqlite3::connection_config(msrFile, MSL_SQLITE_OPEN_READONLY /*| MSL_SQLITE_OPEN_NOMUTEX*/), schemaName));
90
91 // Setting exclusive locking mode is always safe for read-only
92 // mode (but not for readwrite mode). It can make a big
93 // difference in speed because it avoids repeated read
94 // transaction locking.
95 //
96 // https://www.sqlite.org/pragma.html#pragma_locking_mode
97 dbPtr_->connection().execute(std::string("PRAGMA ") + schemaName + ".locking_mode=EXCLUSIVE");
98
99 // Add the new attached db to the cache
100 items_.push_front(std::make_pair(fileId, attachedMsr));
101 itemsMap_.insert( std::make_pair(fileId, items_.begin()) );
102 return attachedMsr;
103 }
104
105 private:
106
107 static constexpr int MAX_MSRS_ATTACHED = 10; // SQLITE_MAX_ATTACHED is 10 by default: https://www.sqlite.org/limits.html#max_attached
108
109 const ms_mascotresfile_msr& resfile_;
110 std::shared_ptr<ms_sqlpp11_connection> dbPtr_;
111
112 std::list<std::pair<int, AttachedMsrPtr>> items_;
113 std::unordered_map<int, decltype(items_.begin()) > itemsMap_;
114 };
115
116 class QPinfoDB
117 {
118 using QPTab = parser_cached_data_v1_0::CachedData_qPInfo;
119
120 using PrepType = decltype(std::declval<sqlpp::msl_sqlite3::connection>().prepare(
121 insert_into(std::declval<QPTab>()).set(
122 std::declval<QPTab>().paramsId = parameter(std::declval<QPTab>().paramsId),
123 std::declval<QPTab>().queryId = parameter(std::declval<QPTab>().queryId),
124 std::declval<QPTab>().rankId = parameter(std::declval<QPTab>().rankId),
125 std::declval<QPTab>().prettyRank = parameter(std::declval<QPTab>().prettyRank),
126 std::declval<QPTab>().protFirstAppearedIn = parameter(std::declval<QPTab>().protFirstAppearedIn),
127 std::declval<QPTab>().isUnique = parameter(std::declval<QPTab>().isUnique),
128 std::declval<QPTab>().proteinHitIds = parameter(std::declval<QPTab>().proteinHitIds),
129 std::declval<QPTab>().ambiguityGroupId = parameter(std::declval<QPTab>().ambiguityGroupId),
130 std::declval<QPTab>().ambiguitySiblings = parameter(std::declval<QPTab>().ambiguitySiblings)
131 ))
132 );
133
134 public:
135 QPinfoDB(const int paramsId, std::shared_ptr<ms_sqlpp11_connection> dbPtr, const ms_mascotresfile_msr & resfile, const ms_peptidesummary_msr & results)
136 : dbPtr_(dbPtr),
137 //tx_(start_transaction(dbPtr->connection())),
138 prepSt_(), paramsId_(paramsId),
139 resfile_(resfile),
140 results_(results),
141 qAlreadyDone_(resfile_.getNumQueries(), false) {
142
143 constexpr auto t = QPTab {};
144 prepSt_ = dbPtr_->connection().prepare(
145 insert_into(t).set(
146 t.paramsId = parameter(t.paramsId),
147 t.queryId = parameter(t.queryId),
148 t.rankId = parameter(t.rankId),
149 t.prettyRank = parameter(t.prettyRank),
150 t.protFirstAppearedIn = parameter(t.protFirstAppearedIn),
151 t.isUnique = parameter(t.isUnique),
152 t.proteinHitIds = parameter(t.proteinHitIds),
153 t.ambiguityGroupId = parameter(t.ambiguityGroupId),
154 t.ambiguitySiblings = parameter(t.ambiguitySiblings)
155 ));
156 }
157
158 void add(const int q, const bool mustBeUnique=false) {
159 if (!qAlreadyDone_[q-1]) {
160 for (int p=1; p <= results_.getMaxRankValue(); ++p) {
161 ms_peptide* pep;
162 if (results_.getPeptide(q, p, pep)) {
163 bool isUnique = mustBeUnique ? true : results_.isPeptideUnique(q, p);
164 prepSt_.params.paramsId = paramsId_;
165 prepSt_.params.queryId = q;
166 prepSt_.params.rankId = p;
167 int prettyRank = pep->getPrettyRank();
168 prepSt_.params.prettyRank = (prettyRank == 0) ? p : prettyRank;
169 prepSt_.params.protFirstAppearedIn = pep->getFirstProtAppearedIn();
170 prepSt_.params.isUnique = isUnique;
171 prepSt_.params.proteinHitIds = msparser_internal::join(pep->getProteins(), ",");
172 prepSt_.params.ambiguityGroupId = pep->getAmbiguityGroupId();
173 prepSt_.params.ambiguitySiblings = msparser_internal::join(_getAmbiguitySiblings(q, p, pep), ",");
174 (*dbPtr_)(prepSt_);
175 }
176 }
177 qAlreadyDone_[q-1] = true;
178 }
179 }
180
181 /*
182 This is called from ms_peptidesumsql::_saveHitsData() after all the (q,p) that are part of any protein family
183 have ben inserted.
184 At this point, only (q,p) that are unassigned are left. They must be unique
185 */
186 void finish() {
187 int n =resfile_.getNumQueries();
188 for (int q = 1; q <= n; ++q) {
189 if (!qAlreadyDone_[q-1]) {
190 add(q, true);
191 }
192 }
193 }
194
195 private:
196 // TODO: Almost identical to ms_peptidesumcdb::serialiseAmbiguitySiblings
197 std::vector<int> _getAmbiguitySiblings(const int q, const int p, const ms_peptide * const pep) {
198 std::vector<int> siblings;
199
200 if ( resfile_.anySpectralLibraryMatches() != resfile_.anyFastaMatches() ) {
201 //we only want ambiguity group ids in integrated searches
202 return siblings;
203 }
204
205 if (pep->getPeptideStr().empty()) {
206 //this is not an actual match
207 return siblings;
208 }
209
210 //Let's iterate from the highest rank to find the first non-zero value
211 //We need to detect the first non-zero value to check if all ids are different
212 //If they are all different, do not save anything to save space
213 bool onlyZeros = true;
214 bool firstNonZero = false;
215 for (int otherP = results_.getMaxRankValue(); otherP >= 1; --otherP) {
216 ms_peptide* otherPep;
217 if (results_.getPeptide(q, otherP, otherPep)) {
218 if (otherPep->getAmbiguityGroupId() == 0) {
219 continue;
220 } else if (onlyZeros) {
221 onlyZeros = false;
222 firstNonZero = true;
223 }
224
225 if (firstNonZero && (otherPep->getAmbiguityGroupId() == otherP) ) {
226 //if the highest valid rank is equal to its ambiguity group id, it means all the ids are different
227 return siblings;
228 } else {
229 firstNonZero = false;
230 }
231
232 if (otherPep->getAmbiguityGroupId() == pep->getAmbiguityGroupId()) {
233 siblings.push_back(otherP);
234 }
235 }
236 } // end for
237 return siblings;
238 }
239
240 std::shared_ptr<ms_sqlpp11_connection> dbPtr_;
241 //sqlpp::transaction_t<sqlpp::normal_connection<sqlpp::msl_sqlite3::connection_base> > tx_;
242 PrepType prepSt_;
243 int paramsId_;
244 const ms_mascotresfile_msr & resfile_;
245 const ms_peptidesummary_msr & results_;
246 std::vector<bool> qAlreadyDone_;
247 };
248
249 SQLPP_ALIAS_PROVIDER(total_rows)
250 class ms_peptidesumsql : public ms_peptidesumcache, public ms_errors
251 {
252 public:
253 static std::string getCacheFilename(
254 const ms_mascotresfile_msr & resfile,
255 const ms_mascotresults_params & parameters,
256 double minProbabilityForCache);
257
258 static int64_t embedFileIdIntoProtId(const int64_t fileId, const int64_t proteinId);
259
260 ms_peptidesumsql(const ms_mascotresfile_msr & resfile,
261 const ms_mascotresults_params & parameters,
262 bool useIndex,
263 double minProbabilityForCache);
264
265 ~ms_peptidesumsql();
266
267 bool isOpenForReading() const override;
268 bool isPossibleToCreate() const override;
269 bool prepareToCreate() override;
270
271 void openIndexFileForVerification() override;
272 void createInMemoryIndexFile();
273 void createDirectoryAndOpenIndexFile() override;
274 std::string getFeatures() override;
275 bool getIsNA() override;
276 void getAvePepIdentThresh(int &aveMascot, int &aveSL) override;
277 double getTargetFdrMinProbability() override;
278 double getErrTolMinProbability() override;
279 void getQueryHasSignificant1stPass(std::vector<bool> &queryHasSignificant1stPassTarget, std::vector<bool> &queryHasSignificant1stPassDecoy) override;
280 void getSrcRanks(std::vector<unsigned short> & srcRanksActiveSection, std::vector<unsigned short> & srcRanksInactiveSection) override;
281 int getNumHits() override;
282 void getTop50scores(double * top50Scores) override;
283 ms_mascotresults::acc_dbidx_set_t getAccessionsForHit(const int hit, std::string & masterAcc, int & masterDbIdx) override;
284 ms_mascotresults::q_p_vect_t getQPlistForHit(const int hit, bool getIgnored) override;
285 ms_mascotresults::q_p_vect_t getFullQPlistForHit(const int hit) override;
286 ms_mascotresults::q_p_vect_t getQPlistForAccession(const int dbIdx, const std::string & accession, bool getIgnored, const int64_t protId=-1) override;
287 std::vector<std::pair<bool, bool> > getBoldRedChkBox(const int hit) override;
288 std::vector<int> getQPinfo(int q, int p, int & prettyRank, int & protFirstAppearedIn, bool & isUnique, int & ambiguityGroupId, std::set<int> * pSetAmbiguitySiblings = NULL) override;
289 ms_mascotresults::UNIQUE_PEP_RULES getUniqePepRulesSaved() override;
290 std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes) override;
291 bool getDecoyCounts(double & dOneInXprobRndForDecoy,
292 long & numHitsAboveIdentity,
293 long & numDecoyHitsAboveIdentity,
294 long & numHitsAboveHomology,
295 long & numDecoyHitsAboveHomology) override;
296 void getDecoyCounts_seq_FASTA(long & numHitsAboveIdentity,
297 long & numDecoyHitsAboveIdentity,
298 long & numHitsAboveHomology,
299 long & numDecoyHitsAboveHomology) override;
300 void getDecoyCounts_PSM_SL(long & numHitsAboveIdentity,
301 long & numDecoyHitsAboveIdentity,
302 long & numHitsAboveHomology,
303 long & numDecoyHitsAboveHomology) override;
304 void getDecoyCounts_PSM_both(long & numHitsAboveIdentity,
305 long & numDecoyHitsAboveIdentity,
306 long & numHitsAboveHomology,
307 long & numDecoyHitsAboveHomology) override;
308 void getDecoyCounts_seq_SL(long & numHitsAboveIdentity,
309 long & numDecoyHitsAboveIdentity,
310 long & numHitsAboveHomology,
311 long & numDecoyHitsAboveHomology) override;
312 void getDecoyCounts_seq_both(long & numHitsAboveIdentity,
313 long & numDecoyHitsAboveIdentity,
314 long & numHitsAboveHomology,
315 long & numDecoyHitsAboveHomology) override;
316 void getDecoyCounts_PSM_ET_1st(long & numHitsAboveIdentity,
317 long & numDecoyHitsAboveIdentity,
318 long & numHitsAboveHomology,
319 long & numDecoyHitsAboveHomology) override;
320 void getDecoyCounts_PSM_ET_2nd(long & numHitsAboveIdentity,
321 long & numDecoyHitsAboveIdentity,
322 long & numHitsAboveHomology,
323 long & numDecoyHitsAboveHomology) override;
324 void getDecoyCounts_seq_ET_1st(long & numHitsAboveIdentity,
325 long & numDecoyHitsAboveIdentity,
326 long & numHitsAboveHomology,
327 long & numDecoyHitsAboveHomology) override;
328 void getDecoyCounts_seq_ET_2nd(long & numHitsAboveIdentity,
329 long & numDecoyHitsAboveIdentity,
330 long & numHitsAboveHomology,
331 long & numDecoyHitsAboveHomology) override;
332 int getUnassignedList(std::string & str) override;
333 void getIonsScoreHistograms(std::vector<int> & ionsScoreHistogramTopMatchMascot,
334 std::vector<int> & ionsScoreHistogramTop10Mascot,
335 std::vector<int> & ionsScoreHistogramTopMatchSL,
336 std::vector<int> & ionsScoreHistogramTop10SL
337 ) override;
338 void getPercolatorScores(ms_percolator_scores_vector & percolator, const int numQueries) override;
339 void getSLScoreStats(double *slScoreStats) override;
340 std::string getQueryList(ms_peptidesummary::QL_FLAG flag) override;
341 bool getInference(const std::string & masterAcc, const int masterDbIdx,
342 ms_protein::dbIdxPlusAccVect_t & familyProteins,
343 ms_protein::dbIdxPlusAccVect_t & samesetProteins,
344 ms_protein::dbIdxPlusAccVect_t & subsetProteins,
345 ms_protein::dbIdxPlusAccVect_t & allSubsetProteins) override;
346 int getNumberOfFamilyMembers() override;
347 std::string getProtein(const std::string & accession,
348 const int dbIdx,
349 ms_protein::dbIdxPlusAccVect_t & supersets,
350 ms_protein::dbIdxPlusAccVect_t & components) override;
351 ms_protein getProtein(const std::string & accession,
352 const int dbIdx,
353 ms_mascotresultsbase & results);
354 bool getTreeClusterNodes(const int hit,
355 const std::string accession,
356 const int dbIdx,
357 std::vector<int> &left,
358 std::vector<int> &right,
359 std::vector<double> &distance,
360 ms_mascotresults::TREE_CLUSTER_METHOD tcm) override;
361 int getAllFamilyMembersWithThisPepMatch(const ms_mascotresultsbase & results,
362 const int hit,
363 const int q,
364 const int p,
365 std::vector< int >& db,
366 std::vector< std::string >& acc,
367 std::vector<int64_t>& protId,
368 std::vector< int >& dupe_status) override;
369 bool getIonsScores(const bool decoy,
370 const int rank,
371 std::vector<double> &scores,
372 const int numQueries) override;
373
374 bool getComponentIntensities(ms_peptidesummarybase::componentNames_t & componentNames,
375 ms_peptidesummarybase::componentIntensities_t & intensities) override;
376
377 void getQmatchValues(const ms_mascotresultsbase & results, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) override;
378 void getPlugholeValues(const ms_mascotresultsbase & results, const ms_mascotresults::QMATCH_PLUGHOLE_INDEX_SECTIONS index) override;
379 bool getemPAIminMaxCleavage(int & emPAIminCleavage, int & emPAImaxCleavage) override;
380 bool getModificationCounts(
381 std::vector<ms_mod_instances_count::mod_residue_count_t> &fixed_mod_count,
382 std::vector<ms_mod_instances_count::mod_residue_count_t> &var_mod_count,
383 std::map<std::pair<int, int>, ms_mod_instances_count::mod_residue_count_t> &monolink_count,
384 std::map<std::pair<int, int>, ms_mod_instances_count::linked_residue_count_t> &looplink_count,
385 std::map<std::pair<int, int>, ms_mod_instances_count::linked_residue_count_t> &intact_link_count,
386 std::vector<std::string> &var_mod_position_types,
387 std::map<std::string, std::map<std::string, ms_mod_instances_count::mod_residue_count_t> > &local_mod_count,
388 std::vector<std::string> &local_mod_deltas,
389 std::map<std::string, std::map<std::string, ms_mod_instances_count::mod_residue_count_t> > &et_mod_count,
390 std::vector<std::string> &et_mod_deltas,
391 int &num_nonspecific_cleavage,
392 int num_library_mods,
393 std::vector<ms_mod_instances_count::mod_residue_count_t> &library_mod_count) override;
394
395 void prepareTmpDBForHit(const ms_peptidesummary_msr & results, const msparser_internal::ms_proteininference * pProteinInferencer, const int hit);
396 void createSQLFile(ms_peptidesummary_msr & results,
397 const std::vector<unsigned short> & srcRanksActiveSection,
398 const std::vector<unsigned short> & srcRanksInactiveSection,
399 const std::vector<bool> & queryHasSignificant1stPassTarget,
400 const std::vector<bool> & queryHasSignificant1stPassDecoy,
401 const std::vector<ms_unassignedItem *>& unassignedSorted,
402 const std::vector<int> & ionsScoreHistogramTopMatchMascot,
403 const std::vector<int> & ionsScoreHistogramTop10Mascot,
404 const std::vector<int> & ionsScoreHistogramTopMatchSL,
405 const std::vector<int> & ionsScoreHistogramTop10SL,
406 const ms_percolator_scores_vector & percolator,
407 const msparser_internal::ms_proteininference * pProteinInferencer,
408 const double *slScoreStats);
409
410 bool dumper(const std::string & filename) override;
411
412 std::shared_ptr<ms_sqlpp11_connection> dbPtr() const { return dbPtr_; }
413
414 std::string getCacheFileName() const { return cacheFileName_; }
415
416 int getParamsId() const { return paramsId_; }
417
418 int findPeptides(const ms_peptidesummary_msr & results,
419 const int startHit,
420 const std::string & str,
421 ms_mascotresults::FIND_FLAGS item,
422 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
423 std::vector<int> & q,
424 std::vector<int> & p) const;
425
426 int findProteins(const ms_peptidesummary_msr & results,
427 const int startHit,
428 const std::string & str,
429 const int dbIdx,
430 ms_mascotresults::FIND_FLAGS item,
431 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
432 std::vector<std::string> & accessions,
433 std::vector<int> & dbIndexes) const;
434
435 void addQPinfo(const int q);
436
437 //TODO: Move this somewhere else if needed from other classes
438 template <class TableType>
439 bool doesTableExist() {
440 std::string name = sqlpp::name_of<TableType>::template char_ptr<std::stringstream>();
441 int64_t countN = (dbPtr_->connection())(custom_query(sqlpp::verbatim("select count(name) from sqlite_master where name="), name)
442 .with_result_type_of(select(sqlpp::value(1).as(total_rows))))
443 .front()
444 .total_rows;
445 return (countN>0);
446 }
447
448 bool isBeingCreated() const { return isBeingCreated_; }
449 bool isBeingHeld() { return dbPtr_ && dbPtr_->isLockBeingHeld(); }
450
451 protected:
452 // Not safe to copy or assign this object.
453 ms_peptidesumsql(const ms_peptidesumsql & rhs);
454 ms_peptidesumsql & operator=(const ms_peptidesumsql & rhs);
455
456 private:
457
458 static constexpr int ABOVE_HOMOLOGY = 0;
459 static constexpr int ABOVE_IDENTITY = 1;
460
461 bool _openDB(const bool readWrite);
462 bool _initDB();
463 void _createTables();
464
465 void _validateData();
466
467 void _saveParamsId();
468 void _saveQPinfo(ms_peptidesummary_msr & results);
469 void _saveComponentIntensities(ms_peptidesummary_msr & results);
470 void _savePercolatorFilesMetadata();
471 void _savePercolatorScores(const ms_percolator_scores_vector & percolator);
472 void _saveQueryList(ms_peptidesummary_msr & results);
473 void _saveHitCountsAboveThreshold(ms_peptidesummary_msr & results);
474 void _saveModCounts(ms_peptidesummary_msr & results);
475 void _saveCachedMiscData(const std::vector<unsigned short> & srcRanksActiveSection, const std::vector<unsigned short> & srcRanksInactiveSection,
476 const std::vector<bool> & queryHasSignificant1stPassTarget, const std::vector<bool> & queryHasSignificant1stPassDecoy);
477 void _saveUnassigned(const std::vector<ms_unassignedItem *>& unassignedSorted);
478 void _saveGeneralStats(ms_peptidesummary_msr & results,
479 const msparser_internal::ms_proteininference * pProteinInferencer,
480 const std::vector<int> & ionsScoreHistogramTopMatchMascot,
481 const std::vector<int> & ionsScoreHistogramTop10Mascot,
482 const std::vector<int> & ionsScoreHistogramTopMatchSL,
483 const std::vector<int> & ionsScoreHistogramTop10SL,
484 const double *slScoreStats);
485 void _saveHitsData(const ms_peptidesummary_msr & results, const msparser_internal::ms_proteininference * pProteinInferencer, const int startHit=-1);
486
487 template <class Q, class DB>
488 auto _getPreparedStatement(const Q& query, DB& db) -> typename std::add_lvalue_reference<decltype(db->connection().prepare(query))>::type
489 {
490 static auto st = db->connection().prepare(query);
491 return st;
492 }
493
494 void _loadGeneralStats();
495 void _loadCachedMisc();
496 void _loadHitCountsAboveThreshold();
497 void _loadProtAccsCache(const int hitId);
498 void _loadQPlistCache(const int hitId);
499 void _loadQPproteinsCache(const int64_t proteinId);
500 void _loadBRCheckboxCache(const int hitId);
501 void _loadQPinfoCache(const int queryId);
502 void _loadInferenceCache(const std::string& masterAcc, const int masterDbIdx);
503 void _loadFamilyMembersCache(const int hitId, const ms_mascotresultsbase & results);
504
505 void _attachMSRs();
506
507 void _cacheProteinData(const int64_t proteinId, int& dbId, std::string& acc);
508
509 int _getProteinFromMsr(const std::string& acc, const int extDbId, int64_t& proteinId);
510
511 // Used to initalise pepsumId_
512 int _createId() {
513 static std::atomic<int> id{0};
514 return id++;
515 }
516
517 std::shared_ptr<ms_sqlpp11_connection> dbPtr_;
518
519 std::string cacheFileName_;
520
521 const ms_mascotresfile_msr & resfile_;
522 std::shared_ptr<AttachedMsrs> msrDbs_;
523
524 // Different .sdb files can have the same params_id even if they have different parameters.
525 // Use pepsumId_ instead of paramsId_ to uniquely identify an ms_peptidesumsql object in all the thread_local data structures.
526 int pepsumId_;
527 int paramsId_;
528 int percolatorParamsId_;
529 int resfileId_;
530
531 bool isReady_;
532 unsigned int flags_;
533 unsigned int flags2_;
534 std::string allResfilesStr_;
535 double probabilityThreshold_;
536 int maxHitsToReport_;
537 double ignoreIonsScoreBelow_;
538 int minPepLenInPepSummary_;
539 std::string unigeneIndexFile_;
540 std::string singleHit_;
541 int minNumSigUniqueSeqs_;
542 double minProbabilityForCache_;
543 double targetFdrForCache_;
544 int fdrTypeForCache_;
545 bool isDecoy_;
546 std::map<int, int> refDbOfSl_;
547 std::map<int, int> slIdOfRefDb_;
548
549 // True after calling prepareToCreate() and until createSQLFile() is finished
550 bool isBeingCreated_;
551
552 struct GeneralStats
553 {
554 GeneralStats()
555 : paramsId(-1)
556 {}
557 int paramsId;
558
559 int avgIdentityThreshold,
560 avgIdentityThresholdSl;
561 double decoyOneInXProbRnd;
562 std::vector<int> ionsScoreHistogramTopMatchMascot,
563 ionsScoreHistogramTop10Mascot,
564 ionsScoreHistogramTopMatchSl,
565 ionsScoreHistogramTop10Sl;
566 double slScoreStatsMascotMean,
567 slScoreStatsMascotStdev,
568 slScoreStatsLibraryMean,
569 slScoreStatsLibraryStdev,
570 targetFDRMinProbability,
571 errTolMinProbability;
572 std::vector<double> top50Scores;
573 int nonSpecificCleavageCount,
574 empaiMinCleavage,
575 empaiMaxCleavage,
576 unassignedCount,
577 numHits,
578 numFamilyMembers;
579 bool isNa;
580 };
581 GeneralStats generalStats_;
582
583 struct CachedMisc
584 {
585 CachedMisc()
586 : paramsId(-1)
587 {}
588 int paramsId;
589
590 std::vector<unsigned short> srcRanksActiveSec,
591 srcRanksInactiveSec;
592 std::vector<bool> queryHasSignificant1stPassTarget,
593 queryHasSignificant1stPassDecoy;
594 };
595 CachedMisc cachedMisc_;
596
597 struct HitCounts
598 {
599 int total,
600 seqFasta,
601 psmSl,
602 psmBoth,
603 seqSl,
604 seqBoth,
605 psmEtFirstPass,
606 psmEtSecondPass,
607 seqEtFirstPass,
608 seqEtSecondPass;
609 };
610 struct HitCountsAboveThreshold
611 {
612 HitCountsAboveThreshold()
613 : paramsId(-1)
614 {}
615 int paramsId;
616 // (isDecoy, thresholdType). 0=aboveHomology, 1=aboveIdentity
617 std::map<bool, std::map<int, HitCounts>> counts;
618 };
619 HitCountsAboveThreshold hitCountsAboveThreshold_;
620
621 static constexpr int CACHE_SIZE = 10;
622 struct ProtAccs
623 {
624 ProtAccs()
625 : paramsId(-1)
626 {}
627
628 int paramsId;
629 // [(hitId, (proteinId, dbId, acc)), ...]
630 std::array<std::pair<int, std::vector<std::tuple<int64_t, int, std::string>>>, CACHE_SIZE> data;
631 };
632 using ProtAccsCache = std::map<int, ProtAccs>;
633 thread_local static ProtAccsCache protAccsCache_;
634
635 struct QPlist
636 {
637 QPlist()
638 : hitId(-1)
639 {}
640
641 int hitId;
642 // (ignored, (q, p))
643 std::vector< std::pair<bool, std::pair<int, int>> > qps;
644 };
645 struct QPlistData
646 {
647 QPlistData()
648 : paramsId(-1)
649 {}
650
651 int paramsId;
652 std::array<QPlist, CACHE_SIZE> data;
653 };
654 using QPlistCache = std::map<int, QPlistData>;
655 thread_local static QPlistCache qPlistCache_;
656
657 struct QPproteins
658 {
659 QPproteins()
660 : proteinId(-1)
661 {}
662
663 int64_t proteinId;
664 int dbId;
665 std::string acc;
666 // (ignored, (q,p))
667 std::vector< std::pair<bool, std::pair<int, int>> > qps;
668 };
669 struct QPproteinsData
670 {
671 QPproteinsData()
672 : paramsId(-1)
673 {}
674
675 int paramsId;
676 std::array<QPproteins, CACHE_SIZE> data;
677 };
678 using QPproteinsCache = std::map<int, QPproteinsData>;
679 thread_local static QPproteinsCache qPproteinsCache_;
680
681 struct BRCheckbox
682 {
683 BRCheckbox()
684 : hitId(-1)
685 {}
686
687 int hitId;
688 // (isBold, show_checkbox)
689 std::vector<std::pair<bool, bool>> chkBox;
690 };
691 struct BRCheckboxData
692 {
693 BRCheckboxData()
694 : paramsId(-1)
695 {}
696
697 int paramsId;
698 std::array<BRCheckbox, CACHE_SIZE> data;
699 };
700 using BRCheckboxCache = std::map<int, BRCheckboxData>;
701 thread_local static BRCheckboxCache brCheckboxCache_;
702
703 struct Pinfo
704 {
705 int prettyRank,
706 protFirstAppearedIn,
707 ambiguityGroupId;
708 bool isUnique;
709 std::vector<int> proteinHitIds;
710 std::vector<int> ambiguitySiblings;
711 };
712 struct QPinfo
713 {
714 QPinfo()
715 : queryId(-1)
716 {}
717
718 int queryId;
719 std::vector<Pinfo> pInfo;
720
721 };
722 struct QPinfoData
723 {
724 QPinfoData()
725 : paramsId(-1)
726 {}
727
728 int paramsId;
729 std::array<QPinfo, CACHE_SIZE> data;
730 };
731 using QPinfoCache = std::map<int, QPinfoData>;
732 thread_local static QPinfoCache qpInfoCache_;
733
734 // Map (dbId, acc) -> protein id
735 using InferenceCacheProtIds = std::unordered_map<int, std::unordered_map<std::string, int64_t>>;
736 using InferenceCache = std::map<int, InferenceCacheProtIds>;
737 thread_local static InferenceCache inferenceCacheProtIds_;
738
739 struct ProteinsSetData
740 {
741 ProteinsSetData()
742 :paramsId(-1)
743 {}
744
745 int paramsId;
746 std::map<int64_t, ms_protein::dbIdxPlusAccVect_t> familyData,
747 samesetData,
748 subsetData,
749 allSubsetData;
750 };
751 using ProteinsSetCache = std::map<int, ProteinsSetData>;
752 thread_local static ProteinsSetCache proteinSetsCache_;
753
754 struct FamilyProteins
755 {
756 std::vector<int> db;
757 std::vector<std::string> acc;
758 std::vector<int64_t> protId;
759 std::vector<int> dupeStatus;
760 };
761 struct FamilyMembers
762 {
763 FamilyMembers()
764 : hit(-1)
765 {}
766
767 int hit;
768 std::map<std::pair<int, int>,FamilyProteins> members;
769 };
770 struct FamilyMembersData
771 {
772 FamilyMembersData()
773 : paramsId(-1)
774 {}
775
776 int paramsId;
777 std::array<FamilyMembers, CACHE_SIZE> data;
778 };
779 using FamilyMembersCache = std::map<int, FamilyMembersData>;
780 thread_local static FamilyMembersCache familyMembersCache_;
781
782 // protId -> (dbId, acc)
783 using ProteinInfoData = std::unordered_map<int64_t, std::pair<int,std::string>>;
784 using ProteinInfoCache = std::map<int, ProteinInfoData>;
785 thread_local static ProteinInfoCache proteinInfoCache_;
786
787 std::shared_ptr<QPinfoDB> qpInfoDB_;
788
789
790 // (q, p) -> ProteinMatchData
791 //std::map<std::pair<int, int>, ProteinMatchData> protMatchDataCache_;
792
793
794
795
796 };
797#endif // SWIG
798} // msparser_internal namespace
799#endif // MS_PEPTIDESUMSQL_HPP
800
801/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_mascotresfile_msr
Class for parsing and reading files in MSR format.
Definition: ms_mascotresfile_msr.hpp:105
matrix_science::ms_mascotresfile_msr::getNumQueries
int getNumQueries(const int resfileID=0) const override
Returns the number of queries (peptide masses or ms-ms spectra).
Definition: ms_mascotresfile_msr.cpp:345
matrix_science::ms_mascotresfile_msr::anySpectralLibraryMatches
bool anySpectralLibraryMatches(const bool isDecoy=false) const override
Returns true if there are any Spectral library matches.
Definition: ms_mascotresfile_msr.cpp:881
matrix_science::ms_mascotresfile_msr::anyFastaMatches
bool anyFastaMatches(const bool isDecoy=false) const override
Returns true if there are any FASTA matches.
Definition: ms_mascotresfile_msr.cpp:872
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults::FIND_COMPARE_FLAGS
FIND_COMPARE_FLAGS
Flags to specify how comparisons are performed in the find functions.
Definition: ms_mascotresults.hpp:189
matrix_science::ms_mascotresults::TREE_CLUSTER_METHOD
TREE_CLUSTER_METHOD
Flags for getTreeClusterNodes().
Definition: ms_mascotresults.hpp:128
matrix_science::ms_mascotresults::UNIQUE_PEP_RULES
UNIQUE_PEP_RULES
Flags for isPeptideUnique().
Definition: ms_mascotresults.hpp:360
matrix_science::ms_mascotresults::FIND_FLAGS
FIND_FLAGS
Flags for findPeptides() and findProteins().
Definition: ms_mascotresults.hpp:146
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::getProteins
const std::vector< int > getProteins() const
Return a list of hit numbers for the proteins that contain this peptide.
Definition: ms_peptide.cpp:1243
matrix_science::ms_peptide::getFirstProtAppearedIn
int getFirstProtAppearedIn() const
Returns the hit numberof the first protein that contains this peptide.
Definition: ms_peptide.cpp:1155
matrix_science::ms_peptide::getPrettyRank
int getPrettyRank() const
Similar to getRank() except that equivalent scores get the same rank.
Definition: ms_peptide.cpp:517
matrix_science::ms_peptide::getPeptideStr
std::string getPeptideStr(bool substituteAmbiguous=true, const PSM psmComponent=PSM_COMPLETE) const
Returns the sequence found for the peptide.
Definition: ms_peptide.cpp:710
matrix_science::ms_peptidesummary::QL_FLAG
QL_FLAG
Flags for getQueryList().
Definition: ms_peptidesummary.hpp:124
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_processoroptions.hpp Source File

  • inc
ms_processoroptions.hpp
1/*
2##############################################################################
3# file: ms_processoroptions.hpp #
4# 'msparser' toolkit #
5# Represents parameters of "Processors" section of "mascot.dat"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_processoroptions.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PROCESSOROPTIONS_HPP
20#define MS_PROCESSOROPTIONS_HPP
21
22
23#include <string>
24#include <vector>
25
26
27namespace matrix_science {
34 class MS_MASCOTRESFILE_API ms_dbprocessors
35 {
36 friend class ms_datfile;
37 friend class ms_processoroptions;
38 public:
40 ms_dbprocessors();
41
43 ms_dbprocessors(const ms_dbprocessors& src);
44
46 ~ms_dbprocessors();
47
49 void defaultValues();
50
52 void copyFrom(const ms_dbprocessors* right);
53
54#ifndef SWIG
56 ms_dbprocessors& operator=(const ms_dbprocessors& right);
57#endif
59 std::string getName() const;
60
62 void setName(const char * str);
63
65 int getNumberOfThreads() const;
66
68 void clearThreads();
69
71 int getThreadProcessorID(const int threadIndex) const;
72
74 void appendThreadProcessorID(const int proccessorID);
75 private:
76 std::string name_;
77 std::vector<int> threads_;
78
79 std::string getStringValue() const;
80 }; // class ms_dbprocessors
81
83
108 class MS_MASCOTRESFILE_API ms_processoroptions : public ms_customproperty
109 {
110 friend class ms_datfile;
111 public:
112
114 ms_processoroptions();
115
117 ms_processoroptions(const ms_processoroptions& src);
118
120 ~ms_processoroptions();
121
123 void defaultValues();
124
126 void copyFrom(const ms_processoroptions* right);
127
128#ifndef SWIG
130 ms_processoroptions& operator=(const ms_processoroptions& right);
131#endif
133 bool isSectionAvailable() const;
134
136 void setSectionAvailable(const bool value);
137
139 int getNumberOfProcessors() const;
140
142 void clearProcessors();
143
145 int getProcessor(const int index) const;
146
148 void appendProcessor(const int processorID);
149
151 int getNumberOfDatabases() const;
152
154 const ms_dbprocessors* getDatabase(const int index) const;
155
157 void clearDatabases();
158
160 void appendDatabase(const ms_dbprocessors* db);
161
162#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
163#include "suppress_ms_customproperty.hpp"
164#endif
165
166 private:
167 bool sectionAvailable_;
168 std::vector<int> processors_;
169 std::vector<ms_dbprocessors*> dbs_;
170 }; // class ms_processoroptions // end of config_group
172} // namespace matrix_science;
173
174#endif // MS_PROCESSOROPTIONS_HPP
175
176/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_dbprocessors
Represent a single dabatase entry in the Processors section.
Definition: ms_processoroptions.hpp:35
matrix_science::ms_processoroptions
An instance of this class represents all the parameters specified in the Processors section of mascot...
Definition: ms_processoroptions.hpp:109
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_processors.hpp Source File

  • inc
ms_processors.hpp
1/*
2##############################################################################
3# file: ms_processors.hpp #
4# 'msparser' toolkit #
5# Use this class to retrieve current CPU configuration #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_processors.hpp $ #
12# $Author: dcreasy@matrixscience.com $ #
13# $Date: 2019-10-15 16:50:41 +0100 $ #
14# $Revision: 35b34891b5eee100f767f95780f54a007d0db4b5 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PROCESSORS_HPP
20#define MS_PROCESSORS_HPP
21
22#include <string>
23#include <vector>
24
25namespace msparser_internal {
26 class ms_processors_impl;
27}
28
29namespace matrix_science {
30
37
49 class MS_MASCOTRESFILE_API ms_processors: public ms_errors
50 {
51 public:
53
60 enum HYPERTHREADING
61 {
62 HT_NOT_CAPABLE = 0,
63 HT_ENABLED = 1,
64 HT_DISABLED = 2,
65 HT_SUPPORTED_NOT_ENABLED = 3,
66 HT_CANNOT_DETECT = 4
67 };
68
70
79 enum {
80 DEPRECATED_MAX_CORES_PER_LICENSE = 4
81 };
82
84 ms_processors(bool checkLinuxHT, int unused);
85
87 ms_processors(const ms_processors& src);
88
90 ~ms_processors();
91
93 void copyFrom(const ms_processors* right);
94
95#ifndef SWIG
97 ms_processors& operator=(const ms_processors& right);
98#endif
100 int getNumOnSystem() const;
101
103 int getNumAvailableToProcess() const;
104
106 bool isProcessAffinitySupported() const;
107
109 bool isUseProcessesNotThreads() const;
110
112 UINT64 getWhichAvailableForMascot() const;
113
115 std::vector<int> getWhichAvailableForMascot2() const;
116
118 bool isLogicalCPUAvailableForMascot(const int cpu) const;
119
121 int getNumProcessorGroups() const;
122
124 int getNumPhysicalOnSystem() const;
125
127 HYPERTHREADING getHyperThreadingState() const;
128
130 int getNumLogicalPerPhysical(const int packageID = 0) const;
131
133 int getNumCores(const int packageID = -1) const;
134
136 int getPhysicalFromLogical(const int cpu) const;
137
139 std::string getProcessorName() const;
140
142 std::string getMultithreadedName() const;
143
145 UINT64 getHyperThreadedCPUsMask() const;
146
148 bool isPrimaryLogicalProcessor(const int cpu) const;
149
151 bool isThreadedLogicalProcessor(const int cpu) const;
152
154 int getCoreFromLogical(const int cpu) const;
155
157 int getHT_IDFromLogical(const int cpu) const;
158
160 int getAutoDetectNumThreads(const int numLicensed, const int numCoresPerCpuLicense) const;
161
163 bool setProcessAffinity(const std::vector<unsigned int> & vecCpu) const;
164
166 bool setProcessAffinity(const std::vector<int> & vecCpu) const;
167
169 bool setThreadAffinity(const int logicalCpu) const;
170
171 private:
172 msparser_internal::ms_processors_impl * pImpl_;
173 }; // class ms_processors // end of config_group
175} // namespace matrix_science
176
177#endif // MS_PROCESSORS_HPP
178
179/*------------------------------- End of File -------------------------------*/
180
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_processors
This class is designed to retrieve current CPU configuration on the computer and set affinity.
Definition: ms_processors.hpp:50
matrix_science::ms_processors::HYPERTHREADING
HYPERTHREADING
Hyper-threading status for the CPUs.
Definition: ms_processors.hpp:61
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_processors_impl.hpp Source File

  • src
  • configfiles
ms_processors_impl.hpp
1/*
2##############################################################################
3# file: ms_processors_impl.hpp #
4# 'msparser' toolkit #
5# Use this class to retrieve current CPU configuration #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_processors.hpp $ #
12# $Author$ #
13# $Date$ #
14# $Revision$ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PROCESSORS_INTERNAL_HPP
20#define MS_PROCESSORS_INTERNAL_HPP
21
22
23#include <string>
24#include <vector>
25#include <map>
26
27#include "hwloc.h"
28
29namespace msparser_internal {
30
31 class ms_cpuinfo
32 {
33 public:
34 ms_cpuinfo() : package_id_(0),
35 core_id_(0),
36 ht_id(0),
37 availableForMascot_(true),
38 isPrimary_(true) {};
39 // int logical_id use as the map
40 int package_id_; // i.e. what goes in a socket. Zero based
41 int core_id_; // Zero based id, restarts at zero for each package
42 int ht_id; // Zero based id, restarts at zero for each core
43 bool availableForMascot_; // Should always be true?
44 bool isPrimary_;
45 hwloc_cpuset_t hwloc_cpuset_;
46 };
47
48 class ms_processors_impl
49 {
50 public:
52 ms_processors_impl(matrix_science::ms_errs & errs);
53
55 ms_processors_impl(const ms_processors_impl & src);
56
58 ~ms_processors_impl();
59
61 void copyFrom(const ms_processors_impl* right);
62
64 ms_processors_impl& operator=(const ms_processors_impl & right);
65
67 int getNumOnSystem() const;
68
70 int getNumAvailableToProcess() const;
71
73 bool isProcessAffinitySupported() const;
74
76 bool isUseProcessesNotThreads() const;
77
79 UINT64 getWhichAvailableForMascot() const;
80
82 std::vector<int> getWhichAvailableForMascot2() const;
83
85 bool isLogicalCPUAvailableForMascot(const int cpu) const;
86
88 int getNumProcessorGroups() const;
89
91 int getNumPhysicalOnSystem() const;
92
94 matrix_science::ms_processors::HYPERTHREADING getHyperThreadingState() const;
95
97 int getNumLogicalPerPhysical(const int packageID = 0) const;
98
100 int getNumCores(const int packageID = -1) const;
101
103 int getPhysicalFromLogical(const int cpu) const;
104
106 std::string getProcessorName() const;
107
109 std::string getMultithreadedName() const;
110
112 UINT64 getHyperThreadedCPUsMask() const;
113
115 bool isPrimaryLogicalProcessor(const int cpu) const;
116
118 bool isThreadedLogicalProcessor(const int cpu) const;
119
121 int getCoreFromLogical(const int cpu) const;
122
124 int getHT_IDFromLogical(const int cpu) const;
125
127 int getAutoDetectNumThreads(const int numLicensed, const int numCoresPerCpuLicense) const;
128
130 bool setProcessAffinity(const std::vector<unsigned int> & vecCpu) const;
131
133 bool setProcessAffinity(const std::vector<int> & vecCpu) const;
134
136 bool setThreadAffinity(const int logicalCpu) const;
137
138 private:
139 matrix_science::ms_errs & errs_;
140 typedef std::map<int, ms_cpuinfo> cpuInfo_t;
141 cpuInfo_t cpuInfo_;
142 int numProcessorGroups_;
143 bool processAffinitySupported_;
144 bool useProcessesNotThreads_;
145 matrix_science::ms_processors::HYPERTHREADING hyperThreading_;
146 std::string processorName_; // e.g. "Intel", "AMD Opteron", "Power 5"
147 std::string multiThreadName_; // e.g. "Hyper-threading", "Dual Core", "SMT"
148 bool isIntelProcessor_;
149 hwloc_topology_t hwlocTopology_;
150
151 void defaultValues();
152 void getChipManufacturer();
153 void iterateHwlocChildren(hwloc_obj_t hwLocObj, unsigned int depth,
154 unsigned int & packageID, unsigned int & coreID, unsigned int & processingUnitID);
155 void checkProcessorsAvailable();
156 }; // class ms_processors_impl
157} // namespace msparser_internal
158
159#endif // MS_PROCESSORS_INTERNAL_HPP
160
161/*------------------------------- End of File -------------------------------*/
162
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_processors::HYPERTHREADING
HYPERTHREADING
Hyper-threading status for the CPUs.
Definition: ms_processors.hpp:61
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_progress_info.hpp Source File

  • inc
ms_progress_info.hpp
1/*
2##############################################################################
3# file: ms_progress_info.hpp
4# 'msparser' toolkit
5# Current progress through a file load or dave
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_progress_info.hpp $
12 * @(#)$Revision: 13eeeb76d98cb3364b3262ac81b740f5a2a28aba | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-10-18 17:21:45 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_PROGRESS_INFO_HPP
18#define MS_PROGRESS_INFO_HPP
19
20
21// Includes from the standard template library
22#include <list>
23#include <string>
24
25namespace matrix_science
26{
27 //=========================================================================
33 class ms_progress_info;
34
36
39 class MS_MASCOTRESFILE_API ms_progress_info
40 {
41 public:
43 enum STATUS
44 {
45 S_NOT_STARTED,
46 S_RUNNING,
47 S_RUNNING_INDETERMINATE,
48 S_STOPPED_FAIL,
49 S_STOPPED_BREAK,
50 S_STOPPED_COMPLETE
51 };
52
54 ms_progress_info();
55
57 ms_progress_info(const std::string & description, size_t total);
58
60 ~ms_progress_info();
61
63 void clear(const std::string & description = "", size_t total = 0);
65 STATUS getStatus() const;
67 const std::string & getDescription() const;
69 size_t getTotal() const;
71 size_t getProgress() const;
73 int getNumberOfSubtasks() const;
75 const ms_progress_info * getSubtaskProgress(int index) const;
77 void setBreak() const;
78
80 ms_progress_info * addSubtask(const std::string & description, size_t total);
82 void addSubtask(const ms_progress_info * task);
84 void updateProgress(size_t progress, size_t total);
86 void updateFail();
88 void updateBreak();
90 void updateComplete();
92 void updateIndeterminate();
94 bool isBreaking() const;
96 void removeSubtask(int index);
97
98 private:
99 // noncopyable
100 ms_progress_info(const ms_progress_info &);
101 void operator= (const ms_progress_info &);
102
103 std::string description_;
104 STATUS status_;
105 size_t total_;
106 size_t progress_;
107 mutable bool break_;
108
109 // The bool item in the list is used to specify whether the parent
110 // destructor should delete the child object.
111 // If the object is created by calling
112 // addSubtask(description, total) then it has been created by the
113 // parent and will be deleted by the parent.
114 std::list<std::pair<bool, ms_progress_info*> > subtasks_;
115 };
116 // end of quantitation_group
118 //=========================================================================
119
120} // namespace matrix_science
121
122#endif // MS_PROGRESS_INFO_HPP
123
124/*------------------------------- End of File -------------------------------*/
matrix_science::ms_progress_info
Contains information of the current progress of a task being performed.
Definition: ms_progress_info.hpp:40
matrix_science::ms_progress_info::STATUS
STATUS
Enum containing progress status information values.
Definition: ms_progress_info.hpp:44
matrix_science::ms_progress_info::S_STOPPED_BREAK
@ S_STOPPED_BREAK
Task was cancelled by the user.
Definition: ms_progress_info.hpp:49
matrix_science::ms_progress_info::S_STOPPED_FAIL
@ S_STOPPED_FAIL
Task failed.
Definition: ms_progress_info.hpp:48
matrix_science::ms_progress_info::S_RUNNING
@ S_RUNNING
Task is currently running.
Definition: ms_progress_info.hpp:46
matrix_science::ms_progress_info::S_NOT_STARTED
@ S_NOT_STARTED
Task has not started.
Definition: ms_progress_info.hpp:45
matrix_science::ms_progress_info::S_RUNNING_INDETERMINATE
@ S_RUNNING_INDETERMINATE
Task is running but progress is indeterminate.
Definition: ms_progress_info.hpp:47
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_protein.hpp Source File

  • inc
ms_protein.hpp
1/*
2##############################################################################
3# file: ms_mascotresprotein.hpp #
4# 'msparser' toolkit #
5# Encapsulates a protein - either for protein summary or peptide summary #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2018 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_mascotresprotein.hpp $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-08-29 15:05:00 +0100 $ #
14# $Revision: 59a8ab98151c86e0bdeddc2efea60d287d6087ba | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESPROTEIN_HPP
20#define MS_MASCOTRESPROTEIN_HPP
21
22
23// Includes from the standard template library
24#include <string>
25#include <list>
26#include <vector>
27#include <set>
28#include <map>
29#include <ostream>
30
31namespace msparser_internal {
32 class ms_protein_match_data;
33 class PEPINFO;
34 class ms_mascotresultsbase;
35 class ms_peptidesumsql;
36}
37
38namespace matrix_science {
39 class ms_mascotresults;
40 class ms_proteinsummary;
41 class ms_pepinfoSortByScore;
42 class ms_peptide;
43
50
56 class MS_MASCOTRESFILE_API ms_protein
57 {
58 public:
60
73 enum GROUP
74 {
75 GROUP_UNKNOWN,
76 GROUP_NO,
77 GROUP_SUBSET,
78 GROUP_COMPLETE,
79 GROUP_FAMILY
80 };
81
82#ifdef DUPLICATE
83 #ifdef _WIN32
84// #pragma message("WARNING: The identifier 'DUPLICATE' was defined but is incompatible with the definition for ms_protein")
85 #endif
86 #undef DUPLICATE
87#endif
88
90
97 enum DUPLICATE
98 {
99 DUPE_NotDuplicate,
100 DUPE_Duplicate,
101 DUPE_DuplicateSameQuery,
102 DUPE_HighestScoringDuplicate,
103 DUPE_Ignored
104 };
105
107
116 enum MASS_FLAGS
117 {
118 MASS_NON_SELECT_NON_MATCH = 0x0001,
119 MASS_SELECT_NON_MATCH = 0x0010,
120 MASS_NON_SELECT_MATCH = 0x0100,
121 MASS_SELECT_MATCH = 0x1000
122 };
123
125
186 enum DISTINCT_PEPTIDE_FLAGS
187 {
188 DPF_SEQUENCE = 0x0001,
189 DPF_CHARGE = 0x0002,
190 DPF_MODS = 0x0004,
191 DPF_UNIQUE = 0x0008,
192 DPF_NODUPSAMEQUERY = 0x0010
193 };
194
195 // Types for uniquely identifying a protein
196 typedef std::pair<int, std::string> dbIdxPlusAcc_t;
197 typedef std::vector<dbIdxPlusAcc_t> dbIdxPlusAccVect_t;
198 typedef std::set<dbIdxPlusAcc_t> dbIdxPlusAccSet_t;
199
200
202 ms_protein(const double score,
203 const std::string accession,
204 const bool updateScoreFromPepScores,
205 const int proteinSummaryHit = 0);
206
208 ms_protein(const ms_protein& src);
209
211 ~ms_protein();
212
213#ifndef SWIG
215 ms_protein& operator=(const ms_protein& right);
216#endif
217
219 void copyFrom(const ms_protein* src);
220
222 int64_t getProteinId() const;
223
225 void setProteinId(int64_t proteinId);
226
228 std::string getAccession() const;
229
231 int getDB() const;
232
234 void setDB(int dbIdx);
235
237 double getScore() const;
238
240 double getNonMudpitScore() const;
241
243 double getScoreWithET() const;
244
246 int getNumPeptides() const;
247
249 int getNumDisplayPeptides(bool aboveThreshold = false) const;
250
252 GROUP getGrouping() const;
253
254#ifndef DOXYGEN_SHOULD_SKIP_THIS
256 void setGrouping(GROUP g) { group_ = g; }
257
259 std::string getForCache(dbIdxPlusAccVect_t & supersetProteinsUnsorted,
260 dbIdxPlusAccVect_t & components) const;
261
263 bool setFromCache(const std::string & str, msparser_internal::ms_mascotresultsbase & results,
264 const dbIdxPlusAccVect_t & supersetProteinsUnsorted,
265 const dbIdxPlusAccVect_t & components,
266 const std::string & cdbFeatures);
267
269 std::vector<std::pair<int, int> > getIgnoredQPs() const;
270
272 bool isIgnoredQP(const int q, const int p) const;
273#endif
274
276 void getIgnoredQPs(std::vector<int> &q, std::vector<int> &p) const;
277
279 int getPeptideQuery (const int pepNumber) const;
280
282 int getPeptideP (const int pepNumber) const;
283
285 int getPepNumber(const int q, const int p) const;
286
288 int getPeptideFrame (const int pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
289
291 long getPeptideStart (const int pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
292
294 long getPeptideEnd (const int pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
295
297 long getPeptideMultiplicity (const int pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
298
300 DUPLICATE getPeptideDuplicate (const int pepNumber, const bool allowErrTolDuplicate = true) const;
301
303 double getPeptideIonsScore (const int pepNumber) const;
304
306 bool getPeptideIsBold (const int pepNumber) const;
307
309 void setPeptideIsBold (const int pepNumber);
310
312 bool getPeptideShowCheckbox (const int pepNumber) const;
313
315 void setPeptideShowCheckbox (const int pepNumber);
316
318 int getPeptideComponentID (const int pepNumber) const;
319
321 char getPeptideResidueBefore (const int pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
322
324 char getPeptideResidueAfter (const int pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
325
327 bool isASimilarProtein(const ms_protein * prot,
328 const ms_mascotresults * results,
329 const bool groupByQueryNumber = false);
330
332 std::string getSimilarProteinName() const;
333
335 int getSimilarProteinDB() const;
336
338 bool isSimilarProtein(const std::string & acc, const int dbIdx) const;
339
341 int getSimilarProteins(std::vector<std::string> & accessions, std::vector<int> & dbIdxs) const;
342
344 void setSimilarProtein(const ms_protein * prot);
345
348 void addOnePeptide( ms_mascotresults & results,
349 const int q, const int p,
350 const msparser_internal::ms_protein_match_data &proteinMatchData,
351 const double correctedScore,
352 const double uncorrectedScore,
353 const ms_protein * component,
354 const ms_peptide::SEARCH_PHASE searchPhase,
355 const bool isIgnored);
356
357
359 long getCoverage() const;
360
362 bool anyMatchToQuery(const int query) const;
363
365 bool anyMatchToQueryAndP(const int query, const int P) const;
366
368 std::string getUnmatchedMasses(ms_mascotresfilebase & resfile,
369 const int numDecimalPlaces = 2) const;
370
372 std::string getMasses(ms_mascotresfilebase & resfile,
373 const ms_proteinsummary & summary,
374 const unsigned int flags = MASS_SELECT_MATCH,
375 const int numDecimalPlaces = 2) const;
376
378 int getFrame() const;
379
381 bool anyBoldRedPeptides(const ms_mascotresults & results) const;
382
384 bool isUnigene() const;
385
387 void setIsUnigeneEntry();
388
390 bool isPMFMixture() const;
391
393 void setIsPMFMixture();
394
396 bool isUpdateScoreFromPepScores() const;
397
399 void sortPeptides(const ms_mascotresults & results, bool keepAlive = false, int keepAlivePercent = 0, const char * keepAliveAccession = "", int keepAliveCount = 0);
400
402 int getNumComponents() const;
403
405 const ms_protein * getComponent(const int componentNumber) const;
406
408 int getProteinSummaryHit() const;
409
411 double getRMSDeltas(const ms_mascotresults & results) const;
412
414 int getHitNumber() const;
415
422 void setHitNumber(const int hit) { hitNum_ = hit;}
423
425 int getMemberNumber() const;
426
428 int getLongestPeptideLen() const;
429
431 int getNumDistinctPeptides(bool aboveThreshold = false,
432 DISTINCT_PEPTIDE_FLAGS flags = DPF_SEQUENCE) const;
433
435 int getNumDistinctPeptideRepeats(
436 int distinctIndex, // 1..getNumDistinctPeptides
437 bool aboveThreshold = false,
438 DISTINCT_PEPTIDE_FLAGS flags = DPF_SEQUENCE) const;
439
441 ms_peptide getDistinctPeptide(
442 int distinctIndex, // 1..getNumDistinctPeptides
443 int repeatIndex = 1, // 1..getNumDistinctPeptideRepeats
444 bool aboveThreshold = false,
445 DISTINCT_PEPTIDE_FLAGS flags = DPF_SEQUENCE) const;
446
448 int getLongestSigPeptideLen() const;
449
451 int getNumObservedForEmPAI() const;
452#ifndef SWIG
454
463 friend inline bool operator<(const ms_protein & lhs, const ms_protein & rhs) {
464 if (lhs.dbIdx_ == rhs.dbIdx_) {
465 if ( lhs.proteinSummaryHit_ == 0 ) {
466 return lhs.accession_ < rhs.accession_;
467 } else { // i.e ms_proteinsummary - see parser bug 493
468 if ( lhs.accession_ == rhs.accession_) {
469 return lhs.getFrame() < rhs.getFrame();
470 } else {
471 return lhs.accession_ < rhs.accession_;
472 }
473 }
474 } else {
475 return lhs.dbIdx_ < rhs.dbIdx_;
476 }
477 }
478#endif
479 // Undocumented function for fast access
480 const char * getAccessionStr() const { return accession_.c_str(); }
481
482 const std::vector<std::pair<int,int64_t>>& getSupersetProteinIds() const { return supersetProteinIdsUnsorted_; }
483 const std::vector<std::pair<int,int64_t>>& getComponentProteinIds() const { return componentProteinIds_; }
484
485 std::string stringify() const;
486
487 private:
488
489 // Values for flags_
490 // These ones are not cached in the cdb file (obviously!)
491 static constexpr unsigned char FL_LOADED_BASE_INFO_FROM_CACHE = 0x01; // False if not using cdb, otherwise true once setFromCache() has been called
492 static constexpr unsigned char FL_LOADED_QP_FROM_CACHE = 0x02; // True is using cdb and just q/p values loaded.
493 static constexpr unsigned char FL_LOADED_ALL_FROM_CACHE = 0x02; // Same as FL_SORTED
494 // These ones are cached in the cdb file
495 static constexpr unsigned char FL_SORTED = 0x10; // Sorting the list of peptides is expensive - don't repeat...
496 static constexpr unsigned char FL_UNIGENE = 0x20; // For unigene, we need to get the description line from the unigene file
497 static constexpr unsigned char FL_UPDATE_SCORE_FROM_PEP_SCORES = 0x40; // For protein summary, the protein score is calculated by
498 // nph-mascot.exe, and is in the results file. For the
499 // peptide summary, the score is calculated by adding the ions
500 // scores
501
502 static constexpr unsigned char FL_PMF_MIXTURE = 0x80; // True if protein actually originates from a PMF mixture
503
504 void initialiseDistinctPeptideTree(
505 bool aboveThreshold,
506 DISTINCT_PEPTIDE_FLAGS flags) const;
507
508 ms_errs* getErrorHandler() const;
509
510 // --- Start of uncached variables
511 mutable std::vector<msparser_internal::PEPINFO *> peptides_; // sort by query
512 mutable std::vector<msparser_internal::PEPINFO *> ignoredPeptides_;
513 mutable std::vector<msparser_internal::PEPINFO> allPeptides_;
514
515 msparser_internal::ms_mascotresultsbase * results_;
516// bool loadedFromCache_;
517 // --- End of uncached variables
518
519 // Start of all cached variables
520 unsigned char flags_; // See FL_... not all bits are cached
521
522 int numPeptides_; // Only used if loadedFromCache_ is true - otherwise peptides_.size();
523 mutable int numDisplayPeptides_;
524 mutable int numDisplayPeptidesAboveThresh_;
525 mutable int numDistinctPeptides_;
526 mutable int numDistinctPeptidesAboveThresh_;
527 mutable int numDistinctUniquePeptides_;
528 mutable int numDistinctUniqPepAboveThresh_;
529 mutable int lenLongestPeptideAboveThresh_;
530 mutable int numObservedForEmPAI_;
531 mutable int frame_;
532 mutable bool distinctPeptideAboveThreshold_;
533 mutable DISTINCT_PEPTIDE_FLAGS distinctPeptideFlags_;
534 mutable std::list<std::list<ms_peptide*> > distinctPeptideTree_;
535 dbIdxPlusAccSet_t supersetProteins_; // This one is filled when loading from cache
536 dbIdxPlusAccVect_t supersetProteinsUnsorted_;
537 // Same as supersetProteinsUnsorted_ but using protein ids
538 std::vector<std::pair<int,int64_t>> supersetProteinIdsUnsorted_;
539
540 // For unignene and PMF mixture, the protein is really a 'pseudo'
541 // protein, made up from a number of 'real' proteins
542 dbIdxPlusAccVect_t components_;
543 // Same as components_but using protein ids
544 std::vector<std::pair<int,int64_t>> componentProteinIds_;
545
546 int64_t proteinId_;
547 std::string accession_;
548 int dbIdx_;
549 double score_;
550 double nonMudPITScore_;
551 double scoreWithET_;
552 GROUP group_;
553 int proteinSummaryHit_;
554 int hitNum_;
555 mutable int memberNum_;
556 int longestPeptideLen_; // Useful with minPepLenInPepSummary
557 mutable long coverage_;
558// bool pmfMixture_; // True if protein actually originates from a PMF mixture
559// bool sorted_; // Sorting the list of peptides is expensive - don't repeat...
560// bool unigene_; // For unigene, we need to get the description line from the unigene file
561// bool updateScoreFromPepScores_; // For protein summary, the protein score is calculated by
562 // nph-mascot.exe, and is in the results file. For the
563 // peptide summary, the score is calculated by adding the ions
564 // scores
565
566 // Functions
567 void copyPeptidePointers(std::vector<msparser_internal::PEPINFO *> &pointersTo, const std::vector<msparser_internal::PEPINFO *> &pointersFrom, const ms_protein *src);
568 void checkFromCache(const char * calledBy) const;
569 void checkQPFromCache(const char * calledBy) const;
570 bool isFlagSet(unsigned char fl) const { return (flags_ & fl)?true:false; }
571 void setFlag(unsigned char fl, bool val) {
572 if (val) {
573 flags_ |= fl;
574 } else {
575 //the standard says that complement must promote to an int... there is no performance difference though
576 flags_ = static_cast<unsigned char>(flags_ & ~fl);
577 }
578 }
579
580 static bool isVarModStrEmpty(const std::string &str);
581
582 friend class prot_sort;
583 friend class ms_pepinfoSortByScore;
584 friend class msparser_internal::ms_peptidesumsql;
585 };
586#ifndef SWIG
587 // Helper class - don't use from outside library
588 class ms_proteinPtrSortByAccession
589 {
590 public:
591 bool operator() (const ms_protein * p1, const ms_protein * p2) const {
592 return (*p1 < *p2);
593 }
594 };
595
596 class ms_proteinPtrSortByScore
597 {
598 public:
599 bool operator() (const ms_protein * p1, const ms_protein * p2) const {
600 if (p1->getScore() != p2->getScore()) {
601 return (p1->getScore() > p2->getScore());
602 } else {
603 return (*p1 < *p2);
604 }
605 }
606 };
607
608
609 class ms_pepinfoSortByScore
610 {
611 public:
612 ms_pepinfoSortByScore(std::pair<bool, bool> pairParam): removeDiffPos_(pairParam.first), anyLibraryMatches_(pairParam.second) { }
613 bool operator() (const msparser_internal::PEPINFO * p1, const msparser_internal::PEPINFO * p2) const;
614 ms_pepinfoSortByScore(const ms_pepinfoSortByScore& other): removeDiffPos_(other.removeDiffPos_), anyLibraryMatches_(other.anyLibraryMatches_){}
615 ms_pepinfoSortByScore& operator=(const ms_pepinfoSortByScore& other)
616 {
617 if (&other != this) {
618 removeDiffPos_ = other.removeDiffPos_;
619 anyLibraryMatches_ = other.anyLibraryMatches_;
620 }
621 return *this;
622 }
623
624 private:
625 bool removeDiffPos_;
626 bool anyLibraryMatches_;
627 };
628
629 inline std::ostream& operator << (std::ostream& out, const ms_protein& prot)
630 {
631 out << prot.stringify();
632 return out;
633 }
634
635#endif // end of resfile_group
637} // matrix_science namespace
638
639
640#endif // MS_MASCOTRESPROTEIN_HPP
641
642/*------------------------------- End of File -------------------------------*/
643
644
645
646
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_protein::DISTINCT_PEPTIDE_FLAGS
DISTINCT_PEPTIDE_FLAGS
Enum for getNumDistinctPeptides().
Definition: ms_protein.hpp:187
matrix_science::ms_protein::GROUP
GROUP
Enum to say if a protein is similar to another higher scoring protein.
Definition: ms_protein.hpp:74
matrix_science::ms_protein::GROUP_NO
@ GROUP_NO
Does not contain same set (or subset) of peptides as another proteins. A 'lead' protein.
Definition: ms_protein.hpp:76
matrix_science::ms_protein::GROUP_UNKNOWN
@ GROUP_UNKNOWN
No information about grouping.
Definition: ms_protein.hpp:75
matrix_science::ms_protein::GROUP_COMPLETE
@ GROUP_COMPLETE
Contains an identical set of peptides to one or more other proteins.
Definition: ms_protein.hpp:78
matrix_science::ms_protein::GROUP_SUBSET
@ GROUP_SUBSET
Contains a subset of peptides in one ore more other proteins.
Definition: ms_protein.hpp:77
matrix_science::ms_protein::ms_protein
ms_protein(const double score, const std::string accession, const bool updateScoreFromPepScores, const int proteinSummaryHit=0)
Constructors - used from ms_proteinsummary and ms_peptidesummary.
matrix_science::ms_protein::MASS_FLAGS
MASS_FLAGS
enum for each protein to specify what masses to select.
Definition: ms_protein.hpp:117
matrix_science::ms_protein::getFrame
int getFrame() const
Returns the frame number for the protein.
Definition: ms_protein.cpp:1403
matrix_science::ms_protein::operator<
friend bool operator<(const ms_protein &lhs, const ms_protein &rhs)
Protein objects perform a simple sort of themselves by database ID and then accession.
Definition: ms_protein.hpp:463
matrix_science::ms_protein::DUPLICATE
DUPLICATE
Enum for the each peptide in the protein to indicate if it is a duplicate.
Definition: ms_protein.hpp:98
matrix_science::ms_protein::DUPE_DuplicateSameQuery
@ DUPE_DuplicateSameQuery
Another match for the same query with the same peptide string got a higher score (different mods).
Definition: ms_protein.hpp:101
matrix_science::ms_protein::DUPE_Duplicate
@ DUPE_Duplicate
Another peptide from a different query with the same sequence as this got a higher score.
Definition: ms_protein.hpp:100
matrix_science::ms_protein::DUPE_NotDuplicate
@ DUPE_NotDuplicate
There are no other peptides with the same sequence in this protein - from this query or other queries...
Definition: ms_protein.hpp:99
matrix_science::ms_protein::DUPE_HighestScoringDuplicate
@ DUPE_HighestScoringDuplicate
There is at least one other peptide the same as this with a lower score.
Definition: ms_protein.hpp:102
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_protein_quant_ratio.hpp Source File

  • inc
ms_protein_quant_ratio.hpp
1/*
2##############################################################################
3# file: ms_protein_quant_ratio.hpp #
4# 'msparser' toolkit #
5# Protein ratio for relative quantitation, estimated from peptide ratios #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: villek@matrixscience.com $ #
12# $Date: 2018-07-30 16:23:53 +0100 $ #
13# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_PROTEIN_QUANT_RATIO_HPP
19#define MS_PROTEIN_QUANT_RATIO_HPP
20
21
22// Includes from the standard template library
23#include <string>
24#include <map>
25
26namespace matrix_science {
27 class ms_peptide_quant_key;
28 class ms_peptide_quant_key_vector;
29
36
71 class MS_MASCOTRESFILE_API ms_protein_quant_ratio
72 {
73 friend class ms_quantitation;
74 friend class ms_ms1quantitation;
75 friend class ms_ms2quantitation;
76 friend class ms_customquantitation;
77
78 public:
81 ms_protein_quant_ratio(const std::string &accession, int dbIdx, const std::string &ratioName);
82
85 ms_protein_quant_ratio(const std::string &accession, int dbIdx, const std::string &ratioName, double value, double stdev, double stderror, double hypothesisPvalue, double normalityPvalue, unsigned int sampleSize);
86
88 ms_protein_quant_ratio(const ms_protein_quant_ratio& src);
89
91 ~ms_protein_quant_ratio();
92
93#ifndef SWIG
95 ms_protein_quant_ratio& operator=(const ms_protein_quant_ratio& right);
96
98 bool operator==(const ms_protein_quant_ratio& right) const;
99
101 bool operator!=(const ms_protein_quant_ratio& right) const;
102#endif
104 void copyFrom(const ms_protein_quant_ratio* src);
105
107 bool isMissing() const;
108
110 std::string getAccession() const;
111
113 int getDB() const;
114
116 std::string getRatioName() const;
117
119 double getValue() const;
120
122 unsigned int getSampleSize() const;
123
125 double getStandardDeviation() const;
126
128 double getStandardDeviation(std::string &whyUnavailable) const;
129
131 double getStandardError() const;
132
134 double getStandardError(std::string &whyUnavailable) const;
135
137 ms_peptide_quant_key_vector getActiveKeys() const;
138
140 ms_peptide_quant_key_vector getSkippedKeys() const;
141
143 ms_peptide_quant_key_vector getOutlierKeys() const;
144
146 ms_peptide_quant_key_vector getExcludedKeys() const;
147
149 double getHypothesisPvalue() const;
150
152 double getHypothesisPvalue(std::string &whyUnavailable) const;
153
155 bool isSignificant(double threshold = 0.05) const;
156
158 double getNormalityPvalue() const;
159
161 double getNormalityPvalue(std::string &whyUnavailable) const;
162
164 bool isLogNormal(double threshold = 0.05) const;
165
167 static ms_protein_quant_ratio fromSerialisedString(const std::string &serialisedStr);
168
170 std::string serialise() const;
171
173 static std::string serialisationFormatVersion();
174
175 private:
176 enum PEPQUANTKEY_STATE {
177 PEPQUANTKEY_SKIPPED = 0x0001,
178 PEPQUANTKEY_OUTLIER = 0x0002,
179 PEPQUANTKEY_EXCLUDED = 0x0004
180 };
181
182 enum REASON_WHY_UNAVAILABLE {
183 REASON_NOT_UNAVAILABLE = 0,
184 REASON_MISSING_RATIO = 1,
185 REASON_TYPE_WEIGHTED = 2
186 };
187
188 static std::string lookupWhyUnavailable(int reason);
189
190//Warning 325: Nested struct not currently supported
191#ifndef SWIG
192 typedef struct { int why; const char *str; } reason_why_t;
193 static const reason_why_t reason_why_db[];
194#endif
197 ms_protein_quant_ratio(const std::string &accession, int dbIdx, const std::string &ratioName, double value, double stdev, double stderror, double hypothesisPvalue, double normalityPvalue, const std::vector<ms_peptide_quant_key> &activeKeys, const std::map<ms_peptide_quant_key, int> &inactiveKeys);
198
199 ms_peptide_quant_key_vector collectKeys(int type) const;
200
201 bool isMissing_;
202
203 std::string accession_;
204 int dbIdx_;
205 std::string ratioName_;
206
207 double value_;
208
209 double stdev_;
210 double stderror_;
211 int whyStdevUnavailable_;
212
213 double hypothesisPvalue_;
214 int whyHypothesisPUnavailable_;
215
216 double normalityPvalue_;
217 int whyNormalityPUnavailable_;
218
219 unsigned int sampleSize_;
220
221 std::vector<ms_peptide_quant_key> activeKeys_;
222 std::map<ms_peptide_quant_key, int> inactiveKeys_;
223 }; // end of quantitation_group
225} // matrix_science namespace
226
227#endif // MS_PROTEIN_QUANT_RATIO_HPP
228
229/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customquantitation
Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings.
Definition: ms_customquantitation.hpp:119
matrix_science::ms_ms1quantitation
The result of quantitation calculations applied to peptide summary.
Definition: ms_ms1quantitation.hpp:92
matrix_science::ms_ms2quantitation
Peptide and protein quantitation in a Reporter or Multiplex Mascot results file.
Definition: ms_ms2quantitation.hpp:127
matrix_science::ms_peptide_quant_key_vector
A vector of peptide quant keys.
Definition: ms_peptide_quant_key_vector.hpp:47
matrix_science::ms_protein_quant_ratio
Protein abundance in one component relative to another in a quantitation experiment,...
Definition: ms_protein_quant_ratio.hpp:72
matrix_science::ms_quantitation
Base class for peptide and protein quantitation.
Definition: ms_quantitation.hpp:138
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_proteininference.hpp Source File

  • src
  • resfile
  • impl
ms_proteininference.hpp
1/*
2##############################################################################
3# file: ms_proteininference.hpp #
4# 'msparser' toolkit #
5# Private class for grouping proteins for ms_peptidesummary or #
6# ms_proteinsummary #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2009 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresul $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_PROTEININFERENCE_HPP
21#define MS_PROTEININFERENCE_HPP
22
23// Includes from the standard template library
24#include <string>
25#include <list>
26#include <vector>
27#include <set>
28#include <map>
29#include <time.h>
30#include <sstream>
31
32#include <boost/dynamic_bitset.hpp>
33#include <boost/utility.hpp> // for enable_if
34#include <boost/type_traits.hpp>
35
36#include "ms_peptidesumcache.hpp"
37
38#ifndef SWIG
39 // Helper class - don't use from outside library
40
41using namespace matrix_science;
42
43namespace msparser_internal {
44
46
52 class qp_t {
53 public:
54 int q_;
55 int p_;
56 qp_t(int q, int p) { q_=q; p_=p; }
57 qp_t() { q_=0; p_=0; }
58 qp_t(const ms_peptide * pep) { q_ = pep->getQuery(); p_ = pep->getPrettyRank(); }
59 bool operator ==(const qp_t & right) { return q_ == right.q_ && p_ == right.p_; }
60 bool operator <(const qp_t & rhs) const {
61 if (q_ == rhs.q_) {
62 return p_ < rhs.p_;
63 } else {
64 return q_ < rhs.q_;
65 }
66 }
67 };
68
69 // Some useful typedefs
70 typedef std::set<qp_t> peptideSet_t; // query, prettyRank (or rank)
71 typedef std::set<const ms_protein *> prot_set_t;
72 typedef std::set<const ms_protein *, ms_proteinPtrSortByScore> proteinSet_t;
73 typedef std::map<const ms_protein *, proteinSet_t, ms_proteinPtrSortByScore> proteinFamily_t;
74 typedef std::map<const ms_protein *, const ms_protein *> proteinProteinMap_t;
75
76 class ms_protein_matrix_attrs {
77 public:
78 int dbIdx(const ms_protein* prot) const { return prot->getDB(); }
79 std::string accession(const ms_protein* prot) const { return prot->getAccession(); }
80 };
81
82 // peptideMatrix has sequences as columns and accessions as rows.
83 // In each row, there's a 1 if the sequence is found in the accession.
84 //
85 // Typically, proteinT = ms_protein* and peptideT = std::string
86 // (sequence), so these are the defaults. proteinAttributeExtractorT must
87 // be a functor that extracts a database index (dbIdx) from proteinT.
88 template<
89 class proteinT = const ms_protein*,
90 class peptideT = std::string,
91 class proteinAttributeExtractorT = ms_protein_matrix_attrs
92 >
93 class peptideMatrix {
94 public:
95 peptideMatrix(const std::vector<DATABASE_TYPE> &dbTypeMap)
96 : dbTypeMap_(dbTypeMap)
97 , numPeptides_(0)
98 , numProteins_(0)
99 {}
100
101 ~peptideMatrix();
102
103 // Add links from protein to a sequence of peptides. The iterators
104 // must point to a container of peptideT elements.
105 template<class Iterator>
106 typename boost::enable_if<
107 boost::is_same<peptideT, typename std::iterator_traits<Iterator>::value_type>,
108 void
109 >::type
110 addPeptideLinks(const proteinT &prot, Iterator seqBegin, Iterator seqEnd) {
111 addLinks<proteinT, peptideT, Iterator>(prot, seqBegin, seqEnd);
112 }
113
114 // Mark a peptide significant. Only significant peptides get a column
115 // in the finalised peptide matrix.
116 void makePeptideSignificant(const peptideT &pep) {
117 peptideNode_t *node = getNode(pep);
118 node->isSignificant = true;
119 }
120
121 // Call finalise() once all the links have been added. This
122 // initialises lookup tables.
123 void finalise();
124
125 void debug_print(std::ostringstream &zzf) const;
126 bool empty() const { return proteinNodes_.empty(); }
127
128 private:
129 // Indices are 0 (unused) and 1..getNumberOfDatabases().
130 const std::vector<DATABASE_TYPE> &dbTypeMap_;
131 proteinAttributeExtractorT proteinAttrExtractor_;
132
133 int numPeptides_;
134 int numProteins_;
135
136 template<class L, class R>
137 class linkNode_t;
138
139 template<class L, class R> // link is from L to R
140 class linkNode_t {
141 public:
142 linkNode_t(): idx(0), isSignificant(false) { }
143 linkNode_t(int i): idx(i), isSignificant(false) { }
144 const int idx;
145 bool isSignificant; // relevant for peptides only
146 std::set<linkNode_t<R, L>*> links;
147 };
148
149 typedef linkNode_t<proteinT, peptideT> proteinNode_t;
150 typedef linkNode_t<peptideT, proteinT> peptideNode_t;
151
152 std::map<proteinT, proteinNode_t*> proteinNodes_;
153 std::map<peptideT, peptideNode_t*> peptideNodes_;
154
155 typedef std::map<proteinT, boost::dynamic_bitset<> > peptideRows_t;
156 peptideRows_t peptideRows_;
157 std::map<proteinT, proteinT> samesetParents_;
158 std::list<proteinT> discardedSLProteins_;
159
160 private:
161 proteinNode_t* getNode(const proteinT &prot) {
162 return getOrCreateNode<proteinT, proteinNode_t>(prot, proteinNodes_, numProteins_);
163 }
164 const proteinNode_t* getNode(const proteinT &prot) const {
165 return getNodeOrNull<proteinT, proteinNode_t>(prot, proteinNodes_);
166 }
167 peptideNode_t* getNode(const peptideT &pep) {
168 return getOrCreateNode<peptideT, peptideNode_t>(pep, peptideNodes_, numPeptides_);
169 }
170 const peptideNode_t* getNode(const peptideT &pep) const {
171 return getNodeOrNull<peptideT, peptideNode_t>(pep, peptideNodes_);
172 }
173
174 template<class keyT, class nodeT>
175 nodeT* getOrCreateNode(const keyT &key, std::map<keyT, nodeT*> &nodes, int &numKeys);
176 template<class keyT, class nodeT>
177 const nodeT* getNodeOrNull(const keyT &key, const std::map<keyT, nodeT*> &nodes) const;
178
179 static int grouping_preference_order(DATABASE_TYPE t) {
180 switch (t) {
181 case AA:
182 case NA:
183 return 0;
184 case SLREF:
185 return 1;
186 case SL:
187 return 2;
188 default:
189 return 0;
190 }
191 }
192
193 // Return -1 if prot1 is preferred over prot2; 0 if neither is
194 // preferred over the other; and 1 if prot2 is preferred.
195 // Preference is by database type: FASTA accessions are preferred
196 // over library accessions as sameset parents and superset proteins.
197 int grouping_preference(const proteinT &prot1, const proteinT &prot2) const {
198 if (dbTypeMap_.empty())
199 return 0;
200
201 DATABASE_TYPE t1 = dbTypeMap_[proteinAttrExtractor_.dbIdx(prot1)];
202 DATABASE_TYPE t2 = dbTypeMap_[proteinAttrExtractor_.dbIdx(prot2)];
203
204 int pref1 = grouping_preference_order(t1);
205 int pref2 = grouping_preference_order(t2);
206
207 if (pref1 == pref2)
208 return 0;
209
210 return pref1 < pref2 ? -1 : 1;
211 }
212
213 // Generic method for adding links between a protein and a sequence of
214 // peptides, or vice versa.
215 template<class node1T, class node2T, class Iterator>
216 typename boost::enable_if<
217 boost::is_same<node2T, typename std::iterator_traits<Iterator>::value_type>,
218 void
219 >::type
220 addLinks(const node1T &a, Iterator seqBegin, Iterator seqEnd) {
221 // Step 1: find or create the node for item "a".
222 // (The link node for item "a" contains items of type "b".)
223 linkNode_t<node1T, node2T> *aNode = getNode(a);
224 for (Iterator it = seqBegin; it != seqEnd; ++it) {
225 // Step 2: find or create the node for item "b".
226 linkNode_t<node2T, node1T> *bNode = getNode(*it);
227 // Step 3: add links both ways.
228 aNode->links.insert(bNode);
229 bNode->links.insert(aNode);
230 }
231 }
232
233 public:
234 // Return the number of proteins discovered. (Some may be samesets.)
235 int proteinCount() const { return numProteins_; }
236
237 // Return the internal index number of the node. (Only useful for debugging purposes.)
238 int getNodeIdx(const proteinT &prot) const {
239 const proteinNode_t *node = getNode(prot);
240 if (node) {
241 return node->idx;
242 }
243 return -1;
244 }
245
246 // Return the lead proteins. Only available after finalise().
247 template<class Container>
248 void getLeadProteins(Container &c) const {
249 for (auto it = peptideRows_.begin(); it != peptideRows_.end(); ++it) {
250 c.insert(it->first);
251 }
252 }
253
254 // Return a mapping from protein to its sameset parent.
255 template<class Container>
256 void getSamesetParents(Container &c) const {
257 for (auto it = samesetParents_.begin(); it != samesetParents_.end(); ++it) {
258 c.insert(std::make_pair(it->first, it->second));
259 }
260 }
261
262 // Return any SL or SLREF accessions discarded during sameset
263 // detection.
264 const std::list<proteinT>& getDiscardedSLProteins() const {
265 return discardedSLProteins_;
266 }
267
268 enum SUPERSET_EVIDENCE {
269 SUPERSET_EVIDENCE_MUST_EXCEED_SUBSET_EVIDENCE = 1,
270 SUPERSET_EVIDENCE_NOT_RESTRICTED = 2
271 };
272
273 // Return the number of free peptides \a prot has, relative to
274 // the sequence of reference proteins. If \a prot has no free
275 // peptides, push its superset proteins in \a superset.
276 //
277 // Note that free count may be zero even if \a superset is empty,
278 // for example if \a prot has no row in the matrix.
279 template<class Iterator, class Container>
280 typename boost::enable_if<
281 boost::is_same<proteinT, typename std::iterator_traits<Iterator>::value_type>,
282 int
283 >::type
284 countFreePeptides(const proteinT &prot, Iterator seqBegin, Iterator seqEnd, Container &superset, SUPERSET_EVIDENCE supersetEvidence) const;
285 };
286
287 // Helper class - don't use from outside library
288 class ms_protSorter
289 {
290 public:
292
298 enum PROTEIN_SORTBY
299 {
300 PROTEIN_SORTBY_SCORE_THEN_ACC,
301 PROTEIN_SORTBY_SCORE_THEN_HIT,
302 PROTEIN_SORTBY_SCORE_THEN_DELTA
303 };
304 ms_protSorter(PROTEIN_SORTBY s, const ms_mascotresultsbase * r = 0): s_(s), r_(r) {}
305
306 bool operator() (const ms_protein * p1, const ms_protein * p2) const;
307
308 private:
309 PROTEIN_SORTBY s_;
310 const ms_mascotresultsbase * r_;
311 };
312
313
314 class ms_proteininference
315 {
316 public:
318 ms_proteininference(const ms_mascotresfilebase & resfile,
319 const ms_mascotresultsbase & results,
320 const ms_mascotresults::proteinSet & proteins,
321 const int maxHitsToReport,
322 double * top50Scores,
323 const double minProbability,
324 const bool extraProtAfterMinProtScore,
325 const int minPepLenInPepSummary,
326 const int minNumSigUniqueSeqs,
327 const bool groupByQueryNumber,
328 const ms_protSorter::PROTEIN_SORTBY psb,
329 const int flags2 = ms_peptidesummary::MSPEPSUM_NONE,
330 std::shared_ptr<ms_peptidesumcache> pCacheFile = std::shared_ptr<ms_peptidesumcache>());
331
332 // Not safe to copy or assign this object.
333 ms_proteininference(const ms_proteininference & rhs) = delete;
334 ms_proteininference & operator=(const ms_proteininference & rhs) = delete;
335
336 virtual ~ms_proteininference();
337
339 const ms_protein * getHit(const int hit) const;
340
342 void clearHit(const int hit);
343
345 int getNumberOfHits() const;
346
348 int getNumberOfFamilyMembers() const;
349
351 ms_protein * getNextSimilarProtein(const int masterHit, const int id) const;
352
354 ms_protein * getNextSimilarProteinOf(const char * masterAccession, const int masterDB, const int id) const;
355
357 ms_protein * getNextSubsetProtein(const int masterHit, const int id,
358 const bool searchWholeFamily,
359 const double subsetsScoreFraction) const;
360
362 ms_protein * getNextSubsetProteinOf(const char * masterAccession, const int masterDB,
363 const int id,
364 const double subsetsScoreFraction) const;
365
367 ms_protein * getNextFamilyProtein(const int masterHit, const int id) const;
368
370 //void setSubsetsThreshold(const double scoreFraction);
371
373 const ms_protein * addHit(const int hit, const ms_protein * prot = 0);
374
376 void findMatchesForThisProteinAndChildren(bool isTopLevelHit,
377 const int hit,
378 const ms_protein * proteinHit, // maybe parent hit for component
379 ms_mascotresults::q_p_set_t & qplist,
380 ms_mascotresults::q_p_set_t & qplist_ignored,
381 std::vector<int> & brChkBox,
382 prot_set_t & protsAlreadyDone,
383 std::ostringstream & accList,
384 std::vector<std::tuple<int,std::string,int64_t>> & proteinIds) const;
385
387 bool getInference(const std::string & masterAcc, const int masterDbIdx,
388 ms_protein::dbIdxPlusAccVect_t & familyProteins,
389 ms_protein::dbIdxPlusAccVect_t & samesetProteins,
390 ms_protein::dbIdxPlusAccVect_t & subsetProteins,
391 ms_protein::dbIdxPlusAccVect_t & allSubsetProteins) const;
392
393 bool getInference(const std::string & masterAcc, const int masterDbIdx,
394 std::vector<std::pair<int,int64_t>> & familyProteins,
395 std::vector<std::pair<int,int64_t>> & samesetProteins,
396 std::vector<std::pair<int,int64_t>> & subsetProteins,
397 std::vector<std::pair<int,int64_t>> & allSubsetProteins) const;
398
399 private:
400 // Not cached, set in CTOR
401 const ms_mascotresfilebase & resfile_;
402 const ms_mascotresultsbase & results_;
403 const ms_mascotresults::proteinSet & proteins_;
404 ms_errs * log_;
405 int maxHitsToReport_;
406 double minProbability_;
407 const bool extraProtAfterMinProtScore_;
408 const int minPepLenInPepSummary_;
409 const int minNumSigUniqueSeqs_;
410 const bool groupByQueryNumber_;
411 std::shared_ptr<ms_peptidesumcache> pCacheFile_;
412 const unsigned int flags_;
413 const unsigned int flags2_;
414 std::vector<DATABASE_TYPE> dbTypeMap_;
415 ms_protSorter * proteinSorter_;
416 // End of not cached, set in CTOR
417
418 // Only used by sortByScore
419 typedef std::set<ms_protein *,ms_protSorter> sortedSet;
420 sortedSet * sorted_;
421 // End of only used by sortByScore
422
423 // Not cached. Filled in by addHit()
424 typedef std::vector<const ms_protein *> proteinVector_t;
425 proteinVector_t hits_;
426 // End of not cached.
427
428 // Cached
429 struct relations_t {
430 ms_protein::dbIdxPlusAccVect_t familyProteins;
431 ms_protein::dbIdxPlusAccVect_t samesetProteins;
432 ms_protein::dbIdxPlusAccVect_t subsetProteins;
433 ms_protein::dbIdxPlusAccVect_t allSubsetProteins; // (from all in the family)
434 };
435
436 typedef std::map<ms_protein::dbIdxPlusAcc_t, relations_t> relations_map_t;
437 mutable relations_map_t relations_;
438 mutable std::map<int64_t, std::pair<int, std::string>> mapProtId2DbIdAcc_;
439 mutable std::map<ms_protein::dbIdxPlusAcc_t, int64_t> mapDbIdAcc2ProtId_;
440 int numberOfFamilyMembers_;
441 // End of cached
442
443 int _keepAlivePercent;
444 std::string _keepAliveAccession;
445 int _keepAliveCount;
446 time_t _keepAlivePreviousTime;
447
448 // Private functions
449 bool sortByScore(double * top50Scores, const int hitToAdd = -1);
450 bool setBoldAndCheckBoxItems(ms_protein * prot,
451 const int proteinNumber);
452 void findSameSetMatches(const int hit,
453 const ms_protein * protein,
454 prot_set_t & protsAlreadyDone,
455 ms_mascotresults::q_p_set_t & qplist,
456 ms_mascotresults::q_p_set_t & qplist_ignored,
457 std::vector<int> & brChkBox,
458 std::ostringstream & accList,
459 std::vector<std::tuple<int,std::string,int64_t>>& proteinIds) const;
460
461 enum RELATION {REL_FAMILY, REL_SAMESET, REL_SUBSET, REL_ALLSUBSETS};
462 ms_protein * getNextXXProtein(const RELATION relation,
463 const char * accession,
464 const int dbIdx,
465 const int id,
466 const double subsetsScoreFraction = 1.0) const;
467 void addRelation(RELATION relation, const ms_protein *parent, ms_protein *child);
468
469
470
471 void findFamily(const ms_protein * & prot,
472 const int numProteins,
473 proteinSet_t & processed,
474 bool & keepingThisOne);
475 void partition_peptides(const ms_protein * prot,
476 std::list<ms_peptide *> & peps_above,
477 std::list<ms_peptide *> & peps_below) const;
478 std::map<std::string, std::list<qp_t> > find_representative_sequences(const ms_protein *prot,
479 const std::list<ms_peptide *> &peptides) const;
480 proteinSet_t homologous_proteins(const ms_protein * prot,
481 const std::list<ms_peptide *> & peptides_above,
482 const std::list<ms_peptide *> & peptides_below,
483 peptideSet_t & processed_peptides,
484 proteinSet_t & processed,
485 proteinSet_t & in_queue) const;
486 void groupFamily(const peptideMatrix<> & peptide_matrix_precise,
487 const peptideMatrix<> & peptide_matrix_smeared,
488 const ms_protein * & mainProtein,
489 bool & keepingThisOne);
490 void eliminate_intersections(const proteinSet_t & sameset_arents,
491 const peptideMatrix<> & peptide_matrix_precise,
492 const peptideMatrix<> & peptide_matrix_smeared,
493 proteinSet_t & lead_proteins,
494 proteinFamily_t & subset_proteins);
495 const ms_protein* choose_next_free_protein(const proteinSet_t & lead_proteins,
496 const peptideMatrix<> & peptide_matrix,
497 proteinSet_t & unused_proteins,
498 proteinFamily_t & subset_proteins);
499 void remove_conflicting_proteins(const peptideMatrix<> & peptide_matrix,
500 proteinSet_t & lead_proteins,
501 proteinFamily_t & subset_proteins);
502 };
503 // end of resfile_group
505
507
508} // msparser_internal namespace
509
510#endif // SWIG
511
512#endif // MS_PROTEININFERENCE_HPP
513
514/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::getPrettyRank
int getPrettyRank() const
Similar to getRank() except that equivalent scores get the same rank.
Definition: ms_peptide.cpp:517
matrix_science::ms_peptide::getQuery
int getQuery() const
Each peptide is associate with a query.
Definition: ms_peptide.cpp:441
matrix_science::ms_peptidesummary::MSPEPSUM_NONE
@ MSPEPSUM_NONE
Default.
Definition: ms_peptidesummary.hpp:141
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_protein::getDB
int getDB() const
Return the index of the database where the sequence is found.
Definition: ms_protein.cpp:494
matrix_science::ms_protein::getAccession
std::string getAccession() const
Return the accession string for a protein.
Definition: ms_protein.cpp:479
matrix_science::DATABASE_TYPE
DATABASE_TYPE
Definition: ms_databaseoptions.hpp:39
matrix_science::SLREF
@ SLREF
FASTA reference database of a Spectral Library.
Definition: ms_databaseoptions.hpp:43
matrix_science::SL
@ SL
Spectral Library (MSP file)
Definition: ms_databaseoptions.hpp:42
matrix_science::NA
@ NA
NA sequence database (FASTA file, nucleic acid)
Definition: ms_databaseoptions.hpp:41
matrix_science::AA
@ AA
Protein sequence database (FASTA file, amino acid)
Definition: ms_databaseoptions.hpp:40
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_proteinsummary.hpp Source File

  • inc
ms_proteinsummary.hpp
1/*
2##############################################################################
3# file: ms_mascotresproteinsum.cpp #
4# 'msparser' toolkit #
5# Encapsulates the protein summary report from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespr $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2024-08-29 17:08:49 +0100 $ #
14# $Revision: 5342f33ad8c8306230f6edda6c723ef3d3ff158b | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESPROTEINSUM_HPP
20#define MS_MASCOTRESPROTEINSUM_HPP
21
22
23// Includes from the standard template library
24#include <string>
25
26namespace msparser_internal {
27 class ms_proteinsummarybase;
28}
29
30namespace matrix_science {
31 class ms_mascotresults_parameters;
32
44 class MS_MASCOTRESFILE_API ms_proteinsummary : public ms_mascotresults
45 {
46 public:
48 ms_proteinsummary(const ms_mascotresfilebase &resfile,
49 const unsigned int flags = ms_mascotresults::MSRES_GROUP_PROTEINS
50 | ms_mascotresults::MSRES_SHOW_SUBSETS,
51 double minProbability = 0.0,
52 int maxHitsToReport = 50,
53 const char * unigeneIndexFile = 0,
54 const char * singleHit = 0);
55
57 ms_proteinsummary(const ms_mascotresfilebase &resfile,
58 const ms_mascotresults_params & parameters);
59
60 virtual ~ms_proteinsummary() = default;
61
63 virtual ms_peptide getPeptide(const int q, const int p) const;
64
66 virtual double getIonsScore(const int q, const int p, const bool decoy) const;
67
69 virtual bool isPeptideUnique(const int q, const int p, const ms_mascotresults::UNIQUE_PEP_RULES rules = ms_mascotresults::UPR_DEFAULT) const;
70
72 virtual bool getPeptide(const int q, const int p, ms_peptide * & pep) const;
73
75 virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false);
76
78 virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
79 std::vector<int> & start,
80 std::vector<int> & end,
81 std::vector<std::string> &pre,
82 std::vector<std::string> &post,
83 std::vector<int> & frame,
84 std::vector<int> & multiplicity,
85 std::vector<int> & db) const;
86
88 virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
89 std::vector<int> & start,
90 std::vector<int> & end,
91 std::vector<std::string> &pre,
92 std::vector<std::string> &post,
93 std::vector<int> & frame,
94 std::vector<int> & multiplicity,
95 std::vector<int> & db,
96 std::vector<int> & psmComponent) const;
97
99 virtual int getAllFamilyMembersWithThisPepMatch(const int hit,
100 const int q,
101 const int p,
102 std::vector< int >& db,
103 std::vector< std::string >& acc,
104 std::vector< int >& dupe_status) const;
105
106
108 virtual std::string getErrTolModString(const int q, const int p) const;
109
111 virtual std::string getLibraryModString(const int q, const int p) const;
112
114 virtual std::string getErrTolModMasterString(const int q, const int p) const;
115
117 virtual std::string getErrTolModSlaveString(const int q, const int p) const;
118
120 virtual std::string getErrTolModPepString(const int q, const int p) const;
121
123 virtual std::string getErrTolModReqPepString(const int q, const int p) const;
124
126 virtual std::string getTagString(const int q, const int p) const;
127
129 virtual int getTagDeltaRangeStart(const int q, const int p) const;
130
132 virtual int getTagDeltaRangeEnd(const int q, const int p) const;
133
135 virtual std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
136
138 virtual std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
139
141 virtual int getProteinScoreCutoff(double OneInXprobRnd) const;
142
144 int getNumPmfQueriesUsed() const;
145
147 bool isPmfQueryUsed(const int queryIdx) const;
148
150 virtual std::vector<int> getPepsWithSameScore(const int q, const int p) const;
151#ifndef SWIG
153 virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & value, double & rawValue) const;
154#else // SWIG Multiple return values
155 virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & OUTPUT, double & OUTPUT) const;
156#endif
158 virtual bool isValidQandP(const int q, const int h) const;
159
161 virtual ms_mascotresults::QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide(
162 const matrix_science::ms_peptide & peptide,
163 matrix_science::ms_quant_component & component,
164 const matrix_science::ms_quant_method * method = NULL) const;
165
166 protected:
167 // Not safe to copy or assign this object.
168 ms_proteinsummary(const ms_proteinsummary & rhs);
169#ifndef SWIG
170 ms_proteinsummary & operator=(const ms_proteinsummary & rhs);
171#endif
172
174 virtual int findProteins(const int startHit,
175 const std::string & str,
176 const int dbIdx,
177 ms_mascotresults::FIND_FLAGS item,
178 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
179 std::vector<std::string> & accessions,
180 std::vector<int> & dbIndexes) const;
181
183 virtual int findProteinsByAccession(const int startHit,
184 const std::string & str,
185 const int dbIdx,
186 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
187 std::vector<std::string> & accessions,
188 std::vector<int> & dbIndexes) const;
189
191 virtual int findProteinsByDescription(const int startHit,
192 const std::string & str,
193 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
194 std::vector<std::string> & accessions,
195 std::vector<int> & dbIndexes) const;
196
198 virtual int findPeptides(const int startHit,
199 const std::string & str,
200 ms_mascotresults::FIND_FLAGS item,
201 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
202 std::vector<int> & q,
203 std::vector<int> & p) const;
204
205 private:
206 std::shared_ptr<msparser_internal::ms_proteinsummarybase> iProtSum_;
207 }; // end of resfile_group
209} // matrix_science namespace
210
211#endif // MS_MASCOTRESPROTEINSUM_HPP
212
213/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults.hpp:83
matrix_science::ms_mascotresults::FIND_COMPARE_FLAGS
FIND_COMPARE_FLAGS
Flags to specify how comparisons are performed in the find functions.
Definition: ms_mascotresults.hpp:189
matrix_science::ms_mascotresults::UNIQUE_PEP_RULES
UNIQUE_PEP_RULES
Flags for isPeptideUnique().
Definition: ms_mascotresults.hpp:360
matrix_science::ms_mascotresults::FIND_FLAGS
FIND_FLAGS
Flags for findPeptides() and findProteins().
Definition: ms_mascotresults.hpp:146
matrix_science::ms_mascotresults::QUANT_COMPONENT_STATUS
QUANT_COMPONENT_STATUS
Return codes for getQuantitationComponentForPeptide().
Definition: ms_mascotresults.hpp:279
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_proteinsummary_dat.hpp Source File

  • src
  • resfile
  • impl
ms_proteinsummary_dat.hpp
1/*
2##############################################################################
3# file: ms_proteinsummary_dat.cpp #
4# 'msparser' toolkit #
5# Encapsulates the protein summary report from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespr $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-01-27 11:19:14 +0000 $ #
14# $Revision: 4d11ca7970abea85b29e796ae1af103b9476ea4c | MSPARSER_ALPHA_2_8_100-340-gd270de69e1 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PROTEINSUMMARY_DAT_HPP
20#define MS_PROTEINSUMMARY_DAT_HPP
21
22
23// Includes from the standard template library
24#include <string>
25
26#include "ms_proteinsummarybase.hpp"
27
28using namespace matrix_science;
29
30namespace msparser_internal {
31 class ms_mascotresults_dat;
32 class ms_mascotresults_parameters;
33
35
36
48 class ms_proteinsummary_dat : public ms_proteinsummarybase
49 {
50 public:
51
53 ms_proteinsummary_dat(
54 const ms_mascotresults_params & parameters,
55 const ms_mascotresfile_dat & resfile,
56 ms_proteinsummary & protSum);
57
59 ms_proteinsummary_dat(std::shared_ptr<ms_mascotresults_dat> resultsImpl, ms_proteinsummary & protSum);
60
61 void initialise();
62
63 virtual ~ms_proteinsummary_dat();
64
66 std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
67 std::vector<int> & start,
68 std::vector<int> & end,
69 std::vector<std::string> &pre,
70 std::vector<std::string> &post,
71 std::vector<int> & frame,
72 std::vector<int> & multiplicity,
73 std::vector<int> & db,
74 std::vector<int64_t> & protId) const override;
75
77 std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
78 std::vector<int> & start,
79 std::vector<int> & end,
80 std::vector<std::string> &pre,
81 std::vector<std::string> &post,
82 std::vector<int> & frame,
83 std::vector<int> & multiplicity,
84 std::vector<int> & db,
85 std::vector<int64_t> & protId,
86 std::vector<int> & psmComponent) const override;
87
88
90 std::string getErrTolModString(const int q, const int p) const override;
91
93 std::string getLibraryModString(const int q, const int p) const override;
94
96 std::string getErrTolModMasterString(const int q, const int p) const override;
97
99 std::string getErrTolModSlaveString(const int q, const int p) const override;
100
102 std::string getErrTolModPepString(const int q, const int p) const override;
103
105 std::string getErrTolModReqPepString(const int q, const int p) const override;
106
108 std::string getErrTolOriginalNaSeq(const int q, const int p) const override;
109
111 std::string getErrTolModifiedNaSeq(const int q, const int p) const override;
112
114 std::string getTagString(const int q, const int p) const override;
115
117 int getTagDeltaRangeStart(const int q, const int p) const override;
118
120 int getTagDeltaRangeEnd(const int q, const int p) const override;
121
123 std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const override;
124
126 std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const override;
127
129 int getProteinScoreCutoff(double OneInXprobRnd) const override;
130
131 protected:
132 // Not safe to copy or assign this object.
133 ms_proteinsummary_dat(const ms_proteinsummary_dat & rhs);
134#ifndef SWIG
135 ms_proteinsummary_dat & operator=(const ms_proteinsummary_dat & rhs);
136#endif
137
138
139
140 private:
141
142 bool parseProtein(const int hit);
143 void loadPepRes(const int hit,
144 const int dbIdx,
145 std::string & accession,
146 const int frame);
147 void addMixtureHits() override;
148
149 std::shared_ptr<ms_mascotresults_dat> resultsImpl_;
150 ms_proteinsummary & protSum_;
151 const ms_mascotresfile_dat &resfile_;
152
153 ms_mascotresfile_dat::section secSummary_;
154 ms_mascotresfile_dat::section secMixture_;
155 ms_mascotresfile_dat::section secPeptides_;
156 ms_mascotresfile_dat::section secProteins_;
157
158
159
160 }; // end of resfile_group
162
164
165} // msparser_internal namespace
166
167#endif // MS_PROTEINSUMMARY_DAT_HPP
168
169/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfile_dat
Class for parsing and reading files in dat28 format.
Definition: ms_mascotresfile_dat.hpp:121
matrix_science::ms_mascotresfile_dat::section
section
Section names in the standard mascot results files.
Definition: ms_mascotresfile_dat.hpp:132
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_peptide::PSM_COMPLETE
@ PSM_COMPLETE
Peptide-spectrum match, also linear peptide in a non-crosslinked match.
Definition: ms_peptide.hpp:99
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_proteinsummary_msr.hpp Source File

  • src
  • resfile
  • impl
ms_proteinsummary_msr.hpp
1/*
2##############################################################################
3# file: ms_proteinsummary_msr.cpp #
4# 'msparser' toolkit #
5# Encapsulates the protein summary report from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespr $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2023-04-14 14:24:04 +0100 $ #
14# $Revision: 11c8021bd289e3ddfb788ec8d8b24869657adc09 | MSPARSER_ALPHA_2_8_100-455-g58a3057437 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PROTEINSUMMARY_MSR_HPP
20#define MS_PROTEINSUMMARY_MSR_HPP
21
22#include "ms_proteinsummarybase.hpp"
23
24// Includes from the standard template library
25#include <string>
26
27
28namespace matrix_science {
29 class ms_mascotresults_parameters;
30}
31
32using namespace matrix_science;
33
34namespace msparser_internal {
35 class ms_mascotresults_msr;
36
38
50 class ms_proteinsummary_msr : public ms_proteinsummarybase
51 {
52 public:
53
55 ms_proteinsummary_msr(
56 const ms_mascotresults_params & parameters,
57 const ms_mascotresfile_msr & resfile,
58 ms_proteinsummary & protSum);
59
61 ms_proteinsummary_msr(std::shared_ptr<ms_mascotresults_msr> resultsImpl,
62 ms_proteinsummary & protSum);
63
64 virtual ~ms_proteinsummary_msr() = default;
65
66 void initialise();
67
69 std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
70 std::vector<int> & start,
71 std::vector<int> & end,
72 std::vector<std::string> &pre,
73 std::vector<std::string> &post,
74 std::vector<int> & frame,
75 std::vector<int> & multiplicity,
76 std::vector<int> & db,
77 std::vector<int64_t> & protId) const override;
78
80 std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
81 std::vector<int> & start,
82 std::vector<int> & end,
83 std::vector<std::string> &pre,
84 std::vector<std::string> &post,
85 std::vector<int> & frame,
86 std::vector<int> & multiplicity,
87 std::vector<int> & db,
88 std::vector<int64_t> & protId,
89 std::vector<int> & psmComponent) const override;
90
91
92
94 std::string getErrTolModString(const int q, const int p) const override;
95
97 std::string getLibraryModString(const int q, const int p) const override;
98
100 std::string getErrTolModMasterString(const int q, const int p) const override;
101
103 std::string getErrTolModSlaveString(const int q, const int p) const override;
104
106 std::string getErrTolModPepString(const int q, const int p) const override;
107
109 std::string getErrTolModReqPepString(const int q, const int p) const override;
110
112 std::string getErrTolOriginalNaSeq(const int q, const int p) const override;
113
115 std::string getErrTolModifiedNaSeq(const int q, const int p) const override;
116
117
119 std::string getTagString(const int q, const int p) const override;
120
122 int getTagDeltaRangeStart(const int q, const int p) const override;
123
125 int getTagDeltaRangeEnd(const int q, const int p) const override;
126
128 std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const override;
129
131 std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const override;
132
134 int getProteinScoreCutoff(double OneInXprobRnd) const override;
135
136 protected:
137 // Not safe to copy or assign this object.
138 ms_proteinsummary_msr(const ms_proteinsummary_msr & rhs);
139#ifndef SWIG
140 ms_proteinsummary_msr & operator=(const ms_proteinsummary_msr & rhs);
141#endif
142
143 private:
144
145 std::map<int, msparser_internal::msr_cached_data::EtModsData> getEtModsCachedData(const int q, const ms_peptide::PSM_TYPE psmType) const override;
146 std::map<std::pair<int, int>, msparser_internal::msr_cached_data::TagData> getTagCachedData(const int q, const ms_peptide::PSM_TYPE psmType) const override;
147
148 bool parseProtein(const int hit) override;
149 void loadPepRes(const int hit,
150 const int dbIdx,
151 std::string & accession,
152 const int frame);
153 void addMixtureHits() override;
154
155 std::shared_ptr<ms_mascotresults_msr> resultsImpl_;
156 ms_proteinsummary & protSum_;
157 const ms_mascotresfile_msr &resfile_;
158 ms_sqlpp11_connection & db_;
159
160 ms_peptide emptyPeptide_;
161
162 bool isPmfRanks_;
163 int numPmfQueriesUsed_;
164 std::vector<int> pmfQueriesUsed_;
165 int numPmfHitsPreserved_;
166
167 }; // end of resfile_group
169
171
172} // msparser_internal namespace
173
174#endif // MS_PROTEINSUMMARY_MSR_HPP
175
176/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfile_msr
Class for parsing and reading files in MSR format.
Definition: ms_mascotresfile_msr.hpp:105
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_peptide::PSM
PSM
Type of data to return from accessor methods.
Definition: ms_peptide.hpp:98
matrix_science::ms_peptide::PSM_COMPLETE
@ PSM_COMPLETE
Peptide-spectrum match, also linear peptide in a non-crosslinked match.
Definition: ms_peptide.hpp:99
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_proteinsummarybase.hpp Source File

  • src
  • resfile
  • impl
ms_proteinsummarybase.hpp
1/*
2##############################################################################
3# file: ms_ipepsum.hpp #
4# 'msparser' toolkit #
5# Encapsulates the peptide summary report from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
12# $Author: robertog@matrixscience.com $ #
13# $Date: 2022-11-15 10:10:42 +0000 $ #
14# $Revision: ae5726eb41aa1ec4bfda1bd4fafc686727881fd8 | MSPARSER_ALPHA_2_8_100-340-gd270de69e1 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_PROTEINSUMMARYBASE_HPP
20#define MS_PROTEINSUMMARYBASE_HPP
21
22#include "ms_mascotresultsbase.hpp"
23
24namespace msparser_internal {
26
32 class ms_proteinsummarybase : public ms_mascotresultsbase
33 {
34 public:
35
36 static ms_mascotresults_params getValidProteinSummaryParams(const ms_mascotresfilebase &resfile, const ms_mascotresults_params &params);
37 ms_proteinsummarybase(
38 std::shared_ptr<ms_mascotresults_implbase> resultsImpl,
39 ms_proteinsummary& protSum);
40
41 void initialise();
42
44 ms_peptide getPeptide(const int q, const int p) const override;
45
47 double getIonsScore(const int q, const int p, const bool decoy) const override;
48
50 bool isPeptideUnique(const int q, const int p, const ms_mascotresults::UNIQUE_PEP_RULES rules = ms_mascotresults::UPR_DEFAULT) const override;
51
53 bool getPeptide(const int q, const int p, ms_peptide* & pep) const override;
54
56 bool isValidQandP(const int q, const int h) const override;
57
59 std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) override;
60
62 int getAllFamilyMembersWithThisPepMatch(const int hit,
63 const int q,
64 const int p,
65 std::vector< int >& db,
66 std::vector< std::string >& acc,
67 std::vector< int >& dupe_status) const override;
68
69 int getAllFamilyMembersWithThisPepMatchProtected(const int hit,
70 const int q,
71 const int p,
72 std::vector< int >& db,
73 std::vector< std::string >& acc,
74 std::vector<int64_t> & protId,
75 std::vector< int >& dupe_status) const override;
76
77 bool queryHasSignificantRank1Match(ms_peptide::PSM_TYPE typePeptides,
78 int query) const override;
79
80 void calculateDecoyStats( double dOneInXprobRnd) override;
81
82 bool getThresholdForFDR(bool homology, double targetFDR,
83 ms_mascotresults::DECOY_STATS_COUNT_TYPE countType, ms_mascotresults::DB_MATCH_TYPE dbType,
84 double * closestFDR, double * minProbability,
85 int * pNumTargetMatches, int * pNumDecoyMatches) override;
86
87 bool cacheModificationCounts() override;
88
89 int getSrcRankAndPsmType(int q, int p, ms_peptide::PSM_TYPE & psmType, bool * pRejected = 0, bool inactiveSection = false) const override;
90
92 int getSrcRank(int q, int p) const override;
93
95 int getNumPmfQueriesUsed() const;
96
98 bool isPmfQueryUsed(const int queryIdx) const;
99
100
102 std::vector<int> getPepsWithSameScore(const int q, const int p) const override;
103#ifndef SWIG
105 bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & value, double & rawValue) const override;
106#else // SWIG Multiple return values
107 bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & OUTPUT, double & OUTPUT) const override;
108#endif
109
111 ms_mascotresults::QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide(
112 const matrix_science::ms_peptide & peptide,
113 matrix_science::ms_quant_component & component,
114 const matrix_science::ms_quant_method * method = NULL) const override;
115
117 int findProteins(const int startHit,
118 const std::string & str,
119 const int dbIdx,
120 ms_mascotresults::FIND_FLAGS item,
121 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
122 std::vector<std::string> & accessions,
123 std::vector<int> & dbIndexes) const override;
124
126 int findProteinsByAccession(const int startHit,
127 const std::string & str,
128 const int dbIdx,
129 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
130 std::vector<std::string> & accessions,
131 std::vector<int> & dbIndexes) const override;
132
134 int findProteinsByDescription(const int startHit,
135 const std::string & str,
136 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
137 std::vector<std::string> & accessions,
138 std::vector<int> & dbIndexes) const override;
139
141 int findPeptides(const int startHit,
142 const std::string & str,
143 ms_mascotresults::FIND_FLAGS item,
144 ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
145 std::vector<int> & q,
146 std::vector<int> & p) const override;
147
148
149
150
151
152
153
154
155
156
157 virtual bool parseProtein(const int hit) = 0;
158 virtual void addMixtureHits() = 0;
159
160 protected:
161 std::shared_ptr<ms_mascotresults_implbase> resultsImpl_;
162 ms_proteinsummary & protSum_;
163
164 int singleHitAsInt_;
165 //ms_peptide emptyPeptide_;
166
167 bool isPmfRanks_;
168 int numPmfQueriesUsed_;
169 std::vector<int> pmfQueriesUsed_;
170 int numPmfHitsPreserved_;
171
172
173 }; // end of resfile_group
175
177
178} // msparser_internal namespace
179
180#endif // MS_PROTEINSUMMARYBASE_HPP
181
182/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.
Definition: ms_mascotresults_params.hpp:32
matrix_science::ms_mascotresults::FIND_COMPARE_FLAGS
FIND_COMPARE_FLAGS
Flags to specify how comparisons are performed in the find functions.
Definition: ms_mascotresults.hpp:189
matrix_science::ms_mascotresults::DECOY_STATS_COUNT_TYPE
DECOY_STATS_COUNT_TYPE
Type of object counted by getNumHitsAboveIdentity() and friends.
Definition: ms_mascotresults.hpp:382
matrix_science::ms_mascotresults::UNIQUE_PEP_RULES
UNIQUE_PEP_RULES
Flags for isPeptideUnique().
Definition: ms_mascotresults.hpp:360
matrix_science::ms_mascotresults::UPR_DEFAULT
@ UPR_DEFAULT
Set to UPR_WITHIN_FAMILY_MEMBER | UPR_IGNORE_SUBSET_PROTEINS.
Definition: ms_mascotresults.hpp:365
matrix_science::ms_mascotresults::FIND_FLAGS
FIND_FLAGS
Flags for findPeptides() and findProteins().
Definition: ms_mascotresults.hpp:146
matrix_science::ms_mascotresults::DB_MATCH_TYPE
DB_MATCH_TYPE
Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreH...
Definition: ms_mascotresults.hpp:344
matrix_science::ms_mascotresults::QUANT_COMPONENT_STATUS
QUANT_COMPONENT_STATUS
Return codes for getQuantitationComponentForPeptide().
Definition: ms_mascotresults.hpp:279
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_TYPE
PSM_TYPE
Specifies the search pass and origin of the peptide match.
Definition: ms_peptide.hpp:107
matrix_science::ms_proteinsummary
Definition: ms_proteinsummary.hpp:45
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_average.hpp Source File

  • inc
ms_quant_average.hpp
1/*
2##############################################################################
3# file: ms_quant_average.hpp #
4# 'msparser' toolkit #
5# Encapsulates average-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_average.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_AVERAGE_HPP
18#define MS_QUANT_AVERAGE_HPP
19
20
21// forward declarations
22namespace msparser_internal {
23 class ms_quant_xmlloader;
24}
25
26namespace matrix_science {
27
28 class ms_xml_schema; // forward declaration
29
36
39 class MS_MASCOTRESFILE_API ms_quant_average: public ms_quant_parameters
40 {
41 friend class msparser_internal::ms_quant_xmlloader;
42 public:
44 ms_quant_average();
45
47 ms_quant_average(const ms_quant_average& src);
48
50 virtual ~ms_quant_average();
51
53 void defaultValues();
54
56 void copyFrom(const ms_quant_average* right);
57
58#ifndef SWIG
60 ms_quant_average& operator=(const ms_quant_average& right);
61#endif
63 virtual std::string getSchemaType() const;
64
66 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
67
69 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
70
71
73 bool haveNumPeptides() const;
74
76 int getNumPeptides() const;
77
79 void setNumPeptides(int value);
80
82 void dropNumPeptides();
83
85 std::string getNumPeptidesSchemaType() const;
86
87
89 bool haveSelection() const;
90
92 std::string getSelection() const;
93
95 void setSelection(const char* value);
96
98 void dropSelection();
99
101 std::string getSelectionSchemaType() const;
102
103
105 bool haveReferenceAccession() const;
106
108 std::string getReferenceAccession() const;
109
111 void setReferenceAccession(const char* value);
112
114 void dropReferenceAccession();
115
117 std::string getReferenceAccessionSchemaType() const;
118
119
121 bool haveReferenceDatabase() const;
122
124 std::string getReferenceDatabase() const;
125
127 void setReferenceDatabase(const char* value);
128
130 void dropReferenceDatabase();
131
133 std::string getReferenceDatabaseSchemaType() const;
134
135
137 bool haveReferenceAmount() const;
138
140 std::string getReferenceAmount() const;
141
143 void setReferenceAmount(const char* value);
144
146 void dropReferenceAmount();
147
149 std::string getReferenceAmountSchemaType() const;
150 private:
151
152 int _numPeptides;
153 bool _numPeptides_set;
154
155 std::string _selection;
156 bool _selection_set;
157
158 std::string _referenceAccession;
159 bool _referenceAccession_set;
160
161 std::string _referenceDatabase;
162 bool _referenceDatabase_set;
163
164 std::string _referenceAmount;
165 bool _referenceAmount_set;
166 }; // class ms_quant_average
167 // end of config_group
169
170} // namespace matrix_science
171
172#endif // MS_QUANT_AVERAGE_HPP
173
174/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_average
An object of this class represent a single "average" element in quantitation.xml.
Definition: ms_quant_average.hpp:40
matrix_science::ms_quant_parameters
A class that represents base parametersType in quantitation.xml.
Definition: ms_quant_parameters.hpp:82
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_component.hpp Source File

  • inc
ms_quant_component.hpp
1/*
2##############################################################################
3# file: ms_quant_component.hpp #
4# 'msparser' toolkit #
5# Encapsulates component-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_component.hpp $
12 * @(#)$Revision: b16aae2ec68e22e8ed391e0142135bc5ee360bea | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2021-10-18 13:38:36 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_COMPONENT_HPP
18#define MS_QUANT_COMPONENT_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_quant_modgroup; // forward declaration
32 class ms_quant_moverz; // forward declaration
33 class ms_quant_correction; // forward declaration
34 class ms_quant_isotope; // forward declaration
35 class ms_quant_satellite; // forward declaration
36 class ms_xml_schema; // forward declaration
37
44
47 class MS_MASCOTRESFILE_API ms_quant_component: public ms_xml_IValidatable
48 {
49 friend class msparser_internal::ms_quant_xmlloader;
50
51 public:
53 ms_quant_component();
54
56 ms_quant_component(const ms_quant_component& src);
57
59 virtual ~ms_quant_component();
60
62 void defaultValues();
63
65 void copyFrom(const ms_quant_component* right);
66
67#ifndef SWIG
69 ms_quant_component& operator=(const ms_quant_component& right);
70#endif
71
73 virtual std::string getSchemaType() const;
74
76 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
77
79 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
80
81
83 bool haveMoverz() const;
84
86 const ms_quant_moverz* getMoverz() const;
87
89 void setMoverz(const ms_quant_moverz* moverz);
90
92 void dropMoverz();
93
95 std::string getMoverzSchemaType() const;
96
97
99 int getNumberOfModificationGroups() const;
100
102 void clearModificationGroups();
103
105 void appendModificationGroup(const ms_quant_modgroup *item);
106
108 const ms_quant_modgroup * getModificationGroupByNumber(const int idx) const;
109
111 const ms_quant_modgroup * getModificationGroupByName(const char *name) const;
112
114 bool updateModificationGroupByNumber(const int idx, const ms_quant_modgroup* modgroup);
115
117 bool updateModificationGroupByName(const char *name, const ms_quant_modgroup* modgroup);
118
120 bool deleteModificationGroupByNumber(const int idx);
121
123 bool deleteModificationGroupByName(const char *name);
124
126 std::string getModificationGroupSchemaType() const;
127
128
130 int getNumberOfIsotopes() const;
131
133 void clearIsotopes();
134
136 void appendIsotope(const ms_quant_isotope* isotope);
137
139 const ms_quant_isotope* getIsotope(const int idx) const;
140
142 bool updateIsotope(const int idx, const ms_quant_isotope* isotope);
143
145 bool deleteIsotope(const int idx);
146
148 std::string getIsotopeSchemaType() const;
149
150
151
153 bool haveFileIndex() const;
154
156 int getFileIndex() const;
157
159 void setFileIndex(const int file_index);
160
162 void dropFileIndex();
163
165 std::string getFileIndexSchemaType() const;
166
168 int getNumberOfFileIndexes() const;
169
171 void clearFileIndexes();
172
174 void appendFileIndex(const ms_quant_file_index * file_index);
175
177 const ms_quant_file_index* getFileIndex(const int idx) const;
178
180 bool updateFileIndex(const int idx, const ms_quant_file_index * file_index);
181
183 bool deleteFileIndex(const int idx);
184
185
187 int getNumberOfCorrections() const;
188
190 void clearCorrections();
191
193 void appendCorrection(const ms_quant_correction* correction);
194
196 const ms_quant_correction* getCorrection(const int idx) const;
197
199 bool updateCorrection(const int idx, const ms_quant_correction* isotope);
200
202 bool deleteCorrection(const int idx);
203
205 std::string getCorrectionSchemaType() const;
206
207
209 bool haveName() const;
210
212 std::string getName() const;
213
215 void setName(const char* value);
216
218 void dropName();
219
221 std::string getNameSchemaType() const;
222
223
225 bool haveSatellite() const;
226
228 const ms_quant_satellite* getSatellite() const;
229
231 void setSatellite(const ms_quant_satellite* satellite);
232
234 void dropSatellite();
235
237 std::string getSatelliteSchemaType() const;
238
239 private:
240 // elements
241 ms_quant_moverz *_pMoverz;
242 bool _moverz_set;
243
244 typedef std::vector< ms_quant_modgroup* > modgroup_vector;
245 modgroup_vector _modgroups;
246
247 typedef std::vector< ms_quant_isotope* > isotope_vector;
248 isotope_vector _isotopes;
249
250 typedef std::vector< ms_quant_file_index *> file_index_vector;
251 file_index_vector _file_indexes;
252
253 typedef std::vector< ms_quant_correction* > correction_vector;
254 correction_vector _corrections;
255
256 // attributes
257 std::string _name;
258 bool _name_set;
259
260 ms_quant_satellite *_pSatellite;
261 bool _satellite_set;
262 }; // class ms_quant_component
263 // end of config_group
265
266} // namespace matrix_science
267
268#endif // MS_QUANT_COMPONENT_HPP
269
270/*------------------------------- End of File -------------------------------*/
271
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_correction
Represents a correction element.
Definition: ms_quant_correction.hpp:40
matrix_science::ms_quant_file_index
Represents a file_index element.
Definition: ms_quant_file_index.hpp:52
matrix_science::ms_quant_isotope
Represents an isotope element.
Definition: ms_quant_isotope.hpp:40
matrix_science::ms_quant_modgroup
An object of this class represent a single modification group element in quantitation....
Definition: ms_quant_modgroup.hpp:46
matrix_science::ms_quant_moverz
Parameter name and value pair.
Definition: ms_quant_moverz.hpp:39
matrix_science::ms_quant_satellite
An object of this class represent a single satellite element in quantitation.xml.
Definition: ms_quant_satellite.hpp:45
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_composition.hpp Source File

  • inc
ms_quant_composition.hpp
1/*
2##############################################################################
3# file: ms_quant_composition.hpp #
4# 'msparser' toolkit #
5# Encapsulates "compositionType" from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_composition.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_COMPOSITION_HPP
18#define MS_QUANT_COMPOSITION_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_xml_schema; // forward declaration
32
39 class MS_MASCOTRESFILE_API ms_quant_element: public ms_xml_IValidatable
40 {
41 friend class msparser_internal::ms_quant_xmlloader;
42
43 public:
45 ms_quant_element();
46
48 ms_quant_element(const ms_quant_element& src);
49
51 virtual ~ms_quant_element();
52
54 void defaultValues();
55
57 void copyFrom(const ms_quant_element* right);
58
59#ifndef SWIG
61 ms_quant_element& operator=(const ms_quant_element& right);
62#endif
63
65 virtual std::string getSchemaType() const;
66
68 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
69
71 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
72
73
75 bool haveSymbol() const;
76
78 std::string getSymbol() const;
79
81 void setSymbol(const char* symbol);
82
84 void dropSymbol();
85
87 std::string getSymbolSchemaType() const;
88
89
91 bool haveNumber() const;
92
94 int getNumber() const;
95
97 void setNumber(const int number);
98
100 void dropNumber();
101
103 std::string getNumberSchemaType() const;
104
105
106 private:
107 std::string _symbol;
108 bool _symbol_set;
109
110 int _number;
111 bool _number_set;
112
113 }; // class ms_quant_element
114
116
119 class MS_MASCOTRESFILE_API ms_quant_composition: public ms_xml_IValidatable
120 {
121 friend class msparser_internal::ms_quant_xmlloader;
122 public:
124 ms_quant_composition();
125
127 ms_quant_composition(const ms_quant_composition& src);
128
130 virtual ~ms_quant_composition();
131
133 void defaultValues();
134
136 void copyFrom(const ms_quant_composition* right);
137
138#ifndef SWIG
140 ms_quant_composition& operator=(const ms_quant_composition& right);
141#endif
143 virtual std::string getSchemaType() const;
144
146 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
147
149 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
150
151
153 int getNumberOfElements() const;
154
156 void clearElements();
157
159 void appendElement(const ms_quant_element *element);
160
162 const ms_quant_element * getElement(const int idx) const;
163
165 bool updateElement(const int idx, const ms_quant_element* element);
166
168 bool deleteElement(const int idx);
169
171 std::string getElementSchemaType() const;
172
173 private:
174 typedef std::vector< ms_quant_element* > element_vector;
175 element_vector _elements;
176
177 }; // class ms_quant_composition
178 // end of config_group
180
181} // namespace matrix_science
182
183#endif // MS_QUANT_COMPOSITION_HPP
184
185/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_composition
Describes the compositionType type in quantitation.xml.
Definition: ms_quant_composition.hpp:120
matrix_science::ms_quant_element
The element sub-element of compositionType in quantitation.xml.
Definition: ms_quant_composition.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_configfile.hpp Source File

  • inc
ms_quant_configfile.hpp
1/*
2##############################################################################
3# file: ms_quant_configfile.hpp #
4# 'msparser' toolkit #
5# Encapsulates "quantitation.xml"-file that serves as quantitation #
6# configuration file #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12 * @(#)$Source: parser/inc/ms_quant_configfile.hpp $
13 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
14 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
15##############################################################################
16 */
17
18#ifndef MS_QUANT_CONFIGFILE_HPP
19#define MS_QUANT_CONFIGFILE_HPP
20
21
22#include <string>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27 class ms_quant_configfile_impl;
28}
29
30namespace matrix_science {
31
32 class ms_connection_settings; // forward declaration
33 class ms_quant_method; // forward declaration
34
41
51 class MS_MASCOTRESFILE_API ms_quant_configfile: public ms_errors
52 {
53 friend class msparser_internal::ms_quant_xmlloader;
54 public:
56 ms_quant_configfile();
57
59 ms_quant_configfile(const ms_quant_configfile& src);
60
62 ms_quant_configfile(const char* fileName, const char* schemaFileName,
63 const ms_connection_settings * cs = 0);
64
66 ~ms_quant_configfile();
67
69 void defaultValues();
70
72 void copyFrom(const ms_quant_configfile* right);
73
74#ifndef SWIG
76 ms_quant_configfile& operator=(const ms_quant_configfile& right);
77#endif
79 void setFileName(const char* name);
80
82 std::string getFileName() const;
83
85 void setSchemaFileName(const char* name);
86
88 std::string getSchemaFileName() const;
89
91 void setSchemaDirectory(const char * dir);
92
94 std::string getSchemaDirectory() const;
95
97 void setConnectionSettings(const ms_connection_settings & cs);
98
100 ms_connection_settings getConnectionSettings() const;
101
103 void read_file();
104
106 void save_file();
107
109 void read_buffer(const char *buffer);
110
112 std::string save_buffer();
113
115 std::string validateDocument() const;
116
118 int getNumberOfMethods() const;
119
121 void clearMethods();
122
124 void appendMethod(const ms_quant_method *item);
125
127 const ms_quant_method * getMethodByNumber(const int idx) const;
128
130 const ms_quant_method * getMethodByName(const char *name) const;
131
133 bool updateMethodByNumber(const int idx, const ms_quant_method *mod);
134
136 bool updateMethodByName(const char *name, const ms_quant_method *mod);
137
139 bool deleteMethodByNumber(const int idx);
140
142 bool deleteMethodByName(const char *name);
143
145 std::string getMajorVersion() const;
146
148 std::string getMinorVersion() const;
149
150 private:
151 msparser_internal::ms_quant_configfile_impl * m_pImpl;
152 }; // class ms_quant_configfile
153 // end of config_group
155
156} // namespace matrix_science
157
158#endif // MS_QUANT_CONFIGFILE_HPP
159
160/*------------------------------- End of File -------------------------------*/
161
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_quant_configfile
Use this class in order to read/write quantitation.xml.
Definition: ms_quant_configfile.hpp:52
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_correction.hpp Source File

  • inc
ms_quant_correction.hpp
1/*
2##############################################################################
3# file: ms_quant_correction.hpp #
4# 'msparser' toolkit #
5# Encapsulates \c correction element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_correction.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_CORRECTION_HPP
18#define MS_QUANT_CORRECTION_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_xml_schema; // forward declaration
32
39 class MS_MASCOTRESFILE_API ms_quant_correction: public ms_xml_IValidatable
40 {
41 friend class msparser_internal::ms_quant_xmlloader;
42
43 public:
45 ms_quant_correction();
46
48 ms_quant_correction(const ms_quant_correction& src);
49
51 virtual ~ms_quant_correction();
52
54 void defaultValues();
55
57 void copyFrom(const ms_quant_correction* right);
58
59#ifndef SWIG
61 ms_quant_correction& operator=(const ms_quant_correction& right);
62#endif
63
65 virtual std::string getSchemaType() const;
66
68 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
69
71 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
72
73
75 bool haveShift() const;
76
78 int getShift() const;
79
81 void setShift(const int value);
82
84 void dropShift();
85
87 std::string getShiftSchemaType() const;
88
89
91 bool haveType() const;
92
94 std::string getType() const;
95
97 void setType(const char* value);
98
100 void dropType();
101
103 std::string getTypeSchemaType() const;
104
105
107 bool haveElement() const;
108
110 std::string getElement() const;
111
113 void setElement(const char* value);
114
116 void dropElement();
117
119 std::string getElementSchemaType() const;
120
121
123 std::string getContent() const;
124
126 void setContent(const char* value);
127
129 std::string getContentSchemaType() const;
130
131 private:
132 int _shift;
133 bool _shift_set;
134
135 std::string _type;
136 bool _type_set;
137
138 std::string _element;
139 bool _element_set;
140
141 std::string _content;
142
143 }; // class ms_quant_correction
144 // end of config_group
146
147} // namespace matrix_science
148
149#endif // MS_QUANT_CORRECTION_HPP
150
151/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_correction
Represents a correction element.
Definition: ms_quant_correction.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_extractors.hpp Source File

  • src
  • tools
ms_quant_extractors.hpp
1/*
2##############################################################################
3# file: ms_quant_extractors.hpp #
4# 'msparser' toolkit #
5# Reporter and Multiplex MS/MS component intensity extractors #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author$ #
12# $Date$ #
13# $Revision$ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_QUANT_EXTRACTORS_HPP
19#define MS_QUANT_EXTRACTORS_HPP
20
21#include <string>
22#include <vector>
23#include <utility>
24
25#include "boost/format.hpp"
26#include "ms_matrix.hpp"
27
28// Include "ms_quant_mod_parsing.hpp" and "ms_fragment.hpp" to use this header
29
30namespace matrix_science {
31 class ms_errors;
32 class ms_quant_method;
33 class ms_mascotresfilebase;
34 class ms_inputquery;
35 class ms_peptide;
36 class ms_aahelper;
37 class ms_quant_multiplex;
38 class ms_fragment;
39 class ms_umod_composition;
40}
41
42namespace msparser_internal {
43 using namespace matrix_science;
44
45 // There isn't much common code between the classes except error
46 // handling and two method interfaces.
47 class ms_quant_extractor
48 {
49 public:
50 virtual ~ms_quant_extractor();
51
53 bool isValid() const { return !hasInitialisationError_; }
54
56 std::string getLastErrorString() const { return initialisationErrorString_; }
57
58 virtual unsigned int collectIntensities(ms_inputquery &query, const ms_peptide &peptide, std::vector<double> &intensities, std::vector<double> &rawIntensities, std::string *reason = 0) const = 0;
59
60 protected:
61 ms_quant_extractor(): hasInitialisationError_(false), initialisationErrorString_("") { }
62
63 void setInitialisationError(const std::string &errstr) {
64 hasInitialisationError_ = true;
65 initialisationErrorString_ = errstr;
66 }
67
68 void setInitialisationError(const boost::format &fmt);
69
70 private:
71 ms_quant_extractor(const ms_quant_extractor &);
72 ms_quant_extractor& operator=(const ms_quant_extractor &);
73
74 bool hasInitialisationError_;
75 std::string initialisationErrorString_;
76 };
77
78 typedef matrix_science::ms_matrix::column_vector_t column_vector_t;
79 typedef matrix_science::ms_matrix::matrix_t matrix_t;
80
81 typedef std::pair<double, double> peak_t;
82
83 class ms_quant_reporter_extractor: public ms_quant_extractor
84 {
85 public:
86 enum REPORTER_COLLECTION_STATE {
87 REPORTER_COLLECTION_SUCCEEDED = 0x0000,
88
89 REPORTER_COLLECTION_UNAVAILABLE = 0xf000
90 };
91
93 ms_quant_reporter_extractor(std::shared_ptr<const ms_mascotresfilebase> resfile, const ms_quant_method &qm);
94
96 virtual ~ms_quant_reporter_extractor();
97
99 virtual unsigned int collectIntensities(ms_inputquery &query, const ms_peptide &peptide, std::vector<double> &intensities, std::vector<double> &rawIntensities, std::string *reason = 0) const;
100
101 private:
103 unsigned int collectIntensities(const std::vector<peak_t> &spectrum, std::vector<double> &intensities, std::vector<double> &rawIntensities, std::string *reason = 0) const;
104
105 // No copying.
106 ms_quant_reporter_extractor(const ms_quant_reporter_extractor&);
107 ms_quant_reporter_extractor& operator=(const ms_quant_reporter_extractor&);
108
109 bool populateCorrectionMatrix(const ms_quant_method &qm);
110
111 const int numComponents_;
112 const unsigned int numComponentElts_;
113 matrix_t *matA_;
114 std::vector<unsigned int> *permutationVector_;
115 std::vector<double> componentMz_;
116 double mzTolerance_;
117 double mzWindowMin_;
118 double mzWindowMax_;
119 };
120
121 class ms_quant_multiplex_extractor: public ms_quant_extractor
122 {
123 public:
124 enum MULTIPLEX_COLLECTION_STATE {
125 MULTIPLEX_COLLECTION_SUCCEEDED = 0x0000,
126
127 MULTIPLEX_MATCHES_NO_COMPONENTS = 0x0001,
128 MULTIPLEX_MATCHES_MULTIPLE_COMPONENTS = 0x0002,
129
130 MULTIPLEX_NOT_ENOUGH_ION_PAIRS = 0x0010,
131
132 // MULTIPLEX_HAS_INTERNAL_MODIFICATION_SITE
133
134 MULTIPLEX_COLLECTION_UNAVAILABLE = 0xf000
135 };
136
138 ms_quant_multiplex_extractor(std::shared_ptr<const ms_mascotresfilebase> resfile, const ms_quant_method &qm);
139
140 virtual ~ms_quant_multiplex_extractor();
141
143 virtual unsigned int collectIntensities(ms_inputquery &query, const ms_peptide &peptide, std::vector<double> &intensities, std::vector<double> &rawIntensities, std::string *reason = 0) const;
144
145 private:
147 unsigned int collectIntensities(const std::vector<peak_t> &spectrum, const ms_peptide &peptide, std::vector<double> &intensities, std::vector<double> &rawIntensities, const std::string *queryRules = 0, double minInternalMass = -1, double maxInternalMass = -1, std::string *reason = 0) const;
148
149 // No copying.
150 ms_quant_multiplex_extractor(const ms_quant_multiplex_extractor&);
151 ms_quant_multiplex_extractor& operator=(const ms_quant_multiplex_extractor&);
152
153 const int numComponents_;
154 const unsigned int numComponentElts_;
155 double C13MassDiff_;
156 const double defaultMinInternalMass_;
157 const double defaultMaxInternalMass_;
158 double ionTolerance_;
159 MASS_TYPE massType_;
160 double ionIntensityThreshold_;
161 bool isExcludeIsobaricFragments_;
162 int minIonPairs_;
163
164 static const int NUM_RULES;
165 std::vector<bool> defaultRules_; // of size NUM_RULES
166
167 typedef struct { int index; char terminus; } supported_series_t;
168 static const supported_series_t supported_series[];
169
170 // Ion series used in our quantitation method.
171 std::set<const supported_series_t *> protocolIonSeries_;
172
173 bool determineProtocolIonSeries(const ms_quant_multiplex *multiplex);
174 void initialiseC13massDiff(const ms_umod_configfile &umodfile);
175
176 const bool useAveragineCorrection_;
177
178 bool useImpurityCorrection_;
179 double impurityLightCorrection_;
180 double impurityHeavyCorrection_;
181 std::string impurityHeavySymbol_;
182 // int is large enough, as we don't expect the integer mass
183 // difference to be bigger than a few Da.
184 int impurityLightHeavyMassDiff_;
185
186 // Scratch variables for intensity correction
187 matrix_t *matA_;
188 matrix_t *matIN_;
189 matrix_t *matIC_;
190 matrix_t *matJ_;
191 std::vector<unsigned int> *matIN_permutation_;
192 std::vector<unsigned int> *matIC_permutation_;
193 std::vector<unsigned int> *matA_permutation_;
194
195 bool determineImpurityCorrectionElements(const ms_quant_method &qm, const ms_umod_configfile &umodfile);
196
197 typedef std::pair<int, double> isotope_correction_def_t;
198 typedef std::vector<isotope_correction_def_t> isotope_correction_defs_t;
199
200 typedef struct {
201 std::string title;
202 modification_sites_t modification_sites;
203 char varmod_char; // 0..9,A..W
204 char nl_char; // nonnegative integer
205
206 // Impurity correction (optional)
207 isotope_correction_defs_t isotope_corrections;
208
209 // Delta is only needed in averagine and impurity corrections
210 int int_delta;
211 } component_modification_t;
212
213 typedef std::vector<component_modification_t> component_modifications_t;
214
215 // Multiplex modifications in our quantitation method. Each
216 // component has at least one modification, and each modification
217 // has at least one site.
218 std::vector<component_modifications_t> componentModifications_;
219
220 // Reverse mapping of the above by integer delta.
221 static const unsigned int DELTA_NTERM = 0;
222 static const unsigned int DELTA_CTERM = 1;
223 typedef std::vector<int> component_to_delta_t;
224 std::vector<component_to_delta_t> componentTerminusDelta_;
225
226 // Initialiser for the two data structures above:
227 bool determineProtocolModificationSites(const ms_quant_method &qm, const ms_umod_configfile &umodfile, ms_searchparams &params);
228 bool findComponentModifications(const ms_quant_modgroup *modgroup, const ms_umod_configfile &umodfile, const varmod_title_map_t &varmod_title_map, ms_searchparams &params, component_modifications_t &found_mods);
229 char chooseNeutralLossIndex(ms_searchparams &params, char varmod_char);
230 std::vector<isotope_correction_def_t> calculateIsotopeCorrections(const ms_umod_composition *comp) const;
231 bool isComponentModificationOK(component_modification_t &compmod);
232
233 ms_aahelper *aahelper_;
234
235 bool initialiseAAhelper(const ms_umod_configfile &umodfile, ms_searchparams &params);
236
237 void ignoreMultiplexSeries(std::vector<bool> &rules) const;
238 int countMatchingComponents(const ms_peptide &peptide) const;
239 std::vector<ms_peptide> conformPeptideToComponents(const ms_peptide &peptide) const;
240 void calculateFragments(int ruleID, const ms_peptide &conformingPeptide, double minMass, double maxMass, int max_fragment_charge, std::vector<ms_fragment> &fragments) const;
241
242 struct fragment_t {
243 unsigned int component;
244 int charge;
245 double mz;
246 double intensity;
247 std::string label;
248 bool isNterm;
249 bool isCterm;
250
251 explicit fragment_t(double m);
252 fragment_t(unsigned int component_idx, const ms_fragment &frag);
253 bool operator<(const fragment_t &right) const;
254 };
255 typedef std::vector<fragment_t> fragments_t;
256
257 fragments_t calculateFragmentIons(const std::vector<ms_peptide> &conformingPeptides, int max_fragment_charge) const;
258 void assignExperimentalIntensities(fragments_t &multiplexIons, const std::vector<peak_t> &spectrum) const;
259
260 void eliminateIsobaricOverlap(fragments_t &multiplexIons, const std::vector<ms_peptide> &conformingPeptides, double minInternalMass, double maxInternalMass, int max_fragment_charge, const std::vector<bool> &rules) const;
261 void eliminateInternalCollisions(fragments_t &multiplexIons) const;
262
263 void initialiseAveragineCorrectionMatrix(matrix_t *matJ, int charge, double mz, const component_to_delta_t &componentToDelta) const;
264 void initialiseImpurityCorrectionMatrices(matrix_t *matIN, matrix_t *matIC, const ms_peptide &peptide) const;
265
266 void correctTheseIntensities(std::vector<double> &ints, int charge, double mz, const component_to_delta_t &componentToDelta, matrix_t *matA, matrix_t *matI, matrix_t *matJ, std::vector<unsigned int> *matI_permutation) const;
267
268 // A fragment set is a vector of size numComponents_ of fragment
269 // ion intensities, grouped by fragment ion label. We don't need
270 // the label or the other attributes after the initial processing.
271 typedef std::set< std::vector<double> > fragment_sets_t;
272 void collectCompletePeakSets(const fragments_t &multiplexIons, const ms_peptide &peptide, fragment_sets_t &peakSets, fragment_sets_t &rawPeakSets) const;
273
274 int accumulateComponentIntensities(const fragment_sets_t &peakSets, std::vector<double> &intensities) const;
275
276 static std::vector<bool> split_rule_string(const std::string &str);
277 static void _dump_fragments(const fragments_t &multiplexIons, bool printIntensity);
278 static void _dump_peaksets(unsigned int numComponentElts, const std::string &fragment_label, const std::vector<fragment_t> &fragments, const std::vector<double> &ints, bool corrected);
279 };
280} // msparser_internal namespace
281#endif // MS_QUANT_EXTRACTORS_HPP
282
283/*------------------------------- End of File -------------------------------*/
matrix_science::ms_aahelper
This class facilitates creation of peptides and calculation of MS-fragment masses.
Definition: ms_aahelper.hpp:35
matrix_science::ms_fragment
Class representing a single peptide fragment.
Definition: ms_fragment.hpp:38
matrix_science::ms_inputquery
This class encapsulates the input queries (peak lists) in the Mascot results file.
Definition: ms_inputquery.hpp:43
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_quant_modgroup
An object of this class represent a single modification group element in quantitation....
Definition: ms_quant_modgroup.hpp:46
matrix_science::ms_quant_multiplex
An object of this class represent a multiplex element in quantitation.xml.
Definition: ms_quant_multiplex.hpp:40
matrix_science::ms_searchparams
This class encapsulates the search parameters in the Mascot results file.
Definition: ms_searchparams.hpp:47
matrix_science::ms_umod_composition
Represents the composition type in unimod.xml.
Definition: ms_umod_composition.hpp:48
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::MASS_TYPE
MASS_TYPE
All possible mass types.
Definition: ms_modfile.hpp:65
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_file_index.hpp Source File

  • inc
ms_quant_file_index.hpp
1/*
2##############################################################################
3# file: ms_quant_file_index.hpp #
4# 'msparser' toolkit #
5# Encapsulates \c correction element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_file_index.hpp $
12 * @(#)$Revision: 13df8a1acb577c00eb17a154317b079d156f9538 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2022-01-05 16:48:40 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_FILE_INDEX_HPP
18#define MS_QUANT_FILE_INDEX_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_xml_schema; // forward declaration
32
39
51 class MS_MASCOTRESFILE_API ms_quant_file_index: public ms_xml_IValidatable
52 {
53 friend class msparser_internal::ms_quant_xmlloader;
54
55 public:
57 ms_quant_file_index();
58
60 ms_quant_file_index(const ms_quant_file_index& src);
61
63 virtual ~ms_quant_file_index();
64
66 void defaultValues();
67
69 void copyFrom(const ms_quant_file_index* right);
70
71#ifndef SWIG
73 ms_quant_file_index& operator=(const ms_quant_file_index& right);
74#endif
75
77 virtual std::string getSchemaType() const;
78
80 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
81
83 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
84
85
87 bool haveFraction() const;
88
90 int getFraction() const;
91
93 void setFraction(const int value);
94
96 void dropFraction();
97
99 std::string getFractionSchemaType() const;
100
101
103 int getContent() const;
104
106 void setContent(const int fileIndex);
107
109 std::string getContentSchemaType() const;
110
112 static const int file_index_value_not_set = -1;
113
114 private:
115 int _content;
116 int _fraction;
117 bool _fraction_set;
118
119 }; // class ms_quant_file_index
120 // end of config_group
122
123} // namespace matrix_science
124
125#endif // MS_QUANT_FILE_INDEX_HPP
126
127/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_file_index
Represents a file_index element.
Definition: ms_quant_file_index.hpp:52
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_helper.hpp Source File

  • inc
ms_quant_helper.hpp
1/*
2##############################################################################
3# file: ms_quant_helper.hpp #
4# 'msparser' toolkit #
5# Helper routines for peptide and protein quantitation #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: dcreasy@matrixscience.com $ #
12# $Date: 2022-01-10 16:56:39 +0000 $ #
13# $Revision: 2dcc5a5c97c2ef1f6d52f0f45adbf5cbce43ce2e | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_QUANT_HELPER_HPP
19#define MS_QUANT_HELPER_HPP
20
21
22#include <string>
23#include <vector>
24#include <list>
25
26namespace msparser_internal {
27 typedef std::pair<char, int> modification_site_t;
28 typedef std::vector<modification_site_t> modification_sites_t;
29 typedef std::map<std::string, char> varmod_title_map_t;
30}
31
32namespace matrix_science {
33 class ms_quant_method;
34 class ms_quant_localdef;
35 class ms_quant_unmodified;
36 class ms_peptide;
37 class ms_peptidesummary;
38 class ms_protein;
39 class ms_ms1quant_match;
40
47
49 class MS_MASCOTRESFILE_API ms_quant_helper: public ms_errors
50 {
51 public:
53 enum PEPTIDE_QUANTIFIABILITY {
54 PEPTIDE_IS_QUANTIFIABLE = 0x0000,
55 PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD = 0x0001,
56 PEPTIDE_HAS_NO_REQUIRED_VARMOD = 0x0002,
57 PEPTIDE_HAS_EXCLUDED_FIXEDMOD = 0x0010,
58 PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD = 0x0011,
59 PEPTIDE_HAS_EXCLUDED_VARMOD = 0x0012,
60 PEPTIDE_HAS_UNMODIFIED_SITE = 0x0013,
61 PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD = 0x0014,
62 PEPTIDE_HAS_NO_EXCLUSIVE_MODS = 0x0015,
63
64 PEPTIDE_QUANTIFIABILITY_UNAVAILABLE = 0xf000
65 };
66
68 enum PEPTIDE_QUALITY {
69 PEPTIDE_QUALITY_IS_OK = 0x0000,
70 PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN = 0x0001,
71 PEPTIDE_SCORE_BELOW_SCORE_THR = 0x0002,
72 PEPTIDE_EXPECT_ABOVE_THRESHOLD = 0x0003,
73 PEPTIDE_SCORE_BELOW_IDENTITY_THR = 0x0004,
74 PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM = 0x0005,
75 PEPTIDE_SCORE_BELOW_HOMOLOGY_THR = 0x0006,
76 PEPTIDE_NOT_UNIQUE = 0x0007,
77
78 PEPTIDE_QUALITY_UNAVAILABLE = 0xf000
79 };
80
82 ms_quant_helper(const ms_peptidesummary &pepsum, const ms_quant_method &qm, const ms_umod_configfile &umodfile, const int file_index = ms_quant_file_index::file_index_value_not_set);
83
85 ~ms_quant_helper();
86
87 const ms_peptidesummary & getSummary() const;
88 const ms_quant_method & getMethod() const;
89#ifndef SWIG
91 int isPeptideQuantifiable(int q, int p, const ms_protein *protein, int peptideIndex, std::string & reasonStrRef) const;
92
94 int isPeptideQualityOK(int q, int p, std::string & reasonStrRef) const;
95#else // SWIG Multiple return values
96 int isPeptideQuantifiable(int q, int p, const ms_protein *protein, int peptideIndex, std::string & OUTPUT) const;
97 int isPeptideQualityOK(int q, int p, std::string & OUTPUT) const;
98#endif
100 int testProteinTerminusExclusion(int q, int p, const ms_protein *, int peptideIndex, std::string & reason) const;
101
103 int createMissingComponents(matrix_science::ms_ms1quant_match * match) const;
104
105 // For a given file_index (1..num raw files), return the fraction
106 int getFraction(const int file_index) const;
107
108 matrix_science::ms_ms1quant_peptide_status::peptideStatus group_peptide(
109 const matrix_science::ms_protein & hit,
110 int iPeptide,
111 matrix_science::ms_peptide *& peptide,
112 matrix_science::ms_quant_component & component,
113 matrix_science::ms_quant_helper::PEPTIDE_QUANTIFIABILITY * quantifiabilityStatus = 0,
114 matrix_science::ms_quant_helper::PEPTIDE_QUALITY * qualityStatus = 0,
115 matrix_science::ms_mascotresults::QUANT_COMPONENT_STATUS * componentStatus = 0,
116 std::string * reason = 0 ) const;
117
118 matrix_science::ms_ms1quant_peptide_status::peptideStatus group_peptide(
119 const matrix_science::ms_peptide & peptide,
120 matrix_science::ms_quant_component & component,
121 matrix_science::ms_quant_helper::PEPTIDE_QUANTIFIABILITY * quantifiabilityStatus = 0,
122 matrix_science::ms_quant_helper::PEPTIDE_QUALITY * qualityStatus = 0,
123 matrix_science::ms_mascotresults::QUANT_COMPONENT_STATUS * componentStatus = 0,
124 std::string * reason = 0,
125 const matrix_science::ms_protein * hit = 0,
126 int iPeptide = 0
127 ) const;
128
129 private:
130 // No copying.
131 ms_quant_helper(const ms_quant_helper& src);
132 ms_quant_helper& operator=(const ms_quant_helper& right);
133
134 void applyComponentMods(
135 std::string * newVarMods,
136 std::string * newSummedMods,
137 const matrix_science::ms_quant_component & targetComponent,
138 const std::string & pepStr,
139 const std::string & labelFreeVarMods,
140 bool isProteinNterm,
141 bool isProteinCterm
142 ) const;
143
144 void applyComponentMods(
145 std::string * newVarMods,
146 std::string * newSummedMods,
147 const matrix_science::ms_quant_component & targetComponent,
148 const matrix_science::ms_quant_component & sourceComponent,
149 const std::string & pepStr,
150 const std::string & labelFreeVarMods,
151 const std::string & sourceVarMods,
152 const std::string & sourceSummedMods,
153 bool isProteinNterm,
154 bool isProteinCterm
155 ) const;
156
157 char ModLetter(const std::string & modName) const;
158
159 const ms_peptidesummary &pepsum_;
160 const ms_quant_method &method_;
161 const ms_umod_configfile & umodfile_;
162 const int this_file_index_;
163 std::map<int, int> indexToFraction_;
164
165 std::map<char, std::string> varModTitles_;
166 std::map<char, std::string> fixedModTitles_;
167
168 bool haveRequiredMods_;
169 std::string sortedRequiredFixedMods_;
170 std::string sortedRequiredVarMods_;
171
172 bool haveExclusions_;
173 bool haveProteinTerminusTest_;
174
175 bool initRequiredMods(const ms_quant_modgroup *modgroup, const ms_umod_configfile &umodfile, const msparser_internal::varmod_title_map_t &varmod_title_map, std::set<char> &requiredFixedMods, std::set<char> &requiredVarMods);
176 bool initFixedExclusion(const ms_quant_modgroup *modgroup, const ms_umod_configfile &umodfile);
177
178 int testRequiredMods(const std::string &peptide_str, const std::string &varmods_str, std::string & reason) const;
179
180 int testFixedExclusions(const std::string &peptide_str, const std::string &varmods_str, const ms_protein *protein, int peptideIndex, std::string & reason) const;
181 int testVariableExclusions(const std::string &peptide_str, const std::string &varmods_str, const ms_protein *protein, int peptideIndex, std::string & reason) const;
182
183 bool requireUniquePeptide_;
184 int minPrecursorCharge_;
185 double ionsScoreThreshold_;
186 double expectationValueThreshold_;
187 bool mustPassIdentityThreshold_;
188 bool mustPassHomologyThreshold_;
189 bool isAverageProtocol_;
190
191//Warning 325: Nested struct not currently supported
192#ifndef SWIG
193 typedef struct {
194 int why;
195 std::string fmt;
196 msparser_internal::modification_sites_t modsites;
197 } fixed_exclusion_t;
198
199 typedef struct {
200 int why;
201 std::string fmt;
202 char varmod_id;
203 msparser_internal::modification_sites_t modsites;
204 } variable_exclusion_t;
205
206 std::list<fixed_exclusion_t> fixedExclusions_;
207 std::list<variable_exclusion_t> variableExclusions_;
208
209 std::list< std::list<variable_exclusion_t> > qualityExclusions_;
210
211 bool initVariableExclusion(const ms_quant_modgroup *modgroup, const ms_umod_configfile &umodfile, const msparser_internal::varmod_title_map_t &varmod_title_map, std::list<variable_exclusion_t> &variableExclusions);
212#endif
213
214 bool peptideFitsExclusiveGroup(const std::string &peptide_str, const std::string &varmods_str) const;
215 bool peptideFitsExclusiveGroupMods(const std::string &peptide_str, const std::string &varmods_str, const std::list<variable_exclusion_t> &qualityExclusions) const;
216
217 static bool mod_can_be_fixed(char site, int position);
218 static bool excluded_due_to_fixed_mod(const std::string &peptide_str, char site, int position);
219 static bool excluded_due_to_variable_mod(const std::string &peptide_str, const std::string &varmods_str, char site, int position, char varmod_id, const ms_protein *protein, int peptideIndex);
220
221 }; // end of quantitation_group
223} // matrix_science namespace
224
225#endif // MS_QUANT_HELPER_HPP
226
227/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_mascotresults::QUANT_COMPONENT_STATUS
QUANT_COMPONENT_STATUS
Return codes for getQuantitationComponentForPeptide().
Definition: ms_mascotresults.hpp:279
matrix_science::ms_ms1quant_match
A peptide that has been matched, in quantitation, to a protein hit.
Definition: ms_ms1quant_match.hpp:47
matrix_science::ms_ms1quant_peptide_status::peptideStatus
peptideStatus
Status codes from fitting peptides.
Definition: ms_ms1quant_peptide_status.hpp:48
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_helper
Helper routines for peptide quantitation.
Definition: ms_quant_helper.hpp:50
matrix_science::ms_quant_helper::PEPTIDE_QUANTIFIABILITY
PEPTIDE_QUANTIFIABILITY
Possible reasons a peptide is not quantifiable using a given quantitation method.
Definition: ms_quant_helper.hpp:53
matrix_science::ms_quant_helper::PEPTIDE_QUALITY
PEPTIDE_QUALITY
Possible reasons why a peptide does not pass quality tests using a given quantitation method.
Definition: ms_quant_helper.hpp:68
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_quant_modgroup
An object of this class represent a single modification group element in quantitation....
Definition: ms_quant_modgroup.hpp:46
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_integration.hpp Source File

  • inc
ms_quant_integration.hpp
1/*
2##############################################################################
3# file: ms_quant_integration.hpp #
4# 'msparser' toolkit #
5# Encapsulates integration-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_integration.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_INTEGRATION_HPP
18#define MS_QUANT_INTEGRATION_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27 class ms_quant_integration_impl;
28}
29
30
31namespace matrix_science {
32
33 class ms_xml_schema; // forward declaration
34
41
45 class MS_MASCOTRESFILE_API ms_quant_integration: public ms_quant_parameters
46 {
47 friend class msparser_internal::ms_quant_xmlloader;
48 public:
50 ms_quant_integration();
51
53 ms_quant_integration(const ms_quant_integration& src);
54
56 virtual ~ms_quant_integration();
57
59 void defaultValues();
60
62 void copyFrom(const ms_quant_integration* right);
63
64#ifndef SWIG
66 ms_quant_integration& operator=(const ms_quant_integration& right);
67#endif
69 virtual std::string getSchemaType() const;
70
72 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
73
75 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
76
77
79 bool haveMethod() const;
80
82 std::string getMethod() const;
83
85 void setMethod(const char* value);
86
88 void dropMethod();
89
91 std::string getMethodSchemaType() const;
92
93
95 bool haveSource() const;
96
98 std::string getSource() const;
99
101 void setSource(const char* value);
102
104 void dropSource();
105
107 std::string getSourceSchemaType() const;
108
109
111 bool haveMassDelta() const;
112
114 std::string getMassDelta() const;
115
117 void setMassDelta(const char* value);
118
120 void dropMassDelta();
121
123 std::string getMassDeltaSchemaType() const;
124
125
127 bool haveMassDeltaUnit() const;
128
130 std::string getMassDeltaUnit() const;
131
133 void setMassDeltaUnit(const char* value);
134
136 void dropMassDeltaUnit();
137
139 std::string getMassDeltaUnitSchemaType() const;
140
141
143 bool haveElutionTimeDelta() const;
144
146 std::string getElutionTimeDelta() const;
147
149 void setElutionTimeDelta(const char* value);
150
152 void dropElutionTimeDelta();
153
155 std::string getElutionTimeDeltaSchemaType() const;
156
157
159 bool haveElutionTimeDeltaUnit() const;
160
162 std::string getElutionTimeDeltaUnit() const;
163
165 void setElutionTimeDeltaUnit(const char* value);
166
168 void dropElutionTimeDeltaUnit();
169
171 std::string getElutionTimeDeltaUnitSchemaType() const;
172
173
175 bool haveElutionProfileCorrelationThreshold() const;
176
178 std::string getElutionProfileCorrelationThreshold() const;
179
181 void setElutionProfileCorrelationThreshold(const char* value);
182
184 void dropElutionProfileCorrelationThreshold();
185
187 std::string getElutionProfileCorrelationThresholdSchemaType() const;
188
189
191 bool haveProcessingOptions() const;
192
194 std::string getProcessingOptions() const;
195
197 void setProcessingOptions(const std::string value);
198
200 void dropProcessingOptions();
201
203 std::string getProcessingOptionsSchemaType() const;
204
205
207 bool havePrecursorRange() const;
208
210 std::string getPrecursorRange() const;
211
213 void setPrecursorRange(const char* value);
214
216 void dropPrecursorRange();
217
219 std::string getPrecursorRangeSchemaType() const;
220
221
223 bool haveMatchedRho() const;
224
226 std::string getMatchedRho() const;
227
229 void setMatchedRho(const char * value);
230
232 void dropMatchedRho();
233
235 std::string getMatchedRhoSchemaType() const;
236
237
239 bool haveXicThreshold() const;
240
242 std::string getXicThreshold() const;
243
245 void setXicThreshold(const char * value);
246
248 void dropXicThreshold();
249
251 std::string getXicThresholdSchemaType() const;
252
253
255 bool haveXicMaxWidth() const;
256
258 int getXicMaxWidth() const;
259
261 void setXicMaxWidth(int value);
262
264 void dropXicMaxWidth();
265
267 std::string getXicMaxWidthSchemaType() const;
268
269
271 bool haveXicSmoothing() const;
272
274 int getXicSmoothing() const;
275
277 void setXicSmoothing(int value);
278
280 void dropXicSmoothing();
281
283 std::string getXicSmoothingSchemaType() const;
284
285
287 bool haveAllChargeStates() const;
288
290 bool isAllChargeStates() const;
291
293 void setAllChargeStates(const bool value);
294
296 void dropAllChargeStates();
297
299 std::string getAllChargeStatesSchemaType() const;
300
301
303 bool haveSimpleRatio() const;
304
306 bool isSimpleRatio() const;
307
309 void setSimpleRatio(const bool value);
310
312 void dropSimpleRatio();
313
315 std::string getSimpleRatioSchemaType() const;
316
317
319 bool haveAllChargeStatesThreshold() const;
320
322 std::string getAllChargeStatesThreshold() const;
323
325 void setAllChargeStatesThreshold(const char * value);
326
328 void dropAllChargeStatesThreshold();
329
331 std::string getAllChargeStatesThresholdSchemaType() const;
332
333
335 bool haveAllowElutionShift() const;
336
338 bool isAllowElutionShift() const;
339
341 void setAllowElutionShift(const bool value);
342
344 void dropAllowElutionShift();
345
347 std::string getAllowElutionShiftSchemaType() const;
348
349 private:
350 msparser_internal::ms_quant_integration_impl *m_pImpl;
351 }; // class ms_quant_integration
352 // end of config_group
354
355} // namespace matrix_science
356
357#endif // MS_QUANT_INTEGRATION_HPP
358
359/*------------------------------- End of File -------------------------------*/
360
matrix_science::ms_quant_integration
An object of this class represent a single integration element in quantitation.xml.
Definition: ms_quant_integration.hpp:46
matrix_science::ms_quant_parameters
A class that represents base parametersType in quantitation.xml.
Definition: ms_quant_parameters.hpp:82
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_isotope.hpp Source File

  • inc
ms_quant_isotope.hpp
1/*
2##############################################################################
3# file: ms_quant_isotope.hpp #
4# 'msparser' toolkit #
5# Encapsulates \c isotope element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_isotope.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_ISOTOPE_HPP
18#define MS_QUANT_ISOTOPE_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_xml_schema; // forward declaration
32
39 class MS_MASCOTRESFILE_API ms_quant_isotope: public ms_xml_IValidatable
40 {
41 friend class msparser_internal::ms_quant_xmlloader;
42
43 public:
45 ms_quant_isotope();
46
48 ms_quant_isotope(const ms_quant_isotope& src);
49
51 virtual ~ms_quant_isotope();
52
54 void defaultValues();
55
57 void copyFrom(const ms_quant_isotope* right);
58
59#ifndef SWIG
61 ms_quant_isotope& operator=(const ms_quant_isotope& right);
62#endif
63
65 virtual std::string getSchemaType() const;
66
68 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
69
71 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
72
73
75 bool haveOld() const;
76
78 std::string getOld() const;
79
81 void setOld(const char* value);
82
84 void dropOld();
85
87 std::string getOldSchemaType() const;
88
89
91 bool haveNew() const;
92
94 std::string getNew() const;
95
97 void setNew(const char* value);
98
100 void dropNew();
101
103 std::string getNewSchemaType() const;
104
105 private:
106
107 std::string _old;
108 bool _old_set;
109
110 std::string _new;
111 bool _new_set;
112
113 }; // class ms_quant_isotope
114 // end of config_group
116
117} // namespace matrix_science
118
119#endif // MS_QUANT_ISOTOPE_HPP
120
121/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_isotope
Represents an isotope element.
Definition: ms_quant_isotope.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_localdef.hpp Source File

  • inc
ms_quant_localdef.hpp
1/*
2##############################################################################
3# file: ms_quant_localdef.hpp #
4# 'msparser' toolkit #
5# Encapsulates \c local_definition element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_localdef.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_LOCALDEF_HPP
18#define MS_QUANT_LOCALDEF_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_quant_specificity; // forward declaration
32 class ms_quant_composition; // forward declaration
33 class ms_xml_schema; // forward declaration
34
41 class MS_MASCOTRESFILE_API ms_quant_localdef: public ms_xml_IValidatable
42 {
43 friend class msparser_internal::ms_quant_xmlloader;
44
45 public:
47 ms_quant_localdef();
48
50 ms_quant_localdef(const ms_quant_localdef& src);
51
53 virtual ~ms_quant_localdef();
54
56 void defaultValues();
57
59 void copyFrom(const ms_quant_localdef* right);
60
61#ifndef SWIG
63 ms_quant_localdef& operator=(const ms_quant_localdef& right);
64#endif
66 virtual std::string getSchemaType() const;
67
69 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
70
72 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
73
74
76 int getNumberOfSpecificities() const;
77
79 void clearSpecificities();
80
82 void appendSpecificity(const ms_quant_specificity *specificity);
83
85 const ms_quant_specificity * getSpecificity(const int idx) const;
86
88 bool updateSpecificity(const int idx, const ms_quant_specificity* specificity);
89
91 bool deleteSpecificity(const int idx);
92
94 std::string getSpecificitySchemaType() const;
95
96
98 bool haveDelta() const;
99
101 const ms_quant_composition* getDelta() const;
102
104 void setDelta(const ms_quant_composition *delta);
105
107 void dropDelta();
108
110 std::string getDeltaSchemaType() const;
111
112
114 int getNumberOfIgnores() const;
115
117 void clearIgnores();
118
120 void appendIgnore(const ms_quant_composition *ignore);
121
123 const ms_quant_composition * getIgnore(const int idx) const;
124
126 bool updateIgnore(const int idx, const ms_quant_composition* ignore);
127
129 bool deleteIgnore(const int idx);
130
132 std::string getIgnoreSchemaType() const;
133
134
136 bool haveTitle() const;
137
139 std::string getTitle() const;
140
142 void setTitle(const char* value);
143
145 void dropTitle();
146
148 std::string getTitleSchemaType() const;
149
150
151 private:
152 // elements
153 typedef std::vector< ms_quant_specificity* > specificity_vector;
154 specificity_vector _specificities;
155
156 ms_quant_composition* _pDelta;
157 bool _delta_set;
158
159 typedef std::vector< ms_quant_composition* > composition_vector;
160 composition_vector _ignores;
161
162 // attributes
163 std::string _title;
164 bool _title_set;
165
166 }; // class ms_quant_localdef
167 // end of config_group
169
170} // namespace matrix_science
171
172#endif // MS_QUANT_LOCALDEF_HPP
173
174/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_composition
Describes the compositionType type in quantitation.xml.
Definition: ms_quant_composition.hpp:120
matrix_science::ms_quant_localdef
Represents a local_definition element.
Definition: ms_quant_localdef.hpp:42
matrix_science::ms_quant_specificity
Describes a specificity element in quantitation.xml (Unimod style specificity).
Definition: ms_quant_specificity.hpp:45
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_method.hpp Source File

  • inc
ms_quant_method.hpp
1/*
2##############################################################################
3# file: ms_quant_method.hpp #
4# 'msparser' toolkit #
5# Encapsulates method-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_method.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_METHOD_HPP
18#define MS_QUANT_METHOD_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27 class ms_quant_method_impl;
28 class ms_quant_configfile_impl;
29}
30
31namespace matrix_science {
32
33 class ms_quant_modgroup; // forward declaration
34 class ms_quant_component; // forward declaration
35 class ms_quant_quality; // forward declaration
36 class ms_quant_integration; // forward delcaration
37 class ms_quant_outliers; // forward declaration
38 class ms_quant_normalisation; // forward declaration
39 class ms_quant_protocol; // forward declaration
40 class ms_quant_ratio; // forward declaration
41 class ms_xml_schema; // forward declaration
42 class ms_quant_localdef; // forward declaration
43
50 class MS_MASCOTRESFILE_API ms_quant_method: public ms_xml_IValidatable
51 {
52 friend class msparser_internal::ms_quant_xmlloader;
53 friend class msparser_internal::ms_quant_configfile_impl;
54
55 public:
57
63 enum METHOD_COMPATIBLE{
64 COMPATIBLE,
65 COMPATIBLE_DIFF_PROTOCOL,
66 COMPATIBLE_DIFF_NUM_COMPONENTS,
67 COMPATIBLE_MISSING_COMPONENT,
68 COMPATIBLE_DIFF_NUM_MOD_GROUPS,
69 COMPATIBLE_MISSING_MOD_GROUP,
70 COMPATIBLE_DIFF_NUM_LOCAL_MODS,
71 COMPATIBLE_DIFF_LOCAL_MOD,
72 COMPATIBLE_DIFF_NUM_MODS,
73 COMPATIBLE_MISSING_MOD,
74 COMPATIBLE_MISSING_INTEGRATION,
75 COMPATIBLE_MISSING_INTEGRATION_PARAM,
76 COMPATIBLE_DIFF_INTEGRATION_PARAM,
77 COMPATIBLE_DIFF_NUM_ISOTOPES
78 };
79
81 ms_quant_method();
82
84 ms_quant_method(const ms_quant_method& src);
85
87 virtual ~ms_quant_method();
88
90 void defaultValues();
91
93 void copyFrom(const ms_quant_method* right);
94
95#ifndef SWIG
97 ms_quant_method& operator=(const ms_quant_method& right);
98#endif
100 virtual std::string getSchemaType() const;
101
103 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
104
106 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
107
108
110 int getNumberOfModificationGroups() const;
111
113 void clearModificationGroups();
114
116 void appendModificationGroup(const ms_quant_modgroup *item);
117
119 const ms_quant_modgroup * getModificationGroupByNumber(const int idx) const;
120
122 const ms_quant_modgroup * getModificationGroupByName(const char *name) const;
123
125 bool updateModificationGroupByNumber(const int idx, const ms_quant_modgroup* modgroup);
126
128 bool updateModificationGroupByName(const char *name, const ms_quant_modgroup* modgroup);
129
131 bool deleteModificationGroupByNumber(const int idx);
132
134 bool deleteModificationGroupByName(const char *name);
135
137 std::string getModificationGroupSchemaType() const;
138
140 void getLocalModifications(std::vector<const ms_quant_localdef *> &localDefVector);
141
143 int getNumberOfComponents() const;
144
146 void clearComponents();
147
149 void appendComponent(const ms_quant_component *item);
150
152 const ms_quant_component * getComponentByNumber(const int idx) const;
153
155 const ms_quant_component * getComponentByName(const char *name) const;
156
158 bool updateComponentByNumber(const int idx, const ms_quant_component* comp);
159
161 bool updateComponentByName(const char *name, const ms_quant_component* comp);
162
164 bool deleteComponentByNumber(const int idx);
165
167 bool deleteComponentByName(const char *name);
168
170 std::string getComponentSchemaType() const;
171
172
174 int getNumberOfReportRatios() const;
175
177 void clearReportRatios();
178
180 void appendReportRatio(const ms_quant_ratio *ratio);
181
183 const ms_quant_ratio * getReportRatioByNumber(const int idx) const;
184
186 const ms_quant_ratio * getReportRatioByName(const char *name) const;
187
189 bool updateReportRatioByNumber(const int idx, const ms_quant_ratio* ratio);
190
192 bool updateReportRatioByName(const char *name, const ms_quant_ratio* ratio);
193
195 bool deleteReportRatioByNumber(const int idx);
196
198 bool deleteReportRatioByName(const char *name);
199
201 std::string getReportRatioSchemaType() const;
202
203
205 int getNumberOfExclusions() const;
206
208 void clearExclusions();
209
211 void appendExclusion(const char* exclusion);
212
214 std::string getExclusion(const int idx) const;
215
217 bool updateExclusion(const int idx, const char* exclusion);
218
220 bool deleteExclusion(const int idx);
221
223 std::string getExclusionSchemaType() const;
224
225
227 int getNumberOfSeqs() const;
228
230 void clearSeqs();
231
233 void appendSeq(const char* seq);
234
236 std::string getSeq(const int idx) const;
237
239 bool updateSeq(const int idx, const char* seq);
240
242 bool deleteSeq(const int idx);
243
245 std::string getSeqSchemaType() const;
246
247
249 bool haveComp() const;
250
252 std::string getComp() const;
253
255 void setComp(const char* value);
256
258 void dropComp();
259
261 std::string getCompSchemaType() const;
262
263
265 bool haveQuality() const;
266
268 const ms_quant_quality* getQuality() const;
269
271 void setQuality(const ms_quant_quality* quality);
272
274 void dropQuality();
275
277 std::string getQualitySchemaType() const;
278
279
281 bool haveIntegration() const;
282
284 const ms_quant_integration* getIntegration() const;
285
287 void setIntegration(const ms_quant_integration* integration);
288
290 void dropIntegration();
291
293 std::string getIntegrationSchemaType() const;
294
295
297 bool haveOutliers() const;
298
300 const ms_quant_outliers* getOutliers() const;
301
303 void setOutliers(const ms_quant_outliers* outliers);
304
306 void dropOutliers();
307
309 std::string getOutliersSchemaType() const;
310
311
313 bool haveNormalisation() const;
314
316 const ms_quant_normalisation* getNormalisation() const;
317
319 void setNormalisation(const ms_quant_normalisation* normalisation);
320
322 void dropNormalisation();
323
325 std::string getNormalisationSchemaType() const;
326
327
329 bool haveProtocol() const;
330
332 const ms_quant_protocol* getProtocol() const;
333
335 void setProtocol(const ms_quant_protocol* protocol);
336
338 void dropProtocol();
339
341 std::string getProtocolSchemaType() const;
342
343
345 bool haveName() const;
346
348 std::string getName() const;
349
351 void setName(const char* value);
352
354 void dropName();
355
357 std::string getNameSchemaType() const;
358
359
361 bool haveDescription() const;
362
364 std::string getDescription() const;
365
367 void setDescription(const char* value);
368
370 void dropDescription();
371
373 std::string getDescriptionSchemaType() const;
374
375
377 bool haveConstrainSearch() const;
378
380 bool isConstrainSearch() const;
381
383 void setConstrainSearch(const bool value);
384
386 void dropConstrainSearch();
387
389 std::string getConstrainSearchSchemaType() const;
390
391
393 bool haveProteinRatioType() const;
394
396 std::string getProteinRatioType() const;
397
399 void setProteinRatioType(const char* value);
400
402 void dropProteinRatioType();
403
405 std::string getProteinRatioTypeSchemaType() const;
406
407
409 bool haveReportDetail() const;
410
412 bool isReportDetail() const;
413
415 void setReportDetail(const bool value);
416
418 void dropReportDetail();
419
421 std::string getReportDetailSchemaType() const;
422
423
425 bool haveMinNumPeptides() const;
426
428 int getMinNumPeptides() const;
429
431 void setMinNumPeptides(const int value);
432
434 void dropMinNumPeptides();
435
437 std::string getMinNumPeptidesSchemaType() const;
438
439
441 bool haveProtScoreType() const;
442
444 std::string getProtScoreType() const;
445
447 void setProtScoreType(const char* value);
448
450 void dropProtScoreType();
451
453 std::string getProtScoreTypeSchemaType() const;
454
455
457 bool haveSigThresholdValue() const;
458
460 std::string getSigThresholdValue() const;
461
463 void setSigThresholdValue(const char* value);
464
466 void dropSigThresholdValue();
467
469 std::string getSigThresholdValueSchemaType() const;
470
471
473 bool haveShowSubSets() const;
474
476 std::string getShowSubSets() const;
477
479 void setShowSubSets(const char* value);
480
482 void dropShowSubSets();
483
485 std::string getShowSubSetsSchemaType() const;
486
487
489 bool haveRequireBoldRed() const;
490
492 bool isRequireBoldRed() const;
493
495 void setRequireBoldRed(const bool value);
496
498 void dropRequireBoldRed();
499
501 std::string getRequireBoldRedSchemaType() const;
502#ifndef SWIG
504 int isMethodCompatible(const ms_quant_method &other, std::string & reasonStrRef) const;
505#else // SWIG Multiple return values
506 int isMethodCompatible(const ms_quant_method &other, std::string & OUTPUT) const;
507#endif
508 private:
509 msparser_internal::ms_quant_method_impl * m_pImpl;
510 }; // class ms_quant_method
511 // end of config_group
513
514} // namespace matrix_science
515
516#endif // MS_QUANT_METHOD_HPP
517
518/*------------------------------- End of File -------------------------------*/
519
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_integration
An object of this class represent a single integration element in quantitation.xml.
Definition: ms_quant_integration.hpp:46
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_quant_method::METHOD_COMPATIBLE
METHOD_COMPATIBLE
Enum used by isMethodCompatible()
Definition: ms_quant_method.hpp:63
matrix_science::ms_quant_method::COMPATIBLE_DIFF_NUM_LOCAL_MODS
@ COMPATIBLE_DIFF_NUM_LOCAL_MODS
Methods 'x' and 'y' are incompatible: Different number of local modification definitions ('mg1' and '...
Definition: ms_quant_method.hpp:70
matrix_science::ms_quant_method::COMPATIBLE_MISSING_INTEGRATION
@ COMPATIBLE_MISSING_INTEGRATION
Methods 'x' and 'y' are incompatible: One method has integration parameters and the other has none.
Definition: ms_quant_method.hpp:74
matrix_science::ms_quant_method::COMPATIBLE_MISSING_INTEGRATION_PARAM
@ COMPATIBLE_MISSING_INTEGRATION_PARAM
Methods 'x' and 'y' are incompatible: "Method 'x' has integration parameter 'p' but method 'y' does n...
Definition: ms_quant_method.hpp:75
matrix_science::ms_quant_method::COMPATIBLE_DIFF_NUM_COMPONENTS
@ COMPATIBLE_DIFF_NUM_COMPONENTS
Methods 'x' and 'y' are incompatible: Different number of components ('c1' and 'c2').
Definition: ms_quant_method.hpp:66
matrix_science::ms_quant_method::COMPATIBLE_MISSING_MOD
@ COMPATIBLE_MISSING_MOD
Methods 'x' and 'y' are incompatible: Modification 'mod' is missing from modification group 'mg'.
Definition: ms_quant_method.hpp:73
matrix_science::ms_quant_method::COMPATIBLE_MISSING_COMPONENT
@ COMPATIBLE_MISSING_COMPONENT
Methods 'x' and 'y' are incompatible: Component 'c1' is missing from method 'y'.
Definition: ms_quant_method.hpp:67
matrix_science::ms_quant_method::COMPATIBLE_DIFF_NUM_MODS
@ COMPATIBLE_DIFF_NUM_MODS
Methods 'x' and 'y' are incompatible: Different number of modifications ('mg1' and 'mg2') for modific...
Definition: ms_quant_method.hpp:72
matrix_science::ms_quant_method::COMPATIBLE_DIFF_PROTOCOL
@ COMPATIBLE_DIFF_PROTOCOL
Methods 'x' and 'y' are incompatible: Different protocols ('p1' and 'p2') for the methods.
Definition: ms_quant_method.hpp:65
matrix_science::ms_quant_method::COMPATIBLE
@ COMPATIBLE
Methods are compatible.
Definition: ms_quant_method.hpp:64
matrix_science::ms_quant_method::COMPATIBLE_DIFF_LOCAL_MOD
@ COMPATIBLE_DIFF_LOCAL_MOD
Methods 'x' and 'y' are incompatible: Local modification 'lm' definition differs.
Definition: ms_quant_method.hpp:71
matrix_science::ms_quant_method::COMPATIBLE_DIFF_NUM_MOD_GROUPS
@ COMPATIBLE_DIFF_NUM_MOD_GROUPS
Methods 'x' and 'y' are incompatible: Different number of modification groups ('mg1' and 'mg2') for c...
Definition: ms_quant_method.hpp:68
matrix_science::ms_quant_method::COMPATIBLE_MISSING_MOD_GROUP
@ COMPATIBLE_MISSING_MOD_GROUP
Methods 'x' and 'y' are incompatible: Modification group mg is missing from component 'c'.
Definition: ms_quant_method.hpp:69
matrix_science::ms_quant_method::COMPATIBLE_DIFF_INTEGRATION_PARAM
@ COMPATIBLE_DIFF_INTEGRATION_PARAM
Methods 'x' and 'y' are incompatible: Method 'x' has integration parameter 'p1'='v1' but method 'y' h...
Definition: ms_quant_method.hpp:76
matrix_science::ms_quant_modgroup
An object of this class represent a single modification group element in quantitation....
Definition: ms_quant_modgroup.hpp:46
matrix_science::ms_quant_normalisation
An object of this class represent a single normalisation element in quantitation.xml.
Definition: ms_quant_normalisation.hpp:42
matrix_science::ms_quant_outliers
An object of this class represent a single OUTLIERS element in quantitation.xml.
Definition: ms_quant_outliers.hpp:44
matrix_science::ms_quant_protocol
An object of this class represent a protocol element in quantitation.xml.
Definition: ms_quant_protocol.hpp:55
matrix_science::ms_quant_quality
An object of this class represent a single quality element in quantitation.xml.
Definition: ms_quant_quality.hpp:40
matrix_science::ms_quant_ratio
Represents the ratioType type for the report_ratio element in quantitation.xml.
Definition: ms_quant_ratio.hpp:41
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_mod_parsing.hpp Source File

  • src
  • tools
ms_quant_mod_parsing.hpp
1/*
2##############################################################################
3# file: ms_quant_mod_parsing.hpp #
4# 'msparser' toolkit #
5# Helper routines for parsing modification specificities #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author$ #
12# $Date$ #
13# $Revision$ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_QUANT_MOD_PARSING_HPP
19#define MS_QUANT_MOD_PARSING_HPP
20
21#include <string>
22#include <vector>
23#include <utility>
24
25namespace matrix_science {
26 class ms_quant_localdef;
27 class ms_quant_unmodified;
28}
29
30namespace msparser_internal {
31 using namespace matrix_science;
32
33 typedef std::pair<char, int> modification_site_t;
34 typedef std::vector<modification_site_t> modification_sites_t;
35 typedef std::map<std::string, char> varmod_title_map_t;
36
37 // These are '0' and '1' so that we can use them with 'A'..'Z'.
38 enum SITE_SPECIAL { SITE_NTERM = '0', SITE_CTERM = '1' };
39
40 enum MOD_POSITION {
41 MOD_POSITION_ANYWHERE = 0x0000,
42
43 MOD_POSITION_ANY_NTERM = 0x0001,
44 MOD_POSITION_PROTEIN_NTERM = 0x0002,
45 MOD_POSITION_NTERM_MASK = 0x000F,
46
47 MOD_POSITION_ANY_CTERM = 0x0010,
48 MOD_POSITION_PROTEIN_CTERM = 0x0020,
49 MOD_POSITION_CTERM_MASK = 0x00F0,
50
51 MOD_POSITION_PROTEIN_MASK = 0x0022
52 };
53
54 namespace ms_quant_mod_parsing {
55 void addLocalDefinitions(const ms_quant_method &qm, ms_umod_configfile &umodfile);
56
57 bool parse_localdef_modification_sites(const ms_quant_localdef *def, modification_sites_t &modsites);
58 bool parse_umod_modification_sites(const ms_umod_modification *def, modification_sites_t &modsites);
59 bool parse_modfile_style_sites(const ms_modification &mod, modification_sites_t &modsites);
60 bool parse_unmodified_sites(const ms_quant_unmodified *def, modification_sites_t &modsites);
61
62 bool parse_mod_site_str(std::string str, std::string &sites);
63
64 bool parse_mod_position_str(std::string str, int *position);
65 std::string mod_position_to_str(int position);
66
67 varmod_title_map_t create_varmod_title_mapping(const ms_searchparams &params);
68
69 char varmod_int_to_char(int i);
70 int varmod_char_to_int(char c);
71 }
72} // msparser_internal namespace
73
74#endif // MS_QUANT_MOD_PARSING_HPP
75
76/*------------------------------- End of File -------------------------------*/
matrix_science::ms_modification
The class represents a single modification-entry in mod_file.
Definition: ms_modfile.hpp:134
matrix_science::ms_quant_localdef
Represents a local_definition element.
Definition: ms_quant_localdef.hpp:42
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_quant_unmodified
Describes an unmodified element in quantitation.xml.
Definition: ms_quant_unmodified.hpp:39
matrix_science::ms_searchparams
This class encapsulates the search parameters in the Mascot results file.
Definition: ms_searchparams.hpp:47
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_modification
Represents a modif object in unimod.xml.
Definition: ms_umod_modification.hpp:47
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_modgroup.hpp Source File

  • inc
ms_quant_modgroup.hpp
1/*
2##############################################################################
3# file: ms_quant_modgroup.hpp #
4# 'msparser' toolkit #
5# Encapsulates modification_group-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_modgroup.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_MODGROUP_HPP
18#define MS_QUANT_MODGROUP_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_quant_unmodified; // forward declaration
32 class ms_quant_localdef; // forward declaration
33 class ms_xml_schema; // forward declaration
34
41
45 class MS_MASCOTRESFILE_API ms_quant_modgroup: public ms_xml_IValidatable
46 {
47 friend class msparser_internal::ms_quant_xmlloader;
48
49 public:
51 ms_quant_modgroup();
52
54 ms_quant_modgroup(const ms_quant_modgroup& src);
55
57 virtual ~ms_quant_modgroup();
58
60 void defaultValues();
61
63 void copyFrom(const ms_quant_modgroup* right);
64
65#ifndef SWIG
67 ms_quant_modgroup& operator=(const ms_quant_modgroup& right);
68#endif
70 virtual std::string getSchemaType() const;
71
73 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
74
76 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
77
78
80 int getNumberOfModFiles() const;
81
83 void clearModFiles();
84
86 void appendModFile(const char* mod);
87
89 int findModFile(const char* mod) const;
90
92 std::string getModFile(const int idx) const;
93
95 bool deleteModFile(const int idx);
96
98 std::string getModFileSchemaType() const;
99
100
102 int getNumberOfUnmodified() const;
103
105 void clearUnmodified();
106
108 void appendUnmodified(const ms_quant_unmodified* unmodified);
109
111 const ms_quant_unmodified* getUnmodified(const int idx) const;
112
114 bool updateUnmodified(const int idx, const ms_quant_unmodified* unmodified);
115
117 bool deleteUnmodified(const int idx);
118
120 std::string getUnmodifiedSchemaType() const;
121
122
124 int getNumberOfLocalDefinitions() const;
125
127 void clearLocalDefinitions();
128
130 void appendLocalDefinition(const ms_quant_localdef* localdef);
131
133 const ms_quant_localdef* getLocalDefinition(const int idx) const;
134
136 bool updateLocalDefinition(const int idx, const ms_quant_localdef* localdef);
137
139 bool deleteLocalDefinition(const int idx);
140
142 std::string getLocalDefinitionSchemaType() const;
143
144
146 bool haveName() const;
147
149 std::string getName() const;
150
152 void setName(const char* value);
153
155 void dropName();
156
158 std::string getNameSchemaType() const;
159
160
162 bool haveMode() const;
163
165 std::string getMode() const;
166
168 void setMode(const char* value);
169
171 void dropMode();
172
174 std::string getModeSchemaType() const;
175
176
178 bool haveRequired() const;
179
181 bool isRequired() const;
182
184 void setRequired(bool value);
185
187 void dropRequired();
188
190 std::string getRequiredSchemaType() const;
191
192 private:
193
194 typedef std::vector< std::string > modfile_vector;
195 modfile_vector _modFiles;
196
197 typedef std::vector< ms_quant_unmodified* > unmodified_vector;
198 unmodified_vector _unmodified;
199
200 typedef std::vector< ms_quant_localdef* > localdef_vector;
201 localdef_vector _localdefs;
202
203 std::string _name;
204 bool _name_set;
205
206 std::string _mode;
207 bool _mode_set;
208
209 bool m_required;
210 bool m_required_set;
211
212 }; // class ms_quant_modgroup
213 // end of config_group
215
216} // namespace matrix_science
217
218#endif // MS_QUANT_MODGROUP_HPP
219
220/*------------------------------- End of File -------------------------------*/
221
matrix_science::ms_quant_localdef
Represents a local_definition element.
Definition: ms_quant_localdef.hpp:42
matrix_science::ms_quant_modgroup
An object of this class represent a single modification group element in quantitation....
Definition: ms_quant_modgroup.hpp:46
matrix_science::ms_quant_unmodified
Describes an unmodified element in quantitation.xml.
Definition: ms_quant_unmodified.hpp:39
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_moverz.hpp Source File

  • inc
ms_quant_moverz.hpp
1/*
2##############################################################################
3# file: ms_quant_moverz.hpp #
4# 'msparser' toolkit #
5# Encapsulates "moverz" element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_moverz.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_MOVERZ_HPP
18#define MS_QUANT_MOVERZ_HPP
19
20
21#include <string>
22
23// forward declarations
24namespace msparser_internal {
25 class ms_quant_xmlloader;
26}
27
28namespace matrix_science {
29
30 class ms_xml_schema; // forward declaration
31
38 class MS_MASCOTRESFILE_API ms_quant_moverz: public ms_xml_IValidatable
39 {
40 friend class msparser_internal::ms_quant_xmlloader;
41
42 public:
44 ms_quant_moverz();
45
47 ms_quant_moverz(const ms_quant_moverz& src);
48
50 virtual ~ms_quant_moverz();
51
53 void defaultValues();
54
56 void copyFrom(const ms_quant_moverz* right);
57
58#ifndef SWIG
60 ms_quant_moverz& operator=(const ms_quant_moverz& right);
61#endif
62
64 virtual std::string getSchemaType() const;
65
67 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
68
70 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
71
72
74 bool haveMonoisotopic() const;
75
77 std::string getMonoisotopic() const;
78
80 void setMonoisotopic(const char* value);
81
83 void dropMonoisotopic();
84
86 std::string getMonoisotopicSchemaType() const;
87
88
90 bool haveAverage() const;
91
93 std::string getAverage() const;
94
96 void setAverage(const char* value);
97
99 void dropAverage();
100
102 std::string getAverageSchemaType() const;
103
104 private:
105 std::string _monoisotopic;
106 bool _monoisotopic_set;
107
108 std::string _average;
109 bool _average_set;
110
111 }; // class ms_quant_moverz
112 // end of config_group
114
115} // namespace matrix_science
116
117#endif // MS_QUANT_MOVERZ_HPP
118
119/*------------------------------- End of File -------------------------------*/
120
matrix_science::ms_quant_moverz
Parameter name and value pair.
Definition: ms_quant_moverz.hpp:39
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_multiplex.hpp Source File

  • inc
ms_quant_multiplex.hpp
1/*
2##############################################################################
3# file: ms_quant_multiplex.hpp #
4# 'msparser' toolkit #
5# Encapsulates normalisation-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_multiplex.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_MULTIPLEX_HPP
18#define MS_QUANT_MULTIPLEX_HPP
19
20
21// forward declarations
22namespace msparser_internal {
23 class ms_quant_xmlloader;
24}
25
26namespace matrix_science {
27
28 class ms_xml_schema; // forward declaration
29
36
39 class MS_MASCOTRESFILE_API ms_quant_multiplex: public ms_quant_parameters
40 {
41 friend class msparser_internal::ms_quant_xmlloader;
42 public:
44 ms_quant_multiplex();
45
47 ms_quant_multiplex(const ms_quant_multiplex& src);
48
50 virtual ~ms_quant_multiplex();
51
53 void defaultValues();
54
56 void copyFrom(const ms_quant_multiplex* right);
57
58#ifndef SWIG
60 ms_quant_multiplex& operator=(const ms_quant_multiplex& right);
61#endif
63 virtual std::string getSchemaType() const;
64
66 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
67
69 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
70
71
73 bool haveIonSeries() const;
74
76 void setIonSeries(const std::string ionSeries);
77
79 void dropIonSeries();
80
82 std::string getIonSeriesSchemaType() const;
83
85 int getNumberOfIonSeries() const;
86
88 void clearIonSeries();
89
91 void appendIonSeries(const std::string ionSeries);
92
94 const std::string getIonSeries(const int idx=0) const;
95
97 bool updateIonSeries(const int idx, const std::string ionSeries);
98
100 bool deleteIonSeries(const int idx);
101
103 bool haveExcludeInternalLabel() const;
104
106 bool isExcludeInternalLabel() const;
107
109 void setExcludeInternalLabel(const bool value);
110
112 void dropExcludeInternalLabel();
113
115 std::string getExcludeInternalLabelSchemaType() const;
116
117
119 bool haveIonIntensityThreshold() const;
120
122 std::string getIonIntensityThreshold() const;
123
125 void setIonIntensityThreshold(const char* value);
126
128 void dropIonIntensityThreshold();
129
131 std::string getIonIntensityThresholdSchemaType() const;
132
133
135 bool haveExcludeIsobaricFragments() const;
136
138 bool isExcludeIsobaricFragments() const;
139
141 void setExcludeIsobaricFragments(const bool value);
142
144 void dropExcludeIsobaricFragments();
145
147 std::string getExcludeIsobaricFragmentsSchemaType() const;
148
149
151 bool haveMinIonPairs() const;
152
154 int getMinIonPairs() const;
155
157 void setMinIonPairs(const int value);
158
160 void dropMinIonPairs();
161
163 std::string getMinIonPairsSchemaType() const;
164
165 private:
166
167 typedef std::vector< std::string > string_vector;
168 string_vector _ionSeries;
169
170 bool _excludeInternalLabel;
171 bool _excludeInternalLabel_set;
172
173 std::string _ionIntensityThreshold;
174 bool _ionIntensityThreshold_set;
175
176 bool _excludeIsobaricFragments;
177 bool _excludeIsobaricFragments_set;
178
179 int _minIonPairs;
180 bool _minIonPairs_set;
181 }; // class ms_quant_multiplex
182 // end of config_group
184
185} // namespace matrix_science
186
187#endif // MS_QUANT_MULTIPLEX_HPP
188
189/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_multiplex
An object of this class represent a multiplex element in quantitation.xml.
Definition: ms_quant_multiplex.hpp:40
matrix_science::ms_quant_parameters
A class that represents base parametersType in quantitation.xml.
Definition: ms_quant_parameters.hpp:82
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_neutralloss.hpp Source File

  • inc
ms_quant_neutralloss.hpp
1/*
2##############################################################################
3# file: ms_quant_neutralloss.hpp #
4# 'msparser' toolkit #
5# Encapsulates "NeutralLoss" element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_neutralloss.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_NEUTRALLOSS_HPP
18#define MS_QUANT_NEUTRALLOSS_HPP
19
20
21// forward declarations
22namespace msparser_internal {
23 class ms_quant_xmlloader;
24}
25
26namespace matrix_science {
27
28 class ms_xml_schema; // forward declaration
29
36 class MS_MASCOTRESFILE_API ms_quant_neutralloss: public ms_quant_composition
37 {
38 friend class msparser_internal::ms_quant_xmlloader;
39 public:
41 ms_quant_neutralloss();
42
44 ms_quant_neutralloss(const ms_quant_neutralloss& src);
45
47 virtual ~ms_quant_neutralloss();
48
50 void defaultValues();
51
53 void copyFrom(const ms_quant_neutralloss* right);
54
55#ifndef SWIG
57 ms_quant_neutralloss& operator=(const ms_quant_neutralloss& right);
58#endif
60 virtual std::string getSchemaType() const;
61
63 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
64
66 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
67
68
70 bool haveFlag() const;
71
73 bool isFlag() const;
74
76 void setFlag(const bool flag);
77
79 void dropFlag();
80
82 std::string getFlagSchemaType() const;
83
84 private:
85
86 bool _flag;
87 bool _flag_set;
88
89 }; // class ms_quant_neutralloss
90 // end of config_group
92
93} // namespace matrix_science
94
95#endif // MS_QUANT_NEUTRALLOSS_HPP
96
97/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_composition
Describes the compositionType type in quantitation.xml.
Definition: ms_quant_composition.hpp:120
matrix_science::ms_quant_neutralloss
A neutral loss for the sequence ions, e.g. loss of phosphate.
Definition: ms_quant_neutralloss.hpp:37
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_normalisation.hpp Source File

  • inc
ms_quant_normalisation.hpp
1/*
2##############################################################################
3# file: ms_quant_normalisation.hpp #
4# 'msparser' toolkit #
5# Encapsulates normalisation-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_normalisation.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_NORMALISATION_HPP
18#define MS_QUANT_NORMALISATION_HPP
19
20
21// forward declarations
22namespace msparser_internal {
23 class ms_quant_xmlloader;
24}
25
26namespace matrix_science {
27
28 class ms_xml_schema; // forward declaration
29 class ms_quant_normalisation_peptides; // forward declaration
30 class ms_quant_normalisation_proteins; // forward declaration
31
38
41 class MS_MASCOTRESFILE_API ms_quant_normalisation: public ms_quant_parameters
42 {
43 friend class msparser_internal::ms_quant_xmlloader;
44
45 public:
47 ms_quant_normalisation();
48
50 ms_quant_normalisation(const ms_quant_normalisation& src);
51
53 virtual ~ms_quant_normalisation();
54
56 void defaultValues();
57
59 void copyFrom(const ms_quant_normalisation* right);
60
61#ifndef SWIG
63 ms_quant_normalisation& operator=(const ms_quant_normalisation& right);
64#endif
66 virtual std::string getSchemaType() const;
67
69 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
70
72 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
73
74
76 bool haveMethod() const;
77
79 std::string getMethod() const;
80
82 void setMethod(const char* value);
83
85 void dropMethod();
86
88 std::string getMethodSchemaType() const;
89
90
92 bool havePeptides() const;
93
95 const ms_quant_normalisation_peptides* getPeptides() const;
96
98 void setPeptides(const ms_quant_normalisation_peptides* peptides);
99
101 void dropPeptides();
102
104 std::string getPeptidesSchemaType() const;
105
106
108 bool haveProteins() const;
109
111 const ms_quant_normalisation_proteins* getProteins() const;
112
114 void setProteins(const ms_quant_normalisation_proteins* proteins);
115
117 void dropProteins();
118
120 std::string getProteinsSchemaType() const;
121
122 private:
123
124 std::string _method;
125 bool _method_set;
126
127 ms_quant_normalisation_peptides *_pPeptides;
128 bool _peptides_set;
129
130 ms_quant_normalisation_proteins *_pProteins;
131 bool _proteins_set;
132 }; // class ms_quant_normalisation
133 // end of config_group
135
136} // namespace matrix_science
137
138#endif // MS_QUANT_NORMALISATION_HPP
139
140/*------------------------------- End of File -------------------------------*/
141
matrix_science::ms_quant_normalisation_peptides
An object of this class represent a collection of peptide elements in quantitation....
Definition: ms_quant_normalisation_peptide.hpp:100
matrix_science::ms_quant_normalisation_proteins
An object of this class represent a collection of peptide elements in quantitation....
Definition: ms_quant_normalisation_protein.hpp:100
matrix_science::ms_quant_normalisation
An object of this class represent a single normalisation element in quantitation.xml.
Definition: ms_quant_normalisation.hpp:42
matrix_science::ms_quant_parameters
A class that represents base parametersType in quantitation.xml.
Definition: ms_quant_parameters.hpp:82
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_normalisation_peptide.hpp Source File

  • inc
ms_quant_normalisation_peptide.hpp
1/*
2##############################################################################
3# file: ms_quant_normalisation_peptide.hpp #
4# 'msparser' toolkit #
5# Encapsulates peptide-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2009 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_normalisation_peptide.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_NORMALISATION_PEPTIDE_HPP
18#define MS_QUANT_NORMALISATION_PEPTIDE_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_quant_modgroup; // forward declaration
32 class ms_xml_schema; // forward declaration
33
40
43 class MS_MASCOTRESFILE_API ms_quant_normalisation_peptide: public ms_xml_IValidatable
44 {
45 friend class msparser_internal::ms_quant_xmlloader;
46
47 public:
49 ms_quant_normalisation_peptide();
50
52 ms_quant_normalisation_peptide(const ms_quant_normalisation_peptide& src);
53
55 virtual ~ms_quant_normalisation_peptide();
56
58 void defaultValues();
59
61 void copyFrom(const ms_quant_normalisation_peptide* right);
62
63#ifndef SWIG
65 ms_quant_normalisation_peptide& operator=(const ms_quant_normalisation_peptide& right);
66#endif
68 virtual std::string getSchemaType() const;
69
71 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
72
74 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
75
76
78 bool haveSequence() const;
79
81 std::string getSequence() const;
82
84 void setSequence(const char * value);
85
87 void dropSequence();
88
90 std::string getSequenceSchemaType() const;
91
92 private:
93
94 std::string _sequence;
95 bool _sequence_set;
96 }; // class ms_quant_normalisation_peptide
97
99 class MS_MASCOTRESFILE_API ms_quant_normalisation_peptides: public ms_xml_IValidatable
100 {
101 friend class msparser_internal::ms_quant_xmlloader;
102
103 public:
105 ms_quant_normalisation_peptides();
106
108 ms_quant_normalisation_peptides(const ms_quant_normalisation_peptides& src);
109
111 virtual ~ms_quant_normalisation_peptides();
112
114 void defaultValues();
115
117 void copyFrom(const ms_quant_normalisation_peptides* right);
118
119#ifndef SWIG
121 ms_quant_normalisation_peptides& operator=(const ms_quant_normalisation_peptides& right);
122#endif
124 virtual std::string getSchemaType() const;
125
127 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
128
130 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
131
132
134 int getNumberOfPeptides() const;
135
137 void clearPeptides();
138
140 void appendPeptide(const ms_quant_normalisation_peptide* pep);
141
143 const ms_quant_normalisation_peptide* getPeptide(const int idx) const;
144
146 bool updatePeptide(const int idx, const ms_quant_normalisation_peptide* pep);
147
149 bool deletePeptide(const int idx);
150
152 std::string getPeptideSchemaType() const;
153
154 private:
155
156 typedef std::vector< ms_quant_normalisation_peptide* > pep_vector;
157 pep_vector _peptides;
158 }; // class ms_quant_normalisation_peptides
159 // end of config_group
161
162} // namespace matrix_science
163
164#endif // MS_QUANT_NORMALISATION_PEPTIDE_HPP
165
166/*------------------------------- End of File -------------------------------*/
167
matrix_science::ms_quant_normalisation_peptide
An object of this class represent a single peptide element in quantitation.xml.
Definition: ms_quant_normalisation_peptide.hpp:44
matrix_science::ms_quant_normalisation_peptides
An object of this class represent a collection of peptide elements in quantitation....
Definition: ms_quant_normalisation_peptide.hpp:100
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_normalisation_protein.hpp Source File

  • inc
ms_quant_normalisation_protein.hpp
1/*
2##############################################################################
3# file: ms_quant_normalisation_protein.hpp #
4# 'msparser' toolkit #
5# Encapsulates protein-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2009 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_normalisation_protein.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_NORMALISATION_PROTEIN_HPP
18#define MS_QUANT_NORMALISATION_PROTEIN_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_quant_modgroup; // forward declaration
32 class ms_xml_schema; // forward declaration
33
40
43 class MS_MASCOTRESFILE_API ms_quant_normalisation_protein: public ms_xml_IValidatable
44 {
45 friend class msparser_internal::ms_quant_xmlloader;
46
47 public:
49 ms_quant_normalisation_protein();
50
52 ms_quant_normalisation_protein(const ms_quant_normalisation_protein& src);
53
55 virtual ~ms_quant_normalisation_protein();
56
58 void defaultValues();
59
61 void copyFrom(const ms_quant_normalisation_protein* right);
62
63#ifndef SWIG
65 ms_quant_normalisation_protein& operator=(const ms_quant_normalisation_protein& right);
66#endif
68 virtual std::string getSchemaType() const;
69
71 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
72
74 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
75
76
78 bool haveAccession() const;
79
81 std::string getAccession() const;
82
84 void setAccession(const char * value);
85
87 void dropAccession();
88
90 std::string getAccessionSchemaType() const;
91
92 private:
93
94 std::string _accession;
95 bool _accession_set;
96 }; // class ms_quant_normalisation_protein
97
99 class MS_MASCOTRESFILE_API ms_quant_normalisation_proteins: public ms_xml_IValidatable
100 {
101 friend class msparser_internal::ms_quant_xmlloader;
102
103 public:
105 ms_quant_normalisation_proteins();
106
108 ms_quant_normalisation_proteins(const ms_quant_normalisation_proteins& src);
109
111 virtual ~ms_quant_normalisation_proteins();
112
114 void defaultValues();
115
117 void copyFrom(const ms_quant_normalisation_proteins* right);
118
119#ifndef SWIG
121 ms_quant_normalisation_proteins& operator=(const ms_quant_normalisation_proteins& right);
122#endif
124 virtual std::string getSchemaType() const;
125
127 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
128
130 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
131
132
134 int getNumberOfProteins() const;
135
137 void clearProteins();
138
140 void appendProtein(const ms_quant_normalisation_protein* protein);
141
143 const ms_quant_normalisation_protein* getProtein(const int idx) const;
144
146 bool updateProtein(const int idx, const ms_quant_normalisation_protein* protein);
147
149 bool deleteProtein(const int idx);
150
152 std::string getProteinSchemaType() const;
153
154 private:
155
156 typedef std::vector< ms_quant_normalisation_protein* > prot_vector;
157 prot_vector _proteins;
158 }; // class ms_quant_normalisation_proteins
159 // end of config_group
161
162} // namespace matrix_science
163
164#endif // MS_QUANT_NORMALISATION_PROTEIN_HPP
165
166/*------------------------------- End of File -------------------------------*/
167
matrix_science::ms_quant_normalisation_protein
An object of this class represent a single protein element in quantitation.xml.
Definition: ms_quant_normalisation_protein.hpp:44
matrix_science::ms_quant_normalisation_proteins
An object of this class represent a collection of peptide elements in quantitation....
Definition: ms_quant_normalisation_protein.hpp:100
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_numerator.hpp Source File

  • inc
ms_quant_numerator.hpp
1/*
2##############################################################################
3# file: ms_quant_numerator.hpp #
4# 'msparser' toolkit #
5# Encapsulates "numerator_component" and \c denominator_component elements #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_numerator.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_NUMERATOR_HPP
18#define MS_QUANT_NUMERATOR_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_xml_schema; // forward declaration
32
39 class MS_MASCOTRESFILE_API ms_quant_numerator: public ms_xml_IValidatable
40 {
41 friend class msparser_internal::ms_quant_xmlloader;
42
43 public:
45 ms_quant_numerator();
46
48 ms_quant_numerator(const ms_quant_numerator& src);
49
51 virtual ~ms_quant_numerator();
52
54 void defaultValues();
55
57 void copyFrom(const ms_quant_numerator* right);
58
59#ifndef SWIG
61 ms_quant_numerator& operator=(const ms_quant_numerator& right);
62#endif
64 virtual std::string getSchemaType() const;
65
67 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
68
70 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
71
72
74 bool haveName() const;
75
77 std::string getName() const;
78
80 void setName(const char* value);
81
83 void dropName();
84
86 std::string getNameSchemaType() const;
87
88
90 bool haveCoefficient() const;
91
93 std::string getCoefficient() const;
94
96 void setCoefficient(const char* value);
97
99 void dropCoefficient();
100
102 std::string getCoefficientSchemaType() const;
103
104
106 std::string getContent() const;
107
109 void setContent(const char* value);
110
112 std::string getContentSchemaType() const;
113
114 private:
115 std::string _name;
116 bool _name_set;
117
118 std::string _coefficient;
119 bool _coefficient_set;
120
121 std::string _value;
122
123 }; // class ms_quant_numerator
124 // end of config_group
126
127} // namespace matrix_science
128
129#endif // MS_QUANT_NUMERATOR_HPP
130
131/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_numerator
Represent numerator_component and denominator_component elements.
Definition: ms_quant_numerator.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_outliers.hpp Source File

  • inc
ms_quant_outliers.hpp
1/*
2##############################################################################
3# file: ms_quant_outliers.hpp #
4# 'msparser' toolkit #
5# Encapsulates outliers-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_outliers.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_OUTLIERS_HPP
18#define MS_QUANT_OUTLIERS_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_xml_schema; // forward declaration
32
39
43 class MS_MASCOTRESFILE_API ms_quant_outliers: public ms_quant_parameters
44 {
45 friend class msparser_internal::ms_quant_xmlloader;
46 public:
48 ms_quant_outliers();
49
51 ms_quant_outliers(const ms_quant_outliers& src);
52
54 virtual ~ms_quant_outliers();
55
57 void defaultValues();
58
60 void copyFrom(const ms_quant_outliers* right);
61
62#ifndef SWIG
64 ms_quant_outliers& operator=(const ms_quant_outliers& right);
65#endif
67 virtual std::string getSchemaType() const;
68
70 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
71
73 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
74
75
77 bool haveMethod() const;
78
80 std::string getMethod() const;
81
83 void setMethod(const char* value);
84
86 void dropMethod();
87
89 std::string getMethodSchemaType() const;
90
91 private:
92
93 std::string _method;
94 bool _method_set;
95
96 }; // class ms_quant_outliers
97 // end of config_group
99
100} // namespace matrix_science
101
102#endif // MS_QUANT_OUTLIERS_HPP
103
104/*------------------------------- End of File -------------------------------*/
105
matrix_science::ms_quant_outliers
An object of this class represent a single OUTLIERS element in quantitation.xml.
Definition: ms_quant_outliers.hpp:44
matrix_science::ms_quant_parameters
A class that represents base parametersType in quantitation.xml.
Definition: ms_quant_parameters.hpp:82
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_parameters.hpp Source File

  • inc
ms_quant_parameters.hpp
1/*
2##############################################################################
3# file: ms_quant_parameters.hpp #
4# 'msparser' toolkit #
5# Encapsulates parametersType-definition from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_parameters.hpp $
12 * @(#)$Revision: 8fee77726a13a239ca8bcf2b46212bff297db9b7 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-12-20 10:50:55 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_PARAMETERS_HPP
18#define MS_QUANT_PARAMETERS_HPP
19
20
21#include <string>
22#include <vector>
23
24namespace msparser_internal {
25 class ms_quant_xmlloader;
26}
27
28namespace matrix_science {
29 class ms_xml_schema; // forward declaration
30 class ms_xml_parameter;
31 class ms_xml_parameters;
32
39 class MS_MASCOTRESFILE_API ms_quant_parameter: public ms_xml_parameter
40 {
41 friend class msparser_internal::ms_quant_xmlloader;
42
43 public:
45 ms_quant_parameter();
46
48 ms_quant_parameter(const ms_quant_parameter& src);
49
51 virtual ~ms_quant_parameter();
52
54 void copyFrom(const ms_quant_parameter* right);
55
56#ifndef SWIG
58 ms_quant_parameter& operator=(const ms_quant_parameter& right);
59#endif
61 virtual std::string getSchemaType() const;
62
64 virtual std::string getNameSchemaType() const;
65
67 virtual std::string getDescriptionSchemaType() const;
68
70 virtual std::string getValueSchemaType() const;
71
72 protected:
73 virtual bool saveToXML_ParameterByNumber(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const;
74
75 }; // class ms_quant_parameter
76
78
81 class MS_MASCOTRESFILE_API ms_quant_parameters: public ms_xml_parameters
82 {
83 friend class msparser_internal::ms_quant_xmlloader;
84 public:
86 ms_quant_parameters();
87
89 ms_quant_parameters(const ms_quant_parameters& src);
90
92 virtual ~ms_quant_parameters();
93
95 void defaultValues();
96
98 void copyFrom(const ms_quant_parameters* right);
99
100#ifndef SWIG
102 ms_quant_parameters& operator=(const ms_quant_parameters& right);
103#endif
105 virtual std::string getSchemaType() const;
106
108 virtual int getNumberOfParameters() const;
109
111 virtual void clearParameters();
112
114 void appendParameter(const ms_quant_parameter *item);
115
117 const ms_quant_parameter * getParameterByNumber(const int idx) const;
118
120 const ms_quant_parameter * getParameterByName(const char *name) const;
121
123 bool updateParameterByNumber(const int idx, const ms_quant_parameter *param);
124
126 bool updateParameterByName(const char *name, const ms_quant_parameter *param);
127
129 virtual bool deleteParameterByNumber(const int idx);
130
132 virtual bool deleteParameterByName(const char *name);
133
135 virtual std::string getParameterSchemaType() const;
136
137 protected:
138 virtual bool saveToXML_Parameters(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const;
139
140 private:
141 typedef std::vector< ms_quant_parameter* > entries_vector;
142 entries_vector _entries;
143
144 }; // class ms_quant_parameters
145 // end of config_group
147
148} // namespace matrix_science
149
150#endif // MS_QUANT_PARAMETERS_HPP
151
152/*------------------------------- End of File -------------------------------*/
153
matrix_science::ms_quant_parameter
Parameter name and value pair.
Definition: ms_quant_parameters.hpp:40
matrix_science::ms_quant_parameters
A class that represents base parametersType in quantitation.xml.
Definition: ms_quant_parameters.hpp:82
matrix_science::ms_xml_parameter
Parameter name and value pair.
Definition: ms_xml_parameters.hpp:46
matrix_science::ms_xml_parameters
A class that represents a base parametersType.
Definition: ms_xml_parameters.hpp:140
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_pepneutralloss.hpp Source File

  • inc
ms_quant_pepneutralloss.hpp
1/*
2##############################################################################
3# file: ms_quant_pepneutralloss.hpp #
4# 'msparser' toolkit #
5# Encapsulates "PepNeutralLoss" element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_pepneutralloss.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_PEPNEUTRALLOSS_HPP
18#define MS_QUANT_PEPNEUTRALLOSS_HPP
19
20
21// forward declarations
22namespace msparser_internal {
23 class ms_quant_xmlloader;
24}
25
26namespace matrix_science {
27
28 class ms_xml_schema; // forward declaration
29
36 class MS_MASCOTRESFILE_API ms_quant_pepneutralloss: public ms_quant_composition
37 {
38 friend class msparser_internal::ms_quant_xmlloader;
39 public:
41 ms_quant_pepneutralloss();
42
44 ms_quant_pepneutralloss(const ms_quant_pepneutralloss& src);
45
47 virtual ~ms_quant_pepneutralloss();
48
50 void defaultValues();
51
53 void copyFrom(const ms_quant_pepneutralloss* right);
54
55#ifndef SWIG
57 ms_quant_pepneutralloss& operator=(const ms_quant_pepneutralloss& right);
58#endif
60 virtual std::string getSchemaType() const;
61
63 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
64
66 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
67
68
70 bool haveRequired() const;
71
73 bool isRequired() const;
74
76 void setRequired(const bool required);
77
79 void dropRequired();
80
82 std::string getRequiredSchemaType() const;
83
84 private:
85
86 bool _required;
87 bool _required_set;
88
89 }; // class ms_quant_pepneutralloss
90 // end of config_group
92
93} // namespace matrix_science
94
95#endif // MS_QUANT_NEUTRALLOSS_HPP
96
97/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_composition
Describes the compositionType type in quantitation.xml.
Definition: ms_quant_composition.hpp:120
matrix_science::ms_quant_pepneutralloss
A neutral loss from the precursor.
Definition: ms_quant_pepneutralloss.hpp:37
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_precursor.hpp Source File

  • inc
ms_quant_precursor.hpp
1/*
2##############################################################################
3# file: ms_quant_precursor.hpp #
4# 'msparser' toolkit #
5# Encapsulates precursor-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_precursor.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_PRECURSOR_HPP
18#define MS_QUANT_PRECURSOR_HPP
19
20
21// forward declarations
22namespace msparser_internal {
23 class ms_quant_xmlloader;
24 class ms_quant_precursor_impl;
25 class ms_quant_configfile_impl;
26 class ms_quant_protocol_impl;
27}
28
29namespace matrix_science {
30
31 class ms_xml_schema; // forward declaration
32
39
42 class MS_MASCOTRESFILE_API ms_quant_precursor: public ms_quant_parameters
43 {
44 friend class msparser_internal::ms_quant_xmlloader;
45 friend class msparser_internal::ms_quant_configfile_impl;
46 friend class msparser_internal::ms_quant_protocol_impl;
47 public:
49 ms_quant_precursor();
50
52 ms_quant_precursor(const ms_quant_precursor& src);
53
55 virtual ~ms_quant_precursor();
56
58 void defaultValues();
59
61 void copyFrom(const ms_quant_precursor* right);
62
63#ifndef SWIG
65 ms_quant_precursor& operator=(const ms_quant_precursor& right);
66#endif
68 virtual std::string getSchemaType() const;
69
71 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
72
74 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
75
76
78 bool haveAllowMassTimeMatch() const;
79
81 bool isAllowMassTimeMatch() const;
82
84 void setAllowMassTimeMatch(const bool value);
85
87 void dropAllowMassTimeMatch();
88
90 std::string getAllowMassTimeMatchSchemaType() const;
91
92
94 bool haveAllowElutionShift() const;
95
97 bool isAllowElutionShift() const;
98
100
105 //void setAllowElutionShift(const bool value);
106
108 void dropAllowElutionShift();
109
111 std::string getAllowElutionShiftSchemaType() const;
112
113
115 bool haveAllChargeStates() const;
116
118 bool isAllChargeStates() const;
119
121
126 //void setAllChargeStates(const bool value);
127
129 void dropAllChargeStates();
130
132 std::string getAllChargeStatesSchemaType() const;
133
134 private:
135
136 msparser_internal::ms_quant_precursor_impl * m_pImpl;
137 }; // class ms_quant_precursor
138 // end of config_group
140
141} // namespace matrix_science
142
143#endif // MS_QUANT_PRECURSOR_HPP
144
145/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_parameters
A class that represents base parametersType in quantitation.xml.
Definition: ms_quant_parameters.hpp:82
matrix_science::ms_quant_precursor
An object of this class represent a single precursor element in quantitation.xml.
Definition: ms_quant_precursor.hpp:43
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_protocol.hpp Source File

  • inc
ms_quant_protocol.hpp
1/*
2##############################################################################
3# file: ms_quant_protocol.hpp #
4# 'msparser' toolkit #
5# Encapsulates protocol-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_protocol.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_PROTOCOL_HPP
18#define MS_QUANT_PROTOCOL_HPP
19
20
21#include <string>
22
23// forward declarations
24namespace msparser_internal {
25 class ms_quant_xmlloader;
26 class ms_quant_protocol_impl;
27 class ms_quant_method_impl;
28}
29
30namespace matrix_science {
31
32 // forward declarations
33 class ms_quant_parameters;
34 class ms_quant_reporter;
35 class ms_quant_precursor;
36 class ms_quant_replicate;
37 class ms_quant_average;
38 class ms_quant_multiplex;
39 class ms_xml_schema;
40
47
54 class MS_MASCOTRESFILE_API ms_quant_protocol: public ms_xml_IValidatable
55 {
56 friend class msparser_internal::ms_quant_xmlloader;
57 friend class msparser_internal::ms_quant_method_impl;
58 public:
60 ms_quant_protocol();
61
63 ms_quant_protocol(const ms_quant_protocol& src);
64
66 virtual ~ms_quant_protocol();
67
69 void defaultValues();
70
72 void copyFrom(const ms_quant_protocol* right);
73
74#ifndef SWIG
76 ms_quant_protocol& operator=(const ms_quant_protocol& right);
77#endif
79 virtual std::string getSchemaType() const;
80
82 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
83
85 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
86
87
89 std::string getType() const;
90
92 void setNull();
93
94
96 const ms_quant_reporter* getReporter() const;
97
99 void setReporter(const ms_quant_reporter* reporter);
100
102 std::string getReporterSchemaType() const;
103
104
106 const ms_quant_precursor* getPrecursor() const;
107
109 void setPrecursor(const ms_quant_precursor* precursor);
110
112 std::string getPrecursorSchemaType() const;
113
114
116 const ms_quant_multiplex* getMultiplex() const;
117
119 void setMultiplex(const ms_quant_multiplex* multiplex);
120
122 std::string getMultiplexSchemaType() const;
123
124
126 const ms_quant_replicate* getReplicate() const;
127
129 void setReplicate(const ms_quant_replicate* replicate);
130
132 std::string getReplicateSchemaType() const;
133
134
136 const ms_quant_average* getAverage() const;
137
139 void setAverage(const ms_quant_average* average);
140
142 std::string getAverageSchemaType() const;
143
144 private:
145
146 msparser_internal::ms_quant_protocol_impl * m_pImpl;
147
148 }; // class ms_quant_protocol
149 // end of config_group
151
152} // namespace matrix_science
153
154#endif // MS_QUANT_PROTOCOL_HPP
155
156/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_average
An object of this class represent a single "average" element in quantitation.xml.
Definition: ms_quant_average.hpp:40
matrix_science::ms_quant_multiplex
An object of this class represent a multiplex element in quantitation.xml.
Definition: ms_quant_multiplex.hpp:40
matrix_science::ms_quant_precursor
An object of this class represent a single precursor element in quantitation.xml.
Definition: ms_quant_precursor.hpp:43
matrix_science::ms_quant_protocol
An object of this class represent a protocol element in quantitation.xml.
Definition: ms_quant_protocol.hpp:55
matrix_science::ms_quant_replicate
An object of this class represent a single replicate element in quantitation.xml.
Definition: ms_quant_replicate.hpp:40
matrix_science::ms_quant_reporter
An object of this class represents a single reporter element in quantitation.xml.
Definition: ms_quant_reporter.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_quality.hpp Source File

  • inc
ms_quant_quality.hpp
1/*
2##############################################################################
3# file: ms_quant_quality.hpp #
4# 'msparser' toolkit #
5# Encapsulates quality-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_quality.hpp $
12 * @(#)$Revision: 23deec178247eb6704b4c85e1ed5642a21d26ed1 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2021-08-10 17:22:38 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_QUALITY_HPP
18#define MS_QUANT_QUALITY_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_xml_schema; // forward declaration
32
39 class MS_MASCOTRESFILE_API ms_quant_quality: public ms_quant_parameters
40 {
41 friend class msparser_internal::ms_quant_xmlloader;
42 public:
44 ms_quant_quality();
45
47 ms_quant_quality(const ms_quant_quality& src);
48
50 virtual ~ms_quant_quality();
51
53 void defaultValues();
54
56 void copyFrom(const ms_quant_quality* right);
57
58#ifndef SWIG
60 ms_quant_quality& operator=(const ms_quant_quality& right);
61#endif
63 virtual std::string getSchemaType() const;
64
66 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
67
69 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
70
71
73 bool haveMinPrecursorCharge() const;
74
76 int getMinPrecursorCharge() const;
77
79 void setMinPrecursorCharge(const int value);
80
82 void dropMinPrecursorCharge();
83
85 std::string getMinPrecursorChargeSchemaType() const;
86
87
89 bool haveIsolatedPrecursor() const;
90
92 bool isIsolatedPrecursor() const;
93
95 void setIsolatedPrecursor(const bool value);
96
98 void dropIsolatedPrecursor();
99
101 std::string getIsolatedPrecursorSchemaType() const;
102
103
105 bool haveMinimumA1() const;
106
108 std::string getMinimumA1() const;
109
111 void setMinimumA1(const char* value);
112
114 void dropMinimumA1();
115
117 std::string getMinimumA1SchemaType() const;
118
119
121 bool havePepThresholdType() const;
122
124 std::string getPepThresholdType() const;
125
127 void setPepThresholdType(const char* value);
128
130 void dropPepThresholdType();
131
133 std::string getPepThresholdTypeSchemaType() const;
134
135
137 bool havePepThresholdValue() const;
138
140 std::string getPepThresholdValue() const;
141
143 void setPepThresholdValue(const char* value);
144
146 void dropPepThresholdValue();
147
149 std::string getPepThresholdValueSchemaType() const;
150
151
153 bool haveUniquePepseq() const;
154
156 bool isUniquePepseq() const;
157
159 void setUniquePepseq(bool value);
160
162 void dropUniquePepseq();
163
165 std::string getUniquePepseqSchemaType() const;
166
167
169 bool haveIsolatedPrecursorThreshold() const;
170
172 std::string getIsolatedPrecursorThreshold() const;
173
175 void setIsolatedPrecursorThreshold(const char * value);
176
178 void dropIsolatedPrecursorThreshold();
179
181 std::string getIsolatedPrecursorThresholdSchemaType() const;
182
184 bool haveTotalIntensity() const;
185
187 bool isTotalIntensity() const;
188
190 void setTotalIntensity(bool value);
191
193 void dropTotalIntensity();
194
196 std::string getTotalIntensitySchemaType() const;
197
199 bool haveTotalIntensityThreshold() const;
200
202 std::string getTotalIntensityThreshold() const;
203
205 void setTotalIntensityThreshold(std::string value);
206
208 void dropTotalIntensityThreshold();
209
211 std::string getTotalIntensityThresholdSchemaType() const;
212 private:
213
214 int _minPrecursorCharge;
215 bool _minPrecursorCharge_set;
216
217 bool _isolatedPrecursor;
218 bool _isolatedPrecursor_set;
219
220 std::string _minimumA1;
221 bool _minimumA1_set;
222
223 std::string _pepThresholdType;
224 bool _pepThresholdType_set;
225
226 std::string _pepThresholdValue;
227 bool _pepThresholdValue_set;
228
229 bool _uniquePepseq;
230 bool _uniquePepseq_set;
231
232 std::string _isolatedPrecursorThreshold;
233 bool _isolatedPrecursorThreshold_set;
234
235 bool _totalIntensity;
236 bool _totalIntensity_set;
237
238 std::string _totalIntensityThreshold;
239 bool _totalIntensityThreshold_set;
240 }; // class ms_quant_quality
241 // end of config_group
243
244} // namespace matrix_science
245
246#endif // MS_QUANT_QUALITY_HPP
247
248/*------------------------------- End of File -------------------------------*/
249
matrix_science::ms_quant_parameters
A class that represents base parametersType in quantitation.xml.
Definition: ms_quant_parameters.hpp:82
matrix_science::ms_quant_quality
An object of this class represent a single quality element in quantitation.xml.
Definition: ms_quant_quality.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_ratio.hpp Source File

  • inc
ms_quant_ratio.hpp
1/*
2##############################################################################
3# file: ms_quant_ratio.hpp #
4# 'msparser' toolkit #
5# Encapsulates "ratioType" from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_ratio.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_RATIO_HPP
18#define MS_QUANT_RATIO_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_quant_numerator; // forward declaration
32 class ms_xml_schema; // forward declaration
33
40 class MS_MASCOTRESFILE_API ms_quant_ratio: public ms_xml_IValidatable
41 {
42 friend class msparser_internal::ms_quant_xmlloader;
43
44 public:
46 ms_quant_ratio();
47
49 ms_quant_ratio(const ms_quant_ratio& src);
50
52 virtual ~ms_quant_ratio();
53
55 void defaultValues();
56
58 void copyFrom(const ms_quant_ratio* right);
59
60#ifndef SWIG
62 ms_quant_ratio& operator=(const ms_quant_ratio& right);
63#endif
65 virtual std::string getSchemaType() const;
66
68 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
69
71 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
72
73
75 int getNumberOfNumerators() const;
76
78 void clearNumerators();
79
81 void appendNumerator(const ms_quant_numerator *numerator);
82
84 const ms_quant_numerator * getNumeratorByNumber(const int idx) const;
85
87 const ms_quant_numerator * getNumeratorByName(const char *name) const;
88
90 bool updateNumeratorByNumber(const int idx, const ms_quant_numerator* numerator);
91
93 bool updateNumeratorByName(const char *name, const ms_quant_numerator* numerator);
94
96 bool deleteNumeratorByNumber(const int idx);
97
99 bool deleteNumeratorByName(const char *name);
100
102 std::string getNumeratorSchemaType() const;
103
104
106 int getNumberOfDenominators() const;
107
109 void clearDenominators();
110
112 void appendDenominator(const ms_quant_numerator *denominator);
113
115 const ms_quant_numerator * getDenominatorByNumber(const int idx) const;
116
118 const ms_quant_numerator * getDenominatorByName(const char *name) const;
119
121 bool updateDenominatorByNumber(const int idx, const ms_quant_numerator* denominator);
122
124 bool updateDenominatorByName(const char *name, const ms_quant_numerator* denominator);
125
127 bool deleteDenominatorByNumber(const int idx);
128
130 bool deleteDenominatorByName(const char *name);
131
133 std::string getDenominatorSchemaType() const;
134
135
137 bool haveName() const;
138
140 std::string getName() const;
141
143 void setName(const char* value);
144
146 void dropName();
147
149 std::string getNameSchemaType() const;
150
151 private:
152 typedef std::vector< ms_quant_numerator* > numerator_vector;
153 numerator_vector _numerators;
154
155 numerator_vector _denominators;
156
157 std::string _name;
158 bool _name_set;
159
160 }; // class ms_quant_ratio
161 // end of config_group
163
164} // namespace matrix_science
165
166#endif // MS_QUANT_RATIO_HPP
167
168/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_numerator
Represent numerator_component and denominator_component elements.
Definition: ms_quant_numerator.hpp:40
matrix_science::ms_quant_ratio
Represents the ratioType type for the report_ratio element in quantitation.xml.
Definition: ms_quant_ratio.hpp:41
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_replicate.hpp Source File

  • inc
ms_quant_replicate.hpp
1/*
2##############################################################################
3# file: ms_quant_replicate.hpp #
4# 'msparser' toolkit #
5# Encapsulates replicate-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_replicate.hpp $
12 * @(#)$Revision: 1caf47bbc80949a038f104b65af87b0f2a38e4a7 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2024-04-20 10:59:36 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_REPLICATE_HPP
18#define MS_QUANT_REPLICATE_HPP
19
20
21// forward declarations
22namespace msparser_internal {
23 class ms_quant_xmlloader;
24}
25
26namespace matrix_science {
27
28 class ms_xml_schema; // forward declaration
29
36
39 class MS_MASCOTRESFILE_API ms_quant_replicate: public ms_quant_parameters
40 {
41 friend class msparser_internal::ms_quant_xmlloader;
42 public:
44 ms_quant_replicate();
45
47 ms_quant_replicate(const ms_quant_replicate& src);
48
50 virtual ~ms_quant_replicate();
51
53 void defaultValues();
54
56 void copyFrom(const ms_quant_replicate* right);
57
58#ifndef SWIG
60 ms_quant_replicate& operator=(const ms_quant_replicate& right);
61#endif
63 virtual std::string getSchemaType() const;
64
66 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
67
69 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
70
72 bool haveTimeAlignmentAlgorithm() const;
73
75 std::string getTimeAlignmentAlgorithm() const;
76
78 void setTimeAlignmentAlgorithm(const char* value);
79
81 void dropTimeAlignmentAlgorithm();
82
84 std::string getTimeAlignmentAlgorithmSchemaType() const;
85
86
87
88 private:
89 std::string _time_alignment_algorithm;
90 bool _time_alignment_algorithm_set;
91
92
93 }; // class ms_quant_replicate
94 // end of config_group
96
97} // namespace matrix_science
98
99#endif // MS_QUANT_REPLICATE_HPP
100
101/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_parameters
A class that represents base parametersType in quantitation.xml.
Definition: ms_quant_parameters.hpp:82
matrix_science::ms_quant_replicate
An object of this class represent a single replicate element in quantitation.xml.
Definition: ms_quant_replicate.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_reporter.hpp Source File

  • inc
ms_quant_reporter.hpp
1/*
2##############################################################################
3# file: ms_quant_reporter.hpp #
4# 'msparser' toolkit #
5# Encapsulates reporter-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_reporter.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_REPORTER_HPP
18#define MS_QUANT_REPORTER_HPP
19
20
21// forward declarations
22namespace msparser_internal {
23 class ms_quant_xmlloader;
24}
25
26namespace matrix_science {
27
28 class ms_xml_schema; // forward declaration
29
36
39 class MS_MASCOTRESFILE_API ms_quant_reporter: public ms_quant_parameters
40 {
41 friend class msparser_internal::ms_quant_xmlloader;
42 public:
44 ms_quant_reporter();
45
47 ms_quant_reporter(const ms_quant_reporter& src);
48
50 virtual ~ms_quant_reporter();
51
53 void defaultValues();
54
56 void copyFrom(const ms_quant_reporter* right);
57
58#ifndef SWIG
60 ms_quant_reporter& operator=(const ms_quant_reporter& right);
61#endif
63 virtual std::string getSchemaType() const;
64
66 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
67
69 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
70
71
73 bool haveReporterTol() const;
74
76 std::string getReporterTol() const;
77
79 void setReporterTol(const char* value);
80
82 void dropReporterTol();
83
85 std::string getReporterTolSchemaType() const;
86
87
89 bool haveReporterTolUnit() const;
90
92 std::string getReporterTolUnit() const;
93
95 void setReporterTolUnit(const char* value);
96
98 void dropReporterTolUnit();
99
101 std::string getReporterTolUnitSchemaType() const;
102 private:
103
104 std::string _reporterTol;
105 bool _reporterTol_set;
106
107 std::string _reporterTolUnit;
108 bool _reporterTolUnit_set;
109 }; // class ms_quant_reporter
110 // end of config_group
112
113} // namespace matrix_science
114
115#endif // MS_QUANT_REPORTER_HPP
116
117/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_parameters
A class that represents base parametersType in quantitation.xml.
Definition: ms_quant_parameters.hpp:82
matrix_science::ms_quant_reporter
An object of this class represents a single reporter element in quantitation.xml.
Definition: ms_quant_reporter.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_satellite.hpp Source File

  • inc
ms_quant_satellite.hpp
1/*
2##############################################################################
3# file: ms_quant_satellite.hpp #
4# 'msparser' toolkit #
5# Encapsulates satellite-element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2009 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_satellite.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_SATELLITE_HPP
18#define MS_QUANT_SATELLITE_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_quant_modgroup; // forward declaration
32 class ms_xml_schema; // forward declaration
33
40
44 class MS_MASCOTRESFILE_API ms_quant_satellite: public ms_xml_IValidatable
45 {
46 friend class msparser_internal::ms_quant_xmlloader;
47
48 public:
50 ms_quant_satellite();
51
53 ms_quant_satellite(const ms_quant_satellite& src);
54
56 virtual ~ms_quant_satellite();
57
59 void defaultValues();
60
62 void copyFrom(const ms_quant_satellite* right);
63
64#ifndef SWIG
66 ms_quant_satellite& operator=(const ms_quant_satellite& right);
67#endif
69 virtual std::string getSchemaType() const;
70
72 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
73
75 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
76
77
79 bool haveModifications() const;
80
82 const ms_quant_modgroup* getModifications() const;
83
85 void setModifications(const ms_quant_modgroup* moverz);
86
88 void dropModifications();
89
91 std::string getModificationsSchemaType() const;
92
93 private:
94
95 ms_quant_modgroup *_pModifications;
96 bool _modifications_set;
97 }; // class ms_quant_satellite
98 // end of config_group
100
101} // namespace matrix_science
102
103#endif // MS_QUANT_SATELLITE_HPP
104
105/*------------------------------- End of File -------------------------------*/
106
matrix_science::ms_quant_modgroup
An object of this class represent a single modification group element in quantitation....
Definition: ms_quant_modgroup.hpp:46
matrix_science::ms_quant_satellite
An object of this class represent a single satellite element in quantitation.xml.
Definition: ms_quant_satellite.hpp:45
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_specificity.hpp Source File

  • inc
ms_quant_specificity.hpp
1/*
2##############################################################################
3# file: ms_quant_specificity.hpp #
4# 'msparser' toolkit #
5# Describes \c specificity element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_specificity.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_SPECIFICITY_HPP
18#define MS_QUANT_SPECIFICITY_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_quant_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_quant_neutralloss; // forward declaration
32 class ms_quant_pepneutralloss; // forward declaration
33 class ms_xml_schema; // forward declaration
34
41
44 class MS_MASCOTRESFILE_API ms_quant_specificity: public ms_xml_IValidatable // defined in "ms_xml_typeinfo.hpp"
45 {
46 friend class msparser_internal::ms_quant_xmlloader;
47
48 public:
50 ms_quant_specificity();
51
53 ms_quant_specificity(const ms_quant_specificity& src);
54
56 virtual ~ms_quant_specificity();
57
59 void defaultValues();
60
62 void copyFrom(const ms_quant_specificity* right);
63
64#ifndef SWIG
66 ms_quant_specificity& operator=(const ms_quant_specificity& right);
67#endif
68 // methods of ms_quant_IValidatable interface
69
71 virtual std::string getSchemaType() const;
72
74 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
75
77 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
78
79
81 int getNumberOfNeutralLosses() const;
82
84 void clearNeutralLosses();
85
87 void appendNeutralLoss(const ms_quant_neutralloss *neutralloss);
88
90 const ms_quant_neutralloss * getNeutralLoss(const int idx) const;
91
93 bool updateNeutralLoss(const int idx, const ms_quant_neutralloss* neutralloss);
94
96 bool deleteNeutralLoss(const int idx);
97
99 std::string getNeutralLossSchemaType() const;
100
101
103 int getNumberOfPepNeutralLosses() const;
104
106 void clearPepNeutralLosses();
107
109 void appendPepNeutralLoss(const ms_quant_pepneutralloss *neutralloss);
110
112 const ms_quant_pepneutralloss* getPepNeutralLoss(const int idx) const;
113
115 bool updatePepNeutralLoss(const int idx, const ms_quant_pepneutralloss* neutralloss);
116
118 bool deletePepNeutralLoss(const int idx);
119
121 std::string getPepNeutralLossSchemaType() const;
122
123
125 bool haveSite() const;
126
128 std::string getSite() const;
129
131 void setSite(const char* site);
132
134 void dropSite();
135
137 std::string getSiteSchemaType() const;
138
139
141 bool havePosition() const;
142
144 std::string getPosition() const;
145
147 void setPosition(const char* position);
148
150 void dropPosition();
151
153 std::string getPositionSchemaType() const;
154
155 private:
156 typedef std::vector< ms_quant_neutralloss* > neutralloss_vector;
157 neutralloss_vector _neutrallosses;
158
159 typedef std::vector< ms_quant_pepneutralloss* > pepneutralloss_vector;
160 pepneutralloss_vector _pepneutrallosses;
161
162 std::string _site;
163 bool _site_set;
164
165 std::string _position;
166 bool _position_set;
167 }; // class ms_quant_specificity
168 // end of config_group
170
171} // namespace matrix_science
172
173#endif // MS_QUANT_SPECIFICITY_HPP
174
175/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_neutralloss
A neutral loss for the sequence ions, e.g. loss of phosphate.
Definition: ms_quant_neutralloss.hpp:37
matrix_science::ms_quant_pepneutralloss
A neutral loss from the precursor.
Definition: ms_quant_pepneutralloss.hpp:37
matrix_science::ms_quant_specificity
Describes a specificity element in quantitation.xml (Unimod style specificity).
Definition: ms_quant_specificity.hpp:45
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_stats.hpp Source File

  • inc
ms_quant_stats.hpp
1/*
2##############################################################################
3# file: ms_quant_stats.hpp #
4# 'msparser' toolkit #
5# Statistics routines and distributions for peptide and protein quantitation #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: villek@matrixscience.com $ #
12# $Date: 2018-07-30 16:23:53 +0100 $ #
13# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_QUANT_STATS_HPP
19#define MS_QUANT_STATS_HPP
20
21
22#include <deque>
23#include <string>
24#include <vector>
25
26namespace matrix_science {
27
34
43 class MS_MASCOTRESFILE_API ms_quant_stats
44 {
45 public:
46#ifndef SWIG
48 static void detectOutliers(const std::vector<double> &sample, std::string outlierMethod, unsigned int * const numLow, unsigned int * const numHigh);
49
51 static void detectOutliers(const std::vector<double> &sample, std::string outlierMethod, double sigLevel, unsigned int * const numLow, unsigned int * const numHigh);
52
54 static void testRosners(const std::vector<double> &sample, unsigned int maxOutliers, double sigLevel, unsigned int * const numLow, unsigned int * const numHigh);
55#else // SWIG Multiple return values
56 static void detectOutliers(const std::vector<double> &sample, std::string outlierMethod, unsigned int * const OUTPUT, unsigned int * const OUTPUT);
57 static void detectOutliers(const std::vector<double> &sample, std::string outlierMethod, double sigLevel, unsigned int * const OUTPUT, unsigned int * const OUTPUT);
58 static void testRosners(const std::vector<double> &sample, unsigned int maxOutliers, double sigLevel, unsigned int * const OUTPUT, unsigned int * const OUTPUT);
59#endif
60
62 static int testDixonsN9(unsigned long sampleSize, double min, double x2, double xn_1, double max, double sigLevel);
63
65 static int testGrubbsN2(unsigned long sampleSize, double min, double mean, double max, double stdev, double sigLevel);
66#ifndef SWIG
68 static bool testShapiroWilkW(const std::vector<double> &sample, double * const W, double * const pValue);
69#else // SWIG Multiple return values
70 static bool testShapiroWilkW(const std::vector<double> &sample, double * const OUTPUT, double * const OUTPUT);
71#endif
73 static double binomialCoefficient(unsigned int n, unsigned int k);
74
76 static double sum(const std::vector<double> &data);
77
79 static double sumsq(const std::vector<double> &data);
80
82 static std::vector<double> meanCentre(const std::vector<double> &data, double mean);
83
85 static std::vector<double> logTransform(const std::vector<double> &data);
86
88 static std::vector<double> expTransform(const std::vector<double> &logData);
89
91 static double sortedMedian(const std::vector<double> &data);
92
94 static double sortedMedian(const std::deque<double> &data);
95
97 static double unsortedMedian(const std::vector<double> &data);
98
100 static double arithmeticMean(const std::vector<double> &data);
101
103 static double weightedArithmeticMean(const std::vector<double> &data, const std::vector<double> &weights);
104
106 static double geometricMean(const std::vector<double> &data);
107
109 static double weightedGeometricMean(const std::vector<double> &data, const std::vector<double> &weights);
110
112 static double arithmeticStandardDeviation(const std::vector<double> &data, double arithmeticMean);
113
115 static double arithmeticStandardErrorOfMean(double arithmeticStdev, unsigned long sampleSize);
116
118 static double geometricStandardDeviation(const std::vector<double> &data, double geometricMean);
119
121 static double arithmeticStandardErrorOfMedian(double arithmeticStdev, unsigned long sampleSize);
122
124 static double weightedArithmeticStandardDeviation(const std::vector<double> &data, const std::vector<double> &weights, double weightedMean);
125
127 static double weightedArithmeticStandardError(const std::vector<double> &weights, double weightedStdev, unsigned long sampleSize);
128
130 static double weightedGeometricStandardDeviation(const std::vector<double> &data, const std::vector<double> &weights, double weightedMean);
131
133 static double normalCumulativeProbability(double x0);
134
136 static double normalCriticalValue(double p);
137
139 static double studentsCriticalValue(unsigned int df, double sigLevel);
140
142 static double chisqUpperCriticalValue(unsigned int df, double sigLevel);
143
145 static double chisqLowerCriticalValue(unsigned int df, double sigLevel);
146
148 static double snedecorsCriticalValue(unsigned int df1, unsigned int df2, double sigLevel);
149
151 static double calculateNormalMeanPvalue(double populationMean, double mean, double stdev, unsigned long sampleSize);
152
154 static double calculateNormalMedianPvalue(double populationMedian, double median, double stdev, unsigned long sampleSize);
155
157 static double calculateNormalWeightedPvalue(double populationMean, double weightedMean, const std::vector<double> &weights, double weightedStdev, unsigned long sampleSize);
158
160 static double medianStandardErrorCorrection(unsigned long sampleSize);
161
163 static double poissonDensity(double lambda, unsigned int k);
164
165 private:
166 // No instances.
167 ms_quant_stats();
168 ~ms_quant_stats();
169
170 // No copying.
171 ms_quant_stats(const ms_quant_stats& src);
172 ms_quant_stats& operator=(const ms_quant_stats& right);
173 }; // end of quantitation_group
175} // matrix_science namespace
176
177#endif // MS_QUANT_STATS_HPP
178
179/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_stats
Mathematical and statistical routines for peptide and protein quantitation.
Definition: ms_quant_stats.hpp:44
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quant_unmodified.hpp Source File

  • inc
ms_quant_unmodified.hpp
1/*
2##############################################################################
3# file: ms_quant_unmodified.hpp #
4# 'msparser' toolkit #
5# Encapsulates "unmodified" element from "quantitation.xml"-file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_quant_unmodified.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_QUANT_UNMODIFIED_HPP
18#define MS_QUANT_UNMODIFIED_HPP
19
20
21#include <string>
22#include <vector>
23
24namespace msparser_internal {
25 class ms_quant_xmlloader;
26}
27
28namespace matrix_science {
29
30 class ms_xml_schema; // forward declaration
31
38 class MS_MASCOTRESFILE_API ms_quant_unmodified: public ms_xml_IValidatable
39 {
40 friend class msparser_internal::ms_quant_xmlloader;
41 public:
43 ms_quant_unmodified();
44
46 ms_quant_unmodified(const ms_quant_unmodified& src);
47
49 virtual ~ms_quant_unmodified();
50
52 void defaultValues();
53
55 void copyFrom(const ms_quant_unmodified* right);
56
57#ifndef SWIG
59 ms_quant_unmodified& operator=(const ms_quant_unmodified& right);
60#endif
62 virtual std::string getSchemaType() const;
63
65 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
66
68 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
69
70
72 std::string getContent() const;
73
75 void setContent(const char* value);
76
78 std::string getContentSchemaType() const;
79
80
82 bool haveSite() const;
83
85 std::string getSite() const;
86
88 void setSite(const char* site);
89
91 void dropSite();
92
94 std::string getSiteSchemaType() const;
95
96
98 bool havePosition() const;
99
101 std::string getPosition() const;
102
104 void setPosition(const char* position);
105
107 void dropPosition();
108
110 std::string getPositionSchemaType() const;
111
112
113 private:
114 std::string _content;
115
116 std::string _site;
117 bool _site_set;
118
119 std::string _position;
120 bool _position_set;
121
122 }; // class ms_quant_unmodified
123 // end of config_group
125
126} // namespace matrix_science
127
128#endif // MS_QUANT_UNMODIFIED_HPP
129
130/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_unmodified
Describes an unmodified element in quantitation.xml.
Definition: ms_quant_unmodified.hpp:39
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_quantitation.hpp Source File

  • inc
ms_quantitation.hpp
1/*
2##############################################################################
3# file: ms_quantitation.hpp #
4# 'msparser' toolkit #
5# Base class for the main quantitation interface #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2013 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: villek@matrixscience.com $ #
12# $Date: 2023-12-07 11:32:07 +0000 $ #
13# $Revision: b2f6316623fa89979f3ea09df34209662543707e | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef MS_QUANTITATION_HPP
19#define MS_QUANTITATION_HPP
20
21
22// Includes from the standard template library
23#include <string>
24#include <vector>
25#include <map>
26#include <set>
27#include <utility>
28
29namespace msparser_internal
30{
31 class ms_XMLElement;
32 class ms_XMLHelper;
33}
34
35namespace matrix_science {
36 class ms_errors;
37 class ms_peptide_quant_key;
38 class ms_peptide_quant_key_vector;
39 class ms_peptide_quant_ratio;
40 class ms_protein_quant_ratio;
41 class ms_quant_outliers;
42 class ms_peptidesummary;
43 class ms_protein;
44 class ms_peptide;
45 class ms_progress_info;
46
53
137 class MS_MASCOTRESFILE_API ms_quantitation: public ms_errors
138 {
139 public:
141 virtual ~ms_quantitation() = 0;
142
144 virtual bool hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const = 0;
145
147 virtual ms_peptide_quant_ratio getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const = 0;
148
150 virtual void setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName) = 0;
151
153 virtual void setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) = 0;
154
156 virtual bool isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const = 0;
157
159 virtual void setQuantOutliers(const ms_quant_outliers *) = 0;
160
162 void setMinNumPeptides(int value);
163
165 virtual void setProteinRatioType(const char *value) = 0;
166
168 const ms_quant_method& getQuantitationMethod() const;
169
171 virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const = 0;
172
174 virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const = 0;
175
177 virtual std::vector<double> getAllProteinRatios(const std::string & accession, const int dbIdx, const std::string & ratioName) const = 0;
178
180 virtual std::vector<std::vector<bool> > getAllProteinRatioFlags(const std::string & accession, const int dbIdx, const std::string & ratioName) const = 0;
181
182
184 ms_peptide_quant_key_vector getPeptideQuantKeys(const std::string &accession, int dbIdx) const;
185
187 double getPeptideRatioNormalisationBase(const std::string &ratioName) const;
188
190 void setPeptideRatioNormalisationBase(const std::string &ratioName, double b);
191
193 void removePeptideRatioNormalisationBase(const std::string &ratioName);
194
196 void removePeptideRatioNormalisationBases();
197
199 const ms_progress_info & getProgressInfo();
200
202 void addRawFileField(const unsigned int id, const std::string & name, const std::string & value);
204 void addHeaderField(const std::string & name, const std::string & value);
206 void clearHeaderFields();
208 void clearRawFileFields();
209
210#ifndef SWIG
212 virtual int countDistinctPeptides(const std::vector<ms_peptide_quant_key> & activeKeys) const;
213#endif
215 virtual int countDistinctPeptides(const ms_peptide_quant_key_vector & activeKeys) const;
216
217
218 protected:
219 ms_quantitation();
220
221 ms_quant_method quantMethod_;
222 typedef std::map<std::string, std::string> HeaderInfo_t;
223 typedef std::vector<HeaderInfo_t> RawFileInfo_t;
224 RawFileInfo_t rawFileInfo_;
225 HeaderInfo_t headerInfo_;
226
228 virtual void getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set<ms_peptide_quant_key> &keys, const std::set<ms_peptide_quant_key> &includeKeys, const std::set<ms_peptide_quant_key> &excludeKeys, std::vector<double> &values, std::vector<double> &weights, std::vector<ms_peptide_quant_key> &activeKeys, std::map<ms_peptide_quant_key, int> &inactiveKeys) const = 0;
229
231 void getProteinRatioSample(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector<ms_peptide_quant_key> &includeKeys, const std::vector<ms_peptide_quant_key> &excludeKeys, std::vector<double> &sample, std::vector<double> &logSample, std::vector<double> &weights, std::vector<ms_peptide_quant_key> &activeKeys, std::map<ms_peptide_quant_key, int> &inactiveKeys, double &normalityPvalue) const;
232
234 ms_protein_quant_ratio calculateMedianRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector<double> &sample, const std::vector<double> &logSample, const std::vector<ms_peptide_quant_key> &activeKeys, const std::map<ms_peptide_quant_key, int> &inactiveKeys, double normalityPvalue) const;
235
237 ms_protein_quant_ratio calculateGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector<double> &sample, const std::vector<double> &logSample, const std::vector<ms_peptide_quant_key> &activeKeys, const std::map<ms_peptide_quant_key, int> &inactiveKeys, double normalityPvalue) const;
238
240 ms_protein_quant_ratio calculateWeightedGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector<double> &sample, const std::vector<double> &logSample, const std::vector<double> &weights, const std::vector<ms_peptide_quant_key> &activeKeys, const std::map<ms_peptide_quant_key, int> &inactiveKeys, double normalityPvalue) const;
241
242 typedef std::pair<std::string, int> protein_key_t; // accession, dbIdx
243 typedef std::map< protein_key_t, std::set<ms_peptide_quant_key> > protein_to_peptide_quant_key_t; // maps from [accession, dbidx] to set<ms_peptide_quant_key>
245 protein_to_peptide_quant_key_t proteinKeys_;
246
248 bool initialiseBaseSettings(const ms_quant_method &qmBase, const ms_quant_method &qmConfig);
249
251 int getMinNumPeptides() const;
252
255 std::string encodeForXml(const std::string & value) const;
256
258 msparser_internal::ms_XMLElement createXmlRoot(msparser_internal::ms_XMLHelper & helper) const;
259
261 msparser_internal::ms_XMLElement createRawFilesElement(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & root) const;
262
264 msparser_internal::ms_XMLElement createHeaderElement(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & root) const;
265
267 bool addQuantitationMethodXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & root) const;
268
270 bool populateProteinHitXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & proteinHitElement, const matrix_science::ms_protein * protein, const matrix_science::ms_peptidesummary & peptideSummary, int hitId, int memberNumber);
271
273 bool addPeptideElement(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & root, const matrix_science::ms_peptide & peptide, const std::string & component) const;
274
276 bool createPeptideGroupStatusElement(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & hitElement, const matrix_science::ms_peptidesummary & peptideSummary, long q, long p, const std::string & status, const std::string & component, char residueBefore, char residueAfter) const;
278
279 mutable ms_progress_info * progressInfo_;
280 private:
281 int minNumPeptides_;
282
283 std::map< std::string, double > logH0ProteinRatio_;
284 typedef std::map< std::string, double > ratio_name_to_normalisation_base_t;
285 ratio_name_to_normalisation_base_t peptideNormalisationBases_;
286 }; // end of quantitation_group
288} // matrix_science namespace
289
290#endif // MS_QUANTITATION_HPP
291
292/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_peptide_quant_key_vector
A vector of peptide quant keys.
Definition: ms_peptide_quant_key_vector.hpp:47
matrix_science::ms_peptide_quant_key
Feature key identifying a peptide ratio.
Definition: ms_peptide_quant_key.hpp:69
matrix_science::ms_peptide_quant_ratio
Peptide abundance in one component relative to another in a quantitation experiment.
Definition: ms_peptide_quant_ratio.hpp:61
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptidesummary
Use this class to get peptide summary results.
Definition: ms_peptidesummary.hpp:51
matrix_science::ms_progress_info
Contains information of the current progress of a task being performed.
Definition: ms_progress_info.hpp:40
matrix_science::ms_protein_quant_ratio
Protein abundance in one component relative to another in a quantitation experiment,...
Definition: ms_protein_quant_ratio.hpp:72
matrix_science::ms_protein
This class encapsulates a protein in the mascot results file.
Definition: ms_protein.hpp:57
matrix_science::ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml.
Definition: ms_quant_method.hpp:51
matrix_science::ms_quant_outliers
An object of this class represent a single OUTLIERS element in quantitation.xml.
Definition: ms_quant_outliers.hpp:44
matrix_science::ms_quantitation
Base class for peptide and protein quantitation.
Definition: ms_quantitation.hpp:138
matrix_science::ms_quantitation::isPeptideRatioExcluded
virtual bool isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const =0
Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?
matrix_science::ms_quantitation::proteinKeys_
protein_to_peptide_quant_key_t proteinKeys_
Protein-to-peptide mapping.
Definition: ms_quantitation.hpp:245
matrix_science::ms_quantitation::getProteinRatio
virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const =0
Given the protein accession, database ID and ratio name, return the protein ratio data.
matrix_science::ms_quantitation::clearRawFileFields
void clearRawFileFields()
Clears any raw file header information from the result.
matrix_science::ms_quantitation::setQuantOutliers
virtual void setQuantOutliers(const ms_quant_outliers *)=0
Set new peptide ratio outlier settings.
matrix_science::ms_quantitation::getSortedFinitePeptideRatioValues
virtual void getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKeys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const =0
Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them...
matrix_science::ms_quantitation::addHeaderField
void addHeaderField(const std::string &name, const std::string &value)
Adds an item of project or search header information.
matrix_science::ms_quantitation::setPeptideRatioIncluded
virtual void setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName)=0
Globally include a particular peptide ratio in protein ratio calculation.
matrix_science::ms_quantitation::clearHeaderFields
void clearHeaderFields()
Clears any header information from the result.
matrix_science::ms_quantitation::getProteinRatio
virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const =0
Given the protein accession, database ID and ratio name, return the protein ratio data,...
matrix_science::ms_quantitation::addRawFileField
void addRawFileField(const unsigned int id, const std::string &name, const std::string &value)
Adds an item of raw file header information.
matrix_science::ms_quantitation::getPeptideRatio
virtual ms_peptide_quant_ratio getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const =0
Given peptide quant key and ratio name, return the corresponding peptide ratio data.
matrix_science::ms_quantitation::hasPeptideRatio
virtual bool hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const =0
Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name ...
matrix_science::ms_quantitation::setPeptideRatioExcluded
virtual void setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName)=0
Globally exclude a particular peptide ratio from protein ratio calculation.
matrix_science::ms_quantitation::setProteinRatioType
virtual void setProteinRatioType(const char *value)=0
Set the protein ratio type.
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_searchparams.hpp Source File

  • inc
ms_searchparams.hpp
1/*
2##############################################################################
3# file: ms_mascotresparams.hpp #
4# 'msparser' toolkit #
5# Encapsulates the parameters & masses sections from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespa $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2024-09-23 15:59:15 +0100 $ #
14# $Revision: 80290236f1981378c76180c6677fb9983e5275d5 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_MASCOTRESPARAMS_HPP
20#define MS_MASCOTRESPARAMS_HPP
21
22
23// Includes from the standard template library
24#include <string>
25
26namespace msparser_internal
27{
28 class ms_searchparamsbase;
29 class ms_searchparams_dat;
30 class ms_searchparams_msr;
31}
32namespace matrix_science {
33
40
46 class MS_MASCOTRESFILE_API ms_searchparams
47 {
48 friend class ms_mascotresfilebase;
49 public:
50
52
59 enum MULTI_SITE_MODS {
60 MSM_NOT_PERMITTED = 0x0000,
61 MSM_EXCLUSIVE_PLUS_VARIABLE = 0x0001
62 };
63
65 ms_searchparams(const ms_mascotresfilebase &resfile);
66
67
69 ~ms_searchparams() {};
70
72 std::string getLICENSE();
73#ifndef SWIGCSHARP
75 std::string getCOM();
76#else
77 std::wstring getCOM() {
78 return getCOMWide();
79 };
80#endif
82 int getSEG();
83
85 double getTOL();
86
88 std::string getTOLU();
89
91 double getITOL();
92
94 std::string getITOLU();
95
97 int getPFA();
98
100 std::string getDB(int idx = 1);
101
103 int getNumberOfDatabases();
104
106 std::string getMODS();
107
109 std::string getMASS();
110
112 MASS_TYPE getMassType();
113
115 std::string getCLE();
116
118 std::string getFILENAME();
119
121 std::string getDATAURL();
122
124 std::string getQUE();
125
127 std::string getSEARCH();
128
129#ifndef SWIGCSHARP
131 std::string getUSERNAME();
132#else
133 std::wstring getUSERNAME() {
134 return getUSERNAMEWide();
135 };
136#endif
137
138#ifndef SWIGCSHARP
140 std::string getUSEREMAIL();
141#else
142 std::wstring getUSEREMAIL() {
143 return getUSEREMAILWide();
144 };
145#endif
146
148 int getUSERID();
149
151 std::string getCHARGE();
152
154 std::string getINTERMEDIATE();
155
157 int getREPORT();
158
160 bool getOVERVIEW();
161
163 std::string getFORMAT();
164
166 std::string getFORMVER();
167
169 std::string getIT_MODS();
170
172 std::string getUSERField(int num);
173
175 std::string getAllUSERParams() const;
176
178 double getPRECURSOR();
179
181 std::string getTAXONOMY();
182
184 std::string getREPTYPE();
185
187 std::string getACCESSION();
188
190 int getSUBCLUSTER();
191
193 bool getICAT();
194
196 std::string getINSTRUMENT();
197
199 bool getERRORTOLERANT();
200
202 std::string getRULES();
203
205 double getMinInternalMass();
206
208 double getMaxInternalMass();
209
211 bool hasINTERNALS() const;
212
214 double getResidueMass(char residue);
215
217 double getCTermMass();
218
220 double getNTermMass();
221
223 double getHydrogenMass() const;
224
226 double getOxygenMass() const;
227
229 double getCarbonMass() const;
230
232 double getNitrogenMass() const;
233
235 double getElectronMass() const;
236
237 // Returns the name of the specified variable modification selected by the user.
238 std::string getVarModsName(int num) const;
239
241 double getVarModsDelta(int num);
242
244 double getVarModsNeutralLoss(int num);
245
247 std::vector<double> getVarModsNeutralLosses(int num) const;
248
250 std::vector<double> getVarModsPepNeutralLoss(int num);
251
253 std::vector<double> getVarModsReqPepNeutralLoss(int num);
254
255 // Returns the name of the specified fixed modification.
256 std::string getFixedModsName(int num) const;
257
259 double getFixedModsDelta(int num);
260
262 double getFixedModsNeutralLoss(int num);
263
265 std::string getFixedModsResidues(int num) const;
266
268 int getNumberOfLibraryMods() const;
269
271 std::string getLibraryModName(int num) const;
272
274 double getLibraryModDelta(int num) const;
275
277 std::string getErrTolParentFilename();
278
280 std::string getQUANTITATION() const;
281
283 std::string getCROSSLINKING() const;
284
286 int getPEP_ISOTOPE_ERROR() const;
287
289 int getDECOY() const;
290
292 double getTARGET_FDR_PERCENT() const;
293
295 int getPERCOLATE() const;
296
298 std::vector<std::string> getML_ADAPTER_PARAM() const;
299
301 int getLIBRARY_SEARCH() const;
302
304 unsigned int getMULTI_SITE_MODS() const;
305
306 protected:
307 // Not safe to copy or assign this object.
308#ifndef SWIG
309 ms_searchparams(const ms_searchparams & rhs);
310 ms_searchparams & operator=(const ms_searchparams & rhs);
311#endif
312 private:
313
314 std::shared_ptr<msparser_internal::ms_searchparamsbase> impl_;
315
316 std::wstring getCOMWide();
317 std::wstring getUSERNAMEWide();
318 std::wstring getUSEREMAILWide();
319
320 bool isDefaultMass(const std::string symbol) const;
321
322 }; // end of resfile_group
324} // matrix_science namespace
325
326#endif // MS_MASCOTRESPARAMS_HPP
327
328/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_searchparams
This class encapsulates the search parameters in the Mascot results file.
Definition: ms_searchparams.hpp:47
matrix_science::ms_searchparams::MULTI_SITE_MODS
MULTI_SITE_MODS
Possible values for MULTI_SITE_MODS.
Definition: ms_searchparams.hpp:59
matrix_science::ms_searchparams::~ms_searchparams
~ms_searchparams()
Should never need to call this destructor directly.
Definition: ms_searchparams.hpp:69
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_searchparams_dat.hpp Source File

  • src
  • resfile
  • impl
ms_searchparams_dat.hpp
1/*
2##############################################################################
3# file: ms_searchparams_dat.hpp #
4# 'msparser' toolkit #
5# Encapsulates a query from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_inputquery. $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2023-02-02 13:47:30 +0000 $ #
14# $Revision: a80892d71615baa5079d40d1461ed9c24e3bffff | MSPARSER_ALPHA_2_8_100-378-g5b7ff32217 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_SEARCHPARAMS_DAT_HPP
20#define MS_SEARCHPARAMS_DAT_HPP
21
22#include <string>
23
24#include "ms_searchparamsbase.hpp"
25
26namespace msparser_internal {
27
28 class ms_searchparams_dat : public ms_searchparamsbase
29 {
30 public:
31 ms_searchparams_dat(const matrix_science::ms_mascotresfile_dat &resfile);
32 virtual ~ms_searchparams_dat() = default;
33
34 std::string getLICENSE() override;
35
36 std::string getCOM() override;
37
38 std::wstring getCOMWide() override;
39
40 int getSEG() override;
41
42 double getTOL() override;
43
44 std::string getTOLU() override;
45
46 double getITOL() override;
47
48 std::string getITOLU() override;
49
50 int getPFA() override;
51
52 std::string getDB(int idx = 1) override;
53
54 int getNumberOfDatabases() override;
55
56 std::string getMODS() override;
57
58 std::string getMASS() override;
59
60 matrix_science::MASS_TYPE getMassType() override;
61
62 std::string getCLE() override;
63
64 std::string getFILENAME() override;
65
66 std::string getDATAURL() override;
67
68 std::string getQUE() override;
69
70 std::string getSEARCH() override;
71
72 std::string getUSERNAME() override;
73
74 std::wstring getUSERNAMEWide() override;
75
76 std::string getUSEREMAIL() override;
77
78 std::wstring getUSEREMAILWide() override;
79
80 int getUSERID() override;
81
82 std::string getCHARGE() override;
83
84 std::string getINTERMEDIATE() override;
85
86 int getREPORT() override;
87
88 bool getOVERVIEW() override;
89
90 std::string getFORMAT() override;
91
92 std::string getFORMVER() override;
93
94 std::string getIT_MODS() override;
95
96 std::string getUSERField(int num) override;
97
98 std::string getAllUSERParams() const override;
99
100 double getPRECURSOR() override;
101
102 std::string getTAXONOMY() override;
103
104 std::string getREPTYPE() override;
105
106 std::string getACCESSION() override;
107
108 int getSUBCLUSTER() override;
109
110 bool getICAT() override;
111
112 std::string getINSTRUMENT() override;
113
114 bool getERRORTOLERANT() override;
115
116 std::string getRULES() override;
117
118 double getMinInternalMass() override;
119
120 double getMaxInternalMass() override;
121
122 double getResidueMass(char residue) override;
123
124 double getCTermMass() override;
125
126 double getNTermMass() override;
127
128 double getHydrogenMass() const override;
129
130 double getOxygenMass() const override;
131
132 double getCarbonMass() const override;
133
134 double getNitrogenMass() const override;
135
136 double getElectronMass() const override;
137
138 std::string getVarModsName(int num) const override;
139
140 double getVarModsDelta(int num) override;
141
142 double getVarModsNeutralLoss(int num) override;
143
144 std::vector<double> getVarModsNeutralLosses(int num) const override;
145
146 std::vector<double> getVarModsPepNeutralLoss(int num) override;
147
148 std::vector<double> getVarModsReqPepNeutralLoss(int num) override;
149
150 std::string getFixedModsName(int num) const override;
151
152 double getFixedModsDelta(int num) override;
153
154 double getFixedModsNeutralLoss(int num) override;
155
156 std::string getFixedModsResidues(int num) const override;
157
158 int getNumberOfLibraryMods() const override;
159
160 std::string getLibraryModName(int num) const override;
161
162 double getLibraryModDelta(int num) const override;
163
164 std::string getErrTolParentFilename() override;
165
166 std::string getQUANTITATION() const override;
167
168 std::string getCROSSLINKING() const override;
169
170 int getPEP_ISOTOPE_ERROR() const override;
171
172 int getDECOY() const override;
173
174 double getTARGET_FDR_PERCENT() const override;
175
176 int getPERCOLATE() const override;
177
178 std::vector<std::string> getML_ADAPTER_PARAM() const override;
179
180 int getLIBRARY_SEARCH() const override;
181
182 unsigned int getMULTI_SITE_MODS() const override;
183
184 bool hasINTERNALS() const override;
185
186 bool isDefaultMass(const std::string symbol) const override;
187
188 private:
189 bool parseLibraryMod(const matrix_science::ms_mascotresfile_dat & resfile, int num, std::string & name, double & delta) const;
190
191 int getNumberOfDatabases(const matrix_science::ms_mascotresfile_dat & resfile) const;
192 };
193} // msparser_internal namespace
194
195#endif // !defined(MS_SEARCHPARAMSBASE_HPP)
matrix_science::ms_mascotresfile_dat
Class for parsing and reading files in dat28 format.
Definition: ms_mascotresfile_dat.hpp:121
matrix_science::MASS_TYPE
MASS_TYPE
All possible mass types.
Definition: ms_modfile.hpp:65
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_searchparams_msr.hpp Source File

  • src
  • resfile
  • impl
ms_searchparams_msr.hpp
1/*
2##############################################################################
3# file: ms_searchparams_msr.hpp #
4# 'msparser' toolkit #
5# Encapsulates a query from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_inputquery. $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2023-02-02 13:47:30 +0000 $ #
14# $Revision: a80892d71615baa5079d40d1461ed9c24e3bffff | MSPARSER_ALPHA_2_8_100-378-g5b7ff32217 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_SEARCHPARAMS_MSR_HPP
20#define MS_SEARCHPARAMS_MSR_HPP
21
22#include <string>
23
24#include "ms_searchparamsbase.hpp"
25
26namespace msparser_internal {
27
29
30 class ms_searchparams_msr : public ms_searchparamsbase
31 {
32 public:
33 ms_searchparams_msr(const matrix_science::ms_mascotresfile_msr &resfile);
34 virtual ~ms_searchparams_msr() = default;
35
36 std::string getLICENSE() override;
37
38 std::string getCOM() override;
39
40 std::wstring getCOMWide() override;
41
42 int getSEG() override;
43
44 double getTOL() override;
45
46 std::string getTOLU() override;
47
48 double getITOL() override;
49
50 std::string getITOLU() override;
51
52 int getPFA() override;
53
54 std::string getDB(int idx = 1) override;
55
56 int getNumberOfDatabases() override;
57
58 std::string getMODS() override;
59
60 std::string getMASS() override;
61
62 matrix_science::MASS_TYPE getMassType() override;
63
64 std::string getCLE() override;
65
66 std::string getFILENAME() override;
67
68 std::string getDATAURL() override;
69
70 std::string getQUE() override;
71
72 std::string getSEARCH() override;
73
74 std::string getUSERNAME() override;
75
76 std::wstring getUSERNAMEWide() override;
77
78 std::string getUSEREMAIL() override;
79
80 std::wstring getUSEREMAILWide() override;
81
82 int getUSERID() override;
83
84 std::string getCHARGE() override;
85
86 std::string getINTERMEDIATE() override;
87
88 int getREPORT() override;
89
90 bool getOVERVIEW() override;
91
92 std::string getFORMAT() override;
93
94 std::string getFORMVER() override;
95
96 std::string getIT_MODS() override;
97
98 std::string getUSERField(int num) override;
99
100 std::string getAllUSERParams() const override;
101
102 double getPRECURSOR() override;
103
104 std::string getTAXONOMY() override;
105
106 std::string getREPTYPE() override;
107
108 std::string getACCESSION() override;
109
110 int getSUBCLUSTER() override;
111
112 bool getICAT() override;
113
114 std::string getINSTRUMENT() override;
115
116 bool getERRORTOLERANT() override;
117
118 std::string getRULES() override;
119
120 double getMinInternalMass() override;
121
122 double getMaxInternalMass() override;
123
124 double getResidueMass(char residue) override;
125
126 double getCTermMass() override;
127
128 double getNTermMass() override;
129
130 double getHydrogenMass() const override;
131
132 double getOxygenMass() const override;
133
134 double getCarbonMass() const override;
135
136 double getNitrogenMass() const override;
137
138 double getElectronMass() const override;
139
140 std::string getVarModsName(int num) const override;
141
142 double getVarModsDelta(int num) override;
143
144 double getVarModsNeutralLoss(int num) override;
145
146 std::vector<double> getVarModsNeutralLosses(int num) const override;
147
148 std::vector<double> getVarModsPepNeutralLoss(int num) override;
149
150 std::vector<double> getVarModsReqPepNeutralLoss(int num) override;
151
152 std::string getFixedModsName(int num) const override;
153
154 double getFixedModsDelta(int num) override;
155
156 double getFixedModsNeutralLoss(int num) override;
157
158 std::string getFixedModsResidues(int num) const override;
159
160 int getNumberOfLibraryMods() const override;
161
162 std::string getLibraryModName(int num) const override;
163
164 double getLibraryModDelta(int num) const override;
165
166 std::string getErrTolParentFilename() override;
167
168 std::string getQUANTITATION() const override;
169
170 std::string getCROSSLINKING() const override;
171
172 int getPEP_ISOTOPE_ERROR() const override;
173
174 int getDECOY() const override;
175
176 double getTARGET_FDR_PERCENT() const override;
177
178 int getPERCOLATE() const override;
179
180 std::vector<std::string> getML_ADAPTER_PARAM() const override;
181
182 int getLIBRARY_SEARCH() const override;
183
184 unsigned int getMULTI_SITE_MODS() const override;
185
186 bool hasINTERNALS() const override;
187
188 bool isDefaultMass(const std::string symbol) const override;
189
190 private:
191
193 bool _getVarMod(const matrix_science::ms_mascotresfile_msr &resfile, const int modNum, std::string& varModName, double& varModDelta) const;
195 std::vector<double> _getVarModNeutralLosses(const matrix_science::ms_mascotresfile_msr &resfile, const int modNum) const;
196
198 std::vector<double> _getVarModPepNeutralLosses(const matrix_science::ms_mascotresfile_msr &resfile, const int modNum) const;
199
201 std::vector<double> _getVarModReqPepNeutralLosses(const matrix_science::ms_mascotresfile_msr &resfile, const int modNum) const;
202
204 bool _getFixedMod(const matrix_science::ms_mascotresfile_msr &resfile, const int modNum, std::string& fixedModName, double& fixedModDelta) const;
205
207 bool _getFixedModNeutralLoss(const matrix_science::ms_mascotresfile_msr &resfile, const int modNum, double& neutralLoss) const;
208
210 std::string _getFixedModResidues(const matrix_science::ms_mascotresfile_msr &resfile, const int modNum) const;
211
212 int getNumberOfDatabases(const std::map<std::string, std::string> &mapParams) const;
213
214 };
215
217
218} // msparser_internal namespace
219
220#endif // !defined(MS_SEARCHPARAMS_MSR_HPP)
matrix_science::ms_mascotresfile_msr
Class for parsing and reading files in MSR format.
Definition: ms_mascotresfile_msr.hpp:105
matrix_science::MASS_TYPE
MASS_TYPE
All possible mass types.
Definition: ms_modfile.hpp:65
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_searchparams_nil.hpp Source File

  • src
  • resfile
  • impl
ms_searchparams_nil.hpp
1/*
2##############################################################################
3# file: ms_searchparams_nil.hpp #
4# 'msparser' toolkit #
5# Encapsulates a query from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_inputquery. $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2023-02-02 13:47:30 +0000 $ #
14# $Revision: a80892d71615baa5079d40d1461ed9c24e3bffff | MSPARSER_ALPHA_2_8_100-378-g5b7ff32217 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_SEARCHPARAMS_NIL_HPP
20#define MS_SEARCHPARAMS_NIL_HPP
21
22#include <string>
23
24#include "ms_searchparamsbase.hpp"
25#include "ms_modfile.hpp"
26
27namespace msparser_internal {
28
30
36 class ms_mascotresfile_nil;
37
38 class ms_searchparams_nil : public ms_searchparamsbase
39 {
40 public:
41 ms_searchparams_nil(const ms_mascotresfile_nil &resfile) {}
42 virtual ~ms_searchparams_nil() = default;
43
44 std::string getLICENSE() override { return {}; }
45
46 std::string getCOM() override { return {}; }
47
48 std::wstring getCOMWide() override { return {}; }
49
50 int getSEG() override { return 0; }
51
52 double getTOL() override { return 0.0; }
53
54 std::string getTOLU() override { return {}; }
55
56 double getITOL() override { return 0.0; }
57
58 std::string getITOLU() override { return {}; }
59
60 int getPFA() override { return 0; }
61
62 std::string getDB(int idx = 1) override { return {}; }
63
64 int getNumberOfDatabases() override { return 0; }
65
66 std::string getMODS() override { return {}; }
67
68 std::string getMASS() override { return {}; }
69
70 matrix_science::MASS_TYPE getMassType() override { return matrix_science::MASS_TYPE_AVE; }
71
72 std::string getCLE() override { return {}; }
73
74 std::string getFILENAME() override { return {}; }
75
76 std::string getDATAURL() override { return {}; }
77
78 std::string getQUE() override { return {}; }
79
80 std::string getSEARCH() override { return {}; }
81
82 std::string getUSERNAME() override { return {}; }
83
84 std::wstring getUSERNAMEWide() override { return {}; }
85
86 std::string getUSEREMAIL() override { return {}; }
87
88 std::wstring getUSEREMAILWide() override { return {}; }
89
90 int getUSERID() override { return 0; }
91
92 std::string getCHARGE() override { return {}; }
93
94 std::string getINTERMEDIATE() override { return {}; }
95
96 int getREPORT() override { return 0; }
97
98 bool getOVERVIEW() override { return false; }
99
100 std::string getFORMAT() override { return {}; }
101
102 std::string getFORMVER() override { return {}; }
103
104 std::string getIT_MODS() override { return {}; }
105
106 std::string getUSERField(int num) override { return {}; }
107
108 std::string getAllUSERParams() const override { return {}; }
109
110 double getPRECURSOR() override { return 0.0; }
111
112 std::string getTAXONOMY() override { return {}; }
113
114 std::string getREPTYPE() override { return {}; }
115
116 std::string getACCESSION() override { return {}; }
117
118 int getSUBCLUSTER() override { return 0; }
119
120 bool getICAT() override { return false; }
121
122 std::string getINSTRUMENT() override { return {}; }
123
124 bool getERRORTOLERANT() override { return false; }
125
126 std::string getRULES() override { return {}; }
127
128 double getMinInternalMass() override { return 0.0; }
129
130 double getMaxInternalMass() override { return 0.0; }
131
132 double getResidueMass(char residue) override { return 0.0; }
133
134 double getCTermMass() override { return 0.0; }
135
136 double getNTermMass() override { return 0.0; }
137
138 double getHydrogenMass() const override { return 0.0; }
139
140 double getOxygenMass() const override { return 0.0; }
141
142 double getCarbonMass() const override { return 0.0; }
143
144 double getNitrogenMass() const override { return 0.0; }
145
146 double getElectronMass() const override { return 0.0; }
147
148 std::string getVarModsName(int num) const override { return {}; }
149
150 double getVarModsDelta(int num) override { return 0.0; }
151
152 double getVarModsNeutralLoss(int num) override { return 0.0; }
153
154 std::vector<double> getVarModsNeutralLosses(int num) const override { return {}; }
155
156 std::vector<double> getVarModsPepNeutralLoss(int num) override { return {}; }
157
158 std::vector<double> getVarModsReqPepNeutralLoss(int num) override { return {}; }
159
160 std::string getFixedModsName(int num) const override { return {}; }
161
162 double getFixedModsDelta(int num) override { return 0.0; }
163
164 double getFixedModsNeutralLoss(int num) override { return 0.0; }
165
166 std::string getFixedModsResidues(int num) const override { return {}; }
167
168 int getNumberOfLibraryMods() const override { return 0; }
169
170 std::string getLibraryModName(int num) const override { return {}; }
171
172 double getLibraryModDelta(int num) const override { return 0.0; }
173
174 std::string getErrTolParentFilename() override { return {}; }
175
176 std::string getQUANTITATION() const override { return {}; }
177
178 std::string getCROSSLINKING() const override { return {}; }
179
180 int getPEP_ISOTOPE_ERROR() const override { return 0; }
181
182 int getDECOY() const override { return 0; }
183
184 double getTARGET_FDR_PERCENT() const override { return 0.0; }
185
186 int getPERCOLATE() const override { return -1; }
187
188 std::vector<std::string> getML_ADAPTER_PARAM() const override { return {}; }
189
190 int getLIBRARY_SEARCH() const override { return 0; }
191
192 unsigned int getMULTI_SITE_MODS() const override { return 0; }
193
194 bool hasINTERNALS() const override { return false; }
195
196 bool isDefaultMass(const std::string symbol) const override { return false; }
197 };
198 // end of resfile_group
200
202
203} // msparser_internal namespace
204
205#endif // !defined(MS_SEARCHPARAMS_NIL_HPP)
matrix_science::MASS_TYPE
MASS_TYPE
All possible mass types.
Definition: ms_modfile.hpp:65
matrix_science::MASS_TYPE_AVE
@ MASS_TYPE_AVE
average mass index
Definition: ms_modfile.hpp:67
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_searchparamsbase.hpp Source File

  • src
  • resfile
  • impl
ms_searchparamsbase.hpp
1/*
2##############################################################################
3# file: ms_inputquerybase.hpp #
4# 'msparser' toolkit #
5# Encapsulates a query from the mascot results file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2002 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_inputquery. $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2023-02-02 13:47:30 +0000 $ #
14# $Revision: a80892d71615baa5079d40d1461ed9c24e3bffff | MSPARSER_ALPHA_2_8_100-378-g5b7ff32217 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_SEARCHPARAMSBASE_HPP
20#define MS_SEARCHPARAMSBASE_HPP
21
22#include <string>
23
24#include "ms_modfile.hpp"
25
26namespace msparser_internal {
27
29
30 class ms_searchparamsbase
31 {
32 public:
33 ms_searchparamsbase() = default;
34 virtual ~ms_searchparamsbase() = default;
35
36 virtual std::string getLICENSE() = 0;
37
38 virtual std::string getCOM() = 0;
39
40 virtual std::wstring getCOMWide() = 0;
41
42 virtual int getSEG() = 0;
43
44 virtual double getTOL() = 0;
45
46 virtual std::string getTOLU() = 0;
47
48 virtual double getITOL() = 0;
49
50 virtual std::string getITOLU() = 0;
51
52 virtual int getPFA() = 0;
53
54 virtual std::string getDB(int idx = 1) = 0;
55
56 virtual int getNumberOfDatabases() = 0;
57
58 virtual std::string getMODS() = 0;
59
60 virtual std::string getMASS() = 0;
61
62 virtual matrix_science::MASS_TYPE getMassType() = 0;
63
64 virtual std::string getCLE() = 0;
65
66 virtual std::string getFILENAME() = 0;
67
68 virtual std::string getDATAURL() = 0;
69
70 virtual std::string getQUE() = 0;
71
72 virtual std::string getSEARCH() = 0;
73
74 virtual std::string getUSERNAME() = 0;
75
76 virtual std::wstring getUSERNAMEWide() = 0;
77
78 virtual std::string getUSEREMAIL() = 0;
79
80 virtual std::wstring getUSEREMAILWide() = 0;
81
82 virtual int getUSERID() = 0;
83
84 virtual std::string getCHARGE() = 0;
85
86 virtual std::string getINTERMEDIATE() = 0;
87
88 virtual int getREPORT() = 0;
89
90 virtual bool getOVERVIEW() = 0;
91
92 virtual std::string getFORMAT() = 0;
93
94 virtual std::string getFORMVER() = 0;
95
96 virtual std::string getIT_MODS() = 0;
97
98 virtual std::string getUSERField(int num) = 0;
99
100 virtual std::string getAllUSERParams() const = 0;
101
102 virtual double getPRECURSOR() = 0;
103
104 virtual std::string getTAXONOMY() = 0;
105
106 virtual std::string getREPTYPE() = 0;
107
108 virtual std::string getACCESSION() = 0;
109
110 virtual int getSUBCLUSTER() = 0;
111
112 virtual bool getICAT() = 0;
113
114 virtual std::string getINSTRUMENT() = 0;
115
116 virtual bool getERRORTOLERANT() = 0;
117
118 virtual std::string getRULES() = 0;
119
120 virtual double getMinInternalMass() = 0;
121
122 virtual double getMaxInternalMass() = 0;
123
124 virtual double getResidueMass(char residue) = 0;
125
126 virtual double getCTermMass() = 0;
127
128 virtual double getNTermMass() = 0;
129
130 virtual double getHydrogenMass() const = 0;
131
132 virtual double getOxygenMass() const = 0;
133
134 virtual double getCarbonMass() const = 0;
135
136 virtual double getNitrogenMass() const = 0;
137
138 virtual double getElectronMass() const = 0;
139
140 virtual std::string getVarModsName(int num) const = 0;
141
142 virtual double getVarModsDelta(int num) = 0;
143
144 virtual double getVarModsNeutralLoss(int num) = 0;
145
146 virtual std::vector<double> getVarModsNeutralLosses(int num) const = 0;
147
148 virtual std::vector<double> getVarModsPepNeutralLoss(int num) = 0;
149
150 virtual std::vector<double> getVarModsReqPepNeutralLoss(int num) = 0;
151
152 virtual std::string getFixedModsName(int num) const = 0;
153
154 virtual double getFixedModsDelta(int num) = 0;
155
156 virtual double getFixedModsNeutralLoss(int num) = 0;
157
158 virtual std::string getFixedModsResidues(int num) const = 0;
159
160 virtual int getNumberOfLibraryMods() const = 0;
161
162 virtual std::string getLibraryModName(int num) const = 0;
163
164 virtual double getLibraryModDelta(int num) const = 0;
165
166 virtual std::string getErrTolParentFilename() = 0;
167
168 virtual std::string getQUANTITATION() const = 0;
169
170 virtual std::string getCROSSLINKING() const = 0;
171
172 virtual int getPEP_ISOTOPE_ERROR() const = 0;
173
174 virtual int getDECOY() const = 0;
175
176 virtual double getTARGET_FDR_PERCENT() const = 0;
177
178 virtual int getPERCOLATE() const = 0;
179
180 virtual std::vector<std::string> getML_ADAPTER_PARAM() const = 0;
181
182 virtual int getLIBRARY_SEARCH() const = 0;
183
184 virtual unsigned int getMULTI_SITE_MODS() const = 0;
185
186 virtual bool hasINTERNALS() const = 0;
187
188 virtual bool isDefaultMass(const std::string symbol) const = 0;
189
190 protected:
191
192 std::string decryptNumber(const std::string & input) const;
193
194 static std::vector<std::string> parse_csv_param_value(const std::string &str);
195
196 int numDB_;
197 std::string license_;
198 std::string com_;
199 int seg_;
200 double tol_;
201 std::string tolu_;
202 double itol_;
203 std::string itolu_;
204 int PFA_;
205 std::vector<std::string> DBnames_;
206 std::string mods_;
207 std::string massTypeStr_;
208 std::string cle_;
209 std::string FILENAME_;
210 std::string DATAURL_;
211 std::string QUE_;
212 std::string SEARCH_;
213 std::string USERNAME_;
214 int USERID_;
215 std::string USEREMAIL_;
216 std::string CHARGE_;
217 std::string INTERMEDIATE_;
218 int REPORT_;
219 bool OVERVIEW_;
220 std::string FORMAT_;
221 std::string FORMVER_;
222 std::string IT_MODS_;
223 std::vector<std::string> userField_;
224 std::string allUserParams_;
225 double PRECURSOR_;
226 std::string TAXONOMY_;
227 std::string REPTYPE_;
228 std::string ACCESSION_;
229 int SUBCLUSTER_;
230 bool ICAT_;
231 std::string INSTRUMENT_;
232 bool ERRORTOLERANT_;
233 std::string RULES_;
234 double minInternalMass_;
235 double maxInternalMass_;
236 std::map<char, double> residueMasses_;
237 double C_term_;
238 double N_term_;
239 double HydrogenMass_;
240 double OxygenMass_;
241 double CarbonMass_;
242 double NitrogenMass_;
243 double ElectronMass_;
244 std::map<int, std::string> varModsName_;
245 std::map<int, double> varModsDelta_;
246 std::map<int, std::vector<double> > varModsNeutralLosses_;
247 std::map<int, std::vector<double> > pepNeutralLoss_;
248 std::map<int, std::vector<double> > reqPepNeutralLoss_;
249 std::map<int, std::string> fixedModsName_;
250 std::map<int, double> fixedModsDelta_;
251 std::map<int, double> fixedModsNeutralLoss_;
252 std::map<int, std::string> fixedModsResidues_;
253 std::vector<std::string> libraryModNames_;
254 std::vector<double> libraryModDeltas_;
255 int numLibraryMods_;
256 std::string errTolParentFilename_;
257 std::string QUANTITATION_;
258 std::string CROSSLINKING_;
259 int PEP_ISOTOPE_ERROR_;
260 int decoy_;
261 double TARGET_FDR_PERCENT_;
262 int PERCOLATE_;
263 std::vector<std::string> ML_ADAPTER_PARAM_;
264 int LIBRARY_SEARCH_;
265 int MULTI_SITE_MODS_;
266 bool hasINTERNALS_;
267 // FIXME: This is not used anywhere.
268 std::map<std::string, std::string> userParams_;
269 std::set<std::string> setMasses_;
270
271
272 };
273
275
276} // msparser_internal namespace
277
278#endif // !defined(MS_SEARCHPARAMSBASE_HPP)
matrix_science::MASS_TYPE
MASS_TYPE
All possible mass types.
Definition: ms_modfile.hpp:65
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security.hpp Source File

  • inc
ms_security.hpp
1/*
2##############################################################################
3# file: ms_security.hpp #
4# 'msparser' toolkit #
5# Encapsulates Mascot security as used in authentication #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2004 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19
20
21#if !defined(ms_security_INCLUDED_)
22#define ms_security_INCLUDED_
23
24
25// Includes from the standard template library
26#include <string>
27#include <set>
28#include <vector>
29#include <map>
30
31
32#ifdef _WIN32
33#include <io.h>
34#endif
35
36#include <time.h>
37
38namespace matrix_science {
39 class ms_security_options;
40 class ms_security_task;
41 class ms_security_tasks;
42
43#ifndef SWIG
44 class ms_userSortByID
45 {
46 public:
47 bool operator() (const ms_user * t1, const ms_user * t2) const
48 {
49 return (t1->getID() < t2->getID());
50 }
51 };
52
53 class ms_userSortByLoginName
54 {
55 public:
56 bool operator() (const ms_user * t1, const ms_user * t2) const
57 {
58 return (t1->getName() < t2->getName());
59 }
60 };
61
62 class ms_userSortByFullName
63 {
64 public:
65 bool operator() (const ms_user * t1, const ms_user * t2) const
66 {
67 return (t1->getFullName() < t2->getFullName());
68 }
69 };
70
71 class ms_groupSortByID
72 {
73 public:
74 bool operator() (const ms_group * t1, const ms_group * t2) const
75 {
76 return (t1->getID() < t2->getID());
77 }
78 };
79
80#endif
81
87
93 class MS_MASCOTRESFILE_API ms_security : public ms_errors
94 {
95
96 public:
98 ms_security();
99 ~ms_security();
100
101 public:
102
104 enum USERID_SORTBY
105 {
106 USERID_SORTBY_ID = 1,
107 USERID_SORTBY_LOGINNAME = 2,
108 USERID_SORTBY_FULLNAME = 3
109 };
110
112 bool addNewUser(const std::string sessionID,
113 const int userID,
114 const std::string userName,
115 const std::string password,
116 const time_t passwordExpiry,
117 const std::string fullName,
118 const std::string emailAddress,
119 const ms_user::usertype userType,
120 const bool enabled);
121
123 ms_user getUser(const std::string userName) const;
124
126 ms_user getUserFromID(const int userID) const;
127
129 bool isUserExists(const int userID) const;
130
132 std::vector<int> sortUsers(std::vector<ms_user*> & vecUsers, const USERID_SORTBY sortby) const;
133
135 std::vector<int> getAllUserIDs(const USERID_SORTBY sortby = USERID_SORTBY_ID) const;
136
138 bool deleteUser(const std::string sessionID, const std::string userName);
139
141 bool updateUser(const std::string sessionID, const ms_user user);
142
144 bool updatePassword(const std::string sessionID,
145 const std::string userName,
146 const std::string oldPassword,
147 const std::string newPassword);
148
150 std::vector<std::string> getIntegraUsers() const;
151
153 bool addNewGroup(const std::string sessionID,
154 const int groupID,
155 const std::string groupName);
156
158 ms_group getGroup(const std::string groupName) const;
159
161 ms_group getGroupFromID(const int groupID) const;
162
164 std::vector<int> getAllGroupIDs() const;
165
167 bool deleteGroup(const std::string sessionID, const std::string groupName);
168
170 bool updateGroup(const std::string sessionID, const ms_group & group);
171
173 ms_security_tasks getPermittedTasksForUser(const std::string name) const;
174
176 ms_user::customParams_t getAllCustomParamsForUser(const ms_user & user) const;
177
179 ms_security_options getMascotSecurityOptions() const;
180
182 ms_security_tasks getTasks() const;
183
185 bool isTaskExists(const int taskID) const;
186
188 bool createDefaults(const std::string sessionID = "");
189
191 bool updateAllSessionFiles(bool deleteOnly = false);
192
193 protected:
194 bool loadFromFile();
195 bool saveToFile();
196
197 private:
198 //do not copy this class
199 ms_security(const ms_security & src);
200 ms_security& operator=(const ms_security & right);
201
202 typedef std::set<ms_user *, ms_userSortByID> userlist_t;
203 typedef std::set<ms_group *, ms_groupSortByID> grouplist_t;
204
205 const char * invalidChars_;
206
207 userlist_t users_;
208 grouplist_t groups_;
209 ms_security_tasks * tasks_;
210 ms_security_options options_;
211 int nextFreeGroupID_;
212 int nextFreeUserID_;
213
214 void removeAllUsersFromMemory();
215 void removeAllGroupsFromMemory();
216 bool doUpdateUser(const ms_user user);
217
218 }; // end of security_group
220}
221#endif // !defined(ms_security_INCLUDED_)
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_group
This class will normally only be used by Mascot Security Administration applications.
Definition: ms_security_group.hpp:39
matrix_science::ms_security_options
Options for the Mascot security system.
Definition: ms_security_options.hpp:46
matrix_science::ms_security_tasks
Each group has permission to do one or more tasks. This class defines a collection of tasks.
Definition: ms_security_tasks.hpp:51
matrix_science::ms_security
The main security class to be used by the administration application.
Definition: ms_security.hpp:94
matrix_science::ms_security::USERID_SORTBY
USERID_SORTBY
Sorting criterion to retrieve all users.
Definition: ms_security.hpp:105
matrix_science::ms_user
This class will normally only be used by Mascot Security Administration applications.
Definition: ms_security_user.hpp:49
matrix_science::ms_user::usertype
usertype
Definitions for types of user.
Definition: ms_security_user.hpp:57
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security_group.hpp Source File

  • inc
ms_security_group.hpp
1/*
2##############################################################################
3# file: ms_security_group.hpp #
4# 'msparser' toolkit #
5# Encapsulates a mascot user as used in authentication #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2004 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19
20
21#if !defined(ms_users_group_INCLUDED_)
22#define ms_users_group_INCLUDED_
23
24
25// Includes from the standard template library
26#include <string>
27#include <set>
28#include <vector>
29#include <map>
30#include <time.h>
31
32namespace matrix_science {
38 class MS_MASCOTRESFILE_API ms_group
39 {
40
41 public:
43
46 enum systemids
47 {
48 GROUPID_GUESTS = 0x0001,
49 GROUPID_ADMINISTRATORS = 0x0002,
50 GROUPID_POWERUSERS = 0x0003,
51 GROUPID_DAEMONS = 0x0004,
52 GROUPID_INTEGRA_SYSTEM = 0x0005,
53 GROUPID_LAST = 0x0006
54 };
55
57 ms_group();
58
60 ms_group(const int groupID, const std::string groupName);
61
62 // Copying constructor for c++ programs - don't document
63 ms_group(const ms_group &src);
64
65#ifndef SWIG
66 // Assignment operator for c++ programs - don't document
67 ms_group & operator=(const ms_group & right);
68#endif
69 ~ms_group();
70
72 bool addUser(const int userID);
73
75 bool deleteUser(const int userID);
76
78 bool isUserInGroup(const int userID) const;
79
81 std::vector<int> getAllUserIDs(const void * const security = NULL, const int voidSortby = 1) const;
82
84 std::string getName() const;
85
87 void setName(const std::string newVal);
88
90 void addPermittedTask(const matrix_science::ms_security_task & task);
91
93 bool removePermittedTask(const int taskID);
94
96 matrix_science::ms_security_tasks getPermittedTasks() const;
97
99 void setPermittedTasks(matrix_science::ms_security_tasks& tasks);
100
102 int getID() const;
103
105 void setID(int newVal);
106
108 bool saveStringParam(const std::string name, const std::string param);
109
110#ifndef SWIG
112 bool getStringParam(const std::string name, std::string & param) const;
113#endif
114
116 std::string getStringParam(const std::string name) const;
117
119 bool clearParam(const std::string name);
120
121#ifndef SWIG
122#ifndef DOXYGEN_SHOULD_SKIP_THIS
123 typedef std::map<std::string, std::string> customParams_t;
124 customParams_t getAllCustomParams() const { return params_; }
125#endif
126#endif
127
128 private:
129 int groupID_;
130 typedef std::set<int> users_t;
131 ms_security_tasks tasks_;
132 std::string groupName_;
133 users_t users_;
134 customParams_t params_;
135
136 void copyFrom(const ms_group * src);
137 void updateUsersArrayTasks();
138 }; // end of security_group
140}
141#endif // !defined(ms_users_group_INCLUDED_)
matrix_science::ms_group
This class will normally only be used by Mascot Security Administration applications.
Definition: ms_security_group.hpp:39
matrix_science::ms_group::systemids
systemids
Definitions for predefined groups.
Definition: ms_security_group.hpp:47
matrix_science::ms_security_task
Each group has permission to do one or more tasks. This class defines an individual task.
Definition: ms_security_task.hpp:51
matrix_science::ms_security_tasks
Each group has permission to do one or more tasks. This class defines a collection of tasks.
Definition: ms_security_tasks.hpp:51
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security_options.hpp Source File

  • inc
ms_security_options.hpp
1/*
2##############################################################################
3# file: ms_security_options.hpp #
4# 'msparser' toolkit #
5# Encapsulates the global security options for Mascot authentication #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2004 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19
20#if !defined(ms_security_options_INCLUDED_)
21#define ms_security_options_INCLUDED_
22
23
24// Includes from the standard template library
25#include <string>
26#include <set>
27#include <vector>
28#include <map>
29#include <time.h>
30
31namespace matrix_science {
37 class ms_security;
38
40
45 class MS_MASCOTRESFILE_API ms_security_options: public ms_errors
46 {
47
48 public:
50 ms_security_options();
51
52 ~ms_security_options();
53
54 ms_security_options(const ms_security_options & src);
55#ifndef SWIG
56 ms_security_options& operator=(const ms_security_options & right);
57#endif
58 void copyFrom(const ms_security_options * right);
59
61 bool isSecurityEnabled() const;
62
64 void setSecurityEnabled(bool newVal);
65
67 time_t getSessionTimeout() const;
68
70 void setSessionTimeout(time_t newVal);
71
73 time_t getDefaultPasswordExpiryTime() const;
74
76 void setDefaultPasswordExpiryTime(time_t newVal);
77
79 unsigned int getMinimumPasswordLength() const;
80
82 void setMinimumPasswordLength(unsigned int newVal);
83
85 bool getUseSessionCookies() const;
86
88 void setUseSessionCookies(bool newVal);
89
91 bool getVerifySessionIPAddress() const;
92
94 void setVerifySessionIPAddress(bool newVal);
95
97 matrix_science::ms_errs::msg_sev getLoggingLevel() const;
98
100 void setLoggingLevel(ms_errs::msg_sev newVal);
101
103 std::string getIntegraAppServerURL() const;
104
106 void setIntegraAppServerURL(std::string newVal);
107
109 std::string getIntegraDatabaseName() const;
110
112 void setIntegraDatabaseName(std::string newVal);
113
115 std::string getIntegraOracleServerName() const;
116
118 void setIntegraOracleServerName(std::string newVal);
119
121 std::string getLogFileName();
122
124 void setLogFileName(std::string newVal);
125
126 protected:
127 bool loadFromFile();
128 bool saveToFile();
129
130 private:
131 std::string filename_;
132
133 bool securityEnabled_;
134 time_t sessionTimeout_;
135 time_t defaultPasswordExpiryTime_;
136 unsigned int minimumPasswordLength_;
137 bool useSessionCookies_;
138 bool verifySessionIPAddress_;
139 ms_errs::msg_sev logLevel_;
140 std::string logFile_;
141 std::string integraAppServerURL_;
142 std::string integraDatabaseName_;
143 std::string integraOracleServerName_;
144 }; // end of security_group
146
147}
148#endif // !defined(ms_security_options_INCLUDED_)
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_log::msg_sev
msg_sev
Message severity levels.
Definition: ms_log.hpp:47
matrix_science::ms_security_options
Options for the Mascot security system.
Definition: ms_security_options.hpp:46
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security_session.hpp Source File

  • inc
ms_security_session.hpp
1/*
2##############################################################################
3# file: ms_security_session.hpp #
4# 'msparser' toolkit #
5# Encapsulates a mascot session as used in authentication #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2004 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#if !defined(mascot_session_DA3EC794_90F8_4c4f_AD5D_13C3B6971A51__INCLUDED_)
20#define mascot_session_DA3EC794_90F8_4c4f_AD5D_13C3B6971A51__INCLUDED_
21
22
23// Includes from the standard template library
24#include <string>
25#include <set>
26#include <vector>
27#include <map>
28#include <time.h>
29
30namespace matrix_science {
35 class ms_security;
36 class ms_security_options;
37
39
122 class MS_MASCOTRESFILE_API ms_session : public ms_errors
123 {
124 public:
126 ms_session(const std::string session_id = "");
127
129 ms_session(const std::string userName,
130 const std::string userPassword);
131
133 ms_session(const std::string userName,
134 const std::string connectionID,
135 const std::string database);
136
138 ms_session(const int timeout, const std::string prefix);
139
140
141#if !defined(DOXYGEN_SHOULD_SKIP_THIS)
142 ms_session(const ms_session& src);
143#endif
144 /* SWIG function dispatcher fails in Perl 5.12 for some reason, and
145 * tries to use ms_session(const ms_security&, const std::string&) as
146 * the constructor for cases such as ms_session(300, "score_gif")...
147 * This constructor is supposed to be for internal use anyway, which
148 * is why it is defined out.
149 */
150#if !defined(DOXYGEN_SHOULD_SKIP_THIS) && !defined(SWIG)
151 ms_session(const ms_security &sec,
152 const std::string &session_id);
153 ms_session(const ms_security &sec,
154 const ms_user & user);
155 ms_session& operator =(const ms_session& right);
156#endif
157
158 ~ms_session();
159
160 public:
162 std::string getID() const;
163
165 int getUserID() const;
166
168 std::string getUserName() const;
169
171 std::string getFullUserName() const;
172
174 std::string getEmailAddress() const;
175
177 bool isSecurityEnabled() const;
178
180 time_t getLastAccessed() const;
181
183 time_t getTimeout() const;
184
186 std::string getIPAddress() const;
187
189 matrix_science::ms_security_tasks getPermittedTasks() const;
190
192 bool setPermittedTasks(const matrix_science::ms_security_tasks & val);
193
195 std::map<std::string, std::string> getParams() const;
196
198 bool isPermitted(const int taskID) const;
199
201 bool isPermitted_long(const int taskID, const long value) const;
202
204 bool isPermitted_double(const int taskID, const double value) const;
205
207 bool isPermitted_string(const int taskID, const std::string value) const;
208
210 bool isFastaPermitted(const std::string database) const;
211
213 bool canResultsFileBeViewed(const int userID) const;
214
216 bool saveStringParam(const std::string name, const std::string param);
217
219 bool saveIntParam(const std::string name, int param);
220
222 bool saveLongParam(const std::string name, long param);
223
225 bool saveTimeParam(const std::string name, time_t param);
226
228 bool saveDoubleParam(const std::string name, double param);
229
231 bool saveBoolParam(const std::string name, bool param);
232
233#ifndef SWIG
235 bool getStringParam(const std::string name, std::string & param) const;
236#endif
238 std::string getStringParam(const std::string name) const;
239
241 bool getIntParam(const std::string name, int & param) const;
242
244 int getIntParam(const std::string name) const;
245
247 bool getLongParam(const std::string name, long & param) const;
248
250 long getLongParam(const std::string name) const;
251
253 bool getTimeParam(const std::string name, time_t & param) const;
254
256 time_t getTimeParam(const std::string name) const;
257
259 bool getDoubleParam(const std::string name, double & param) const;
260
262 double getDoubleParam(const std::string name) const;
263
265 bool getBoolParam(const std::string name, bool & param) const;
266
268 bool clearParam(const std::string name);
269
271 bool destroy();
272
274 bool isTimedOut() const;
275
277 matrix_science::ms_user::usertype getUserType() const;
278
280 bool update(const ms_security & sec);
281
283 std::vector<int> getSpoofableUsers() const;
284
285 private:
286 typedef std::map<std::string, std::string> param_t;
287 std::string sessionID_;
288 param_t params_;
289 param_t customParams_;
290 typedef std::set<std::string> cpIdentifier_t;
291 cpIdentifier_t systemIdentifiers_;
292 ms_security_tasks permittedTasks_;
293 bool saveParamShouldSaveFile_;
294 bool allowParamAndFileSaving_;
295
296 void init();
297 bool loadSessionFromFile(const ms_security * const sec);
298 bool saveSessionToFile(const ms_security * const sec);
299 void setDisabledSession(const ms_security_options & opts);
300 bool setCommandLineSession(const ms_security_options & secOpt);
301 bool setGuestSession();
302 bool doesSessionFileExist(const std::string sess);
303 bool getAllParams(const ms_user & u, const ms_security & sec);
304 std::string getSessionIDFromUser(const ms_user & user);
305 std::string getWebSvrAuthSessionID(std::string userName = "");
306 bool checkIPAddressOrComputerName(const std::string ipAddress,
307 std::string & sessionID);
308 bool checkAgentString(std::string & sessionID);
309 bool validateIntegraPassword(const ms_user & u,
310 const ms_security_options & secOpt,
311 const std::string & userPassword,
312 std::string & session_id,
313 int & errorFlag) const;
314 bool verifyIntegraConnection() const;
315 bool isSessionIdentical(const ms_session & sess) const;
316 void copyFrom(const ms_session * src);
317 void createSessionFromID(const std::string session_id);
318 }; // end of security_group
320}
321#endif // !defined(mascot_session_DA3EC794_90F8_4c4f_AD5D_13C3B6971A51__INCLUDED_)
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_security_options
Options for the Mascot security system.
Definition: ms_security_options.hpp:46
matrix_science::ms_security_tasks
Each group has permission to do one or more tasks. This class defines a collection of tasks.
Definition: ms_security_tasks.hpp:51
matrix_science::ms_security
The main security class to be used by the administration application.
Definition: ms_security.hpp:94
matrix_science::ms_session
Use this class to determine if a user is logged in and if they have 'permission' to perform tasks.
Definition: ms_security_session.hpp:123
matrix_science::ms_user
This class will normally only be used by Mascot Security Administration applications.
Definition: ms_security_user.hpp:49
matrix_science::ms_user::usertype
usertype
Definitions for types of user.
Definition: ms_security_user.hpp:57
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security_task.hpp Source File

  • inc
ms_security_task.hpp
1/*
2##############################################################################
3# file: ms_security_task.hpp #
4# 'msparser' toolkit #
5# Encapsulates Mascot security as used in authentication #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2004 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19
20
21#if !defined(ms_sec_task_INCLUDED_)
22#define ms_sec_task_INCLUDED_
23
24
25// Includes from the standard template library
26#include <string>
27#include <set>
28#include <time.h>
29#include <vector>
30
31namespace matrix_science {
32
38
50 class MS_MASCOTRESFILE_API ms_security_task
51 {
52 public:
54
62 enum paramType
63 {
64 TYPE_BOOL = 0x0000,
65 TYPE_EQ_LONG = 0x0001,
66 TYPE_LTE_LONG = 0x0002,
67 TYPE_GTE_LONG = 0x0003,
68 TYPE_LONG_ARRAY = 0x0004,
69 TYPE_EQ_DOUBLE = 0x0005,
70 TYPE_LTE_DOUBLE = 0x0006,
71 TYPE_GTE_DOUBLE = 0x0007,
72 TYPE_DOUBLE_ARRAY = 0x0008,
73 TYPE_EQ_STRING = 0x0009,
74 TYPE_STRING_ARRAY = 0x000A,
75 TYPE_USERS_ARRAY = 0x000B,
76 TYPE_ALL_USERS_ARRAY= 0x000C
77 };
78
80 ms_security_task();
81
83 ~ms_security_task();
84
85 // Copying constructor for c++ programs - don't document
86 ms_security_task(const ms_security_task& src);
87
88#ifndef SWIG
89 // Assignment operator for c++ programs - don't document
90 ms_security_task& operator=(const ms_security_task& right);
91#endif
93 int getID() const;
94
96 void setID(const int id);
97
99 std::string getConstantName() const;
100
101 void setConstantName(const std::string value);
102
104 std::string getNotes() const;
105
106 void setNotes(const std::string value);
107
109 std::string getDescription() const;
110
111 void setDescription(const std::string value);
112
114 paramType getType() const;
115
116 void setType(const paramType value);
117
119 void clearParams();
120
122 void setParams(const std::string value);
123
125 bool addLongParam(const long value);
126
128 bool addDoubleParam(const double value);
129
131 bool addStringParam(const std::string value);
132
134 std::vector<long> getLongParams() const;
135
137 std::vector<double> getDoubleParams() const;
138
140 std::vector<std::string> getStringParams() const;
141
143 std::string getAllParamsAsString() const;
144
146 bool isPermitted() const;
147
149 bool isPermitted_long(const long value) const;
150
152 bool isPermitted_double(const double value) const;
153
155 bool isPermitted_string(const std::string value) const;
156
157 private:
158 int id_;
159 std::string description_;
160 std::string notes_;
161 std::string constantName_;
162 paramType type_;
163 std::set<long> longParams_;
164 std::set<double> doubleParams_;
165 std::set<std::string> stringParams_;
166
167 void copyFrom(const ms_security_task* src);
168 }; // end of security_group
170}
171
172#endif // !defined(ms_sec_task_INCLUDED_)
matrix_science::ms_security_task
Each group has permission to do one or more tasks. This class defines an individual task.
Definition: ms_security_task.hpp:51
matrix_science::ms_security_task::paramType
paramType
Definitions for parameter type.
Definition: ms_security_task.hpp:63
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security_tasks.hpp Source File

  • inc
ms_security_tasks.hpp
1/*
2##############################################################################
3# file: ms_security_tasks.hpp #
4# 'msparser' toolkit #
5# Encapsulates Mascot security as used in authentication #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2004 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
12# $Author: francoisr@matrixscience.com $ #
13# $Date: 2023-03-30 14:50:13 +0100 $ #
14# $Revision: 2f46535a8719ebb26a29bd04395eac8f0a9d9eeb | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19
20
21#if !defined(ms_security_tasks_INCLUDED_)
22#define ms_security_tasks_INCLUDED_
23
24
25// Includes from the standard template library
26#include <string>
27#include <map>
28#include <time.h>
29#include <vector>
30
31namespace matrix_science {
32
38
50 class MS_MASCOTRESFILE_API ms_security_tasks: public ms_errors
51 {
52 public:
54
63 enum TASKID
64 {
65 SECTASK_ALLOWPMF = 1,
66 SECTASK_ALLOWMSMS = 2,
67 SECTASK_ALLOWMSMSNOENZYME = 3,
68 SECTASK_ALLOWPMFNOENZYME = 4,
69 SECTASK_MAXCONCURRENTSEARCHES = 5,
70 SECTASK_MAXJOBPRIORITY = 6,
71 SECTASK_MAXQUERIES = 7,
72 SECTASK_MAXEXECUTIONTIME = 8,
73 SECTASK_ALLFASTA = 9,
74 SECTASK_NAMEDFASTA = 10,
75 SECTASK_MAXVARMODS = 11,
76 SECTASK_MAXETVARMODS = 12,
77
78 SECTASK_SEESEARCHINGROUP = 13,
79 SECTASK_SEEALLSEARCHESWITHUSERID= 14,
80 SECTASK_SEEOLDSEARCHES = 15,
81 SECTASK_USEMSREVIEWEXE = 16,
82
83 SECTASK_VIEWCONFIGUSINGMSSTATUS = 17,
84 SECTASK_MODIFYOWNPROFILE = 18,
85
86 SECTASK_DAEMONCLIENT = 19,
87 SECTASK_DISTILLERCLIENT = 20,
88 SECTASK_ALLOWSPOOFOTHERUSER = 22,
89 SECTASK_INTEGRASYSTEMACCOUNT = 23,
90 SECTASK_BIOTOOLSBATCH = 24,
91 SECTASK_SPOOFNAMEDGROUPSONLY = 25,
92 SECTASK_DOWNLOAD_DISTILLER_XML = 26,
93 SECTASK_UPLOAD_DISTILLER_XML = 27,
94
95 SECTASK_ADMINPAGES = 30,
96 SECTASK_ACCESSDBSETUP = 31,
97 SECTASK_USEMSSTATUSEXE = 32,
98 SECTASK_MSSTATUSEXECLUSTER = 33,
99 SECTASK_MSSTATUSEXERETRYDB = 34,
100 SECTASK_KILLTASKINGROUP = 35,
101 SECTASK_KILLALLTASK = 36,
102 SECTASK_VIEWCONFIG = 37,
103 SECTASK_EDITCONFIG = 38,
104
105 SECTASK_MAXETACCESSIONS = 50,
106 SECTASK_MAXNOENZQUERIES = 51,
107 SECTASK_MAXFASTAFILES = 52,
108 SECTASK_DENYQUANT = 53,
109 SECTASK_DATAURLPROTOCOLS = 54,
110 SECTASK_DATAURLMAXSIZE = 55,
111
112 SECTASK_SEESEARCHINANYGROUP = 60,
113
114 MISECTASK_ACCESS =100,
115 MISECTASK_PROTEINAPPROVAL =101,
116 MISECTASK_ADDIMPORTFILTER =102,
117 MISECTASK_ADMIN =103,
118 MISECTASK_ADDCUSTOMREPORT =104,
119 MISECTASK_DELETECUSTOMREPORT =105,
120 MISECTASK_ADDEXCLUSIONFILE =106,
121 MISECTASK_DELETEEXCLUSIONFILE =107,
122 MISECTASK_SENDNOTIFICATION =108
123 };
124
126 ms_security_tasks();
127
129 ~ms_security_tasks();
130
131 // Copying constructor for c++ programs - don't document
132 ms_security_tasks(const ms_security_tasks& src);
133
135 ms_security_tasks(const char * filename);
136
137#ifndef SWIG
138 // Assignment operator for c++ programs - don't document
139 ms_security_tasks& operator=(const ms_security_tasks& right);
140#endif
142 bool loadFromFile(const char * filename);
143
145 bool saveToFile(const char * filename);
146
148 bool addTask(const ms_security_task & task);
149
151 bool removeTask(const int taskID);
152
154 void removeAllTasks();
155
157 bool isPermitted(const int taskID) const;
158
160 bool isPermitted_long(const int taskID, const long value) const;
161
163 bool isPermitted_double(const int taskID, const double value) const;
164
166 bool isPermitted_string(const int taskID, const std::string value) const;
167
169 bool isFastaPermitted(const std::string database) const;
170
172 int getNumberOfTasks() const;
173
175 ms_security_task getTask(const int num) const;
176
178 ms_security_task getTaskFromID(const int taskID) const;
179
181 bool isTaskExists(const int taskID) const;
182
184 bool updateTask(const ms_security_task & task);
185#ifndef SWIG
186 ms_security_tasks & operator+=(const ms_security_tasks & a);
187#endif
189 std::string getDiffsAsText(const ms_security_tasks & old);
190
191 // Don't document
192 void updateAllUsersTasks(const std::set<int> & allUsers);
193
194 private:
195 typedef std::map<int, ms_security_task> tasksSet;
196 tasksSet tasks_;
197
198 void copyFrom(const ms_security_tasks* src);
199 }; // end of security_group
201
202}
203
204#endif // !defined(ms_security_tasks_INCLUDED_)
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_security_task
Each group has permission to do one or more tasks. This class defines an individual task.
Definition: ms_security_task.hpp:51
matrix_science::ms_security_tasks
Each group has permission to do one or more tasks. This class defines a collection of tasks.
Definition: ms_security_tasks.hpp:51
matrix_science::ms_security_tasks::TASKID
TASKID
Definitions for TASKID.
Definition: ms_security_tasks.hpp:64
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_security_user.hpp Source File

  • inc
ms_security_user.hpp
1/*
2##############################################################################
3# file: ms_security_user.hpp #
4# 'msparser' toolkit #
5# Encapsulates a mascot user as used in authentication #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2004 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19
20
21#if !defined(ms_security_user_INCLUDED_)
22#define ms_security_user_INCLUDED_
23
24
25// Includes from the standard template library
26#include <string>
27#include <set>
28#include <vector>
29#include <map>
30#include <time.h>
31
32
33namespace matrix_science {
39
48 class MS_MASCOTRESFILE_API ms_user
49 {
50
51 public:
53
56 enum usertype
57 {
58 USER_SECURITY_DISABLED = 0x0000,
59 USER_NORMAL = 0x0001,
60 USER_INTEGRA = 0x0002,
61 USER_COMPUTER_NAME = 0x0003,
62 USER_IP_ADDRESS = 0x0004,
63 USER_AGENT_STRING = 0x0005,
64 USER_WEBAUTH = 0x0006
65 };
66
68
71 enum systemids
72 {
73 USERID_SECURITY_DISABLED= 0x0000,
74 USERID_GUEST = 0x0001,
75 USERID_ADMINISTRATOR = 0x0002,
76 USERID_CMDLINE = 0x0003,
77 USERID_DAEMON = 0x0004,
78 USERID_PUBLIC_SEARCHES = 0x0005,
79 USERID_INTEGRA_SYSTEM = 0x0006,
80 USERID_LAST = 0x0007
81 };
82
84 ms_user(const int userID,
85 const std::string userName,
86 const std::string password,
87 const long passwordExpiry,
88 const std::string fullName,
89 const std::string emailAddress,
90 const usertype userType,
91 const bool enabled);
92
94 ms_user();
95
96 // Copying constructor for c++ programs - don't document
97 ms_user(const ms_user &src);
98
99#ifndef SWIG
100 // Assignment operator for c++ programs - don't document
101 ms_user & operator=(const ms_user & right);
102#endif
103 ~ms_user();
104
106 usertype getUserType() const;
107
109 void setUserType(usertype newVal);
110
112 std::string getFullName() const;
113
115 void setFullName(std::string newVal);
116
118 std::string getEncryptedPassword() const;
119
121 void setEncryptedPassword(std::string newVal);
122
124 void setPassword(std::string barePassword);
125
127 bool validatePassword(const std::string pwd, int & errorFlag) const;
128
130 time_t getPasswordExpiry() const;
131
133 void setPasswordExpiry(time_t newVal);
134
136 int getID() const;
137
139 void setID(int newVal);
140
142 std::string getName() const;
143
145 void setName(std::string newVal);
146
148 bool isAccountEnabled() const;
149
151 void setAccountEnabled(bool newVal);
152
154 std::string getEmailAddress() const;
155
157 void setEmailAddress(std::string newVal);
158
160 bool hasPasswordExpired() const;
161
163 bool saveStringParam(const std::string name, const std::string param);
164
165#ifndef SWIG
167 bool getStringParam(const std::string name, std::string & param) const;
168#endif
169
171 std::string getStringParam(const std::string name) const;
172
174 bool clearParam(const std::string name);
175
176#ifndef SWIG
177#ifndef DOXYGEN_SHOULD_SKIP_THIS
178 typedef std::map<std::string, std::string> customParams_t;
179 customParams_t getAllCustomParams() const { return params_; }
180#endif
181#endif
182
183 private:
184 int userID_;
185 std::string userName_;
186 std::string fullName_;
187 std::string encryptedPassword_;
188 time_t passwordExpiry_;
189 std::string emailAddress_;
190 bool accountEnabled_;
191 usertype userType_;
192 customParams_t params_;
193
194 void copyFrom(const ms_user * src);
195 }; // end of security_group
197}
198#endif // !defined(ms_security_user_INCLUDED_)
matrix_science::ms_user
This class will normally only be used by Mascot Security Administration applications.
Definition: ms_security_user.hpp:49
matrix_science::ms_user::usertype
usertype
Definitions for types of user.
Definition: ms_security_user.hpp:57
matrix_science::ms_user::systemids
systemids
Definitions for predefined users.
Definition: ms_security_user.hpp:72
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_shapiro_wilk.hpp Source File

  • inc
ms_shapiro_wilk.hpp
1/*
2##############################################################################
3# File: ms_shapiro_wilk.hpp #
4# Mascot Parser toolkit #
5# Include file for Shapiro-Wilk W test (statistical algorithm) #
6##############################################################################
7# $Source: parser/inc/ms_shapiro_wilk.hpp $
8# $Author: villek@matrixscience.com $
9# $Date: 2018-07-30 16:23:53 +0100 $
10# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
11##############################################################################
12*/
13/*
14##############################################################################
15# Applied Statistics algorithms #
16# #
17# Translated and adapted from routines that originally appeared in the #
18# Journal of the Royal Statistical Society Series C (Applied Statistics) #
19# and made available through StatLib http://lib.stat.cmu.edu/ #
20# #
21# The implementation and source code for this algorithm is available as a #
22# free download from http://www.matrixscience.com/msparser.html #
23# to conform with the requirement that no fee is charged for their use #
24##############################################################################
25*/
26
27
28#ifndef MS_SHAPIRO_WILK_HPP
29#define MS_SHAPIRO_WILK_HPP
30
31
32// Includes from the standard template library
33#include <string>
34#include <deque>
35#include <list>
36#include <vector>
37#include <set>
38#include <map>
39
40namespace matrix_science {
41 class ms_quant_stats;
42
50
95 class MS_MASCOTRESFILE_API ms_shapiro_wilk
96 {
97 public:
98 ms_shapiro_wilk();
99 ~ms_shapiro_wilk();
100
102 ms_shapiro_wilk(std::deque<std::pair<size_t,double> > x, long n, long n1, long n2);
103
105 void calculate(long n, long n1, long n2);
106
108 void appendSampleValue(double y);
109
111 void clearSampleValues();
112
114 double getResult() const;
115
117 double getPValue() const;
118
120 double getErrorCode() const;
121
122 private:
123 bool init_;
124 double w_; // The Shapiro-Wilks W-statistic.
125 double pw_; // the P-value for w
126 int ifault_; // error indicator
127 std::deque<double> a_;
128 std::deque<std::pair<size_t,double> > x_;
129
130 public:
132 static void swilk(bool init, std::deque<std::pair<size_t,double> > x, long n, long n1, long n2, std::deque<double> &a, double &w, double &pw, int &ifault);
133
134 private:
136 static double poly(const double *cc, int nord, double x);
138 static double ppnd7(double p,int &ifault);
140 static double alnorm(double x,bool upper);
141
142 static long sign(long x,long y);
143 };
144 // end of quantitation_group
146} // matrix_science
147
148
149#endif // MS_SHAPIRO_WILK_HPP
150/*------------------------------- End of File -------------------------------*/
matrix_science::ms_shapiro_wilk
The Shapiro-Wilk W test.
Definition: ms_shapiro_wilk.hpp:96
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_spectral_lib_entry.hpp Source File

  • inc
ms_spectral_lib_entry.hpp
1/*
2##############################################################################
3# File: ms_spectral_lib_entry.hpp #
4# Mascot Parser toolkit #
5# Encapsulates a single entry from a spectral library file #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 2015 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Source: parser/inc/ms_spectral_lib_entry.hpp $
13# $Author: francoisr@matrixscience.com $
14# $Date: 2021-05-27 10:03:04 +0100 $
15# $Revision: a47aab4c911db687b9c37e6e2e3e9b23174da535 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
16##############################################################################
17*/
18
19#ifndef MS_SPECTRAL_LIB_ENTRY
20#define MS_SPECTRAL_LIB_ENTRY
21
22
23// Includes from the standard template library
24
25#include <map>
26#include <string>
27
28
29namespace matrix_science {
30
38
67 class MS_MASCOTRESFILE_API ms_spectral_lib_entry : public ms_errors
68 {
69 public:
71
76 enum WHAT_TO_ANNOTATE {
77 ANNOTATE_NONE,
78 ANNOTATE_REPLACE_ALL,
79 ANNOTATE_REPLACE_QUESTION_MARKS,
80 ANNOTATE_REPLACE_IF_ALL_EMPTY
81 };
82
84 ms_spectral_lib_entry();
85
87 ms_spectral_lib_entry(const ms_spectral_lib_entry & src);
88
90 ms_spectral_lib_entry(const std::string & entry, const std::string & fileName, const ms_spectral_lib::FILE_FORMAT format);
91
93 ms_spectral_lib_entry(const std::vector<std::string> & entry, const std::string & fileName, const ms_spectral_lib::FILE_FORMAT format);
94
96 virtual ~ms_spectral_lib_entry();
97
99 void copyFrom(const ms_spectral_lib_entry* right);
100
101#ifndef SWIG
103 ms_spectral_lib_entry& operator=(const ms_spectral_lib_entry& right);
104#endif
105
107 const std::string get() const;
108
110 std::string getLine(const char * key) const;
111
113 std::string getName() const;
114
116 double getPrecursorMZ() const;
117
119 int getCharge() const;
120
122 std::string getSequence() const;
123
125 std::string getComment() const;
126
128 std::string getCommentField(const char * fieldName) const;
129
131 int getMods(std::vector<std::string> & names,
132 std::vector<int> & positions) const;
133
135 int getMods(std::vector<std::string> & names,
136 std::vector<int> & positions,
137 bool & anyModfileStyleName,
138 std::string & modsWithoutSpecificities) const;
139
141 int getNumPeaks() const;
142
144 double getMW() const;
145
147 std::vector<std::string> getPeakList(bool convertToNISTformat = false) const;
148
150 matrix_science::ms_spectral_lib_peak_list getPeakListObject() const;
151
153 std::string getPeakListChecksum() const;
154
156 std::string getFileName() const;
157
159 bool annotatePeaks(const WHAT_TO_ANNOTATE whatToAnnotate, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, const ms_umod_configfile * unimod = 0);
160
162 void clearAnnotation();
163
164 private:
165 bool parseLines(const std::vector<std::string> & lines);
166 bool parseMSPLines(const std::vector<std::string> & lines, ms_spectral_lib::FILE_FORMAT format);
167 bool parseXHunterLines(const std::vector<std::string> & lines);
168
169 typedef std::map<std::string, std::string> values_t;
170 values_t values_;
171 std::vector<std::string> originalLines_;
172 ms_spectral_lib_peak_list peakList_;
173 ms_spectral_lib::FILE_FORMAT format_;
174 std::string fileName_;
175 }; // class ms_spectral_lib_entry
176 // end of tools_group
178} // namespace matrix_science
179
180#endif // MS_SPECTRAL_LIB_ENTRY
181
182/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_spectral_lib_entry
This class is used to encapsulate a single entry, i.e. single spectrum from a NIST ....
Definition: ms_spectral_lib_entry.hpp:68
matrix_science::ms_spectral_lib_entry::WHAT_TO_ANNOTATE
WHAT_TO_ANNOTATE
Used by annotatePeaks to specify if existing annotation should be overwritten.
Definition: ms_spectral_lib_entry.hpp:76
matrix_science::ms_spectral_lib_entry::ANNOTATE_NONE
@ ANNOTATE_NONE
Don't perform any annotation.
Definition: ms_spectral_lib_entry.hpp:77
matrix_science::ms_spectral_lib_entry::ANNOTATE_REPLACE_QUESTION_MARKS
@ ANNOTATE_REPLACE_QUESTION_MARKS
Only annotate if ms_spectral_lib_peak_list::getPeakAnnotationLevel returns ms_spectral_lib_peak_list:...
Definition: ms_spectral_lib_entry.hpp:79
matrix_science::ms_spectral_lib_entry::ANNOTATE_REPLACE_ALL
@ ANNOTATE_REPLACE_ALL
Replace all existing annotation.
Definition: ms_spectral_lib_entry.hpp:78
matrix_science::ms_spectral_lib_peak_list
This class is used to encapsulate a peak list from a single spectrum in a NIST .msp or a SpectraST ....
Definition: ms_spectral_lib_peak_list.hpp:39
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_spectral_lib::FILE_FORMAT
FILE_FORMAT
Definition: ms_spectral_lib_peak.hpp:48
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_spectral_lib_file.hpp Source File

  • inc
ms_spectral_lib_file.hpp
1/*
2##############################################################################
3# File: ms_nist_msp.hpp #
4# Mascot Parser toolkit #
5# Encapsulates spectral library files (e.g. msp, sptext) #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 2015 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Source: parser/inc/ms_spectral_lib_file.hpp $
13# $Author: dcreasy@matrixscience.com $
14# $Date: 2019-10-23 11:32:40 +0100 $
15# $Revision: e1e932b0e014aa84a197578948d47baeca33fd07 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
16##############################################################################
17*/
18
19#ifndef MS_SPECTRAL_LIB_FILE
20#define MS_SPECTRAL_LIB_FILE
21
22
23// Includes from the standard template library
24
25#include <map>
26#include <set>
27#include <string>
28
29
30namespace matrix_science {
31
38
65 class MS_MASCOTRESFILE_API ms_spectral_lib_file : public ms_errors
66 {
67 public:
69 ms_spectral_lib_file(const char * fileName, const char * regexForAccession, const char * cdbFileName = 0);
70
71#ifndef SWIG
73 ms_spectral_lib_file(const char * fileName, const char * regexForAccession, const char * cdbFileName, const std::map<std::string, std::string> & modificationAliases);
74#endif
75
77 ~ms_spectral_lib_file();
78
80 int getNumEntries() const;
81
83 int getNumResidues() const;
84
86 std::vector<int> findEntries(const char * sequence, const char * checksum = 0, const char * accession = 0, const char * mods=0) const;
87
89 ms_spectral_lib_entry getEntryFromNumber(const int number) const;
90
92 std::vector<std::string> getEntryFromNumberAsText(const int number) const;
93
94
96 std::string getAccessionFromNumber(const int number) const;
97
99 std::string getChecksumFromNumber(const int number) const;
100
102 std::string getSequenceFromNumber(const int number) const;
103
105 std::string getModsFromNumber(const int number) const;
106
108 double getPrecursorMZFromNumber(const int number) const;
109
111 int getPrecursorChargeFromNumber(const int number) const;
112
114 std::vector<std::string> getAllMods() const;
115
117 ms_spectral_lib::FILE_FORMAT getFormat() const;
118
120 bool saveAs(const char * fileName,
121 const bool replaceProteinName = true,
122 ms_spectral_lib::FILE_FORMAT fileFormat = ms_spectral_lib::FORMAT_NIST_MSP,
123 const int startNumber = 1,
124 const int endNumber = -1,
125 const ms_spectral_lib_entry::WHAT_TO_ANNOTATE whatToAnnotate = ms_spectral_lib_entry::ANNOTATE_REPLACE_QUESTION_MARKS,
126 const double annotateTol = 0.6,
127 const char * annotateTolu = "Da",
128 const ms_umod_configfile * unimod = 0) const;
129
131 std::string getStatsInformation() const;
132
134 std::string getFileName() const;
135
137 long getQmatch(double minMz, double maxMz) const;
138
140 bool verifyThatModsAreInUnimod(const ms_umod_configfile & unimod);
141
142 private:
143 //Do not copy this object
144 ms_spectral_lib_file(const ms_spectral_lib_file & src);
145 ms_spectral_lib_file& operator=(const ms_spectral_lib_file & right);
146
147 struct sequentialIndex_t {
148 std::string accession;
149 std::string checksum;
150 std::string sequence;
151 std::string mods;
152 double precursorMZ;
153 int precursorCharge;
154 OFFSET64_T fileOffset;
155 };
156 void initialise(const char * fileName, const char * regexForAccession, const char * cdbFileName, const std::map<std::string, std::string> & aliases);
157 bool readFile(int recordNumber) const;
158 void getline(std::string & str) const;
159 ms_errs::err getEntryAsText(const int number, std::vector<std::string> & lines, std::string & errorMsg) const;
160
161 void saveIndexes(const ms_spectral_lib_entry & msp,
162 const OFFSET64_T fileOffset);
163 OFFSET64_T getFileOffsetFromId(int number) const;
164 const char * getSpectrumDelimiter() const;
165
166 int applyModAliases(const std::map<std::string, std::string> & aliases);
167 void replaceModAliases(std::string & comment, const ms_spectral_lib_entry & spect) const;
168
169 // the following are always valid - with or without a cdb file
170 std::string fileName_;
171 mutable int numEntries_; // May be less than the total in the file if it's being read on demand
172 mutable int numResidues_; // May be less than the total in the file if it's being read on demand
173 ms_parserule parseRule_;
174 mutable bool wholeFileRead_;
175 FILE * ifs_;
176 mutable ms_spectral_lib::FILE_FORMAT fileFormat_;
177
178 // the following are valid when creating or using the cdb file
179 ms_tinycdb * cdb_;
180
181 // the following are only valid when no cdb specified *or* when *first creating* the cdb file
182 mutable OFFSET64_T offsetToNextRecord_;
183 typedef std::map<std::string, std::vector<int> > strLookup_t; // e.g. sequence => vector of spectra
184 std::vector<strLookup_t> lookup_;
185 std::vector<sequentialIndex_t> sequentialIndex_;
186 typedef std::map<std::string, std::string> modMap_t; // nameInMsp => nameInUnimod (or empty if no alias)
187 mutable modMap_t modsMap_;
188
189 typedef std::multiset<double> precursors_t;
190 mutable precursors_t precursors_;
191
192 }; // class ms_spectral_lib_file
193 // end of tools_group
195} // namespace matrix_science
196
197#endif // MS_SPECTRAL_LIB_FILE
198
199/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs::err
msg_num_t err
Definitions for error numbers.
Definition: ms_errors.hpp:41
matrix_science::ms_parserule
Represents a single regular expression parsing rule.
Definition: ms_parserule.hpp:38
matrix_science::ms_spectral_lib_entry
This class is used to encapsulate a single entry, i.e. single spectrum from a NIST ....
Definition: ms_spectral_lib_entry.hpp:68
matrix_science::ms_spectral_lib_entry::WHAT_TO_ANNOTATE
WHAT_TO_ANNOTATE
Used by annotatePeaks to specify if existing annotation should be overwritten.
Definition: ms_spectral_lib_entry.hpp:76
matrix_science::ms_spectral_lib_file
This class is used to encapsulate a complete NIST .msp, SpectraST .sptxt or X!Hunter ASL MGF file.
Definition: ms_spectral_lib_file.hpp:66
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_spectral_lib::FILE_FORMAT
FILE_FORMAT
Definition: ms_spectral_lib_peak.hpp:48
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_spectral_lib_peak.hpp Source File

  • inc
ms_spectral_lib_peak.hpp
1/*
2##############################################################################
3# File: ms_spectral_lib_peak_list.hpp #
4# Mascot Parser toolkit #
5# Encapsulates a single peak plus annotations for spectral library files #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 2015 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Source: parser/inc/ms_spectral_lib_peak.hpp $
13# $Author: dcreasy@matrixscience.com $
14# $Date: 2019-01-09 17:36:22 +0000 $
15# $Revision: 8cb0d9cae7732a8c4def8cb60456be4a3be7a559 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
16##############################################################################
17*/
18
19#ifndef MS_SPECTRAL_LIB_PEAK
20#define MS_SPECTRAL_LIB_PEAK
21
22
23// Includes from the standard template library
24
25#include <map>
26#include <string>
27
28
29namespace matrix_science {
30
40 namespace ms_spectral_lib {
48 enum FILE_FORMAT {
49 FORMAT_UNKNOWN,
50 FORMAT_NIST_MSP,
51 FORMAT_SPECTRAST,
52 FORMAT_MGF,
53 FORMAT_XHUNTER
54 };
55 };
56
58 class MS_MASCOTRESFILE_API ms_spectral_lib_peak
59 {
60 public:
62 ms_spectral_lib_peak(const std::string & text,
63 ms_spectral_lib::FILE_FORMAT format,
64 matrix_science::ms_errs & errs);
65
67 ms_spectral_lib_peak(const double mz,
68 const double intensity,
69 const std::string & annotation,
70 ms_spectral_lib::FILE_FORMAT format);
71
73 ms_spectral_lib_peak(const ms_spectral_lib_peak & src);
74
76 void copyFrom(const ms_spectral_lib_peak* right);
77
78#ifndef SWIG
80 ms_spectral_lib_peak& operator=(const ms_spectral_lib_peak& right);
81#endif
82
84 double getMz() const;
85
87 double getIntensity() const;
88
90 std::string getAnnotation(ms_spectral_lib::FILE_FORMAT format = ms_spectral_lib::FORMAT_NIST_MSP) const;
91
93 void setAnnotation(const std::string & annotation, ms_spectral_lib::FILE_FORMAT format);
94
96 void clearAnnotation();
97
99 double getDelta() const;
100
102 bool isMatchedToCalculatedPeak() const;
103
105 bool isSuspectAssignment() const;
106
108 bool getConsensusData(int * numerator, int * denominator, double * medianDeviation) const;
109
111 std::string asText(ms_spectral_lib::FILE_FORMAT format) const;
112
114 bool isValid() const;
115
117 static std::string getUnmatchedAnnotationStr(ms_spectral_lib::FILE_FORMAT format);
118
119
120 private:
121 bool valid_;
122 double mz_;
123 double intensity_;
124 std::string mzText_;
125 std::string intensityText_;
126 std::string annotation_;
127 ms_spectral_lib::FILE_FORMAT currAnnotationFormat_;
128 double delta_;
129 bool consensusDataAvailable_;
130 int consensusNumerator_;
131 int consensusDenominator_;
132 double medianDeviationOfConsensusPeaks_;
133 };
134
135 // end of tools_group
137} // namespace matrix_science
138
139#endif // MS_SPECTRAL_LIB_PEAK
140
141/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_spectral_lib_peak
This class is used to encapsulate a single fragment ion in a NIST .msp or a SpectraST ....
Definition: ms_spectral_lib_peak.hpp:59
matrix_science::ms_spectral_lib::FILE_FORMAT
FILE_FORMAT
Definition: ms_spectral_lib_peak.hpp:48
matrix_science::ms_spectral_lib::FORMAT_UNKNOWN
@ FORMAT_UNKNOWN
Unknown format.
Definition: ms_spectral_lib_peak.hpp:49
matrix_science::ms_spectral_lib::FORMAT_MGF
@ FORMAT_MGF
Mascot Generic Format. Only suitable for output.
Definition: ms_spectral_lib_peak.hpp:52
matrix_science::ms_spectral_lib::FORMAT_SPECTRAST
@ FORMAT_SPECTRAST
Institute for Systems Biology (ISB) SpectraST format.
Definition: ms_spectral_lib_peak.hpp:51
matrix_science::ms_spectral_lib::FORMAT_NIST_MSP
@ FORMAT_NIST_MSP
NIST MSP formt.
Definition: ms_spectral_lib_peak.hpp:50
matrix_science::ms_spectral_lib::FORMAT_XHUNTER
@ FORMAT_XHUNTER
X!HUNTER ASL MGF file format (2007.06.01)
Definition: ms_spectral_lib_peak.hpp:53
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_spectral_lib_peak_list.hpp Source File

  • inc
ms_spectral_lib_peak_list.hpp
1/*
2##############################################################################
3# File: ms_spectral_lib_peak_list.hpp #
4# Mascot Parser toolkit #
5# Encapsulates peak lists for spectral library files (e.g. msp, sptext) #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 2015 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Source: parser/inc/ms_spectral_lib_peak_list.hpp $
13# $Author: villek@matrixscience.com $
14# $Date: 2018-07-30 16:23:53 +0100 $
15# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
16##############################################################################
17*/
18
19#ifndef MS_SPECTRAL_LIB_PEAK_LIST
20#define MS_SPECTRAL_LIB_PEAK_LIST
21
22
23// Includes from the standard template library
24
25#include <vector>
26#include <map>
27#include <string>
28
29
30namespace matrix_science {
31
38 class MS_MASCOTRESFILE_API ms_spectral_lib_peak_list : public ms_errors
39 {
40 public:
42
49 enum PEAK_ANNOTATION_LEVEL {
50 ANNOT_LVL_NONE,
51 ANNOT_LVL_QUESTION_MARKS,
52 ANNOT_LVL_SOME_PEAKS,
53 ANNOT_LVL_CANNOT_ANNOTATE,
54 };
56 ms_spectral_lib_peak_list();
57
59 ~ms_spectral_lib_peak_list();
60
62 ms_spectral_lib_peak_list(std::vector<std::string> input, ms_spectral_lib::FILE_FORMAT format);
63
65 ms_spectral_lib_peak_list(const ms_spectral_lib_peak_list & src);
66
68 void copyFrom(const ms_spectral_lib_peak_list* right);
69
70#ifndef SWIG
72 ms_spectral_lib_peak_list& operator=(const ms_spectral_lib_peak_list& right);
73#endif
75 int getNumPeaks() const;
76
78 const ms_spectral_lib_peak * getPeak(const int pkNum) const;
79
81 void addPeaks(const std::vector<double> &vecMz, const std::vector<double> &vecIntensity);
82
84 void annotatePeaks(const ms_fragmentvector *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz);
85
86#ifndef SWIG
88 void annotatePeaks(const std::vector<ms_fragment> *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz);
89#endif
90
92 void clearAnnotation();
93
95 PEAK_ANNOTATION_LEVEL getPeakAnnotationLevel() const;
96
98 std::vector<std::string> asText(ms_spectral_lib::FILE_FORMAT format) const;
99
101 std::string getChecksum() const;
102
104 void setAnnotationLevel(PEAK_ANNOTATION_LEVEL level);
105
106 private:
107 void setAnnotationLevel(const ms_spectral_lib_peak & pk);
108
109 std::vector<ms_spectral_lib_peak> peakList_;
110 bool isConsensusSpectrum_;
111 PEAK_ANNOTATION_LEVEL annotationLevel_;
112 std::string checksum_;
113 };
114
115 // end of tools_group
117} // namespace matrix_science
118
119#endif // MS_SPECTRAL_LIB_PEAK_LIST
120
121/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_fragmentvector
Class for holding a list of ms_fragment objects.
Definition: ms_fragmentvector.hpp:47
matrix_science::ms_spectral_lib_peak_list
This class is used to encapsulate a peak list from a single spectrum in a NIST .msp or a SpectraST ....
Definition: ms_spectral_lib_peak_list.hpp:39
matrix_science::ms_spectral_lib_peak_list::PEAK_ANNOTATION_LEVEL
PEAK_ANNOTATION_LEVEL
Amount of annotation as returned by getAnnotationLevel()
Definition: ms_spectral_lib_peak_list.hpp:49
matrix_science::ms_spectral_lib_peak_list::ANNOT_LVL_QUESTION_MARKS
@ ANNOT_LVL_QUESTION_MARKS
In Parser 2.6.0, when calling ms_spectral_lib_file::saveAs(), the resulting file adds "?...
Definition: ms_spectral_lib_peak_list.hpp:51
matrix_science::ms_spectral_lib_peak_list::ANNOT_LVL_SOME_PEAKS
@ ANNOT_LVL_SOME_PEAKS
One or more peaks have annotation that is not just a "?".
Definition: ms_spectral_lib_peak_list.hpp:52
matrix_science::ms_spectral_lib_peak_list::ANNOT_LVL_CANNOT_ANNOTATE
@ ANNOT_LVL_CANNOT_ANNOTATE
A call to ms_spectral_lib_entry::annotatePeaks() or ms_spectral_lib_peak_list::annotatePeaks() failed...
Definition: ms_spectral_lib_peak_list.hpp:53
matrix_science::ms_spectral_lib_peak_list::ANNOT_LVL_NONE
@ ANNOT_LVL_NONE
None of the peaks have any annotation.
Definition: ms_spectral_lib_peak_list.hpp:50
matrix_science::ms_spectral_lib_peak
This class is used to encapsulate a single fragment ion in a NIST .msp or a SpectraST ....
Definition: ms_spectral_lib_peak.hpp:59
matrix_science::ms_spectral_lib::FILE_FORMAT
FILE_FORMAT
Definition: ms_spectral_lib_peak.hpp:48
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_sql_find.hpp Source File

  • src
  • resfile
  • impl
ms_sql_find.hpp
1#ifndef MS_SQL_FIND_HPP
2#define MS_SQL_FIND_HPP
3
4#ifdef _MSC_VER
5#if _MSC_VER >= 1900 && _MSC_VER < 1910
6#pragma warning(once : 4503)
7#endif
8#endif
9
10#include <sqlpp11/functions.h>
11#include <sqlpp11/select.h>
12
13#include "ms_peptidesummarybase.hpp"
14#include "ms_mascotresults.hpp"
15#include <private/strutils.hpp>
16#include <private/ms_sqlpp11_connection.hpp>
17#include <private/sql/mascot_search_results_v1_0.hpp>
18#include <private/sql/parser_cached_data_v1_0.hpp>
19
20using namespace matrix_science;
21
22namespace msparser_internal {
23
24 namespace ms_sql {
25 class HitIterator {
26 public:
27 HitIterator(const ms_peptidesummarybase & results, const int startHit, const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags, const std::vector<int>& q)
28 : startHit_(startHit), endHit_(-1), hit_(-1), compareFlags_(compareFlags), q_(q){
29 endHit_ = (compareFlags & ms_mascotresults::FC_RESTRICT_TO_HIT) ? startHit : results.getNumberOfHits();
30 }
31
32 bool operator()() {
33 if (hit_ == -1)
34 {
35 hit_ = startHit_;
36 return true;
37 }
38 if (!q_.empty())
39 {
40 return false;
41 }
42
43 if (startHit_ == 0 && hit_ == 0 && !(compareFlags_ & ms_mascotresults::FC_LOOP_FROM_UNASSIGNED))
44 {
45 return false;
46 }
47 else if (compareFlags_ & ms_mascotresults::FC_REVERSE)
48 {
49 hit_--;
50 if (hit_ < 0)
51 {
52 return false;
53 }
54 }
55 else
56 {
57 hit_++;
58 if (hit_ > endHit_)
59 {
60 hit_ = 0;
61 }
62 }
63 if (hit_ == 0 && !(compareFlags_ & ms_mascotresults::FC_LOOP_INTO_UNASSIGNED))
64 {
65 return false;
66 }
67 // if FC_LOOP_FROM_UNASSIGNED and FC_FORWARD then could go
68 // 1..numHits -> 0 -> 1 -> 2...
69 // ad infenitum. So, break the loop.
70 if (hit_ == startHit_)
71 {
72 return false;
73 }
74 return true;
75 }
76
77 int currentHit() const { return hit_; }
78 private:
79 const int startHit_;
80 int endHit_, hit_;
81 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags_;
82 const std::vector<int>& q_;
83 };
84
85 std::pair<double, double> _findRange(const std::string & str);
86
87 bool _isFromPeptidesTable(const ms_mascotresults::FIND_FLAGS item);
88
89 bool _isFromSummaryQueryInfo(const ms_mascotresults::FIND_FLAGS item);
90
91 template<class QueryType, class QPTabType>
92 int _runQpsQuery(const ms_peptidesummarybase& pepSum,
93 const ms_mascotresults::FIND_FLAGS item,
94 const int queryShift,
95 ms_sqlpp11_connection& db, QueryType& query,
96 const QPTabType& qpTab,
97 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
98 const int hitId, std::vector<int>& q, std::vector<int>& p)
99 {
100 if (compareFlags & ms_mascotresults::FC_REVERSE)
101 {
102 query.where.add(qpTab.hitId <= hitId);
103 query.order_by.add(qpTab.hitId.desc());
104
105 }
106 else
107 {
108 query.where.add(qpTab.hitId >= hitId);
109 query.order_by.add(qpTab.hitId.asc());
110 }
111
112 // (1) If we want all the ranks, just extract the first rank
113 // for the first query that is selected
114 if (compareFlags & ms_mascotresults::FC_SEARCH_ALL_RANKS)
115 {
116 query.limit.set(1u);
117 }
118 query.order_by.add(qpTab.localQ.asc());
119 query.order_by.add(qpTab.p.asc());
120
121 int firstHitId = -1;
122 for (const auto& row : (db)(query))
123 {
124 const int currentHitId = sqlpp11_int32(row.hitId);
125 if (firstHitId == -1)
126 {
127 firstHitId = sqlpp11_int32(row.hitId);
128 }
129 if (currentHitId != firstHitId)
130 {
131 break; // We only want results for one hit
132 }
133 q.push_back(sqlpp11_int32(row.localQ) + queryShift);
134 p.push_back(sqlpp11_int32(row.p));
135 }
136 // (2) and add all the remaining ranks
137 if (compareFlags & ms_mascotresults::FC_SEARCH_ALL_RANKS)
138 {
139 ms_peptide* pep;
140 if (p.size()>0)
141 {
142 for (int rank=p.back()+1; rank<=pepSum.getMaxRankValue(); ++rank)
143 {
144 if (item == ms_peptidesummary::FT_PEPTIDE_EXP_MZ)
145 {
146 // See BUG#10793 to understand why this condition
147 if (pepSum.getPeptide(q.back(), rank, pep) && pep->getAnyMatch() )
148 {
149 q.push_back(q.back());
150 p.push_back(rank);
151 }
152 }
153 else
154 {
155 q.push_back(q.back());
156 p.push_back(rank);
157 }
158 }
159 }
160 }
161
162 return firstHitId;
163 }
164
165 template<class QueryType>
166 int _runProteinsQuery(ms_sqlpp11_connection& db, QueryType& query,
167 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
168 const int hitId,
169 std::vector<std::string>& accessions,
170 std::vector<int>& dbIndexes)
171 {
172 auto keepProt = [&](const int grouping) {
173 switch (grouping)
174 {
175 case ms_protein::GROUP_UNKNOWN : break;
176 case ms_protein::GROUP_NO : break; // A 'lead' protein.
177 case ms_protein::GROUP_SUBSET : // Contains a subset of peptides in one ore more other proteins.
178 if (compareFlags & ms_mascotresults::FC_PROTEIN_IGN_SUBSETS) {
179 return false;
180 }
181 break;
182
183 case ms_protein::GROUP_COMPLETE: // Contains an identical set of peptides to one or more other proteins.
184 if (compareFlags & ms_mascotresults::FC_PROTEIN_IGN_SAMESETS) {
185 return false;
186 }
187 break;
188
189 case ms_protein::GROUP_FAMILY :
190 if (compareFlags & ms_mascotresults::FC_PROTEIN_IGN_FAMILY) {
191 return false;
192 }
193 break;
194 default:
195 return true;
196 }
197 return true;
198 };
199
200 int firstHitId = -1;
201 for (const auto& row : (db)(query))
202 {
203 if ( keepProt(sqlpp11_int32(row.group)) )
204 {
205 const int currentHitId = sqlpp11_int32(row.hitId);
206 if (firstHitId == -1)
207 {
208 firstHitId = sqlpp11_int32(row.hitId);
209 }
210 if (currentHitId != firstHitId)
211 {
212 break; // We only want results for one hit
213 }
214 accessions.push_back(row.accessionStr);
215 dbIndexes.push_back( sqlpp11_int32(row.dbId) );
216 }
217 }
218 return firstHitId;
219 }
220
221 template<class QueryType, class AccTabType, class ProtTabType>
222 void _addHitOrderWhere(QueryType& query,
223 const AccTabType& accTab,
224 const ProtTabType& protTab,
225 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
226 const int hitId,
227 const int dbIdxRequired)
228 {
229 if (dbIdxRequired != -1)
230 {
231 query.where.add(protTab.dbId==dbIdxRequired);
232 }
233
234 if (compareFlags & ms_mascotresults::FC_REVERSE)
235 {
236 query.where.add(accTab.hitId <= hitId);
237 query.order_by.add(accTab.hitId.desc());
238 }
239 else
240 {
241 query.where.add(accTab.hitId >= hitId);
242 query.order_by.add(accTab.hitId.asc());
243 }
244
245
246 }
247
248 template<typename QueryType, typename PepTable>
249 void _addPepTabWhere(QueryType& pepQuery,
250 const PepTable& pepTab,
251 const ms_peptidesummarybase& pepSum,
252 const ms_mascotresults::FIND_FLAGS item,
253 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
254 const std::string& str,
255 const int queryShift)
256 {
257 auto addFixedModCond = [&] (std::string& residues) {
258 if (residues.empty())
259 {
260 return;
261 }
262
263 bool nTerm=false, cTerm=false;
264 if (residues.find("N_term") != residues.npos) {
265 nTerm = true;
266 residues.erase(residues.find("N_term"), strlen("N_term"));
267 }
268 if (residues.find("C_term") != residues.npos) {
269 cTerm = true;
270 residues.erase(residues.find("C_term"), strlen("C_term"));
271 }
272
273 std::string conditions;
274 if (nTerm)
275 {
276 // N-term residue is not modified by a variable mod
277 conditions += "varmods_string LIKE '0%' ";
278 }
279 if (cTerm)
280 {
281 if (nTerm)
282 {
283 conditions += "OR ";
284 }
285 // C-term residue is not modified by a variable mod
286 conditions += "varmods_string LIKE '%0' ";
287 }
288 if (conditions.empty())
289 conditions = "FALSE ";
290
291 for (char residue : residues)
292 {
293 // The fixed mod residue is not modified by a variable mod.
294 conditions += "OR SUBSTR(varmods_string, INSTR(peptide_str, '";
295 conditions += residue;
296 conditions += "')+1, 1)='0' ";
297 }
298 pepQuery.where.add(sqlpp::verbatim<sqlpp::boolean>(conditions));
299 };
300
301 auto addPepStrCond = [&] () {
302 switch (compareFlags & ms_mascotresults::FC_MASK_STR_PART)
303 {
304 case ms_mascotresults::FC_COMPLETESTR:
305 pepQuery.where.add(pepTab.sequence == str);
306 break;
307 case ms_mascotresults::FC_SUBSTR:
308 pepQuery.where.add(pepTab.sequence.like("%"+str+"%"));
309 break;
310 case ms_mascotresults::FC_STARTSTR:
311 pepQuery.where.add(pepTab.sequence.like(str+"%"));
312 break;
313 case ms_mascotresults::FC_STRTOK:
314 std::string conditions;
315 for (const char c : str)
316 {
317 conditions += "peptide_str LIKE %";
318 conditions += c;
319 conditions += "% OR";
320 }
321 conditions.erase( conditions.end()-2 ); // Remove last 'OR'
322 pepQuery.where.add(sqlpp::verbatim<sqlpp::boolean>(conditions));
323 break;
324 }
325 };
326
327 // TODO: Consider case insensitive comparisons
328 //bool caseInsensitive = ((compareFlags & ms_mascotresults::FC_MASK_CASE) == ms_mascotresults::FC_CASE_INSENSITIVE);
329
330 switch(item)
331 {
332 case ms_peptidesummary::FT_PEPTIDE_CALC_MZ:
333 {
334 auto bounds = _findRange(str);
335 pepQuery.where.add(pepTab.delta + pepTab.peptideMr >= bounds.first && pepTab.delta + pepTab.peptideMr < bounds.second);
336 break;
337 }
338 case ms_peptidesummary::FT_PEPTIDE_CALC_MR:
339 {
340 auto bounds = _findRange(str);
341 pepQuery.where.add(pepTab.peptideMr >= bounds.first && pepTab.peptideMr < bounds.second);
342 break;
343 }
344 case ms_peptidesummary::FT_PEPTIDE_STRING:
345 {
346 addPepStrCond();
347 break;
348 }
349 case ms_peptidesummary::FT_PEPTIDE_QUERY:
350 {
351 pepQuery.where.add(pepTab.queryId+queryShift==msparser_internal::strToInt(str));
352 break;
353 }
354 case ms_peptidesummary::FT_PEPTIDE_VARMOD:
355 {
356 pepQuery.where.add(pepTab.varmodsString.like("%"+str+"%") || pepTab.summedModsString.like("%"+str+"%"));
357 break;
358 }
359 case ms_peptidesummary::FT_PEPTIDE_FIXMOD:
360 {
361 // Number 1..20
362 int num = msparser_internal::strToInt(str);
363 std::string residues=pepSum.getResfile().params().getFixedModsResidues(num);
364 addFixedModCond(residues);
365 break;
366 }
367 default:
368 break;
369 }
370 }
371
372 template<typename QueryType, typename QInfoTable>
373 void _addQueryInfoWhere(QueryType& pepQuery,
374 const QInfoTable& qInfoTab,
375 const ms_mascotresults::FIND_FLAGS item,
376 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
377 const std::string& str)
378 {
379 auto bounds = _findRange(str);
380 if (item == ms_peptidesummary::FT_PEPTIDE_EXP_MZ)
381 {
382 pepQuery.where.add(qInfoTab.observedMZ >= bounds.first && qInfoTab.observedMZ < bounds.second);
383 }
384 else if (item == ms_peptidesummary::FT_PEPTIDE_EXP_MR)
385 {
386 pepQuery.where.add(qInfoTab.observedMr >= bounds.first && qInfoTab.observedMr < bounds.second);
387 }
388 }
389
390 template<typename QueryType, typename PepTable, typename EtTable>
391 void _addEtWhere(QueryType& query,
392 const PepTable& pepTab,
393 const EtTable& etTab,
394 const ms_mascotresults::FIND_FLAGS item,
395 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
396 const std::string& str,
397 const double tolerance,
398 const double toleranceFactor)
399 {
400 double targetDelta = msparser_internal::strToDouble(str);
401 if (tolerance > -1)
402 {
403 double lowerBound = targetDelta - tolerance;
404 double upperBound = targetDelta + tolerance;
405 query.where.add(etTab.mass >= lowerBound && etTab.mass < upperBound);
406 }
407 else // Tolerance relative to mass
408 {
409 // targetDelta is on the left hand side of the '>=' to avoid compile errors in sqlpp11
410 query.where.add(etTab.mass -targetDelta >= -(pepTab.peptideMr*toleranceFactor) && etTab.mass < ((pepTab.peptideMr*toleranceFactor) + targetDelta));
411 }
412 }
413
414 template<typename QueryType, typename SlTable>
415 void _addSlModWhere(QueryType& query,
416 const SlTable& slTab,
417 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
418 const std::string& str)
419 {
420 query.where.add(slTab.modName.like("%"+str+"%"));
421 }
422
423 template<typename QueryType, typename VarModTable, typename PepTable>
424 void _addVarModWhere(ms_sqlpp11_connection& db,
425 QueryType& query,
426 const VarModTable& varModTab,
427 const PepTable& pepTab,
428 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
429 const std::string& str)
430 {
431 sqlpp::msl_sqlite3::context_t printer{db.connection()};
432 const std::string modNumColStr = sqlpp::serialize(varModTab.modNum, printer).str();
433 // varModTab.modNum is an integer column and pepTab.varModsString is a text column.
434 // pepTab.varmodsString.like(varModTab.modNum) won't compile because their types are incompatible
435 query.where.add(varModTab.modName.like("%"+str+"%") && pepTab.varmodsString.like(sqlpp::verbatim<sqlpp::text>("'%'||"+modNumColStr+"||'%'")));
436 }
437
438 template<class PepTab, class SumQInfoTab, class PepEtModsTab, class SlModTab, class PepSlModTab, class VarModsTab>
439 int findPeptideItem(
440 const int paramsId,
441 const ms_peptidesummarybase& pepSum,
442 ms_sqlpp11_connection& db,
443 const std::tuple<PepTab, SumQInfoTab, PepEtModsTab, SlModTab, PepSlModTab, VarModsTab>& tabs,
444 const int hitId,
445 const ms_mascotresults::FIND_FLAGS item,
446 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
447 const std::string& str,
448 const int queryShift,
449 std::vector<int>& q,
450 std::vector<int>& p)
451 {
452 constexpr auto qpTab = parser_cached_data_v1_0::CachedProteinInference_qPList {};
453 int psmType = static_cast<int>(pepSum.typePeptides());
454
455 if (item == ms_peptidesummary::FT_PEPTIDE_QUERY)
456 {
457 auto sql =
458 sqlpp::dynamic_select(db.connection()).dynamic_flags().dynamic_columns(qpTab.hitId, qpTab.localQ, qpTab.p)
459 .from(qpTab)
460 .dynamic_where(qpTab.paramsId == paramsId && qpTab.queryShift == queryShift && qpTab.localQ == (msparser_internal::strToInt(str)-queryShift))
461 .dynamic_limit().dynamic_order_by();
462
463 return _runQpsQuery(pepSum, item, queryShift, db, sql, qpTab, compareFlags, hitId, q, p);
464 }
465 else if (_isFromPeptidesTable(item))
466 {
467 const auto& pepTab = std::get<0>(tabs);
468 auto sql =
469 sqlpp::dynamic_select(db.connection()).dynamic_flags().dynamic_columns(qpTab.hitId, qpTab.localQ, qpTab.p)
470 .from(qpTab
471 .join(pepTab).on(qpTab.localQ==pepTab.queryId && qpTab.p==pepTab.rankId))
472 .dynamic_where(pepTab.psmType == psmType && qpTab.paramsId == paramsId && qpTab.queryShift == queryShift)
473 .dynamic_limit().dynamic_order_by();
474
475 _addPepTabWhere(sql, pepTab, pepSum, item, compareFlags, str, queryShift);
476
477 return _runQpsQuery(pepSum, item, queryShift, db, sql, qpTab, compareFlags, hitId, q, p);
478
479 }
480 else if (_isFromSummaryQueryInfo(item))
481 {
482 const auto& qInfoTab = std::get<1>(tabs);
483 auto sql =
484 sqlpp::dynamic_select(db.connection()).dynamic_columns(qpTab.hitId, qpTab.localQ, qpTab.p)
485 .from(qpTab
486 .join(qInfoTab).on(qpTab.localQ==qInfoTab.queryId))
487 .dynamic_where(qInfoTab.psmType == psmType && qpTab.paramsId == paramsId && qpTab.queryShift == queryShift)
488 .dynamic_limit().dynamic_order_by();
489
490 _addQueryInfoWhere(sql, qInfoTab, item, compareFlags, str);
491
492 return _runQpsQuery(pepSum, item, queryShift, db, sql, qpTab, compareFlags, hitId, q, p);
493 }
494 else if (item == ms_peptidesummary::FT_PEPTIDE_ETMOD)
495 {
496 const auto& pepTab = std::get<0>(tabs);
497 const auto& etTab = std::get<2>(tabs);
498 int etPsm = static_cast<int>(ms_peptide::PSM_ERRTOL);
499 auto sql =
500 sqlpp::dynamic_select(db.connection()).dynamic_flags().dynamic_columns(qpTab.hitId, qpTab.localQ, qpTab.p)
501 .from(etTab
502 .join(qpTab).on(etTab.queryId==qpTab.localQ && etTab.rankId==qpTab.p)
503 .join(pepTab).on(etTab.queryId == pepTab.queryId && etTab.rankId == pepTab.rankId && etTab.psmType == pepTab.psmType))
504 .dynamic_where(etTab.psmType==etPsm && qpTab.paramsId == paramsId && qpTab.queryShift == queryShift)
505 .dynamic_limit().dynamic_order_by();
506
507 double tolerance = pepSum.getTolerance();
508 double toleranceFactor = pepSum.getToleranceFactor();
509 _addEtWhere(sql, pepTab, etTab, item, compareFlags, str, tolerance, toleranceFactor);
510
511 return _runQpsQuery(pepSum, item, queryShift, db, sql, qpTab, compareFlags, hitId, q, p);
512
513 }
514 else if (item == ms_peptidesummary::FT_PEPTIDE_SLMOD)
515 {
516 const auto& slTab = std::get<3>(tabs);
517 const auto& pepSlTab = std::get<4>(tabs);
518 int slPsm = static_cast<int>(ms_peptide::PSM_LIBRARY);
519 auto sql =
520 sqlpp::dynamic_select(db.connection()).dynamic_flags().dynamic_columns(qpTab.hitId, qpTab.localQ, qpTab.p)
521 .from(pepSlTab
522 .join(qpTab).on(pepSlTab.queryId == qpTab.localQ && pepSlTab.rankId == qpTab.p)
523 .join(slTab).on(pepSlTab.modNum == slTab.modNum))
524 .dynamic_where(pepSlTab.psmType == slPsm && qpTab.paramsId == paramsId && qpTab.queryShift == queryShift)
525 .dynamic_limit().dynamic_order_by();
526
527 _addSlModWhere(sql, slTab, compareFlags, str);
528
529 return _runQpsQuery(pepSum, item, queryShift, db, sql, qpTab, compareFlags, hitId, q, p);
530 }
531 else if (item == ms_peptidesummary::FT_PEPTIDE_VARMOD_BYNAME)
532 {
533 const auto& pepTab = std::get<0>(tabs);
534 const auto& varModTab = std::get<5>(tabs);
535 auto sql =
536 sqlpp::dynamic_select(db.connection()).dynamic_flags().dynamic_columns(qpTab.hitId, qpTab.localQ, qpTab.p)
537 .from(pepTab
538 .join(qpTab).on(pepTab.queryId == qpTab.localQ && pepTab.rankId == qpTab.p).cross_join(varModTab))
539 .dynamic_where(pepTab.psmType == psmType && qpTab.paramsId == paramsId && qpTab.queryShift == queryShift)
540 .dynamic_limit()
541 .dynamic_order_by(pepTab.queryId.asc(), pepTab.rankId.asc());
542
543 _addVarModWhere(db, sql, varModTab, pepTab, compareFlags, str);
544
545 return _runQpsQuery(pepSum, item, queryShift, db, sql, qpTab, compareFlags, hitId, q, p);
546 }
547
548 return -1;
549 }
550
551 template<class PepTab, class SumQInfoTab, class PepEtModsTab, class SlModTab, class PepSlModTab, class VarModsTab, class PepProtTab, class ProtTab>
552 int findProteinItemWithQps(
553 const int paramsId,
554 const ms_peptidesummarybase& pepSum,
555 ms_sqlpp11_connection& db,
556 const std::tuple<PepTab, SumQInfoTab, PepEtModsTab, SlModTab, PepSlModTab, VarModsTab, PepProtTab, ProtTab>& tabs,
557 const int dbIdxRequired,
558 const int hitId,
559 const ms_mascotresults::FIND_FLAGS item,
560 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
561 const std::string& str,
562 const int queryShift,
563 std::vector<std::string>& accessions,
564 std::vector<int>& dbIndexes)
565 {
566 constexpr auto accTab = parser_cached_data_v1_0::CachedProteinInference_accessions {};
567 constexpr auto qpTab = parser_cached_data_v1_0::CachedProteinInference_qPList {};
568 constexpr auto protDataTab = parser_cached_data_v1_0::CachedProteinInference_proteinData {};
569
570 int psmType = static_cast<int>(pepSum.typeSummary());
571
572 if (_isFromPeptidesTable(item))
573 {
574 const auto& pepTab = std::get<0>(tabs);
575 const auto& pepProtTab = std::get<6>(tabs);
576 const auto& protTab = std::get<7>(tabs);
577 auto sql =
578 sqlpp::dynamic_select(db.connection()).dynamic_flags().dynamic_columns(accTab.hitId, protTab.dbId, protTab.accessionStr, protDataTab.group)
579 .from(qpTab
580 .join(pepTab).on(qpTab.localQ==pepTab.queryId && qpTab.p==pepTab.rankId)
581 .join(pepProtTab).on(pepTab.queryId==pepProtTab.queryId && pepTab.rankId==pepProtTab.rankId && pepTab.sequenceIdx == pepProtTab.sequenceIdx && pepTab.psmType == pepProtTab.psmType)
582 .join(protTab).on(protTab.proteinId==pepProtTab.proteinId)
583 .join(accTab).on(accTab.proteinId==protTab.proteinId && accTab.hitId==qpTab.hitId && accTab.paramsId==qpTab.paramsId)
584 .join(protDataTab).on(protTab.proteinId==protDataTab.proteinId))
585 .dynamic_where(pepTab.psmType == psmType && qpTab.paramsId == paramsId && qpTab.queryShift == queryShift && protDataTab.paramsId == paramsId)
586 .dynamic_limit().dynamic_order_by();
587
588 _addPepTabWhere(sql, pepTab, pepSum, item, compareFlags, str, queryShift);
589 _addHitOrderWhere(sql, accTab, protTab, compareFlags, hitId, dbIdxRequired);
590 sql.order_by.add(qpTab.localQ.asc());
591 sql.order_by.add(qpTab.p.asc());
592
593 return _runProteinsQuery(db, sql, compareFlags, hitId, accessions, dbIndexes);
594 }
595 else if (_isFromSummaryQueryInfo(item))
596 {
597 const auto& qInfoTab = std::get<1>(tabs);
598 const auto& pepProtTab = std::get<6>(tabs);
599 const auto& protTab = std::get<7>(tabs);
600 auto sql =
601 sqlpp::dynamic_select(db.connection()).dynamic_columns(accTab.hitId, protTab.dbId, protTab.accessionStr, protDataTab.group)
602 .from(qpTab
603 .join(qInfoTab).on(qpTab.localQ==qInfoTab.queryId)
604 .join(pepProtTab).on(qpTab.localQ==pepProtTab.queryId && qpTab.p==pepProtTab.rankId)
605 .join(protTab).on(protTab.proteinId==pepProtTab.proteinId)
606 .join(accTab).on(accTab.proteinId==protTab.proteinId && accTab.hitId==qpTab.hitId && accTab.paramsId==qpTab.paramsId)
607 .join(protDataTab).on(protTab.proteinId==protDataTab.proteinId))
608 .dynamic_where(pepProtTab.psmType == psmType && qpTab.paramsId==paramsId && protDataTab.paramsId==paramsId)
609 .dynamic_limit().dynamic_order_by();
610
611 _addQueryInfoWhere(sql, qInfoTab, item, compareFlags, str);
612 _addHitOrderWhere(sql, accTab, protTab, compareFlags, hitId, dbIdxRequired);
613 sql.order_by.add(qpTab.localQ.asc());
614 sql.order_by.add(qpTab.p.asc());
615
616 return _runProteinsQuery(db, sql, compareFlags, hitId, accessions, dbIndexes);
617 }
618 else if (item == ms_peptidesummary::FT_PEPTIDE_ETMOD)
619 {
620 const auto& pepTab = std::get<0>(tabs);
621 const auto& etTab = std::get<2>(tabs);
622 const auto& pepProtTab = std::get<6>(tabs);
623 const auto& protTab = std::get<7>(tabs);
624
625 auto sql =
626 sqlpp::dynamic_select(db.connection()).dynamic_flags().dynamic_columns(accTab.hitId, protTab.dbId, protTab.accessionStr, protDataTab.group)
627 .from(qpTab
628 .join(pepTab).on(qpTab.localQ==pepTab.queryId && qpTab.p==pepTab.rankId)
629 .join(etTab).on(pepTab.queryId==etTab.queryId && pepTab.rankId==etTab.rankId && pepTab.psmType == etTab.psmType)
630 .join(pepProtTab).on(pepTab.queryId==pepProtTab.queryId && pepTab.rankId==pepProtTab.rankId && pepTab.sequenceIdx == pepProtTab.sequenceIdx && pepTab.psmType == pepProtTab.psmType)
631 .join(protTab).on(protTab.proteinId==pepProtTab.proteinId)
632 .join(accTab).on(accTab.proteinId==protTab.proteinId && accTab.hitId==qpTab.hitId && accTab.paramsId==qpTab.paramsId)
633 .join(protDataTab).on(protTab.proteinId==protDataTab.proteinId))
634 .dynamic_where(pepTab.psmType == psmType && qpTab.paramsId==paramsId && protDataTab.paramsId==paramsId)
635 .dynamic_limit().dynamic_order_by();
636
637 double tolerance = pepSum.getTolerance();
638 double toleranceFactor = pepSum.getToleranceFactor();
639 _addEtWhere(sql, pepTab, etTab, item, compareFlags, str, tolerance, toleranceFactor);
640 _addHitOrderWhere(sql, accTab, protTab, compareFlags, hitId, dbIdxRequired);
641 sql.order_by.add(qpTab.localQ.asc());
642 sql.order_by.add(qpTab.p.asc());
643
644 return _runProteinsQuery(db, sql, compareFlags, hitId, accessions, dbIndexes);
645
646 }
647 else if (item == ms_peptidesummary::FT_PEPTIDE_SLMOD)
648 {
649 const auto& slTab = std::get<3>(tabs);
650 const auto& pepSlTab = std::get<4>(tabs);
651 const auto& pepProtTab = std::get<6>(tabs);
652 const auto& protTab = std::get<7>(tabs);
653
654 auto sql =
655 sqlpp::dynamic_select(db.connection()).dynamic_flags().dynamic_columns(accTab.hitId, protTab.dbId, protTab.accessionStr, protDataTab.group)
656 .from(qpTab
657 .join(pepProtTab).on(qpTab.localQ==pepProtTab.queryId && qpTab.p==pepProtTab.rankId)
658 .join(pepSlTab).on(pepProtTab.queryId==pepSlTab.queryId && pepProtTab.rankId==pepSlTab.rankId && pepProtTab.psmType == pepSlTab.psmType)
659 .join(slTab).on(pepSlTab.modNum == slTab.modNum)
660 .join(protTab).on(protTab.proteinId==pepProtTab.proteinId)
661 .join(accTab).on(accTab.proteinId==protTab.proteinId && accTab.hitId==qpTab.hitId && accTab.paramsId==qpTab.paramsId)
662 .join(protDataTab).on(protTab.proteinId==protDataTab.proteinId))
663 .dynamic_where(pepProtTab.psmType == psmType && qpTab.paramsId==paramsId && protDataTab.paramsId==paramsId)
664 .dynamic_limit().dynamic_order_by();
665
666 _addSlModWhere(sql, slTab, compareFlags, str);
667 _addHitOrderWhere(sql, accTab, protTab, compareFlags, hitId, dbIdxRequired);
668 sql.order_by.add(qpTab.localQ.asc());
669 sql.order_by.add(qpTab.p.asc());
670
671 return _runProteinsQuery(db, sql, compareFlags, hitId, accessions, dbIndexes);
672 }
673 else if (item == ms_peptidesummary::FT_PEPTIDE_VARMOD_BYNAME)
674 {
675 const auto& pepTab = std::get<0>(tabs);
676 const auto& varModTab = std::get<5>(tabs);
677 const auto& pepProtTab = std::get<6>(tabs);
678 const auto& protTab = std::get<7>(tabs);
679
680 auto sql =
681 sqlpp::dynamic_select(db.connection()).dynamic_flags().dynamic_columns(accTab.hitId, protTab.dbId, protTab.accessionStr, protDataTab.group)
682 .from(pepProtTab
683 .join(qpTab).on(pepProtTab.queryId == qpTab.localQ && pepProtTab.rankId == qpTab.p)
684 .join(pepTab).on(qpTab.localQ==pepTab.queryId && qpTab.p==pepTab.rankId)
685 .cross_join(varModTab)
686 .join(protTab).on(protTab.proteinId==pepProtTab.proteinId)
687 .join(accTab).on(accTab.proteinId==protTab.proteinId && accTab.hitId==qpTab.hitId && accTab.paramsId==qpTab.paramsId)
688 .join(protDataTab).on(protTab.proteinId==protDataTab.proteinId))
689 .dynamic_where(pepProtTab.psmType == psmType && qpTab.paramsId==paramsId && protDataTab.paramsId==paramsId)
690 .dynamic_limit().dynamic_order_by();
691
692 _addVarModWhere(db, sql, varModTab, pepTab, compareFlags, str);
693 _addHitOrderWhere(sql, accTab, protTab, compareFlags, hitId, dbIdxRequired);
694 sql.order_by.add(qpTab.localQ.asc());
695 sql.order_by.add(qpTab.p.asc());
696
697 return _runProteinsQuery(db, sql, compareFlags, hitId, accessions, dbIndexes);
698 }
699 return -1;
700 }
701
702 template<typename QueryType, typename ProteinsTable>
703 void _addProteinsWhere(QueryType& query,
704 const ProteinsTable& protTab,
705 const ms_mascotresults::FIND_FLAGS item,
706 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
707 const std::string& str)
708 {
709 if (item & ms_peptidesummary::FT_PROTEIN_DESCRIPTION)
710 {
711 query.where.add(protTab.title.like("%"+str+"%"));
712 }
713 else if (item & ms_peptidesummary::FT_PROTEIN_ACCESSION)
714 {
715 query.where.add(protTab.accessionStr.like("%"+str+"%"));
716 }
717 }
718
719 template<class ProtTab>
720 int findProteinItem(
721 const int paramsId,
722 ms_sqlpp11_connection& db,
723 const ProtTab& protTab,
724 const int dbIdxRequired,
725 const int hitId,
726 const ms_mascotresults::FIND_FLAGS item,
727 const ms_mascotresults::FIND_COMPARE_FLAGS compareFlags,
728 const std::string& str,
729 std::vector<std::string>& accessions,
730 std::vector<int>& dbIndexes)
731 {
732 constexpr auto accTab = parser_cached_data_v1_0::CachedProteinInference_accessions {};
733 constexpr auto protDataTab = parser_cached_data_v1_0::CachedProteinInference_proteinData {};
734
735 auto sql =
736 sqlpp::dynamic_select(db.connection()).dynamic_flags().dynamic_columns(accTab.hitId, protTab.dbId, protTab.accessionStr, protDataTab.group)
737 .from(protTab
738 .join(accTab).on(protTab.proteinId==accTab.proteinId)
739 .join(protDataTab).on(protTab.proteinId==protDataTab.proteinId))
740 .dynamic_where(accTab.paramsId==paramsId && protDataTab.paramsId==paramsId)
741 .dynamic_limit().dynamic_order_by();
742
743 _addProteinsWhere(sql, protTab, item, compareFlags, str);
744 _addHitOrderWhere(sql, accTab, protTab, compareFlags, hitId, dbIdxRequired);
745
746 return _runProteinsQuery(db, sql, compareFlags, hitId, accessions, dbIndexes);
747 }
748
749 } // ms_sql
750} // msparser_internal
751
752#endif // MS_SQL_FIND_HPP
matrix_science::ms_mascotresults::FIND_COMPARE_FLAGS
FIND_COMPARE_FLAGS
Flags to specify how comparisons are performed in the find functions.
Definition: ms_mascotresults.hpp:189
matrix_science::ms_mascotresults::FC_LOOP_INTO_UNASSIGNED
@ FC_LOOP_INTO_UNASSIGNED
If no matches are found in the passed hit, or any subsequent hit, then search the unassigned list.
Definition: ms_mascotresults.hpp:205
matrix_science::ms_mascotresults::FC_STRTOK
@ FC_STRTOK
Supplied string is a set of tokens, for example "STY" could be used to search for S or T or Y in a pe...
Definition: ms_mascotresults.hpp:193
matrix_science::ms_mascotresults::FC_PROTEIN_IGN_FAMILY
@ FC_PROTEIN_IGN_FAMILY
Ignore family member proteins - only used for findProteins()
Definition: ms_mascotresults.hpp:220
matrix_science::ms_mascotresults::FC_MASK_STR_PART
@ FC_MASK_STR_PART
Bit mask to extract which one of FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK has been specified...
Definition: ms_mascotresults.hpp:194
matrix_science::ms_mascotresults::FC_LOOP_FROM_UNASSIGNED
@ FC_LOOP_FROM_UNASSIGNED
If the passed hit number is 0, and no match is found in the unassigned list, then start searching at ...
Definition: ms_mascotresults.hpp:206
matrix_science::ms_mascotresults::FC_STARTSTR
@ FC_STARTSTR
String must match to start of target string. If search item is a decimal number then match to the sam...
Definition: ms_mascotresults.hpp:192
matrix_science::ms_mascotresults::FC_PROTEIN_IGN_SAMESETS
@ FC_PROTEIN_IGN_SAMESETS
Ignore sameset proteins - only used for findProteins()
Definition: ms_mascotresults.hpp:218
matrix_science::ms_mascotresults::FC_REVERSE
@ FC_REVERSE
Reverse search. The returned hit number will be the same as or lower than the start hit number.
Definition: ms_mascotresults.hpp:201
matrix_science::ms_mascotresults::FC_SEARCH_ALL_RANKS
@ FC_SEARCH_ALL_RANKS
For use with findPeptides() only. Ordinarily only those queries and ranks are searched that are assig...
Definition: ms_mascotresults.hpp:209
matrix_science::ms_mascotresults::FC_COMPLETESTR
@ FC_COMPLETESTR
Search for the complete string. If search item is a decimal number then match the number exactly.
Definition: ms_mascotresults.hpp:190
matrix_science::ms_mascotresults::FC_PROTEIN_IGN_SUBSETS
@ FC_PROTEIN_IGN_SUBSETS
Ignore subset proteins - only used for findProteins()
Definition: ms_mascotresults.hpp:219
matrix_science::ms_mascotresults::FC_RESTRICT_TO_HIT
@ FC_RESTRICT_TO_HIT
Don't search beyond the specified hit number. Cannot be used with FC_LOOP_INTO_UNASSIGNED or FC_LOOP_...
Definition: ms_mascotresults.hpp:204
matrix_science::ms_mascotresults::FC_SUBSTR
@ FC_SUBSTR
Search for any substring. Not valid if search item is a decimal number.
Definition: ms_mascotresults.hpp:191
matrix_science::ms_mascotresults::FIND_FLAGS
FIND_FLAGS
Flags for findPeptides() and findProteins().
Definition: ms_mascotresults.hpp:146
matrix_science::ms_peptide
This class encapsulates a peptide from the mascot results file.
Definition: ms_peptide.hpp:57
matrix_science::ms_peptide::PSM_ERRTOL
@ PSM_ERRTOL
Error tolerant (second pass search, target database)
Definition: ms_peptide.hpp:110
matrix_science::ms_peptide::PSM_LIBRARY
@ PSM_LIBRARY
Spectral library (SL search of target library)
Definition: ms_peptide.hpp:112
matrix_science::ms_peptide::getAnyMatch
bool getAnyMatch() const
Returns true if there was a peptide match to this spectrum.
Definition: ms_peptide.cpp:557
matrix_science::ms_protein::GROUP_FAMILY
@ GROUP_FAMILY
Second or subsequent family member when using new family grouping introduced in Mascot 2....
Definition: ms_protein.hpp:79
matrix_science::ms_protein::GROUP_NO
@ GROUP_NO
Does not contain same set (or subset) of peptides as another proteins. A 'lead' protein.
Definition: ms_protein.hpp:76
matrix_science::ms_protein::GROUP_UNKNOWN
@ GROUP_UNKNOWN
No information about grouping.
Definition: ms_protein.hpp:75
matrix_science::ms_protein::GROUP_COMPLETE
@ GROUP_COMPLETE
Contains an identical set of peptides to one or more other proteins.
Definition: ms_protein.hpp:78
matrix_science::ms_protein::GROUP_SUBSET
@ GROUP_SUBSET
Contains a subset of peptides in one ore more other proteins.
Definition: ms_protein.hpp:77
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_sql_stream_restorer.hpp Source File

  • src
  • tools
ms_sql_stream_restorer.hpp
1/*
2##############################################################################
3# file: ms_sql_stream_restorer.hpp #
4# 'msparser' toolkit #
5# Helper class for executing SQL statements on a fresh SQLite database
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author$
12# $Date$
13# $Revision$
14##############################################################################
15*/
16
17#ifndef MS_SQL_STREAM_RESTORER_HPP
18#define MS_SQL_STREAM_RESTORER_HPP
19
20#include <string>
21
22namespace matrix_science {
23 class ms_errors;
24 class ms_errs;
25}
26
27namespace msparser_internal {
28 class ms_http_helper_progress_impl;
29
31
38
53 class MS_MASCOTRESFILE_API ms_sql_stream_restorer : public matrix_science::ms_errors
54 {
55 public:
57 ms_sql_stream_restorer();
58
59 ~ms_sql_stream_restorer();
60
62 bool run(const std::string &source_filepath, const std::string &target_filepath, msparser_internal::ms_http_helper_progress_impl *progress = nullptr);
63
64 private:
65 static bool looksLikeCompression(const std::string &str);
66 };
67 // end of tools_group
69
71
72} // msparser_internal namespace
73
74#endif // MS_SQL_STREAM_RESTORER_HPP
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_sql_stream_statement_chopper.hpp Source File

  • src
  • tools
ms_sql_stream_statement_chopper.hpp
1/*
2##############################################################################
3# file: ms_sql_stream_statement_chopper.hpp #
4# 'msparser' toolkit #
5# Helper class for pulling out SQL statements from a stream of text
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author$
12# $Date$
13# $Revision$
14##############################################################################
15*/
16
17#ifndef MS_SQL_STREAM_STATEMENT_CHOPPER_HPP
18#define MS_SQL_STREAM_STATEMENT_CHOPPER_HPP
19
20#include <string>
21#include <functional>
22#include <algorithm>
23#include <cctype>
24
25namespace matrix_science {
26 class ms_errors;
27 class ms_errs;
28}
29
30namespace msparser_internal {
32
39
70 class MS_MASCOTRESFILE_API ms_sql_stream_statement_chopper : public matrix_science::ms_errors
71 {
72 public:
73 typedef std::function<bool(const std::string&)> CallbackFunctor;
74
76 ms_sql_stream_statement_chopper(matrix_science::ms_errs *errs_parent, CallbackFunctor cf);
77
78 ~ms_sql_stream_statement_chopper();
79
81 bool empty() const { return retained_.empty(); }
82
84 bool emptyOrBlank() const {
85 return (empty()
86 || std::all_of(retained_.begin(), retained_.end(), [](unsigned char c) { return std::isspace(c); }));
87 }
88
90 bool nextChunk(const std::string &buffer);
91
92 private:
93 ms_sql_stream_statement_chopper();
94 ms_sql_stream_statement_chopper(const ms_sql_stream_statement_chopper&);
95
96 private:
97 CallbackFunctor cf_;
98 std::string retained_;
99 };
100 // end of tools_group
102
104
105} // msparser_internal namespace
106
107#endif // MS_SQL_STREAM_STATEMENT_CHOPPER_HPP
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_sql_stream_statement_executor.hpp Source File

  • src
  • tools
ms_sql_stream_statement_executor.hpp
1/*
2##############################################################################
3# file: ms_sql_stream_statement_executor.hpp #
4# 'msparser' toolkit #
5# Helper class for executing SQL statements on a fresh SQLite database
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author$
12# $Date$
13# $Revision$
14##############################################################################
15*/
16
17#ifndef MS_SQL_STREAM_STATEMENT_EXECUTOR_HPP
18#define MS_SQL_STREAM_STATEMENT_EXECUTOR_HPP
19
20#include <string>
21
22namespace matrix_science {
23 class ms_errors;
24 class ms_errs;
25}
26
27struct msl_sqlite3;
28
29namespace msparser_internal {
31
38
48 class MS_MASCOTRESFILE_API ms_sql_stream_statement_executor : public matrix_science::ms_errors
49 {
50 public:
52 ms_sql_stream_statement_executor(matrix_science::ms_errs *errs_parent, const std::string &filepath);
53
54 ~ms_sql_stream_statement_executor();
55
57 bool operator()(const std::string &str) const;
58
59 private:
60 ms_sql_stream_statement_executor();
61 ms_sql_stream_statement_executor(const ms_sql_stream_statement_executor&);
62 bool execute(const std::string &str) const;
63
64 private:
65 const std::string filepath_;
66 msl_sqlite3 *handle_;
67 };
68 // end of tools_group
70
72
73} // msparser_internal namespace
74
75#endif // MS_SQL_STREAM_STATEMENT_EXECUTOR_HPP
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_taxonomyfile.hpp Source File

  • inc
ms_taxonomyfile.hpp
1/*
2##############################################################################
3# file: ms_taxonomyfile.hpp #
4# 'msparser' toolkit #
5# Encapsulates "taxonomy"-file that available taxonomy choices #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2004 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_taxonomyfile.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_TAXONOMYFILE_HPP
20#define MS_TAXONOMYFILE_HPP
21
22
23#include <string>
24#include <vector>
25
26namespace matrix_science {
33
48 class MS_MASCOTRESFILE_API ms_taxonomychoice: public ms_customproperty
49 {
50 friend class ms_taxonomyfile;
51 public:
52
54 ms_taxonomychoice();
55
57 ms_taxonomychoice(const ms_taxonomychoice& src);
58
60 ~ms_taxonomychoice();
61
63 void defaultValues();
64
66 void copyFrom(const ms_taxonomychoice* src);
67
68#ifndef SWIG
70 ms_taxonomychoice& operator=(const ms_taxonomychoice& right);
71#endif
73 std::string getTitle() const;
74
76 void setTitle(const char* value);
77
79 int getNumberOfIncludeTaxonomies() const;
80
82 int getIncludeTaxonomy(const int n) const;
83
85 void clearIncludeTaxonomies();
86
88 void appendIncludeTaxonomy(const int id);
89
91 int getNumberOfExcludeTaxonomies() const;
92
94 int getExcludeTaxonomy(const int n) const;
95
97 void clearExcludeTaxonomies();
98
100 void appendExcludeTaxonomy(const int id);
101
102#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
103#include "suppress_ms_customproperty.hpp"
104#endif
105
106 private:
107 void setCustomProperty();
108
109 private:
110 std::string title;
111
112 std::vector< int > includeList;
113 std::vector< int > excludeList;
114 }; // ms_taxonomychoice
115
116 class ms_filesource;
117
119
144 class MS_MASCOTRESFILE_API ms_taxonomyfile: public ms_errors
145 {
146 public:
148 ms_taxonomyfile();
149
151 ms_taxonomyfile(const ms_taxonomyfile& src);
152
154 ms_taxonomyfile(const char* filename, const matrix_science::ms_connection_settings * cs = 0);
155
157 ~ms_taxonomyfile();
158
160 void defaultValues();
161
163 void copyFrom(const ms_taxonomyfile* right);
164
165#ifndef SWIG
167 ms_taxonomyfile& operator=(const ms_taxonomyfile& right);
168#endif
170 void setFileName(const char* name);
171
173 std::string getFileName() const;
174
176
180 void setConnectionSettings(const matrix_science::ms_connection_settings & cs);
181
183
186 matrix_science::ms_connection_settings getConnectionSettings() const;
187
189 void read_file();
190
192 void read_buffer(const char* buffer);
193
195 void save_file();
196
198 int getNumberOfEntries() const;
199
201 void clearEntries();
202
204 void appendEntry(const ms_taxonomychoice* item);
205
207 const ms_taxonomychoice * getEntryByNumber(const int index) const;
208
210 ms_taxonomychoice * getEntryByName(const char* name);
211
212 private:
213 void read_internal(ms_filesource *pFSource);
214
215 typedef std::vector<ms_taxonomychoice* > entries_vector;
216 entries_vector entries;
217
218 std::string filename_;
219 std::vector< std::string > comments_;
220 ms_connection_settings cs_;
221 }; // ms_taxonomyfile // end of config_group
223} // namespace matrix_science
224
225#endif // MS_TAXONOMYFILE_HPP
226
227/*------------------------------- End of File -------------------------------*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_taxonomychoice
The class represents a single taxonomy choice entry in the taxonomy file.
Definition: ms_taxonomyfile.hpp:49
matrix_science::ms_taxonomyfile
Use this class in order to read in a taxonomy file.
Definition: ms_taxonomyfile.hpp:145
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_taxonomyrules.hpp Source File

  • inc
ms_taxonomyrules.hpp
1/*
2##############################################################################
3# file: ms_taxonomyrules.hpp #
4# 'msparser' toolkit #
5# Encapsulates "mascot.dat"-file that describes most important parameters #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_taxonomyrules.hpp $ #
12# $Author: francoisr@matrixscience.com $ #
13# $Date: 2022-01-12 12:34:37 +0000 $ #
14# $Revision: b158d77079a10225ce667f6e66a6df8412823ac0 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_TAXONOMYRULES_HPP
20#define MS_TAXONOMYRULES_HPP
21
22
23#include <string>
24#include <vector>
25
26
27namespace matrix_science {
38 enum TAX_SPECIES_FORMAT
39 {
40 TAX_SPECIES_NCBI,
41 TAX_SPECIES_SWISSPROT,
42 TAX_SPECIES_PDB,
43 TAX_SPECIES_GI2TAXID,
44 TAX_SPECIES_ACC2TAXID,
45 TAX_SPECIES_EXPLICIT,
46 TAX_SPECIES_FORMAT_COUNT /* Always leave this one last */
47 };
48
50 class MS_MASCOTRESFILE_API ms_taxspeciesfiles
51 {
52 friend class ms_datfile;
53 friend class ms_taxonomyrules;
54
55 public:
57 ms_taxspeciesfiles();
58
60 ms_taxspeciesfiles(const ms_taxspeciesfiles& src);
61
63 ~ms_taxspeciesfiles();
64
66 void defaultValues();
67
69 void copyFrom(const ms_taxspeciesfiles* right);
70
71#ifndef SWIG
73 ms_taxspeciesfiles& operator=(const ms_taxspeciesfiles& right);
74#endif
76 TAX_SPECIES_FORMAT getFormat() const;
77
79 void setFormat(const TAX_SPECIES_FORMAT value);
80
82 std::string getFileName() const;
83
85 void setFileName(const char* name);
86
87 private:
88 TAX_SPECIES_FORMAT format_;
89 std::string filename_;
90
91 std::string getStringValue() const;
92 }; // class ms_taxspeciesfiles
93
99 enum TAX_NODE_FORMAT
100 {
101 TAX_NODE_NCBI,
102 TAX_NODE_GENCODE
103 };
104
106
108 class MS_MASCOTRESFILE_API ms_taxnodesfiles
109 {
110 friend class ms_datfile;
111 friend class ms_taxonomyrules;
112 public:
113
115 ms_taxnodesfiles();
116
118 ms_taxnodesfiles(const ms_taxnodesfiles& src);
119
121 ~ms_taxnodesfiles();
122
124 void defaultValues();
125
127 void copyFrom(const ms_taxnodesfiles* right);
128
129#ifndef SWIG
131 ms_taxnodesfiles& operator=(const ms_taxnodesfiles& right);
132#endif
134 TAX_NODE_FORMAT getFormat() const;
135
137 void setFormat(const TAX_NODE_FORMAT value);
138
140 std::string getFileName() const;
141
143 void setFileName(const char* name);
144
145 private:
146 TAX_NODE_FORMAT format_;
147 std::string filename_;
148 std::string getStringValue() const;
149 }; // class ms_taxnodesfiles
150
152 class MS_MASCOTRESFILE_API ms_parserule_plus
153 {
154 friend class ms_datfile;
155 friend class ms_taxonomyrules;
156
157 public:
159
162 enum TAX_CHOP_TYPES
163 {
164 TAX_CHOP_PREFIX = 0x0001,
165 TAX_CHOP_SUFFIX = 0x0002,
166 TAX_CHOP_WORDS = 0x0004
167 };
168
170 typedef unsigned int TAX_CHOP_SRC;
171
173 ms_parserule_plus();
174
176 ms_parserule_plus(const ms_parserule_plus& src);
177
179 ~ms_parserule_plus();
180
182 void defaultValues();
183
185 void copyFrom(const ms_parserule_plus* right);
186
187#ifndef SWIG
189 ms_parserule_plus& operator=(const ms_parserule_plus& right);
190#endif
192 TAX_SPECIES_FORMAT getFileTypeToSearch() const;
193
195 void setFileTypeToSearch(const TAX_SPECIES_FORMAT value);
196
198 const ms_parserule* getRule() const;
199
201 void setRule(const ms_parserule* src);
202
204 TAX_CHOP_SRC getChopSource() const;
205
207 void setChopSource(const TAX_CHOP_SRC value);
208
210 std::string getNameOfDB() const;
211
213 void setNameOfDB(const char* name);
214
215 private:
216 TAX_SPECIES_FORMAT fileTypeToSearch_;
217 ms_parserule rule_;
218 TAX_CHOP_SRC chopSrc_;
219 std::string nameOfDb_;
220 std::string getStringValue() const;
221 }; // ms_parserule_plus
222
224
246 class MS_MASCOTRESFILE_API ms_taxonomyrules: public ms_customproperty
247 {
248 friend class ms_datfile;
249
250 public:
252 ms_taxonomyrules();
253
255 ms_taxonomyrules(const ms_taxonomyrules& src);
256
258 ~ms_taxonomyrules();
259
261 void defaultValues();
262
264 void copyFrom(const ms_taxonomyrules* right);
265
266#ifndef SWIG
268 ms_taxonomyrules& operator=(const ms_taxonomyrules& right);
269#endif
271 bool isSectionAvailable() const;
272
274 void setSectionAvailable(const bool value);
275
277 bool isEnabled() const;
278
280 void setEnabled(const bool flag);
281
283 std::string getIdentifier() const;
284
286 void setIdentifier(const char* str);
287
289 int getErrorLevel() const;
290
292 void setErrorLevel(const int value);
293
295 bool isFromRefFile() const;
296
298 void setFromRefFile(const bool flag);
299
301 bool isConcatRefFileLines() const;
302
304 void setConcatRefFileLines(const bool flag);
305
307 char getDescriptionLineSep() const;
308
310 void setDescriptionLineSep(const char value);
311
313 int getNumberOfNoBreakDescLineIf() const;
314
316 std::string getNoBreakDescLineIf(const int index) const;
317
319 void clearNoBreakDescLineIf();
320
322 void appendNoBreakDescLineIf(const char* str);
323
325 int getNumberOfSpeciesFiles() const;
326
328 const ms_taxspeciesfiles * getSpeciesFile(const int index) const;
329
331 void clearSpeciesFiles();
332
334 void appendSpeciesFile(const ms_taxspeciesfiles * item);
335
336 // no longer in use
337 int getNumberOfStrFiles() const;
338 // no longer in use
339 const ms_taxspeciesfiles * getStrFile(const int index) const;
340 // no longer in use
341 void clearStrFiles();
342 // no longer in use
343 void appendStrFile(const ms_taxspeciesfiles * item);
344
345 // no longer in use
346 const ms_parserule_plus* getStrRule() const;
347 // no longer in use
348 void setStrRule(const ms_parserule_plus* src);
349
351 int getNumberOfNodesFiles() const;
352
354 const ms_taxnodesfiles * getNodesFile(const int index) const;
355
357 void clearNodesFiles();
358
360 void appendNodesFile(const ms_taxnodesfiles * item);
361
363 int getNumberOfGencodeFiles() const;
364
366 const ms_taxnodesfiles * getGencodeFile(const int index) const;
367
369 void clearGencodeFiles();
370
372 void appendGencodeFile(const ms_taxnodesfiles * item);
373
375 const ms_parserule_plus* getDefaultRule() const;
376
378 void setDefaultRule(const ms_parserule_plus* src);
379
381 int getNumberOfPrefixRemoves() const;
382
384 std::string getPrefixRemove(const int index) const;
385
387 void clearPrefixRemoves();
388
390 void appendPrefixRemove(const char * item);
391
393 int getNumberOfSuffixRemoves() const;
394
396 std::string getSuffixRemove(const int index) const;
397
399 void clearSuffixRemoves();
400
402 void appendSuffixRemove(const char * item);
403
405 const ms_parserule* getSrcDatabaseRule() const;
406
408 void setSrcDatabaseRule(const ms_parserule* src);
409
411 int getNumberOfPerDbSrcRules() const;
412
414 const ms_parserule_plus * getPerDbSrcRule(const int index) const;
415
417 void clearPerDbSrcRules();
418
420 void appendPerDbSrcRule(const ms_parserule_plus * item);
421
423 const ms_parserule* getDoThisRuleFirst() const;
424
426 void setDoThisRuleFirst(const ms_parserule* src);
427
429 const ms_parserule* getAccFromSpeciesLine() const;
430
432 void setAccFromSpeciesLine(const ms_parserule* src);
433
435 std::string getQuickRefSearch() const;
436
438 void setQuickRefSearch(const char* str);
439
441 int getDBLevelTaxId() const;
442
444 void setDBLevelTaxId(const int value);
445
447 bool isDBLevelTaxId() const;
448
450 void clearDBLevelTaxId();
451
453 bool isMitochondrialTranslation() const;
454
456 void setMitochondrialTranslation(const bool flag);
457
459 std::string getSpeciesFormatRegex(const TAX_SPECIES_FORMAT format) const;
460
462 void setSpeciesFormatRegex(const TAX_SPECIES_FORMAT format, const std::string regex);
463
464#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
465#include "suppress_ms_customproperty.hpp"
466#endif
467
468 private:
469 bool sectionAvailable_;
470 bool enabled_;
471 std::string identifier_;
472 int errorLevel_;
473 bool fromRefFile_;
474 bool concatRefFileLines_;
475 char descriptionLineSep_;
476
477 std::vector< std::string > noBreakDescLineIf_;
478 std::vector< ms_taxspeciesfiles* > speciesFiles_;
479 std::vector< ms_taxspeciesfiles* > strStrFiles_;
480 std::vector< ms_taxnodesfiles* > nodesFiles_;
481 std::vector< ms_taxnodesfiles* > gencodeFiles_;
482 std::vector< ms_parserule_plus* > perDbSrcRules_;
483 std::vector< std::string > prefixRemoves_;
484 std::vector< std::string > suffixRemoves_;
485 std::vector< std::string > speciesFormatRegex_;
486
487 ms_parserule srcDatabaseRule_;
488 ms_parserule doThisRuleFirst_;
489 ms_parserule accFromSpeciesLine_;
490 ms_parserule_plus defaultRule_;
491 ms_parserule_plus strStrRule_;
492
493 std::string quickRefSearch_;
494 int dbLevelTaxId_;
495 bool mitochondrialTranslation_;
496 }; // class ms_taxonomyrules
497
498 class ms_tinycdb;
499 class ms_taxonomychoice;
500
502
540 class MS_MASCOTRESFILE_API ms_taxonomytree : public ms_errors
541 {
542 public:
544 ms_taxonomytree(const ms_taxonomyrules * taxonomyRules,
545 const char * taxonomyDirectory = "../taxonomy",
546 const bool useIndex = true,
547 const bool createList = false,
548 const char * preparingDirectory = "../taxonomy/preparing",
549 const char * oldDirectory = "../taxonomy/old");
550
552 ms_taxonomytree(const ms_taxonomytree & src);
553
555 ~ms_taxonomytree();
556
558 void copyFrom(const ms_taxonomytree * right);
559
560#ifndef SWIG
562 ms_taxonomytree& operator=(const ms_taxonomytree & right);
563
564 struct TAX_TREE_NODE {
565 int parentId;
566 int tableId;
567 };
568 typedef std::vector<TAX_TREE_NODE> TAX_TREE_NODES;
569
571 TAX_TREE_NODES * getTaxIDArray();
572#endif
573
575 bool usingIndex() const;
576
578 std::string getTaxonomyAndIndexFiles() const;
579
581 bool isSpeciesDescendantOf(const int parentID, const int id) const;
582
583#ifndef SWIG
585 bool getParent(const int id, int & ttParent, int & ttGenTable) const;
586#else // SWIG Multiple return values
587 bool getParent(const int id, int & OUTPUT, int & OUTPUT) const;
588#endif
589
591 bool isIncludedIn(const int id, const ms_taxonomychoice * choice) const;
592
593 private:
594 bool usingCDB_;
595 std::vector<ms_taxnodesfiles> files_;
596 TAX_TREE_NODES nodes_;
597 std::vector<std::string> fileNames_;
598 std::vector<ms_tinycdb *> cdbFiles_;
599
600 bool readFile(const std::string & filename,
601 const bool isMitochondrialTranslation);
602
603 };
604
605 // end of config_group
607} // namespace matrix_science
608
609#endif // MS_TAXONOMYRULES_HPP
610
611/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_parserule_plus
Represents regular expression parse rule plus some additional parameters.
Definition: ms_taxonomyrules.hpp:153
matrix_science::ms_parserule_plus::TAX_CHOP_SRC
unsigned int TAX_CHOP_SRC
Data type used for the parameter specifying how to chop a source line. This will be zero or more of t...
Definition: ms_taxonomyrules.hpp:170
matrix_science::ms_parserule_plus::TAX_CHOP_TYPES
TAX_CHOP_TYPES
Constants used for combining TAX_CHOP_SRC values.
Definition: ms_taxonomyrules.hpp:163
matrix_science::ms_parserule
Represents a single regular expression parsing rule.
Definition: ms_parserule.hpp:38
matrix_science::ms_taxnodesfiles
Filenames and formats for taxonomy nodes or genetic codes files.
Definition: ms_taxonomyrules.hpp:109
matrix_science::ms_taxonomychoice
The class represents a single taxonomy choice entry in the taxonomy file.
Definition: ms_taxonomyfile.hpp:49
matrix_science::ms_taxonomyrules
This class represents a single Taxonomy_XXX section in mascot.dat.
Definition: ms_taxonomyrules.hpp:247
matrix_science::ms_taxonomytree
The complete taxonomy tree as built from one or more files such as nodes.dmp.
Definition: ms_taxonomyrules.hpp:541
matrix_science::ms_taxspeciesfiles
An instance of this class describes one entry of taxonomy species files.
Definition: ms_taxonomyrules.hpp:51
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
matrix_science::TAX_SPECIES_FORMAT
TAX_SPECIES_FORMAT
Definition: ms_taxonomyrules.hpp:39
matrix_science::TAX_NODE_FORMAT
TAX_NODE_FORMAT
Definition: ms_taxonomyrules.hpp:100
matrix_science::TAX_SPECIES_NCBI
@ TAX_SPECIES_NCBI
NCBI names.dmp taxonomy species files.
Definition: ms_taxonomyrules.hpp:40
matrix_science::TAX_SPECIES_GI2TAXID
@ TAX_SPECIES_GI2TAXID
GI2TAXID.
Definition: ms_taxonomyrules.hpp:43
matrix_science::TAX_SPECIES_EXPLICIT
@ TAX_SPECIES_EXPLICIT
No lookup required, because the ID is given in the description line. For example: >IPI:IPI00000001....
Definition: ms_taxonomyrules.hpp:45
matrix_science::TAX_SPECIES_PDB
@ TAX_SPECIES_PDB
PDB.
Definition: ms_taxonomyrules.hpp:42
matrix_science::TAX_SPECIES_SWISSPROT
@ TAX_SPECIES_SWISSPROT
SwissProt.
Definition: ms_taxonomyrules.hpp:41
matrix_science::TAX_SPECIES_ACC2TAXID
@ TAX_SPECIES_ACC2TAXID
Simple 'accession taxID' (any whitespace).
Definition: ms_taxonomyrules.hpp:44
matrix_science::TAX_NODE_GENCODE
@ TAX_NODE_GENCODE
NCBI gencode.dmp format.
Definition: ms_taxonomyrules.hpp:102
matrix_science::TAX_NODE_NCBI
@ TAX_NODE_NCBI
NCBI nodes.dmp format.
Definition: ms_taxonomyrules.hpp:101
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_tinycdb.hpp Source File

  • inc
ms_tinycdb.hpp
1/*
2##############################################################################
3# file: ms_tinycdb.hpp #
4# 'msparser' toolkit #
5# Used internally in Mascot Parser as well as being available externally #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2009 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
13# $Author: villek@matrixscience.com $ #
14# $Date: 2018-07-30 16:23:53 +0100 $ #
15# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_TINYCDB_HPP
21#define MS_TINYCDB_HPP
22
23
24
25// Includes from the standard template library
26#include <string>
27#include <vector>
28
29// These values are the key names for special cases
30// User defined keys must not begin with "=0."
31#define CDBIDX_DUPE_ACCESSION "=0.1"
32#define CDBIDX_VERSION "=0.2"
33#define CDBIDX_FILE_TOO_LARGE "=0.3"
34#define CDBIDX_SRC_FILE_SIZE "=0.4"
35#define CDBIDX_SRC_FILE_DATE "=0.5"
36#define CDBIDX_BUGFIX_10627 "=0.6"
37
38
39// Need to be a bit less than 2Gb / 4Gb so that we can write the error strings...
40#define MAX_CDB_SIZE (OFFSET64_C(0xFFFFFFFFFFFF) - OFFSET64_C(0x1000000)) // 281,474,959,933,439 = 256 TB
41#define MAX_CDB_SIZE_STR "256TB"
42#define OLD_MAX_CDB_SIZE_STR_4GB "4Gb"
43#define OLD_MAX_32_BIT_CDB_SIZE (0x7FFFFFFF - 0x1000000)
44#define OLD_MAX_32_BIT_CDB_SIZE_STR "2Gb"
45
46
47// Forward declarations, so no need to include cdb.h
48struct cdb;
49struct cdb_make;
50
51
52namespace matrix_science {
53
59
123 class MS_MASCOTRESFILE_API ms_tinycdb : public ms_errors
124 {
125 public:
127 ms_tinycdb(const char * indexFileName,
128 const char * versionNumber,
129 const char * sourceFileName);
130
132 ~ms_tinycdb();
133
134
136 std::string getIndexFileName() const;
137
139 void setIndexFileName(const char * filename);
140
142 bool openIndexFile(const bool mayRetryBuilding);
143
145 void closeIndexFile();
146
148 bool isPossibleToCreate() const;
149
151 bool isOpenForReading() const;
152
154 bool isCreating() const;
155
157 bool prepareToCreate();
158
160 bool saveValueForKey(const char * keyName,
161 const char * value,
162 const unsigned int keyNameLen = 0,
163 const unsigned int valueLen = 0);
164
166 bool finishCreate();
167
169 std::string getValueFromKey(const std::string & keyName, const int count = 0);
170
172 std::vector<std::string> getAllValuesFromKey(const std::string & keyName);
173
175 OFFSET64_T getFileOffsetFromKey(const std::string & keyName);
176
178 bool saveFileOffsetForKey(const std::string & keyName, OFFSET64_T offset);
179
181 int getIntFromKey(const std::string & keyName);
182
184 int getIntFromKey(const std::string & keyName, bool & found);
185
187 bool saveIntForKey(const std::string & keyName, int value);
188
190 int makeExists(const char * key) const;
191
192
193 protected:
194 // Not safe to copy or assign this object.
195 ms_tinycdb(const ms_tinycdb & rhs);
196#ifndef SWIG
197 ms_tinycdb & operator=(const ms_tinycdb & rhs);
198#endif
199 private:
200 std::string indexFileName_;
201 std::string versionNumber_;
202 std::string sourceFileName_;
203 bool isPossibleToCreate_;
204 int fdCDB_;
205 struct cdb * cdb_;
206 struct cdb_make * cdbm_;
207 bool creatingCDB_;
208 OFFSET64_T calcFileSize_;
209 bool addKeyErrorReported_;
210 bool tooLargeErrorReported_;
211 bool cdbInitOK_;
212
213 bool lockFile(int hFile);
214 bool unlockFile(int hFile);
215 }; // end of tools_group
217} // matrix_science
218
219#endif // MS_TINYCDB_HPP
220
221/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_treecluster.hpp Source File

  • inc
ms_treecluster.hpp
1/*
2##############################################################################
3# File: ms_treecluster.hpp #
4# Mascot Parser toolkit #
5# Utility functions for hierarchical clustering #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source: parser/inc/ms_treecluster.hpp $
12# $Author: villek@matrixscience.com $
13# $Date: 2019-05-10 10:45:13 +0100 $
14# $Revision: 3770d1f7ee65bb20469e6c0ca909b2045b16fd74 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
15##############################################################################
16*/
17
18#ifndef MS_TREECLUSTER_HPP
19#define MS_TREECLUSTER_HPP
20
21
22#include <string>
23#include <vector>
24
25
26namespace matrix_science {
34
48 class MS_MASCOTRESFILE_API ms_treecluster: public ms_errors
49 {
50 public:
51
53
60 enum TREE_CLUSTER_DISTANCE {
61 TCD_CORRELATION,
62 TCD_ABS_CORRELATION,
63 TCD_UNCENTERED_CORRELATION,
64 TCD_ABS_UNCENTERED_CORRELATION,
65 TCD_SPEARMANS_RANK_CORRELATION,
66 TCD_KENDALLS_TAU_CORRELATION,
67 TCD_EUCLIDEAN,
68 TCD_CITY_BLOCK
69 };
70
72 ms_treecluster(int rows, int columns);
73
75 ms_treecluster(const ms_treecluster& right);
76
78 ~ms_treecluster();
79
80#ifndef SWIG
82 ms_treecluster& operator=(const ms_treecluster& right);
83#endif
85 void copyFrom(const ms_treecluster* right);
86
88 void defaultValues();
89
91 bool setRow(int row, std::vector< double > datarow, std::vector< int > maskrow);
92
94 bool cluster(TREE_CLUSTER_DISTANCE tcd,
95 ms_mascotresults::TREE_CLUSTER_METHOD tcm,
96 const std::vector< double > & weight,
97 std::vector< int > &left,
98 std::vector< int > &right,
99 std::vector< double > &distance,
100 bool transpose = false );
101
102 private:
103 int numRows_;
104 int numCols_;
105 double ** data_;
106 int ** mask_;
107
108 void freeMemory();
109
110 }; // ms_treecluster // end of tools_group
112} // matrix_science
113
114#endif // MS_TREECLUSTER_HPP
115
116/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_mascotresults::TREE_CLUSTER_METHOD
TREE_CLUSTER_METHOD
Flags for getTreeClusterNodes().
Definition: ms_mascotresults.hpp:128
matrix_science::ms_treecluster
This class is an interface to the cluster algorithm described at http://bonsai.hgc....
Definition: ms_treecluster.hpp:49
matrix_science::ms_treecluster::TREE_CLUSTER_DISTANCE
TREE_CLUSTER_DISTANCE
Flags for cluster().
Definition: ms_treecluster.hpp:60
matrix_science::ms_treecluster::TCD_EUCLIDEAN
@ TCD_EUCLIDEAN
'e': Euclidean distance
Definition: ms_treecluster.hpp:67
matrix_science::ms_treecluster::TCD_KENDALLS_TAU_CORRELATION
@ TCD_KENDALLS_TAU_CORRELATION
'k': Kendall tau rank correlation coefficient
Definition: ms_treecluster.hpp:66
matrix_science::ms_treecluster::TCD_ABS_UNCENTERED_CORRELATION
@ TCD_ABS_UNCENTERED_CORRELATION
'x': Absolute uncentered Pearson correlation
Definition: ms_treecluster.hpp:64
matrix_science::ms_treecluster::TCD_UNCENTERED_CORRELATION
@ TCD_UNCENTERED_CORRELATION
'u': Uncentered Pearson correlation (equivalent to the cosine of the angle between two data vectors)
Definition: ms_treecluster.hpp:63
matrix_science::ms_treecluster::TCD_SPEARMANS_RANK_CORRELATION
@ TCD_SPEARMANS_RANK_CORRELATION
's': Spearman�s rank correlation;
Definition: ms_treecluster.hpp:65
matrix_science::ms_treecluster::TCD_CORRELATION
@ TCD_CORRELATION
'c': Pearson correlation coefficient
Definition: ms_treecluster.hpp:61
matrix_science::ms_treecluster::TCD_ABS_CORRELATION
@ TCD_ABS_CORRELATION
'a': Absolute value of the Pearson correlation coefficient
Definition: ms_treecluster.hpp:62
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_aminoacid.hpp Source File

  • inc
ms_umod_aminoacid.hpp
1/*
2##############################################################################
3# file: ms_umod_aminoacid.hpp #
4# 'msparser' toolkit #
5# Represents 'amino acid' object from unimod.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_umod_aminoacid.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_UMOD_AMINOACID_HPP
18#define MS_UMOD_AMINOACID_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_umod_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_umod_elemref; // forward declaration
32 class ms_xml_schema; // forward declaration
33
40 class MS_MASCOTRESFILE_API ms_umod_aminoacid: public ms_xml_IValidatable
41 {
42 friend class msparser_internal::ms_umod_xmlloader;
43 friend class ms_umod_configfile;
44
45 public:
47 ms_umod_aminoacid();
48
50 ms_umod_aminoacid(const ms_umod_aminoacid& src);
51
53 virtual ~ms_umod_aminoacid();
54
56 void defaultValues();
57
59 void copyFrom(const ms_umod_aminoacid* right);
60
61#ifndef SWIG
63 ms_umod_aminoacid& operator=(const ms_umod_aminoacid& right);
64#endif
66 virtual std::string getSchemaType() const;
67
69 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
70
72 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
73
74
76 int getNumberOfElemRefs() const;
77
79 void clearElemRefs();
80
82 void appendElemRef(const ms_umod_elemref *elemref);
83
85 const ms_umod_elemref* getElemRef(const int idx) const;
86
88 bool updateElemRef(const int idx, const ms_umod_elemref *elemref);
89
91 bool deleteElemRef(const int idx);
92
94 std::string getElemRefSchemaType() const;
95
96
98 bool haveTitle() const;
99
101 std::string getTitle() const;
102
104 void setTitle(const char* value);
105
107 void dropTitle();
108
110 std::string getTitleSchemaType() const;
111
112
114 bool haveThreeLetter() const;
115
117 std::string getThreeLetter() const;
118
120 void setThreeLetter(const char* value);
121
123 void dropThreeLetter();
124
126 std::string getThreeLetterSchemaType() const;
127
128
130 bool haveFullName() const;
131
133 std::string getFullName() const;
134
136 void setFullName(const char* value);
137
139 void dropFullName();
140
142 std::string getFullNameSchemaType() const;
143
144
146 bool haveAvgeMass() const;
147
149 double getAvgeMass() const;
150
152 void setAvgeMass(const double value);
153
155 void dropAvgeMass();
156
158 std::string getAvgeMassSchemaType() const;
159
160
162 bool haveMonoMass() const;
163
165 double getMonoMass() const;
166
168 void setMonoMass(const double value);
169
171 void dropMonoMass();
172
174 std::string getMonoMassSchemaType() const;
175
176 private:
177
178 typedef std::vector< ms_umod_elemref* > elemref_vector;
179 elemref_vector _elemRefs;
180
181 std::string _title;
182 bool _title_set;
183
184 std::string _threeLetter;
185 bool _threeLetter_set;
186
187 std::string _fullName;
188 bool _fullName_set;
189
190 double _avgeMass;
191 bool _avgeMass_set;
192
193 double _monoMass;
194 bool _monoMass_set;
195 }; // class ms_umod_aminoacid
196 // end of config_group
198
199} // namespace matrix_science
200
201#endif // MS_UMOD_AMINOACID_HPP
202
203/*------------------------------- End of File -------------------------------*/
matrix_science::ms_umod_aminoacid
Represents an "amino acid" object in unimod.xml.
Definition: ms_umod_aminoacid.hpp:41
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_elemref
Represents the elemref_t type in unimod.xml.
Definition: ms_umod_elemref.hpp:45
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_composition.hpp Source File

  • inc
ms_umod_composition.hpp
1/*
2##############################################################################
3# file: ms_umod_composition.hpp #
4# 'msparser' toolkit #
5# Represents 'composition_t' type from unimod.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_umod_composition.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_UMOD_COMPOSITION_HPP
18#define MS_UMOD_COMPOSITION_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_umod_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_umod_elemref; // forward declaration
32 class ms_quant_composition; // forward declaration
33 class ms_quant_component; // forward declaration
34 class ms_umod_configfile; // forward declaration
35 class ms_xml_schema; // forward declaration
36
43
47 class MS_MASCOTRESFILE_API ms_umod_composition: public ms_xml_IValidatable
48 {
49 friend class msparser_internal::ms_umod_xmlloader;
50 friend class ms_umod_configfile;
51
52 public:
54 ms_umod_composition();
55
57 ms_umod_composition(const ms_umod_composition& src);
58
60 ms_umod_composition(const ms_quant_composition& src, const ms_umod_configfile& umodFile);
61
63 void updateMasses(const ms_umod_configfile& umodFile, const ms_quant_component& quantComp);
64
66 virtual ~ms_umod_composition();
67
69 void defaultValues();
70
72 void copyFrom(const ms_umod_composition* right);
73
75 void copyFrom(const ms_quant_composition* right, const ms_umod_configfile& umodFile);
76
77#ifndef SWIG
79 ms_umod_composition& operator=(const ms_umod_composition& right);
80#endif
82 virtual std::string getSchemaType() const;
83
85 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
86
88 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
89
90
92 int getNumberOfElemRefs() const;
93
95 void clearElemRefs();
96
98 void appendElemRef(const ms_umod_elemref *elemref);
99
101 const ms_umod_elemref* getElemRef(const int idx) const;
102
104 bool updateElemRef(const int idx, const ms_umod_elemref *elemref);
105
107 bool deleteElemRef(const int idx);
108
110 std::string getElemRefSchemaType() const;
111
112
114 bool haveCompositionString() const;
115
117 std::string getCompositionString() const;
118
120 void setCompositionString(const char* value);
121
123 void dropCompositionString();
124
126 std::string getCompositionStringSchemaType() const;
127
128
130 bool haveAvgeMass() const;
131
133 double getAvgeMass() const;
134
136 void setAvgeMass(const double value);
137
139 void dropAvgeMass();
140
142 std::string getAvgeMassSchemaType() const;
143
144
146 bool haveMonoMass() const;
147
149 double getMonoMass() const;
150
152 void setMonoMass(const double value);
153
155 void dropMonoMass();
156
158 std::string getMonoMassSchemaType() const;
159
161 bool isSameAs(const ms_umod_composition& right) const;
162
163 private:
164
165 typedef std::vector< ms_umod_elemref* > elemref_vector;
166 elemref_vector _elemRefs;
167
168 std::string _composition;
169 bool _composition_set;
170
171 double _avgeMass;
172 bool _avgeMass_set;
173
174 double _monoMass;
175 bool _monoMass_set;
176 }; // class ms_umod_composition
177 // end of config_group
179
180} // namespace matrix_science
181
182#endif // MS_UMOD_COMPOSITION_HPP
183
184/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_composition
Describes the compositionType type in quantitation.xml.
Definition: ms_quant_composition.hpp:120
matrix_science::ms_umod_composition
Represents the composition type in unimod.xml.
Definition: ms_umod_composition.hpp:48
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_elemref
Represents the elemref_t type in unimod.xml.
Definition: ms_umod_elemref.hpp:45
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_configfile.hpp Source File

  • inc
ms_umod_configfile.hpp
1/*
2##############################################################################
3# file: ms_umod_configfile.hpp #
4# 'msparser' toolkit #
5# Represents unimod.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_umod_configfile.hpp $ #
12# $Author: francoisr@matrixscience.com $ #
13# $Date: 2019-03-08 13:54:54 +0000 $ #
14# $Revision: 7979cc541377e595bc9460c7439a78c7ed72e3d9 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_UMOD_CONFIGFILE_HPP
20#define MS_UMOD_CONFIGFILE_HPP
21
22
23#include <string>
24#include <vector>
25
26
27namespace matrix_science {
28
29 class ms_umod_element; // forward declaration
30 class ms_umod_modification; // forward declaration
31 class ms_umod_aminoacid; // forward declaration
32 class ms_umod_modbrick; // forward declaration
33 class ms_session;
34
41
53 class MS_MASCOTRESFILE_API ms_umod_configfile: public ms_errors
54 {
55 public:
57
64 enum MODFILE_FLAGS
65 {
66 MODFILE_FLAGS_EMPTY = 0x00000000,
67 MODFILE_FLAGS_REGULAR = 0x00000001,
68 MODFILE_FLAGS_HIDDEN = 0x00000002,
69 MODFILE_FLAGS_AASUBST = 0x00000004,
70 MODFILE_FLAGS_ALL = 0x7FFFFFFF
71 };
72
74 ms_umod_configfile();
75
77 ms_umod_configfile(const char* fileName, const char* schemaFileName,
78 const ms_connection_settings * cs = 0, bool useSchema = true);
79
81 ms_umod_configfile(const ms_umod_configfile& right);
82
84 virtual ~ms_umod_configfile();
85
86#ifndef SWIG
88 ms_umod_configfile& operator=(const ms_umod_configfile& right);
89#endif
91 void copyFrom(const ms_umod_configfile* right);
92
94 virtual void defaultValues();
95
97 void updateMasses();
98
99
101 std::string getFileName() const;
102
104 void setFileName(const char* filename);
105
106
108 void setSchemaFileName(const char* name);
109
111 std::string getSchemaFileName() const;
112
114 static std::string getDefaultSchemaFileName();
115
117 void setConnectionSettings(const ms_connection_settings & cs);
118
120 ms_connection_settings getConnectionSettings() const;
121
122
124 void read_file();
125
127 void save_file();
128
130 void applyVisibility( const ms_session *session);
131
133 void applyVisibility(const std::vector<int> & groupIds);
134
136 void read_buffer(const char* buffer);
137
139 std::string save_buffer(bool validateAgainstSchema = true);
140
141
143 std::string validateDocument() const;
144
145
147 int getNumberOfElements() const;
148
150 void clearElements();
151
153 void appendElement(const ms_umod_element *elem);
154
156 const ms_umod_element * getElementByNumber(const int idx) const;
157
159 const ms_umod_element * getElementByName(const char *name) const;
160
162 bool updateElementByNumber(const int idx, const ms_umod_element* element);
163
165 bool updateElementByName(const char *name, const ms_umod_element* element);
166
168 bool deleteElementByNumber(const int idx);
169
171 bool deleteElementByName(const char *name);
172
173
175 std::vector< std::string > getModFileList(const unsigned int flags = MODFILE_FLAGS_ALL) const;
176
178 int findModFileName(const char * modFileName) const;
179
181 int findModification(const char* modName) const;
182
183
185 int getNumberOfModifications() const;
186
188 void clearModifications();
189
191 void appendModification(const ms_umod_modification *mod);
192
194 const ms_umod_modification * getModificationByNumber(const int idx) const;
195
197 const ms_umod_modification * getModificationByName(const char *name) const;
198
200 bool updateModificationByNumber(const int idx, const ms_umod_modification *mod);
201
203 bool updateModificationByName(const char *name, const ms_umod_modification *mod);
204
206 bool deleteModificationByNumber(const int idx);
207
209 bool deleteModificationByName(const char *name);
210
211
213 int getNumberOfAminoAcids() const;
214
216 void clearAminoAcids();
217
219 void appendAminoAcid(const ms_umod_aminoacid *aa);
220
222 const ms_umod_aminoacid * getAminoAcidByNumber(const int idx) const;
223
225 const ms_umod_aminoacid * getAminoAcidByName(const char *name) const;
226
228 bool updateAminoAcidByNumber(const int idx, const ms_umod_aminoacid *aa);
229
231 bool updateAminoAcidByName(const char *name, const ms_umod_aminoacid *aa);
232
234 bool deleteAminoAcidByNumber(const int idx);
235
237 bool deleteAminoAcidByName(const char *name);
238
239
241 int getNumberOfModBricks() const;
242
244 void clearModBricks();
245
247 void appendModBrick(const ms_umod_modbrick *brick);
248
250 const ms_umod_modbrick * getModBrickByNumber(const int idx) const;
251
253 const ms_umod_modbrick * getModBrickByName(const char *name) const;
254
256 bool updateModBrickByNumber(const int idx, const ms_umod_modbrick *brick);
257
259 bool updateModBrickByName(const char *name, const ms_umod_modbrick *brick);
260
262 bool deleteModBrickByNumber(const int idx);
263
265 bool deleteModBrickByName(const char *name);
266
268 std::string getMajorVersion() const;
269
271 std::string getMinorVersion() const;
272
274 void setMajorVersion(const std::string & version);
275
277 void setMinorVersion(const std::string & version);
278 private:
279
280 void applyVisibilityHelper();
281
282 std::string m_fileName;
283 std::string m_schemaFileName;
284 ms_connection_settings m_cs;
285
286 typedef std::vector< ms_umod_element* > element_vector;
287 element_vector m_elements;
288
289 typedef std::vector< ms_umod_modification* > modification_vector;
290 modification_vector m_modifications;
291 typedef std::map<std::string, size_t> modification_index_map;
292 modification_index_map m_modifications_nameToIndex;
293
294 typedef std::vector< ms_umod_aminoacid* > aminoacid_vector;
295 aminoacid_vector m_aminoacids;
296
297 typedef std::vector< ms_umod_modbrick* > modbrick_vector;
298 modbrick_vector m_modbricks;
299
300 std::string m_majorVersion;
301 std::string m_minorVersion;
302
303 std::string m_encodingName;
304 bool m_useSchema;
305 }; // class ms_umod_configfile
306 // end of config_group
308
309} // namespace matrix_science
310
311#endif // MS_UMOD_CONFIGFILE_HPP
312/*------------------------------- End of File -------------------------------*/
matrix_science::ms_connection_settings
Settings required to make an HTTP connection to a Mascot server.
Definition: ms_connection_settings.hpp:54
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_session
Use this class to determine if a user is logged in and if they have 'permission' to perform tasks.
Definition: ms_security_session.hpp:123
matrix_science::ms_umod_aminoacid
Represents an "amino acid" object in unimod.xml.
Definition: ms_umod_aminoacid.hpp:41
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_configfile::MODFILE_FLAGS
MODFILE_FLAGS
Flags for the type of modifications to retrieve.
Definition: ms_umod_configfile.hpp:65
matrix_science::ms_umod_element
Represents an element object in unimod.xml.
Definition: ms_umod_element.hpp:40
matrix_science::ms_umod_modbrick
Represents a modification brick object in unimod.xml.
Definition: ms_umod_modbrick.hpp:41
matrix_science::ms_umod_modification
Represents a modif object in unimod.xml.
Definition: ms_umod_modification.hpp:47
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_element.hpp Source File

  • inc
ms_umod_element.hpp
1/*
2##############################################################################
3# file: ms_umod_element.hpp #
4# 'msparser' toolkit #
5# Represents chemical element information from unimod.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_umod_element.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_UMOD_ELEMENT_HPP
18#define MS_UMOD_ELEMENT_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_umod_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_xml_schema; // forward declaration
32
39 class MS_MASCOTRESFILE_API ms_umod_element: public ms_xml_IValidatable
40 {
41 friend class msparser_internal::ms_umod_xmlloader;
42 friend class ms_umod_configfile;
43
44 public:
46 ms_umod_element();
47
49 ms_umod_element(const ms_umod_element& src);
50
52 virtual ~ms_umod_element();
53
55 void defaultValues();
56
58 void copyFrom(const ms_umod_element* right);
59
60#ifndef SWIG
62 ms_umod_element& operator=(const ms_umod_element& right);
63#endif
65 virtual std::string getSchemaType() const;
66
68 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
69
71 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
72
73
75 bool haveTitle() const;
76
78 std::string getTitle() const;
79
81 void setTitle(const char* value);
82
84 void dropTitle();
85
87 std::string getTitleSchemaType() const;
88
89
91 bool haveFullName() const;
92
94 std::string getFullName() const;
95
97 void setFullName(const char* value);
98
100 void dropFullName();
101
103 std::string getFullNameSchemaType() const;
104
105
107 bool haveAvgeMass() const;
108
110 std::string getAvgeMass() const;
111
113 double getAvgeMassAsNumber() const;
114
116 bool setAvgeMass(const char* value, ms_errs* err = NULL);
117
119 void dropAvgeMass();
120
122 std::string getAvgeMassSchemaType() const;
123
124
126 bool haveMonoMass() const;
127
129 std::string getMonoMass() const;
130
132 double getMonoMassAsNumber() const;
133
135 bool setMonoMass(const char* value, ms_errs* err = NULL);
136
138 void dropMonoMass();
139
141 std::string getMonoMassSchemaType() const;
142
143 private:
144 std::string _title;
145 bool _title_set;
146
147 std::string _fullName;
148 bool _fullName_set;
149
150 std::string _avgeMass;
151 double _avgeMassDouble;
152 bool _avgeMass_set;
153
154 std::string _monoMass;
155 double _monoMassDouble;
156 bool _monoMass_set;
157 }; // class ms_umod_element
158 // end of config_group
160
161} // namespace matrix_science
162
163#endif // MS_UMOD_ELEMENT_HPP
164
165/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errs
All errors are collected in an instance of this class.
Definition: ms_errors.hpp:37
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_element
Represents an element object in unimod.xml.
Definition: ms_umod_element.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_elemref.hpp Source File

  • inc
ms_umod_elemref.hpp
1/*
2##############################################################################
3# file: ms_umod_elemref.hpp #
4# 'msparser' toolkit #
5# Represents 'elemref_t' type in unimod.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_umod_elemref.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_UMOD_ELEMREF_HPP
18#define MS_UMOD_ELEMREF_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_umod_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_quant_element; // forward declaration;
32 class ms_xml_schema; // forward declaration
33
40
44 class MS_MASCOTRESFILE_API ms_umod_elemref: public ms_xml_IValidatable
45 {
46 friend class msparser_internal::ms_umod_xmlloader;
47 friend class ms_umod_configfile;
48
49 public:
51 ms_umod_elemref();
52
54 ms_umod_elemref(const ms_umod_elemref& src);
55
57 ms_umod_elemref(const ms_quant_element& src);
58
59
61 virtual ~ms_umod_elemref();
62
64 void defaultValues();
65
67 void copyFrom(const ms_umod_elemref* right);
68
70 void copyFrom(const ms_quant_element* right);
71
72#ifndef SWIG
74 ms_umod_elemref& operator=(const ms_umod_elemref& right);
75#endif
77 virtual std::string getSchemaType() const;
78
80 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
81
83 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
84
85
87 bool haveSymbol() const;
88
90 std::string getSymbol() const;
91
93 void setSymbol(const char* value);
94
96 void dropSymbol();
97
99 std::string getSymbolSchemaType() const;
100
101
103 bool haveNumber() const;
104
106 int getNumber() const;
107
109 void setNumber(const int value);
110
112 void dropNumber();
113
115 std::string getNumberSchemaType() const;
116
117 private:
118
119 std::string _symbol;
120 bool _symbol_set;
121
122 int _number;
123 bool _number_set;
124 }; // class ms_umod_elemref
125 // end of config_group
127
128} // namespace matrix_science
129
130#endif // MS_UMOD_ELEMREF_HPP
131
132/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_element
The element sub-element of compositionType in quantitation.xml.
Definition: ms_quant_composition.hpp:40
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_elemref
Represents the elemref_t type in unimod.xml.
Definition: ms_umod_elemref.hpp:45
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_modbrick.hpp Source File

  • inc
ms_umod_modbrick.hpp
1/*
2##############################################################################
3# file: ms_umod_modbrick.hpp #
4# 'msparser' toolkit #
5# Represents modbrick object from unimod.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_umod_modbrick.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_UMOD_MODBRICK_HPP
18#define MS_UMOD_MODBRICK_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_umod_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_umod_elemref; // forward declaration
32 class ms_xml_schema; // forward declaration
33
40 class MS_MASCOTRESFILE_API ms_umod_modbrick: public ms_xml_IValidatable
41 {
42 friend class msparser_internal::ms_umod_xmlloader;
43 friend class ms_umod_configfile;
44
45 public:
47 ms_umod_modbrick();
48
50 ms_umod_modbrick(const ms_umod_modbrick& src);
51
53 virtual ~ms_umod_modbrick();
54
56 void defaultValues();
57
59 void copyFrom(const ms_umod_modbrick* right);
60
61#ifndef SWIG
63 ms_umod_modbrick& operator=(const ms_umod_modbrick& right);
64#endif
66 virtual std::string getSchemaType() const;
67
69 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
70
72 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
73
74
76 int getNumberOfElemRefs() const;
77
79 void clearElemRefs();
80
82 void appendElemRef(const ms_umod_elemref *elemref);
83
85 const ms_umod_elemref* getElemRef(const int idx) const;
86
88 bool updateElemRef(const int idx, const ms_umod_elemref *elemref);
89
91 bool deleteElemRef(const int idx);
92
94 std::string getElemRefSchemaType() const;
95
96
98 bool haveTitle() const;
99
101 std::string getTitle() const;
102
104 void setTitle(const char* value);
105
107 void dropTitle();
108
110 std::string getTitleSchemaType() const;
111
112
114 bool haveFullName() const;
115
117 std::string getFullName() const;
118
120 void setFullName(const char* value);
121
123 void dropFullName();
124
126 std::string getFullNameSchemaType() const;
127
128
130 bool haveAvgeMass() const;
131
133 double getAvgeMass() const;
134
136 void setAvgeMass(const double value);
137
139 void dropAvgeMass();
140
142 std::string getAvgeMassSchemaType() const;
143
144
146 bool haveMonoMass() const;
147
149 double getMonoMass() const;
150
152 void setMonoMass(const double value);
153
155 void dropMonoMass();
156
158 std::string getMonoMassSchemaType() const;
159
160 private:
161
162 typedef std::vector< ms_umod_elemref* > elemref_vector;
163 elemref_vector _elemRefs;
164
165 std::string _title;
166 bool _title_set;
167
168 std::string _fullName;
169 bool _fullName_set;
170
171 double _avgeMass;
172 bool _avgeMass_set;
173
174 double _monoMass;
175 bool _monoMass_set;
176 }; // class ms_umod_modbrick
177 // end of config_group
179
180} // namespace matrix_science
181
182#endif // MS_UMOD_MODBRICK_HPP
183
184/*------------------------------- End of File -------------------------------*/
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_elemref
Represents the elemref_t type in unimod.xml.
Definition: ms_umod_elemref.hpp:45
matrix_science::ms_umod_modbrick
Represents a modification brick object in unimod.xml.
Definition: ms_umod_modbrick.hpp:41
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_modification.hpp Source File

  • inc
ms_umod_modification.hpp
1/*
2##############################################################################
3# file: ms_umod_modification.hpp #
4# 'msparser' toolkit #
5# Represents modification object in unimod.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_umod_modification.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_UMOD_MODIFICATION_HPP
18#define MS_UMOD_MODIFICATION_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_umod_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_umod_composition; // forward declaration
32 class ms_umod_specificity; // forward declaration
33 class ms_umod_xref; // forward declaration
34 class ms_quant_localdef; // forward declaration
35 class ms_quant_unmodified; // forward declaration
36 class ms_umod_configfile; // forward declaration
37 class ms_quant_component; // forward declaration
38 class ms_xml_schema; // forward declaration
39
46 class MS_MASCOTRESFILE_API ms_umod_modification: public ms_xml_IValidatable
47 {
48 friend class msparser_internal::ms_umod_xmlloader;
49 friend class ms_umod_configfile;
50
51 public:
53 ms_umod_modification();
54
56 ms_umod_modification(const ms_umod_modification& src);
57
59 ms_umod_modification(const ms_quant_localdef& src, const ms_umod_configfile& umodFile);
60
62 ms_umod_modification(const ms_quant_unmodified& src);
63
65 void updateMasses(const ms_umod_configfile& umodFile, const ms_quant_component& quantComp);
66
68 virtual ~ms_umod_modification();
69
71 void defaultValues();
72
74 void copyFrom(const ms_umod_modification* right);
75
77 void copyFrom(const ms_quant_localdef* right, const ms_umod_configfile& umodFile);
78
80 void copyFrom(const ms_quant_unmodified* right);
81
82#ifndef SWIG
84 ms_umod_modification& operator=(const ms_umod_modification& right);
85#endif
86
88 bool isSameAs(const ms_umod_modification& right_mod) const;
89
91 virtual std::string getSchemaType() const;
92
94 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
95
97 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
98
99
101 std::vector< std::string > getModFileList(const unsigned int flags = ms_umod_configfile::MODFILE_FLAGS_ALL) const;
102
104 int findSpecGroup(const char* modFileName) const;
105
107 int getNumberOfSpecificities() const;
108
110 void clearSpecificities();
111
113 void appendSpecificity(const ms_umod_specificity *specificity);
114
116 const ms_umod_specificity * getSpecificity(const int idx) const;
117
119 const ms_umod_specificity * getSpecificityBySite(const char *site) const;
120
122 const ms_umod_specificity * getSpecificityBySiteAndPosition(const char *site, const char *position) const;
123
125 bool updateSpecificity(const int idx, const ms_umod_specificity *specificity);
126
128 bool deleteSpecificity(const int idx);
129
131 std::string getSpecificitySchemaType() const;
132
133
135 bool haveDelta() const;
136
138 const ms_umod_composition* getDelta() const;
139
141 void setDelta(const ms_umod_composition* delta);
142
144 void dropDelta();
145
147 std::string getDeltaSchemaType() const;
148
149
151 int getNumberOfIgnores() const;
152
154 void clearIgnores();
155
157 void appendIgnore(const ms_umod_composition *ignore);
158
160 const ms_umod_composition * getIgnore(const int idx) const;
161
163 bool updateIgnore(const int idx, const ms_umod_composition *ignore);
164
166 bool deleteIgnore(const int idx);
167
169 std::string getIgnoreSchemaType() const;
170
171
173 int getNumberOfAltNames() const;
174
176 void clearAltNames();
177
179 void appendAltName(const char *alt_name);
180
182 std::string getAltName(const int idx) const;
183
185 bool updateAltName(const int idx, const char *alt_name);
186
188 bool deleteAltName(const int idx);
189
191 std::string getAltNameSchemaType() const;
192
193
195 int getNumberOfXrefs() const;
196
198 void clearXrefs();
199
201 void appendXref(const ms_umod_xref *xref);
202
204 const ms_umod_xref* getXref(const int idx) const;
205
207 bool updateXref(const int idx, const ms_umod_xref *xref);
208
210 bool deleteXref(const int idx);
211
213 std::string getXrefSchemaType() const;
214
215
217 bool haveMiscNotes() const;
218
220 std::string getMiscNotes() const;
221
223 void setMiscNotes(const char* value);
224
226 void dropMiscNotes();
227
229 std::string getMiscNotesSchemaType() const;
230
231
233 bool haveTitle() const;
234
236 std::string getTitle() const;
237
239 void setTitle(const char* value);
240
242 void dropTitle();
243
245 std::string getTitleSchemaType() const;
246
247
249 bool haveFullName() const;
250
252 std::string getFullName() const;
253
255 void setFullName(const char* value);
256
258 void dropFullName();
259
261 std::string getFullNameSchemaType() const;
262
263
265 bool haveApproved() const;
266
268 bool isApproved() const;
269
271 void setApproved(const bool value);
272
274 void dropApproved();
275
277 std::string getApprovedSchemaType() const;
278
279
281 bool haveUsernameOfPoster() const;
282
284 std::string getUsernameOfPoster() const;
285
287 void setUsernameOfPoster(const char* value);
288
290 void dropUsernameOfPoster();
291
293 std::string getUsernameOfPosterSchemaType() const;
294
295
297 bool haveGroupOfPoster() const;
298
300 std::string getGroupOfPoster() const;
301
303 void setGroupOfPoster(const char* value);
304
306 void dropGroupOfPoster();
307
309 std::string getGroupOfPosterSchemaType() const;
310
311
313 bool haveDateTimePosted() const;
314
316 std::string getDateTimePosted() const;
317
319 void setDateTimePosted(const char* value);
320
322 void dropDateTimePosted();
323
325 std::string getDateTimePostedSchemaType() const;
326
327
329 bool haveDateTimeModified() const;
330
332 std::string getDateTimeModified() const;
333
335 void setDateTimeModified(const char* value);
336
338 void dropDateTimeModified();
339
341 std::string getDateTimeModifiedSchemaType() const;
342
344 bool haveRecordID() const;
345
347 std::string getRecordID() const;
348
350 void setRecordID(const char* value);
351
353 void dropRecordID();
354
356 std::string getRecordIDSchemaType() const;
357
359 bool isPrivate() const;
360
362 void setPrivate(bool b);
363
365 bool isPrivacyEnabled() const;
366
368 void setPrivacyEnabled(bool b);
369
370 private:
371
372 typedef std::vector< ms_umod_specificity * > specificity_vector;
373 specificity_vector _specificities;
374
375 ms_umod_composition* _delta;
376 bool _delta_set;
377
378 typedef std::vector< ms_umod_composition* > ignore_vector;
379 ignore_vector _ignores;
380
381 typedef std::vector< std::string > altNames_vector;
382 altNames_vector _altnames;
383
384 typedef std::vector< ms_umod_xref* > xref_vector;
385 xref_vector _xrefs;
386
387 std::string _miscNotes;
388 bool _miscNotes_set;
389
390 std::string _title;
391 bool _title_set;
392
393 std::string _fullName;
394 bool _fullName_set;
395
396 bool _approved;
397 bool _approved_set;
398
399 std::string _usernameOfPoster;
400 bool _usernameOfPoster_set;
401
402 std::string _groupOfPoster;
403 bool _groupOfPoster_set;
404
405 std::string _dateTimePosted;
406 bool _dateTimePosted_set;
407
408 std::string _dateTimeModified;
409 bool _dateTimeModified_set;
410
411 std::string _recordID;
412 bool _recordID_set;
413
414 bool _isPrivate;
415 bool _isPrivacyEnabled;
416
417 }; // class ms_umod_modification
418 // end of config_group
420
421} // namespace matrix_science
422
423#endif // MS_UMOD_MODIFICATION_HPP
424
425/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_component
An object of this class represent a single component element in quantitation.xml.
Definition: ms_quant_component.hpp:48
matrix_science::ms_quant_localdef
Represents a local_definition element.
Definition: ms_quant_localdef.hpp:42
matrix_science::ms_quant_unmodified
Describes an unmodified element in quantitation.xml.
Definition: ms_quant_unmodified.hpp:39
matrix_science::ms_umod_composition
Represents the composition type in unimod.xml.
Definition: ms_umod_composition.hpp:48
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_modification
Represents a modif object in unimod.xml.
Definition: ms_umod_modification.hpp:47
matrix_science::ms_umod_specificity
Represents modification specificity objects in unimod.xml.
Definition: ms_umod_specificity.hpp:43
matrix_science::ms_umod_xref
Represents the cross references objects in unimod.xml.
Definition: ms_umod_xref.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_neutralloss.hpp Source File

  • inc
ms_umod_neutralloss.hpp
1/*
2##############################################################################
3# file: ms_umod_neutralloss.hpp #
4# 'msparser' toolkit #
5# Represents 'NeutralLoss' element in unimod.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_umod_neutralloss.hpp $
12 * @(#)$Revision: 0bb105c754f1d83ce7437808601186f321028555 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2019-04-17 12:17:44 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_UMOD_NEUTRALLOSS_HPP
18#define MS_UMOD_NEUTRALLOSS_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_umod_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_quant_neutralloss; // forward declaration
32 class ms_quant_pepneutralloss; // forward declaration
33 class ms_umod_configfile;
34 class ms_xml_schema; // forward declaration
35
42
47 class MS_MASCOTRESFILE_API ms_umod_neutralloss: public ms_umod_composition
48 {
49 friend class msparser_internal::ms_umod_xmlloader;
50
51 public:
53 ms_umod_neutralloss();
54
56 ms_umod_neutralloss(const ms_umod_neutralloss& src);
57
59 ms_umod_neutralloss(const ms_quant_neutralloss& src, const ms_umod_configfile& umodFile);
60
62 ms_umod_neutralloss(const ms_quant_pepneutralloss& src, const ms_umod_configfile& umodFile);
63
65 virtual ~ms_umod_neutralloss();
66
68 void defaultValues();
69
71 void copyFrom(const ms_umod_neutralloss* right);
72
74 void copyFrom(const ms_quant_neutralloss* right, const ms_umod_configfile& umodFile);
75
77 void copyFrom(const ms_quant_pepneutralloss* right, const ms_umod_configfile& umodFile);
78
79#ifndef SWIG
81 ms_umod_neutralloss& operator=(const ms_umod_neutralloss& right);
82#endif
84 virtual std::string getSchemaType() const;
85
87 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
88
90 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
91
92
94 bool haveFlag() const;
95
97 bool isFlag() const;
98
100 void setFlag(const bool value);
101
103 void dropFlag();
104
106 std::string getFlagSchemaType() const;
107
108
110 bool haveCode() const;
111
113 std::string getCode() const;
114
116 void setCode(const char* value);
117
119 void dropCode();
120
122 std::string getCodeSchemaType() const;
123
124
126 bool havePairsWith() const;
127
129 std::string getPairsWith() const;
130
132 void setPairsWith(const char* value);
133
135 void dropPairsWith();
136
138 std::string getPairsWithSchemaType() const;
139
140
142 bool haveDescription() const;
143
145 std::string getDescription() const;
146
148 void setDescription(const char* value);
149
151 void dropDescription();
152
154 std::string getDescriptionSchemaType() const;
155
156 private:
157
158 bool _flag;
159 bool _flag_set;
160
161 std::string _code;
162 bool _code_set;
163
164 std::string _pairsWith;
165 bool _pairsWith_set;
166
167 std::string _description;
168 bool _description_set;
169 }; // class ms_umod_neutralloss
170 // end of config_group
172
173} // namespace matrix_science
174
175#endif // MS_UMOD_NEUTRALLOSS_HPP
176
177/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_neutralloss
A neutral loss for the sequence ions, e.g. loss of phosphate.
Definition: ms_quant_neutralloss.hpp:37
matrix_science::ms_quant_pepneutralloss
A neutral loss from the precursor.
Definition: ms_quant_pepneutralloss.hpp:37
matrix_science::ms_umod_composition
Represents the composition type in unimod.xml.
Definition: ms_umod_composition.hpp:48
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_neutralloss
Represents NeutralLoss and PepNeutralLoss objects in unimod.xml.
Definition: ms_umod_neutralloss.hpp:48
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_specificity.hpp Source File

  • inc
ms_umod_specificity.hpp
1/*
2##############################################################################
3# file: ms_umod_specificity.hpp #
4# 'msparser' toolkit #
5# Represents 'specificity' object from unimod.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_umod_specificity.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_UMOD_SPECIFICITY_HPP
18#define MS_UMOD_SPECIFICITY_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_umod_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_umod_neutralloss; // forward declaration
32 class ms_quant_specificity; // forward declaration
33 class ms_umod_configfile; // forward declaration
34 class ms_xml_schema; // forward declaration
35
42 class MS_MASCOTRESFILE_API ms_umod_specificity
43 {
44 friend class msparser_internal::ms_umod_xmlloader;
45 friend class ms_umod_modification;
46 friend class ms_umod_configfile;
47
48 public:
50 ms_umod_specificity();
51
53 ms_umod_specificity(const ms_umod_specificity& src);
54
56 ms_umod_specificity(const ms_quant_specificity& src, const ms_umod_configfile& umodFile);
57
59 virtual ~ms_umod_specificity();
60
62 void defaultValues();
63
65 void copyFrom(const ms_umod_specificity* right);
66
68 void copyFrom(const ms_quant_specificity* right, const ms_umod_configfile& umodFile);
69
70#ifndef SWIG
72 ms_umod_specificity& operator=(const ms_umod_specificity& right);
73#endif
75 virtual std::string getSchemaType() const;
76
78 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
79
81 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
82
83
85 int getNumberOfNeutralLosses() const;
86
88 void clearNeutralLosses();
89
91 void appendNeutralLoss(const ms_umod_neutralloss *nl);
92
94 const ms_umod_neutralloss* getNeutralLoss(const int idx) const;
95
97 bool updateNeutralLoss(const int idx, const ms_umod_neutralloss *nl);
98
100 bool deleteNeutralLoss(const int idx);
101
103 std::string getNeutralLossSchemaType() const;
104
105
107 int getNumberOfPepNeutralLosses() const;
108
110 void clearPepNeutralLosses();
111
113 void appendPepNeutralLoss(const ms_umod_neutralloss *pnl);
114
116 const ms_umod_neutralloss* getPepNeutralLoss(const int idx) const;
117
119 bool updatePepNeutralLoss(const int idx, const ms_umod_neutralloss *pnl);
120
122 bool deletePepNeutralLoss(const int idx);
123
125 std::string getPepNeutralLossSchemaType() const;
126
127
129 bool haveMiscNotes() const;
130
132 std::string getMiscNotes() const;
133
135 void setMiscNotes(const char* value);
136
138 void dropMiscNotes();
139
141 std::string getMiscNotesSchemaType() const;
142
143
145 bool haveHidden() const;
146
148 bool isHidden() const;
149
151 void setHidden(const bool value);
152
154 void dropHidden();
155
157 std::string getHiddenSchemaType() const;
158
159
161 bool haveSite() const;
162
164 std::string getSite() const;
165
167 void setSite(const char* value);
168
170 void dropSite();
171
173 std::string getSiteSchemaType() const;
174
175
177 bool havePosition() const;
178
180 std::string getPosition() const;
181
183 void setPosition(const char* value);
184
186 void dropPosition();
187
189 std::string getPositionSchemaType() const;
190
191
193 bool haveClassification() const;
194
196 std::string getClassification() const;
197
199 void setClassification(const char* value);
200
202 void dropClassification();
203
205 std::string getClassificationSchemaType() const;
206
207
209 bool haveSpecGroup() const;
210
212 int getSpecGroup() const;
213
215 void setSpecGroup(const int value);
216
218 void dropSpecGroup();
219
221 std::string getSpecGroupSchemaType() const;
222
224 bool inShortList() const;
225
226 // ! Sets whether this specificity is in the short list on the Mascot search form.
227 void showInShortList(bool b);
228
230 bool inLongList() const;
231
232 // ! Sets whether this specificity is in the full list on the Mascot search form.
233 void showInLongList(bool b);
234
235 // ! Indicates if this specificity is included in error tolerant searches.
236 bool inErrorTolerant() const;
237
238 // ! Sets if this specificity is included in error tolerant searches.
239 void useInErrorTolerant(bool b);
240
242 bool isSameAs(const ms_umod_specificity& right) const;
243
244 private:
245
246 typedef std::vector< ms_umod_neutralloss* > nl_vector;
247 nl_vector _neutrallosses;
248
249 typedef std::vector< ms_umod_neutralloss* > pnl_vector;
250 pnl_vector _pepneutrallosses;
251
252 std::string _miscNotes;
253 bool _miscNotes_set;
254
255 bool _hidden;
256 bool _hidden_set;
257
258 std::string _site;
259 bool _site_set;
260
261 std::string _position;
262 bool _position_set;
263
264 std::string _classification;
265 bool _classification_set;
266
267 int _specGroup;
268 bool _specGroup_set;
269
270 // Not persistent in unimod xml files
271 bool _show_in_long_list;
272 bool _use_in_error_tolerant;
273
274 }; // class ms_umod_specificity
275 // end of config_group
277
278} // namespace matrix_science
279
280#endif // MS_UMOD_SPECIFICITY_HPP
281
282/*------------------------------- End of File -------------------------------*/
matrix_science::ms_quant_specificity
Describes a specificity element in quantitation.xml (Unimod style specificity).
Definition: ms_quant_specificity.hpp:45
matrix_science::ms_umod_configfile
This class represents the file unimod.xml.
Definition: ms_umod_configfile.hpp:54
matrix_science::ms_umod_modification
Represents a modif object in unimod.xml.
Definition: ms_umod_modification.hpp:47
matrix_science::ms_umod_neutralloss
Represents NeutralLoss and PepNeutralLoss objects in unimod.xml.
Definition: ms_umod_neutralloss.hpp:48
matrix_science::ms_umod_specificity
Represents modification specificity objects in unimod.xml.
Definition: ms_umod_specificity.hpp:43
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_umod_xref.hpp Source File

  • inc
ms_umod_xref.hpp
1/*
2##############################################################################
3# file: ms_umod_xref.hpp #
4# 'msparser' toolkit #
5# Represents 'xref_t' type in unimod.xml file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_umod_xref.hpp $
12 * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-07-30 16:23:53 +0100 $
14##############################################################################
15 */
16
17#ifndef MS_UMOD_XREF_HPP
18#define MS_UMOD_XREF_HPP
19
20
21#include <string>
22#include <vector>
23
24// forward declarations
25namespace msparser_internal {
26 class ms_umod_xmlloader;
27}
28
29namespace matrix_science {
30
31 class ms_xml_schema; // forward declaration
32
39 class MS_MASCOTRESFILE_API ms_umod_xref: public ms_xml_IValidatable
40 {
41 friend class msparser_internal::ms_umod_xmlloader;
42
43 public:
45 ms_umod_xref();
46
48 ms_umod_xref(const ms_umod_xref& src);
49
51 virtual ~ms_umod_xref();
52
54 void defaultValues();
55
57 void copyFrom(const ms_umod_xref* right);
58
59#ifndef SWIG
61 ms_umod_xref& operator=(const ms_umod_xref& right);
62#endif
64 virtual std::string getSchemaType() const;
65
67 virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
68
70 virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
71
72
74 bool haveText() const;
75
77 std::string getText() const;
78
80 void setText(const char* value);
81
83 void dropText();
84
86 std::string getTextSchemaType() const;
87
88
90 bool haveSource() const;
91
93 std::string getSource() const;
94
96 void setSource(const char* value);
97
99 void dropSource();
100
102 std::string getSourceSchemaType() const;
103
104
106 bool haveUrl() const;
107
109 std::string getUrl() const;
110
112 void setUrl(const char* value);
113
115 void dropUrl();
116
118 std::string getUrlSchemaType() const;
119
121 bool isSameAs(const ms_umod_xref& right) const;
122
123 private:
124
125 std::string _text;
126 bool _text_set;
127
128 std::string _source;
129 bool _source_set;
130
131 std::string _url;
132 bool _url_set;
133 }; // class ms_umod_xref
134 // end of config_group
136
137} // namespace matrix_science
138
139#endif // MS_UMOD_XREF_HPP
140
141/*------------------------------- End of File -------------------------------*/
matrix_science::ms_umod_xref
Represents the cross references objects in unimod.xml.
Definition: ms_umod_xref.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_unassigned.hpp Source File

  • src
  • resfile
  • impl
ms_unassigned.hpp
1/*
2##############################################################################
3# file: ms_unassigned.hpp #
4# 'msparser' toolkit #
5# Private class for unassigned peptide handling for ms_peptidesummary or #
6# ms_proteinsummary #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2010 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresul $ #
13# $Author$ #
14# $Date$ #
15# $Revision$ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_UNASSIGNED_HPP
21#define MS_UNASSIGNED_HPP
22
23// Includes from the standard template library
24#include <string>
25#include <vector>
26#include <set>
27
28#include "http/ms_mutex.hpp"
29
30#ifndef SWIG
31 // Helper class - don't use from outside library
32
33using namespace matrix_science;
34
35namespace msparser_internal {
36 // Helper classes - don't use from outside library
37 class ms_unassignedItem
38 {
39 public:
40 ms_unassignedItem(int query, int p, double sortingScore, double intensity)
41 : query_(query), p_(p), sortingScore_(sortingScore), intensity_(intensity) {};
42 ms_unassignedItem()
43 : query_(0), p_(0), sortingScore_(0), intensity_(0) {};
44 int getQuery() const { return query_; }
45 int getP() const { return p_; }
46 double getSortingScore() const { return sortingScore_; }
47 double getIntensity() const { return intensity_; }
48 void setQuery(int v) { query_ = v; }
49 void setP(int v) { p_ = v; }
50 void setSortingScore(double v) { sortingScore_ = v; }
51 void setIntensity(double v) { intensity_ = v; }
52 private:
53 int query_;
54 int p_;
55 double sortingScore_;
56 double intensity_;
57 };
58
59 class ms_unassignedSorter
60 {
61 public:
62 bool operator() (const ms_unassignedItem * i1, const ms_unassignedItem * i2) const;
63 void setMode(ms_mascotresults::sortBy mode) { mode_ = mode; }
64 ms_mascotresults::sortBy getMode() const { return mode_; }
65 private:
66 ms_mascotresults::sortBy mode_;
67 };
68
69 class ms_unassigned
70 {
71 public:
72 ms_unassigned(const ms_mascotresfilebase & resfile,
73 ms_mascotresultsbase & results,
74 ms_mascotresults::sortBy mode=ms_mascotresults::QUERY);
75 ms_unassigned(const ms_mascotresfilebase & resfile,
76 ms_mascotresultsbase & results,
77 int countFromCache,
78 const std::string & cachedUnassignedListAsString,
79 const bool parserVersion_2_5_OrOlder,
80 ms_mascotresults::sortBy mode=ms_mascotresults::QUERY);
81 ms_unassigned(const ms_mascotresfilebase & resfile,
82 ms_mascotresultsbase & results,
83 const int countFromCache,
84 const std::shared_ptr<ms_sqlpp11_connection>& dbPtr,
85 const int paramsId,
86 ms_mascotresults::sortBy mode=ms_mascotresults::QUERY);
87 ~ms_unassigned();
88 void setMode(ms_mascotresults::sortBy mode);
89 ms_mascotresults::sortBy getMode() const { return sorter_.getMode(); }
90 int getCount() const;
91 bool get(const int num, int & q, int & p, double & score, double & intensity) const;
92 void getAsString(std::string & str);
93 const std::vector<ms_unassignedItem *>& getUnassignedSorted() const{ return unassignedSorted_; }
94
95 private:
96 const ms_mascotresfilebase & resfile_;
97 ms_mascotresultsbase & results_;
98 ms_mutex mutex_;
99
100 int cachedUnassignedCount_;
101 std::string cachedUnassignedListAsString_;
102 std::shared_ptr<ms_sqlpp11_connection> dbPtr_;
103 int paramsId_;
104 bool loaded_;
105 bool haveIntensities_;
106 bool negateOldSortingScore_;
107
108 ms_unassignedSorter sorter_;
109 typedef std::vector<ms_unassignedItem> unassignedItemVect_t;
110 unassignedItemVect_t unassigned_;
111 typedef std::vector<ms_unassignedItem *> unassignedItemPtrVect_t;
112 unassignedItemPtrVect_t unassignedSorted_;
113
114 bool loadFromSqlCache();
115 bool loadFromCacheString();
116 bool loadFromCache() const;
117 double getQueryIntensity(const int q) const;
118 };
119}
120
121#endif // SWIG
122
123#endif // MS_UNASSIGNED_HPP
124
125/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_mascotresults::sortBy
sortBy
Flags for createUnassignedList().
Definition: ms_mascotresults.hpp:95
matrix_science::ms_mascotresults::QUERY
@ QUERY
Sort the unassigned list by ascending query number - this is the same as ascending relative mass orde...
Definition: ms_mascotresults.hpp:96
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_unigene.hpp Source File

  • inc
ms_unigene.hpp
1/*
2##############################################################################
3# file: ms_mascotrespeptide.hpp #
4# 'msparser' toolkit #
5# Encapsulates a Unigene file (from NCBI) #
6# #
7##############################################################################
8# COPYRIGHT NOTICE #
9# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
10# #
11##############################################################################
12# $Archive:: /Mowse/ms_mascotresfile/include/ms_unigene.hpp $ #
13# $Author: robertog@matrixscience.com $ #
14# $Date: 2023-08-29 15:05:00 +0100 $ #
15# $Revision: 59a8ab98151c86e0bdeddc2efea60d287d6087ba | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
16# $NoKeywords:: $ #
17##############################################################################
18*/
19
20#ifndef MS_MASCOTRESUNIGENE_HPP
21#define MS_MASCOTRESUNIGENE_HPP
22
23
24// Includes from the standard template library
25#include <stdio.h>
26#include <string>
27#include <vector>
28
29
30
31namespace matrix_science {
32 class ms_tinycdb;
33
40
45 class MS_MASCOTRESFILE_API ms_unigene_entry
46 {
47 public:
49 ms_unigene_entry(FILE * f, ms_unigene & unigene);
50
52 ms_unigene_entry(const std::string & id,
53 const std::string & title,
54 const std::string & gene,
55 const std::string & cytoBand,
56 const std::string & locusLink,
57 const std::string & express,
58 const long chromosome,
59 const int numAccessions,
60 const OFFSET64_T fileOffset);
61
63 ~ms_unigene_entry();
64
66
71 int getNumAccessions() const { return numAccessions_; }
72
74
77 std::string getID() const { return id_; }
78
80
83 std::string getTitle() const { return title_; }
84
86
89 std::string getGene() const { return gene_; }
90
92
95 std::string getCytoBand() const { return cytoBand_; }
96
98
102 std::string getLocusLink() const { return locuslink_; }
103
105
111 std::string getExpress() const { return express_; }
112
114
117 long getChromosome() const { return chromosome_; }
118
120
124 OFFSET64_T getFileOffset() const { return fileOffset_; }
125
126 protected:
127 // Not safe to copy or assign this object.
128#ifndef SWIG
129 ms_unigene_entry(const ms_unigene_entry & rhs);
130 ms_unigene_entry & operator=(const ms_unigene_entry & rhs);
131#endif
132 private:
134 bool getString(const char * buf, const char * id,
135 const int idLen, std::string &res);
136
138 bool getLong(const char * buf, const char * id,
139 const int idLen, long &res);
140
142 bool getAccessions(const char * buf, const char * id, const int idLen,
143 std::string & giNumber, std::string & accession);
144 std::string id_;
145 std::string title_;
146 std::string gene_;
147 std::string cytoBand_;
148 std::string locuslink_;
149 std::string express_;
150 long chromosome_;
151 int numAccessions_;
152 OFFSET64_T fileOffset_;
153 };
154
156
161 class MS_MASCOTRESFILE_API ms_unigene
162 {
163 friend class ms_unigene_entry;
164
165 public:
167 ms_unigene(const ms_mascotresfilebase& resfile, const char * filename);
168
169 virtual ~ms_unigene() = default;
170
172 virtual const ms_unigene_entry * findEntry(const char * id) = 0;
173
175 virtual std::string getUnigeneForAccession(const std::string accession,
176 const int index) = 0;
177
178 protected:
179 // Not safe to copy or assign this object.
180#ifndef SWIG
181 ms_unigene(const ms_unigene & rhs);
182 ms_unigene & operator=(const ms_unigene & rhs);
183#endif
185 void addAccessionUnigenePair(const ms_unigene_entry * unigene,
186 const std::string & accession);
187
188 protected:
189 const ms_mascotresfilebase& resfile_;
190 std::vector<ms_unigene_entry *> entries_;
191 std::string filename_;
192 int numAccessions_;
193 typedef std::multimap<std::string, const ms_unigene_entry *> unigenesForAcc;
194 unigenesForAcc accessionToUnigene_;
195
196 };
197
198
199 class MS_MASCOTRESFILE_API ms_unigene_dat : public ms_unigene
200 {
201 friend class ms_unigene_entry;
202
203 public:
205 ms_unigene_dat(const ms_mascotresfile_dat &resfile, const char * filename);
206
207 virtual ~ms_unigene_dat();
208
210 virtual const ms_unigene_entry * findEntry(const char * id);
211
213 virtual std::string getUnigeneForAccession(const std::string accession,
214 const int index);
215
216 protected:
217 // Not safe to copy or assign this object.
218#ifndef SWIG
219 ms_unigene_dat(const ms_unigene_dat & rhs);
220 ms_unigene_dat & operator=(const ms_unigene_dat & rhs);
221#endif
222 private:
223
224 ms_tinycdb * pcdb_;
225
226 }; // end of resfile_group
228} // matrix_science namespace
229
230
231#endif // MS_MASCOTRESUNIGENE_HPP
232
233/*------------------------------- End of File -------------------------------*/
matrix_science::ms_mascotresfile_dat
Class for parsing and reading files in dat28 format.
Definition: ms_mascotresfile_dat.hpp:121
matrix_science::ms_mascotresfilebase
Abstract base class of ms_mascotresfile_dat and ms_mascotresfile_msr.
Definition: ms_mascotresfilebase.hpp:72
matrix_science::ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokare...
Definition: ms_tinycdb.hpp:124
matrix_science::ms_unigene_entry
This class encapsulates a single entry from a unigene file.
Definition: ms_unigene.hpp:46
matrix_science::ms_unigene_entry::getNumAccessions
int getNumAccessions() const
Return the number of accessions (gi numbers or EMBL accessions) that comprise this entry.
Definition: ms_unigene.hpp:71
matrix_science::ms_unigene_entry::getLocusLink
std::string getLocusLink() const
Return the LocusLink - e.g. 125.
Definition: ms_unigene.hpp:102
matrix_science::ms_unigene_entry::getCytoBand
std::string getCytoBand() const
Return the CYTOBAND - e.g. 4q21-q23.
Definition: ms_unigene.hpp:95
matrix_science::ms_unigene_entry::getChromosome
long getChromosome() const
Return the chromosome that contains the unignene entry.
Definition: ms_unigene.hpp:117
matrix_science::ms_unigene_entry::getID
std::string getID() const
Return the 'ID' of this entry - e.g. Hs.4.
Definition: ms_unigene.hpp:77
matrix_science::ms_unigene_entry::getTitle
std::string getTitle() const
Return the 'title' of this entry - e.g. "alcohol dehydrogenase...".
Definition: ms_unigene.hpp:83
matrix_science::ms_unigene_entry::getExpress
std::string getExpress() const
Return the EXPRESS entry. Can be very long - 5000 bytes.
Definition: ms_unigene.hpp:111
matrix_science::ms_unigene_entry::getGene
std::string getGene() const
Return the gene name for this entry - e.g. "ADH1B".
Definition: ms_unigene.hpp:89
matrix_science::ms_unigene_entry::getFileOffset
OFFSET64_T getFileOffset() const
Return the offset into the unigene data file for this entry.
Definition: ms_unigene.hpp:124
matrix_science::ms_unigene
This class encapsulates a complete unigene file.
Definition: ms_unigene.hpp:162
matrix_science::ms_unigene::findEntry
virtual const ms_unigene_entry * findEntry(const char *id)=0
Given an accession, return a pointer to the relevant unigene entry.
matrix_science::ms_unigene::getUnigeneForAccession
virtual std::string getUnigeneForAccession(const std::string accession, const int index)=0
Return the Unigene 'accession' (ID) for a given EST accession.
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_unigeneoptions.hpp Source File

  • inc
ms_unigeneoptions.hpp
1/*
2##############################################################################
3# file: ms_unigeneoptions.hpp #
4# 'msparser' toolkit #
5# Encapsulates "UniGene" section of "mascot.dat" file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2007 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_unigeneoptions.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_UNIGENEOPTIONS_HPP
20#define MS_UNIGENEOPTIONS_HPP
21
22
23#include <string>
24#include <vector>
25
26namespace matrix_science {
33
58 class MS_MASCOTRESFILE_API ms_unigeneoptions: public ms_customproperty
59 {
60 friend class ms_datfile;
61
62 public:
63
65 ms_unigeneoptions();
66
68 ms_unigeneoptions(const ms_unigeneoptions& src);
69
71 virtual ~ms_unigeneoptions();
72
74 void copyFrom(const ms_unigeneoptions* right);
75
76#ifndef SWIG
78 ms_unigeneoptions& operator=(const ms_unigeneoptions& right);
79#endif
81 virtual void defaultValues();
82
84 bool isSectionAvailable() const;
85
87 void setSectionAvailable(const bool value);
88
89#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
90#include "suppress_ms_customproperty.hpp"
91#endif
92
93
94 private:
95 bool sectionAvailable_;
96
97 }; // class options // end of config_group
99} // namespace matrix_science
100
101#endif // MS_UNIGEGEOPTIONS_HPP
102
103/*------------------------------- End of File -------------------------------*/
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_unigeneoptions
An instance of this class represents all the parameters specified in UniGene section of mascot....
Definition: ms_unigeneoptions.hpp:59
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_wwwoptions.hpp Source File

  • inc
ms_wwwoptions.hpp
1/*
2##############################################################################
3# file: ms_wwwoptions.hpp #
4# 'msparser' toolkit #
5# Represents "WWW" section of "mascot.dat" file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2003 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_wwwoptions.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2018-07-30 16:23:53 +0100 $ #
14# $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MS_WWWOPTIONS_HPP
20#define MS_WWWOPTIONS_HPP
21
22
23#include <string>
24#include <vector>
25
26
27namespace matrix_science {
38 enum WWW_TYPE
39 {
40 WWW_SEQ = 0,
41 WWW_REP = 1
42 };
43
45
51 class MS_MASCOTRESFILE_API ms_wwwentry
52 {
53 friend class ms_datfile;
54 friend class ms_wwwoptions;
55
56 public:
58 ms_wwwentry();
59
61 ms_wwwentry(const ms_wwwentry& src);
62
64 ~ms_wwwentry();
65
67 void defaultValues();
68
70 void copyFrom(const ms_wwwentry* right);
71
72#ifndef SWIG
74 ms_wwwentry& operator=(const ms_wwwentry& right);
75#endif
77 std::string getName() const;
78
80 void setName(const char* value);
81
83 WWW_TYPE getType() const;
84
86 void setType(const WWW_TYPE value);
87
89 int getParseRule() const;
90
92 void setParseRule(const int value);
93
95 std::string getHostName() const;
96
98 void setHostName(const char* value);
99
101 int getPortNumber() const;
102
104 void setPortNumber(const int value);
105
107 std::string getPath() const;
108
110 void setPath(const char* value);
111
112 private:
113 std::string name_;
114 WWW_TYPE type_;
115 int parseRuleNum_;
116 std::string hostName_;
117 int portNumber_;
118 std::string path_;
119
120 std::string getStringName() const;
121 std::string getStringValue() const;
122 }; // class MS_MASCOTRESFILE_API ms_wwwentry
123
125
156 class MS_MASCOTRESFILE_API ms_wwwoptions: public ms_customproperty
157 {
158 friend class ms_datfile;
159 public:
160
162 ms_wwwoptions();
163
165 ms_wwwoptions(const ms_wwwoptions& src);
166
168 ~ms_wwwoptions();
169
171 void defaultValues();
172
174 void copyFrom(const ms_wwwoptions* right);
175
176#ifndef SWIG
178 ms_wwwoptions& operator=(const ms_wwwoptions& right);
179#endif
181 bool isSectionAvailable() const;
182
184 void setSectionAvailable(const bool value);
185
187 int getNumberOfEntries() const;
188
190 const ms_wwwentry* getEntry(const int index) const;
191
193 const ms_wwwentry* getSeqEntryByName(const char* dbName) const;
194
196 const ms_wwwentry* getRepEntryByName(const char* dbName) const;
197
199 void clearEntries();
200
202 void appendEntry(const ms_wwwentry* item);
203
205 void setEntry(const int index, const ms_wwwentry* item);
206
208 void dropEntry(const int index);
209
210#ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
211#include "suppress_ms_customproperty.hpp"
212#endif
213
214 private:
215 bool sectionAvailable_;
216 std::vector< ms_wwwentry* > entries_;
217 }; // class ms_wwwoptions // end of config_group
219} // namespace matrix_science
220
221#endif // MS_WWWOPTIONS_HPP
matrix_science::ms_customproperty
The class is used as a base for property-containing classes, such as ms_mascotoptions.
Definition: ms_customproperty.hpp:91
matrix_science::ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters.
Definition: ms_datfile.hpp:47
matrix_science::ms_wwwentry
Represent a single entry in the WWW section of mascot.dat.
Definition: ms_wwwoptions.hpp:52
matrix_science::ms_wwwoptions
Represents the whole WWW section.
Definition: ms_wwwoptions.hpp:157
matrix_science::WWW_TYPE
WWW_TYPE
Definition: ms_wwwoptions.hpp:39
matrix_science::WWW_REP
@ WWW_REP
Full text report source.
Definition: ms_wwwoptions.hpp:41
matrix_science::WWW_SEQ
@ WWW_SEQ
Sequence string source.
Definition: ms_wwwoptions.hpp:40
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_xic.hpp Source File

  • inc
ms_xic.hpp
1/*
2##############################################################################
3# file: ms_xic.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source: parser/inc/ms_xic.hpp $
12 * @(#)$Revision: f7c430569a82a92eac8833564053b59680ac20a8 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2021-01-11 13:23:17 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_XIC_HPP
18#define MS_XIC_HPP
19
20
21// Includes from the standard template library
22#include <string>
23
24namespace matrix_science
25{
26 //=========================================================================
32 class ms_xic_body;
33 class ms_cache_file;
34
36
39 class MS_MASCOTRESFILE_API ms_xic_point
40 {
41 public:
42 ms_xic_point();
43 ms_xic_point(double rt, int scanId, double intensity);
44
45 double getRt() const;
46 int getScanId() const;
47 double getIntensity() const;
48
49 void setRt(double rt);
50 void setScanId(int scanId);
51 void setIntensity(double intensity);
52
53 private:
54 double rt_;
55 int scanId_;
56 double intensity_;
57 };
58
60
67 class MS_MASCOTRESFILE_API ms_xic :
68 public ms_handle
69 {
70 public:
72
75 enum peakState
76 {
77 PEAK_STATE_UNKNOWN = 0,
78 PEAK_STATE_OK = 1,
79 PEAK_STATE_DISCARD =3,
80 };
81
83 static std::string getXmlCode(peakState code);
84
86 static peakState getCodeFromXml(std::string text);
87
89 ms_xic();
90
92 explicit ms_xic(const ms_xic_body & body);
93
95 explicit ms_xic(ms_xic_body * body);
96
98 void defaultValues();
99
101 void copyFrom(const ms_xic * src);
102
103#ifndef SWIG
105 ms_xic_body * body();
106
108 const ms_xic_body * body() const;
110 void setCacheFile(matrix_science::ms_cache_file * cacheFile);
111#endif
112
114 peakState getPeakState() const;
115
117 bool hasIndexes() const;
118
120 int getPeakStartIndex() const;
121
123 int getPeakEndIndex() const;
124
126 int getRegionStartIndex() const;
127
129 int getRegionEndIndex() const;
130
132 int getStartIndex() const;
133
135 int getEndIndex() const;
136
138 int getPeakStartScanId() const;
139
141 int getPeakEndScanId() const;
142
144 int getRegionStartScanId() const;
145
147 int getRegionEndScanId() const;
148
150 int getStartScanId() const;
151
153 int getEndScanId() const;
154
156 bool getUseTimeShift() const;
157
159 double getElutionTimeShift() const;
160
162 double getRtPeakStart() const;
163
165 double getRtPeakEnd() const;
166
168 double getRtRegionStart() const;
169
171 double getRtRegionEnd() const;
172
174 int getNumPoints() const;
175#ifndef SWIG
177 void getPoint(int index, double & rt, int & scanId, double & intensity) const;
178#else // SWIG Multiple return values
179 void getPoint(int index, double & OUTPUT, int & OUTPUT, double & OUTPUT) const;
180#endif
182 void setPeakStartIndex(int value);
183
185 void setPeakEndIndex(int value);
186
188 void setRegionStartIndex(int value);
189
191 void setRegionEndIndex(int value);
192
194 void setStartIndex(int value);
195
197 void setEndIndex(int value);
198
200 void setPeakStartScanId(int value);
201
203 void setPeakEndScanId(int scanId);
204
206 void setRegionStartScanId(int scanId);
207
209 void setRegionEndScanId(int scanId);
210
212 void setStartScanId(int scanId);
213
215 void setEndScanId(int scanId);
216
218 void setRtPeakStart(double value);
219
221 void setRtPeakEnd(double value);
222
224 void setRtRegionStart(double value);
225
227 void setRtRegionEnd(double value);
228
230 void setUseTimeShift(bool value);
231
233 void setElutionTimeShift(double value);
234
236 void setPeakState(peakState value);
237
238 protected:
240 std::deque<ms_xic_point> & getPoints();
241
243 const std::deque<ms_xic_point> & getPoints() const;
244
245 };
246 // end of quantitation_group
248 //=========================================================================
249
250} // namespace matrix_science
251
252#endif // MS_XIC_HPP
253
254/*------------------------------- End of File -------------------------------*/
matrix_science::ms_xic_point
A single point from a matrix_science::ms_xic object.
Definition: ms_xic.hpp:40
matrix_science::ms_xic
An eXtracted Ion Chromatogram (XIC).
Definition: ms_xic.hpp:69
matrix_science::ms_xic::peakState
peakState
Status codes from fitting peaks.
Definition: ms_xic.hpp:76
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_xic_body.hpp Source File

  • src
  • resfile
ms_xic_body.hpp
1/*
2##############################################################################
3# file: ms_xic_body.hpp
4# 'msparser' toolkit
5# An extracted ion chromatogram - body
6##############################################################################
7# COPYRIGHT NOTICE
8# Copyright 1998-2014 Matrix Science Limited All Rights Reserved.
9#
10##############################################################################
11 * @(#)$Source$
12 * @(#)$Revision$
13 * @(#)$Date$
14##############################################################################
15 */
16
17#ifndef MS_XIC_BODY_HPP
18#define MS_XIC_BODY_HPP
19
20// Includes from the standard template library
21#include <string>
22
23namespace matrix_science
24{
25 class MS_PARSERINTERNAL_API ms_xic_body :
26 public matrix_science::ms_body
27 {
28 public:
29
30 ms_xic_body();
31 ~ms_xic_body();
32
33 ms_xic_body(const ms_xic_body & copy);
34 void operator =(const ms_xic_body & copy);
35
36 bool loadCacheData() const;
37 void dropCacheData() const;
38
39 bool loadStream(matrix_science::ms_cache_stream & stream);
40 bool loadCache(matrix_science::ms_cache_file & cacheFile);
41 bool loadFromXmlParent(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & xmlParent);
42 bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & xmlCurrent);
43
44 bool saveToStream(matrix_science::ms_cache_stream & stream) const;
45 bool saveToCache(matrix_science::ms_cache_file & cacheFile) const;
46 bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, bool processSeparately, bool completeReport) const;
47
48 mutable INT64 cacheStreamId_;
49
50 int peakStartIndex_;
51 int peakEndIndex_;
52 int regionStartIndex_;
53 int regionEndIndex_;
54 int startIndex_;
55 int endIndex_;
56
57 int peakStartScanId_;
58 int peakEndScanId_;
59 int regionStartScanId_;
60 int regionEndScanId_;
61 int startScanId_;
62 int endScanId_;
63
64 ms_xic::peakState peakState_;
65
66 bool useTimeShift_;
67 double elutionTimeShift_;
68 double rtPeakStart_;
69 double rtPeakEnd_;
70 double rtRegionStart_;
71 double rtRegionEnd_;
72
73 // points are the only cached data
74 mutable matrix_science::ms_cache_file * cacheFile_; // null if not associated with a cache file, will change during saveToCache
75 mutable bool isCacheDataLoaded_; // true if data is loaded, even if not from a cache file
76 mutable std::deque<ms_xic_point> points_;
77 mutable bool hasPointsRt_;
78 mutable bool hasPointsScanid_;
79 };
80
81} // namespace matrix_science
82
83#endif // MS_XIC_BODY_HPP
84
85/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_xml_parameters.hpp Source File

  • inc
ms_xml_parameters.hpp
1/*
2##############################################################################
3# file: ms_xml_parameters.hpp #
4# 'msparser' toolkit #
5# Base class for parameterType-definitions #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2019 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11 * @(#)$Source: parser/inc/ms_xml_parameters.hpp $
12 * @(#)$Revision: 8fee77726a13a239ca8bcf2b46212bff297db9b7 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
13 * @(#)$Date: 2018-12-20 10:50:55 +0000 $
14##############################################################################
15 */
16
17#ifndef MS_XML_PARAMETERS_HPP
18#define MS_XML_PARAMETERS_HPP
19
20
21#include <string>
22#include <vector>
23
24namespace msparser_internal {
25 class ms_xml_xmlloader;
26 class ms_XMLHelper;
27 class ms_XMLElement;
28}
29
30namespace matrix_science {
31 class ms_xml_schema; // forward declaration
32
39
45 class MS_MASCOTRESFILE_API ms_xml_parameter: public ms_xml_IValidatable
46 {
47 public:
49 ms_xml_parameter();
50
52 ms_xml_parameter(const ms_xml_parameter& src);
53
55 virtual ~ms_xml_parameter();
56
58 void defaultValues();
59
61 void copyFrom(const ms_xml_parameter* right);
62
63#ifndef SWIG
65 ms_xml_parameter& operator=(const ms_xml_parameter& right);
66#endif
68 virtual std::string getSchemaType() const = 0;
69
71 std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
72
74 std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
75
76
78 bool haveName() const;
79
81 std::string getName() const;
82
84 void setName(const char* value);
85
87 void dropName();
88
90 virtual std::string getNameSchemaType() const = 0;
91
92
94 bool haveDescription() const;
95
97 std::string getDescription() const;
98
100 void setDescription(const char* value);
101
103 void dropDescription();
104
106 virtual std::string getDescriptionSchemaType() const = 0;
107
108
110 std::string getValue() const;
111
113 void setValue(const char* value);
114
116 virtual std::string getValueSchemaType() const = 0;
117
118 protected:
119 virtual bool saveToXML_ParameterByNumber(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const = 0;
120
121 std::string _name;
122 bool _name_set;
123
124 std::string _description;
125 bool _description_set;
126
127 std::string _value;
128
129 }; // class ms_xml_parameter
130
132
139 class MS_MASCOTRESFILE_API ms_xml_parameters: public ms_xml_IValidatable
140 {
141 public:
143 ms_xml_parameters();
144
146 ms_xml_parameters(const ms_xml_parameters& src);
147
149 virtual ~ms_xml_parameters();
150
152 void defaultValues();
153
155 virtual std::string getSchemaType() const = 0;
156
158 std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
159
161 std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
162
163
165 virtual int getNumberOfParameters() const = 0;
166
168 virtual void clearParameters() = 0;
169
171 virtual bool deleteParameterByNumber(const int idx) = 0;
172
174 virtual bool deleteParameterByName(const char *name) = 0;
175
177 virtual std::string getParameterSchemaType() const = 0;
178
179 protected:
180 virtual bool saveToXML_Parameters(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const = 0;
181
182 }; // class ms_xml_parameters
183 // end of config_group
185
186} // namespace matrix_science
187
188#endif // MS_XML_PARAMETERS_HPP
189
190/*------------------------------- End of File -------------------------------*/
191
matrix_science::ms_xml_parameter
Parameter name and value pair.
Definition: ms_xml_parameters.hpp:46
matrix_science::ms_xml_parameter::getValueSchemaType
virtual std::string getValueSchemaType() const =0
Obtain a symbolic name for the value attribute schema type.
matrix_science::ms_xml_parameter::getDescriptionSchemaType
virtual std::string getDescriptionSchemaType() const =0
Obtain a symbolic name for the description attribute schema type.
matrix_science::ms_xml_parameter::getNameSchemaType
virtual std::string getNameSchemaType() const =0
Obtain a symbolic name for the name attribute schema type.
matrix_science::ms_xml_parameter::getSchemaType
virtual std::string getSchemaType() const =0
Returns name of the schema type that can be used to validate this element.
matrix_science::ms_xml_parameters
A class that represents a base parametersType.
Definition: ms_xml_parameters.hpp:140
matrix_science::ms_xml_parameters::getNumberOfParameters
virtual int getNumberOfParameters() const =0
Returns the number of parameters held.
matrix_science::ms_xml_parameters::deleteParameterByName
virtual bool deleteParameterByName(const char *name)=0
Remove a parameter from the list in memory by its unique name.
matrix_science::ms_xml_parameters::getParameterSchemaType
virtual std::string getParameterSchemaType() const =0
Obtain a symbolic name for the parameter element schema type.
matrix_science::ms_xml_parameters::clearParameters
virtual void clearParameters()=0
Deletes all parameters from the list.
matrix_science::ms_xml_parameters::deleteParameterByNumber
virtual bool deleteParameterByNumber(const int idx)=0
Remove a parameter from the list in memory by its index.
matrix_science::ms_xml_parameters::getSchemaType
virtual std::string getSchemaType() const =0
Returns name of the schema type that can be used to validate this element.
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: ms_zip.hpp Source File

  • inc
ms_zip.hpp
1/*
2##############################################################################
3# file: ms_zip.hpp #
4# 'msparser' toolkit #
5# Utilities class for zipping and unzipping a buffer #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2023 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/ms_zip.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2023-08-25 09:37:06 +0100 $ #
14# $Revision: a93b9fa8957b5f46765e9c3292c87eda6e2ca94c | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef ms_zip_HPP
20#define ms_zip_HPP
21
22
23#include <string>
24
25
26namespace matrix_science {
33
113 class MS_MASCOTRESFILE_API ms_zip : public ms_errors
114 {
115 public:
117 ms_zip(const bool isZipped, const unsigned char * buffer, const unsigned long len);
118
120 ms_zip(const bool isZipped, const std::string & buffer);
121
123 explicit ms_zip(const bool isZipped);
124
126 ms_zip(const ms_zip& src);
127
129 void copyFrom(const ms_zip* right);
130
131#ifndef SWIG
133 ms_zip& operator=(const ms_zip& right);
134#endif
135 ~ms_zip();
136
138 std::string compressMore(const std::string& dataIn);
139
141 void compressMore(const unsigned char *dataIn, const unsigned long inputLen, unsigned char *dataOut, unsigned long *outputLen);
142
144 std::string decompressMore(const std::string &dataIn);
145
147 void decompressMore(const unsigned char *dataIn, const unsigned long inputLen, unsigned char *dataOut, unsigned long *outputLen);
148
150 unsigned long getZipped(unsigned char * buffer, const unsigned long len) const;
151
153 unsigned long getUnZipped(unsigned char * buffer, const unsigned long len) const;
154
156 std::string getZipped() const;
157
159 std::string getUnZipped() const;
160
162 unsigned long getZippedLen() const;
163
165 unsigned long getUnZippedLen() const;
166
167 enum { MAX_UNCOMPRESSED_SIZE = (1024 * 1024 * 100), MAX_COMPRESSED_SIZE = (1024 * 1024 * 100) };
168 private:
169 void init_buffer(const bool isZipped, const unsigned char * buffer, const unsigned long len);
170 unsigned long zippedLen_;
171 unsigned long zippedCap_;
172 unsigned long maxZippedCap_;
173 unsigned long maxUnZippedCap_;
174 unsigned long unZippedLen_;
175 unsigned long unZippedCap_;
176 unsigned char * pUnZipped_;
177 unsigned char * pZipped_;
178 void* pInStreamData_;
179 void* pOutStreamData_;
180 bool doneStreaming_;
181 typedef std::basic_string<unsigned char> ustring;
182 std::list<ustring> outputQueue_;
183 }; // class ms_zip // end of tools_group
185} // namespace matrix_science
186#endif // ms_zip_HPP
187
188/*------------------------------- End of File -------------------------------*/
matrix_science::ms_errors
This class is used as a base class for several Mascot Parser classes.
Definition: ms_errors.hpp:696
matrix_science::ms_zip
Utility class for compressing and decompressing data in compress format, and compressing in gzip form...
Definition: ms_zip.hpp:114
matrix_science::ms_zip::operator=
ms_zip & operator=(const ms_zip &right)
C++ style assignment operator.
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: msparser.hpp Source File

  • inc
msparser.hpp
1/*
2##############################################################################
3# File: msparser.hpp #
4# Mascot Parser toolkit #
5# Master include file #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2006 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Source: parser/inc/msparser.hpp $
12# $Author: villek@matrixscience.com $
13# $Date: 2024-04-23 13:44:38 +0100 $
14# $Revision: d68a41bc8e47b8ed51f15aa732b0a03e4685c239 | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $
15##############################################################################
16*/
17
19// Configuration files functionality //
21
22// Some necessary constants
23#include "msparser_lim.hpp"
24
25// General-purpose functionality or base classes
26#include "ms_logging.hpp" // generic logging mechanism
27#include "ms_log.hpp" // log messages for internal use
28#include "ms_errors.hpp" // generic error-handling mechanism
29#include "ms_customproperty.hpp" // custom property functionality
30#include "ms_fileutilities.hpp" // file-handling utilities
31#include "ms_connection_settings.hpp" // proxy server and sessionID for config files
32#include "ms_tinycdb.hpp" // cdb index files
33#include "ms_input_stream.hpp" // input sream interface
34#include "ms_progress_info.hpp"
35
36
37// 'mascot.dat' file
38#include "ms_computeraddress.hpp" // auxiliary definition classes
39#include "ms_mascotfiles.hpp" // location of other configuration files
40#include "ms_clusterparams.hpp" // 'Cluster'-section
41#include "ms_unigeneoptions.hpp"
42#include "ms_cronoptions.hpp" // 'Cron'-section
43#include "ms_databaseoptions.hpp" // 'Databases'-section
44#include "ms_libraryoptions.hpp" // 'LibraryOptions' -section
45#include "ms_parserule.hpp" // 'Parse'-section
46#include "ms_processoroptions.hpp" // 'Processor'-section
47#include "ms_taxonomyrules.hpp" // 'Taxonomy_XXX'-section
48#include "ms_wwwoptions.hpp" // 'WWW'-section
49#include "ms_mascotoptions.hpp" // 'Options'-section
50#include "ms_datfile.hpp" // main class that represents the whole file
51
52// 'enzymes' file
53#include "ms_enzyme.hpp"
54
55// 'fragmentation_rules' file
56#include "ms_fragmentationrules.hpp"
57
58// 'mascot.license' file
59#include "ms_license.hpp"
60
61#include "ms_umod_configfile.hpp"
62
63// 'mod_file' and 'substitutions' files
64#include "ms_modfile.hpp"
65
66// 'masses file'
67#include "ms_masses.hpp"
68
69// CPU configuration retreival
70#include "ms_processors.hpp"
71
72// 'taxonomy' file
73#include "ms_taxonomyfile.hpp"
74
75// authentication
76#include "ms_security_task.hpp"
77#include "ms_security_tasks.hpp"
78#include "ms_security_user.hpp"
79#include "ms_security_group.hpp"
80#include "ms_security_options.hpp"
81#include "ms_security.hpp"
82#include "ms_security_session.hpp"
83
84// generic XML handling
85#include "ms_xml_typeinfo.hpp"
86#include "ms_xml_schema.hpp"
87#include "ms_xml_parameters.hpp"
88
89// crosslinking.xml programming interface
90#include "ms_crosslinking_accessions.hpp"
91#include "ms_crosslinking_accession.hpp"
92#include "ms_crosslinking_configfile.hpp"
93#include "ms_crosslinking_parameters.hpp"
94#include "ms_crosslinking_linkers.hpp"
95#include "ms_crosslinking_linker.hpp"
96#include "ms_crosslinking_method.hpp"
97#include "ms_crosslinking_monolink.hpp"
98#include "ms_crosslinking_does_not_pair_with.hpp"
99#include "ms_crosslinking_filters.hpp"
100#include "ms_crosslinking_scope.hpp"
101#include "ms_crosslinking_settings.hpp"
102
103// quantitation.xml programming interface
104#include "ms_quant_moverz.hpp"
105#include "ms_quant_correction.hpp"
106#include "ms_quant_file_index.hpp"
107#include "ms_quant_isotope.hpp"
108#include "ms_quant_component.hpp"
109#include "ms_quant_composition.hpp"
110#include "ms_quant_parameters.hpp"
111#include "ms_quant_integration.hpp"
112#include "ms_quant_neutralloss.hpp"
113#include "ms_quant_specificity.hpp"
114#include "ms_quant_pepneutralloss.hpp"
115#include "ms_quant_localdef.hpp"
116#include "ms_quant_unmodified.hpp"
117#include "ms_quant_modgroup.hpp"
118#include "ms_quant_quality.hpp"
119#include "ms_quant_outliers.hpp"
120#include "ms_quant_normalisation.hpp"
121#include "ms_quant_precursor.hpp"
122#include "ms_quant_average.hpp"
123#include "ms_quant_multiplex.hpp"
124#include "ms_quant_reporter.hpp"
125#include "ms_quant_replicate.hpp"
126#include "ms_quant_protocol.hpp"
127#include "ms_quant_numerator.hpp"
128#include "ms_quant_ratio.hpp"
129#include "ms_quant_method.hpp"
130#include "ms_quant_configfile.hpp"
131#include "ms_quant_satellite.hpp"
132#include "ms_quant_normalisation_peptide.hpp"
133#include "ms_quant_normalisation_protein.hpp"
134#include "ms_quant_stats.hpp"
135#include "ms_peptide_quant_key.hpp"
136#include "ms_peptide_quant_key_vector.hpp"
137#include "ms_peptide_quant_ratio.hpp"
138#include "ms_protein_quant_ratio.hpp"
139#include "ms_quantitation.hpp"
140#include "ms_ms2quantitation.hpp"
141#include "ms_customquantitation.hpp"
142
143// unimod.xml programming interface
144#include "ms_umod_element.hpp"
145#include "ms_umod_modification.hpp"
146#include "ms_umod_aminoacid.hpp"
147#include "ms_umod_modbrick.hpp"
148#include "ms_umod_specificity.hpp"
149#include "ms_umod_composition.hpp"
150#include "ms_umod_neutralloss.hpp"
151#include "ms_umod_elemref.hpp"
152#include "ms_umod_xref.hpp"
153
154// HTTP connection
155#include "ms_http_helper_handles.hpp"
156#include "ms_http_helper_progress.hpp"
157#include "ms_http_helper_response.hpp"
158#include "ms_http_helper_return.hpp"
159#include "ms_http_helper.hpp"
160
161// remote Mascot server
162#include "ms_http_client_mime.hpp"
163#include "ms_http_client_search.hpp"
164#include "ms_http_client_session.hpp"
165#include "ms_http_client.hpp"
166
167
169// Mascot result files functionality //
171
172#include "ms_peptide.hpp"
173#include "ms_linker_site.hpp"
174#include "ms_linker_site_vector.hpp"
175#include "ms_mascotresfilebase.hpp"
176#include "ms_mascotresfile_dat.hpp"
177#include "ms_mascotresfile_msr.hpp"
178#include "ms_protein.hpp"
179#include "ms_mascotresults.hpp"
180#include "ms_proteinsummary.hpp"
181#include "ms_peptidesummary.hpp"
182#include "ms_mascotresults_params.hpp"
183#include "ms_inputquery.hpp"
184#include "ms_searchparams.hpp"
185#include "ms_unigene.hpp"
186
187#include "ms_fragment.hpp"
188#include "ms_fragmentvector.hpp"
189
190#include "ms_aahelper.hpp"
191#include "ms_zip.hpp"
192#include "ms_shapiro_wilk.hpp"
193#include "ms_obofile.hpp"
194#include "ms_msr2dat28.hpp"
195
197
198#include "ms_body.hpp"
199#include "ms_ms1quant_peptide_status.hpp"
200#include "ms_quant_helper.hpp"
201
202#include "ms_cache_file.hpp"
203#include "ms_cache_stream.hpp"
204#include "ms_matrix.hpp"
205#include "ms_body.hpp"
206#include "ms_xic.hpp"
207#include "ms_ms1quant_match_range.hpp"
208#include "ms_ms1quant_match_component.hpp"
209#include "ms_ms1quant_match_ratio.hpp"
210#include "ms_fitexy_result.hpp"
211#include "ms_ms1quant_charge_state.hpp"
212#include "ms_ms1quant_match.hpp"
213#include "ms_ms1quant_average_results.hpp"
214#include "ms_ms1quant_peptide_status.hpp"
215#include "ms_ms1quant_time_align_limits.hpp"
216#include "ms_ms1quant_time_align.hpp"
217
218#include "ms_ms1quantitation.hpp"
219
220#include "ms_distiller_data.hpp"
221#include "ms_distiller_data_quant.hpp"
222#include "ms_distiller_data_search.hpp"
223#include "ms_distiller_master_project.hpp"
224#include "ms_distiller_subsearch.hpp"
225#include "ms_distiller_master_search.hpp"
226#include "ms_distiller_search_status.hpp"
227#include "ms_distiller_search_status_list.hpp"
228#include "ms_distiller_sub_project.hpp"
229
230#include "ms_spectral_lib_peak.hpp"
231#include "ms_spectral_lib_peak_list.hpp"
232#include "ms_spectral_lib_entry.hpp"
233#include "ms_spectral_lib_file.hpp"
234
235#include "ms_imputation.hpp"
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: msparser_lim.hpp Source File

  • inc
msparser_lim.hpp
1/*
2##############################################################################
3# file: msparser_lim.hpp #
4# 'msparser' toolkit #
5# Contains definitions used in all projects #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2012 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Archive:: /Mowse/ms_mascotresfile/include/msparser_lim.hpp $ #
12# $Author: villek@matrixscience.com $ #
13# $Date: 2019-07-19 12:20:12 +0100 $ #
14# $Revision: e9a05e64c0974c6b7b9e18e38ad5b4430cfa45bd | MSPARSER_REL_3_0_0-2024-09-24-0-g93ebaeb4f4 $ #
15# $NoKeywords:: $ #
16##############################################################################
17*/
18
19#ifndef MSPARSER_LIM_HPP
20#define MSPARSER_LIM_HPP
21
22/* Define some other values depending on the compiler / platform */
23#ifdef _WIN32
24#ifdef __GNUC__
25typedef long long INT64;
26typedef unsigned long long UINT64;
27#define FORMAT_STRING_FOR_I64 "%lld" // checked with man pages
28#define FORMAT_STRING_FOR_UI64 "%llu"
29#else
30#include <basetsd.h>
31#ifndef SWIG
32#define FORMAT_STRING_FOR_I64 "%I64d" // checked with MSDN
33#define FORMAT_STRING_FOR_UI64 "%I64u"
34#endif // !SWIG
35#endif
36#endif
37
38#ifdef __LINUX__
39#include <stdint.h>
40typedef int64_t INT64;
41typedef uint64_t UINT64;
42#define FORMAT_STRING_FOR_I64 "%lld" // checked with man pages
43#define FORMAT_STRING_FOR_UI64 "%llu"
44#endif
45
46#ifdef __LINUX64__
47#include <stdint.h>
48typedef int64_t INT64;
49typedef uint64_t UINT64;
50#define FORMAT_STRING_FOR_I64 "%ld" // checked with man pages
51#define FORMAT_STRING_FOR_UI64 "%lu"
52#endif
53
54#ifdef SWIG_VERSION
55namespace matrix_science {
56#ifdef _USE_32BIT_TIME_T
57 // See comments in "msparser.i"
58 typedef __time64_t time_t;
59#endif
60} // namespace matrix_science
61#endif // SWIG_VERSION
62
63#ifdef _MSC_VER
64#pragma warning(disable:4251) // Don't want all classes to be exported
65#pragma warning(disable:4786) // Debug symbols too long
66#endif
67
68#ifdef _WIN32
69# ifndef _MATRIX_USE_STATIC_LIB
70# ifdef MS_MASCOTRESFILE_EXPORTS
71# define MS_MASCOTRESFILE_API __declspec(dllexport)
72# define MS_PARSERINTERNAL_API __declspec(dllexport)
73# else
74# define MS_MASCOTRESFILE_API __declspec(dllimport)
75# define MS_PARSERINTERNAL_API __declspec(dllimport)
76# endif
77# else
78# define MS_MASCOTRESFILE_API
79# define MS_PARSERINTERNAL_API
80# endif
81#else
82# define MS_MASCOTRESFILE_API
83# define MS_PARSERINTERNAL_API
84#endif
85
86#endif // MSPARSER_LIM_HPP
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: numerical_recipes.hpp Source File

  • src
  • tools
numerical_recipes.hpp
1/*
2##############################################################################
3# file: numerical_recipes.hpp #
4# 'msparser' toolkit #
5# Numerical algorithms for internal use #
6##############################################################################
7# COPYRIGHT NOTICE #
8# Copyright 1998-2016 Matrix Science Limited All Rights Reserved. #
9# #
10##############################################################################
11# $Author: #
12# $Date$ #
13# $Revision$ #
14# $NoKeywords:: $ #
15##############################################################################
16*/
17
18#ifndef NUMERICAL_RECIPES_HPP
19#define NUMERICAL_RECIPES_HPP
20
21#include <math.h>
22
23namespace msparser_internal {
25
30 namespace NR {
32 inline double SQR(const double x) { return x*x; }
33
35 MS_PARSERINTERNAL_API double gammaln(const double xx);
36
38 double factrl(const int n);
40 double factln(const int n);
41
43 MS_PARSERINTERNAL_API double students_aa(const long nu, const double t);
44
46 MS_PARSERINTERNAL_API double studenttdistribution(const long nu, const double t);
48 MS_PARSERINTERNAL_API double invstudenttdistribution(const long nu, const double p);
49
51
58 inline bool approximately_equal(const double x1, const double x2, const double rel_error) {
59 return fabs(x1 - x2) <= rel_error * fabs(x2);
60 }
61 }
62
64} // msparser_internal namespace
65
66#endif // NUMERICAL_RECIPES_HPP
67
68/*------------------------------- End of File -------------------------------*/
Generated on Tue Sep 24 2024 11:06:11 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: Related Pages

Related Pages
Here is a list of all related documentation pages:
► License information for Mascot Parser
► Release notes and version history
► Updating from earlier versions of Mascot Parser
Deprecated List
Generated on Tue Sep 24 2024 11:06:16 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6


Matrix Science Mascot Parser toolkit: time_utils.hpp Source File

  • src
  • configfiles
time_utils.hpp
1/*
2 * Copyright (C) 2002-2005, Matrix Science Limited, London, UK.
3 * All rights reserved.
4 *
5 * @(#)$Source$
6 * @(#)$Revision$
7 * @(#)$Date$
8 */
9
10// NB: This file is originally a copy of mascot/src/matrix/time_utils.h.
11
12#ifndef TIME_UTILS_h
13#define TIME_UTILS_h 1
14
15#include <time.h>
16
17namespace msparser_internal {
18// \cond INTERNAL
19
21
27class CTimeUtils {
28public:
29 CTimeUtils(void);
30 virtual ~CTimeUtils(void);
31
33 time_t time(void);
34
36 const char* ctime(time_t time);
37
39 const char* asctime(struct tm time);
40
42 const char* asctimeNoYear(struct tm time);
43
45 const struct tm *gmtime(time_t time);
46
48 const struct tm *localtime(time_t time);
49
51 time_t mktime(struct tm *time);
52
53
55 const char *asctime(const struct tm *time) { if (time) return asctime(*time); return ""; }
56
58 std::string asctimeNonStandard(const struct tm *time);
59
61 bool compareTimesStandardFormat(std::string str1, std::string str2);
62
63private:
64 bool m_anyErrors;
65
66#define INTERNAL_BUFFER_SIZE 64 // although 26 is enough
67 char m_buffer[INTERNAL_BUFFER_SIZE];
68 time_t m_buffer_time;
69 struct tm m_buffer_tm;
70};
71
72// \endcond
73
74} // namespace
75
76#endif // TIME_UTILS_h
Generated on Tue Sep 24 2024 11:06:10 for Matrix Science Mascot Parser toolkit by doxygen 1.9.6